Introduction to Aptify 4.5 SDK

Introduction to the Aptify 5.0 Software Development Kit (SDK)

Copyright Notice

The Aptify Framework provides a rich set of functionality that is designed to make the process of designing, building, and deploying powerful business applications more productive. Aptify's flexible framework makes it possible to rapidly build professional business applications in a fraction of the time that would be required with a system built without the benefit of a framework.

Traditional business application development normally requires that the programmer develop a structure to perform a number of fundamental tasks required by all professional applications. These tasks include ensuring adequate security, providing a mechanism for users to log into the system, ensuring that validation exists to maintain the quality of the data, and designing standards to ensure consistency in the user interface.

While it is possible for an organization to build effective business applications from the ground up, the total cost of ownership is higher than with Aptify because the organization must design and write all of the system's components. The benefits of generic component software are often not achieved in development projects with tight time lines, and the result is often a system that performs its intended function but cannot grow and evolve to meet the future needs of the organization.

The power of Aptify is derived from the use of flexible component software, which allows functionality to be broken down into generic and reusable Objects. The process of designing components as easily managed units is called object oriented programming. The basic idea behind object-oriented programming is to increase efficiency by reducing the time required to develop, maintain, and extend the functionality of an application.

Microsoft's .NET Framework is one of several structured frameworks grounded in the principles of object oriented design methodologies. The Aptify Framework is comprised of a large number of .NET components, most of which provide generic functionality that can be used in a wide variety of applications. The Aptify Software Development Kit provides information related to the .NET components that have been developed and incorporated into the Aptify Framework and into Aptify Business Applications.

©2008 Aptify®
Confidential and Proprietary
 http://www.aptify.com


The Aptify Software Development Kit

The Aptify Software Development Kit (SDK) is a valuable resource that provides access to object interfaces and object classes that make up the Aptify Framework and Aptify Business Applications. A developer can use the information in this SDK to add new functionality or modify existing functionality in an organization's Aptify installation. A developer create new objects that build upon and inherit from the objects described in the SDK.

The SDK is comprised of multiple levels so that a developer can drill down into a specific object and see what specific members make up that object.

©2008 Aptify®
Confidential and Proprietary
 http://www.aptify.com


Aptify SDK Structure

The objective of this SDK is to provide the information necessary to take advantage of Aptify objects. Aptify objects are grouped together by functional area in .NET Namespaces. See Aptify Framework Functionality Overview for a list of some of the functional areas covered in this SDK.

The SDK's Object Reference provides information on every Aptify namespace and the objects contained in each. Below is a high level overview of the type of information which is provided for each object:

  • For each Aptify namespace, the SDK provides a list of objects contained within the namespace. Object types include:
    • Classes
    • Interfaces
    • Structures
    • Delegates
    • Enumerations
  • The SDK contains a description of the functionality provided by each object.
  • The SDK includes the name of the assembly that stores the object.
  • The SDK displays the namespace for each object. See .NET Namespace for more information.
  • Where applicable, the SDK lists the objects whose functionality the selected class inherits. See Object Inheritance for details.
  • The SDK includes sample code for an object, if applicable. The sample code provides an extended example of how a developer might reference the object's properties, methods and events in code. The sample code is an excellent starting point for developers who are unfamiliar with a particular object's usage.
  • The SDK documents the public and protected Members for each object in the namespace, where applicable. See Member Types for more information.

.NET Namespace

The .NET Framework uses namespaces to organize and group system functionality in a hierarchical manner. For example, Aptify's base namespace for Framework functionality is Aptify.Framework and the base namespace for Application functionality is Aptify.Application. The namespace for Generic Entity functionality, which is part of the Framework, is Aptify.Framework.BusinessLogic.GenericEntity.

This SDK identifies objects using the Aptify namespace. Using namespaces with the .NET Framework provides a logical organization to functionality, making it easier for developers to browse and review code. However, note that namespaces are not necessarily related to assembly names. Refer to a .NET Framework reference book or Web site for additional information on namespaces.

Object Inheritance

The .NET Framework supports implementation inheritance, which allows an object to use the functionality defined in another object. Typically, a derived object class inherits and then extends the functionality defined in a base class. A developer can define additional types and methods for the derived class and override functionality that may exist in the base class as necessary. Refer to a .NET Framework reference book or Web site for additional information on object inheritance.

In Aptify, many of the object classes and interfaces inherit functionality from other Windows or Aptify objects. This SDK displays a hierarchical listing of inherited types for each object class in an Inheritance Hierarchy (a sample hierarchy is circled in the screen capture below).

Member Types

The SDK lists the members for each object in a namespace, where applicable. Members include:

  • Constructors
  • Fields
  • Methods
  • Properties
  • Events

For each member, the SDK provides the following information, where applicable:

  • A description of the functionality provided.
  • The object the member is inherited from.
  • Whether or not the member is overloaded (applies to methods).
  • The data type of the value returned by the member.
  • Syntax and/or remarks explaining how the member is used.
  • Parameters that relate to the member.

©2008 Aptify®
Confidential and Proprietary
 http://www.aptify.com


Requirements

Aptify requires that the following prerequisites to develop objects using the Aptify controls documented in this SDK:

  • Microsoft® Visual Studio 2008

  • Microsoft .NET Framework version 3.5 SP1

  • Infragistics® NetAdvantage® 2008 Volume 1 (may not be required)

  • ComponentOne Studio® for WinForms (may not be required)

  • ComponentArt™ Web.UI Version 2007.1 for ASP.NET 2.0 (may not be required)

Note: Refer to the Aptify Developer Guide and the Aptify E-Business Developer Guide for more information on Aptify developer requirements.

©2008 Aptify®
Confidential and Proprietary
 http://www.aptify.com


Aptify Framework Functionality Overview

The SDK documents all of the Aptify namespaces. The Object Reference introduction summaries the Aptify namespaces and indicates what functionality is contained in each. In general, you can find information about how to use the stated functionality in the Aptify User Guides.

Also, the following framework functional areas merit additional explanation:

  • Application Object: This section contains information on the Application Object, which is the main object used to retrieve information from the Aptify system.
  • Attribute Manager: This section describes the purpose and use of the Attribute Manager.
  • Bound Controls: This section contains information on the bound controls that appear on Aptify forms, such as a text field, link box, or drop-down list field.
  • Data Services Layer: This section contains information on the Aptify Data Services Layer, which is responsible for accessing the database.
  • Digital Dashboards: This section contains information on the object classes and interfaces available to developers for configuring the building blocks for dashboards. Dashboards appear in the Aptify GUI's main display window when a user selects Aptify Technology Platform or an Application heading in the Folder List.
  • Exception Manager: This section describes the purpose and use of the Exception Manager.
  • Generic Entity: This section contains information on the Generic Entity architecture, which provides a standard, generic interface to the database.
  • Object Repository: This section contains information about the Aptify Object Repository, which is a central repository for all software components, reports, and other files that are used within the system.

©2008 Aptify®
Confidential and Proprietary
 http://www.aptify.com


Application Object

Aptify's Application Object provides a set of utility functions that are used primarily to access metadata associated with entities. This includes information about attachments, entity actions, entity attributes, views, sub-types, and other entity metadata.

Many of the methods provided by the Application Object classes are convenient substitutes for common SQL queries. For example, rather than writing a SQL query to obtain the Entity ID of the Dashboards entity, a developer can use the GetEntityID method of the AptifyApplication class. In addition to convenience, the use of the Application Object enforces consistency on development activities by providing a common set of functions that all developers can use from any project.

Developers familiar with CGI Explorer may notice that the Application Object provides the same functionality in Aptify 5.0 as DMInfo provided in CGI Explorer 2.x and 3.x.

For information on the Application Object, see the Aptify.Framework.Application namespace.

©2008 Aptify®
Confidential and Proprietary
 http://www.aptify.com


Attribute Manager

The Attribute Manager is responsible for creating, retrieving, and changing code level custom attributes. It is ideal for use with XML configuration files.

For information on the Attribute Manager, see the Aptify.Framework.AttributeManagement namespace.

©2008 Aptify®
Confidential and Proprietary
 http://www.aptify.com


Bound Controls

The Aptify Bound Controls interface with the Generic Entity to display the fields defined in an Entities record within the user interface. These controls determine the appearance of the various field types displayed on an Aptify form, including text boxes, link boxes, check boxes, and drop-down list boxes.

The Aptify Bound Controls build upon the standard Windows User Controls. For information on the Bound Controls, see the Aptify.Framework.WindowsControls namespace.

©2008 Aptify®
Confidential and Proprietary
 http://www.aptify.com


Data Services Layer

The Data Services Layer is designed to handle database access for the Aptify Framework and all of its applications. It consists of many components that contain interface definitions and implementations that provide the functionality required to manage all database access for Aptify. The Data Services Layer manages connections to database servers, connection caching, data access, data modification, data caching and transaction management.

Typically, developers working on Aptify configurations will use the Data Services Layer to retrieve information from the database. Data modifications should be handled through the Aptify business objects, which internally use the Data Services Layer to perform data access and modification.

For information on the Data Services Layer, see the Aptify.Framework.DataServices namespace.

©2008 Aptify®
Confidential and Proprietary
 http://www.aptify.com


Digital Dashboards

One of the unique features of Aptify's user interface is the Digital Dashboards functionality.

Aptify stores and manages a wide variety of information to meet the diverse operating needs of your organization. However, each individual within an organization will typically use only a small portion of Aptify's capabilities over the course of an average day. An end user wants to have easy access to those features only and does not want to sort through data which is not related to the user's job function.

With Digital Dashboards, users can modify their desktop to organize, filter, and focus on the data and applications that they work with on a daily basis. Dashboards can present a wide variety of information, including entity list views, action buttons, and Outlook components.

Each application heading has a different digital dashboard. In addition, there is a global dashboard that appears when you click the main Aptify Technology Platform heading in the Folder List.

A Dashboard (which is also referred to as a Dashboard Container) is comprised of one or more Dashboard Areas. Each Dashboard Area contains one or more Dashboard Parts. Each Dashboard Part uses a Dashboard Component; this component defines the type of information that the Dashboard Part displays (such as an Entity List View, a Button Bar, an Outlook component, etc.).

In general, a developer will use the dashboard framework provided by Aptify and add new Dashboard Components using the IDashboardComponent interface to the system as necessary.

For information on dashboards, see the Aptify.Framework.DigitalDashboard namespace.

©2008 Aptify®
Confidential and Proprietary
 http://www.aptify.com


Exception Manager

The Exception Manager is responsible for persisting and displaying application exceptions as they occur throughout the application.

From a user perspective, exceptions published to the manager appear in Aptify's Session Exception viewer (opened from the Aptify > Session Exceptions menu item) and in Microsoft Windows Event Viewer's Applications log.

For information on the Exception Manager, see the Aptify.Framework.ExceptionManagement namespace.

©2008 Aptify®
Confidential and Proprietary
 http://www.aptify.com


Generic Entity

Aptify's Generic Entity Architecture provides a standard, generic interface to relational data models, thereby simplifying programming, improving stability of systems, decreasing development time, and increasing the standard feature set for products developed using this architecture.

Historically, many database systems have been difficult to develop, costly to maintain, and lacking in features. One reason for these drawbacks is the direct access from the user interface to the database that is common in these applications. In most systems, developers of the user interface are responsible for understanding the schema in the relational data source, for accessing this data, and for using the appropriate coding techniques to ensure data integrity (for example, transactions and validation).

This methodology of system development has proven to be difficult for many reasons including:

  1. Programming correctly requires systematic and consistent attention to error handling, data validation, and database transactions. Because most systems are built under severe time pressure, proper attention to these details is often the first thing to slip. Additionally, most systems are built with less than adequate time to test for these shortcomings.
  2. Programming correctly requires significant understanding of many technologies, how they fit together, and their appropriate uses. While quite a few developers are capable of grasping all of these concepts, people are typically most efficient when dealing with a smaller set of the big picture. Additionally, some programming professionals are unable to understand the complex data models that exist in today's relational implementations.
  3. Database level programming is relatively low-level. To simply update a record in a SQL Data source, a programmer must understand how to:
    • Obtain a connection to the database.
    • Notify the database system of the start of a transaction.
    • Prepare a relatively cryptic SQL statement, which can easily be flawed (because it is difficult to test all cases of a SQL statement for each update sequence).
    • Run the statement on the server using the appropriate options with the connection technology chosen (such as ADO, RDO, and ODBCDirect).
    • Notify the database of the completion of a transaction, or rollback if unsuccessful.
    • Close the connection to the database.

With this many steps at a high level, it is easy to see how the complexity of directly modifying the data in a relational source typically leads to largely untested and unsuitable code for critical systems.

Aptify's approach, which provides a generic, object-driven model to access any type of relational data, greatly simplifies the development of database systems. Additionally, this generic abstraction layer serves as a foundation for the development of other reliable and scalable generic system services. Programmers who understand the Generic Entity Architecture and its benefits can create and add new objects to Aptify to provide customized functionality.

Generic Entity Architecture Features

Aptify's Generic Entity Architecture includes the following advantages:

Provides Easy Access To Data

The Generic Entity Architecture uses an object model that is based on objects and collections. For example, to access all of the fields in a record, a programmer uses the fields collection of the generic entity. Programmers with database experience are accustomed to this kind of process, but the process is also easy to learn for people without database experience.

Provides Validation

The Generic Entity provides validation for all standard field-level validation needs. The following validation rules apply:

  • Required fields may not be left blank
  • For numeric fields, a valid numeric value is required
  • For text fields, a valid text value is required (no use of the quoted identifier)
  • For date fields, a valid date value is required

While these rules are indeed quite simple, they provide the field-level validation that most database systems do not consistently implement. In many cases, additional validation code is required when the logic goes beyond the field level. Each object derivation from the Generic Entity may implement any combination of validation logic.

Provides Abstract Data Model

By providing a powerful, abstract data model, the Generic Entity Architecture enables the creation of tools that dynamically configure themselves around the structure of an object. For example, it is quite easy to create generic viewers, export tools, and merging tools that take advantage of the generic entity's object model.

Supports Complex Data Types

In most database systems, relations between data are highly abundant. In many cases, one-to-many relations exist that typically consist of foreign key links between tables. Typically, it is difficult to write code that will easily manipulate master/detail data relationships. The Generic Entity supports modelling complex one-to-many and many-to-many data relationships via extended object attributes called Sub-Types.

Sub-Types allow you to model data with the objects with any level of depth. Additionally, it is possible to have any number of sub-type collections at any given level of the data model. It is also possible to dynamically examine the capabilities of the object via a standard GE interface.

Permits Overriding Standard Functionality

Although problems exist in the traditional database development methodology, framework-based development has not been very successful for several reasons. One of the most pressing reasons not to use a framework to develop database applications is that most frameworks limits developer flexibility. Additionally, most frameworks are design-time frameworks, not run-time frameworks, which causes additional loss of value.

In Aptify's Generic Entity Architecture, as with all Aptify technologies, it is possible to select the services your application requires. At any point, it is quite easy to augment, override, or use the capabilities of the generic entity. Because of this focus, it is always possible to go around the default functionality of the Generic Entity to accomplish a task. While the vast majority of requirements fall within what the Generic Entity can accomplish by itself, the need does arise to go around or augment its basic functionality.

In Aptify, a developer can create a plug-in to modify the standard behavior of an entity, including validation, duplicate checking, merging operations.

Provides Security

The Generic Entity Architecture provides a standard security layer. Using the Generic Entity architecture automatically enables the configurability of each entity with separate permission control lists for Read, Create, Edit, and Delete permissions. It is easy to add more security capabilities to Generic Entity derived objects, or to override the basic security capabilities if necessary.

Enables Rapid Development

By abstracting complex data models with a standard object interface and providing the necessary tools to build such objects quickly, the Generic Entity Architecture helps to decrease overall development time while improving reliability and feature set. One of the greatest benefits for system development efforts is that this architecture establishes a well-defined interface between each layer of the application architecture. As a result, a developer can become very efficient at developing GUIs without prior knowledge of the inner workings of the data model. In fact, the design goal of this object architecture was to enable business analysts to take a system directly from prototype to production (GUI level) with no understanding of the data model in its raw relational form (only an understanding of object fields, sub-types, and so forth). This encapsulation of system logic effectively allows for the separate encapsulation of knowledge of the database and the GUI, simplifying the overall development cycle.

Provides Automatic Version Control for Data

Another problem with many database systems is tracking and controlling changes to the data. As database systems are used, the value of the information contained within them grows. Due to this natural effect, it is important for an organization to be able to control and review changes made to the data. In most systems, data changes are difficult to control and difficult to track. In any Generic Entity based system, it is easy to control access to data (see Security section above), and to track changes to the data. Version Control is built into the Generic Entity, and any object built using the Generic Entity automatically receives this feature. It is a configurable option that an administrator can turn on or off for each entity. Because mass storage is available at low cost, version control is typically left on for all entities.

In addition to tracking changes, it is possible for the Generic Entity to require the user making the change to document the reason for the change (by entering comments, who requested the change, and so forth).

As the system records data changes, a user-oriented "change string" is recorded along with a snapshot of the object. The Change String is a message that states which fields were changed in a user-oriented syntax. An example is shown below:

First Name changed from "Bob" to "John"
Last Name changes from "Jones" to "Smith"
Title changed from "President" to "CEO"
Company changed from "ABM Corp." to "SOL Corp."

The snapshot of the object is required in an HTML style markup language. An example is shown below:

Version 2 of the record

<OBJECT TYPE=FULL_VERSION ENTITY=Person VERSION=2>

<FIELD NAME=FirstName>John</FIELD>
<FIELD NAME=LastName>Smith</FIELD>
<FIELD NAME=Title>CEO</FIELD>
<FIELD NAME=Company>SOL Corp.</FIELD>

</OBJECT>

Version 1 of the record

<OBJECT TYPE=FULL_VERSION ENTITY=Person VERSION=1>

<FIELD NAME=FirstName>Bob</FIELD>
<FIELD NAME=LastName>Jones</FIELD>
<FIELD NAME=Title>President</FIELD>
<FIELD NAME=Company>ABM Corp.</FIELD>

</OBJECT>

The syntax of this language is designed to accommodate nearly any type of data format. Due to its highly structured format, it is possible for the Generic Entity layer to restore prior versions automatically to perform difference analysis and to do merging.

Provides Duplication Check Object

The Generic Entity defines a "hook" in the system to allow each customer to define the logic for checking for duplication of data. For example, depending on the locale, the customer, and a number of other factors, customers may often have companies entered into the system that are really duplicates. The Generic Entity defines a standard interface that can be used to define a duplication object which determines if a record about to be created would potentially (or absolutely) be a duplicate of any other record. The two levels are defined as follows:

  1. Absolute duplicates-If the duplication check object finds what it considers to be an absolute match (for example, a company record that has ALL relevant fields matching: name, address, phone, city, state, and so forth), then the Generic Entity does not allow the record to be created.
  2. Potential duplicates-If the duplication object finds what it considers to be a potential match, but is not absolutely certain that it is indeed a match, the system prompts the user stating that it has found X potential duplicate(s) and allows the user to view them.

Each duplication object simply defines the logic and returns to the Generic Entity a listing of absolute and/or potential duplicates. The Generic Entity in turn provides the GUI and decision logic required for the end-user, thus standardizing the GUI and simplifying the programming to implement this feature.

Provides Customer-Extensible Logic System

The Generic Entity Architecture provides a "hook" into the logic of the creating and updating of records in the database called a verify object. This object is an optional, customer-defined object that hooks into the Save process of the Generic Entity for a given object type. For example, a customer may want to add logic to send an email to a specific user whenever a new order is placed. We could easily build an object to comply with the requirements for the Verify Object interface and perform its custom operations. By supporting this generic extensibility, systems can be developed quite simply to eliminate the need to modify the base objects. That way even the business systems developed on top of the Generic Entity can easily provide extensibilty to their customers implementation needs.

Builds in Transaction Processing

In many cases, a transaction, meaning a change to the database, has multiple steps. It is vital to the integrity of the data that the transaction occurs in its entirety or it does not occur at all. The way to accomplish this is to use transaction processing command blocks directed to the server. This ensures that an atomic transaction space wraps to the individual database commands and enables the commit or rollback of the entire transaction. The Generic Entity Architecture automatically creates transactional wrappers around any changes made to the database. This makes it very easy to build a database system that automatically ensures data integrity. (Most existing systems were developed without transaction processing code because many developers are either unaware of the necessity of this part of the application, or are unfamiliar with implementation or lack time to implement it properly.)

Supports Distribution of Objects

The Generic Entity Architecture automatically supports the distribution of object processing.

For information on the Generic Entity, see the Aptify.Framework.BusinessLogic.GenericEntity namespace.

©2008 Aptify®
Confidential and Proprietary
 http://www.aptify.com


Object Repository

The Aptify Object Repository is a central repository for all software components, reports, and other files that are used within the system. Aptify's component-based software development approach offers a great deal of flexibility by allowing administrators and developers to update software on the server that is automatically distributed to each client machine. The automatic distribution feature of Aptify is a key benefit that dramatically reduces the administrative overhead traditionally associated with supporting enterprise business applications.

To implement new functionality within Aptify, an organization first adds objects created by a developer to the Object Repository for distribution.

The Object Repository in Aptify is managed through the Administration - Object Repository application, which includes a management dashboard to easily locate system objects. The services included in this application allow the administrator to define object contexts, configure object types, and store or update files required by Aptify to run.

Automatic File Distribution to Client Computers

When installing the Aptify client on a computer, the installation wizard adds the Aptify Object Repository Download Installer as a Windows Service. This service manages downloads from the Object Repository to a client computer's ObjectCache folder (or another location specified by your organization). The Object Repository Download Installer is a Windows service that starts automatically after the Aptify Client application is installed and each time the client computer restarts.

The Object Repository Download Installer runs under the LocalSystem so users do not need elevated permissions to download Aptify objects. When using the Object Repository Download Installer service, administrators can configure a user as a Windows Restricted user (that is, a member of Windows's Users Group) while maintaining the ability to automatically push updated files to the client's computer.

The Object Repository stores all of the files required by an Aptify system. When a user connects to Aptify for the first time, the Object Repository Download Installer retrieves all of the objects from the Startup packages. Computers that have the Aptify client application installed automatically download the necessary Object Repository files the first time the application is run. The server also automatically distributes new and updated repository files to clients as necessary.

Object Repository Structure

Aptify designed the Object Repository so that an organization can control which objects are downloaded to a specific user's computer, depending on the user's access requirements. To implement this approach, the Object Repository uses the following structure to provide users with a specific set of system objects:

  • An administrator associates each user with an Object Context.
  • Each Object Context contains one or more Object Packages.
  • Each Object Package contains one or more Object Repository Objects.
  • Each Object Repository Object is assigned an Object Type.
    • Standard Object Types include .NET Assemblies, ActiveX Controls, COM-based DLLs, Text files, and Image files.
  • The system automatically detects class information for .NET assemblies and COM objects that are added to the repository.
    • Object Repository Classes track information about .NET and COM classes that belong to Object Repository Objects, including licensing information associated with the class. When an object is created that is a COM object or .NET assembly, an Object Repository Classes record is created for each class included within the object.

When a user logs in to Aptify, the Object Repository Download Installer retrieves all of the objects associated with the user's assigned Object Context. Note that the standard Aptify installation includes one Object Context, named Production.

See the Aptify Administration Guide for more functional information on the Object Repository, including information on the Object Repository Administration dashboard and the services associated with the repository.

For SDK information on the Object Repository, see the Aptify.Framework.ObjectRepository namespace.

©2008 Aptify®
Confidential and Proprietary
 http://www.aptify.com


Overview of Microsoft .NET Framework

The Microsoft .NET Framework is a technology that serves as a foundation for component-based software development, with particular emphasis on solving some of the problems that affected developers using earlier frameworks, such as Microsoft's Component Object Model (COM). Additionally, the Microsoft .NET Framework has emphasized the importance of the internet in software development, and Microsoft has invested heavily in development tools and related technologies designed to make it more productive for programmers to produce web-based applications. The .NET Framework also provides a number of important solutions for deployment of software that will make it easier and safer for software vendors to release new versions of code without impacting the functionality of legacy systems.

Note that Microsoft .NET Framework is not a business application framework; it is a technological standard for component-based software development, upon which business application frameworks, such as Aptify's, may be constructed. .NET is an entirely new component architecture that is a replacement for Microsoft's COM technology. However, developers can still use .NET's interop functionality to interface with any existing COM object.

There are many books and Web sites devoted to the .NET Framework that are available for further study. If you are unfamiliar with .NET, you may want to refer to the following Web sites for more information:
  • Microsoft's .NET Framework Development Center: http://msdn.microsoft.com/netframework/
  • Microsoft's .NET Home Page: http://www.microsoft.com/NET/
  • GotDotNet: The Microsoft .NET Framework Community: http://www.gotdotnet.com/

©2008 Aptify®
Confidential and Proprietary
 http://www.aptify.com


Object Reference

This section contains information on all objects used by the Aptify system. Functionality is presented in alphabetical order based on the associated .NET Namespace.

This SDK includes information about the following Aptify namespaces:

This SDK also includes links to Microsoft's MSDN, and information from Microsoft's MSDN is loaded automatically, when applicable. For example, if you click the link for the AptifyApplication class's Equals method, the SDK displays the information on the Object.Equals method from Microsoft's .NET Framework Class (since AptifyApplication inherits this method from Microsoft's System.Object class).

Namespace

Corresponding Aptify Functionality

Aptify.Application.DataSetGUI

Map Views

Aptify.Application.Wizards

Generic Metadata Wizards

Aptify.Applications

Aptify Business Applications

Aptify.Applications.Accounting

Accounting Functionality

Aptify.Applications.Accounting.AP

Accounts Payable Integration

Aptify.Applications.Accounting.Currency

Multi-Currency Accounting

Aptify.Applications.Accounting.SchedTransGroupsLayout

Scheduled Transaction Group Form Template

Aptify.Applications.Accounting.WindowsControls

Form Templates for Other Accounting-related Entities

Aptify.Applications.Advertising

Advertising

Aptify.Applications.AptifyHierarchyControl

Hierarchy Browser

Aptify.Application.AptifySpecialFields

Special Field Text Box Form Component

Aptify.Applications.BulkWriteOffWizard

Bulk Write Off Wizard

Aptify.Applications.Campaigns

Campaign Management

Aptify.Applications.Campaigns.ListImport

Campaign List Import Wizard

Aptify.Applications.CaseManagement

Case Management

Aptify.Applications.Chapters

Chapter Management

Aptify.Applications.Commissions

Commissions

Aptify.Applications.CommiteeTerm

Committee Management

Aptify.Applications.CommitteeTerm

Committee Management

Aptify.Applications.Companies

Companies Service

Aptify.Applications.Companies.CompanyListsControl

Companies Form's Lists Tab

Aptify.Applications.Companies.CompanyOrdersControl

Companies Form's Orders Tab

Aptify.Applications.CompanyObject

Companies Business Logic

Aptify.Applications.ContactManagement

Contact Log

Aptify.Applications.ContactManagement.WindowsControls

Contact Log

Aptify.Applications.CRM

Customer Relationship Management Functionality

Aptify.Applications.Education

Education Management

Aptify.Applications.Education.WindowsControls

Class Registrations Form Template

Aptify.Applications.ExpoManagement

Expo Management

Aptify.Applications.Expos

Expo Management's Priority Points Functionality

Aptify.Applications.Expos.ExpoCAD

Expo Management Integration with ExpoCAD

Aptify.Applications.Expos.FloorplanIntegration

Expo Management's Generic Integration Framework for Third-Party Floorplan Systems

Aptify.Applications.Fundraising

Fundraising Management

Aptify.Applications.Housing

Housing Management

Aptify.Applications.Inventory

Inventory Management

Aptify.Applications.InventoryManagement

Inventory Management Wizards

Aptify.Applications.Marketplace

E-Business Marketplace Listings Functionality

Aptify.Applications.MeetingManagement

Meeting Management

Aptify.Applications.Meetings

Check Meeting Inventory Functionality

Aptify.Applications.MemberTypes

Member Types Entity Object

Aptify.Applications.Notes

Notes

Aptify.Applications.OrderEntry

Order Entry

Aptify.Applications.OrderEntry.Payments

Payment Processing

Aptify.Applications.OrderEntry.Payments.ElectronicPaymentVerisign

Integration with VeriSign for Electronic Payment Processing

Aptify.Applications.OrderEntry.Payments.Exceptions

Payment Processing

Aptify.Applications.OrderEntry.Subscriptions

Subscription Management

Aptify.Applications.OrderEntry.WindowsControls

Orders Form Template

Aptify.Applications.Organization

Organizations Entity

Aptify.Applications.PersonCompanies.PersonCompaniesLayout

PersonCompanies Sub-Type Form Template

Aptify.Applications.Persons

Persons Entity

Aptify.Applications.Persons.Committees

Committee Management

Aptify.Applications.Persons.WebAccess

Web Access Functionality for Persons Entity

Aptify.Applications.ProductSetup

Products Setup and Maintenance

Aptify.Applications.ProductSetup.WebAccess

AWA Web Layout Control for Products Form

Aptify.Applications.ProductSetup.WindowsControls

Product-related Form Templates

Aptify.Applications.SalesForceAutomation

Sales Force Automation

Aptify.Applications.Subscriptions

Subscription Management

Aptify.Applications.Subscriptions.WindowsControls

Subscription-related Form Templates

Aptify.Applications.Tasks

Task Management

Aptify.Framework.AcctMgrTransferPFComp

Account Manager Transfer Wizard

Aptify.Framework.Administration

Virtual Entity Wizard

Aptify.Framework.Application

Application Object

Aptify.Framework.ApplicationRibbonGroup.Components

Aptify Ribbon Configuration Tool

Aptify.Framework.Archive

Archive Runs

Aptify.Framework.AttributeManagement

Attribute Manager

Aptify.Framework.AttributeManagement.Exceptions

Attribute Manager

Aptify.Framework.AttributeManagement.Interfaces

Attribute Manager

Aptify.Framework.BusinessLogic

Generic Business Processes, including User Management and Merging

Aptify.Framework.BusinessLogic.Address

Address Management

Aptify.Framework.BusinessLogic.Alerts

Alerts

Aptify.Framework.BusinessLogic.AttachmentCategories

Attachment Categories

Aptify.Framework.BusinessLogic.CalendarView

Calendar Views

Aptify.Framework.BusinessLogic.DBObject

Database Objects

Aptify.Framework.BusinessLogic.DBObject.Exceptions

Database Objects

Aptify.Framework.BusinessLogic.DuplicateProcessing

Processing Duplicate Records

Aptify.Framework.BusinessLogic.Entity

Common Entity functionality and related viewers (such as Base Fields, Entity Bulk Operations, Form Templates, and Process Flows).

Aptify.Framework.BusinessLogic.Entity.Employees

Employees

Aptify.Framework.BusinessLogic.Entity.EntitySubTables

Entity Sub-Tables and Filegroup Assignments

Aptify.Framework.BusinessLogic.Entity.Exceptions

Entities

Aptify.Framework.BusinessLogic.FilterRules

Filter Rules

Aptify.Framework.BusinessLogic.FormTemplate

Form Templates

Aptify.Framework.BusinessLogic.GenericEntity

Generic Entity

Aptify.Framework.BusinessLogic.GenericEntity.Generated

Objects Created by Strongly Typed Entity Object Generator

Aptify.Framework.BusinessLogic.Packers

Entity and Data Packing

Aptify.Framework.BusinessLogic.PendingChanges

Pending Changes

Aptify.Framework.BusinessLogic.PendingChanges.Exceptions

Pending Changes

Aptify.Framework.BusinessLogic.ProcessPipeline

Process Flows and the Application Server

Aptify.Framework.BusinessLogic.ProcessPipeline.Components

Process Components

Aptify.Framework.BusinessLogic.ProcessPipeline.WindowsControl

Process Flow Form

Aptify.Framework.BusinessLogic.Reporting

Report Wizard

Aptify.Framework.BusinessLogic.ScheduledTasks

Scheduled Tasks

Aptify.Framework.BusinessLogic.ScheduledTasks.TaskScheduler

Scheduled Tasks

Aptify.Framework.BusinessLogic.Security

Security Keys and Field Level Encryption

Aptify.Framework.BusinessLogic.Spelling

Spell Check Functionality

Aptify.Framework.BusinessLogic.Views

Views

Aptify.Framework.DataPacker

Data Packer and Unpacker Wizards

Aptify.Framework.DataServices

Data Services Layer

Aptify.Framework.DataServices.SQLDataServices

Data Services Layer

Aptify.Framework.DigitalDashboard

Digital Dashboards

Aptify.Framework.DigitalDashboard.Components

Digital Dashboards

Aptify.Framework.EntityPacker

Entity Packer and Unpacker Wizards

Aptify.Framework.ExceptionManagement

Session Exception Manager

Aptify.Framework.ExceptionManagement.Interfaces

Session Exception Manager

Aptify.Framework.Formtemplate

Form Template Copy Wizard

Aptify.Framework.GenericImport

Generic Import Wizard

Aptify.Framework.GenericImport.Components

Generic Import Wizard

Aptify.Framework.GenericWizard

Generic Metadata Wizards

Aptify.Framework.GenericWizard.WindowsControls

Generic Metadata Wizards

Aptify.Framework.Integration

E-Business Integration with Content Management Systems

Aptify.Framework.Integration.AptifyEktronWS

E-Business Integration with Ektron CMS

Aptify.Framework.Integration.AptifySiteFinityWS

E-Business Integration with Sitefinity CMS

Aptify.Framework.Integration.ContentService

E-Business Integration with Content Management Systems

Aptify.Framework.Integration.EktronControls

E-Business Integration with Ektron CMS

Aptify.Framework.Integration.FolderService

E-Business Integration with Content Management Systems

Aptify.Framework.Integration.TaxonomyService

E-Business Integration with Content Management Systems

Aptify.Framework.Integration.UserService

E-Business Integration with Content Management Systems

Aptify.Framework.LoginServices

Aptify Login

Aptify.Framework.LoginServices.ConnectionStateExceptions

Connection State Login Options

Aptify.Framework.Messaging

Bulk Messaging

Aptify.Framework.MicrosoftWord

Microsoft Word Mail Merge Wizard

Aptify.Framework.Misc

Sample Data Loader

Aptify.Framework.MultiEntityGrid

Multi Entity Grid

Aptify.Framework.MultiEntityGrid.WindowsControls

Multi Entity Grid

Aptify.Framework.ObjectRepository

Object Repository

Aptify.Framework.RecordTemplate

Record Templates

Aptify.Framework.Replication

Replication

Aptify.Framework.Replication.Exceptions

Replication

Aptify.Framework.Replication.Exceptions.ConflictManagement

Replication

Aptify.Framework.Replication.Exceptions.SynchExceptions

Replication

Aptify.Framework.Replication.Wizards

Replication

Aptify.Framework.Scanner

Aptify Framework

Aptify.Framework.Scanner.Implementations

Aptify Framework

Aptify.Framework.Scripting

Scripting Engine for Scipts entity that has embedded links to numerous services, including Message Parts, Process Flows, and Field Validation

Aptify.Framework.Web.AWA

Aptify Web Access (AWA) Functionality

Aptify.Framework.Web.AWA.Components

Aptify Web Access (AWA) Functionality

Aptify.Framework.Web.Common

Aptify Web Functionality Common to AWA and E-Business

Aptify.Framework.Web.Common.RSS

RSS Functionality for Aptify Web Applications

Aptify.Framework.Web.Common.TabControl

Tab Control for Aptify Web forms

Aptify.Framework.Web.eBusiness

E-Business

Aptify.Framework.Web.eBusiness.Knowledge

E-Business Surveys

Aptify.Framework.Web.eBusiness.Knowledge.Admin

E-Business Surveys

Aptify.Framework.Web.eBusiness.Knowledge.Controls

E-Business Surveys

Aptify.Framework.Web.eBusiness.LearningManagementSystems

E-Business Integration with Learning Management Systems

Aptify.Framework.Web.eBusiness.ProductCatalog

E-Business Product Catalog

Aptify.Framework.WindowsControls

Bound Controls, Notes viewer, Views, and other system functionality

Aptify.Framework.WindowsControls.Address

Windows Controls for Address Management

Aptify.Framework.WindowsControls.Phone

Windows Controls for Telephone Number Management

Aptify.Framework.WindowsControls.TaskTray

Aptify Task Tray Icon

Aptify.Framework.WindowsForms

Specialized forms and wizards, including the Views form and dialog, the User Administration wizard, and the Object Viewer

Aptify.Framework.WindowsForms.EntitiesViewer

Windows forms for the Entities service

Aptify.Framework.WindowsForms.Excel

Microsoft Excel Integration Wizard

Aptify.Framework.WindowsForms.Exceptions

Error handling for specialized forms

©2008 Aptify®
Confidential and Proprietary
 http://www.aptify.com


Aptify.Application.DataSetGUI

Aptify 5.0 Software Development Kit (SDK)

Aptify.Application.DataSetGUI Namespace

This namespace contains the layout logic for the Map View's Data Set configuration dialog.

Namespace hierarchy

Classes

Class | Description
DataSetLayout | Provides presentation layer logic for MapView DataSet

Send comments on this topic.

Copyright © 2008 Aptify® - Confidential and Proprietary


DataSetLayout Class

Provides presentation layer logic for MapView DataSet

For a list of all members of this type, see DataSetLayout Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
DataSetLayout

public class DataSetLayout : FormTemplateLayout

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Application.DataSetGUI

Assembly: AptifyMapViewDataSetGUI (in AptifyMapViewDataSetGUI.dll)

See Also

DataSetLayout Members | Aptify.Application.DataSetGUI Namespace


DataSetLayout Members

DataSetLayout overview

Public Instance Constructors

DataSetLayout Constructor Initializes a new instance of the DataSetLayout class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

lnkView

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindViewControl | This method able to access the view link box control on the form template.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetCategoryID |
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetHiddenFilterClause | This function Sets the OnwerID of the view as per the user logged in to aptify.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded | Contains logic to setup Event handlers for controls on the FormTemplate Layout.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

DataSetLayout Class | Aptify.Application.DataSetGUI Namespace


DataSetLayout Constructor

Initializes a new instance of the DataSetLayout class.

public DataSetLayout();

See Also

DataSetLayout Class | Aptify.Application.DataSetGUI Namespace


DataSetLayout Fields

The fields of the DataSetLayout class are listed below. For a complete list of DataSetLayout class members, see the DataSetLayout Members topic.

Protected Instance Fields

lnkView

See Also

DataSetLayout Class | Aptify.Application.DataSetGUI Namespace


DataSetLayout.lnkView Field

protected lnkView lnkView;

See Also

DataSetLayout Class | Aptify.Application.DataSetGUI Namespace


DataSetLayout Methods

The methods of the DataSetLayout class are listed below. For a complete list of DataSetLayout class members, see the DataSetLayout Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindViewControl | This method able to access the view link box control on the form template.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetCategoryID |
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetHiddenFilterClause | This function Sets the OnwerID of the view as per the user logged in to aptify.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded | Contains logic to setup Event handlers for controls on the FormTemplate Layout.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

DataSetLayout Class | Aptify.Application.DataSetGUI Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

DataSetLayout.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

DataSetLayout Class | Aptify.Application.DataSetGUI Namespace


DataSetLayout.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

DataSetLayout Class | Aptify.Application.DataSetGUI Namespace | DataSetLayout.Dispose Overload List


DataSetLayout.FindViewControl Method

This method able to access the view link box control on the form template.

protected void FindViewControl();

Remarks

See Also

DataSetLayout Class | Aptify.Application.DataSetGUI Namespace


DataSetLayout.GetCategoryID Method

protected string GetCategoryID();

See Also

DataSetLayout Class | Aptify.Application.DataSetGUI Namespace


DataSetLayout.GetHiddenFilterClause Method

This function Sets the OnwerID of the view as per the user logged in to aptify.

protected string GetHiddenFilterClause();

Return Value

Remarks

See Also

DataSetLayout Class | Aptify.Application.DataSetGUI Namespace


DataSetLayout.OnFormTemplateLoaded Method

Contains logic to setup Event handlers for controls on the FormTemplate Layout.

protected override void OnFormTemplateLoaded(
FormTemplateLayout.FormTemplateLoadedEventArgs e
);

Parameters

e

Remarks

See Also

DataSetLayout Class | Aptify.Application.DataSetGUI Namespace


Aptify.Application.Wizards

Aptify 5.0 Software Development Kit (SDK)

Aptify.Application.Wizards Namespace

This namespace contains the layout logic for forms used to build a metadata wizard.

Namespace hierarchy

Classes

Class | Description
Wizards |


Wizards Class

For a list of all members of this type, see Wizards Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
Wizards

public class Wizards : FormTemplateLayout

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Application.Wizards

Assembly: WizardLayoutControls (in WizardLayoutControls.dll)

See Also

Wizards Members | Aptify.Application.Wizards Namespace


Wizards Members

Wizards overview

Public Instance Constructors

Wizards Constructor Initializes a new instance of the Wizards class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

Wizards Class | Aptify.Application.Wizards Namespace


Wizards Constructor

Initializes a new instance of the Wizards class.

public Wizards();

See Also

Wizards Class | Aptify.Application.Wizards Namespace


Wizards Methods

The methods of the Wizards class are listed below. For a complete list of Wizards class members, see the Wizards Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

Wizards Class | Aptify.Application.Wizards Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

Wizards.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

Wizards Class | Aptify.Application.Wizards Namespace


Wizards.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

Wizards Class | Aptify.Application.Wizards Namespace | Wizards.Dispose Overload List


Wizards.OnFormTemplateLoaded Method

protected override void OnFormTemplateLoaded(
FormTemplateLayout.FormTemplateLoadedEventArgs e
);

See Also

Wizards Class | Aptify.Application.Wizards Namespace


Aptify.Applications

Aptify 5.0 Software Development Kit (SDK)

Aptify.Applications Namespace

This namespace contains the generic control for displaying GL Entries in Aptify.

Namespace hierarchy

Classes

Class | Description
GLEntriesControl | Aptify GL Entries Control - Generic Control for viewing/editing GL Entries


GLEntriesControl Class

Aptify GL Entries Control - Generic Control for viewing/editing GL Entries

For a list of all members of this type, see GLEntriesControl Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
GLEntriesControl

public class GLEntriesControl : FormComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications

Assembly: GLEntriesControl (in GLEntriesControl.dll)

See Also

GLEntriesControl Members | Aptify.Applications Namespace


GLEntriesControl Members

GLEntriesControl overview

Public Instance Constructors

GLEntriesControl Constructor Initializes a new instance of the GLEntriesControl class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrencyFormat |
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
GLEntriesSubTypeName |
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RecalculateTotals |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormComponent) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateContext (inherited from FormComponent) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormComponent) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormComponent) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormComponent) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

GLEntriesControl Class | Aptify.Applications Namespace


GLEntriesControl Constructor

Initializes a new instance of the GLEntriesControl class.

public GLEntriesControl();

See Also

GLEntriesControl Class | Aptify.Applications Namespace


GLEntriesControl Properties

The properties of the GLEntriesControl class are listed below. For a complete list of GLEntriesControl class members, see the GLEntriesControl Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrencyFormat |
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
GLEntriesSubTypeName |
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateContext (inherited from FormComponent) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

GLEntriesControl Class | Aptify.Applications Namespace


CurrencyFormat Property

Aptify 5.0 Software Development Kit (SDK)

GLEntriesControl.CurrencyFormat Property

public String CurrencyFormat {get; set;}

See Also

GLEntriesControl Class | Aptify.Applications Namespace


GLEntriesSubTypeName Property

Aptify 5.0 Software Development Kit (SDK)

GLEntriesControl.GLEntriesSubTypeName Property

public String GLEntriesSubTypeName {get; set;}

See Also

GLEntriesControl Class | Aptify.Applications Namespace


GLEntriesControl Methods

The methods of the GLEntriesControl class are listed below. For a complete list of GLEntriesControl class members, see the GLEntriesControl Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RecalculateTotals |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormComponent) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormComponent) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormComponent) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormComponent) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

GLEntriesControl Class | Aptify.Applications Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

GLEntriesControl.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

GLEntriesControl Class | Aptify.Applications Namespace


GLEntriesControl.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

GLEntriesControl Class | Aptify.Applications Namespace | GLEntriesControl.Dispose Overload List


GLEntriesControl.OnFormComponentConfig Method

protected override void OnFormComponentConfig(
AptifyFormTemplateContext FormTemplateContext
);

Implements

IFormComponent.

See Also

GLEntriesControl Class | Aptify.Applications Namespace


OnShow Method

Aptify 5.0 Software Development Kit (SDK)

GLEntriesControl.OnShow Method

Overload List

Inherited from FormComponent.

protected virtual void OnShow();

protected override void OnShow(Boolean);

See Also

GLEntriesControl Class | Aptify.Applications Namespace


GLEntriesControl.OnShow Method (Boolean)

protected override void OnShow(
Boolean Refresh
);

Implements

IFormComponent.

See Also

GLEntriesControl Class | Aptify.Applications Namespace | GLEntriesControl.OnShow Overload List


GLEntriesControl.RecalculateTotals Method

public void RecalculateTotals();

See Also

GLEntriesControl Class | Aptify.Applications Namespace


Aptify.Applications.Accounting

Aptify 5.0 Software Development Kit (SDK)

Aptify.Applications.Accounting Namespace

This namespace contains objects related to Aptify's standard Accounting functionality, including General Ledger batches, Cash Control Batches, Scheduled Transactions, and Sales Tax Rates.

Namespace hierarchy

Classes

Class | Description
Batch | This class is the Batch Object Generic Entity sub-class and handles functionality related to creating, and managing GL Export Batches in Aptify.
BatchGLDetailForm |
BatchRecordsForm |
BatchResultsForm |
BatchViewerForm |
BatchWizard |
BatchWizardForm |
CashControlBatch | Contains the GUI used by the Cash Control Batches Entity.
CashControlBatchDetail | Control used to display the contents of a Cash Control Batch Detail.
CashControlBatchDetailForm | Used to display a CashControlBatchDetailForm
CashControlBatchGUIException | Thrown when Cash Control Batch specific exceptions occur in a GUI element.
DemoLockBoxImport | This is a demonstration of a bank file import for the Aptify Lock Box Import Wizard The purpose of this class is to provide an example of how to plug in file formats that can accomodate various types of import options The demo file format has a first line comment, a second line that contains header information, and third lines and beyond contain payment line items. First Line: Comment - Ignore it Second Line: DepositDate,BankBatch,Total,PaymentType Third+ Lines: OrderID, Customer Name, PaymentAmount, Check Number
DemoLockBoxImportException | Thrown where there is a problem during the Demo Lock Box Import.
ExpandScheduledTransactions | Written by Ravi Nagarajan, October 13, 1999 The purpose of this object is to review Scheduled Transaction Group records in the database and create the associated scheduled transaction records based on the group attributes. This process was introduced starting with the 1.20 build to improve the speed of the order entry system. Rather than generating individual scheduled transaction records during the Order save process, we create a single record per order line from which we can later generate the individual scheduled transaction records.
GLExport |
GreatPlainsExport | This GL Export Driver produces an export file that can be imported by Microsoft Great Plains The default implementation logic for this driver is to output a comma delimited file that has the following fields in each line of the file. The first line of the file shows the column headers. Columns: AccountNumber, Amount, Reference, Date, WeightedAvgSpotRate Note: The standard driver produces a "Reference" field of "Aptify Batch ID: 12345" for each line where 12345 is the Batch # for the export batch.
InvoiceConsolidation | This class implements the functionality for consolidation of invoices for persons and/or companies. The class provides a type-specific set of members for direct access and also implements IProcessComponent for use with the Process Pipeline architecture.
InvoiceConsolidation.CreditOrderInfo |
InvoiceConsolidation.OrderInfo |
InvoiceConsolidation.TransferInfo |
InvoiceConsolidationWizard | User Interface Wizard for consolidation of invoices/payments/balances on an account. This wizard uses the InvoiceConsolidation object to perform the business logic for the user's selections.
LockBoxAllocProducts | This class provides the default implmentation of the ILockBoxAllocQuery interface for the lock box architecture. It is possible to sub-class this class and override its various members to provide the specific functionality required for an implementation of the lock box architecture that requires different logic in this area of the system. Alternatively, it is also possible to build a new class that also implements ILockBoxAllocQuery and to plug in that entirely new class as well into the architecture using the meta-data attributes in the Cash Control Batches entity.
LockBoxBase | This is a base class that is used as a generic base layer for all of the other lock-box application classes that are in this assembly. It provides some generalized functionality for managing Aptify application objects, database names, and data actions to simplify the programming of sub-classes. This class is marked as MustInherit since by itself it doesn't provide a set of functional capabilities that can be directly used by a consumer of the class
LockBoxException | Thrown when there is a problem with Lock Box functionality.
LockBoxImportBase | This class provides a set of utility functions as a base class for all other import objects that need to provide lock box import functionality
LockBoxMatch | This class provides the default Aptify implementation for the ILockBoxMatch interface. The base class implements a number of basic matching methods which are overridable if it is necessary to alter the functionality that the matching object provides.
LockBoxPost | This class provides the default Aptify implementation for the ILockBoxPost interface
LockBoxPostRecord | This class provides the default Aptify implementation for the ILockBoxPostRecord interface
LockBoxTextFileImport | This is a base class for all text file based imports for lock box and provides general file manipulation utilities to all of its sub-classes.
LockBoxWizard | Displays a Wizard that walks users through importing a Lock Box File.
NavisionExport |
OrderPaymentTotals |
OrganizationTaxAddressCache | Caches Organization Address information in TaxAddress objects. Shared, on-demand cache.
PaymentInformation | This class provides the default business logic implementation for the Payment Information entity.
PaymentType |
PaymentTypeCache |
RossFinancialsExport |
SalesTax | This object implements the Aptify.Framework.Applications.Accounting.ISalesTaxRate interface. The purpose of this component is to return a tax rate for a given set of input parameters base currency id.
SalesTaxRate | This object implements the Aptify.Framework.Applications.Accounting.ISalesTaxRate interface. The purpose of this component is to return a tax rate for a given set of input parameters base currency id.
SalesTaxRateEntity |
SalesTaxRateLayout |
SavedPaymentMethod |
ScheduledTransaction |
ScheduledTransactionGroupsExtension | View Extension for Scheduled Transaction Groups. Supports the expansion of Scheduled Transaction Group records from a View.
ScheduledTransactionLayout |
ScheduleTransactionExtension | Extends the context menu displayed in Scheduled Transactions Views.
SelectCurrencyType | Dialog that allows a user to select one of the specified currency types that are provided in the Config() method.
SolomonExport |
StandingOrderFulfillment | Provides functionality to fulfill a group of standing orders based on a list of standing order record ID values or based on a View of Standing Orders. This object implements a specialized set of methods that are publicly available as well as IProcessComponent
StandingOrderFulfillmentWizard | Aptify Standing Order Fulfillment Wizard GUI Class
StandingOrdersEntity |
Status |
TaxJurisdictionCache | Caches Tax Jurisdictions information. Shared, on-demand cache.
TaxJurisdictionData |
TaxJurisdictionsLayout |

Interfaces

Interface | Description
IExpandScheduledTransactions |
IGenerateGL | This interface is used for plug-ins to create GL entries as needed in different application areas in the Aptify Order Entry, Payment Processing and Accounting Integration system areas.
IGLExport |
ILockBoxAllocQuery | This interface is used to create plug-in components that provide a list of available Products that the cash control batch allows a user to allocate overpayments to.
ILockBoxImport | Interface used to create plug-ins for the lock box import engine/process
ILockBoxMatch |
ILockBoxPost | This interface is used to create plug-in components than handle the posting phase of the lock box import/match/post process.
ILockBoxPostException |
ILockBoxPostMatch | This interface is used to create plug-in components that handle the logic for posting individual detail match records inside a cash control batch based on any logic required by the application.
ISalesTaxRate | Interface used to create plug-ins for setting sales tax rates for orders
IStandingOrder | Interface used to create plug-ins for standing order processes

Structures

Structure | Description
GLExport.GLExportFileOperation |

Delegates

Delegate | Description
Batch.GenerateGLEntryStatusEventHandler |
Batch.GenerateGLSummaryEventHandler |
Batch.GenerateSchedTransStatusEventHandler |
ExpandScheduledTransactions.GroupExpansionStatusEventHandler |
IExpandScheduledTransactions.GroupExpansionStatusEventHandler |
InvoiceConsolidation.StatusUpdateEventHandler |
StandingOrderFulfillment.SetMessageEventHandler |
StandingOrderFulfillment.StatusUpdateEventHandler |
StatusUpdateEventHandler | Represents the Method that should be called when Status for a long running task should be updated.

Enumerations

Enumeration | Description
Batch.BetterInStrType |
BatchWizardForm.BetterInStrType |
ExpandScheduledTransactions.BetterInStrType |
GLExport.GLExportFileWriteAction |
PaymentInformation.BasePaymentTypes |
PaymentType.PaymentTypeServiceChargeMethod |
PaymentType.PaymentTypeServiceChargeType |
StandingOrderType | Enumerated type representing the different types of standing orders that can exist
TaxJurisdictionScope |


Batch Class

This class is the Batch Object Generic Entity sub-class and handles functionality related to creating, and managing GL Export Batches in Aptify.

For a list of all members of this type, see Batch Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
Batch

public class Batch : AptifyGenericEntity, IProcessComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: BatchObject (in BatchObject.dll)

See Also

Batch Members | Aptify.Applications.Accounting Namespace


Batch Members

Batch overview

Public Instance Constructors

Batch Constructor Initializes a new instance of the Batch class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
Properties |
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
BetterInStr |
CancelProcess |
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
ConfigBatch | Overloaded.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
DoGLExport | Overloaded.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenerateDetailGLEntries |
GenerateScheduledTransactions |
GenerateSummaryGLEntries |
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetBatchSQL |
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetExcludedSQL |
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
MinNot |
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
ProcessComponentConfig |
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Run | Component assumes these input properties: View ID - optional View SQL - optional Batch Type - Orders, Payments or Scheduled Transactions Batch Name - Optional - if not provided a generated name will be placed Effective Date - Optional - if not provided, current date will be used CurrencyTypeID - Required - FunctionalCurrencyTypeID - Required - Output Properties - Batch ID Result Codes - SUCCESS, FAILED
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
UpdateOrderInventory |
UpdateRecordBatchID |
Validate | Overloaded.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
GenerateGLEntryStatus |
GenerateGLSummary |
GenerateSchedTransStatus |
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
DoProcess |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

Batch Class | Aptify.Applications.Accounting Namespace


Batch Constructor

Initializes a new instance of the Batch class.

public Batch();

See Also

Batch Class | Aptify.Applications.Accounting Namespace


Batch Properties

The properties of the Batch class are listed below. For a complete list of Batch class members, see the Batch Members topic.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
Properties |
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

Batch Class | Aptify.Applications.Accounting Namespace


Properties Property

Aptify 5.0 Software Development Kit (SDK)

Batch.Properties Property

public AptifyProperties Properties {get;}

Implements

IProcessComponent.

See Also

Batch Class | Aptify.Applications.Accounting Namespace


Batch Methods

The methods of the Batch class are listed below. For a complete list of Batch class members, see the Batch Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
BetterInStr |
CancelProcess |
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
ConfigBatch | Overloaded.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
DoGLExport | Overloaded.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenerateDetailGLEntries |
GenerateScheduledTransactions |
GenerateSummaryGLEntries |
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetBatchSQL |
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetExcludedSQL |
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
MinNot |
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
ProcessComponentConfig |
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Run | Component assumes these input properties: View ID - optional View SQL - optional Batch Type - Orders, Payments or Scheduled Transactions Batch Name - Optional - if not provided a generated name will be placed Effective Date - Optional - if not provided, current date will be used CurrencyTypeID - Required - FunctionalCurrencyTypeID - Required - Output Properties - Batch ID Result Codes - SUCCESS, FAILED
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
UpdateOrderInventory |
UpdateRecordBatchID |
Validate | Overloaded.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
DoProcess |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

Batch Class | Aptify.Applications.Accounting Namespace


Batch.BetterInStr Method

public int BetterInStr(
String sStr,
String sTerm,
Batch.BetterInStrType iType
);

See Also

Batch Class | Aptify.Applications.Accounting Namespace


Batch.CancelProcess Method

public void CancelProcess();

See Also

Batch Class | Aptify.Applications.Accounting Namespace


ConfigBatch Method

Aptify 5.0 Software Development Kit (SDK)

Batch.ConfigBatch Method

Overload List

public bool ConfigBatch(AptifyApplication,Int64);

public bool ConfigBatch(AptifyApplication,Int64,Int64);

public bool ConfigBatch(AptifyApplication,Int64,String);

See Also

Batch Class | Aptify.Applications.Accounting Namespace


Batch.ConfigBatch Method (AptifyApplication, Int64)

public bool ConfigBatch(
AptifyApplication Application,
Int64 EntityID
);

See Also

Batch Class | Aptify.Applications.Accounting Namespace | Batch.ConfigBatch Overload List


Batch.ConfigBatch Method (AptifyApplication, Int64, Int64)

public bool ConfigBatch(
AptifyApplication Application,
Int64 EntityID,
Int64 ViewID
);

See Also

Batch Class | Aptify.Applications.Accounting Namespace | Batch.ConfigBatch Overload List


Batch.ConfigBatch Method (AptifyApplication, Int64, String)

public bool ConfigBatch(
AptifyApplication Application,
Int64 EntityID,
String ViewSQL
);

See Also

Batch Class | Aptify.Applications.Accounting Namespace | Batch.ConfigBatch Overload List


DoGLExport Method

Aptify 5.0 Software Development Kit (SDK)

Batch.DoGLExport Method

Overload List

public bool DoGLExport(String,AptifyApplication,Boolean);

public bool DoGLExport(String,Boolean);

See Also

Batch Class | Aptify.Applications.Accounting Namespace


Batch.DoGLExport Method (String, AptifyApplication, Boolean)

public bool DoGLExport(
String DefaultExportLocation,
AptifyApplication oApplication,
Boolean ShowGUI
);

See Also

Batch Class | Aptify.Applications.Accounting Namespace | Batch.DoGLExport Overload List


Batch.DoGLExport Method (String, Boolean)

public bool DoGLExport(
String DefaultExportLocation,
Boolean ShowGUI
);

See Also

Batch Class | Aptify.Applications.Accounting Namespace | Batch.DoGLExport Overload List


Batch.DoProcess Method

protected virtual string DoProcess(
String BatchType,
DateTime EffectiveDate,
String BatchName,
Int64 CurrencyTypeID,
Int64 FunctionalCurrencyTypeID
);

See Also

Batch Class | Aptify.Applications.Accounting Namespace


Batch.GenerateDetailGLEntries Method

public bool GenerateDetailGLEntries(
Boolean ShowProgress
);

See Also

Batch Class | Aptify.Applications.Accounting Namespace


Batch.GenerateScheduledTransactions Method

public bool GenerateScheduledTransactions(
Boolean ShowProgress
);

See Also

Batch Class | Aptify.Applications.Accounting Namespace


Batch.GenerateSummaryGLEntries Method

public bool GenerateSummaryGLEntries(
Boolean bShowProgress
);

See Also

Batch Class | Aptify.Applications.Accounting Namespace


Batch.GetBatchSQL Method

public string GetBatchSQL();

See Also

Batch Class | Aptify.Applications.Accounting Namespace


Batch.GetExcludedSQL Method

public string GetExcludedSQL();

See Also

Batch Class | Aptify.Applications.Accounting Namespace


Batch.MinNot Method

public int MinNot(
Int32 iNot,
Int32 iOne,
Int32 iTwo
);

See Also

Batch Class | Aptify.Applications.Accounting Namespace


Batch.ProcessComponentConfig Method

public void ProcessComponentConfig(
AptifyApplication ApplicationObject
);

Implements

IProcessComponent.

See Also

Batch Class | Aptify.Applications.Accounting Namespace


Batch.Run Method

Component assumes these input properties: View ID - optional View SQL - optional Batch Type - Orders, Payments or Scheduled Transactions Batch Name - Optional - if not provided a generated name will be placed Effective Date - Optional - if not provided, current date will be used CurrencyTypeID - Required - FunctionalCurrencyTypeID - Required - Output Properties - Batch ID Result Codes - SUCCESS, FAILED

public virtual string Run();

Return Value

Implements

IProcessComponent.

Remarks

See Also

Batch Class | Aptify.Applications.Accounting Namespace


Batch.UpdateOrderInventory Method

public bool UpdateOrderInventory();

See Also

Batch Class | Aptify.Applications.Accounting Namespace


Batch.UpdateRecordBatchID Method

public bool UpdateRecordBatchID(
Int64 BatchID,
Boolean ShowProgress
);

See Also

Batch Class | Aptify.Applications.Accounting Namespace


Validate Method

Aptify 5.0 Software Development Kit (SDK)

Batch.Validate Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Validate();

public override bool Validate(ref String&);

See Also

Batch Class | Aptify.Applications.Accounting Namespace


Batch.Validate Method (String&)

public override bool Validate(
ref String& ErrorString
);

See Also

Batch Class | Aptify.Applications.Accounting Namespace | Batch.Validate Overload List


Batch Events

The events of the Batch class are listed below. For a complete list of Batch class members, see the Batch Members topic.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
GenerateGLEntryStatus |
GenerateGLSummary |
GenerateSchedTransStatus |
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

See Also

Batch Class | Aptify.Applications.Accounting Namespace


Batch.Batch.GenerateGLEntryStatusEventHandler Event

public event Batch.GenerateGLEntryStatusEventHandler GenerateGLEntryStatus;

See Also

Batch Class | Aptify.Applications.Accounting Namespace


Batch.Batch.GenerateGLSummaryEventHandler Event

public event Batch.GenerateGLSummaryEventHandler GenerateGLSummary;

See Also

Batch Class | Aptify.Applications.Accounting Namespace


Batch.Batch.GenerateSchedTransStatusEventHandler Event

public event Batch.GenerateSchedTransStatusEventHandler GenerateSchedTransStatus;

See Also

Batch Class | Aptify.Applications.Accounting Namespace


Batch.BetterInStrType Enumeration

public enum Batch.BetterInStrType

Members

Member Name | Description
Right |
Left |
Both |

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: BatchObject (in BatchObject.dll)

See Also

Aptify.Applications.Accounting Namespace


Batch.GenerateGLEntryStatusEventHandler Delegate

public delegate void Batch.GenerateGLEntryStatusEventHandler(
Int64 CurrentRecord,
Int64 TotalRecords
);

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: BatchObject (in BatchObject.dll)

See Also

Aptify.Applications.Accounting Namespace


Batch.GenerateGLSummaryEventHandler Delegate

public delegate void Batch.GenerateGLSummaryEventHandler(
Int64 CurrentRecord,
Int64 TotalRecords
);

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: BatchObject (in BatchObject.dll)

See Also

Aptify.Applications.Accounting Namespace


Batch.GenerateSchedTransStatusEventHandler Delegate

public delegate void Batch.GenerateSchedTransStatusEventHandler(
Int64 CurrentPosition,
Int64 OverallPosition,
Int64 CurrentRecord,
Int64 TotalRecords
);

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: BatchObject (in BatchObject.dll)

See Also

Aptify.Applications.Accounting Namespace


BatchGLDetailForm Class

For a list of all members of this type, see BatchGLDetailForm Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
BatchGLDetailForm

public class BatchGLDetailForm : Form

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: BatchWizard (in BatchWizard.dll)

See Also

BatchGLDetailForm Members | Aptify.Applications.Accounting Namespace


BatchGLDetailForm Members

BatchGLDetailForm overview

Public Instance Constructors

BatchGLDetailForm Constructor Initializes a new instance of the BatchGLDetailForm class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UserCredential |
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

BatchGLDetailForm Class | Aptify.Applications.Accounting Namespace


BatchGLDetailForm Constructor

Initializes a new instance of the BatchGLDetailForm class.

public BatchGLDetailForm();

See Also

BatchGLDetailForm Class | Aptify.Applications.Accounting Namespace


BatchGLDetailForm Properties

The properties of the BatchGLDetailForm class are listed below. For a complete list of BatchGLDetailForm class members, see the BatchGLDetailForm Members topic.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UserCredential |
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

BatchGLDetailForm Class | Aptify.Applications.Accounting Namespace


UserCredential Property

Aptify 5.0 Software Development Kit (SDK)

BatchGLDetailForm.UserCredential Property

public UserCredentials UserCredential {get; set;}

See Also

BatchGLDetailForm Class | Aptify.Applications.Accounting Namespace


BatchGLDetailForm Methods

The methods of the BatchGLDetailForm class are listed below. For a complete list of BatchGLDetailForm class members, see the BatchGLDetailForm Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

BatchGLDetailForm Class | Aptify.Applications.Accounting Namespace


BatchGLDetailForm.ApplySkin Method

protected virtual void ApplySkin();

See Also

BatchGLDetailForm Class | Aptify.Applications.Accounting Namespace


BatchGLDetailForm.Config Method

public bool Config(
AptifyGenericEntityBase oBatchGE,
String sCurrencyFormat
);

See Also

BatchGLDetailForm Class | Aptify.Applications.Accounting Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

BatchGLDetailForm.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

BatchGLDetailForm Class | Aptify.Applications.Accounting Namespace


BatchGLDetailForm.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

BatchGLDetailForm Class | Aptify.Applications.Accounting Namespace | BatchGLDetailForm.Dispose Overload List


BatchRecordsForm Class

For a list of all members of this type, see BatchRecordsForm Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
BatchRecordsForm

public class BatchRecordsForm : Form

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: BatchWizard (in BatchWizard.dll)

See Also

BatchRecordsForm Members | Aptify.Applications.Accounting Namespace


BatchRecordsForm Members

BatchRecordsForm overview

Public Instance Constructors

BatchRecordsForm Constructor Initializes a new instance of the BatchRecordsForm class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

BatchRecordsForm Class | Aptify.Applications.Accounting Namespace


BatchRecordsForm Constructor

Initializes a new instance of the BatchRecordsForm class.

public BatchRecordsForm();

See Also

BatchRecordsForm Class | Aptify.Applications.Accounting Namespace


BatchRecordsForm Methods

The methods of the BatchRecordsForm class are listed below. For a complete list of BatchRecordsForm class members, see the BatchRecordsForm Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

BatchRecordsForm Class | Aptify.Applications.Accounting Namespace


BatchRecordsForm.ApplySkin Method

protected virtual void ApplySkin();

See Also

BatchRecordsForm Class | Aptify.Applications.Accounting Namespace


BatchRecordsForm.Config Method

public bool Config(
DataTable dtBatchRecords,
DataTable dtExcludedRecords,
Int64 lEntityID,
AptifyApplication oApp
);

See Also

BatchRecordsForm Class | Aptify.Applications.Accounting Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

BatchRecordsForm.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

BatchRecordsForm Class | Aptify.Applications.Accounting Namespace


BatchRecordsForm.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

BatchRecordsForm Class | Aptify.Applications.Accounting Namespace | BatchRecordsForm.Dispose Overload List


BatchResultsForm Class

For a list of all members of this type, see BatchResultsForm Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
BatchResultsForm

public class BatchResultsForm : Form

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: BatchWizard (in BatchWizard.dll)

See Also

BatchResultsForm Members | Aptify.Applications.Accounting Namespace


BatchResultsForm Members

BatchResultsForm overview

Public Instance Constructors

BatchResultsForm Constructor Initializes a new instance of the BatchResultsForm class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

BatchResultsForm Class | Aptify.Applications.Accounting Namespace


BatchResultsForm Constructor

Initializes a new instance of the BatchResultsForm class.

public BatchResultsForm();

See Also

BatchResultsForm Class | Aptify.Applications.Accounting Namespace


BatchResultsForm Methods

The methods of the BatchResultsForm class are listed below. For a complete list of BatchResultsForm class members, see the BatchResultsForm Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

BatchResultsForm Class | Aptify.Applications.Accounting Namespace


BatchResultsForm.ApplySkin Method

protected virtual void ApplySkin();

See Also

BatchResultsForm Class | Aptify.Applications.Accounting Namespace


BatchResultsForm.Config Method

public bool Config(
Int64[] arBatchIDs,
String[] arBatchNames,
AptifyApplication oApp
);

See Also

BatchResultsForm Class | Aptify.Applications.Accounting Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

BatchResultsForm.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

BatchResultsForm Class | Aptify.Applications.Accounting Namespace


BatchResultsForm.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

BatchResultsForm Class | Aptify.Applications.Accounting Namespace | BatchResultsForm.Dispose Overload List


BatchViewerForm Class

For a list of all members of this type, see BatchViewerForm Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
BatchViewerForm

public class BatchViewerForm : Form, IAptifyTopLevelViewer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: BatchViewer (in BatchViewer.dll)

See Also

BatchViewerForm Members | Aptify.Applications.Accounting Namespace


BatchViewerForm Members

BatchViewerForm overview

Public Instance Constructors

BatchViewerForm Constructor Initializes a new instance of the BatchViewerForm class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BatchValidate |
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config | Overloaded.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PermissionCheck |
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
SetupControls |
Show | Overloaded.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
ShowDialog | Overloaded.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog with the specified owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

BatchViewerForm Class | Aptify.Applications.Accounting Namespace


BatchViewerForm Constructor

Initializes a new instance of the BatchViewerForm class.

public BatchViewerForm();

See Also

BatchViewerForm Class | Aptify.Applications.Accounting Namespace


BatchViewerForm Methods

The methods of the BatchViewerForm class are listed below. For a complete list of BatchViewerForm class members, see the BatchViewerForm Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BatchValidate |
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config | Overloaded.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PermissionCheck |
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
SetupControls |
Show | Overloaded.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
ShowDialog | Overloaded.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog with the specified owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

BatchViewerForm Class | Aptify.Applications.Accounting Namespace


BatchViewerForm.ApplySkin Method

protected virtual void ApplySkin();

See Also

BatchViewerForm Class | Aptify.Applications.Accounting Namespace


BatchViewerForm.BatchValidate Method

public string BatchValidate(
Boolean bShowErrors
);

See Also

BatchViewerForm Class | Aptify.Applications.Accounting Namespace


Config Method

Aptify 5.0 Software Development Kit (SDK)

BatchViewerForm.Config Method

Overload List

public void Config(AptifyGenericEntityBase);

public void Config(UserCredentials,String);

public void Config(UserCredentials,String,Int64);

public void Config(UserCredentials,String,String);

See Also

BatchViewerForm Class | Aptify.Applications.Accounting Namespace


BatchViewerForm.Config Method (AptifyGenericEntityBase)

public void Config(
AptifyGenericEntityBase GE
);

Implements

IAptifyTopLevelViewer.

See Also

BatchViewerForm Class | Aptify.Applications.Accounting Namespace | BatchViewerForm.Config Overload List


BatchViewerForm.Config Method (UserCredentials, String)

public void Config(
UserCredentials UserCredentials,
String CmdString
);

Implements

IAptifyTopLevelViewer.

See Also

BatchViewerForm Class | Aptify.Applications.Accounting Namespace | BatchViewerForm.Config Overload List


BatchViewerForm.Config Method (UserCredentials, String, Int64)

public void Config(
UserCredentials UserCredentials,
String EntityName,
Int64 RecordID
);

Implements

IAptifyTopLevelViewer.

See Also

BatchViewerForm Class | Aptify.Applications.Accounting Namespace | BatchViewerForm.Config Overload List


BatchViewerForm.Config Method (UserCredentials, String, String)

public void Config(
UserCredentials UserCredentials,
String EntityName,
String NewRecordParameters
);

Implements

IAptifyTopLevelViewer.

See Also

BatchViewerForm Class | Aptify.Applications.Accounting Namespace | BatchViewerForm.Config Overload List


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

BatchViewerForm.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

BatchViewerForm Class | Aptify.Applications.Accounting Namespace


BatchViewerForm.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

BatchViewerForm Class | Aptify.Applications.Accounting Namespace | BatchViewerForm.Dispose Overload List


BatchViewerForm.PermissionCheck Method

public bool PermissionCheck();

See Also

BatchViewerForm Class | Aptify.Applications.Accounting Namespace


BatchViewerForm.SetupControls Method

public void SetupControls();

See Also

BatchViewerForm Class | Aptify.Applications.Accounting Namespace


Show Method

Aptify 5.0 Software Development Kit (SDK)

BatchViewerForm.Show Method

Overload List

new public void Show();

public void Show(Form);

Inherited from Form.

public void Show(IWin32Window);

See Also

BatchViewerForm Class | Aptify.Applications.Accounting Namespace


BatchViewerForm.Show Method ()

new public void Show();

Implements

IAptifyTopLevelViewer.

See Also

BatchViewerForm Class | Aptify.Applications.Accounting Namespace | BatchViewerForm.Show Overload List


BatchViewerForm.Show Method (Form)

public void Show(
Form ParentForm
);

Implements

IAptifyTopLevelViewer.

See Also

BatchViewerForm Class | Aptify.Applications.Accounting Namespace | BatchViewerForm.Show Overload List


ShowDialog Method

Aptify 5.0 Software Development Kit (SDK)

BatchViewerForm.ShowDialog Method

Overload List

new public DialogResult ShowDialog();

public DialogResult ShowDialog(Form);

Inherited from Form.

public DialogResult ShowDialog(IWin32Window);

See Also

BatchViewerForm Class | Aptify.Applications.Accounting Namespace


BatchViewerForm.ShowDialog Method ()

new public DialogResult ShowDialog();

Implements

IAptifyTopLevelViewer.

See Also

BatchViewerForm Class | Aptify.Applications.Accounting Namespace | BatchViewerForm.ShowDialog Overload List


BatchViewerForm.ShowDialog Method (Form)

public DialogResult ShowDialog(
Form ParentForm
);

Implements

IAptifyTopLevelViewer.

See Also

BatchViewerForm Class | Aptify.Applications.Accounting Namespace | BatchViewerForm.ShowDialog Overload List


BatchWizard Class

For a list of all members of this type, see BatchWizard Members.

System.Object
BatchWizard

public class BatchWizard : IAptifyAction

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: BatchWizard (in BatchWizard.dll)

See Also

BatchWizard Members | Aptify.Applications.Accounting Namespace


BatchWizard Members

BatchWizard overview

Public Instance Constructors

BatchWizard Constructor Initializes a new instance of the BatchWizard class.

Public Instance Methods

DoAction | Overloaded.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BatchWizard Class | Aptify.Applications.Accounting Namespace


BatchWizard Constructor

Initializes a new instance of the BatchWizard class.

public BatchWizard();

See Also

BatchWizard Class | Aptify.Applications.Accounting Namespace


BatchWizard Methods

The methods of the BatchWizard class are listed below. For a complete list of BatchWizard class members, see the BatchWizard Members topic.

Public Instance Methods

DoAction | Overloaded.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BatchWizard Class | Aptify.Applications.Accounting Namespace


DoAction Method

Aptify 5.0 Software Development Kit (SDK)

BatchWizard.DoAction Method

Overload List

public void DoAction(AptifyApplication,Int64);

public void DoAction(AptifyApplication,Int64,Int64);

public void DoAction(AptifyApplication,Int64,Int64,params Object[]);

public void DoAction(AptifyApplication,Int64,params String[]);

See Also

BatchWizard Class | Aptify.Applications.Accounting Namespace


BatchWizard.DoAction Method (AptifyApplication, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID
);

Implements

IAptifyAction.

See Also

BatchWizard Class | Aptify.Applications.Accounting Namespace | BatchWizard.DoAction Overload List


BatchWizard.DoAction Method (AptifyApplication, Int64, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID
);

Implements

IAptifyAction.

See Also

BatchWizard Class | Aptify.Applications.Accounting Namespace | BatchWizard.DoAction Overload List


BatchWizard.DoAction Method (AptifyApplication, Int64, Int64, Object[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID,
params Object[] SelectedItems
);

Implements

IAptifyAction.

See Also

BatchWizard Class | Aptify.Applications.Accounting Namespace | BatchWizard.DoAction Overload List


BatchWizard.DoAction Method (AptifyApplication, Int64, String[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
params String[] SelectedItems
);

Implements

IAptifyAction.

See Also

BatchWizard Class | Aptify.Applications.Accounting Namespace | BatchWizard.DoAction Overload List


BatchWizardForm Class

For a list of all members of this type, see BatchWizardForm Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
BatchWizardForm

public class BatchWizardForm : Form

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: BatchWizard (in BatchWizard.dll)

See Also

BatchWizardForm Members | Aptify.Applications.Accounting Namespace


BatchWizardForm Members

BatchWizardForm overview

Public Instance Constructors

BatchWizardForm Constructor Initializes a new instance of the BatchWizardForm class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BetterInStr |
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
MinNot |
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

BatchWizardForm Class | Aptify.Applications.Accounting Namespace


BatchWizardForm Constructor

Initializes a new instance of the BatchWizardForm class.

public BatchWizardForm();

See Also

BatchWizardForm Class | Aptify.Applications.Accounting Namespace


BatchWizardForm Methods

The methods of the BatchWizardForm class are listed below. For a complete list of BatchWizardForm class members, see the BatchWizardForm Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BetterInStr |
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
MinNot |
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

BatchWizardForm Class | Aptify.Applications.Accounting Namespace


BatchWizardForm.ApplySkin Method

protected virtual void ApplySkin();

See Also

BatchWizardForm Class | Aptify.Applications.Accounting Namespace


BatchWizardForm.BetterInStr Method

public virtual int BetterInStr(
String sStr,
String sTerm,
BatchWizardForm.BetterInStrType iType
);

See Also

BatchWizardForm Class | Aptify.Applications.Accounting Namespace


BatchWizardForm.Config Method

public bool Config(
AptifyApplication ApplicationObject,
Int64 lEntityID,
Int64 lViewID
);

See Also

BatchWizardForm Class | Aptify.Applications.Accounting Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

BatchWizardForm.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

BatchWizardForm Class | Aptify.Applications.Accounting Namespace


BatchWizardForm.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

BatchWizardForm Class | Aptify.Applications.Accounting Namespace | BatchWizardForm.Dispose Overload List


BatchWizardForm.MinNot Method

public virtual int MinNot(
Int32 iNot,
Int32 iOne,
Int32 iTwo
);

See Also

BatchWizardForm Class | Aptify.Applications.Accounting Namespace


BatchWizardForm.BetterInStrType Enumeration

public enum BatchWizardForm.BetterInStrType

Members

Member Name | Description
RightOnly |
LeftOnly |
Both |

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: BatchWizard (in BatchWizard.dll)

See Also

Aptify.Applications.Accounting Namespace


CashControlBatch Class

Contains the GUI used by the Cash Control Batches Entity.

For a list of all members of this type, see CashControlBatch Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
CashControlBatch

public class CashControlBatch : FormComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: AptifyCashControlBatchesGUI (in AptifyCashControlBatchesGUI.dll)

See Also

CashControlBatch Members | Aptify.Applications.Accounting Namespace


CashControlBatch Members

CashControlBatch overview

Public Instance Constructors

CashControlBatch Constructor Initializes a new instance of the CashControlBatch class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormComponent) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

m_bCancelProcess
m_geCCB
m_oObjectRepository

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateContext (inherited from FormComponent) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
PaymentsPostedView |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AddBatchDetail | Contains the logic that is executed when btnAddDetail is clicked."
AdjustFormScrollbars (inherited from ContainerControl) |
AfterEdit | Contains logic that is executed after a grid cell is modified.
ApplySkin |
ApproveCashControlBatch | Contains the logic that is executed when btnApprove is clicked."
BeforeEdit | Contains logic that is executed before a grid cell is modified.
BeforeNewCashCtrlBatchDetail | Gets called when a user attempts to add a New Cash Control Batch Detail to the Sub-Type.
ClearAndConfigureLockBoxGrid | Clears and Configures the LockBox grid with rows and columns.
ConfigurePaymentsPostedELV |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
DoLockBoxMatch | Contains the logic that is executed when btnMatch is clicked."
DoLockBoxPost |
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetCurrentEmployeeID | Gets the current employee that is associated with the user that is logged in to the system.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
LoadLockBox | Overloaded. Loads the LockBox grid
LockBoxMatchFinished | This is called when the mathching process is finished.
LockBoxPostFinished | This is called when the mathching process is finished.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig | configures the form component.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormComponent) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh | Refreshes the control and the data on it.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormComponent) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetupControl |
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
ShowDetailForm | Overloaded. Contains the logic used when a CashControlBatchDetail should be shown.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
StatusUpdateHandler | Gets called during status updates.
TotalsMatch | Calculates the Payment Total and the Cash Total and then returns true if they are the same.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateCashTotal | Updates the txtCALC_CashTotal based on the total amount of the CashCtrlBatchDetail SUB_TYPE
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdatePayTotal | Updates the Payment Total Text box.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CashControlBatch Class | Aptify.Applications.Accounting Namespace


CashControlBatch Constructor

Initializes a new instance of the CashControlBatch class.

public CashControlBatch();

See Also

CashControlBatch Class | Aptify.Applications.Accounting Namespace


CashControlBatch Fields

The fields of the CashControlBatch class are listed below. For a complete list of CashControlBatch class members, see the CashControlBatch Members topic.

Protected Instance Fields

m_bCancelProcess
m_geCCB
m_oObjectRepository

See Also

CashControlBatch Class | Aptify.Applications.Accounting Namespace


CashControlBatch.m_bCancelProcess Field

protected m_bCancelProcess m_bCancelProcess;

See Also

CashControlBatch Class | Aptify.Applications.Accounting Namespace


CashControlBatch.m_geCCB Field

protected m_geCCB m_geCCB;

See Also

CashControlBatch Class | Aptify.Applications.Accounting Namespace


CashControlBatch.m_oObjectRepository Field

protected m_oObjectRepository m_oObjectRepository;

See Also

CashControlBatch Class | Aptify.Applications.Accounting Namespace


CashControlBatch Properties

The properties of the CashControlBatch class are listed below. For a complete list of CashControlBatch class members, see the CashControlBatch Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateContext (inherited from FormComponent) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
PaymentsPostedView |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

CashControlBatch Class | Aptify.Applications.Accounting Namespace


PaymentsPostedView Property

Aptify 5.0 Software Development Kit (SDK)

CashControlBatch.PaymentsPostedView Property

protected virtual EntityListView PaymentsPostedView {get; set;}

See Also

CashControlBatch Class | Aptify.Applications.Accounting Namespace


CashControlBatch Methods

The methods of the CashControlBatch class are listed below. For a complete list of CashControlBatch class members, see the CashControlBatch Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormComponent) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AddBatchDetail | Contains the logic that is executed when btnAddDetail is clicked."
AdjustFormScrollbars (inherited from ContainerControl) |
AfterEdit | Contains logic that is executed after a grid cell is modified.
ApplySkin |
ApproveCashControlBatch | Contains the logic that is executed when btnApprove is clicked."
BeforeEdit | Contains logic that is executed before a grid cell is modified.
BeforeNewCashCtrlBatchDetail | Gets called when a user attempts to add a New Cash Control Batch Detail to the Sub-Type.
ClearAndConfigureLockBoxGrid | Clears and Configures the LockBox grid with rows and columns.
ConfigurePaymentsPostedELV |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
DoLockBoxMatch | Contains the logic that is executed when btnMatch is clicked."
DoLockBoxPost |
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetCurrentEmployeeID | Gets the current employee that is associated with the user that is logged in to the system.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
LoadLockBox | Overloaded. Loads the LockBox grid
LockBoxMatchFinished | This is called when the mathching process is finished.
LockBoxPostFinished | This is called when the mathching process is finished.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig | configures the form component.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormComponent) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh | Refreshes the control and the data on it.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormComponent) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetupControl |
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
ShowDetailForm | Overloaded. Contains the logic used when a CashControlBatchDetail should be shown.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
StatusUpdateHandler | Gets called during status updates.
TotalsMatch | Calculates the Payment Total and the Cash Total and then returns true if they are the same.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateCashTotal | Updates the txtCALC_CashTotal based on the total amount of the CashCtrlBatchDetail SUB_TYPE
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdatePayTotal | Updates the Payment Total Text box.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CashControlBatch Class | Aptify.Applications.Accounting Namespace


CashControlBatch.AddBatchDetail Method

Contains the logic that is executed when btnAddDetail is clicked."

protected void AddBatchDetail();

Remarks

It is called when the Add button is clicked.

See Also

CashControlBatch Class | Aptify.Applications.Accounting Namespace


CashControlBatch.AfterEdit Method

Contains logic that is executed after a grid cell is modified.

protected void AfterEdit(
RowColEventArgs e
);

Parameters

e

Remarks

See Also

CashControlBatch Class | Aptify.Applications.Accounting Namespace


CashControlBatch.ApplySkin Method

protected virtual void ApplySkin();

See Also

CashControlBatch Class | Aptify.Applications.Accounting Namespace


CashControlBatch.ApproveCashControlBatch Method

Contains the logic that is executed when btnApprove is clicked."

protected void ApproveCashControlBatch();

Remarks

See Also

CashControlBatch Class | Aptify.Applications.Accounting Namespace


CashControlBatch.BeforeEdit Method

Contains logic that is executed before a grid cell is modified.

protected void BeforeEdit(
RowColEventArgs e
);

Parameters

e

Remarks

See Also

CashControlBatch Class | Aptify.Applications.Accounting Namespace


CashControlBatch.BeforeNewCashCtrlBatchDetail Method

Gets called when a user attempts to add a New Cash Control Batch Detail to the Sub-Type.

protected void BeforeNewCashCtrlBatchDetail(
ref Boolean& Cancel
);

Parameters

Cancel

Remarks

See Also

CashControlBatch Class | Aptify.Applications.Accounting Namespace


CashControlBatch.ClearAndConfigureLockBoxGrid Method

Clears and Configures the LockBox grid with rows and columns.

protected void ClearAndConfigureLockBoxGrid();

Remarks

Called from LoadLockBox. Clears Row Data if it exists.

See Also

CashControlBatch Class | Aptify.Applications.Accounting Namespace


CashControlBatch.ConfigurePaymentsPostedELV Method

protected void ConfigurePaymentsPostedELV();

See Also

CashControlBatch Class | Aptify.Applications.Accounting Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

CashControlBatch.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

CashControlBatch Class | Aptify.Applications.Accounting Namespace


CashControlBatch.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

CashControlBatch Class | Aptify.Applications.Accounting Namespace | CashControlBatch.Dispose Overload List


CashControlBatch.DoLockBoxMatch Method

Contains the logic that is executed when btnMatch is clicked."

protected void DoLockBoxMatch();

Remarks

See Also

CashControlBatch Class | Aptify.Applications.Accounting Namespace


CashControlBatch.DoLockBoxPost Method

protected void DoLockBoxPost();

See Also

CashControlBatch Class | Aptify.Applications.Accounting Namespace


CashControlBatch.GetCurrentEmployeeID Method

Gets the current employee that is associated with the user that is logged in to the system.

protected long GetCurrentEmployeeID();

Return Value

Remarks

See Also

CashControlBatch Class | Aptify.Applications.Accounting Namespace


LoadLockBox Method

Aptify 5.0 Software Development Kit (SDK)

CashControlBatch.LoadLockBox Method

Loads the LockBox grid

Overload List

Loads the LockBox grid

protected void LoadLockBox();

Loads the Lock box Grid

protected void LoadLockBox(String);

See Also

CashControlBatch Class | Aptify.Applications.Accounting Namespace


CashControlBatch.LoadLockBox Method ()

Loads the LockBox grid

protected void LoadLockBox();

Remarks

See Also

CashControlBatch Class | Aptify.Applications.Accounting Namespace | CashControlBatch.LoadLockBox Overload List


CashControlBatch.LoadLockBox Method (String)

Loads the Lock box Grid

protected void LoadLockBox(
String MatchType
);

Parameters

MatchType

Remarks

See Also

CashControlBatch Class | Aptify.Applications.Accounting Namespace | CashControlBatch.LoadLockBox Overload List


CashControlBatch.LockBoxMatchFinished Method

This is called when the mathching process is finished.

protected void LockBoxMatchFinished(
Boolean Finished
);

Remarks

This method will be thread safe.

See Also

CashControlBatch Class | Aptify.Applications.Accounting Namespace


CashControlBatch.LockBoxPostFinished Method

This is called when the mathching process is finished.

protected void LockBoxPostFinished(
Boolean Finished
);

Remarks

This method will be thread safe.

See Also

CashControlBatch Class | Aptify.Applications.Accounting Namespace


CashControlBatch.OnFormComponentConfig Method

configures the form component.

protected override void OnFormComponentConfig(
AptifyFormTemplateContext FormTemplateContext
);

Parameters

FormTemplateContext

Implements

IFormComponent.

Remarks

holds the logic for AfterNew and AfterLoad.

See Also

CashControlBatch Class | Aptify.Applications.Accounting Namespace


CashControlBatch.OnRefresh Method

Refreshes the control and the data on it.

protected override void OnRefresh();

Implements

IFormComponent.

Remarks

The will be called on the AfterSave of the data control.

See Also

CashControlBatch Class | Aptify.Applications.Accounting Namespace


CashControlBatch.SetupControl Method

protected virtual void SetupControl();

See Also

CashControlBatch Class | Aptify.Applications.Accounting Namespace


ShowDetailForm Method

Aptify 5.0 Software Development Kit (SDK)

CashControlBatch.ShowDetailForm Method

Contains the logic used when a CashControlBatchDetail should be shown.

Overload List

Contains the logic used when a CashControlBatchDetail should be shown.

protected void ShowDetailForm();

protected bool ShowDetailForm(Row,AptifyGenericEntityBase);

See Also

CashControlBatch Class | Aptify.Applications.Accounting Namespace


CashControlBatch.ShowDetailForm Method ()

Contains the logic used when a CashControlBatchDetail should be shown.

protected void ShowDetailForm();

Remarks

Called from places like Grid Double Click and Grid Key Press(Enter).

See Also

CashControlBatch Class | Aptify.Applications.Accounting Namespace | CashControlBatch.ShowDetailForm Overload List


CashControlBatch.ShowDetailForm Method (Row, AptifyGenericEntityBase)

protected bool ShowDetailForm(
Row GridRow,
AptifyGenericEntityBase DetailGE
);

See Also

CashControlBatch Class | Aptify.Applications.Accounting Namespace | CashControlBatch.ShowDetailForm Overload List


CashControlBatch.StatusUpdateHandler Method

Gets called during status updates.

protected void StatusUpdateHandler(
Int32 PercentComplete,
ref Boolean& Cancel
);

Parameters

PercentComplete
Cancel

Remarks

This method has been marshaled to be thread safe.

See Also

CashControlBatch Class | Aptify.Applications.Accounting Namespace


CashControlBatch.TotalsMatch Method

Calculates the Payment Total and the Cash Total and then returns true if they are the same.

protected bool TotalsMatch();

Return Value

Remarks

See Also

CashControlBatch Class | Aptify.Applications.Accounting Namespace


CashControlBatch.UpdateCashTotal Method

Updates the txtCALC_CashTotal based on the total amount of the CashCtrlBatchDetail SUB_TYPE

protected void UpdateCashTotal();

Remarks

See Also

CashControlBatch Class | Aptify.Applications.Accounting Namespace


CashControlBatch.UpdatePayTotal Method

Updates the Payment Total Text box.

protected void UpdatePayTotal();

Remarks

See Also

CashControlBatch Class | Aptify.Applications.Accounting Namespace


CashControlBatchDetail Class

Control used to display the contents of a Cash Control Batch Detail.

For a list of all members of this type, see CashControlBatchDetail Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
CashControlBatchDetail

public class CashControlBatchDetail : FormComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: AptifyCashControlBatchesGUI (in AptifyCashControlBatchesGUI.dll)

See Also

CashControlBatchDetail Members | Aptify.Applications.Accounting Namespace


CashControlBatchDetail Members

CashControlBatchDetail overview

Public Instance Constructors

CashControlBatchDetail Constructor Initializes a new instance of the CashControlBatchDetail class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsLockBox |
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ShowAllocationTab |
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormComponent) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateContext (inherited from FormComponent) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
ApplySkin |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateAllocationObject |
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetOrderInfo |
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
LoadAllocationGrid |
LoadProducts |
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormComponent) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormComponent) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecalcTotal |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CashControlBatchDetail Class | Aptify.Applications.Accounting Namespace


CashControlBatchDetail Constructor

Initializes a new instance of the CashControlBatchDetail class.

public CashControlBatchDetail();

See Also

CashControlBatchDetail Class | Aptify.Applications.Accounting Namespace


CashControlBatchDetail Properties

The properties of the CashControlBatchDetail class are listed below. For a complete list of CashControlBatchDetail class members, see the CashControlBatchDetail Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsLockBox |
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ShowAllocationTab |
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateContext (inherited from FormComponent) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

CashControlBatchDetail Class | Aptify.Applications.Accounting Namespace


IsLockBox Property

Aptify 5.0 Software Development Kit (SDK)

CashControlBatchDetail.IsLockBox Property

public Boolean IsLockBox {get; set;}

See Also

CashControlBatchDetail Class | Aptify.Applications.Accounting Namespace


ShowAllocationTab Property

Aptify 5.0 Software Development Kit (SDK)

CashControlBatchDetail.ShowAllocationTab Property

public Boolean ShowAllocationTab {get; set;}

See Also

CashControlBatchDetail Class | Aptify.Applications.Accounting Namespace


CashControlBatchDetail Methods

The methods of the CashControlBatchDetail class are listed below. For a complete list of CashControlBatchDetail class members, see the CashControlBatchDetail Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormComponent) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
ApplySkin |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateAllocationObject |
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetOrderInfo |
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
LoadAllocationGrid |
LoadProducts |
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormComponent) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormComponent) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecalcTotal |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CashControlBatchDetail Class | Aptify.Applications.Accounting Namespace


CashControlBatchDetail.ApplySkin Method

protected virtual void ApplySkin();

See Also

CashControlBatchDetail Class | Aptify.Applications.Accounting Namespace


CashControlBatchDetail.CreateAllocationObject Method

protected void CreateAllocationObject();

See Also

CashControlBatchDetail Class | Aptify.Applications.Accounting Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

CashControlBatchDetail.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

CashControlBatchDetail Class | Aptify.Applications.Accounting Namespace


CashControlBatchDetail.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

CashControlBatchDetail Class | Aptify.Applications.Accounting Namespace | CashControlBatchDetail.Dispose Overload List


CashControlBatchDetail.GetOrderInfo Method

protected void GetOrderInfo(
Int64 OrderID
);

See Also

CashControlBatchDetail Class | Aptify.Applications.Accounting Namespace


CashControlBatchDetail.LoadAllocationGrid Method

protected void LoadAllocationGrid();

See Also

CashControlBatchDetail Class | Aptify.Applications.Accounting Namespace


CashControlBatchDetail.LoadProducts Method

protected void LoadProducts();

See Also

CashControlBatchDetail Class | Aptify.Applications.Accounting Namespace


CashControlBatchDetail.OnFormComponentConfig Method

protected override void OnFormComponentConfig(
AptifyFormTemplateContext FormTemplateContext
);

Implements

IFormComponent.

See Also

CashControlBatchDetail Class | Aptify.Applications.Accounting Namespace


CashControlBatchDetail.OnTransferDataToObject Method

protected override void OnTransferDataToObject(
ref Boolean& Cancel
);

Implements

IFormComponent.

See Also

CashControlBatchDetail Class | Aptify.Applications.Accounting Namespace


CashControlBatchDetail.RecalcTotal Method

protected void RecalcTotal();

See Also

CashControlBatchDetail Class | Aptify.Applications.Accounting Namespace


CashControlBatchDetailForm Class

Used to display a CashControlBatchDetailForm

For a list of all members of this type, see CashControlBatchDetailForm Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
CashControlBatchDetailForm

public class CashControlBatchDetailForm : Form

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: AptifyCashControlBatchesGUI (in AptifyCashControlBatchesGUI.dll)

See Also

CashControlBatchDetailForm Members | Aptify.Applications.Accounting Namespace


CashControlBatchDetailForm Members

CashControlBatchDetailForm overview

Public Instance Constructors

CashControlBatchDetailForm Constructor Initializes a new instance of the CashControlBatchDetailForm class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CancelClose |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CashControlBatchDetailForm Class | Aptify.Applications.Accounting Namespace


CashControlBatchDetailForm Constructor

Initializes a new instance of the CashControlBatchDetailForm class.

public CashControlBatchDetailForm();

See Also

CashControlBatchDetailForm Class | Aptify.Applications.Accounting Namespace


CashControlBatchDetailForm Methods

The methods of the CashControlBatchDetailForm class are listed below. For a complete list of CashControlBatchDetailForm class members, see the CashControlBatchDetailForm Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CancelClose |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CashControlBatchDetailForm Class | Aptify.Applications.Accounting Namespace


CashControlBatchDetailForm.CancelClose Method

protected bool CancelClose(
CloseReason ClosingReason
);

See Also

CashControlBatchDetailForm Class | Aptify.Applications.Accounting Namespace


CashControlBatchDetailForm.Config Method

public void Config(
AptifyGenericEntityBase CashControlBatchDetail,
Boolean IsLockBox
);

See Also

CashControlBatchDetailForm Class | Aptify.Applications.Accounting Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

CashControlBatchDetailForm.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

CashControlBatchDetailForm Class | Aptify.Applications.Accounting Namespace


CashControlBatchDetailForm.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

CashControlBatchDetailForm Class | Aptify.Applications.Accounting Namespace | CashControlBatchDetailForm.Dispose Overload List


CashControlBatchGUIException Class

Thrown when Cash Control Batch specific exceptions occur in a GUI element.

For a list of all members of this type, see CashControlBatchGUIException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
CashControlBatchGUIException

public class CashControlBatchGUIException : BaseApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: AptifyCashControlBatchesGUI (in AptifyCashControlBatchesGUI.dll)

See Also

CashControlBatchGUIException Members | Aptify.Applications.Accounting Namespace


CashControlBatchGUIException Members

CashControlBatchGUIException overview

Public Instance Constructors

CashControlBatchGUIException Overloaded. Initializes a new instance of the CashControlBatchGUIException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from BaseApplicationException) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CashControlBatchGUIException Class | Aptify.Applications.Accounting Namespace


CashControlBatchGUIException Constructor

Initializes a new instance of the CashControlBatchGUIException class.

Overload List

Initializes a new instance of the CashControlBatchGUIException class.

public CashControlBatchGUIException();

public CashControlBatchGUIException(String);

public CashControlBatchGUIException(String,Exception);

See Also

CashControlBatchGUIException Class | Aptify.Applications.Accounting Namespace


CashControlBatchGUIException Constructor ()

Initializes a new instance of the CashControlBatchGUIException class.

public CashControlBatchGUIException();

See Also

CashControlBatchGUIException Class | Aptify.Applications.Accounting Namespace | CashControlBatchGUIException Constructor Overload List


CashControlBatchGUIException Constructor (String)

public CashControlBatchGUIException(
String Message
);

See Also

CashControlBatchGUIException Class | Aptify.Applications.Accounting Namespace | CashControlBatchGUIException Constructor Overload List


CashControlBatchGUIException Constructor (String, Exception)

public CashControlBatchGUIException(
String Message,
Exception InnerException
);

See Also

CashControlBatchGUIException Class | Aptify.Applications.Accounting Namespace | CashControlBatchGUIException Constructor Overload List


DemoLockBoxImport Class

This is a demonstration of a bank file import for the Aptify Lock Box Import Wizard The purpose of this class is to provide an example of how to plug in file formats that can accomodate various types of import options The demo file format has a first line comment, a second line that contains header information, and third lines and beyond contain payment line items. First Line: Comment - Ignore it Second Line: DepositDate,BankBatch,Total,PaymentType Third+ Lines: OrderID, Customer Name, PaymentAmount, Check Number

For a list of all members of this type, see DemoLockBoxImport Members.

System.Object
LockBoxBase
LockBoxImportBase
LockBoxTextFileImport
DemoLockBoxImport

public class DemoLockBoxImport : LockBoxTextFileImport

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: DemoLockBoxImport (in DemoLockBoxImport.dll)

See Also

DemoLockBoxImport Members | Aptify.Applications.Accounting Namespace


DemoLockBoxImport Members

DemoLockBoxImport overview

Public Instance Constructors

DemoLockBoxImport Constructor Initializes a new instance of the DemoLockBoxImport class.

Public Instance Properties

Application (inherited from LockBoxBase) | Aptify Application Instance (only available after Config() is called)
DataAction (inherited from LockBoxBase) | Aptify Data Action Instance (only available after Config() is called)
Database (inherited from LockBoxBase) | Base Database for Lock Box Application Entities (derived from Base Database of Cash Control Batches entity) (only available after Config() is called)
EOF (inherited from LockBoxImportBase) | '01/04/08 Tamasa, Added for issue 5500.This will is the EOF file is reached or not.
Properties (inherited from LockBoxImportBase) |

Public Instance Methods

Config (inherited from LockBoxImportBase) |
Dispose (inherited from LockBoxTextFileImport) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetSQLIntegerValue (inherited from LockBoxBase) | This is a utility method that returns the value of any SQL statement scalar value and casts it to a Integer type
GetSQLStringValue (inherited from LockBoxBase) | This is a utility method that returns the value of any SQL statement scalar value and casts it to a String type
GetSQLValue (inherited from LockBoxBase) | This is a utility method that returns the value of any SQL statement scalar value as a default Object type
GetStatusOfFile (inherited from LockBoxImportBase) |
GetType (inherited from Object) | Gets the Type of the current instance.
ProcessFile (inherited from LockBoxImportBase) | Overloaded. Processes a Lock box file.
Run (inherited from LockBoxImportBase) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

StatusUpdate (inherited from LockBoxImportBase)

Protected Instance Properties

BytesRead (inherited from LockBoxTextFileImport) | Returns the number of bytes read so far
FileSize (inherited from LockBoxTextFileImport) | Returns the size of the current file in bytes
PercentRead (inherited from LockBoxTextFileImport) | Returns the percentage of the file read so far dividing Bytes Read by File Size and multiplying by 100 (Range from 0 to 100)
ReadCount (inherited from LockBoxTextFileImport) | 01/04/08 Tamasa, Added for issue 5500. This will return the count of line read from file.
StreamReader (inherited from LockBoxTextFileImport) | Returns the stream being operated on

Protected Instance Methods

CloseFile (inherited from LockBoxTextFileImport) |
Finalize (inherited from LockBoxTextFileImport) |
GetCurrentEmployeeID (inherited from LockBoxBase) | Returns the ID value from the Employees entity that matches the Current logged in user based on the provided User credentials (Uses Entity Record Relations via the spGetCurrentEmployeeID)
GetSingleFileLine (inherited from LockBoxTextFileImport) |
ImportDetails | This routine provides an example of an ImportDetails() routine
ImportHeader | This function provides an example of an ImportHeader()
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnStatusUpdate (inherited from LockBoxImportBase) |
OpenFile (inherited from LockBoxTextFileImport) |
SetupCashBatchGE (inherited from LockBoxTextFileImport) | This method setups the Cash Batch GE object with various field values that are required. This method is not called by the LockBoxTextFileImport class itself, it is intended to be called from sub-classes while their ImportHeader() routine is being executed

See Also

DemoLockBoxImport Class | Aptify.Applications.Accounting Namespace


DemoLockBoxImport Constructor

Initializes a new instance of the DemoLockBoxImport class.

public DemoLockBoxImport();

See Also

DemoLockBoxImport Class | Aptify.Applications.Accounting Namespace


DemoLockBoxImport Methods

The methods of the DemoLockBoxImport class are listed below. For a complete list of DemoLockBoxImport class members, see the DemoLockBoxImport Members topic.

Public Instance Methods

Config (inherited from LockBoxImportBase) |
Dispose (inherited from LockBoxTextFileImport) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetSQLIntegerValue (inherited from LockBoxBase) | This is a utility method that returns the value of any SQL statement scalar value and casts it to a Integer type
GetSQLStringValue (inherited from LockBoxBase) | This is a utility method that returns the value of any SQL statement scalar value and casts it to a String type
GetSQLValue (inherited from LockBoxBase) | This is a utility method that returns the value of any SQL statement scalar value as a default Object type
GetStatusOfFile (inherited from LockBoxImportBase) |
GetType (inherited from Object) | Gets the Type of the current instance.
ProcessFile (inherited from LockBoxImportBase) | Overloaded. Processes a Lock box file.
Run (inherited from LockBoxImportBase) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CloseFile (inherited from LockBoxTextFileImport) |
Finalize (inherited from LockBoxTextFileImport) |
GetCurrentEmployeeID (inherited from LockBoxBase) | Returns the ID value from the Employees entity that matches the Current logged in user based on the provided User credentials (Uses Entity Record Relations via the spGetCurrentEmployeeID)
GetSingleFileLine (inherited from LockBoxTextFileImport) |
ImportDetails | This routine provides an example of an ImportDetails() routine
ImportHeader | This function provides an example of an ImportHeader()
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnStatusUpdate (inherited from LockBoxImportBase) |
OpenFile (inherited from LockBoxTextFileImport) |
SetupCashBatchGE (inherited from LockBoxTextFileImport) | This method setups the Cash Batch GE object with various field values that are required. This method is not called by the LockBoxTextFileImport class itself, it is intended to be called from sub-classes while their ImportHeader() routine is being executed

See Also

DemoLockBoxImport Class | Aptify.Applications.Accounting Namespace


DemoLockBoxImport.ImportDetails Method

This routine provides an example of an ImportDetails() routine

protected override AptifyGenericEntityBase ImportDetails(
AptifyGenericEntityBase CashBatchGE,
Decimal TotalAmount
);

Parameters

CashBatchGE
TotalAmount

Return Value

Remarks

See Also

DemoLockBoxImport Class | Aptify.Applications.Accounting Namespace


DemoLockBoxImport.ImportHeader Method

This function provides an example of an ImportHeader()

protected override void ImportHeader(
ref AptifyGenericEntityBase& CashBatchGE,
ref Decimal& TotalAmount,
Int64 PaymentTypeID
);

Parameters

CashBatchGE
TotalAmount
PaymentTypeID

Remarks

See Also

DemoLockBoxImport Class | Aptify.Applications.Accounting Namespace


DemoLockBoxImportException Class

Thrown where there is a problem during the Demo Lock Box Import.

For a list of all members of this type, see DemoLockBoxImportException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
DemoLockBoxImportException

public class DemoLockBoxImportException : BaseApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: DemoLockBoxImport (in DemoLockBoxImport.dll)

See Also

DemoLockBoxImportException Members | Aptify.Applications.Accounting Namespace


DemoLockBoxImportException Members

DemoLockBoxImportException overview

Public Instance Constructors

DemoLockBoxImportException Overloaded. Initializes a new instance of the DemoLockBoxImportException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from BaseApplicationException) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DemoLockBoxImportException Class | Aptify.Applications.Accounting Namespace


DemoLockBoxImportException Constructor

Initializes a new instance of the DemoLockBoxImportException class.

Overload List

Initializes a new instance of the DemoLockBoxImportException class.

public DemoLockBoxImportException();

public DemoLockBoxImportException(String);

public DemoLockBoxImportException(String,Exception);

See Also

DemoLockBoxImportException Class | Aptify.Applications.Accounting Namespace


DemoLockBoxImportException Constructor ()

Initializes a new instance of the DemoLockBoxImportException class.

public DemoLockBoxImportException();

See Also

DemoLockBoxImportException Class | Aptify.Applications.Accounting Namespace | DemoLockBoxImportException Constructor Overload List


DemoLockBoxImportException Constructor (String)

public DemoLockBoxImportException(
String Message
);

See Also

DemoLockBoxImportException Class | Aptify.Applications.Accounting Namespace | DemoLockBoxImportException Constructor Overload List


DemoLockBoxImportException Constructor (String, Exception)

public DemoLockBoxImportException(
String Message,
Exception InnerException
);

See Also

DemoLockBoxImportException Class | Aptify.Applications.Accounting Namespace | DemoLockBoxImportException Constructor Overload List


ExpandScheduledTransactions Class

Written by Ravi Nagarajan, October 13, 1999 The purpose of this object is to review Scheduled Transaction Group records in the database and create the associated scheduled transaction records based on the group attributes. This process was introduced starting with the 1.20 build to improve the speed of the order entry system. Rather than generating individual scheduled transaction records during the Order save process, we create a single record per order line from which we can later generate the individual scheduled transaction records.

For a list of all members of this type, see ExpandScheduledTransactions Members.

System.Object
ExpandScheduledTransactions

public class ExpandScheduledTransactions : IProcessComponent, IAptifyAction

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

RN 10/13/1999 Modified by Ravi Nagarajan, November 5, 1999 We must NOT expand any scheduled transaction groups unless they are linked to orders that have already been shipped to the customer. Otherwise, the user can never modify the ordre again b/c the order module deletes and' re-creates the sched trans group BUT the group record cannot be deleted b/c there are scheduled transactions linked to it. ' AN - 10/14/2005 - Modified by Amith Nagarajan Migrated the implementation of IProcessComponent into this object Also Migrated the implementation of IAptifyAction into this object

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: ExpandScheduledTransactions (in ExpandScheduledTransactions.dll)

See Also

ExpandScheduledTransactions Members | Aptify.Applications.Accounting Namespace


ExpandScheduledTransactions Members

ExpandScheduledTransactions overview

Public Instance Constructors

ExpandScheduledTransactions Constructor Initializes a new instance of the ExpandScheduledTransactions class.

Public Instance Properties

CancelledByUser
Properties

Public Instance Methods

BetterInStr |
CancelProcess |
Config |
DoAction | Overloaded.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ExpandScheduledTransactionGroups | Overloaded.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetScheduledTransactionGroupCount |
GetType (inherited from Object) | Gets the Type of the current instance.
MinNot |
Run |
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

GroupExpansionStatus

Protected Instance Properties

SubscriptionDateObject

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
InternalExpandScheduledTransactionGroups |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ModifyViewSQL |
OnGroupExpansionStatus |

See Also

ExpandScheduledTransactions Class | Aptify.Applications.Accounting Namespace


ExpandScheduledTransactions Constructor

Initializes a new instance of the ExpandScheduledTransactions class.

public ExpandScheduledTransactions();

See Also

ExpandScheduledTransactions Class | Aptify.Applications.Accounting Namespace


ExpandScheduledTransactions Properties

The properties of the ExpandScheduledTransactions class are listed below. For a complete list of ExpandScheduledTransactions class members, see the ExpandScheduledTransactions Members topic.

Public Instance Properties

CancelledByUser
Properties

Protected Instance Properties

SubscriptionDateObject

See Also

ExpandScheduledTransactions Class | Aptify.Applications.Accounting Namespace


CancelledByUser Property

Aptify 5.0 Software Development Kit (SDK)

ExpandScheduledTransactions.CancelledByUser Property

public virtual Boolean CancelledByUser {get;}

See Also

ExpandScheduledTransactions Class | Aptify.Applications.Accounting Namespace


Properties Property

Aptify 5.0 Software Development Kit (SDK)

ExpandScheduledTransactions.Properties Property

public AptifyProperties Properties {get;}

Implements

IProcessComponent.

See Also

ExpandScheduledTransactions Class | Aptify.Applications.Accounting Namespace


SubscriptionDateObject Property

Aptify 5.0 Software Development Kit (SDK)

ExpandScheduledTransactions.SubscriptionDateObject Property

protected ISubscriptionDate SubscriptionDateObject {get;}

See Also

ExpandScheduledTransactions Class | Aptify.Applications.Accounting Namespace


ExpandScheduledTransactions Methods

The methods of the ExpandScheduledTransactions class are listed below. For a complete list of ExpandScheduledTransactions class members, see the ExpandScheduledTransactions Members topic.

Public Instance Methods

BetterInStr |
CancelProcess |
Config |
DoAction | Overloaded.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ExpandScheduledTransactionGroups | Overloaded.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetScheduledTransactionGroupCount |
GetType (inherited from Object) | Gets the Type of the current instance.
MinNot |
Run |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
InternalExpandScheduledTransactionGroups |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ModifyViewSQL |
OnGroupExpansionStatus |

See Also

ExpandScheduledTransactions Class | Aptify.Applications.Accounting Namespace


ExpandScheduledTransactions.BetterInStr Method

public virtual int BetterInStr(
String sStr,
String sTerm,
ExpandScheduledTransactions.BetterInStrType iType
);

See Also

ExpandScheduledTransactions Class | Aptify.Applications.Accounting Namespace


ExpandScheduledTransactions.CancelProcess Method

public virtual bool CancelProcess();

See Also

ExpandScheduledTransactions Class | Aptify.Applications.Accounting Namespace


ExpandScheduledTransactions.Config Method

public virtual void Config(
AptifyApplication Application
);

Implements

IProcessComponent.

See Also

ExpandScheduledTransactions Class | Aptify.Applications.Accounting Namespace


DoAction Method

Aptify 5.0 Software Development Kit (SDK)

ExpandScheduledTransactions.DoAction Method

Overload List

public void DoAction(AptifyApplication,Int64);

public void DoAction(AptifyApplication,Int64,Int64);

public void DoAction(AptifyApplication,Int64,Int64,params Object[]);

public void DoAction(AptifyApplication,Int64,params String[]);

See Also

ExpandScheduledTransactions Class | Aptify.Applications.Accounting Namespace


ExpandScheduledTransactions.DoAction Method (AptifyApplication, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID
);

Implements

IAptifyAction.

See Also

ExpandScheduledTransactions Class | Aptify.Applications.Accounting Namespace | ExpandScheduledTransactions.DoAction Overload List


ExpandScheduledTransactions.DoAction Method (AptifyApplication, Int64, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID
);

Implements

IAptifyAction.

See Also

ExpandScheduledTransactions Class | Aptify.Applications.Accounting Namespace | ExpandScheduledTransactions.DoAction Overload List


ExpandScheduledTransactions.DoAction Method (AptifyApplication, Int64, Int64, Object[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID,
params Object[] SelectedItems
);

Implements

IAptifyAction.

See Also

ExpandScheduledTransactions Class | Aptify.Applications.Accounting Namespace | ExpandScheduledTransactions.DoAction Overload List


ExpandScheduledTransactions.DoAction Method (AptifyApplication, Int64, String[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
params String[] SelectedItems
);

Implements

IAptifyAction.

See Also

ExpandScheduledTransactions Class | Aptify.Applications.Accounting Namespace | ExpandScheduledTransactions.DoAction Overload List


ExpandScheduledTransactionGroups Method

Aptify 5.0 Software Development Kit (SDK)

ExpandScheduledTransactions.ExpandScheduledTransactionGroups Method

Overload List

public virtual bool ExpandScheduledTransactionGroups(Boolean);

public virtual bool ExpandScheduledTransactionGroups(Boolean,Int64);

public virtual bool ExpandScheduledTransactionGroups(Boolean,Int64,Int64);

public virtual bool ExpandScheduledTransactionGroups(Boolean,String);

public virtual bool ExpandScheduledTransactionGroups(Boolean,String,Int64);

See Also

ExpandScheduledTransactions Class | Aptify.Applications.Accounting Namespace


ExpandScheduledTransactions.ExpandScheduledTransactionGroups Method (Boolean)

public virtual bool ExpandScheduledTransactionGroups(
Boolean ShowProgress
);

See Also

ExpandScheduledTransactions Class | Aptify.Applications.Accounting Namespace | ExpandScheduledTransactions.ExpandScheduledTransactionGroups Overload List


ExpandScheduledTransactions.ExpandScheduledTransactionGroups Method (Boolean, Int64)

public virtual bool ExpandScheduledTransactionGroups(
Boolean ShowProgress,
Int64 ViewID
);

See Also

ExpandScheduledTransactions Class | Aptify.Applications.Accounting Namespace | ExpandScheduledTransactions.ExpandScheduledTransactionGroups Overload List


ExpandScheduledTransactions.ExpandScheduledTransactionGroups Method (Boolean, Int64, Int64)

public virtual bool ExpandScheduledTransactionGroups(
Boolean ShowProgress,
Int64 ViewID,
Int64 ProductID
);

See Also

ExpandScheduledTransactions Class | Aptify.Applications.Accounting Namespace | ExpandScheduledTransactions.ExpandScheduledTransactionGroups Overload List


ExpandScheduledTransactions.ExpandScheduledTransactionGroups Method (Boolean, String)

public virtual bool ExpandScheduledTransactionGroups(
Boolean ShowProgress,
String SQLWorkingSet
);

See Also

ExpandScheduledTransactions Class | Aptify.Applications.Accounting Namespace | ExpandScheduledTransactions.ExpandScheduledTransactionGroups Overload List


ExpandScheduledTransactions.ExpandScheduledTransactionGroups Method (Boolean, String, Int64)

public virtual bool ExpandScheduledTransactionGroups(
Boolean ShowProgress,
String SQLWorkingSet,
Int64 ProductID
);

See Also

ExpandScheduledTransactions Class | Aptify.Applications.Accounting Namespace | ExpandScheduledTransactions.ExpandScheduledTransactionGroups Overload List


ExpandScheduledTransactions.GetScheduledTransactionGroupCount Method

public virtual long GetScheduledTransactionGroupCount(
Int64 ViewID,
String ViewSQL
);

See Also

ExpandScheduledTransactions Class | Aptify.Applications.Accounting Namespace


ExpandScheduledTransactions.InternalExpandScheduledTransactionGroups Method

protected virtual bool InternalExpandScheduledTransactionGroups(
Boolean ShowProgress,
String SQLWorkingSet,
Int64 ViewID,
Int64 ProductID
);

Parameters

ShowProgress
SQLWorkingSet
If SQLWorkingSet is not an empty string, use it to create the working set of Scheduled Transaction Groups to expand.
ViewID
If ViewID > 0 (and SQLWorkingSet wasn't provided) then use the View to define the working set of Scheduled Transaction Groups If ViewID less or equal to 0 (and SQLWorkingSet wasn't provided) then process all of the pending Scheduled Transaction Groups.
ProductID
If ProductID > 0 then process only the scheduled tranasaction groups that are part of the working set and for the Product identified by ProductID

Return Value

Remarks

See Also

ExpandScheduledTransactions Class | Aptify.Applications.Accounting Namespace


ExpandScheduledTransactions.MinNot Method

public virtual int MinNot(
Int32 iNot,
Int32 iOne,
Int32 iTwo
);

See Also

ExpandScheduledTransactions Class | Aptify.Applications.Accounting Namespace


ExpandScheduledTransactions.ModifyViewSQL Method

protected virtual string ModifyViewSQL(
String sSQL,
Boolean bReturnCount
);

See Also

ExpandScheduledTransactions Class | Aptify.Applications.Accounting Namespace


ExpandScheduledTransactions.OnGroupExpansionStatus Method

protected virtual void OnGroupExpansionStatus(
Int64 CurrentPosition,
Int64 OverallPosition,
Int64 CurrentRecordID,
Int64 CurrentProductID,
Int64 TotalRecords,
ref Boolean& Cancel
);

See Also

ExpandScheduledTransactions Class | Aptify.Applications.Accounting Namespace


ExpandScheduledTransactions.Run Method

public string Run();

Implements

IProcessComponent.

See Also

ExpandScheduledTransactions Class | Aptify.Applications.Accounting Namespace


ExpandScheduledTransactions Events

The events of the ExpandScheduledTransactions class are listed below. For a complete list of ExpandScheduledTransactions class members, see the ExpandScheduledTransactions Members topic.

Public Instance Events

GroupExpansionStatus

See Also

ExpandScheduledTransactions Class | Aptify.Applications.Accounting Namespace


ExpandScheduledTransactions.ExpandScheduledTransactions.GroupExpansionStatusEventHandler Event

public event ExpandScheduledTransactions.GroupExpansionStatusEventHandler GroupExpansionStatus;

See Also

ExpandScheduledTransactions Class | Aptify.Applications.Accounting Namespace


ExpandScheduledTransactions.BetterInStrType Enumeration

public enum ExpandScheduledTransactions.BetterInStrType

Members

Member Name | Description
RightOnly |
LeftOnly |
Both |

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: ExpandScheduledTransactions (in ExpandScheduledTransactions.dll)

See Also

Aptify.Applications.Accounting Namespace


ExpandScheduledTransactions.GroupExpansionStatusEventHandler Delegate

public delegate void ExpandScheduledTransactions.GroupExpansionStatusEventHandler(
Int64 CurrentPosition,
Int64 OverallPosition,
Int64 CurrentRecordID,
Int64 CurrentProductID,
Int64 TotalRecords,
ref Boolean& Cancel
);

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: ExpandScheduledTransactions (in ExpandScheduledTransactions.dll)

See Also

Aptify.Applications.Accounting Namespace


GLExport Class

For a list of all members of this type, see GLExport Members.

System.Object
GLExport

public class GLExport : IProcessComponent, IGLExport

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: GLExport (in GLExport.dll)

See Also

GLExport Members | Aptify.Applications.Accounting Namespace


GLExport Members

GLExport overview

Public Instance Constructors

GLExport Constructor Initializes a new instance of the GLExport class.

Public Instance Properties

Properties

Public Instance Methods

Config |
DoGLExport |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBatchAttributeValue |
GetDefaultBatchFileName |
GetEffectiveDate | Overloaded.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
PromptBatchSaveDialog |
Run |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GLExport Class | Aptify.Applications.Accounting Namespace


GLExport Constructor

Initializes a new instance of the GLExport class.

public GLExport();

See Also

GLExport Class | Aptify.Applications.Accounting Namespace


GLExport Properties

The properties of the GLExport class are listed below. For a complete list of GLExport class members, see the GLExport Members topic.

Public Instance Properties

Properties

See Also

GLExport Class | Aptify.Applications.Accounting Namespace


Properties Property

Aptify 5.0 Software Development Kit (SDK)

GLExport.Properties Property

public AptifyProperties Properties {get;}

Implements

IProcessComponent.

See Also

GLExport Class | Aptify.Applications.Accounting Namespace


GLExport Methods

The methods of the GLExport class are listed below. For a complete list of GLExport class members, see the GLExport Members topic.

Public Instance Methods

Config |
DoGLExport |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBatchAttributeValue |
GetDefaultBatchFileName |
GetEffectiveDate | Overloaded.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
PromptBatchSaveDialog |
Run |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GLExport Class | Aptify.Applications.Accounting Namespace


GLExport.Config Method

public void Config(
AptifyApplication ApplicationObject
);

Implements

IProcessComponent.

See Also

GLExport Class | Aptify.Applications.Accounting Namespace


GLExport.DoGLExport Method

public bool DoGLExport(
AptifyGenericEntityBase BatchGE,
String DefaultExportLocation,
Boolean ShowGUI
);

Implements

IGLExport.

See Also

GLExport Class | Aptify.Applications.Accounting Namespace


GLExport.GetBatchAttributeValue Method

public string GetBatchAttributeValue(
String AttributeName,
AptifyApplication Application
);

See Also

GLExport Class | Aptify.Applications.Accounting Namespace


GLExport.GetDefaultBatchFileName Method

public string GetDefaultBatchFileName();

See Also

GLExport Class | Aptify.Applications.Accounting Namespace


GetEffectiveDate Method

Aptify 5.0 Software Development Kit (SDK)

GLExport.GetEffectiveDate Method

11-05-08 Tamasa,Added the overloaded function to fix the issue 7116.

Overload List

11-05-08 Tamasa,Added the overloaded function to fix the issue 7116.

public virtual bool GetEffectiveDate(ref UserCredentials&,ref String&,Boolean);

public bool GetEffectiveDate(ref String&,Boolean);

See Also

GLExport Class | Aptify.Applications.Accounting Namespace


GLExport.GetEffectiveDate Method (UserCredentials&, String&, Boolean)

11-05-08 Tamasa,Added the overloaded function to fix the issue 7116.

public virtual bool GetEffectiveDate(
ref UserCredentials& UserCredential,
ref String& sDate,
Boolean ShowGUI
);

Parameters

UserCredential
sDate
ShowGUI

Return Value

Remarks

See Also

GLExport Class | Aptify.Applications.Accounting Namespace | GLExport.GetEffectiveDate Overload List


GLExport.GetEffectiveDate Method (String&, Boolean)

public bool GetEffectiveDate(
ref String& sDate,
Boolean ShowGUI
);

See Also

GLExport Class | Aptify.Applications.Accounting Namespace | GLExport.GetEffectiveDate Overload List


GLExport.PromptBatchSaveDialog Method

public GLExportFileOperation PromptBatchSaveDialog(
String DefaultExportLocation,
String DefaultFileName
);

See Also

GLExport Class | Aptify.Applications.Accounting Namespace


GLExport.Run Method

public string Run();

Implements

IProcessComponent.

See Also

GLExport Class | Aptify.Applications.Accounting Namespace


GLExport.GLExportFileOperation Structure

For a list of all members of this type, see GLExport.GLExportFileOperation Members.

System.Object
ValueType
GLExport.GLExportFileOperation

public struct GLExport.GLExportFileOperation

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: GLExport (in GLExport.dll)

See Also

GLExport.GLExportFileOperation Members | Aptify.Applications.Accounting Namespace


GLExport.GLExportFileOperation Members

GLExport.GLExportFileOperation overview

Public Instance Constructors

GLExport.GLExportFileOperation Constructor

Public Instance Fields

FileAction
FileName

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

GLExport.GLExportFileOperation Structure | Aptify.Applications.Accounting Namespace


GLExport.GLExportFileOperation Constructor

public GLExport.GLExportFileOperation(
GLExport.GLExportFileWriteAction Action,
String sFileName
);

See Also

GLExport.GLExportFileOperation Structure | Aptify.Applications.Accounting Namespace


GLExport.GLExportFileOperation Fields

The fields of the GLExport.GLExportFileOperation structure are listed below. For a complete list of GLExport.GLExportFileOperation structure members, see the GLExport.GLExportFileOperation Members topic.

Public Instance Fields

FileAction
FileName

See Also

GLExport.GLExportFileOperation Structure | Aptify.Applications.Accounting Namespace


GLExport.GLExportFileOperation.FileAction Field

public FileAction FileAction;

See Also

GLExport.GLExportFileOperation Class | Aptify.Applications.Accounting Namespace


GLExport.GLExportFileOperation.FileName Field

public FileName FileName;

See Also

GLExport.GLExportFileOperation Class | Aptify.Applications.Accounting Namespace


GLExport.GLExportFileWriteAction Enumeration

public enum GLExport.GLExportFileWriteAction

Members

Member Name | Description
Replace |
Append |
Leave |

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: GLExport (in GLExport.dll)

See Also

Aptify.Applications.Accounting Namespace


GreatPlainsExport Class

This GL Export Driver produces an export file that can be imported by Microsoft Great Plains The default implementation logic for this driver is to output a comma delimited file that has the following fields in each line of the file. The first line of the file shows the column headers. Columns: AccountNumber, Amount, Reference, Date, WeightedAvgSpotRate Note: The standard driver produces a "Reference" field of "Aptify Batch ID: 12345" for each line where 12345 is the Batch # for the export batch.

For a list of all members of this type, see GreatPlainsExport Members.

System.Object
GreatPlainsExport

public class GreatPlainsExport : IGLExport

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: GLExportDrivers (in GLExportDrivers.dll)

See Also

GreatPlainsExport Members | Aptify.Applications.Accounting Namespace


GreatPlainsExport Members

GreatPlainsExport overview

Public Instance Constructors

GreatPlainsExport Overloaded. Initializes a new instance of the GreatPlainsExport class.

Public Instance Methods

DoGLExport |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OutputFileHeader | This method is responsible for outputing the file header and is called from the DoGLExport() method once per export. Override this method to alter the default business logic. The default business logic for this object is to output a string with the following value: AccountNumber, Amount, Reference, Date, WeightedAvgSpotRate
OutputFileLine | This method is responsible for outputing a single file line from the batch to the provided output stream. The default logic for this implementation is to output the file information in the format specified in the class description. This method is called once for each Account Entry sub-type entry in the BatchGE from the DoGLExport() method. Override this method to alter the output of each line of the file.

See Also

GreatPlainsExport Class | Aptify.Applications.Accounting Namespace


GreatPlainsExport Constructor

Default constructor

Overload List

Default constructor

public GreatPlainsExport();

public GreatPlainsExport(AptifyApplication);

See Also

GreatPlainsExport Class | Aptify.Applications.Accounting Namespace


GreatPlainsExport Constructor ()

Default constructor

public GreatPlainsExport();

Remarks

See Also

GreatPlainsExport Class | Aptify.Applications.Accounting Namespace | GreatPlainsExport Constructor Overload List


GreatPlainsExport Constructor (AptifyApplication)

public GreatPlainsExport(
AptifyApplication Application
);

See Also

GreatPlainsExport Class | Aptify.Applications.Accounting Namespace | GreatPlainsExport Constructor Overload List


GreatPlainsExport Methods

The methods of the GreatPlainsExport class are listed below. For a complete list of GreatPlainsExport class members, see the GreatPlainsExport Members topic.

Public Instance Methods

DoGLExport |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OutputFileHeader | This method is responsible for outputing the file header and is called from the DoGLExport() method once per export. Override this method to alter the default business logic. The default business logic for this object is to output a string with the following value: AccountNumber, Amount, Reference, Date, WeightedAvgSpotRate
OutputFileLine | This method is responsible for outputing a single file line from the batch to the provided output stream. The default logic for this implementation is to output the file information in the format specified in the class description. This method is called once for each Account Entry sub-type entry in the BatchGE from the DoGLExport() method. Override this method to alter the output of each line of the file.

See Also

GreatPlainsExport Class | Aptify.Applications.Accounting Namespace


GreatPlainsExport.DoGLExport Method

public bool DoGLExport(
AptifyGenericEntityBase BatchGE,
String DefaultExportLocation,
Boolean ShowGUI
);

Implements

IGLExport.

See Also

GreatPlainsExport Class | Aptify.Applications.Accounting Namespace


GreatPlainsExport.OutputFileHeader Method

This method is responsible for outputing the file header and is called from the DoGLExport() method once per export. Override this method to alter the default business logic. The default business logic for this object is to output a string with the following value: AccountNumber, Amount, Reference, Date, WeightedAvgSpotRate

protected virtual void OutputFileHeader(
StreamWriter OutputStream,
AptifyGenericEntityBase BatchGE
);

Parameters

OutputStream
BatchGE

Remarks

See Also

GreatPlainsExport Class | Aptify.Applications.Accounting Namespace


GreatPlainsExport.OutputFileLine Method

This method is responsible for outputing a single file line from the batch to the provided output stream. The default logic for this implementation is to output the file information in the format specified in the class description. This method is called once for each Account Entry sub-type entry in the BatchGE from the DoGLExport() method. Override this method to alter the output of each line of the file.

protected virtual void OutputFileLine(
StreamWriter OutputStream,
AptifyGenericEntityBase BatchAccountEntryGE,
String EffectiveDate,
String DefaultDescription
);

Remarks

See Also

GreatPlainsExport Class | Aptify.Applications.Accounting Namespace


IExpandScheduledTransactions Interface

For a list of all members of this type, see IExpandScheduledTransactions Members.

public interface IExpandScheduledTransactions

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: IExpandScheduledTransactionGroups (in IExpandScheduledTransactionGroups.dll)

See Also

IExpandScheduledTransactions Members | Aptify.Applications.Accounting Namespace


IExpandScheduledTransactions Members

IExpandScheduledTransactions overview

Public Instance Properties

CancelledByUser

Public Instance Methods

Config |
ExpandScheduledTransactionGroups | Overloaded.

Public Instance Events

GroupExpansionStatus

See Also

IExpandScheduledTransactions Interface | Aptify.Applications.Accounting Namespace


IExpandScheduledTransactions Properties

The properties of the IExpandScheduledTransactions interface are listed below. For a complete list of IExpandScheduledTransactions interface members, see the IExpandScheduledTransactions Members topic.

Public Instance Properties

CancelledByUser

See Also

IExpandScheduledTransactions Interface | Aptify.Applications.Accounting Namespace


CancelledByUser Property

Aptify 5.0 Software Development Kit (SDK)

IExpandScheduledTransactions.CancelledByUser Property

Boolean CancelledByUser {get;}

See Also

IExpandScheduledTransactions Interface | Aptify.Applications.Accounting Namespace


IExpandScheduledTransactions Methods

The methods of the IExpandScheduledTransactions interface are listed below. For a complete list of IExpandScheduledTransactions interface members, see the IExpandScheduledTransactions Members topic.

Public Instance Methods

Config |
ExpandScheduledTransactionGroups | Overloaded.

See Also

IExpandScheduledTransactions Interface | Aptify.Applications.Accounting Namespace


IExpandScheduledTransactions.Config Method

void Config(
AptifyApplication Application
);

See Also

IExpandScheduledTransactions Interface | Aptify.Applications.Accounting Namespace


ExpandScheduledTransactionGroups Method

Aptify 5.0 Software Development Kit (SDK)

IExpandScheduledTransactions.ExpandScheduledTransactionGroups Method

Overload List

bool ExpandScheduledTransactionGroups(Boolean);

bool ExpandScheduledTransactionGroups(Boolean,Int64);

bool ExpandScheduledTransactionGroups(Boolean,Int64,Int64);

bool ExpandScheduledTransactionGroups(Boolean,String);

bool ExpandScheduledTransactionGroups(Boolean,String,Int64);

See Also

IExpandScheduledTransactions Interface | Aptify.Applications.Accounting Namespace


IExpandScheduledTransactions.ExpandScheduledTransactionGroups Method (Boolean)

bool ExpandScheduledTransactionGroups(
Boolean ShowProgress
);

See Also

IExpandScheduledTransactions Interface | Aptify.Applications.Accounting Namespace | IExpandScheduledTransactions.ExpandScheduledTransactionGroups Overload List


IExpandScheduledTransactions.ExpandScheduledTransactionGroups Method (Boolean, Int64)

bool ExpandScheduledTransactionGroups(
Boolean ShowProgress,
Int64 ViewID
);

See Also

IExpandScheduledTransactions Interface | Aptify.Applications.Accounting Namespace | IExpandScheduledTransactions.ExpandScheduledTransactionGroups Overload List


IExpandScheduledTransactions.ExpandScheduledTransactionGroups Method (Boolean, Int64, Int64)

bool ExpandScheduledTransactionGroups(
Boolean ShowProgress,
Int64 ViewID,
Int64 ProductID
);

See Also

IExpandScheduledTransactions Interface | Aptify.Applications.Accounting Namespace | IExpandScheduledTransactions.ExpandScheduledTransactionGroups Overload List


IExpandScheduledTransactions.ExpandScheduledTransactionGroups Method (Boolean, String)

bool ExpandScheduledTransactionGroups(
Boolean ShowProgress,
String SQLWorkingSet
);

See Also

IExpandScheduledTransactions Interface | Aptify.Applications.Accounting Namespace | IExpandScheduledTransactions.ExpandScheduledTransactionGroups Overload List


IExpandScheduledTransactions.ExpandScheduledTransactionGroups Method (Boolean, String, Int64)

bool ExpandScheduledTransactionGroups(
Boolean ShowProgress,
String SQLWorkingSet,
Int64 ProductID
);

See Also

IExpandScheduledTransactions Interface | Aptify.Applications.Accounting Namespace | IExpandScheduledTransactions.ExpandScheduledTransactionGroups Overload List


IExpandScheduledTransactions Events

The events of the IExpandScheduledTransactions interface are listed below. For a complete list of IExpandScheduledTransactions interface members, see the IExpandScheduledTransactions Members topic.

Public Instance Events

GroupExpansionStatus

See Also

IExpandScheduledTransactions Interface | Aptify.Applications.Accounting Namespace


IExpandScheduledTransactions.IExpandScheduledTransactions.GroupExpansionStatusEventHandler Event

event IExpandScheduledTransactions.GroupExpansionStatusEventHandler GroupExpansionStatus;

See Also

IExpandScheduledTransactions Interface | Aptify.Applications.Accounting Namespace


IExpandScheduledTransactions.GroupExpansionStatusEventHandler Delegate

public delegate void IExpandScheduledTransactions.GroupExpansionStatusEventHandler(
Int64 CurrentPosition,
Int64 OverallPosition,
Int64 CurrentRecordID,
Int64 CurrentProductID,
Int64 TotalRecords,
ref Boolean& Cancel
);

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: IExpandScheduledTransactionGroups (in IExpandScheduledTransactionGroups.dll)

See Also

Aptify.Applications.Accounting Namespace


IGenerateGL Interface

This interface is used for plug-ins to create GL entries as needed in different application areas in the Aptify Order Entry, Payment Processing and Accounting Integration system areas.

For a list of all members of this type, see IGenerateGL Members.

public interface IGenerateGL

Types that implement IGenerateGL

Type | Description
OrderGenerateGL | This object implements the Aptify.Applications.Accounting.IGenerateGL interface. The purpose of this component is to generate GL entries for an order
PaymentGenerateGL | This object implements the Aptify.Applications.Accounting.IGenerateGL interface. The purpose of this component is to generate GL entries for a payment

Remarks

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: IGenerateGL (in IGenerateGL.dll)

See Also

IGenerateGL Members | Aptify.Applications.Accounting Namespace


IGenerateGL Members

IGenerateGL overview

Public Instance Methods

Config
GenerateGLEntries
RemoveGLEntries

See Also

IGenerateGL Interface | Aptify.Applications.Accounting Namespace


IGenerateGL Methods

The methods of the IGenerateGL interface are listed below. For a complete list of IGenerateGL interface members, see the IGenerateGL Members topic.

Public Instance Methods

Config
GenerateGLEntries
RemoveGLEntries

See Also

IGenerateGL Interface | Aptify.Applications.Accounting Namespace


IGenerateGL.Config Method

void Config(
AptifyGenericEntityBase GE,
AptifyApplication Application
);

See Also

IGenerateGL Interface | Aptify.Applications.Accounting Namespace


IGenerateGL.GenerateGLEntries Method

bool GenerateGLEntries(
Boolean ShowErrors
);

See Also

IGenerateGL Interface | Aptify.Applications.Accounting Namespace


IGenerateGL.RemoveGLEntries Method

bool RemoveGLEntries(
Boolean ShowErrors
);

See Also

IGenerateGL Interface | Aptify.Applications.Accounting Namespace


IGLExport Interface

For a list of all members of this type, see IGLExport Members.

public interface IGLExport

Types that implement IGLExport

Type | Description
GLExport |
GreatPlainsExport | This GL Export Driver produces an export file that can be imported by Microsoft Great Plains The default implementation logic for this driver is to output a comma delimited file that has the following fields in each line of the file. The first line of the file shows the column headers. Columns: AccountNumber, Amount, Reference, Date, WeightedAvgSpotRate Note: The standard driver produces a "Reference" field of "Aptify Batch ID: 12345" for each line where 12345 is the Batch # for the export batch.
NavisionExport |
RossFinancialsExport |
SolomonExport |

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: IGLExport (in IGLExport.dll)

See Also

IGLExport Members | Aptify.Applications.Accounting Namespace


IGLExport Members

IGLExport overview

Public Instance Methods

DoGLExport

See Also

IGLExport Interface | Aptify.Applications.Accounting Namespace


IGLExport Methods

The methods of the IGLExport interface are listed below. For a complete list of IGLExport interface members, see the IGLExport Members topic.

Public Instance Methods

DoGLExport

See Also

IGLExport Interface | Aptify.Applications.Accounting Namespace


IGLExport.DoGLExport Method

bool DoGLExport(
AptifyGenericEntityBase BatchGE,
String DefaultExportLocation,
Boolean ShowGUI
);

See Also

IGLExport Interface | Aptify.Applications.Accounting Namespace


ILockBoxAllocQuery Interface

This interface is used to create plug-in components that provide a list of available Products that the cash control batch allows a user to allocate overpayments to.

For a list of all members of this type, see ILockBoxAllocQuery Members.

public interface ILockBoxAllocQuery

Types that implement ILockBoxAllocQuery

Type | Description
LockBoxAllocProducts | This class provides the default implmentation of the ILockBoxAllocQuery interface for the lock box architecture. It is possible to sub-class this class and override its various members to provide the specific functionality required for an implementation of the lock box architecture that requires different logic in this area of the system. Alternatively, it is also possible to build a new class that also implements ILockBoxAllocQuery and to plug in that entirely new class as well into the architecture using the meta-data attributes in the Cash Control Batches entity.

Remarks

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: ICashControlBatch (in ICashControlBatch.dll)

See Also

ILockBoxAllocQuery Members | Aptify.Applications.Accounting Namespace


ILockBoxAllocQuery Members

ILockBoxAllocQuery overview

Public Instance Methods

Config | Call this function before using any other method on the interface to configure the object for use
GetAllocProducts | This function returns a list of product record ID values that can be used for allocating overpayments.

See Also

ILockBoxAllocQuery Interface | Aptify.Applications.Accounting Namespace


ILockBoxAllocQuery Methods

The methods of the ILockBoxAllocQuery interface are listed below. For a complete list of ILockBoxAllocQuery interface members, see the ILockBoxAllocQuery Members topic.

Public Instance Methods

Config | Call this function before using any other method on the interface to configure the object for use
GetAllocProducts | This function returns a list of product record ID values that can be used for allocating overpayments.

See Also

ILockBoxAllocQuery Interface | Aptify.Applications.Accounting Namespace


ILockBoxAllocQuery.Config Method

Call this function before using any other method on the interface to configure the object for use

void Config(
AptifyApplication Application
);

Parameters

Application
Aptify Application Required for Use of the Object

Remarks

See Also

ILockBoxAllocQuery Interface | Aptify.Applications.Accounting Namespace


ILockBoxAllocQuery.GetAllocProducts Method

This function returns a list of product record ID values that can be used for allocating overpayments.

List<T> GetAllocProducts();

Return Value

A List(Of Long) that has the product ID values in it that are allowed for alloating overpayments

Remarks

See Also

ILockBoxAllocQuery Interface | Aptify.Applications.Accounting Namespace


ILockBoxImport Interface

Interface used to create plug-ins for the lock box import engine/process

For a list of all members of this type, see ILockBoxImport Members.

public interface ILockBoxImport

Types that implement ILockBoxImport

Type | Description
DemoLockBoxImport | This is a demonstration of a bank file import for the Aptify Lock Box Import Wizard The purpose of this class is to provide an example of how to plug in file formats that can accomodate various types of import options The demo file format has a first line comment, a second line that contains header information, and third lines and beyond contain payment line items. First Line: Comment - Ignore it Second Line: DepositDate,BankBatch,Total,PaymentType Third+ Lines: OrderID, Customer Name, PaymentAmount, Check Number
LockBoxImportBase | This class provides a set of utility functions as a base class for all other import objects that need to provide lock box import functionality
LockBoxTextFileImport | This is a base class for all text file based imports for lock box and provides general file manipulation utilities to all of its sub-classes.

Remarks

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: ICashControlBatch (in ICashControlBatch.dll)

See Also

ILockBoxImport Members | Aptify.Applications.Accounting Namespace


ILockBoxImport Members

ILockBoxImport overview

Public Instance Methods

Config | Call this function before using any other method on the interface to configure the object for use
GetStatusOfFile |
ProcessFile | Overloaded. Call this method to start the processing of a file as specified

Public Instance Events

StatusUpdate This event will be raised throughout the processing of the file in the ProcessFile() function Use event handlers for this event to be notified of the progress of this function.

See Also

ILockBoxImport Interface | Aptify.Applications.Accounting Namespace


ILockBoxImport Methods

The methods of the ILockBoxImport interface are listed below. For a complete list of ILockBoxImport interface members, see the ILockBoxImport Members topic.

Public Instance Methods

Config | Call this function before using any other method on the interface to configure the object for use
GetStatusOfFile |
ProcessFile | Overloaded. Call this method to start the processing of a file as specified

See Also

ILockBoxImport Interface | Aptify.Applications.Accounting Namespace


ILockBoxImport.Config Method

Call this function before using any other method on the interface to configure the object for use

void Config(
AptifyApplication Application
);

Parameters

Application
Aptify Application Required for Use of the Object

Remarks

See Also

ILockBoxImport Interface | Aptify.Applications.Accounting Namespace


ILockBoxImport.GetStatusOfFile Method

bool GetStatusOfFile();

See Also

ILockBoxImport Interface | Aptify.Applications.Accounting Namespace


ProcessFile Method

Aptify 5.0 Software Development Kit (SDK)

ILockBoxImport.ProcessFile Method

Call this method to start the processing of a file as specified

Overload List

Call this method to start the processing of a file as specified

AptifyGenericEntityBase ProcessFile(String,AptifyGenericEntityBase);

Call this method to start the processing of a file as specified

AptifyGenericEntityBase ProcessFile(String,AptifyGenericEntityBase,Int64);

Call this method to start the processing of a file as specified where multiple batches will be created based on mixed payment types that exist inside the batch file This method works like the rest of the ProcessFile() methods however it is overloaded to accept a collection of CashControlBatchGE records so that it is possible for the system to create multiple batches from a single file if needed.

IList<T> ProcessFile(String,IList<T>,Int64);

Call this method to start the processing of a file as specified

AptifyGenericEntityBase ProcessFile(String,Int64);

Call this method to start the processing of a file as specified

AptifyGenericEntityBase ProcessFile(String,Int64,Int64);

See Also

ILockBoxImport Interface | Aptify.Applications.Accounting Namespace


ILockBoxImport.ProcessFile Method (String, AptifyGenericEntityBase)

Call this method to start the processing of a file as specified

AptifyGenericEntityBase ProcessFile(
String FileName,
AptifyGenericEntityBase CashControlBatchGE
);

Parameters

FileName
Fully qualfied path name and file name to use for the lock box import process
CashControlBatchGE
Aptify GE Object for the Cash Control Batch to use for the import process

Return Value

Nothing if there was a failure. If a valida object was returned then there was success.

Remarks

The objects that are returned are populated, but not saved.

See Also

ILockBoxImport Interface | Aptify.Applications.Accounting Namespace | ILockBoxImport.ProcessFile Overload List


ILockBoxImport.ProcessFile Method (String, AptifyGenericEntityBase, Int64)

Call this method to start the processing of a file as specified

AptifyGenericEntityBase ProcessFile(
String FileName,
AptifyGenericEntityBase CashControlBatchGE,
Int64 PaymentTypeID
);

Parameters

FileName
Fully qualfied path name and file name to use for the lock box import process
CashControlBatchGE
Aptify GE Object for the Cash Control Batch to use for the import process
PaymentTypeID
Payment Type to use for payments created in this batch

Return Value

Nothing if there was a failure. If a valida object was returned then there was success.

Remarks

The objects that are returned are populated, but not saved.

See Also

ILockBoxImport Interface | Aptify.Applications.Accounting Namespace | ILockBoxImport.ProcessFile Overload List


ILockBoxImport.ProcessFile Method (String, IList<T>, Int64)

Call this method to start the processing of a file as specified where multiple batches will be created based on mixed payment types that exist inside the batch file This method works like the rest of the ProcessFile() methods however it is overloaded to accept a collection of CashControlBatchGE records so that it is possible for the system to create multiple batches from a single file if needed.

IList<T> ProcessFile(
String FileName,
IList<T> CashControlBatchGE,
Int64 PaymentTypeID
);

Parameters

FileName
Fully qualfied path name and file name to use for the lock box import process
CashControlBatchGE
Aptify GE Object for the Cash Control Batch to use for the import process
PaymentTypeID
Payment Type to use for payments created in this batch

Return Value

Nothing if there was a failure. If a valida object was returned then there was success.

Remarks

The objects that are returned are populated, but not saved.

See Also

ILockBoxImport Interface | Aptify.Applications.Accounting Namespace | ILockBoxImport.ProcessFile Overload List


ILockBoxImport.ProcessFile Method (String, Int64)

Call this method to start the processing of a file as specified

AptifyGenericEntityBase ProcessFile(
String FileName,
Int64 CashControlBatchID
);

Parameters

FileName
Fully qualfied path name and file name to use for the lock box import process
CashControlBatchID
Cash Control Batch ID to use for the import process

Return Value

Nothing if there was a failure. If a valida object was returned then there was success.

Remarks

The objects that are returned are populated, but not saved.

See Also

ILockBoxImport Interface | Aptify.Applications.Accounting Namespace | ILockBoxImport.ProcessFile Overload List


ILockBoxImport.ProcessFile Method (String, Int64, Int64)

Call this method to start the processing of a file as specified

AptifyGenericEntityBase ProcessFile(
String FileName,
Int64 CashControlBatchID,
Int64 PaymentTypeID
);

Parameters

FileName
Fully qualfied path name and file name to use for the lock box import process
CashControlBatchID
Cash Control Batch ID to use for the import process
PaymentTypeID
Payment Type to use for payments created in this batch

Return Value

Nothing if there was a failure. If a valida object was returned then there was success.

Remarks

The objects that are returned are populated, but not saved.

See Also

ILockBoxImport Interface | Aptify.Applications.Accounting Namespace | ILockBoxImport.ProcessFile Overload List


ILockBoxImport Events

The events of the ILockBoxImport interface are listed below. For a complete list of ILockBoxImport interface members, see the ILockBoxImport Members topic.

Public Instance Events

StatusUpdate This event will be raised throughout the processing of the file in the ProcessFile() function Use event handlers for this event to be notified of the progress of this function.

See Also

ILockBoxImport Interface | Aptify.Applications.Accounting Namespace


ILockBoxImport.StatusUpdateEventHandler Event

This event will be raised throughout the processing of the file in the ProcessFile() function Use event handlers for this event to be notified of the progress of this function.

event StatusUpdateEventHandler StatusUpdate;

See Also

ILockBoxImport Interface | Aptify.Applications.Accounting Namespace


ILockBoxMatch Interface

For a list of all members of this type, see ILockBoxMatch Members.

public interface ILockBoxMatch

Types that implement ILockBoxMatch

Type | Description
LockBoxMatch | This class provides the default Aptify implementation for the ILockBoxMatch interface. The base class implements a number of basic matching methods which are overridable if it is necessary to alter the functionality that the matching object provides.

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: ICashControlBatch (in ICashControlBatch.dll)

See Also

ILockBoxMatch Members | Aptify.Applications.Accounting Namespace


ILockBoxMatch Members

ILockBoxMatch overview

Public Instance Methods

Config | Call this function before using any other method on the interface to configure the object for use
MatchBatch | Overloaded. This method is responsible for starting and running the matching process where detail records that were imported from the batch are compared to information in the database to determine if a match exists or not

Public Instance Events

StatusUpdate This event will be raised throughout the processing of the batch in the MatchBatch() function Use event handlers for this event to be notified of the progress of this function.

See Also

ILockBoxMatch Interface | Aptify.Applications.Accounting Namespace


ILockBoxMatch Methods

The methods of the ILockBoxMatch interface are listed below. For a complete list of ILockBoxMatch interface members, see the ILockBoxMatch Members topic.

Public Instance Methods

Config | Call this function before using any other method on the interface to configure the object for use
MatchBatch | Overloaded. This method is responsible for starting and running the matching process where detail records that were imported from the batch are compared to information in the database to determine if a match exists or not

See Also

ILockBoxMatch Interface | Aptify.Applications.Accounting Namespace


ILockBoxMatch.Config Method

Call this function before using any other method on the interface to configure the object for use

void Config(
AptifyApplication Application
);

Parameters

Application
Aptify Application Required for Use of the Object

Remarks

See Also

ILockBoxMatch Interface | Aptify.Applications.Accounting Namespace


MatchBatch Method

Aptify 5.0 Software Development Kit (SDK)

ILockBoxMatch.MatchBatch Method

This method is responsible for starting and running the matching process where detail records that were imported from the batch are compared to information in the database to determine if a match exists or not

Overload List

This method is responsible for starting and running the matching process where detail records that were imported from the batch are compared to information in the database to determine if a match exists or not

bool MatchBatch(AptifyGenericEntityBase);

This method is responsible for starting and running the matching process where detail records that were imported from the batch are compared to information in the database to determine if a match exists or not

bool MatchBatch(Int64);

See Also

ILockBoxMatch Interface | Aptify.Applications.Accounting Namespace


ILockBoxMatch.MatchBatch Method (AptifyGenericEntityBase)

This method is responsible for starting and running the matching process where detail records that were imported from the batch are compared to information in the database to determine if a match exists or not

bool MatchBatch(
AptifyGenericEntityBase CashControlBatchGE
);

Parameters

CashControlBatchGE

Return Value

Remarks

See Also

ILockBoxMatch Interface | Aptify.Applications.Accounting Namespace | ILockBoxMatch.MatchBatch Overload List


ILockBoxMatch.MatchBatch Method (Int64)

This method is responsible for starting and running the matching process where detail records that were imported from the batch are compared to information in the database to determine if a match exists or not

bool MatchBatch(
Int64 CashControlBatchID
);

Parameters

CashControlBatchID

Return Value

Remarks

See Also

ILockBoxMatch Interface | Aptify.Applications.Accounting Namespace | ILockBoxMatch.MatchBatch Overload List


ILockBoxMatch Events

The events of the ILockBoxMatch interface are listed below. For a complete list of ILockBoxMatch interface members, see the ILockBoxMatch Members topic.

Public Instance Events

StatusUpdate This event will be raised throughout the processing of the batch in the MatchBatch() function Use event handlers for this event to be notified of the progress of this function.

See Also

ILockBoxMatch Interface | Aptify.Applications.Accounting Namespace


ILockBoxMatch.StatusUpdateEventHandler Event

This event will be raised throughout the processing of the batch in the MatchBatch() function Use event handlers for this event to be notified of the progress of this function.

event StatusUpdateEventHandler StatusUpdate;

See Also

ILockBoxMatch Interface | Aptify.Applications.Accounting Namespace


ILockBoxPost Interface

This interface is used to create plug-in components than handle the posting phase of the lock box import/match/post process.

For a list of all members of this type, see ILockBoxPost Members.

public interface ILockBoxPost

Types that implement ILockBoxPost

Type | Description
LockBoxPost | This class provides the default Aptify implementation for the ILockBoxPost interface

Remarks

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: ICashControlBatch (in ICashControlBatch.dll)

See Also

ILockBoxPost Members | Aptify.Applications.Accounting Namespace


ILockBoxPost Members

ILockBoxPost overview

Public Instance Methods

Config | Call this function before using any other method on the interface to configure the object for use
PostLockBox | Overloaded. This method is responsible for posting records in the database after the matching process has completed. This method will invoke the individual posting handled by an object that implements the ILockBoxPostMatch and ILockBoxPostException interfaces

Public Instance Events

StatusUpdate This event will be raised throughout the processing of the batch in the PostLockBox() function Use event handlers for this event to be notified of the progress of this function.

See Also

ILockBoxPost Interface | Aptify.Applications.Accounting Namespace


ILockBoxPost Methods

The methods of the ILockBoxPost interface are listed below. For a complete list of ILockBoxPost interface members, see the ILockBoxPost Members topic.

Public Instance Methods

Config | Call this function before using any other method on the interface to configure the object for use
PostLockBox | Overloaded. This method is responsible for posting records in the database after the matching process has completed. This method will invoke the individual posting handled by an object that implements the ILockBoxPostMatch and ILockBoxPostException interfaces

See Also

ILockBoxPost Interface | Aptify.Applications.Accounting Namespace


ILockBoxPost.Config Method

Call this function before using any other method on the interface to configure the object for use

void Config(
AptifyApplication Application
);

Parameters

Application
Aptify Application Required for Use of the Object

Remarks

See Also

ILockBoxPost Interface | Aptify.Applications.Accounting Namespace


PostLockBox Method

Aptify 5.0 Software Development Kit (SDK)

ILockBoxPost.PostLockBox Method

This method is responsible for posting records in the database after the matching process has completed. This method will invoke the individual posting handled by an object that implements the ILockBoxPostMatch and ILockBoxPostException interfaces

Overload List

This method is responsible for posting records in the database after the matching process has completed. This method will invoke the individual posting handled by an object that implements the ILockBoxPostMatch and ILockBoxPostException interfaces

bool PostLockBox(AptifyGenericEntityBase);

This method is responsible for posting records in the database after the matching process has completed. This method will invoke the individual posting handled by an object that implements the ILockBoxPostMatch and ILockBoxPostException interfaces

bool PostLockBox(Int64);

See Also

ILockBoxPost Interface | Aptify.Applications.Accounting Namespace


ILockBoxPost.PostLockBox Method (AptifyGenericEntityBase)

This method is responsible for posting records in the database after the matching process has completed. This method will invoke the individual posting handled by an object that implements the ILockBoxPostMatch and ILockBoxPostException interfaces

bool PostLockBox(
AptifyGenericEntityBase CashControlBatchGE
);

Parameters

CashControlBatchGE

Return Value

True if the method is succesful, False otherwise

Remarks

See Also

ILockBoxPost Interface | Aptify.Applications.Accounting Namespace | ILockBoxPost.PostLockBox Overload List


ILockBoxPost.PostLockBox Method (Int64)

This method is responsible for posting records in the database after the matching process has completed. This method will invoke the individual posting handled by an object that implements the ILockBoxPostMatch and ILockBoxPostException interfaces

bool PostLockBox(
Int64 CashControlBatchID
);

Parameters

CashControlBatchID

Return Value

True if the method is succesful, False otherwise

Remarks

See Also

ILockBoxPost Interface | Aptify.Applications.Accounting Namespace | ILockBoxPost.PostLockBox Overload List


ILockBoxPost Events

The events of the ILockBoxPost interface are listed below. For a complete list of ILockBoxPost interface members, see the ILockBoxPost Members topic.

Public Instance Events

StatusUpdate This event will be raised throughout the processing of the batch in the PostLockBox() function Use event handlers for this event to be notified of the progress of this function.

See Also

ILockBoxPost Interface | Aptify.Applications.Accounting Namespace


ILockBoxPost.StatusUpdateEventHandler Event

This event will be raised throughout the processing of the batch in the PostLockBox() function Use event handlers for this event to be notified of the progress of this function.

event StatusUpdateEventHandler StatusUpdate;

See Also

ILockBoxPost Interface | Aptify.Applications.Accounting Namespace


ILockBoxPostException Interface

For a list of all members of this type, see ILockBoxPostException Members.

public interface ILockBoxPostException

Types that implement ILockBoxPostException

Type | Description
LockBoxPostRecord | This class provides the default Aptify implementation for the ILockBoxPostRecord interface

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: ICashControlBatch (in ICashControlBatch.dll)

See Also

ILockBoxPostException Members | Aptify.Applications.Accounting Namespace


ILockBoxPostException Members

ILockBoxPostException overview

Public Instance Methods

Config | Call this function before using any other method on the interface to configure the object for use
PostException | This method is responsible for posting an individual exception cash line item in a cash control batch to the database based on the information stored in the Cash Detail GE object that is passed in

See Also

ILockBoxPostException Interface | Aptify.Applications.Accounting Namespace


ILockBoxPostException Methods

The methods of the ILockBoxPostException interface are listed below. For a complete list of ILockBoxPostException interface members, see the ILockBoxPostException Members topic.

Public Instance Methods

Config | Call this function before using any other method on the interface to configure the object for use
PostException | This method is responsible for posting an individual exception cash line item in a cash control batch to the database based on the information stored in the Cash Detail GE object that is passed in

See Also

ILockBoxPostException Interface | Aptify.Applications.Accounting Namespace


ILockBoxPostException.Config Method

Call this function before using any other method on the interface to configure the object for use

void Config(
AptifyApplication Application
);

Parameters

Application
Aptify Application Required for Use of the Object

Remarks

See Also

ILockBoxPostException Interface | Aptify.Applications.Accounting Namespace


ILockBoxPostException.PostException Method

This method is responsible for posting an individual exception cash line item in a cash control batch to the database based on the information stored in the Cash Detail GE object that is passed in

bool PostException(
AptifyGenericEntityBase CashBatchGE,
AptifyGenericEntityBase CashDetailGE,
Int32 LineNumber,
Decimal PaymentAmount
);

Parameters

CashBatchGE
CashDetailGE
LineNumber
PaymentAmount

Return Value

True if the method is succesful, False otherwise

Remarks

See Also

ILockBoxPostException Interface | Aptify.Applications.Accounting Namespace


ILockBoxPostMatch Interface

This interface is used to create plug-in components that handle the logic for posting individual detail match records inside a cash control batch based on any logic required by the application.

For a list of all members of this type, see ILockBoxPostMatch Members.

public interface ILockBoxPostMatch

Types that implement ILockBoxPostMatch

Type | Description
LockBoxPostRecord | This class provides the default Aptify implementation for the ILockBoxPostRecord interface

Remarks

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: ICashControlBatch (in ICashControlBatch.dll)

See Also

ILockBoxPostMatch Members | Aptify.Applications.Accounting Namespace


ILockBoxPostMatch Members

ILockBoxPostMatch overview

Public Instance Methods

Config | Call this function before using any other method on the interface to configure the object for use
PostMatch | This method is responsible for posting an individual matched cash line item in a cash control batch to the database based on the information stored in the Cash Detail GE object that is passed in

See Also

ILockBoxPostMatch Interface | Aptify.Applications.Accounting Namespace


ILockBoxPostMatch Methods

The methods of the ILockBoxPostMatch interface are listed below. For a complete list of ILockBoxPostMatch interface members, see the ILockBoxPostMatch Members topic.

Public Instance Methods

Config | Call this function before using any other method on the interface to configure the object for use
PostMatch | This method is responsible for posting an individual matched cash line item in a cash control batch to the database based on the information stored in the Cash Detail GE object that is passed in

See Also

ILockBoxPostMatch Interface | Aptify.Applications.Accounting Namespace


ILockBoxPostMatch.Config Method

Call this function before using any other method on the interface to configure the object for use

void Config(
AptifyApplication Application
);

Parameters

Application
Aptify Application Required for Use of the Object

Remarks

See Also

ILockBoxPostMatch Interface | Aptify.Applications.Accounting Namespace


ILockBoxPostMatch.PostMatch Method

This method is responsible for posting an individual matched cash line item in a cash control batch to the database based on the information stored in the Cash Detail GE object that is passed in

bool PostMatch(
AptifyGenericEntityBase CashBatchGE,
AptifyGenericEntityBase CashDetailGE,
Int32 LineNumber,
Decimal PaymentAmount
);

Parameters

CashBatchGE
CashDetailGE
LineNumber
PaymentAmount

Return Value

True if the method is succesful, False otherwise

Remarks

See Also

ILockBoxPostMatch Interface | Aptify.Applications.Accounting Namespace


InvoiceConsolidation Class

This class implements the functionality for consolidation of invoices for persons and/or companies. The class provides a type-specific set of members for direct access and also implements IProcessComponent for use with the Process Pipeline architecture.

For a list of all members of this type, see InvoiceConsolidation Members.

System.Object
InvoiceConsolidation

public class InvoiceConsolidation : IProcessComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: AptifyInvoiceConsolidation (in AptifyInvoiceConsolidation.dll)

See Also

InvoiceConsolidation Members | Aptify.Applications.Accounting Namespace


InvoiceConsolidation Members

InvoiceConsolidation overview

Public Instance Constructors

InvoiceConsolidation Constructor Initializes a new instance of the InvoiceConsolidation class.

Public Instance Properties

Application | Returns an instance of the Aptify Application object
DataAction | Retursn an instance of the Aptify DataAction object
Database | Returns the name of the database where the Decimal Types and related entities are stored
Properties |

Public Instance Methods

CanConsolidateInvoices | This method checks to see if it is possible for the given PersonID and CompanyID combination to consolidate invoices at the present time. If orders exist for the given PersonID/CompanyID combination that span multiple currencies - the following logic is used. 1) If CurrencyTypeID is provided, that CurrencyType is used 2) If CurrencyTypeID is NOT provided and AllowUI is set to True, then the user is asked to specify which Currency Type to use for the consolidation since orders/payments with different currencies can not be mixed. 3) If the AllowUI parameter is set to False, and CurrencyTypeID is not provided then the first currency found is used automatically and is returned in the CurrencyTypeID parameter as an OUT parameter value.
Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCurrentEmployeeID | Returns the current employee record assocatied with the logged in user account.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetOpenInvoices |
GetPersonCompanyPreferredCurrencyTypeID | This method returns the Preferred Currency Type ID for the person, if available, and if not, at the company level specified. If neither are set, then the system's functional currency is returned by calling the GetSystemFunctionalCurrencyTypeID() method. In a system with multiple functional currencies defined, the Functional Currency returned will be one of the Functional Currencies.
GetPersonOrderLevelID | This method returns the peron's Order Level ID stored in the Persons entity
GetPersonPaymentLevelID |
GetScalarLong | Returns a scalar long value from a SQL statement, assumes SQL statement will produce a single value in a single row
GetSystemFunctionalCurrencyTypeID | This method will return the system's functional currency, which is set by a BIT field on the Currency Types entity. In a system that has defined multiple functional currencies, this method is obsolete.
GetType (inherited from Object) | Gets the Type of the current instance.
PostConsolidationPayments | Overloaded. This method is responsible for posting the consolidation payments which will consolidate invoices(orders) together based on reapplying balances to the orders appropriately
Run | Result Codes are SUCCESS and FAILED
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

StatusUpdate

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnStatusUpdate | This method raises the StatusUpdate event and can be called by sub-classes to raise the StatusUpdate event in the base class.

See Also

InvoiceConsolidation Class | Aptify.Applications.Accounting Namespace


InvoiceConsolidation Constructor

Initializes a new instance of the InvoiceConsolidation class.

public InvoiceConsolidation();

See Also

InvoiceConsolidation Class | Aptify.Applications.Accounting Namespace


InvoiceConsolidation Properties

The properties of the InvoiceConsolidation class are listed below. For a complete list of InvoiceConsolidation class members, see the InvoiceConsolidation Members topic.

Public Instance Properties

Application | Returns an instance of the Aptify Application object
DataAction | Retursn an instance of the Aptify DataAction object
Database | Returns the name of the database where the Decimal Types and related entities are stored
Properties |

See Also

InvoiceConsolidation Class | Aptify.Applications.Accounting Namespace


Application Property

Aptify 5.0 Software Development Kit (SDK)

InvoiceConsolidation.Application Property

Returns an instance of the Aptify Application object

public virtual AptifyApplication Application {get;}

Property Value

Remarks

See Also

InvoiceConsolidation Class | Aptify.Applications.Accounting Namespace


DataAction Property

Aptify 5.0 Software Development Kit (SDK)

InvoiceConsolidation.DataAction Property

Retursn an instance of the Aptify DataAction object

public virtual DataAction DataAction {get;}

Property Value

Remarks

See Also

InvoiceConsolidation Class | Aptify.Applications.Accounting Namespace


Database Property

Aptify 5.0 Software Development Kit (SDK)

InvoiceConsolidation.Database Property

Returns the name of the database where the Decimal Types and related entities are stored

public virtual String Database {get;}

Property Value

Remarks

See Also

InvoiceConsolidation Class | Aptify.Applications.Accounting Namespace


Properties Property

Aptify 5.0 Software Development Kit (SDK)

InvoiceConsolidation.Properties Property

public AptifyProperties Properties {get;}

Implements

IProcessComponent.

See Also

InvoiceConsolidation Class | Aptify.Applications.Accounting Namespace


InvoiceConsolidation Methods

The methods of the InvoiceConsolidation class are listed below. For a complete list of InvoiceConsolidation class members, see the InvoiceConsolidation Members topic.

Public Instance Methods

CanConsolidateInvoices | This method checks to see if it is possible for the given PersonID and CompanyID combination to consolidate invoices at the present time. If orders exist for the given PersonID/CompanyID combination that span multiple currencies - the following logic is used. 1) If CurrencyTypeID is provided, that CurrencyType is used 2) If CurrencyTypeID is NOT provided and AllowUI is set to True, then the user is asked to specify which Currency Type to use for the consolidation since orders/payments with different currencies can not be mixed. 3) If the AllowUI parameter is set to False, and CurrencyTypeID is not provided then the first currency found is used automatically and is returned in the CurrencyTypeID parameter as an OUT parameter value.
Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCurrentEmployeeID | Returns the current employee record assocatied with the logged in user account.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetOpenInvoices |
GetPersonCompanyPreferredCurrencyTypeID | This method returns the Preferred Currency Type ID for the person, if available, and if not, at the company level specified. If neither are set, then the system's functional currency is returned by calling the GetSystemFunctionalCurrencyTypeID() method. In a system with multiple functional currencies defined, the Functional Currency returned will be one of the Functional Currencies.
GetPersonOrderLevelID | This method returns the peron's Order Level ID stored in the Persons entity
GetPersonPaymentLevelID |
GetScalarLong | Returns a scalar long value from a SQL statement, assumes SQL statement will produce a single value in a single row
GetSystemFunctionalCurrencyTypeID | This method will return the system's functional currency, which is set by a BIT field on the Currency Types entity. In a system that has defined multiple functional currencies, this method is obsolete.
GetType (inherited from Object) | Gets the Type of the current instance.
PostConsolidationPayments | Overloaded. This method is responsible for posting the consolidation payments which will consolidate invoices(orders) together based on reapplying balances to the orders appropriately
Run | Result Codes are SUCCESS and FAILED
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnStatusUpdate | This method raises the StatusUpdate event and can be called by sub-classes to raise the StatusUpdate event in the base class.

See Also

InvoiceConsolidation Class | Aptify.Applications.Accounting Namespace


InvoiceConsolidation.CanConsolidateInvoices Method

This method checks to see if it is possible for the given PersonID and CompanyID combination to consolidate invoices at the present time. If orders exist for the given PersonID/CompanyID combination that span multiple currencies - the following logic is used. 1) If CurrencyTypeID is provided, that CurrencyType is used 2) If CurrencyTypeID is NOT provided and AllowUI is set to True, then the user is asked to specify which Currency Type to use for the consolidation since orders/payments with different currencies can not be mixed. 3) If the AllowUI parameter is set to False, and CurrencyTypeID is not provided then the first currency found is used automatically and is returned in the CurrencyTypeID parameter as an OUT parameter value.

public virtual bool CanConsolidateInvoices(
Int64 PersonID,
Int64 CompanyID,
ref Int64& CurrencyTypeID,
Boolean AllowUI,
ref String& ErrorMessage
);

Parameters

PersonID
CompanyID
CurrencyTypeID
AllowUI
ErrorMessage

Return Value

Remarks

See Also

InvoiceConsolidation Class | Aptify.Applications.Accounting Namespace


InvoiceConsolidation.Config Method

public virtual void Config(
AptifyApplication Application
);

Implements

IProcessComponent.

See Also

InvoiceConsolidation Class | Aptify.Applications.Accounting Namespace


InvoiceConsolidation.GetCurrentEmployeeID Method

Returns the current employee record assocatied with the logged in user account.

public virtual long GetCurrentEmployeeID();

Return Value

Remarks

See Also

InvoiceConsolidation Class | Aptify.Applications.Accounting Namespace


InvoiceConsolidation.GetOpenInvoices Method

public virtual bool GetOpenInvoices(
Int64 PersonID,
Int64 CurrencyTypeID,
ref List`1& CreditOrders,
ref List`1& UnpaidOrders,
ref Decimal& AvailableCredit
);

See Also

InvoiceConsolidation Class | Aptify.Applications.Accounting Namespace


InvoiceConsolidation.GetPersonCompanyPreferredCurrencyTypeID Method

This method returns the Preferred Currency Type ID for the person, if available, and if not, at the company level specified. If neither are set, then the system's functional currency is returned by calling the GetSystemFunctionalCurrencyTypeID() method. In a system with multiple functional currencies defined, the Functional Currency returned will be one of the Functional Currencies.

public virtual long GetPersonCompanyPreferredCurrencyTypeID(
Int64 PersonID,
Int64 CompanyID
);

Parameters

PersonID
CompanyID

Return Value

Remarks

See Also

InvoiceConsolidation Class | Aptify.Applications.Accounting Namespace


InvoiceConsolidation.GetPersonOrderLevelID Method

This method returns the peron's Order Level ID stored in the Persons entity

public virtual long GetPersonOrderLevelID(
Int64 PersonID
);

Parameters

PersonID

Return Value

Remarks

See Also

InvoiceConsolidation Class | Aptify.Applications.Accounting Namespace


InvoiceConsolidation.GetPersonPaymentLevelID Method

public virtual long GetPersonPaymentLevelID(
Int64 PersonID
);

See Also

InvoiceConsolidation Class | Aptify.Applications.Accounting Namespace


InvoiceConsolidation.GetScalarLong Method

Returns a scalar long value from a SQL statement, assumes SQL statement will produce a single value in a single row

public virtual long GetScalarLong(
String SQL,
IAptifyDataAction.DSLCacheSetting CacheSetting,
Int64 DefaultValue
);

Parameters

SQL
SQL Statement to Execute
CacheSetting
Cache Setting To Use
DefaultValue
Default Value to Return if Query Fails or Returns No Value

Return Value

Remarks

See Also

InvoiceConsolidation Class | Aptify.Applications.Accounting Namespace


InvoiceConsolidation.GetSystemFunctionalCurrencyTypeID Method

This method will return the system's functional currency, which is set by a BIT field on the Currency Types entity. In a system that has defined multiple functional currencies, this method is obsolete.

public virtual long GetSystemFunctionalCurrencyTypeID();

Return Value

Remarks

See Also

InvoiceConsolidation Class | Aptify.Applications.Accounting Namespace


InvoiceConsolidation.OnStatusUpdate Method

This method raises the StatusUpdate event and can be called by sub-classes to raise the StatusUpdate event in the base class.

protected virtual void OnStatusUpdate(
String Message,
Int64 RecordNumber,
Int64 TotalRecords,
Int32 PercentComplete,
ref Boolean& Cancel
);

Parameters

Message
RecordNumber
TotalRecords
PercentComplete
Cancel

Remarks

See Also

InvoiceConsolidation Class | Aptify.Applications.Accounting Namespace


PostConsolidationPayments Method

Aptify 5.0 Software Development Kit (SDK)

InvoiceConsolidation.PostConsolidationPayments Method

This method is responsible for posting the consolidation payments which will consolidate invoices(orders) together based on reapplying balances to the orders appropriately

Overload List

This method is responsible for posting the consolidation payments which will consolidate invoices(orders) together based on reapplying balances to the orders appropriately

public virtual bool PostConsolidationPayments(List<T>,Int64,Int64,DateTime,Int64,ref Int64&,ref String&);

This method is responsible for posting the consolidation payments which will consolidate invoices(orders) together based on reapplying balances to the orders appropriately

public virtual bool PostConsolidationPayments(List<T>,Int64,Int64,Int64,ref Int64&,ref String&);

See Also

InvoiceConsolidation Class | Aptify.Applications.Accounting Namespace


InvoiceConsolidation.PostConsolidationPayments Method (List<T>, Int64, Int64, DateTime, Int64, Int64&, String&)

This method is responsible for posting the consolidation payments which will consolidate invoices(orders) together based on reapplying balances to the orders appropriately

public virtual bool PostConsolidationPayments(
List<T> OrdersToConsolidate,
Int64 PersonID,
Int64 CompanyID,
DateTime EffectiveDate,
Int64 CurrencyTypeID,
ref Int64& EmployeeID,
ref String& ErrorMessage
);

Parameters

OrdersToConsolidate
PersonID
CompanyID
EffectiveDate
CurrencyTypeID
EmployeeID
If not provided, the GetCurrentEmployeeID() method is called to retrieve the Employee ID for the currently logged in user. The current employee ID is passed back through this parameter as well
ErrorMessage

Return Value

True if successful, False otherwise

Remarks

See Also

InvoiceConsolidation Class | Aptify.Applications.Accounting Namespace | InvoiceConsolidation.PostConsolidationPayments Overload List


InvoiceConsolidation.PostConsolidationPayments Method (List<T>, Int64, Int64, Int64, Int64&, String&)

This method is responsible for posting the consolidation payments which will consolidate invoices(orders) together based on reapplying balances to the orders appropriately

public virtual bool PostConsolidationPayments(
List<T> OrdersToConsolidate,
Int64 PersonID,
Int64 CompanyID,
Int64 CurrencyTypeID,
ref Int64& EmployeeID,
ref String& ErrorMessage
);

Parameters

OrdersToConsolidate
PersonID
CompanyID
CurrencyTypeID
EmployeeID
If not proviced, the GetCurrentEmployeeID() method is called to retrieve the Employee ID for the currently logged in user. The current employee ID is passed back through this parameter as well
ErrorMessage

Return Value

True if successful, False otherwise

Remarks

See Also

InvoiceConsolidation Class | Aptify.Applications.Accounting Namespace | InvoiceConsolidation.PostConsolidationPayments Overload List


InvoiceConsolidation.Run Method

Result Codes are SUCCESS and FAILED

public string Run();

Return Value

Implements

IProcessComponent.

Remarks

See Also

InvoiceConsolidation Class | Aptify.Applications.Accounting Namespace


InvoiceConsolidation Events

The events of the InvoiceConsolidation class are listed below. For a complete list of InvoiceConsolidation class members, see the InvoiceConsolidation Members topic.

Public Instance Events

StatusUpdate

See Also

InvoiceConsolidation Class | Aptify.Applications.Accounting Namespace


InvoiceConsolidation.InvoiceConsolidation.StatusUpdateEventHandler Event

public event InvoiceConsolidation.StatusUpdateEventHandler StatusUpdate;

See Also

InvoiceConsolidation Class | Aptify.Applications.Accounting Namespace


InvoiceConsolidation.CreditOrderInfo Class

For a list of all members of this type, see InvoiceConsolidation.CreditOrderInfo Members.

System.Object
InvoiceConsolidation.CreditOrderInfo

public class InvoiceConsolidation.CreditOrderInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: AptifyInvoiceConsolidation (in AptifyInvoiceConsolidation.dll)

See Also

InvoiceConsolidation.CreditOrderInfo Members | Aptify.Applications.Accounting Namespace


InvoiceConsolidation.CreditOrderInfo Members

InvoiceConsolidation.CreditOrderInfo overview

Public Instance Constructors

InvoiceConsolidation.CreditOrderInfo Constructor

Public Instance Fields

Allocated
Balance
ID
OrderDate

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

InvoiceConsolidation.CreditOrderInfo Class | Aptify.Applications.Accounting Namespace


InvoiceConsolidation.CreditOrderInfo Constructor

public InvoiceConsolidation.CreditOrderInfo(
Int64 ID,
DateTime OrderDate,
Decimal Balance,
Decimal Allocated
);

See Also

InvoiceConsolidation.CreditOrderInfo Class | Aptify.Applications.Accounting Namespace


InvoiceConsolidation.CreditOrderInfo Fields

The fields of the InvoiceConsolidation.CreditOrderInfo class are listed below. For a complete list of InvoiceConsolidation.CreditOrderInfo class members, see the InvoiceConsolidation.CreditOrderInfo Members topic.

Public Instance Fields

Allocated
Balance
ID
OrderDate

See Also

InvoiceConsolidation.CreditOrderInfo Class | Aptify.Applications.Accounting Namespace


InvoiceConsolidation.CreditOrderInfo.Allocated Field

public Allocated Allocated;

See Also

InvoiceConsolidation.CreditOrderInfo Class | Aptify.Applications.Accounting Namespace


InvoiceConsolidation.CreditOrderInfo.Balance Field

public Balance Balance;

See Also

InvoiceConsolidation.CreditOrderInfo Class | Aptify.Applications.Accounting Namespace


InvoiceConsolidation.CreditOrderInfo.ID Field

public ID ID;

See Also

InvoiceConsolidation.CreditOrderInfo Class | Aptify.Applications.Accounting Namespace


InvoiceConsolidation.CreditOrderInfo.OrderDate Field

public OrderDate OrderDate;

See Also

InvoiceConsolidation.CreditOrderInfo Class | Aptify.Applications.Accounting Namespace


InvoiceConsolidation.OrderInfo Class

For a list of all members of this type, see InvoiceConsolidation.OrderInfo Members.

System.Object
InvoiceConsolidation.OrderInfo

public class InvoiceConsolidation.OrderInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: AptifyInvoiceConsolidation (in AptifyInvoiceConsolidation.dll)

See Also

InvoiceConsolidation.OrderInfo Members | Aptify.Applications.Accounting Namespace


InvoiceConsolidation.OrderInfo Members

InvoiceConsolidation.OrderInfo overview

Public Instance Constructors

InvoiceConsolidation.OrderInfo Constructor

Public Instance Fields

Balance
DueDate
ID
Transfer
TransferTotal

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

InvoiceConsolidation.OrderInfo Class | Aptify.Applications.Accounting Namespace


InvoiceConsolidation.OrderInfo Constructor

public InvoiceConsolidation.OrderInfo(
Int64 ID,
DateTime DueDate,
Decimal Balance
);

See Also

InvoiceConsolidation.OrderInfo Class | Aptify.Applications.Accounting Namespace


InvoiceConsolidation.OrderInfo Fields

The fields of the InvoiceConsolidation.OrderInfo class are listed below. For a complete list of InvoiceConsolidation.OrderInfo class members, see the InvoiceConsolidation.OrderInfo Members topic.

Public Instance Fields

Balance
DueDate
ID
Transfer
TransferTotal

See Also

InvoiceConsolidation.OrderInfo Class | Aptify.Applications.Accounting Namespace


InvoiceConsolidation.OrderInfo.Balance Field

public Balance Balance;

See Also

InvoiceConsolidation.OrderInfo Class | Aptify.Applications.Accounting Namespace


InvoiceConsolidation.OrderInfo.DueDate Field

public DueDate DueDate;

See Also

InvoiceConsolidation.OrderInfo Class | Aptify.Applications.Accounting Namespace


InvoiceConsolidation.OrderInfo.ID Field

public ID ID;

See Also

InvoiceConsolidation.OrderInfo Class | Aptify.Applications.Accounting Namespace


InvoiceConsolidation.OrderInfo.Transfer Field

public Transfer Transfer;

See Also

InvoiceConsolidation.OrderInfo Class | Aptify.Applications.Accounting Namespace


InvoiceConsolidation.OrderInfo.TransferTotal Field

public TransferTotal TransferTotal;

See Also

InvoiceConsolidation.OrderInfo Class | Aptify.Applications.Accounting Namespace


InvoiceConsolidation.StatusUpdateEventHandler Delegate

public delegate void InvoiceConsolidation.StatusUpdateEventHandler(
String Message,
Int64 RecordNumber,
Int64 TotalRecords,
Int32 PercentComplete,
ref Boolean& Cancel
);

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: AptifyInvoiceConsolidation (in AptifyInvoiceConsolidation.dll)

See Also

Aptify.Applications.Accounting Namespace


InvoiceConsolidation.TransferInfo Class

For a list of all members of this type, see InvoiceConsolidation.TransferInfo Members.

System.Object
InvoiceConsolidation.TransferInfo

public class InvoiceConsolidation.TransferInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: AptifyInvoiceConsolidation (in AptifyInvoiceConsolidation.dll)

See Also

InvoiceConsolidation.TransferInfo Members | Aptify.Applications.Accounting Namespace


InvoiceConsolidation.TransferInfo Members

InvoiceConsolidation.TransferInfo overview

Public Instance Constructors

InvoiceConsolidation.TransferInfo Constructor Initializes a new instance of the InvoiceConsolidation.TransferInfo class.

Public Instance Fields

Amount
CreditOrderID
PaymentID

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

InvoiceConsolidation.TransferInfo Class | Aptify.Applications.Accounting Namespace


InvoiceConsolidation.TransferInfo Constructor

Initializes a new instance of the InvoiceConsolidation.TransferInfo class.

public InvoiceConsolidation.TransferInfo();

See Also

InvoiceConsolidation.TransferInfo Class | Aptify.Applications.Accounting Namespace


InvoiceConsolidation.TransferInfo Fields

The fields of the InvoiceConsolidation.TransferInfo class are listed below. For a complete list of InvoiceConsolidation.TransferInfo class members, see the InvoiceConsolidation.TransferInfo Members topic.

Public Instance Fields

Amount
CreditOrderID
PaymentID

See Also

InvoiceConsolidation.TransferInfo Class | Aptify.Applications.Accounting Namespace


InvoiceConsolidation.TransferInfo.Amount Field

public Amount Amount;

See Also

InvoiceConsolidation.TransferInfo Class | Aptify.Applications.Accounting Namespace


InvoiceConsolidation.TransferInfo.CreditOrderID Field

public CreditOrderID CreditOrderID;

See Also

InvoiceConsolidation.TransferInfo Class | Aptify.Applications.Accounting Namespace


InvoiceConsolidation.TransferInfo.PaymentID Field

public PaymentID PaymentID;

See Also

InvoiceConsolidation.TransferInfo Class | Aptify.Applications.Accounting Namespace


InvoiceConsolidationWizard Class

User Interface Wizard for consolidation of invoices/payments/balances on an account. This wizard uses the InvoiceConsolidation object to perform the business logic for the user's selections.

For a list of all members of this type, see InvoiceConsolidationWizard Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
InvoiceConsolidationWizard

public class InvoiceConsolidationWizard : Form, IAptifyAction

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: AptifyInvoiceConsolidationWizard (in AptifyInvoiceConsolidationWizard.dll)

See Also

InvoiceConsolidationWizard Members | Aptify.Applications.Accounting Namespace


InvoiceConsolidationWizard Members

InvoiceConsolidationWizard overview

Public Instance Constructors

InvoiceConsolidationWizard Constructor Initializes a new instance of the InvoiceConsolidationWizard class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoAction | Overloaded.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

InvoiceConsolidationWizard Class | Aptify.Applications.Accounting Namespace


InvoiceConsolidationWizard Constructor

Initializes a new instance of the InvoiceConsolidationWizard class.

public InvoiceConsolidationWizard();

See Also

InvoiceConsolidationWizard Class | Aptify.Applications.Accounting Namespace


InvoiceConsolidationWizard Methods

The methods of the InvoiceConsolidationWizard class are listed below. For a complete list of InvoiceConsolidationWizard class members, see the InvoiceConsolidationWizard Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoAction | Overloaded.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

InvoiceConsolidationWizard Class | Aptify.Applications.Accounting Namespace


InvoiceConsolidationWizard.ApplySkin Method

protected virtual void ApplySkin();

See Also

InvoiceConsolidationWizard Class | Aptify.Applications.Accounting Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

InvoiceConsolidationWizard.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

InvoiceConsolidationWizard Class | Aptify.Applications.Accounting Namespace


InvoiceConsolidationWizard.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

InvoiceConsolidationWizard Class | Aptify.Applications.Accounting Namespace | InvoiceConsolidationWizard.Dispose Overload List


DoAction Method

Aptify 5.0 Software Development Kit (SDK)

InvoiceConsolidationWizard.DoAction Method

Overload List

public void DoAction(AptifyApplication,Int64);

public void DoAction(AptifyApplication,Int64,Int64);

public void DoAction(AptifyApplication,Int64,Int64,params Object[]);

public void DoAction(AptifyApplication,Int64,params String[]);

See Also

InvoiceConsolidationWizard Class | Aptify.Applications.Accounting Namespace


InvoiceConsolidationWizard.DoAction Method (AptifyApplication, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID
);

Implements

IAptifyAction.

See Also

InvoiceConsolidationWizard Class | Aptify.Applications.Accounting Namespace | InvoiceConsolidationWizard.DoAction Overload List


InvoiceConsolidationWizard.DoAction Method (AptifyApplication, Int64, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID
);

Implements

IAptifyAction.

See Also

InvoiceConsolidationWizard Class | Aptify.Applications.Accounting Namespace | InvoiceConsolidationWizard.DoAction Overload List


InvoiceConsolidationWizard.DoAction Method (AptifyApplication, Int64, Int64, Object[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID,
params Object[] SelectedItems
);

Implements

IAptifyAction.

See Also

InvoiceConsolidationWizard Class | Aptify.Applications.Accounting Namespace | InvoiceConsolidationWizard.DoAction Overload List


InvoiceConsolidationWizard.DoAction Method (AptifyApplication, Int64, String[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
params String[] SelectedItems
);

Implements

IAptifyAction.

See Also

InvoiceConsolidationWizard Class | Aptify.Applications.Accounting Namespace | InvoiceConsolidationWizard.DoAction Overload List


ISalesTaxRate Interface

Interface used to create plug-ins for setting sales tax rates for orders

For a list of all members of this type, see ISalesTaxRate Members.

public interface ISalesTaxRate

Types that implement ISalesTaxRate

Type | Description
SalesTaxRate | This object implements the Aptify.Framework.Applications.Accounting.ISalesTaxRate interface. The purpose of this component is to return a tax rate for a given set of input parameters base currency id.

Remarks

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: ISalesTaxRate (in ISalesTaxRate.dll)

See Also

ISalesTaxRate Members | Aptify.Applications.Accounting Namespace


ISalesTaxRate Members

ISalesTaxRate overview

Public Instance Methods

Config |
GetCountyFromPostalCode | This function simply wraps the AddressInfo class in Aptify 4+ which now provides the functionality to return county (and other address information) based on postal code data
GetSalesTaxRate | Overloaded.
IsCompanyTaxExempt |
IsPersonTaxExempt |
SetSalesTaxRate |

See Also

ISalesTaxRate Interface | Aptify.Applications.Accounting Namespace


ISalesTaxRate Methods

The methods of the ISalesTaxRate interface are listed below. For a complete list of ISalesTaxRate interface members, see the ISalesTaxRate Members topic.

Public Instance Methods

Config |
GetCountyFromPostalCode | This function simply wraps the AddressInfo class in Aptify 4+ which now provides the functionality to return county (and other address information) based on postal code data
GetSalesTaxRate | Overloaded.
IsCompanyTaxExempt |
IsPersonTaxExempt |
SetSalesTaxRate |

See Also

ISalesTaxRate Interface | Aptify.Applications.Accounting Namespace


ISalesTaxRate.Config Method

void Config(
AptifyApplication Application
);

See Also

ISalesTaxRate Interface | Aptify.Applications.Accounting Namespace


ISalesTaxRate.GetCountyFromPostalCode Method

This function simply wraps the AddressInfo class in Aptify 4+ which now provides the functionality to return county (and other address information) based on postal code data

string GetCountyFromPostalCode(
String PostalCode,
String ISOCountryCode
);

Parameters

PostalCode
ISOCountryCode

Return Value

Remarks

See Also

ISalesTaxRate Interface | Aptify.Applications.Accounting Namespace


GetSalesTaxRate Method

Aptify 5.0 Software Development Kit (SDK)

ISalesTaxRate.GetSalesTaxRate Method

Overload List

bool GetSalesTaxRate(Int64,ref Boolean&,ref Int64&,ref Single&);

bool GetSalesTaxRate(Int64,Int64,Int64,ref Boolean&,ref Int64&,ref Single&);

bool GetSalesTaxRate(Int64,Int64,Int64,ref Int64&,ref Single&);

bool GetSalesTaxRate(Int64,ref Int64&,ref Single&);

bool GetSalesTaxRate(String,String,String,String,String,ref Boolean&,ref Int64&,ref Single&);

bool GetSalesTaxRate(String,String,String,String,String,Int64,Int64,ref Boolean&,ref Int64&,ref Single&);

bool GetSalesTaxRate(String,String,String,String,String,Int64,Int64,ref Int64&,ref Single&);

bool GetSalesTaxRate(String,String,String,String,String,ref Int64&,ref Single&);

See Also

ISalesTaxRate Interface | Aptify.Applications.Accounting Namespace


ISalesTaxRate.GetSalesTaxRate Method (Int64, Boolean&, Int64&, Single&)

bool GetSalesTaxRate(
Int64 AddressID,
ref Boolean& TaxExempt,
ref Int64& TaxRateID,
ref Single& Rate
);

See Also

ISalesTaxRate Interface | Aptify.Applications.Accounting Namespace | ISalesTaxRate.GetSalesTaxRate Overload List


ISalesTaxRate.GetSalesTaxRate Method (Int64, Int64, Int64, Boolean&, Int64&, Single&)

bool GetSalesTaxRate(
Int64 AddressID,
Int64 BillToCompanyID,
Int64 BillToPersonID,
ref Boolean& TaxExempt,
ref Int64& TaxRateID,
ref Single& Rate
);

See Also

ISalesTaxRate Interface | Aptify.Applications.Accounting Namespace | ISalesTaxRate.GetSalesTaxRate Overload List


ISalesTaxRate.GetSalesTaxRate Method (Int64, Int64, Int64, Int64&, Single&)

bool GetSalesTaxRate(
Int64 AddressID,
Int64 BillToCompanyID,
Int64 BillToPersonID,
ref Int64& TaxRateID,
ref Single& Rate
);

See Also

ISalesTaxRate Interface | Aptify.Applications.Accounting Namespace | ISalesTaxRate.GetSalesTaxRate Overload List


ISalesTaxRate.GetSalesTaxRate Method (Int64, Int64&, Single&)

bool GetSalesTaxRate(
Int64 AddressID,
ref Int64& TaxRateID,
ref Single& Rate
);

See Also

ISalesTaxRate Interface | Aptify.Applications.Accounting Namespace | ISalesTaxRate.GetSalesTaxRate Overload List


ISalesTaxRate.GetSalesTaxRate Method (String, String, String, String, String, Boolean&, Int64&, Single&)

bool GetSalesTaxRate(
String PostalCode,
String City,
String StateProvince,
String County,
String ISOCountryCode,
ref Boolean& TaxExempt,
ref Int64& TaxRateID,
ref Single& Rate
);

See Also

ISalesTaxRate Interface | Aptify.Applications.Accounting Namespace | ISalesTaxRate.GetSalesTaxRate Overload List


ISalesTaxRate.GetSalesTaxRate Method (String, String, String, String, String, Int64, Int64, Boolean&, Int64&, Single&)

bool GetSalesTaxRate(
String PostalCode,
String City,
String StateProvince,
String County,
String ISOCountryCode,
Int64 BillToCompanyID,
Int64 BillToPersonID,
ref Boolean& TaxExempt,
ref Int64& TaxRateID,
ref Single& Rate
);

See Also

ISalesTaxRate Interface | Aptify.Applications.Accounting Namespace | ISalesTaxRate.GetSalesTaxRate Overload List


ISalesTaxRate.GetSalesTaxRate Method (String, String, String, String, String, Int64, Int64, Int64&, Single&)

bool GetSalesTaxRate(
String PostalCode,
String City,
String StateProvince,
String County,
String ISOCountryCode,
Int64 BillToCompanyID,
Int64 BillToPersonID,
ref Int64& TaxRateID,
ref Single& Rate
);

See Also

ISalesTaxRate Interface | Aptify.Applications.Accounting Namespace | ISalesTaxRate.GetSalesTaxRate Overload List


ISalesTaxRate.GetSalesTaxRate Method (String, String, String, String, String, Int64&, Single&)

bool GetSalesTaxRate(
String PostalCode,
String City,
String StateProvince,
String County,
String ISOCountryCode,
ref Int64& TaxRateID,
ref Single& Rate
);

See Also

ISalesTaxRate Interface | Aptify.Applications.Accounting Namespace | ISalesTaxRate.GetSalesTaxRate Overload List


ISalesTaxRate.IsCompanyTaxExempt Method

bool IsCompanyTaxExempt(
Int64 CompanyID,
String City,
String StateProvince,
String County,
String PostalCode,
String ISOCountryCode
);

See Also

ISalesTaxRate Interface | Aptify.Applications.Accounting Namespace


ISalesTaxRate.IsPersonTaxExempt Method

bool IsPersonTaxExempt(
Int64 PersonID,
String City,
String StateProvince,
String County,
String PostalCode,
String ISOCountryCode
);

See Also

ISalesTaxRate Interface | Aptify.Applications.Accounting Namespace


ISalesTaxRate.SetSalesTaxRate Method

bool SetSalesTaxRate(
AptifyGenericEntityBase OrderGE
);

See Also

ISalesTaxRate Interface | Aptify.Applications.Accounting Namespace


IStandingOrder Interface

Interface used to create plug-ins for standing order processes

For a list of all members of this type, see IStandingOrder Members.

public interface IStandingOrder

Types that implement IStandingOrder

Type | Description
StandingOrdersEntity |

Remarks

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: IStandingOrder (in IStandingOrder.dll)

See Also

IStandingOrder Members | Aptify.Applications.Accounting Namespace


IStandingOrder Members

IStandingOrder overview

Public Instance Methods

ExpandSchedule | Overloaded. This function is used to generate a schedule for the standing order and is only application for those standing orders where the Type is set to Frequency. For standing orders that are version based, this method will have no impact and throw an exception
FillStandingOrder | This function will fill the standing order specified based on the information in the standing order that is passed in as a parameter. The function returns True/False based on the success of the operation and returns the ID of the Order created by the process in the OrderID OUT parameter

See Also

IStandingOrder Interface | Aptify.Applications.Accounting Namespace


IStandingOrder Methods

The methods of the IStandingOrder interface are listed below. For a complete list of IStandingOrder interface members, see the IStandingOrder Members topic.

Public Instance Methods

ExpandSchedule | Overloaded. This function is used to generate a schedule for the standing order and is only application for those standing orders where the Type is set to Frequency. For standing orders that are version based, this method will have no impact and throw an exception
FillStandingOrder | This function will fill the standing order specified based on the information in the standing order that is passed in as a parameter. The function returns True/False based on the success of the operation and returns the ID of the Order created by the process in the OrderID OUT parameter

See Also

IStandingOrder Interface | Aptify.Applications.Accounting Namespace


ExpandSchedule Method

Aptify 5.0 Software Development Kit (SDK)

IStandingOrder.ExpandSchedule Method

This function is used to generate a schedule for the standing order and is only application for those standing orders where the Type is set to Frequency. For standing orders that are version based, this method will have no impact and throw an exception

Overload List

This function is used to generate a schedule for the standing order and is only application for those standing orders where the Type is set to Frequency. For standing orders that are version based, this method will have no impact and throw an exception

bool ExpandSchedule(AptifyGenericEntityBase);

This function is used to generate a schedule for the standing order and is only application for those standing orders where the Type is set to Frequency. For standing orders that are version based, this method will have no impact and throw an exception

bool ExpandSchedule(Int64);

See Also

IStandingOrder Interface | Aptify.Applications.Accounting Namespace


IStandingOrder.ExpandSchedule Method (AptifyGenericEntityBase)

This function is used to generate a schedule for the standing order and is only application for those standing orders where the Type is set to Frequency. For standing orders that are version based, this method will have no impact and throw an exception

bool ExpandSchedule(
AptifyGenericEntityBase StandingOrderGE
);

Parameters

StandingOrderGE
GE Object for the Standing Order

Return Value

True if the operation is a success, False otherwise

Remarks

See Also

IStandingOrder Interface | Aptify.Applications.Accounting Namespace | IStandingOrder.ExpandSchedule Overload List


IStandingOrder.ExpandSchedule Method (Int64)

This function is used to generate a schedule for the standing order and is only application for those standing orders where the Type is set to Frequency. For standing orders that are version based, this method will have no impact and throw an exception

bool ExpandSchedule(
Int64 StandingOrderID
);

Parameters

StandingOrderID
ID number of the standing order to expand

Return Value

True if the operation is a success, False otherwise

Remarks

See Also

IStandingOrder Interface | Aptify.Applications.Accounting Namespace | IStandingOrder.ExpandSchedule Overload List


IStandingOrder.FillStandingOrder Method

This function will fill the standing order specified based on the information in the standing order that is passed in as a parameter. The function returns True/False based on the success of the operation and returns the ID of the Order created by the process in the OrderID OUT parameter

bool FillStandingOrder(
DateTime OrderDate,
Int64 StandingOrderID,
ref Int64& OrderID
);

Parameters

OrderDate
Date to be used for the OrderDate field in the new order being created
StandingOrderID
Standing Order to Fill
OrderID
OUT parameter - returns the Order ID created by this operation

Return Value

True if the operation is a success, False otherwise

Remarks

See Also

IStandingOrder Interface | Aptify.Applications.Accounting Namespace


LockBoxAllocProducts Class

This class provides the default implmentation of the ILockBoxAllocQuery interface for the lock box architecture. It is possible to sub-class this class and override its various members to provide the specific functionality required for an implementation of the lock box architecture that requires different logic in this area of the system. Alternatively, it is also possible to build a new class that also implements ILockBoxAllocQuery and to plug in that entirely new class as well into the architecture using the meta-data attributes in the Cash Control Batches entity.

For a list of all members of this type, see LockBoxAllocProducts Members.

System.Object
LockBoxBase
LockBoxAllocProducts

public class LockBoxAllocProducts : LockBoxBase, ILockBoxAllocQuery

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: AptifyCashControlBatch (in AptifyCashControlBatch.dll)

See Also

LockBoxAllocProducts Members | Aptify.Applications.Accounting Namespace


LockBoxAllocProducts Members

LockBoxAllocProducts overview

Public Instance Constructors

LockBoxAllocProducts Constructor Initializes a new instance of the LockBoxAllocProducts class.

Public Instance Properties

Application (inherited from LockBoxBase) | Aptify Application Instance (only available after Config() is called)
DataAction (inherited from LockBoxBase) | Aptify Data Action Instance (only available after Config() is called)
Database (inherited from LockBoxBase) | Base Database for Lock Box Application Entities (derived from Base Database of Cash Control Batches entity) (only available after Config() is called)

Public Instance Methods

Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAllocProducts | This function is responsible for returning a List of the Product ID values that are acceptable for use for allocation of over-payments that are made during the exception processing cycle of the lock box application. The default implementation of this method calls the GetAllocProductSQL() method which can be overriden, and that method is responsible for providing a SQL statement that returns a set of ID values from the Products entity that are acceptable for use in allocating overpayments
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetSQLIntegerValue (inherited from LockBoxBase) | This is a utility method that returns the value of any SQL statement scalar value and casts it to a Integer type
GetSQLStringValue (inherited from LockBoxBase) | This is a utility method that returns the value of any SQL statement scalar value and casts it to a String type
GetSQLValue (inherited from LockBoxBase) | This is a utility method that returns the value of any SQL statement scalar value as a default Object type
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAllocProductSQL | This method is responsible for returning a list of the products that are acceptable for use in allocating overpayments in the lock-box process. The default implementation of this method simply executes the spGetAllocProducts stored procedure that is in the database. Override this method to alter the SQL that is used to generate the list of acceptable allocation products for overpayment in the lock-box process
GetCurrentEmployeeID (inherited from LockBoxBase) | Returns the ID value from the Employees entity that matches the Current logged in user based on the provided User credentials (Uses Entity Record Relations via the spGetCurrentEmployeeID)
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LockBoxAllocProducts Class | Aptify.Applications.Accounting Namespace


LockBoxAllocProducts Constructor

Initializes a new instance of the LockBoxAllocProducts class.

public LockBoxAllocProducts();

See Also

LockBoxAllocProducts Class | Aptify.Applications.Accounting Namespace


LockBoxAllocProducts Methods

The methods of the LockBoxAllocProducts class are listed below. For a complete list of LockBoxAllocProducts class members, see the LockBoxAllocProducts Members topic.

Public Instance Methods

Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAllocProducts | This function is responsible for returning a List of the Product ID values that are acceptable for use for allocation of over-payments that are made during the exception processing cycle of the lock box application. The default implementation of this method calls the GetAllocProductSQL() method which can be overriden, and that method is responsible for providing a SQL statement that returns a set of ID values from the Products entity that are acceptable for use in allocating overpayments
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetSQLIntegerValue (inherited from LockBoxBase) | This is a utility method that returns the value of any SQL statement scalar value and casts it to a Integer type
GetSQLStringValue (inherited from LockBoxBase) | This is a utility method that returns the value of any SQL statement scalar value and casts it to a String type
GetSQLValue (inherited from LockBoxBase) | This is a utility method that returns the value of any SQL statement scalar value as a default Object type
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAllocProductSQL | This method is responsible for returning a list of the products that are acceptable for use in allocating overpayments in the lock-box process. The default implementation of this method simply executes the spGetAllocProducts stored procedure that is in the database. Override this method to alter the SQL that is used to generate the list of acceptable allocation products for overpayment in the lock-box process
GetCurrentEmployeeID (inherited from LockBoxBase) | Returns the ID value from the Employees entity that matches the Current logged in user based on the provided User credentials (Uses Entity Record Relations via the spGetCurrentEmployeeID)
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LockBoxAllocProducts Class | Aptify.Applications.Accounting Namespace


LockBoxAllocProducts.Config Method

public override void Config(
AptifyApplication Application
);

Implements

ILockBoxAllocQuery.

See Also

LockBoxAllocProducts Class | Aptify.Applications.Accounting Namespace


LockBoxAllocProducts.GetAllocProducts Method

This function is responsible for returning a List of the Product ID values that are acceptable for use for allocation of over-payments that are made during the exception processing cycle of the lock box application. The default implementation of this method calls the GetAllocProductSQL() method which can be overriden, and that method is responsible for providing a SQL statement that returns a set of ID values from the Products entity that are acceptable for use in allocating overpayments

public List<T> GetAllocProducts();

Return Value

Implements

ILockBoxAllocQuery.

Remarks

See Also

LockBoxAllocProducts Class | Aptify.Applications.Accounting Namespace


LockBoxAllocProducts.GetAllocProductSQL Method

This method is responsible for returning a list of the products that are acceptable for use in allocating overpayments in the lock-box process. The default implementation of this method simply executes the spGetAllocProducts stored procedure that is in the database. Override this method to alter the SQL that is used to generate the list of acceptable allocation products for overpayment in the lock-box process

protected virtual string GetAllocProductSQL();

Return Value

A valid SQL statement that returns a list of ID values from the Products Entity

Remarks

See Also

LockBoxAllocProducts Class | Aptify.Applications.Accounting Namespace


LockBoxBase Class

This is a base class that is used as a generic base layer for all of the other lock-box application classes that are in this assembly. It provides some generalized functionality for managing Aptify application objects, database names, and data actions to simplify the programming of sub-classes. This class is marked as MustInherit since by itself it doesn't provide a set of functional capabilities that can be directly used by a consumer of the class

For a list of all members of this type, see LockBoxBase Members.

System.Object
LockBoxBase
LockBoxAllocProducts
LockBoxImportBase
LockBoxMatch
LockBoxPost
LockBoxPostRecord

public class LockBoxBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: AptifyCashControlBatch (in AptifyCashControlBatch.dll)

See Also

LockBoxBase Members | Aptify.Applications.Accounting Namespace


LockBoxBase Members

LockBoxBase overview

Public Instance Constructors

LockBoxBase Constructor Initializes a new instance of the LockBoxBase class.

Public Instance Properties

Application | Aptify Application Instance (only available after Config() is called)
DataAction | Aptify Data Action Instance (only available after Config() is called)
Database | Base Database for Lock Box Application Entities (derived from Base Database of Cash Control Batches entity) (only available after Config() is called)

Public Instance Methods

Config | This method must be called before any other member of this class is accessed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetSQLIntegerValue | This is a utility method that returns the value of any SQL statement scalar value and casts it to a Integer type
GetSQLStringValue | This is a utility method that returns the value of any SQL statement scalar value and casts it to a String type
GetSQLValue | This is a utility method that returns the value of any SQL statement scalar value as a default Object type
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetCurrentEmployeeID | Returns the ID value from the Employees entity that matches the Current logged in user based on the provided User credentials (Uses Entity Record Relations via the spGetCurrentEmployeeID)
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LockBoxBase Class | Aptify.Applications.Accounting Namespace


LockBoxBase Constructor

Initializes a new instance of the LockBoxBase class.

public LockBoxBase();

See Also

LockBoxBase Class | Aptify.Applications.Accounting Namespace


LockBoxBase Properties

The properties of the LockBoxBase class are listed below. For a complete list of LockBoxBase class members, see the LockBoxBase Members topic.

Public Instance Properties

Application | Aptify Application Instance (only available after Config() is called)
DataAction | Aptify Data Action Instance (only available after Config() is called)
Database | Base Database for Lock Box Application Entities (derived from Base Database of Cash Control Batches entity) (only available after Config() is called)

See Also

LockBoxBase Class | Aptify.Applications.Accounting Namespace


Application Property

Aptify 5.0 Software Development Kit (SDK)

LockBoxBase.Application Property

Aptify Application Instance (only available after Config() is called)

public virtual AptifyApplication Application {get;}

Property Value

Remarks

See Also

LockBoxBase Class | Aptify.Applications.Accounting Namespace


DataAction Property

Aptify 5.0 Software Development Kit (SDK)

LockBoxBase.DataAction Property

Aptify Data Action Instance (only available after Config() is called)

public virtual DataAction DataAction {get;}

Property Value

Remarks

See Also

LockBoxBase Class | Aptify.Applications.Accounting Namespace


Database Property

Aptify 5.0 Software Development Kit (SDK)

LockBoxBase.Database Property

Base Database for Lock Box Application Entities (derived from Base Database of Cash Control Batches entity) (only available after Config() is called)

public virtual String Database {get;}

Property Value

Remarks

See Also

LockBoxBase Class | Aptify.Applications.Accounting Namespace


LockBoxBase Methods

The methods of the LockBoxBase class are listed below. For a complete list of LockBoxBase class members, see the LockBoxBase Members topic.

Public Instance Methods

Config | This method must be called before any other member of this class is accessed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetSQLIntegerValue | This is a utility method that returns the value of any SQL statement scalar value and casts it to a Integer type
GetSQLStringValue | This is a utility method that returns the value of any SQL statement scalar value and casts it to a String type
GetSQLValue | This is a utility method that returns the value of any SQL statement scalar value as a default Object type
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetCurrentEmployeeID | Returns the ID value from the Employees entity that matches the Current logged in user based on the provided User credentials (Uses Entity Record Relations via the spGetCurrentEmployeeID)
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LockBoxBase Class | Aptify.Applications.Accounting Namespace


LockBoxBase.Config Method

This method must be called before any other member of this class is accessed.

public virtual void Config(
AptifyApplication Application
);

Parameters

Application

Remarks

See Also

LockBoxBase Class | Aptify.Applications.Accounting Namespace


LockBoxBase.GetCurrentEmployeeID Method

Returns the ID value from the Employees entity that matches the Current logged in user based on the provided User credentials (Uses Entity Record Relations via the spGetCurrentEmployeeID)

protected virtual long GetCurrentEmployeeID();

Return Value

Remarks

See Also

LockBoxBase Class | Aptify.Applications.Accounting Namespace


LockBoxBase.GetSQLIntegerValue Method

This is a utility method that returns the value of any SQL statement scalar value and casts it to a Integer type

public virtual int GetSQLIntegerValue(
String SQL,
ref Boolean& RefreshCache
);

Parameters

SQL
RefreshCache
Set this parameter to true to refresh the Aptify data cache, otherwise do not pass it in the and the default value of False will use the cached result if available

Return Value

Remarks

See Also

LockBoxBase Class | Aptify.Applications.Accounting Namespace


LockBoxBase.GetSQLStringValue Method

This is a utility method that returns the value of any SQL statement scalar value and casts it to a String type

public virtual string GetSQLStringValue(
String SQL,
ref Boolean& RefreshCache
);

Parameters

SQL
RefreshCache
Set this parameter to true to refresh the Aptify data cache, otherwise do not pass it in the and the default value of False will use the cached result if available

Return Value

Remarks

See Also

LockBoxBase Class | Aptify.Applications.Accounting Namespace


LockBoxBase.GetSQLValue Method

This is a utility method that returns the value of any SQL statement scalar value as a default Object type

public virtual object GetSQLValue(
String SQL,
ref Boolean& RefreshCache
);

Parameters

SQL
RefreshCache
Set this parameter to true to refresh the Aptify data cache, otherwise do not pass it in the and the default value of False will use the cached result if available

Return Value

Remarks

See Also

LockBoxBase Class | Aptify.Applications.Accounting Namespace


LockBoxException Class

Thrown when there is a problem with Lock Box functionality.

For a list of all members of this type, see LockBoxException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
LockBoxException

public class LockBoxException : BaseApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: AptifyCashControlBatch (in AptifyCashControlBatch.dll)

See Also

LockBoxException Members | Aptify.Applications.Accounting Namespace


LockBoxException Members

LockBoxException overview

Public Instance Constructors

LockBoxException Overloaded. Initializes a new instance of the LockBoxException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from BaseApplicationException) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LockBoxException Class | Aptify.Applications.Accounting Namespace


LockBoxException Constructor

Initializes a new instance of the LockBoxException class.

Overload List

Initializes a new instance of the LockBoxException class.

public LockBoxException();

public LockBoxException(String);

public LockBoxException(String,Exception);

See Also

LockBoxException Class | Aptify.Applications.Accounting Namespace


LockBoxException Constructor ()

Initializes a new instance of the LockBoxException class.

public LockBoxException();

See Also

LockBoxException Class | Aptify.Applications.Accounting Namespace | LockBoxException Constructor Overload List


LockBoxException Constructor (String)

public LockBoxException(
String Message
);

See Also

LockBoxException Class | Aptify.Applications.Accounting Namespace | LockBoxException Constructor Overload List


LockBoxException Constructor (String, Exception)

public LockBoxException(
String Message,
Exception InnerException
);

See Also

LockBoxException Class | Aptify.Applications.Accounting Namespace | LockBoxException Constructor Overload List


LockBoxImportBase Class

This class provides a set of utility functions as a base class for all other import objects that need to provide lock box import functionality

For a list of all members of this type, see LockBoxImportBase Members.

System.Object
LockBoxBase
LockBoxImportBase
LockBoxTextFileImport

public class LockBoxImportBase : LockBoxBase, ILockBoxImport, IProcessComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: AptifyCashControlBatch (in AptifyCashControlBatch.dll)

See Also

LockBoxImportBase Members | Aptify.Applications.Accounting Namespace


LockBoxImportBase Members

LockBoxImportBase overview

Public Instance Constructors

LockBoxImportBase Constructor Initializes a new instance of the LockBoxImportBase class.

Public Instance Properties

Application (inherited from LockBoxBase) | Aptify Application Instance (only available after Config() is called)
DataAction (inherited from LockBoxBase) | Aptify Data Action Instance (only available after Config() is called)
Database (inherited from LockBoxBase) | Base Database for Lock Box Application Entities (derived from Base Database of Cash Control Batches entity) (only available after Config() is called)
EOF | '01/04/08 Tamasa, Added for issue 5500.This will is the EOF file is reached or not.
Properties |

Public Instance Methods

Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetSQLIntegerValue (inherited from LockBoxBase) | This is a utility method that returns the value of any SQL statement scalar value and casts it to a Integer type
GetSQLStringValue (inherited from LockBoxBase) | This is a utility method that returns the value of any SQL statement scalar value and casts it to a String type
GetSQLValue (inherited from LockBoxBase) | This is a utility method that returns the value of any SQL statement scalar value as a default Object type
GetStatusOfFile |
GetType (inherited from Object) | Gets the Type of the current instance.
ProcessFile | Overloaded. Processes a Lock box file.
Run |
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

StatusUpdate

Protected Instance Methods

CloseFile | This method is called by the base class whenever it is complete in processing and it is safe to close the file or other data source connection points and free up the associated resources.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetCurrentEmployeeID (inherited from LockBoxBase) | Returns the ID value from the Employees entity that matches the Current logged in user based on the provided User credentials (Uses Entity Record Relations via the spGetCurrentEmployeeID)
ImportDetails | This method is called once for each import process and is responsible for loading up all of the batch details from the data source. In addition, this method is expected to validate the data source integrity by comparing the Total Amount field that is passed in to the actual total amounts that exist in the file. This Total check can be skipped if the batch file or data source type does not provide header information.
ImportHeader | This method is called once for each import process and is responsible for loading up any batch header information. Of specific importance is to pass back to the calling function the total amount of the batch in the TotalAmount parameter
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnStatusUpdate |
OpenFile | This method is responsible for doing any needed work to open a file or other data source to get the process ready to import data from the data source.

See Also

LockBoxImportBase Class | Aptify.Applications.Accounting Namespace


LockBoxImportBase Constructor

Initializes a new instance of the LockBoxImportBase class.

public LockBoxImportBase();

See Also

LockBoxImportBase Class | Aptify.Applications.Accounting Namespace


LockBoxImportBase Properties

The properties of the LockBoxImportBase class are listed below. For a complete list of LockBoxImportBase class members, see the LockBoxImportBase Members topic.

Public Instance Properties

Application (inherited from LockBoxBase) | Aptify Application Instance (only available after Config() is called)
DataAction (inherited from LockBoxBase) | Aptify Data Action Instance (only available after Config() is called)
Database (inherited from LockBoxBase) | Base Database for Lock Box Application Entities (derived from Base Database of Cash Control Batches entity) (only available after Config() is called)
EOF | '01/04/08 Tamasa, Added for issue 5500.This will is the EOF file is reached or not.
Properties |

See Also

LockBoxImportBase Class | Aptify.Applications.Accounting Namespace


EOF Property

Aptify 5.0 Software Development Kit (SDK)

LockBoxImportBase.EOF Property

'01/04/08 Tamasa, Added for issue 5500.This will is the EOF file is reached or not.

public Boolean EOF {get; set;}

Property Value

Remarks

See Also

LockBoxImportBase Class | Aptify.Applications.Accounting Namespace


Properties Property

Aptify 5.0 Software Development Kit (SDK)

LockBoxImportBase.Properties Property

public AptifyProperties Properties {get;}

Implements

IProcessComponent.

See Also

LockBoxImportBase Class | Aptify.Applications.Accounting Namespace


LockBoxImportBase Methods

The methods of the LockBoxImportBase class are listed below. For a complete list of LockBoxImportBase class members, see the LockBoxImportBase Members topic.

Public Instance Methods

Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetSQLIntegerValue (inherited from LockBoxBase) | This is a utility method that returns the value of any SQL statement scalar value and casts it to a Integer type
GetSQLStringValue (inherited from LockBoxBase) | This is a utility method that returns the value of any SQL statement scalar value and casts it to a String type
GetSQLValue (inherited from LockBoxBase) | This is a utility method that returns the value of any SQL statement scalar value as a default Object type
GetStatusOfFile |
GetType (inherited from Object) | Gets the Type of the current instance.
ProcessFile | Overloaded. Processes a Lock box file.
Run |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CloseFile | This method is called by the base class whenever it is complete in processing and it is safe to close the file or other data source connection points and free up the associated resources.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetCurrentEmployeeID (inherited from LockBoxBase) | Returns the ID value from the Employees entity that matches the Current logged in user based on the provided User credentials (Uses Entity Record Relations via the spGetCurrentEmployeeID)
ImportDetails | This method is called once for each import process and is responsible for loading up all of the batch details from the data source. In addition, this method is expected to validate the data source integrity by comparing the Total Amount field that is passed in to the actual total amounts that exist in the file. This Total check can be skipped if the batch file or data source type does not provide header information.
ImportHeader | This method is called once for each import process and is responsible for loading up any batch header information. Of specific importance is to pass back to the calling function the total amount of the batch in the TotalAmount parameter
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnStatusUpdate |
OpenFile | This method is responsible for doing any needed work to open a file or other data source to get the process ready to import data from the data source.

See Also

LockBoxImportBase Class | Aptify.Applications.Accounting Namespace


LockBoxImportBase.CloseFile Method

This method is called by the base class whenever it is complete in processing and it is safe to close the file or other data source connection points and free up the associated resources.

protected abstract void CloseFile();

Remarks

See Also

LockBoxImportBase Class | Aptify.Applications.Accounting Namespace


LockBoxImportBase.Config Method

public override void Config(
AptifyApplication Application
);

Implements

IProcessComponent.

See Also

LockBoxImportBase Class | Aptify.Applications.Accounting Namespace


LockBoxImportBase.GetStatusOfFile Method

public bool GetStatusOfFile();

Implements

ILockBoxImport.

See Also

LockBoxImportBase Class | Aptify.Applications.Accounting Namespace


LockBoxImportBase.ImportDetails Method

This method is called once for each import process and is responsible for loading up all of the batch details from the data source. In addition, this method is expected to validate the data source integrity by comparing the Total Amount field that is passed in to the actual total amounts that exist in the file. This Total check can be skipped if the batch file or data source type does not provide header information.

protected abstract AptifyGenericEntityBase ImportDetails(
AptifyGenericEntityBase CashBatchGE,
Decimal TotalAmount
);

Parameters

CashBatchGE
TotalAmount

Return Value

Nothing if there was a failure. If a valida object was returned then there was success.

Remarks

The objects that are returned are populated, but not saved.

See Also

LockBoxImportBase Class | Aptify.Applications.Accounting Namespace


LockBoxImportBase.ImportHeader Method

This method is called once for each import process and is responsible for loading up any batch header information. Of specific importance is to pass back to the calling function the total amount of the batch in the TotalAmount parameter

protected abstract void ImportHeader(
ref AptifyGenericEntityBase& CashBatchGE,
ref Decimal& TotalAmount,
Int64 PaymentTypeID
);

Parameters

CashBatchGE
OUT Parameter: If this is nothing then the import header failed.
TotalAmount
OUT Parameter: This method will pass back to the calling function the total amount of the batch read from the batch header
PaymentTypeID

Remarks

See Also

LockBoxImportBase Class | Aptify.Applications.Accounting Namespace


LockBoxImportBase.OnStatusUpdate Method

protected virtual void OnStatusUpdate(
Int32 PercentComplete,
ref Boolean& Cancel
);

See Also

LockBoxImportBase Class | Aptify.Applications.Accounting Namespace


LockBoxImportBase.OpenFile Method

This method is responsible for doing any needed work to open a file or other data source to get the process ready to import data from the data source.

protected abstract void OpenFile(
String FileName
);

Parameters

FileName
File Name or other initialization information that is specific to the import object being called

Remarks

See Also

LockBoxImportBase Class | Aptify.Applications.Accounting Namespace


ProcessFile Method

Aptify 5.0 Software Development Kit (SDK)

LockBoxImportBase.ProcessFile Method

Processes a Lock box file.

Overload List

Processes a Lock box file.

public AptifyGenericEntityBase ProcessFile(String,AptifyGenericEntityBase);

Processes a Lock box file.

public AptifyGenericEntityBase ProcessFile(String,AptifyGenericEntityBase,Int64);

Note: This implementation of Process File does not support multiple batches being created based on payment type. To support this, sub-class this class or one of its existing derived classes and override the approprate methods such as ImportHeader and ImportDetail to implement the desired batch splitting logic.

public IList<T> ProcessFile(String,IList<T>,Int64);

Processes a Lock box file.

public AptifyGenericEntityBase ProcessFile(String,Int64);

Processes a Lock box file.

public AptifyGenericEntityBase ProcessFile(String,Int64,Int64);

See Also

LockBoxImportBase Class | Aptify.Applications.Accounting Namespace


LockBoxImportBase.ProcessFile Method (String, AptifyGenericEntityBase)

Processes a Lock box file.

public AptifyGenericEntityBase ProcessFile(
String FileName,
AptifyGenericEntityBase CashControlBatchGE
);

Return Value

Nothing if there was a failure. If a valida object was returned then there was success.

Implements

ILockBoxImport.

Remarks

The objects that are returned are populated, but not saved.

See Also

LockBoxImportBase Class | Aptify.Applications.Accounting Namespace | LockBoxImportBase.ProcessFile Overload List


LockBoxImportBase.ProcessFile Method (String, AptifyGenericEntityBase, Int64)

Processes a Lock box file.

public AptifyGenericEntityBase ProcessFile(
String FileName,
AptifyGenericEntityBase CashControlBatchGE,
Int64 PaymentTypeID
);

Parameters

FileName
CashControlBatchGE
PaymentTypeID

Return Value

Nothing if there was a failure. If a valida object was returned then there was success.

Implements

ILockBoxImport.

Remarks

The objects that are returned are populated, but not saved.

See Also

LockBoxImportBase Class | Aptify.Applications.Accounting Namespace | LockBoxImportBase.ProcessFile Overload List


LockBoxImportBase.ProcessFile Method (String, IList<T>, Int64)

Note: This implementation of Process File does not support multiple batches being created based on payment type. To support this, sub-class this class or one of its existing derived classes and override the approprate methods such as ImportHeader and ImportDetail to implement the desired batch splitting logic.

public IList<T> ProcessFile(
String FileName,
IList<T> CashControlBatchGE,
Int64 PaymentTypeID
);

Parameters

FileName
CashControlBatchGE
PaymentTypeID

Return Value

Nothing if there was a failure. If a valida object was returned then there was success.

Implements

ILockBoxImport.

Remarks

The objects that are returned are populated, but not saved.

See Also

LockBoxImportBase Class | Aptify.Applications.Accounting Namespace | LockBoxImportBase.ProcessFile Overload List


LockBoxImportBase.ProcessFile Method (String, Int64)

Processes a Lock box file.

public AptifyGenericEntityBase ProcessFile(
String FileName,
Int64 CashControlBatchID
);

Parameters

FileName
CashControlBatchID

Return Value

Nothing if there was a failure. If a valida object was returned then there was success.

Implements

ILockBoxImport.

Remarks

The objects that are returned are populated, but not saved.

See Also

LockBoxImportBase Class | Aptify.Applications.Accounting Namespace | LockBoxImportBase.ProcessFile Overload List


LockBoxImportBase.ProcessFile Method (String, Int64, Int64)

Processes a Lock box file.

public AptifyGenericEntityBase ProcessFile(
String FileName,
Int64 CashControlBatchID,
Int64 PaymentTypeID
);

Parameters

FileName
CashControlBatchID
PaymentTypeID

Return Value

Nothing if there was a failure. If a valida object was returned then there was success.

Implements

ILockBoxImport.

Remarks

The objects that are returned are populated, but not saved.

See Also

LockBoxImportBase Class | Aptify.Applications.Accounting Namespace | LockBoxImportBase.ProcessFile Overload List


LockBoxImportBase.Run Method

public string Run();

Implements

IProcessComponent.

See Also

LockBoxImportBase Class | Aptify.Applications.Accounting Namespace


LockBoxImportBase Events

The events of the LockBoxImportBase class are listed below. For a complete list of LockBoxImportBase class members, see the LockBoxImportBase Members topic.

Public Instance Events

StatusUpdate

See Also

LockBoxImportBase Class | Aptify.Applications.Accounting Namespace


LockBoxImportBase.StatusUpdateEventHandler Event

public event StatusUpdateEventHandler StatusUpdate;

Implements

ILockBoxImport.

See Also

LockBoxImportBase Class | Aptify.Applications.Accounting Namespace


LockBoxMatch Class

This class provides the default Aptify implementation for the ILockBoxMatch interface. The base class implements a number of basic matching methods which are overridable if it is necessary to alter the functionality that the matching object provides.

For a list of all members of this type, see LockBoxMatch Members.

System.Object
LockBoxBase
LockBoxMatch

public class LockBoxMatch : LockBoxBase, ILockBoxMatch, IProcessComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: AptifyCashControlBatch (in AptifyCashControlBatch.dll)

See Also

LockBoxMatch Members | Aptify.Applications.Accounting Namespace


LockBoxMatch Members

LockBoxMatch overview

Public Instance Constructors

LockBoxMatch Constructor Initializes a new instance of the LockBoxMatch class.

Public Instance Properties

Application (inherited from LockBoxBase) | Aptify Application Instance (only available after Config() is called)
DataAction (inherited from LockBoxBase) | Aptify Data Action Instance (only available after Config() is called)
Database (inherited from LockBoxBase) | Base Database for Lock Box Application Entities (derived from Base Database of Cash Control Batches entity) (only available after Config() is called)
Properties |

Public Instance Methods

Config | This method must be called before any other member of the class is accessed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetSQLIntegerValue (inherited from LockBoxBase) | This is a utility method that returns the value of any SQL statement scalar value and casts it to a Integer type
GetSQLStringValue (inherited from LockBoxBase) | This is a utility method that returns the value of any SQL statement scalar value and casts it to a String type
GetSQLValue (inherited from LockBoxBase) | This is a utility method that returns the value of any SQL statement scalar value as a default Object type
GetType (inherited from Object) | Gets the Type of the current instance.
MatchBatch | Overloaded. This method is responsible for mathching all of the records in the batch that have a status of 'Unmatched'. Other records in the batch will be ignored.
Run |
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

StatusUpdate This event is raised during long-running processes and allows the consumer object to cancel the operation by setting the Cancel parameter to True.

Protected Instance Methods

AttemptSingleRecordMatch | This method is responsible for attempting to match a single record inside the Cash Control Batch record. The method makes a call to the FindOrderMatch() method to determine if an order can be found in the database that matches the information imported from the lock box file or not. If the logic to find an order needs to be overriden, override the FindOrderMatch() method instead of this method, only override if you need to pre/post process or override the overall process of matching a single record.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FindOrderMatch | This method is responsible for finding an order in the database that matches the information in the Cash Control Batch Detail GE object that is passed in. The default implementation of this method in the LockBoxMatch base class assumes that the BankKey that exist in the Cash Control Batch Detail record is an Order ID number. For this reason, it attempts to match that Bank Key value against orders in the Orders entity in the database and returns an Order ID if found. In addition, this method is responsible for passing back the current balance in the Order ID, if an Order ID is found that matches. If the bank key in a lock box file represents a value other than the Order ID, for example a Person or Company ID value, override this method and implement the necessary logic to find the Order ID that is required by the Cash Control Batch architecture using any appropriate logic. For example, in the case where the Bank Key represents a Person ID number instead of an Order ID, you could query the database to retrieve an order that matches the Person's ID in the ShipTo/BillTo of the Orders Database where the Balance matches the amount of the payment. Of course, any other logic could also be implemetned in accordance with the business practices required, this is simply one example.
GetCurrentEmployeeID (inherited from LockBoxBase) | Returns the ID value from the Employees entity that matches the Current logged in user based on the provided User credentials (Uses Entity Record Relations via the spGetCurrentEmployeeID)
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetException | This method is responsible for setting field values in the Cash Control Batch Detail GE object that is passed in based on the parameters that are defined in the method

See Also

LockBoxMatch Class | Aptify.Applications.Accounting Namespace


LockBoxMatch Constructor

Initializes a new instance of the LockBoxMatch class.

public LockBoxMatch();

See Also

LockBoxMatch Class | Aptify.Applications.Accounting Namespace


LockBoxMatch Properties

The properties of the LockBoxMatch class are listed below. For a complete list of LockBoxMatch class members, see the LockBoxMatch Members topic.

Public Instance Properties

Application (inherited from LockBoxBase) | Aptify Application Instance (only available after Config() is called)
DataAction (inherited from LockBoxBase) | Aptify Data Action Instance (only available after Config() is called)
Database (inherited from LockBoxBase) | Base Database for Lock Box Application Entities (derived from Base Database of Cash Control Batches entity) (only available after Config() is called)
Properties |

See Also

LockBoxMatch Class | Aptify.Applications.Accounting Namespace


Properties Property

Aptify 5.0 Software Development Kit (SDK)

LockBoxMatch.Properties Property

public AptifyProperties Properties {get;}

Implements

IProcessComponent.

See Also

LockBoxMatch Class | Aptify.Applications.Accounting Namespace


LockBoxMatch Methods

The methods of the LockBoxMatch class are listed below. For a complete list of LockBoxMatch class members, see the LockBoxMatch Members topic.

Public Instance Methods

Config | This method must be called before any other member of the class is accessed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetSQLIntegerValue (inherited from LockBoxBase) | This is a utility method that returns the value of any SQL statement scalar value and casts it to a Integer type
GetSQLStringValue (inherited from LockBoxBase) | This is a utility method that returns the value of any SQL statement scalar value and casts it to a String type
GetSQLValue (inherited from LockBoxBase) | This is a utility method that returns the value of any SQL statement scalar value as a default Object type
GetType (inherited from Object) | Gets the Type of the current instance.
MatchBatch | Overloaded. This method is responsible for mathching all of the records in the batch that have a status of 'Unmatched'. Other records in the batch will be ignored.
Run |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

AttemptSingleRecordMatch | This method is responsible for attempting to match a single record inside the Cash Control Batch record. The method makes a call to the FindOrderMatch() method to determine if an order can be found in the database that matches the information imported from the lock box file or not. If the logic to find an order needs to be overriden, override the FindOrderMatch() method instead of this method, only override if you need to pre/post process or override the overall process of matching a single record.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FindOrderMatch | This method is responsible for finding an order in the database that matches the information in the Cash Control Batch Detail GE object that is passed in. The default implementation of this method in the LockBoxMatch base class assumes that the BankKey that exist in the Cash Control Batch Detail record is an Order ID number. For this reason, it attempts to match that Bank Key value against orders in the Orders entity in the database and returns an Order ID if found. In addition, this method is responsible for passing back the current balance in the Order ID, if an Order ID is found that matches. If the bank key in a lock box file represents a value other than the Order ID, for example a Person or Company ID value, override this method and implement the necessary logic to find the Order ID that is required by the Cash Control Batch architecture using any appropriate logic. For example, in the case where the Bank Key represents a Person ID number instead of an Order ID, you could query the database to retrieve an order that matches the Person's ID in the ShipTo/BillTo of the Orders Database where the Balance matches the amount of the payment. Of course, any other logic could also be implemetned in accordance with the business practices required, this is simply one example.
GetCurrentEmployeeID (inherited from LockBoxBase) | Returns the ID value from the Employees entity that matches the Current logged in user based on the provided User credentials (Uses Entity Record Relations via the spGetCurrentEmployeeID)
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetException | This method is responsible for setting field values in the Cash Control Batch Detail GE object that is passed in based on the parameters that are defined in the method

See Also

LockBoxMatch Class | Aptify.Applications.Accounting Namespace


LockBoxMatch.AttemptSingleRecordMatch Method

This method is responsible for attempting to match a single record inside the Cash Control Batch record. The method makes a call to the FindOrderMatch() method to determine if an order can be found in the database that matches the information imported from the lock box file or not. If the logic to find an order needs to be overriden, override the FindOrderMatch() method instead of this method, only override if you need to pre/post process or override the overall process of matching a single record.

protected virtual bool AttemptSingleRecordMatch(
AptifyGenericEntityBase DetailGE
);

Parameters

DetailGE

Return Value

True if the process is succesful, False otherwise

Remarks

See Also

LockBoxMatch Class | Aptify.Applications.Accounting Namespace


LockBoxMatch.Config Method

This method must be called before any other member of the class is accessed.

public override void Config(
AptifyApplication Application
);

Parameters

Application

Implements

IProcessComponent.

Remarks

See Also

LockBoxMatch Class | Aptify.Applications.Accounting Namespace


LockBoxMatch.FindOrderMatch Method

This method is responsible for finding an order in the database that matches the information in the Cash Control Batch Detail GE object that is passed in. The default implementation of this method in the LockBoxMatch base class assumes that the BankKey that exist in the Cash Control Batch Detail record is an Order ID number. For this reason, it attempts to match that Bank Key value against orders in the Orders entity in the database and returns an Order ID if found. In addition, this method is responsible for passing back the current balance in the Order ID, if an Order ID is found that matches. If the bank key in a lock box file represents a value other than the Order ID, for example a Person or Company ID value, override this method and implement the necessary logic to find the Order ID that is required by the Cash Control Batch architecture using any appropriate logic. For example, in the case where the Bank Key represents a Person ID number instead of an Order ID, you could query the database to retrieve an order that matches the Person's ID in the ShipTo/BillTo of the Orders Database where the Balance matches the amount of the payment. Of course, any other logic could also be implemetned in accordance with the business practices required, this is simply one example.

protected virtual long FindOrderMatch(
AptifyGenericEntityBase DetailGE,
ref Decimal& OrderBalance
);

Parameters

DetailGE
Cash Control Batch Detail Aptify GE Object
OrderBalance

Return Value

A positive value, Order ID number from the Orders entity if the function executes succesfully and finds a match. Otherwise -1 will be returned

Remarks

See Also

LockBoxMatch Class | Aptify.Applications.Accounting Namespace


MatchBatch Method

Aptify 5.0 Software Development Kit (SDK)

LockBoxMatch.MatchBatch Method

This method is responsible for mathching all of the records in the batch that have a status of 'Unmatched'. Other records in the batch will be ignored.

Overload List

This method is responsible for mathching all of the records in the batch that have a status of 'Unmatched'. Other records in the batch will be ignored.

public bool MatchBatch(AptifyGenericEntityBase);

This method is responsible for mathching all of the records in the batch that have a status of 'Unmatched'. Other records in the batch will be ignored.

public bool MatchBatch(Int64);

See Also

LockBoxMatch Class | Aptify.Applications.Accounting Namespace


LockBoxMatch.MatchBatch Method (AptifyGenericEntityBase)

This method is responsible for mathching all of the records in the batch that have a status of 'Unmatched'. Other records in the batch will be ignored.

public bool MatchBatch(
AptifyGenericEntityBase CashControlBatchGE
);

Parameters

CashControlBatchGE

Return Value

Implements

ILockBoxMatch.

Remarks

See Also

LockBoxMatch Class | Aptify.Applications.Accounting Namespace | LockBoxMatch.MatchBatch Overload List


LockBoxMatch.MatchBatch Method (Int64)

This method is responsible for mathching all of the records in the batch that have a status of 'Unmatched'. Other records in the batch will be ignored.

public bool MatchBatch(
Int64 CashControlBatchID
);

Parameters

CashControlBatchID

Return Value

Implements

ILockBoxMatch.

Remarks

See Also

LockBoxMatch Class | Aptify.Applications.Accounting Namespace | LockBoxMatch.MatchBatch Overload List


LockBoxMatch.Run Method

public string Run();

Implements

IProcessComponent.

See Also

LockBoxMatch Class | Aptify.Applications.Accounting Namespace


LockBoxMatch.SetException Method

This method is responsible for setting field values in the Cash Control Batch Detail GE object that is passed in based on the parameters that are defined in the method

protected virtual void SetException(
String ExceptionType,
AptifyGenericEntityBase DetailGE,
String ExceptionComments
);

Parameters

ExceptionType
DetailGE
ExceptionComments

Remarks

See Also

LockBoxMatch Class | Aptify.Applications.Accounting Namespace


LockBoxMatch Events

The events of the LockBoxMatch class are listed below. For a complete list of LockBoxMatch class members, see the LockBoxMatch Members topic.

Public Instance Events

StatusUpdate This event is raised during long-running processes and allows the consumer object to cancel the operation by setting the Cancel parameter to True.

See Also

LockBoxMatch Class | Aptify.Applications.Accounting Namespace


LockBoxMatch.StatusUpdateEventHandler Event

This event is raised during long-running processes and allows the consumer object to cancel the operation by setting the Cancel parameter to True.

public event StatusUpdateEventHandler StatusUpdate;

Implements

ILockBoxMatch.

Remarks

See Also

LockBoxMatch Class | Aptify.Applications.Accounting Namespace


LockBoxPost Class

This class provides the default Aptify implementation for the ILockBoxPost interface

For a list of all members of this type, see LockBoxPost Members.

System.Object
LockBoxBase
LockBoxPost

public class LockBoxPost : LockBoxBase, ILockBoxPost, IProcessComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: AptifyCashControlBatch (in AptifyCashControlBatch.dll)

See Also

LockBoxPost Members | Aptify.Applications.Accounting Namespace


LockBoxPost Members

LockBoxPost overview

Public Instance Constructors

LockBoxPost Constructor Initializes a new instance of the LockBoxPost class.

Public Instance Properties

Application (inherited from LockBoxBase) | Aptify Application Instance (only available after Config() is called)
DataAction (inherited from LockBoxBase) | Aptify Data Action Instance (only available after Config() is called)
Database (inherited from LockBoxBase) | Base Database for Lock Box Application Entities (derived from Base Database of Cash Control Batches entity) (only available after Config() is called)
Properties |

Public Instance Methods

Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetSQLIntegerValue (inherited from LockBoxBase) | This is a utility method that returns the value of any SQL statement scalar value and casts it to a Integer type
GetSQLStringValue (inherited from LockBoxBase) | This is a utility method that returns the value of any SQL statement scalar value and casts it to a String type
GetSQLValue (inherited from LockBoxBase) | This is a utility method that returns the value of any SQL statement scalar value as a default Object type
GetType (inherited from Object) | Gets the Type of the current instance.
PostLockBox | Overloaded. This function will post the lock-box. The process goes through each item in the Cash Control Batch Detail sub-type(CashCtrlBatchDetail) For each item if the Status = "Matched" or the Status="Exception" AND ExceptionStatus="Resolved" it will call the appropriate posting object, either ILockBoxPostMatch or ILockBoxPostException The meta-data used to derive the implementation objects for each of these interfaces is as follows: ILockBoxPostMatch Implementation is defined by the following entity attributes on the Cash Control Batches Entity LockBoxPostMatchObject LockBoxPostMatchAssembly LockBoxPostMatchClass ILockBoxPostException Implementation is defined by the following entity attributes on the Cash Control Batches Entity LockBoxPostExceptionObject LockBoxPostExceptionAssembly LockBoxPostExceptionClass
Run |
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

StatusUpdate

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetCurrentEmployeeID (inherited from LockBoxBase) | Returns the ID value from the Employees entity that matches the Current logged in user based on the provided User credentials (Uses Entity Record Relations via the spGetCurrentEmployeeID)
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LockBoxPost Class | Aptify.Applications.Accounting Namespace


LockBoxPost Constructor

Initializes a new instance of the LockBoxPost class.

public LockBoxPost();

See Also

LockBoxPost Class | Aptify.Applications.Accounting Namespace


LockBoxPost Properties

The properties of the LockBoxPost class are listed below. For a complete list of LockBoxPost class members, see the LockBoxPost Members topic.

Public Instance Properties

Application (inherited from LockBoxBase) | Aptify Application Instance (only available after Config() is called)
DataAction (inherited from LockBoxBase) | Aptify Data Action Instance (only available after Config() is called)
Database (inherited from LockBoxBase) | Base Database for Lock Box Application Entities (derived from Base Database of Cash Control Batches entity) (only available after Config() is called)
Properties |

See Also

LockBoxPost Class | Aptify.Applications.Accounting Namespace


Properties Property

Aptify 5.0 Software Development Kit (SDK)

LockBoxPost.Properties Property

public AptifyProperties Properties {get;}

Implements

IProcessComponent.

See Also

LockBoxPost Class | Aptify.Applications.Accounting Namespace


LockBoxPost Methods

The methods of the LockBoxPost class are listed below. For a complete list of LockBoxPost class members, see the LockBoxPost Members topic.

Public Instance Methods

Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetSQLIntegerValue (inherited from LockBoxBase) | This is a utility method that returns the value of any SQL statement scalar value and casts it to a Integer type
GetSQLStringValue (inherited from LockBoxBase) | This is a utility method that returns the value of any SQL statement scalar value and casts it to a String type
GetSQLValue (inherited from LockBoxBase) | This is a utility method that returns the value of any SQL statement scalar value as a default Object type
GetType (inherited from Object) | Gets the Type of the current instance.
PostLockBox | Overloaded. This function will post the lock-box. The process goes through each item in the Cash Control Batch Detail sub-type(CashCtrlBatchDetail) For each item if the Status = "Matched" or the Status="Exception" AND ExceptionStatus="Resolved" it will call the appropriate posting object, either ILockBoxPostMatch or ILockBoxPostException The meta-data used to derive the implementation objects for each of these interfaces is as follows: ILockBoxPostMatch Implementation is defined by the following entity attributes on the Cash Control Batches Entity LockBoxPostMatchObject LockBoxPostMatchAssembly LockBoxPostMatchClass ILockBoxPostException Implementation is defined by the following entity attributes on the Cash Control Batches Entity LockBoxPostExceptionObject LockBoxPostExceptionAssembly LockBoxPostExceptionClass
Run |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetCurrentEmployeeID (inherited from LockBoxBase) | Returns the ID value from the Employees entity that matches the Current logged in user based on the provided User credentials (Uses Entity Record Relations via the spGetCurrentEmployeeID)
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LockBoxPost Class | Aptify.Applications.Accounting Namespace


LockBoxPost.Config Method

public override void Config(
AptifyApplication Application
);

Implements

IProcessComponent.

See Also

LockBoxPost Class | Aptify.Applications.Accounting Namespace


PostLockBox Method

Aptify 5.0 Software Development Kit (SDK)

LockBoxPost.PostLockBox Method

This function will post the lock-box. The process goes through each item in the Cash Control Batch Detail sub-type(CashCtrlBatchDetail) For each item if the Status = "Matched" or the Status="Exception" AND ExceptionStatus="Resolved" it will call the appropriate posting object, either ILockBoxPostMatch or ILockBoxPostException The meta-data used to derive the implementation objects for each of these interfaces is as follows: ILockBoxPostMatch Implementation is defined by the following entity attributes on the Cash Control Batches Entity LockBoxPostMatchObject LockBoxPostMatchAssembly LockBoxPostMatchClass ILockBoxPostException Implementation is defined by the following entity attributes on the Cash Control Batches Entity LockBoxPostExceptionObject LockBoxPostExceptionAssembly LockBoxPostExceptionClass

Overload List

This function will post the lock-box. The process goes through each item in the Cash Control Batch Detail sub-type(CashCtrlBatchDetail) For each item if the Status = "Matched" or the Status="Exception" AND ExceptionStatus="Resolved" it will call the appropriate posting object, either ILockBoxPostMatch or ILockBoxPostException The meta-data used to derive the implementation objects for each of these interfaces is as follows: ILockBoxPostMatch Implementation is defined by the following entity attributes on the Cash Control Batches Entity LockBoxPostMatchObject LockBoxPostMatchAssembly LockBoxPostMatchClass ILockBoxPostException Implementation is defined by the following entity attributes on the Cash Control Batches Entity LockBoxPostExceptionObject LockBoxPostExceptionAssembly LockBoxPostExceptionClass

public bool PostLockBox(AptifyGenericEntityBase);

public bool PostLockBox(Int64);

See Also

LockBoxPost Class | Aptify.Applications.Accounting Namespace


LockBoxPost.PostLockBox Method (AptifyGenericEntityBase)

This function will post the lock-box. The process goes through each item in the Cash Control Batch Detail sub-type(CashCtrlBatchDetail) For each item if the Status = "Matched" or the Status="Exception" AND ExceptionStatus="Resolved" it will call the appropriate posting object, either ILockBoxPostMatch or ILockBoxPostException The meta-data used to derive the implementation objects for each of these interfaces is as follows: ILockBoxPostMatch Implementation is defined by the following entity attributes on the Cash Control Batches Entity LockBoxPostMatchObject LockBoxPostMatchAssembly LockBoxPostMatchClass ILockBoxPostException Implementation is defined by the following entity attributes on the Cash Control Batches Entity LockBoxPostExceptionObject LockBoxPostExceptionAssembly LockBoxPostExceptionClass

public bool PostLockBox(
AptifyGenericEntityBase CashControlBatchGE
);

Parameters

CashControlBatchGE

Return Value

True if the process completes succesfully, False otherwise

Implements

ILockBoxPost.

Remarks

See Also

LockBoxPost Class | Aptify.Applications.Accounting Namespace | LockBoxPost.PostLockBox Overload List


LockBoxPost.PostLockBox Method (Int64)

public bool PostLockBox(
Int64 CashControlBatchID
);

Implements

ILockBoxPost.

See Also

LockBoxPost Class | Aptify.Applications.Accounting Namespace | LockBoxPost.PostLockBox Overload List


LockBoxPost.Run Method

public string Run();

Implements

IProcessComponent.

See Also

LockBoxPost Class | Aptify.Applications.Accounting Namespace


LockBoxPost Events

The events of the LockBoxPost class are listed below. For a complete list of LockBoxPost class members, see the LockBoxPost Members topic.

Public Instance Events

StatusUpdate

See Also

LockBoxPost Class | Aptify.Applications.Accounting Namespace


LockBoxPost.StatusUpdateEventHandler Event

public event StatusUpdateEventHandler StatusUpdate;

Implements

ILockBoxPost.

See Also

LockBoxPost Class | Aptify.Applications.Accounting Namespace


LockBoxPostRecord Class

This class provides the default Aptify implementation for the ILockBoxPostRecord interface

For a list of all members of this type, see LockBoxPostRecord Members.

System.Object
LockBoxBase
LockBoxPostRecord

public class LockBoxPostRecord : LockBoxBase, ILockBoxPostMatch, ILockBoxPostException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: AptifyCashControlBatch (in AptifyCashControlBatch.dll)

See Also

LockBoxPostRecord Members | Aptify.Applications.Accounting Namespace


LockBoxPostRecord Members

LockBoxPostRecord overview

Public Instance Constructors

LockBoxPostRecord Constructor Initializes a new instance of the LockBoxPostRecord class.

Public Instance Properties

Application (inherited from LockBoxBase) | Aptify Application Instance (only available after Config() is called)
DataAction (inherited from LockBoxBase) | Aptify Data Action Instance (only available after Config() is called)
Database (inherited from LockBoxBase) | Base Database for Lock Box Application Entities (derived from Base Database of Cash Control Batches entity) (only available after Config() is called)

Public Instance Methods

Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetSQLIntegerValue (inherited from LockBoxBase) | This is a utility method that returns the value of any SQL statement scalar value and casts it to a Integer type
GetSQLStringValue (inherited from LockBoxBase) | This is a utility method that returns the value of any SQL statement scalar value and casts it to a String type
GetSQLValue (inherited from LockBoxBase) | This is a utility method that returns the value of any SQL statement scalar value as a default Object type
GetType (inherited from Object) | Gets the Type of the current instance.
PostException | This method is responsible for posting exception records within the cash control batch. The types of exception resolution that are supported are shown below. Resolution: * Post * Post/Refund * Post/Refund All * Allocate * Allocate/New The following steps are followed to manage posting exception records in the cash control batch. The first three resolution types(Post, Post/Refund, Post/Refund All) start off by creating a payment just like a match would get create. Then, afterwards, for Post/Refund and Post/Refund All, a refund payment is created The last two types (Allocate, Allocate/New) start off by either updating the existing order, or in the case of Allocate/New, creating a new order with lines on it from the Allocation sub-type of the cash detail record. For the allocation resolution types, the final step is a payment is posted against the original order and the new order at the same time and the NewOrderID field is filled in in the CashDetail record
PostMatch | This method provides the default implementation of posting matching records in the cash control batch. The default implementation follows the following steps in doing so. 1. Create Payment Object 2. Set Payment Object Data Fields 2.1. PersonID, CompanyID 2.2. Set CashCtrlBatchID 2.3. Set DepositDate, PaymentDate, EffectiveDate 2.4. Set PaymentType 2.5. Add one payment line for the amount of PaymentAmount 3. Save Payment Object 4. Set Cash Control Detail PaymentID to the newly created Payment's ID 5. Set Cash Control Detail Status to "Posted"
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

AddItemsToOrder | This method is responsible for adding items to the provided Order Object for the allocation selected in the Cash Control Batch Detail record GE that is passed in as a parameter to this function.
Allocate | This method is responsible for handling allocation of overpayment items in a cash control batch detail line item to the existing order in the system. If an order does not have a Status of 'Taken' this function can not process as the order will not allow the order to be modified since it has been shipped, cancelled, or back-ordered. Therefore, the function, in that situation will post a message indicating the fact to the session exception log, but then call the AllocateNew() method automatically on behalf of the callee.
AllocateNew | This method is responsible for creating a new order, adding overpayment allocation items to it, and then applying the payment amount specified to the new order as well.
CopyOrderHeader | This method is responsible for copying certain order header information from the old GE object passed in to the new one. This method is called from the AllocateNew() method which uses it to create a new order when it is necessary to allocate overpayment items to a new order either due to user selection to allocate to a new order, or because the existing order has already been shipped and therefore can not be modified directly. To alter the behavior, override this method and implement the desired logic. The default logic copies the following fields from the old GE object to the new GE object. ShipToID, ShipToCompanyID, ShipToAddressID, ShipToPhoneID BillToID, BillToCompanyID, BillToAddressID, BillToPhoneID OrderLevelID, ShipTypeID, SalesTaxRateID
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetCurrentEmployeeID (inherited from LockBoxBase) | Returns the ID value from the Employees entity that matches the Current logged in user based on the provided User credentials (Uses Entity Record Relations via the spGetCurrentEmployeeID)
GetDefaultPaymentLevelID | Returns the lowest Payment Level ID from the GL Payment Levels entity
GetOrderInfo | This method is responsible for retrieving order header information for the rest of the process including the Bill To Person ID and Bill To Company ID and Balance.
GetPaymentTypeType | This method is responsible for determining the Base Payment Type (The Type field on the Payment Types Entity) that drives the functionality in the system with regards to payment processing.
GetPurchaseOrderPaymentTypeID | Returns the lowest Payment Type ID that is for a payment type with a base type of Purchase Order. Uses the Payments Entity object's GetPurchaseOrderTypeID method.
GetRefundPaymentTypeID | Overloaded. Returns the default Refund Voucher Payment Type ID. This method uses the Payments Entity object's GetRefundVoucherTypeID method.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PostRefund | This method is called whenever an exception resolution of Refund (Either 'Refund Overpayment' or 'Refund All') is chosen for the given payment line. This method will create a new payment record that has a refund payment type.
SetupPaymentHeader | This method is responsible for setting up a payment header for the cash control batch lock box posting process. This method sets up a variety of different fields on the payment header and can be overriden/augmented as required. Suggested method for overriding this method is to override the Function and then to make a call to the base class method implementation first before doing any additional processing.

See Also

LockBoxPostRecord Class | Aptify.Applications.Accounting Namespace


LockBoxPostRecord Constructor

Initializes a new instance of the LockBoxPostRecord class.

public LockBoxPostRecord();

See Also

LockBoxPostRecord Class | Aptify.Applications.Accounting Namespace


LockBoxPostRecord Methods

The methods of the LockBoxPostRecord class are listed below. For a complete list of LockBoxPostRecord class members, see the LockBoxPostRecord Members topic.

Public Instance Methods

Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetSQLIntegerValue (inherited from LockBoxBase) | This is a utility method that returns the value of any SQL statement scalar value and casts it to a Integer type
GetSQLStringValue (inherited from LockBoxBase) | This is a utility method that returns the value of any SQL statement scalar value and casts it to a String type
GetSQLValue (inherited from LockBoxBase) | This is a utility method that returns the value of any SQL statement scalar value as a default Object type
GetType (inherited from Object) | Gets the Type of the current instance.
PostException | This method is responsible for posting exception records within the cash control batch. The types of exception resolution that are supported are shown below. Resolution: * Post * Post/Refund * Post/Refund All * Allocate * Allocate/New The following steps are followed to manage posting exception records in the cash control batch. The first three resolution types(Post, Post/Refund, Post/Refund All) start off by creating a payment just like a match would get create. Then, afterwards, for Post/Refund and Post/Refund All, a refund payment is created The last two types (Allocate, Allocate/New) start off by either updating the existing order, or in the case of Allocate/New, creating a new order with lines on it from the Allocation sub-type of the cash detail record. For the allocation resolution types, the final step is a payment is posted against the original order and the new order at the same time and the NewOrderID field is filled in in the CashDetail record
PostMatch | This method provides the default implementation of posting matching records in the cash control batch. The default implementation follows the following steps in doing so. 1. Create Payment Object 2. Set Payment Object Data Fields 2.1. PersonID, CompanyID 2.2. Set CashCtrlBatchID 2.3. Set DepositDate, PaymentDate, EffectiveDate 2.4. Set PaymentType 2.5. Add one payment line for the amount of PaymentAmount 3. Save Payment Object 4. Set Cash Control Detail PaymentID to the newly created Payment's ID 5. Set Cash Control Detail Status to "Posted"
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

AddItemsToOrder | This method is responsible for adding items to the provided Order Object for the allocation selected in the Cash Control Batch Detail record GE that is passed in as a parameter to this function.
Allocate | This method is responsible for handling allocation of overpayment items in a cash control batch detail line item to the existing order in the system. If an order does not have a Status of 'Taken' this function can not process as the order will not allow the order to be modified since it has been shipped, cancelled, or back-ordered. Therefore, the function, in that situation will post a message indicating the fact to the session exception log, but then call the AllocateNew() method automatically on behalf of the callee.
AllocateNew | This method is responsible for creating a new order, adding overpayment allocation items to it, and then applying the payment amount specified to the new order as well.
CopyOrderHeader | This method is responsible for copying certain order header information from the old GE object passed in to the new one. This method is called from the AllocateNew() method which uses it to create a new order when it is necessary to allocate overpayment items to a new order either due to user selection to allocate to a new order, or because the existing order has already been shipped and therefore can not be modified directly. To alter the behavior, override this method and implement the desired logic. The default logic copies the following fields from the old GE object to the new GE object. ShipToID, ShipToCompanyID, ShipToAddressID, ShipToPhoneID BillToID, BillToCompanyID, BillToAddressID, BillToPhoneID OrderLevelID, ShipTypeID, SalesTaxRateID
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetCurrentEmployeeID (inherited from LockBoxBase) | Returns the ID value from the Employees entity that matches the Current logged in user based on the provided User credentials (Uses Entity Record Relations via the spGetCurrentEmployeeID)
GetDefaultPaymentLevelID | Returns the lowest Payment Level ID from the GL Payment Levels entity
GetOrderInfo | This method is responsible for retrieving order header information for the rest of the process including the Bill To Person ID and Bill To Company ID and Balance.
GetPaymentTypeType | This method is responsible for determining the Base Payment Type (The Type field on the Payment Types Entity) that drives the functionality in the system with regards to payment processing.
GetPurchaseOrderPaymentTypeID | Returns the lowest Payment Type ID that is for a payment type with a base type of Purchase Order. Uses the Payments Entity object's GetPurchaseOrderTypeID method.
GetRefundPaymentTypeID | Overloaded. Returns the default Refund Voucher Payment Type ID. This method uses the Payments Entity object's GetRefundVoucherTypeID method.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PostRefund | This method is called whenever an exception resolution of Refund (Either 'Refund Overpayment' or 'Refund All') is chosen for the given payment line. This method will create a new payment record that has a refund payment type.
SetupPaymentHeader | This method is responsible for setting up a payment header for the cash control batch lock box posting process. This method sets up a variety of different fields on the payment header and can be overriden/augmented as required. Suggested method for overriding this method is to override the Function and then to make a call to the base class method implementation first before doing any additional processing.

See Also

LockBoxPostRecord Class | Aptify.Applications.Accounting Namespace


LockBoxPostRecord.AddItemsToOrder Method

This method is responsible for adding items to the provided Order Object for the allocation selected in the Cash Control Batch Detail record GE that is passed in as a parameter to this function.

protected virtual bool AddItemsToOrder(
AptifyGenericEntityBase CashDetailGE,
AptifyGenericEntityBase OrderGE
);

Parameters

CashDetailGE
OrderGE

Return Value

True if operation is a success, False otherwise

Remarks

See Also

LockBoxPostRecord Class | Aptify.Applications.Accounting Namespace


LockBoxPostRecord.Allocate Method

This method is responsible for handling allocation of overpayment items in a cash control batch detail line item to the existing order in the system. If an order does not have a Status of 'Taken' this function can not process as the order will not allow the order to be modified since it has been shipped, cancelled, or back-ordered. Therefore, the function, in that situation will post a message indicating the fact to the session exception log, but then call the AllocateNew() method automatically on behalf of the callee.

protected virtual bool Allocate(
AptifyGenericEntityBase CashBatchGE,
AptifyGenericEntityBase CashDetailGE,
Int32 LineNumber,
Decimal PaymentAmount
);

Parameters

CashBatchGE
CashDetailGE
LineNumber
PaymentAmount

Return Value

True if succesful, False otherwise

Remarks

See Also

LockBoxPostRecord Class | Aptify.Applications.Accounting Namespace


LockBoxPostRecord.AllocateNew Method

This method is responsible for creating a new order, adding overpayment allocation items to it, and then applying the payment amount specified to the new order as well.

protected virtual bool AllocateNew(
AptifyGenericEntityBase CashBatchGE,
AptifyGenericEntityBase CashDetailGE,
Int32 LineNumber,
Decimal PaymentAmount
);

Parameters

CashBatchGE
CashDetailGE
LineNumber
PaymentAmount

Return Value

Remarks

See Also

LockBoxPostRecord Class | Aptify.Applications.Accounting Namespace


LockBoxPostRecord.Config Method

public override void Config(
AptifyApplication Application
);

Implements

ILockBoxPostException.

See Also

LockBoxPostRecord Class | Aptify.Applications.Accounting Namespace


LockBoxPostRecord.CopyOrderHeader Method

This method is responsible for copying certain order header information from the old GE object passed in to the new one. This method is called from the AllocateNew() method which uses it to create a new order when it is necessary to allocate overpayment items to a new order either due to user selection to allocate to a new order, or because the existing order has already been shipped and therefore can not be modified directly. To alter the behavior, override this method and implement the desired logic. The default logic copies the following fields from the old GE object to the new GE object. ShipToID, ShipToCompanyID, ShipToAddressID, ShipToPhoneID BillToID, BillToCompanyID, BillToAddressID, BillToPhoneID OrderLevelID, ShipTypeID, SalesTaxRateID

protected virtual void CopyOrderHeader(
AptifyGenericEntityBase NewOrderGE,
AptifyGenericEntityBase OldOrderGE
);

Parameters

NewOrderGE
New Order GE Object
OldOrderGE
Old Order GE Object

Remarks

See Also

LockBoxPostRecord Class | Aptify.Applications.Accounting Namespace


LockBoxPostRecord.GetDefaultPaymentLevelID Method

Returns the lowest Payment Level ID from the GL Payment Levels entity

protected virtual long GetDefaultPaymentLevelID();

Return Value

Remarks

See Also

LockBoxPostRecord Class | Aptify.Applications.Accounting Namespace


LockBoxPostRecord.GetOrderInfo Method

This method is responsible for retrieving order header information for the rest of the process including the Bill To Person ID and Bill To Company ID and Balance.

protected virtual void GetOrderInfo(
Int64 OrderID,
ref Int64& BillToPersonID,
ref Int64& BillToCompanyID,
ref Decimal& Balance
);

Parameters

OrderID
Order ID for which information is required
BillToPersonID
OUT Paramter: Returns BillToID field from Orders Entity
BillToCompanyID
OUT Paramter: Returns BillToCompanyID field from Orders Entity
Balance
OUT Paramter: Returns Balance field from Orders Entity

Remarks

Exceptions

Exception Type | Condition
LockBoxException | Thrown if a record that matches OrderID cannot be found.

See Also

LockBoxPostRecord Class | Aptify.Applications.Accounting Namespace


LockBoxPostRecord.GetPaymentTypeType Method

This method is responsible for determining the Base Payment Type (The Type field on the Payment Types Entity) that drives the functionality in the system with regards to payment processing.

protected virtual string GetPaymentTypeType(
Int64 PaymentTypeID
);

Parameters

PaymentTypeID
The Payment Type ID to retreive the Base Payment Type(Payment Types.Type) for

Return Value

A string value with the value of the Payment Types Entity Type field

Remarks

See Also

LockBoxPostRecord Class | Aptify.Applications.Accounting Namespace


LockBoxPostRecord.GetPurchaseOrderPaymentTypeID Method

Returns the lowest Payment Type ID that is for a payment type with a base type of Purchase Order. Uses the Payments Entity object's GetPurchaseOrderTypeID method.

protected virtual long GetPurchaseOrderPaymentTypeID();

Return Value

Remarks

See Also

LockBoxPostRecord Class | Aptify.Applications.Accounting Namespace


GetRefundPaymentTypeID Method

Aptify 5.0 Software Development Kit (SDK)

LockBoxPostRecord.GetRefundPaymentTypeID Method

Returns the default Refund Voucher Payment Type ID. This method uses the Payments Entity object's GetRefundVoucherTypeID method.

Overload List

Returns the default Refund Voucher Payment Type ID. This method uses the Payments Entity object's GetRefundVoucherTypeID method.

protected virtual long GetRefundPaymentTypeID();

Returns the Refund Voucher Payment Type ID for a given Payment Type, identified by OriginalPaymentTypeID. If the OriginalPaymentTypeID is a credit card, the system's default Refund Voucher Type will be used.

protected virtual long GetRefundPaymentTypeID(Int64);

See Also

LockBoxPostRecord Class | Aptify.Applications.Accounting Namespace


LockBoxPostRecord.GetRefundPaymentTypeID Method ()

Returns the default Refund Voucher Payment Type ID. This method uses the Payments Entity object's GetRefundVoucherTypeID method.

protected virtual long GetRefundPaymentTypeID();

Return Value

Remarks

See Also

LockBoxPostRecord Class | Aptify.Applications.Accounting Namespace | LockBoxPostRecord.GetRefundPaymentTypeID Overload List


LockBoxPostRecord.GetRefundPaymentTypeID Method (Int64)

Returns the Refund Voucher Payment Type ID for a given Payment Type, identified by OriginalPaymentTypeID. If the OriginalPaymentTypeID is a credit card, the system's default Refund Voucher Type will be used.

protected virtual long GetRefundPaymentTypeID(
Int64 OriginalPaymentTypeID
);

Parameters

OriginalPaymentTypeID

Return Value

Remarks

See Also

LockBoxPostRecord Class | Aptify.Applications.Accounting Namespace | LockBoxPostRecord.GetRefundPaymentTypeID Overload List


LockBoxPostRecord.PostException Method

This method is responsible for posting exception records within the cash control batch. The types of exception resolution that are supported are shown below. Resolution: * Post * Post/Refund * Post/Refund All * Allocate * Allocate/New The following steps are followed to manage posting exception records in the cash control batch. The first three resolution types(Post, Post/Refund, Post/Refund All) start off by creating a payment just like a match would get create. Then, afterwards, for Post/Refund and Post/Refund All, a refund payment is created The last two types (Allocate, Allocate/New) start off by either updating the existing order, or in the case of Allocate/New, creating a new order with lines on it from the Allocation sub-type of the cash detail record. For the allocation resolution types, the final step is a payment is posted against the original order and the new order at the same time and the NewOrderID field is filled in in the CashDetail record

public bool PostException(
AptifyGenericEntityBase CashBatchGE,
AptifyGenericEntityBase CashDetailGE,
Int32 LineNumber,
Decimal PaymentAmount
);

Parameters

CashBatchGE
CashDetailGE
LineNumber
PaymentAmount

Return Value

Implements

ILockBoxPostException.

Remarks

See Also

LockBoxPostRecord Class | Aptify.Applications.Accounting Namespace


LockBoxPostRecord.PostMatch Method

This method provides the default implementation of posting matching records in the cash control batch. The default implementation follows the following steps in doing so. 1. Create Payment Object 2. Set Payment Object Data Fields 2.1. PersonID, CompanyID 2.2. Set CashCtrlBatchID 2.3. Set DepositDate, PaymentDate, EffectiveDate 2.4. Set PaymentType 2.5. Add one payment line for the amount of PaymentAmount 3. Save Payment Object 4. Set Cash Control Detail PaymentID to the newly created Payment's ID 5. Set Cash Control Detail Status to "Posted"

public bool PostMatch(
AptifyGenericEntityBase CashBatchGE,
AptifyGenericEntityBase CashDetailGE,
Int32 LineNumber,
Decimal PaymentAmount
);

Parameters

CashBatchGE
CashDetailGE
LineNumber
PaymentAmount

Return Value

Implements

ILockBoxPostMatch.

Remarks

See Also

LockBoxPostRecord Class | Aptify.Applications.Accounting Namespace


LockBoxPostRecord.PostRefund Method

This method is called whenever an exception resolution of Refund (Either 'Refund Overpayment' or 'Refund All') is chosen for the given payment line. This method will create a new payment record that has a refund payment type.

protected virtual bool PostRefund(
AptifyGenericEntityBase CashBatchGE,
AptifyGenericEntityBase CashDetailGE,
Decimal Amount
);

Parameters

CashBatchGE
CashDetailGE
Amount
Amount to be refunded

Return Value

True if operation is a success, False Otherwise

Remarks

See Also

LockBoxPostRecord Class | Aptify.Applications.Accounting Namespace


LockBoxPostRecord.SetupPaymentHeader Method

This method is responsible for setting up a payment header for the cash control batch lock box posting process. This method sets up a variety of different fields on the payment header and can be overriden/augmented as required. Suggested method for overriding this method is to override the Function and then to make a call to the base class method implementation first before doing any additional processing.

protected virtual bool SetupPaymentHeader(
AptifyGenericEntityBase CashDetailGE,
AptifyGenericEntityBase CashBatchGE,
AptifyGenericEntityBase PaymentGE
);

Parameters

CashDetailGE
Cash Control Batch Detail Sub-Type GE Object For Current Line in Cash Batch being processed
CashBatchGE
Cash Control Batches GE Object
PaymentGE
Payments Entity GE Object

Return Value

Remarks

See Also

LockBoxPostRecord Class | Aptify.Applications.Accounting Namespace


LockBoxTextFileImport Class

This is a base class for all text file based imports for lock box and provides general file manipulation utilities to all of its sub-classes.

For a list of all members of this type, see LockBoxTextFileImport Members.

System.Object
LockBoxBase
LockBoxImportBase
LockBoxTextFileImport
DemoLockBoxImport

public class LockBoxTextFileImport : LockBoxImportBase, IDisposable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: AptifyCashControlBatch (in AptifyCashControlBatch.dll)

See Also

LockBoxTextFileImport Members | Aptify.Applications.Accounting Namespace


LockBoxTextFileImport Members

LockBoxTextFileImport overview

Public Instance Constructors

LockBoxTextFileImport Constructor Initializes a new instance of the LockBoxTextFileImport class.

Public Instance Properties

Application (inherited from LockBoxBase) | Aptify Application Instance (only available after Config() is called)
DataAction (inherited from LockBoxBase) | Aptify Data Action Instance (only available after Config() is called)
Database (inherited from LockBoxBase) | Base Database for Lock Box Application Entities (derived from Base Database of Cash Control Batches entity) (only available after Config() is called)
EOF (inherited from LockBoxImportBase) | '01/04/08 Tamasa, Added for issue 5500.This will is the EOF file is reached or not.
Properties (inherited from LockBoxImportBase) |

Public Instance Methods

Config (inherited from LockBoxImportBase) |
Dispose |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetSQLIntegerValue (inherited from LockBoxBase) | This is a utility method that returns the value of any SQL statement scalar value and casts it to a Integer type
GetSQLStringValue (inherited from LockBoxBase) | This is a utility method that returns the value of any SQL statement scalar value and casts it to a String type
GetSQLValue (inherited from LockBoxBase) | This is a utility method that returns the value of any SQL statement scalar value as a default Object type
GetStatusOfFile (inherited from LockBoxImportBase) |
GetType (inherited from Object) | Gets the Type of the current instance.
ProcessFile (inherited from LockBoxImportBase) | Overloaded. Processes a Lock box file.
Run (inherited from LockBoxImportBase) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

StatusUpdate (inherited from LockBoxImportBase)

Protected Instance Properties

BytesRead | Returns the number of bytes read so far
FileSize | Returns the size of the current file in bytes
PercentRead | Returns the percentage of the file read so far dividing Bytes Read by File Size and multiplying by 100 (Range from 0 to 100)
ReadCount | 01/04/08 Tamasa, Added for issue 5500. This will return the count of line read from file.
StreamReader | Returns the stream being operated on

Protected Instance Methods

CloseFile |
Finalize |
GetCurrentEmployeeID (inherited from LockBoxBase) | Returns the ID value from the Employees entity that matches the Current logged in user based on the provided User credentials (Uses Entity Record Relations via the spGetCurrentEmployeeID)
GetSingleFileLine |
ImportDetails (inherited from LockBoxImportBase) | This method is called once for each import process and is responsible for loading up all of the batch details from the data source. In addition, this method is expected to validate the data source integrity by comparing the Total Amount field that is passed in to the actual total amounts that exist in the file. This Total check can be skipped if the batch file or data source type does not provide header information.
ImportHeader (inherited from LockBoxImportBase) | This method is called once for each import process and is responsible for loading up any batch header information. Of specific importance is to pass back to the calling function the total amount of the batch in the TotalAmount parameter
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnStatusUpdate (inherited from LockBoxImportBase) |
OpenFile |
SetupCashBatchGE | This method setups the Cash Batch GE object with various field values that are required. This method is not called by the LockBoxTextFileImport class itself, it is intended to be called from sub-classes while their ImportHeader() routine is being executed

See Also

LockBoxTextFileImport Class | Aptify.Applications.Accounting Namespace


LockBoxTextFileImport Constructor

Initializes a new instance of the LockBoxTextFileImport class.

public LockBoxTextFileImport();

See Also

LockBoxTextFileImport Class | Aptify.Applications.Accounting Namespace


LockBoxTextFileImport Properties

The properties of the LockBoxTextFileImport class are listed below. For a complete list of LockBoxTextFileImport class members, see the LockBoxTextFileImport Members topic.

Public Instance Properties

Application (inherited from LockBoxBase) | Aptify Application Instance (only available after Config() is called)
DataAction (inherited from LockBoxBase) | Aptify Data Action Instance (only available after Config() is called)
Database (inherited from LockBoxBase) | Base Database for Lock Box Application Entities (derived from Base Database of Cash Control Batches entity) (only available after Config() is called)
EOF (inherited from LockBoxImportBase) | '01/04/08 Tamasa, Added for issue 5500.This will is the EOF file is reached or not.
Properties (inherited from LockBoxImportBase) |

Protected Instance Properties

BytesRead | Returns the number of bytes read so far
FileSize | Returns the size of the current file in bytes
PercentRead | Returns the percentage of the file read so far dividing Bytes Read by File Size and multiplying by 100 (Range from 0 to 100)
ReadCount | 01/04/08 Tamasa, Added for issue 5500. This will return the count of line read from file.
StreamReader | Returns the stream being operated on

See Also

LockBoxTextFileImport Class | Aptify.Applications.Accounting Namespace


BytesRead Property

Aptify 5.0 Software Development Kit (SDK)

LockBoxTextFileImport.BytesRead Property

Returns the number of bytes read so far

protected virtual Int64 BytesRead {get;}

Property Value

Remarks

See Also

LockBoxTextFileImport Class | Aptify.Applications.Accounting Namespace


FileSize Property

Aptify 5.0 Software Development Kit (SDK)

LockBoxTextFileImport.FileSize Property

Returns the size of the current file in bytes

protected virtual Int64 FileSize {get;}

Property Value

Remarks

See Also

LockBoxTextFileImport Class | Aptify.Applications.Accounting Namespace


PercentRead Property

Aptify 5.0 Software Development Kit (SDK)

LockBoxTextFileImport.PercentRead Property

Returns the percentage of the file read so far dividing Bytes Read by File Size and multiplying by 100 (Range from 0 to 100)

protected virtual Int32 PercentRead {get;}

Property Value

Remarks

See Also

LockBoxTextFileImport Class | Aptify.Applications.Accounting Namespace


ReadCount Property

Aptify 5.0 Software Development Kit (SDK)

LockBoxTextFileImport.ReadCount Property

01/04/08 Tamasa, Added for issue 5500. This will return the count of line read from file.

protected Int32 ReadCount {get; set;}

Property Value

Remarks

See Also

LockBoxTextFileImport Class | Aptify.Applications.Accounting Namespace


StreamReader Property

Aptify 5.0 Software Development Kit (SDK)

LockBoxTextFileImport.StreamReader Property

Returns the stream being operated on

protected virtual StreamReader StreamReader {get;}

Property Value

Remarks

Nothing if the stream has not been opened

See Also

LockBoxTextFileImport Class | Aptify.Applications.Accounting Namespace


LockBoxTextFileImport Methods

The methods of the LockBoxTextFileImport class are listed below. For a complete list of LockBoxTextFileImport class members, see the LockBoxTextFileImport Members topic.

Public Instance Methods

Config (inherited from LockBoxImportBase) |
Dispose |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetSQLIntegerValue (inherited from LockBoxBase) | This is a utility method that returns the value of any SQL statement scalar value and casts it to a Integer type
GetSQLStringValue (inherited from LockBoxBase) | This is a utility method that returns the value of any SQL statement scalar value and casts it to a String type
GetSQLValue (inherited from LockBoxBase) | This is a utility method that returns the value of any SQL statement scalar value as a default Object type
GetStatusOfFile (inherited from LockBoxImportBase) |
GetType (inherited from Object) | Gets the Type of the current instance.
ProcessFile (inherited from LockBoxImportBase) | Overloaded. Processes a Lock box file.
Run (inherited from LockBoxImportBase) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CloseFile |
Finalize |
GetCurrentEmployeeID (inherited from LockBoxBase) | Returns the ID value from the Employees entity that matches the Current logged in user based on the provided User credentials (Uses Entity Record Relations via the spGetCurrentEmployeeID)
GetSingleFileLine |
ImportDetails (inherited from LockBoxImportBase) | This method is called once for each import process and is responsible for loading up all of the batch details from the data source. In addition, this method is expected to validate the data source integrity by comparing the Total Amount field that is passed in to the actual total amounts that exist in the file. This Total check can be skipped if the batch file or data source type does not provide header information.
ImportHeader (inherited from LockBoxImportBase) | This method is called once for each import process and is responsible for loading up any batch header information. Of specific importance is to pass back to the calling function the total amount of the batch in the TotalAmount parameter
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnStatusUpdate (inherited from LockBoxImportBase) |
OpenFile |
SetupCashBatchGE | This method setups the Cash Batch GE object with various field values that are required. This method is not called by the LockBoxTextFileImport class itself, it is intended to be called from sub-classes while their ImportHeader() routine is being executed

See Also

LockBoxTextFileImport Class | Aptify.Applications.Accounting Namespace


LockBoxTextFileImport.CloseFile Method

protected override void CloseFile();

See Also

LockBoxTextFileImport Class | Aptify.Applications.Accounting Namespace


LockBoxTextFileImport.Dispose Method

public void Dispose();

Implements

IDisposable.

See Also

LockBoxTextFileImport Class | Aptify.Applications.Accounting Namespace


LockBoxTextFileImport.Finalize Method

protected override void Finalize();

See Also

LockBoxTextFileImport Class | Aptify.Applications.Accounting Namespace


LockBoxTextFileImport.GetSingleFileLine Method

protected string GetSingleFileLine();

See Also

LockBoxTextFileImport Class | Aptify.Applications.Accounting Namespace


LockBoxTextFileImport.OpenFile Method

protected override void OpenFile(
String FileName
);

See Also

LockBoxTextFileImport Class | Aptify.Applications.Accounting Namespace


LockBoxTextFileImport.SetupCashBatchGE Method

This method setups the Cash Batch GE object with various field values that are required. This method is not called by the LockBoxTextFileImport class itself, it is intended to be called from sub-classes while their ImportHeader() routine is being executed

protected virtual AptifyGenericEntityBase SetupCashBatchGE(
AptifyGenericEntityBase CashBatchGE,
Int64 PaymentTypeID,
DateTime DepositDate,
String BankBatchID
);

Parameters

CashBatchGE
PaymentTypeID
DepositDate
BankBatchID

Return Value

Nothing if there was a failure. If a valida object was returned then there was success.

Remarks

The objects that are returned are populated, but not saved.

See Also

LockBoxTextFileImport Class | Aptify.Applications.Accounting Namespace


LockBoxWizard Class

Displays a Wizard that walks users through importing a Lock Box File.

For a list of all members of this type, see LockBoxWizard Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
LockBoxWizard

public class LockBoxWizard : Form, IAptifyAction

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: AptifyLockBoxWizard (in AptifyLockBoxWizard.dll)

See Also

LockBoxWizard Members | Aptify.Applications.Accounting Namespace


LockBoxWizard Members

LockBoxWizard overview

Public Instance Constructors

LockBoxWizard Constructor Initializes a new instance of the LockBoxWizard class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoAction | Overloaded.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

m_oObjectRepository

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
LockBoxImportFinished | This is called when the Importing process is finished.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
StatusUpdateHandler | Gets called during status updates.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

LockBoxWizard Class | Aptify.Applications.Accounting Namespace


LockBoxWizard Constructor

Initializes a new instance of the LockBoxWizard class.

public LockBoxWizard();

See Also

LockBoxWizard Class | Aptify.Applications.Accounting Namespace


LockBoxWizard Fields

The fields of the LockBoxWizard class are listed below. For a complete list of LockBoxWizard class members, see the LockBoxWizard Members topic.

Protected Instance Fields

m_oObjectRepository

See Also

LockBoxWizard Class | Aptify.Applications.Accounting Namespace


LockBoxWizard.m_oObjectRepository Field

protected m_oObjectRepository m_oObjectRepository;

See Also

LockBoxWizard Class | Aptify.Applications.Accounting Namespace


LockBoxWizard Methods

The methods of the LockBoxWizard class are listed below. For a complete list of LockBoxWizard class members, see the LockBoxWizard Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoAction | Overloaded.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
LockBoxImportFinished | This is called when the Importing process is finished.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
StatusUpdateHandler | Gets called during status updates.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

LockBoxWizard Class | Aptify.Applications.Accounting Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

LockBoxWizard.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

LockBoxWizard Class | Aptify.Applications.Accounting Namespace


LockBoxWizard.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

LockBoxWizard Class | Aptify.Applications.Accounting Namespace | LockBoxWizard.Dispose Overload List


DoAction Method

Aptify 5.0 Software Development Kit (SDK)

LockBoxWizard.DoAction Method

Overload List

public void DoAction(AptifyApplication,Int64);

public void DoAction(AptifyApplication,Int64,Int64);

Starts the Aptify Lock Box Wizard.

public void DoAction(AptifyApplication,Int64,Int64,params Object[]);

public void DoAction(AptifyApplication,Int64,params String[]);

See Also

LockBoxWizard Class | Aptify.Applications.Accounting Namespace


LockBoxWizard.DoAction Method (AptifyApplication, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID
);

Implements

IAptifyAction.

See Also

LockBoxWizard Class | Aptify.Applications.Accounting Namespace | LockBoxWizard.DoAction Overload List


LockBoxWizard.DoAction Method (AptifyApplication, Int64, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID
);

Implements

IAptifyAction.

See Also

LockBoxWizard Class | Aptify.Applications.Accounting Namespace | LockBoxWizard.DoAction Overload List


LockBoxWizard.DoAction Method (AptifyApplication, Int64, Int64, Object[])

Starts the Aptify Lock Box Wizard.

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID,
params Object[] SelectedItems
);

Parameters

ApplicationObject
A valid AptifyApplication.
EntityID
Not Used
ViewID
Not Used
SelectedItems
Not Used

Implements

IAptifyAction.

Remarks

See Also

LockBoxWizard Class | Aptify.Applications.Accounting Namespace | LockBoxWizard.DoAction Overload List


LockBoxWizard.DoAction Method (AptifyApplication, Int64, String[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
params String[] SelectedItems
);

Implements

IAptifyAction.

See Also

LockBoxWizard Class | Aptify.Applications.Accounting Namespace | LockBoxWizard.DoAction Overload List


LockBoxWizard.LockBoxImportFinished Method

This is called when the Importing process is finished.

protected void LockBoxImportFinished(
AptifyGenericEntityBase CCBGE
);

Remarks

This method will be thread safe.

See Also

LockBoxWizard Class | Aptify.Applications.Accounting Namespace


LockBoxWizard.StatusUpdateHandler Method

Gets called during status updates.

protected void StatusUpdateHandler(
Int32 PercentComplete,
ref Boolean& Cancel
);

Parameters

PercentComplete
Cancel

Remarks

This method has been marshaled to be thread safe.

See Also

LockBoxWizard Class | Aptify.Applications.Accounting Namespace


NavisionExport Class

For a list of all members of this type, see NavisionExport Members.

System.Object
NavisionExport

public class NavisionExport : IGLExport

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: GLExportDrivers (in GLExportDrivers.dll)

See Also

NavisionExport Members | Aptify.Applications.Accounting Namespace


NavisionExport Members

NavisionExport overview

Public Instance Constructors

NavisionExport Overloaded. Initializes a new instance of the NavisionExport class.

Public Instance Methods

DoGLExport |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NavisionExport Class | Aptify.Applications.Accounting Namespace


NavisionExport Constructor

Default constructor

Overload List

Default constructor

public NavisionExport();

public NavisionExport(AptifyApplication);

See Also

NavisionExport Class | Aptify.Applications.Accounting Namespace


NavisionExport Constructor ()

Default constructor

public NavisionExport();

Remarks

See Also

NavisionExport Class | Aptify.Applications.Accounting Namespace | NavisionExport Constructor Overload List


NavisionExport Constructor (AptifyApplication)

public NavisionExport(
AptifyApplication Application
);

See Also

NavisionExport Class | Aptify.Applications.Accounting Namespace | NavisionExport Constructor Overload List


NavisionExport Methods

The methods of the NavisionExport class are listed below. For a complete list of NavisionExport class members, see the NavisionExport Members topic.

Public Instance Methods

DoGLExport |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NavisionExport Class | Aptify.Applications.Accounting Namespace


NavisionExport.DoGLExport Method

public bool DoGLExport(
AptifyGenericEntityBase BatchGE,
String DefaultExportLocation,
Boolean ShowGUI
);

Implements

IGLExport.

See Also

NavisionExport Class | Aptify.Applications.Accounting Namespace


OrderPaymentTotals Class

For a list of all members of this type, see OrderPaymentTotals Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
OrderPaymentTotals

public class OrderPaymentTotals : FormComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: AptifyCashControlBatchesGUI (in AptifyCashControlBatchesGUI.dll)

See Also

OrderPaymentTotals Members | Aptify.Applications.Accounting Namespace


OrderPaymentTotals Members

OrderPaymentTotals overview

Public Instance Constructors

OrderPaymentTotals Constructor Initializes a new instance of the OrderPaymentTotals class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormComponent) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetOrderTotal |
SetPriorPmts |
SetThisPmt |
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateContext (inherited from FormComponent) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormComponent) |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormComponent) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormComponent) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormComponent) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

OrderPaymentTotals Class | Aptify.Applications.Accounting Namespace


OrderPaymentTotals Constructor

Initializes a new instance of the OrderPaymentTotals class.

public OrderPaymentTotals();

See Also

OrderPaymentTotals Class | Aptify.Applications.Accounting Namespace


OrderPaymentTotals Methods

The methods of the OrderPaymentTotals class are listed below. For a complete list of OrderPaymentTotals class members, see the OrderPaymentTotals Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormComponent) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetOrderTotal |
SetPriorPmts |
SetThisPmt |
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormComponent) |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormComponent) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormComponent) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormComponent) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

OrderPaymentTotals Class | Aptify.Applications.Accounting Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

OrderPaymentTotals.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

OrderPaymentTotals Class | Aptify.Applications.Accounting Namespace


OrderPaymentTotals.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

OrderPaymentTotals Class | Aptify.Applications.Accounting Namespace | OrderPaymentTotals.Dispose Overload List


OrderPaymentTotals.SetOrderTotal Method

public void SetOrderTotal(
Decimal OrderTotal
);

See Also

OrderPaymentTotals Class | Aptify.Applications.Accounting Namespace


OrderPaymentTotals.SetPriorPmts Method

public void SetPriorPmts(
Decimal PriorPmts
);

See Also

OrderPaymentTotals Class | Aptify.Applications.Accounting Namespace


OrderPaymentTotals.SetThisPmt Method

public void SetThisPmt(
Decimal Pmt
);

See Also

OrderPaymentTotals Class | Aptify.Applications.Accounting Namespace


OrganizationTaxAddressCache Class

Caches Organization Address information in TaxAddress objects. Shared, on-demand cache.

For a list of all members of this type, see OrganizationTaxAddressCache Members.

System.Object
OrganizationTaxAddressCache

public class OrganizationTaxAddressCache

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: AptifySalesTax (in AptifySalesTax.dll)

See Also

OrganizationTaxAddressCache Members | Aptify.Applications.Accounting Namespace


OrganizationTaxAddressCache Members

OrganizationTaxAddressCache overview

Public Static Methods

Instance

Public Instance Properties

OrganizationTaxAddress This method will either return a TaxAddress object from the cache or, if the cache doesn't contain a TaxAddress object for the Organization, the information will be retrieved from the database and used to populate a TaxAddress object which will be added to the cache and returned to the caller.

Public Instance Methods

Clear | Clears the Organizations TaxAddress cache.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
RemoveOrganizationAddressFromCache |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

OrganizationTaxAddressCache Class | Aptify.Applications.Accounting Namespace


OrganizationTaxAddressCache Properties

The properties of the OrganizationTaxAddressCache class are listed below. For a complete list of OrganizationTaxAddressCache class members, see the OrganizationTaxAddressCache Members topic.

Public Instance Properties

OrganizationTaxAddress This method will either return a TaxAddress object from the cache or, if the cache doesn't contain a TaxAddress object for the Organization, the information will be retrieved from the database and used to populate a TaxAddress object which will be added to the cache and returned to the caller.

See Also

OrganizationTaxAddressCache Class | Aptify.Applications.Accounting Namespace


OrganizationTaxAddress Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationTaxAddressCache.OrganizationTaxAddress Property

This method will either return a TaxAddress object from the cache or, if the cache doesn't contain a TaxAddress object for the Organization, the information will be retrieved from the database and used to populate a TaxAddress object which will be added to the cache and returned to the caller.

public virtual TaxAddress this[
Int64 OrganizationID,
Boolean ForceRefresh
] {get;}

Parameters

OrganizationID
ForceRefresh

Property Value

Remarks

See Also

OrganizationTaxAddressCache Class | Aptify.Applications.Accounting Namespace


OrganizationTaxAddressCache Methods

The methods of the OrganizationTaxAddressCache class are listed below. For a complete list of OrganizationTaxAddressCache class members, see the OrganizationTaxAddressCache Members topic.

Public Static Methods

Instance

Public Instance Methods

Clear | Clears the Organizations TaxAddress cache.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
RemoveOrganizationAddressFromCache |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

OrganizationTaxAddressCache Class | Aptify.Applications.Accounting Namespace


OrganizationTaxAddressCache.Clear Method

Clears the Organizations TaxAddress cache.

public void Clear();

Remarks

See Also

OrganizationTaxAddressCache Class | Aptify.Applications.Accounting Namespace


OrganizationTaxAddressCache.Instance Method

public static OrganizationTaxAddressCache Instance(
AptifyApplication Application
);

See Also

OrganizationTaxAddressCache Class | Aptify.Applications.Accounting Namespace


OrganizationTaxAddressCache.RemoveOrganizationAddressFromCache Method

public virtual void RemoveOrganizationAddressFromCache(
Int64 OrganizationID
);

See Also

OrganizationTaxAddressCache Class | Aptify.Applications.Accounting Namespace


PaymentInformation Class

This class provides the default business logic implementation for the Payment Information entity.

For a list of all members of this type, see PaymentInformation Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
PaymentInformation

public class PaymentInformation : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: PaymentInfoObject (in PaymentInfoObject.dll)

See Also

PaymentInformation Members | Aptify.Applications.Accounting Namespace


PaymentInformation Members

PaymentInformation overview

Public Static Methods

GetSharedCCPartial This method is responsible for creating a "Partial" string for a Credit Card number. Credit Card numbers should be encrypted in the database and likely will also have field-level security applied to them. For users to identify credit card numbers for payment validation and future analysis, the Partial field is used. Typical Partial-Field examples include showing the "Last Four" digits or the first digit and last 3 digits, etc. The default implementation of this method will show the First Digit of the Credit Card Number, followed by 13 "x" characters and then the last 3 digits.

Public Instance Constructors

PaymentInformation Constructor Initializes a new instance of the PaymentInformation class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CreditCardSecurityNumber |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SavedPaymentMethodCache |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
CopySavedPaymentMethodToCurrent |
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetCCPartial | This method is responsible for creating a "Partial" string for a Credit Card number. Credit Card numbers should be encrypted in the database and likely will also have field-level security applied to them. For users to identify credit card numbers for payment validation and future analysis, the Partial field is used. Typical Partial-Field examples include showing the "Last Four" digits or the first digit and last 3 digits, etc. The default implementation of this method will show the First Digit of the Credit Card Number, followed by 13 "x" characters and then the last 3 digits.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LoadSavedPayments | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded. This method overrides the base class Save() method and ensures that the Credit Card Partial field is updated whenever the Credit Card Account Number field is updated. The default behavior for this method is to call the GetCCPartial() method of this class, which can be overriden in sub-classes to change the methodology for partial credit card number storage. See the GetCCPartial() method for more information.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

PaymentInformation Class | Aptify.Applications.Accounting Namespace


PaymentInformation Constructor

Initializes a new instance of the PaymentInformation class.

public PaymentInformation();

See Also

PaymentInformation Class | Aptify.Applications.Accounting Namespace


PaymentInformation Properties

The properties of the PaymentInformation class are listed below. For a complete list of PaymentInformation class members, see the PaymentInformation Members topic.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CreditCardSecurityNumber |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SavedPaymentMethodCache |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

PaymentInformation Class | Aptify.Applications.Accounting Namespace


CreditCardSecurityNumber Property

Aptify 5.0 Software Development Kit (SDK)

PaymentInformation.CreditCardSecurityNumber Property

public String CreditCardSecurityNumber {get; set;}

See Also

PaymentInformation Class | Aptify.Applications.Accounting Namespace


SavedPaymentMethodCache Property

Aptify 5.0 Software Development Kit (SDK)

PaymentInformation.SavedPaymentMethodCache Property

public Dictionary<TKey,TValue> SavedPaymentMethodCache {get;}

See Also

PaymentInformation Class | Aptify.Applications.Accounting Namespace


PaymentInformation Methods

The methods of the PaymentInformation class are listed below. For a complete list of PaymentInformation class members, see the PaymentInformation Members topic.

Public Static Methods

GetSharedCCPartial This method is responsible for creating a "Partial" string for a Credit Card number. Credit Card numbers should be encrypted in the database and likely will also have field-level security applied to them. For users to identify credit card numbers for payment validation and future analysis, the Partial field is used. Typical Partial-Field examples include showing the "Last Four" digits or the first digit and last 3 digits, etc. The default implementation of this method will show the First Digit of the Credit Card Number, followed by 13 "x" characters and then the last 3 digits.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
CopySavedPaymentMethodToCurrent |
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetCCPartial | This method is responsible for creating a "Partial" string for a Credit Card number. Credit Card numbers should be encrypted in the database and likely will also have field-level security applied to them. For users to identify credit card numbers for payment validation and future analysis, the Partial field is used. Typical Partial-Field examples include showing the "Last Four" digits or the first digit and last 3 digits, etc. The default implementation of this method will show the First Digit of the Credit Card Number, followed by 13 "x" characters and then the last 3 digits.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LoadSavedPayments | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded. This method overrides the base class Save() method and ensures that the Credit Card Partial field is updated whenever the Credit Card Account Number field is updated. The default behavior for this method is to call the GetCCPartial() method of this class, which can be overriden in sub-classes to change the methodology for partial credit card number storage. See the GetCCPartial() method for more information.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

PaymentInformation Class | Aptify.Applications.Accounting Namespace


PaymentInformation.CopySavedPaymentMethodToCurrent Method

public bool CopySavedPaymentMethodToCurrent(
Int64 lPaymentInfoID
);

See Also

PaymentInformation Class | Aptify.Applications.Accounting Namespace


PaymentInformation.GetCCPartial Method

This method is responsible for creating a "Partial" string for a Credit Card number. Credit Card numbers should be encrypted in the database and likely will also have field-level security applied to them. For users to identify credit card numbers for payment validation and future analysis, the Partial field is used. Typical Partial-Field examples include showing the "Last Four" digits or the first digit and last 3 digits, etc. The default implementation of this method will show the First Digit of the Credit Card Number, followed by 13 "x" characters and then the last 3 digits.

public virtual string GetCCPartial(
String CreditCardNumber
);

Parameters

CreditCardNumber

Return Value

Remarks

See Also

PaymentInformation Class | Aptify.Applications.Accounting Namespace


PaymentInformation.GetSharedCCPartial Method

This method is responsible for creating a "Partial" string for a Credit Card number. Credit Card numbers should be encrypted in the database and likely will also have field-level security applied to them. For users to identify credit card numbers for payment validation and future analysis, the Partial field is used. Typical Partial-Field examples include showing the "Last Four" digits or the first digit and last 3 digits, etc. The default implementation of this method will show the First Digit of the Credit Card Number, followed by 13 "x" characters and then the last 3 digits.

public static string GetSharedCCPartial(
String CreditCardNumber
);

Parameters

CreditCardNumber

Return Value

Remarks

This shared function can be used by UI components to format a CC Number to a control.

See Also

PaymentInformation Class | Aptify.Applications.Accounting Namespace


LoadSavedPayments Method

Aptify 5.0 Software Development Kit (SDK)

PaymentInformation.LoadSavedPayments Method

Overload List

public virtual void LoadSavedPayments(Int64);

public virtual void LoadSavedPayments(Int64,Int64);

See Also

PaymentInformation Class | Aptify.Applications.Accounting Namespace


PaymentInformation.LoadSavedPayments Method (Int64)

public virtual void LoadSavedPayments(
Int64 lPersonID
);

See Also

PaymentInformation Class | Aptify.Applications.Accounting Namespace | PaymentInformation.LoadSavedPayments Overload List


PaymentInformation.LoadSavedPayments Method (Int64, Int64)

public virtual void LoadSavedPayments(
Int64 lPersonID,
Int64 lCompanyID
);

See Also

PaymentInformation Class | Aptify.Applications.Accounting Namespace | PaymentInformation.LoadSavedPayments Overload List


Save Method

Aptify 5.0 Software Development Kit (SDK)

PaymentInformation.Save Method

This method overrides the base class Save() method and ensures that the Credit Card Partial field is updated whenever the Credit Card Account Number field is updated. The default behavior for this method is to call the GetCCPartial() method of this class, which can be overriden in sub-classes to change the methodology for partial credit card number storage. See the GetCCPartial() method for more information.

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Save();

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean,ref String&);

This method overrides the base class Save() method and ensures that the Credit Card Partial field is updated whenever the Credit Card Account Number field is updated. The default behavior for this method is to call the GetCCPartial() method of this class, which can be overriden in sub-classes to change the methodology for partial credit card number storage. See the GetCCPartial() method for more information.

public override bool Save(Boolean,ref String&,String);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(ref String&);

See Also

PaymentInformation Class | Aptify.Applications.Accounting Namespace


PaymentInformation.Save Method (Boolean, String&, String)

This method overrides the base class Save() method and ensures that the Credit Card Partial field is updated whenever the Credit Card Account Number field is updated. The default behavior for this method is to call the GetCCPartial() method of this class, which can be overriden in sub-classes to change the methodology for partial credit card number storage. See the GetCCPartial() method for more information.

public override bool Save(
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

Parameters

AllowGUI
ErrorString
TransactionID

Return Value

Remarks

See Also

PaymentInformation Class | Aptify.Applications.Accounting Namespace | PaymentInformation.Save Overload List


Validate Method

Aptify 5.0 Software Development Kit (SDK)

PaymentInformation.Validate Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Validate();

public override bool Validate(ref String&);

See Also

PaymentInformation Class | Aptify.Applications.Accounting Namespace


PaymentInformation.Validate Method (String&)

public override bool Validate(
ref String& ErrorString
);

See Also

PaymentInformation Class | Aptify.Applications.Accounting Namespace | PaymentInformation.Validate Overload List


PaymentInformation.BasePaymentTypes Enumeration

public enum PaymentInformation.BasePaymentTypes

Members

Member Name | Description
Check |
CreditCard |
PurchaseOrder |
ACH |
CreditMemo |
RefundVoucher |

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: PaymentInfoObject (in PaymentInfoObject.dll)

See Also

Aptify.Applications.Accounting Namespace


PaymentType Class

For a list of all members of this type, see PaymentType Members.

System.Object
PaymentType

public class PaymentType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: PaymentInfoObject (in PaymentInfoObject.dll)

See Also

PaymentType Members | Aptify.Applications.Accounting Namespace


PaymentType Members

PaymentType overview

Public Instance Constructors

PaymentType Constructor

Public Instance Properties

Active
ApplyServiceCharge
Description
GeneratedCreditMemoProductID
ID
Inflow
Name
RefundVoucherPaymentTypeID
ServiceChargeFlatFee
ServiceChargeFlatFeeCurrencyTypeID
ServiceChargeGLAcccount
ServiceChargeLiabilityGLAccount
ServiceChargeMethod
ServiceChargePercent
ServiceChargeType
Type

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsValidForOrganization | Given the ID of an Organization, return whether or not the Payment Type is valid/supported for that Organization.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PaymentType Class | Aptify.Applications.Accounting Namespace


PaymentType Constructor

public PaymentType(
DataRow row,
List<T> SupportedOrganizationIDs
);

See Also

PaymentType Class | Aptify.Applications.Accounting Namespace


PaymentType Properties

The properties of the PaymentType class are listed below. For a complete list of PaymentType class members, see the PaymentType Members topic.

Public Instance Properties

Active
ApplyServiceCharge
Description
GeneratedCreditMemoProductID
ID
Inflow
Name
RefundVoucherPaymentTypeID
ServiceChargeFlatFee
ServiceChargeFlatFeeCurrencyTypeID
ServiceChargeGLAcccount
ServiceChargeLiabilityGLAccount
ServiceChargeMethod
ServiceChargePercent
ServiceChargeType
Type

See Also

PaymentType Class | Aptify.Applications.Accounting Namespace


Active Property

Aptify 5.0 Software Development Kit (SDK)

PaymentType.Active Property

public Boolean Active {get;}

See Also

PaymentType Class | Aptify.Applications.Accounting Namespace


ApplyServiceCharge Property

Aptify 5.0 Software Development Kit (SDK)

PaymentType.ApplyServiceCharge Property

public Boolean ApplyServiceCharge {get;}

See Also

PaymentType Class | Aptify.Applications.Accounting Namespace


Description Property

Aptify 5.0 Software Development Kit (SDK)

PaymentType.Description Property

public String Description {get;}

See Also

PaymentType Class | Aptify.Applications.Accounting Namespace


GeneratedCreditMemoProductID Property

Aptify 5.0 Software Development Kit (SDK)

PaymentType.GeneratedCreditMemoProductID Property

public Int64 GeneratedCreditMemoProductID {get;}

See Also

PaymentType Class | Aptify.Applications.Accounting Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

PaymentType.ID Property

public Int64 ID {get;}

See Also

PaymentType Class | Aptify.Applications.Accounting Namespace


Inflow Property

Aptify 5.0 Software Development Kit (SDK)

PaymentType.Inflow Property

public Boolean Inflow {get;}

See Also

PaymentType Class | Aptify.Applications.Accounting Namespace


Name Property

Aptify 5.0 Software Development Kit (SDK)

PaymentType.Name Property

public String Name {get;}

See Also

PaymentType Class | Aptify.Applications.Accounting Namespace


RefundVoucherPaymentTypeID Property

Aptify 5.0 Software Development Kit (SDK)

PaymentType.RefundVoucherPaymentTypeID Property

public Int64 RefundVoucherPaymentTypeID {get;}

See Also

PaymentType Class | Aptify.Applications.Accounting Namespace


ServiceChargeFlatFee Property

Aptify 5.0 Software Development Kit (SDK)

PaymentType.ServiceChargeFlatFee Property

public Decimal ServiceChargeFlatFee {get;}

See Also

PaymentType Class | Aptify.Applications.Accounting Namespace


ServiceChargeFlatFeeCurrencyTypeID Property

Aptify 5.0 Software Development Kit (SDK)

PaymentType.ServiceChargeFlatFeeCurrencyTypeID Property

public Int32 ServiceChargeFlatFeeCurrencyTypeID {get;}

See Also

PaymentType Class | Aptify.Applications.Accounting Namespace


ServiceChargeGLAcccount Property

Aptify 5.0 Software Development Kit (SDK)

PaymentType.ServiceChargeGLAcccount Property

public String ServiceChargeGLAcccount {get;}

See Also

PaymentType Class | Aptify.Applications.Accounting Namespace


ServiceChargeLiabilityGLAccount Property

Aptify 5.0 Software Development Kit (SDK)

PaymentType.ServiceChargeLiabilityGLAccount Property

public String ServiceChargeLiabilityGLAccount {get;}

See Also

PaymentType Class | Aptify.Applications.Accounting Namespace


ServiceChargeMethod Property

Aptify 5.0 Software Development Kit (SDK)

PaymentType.ServiceChargeMethod Property

public PaymentType.PaymentTypeServiceChargeMethod ServiceChargeMethod {get;}

See Also

PaymentType Class | Aptify.Applications.Accounting Namespace


ServiceChargePercent Property

Aptify 5.0 Software Development Kit (SDK)

PaymentType.ServiceChargePercent Property

public Decimal ServiceChargePercent {get;}

See Also

PaymentType Class | Aptify.Applications.Accounting Namespace


ServiceChargeType Property

Aptify 5.0 Software Development Kit (SDK)

PaymentType.ServiceChargeType Property

public PaymentType.PaymentTypeServiceChargeType ServiceChargeType {get;}

See Also

PaymentType Class | Aptify.Applications.Accounting Namespace


Type Property

Aptify 5.0 Software Development Kit (SDK)

PaymentType.Type Property

public String Type {get;}

See Also

PaymentType Class | Aptify.Applications.Accounting Namespace


PaymentType Methods

The methods of the PaymentType class are listed below. For a complete list of PaymentType class members, see the PaymentType Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsValidForOrganization | Given the ID of an Organization, return whether or not the Payment Type is valid/supported for that Organization.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PaymentType Class | Aptify.Applications.Accounting Namespace


PaymentType.IsValidForOrganization Method

Given the ID of an Organization, return whether or not the Payment Type is valid/supported for that Organization.

public bool IsValidForOrganization(
Int64 OrganizationID
);

Parameters

OrganizationID

Return Value

Remarks

See Also

PaymentType Class | Aptify.Applications.Accounting Namespace


PaymentType.PaymentTypeServiceChargeMethod Enumeration

public enum PaymentType.PaymentTypeServiceChargeMethod

Members

Member Name | Description
Net |
Gross |

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: PaymentInfoObject (in PaymentInfoObject.dll)

See Also

Aptify.Applications.Accounting Namespace


PaymentType.PaymentTypeServiceChargeType Enumeration

public enum PaymentType.PaymentTypeServiceChargeType

Members

Member Name | Description
Percentage |
Flat |
Both |

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: PaymentInfoObject (in PaymentInfoObject.dll)

See Also

Aptify.Applications.Accounting Namespace


PaymentTypeCache Class

For a list of all members of this type, see PaymentTypeCache Members.

System.Object
PaymentTypeCache

public class PaymentTypeCache

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: PaymentInfoObject (in PaymentInfoObject.dll)

See Also

PaymentTypeCache Members | Aptify.Applications.Accounting Namespace


PaymentTypeCache Members

PaymentTypeCache overview

Public Static Methods

Instance

Public Instance Constructors

PaymentTypeCache Constructor

Public Instance Properties

PaymentType This method will return a PaymentType object from the cache.

Public Instance Methods

Clear | Clears the Payment Types GL Accounts cache.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetOrganizationPaymentTypes | Gets the List of PaymentType objects that are by the Organization passed in.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PaymentTypeCache Class | Aptify.Applications.Accounting Namespace


PaymentTypeCache Constructor

public PaymentTypeCache(
AptifyApplication Application
);

See Also

PaymentTypeCache Class | Aptify.Applications.Accounting Namespace


PaymentTypeCache Properties

The properties of the PaymentTypeCache class are listed below. For a complete list of PaymentTypeCache class members, see the PaymentTypeCache Members topic.

Public Instance Properties

PaymentType This method will return a PaymentType object from the cache.

See Also

PaymentTypeCache Class | Aptify.Applications.Accounting Namespace


PaymentType Property

Aptify 5.0 Software Development Kit (SDK)

PaymentTypeCache.PaymentType Property

This method will return a PaymentType object from the cache.

public virtual PaymentType this[
Int64 ID
] {get;}

Parameters

ID

Property Value

Remarks

See Also

PaymentTypeCache Class | Aptify.Applications.Accounting Namespace


PaymentTypeCache Methods

The methods of the PaymentTypeCache class are listed below. For a complete list of PaymentTypeCache class members, see the PaymentTypeCache Members topic.

Public Static Methods

Instance

Public Instance Methods

Clear | Clears the Payment Types GL Accounts cache.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetOrganizationPaymentTypes | Gets the List of PaymentType objects that are by the Organization passed in.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PaymentTypeCache Class | Aptify.Applications.Accounting Namespace


PaymentTypeCache.Clear Method

Clears the Payment Types GL Accounts cache.

public void Clear();

Remarks

See Also

PaymentTypeCache Class | Aptify.Applications.Accounting Namespace


PaymentTypeCache.GetOrganizationPaymentTypes Method

Gets the List of PaymentType objects that are by the Organization passed in.

public virtual List<T> GetOrganizationPaymentTypes(
Int64 OrganizationID
);

Parameters

OrganizationID

Return Value

Remarks

See Also

PaymentTypeCache Class | Aptify.Applications.Accounting Namespace


PaymentTypeCache.Instance Method

public static PaymentTypeCache Instance(
AptifyApplication Application
);

See Also

PaymentTypeCache Class | Aptify.Applications.Accounting Namespace


RossFinancialsExport Class

For a list of all members of this type, see RossFinancialsExport Members.

System.Object
RossFinancialsExport

public class RossFinancialsExport : IGLExport

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: GLExportDrivers (in GLExportDrivers.dll)

See Also

RossFinancialsExport Members | Aptify.Applications.Accounting Namespace


RossFinancialsExport Members

RossFinancialsExport overview

Public Instance Constructors

RossFinancialsExport Overloaded. Initializes a new instance of the RossFinancialsExport class.

Public Instance Methods

CreateAndSaveWorkBook |
DoGLExport |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RossFinancialsExport Class | Aptify.Applications.Accounting Namespace


RossFinancialsExport Constructor

Default constructor

Overload List

Default constructor

public RossFinancialsExport();

public RossFinancialsExport(AptifyApplication);

See Also

RossFinancialsExport Class | Aptify.Applications.Accounting Namespace


RossFinancialsExport Constructor ()

Default constructor

public RossFinancialsExport();

Remarks

See Also

RossFinancialsExport Class | Aptify.Applications.Accounting Namespace | RossFinancialsExport Constructor Overload List


RossFinancialsExport Constructor (AptifyApplication)

public RossFinancialsExport(
AptifyApplication Application
);

See Also

RossFinancialsExport Class | Aptify.Applications.Accounting Namespace | RossFinancialsExport Constructor Overload List


RossFinancialsExport Methods

The methods of the RossFinancialsExport class are listed below. For a complete list of RossFinancialsExport class members, see the RossFinancialsExport Members topic.

Public Instance Methods

CreateAndSaveWorkBook |
DoGLExport |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RossFinancialsExport Class | Aptify.Applications.Accounting Namespace


RossFinancialsExport.CreateAndSaveWorkBook Method

public bool CreateAndSaveWorkBook(
String Name,
String Address,
String SheetName,
DataTable oDataTable,
Boolean ShowGUI,
Cursor LastCursor
);

See Also

RossFinancialsExport Class | Aptify.Applications.Accounting Namespace


RossFinancialsExport.DoGLExport Method

public bool DoGLExport(
AptifyGenericEntityBase BatchGE,
String DefaultExportLocation,
Boolean ShowGUI
);

Implements

IGLExport.

See Also

RossFinancialsExport Class | Aptify.Applications.Accounting Namespace


SalesTax Class

This object implements the Aptify.Framework.Applications.Accounting.ISalesTaxRate interface. The purpose of this component is to return a tax rate for a given set of input parameters base currency id.

For a list of all members of this type, see SalesTax Members.

System.Object
SalesTax

public class SalesTax : ISalesTax

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: AptifySalesTax (in AptifySalesTax.dll)

See Also

SalesTax Members | Aptify.Applications.Accounting Namespace


SalesTax Members

SalesTax overview

Public Instance Constructors

SalesTax Constructor Initializes a new instance of the SalesTax class.

Public Instance Methods

CalculateSalesTax | Overloaded. Calculate the Sales Tax for the entire Order, which includes all of the Order Lines and the Shipments.
CalculateSalesTaxOnShipment | Calculate the Sales Tax, after determining the Tax Jurisdiction, for a single Order Shipment.
Config |
DetermineTaxJurisdiction | Overloaded. Using the information provided in the Address parameter, determine the Tax Jurisdiction. Since only one address is provided, that information will be considered as the Bill To, Ship To and Selling Location addresses.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetTaxJurisdictionAndSalesTaxRates | Overloaded.
GetType (inherited from Object) | Gets the Type of the current instance.
IsCompanyTaxExempt | Given a Company ID and Sales Tax Rate ID, return whether or not that Company is tax exempt for that Sales Tax Rate.
IsPersonTaxExempt | Given a Person ID and Sales Tax Rate ID, return whether or not that Person is tax exempt for that Sales Tax Rate.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CalculateInclusiveTaxAmount |
CalculateTaxAmount |
CalculateTaxesOnOrderLine |
CalculateTaxesOnShipment |
ExecuteOrderLineTaxFilterRule |
ExecuteShippingTaxFilterRule |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetEntityInstanceUsedFields |
LoadEntityInstanceData |
LoadOrderEntityInstanceData | This method pulls the required elements from the OrderGE as opposed to going to the database since the Order GE data is live.
LoadOrderLineEntityInstanceData | This method pulls the required elements from the OrderLineGE as opposed to going to the database since the OrderLine GE data is live.
LoadOrderShipmentEntityInstanceData | This method pulls the required elements from the OrderShipmentGE as opposed to going to the database since the OrderShipment GE data is live.
LoadProductInstanceData | This method pulls the required elements from the ProductData cache as opposed to going to the database since the Product data is live.
LoadSalesTaxRateInstanceData | This method pulls the required elements from the Tax Jurisdiction Sales Tax Rate cache as opposed to going to the database since the Sales Tax Rate data is cached.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ProcessOrderLine |
ProcessOrderLines |
ProcessOrderShipment |
ProcessShipments |
QualifyOrderLineSalesTaxes |
QualifySalesTaxExemption | If BillToCompanyID is provided (greater than 0) then the Company Tax Exemption information is used. Otherwise, the Person Tax Exemption information for the BillToPersonID is used.
QualifySalesTaxRateAgainstOrderDate |
QualifyShippingSalesTaxes |
RetrieveOrderInformation |

See Also

SalesTax Class | Aptify.Applications.Accounting Namespace


SalesTax Constructor

Initializes a new instance of the SalesTax class.

public SalesTax();

See Also

SalesTax Class | Aptify.Applications.Accounting Namespace


SalesTax Methods

The methods of the SalesTax class are listed below. For a complete list of SalesTax class members, see the SalesTax Members topic.

Public Instance Methods

CalculateSalesTax | Overloaded. Calculate the Sales Tax for the entire Order, which includes all of the Order Lines and the Shipments.
CalculateSalesTaxOnShipment | Calculate the Sales Tax, after determining the Tax Jurisdiction, for a single Order Shipment.
Config |
DetermineTaxJurisdiction | Overloaded. Using the information provided in the Address parameter, determine the Tax Jurisdiction. Since only one address is provided, that information will be considered as the Bill To, Ship To and Selling Location addresses.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetTaxJurisdictionAndSalesTaxRates | Overloaded.
GetType (inherited from Object) | Gets the Type of the current instance.
IsCompanyTaxExempt | Given a Company ID and Sales Tax Rate ID, return whether or not that Company is tax exempt for that Sales Tax Rate.
IsPersonTaxExempt | Given a Person ID and Sales Tax Rate ID, return whether or not that Person is tax exempt for that Sales Tax Rate.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CalculateInclusiveTaxAmount |
CalculateTaxAmount |
CalculateTaxesOnOrderLine |
CalculateTaxesOnShipment |
ExecuteOrderLineTaxFilterRule |
ExecuteShippingTaxFilterRule |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetEntityInstanceUsedFields |
LoadEntityInstanceData |
LoadOrderEntityInstanceData | This method pulls the required elements from the OrderGE as opposed to going to the database since the Order GE data is live.
LoadOrderLineEntityInstanceData | This method pulls the required elements from the OrderLineGE as opposed to going to the database since the OrderLine GE data is live.
LoadOrderShipmentEntityInstanceData | This method pulls the required elements from the OrderShipmentGE as opposed to going to the database since the OrderShipment GE data is live.
LoadProductInstanceData | This method pulls the required elements from the ProductData cache as opposed to going to the database since the Product data is live.
LoadSalesTaxRateInstanceData | This method pulls the required elements from the Tax Jurisdiction Sales Tax Rate cache as opposed to going to the database since the Sales Tax Rate data is cached.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ProcessOrderLine |
ProcessOrderLines |
ProcessOrderShipment |
ProcessShipments |
QualifyOrderLineSalesTaxes |
QualifySalesTaxExemption | If BillToCompanyID is provided (greater than 0) then the Company Tax Exemption information is used. Otherwise, the Person Tax Exemption information for the BillToPersonID is used.
QualifySalesTaxRateAgainstOrderDate |
QualifyShippingSalesTaxes |
RetrieveOrderInformation |

See Also

SalesTax Class | Aptify.Applications.Accounting Namespace


SalesTax.CalculateInclusiveTaxAmount Method

protected virtual decimal CalculateInclusiveTaxAmount(
Decimal PriceIncludingTax,
SalesTaxRate Tax
);

See Also

SalesTax Class | Aptify.Applications.Accounting Namespace


CalculateSalesTax Method

Aptify 5.0 Software Development Kit (SDK)

SalesTax.CalculateSalesTax Method

Calculate the Sales Tax, after determining the Tax Jurisdiction, for a single Order Line.

Overload List

Calculate the Sales Tax, after determining the Tax Jurisdiction, for a single Order Line.

public virtual void CalculateSalesTax(OrderLinesEntity);

Calculate the Sales Tax for the entire Order, which includes all of the Order Lines and the Shipments.

public virtual void CalculateSalesTax(OrdersEntity);

See Also

SalesTax Class | Aptify.Applications.Accounting Namespace


SalesTax.CalculateSalesTax Method (OrderLinesEntity)

Calculate the Sales Tax, after determining the Tax Jurisdiction, for a single Order Line.

public virtual void CalculateSalesTax(
OrderLinesEntity OrderLineGE
);

Implements

ISalesTax.

Remarks

See Also

SalesTax Class | Aptify.Applications.Accounting Namespace | SalesTax.CalculateSalesTax Overload List


SalesTax.CalculateSalesTax Method (OrdersEntity)

Calculate the Sales Tax for the entire Order, which includes all of the Order Lines and the Shipments.

public virtual void CalculateSalesTax(
OrdersEntity OrderGE
);

Parameters

OrderGE

Implements

ISalesTax.

Remarks

See Also

SalesTax Class | Aptify.Applications.Accounting Namespace | SalesTax.CalculateSalesTax Overload List


SalesTax.CalculateSalesTaxOnShipment Method

Calculate the Sales Tax, after determining the Tax Jurisdiction, for a single Order Shipment.

public virtual void CalculateSalesTaxOnShipment(
AptifyGenericEntityBase OrderShipmentGE
);

Parameters

OrderShipmentGE

Implements

ISalesTax.

Remarks

See Also

SalesTax Class | Aptify.Applications.Accounting Namespace


SalesTax.CalculateTaxAmount Method

protected virtual decimal CalculateTaxAmount(
Decimal TaxableAmount,
SalesTaxRate Tax
);

See Also

SalesTax Class | Aptify.Applications.Accounting Namespace


SalesTax.CalculateTaxesOnOrderLine Method

protected virtual void CalculateTaxesOnOrderLine(
OrderLinesEntity OrderLineGE,
List<T> PotentialSalesTaxRates
);

See Also

SalesTax Class | Aptify.Applications.Accounting Namespace


SalesTax.CalculateTaxesOnShipment Method

protected virtual void CalculateTaxesOnShipment(
AptifyGenericEntityBase ShipmentGE,
List<T> PotentialSalesTaxRates
);

See Also

SalesTax Class | Aptify.Applications.Accounting Namespace


SalesTax.Config Method

public virtual void Config(
AptifyApplication Application
);

Implements

ISalesTax.

See Also

SalesTax Class | Aptify.Applications.Accounting Namespace


DetermineTaxJurisdiction Method

Aptify 5.0 Software Development Kit (SDK)

SalesTax.DetermineTaxJurisdiction Method

Using the information provided in the Address parameter, determine the Tax Jurisdiction. Since only one address is provided, that information will be considered as the Bill To, Ship To and Selling Location addresses.

Overload List

Using the information provided in the Address parameter, determine the Tax Jurisdiction. Since only one address is provided, that information will be considered as the Bill To, Ship To and Selling Location addresses.

public virtual long DetermineTaxJurisdiction(TaxAddress);

Using the address information provided, determine the appropriate Tax Jurisdiction.

public virtual long DetermineTaxJurisdiction(TaxAddress,TaxAddress,TaxAddress);

See Also

SalesTax Class | Aptify.Applications.Accounting Namespace


SalesTax.DetermineTaxJurisdiction Method (TaxAddress)

Using the information provided in the Address parameter, determine the Tax Jurisdiction. Since only one address is provided, that information will be considered as the Bill To, Ship To and Selling Location addresses.

public virtual long DetermineTaxJurisdiction(
TaxAddress Address
);

Parameters

Address

Return Value

Returns the qualifying Tax Jurisdiction's ID, if one exists. Otherwise, returns -1.

Implements

ISalesTax.

Remarks

See Also

SalesTax Class | Aptify.Applications.Accounting Namespace | SalesTax.DetermineTaxJurisdiction Overload List


SalesTax.DetermineTaxJurisdiction Method (TaxAddress, TaxAddress, TaxAddress)

Using the address information provided, determine the appropriate Tax Jurisdiction.

public virtual long DetermineTaxJurisdiction(
TaxAddress ShipToAddress,
TaxAddress BillToAddress,
TaxAddress SellingLocationAddress
);

Parameters

ShipToAddress
BillToAddress
SellingLocationAddress

Return Value

Returns the qualifying Tax Jurisdiction's ID, if one exists. Otherwise, returns -1.

Implements

ISalesTax.

Remarks

See Also

SalesTax Class | Aptify.Applications.Accounting Namespace | SalesTax.DetermineTaxJurisdiction Overload List


SalesTax.ExecuteOrderLineTaxFilterRule Method

protected virtual bool ExecuteOrderLineTaxFilterRule(
SalesTaxRate tax,
OrderLinesEntity OrderLineGE,
Boolean RefreshCache
);

See Also

SalesTax Class | Aptify.Applications.Accounting Namespace


SalesTax.ExecuteShippingTaxFilterRule Method

protected virtual bool ExecuteShippingTaxFilterRule(
SalesTaxRate tax,
AptifyGenericEntityBase OrderShipmentGE,
Boolean RefreshCache
);

See Also

SalesTax Class | Aptify.Applications.Accounting Namespace


SalesTax.GetEntityInstanceUsedFields Method

protected virtual List<T> GetEntityInstanceUsedFields(
String EntityInstance,
FilterRule oFilterRule
);

See Also

SalesTax Class | Aptify.Applications.Accounting Namespace


GetTaxJurisdictionAndSalesTaxRates Method

Aptify 5.0 Software Development Kit (SDK)

SalesTax.GetTaxJurisdictionAndSalesTaxRates Method

Overload List

public virtual void GetTaxJurisdictionAndSalesTaxRates(TaxAddress,TaxAddress,TaxAddress,ref Int64&,ref List`1&);

public virtual void GetTaxJurisdictionAndSalesTaxRates(TaxAddress,ref Int64&,ref List`1&);

See Also

SalesTax Class | Aptify.Applications.Accounting Namespace


SalesTax.GetTaxJurisdictionAndSalesTaxRates Method (TaxAddress, TaxAddress, TaxAddress, Int64&, List`1&)

public virtual void GetTaxJurisdictionAndSalesTaxRates(
TaxAddress ShipToAddress,
TaxAddress BillToAddress,
TaxAddress SellingLocationAddress,
ref Int64& TaxJurisdictionID,
ref List`1& SalesTaxRates
);

Implements

ISalesTax.

See Also

SalesTax Class | Aptify.Applications.Accounting Namespace | SalesTax.GetTaxJurisdictionAndSalesTaxRates Overload List


SalesTax.GetTaxJurisdictionAndSalesTaxRates Method (TaxAddress, Int64&, List`1&)

public virtual void GetTaxJurisdictionAndSalesTaxRates(
TaxAddress Address,
ref Int64& TaxJurisdictionID,
ref List`1& SalesTaxRates
);

Implements

ISalesTax.

See Also

SalesTax Class | Aptify.Applications.Accounting Namespace | SalesTax.GetTaxJurisdictionAndSalesTaxRates Overload List


SalesTax.IsCompanyTaxExempt Method

Given a Company ID and Sales Tax Rate ID, return whether or not that Company is tax exempt for that Sales Tax Rate.

public virtual bool IsCompanyTaxExempt(
Int64 CompanyID,
Int64 SalesTaxRateID
);

Parameters

CompanyID
SalesTaxRateID

Return Value

Implements

ISalesTax.

Remarks

See Also

SalesTax Class | Aptify.Applications.Accounting Namespace


SalesTax.IsPersonTaxExempt Method

Given a Person ID and Sales Tax Rate ID, return whether or not that Person is tax exempt for that Sales Tax Rate.

public virtual bool IsPersonTaxExempt(
Int64 PersonID,
Int64 SalesTaxRateID
);

Parameters

PersonID
SalesTaxRateID

Return Value

Implements

ISalesTax.

Remarks

See Also

SalesTax Class | Aptify.Applications.Accounting Namespace


SalesTax.LoadEntityInstanceData Method

protected virtual DataRow LoadEntityInstanceData(
String EntityInstance,
String EntityName,
Int64 InstanceRecordID,
FilterRule oFilterRule
);

See Also

SalesTax Class | Aptify.Applications.Accounting Namespace


SalesTax.LoadOrderEntityInstanceData Method

This method pulls the required elements from the OrderGE as opposed to going to the database since the Order GE data is live.

protected virtual DataRow LoadOrderEntityInstanceData(
AptifyGenericEntityBase OrderGE,
FilterRule oFilterRule
);

Parameters

OrderGE
oFilterRule

Return Value

Remarks

See Also

SalesTax Class | Aptify.Applications.Accounting Namespace


SalesTax.LoadOrderLineEntityInstanceData Method

This method pulls the required elements from the OrderLineGE as opposed to going to the database since the OrderLine GE data is live.

protected virtual DataRow LoadOrderLineEntityInstanceData(
OrderLinesEntity OrderLineGE,
FilterRule oFilterRule
);

Parameters

OrderLineGE
oFilterRule

Return Value

Remarks

See Also

SalesTax Class | Aptify.Applications.Accounting Namespace


SalesTax.LoadOrderShipmentEntityInstanceData Method

This method pulls the required elements from the OrderShipmentGE as opposed to going to the database since the OrderShipment GE data is live.

protected virtual DataRow LoadOrderShipmentEntityInstanceData(
AptifyGenericEntityBase OrderShipmentGE,
FilterRule oFilterRule
);

Parameters

OrderShipmentGE
oFilterRule

Return Value

Remarks

See Also

SalesTax Class | Aptify.Applications.Accounting Namespace


SalesTax.LoadProductInstanceData Method

This method pulls the required elements from the ProductData cache as opposed to going to the database since the Product data is live.

protected virtual DataRow LoadProductInstanceData(
ProductData productData,
FilterRule oFilterRule
);

Parameters

productData
oFilterRule

Return Value

Remarks

See Also

SalesTax Class | Aptify.Applications.Accounting Namespace


SalesTax.LoadSalesTaxRateInstanceData Method

This method pulls the required elements from the Tax Jurisdiction Sales Tax Rate cache as opposed to going to the database since the Sales Tax Rate data is cached.

protected virtual DataRow LoadSalesTaxRateInstanceData(
SalesTaxRate tax,
FilterRule oFilterRule
);

Parameters

tax
oFilterRule

Return Value

Remarks

See Also

SalesTax Class | Aptify.Applications.Accounting Namespace


SalesTax.ProcessOrderLine Method

protected virtual void ProcessOrderLine(
OrderLinesEntity OrderLineGE,
Int64 BillToCompanyID,
Int64 BillToPersonID,
TaxAddress OrderShipToAddress,
TaxAddress BillToAddress,
Int64 OriginalOrderID,
DateTime OrderDate,
TaxAddress SellingLocationAddress,
TaxJurisdictionData OrderTaxJurisdiction,
OrderProductCache ProductCache
);

See Also

SalesTax Class | Aptify.Applications.Accounting Namespace


SalesTax.ProcessOrderLines Method

protected virtual void ProcessOrderLines(
OrdersEntity OrderGE,
TaxAddress OrderShipToAddress,
Int64 BillToPersonID,
Int64 BillToCompanyID,
TaxAddress BillToAddress,
Int64 OriginalOrderID,
DateTime OrderDate,
TaxAddress SellingLocationAddress,
TaxJurisdictionData OrderTaxJurisdiction
);

See Also

SalesTax Class | Aptify.Applications.Accounting Namespace


SalesTax.ProcessOrderShipment Method

protected virtual void ProcessOrderShipment(
AptifyGenericEntityBase OrderShipmentGE,
Int64 BillToCompanyID,
Int64 BillToPersonID,
TaxAddress OrderShipToAddress,
TaxAddress BillToAddress,
Int64 OriginalOrderID,
DateTime OrderDate,
TaxAddress SellingLocationAddress,
TaxJurisdictionData OrderTaxJurisdiction
);

See Also

SalesTax Class | Aptify.Applications.Accounting Namespace


SalesTax.ProcessShipments Method

protected virtual void ProcessShipments(
OrdersEntity OrderGE,
TaxAddress OrderShipToAddress,
Int64 BillToPersonID,
Int64 BillToCompanyID,
TaxAddress BillToTaxAddress,
Int64 originalOrderID,
DateTime OrderDate,
TaxAddress SellingLocationAddress,
TaxJurisdictionData OrderTaxJurisdiction
);

See Also

SalesTax Class | Aptify.Applications.Accounting Namespace


SalesTax.QualifyOrderLineSalesTaxes Method

protected virtual void QualifyOrderLineSalesTaxes(
OrderLinesEntity OrderLineGE,
List<T> SalesTaxRates,
Int64 BillToPersonID,
Int64 BillToCompanyID,
DateTime OrderDate
);

See Also

SalesTax Class | Aptify.Applications.Accounting Namespace


SalesTax.QualifySalesTaxExemption Method

If BillToCompanyID is provided (greater than 0) then the Company Tax Exemption information is used. Otherwise, the Person Tax Exemption information for the BillToPersonID is used.

protected virtual bool QualifySalesTaxExemption(
SalesTaxRate Tax,
Int64 BillToPersonID,
Int64 BillToCompanyID
);

Parameters

Tax
BillToPersonID
BillToCompanyID

Return Value

Remarks

See Also

SalesTax Class | Aptify.Applications.Accounting Namespace


SalesTax.QualifySalesTaxRateAgainstOrderDate Method

protected virtual bool QualifySalesTaxRateAgainstOrderDate(
SalesTaxRate Tax,
DateTime OrderDate
);

See Also

SalesTax Class | Aptify.Applications.Accounting Namespace


SalesTax.QualifyShippingSalesTaxes Method

protected virtual void QualifyShippingSalesTaxes(
AptifyGenericEntityBase OrderShipmentGE,
List<T> SalesTaxRates,
Int64 BillToPersonID,
Int64 BillToCompanyID,
DateTime OrderDate
);

See Also

SalesTax Class | Aptify.Applications.Accounting Namespace


SalesTax.RetrieveOrderInformation Method

protected virtual void RetrieveOrderInformation(
OrdersEntity OrderGE,
ref Int64& BillToCompanyID,
ref Int64& BillToPersonID,
ref TaxAddress& ShipToAddress,
ref TaxAddress& BillToAddress,
ref Int64& OriginalOrderID,
ref DateTime& OrderDate,
ref TaxAddress& SellingLocationAddress,
ref TaxJurisdictionData& TaxJurisdiction
);

See Also

SalesTax Class | Aptify.Applications.Accounting Namespace


SalesTaxRate Class

This object implements the Aptify.Framework.Applications.Accounting.ISalesTaxRate interface. The purpose of this component is to return a tax rate for a given set of input parameters base currency id.

For a list of all members of this type, see SalesTaxRate Members.

System.Object
SalesTaxRate

public class SalesTaxRate : ISalesTaxRate

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: SalesTaxRate (in SalesTaxRate.dll)

See Also

SalesTaxRate Members | Aptify.Applications.Accounting Namespace


SalesTaxRate Members

SalesTaxRate overview

Public Instance Constructors

SalesTaxRate Constructor Initializes a new instance of the SalesTaxRate class.

Public Instance Methods

Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCountyFromPostalCode |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetSalesTaxRate | Overloaded.
GetType (inherited from Object) | Gets the Type of the current instance.
IsCompanyTaxExempt |
IsPersonTaxExempt |
SetSalesTaxRate |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SalesTaxRate Class | Aptify.Applications.Accounting Namespace


SalesTaxRate Constructor

Initializes a new instance of the SalesTaxRate class.

public SalesTaxRate();

See Also

SalesTaxRate Class | Aptify.Applications.Accounting Namespace


SalesTaxRate Methods

The methods of the SalesTaxRate class are listed below. For a complete list of SalesTaxRate class members, see the SalesTaxRate Members topic.

Public Instance Methods

Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCountyFromPostalCode |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetSalesTaxRate | Overloaded.
GetType (inherited from Object) | Gets the Type of the current instance.
IsCompanyTaxExempt |
IsPersonTaxExempt |
SetSalesTaxRate |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SalesTaxRate Class | Aptify.Applications.Accounting Namespace


SalesTaxRate.Config Method

public void Config(
AptifyApplication Application
);

Implements

ISalesTaxRate.

See Also

SalesTaxRate Class | Aptify.Applications.Accounting Namespace


SalesTaxRate.GetCountyFromPostalCode Method

public string GetCountyFromPostalCode(
String PostalCode,
String ISOCountryCode
);

Implements

ISalesTaxRate.

See Also

SalesTaxRate Class | Aptify.Applications.Accounting Namespace


GetSalesTaxRate Method

Aptify 5.0 Software Development Kit (SDK)

SalesTaxRate.GetSalesTaxRate Method

Overload List

public bool GetSalesTaxRate(Int64,ref Boolean&,ref Int64&,ref Single&);

public bool GetSalesTaxRate(Int64,Int64,Int64,ref Boolean&,ref Int64&,ref Single&);

public bool GetSalesTaxRate(Int64,Int64,Int64,ref Int64&,ref Single&);

public bool GetSalesTaxRate(Int64,ref Int64&,ref Single&);

public bool GetSalesTaxRate(String,String,String,String,String,ref Boolean&,ref Int64&,ref Single&);

public bool GetSalesTaxRate(String,String,String,String,String,Int64,Int64,ref Boolean&,ref Int64&,ref Single&);

public bool GetSalesTaxRate(String,String,String,String,String,Int64,Int64,ref Int64&,ref Single&);

public bool GetSalesTaxRate(String,String,String,String,String,ref Int64&,ref Single&);

See Also

SalesTaxRate Class | Aptify.Applications.Accounting Namespace


SalesTaxRate.GetSalesTaxRate Method (Int64, Boolean&, Int64&, Single&)

public bool GetSalesTaxRate(
Int64 AddressID,
ref Boolean& TaxExempt,
ref Int64& TaxRateID,
ref Single& Rate
);

Implements

ISalesTaxRate.

See Also

SalesTaxRate Class | Aptify.Applications.Accounting Namespace | SalesTaxRate.GetSalesTaxRate Overload List


SalesTaxRate.GetSalesTaxRate Method (Int64, Int64, Int64, Boolean&, Int64&, Single&)

public bool GetSalesTaxRate(
Int64 AddressID,
Int64 BillToCompanyID,
Int64 BillToPersonID,
ref Boolean& TaxExempt,
ref Int64& TaxRateID,
ref Single& Rate
);

Implements

ISalesTaxRate.

See Also

SalesTaxRate Class | Aptify.Applications.Accounting Namespace | SalesTaxRate.GetSalesTaxRate Overload List


SalesTaxRate.GetSalesTaxRate Method (Int64, Int64, Int64, Int64&, Single&)

public bool GetSalesTaxRate(
Int64 AddressID,
Int64 BillToCompanyID,
Int64 BillToPersonID,
ref Int64& TaxRateID,
ref Single& Rate
);

Implements

ISalesTaxRate.

See Also

SalesTaxRate Class | Aptify.Applications.Accounting Namespace | SalesTaxRate.GetSalesTaxRate Overload List


SalesTaxRate.GetSalesTaxRate Method (Int64, Int64&, Single&)

public bool GetSalesTaxRate(
Int64 AddressID,
ref Int64& TaxRateID,
ref Single& Rate
);

Implements

ISalesTaxRate.

See Also

SalesTaxRate Class | Aptify.Applications.Accounting Namespace | SalesTaxRate.GetSalesTaxRate Overload List


SalesTaxRate.GetSalesTaxRate Method (String, String, String, String, String, Boolean&, Int64&, Single&)

public bool GetSalesTaxRate(
String PostalCode,
String City,
String StateProvince,
String County,
String ISOCountryCode,
ref Boolean& TaxExempt,
ref Int64& TaxRateID,
ref Single& Rate
);

Implements

ISalesTaxRate.

See Also

SalesTaxRate Class | Aptify.Applications.Accounting Namespace | SalesTaxRate.GetSalesTaxRate Overload List


SalesTaxRate.GetSalesTaxRate Method (String, String, String, String, String, Int64, Int64, Boolean&, Int64&, Single&)

public bool GetSalesTaxRate(
String PostalCode,
String City,
String StateProvince,
String County,
String ISOCountryCode,
Int64 BillToCompanyID,
Int64 BillToPersonID,
ref Boolean& TaxExempt,
ref Int64& TaxRateID,
ref Single& Rate
);

Implements

ISalesTaxRate.

See Also

SalesTaxRate Class | Aptify.Applications.Accounting Namespace | SalesTaxRate.GetSalesTaxRate Overload List


SalesTaxRate.GetSalesTaxRate Method (String, String, String, String, String, Int64, Int64, Int64&, Single&)

public bool GetSalesTaxRate(
String PostalCode,
String City,
String StateProvince,
String County,
String ISOCountryCode,
Int64 BillToCompanyID,
Int64 BillToPersonID,
ref Int64& TaxRateID,
ref Single& Rate
);

Implements

ISalesTaxRate.

See Also

SalesTaxRate Class | Aptify.Applications.Accounting Namespace | SalesTaxRate.GetSalesTaxRate Overload List


SalesTaxRate.GetSalesTaxRate Method (String, String, String, String, String, Int64&, Single&)

public bool GetSalesTaxRate(
String PostalCode,
String City,
String StateProvince,
String County,
String ISOCountryCode,
ref Int64& TaxRateID,
ref Single& Rate
);

Implements

ISalesTaxRate.

See Also

SalesTaxRate Class | Aptify.Applications.Accounting Namespace | SalesTaxRate.GetSalesTaxRate Overload List


SalesTaxRate.IsCompanyTaxExempt Method

public bool IsCompanyTaxExempt(
Int64 CompanyID,
String City,
String StateProvince,
String County,
String PostalCode,
String ISOCountryCode
);

Implements

ISalesTaxRate.

See Also

SalesTaxRate Class | Aptify.Applications.Accounting Namespace


SalesTaxRate.IsPersonTaxExempt Method

public bool IsPersonTaxExempt(
Int64 PersonID,
String City,
String StateProvince,
String County,
String PostalCode,
String ISOCountryCode
);

Implements

ISalesTaxRate.

See Also

SalesTaxRate Class | Aptify.Applications.Accounting Namespace


SalesTaxRate.SetSalesTaxRate Method

public bool SetSalesTaxRate(
AptifyGenericEntityBase OrderGE
);

Implements

ISalesTaxRate.

See Also

SalesTaxRate Class | Aptify.Applications.Accounting Namespace


SalesTaxRateEntity Class

For a list of all members of this type, see SalesTaxRateEntity Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
SalesTaxRateEntity

public class SalesTaxRateEntity : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: AptifySalesTaxRate (in AptifySalesTaxRate.dll)

See Also

SalesTaxRateEntity Members | Aptify.Applications.Accounting Namespace


SalesTaxRateEntity Members

SalesTaxRateEntity overview

Public Instance Constructors

SalesTaxRateEntity Constructor Initializes a new instance of the SalesTaxRateEntity class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded. This method overrides the base functionality to ensure that if the Sales Tax Rate has a filter rule setup, that the Sales Tax Rate filter rule is named appropriately.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

SalesTaxRateEntity Class | Aptify.Applications.Accounting Namespace


SalesTaxRateEntity Constructor

Initializes a new instance of the SalesTaxRateEntity class.

public SalesTaxRateEntity();

See Also

SalesTaxRateEntity Class | Aptify.Applications.Accounting Namespace


SalesTaxRateEntity Methods

The methods of the SalesTaxRateEntity class are listed below. For a complete list of SalesTaxRateEntity class members, see the SalesTaxRateEntity Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded. This method overrides the base functionality to ensure that if the Sales Tax Rate has a filter rule setup, that the Sales Tax Rate filter rule is named appropriately.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

SalesTaxRateEntity Class | Aptify.Applications.Accounting Namespace


Save Method

Aptify 5.0 Software Development Kit (SDK)

SalesTaxRateEntity.Save Method

This method overrides the base functionality to ensure that if the Sales Tax Rate has a filter rule setup, that the Sales Tax Rate filter rule is named appropriately.

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Save();

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean,ref String&);

This method overrides the base functionality to ensure that if the Sales Tax Rate has a filter rule setup, that the Sales Tax Rate filter rule is named appropriately.

public override bool Save(Boolean,ref String&,String);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(ref String&);

See Also

SalesTaxRateEntity Class | Aptify.Applications.Accounting Namespace


SalesTaxRateEntity.Save Method (Boolean, String&, String)

This method overrides the base functionality to ensure that if the Sales Tax Rate has a filter rule setup, that the Sales Tax Rate filter rule is named appropriately.

public override bool Save(
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

Parameters

AllowGUI
ErrorString
TransactionID

Return Value

Remarks

See Also

SalesTaxRateEntity Class | Aptify.Applications.Accounting Namespace | SalesTaxRateEntity.Save Overload List


SalesTaxRateLayout Class

For a list of all members of this type, see SalesTaxRateLayout Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
SalesTaxRateLayout

public class SalesTaxRateLayout : FormTemplateLayout

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: SalesTaxRateControls (in SalesTaxRateControls.dll)

See Also

SalesTaxRateLayout Members | Aptify.Applications.Accounting Namespace


SalesTaxRateLayout Members

SalesTaxRateLayout overview

Public Instance Constructors

SalesTaxRateLayout Constructor Initializes a new instance of the SalesTaxRateLayout class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

m_ctlOrderLinesFilterRule
m_ctlOrderShipmentsFilterRule

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
m_ctlApplyOrderLinesFilterRule |
m_ctlApplyOrderShipmentsFilterRule |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControls |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded | Contains logic to setup Event handlers for controls on the FormTemplate Layout.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlVisibility |
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

SalesTaxRateLayout Class | Aptify.Applications.Accounting Namespace


SalesTaxRateLayout Constructor

Initializes a new instance of the SalesTaxRateLayout class.

public SalesTaxRateLayout();

See Also

SalesTaxRateLayout Class | Aptify.Applications.Accounting Namespace


SalesTaxRateLayout Fields

The fields of the SalesTaxRateLayout class are listed below. For a complete list of SalesTaxRateLayout class members, see the SalesTaxRateLayout Members topic.

Protected Instance Fields

m_ctlOrderLinesFilterRule
m_ctlOrderShipmentsFilterRule

See Also

SalesTaxRateLayout Class | Aptify.Applications.Accounting Namespace


SalesTaxRateLayout.m_ctlOrderLinesFilterRule Field

protected m_ctlOrderLinesFilterRule m_ctlOrderLinesFilterRule;

See Also

SalesTaxRateLayout Class | Aptify.Applications.Accounting Namespace


SalesTaxRateLayout.m_ctlOrderShipmentsFilterRule Field

protected m_ctlOrderShipmentsFilterRule m_ctlOrderShipmentsFilterRule;

See Also

SalesTaxRateLayout Class | Aptify.Applications.Accounting Namespace


SalesTaxRateLayout Properties

The properties of the SalesTaxRateLayout class are listed below. For a complete list of SalesTaxRateLayout class members, see the SalesTaxRateLayout Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
m_ctlApplyOrderLinesFilterRule |
m_ctlApplyOrderShipmentsFilterRule |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

SalesTaxRateLayout Class | Aptify.Applications.Accounting Namespace


m_ctlApplyOrderLinesFilterRule Property

Aptify 5.0 Software Development Kit (SDK)

SalesTaxRateLayout.m_ctlApplyOrderLinesFilterRule Property

protected virtual AptifyCheckBox m_ctlApplyOrderLinesFilterRule {get; set;}

See Also

SalesTaxRateLayout Class | Aptify.Applications.Accounting Namespace


m_ctlApplyOrderShipmentsFilterRule Property

Aptify 5.0 Software Development Kit (SDK)

SalesTaxRateLayout.m_ctlApplyOrderShipmentsFilterRule Property

protected virtual AptifyCheckBox m_ctlApplyOrderShipmentsFilterRule {get; set;}

See Also

SalesTaxRateLayout Class | Aptify.Applications.Accounting Namespace


SalesTaxRateLayout Methods

The methods of the SalesTaxRateLayout class are listed below. For a complete list of SalesTaxRateLayout class members, see the SalesTaxRateLayout Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControls |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded | Contains logic to setup Event handlers for controls on the FormTemplate Layout.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlVisibility |
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

SalesTaxRateLayout Class | Aptify.Applications.Accounting Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

SalesTaxRateLayout.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

SalesTaxRateLayout Class | Aptify.Applications.Accounting Namespace


SalesTaxRateLayout.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

SalesTaxRateLayout Class | Aptify.Applications.Accounting Namespace | SalesTaxRateLayout.Dispose Overload List


SalesTaxRateLayout.FindControls Method

protected void FindControls(
String FormTemplateLayoutName
);

See Also

SalesTaxRateLayout Class | Aptify.Applications.Accounting Namespace


SalesTaxRateLayout.OnFormTemplateLoaded Method

Contains logic to setup Event handlers for controls on the FormTemplate Layout.

protected override void OnFormTemplateLoaded(
FormTemplateLayout.FormTemplateLoadedEventArgs e
);

Parameters

e

Remarks

See Also

SalesTaxRateLayout Class | Aptify.Applications.Accounting Namespace


SalesTaxRateLayout.OnRefresh Method

protected override void OnRefresh();

Implements

IFormComponent.

See Also

SalesTaxRateLayout Class | Aptify.Applications.Accounting Namespace


SalesTaxRateLayout.SetControlVisibility Method

protected virtual void SetControlVisibility();

See Also

SalesTaxRateLayout Class | Aptify.Applications.Accounting Namespace


SavedPaymentMethod Class

For a list of all members of this type, see SavedPaymentMethod Members.

System.Object
SavedPaymentMethod

public class SavedPaymentMethod

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: PaymentInfoObject (in PaymentInfoObject.dll)

See Also

SavedPaymentMethod Members | Aptify.Applications.Accounting Namespace


SavedPaymentMethod Members

SavedPaymentMethod overview

Public Instance Constructors

SavedPaymentMethod Constructor

Public Instance Properties

AccountNumber
Inflow
Name
PaymentInfoID
PaymentType
Source

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SavedPaymentMethod Class | Aptify.Applications.Accounting Namespace


SavedPaymentMethod Constructor

public SavedPaymentMethod(
Int64 PaymentInfoID,
String Name,
String PaymentType,
String AccountNumber,
String Source,
Boolean Inflow
);

See Also

SavedPaymentMethod Class | Aptify.Applications.Accounting Namespace


SavedPaymentMethod Properties

The properties of the SavedPaymentMethod class are listed below. For a complete list of SavedPaymentMethod class members, see the SavedPaymentMethod Members topic.

Public Instance Properties

AccountNumber
Inflow
Name
PaymentInfoID
PaymentType
Source

See Also

SavedPaymentMethod Class | Aptify.Applications.Accounting Namespace


AccountNumber Property

Aptify 5.0 Software Development Kit (SDK)

SavedPaymentMethod.AccountNumber Property

public String AccountNumber {get;}

See Also

SavedPaymentMethod Class | Aptify.Applications.Accounting Namespace


Inflow Property

Aptify 5.0 Software Development Kit (SDK)

SavedPaymentMethod.Inflow Property

public Boolean Inflow {get;}

See Also

SavedPaymentMethod Class | Aptify.Applications.Accounting Namespace


Name Property

Aptify 5.0 Software Development Kit (SDK)

SavedPaymentMethod.Name Property

public String Name {get;}

See Also

SavedPaymentMethod Class | Aptify.Applications.Accounting Namespace


PaymentInfoID Property

Aptify 5.0 Software Development Kit (SDK)

SavedPaymentMethod.PaymentInfoID Property

public Int64 PaymentInfoID {get;}

See Also

SavedPaymentMethod Class | Aptify.Applications.Accounting Namespace


PaymentType Property

Aptify 5.0 Software Development Kit (SDK)

SavedPaymentMethod.PaymentType Property

public String PaymentType {get;}

See Also

SavedPaymentMethod Class | Aptify.Applications.Accounting Namespace


Source Property

Aptify 5.0 Software Development Kit (SDK)

SavedPaymentMethod.Source Property

public String Source {get;}

See Also

SavedPaymentMethod Class | Aptify.Applications.Accounting Namespace


ScheduledTransaction Class

For a list of all members of this type, see ScheduledTransaction Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
ScheduledTransactionsClass
ScheduledTransaction

public class ScheduledTransaction : ScheduledTransactionsClass

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: ScheduledTransaction (in ScheduledTransaction.dll)

See Also

ScheduledTransaction Members | Aptify.Applications.Accounting Namespace


ScheduledTransaction Members

ScheduledTransaction overview

Public Instance Constructors

ScheduledTransaction Constructor Initializes a new instance of the ScheduledTransaction class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BatchID (inherited from ScheduledTransactionsClass) |
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
CALC_Total (inherited from ScheduledTransactionsClass) |
Comments (inherited from ScheduledTransactionsClass) |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrencySpotRateID (inherited from ScheduledTransactionsClass) |
CurrencyType (inherited from ScheduledTransactionsClass) |
CurrencyTypeID (inherited from ScheduledTransactionsClass) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DateCreated (inherited from ScheduledTransactionsClass) |
DateUpdated (inherited from ScheduledTransactionsClass) |
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
Description (inherited from ScheduledTransactionsClass) |
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
ID (inherited from ScheduledTransactionsClass) |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
OrderID (inherited from ScheduledTransactionsClass) |
OrderStatusID (inherited from ScheduledTransactionsClass) |
Organization (inherited from ScheduledTransactionsClass) |
OrganizationID (inherited from ScheduledTransactionsClass) |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
ScheduledDate (inherited from ScheduledTransactionsClass) |
ScheduledTransactionGroupID (inherited from ScheduledTransactionsClass) |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
Type (inherited from ScheduledTransactionsClass) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.
WhoCreated (inherited from ScheduledTransactionsClass) |
WhoUpdated (inherited from ScheduledTransactionsClass) |

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete | Overloaded.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
ScheduledTransactionAccountEntries (inherited from ScheduledTransactionsClass) |
ScheduledTransactionAccountEntriesObject (inherited from ScheduledTransactionsClass) |
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetOrganizationID | Called by the Save method if the OrganizationID has not been set. If the Scheduled Transaction has an OrderID, the Order's OrganizationID will be used to set the OrganzationID. Otherwise, the DefaultOrganzationID defined as an Organizations' Entity Attribute.
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

ScheduledTransaction Class | Aptify.Applications.Accounting Namespace


ScheduledTransaction Constructor

Initializes a new instance of the ScheduledTransaction class.

public ScheduledTransaction();

See Also

ScheduledTransaction Class | Aptify.Applications.Accounting Namespace


ScheduledTransaction Methods

The methods of the ScheduledTransaction class are listed below. For a complete list of ScheduledTransaction class members, see the ScheduledTransaction Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete | Overloaded.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
ScheduledTransactionAccountEntries (inherited from ScheduledTransactionsClass) |
ScheduledTransactionAccountEntriesObject (inherited from ScheduledTransactionsClass) |
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetOrganizationID | Called by the Save method if the OrganizationID has not been set. If the Scheduled Transaction has an OrderID, the Order's OrganizationID will be used to set the OrganzationID. Otherwise, the DefaultOrganzationID defined as an Organizations' Entity Attribute.
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

ScheduledTransaction Class | Aptify.Applications.Accounting Namespace


Delete Method

Aptify 5.0 Software Development Kit (SDK)

ScheduledTransaction.Delete Method

Overload List

public override bool Delete();

Inherited from AptifyGenericEntity.

public override bool Delete(String);

See Also

ScheduledTransaction Class | Aptify.Applications.Accounting Namespace


ScheduledTransaction.Delete Method ()

public override bool Delete();

See Also

ScheduledTransaction Class | Aptify.Applications.Accounting Namespace | ScheduledTransaction.Delete Overload List


Save Method

Aptify 5.0 Software Development Kit (SDK)

ScheduledTransaction.Save Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Save();

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean,ref String&);

public override bool Save(Boolean,ref String&,String);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(ref String&);

See Also

ScheduledTransaction Class | Aptify.Applications.Accounting Namespace


ScheduledTransaction.Save Method (Boolean, String&, String)

public override bool Save(
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

See Also

ScheduledTransaction Class | Aptify.Applications.Accounting Namespace | ScheduledTransaction.Save Overload List


ScheduledTransaction.SetOrganizationID Method

Called by the Save method if the OrganizationID has not been set. If the Scheduled Transaction has an OrderID, the Order's OrganizationID will be used to set the OrganzationID. Otherwise, the DefaultOrganzationID defined as an Organizations' Entity Attribute.

protected virtual void SetOrganizationID();

Remarks

See Also

ScheduledTransaction Class | Aptify.Applications.Accounting Namespace


Validate Method

Aptify 5.0 Software Development Kit (SDK)

ScheduledTransaction.Validate Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Validate();

public override bool Validate(ref String&);

See Also

ScheduledTransaction Class | Aptify.Applications.Accounting Namespace


ScheduledTransaction.Validate Method (String&)

public override bool Validate(
ref String& ErrorString
);

See Also

ScheduledTransaction Class | Aptify.Applications.Accounting Namespace | ScheduledTransaction.Validate Overload List


ScheduledTransactionGroupsExtension Class

View Extension for Scheduled Transaction Groups. Supports the expansion of Scheduled Transaction Group records from a View.

For a list of all members of this type, see ScheduledTransactionGroupsExtension Members.

System.Object
ScheduledTransactionGroupsExtension

public class ScheduledTransactionGroupsExtension : IAptifyViewExtension

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

This object assumes that the first Action defined for the Scheduled Transaction Groups Entity defines the Expand Scheduled Transaction Groups process. The same object that is defined in the Entity Action will be used by this object.

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: STGExtension (in STGExtension.dll)

See Also

ScheduledTransactionGroupsExtension Members | Aptify.Applications.Accounting Namespace


ScheduledTransactionGroupsExtension Members

ScheduledTransactionGroupsExtension overview

Public Instance Constructors

ScheduledTransactionGroupsExtension Constructor Initializes a new instance of the ScheduledTransactionGroupsExtension class.

Public Instance Properties

Application
ExtensionMenuItem
ViewPlugIn

Public Instance Methods

Attach |
Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

AfterAttach
AfterConfig
AfterExecute
BeforeAttach
BeforeConfig
BeforeExecute

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ScheduledTransactionGroupsExtension Class | Aptify.Applications.Accounting Namespace


ScheduledTransactionGroupsExtension Constructor

Initializes a new instance of the ScheduledTransactionGroupsExtension class.

public ScheduledTransactionGroupsExtension();

See Also

ScheduledTransactionGroupsExtension Class | Aptify.Applications.Accounting Namespace


ScheduledTransactionGroupsExtension Properties

The properties of the ScheduledTransactionGroupsExtension class are listed below. For a complete list of ScheduledTransactionGroupsExtension class members, see the ScheduledTransactionGroupsExtension Members topic.

Public Instance Properties

Application
ExtensionMenuItem
ViewPlugIn

See Also

ScheduledTransactionGroupsExtension Class | Aptify.Applications.Accounting Namespace


Application Property

Aptify 5.0 Software Development Kit (SDK)

ScheduledTransactionGroupsExtension.Application Property

public AptifyApplication Application {get;}

Implements

IAptifyViewExtension.

See Also

ScheduledTransactionGroupsExtension Class | Aptify.Applications.Accounting Namespace


ExtensionMenuItem Property

Aptify 5.0 Software Development Kit (SDK)

ScheduledTransactionGroupsExtension.ExtensionMenuItem Property

public MenuItem ExtensionMenuItem {get;}

Implements

IAptifyViewExtension.

See Also

ScheduledTransactionGroupsExtension Class | Aptify.Applications.Accounting Namespace


ViewPlugIn Property

Aptify 5.0 Software Development Kit (SDK)

ScheduledTransactionGroupsExtension.ViewPlugIn Property

public IAptifyViewPlugIn ViewPlugIn {get;}

Implements

IAptifyViewExtension.

See Also

ScheduledTransactionGroupsExtension Class | Aptify.Applications.Accounting Namespace


ScheduledTransactionGroupsExtension Methods

The methods of the ScheduledTransactionGroupsExtension class are listed below. For a complete list of ScheduledTransactionGroupsExtension class members, see the ScheduledTransactionGroupsExtension Members topic.

Public Instance Methods

Attach |
Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ScheduledTransactionGroupsExtension Class | Aptify.Applications.Accounting Namespace


ScheduledTransactionGroupsExtension.Attach Method

public void Attach(
MenuItem ExtensionMenuItem
);

Implements

IAptifyViewExtension.

See Also

ScheduledTransactionGroupsExtension Class | Aptify.Applications.Accounting Namespace


ScheduledTransactionGroupsExtension.Config Method

public void Config(
AptifyApplication Application,
IAptifyViewPlugIn ViewPlugIn
);

Implements

IAptifyViewExtension.

See Also

ScheduledTransactionGroupsExtension Class | Aptify.Applications.Accounting Namespace


ScheduledTransactionGroupsExtension.Execute Method

public void Execute(
MenuItem FunctionMenuItem
);

Implements

IAptifyViewExtension.

See Also

ScheduledTransactionGroupsExtension Class | Aptify.Applications.Accounting Namespace


ScheduledTransactionGroupsExtension Events

The events of the ScheduledTransactionGroupsExtension class are listed below. For a complete list of ScheduledTransactionGroupsExtension class members, see the ScheduledTransactionGroupsExtension Members topic.

Public Instance Events

AfterAttach
AfterConfig
AfterExecute
BeforeAttach
BeforeConfig
BeforeExecute

See Also

ScheduledTransactionGroupsExtension Class | Aptify.Applications.Accounting Namespace


ScheduledTransactionGroupsExtension.IAptifyViewExtension.AfterAttachEventHandler Event

public event IAptifyViewExtension.AfterAttachEventHandler AfterAttach;

Implements

IAptifyViewExtension.

See Also

ScheduledTransactionGroupsExtension Class | Aptify.Applications.Accounting Namespace


ScheduledTransactionGroupsExtension.IAptifyViewExtension.AfterConfigEventHandler Event

public event IAptifyViewExtension.AfterConfigEventHandler AfterConfig;

Implements

IAptifyViewExtension.

See Also

ScheduledTransactionGroupsExtension Class | Aptify.Applications.Accounting Namespace


ScheduledTransactionGroupsExtension.IAptifyViewExtension.AfterExecuteEventHandler Event

public event IAptifyViewExtension.AfterExecuteEventHandler AfterExecute;

Implements

IAptifyViewExtension.

See Also

ScheduledTransactionGroupsExtension Class | Aptify.Applications.Accounting Namespace


ScheduledTransactionGroupsExtension.IAptifyViewExtension.BeforeAttachEventHandler Event

public event IAptifyViewExtension.BeforeAttachEventHandler BeforeAttach;

Implements

IAptifyViewExtension.

See Also

ScheduledTransactionGroupsExtension Class | Aptify.Applications.Accounting Namespace


ScheduledTransactionGroupsExtension.IAptifyViewExtension.BeforeConfigEventHandler Event

public event IAptifyViewExtension.BeforeConfigEventHandler BeforeConfig;

Implements

IAptifyViewExtension.

See Also

ScheduledTransactionGroupsExtension Class | Aptify.Applications.Accounting Namespace


ScheduledTransactionGroupsExtension.IAptifyViewExtension.BeforeExecuteEventHandler Event

public event IAptifyViewExtension.BeforeExecuteEventHandler BeforeExecute;

Implements

IAptifyViewExtension.

See Also

ScheduledTransactionGroupsExtension Class | Aptify.Applications.Accounting Namespace


ScheduledTransactionLayout Class

For a list of all members of this type, see ScheduledTransactionLayout Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
ScheduledTransactionLayout

public class ScheduledTransactionLayout : FormTemplateLayout

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: ScheduledTransactionLayout (in ScheduledTransactionLayout.dll)

See Also

ScheduledTransactionLayout Members | Aptify.Applications.Accounting Namespace


ScheduledTransactionLayout Members

ScheduledTransactionLayout overview

Public Instance Constructors

ScheduledTransactionLayout Constructor Initializes a new instance of the ScheduledTransactionLayout class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDataControlBeforeParams | Used to handle the Data Control's BeforeParams event. This method parses the Params string to remove fields that are not supported as New Record Parameters. Unsupported Fields: BatchID
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig |
OnFormTemplateLoaded |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ScheduledTransactionLayout Class | Aptify.Applications.Accounting Namespace


ScheduledTransactionLayout Constructor

Initializes a new instance of the ScheduledTransactionLayout class.

public ScheduledTransactionLayout();

See Also

ScheduledTransactionLayout Class | Aptify.Applications.Accounting Namespace


ScheduledTransactionLayout Methods

The methods of the ScheduledTransactionLayout class are listed below. For a complete list of ScheduledTransactionLayout class members, see the ScheduledTransactionLayout Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDataControlBeforeParams | Used to handle the Data Control's BeforeParams event. This method parses the Params string to remove fields that are not supported as New Record Parameters. Unsupported Fields: BatchID
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig |
OnFormTemplateLoaded |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ScheduledTransactionLayout Class | Aptify.Applications.Accounting Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

ScheduledTransactionLayout.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

ScheduledTransactionLayout Class | Aptify.Applications.Accounting Namespace


ScheduledTransactionLayout.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

ScheduledTransactionLayout Class | Aptify.Applications.Accounting Namespace | ScheduledTransactionLayout.Dispose Overload List


ScheduledTransactionLayout.OnDataControlBeforeParams Method

Used to handle the Data Control's BeforeParams event. This method parses the Params string to remove fields that are not supported as New Record Parameters. Unsupported Fields: BatchID

protected virtual void OnDataControlBeforeParams(
ref String& Params,
ref Boolean& Cancel
);

Parameters

Params
Cancel

Remarks

See Also

ScheduledTransactionLayout Class | Aptify.Applications.Accounting Namespace


ScheduledTransactionLayout.OnFormComponentConfig Method

protected override void OnFormComponentConfig(
AptifyFormTemplateContext Context
);

Implements

IFormComponent.

See Also

ScheduledTransactionLayout Class | Aptify.Applications.Accounting Namespace


ScheduledTransactionLayout.OnFormTemplateLoaded Method

protected override void OnFormTemplateLoaded(
FormTemplateLayout.FormTemplateLoadedEventArgs e
);

See Also

ScheduledTransactionLayout Class | Aptify.Applications.Accounting Namespace


ScheduledTransactionLayout.OnRefresh Method

protected override void OnRefresh();

Implements

IFormComponent.

See Also

ScheduledTransactionLayout Class | Aptify.Applications.Accounting Namespace


ScheduleTransactionExtension Class

Extends the context menu displayed in Scheduled Transactions Views.

For a list of all members of this type, see ScheduleTransactionExtension Members.

System.Object
ScheduleTransactionExtension

public class ScheduleTransactionExtension : IAptifyViewExtension

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: ScheduleTransactionExtension (in ScheduleTransactionExtension.dll)

See Also

ScheduleTransactionExtension Members | Aptify.Applications.Accounting Namespace


ScheduleTransactionExtension Members

ScheduleTransactionExtension overview

Public Instance Constructors

ScheduleTransactionExtension Constructor Initializes a new instance of the ScheduleTransactionExtension class.

Public Instance Properties

Application
ExtensionMenuItem
ViewPlugIn

Public Instance Methods

Attach |
Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

AfterAttach
AfterConfig
AfterExecute
BeforeAttach
BeforeConfig
BeforeExecute

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetWizardInstance |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ScheduleTransactionExtension Class | Aptify.Applications.Accounting Namespace


ScheduleTransactionExtension Constructor

Initializes a new instance of the ScheduleTransactionExtension class.

public ScheduleTransactionExtension();

See Also

ScheduleTransactionExtension Class | Aptify.Applications.Accounting Namespace


ScheduleTransactionExtension Properties

The properties of the ScheduleTransactionExtension class are listed below. For a complete list of ScheduleTransactionExtension class members, see the ScheduleTransactionExtension Members topic.

Public Instance Properties

Application
ExtensionMenuItem
ViewPlugIn

See Also

ScheduleTransactionExtension Class | Aptify.Applications.Accounting Namespace


Application Property

Aptify 5.0 Software Development Kit (SDK)

ScheduleTransactionExtension.Application Property

public AptifyApplication Application {get;}

Implements

IAptifyViewExtension.

See Also

ScheduleTransactionExtension Class | Aptify.Applications.Accounting Namespace


ExtensionMenuItem Property

Aptify 5.0 Software Development Kit (SDK)

ScheduleTransactionExtension.ExtensionMenuItem Property

public MenuItem ExtensionMenuItem {get;}

Implements

IAptifyViewExtension.

See Also

ScheduleTransactionExtension Class | Aptify.Applications.Accounting Namespace


ViewPlugIn Property

Aptify 5.0 Software Development Kit (SDK)

ScheduleTransactionExtension.ViewPlugIn Property

public IAptifyViewPlugIn ViewPlugIn {get;}

Implements

IAptifyViewExtension.

See Also

ScheduleTransactionExtension Class | Aptify.Applications.Accounting Namespace


ScheduleTransactionExtension Methods

The methods of the ScheduleTransactionExtension class are listed below. For a complete list of ScheduleTransactionExtension class members, see the ScheduleTransactionExtension Members topic.

Public Instance Methods

Attach |
Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetWizardInstance |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ScheduleTransactionExtension Class | Aptify.Applications.Accounting Namespace


ScheduleTransactionExtension.Attach Method

public void Attach(
MenuItem ExtensionMenuItem
);

Implements

IAptifyViewExtension.

See Also

ScheduleTransactionExtension Class | Aptify.Applications.Accounting Namespace


ScheduleTransactionExtension.Config Method

public void Config(
AptifyApplication Application,
IAptifyViewPlugIn ViewPlugIn
);

Implements

IAptifyViewExtension.

See Also

ScheduleTransactionExtension Class | Aptify.Applications.Accounting Namespace


ScheduleTransactionExtension.Execute Method

public void Execute(
MenuItem FunctionMenuItem
);

Implements

IAptifyViewExtension.

See Also

ScheduleTransactionExtension Class | Aptify.Applications.Accounting Namespace


ScheduleTransactionExtension.GetWizardInstance Method

protected IAptifyAction GetWizardInstance(
String sEntity,
String sActionName
);

See Also

ScheduleTransactionExtension Class | Aptify.Applications.Accounting Namespace


ScheduleTransactionExtension Events

The events of the ScheduleTransactionExtension class are listed below. For a complete list of ScheduleTransactionExtension class members, see the ScheduleTransactionExtension Members topic.

Public Instance Events

AfterAttach
AfterConfig
AfterExecute
BeforeAttach
BeforeConfig
BeforeExecute

See Also

ScheduleTransactionExtension Class | Aptify.Applications.Accounting Namespace


ScheduleTransactionExtension.IAptifyViewExtension.AfterAttachEventHandler Event

public event IAptifyViewExtension.AfterAttachEventHandler AfterAttach;

Implements

IAptifyViewExtension.

See Also

ScheduleTransactionExtension Class | Aptify.Applications.Accounting Namespace


ScheduleTransactionExtension.IAptifyViewExtension.AfterConfigEventHandler Event

public event IAptifyViewExtension.AfterConfigEventHandler AfterConfig;

Implements

IAptifyViewExtension.

See Also

ScheduleTransactionExtension Class | Aptify.Applications.Accounting Namespace


ScheduleTransactionExtension.IAptifyViewExtension.AfterExecuteEventHandler Event

public event IAptifyViewExtension.AfterExecuteEventHandler AfterExecute;

Implements

IAptifyViewExtension.

See Also

ScheduleTransactionExtension Class | Aptify.Applications.Accounting Namespace


ScheduleTransactionExtension.IAptifyViewExtension.BeforeAttachEventHandler Event

public event IAptifyViewExtension.BeforeAttachEventHandler BeforeAttach;

Implements

IAptifyViewExtension.

See Also

ScheduleTransactionExtension Class | Aptify.Applications.Accounting Namespace


ScheduleTransactionExtension.IAptifyViewExtension.BeforeConfigEventHandler Event

public event IAptifyViewExtension.BeforeConfigEventHandler BeforeConfig;

Implements

IAptifyViewExtension.

See Also

ScheduleTransactionExtension Class | Aptify.Applications.Accounting Namespace


ScheduleTransactionExtension.IAptifyViewExtension.BeforeExecuteEventHandler Event

public event IAptifyViewExtension.BeforeExecuteEventHandler BeforeExecute;

Implements

IAptifyViewExtension.

See Also

ScheduleTransactionExtension Class | Aptify.Applications.Accounting Namespace


SelectCurrencyType Class

Dialog that allows a user to select one of the specified currency types that are provided in the Config() method.

For a list of all members of this type, see SelectCurrencyType Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
SelectCurrencyType

public class SelectCurrencyType : Form

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: AptifyInvoiceConsolidation (in AptifyInvoiceConsolidation.dll)

See Also

SelectCurrencyType Members | Aptify.Applications.Accounting Namespace


SelectCurrencyType Members

SelectCurrencyType overview

Public Instance Constructors

SelectCurrencyType Constructor Initializes a new instance of the SelectCurrencyType class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
SelectedCurrencyTypeID |
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnFormLoad |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

SelectCurrencyType Class | Aptify.Applications.Accounting Namespace


SelectCurrencyType Constructor

Initializes a new instance of the SelectCurrencyType class.

public SelectCurrencyType();

See Also

SelectCurrencyType Class | Aptify.Applications.Accounting Namespace


SelectCurrencyType Properties

The properties of the SelectCurrencyType class are listed below. For a complete list of SelectCurrencyType class members, see the SelectCurrencyType Members topic.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
SelectedCurrencyTypeID |
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

SelectCurrencyType Class | Aptify.Applications.Accounting Namespace


SelectedCurrencyTypeID Property

Aptify 5.0 Software Development Kit (SDK)

SelectCurrencyType.SelectedCurrencyTypeID Property

public virtual Int64 SelectedCurrencyTypeID {get;}

See Also

SelectCurrencyType Class | Aptify.Applications.Accounting Namespace


SelectCurrencyType Methods

The methods of the SelectCurrencyType class are listed below. For a complete list of SelectCurrencyType class members, see the SelectCurrencyType Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnFormLoad |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

SelectCurrencyType Class | Aptify.Applications.Accounting Namespace


SelectCurrencyType.Config Method

public virtual bool Config(
AptifyApplication Application,
List<T> CurrencyTypes
);

See Also

SelectCurrencyType Class | Aptify.Applications.Accounting Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

SelectCurrencyType.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

SelectCurrencyType Class | Aptify.Applications.Accounting Namespace


SelectCurrencyType.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

SelectCurrencyType Class | Aptify.Applications.Accounting Namespace | SelectCurrencyType.Dispose Overload List


SelectCurrencyType.OnFormLoad Method

protected virtual void OnFormLoad(
Object sender,
EventArgs e
);

See Also

SelectCurrencyType Class | Aptify.Applications.Accounting Namespace


SolomonExport Class

For a list of all members of this type, see SolomonExport Members.

System.Object
SolomonExport

public class SolomonExport : IGLExport

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: GLExportDrivers (in GLExportDrivers.dll)

See Also

SolomonExport Members | Aptify.Applications.Accounting Namespace


SolomonExport Members

SolomonExport overview

Public Instance Constructors

SolomonExport Overloaded. Initializes a new instance of the SolomonExport class.

Public Instance Methods

DoGLExport |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SolomonExport Class | Aptify.Applications.Accounting Namespace


SolomonExport Constructor

Default constructor

Overload List

Default constructor

public SolomonExport();

public SolomonExport(AptifyApplication);

See Also

SolomonExport Class | Aptify.Applications.Accounting Namespace


SolomonExport Constructor ()

Default constructor

public SolomonExport();

Remarks

See Also

SolomonExport Class | Aptify.Applications.Accounting Namespace | SolomonExport Constructor Overload List


SolomonExport Constructor (AptifyApplication)

public SolomonExport(
AptifyApplication Application
);

See Also

SolomonExport Class | Aptify.Applications.Accounting Namespace | SolomonExport Constructor Overload List


SolomonExport Methods

The methods of the SolomonExport class are listed below. For a complete list of SolomonExport class members, see the SolomonExport Members topic.

Public Instance Methods

DoGLExport |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SolomonExport Class | Aptify.Applications.Accounting Namespace


SolomonExport.DoGLExport Method

public bool DoGLExport(
AptifyGenericEntityBase BatchGE,
String DefaultExportLocation,
Boolean ShowGUI
);

Implements

IGLExport.

See Also

SolomonExport Class | Aptify.Applications.Accounting Namespace


StandingOrderFulfillment Class

Provides functionality to fulfill a group of standing orders based on a list of standing order record ID values or based on a View of Standing Orders. This object implements a specialized set of methods that are publicly available as well as IProcessComponent

For a list of all members of this type, see StandingOrderFulfillment Members.

System.Object
StandingOrderFulfillment

public class StandingOrderFulfillment : IProcessComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: StandingOrderFulfillment (in StandingOrderFulfillment.dll)

See Also

StandingOrderFulfillment Members | Aptify.Applications.Accounting Namespace


StandingOrderFulfillment Members

StandingOrderFulfillment overview

Public Instance Constructors

StandingOrderFulfillment Constructor Initializes a new instance of the StandingOrderFulfillment class.

Public Instance Properties

Properties

Public Instance Methods

Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FulfillStandingOrders | Overloaded. This method handles the process of fulfilling a group of standing orders from the specified View SQL. The only assumption on the ViewSQL is that it will return a list of standing order records that have the Standing Order ID included.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run | This process component supports 4 input properties. OrderDate - Required - Date that the orders will be set toRecordIDList - One or more Standing Order Record ID values (comma delimited), If provided, ViewSQL and ViewID are both ignoredViewSQL - If provided, ViewID is ignoredViewID
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

SetMessage |
StatusUpdate | This event provides status updates to the consumer of this object along with a Cancel parameter that allows the process to be cancelled.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StandingOrderFulfillment Class | Aptify.Applications.Accounting Namespace


StandingOrderFulfillment Constructor

Initializes a new instance of the StandingOrderFulfillment class.

public StandingOrderFulfillment();

See Also

StandingOrderFulfillment Class | Aptify.Applications.Accounting Namespace


StandingOrderFulfillment Properties

The properties of the StandingOrderFulfillment class are listed below. For a complete list of StandingOrderFulfillment class members, see the StandingOrderFulfillment Members topic.

Public Instance Properties

Properties

See Also

StandingOrderFulfillment Class | Aptify.Applications.Accounting Namespace


Properties Property

Aptify 5.0 Software Development Kit (SDK)

StandingOrderFulfillment.Properties Property

public AptifyProperties Properties {get;}

Implements

IProcessComponent.

See Also

StandingOrderFulfillment Class | Aptify.Applications.Accounting Namespace


StandingOrderFulfillment Methods

The methods of the StandingOrderFulfillment class are listed below. For a complete list of StandingOrderFulfillment class members, see the StandingOrderFulfillment Members topic.

Public Instance Methods

Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FulfillStandingOrders | Overloaded. This method handles the process of fulfilling a group of standing orders from the specified View SQL. The only assumption on the ViewSQL is that it will return a list of standing order records that have the Standing Order ID included.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run | This process component supports 4 input properties. OrderDate - Required - Date that the orders will be set toRecordIDList - One or more Standing Order Record ID values (comma delimited), If provided, ViewSQL and ViewID are both ignoredViewSQL - If provided, ViewID is ignoredViewID
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StandingOrderFulfillment Class | Aptify.Applications.Accounting Namespace


StandingOrderFulfillment.Config Method

public void Config(
AptifyApplication ApplicationObject
);

Implements

IProcessComponent.

See Also

StandingOrderFulfillment Class | Aptify.Applications.Accounting Namespace


FulfillStandingOrders Method

Aptify 5.0 Software Development Kit (SDK)

StandingOrderFulfillment.FulfillStandingOrders Method

This method handles the process of fulfilling a group of standing orders with a list of standing order record ID values.

Overload List

This method handles the process of fulfilling a group of standing orders with a list of standing order record ID values.

public virtual bool FulfillStandingOrders(DateTime,List<T>);

This method handles the process of fulfilling a group of standing orders from the specified View ID

public virtual bool FulfillStandingOrders(DateTime,Int64);

This method handles the process of fulfilling a group of standing orders with a list of standing order record ID values.

public virtual bool FulfillStandingOrders(DateTime,Int64[]);

This method handles the process of fulfilling a group of standing orders from the specified View SQL. The only assumption on the ViewSQL is that it will return a list of standing order records that have the Standing Order ID included.

public virtual bool FulfillStandingOrders(DateTime,String);

See Also

StandingOrderFulfillment Class | Aptify.Applications.Accounting Namespace


StandingOrderFulfillment.FulfillStandingOrders Method (DateTime, List<T>)

This method handles the process of fulfilling a group of standing orders with a list of standing order record ID values.

public virtual bool FulfillStandingOrders(
DateTime OrderDate,
List<T> StandingOrderIDList
);

Return Value

Remarks

See Also

StandingOrderFulfillment Class | Aptify.Applications.Accounting Namespace | StandingOrderFulfillment.FulfillStandingOrders Overload List


StandingOrderFulfillment.FulfillStandingOrders Method (DateTime, Int64)

This method handles the process of fulfilling a group of standing orders from the specified View ID

public virtual bool FulfillStandingOrders(
DateTime OrderDate,
Int64 ViewID
);

Return Value

Remarks

See Also

StandingOrderFulfillment Class | Aptify.Applications.Accounting Namespace | StandingOrderFulfillment.FulfillStandingOrders Overload List


StandingOrderFulfillment.FulfillStandingOrders Method (DateTime, Int64[])

This method handles the process of fulfilling a group of standing orders with a list of standing order record ID values.

public virtual bool FulfillStandingOrders(
DateTime OrderDate,
Int64[] StandingOrderIDArray
);

Return Value

Remarks

See Also

StandingOrderFulfillment Class | Aptify.Applications.Accounting Namespace | StandingOrderFulfillment.FulfillStandingOrders Overload List


StandingOrderFulfillment.FulfillStandingOrders Method (DateTime, String)

This method handles the process of fulfilling a group of standing orders from the specified View SQL. The only assumption on the ViewSQL is that it will return a list of standing order records that have the Standing Order ID included.

public virtual bool FulfillStandingOrders(
DateTime OrderDate,
String ViewSQL
);

Return Value

Remarks

See Also

StandingOrderFulfillment Class | Aptify.Applications.Accounting Namespace | StandingOrderFulfillment.FulfillStandingOrders Overload List


StandingOrderFulfillment.Run Method

This process component supports 4 input properties. OrderDate - Required - Date that the orders will be set toRecordIDList - One or more Standing Order Record ID values (comma delimited), If provided, ViewSQL and ViewID are both ignoredViewSQL - If provided, ViewID is ignoredViewID

public string Run();

Return Value

Implements

IProcessComponent.

Remarks

See Also

StandingOrderFulfillment Class | Aptify.Applications.Accounting Namespace


StandingOrderFulfillment Events

The events of the StandingOrderFulfillment class are listed below. For a complete list of StandingOrderFulfillment class members, see the StandingOrderFulfillment Members topic.

Public Instance Events

SetMessage |
StatusUpdate | This event provides status updates to the consumer of this object along with a Cancel parameter that allows the process to be cancelled.

See Also

StandingOrderFulfillment Class | Aptify.Applications.Accounting Namespace


StandingOrderFulfillment.StandingOrderFulfillment.SetMessageEventHandler Event

public event StandingOrderFulfillment.SetMessageEventHandler SetMessage;

See Also

StandingOrderFulfillment Class | Aptify.Applications.Accounting Namespace


StandingOrderFulfillment.StandingOrderFulfillment.StatusUpdateEventHandler Event

This event provides status updates to the consumer of this object along with a Cancel parameter that allows the process to be cancelled.

public event StandingOrderFulfillment.StatusUpdateEventHandler StatusUpdate;

Remarks

See Also

StandingOrderFulfillment Class | Aptify.Applications.Accounting Namespace


StandingOrderFulfillment.SetMessageEventHandler Delegate

public delegate void StandingOrderFulfillment.SetMessageEventHandler(
String Message
);

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: StandingOrderFulfillment (in StandingOrderFulfillment.dll)

See Also

Aptify.Applications.Accounting Namespace


StandingOrderFulfillment.StatusUpdateEventHandler Delegate

public delegate void StandingOrderFulfillment.StatusUpdateEventHandler(
String Message,
Int32 PercentComplete,
ref Boolean& Cancel
);

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: StandingOrderFulfillment (in StandingOrderFulfillment.dll)

See Also

Aptify.Applications.Accounting Namespace


StandingOrderFulfillmentWizard Class

Aptify Standing Order Fulfillment Wizard GUI Class

For a list of all members of this type, see StandingOrderFulfillmentWizard Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
StandingOrderFulfillmentWizard

public class StandingOrderFulfillmentWizard : Form, IAptifyAction

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: StandingOrderFulfillmentWizard (in StandingOrderFulfillmentWizard.dll)

See Also

StandingOrderFulfillmentWizard Members | Aptify.Applications.Accounting Namespace


StandingOrderFulfillmentWizard Members

StandingOrderFulfillmentWizard overview

Public Instance Constructors

StandingOrderFulfillmentWizard Constructor Initializes a new instance of the StandingOrderFulfillmentWizard class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoAction | Overloaded.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBeforeFinish |
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

StandingOrderFulfillmentWizard Class | Aptify.Applications.Accounting Namespace


StandingOrderFulfillmentWizard Constructor

Initializes a new instance of the StandingOrderFulfillmentWizard class.

public StandingOrderFulfillmentWizard();

See Also

StandingOrderFulfillmentWizard Class | Aptify.Applications.Accounting Namespace


StandingOrderFulfillmentWizard Methods

The methods of the StandingOrderFulfillmentWizard class are listed below. For a complete list of StandingOrderFulfillmentWizard class members, see the StandingOrderFulfillmentWizard Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoAction | Overloaded.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBeforeFinish |
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

StandingOrderFulfillmentWizard Class | Aptify.Applications.Accounting Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

StandingOrderFulfillmentWizard.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

StandingOrderFulfillmentWizard Class | Aptify.Applications.Accounting Namespace


StandingOrderFulfillmentWizard.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

StandingOrderFulfillmentWizard Class | Aptify.Applications.Accounting Namespace | StandingOrderFulfillmentWizard.Dispose Overload List


DoAction Method

Aptify 5.0 Software Development Kit (SDK)

StandingOrderFulfillmentWizard.DoAction Method

Overload List

public void DoAction(AptifyApplication,Int64);

public void DoAction(AptifyApplication,Int64,Int64);

public void DoAction(AptifyApplication,Int64,Int64,params Object[]);

public void DoAction(AptifyApplication,Int64,params String[]);

See Also

StandingOrderFulfillmentWizard Class | Aptify.Applications.Accounting Namespace


StandingOrderFulfillmentWizard.DoAction Method (AptifyApplication, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID
);

Implements

IAptifyAction.

See Also

StandingOrderFulfillmentWizard Class | Aptify.Applications.Accounting Namespace | StandingOrderFulfillmentWizard.DoAction Overload List


StandingOrderFulfillmentWizard.DoAction Method (AptifyApplication, Int64, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID
);

Implements

IAptifyAction.

See Also

StandingOrderFulfillmentWizard Class | Aptify.Applications.Accounting Namespace | StandingOrderFulfillmentWizard.DoAction Overload List


StandingOrderFulfillmentWizard.DoAction Method (AptifyApplication, Int64, Int64, Object[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID,
params Object[] SelectedItems
);

Implements

IAptifyAction.

See Also

StandingOrderFulfillmentWizard Class | Aptify.Applications.Accounting Namespace | StandingOrderFulfillmentWizard.DoAction Overload List


StandingOrderFulfillmentWizard.DoAction Method (AptifyApplication, Int64, String[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
params String[] SelectedItems
);

Implements

IAptifyAction.

See Also

StandingOrderFulfillmentWizard Class | Aptify.Applications.Accounting Namespace | StandingOrderFulfillmentWizard.DoAction Overload List


StandingOrderFulfillmentWizard.OnBeforeFinish Method

protected virtual void OnBeforeFinish(
ref Boolean& Cancel
);

See Also

StandingOrderFulfillmentWizard Class | Aptify.Applications.Accounting Namespace


StandingOrdersEntity Class

For a list of all members of this type, see StandingOrdersEntity Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
StandingOrdersEntity

public class StandingOrdersEntity : AptifyGenericEntity, IStandingOrder

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: StandingOrder (in StandingOrder.dll)

See Also

StandingOrdersEntity Members | Aptify.Applications.Accounting Namespace


StandingOrdersEntity Members

StandingOrdersEntity overview

Public Instance Constructors

StandingOrdersEntity Constructor Initializes a new instance of the StandingOrdersEntity class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config | Overloaded.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ExpandSchedule | Overloaded.
FillStandingOrder |
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetStandingOrderType | Returns the Type of Standing Order based on the Standing Order ID number
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase)
BroadcastChange (inherited from AptifyGenericEntity)
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase)
CloneSubType (inherited from AptifyGenericEntity)
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateOrder | This function will create an order record in Aptify, based on the listing of information in the standing order as well as the listing of information in the data table(dt parameter)
CreateRecord (inherited from AptifyGenericEntity)
CreateStandingOrderPurchase | This function creates a record in the Standing Order Purchase Sub-Type and optionally will save the standing order record if SaveGE is set to True
CreateSubTypeRecord (inherited from AptifyGenericEntity)
CreateTopLevelRecord (inherited from AptifyGenericEntity)
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase)
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity)
DoSingleFrequencyOrder | This function generates an order for the standing order based on the sequence in the frequency schedule provided
FillFrequencyStandingOrder | This function will determine if we need to fill this standing order or not. Unlike the version based standing orders which are dependant on if we have already sent this recipient the particular version of whichever products and product categories are in the Standing Order, this type of Standing Order fill simply checks to see if there is anything in the standing order schedule that has a date less than the current date. For each such schedule entry that is LESS than or equal to the OrderDate, this process will generate an order, and then it will push the information
FillVersionStandingOrder | Create a list of all products that are "qualified" for this standing order The concept of a qualified product is any product that matches the following criterium... A) Product.ID is in the list of IDs in the StandingOrProducts SubType B) Product.BaseProductID is in the list of IDs in the StandingOrProducts SubType C) Product.CategoryID is in the list of ID's in the StandingOrProdCats SubType A product can qualify by meeting any of the above A,B, or C criteria. In addition to meeting one or more of the above criteria, the qualfied products are defined to have to have the following attributes D) Product.CurrentlySold = True AND Product.TopLevelItem=TRUE E) Product.AvailableOn = NULL OR Product.AvailableOn less than or equal to sOrderDate F) Product.AvailableUntil=NULL OR Product.AvailableUntil >= sOrderDate A product must meet D, E AND F in order to Qualify Finally, a product must not have already been sent VIA this standing order. That is no order, generated by a prior fulfillment of this standing order can have that product ID included in it if that product is to be sent out again. G) Product.ID NOT IN (SELECT ProductID FROM OrderDetail WHERE OrderID IN LIST OF ORDERS IN StandingOrderPurchase SubType) So, the summary of the query logic required to get this list of products that we need to take an order for is as follows. *************************************************** (A OR B OR C) AND D AND E AND F AND G *************************************************** All of the above logic is implemented in the stored procedure spGetStandingOrderFillList as well as the view that this stored proc queries from.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity)
FinishTransactionSubType (inherited from AptifyGenericEntity)
FinishTransactionTopLevel (inherited from AptifyGenericEntity)
FireEvent (inherited from AptifyGenericEntity)
FireValidationEvent (inherited from AptifyGenericEntity)
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity)
GenerateCreateSQL (inherited from AptifyGenericEntity)
GenerateDeleteSQL (inherited from AptifyGenericEntity)
GenerateFieldSQL (inherited from AptifyGenericEntity)
GenerateFrequencyFillListSQL | This function will generate a SQL statement that will return ProductID,Name, Quantity,PriceType, and Price from a join of the StandingOrder information and the information in the products table based on the provided standing order For PRODUCTS that are listed individually in the StandingOrProducts sub-type, simply list those. For PRODUCT CATEGORIES that are listed in the StandingOrProdCat sub-type, expand those in the SQL Statement and assume "REGULAR" pricing for those.
GenerateUpdateSQL (inherited from AptifyGenericEntity)
GetFirstPaymentIDFromOrderID | This is a utility function that returns the lowest payment ID (first payment applied to an order) for a given order.
GetFrequencyNextDate | Retuns the next date based on the frequency specified in the function. This is used by frequency based standing orders to calculate the next date when a standing order should be filled based on the last fulfillment date
GetRecursiveProdCatList
GetStandingOrderLastScheduledDate | Returns the last scheduled date from the Schedule of the standing ordre
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase)
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity)
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity)
RefreshLinkedFields (inherited from AptifyGenericEntity)
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase)
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity)
RestoreCopiedFields (inherited from AptifyGenericEntity)
RollbackEmbeddedObjects (inherited from AptifyGenericEntity)
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase)
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase)
SetupOrderDetails
SetupTransaction (inherited from AptifyGenericEntity)
SetupTransactionSubType (inherited from AptifyGenericEntity)
SetupTransactionTopLevel (inherited from AptifyGenericEntity)
UpdateRecord (inherited from AptifyGenericEntity)
ValidateSubTypes (inherited from AptifyGenericEntityBase)
VerifyObject (inherited from AptifyGenericEntity)

See Also

StandingOrdersEntity Class | Aptify.Applications.Accounting Namespace


StandingOrdersEntity Constructor

Initializes a new instance of the StandingOrdersEntity class.

public StandingOrdersEntity();

See Also

StandingOrdersEntity Class | Aptify.Applications.Accounting Namespace


StandingOrdersEntity Methods

The methods of the StandingOrdersEntity class are listed below. For a complete list of StandingOrdersEntity class members, see the StandingOrdersEntity Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config | Overloaded.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ExpandSchedule | Overloaded.
FillStandingOrder |
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetStandingOrderType | Returns the Type of Standing Order based on the Standing Order ID number
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase)
BroadcastChange (inherited from AptifyGenericEntity)
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase)
CloneSubType (inherited from AptifyGenericEntity)
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateOrder | This function will create an order record in Aptify, based on the listing of information in the standing order as well as the listing of information in the data table(dt parameter)
CreateRecord (inherited from AptifyGenericEntity)
CreateStandingOrderPurchase | This function creates a record in the Standing Order Purchase Sub-Type and optionally will save the standing order record if SaveGE is set to True
CreateSubTypeRecord (inherited from AptifyGenericEntity)
CreateTopLevelRecord (inherited from AptifyGenericEntity)
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase)
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity)
DoSingleFrequencyOrder | This function generates an order for the standing order based on the sequence in the frequency schedule provided
FillFrequencyStandingOrder | This function will determine if we need to fill this standing order or not. Unlike the version based standing orders which are dependant on if we have already sent this recipient the particular version of whichever products and product categories are in the Standing Order, this type of Standing Order fill simply checks to see if there is anything in the standing order schedule that has a date less than the current date. For each such schedule entry that is LESS than or equal to the OrderDate, this process will generate an order, and then it will push the information
FillVersionStandingOrder | Create a list of all products that are "qualified" for this standing order The concept of a qualified product is any product that matches the following criterium... A) Product.ID is in the list of IDs in the StandingOrProducts SubType B) Product.BaseProductID is in the list of IDs in the StandingOrProducts SubType C) Product.CategoryID is in the list of ID's in the StandingOrProdCats SubType A product can qualify by meeting any of the above A,B, or C criteria. In addition to meeting one or more of the above criteria, the qualfied products are defined to have to have the following attributes D) Product.CurrentlySold = True AND Product.TopLevelItem=TRUE E) Product.AvailableOn = NULL OR Product.AvailableOn less than or equal to sOrderDate F) Product.AvailableUntil=NULL OR Product.AvailableUntil >= sOrderDate A product must meet D, E AND F in order to Qualify Finally, a product must not have already been sent VIA this standing order. That is no order, generated by a prior fulfillment of this standing order can have that product ID included in it if that product is to be sent out again. G) Product.ID NOT IN (SELECT ProductID FROM OrderDetail WHERE OrderID IN LIST OF ORDERS IN StandingOrderPurchase SubType) So, the summary of the query logic required to get this list of products that we need to take an order for is as follows. *************************************************** (A OR B OR C) AND D AND E AND F AND G *************************************************** All of the above logic is implemented in the stored procedure spGetStandingOrderFillList as well as the view that this stored proc queries from.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity)
FinishTransactionSubType (inherited from AptifyGenericEntity)
FinishTransactionTopLevel (inherited from AptifyGenericEntity)
FireEvent (inherited from AptifyGenericEntity)
FireValidationEvent (inherited from AptifyGenericEntity)
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity)
GenerateCreateSQL (inherited from AptifyGenericEntity)
GenerateDeleteSQL (inherited from AptifyGenericEntity)
GenerateFieldSQL (inherited from AptifyGenericEntity)
GenerateFrequencyFillListSQL | This function will generate a SQL statement that will return ProductID,Name, Quantity,PriceType, and Price from a join of the StandingOrder information and the information in the products table based on the provided standing order For PRODUCTS that are listed individually in the StandingOrProducts sub-type, simply list those. For PRODUCT CATEGORIES that are listed in the StandingOrProdCat sub-type, expand those in the SQL Statement and assume "REGULAR" pricing for those.
GenerateUpdateSQL (inherited from AptifyGenericEntity)
GetFirstPaymentIDFromOrderID | This is a utility function that returns the lowest payment ID (first payment applied to an order) for a given order.
GetFrequencyNextDate | Retuns the next date based on the frequency specified in the function. This is used by frequency based standing orders to calculate the next date when a standing order should be filled based on the last fulfillment date
GetRecursiveProdCatList
GetStandingOrderLastScheduledDate | Returns the last scheduled date from the Schedule of the standing ordre
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase)
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity)
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity)
RefreshLinkedFields (inherited from AptifyGenericEntity)
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase)
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity)
RestoreCopiedFields (inherited from AptifyGenericEntity)
RollbackEmbeddedObjects (inherited from AptifyGenericEntity)
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase)
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase)
SetupOrderDetails
SetupTransaction (inherited from AptifyGenericEntity)
SetupTransactionSubType (inherited from AptifyGenericEntity)
SetupTransactionTopLevel (inherited from AptifyGenericEntity)
UpdateRecord (inherited from AptifyGenericEntity)
ValidateSubTypes (inherited from AptifyGenericEntityBase)
VerifyObject (inherited from AptifyGenericEntity)

See Also

StandingOrdersEntity Class | Aptify.Applications.Accounting Namespace


Config Method

Aptify 5.0 Software Development Kit (SDK)

StandingOrdersEntity.Config Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual void Config(AptifySubTypeBase);

Inherited from AptifyGenericEntity.

public override void Config(AptifySubTypeBase,Int64);

Inherited from AptifyGenericEntityBase.

public virtual void Config(UserCredentials,String);

public override void Config(UserCredentials,String,Int64);

See Also

StandingOrdersEntity Class | Aptify.Applications.Accounting Namespace


StandingOrdersEntity.Config Method (UserCredentials, String, Int64)

public override void Config(
UserCredentials UserCredentials,
String EntityName,
Int64 RecordID
);

See Also

StandingOrdersEntity Class | Aptify.Applications.Accounting Namespace | StandingOrdersEntity.Config Overload List


StandingOrdersEntity.CreateOrder Method

This function will create an order record in Aptify, based on the listing of information in the standing order as well as the listing of information in the data table(dt parameter)

protected bool CreateOrder(
DataTable dt,
ref Int64& OrderID,
AptifyGenericEntityBase StandingOrderGE,
DateTime OrderDate
);

Parameters

dt
OrderID
StandingOrderGE
OrderDate

Return Value

Remarks

See Also

StandingOrdersEntity Class | Aptify.Applications.Accounting Namespace


StandingOrdersEntity.CreateStandingOrderPurchase Method

This function creates a record in the Standing Order Purchase Sub-Type and optionally will save the standing order record if SaveGE is set to True

protected bool CreateStandingOrderPurchase(
AptifyGenericEntityBase StandingOrderGE,
Int64 OrderID,
Boolean SaveGE
);

Parameters

StandingOrderGE
OrderID
SaveGE

Return Value

Remarks

See Also

StandingOrdersEntity Class | Aptify.Applications.Accounting Namespace


StandingOrdersEntity.DoSingleFrequencyOrder Method

This function generates an order for the standing order based on the sequence in the frequency schedule provided

protected bool DoSingleFrequencyOrder(
AptifyGenericEntityBase StandingOrderGE,
Int32 Sequence,
DateTime OrderDate,
ref Int64& OrderID,
DataTable FillList
);

Parameters

StandingOrderGE
Sequence
OrderDate
OrderID
FillList

Return Value

Remarks

See Also

StandingOrdersEntity Class | Aptify.Applications.Accounting Namespace


ExpandSchedule Method

Aptify 5.0 Software Development Kit (SDK)

StandingOrdersEntity.ExpandSchedule Method

Overload List

public bool ExpandSchedule(AptifyGenericEntityBase);

public bool ExpandSchedule(Int64);

See Also

StandingOrdersEntity Class | Aptify.Applications.Accounting Namespace


StandingOrdersEntity.ExpandSchedule Method (AptifyGenericEntityBase)

public bool ExpandSchedule(
AptifyGenericEntityBase StandingOrderGE
);

Implements

IStandingOrder.

See Also

StandingOrdersEntity Class | Aptify.Applications.Accounting Namespace | StandingOrdersEntity.ExpandSchedule Overload List


StandingOrdersEntity.ExpandSchedule Method (Int64)

public bool ExpandSchedule(
Int64 StandingOrderID
);

Implements

IStandingOrder.

See Also

StandingOrdersEntity Class | Aptify.Applications.Accounting Namespace | StandingOrdersEntity.ExpandSchedule Overload List


StandingOrdersEntity.FillFrequencyStandingOrder Method

This function will determine if we need to fill this standing order or not. Unlike the version based standing orders which are dependant on if we have already sent this recipient the particular version of whichever products and product categories are in the Standing Order, this type of Standing Order fill simply checks to see if there is anything in the standing order schedule that has a date less than the current date. For each such schedule entry that is LESS than or equal to the OrderDate, this process will generate an order, and then it will push the information

protected virtual bool FillFrequencyStandingOrder(
DateTime OrderDate,
Int64 StandingOrderID,
ref Int64& OrderID
);

Parameters

OrderDate
StandingOrderID
OrderID

Return Value

Remarks

See Also

StandingOrdersEntity Class | Aptify.Applications.Accounting Namespace


StandingOrdersEntity.FillStandingOrder Method

public bool FillStandingOrder(
DateTime OrderDate,
Int64 StandingOrderID,
ref Int64& OrderID
);

Implements

IStandingOrder.

See Also

StandingOrdersEntity Class | Aptify.Applications.Accounting Namespace


StandingOrdersEntity.FillVersionStandingOrder Method

Create a list of all products that are "qualified" for this standing order The concept of a qualified product is any product that matches the following criterium... A) Product.ID is in the list of IDs in the StandingOrProducts SubType B) Product.BaseProductID is in the list of IDs in the StandingOrProducts SubType C) Product.CategoryID is in the list of ID's in the StandingOrProdCats SubType A product can qualify by meeting any of the above A,B, or C criteria. In addition to meeting one or more of the above criteria, the qualfied products are defined to have to have the following attributes D) Product.CurrentlySold = True AND Product.TopLevelItem=TRUE E) Product.AvailableOn = NULL OR Product.AvailableOn less than or equal to sOrderDate F) Product.AvailableUntil=NULL OR Product.AvailableUntil >= sOrderDate A product must meet D, E AND F in order to Qualify Finally, a product must not have already been sent VIA this standing order. That is no order, generated by a prior fulfillment of this standing order can have that product ID included in it if that product is to be sent out again. G) Product.ID NOT IN (SELECT ProductID FROM OrderDetail WHERE OrderID IN LIST OF ORDERS IN StandingOrderPurchase SubType) So, the summary of the query logic required to get this list of products that we need to take an order for is as follows. *************************************************** (A OR B OR C) AND D AND E AND F AND G *************************************************** All of the above logic is implemented in the stored procedure spGetStandingOrderFillList as well as the view that this stored proc queries from.

protected virtual bool FillVersionStandingOrder(
DateTime OrderDate,
Int64 StandingOrderID,
ref Int64& OrderID
);

Parameters

OrderDate
StandingOrderID
OrderID

Return Value

Remarks

See Also

StandingOrdersEntity Class | Aptify.Applications.Accounting Namespace


StandingOrdersEntity.GenerateFrequencyFillListSQL Method

This function will generate a SQL statement that will return ProductID,Name, Quantity,PriceType, and Price from a join of the StandingOrder information and the information in the products table based on the provided standing order For PRODUCTS that are listed individually in the StandingOrProducts sub-type, simply list those. For PRODUCT CATEGORIES that are listed in the StandingOrProdCat sub-type, expand those in the SQL Statement and assume "REGULAR" pricing for those.

protected string GenerateFrequencyFillListSQL(
AptifyGenericEntityBase StandingOrderGE,
DateTime OrderDate
);

Parameters

StandingOrderGE
OrderDate

Return Value

Remarks

See Also

StandingOrdersEntity Class | Aptify.Applications.Accounting Namespace


StandingOrdersEntity.GetFirstPaymentIDFromOrderID Method

This is a utility function that returns the lowest payment ID (first payment applied to an order) for a given order.

protected long GetFirstPaymentIDFromOrderID(
Int64 OrderID
);

Parameters

OrderID
The Order to check

Return Value

The lowest payment ID associated with OrderID, or -1 if no payments have been applied to OrderID

Remarks

See Also

StandingOrdersEntity Class | Aptify.Applications.Accounting Namespace


StandingOrdersEntity.GetFrequencyNextDate Method

Retuns the next date based on the frequency specified in the function. This is used by frequency based standing orders to calculate the next date when a standing order should be filled based on the last fulfillment date

protected virtual DateTime GetFrequencyNextDate(
DateTime BaseDate,
String Frequency
);

Parameters

BaseDate
Starting Date from which to calculate the future specified date
Frequency
Frequency of the Standing Order

Return Value

Remarks

See Also

StandingOrdersEntity Class | Aptify.Applications.Accounting Namespace


StandingOrdersEntity.GetRecursiveProdCatList Method

protected string GetRecursiveProdCatList(
Int64 lCategoryID
);

See Also

StandingOrdersEntity Class | Aptify.Applications.Accounting Namespace


StandingOrdersEntity.GetStandingOrderLastScheduledDate Method

Returns the last scheduled date from the Schedule of the standing ordre

protected DateTime GetStandingOrderLastScheduledDate(
AptifyGenericEntityBase StandingOrderGE
);

Parameters

StandingOrderGE

Return Value

Remarks

See Also

StandingOrdersEntity Class | Aptify.Applications.Accounting Namespace


StandingOrdersEntity.GetStandingOrderType Method

Returns the Type of Standing Order based on the Standing Order ID number

public StandingOrderType GetStandingOrderType(
Int64 StandingOrderID
);

Parameters

StandingOrderID
Standing Order ID Number

Return Value

The value of the Type field in the standing order

Remarks

See Also

StandingOrdersEntity Class | Aptify.Applications.Accounting Namespace


StandingOrdersEntity.SetupOrderDetails Method

protected bool SetupOrderDetails(
OrdersEntity oOrder,
DataTable dt
);

See Also

StandingOrdersEntity Class | Aptify.Applications.Accounting Namespace


StandingOrderType Enumeration

Enumerated type representing the different types of standing orders that can exist

public enum StandingOrderType

Remarks

Members

Member Name | Description
Version | Version based standing order - fulfillment occurs when new version(s) of products and/or product categories are made available
Frequency | Frequency based standing order - fulfillment occurs on a defined frequency established in the schedule within the standing order

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: StandingOrder (in StandingOrder.dll)

See Also

Aptify.Applications.Accounting Namespace


Status Class

For a list of all members of this type, see Status Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
Status

public class Status : Form

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: ExpandScheduledTransactions (in ExpandScheduledTransactions.dll)

See Also

Status Members | Aptify.Applications.Accounting Namespace


Status Members

Status overview

Public Instance Constructors

Status Constructor Initializes a new instance of the Status class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UserCredential |
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
CancelledByUser |
Close (inherited from Form) | Closes the form.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DoLocalization |
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
UpdateStatus |
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

Status Class | Aptify.Applications.Accounting Namespace


Status Constructor

Initializes a new instance of the Status class.

public Status();

See Also

Status Class | Aptify.Applications.Accounting Namespace


Status Properties

The properties of the Status class are listed below. For a complete list of Status class members, see the Status Members topic.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UserCredential |
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

Status Class | Aptify.Applications.Accounting Namespace


UserCredential Property

Aptify 5.0 Software Development Kit (SDK)

Status.UserCredential Property

public UserCredentials UserCredential {get; set;}

See Also

Status Class | Aptify.Applications.Accounting Namespace


Status Methods

The methods of the Status class are listed below. For a complete list of Status class members, see the Status Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
CancelledByUser |
Close (inherited from Form) | Closes the form.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DoLocalization |
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
UpdateStatus |
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

Status Class | Aptify.Applications.Accounting Namespace


Status.CancelledByUser Method

public bool CancelledByUser();

See Also

Status Class | Aptify.Applications.Accounting Namespace


Status.Config Method

public void Config();

See Also

Status Class | Aptify.Applications.Accounting Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

Status.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

Status Class | Aptify.Applications.Accounting Namespace


Status.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

Status Class | Aptify.Applications.Accounting Namespace | Status.Dispose Overload List


Status.DoLocalization Method

public void DoLocalization();

See Also

Status Class | Aptify.Applications.Accounting Namespace


Status.UpdateStatus Method

public void UpdateStatus(
Int32 CurrentPercent,
Int64 CurrentProductID
);

See Also

Status Class | Aptify.Applications.Accounting Namespace


StatusUpdateEventHandler Delegate

Represents the Method that should be called when Status for a long running task should be updated.

public delegate void StatusUpdateEventHandler(
Int32 PercentComplete,
ref Boolean& Cancel
);

Parameters

PercentComplete
A value 0-100.
Cancel
If the target method sets this to false, the task should attempt to cancel.

Remarks

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: ICashControlBatch (in ICashControlBatch.dll)

See Also

Aptify.Applications.Accounting Namespace


TaxJurisdictionCache Class

Caches Tax Jurisdictions information. Shared, on-demand cache.

For a list of all members of this type, see TaxJurisdictionCache Members.

System.Object
TaxJurisdictionCache

public class TaxJurisdictionCache

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: AptifySalesTax (in AptifySalesTax.dll)

See Also

TaxJurisdictionCache Members | Aptify.Applications.Accounting Namespace


TaxJurisdictionCache Members

TaxJurisdictionCache overview

Public Static Methods

Instance

Public Instance Properties

ChildTaxJurisdictions |
RootTaxJurisdictions | This method will retrieve the Root level Tax Jurisdictions and return them as a collection.

Public Instance Methods

Clear | Clears the Tax Jurisdictions cache.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetQualifyingTaxJurisdiction | Overloaded. Given an Address, find the Tax Jurisdiction for that Address. With only one Address passed in, that Address will be used as a Bill To, Ship To and Selling Location Address.
GetTaxJurisdictionSalesTaxRates |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TaxJurisdictionCache Class | Aptify.Applications.Accounting Namespace


TaxJurisdictionCache Properties

The properties of the TaxJurisdictionCache class are listed below. For a complete list of TaxJurisdictionCache class members, see the TaxJurisdictionCache Members topic.

Public Instance Properties

ChildTaxJurisdictions |
RootTaxJurisdictions | This method will retrieve the Root level Tax Jurisdictions and return them as a collection.

See Also

TaxJurisdictionCache Class | Aptify.Applications.Accounting Namespace


ChildTaxJurisdictions Property

Aptify 5.0 Software Development Kit (SDK)

TaxJurisdictionCache.ChildTaxJurisdictions Property

public List<T> this[
TaxJurisdictionData Parent
] {get;}

See Also

TaxJurisdictionCache Class | Aptify.Applications.Accounting Namespace


RootTaxJurisdictions Property

Aptify 5.0 Software Development Kit (SDK)

TaxJurisdictionCache.RootTaxJurisdictions Property

This method will retrieve the Root level Tax Jurisdictions and return them as a collection.

public List<T> this[
Boolean ForceRefresh
] {get;}

Property Value

Remarks

See Also

TaxJurisdictionCache Class | Aptify.Applications.Accounting Namespace


TaxJurisdictionCache Methods

The methods of the TaxJurisdictionCache class are listed below. For a complete list of TaxJurisdictionCache class members, see the TaxJurisdictionCache Members topic.

Public Static Methods

Instance

Public Instance Methods

Clear | Clears the Tax Jurisdictions cache.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetQualifyingTaxJurisdiction | Overloaded. Given an Address, find the Tax Jurisdiction for that Address. With only one Address passed in, that Address will be used as a Bill To, Ship To and Selling Location Address.
GetTaxJurisdictionSalesTaxRates |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TaxJurisdictionCache Class | Aptify.Applications.Accounting Namespace


TaxJurisdictionCache.Clear Method

Clears the Tax Jurisdictions cache.

public void Clear();

Remarks

See Also

TaxJurisdictionCache Class | Aptify.Applications.Accounting Namespace


GetQualifyingTaxJurisdiction Method

Aptify 5.0 Software Development Kit (SDK)

TaxJurisdictionCache.GetQualifyingTaxJurisdiction Method

Given an Address, find the Tax Jurisdiction for that Address. With only one Address passed in, that Address will be used as a Bill To, Ship To and Selling Location Address.

Overload List

Given an Address, find the Tax Jurisdiction for that Address. With only one Address passed in, that Address will be used as a Bill To, Ship To and Selling Location Address.

public TaxJurisdictionData GetQualifyingTaxJurisdiction(TaxAddress);

Given Ship To, Bill To and Selling Location Addresses, find the qualifying Tax Jurisdiction.

public TaxJurisdictionData GetQualifyingTaxJurisdiction(TaxAddress,TaxAddress,TaxAddress);

See Also

TaxJurisdictionCache Class | Aptify.Applications.Accounting Namespace


TaxJurisdictionCache.GetQualifyingTaxJurisdiction Method (TaxAddress)

Given an Address, find the Tax Jurisdiction for that Address. With only one Address passed in, that Address will be used as a Bill To, Ship To and Selling Location Address.

public TaxJurisdictionData GetQualifyingTaxJurisdiction(
TaxAddress Address
);

Parameters

Address

Return Value

Returns a TaxJurisdictionData object populated with the Qualifying Tax Jurisdiction information. If no qualifying Tax Jurisdiction is found, Nothing is returned.

Remarks

See Also

TaxJurisdictionCache Class | Aptify.Applications.Accounting Namespace | TaxJurisdictionCache.GetQualifyingTaxJurisdiction Overload List


TaxJurisdictionCache.GetQualifyingTaxJurisdiction Method (TaxAddress, TaxAddress, TaxAddress)

Given Ship To, Bill To and Selling Location Addresses, find the qualifying Tax Jurisdiction.

public TaxJurisdictionData GetQualifyingTaxJurisdiction(
TaxAddress ShipToAddress,
TaxAddress BillToAddress,
TaxAddress SellingLocationAddress
);

Parameters

ShipToAddress
BillToAddress
SellingLocationAddress

Return Value

Returns a TaxJurisdictionData object populated with the Qualifying Tax Jurisdiction information. If no qualifying Tax Jurisdiction is found, Nothing is returned.

Remarks

See Also

TaxJurisdictionCache Class | Aptify.Applications.Accounting Namespace | TaxJurisdictionCache.GetQualifyingTaxJurisdiction Overload List


TaxJurisdictionCache.GetTaxJurisdictionSalesTaxRates Method

public List<T> GetTaxJurisdictionSalesTaxRates(
Int64 TaxJurisdictionID
);

See Also

TaxJurisdictionCache Class | Aptify.Applications.Accounting Namespace


TaxJurisdictionCache.Instance Method

public static TaxJurisdictionCache Instance(
AptifyApplication Application
);

See Also

TaxJurisdictionCache Class | Aptify.Applications.Accounting Namespace


TaxJurisdictionData Class

For a list of all members of this type, see TaxJurisdictionData Members.

System.Object
TaxJurisdictionData

public class TaxJurisdictionData

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: AptifySalesTax (in AptifySalesTax.dll)

See Also

TaxJurisdictionData Members | Aptify.Applications.Accounting Namespace


TaxJurisdictionData Members

TaxJurisdictionData overview

Public Instance Constructors

TaxJurisdictionData Constructor

Public Instance Properties

AppliesToBillToAddress |
AppliesToSellingLocation |
AppliesToShipToAddress |
Children | Returns the Tax Jurisdictions that are the children of the current Tax Jurisdiction. Child Tax Jurisdictions have a ParentID equal to the current record's ID.
City |
CountryID |
County |
HasChildren |
ID |
Name |
Parent |
PostalCode |
QualifyingTaxJurisdiction | Overloaded. If the Address qualifies, the lowest level Tax Jurisdiction will be returned. If the Address does not qualify, the property will return Nothing. With only one Address provided, the Address will be used for Ship To, Bill To and Selling Location Addresses.
SalesTaxRates | Returns the list of active Sales Tax Rates for the current Tax Jurisdiction. Uses parent Tax Jurisdiction Sales Tax Rates where appropriate.
Scope |

Public Instance Methods

AddressMatch | Overloaded. Checks to see if the Address passed in matches the current Tax Jurisdiction definition. With only one Address provided, the Address will be used for the Ship To, Bill To and Selling Location Addresses.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TaxJurisdictionData Class | Aptify.Applications.Accounting Namespace


TaxJurisdictionData Constructor

public TaxJurisdictionData(
TaxJurisdictionCache CacheInstance,
DataRow rowTax,
TaxJurisdictionData Parent
);

See Also

TaxJurisdictionData Class | Aptify.Applications.Accounting Namespace


TaxJurisdictionData Properties

The properties of the TaxJurisdictionData class are listed below. For a complete list of TaxJurisdictionData class members, see the TaxJurisdictionData Members topic.

Public Instance Properties

AppliesToBillToAddress |
AppliesToSellingLocation |
AppliesToShipToAddress |
Children | Returns the Tax Jurisdictions that are the children of the current Tax Jurisdiction. Child Tax Jurisdictions have a ParentID equal to the current record's ID.
City |
CountryID |
County |
HasChildren |
ID |
Name |
Parent |
PostalCode |
QualifyingTaxJurisdiction | Overloaded. If the Address qualifies, the lowest level Tax Jurisdiction will be returned. If the Address does not qualify, the property will return Nothing. With only one Address provided, the Address will be used for Ship To, Bill To and Selling Location Addresses.
SalesTaxRates | Returns the list of active Sales Tax Rates for the current Tax Jurisdiction. Uses parent Tax Jurisdiction Sales Tax Rates where appropriate.
Scope |

See Also

TaxJurisdictionData Class | Aptify.Applications.Accounting Namespace


AppliesToBillToAddress Property

Aptify 5.0 Software Development Kit (SDK)

TaxJurisdictionData.AppliesToBillToAddress Property

public Boolean AppliesToBillToAddress {get;}

See Also

TaxJurisdictionData Class | Aptify.Applications.Accounting Namespace


AppliesToSellingLocation Property

Aptify 5.0 Software Development Kit (SDK)

TaxJurisdictionData.AppliesToSellingLocation Property

public Boolean AppliesToSellingLocation {get;}

See Also

TaxJurisdictionData Class | Aptify.Applications.Accounting Namespace


AppliesToShipToAddress Property

Aptify 5.0 Software Development Kit (SDK)

TaxJurisdictionData.AppliesToShipToAddress Property

public Boolean AppliesToShipToAddress {get;}

See Also

TaxJurisdictionData Class | Aptify.Applications.Accounting Namespace


Children Property

Aptify 5.0 Software Development Kit (SDK)

TaxJurisdictionData.Children Property

Returns the Tax Jurisdictions that are the children of the current Tax Jurisdiction. Child Tax Jurisdictions have a ParentID equal to the current record's ID.

public List<T> Children {get;}

Property Value

Remarks

See Also

TaxJurisdictionData Class | Aptify.Applications.Accounting Namespace


City Property

Aptify 5.0 Software Development Kit (SDK)

TaxJurisdictionData.City Property

public String City {get;}

See Also

TaxJurisdictionData Class | Aptify.Applications.Accounting Namespace


CountryID Property

Aptify 5.0 Software Development Kit (SDK)

TaxJurisdictionData.CountryID Property

public Int32 CountryID {get;}

See Also

TaxJurisdictionData Class | Aptify.Applications.Accounting Namespace


County Property

Aptify 5.0 Software Development Kit (SDK)

TaxJurisdictionData.County Property

public String County {get;}

See Also

TaxJurisdictionData Class | Aptify.Applications.Accounting Namespace


HasChildren Property

Aptify 5.0 Software Development Kit (SDK)

TaxJurisdictionData.HasChildren Property

public Boolean HasChildren {get;}

See Also

TaxJurisdictionData Class | Aptify.Applications.Accounting Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

TaxJurisdictionData.ID Property

public Int64 ID {get;}

See Also

TaxJurisdictionData Class | Aptify.Applications.Accounting Namespace


Name Property

Aptify 5.0 Software Development Kit (SDK)

TaxJurisdictionData.Name Property

public String Name {get;}

See Also

TaxJurisdictionData Class | Aptify.Applications.Accounting Namespace


Parent Property

Aptify 5.0 Software Development Kit (SDK)

TaxJurisdictionData.Parent Property

public TaxJurisdictionData Parent {get;}

See Also

TaxJurisdictionData Class | Aptify.Applications.Accounting Namespace


PostalCode Property

Aptify 5.0 Software Development Kit (SDK)

TaxJurisdictionData.PostalCode Property

public String PostalCode {get;}

See Also

TaxJurisdictionData Class | Aptify.Applications.Accounting Namespace


TaxJurisdictionData Property

Aptify 5.0 Software Development Kit (SDK)

TaxJurisdictionData.TaxJurisdictionData Property

If the Address qualifies, the lowest level Tax Jurisdiction will be returned. If the Address does not qualify, the property will return Nothing. With only one Address provided, the Address will be used for Ship To, Bill To and Selling Location Addresses.

Overload List

If the Address qualifies, the lowest level Tax Jurisdiction will be returned. If the Address does not qualify, the property will return Nothing. With only one Address provided, the Address will be used for Ship To, Bill To and Selling Location Addresses.

public TaxJurisdictionData this[TaxAddress] {get;}

If the Ship To and Bill To Addresses match a Tax Juridiction, the lowest level Tax Jurisdiction will be returned. If the Address does not qualify, the property will return Nothing.

public TaxJurisdictionData this[TaxAddress, TaxAddress, TaxAddress] {get;}

See Also

TaxJurisdictionData Class | Aptify.Applications.Accounting Namespace


QualifyingTaxJurisdiction Property (TaxAddress)

Aptify 5.0 Software Development Kit (SDK)

TaxJurisdictionData.QualifyingTaxJurisdiction Property (TaxAddress)

If the Address qualifies, the lowest level Tax Jurisdiction will be returned. If the Address does not qualify, the property will return Nothing. With only one Address provided, the Address will be used for Ship To, Bill To and Selling Location Addresses.

public TaxJurisdictionData this[
TaxAddress Address
] {get;}

Parameters

Address

Property Value

Remarks

See Also

TaxJurisdictionData Class | Aptify.Applications.Accounting Namespace | TaxJurisdictionData.TaxJurisdictionData Overload List


QualifyingTaxJurisdiction Property (TaxAddress, TaxAddress, TaxAddress)

Aptify 5.0 Software Development Kit (SDK)

TaxJurisdictionData.QualifyingTaxJurisdiction Property (TaxAddress, TaxAddress, TaxAddress)

If the Ship To and Bill To Addresses match a Tax Juridiction, the lowest level Tax Jurisdiction will be returned. If the Address does not qualify, the property will return Nothing.

public TaxJurisdictionData this[
TaxAddress ShipToAddress,
TaxAddress BillToAddress,
TaxAddress SellingLocationAddress
] {get;}

Parameters

ShipToAddress
BillToAddress
SellingLocationAddress

Property Value

Remarks

See Also

TaxJurisdictionData Class | Aptify.Applications.Accounting Namespace | TaxJurisdictionData.TaxJurisdictionData Overload List


SalesTaxRates Property

Aptify 5.0 Software Development Kit (SDK)

TaxJurisdictionData.SalesTaxRates Property

Returns the list of active Sales Tax Rates for the current Tax Jurisdiction. Uses parent Tax Jurisdiction Sales Tax Rates where appropriate.

public List<T> SalesTaxRates {get;}

Property Value

Remarks

See Also

TaxJurisdictionData Class | Aptify.Applications.Accounting Namespace


Scope Property

Aptify 5.0 Software Development Kit (SDK)

TaxJurisdictionData.Scope Property

public TaxJurisdictionScope Scope {get;}

See Also

TaxJurisdictionData Class | Aptify.Applications.Accounting Namespace


TaxJurisdictionData Methods

The methods of the TaxJurisdictionData class are listed below. For a complete list of TaxJurisdictionData class members, see the TaxJurisdictionData Members topic.

Public Instance Methods

AddressMatch | Overloaded. Checks to see if the Address passed in matches the current Tax Jurisdiction definition. With only one Address provided, the Address will be used for the Ship To, Bill To and Selling Location Addresses.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TaxJurisdictionData Class | Aptify.Applications.Accounting Namespace


AddressMatch Method

Aptify 5.0 Software Development Kit (SDK)

TaxJurisdictionData.AddressMatch Method

Checks to see if the Address passed in matches the current Tax Jurisdiction definition. With only one Address provided, the Address will be used for the Ship To, Bill To and Selling Location Addresses.

Overload List

Checks to see if the Address passed in matches the current Tax Jurisdiction definition. With only one Address provided, the Address will be used for the Ship To, Bill To and Selling Location Addresses.

public bool AddressMatch(TaxAddress);

Returns whether or not the Ship To, Bill To and/or Selling Location Address information qualifies for the current Tax Jurisdiction.

public bool AddressMatch(TaxAddress,TaxAddress,TaxAddress);

See Also

TaxJurisdictionData Class | Aptify.Applications.Accounting Namespace


TaxJurisdictionData.AddressMatch Method (TaxAddress)

Checks to see if the Address passed in matches the current Tax Jurisdiction definition. With only one Address provided, the Address will be used for the Ship To, Bill To and Selling Location Addresses.

public bool AddressMatch(
TaxAddress Address
);

Parameters

Address

Return Value

Returns true is the Address qualifies for the Tax Jurisdiction. Otherwise, returns false.

Remarks

See Also

TaxJurisdictionData Class | Aptify.Applications.Accounting Namespace | TaxJurisdictionData.AddressMatch Overload List


TaxJurisdictionData.AddressMatch Method (TaxAddress, TaxAddress, TaxAddress)

Returns whether or not the Ship To, Bill To and/or Selling Location Address information qualifies for the current Tax Jurisdiction.

public bool AddressMatch(
TaxAddress ShipToAddress,
TaxAddress BillToAddress,
TaxAddress SellingLocationAddress
);

Parameters

ShipToAddress
BillToAddress
SellingLocationAddress

Return Value

Returns true if the Addresses match the Tax Jurisdiction definition. Otherwise, returns false.

Remarks

See Also

TaxJurisdictionData Class | Aptify.Applications.Accounting Namespace | TaxJurisdictionData.AddressMatch Overload List


TaxJurisdictionScope Enumeration

public enum TaxJurisdictionScope

Members

Member Name | Description
Country |
StateProvince |
County |
City |
PostalCode |

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: AptifySalesTax (in AptifySalesTax.dll)

See Also

Aptify.Applications.Accounting Namespace


TaxJurisdictionsLayout Class

For a list of all members of this type, see TaxJurisdictionsLayout Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
TaxJurisdictionsLayout

public class TaxJurisdictionsLayout : FormTemplateLayout

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Accounting

Assembly: SalesTaxRateControls (in SalesTaxRateControls.dll)

See Also

TaxJurisdictionsLayout Members | Aptify.Applications.Accounting Namespace


TaxJurisdictionsLayout Members

TaxJurisdictionsLayout overview

Public Instance Constructors

TaxJurisdictionsLayout Constructor Initializes a new instance of the TaxJurisdictionsLayout class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
m_dcbStateProvince |
m_lnkCountryID |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControls |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCountryIDChanged |
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded | Contains logic to setup Event handlers for controls on the FormTemplate Layout.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControls |
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

TaxJurisdictionsLayout Class | Aptify.Applications.Accounting Namespace


TaxJurisdictionsLayout Constructor

Initializes a new instance of the TaxJurisdictionsLayout class.

public TaxJurisdictionsLayout();

See Also

TaxJurisdictionsLayout Class | Aptify.Applications.Accounting Namespace


TaxJurisdictionsLayout Properties

The properties of the TaxJurisdictionsLayout class are listed below. For a complete list of TaxJurisdictionsLayout class members, see the TaxJurisdictionsLayout Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
m_dcbStateProvince |
m_lnkCountryID |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

TaxJurisdictionsLayout Class | Aptify.Applications.Accounting Namespace


m_dcbStateProvince Property

Aptify 5.0 Software Development Kit (SDK)

TaxJurisdictionsLayout.m_dcbStateProvince Property

protected virtual AptifyDataComboBox m_dcbStateProvince {get; set;}

See Also

TaxJurisdictionsLayout Class | Aptify.Applications.Accounting Namespace


m_lnkCountryID Property

Aptify 5.0 Software Development Kit (SDK)

TaxJurisdictionsLayout.m_lnkCountryID Property

protected virtual AptifyLinkBox m_lnkCountryID {get; set;}

See Also

TaxJurisdictionsLayout Class | Aptify.Applications.Accounting Namespace


TaxJurisdictionsLayout Methods

The methods of the TaxJurisdictionsLayout class are listed below. For a complete list of TaxJurisdictionsLayout class members, see the TaxJurisdictionsLayout Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControls |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCountryIDChanged |
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded | Contains logic to setup Event handlers for controls on the FormTemplate Layout.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControls |
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

TaxJurisdictionsLayout Class | Aptify.Applications.Accounting Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

TaxJurisdictionsLayout.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

TaxJurisdictionsLayout Class | Aptify.Applications.Accounting Namespace


TaxJurisdictionsLayout.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

TaxJurisdictionsLayout Class | Aptify.Applications.Accounting Namespace | TaxJurisdictionsLayout.Dispose Overload List


TaxJurisdictionsLayout.FindControls Method

protected void FindControls(
String FormTemplateLayoutName
);

See Also

TaxJurisdictionsLayout Class | Aptify.Applications.Accounting Namespace


TaxJurisdictionsLayout.OnCountryIDChanged Method

protected virtual void OnCountryIDChanged(
Object OldValue,
Object NewValue
);

See Also

TaxJurisdictionsLayout Class | Aptify.Applications.Accounting Namespace


TaxJurisdictionsLayout.OnFormTemplateLoaded Method

Contains logic to setup Event handlers for controls on the FormTemplate Layout.

protected override void OnFormTemplateLoaded(
FormTemplateLayout.FormTemplateLoadedEventArgs e
);

Parameters

e

Remarks

See Also

TaxJurisdictionsLayout Class | Aptify.Applications.Accounting Namespace


TaxJurisdictionsLayout.OnRefresh Method

protected override void OnRefresh();

Implements

IFormComponent.

See Also

TaxJurisdictionsLayout Class | Aptify.Applications.Accounting Namespace


TaxJurisdictionsLayout.SetControls Method

protected virtual void SetControls();

See Also

TaxJurisdictionsLayout Class | Aptify.Applications.Accounting Namespace


Aptify.Applications.Accounting.AP

Aptify 5.0 Software Development Kit (SDK)

Aptify.Applications.Accounting.AP Namespace

This namespace contains objects and interfaces that are used within the Aptify's Accounts Payable (AP) integration functionality. The Aptify AP integration functionality is used to communicate information between Aptify and the AP system of choice, such as when processing refunds.

Namespace hierarchy

Classes

Class | Description
APEngine | This class tracks information for a single AP vendor record and is used to pass information throughout the interfaces in the AP Integration engine. This class also provides a number of overridable methods which allow for a sub-class to override and alter the behavior of the base class functionality.
APGreatPlains | This class implements the integration(export/import) process for the Great Plains Dynamics AP file format.
APIntegrationBase | This class provides base functionality for implementation of an AP system driver. This class provides base functionality that must be overriden for DoExport and DoImport() methods in each driver.
APSystem | This class tracks information for a single AP system record and is used to cache information about the AP systems available.
APSystemCache |
APTransaction | This class tracks information for a single AP transaction and is used to pass information throughout the interfaces in the AP Integration engine.
APVendor | This class tracks information for a single AP vendor record and is used to pass information throughout the interfaces in the AP Integration engine.
ExportWizard | Aptify AP Export Wizard
ImportWizard | Aptify AP Import Wizard

Interfaces

Interface | Description
IAPEngine | This interface is provides functionality to interoperate with the AP Integration Engine, which in turn uses a driver model for actually communicating with the AP system in place.
IAPIntegration | This interface is implemented by each "Driver" class that will be plugged into the AP Integration system. A developer of an AP driver can either directly implement this interface for creating a plug-in driver, or alternatively sub-class the APIntegrationBase class which implements the interface.

Enumerations

Enumeration | Description
APTransaction.APPaymentType |


APEngine Class

This class tracks information for a single AP vendor record and is used to pass information throughout the interfaces in the AP Integration engine. This class also provides a number of overridable methods which allow for a sub-class to override and alter the behavior of the base class functionality.

For a list of all members of this type, see APEngine Members.

System.Object
APEngine

public class APEngine : IAPEngine

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Accounting.AP

Assembly: AptifyAPEngine (in AptifyAPEngine.dll)

See Also

APEngine Members | Aptify.Applications.Accounting.AP Namespace


APEngine Members

APEngine overview

Public Instance Constructors

APEngine Constructor Initializes a new instance of the APEngine class.

Public Instance Properties

Application
APSystemID
DataAction
Database

Public Instance Methods

Config |
DoExport | This method implements the DoExport() method of the IAPEngine interface. This method will perform the following steps as part of the process of handling the export of data from Aptify to the AP system in question 1) Create an AP Export Run Record 2) Instantiate and Execute the DoExport() function of the appropriate AP integration driver to use based on the APSystemID parameter passed to the Config() method of this class. 3) If #2 is succesful, then mark the status of the AP Export Run record as complete, otherwise mark it as having an error 4) Return either -1 or the Export Run ID (Export Run ID returned if success.)
DoImport | This method implements the DoImport() method in the IAPEngine interface and will be used to import back in information from an AP file and place it in the payment records. In addition, this process creates a new AP Import Runs record in the system
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

ImportExportDate Property used to set or retrieve the date/time the import or export activity is to be recorded. The default value is Now.

Protected Instance Methods

CheckUpdateAPVendorID | This method updates the APVendorID field in either Persons or Companies entity based on the provided parameters.
CreateVendorCollection | This method is responsible for creating a new collection of APVendor records that are distinct, FROM the list of transactions included above The KEY into the index of this dictionary will be ID_COID_PERID Where ID is a constant, COID is equal to the numeric ID number of the company record and PERID is equal to the numeric ID number of the person record
DoExportRun | This method handles the process of instantiating the appropriate driver for the AP System currently in use runs its DoExport() function subsequently, it updates the APExportRun GE record, as appropriate
DoImportRun | This method handles the actual import process by instantiating the correct AP driver based on the current AP system and calling the DoImport() method on that class. In addition, this method will update the ImportRun GE appropriately based on the result of the driver's DoImport() call.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAPDriver | This method is responsible for creating a new instance of the object that implements the IAPIntegration interface for the specified APSystemID. If APSystemID is not provided then the current AP System ID (as defined in the APSystemID property) is used.
GetRecordField | This method returns a single(scalar) value from a particular view in the database.
ImportTransactions | This method handles the process of importing the transactions that were loaded from the file by the appropriate AP driver.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PopulateVendorAddressPhone | This method will populate the Vendor object with the phone and address information for the vendor from the persons OR companies entity, depending on if the vendor type is Person or Company
UpdatePaymentExportRunID | This method is responsible for updating all of the payment records that were affected by the specified Export Run and set the APExportRunID in those payment records to the value provided in the APExportRun parameter of this method.
UpdatePaymentRecord | This method updates a single payment record in the Aptify database based on the provider parameters.

See Also

APEngine Class | Aptify.Applications.Accounting.AP Namespace


APEngine Constructor

Initializes a new instance of the APEngine class.

public APEngine();

See Also

APEngine Class | Aptify.Applications.Accounting.AP Namespace


APEngine Properties

The properties of the APEngine class are listed below. For a complete list of APEngine class members, see the APEngine Members topic.

Public Instance Properties

Application
APSystemID
DataAction
Database

Protected Instance Properties

ImportExportDate Property used to set or retrieve the date/time the import or export activity is to be recorded. The default value is Now.

See Also

APEngine Class | Aptify.Applications.Accounting.AP Namespace


Application Property

Aptify 5.0 Software Development Kit (SDK)

APEngine.Application Property

public virtual AptifyApplication Application {get;}

See Also

APEngine Class | Aptify.Applications.Accounting.AP Namespace


APSystemID Property

Aptify 5.0 Software Development Kit (SDK)

APEngine.APSystemID Property

public virtual Int64 APSystemID {get;}

See Also

APEngine Class | Aptify.Applications.Accounting.AP Namespace


DataAction Property

Aptify 5.0 Software Development Kit (SDK)

APEngine.DataAction Property

public virtual DataAction DataAction {get;}

See Also

APEngine Class | Aptify.Applications.Accounting.AP Namespace


Database Property

Aptify 5.0 Software Development Kit (SDK)

APEngine.Database Property

public virtual String Database {get;}

See Also

APEngine Class | Aptify.Applications.Accounting.AP Namespace


ImportExportDate Property

Aptify 5.0 Software Development Kit (SDK)

APEngine.ImportExportDate Property

Property used to set or retrieve the date/time the import or export activity is to be recorded. The default value is Now.

protected virtual DateTime ImportExportDate {get; set;}

Property Value

Remarks

See Also

APEngine Class | Aptify.Applications.Accounting.AP Namespace


APEngine Methods

The methods of the APEngine class are listed below. For a complete list of APEngine class members, see the APEngine Members topic.

Public Instance Methods

Config |
DoExport | This method implements the DoExport() method of the IAPEngine interface. This method will perform the following steps as part of the process of handling the export of data from Aptify to the AP system in question 1) Create an AP Export Run Record 2) Instantiate and Execute the DoExport() function of the appropriate AP integration driver to use based on the APSystemID parameter passed to the Config() method of this class. 3) If #2 is succesful, then mark the status of the AP Export Run record as complete, otherwise mark it as having an error 4) Return either -1 or the Export Run ID (Export Run ID returned if success.)
DoImport | This method implements the DoImport() method in the IAPEngine interface and will be used to import back in information from an AP file and place it in the payment records. In addition, this process creates a new AP Import Runs record in the system
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CheckUpdateAPVendorID | This method updates the APVendorID field in either Persons or Companies entity based on the provided parameters.
CreateVendorCollection | This method is responsible for creating a new collection of APVendor records that are distinct, FROM the list of transactions included above The KEY into the index of this dictionary will be ID_COID_PERID Where ID is a constant, COID is equal to the numeric ID number of the company record and PERID is equal to the numeric ID number of the person record
DoExportRun | This method handles the process of instantiating the appropriate driver for the AP System currently in use runs its DoExport() function subsequently, it updates the APExportRun GE record, as appropriate
DoImportRun | This method handles the actual import process by instantiating the correct AP driver based on the current AP system and calling the DoImport() method on that class. In addition, this method will update the ImportRun GE appropriately based on the result of the driver's DoImport() call.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAPDriver | This method is responsible for creating a new instance of the object that implements the IAPIntegration interface for the specified APSystemID. If APSystemID is not provided then the current AP System ID (as defined in the APSystemID property) is used.
GetRecordField | This method returns a single(scalar) value from a particular view in the database.
ImportTransactions | This method handles the process of importing the transactions that were loaded from the file by the appropriate AP driver.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PopulateVendorAddressPhone | This method will populate the Vendor object with the phone and address information for the vendor from the persons OR companies entity, depending on if the vendor type is Person or Company
UpdatePaymentExportRunID | This method is responsible for updating all of the payment records that were affected by the specified Export Run and set the APExportRunID in those payment records to the value provided in the APExportRun parameter of this method.
UpdatePaymentRecord | This method updates a single payment record in the Aptify database based on the provider parameters.

See Also

APEngine Class | Aptify.Applications.Accounting.AP Namespace


APEngine.CheckUpdateAPVendorID Method

This method updates the APVendorID field in either Persons or Companies entity based on the provided parameters.

protected virtual bool CheckUpdateAPVendorID(
APTransaction.APPaymentType Type,
Int64 RecordID,
String APVendorID
);

Parameters

Type
RecordID
APVendorID

Return Value

Remarks

See Also

APEngine Class | Aptify.Applications.Accounting.AP Namespace


APEngine.Config Method

public virtual bool Config(
AptifyApplication Application,
Int64 APSystemID
);

Implements

IAPEngine.

See Also

APEngine Class | Aptify.Applications.Accounting.AP Namespace


APEngine.CreateVendorCollection Method

This method is responsible for creating a new collection of APVendor records that are distinct, FROM the list of transactions included above The KEY into the index of this dictionary will be ID_COID_PERID Where ID is a constant, COID is equal to the numeric ID number of the company record and PERID is equal to the numeric ID number of the person record

protected virtual Dictionary<TKey,TValue> CreateVendorCollection(
List<T> Transactions
);

Parameters

Transactions

Return Value

Remarks

See Also

APEngine Class | Aptify.Applications.Accounting.AP Namespace


APEngine.DoExport Method

This method implements the DoExport() method of the IAPEngine interface. This method will perform the following steps as part of the process of handling the export of data from Aptify to the AP system in question 1) Create an AP Export Run Record 2) Instantiate and Execute the DoExport() function of the appropriate AP integration driver to use based on the APSystemID parameter passed to the Config() method of this class. 3) If #2 is succesful, then mark the status of the AP Export Run record as complete, otherwise mark it as having an error 4) Return either -1 or the Export Run ID (Export Run ID returned if success.)

public virtual long DoExport(
List<T> Transactions,
String ExportPath,
String Comments
);

Parameters

Transactions
ExportPath
Comments

Return Value

Implements

IAPEngine.

Remarks

See Also

APEngine Class | Aptify.Applications.Accounting.AP Namespace


APEngine.DoExportRun Method

This method handles the process of instantiating the appropriate driver for the AP System currently in use runs its DoExport() function subsequently, it updates the APExportRun GE record, as appropriate

protected virtual long DoExportRun(
AptifyGenericEntityBase APExportRun,
List<T> APTransactions,
String ExportPath
);

Parameters

APExportRun
APTransactions
ExportPath

Return Value

Remarks

See Also

APEngine Class | Aptify.Applications.Accounting.AP Namespace


APEngine.DoImport Method

This method implements the DoImport() method in the IAPEngine interface and will be used to import back in information from an AP file and place it in the payment records. In addition, this process creates a new AP Import Runs record in the system

public virtual long DoImport(
String ImportFile
);

Parameters

ImportFile

Return Value

Implements

IAPEngine.

Remarks

See Also

APEngine Class | Aptify.Applications.Accounting.AP Namespace


APEngine.DoImportRun Method

This method handles the actual import process by instantiating the correct AP driver based on the current AP system and calling the DoImport() method on that class. In addition, this method will update the ImportRun GE appropriately based on the result of the driver's DoImport() call.

protected virtual long DoImportRun(
AptifyGenericEntityBase ImportRun,
String ImportFile
);

Parameters

ImportRun
ImportFile

Return Value

Remarks

See Also

APEngine Class | Aptify.Applications.Accounting.AP Namespace


APEngine.GetAPDriver Method

This method is responsible for creating a new instance of the object that implements the IAPIntegration interface for the specified APSystemID. If APSystemID is not provided then the current AP System ID (as defined in the APSystemID property) is used.

protected virtual IAPIntegration GetAPDriver(
Int64 APSystemID
);

Return Value

Remarks

See Also

APEngine Class | Aptify.Applications.Accounting.AP Namespace


APEngine.GetRecordField Method

This method returns a single(scalar) value from a particular view in the database.

protected virtual object GetRecordField(
String ViewName,
String FieldName,
Int64 RecordID,
IAptifyDataAction.DSLCacheSetting CacheSetting
);

Parameters

ViewName
FieldName
RecordID
CacheSetting

Return Value

Remarks

See Also

APEngine Class | Aptify.Applications.Accounting.AP Namespace


APEngine.ImportTransactions Method

This method handles the process of importing the transactions that were loaded from the file by the appropriate AP driver.

protected virtual bool ImportTransactions(
Int64 APImportRunID,
List<T> APTransactions,
ref Decimal& AmountTotal,
ref Int64& PaymentCount
);

Parameters

APImportRunID
APTransactions
AmountTotal
PaymentCount

Return Value

Remarks

See Also

APEngine Class | Aptify.Applications.Accounting.AP Namespace


APEngine.PopulateVendorAddressPhone Method

This method will populate the Vendor object with the phone and address information for the vendor from the persons OR companies entity, depending on if the vendor type is Person or Company

protected virtual bool PopulateVendorAddressPhone(
APVendor Vendor,
APTransaction Transaction
);

Parameters

Vendor
Transaction

Return Value

Remarks

See Also

APEngine Class | Aptify.Applications.Accounting.AP Namespace


APEngine.UpdatePaymentExportRunID Method

This method is responsible for updating all of the payment records that were affected by the specified Export Run and set the APExportRunID in those payment records to the value provided in the APExportRun parameter of this method.

protected virtual bool UpdatePaymentExportRunID(
List<T> APTransactions,
Int64 APExportRunID,
ref Int64& PaymentCount,
ref Decimal& AmountTotal
);

Parameters

APTransactions
APExportRunID
PaymentCount
OUT Parameter: returns the total # of payment records updated in this method.
AmountTotal
OUT Parameter: returns the total amount of all payment records updated in this method.

Return Value

Remarks

See Also

APEngine Class | Aptify.Applications.Accounting.AP Namespace


APEngine.UpdatePaymentRecord Method

This method updates a single payment record in the Aptify database based on the provider parameters.

protected virtual bool UpdatePaymentRecord(
Int64 APImportRunID,
APTransaction Transaction,
ref Decimal& Amount
);

Parameters

APImportRunID
Transaction
Amount

Return Value

Remarks

See Also

APEngine Class | Aptify.Applications.Accounting.AP Namespace


APGreatPlains Class

This class implements the integration(export/import) process for the Great Plains Dynamics AP file format.

For a list of all members of this type, see APGreatPlains Members.

System.Object
APIntegrationBase
APGreatPlains

public class APGreatPlains : APIntegrationBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Accounting.AP

Assembly: AptifyAPGreatPlains (in AptifyAPGreatPlains.dll)

See Also

APGreatPlains Members | Aptify.Applications.Accounting.AP Namespace


APGreatPlains Members

APGreatPlains overview

Public Instance Constructors

APGreatPlains Constructor Initializes a new instance of the APGreatPlains class.

Public Instance Properties

Application (inherited from APIntegrationBase)
APSystemID (inherited from APIntegrationBase)
DataAction (inherited from APIntegrationBase)
Database (inherited from APIntegrationBase)

Public Instance Methods

Config (inherited from APIntegrationBase) |
DoExport | This method implements the Great Plains export for AP data. The method will call the CreateVendorFile() method first and subsequently call teh CreateTransactionFile() method. If bot methods are successful, True is returned, otherwise False is returned.
DoImport | The method is responsible for loading up a collection of records into the oAPTransactions collection that represent the data in the file sImportFile File Format has the following fields in this order: - Payment ID - Check Date - Check # - Name of Payee - GP Vendor ID - Company ID - PersonID -----------------------
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetRecordField (inherited from APIntegrationBase) | This method returns a single(scalar) value from a particular view in the database.
GetSQLValue (inherited from APIntegrationBase) | This method returns a single(scalar) value from the provided SQL statement
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CreateTransactionFile | This method will output a file with the following format. COMMA DELIMITED FILE FORMAT WITH The following field order: GP Vendor ID Amount Payment ID BEGIN: Added so that transaction file and vendor file can be matched up at GP AG Company ID Person ID END Description(Refund Reason) GL Sales Account Previously Used ??? Export Date List ID - This is the AP Export Run ID
CreateVendorFile | This method will output a file to the ExportPath and will use the following comma delimited file format FIELD ORDER: GP Vendor ID Name of Payee (Person or Company) Address Line 1 Address Line 2 City State Zip Code Country Phone Number Company ID Person ID
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

APGreatPlains Class | Aptify.Applications.Accounting.AP Namespace


APGreatPlains Constructor

Initializes a new instance of the APGreatPlains class.

public APGreatPlains();

See Also

APGreatPlains Class | Aptify.Applications.Accounting.AP Namespace


APGreatPlains Methods

The methods of the APGreatPlains class are listed below. For a complete list of APGreatPlains class members, see the APGreatPlains Members topic.

Public Instance Methods

Config (inherited from APIntegrationBase) |
DoExport | This method implements the Great Plains export for AP data. The method will call the CreateVendorFile() method first and subsequently call teh CreateTransactionFile() method. If bot methods are successful, True is returned, otherwise False is returned.
DoImport | The method is responsible for loading up a collection of records into the oAPTransactions collection that represent the data in the file sImportFile File Format has the following fields in this order: - Payment ID - Check Date - Check # - Name of Payee - GP Vendor ID - Company ID - PersonID -----------------------
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetRecordField (inherited from APIntegrationBase) | This method returns a single(scalar) value from a particular view in the database.
GetSQLValue (inherited from APIntegrationBase) | This method returns a single(scalar) value from the provided SQL statement
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CreateTransactionFile | This method will output a file with the following format. COMMA DELIMITED FILE FORMAT WITH The following field order: GP Vendor ID Amount Payment ID BEGIN: Added so that transaction file and vendor file can be matched up at GP AG Company ID Person ID END Description(Refund Reason) GL Sales Account Previously Used ??? Export Date List ID - This is the AP Export Run ID
CreateVendorFile | This method will output a file to the ExportPath and will use the following comma delimited file format FIELD ORDER: GP Vendor ID Name of Payee (Person or Company) Address Line 1 Address Line 2 City State Zip Code Country Phone Number Company ID Person ID
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

APGreatPlains Class | Aptify.Applications.Accounting.AP Namespace


APGreatPlains.CreateTransactionFile Method

This method will output a file with the following format. COMMA DELIMITED FILE FORMAT WITH The following field order: GP Vendor ID Amount Payment ID BEGIN: Added so that transaction file and vendor file can be matched up at GP AG Company ID Person ID END Description(Refund Reason) GL Sales Account Previously Used ??? Export Date List ID - This is the AP Export Run ID

protected virtual bool CreateTransactionFile(
Int64 ExportRunID,
List<T> APTransactions,
String ExportPath,
ref String& TransactionFileExportedTo
);

Parameters

ExportRunID
APTransactions
ExportPath
TransactionFileExportedTo

Return Value

Remarks

See Also

APGreatPlains Class | Aptify.Applications.Accounting.AP Namespace


APGreatPlains.CreateVendorFile Method

This method will output a file to the ExportPath and will use the following comma delimited file format FIELD ORDER: GP Vendor ID Name of Payee (Person or Company) Address Line 1 Address Line 2 City State Zip Code Country Phone Number Company ID Person ID

protected virtual bool CreateVendorFile(
Int64 ExportRunID,
Dictionary<TKey,TValue> APVendors,
String ExportPath,
ref String& VendorFileExportedTo
);

Parameters

ExportRunID
APVendors
ExportPath
VendorFileExportedTo

Return Value

Remarks

See Also

APGreatPlains Class | Aptify.Applications.Accounting.AP Namespace


APGreatPlains.DoExport Method

This method implements the Great Plains export for AP data. The method will call the CreateVendorFile() method first and subsequently call teh CreateTransactionFile() method. If bot methods are successful, True is returned, otherwise False is returned.

public override bool DoExport(
Int64 ExportRunID,
Dictionary<TKey,TValue> APVendors,
List<T> APTransactions,
String ExportPath,
ref String& VendorFileExportedTo,
ref String& TransactionFileExportedTo
);

Parameters

ExportRunID
APVendors
APTransactions
ExportPath
VendorFileExportedTo
TransactionFileExportedTo

Return Value

Implements

IAPIntegration.

Remarks

See Also

APGreatPlains Class | Aptify.Applications.Accounting.AP Namespace


APGreatPlains.DoImport Method

The method is responsible for loading up a collection of records into the oAPTransactions collection that represent the data in the file sImportFile File Format has the following fields in this order: - Payment ID - Check Date - Check # - Name of Payee - GP Vendor ID - Company ID - PersonID -----------------------

public override bool DoImport(
Int64 ImportRunID,
String ImportFile,
List<T> APTransactions
);

Parameters

ImportRunID
ImportFile
APTransactions

Return Value

Implements

IAPIntegration.

Remarks

See Also

APGreatPlains Class | Aptify.Applications.Accounting.AP Namespace


APIntegrationBase Class

This class provides base functionality for implementation of an AP system driver. This class provides base functionality that must be overriden for DoExport and DoImport() methods in each driver.

For a list of all members of this type, see APIntegrationBase Members.

System.Object
APIntegrationBase
APGreatPlains

public class APIntegrationBase : IAPIntegration

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Accounting.AP

Assembly: IAptifyAP (in IAptifyAP.dll)

See Also

APIntegrationBase Members | Aptify.Applications.Accounting.AP Namespace


APIntegrationBase Members

APIntegrationBase overview

Public Instance Constructors

APIntegrationBase Constructor Initializes a new instance of the APIntegrationBase class.

Public Instance Properties

Application
APSystemID
DataAction
Database

Public Instance Methods

Config |
DoExport | This method implements DoExport() in the IAPIntegration interface and must be overriden in sub-classes
DoImport | This method implements DoImport() in the IAPIntegration interface and must be overriden in subclasses
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetRecordField | This method returns a single(scalar) value from a particular view in the database.
GetSQLValue | This method returns a single(scalar) value from the provided SQL statement
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

APIntegrationBase Class | Aptify.Applications.Accounting.AP Namespace


APIntegrationBase Constructor

Initializes a new instance of the APIntegrationBase class.

public APIntegrationBase();

See Also

APIntegrationBase Class | Aptify.Applications.Accounting.AP Namespace


APIntegrationBase Properties

The properties of the APIntegrationBase class are listed below. For a complete list of APIntegrationBase class members, see the APIntegrationBase Members topic.

Public Instance Properties

Application
APSystemID
DataAction
Database

See Also

APIntegrationBase Class | Aptify.Applications.Accounting.AP Namespace


Application Property

Aptify 5.0 Software Development Kit (SDK)

APIntegrationBase.Application Property

public virtual AptifyApplication Application {get;}

See Also

APIntegrationBase Class | Aptify.Applications.Accounting.AP Namespace


APSystemID Property

Aptify 5.0 Software Development Kit (SDK)

APIntegrationBase.APSystemID Property

public virtual Int64 APSystemID {get;}

See Also

APIntegrationBase Class | Aptify.Applications.Accounting.AP Namespace


DataAction Property

Aptify 5.0 Software Development Kit (SDK)

APIntegrationBase.DataAction Property

public virtual DataAction DataAction {get;}

See Also

APIntegrationBase Class | Aptify.Applications.Accounting.AP Namespace


Database Property

Aptify 5.0 Software Development Kit (SDK)

APIntegrationBase.Database Property

public virtual String Database {get;}

See Also

APIntegrationBase Class | Aptify.Applications.Accounting.AP Namespace


APIntegrationBase Methods

The methods of the APIntegrationBase class are listed below. For a complete list of APIntegrationBase class members, see the APIntegrationBase Members topic.

Public Instance Methods

Config |
DoExport | This method implements DoExport() in the IAPIntegration interface and must be overriden in sub-classes
DoImport | This method implements DoImport() in the IAPIntegration interface and must be overriden in subclasses
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetRecordField | This method returns a single(scalar) value from a particular view in the database.
GetSQLValue | This method returns a single(scalar) value from the provided SQL statement
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

APIntegrationBase Class | Aptify.Applications.Accounting.AP Namespace


APIntegrationBase.Config Method

public virtual bool Config(
AptifyApplication Application,
Int64 APSystemID
);

Implements

IAPIntegration.

See Also

APIntegrationBase Class | Aptify.Applications.Accounting.AP Namespace


APIntegrationBase.DoExport Method

This method implements DoExport() in the IAPIntegration interface and must be overriden in sub-classes

public abstract bool DoExport(
Int64 ExportRunID,
Dictionary<TKey,TValue> APVendors,
List<T> APTransactions,
String ExportPath,
ref String& VendorFileExportedTo,
ref String& TransactionFileExportedTo
);

Parameters

ExportRunID
APVendors
APTransactions
ExportPath
VendorFileExportedTo
TransactionFileExportedTo

Return Value

Implements

IAPIntegration.

Remarks

See Also

APIntegrationBase Class | Aptify.Applications.Accounting.AP Namespace


APIntegrationBase.DoImport Method

This method implements DoImport() in the IAPIntegration interface and must be overriden in subclasses

public abstract bool DoImport(
Int64 ImportRunID,
String ImportFile,
List<T> APTransactions
);

Parameters

ImportRunID
ImportFile
APTransactions

Return Value

Implements

IAPIntegration.

Remarks

See Also

APIntegrationBase Class | Aptify.Applications.Accounting.AP Namespace


APIntegrationBase.GetRecordField Method

This method returns a single(scalar) value from a particular view in the database.

public virtual object GetRecordField(
String ViewName,
String FieldName,
Int64 RecordID,
IAptifyDataAction.DSLCacheSetting CacheSetting
);

Parameters

ViewName
FieldName
RecordID
CacheSetting

Return Value

Remarks

See Also

APIntegrationBase Class | Aptify.Applications.Accounting.AP Namespace


APIntegrationBase.GetSQLValue Method

This method returns a single(scalar) value from the provided SQL statement

public virtual object GetSQLValue(
String SQL,
IAptifyDataAction.DSLCacheSetting CacheSetting
);

Parameters

SQL
CacheSetting

Return Value

Remarks

See Also

APIntegrationBase Class | Aptify.Applications.Accounting.AP Namespace


APSystem Class

This class tracks information for a single AP system record and is used to cache information about the AP systems available.

For a list of all members of this type, see APSystem Members.

System.Object
APSystem

public class APSystem

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Accounting.AP

Assembly: IAptifyAP (in IAptifyAP.dll)

See Also

APSystem Members | Aptify.Applications.Accounting.AP Namespace


APSystem Members

APSystem overview

Public Instance Constructors

APSystem Constructor This class is instantiated by passing a Datarow that contains a row from the AP Systems entity base view that is then used to populate the values in this class

Public Instance Properties

AllowExportPathOverride
AllowImportPathOverride
Assembly
Class
ExportPathDefault
ID
ImportFileAction
ImportPathDefault
Name
Object

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

APSystem Class | Aptify.Applications.Accounting.AP Namespace


APSystem Constructor

This class is instantiated by passing a Datarow that contains a row from the AP Systems entity base view that is then used to populate the values in this class

public APSystem(
DataRow dr
);

Parameters

dr

Remarks

See Also

APSystem Class | Aptify.Applications.Accounting.AP Namespace


APSystem Properties

The properties of the APSystem class are listed below. For a complete list of APSystem class members, see the APSystem Members topic.

Public Instance Properties

AllowExportPathOverride
AllowImportPathOverride
Assembly
Class
ExportPathDefault
ID
ImportFileAction
ImportPathDefault
Name
Object

See Also

APSystem Class | Aptify.Applications.Accounting.AP Namespace


AllowExportPathOverride Property

Aptify 5.0 Software Development Kit (SDK)

APSystem.AllowExportPathOverride Property

public virtual Boolean AllowExportPathOverride {get;}

See Also

APSystem Class | Aptify.Applications.Accounting.AP Namespace


AllowImportPathOverride Property

Aptify 5.0 Software Development Kit (SDK)

APSystem.AllowImportPathOverride Property

public virtual Boolean AllowImportPathOverride {get;}

See Also

APSystem Class | Aptify.Applications.Accounting.AP Namespace


Assembly Property

Aptify 5.0 Software Development Kit (SDK)

APSystem.Assembly Property

public virtual String Assembly {get;}

See Also

APSystem Class | Aptify.Applications.Accounting.AP Namespace


Class Property

Aptify 5.0 Software Development Kit (SDK)

APSystem.Class Property

public virtual String Class {get;}

See Also

APSystem Class | Aptify.Applications.Accounting.AP Namespace


ExportPathDefault Property

Aptify 5.0 Software Development Kit (SDK)

APSystem.ExportPathDefault Property

public virtual String ExportPathDefault {get;}

See Also

APSystem Class | Aptify.Applications.Accounting.AP Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

APSystem.ID Property

public virtual Int64 ID {get;}

See Also

APSystem Class | Aptify.Applications.Accounting.AP Namespace


ImportFileAction Property

Aptify 5.0 Software Development Kit (SDK)

APSystem.ImportFileAction Property

public virtual String ImportFileAction {get;}

See Also

APSystem Class | Aptify.Applications.Accounting.AP Namespace


ImportPathDefault Property

Aptify 5.0 Software Development Kit (SDK)

APSystem.ImportPathDefault Property

public virtual String ImportPathDefault {get;}

See Also

APSystem Class | Aptify.Applications.Accounting.AP Namespace


Name Property

Aptify 5.0 Software Development Kit (SDK)

APSystem.Name Property

public virtual String Name {get;}

See Also

APSystem Class | Aptify.Applications.Accounting.AP Namespace


Object Property

Aptify 5.0 Software Development Kit (SDK)

APSystem.Object Property

public virtual String Object {get;}

See Also

APSystem Class | Aptify.Applications.Accounting.AP Namespace


APSystemCache Class

For a list of all members of this type, see APSystemCache Members.

System.Object
APSystemCache

public class APSystemCache

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Accounting.AP

Assembly: IAptifyAP (in IAptifyAP.dll)

See Also

APSystemCache Members | Aptify.Applications.Accounting.AP Namespace


APSystemCache Members

APSystemCache overview

Public Static Properties

APSystems

Public Instance Constructors

APSystemCache Constructor Initializes a new instance of the APSystemCache class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

APSystemCache Class | Aptify.Applications.Accounting.AP Namespace


APSystemCache Constructor

Initializes a new instance of the APSystemCache class.

public APSystemCache();

See Also

APSystemCache Class | Aptify.Applications.Accounting.AP Namespace


APSystemCache Properties

The properties of the APSystemCache class are listed below. For a complete list of APSystemCache class members, see the APSystemCache Members topic.

Public Static Properties

APSystems

See Also

APSystemCache Class | Aptify.Applications.Accounting.AP Namespace


APSystems Property

Aptify 5.0 Software Development Kit (SDK)

APSystemCache.APSystems Property

public static List<T> this[
AptifyApplication Application,
Boolean Refresh
] {get;}

See Also

APSystemCache Class | Aptify.Applications.Accounting.AP Namespace


APTransaction Class

This class tracks information for a single AP transaction and is used to pass information throughout the interfaces in the AP Integration engine.

For a list of all members of this type, see APTransaction Members.

System.Object
APTransaction

public class APTransaction

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Accounting.AP

Assembly: IAptifyAP (in IAptifyAP.dll)

See Also

APTransaction Members | Aptify.Applications.Accounting.AP Namespace


APTransaction Members

APTransaction overview

Public Instance Constructors

APTransaction Constructor Initializes a new instance of the APTransaction class.

Public Instance Fields

Amount
APVendorID
CheckDate
CheckNumber
CheckPayee
CompanyID
CompanyName
FirstName
LastName
PaymentID
PaymentReason
PersonID
Type

Public Instance Properties

RefundReason Maintained for code-level backwards compatibility - new member Payment Reason should be used going forward

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

APTransaction Class | Aptify.Applications.Accounting.AP Namespace


APTransaction Constructor

Initializes a new instance of the APTransaction class.

public APTransaction();

See Also

APTransaction Class | Aptify.Applications.Accounting.AP Namespace


APTransaction Fields

The fields of the APTransaction class are listed below. For a complete list of APTransaction class members, see the APTransaction Members topic.

Public Instance Fields

Amount
APVendorID
CheckDate
CheckNumber
CheckPayee
CompanyID
CompanyName
FirstName
LastName
PaymentID
PaymentReason
PersonID
Type

See Also

APTransaction Class | Aptify.Applications.Accounting.AP Namespace


APTransaction.Amount Field

public Amount Amount;

See Also

APTransaction Class | Aptify.Applications.Accounting.AP Namespace


APTransaction.APVendorID Field

public APVendorID APVendorID;

See Also

APTransaction Class | Aptify.Applications.Accounting.AP Namespace


APTransaction.CheckDate Field

public CheckDate CheckDate;

See Also

APTransaction Class | Aptify.Applications.Accounting.AP Namespace


APTransaction.CheckNumber Field

public CheckNumber CheckNumber;

See Also

APTransaction Class | Aptify.Applications.Accounting.AP Namespace


APTransaction.CheckPayee Field

public CheckPayee CheckPayee;

See Also

APTransaction Class | Aptify.Applications.Accounting.AP Namespace


APTransaction.CompanyID Field

public CompanyID CompanyID;

See Also

APTransaction Class | Aptify.Applications.Accounting.AP Namespace


APTransaction.CompanyName Field

public CompanyName CompanyName;

See Also

APTransaction Class | Aptify.Applications.Accounting.AP Namespace


APTransaction.FirstName Field

public FirstName FirstName;

See Also

APTransaction Class | Aptify.Applications.Accounting.AP Namespace


APTransaction.LastName Field

public LastName LastName;

See Also

APTransaction Class | Aptify.Applications.Accounting.AP Namespace


APTransaction.PaymentID Field

public PaymentID PaymentID;

See Also

APTransaction Class | Aptify.Applications.Accounting.AP Namespace


APTransaction.PaymentReason Field

public PaymentReason PaymentReason;

See Also

APTransaction Class | Aptify.Applications.Accounting.AP Namespace


APTransaction.PersonID Field

public PersonID PersonID;

See Also

APTransaction Class | Aptify.Applications.Accounting.AP Namespace


APTransaction.Type Field

public Type Type;

See Also

APTransaction Class | Aptify.Applications.Accounting.AP Namespace


APTransaction Properties

The properties of the APTransaction class are listed below. For a complete list of APTransaction class members, see the APTransaction Members topic.

Public Instance Properties

RefundReason Maintained for code-level backwards compatibility - new member Payment Reason should be used going forward

See Also

APTransaction Class | Aptify.Applications.Accounting.AP Namespace


RefundReason Property

Aptify 5.0 Software Development Kit (SDK)

APTransaction.RefundReason Property

Maintained for code-level backwards compatibility - new member Payment Reason should be used going forward

public String RefundReason {get; set;}

Remarks

See Also

APTransaction Class | Aptify.Applications.Accounting.AP Namespace


APTransaction.APPaymentType Enumeration

public enum APTransaction.APPaymentType

Members

Member Name | Description
Individual |
Company |

Requirements

Namespace: Aptify.Applications.Accounting.AP

Assembly: IAptifyAP (in IAptifyAP.dll)

See Also

Aptify.Applications.Accounting.AP Namespace


APVendor Class

This class tracks information for a single AP vendor record and is used to pass information throughout the interfaces in the AP Integration engine.

For a list of all members of this type, see APVendor Members.

System.Object
APVendor

public class APVendor

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Accounting.AP

Assembly: IAptifyAP (in IAptifyAP.dll)

See Also

APVendor Members | Aptify.Applications.Accounting.AP Namespace


APVendor Members

APVendor overview

Public Instance Constructors

APVendor Constructor

Public Instance Fields

APVendorID
CompanyID
CompanyName
FirstName
LastName
MiddleName
PayeeName
PersonID
PhoneNumber

Public Instance Properties

Address |
AddressLine1 |
AddressLine2 |
AddressLine3 |
AddressLine4 |
Application |
City |
Country |
County |
PostalCode |
State | Maintained for backwards compatibility - use StateProvince
StateProvince |
ZipCode | Maintained for code-level backwards compatibility - maps to the PostalCode property.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

APVendor Class | Aptify.Applications.Accounting.AP Namespace


APVendor Constructor

public APVendor(
AptifyApplication Application
);

See Also

APVendor Class | Aptify.Applications.Accounting.AP Namespace


APVendor Fields

The fields of the APVendor class are listed below. For a complete list of APVendor class members, see the APVendor Members topic.

Public Instance Fields

APVendorID
CompanyID
CompanyName
FirstName
LastName
MiddleName
PayeeName
PersonID
PhoneNumber

See Also

APVendor Class | Aptify.Applications.Accounting.AP Namespace


APVendor.APVendorID Field

public APVendorID APVendorID;

See Also

APVendor Class | Aptify.Applications.Accounting.AP Namespace


APVendor.CompanyID Field

public CompanyID CompanyID;

See Also

APVendor Class | Aptify.Applications.Accounting.AP Namespace


APVendor.CompanyName Field

public CompanyName CompanyName;

See Also

APVendor Class | Aptify.Applications.Accounting.AP Namespace


APVendor.FirstName Field

public FirstName FirstName;

See Also

APVendor Class | Aptify.Applications.Accounting.AP Namespace


APVendor.LastName Field

public LastName LastName;

See Also

APVendor Class | Aptify.Applications.Accounting.AP Namespace


APVendor.MiddleName Field

public MiddleName MiddleName;

See Also

APVendor Class | Aptify.Applications.Accounting.AP Namespace


APVendor.PayeeName Field

public PayeeName PayeeName;

See Also

APVendor Class | Aptify.Applications.Accounting.AP Namespace


APVendor.PersonID Field

public PersonID PersonID;

See Also

APVendor Class | Aptify.Applications.Accounting.AP Namespace


APVendor.PhoneNumber Field

public PhoneNumber PhoneNumber;

See Also

APVendor Class | Aptify.Applications.Accounting.AP Namespace


APVendor Properties

The properties of the APVendor class are listed below. For a complete list of APVendor class members, see the APVendor Members topic.

Public Instance Properties

Address |
AddressLine1 |
AddressLine2 |
AddressLine3 |
AddressLine4 |
Application |
City |
Country |
County |
PostalCode |
State | Maintained for backwards compatibility - use StateProvince
StateProvince |
ZipCode | Maintained for code-level backwards compatibility - maps to the PostalCode property.

See Also

APVendor Class | Aptify.Applications.Accounting.AP Namespace


Address Property

Aptify 5.0 Software Development Kit (SDK)

APVendor.Address Property

public virtual AddressInfo Address {get;}

See Also

APVendor Class | Aptify.Applications.Accounting.AP Namespace


AddressLine1 Property

Aptify 5.0 Software Development Kit (SDK)

APVendor.AddressLine1 Property

public virtual String AddressLine1 {get; set;}

See Also

APVendor Class | Aptify.Applications.Accounting.AP Namespace


AddressLine2 Property

Aptify 5.0 Software Development Kit (SDK)

APVendor.AddressLine2 Property

public virtual String AddressLine2 {get; set;}

See Also

APVendor Class | Aptify.Applications.Accounting.AP Namespace


AddressLine3 Property

Aptify 5.0 Software Development Kit (SDK)

APVendor.AddressLine3 Property

public virtual String AddressLine3 {get; set;}

See Also

APVendor Class | Aptify.Applications.Accounting.AP Namespace


AddressLine4 Property

Aptify 5.0 Software Development Kit (SDK)

APVendor.AddressLine4 Property

public virtual String AddressLine4 {get; set;}

See Also

APVendor Class | Aptify.Applications.Accounting.AP Namespace


Application Property

Aptify 5.0 Software Development Kit (SDK)

APVendor.Application Property

public virtual AptifyApplication Application {get;}

See Also

APVendor Class | Aptify.Applications.Accounting.AP Namespace


City Property

Aptify 5.0 Software Development Kit (SDK)

APVendor.City Property

public virtual String City {get; set;}

See Also

APVendor Class | Aptify.Applications.Accounting.AP Namespace


Country Property

Aptify 5.0 Software Development Kit (SDK)

APVendor.Country Property

public virtual String Country {get; set;}

See Also

APVendor Class | Aptify.Applications.Accounting.AP Namespace


County Property

Aptify 5.0 Software Development Kit (SDK)

APVendor.County Property

public virtual String County {get; set;}

See Also

APVendor Class | Aptify.Applications.Accounting.AP Namespace


PostalCode Property

Aptify 5.0 Software Development Kit (SDK)

APVendor.PostalCode Property

public virtual String PostalCode {get; set;}

See Also

APVendor Class | Aptify.Applications.Accounting.AP Namespace


State Property

Aptify 5.0 Software Development Kit (SDK)

APVendor.State Property

Maintained for backwards compatibility - use StateProvince

public virtual String State {get; set;}

Property Value

Remarks

See Also

APVendor Class | Aptify.Applications.Accounting.AP Namespace


StateProvince Property

Aptify 5.0 Software Development Kit (SDK)

APVendor.StateProvince Property

public virtual String StateProvince {get; set;}

See Also

APVendor Class | Aptify.Applications.Accounting.AP Namespace


ZipCode Property

Aptify 5.0 Software Development Kit (SDK)

APVendor.ZipCode Property

Maintained for code-level backwards compatibility - maps to the PostalCode property.

public virtual String ZipCode {get; set;}

Property Value

Remarks

See Also

APVendor Class | Aptify.Applications.Accounting.AP Namespace


ExportWizard Class

Aptify AP Export Wizard

For a list of all members of this type, see ExportWizard Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
ExportWizard

public class ExportWizard : Form, IAptifyAction

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Accounting.AP

Assembly: AptifyAPWizards (in AptifyAPWizards.dll)

See Also

ExportWizard Members | Aptify.Applications.Accounting.AP Namespace


ExportWizard Members

ExportWizard overview

Public Instance Constructors

ExportWizard Constructor Initializes a new instance of the ExportWizard class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoAction | Overloaded.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
PopulateAPTransactions |
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ExportWizard Class | Aptify.Applications.Accounting.AP Namespace


ExportWizard Constructor

Initializes a new instance of the ExportWizard class.

public ExportWizard();

See Also

ExportWizard Class | Aptify.Applications.Accounting.AP Namespace


ExportWizard Methods

The methods of the ExportWizard class are listed below. For a complete list of ExportWizard class members, see the ExportWizard Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoAction | Overloaded.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
PopulateAPTransactions |
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ExportWizard Class | Aptify.Applications.Accounting.AP Namespace


ExportWizard.ApplySkin Method

protected virtual void ApplySkin();

See Also

ExportWizard Class | Aptify.Applications.Accounting.AP Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

ExportWizard.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

ExportWizard Class | Aptify.Applications.Accounting.AP Namespace


ExportWizard.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

ExportWizard Class | Aptify.Applications.Accounting.AP Namespace | ExportWizard.Dispose Overload List


DoAction Method

Aptify 5.0 Software Development Kit (SDK)

ExportWizard.DoAction Method

Overload List

public void DoAction(AptifyApplication,Int64);

public void DoAction(AptifyApplication,Int64,Int64);

public void DoAction(AptifyApplication,Int64,Int64,params Object[]);

public void DoAction(AptifyApplication,Int64,params String[]);

See Also

ExportWizard Class | Aptify.Applications.Accounting.AP Namespace


ExportWizard.DoAction Method (AptifyApplication, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID
);

Implements

IAptifyAction.

See Also

ExportWizard Class | Aptify.Applications.Accounting.AP Namespace | ExportWizard.DoAction Overload List


ExportWizard.DoAction Method (AptifyApplication, Int64, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID
);

Implements

IAptifyAction.

See Also

ExportWizard Class | Aptify.Applications.Accounting.AP Namespace | ExportWizard.DoAction Overload List


ExportWizard.DoAction Method (AptifyApplication, Int64, Int64, Object[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID,
params Object[] SelectedItems
);

Implements

IAptifyAction.

See Also

ExportWizard Class | Aptify.Applications.Accounting.AP Namespace | ExportWizard.DoAction Overload List


ExportWizard.DoAction Method (AptifyApplication, Int64, String[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
params String[] SelectedItems
);

Implements

IAptifyAction.

See Also

ExportWizard Class | Aptify.Applications.Accounting.AP Namespace | ExportWizard.DoAction Overload List


ExportWizard.PopulateAPTransactions Method

protected virtual bool PopulateAPTransactions();

See Also

ExportWizard Class | Aptify.Applications.Accounting.AP Namespace


IAPEngine Interface

This interface is provides functionality to interoperate with the AP Integration Engine, which in turn uses a driver model for actually communicating with the AP system in place.

For a list of all members of this type, see IAPEngine Members.

public interface IAPEngine

Types that implement IAPEngine

Type | Description
APEngine | This class tracks information for a single AP vendor record and is used to pass information throughout the interfaces in the AP Integration engine. This class also provides a number of overridable methods which allow for a sub-class to override and alter the behavior of the base class functionality.

Remarks

Requirements

Namespace: Aptify.Applications.Accounting.AP

Assembly: IAptifyAP (in IAptifyAP.dll)

See Also

IAPEngine Members | Aptify.Applications.Accounting.AP Namespace


IAPEngine Members

IAPEngine overview

Public Instance Methods

Config | This method must be called before any other member of the class is accessed.
DoExport | This method will create an AP Export Run record and process the transactions provided creating a file at the path specified. This method in the engine will utilize the appropriate driver class based on the APSystem used in the Config() method.
DoImport | Imports the specified file and creates an AP Import Run record in the Aptify database.

See Also

IAPEngine Interface | Aptify.Applications.Accounting.AP Namespace


IAPEngine Methods

The methods of the IAPEngine interface are listed below. For a complete list of IAPEngine interface members, see the IAPEngine Members topic.

Public Instance Methods

Config | This method must be called before any other member of the class is accessed.
DoExport | This method will create an AP Export Run record and process the transactions provided creating a file at the path specified. This method in the engine will utilize the appropriate driver class based on the APSystem used in the Config() method.
DoImport | Imports the specified file and creates an AP Import Run record in the Aptify database.

See Also

IAPEngine Interface | Aptify.Applications.Accounting.AP Namespace


IAPEngine.Config Method

This method must be called before any other member of the class is accessed.

bool Config(
AptifyApplication Application,
Int64 APSystemID
);

Parameters

Application
Aptify Application object
APSystemID
Aptify AP System Record ID # that will be used with this instance of the engine

Return Value

Remarks

See Also

IAPEngine Interface | Aptify.Applications.Accounting.AP Namespace


IAPEngine.DoExport Method

This method will create an AP Export Run record and process the transactions provided creating a file at the path specified. This method in the engine will utilize the appropriate driver class based on the APSystem used in the Config() method.

long DoExport(
List<T> Transactions,
String ExportPath,
String Comments
);

Parameters

Transactions
List of the AP Transactions that will be exported from the Aptify Payments entity to the AP system configured in the Config() method.
ExportPath
File name (including fully qualified path) to export the information to. For drivers that process direct exports to the AP system database, the ExportPath information maybe used for other purposes such as passing credentials for the AP system database.
Comments
Comments to be passed along to the file format by the export driver, if the export format allows comments

Return Value

If successful, returns the AP Export Run ID to the caller. If this is not succesful, it will return -1

Remarks

See Also

IAPEngine Interface | Aptify.Applications.Accounting.AP Namespace


IAPEngine.DoImport Method

Imports the specified file and creates an AP Import Run record in the Aptify database.

long DoImport(
String ImportFile
);

Parameters

ImportFile
File location(including full path) to import from. For AP Systems that do not use files and have direct integration at the database level, this parameter may be used for login credentials and/or other information as needed by the specified driver.

Return Value

Record ID for the AP Import Run, if the method succeeds. If the method fails, -1 is returned.

Remarks

See Also

IAPEngine Interface | Aptify.Applications.Accounting.AP Namespace


IAPIntegration Interface

This interface is implemented by each "Driver" class that will be plugged into the AP Integration system. A developer of an AP driver can either directly implement this interface for creating a plug-in driver, or alternatively sub-class the APIntegrationBase class which implements the interface.

For a list of all members of this type, see IAPIntegration Members.

public interface IAPIntegration

Types that implement IAPIntegration

Type | Description
APGreatPlains | This class implements the integration(export/import) process for the Great Plains Dynamics AP file format.
APIntegrationBase | This class provides base functionality for implementation of an AP system driver. This class provides base functionality that must be overriden for DoExport and DoImport() methods in each driver.

Remarks

Requirements

Namespace: Aptify.Applications.Accounting.AP

Assembly: IAptifyAP (in IAptifyAP.dll)

See Also

IAPIntegration Members | Aptify.Applications.Accounting.AP Namespace


IAPIntegration Members

IAPIntegration overview

Public Instance Methods

Config | This method must be called before any other member of the interface is accessed
DoExport | This method will export the provided vendor and transaction information returning True if the process succeeded and False otherwise.
DoImport | This method will import data from the specified ImportFile and populate the APCollections parameter with the data from the file. The purpose of this method is to populate the collection which in turn is imported into the database by the AP Engine.

See Also

IAPIntegration Interface | Aptify.Applications.Accounting.AP Namespace


IAPIntegration Methods

The methods of the IAPIntegration interface are listed below. For a complete list of IAPIntegration interface members, see the IAPIntegration Members topic.

Public Instance Methods

Config | This method must be called before any other member of the interface is accessed
DoExport | This method will export the provided vendor and transaction information returning True if the process succeeded and False otherwise.
DoImport | This method will import data from the specified ImportFile and populate the APCollections parameter with the data from the file. The purpose of this method is to populate the collection which in turn is imported into the database by the AP Engine.

See Also

IAPIntegration Interface | Aptify.Applications.Accounting.AP Namespace


IAPIntegration.Config Method

This method must be called before any other member of the interface is accessed

bool Config(
AptifyApplication Application,
Int64 APSystemID
);

Parameters

Application
APSystemID

Return Value

Remarks

See Also

IAPIntegration Interface | Aptify.Applications.Accounting.AP Namespace


IAPIntegration.DoExport Method

This method will export the provided vendor and transaction information returning True if the process succeeded and False otherwise.

bool DoExport(
Int64 ExportRunID,
Dictionary<TKey,TValue> APVendors,
List<T> APTransactions,
String ExportPath,
ref String& VendorFileExportedTo,
ref String& TransactionFileExportedTo
);

Parameters

ExportRunID
The AP Export Run record ID created by the AP Engine prior to this method being called
APVendors
APTransactions
ExportPath
Path to export the file to
VendorFileExportedTo
OUT Parameter: Returns the name of the file the vendor data was exported to.
TransactionFileExportedTo
OUT Parameter: Returns the name of the file the transaction data was exported to.

Return Value

Remarks

See Also

IAPIntegration Interface | Aptify.Applications.Accounting.AP Namespace


IAPIntegration.DoImport Method

This method will import data from the specified ImportFile and populate the APCollections parameter with the data from the file. The purpose of this method is to populate the collection which in turn is imported into the database by the AP Engine.

bool DoImport(
Int64 ImportRunID,
String ImportFile,
List<T> APTransactions
);

Parameters

ImportRunID
ImportFile
APTransactions

Return Value

Remarks

See Also

IAPIntegration Interface | Aptify.Applications.Accounting.AP Namespace


ImportWizard Class

Aptify AP Import Wizard

For a list of all members of this type, see ImportWizard Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
ImportWizard

public class ImportWizard : Form, IAptifyAction

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Accounting.AP

Assembly: AptifyAPWizards (in AptifyAPWizards.dll)

See Also

ImportWizard Members | Aptify.Applications.Accounting.AP Namespace


ImportWizard Members

ImportWizard overview

Public Instance Constructors

ImportWizard Constructor Initializes a new instance of the ImportWizard class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoAction | Overloaded.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ImportWizard Class | Aptify.Applications.Accounting.AP Namespace


ImportWizard Constructor

Initializes a new instance of the ImportWizard class.

public ImportWizard();

See Also

ImportWizard Class | Aptify.Applications.Accounting.AP Namespace


ImportWizard Methods

The methods of the ImportWizard class are listed below. For a complete list of ImportWizard class members, see the ImportWizard Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoAction | Overloaded.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ImportWizard Class | Aptify.Applications.Accounting.AP Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

ImportWizard.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

ImportWizard Class | Aptify.Applications.Accounting.AP Namespace


ImportWizard.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

ImportWizard Class | Aptify.Applications.Accounting.AP Namespace | ImportWizard.Dispose Overload List


DoAction Method

Aptify 5.0 Software Development Kit (SDK)

ImportWizard.DoAction Method

Overload List

public void DoAction(AptifyApplication,Int64);

public void DoAction(AptifyApplication,Int64,Int64);

public void DoAction(AptifyApplication,Int64,Int64,params Object[]);

public void DoAction(AptifyApplication,Int64,params String[]);

See Also

ImportWizard Class | Aptify.Applications.Accounting.AP Namespace


ImportWizard.DoAction Method (AptifyApplication, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID
);

Implements

IAptifyAction.

See Also

ImportWizard Class | Aptify.Applications.Accounting.AP Namespace | ImportWizard.DoAction Overload List


ImportWizard.DoAction Method (AptifyApplication, Int64, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID
);

Implements

IAptifyAction.

See Also

ImportWizard Class | Aptify.Applications.Accounting.AP Namespace | ImportWizard.DoAction Overload List


ImportWizard.DoAction Method (AptifyApplication, Int64, Int64, Object[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID,
params Object[] SelectedItems
);

Implements

IAptifyAction.

See Also

ImportWizard Class | Aptify.Applications.Accounting.AP Namespace | ImportWizard.DoAction Overload List


ImportWizard.DoAction Method (AptifyApplication, Int64, String[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
params String[] SelectedItems
);

Implements

IAptifyAction.

See Also

ImportWizard Class | Aptify.Applications.Accounting.AP Namespace | ImportWizard.DoAction Overload List


Aptify.Applications.Accounting.Currency

Aptify 5.0 Software Development Kit (SDK)

Aptify.Applications.Accounting.Currency Namespace

The objects in this namespace provide Aptify's multi-currency functionality.

Namespace hierarchy

Classes

Class | Description
CurrencyException |
CurrencyMarkToMarket | This class implements the ICurrencyMarkToMarket interface and is the base class for marking Currency to market in the Aptify CRM/Order Entry system. If functional changes are required to this area of the system, it is recommended that this class be sub-classed and the appropriate methods of this class be overriden to augment/alter the functionality. Alternatively, it is also possible to implement the ICurrencyMarkToMarket interface by a completely separate class if that is required. Additional details on the methods provided in this class can be obtained in the documentation for the ICurrencyMarkToMarket interface.
CurrencyMarkToMarket.OrganizationExchangeRateGLAccounts |
CurrencyTypesEntity |
MarkToMarketException | Provides an exception that can be throw to indicate errors specific to the Mark-To-Market process.
MarkToMarketWizard |
RetrieveSpotRate | This object implements the Aptify.Framework.Applications.Currency.ISpotRate interface. The purpose of this component is to return a spot rate along with a spot rate ID to the calling application based on a currency ID and a base currency id.

Interfaces

Interface | Description
ICurrencyMarkToMarket | Interface used to create plug-ins for marking Open A/R denominated in foreign currencies to market values based on current exchange rates. The default object for this plug in interface's implementation is Aptify.Applications.Accounting.CurrencyMarkToMarket
ISpotRate | Interface used to create plug-ins for retrieving spot rates for currency pairs

Delegates

Delegate | Description
ICurrencyMarkToMarket.StatusUpdateEventHandler |

Enumerations

Enumeration | Description
CurrencyMarkToMarket.ProcessFlowRunMode |


CurrencyException Class

For a list of all members of this type, see CurrencyException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
CurrencyException

public class CurrencyException : BaseApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Accounting.Currency

Assembly: CurrencyRetrieval (in CurrencyRetrieval.dll)

See Also

CurrencyException Members | Aptify.Applications.Accounting.Currency Namespace


CurrencyException Members

CurrencyException overview

Public Instance Constructors

CurrencyException Overloaded. Initializes a new instance of the CurrencyException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from BaseApplicationException) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CurrencyException Class | Aptify.Applications.Accounting.Currency Namespace


CurrencyException Constructor

Overload List

public CurrencyException(SerializationInfo,StreamingContext);

public CurrencyException(String);

public CurrencyException(String,Exception);

See Also

CurrencyException Class | Aptify.Applications.Accounting.Currency Namespace


CurrencyException Constructor (String)

public CurrencyException(
String Message
);

See Also

CurrencyException Class | Aptify.Applications.Accounting.Currency Namespace | CurrencyException Constructor Overload List


CurrencyException Constructor (String, Exception)

public CurrencyException(
String Message,
Exception inner
);

See Also

CurrencyException Class | Aptify.Applications.Accounting.Currency Namespace | CurrencyException Constructor Overload List


CurrencyException Constructor (SerializationInfo, StreamingContext)

public CurrencyException(
SerializationInfo info,
StreamingContext context
);

See Also

CurrencyException Class | Aptify.Applications.Accounting.Currency Namespace | CurrencyException Constructor Overload List


CurrencyMarkToMarket Class

This class implements the ICurrencyMarkToMarket interface and is the base class for marking Currency to market in the Aptify CRM/Order Entry system. If functional changes are required to this area of the system, it is recommended that this class be sub-classed and the appropriate methods of this class be overriden to augment/alter the functionality. Alternatively, it is also possible to implement the ICurrencyMarkToMarket interface by a completely separate class if that is required. Additional details on the methods provided in this class can be obtained in the documentation for the ICurrencyMarkToMarket interface.

For a list of all members of this type, see CurrencyMarkToMarket Members.

System.Object
CurrencyMarkToMarket

public class CurrencyMarkToMarket : ICurrencyMarkToMarket, IProcessComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Accounting.Currency

Assembly: CurrencyMarkToMarket (in CurrencyMarkToMarket.dll)

See Also

CurrencyMarkToMarket Members | Aptify.Applications.Accounting.Currency Namespace


CurrencyMarkToMarket Members

CurrencyMarkToMarket overview

Public Instance Constructors

CurrencyMarkToMarket Constructor Initializes a new instance of the CurrencyMarkToMarket class.

Public Instance Properties

Application | Returns an instance of the Aptify Application object
DataAction | Retursn an instance of the Aptify DataAction object
Database | Returns the name of the database where the Currency Types and related entities are stored
Properties |

Public Instance Methods

Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetSystemFunctionalCurrency | Overloaded. Returns a Functional Currency Type ID. In a system with a single Functional Currency, this method will return the system's Functional Currency Type ID. In a system with multiple functional currencies, the ID for one of the Functional Currencies will be returned.
GetType (inherited from Object) | Gets the Type of the current instance.
OrderQualifies | Overloaded.
ProcessOrders | Overloaded.
ProcessSingleOrder | Overloaded.
Run | This implementation of IProcessComponent has two possible modes of operation, single record and multiple record. Input Properties Mode (Single or Multiple or All) The following Input Properties are used when Mode is Multiple ViewID ViewSQL The following Input Properties are used when Mode is Single OrderID OrderGE When Mode=All, none of the above input properites other than Mode are considered No Output Properties are provided Result Codes are SUCCESS and FAILED
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

StatusUpdate

Protected Instance Fields

m_dicOrganizationExchangeRates

Protected Instance Methods

CreateAdjustingScheduledTransaction | This method is responsible for creating any required adjusting scheduled transactions when mark to market has occured more than once for a given order. This function should only be called when an order has more than one prior mark-to-market action on it otherwise it will fail.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAllQualifyingOrdersSQL | This method returns a SQL statement that will return a list of all order id values that qualify for being marked to market. This returns a list of orders using the a query which tests for orders that are NOT quotations, have been shipped, have a Currency type other than the functional currency of Organization that owns the Order have a balance not equal to 0.
GetARAccountFromOrder | Returns the AR Account Used within a specified order
GetCurrencyTypeName | This method returns the name of a Currency type based on its ID value
GetOrganizationExchangeRateGLAccounts |
GetProcessFlowRunMode | This method determines, using the Input Property "Mode" the mode of opeation for the requested process flow
GetQuotationOrderTypeID | This method returns the ID value in the Order Types entity that corresponds to Quotation Type
GetScalarLong | This utility method returns a scalar long value from a SQL statement
GetScalarString | This utility method returns a scalar string value from a SQL statement
GetShippedOrderStatusID | This method returns the ID value in the Order Status Types entity that corresponds to Shipped.
GetSpotRateRetrievalObject | This method returns a configured spot rate retrieval object.
InternalProcessSingleOrder | This method is responsible for handing the process of marking a single order to market. This method is called internally from the ProcessSingleOrder() public methods once it is verified that an order is indeed qualfied for marking-to-market. Before calling this method, the ProcessSingleOrder() methods check to make sure that the order qualifies. If this method is to be used by a sub-class, it is critical that OrderQualifies() is called before this method is called
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ModifyViewSQLForQualifyingRecords | This method can be used by User Interface components such as the Mark To Market wizard as a utility to modify the the provided View SQL statement to remove the order-by clause and also ensure that Order ID, Currency, Balance and Status are included in the query so that the caller has access to this values for display purposes. This function is not used directly within the CurrencyMarkToMarket object itself, but can be used by calling applications.
OnStatusUpdate | This method is called by the ProcessOrders() method to nofity calling applications/objects of progress and to allow cancellation via the Cancel OUT Parameter

See Also

CurrencyMarkToMarket Class | Aptify.Applications.Accounting.Currency Namespace


CurrencyMarkToMarket Constructor

Initializes a new instance of the CurrencyMarkToMarket class.

public CurrencyMarkToMarket();

See Also

CurrencyMarkToMarket Class | Aptify.Applications.Accounting.Currency Namespace


CurrencyMarkToMarket Fields

The fields of the CurrencyMarkToMarket class are listed below. For a complete list of CurrencyMarkToMarket class members, see the CurrencyMarkToMarket Members topic.

Protected Instance Fields

m_dicOrganizationExchangeRates

See Also

CurrencyMarkToMarket Class | Aptify.Applications.Accounting.Currency Namespace


CurrencyMarkToMarket.m_dicOrganizationExchangeRates Field

protected m_dicOrganizationExchangeRates m_dicOrganizationExchangeRates;

See Also

CurrencyMarkToMarket Class | Aptify.Applications.Accounting.Currency Namespace


CurrencyMarkToMarket Properties

The properties of the CurrencyMarkToMarket class are listed below. For a complete list of CurrencyMarkToMarket class members, see the CurrencyMarkToMarket Members topic.

Public Instance Properties

Application | Returns an instance of the Aptify Application object
DataAction | Retursn an instance of the Aptify DataAction object
Database | Returns the name of the database where the Currency Types and related entities are stored
Properties |

See Also

CurrencyMarkToMarket Class | Aptify.Applications.Accounting.Currency Namespace


Application Property

Aptify 5.0 Software Development Kit (SDK)

CurrencyMarkToMarket.Application Property

Returns an instance of the Aptify Application object

public virtual AptifyApplication Application {get;}

Property Value

Remarks

See Also

CurrencyMarkToMarket Class | Aptify.Applications.Accounting.Currency Namespace


DataAction Property

Aptify 5.0 Software Development Kit (SDK)

CurrencyMarkToMarket.DataAction Property

Retursn an instance of the Aptify DataAction object

public virtual DataAction DataAction {get;}

Property Value

Remarks

See Also

CurrencyMarkToMarket Class | Aptify.Applications.Accounting.Currency Namespace


Database Property

Aptify 5.0 Software Development Kit (SDK)

CurrencyMarkToMarket.Database Property

Returns the name of the database where the Currency Types and related entities are stored

public virtual String Database {get;}

Property Value

Remarks

See Also

CurrencyMarkToMarket Class | Aptify.Applications.Accounting.Currency Namespace


Properties Property

Aptify 5.0 Software Development Kit (SDK)

CurrencyMarkToMarket.Properties Property

public AptifyProperties Properties {get;}

Implements

IProcessComponent.

See Also

CurrencyMarkToMarket Class | Aptify.Applications.Accounting.Currency Namespace


CurrencyMarkToMarket Methods

The methods of the CurrencyMarkToMarket class are listed below. For a complete list of CurrencyMarkToMarket class members, see the CurrencyMarkToMarket Members topic.

Public Instance Methods

Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetSystemFunctionalCurrency | Overloaded. Returns a Functional Currency Type ID. In a system with a single Functional Currency, this method will return the system's Functional Currency Type ID. In a system with multiple functional currencies, the ID for one of the Functional Currencies will be returned.
GetType (inherited from Object) | Gets the Type of the current instance.
OrderQualifies | Overloaded.
ProcessOrders | Overloaded.
ProcessSingleOrder | Overloaded.
Run | This implementation of IProcessComponent has two possible modes of operation, single record and multiple record. Input Properties Mode (Single or Multiple or All) The following Input Properties are used when Mode is Multiple ViewID ViewSQL The following Input Properties are used when Mode is Single OrderID OrderGE When Mode=All, none of the above input properites other than Mode are considered No Output Properties are provided Result Codes are SUCCESS and FAILED
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CreateAdjustingScheduledTransaction | This method is responsible for creating any required adjusting scheduled transactions when mark to market has occured more than once for a given order. This function should only be called when an order has more than one prior mark-to-market action on it otherwise it will fail.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAllQualifyingOrdersSQL | This method returns a SQL statement that will return a list of all order id values that qualify for being marked to market. This returns a list of orders using the a query which tests for orders that are NOT quotations, have been shipped, have a Currency type other than the functional currency of Organization that owns the Order have a balance not equal to 0.
GetARAccountFromOrder | Returns the AR Account Used within a specified order
GetCurrencyTypeName | This method returns the name of a Currency type based on its ID value
GetOrganizationExchangeRateGLAccounts |
GetProcessFlowRunMode | This method determines, using the Input Property "Mode" the mode of opeation for the requested process flow
GetQuotationOrderTypeID | This method returns the ID value in the Order Types entity that corresponds to Quotation Type
GetScalarLong | This utility method returns a scalar long value from a SQL statement
GetScalarString | This utility method returns a scalar string value from a SQL statement
GetShippedOrderStatusID | This method returns the ID value in the Order Status Types entity that corresponds to Shipped.
GetSpotRateRetrievalObject | This method returns a configured spot rate retrieval object.
InternalProcessSingleOrder | This method is responsible for handing the process of marking a single order to market. This method is called internally from the ProcessSingleOrder() public methods once it is verified that an order is indeed qualfied for marking-to-market. Before calling this method, the ProcessSingleOrder() methods check to make sure that the order qualifies. If this method is to be used by a sub-class, it is critical that OrderQualifies() is called before this method is called
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ModifyViewSQLForQualifyingRecords | This method can be used by User Interface components such as the Mark To Market wizard as a utility to modify the the provided View SQL statement to remove the order-by clause and also ensure that Order ID, Currency, Balance and Status are included in the query so that the caller has access to this values for display purposes. This function is not used directly within the CurrencyMarkToMarket object itself, but can be used by calling applications.
OnStatusUpdate | This method is called by the ProcessOrders() method to nofity calling applications/objects of progress and to allow cancellation via the Cancel OUT Parameter

See Also

CurrencyMarkToMarket Class | Aptify.Applications.Accounting.Currency Namespace


CurrencyMarkToMarket.Config Method

public virtual void Config(
AptifyApplication Application
);

Implements

IProcessComponent.

See Also

CurrencyMarkToMarket Class | Aptify.Applications.Accounting.Currency Namespace


CurrencyMarkToMarket.CreateAdjustingScheduledTransaction Method

This method is responsible for creating any required adjusting scheduled transactions when mark to market has occured more than once for a given order. This function should only be called when an order has more than one prior mark-to-market action on it otherwise it will fail.

protected virtual void CreateAdjustingScheduledTransaction(
AptifyGenericEntityBase OrderGE
);

Parameters

OrderGE

Remarks

See Also

CurrencyMarkToMarket Class | Aptify.Applications.Accounting.Currency Namespace


CurrencyMarkToMarket.GetAllQualifyingOrdersSQL Method

This method returns a SQL statement that will return a list of all order id values that qualify for being marked to market. This returns a list of orders using the a query which tests for orders that are NOT quotations, have been shipped, have a Currency type other than the functional currency of Organization that owns the Order have a balance not equal to 0.

protected virtual string GetAllQualifyingOrdersSQL();

Return Value

Remarks

See Also

CurrencyMarkToMarket Class | Aptify.Applications.Accounting.Currency Namespace


CurrencyMarkToMarket.GetARAccountFromOrder Method

Returns the AR Account Used within a specified order

protected virtual string GetARAccountFromOrder(
AptifyGenericEntityBase OrderGE
);

Parameters

OrderGE

Return Value

Remarks

See Also

CurrencyMarkToMarket Class | Aptify.Applications.Accounting.Currency Namespace


CurrencyMarkToMarket.GetCurrencyTypeName Method

This method returns the name of a Currency type based on its ID value

protected virtual string GetCurrencyTypeName(
Int64 CurrencyTypeID
);

Parameters

CurrencyTypeID

Return Value

Remarks

See Also

CurrencyMarkToMarket Class | Aptify.Applications.Accounting.Currency Namespace


CurrencyMarkToMarket.GetOrganizationExchangeRateGLAccounts Method

protected virtual OrganizationExchangeRateGLAccounts GetOrganizationExchangeRateGLAccounts(
Int64 OrganizationID
);

See Also

CurrencyMarkToMarket Class | Aptify.Applications.Accounting.Currency Namespace


CurrencyMarkToMarket.GetProcessFlowRunMode Method

This method determines, using the Input Property "Mode" the mode of opeation for the requested process flow

protected virtual ProcessFlowRunMode GetProcessFlowRunMode();

Return Value

Remarks

See Also

CurrencyMarkToMarket Class | Aptify.Applications.Accounting.Currency Namespace


CurrencyMarkToMarket.GetQuotationOrderTypeID Method

This method returns the ID value in the Order Types entity that corresponds to Quotation Type

protected virtual long GetQuotationOrderTypeID();

Return Value

Remarks

See Also

CurrencyMarkToMarket Class | Aptify.Applications.Accounting.Currency Namespace


CurrencyMarkToMarket.GetScalarLong Method

This utility method returns a scalar long value from a SQL statement

protected virtual long GetScalarLong(
String SQL,
IAptifyDataAction.DSLCacheSetting CacheSetting
);

Parameters

SQL
CacheSetting

Return Value

Remarks

See Also

CurrencyMarkToMarket Class | Aptify.Applications.Accounting.Currency Namespace


CurrencyMarkToMarket.GetScalarString Method

This utility method returns a scalar string value from a SQL statement

protected virtual string GetScalarString(
String SQL,
IAptifyDataAction.DSLCacheSetting CacheSetting
);

Parameters

SQL
CacheSetting

Return Value

Remarks

See Also

CurrencyMarkToMarket Class | Aptify.Applications.Accounting.Currency Namespace


CurrencyMarkToMarket.GetShippedOrderStatusID Method

This method returns the ID value in the Order Status Types entity that corresponds to Shipped.

protected virtual long GetShippedOrderStatusID();

Return Value

Remarks

See Also

CurrencyMarkToMarket Class | Aptify.Applications.Accounting.Currency Namespace


CurrencyMarkToMarket.GetSpotRateRetrievalObject Method

This method returns a configured spot rate retrieval object.

protected virtual ISpotRate GetSpotRateRetrievalObject();

Return Value

Remarks

See Also

CurrencyMarkToMarket Class | Aptify.Applications.Accounting.Currency Namespace


GetSystemFunctionalCurrency Method

Aptify 5.0 Software Development Kit (SDK)

CurrencyMarkToMarket.GetSystemFunctionalCurrency Method

Returns a Functional Currency Type ID. In a system with a single Functional Currency, this method will return the system's Functional Currency Type ID. In a system with multiple functional currencies, the ID for one of the Functional Currencies will be returned.

Overload List

Returns a Functional Currency Type ID. In a system with a single Functional Currency, this method will return the system's Functional Currency Type ID. In a system with multiple functional currencies, the ID for one of the Functional Currencies will be returned.

public virtual long GetSystemFunctionalCurrency();

Returns a Functional Currency Type ID and the Name of that Currency Type in the CurrencyName parameter. In a system with a single Functional Currency, this method will return the system's Functional Currency Type ID. In a system with multiple functional currencies, the ID for one of the Functional Currencies will be returned.

public virtual long GetSystemFunctionalCurrency(ref String&);

See Also

CurrencyMarkToMarket Class | Aptify.Applications.Accounting.Currency Namespace


CurrencyMarkToMarket.GetSystemFunctionalCurrency Method ()

Returns a Functional Currency Type ID. In a system with a single Functional Currency, this method will return the system's Functional Currency Type ID. In a system with multiple functional currencies, the ID for one of the Functional Currencies will be returned.

public virtual long GetSystemFunctionalCurrency();

Return Value

Implements

ICurrencyMarkToMarket.

Remarks

See Also

CurrencyMarkToMarket Class | Aptify.Applications.Accounting.Currency Namespace | CurrencyMarkToMarket.GetSystemFunctionalCurrency Overload List


CurrencyMarkToMarket.GetSystemFunctionalCurrency Method (String&)

Returns a Functional Currency Type ID and the Name of that Currency Type in the CurrencyName parameter. In a system with a single Functional Currency, this method will return the system's Functional Currency Type ID. In a system with multiple functional currencies, the ID for one of the Functional Currencies will be returned.

public virtual long GetSystemFunctionalCurrency(
ref String& CurrencyName
);

Return Value

Implements

ICurrencyMarkToMarket.

Remarks

See Also

CurrencyMarkToMarket Class | Aptify.Applications.Accounting.Currency Namespace | CurrencyMarkToMarket.GetSystemFunctionalCurrency Overload List


CurrencyMarkToMarket.InternalProcessSingleOrder Method

This method is responsible for handing the process of marking a single order to market. This method is called internally from the ProcessSingleOrder() public methods once it is verified that an order is indeed qualfied for marking-to-market. Before calling this method, the ProcessSingleOrder() methods check to make sure that the order qualifies. If this method is to be used by a sub-class, it is critical that OrderQualifies() is called before this method is called

protected virtual bool InternalProcessSingleOrder(
AptifyGenericEntityBase OrderGE
);

Parameters

OrderGE

Return Value

True if operation succeeds, False otherwise

Remarks

See Also

CurrencyMarkToMarket Class | Aptify.Applications.Accounting.Currency Namespace


CurrencyMarkToMarket.ModifyViewSQLForQualifyingRecords Method

This method can be used by User Interface components such as the Mark To Market wizard as a utility to modify the the provided View SQL statement to remove the order-by clause and also ensure that Order ID, Currency, Balance and Status are included in the query so that the caller has access to this values for display purposes. This function is not used directly within the CurrencyMarkToMarket object itself, but can be used by calling applications.

protected virtual string ModifyViewSQLForQualifyingRecords(
String SQL
);

Parameters

SQL

Return Value

Implements

ICurrencyMarkToMarket.

Remarks

See Also

CurrencyMarkToMarket Class | Aptify.Applications.Accounting.Currency Namespace


CurrencyMarkToMarket.OnStatusUpdate Method

This method is called by the ProcessOrders() method to nofity calling applications/objects of progress and to allow cancellation via the Cancel OUT Parameter

protected virtual void OnStatusUpdate(
Int64 OrderID,
Int64 RecordNumber,
Int64 TotalRecords,
Int32 PercentComplete,
ref Boolean& Cancel
);

Parameters

OrderID
RecordNumber
TotalRecords
PercentComplete
Cancel

Remarks

See Also

CurrencyMarkToMarket Class | Aptify.Applications.Accounting.Currency Namespace


OrderQualifies Method

Aptify 5.0 Software Development Kit (SDK)

CurrencyMarkToMarket.OrderQualifies Method

Overload List

public virtual bool OrderQualifies(AptifyGenericEntityBase);

public virtual bool OrderQualifies(Int64);

See Also

CurrencyMarkToMarket Class | Aptify.Applications.Accounting.Currency Namespace


CurrencyMarkToMarket.OrderQualifies Method (AptifyGenericEntityBase)

public virtual bool OrderQualifies(
AptifyGenericEntityBase OrderGE
);

Implements

ICurrencyMarkToMarket.

See Also

CurrencyMarkToMarket Class | Aptify.Applications.Accounting.Currency Namespace | CurrencyMarkToMarket.OrderQualifies Overload List


CurrencyMarkToMarket.OrderQualifies Method (Int64)

public virtual bool OrderQualifies(
Int64 OrderID
);

Implements

ICurrencyMarkToMarket.

See Also

CurrencyMarkToMarket Class | Aptify.Applications.Accounting.Currency Namespace | CurrencyMarkToMarket.OrderQualifies Overload List


ProcessOrders Method

Aptify 5.0 Software Development Kit (SDK)

CurrencyMarkToMarket.ProcessOrders Method

Overload List

public virtual bool ProcessOrders();

public virtual bool ProcessOrders(List<T>);

public virtual bool ProcessOrders(Int64);

public virtual bool ProcessOrders(String);

See Also

CurrencyMarkToMarket Class | Aptify.Applications.Accounting.Currency Namespace


CurrencyMarkToMarket.ProcessOrders Method ()

public virtual bool ProcessOrders();

Implements

ICurrencyMarkToMarket.

See Also

CurrencyMarkToMarket Class | Aptify.Applications.Accounting.Currency Namespace | CurrencyMarkToMarket.ProcessOrders Overload List


CurrencyMarkToMarket.ProcessOrders Method (List<T>)

public virtual bool ProcessOrders(
List<T> OrderList
);

Implements

ICurrencyMarkToMarket.

See Also

CurrencyMarkToMarket Class | Aptify.Applications.Accounting.Currency Namespace | CurrencyMarkToMarket.ProcessOrders Overload List


CurrencyMarkToMarket.ProcessOrders Method (Int64)

public virtual bool ProcessOrders(
Int64 ViewID
);

Implements

ICurrencyMarkToMarket.

See Also

CurrencyMarkToMarket Class | Aptify.Applications.Accounting.Currency Namespace | CurrencyMarkToMarket.ProcessOrders Overload List


CurrencyMarkToMarket.ProcessOrders Method (String)

public virtual bool ProcessOrders(
String ViewSQL
);

Implements

ICurrencyMarkToMarket.

See Also

CurrencyMarkToMarket Class | Aptify.Applications.Accounting.Currency Namespace | CurrencyMarkToMarket.ProcessOrders Overload List


ProcessSingleOrder Method

Aptify 5.0 Software Development Kit (SDK)

CurrencyMarkToMarket.ProcessSingleOrder Method

Overload List

public virtual bool ProcessSingleOrder(AptifyGenericEntityBase);

public virtual bool ProcessSingleOrder(Int64);

See Also

CurrencyMarkToMarket Class | Aptify.Applications.Accounting.Currency Namespace


CurrencyMarkToMarket.ProcessSingleOrder Method (AptifyGenericEntityBase)

public virtual bool ProcessSingleOrder(
AptifyGenericEntityBase OrderGE
);

Implements

ICurrencyMarkToMarket.

See Also

CurrencyMarkToMarket Class | Aptify.Applications.Accounting.Currency Namespace | CurrencyMarkToMarket.ProcessSingleOrder Overload List


CurrencyMarkToMarket.ProcessSingleOrder Method (Int64)

public virtual bool ProcessSingleOrder(
Int64 OrderID
);

Implements

ICurrencyMarkToMarket.

See Also

CurrencyMarkToMarket Class | Aptify.Applications.Accounting.Currency Namespace | CurrencyMarkToMarket.ProcessSingleOrder Overload List


CurrencyMarkToMarket.Run Method

This implementation of IProcessComponent has two possible modes of operation, single record and multiple record. Input Properties Mode (Single or Multiple or All) The following Input Properties are used when Mode is Multiple ViewID ViewSQL The following Input Properties are used when Mode is Single OrderID OrderGE When Mode=All, none of the above input properites other than Mode are considered No Output Properties are provided Result Codes are SUCCESS and FAILED

public string Run();

Return Value

Implements

IProcessComponent.

Remarks

See Also

CurrencyMarkToMarket Class | Aptify.Applications.Accounting.Currency Namespace


CurrencyMarkToMarket Events

The events of the CurrencyMarkToMarket class are listed below. For a complete list of CurrencyMarkToMarket class members, see the CurrencyMarkToMarket Members topic.

Public Instance Events

StatusUpdate

See Also

CurrencyMarkToMarket Class | Aptify.Applications.Accounting.Currency Namespace


CurrencyMarkToMarket.ICurrencyMarkToMarket.StatusUpdateEventHandler Event

public event ICurrencyMarkToMarket.StatusUpdateEventHandler StatusUpdate;

Implements

ICurrencyMarkToMarket.

See Also

CurrencyMarkToMarket Class | Aptify.Applications.Accounting.Currency Namespace


CurrencyMarkToMarket.OrganizationExchangeRateGLAccounts Class

For a list of all members of this type, see CurrencyMarkToMarket.OrganizationExchangeRateGLAccounts Members.

System.Object
CurrencyMarkToMarket.OrganizationExchangeRateGLAccounts

protected class CurrencyMarkToMarket.OrganizationExchangeRateGLAccounts

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Accounting.Currency

Assembly: CurrencyMarkToMarket (in CurrencyMarkToMarket.dll)

See Also

CurrencyMarkToMarket.OrganizationExchangeRateGLAccounts Members | Aptify.Applications.Accounting.Currency Namespace


CurrencyMarkToMarket.OrganizationExchangeRateGLAccounts Members

CurrencyMarkToMarket.OrganizationExchangeRateGLAccounts overview

Public Instance Constructors

CurrencyMarkToMarket.OrganizationExchangeRateGLAccounts Constructor Initializes a new instance of the CurrencyMarkToMarket.OrganizationExchangeRateGLAccounts class.

Public Instance Fields

GainGLAccount
LossGLAccount
OrganizationID

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CurrencyMarkToMarket.OrganizationExchangeRateGLAccounts Class | Aptify.Applications.Accounting.Currency Namespace


CurrencyMarkToMarket.OrganizationExchangeRateGLAccounts Constructor

Initializes a new instance of the CurrencyMarkToMarket.OrganizationExchangeRateGLAccounts class.

public CurrencyMarkToMarket.OrganizationExchangeRateGLAccounts();

See Also

CurrencyMarkToMarket.OrganizationExchangeRateGLAccounts Class | Aptify.Applications.Accounting.Currency Namespace


CurrencyMarkToMarket.OrganizationExchangeRateGLAccounts Fields

The fields of the CurrencyMarkToMarket.OrganizationExchangeRateGLAccounts class are listed below. For a complete list of CurrencyMarkToMarket.OrganizationExchangeRateGLAccounts class members, see the CurrencyMarkToMarket.OrganizationExchangeRateGLAccounts Members topic.

Public Instance Fields

GainGLAccount
LossGLAccount
OrganizationID

See Also

CurrencyMarkToMarket.OrganizationExchangeRateGLAccounts Class | Aptify.Applications.Accounting.Currency Namespace


CurrencyMarkToMarket.OrganizationExchangeRateGLAccounts.GainGLAccount Field

public GainGLAccount GainGLAccount;

See Also

CurrencyMarkToMarket.OrganizationExchangeRateGLAccounts Class | Aptify.Applications.Accounting.Currency Namespace


CurrencyMarkToMarket.OrganizationExchangeRateGLAccounts.LossGLAccount Field

public LossGLAccount LossGLAccount;

See Also

CurrencyMarkToMarket.OrganizationExchangeRateGLAccounts Class | Aptify.Applications.Accounting.Currency Namespace


CurrencyMarkToMarket.OrganizationExchangeRateGLAccounts.OrganizationID Field

public OrganizationID OrganizationID;

See Also

CurrencyMarkToMarket.OrganizationExchangeRateGLAccounts Class | Aptify.Applications.Accounting.Currency Namespace


CurrencyMarkToMarket.ProcessFlowRunMode Enumeration

public enum CurrencyMarkToMarket.ProcessFlowRunMode

Members

Member Name | Description
SingleRecord |
MultipleRecords |
AllQualifyingRecords |

Requirements

Namespace: Aptify.Applications.Accounting.Currency

Assembly: CurrencyMarkToMarket (in CurrencyMarkToMarket.dll)

See Also

Aptify.Applications.Accounting.Currency Namespace


CurrencyTypesEntity Class

For a list of all members of this type, see CurrencyTypesEntity Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
CurrencyTypesEntity

public class CurrencyTypesEntity : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Accounting.Currency

Assembly: CurrencyTypeObject (in CurrencyTypeObject.dll)

See Also

CurrencyTypesEntity Members | Aptify.Applications.Accounting.Currency Namespace


CurrencyTypesEntity Members

CurrencyTypesEntity overview

Public Instance Constructors

CurrencyTypesEntity Constructor Initializes a new instance of the CurrencyTypesEntity class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

CurrencyTypesEntity Class | Aptify.Applications.Accounting.Currency Namespace


CurrencyTypesEntity Constructor

Initializes a new instance of the CurrencyTypesEntity class.

public CurrencyTypesEntity();

See Also

CurrencyTypesEntity Class | Aptify.Applications.Accounting.Currency Namespace


CurrencyTypesEntity Methods

The methods of the CurrencyTypesEntity class are listed below. For a complete list of CurrencyTypesEntity class members, see the CurrencyTypesEntity Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

CurrencyTypesEntity Class | Aptify.Applications.Accounting.Currency Namespace


Validate Method

Aptify 5.0 Software Development Kit (SDK)

CurrencyTypesEntity.Validate Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Validate();

public override bool Validate(ref String&);

See Also

CurrencyTypesEntity Class | Aptify.Applications.Accounting.Currency Namespace


CurrencyTypesEntity.Validate Method (String&)

public override bool Validate(
ref String& ErrorString
);

See Also

CurrencyTypesEntity Class | Aptify.Applications.Accounting.Currency Namespace | CurrencyTypesEntity.Validate Overload List


ICurrencyMarkToMarket Interface

Interface used to create plug-ins for marking Open A/R denominated in foreign currencies to market values based on current exchange rates. The default object for this plug in interface's implementation is Aptify.Applications.Accounting.CurrencyMarkToMarket

For a list of all members of this type, see ICurrencyMarkToMarket Members.

public interface ICurrencyMarkToMarket

Types that implement ICurrencyMarkToMarket

Type | Description
CurrencyMarkToMarket | This class implements the ICurrencyMarkToMarket interface and is the base class for marking Currency to market in the Aptify CRM/Order Entry system. If functional changes are required to this area of the system, it is recommended that this class be sub-classed and the appropriate methods of this class be overriden to augment/alter the functionality. Alternatively, it is also possible to implement the ICurrencyMarkToMarket interface by a completely separate class if that is required. Additional details on the methods provided in this class can be obtained in the documentation for the ICurrencyMarkToMarket interface.

Remarks

Requirements

Namespace: Aptify.Applications.Accounting.Currency

Assembly: ICurrencyMarkToMarket (in ICurrencyMarkToMarket.dll)

See Also

ICurrencyMarkToMarket Members | Aptify.Applications.Accounting.Currency Namespace


ICurrencyMarkToMarket Members

ICurrencyMarkToMarket overview

Public Instance Methods

Config | Call this function before using any other method on the interface to configure the object for use
GetSystemFunctionalCurrency | Overloaded. This method returns the functional currency for the current system as a Long value (The ID of the Currency Types entity record that is the functional currency for the system). In a system with multiple functional currencies, this method is obsolete.
ModifyViewSQLForQualifyingRecords | This method can be used by User Interface components such as the Mark To Market wizard as a utility to modify the the provided View SQL statement to remove the order-by clause and also ensure that Order ID, Currency, Balance and Status are included in the query so that the caller has access to this values for display purposes.
OrderQualifies | Overloaded. Determines if an order qualifies for being marked to market. To qualify, the following conditions must be True: 1) Order must not be a Quotation Type order 2) Order must be shipped 3) Order must have a CurrencyTypeID OTHER THAN the functional currency of the Organization that owns the Order. 4) Order must have a non-zero balance
ProcessOrders | Overloaded. This function will mark to market all open A/R in the entire system using a query on the vwOrders view that returns all orders that have an order type other than Quotation where Balance is not equal to zero and OrderStatus='Shipped' AND a Currency other than the functional currency of the Organization that owns the order. As this method progresses, the StatusUpdate() event will be fired as each record is processed so that progress can be indicated to the user by the calling application, if appropriate.
ProcessSingleOrder | Overloaded. Marks a single order to market

Public Instance Events

StatusUpdate This event is fired for each record processed by the ProcessOrders() method to provide both status update capabilities for the calling application/object as well as the ability to cancel the process.

See Also

ICurrencyMarkToMarket Interface | Aptify.Applications.Accounting.Currency Namespace


ICurrencyMarkToMarket Methods

The methods of the ICurrencyMarkToMarket interface are listed below. For a complete list of ICurrencyMarkToMarket interface members, see the ICurrencyMarkToMarket Members topic.

Public Instance Methods

Config | Call this function before using any other method on the interface to configure the object for use
GetSystemFunctionalCurrency | Overloaded. This method returns the functional currency for the current system as a Long value (The ID of the Currency Types entity record that is the functional currency for the system). In a system with multiple functional currencies, this method is obsolete.
ModifyViewSQLForQualifyingRecords | This method can be used by User Interface components such as the Mark To Market wizard as a utility to modify the the provided View SQL statement to remove the order-by clause and also ensure that Order ID, Currency, Balance and Status are included in the query so that the caller has access to this values for display purposes.
OrderQualifies | Overloaded. Determines if an order qualifies for being marked to market. To qualify, the following conditions must be True: 1) Order must not be a Quotation Type order 2) Order must be shipped 3) Order must have a CurrencyTypeID OTHER THAN the functional currency of the Organization that owns the Order. 4) Order must have a non-zero balance
ProcessOrders | Overloaded. This function will mark to market all open A/R in the entire system using a query on the vwOrders view that returns all orders that have an order type other than Quotation where Balance is not equal to zero and OrderStatus='Shipped' AND a Currency other than the functional currency of the Organization that owns the order. As this method progresses, the StatusUpdate() event will be fired as each record is processed so that progress can be indicated to the user by the calling application, if appropriate.
ProcessSingleOrder | Overloaded. Marks a single order to market

See Also

ICurrencyMarkToMarket Interface | Aptify.Applications.Accounting.Currency Namespace


ICurrencyMarkToMarket.Config Method

Call this function before using any other method on the interface to configure the object for use

void Config(
AptifyApplication Application
);

Parameters

Application
Aptify Application Required for Use of the Object

Remarks

See Also

ICurrencyMarkToMarket Interface | Aptify.Applications.Accounting.Currency Namespace


GetSystemFunctionalCurrency Method

Aptify 5.0 Software Development Kit (SDK)

ICurrencyMarkToMarket.GetSystemFunctionalCurrency Method

This method returns the functional currency for the current system as a Long value (The ID of the Currency Types entity record that is the functional currency for the system) In a system with multiple functional currencies, this method is obsolete.

Overload List

This method returns the functional currency for the current system as a Long value (The ID of the Currency Types entity record that is the functional currency for the system) In a system with multiple functional currencies, this method is obsolete.

long GetSystemFunctionalCurrency();

This method returns the functional currency for the current system as a Long value (The ID of the Currency Types entity record that is the functional currency for the system). In a system with multiple functional currencies, this method is obsolete.

long GetSystemFunctionalCurrency(ref String&);

See Also

ICurrencyMarkToMarket Interface | Aptify.Applications.Accounting.Currency Namespace


ICurrencyMarkToMarket.GetSystemFunctionalCurrency Method ()

This method returns the functional currency for the current system as a Long value (The ID of the Currency Types entity record that is the functional currency for the system) In a system with multiple functional currencies, this method is obsolete.

long GetSystemFunctionalCurrency();

Return Value

Positive ID value for Currency Types entity, -1 if function failed

Remarks

See Also

ICurrencyMarkToMarket Interface | Aptify.Applications.Accounting.Currency Namespace | ICurrencyMarkToMarket.GetSystemFunctionalCurrency Overload List


ICurrencyMarkToMarket.GetSystemFunctionalCurrency Method (String&)

This method returns the functional currency for the current system as a Long value (The ID of the Currency Types entity record that is the functional currency for the system). In a system with multiple functional currencies, this method is obsolete.

long GetSystemFunctionalCurrency(
ref String& CurrencyName
);

Parameters

CurrencyName
OUT Parameter: Returns Name of Currency for the System Functional Currency. ID is returned as the return value of the method.

Return Value

Positive ID value for Currency Types entity, -1 if function failed

Remarks

See Also

ICurrencyMarkToMarket Interface | Aptify.Applications.Accounting.Currency Namespace | ICurrencyMarkToMarket.GetSystemFunctionalCurrency Overload List


ICurrencyMarkToMarket.ModifyViewSQLForQualifyingRecords Method

This method can be used by User Interface components such as the Mark To Market wizard as a utility to modify the the provided View SQL statement to remove the order-by clause and also ensure that Order ID, Currency, Balance and Status are included in the query so that the caller has access to this values for display purposes.

string ModifyViewSQLForQualifyingRecords(
String ViewSQL
);

Parameters

ViewSQL

Return Value

Remarks

See Also

ICurrencyMarkToMarket Interface | Aptify.Applications.Accounting.Currency Namespace


OrderQualifies Method

Aptify 5.0 Software Development Kit (SDK)

ICurrencyMarkToMarket.OrderQualifies Method

Determines if an order qualifies for being marked to market. To qualify, the following conditions must be True: 1) Order must not be a Quotation Type order 2) Order must be shipped 3) Order must have a CurrencyTypeID OTHER THAN the functional currency of the Organization that owns the Order. 4) Order must have a non-zero balance

Overload List

Determines if an order qualifies for being marked to market. To qualify, the following conditions must be True: 1) Order must not be a Quotation Type order 2) Order must be shipped 3) Order must have a CurrencyTypeID OTHER THAN the functional currency of the Organization that owns the Order. 4) Order must have a non-zero balance

bool OrderQualifies(AptifyGenericEntityBase);

Determines if an order qualifies for being marked to market. To qualify, the following conditions must be True: 1) Order must not be a Quotation Type order 2) Order must be shipped 3) Order must have a CurrencyTypeID OTHER THAN the functional currency of the Organization that owns the Order. 4) Order must have a non-zero balance

bool OrderQualifies(Int64);

See Also

ICurrencyMarkToMarket Interface | Aptify.Applications.Accounting.Currency Namespace


ICurrencyMarkToMarket.OrderQualifies Method (AptifyGenericEntityBase)

Determines if an order qualifies for being marked to market. To qualify, the following conditions must be True: 1) Order must not be a Quotation Type order 2) Order must be shipped 3) Order must have a CurrencyTypeID OTHER THAN the functional currency of the Organization that owns the Order. 4) Order must have a non-zero balance

bool OrderQualifies(
AptifyGenericEntityBase OrderGE
);

Parameters

OrderGE
Order GE Object within the Orders Entity

Return Value

Remarks

See Also

ICurrencyMarkToMarket Interface | Aptify.Applications.Accounting.Currency Namespace | ICurrencyMarkToMarket.OrderQualifies Overload List


ICurrencyMarkToMarket.OrderQualifies Method (Int64)

Determines if an order qualifies for being marked to market. To qualify, the following conditions must be True: 1) Order must not be a Quotation Type order 2) Order must be shipped 3) Order must have a CurrencyTypeID OTHER THAN the functional currency of the Organization that owns the Order. 4) Order must have a non-zero balance

bool OrderQualifies(
Int64 OrderID
);

Parameters

OrderID
Order ID within the Orders Entity

Return Value

Remarks

See Also

ICurrencyMarkToMarket Interface | Aptify.Applications.Accounting.Currency Namespace | ICurrencyMarkToMarket.OrderQualifies Overload List


ProcessOrders Method

Aptify 5.0 Software Development Kit (SDK)

ICurrencyMarkToMarket.ProcessOrders Method

This function will mark to market all open A/R in the entire system using a query on the vwOrders view that returns all orders that have an order type other than Quotation where Balance is not equal to zero and OrderStatus='Shipped' AND a Currency other than the functional currency of the Organization that owns the order. As this method progresses, the StatusUpdate() event will be fired as each record is processed so that progress can be indicated to the user by the calling application, if appropriate.

Overload List

This function will mark to market all open A/R in the entire system using a query on the vwOrders view that returns all orders that have an order type other than Quotation where Balance is not equal to zero and OrderStatus='Shipped' AND a Currency other than the functional currency of the Organization that owns the order. As this method progresses, the StatusUpdate() event will be fired as each record is processed so that progress can be indicated to the user by the calling application, if appropriate.

bool ProcessOrders();

This version of the ProcessOrders() method will process all of the orders in the provided list using the ProcessSingleOrder() method. Each order will be tested to ensure that it qualifies for being Marked To Market by the OrderQualifies() method.

bool ProcessOrders(List<T>);

This version of the ProcessOrders() method will process all of the orders in the provided View using the ProcessSingleOrder() method. Each order will be tested to ensure that it qualifies for being Marked To Market by the OrderQualifies() method.

bool ProcessOrders(Int64);

This version of the ProcessOrders() method will process all of the orders in the provided View SQL using the ProcessSingleOrder() method. Each order will be tested to ensure that it qualifies for being Marked To Market by the OrderQualifies() method.

bool ProcessOrders(String);

See Also

ICurrencyMarkToMarket Interface | Aptify.Applications.Accounting.Currency Namespace


ICurrencyMarkToMarket.ProcessOrders Method ()

This function will mark to market all open A/R in the entire system using a query on the vwOrders view that returns all orders that have an order type other than Quotation where Balance is not equal to zero and OrderStatus='Shipped' AND a Currency other than the functional currency of the Organization that owns the order. As this method progresses, the StatusUpdate() event will be fired as each record is processed so that progress can be indicated to the user by the calling application, if appropriate.

bool ProcessOrders();

Return Value

True if the method is succesful, False otherwise

Remarks

See Also

ICurrencyMarkToMarket Interface | Aptify.Applications.Accounting.Currency Namespace | ICurrencyMarkToMarket.ProcessOrders Overload List


ICurrencyMarkToMarket.ProcessOrders Method (List<T>)

This version of the ProcessOrders() method will process all of the orders in the provided list using the ProcessSingleOrder() method. Each order will be tested to ensure that it qualifies for being Marked To Market by the OrderQualifies() method.

bool ProcessOrders(
List<T> OrderList
);

Parameters

OrderList
List of Orders to Be Marked To Market

Return Value

Remarks

See Also

ICurrencyMarkToMarket Interface | Aptify.Applications.Accounting.Currency Namespace | ICurrencyMarkToMarket.ProcessOrders Overload List


ICurrencyMarkToMarket.ProcessOrders Method (Int64)

This version of the ProcessOrders() method will process all of the orders in the provided View using the ProcessSingleOrder() method. Each order will be tested to ensure that it qualifies for being Marked To Market by the OrderQualifies() method.

bool ProcessOrders(
Int64 ViewID
);

Parameters

ViewID
View ID in the Aptify Viewing System to Use. This View must be a View on the Orders Entity

Return Value

Remarks

See Also

ICurrencyMarkToMarket Interface | Aptify.Applications.Accounting.Currency Namespace | ICurrencyMarkToMarket.ProcessOrders Overload List


ICurrencyMarkToMarket.ProcessOrders Method (String)

This version of the ProcessOrders() method will process all of the orders in the provided View SQL using the ProcessSingleOrder() method. Each order will be tested to ensure that it qualifies for being Marked To Market by the OrderQualifies() method.

bool ProcessOrders(
String ViewSQL
);

Parameters

ViewSQL
Valid SQL Statement that returns a list of Order ID values (can include other field selection, but must return the vwOrders.ID field

Return Value

Remarks

See Also

ICurrencyMarkToMarket Interface | Aptify.Applications.Accounting.Currency Namespace | ICurrencyMarkToMarket.ProcessOrders Overload List


ProcessSingleOrder Method

Aptify 5.0 Software Development Kit (SDK)

ICurrencyMarkToMarket.ProcessSingleOrder Method

Mark a single order to market using the GE Object

Overload List

Mark a single order to market using the GE Object

bool ProcessSingleOrder(AptifyGenericEntityBase);

Marks a single order to market

bool ProcessSingleOrder(Int64);

See Also

ICurrencyMarkToMarket Interface | Aptify.Applications.Accounting.Currency Namespace


ICurrencyMarkToMarket.ProcessSingleOrder Method (AptifyGenericEntityBase)

Mark a single order to market using the GE Object

bool ProcessSingleOrder(
AptifyGenericEntityBase OrderGE
);

Parameters

OrderGE

Return Value

Remarks

See Also

ICurrencyMarkToMarket Interface | Aptify.Applications.Accounting.Currency Namespace | ICurrencyMarkToMarket.ProcessSingleOrder Overload List


ICurrencyMarkToMarket.ProcessSingleOrder Method (Int64)

Marks a single order to market

bool ProcessSingleOrder(
Int64 OrderID
);

Parameters

OrderID

Return Value

Remarks

See Also

ICurrencyMarkToMarket Interface | Aptify.Applications.Accounting.Currency Namespace | ICurrencyMarkToMarket.ProcessSingleOrder Overload List


ICurrencyMarkToMarket Events

The events of the ICurrencyMarkToMarket interface are listed below. For a complete list of ICurrencyMarkToMarket interface members, see the ICurrencyMarkToMarket Members topic.

Public Instance Events

StatusUpdate This event is fired for each record processed by the ProcessOrders() method to provide both status update capabilities for the calling application/object as well as the ability to cancel the process.

See Also

ICurrencyMarkToMarket Interface | Aptify.Applications.Accounting.Currency Namespace


ICurrencyMarkToMarket.ICurrencyMarkToMarket.StatusUpdateEventHandler Event

This event is fired for each record processed by the ProcessOrders() method to provide both status update capabilities for the calling application/object as well as the ability to cancel the process.

event ICurrencyMarkToMarket.StatusUpdateEventHandler StatusUpdate;

Remarks

See Also

ICurrencyMarkToMarket Interface | Aptify.Applications.Accounting.Currency Namespace


ICurrencyMarkToMarket.StatusUpdateEventHandler Delegate

public delegate void ICurrencyMarkToMarket.StatusUpdateEventHandler(
Int64 OrderID,
Int64 RecordNumber,
Int64 TotalRecords,
Int32 PercentComplete,
ref Boolean& Cancel
);

Requirements

Namespace: Aptify.Applications.Accounting.Currency

Assembly: ICurrencyMarkToMarket (in ICurrencyMarkToMarket.dll)

See Also

Aptify.Applications.Accounting.Currency Namespace


ISpotRate Interface

Interface used to create plug-ins for retrieving spot rates for currency pairs

For a list of all members of this type, see ISpotRate Members.

public interface ISpotRate

Types that implement ISpotRate

Type | Description
RetrieveSpotRate | This object implements the Aptify.Framework.Applications.Currency.ISpotRate interface. The purpose of this component is to return a spot rate along with a spot rate ID to the calling application based on a currency ID and a base currency id.

Remarks

Requirements

Namespace: Aptify.Applications.Accounting.Currency

Assembly: ICurrencyRetrieval (in ICurrencyRetrieval.dll)

See Also

ISpotRate Members | Aptify.Applications.Accounting.Currency Namespace


ISpotRate Members

ISpotRate overview

Public Instance Methods

Config | Call this function before using any other method on the interface to configure the object for use
Convert | Converts Amount from the currency defined by FromCurrencyID to an amount in the currency defined by ToCurrencyID.
RetrieveCurrencySpotRate | Overloaded. Retrieves a currency spot rate based on the given input parameters
RetrieveFunctionalCurrencyTypeID | Method used to return the system-wide functional currency.

See Also

ISpotRate Interface | Aptify.Applications.Accounting.Currency Namespace


ISpotRate Methods

The methods of the ISpotRate interface are listed below. For a complete list of ISpotRate interface members, see the ISpotRate Members topic.

Public Instance Methods

Config | Call this function before using any other method on the interface to configure the object for use
Convert | Converts Amount from the currency defined by FromCurrencyID to an amount in the currency defined by ToCurrencyID.
RetrieveCurrencySpotRate | Overloaded. Retrieves a currency spot rate based on the given input parameters
RetrieveFunctionalCurrencyTypeID | Method used to return the system-wide functional currency.

See Also

ISpotRate Interface | Aptify.Applications.Accounting.Currency Namespace


ISpotRate.Config Method

Call this function before using any other method on the interface to configure the object for use

void Config(
AptifyApplication Application
);

Parameters

Application
Aptify Application Required for Use of the Object

Remarks

See Also

ISpotRate Interface | Aptify.Applications.Accounting.Currency Namespace


ISpotRate.Convert Method

Converts Amount from the currency defined by FromCurrencyID to an amount in the currency defined by ToCurrencyID.

decimal Convert(
Decimal Amount,
Int64 FromCurrencyID,
Int64 ToCurrencyID
);

Parameters

Amount
FromCurrencyID
ToCurrencyID

Return Value

Remarks

See Also

ISpotRate Interface | Aptify.Applications.Accounting.Currency Namespace


RetrieveCurrencySpotRate Method

Aptify 5.0 Software Development Kit (SDK)

ISpotRate.RetrieveCurrencySpotRate Method

Retrieves a currency spot rate based on the given input parameters

Overload List

Retrieves a currency spot rate based on the given input parameters

bool RetrieveCurrencySpotRate(DateTime,Int64,Int64,ref Int64&,ref Decimal&);

Retrieves a currency spot rate based on the given input parameters

bool RetrieveCurrencySpotRate(Int64,Int64,ref Int64&,ref Decimal&);

See Also

ISpotRate Interface | Aptify.Applications.Accounting.Currency Namespace


ISpotRate.RetrieveCurrencySpotRate Method (DateTime, Int64, Int64, Int64&, Decimal&)

Retrieves a currency spot rate based on the given input parameters

bool RetrieveCurrencySpotRate(
DateTime SpotRateDate,
Int64 CurrencyID,
Int64 BaseCurrencyID,
ref Int64& CurrencySpotRateID,
ref Decimal& SpotRate
);

Parameters

SpotRateDate
Effective Date of Spot Rate Requested
CurrencyID
Currency to get spot rate for
BaseCurrencyID
Base currency to compare CurrencyID against for the spot rate
CurrencySpotRateID
Returns the spot rate record.
SpotRate
Returns the number of units of CurrencyID per 1 unit of BaseCurrencyID

Return Value

Remarks

See Also

ISpotRate Interface | Aptify.Applications.Accounting.Currency Namespace | ISpotRate.RetrieveCurrencySpotRate Overload List


ISpotRate.RetrieveCurrencySpotRate Method (Int64, Int64, Int64&, Decimal&)

Retrieves a currency spot rate based on the given input parameters

bool RetrieveCurrencySpotRate(
Int64 CurrencyID,
Int64 BaseCurrencyID,
ref Int64& CurrencySpotRateID,
ref Decimal& SpotRate
);

Parameters

CurrencyID
Currency to get spot rate for
BaseCurrencyID
Base currency to compare CurrencyID against for the spot rate
CurrencySpotRateID
Returns the spot rate record.
SpotRate
Returns the number of units of CurrencyID per 1 unit of BaseCurrencyID

Return Value

Remarks

See Also

ISpotRate Interface | Aptify.Applications.Accounting.Currency Namespace | ISpotRate.RetrieveCurrencySpotRate Overload List


ISpotRate.RetrieveFunctionalCurrencyTypeID Method

Method used to return the system-wide functional currency.

long RetrieveFunctionalCurrencyTypeID();

Return Value

Remarks

See Also

ISpotRate Interface | Aptify.Applications.Accounting.Currency Namespace


MarkToMarketException Class

Provides an exception that can be throw to indicate errors specific to the Mark-To-Market process.

For a list of all members of this type, see MarkToMarketException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
MarkToMarketException

public class MarkToMarketException : BaseApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Accounting.Currency

Assembly: ICurrencyMarkToMarket (in ICurrencyMarkToMarket.dll)

See Also

MarkToMarketException Members | Aptify.Applications.Accounting.Currency Namespace


MarkToMarketException Members

MarkToMarketException overview

Public Instance Constructors

MarkToMarketException Overloaded. Initializes a new instance of the MarkToMarketException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from BaseApplicationException) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MarkToMarketException Class | Aptify.Applications.Accounting.Currency Namespace


MarkToMarketException Constructor

Initializes a new instance of the MarkToMarketException class.

Overload List

Initializes a new instance of the MarkToMarketException class.

public MarkToMarketException();

public MarkToMarketException(SerializationInfo,StreamingContext);

public MarkToMarketException(String);

public MarkToMarketException(String,Exception);

See Also

MarkToMarketException Class | Aptify.Applications.Accounting.Currency Namespace


MarkToMarketException Constructor ()

Initializes a new instance of the MarkToMarketException class.

public MarkToMarketException();

See Also

MarkToMarketException Class | Aptify.Applications.Accounting.Currency Namespace | MarkToMarketException Constructor Overload List


MarkToMarketException Constructor (String)

public MarkToMarketException(
String Message
);

See Also

MarkToMarketException Class | Aptify.Applications.Accounting.Currency Namespace | MarkToMarketException Constructor Overload List


MarkToMarketException Constructor (String, Exception)

public MarkToMarketException(
String Message,
Exception InnerException
);

See Also

MarkToMarketException Class | Aptify.Applications.Accounting.Currency Namespace | MarkToMarketException Constructor Overload List


MarkToMarketException Constructor (SerializationInfo, StreamingContext)

public MarkToMarketException(
SerializationInfo Info,
StreamingContext Context
);

See Also

MarkToMarketException Class | Aptify.Applications.Accounting.Currency Namespace | MarkToMarketException Constructor Overload List


MarkToMarketWizard Class

For a list of all members of this type, see MarkToMarketWizard Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
MarkToMarketWizard

public class MarkToMarketWizard : Form, IAptifyAction

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Accounting.Currency

Assembly: AptifyMarkToMarketWizard (in AptifyMarkToMarketWizard.dll)

See Also

MarkToMarketWizard Members | Aptify.Applications.Accounting.Currency Namespace


MarkToMarketWizard Members

MarkToMarketWizard overview

Public Instance Constructors

MarkToMarketWizard Constructor Initializes a new instance of the MarkToMarketWizard class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoAction | Overloaded.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetMarkToMarketPlugIn | Retrieves the plug-in that has been configured for the Mark-To-Market object.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessQualifyingRecords | Builds the list of records to be processed and then starts the process.
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetupReviewStep |
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

MarkToMarketWizard Class | Aptify.Applications.Accounting.Currency Namespace


MarkToMarketWizard Constructor

Initializes a new instance of the MarkToMarketWizard class.

public MarkToMarketWizard();

See Also

MarkToMarketWizard Class | Aptify.Applications.Accounting.Currency Namespace


MarkToMarketWizard Methods

The methods of the MarkToMarketWizard class are listed below. For a complete list of MarkToMarketWizard class members, see the MarkToMarketWizard Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoAction | Overloaded.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetMarkToMarketPlugIn | Retrieves the plug-in that has been configured for the Mark-To-Market object.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessQualifyingRecords | Builds the list of records to be processed and then starts the process.
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetupReviewStep |
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

MarkToMarketWizard Class | Aptify.Applications.Accounting.Currency Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

MarkToMarketWizard.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

MarkToMarketWizard Class | Aptify.Applications.Accounting.Currency Namespace


MarkToMarketWizard.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

MarkToMarketWizard Class | Aptify.Applications.Accounting.Currency Namespace | MarkToMarketWizard.Dispose Overload List


DoAction Method

Aptify 5.0 Software Development Kit (SDK)

MarkToMarketWizard.DoAction Method

Overload List

public void DoAction(AptifyApplication,Int64);

public void DoAction(AptifyApplication,Int64,Int64);

public void DoAction(AptifyApplication,Int64,Int64,params Object[]);

public void DoAction(AptifyApplication,Int64,params String[]);

See Also

MarkToMarketWizard Class | Aptify.Applications.Accounting.Currency Namespace


MarkToMarketWizard.DoAction Method (AptifyApplication, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID
);

Implements

IAptifyAction.

See Also

MarkToMarketWizard Class | Aptify.Applications.Accounting.Currency Namespace | MarkToMarketWizard.DoAction Overload List


MarkToMarketWizard.DoAction Method (AptifyApplication, Int64, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID
);

Implements

IAptifyAction.

See Also

MarkToMarketWizard Class | Aptify.Applications.Accounting.Currency Namespace | MarkToMarketWizard.DoAction Overload List


MarkToMarketWizard.DoAction Method (AptifyApplication, Int64, Int64, Object[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID,
params Object[] SelectedItems
);

Implements

IAptifyAction.

See Also

MarkToMarketWizard Class | Aptify.Applications.Accounting.Currency Namespace | MarkToMarketWizard.DoAction Overload List


MarkToMarketWizard.DoAction Method (AptifyApplication, Int64, String[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
params String[] SelectedItems
);

Implements

IAptifyAction.

See Also

MarkToMarketWizard Class | Aptify.Applications.Accounting.Currency Namespace | MarkToMarketWizard.DoAction Overload List


MarkToMarketWizard.GetMarkToMarketPlugIn Method

Retrieves the plug-in that has been configured for the Mark-To-Market object.

protected virtual void GetMarkToMarketPlugIn();

Remarks

If it is found, then it should instantiate the object and configure it.

See Also

MarkToMarketWizard Class | Aptify.Applications.Accounting.Currency Namespace


MarkToMarketWizard.ProcessQualifyingRecords Method

Builds the list of records to be processed and then starts the process.

protected virtual void ProcessQualifyingRecords();

Remarks

See Also

MarkToMarketWizard Class | Aptify.Applications.Accounting.Currency Namespace


MarkToMarketWizard.SetupReviewStep Method

protected virtual void SetupReviewStep();

See Also

MarkToMarketWizard Class | Aptify.Applications.Accounting.Currency Namespace


RetrieveSpotRate Class

This object implements the Aptify.Framework.Applications.Currency.ISpotRate interface. The purpose of this component is to return a spot rate along with a spot rate ID to the calling application based on a currency ID and a base currency id.

For a list of all members of this type, see RetrieveSpotRate Members.

System.Object
RetrieveSpotRate

public class RetrieveSpotRate : ISpotRate

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Written by Ravi Nagarajan, June 6, 2002. Modified by Ravi Nagarajan, June 14, 2002. DAL/ADO Conversion, Ravi Nagarajan, July 1, 2002. Removed Ad Hoc SQL code, Ravi Nagarajan, July 1, 2002. Ported to Aptify 4.0/.NET - Amith Nagarajan - October 6, 2005 An Optimization Note: We have some minor inefficiencies in this code. We are checking the dates on the three possible mechanisms for retrieving spot rates: Direct, Indirect, and Cross. However, after determining which one to use, we call essentially the same query again. As a result, we use about 4 SQL round trips rather than a possible 3 round trips. This could be optimized in the future, but at this point, the 1 additional round trip didn't appear to be material enough to worry about. RN 7/2/2002.

Requirements

Namespace: Aptify.Applications.Accounting.Currency

Assembly: CurrencyRetrieval (in CurrencyRetrieval.dll)

See Also

RetrieveSpotRate Members | Aptify.Applications.Accounting.Currency Namespace


RetrieveSpotRate Members

RetrieveSpotRate overview

Public Instance Constructors

RetrieveSpotRate Constructor Initializes a new instance of the RetrieveSpotRate class.

Public Instance Methods

Config |
Convert | Converts Amount from the currency defined by FromCurrencyID to an amount in the currency defined by ToCurrencyID. Return value is rounded to the appropriate number of digits after the decimal place based on the Currency Type information stored for the Currency Type defined by ToCurrencyID.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
RetrieveCurrencySpotRate | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RetrieveSpotRate Class | Aptify.Applications.Accounting.Currency Namespace


RetrieveSpotRate Constructor

Initializes a new instance of the RetrieveSpotRate class.

public RetrieveSpotRate();

See Also

RetrieveSpotRate Class | Aptify.Applications.Accounting.Currency Namespace


RetrieveSpotRate Methods

The methods of the RetrieveSpotRate class are listed below. For a complete list of RetrieveSpotRate class members, see the RetrieveSpotRate Members topic.

Public Instance Methods

Config |
Convert | Converts Amount from the currency defined by FromCurrencyID to an amount in the currency defined by ToCurrencyID. Return value is rounded to the appropriate number of digits after the decimal place based on the Currency Type information stored for the Currency Type defined by ToCurrencyID.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
RetrieveCurrencySpotRate | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RetrieveSpotRate Class | Aptify.Applications.Accounting.Currency Namespace


RetrieveSpotRate.Config Method

public virtual void Config(
AptifyApplication Application
);

Implements

ISpotRate.

See Also

RetrieveSpotRate Class | Aptify.Applications.Accounting.Currency Namespace


RetrieveSpotRate.Convert Method

Converts Amount from the currency defined by FromCurrencyID to an amount in the currency defined by ToCurrencyID. Return value is rounded to the appropriate number of digits after the decimal place based on the Currency Type information stored for the Currency Type defined by ToCurrencyID.

public decimal Convert(
Decimal Amount,
Int64 FromCurrencyID,
Int64 ToCurrencyID
);

Parameters

Amount
FromCurrencyID
ToCurrencyID

Return Value

Implements

ISpotRate.

Remarks

See Also

RetrieveSpotRate Class | Aptify.Applications.Accounting.Currency Namespace


RetrieveCurrencySpotRate Method

Aptify 5.0 Software Development Kit (SDK)

RetrieveSpotRate.RetrieveCurrencySpotRate Method

Overload List

public virtual bool RetrieveCurrencySpotRate(DateTime,Int64,Int64,ref Int64&,ref Decimal&);

public bool RetrieveCurrencySpotRate(Int64,Int64,ref Int64&,ref Decimal&);

See Also

RetrieveSpotRate Class | Aptify.Applications.Accounting.Currency Namespace


RetrieveSpotRate.RetrieveCurrencySpotRate Method (DateTime, Int64, Int64, Int64&, Decimal&)

public virtual bool RetrieveCurrencySpotRate(
DateTime SpotRateDate,
Int64 CurrencyID,
Int64 BaseCurrencyID,
ref Int64& CurrencySpotRateID,
ref Decimal& SpotRate
);

Implements

ISpotRate.

See Also

RetrieveSpotRate Class | Aptify.Applications.Accounting.Currency Namespace | RetrieveSpotRate.RetrieveCurrencySpotRate Overload List


RetrieveSpotRate.RetrieveCurrencySpotRate Method (Int64, Int64, Int64&, Decimal&)

public bool RetrieveCurrencySpotRate(
Int64 CurrencyID,
Int64 BaseCurrencyID,
ref Int64& CurrencySpotRateID,
ref Decimal& SpotRate
);

Implements

ISpotRate.

See Also

RetrieveSpotRate Class | Aptify.Applications.Accounting.Currency Namespace | RetrieveSpotRate.RetrieveCurrencySpotRate Overload List


Aptify.Applications.Accounting.SchedTransGroupsLayout

Aptify 5.0 Software Development Kit (SDK)

Aptify.Applications.Accounting.SchedTransGroupsLayout Namespace

This namespace defines the form template for the Scheduled Transaction Groups entity.

Namespace hierarchy

Classes

Class | Description
ScheduleTransactionsGroupsLayout |


ScheduleTransactionsGroupsLayout Class

For a list of all members of this type, see ScheduleTransactionsGroupsLayout Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
ScheduleTransactionsGroupsLayout

public class ScheduleTransactionsGroupsLayout : FormTemplateLayout

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Accounting.SchedTransGroupsLayout

Assembly: SchedTransGroupsLayout (in SchedTransGroupsLayout.dll)

See Also

ScheduleTransactionsGroupsLayout Members | Aptify.Applications.Accounting.SchedTransGroupsLayout Namespace


ScheduleTransactionsGroupsLayout Members

ScheduleTransactionsGroupsLayout overview

Public Instance Constructors

ScheduleTransactionsGroupsLayout Constructor Initializes a new instance of the ScheduleTransactionsGroupsLayout class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ScheduleTransactionsGroupsLayout Class | Aptify.Applications.Accounting.SchedTransGroupsLayout Namespace


ScheduleTransactionsGroupsLayout Constructor

Initializes a new instance of the ScheduleTransactionsGroupsLayout class.

public ScheduleTransactionsGroupsLayout();

See Also

ScheduleTransactionsGroupsLayout Class | Aptify.Applications.Accounting.SchedTransGroupsLayout Namespace


ScheduleTransactionsGroupsLayout Methods

The methods of the ScheduleTransactionsGroupsLayout class are listed below. For a complete list of ScheduleTransactionsGroupsLayout class members, see the ScheduleTransactionsGroupsLayout Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ScheduleTransactionsGroupsLayout Class | Aptify.Applications.Accounting.SchedTransGroupsLayout Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

ScheduleTransactionsGroupsLayout.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

ScheduleTransactionsGroupsLayout Class | Aptify.Applications.Accounting.SchedTransGroupsLayout Namespace


ScheduleTransactionsGroupsLayout.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

ScheduleTransactionsGroupsLayout Class | Aptify.Applications.Accounting.SchedTransGroupsLayout Namespace | ScheduleTransactionsGroupsLayout.Dispose Overload List


ScheduleTransactionsGroupsLayout.OnFormTemplateLoaded Method

protected override void OnFormTemplateLoaded(
FormTemplateLayout.FormTemplateLoadedEventArgs e
);

See Also

ScheduleTransactionsGroupsLayout Class | Aptify.Applications.Accounting.SchedTransGroupsLayout Namespace


ScheduleTransactionsGroupsLayout.OnTransferDataToObject Method

protected override void OnTransferDataToObject(
ref Boolean& Cancel
);

Implements

IFormComponent.

See Also

ScheduleTransactionsGroupsLayout Class | Aptify.Applications.Accounting.SchedTransGroupsLayout Namespace


Aptify.Applications.Accounting.WindowsControls

Aptify 5.0 Software Development Kit (SDK)

Aptify.Applications.Accounting.WindowsControls Namespace

This namespace defines the Windows Control for the standard payment types and the form template for the Standing Orders entity.

Namespace hierarchy

Classes

Class | Description
ACH |
Cash |
Check |
CreditCard |
CreditMemo |
PaymentControl | This class is used as the base class for all of the payment-type specific controls such as Check, Credit Card, etc.
PaymentInfoControl | This class provides a generic payment information view/edit capability and is designed to be used anywhere where the Payment Information entity is used as an embedded object in any other entity.
PurchaseOrder |
StandingOrderLayout | Provides presentation layer logic used for Standing Orders Entity Top-Level records

Enumerations

Enumeration | Description
CreditCard.AccountNumberMaskingTypes |
PaymentInfoControl.BasePaymentType |
PaymentInfoControl.TypesToShow |


ACH Class

For a list of all members of this type, see ACH Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
PaymentControl
ACH

public class ACH : PaymentControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Accounting.WindowsControls

Assembly: PaymentInfoControl (in PaymentInfoControl.dll)

See Also

ACH Members | Aptify.Applications.Accounting.WindowsControls Namespace


ACH Members

ACH overview

Public Instance Constructors

ACH Constructor Initializes a new instance of the ACH class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Control (inherited from PaymentControl) |
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateContext (inherited from PaymentControl) |
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TransactionControlsVisible (inherited from PaymentControl) | Gets or sets the Visible property of transaction specific controls.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ClearControls |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
FormComponentConfig |
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from PaymentControl) |
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from PaymentControl) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from PaymentControl) | Overloaded.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
TransferDataToObject (inherited from PaymentControl) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from PaymentControl) |
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from PaymentControl) |
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from PaymentControl) |
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from PaymentControl) |
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from PaymentControl) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

m_bTransactionControlsVisible (inherited from PaymentControl)
m_oApp (inherited from PaymentControl)
m_oUserCredential (inherited from PaymentControl)

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
ConfigChildControls (inherited from PaymentControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnValueChanged (inherited from PaymentControl) |
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetTransactionControls (inherited from PaymentControl) |
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ACH Class | Aptify.Applications.Accounting.WindowsControls Namespace


ACH Constructor

Initializes a new instance of the ACH class.

public ACH();

See Also

ACH Class | Aptify.Applications.Accounting.WindowsControls Namespace


ACH Methods

The methods of the ACH class are listed below. For a complete list of ACH class members, see the ACH Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ClearControls |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
FormComponentConfig |
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from PaymentControl) |
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from PaymentControl) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from PaymentControl) | Overloaded.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
TransferDataToObject (inherited from PaymentControl) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
ConfigChildControls (inherited from PaymentControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnValueChanged (inherited from PaymentControl) |
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetTransactionControls (inherited from PaymentControl) |
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ACH Class | Aptify.Applications.Accounting.WindowsControls Namespace


ACH.ClearControls Method

public override void ClearControls();

See Also

ACH Class | Aptify.Applications.Accounting.WindowsControls Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

ACH.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

ACH Class | Aptify.Applications.Accounting.WindowsControls Namespace


ACH.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

ACH Class | Aptify.Applications.Accounting.WindowsControls Namespace | ACH.Dispose Overload List


ACH.FormComponentConfig Method

public override void FormComponentConfig(
AptifyFormTemplateContext FormTemplateContext
);

Implements

IFormComponent.

See Also

ACH Class | Aptify.Applications.Accounting.WindowsControls Namespace


Cash Class

For a list of all members of this type, see Cash Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
PaymentControl
Cash

public class Cash : PaymentControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Accounting.WindowsControls

Assembly: PaymentInfoControl (in PaymentInfoControl.dll)

See Also

Cash Members | Aptify.Applications.Accounting.WindowsControls Namespace


Cash Members

Cash overview

Public Instance Constructors

Cash Constructor Initializes a new instance of the Cash class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Control (inherited from PaymentControl) |
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateContext (inherited from PaymentControl) |
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TransactionControlsVisible (inherited from PaymentControl) | Gets or sets the Visible property of transaction specific controls.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ClearControls |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
FormComponentConfig (inherited from PaymentControl) | If this component is being used for an embedded field, provide the DataField input property to the Form Template Part.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from PaymentControl) |
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from PaymentControl) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from PaymentControl) | Overloaded.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
TransferDataToObject (inherited from PaymentControl) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from PaymentControl) |
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from PaymentControl) |
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from PaymentControl) |
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from PaymentControl) |
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from PaymentControl) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

m_bTransactionControlsVisible (inherited from PaymentControl)
m_oApp (inherited from PaymentControl)
m_oUserCredential (inherited from PaymentControl)

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
ConfigChildControls (inherited from PaymentControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnValueChanged (inherited from PaymentControl) |
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetTransactionControls (inherited from PaymentControl) |
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

Cash Class | Aptify.Applications.Accounting.WindowsControls Namespace


Cash Constructor

Initializes a new instance of the Cash class.

public Cash();

See Also

Cash Class | Aptify.Applications.Accounting.WindowsControls Namespace


Cash Methods

The methods of the Cash class are listed below. For a complete list of Cash class members, see the Cash Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ClearControls |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
FormComponentConfig (inherited from PaymentControl) | If this component is being used for an embedded field, provide the DataField input property to the Form Template Part.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from PaymentControl) |
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from PaymentControl) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from PaymentControl) | Overloaded.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
TransferDataToObject (inherited from PaymentControl) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
ConfigChildControls (inherited from PaymentControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnValueChanged (inherited from PaymentControl) |
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetTransactionControls (inherited from PaymentControl) |
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

Cash Class | Aptify.Applications.Accounting.WindowsControls Namespace


Cash.ClearControls Method

public override void ClearControls();

See Also

Cash Class | Aptify.Applications.Accounting.WindowsControls Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

Cash.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

Cash Class | Aptify.Applications.Accounting.WindowsControls Namespace


Cash.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

Cash Class | Aptify.Applications.Accounting.WindowsControls Namespace | Cash.Dispose Overload List


Check Class

For a list of all members of this type, see Check Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
PaymentControl
Check

public class Check : PaymentControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Accounting.WindowsControls

Assembly: PaymentInfoControl (in PaymentInfoControl.dll)

See Also

Check Members | Aptify.Applications.Accounting.WindowsControls Namespace


Check Members

Check overview

Public Instance Constructors

Check Constructor Initializes a new instance of the Check class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Control (inherited from PaymentControl) |
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateContext (inherited from PaymentControl) |
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TransactionControlsVisible (inherited from PaymentControl) | Gets or sets the Visible property of transaction specific controls.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ClearControls |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
FormComponentConfig (inherited from PaymentControl) | If this component is being used for an embedded field, provide the DataField input property to the Form Template Part.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from PaymentControl) |
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from PaymentControl) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from PaymentControl) | Overloaded.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
TransferDataToObject (inherited from PaymentControl) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from PaymentControl) |
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from PaymentControl) |
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from PaymentControl) |
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from PaymentControl) |
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from PaymentControl) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

m_bTransactionControlsVisible (inherited from PaymentControl)
m_oApp (inherited from PaymentControl)
m_oUserCredential (inherited from PaymentControl)

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
ConfigChildControls (inherited from PaymentControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnValueChanged (inherited from PaymentControl) |
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetTransactionControls (inherited from PaymentControl) |
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

Check Class | Aptify.Applications.Accounting.WindowsControls Namespace


Check Constructor

Initializes a new instance of the Check class.

public Check();

See Also

Check Class | Aptify.Applications.Accounting.WindowsControls Namespace


Check Methods

The methods of the Check class are listed below. For a complete list of Check class members, see the Check Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ClearControls |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
FormComponentConfig (inherited from PaymentControl) | If this component is being used for an embedded field, provide the DataField input property to the Form Template Part.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from PaymentControl) |
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from PaymentControl) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from PaymentControl) | Overloaded.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
TransferDataToObject (inherited from PaymentControl) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
ConfigChildControls (inherited from PaymentControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnValueChanged (inherited from PaymentControl) |
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetTransactionControls (inherited from PaymentControl) |
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

Check Class | Aptify.Applications.Accounting.WindowsControls Namespace


Check.ClearControls Method

public override void ClearControls();

See Also

Check Class | Aptify.Applications.Accounting.WindowsControls Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

Check.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

Check Class | Aptify.Applications.Accounting.WindowsControls Namespace


Check.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

Check Class | Aptify.Applications.Accounting.WindowsControls Namespace | Check.Dispose Overload List


CreditCard Class

For a list of all members of this type, see CreditCard Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
PaymentControl
CreditCard

public class CreditCard : PaymentControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Accounting.WindowsControls

Assembly: PaymentInfoControl (in PaymentInfoControl.dll)

See Also

CreditCard Members | Aptify.Applications.Accounting.WindowsControls Namespace


CreditCard Members

CreditCard overview

Public Instance Constructors

CreditCard Constructor Initializes a new instance of the CreditCard class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
CCSecurityCode |
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Control (inherited from PaymentControl) |
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateContext (inherited from PaymentControl) |
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TransactionControlsVisible (inherited from PaymentControl) | Gets or sets the Visible property of transaction specific controls.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ClearControls |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
FormComponentConfig |
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from PaymentControl) |
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from PaymentControl) | Overloaded.
ShowHideAccountNumber | Overloaded. Method used to display the account number or the masked account number. The default is to utilize encryption to determine if masking should be displayed.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
TransferDataToObject (inherited from PaymentControl) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from PaymentControl) |
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from PaymentControl) |
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from PaymentControl) |
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from PaymentControl) |
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from PaymentControl) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

m_bCardEncrypted
m_bTransactionControlsVisible (inherited from PaymentControl)
m_oApp (inherited from PaymentControl)
m_oUserCredential (inherited from PaymentControl)

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
ConfigChildControls (inherited from PaymentControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnValueChanged |
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetTransactionControls |
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CreditCard Class | Aptify.Applications.Accounting.WindowsControls Namespace


CreditCard Constructor

Initializes a new instance of the CreditCard class.

public CreditCard();

See Also

CreditCard Class | Aptify.Applications.Accounting.WindowsControls Namespace


CreditCard Fields

The fields of the CreditCard class are listed below. For a complete list of CreditCard class members, see the CreditCard Members topic.

Protected Instance Fields

m_bCardEncrypted
m_bTransactionControlsVisible (inherited from PaymentControl)
m_oApp (inherited from PaymentControl)
m_oUserCredential (inherited from PaymentControl)

See Also

CreditCard Class | Aptify.Applications.Accounting.WindowsControls Namespace


CreditCard.m_bCardEncrypted Field

protected m_bCardEncrypted m_bCardEncrypted;

See Also

CreditCard Class | Aptify.Applications.Accounting.WindowsControls Namespace


CreditCard Properties

The properties of the CreditCard class are listed below. For a complete list of CreditCard class members, see the CreditCard Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
CCSecurityCode |
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Control (inherited from PaymentControl) |
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateContext (inherited from PaymentControl) |
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TransactionControlsVisible (inherited from PaymentControl) | Gets or sets the Visible property of transaction specific controls.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

CreditCard Class | Aptify.Applications.Accounting.WindowsControls Namespace


CCSecurityCode Property

Aptify 5.0 Software Development Kit (SDK)

CreditCard.CCSecurityCode Property

public String CCSecurityCode {get; set;}

See Also

CreditCard Class | Aptify.Applications.Accounting.WindowsControls Namespace


CreditCard Methods

The methods of the CreditCard class are listed below. For a complete list of CreditCard class members, see the CreditCard Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ClearControls |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
FormComponentConfig |
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from PaymentControl) |
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from PaymentControl) | Overloaded.
ShowHideAccountNumber | Overloaded. Method used to display the account number or the masked account number. The default is to utilize encryption to determine if masking should be displayed.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
TransferDataToObject (inherited from PaymentControl) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
ConfigChildControls (inherited from PaymentControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnValueChanged |
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetTransactionControls |
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CreditCard Class | Aptify.Applications.Accounting.WindowsControls Namespace


CreditCard.ClearControls Method

public override void ClearControls();

See Also

CreditCard Class | Aptify.Applications.Accounting.WindowsControls Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

CreditCard.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

CreditCard Class | Aptify.Applications.Accounting.WindowsControls Namespace


CreditCard.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

CreditCard Class | Aptify.Applications.Accounting.WindowsControls Namespace | CreditCard.Dispose Overload List


CreditCard.FormComponentConfig Method

public override void FormComponentConfig(
AptifyFormTemplateContext FormTemplateContext
);

Implements

IFormComponent.

See Also

CreditCard Class | Aptify.Applications.Accounting.WindowsControls Namespace


CreditCard.OnValueChanged Method

protected override void OnValueChanged(
Object Sender,
Object OldValue,
Object NewValue,
Boolean bCancel
);

See Also

CreditCard Class | Aptify.Applications.Accounting.WindowsControls Namespace


CreditCard.Refresh Method

public override void Refresh();

Implements

IFormComponent.

See Also

CreditCard Class | Aptify.Applications.Accounting.WindowsControls Namespace


CreditCard.SetTransactionControls Method

protected override bool SetTransactionControls(
Boolean bVisible
);

See Also

CreditCard Class | Aptify.Applications.Accounting.WindowsControls Namespace


ShowHideAccountNumber Method

Aptify 5.0 Software Development Kit (SDK)

CreditCard.ShowHideAccountNumber Method

Overload List

public virtual void ShowHideAccountNumber();

Method used to display the account number or the masked account number. The default is to utilize encryption to determine if masking should be displayed.

public virtual void ShowHideAccountNumber(CreditCard.AccountNumberMaskingTypes);

See Also

CreditCard Class | Aptify.Applications.Accounting.WindowsControls Namespace


CreditCard.ShowHideAccountNumber Method ()

public virtual void ShowHideAccountNumber();

See Also

CreditCard Class | Aptify.Applications.Accounting.WindowsControls Namespace | CreditCard.ShowHideAccountNumber Overload List


CreditCard.ShowHideAccountNumber Method (AccountNumberMaskingTypes)

Method used to display the account number or the masked account number. The default is to utilize encryption to determine if masking should be displayed.

public virtual void ShowHideAccountNumber(
CreditCard.AccountNumberMaskingTypes MaskingType
);

Parameters

MaskingType
Parameter used to determine the behavior desired.

Remarks

See Also

CreditCard Class | Aptify.Applications.Accounting.WindowsControls Namespace | CreditCard.ShowHideAccountNumber Overload List


CreditCard.AccountNumberMaskingTypes Enumeration

public enum CreditCard.AccountNumberMaskingTypes

Members

Member Name | Description
UseDefault |
Mask |
NoMask |

Requirements

Namespace: Aptify.Applications.Accounting.WindowsControls

Assembly: PaymentInfoControl (in PaymentInfoControl.dll)

See Also

Aptify.Applications.Accounting.WindowsControls Namespace


CreditMemo Class

For a list of all members of this type, see CreditMemo Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
PaymentControl
CreditMemo

public class CreditMemo : PaymentControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Accounting.WindowsControls

Assembly: PaymentInfoControl (in PaymentInfoControl.dll)

See Also

CreditMemo Members | Aptify.Applications.Accounting.WindowsControls Namespace


CreditMemo Members

CreditMemo overview

Public Instance Constructors

CreditMemo Constructor Initializes a new instance of the CreditMemo class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Control (inherited from PaymentControl) |
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateContext (inherited from PaymentControl) |
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TransactionControlsVisible (inherited from PaymentControl) | Gets or sets the Visible property of transaction specific controls.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ClearControls |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
FormComponentConfig |
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValidateCreditMemoAttribute |
Hide (inherited from PaymentControl) |
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetSQLFilter |
Show (inherited from PaymentControl) | Overloaded.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
TransferDataToObject (inherited from PaymentControl) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from PaymentControl) |
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from PaymentControl) |
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from PaymentControl) |
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from PaymentControl) |
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from PaymentControl) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

m_bTransactionControlsVisible (inherited from PaymentControl)
m_oApp (inherited from PaymentControl)
m_oUserCredential (inherited from PaymentControl)

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
ConfigChildControls (inherited from PaymentControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnValueChanged (inherited from PaymentControl) |
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetTransactionControls (inherited from PaymentControl) |
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CreditMemo Class | Aptify.Applications.Accounting.WindowsControls Namespace


CreditMemo Constructor

Initializes a new instance of the CreditMemo class.

public CreditMemo();

See Also

CreditMemo Class | Aptify.Applications.Accounting.WindowsControls Namespace


CreditMemo Methods

The methods of the CreditMemo class are listed below. For a complete list of CreditMemo class members, see the CreditMemo Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ClearControls |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
FormComponentConfig |
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValidateCreditMemoAttribute |
Hide (inherited from PaymentControl) |
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetSQLFilter |
Show (inherited from PaymentControl) | Overloaded.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
TransferDataToObject (inherited from PaymentControl) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
ConfigChildControls (inherited from PaymentControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnValueChanged (inherited from PaymentControl) |
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetTransactionControls (inherited from PaymentControl) |
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CreditMemo Class | Aptify.Applications.Accounting.WindowsControls Namespace


CreditMemo.ClearControls Method

public override void ClearControls();

See Also

CreditMemo Class | Aptify.Applications.Accounting.WindowsControls Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

CreditMemo.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

CreditMemo Class | Aptify.Applications.Accounting.WindowsControls Namespace


CreditMemo.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

CreditMemo Class | Aptify.Applications.Accounting.WindowsControls Namespace | CreditMemo.Dispose Overload List


CreditMemo.FormComponentConfig Method

public override void FormComponentConfig(
AptifyFormTemplateContext FormTemplateContext
);

Implements

IFormComponent.

See Also

CreditMemo Class | Aptify.Applications.Accounting.WindowsControls Namespace


CreditMemo.GetValidateCreditMemoAttribute Method

public bool GetValidateCreditMemoAttribute();

See Also

CreditMemo Class | Aptify.Applications.Accounting.WindowsControls Namespace


CreditMemo.Refresh Method

public override void Refresh();

Implements

IFormComponent.

See Also

CreditMemo Class | Aptify.Applications.Accounting.WindowsControls Namespace


CreditMemo.SetSQLFilter Method

public virtual void SetSQLFilter(
Int32 BillToID,
Int32 BillToCompanyID
);

See Also

CreditMemo Class | Aptify.Applications.Accounting.WindowsControls Namespace


PaymentControl Class

This class is used as the base class for all of the payment-type specific controls such as Check, Credit Card, etc.

For a list of all members of this type, see PaymentControl Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
PaymentControl
Derived types

public class PaymentControl : UserControl, IFormComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Accounting.WindowsControls

Assembly: PaymentInfoControl (in PaymentInfoControl.dll)

See Also

PaymentControl Members | Aptify.Applications.Accounting.WindowsControls Namespace


PaymentControl Members

PaymentControl overview

Public Instance Constructors

PaymentControl Constructor Initializes a new instance of the PaymentControl class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Control |
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateContext |
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TransactionControlsVisible | Gets or sets the Visible property of transaction specific controls.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ClearControls |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
FormComponentConfig | If this component is being used for an embedded field, provide the DataField input property to the Form Template Part.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide |
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show | Overloaded.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
TransferDataToObject |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click |
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick |
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus |
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus |
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

m_bTransactionControlsVisible
m_oApp
m_oUserCredential

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
ConfigChildControls |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from ContainerControl) | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnValueChanged |
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetTransactionControls |
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

PaymentControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


PaymentControl Constructor

Initializes a new instance of the PaymentControl class.

public PaymentControl();

See Also

PaymentControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


PaymentControl Fields

The fields of the PaymentControl class are listed below. For a complete list of PaymentControl class members, see the PaymentControl Members topic.

Protected Instance Fields

m_bTransactionControlsVisible
m_oApp
m_oUserCredential

See Also

PaymentControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


PaymentControl.m_bTransactionControlsVisible Field

protected m_bTransactionControlsVisible m_bTransactionControlsVisible;

See Also

PaymentControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


PaymentControl.m_oApp Field

protected m_oApp m_oApp;

See Also

PaymentControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


PaymentControl.m_oUserCredential Field

protected m_oUserCredential m_oUserCredential;

See Also

PaymentControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


PaymentControl Properties

The properties of the PaymentControl class are listed below. For a complete list of PaymentControl class members, see the PaymentControl Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Control |
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateContext |
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TransactionControlsVisible | Gets or sets the Visible property of transaction specific controls.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

PaymentControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


Control Property

Aptify 5.0 Software Development Kit (SDK)

PaymentControl.Control Property

public virtual Control Control {get;}

Implements

IFormComponent.

See Also

PaymentControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


FormTemplateContext Property

Aptify 5.0 Software Development Kit (SDK)

PaymentControl.FormTemplateContext Property

public virtual AptifyFormTemplateContext FormTemplateContext {get;}

Implements

IFormComponent.

See Also

PaymentControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


TransactionControlsVisible Property

Aptify 5.0 Software Development Kit (SDK)

PaymentControl.TransactionControlsVisible Property

Gets or sets the Visible property of transaction specific controls.

public Boolean TransactionControlsVisible {get; set;}

Property Value

Remarks

See Also

PaymentControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


PaymentControl Methods

The methods of the PaymentControl class are listed below. For a complete list of PaymentControl class members, see the PaymentControl Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ClearControls |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
FormComponentConfig | If this component is being used for an embedded field, provide the DataField input property to the Form Template Part.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide |
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show | Overloaded.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
TransferDataToObject |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
ConfigChildControls |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from ContainerControl) | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnValueChanged |
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetTransactionControls |
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

PaymentControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


PaymentControl.ClearControls Method

public virtual void ClearControls();

See Also

PaymentControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


PaymentControl.ConfigChildControls Method

protected virtual void ConfigChildControls(
Control ParentControl,
AptifyFormTemplateContext FormTemplateContext
);

See Also

PaymentControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


PaymentControl.FormComponentConfig Method

If this component is being used for an embedded field, provide the DataField input property to the Form Template Part.

public virtual void FormComponentConfig(
AptifyFormTemplateContext FormTemplateContext
);

Parameters

FormTemplateContext

Implements

IFormComponent.

Remarks

See Also

PaymentControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


PaymentControl.Hide Method

new public virtual void Hide();

Implements

IFormComponent.

See Also

PaymentControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


PaymentControl.OnValueChanged Method

protected virtual void OnValueChanged(
Object Sender,
Object OldValue,
Object NewValue,
Boolean bCancel
);

See Also

PaymentControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


PaymentControl.Refresh Method

public override void Refresh();

Implements

IFormComponent.

See Also

PaymentControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


PaymentControl.SetTransactionControls Method

protected virtual bool SetTransactionControls(
Boolean bVisible
);

See Also

PaymentControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


Show Method

Aptify 5.0 Software Development Kit (SDK)

PaymentControl.Show Method

Overload List

new public virtual void Show();

public virtual void Show(Boolean);

See Also

PaymentControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


PaymentControl.Show Method ()

new public virtual void Show();

Implements

IFormComponent.

See Also

PaymentControl Class | Aptify.Applications.Accounting.WindowsControls Namespace | PaymentControl.Show Overload List


PaymentControl.Show Method (Boolean)

public virtual void Show(
Boolean Refresh
);

Implements

IFormComponent.

See Also

PaymentControl Class | Aptify.Applications.Accounting.WindowsControls Namespace | PaymentControl.Show Overload List


PaymentControl.TransferDataToObject Method

public virtual void TransferDataToObject(
ref Boolean& Cancel
);

Implements

IFormComponent.

See Also

PaymentControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


PaymentControl Events

The events of the PaymentControl class are listed below. For a complete list of PaymentControl class members, see the PaymentControl Members topic.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click |
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick |
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus |
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus |
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

PaymentControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


PaymentControl.IFormComponent.ClickEventHandler Event

public event IFormComponent.ClickEventHandler Click;

Implements

IFormComponent.

See Also

PaymentControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


PaymentControl.IFormComponent.DoubleClickEventHandler Event

public event IFormComponent.DoubleClickEventHandler DoubleClick;

Implements

IFormComponent.

See Also

PaymentControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


PaymentControl.IFormComponent.GotFocusEventHandler Event

public event IFormComponent.GotFocusEventHandler GotFocus;

Implements

IFormComponent.

See Also

PaymentControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


PaymentControl.IFormComponent.LostFocusEventHandler Event

public event IFormComponent.LostFocusEventHandler LostFocus;

Implements

IFormComponent.

See Also

PaymentControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


PaymentControl.IFormComponent.ValueChangedEventHandler Event

public event IFormComponent.ValueChangedEventHandler ValueChanged;

Implements

IFormComponent.

See Also

PaymentControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


PaymentInfoControl Class

This class provides a generic payment information view/edit capability and is designed to be used anywhere where the Payment Information entity is used as an embedded object in any other entity.

For a list of all members of this type, see PaymentInfoControl Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
PaymentInfoControl

public class PaymentInfoControl : UserControl, IFormComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Accounting.WindowsControls

Assembly: PaymentInfoControl (in PaymentInfoControl.dll)

See Also

PaymentInfoControl Members | Aptify.Applications.Accounting.WindowsControls Namespace


PaymentInfoControl Members

PaymentInfoControl overview

Public Instance Constructors

PaymentInfoControl Constructor Initializes a new instance of the PaymentInfoControl class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Control |
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CreditCardSecurityCode |
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateContext |
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PaymentTypeEnabled | Gets or sets the enabled property of the Payment Type combo box.
PaymentTypesToShow |
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TransactionControlsVisible | Gets or sets the Visible property of transaction specific controls.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
FormComponentConfig |
GetBasePaymentType | This utility method is used to get the base payment type of any given Payment Type ID provided as a parameter.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValidateCreditMemoAttribute |
Hide |
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LoadSavedPaymentMethods | Overloaded.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetSQLFilter |
Show | Overloaded.
ShowHideAccountNumber |
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
TransferDataToObject |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click |
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick |
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus |
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus |
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

m_iBillToCompanyID
m_iBillToID
m_oACH
m_oCash
m_oCheck
m_oCreditCard
m_oCreditMemo
m_oPO

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
dbcPaymentType |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
PaymentTypeTextBox |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl)
ApplySkin
ConfigChildControls
ConfigurePaymentTypeDisplay
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
GetTypeSpecificAttributes
GetTypeSpecificControl
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
LoadTypeSpecificControls | This method is responsible for loading up instances of the type-specific controls which are Check (which includes Refund Voucher), Credit Card, Credit Memo and Purchase Order. These four base payment types are used within other payment types and the PaymentInfoControl will load up each one of these as required based on the payment type being shown to the user for a given record. In order to allow for easy sub-classing of these four different controls, Entity Attributes in the Payment Information entity are used to specify the class, object repository location and assembly names for each of the four types. The classes for Check, CreditCard, PurchaseOrder and CreditMemo must inherit from the respective base classes defined herein. The Entity Attributes used are as follows: Check, Refund Voucher ----- Class - CheckClass Object - CheckObject Assembly - CheckAssembly Credit Card ----------- Class - CreditCardClass Object - CreditCardObject Assembly - CreditCardAssembly Credit Memo ----------- Class - CreditMemoClass Object - CreditMemoObject Assembly - CreditMemoAssembly Purchase Order -------------- Class - PurchaseOrderClass Object - PurchaseOrderObject Assembly - PurchaseOrderAssembly
m_oFormTemplateContext_GEChanged
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NeedToLoadSpecificControl
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl)
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl)
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl)
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl)
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl)
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl)
OnRightToLeftChanged (inherited from ScrollableControl)
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl)
ProcessCmdKey (inherited from ContainerControl)
ProcessDialogChar (inherited from ContainerControl)
ProcessDialogKey (inherited from ContainerControl)
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshControlChildren
RefreshPaymentTypeDropDown | This method is responsible for setting up the payment type drop down. The query used to setup the payment type drop down returns all Active payment types. If PaymentTypesToShow is set to a value other than All, an additional filter is placed based on the type
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl)
ScaleCore (inherited from ScrollableControl)
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetTransactionControlVisibility
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
ShowTypeSpecificControl
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
TransferChildControls
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
UseSavedPaymentMethod
WndProc (inherited from UserControl)

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

PaymentInfoControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


PaymentInfoControl Constructor

Initializes a new instance of the PaymentInfoControl class.

public PaymentInfoControl();

See Also

PaymentInfoControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


PaymentInfoControl Fields

The fields of the PaymentInfoControl class are listed below. For a complete list of PaymentInfoControl class members, see the PaymentInfoControl Members topic.

Protected Instance Fields

m_iBillToCompanyID
m_iBillToID
m_oACH
m_oCash
m_oCheck
m_oCreditCard
m_oCreditMemo
m_oPO

See Also

PaymentInfoControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


PaymentInfoControl.m_iBillToCompanyID Field

protected m_iBillToCompanyID m_iBillToCompanyID;

See Also

PaymentInfoControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


PaymentInfoControl.m_iBillToID Field

protected m_iBillToID m_iBillToID;

See Also

PaymentInfoControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


PaymentInfoControl.m_oACH Field

protected m_oACH m_oACH;

See Also

PaymentInfoControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


PaymentInfoControl.m_oCash Field

protected m_oCash m_oCash;

See Also

PaymentInfoControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


PaymentInfoControl.m_oCheck Field

protected m_oCheck m_oCheck;

See Also

PaymentInfoControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


PaymentInfoControl.m_oCreditCard Field

protected m_oCreditCard m_oCreditCard;

See Also

PaymentInfoControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


PaymentInfoControl.m_oCreditMemo Field

protected m_oCreditMemo m_oCreditMemo;

See Also

PaymentInfoControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


PaymentInfoControl.m_oPO Field

protected m_oPO m_oPO;

See Also

PaymentInfoControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


PaymentInfoControl Properties

The properties of the PaymentInfoControl class are listed below. For a complete list of PaymentInfoControl class members, see the PaymentInfoControl Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Control |
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CreditCardSecurityCode |
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateContext |
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PaymentTypeEnabled | Gets or sets the enabled property of the Payment Type combo box.
PaymentTypesToShow |
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TransactionControlsVisible | Gets or sets the Visible property of transaction specific controls.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
dbcPaymentType |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
PaymentTypeTextBox |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

PaymentInfoControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


Control Property

Aptify 5.0 Software Development Kit (SDK)

PaymentInfoControl.Control Property

public Control Control {get;}

Implements

IFormComponent.

See Also

PaymentInfoControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


CreditCardSecurityCode Property

Aptify 5.0 Software Development Kit (SDK)

PaymentInfoControl.CreditCardSecurityCode Property

public virtual String CreditCardSecurityCode {get; set;}

See Also

PaymentInfoControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


dbcPaymentType Property

Aptify 5.0 Software Development Kit (SDK)

PaymentInfoControl.dbcPaymentType Property

protected virtual AptifyDataComboBox dbcPaymentType {get; set;}

See Also

PaymentInfoControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


FormTemplateContext Property

Aptify 5.0 Software Development Kit (SDK)

PaymentInfoControl.FormTemplateContext Property

public AptifyFormTemplateContext FormTemplateContext {get;}

Implements

IFormComponent.

See Also

PaymentInfoControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


PaymentTypeEnabled Property

Aptify 5.0 Software Development Kit (SDK)

PaymentInfoControl.PaymentTypeEnabled Property

Gets or sets the enabled property of the Payment Type combo box.

public Boolean PaymentTypeEnabled {get; set;}

Property Value

Remarks

See Also

PaymentInfoControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


PaymentTypesToShow Property

Aptify 5.0 Software Development Kit (SDK)

PaymentInfoControl.PaymentTypesToShow Property

public PaymentInfoControl.TypesToShow PaymentTypesToShow {get; set;}

See Also

PaymentInfoControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


PaymentTypeTextBox Property

Aptify 5.0 Software Development Kit (SDK)

PaymentInfoControl.PaymentTypeTextBox Property

protected virtual AptifyTextBox PaymentTypeTextBox {get; set;}

See Also

PaymentInfoControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


TransactionControlsVisible Property

Aptify 5.0 Software Development Kit (SDK)

PaymentInfoControl.TransactionControlsVisible Property

Gets or sets the Visible property of transaction specific controls.

public Boolean TransactionControlsVisible {get; set;}

Property Value

Remarks

See Also

PaymentInfoControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


PaymentInfoControl Methods

The methods of the PaymentInfoControl class are listed below. For a complete list of PaymentInfoControl class members, see the PaymentInfoControl Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
FormComponentConfig |
GetBasePaymentType | This utility method is used to get the base payment type of any given Payment Type ID provided as a parameter.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValidateCreditMemoAttribute |
Hide |
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LoadSavedPaymentMethods | Overloaded.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetSQLFilter |
Show | Overloaded.
ShowHideAccountNumber |
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
TransferDataToObject |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl)
ApplySkin
ConfigChildControls
ConfigurePaymentTypeDisplay
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
GetTypeSpecificAttributes
GetTypeSpecificControl
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
LoadTypeSpecificControls | This method is responsible for loading up instances of the type-specific controls which are Check (which includes Refund Voucher), Credit Card, Credit Memo and Purchase Order. These four base payment types are used within other payment types and the PaymentInfoControl will load up each one of these as required based on the payment type being shown to the user for a given record. In order to allow for easy sub-classing of these four different controls, Entity Attributes in the Payment Information entity are used to specify the class, object repository location and assembly names for each of the four types. The classes for Check, CreditCard, PurchaseOrder and CreditMemo must inherit from the respective base classes defined herein. The Entity Attributes used are as follows: Check, Refund Voucher ----- Class - CheckClass Object - CheckObject Assembly - CheckAssembly Credit Card ----------- Class - CreditCardClass Object - CreditCardObject Assembly - CreditCardAssembly Credit Memo ----------- Class - CreditMemoClass Object - CreditMemoObject Assembly - CreditMemoAssembly Purchase Order -------------- Class - PurchaseOrderClass Object - PurchaseOrderObject Assembly - PurchaseOrderAssembly
m_oFormTemplateContext_GEChanged
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NeedToLoadSpecificControl
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl)
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl)
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl)
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl)
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl)
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl)
OnRightToLeftChanged (inherited from ScrollableControl)
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl)
ProcessCmdKey (inherited from ContainerControl)
ProcessDialogChar (inherited from ContainerControl)
ProcessDialogKey (inherited from ContainerControl)
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshControlChildren
RefreshPaymentTypeDropDown | This method is responsible for setting up the payment type drop down. The query used to setup the payment type drop down returns all Active payment types. If PaymentTypesToShow is set to a value other than All, an additional filter is placed based on the type
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl)
ScaleCore (inherited from ScrollableControl)
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetTransactionControlVisibility
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
ShowTypeSpecificControl
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
TransferChildControls
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
UseSavedPaymentMethod
WndProc (inherited from UserControl)

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

PaymentInfoControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


PaymentInfoControl.ApplySkin Method

protected virtual void ApplySkin();

See Also

PaymentInfoControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


PaymentInfoControl.ConfigChildControls Method

protected virtual void ConfigChildControls(
Control ParentControl,
AptifyFormTemplateContext FormTemplateContext
);

See Also

PaymentInfoControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


PaymentInfoControl.ConfigurePaymentTypeDisplay Method

protected virtual void ConfigurePaymentTypeDisplay();

See Also

PaymentInfoControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

PaymentInfoControl.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

PaymentInfoControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


PaymentInfoControl.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

PaymentInfoControl Class | Aptify.Applications.Accounting.WindowsControls Namespace | PaymentInfoControl.Dispose Overload List


PaymentInfoControl.FormComponentConfig Method

public void FormComponentConfig(
AptifyFormTemplateContext FormTemplateContext
);

Implements

IFormComponent.

See Also

PaymentInfoControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


PaymentInfoControl.GetBasePaymentType Method

This utility method is used to get the base payment type of any given Payment Type ID provided as a parameter.

public virtual BasePaymentType GetBasePaymentType(
Int64 PaymentTypeID
);

Parameters

PaymentTypeID

Return Value

Remarks

See Also

PaymentInfoControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


PaymentInfoControl.GetTypeSpecificAttributes Method

protected virtual void GetTypeSpecificAttributes(
PaymentInfoControl.BasePaymentType BaseType,
ref String& sObject,
ref String& sClass,
ref String& sAssembly
);

See Also

PaymentInfoControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


PaymentInfoControl.GetTypeSpecificControl Method

protected virtual PaymentControl GetTypeSpecificControl(
String sObject,
String sClass,
String sAssembly,
PaymentInfoControl.BasePaymentType iBaseType
);

See Also

PaymentInfoControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


PaymentInfoControl.GetValidateCreditMemoAttribute Method

public bool GetValidateCreditMemoAttribute();

See Also

PaymentInfoControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


PaymentInfoControl.Hide Method

new public virtual void Hide();

Implements

IFormComponent.

See Also

PaymentInfoControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


LoadSavedPaymentMethods Method

Aptify 5.0 Software Development Kit (SDK)

PaymentInfoControl.LoadSavedPaymentMethods Method

Overload List

public virtual void LoadSavedPaymentMethods(Int64);

public virtual void LoadSavedPaymentMethods(Int64,Int64);

See Also

PaymentInfoControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


PaymentInfoControl.LoadSavedPaymentMethods Method (Int64)

public virtual void LoadSavedPaymentMethods(
Int64 lPersonID
);

See Also

PaymentInfoControl Class | Aptify.Applications.Accounting.WindowsControls Namespace | PaymentInfoControl.LoadSavedPaymentMethods Overload List


PaymentInfoControl.LoadSavedPaymentMethods Method (Int64, Int64)

public virtual void LoadSavedPaymentMethods(
Int64 lPersonID,
Int64 lCompanyID
);

See Also

PaymentInfoControl Class | Aptify.Applications.Accounting.WindowsControls Namespace | PaymentInfoControl.LoadSavedPaymentMethods Overload List


PaymentInfoControl.LoadTypeSpecificControls Method

This method is responsible for loading up instances of the type-specific controls which are Check (which includes Refund Voucher), Credit Card, Credit Memo and Purchase Order. These four base payment types are used within other payment types and the PaymentInfoControl will load up each one of these as required based on the payment type being shown to the user for a given record. In order to allow for easy sub-classing of these four different controls, Entity Attributes in the Payment Information entity are used to specify the class, object repository location and assembly names for each of the four types. The classes for Check, CreditCard, PurchaseOrder and CreditMemo must inherit from the respective base classes defined herein. The Entity Attributes used are as follows: Check, Refund Voucher ----- Class - CheckClass Object - CheckObject Assembly - CheckAssembly Credit Card ----------- Class - CreditCardClass Object - CreditCardObject Assembly - CreditCardAssembly Credit Memo ----------- Class - CreditMemoClass Object - CreditMemoObject Assembly - CreditMemoAssembly Purchase Order -------------- Class - PurchaseOrderClass Object - PurchaseOrderObject Assembly - PurchaseOrderAssembly

protected virtual void LoadTypeSpecificControls(
Int64 PaymentTypeID
);

Remarks

See Also

PaymentInfoControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


PaymentInfoControl.m_oFormTemplateContext_GEChanged Method

protected void m_oFormTemplateContext_GEChanged(
Object sender,
AptifyFormTemplateContext.GEChangedArgs e
);

See Also

PaymentInfoControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


PaymentInfoControl.NeedToLoadSpecificControl Method

protected virtual bool NeedToLoadSpecificControl(
PaymentInfoControl.BasePaymentType BaseType
);

See Also

PaymentInfoControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


PaymentInfoControl.Refresh Method

new public virtual void Refresh();

Implements

IFormComponent.

See Also

PaymentInfoControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


PaymentInfoControl.RefreshControlChildren Method

protected virtual void RefreshControlChildren(
Control parent
);

See Also

PaymentInfoControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


PaymentInfoControl.RefreshPaymentTypeDropDown Method

This method is responsible for setting up the payment type drop down. The query used to setup the payment type drop down returns all Active payment types. If PaymentTypesToShow is set to a value other than All, an additional filter is placed based on the type

protected virtual void RefreshPaymentTypeDropDown();

Remarks

See Also

PaymentInfoControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


PaymentInfoControl.SetSQLFilter Method

public void SetSQLFilter(
Int32 BillToID,
Int32 BillToCompanyID
);

See Also

PaymentInfoControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


PaymentInfoControl.SetTransactionControlVisibility Method

protected bool SetTransactionControlVisibility(
Boolean bVisible
);

See Also

PaymentInfoControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


Show Method

Aptify 5.0 Software Development Kit (SDK)

PaymentInfoControl.Show Method

Overload List

new public virtual void Show();

public virtual void Show(Boolean);

See Also

PaymentInfoControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


PaymentInfoControl.Show Method ()

new public virtual void Show();

Implements

IFormComponent.

See Also

PaymentInfoControl Class | Aptify.Applications.Accounting.WindowsControls Namespace | PaymentInfoControl.Show Overload List


PaymentInfoControl.Show Method (Boolean)

public virtual void Show(
Boolean Refresh
);

Implements

IFormComponent.

See Also

PaymentInfoControl Class | Aptify.Applications.Accounting.WindowsControls Namespace | PaymentInfoControl.Show Overload List


PaymentInfoControl.ShowHideAccountNumber Method

public void ShowHideAccountNumber(
CreditCard.AccountNumberMaskingTypes MaskingType
);

See Also

PaymentInfoControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


PaymentInfoControl.ShowTypeSpecificControl Method

protected virtual void ShowTypeSpecificControl(
PaymentInfoControl.BasePaymentType BaseType
);

See Also

PaymentInfoControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


PaymentInfoControl.TransferChildControls Method

protected virtual bool TransferChildControls(
Control ParentControl
);

See Also

PaymentInfoControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


PaymentInfoControl.TransferDataToObject Method

public void TransferDataToObject(
ref Boolean& Cancel
);

Implements

IFormComponent.

See Also

PaymentInfoControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


PaymentInfoControl.UseSavedPaymentMethod Method

protected void UseSavedPaymentMethod(
Int64 lPaymentInfoID
);

See Also

PaymentInfoControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


PaymentInfoControl Events

The events of the PaymentInfoControl class are listed below. For a complete list of PaymentInfoControl class members, see the PaymentInfoControl Members topic.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click |
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick |
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus |
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus |
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

PaymentInfoControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


PaymentInfoControl.IFormComponent.ClickEventHandler Event

public event IFormComponent.ClickEventHandler Click;

Implements

IFormComponent.

See Also

PaymentInfoControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


PaymentInfoControl.IFormComponent.DoubleClickEventHandler Event

public event IFormComponent.DoubleClickEventHandler DoubleClick;

Implements

IFormComponent.

See Also

PaymentInfoControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


PaymentInfoControl.IFormComponent.GotFocusEventHandler Event

public event IFormComponent.GotFocusEventHandler GotFocus;

Implements

IFormComponent.

See Also

PaymentInfoControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


PaymentInfoControl.IFormComponent.LostFocusEventHandler Event

public event IFormComponent.LostFocusEventHandler LostFocus;

Implements

IFormComponent.

See Also

PaymentInfoControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


PaymentInfoControl.IFormComponent.ValueChangedEventHandler Event

public event IFormComponent.ValueChangedEventHandler ValueChanged;

Implements

IFormComponent.

See Also

PaymentInfoControl Class | Aptify.Applications.Accounting.WindowsControls Namespace


PaymentInfoControl.BasePaymentType Enumeration

public enum PaymentInfoControl.BasePaymentType

Members

Member Name | Description
Check |
CreditCard |
PurchaseOrder |
CreditMemo |
ACH |
RefundVoucher |
Cash |

Requirements

Namespace: Aptify.Applications.Accounting.WindowsControls

Assembly: PaymentInfoControl (in PaymentInfoControl.dll)

See Also

Aptify.Applications.Accounting.WindowsControls Namespace


PaymentInfoControl.TypesToShow Enumeration

public enum PaymentInfoControl.TypesToShow

Members

Member Name | Description
Inflow |
OnAccount |
All |
ExcludeCheck |
ExcludeCashAndCheck |

Requirements

Namespace: Aptify.Applications.Accounting.WindowsControls

Assembly: PaymentInfoControl (in PaymentInfoControl.dll)

See Also

Aptify.Applications.Accounting.WindowsControls Namespace


PurchaseOrder Class

For a list of all members of this type, see PurchaseOrder Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
PaymentControl
PurchaseOrder

public class PurchaseOrder : PaymentControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Accounting.WindowsControls

Assembly: PaymentInfoControl (in PaymentInfoControl.dll)

See Also

PurchaseOrder Members | Aptify.Applications.Accounting.WindowsControls Namespace


PurchaseOrder Members

PurchaseOrder overview

Public Instance Constructors

PurchaseOrder Constructor Initializes a new instance of the PurchaseOrder class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Control (inherited from PaymentControl) |
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateContext (inherited from PaymentControl) |
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TransactionControlsVisible (inherited from PaymentControl) | Gets or sets the Visible property of transaction specific controls.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ClearControls |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
FormComponentConfig (inherited from PaymentControl) | If this component is being used for an embedded field, provide the DataField input property to the Form Template Part.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from PaymentControl) |
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from PaymentControl) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from PaymentControl) | Overloaded.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
TransferDataToObject (inherited from PaymentControl) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from PaymentControl) |
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from PaymentControl) |
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from PaymentControl) |
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from PaymentControl) |
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from PaymentControl) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

m_bTransactionControlsVisible (inherited from PaymentControl)
m_oApp (inherited from PaymentControl)
m_oUserCredential (inherited from PaymentControl)

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
ConfigChildControls (inherited from PaymentControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnValueChanged (inherited from PaymentControl) |
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetTransactionControls (inherited from PaymentControl) |
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

PurchaseOrder Class | Aptify.Applications.Accounting.WindowsControls Namespace


PurchaseOrder Constructor

Initializes a new instance of the PurchaseOrder class.

public PurchaseOrder();

See Also

PurchaseOrder Class | Aptify.Applications.Accounting.WindowsControls Namespace


PurchaseOrder Methods

The methods of the PurchaseOrder class are listed below. For a complete list of PurchaseOrder class members, see the PurchaseOrder Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ClearControls |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
FormComponentConfig (inherited from PaymentControl) | If this component is being used for an embedded field, provide the DataField input property to the Form Template Part.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from PaymentControl) |
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from PaymentControl) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from PaymentControl) | Overloaded.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
TransferDataToObject (inherited from PaymentControl) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
ConfigChildControls (inherited from PaymentControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnValueChanged (inherited from PaymentControl) |
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetTransactionControls (inherited from PaymentControl) |
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

PurchaseOrder Class | Aptify.Applications.Accounting.WindowsControls Namespace


PurchaseOrder.ClearControls Method

public override void ClearControls();

See Also

PurchaseOrder Class | Aptify.Applications.Accounting.WindowsControls Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

PurchaseOrder.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

PurchaseOrder Class | Aptify.Applications.Accounting.WindowsControls Namespace


PurchaseOrder.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

PurchaseOrder Class | Aptify.Applications.Accounting.WindowsControls Namespace | PurchaseOrder.Dispose Overload List


StandingOrderLayout Class

Provides presentation layer logic used for Standing Orders Entity Top-Level records

For a list of all members of this type, see StandingOrderLayout Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
StandingOrderLayout

public class StandingOrderLayout : FormTemplateLayout

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Accounting.WindowsControls

Assembly: StandingOrderLayoutControls (in StandingOrderLayoutControls.dll)

See Also

StandingOrderLayout Members | Aptify.Applications.Accounting.WindowsControls Namespace


StandingOrderLayout Members

StandingOrderLayout overview

Public Instance Constructors

StandingOrderLayout Constructor Initializes a new instance of the StandingOrderLayout class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
m_ctlBillToCompanyID |
m_ctlBillToID |
m_ctlEmployeeID |
m_ctlFrequency |
m_ctlFulfillNow |
m_ctlGenerateSchedule |
m_ctlPaymentInfo |
m_ctlShipToCompanyID |
m_ctlShipToID |
m_ctlSubTypePurchases |
m_ctlType |
m_oMsgObject |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
BindControl | Overloaded. This method handles binding a control reference to a specific field name using the GetFormComponent() method of the base class. The method only attempts to bind the control reference if the control reference is Nothing or its inner control is disposed.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormTemplateLayout) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControls | This method handles binding the controls to their internal protected members.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetCurrentEmployeeID | Returns the current employee ID based on the Users entity meta-data
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetPersonCompanyID | This method is responsible for retrieving the Company ID to associate with a given Person ID and is used from the On_ShipToID_ValueChanged and On_BillToID_ValueChanged methods.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetSubTypeControl | This method is responsible for finding a sub-type control within the form template based on the name of the Sub Type.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
On_BillToID_ValueChanged | This method is responsible for handling the event when the Bill To changes and will by default flow down information to the Bill To Company ID
On_FulfillNow_Click | This method is responsible for handling the click on the Fulfill Now button. This method by default in the base class will call the Standing Order business object to handle the fulfillment of this standing order and then refresh the Purchases sub-type control on the user interface if it has been loaded.
On_GenerateSchedule_Click | This method is responsible for handling the click on the Generate Schedule button. This method by default in the base class will call the Standing Order business object to handle the schedule generation for this standing order and then refresh the Purchases sub-type control on the user interface if it has been loaded.
On_ShipToID_ValueChanged | This method is responsible for handling the event when the Ship To changes and will by default flow down information to the Ship To Company ID, Bill To Company ID and Bill To ID.
On_Type_ValueChanged | This method is responsible for handing the ValueChanged event in the Type control and disables/enables the Frequencye control so that it is only available if Type=Frequency.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded | Contains logic to setup Event handlers for controls on the FormTemplate Layout.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetupControls |
SetupEmployeeID | This method will set the Employee ID in the current record to the current employee based on the Users meta-data.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

StandingOrderLayout Class | Aptify.Applications.Accounting.WindowsControls Namespace


StandingOrderLayout Constructor

Initializes a new instance of the StandingOrderLayout class.

public StandingOrderLayout();

See Also

StandingOrderLayout Class | Aptify.Applications.Accounting.WindowsControls Namespace


StandingOrderLayout Properties

The properties of the StandingOrderLayout class are listed below. For a complete list of StandingOrderLayout class members, see the StandingOrderLayout Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
m_ctlBillToCompanyID |
m_ctlBillToID |
m_ctlEmployeeID |
m_ctlFrequency |
m_ctlFulfillNow |
m_ctlGenerateSchedule |
m_ctlPaymentInfo |
m_ctlShipToCompanyID |
m_ctlShipToID |
m_ctlSubTypePurchases |
m_ctlType |
m_oMsgObject |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

StandingOrderLayout Class | Aptify.Applications.Accounting.WindowsControls Namespace


m_ctlBillToCompanyID Property

Aptify 5.0 Software Development Kit (SDK)

StandingOrderLayout.m_ctlBillToCompanyID Property

protected virtual IAptifyDataFieldControlBase m_ctlBillToCompanyID {get; set;}

See Also

StandingOrderLayout Class | Aptify.Applications.Accounting.WindowsControls Namespace


m_ctlBillToID Property

Aptify 5.0 Software Development Kit (SDK)

StandingOrderLayout.m_ctlBillToID Property

protected virtual IAptifyDataFieldControlBase m_ctlBillToID {get; set;}

See Also

StandingOrderLayout Class | Aptify.Applications.Accounting.WindowsControls Namespace


m_ctlEmployeeID Property

Aptify 5.0 Software Development Kit (SDK)

StandingOrderLayout.m_ctlEmployeeID Property

protected virtual IAptifyDataFieldControlBase m_ctlEmployeeID {get; set;}

See Also

StandingOrderLayout Class | Aptify.Applications.Accounting.WindowsControls Namespace


m_ctlFrequency Property

Aptify 5.0 Software Development Kit (SDK)

StandingOrderLayout.m_ctlFrequency Property

protected virtual IAptifyDataFieldControlBase m_ctlFrequency {get; set;}

See Also

StandingOrderLayout Class | Aptify.Applications.Accounting.WindowsControls Namespace


m_ctlFulfillNow Property

Aptify 5.0 Software Development Kit (SDK)

StandingOrderLayout.m_ctlFulfillNow Property

protected virtual AptifyActiveButton m_ctlFulfillNow {get; set;}

See Also

StandingOrderLayout Class | Aptify.Applications.Accounting.WindowsControls Namespace


m_ctlGenerateSchedule Property

Aptify 5.0 Software Development Kit (SDK)

StandingOrderLayout.m_ctlGenerateSchedule Property

protected virtual AptifyActiveButton m_ctlGenerateSchedule {get; set;}

See Also

StandingOrderLayout Class | Aptify.Applications.Accounting.WindowsControls Namespace


m_ctlPaymentInfo Property

Aptify 5.0 Software Development Kit (SDK)

StandingOrderLayout.m_ctlPaymentInfo Property

protected virtual PaymentInfoControl m_ctlPaymentInfo {get; set;}

See Also

StandingOrderLayout Class | Aptify.Applications.Accounting.WindowsControls Namespace


m_ctlShipToCompanyID Property

Aptify 5.0 Software Development Kit (SDK)

StandingOrderLayout.m_ctlShipToCompanyID Property

protected virtual IAptifyDataFieldControlBase m_ctlShipToCompanyID {get; set;}

See Also

StandingOrderLayout Class | Aptify.Applications.Accounting.WindowsControls Namespace


m_ctlShipToID Property

Aptify 5.0 Software Development Kit (SDK)

StandingOrderLayout.m_ctlShipToID Property

protected virtual IAptifyDataFieldControlBase m_ctlShipToID {get; set;}

See Also

StandingOrderLayout Class | Aptify.Applications.Accounting.WindowsControls Namespace


m_ctlSubTypePurchases Property

Aptify 5.0 Software Development Kit (SDK)

StandingOrderLayout.m_ctlSubTypePurchases Property

protected virtual AptifySubType m_ctlSubTypePurchases {get; set;}

See Also

StandingOrderLayout Class | Aptify.Applications.Accounting.WindowsControls Namespace


m_ctlType Property

Aptify 5.0 Software Development Kit (SDK)

StandingOrderLayout.m_ctlType Property

protected virtual IAptifyDataFieldControlBase m_ctlType {get; set;}

See Also

StandingOrderLayout Class | Aptify.Applications.Accounting.WindowsControls Namespace


m_oMsgObject Property

Aptify 5.0 Software Development Kit (SDK)

StandingOrderLayout.m_oMsgObject Property

protected virtual AptifyMessage m_oMsgObject {get; set;}

See Also

StandingOrderLayout Class | Aptify.Applications.Accounting.WindowsControls Namespace


StandingOrderLayout Methods

The methods of the StandingOrderLayout class are listed below. For a complete list of StandingOrderLayout class members, see the StandingOrderLayout Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
BindControl | Overloaded. This method handles binding a control reference to a specific field name using the GetFormComponent() method of the base class. The method only attempts to bind the control reference if the control reference is Nothing or its inner control is disposed.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormTemplateLayout) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControls | This method handles binding the controls to their internal protected members.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetCurrentEmployeeID | Returns the current employee ID based on the Users entity meta-data
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetPersonCompanyID | This method is responsible for retrieving the Company ID to associate with a given Person ID and is used from the On_ShipToID_ValueChanged and On_BillToID_ValueChanged methods.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetSubTypeControl | This method is responsible for finding a sub-type control within the form template based on the name of the Sub Type.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
On_BillToID_ValueChanged | This method is responsible for handling the event when the Bill To changes and will by default flow down information to the Bill To Company ID
On_FulfillNow_Click | This method is responsible for handling the click on the Fulfill Now button. This method by default in the base class will call the Standing Order business object to handle the fulfillment of this standing order and then refresh the Purchases sub-type control on the user interface if it has been loaded.
On_GenerateSchedule_Click | This method is responsible for handling the click on the Generate Schedule button. This method by default in the base class will call the Standing Order business object to handle the schedule generation for this standing order and then refresh the Purchases sub-type control on the user interface if it has been loaded.
On_ShipToID_ValueChanged | This method is responsible for handling the event when the Ship To changes and will by default flow down information to the Ship To Company ID, Bill To Company ID and Bill To ID.
On_Type_ValueChanged | This method is responsible for handing the ValueChanged event in the Type control and disables/enables the Frequencye control so that it is only available if Type=Frequency.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded | Contains logic to setup Event handlers for controls on the FormTemplate Layout.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetupControls |
SetupEmployeeID | This method will set the Employee ID in the current record to the current employee based on the Users meta-data.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

StandingOrderLayout Class | Aptify.Applications.Accounting.WindowsControls Namespace


BindControl Method

Aptify 5.0 Software Development Kit (SDK)

StandingOrderLayout.BindControl Method

Overload List

protected virtual void BindControl(ref IAptifyControlBase&,String);

This method handles binding a control reference to a specific field name using the GetFormComponent() method of the base class. The method only attempts to bind the control reference if the control reference is Nothing or its inner control is disposed.

protected virtual void BindControl(ref IAptifyDataFieldControlBase&,String);

See Also

StandingOrderLayout Class | Aptify.Applications.Accounting.WindowsControls Namespace


StandingOrderLayout.BindControl Method (IAptifyControlBase&, String)

protected virtual void BindControl(
ref IAptifyControlBase& control,
String FieldName
);

See Also

StandingOrderLayout Class | Aptify.Applications.Accounting.WindowsControls Namespace | StandingOrderLayout.BindControl Overload List


StandingOrderLayout.BindControl Method (IAptifyDataFieldControlBase&, String)

This method handles binding a control reference to a specific field name using the GetFormComponent() method of the base class. The method only attempts to bind the control reference if the control reference is Nothing or its inner control is disposed.

protected virtual void BindControl(
ref IAptifyDataFieldControlBase& control,
String FieldName
);

Parameters

control
FieldName

Remarks

See Also

StandingOrderLayout Class | Aptify.Applications.Accounting.WindowsControls Namespace | StandingOrderLayout.BindControl Overload List


StandingOrderLayout.FindControls Method

This method handles binding the controls to their internal protected members.

protected virtual void FindControls();

Remarks

See Also

StandingOrderLayout Class | Aptify.Applications.Accounting.WindowsControls Namespace


StandingOrderLayout.GetCurrentEmployeeID Method

Returns the current employee ID based on the Users entity meta-data

protected virtual long GetCurrentEmployeeID();

Return Value

Remarks

See Also

StandingOrderLayout Class | Aptify.Applications.Accounting.WindowsControls Namespace


StandingOrderLayout.GetPersonCompanyID Method

This method is responsible for retrieving the Company ID to associate with a given Person ID and is used from the On_ShipToID_ValueChanged and On_BillToID_ValueChanged methods.

protected virtual long GetPersonCompanyID(
Int64 PersonID
);

Parameters

PersonID

Return Value

Remarks

See Also

StandingOrderLayout Class | Aptify.Applications.Accounting.WindowsControls Namespace


StandingOrderLayout.GetSubTypeControl Method

This method is responsible for finding a sub-type control within the form template based on the name of the Sub Type.

protected virtual AptifySubType GetSubTypeControl(
Control ParentControl,
String SubTypeName
);

Parameters

ParentControl
SubTypeName

Return Value

Remarks

See Also

StandingOrderLayout Class | Aptify.Applications.Accounting.WindowsControls Namespace


StandingOrderLayout.On_BillToID_ValueChanged Method

This method is responsible for handling the event when the Bill To changes and will by default flow down information to the Bill To Company ID

protected virtual void On_BillToID_ValueChanged(
Object sender,
Object OldValue,
Object NewValue
);

Parameters

sender
OldValue
NewValue

Remarks

See Also

StandingOrderLayout Class | Aptify.Applications.Accounting.WindowsControls Namespace


StandingOrderLayout.On_FulfillNow_Click Method

This method is responsible for handling the click on the Fulfill Now button. This method by default in the base class will call the Standing Order business object to handle the fulfillment of this standing order and then refresh the Purchases sub-type control on the user interface if it has been loaded.

protected virtual void On_FulfillNow_Click(
Object sender,
EventArgs e
);

Parameters

sender
e

Remarks

See Also

StandingOrderLayout Class | Aptify.Applications.Accounting.WindowsControls Namespace


StandingOrderLayout.On_GenerateSchedule_Click Method

This method is responsible for handling the click on the Generate Schedule button. This method by default in the base class will call the Standing Order business object to handle the schedule generation for this standing order and then refresh the Purchases sub-type control on the user interface if it has been loaded.

protected virtual void On_GenerateSchedule_Click(
Object sender,
EventArgs e
);

Parameters

sender
e

Remarks

See Also

StandingOrderLayout Class | Aptify.Applications.Accounting.WindowsControls Namespace


StandingOrderLayout.On_ShipToID_ValueChanged Method

This method is responsible for handling the event when the Ship To changes and will by default flow down information to the Ship To Company ID, Bill To Company ID and Bill To ID.

protected virtual void On_ShipToID_ValueChanged(
Object sender,
Object OldValue,
Object NewValue
);

Parameters

sender
OldValue
NewValue

Remarks

See Also

StandingOrderLayout Class | Aptify.Applications.Accounting.WindowsControls Namespace


StandingOrderLayout.On_Type_ValueChanged Method

This method is responsible for handing the ValueChanged event in the Type control and disables/enables the Frequencye control so that it is only available if Type=Frequency.

protected virtual void On_Type_ValueChanged(
Object sender,
Object OldValue,
Object NewValue
);

Parameters

sender
OldValue
NewValue

Remarks

See Also

StandingOrderLayout Class | Aptify.Applications.Accounting.WindowsControls Namespace


StandingOrderLayout.OnFormTemplateLoaded Method

Contains logic to setup Event handlers for controls on the FormTemplate Layout.

protected override void OnFormTemplateLoaded(
FormTemplateLayout.FormTemplateLoadedEventArgs e
);

Parameters

e

Remarks

See Also

StandingOrderLayout Class | Aptify.Applications.Accounting.WindowsControls Namespace


StandingOrderLayout.SetupControls Method

protected virtual void SetupControls();

See Also

StandingOrderLayout Class | Aptify.Applications.Accounting.WindowsControls Namespace


StandingOrderLayout.SetupEmployeeID Method

This method will set the Employee ID in the current record to the current employee based on the Users meta-data.

protected virtual void SetupEmployeeID();

Remarks

See Also

StandingOrderLayout Class | Aptify.Applications.Accounting.WindowsControls Namespace


Aptify.Applications.Advertising

Aptify 5.0 Software Development Kit (SDK)

Aptify.Applications.Advertising Namespace

The objects in this namespace implement Aptify's Advertising add-on module.

Namespace hierarchy

Classes

Class | Description
AdvertisingContract | This class provides the implementation for business logic for the Advertising Contracts entity in the Aptify Advertising Management system.
AdvertisingContractLayout |
AdvertisingContractPubLayout |
AdvertisingContractSalesRepLayout |
AdvertisingInsertionOrder | This class provides the implementation for business logic for the Advertising Insertion Orders entity in the Aptify Advertising Management system.
AdvertisingInsertionOrderPricing | This class provides the default implementation for pricing for Insertion Orders in the Aptify Advertising Management system. This class can be sub-classed if it is necessary to override functionality in the base implementation for insertion order pricing. Alternatively, it is also possible to create a completely separate class that implements IAdvertisingInsertionOrderPricing and plug in that class as well. In either case, sub-classes or separate implementations of the interface must be plugged into the Advertising Insertion Orders entity using the Entity Attributes shown below (All of the below are attributes of the Advertising Insertion Orders entity)
AdvertisingLayoutBase |
AdvertisingOption | This class provides the implementation for business logic for the Advertising Options entity in the Aptify Advertising Management system.
AdvertisingRateCardDeadline |
AdvertisingRateCardDeadlineEntity |
AdvertisingRateCardLayout |
AdvertisingRateCardRate | This class provides the implementation for business logic for the Advertising Rate Card Rates sub-type entity in the Aptify Advertising Management system.
AdvertisingRateCardRateOption | This class provides the implementation for business logic for the Advertising Rate Card Options sub-type entity in the Aptify Advertising Management system.
AdvertisingRateCardSectionLayout |
AdvertisingUnitDefinition | This class provides the implementation for business logic for the Advertising Unit Definitions entity in the Aptify Advertising Management system.
AptifyLinkLabel |
DefaultUnitDefinition |
InsertionMultiBillToLayout |
InsertionOrderAdjHistoryLayout |
InsertionOrderBillToSelector |
InsertionOrderDetailLayout |
InsertionOrderLayout | The InsertionOrderLayout control is responsible for performing user interface logic on the Insertion Order form templates. This layout control is designed to reside on the top level Insertion Order form template.
InsertionOrderOptions |
MultipleBillTo | Represents a strongly typed in-memory cache of data.
MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable | Represents the strongly named DataTable class.
MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow | Represents strongly named DataRow class.
MultipleBillTo.vwAdvertisingInsertionOrderBillTosRowChangeEvent | Row event argument class
OptionsDataSet | Represents a strongly typed in-memory cache of data.
OptionsDataSet.OptionsDataTable | Represents the strongly named DataTable class.
OptionsDataSet.OptionsRow | Represents strongly named DataRow class.
OptionsDataSet.OptionsRowChangeEvent | Row event argument class

Interfaces

Interface | Description
IAdvertisingInsertionOrderPricing |
IAdvertisingUnitDefinition | This interface is used to allow extensibility of Unit Definitions for the Advertising Rate Cards and Insertion Order objects. The Rate Card Rate and Advertising Insertion Order information will provide enough information to calculate the Unit Count, but override parameters can be sent in when the CalculateUnitCount is called.

Structures

Structure | Description
AdvertisingInsertionOrder.BillToAmount | Used in conjunction with the GetBillToSplitAmounts() method

Delegates

Delegate | Description
MultipleBillTo.vwAdvertisingInsertionOrderBillTosRowChangeEventHandler |
OptionsDataSet.OptionsRowChangeEventHandler |


AdvertisingContract Class

This class provides the implementation for business logic for the Advertising Contracts entity in the Aptify Advertising Management system.

For a list of all members of this type, see AdvertisingContract Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
AdvertisingContract

public class AdvertisingContract : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Advertising

Assembly: AdvertisingContract (in AdvertisingContract.dll)

See Also

AdvertisingContract Members | Aptify.Applications.Advertising Namespace


AdvertisingContract Members

AdvertisingContract overview

Public Instance Constructors

AdvertisingContract Constructor Initializes a new instance of the AdvertisingContract class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CalculateSplitPercentage | This method returns through the PrimarySalesRepPercent parameter, the amount of the commission split that the primary sales rep will receive. This is calculated by calculating the sum of all of the split percentages within the AdvertisingContractSalesRep sub-type and then returning the amount left within a commission base of 100%
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config | Overloaded.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded. This method overrides the base GE Save() method and sets the EndDate field to be 12 months from the Start Date field less one day. This default logic is in place to accomodate the typical Advertising Contract, but can be overriden by sub-classing the AdvertisingContract class and then overriding the SetDefaultEndDate() method.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
Database |
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
CheckPublicationOnRateCards | This method checks to make sure that the PublicationID for each AdvertisingContractPublications record is the same as for the related rate card.
CheckSubTypeDuplicates | This method checks to see if there are duplicate records in the specified sub-type by comparing the values of each sub-type record in the specified sub-type via the CompareField.
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
DoesAtLeastOnePublicationExist | This method checks to see if there are any records in the AdvertisingContractPublications sub-type and returns True if there are any records in the sub-type and false otherwise.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
GetPrimarySalesRepItemFromSubType | This method returns the item from the AdvertisingContractSalesRep sub-type that has the IsPrimary BIT field set to 1. If no such record is found, the method returns Nothing.
GetRateCardInfoByID | This method returns a data table that has a single row in it representing the details for a given Advertising Rate Card entity record.
GetSalesRepSubTypeTotalPercent | This method returns a decimal value equal to the sum of all of the SplitPercentage fields within the AdvertisingContractSalesRep sub-type.
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
IsPublicationAndRatePublicationSame | This method is responsible for checking to see if an individual AdvertisingContractPublication sub-type item is valid by determining if the Rate Card's publication is the same.
IsTopAndSubSalesRepsPercentSync | This method checks to see if the top-level Sales Rep and Sub type Sales Rep percentage amounts are syncronized by checking to make sure that the PrimarySalesRepSplitPercentage field in the Top Level Advertising Contract entity matches the SplitPercentage field in the Sub-type record within AdvertisingContractSalesRep entity.
IsTopAndSubSalesRepsSync | This method validates to make sure that the primary sales rep that is represented by the SalesRepID field on the Advertising Contracts top-level entity is both inside the AdvertisignContractSalesRep sub-type and is marked as the primary sales rep at that level.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetDefaultEndDate | This method is responsible for setting the Default End Date for the Advertising Contract. The Base Class implementation of this method is to set the EndDate field of the record to 12 months, less one day, from the start date. The default implementation of this method only makes this change for New Records so that existing records that have no end date can stay that way if desired.
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

AdvertisingContract Class | Aptify.Applications.Advertising Namespace


AdvertisingContract Constructor

Initializes a new instance of the AdvertisingContract class.

public AdvertisingContract();

See Also

AdvertisingContract Class | Aptify.Applications.Advertising Namespace


AdvertisingContract Properties

The properties of the AdvertisingContract class are listed below. For a complete list of AdvertisingContract class members, see the AdvertisingContract Members topic.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
Database |
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

AdvertisingContract Class | Aptify.Applications.Advertising Namespace


Database Property

Aptify 5.0 Software Development Kit (SDK)

AdvertisingContract.Database Property

protected virtual String Database {get;}

See Also

AdvertisingContract Class | Aptify.Applications.Advertising Namespace


AdvertisingContract Methods

The methods of the AdvertisingContract class are listed below. For a complete list of AdvertisingContract class members, see the AdvertisingContract Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CalculateSplitPercentage | This method returns through the PrimarySalesRepPercent parameter, the amount of the commission split that the primary sales rep will receive. This is calculated by calculating the sum of all of the split percentages within the AdvertisingContractSalesRep sub-type and then returning the amount left within a commission base of 100%
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config | Overloaded.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded. This method overrides the base GE Save() method and sets the EndDate field to be 12 months from the Start Date field less one day. This default logic is in place to accomodate the typical Advertising Contract, but can be overriden by sub-classing the AdvertisingContract class and then overriding the SetDefaultEndDate() method.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
CheckPublicationOnRateCards | This method checks to make sure that the PublicationID for each AdvertisingContractPublications record is the same as for the related rate card.
CheckSubTypeDuplicates | This method checks to see if there are duplicate records in the specified sub-type by comparing the values of each sub-type record in the specified sub-type via the CompareField.
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
DoesAtLeastOnePublicationExist | This method checks to see if there are any records in the AdvertisingContractPublications sub-type and returns True if there are any records in the sub-type and false otherwise.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
GetPrimarySalesRepItemFromSubType | This method returns the item from the AdvertisingContractSalesRep sub-type that has the IsPrimary BIT field set to 1. If no such record is found, the method returns Nothing.
GetRateCardInfoByID | This method returns a data table that has a single row in it representing the details for a given Advertising Rate Card entity record.
GetSalesRepSubTypeTotalPercent | This method returns a decimal value equal to the sum of all of the SplitPercentage fields within the AdvertisingContractSalesRep sub-type.
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
IsPublicationAndRatePublicationSame | This method is responsible for checking to see if an individual AdvertisingContractPublication sub-type item is valid by determining if the Rate Card's publication is the same.
IsTopAndSubSalesRepsPercentSync | This method checks to see if the top-level Sales Rep and Sub type Sales Rep percentage amounts are syncronized by checking to make sure that the PrimarySalesRepSplitPercentage field in the Top Level Advertising Contract entity matches the SplitPercentage field in the Sub-type record within AdvertisingContractSalesRep entity.
IsTopAndSubSalesRepsSync | This method validates to make sure that the primary sales rep that is represented by the SalesRepID field on the Advertising Contracts top-level entity is both inside the AdvertisignContractSalesRep sub-type and is marked as the primary sales rep at that level.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetDefaultEndDate | This method is responsible for setting the Default End Date for the Advertising Contract. The Base Class implementation of this method is to set the EndDate field of the record to 12 months, less one day, from the start date. The default implementation of this method only makes this change for New Records so that existing records that have no end date can stay that way if desired.
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

AdvertisingContract Class | Aptify.Applications.Advertising Namespace


AdvertisingContract.CalculateSplitPercentage Method

This method returns through the PrimarySalesRepPercent parameter, the amount of the commission split that the primary sales rep will receive. This is calculated by calculating the sum of all of the split percentages within the AdvertisingContractSalesRep sub-type and then returning the amount left within a commission base of 100%

public virtual bool CalculateSplitPercentage(
ref Decimal& PrimarySalesRepPercent
);

Parameters

PrimarySalesRepPercent

Return Value

True if the method is succesful, False otherwise

Remarks

See Also

AdvertisingContract Class | Aptify.Applications.Advertising Namespace


AdvertisingContract.CheckPublicationOnRateCards Method

This method checks to make sure that the PublicationID for each AdvertisingContractPublications record is the same as for the related rate card.

protected virtual bool CheckPublicationOnRateCards(
ref String& ErroneousRateCards
);

Parameters

ErroneousRateCards
OUT Parameter: Returns a string that contains information about the rate cards that are incorrect

Return Value

Remarks

See Also

AdvertisingContract Class | Aptify.Applications.Advertising Namespace


AdvertisingContract.CheckSubTypeDuplicates Method

This method checks to see if there are duplicate records in the specified sub-type by comparing the values of each sub-type record in the specified sub-type via the CompareField.

protected virtual bool CheckSubTypeDuplicates(
String SubTypeName,
String CompareField,
Int32 Sequence,
ref String& Duplicate
);

Parameters

SubTypeName
CompareField
Sequence
Duplicate

Return Value

Remarks

See Also

AdvertisingContract Class | Aptify.Applications.Advertising Namespace


Config Method

Aptify 5.0 Software Development Kit (SDK)

AdvertisingContract.Config Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual void Config(AptifySubTypeBase);

Inherited from AptifyGenericEntity.

public override void Config(AptifySubTypeBase,Int64);

Inherited from AptifyGenericEntityBase.

public virtual void Config(UserCredentials,String);

public override void Config(UserCredentials,String,Int64);

See Also

AdvertisingContract Class | Aptify.Applications.Advertising Namespace


AdvertisingContract.Config Method (UserCredentials, String, Int64)

public override void Config(
UserCredentials UserCredentials,
String EntityName,
Int64 RecordID
);

See Also

AdvertisingContract Class | Aptify.Applications.Advertising Namespace | AdvertisingContract.Config Overload List


AdvertisingContract.DoesAtLeastOnePublicationExist Method

This method checks to see if there are any records in the AdvertisingContractPublications sub-type and returns True if there are any records in the sub-type and false otherwise.

protected virtual bool DoesAtLeastOnePublicationExist();

Return Value

Remarks

See Also

AdvertisingContract Class | Aptify.Applications.Advertising Namespace


AdvertisingContract.GetPrimarySalesRepItemFromSubType Method

This method returns the item from the AdvertisingContractSalesRep sub-type that has the IsPrimary BIT field set to 1. If no such record is found, the method returns Nothing.

protected virtual AptifyGenericEntityBase GetPrimarySalesRepItemFromSubType();

Return Value

Remarks

See Also

AdvertisingContract Class | Aptify.Applications.Advertising Namespace


AdvertisingContract.GetRateCardInfoByID Method

This method returns a data table that has a single row in it representing the details for a given Advertising Rate Card entity record.

protected virtual DataTable GetRateCardInfoByID(
Int64 RateCardID
);

Parameters

RateCardID
The ID value of the Rate Card to select and return

Return Value

Remarks

See Also

AdvertisingContract Class | Aptify.Applications.Advertising Namespace


AdvertisingContract.GetSalesRepSubTypeTotalPercent Method

This method returns a decimal value equal to the sum of all of the SplitPercentage fields within the AdvertisingContractSalesRep sub-type.

protected virtual decimal GetSalesRepSubTypeTotalPercent();

Return Value

Remarks

See Also

AdvertisingContract Class | Aptify.Applications.Advertising Namespace


AdvertisingContract.IsPublicationAndRatePublicationSame Method

This method is responsible for checking to see if an individual AdvertisingContractPublication sub-type item is valid by determining if the Rate Card's publication is the same.

protected virtual bool IsPublicationAndRatePublicationSame(
AptifyGenericEntityBase AdvertisingContractPublicationItemGE,
ref String& ErroneousRateName
);

Parameters

AdvertisingContractPublicationItemGE
ErroneousRateName

Return Value

Remarks

See Also

AdvertisingContract Class | Aptify.Applications.Advertising Namespace


AdvertisingContract.IsTopAndSubSalesRepsPercentSync Method

This method checks to see if the top-level Sales Rep and Sub type Sales Rep percentage amounts are syncronized by checking to make sure that the PrimarySalesRepSplitPercentage field in the Top Level Advertising Contract entity matches the SplitPercentage field in the Sub-type record within AdvertisingContractSalesRep entity.

protected virtual bool IsTopAndSubSalesRepsPercentSync();

Return Value

Remarks

See Also

AdvertisingContract Class | Aptify.Applications.Advertising Namespace


AdvertisingContract.IsTopAndSubSalesRepsSync Method

This method validates to make sure that the primary sales rep that is represented by the SalesRepID field on the Advertising Contracts top-level entity is both inside the AdvertisignContractSalesRep sub-type and is marked as the primary sales rep at that level.

protected virtual bool IsTopAndSubSalesRepsSync();

Return Value

Remarks

See Also

AdvertisingContract Class | Aptify.Applications.Advertising Namespace


Save Method

Aptify 5.0 Software Development Kit (SDK)

AdvertisingContract.Save Method

This method overrides the base GE Save() method and sets the EndDate field to be 12 months from the Start Date field less one day. This default logic is in place to accomodate the typical Advertising Contract, but can be overriden by sub-classing the AdvertisingContract class and then overriding the SetDefaultEndDate() method.

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Save();

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean,ref String&);

This method overrides the base GE Save() method and sets the EndDate field to be 12 months from the Start Date field less one day. This default logic is in place to accomodate the typical Advertising Contract, but can be overriden by sub-classing the AdvertisingContract class and then overriding the SetDefaultEndDate() method.

public override bool Save(Boolean,ref String&,String);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(ref String&);

See Also

AdvertisingContract Class | Aptify.Applications.Advertising Namespace


AdvertisingContract.Save Method (Boolean, String&, String)

This method overrides the base GE Save() method and sets the EndDate field to be 12 months from the Start Date field less one day. This default logic is in place to accomodate the typical Advertising Contract, but can be overriden by sub-classing the AdvertisingContract class and then overriding the SetDefaultEndDate() method.

public override bool Save(
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

Parameters

AllowGUI
ErrorString
TransactionID

Return Value

Remarks

See Also

AdvertisingContract Class | Aptify.Applications.Advertising Namespace | AdvertisingContract.Save Overload List


AdvertisingContract.SetDefaultEndDate Method

This method is responsible for setting the Default End Date for the Advertising Contract. The Base Class implementation of this method is to set the EndDate field of the record to 12 months, less one day, from the start date. The default implementation of this method only makes this change for New Records so that existing records that have no end date can stay that way if desired.

protected virtual void SetDefaultEndDate();

Remarks

See Also

AdvertisingContract Class | Aptify.Applications.Advertising Namespace


Validate Method

Aptify 5.0 Software Development Kit (SDK)

AdvertisingContract.Validate Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Validate();

public override bool Validate(ref String&);

See Also

AdvertisingContract Class | Aptify.Applications.Advertising Namespace


AdvertisingContract.Validate Method (String&)

public override bool Validate(
ref String& ErrorString
);

See Also

AdvertisingContract Class | Aptify.Applications.Advertising Namespace | AdvertisingContract.Validate Overload List


AdvertisingContractLayout Class

For a list of all members of this type, see AdvertisingContractLayout Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
AdvertisingLayoutBase
AdvertisingContractLayout

public class AdvertisingContractLayout : AdvertisingLayoutBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Advertising

Assembly: AdvertisingContractControls (in AdvertisingContractControls.dll)

See Also

AdvertisingContractLayout Members | Aptify.Applications.Advertising Namespace


AdvertisingContractLayout Members

AdvertisingContractLayout overview

Public Instance Constructors

AdvertisingContractLayout Constructor Initializes a new instance of the AdvertisingContractLayout class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

datEntity
dlgControlClicked
dlgKeyPress
dlgLostFocus
dlgOptinoSelected
dlgValueChanged
m_oSaleRepItem
msDatabase

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
LayoutDataComboControl (inherited from AdvertisingLayoutBase) |
LayoutDataControl (inherited from AdvertisingLayoutBase) |
LayoutLinkBoxControl (inherited from AdvertisingLayoutBase) |
moMessage |
mTabs |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
subPublications |
subSalesReps |
SubtypeControl (inherited from AdvertisingLayoutBase) |
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AddControlEventHandler (inherited from AdvertisingLayoutBase) |
AddControlEventHandlerFromFieldName (inherited from AdvertisingLayoutBase) |
AddControlEventHandlerFromSubTypeName (inherited from AdvertisingLayoutBase) |
AdjustFormScrollbars (inherited from ContainerControl) |
ConfigureControlEventHandling |
ConfigureDisplay |
ConfigureMessageObject |
ControlClicked |
ControlKeyPress |
ControlLostFocus |
ControlValueChanged |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DeConfigureMessageObject |
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControlFromFieldName (inherited from AdvertisingLayoutBase) |
FindDataControl (inherited from AdvertisingLayoutBase) |
FindSubTypeControlFromName (inherited from AdvertisingLayoutBase) |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetControlFromFieldName (inherited from AdvertisingLayoutBase) |
GetControlProperty (inherited from AdvertisingLayoutBase) |
GetDataControlProperty (inherited from AdvertisingLayoutBase) |
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetSubTypeControlFromName (inherited from AdvertisingLayoutBase) |
GetTabControl (inherited from AdvertisingLayoutBase) | Overloaded.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded (inherited from FormTemplateLayout) | Raises the FormTemplateLoaded event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad |
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
OptionSelected |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlProperty (inherited from AdvertisingLayoutBase) | Overloaded.
SetDataControlProperty (inherited from AdvertisingLayoutBase) | Overloaded.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

AdvertisingContractLayout Class | Aptify.Applications.Advertising Namespace


AdvertisingContractLayout Constructor

Initializes a new instance of the AdvertisingContractLayout class.

public AdvertisingContractLayout();

See Also

AdvertisingContractLayout Class | Aptify.Applications.Advertising Namespace


AdvertisingContractLayout Fields

The fields of the AdvertisingContractLayout class are listed below. For a complete list of AdvertisingContractLayout class members, see the AdvertisingContractLayout Members topic.

Protected Instance Fields

datEntity
dlgControlClicked
dlgKeyPress
dlgLostFocus
dlgOptinoSelected
dlgValueChanged
m_oSaleRepItem
msDatabase

See Also

AdvertisingContractLayout Class | Aptify.Applications.Advertising Namespace


AdvertisingContractLayout.datEntity Field

protected datEntity datEntity;

See Also

AdvertisingContractLayout Class | Aptify.Applications.Advertising Namespace


AdvertisingContractLayout.dlgControlClicked Field

protected dlgControlClicked dlgControlClicked;

See Also

AdvertisingContractLayout Class | Aptify.Applications.Advertising Namespace


AdvertisingContractLayout.dlgKeyPress Field

protected dlgKeyPress dlgKeyPress;

See Also

AdvertisingContractLayout Class | Aptify.Applications.Advertising Namespace


AdvertisingContractLayout.dlgLostFocus Field

protected dlgLostFocus dlgLostFocus;

See Also

AdvertisingContractLayout Class | Aptify.Applications.Advertising Namespace


AdvertisingContractLayout.dlgOptinoSelected Field

protected dlgOptinoSelected dlgOptinoSelected;

See Also

AdvertisingContractLayout Class | Aptify.Applications.Advertising Namespace


AdvertisingContractLayout.dlgValueChanged Field

protected dlgValueChanged dlgValueChanged;

See Also

AdvertisingContractLayout Class | Aptify.Applications.Advertising Namespace


AdvertisingContractLayout.m_oSaleRepItem Field

protected m_oSaleRepItem m_oSaleRepItem;

See Also

AdvertisingContractLayout Class | Aptify.Applications.Advertising Namespace


AdvertisingContractLayout.msDatabase Field

protected msDatabase msDatabase;

See Also

AdvertisingContractLayout Class | Aptify.Applications.Advertising Namespace


AdvertisingContractLayout Properties

The properties of the AdvertisingContractLayout class are listed below. For a complete list of AdvertisingContractLayout class members, see the AdvertisingContractLayout Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
LayoutDataComboControl (inherited from AdvertisingLayoutBase) |
LayoutDataControl (inherited from AdvertisingLayoutBase) |
LayoutLinkBoxControl (inherited from AdvertisingLayoutBase) |
moMessage |
mTabs |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
subPublications |
subSalesReps |
SubtypeControl (inherited from AdvertisingLayoutBase) |
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

AdvertisingContractLayout Class | Aptify.Applications.Advertising Namespace


moMessage Property

Aptify 5.0 Software Development Kit (SDK)

AdvertisingContractLayout.moMessage Property

protected virtual AptifyMessage moMessage {get; set;}

See Also

AdvertisingContractLayout Class | Aptify.Applications.Advertising Namespace


mTabs Property

Aptify 5.0 Software Development Kit (SDK)

AdvertisingContractLayout.mTabs Property

protected virtual UltraTabControl mTabs {get; set;}

See Also

AdvertisingContractLayout Class | Aptify.Applications.Advertising Namespace


subPublications Property

Aptify 5.0 Software Development Kit (SDK)

AdvertisingContractLayout.subPublications Property

protected virtual AptifySubType subPublications {get; set;}

See Also

AdvertisingContractLayout Class | Aptify.Applications.Advertising Namespace


subSalesReps Property

Aptify 5.0 Software Development Kit (SDK)

AdvertisingContractLayout.subSalesReps Property

protected virtual AptifySubType subSalesReps {get; set;}

See Also

AdvertisingContractLayout Class | Aptify.Applications.Advertising Namespace


AdvertisingContractLayout Methods

The methods of the AdvertisingContractLayout class are listed below. For a complete list of AdvertisingContractLayout class members, see the AdvertisingContractLayout Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AddControlEventHandler (inherited from AdvertisingLayoutBase) |
AddControlEventHandlerFromFieldName (inherited from AdvertisingLayoutBase) |
AddControlEventHandlerFromSubTypeName (inherited from AdvertisingLayoutBase) |
AdjustFormScrollbars (inherited from ContainerControl) |
ConfigureControlEventHandling |
ConfigureDisplay |
ConfigureMessageObject |
ControlClicked |
ControlKeyPress |
ControlLostFocus |
ControlValueChanged |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DeConfigureMessageObject |
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControlFromFieldName (inherited from AdvertisingLayoutBase) |
FindDataControl (inherited from AdvertisingLayoutBase) |
FindSubTypeControlFromName (inherited from AdvertisingLayoutBase) |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetControlFromFieldName (inherited from AdvertisingLayoutBase) |
GetControlProperty (inherited from AdvertisingLayoutBase) |
GetDataControlProperty (inherited from AdvertisingLayoutBase) |
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetSubTypeControlFromName (inherited from AdvertisingLayoutBase) |
GetTabControl (inherited from AdvertisingLayoutBase) | Overloaded.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded (inherited from FormTemplateLayout) | Raises the FormTemplateLoaded event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad |
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
OptionSelected |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlProperty (inherited from AdvertisingLayoutBase) | Overloaded.
SetDataControlProperty (inherited from AdvertisingLayoutBase) | Overloaded.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

AdvertisingContractLayout Class | Aptify.Applications.Advertising Namespace


AdvertisingContractLayout.ConfigureControlEventHandling Method

protected virtual void ConfigureControlEventHandling();

See Also

AdvertisingContractLayout Class | Aptify.Applications.Advertising Namespace


AdvertisingContractLayout.ConfigureDisplay Method

protected virtual void ConfigureDisplay();

See Also

AdvertisingContractLayout Class | Aptify.Applications.Advertising Namespace


AdvertisingContractLayout.ConfigureMessageObject Method

protected virtual void ConfigureMessageObject();

See Also

AdvertisingContractLayout Class | Aptify.Applications.Advertising Namespace


AdvertisingContractLayout.ControlClicked Method

protected virtual void ControlClicked(
Object sender,
EventArgs e
);

See Also

AdvertisingContractLayout Class | Aptify.Applications.Advertising Namespace


AdvertisingContractLayout.ControlKeyPress Method

protected virtual void ControlKeyPress(
Object sender,
KeyPressEventArgs e
);

See Also

AdvertisingContractLayout Class | Aptify.Applications.Advertising Namespace


AdvertisingContractLayout.ControlLostFocus Method

protected virtual void ControlLostFocus(
Object sender,
EventArgs e
);

See Also

AdvertisingContractLayout Class | Aptify.Applications.Advertising Namespace


AdvertisingContractLayout.ControlValueChanged Method

protected virtual void ControlValueChanged(
Object sender,
Object OldValue,
Object NewValue
);

See Also

AdvertisingContractLayout Class | Aptify.Applications.Advertising Namespace


AdvertisingContractLayout.DeConfigureMessageObject Method

protected virtual void DeConfigureMessageObject();

See Also

AdvertisingContractLayout Class | Aptify.Applications.Advertising Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

AdvertisingContractLayout.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

AdvertisingContractLayout Class | Aptify.Applications.Advertising Namespace


AdvertisingContractLayout.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

AdvertisingContractLayout Class | Aptify.Applications.Advertising Namespace | AdvertisingContractLayout.Dispose Overload List


AdvertisingContractLayout.OnLoad Method

protected override void OnLoad(
EventArgs e
);

See Also

AdvertisingContractLayout Class | Aptify.Applications.Advertising Namespace


AdvertisingContractLayout.OnRefresh Method

protected override void OnRefresh();

Implements

IFormComponent.

See Also

AdvertisingContractLayout Class | Aptify.Applications.Advertising Namespace


AdvertisingContractLayout.OptionSelected Method

protected virtual void OptionSelected(
Object sender,
GroupedOptions.OptionSelectedEventArgs e
);

See Also

AdvertisingContractLayout Class | Aptify.Applications.Advertising Namespace


AdvertisingContractPubLayout Class

For a list of all members of this type, see AdvertisingContractPubLayout Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
AdvertisingLayoutBase
AdvertisingContractPubLayout

public class AdvertisingContractPubLayout : AdvertisingLayoutBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Advertising

Assembly: AdvertisingContractControls (in AdvertisingContractControls.dll)

See Also

AdvertisingContractPubLayout Members | Aptify.Applications.Advertising Namespace


AdvertisingContractPubLayout Members

AdvertisingContractPubLayout overview

Public Instance Constructors

AdvertisingContractPubLayout Constructor Initializes a new instance of the AdvertisingContractPubLayout class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

dlgControlValueChanged
msDatabase

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
LayoutDataComboControl (inherited from AdvertisingLayoutBase) |
LayoutDataControl (inherited from AdvertisingLayoutBase) |
LayoutLinkBoxControl (inherited from AdvertisingLayoutBase) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
SubtypeControl (inherited from AdvertisingLayoutBase) |
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AddControlEventHandler (inherited from AdvertisingLayoutBase) |
AddControlEventHandlerFromFieldName (inherited from AdvertisingLayoutBase) |
AddControlEventHandlerFromSubTypeName (inherited from AdvertisingLayoutBase) |
AdjustFormScrollbars (inherited from ContainerControl) |
ConfigureDisplay |
ControlValueChanged |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormTemplateLayout) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControlFromFieldName (inherited from AdvertisingLayoutBase) |
FindDataControl (inherited from AdvertisingLayoutBase) |
FindSubTypeControlFromName (inherited from AdvertisingLayoutBase) |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetControlFromFieldName (inherited from AdvertisingLayoutBase) |
GetControlProperty (inherited from AdvertisingLayoutBase) |
GetDataControlProperty (inherited from AdvertisingLayoutBase) |
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetSubTypeControlFromName (inherited from AdvertisingLayoutBase) |
GetTabControl (inherited from AdvertisingLayoutBase) | Overloaded.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded (inherited from FormTemplateLayout) | Raises the FormTemplateLoaded event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad |
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlProperty (inherited from AdvertisingLayoutBase) | Overloaded.
SetDataControlProperty (inherited from AdvertisingLayoutBase) | Overloaded.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetEventHandlers |
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

AdvertisingContractPubLayout Class | Aptify.Applications.Advertising Namespace


AdvertisingContractPubLayout Constructor

Initializes a new instance of the AdvertisingContractPubLayout class.

public AdvertisingContractPubLayout();

See Also

AdvertisingContractPubLayout Class | Aptify.Applications.Advertising Namespace


AdvertisingContractPubLayout Fields

The fields of the AdvertisingContractPubLayout class are listed below. For a complete list of AdvertisingContractPubLayout class members, see the AdvertisingContractPubLayout Members topic.

Protected Instance Fields

dlgControlValueChanged
msDatabase

See Also

AdvertisingContractPubLayout Class | Aptify.Applications.Advertising Namespace


AdvertisingContractPubLayout.dlgControlValueChanged Field

protected dlgControlValueChanged dlgControlValueChanged;

See Also

AdvertisingContractPubLayout Class | Aptify.Applications.Advertising Namespace


AdvertisingContractPubLayout.msDatabase Field

protected msDatabase msDatabase;

See Also

AdvertisingContractPubLayout Class | Aptify.Applications.Advertising Namespace


AdvertisingContractPubLayout Methods

The methods of the AdvertisingContractPubLayout class are listed below. For a complete list of AdvertisingContractPubLayout class members, see the AdvertisingContractPubLayout Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AddControlEventHandler (inherited from AdvertisingLayoutBase) |
AddControlEventHandlerFromFieldName (inherited from AdvertisingLayoutBase) |
AddControlEventHandlerFromSubTypeName (inherited from AdvertisingLayoutBase) |
AdjustFormScrollbars (inherited from ContainerControl) |
ConfigureDisplay |
ControlValueChanged |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormTemplateLayout) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControlFromFieldName (inherited from AdvertisingLayoutBase) |
FindDataControl (inherited from AdvertisingLayoutBase) |
FindSubTypeControlFromName (inherited from AdvertisingLayoutBase) |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetControlFromFieldName (inherited from AdvertisingLayoutBase) |
GetControlProperty (inherited from AdvertisingLayoutBase) |
GetDataControlProperty (inherited from AdvertisingLayoutBase) |
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetSubTypeControlFromName (inherited from AdvertisingLayoutBase) |
GetTabControl (inherited from AdvertisingLayoutBase) | Overloaded.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded (inherited from FormTemplateLayout) | Raises the FormTemplateLoaded event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad |
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlProperty (inherited from AdvertisingLayoutBase) | Overloaded.
SetDataControlProperty (inherited from AdvertisingLayoutBase) | Overloaded.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetEventHandlers |
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

AdvertisingContractPubLayout Class | Aptify.Applications.Advertising Namespace


AdvertisingContractPubLayout.ConfigureDisplay Method

protected virtual void ConfigureDisplay();

See Also

AdvertisingContractPubLayout Class | Aptify.Applications.Advertising Namespace


AdvertisingContractPubLayout.ControlValueChanged Method

protected virtual void ControlValueChanged(
Object sender,
Object OldValue,
Object NewValue
);

See Also

AdvertisingContractPubLayout Class | Aptify.Applications.Advertising Namespace


AdvertisingContractPubLayout.OnLoad Method

protected override void OnLoad(
EventArgs e
);

See Also

AdvertisingContractPubLayout Class | Aptify.Applications.Advertising Namespace


AdvertisingContractPubLayout.OnRefresh Method

protected override void OnRefresh();

Implements

IFormComponent.

See Also

AdvertisingContractPubLayout Class | Aptify.Applications.Advertising Namespace


AdvertisingContractPubLayout.SetEventHandlers Method

protected virtual void SetEventHandlers();

See Also

AdvertisingContractPubLayout Class | Aptify.Applications.Advertising Namespace


AdvertisingContractSalesRepLayout Class

For a list of all members of this type, see AdvertisingContractSalesRepLayout Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
AdvertisingLayoutBase
AdvertisingContractSalesRepLayout

public class AdvertisingContractSalesRepLayout : AdvertisingLayoutBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Advertising

Assembly: AdvertisingContractControls (in AdvertisingContractControls.dll)

See Also

AdvertisingContractSalesRepLayout Members | Aptify.Applications.Advertising Namespace


AdvertisingContractSalesRepLayout Members

AdvertisingContractSalesRepLayout overview

Public Instance Constructors

AdvertisingContractSalesRepLayout Constructor Initializes a new instance of the AdvertisingContractSalesRepLayout class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

dlgControlValueChanged

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
LayoutDataComboControl (inherited from AdvertisingLayoutBase) |
LayoutDataControl (inherited from AdvertisingLayoutBase) |
LayoutLinkBoxControl (inherited from AdvertisingLayoutBase) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
SubtypeControl (inherited from AdvertisingLayoutBase) |
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AddControlEventHandler (inherited from AdvertisingLayoutBase) |
AddControlEventHandlerFromFieldName (inherited from AdvertisingLayoutBase) |
AddControlEventHandlerFromSubTypeName (inherited from AdvertisingLayoutBase) |
AdjustFormScrollbars (inherited from ContainerControl) |
ControlValueChanged |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormTemplateLayout) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControlFromFieldName (inherited from AdvertisingLayoutBase) |
FindDataControl (inherited from AdvertisingLayoutBase) |
FindSubTypeControlFromName (inherited from AdvertisingLayoutBase) |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetControlFromFieldName (inherited from AdvertisingLayoutBase) |
GetControlProperty (inherited from AdvertisingLayoutBase) |
GetDataControlProperty (inherited from AdvertisingLayoutBase) |
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetSubTypeControlFromName (inherited from AdvertisingLayoutBase) |
GetTabControl (inherited from AdvertisingLayoutBase) | Overloaded.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded (inherited from FormTemplateLayout) | Raises the FormTemplateLoaded event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad |
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlProperty (inherited from AdvertisingLayoutBase) | Overloaded.
SetDataControlProperty (inherited from AdvertisingLayoutBase) | Overloaded.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

AdvertisingContractSalesRepLayout Class | Aptify.Applications.Advertising Namespace


AdvertisingContractSalesRepLayout Constructor

Initializes a new instance of the AdvertisingContractSalesRepLayout class.

public AdvertisingContractSalesRepLayout();

See Also

AdvertisingContractSalesRepLayout Class | Aptify.Applications.Advertising Namespace


AdvertisingContractSalesRepLayout Fields

The fields of the AdvertisingContractSalesRepLayout class are listed below. For a complete list of AdvertisingContractSalesRepLayout class members, see the AdvertisingContractSalesRepLayout Members topic.

Protected Instance Fields

dlgControlValueChanged

See Also

AdvertisingContractSalesRepLayout Class | Aptify.Applications.Advertising Namespace


AdvertisingContractSalesRepLayout.dlgControlValueChanged Field

protected dlgControlValueChanged dlgControlValueChanged;

See Also

AdvertisingContractSalesRepLayout Class | Aptify.Applications.Advertising Namespace


AdvertisingContractSalesRepLayout Methods

The methods of the AdvertisingContractSalesRepLayout class are listed below. For a complete list of AdvertisingContractSalesRepLayout class members, see the AdvertisingContractSalesRepLayout Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AddControlEventHandler (inherited from AdvertisingLayoutBase) |
AddControlEventHandlerFromFieldName (inherited from AdvertisingLayoutBase) |
AddControlEventHandlerFromSubTypeName (inherited from AdvertisingLayoutBase) |
AdjustFormScrollbars (inherited from ContainerControl) |
ControlValueChanged |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormTemplateLayout) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControlFromFieldName (inherited from AdvertisingLayoutBase) |
FindDataControl (inherited from AdvertisingLayoutBase) |
FindSubTypeControlFromName (inherited from AdvertisingLayoutBase) |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetControlFromFieldName (inherited from AdvertisingLayoutBase) |
GetControlProperty (inherited from AdvertisingLayoutBase) |
GetDataControlProperty (inherited from AdvertisingLayoutBase) |
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetSubTypeControlFromName (inherited from AdvertisingLayoutBase) |
GetTabControl (inherited from AdvertisingLayoutBase) | Overloaded.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded (inherited from FormTemplateLayout) | Raises the FormTemplateLoaded event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad |
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlProperty (inherited from AdvertisingLayoutBase) | Overloaded.
SetDataControlProperty (inherited from AdvertisingLayoutBase) | Overloaded.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

AdvertisingContractSalesRepLayout Class | Aptify.Applications.Advertising Namespace


AdvertisingContractSalesRepLayout.ControlValueChanged Method

protected virtual void ControlValueChanged(
Object sender,
Object OldValue,
Object NewValue
);

See Also

AdvertisingContractSalesRepLayout Class | Aptify.Applications.Advertising Namespace


AdvertisingContractSalesRepLayout.OnLoad Method

protected override void OnLoad(
EventArgs e
);

See Also

AdvertisingContractSalesRepLayout Class | Aptify.Applications.Advertising Namespace


AdvertisingContractSalesRepLayout.OnRefresh Method

protected override void OnRefresh();

Implements

IFormComponent.

See Also

AdvertisingContractSalesRepLayout Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder Class

This class provides the implementation for business logic for the Advertising Insertion Orders entity in the Aptify Advertising Management system.

For a list of all members of this type, see AdvertisingInsertionOrder Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
AdvertisingInsertionOrder

public class AdvertisingInsertionOrder : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Advertising

Assembly: AdvertisingInsertionOrder (in AdvertisingInsertionOrder.dll)

See Also

AdvertisingInsertionOrder Members | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder Members

AdvertisingInsertionOrder overview

Public Instance Constructors

AdvertisingInsertionOrder Constructor Initializes a new instance of the AdvertisingInsertionOrder class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentEmployeeID | This member returns the Aptify Employees Entity ID value for the currently logged in user. If no Employee ID is found associated with the Current User, or if an error takes place, a value of -1 is returned.
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
OKToModify | This property returns True if the Insertion Order maybe modified, otherwise it returns False. This property checks to see if an order has been created for this Insertion Order and if the Order has been shipped or not. If the Order linked to the insertion order has been shipped it is no longer acceptable to modify the Insertion Order. In other cases, it is acceptable to modify an Insertion Order.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CalculateDiscount | This method is responsible for calculating discounts
CalculateRateCardRate | This method returns the rate calculated using the rate card functionality.
CalculateUnitCount | This method returns the number of units in the insertion order based on
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config | Overloaded.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetCurrencyTypeNumDigitsAfterDecimal | This method returns the number of digits to use after the decimal for the specified currency type.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetEmployeeName | Overloaded. Returns the name (FirstName+LastName) for the Current Employee
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetOrderData | This method returns all of the fields for a given Order ID in a single table. If the order is not found or an error takes place, the value of Nothing is returned.
GetOrderStatusID | Returns an ID value from the Order Status Types entity based on the Name provided.
GetPersonPaymentLevelID | This method returns the GLPaymentLevelID field from the Persons entity for the PersonID specified
GetProductGLAccount | Returns the GL Account to use for the specific Product ID, Account Type and GL Order Level ID. If GLOrderLevelID is not specified, the GetDefaultOrderLevelID() is called to get the default order level.
GetProductIssueRevenueRecognitionDate | This method returns the RevenueRecognitionDate field from the Product Issues entity for the specified ProductIssueID
GetRateCardRateGE | This method returns a GE Object for the Rate Card Rate sub-type for the current insertion order based on the information populated in the insertion order for Color Code, Size Code, Position Code and based on the current Advertising Contract ID (stored in Insertion Orders.AdvertisingContractID)
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetSQLLongValue | This method executes the provided SQL statement and returns the value from the statement. The statement is assume to return a single numeric value that can be cast to a Long.
GetSubTypeObject | Overloaded. Returns the Sub-Type object based on the index provided in SubTypeIndex
GetSystemFunctionalCurrencyTypeID | This method returns the ID value of the Currency Types entity record that is marked as the functional currency for the system (using the FunctionalCurrency BIT field in the Currency Types entity).
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
GetZeroRateTaxRateID | This method returns the lowest ID value from the Sales Tax Rates entity that has a Rate = 0
IsSameUnitDefintion | This method determines if the current unit definition has changed.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
OrderExists | This method internally uses the GetOrderData() method to determine if an order exists and returns True if it does exist and False otherwise.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded. This method overrides the base GE Validate to validate Insertion Order specific requirements. This method Validates the Billing elements of the Insertion Order( through ValidateBillTo() method), the SalesRep information (through the ValidateSalesRep() method ) and the Insertion Order options selectetd (through the ValidateInsertionOrderOptions() method).
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
Database |
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RecordVersionChanged |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AdjustAmount | This method adjusts the last line of the provided Order to make sure that the order total is equal to the Amount parameter. This method is used in various places within the class in order to ensure that rounding adjustments are accounted for in the final total for an insertion order's underlying Order in the Order Entry system.
AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
CalculateCommissionSplitPercentage | This method calculates the primary sales reps split percentage based on the total percentage that is used by sales reps for the insertion order other than the primary sales rep and returns that value as a decimal value through the PrimarySalesRepPercent OUT parameter.
CancelMultipleOrders | This method iterates through the AdvertisingInsertionOrderBillTo Sub-Type and calls DoCancelOrder() for each item within the sub-type that has an Order ID > 0.
CheckCredit | This method uses the Credit Check component registered within the Order Entry system to check credit for the provided OrderGE. The method invokes the object that implements Aptify.Applications.OrderEntry.ICheckCredit and is specified by the following Entity Attributes(same as for Order Entry) within the Orders entity. Object Repository Location - Attribute Name: Credit Check Object Class Name - Attribute Name: Credit Check Class Assembly Name - Attribute Name: Credit Check Assembly
CheckSubTypeDupes | This method checks to see if there are any duplicate records in the sub-type specified by SubTypeName by comparing the fields values in the CompareField field in each record and determining if more than one such record exists in the specified sub-type.
ClearBillToValues | This method clears the bill to information in the AdvertisingInsertionOrderBillTo sub-type by going through each sub-type record and setting OrderID, Amount and Balance to blank values. This method is called from the CreateMultipleOrders() method in the event of a failure of the method to complete its operation.
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateCancelRecognitionSchedTrans | This method creates a scheduled transaction for of revenue recognition for cancellations of advertising revenue at the date specified by Revenue Date.
CreateCancelReversalScheduledTransaction | This method creates a scheduled transaction for reversal of revenue for a cancellation order of advertising revenue at the date specified by Order Date.
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateMultipleOrders |
CreateNewOrder |
CreateOrders | This method creates order for the insertion order as required based on the BillTo sub-type in the Insertion Order.
CreatePaymentDetail | This method adds a Payment Line to the Payment GE for the OrderID and Amount specified
CreateRecognitionScheduledTransaction | This method creates a scheduled transaction for revenue recognition of advertising revenue at the date specified by Revenue Date.
CreateRecord (inherited from AptifyGenericEntity) |
CreateRefundPaymentHeader | This method sets up the payment header details for the Payments entity for a refund payment based on the information provided. The PaymentGE passed in should be a New Payments entity record.
CreateReversalScheduledTransaction | This method creates a scheduled transaction for revenue reversal of advertising revenue at the date specified by Order Date.
CreateScheduledTransaction | This method creates a scheduled transaction for the insertion order based on the revenue recognition date for the Product Issue that the insertion order is going into.
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
DoCancelOrder | This method cancels an individual order by creating a new order that has an Order Type of Cancellation and by reversing each line of the original order (specified by the Order ID parameter) and then saving the Cancellation Order.
DoesContractHaveAgency | Overloaded. This method determines if the advertising contract linked to this insertion order has an Advertising Agency attached to it (via the Advertising Contracts.AgencyID field) and returns True in that case, False otherwise.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
FormatDecimalAsCurrency | This method formats the specified decimal value to be used as a currency type with only the number of digits after decimal based on the system's functional currency.
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
GetBillToSplitAmounts |
GetCheckPaymentTypeID | This method retrieves a Payment Type ID (from the Payment Types entity) for the lowest ID that has its Type field exactly matching the value 'Check'
GetCreditMemoPaymentTypeID | Returns the lowest Payment Types record that has a name that excactly matches 'Credit Memo'
GetCreditOrderBalance | This method returns the balance of the specified Order record ID. It is assumed that the OrderID provided is a Credit Order that has a negative balance in the database(meaning a credit balance). The value returned will be a positive value representing the credit balance on the order.
GetDueDate | This method returns the due date to use when creating orders from this insertion order. The default functionality for this method uses an Entity Attribute in the Advertising Insertion Orders entity called DueDatePeriod which stores (in days) the period from the original order date to defer the due date for the insertion order.
GetLastPayementTypeInfo | This method returns payment information for the most recent payment posted against the Orders entity record specified by the OrderID parameter.
GetObjectByAttributes | This utility method will retrieve an object based on entity attribute information.
GetOptionsDataTable | This method returns a datatable with one row for each option that is included in this insertion order. By default, this method uses the Aptify DSL cache to retrieve the data, unless the CacheSetting is provided with an alternative option to Refresh or Bypass the cache.
GetOrderFieldValue | This method returns a single field from the Orders Entity for the specified OrderID. If it is necessary to retrieve more than one field value from an order, it is more efficient to use GetOrderData() which will return a DataTable with a single row in it for the specified Order ID.
GetPrimarySalesRepItemFromSubType | This method returns the AptifyGenericEntityBase object within the AdvertisingInsertionOrderSalesReps sub-type that matches the PrimarySalesRepID in the top-level Insertion Order record.
GetPurchaseOrderPaymentTypeID | Returns the lowest Payment Types record that has a Type that begins with 'Purchase Order'
GetScheduledTransactionRevenueDate | This method retrieves the original revenue recognition date(ScheduledDate) from the Scheduled Transaction that was created for the specified OrderID where the Type='Ad Revenue Recognition', which is the type that is used by this class when creating Scheduled Transactions for revenue recognition.
GetUnitDefinitionObject | This method is responsible for retrieving the Unit Definition object based on the attributes stored in the Advertising Unit Definitions Entity.
GetWriteOffPaymentTypeID | This method retrieves a Payment Type ID (from the Payment Types entity) for the lowest ID that has its Type field exactly matching the value 'Bad Debt'
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
InsertionOrderHasOrder | This method returns True if the Insertion Order has one or more Order linked to it through the AdvertisingInsertionOrderBillTo sub-type. In addition, the method returns the first OrderID found. In addition, the IsCancelled parameter returns True if the Insertion Order has a Cancellation Order. If Refresh is set to True, the system will pull data from the database, otherwise information from the GE object in memory will be used.
InternalSave | This method implements the Save() functionality specific to Insertion Order processing including creating and/or updating a record in the Orders entity when an insertion order reaches the appropriate Status level.
IsOverHundredPercent | This method is responsible for checking to see if the sum of all the SplitPercentage fields in the AdvertisingInsertionOrderSalesReps sub-type is over 100%.
IsTopAndSubSalesRepsPercentSync |
IsTopAndSubSalesRepsSync | This method checks to make sure the top-level field in the InsertionOrder PrimarySalesRepID matches the sub-type record in the Sales Reps sub-type that is marked as IsPrimary=1.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MarkOrderAsShipped | This method will mark the specified order as shipped so that when it is saved it will handle the appropriate processes for revenue recognition and other required process steps.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OffsetPayment | This method is responsible for offsetting payment between the original order and cancellation order
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
OptionExists | This method determines if the specified Advertising Option exists in the insertion order.
PopulateAddressWPersonInfo | This method populates the provided OrderGE ShipTo and BillTo Address and Phone information based on the BillToID person in the OrderGE. This is done using the PreferredAddress Object registered under the Persons entity with the Preferred Address Object and Preferred Address Object Class Entity Attributes within the Persons Entity.
PopulateOrderLine | This method populates an Order Line GE object from the parameters provided.
PopulateShipToInfo | This method populates the ShipToAddressID and ShipToPhoneID fields in the OrderGE from values in the first row of dtTemp assumed to be named AddressID and PhoneID respectively
ProductExists | This method determines if the specified product already exists in the OrderGE object
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
RemoveOrderLines | This method is used to remove order lines that have a matching attribute value(non-zero) for the specified FieldToCheck parameter. This method is used by various areas of the class to remove unnecessary order lines that maybe created during a process and are temporary in nature. This is a utility method.
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SalesSubTypeTotalPercentage | This method calculates the sum of all of the SplitPercentage fields in the AdvertisingInsertionOrderSalesReps sub-type and returns that calculated summary value.
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetSeparateDiscountPerLine |
SetupOptionOrderLines | This method creates order lines in the OrderGE object based on the options that were selected in the Insertion Order. For each option in the AdvertisingInsertionOrderOptions sub-type, one order line is created in this method.
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
SplitAndNormalizeAmount |
UpdateMultipleOrders | This method is responsible for updating all of the orders linked to this insertion order whenever an insertion order is saved and changes have been made that require updates to be propogated to the underlying Order records.
UpdateOptionOrderLines |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateBillTo | This method validates the Billing aspects of the Insertion Order. Billing information is required for Insertion Orders once they are at the Status of Quote or above in the process. Billing information includes the AdvertisingInsertionOrderBillTo Sub-Type as well as the EmployeeID field on the Insertion Order top-level record. In addition, for Insertion Orders that already have an Order record created and linked in the Orders entity, BillTo information may not be deleted.
ValidateInsertionOrderOptions | This method validates the AdvertisingInsertionOrderOptions sub-type to make sure that an option has not been selected more than once. In addition, Options may not be altered after an Order is created in the Orders Entity for this Insertion Order since the Options selected for an insertio may alter the financial aspects of the record.
ValidateProductRevenueRecognitionDate | This method checks to Revenue Recognition Date at the Product level. If the Revenue Recognition Date field in the Products entity for the specified Product ID is NOT blank, this method will return False as Advertising Insertion Orders utilize the Revenue Recognition Date at the Product Issue level to drive revenue recognition through Scheduled Transactions.
ValidateSalesRep | This method validates the sales rep information in the Insertion Order by checking to make sure that Top and Sub-Type level sales rep information is in sync, that commission percentage totals do not exceed 100% and that Top and Sub-Type level commision percentages are in sync for the primary sales rep. Lastly, this method checks to make sure that there are not any version conflicts with this insertion order if an Orders entity record has been created and is linked to the Insertion Order.
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder Constructor

Initializes a new instance of the AdvertisingInsertionOrder class.

public AdvertisingInsertionOrder();

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder Properties

The properties of the AdvertisingInsertionOrder class are listed below. For a complete list of AdvertisingInsertionOrder class members, see the AdvertisingInsertionOrder Members topic.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentEmployeeID | This member returns the Aptify Employees Entity ID value for the currently logged in user. If no Employee ID is found associated with the Current User, or if an error takes place, a value of -1 is returned.
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
OKToModify | This property returns True if the Insertion Order maybe modified, otherwise it returns False. This property checks to see if an order has been created for this Insertion Order and if the Order has been shipped or not. If the Order linked to the insertion order has been shipped it is no longer acceptable to modify the Insertion Order. In other cases, it is acceptable to modify an Insertion Order.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
Database |
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RecordVersionChanged |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


CurrentEmployeeID Property

Aptify 5.0 Software Development Kit (SDK)

AdvertisingInsertionOrder.CurrentEmployeeID Property

This member returns the Aptify Employees Entity ID value for the currently logged in user. If no Employee ID is found associated with the Current User, or if an error takes place, a value of -1 is returned.

public virtual Int64 CurrentEmployeeID {get;}

Property Value

Remarks

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


Database Property

Aptify 5.0 Software Development Kit (SDK)

AdvertisingInsertionOrder.Database Property

protected virtual String Database {get;}

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


OKToModify Property

Aptify 5.0 Software Development Kit (SDK)

AdvertisingInsertionOrder.OKToModify Property

This property returns True if the Insertion Order maybe modified, otherwise it returns False. This property checks to see if an order has been created for this Insertion Order and if the Order has been shipped or not. If the Order linked to the insertion order has been shipped it is no longer acceptable to modify the Insertion Order. In other cases, it is acceptable to modify an Insertion Order.

public virtual Boolean OKToModify {get;}

Property Value

Remarks

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


RecordVersionChanged Property

Aptify 5.0 Software Development Kit (SDK)

AdvertisingInsertionOrder.RecordVersionChanged Property

protected virtual Boolean RecordVersionChanged {get;}

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder Methods

The methods of the AdvertisingInsertionOrder class are listed below. For a complete list of AdvertisingInsertionOrder class members, see the AdvertisingInsertionOrder Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CalculateDiscount | This method is responsible for calculating discounts
CalculateRateCardRate | This method returns the rate calculated using the rate card functionality.
CalculateUnitCount | This method returns the number of units in the insertion order based on
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config | Overloaded.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetCurrencyTypeNumDigitsAfterDecimal | This method returns the number of digits to use after the decimal for the specified currency type.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetEmployeeName | Overloaded. Returns the name (FirstName+LastName) for the Current Employee
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetOrderData | This method returns all of the fields for a given Order ID in a single table. If the order is not found or an error takes place, the value of Nothing is returned.
GetOrderStatusID | Returns an ID value from the Order Status Types entity based on the Name provided.
GetPersonPaymentLevelID | This method returns the GLPaymentLevelID field from the Persons entity for the PersonID specified
GetProductGLAccount | Returns the GL Account to use for the specific Product ID, Account Type and GL Order Level ID. If GLOrderLevelID is not specified, the GetDefaultOrderLevelID() is called to get the default order level.
GetProductIssueRevenueRecognitionDate | This method returns the RevenueRecognitionDate field from the Product Issues entity for the specified ProductIssueID
GetRateCardRateGE | This method returns a GE Object for the Rate Card Rate sub-type for the current insertion order based on the information populated in the insertion order for Color Code, Size Code, Position Code and based on the current Advertising Contract ID (stored in Insertion Orders.AdvertisingContractID)
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetSQLLongValue | This method executes the provided SQL statement and returns the value from the statement. The statement is assume to return a single numeric value that can be cast to a Long.
GetSubTypeObject | Overloaded. Returns the Sub-Type object based on the index provided in SubTypeIndex
GetSystemFunctionalCurrencyTypeID | This method returns the ID value of the Currency Types entity record that is marked as the functional currency for the system (using the FunctionalCurrency BIT field in the Currency Types entity).
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
GetZeroRateTaxRateID | This method returns the lowest ID value from the Sales Tax Rates entity that has a Rate = 0
IsSameUnitDefintion | This method determines if the current unit definition has changed.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
OrderExists | This method internally uses the GetOrderData() method to determine if an order exists and returns True if it does exist and False otherwise.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded. This method overrides the base GE Validate to validate Insertion Order specific requirements. This method Validates the Billing elements of the Insertion Order( through ValidateBillTo() method), the SalesRep information (through the ValidateSalesRep() method ) and the Insertion Order options selectetd (through the ValidateInsertionOrderOptions() method).
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AdjustAmount | This method adjusts the last line of the provided Order to make sure that the order total is equal to the Amount parameter. This method is used in various places within the class in order to ensure that rounding adjustments are accounted for in the final total for an insertion order's underlying Order in the Order Entry system.
AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
CalculateCommissionSplitPercentage | This method calculates the primary sales reps split percentage based on the total percentage that is used by sales reps for the insertion order other than the primary sales rep and returns that value as a decimal value through the PrimarySalesRepPercent OUT parameter.
CancelMultipleOrders | This method iterates through the AdvertisingInsertionOrderBillTo Sub-Type and calls DoCancelOrder() for each item within the sub-type that has an Order ID > 0.
CheckCredit | This method uses the Credit Check component registered within the Order Entry system to check credit for the provided OrderGE. The method invokes the object that implements Aptify.Applications.OrderEntry.ICheckCredit and is specified by the following Entity Attributes(same as for Order Entry) within the Orders entity. Object Repository Location - Attribute Name: Credit Check Object Class Name - Attribute Name: Credit Check Class Assembly Name - Attribute Name: Credit Check Assembly
CheckSubTypeDupes | This method checks to see if there are any duplicate records in the sub-type specified by SubTypeName by comparing the fields values in the CompareField field in each record and determining if more than one such record exists in the specified sub-type.
ClearBillToValues | This method clears the bill to information in the AdvertisingInsertionOrderBillTo sub-type by going through each sub-type record and setting OrderID, Amount and Balance to blank values. This method is called from the CreateMultipleOrders() method in the event of a failure of the method to complete its operation.
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateCancelRecognitionSchedTrans | This method creates a scheduled transaction for of revenue recognition for cancellations of advertising revenue at the date specified by Revenue Date.
CreateCancelReversalScheduledTransaction | This method creates a scheduled transaction for reversal of revenue for a cancellation order of advertising revenue at the date specified by Order Date.
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateMultipleOrders |
CreateNewOrder |
CreateOrders | This method creates order for the insertion order as required based on the BillTo sub-type in the Insertion Order.
CreatePaymentDetail | This method adds a Payment Line to the Payment GE for the OrderID and Amount specified
CreateRecognitionScheduledTransaction | This method creates a scheduled transaction for revenue recognition of advertising revenue at the date specified by Revenue Date.
CreateRecord (inherited from AptifyGenericEntity) |
CreateRefundPaymentHeader | This method sets up the payment header details for the Payments entity for a refund payment based on the information provided. The PaymentGE passed in should be a New Payments entity record.
CreateReversalScheduledTransaction | This method creates a scheduled transaction for revenue reversal of advertising revenue at the date specified by Order Date.
CreateScheduledTransaction | This method creates a scheduled transaction for the insertion order based on the revenue recognition date for the Product Issue that the insertion order is going into.
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
DoCancelOrder | This method cancels an individual order by creating a new order that has an Order Type of Cancellation and by reversing each line of the original order (specified by the Order ID parameter) and then saving the Cancellation Order.
DoesContractHaveAgency | Overloaded. This method determines if the advertising contract linked to this insertion order has an Advertising Agency attached to it (via the Advertising Contracts.AgencyID field) and returns True in that case, False otherwise.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
FormatDecimalAsCurrency | This method formats the specified decimal value to be used as a currency type with only the number of digits after decimal based on the system's functional currency.
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
GetBillToSplitAmounts |
GetCheckPaymentTypeID | This method retrieves a Payment Type ID (from the Payment Types entity) for the lowest ID that has its Type field exactly matching the value 'Check'
GetCreditMemoPaymentTypeID | Returns the lowest Payment Types record that has a name that excactly matches 'Credit Memo'
GetCreditOrderBalance | This method returns the balance of the specified Order record ID. It is assumed that the OrderID provided is a Credit Order that has a negative balance in the database(meaning a credit balance). The value returned will be a positive value representing the credit balance on the order.
GetDueDate | This method returns the due date to use when creating orders from this insertion order. The default functionality for this method uses an Entity Attribute in the Advertising Insertion Orders entity called DueDatePeriod which stores (in days) the period from the original order date to defer the due date for the insertion order.
GetLastPayementTypeInfo | This method returns payment information for the most recent payment posted against the Orders entity record specified by the OrderID parameter.
GetObjectByAttributes | This utility method will retrieve an object based on entity attribute information.
GetOptionsDataTable | This method returns a datatable with one row for each option that is included in this insertion order. By default, this method uses the Aptify DSL cache to retrieve the data, unless the CacheSetting is provided with an alternative option to Refresh or Bypass the cache.
GetOrderFieldValue | This method returns a single field from the Orders Entity for the specified OrderID. If it is necessary to retrieve more than one field value from an order, it is more efficient to use GetOrderData() which will return a DataTable with a single row in it for the specified Order ID.
GetPrimarySalesRepItemFromSubType | This method returns the AptifyGenericEntityBase object within the AdvertisingInsertionOrderSalesReps sub-type that matches the PrimarySalesRepID in the top-level Insertion Order record.
GetPurchaseOrderPaymentTypeID | Returns the lowest Payment Types record that has a Type that begins with 'Purchase Order'
GetScheduledTransactionRevenueDate | This method retrieves the original revenue recognition date(ScheduledDate) from the Scheduled Transaction that was created for the specified OrderID where the Type='Ad Revenue Recognition', which is the type that is used by this class when creating Scheduled Transactions for revenue recognition.
GetUnitDefinitionObject | This method is responsible for retrieving the Unit Definition object based on the attributes stored in the Advertising Unit Definitions Entity.
GetWriteOffPaymentTypeID | This method retrieves a Payment Type ID (from the Payment Types entity) for the lowest ID that has its Type field exactly matching the value 'Bad Debt'
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
InsertionOrderHasOrder | This method returns True if the Insertion Order has one or more Order linked to it through the AdvertisingInsertionOrderBillTo sub-type. In addition, the method returns the first OrderID found. In addition, the IsCancelled parameter returns True if the Insertion Order has a Cancellation Order. If Refresh is set to True, the system will pull data from the database, otherwise information from the GE object in memory will be used.
InternalSave | This method implements the Save() functionality specific to Insertion Order processing including creating and/or updating a record in the Orders entity when an insertion order reaches the appropriate Status level.
IsOverHundredPercent | This method is responsible for checking to see if the sum of all the SplitPercentage fields in the AdvertisingInsertionOrderSalesReps sub-type is over 100%.
IsTopAndSubSalesRepsPercentSync |
IsTopAndSubSalesRepsSync | This method checks to make sure the top-level field in the InsertionOrder PrimarySalesRepID matches the sub-type record in the Sales Reps sub-type that is marked as IsPrimary=1.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MarkOrderAsShipped | This method will mark the specified order as shipped so that when it is saved it will handle the appropriate processes for revenue recognition and other required process steps.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OffsetPayment | This method is responsible for offsetting payment between the original order and cancellation order
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
OptionExists | This method determines if the specified Advertising Option exists in the insertion order.
PopulateAddressWPersonInfo | This method populates the provided OrderGE ShipTo and BillTo Address and Phone information based on the BillToID person in the OrderGE. This is done using the PreferredAddress Object registered under the Persons entity with the Preferred Address Object and Preferred Address Object Class Entity Attributes within the Persons Entity.
PopulateOrderLine | This method populates an Order Line GE object from the parameters provided.
PopulateShipToInfo | This method populates the ShipToAddressID and ShipToPhoneID fields in the OrderGE from values in the first row of dtTemp assumed to be named AddressID and PhoneID respectively
ProductExists | This method determines if the specified product already exists in the OrderGE object
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
RemoveOrderLines | This method is used to remove order lines that have a matching attribute value(non-zero) for the specified FieldToCheck parameter. This method is used by various areas of the class to remove unnecessary order lines that maybe created during a process and are temporary in nature. This is a utility method.
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SalesSubTypeTotalPercentage | This method calculates the sum of all of the SplitPercentage fields in the AdvertisingInsertionOrderSalesReps sub-type and returns that calculated summary value.
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetSeparateDiscountPerLine |
SetupOptionOrderLines | This method creates order lines in the OrderGE object based on the options that were selected in the Insertion Order. For each option in the AdvertisingInsertionOrderOptions sub-type, one order line is created in this method.
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
SplitAndNormalizeAmount |
UpdateMultipleOrders | This method is responsible for updating all of the orders linked to this insertion order whenever an insertion order is saved and changes have been made that require updates to be propogated to the underlying Order records.
UpdateOptionOrderLines |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateBillTo | This method validates the Billing aspects of the Insertion Order. Billing information is required for Insertion Orders once they are at the Status of Quote or above in the process. Billing information includes the AdvertisingInsertionOrderBillTo Sub-Type as well as the EmployeeID field on the Insertion Order top-level record. In addition, for Insertion Orders that already have an Order record created and linked in the Orders entity, BillTo information may not be deleted.
ValidateInsertionOrderOptions | This method validates the AdvertisingInsertionOrderOptions sub-type to make sure that an option has not been selected more than once. In addition, Options may not be altered after an Order is created in the Orders Entity for this Insertion Order since the Options selected for an insertio may alter the financial aspects of the record.
ValidateProductRevenueRecognitionDate | This method checks to Revenue Recognition Date at the Product level. If the Revenue Recognition Date field in the Products entity for the specified Product ID is NOT blank, this method will return False as Advertising Insertion Orders utilize the Revenue Recognition Date at the Product Issue level to drive revenue recognition through Scheduled Transactions.
ValidateSalesRep | This method validates the sales rep information in the Insertion Order by checking to make sure that Top and Sub-Type level sales rep information is in sync, that commission percentage totals do not exceed 100% and that Top and Sub-Type level commision percentages are in sync for the primary sales rep. Lastly, this method checks to make sure that there are not any version conflicts with this insertion order if an Orders entity record has been created and is linked to the Insertion Order.
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.AdjustAmount Method

This method adjusts the last line of the provided Order to make sure that the order total is equal to the Amount parameter. This method is used in various places within the class in order to ensure that rounding adjustments are accounted for in the final total for an insertion order's underlying Order in the Order Entry system.

protected virtual bool AdjustAmount(
AptifyGenericEntityBase OrderGE,
Decimal Amount,
Decimal Discount
);

Parameters

OrderGE
Amount
Discount

Return Value

Remarks

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.CalculateCommissionSplitPercentage Method

This method calculates the primary sales reps split percentage based on the total percentage that is used by sales reps for the insertion order other than the primary sales rep and returns that value as a decimal value through the PrimarySalesRepPercent OUT parameter.

protected virtual bool CalculateCommissionSplitPercentage(
ref Decimal& PrimarySalesRepPercent
);

Parameters

PrimarySalesRepPercent

Return Value

True if succesful, False otherwise

Remarks

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.CalculateDiscount Method

This method is responsible for calculating discounts

public virtual bool CalculateDiscount(
String DiscountType,
Decimal RateCardAmount,
ref Decimal& DiscountPercent,
ref Decimal& DiscountAmount,
Decimal DiscretionaryDiscount,
ref Decimal& TotalAmount
);

Parameters

DiscountType
RateCardAmount
DiscountPercent
DiscountAmount
DiscretionaryDiscount
TotalAmount

Return Value

Remarks

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.CalculateRateCardRate Method

This method returns the rate calculated using the rate card functionality.

public virtual decimal CalculateRateCardRate();

Return Value

Remarks

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.CalculateUnitCount Method

This method returns the number of units in the insertion order based on

public virtual double CalculateUnitCount();

Return Value

Remarks

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.CancelMultipleOrders Method

This method iterates through the AdvertisingInsertionOrderBillTo Sub-Type and calls DoCancelOrder() for each item within the sub-type that has an Order ID > 0.

protected virtual bool CancelMultipleOrders(
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

Return Value

Remarks

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.CheckCredit Method

This method uses the Credit Check component registered within the Order Entry system to check credit for the provided OrderGE. The method invokes the object that implements Aptify.Applications.OrderEntry.ICheckCredit and is specified by the following Entity Attributes(same as for Order Entry) within the Orders entity. Object Repository Location - Attribute Name: Credit Check Object Class Name - Attribute Name: Credit Check Class Assembly Name - Attribute Name: Credit Check Assembly

protected virtual bool CheckCredit(
AptifyGenericEntityBase OrderGE,
ref String& ErrorMessage
);

Parameters

OrderGE
ErrorMessage

Return Value

Remarks

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.CheckSubTypeDupes Method

This method checks to see if there are any duplicate records in the sub-type specified by SubTypeName by comparing the fields values in the CompareField field in each record and determining if more than one such record exists in the specified sub-type.

protected virtual bool CheckSubTypeDupes(
String SubTypeName,
String CompareField,
Int32 Sequence,
ref String& Duplicates,
ref String& DuplicateComparedFieldValue
);

Parameters

SubTypeName
CompareField
Sequence
Duplicates
DuplicateComparedFieldValue

Return Value

Remarks

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.ClearBillToValues Method

This method clears the bill to information in the AdvertisingInsertionOrderBillTo sub-type by going through each sub-type record and setting OrderID, Amount and Balance to blank values. This method is called from the CreateMultipleOrders() method in the event of a failure of the method to complete its operation.

protected virtual bool ClearBillToValues();

Return Value

Remarks

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


Config Method

Aptify 5.0 Software Development Kit (SDK)

AdvertisingInsertionOrder.Config Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual void Config(AptifySubTypeBase);

Inherited from AptifyGenericEntity.

public override void Config(AptifySubTypeBase,Int64);

Inherited from AptifyGenericEntityBase.

public virtual void Config(UserCredentials,String);

public override void Config(UserCredentials,String,Int64);

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.Config Method (UserCredentials, String, Int64)

public override void Config(
UserCredentials UserCredentials,
String EntityName,
Int64 RecordID
);

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace | AdvertisingInsertionOrder.Config Overload List


AdvertisingInsertionOrder.CreateCancelRecognitionSchedTrans Method

This method creates a scheduled transaction for of revenue recognition for cancellations of advertising revenue at the date specified by Revenue Date.

protected virtual bool CreateCancelRecognitionSchedTrans(
AptifyGenericEntityBase ScheduledTransactionGE,
String RevenueGLAccount,
String DeferredGLAccount,
String DiscountGLAccount,
DateTime RevenueDate,
DateTime OrderDate,
Int64 OrderID,
Int64 ProductID,
Decimal Amount,
Decimal DiscountAmount
);

Parameters

ScheduledTransactionGE
RevenueGLAccount
DeferredGLAccount
DiscountGLAccount
RevenueDate
OrderDate
OrderID
ProductID
Amount
DiscountAmount

Return Value

Remarks

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.CreateCancelReversalScheduledTransaction Method

This method creates a scheduled transaction for reversal of revenue for a cancellation order of advertising revenue at the date specified by Order Date.

protected virtual bool CreateCancelReversalScheduledTransaction(
AptifyGenericEntityBase ScheduledTransactionGE,
String RevenueGLAccount,
String DeferredGLAccount,
String DiscountGLAccount,
DateTime RevenueDate,
DateTime OrderDate,
Int64 OrderID,
Int64 ProductID,
Decimal Amount,
Decimal DiscountAmount
);

Parameters

ScheduledTransactionGE
RevenueGLAccount
DeferredGLAccount
DiscountGLAccount
RevenueDate
OrderDate
OrderID
ProductID
Amount
DiscountAmount

Return Value

Remarks

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.CreateMultipleOrders Method

protected virtual bool CreateMultipleOrders(
AptifyGenericEntityBase OrderGE,
Int64 ProductID,
String ProductDescription,
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.CreateNewOrder Method

protected virtual long CreateNewOrder(
AptifyGenericEntityBase OrderGE,
Int64 ShipToID,
Int64 ShipToCompanyID,
Int64 BillToID,
Int64 BillToCompanyID,
Int64 ProductID,
Decimal Amount,
Decimal DiscretionaryAmount,
Decimal AgencyDiscountAmount,
String ProductDescription,
Decimal OptionAmount,
ref String& ErrorString
);

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.CreateOrders Method

This method creates order for the insertion order as required based on the BillTo sub-type in the Insertion Order.

protected virtual bool CreateOrders(
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

Parameters

AllowGUI
ErrorString
TransactionID

Return Value

Remarks

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.CreatePaymentDetail Method

This method adds a Payment Line to the Payment GE for the OrderID and Amount specified

protected virtual bool CreatePaymentDetail(
AptifyGenericEntityBase PaymentGE,
Int64 OrderID,
Decimal Amount
);

Parameters

PaymentGE
OrderID
Amount

Return Value

Remarks

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.CreateRecognitionScheduledTransaction Method

This method creates a scheduled transaction for revenue recognition of advertising revenue at the date specified by Revenue Date.

protected virtual bool CreateRecognitionScheduledTransaction(
AptifyGenericEntityBase ScheduledTransactionGE,
String RevenueGLAccount,
String DeferredGLAccount,
String DiscountGLAccount,
DateTime RevenueDate,
DateTime OrderDate,
Int64 OrderID,
Int64 ProductID,
Decimal Amount,
Decimal DiscountAmount
);

Parameters

ScheduledTransactionGE
RevenueGLAccount
DeferredGLAccount
DiscountGLAccount
RevenueDate
OrderDate
OrderID
ProductID
Amount
DiscountAmount

Return Value

Remarks

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.CreateRefundPaymentHeader Method

This method sets up the payment header details for the Payments entity for a refund payment based on the information provided. The PaymentGE passed in should be a New Payments entity record.

protected virtual bool CreateRefundPaymentHeader(
AptifyGenericEntityBase PaymentGE,
AptifyGenericEntityBase OrderGE,
String BasePaymentType,
Int64 PaymentTypeID,
Int64 EmployeeID,
Int64 CreditOrderID,
DataTable PaymentData
);

Parameters

PaymentGE
OrderGE
BasePaymentType
PaymentTypeID
EmployeeID
CreditOrderID
PaymentData

Return Value

Remarks

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.CreateReversalScheduledTransaction Method

This method creates a scheduled transaction for revenue reversal of advertising revenue at the date specified by Order Date.

protected virtual bool CreateReversalScheduledTransaction(
AptifyGenericEntityBase ScheduledTransactionGE,
String RevenueGLAccount,
String DeferredGLAccount,
String DiscountGLAccount,
DateTime RevenueDate,
DateTime OrderDate,
Int64 OrderID,
Int64 ProductID,
Decimal Amount,
Decimal DiscountAmount
);

Parameters

ScheduledTransactionGE
RevenueGLAccount
DeferredGLAccount
DiscountGLAccount
RevenueDate
OrderDate
OrderID
ProductID
Amount
DiscountAmount

Return Value

Remarks

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.CreateScheduledTransaction Method

This method creates a scheduled transaction for the insertion order based on the revenue recognition date for the Product Issue that the insertion order is going into.

protected virtual bool CreateScheduledTransaction(
DateTime RevenueDate,
DateTime OrderDate,
Int64 OrderID,
Int64 ProductID,
Decimal Amount,
Decimal DiscountAmount,
String OrderType
);

Parameters

RevenueDate
The date to recognize the revenue for the insertion on
OrderDate
OrderID
ProductID
Amount
DiscountAmount
OrderType

Return Value

Remarks

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.DoCancelOrder Method

This method cancels an individual order by creating a new order that has an Order Type of Cancellation and by reversing each line of the original order (specified by the Order ID parameter) and then saving the Cancellation Order.

protected virtual long DoCancelOrder(
Int64 OrderID,
ref String& ErrorString,
String TransactionID
);

Parameters

OrderID
ErrorString
TransactionID

Return Value

The record ID(Orders Entity) of the Cancellation Order if saved succesfully, otherwise -1 is returned

Remarks

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


DoesContractHaveAgency Method

Aptify 5.0 Software Development Kit (SDK)

AdvertisingInsertionOrder.DoesContractHaveAgency Method

This method determines if the advertising contract provided by the AdvertisingContractID parameter has an Advertising Agency attached to it (via the Advertising Contracts.AgencyID field) and returns True in that case, False otherwise.

Overload List

This method determines if the advertising contract provided by the AdvertisingContractID parameter has an Advertising Agency attached to it (via the Advertising Contracts.AgencyID field) and returns True in that case, False otherwise.

protected virtual bool DoesContractHaveAgency(Int64,ref String&,ref Int64&);

This method determines if the advertising contract linked to this insertion order has an Advertising Agency attached to it (via the Advertising Contracts.AgencyID field) and returns True in that case, False otherwise.

protected virtual bool DoesContractHaveAgency(ref String&,ref Int64&);

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.DoesContractHaveAgency Method (Int64, String&, Int64&)

This method determines if the advertising contract provided by the AdvertisingContractID parameter has an Advertising Agency attached to it (via the Advertising Contracts.AgencyID field) and returns True in that case, False otherwise.

protected virtual bool DoesContractHaveAgency(
Int64 AdvertisingContractID,
ref String& AgencyName,
ref Int64& AgencyID
);

Parameters

AdvertisingContractID
AgencyName
AgencyID

Return Value

Remarks

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace | AdvertisingInsertionOrder.DoesContractHaveAgency Overload List


AdvertisingInsertionOrder.DoesContractHaveAgency Method (String&, Int64&)

This method determines if the advertising contract linked to this insertion order has an Advertising Agency attached to it (via the Advertising Contracts.AgencyID field) and returns True in that case, False otherwise.

protected virtual bool DoesContractHaveAgency(
ref String& AgencyName,
ref Int64& AgencyID
);

Parameters

AgencyName
AgencyID

Return Value

Remarks

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace | AdvertisingInsertionOrder.DoesContractHaveAgency Overload List


AdvertisingInsertionOrder.FormatDecimalAsCurrency Method

This method formats the specified decimal value to be used as a currency type with only the number of digits after decimal based on the system's functional currency.

protected virtual decimal FormatDecimalAsCurrency(
Decimal Value
);

Parameters

Value

Return Value

Remarks

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.GetBillToSplitAmounts Method

protected virtual bool GetBillToSplitAmounts(
ref List`1& Amounts
);

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.GetCheckPaymentTypeID Method

This method retrieves a Payment Type ID (from the Payment Types entity) for the lowest ID that has its Type field exactly matching the value 'Check'

protected virtual long GetCheckPaymentTypeID();

Return Value

Remarks

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.GetCreditMemoPaymentTypeID Method

Returns the lowest Payment Types record that has a name that excactly matches 'Credit Memo'

protected virtual long GetCreditMemoPaymentTypeID();

Return Value

Remarks

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.GetCreditOrderBalance Method

This method returns the balance of the specified Order record ID. It is assumed that the OrderID provided is a Credit Order that has a negative balance in the database(meaning a credit balance). The value returned will be a positive value representing the credit balance on the order.

protected virtual decimal GetCreditOrderBalance(
Int64 CreditOrderID
);

Parameters

CreditOrderID
Optional: If not provided, the CreditOrderID in the Insertion Order will be used

Return Value

Remarks

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.GetCurrencyTypeNumDigitsAfterDecimal Method

This method returns the number of digits to use after the decimal for the specified currency type.

public virtual int GetCurrencyTypeNumDigitsAfterDecimal(
Int64 CurrencyTypeID,
IAptifyDataAction.DSLCacheSetting CacheSetting
);

Parameters

CurrencyTypeID
CacheSetting

Return Value

Remarks

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.GetDueDate Method

This method returns the due date to use when creating orders from this insertion order. The default functionality for this method uses an Entity Attribute in the Advertising Insertion Orders entity called DueDatePeriod which stores (in days) the period from the original order date to defer the due date for the insertion order.

protected virtual DateTime GetDueDate();

Return Value

Remarks

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


GetEmployeeName Method

Aptify 5.0 Software Development Kit (SDK)

AdvertisingInsertionOrder.GetEmployeeName Method

Returns the name (FirstName+LastName) for the Current Employee

Overload List

Returns the name (FirstName+LastName) for the Current Employee

public virtual string GetEmployeeName();

Returns the name (FirstName+LastName) for the specified Employee ID

public virtual string GetEmployeeName(Int64);

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.GetEmployeeName Method ()

Returns the name (FirstName+LastName) for the Current Employee

public virtual string GetEmployeeName();

Return Value

Remarks

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace | AdvertisingInsertionOrder.GetEmployeeName Overload List


AdvertisingInsertionOrder.GetEmployeeName Method (Int64)

Returns the name (FirstName+LastName) for the specified Employee ID

public virtual string GetEmployeeName(
Int64 EmployeeID
);

Parameters

EmployeeID

Return Value

Remarks

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace | AdvertisingInsertionOrder.GetEmployeeName Overload List


AdvertisingInsertionOrder.GetLastPayementTypeInfo Method

This method returns payment information for the most recent payment posted against the Orders entity record specified by the OrderID parameter.

protected virtual DataTable GetLastPayementTypeInfo(
Int64 OrderID
);

Parameters

OrderID

Return Value

Remarks

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.GetObjectByAttributes Method

This utility method will retrieve an object based on entity attribute information.

protected virtual object GetObjectByAttributes(
String EntityName,
String ObjectAttributeName,
String AssemblyAttributeName,
String ClassAttributeName
);

Parameters

EntityName
Name of the entity that contains the entity attributes to be used for instantiating an object
ObjectAttributeName
Attribute name for the attribute that contains the repository object location
AssemblyAttributeName
Attribute name for the attribute that contains the assembly name
ClassAttributeName
Attribute name for the attribute that contains the class/type name

Return Value

Remarks

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.GetOptionsDataTable Method

This method returns a datatable with one row for each option that is included in this insertion order. By default, this method uses the Aptify DSL cache to retrieve the data, unless the CacheSetting is provided with an alternative option to Refresh or Bypass the cache.

protected virtual DataTable GetOptionsDataTable(
IAptifyDataAction.DSLCacheSetting CacheSetting
);

Return Value

Remarks

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.GetOrderData Method

This method returns all of the fields for a given Order ID in a single table. If the order is not found or an error takes place, the value of Nothing is returned.

public virtual DataTable GetOrderData(
Int64 OrderID,
IAptifyDataAction.DSLCacheSetting CacheSetting
);

Parameters

OrderID
CacheSetting

Return Value

Remarks

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.GetOrderFieldValue Method

This method returns a single field from the Orders Entity for the specified OrderID. If it is necessary to retrieve more than one field value from an order, it is more efficient to use GetOrderData() which will return a DataTable with a single row in it for the specified Order ID.

protected virtual string GetOrderFieldValue(
String FieldName,
Int64 OrderID,
IAptifyDataAction.DSLCacheSetting CacheSetting
);

Parameters

FieldName
OrderID
CacheSetting

Return Value

Remarks

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.GetOrderStatusID Method

Returns an ID value from the Order Status Types entity based on the Name provided.

public virtual long GetOrderStatusID(
String StatusName
);

Parameters

StatusName

Return Value

Remarks

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.GetPersonPaymentLevelID Method

This method returns the GLPaymentLevelID field from the Persons entity for the PersonID specified

public virtual long GetPersonPaymentLevelID(
Int64 PersonID
);

Parameters

PersonID

Return Value

Remarks

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.GetPrimarySalesRepItemFromSubType Method

This method returns the AptifyGenericEntityBase object within the AdvertisingInsertionOrderSalesReps sub-type that matches the PrimarySalesRepID in the top-level Insertion Order record.

protected virtual AptifyGenericEntityBase GetPrimarySalesRepItemFromSubType();

Return Value

Remarks

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.GetProductGLAccount Method

Returns the GL Account to use for the specific Product ID, Account Type and GL Order Level ID. If GLOrderLevelID is not specified, the GetDefaultOrderLevelID() is called to get the default order level.

public virtual string GetProductGLAccount(
Int64 ProductID,
String AccountType,
Int64 GLOrderLevelID
);

Parameters

ProductID
AccountType
GLOrderLevelID

Return Value

Remarks

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.GetProductIssueRevenueRecognitionDate Method

This method returns the RevenueRecognitionDate field from the Product Issues entity for the specified ProductIssueID

public virtual DateTime GetProductIssueRevenueRecognitionDate(
Int64 ProductIssueID
);

Parameters

ProductIssueID

Return Value

Remarks

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.GetPurchaseOrderPaymentTypeID Method

Returns the lowest Payment Types record that has a Type that begins with 'Purchase Order'

protected virtual long GetPurchaseOrderPaymentTypeID();

Return Value

Remarks

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.GetRateCardRateGE Method

This method returns a GE Object for the Rate Card Rate sub-type for the current insertion order based on the information populated in the insertion order for Color Code, Size Code, Position Code and based on the current Advertising Contract ID (stored in Insertion Orders.AdvertisingContractID)

public virtual AptifyGenericEntityBase GetRateCardRateGE(
ref AptifyGenericEntityBase& RateCardGE
);

Parameters

RateCardGE
Optional OUT Parameter: Returns the Rate Card GE object

Return Value

Remarks

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.GetScheduledTransactionRevenueDate Method

This method retrieves the original revenue recognition date(ScheduledDate) from the Scheduled Transaction that was created for the specified OrderID where the Type='Ad Revenue Recognition', which is the type that is used by this class when creating Scheduled Transactions for revenue recognition.

protected virtual DateTime GetScheduledTransactionRevenueDate(
Int64 OrderID
);

Parameters

OrderID

Return Value

Remarks

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.GetSQLLongValue Method

This method executes the provided SQL statement and returns the value from the statement. The statement is assume to return a single numeric value that can be cast to a Long.

public virtual long GetSQLLongValue(
String SQL,
IAptifyDataAction.DSLCacheSetting CacheSetting
);

Parameters

SQL
CacheSetting

Return Value

If this method is succesful, the value is returned from the SQL parameter execution, otherwise a value of -1 is returned

Remarks

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


GetSubTypeObject Method

Aptify 5.0 Software Development Kit (SDK)

AdvertisingInsertionOrder.GetSubTypeObject Method

Returns the Sub-Type object based on the index provided in SubTypeIndex

Overload List

Returns the Sub-Type object based on the index provided in SubTypeIndex

public AptifySubTypeBase GetSubTypeObject(Int32);

Returns the Sub-Type object based on the name provided in SubTypeName

public AptifySubTypeBase GetSubTypeObject(String);

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.GetSubTypeObject Method (Int32)

Returns the Sub-Type object based on the index provided in SubTypeIndex

public AptifySubTypeBase GetSubTypeObject(
Int32 SubTypeIndex
);

Parameters

SubTypeIndex

Return Value

Remarks

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace | AdvertisingInsertionOrder.GetSubTypeObject Overload List


AdvertisingInsertionOrder.GetSubTypeObject Method (String)

Returns the Sub-Type object based on the name provided in SubTypeName

public AptifySubTypeBase GetSubTypeObject(
String SubTypeName
);

Parameters

SubTypeName

Return Value

Remarks

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace | AdvertisingInsertionOrder.GetSubTypeObject Overload List


AdvertisingInsertionOrder.GetSystemFunctionalCurrencyTypeID Method

This method returns the ID value of the Currency Types entity record that is marked as the functional currency for the system (using the FunctionalCurrency BIT field in the Currency Types entity).

public virtual long GetSystemFunctionalCurrencyTypeID(
IAptifyDataAction.DSLCacheSetting CacheSetting
);

Parameters

CacheSetting

Return Value

Remarks

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.GetUnitDefinitionObject Method

This method is responsible for retrieving the Unit Definition object based on the attributes stored in the Advertising Unit Definitions Entity.

protected virtual IAdvertisingUnitDefinition GetUnitDefinitionObject();

Return Value

Remarks

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.GetWriteOffPaymentTypeID Method

This method retrieves a Payment Type ID (from the Payment Types entity) for the lowest ID that has its Type field exactly matching the value 'Bad Debt'

protected virtual long GetWriteOffPaymentTypeID();

Return Value

Remarks

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.GetZeroRateTaxRateID Method

This method returns the lowest ID value from the Sales Tax Rates entity that has a Rate = 0

public virtual long GetZeroRateTaxRateID();

Return Value

Remarks

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.InsertionOrderHasOrder Method

This method returns True if the Insertion Order has one or more Order linked to it through the AdvertisingInsertionOrderBillTo sub-type. In addition, the method returns the first OrderID found. In addition, the IsCancelled parameter returns True if the Insertion Order has a Cancellation Order. If Refresh is set to True, the system will pull data from the database, otherwise information from the GE object in memory will be used.

protected virtual bool InsertionOrderHasOrder(
ref Int64& OrderID,
ref Boolean& IsCancelled,
Boolean Refresh
);

Parameters

OrderID
IsCancelled
Refresh

Return Value

Remarks

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.InternalSave Method

This method implements the Save() functionality specific to Insertion Order processing including creating and/or updating a record in the Orders entity when an insertion order reaches the appropriate Status level.

protected virtual bool InternalSave(
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

Parameters

AllowGUI
ErrorString
TransactionID

Return Value

Remarks

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.IsOverHundredPercent Method

This method is responsible for checking to see if the sum of all the SplitPercentage fields in the AdvertisingInsertionOrderSalesReps sub-type is over 100%.

protected virtual bool IsOverHundredPercent();

Return Value

Remarks

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.IsSameUnitDefintion Method

This method determines if the current unit definition has changed.

public virtual bool IsSameUnitDefintion(
ref Boolean& UnitDefinitionExists
);

Parameters

UnitDefinitionExists

Return Value

Remarks

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.IsTopAndSubSalesRepsPercentSync Method

protected virtual bool IsTopAndSubSalesRepsPercentSync();

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.IsTopAndSubSalesRepsSync Method

This method checks to make sure the top-level field in the InsertionOrder PrimarySalesRepID matches the sub-type record in the Sales Reps sub-type that is marked as IsPrimary=1.

protected virtual bool IsTopAndSubSalesRepsSync();

Return Value

Remarks

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.MarkOrderAsShipped Method

This method will mark the specified order as shipped so that when it is saved it will handle the appropriate processes for revenue recognition and other required process steps.

protected virtual bool MarkOrderAsShipped(
AptifyGenericEntityBase OrderGE
);

Parameters

OrderGE

Return Value

Remarks

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.OffsetPayment Method

This method is responsible for offsetting payment between the original order and cancellation order

protected virtual bool OffsetPayment(
AptifyGenericEntityBase OriginalOrderGE,
AptifyGenericEntityBase CancellationOrderGE
);

Parameters

OriginalOrderGE
CancellationOrderGE

Return Value

Remarks

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.OptionExists Method

This method determines if the specified Advertising Option exists in the insertion order.

protected virtual bool OptionExists(
Int64 OptionID,
ref Int32& ItemSequence
);

Parameters

OptionID
ItemSequence

Return Value

Remarks

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.OrderExists Method

This method internally uses the GetOrderData() method to determine if an order exists and returns True if it does exist and False otherwise.

public virtual bool OrderExists(
Int64 OrderID,
IAptifyDataAction.DSLCacheSetting CacheSetting
);

Parameters

OrderID
CacheSetting

Return Value

Remarks

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.PopulateAddressWPersonInfo Method

This method populates the provided OrderGE ShipTo and BillTo Address and Phone information based on the BillToID person in the OrderGE. This is done using the PreferredAddress Object registered under the Persons entity with the Preferred Address Object and Preferred Address Object Class Entity Attributes within the Persons Entity.

protected virtual bool PopulateAddressWPersonInfo(
AptifyGenericEntityBase OrderGE
);

Parameters

OrderGE

Return Value

Remarks

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.PopulateOrderLine Method

This method populates an Order Line GE object from the parameters provided.

protected virtual bool PopulateOrderLine(
AptifyGenericEntityBase OrderLineGE,
Int64 ProductID,
Decimal Quantity,
Decimal Price,
Decimal DiscountAmount
);

Parameters

OrderLineGE
ProductID
Quantity
Price
DiscountAmount

Return Value

Remarks

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.PopulateShipToInfo Method

This method populates the ShipToAddressID and ShipToPhoneID fields in the OrderGE from values in the first row of dtTemp assumed to be named AddressID and PhoneID respectively

protected virtual bool PopulateShipToInfo(
AptifyGenericEntityBase OrderGE,
DataTable dtTemp
);

Parameters

OrderGE
dtTemp

Return Value

Remarks

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.ProductExists Method

This method determines if the specified product already exists in the OrderGE object

protected virtual bool ProductExists(
AptifyGenericEntityBase OrderGE,
Int64 ProductID,
String UpdatedAttributeField,
Int32 StartSequence,
ref Int32& FoundSequence,
ref AptifyGenericEntityBase& OrderLineGE
);

Parameters

OrderGE
ProductID
UpdatedAttributeField
The field in each order line to test for a numeric value existance.
StartSequence
FoundSequence
OrderLineGE

Return Value

Remarks

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.RemoveOrderLines Method

This method is used to remove order lines that have a matching attribute value(non-zero) for the specified FieldToCheck parameter. This method is used by various areas of the class to remove unnecessary order lines that maybe created during a process and are temporary in nature. This is a utility method.

protected virtual bool RemoveOrderLines(
AptifyGenericEntityBase OrderGE,
Int32 StartingOrderLineIndex,
String FieldToCheck
);

Parameters

OrderGE
StartingOrderLineIndex
FieldToCheck

Return Value

Remarks

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.SalesSubTypeTotalPercentage Method

This method calculates the sum of all of the SplitPercentage fields in the AdvertisingInsertionOrderSalesReps sub-type and returns that calculated summary value.

protected virtual decimal SalesSubTypeTotalPercentage();

Return Value

Remarks

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


Save Method

Aptify 5.0 Software Development Kit (SDK)

AdvertisingInsertionOrder.Save Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Save();

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean,ref String&);

public override bool Save(Boolean,ref String&,String);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(ref String&);

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.Save Method (Boolean, String&, String)

public override bool Save(
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace | AdvertisingInsertionOrder.Save Overload List


AdvertisingInsertionOrder.SetSeparateDiscountPerLine Method

protected virtual bool SetSeparateDiscountPerLine(
AptifyGenericEntityBase OrderGE,
Decimal AgencyDiscountAmountTotal,
Decimal DiscretionaryAmountTotal
);

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.SetupOptionOrderLines Method

This method creates order lines in the OrderGE object based on the options that were selected in the Insertion Order. For each option in the AdvertisingInsertionOrderOptions sub-type, one order line is created in this method.

protected virtual bool SetupOptionOrderLines(
AptifyGenericEntityBase OrderGE,
Decimal OptionAmount,
Decimal AgencyDiscount,
Decimal DiscretionaryDiscount,
Decimal AdAmount
);

Parameters

OrderGE
OptionAmount
AgencyDiscount
DiscretionaryDiscount
AdAmount

Return Value

Remarks

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.SplitAndNormalizeAmount Method

protected virtual bool SplitAndNormalizeAmount(
Decimal OriginalAmount,
ref List`1& Amounts
);

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.UpdateMultipleOrders Method

This method is responsible for updating all of the orders linked to this insertion order whenever an insertion order is saved and changes have been made that require updates to be propogated to the underlying Order records.

protected virtual bool UpdateMultipleOrders(
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

Parameters

AllowGUI
ErrorString
TransactionID

Return Value

Remarks

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.UpdateOptionOrderLines Method

protected virtual bool UpdateOptionOrderLines(
AptifyGenericEntityBase OrderGE,
Decimal OptionAmount,
Decimal AgencyDiscount,
Decimal DiscretionaryDiscount,
Decimal AdAmount
);

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


Validate Method

Aptify 5.0 Software Development Kit (SDK)

AdvertisingInsertionOrder.Validate Method

This method overrides the base GE Validate to validate Insertion Order specific requirements. This method Validates the Billing elements of the Insertion Order( through ValidateBillTo() method), the SalesRep information (through the ValidateSalesRep() method ) and the Insertion Order options selectetd (through the ValidateInsertionOrderOptions() method).

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Validate();

This method overrides the base GE Validate to validate Insertion Order specific requirements. This method Validates the Billing elements of the Insertion Order( through ValidateBillTo() method), the SalesRep information (through the ValidateSalesRep() method ) and the Insertion Order options selectetd (through the ValidateInsertionOrderOptions() method).

public override bool Validate(ref String&);

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.Validate Method (String&)

This method overrides the base GE Validate to validate Insertion Order specific requirements. This method Validates the Billing elements of the Insertion Order( through ValidateBillTo() method), the SalesRep information (through the ValidateSalesRep() method ) and the Insertion Order options selectetd (through the ValidateInsertionOrderOptions() method).

public override bool Validate(
ref String& ErrorString
);

Parameters

ErrorString

Return Value

Remarks

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace | AdvertisingInsertionOrder.Validate Overload List


AdvertisingInsertionOrder.ValidateBillTo Method

This method validates the Billing aspects of the Insertion Order. Billing information is required for Insertion Orders once they are at the Status of Quote or above in the process. Billing information includes the AdvertisingInsertionOrderBillTo Sub-Type as well as the EmployeeID field on the Insertion Order top-level record. In addition, for Insertion Orders that already have an Order record created and linked in the Orders entity, BillTo information may not be deleted.

protected virtual bool ValidateBillTo(
ref String& ErrorString
);

Parameters

ErrorString

Return Value

Remarks

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.ValidateInsertionOrderOptions Method

This method validates the AdvertisingInsertionOrderOptions sub-type to make sure that an option has not been selected more than once. In addition, Options may not be altered after an Order is created in the Orders Entity for this Insertion Order since the Options selected for an insertio may alter the financial aspects of the record.

protected virtual bool ValidateInsertionOrderOptions(
ref String& ErrorString
);

Parameters

ErrorString

Return Value

Remarks

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.ValidateProductRevenueRecognitionDate Method

This method checks to Revenue Recognition Date at the Product level. If the Revenue Recognition Date field in the Products entity for the specified Product ID is NOT blank, this method will return False as Advertising Insertion Orders utilize the Revenue Recognition Date at the Product Issue level to drive revenue recognition through Scheduled Transactions.

protected virtual bool ValidateProductRevenueRecognitionDate(
Int64 ProductID
);

Parameters

ProductID

Return Value

Remarks

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.ValidateSalesRep Method

This method validates the sales rep information in the Insertion Order by checking to make sure that Top and Sub-Type level sales rep information is in sync, that commission percentage totals do not exceed 100% and that Top and Sub-Type level commision percentages are in sync for the primary sales rep. Lastly, this method checks to make sure that there are not any version conflicts with this insertion order if an Orders entity record has been created and is linked to the Insertion Order.

protected virtual bool ValidateSalesRep(
ref String& ErrorString
);

Parameters

ErrorString

Return Value

Remarks

See Also

AdvertisingInsertionOrder Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.BillToAmount Structure

Used in conjunction with the GetBillToSplitAmounts() method

For a list of all members of this type, see AdvertisingInsertionOrder.BillToAmount Members.

System.Object
ValueType
AdvertisingInsertionOrder.BillToAmount

protected struct AdvertisingInsertionOrder.BillToAmount

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Advertising

Assembly: AdvertisingInsertionOrder (in AdvertisingInsertionOrder.dll)

See Also

AdvertisingInsertionOrder.BillToAmount Members | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.BillToAmount Members

AdvertisingInsertionOrder.BillToAmount overview

Public Instance Fields

AgencyDiscount
DiscretionaryDiscount
OptionPrice
RateCard

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

AdvertisingInsertionOrder.BillToAmount Structure | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.BillToAmount Fields

The fields of the AdvertisingInsertionOrder.BillToAmount structure are listed below. For a complete list of AdvertisingInsertionOrder.BillToAmount structure members, see the AdvertisingInsertionOrder.BillToAmount Members topic.

Public Instance Fields

AgencyDiscount
DiscretionaryDiscount
OptionPrice
RateCard

See Also

AdvertisingInsertionOrder.BillToAmount Structure | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.BillToAmount.AgencyDiscount Field

public AgencyDiscount AgencyDiscount;

See Also

AdvertisingInsertionOrder.BillToAmount Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.BillToAmount.DiscretionaryDiscount Field

public DiscretionaryDiscount DiscretionaryDiscount;

See Also

AdvertisingInsertionOrder.BillToAmount Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.BillToAmount.OptionPrice Field

public OptionPrice OptionPrice;

See Also

AdvertisingInsertionOrder.BillToAmount Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrder.BillToAmount.RateCard Field

public RateCard RateCard;

See Also

AdvertisingInsertionOrder.BillToAmount Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrderPricing Class

This class provides the default implementation for pricing for Insertion Orders in the Aptify Advertising Management system. This class can be sub-classed if it is necessary to override functionality in the base implementation for insertion order pricing. Alternatively, it is also possible to create a completely separate class that implements IAdvertisingInsertionOrderPricing and plug in that class as well. In either case, sub-classes or separate implementations of the interface must be plugged into the Advertising Insertion Orders entity using the Entity Attributes shown below (All of the below are attributes of the Advertising Insertion Orders entity)

For a list of all members of this type, see AdvertisingInsertionOrderPricing Members.

System.Object
AdvertisingInsertionOrderPricing

public class AdvertisingInsertionOrderPricing : IAdvertisingInsertionOrderPricing

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Advertising

Assembly: AdvertisingInsertionOrderPricing (in AdvertisingInsertionOrderPricing.dll)

See Also

AdvertisingInsertionOrderPricing Members | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrderPricing Members

AdvertisingInsertionOrderPricing overview

Public Instance Constructors

AdvertisingInsertionOrderPricing Constructor Initializes a new instance of the AdvertisingInsertionOrderPricing class.

Public Instance Methods

Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GenerateInsertionOrderDetails | This function will generate the insertion order line items by using the information from the insertion order's contract as well as the insertion order attribute list and comparing those attributes against the rate card.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Fields

m_oApp
m_oDataAction
m_sDatabase

Protected Instance Methods

ApplyRateCardRates | This method applies rates from the rate card associated with the contract that is linked to the Insertion Order through its contract.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetInsertionOrderRateCardID | This method returns the Rate Card ID that is associated with the insertion order based on the contract information and the publication specific to this insertion order.
GetLineItemTotal | This method returns the sum of all of the Amount fields from the AdvertisingInsertionOrderLineItems sub-type within the provided InsertionOrderGE object.
GetRateCardRateID | This method returns the Rate Card Rate ID stored within a single rate card based on the specified AttributeID and Value parameters. This method uses the spGetRateCardRateFromSingleAttribute stored procedure to provide this functionality.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
StoreCustomLineItems | This method iterates through each line item in the insertion order in the AdvertisingInsertionOrderLineItems sub-type and adds the line items to the CustomLineItems List that have the IsGenerated BIT value set to 0. This method is called from GenerateInsertionOrderDetails()

See Also

AdvertisingInsertionOrderPricing Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrderPricing Constructor

Initializes a new instance of the AdvertisingInsertionOrderPricing class.

public AdvertisingInsertionOrderPricing();

See Also

AdvertisingInsertionOrderPricing Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrderPricing Fields

The fields of the AdvertisingInsertionOrderPricing class are listed below. For a complete list of AdvertisingInsertionOrderPricing class members, see the AdvertisingInsertionOrderPricing Members topic.

Protected Instance Fields

m_oApp
m_oDataAction
m_sDatabase

See Also

AdvertisingInsertionOrderPricing Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrderPricing.m_oApp Field

protected m_oApp m_oApp;

See Also

AdvertisingInsertionOrderPricing Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrderPricing.m_oDataAction Field

protected m_oDataAction m_oDataAction;

See Also

AdvertisingInsertionOrderPricing Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrderPricing.m_sDatabase Field

protected m_sDatabase m_sDatabase;

See Also

AdvertisingInsertionOrderPricing Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrderPricing Methods

The methods of the AdvertisingInsertionOrderPricing class are listed below. For a complete list of AdvertisingInsertionOrderPricing class members, see the AdvertisingInsertionOrderPricing Members topic.

Public Instance Methods

Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GenerateInsertionOrderDetails | This function will generate the insertion order line items by using the information from the insertion order's contract as well as the insertion order attribute list and comparing those attributes against the rate card.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

ApplyRateCardRates | This method applies rates from the rate card associated with the contract that is linked to the Insertion Order through its contract.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetInsertionOrderRateCardID | This method returns the Rate Card ID that is associated with the insertion order based on the contract information and the publication specific to this insertion order.
GetLineItemTotal | This method returns the sum of all of the Amount fields from the AdvertisingInsertionOrderLineItems sub-type within the provided InsertionOrderGE object.
GetRateCardRateID | This method returns the Rate Card Rate ID stored within a single rate card based on the specified AttributeID and Value parameters. This method uses the spGetRateCardRateFromSingleAttribute stored procedure to provide this functionality.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
StoreCustomLineItems | This method iterates through each line item in the insertion order in the AdvertisingInsertionOrderLineItems sub-type and adds the line items to the CustomLineItems List that have the IsGenerated BIT value set to 0. This method is called from GenerateInsertionOrderDetails()

See Also

AdvertisingInsertionOrderPricing Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrderPricing.ApplyRateCardRates Method

This method applies rates from the rate card associated with the contract that is linked to the Insertion Order through its contract.

protected virtual bool ApplyRateCardRates(
AptifyGenericEntityBase InsertionOrderGE
);

Parameters

InsertionOrderGE

Return Value

Remarks

See Also

AdvertisingInsertionOrderPricing Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrderPricing.Config Method

public void Config(
AptifyApplication Application
);

Implements

IAdvertisingInsertionOrderPricing.

See Also

AdvertisingInsertionOrderPricing Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrderPricing.GenerateInsertionOrderDetails Method

This function will generate the insertion order line items by using the information from the insertion order's contract as well as the insertion order attribute list and comparing those attributes against the rate card.

public bool GenerateInsertionOrderDetails(
AptifyGenericEntityBase InsertionOrderGE
);

Parameters

InsertionOrderGE

Return Value

Implements

IAdvertisingInsertionOrderPricing.

Remarks

See Also

AdvertisingInsertionOrderPricing Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrderPricing.GetInsertionOrderRateCardID Method

This method returns the Rate Card ID that is associated with the insertion order based on the contract information and the publication specific to this insertion order.

protected virtual long GetInsertionOrderRateCardID(
AptifyGenericEntityBase InsertionOrderGE
);

Parameters

InsertionOrderGE

Return Value

Rate Card ID if succesful, otherwise -1

Remarks

See Also

AdvertisingInsertionOrderPricing Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrderPricing.GetLineItemTotal Method

This method returns the sum of all of the Amount fields from the AdvertisingInsertionOrderLineItems sub-type within the provided InsertionOrderGE object.

protected virtual decimal GetLineItemTotal(
AptifyGenericEntityBase InsertionOrderGE
);

Parameters

InsertionOrderGE

Return Value

Remarks

See Also

AdvertisingInsertionOrderPricing Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrderPricing.GetRateCardRateID Method

This method returns the Rate Card Rate ID stored within a single rate card based on the specified AttributeID and Value parameters. This method uses the spGetRateCardRateFromSingleAttribute stored procedure to provide this functionality.

protected virtual long GetRateCardRateID(
Int64 RateCardID,
Int64 RateCardAttributeID,
String Value
);

Parameters

RateCardID
RateCardAttributeID
Value

Return Value

Rate Card Rate ID if succesful, otherwise -1

Remarks

See Also

AdvertisingInsertionOrderPricing Class | Aptify.Applications.Advertising Namespace


AdvertisingInsertionOrderPricing.StoreCustomLineItems Method

This method iterates through each line item in the insertion order in the AdvertisingInsertionOrderLineItems sub-type and adds the line items to the CustomLineItems List that have the IsGenerated BIT value set to 0. This method is called from GenerateInsertionOrderDetails()

protected virtual bool StoreCustomLineItems(
AptifyGenericEntityBase InsertionOrderGE,
List<T> CustomLineItems
);

Parameters

InsertionOrderGE
CustomLineItems

Return Value

Remarks

See Also

AdvertisingInsertionOrderPricing Class | Aptify.Applications.Advertising Namespace


AdvertisingLayoutBase Class

For a list of all members of this type, see AdvertisingLayoutBase Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
AdvertisingLayoutBase
Derived types

public class AdvertisingLayoutBase : FormTemplateLayout

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Advertising

Assembly: AdvertisingLayoutBase (in AdvertisingLayoutBase.dll)

See Also

AdvertisingLayoutBase Members | Aptify.Applications.Advertising Namespace


AdvertisingLayoutBase Members

AdvertisingLayoutBase overview

Public Instance Constructors

AdvertisingLayoutBase Constructor Initializes a new instance of the AdvertisingLayoutBase class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
LayoutDataComboControl |
LayoutDataControl |
LayoutLinkBoxControl |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
SubtypeControl |
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AddControlEventHandler |
AddControlEventHandlerFromFieldName |
AddControlEventHandlerFromSubTypeName |
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormTemplateLayout) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControlFromFieldName |
FindDataControl |
FindSubTypeControlFromName |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetControlFromFieldName |
GetControlProperty |
GetDataControlProperty |
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetSubTypeControlFromName |
GetTabControl | Overloaded.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded (inherited from FormTemplateLayout) | Raises the FormTemplateLoaded event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad |
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlProperty | Overloaded.
SetDataControlProperty | Overloaded.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

AdvertisingLayoutBase Class | Aptify.Applications.Advertising Namespace


AdvertisingLayoutBase Constructor

Initializes a new instance of the AdvertisingLayoutBase class.

public AdvertisingLayoutBase();

See Also

AdvertisingLayoutBase Class | Aptify.Applications.Advertising Namespace


AdvertisingLayoutBase Properties

The properties of the AdvertisingLayoutBase class are listed below. For a complete list of AdvertisingLayoutBase class members, see the AdvertisingLayoutBase Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
LayoutDataComboControl |
LayoutDataControl |
LayoutLinkBoxControl |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
SubtypeControl |
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

AdvertisingLayoutBase Class | Aptify.Applications.Advertising Namespace


LayoutDataComboControl Property

Aptify 5.0 Software Development Kit (SDK)

AdvertisingLayoutBase.LayoutDataComboControl Property

protected AptifyDataComboBox this[
String sFieldName
] {get;}

See Also

AdvertisingLayoutBase Class | Aptify.Applications.Advertising Namespace


LayoutDataControl Property

Aptify 5.0 Software Development Kit (SDK)

AdvertisingLayoutBase.LayoutDataControl Property

protected AptifyDataFieldControlBase this[
String sFieldName
] {get;}

See Also

AdvertisingLayoutBase Class | Aptify.Applications.Advertising Namespace


LayoutLinkBoxControl Property

Aptify 5.0 Software Development Kit (SDK)

AdvertisingLayoutBase.LayoutLinkBoxControl Property

protected AptifyLinkBox this[
String sFieldName
] {get;}

See Also

AdvertisingLayoutBase Class | Aptify.Applications.Advertising Namespace


SubtypeControl Property

Aptify 5.0 Software Development Kit (SDK)

AdvertisingLayoutBase.SubtypeControl Property

protected AptifySubType this[
String sSubTypeName
] {get;}

See Also

AdvertisingLayoutBase Class | Aptify.Applications.Advertising Namespace


AdvertisingLayoutBase Methods

The methods of the AdvertisingLayoutBase class are listed below. For a complete list of AdvertisingLayoutBase class members, see the AdvertisingLayoutBase Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AddControlEventHandler |
AddControlEventHandlerFromFieldName |
AddControlEventHandlerFromSubTypeName |
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormTemplateLayout) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControlFromFieldName |
FindDataControl |
FindSubTypeControlFromName |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetControlFromFieldName |
GetControlProperty |
GetDataControlProperty |
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetSubTypeControlFromName |
GetTabControl | Overloaded.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded (inherited from FormTemplateLayout) | Raises the FormTemplateLoaded event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad |
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlProperty | Overloaded.
SetDataControlProperty | Overloaded.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

AdvertisingLayoutBase Class | Aptify.Applications.Advertising Namespace


AdvertisingLayoutBase.AddControlEventHandler Method

protected bool AddControlEventHandler(
String sFTPName,
String sEventName,
Delegate oHandler
);

See Also

AdvertisingLayoutBase Class | Aptify.Applications.Advertising Namespace


AdvertisingLayoutBase.AddControlEventHandlerFromFieldName Method

protected virtual bool AddControlEventHandlerFromFieldName(
String sFieldName,
String sEventName,
Delegate oHandler
);

See Also

AdvertisingLayoutBase Class | Aptify.Applications.Advertising Namespace


AdvertisingLayoutBase.AddControlEventHandlerFromSubTypeName Method

protected virtual bool AddControlEventHandlerFromSubTypeName(
String sSubTypeName,
String sEventName,
Delegate oHandler
);

See Also

AdvertisingLayoutBase Class | Aptify.Applications.Advertising Namespace


AdvertisingLayoutBase.FindControlFromFieldName Method

protected virtual AptifyDataFieldControlBase FindControlFromFieldName(
Control oControl,
String sFieldName
);

See Also

AdvertisingLayoutBase Class | Aptify.Applications.Advertising Namespace


AdvertisingLayoutBase.FindDataControl Method

protected virtual IDataControl FindDataControl(
Control oControl
);

See Also

AdvertisingLayoutBase Class | Aptify.Applications.Advertising Namespace


AdvertisingLayoutBase.FindSubTypeControlFromName Method

protected virtual AptifySubType FindSubTypeControlFromName(
Control oControl,
String sSubTypeName
);

See Also

AdvertisingLayoutBase Class | Aptify.Applications.Advertising Namespace


AdvertisingLayoutBase.GetControlFromFieldName Method

protected virtual AptifyDataFieldControlBase GetControlFromFieldName(
Control oControl,
String sFieldName
);

See Also

AdvertisingLayoutBase Class | Aptify.Applications.Advertising Namespace


AdvertisingLayoutBase.GetControlProperty Method

protected object GetControlProperty(
String sFTPName,
String sPropertyName,
Type tReturnType,
Type[] tParams,
Object oDefault
);

See Also

AdvertisingLayoutBase Class | Aptify.Applications.Advertising Namespace


AdvertisingLayoutBase.GetDataControlProperty Method

protected object GetDataControlProperty(
String sFieldName,
String sPropertyName,
Type tReturnType,
Type[] tparams,
Object oDefault
);

See Also

AdvertisingLayoutBase Class | Aptify.Applications.Advertising Namespace


AdvertisingLayoutBase.GetSubTypeControlFromName Method

protected virtual AptifySubType GetSubTypeControlFromName(
String sSubTypeName
);

See Also

AdvertisingLayoutBase Class | Aptify.Applications.Advertising Namespace


GetTabControl Method

Aptify 5.0 Software Development Kit (SDK)

AdvertisingLayoutBase.GetTabControl Method

Overload List

protected virtual UltraTabControl GetTabControl();

protected virtual UltraTabControl GetTabControl(String);

See Also

AdvertisingLayoutBase Class | Aptify.Applications.Advertising Namespace


AdvertisingLayoutBase.GetTabControl Method ()

protected virtual UltraTabControl GetTabControl();

See Also

AdvertisingLayoutBase Class | Aptify.Applications.Advertising Namespace | AdvertisingLayoutBase.GetTabControl Overload List


AdvertisingLayoutBase.GetTabControl Method (String)

protected virtual UltraTabControl GetTabControl(
String sFTPName
);

See Also

AdvertisingLayoutBase Class | Aptify.Applications.Advertising Namespace | AdvertisingLayoutBase.GetTabControl Overload List


AdvertisingLayoutBase.OnLoad Method

protected override void OnLoad(
EventArgs e
);

See Also

AdvertisingLayoutBase Class | Aptify.Applications.Advertising Namespace


AdvertisingLayoutBase.OnRefresh Method

protected override void OnRefresh();

Implements

IFormComponent.

See Also

AdvertisingLayoutBase Class | Aptify.Applications.Advertising Namespace


SetControlProperty Method

Aptify 5.0 Software Development Kit (SDK)

AdvertisingLayoutBase.SetControlProperty Method

Overload List

protected bool SetControlProperty(String,String,Object);

protected bool SetControlProperty(String,String,Object,Type,Type[]);

See Also

AdvertisingLayoutBase Class | Aptify.Applications.Advertising Namespace


AdvertisingLayoutBase.SetControlProperty Method (String, String, Object)

protected bool SetControlProperty(
String sFTPName,
String sPropertyName,
Object oValue
);

See Also

AdvertisingLayoutBase Class | Aptify.Applications.Advertising Namespace | AdvertisingLayoutBase.SetControlProperty Overload List


AdvertisingLayoutBase.SetControlProperty Method (String, String, Object, Type, Type[])

protected bool SetControlProperty(
String sFTPName,
String sPropertyName,
Object oValue,
Type ReturnType,
Type[] Params
);

See Also

AdvertisingLayoutBase Class | Aptify.Applications.Advertising Namespace | AdvertisingLayoutBase.SetControlProperty Overload List


SetDataControlProperty Method

Aptify 5.0 Software Development Kit (SDK)

AdvertisingLayoutBase.SetDataControlProperty Method

Overload List

protected bool SetDataControlProperty(String,String,Object);

protected bool SetDataControlProperty(String,String,Object,Type,Type[]);

See Also

AdvertisingLayoutBase Class | Aptify.Applications.Advertising Namespace


AdvertisingLayoutBase.SetDataControlProperty Method (String, String, Object)

protected bool SetDataControlProperty(
String sFieldName,
String sPropertyName,
Object oValue
);

See Also

AdvertisingLayoutBase Class | Aptify.Applications.Advertising Namespace | AdvertisingLayoutBase.SetDataControlProperty Overload List


AdvertisingLayoutBase.SetDataControlProperty Method (String, String, Object, Type, Type[])

protected bool SetDataControlProperty(
String sFieldName,
String sPropertyName,
Object oValue,
Type ReturnType,
Type[] Params
);

See Also

AdvertisingLayoutBase Class | Aptify.Applications.Advertising Namespace | AdvertisingLayoutBase.SetDataControlProperty Overload List


AdvertisingOption Class

This class provides the implementation for business logic for the Advertising Options entity in the Aptify Advertising Management system.

For a list of all members of this type, see AdvertisingOption Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
AdvertisingOption

public class AdvertisingOption : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Advertising

Assembly: AdvertisingOption (in AdvertisingOption.dll)

See Also

AdvertisingOption Members | Aptify.Applications.Advertising Namespace


AdvertisingOption Members

AdvertisingOption overview

Public Instance Constructors

AdvertisingOption Constructor Initializes a new instance of the AdvertisingOption class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config | Overloaded.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete | Overloaded. This method overrides the base GE Delete() method to check to make sure that no rate cards are linked to this record if it is saved. If any rate cards are linked to this Advertising Option record, Delete returns False.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded. This method overrides the base GE Validate() to add validation which makes sure that it is linked to a valid top-level entity through the LinkedEntityID field as well as to make sure that the record is not modified in any way after it is used by an insertion order.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
Database |
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
EntityExistsAndIsTopLevel | This method determines if the specified EntityID Exists or not and is a Top-Level entity. If the Entity ID exists and is a top-level entity, this method returns True, otherwise, this method returns False.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordIsLinkedByIO | This method checks to see if this Advertising Option record has been linked to any insertion orders.
RecordIsLinkedByRateCard | This method determines if the record is linked to any Rate Cards via the AdvertisingRateCardRateOptions sub-type entity
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

AdvertisingOption Class | Aptify.Applications.Advertising Namespace


AdvertisingOption Constructor

Initializes a new instance of the AdvertisingOption class.

public AdvertisingOption();

See Also

AdvertisingOption Class | Aptify.Applications.Advertising Namespace


AdvertisingOption Properties

The properties of the AdvertisingOption class are listed below. For a complete list of AdvertisingOption class members, see the AdvertisingOption Members topic.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
Database |
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

AdvertisingOption Class | Aptify.Applications.Advertising Namespace


Database Property

Aptify 5.0 Software Development Kit (SDK)

AdvertisingOption.Database Property

protected virtual String Database {get;}

See Also

AdvertisingOption Class | Aptify.Applications.Advertising Namespace


AdvertisingOption Methods

The methods of the AdvertisingOption class are listed below. For a complete list of AdvertisingOption class members, see the AdvertisingOption Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config | Overloaded.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete | Overloaded. This method overrides the base GE Delete() method to check to make sure that no rate cards are linked to this record if it is saved. If any rate cards are linked to this Advertising Option record, Delete returns False.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded. This method overrides the base GE Validate() to add validation which makes sure that it is linked to a valid top-level entity through the LinkedEntityID field as well as to make sure that the record is not modified in any way after it is used by an insertion order.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
EntityExistsAndIsTopLevel | This method determines if the specified EntityID Exists or not and is a Top-Level entity. If the Entity ID exists and is a top-level entity, this method returns True, otherwise, this method returns False.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordIsLinkedByIO | This method checks to see if this Advertising Option record has been linked to any insertion orders.
RecordIsLinkedByRateCard | This method determines if the record is linked to any Rate Cards via the AdvertisingRateCardRateOptions sub-type entity
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

AdvertisingOption Class | Aptify.Applications.Advertising Namespace


Config Method

Aptify 5.0 Software Development Kit (SDK)

AdvertisingOption.Config Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual void Config(AptifySubTypeBase);

Inherited from AptifyGenericEntity.

public override void Config(AptifySubTypeBase,Int64);

Inherited from AptifyGenericEntityBase.

public virtual void Config(UserCredentials,String);

public override void Config(UserCredentials,String,Int64);

See Also

AdvertisingOption Class | Aptify.Applications.Advertising Namespace


AdvertisingOption.Config Method (UserCredentials, String, Int64)

public override void Config(
UserCredentials UserCredentials,
String EntityName,
Int64 RecordID
);

See Also

AdvertisingOption Class | Aptify.Applications.Advertising Namespace | AdvertisingOption.Config Overload List


Delete Method

Aptify 5.0 Software Development Kit (SDK)

AdvertisingOption.Delete Method

This method overrides the base GE Delete() method to check to make sure that no rate cards are linked to this record if it is saved. If any rate cards are linked to this Advertising Option record, Delete returns False.

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Delete();

This method overrides the base GE Delete() method to check to make sure that no rate cards are linked to this record if it is saved. If any rate cards are linked to this Advertising Option record, Delete returns False.

public override bool Delete(String);

See Also

AdvertisingOption Class | Aptify.Applications.Advertising Namespace


AdvertisingOption.Delete Method (String)

This method overrides the base GE Delete() method to check to make sure that no rate cards are linked to this record if it is saved. If any rate cards are linked to this Advertising Option record, Delete returns False.

public override bool Delete(
String TransactionID
);

Parameters

TransactionID

Return Value

Remarks

See Also

AdvertisingOption Class | Aptify.Applications.Advertising Namespace | AdvertisingOption.Delete Overload List


AdvertisingOption.EntityExistsAndIsTopLevel Method

This method determines if the specified EntityID Exists or not and is a Top-Level entity. If the Entity ID exists and is a top-level entity, this method returns True, otherwise, this method returns False.

protected virtual bool EntityExistsAndIsTopLevel(
Int64 EntityID
);

Return Value

Remarks

See Also

AdvertisingOption Class | Aptify.Applications.Advertising Namespace


AdvertisingOption.RecordIsLinkedByIO Method

This method checks to see if this Advertising Option record has been linked to any insertion orders.

protected virtual bool RecordIsLinkedByIO();

Return Value

Remarks

See Also

AdvertisingOption Class | Aptify.Applications.Advertising Namespace


AdvertisingOption.RecordIsLinkedByRateCard Method

This method determines if the record is linked to any Rate Cards via the AdvertisingRateCardRateOptions sub-type entity

protected virtual bool RecordIsLinkedByRateCard();

Return Value

Remarks

See Also

AdvertisingOption Class | Aptify.Applications.Advertising Namespace


Validate Method

Aptify 5.0 Software Development Kit (SDK)

AdvertisingOption.Validate Method

This method overrides the base GE Validate() to add validation which makes sure that it is linked to a valid top-level entity through the LinkedEntityID field as well as to make sure that the record is not modified in any way after it is used by an insertion order.

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Validate();

This method overrides the base GE Validate() to add validation which makes sure that it is linked to a valid top-level entity through the LinkedEntityID field as well as to make sure that the record is not modified in any way after it is used by an insertion order.

public override bool Validate(ref String&);

See Also

AdvertisingOption Class | Aptify.Applications.Advertising Namespace


AdvertisingOption.Validate Method (String&)

This method overrides the base GE Validate() to add validation which makes sure that it is linked to a valid top-level entity through the LinkedEntityID field as well as to make sure that the record is not modified in any way after it is used by an insertion order.

public override bool Validate(
ref String& ErrorString
);

Parameters

ErrorString

Return Value

Remarks

See Also

AdvertisingOption Class | Aptify.Applications.Advertising Namespace | AdvertisingOption.Validate Overload List


AdvertisingRateCardDeadline Class

For a list of all members of this type, see AdvertisingRateCardDeadline Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
AdvertisingLayoutBase
AdvertisingRateCardDeadline

public class AdvertisingRateCardDeadline : AdvertisingLayoutBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Advertising

Assembly: AdvertisingRateCardControls (in AdvertisingRateCardControls.dll)

See Also

AdvertisingRateCardDeadline Members | Aptify.Applications.Advertising Namespace


AdvertisingRateCardDeadline Members

AdvertisingRateCardDeadline overview

Public Instance Constructors

AdvertisingRateCardDeadline Constructor Initializes a new instance of the AdvertisingRateCardDeadline class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
LayoutDataComboControl (inherited from AdvertisingLayoutBase) |
LayoutDataControl (inherited from AdvertisingLayoutBase) |
LayoutLinkBoxControl (inherited from AdvertisingLayoutBase) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
SubtypeControl (inherited from AdvertisingLayoutBase) |
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AddControlEventHandler (inherited from AdvertisingLayoutBase) |
AddControlEventHandlerFromFieldName (inherited from AdvertisingLayoutBase) |
AddControlEventHandlerFromSubTypeName (inherited from AdvertisingLayoutBase) |
AdjustFormScrollbars (inherited from ContainerControl) |
ConfigureDisplay |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormTemplateLayout) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControlFromFieldName (inherited from AdvertisingLayoutBase) |
FindDataControl (inherited from AdvertisingLayoutBase) |
FindSubTypeControlFromName (inherited from AdvertisingLayoutBase) |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetControlFromFieldName (inherited from AdvertisingLayoutBase) |
GetControlProperty (inherited from AdvertisingLayoutBase) |
GetDataControlProperty (inherited from AdvertisingLayoutBase) |
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetSubTypeControlFromName (inherited from AdvertisingLayoutBase) |
GetTabControl (inherited from AdvertisingLayoutBase) | Overloaded.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded (inherited from FormTemplateLayout) | Raises the FormTemplateLoaded event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad |
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlProperty (inherited from AdvertisingLayoutBase) | Overloaded.
SetDataControlProperty (inherited from AdvertisingLayoutBase) | Overloaded.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

AdvertisingRateCardDeadline Class | Aptify.Applications.Advertising Namespace


AdvertisingRateCardDeadline Constructor

Initializes a new instance of the AdvertisingRateCardDeadline class.

public AdvertisingRateCardDeadline();

See Also

AdvertisingRateCardDeadline Class | Aptify.Applications.Advertising Namespace


AdvertisingRateCardDeadline Methods

The methods of the AdvertisingRateCardDeadline class are listed below. For a complete list of AdvertisingRateCardDeadline class members, see the AdvertisingRateCardDeadline Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AddControlEventHandler (inherited from AdvertisingLayoutBase) |
AddControlEventHandlerFromFieldName (inherited from AdvertisingLayoutBase) |
AddControlEventHandlerFromSubTypeName (inherited from AdvertisingLayoutBase) |
AdjustFormScrollbars (inherited from ContainerControl) |
ConfigureDisplay |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormTemplateLayout) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControlFromFieldName (inherited from AdvertisingLayoutBase) |
FindDataControl (inherited from AdvertisingLayoutBase) |
FindSubTypeControlFromName (inherited from AdvertisingLayoutBase) |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetControlFromFieldName (inherited from AdvertisingLayoutBase) |
GetControlProperty (inherited from AdvertisingLayoutBase) |
GetDataControlProperty (inherited from AdvertisingLayoutBase) |
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetSubTypeControlFromName (inherited from AdvertisingLayoutBase) |
GetTabControl (inherited from AdvertisingLayoutBase) | Overloaded.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded (inherited from FormTemplateLayout) | Raises the FormTemplateLoaded event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad |
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlProperty (inherited from AdvertisingLayoutBase) | Overloaded.
SetDataControlProperty (inherited from AdvertisingLayoutBase) | Overloaded.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

AdvertisingRateCardDeadline Class | Aptify.Applications.Advertising Namespace


AdvertisingRateCardDeadline.ConfigureDisplay Method

protected virtual void ConfigureDisplay();

See Also

AdvertisingRateCardDeadline Class | Aptify.Applications.Advertising Namespace


AdvertisingRateCardDeadline.OnLoad Method

protected override void OnLoad(
EventArgs e
);

See Also

AdvertisingRateCardDeadline Class | Aptify.Applications.Advertising Namespace


AdvertisingRateCardDeadline.OnRefresh Method

protected override void OnRefresh();

Implements

IFormComponent.

See Also

AdvertisingRateCardDeadline Class | Aptify.Applications.Advertising Namespace


AdvertisingRateCardDeadlineEntity Class

For a list of all members of this type, see AdvertisingRateCardDeadlineEntity Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
AdvertisingRateCardDeadlineEntity

public class AdvertisingRateCardDeadlineEntity : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Advertising

Assembly: AdvertisingRateCard (in AdvertisingRateCard.dll)

See Also

AdvertisingRateCardDeadlineEntity Members | Aptify.Applications.Advertising Namespace


AdvertisingRateCardDeadlineEntity Members

AdvertisingRateCardDeadlineEntity overview

Public Instance Constructors

AdvertisingRateCardDeadlineEntity Constructor Initializes a new instance of the AdvertisingRateCardDeadlineEntity class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

AdvertisingRateCardDeadlineEntity Class | Aptify.Applications.Advertising Namespace


AdvertisingRateCardDeadlineEntity Constructor

Initializes a new instance of the AdvertisingRateCardDeadlineEntity class.

public AdvertisingRateCardDeadlineEntity();

See Also

AdvertisingRateCardDeadlineEntity Class | Aptify.Applications.Advertising Namespace


AdvertisingRateCardDeadlineEntity Methods

The methods of the AdvertisingRateCardDeadlineEntity class are listed below. For a complete list of AdvertisingRateCardDeadlineEntity class members, see the AdvertisingRateCardDeadlineEntity Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

AdvertisingRateCardDeadlineEntity Class | Aptify.Applications.Advertising Namespace


Validate Method

Aptify 5.0 Software Development Kit (SDK)

AdvertisingRateCardDeadlineEntity.Validate Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Validate();

public override bool Validate(ref String&);

See Also

AdvertisingRateCardDeadlineEntity Class | Aptify.Applications.Advertising Namespace


AdvertisingRateCardDeadlineEntity.Validate Method (String&)

public override bool Validate(
ref String& ErrorString
);

See Also

AdvertisingRateCardDeadlineEntity Class | Aptify.Applications.Advertising Namespace | AdvertisingRateCardDeadlineEntity.Validate Overload List


AdvertisingRateCardLayout Class

For a list of all members of this type, see AdvertisingRateCardLayout Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
AdvertisingLayoutBase
AdvertisingRateCardLayout

public class AdvertisingRateCardLayout : AdvertisingLayoutBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Advertising

Assembly: AdvertisingRateCardControls (in AdvertisingRateCardControls.dll)

See Also

AdvertisingRateCardLayout Members | Aptify.Applications.Advertising Namespace


AdvertisingRateCardLayout Members

AdvertisingRateCardLayout overview

Public Instance Constructors

AdvertisingRateCardLayout Constructor Initializes a new instance of the AdvertisingRateCardLayout class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

dlgControlKeyPress
dlgControlValueChanged
m_bDisableValueChangeEvents

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
datEntity |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
LayoutDataComboControl (inherited from AdvertisingLayoutBase) |
LayoutDataControl (inherited from AdvertisingLayoutBase) |
LayoutLinkBoxControl (inherited from AdvertisingLayoutBase) |
msubDeadlines |
msubRates |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
SubtypeControl (inherited from AdvertisingLayoutBase) |
tabMain |
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AddControlEventHandler (inherited from AdvertisingLayoutBase) |
AddControlEventHandlerFromFieldName (inherited from AdvertisingLayoutBase) |
AddControlEventHandlerFromSubTypeName (inherited from AdvertisingLayoutBase) |
AdjustFormScrollbars (inherited from ContainerControl) |
ConfigureDisplay |
ControlKeyPressHandler |
ControlValueChanged |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormTemplateLayout) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControlFromFieldName (inherited from AdvertisingLayoutBase) |
FindControls |
FindDataControl (inherited from AdvertisingLayoutBase) |
FindSubTypeControlFromName (inherited from AdvertisingLayoutBase) |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetControlFromFieldName (inherited from AdvertisingLayoutBase) |
GetControlProperty (inherited from AdvertisingLayoutBase) |
GetDataControlProperty (inherited from AdvertisingLayoutBase) |
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetSubTypeControlFromName (inherited from AdvertisingLayoutBase) |
GetTabControl (inherited from AdvertisingLayoutBase) | Overloaded.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded (inherited from FormTemplateLayout) | Raises the FormTemplateLoaded event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad |
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlProperty (inherited from AdvertisingLayoutBase) | Overloaded.
SetDataControlProperty (inherited from AdvertisingLayoutBase) | Overloaded.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

AdvertisingRateCardLayout Class | Aptify.Applications.Advertising Namespace


AdvertisingRateCardLayout Constructor

Initializes a new instance of the AdvertisingRateCardLayout class.

public AdvertisingRateCardLayout();

See Also

AdvertisingRateCardLayout Class | Aptify.Applications.Advertising Namespace


AdvertisingRateCardLayout Fields

The fields of the AdvertisingRateCardLayout class are listed below. For a complete list of AdvertisingRateCardLayout class members, see the AdvertisingRateCardLayout Members topic.

Protected Instance Fields

dlgControlKeyPress
dlgControlValueChanged
m_bDisableValueChangeEvents

See Also

AdvertisingRateCardLayout Class | Aptify.Applications.Advertising Namespace


AdvertisingRateCardLayout.dlgControlKeyPress Field

protected dlgControlKeyPress dlgControlKeyPress;

See Also

AdvertisingRateCardLayout Class | Aptify.Applications.Advertising Namespace


AdvertisingRateCardLayout.dlgControlValueChanged Field

protected dlgControlValueChanged dlgControlValueChanged;

See Also

AdvertisingRateCardLayout Class | Aptify.Applications.Advertising Namespace


AdvertisingRateCardLayout.m_bDisableValueChangeEvents Field

protected m_bDisableValueChangeEvents m_bDisableValueChangeEvents;

See Also

AdvertisingRateCardLayout Class | Aptify.Applications.Advertising Namespace


AdvertisingRateCardLayout Properties

The properties of the AdvertisingRateCardLayout class are listed below. For a complete list of AdvertisingRateCardLayout class members, see the AdvertisingRateCardLayout Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
datEntity |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
LayoutDataComboControl (inherited from AdvertisingLayoutBase) |
LayoutDataControl (inherited from AdvertisingLayoutBase) |
LayoutLinkBoxControl (inherited from AdvertisingLayoutBase) |
msubDeadlines |
msubRates |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
SubtypeControl (inherited from AdvertisingLayoutBase) |
tabMain |
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

AdvertisingRateCardLayout Class | Aptify.Applications.Advertising Namespace


datEntity Property

Aptify 5.0 Software Development Kit (SDK)

AdvertisingRateCardLayout.datEntity Property

protected virtual AptifyDataControl datEntity {get; set;}

See Also

AdvertisingRateCardLayout Class | Aptify.Applications.Advertising Namespace


msubDeadlines Property

Aptify 5.0 Software Development Kit (SDK)

AdvertisingRateCardLayout.msubDeadlines Property

protected virtual AptifySubType msubDeadlines {get; set;}

See Also

AdvertisingRateCardLayout Class | Aptify.Applications.Advertising Namespace


msubRates Property

Aptify 5.0 Software Development Kit (SDK)

AdvertisingRateCardLayout.msubRates Property

protected virtual AptifySubType msubRates {get; set;}

See Also

AdvertisingRateCardLayout Class | Aptify.Applications.Advertising Namespace


tabMain Property

Aptify 5.0 Software Development Kit (SDK)

AdvertisingRateCardLayout.tabMain Property

protected virtual UltraTabControl tabMain {get; set;}

See Also

AdvertisingRateCardLayout Class | Aptify.Applications.Advertising Namespace


AdvertisingRateCardLayout Methods

The methods of the AdvertisingRateCardLayout class are listed below. For a complete list of AdvertisingRateCardLayout class members, see the AdvertisingRateCardLayout Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AddControlEventHandler (inherited from AdvertisingLayoutBase) |
AddControlEventHandlerFromFieldName (inherited from AdvertisingLayoutBase) |
AddControlEventHandlerFromSubTypeName (inherited from AdvertisingLayoutBase) |
AdjustFormScrollbars (inherited from ContainerControl) |
ConfigureDisplay |
ControlKeyPressHandler |
ControlValueChanged |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormTemplateLayout) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControlFromFieldName (inherited from AdvertisingLayoutBase) |
FindControls |
FindDataControl (inherited from AdvertisingLayoutBase) |
FindSubTypeControlFromName (inherited from AdvertisingLayoutBase) |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetControlFromFieldName (inherited from AdvertisingLayoutBase) |
GetControlProperty (inherited from AdvertisingLayoutBase) |
GetDataControlProperty (inherited from AdvertisingLayoutBase) |
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetSubTypeControlFromName (inherited from AdvertisingLayoutBase) |
GetTabControl (inherited from AdvertisingLayoutBase) | Overloaded.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded (inherited from FormTemplateLayout) | Raises the FormTemplateLoaded event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad |
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlProperty (inherited from AdvertisingLayoutBase) | Overloaded.
SetDataControlProperty (inherited from AdvertisingLayoutBase) | Overloaded.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

AdvertisingRateCardLayout Class | Aptify.Applications.Advertising Namespace


AdvertisingRateCardLayout.ConfigureDisplay Method

protected virtual void ConfigureDisplay();

See Also

AdvertisingRateCardLayout Class | Aptify.Applications.Advertising Namespace


AdvertisingRateCardLayout.ControlKeyPressHandler Method

protected virtual void ControlKeyPressHandler(
Object sender,
KeyPressEventArgs e
);

See Also

AdvertisingRateCardLayout Class | Aptify.Applications.Advertising Namespace


AdvertisingRateCardLayout.ControlValueChanged Method

protected virtual void ControlValueChanged(
Object sender,
Object OldValue,
Object NewValue
);

See Also

AdvertisingRateCardLayout Class | Aptify.Applications.Advertising Namespace


AdvertisingRateCardLayout.FindControls Method

protected virtual void FindControls();

See Also

AdvertisingRateCardLayout Class | Aptify.Applications.Advertising Namespace


AdvertisingRateCardLayout.OnLoad Method

protected override void OnLoad(
EventArgs e
);

See Also

AdvertisingRateCardLayout Class | Aptify.Applications.Advertising Namespace


AdvertisingRateCardLayout.OnRefresh Method

protected override void OnRefresh();

Implements

IFormComponent.

See Also

AdvertisingRateCardLayout Class | Aptify.Applications.Advertising Namespace


AdvertisingRateCardRate Class

This class provides the implementation for business logic for the Advertising Rate Card Rates sub-type entity in the Aptify Advertising Management system.

For a list of all members of this type, see AdvertisingRateCardRate Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
AdvertisingRateCardRate

public class AdvertisingRateCardRate : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Advertising

Assembly: AdvertisingRateCard (in AdvertisingRateCard.dll)

See Also

AdvertisingRateCardRate Members | Aptify.Applications.Advertising Namespace


AdvertisingRateCardRate Members

AdvertisingRateCardRate overview

Public Instance Constructors

AdvertisingRateCardRate Constructor Initializes a new instance of the AdvertisingRateCardRate class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config | Overloaded.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
Database |
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

AdvertisingRateCardRate Class | Aptify.Applications.Advertising Namespace


AdvertisingRateCardRate Constructor

Initializes a new instance of the AdvertisingRateCardRate class.

public AdvertisingRateCardRate();

See Also

AdvertisingRateCardRate Class | Aptify.Applications.Advertising Namespace


AdvertisingRateCardRate Properties

The properties of the AdvertisingRateCardRate class are listed below. For a complete list of AdvertisingRateCardRate class members, see the AdvertisingRateCardRate Members topic.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
Database |
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

AdvertisingRateCardRate Class | Aptify.Applications.Advertising Namespace


Database Property

Aptify 5.0 Software Development Kit (SDK)

AdvertisingRateCardRate.Database Property

protected virtual String Database {get;}

See Also

AdvertisingRateCardRate Class | Aptify.Applications.Advertising Namespace


AdvertisingRateCardRate Methods

The methods of the AdvertisingRateCardRate class are listed below. For a complete list of AdvertisingRateCardRate class members, see the AdvertisingRateCardRate Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config | Overloaded.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

AdvertisingRateCardRate Class | Aptify.Applications.Advertising Namespace


Config Method

Aptify 5.0 Software Development Kit (SDK)

AdvertisingRateCardRate.Config Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual void Config(AptifySubTypeBase);

Inherited from AptifyGenericEntity.

public override void Config(AptifySubTypeBase,Int64);

Inherited from AptifyGenericEntityBase.

public virtual void Config(UserCredentials,String);

public override void Config(UserCredentials,String,Int64);

See Also

AdvertisingRateCardRate Class | Aptify.Applications.Advertising Namespace


AdvertisingRateCardRate.Config Method (UserCredentials, String, Int64)

public override void Config(
UserCredentials UserCredentials,
String EntityName,
Int64 RecordID
);

See Also

AdvertisingRateCardRate Class | Aptify.Applications.Advertising Namespace | AdvertisingRateCardRate.Config Overload List


Validate Method

Aptify 5.0 Software Development Kit (SDK)

AdvertisingRateCardRate.Validate Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Validate();

public override bool Validate(ref String&);

See Also

AdvertisingRateCardRate Class | Aptify.Applications.Advertising Namespace


AdvertisingRateCardRate.Validate Method (String&)

public override bool Validate(
ref String& ErrorString
);

See Also

AdvertisingRateCardRate Class | Aptify.Applications.Advertising Namespace | AdvertisingRateCardRate.Validate Overload List


AdvertisingRateCardRateOption Class

This class provides the implementation for business logic for the Advertising Rate Card Options sub-type entity in the Aptify Advertising Management system.

For a list of all members of this type, see AdvertisingRateCardRateOption Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
AdvertisingRateCardRateOption

public class AdvertisingRateCardRateOption : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Advertising

Assembly: AdvertisingRateCard (in AdvertisingRateCard.dll)

See Also

AdvertisingRateCardRateOption Members | Aptify.Applications.Advertising Namespace


AdvertisingRateCardRateOption Members

AdvertisingRateCardRateOption overview

Public Instance Constructors

AdvertisingRateCardRateOption Constructor Initializes a new instance of the AdvertisingRateCardRateOption class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config | Overloaded.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete | Overloaded. This method overrides the base Delete() method to ensure that if any Insertion Orders are linked to this Rate Card Option record that it is not possible to delete it.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
IsLinkedToInsertionOrder | This method checks to see if this Option record has been linked to an Insertion Order
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
Database |
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

AdvertisingRateCardRateOption Class | Aptify.Applications.Advertising Namespace


AdvertisingRateCardRateOption Constructor

Initializes a new instance of the AdvertisingRateCardRateOption class.

public AdvertisingRateCardRateOption();

See Also

AdvertisingRateCardRateOption Class | Aptify.Applications.Advertising Namespace


AdvertisingRateCardRateOption Properties

The properties of the AdvertisingRateCardRateOption class are listed below. For a complete list of AdvertisingRateCardRateOption class members, see the AdvertisingRateCardRateOption Members topic.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
Database |
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

AdvertisingRateCardRateOption Class | Aptify.Applications.Advertising Namespace


Database Property

Aptify 5.0 Software Development Kit (SDK)

AdvertisingRateCardRateOption.Database Property

protected virtual String Database {get;}

See Also

AdvertisingRateCardRateOption Class | Aptify.Applications.Advertising Namespace


AdvertisingRateCardRateOption Methods

The methods of the AdvertisingRateCardRateOption class are listed below. For a complete list of AdvertisingRateCardRateOption class members, see the AdvertisingRateCardRateOption Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config | Overloaded.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete | Overloaded. This method overrides the base Delete() method to ensure that if any Insertion Orders are linked to this Rate Card Option record that it is not possible to delete it.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
IsLinkedToInsertionOrder | This method checks to see if this Option record has been linked to an Insertion Order
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

AdvertisingRateCardRateOption Class | Aptify.Applications.Advertising Namespace


Config Method

Aptify 5.0 Software Development Kit (SDK)

AdvertisingRateCardRateOption.Config Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual void Config(AptifySubTypeBase);

Inherited from AptifyGenericEntity.

public override void Config(AptifySubTypeBase,Int64);

Inherited from AptifyGenericEntityBase.

public virtual void Config(UserCredentials,String);

public override void Config(UserCredentials,String,Int64);

See Also

AdvertisingRateCardRateOption Class | Aptify.Applications.Advertising Namespace


AdvertisingRateCardRateOption.Config Method (UserCredentials, String, Int64)

public override void Config(
UserCredentials UserCredentials,
String EntityName,
Int64 RecordID
);

See Also

AdvertisingRateCardRateOption Class | Aptify.Applications.Advertising Namespace | AdvertisingRateCardRateOption.Config Overload List


Delete Method

Aptify 5.0 Software Development Kit (SDK)

AdvertisingRateCardRateOption.Delete Method

This method overrides the base Delete() method to ensure that if any Insertion Orders are linked to this Rate Card Option record that it is not possible to delete it.

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Delete();

This method overrides the base Delete() method to ensure that if any Insertion Orders are linked to this Rate Card Option record that it is not possible to delete it.

public override bool Delete(String);

See Also

AdvertisingRateCardRateOption Class | Aptify.Applications.Advertising Namespace


AdvertisingRateCardRateOption.Delete Method (String)

This method overrides the base Delete() method to ensure that if any Insertion Orders are linked to this Rate Card Option record that it is not possible to delete it.

public override bool Delete(
String TransactionID
);

Parameters

TransactionID

Return Value

Remarks

See Also

AdvertisingRateCardRateOption Class | Aptify.Applications.Advertising Namespace | AdvertisingRateCardRateOption.Delete Overload List


AdvertisingRateCardRateOption.IsLinkedToInsertionOrder Method

This method checks to see if this Option record has been linked to an Insertion Order

public virtual bool IsLinkedToInsertionOrder();

Return Value

Remarks

See Also

AdvertisingRateCardRateOption Class | Aptify.Applications.Advertising Namespace


AdvertisingRateCardSectionLayout Class

For a list of all members of this type, see AdvertisingRateCardSectionLayout Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
AdvertisingLayoutBase
AdvertisingRateCardSectionLayout

public class AdvertisingRateCardSectionLayout : AdvertisingLayoutBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Advertising

Assembly: AdvertisingRateCardControls (in AdvertisingRateCardControls.dll)

See Also

AdvertisingRateCardSectionLayout Members | Aptify.Applications.Advertising Namespace


AdvertisingRateCardSectionLayout Members

AdvertisingRateCardSectionLayout overview

Public Instance Constructors

AdvertisingRateCardSectionLayout Constructor Initializes a new instance of the AdvertisingRateCardSectionLayout class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
LayoutDataComboControl (inherited from AdvertisingLayoutBase) |
LayoutDataControl (inherited from AdvertisingLayoutBase) |
LayoutLinkBoxControl (inherited from AdvertisingLayoutBase) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
SubtypeControl (inherited from AdvertisingLayoutBase) |
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AddControlEventHandler (inherited from AdvertisingLayoutBase) |
AddControlEventHandlerFromFieldName (inherited from AdvertisingLayoutBase) |
AddControlEventHandlerFromSubTypeName (inherited from AdvertisingLayoutBase) |
AdjustFormScrollbars (inherited from ContainerControl) |
ConfigureDisplay |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormTemplateLayout) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControlFromFieldName (inherited from AdvertisingLayoutBase) |
FindDataControl (inherited from AdvertisingLayoutBase) |
FindSubTypeControlFromName (inherited from AdvertisingLayoutBase) |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetControlFromFieldName (inherited from AdvertisingLayoutBase) |
GetControlProperty (inherited from AdvertisingLayoutBase) |
GetDataControlProperty (inherited from AdvertisingLayoutBase) |
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetSubTypeControlFromName (inherited from AdvertisingLayoutBase) |
GetTabControl (inherited from AdvertisingLayoutBase) | Overloaded.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded (inherited from FormTemplateLayout) | Raises the FormTemplateLoaded event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad |
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlProperty (inherited from AdvertisingLayoutBase) | Overloaded.
SetDataControlProperty (inherited from AdvertisingLayoutBase) | Overloaded.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

AdvertisingRateCardSectionLayout Class | Aptify.Applications.Advertising Namespace


AdvertisingRateCardSectionLayout Constructor

Initializes a new instance of the AdvertisingRateCardSectionLayout class.

public AdvertisingRateCardSectionLayout();

See Also

AdvertisingRateCardSectionLayout Class | Aptify.Applications.Advertising Namespace


AdvertisingRateCardSectionLayout Methods

The methods of the AdvertisingRateCardSectionLayout class are listed below. For a complete list of AdvertisingRateCardSectionLayout class members, see the AdvertisingRateCardSectionLayout Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AddControlEventHandler (inherited from AdvertisingLayoutBase) |
AddControlEventHandlerFromFieldName (inherited from AdvertisingLayoutBase) |
AddControlEventHandlerFromSubTypeName (inherited from AdvertisingLayoutBase) |
AdjustFormScrollbars (inherited from ContainerControl) |
ConfigureDisplay |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormTemplateLayout) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControlFromFieldName (inherited from AdvertisingLayoutBase) |
FindDataControl (inherited from AdvertisingLayoutBase) |
FindSubTypeControlFromName (inherited from AdvertisingLayoutBase) |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetControlFromFieldName (inherited from AdvertisingLayoutBase) |
GetControlProperty (inherited from AdvertisingLayoutBase) |
GetDataControlProperty (inherited from AdvertisingLayoutBase) |
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetSubTypeControlFromName (inherited from AdvertisingLayoutBase) |
GetTabControl (inherited from AdvertisingLayoutBase) | Overloaded.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded (inherited from FormTemplateLayout) | Raises the FormTemplateLoaded event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad |
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlProperty (inherited from AdvertisingLayoutBase) | Overloaded.
SetDataControlProperty (inherited from AdvertisingLayoutBase) | Overloaded.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

AdvertisingRateCardSectionLayout Class | Aptify.Applications.Advertising Namespace


AdvertisingRateCardSectionLayout.ConfigureDisplay Method

protected virtual void ConfigureDisplay();

See Also

AdvertisingRateCardSectionLayout Class | Aptify.Applications.Advertising Namespace


AdvertisingRateCardSectionLayout.OnLoad Method

protected override void OnLoad(
EventArgs e
);

See Also

AdvertisingRateCardSectionLayout Class | Aptify.Applications.Advertising Namespace


AdvertisingRateCardSectionLayout.OnRefresh Method

protected override void OnRefresh();

Implements

IFormComponent.

See Also

AdvertisingRateCardSectionLayout Class | Aptify.Applications.Advertising Namespace


AdvertisingUnitDefinition Class

This class provides the implementation for business logic for the Advertising Unit Definitions entity in the Aptify Advertising Management system.

For a list of all members of this type, see AdvertisingUnitDefinition Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
AdvertisingUnitDefinition

public class AdvertisingUnitDefinition : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Advertising

Assembly: AdvertisingUnitDefinition (in AdvertisingUnitDefinition.dll)

See Also

AdvertisingUnitDefinition Members | Aptify.Applications.Advertising Namespace


AdvertisingUnitDefinition Members

AdvertisingUnitDefinition overview

Public Instance Constructors

AdvertisingUnitDefinition Constructor Initializes a new instance of the AdvertisingUnitDefinition class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config | Overloaded.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDefaultUnitDefinitionObject | This method returns the default Unit Definition object which is defined in the Entity Attributes for the Advertising Unit Definitions Entity with the following attributes Unit Defintion Object Unit Defintion Assembly Unit Defintion Class
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetUnitDefinitionObject | This method returns the Unit Definition Object for the currently loaded Unit Definition. The default behavior is to look at the Unit Definition Object, Class and Assembly fields within the current object and if all of those fields have values, to use those attributes to instantiate the specified object that implements the IAdvertisingUnitDefinition interface. If any of the fields in the currently loaded object are not filled in, the DefaultUnitDefinitionObject() method is called and its value is returned
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded. This method overrides the base GE Validate() functionality to add additional checking for unit-definition specific logic. Specifically, it instantiates the Unit Definition object provided for this record(if not provided, uses the default unit definition object) and calls the ParseParameters() method of the specified object to make sure that the Type and TypeParameterString fields of the record are valid.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
Database |
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

AdvertisingUnitDefinition Class | Aptify.Applications.Advertising Namespace


AdvertisingUnitDefinition Constructor

Initializes a new instance of the AdvertisingUnitDefinition class.

public AdvertisingUnitDefinition();

See Also

AdvertisingUnitDefinition Class | Aptify.Applications.Advertising Namespace


AdvertisingUnitDefinition Properties

The properties of the AdvertisingUnitDefinition class are listed below. For a complete list of AdvertisingUnitDefinition class members, see the AdvertisingUnitDefinition Members topic.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
Database |
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

AdvertisingUnitDefinition Class | Aptify.Applications.Advertising Namespace


Database Property

Aptify 5.0 Software Development Kit (SDK)

AdvertisingUnitDefinition.Database Property

protected virtual String Database {get;}

See Also

AdvertisingUnitDefinition Class | Aptify.Applications.Advertising Namespace


AdvertisingUnitDefinition Methods

The methods of the AdvertisingUnitDefinition class are listed below. For a complete list of AdvertisingUnitDefinition class members, see the AdvertisingUnitDefinition Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config | Overloaded.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDefaultUnitDefinitionObject | This method returns the default Unit Definition object which is defined in the Entity Attributes for the Advertising Unit Definitions Entity with the following attributes Unit Defintion Object Unit Defintion Assembly Unit Defintion Class
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetUnitDefinitionObject | This method returns the Unit Definition Object for the currently loaded Unit Definition. The default behavior is to look at the Unit Definition Object, Class and Assembly fields within the current object and if all of those fields have values, to use those attributes to instantiate the specified object that implements the IAdvertisingUnitDefinition interface. If any of the fields in the currently loaded object are not filled in, the DefaultUnitDefinitionObject() method is called and its value is returned
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded. This method overrides the base GE Validate() functionality to add additional checking for unit-definition specific logic. Specifically, it instantiates the Unit Definition object provided for this record(if not provided, uses the default unit definition object) and calls the ParseParameters() method of the specified object to make sure that the Type and TypeParameterString fields of the record are valid.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

AdvertisingUnitDefinition Class | Aptify.Applications.Advertising Namespace


Config Method

Aptify 5.0 Software Development Kit (SDK)

AdvertisingUnitDefinition.Config Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual void Config(AptifySubTypeBase);

Inherited from AptifyGenericEntity.

public override void Config(AptifySubTypeBase,Int64);

Inherited from AptifyGenericEntityBase.

public virtual void Config(UserCredentials,String);

public override void Config(UserCredentials,String,Int64);

See Also

AdvertisingUnitDefinition Class | Aptify.Applications.Advertising Namespace


AdvertisingUnitDefinition.Config Method (UserCredentials, String, Int64)

public override void Config(
UserCredentials UserCredentials,
String EntityName,
Int64 RecordID
);

See Also

AdvertisingUnitDefinition Class | Aptify.Applications.Advertising Namespace | AdvertisingUnitDefinition.Config Overload List


AdvertisingUnitDefinition.GetDefaultUnitDefinitionObject Method

This method returns the default Unit Definition object which is defined in the Entity Attributes for the Advertising Unit Definitions Entity with the following attributes Unit Defintion Object Unit Defintion Assembly Unit Defintion Class

public virtual IAdvertisingUnitDefinition GetDefaultUnitDefinitionObject();

Return Value

Remarks

See Also

AdvertisingUnitDefinition Class | Aptify.Applications.Advertising Namespace


AdvertisingUnitDefinition.GetUnitDefinitionObject Method

This method returns the Unit Definition Object for the currently loaded Unit Definition. The default behavior is to look at the Unit Definition Object, Class and Assembly fields within the current object and if all of those fields have values, to use those attributes to instantiate the specified object that implements the IAdvertisingUnitDefinition interface. If any of the fields in the currently loaded object are not filled in, the DefaultUnitDefinitionObject() method is called and its value is returned

public virtual IAdvertisingUnitDefinition GetUnitDefinitionObject();

Return Value

Remarks

See Also

AdvertisingUnitDefinition Class | Aptify.Applications.Advertising Namespace


Validate Method

Aptify 5.0 Software Development Kit (SDK)

AdvertisingUnitDefinition.Validate Method

This method overrides the base GE Validate() functionality to add additional checking for unit-definition specific logic. Specifically, it instantiates the Unit Definition object provided for this record(if not provided, uses the default unit definition object) and calls the ParseParameters() method of the specified object to make sure that the Type and TypeParameterString fields of the record are valid.

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Validate();

This method overrides the base GE Validate() functionality to add additional checking for unit-definition specific logic. Specifically, it instantiates the Unit Definition object provided for this record(if not provided, uses the default unit definition object) and calls the ParseParameters() method of the specified object to make sure that the Type and TypeParameterString fields of the record are valid.

public override bool Validate(ref String&);

See Also

AdvertisingUnitDefinition Class | Aptify.Applications.Advertising Namespace


AdvertisingUnitDefinition.Validate Method (String&)

This method overrides the base GE Validate() functionality to add additional checking for unit-definition specific logic. Specifically, it instantiates the Unit Definition object provided for this record(if not provided, uses the default unit definition object) and calls the ParseParameters() method of the specified object to make sure that the Type and TypeParameterString fields of the record are valid.

public override bool Validate(
ref String& ErrorString
);

Parameters

ErrorString

Return Value

Remarks

See Also

AdvertisingUnitDefinition Class | Aptify.Applications.Advertising Namespace | AdvertisingUnitDefinition.Validate Overload List


AptifyLinkLabel Class

For a list of all members of this type, see AptifyLinkLabel Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
AptifyControlBase
AptifyLinkLabel

public class AptifyLinkLabel : AptifyControlBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Advertising

Assembly: AdvertisingInsertionOrderControls (in AdvertisingInsertionOrderControls.dll)

See Also

AptifyLinkLabel Members | Aptify.Applications.Advertising Namespace


AptifyLinkLabel Members

AptifyLinkLabel overview

Public Instance Constructors

AptifyLinkLabel Constructor Initializes a new instance of the AptifyLinkLabel class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Control (inherited from AptifyControlBase) |
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DataControl (inherited from AptifyControlBase) | Adds a reference to the object for the data control. In the case of it being added, the reference to the bound control base object is added to the data controls collection.
DisableGeDataTransfer (inherited from AptifyControlBase) | If true, the implementer is required to move the value to/from the bound control to the GE or other data access method.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
FieldHelp (inherited from AptifyControlBase) |
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateContext (inherited from AptifyControlBase) | Returns the reference that if is local that is returned else if a DataControl exists, it is returned.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpObject (inherited from AptifyControlBase) | This method is responsible for returning the context-specific help Object file location in the Aptify Object repository. The base class implementation returns the entity-level help, if available, and if not, returns the DefaultHelpObject
HelpURL (inherited from AptifyControlBase) | This method is responsible for returning the context-specific help URL file location within the HelpObject to use. The base class implementation returns the entity-level help URL, if available, and if not, returns Nothing, which results in the content page being displayed.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
LinkLabelText |
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
ObjectRepository (inherited from AptifyControlBase) |
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BoundControlConfig (inherited from AptifyControlBase) | Called by the data control to handle security,enable/disable settings, and set the label from data, if necessary. This is implemented by the sub class.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ClearData (inherited from AptifyControlBase) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DisplayControlHelp (inherited from AptifyControlBase) | This method will display control-level help information. This method will use the HelpTitle and HelpText overridable members to display the Field Help object from Aptify.Framework.WindowsControls.FieldHelp. If the title and text is desired to be overriden it is not necessary to override this method, rather override the HelpTitle and HelpText properties which are used by this method.
DisplayEntityHelp (inherited from AptifyControlBase) | This method is responsible for displaying the help file to the user and will attempt to provide context sensitive help based on the particular entity being displayed. If no entity-specific help file is available for the user then the standard Aptify Shell.Aptify Help file will be used to display help to the user. Override this method in sub-classes to change the method for displaying help.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetDefaultHelpObject (inherited from AptifyControlBase) | This method returns the default help object file in the Aptify Object repository to be used in the event that no entity-specific file exists
GetEntitySpecificHelpObject (inherited from AptifyControlBase) | This method returns the Aptify Object Repository Object location for the help file that is specific to this entity.
GetEntitySpecificHelpTopicURL (inherited from AptifyControlBase) | This method returns the Topic URL location within the help file that is specific to this entity.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseValueChanged (inherited from AptifyControlBase) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from AptifyControlBase) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetUserCredential (inherited from AptifyControlBase) |
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
TransferDataToObject (inherited from AptifyControlBase) | Implemented by the sub class to transfer data from the control to the Generic Entity (GE) or some other data access tool.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AfterDisplayEntityHelp (inherited from AptifyControlBase) | This event is fired after the help file is displayed.
AptifyControlBaseTextChanged (inherited from AptifyControlBase) |
AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BeforeDisplayEntityHelp (inherited from AptifyControlBase) | This event is fired before the help file is displayed. To prevent help from being displayed set the Cancel parameter to True.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click |
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from AptifyControlBase) |
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from AptifyControlBase) |
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from AptifyControlBase) |
KeyPress (inherited from AptifyControlBase) |
KeyUp (inherited from AptifyControlBase) |
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from AptifyControlBase) |
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from AptifyControlBase) |
MouseEnter (inherited from AptifyControlBase) |
MouseHover (inherited from AptifyControlBase) |
MouseLeave (inherited from AptifyControlBase) |
MouseMove (inherited from AptifyControlBase) |
MouseUp (inherited from AptifyControlBase) |
MouseWheel (inherited from AptifyControlBase) |
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from AptifyControlBase) |
Validated (inherited from AptifyControlBase) |
Validating (inherited from AptifyControlBase) |
ValueChanged (inherited from AptifyControlBase) |
VisibleChanged (inherited from AptifyControlBase) |

Protected Instance Fields

m_iDataControl (inherited from AptifyControlBase)
m_oAptifyApplication (inherited from AptifyControlBase)
m_oFormTemplateContext (inherited from AptifyControlBase)
m_oUserCredential (inherited from AptifyControlBase)
mContext

Protected Instance Properties

AptifyApplication (inherited from AptifyControlBase) | Returns an instance of the Aptify Application Object
AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
CurrencyTypeCache (inherited from AptifyControlBase) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DisplayName (inherited from AptifyControlBase) |
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HelpText (inherited from AptifyControlBase) |
HelpTitle (inherited from AptifyControlBase) | This property is designed to be overriden by subclasses that want to provide a different title. The base class returns "Aptify Help" for this property.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
InternalControl (inherited from AptifyControlBase) | Specifies the Main Control of interest in a composite control.
m_oInternalControl (inherited from AptifyControlBase) |
MyApplication (inherited from AptifyControlBase) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowDisplayHelpHyperlink (inherited from AptifyControlBase) | This property can be overriden by sub-classes to be able to selectively turn on or off the Display Help hyperlink that appears by default on the FieldHelp object.
UserCredential (inherited from AptifyControlBase) |
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
ConfigHelp (inherited from AptifyControlBase) | This method configures the base FieldHelp object and sets up a default string in the HelpText field. Sub-Classes should override this to implement specific help relevant to their context of use.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
DoFormComponentConfig |
Finalize (inherited from AptifyControlBase) |
FormComponentConfig (inherited from AptifyControlBase) |
FormComponentHide (inherited from AptifyControlBase) |
FormComponentShow (inherited from AptifyControlBase) | Overloaded.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RequiredGECheck (inherited from AptifyControlBase) |
RequiredPropertiesCheck (inherited from AptifyControlBase) |
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

AptifyLinkLabel Class | Aptify.Applications.Advertising Namespace


AptifyLinkLabel Constructor

Initializes a new instance of the AptifyLinkLabel class.

public AptifyLinkLabel();

See Also

AptifyLinkLabel Class | Aptify.Applications.Advertising Namespace


AptifyLinkLabel Fields

The fields of the AptifyLinkLabel class are listed below. For a complete list of AptifyLinkLabel class members, see the AptifyLinkLabel Members topic.

Protected Instance Fields

m_iDataControl (inherited from AptifyControlBase)
m_oAptifyApplication (inherited from AptifyControlBase)
m_oFormTemplateContext (inherited from AptifyControlBase)
m_oUserCredential (inherited from AptifyControlBase)
mContext

See Also

AptifyLinkLabel Class | Aptify.Applications.Advertising Namespace


AptifyLinkLabel.mContext Field

protected mContext mContext;

See Also

AptifyLinkLabel Class | Aptify.Applications.Advertising Namespace


AptifyLinkLabel Properties

The properties of the AptifyLinkLabel class are listed below. For a complete list of AptifyLinkLabel class members, see the AptifyLinkLabel Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Control (inherited from AptifyControlBase) |
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DataControl (inherited from AptifyControlBase) | Adds a reference to the object for the data control. In the case of it being added, the reference to the bound control base object is added to the data controls collection.
DisableGeDataTransfer (inherited from AptifyControlBase) | If true, the implementer is required to move the value to/from the bound control to the GE or other data access method.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
FieldHelp (inherited from AptifyControlBase) |
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateContext (inherited from AptifyControlBase) | Returns the reference that if is local that is returned else if a DataControl exists, it is returned.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpObject (inherited from AptifyControlBase) | This method is responsible for returning the context-specific help Object file location in the Aptify Object repository. The base class implementation returns the entity-level help, if available, and if not, returns the DefaultHelpObject
HelpURL (inherited from AptifyControlBase) | This method is responsible for returning the context-specific help URL file location within the HelpObject to use. The base class implementation returns the entity-level help URL, if available, and if not, returns Nothing, which results in the content page being displayed.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
LinkLabelText |
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
ObjectRepository (inherited from AptifyControlBase) |
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AptifyApplication (inherited from AptifyControlBase) | Returns an instance of the Aptify Application Object
AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
CurrencyTypeCache (inherited from AptifyControlBase) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DisplayName (inherited from AptifyControlBase) |
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HelpText (inherited from AptifyControlBase) |
HelpTitle (inherited from AptifyControlBase) | This property is designed to be overriden by subclasses that want to provide a different title. The base class returns "Aptify Help" for this property.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
InternalControl (inherited from AptifyControlBase) | Specifies the Main Control of interest in a composite control.
m_oInternalControl (inherited from AptifyControlBase) |
MyApplication (inherited from AptifyControlBase) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowDisplayHelpHyperlink (inherited from AptifyControlBase) | This property can be overriden by sub-classes to be able to selectively turn on or off the Display Help hyperlink that appears by default on the FieldHelp object.
UserCredential (inherited from AptifyControlBase) |
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

AptifyLinkLabel Class | Aptify.Applications.Advertising Namespace


LinkLabelText Property

Aptify 5.0 Software Development Kit (SDK)

AptifyLinkLabel.LinkLabelText Property

public String LinkLabelText {get; set;}

See Also

AptifyLinkLabel Class | Aptify.Applications.Advertising Namespace


AptifyLinkLabel Methods

The methods of the AptifyLinkLabel class are listed below. For a complete list of AptifyLinkLabel class members, see the AptifyLinkLabel Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BoundControlConfig (inherited from AptifyControlBase) | Called by the data control to handle security,enable/disable settings, and set the label from data, if necessary. This is implemented by the sub class.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ClearData (inherited from AptifyControlBase) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DisplayControlHelp (inherited from AptifyControlBase) | This method will display control-level help information. This method will use the HelpTitle and HelpText overridable members to display the Field Help object from Aptify.Framework.WindowsControls.FieldHelp. If the title and text is desired to be overriden it is not necessary to override this method, rather override the HelpTitle and HelpText properties which are used by this method.
DisplayEntityHelp (inherited from AptifyControlBase) | This method is responsible for displaying the help file to the user and will attempt to provide context sensitive help based on the particular entity being displayed. If no entity-specific help file is available for the user then the standard Aptify Shell.Aptify Help file will be used to display help to the user. Override this method in sub-classes to change the method for displaying help.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetDefaultHelpObject (inherited from AptifyControlBase) | This method returns the default help object file in the Aptify Object repository to be used in the event that no entity-specific file exists
GetEntitySpecificHelpObject (inherited from AptifyControlBase) | This method returns the Aptify Object Repository Object location for the help file that is specific to this entity.
GetEntitySpecificHelpTopicURL (inherited from AptifyControlBase) | This method returns the Topic URL location within the help file that is specific to this entity.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseValueChanged (inherited from AptifyControlBase) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from AptifyControlBase) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetUserCredential (inherited from AptifyControlBase) |
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
TransferDataToObject (inherited from AptifyControlBase) | Implemented by the sub class to transfer data from the control to the Generic Entity (GE) or some other data access tool.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
ConfigHelp (inherited from AptifyControlBase) | This method configures the base FieldHelp object and sets up a default string in the HelpText field. Sub-Classes should override this to implement specific help relevant to their context of use.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
DoFormComponentConfig |
Finalize (inherited from AptifyControlBase) |
FormComponentConfig (inherited from AptifyControlBase) |
FormComponentHide (inherited from AptifyControlBase) |
FormComponentShow (inherited from AptifyControlBase) | Overloaded.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RequiredGECheck (inherited from AptifyControlBase) |
RequiredPropertiesCheck (inherited from AptifyControlBase) |
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

AptifyLinkLabel Class | Aptify.Applications.Advertising Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

AptifyLinkLabel.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

AptifyLinkLabel Class | Aptify.Applications.Advertising Namespace


AptifyLinkLabel.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

AptifyLinkLabel Class | Aptify.Applications.Advertising Namespace | AptifyLinkLabel.Dispose Overload List


AptifyLinkLabel.DoFormComponentConfig Method

protected override void DoFormComponentConfig(
AptifyFormTemplateContext FormTemplateContext
);

See Also

AptifyLinkLabel Class | Aptify.Applications.Advertising Namespace


AptifyLinkLabel Events

The events of the AptifyLinkLabel class are listed below. For a complete list of AptifyLinkLabel class members, see the AptifyLinkLabel Members topic.

Public Instance Events

AfterDisplayEntityHelp (inherited from AptifyControlBase) | This event is fired after the help file is displayed.
AptifyControlBaseTextChanged (inherited from AptifyControlBase) |
AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BeforeDisplayEntityHelp (inherited from AptifyControlBase) | This event is fired before the help file is displayed. To prevent help from being displayed set the Cancel parameter to True.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click |
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from AptifyControlBase) |
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from AptifyControlBase) |
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from AptifyControlBase) |
KeyPress (inherited from AptifyControlBase) |
KeyUp (inherited from AptifyControlBase) |
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from AptifyControlBase) |
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from AptifyControlBase) |
MouseEnter (inherited from AptifyControlBase) |
MouseHover (inherited from AptifyControlBase) |
MouseLeave (inherited from AptifyControlBase) |
MouseMove (inherited from AptifyControlBase) |
MouseUp (inherited from AptifyControlBase) |
MouseWheel (inherited from AptifyControlBase) |
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from AptifyControlBase) |
Validated (inherited from AptifyControlBase) |
Validating (inherited from AptifyControlBase) |
ValueChanged (inherited from AptifyControlBase) |
VisibleChanged (inherited from AptifyControlBase) |

See Also

AptifyLinkLabel Class | Aptify.Applications.Advertising Namespace


AptifyLinkLabel.IFormComponent.ClickEventHandler Event

public event IFormComponent.ClickEventHandler Click;

Implements

IFormComponent.

See Also

AptifyLinkLabel Class | Aptify.Applications.Advertising Namespace


DefaultUnitDefinition Class

For a list of all members of this type, see DefaultUnitDefinition Members.

System.Object
DefaultUnitDefinition

public class DefaultUnitDefinition : IAdvertisingUnitDefinition

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Advertising

Assembly: AdvertisingUnitDefinition (in AdvertisingUnitDefinition.dll)

See Also

DefaultUnitDefinition Members | Aptify.Applications.Advertising Namespace


DefaultUnitDefinition Members

DefaultUnitDefinition overview

Public Instance Constructors

DefaultUnitDefinition Constructor Initializes a new instance of the DefaultUnitDefinition class.

Public Instance Properties

UserCredentials

Public Instance Methods

CalculateUnitCount |
Config | This method must be called before any other member of this class is acccessed. This method implements the Config() method of the IAdvertisingUnitDefinition interface. IAdvertisingUnitDefinition
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ParseParameters |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Fields

m_iTabLen
m_oApp
m_oInsertionOrderGE
m_oRateCardRateGE
m_oUnit

Protected Instance Methods

CalcCharUnits | Calculate Number of chars in the string The unit count will simply be the number of characters in the string minus any carriage return and line feed characters. Rules - 1)The carriage return or line feed character should be counted as a character. See Unit Definition Cases - Cases 2,3,4 2)Count {TAB} as 5 characters, unless is explicitly specified either in the Entity Def level or in the Record.
CalcLines | This method calculates the number of line in the UnitText paramter If the text contains lNumCharsInUnit consecutive characters without a line feed, the unit count will incremented by one and the consecutive counter will be reset. If the line feed position num. is less then lNumCharsInUnit,the unit count will incremented by one and the consecutive counter will be reset. If the max characters per line is set and met, and the following character is a carriage return or line feed {lf}, then the {lf} does not increase the line count.
CalcLineUnits | This method calculates the number of lines in UnitText using the definition of a word from the WordDefinition parameter.
CalcWordUnits |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetTabSpace |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DefaultUnitDefinition Class | Aptify.Applications.Advertising Namespace


DefaultUnitDefinition Constructor

Initializes a new instance of the DefaultUnitDefinition class.

public DefaultUnitDefinition();

See Also

DefaultUnitDefinition Class | Aptify.Applications.Advertising Namespace


DefaultUnitDefinition Fields

The fields of the DefaultUnitDefinition class are listed below. For a complete list of DefaultUnitDefinition class members, see the DefaultUnitDefinition Members topic.

Protected Instance Fields

m_iTabLen
m_oApp
m_oInsertionOrderGE
m_oRateCardRateGE
m_oUnit

See Also

DefaultUnitDefinition Class | Aptify.Applications.Advertising Namespace


DefaultUnitDefinition.m_iTabLen Field

protected m_iTabLen m_iTabLen;

See Also

DefaultUnitDefinition Class | Aptify.Applications.Advertising Namespace


DefaultUnitDefinition.m_oApp Field

protected m_oApp m_oApp;

See Also

DefaultUnitDefinition Class | Aptify.Applications.Advertising Namespace


DefaultUnitDefinition.m_oInsertionOrderGE Field

protected m_oInsertionOrderGE m_oInsertionOrderGE;

See Also

DefaultUnitDefinition Class | Aptify.Applications.Advertising Namespace


DefaultUnitDefinition.m_oRateCardRateGE Field

protected m_oRateCardRateGE m_oRateCardRateGE;

See Also

DefaultUnitDefinition Class | Aptify.Applications.Advertising Namespace


DefaultUnitDefinition.m_oUnit Field

protected m_oUnit m_oUnit;

See Also

DefaultUnitDefinition Class | Aptify.Applications.Advertising Namespace


DefaultUnitDefinition Properties

The properties of the DefaultUnitDefinition class are listed below. For a complete list of DefaultUnitDefinition class members, see the DefaultUnitDefinition Members topic.

Public Instance Properties

UserCredentials

See Also

DefaultUnitDefinition Class | Aptify.Applications.Advertising Namespace


UserCredentials Property

Aptify 5.0 Software Development Kit (SDK)

DefaultUnitDefinition.UserCredentials Property

public UserCredentials UserCredentials {get; set;}

See Also

DefaultUnitDefinition Class | Aptify.Applications.Advertising Namespace


DefaultUnitDefinition Methods

The methods of the DefaultUnitDefinition class are listed below. For a complete list of DefaultUnitDefinition class members, see the DefaultUnitDefinition Members topic.

Public Instance Methods

CalculateUnitCount |
Config | This method must be called before any other member of this class is acccessed. This method implements the Config() method of the IAdvertisingUnitDefinition interface. IAdvertisingUnitDefinition
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ParseParameters |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CalcCharUnits | Calculate Number of chars in the string The unit count will simply be the number of characters in the string minus any carriage return and line feed characters. Rules - 1)The carriage return or line feed character should be counted as a character. See Unit Definition Cases - Cases 2,3,4 2)Count {TAB} as 5 characters, unless is explicitly specified either in the Entity Def level or in the Record.
CalcLines | This method calculates the number of line in the UnitText paramter If the text contains lNumCharsInUnit consecutive characters without a line feed, the unit count will incremented by one and the consecutive counter will be reset. If the line feed position num. is less then lNumCharsInUnit,the unit count will incremented by one and the consecutive counter will be reset. If the max characters per line is set and met, and the following character is a carriage return or line feed {lf}, then the {lf} does not increase the line count.
CalcLineUnits | This method calculates the number of lines in UnitText using the definition of a word from the WordDefinition parameter.
CalcWordUnits |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetTabSpace |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DefaultUnitDefinition Class | Aptify.Applications.Advertising Namespace


DefaultUnitDefinition.CalcCharUnits Method

Calculate Number of chars in the string The unit count will simply be the number of characters in the string minus any carriage return and line feed characters. Rules - 1)The carriage return or line feed character should be counted as a character. See Unit Definition Cases - Cases 2,3,4 2)Count {TAB} as 5 characters, unless is explicitly specified either in the Entity Def level or in the Record.

protected virtual double CalcCharUnits(
String UnitText,
String TypeDefinition
);

Parameters

UnitText
TypeDefinition

Return Value

Remarks

See Also

DefaultUnitDefinition Class | Aptify.Applications.Advertising Namespace


DefaultUnitDefinition.CalcLines Method

This method calculates the number of line in the UnitText paramter If the text contains lNumCharsInUnit consecutive characters without a line feed, the unit count will incremented by one and the consecutive counter will be reset. If the line feed position num. is less then lNumCharsInUnit,the unit count will incremented by one and the consecutive counter will be reset. If the max characters per line is set and met, and the following character is a carriage return or line feed {lf}, then the {lf} does not increase the line count.

protected virtual double CalcLines(
String UnitText,
Int64 NumCharsInUnit,
Boolean RoundUp
);

Parameters

UnitText
NumCharsInUnit
RoundUp

Return Value

Remarks

See Also

DefaultUnitDefinition Class | Aptify.Applications.Advertising Namespace


DefaultUnitDefinition.CalcLineUnits Method

This method calculates the number of lines in UnitText using the definition of a word from the WordDefinition parameter.

protected virtual double CalcLineUnits(
String UnitText,
String WordDefinition
);

Parameters

UnitText
WordDefinition

Return Value

Remarks

See Also

DefaultUnitDefinition Class | Aptify.Applications.Advertising Namespace


DefaultUnitDefinition.CalculateUnitCount Method

public double CalculateUnitCount(
String UnitText,
String Type,
String Parameter
);

Implements

IAdvertisingUnitDefinition.

See Also

DefaultUnitDefinition Class | Aptify.Applications.Advertising Namespace


DefaultUnitDefinition.CalcWordUnits Method

protected virtual double CalcWordUnits(
String UnitText,
String WordDefinition
);

See Also

DefaultUnitDefinition Class | Aptify.Applications.Advertising Namespace


DefaultUnitDefinition.Config Method

This method must be called before any other member of this class is acccessed. This method implements the Config() method of the IAdvertisingUnitDefinition interface. IAdvertisingUnitDefinition

public void Config(
ref AptifyGenericEntityBase& RateCardRateGE,
ref AptifyGenericEntityBase& InsertionOrderGE
);

Parameters

RateCardRateGE
InsertionOrderGE

Implements

IAdvertisingUnitDefinition.

Remarks

See Also

DefaultUnitDefinition Class | Aptify.Applications.Advertising Namespace


DefaultUnitDefinition.GetTabSpace Method

protected string GetTabSpace(
String RepeatChar,
Int64 RepeatNumber
);

See Also

DefaultUnitDefinition Class | Aptify.Applications.Advertising Namespace


DefaultUnitDefinition.ParseParameters Method

public bool ParseParameters(
String Type,
String TypeDefinition,
ref String& Separators,
ref Int64& NumChars,
ref String& Roud,
ref Int64& TabLength,
ref String& ErrorString,
ref Object& Arg
);

Implements

IAdvertisingUnitDefinition.

See Also

DefaultUnitDefinition Class | Aptify.Applications.Advertising Namespace


IAdvertisingInsertionOrderPricing Interface

For a list of all members of this type, see IAdvertisingInsertionOrderPricing Members.

public interface IAdvertisingInsertionOrderPricing

Types that implement IAdvertisingInsertionOrderPricing

Type | Description
AdvertisingInsertionOrderPricing | This class provides the default implementation for pricing for Insertion Orders in the Aptify Advertising Management system. This class can be sub-classed if it is necessary to override functionality in the base implementation for insertion order pricing. Alternatively, it is also possible to create a completely separate class that implements IAdvertisingInsertionOrderPricing and plug in that class as well. In either case, sub-classes or separate implementations of the interface must be plugged into the Advertising Insertion Orders entity using the Entity Attributes shown below (All of the below are attributes of the Advertising Insertion Orders entity)

Requirements

Namespace: Aptify.Applications.Advertising

Assembly: AdvertisingInsertionOrderPricing (in AdvertisingInsertionOrderPricing.dll)

See Also

IAdvertisingInsertionOrderPricing Members | Aptify.Applications.Advertising Namespace


IAdvertisingInsertionOrderPricing Members

IAdvertisingInsertionOrderPricing overview

Public Instance Methods

Config
GenerateInsertionOrderDetails

See Also

IAdvertisingInsertionOrderPricing Interface | Aptify.Applications.Advertising Namespace


IAdvertisingInsertionOrderPricing Methods

The methods of the IAdvertisingInsertionOrderPricing interface are listed below. For a complete list of IAdvertisingInsertionOrderPricing interface members, see the IAdvertisingInsertionOrderPricing Members topic.

Public Instance Methods

Config
GenerateInsertionOrderDetails

See Also

IAdvertisingInsertionOrderPricing Interface | Aptify.Applications.Advertising Namespace


IAdvertisingInsertionOrderPricing.Config Method

void Config(
AptifyApplication Application
);

See Also

IAdvertisingInsertionOrderPricing Interface | Aptify.Applications.Advertising Namespace


IAdvertisingInsertionOrderPricing.GenerateInsertionOrderDetails Method

bool GenerateInsertionOrderDetails(
AptifyGenericEntityBase InsertionOrderGE
);

See Also

IAdvertisingInsertionOrderPricing Interface | Aptify.Applications.Advertising Namespace


IAdvertisingUnitDefinition Interface

This interface is used to allow extensibility of Unit Definitions for the Advertising Rate Cards and Insertion Order objects. The Rate Card Rate and Advertising Insertion Order information will provide enough information to calculate the Unit Count, but override parameters can be sent in when the CalculateUnitCount is called.

For a list of all members of this type, see IAdvertisingUnitDefinition Members.

public interface IAdvertisingUnitDefinition

Types that implement IAdvertisingUnitDefinition

Type | Description
DefaultUnitDefinition |

Remarks

Requirements

Namespace: Aptify.Applications.Advertising

Assembly: AdvertisingUnitDefinition (in AdvertisingUnitDefinition.dll)

See Also

IAdvertisingUnitDefinition Members | Aptify.Applications.Advertising Namespace


IAdvertisingUnitDefinition Members

IAdvertisingUnitDefinition overview

Public Instance Methods

CalculateUnitCount
Config
ParseParameters

See Also

IAdvertisingUnitDefinition Interface | Aptify.Applications.Advertising Namespace


IAdvertisingUnitDefinition Methods

The methods of the IAdvertisingUnitDefinition interface are listed below. For a complete list of IAdvertisingUnitDefinition interface members, see the IAdvertisingUnitDefinition Members topic.

Public Instance Methods

CalculateUnitCount
Config
ParseParameters

See Also

IAdvertisingUnitDefinition Interface | Aptify.Applications.Advertising Namespace


IAdvertisingUnitDefinition.CalculateUnitCount Method

double CalculateUnitCount(
String UnitText,
String Type,
String Parameter
);

See Also

IAdvertisingUnitDefinition Interface | Aptify.Applications.Advertising Namespace


IAdvertisingUnitDefinition.Config Method

void Config(
ref AptifyGenericEntityBase& RateCardRateGE,
ref AptifyGenericEntityBase& InsertionOrderGE
);

See Also

IAdvertisingUnitDefinition Interface | Aptify.Applications.Advertising Namespace


IAdvertisingUnitDefinition.ParseParameters Method

bool ParseParameters(
String Type,
String TypeDefinition,
ref String& Separators,
ref Int64& NumChars,
ref String& Roud,
ref Int64& TabLength,
ref String& ErrorString,
ref Object& Arg
);

See Also

IAdvertisingUnitDefinition Interface | Aptify.Applications.Advertising Namespace


InsertionMultiBillToLayout Class

For a list of all members of this type, see InsertionMultiBillToLayout Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
AdvertisingLayoutBase
InsertionMultiBillToLayout

public class InsertionMultiBillToLayout : AdvertisingLayoutBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Advertising

Assembly: AdvertisingInsertionOrderControls (in AdvertisingInsertionOrderControls.dll)

See Also

InsertionMultiBillToLayout Members | Aptify.Applications.Advertising Namespace


InsertionMultiBillToLayout Members

InsertionMultiBillToLayout overview

Public Instance Constructors

InsertionMultiBillToLayout Constructor Initializes a new instance of the InsertionMultiBillToLayout class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

datEntity
dlgControlValueChanged

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
LayoutDataComboControl (inherited from AdvertisingLayoutBase) |
LayoutDataControl (inherited from AdvertisingLayoutBase) |
LayoutLinkBoxControl (inherited from AdvertisingLayoutBase) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
SubtypeControl (inherited from AdvertisingLayoutBase) |
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AddControlEventHandler (inherited from AdvertisingLayoutBase) |
AddControlEventHandlerFromFieldName (inherited from AdvertisingLayoutBase) |
AddControlEventHandlerFromSubTypeName (inherited from AdvertisingLayoutBase) |
AdjustFormScrollbars (inherited from ContainerControl) |
ConfigureControls |
ConfigureDisplay |
ControlValueChanged |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormTemplateLayout) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControlFromFieldName (inherited from AdvertisingLayoutBase) |
FindDataControl (inherited from AdvertisingLayoutBase) |
FindSubTypeControlFromName (inherited from AdvertisingLayoutBase) |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetControlFromFieldName (inherited from AdvertisingLayoutBase) |
GetControlProperty (inherited from AdvertisingLayoutBase) |
GetDataControlProperty (inherited from AdvertisingLayoutBase) |
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetSubTypeControlFromName (inherited from AdvertisingLayoutBase) |
GetTabControl (inherited from AdvertisingLayoutBase) | Overloaded.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded (inherited from FormTemplateLayout) | Raises the FormTemplateLoaded event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad |
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlProperty (inherited from AdvertisingLayoutBase) | Overloaded.
SetDataControlProperty (inherited from AdvertisingLayoutBase) | Overloaded.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

InsertionMultiBillToLayout Class | Aptify.Applications.Advertising Namespace


InsertionMultiBillToLayout Constructor

Initializes a new instance of the InsertionMultiBillToLayout class.

public InsertionMultiBillToLayout();

See Also

InsertionMultiBillToLayout Class | Aptify.Applications.Advertising Namespace


InsertionMultiBillToLayout Fields

The fields of the InsertionMultiBillToLayout class are listed below. For a complete list of InsertionMultiBillToLayout class members, see the InsertionMultiBillToLayout Members topic.

Protected Instance Fields

datEntity
dlgControlValueChanged

See Also

InsertionMultiBillToLayout Class | Aptify.Applications.Advertising Namespace


InsertionMultiBillToLayout.datEntity Field

protected datEntity datEntity;

See Also

InsertionMultiBillToLayout Class | Aptify.Applications.Advertising Namespace


InsertionMultiBillToLayout.dlgControlValueChanged Field

protected dlgControlValueChanged dlgControlValueChanged;

See Also

InsertionMultiBillToLayout Class | Aptify.Applications.Advertising Namespace


InsertionMultiBillToLayout Methods

The methods of the InsertionMultiBillToLayout class are listed below. For a complete list of InsertionMultiBillToLayout class members, see the InsertionMultiBillToLayout Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AddControlEventHandler (inherited from AdvertisingLayoutBase) |
AddControlEventHandlerFromFieldName (inherited from AdvertisingLayoutBase) |
AddControlEventHandlerFromSubTypeName (inherited from AdvertisingLayoutBase) |
AdjustFormScrollbars (inherited from ContainerControl) |
ConfigureControls |
ConfigureDisplay |
ControlValueChanged |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormTemplateLayout) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControlFromFieldName (inherited from AdvertisingLayoutBase) |
FindDataControl (inherited from AdvertisingLayoutBase) |
FindSubTypeControlFromName (inherited from AdvertisingLayoutBase) |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetControlFromFieldName (inherited from AdvertisingLayoutBase) |
GetControlProperty (inherited from AdvertisingLayoutBase) |
GetDataControlProperty (inherited from AdvertisingLayoutBase) |
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetSubTypeControlFromName (inherited from AdvertisingLayoutBase) |
GetTabControl (inherited from AdvertisingLayoutBase) | Overloaded.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded (inherited from FormTemplateLayout) | Raises the FormTemplateLoaded event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad |
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlProperty (inherited from AdvertisingLayoutBase) | Overloaded.
SetDataControlProperty (inherited from AdvertisingLayoutBase) | Overloaded.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

InsertionMultiBillToLayout Class | Aptify.Applications.Advertising Namespace


InsertionMultiBillToLayout.ConfigureControls Method

protected virtual void ConfigureControls();

See Also

InsertionMultiBillToLayout Class | Aptify.Applications.Advertising Namespace


InsertionMultiBillToLayout.ConfigureDisplay Method

protected virtual void ConfigureDisplay();

See Also

InsertionMultiBillToLayout Class | Aptify.Applications.Advertising Namespace


InsertionMultiBillToLayout.ControlValueChanged Method

protected virtual void ControlValueChanged(
Object sender,
Object OldValue,
Object NewValue
);

See Also

InsertionMultiBillToLayout Class | Aptify.Applications.Advertising Namespace


InsertionMultiBillToLayout.OnLoad Method

protected override void OnLoad(
EventArgs e
);

See Also

InsertionMultiBillToLayout Class | Aptify.Applications.Advertising Namespace


InsertionMultiBillToLayout.OnRefresh Method

protected override void OnRefresh();

Implements

IFormComponent.

See Also

InsertionMultiBillToLayout Class | Aptify.Applications.Advertising Namespace


InsertionOrderAdjHistoryLayout Class

For a list of all members of this type, see InsertionOrderAdjHistoryLayout Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
AdvertisingLayoutBase
InsertionOrderAdjHistoryLayout

public class InsertionOrderAdjHistoryLayout : AdvertisingLayoutBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Advertising

Assembly: AdvertisingInsertionOrderControls (in AdvertisingInsertionOrderControls.dll)

See Also

InsertionOrderAdjHistoryLayout Members | Aptify.Applications.Advertising Namespace


InsertionOrderAdjHistoryLayout Members

InsertionOrderAdjHistoryLayout overview

Public Instance Constructors

InsertionOrderAdjHistoryLayout Constructor Initializes a new instance of the InsertionOrderAdjHistoryLayout class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
LayoutDataComboControl (inherited from AdvertisingLayoutBase) |
LayoutDataControl (inherited from AdvertisingLayoutBase) |
LayoutLinkBoxControl (inherited from AdvertisingLayoutBase) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
SubtypeControl (inherited from AdvertisingLayoutBase) |
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AddControlEventHandler (inherited from AdvertisingLayoutBase) |
AddControlEventHandlerFromFieldName (inherited from AdvertisingLayoutBase) |
AddControlEventHandlerFromSubTypeName (inherited from AdvertisingLayoutBase) |
AdjustFormScrollbars (inherited from ContainerControl) |
ConfigureDisplay |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormTemplateLayout) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControlFromFieldName (inherited from AdvertisingLayoutBase) |
FindDataControl (inherited from AdvertisingLayoutBase) |
FindSubTypeControlFromName (inherited from AdvertisingLayoutBase) |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetControlFromFieldName (inherited from AdvertisingLayoutBase) |
GetControlProperty (inherited from AdvertisingLayoutBase) |
GetDataControlProperty (inherited from AdvertisingLayoutBase) |
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetSubTypeControlFromName (inherited from AdvertisingLayoutBase) |
GetTabControl (inherited from AdvertisingLayoutBase) | Overloaded.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded (inherited from FormTemplateLayout) | Raises the FormTemplateLoaded event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad |
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlProperty (inherited from AdvertisingLayoutBase) | Overloaded.
SetDataControlProperty (inherited from AdvertisingLayoutBase) | Overloaded.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

InsertionOrderAdjHistoryLayout Class | Aptify.Applications.Advertising Namespace


InsertionOrderAdjHistoryLayout Constructor

Initializes a new instance of the InsertionOrderAdjHistoryLayout class.

public InsertionOrderAdjHistoryLayout();

See Also

InsertionOrderAdjHistoryLayout Class | Aptify.Applications.Advertising Namespace


InsertionOrderAdjHistoryLayout Methods

The methods of the InsertionOrderAdjHistoryLayout class are listed below. For a complete list of InsertionOrderAdjHistoryLayout class members, see the InsertionOrderAdjHistoryLayout Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AddControlEventHandler (inherited from AdvertisingLayoutBase) |
AddControlEventHandlerFromFieldName (inherited from AdvertisingLayoutBase) |
AddControlEventHandlerFromSubTypeName (inherited from AdvertisingLayoutBase) |
AdjustFormScrollbars (inherited from ContainerControl) |
ConfigureDisplay |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormTemplateLayout) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControlFromFieldName (inherited from AdvertisingLayoutBase) |
FindDataControl (inherited from AdvertisingLayoutBase) |
FindSubTypeControlFromName (inherited from AdvertisingLayoutBase) |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetControlFromFieldName (inherited from AdvertisingLayoutBase) |
GetControlProperty (inherited from AdvertisingLayoutBase) |
GetDataControlProperty (inherited from AdvertisingLayoutBase) |
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetSubTypeControlFromName (inherited from AdvertisingLayoutBase) |
GetTabControl (inherited from AdvertisingLayoutBase) | Overloaded.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded (inherited from FormTemplateLayout) | Raises the FormTemplateLoaded event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad |
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlProperty (inherited from AdvertisingLayoutBase) | Overloaded.
SetDataControlProperty (inherited from AdvertisingLayoutBase) | Overloaded.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

InsertionOrderAdjHistoryLayout Class | Aptify.Applications.Advertising Namespace


InsertionOrderAdjHistoryLayout.ConfigureDisplay Method

protected virtual void ConfigureDisplay();

See Also

InsertionOrderAdjHistoryLayout Class | Aptify.Applications.Advertising Namespace


InsertionOrderAdjHistoryLayout.OnLoad Method

protected override void OnLoad(
EventArgs e
);

See Also

InsertionOrderAdjHistoryLayout Class | Aptify.Applications.Advertising Namespace


InsertionOrderAdjHistoryLayout.OnRefresh Method

protected override void OnRefresh();

Implements

IFormComponent.

See Also

InsertionOrderAdjHistoryLayout Class | Aptify.Applications.Advertising Namespace


InsertionOrderBillToSelector Class

For a list of all members of this type, see InsertionOrderBillToSelector Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
InsertionOrderBillToSelector

public class InsertionOrderBillToSelector : Form

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Advertising

Assembly: AdvertisingInsertionOrderControls (in AdvertisingInsertionOrderControls.dll)

See Also

InsertionOrderBillToSelector Members | Aptify.Applications.Advertising Namespace


InsertionOrderBillToSelector Members

InsertionOrderBillToSelector overview

Public Instance Constructors

InsertionOrderBillToSelector Constructor Initializes a new instance of the InsertionOrderBillToSelector class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
Initialize |
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

m_oUserCredentials
mDAL
moApp

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

InsertionOrderBillToSelector Class | Aptify.Applications.Advertising Namespace


InsertionOrderBillToSelector Constructor

Initializes a new instance of the InsertionOrderBillToSelector class.

public InsertionOrderBillToSelector();

See Also

InsertionOrderBillToSelector Class | Aptify.Applications.Advertising Namespace


InsertionOrderBillToSelector Fields

The fields of the InsertionOrderBillToSelector class are listed below. For a complete list of InsertionOrderBillToSelector class members, see the InsertionOrderBillToSelector Members topic.

Protected Instance Fields

m_oUserCredentials
mDAL
moApp

See Also

InsertionOrderBillToSelector Class | Aptify.Applications.Advertising Namespace


InsertionOrderBillToSelector.m_oUserCredentials Field

protected m_oUserCredentials m_oUserCredentials;

See Also

InsertionOrderBillToSelector Class | Aptify.Applications.Advertising Namespace


InsertionOrderBillToSelector.mDAL Field

protected mDAL mDAL;

See Also

InsertionOrderBillToSelector Class | Aptify.Applications.Advertising Namespace


InsertionOrderBillToSelector.moApp Field

protected moApp moApp;

See Also

InsertionOrderBillToSelector Class | Aptify.Applications.Advertising Namespace


InsertionOrderBillToSelector Methods

The methods of the InsertionOrderBillToSelector class are listed below. For a complete list of InsertionOrderBillToSelector class members, see the InsertionOrderBillToSelector Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
Initialize |
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

InsertionOrderBillToSelector Class | Aptify.Applications.Advertising Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

InsertionOrderBillToSelector.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

InsertionOrderBillToSelector Class | Aptify.Applications.Advertising Namespace


InsertionOrderBillToSelector.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

InsertionOrderBillToSelector Class | Aptify.Applications.Advertising Namespace | InsertionOrderBillToSelector.Dispose Overload List


InsertionOrderBillToSelector.Initialize Method

public void Initialize(
AptifyGenericEntity oIO,
AptifyApplication ApplicationObject
);

See Also

InsertionOrderBillToSelector Class | Aptify.Applications.Advertising Namespace


InsertionOrderDetailLayout Class

For a list of all members of this type, see InsertionOrderDetailLayout Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
AdvertisingLayoutBase
InsertionOrderDetailLayout

public class InsertionOrderDetailLayout : AdvertisingLayoutBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Advertising

Assembly: AdvertisingInsertionOrderControls (in AdvertisingInsertionOrderControls.dll)

See Also

InsertionOrderDetailLayout Members | Aptify.Applications.Advertising Namespace


InsertionOrderDetailLayout Members

InsertionOrderDetailLayout overview

Public Instance Constructors

InsertionOrderDetailLayout Constructor Initializes a new instance of the InsertionOrderDetailLayout class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

dlgControlLostFocus

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
datEntity |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
LayoutDataComboControl (inherited from AdvertisingLayoutBase) |
LayoutDataControl (inherited from AdvertisingLayoutBase) |
LayoutLinkBoxControl (inherited from AdvertisingLayoutBase) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
SubtypeControl (inherited from AdvertisingLayoutBase) |
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AddControlEventHandler (inherited from AdvertisingLayoutBase) |
AddControlEventHandlerFromFieldName (inherited from AdvertisingLayoutBase) |
AddControlEventHandlerFromSubTypeName (inherited from AdvertisingLayoutBase) |
AdjustFormScrollbars (inherited from ContainerControl) |
ConfigureControls |
ConfigureDisplay |
ControlLostFocus |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormTemplateLayout) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControlFromFieldName (inherited from AdvertisingLayoutBase) |
FindDataControl (inherited from AdvertisingLayoutBase) |
FindSubTypeControlFromName (inherited from AdvertisingLayoutBase) |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetControlFromFieldName (inherited from AdvertisingLayoutBase) |
GetControlProperty (inherited from AdvertisingLayoutBase) |
GetDataControlProperty (inherited from AdvertisingLayoutBase) |
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetSubTypeControlFromName (inherited from AdvertisingLayoutBase) |
GetTabControl (inherited from AdvertisingLayoutBase) | Overloaded.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded (inherited from FormTemplateLayout) | Raises the FormTemplateLoaded event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad |
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlProperty (inherited from AdvertisingLayoutBase) | Overloaded.
SetDataControlProperty (inherited from AdvertisingLayoutBase) | Overloaded.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

InsertionOrderDetailLayout Class | Aptify.Applications.Advertising Namespace


InsertionOrderDetailLayout Constructor

Initializes a new instance of the InsertionOrderDetailLayout class.

public InsertionOrderDetailLayout();

See Also

InsertionOrderDetailLayout Class | Aptify.Applications.Advertising Namespace


InsertionOrderDetailLayout Fields

The fields of the InsertionOrderDetailLayout class are listed below. For a complete list of InsertionOrderDetailLayout class members, see the InsertionOrderDetailLayout Members topic.

Protected Instance Fields

dlgControlLostFocus

See Also

InsertionOrderDetailLayout Class | Aptify.Applications.Advertising Namespace


InsertionOrderDetailLayout.dlgControlLostFocus Field

protected dlgControlLostFocus dlgControlLostFocus;

See Also

InsertionOrderDetailLayout Class | Aptify.Applications.Advertising Namespace


InsertionOrderDetailLayout Properties

The properties of the InsertionOrderDetailLayout class are listed below. For a complete list of InsertionOrderDetailLayout class members, see the InsertionOrderDetailLayout Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
datEntity |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
LayoutDataComboControl (inherited from AdvertisingLayoutBase) |
LayoutDataControl (inherited from AdvertisingLayoutBase) |
LayoutLinkBoxControl (inherited from AdvertisingLayoutBase) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
SubtypeControl (inherited from AdvertisingLayoutBase) |
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

InsertionOrderDetailLayout Class | Aptify.Applications.Advertising Namespace


datEntity Property

Aptify 5.0 Software Development Kit (SDK)

InsertionOrderDetailLayout.datEntity Property

protected virtual AptifyDataControl datEntity {get; set;}

See Also

InsertionOrderDetailLayout Class | Aptify.Applications.Advertising Namespace


InsertionOrderDetailLayout Methods

The methods of the InsertionOrderDetailLayout class are listed below. For a complete list of InsertionOrderDetailLayout class members, see the InsertionOrderDetailLayout Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AddControlEventHandler (inherited from AdvertisingLayoutBase) |
AddControlEventHandlerFromFieldName (inherited from AdvertisingLayoutBase) |
AddControlEventHandlerFromSubTypeName (inherited from AdvertisingLayoutBase) |
AdjustFormScrollbars (inherited from ContainerControl) |
ConfigureControls |
ConfigureDisplay |
ControlLostFocus |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormTemplateLayout) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControlFromFieldName (inherited from AdvertisingLayoutBase) |
FindDataControl (inherited from AdvertisingLayoutBase) |
FindSubTypeControlFromName (inherited from AdvertisingLayoutBase) |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetControlFromFieldName (inherited from AdvertisingLayoutBase) |
GetControlProperty (inherited from AdvertisingLayoutBase) |
GetDataControlProperty (inherited from AdvertisingLayoutBase) |
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetSubTypeControlFromName (inherited from AdvertisingLayoutBase) |
GetTabControl (inherited from AdvertisingLayoutBase) | Overloaded.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded (inherited from FormTemplateLayout) | Raises the FormTemplateLoaded event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad |
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlProperty (inherited from AdvertisingLayoutBase) | Overloaded.
SetDataControlProperty (inherited from AdvertisingLayoutBase) | Overloaded.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

InsertionOrderDetailLayout Class | Aptify.Applications.Advertising Namespace


InsertionOrderDetailLayout.ConfigureControls Method

protected virtual void ConfigureControls();

See Also

InsertionOrderDetailLayout Class | Aptify.Applications.Advertising Namespace


InsertionOrderDetailLayout.ConfigureDisplay Method

protected virtual void ConfigureDisplay();

See Also

InsertionOrderDetailLayout Class | Aptify.Applications.Advertising Namespace


InsertionOrderDetailLayout.ControlLostFocus Method

protected void ControlLostFocus(
Object sender,
EventArgs e
);

See Also

InsertionOrderDetailLayout Class | Aptify.Applications.Advertising Namespace


InsertionOrderDetailLayout.OnLoad Method

protected override void OnLoad(
EventArgs e
);

See Also

InsertionOrderDetailLayout Class | Aptify.Applications.Advertising Namespace


InsertionOrderDetailLayout.OnRefresh Method

protected override void OnRefresh();

Implements

IFormComponent.

See Also

InsertionOrderDetailLayout Class | Aptify.Applications.Advertising Namespace


InsertionOrderLayout Class

The InsertionOrderLayout control is responsible for performing user interface logic on the Insertion Order form templates. This layout control is designed to reside on the top level Insertion Order form template.

For a list of all members of this type, see InsertionOrderLayout Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
AdvertisingLayoutBase
InsertionOrderLayout

public class InsertionOrderLayout : AdvertisingLayoutBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Advertising

Assembly: AdvertisingInsertionOrderControls (in AdvertisingInsertionOrderControls.dll)

See Also

InsertionOrderLayout Members | Aptify.Applications.Advertising Namespace


InsertionOrderLayout Members

InsertionOrderLayout overview

Public Instance Constructors

InsertionOrderLayout Constructor Initializes a new instance of the InsertionOrderLayout class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetEmployee |
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

dlgClickEvent
dlgControlLostFocus
dlgKeyDown
dlgKeyPress
dlgMouseMove
dlgValueChanged
msCurrencyFormat

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
datEntity |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
LayoutDataComboControl (inherited from AdvertisingLayoutBase) |
LayoutDataControl (inherited from AdvertisingLayoutBase) |
LayoutLinkBoxControl (inherited from AdvertisingLayoutBase) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
subAdjHistory |
subMultipleBillTo |
subSalesReps |
SubtypeControl (inherited from AdvertisingLayoutBase) |
tabMain |
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AddControlEventHandler (inherited from AdvertisingLayoutBase) |
AddControlEventHandlerFromFieldName (inherited from AdvertisingLayoutBase) |
AddControlEventHandlerFromSubTypeName (inherited from AdvertisingLayoutBase) |
AdjustFormScrollbars (inherited from ContainerControl) |
ConfigureControls |
ConfigureDisplay |
ControlClicked |
ControlKeyDown |
ControlKeyPress |
ControlLostFocus |
ControlMouseMove |
ControlValueChanged |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormTemplateLayout) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControlFromFieldName (inherited from AdvertisingLayoutBase) |
FindDataControl (inherited from AdvertisingLayoutBase) |
FindSubTypeControlFromName (inherited from AdvertisingLayoutBase) |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetControlFromFieldName (inherited from AdvertisingLayoutBase) |
GetControlProperty (inherited from AdvertisingLayoutBase) |
GetCurrencyFormat |
GetDataControlProperty (inherited from AdvertisingLayoutBase) |
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetSubTypeControlFromName (inherited from AdvertisingLayoutBase) |
GetTabControl (inherited from AdvertisingLayoutBase) | Overloaded.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from AdvertisingLayoutBase) |
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged |
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlProperty (inherited from AdvertisingLayoutBase) | Overloaded.
SetDataControlProperty (inherited from AdvertisingLayoutBase) | Overloaded.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

InsertionOrderLayout Class | Aptify.Applications.Advertising Namespace


InsertionOrderLayout Constructor

Initializes a new instance of the InsertionOrderLayout class.

public InsertionOrderLayout();

See Also

InsertionOrderLayout Class | Aptify.Applications.Advertising Namespace


InsertionOrderLayout Fields

The fields of the InsertionOrderLayout class are listed below. For a complete list of InsertionOrderLayout class members, see the InsertionOrderLayout Members topic.

Protected Instance Fields

dlgClickEvent
dlgControlLostFocus
dlgKeyDown
dlgKeyPress
dlgMouseMove
dlgValueChanged
msCurrencyFormat

See Also

InsertionOrderLayout Class | Aptify.Applications.Advertising Namespace


InsertionOrderLayout.dlgClickEvent Field

protected dlgClickEvent dlgClickEvent;

See Also

InsertionOrderLayout Class | Aptify.Applications.Advertising Namespace


InsertionOrderLayout.dlgControlLostFocus Field

protected dlgControlLostFocus dlgControlLostFocus;

See Also

InsertionOrderLayout Class | Aptify.Applications.Advertising Namespace


InsertionOrderLayout.dlgKeyDown Field

protected dlgKeyDown dlgKeyDown;

See Also

InsertionOrderLayout Class | Aptify.Applications.Advertising Namespace


InsertionOrderLayout.dlgKeyPress Field

protected dlgKeyPress dlgKeyPress;

See Also

InsertionOrderLayout Class | Aptify.Applications.Advertising Namespace


InsertionOrderLayout.dlgMouseMove Field

protected dlgMouseMove dlgMouseMove;

See Also

InsertionOrderLayout Class | Aptify.Applications.Advertising Namespace


InsertionOrderLayout.dlgValueChanged Field

protected dlgValueChanged dlgValueChanged;

See Also

InsertionOrderLayout Class | Aptify.Applications.Advertising Namespace


InsertionOrderLayout.msCurrencyFormat Field

protected msCurrencyFormat msCurrencyFormat;

See Also

InsertionOrderLayout Class | Aptify.Applications.Advertising Namespace


InsertionOrderLayout Properties

The properties of the InsertionOrderLayout class are listed below. For a complete list of InsertionOrderLayout class members, see the InsertionOrderLayout Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
datEntity |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
LayoutDataComboControl (inherited from AdvertisingLayoutBase) |
LayoutDataControl (inherited from AdvertisingLayoutBase) |
LayoutLinkBoxControl (inherited from AdvertisingLayoutBase) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
subAdjHistory |
subMultipleBillTo |
subSalesReps |
SubtypeControl (inherited from AdvertisingLayoutBase) |
tabMain |
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

InsertionOrderLayout Class | Aptify.Applications.Advertising Namespace


datEntity Property

Aptify 5.0 Software Development Kit (SDK)

InsertionOrderLayout.datEntity Property

protected virtual AptifyDataControl datEntity {get; set;}

See Also

InsertionOrderLayout Class | Aptify.Applications.Advertising Namespace


subAdjHistory Property

Aptify 5.0 Software Development Kit (SDK)

InsertionOrderLayout.subAdjHistory Property

protected virtual AptifySubType subAdjHistory {get; set;}

See Also

InsertionOrderLayout Class | Aptify.Applications.Advertising Namespace


subMultipleBillTo Property

Aptify 5.0 Software Development Kit (SDK)

InsertionOrderLayout.subMultipleBillTo Property

protected virtual AptifySubType subMultipleBillTo {get; set;}

See Also

InsertionOrderLayout Class | Aptify.Applications.Advertising Namespace


subSalesReps Property

Aptify 5.0 Software Development Kit (SDK)

InsertionOrderLayout.subSalesReps Property

protected virtual AptifySubType subSalesReps {get; set;}

See Also

InsertionOrderLayout Class | Aptify.Applications.Advertising Namespace


tabMain Property

Aptify 5.0 Software Development Kit (SDK)

InsertionOrderLayout.tabMain Property

protected virtual UltraTabControl tabMain {get; set;}

See Also

InsertionOrderLayout Class | Aptify.Applications.Advertising Namespace


InsertionOrderLayout Methods

The methods of the InsertionOrderLayout class are listed below. For a complete list of InsertionOrderLayout class members, see the InsertionOrderLayout Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetEmployee |
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AddControlEventHandler (inherited from AdvertisingLayoutBase) |
AddControlEventHandlerFromFieldName (inherited from AdvertisingLayoutBase) |
AddControlEventHandlerFromSubTypeName (inherited from AdvertisingLayoutBase) |
AdjustFormScrollbars (inherited from ContainerControl) |
ConfigureControls |
ConfigureDisplay |
ControlClicked |
ControlKeyDown |
ControlKeyPress |
ControlLostFocus |
ControlMouseMove |
ControlValueChanged |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormTemplateLayout) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControlFromFieldName (inherited from AdvertisingLayoutBase) |
FindDataControl (inherited from AdvertisingLayoutBase) |
FindSubTypeControlFromName (inherited from AdvertisingLayoutBase) |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetControlFromFieldName (inherited from AdvertisingLayoutBase) |
GetControlProperty (inherited from AdvertisingLayoutBase) |
GetCurrencyFormat |
GetDataControlProperty (inherited from AdvertisingLayoutBase) |
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetSubTypeControlFromName (inherited from AdvertisingLayoutBase) |
GetTabControl (inherited from AdvertisingLayoutBase) | Overloaded.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from AdvertisingLayoutBase) |
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged |
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlProperty (inherited from AdvertisingLayoutBase) | Overloaded.
SetDataControlProperty (inherited from AdvertisingLayoutBase) | Overloaded.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

InsertionOrderLayout Class | Aptify.Applications.Advertising Namespace


InsertionOrderLayout.ConfigureControls Method

protected virtual void ConfigureControls();

See Also

InsertionOrderLayout Class | Aptify.Applications.Advertising Namespace


InsertionOrderLayout.ConfigureDisplay Method

protected virtual void ConfigureDisplay();

See Also

InsertionOrderLayout Class | Aptify.Applications.Advertising Namespace


InsertionOrderLayout.ControlClicked Method

protected virtual void ControlClicked(
Object sender,
EventArgs e
);

See Also

InsertionOrderLayout Class | Aptify.Applications.Advertising Namespace


InsertionOrderLayout.ControlKeyDown Method

protected virtual void ControlKeyDown(
Object sender,
KeyEventArgs e
);

See Also

InsertionOrderLayout Class | Aptify.Applications.Advertising Namespace


InsertionOrderLayout.ControlKeyPress Method

protected virtual void ControlKeyPress(
Object sender,
KeyPressEventArgs e
);

See Also

InsertionOrderLayout Class | Aptify.Applications.Advertising Namespace


InsertionOrderLayout.ControlLostFocus Method

protected virtual void ControlLostFocus(
Object sender,
EventArgs e
);

See Also

InsertionOrderLayout Class | Aptify.Applications.Advertising Namespace


InsertionOrderLayout.ControlMouseMove Method

protected virtual void ControlMouseMove(
Object sender,
MouseEventArgs e
);

See Also

InsertionOrderLayout Class | Aptify.Applications.Advertising Namespace


InsertionOrderLayout.ControlValueChanged Method

protected virtual void ControlValueChanged(
Object sender,
Object OldValue,
Object NewValue
);

See Also

InsertionOrderLayout Class | Aptify.Applications.Advertising Namespace


InsertionOrderLayout.GetCurrencyFormat Method

protected virtual string GetCurrencyFormat();

See Also

InsertionOrderLayout Class | Aptify.Applications.Advertising Namespace


InsertionOrderLayout.OnFormTemplateLoaded Method

protected override void OnFormTemplateLoaded(
FormTemplateLayout.FormTemplateLoadedEventArgs e
);

See Also

InsertionOrderLayout Class | Aptify.Applications.Advertising Namespace


InsertionOrderLayout.OnRefresh Method

protected override void OnRefresh();

Implements

IFormComponent.

See Also

InsertionOrderLayout Class | Aptify.Applications.Advertising Namespace


InsertionOrderLayout.OnTabIndexChanged Method

protected override void OnTabIndexChanged(
EventArgs e
);

See Also

InsertionOrderLayout Class | Aptify.Applications.Advertising Namespace


InsertionOrderLayout.SetEmployee Method

public void SetEmployee();

See Also

InsertionOrderLayout Class | Aptify.Applications.Advertising Namespace


InsertionOrderOptions Class

For a list of all members of this type, see InsertionOrderOptions Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
InsertionOrderOptions

public class InsertionOrderOptions : Form

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Advertising

Assembly: AdvertisingInsertionOrderControls (in AdvertisingInsertionOrderControls.dll)

See Also

InsertionOrderOptions Members | Aptify.Applications.Advertising Namespace


InsertionOrderOptions Members

InsertionOrderOptions overview

Public Instance Constructors

InsertionOrderOptions Constructor Initializes a new instance of the InsertionOrderOptions class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetOptionPrice |
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
NeedMoreInfo |
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RecordNeedsMoreInfo |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Setup |
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

m_oUserCredentials
mDal
moApp

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
mdtOptions |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

InsertionOrderOptions Class | Aptify.Applications.Advertising Namespace


InsertionOrderOptions Constructor

Initializes a new instance of the InsertionOrderOptions class.

public InsertionOrderOptions();

See Also

InsertionOrderOptions Class | Aptify.Applications.Advertising Namespace


InsertionOrderOptions Fields

The fields of the InsertionOrderOptions class are listed below. For a complete list of InsertionOrderOptions class members, see the InsertionOrderOptions Members topic.

Protected Instance Fields

m_oUserCredentials
mDal
moApp

See Also

InsertionOrderOptions Class | Aptify.Applications.Advertising Namespace


InsertionOrderOptions.m_oUserCredentials Field

protected m_oUserCredentials m_oUserCredentials;

See Also

InsertionOrderOptions Class | Aptify.Applications.Advertising Namespace


InsertionOrderOptions.mDal Field

protected mDal mDal;

See Also

InsertionOrderOptions Class | Aptify.Applications.Advertising Namespace


InsertionOrderOptions.moApp Field

protected moApp moApp;

See Also

InsertionOrderOptions Class | Aptify.Applications.Advertising Namespace


InsertionOrderOptions Properties

The properties of the InsertionOrderOptions class are listed below. For a complete list of InsertionOrderOptions class members, see the InsertionOrderOptions Members topic.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
mdtOptions |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

InsertionOrderOptions Class | Aptify.Applications.Advertising Namespace


mdtOptions Property

Aptify 5.0 Software Development Kit (SDK)

InsertionOrderOptions.mdtOptions Property

protected virtual OptionsDataSet.OptionsDataTable mdtOptions {get; set;}

See Also

InsertionOrderOptions Class | Aptify.Applications.Advertising Namespace


InsertionOrderOptions Methods

The methods of the InsertionOrderOptions class are listed below. For a complete list of InsertionOrderOptions class members, see the InsertionOrderOptions Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetOptionPrice |
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
NeedMoreInfo |
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RecordNeedsMoreInfo |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Setup |
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

InsertionOrderOptions Class | Aptify.Applications.Advertising Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

InsertionOrderOptions.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

InsertionOrderOptions Class | Aptify.Applications.Advertising Namespace


InsertionOrderOptions.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

InsertionOrderOptions Class | Aptify.Applications.Advertising Namespace | InsertionOrderOptions.Dispose Overload List


InsertionOrderOptions.GetOptionPrice Method

public decimal GetOptionPrice(
Boolean bShowMe
);

See Also

InsertionOrderOptions Class | Aptify.Applications.Advertising Namespace


InsertionOrderOptions.NeedMoreInfo Method

public bool NeedMoreInfo(
OptionsDataSet.OptionsRow oRow,
String sColumn,
Boolean bShowMessage
);

See Also

InsertionOrderOptions Class | Aptify.Applications.Advertising Namespace


InsertionOrderOptions.RecordNeedsMoreInfo Method

public bool RecordNeedsMoreInfo(
ref String& sColumn,
OptionsDataSet.OptionsRow oRow
);

See Also

InsertionOrderOptions Class | Aptify.Applications.Advertising Namespace


InsertionOrderOptions.Setup Method

public bool Setup(
AptifyGenericEntity oParent,
AptifySubTypeBase oSubType,
AptifyApplication ApplicationObject
);

See Also

InsertionOrderOptions Class | Aptify.Applications.Advertising Namespace


MultipleBillTo Class

Represents a strongly typed in-memory cache of data.

For a list of all members of this type, see MultipleBillTo Members.

System.Object
MarshalByValueComponent
DataSet
MultipleBillTo

public class MultipleBillTo : DataSet

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Advertising

Assembly: AdvertisingInsertionOrderControls (in AdvertisingInsertionOrderControls.dll)

See Also

MultipleBillTo Members | Aptify.Applications.Advertising Namespace


MultipleBillTo Members

MultipleBillTo overview

Public Static Methods

GetTypedDataSetSchema

Public Instance Constructors

MultipleBillTo Overloaded. Initializes a new instance of the MultipleBillTo class.

Public Instance Properties

CaseSensitive (inherited from DataSet) | Gets or sets a value indicating whether string comparisons within DataTable objects are case-sensitive.
Container (inherited from MarshalByValueComponent) | Gets the container for the component.
DataSetName (inherited from DataSet) | Gets or sets the name of the current DataSet.
DefaultViewManager (inherited from DataSet) | Gets a custom view of the data contained in the DataSet to allow filtering, searching, and navigating using a custom DataViewManager.
DesignMode (inherited from MarshalByValueComponent) | Gets a value indicating whether the component is currently in design mode.
EnforceConstraints (inherited from DataSet) | Gets or sets a value indicating whether constraint rules are followed when attempting any update operation.
ExtendedProperties (inherited from DataSet) | Gets the collection of customized user information associated with the DataSet.
HasErrors (inherited from DataSet) | Gets a value indicating whether there are errors in any of the DataTable objects within this DataSet.
IsInitialized (inherited from DataSet) | Gets a value that indicates whether the DataSet is initialized.
Locale (inherited from DataSet) | Gets or sets the locale information used to compare strings within the table.
Namespace (inherited from DataSet) | Gets or sets the namespace of the DataSet.
Prefix (inherited from DataSet) | Gets or sets an XML prefix that aliases the namespace of the DataSet.
Relations |
RemotingFormat (inherited from DataSet) | Gets or sets a SerializationFormat for the DataSet used during remoting.
SchemaSerializationMode |
Site (inherited from DataSet) | Gets or sets an ISite for the DataSet.
Tables |
vwAdvertisingInsertionOrderBillTos |

Public Instance Methods

AcceptChanges (inherited from DataSet) | Commits all the changes made to this DataSet since it was loaded or since the last time AcceptChanges was called.
BeginInit (inherited from DataSet) | Begins the initialization of a DataSet that is used on a form or used by another component. The initialization occurs at run-time.
Clear (inherited from DataSet) | Clears the DataSet of any data by removing all rows in all tables.
Clone |
Copy (inherited from DataSet) | Copies both the structure and data for this DataSet.
CreateDataReader (inherited from DataSet) | Overloaded. Returns a DataTableReader with one result set per DataTable, in the same sequence as the tables appear in the Tables collection.
Dispose (inherited from MarshalByValueComponent) | Overloaded. Releases all resources used by the MarshalByValueComponent.
EndInit (inherited from DataSet) | Ends the initialization of a DataSet that is used on a form or used by another component. The initialization occurs at run time.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetChanges (inherited from DataSet) | Overloaded. Gets a copy of the DataSet that contains all changes made to it since it was loaded or since AcceptChanges was last called.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from DataSet) | Populates a serialization information object with the data needed to serialize the DataSet.
GetService (inherited from MarshalByValueComponent) | Gets the implementer of the IServiceProvider.
GetType (inherited from Object) | Gets the Type of the current instance.
GetXml (inherited from DataSet) | Returns the XML representation of the data stored in the DataSet.
GetXmlSchema (inherited from DataSet) | Returns the XML Schema for the XML representation of the data stored in the DataSet.
HasChanges (inherited from DataSet) | Overloaded. Gets a value indicating whether the DataSet has changes, including new, deleted, or modified rows.
InferXmlSchema (inherited from DataSet) | Overloaded. Applies the XML schema from the specified XmlReader to the DataSet.
Load (inherited from DataSet) | Overloaded. Fills a DataSet with values from a data source using the supplied IDataReader, using an array of DataTable instances to supply the schema and namespace information.
Merge (inherited from DataSet) | Overloaded. Merges a specified DataSet and its schema into the current DataSet.
ReadXml (inherited from DataSet) | Overloaded. Reads XML schema and data into the DataSet using the specified XmlReader.
ReadXmlSchema (inherited from DataSet) | Overloaded. Reads the XML schema from the specified Stream into the DataSet.
RejectChanges (inherited from DataSet) | Rolls back all the changes made to the DataSet since it was created, or since the last time AcceptChanges was called.
Reset (inherited from DataSet) | Resets the DataSet to its original state. Subclasses should override Reset to restore a DataSet to its original state.
ToString (inherited from MarshalByValueComponent) | Returns a String containing the name of the Component, if any. This method should not be overridden.
WriteXml (inherited from DataSet) | Overloaded. Writes the current data for the DataSet using the specified Stream.
WriteXmlSchema (inherited from DataSet) | Overloaded. Writes the DataSet structure as an XML schema to using the specified Stream object.

Public Instance Events

Disposed (inherited from MarshalByValueComponent) | Adds an event handler to listen to the Disposed event on the component.
Initialized (inherited from DataSet) | Occurs after the DataSet is initialized.
MergeFailed (inherited from DataSet) | Occurs when a target and source DataRow have the same primary key value, and EnforceConstraints is set to true.

Protected Instance Constructors

MultipleBillTo Overloaded. Initializes a new instance of the MultipleBillTo class.

Protected Instance Properties

Events (inherited from MarshalByValueComponent) Gets the list of event handlers that are attached to this component.

Protected Instance Methods

DetermineSchemaSerializationMode (inherited from DataSet) | Overloaded. Determines the SchemaSerializationMode for a DataSet.
Dispose (inherited from MarshalByValueComponent) | Overloaded. Releases the unmanaged resources used by the MarshalByValueComponent and optionally releases the managed resources.
Finalize (inherited from MarshalByValueComponent) | [To be supplied.]
GetSchemaSerializable |
GetSerializationData (inherited from DataSet) |
InitializeDerivedDataSet |
IsBinarySerialized (inherited from DataSet) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnPropertyChanging (inherited from DataSet) | Raises the OnPropertyChanging event.
OnRemoveRelation (inherited from DataSet) | Occurs when a DataRelation object is removed from a DataTable.
ReadXmlSerializable |
ShouldSerializeRelations |
ShouldSerializeTables |

Protected Internal Instance Methods

OnRemoveTable (inherited from DataSet) | Occurs when a DataTable is removed from a DataSet.
RaisePropertyChanging (inherited from DataSet) | Sends a notification that the specified DataSet property is about to change.

See Also

MultipleBillTo Class | Aptify.Applications.Advertising Namespace


MultipleBillTo Constructor

Initializes a new instance of the MultipleBillTo class.

Overload List

Initializes a new instance of the MultipleBillTo class.

public MultipleBillTo();

protected MultipleBillTo(SerializationInfo,StreamingContext);

See Also

MultipleBillTo Class | Aptify.Applications.Advertising Namespace


MultipleBillTo Constructor ()

Initializes a new instance of the MultipleBillTo class.

public MultipleBillTo();

See Also

MultipleBillTo Class | Aptify.Applications.Advertising Namespace | MultipleBillTo Constructor Overload List


MultipleBillTo Constructor (SerializationInfo, StreamingContext)

protected MultipleBillTo(
SerializationInfo info,
StreamingContext context
);

See Also

MultipleBillTo Class | Aptify.Applications.Advertising Namespace | MultipleBillTo Constructor Overload List


MultipleBillTo Properties

The properties of the MultipleBillTo class are listed below. For a complete list of MultipleBillTo class members, see the MultipleBillTo Members topic.

Public Instance Properties

CaseSensitive (inherited from DataSet) | Gets or sets a value indicating whether string comparisons within DataTable objects are case-sensitive.
Container (inherited from MarshalByValueComponent) | Gets the container for the component.
DataSetName (inherited from DataSet) | Gets or sets the name of the current DataSet.
DefaultViewManager (inherited from DataSet) | Gets a custom view of the data contained in the DataSet to allow filtering, searching, and navigating using a custom DataViewManager.
DesignMode (inherited from MarshalByValueComponent) | Gets a value indicating whether the component is currently in design mode.
EnforceConstraints (inherited from DataSet) | Gets or sets a value indicating whether constraint rules are followed when attempting any update operation.
ExtendedProperties (inherited from DataSet) | Gets the collection of customized user information associated with the DataSet.
HasErrors (inherited from DataSet) | Gets a value indicating whether there are errors in any of the DataTable objects within this DataSet.
IsInitialized (inherited from DataSet) | Gets a value that indicates whether the DataSet is initialized.
Locale (inherited from DataSet) | Gets or sets the locale information used to compare strings within the table.
Namespace (inherited from DataSet) | Gets or sets the namespace of the DataSet.
Prefix (inherited from DataSet) | Gets or sets an XML prefix that aliases the namespace of the DataSet.
Relations |
RemotingFormat (inherited from DataSet) | Gets or sets a SerializationFormat for the DataSet used during remoting.
SchemaSerializationMode |
Site (inherited from DataSet) | Gets or sets an ISite for the DataSet.
Tables |
vwAdvertisingInsertionOrderBillTos |

Protected Instance Properties

Events (inherited from MarshalByValueComponent) Gets the list of event handlers that are attached to this component.

See Also

MultipleBillTo Class | Aptify.Applications.Advertising Namespace


Relations Property

Aptify 5.0 Software Development Kit (SDK)

MultipleBillTo.Relations Property

new public DataRelationCollection Relations {get;}

See Also

MultipleBillTo Class | Aptify.Applications.Advertising Namespace


SchemaSerializationMode Property

Aptify 5.0 Software Development Kit (SDK)

MultipleBillTo.SchemaSerializationMode Property

public override SchemaSerializationMode SchemaSerializationMode {get; set;}

See Also

MultipleBillTo Class | Aptify.Applications.Advertising Namespace


Tables Property

Aptify 5.0 Software Development Kit (SDK)

MultipleBillTo.Tables Property

new public DataTableCollection Tables {get;}

See Also

MultipleBillTo Class | Aptify.Applications.Advertising Namespace


vwAdvertisingInsertionOrderBillTos Property

Aptify 5.0 Software Development Kit (SDK)

MultipleBillTo.vwAdvertisingInsertionOrderBillTos Property

public MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable vwAdvertisingInsertionOrderBillTos {get;}

See Also

MultipleBillTo Class | Aptify.Applications.Advertising Namespace


MultipleBillTo Methods

The methods of the MultipleBillTo class are listed below. For a complete list of MultipleBillTo class members, see the MultipleBillTo Members topic.

Public Static Methods

GetTypedDataSetSchema

Public Instance Methods

AcceptChanges (inherited from DataSet) | Commits all the changes made to this DataSet since it was loaded or since the last time AcceptChanges was called.
BeginInit (inherited from DataSet) | Begins the initialization of a DataSet that is used on a form or used by another component. The initialization occurs at run-time.
Clear (inherited from DataSet) | Clears the DataSet of any data by removing all rows in all tables.
Clone |
Copy (inherited from DataSet) | Copies both the structure and data for this DataSet.
CreateDataReader (inherited from DataSet) | Overloaded. Returns a DataTableReader with one result set per DataTable, in the same sequence as the tables appear in the Tables collection.
Dispose (inherited from MarshalByValueComponent) | Overloaded. Releases all resources used by the MarshalByValueComponent.
EndInit (inherited from DataSet) | Ends the initialization of a DataSet that is used on a form or used by another component. The initialization occurs at run time.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetChanges (inherited from DataSet) | Overloaded. Gets a copy of the DataSet that contains all changes made to it since it was loaded or since AcceptChanges was last called.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from DataSet) | Populates a serialization information object with the data needed to serialize the DataSet.
GetService (inherited from MarshalByValueComponent) | Gets the implementer of the IServiceProvider.
GetType (inherited from Object) | Gets the Type of the current instance.
GetXml (inherited from DataSet) | Returns the XML representation of the data stored in the DataSet.
GetXmlSchema (inherited from DataSet) | Returns the XML Schema for the XML representation of the data stored in the DataSet.
HasChanges (inherited from DataSet) | Overloaded. Gets a value indicating whether the DataSet has changes, including new, deleted, or modified rows.
InferXmlSchema (inherited from DataSet) | Overloaded. Applies the XML schema from the specified XmlReader to the DataSet.
Load (inherited from DataSet) | Overloaded. Fills a DataSet with values from a data source using the supplied IDataReader, using an array of DataTable instances to supply the schema and namespace information.
Merge (inherited from DataSet) | Overloaded. Merges a specified DataSet and its schema into the current DataSet.
ReadXml (inherited from DataSet) | Overloaded. Reads XML schema and data into the DataSet using the specified XmlReader.
ReadXmlSchema (inherited from DataSet) | Overloaded. Reads the XML schema from the specified Stream into the DataSet.
RejectChanges (inherited from DataSet) | Rolls back all the changes made to the DataSet since it was created, or since the last time AcceptChanges was called.
Reset (inherited from DataSet) | Resets the DataSet to its original state. Subclasses should override Reset to restore a DataSet to its original state.
ToString (inherited from MarshalByValueComponent) | Returns a String containing the name of the Component, if any. This method should not be overridden.
WriteXml (inherited from DataSet) | Overloaded. Writes the current data for the DataSet using the specified Stream.
WriteXmlSchema (inherited from DataSet) | Overloaded. Writes the DataSet structure as an XML schema to using the specified Stream object.

Protected Instance Methods

DetermineSchemaSerializationMode (inherited from DataSet) | Overloaded. Determines the SchemaSerializationMode for a DataSet.
Dispose (inherited from MarshalByValueComponent) | Overloaded. Releases the unmanaged resources used by the MarshalByValueComponent and optionally releases the managed resources.
Finalize (inherited from MarshalByValueComponent) | [To be supplied.]
GetSchemaSerializable |
GetSerializationData (inherited from DataSet) |
InitializeDerivedDataSet |
IsBinarySerialized (inherited from DataSet) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnPropertyChanging (inherited from DataSet) | Raises the OnPropertyChanging event.
OnRemoveRelation (inherited from DataSet) | Occurs when a DataRelation object is removed from a DataTable.
ReadXmlSerializable |
ShouldSerializeRelations |
ShouldSerializeTables |

Protected Internal Instance Methods

OnRemoveTable (inherited from DataSet) | Occurs when a DataTable is removed from a DataSet.
RaisePropertyChanging (inherited from DataSet) | Sends a notification that the specified DataSet property is about to change.

See Also

MultipleBillTo Class | Aptify.Applications.Advertising Namespace


MultipleBillTo.Clone Method

public override DataSet Clone();

See Also

MultipleBillTo Class | Aptify.Applications.Advertising Namespace


MultipleBillTo.GetSchemaSerializable Method

protected override XmlSchema GetSchemaSerializable();

See Also

MultipleBillTo Class | Aptify.Applications.Advertising Namespace


MultipleBillTo.GetTypedDataSetSchema Method

public static XmlSchemaComplexType GetTypedDataSetSchema(
XmlSchemaSet xs
);

See Also

MultipleBillTo Class | Aptify.Applications.Advertising Namespace


MultipleBillTo.InitializeDerivedDataSet Method

protected override void InitializeDerivedDataSet();

See Also

MultipleBillTo Class | Aptify.Applications.Advertising Namespace


MultipleBillTo.ReadXmlSerializable Method

protected override void ReadXmlSerializable(
XmlReader reader
);

See Also

MultipleBillTo Class | Aptify.Applications.Advertising Namespace


MultipleBillTo.ShouldSerializeRelations Method

protected override bool ShouldSerializeRelations();

See Also

MultipleBillTo Class | Aptify.Applications.Advertising Namespace


MultipleBillTo.ShouldSerializeTables Method

protected override bool ShouldSerializeTables();

See Also

MultipleBillTo Class | Aptify.Applications.Advertising Namespace


MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable Class

Represents the strongly named DataTable class.

For a list of all members of this type, see MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable Members.

System.Object
MarshalByValueComponent
DataTable
MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable

public class MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable : DataTable, IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Advertising

Assembly: AdvertisingInsertionOrderControls (in AdvertisingInsertionOrderControls.dll)

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable Members | Aptify.Applications.Advertising Namespace


MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable Members

MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable overview

Public Static Methods

GetTypedTableSchema

Public Instance Constructors

MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable Overloaded. Initializes a new instance of the MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable class.

Public Instance Properties

AmountColumn |
BalanceColumn |
BillToCompanyID_NameColumn |
BillToCompanyIDColumn |
BillToPersonID_NameColumn |
BillToPersonIDColumn |
CancellationOrderColumn |
CaseSensitive (inherited from DataTable) | Indicates whether string comparisons within the table are case-sensitive.
ChildRelations (inherited from DataTable) | Gets the collection of child relations for this DataTable.
Columns (inherited from DataTable) | Gets the collection of columns that belong to this table.
Constraints (inherited from DataTable) | Gets the collection of constraints maintained by this table.
Container (inherited from MarshalByValueComponent) | Gets the container for the component.
Count |
CurrencyTypeIDColumn |
DataSet (inherited from DataTable) | Gets the DataSet to which this table belongs.
DefaultView (inherited from DataTable) | Gets a customized view of the table that may include a filtered view, or a cursor position.
DesignMode (inherited from MarshalByValueComponent) | Gets a value indicating whether the component is currently in design mode.
DisplayExpression (inherited from DataTable) | Gets or sets the expression that returns a value used to represent this table in the user interface.
ExtendedProperties (inherited from DataTable) | Gets the collection of customized user information.
HasErrors (inherited from DataTable) | Gets a value indicating whether there are errors in any of the rows in any of the tables of the DataSet to which the table belongs.
IDColumn |
InsertionOrderIDColumn |
IsInitialized (inherited from DataTable) | Gets a value that indicates whether the DataTable is initialized.
Item |
Locale (inherited from DataTable) | Gets or sets the locale information used to compare strings within the table.
MinimumCapacity (inherited from DataTable) | Gets or sets the initial starting size for this table.
Namespace (inherited from DataTable) | Gets or sets the namespace for the XML representation of the data stored in the DataTable.
OrderIDColumn |
ParentRelations (inherited from DataTable) | Gets the collection of parent relations for this DataTable.
Prefix (inherited from DataTable) | Gets or sets the namespace for the XML representation of the data stored in the DataTable.
PrimaryKey (inherited from DataTable) | Gets or sets an array of columns that function as primary keys for the data table.
RemotingFormat (inherited from DataTable) | Gets or sets the serialization format.
Rows (inherited from DataTable) | Gets the collection of rows that belong to this table.
SequenceColumn |
Site (inherited from DataTable) | Gets or sets an ISite for the DataTable.
SplitPercentColumn |
TableName (inherited from DataTable) | Gets or sets the name of the DataTable.

Public Instance Methods

AcceptChanges (inherited from DataTable) | Commits all the changes made to this table since the last time AcceptChanges was called.
AddvwAdvertisingInsertionOrderBillTosRow | Overloaded.
BeginInit (inherited from DataTable) | Begins the initialization of a DataTable that is used on a form or used by another component. The initialization occurs at runtime.
BeginLoadData (inherited from DataTable) | Turns off notifications, index maintenance, and constraints while loading data.
Clear (inherited from DataTable) | Clears the DataTable of all data.
Clone |
Compute (inherited from DataTable) | Computes the given expression on the current rows that pass the filter criteria.
Copy (inherited from DataTable) | Copies both the structure and data for this DataTable.
CreateDataReader (inherited from DataTable) | Returns a DataTableReader corresponding to the data within this DataTable.
Dispose (inherited from MarshalByValueComponent) | Overloaded. Releases all resources used by the MarshalByValueComponent.
EndInit (inherited from DataTable) | Ends the initialization of a DataTable that is used on a form or used by another component. The initialization occurs at runtime.
EndLoadData (inherited from DataTable) | Turns on notifications, index maintenance, and constraints after loading data.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByID |
GetChanges (inherited from DataTable) | Overloaded. Gets a copy of the DataTable that contains all changes made to it since it was loaded or AcceptChanges was last called.
GetEnumerator |
GetErrors (inherited from DataTable) | Gets an array of DataRow objects that contain errors.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from DataTable) | Populates a serialization information object with the data needed to serialize the DataTable.
GetService (inherited from MarshalByValueComponent) | Gets the implementer of the IServiceProvider.
GetType (inherited from Object) | Gets the Type of the current instance.
ImportRow (inherited from DataTable) | Copies a DataRow into a DataTable, preserving any property settings, as well as original and current values.
Load (inherited from DataTable) | Overloaded. Fills a DataTable with values from a data source using the supplied IDataReader. If the DataTable already contains rows, the incoming data from the data source is merged with the existing rows.
LoadDataRow (inherited from DataTable) | Overloaded. Finds and updates a specific row. If no matching row is found, a new row is created using the given values.
Merge (inherited from DataTable) | Overloaded. Merge the specified DataTable with the current DataTable.
NewRow (inherited from DataTable) | Creates a new DataRow with the same schema as the table.
NewvwAdvertisingInsertionOrderBillTosRow |
ReadXml (inherited from DataTable) | Overloaded. Reads XML schema and data into the DataTable using the specified Stream.
ReadXmlSchema (inherited from DataTable) | Overloaded. Reads an XML schema into the DataTable using the specified stream.
RejectChanges (inherited from DataTable) | Rolls back all changes that have been made to the table since it was loaded, or the last time AcceptChanges was called.
RemovevwAdvertisingInsertionOrderBillTosRow |
Reset (inherited from DataTable) | Resets the DataTable to its original state.
Select (inherited from DataTable) | Overloaded. Gets an array of all DataRow objects.
ToString (inherited from DataTable) | Gets the TableName and DisplayExpression, if there is one as a concatenated string.
WriteXml (inherited from DataTable) | Overloaded. Writes the current data, and optionally the schema, for the DataTable using the specified TextWriter and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. To save the data for the table and all its descendants, set the writeHierarchy parameter to true.
WriteXmlSchema (inherited from DataTable) | Overloaded. Writes the current data structure of the DataTable as an XML schema to the specified stream.

Public Instance Events

ColumnChanged (inherited from DataTable) | Occurs after a value has been changed for the specified DataColumn in a DataRow.
ColumnChanging (inherited from DataTable) | Occurs when a value is being changed for the specified DataColumn in a DataRow.
Disposed (inherited from MarshalByValueComponent) | Adds an event handler to listen to the Disposed event on the component.
Initialized (inherited from DataTable) | Occurs after the DataTable is initialized.
RowChanged (inherited from DataTable) | Occurs after a DataRow has been changed successfully.
RowChanging (inherited from DataTable) | Occurs when a DataRow is changing.
RowDeleted (inherited from DataTable) | Occurs after a row in the table has been deleted.
RowDeleting (inherited from DataTable) | Occurs before a row in the table is about to be deleted.
TableCleared (inherited from DataTable) | Occurs after a DataTable is cleared.
TableClearing (inherited from DataTable) | Occurs when a DataTable is cleared.
TableNewRow (inherited from DataTable) | Occurs when a new DataRow is inserted.
vwAdvertisingInsertionOrderBillTosRowChanged |
vwAdvertisingInsertionOrderBillTosRowChanging |
vwAdvertisingInsertionOrderBillTosRowDeleted |
vwAdvertisingInsertionOrderBillTosRowDeleting |

Protected Instance Constructors

MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable Overloaded. Initializes a new instance of the MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable class.

Protected Instance Properties

Events (inherited from MarshalByValueComponent) Gets the list of event handlers that are attached to this component.

Protected Instance Methods

CreateInstance |
Dispose (inherited from MarshalByValueComponent) | Overloaded. Releases the unmanaged resources used by the MarshalByValueComponent and optionally releases the managed resources.
Finalize (inherited from MarshalByValueComponent) | [To be supplied.]
GetRowType |
GetSchema (inherited from DataTable) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NewRowFromBuilder |
OnPropertyChanging (inherited from DataTable) | Raises the PropertyChanging event.
OnRemoveColumn (inherited from DataTable) | Notifies the DataTable that a DataColumn is being removed.
OnRowChanged |
OnRowChanging |
OnRowDeleted |
OnRowDeleting |
OnTableCleared (inherited from DataTable) | Raises the TableCleared event.
OnTableClearing (inherited from DataTable) | Raises the TableClearing event.
OnTableNewRow (inherited from DataTable) | Raises the TableNewRow event.
ReadXmlSerializable (inherited from DataTable) |

Protected Internal Instance Fields

fInitInProgress (inherited from DataTable)

Protected Internal Instance Methods

NewRowArray (inherited from DataTable) |
OnColumnChanged (inherited from DataTable) | Raises the ColumnChanged event.
OnColumnChanging (inherited from DataTable) | Raises the ColumnChanging event.

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable Class | Aptify.Applications.Advertising Namespace


MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable Constructor

Initializes a new instance of the MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable class.

Overload List

Initializes a new instance of the MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable class.

public MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable();

protected MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable(SerializationInfo,StreamingContext);

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable Class | Aptify.Applications.Advertising Namespace


MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable Constructor ()

Initializes a new instance of the MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable class.

public MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable();

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable Class | Aptify.Applications.Advertising Namespace | MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable Constructor Overload List


MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable Constructor (SerializationInfo, StreamingContext)

protected MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable(
SerializationInfo info,
StreamingContext context
);

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable Class | Aptify.Applications.Advertising Namespace | MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable Constructor Overload List


MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable Properties

The properties of the MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable class are listed below. For a complete list of MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable class members, see the MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable Members topic.

Public Instance Properties

AmountColumn |
BalanceColumn |
BillToCompanyID_NameColumn |
BillToCompanyIDColumn |
BillToPersonID_NameColumn |
BillToPersonIDColumn |
CancellationOrderColumn |
CaseSensitive (inherited from DataTable) | Indicates whether string comparisons within the table are case-sensitive.
ChildRelations (inherited from DataTable) | Gets the collection of child relations for this DataTable.
Columns (inherited from DataTable) | Gets the collection of columns that belong to this table.
Constraints (inherited from DataTable) | Gets the collection of constraints maintained by this table.
Container (inherited from MarshalByValueComponent) | Gets the container for the component.
Count |
CurrencyTypeIDColumn |
DataSet (inherited from DataTable) | Gets the DataSet to which this table belongs.
DefaultView (inherited from DataTable) | Gets a customized view of the table that may include a filtered view, or a cursor position.
DesignMode (inherited from MarshalByValueComponent) | Gets a value indicating whether the component is currently in design mode.
DisplayExpression (inherited from DataTable) | Gets or sets the expression that returns a value used to represent this table in the user interface.
ExtendedProperties (inherited from DataTable) | Gets the collection of customized user information.
HasErrors (inherited from DataTable) | Gets a value indicating whether there are errors in any of the rows in any of the tables of the DataSet to which the table belongs.
IDColumn |
InsertionOrderIDColumn |
IsInitialized (inherited from DataTable) | Gets a value that indicates whether the DataTable is initialized.
Item |
Locale (inherited from DataTable) | Gets or sets the locale information used to compare strings within the table.
MinimumCapacity (inherited from DataTable) | Gets or sets the initial starting size for this table.
Namespace (inherited from DataTable) | Gets or sets the namespace for the XML representation of the data stored in the DataTable.
OrderIDColumn |
ParentRelations (inherited from DataTable) | Gets the collection of parent relations for this DataTable.
Prefix (inherited from DataTable) | Gets or sets the namespace for the XML representation of the data stored in the DataTable.
PrimaryKey (inherited from DataTable) | Gets or sets an array of columns that function as primary keys for the data table.
RemotingFormat (inherited from DataTable) | Gets or sets the serialization format.
Rows (inherited from DataTable) | Gets the collection of rows that belong to this table.
SequenceColumn |
Site (inherited from DataTable) | Gets or sets an ISite for the DataTable.
SplitPercentColumn |
TableName (inherited from DataTable) | Gets or sets the name of the DataTable.

Protected Instance Properties

Events (inherited from MarshalByValueComponent) Gets the list of event handlers that are attached to this component.

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable Class | Aptify.Applications.Advertising Namespace


AmountColumn Property

Aptify 5.0 Software Development Kit (SDK)

MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable.AmountColumn Property

public DataColumn AmountColumn {get;}

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable Class | Aptify.Applications.Advertising Namespace


BalanceColumn Property

Aptify 5.0 Software Development Kit (SDK)

MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable.BalanceColumn Property

public DataColumn BalanceColumn {get;}

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable Class | Aptify.Applications.Advertising Namespace


BillToCompanyID_NameColumn Property

Aptify 5.0 Software Development Kit (SDK)

MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable.BillToCompanyID_NameColumn Property

public DataColumn BillToCompanyID_NameColumn {get;}

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable Class | Aptify.Applications.Advertising Namespace


BillToCompanyIDColumn Property

Aptify 5.0 Software Development Kit (SDK)

MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable.BillToCompanyIDColumn Property

public DataColumn BillToCompanyIDColumn {get;}

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable Class | Aptify.Applications.Advertising Namespace


BillToPersonID_NameColumn Property

Aptify 5.0 Software Development Kit (SDK)

MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable.BillToPersonID_NameColumn Property

public DataColumn BillToPersonID_NameColumn {get;}

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable Class | Aptify.Applications.Advertising Namespace


BillToPersonIDColumn Property

Aptify 5.0 Software Development Kit (SDK)

MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable.BillToPersonIDColumn Property

public DataColumn BillToPersonIDColumn {get;}

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable Class | Aptify.Applications.Advertising Namespace


CancellationOrderColumn Property

Aptify 5.0 Software Development Kit (SDK)

MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable.CancellationOrderColumn Property

public DataColumn CancellationOrderColumn {get;}

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable Class | Aptify.Applications.Advertising Namespace


Count Property

Aptify 5.0 Software Development Kit (SDK)

MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable.Count Property

public Int32 Count {get;}

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable Class | Aptify.Applications.Advertising Namespace


CurrencyTypeIDColumn Property

Aptify 5.0 Software Development Kit (SDK)

MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable.CurrencyTypeIDColumn Property

public DataColumn CurrencyTypeIDColumn {get;}

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable Class | Aptify.Applications.Advertising Namespace


IDColumn Property

Aptify 5.0 Software Development Kit (SDK)

MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable.IDColumn Property

public DataColumn IDColumn {get;}

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable Class | Aptify.Applications.Advertising Namespace


InsertionOrderIDColumn Property

Aptify 5.0 Software Development Kit (SDK)

MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable.InsertionOrderIDColumn Property

public DataColumn InsertionOrderIDColumn {get;}

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable Class | Aptify.Applications.Advertising Namespace


Item Property

Aptify 5.0 Software Development Kit (SDK)

MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable.Item Property

public MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow this[
Int32 index
] {get;}

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable Class | Aptify.Applications.Advertising Namespace


OrderIDColumn Property

Aptify 5.0 Software Development Kit (SDK)

MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable.OrderIDColumn Property

public DataColumn OrderIDColumn {get;}

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable Class | Aptify.Applications.Advertising Namespace


SequenceColumn Property

Aptify 5.0 Software Development Kit (SDK)

MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable.SequenceColumn Property

public DataColumn SequenceColumn {get;}

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable Class | Aptify.Applications.Advertising Namespace


SplitPercentColumn Property

Aptify 5.0 Software Development Kit (SDK)

MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable.SplitPercentColumn Property

public DataColumn SplitPercentColumn {get;}

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable Class | Aptify.Applications.Advertising Namespace


MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable Methods

The methods of the MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable class are listed below. For a complete list of MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable class members, see the MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable Members topic.

Public Static Methods

GetTypedTableSchema

Public Instance Methods

AcceptChanges (inherited from DataTable) | Commits all the changes made to this table since the last time AcceptChanges was called.
AddvwAdvertisingInsertionOrderBillTosRow | Overloaded.
BeginInit (inherited from DataTable) | Begins the initialization of a DataTable that is used on a form or used by another component. The initialization occurs at runtime.
BeginLoadData (inherited from DataTable) | Turns off notifications, index maintenance, and constraints while loading data.
Clear (inherited from DataTable) | Clears the DataTable of all data.
Clone |
Compute (inherited from DataTable) | Computes the given expression on the current rows that pass the filter criteria.
Copy (inherited from DataTable) | Copies both the structure and data for this DataTable.
CreateDataReader (inherited from DataTable) | Returns a DataTableReader corresponding to the data within this DataTable.
Dispose (inherited from MarshalByValueComponent) | Overloaded. Releases all resources used by the MarshalByValueComponent.
EndInit (inherited from DataTable) | Ends the initialization of a DataTable that is used on a form or used by another component. The initialization occurs at runtime.
EndLoadData (inherited from DataTable) | Turns on notifications, index maintenance, and constraints after loading data.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByID |
GetChanges (inherited from DataTable) | Overloaded. Gets a copy of the DataTable that contains all changes made to it since it was loaded or AcceptChanges was last called.
GetEnumerator |
GetErrors (inherited from DataTable) | Gets an array of DataRow objects that contain errors.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from DataTable) | Populates a serialization information object with the data needed to serialize the DataTable.
GetService (inherited from MarshalByValueComponent) | Gets the implementer of the IServiceProvider.
GetType (inherited from Object) | Gets the Type of the current instance.
ImportRow (inherited from DataTable) | Copies a DataRow into a DataTable, preserving any property settings, as well as original and current values.
Load (inherited from DataTable) | Overloaded. Fills a DataTable with values from a data source using the supplied IDataReader. If the DataTable already contains rows, the incoming data from the data source is merged with the existing rows.
LoadDataRow (inherited from DataTable) | Overloaded. Finds and updates a specific row. If no matching row is found, a new row is created using the given values.
Merge (inherited from DataTable) | Overloaded. Merge the specified DataTable with the current DataTable.
NewRow (inherited from DataTable) | Creates a new DataRow with the same schema as the table.
NewvwAdvertisingInsertionOrderBillTosRow |
ReadXml (inherited from DataTable) | Overloaded. Reads XML schema and data into the DataTable using the specified Stream.
ReadXmlSchema (inherited from DataTable) | Overloaded. Reads an XML schema into the DataTable using the specified stream.
RejectChanges (inherited from DataTable) | Rolls back all changes that have been made to the table since it was loaded, or the last time AcceptChanges was called.
RemovevwAdvertisingInsertionOrderBillTosRow |
Reset (inherited from DataTable) | Resets the DataTable to its original state.
Select (inherited from DataTable) | Overloaded. Gets an array of all DataRow objects.
ToString (inherited from DataTable) | Gets the TableName and DisplayExpression, if there is one as a concatenated string.
WriteXml (inherited from DataTable) | Overloaded. Writes the current data, and optionally the schema, for the DataTable using the specified TextWriter and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. To save the data for the table and all its descendants, set the writeHierarchy parameter to true.
WriteXmlSchema (inherited from DataTable) | Overloaded. Writes the current data structure of the DataTable as an XML schema to the specified stream.

Protected Instance Methods

CreateInstance |
Dispose (inherited from MarshalByValueComponent) | Overloaded. Releases the unmanaged resources used by the MarshalByValueComponent and optionally releases the managed resources.
Finalize (inherited from MarshalByValueComponent) | [To be supplied.]
GetRowType |
GetSchema (inherited from DataTable) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NewRowFromBuilder |
OnPropertyChanging (inherited from DataTable) | Raises the PropertyChanging event.
OnRemoveColumn (inherited from DataTable) | Notifies the DataTable that a DataColumn is being removed.
OnRowChanged |
OnRowChanging |
OnRowDeleted |
OnRowDeleting |
OnTableCleared (inherited from DataTable) | Raises the TableCleared event.
OnTableClearing (inherited from DataTable) | Raises the TableClearing event.
OnTableNewRow (inherited from DataTable) | Raises the TableNewRow event.
ReadXmlSerializable (inherited from DataTable) |

Protected Internal Instance Methods

NewRowArray (inherited from DataTable) |
OnColumnChanged (inherited from DataTable) | Raises the ColumnChanged event.
OnColumnChanging (inherited from DataTable) | Raises the ColumnChanging event.

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable Class | Aptify.Applications.Advertising Namespace


AddvwAdvertisingInsertionOrderBillTosRow Method

Aptify 5.0 Software Development Kit (SDK)

MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable.AddvwAdvertisingInsertionOrderBillTosRow Method

Overload List

public void AddvwAdvertisingInsertionOrderBillTosRow(MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow);

public vwAdvertisingInsertionOrderBillTosRow AddvwAdvertisingInsertionOrderBillTosRow(Int32,Int32,Int32,Int32,Decimal,Int32,Int32,String,String,Decimal,Decimal,Int32);

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable Class | Aptify.Applications.Advertising Namespace


MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable.AddvwAdvertisingInsertionOrderBillTosRow Method (vwAdvertisingInsertionOrderBillTosRow)

public void AddvwAdvertisingInsertionOrderBillTosRow(
MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow row
);

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable Class | Aptify.Applications.Advertising Namespace | MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable.AddvwAdvertisingInsertionOrderBillTosRow Overload List


MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable.AddvwAdvertisingInsertionOrderBillTosRow Method (Int32, Int32, Int32, Int32, Decimal, Int32, Int32, String, String, Decimal, Decimal, Int32)

public vwAdvertisingInsertionOrderBillTosRow AddvwAdvertisingInsertionOrderBillTosRow(
Int32 InsertionOrderID,
Int32 Sequence,
Int32 BillToCompanyID,
Int32 BillToPersonID,
Decimal SplitPercent,
Int32 OrderID,
Int32 CancellationOrder,
String BillToCompanyID_Name,
String BillToPersonID_Name,
Decimal Amount,
Decimal Balance,
Int32 CurrencyTypeID
);

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable Class | Aptify.Applications.Advertising Namespace | MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable.AddvwAdvertisingInsertionOrderBillTosRow Overload List


MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable.Clone Method

public override DataTable Clone();

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable Class | Aptify.Applications.Advertising Namespace


MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable.CreateInstance Method

protected override DataTable CreateInstance();

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable Class | Aptify.Applications.Advertising Namespace


MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable.FindByID Method

public vwAdvertisingInsertionOrderBillTosRow FindByID(
Int32 ID
);

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable Class | Aptify.Applications.Advertising Namespace


MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable.GetEnumerator Method

public virtual IEnumerator GetEnumerator();

Implements

IEnumerable.

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable Class | Aptify.Applications.Advertising Namespace


MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable.GetRowType Method

protected override Type GetRowType();

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable Class | Aptify.Applications.Advertising Namespace


MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable.GetTypedTableSchema Method

public static XmlSchemaComplexType GetTypedTableSchema(
XmlSchemaSet xs
);

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable Class | Aptify.Applications.Advertising Namespace


MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable.NewRowFromBuilder Method

protected override DataRow NewRowFromBuilder(
DataRowBuilder builder
);

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable Class | Aptify.Applications.Advertising Namespace


MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable.NewvwAdvertisingInsertionOrderBillTosRow Method

public vwAdvertisingInsertionOrderBillTosRow NewvwAdvertisingInsertionOrderBillTosRow();

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable Class | Aptify.Applications.Advertising Namespace


MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable.OnRowChanged Method

protected override void OnRowChanged(
DataRowChangeEventArgs e
);

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable Class | Aptify.Applications.Advertising Namespace


MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable.OnRowChanging Method

protected override void OnRowChanging(
DataRowChangeEventArgs e
);

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable Class | Aptify.Applications.Advertising Namespace


MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable.OnRowDeleted Method

protected override void OnRowDeleted(
DataRowChangeEventArgs e
);

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable Class | Aptify.Applications.Advertising Namespace


MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable.OnRowDeleting Method

protected override void OnRowDeleting(
DataRowChangeEventArgs e
);

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable Class | Aptify.Applications.Advertising Namespace


MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable.RemovevwAdvertisingInsertionOrderBillTosRow Method

public void RemovevwAdvertisingInsertionOrderBillTosRow(
MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow row
);

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable Class | Aptify.Applications.Advertising Namespace


MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable Events

The events of the MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable class are listed below. For a complete list of MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable class members, see the MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable Members topic.

Public Instance Events

ColumnChanged (inherited from DataTable) | Occurs after a value has been changed for the specified DataColumn in a DataRow.
ColumnChanging (inherited from DataTable) | Occurs when a value is being changed for the specified DataColumn in a DataRow.
Disposed (inherited from MarshalByValueComponent) | Adds an event handler to listen to the Disposed event on the component.
Initialized (inherited from DataTable) | Occurs after the DataTable is initialized.
RowChanged (inherited from DataTable) | Occurs after a DataRow has been changed successfully.
RowChanging (inherited from DataTable) | Occurs when a DataRow is changing.
RowDeleted (inherited from DataTable) | Occurs after a row in the table has been deleted.
RowDeleting (inherited from DataTable) | Occurs before a row in the table is about to be deleted.
TableCleared (inherited from DataTable) | Occurs after a DataTable is cleared.
TableClearing (inherited from DataTable) | Occurs when a DataTable is cleared.
TableNewRow (inherited from DataTable) | Occurs when a new DataRow is inserted.
vwAdvertisingInsertionOrderBillTosRowChanged |
vwAdvertisingInsertionOrderBillTosRowChanging |
vwAdvertisingInsertionOrderBillTosRowDeleted |
vwAdvertisingInsertionOrderBillTosRowDeleting |

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable Class | Aptify.Applications.Advertising Namespace


MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable.MultipleBillTo.vwAdvertisingInsertionOrderBillTosRowChangeEventHandler Event

public event MultipleBillTo.vwAdvertisingInsertionOrderBillTosRowChangeEventHandler vwAdvertisingInsertionOrderBillTosRowChanged;

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable Class | Aptify.Applications.Advertising Namespace


MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable.MultipleBillTo.vwAdvertisingInsertionOrderBillTosRowChangeEventHandler Event

public event MultipleBillTo.vwAdvertisingInsertionOrderBillTosRowChangeEventHandler vwAdvertisingInsertionOrderBillTosRowChanging;

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable Class | Aptify.Applications.Advertising Namespace


MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable.MultipleBillTo.vwAdvertisingInsertionOrderBillTosRowChangeEventHandler Event

public event MultipleBillTo.vwAdvertisingInsertionOrderBillTosRowChangeEventHandler vwAdvertisingInsertionOrderBillTosRowDeleted;

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable Class | Aptify.Applications.Advertising Namespace


MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable.MultipleBillTo.vwAdvertisingInsertionOrderBillTosRowChangeEventHandler Event

public event MultipleBillTo.vwAdvertisingInsertionOrderBillTosRowChangeEventHandler vwAdvertisingInsertionOrderBillTosRowDeleting;

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosDataTable Class | Aptify.Applications.Advertising Namespace


MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow Class

Represents strongly named DataRow class.

For a list of all members of this type, see MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow Members.

System.Object
DataRow
MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow

public class MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow : DataRow

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Advertising

Assembly: AdvertisingInsertionOrderControls (in AdvertisingInsertionOrderControls.dll)

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow Members | Aptify.Applications.Advertising Namespace


MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow Members

MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow overview

Public Instance Properties

Amount |
Balance |
BillToCompanyID |
BillToCompanyID_Name |
BillToPersonID |
BillToPersonID_Name |
CancellationOrder |
CurrencyTypeID |
HasErrors (inherited from DataRow) | Gets a value that indicates whether there are errors in a row.
ID |
InsertionOrderID |
Item (inherited from DataRow) | Gets or sets the data stored in the column specified by index.
Item (inherited from DataRow) | Gets or sets the data stored in the column specified by name.
Item (inherited from DataRow) | Gets or sets the data stored in the specified DataColumn.
Item (inherited from DataRow) | Gets the data stored in the column, specified by index and version of the data to retrieve.
Item (inherited from DataRow) | Gets the specified version of data stored in the named column.
Item (inherited from DataRow) | Gets the specified version of data stored in the specified DataColumn.
ItemArray (inherited from DataRow) | Gets or sets all the values for this row through an array.
OrderID |
RowError (inherited from DataRow) | Gets or sets the custom error description for a row.
RowState (inherited from DataRow) | Gets the current state of the row with regard to its relationship to the DataRowCollection.
Sequence |
SplitPercent |
Table (inherited from DataRow) | Gets the DataTable for which this row has a schema.

Public Instance Methods

AcceptChanges (inherited from DataRow) | Commits all the changes made to this row since the last time AcceptChanges was called.
BeginEdit (inherited from DataRow) | Starts an edit operation on a DataRow object.
CancelEdit (inherited from DataRow) | Cancels the current edit on the row.
ClearErrors (inherited from DataRow) | Clears the errors for the row. This includes the RowError and errors set with SetColumnError.
Delete (inherited from DataRow) | Deletes the DataRow.
EndEdit (inherited from DataRow) | Ends the edit occurring on the row.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetChildRows (inherited from DataRow) | Overloaded. Gets the child rows of a DataRow using the specified RelationName of a DataRelation.
GetColumnError (inherited from DataRow) | Overloaded. Gets the error description for the column specified by index.
GetColumnsInError (inherited from DataRow) | Gets an array of columns that have errors.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetParentRow (inherited from DataRow) | Overloaded. Gets the parent row of a DataRow using the specified RelationName of a DataRelation.
GetParentRows (inherited from DataRow) | Overloaded. Gets the parent rows of a DataRow using the specified RelationName of a DataRelation.
GetType (inherited from Object) | Gets the Type of the current instance.
HasVersion (inherited from DataRow) | Gets a value that indicates whether a specified version exists.
IsAmountNull |
IsBalanceNull |
IsBillToCompanyID_NameNull |
IsBillToCompanyIDNull |
IsBillToPersonID_NameNull |
IsCancellationOrderNull |
IsCurrencyTypeIDNull |
IsNull (inherited from DataRow) | Overloaded. Gets a value that indicates whether the column at the specified index contains a null value.
IsOrderIDNull |
IsSplitPercentNull |
RejectChanges (inherited from DataRow) | Rejects all changes made to the row since AcceptChanges was last called.
SetAdded (inherited from DataRow) | Changes the Rowstate of a DataRow to Added.
SetAmountNull |
SetBalanceNull |
SetBillToCompanyID_NameNull |
SetBillToCompanyIDNull |
SetBillToPersonID_NameNull |
SetCancellationOrderNull |
SetColumnError (inherited from DataRow) | Overloaded. Sets the error description for a column specified by index.
SetCurrencyTypeIDNull |
SetModified (inherited from DataRow) | Changes the Rowstate of a DataRow to Modified.
SetOrderIDNull |
SetParentRow (inherited from DataRow) | Overloaded. Sets the parent row of a DataRow with specified new parent DataRow.
SetSplitPercentNull |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetNull (inherited from DataRow) | Sets the value of the specified DataColumn to a null value.

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow Class | Aptify.Applications.Advertising Namespace


MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow Properties

The properties of the MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow class are listed below. For a complete list of MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow class members, see the MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow Members topic.

Public Instance Properties

Amount |
Balance |
BillToCompanyID |
BillToCompanyID_Name |
BillToPersonID |
BillToPersonID_Name |
CancellationOrder |
CurrencyTypeID |
HasErrors (inherited from DataRow) | Gets a value that indicates whether there are errors in a row.
ID |
InsertionOrderID |
Item (inherited from DataRow) | Gets or sets the data stored in the column specified by index.
Item (inherited from DataRow) | Gets or sets the data stored in the column specified by name.
Item (inherited from DataRow) | Gets or sets the data stored in the specified DataColumn.
Item (inherited from DataRow) | Gets the data stored in the column, specified by index and version of the data to retrieve.
Item (inherited from DataRow) | Gets the specified version of data stored in the named column.
Item (inherited from DataRow) | Gets the specified version of data stored in the specified DataColumn.
ItemArray (inherited from DataRow) | Gets or sets all the values for this row through an array.
OrderID |
RowError (inherited from DataRow) | Gets or sets the custom error description for a row.
RowState (inherited from DataRow) | Gets the current state of the row with regard to its relationship to the DataRowCollection.
Sequence |
SplitPercent |
Table (inherited from DataRow) | Gets the DataTable for which this row has a schema.

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow Class | Aptify.Applications.Advertising Namespace


Amount Property

Aptify 5.0 Software Development Kit (SDK)

MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow.Amount Property

public Decimal Amount {get; set;}

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow Class | Aptify.Applications.Advertising Namespace


Balance Property

Aptify 5.0 Software Development Kit (SDK)

MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow.Balance Property

public Decimal Balance {get; set;}

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow Class | Aptify.Applications.Advertising Namespace


BillToCompanyID Property

Aptify 5.0 Software Development Kit (SDK)

MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow.BillToCompanyID Property

public Int32 BillToCompanyID {get; set;}

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow Class | Aptify.Applications.Advertising Namespace


BillToCompanyID_Name Property

Aptify 5.0 Software Development Kit (SDK)

MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow.BillToCompanyID_Name Property

public String BillToCompanyID_Name {get; set;}

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow Class | Aptify.Applications.Advertising Namespace


BillToPersonID Property

Aptify 5.0 Software Development Kit (SDK)

MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow.BillToPersonID Property

public Int32 BillToPersonID {get; set;}

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow Class | Aptify.Applications.Advertising Namespace


BillToPersonID_Name Property

Aptify 5.0 Software Development Kit (SDK)

MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow.BillToPersonID_Name Property

public String BillToPersonID_Name {get; set;}

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow Class | Aptify.Applications.Advertising Namespace


CancellationOrder Property

Aptify 5.0 Software Development Kit (SDK)

MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow.CancellationOrder Property

public Int32 CancellationOrder {get; set;}

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow Class | Aptify.Applications.Advertising Namespace


CurrencyTypeID Property

Aptify 5.0 Software Development Kit (SDK)

MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow.CurrencyTypeID Property

public Int32 CurrencyTypeID {get; set;}

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow Class | Aptify.Applications.Advertising Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow.ID Property

public Int32 ID {get; set;}

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow Class | Aptify.Applications.Advertising Namespace


InsertionOrderID Property

Aptify 5.0 Software Development Kit (SDK)

MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow.InsertionOrderID Property

public Int32 InsertionOrderID {get; set;}

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow Class | Aptify.Applications.Advertising Namespace


OrderID Property

Aptify 5.0 Software Development Kit (SDK)

MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow.OrderID Property

public Int32 OrderID {get; set;}

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow Class | Aptify.Applications.Advertising Namespace


Sequence Property

Aptify 5.0 Software Development Kit (SDK)

MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow.Sequence Property

public Int32 Sequence {get; set;}

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow Class | Aptify.Applications.Advertising Namespace


SplitPercent Property

Aptify 5.0 Software Development Kit (SDK)

MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow.SplitPercent Property

public Decimal SplitPercent {get; set;}

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow Class | Aptify.Applications.Advertising Namespace


MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow Methods

The methods of the MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow class are listed below. For a complete list of MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow class members, see the MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow Members topic.

Public Instance Methods

AcceptChanges (inherited from DataRow) | Commits all the changes made to this row since the last time AcceptChanges was called.
BeginEdit (inherited from DataRow) | Starts an edit operation on a DataRow object.
CancelEdit (inherited from DataRow) | Cancels the current edit on the row.
ClearErrors (inherited from DataRow) | Clears the errors for the row. This includes the RowError and errors set with SetColumnError.
Delete (inherited from DataRow) | Deletes the DataRow.
EndEdit (inherited from DataRow) | Ends the edit occurring on the row.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetChildRows (inherited from DataRow) | Overloaded. Gets the child rows of a DataRow using the specified RelationName of a DataRelation.
GetColumnError (inherited from DataRow) | Overloaded. Gets the error description for the column specified by index.
GetColumnsInError (inherited from DataRow) | Gets an array of columns that have errors.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetParentRow (inherited from DataRow) | Overloaded. Gets the parent row of a DataRow using the specified RelationName of a DataRelation.
GetParentRows (inherited from DataRow) | Overloaded. Gets the parent rows of a DataRow using the specified RelationName of a DataRelation.
GetType (inherited from Object) | Gets the Type of the current instance.
HasVersion (inherited from DataRow) | Gets a value that indicates whether a specified version exists.
IsAmountNull |
IsBalanceNull |
IsBillToCompanyID_NameNull |
IsBillToCompanyIDNull |
IsBillToPersonID_NameNull |
IsCancellationOrderNull |
IsCurrencyTypeIDNull |
IsNull (inherited from DataRow) | Overloaded. Gets a value that indicates whether the column at the specified index contains a null value.
IsOrderIDNull |
IsSplitPercentNull |
RejectChanges (inherited from DataRow) | Rejects all changes made to the row since AcceptChanges was last called.
SetAdded (inherited from DataRow) | Changes the Rowstate of a DataRow to Added.
SetAmountNull |
SetBalanceNull |
SetBillToCompanyID_NameNull |
SetBillToCompanyIDNull |
SetBillToPersonID_NameNull |
SetCancellationOrderNull |
SetColumnError (inherited from DataRow) | Overloaded. Sets the error description for a column specified by index.
SetCurrencyTypeIDNull |
SetModified (inherited from DataRow) | Changes the Rowstate of a DataRow to Modified.
SetOrderIDNull |
SetParentRow (inherited from DataRow) | Overloaded. Sets the parent row of a DataRow with specified new parent DataRow.
SetSplitPercentNull |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetNull (inherited from DataRow) | Sets the value of the specified DataColumn to a null value.

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow Class | Aptify.Applications.Advertising Namespace


MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow.IsAmountNull Method

public bool IsAmountNull();

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow Class | Aptify.Applications.Advertising Namespace


MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow.IsBalanceNull Method

public bool IsBalanceNull();

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow Class | Aptify.Applications.Advertising Namespace


MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow.IsBillToCompanyID_NameNull Method

public bool IsBillToCompanyID_NameNull();

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow Class | Aptify.Applications.Advertising Namespace


MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow.IsBillToCompanyIDNull Method

public bool IsBillToCompanyIDNull();

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow Class | Aptify.Applications.Advertising Namespace


MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow.IsBillToPersonID_NameNull Method

public bool IsBillToPersonID_NameNull();

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow Class | Aptify.Applications.Advertising Namespace


MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow.IsCancellationOrderNull Method

public bool IsCancellationOrderNull();

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow Class | Aptify.Applications.Advertising Namespace


MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow.IsCurrencyTypeIDNull Method

public bool IsCurrencyTypeIDNull();

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow Class | Aptify.Applications.Advertising Namespace


MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow.IsOrderIDNull Method

public bool IsOrderIDNull();

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow Class | Aptify.Applications.Advertising Namespace


MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow.IsSplitPercentNull Method

public bool IsSplitPercentNull();

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow Class | Aptify.Applications.Advertising Namespace


MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow.SetAmountNull Method

public void SetAmountNull();

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow Class | Aptify.Applications.Advertising Namespace


MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow.SetBalanceNull Method

public void SetBalanceNull();

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow Class | Aptify.Applications.Advertising Namespace


MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow.SetBillToCompanyID_NameNull Method

public void SetBillToCompanyID_NameNull();

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow Class | Aptify.Applications.Advertising Namespace


MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow.SetBillToCompanyIDNull Method

public void SetBillToCompanyIDNull();

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow Class | Aptify.Applications.Advertising Namespace


MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow.SetBillToPersonID_NameNull Method

public void SetBillToPersonID_NameNull();

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow Class | Aptify.Applications.Advertising Namespace


MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow.SetCancellationOrderNull Method

public void SetCancellationOrderNull();

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow Class | Aptify.Applications.Advertising Namespace


MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow.SetCurrencyTypeIDNull Method

public void SetCurrencyTypeIDNull();

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow Class | Aptify.Applications.Advertising Namespace


MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow.SetOrderIDNull Method

public void SetOrderIDNull();

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow Class | Aptify.Applications.Advertising Namespace


MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow.SetSplitPercentNull Method

public void SetSplitPercentNull();

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow Class | Aptify.Applications.Advertising Namespace


MultipleBillTo.vwAdvertisingInsertionOrderBillTosRowChangeEvent Class

Row event argument class

For a list of all members of this type, see MultipleBillTo.vwAdvertisingInsertionOrderBillTosRowChangeEvent Members.

System.Object
EventArgs
MultipleBillTo.vwAdvertisingInsertionOrderBillTosRowChangeEvent

public class MultipleBillTo.vwAdvertisingInsertionOrderBillTosRowChangeEvent : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Advertising

Assembly: AdvertisingInsertionOrderControls (in AdvertisingInsertionOrderControls.dll)

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosRowChangeEvent Members | Aptify.Applications.Advertising Namespace


MultipleBillTo.vwAdvertisingInsertionOrderBillTosRowChangeEvent Members

MultipleBillTo.vwAdvertisingInsertionOrderBillTosRowChangeEvent overview

Public Instance Constructors

MultipleBillTo.vwAdvertisingInsertionOrderBillTosRowChangeEvent Constructor

Public Instance Properties

Action
Row

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosRowChangeEvent Class | Aptify.Applications.Advertising Namespace


MultipleBillTo.vwAdvertisingInsertionOrderBillTosRowChangeEvent Constructor

public MultipleBillTo.vwAdvertisingInsertionOrderBillTosRowChangeEvent(
MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow row,
DataRowAction action
);

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosRowChangeEvent Class | Aptify.Applications.Advertising Namespace


MultipleBillTo.vwAdvertisingInsertionOrderBillTosRowChangeEvent Properties

The properties of the MultipleBillTo.vwAdvertisingInsertionOrderBillTosRowChangeEvent class are listed below. For a complete list of MultipleBillTo.vwAdvertisingInsertionOrderBillTosRowChangeEvent class members, see the MultipleBillTo.vwAdvertisingInsertionOrderBillTosRowChangeEvent Members topic.

Public Instance Properties

Action
Row

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosRowChangeEvent Class | Aptify.Applications.Advertising Namespace


Action Property

Aptify 5.0 Software Development Kit (SDK)

MultipleBillTo.vwAdvertisingInsertionOrderBillTosRowChangeEvent.Action Property

public DataRowAction Action {get;}

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosRowChangeEvent Class | Aptify.Applications.Advertising Namespace


Row Property

Aptify 5.0 Software Development Kit (SDK)

MultipleBillTo.vwAdvertisingInsertionOrderBillTosRowChangeEvent.Row Property

public MultipleBillTo.vwAdvertisingInsertionOrderBillTosRow Row {get;}

See Also

MultipleBillTo.vwAdvertisingInsertionOrderBillTosRowChangeEvent Class | Aptify.Applications.Advertising Namespace


MultipleBillTo.vwAdvertisingInsertionOrderBillTosRowChangeEventHandler Delegate

public delegate void MultipleBillTo.vwAdvertisingInsertionOrderBillTosRowChangeEventHandler(
Object sender,
MultipleBillTo.vwAdvertisingInsertionOrderBillTosRowChangeEvent e
);

Requirements

Namespace: Aptify.Applications.Advertising

Assembly: AdvertisingInsertionOrderControls (in AdvertisingInsertionOrderControls.dll)

See Also

Aptify.Applications.Advertising Namespace


OptionsDataSet Class

Represents a strongly typed in-memory cache of data.

For a list of all members of this type, see OptionsDataSet Members.

System.Object
MarshalByValueComponent
DataSet
OptionsDataSet

public class OptionsDataSet : DataSet

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Advertising

Assembly: AdvertisingInsertionOrderControls (in AdvertisingInsertionOrderControls.dll)

See Also

OptionsDataSet Members | Aptify.Applications.Advertising Namespace


OptionsDataSet Members

OptionsDataSet overview

Public Static Methods

GetTypedDataSetSchema

Public Instance Constructors

OptionsDataSet Overloaded. Initializes a new instance of the OptionsDataSet class.

Public Instance Properties

CaseSensitive (inherited from DataSet) | Gets or sets a value indicating whether string comparisons within DataTable objects are case-sensitive.
Container (inherited from MarshalByValueComponent) | Gets the container for the component.
DataSetName (inherited from DataSet) | Gets or sets the name of the current DataSet.
DefaultViewManager (inherited from DataSet) | Gets a custom view of the data contained in the DataSet to allow filtering, searching, and navigating using a custom DataViewManager.
DesignMode (inherited from MarshalByValueComponent) | Gets a value indicating whether the component is currently in design mode.
EnforceConstraints (inherited from DataSet) | Gets or sets a value indicating whether constraint rules are followed when attempting any update operation.
ExtendedProperties (inherited from DataSet) | Gets the collection of customized user information associated with the DataSet.
HasErrors (inherited from DataSet) | Gets a value indicating whether there are errors in any of the DataTable objects within this DataSet.
IsInitialized (inherited from DataSet) | Gets a value that indicates whether the DataSet is initialized.
Locale (inherited from DataSet) | Gets or sets the locale information used to compare strings within the table.
Namespace (inherited from DataSet) | Gets or sets the namespace of the DataSet.
Options |
Prefix (inherited from DataSet) | Gets or sets an XML prefix that aliases the namespace of the DataSet.
Relations |
RemotingFormat (inherited from DataSet) | Gets or sets a SerializationFormat for the DataSet used during remoting.
SchemaSerializationMode |
Site (inherited from DataSet) | Gets or sets an ISite for the DataSet.
Tables |

Public Instance Methods

AcceptChanges (inherited from DataSet) | Commits all the changes made to this DataSet since it was loaded or since the last time AcceptChanges was called.
BeginInit (inherited from DataSet) | Begins the initialization of a DataSet that is used on a form or used by another component. The initialization occurs at run-time.
Clear (inherited from DataSet) | Clears the DataSet of any data by removing all rows in all tables.
Clone |
Copy (inherited from DataSet) | Copies both the structure and data for this DataSet.
CreateDataReader (inherited from DataSet) | Overloaded. Returns a DataTableReader with one result set per DataTable, in the same sequence as the tables appear in the Tables collection.
Dispose (inherited from MarshalByValueComponent) | Overloaded. Releases all resources used by the MarshalByValueComponent.
EndInit (inherited from DataSet) | Ends the initialization of a DataSet that is used on a form or used by another component. The initialization occurs at run time.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetChanges (inherited from DataSet) | Overloaded. Gets a copy of the DataSet that contains all changes made to it since it was loaded or since AcceptChanges was last called.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from DataSet) | Populates a serialization information object with the data needed to serialize the DataSet.
GetService (inherited from MarshalByValueComponent) | Gets the implementer of the IServiceProvider.
GetType (inherited from Object) | Gets the Type of the current instance.
GetXml (inherited from DataSet) | Returns the XML representation of the data stored in the DataSet.
GetXmlSchema (inherited from DataSet) | Returns the XML Schema for the XML representation of the data stored in the DataSet.
HasChanges (inherited from DataSet) | Overloaded. Gets a value indicating whether the DataSet has changes, including new, deleted, or modified rows.
InferXmlSchema (inherited from DataSet) | Overloaded. Applies the XML schema from the specified XmlReader to the DataSet.
Load (inherited from DataSet) | Overloaded. Fills a DataSet with values from a data source using the supplied IDataReader, using an array of DataTable instances to supply the schema and namespace information.
Merge (inherited from DataSet) | Overloaded. Merges a specified DataSet and its schema into the current DataSet.
ReadXml (inherited from DataSet) | Overloaded. Reads XML schema and data into the DataSet using the specified XmlReader.
ReadXmlSchema (inherited from DataSet) | Overloaded. Reads the XML schema from the specified Stream into the DataSet.
RejectChanges (inherited from DataSet) | Rolls back all the changes made to the DataSet since it was created, or since the last time AcceptChanges was called.
Reset (inherited from DataSet) | Resets the DataSet to its original state. Subclasses should override Reset to restore a DataSet to its original state.
ToString (inherited from MarshalByValueComponent) | Returns a String containing the name of the Component, if any. This method should not be overridden.
WriteXml (inherited from DataSet) | Overloaded. Writes the current data for the DataSet using the specified Stream.
WriteXmlSchema (inherited from DataSet) | Overloaded. Writes the DataSet structure as an XML schema to using the specified Stream object.

Public Instance Events

Disposed (inherited from MarshalByValueComponent) | Adds an event handler to listen to the Disposed event on the component.
Initialized (inherited from DataSet) | Occurs after the DataSet is initialized.
MergeFailed (inherited from DataSet) | Occurs when a target and source DataRow have the same primary key value, and EnforceConstraints is set to true.

Protected Instance Constructors

OptionsDataSet Overloaded. Initializes a new instance of the OptionsDataSet class.

Protected Instance Properties

Events (inherited from MarshalByValueComponent) Gets the list of event handlers that are attached to this component.

Protected Instance Methods

DetermineSchemaSerializationMode (inherited from DataSet) | Overloaded. Determines the SchemaSerializationMode for a DataSet.
Dispose (inherited from MarshalByValueComponent) | Overloaded. Releases the unmanaged resources used by the MarshalByValueComponent and optionally releases the managed resources.
Finalize (inherited from MarshalByValueComponent) | [To be supplied.]
GetSchemaSerializable |
GetSerializationData (inherited from DataSet) |
InitializeDerivedDataSet |
IsBinarySerialized (inherited from DataSet) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnPropertyChanging (inherited from DataSet) | Raises the OnPropertyChanging event.
OnRemoveRelation (inherited from DataSet) | Occurs when a DataRelation object is removed from a DataTable.
ReadXmlSerializable |
ShouldSerializeRelations |
ShouldSerializeTables |

Protected Internal Instance Methods

OnRemoveTable (inherited from DataSet) | Occurs when a DataTable is removed from a DataSet.
RaisePropertyChanging (inherited from DataSet) | Sends a notification that the specified DataSet property is about to change.

See Also

OptionsDataSet Class | Aptify.Applications.Advertising Namespace


OptionsDataSet Constructor

Initializes a new instance of the OptionsDataSet class.

Overload List

Initializes a new instance of the OptionsDataSet class.

public OptionsDataSet();

protected OptionsDataSet(SerializationInfo,StreamingContext);

See Also

OptionsDataSet Class | Aptify.Applications.Advertising Namespace


OptionsDataSet Constructor ()

Initializes a new instance of the OptionsDataSet class.

public OptionsDataSet();

See Also

OptionsDataSet Class | Aptify.Applications.Advertising Namespace | OptionsDataSet Constructor Overload List


OptionsDataSet Constructor (SerializationInfo, StreamingContext)

protected OptionsDataSet(
SerializationInfo info,
StreamingContext context
);

See Also

OptionsDataSet Class | Aptify.Applications.Advertising Namespace | OptionsDataSet Constructor Overload List


OptionsDataSet Properties

The properties of the OptionsDataSet class are listed below. For a complete list of OptionsDataSet class members, see the OptionsDataSet Members topic.

Public Instance Properties

CaseSensitive (inherited from DataSet) | Gets or sets a value indicating whether string comparisons within DataTable objects are case-sensitive.
Container (inherited from MarshalByValueComponent) | Gets the container for the component.
DataSetName (inherited from DataSet) | Gets or sets the name of the current DataSet.
DefaultViewManager (inherited from DataSet) | Gets a custom view of the data contained in the DataSet to allow filtering, searching, and navigating using a custom DataViewManager.
DesignMode (inherited from MarshalByValueComponent) | Gets a value indicating whether the component is currently in design mode.
EnforceConstraints (inherited from DataSet) | Gets or sets a value indicating whether constraint rules are followed when attempting any update operation.
ExtendedProperties (inherited from DataSet) | Gets the collection of customized user information associated with the DataSet.
HasErrors (inherited from DataSet) | Gets a value indicating whether there are errors in any of the DataTable objects within this DataSet.
IsInitialized (inherited from DataSet) | Gets a value that indicates whether the DataSet is initialized.
Locale (inherited from DataSet) | Gets or sets the locale information used to compare strings within the table.
Namespace (inherited from DataSet) | Gets or sets the namespace of the DataSet.
Options |
Prefix (inherited from DataSet) | Gets or sets an XML prefix that aliases the namespace of the DataSet.
Relations |
RemotingFormat (inherited from DataSet) | Gets or sets a SerializationFormat for the DataSet used during remoting.
SchemaSerializationMode |
Site (inherited from DataSet) | Gets or sets an ISite for the DataSet.
Tables |

Protected Instance Properties

Events (inherited from MarshalByValueComponent) Gets the list of event handlers that are attached to this component.

See Also

OptionsDataSet Class | Aptify.Applications.Advertising Namespace


Options Property

Aptify 5.0 Software Development Kit (SDK)

OptionsDataSet.Options Property

public OptionsDataSet.OptionsDataTable Options {get;}

See Also

OptionsDataSet Class | Aptify.Applications.Advertising Namespace


Relations Property

Aptify 5.0 Software Development Kit (SDK)

OptionsDataSet.Relations Property

new public DataRelationCollection Relations {get;}

See Also

OptionsDataSet Class | Aptify.Applications.Advertising Namespace


SchemaSerializationMode Property

Aptify 5.0 Software Development Kit (SDK)

OptionsDataSet.SchemaSerializationMode Property

public override SchemaSerializationMode SchemaSerializationMode {get; set;}

See Also

OptionsDataSet Class | Aptify.Applications.Advertising Namespace


Tables Property

Aptify 5.0 Software Development Kit (SDK)

OptionsDataSet.Tables Property

new public DataTableCollection Tables {get;}

See Also

OptionsDataSet Class | Aptify.Applications.Advertising Namespace


OptionsDataSet Methods

The methods of the OptionsDataSet class are listed below. For a complete list of OptionsDataSet class members, see the OptionsDataSet Members topic.

Public Static Methods

GetTypedDataSetSchema

Public Instance Methods

AcceptChanges (inherited from DataSet) | Commits all the changes made to this DataSet since it was loaded or since the last time AcceptChanges was called.
BeginInit (inherited from DataSet) | Begins the initialization of a DataSet that is used on a form or used by another component. The initialization occurs at run-time.
Clear (inherited from DataSet) | Clears the DataSet of any data by removing all rows in all tables.
Clone |
Copy (inherited from DataSet) | Copies both the structure and data for this DataSet.
CreateDataReader (inherited from DataSet) | Overloaded. Returns a DataTableReader with one result set per DataTable, in the same sequence as the tables appear in the Tables collection.
Dispose (inherited from MarshalByValueComponent) | Overloaded. Releases all resources used by the MarshalByValueComponent.
EndInit (inherited from DataSet) | Ends the initialization of a DataSet that is used on a form or used by another component. The initialization occurs at run time.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetChanges (inherited from DataSet) | Overloaded. Gets a copy of the DataSet that contains all changes made to it since it was loaded or since AcceptChanges was last called.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from DataSet) | Populates a serialization information object with the data needed to serialize the DataSet.
GetService (inherited from MarshalByValueComponent) | Gets the implementer of the IServiceProvider.
GetType (inherited from Object) | Gets the Type of the current instance.
GetXml (inherited from DataSet) | Returns the XML representation of the data stored in the DataSet.
GetXmlSchema (inherited from DataSet) | Returns the XML Schema for the XML representation of the data stored in the DataSet.
HasChanges (inherited from DataSet) | Overloaded. Gets a value indicating whether the DataSet has changes, including new, deleted, or modified rows.
InferXmlSchema (inherited from DataSet) | Overloaded. Applies the XML schema from the specified XmlReader to the DataSet.
Load (inherited from DataSet) | Overloaded. Fills a DataSet with values from a data source using the supplied IDataReader, using an array of DataTable instances to supply the schema and namespace information.
Merge (inherited from DataSet) | Overloaded. Merges a specified DataSet and its schema into the current DataSet.
ReadXml (inherited from DataSet) | Overloaded. Reads XML schema and data into the DataSet using the specified XmlReader.
ReadXmlSchema (inherited from DataSet) | Overloaded. Reads the XML schema from the specified Stream into the DataSet.
RejectChanges (inherited from DataSet) | Rolls back all the changes made to the DataSet since it was created, or since the last time AcceptChanges was called.
Reset (inherited from DataSet) | Resets the DataSet to its original state. Subclasses should override Reset to restore a DataSet to its original state.
ToString (inherited from MarshalByValueComponent) | Returns a String containing the name of the Component, if any. This method should not be overridden.
WriteXml (inherited from DataSet) | Overloaded. Writes the current data for the DataSet using the specified Stream.
WriteXmlSchema (inherited from DataSet) | Overloaded. Writes the DataSet structure as an XML schema to using the specified Stream object.

Protected Instance Methods

DetermineSchemaSerializationMode (inherited from DataSet) | Overloaded. Determines the SchemaSerializationMode for a DataSet.
Dispose (inherited from MarshalByValueComponent) | Overloaded. Releases the unmanaged resources used by the MarshalByValueComponent and optionally releases the managed resources.
Finalize (inherited from MarshalByValueComponent) | [To be supplied.]
GetSchemaSerializable |
GetSerializationData (inherited from DataSet) |
InitializeDerivedDataSet |
IsBinarySerialized (inherited from DataSet) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnPropertyChanging (inherited from DataSet) | Raises the OnPropertyChanging event.
OnRemoveRelation (inherited from DataSet) | Occurs when a DataRelation object is removed from a DataTable.
ReadXmlSerializable |
ShouldSerializeRelations |
ShouldSerializeTables |

Protected Internal Instance Methods

OnRemoveTable (inherited from DataSet) | Occurs when a DataTable is removed from a DataSet.
RaisePropertyChanging (inherited from DataSet) | Sends a notification that the specified DataSet property is about to change.

See Also

OptionsDataSet Class | Aptify.Applications.Advertising Namespace


OptionsDataSet.Clone Method

public override DataSet Clone();

See Also

OptionsDataSet Class | Aptify.Applications.Advertising Namespace


OptionsDataSet.GetSchemaSerializable Method

protected override XmlSchema GetSchemaSerializable();

See Also

OptionsDataSet Class | Aptify.Applications.Advertising Namespace


OptionsDataSet.GetTypedDataSetSchema Method

public static XmlSchemaComplexType GetTypedDataSetSchema(
XmlSchemaSet xs
);

See Also

OptionsDataSet Class | Aptify.Applications.Advertising Namespace


OptionsDataSet.InitializeDerivedDataSet Method

protected override void InitializeDerivedDataSet();

See Also

OptionsDataSet Class | Aptify.Applications.Advertising Namespace


OptionsDataSet.ReadXmlSerializable Method

protected override void ReadXmlSerializable(
XmlReader reader
);

See Also

OptionsDataSet Class | Aptify.Applications.Advertising Namespace


OptionsDataSet.ShouldSerializeRelations Method

protected override bool ShouldSerializeRelations();

See Also

OptionsDataSet Class | Aptify.Applications.Advertising Namespace


OptionsDataSet.ShouldSerializeTables Method

protected override bool ShouldSerializeTables();

See Also

OptionsDataSet Class | Aptify.Applications.Advertising Namespace


OptionsDataSet.OptionsDataTable Class

Represents the strongly named DataTable class.

For a list of all members of this type, see OptionsDataSet.OptionsDataTable Members.

System.Object
MarshalByValueComponent
DataTable
OptionsDataSet.OptionsDataTable

public class OptionsDataSet.OptionsDataTable : DataTable, IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Advertising

Assembly: AdvertisingInsertionOrderControls (in AdvertisingInsertionOrderControls.dll)

See Also

OptionsDataSet.OptionsDataTable Members | Aptify.Applications.Advertising Namespace


OptionsDataSet.OptionsDataTable Members

OptionsDataSet.OptionsDataTable overview

Public Static Methods

GetTypedTableSchema

Public Instance Constructors

OptionsDataSet.OptionsDataTable Overloaded. Initializes a new instance of the OptionsDataSet.OptionsDataTable class.

Public Instance Properties

AllowFreeColumn |
AllowPriceOverrideColumn |
AllowPriceSelectionColumn |
CaseSensitive (inherited from DataTable) | Indicates whether string comparisons within the table are case-sensitive.
ChildRelations (inherited from DataTable) | Gets the collection of child relations for this DataTable.
Columns (inherited from DataTable) | Gets the collection of columns that belong to this table.
CommentsColumn |
Constraints (inherited from DataTable) | Gets the collection of constraints maintained by this table.
Container (inherited from MarshalByValueComponent) | Gets the container for the component.
Count |
DataSet (inherited from DataTable) | Gets the DataSet to which this table belongs.
DefaultView (inherited from DataTable) | Gets a customized view of the table that may include a filtered view, or a cursor position.
DesignMode (inherited from MarshalByValueComponent) | Gets a value indicating whether the component is currently in design mode.
DisplayExpression (inherited from DataTable) | Gets or sets the expression that returns a value used to represent this table in the user interface.
EntityNameColumn |
EntityRecordColumn |
ExtendedColumn |
ExtendedProperties (inherited from DataTable) | Gets the collection of customized user information.
HasErrors (inherited from DataTable) | Gets a value indicating whether there are errors in any of the rows in any of the tables of the DataSet to which the table belongs.
IDColumn |
IsInitialized (inherited from DataTable) | Gets a value that indicates whether the DataTable is initialized.
IsSoldColumn |
Item |
LinkedEntityID_NameColumn |
LinkedEntityIDColumn |
Locale (inherited from DataTable) | Gets or sets the locale information used to compare strings within the table.
MinimumCapacity (inherited from DataTable) | Gets or sets the initial starting size for this table.
MinSellingUnitsColumn |
NameColumn |
Namespace (inherited from DataTable) | Gets or sets the namespace for the XML representation of the data stored in the DataTable.
OptionTypeColumn |
OriginalPriceColumn |
ParentRelations (inherited from DataTable) | Gets the collection of parent relations for this DataTable.
Prefix (inherited from DataTable) | Gets or sets the namespace for the XML representation of the data stored in the DataTable.
PriceColumn |
PriceOverrideColumn |
PrimaryKey (inherited from DataTable) | Gets or sets an array of columns that function as primary keys for the data table.
ProductID_NameColumn |
ProductIDColumn |
QuantityColumn |
RemotingFormat (inherited from DataTable) | Gets or sets the serialization format.
Rows (inherited from DataTable) | Gets the collection of rows that belong to this table.
SelectedColumn |
SequenceColumn |
Site (inherited from DataTable) | Gets or sets an ISite for the DataTable.
TableName (inherited from DataTable) | Gets or sets the name of the DataTable.
TopLevelItemColumn |

Public Instance Methods

AcceptChanges (inherited from DataTable) | Commits all the changes made to this table since the last time AcceptChanges was called.
AddOptionsRow | Overloaded.
BeginInit (inherited from DataTable) | Begins the initialization of a DataTable that is used on a form or used by another component. The initialization occurs at runtime.
BeginLoadData (inherited from DataTable) | Turns off notifications, index maintenance, and constraints while loading data.
Clear (inherited from DataTable) | Clears the DataTable of all data.
Clone |
Compute (inherited from DataTable) | Computes the given expression on the current rows that pass the filter criteria.
Copy (inherited from DataTable) | Copies both the structure and data for this DataTable.
CreateDataReader (inherited from DataTable) | Returns a DataTableReader corresponding to the data within this DataTable.
Dispose (inherited from MarshalByValueComponent) | Overloaded. Releases all resources used by the MarshalByValueComponent.
EndInit (inherited from DataTable) | Ends the initialization of a DataTable that is used on a form or used by another component. The initialization occurs at runtime.
EndLoadData (inherited from DataTable) | Turns on notifications, index maintenance, and constraints after loading data.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByID |
GetChanges (inherited from DataTable) | Overloaded. Gets a copy of the DataTable that contains all changes made to it since it was loaded or AcceptChanges was last called.
GetEnumerator |
GetErrors (inherited from DataTable) | Gets an array of DataRow objects that contain errors.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from DataTable) | Populates a serialization information object with the data needed to serialize the DataTable.
GetService (inherited from MarshalByValueComponent) | Gets the implementer of the IServiceProvider.
GetType (inherited from Object) | Gets the Type of the current instance.
ImportRow (inherited from DataTable) | Copies a DataRow into a DataTable, preserving any property settings, as well as original and current values.
Load (inherited from DataTable) | Overloaded. Fills a DataTable with values from a data source using the supplied IDataReader. If the DataTable already contains rows, the incoming data from the data source is merged with the existing rows.
LoadDataRow (inherited from DataTable) | Overloaded. Finds and updates a specific row. If no matching row is found, a new row is created using the given values.
Merge (inherited from DataTable) | Overloaded. Merge the specified DataTable with the current DataTable.
NewOptionsRow |
NewRow (inherited from DataTable) | Creates a new DataRow with the same schema as the table.
ReadXml (inherited from DataTable) | Overloaded. Reads XML schema and data into the DataTable using the specified Stream.
ReadXmlSchema (inherited from DataTable) | Overloaded. Reads an XML schema into the DataTable using the specified stream.
RejectChanges (inherited from DataTable) | Rolls back all changes that have been made to the table since it was loaded, or the last time AcceptChanges was called.
RemoveOptionsRow |
Reset (inherited from DataTable) | Resets the DataTable to its original state.
Select (inherited from DataTable) | Overloaded. Gets an array of all DataRow objects.
ToString (inherited from DataTable) | Gets the TableName and DisplayExpression, if there is one as a concatenated string.
WriteXml (inherited from DataTable) | Overloaded. Writes the current data, and optionally the schema, for the DataTable using the specified TextWriter and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. To save the data for the table and all its descendants, set the writeHierarchy parameter to true.
WriteXmlSchema (inherited from DataTable) | Overloaded. Writes the current data structure of the DataTable as an XML schema to the specified stream.

Public Instance Events

ColumnChanged (inherited from DataTable) | Occurs after a value has been changed for the specified DataColumn in a DataRow.
ColumnChanging (inherited from DataTable) | Occurs when a value is being changed for the specified DataColumn in a DataRow.
Disposed (inherited from MarshalByValueComponent) | Adds an event handler to listen to the Disposed event on the component.
Initialized (inherited from DataTable) | Occurs after the DataTable is initialized.
OptionsRowChanged |
OptionsRowChanging |
OptionsRowDeleted |
OptionsRowDeleting |
RowChanged (inherited from DataTable) | Occurs after a DataRow has been changed successfully.
RowChanging (inherited from DataTable) | Occurs when a DataRow is changing.
RowDeleted (inherited from DataTable) | Occurs after a row in the table has been deleted.
RowDeleting (inherited from DataTable) | Occurs before a row in the table is about to be deleted.
TableCleared (inherited from DataTable) | Occurs after a DataTable is cleared.
TableClearing (inherited from DataTable) | Occurs when a DataTable is cleared.
TableNewRow (inherited from DataTable) | Occurs when a new DataRow is inserted.

Protected Instance Constructors

OptionsDataSet.OptionsDataTable Overloaded. Initializes a new instance of the OptionsDataSet.OptionsDataTable class.

Protected Instance Properties

Events (inherited from MarshalByValueComponent) Gets the list of event handlers that are attached to this component.

Protected Instance Methods

CreateInstance |
Dispose (inherited from MarshalByValueComponent) | Overloaded. Releases the unmanaged resources used by the MarshalByValueComponent and optionally releases the managed resources.
Finalize (inherited from MarshalByValueComponent) | [To be supplied.]
GetRowType |
GetSchema (inherited from DataTable) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NewRowFromBuilder |
OnPropertyChanging (inherited from DataTable) | Raises the PropertyChanging event.
OnRemoveColumn (inherited from DataTable) | Notifies the DataTable that a DataColumn is being removed.
OnRowChanged |
OnRowChanging |
OnRowDeleted |
OnRowDeleting |
OnTableCleared (inherited from DataTable) | Raises the TableCleared event.
OnTableClearing (inherited from DataTable) | Raises the TableClearing event.
OnTableNewRow (inherited from DataTable) | Raises the TableNewRow event.
ReadXmlSerializable (inherited from DataTable) |

Protected Internal Instance Fields

fInitInProgress (inherited from DataTable)

Protected Internal Instance Methods

NewRowArray (inherited from DataTable) |
OnColumnChanged (inherited from DataTable) | Raises the ColumnChanged event.
OnColumnChanging (inherited from DataTable) | Raises the ColumnChanging event.

See Also

OptionsDataSet.OptionsDataTable Class | Aptify.Applications.Advertising Namespace


OptionsDataSet.OptionsDataTable Constructor

Initializes a new instance of the OptionsDataSet.OptionsDataTable class.

Overload List

Initializes a new instance of the OptionsDataSet.OptionsDataTable class.

public OptionsDataSet.OptionsDataTable();

public OptionsDataSet.OptionsDataTable(Boolean);

protected OptionsDataSet.OptionsDataTable(SerializationInfo,StreamingContext);

See Also

OptionsDataSet.OptionsDataTable Class | Aptify.Applications.Advertising Namespace


OptionsDataSet.OptionsDataTable Constructor ()

Initializes a new instance of the OptionsDataSet.OptionsDataTable class.

public OptionsDataSet.OptionsDataTable();

See Also

OptionsDataSet.OptionsDataTable Class | Aptify.Applications.Advertising Namespace | OptionsDataSet.OptionsDataTable Constructor Overload List


OptionsDataSet.OptionsDataTable Constructor (Boolean)

public OptionsDataSet.OptionsDataTable(
Boolean initExpressions
);

See Also

OptionsDataSet.OptionsDataTable Class | Aptify.Applications.Advertising Namespace | OptionsDataSet.OptionsDataTable Constructor Overload List


OptionsDataSet.OptionsDataTable Constructor (SerializationInfo, StreamingContext)

protected OptionsDataSet.OptionsDataTable(
SerializationInfo info,
StreamingContext context
);

See Also

OptionsDataSet.OptionsDataTable Class | Aptify.Applications.Advertising Namespace | OptionsDataSet.OptionsDataTable Constructor Overload List


OptionsDataSet.OptionsDataTable Properties

The properties of the OptionsDataSet.OptionsDataTable class are listed below. For a complete list of OptionsDataSet.OptionsDataTable class members, see the OptionsDataSet.OptionsDataTable Members topic.

Public Instance Properties

AllowFreeColumn |
AllowPriceOverrideColumn |
AllowPriceSelectionColumn |
CaseSensitive (inherited from DataTable) | Indicates whether string comparisons within the table are case-sensitive.
ChildRelations (inherited from DataTable) | Gets the collection of child relations for this DataTable.
Columns (inherited from DataTable) | Gets the collection of columns that belong to this table.
CommentsColumn |
Constraints (inherited from DataTable) | Gets the collection of constraints maintained by this table.
Container (inherited from MarshalByValueComponent) | Gets the container for the component.
Count |
DataSet (inherited from DataTable) | Gets the DataSet to which this table belongs.
DefaultView (inherited from DataTable) | Gets a customized view of the table that may include a filtered view, or a cursor position.
DesignMode (inherited from MarshalByValueComponent) | Gets a value indicating whether the component is currently in design mode.
DisplayExpression (inherited from DataTable) | Gets or sets the expression that returns a value used to represent this table in the user interface.
EntityNameColumn |
EntityRecordColumn |
ExtendedColumn |
ExtendedProperties (inherited from DataTable) | Gets the collection of customized user information.
HasErrors (inherited from DataTable) | Gets a value indicating whether there are errors in any of the rows in any of the tables of the DataSet to which the table belongs.
IDColumn |
IsInitialized (inherited from DataTable) | Gets a value that indicates whether the DataTable is initialized.
IsSoldColumn |
Item |
LinkedEntityID_NameColumn |
LinkedEntityIDColumn |
Locale (inherited from DataTable) | Gets or sets the locale information used to compare strings within the table.
MinimumCapacity (inherited from DataTable) | Gets or sets the initial starting size for this table.
MinSellingUnitsColumn |
NameColumn |
Namespace (inherited from DataTable) | Gets or sets the namespace for the XML representation of the data stored in the DataTable.
OptionTypeColumn |
OriginalPriceColumn |
ParentRelations (inherited from DataTable) | Gets the collection of parent relations for this DataTable.
Prefix (inherited from DataTable) | Gets or sets the namespace for the XML representation of the data stored in the DataTable.
PriceColumn |
PriceOverrideColumn |
PrimaryKey (inherited from DataTable) | Gets or sets an array of columns that function as primary keys for the data table.
ProductID_NameColumn |
ProductIDColumn |
QuantityColumn |
RemotingFormat (inherited from DataTable) | Gets or sets the serialization format.
Rows (inherited from DataTable) | Gets the collection of rows that belong to this table.
SelectedColumn |
SequenceColumn |
Site (inherited from DataTable) | Gets or sets an ISite for the DataTable.
TableName (inherited from DataTable) | Gets or sets the name of the DataTable.
TopLevelItemColumn |

Protected Instance Properties

Events (inherited from MarshalByValueComponent) Gets the list of event handlers that are attached to this component.

See Also

OptionsDataSet.OptionsDataTable Class | Aptify.Applications.Advertising Namespace


AllowFreeColumn Property

Aptify 5.0 Software Development Kit (SDK)

OptionsDataSet.OptionsDataTable.AllowFreeColumn Property

public DataColumn AllowFreeColumn {get;}

See Also

OptionsDataSet.OptionsDataTable Class | Aptify.Applications.Advertising Namespace


AllowPriceOverrideColumn Property

Aptify 5.0 Software Development Kit (SDK)

OptionsDataSet.OptionsDataTable.AllowPriceOverrideColumn Property

public DataColumn AllowPriceOverrideColumn {get;}

See Also

OptionsDataSet.OptionsDataTable Class | Aptify.Applications.Advertising Namespace


AllowPriceSelectionColumn Property

Aptify 5.0 Software Development Kit (SDK)

OptionsDataSet.OptionsDataTable.AllowPriceSelectionColumn Property

public DataColumn AllowPriceSelectionColumn {get;}

See Also

OptionsDataSet.OptionsDataTable Class | Aptify.Applications.Advertising Namespace


CommentsColumn Property

Aptify 5.0 Software Development Kit (SDK)

OptionsDataSet.OptionsDataTable.CommentsColumn Property

public DataColumn CommentsColumn {get;}

See Also

OptionsDataSet.OptionsDataTable Class | Aptify.Applications.Advertising Namespace


Count Property

Aptify 5.0 Software Development Kit (SDK)

OptionsDataSet.OptionsDataTable.Count Property

public Int32 Count {get;}

See Also

OptionsDataSet.OptionsDataTable Class | Aptify.Applications.Advertising Namespace


EntityNameColumn Property

Aptify 5.0 Software Development Kit (SDK)

OptionsDataSet.OptionsDataTable.EntityNameColumn Property

public DataColumn EntityNameColumn {get;}

See Also

OptionsDataSet.OptionsDataTable Class | Aptify.Applications.Advertising Namespace


EntityRecordColumn Property

Aptify 5.0 Software Development Kit (SDK)

OptionsDataSet.OptionsDataTable.EntityRecordColumn Property

public DataColumn EntityRecordColumn {get;}

See Also

OptionsDataSet.OptionsDataTable Class | Aptify.Applications.Advertising Namespace


ExtendedColumn Property

Aptify 5.0 Software Development Kit (SDK)

OptionsDataSet.OptionsDataTable.ExtendedColumn Property

public DataColumn ExtendedColumn {get;}

See Also

OptionsDataSet.OptionsDataTable Class | Aptify.Applications.Advertising Namespace


IDColumn Property

Aptify 5.0 Software Development Kit (SDK)

OptionsDataSet.OptionsDataTable.IDColumn Property

public DataColumn IDColumn {get;}

See Also

OptionsDataSet.OptionsDataTable Class | Aptify.Applications.Advertising Namespace


IsSoldColumn Property

Aptify 5.0 Software Development Kit (SDK)

OptionsDataSet.OptionsDataTable.IsSoldColumn Property

public DataColumn IsSoldColumn {get;}

See Also

OptionsDataSet.OptionsDataTable Class | Aptify.Applications.Advertising Namespace


Item Property

Aptify 5.0 Software Development Kit (SDK)

OptionsDataSet.OptionsDataTable.Item Property

public OptionsDataSet.OptionsRow this[
Int32 index
] {get;}

See Also

OptionsDataSet.OptionsDataTable Class | Aptify.Applications.Advertising Namespace


LinkedEntityID_NameColumn Property

Aptify 5.0 Software Development Kit (SDK)

OptionsDataSet.OptionsDataTable.LinkedEntityID_NameColumn Property

public DataColumn LinkedEntityID_NameColumn {get;}

See Also

OptionsDataSet.OptionsDataTable Class | Aptify.Applications.Advertising Namespace


LinkedEntityIDColumn Property

Aptify 5.0 Software Development Kit (SDK)

OptionsDataSet.OptionsDataTable.LinkedEntityIDColumn Property

public DataColumn LinkedEntityIDColumn {get;}

See Also

OptionsDataSet.OptionsDataTable Class | Aptify.Applications.Advertising Namespace


MinSellingUnitsColumn Property

Aptify 5.0 Software Development Kit (SDK)

OptionsDataSet.OptionsDataTable.MinSellingUnitsColumn Property

public DataColumn MinSellingUnitsColumn {get;}

See Also

OptionsDataSet.OptionsDataTable Class | Aptify.Applications.Advertising Namespace


NameColumn Property

Aptify 5.0 Software Development Kit (SDK)

OptionsDataSet.OptionsDataTable.NameColumn Property

public DataColumn NameColumn {get;}

See Also

OptionsDataSet.OptionsDataTable Class | Aptify.Applications.Advertising Namespace


OptionTypeColumn Property

Aptify 5.0 Software Development Kit (SDK)

OptionsDataSet.OptionsDataTable.OptionTypeColumn Property

public DataColumn OptionTypeColumn {get;}

See Also

OptionsDataSet.OptionsDataTable Class | Aptify.Applications.Advertising Namespace


OriginalPriceColumn Property

Aptify 5.0 Software Development Kit (SDK)

OptionsDataSet.OptionsDataTable.OriginalPriceColumn Property

public DataColumn OriginalPriceColumn {get;}

See Also

OptionsDataSet.OptionsDataTable Class | Aptify.Applications.Advertising Namespace


PriceColumn Property

Aptify 5.0 Software Development Kit (SDK)

OptionsDataSet.OptionsDataTable.PriceColumn Property

public DataColumn PriceColumn {get;}

See Also

OptionsDataSet.OptionsDataTable Class | Aptify.Applications.Advertising Namespace


PriceOverrideColumn Property

Aptify 5.0 Software Development Kit (SDK)

OptionsDataSet.OptionsDataTable.PriceOverrideColumn Property

public DataColumn PriceOverrideColumn {get;}

See Also

OptionsDataSet.OptionsDataTable Class | Aptify.Applications.Advertising Namespace


ProductID_NameColumn Property

Aptify 5.0 Software Development Kit (SDK)

OptionsDataSet.OptionsDataTable.ProductID_NameColumn Property

public DataColumn ProductID_NameColumn {get;}

See Also

OptionsDataSet.OptionsDataTable Class | Aptify.Applications.Advertising Namespace


ProductIDColumn Property

Aptify 5.0 Software Development Kit (SDK)

OptionsDataSet.OptionsDataTable.ProductIDColumn Property

public DataColumn ProductIDColumn {get;}

See Also

OptionsDataSet.OptionsDataTable Class | Aptify.Applications.Advertising Namespace


QuantityColumn Property

Aptify 5.0 Software Development Kit (SDK)

OptionsDataSet.OptionsDataTable.QuantityColumn Property

public DataColumn QuantityColumn {get;}

See Also

OptionsDataSet.OptionsDataTable Class | Aptify.Applications.Advertising Namespace


SelectedColumn Property

Aptify 5.0 Software Development Kit (SDK)

OptionsDataSet.OptionsDataTable.SelectedColumn Property

public DataColumn SelectedColumn {get;}

See Also

OptionsDataSet.OptionsDataTable Class | Aptify.Applications.Advertising Namespace


SequenceColumn Property

Aptify 5.0 Software Development Kit (SDK)

OptionsDataSet.OptionsDataTable.SequenceColumn Property

public DataColumn SequenceColumn {get;}

See Also

OptionsDataSet.OptionsDataTable Class | Aptify.Applications.Advertising Namespace


TopLevelItemColumn Property

Aptify 5.0 Software Development Kit (SDK)

OptionsDataSet.OptionsDataTable.TopLevelItemColumn Property

public DataColumn TopLevelItemColumn {get;}

See Also

OptionsDataSet.OptionsDataTable Class | Aptify.Applications.Advertising Namespace


OptionsDataSet.OptionsDataTable Methods

The methods of the OptionsDataSet.OptionsDataTable class are listed below. For a complete list of OptionsDataSet.OptionsDataTable class members, see the OptionsDataSet.OptionsDataTable Members topic.

Public Static Methods

GetTypedTableSchema

Public Instance Methods

AcceptChanges (inherited from DataTable) | Commits all the changes made to this table since the last time AcceptChanges was called.
AddOptionsRow | Overloaded.
BeginInit (inherited from DataTable) | Begins the initialization of a DataTable that is used on a form or used by another component. The initialization occurs at runtime.
BeginLoadData (inherited from DataTable) | Turns off notifications, index maintenance, and constraints while loading data.
Clear (inherited from DataTable) | Clears the DataTable of all data.
Clone |
Compute (inherited from DataTable) | Computes the given expression on the current rows that pass the filter criteria.
Copy (inherited from DataTable) | Copies both the structure and data for this DataTable.
CreateDataReader (inherited from DataTable) | Returns a DataTableReader corresponding to the data within this DataTable.
Dispose (inherited from MarshalByValueComponent) | Overloaded. Releases all resources used by the MarshalByValueComponent.
EndInit (inherited from DataTable) | Ends the initialization of a DataTable that is used on a form or used by another component. The initialization occurs at runtime.
EndLoadData (inherited from DataTable) | Turns on notifications, index maintenance, and constraints after loading data.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByID |
GetChanges (inherited from DataTable) | Overloaded. Gets a copy of the DataTable that contains all changes made to it since it was loaded or AcceptChanges was last called.
GetEnumerator |
GetErrors (inherited from DataTable) | Gets an array of DataRow objects that contain errors.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from DataTable) | Populates a serialization information object with the data needed to serialize the DataTable.
GetService (inherited from MarshalByValueComponent) | Gets the implementer of the IServiceProvider.
GetType (inherited from Object) | Gets the Type of the current instance.
ImportRow (inherited from DataTable) | Copies a DataRow into a DataTable, preserving any property settings, as well as original and current values.
Load (inherited from DataTable) | Overloaded. Fills a DataTable with values from a data source using the supplied IDataReader. If the DataTable already contains rows, the incoming data from the data source is merged with the existing rows.
LoadDataRow (inherited from DataTable) | Overloaded. Finds and updates a specific row. If no matching row is found, a new row is created using the given values.
Merge (inherited from DataTable) | Overloaded. Merge the specified DataTable with the current DataTable.
NewOptionsRow |
NewRow (inherited from DataTable) | Creates a new DataRow with the same schema as the table.
ReadXml (inherited from DataTable) | Overloaded. Reads XML schema and data into the DataTable using the specified Stream.
ReadXmlSchema (inherited from DataTable) | Overloaded. Reads an XML schema into the DataTable using the specified stream.
RejectChanges (inherited from DataTable) | Rolls back all changes that have been made to the table since it was loaded, or the last time AcceptChanges was called.
RemoveOptionsRow |
Reset (inherited from DataTable) | Resets the DataTable to its original state.
Select (inherited from DataTable) | Overloaded. Gets an array of all DataRow objects.
ToString (inherited from DataTable) | Gets the TableName and DisplayExpression, if there is one as a concatenated string.
WriteXml (inherited from DataTable) | Overloaded. Writes the current data, and optionally the schema, for the DataTable using the specified TextWriter and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. To save the data for the table and all its descendants, set the writeHierarchy parameter to true.
WriteXmlSchema (inherited from DataTable) | Overloaded. Writes the current data structure of the DataTable as an XML schema to the specified stream.

Protected Instance Methods

CreateInstance |
Dispose (inherited from MarshalByValueComponent) | Overloaded. Releases the unmanaged resources used by the MarshalByValueComponent and optionally releases the managed resources.
Finalize (inherited from MarshalByValueComponent) | [To be supplied.]
GetRowType |
GetSchema (inherited from DataTable) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NewRowFromBuilder |
OnPropertyChanging (inherited from DataTable) | Raises the PropertyChanging event.
OnRemoveColumn (inherited from DataTable) | Notifies the DataTable that a DataColumn is being removed.
OnRowChanged |
OnRowChanging |
OnRowDeleted |
OnRowDeleting |
OnTableCleared (inherited from DataTable) | Raises the TableCleared event.
OnTableClearing (inherited from DataTable) | Raises the TableClearing event.
OnTableNewRow (inherited from DataTable) | Raises the TableNewRow event.
ReadXmlSerializable (inherited from DataTable) |

Protected Internal Instance Methods

NewRowArray (inherited from DataTable) |
OnColumnChanged (inherited from DataTable) | Raises the ColumnChanged event.
OnColumnChanging (inherited from DataTable) | Raises the ColumnChanging event.

See Also

OptionsDataSet.OptionsDataTable Class | Aptify.Applications.Advertising Namespace


AddOptionsRow Method

Aptify 5.0 Software Development Kit (SDK)

OptionsDataSet.OptionsDataTable.AddOptionsRow Method

Overload List

public void AddOptionsRow(OptionsDataSet.OptionsRow);

public OptionsRow AddOptionsRow(Boolean,Boolean,Boolean,Double,Boolean,Boolean,Boolean,Int32,String,Int32,String,String,Int32,String,String,Int32,Decimal,Int64,String,Decimal,Boolean,Int32);

public OptionsRow AddOptionsRow(Boolean,Boolean,Boolean,Double,Boolean,Boolean,Boolean,Int32,String,Int32,String,String,Int32,String,String,Int32,Decimal,Int64,String,Decimal,Decimal,Boolean,Int32);

See Also

OptionsDataSet.OptionsDataTable Class | Aptify.Applications.Advertising Namespace


OptionsDataSet.OptionsDataTable.AddOptionsRow Method (OptionsRow)

public void AddOptionsRow(
OptionsDataSet.OptionsRow row
);

See Also

OptionsDataSet.OptionsDataTable Class | Aptify.Applications.Advertising Namespace | OptionsDataSet.OptionsDataTable.AddOptionsRow Overload List


OptionsDataSet.OptionsDataTable.AddOptionsRow Method (Boolean, Boolean, Boolean, Double, Boolean, Boolean, Boolean, Int32, String, Int32, String, String, Int32, String, String, Int32, Decimal, Int64, String, Decimal, Boolean, Int32)

public OptionsRow AddOptionsRow(
Boolean Selected,
Boolean IsSold,
Boolean TopLevelItem,
Double MinSellingUnits,
Boolean AllowPriceOverride,
Boolean AllowFree,
Boolean AllowPriceSelection,
Int32 ID,
String Name,
Int32 ProductID,
String ProductID_Name,
String OptionType,
Int32 LinkedEntityID,
String LinkedEntityID_Name,
String EntityName,
Int32 Quantity,
Decimal Price,
Int64 EntityRecord,
String Comments,
Decimal OriginalPrice,
Boolean PriceOverride,
Int32 Sequence
);

See Also

OptionsDataSet.OptionsDataTable Class | Aptify.Applications.Advertising Namespace | OptionsDataSet.OptionsDataTable.AddOptionsRow Overload List


OptionsDataSet.OptionsDataTable.AddOptionsRow Method (Boolean, Boolean, Boolean, Double, Boolean, Boolean, Boolean, Int32, String, Int32, String, String, Int32, String, String, Int32, Decimal, Int64, String, Decimal, Decimal, Boolean, Int32)

public OptionsRow AddOptionsRow(
Boolean Selected,
Boolean IsSold,
Boolean TopLevelItem,
Double MinSellingUnits,
Boolean AllowPriceOverride,
Boolean AllowFree,
Boolean AllowPriceSelection,
Int32 ID,
String Name,
Int32 ProductID,
String ProductID_Name,
String OptionType,
Int32 LinkedEntityID,
String LinkedEntityID_Name,
String EntityName,
Int32 Quantity,
Decimal Price,
Int64 EntityRecord,
String Comments,
Decimal OriginalPrice,
Decimal Extended,
Boolean PriceOverride,
Int32 Sequence
);

See Also

OptionsDataSet.OptionsDataTable Class | Aptify.Applications.Advertising Namespace | OptionsDataSet.OptionsDataTable.AddOptionsRow Overload List


OptionsDataSet.OptionsDataTable.Clone Method

public override DataTable Clone();

See Also

OptionsDataSet.OptionsDataTable Class | Aptify.Applications.Advertising Namespace


OptionsDataSet.OptionsDataTable.CreateInstance Method

protected override DataTable CreateInstance();

See Also

OptionsDataSet.OptionsDataTable Class | Aptify.Applications.Advertising Namespace


OptionsDataSet.OptionsDataTable.FindByID Method

public OptionsRow FindByID(
Int32 ID
);

See Also

OptionsDataSet.OptionsDataTable Class | Aptify.Applications.Advertising Namespace


OptionsDataSet.OptionsDataTable.GetEnumerator Method

public virtual IEnumerator GetEnumerator();

Implements

IEnumerable.

See Also

OptionsDataSet.OptionsDataTable Class | Aptify.Applications.Advertising Namespace


OptionsDataSet.OptionsDataTable.GetRowType Method

protected override Type GetRowType();

See Also

OptionsDataSet.OptionsDataTable Class | Aptify.Applications.Advertising Namespace


OptionsDataSet.OptionsDataTable.GetTypedTableSchema Method

public static XmlSchemaComplexType GetTypedTableSchema(
XmlSchemaSet xs
);

See Also

OptionsDataSet.OptionsDataTable Class | Aptify.Applications.Advertising Namespace


OptionsDataSet.OptionsDataTable.NewOptionsRow Method

public OptionsRow NewOptionsRow();

See Also

OptionsDataSet.OptionsDataTable Class | Aptify.Applications.Advertising Namespace


OptionsDataSet.OptionsDataTable.NewRowFromBuilder Method

protected override DataRow NewRowFromBuilder(
DataRowBuilder builder
);

See Also

OptionsDataSet.OptionsDataTable Class | Aptify.Applications.Advertising Namespace


OptionsDataSet.OptionsDataTable.OnRowChanged Method

protected override void OnRowChanged(
DataRowChangeEventArgs e
);

See Also

OptionsDataSet.OptionsDataTable Class | Aptify.Applications.Advertising Namespace


OptionsDataSet.OptionsDataTable.OnRowChanging Method

protected override void OnRowChanging(
DataRowChangeEventArgs e
);

See Also

OptionsDataSet.OptionsDataTable Class | Aptify.Applications.Advertising Namespace


OptionsDataSet.OptionsDataTable.OnRowDeleted Method

protected override void OnRowDeleted(
DataRowChangeEventArgs e
);

See Also

OptionsDataSet.OptionsDataTable Class | Aptify.Applications.Advertising Namespace


OptionsDataSet.OptionsDataTable.OnRowDeleting Method

protected override void OnRowDeleting(
DataRowChangeEventArgs e
);

See Also

OptionsDataSet.OptionsDataTable Class | Aptify.Applications.Advertising Namespace


OptionsDataSet.OptionsDataTable.RemoveOptionsRow Method

public void RemoveOptionsRow(
OptionsDataSet.OptionsRow row
);

See Also

OptionsDataSet.OptionsDataTable Class | Aptify.Applications.Advertising Namespace


OptionsDataSet.OptionsDataTable Events

The events of the OptionsDataSet.OptionsDataTable class are listed below. For a complete list of OptionsDataSet.OptionsDataTable class members, see the OptionsDataSet.OptionsDataTable Members topic.

Public Instance Events

ColumnChanged (inherited from DataTable) | Occurs after a value has been changed for the specified DataColumn in a DataRow.
ColumnChanging (inherited from DataTable) | Occurs when a value is being changed for the specified DataColumn in a DataRow.
Disposed (inherited from MarshalByValueComponent) | Adds an event handler to listen to the Disposed event on the component.
Initialized (inherited from DataTable) | Occurs after the DataTable is initialized.
OptionsRowChanged |
OptionsRowChanging |
OptionsRowDeleted |
OptionsRowDeleting |
RowChanged (inherited from DataTable) | Occurs after a DataRow has been changed successfully.
RowChanging (inherited from DataTable) | Occurs when a DataRow is changing.
RowDeleted (inherited from DataTable) | Occurs after a row in the table has been deleted.
RowDeleting (inherited from DataTable) | Occurs before a row in the table is about to be deleted.
TableCleared (inherited from DataTable) | Occurs after a DataTable is cleared.
TableClearing (inherited from DataTable) | Occurs when a DataTable is cleared.
TableNewRow (inherited from DataTable) | Occurs when a new DataRow is inserted.

See Also

OptionsDataSet.OptionsDataTable Class | Aptify.Applications.Advertising Namespace


OptionsDataSet.OptionsDataTable.OptionsDataSet.OptionsRowChangeEventHandler Event

public event OptionsDataSet.OptionsRowChangeEventHandler OptionsRowChanged;

See Also

OptionsDataSet.OptionsDataTable Class | Aptify.Applications.Advertising Namespace


OptionsDataSet.OptionsDataTable.OptionsDataSet.OptionsRowChangeEventHandler Event

public event OptionsDataSet.OptionsRowChangeEventHandler OptionsRowChanging;

See Also

OptionsDataSet.OptionsDataTable Class | Aptify.Applications.Advertising Namespace


OptionsDataSet.OptionsDataTable.OptionsDataSet.OptionsRowChangeEventHandler Event

public event OptionsDataSet.OptionsRowChangeEventHandler OptionsRowDeleted;

See Also

OptionsDataSet.OptionsDataTable Class | Aptify.Applications.Advertising Namespace


OptionsDataSet.OptionsDataTable.OptionsDataSet.OptionsRowChangeEventHandler Event

public event OptionsDataSet.OptionsRowChangeEventHandler OptionsRowDeleting;

See Also

OptionsDataSet.OptionsDataTable Class | Aptify.Applications.Advertising Namespace


OptionsDataSet.OptionsRow Class

Represents strongly named DataRow class.

For a list of all members of this type, see OptionsDataSet.OptionsRow Members.

System.Object
DataRow
OptionsDataSet.OptionsRow

public class OptionsDataSet.OptionsRow : DataRow

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Advertising

Assembly: AdvertisingInsertionOrderControls (in AdvertisingInsertionOrderControls.dll)

See Also

OptionsDataSet.OptionsRow Members | Aptify.Applications.Advertising Namespace


OptionsDataSet.OptionsRow Members

OptionsDataSet.OptionsRow overview

Public Instance Properties

AllowFree |
AllowPriceOverride |
AllowPriceSelection |
Comments |
EntityName |
EntityRecord |
Extended |
HasErrors (inherited from DataRow) | Gets a value that indicates whether there are errors in a row.
ID |
IsSold |
Item (inherited from DataRow) | Gets or sets the data stored in the column specified by index.
Item (inherited from DataRow) | Gets or sets the data stored in the column specified by name.
Item (inherited from DataRow) | Gets or sets the data stored in the specified DataColumn.
Item (inherited from DataRow) | Gets the data stored in the column, specified by index and version of the data to retrieve.
Item (inherited from DataRow) | Gets the specified version of data stored in the named column.
Item (inherited from DataRow) | Gets the specified version of data stored in the specified DataColumn.
ItemArray (inherited from DataRow) | Gets or sets all the values for this row through an array.
LinkedEntityID |
LinkedEntityID_Name |
MinSellingUnits |
Name |
OptionType |
OriginalPrice |
Price |
PriceOverride |
ProductID |
ProductID_Name |
Quantity |
RowError (inherited from DataRow) | Gets or sets the custom error description for a row.
RowState (inherited from DataRow) | Gets the current state of the row with regard to its relationship to the DataRowCollection.
Selected |
Sequence |
Table (inherited from DataRow) | Gets the DataTable for which this row has a schema.
TopLevelItem |

Public Instance Methods

AcceptChanges (inherited from DataRow) | Commits all the changes made to this row since the last time AcceptChanges was called.
BeginEdit (inherited from DataRow) | Starts an edit operation on a DataRow object.
CancelEdit (inherited from DataRow) | Cancels the current edit on the row.
ClearErrors (inherited from DataRow) | Clears the errors for the row. This includes the RowError and errors set with SetColumnError.
Delete (inherited from DataRow) | Deletes the DataRow.
EndEdit (inherited from DataRow) | Ends the edit occurring on the row.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetChildRows (inherited from DataRow) | Overloaded. Gets the child rows of a DataRow using the specified RelationName of a DataRelation.
GetColumnError (inherited from DataRow) | Overloaded. Gets the error description for the column specified by index.
GetColumnsInError (inherited from DataRow) | Gets an array of columns that have errors.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetParentRow (inherited from DataRow) | Overloaded. Gets the parent row of a DataRow using the specified RelationName of a DataRelation.
GetParentRows (inherited from DataRow) | Overloaded. Gets the parent rows of a DataRow using the specified RelationName of a DataRelation.
GetType (inherited from Object) | Gets the Type of the current instance.
HasVersion (inherited from DataRow) | Gets a value that indicates whether a specified version exists.
IsCommentsNull |
IsEntityNameNull |
IsEntityRecordNull |
IsExtendedNull |
IsLinkedEntityID_NameNull |
IsLinkedEntityIDNull |
IsNull (inherited from DataRow) | Overloaded. Gets a value that indicates whether the column at the specified index contains a null value.
IsOriginalPriceNull |
IsPriceNull |
IsPriceOverrideNull |
IsQuantityNull |
IsSelectedNull |
IsSequenceNull |
RejectChanges (inherited from DataRow) | Rejects all changes made to the row since AcceptChanges was last called.
SetAdded (inherited from DataRow) | Changes the Rowstate of a DataRow to Added.
SetColumnError (inherited from DataRow) | Overloaded. Sets the error description for a column specified by index.
SetCommentsNull |
SetEntityNameNull |
SetEntityRecordNull |
SetExtendedNull |
SetLinkedEntityID_NameNull |
SetLinkedEntityIDNull |
SetModified (inherited from DataRow) | Changes the Rowstate of a DataRow to Modified.
SetOriginalPriceNull |
SetParentRow (inherited from DataRow) | Overloaded. Sets the parent row of a DataRow with specified new parent DataRow.
SetPriceNull |
SetPriceOverrideNull |
SetQuantityNull |
SetSelectedNull |
SetSequenceNull |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetNull (inherited from DataRow) | Sets the value of the specified DataColumn to a null value.

See Also

OptionsDataSet.OptionsRow Class | Aptify.Applications.Advertising Namespace


OptionsDataSet.OptionsRow Properties

The properties of the OptionsDataSet.OptionsRow class are listed below. For a complete list of OptionsDataSet.OptionsRow class members, see the OptionsDataSet.OptionsRow Members topic.

Public Instance Properties

AllowFree |
AllowPriceOverride |
AllowPriceSelection |
Comments |
EntityName |
EntityRecord |
Extended |
HasErrors (inherited from DataRow) | Gets a value that indicates whether there are errors in a row.
ID |
IsSold |
Item (inherited from DataRow) | Gets or sets the data stored in the column specified by index.
Item (inherited from DataRow) | Gets or sets the data stored in the column specified by name.
Item (inherited from DataRow) | Gets or sets the data stored in the specified DataColumn.
Item (inherited from DataRow) | Gets the data stored in the column, specified by index and version of the data to retrieve.
Item (inherited from DataRow) | Gets the specified version of data stored in the named column.
Item (inherited from DataRow) | Gets the specified version of data stored in the specified DataColumn.
ItemArray (inherited from DataRow) | Gets or sets all the values for this row through an array.
LinkedEntityID |
LinkedEntityID_Name |
MinSellingUnits |
Name |
OptionType |
OriginalPrice |
Price |
PriceOverride |
ProductID |
ProductID_Name |
Quantity |
RowError (inherited from DataRow) | Gets or sets the custom error description for a row.
RowState (inherited from DataRow) | Gets the current state of the row with regard to its relationship to the DataRowCollection.
Selected |
Sequence |
Table (inherited from DataRow) | Gets the DataTable for which this row has a schema.
TopLevelItem |

See Also

OptionsDataSet.OptionsRow Class | Aptify.Applications.Advertising Namespace


AllowFree Property

Aptify 5.0 Software Development Kit (SDK)

OptionsDataSet.OptionsRow.AllowFree Property

public Boolean AllowFree {get; set;}

See Also

OptionsDataSet.OptionsRow Class | Aptify.Applications.Advertising Namespace


AllowPriceOverride Property

Aptify 5.0 Software Development Kit (SDK)

OptionsDataSet.OptionsRow.AllowPriceOverride Property

public Boolean AllowPriceOverride {get; set;}

See Also

OptionsDataSet.OptionsRow Class | Aptify.Applications.Advertising Namespace


AllowPriceSelection Property

Aptify 5.0 Software Development Kit (SDK)

OptionsDataSet.OptionsRow.AllowPriceSelection Property

public Boolean AllowPriceSelection {get; set;}

See Also

OptionsDataSet.OptionsRow Class | Aptify.Applications.Advertising Namespace


Comments Property

Aptify 5.0 Software Development Kit (SDK)

OptionsDataSet.OptionsRow.Comments Property

public String Comments {get; set;}

See Also

OptionsDataSet.OptionsRow Class | Aptify.Applications.Advertising Namespace


EntityName Property

Aptify 5.0 Software Development Kit (SDK)

OptionsDataSet.OptionsRow.EntityName Property

public String EntityName {get; set;}

See Also

OptionsDataSet.OptionsRow Class | Aptify.Applications.Advertising Namespace


EntityRecord Property

Aptify 5.0 Software Development Kit (SDK)

OptionsDataSet.OptionsRow.EntityRecord Property

public Int64 EntityRecord {get; set;}

See Also

OptionsDataSet.OptionsRow Class | Aptify.Applications.Advertising Namespace


Extended Property

Aptify 5.0 Software Development Kit (SDK)

OptionsDataSet.OptionsRow.Extended Property

public Decimal Extended {get; set;}

See Also

OptionsDataSet.OptionsRow Class | Aptify.Applications.Advertising Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

OptionsDataSet.OptionsRow.ID Property

public Int32 ID {get; set;}

See Also

OptionsDataSet.OptionsRow Class | Aptify.Applications.Advertising Namespace


IsSold Property

Aptify 5.0 Software Development Kit (SDK)

OptionsDataSet.OptionsRow.IsSold Property

public Boolean IsSold {get; set;}

See Also

OptionsDataSet.OptionsRow Class | Aptify.Applications.Advertising Namespace


LinkedEntityID Property

Aptify 5.0 Software Development Kit (SDK)

OptionsDataSet.OptionsRow.LinkedEntityID Property

public Int32 LinkedEntityID {get; set;}

See Also

OptionsDataSet.OptionsRow Class | Aptify.Applications.Advertising Namespace


LinkedEntityID_Name Property

Aptify 5.0 Software Development Kit (SDK)

OptionsDataSet.OptionsRow.LinkedEntityID_Name Property

public String LinkedEntityID_Name {get; set;}

See Also

OptionsDataSet.OptionsRow Class | Aptify.Applications.Advertising Namespace


MinSellingUnits Property

Aptify 5.0 Software Development Kit (SDK)

OptionsDataSet.OptionsRow.MinSellingUnits Property

public Double MinSellingUnits {get; set;}

See Also

OptionsDataSet.OptionsRow Class | Aptify.Applications.Advertising Namespace


Name Property

Aptify 5.0 Software Development Kit (SDK)

OptionsDataSet.OptionsRow.Name Property

public String Name {get; set;}

See Also

OptionsDataSet.OptionsRow Class | Aptify.Applications.Advertising Namespace


OptionType Property

Aptify 5.0 Software Development Kit (SDK)

OptionsDataSet.OptionsRow.OptionType Property

public String OptionType {get; set;}

See Also

OptionsDataSet.OptionsRow Class | Aptify.Applications.Advertising Namespace


OriginalPrice Property

Aptify 5.0 Software Development Kit (SDK)

OptionsDataSet.OptionsRow.OriginalPrice Property

public Decimal OriginalPrice {get; set;}

See Also

OptionsDataSet.OptionsRow Class | Aptify.Applications.Advertising Namespace


Price Property

Aptify 5.0 Software Development Kit (SDK)

OptionsDataSet.OptionsRow.Price Property

public Decimal Price {get; set;}

See Also

OptionsDataSet.OptionsRow Class | Aptify.Applications.Advertising Namespace


PriceOverride Property

Aptify 5.0 Software Development Kit (SDK)

OptionsDataSet.OptionsRow.PriceOverride Property

public Boolean PriceOverride {get; set;}

See Also

OptionsDataSet.OptionsRow Class | Aptify.Applications.Advertising Namespace


ProductID Property

Aptify 5.0 Software Development Kit (SDK)

OptionsDataSet.OptionsRow.ProductID Property

public Int32 ProductID {get; set;}

See Also

OptionsDataSet.OptionsRow Class | Aptify.Applications.Advertising Namespace


ProductID_Name Property

Aptify 5.0 Software Development Kit (SDK)

OptionsDataSet.OptionsRow.ProductID_Name Property

public String ProductID_Name {get; set;}

See Also

OptionsDataSet.OptionsRow Class | Aptify.Applications.Advertising Namespace


Quantity Property

Aptify 5.0 Software Development Kit (SDK)

OptionsDataSet.OptionsRow.Quantity Property

public Int32 Quantity {get; set;}

See Also

OptionsDataSet.OptionsRow Class | Aptify.Applications.Advertising Namespace


Selected Property

Aptify 5.0 Software Development Kit (SDK)

OptionsDataSet.OptionsRow.Selected Property

public Boolean Selected {get; set;}

See Also

OptionsDataSet.OptionsRow Class | Aptify.Applications.Advertising Namespace


Sequence Property

Aptify 5.0 Software Development Kit (SDK)

OptionsDataSet.OptionsRow.Sequence Property

public Int32 Sequence {get; set;}

See Also

OptionsDataSet.OptionsRow Class | Aptify.Applications.Advertising Namespace


TopLevelItem Property

Aptify 5.0 Software Development Kit (SDK)

OptionsDataSet.OptionsRow.TopLevelItem Property

public Boolean TopLevelItem {get; set;}

See Also

OptionsDataSet.OptionsRow Class | Aptify.Applications.Advertising Namespace


OptionsDataSet.OptionsRow Methods

The methods of the OptionsDataSet.OptionsRow class are listed below. For a complete list of OptionsDataSet.OptionsRow class members, see the OptionsDataSet.OptionsRow Members topic.

Public Instance Methods

AcceptChanges (inherited from DataRow) | Commits all the changes made to this row since the last time AcceptChanges was called.
BeginEdit (inherited from DataRow) | Starts an edit operation on a DataRow object.
CancelEdit (inherited from DataRow) | Cancels the current edit on the row.
ClearErrors (inherited from DataRow) | Clears the errors for the row. This includes the RowError and errors set with SetColumnError.
Delete (inherited from DataRow) | Deletes the DataRow.
EndEdit (inherited from DataRow) | Ends the edit occurring on the row.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetChildRows (inherited from DataRow) | Overloaded. Gets the child rows of a DataRow using the specified RelationName of a DataRelation.
GetColumnError (inherited from DataRow) | Overloaded. Gets the error description for the column specified by index.
GetColumnsInError (inherited from DataRow) | Gets an array of columns that have errors.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetParentRow (inherited from DataRow) | Overloaded. Gets the parent row of a DataRow using the specified RelationName of a DataRelation.
GetParentRows (inherited from DataRow) | Overloaded. Gets the parent rows of a DataRow using the specified RelationName of a DataRelation.
GetType (inherited from Object) | Gets the Type of the current instance.
HasVersion (inherited from DataRow) | Gets a value that indicates whether a specified version exists.
IsCommentsNull |
IsEntityNameNull |
IsEntityRecordNull |
IsExtendedNull |
IsLinkedEntityID_NameNull |
IsLinkedEntityIDNull |
IsNull (inherited from DataRow) | Overloaded. Gets a value that indicates whether the column at the specified index contains a null value.
IsOriginalPriceNull |
IsPriceNull |
IsPriceOverrideNull |
IsQuantityNull |
IsSelectedNull |
IsSequenceNull |
RejectChanges (inherited from DataRow) | Rejects all changes made to the row since AcceptChanges was last called.
SetAdded (inherited from DataRow) | Changes the Rowstate of a DataRow to Added.
SetColumnError (inherited from DataRow) | Overloaded. Sets the error description for a column specified by index.
SetCommentsNull |
SetEntityNameNull |
SetEntityRecordNull |
SetExtendedNull |
SetLinkedEntityID_NameNull |
SetLinkedEntityIDNull |
SetModified (inherited from DataRow) | Changes the Rowstate of a DataRow to Modified.
SetOriginalPriceNull |
SetParentRow (inherited from DataRow) | Overloaded. Sets the parent row of a DataRow with specified new parent DataRow.
SetPriceNull |
SetPriceOverrideNull |
SetQuantityNull |
SetSelectedNull |
SetSequenceNull |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetNull (inherited from DataRow) | Sets the value of the specified DataColumn to a null value.

See Also

OptionsDataSet.OptionsRow Class | Aptify.Applications.Advertising Namespace


OptionsDataSet.OptionsRow.IsCommentsNull Method

public bool IsCommentsNull();

See Also

OptionsDataSet.OptionsRow Class | Aptify.Applications.Advertising Namespace


OptionsDataSet.OptionsRow.IsEntityNameNull Method

public bool IsEntityNameNull();

See Also

OptionsDataSet.OptionsRow Class | Aptify.Applications.Advertising Namespace


OptionsDataSet.OptionsRow.IsEntityRecordNull Method

public bool IsEntityRecordNull();

See Also

OptionsDataSet.OptionsRow Class | Aptify.Applications.Advertising Namespace


OptionsDataSet.OptionsRow.IsExtendedNull Method

public bool IsExtendedNull();

See Also

OptionsDataSet.OptionsRow Class | Aptify.Applications.Advertising Namespace


OptionsDataSet.OptionsRow.IsLinkedEntityID_NameNull Method

public bool IsLinkedEntityID_NameNull();

See Also

OptionsDataSet.OptionsRow Class | Aptify.Applications.Advertising Namespace


OptionsDataSet.OptionsRow.IsLinkedEntityIDNull Method

public bool IsLinkedEntityIDNull();

See Also

OptionsDataSet.OptionsRow Class | Aptify.Applications.Advertising Namespace


OptionsDataSet.OptionsRow.IsOriginalPriceNull Method

public bool IsOriginalPriceNull();

See Also

OptionsDataSet.OptionsRow Class | Aptify.Applications.Advertising Namespace


OptionsDataSet.OptionsRow.IsPriceNull Method

public bool IsPriceNull();

See Also

OptionsDataSet.OptionsRow Class | Aptify.Applications.Advertising Namespace


OptionsDataSet.OptionsRow.IsPriceOverrideNull Method

public bool IsPriceOverrideNull();

See Also

OptionsDataSet.OptionsRow Class | Aptify.Applications.Advertising Namespace


OptionsDataSet.OptionsRow.IsQuantityNull Method

public bool IsQuantityNull();

See Also

OptionsDataSet.OptionsRow Class | Aptify.Applications.Advertising Namespace


OptionsDataSet.OptionsRow.IsSelectedNull Method

public bool IsSelectedNull();

See Also

OptionsDataSet.OptionsRow Class | Aptify.Applications.Advertising Namespace


OptionsDataSet.OptionsRow.IsSequenceNull Method

public bool IsSequenceNull();

See Also

OptionsDataSet.OptionsRow Class | Aptify.Applications.Advertising Namespace


OptionsDataSet.OptionsRow.SetCommentsNull Method

public void SetCommentsNull();

See Also

OptionsDataSet.OptionsRow Class | Aptify.Applications.Advertising Namespace


OptionsDataSet.OptionsRow.SetEntityNameNull Method

public void SetEntityNameNull();

See Also

OptionsDataSet.OptionsRow Class | Aptify.Applications.Advertising Namespace


OptionsDataSet.OptionsRow.SetEntityRecordNull Method

public void SetEntityRecordNull();

See Also

OptionsDataSet.OptionsRow Class | Aptify.Applications.Advertising Namespace


OptionsDataSet.OptionsRow.SetExtendedNull Method

public void SetExtendedNull();

See Also

OptionsDataSet.OptionsRow Class | Aptify.Applications.Advertising Namespace


OptionsDataSet.OptionsRow.SetLinkedEntityID_NameNull Method

public void SetLinkedEntityID_NameNull();

See Also

OptionsDataSet.OptionsRow Class | Aptify.Applications.Advertising Namespace


OptionsDataSet.OptionsRow.SetLinkedEntityIDNull Method

public void SetLinkedEntityIDNull();

See Also

OptionsDataSet.OptionsRow Class | Aptify.Applications.Advertising Namespace


OptionsDataSet.OptionsRow.SetOriginalPriceNull Method

public void SetOriginalPriceNull();

See Also

OptionsDataSet.OptionsRow Class | Aptify.Applications.Advertising Namespace


OptionsDataSet.OptionsRow.SetPriceNull Method

public void SetPriceNull();

See Also

OptionsDataSet.OptionsRow Class | Aptify.Applications.Advertising Namespace


OptionsDataSet.OptionsRow.SetPriceOverrideNull Method

public void SetPriceOverrideNull();

See Also

OptionsDataSet.OptionsRow Class | Aptify.Applications.Advertising Namespace


OptionsDataSet.OptionsRow.SetQuantityNull Method

public void SetQuantityNull();

See Also

OptionsDataSet.OptionsRow Class | Aptify.Applications.Advertising Namespace


OptionsDataSet.OptionsRow.SetSelectedNull Method

public void SetSelectedNull();

See Also

OptionsDataSet.OptionsRow Class | Aptify.Applications.Advertising Namespace


OptionsDataSet.OptionsRow.SetSequenceNull Method

public void SetSequenceNull();

See Also

OptionsDataSet.OptionsRow Class | Aptify.Applications.Advertising Namespace


OptionsDataSet.OptionsRowChangeEvent Class

Row event argument class

For a list of all members of this type, see OptionsDataSet.OptionsRowChangeEvent Members.

System.Object
EventArgs
OptionsDataSet.OptionsRowChangeEvent

public class OptionsDataSet.OptionsRowChangeEvent : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Advertising

Assembly: AdvertisingInsertionOrderControls (in AdvertisingInsertionOrderControls.dll)

See Also

OptionsDataSet.OptionsRowChangeEvent Members | Aptify.Applications.Advertising Namespace


OptionsDataSet.OptionsRowChangeEvent Members

OptionsDataSet.OptionsRowChangeEvent overview

Public Instance Constructors

OptionsDataSet.OptionsRowChangeEvent Constructor

Public Instance Properties

Action
Row

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

OptionsDataSet.OptionsRowChangeEvent Class | Aptify.Applications.Advertising Namespace


OptionsDataSet.OptionsRowChangeEvent Constructor

public OptionsDataSet.OptionsRowChangeEvent(
OptionsDataSet.OptionsRow row,
DataRowAction action
);

See Also

OptionsDataSet.OptionsRowChangeEvent Class | Aptify.Applications.Advertising Namespace


OptionsDataSet.OptionsRowChangeEvent Properties

The properties of the OptionsDataSet.OptionsRowChangeEvent class are listed below. For a complete list of OptionsDataSet.OptionsRowChangeEvent class members, see the OptionsDataSet.OptionsRowChangeEvent Members topic.

Public Instance Properties

Action
Row

See Also

OptionsDataSet.OptionsRowChangeEvent Class | Aptify.Applications.Advertising Namespace


Action Property

Aptify 5.0 Software Development Kit (SDK)

OptionsDataSet.OptionsRowChangeEvent.Action Property

public DataRowAction Action {get;}

See Also

OptionsDataSet.OptionsRowChangeEvent Class | Aptify.Applications.Advertising Namespace


Row Property

Aptify 5.0 Software Development Kit (SDK)

OptionsDataSet.OptionsRowChangeEvent.Row Property

public OptionsDataSet.OptionsRow Row {get;}

See Also

OptionsDataSet.OptionsRowChangeEvent Class | Aptify.Applications.Advertising Namespace


OptionsDataSet.OptionsRowChangeEventHandler Delegate

public delegate void OptionsDataSet.OptionsRowChangeEventHandler(
Object sender,
OptionsDataSet.OptionsRowChangeEvent e
);

Requirements

Namespace: Aptify.Applications.Advertising

Assembly: AdvertisingInsertionOrderControls (in AdvertisingInsertionOrderControls.dll)

See Also

Aptify.Applications.Advertising Namespace


Aptify.Applications.AptifyHierarchyControl

Aptify 5.0 Software Development Kit (SDK)

Aptify.Applications.AptifyHierarchyControl Namespace

The hierarchy control is a generic component that defines a browser to display record hierarchies. The Companies form and Product Categories form include tabs that use this browser.

Namespace hierarchy

Classes

Class | Description
HierarcyBrowser | Aptify Generic Hierarchy Browser Control


HierarcyBrowser Class

Aptify Generic Hierarchy Browser Control

For a list of all members of this type, see HierarcyBrowser Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
HierarcyBrowser

public class HierarcyBrowser : FormComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.AptifyHierarchyControl

Assembly: AptifyHierarchyControl (in AptifyHierarchyControl.dll)

See Also

HierarcyBrowser Members | Aptify.Applications.AptifyHierarchyControl Namespace


HierarcyBrowser Members

HierarcyBrowser overview

Public Instance Constructors

HierarcyBrowser Constructor Initializes a new instance of the HierarcyBrowser class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
InternalConfig |
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateContext (inherited from FormComponent) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormComponent) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormComponent) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormComponent) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

HierarcyBrowser Class | Aptify.Applications.AptifyHierarchyControl Namespace


HierarcyBrowser Constructor

Initializes a new instance of the HierarcyBrowser class.

public HierarcyBrowser();

See Also

HierarcyBrowser Class | Aptify.Applications.AptifyHierarchyControl Namespace


HierarcyBrowser Methods

The methods of the HierarcyBrowser class are listed below. For a complete list of HierarcyBrowser class members, see the HierarcyBrowser Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
InternalConfig |
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormComponent) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormComponent) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormComponent) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

HierarcyBrowser Class | Aptify.Applications.AptifyHierarchyControl Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

HierarcyBrowser.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

HierarcyBrowser Class | Aptify.Applications.AptifyHierarchyControl Namespace


HierarcyBrowser.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

HierarcyBrowser Class | Aptify.Applications.AptifyHierarchyControl Namespace | HierarcyBrowser.Dispose Overload List


HierarcyBrowser.InternalConfig Method

public void InternalConfig(
Int64 lNodeID
);

See Also

HierarcyBrowser Class | Aptify.Applications.AptifyHierarchyControl Namespace


HierarcyBrowser.OnFormComponentConfig Method

protected override void OnFormComponentConfig(
AptifyFormTemplateContext FormTemplateContext
);

Implements

IFormComponent.

See Also

HierarcyBrowser Class | Aptify.Applications.AptifyHierarchyControl Namespace


HierarcyBrowser.Refresh Method

public override void Refresh();

See Also

HierarcyBrowser Class | Aptify.Applications.AptifyHierarchyControl Namespace


Aptify.Applications.AptifySpecialFields

Aptify 5.0 Software Development Kit (SDK)

Aptify.Applications.AptifySpecialFields Namespace

This namespace contains the logic for the Special Field Text Box form component, which is used for certain fields on the Persons and Companies forms. See the Visual Designer section of the Aptify Administration Guide for more information.

Namespace hierarchy

Classes

Class | Description
SpecialFieldTextBox | Used to display special fields for Companies and Persons.


SpecialFieldTextBox Class

Used to display special fields for Companies and Persons.

For a list of all members of this type, see SpecialFieldTextBox Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
AptifyControlBase
AptifyDataFieldControlBase
AptifyTextBox
SpecialFieldTextBox

public class SpecialFieldTextBox : AptifyTextBox

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

This will call the Get value from the entity, before the datafield is assigned. This is, because we want to ensure that the fields is there. It Supports the DataField property.

Requirements

Namespace: Aptify.Applications.AptifySpecialFields

Assembly: AptifySpecialFieldsGUI (in AptifySpecialFieldsGUI.dll)

See Also

SpecialFieldTextBox Members | Aptify.Applications.AptifySpecialFields Namespace


SpecialFieldTextBox Members

SpecialFieldTextBox overview

Public Instance Constructors

SpecialFieldTextBox Constructor Initializes a new instance of the SpecialFieldTextBox class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Control (inherited from AptifyControlBase) |
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DataControl (inherited from AptifyControlBase) | Adds a reference to the object for the data control. In the case of it being added, the reference to the bound control base object is added to the data controls collection.
DataField (inherited from AptifyDataFieldControlBase) | This is the field in the GE to whose value read/write operations are applied.
DataSource (inherited from AptifyDataFieldControlBase) |
DisableGeDataTransfer (inherited from AptifyControlBase) | If true, the implementer is required to move the value to/from the bound control to the GE or other data access method.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
FieldHelp (inherited from AptifyControlBase) |
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from AptifyDataFieldControlBase) | The font for the internal control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormatString (inherited from AptifyTextBox) |
FormTemplateContext (inherited from AptifyControlBase) | Returns the reference that if is local that is returned else if a DataControl exists, it is returned.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpObject (inherited from AptifyDataFieldControlBase) | This member is overriden in this class to provide field-level help if available
HelpURL (inherited from AptifyDataFieldControlBase) | This member is overriden in this class to provide field-level help if available
HideSelection (inherited from AptifyTextBox) |
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LabelAutoSize (inherited from AptifyTextBox) |
LabelFont (inherited from AptifyDataFieldControlBase) | The font of the label.
LabelRequiredFont (inherited from AptifyDataFieldControlBase) |
LabelSize (inherited from AptifyDataFieldControlBase) | Size of the label.
LabelText (inherited from AptifyDataFieldControlBase) |
LabelTextAlign (inherited from AptifyDataFieldControlBase) |
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MaxLength (inherited from AptifyTextBox) | The maximum number of characters that the text box will accept.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
MultiLine (inherited from AptifyTextBox) | If set to true, the control allows multiple lines to be inserted.
Name (inherited from Control) | Gets or sets the name of the control.
ObjectRepository (inherited from AptifyControlBase) |
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PasswordChar (inherited from AptifyTextBox) | Shows a different visible character if this is set.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Required (inherited from AptifyDataFieldControlBase) |
RequiredFieldBackColor (inherited from AptifyTextBox) |
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ScrollBars (inherited from AptifyTextBox) | Sets the scroll bars for the text box control.
ShowLabel (inherited from AptifyDataFieldControlBase) |
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from AptifyDataFieldControlBase) | Sets the Value of the control.
TextAlign (inherited from AptifyTextBox) | The alignment of the text within the text box.
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
Value (inherited from AptifyTextBox) |
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BoundControlConfig (inherited from AptifyTextBox) |
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ClearData (inherited from AptifyDataFieldControlBase) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DisplayControlHelp (inherited from AptifyControlBase) | This method will display control-level help information. This method will use the HelpTitle and HelpText overridable members to display the Field Help object from Aptify.Framework.WindowsControls.FieldHelp. If the title and text is desired to be overriden it is not necessary to override this method, rather override the HelpTitle and HelpText properties which are used by this method.
DisplayEntityHelp (inherited from AptifyControlBase) | This method is responsible for displaying the help file to the user and will attempt to provide context sensitive help based on the particular entity being displayed. If no entity-specific help file is available for the user then the standard Aptify Shell.Aptify Help file will be used to display help to the user. Override this method in sub-classes to change the method for displaying help.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetDefaultHelpObject (inherited from AptifyControlBase) | This method returns the default help object file in the Aptify Object repository to be used in the event that no entity-specific file exists
GetEntityFieldSpecificHelpObject (inherited from AptifyDataFieldControlBase) | This method returns the Aptify Object Repository Object location for the help file that is specific to this entity field.
GetEntityFieldSpecificHelpTopicURL (inherited from AptifyDataFieldControlBase) | This method returns the Topic URL location within the help file that is specific to this entity field.
GetEntitySpecificHelpObject (inherited from AptifyControlBase) | This method returns the Aptify Object Repository Object location for the help file that is specific to this entity.
GetEntitySpecificHelpTopicURL (inherited from AptifyControlBase) | This method returns the Topic URL location within the help file that is specific to this entity.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseValueChanged (inherited from AptifyControlBase) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from AptifyDataFieldControlBase) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from AptifyTextBox) | Overloaded.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetExtendedType (inherited from AptifyTextBox) |
SetUserCredential (inherited from AptifyControlBase) |
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
TransferDataToObject (inherited from AptifyDataFieldControlBase) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AfterDisplayEntityHelp (inherited from AptifyControlBase) | This event is fired after the help file is displayed.
AptifyControlBaseTextChanged (inherited from AptifyControlBase) |
AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BeforeDisplayEntityHelp (inherited from AptifyControlBase) | This event is fired before the help file is displayed. To prevent help from being displayed set the Cancel parameter to True.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from AptifyControlBase) |
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from AptifyControlBase) |
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from AptifyControlBase) |
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from AptifyControlBase) |
KeyPress (inherited from AptifyControlBase) |
KeyUp (inherited from AptifyControlBase) |
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from AptifyControlBase) |
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from AptifyControlBase) |
MouseEnter (inherited from AptifyControlBase) |
MouseHover (inherited from AptifyControlBase) |
MouseLeave (inherited from AptifyControlBase) |
MouseMove (inherited from AptifyControlBase) |
MouseUp (inherited from AptifyControlBase) |
MouseWheel (inherited from AptifyControlBase) |
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from AptifyControlBase) |
Validated (inherited from AptifyControlBase) |
Validating (inherited from AptifyControlBase) |
ValueChanged (inherited from AptifyControlBase) |
VisibleChanged (inherited from AptifyControlBase) |

Protected Instance Fields

m_bEdit (inherited from AptifyDataFieldControlBase)
m_bNewTypedValue (inherited from AptifyDataFieldControlBase)
m_bPreConfig (inherited from AptifyDataFieldControlBase)
m_bRead (inherited from AptifyDataFieldControlBase)
m_bRequired (inherited from AptifyDataFieldControlBase)
m_iDataControl (inherited from AptifyControlBase)
m_oAptifyApplication (inherited from AptifyControlBase)
m_oFormTemplateContext (inherited from AptifyControlBase)
m_oUserCredential (inherited from AptifyControlBase)
m_sDataField (inherited from AptifyDataFieldControlBase)

Protected Instance Properties

AptifyApplication (inherited from AptifyControlBase) | Returns an instance of the Aptify Application Object
AptifyMessage (inherited from AptifyDataFieldControlBase) |
AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
CurrencyTypeCache (inherited from AptifyControlBase) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DisplayName (inherited from AptifyControlBase) |
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
ExtendedType (inherited from AptifyTextBox) |
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HelpText (inherited from AptifyControlBase) |
HelpTitle (inherited from AptifyDataFieldControlBase) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
InternalControl (inherited from AptifyControlBase) | Specifies the Main Control of interest in a composite control.
Label (inherited from AptifyDataFieldControlBase) |
m_oInternalControl (inherited from AptifyControlBase) |
MyApplication (inherited from AptifyControlBase) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowDisplayHelpHyperlink (inherited from AptifyControlBase) | This property can be overriden by sub-classes to be able to selectively turn on or off the Display Help hyperlink that appears by default on the FieldHelp object.
UserCredential (inherited from AptifyControlBase) |
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
AptifyControlBaseValueChangedHandler (inherited from AptifyDataFieldControlBase) |
ConfigHelp (inherited from AptifyDataFieldControlBase) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
CreateMessageObjects (inherited from AptifyDataFieldControlBase) |
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from AptifyTextBox) | Overloaded. Releases all resources used by the Component.
DoFormComponentConfig | Configures the Component.
DoFormComponentConfigRunMode (inherited from AptifyTextBox) |
DoPostal_Leave (inherited from AptifyDataFieldControlBase) |
Finalize (inherited from AptifyControlBase) |
FormatValue (inherited from AptifyTextBox) | Formats the Value of the control using the FormatString. If FormatString is blank, the default formatting for the data type will be used. Example: The Default Format String for money is Currency which uses the client's regional format settings for Currency.
FormComponentConfig (inherited from AptifyControlBase) |
FormComponentHide (inherited from AptifyControlBase) |
FormComponentShow (inherited from AptifyControlBase) | Overloaded.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
LookupPostalInfo (inherited from AptifyDataFieldControlBase) |
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from AptifyTextBox) |
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from AptifyTextBox) |
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from AptifyTextBox) |
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RequiredGECheck (inherited from AptifyControlBase) |
RequiredPropertiesCheck (inherited from AptifyControlBase) |
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlMetaData (inherited from AptifyTextBox) |
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetSecurity (inherited from AptifyDataFieldControlBase) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTextAlignByDataType (inherited from AptifyTextBox) | Sets the TextAlign property based on the Data Type of the DataField. Numeric data types are right-aligned. All others are left-aligned. Note: This behavior is currently disabled.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetValueFromGe (inherited from AptifyDataFieldControlBase) |
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Instance Events

PostConfig (inherited from AptifyDataFieldControlBase)
PreConfig (inherited from AptifyDataFieldControlBase)

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.
StopInitialization (inherited from AptifyDataFieldControlBase) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

SpecialFieldTextBox Class | Aptify.Applications.AptifySpecialFields Namespace


SpecialFieldTextBox Constructor

Initializes a new instance of the SpecialFieldTextBox class.

public SpecialFieldTextBox();

See Also

SpecialFieldTextBox Class | Aptify.Applications.AptifySpecialFields Namespace


SpecialFieldTextBox Methods

The methods of the SpecialFieldTextBox class are listed below. For a complete list of SpecialFieldTextBox class members, see the SpecialFieldTextBox Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BoundControlConfig (inherited from AptifyTextBox) |
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ClearData (inherited from AptifyDataFieldControlBase) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DisplayControlHelp (inherited from AptifyControlBase) | This method will display control-level help information. This method will use the HelpTitle and HelpText overridable members to display the Field Help object from Aptify.Framework.WindowsControls.FieldHelp. If the title and text is desired to be overriden it is not necessary to override this method, rather override the HelpTitle and HelpText properties which are used by this method.
DisplayEntityHelp (inherited from AptifyControlBase) | This method is responsible for displaying the help file to the user and will attempt to provide context sensitive help based on the particular entity being displayed. If no entity-specific help file is available for the user then the standard Aptify Shell.Aptify Help file will be used to display help to the user. Override this method in sub-classes to change the method for displaying help.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetDefaultHelpObject (inherited from AptifyControlBase) | This method returns the default help object file in the Aptify Object repository to be used in the event that no entity-specific file exists
GetEntityFieldSpecificHelpObject (inherited from AptifyDataFieldControlBase) | This method returns the Aptify Object Repository Object location for the help file that is specific to this entity field.
GetEntityFieldSpecificHelpTopicURL (inherited from AptifyDataFieldControlBase) | This method returns the Topic URL location within the help file that is specific to this entity field.
GetEntitySpecificHelpObject (inherited from AptifyControlBase) | This method returns the Aptify Object Repository Object location for the help file that is specific to this entity.
GetEntitySpecificHelpTopicURL (inherited from AptifyControlBase) | This method returns the Topic URL location within the help file that is specific to this entity.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseValueChanged (inherited from AptifyControlBase) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from AptifyDataFieldControlBase) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from AptifyTextBox) | Overloaded.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetExtendedType (inherited from AptifyTextBox) |
SetUserCredential (inherited from AptifyControlBase) |
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
TransferDataToObject (inherited from AptifyDataFieldControlBase) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
AptifyControlBaseValueChangedHandler (inherited from AptifyDataFieldControlBase) |
ConfigHelp (inherited from AptifyDataFieldControlBase) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
CreateMessageObjects (inherited from AptifyDataFieldControlBase) |
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from AptifyTextBox) | Overloaded. Releases all resources used by the Component.
DoFormComponentConfig | Configures the Component.
DoFormComponentConfigRunMode (inherited from AptifyTextBox) |
DoPostal_Leave (inherited from AptifyDataFieldControlBase) |
Finalize (inherited from AptifyControlBase) |
FormatValue (inherited from AptifyTextBox) | Formats the Value of the control using the FormatString. If FormatString is blank, the default formatting for the data type will be used. Example: The Default Format String for money is Currency which uses the client's regional format settings for Currency.
FormComponentConfig (inherited from AptifyControlBase) |
FormComponentHide (inherited from AptifyControlBase) |
FormComponentShow (inherited from AptifyControlBase) | Overloaded.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
LookupPostalInfo (inherited from AptifyDataFieldControlBase) |
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from AptifyTextBox) |
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from AptifyTextBox) |
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from AptifyTextBox) |
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RequiredGECheck (inherited from AptifyControlBase) |
RequiredPropertiesCheck (inherited from AptifyControlBase) |
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlMetaData (inherited from AptifyTextBox) |
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetSecurity (inherited from AptifyDataFieldControlBase) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTextAlignByDataType (inherited from AptifyTextBox) | Sets the TextAlign property based on the Data Type of the DataField. Numeric data types are right-aligned. All others are left-aligned. Note: This behavior is currently disabled.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetValueFromGe (inherited from AptifyDataFieldControlBase) |
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

SpecialFieldTextBox Class | Aptify.Applications.AptifySpecialFields Namespace


SpecialFieldTextBox.DoFormComponentConfig Method

Configures the Component.

protected override void DoFormComponentConfig(
AptifyFormTemplateContext FormTemplateContext
);

Parameters

FormTemplateContext

Remarks

See Also

SpecialFieldTextBox Class | Aptify.Applications.AptifySpecialFields Namespace


Aptify.Applications.BulkWriteOffWizard

Aptify 5.0 Software Development Kit (SDK)

Aptify.Applications.BulkWriteOffWizard Namespace

This namespace corresponds to objects used by the Aptify Bulk Write Off metadata wizard.

Namespace hierarchy

Classes

Class | Description
CreateBulkWriteOffGUI | Contains custom logic that deals with handling display/layout of form components on Create Bulk Write Off Wizard.


CreateBulkWriteOffGUI Class

Contains custom logic that deals with handling display/layout of form components on Create Bulk Write Off Wizard.

For a list of all members of this type, see CreateBulkWriteOffGUI Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
CreateBulkWriteOffGUI

public class CreateBulkWriteOffGUI : FormTemplateLayout

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.BulkWriteOffWizard

Assembly: AptifyBulkWriteOffWizardGUI (in AptifyBulkWriteOffWizardGUI.dll)

See Also

CreateBulkWriteOffGUI Members | Aptify.Applications.BulkWriteOffWizard Namespace


CreateBulkWriteOffGUI Members

CreateBulkWriteOffGUI overview

Public Instance Constructors

CreateBulkWriteOffGUI Constructor Initializes a new instance of the CreateBulkWriteOffGUI class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded | Contains logic to setup Event handlers for controls on the FormTemplate Layout.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CreateBulkWriteOffGUI Class | Aptify.Applications.BulkWriteOffWizard Namespace


CreateBulkWriteOffGUI Constructor

Initializes a new instance of the CreateBulkWriteOffGUI class.

public CreateBulkWriteOffGUI();

See Also

CreateBulkWriteOffGUI Class | Aptify.Applications.BulkWriteOffWizard Namespace


CreateBulkWriteOffGUI Methods

The methods of the CreateBulkWriteOffGUI class are listed below. For a complete list of CreateBulkWriteOffGUI class members, see the CreateBulkWriteOffGUI Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded | Contains logic to setup Event handlers for controls on the FormTemplate Layout.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CreateBulkWriteOffGUI Class | Aptify.Applications.BulkWriteOffWizard Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

CreateBulkWriteOffGUI.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

CreateBulkWriteOffGUI Class | Aptify.Applications.BulkWriteOffWizard Namespace


CreateBulkWriteOffGUI.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

CreateBulkWriteOffGUI Class | Aptify.Applications.BulkWriteOffWizard Namespace | CreateBulkWriteOffGUI.Dispose Overload List


CreateBulkWriteOffGUI.OnFormTemplateLoaded Method

Contains logic to setup Event handlers for controls on the FormTemplate Layout.

protected override void OnFormTemplateLoaded(
FormTemplateLayout.FormTemplateLoadedEventArgs e
);

Parameters

e

Remarks

See Also

CreateBulkWriteOffGUI Class | Aptify.Applications.BulkWriteOffWizard Namespace


Aptify.Applications.Campaigns

Aptify 5.0 Software Development Kit (SDK)

Aptify.Applications.Campaigns Namespace

The objects in this namespace implement Aptify's Campaign Management application.

Namespace hierarchy

Classes

Class | Description
AddToCampaign |
Campaign |
CampaignCalculateDiscount | This object implements the Aptify.Framework.Applications.Decimal.ICampaignCalculateDiscount interface. The purpose of this component is to return a discount for the specified set of parameters provided
CampaignDiscountLayout | This class implements layout logic for the Windows UI for the Campaign Products and Campaign Product Categories entities.
CampaignDocObject |
CampaignList | This is the GE sub-class for the Campaign List Detail entity
CampaignListBuilderObject | Provides functionality to handle the building of a campaign prospect list based on the Campaign Segments that have been defined within the campaign.
CampaignListBuilderWizard | Aptify Campaign List Import Wizard. This GUI component utilizes the CampaignListBuilderObject to perform its underlying operations.
CampaignSegmentLayout | This class implements layout logic for the Windows UI for the Campaign Segments entity.
CampaignSetupWizard |

Interfaces

Interface | Description
ICampaignCalculateDiscount | Interface used to create plug-ins for retrieving discounts associated with Campaigns

Delegates

Delegate | Description
Campaign.StatusChangedEventHandler |
CampaignDocObject.StatusChangedEventHandler |
CampaignList.StatusChangedEventHandler |
CampaignListBuilderObject.StatusUpdateEventHandler |

Enumerations

Enumeration | Description
AddToCampaign.CampaignAddType |


AddToCampaign Class

For a list of all members of this type, see AddToCampaign Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
AddToCampaign

public class AddToCampaign : AptifyGenericEntity, IAptifyAction

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Campaigns

Assembly: AddToCampaign (in AddToCampaign.dll)

See Also

AddToCampaign Members | Aptify.Applications.Campaigns Namespace


AddToCampaign Members

AddToCampaign overview

Public Instance Constructors

AddToCampaign Constructor Initializes a new instance of the AddToCampaign class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

AddToProspectList |
BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
DoAction | Overloaded.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

AddToCampaign Class | Aptify.Applications.Campaigns Namespace


AddToCampaign Constructor

Initializes a new instance of the AddToCampaign class.

public AddToCampaign();

See Also

AddToCampaign Class | Aptify.Applications.Campaigns Namespace


AddToCampaign Methods

The methods of the AddToCampaign class are listed below. For a complete list of AddToCampaign class members, see the AddToCampaign Members topic.

Public Instance Methods

AddToProspectList |
BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
DoAction | Overloaded.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

AddToCampaign Class | Aptify.Applications.Campaigns Namespace


AddToCampaign.AddToProspectList Method

public bool AddToProspectList(
AddToCampaign.CampaignAddType iType,
Int64 lCampaignID,
Int64 lID
);

See Also

AddToCampaign Class | Aptify.Applications.Campaigns Namespace


DoAction Method

Aptify 5.0 Software Development Kit (SDK)

AddToCampaign.DoAction Method

Overload List

public void DoAction(AptifyApplication,Int64);

public void DoAction(AptifyApplication,Int64,Int64);

public void DoAction(AptifyApplication,Int64,Int64,params Object[]);

public void DoAction(AptifyApplication,Int64,params String[]);

See Also

AddToCampaign Class | Aptify.Applications.Campaigns Namespace


AddToCampaign.DoAction Method (AptifyApplication, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID
);

Implements

IAptifyAction.

See Also

AddToCampaign Class | Aptify.Applications.Campaigns Namespace | AddToCampaign.DoAction Overload List


AddToCampaign.DoAction Method (AptifyApplication, Int64, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID
);

Implements

IAptifyAction.

See Also

AddToCampaign Class | Aptify.Applications.Campaigns Namespace | AddToCampaign.DoAction Overload List


AddToCampaign.DoAction Method (AptifyApplication, Int64, Int64, Object[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID,
params Object[] SelectedItems
);

Implements

IAptifyAction.

See Also

AddToCampaign Class | Aptify.Applications.Campaigns Namespace | AddToCampaign.DoAction Overload List


AddToCampaign.DoAction Method (AptifyApplication, Int64, String[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
params String[] SelectedItems
);

Implements

IAptifyAction.

See Also

AddToCampaign Class | Aptify.Applications.Campaigns Namespace | AddToCampaign.DoAction Overload List


AddToCampaign.CampaignAddType Enumeration

public enum AddToCampaign.CampaignAddType

Members

Member Name | Description
Person |
Company |

Requirements

Namespace: Aptify.Applications.Campaigns

Assembly: AddToCampaign (in AddToCampaign.dll)

See Also

Aptify.Applications.Campaigns Namespace


Campaign Class

For a list of all members of this type, see Campaign Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
Campaign

public class Campaign : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Campaigns

Assembly: CampaignObject (in CampaignObject.dll)

See Also

Campaign Members | Aptify.Applications.Campaigns Namespace


Campaign Members

Campaign overview

Public Instance Constructors

Campaign Constructor Initializes a new instance of the Campaign class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
StatusChanged |
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

Campaign Class | Aptify.Applications.Campaigns Namespace


Campaign Constructor

Initializes a new instance of the Campaign class.

public Campaign();

See Also

Campaign Class | Aptify.Applications.Campaigns Namespace


Campaign Methods

The methods of the Campaign class are listed below. For a complete list of Campaign class members, see the Campaign Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

Campaign Class | Aptify.Applications.Campaigns Namespace


Save Method

Aptify 5.0 Software Development Kit (SDK)

Campaign.Save Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Save();

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean,ref String&);

public override bool Save(Boolean,ref String&,String);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(ref String&);

See Also

Campaign Class | Aptify.Applications.Campaigns Namespace


Campaign.Save Method (Boolean, String&, String)

public override bool Save(
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

See Also

Campaign Class | Aptify.Applications.Campaigns Namespace | Campaign.Save Overload List


Validate Method

Aptify 5.0 Software Development Kit (SDK)

Campaign.Validate Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Validate();

public override bool Validate(ref String&);

See Also

Campaign Class | Aptify.Applications.Campaigns Namespace


Campaign.Validate Method (String&)

public override bool Validate(
ref String& ErrorString
);

See Also

Campaign Class | Aptify.Applications.Campaigns Namespace | Campaign.Validate Overload List


Campaign Events

The events of the Campaign class are listed below. For a complete list of Campaign class members, see the Campaign Members topic.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
StatusChanged |
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

See Also

Campaign Class | Aptify.Applications.Campaigns Namespace


Campaign.Campaign.StatusChangedEventHandler Event

public event Campaign.StatusChangedEventHandler StatusChanged;

See Also

Campaign Class | Aptify.Applications.Campaigns Namespace


Campaign.StatusChangedEventHandler Delegate

public delegate void Campaign.StatusChangedEventHandler(
Int64 OldStatusID,
Int64 NewStatusID
);

Requirements

Namespace: Aptify.Applications.Campaigns

Assembly: CampaignObject (in CampaignObject.dll)

See Also

Aptify.Applications.Campaigns Namespace


CampaignCalculateDiscount Class

This object implements the Aptify.Framework.Applications.Decimal.ICampaignCalculateDiscount interface. The purpose of this component is to return a discount for the specified set of parameters provided

For a list of all members of this type, see CampaignCalculateDiscount Members.

System.Object
CampaignCalculateDiscount

public class CampaignCalculateDiscount : ICampaignCalculateDiscount

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Campaigns

Assembly: CampaignCalculateDiscount (in CampaignCalculateDiscount.dll)

See Also

CampaignCalculateDiscount Members | Aptify.Applications.Campaigns Namespace


CampaignCalculateDiscount Members

CampaignCalculateDiscount overview

Public Instance Constructors

CampaignCalculateDiscount Constructor Initializes a new instance of the CampaignCalculateDiscount class.

Public Instance Methods

Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCampaignPricing | Overloaded.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetProductCampaignDiscount |
GetProductCategoryCampaignDiscount |
GetProductCategoryFromProduct |
InnerGetCampaignPricing | This function queries the database to determine if the product passed into the function has a campaign price in effect. If it does, then the function will calculate the percentage discount that must be applied to the system calc price. If no campaign price exists, then we return true and fDiscountPercentage is set to 0.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CampaignCalculateDiscount Class | Aptify.Applications.Campaigns Namespace


CampaignCalculateDiscount Constructor

Initializes a new instance of the CampaignCalculateDiscount class.

public CampaignCalculateDiscount();

See Also

CampaignCalculateDiscount Class | Aptify.Applications.Campaigns Namespace


CampaignCalculateDiscount Methods

The methods of the CampaignCalculateDiscount class are listed below. For a complete list of CampaignCalculateDiscount class members, see the CampaignCalculateDiscount Members topic.

Public Instance Methods

Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCampaignPricing | Overloaded.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetProductCampaignDiscount |
GetProductCategoryCampaignDiscount |
GetProductCategoryFromProduct |
InnerGetCampaignPricing | This function queries the database to determine if the product passed into the function has a campaign price in effect. If it does, then the function will calculate the percentage discount that must be applied to the system calc price. If no campaign price exists, then we return true and fDiscountPercentage is set to 0.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CampaignCalculateDiscount Class | Aptify.Applications.Campaigns Namespace


CampaignCalculateDiscount.Config Method

public void Config(
AptifyApplication Application
);

Implements

ICampaignCalculateDiscount.

See Also

CampaignCalculateDiscount Class | Aptify.Applications.Campaigns Namespace


GetCampaignPricing Method

Aptify 5.0 Software Development Kit (SDK)

CampaignCalculateDiscount.GetCampaignPricing Method

Overload List

public virtual CampaignDiscount GetCampaignPricing(OrderLinesEntity);

public CampaignDiscount GetCampaignPricing(Int64,DateTime,Int64,Int64,Int64,Decimal);

See Also

CampaignCalculateDiscount Class | Aptify.Applications.Campaigns Namespace


CampaignCalculateDiscount.GetCampaignPricing Method (OrderLinesEntity)

public virtual CampaignDiscount GetCampaignPricing(
OrderLinesEntity OrderLineGE
);

Implements

ICampaignCalculateDiscount.

See Also

CampaignCalculateDiscount Class | Aptify.Applications.Campaigns Namespace | CampaignCalculateDiscount.GetCampaignPricing Overload List


CampaignCalculateDiscount.GetCampaignPricing Method (Int64, DateTime, Int64, Int64, Int64, Decimal)

public CampaignDiscount GetCampaignPricing(
Int64 CampaignID,
DateTime OrderDate,
Int64 MemberTypeID,
Int64 CompanyMemberTypeID,
Int64 ProductID,
Decimal SystemCalculatedPrice
);

Implements

ICampaignCalculateDiscount.

See Also

CampaignCalculateDiscount Class | Aptify.Applications.Campaigns Namespace | CampaignCalculateDiscount.GetCampaignPricing Overload List


CampaignCalculateDiscount.GetProductCampaignDiscount Method

protected decimal GetProductCampaignDiscount(
Int64 CampaignID,
DateTime OrderDate,
Int64 MemberTypeID,
Int64 CoMemberTypeID,
Int64 ProductID,
Decimal SystemCalculatedPrice
);

See Also

CampaignCalculateDiscount Class | Aptify.Applications.Campaigns Namespace


CampaignCalculateDiscount.GetProductCategoryCampaignDiscount Method

protected decimal GetProductCategoryCampaignDiscount(
Int64 CampaignID,
DateTime OrderDate,
Int64 MemberTypeID,
Int64 CoMemberTypeID,
Int64 ProductCategoryID,
Decimal SystemCalculatedPrice
);

See Also

CampaignCalculateDiscount Class | Aptify.Applications.Campaigns Namespace


CampaignCalculateDiscount.GetProductCategoryFromProduct Method

protected long GetProductCategoryFromProduct(
Int64 ProductID
);

See Also

CampaignCalculateDiscount Class | Aptify.Applications.Campaigns Namespace


CampaignCalculateDiscount.InnerGetCampaignPricing Method

This function queries the database to determine if the product passed into the function has a campaign price in effect. If it does, then the function will calculate the percentage discount that must be applied to the system calc price. If no campaign price exists, then we return true and fDiscountPercentage is set to 0.

protected virtual CampaignDiscount InnerGetCampaignPricing(
Int64 CampaignID,
DateTime OrderDate,
Int64 MemberTypeID,
Int64 CoMemberTypeID,
Int64 ProductID,
Decimal SystemCalculatedPrice
);

Parameters

CampaignID
The Campaign ID at the order line level, or at the order level
OrderDate
The date of the Order.
MemberTypeID
Member Type ID (Bill To)
CoMemberTypeID
Company Member Type ID (Company Bill To)
ProductID
Product ID
SystemCalculatedPrice
Price calculated by the system

Return Value

Remarks

See Also

CampaignCalculateDiscount Class | Aptify.Applications.Campaigns Namespace


CampaignDiscountLayout Class

This class implements layout logic for the Windows UI for the Campaign Products and Campaign Product Categories entities.

For a list of all members of this type, see CampaignDiscountLayout Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
CampaignDiscountLayout

public class CampaignDiscountLayout : FormTemplateLayout

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Campaigns

Assembly: CampaignLayoutControls (in CampaignLayoutControls.dll)

See Also

CampaignDiscountLayout Members | Aptify.Applications.Campaigns Namespace


CampaignDiscountLayout Members

CampaignDiscountLayout overview

Public Instance Constructors

CampaignDiscountLayout Constructor Initializes a new instance of the CampaignDiscountLayout class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
m_ctlAmount |
m_ctlDiscountAmount |
m_ctlDiscountPercent |
m_ctlType |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
BindControl | This method handles binding a control reference to a specific field name using the GetFormComponent() method of the base class. The method only attempts to bind the control reference if the control reference is Nothing or its inner control is disposed.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormTemplateLayout) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControls | This method handles binding the controls to their internal protected members.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
On_Type_ValueChanged | This member is responsible for processing changes in the Type field value. The default behavior is to enable the Amount field whenever Type='Amount', enable DiscountAmount whenever Type='Discount', and enable DiscountPercent whenever Type='Discount %'.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CampaignDiscountLayout Class | Aptify.Applications.Campaigns Namespace


CampaignDiscountLayout Constructor

Initializes a new instance of the CampaignDiscountLayout class.

public CampaignDiscountLayout();

See Also

CampaignDiscountLayout Class | Aptify.Applications.Campaigns Namespace


CampaignDiscountLayout Properties

The properties of the CampaignDiscountLayout class are listed below. For a complete list of CampaignDiscountLayout class members, see the CampaignDiscountLayout Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
m_ctlAmount |
m_ctlDiscountAmount |
m_ctlDiscountPercent |
m_ctlType |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

CampaignDiscountLayout Class | Aptify.Applications.Campaigns Namespace


m_ctlAmount Property

Aptify 5.0 Software Development Kit (SDK)

CampaignDiscountLayout.m_ctlAmount Property

protected virtual IAptifyDataFieldControlBase m_ctlAmount {get; set;}

See Also

CampaignDiscountLayout Class | Aptify.Applications.Campaigns Namespace


m_ctlDiscountAmount Property

Aptify 5.0 Software Development Kit (SDK)

CampaignDiscountLayout.m_ctlDiscountAmount Property

protected virtual IAptifyDataFieldControlBase m_ctlDiscountAmount {get; set;}

See Also

CampaignDiscountLayout Class | Aptify.Applications.Campaigns Namespace


m_ctlDiscountPercent Property

Aptify 5.0 Software Development Kit (SDK)

CampaignDiscountLayout.m_ctlDiscountPercent Property

protected virtual IAptifyDataFieldControlBase m_ctlDiscountPercent {get; set;}

See Also

CampaignDiscountLayout Class | Aptify.Applications.Campaigns Namespace


m_ctlType Property

Aptify 5.0 Software Development Kit (SDK)

CampaignDiscountLayout.m_ctlType Property

protected virtual IAptifyDataFieldControlBase m_ctlType {get; set;}

See Also

CampaignDiscountLayout Class | Aptify.Applications.Campaigns Namespace


CampaignDiscountLayout Methods

The methods of the CampaignDiscountLayout class are listed below. For a complete list of CampaignDiscountLayout class members, see the CampaignDiscountLayout Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
BindControl | This method handles binding a control reference to a specific field name using the GetFormComponent() method of the base class. The method only attempts to bind the control reference if the control reference is Nothing or its inner control is disposed.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormTemplateLayout) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControls | This method handles binding the controls to their internal protected members.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
On_Type_ValueChanged | This member is responsible for processing changes in the Type field value. The default behavior is to enable the Amount field whenever Type='Amount', enable DiscountAmount whenever Type='Discount', and enable DiscountPercent whenever Type='Discount %'.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CampaignDiscountLayout Class | Aptify.Applications.Campaigns Namespace


CampaignDiscountLayout.BindControl Method

This method handles binding a control reference to a specific field name using the GetFormComponent() method of the base class. The method only attempts to bind the control reference if the control reference is Nothing or its inner control is disposed.

protected virtual void BindControl(
ref IAptifyDataFieldControlBase& control,
String FieldName
);

Parameters

control
FieldName

Remarks

See Also

CampaignDiscountLayout Class | Aptify.Applications.Campaigns Namespace


CampaignDiscountLayout.FindControls Method

This method handles binding the controls to their internal protected members.

protected virtual void FindControls();

Remarks

See Also

CampaignDiscountLayout Class | Aptify.Applications.Campaigns Namespace


CampaignDiscountLayout.On_Type_ValueChanged Method

This member is responsible for processing changes in the Type field value. The default behavior is to enable the Amount field whenever Type='Amount', enable DiscountAmount whenever Type='Discount', and enable DiscountPercent whenever Type='Discount %'.

protected virtual void On_Type_ValueChanged(
Object sender,
Object OldValue,
Object NewValue
);

Parameters

sender
OldValue
NewValue

Remarks

See Also

CampaignDiscountLayout Class | Aptify.Applications.Campaigns Namespace


CampaignDiscountLayout.OnFormTemplateLoaded Method

protected override void OnFormTemplateLoaded(
FormTemplateLayout.FormTemplateLoadedEventArgs e
);

See Also

CampaignDiscountLayout Class | Aptify.Applications.Campaigns Namespace


CampaignDocObject Class

For a list of all members of this type, see CampaignDocObject Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
CampaignDocObject

public class CampaignDocObject : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Campaigns

Assembly: CampaignObject (in CampaignObject.dll)

See Also

CampaignDocObject Members | Aptify.Applications.Campaigns Namespace


CampaignDocObject Members

CampaignDocObject overview

Public Instance Constructors

CampaignDocObject Constructor Initializes a new instance of the CampaignDocObject class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
StatusChanged |
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

CampaignDocObject Class | Aptify.Applications.Campaigns Namespace


CampaignDocObject Constructor

Initializes a new instance of the CampaignDocObject class.

public CampaignDocObject();

See Also

CampaignDocObject Class | Aptify.Applications.Campaigns Namespace


CampaignDocObject Methods

The methods of the CampaignDocObject class are listed below. For a complete list of CampaignDocObject class members, see the CampaignDocObject Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

CampaignDocObject Class | Aptify.Applications.Campaigns Namespace


Save Method

Aptify 5.0 Software Development Kit (SDK)

CampaignDocObject.Save Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Save();

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean,ref String&);

public override bool Save(Boolean,ref String&,String);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(ref String&);

See Also

CampaignDocObject Class | Aptify.Applications.Campaigns Namespace


CampaignDocObject.Save Method (Boolean, String&, String)

public override bool Save(
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

See Also

CampaignDocObject Class | Aptify.Applications.Campaigns Namespace | CampaignDocObject.Save Overload List


CampaignDocObject Events

The events of the CampaignDocObject class are listed below. For a complete list of CampaignDocObject class members, see the CampaignDocObject Members topic.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
StatusChanged |
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

See Also

CampaignDocObject Class | Aptify.Applications.Campaigns Namespace


CampaignDocObject.CampaignDocObject.StatusChangedEventHandler Event

public event CampaignDocObject.StatusChangedEventHandler StatusChanged;

See Also

CampaignDocObject Class | Aptify.Applications.Campaigns Namespace


CampaignDocObject.StatusChangedEventHandler Delegate

public delegate void CampaignDocObject.StatusChangedEventHandler(
Int64 OldStatusID,
Int64 NewStatusID
);

Requirements

Namespace: Aptify.Applications.Campaigns

Assembly: CampaignObject (in CampaignObject.dll)

See Also

Aptify.Applications.Campaigns Namespace


CampaignList Class

This is the GE sub-class for the Campaign List Detail entity

For a list of all members of this type, see CampaignList Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
CampaignList

public class CampaignList : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Campaigns

Assembly: CampaignObject (in CampaignObject.dll)

See Also

CampaignList Members | Aptify.Applications.Campaigns Namespace


CampaignList Members

CampaignList overview

Public Instance Constructors

CampaignList Constructor Initializes a new instance of the CampaignList class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
StatusChanged | This event is fired whenever the status is changed (for existing records only)
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireStatusChanged | This method is used to fire the Process Flow event CampaignListStatusChanged whenever the status is changed (for existing records only)
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

CampaignList Class | Aptify.Applications.Campaigns Namespace


CampaignList Constructor

Initializes a new instance of the CampaignList class.

public CampaignList();

See Also

CampaignList Class | Aptify.Applications.Campaigns Namespace


CampaignList Methods

The methods of the CampaignList class are listed below. For a complete list of CampaignList class members, see the CampaignList Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireStatusChanged | This method is used to fire the Process Flow event CampaignListStatusChanged whenever the status is changed (for existing records only)
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

CampaignList Class | Aptify.Applications.Campaigns Namespace


CampaignList.FireStatusChanged Method

This method is used to fire the Process Flow event CampaignListStatusChanged whenever the status is changed (for existing records only)

protected virtual bool FireStatusChanged(
Int64 OldStatusID,
Int64 NewStatusID,
ref String& ErrorString
);

Parameters

OldStatusID
NewStatusID
ErrorString

Return Value

Remarks

See Also

CampaignList Class | Aptify.Applications.Campaigns Namespace


Save Method

Aptify 5.0 Software Development Kit (SDK)

CampaignList.Save Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Save();

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean,ref String&);

public override bool Save(Boolean,ref String&,String);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(ref String&);

See Also

CampaignList Class | Aptify.Applications.Campaigns Namespace


CampaignList.Save Method (Boolean, String&, String)

public override bool Save(
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

See Also

CampaignList Class | Aptify.Applications.Campaigns Namespace | CampaignList.Save Overload List


Validate Method

Aptify 5.0 Software Development Kit (SDK)

CampaignList.Validate Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Validate();

public override bool Validate(ref String&);

See Also

CampaignList Class | Aptify.Applications.Campaigns Namespace


CampaignList.Validate Method (String&)

public override bool Validate(
ref String& ErrorString
);

See Also

CampaignList Class | Aptify.Applications.Campaigns Namespace | CampaignList.Validate Overload List


CampaignList Events

The events of the CampaignList class are listed below. For a complete list of CampaignList class members, see the CampaignList Members topic.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
StatusChanged | This event is fired whenever the status is changed (for existing records only)
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

See Also

CampaignList Class | Aptify.Applications.Campaigns Namespace


CampaignList.CampaignList.StatusChangedEventHandler Event

This event is fired whenever the status is changed (for existing records only)

public event CampaignList.StatusChangedEventHandler StatusChanged;

Remarks

See Also

CampaignList Class | Aptify.Applications.Campaigns Namespace


CampaignList.StatusChangedEventHandler Delegate

public delegate void CampaignList.StatusChangedEventHandler(
Int64 OldStatusID,
Int64 NewStatusID
);

Requirements

Namespace: Aptify.Applications.Campaigns

Assembly: CampaignObject (in CampaignObject.dll)

See Also

Aptify.Applications.Campaigns Namespace


CampaignListBuilderObject Class

Provides functionality to handle the building of a campaign prospect list based on the Campaign Segments that have been defined within the campaign.

For a list of all members of this type, see CampaignListBuilderObject Members.

System.Object
CampaignListBuilderObject

public class CampaignListBuilderObject : IProcessComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Campaigns

Assembly: AptifyCampaignListBuilderObject (in AptifyCampaignListBuilderObject.dll)

See Also

CampaignListBuilderObject Members | Aptify.Applications.Campaigns Namespace


CampaignListBuilderObject Members

CampaignListBuilderObject overview

Public Instance Constructors

CampaignListBuilderObject Constructor Initializes a new instance of the CampaignListBuilderObject class.

Public Instance Properties

Application
DataAction
Database
Properties

Public Instance Methods

BuildCampaignProspectList | This method will build a campaign list for the specified Campaign ID. See the parameter descriptions for details on what each parameter does. As this process progresses the StatusUpdate() event is raised which allows for monitoring of progress and/or cancelling of the process if required. See the StatusUpdate event for details. The function returns True if succesfully completed, False otherwise.
Config | This method must be called before the object has any other methods called.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run | This process component supports running with the following parameters that are documents in the BuildCampaignProspectList method which this ProcessComponent will execute with the provided process component parameters. CampaignID (Required) Long StatusID (Required) Long InitializeList (Optional) Boolean - Defaults to True PreserveManualEntries (Optional) Boolean - Defaults To True The process component returns either "SUCCESS" or "FAILED" as its result code. Check the exception log for any additional details if the process component fails.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

StatusUpdate This event is raised from the BuildCampaignProspectList() method for each item being processed in a list. This event can be listened to for providing status information to the user as well as to cancel the process if required by setting the Cancel parameter of this event to True.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnStatusUpdate | This method should be called to raise the StatusUpdate() event. This method can be called by sub-classes to raise the event from the base-class

See Also

CampaignListBuilderObject Class | Aptify.Applications.Campaigns Namespace


CampaignListBuilderObject Constructor

Initializes a new instance of the CampaignListBuilderObject class.

public CampaignListBuilderObject();

See Also

CampaignListBuilderObject Class | Aptify.Applications.Campaigns Namespace


CampaignListBuilderObject Properties

The properties of the CampaignListBuilderObject class are listed below. For a complete list of CampaignListBuilderObject class members, see the CampaignListBuilderObject Members topic.

Public Instance Properties

Application
DataAction
Database
Properties

See Also

CampaignListBuilderObject Class | Aptify.Applications.Campaigns Namespace


Application Property

Aptify 5.0 Software Development Kit (SDK)

CampaignListBuilderObject.Application Property

public virtual AptifyApplication Application {get;}

See Also

CampaignListBuilderObject Class | Aptify.Applications.Campaigns Namespace


DataAction Property

Aptify 5.0 Software Development Kit (SDK)

CampaignListBuilderObject.DataAction Property

public virtual DataAction DataAction {get;}

See Also

CampaignListBuilderObject Class | Aptify.Applications.Campaigns Namespace


Database Property

Aptify 5.0 Software Development Kit (SDK)

CampaignListBuilderObject.Database Property

public virtual String Database {get;}

See Also

CampaignListBuilderObject Class | Aptify.Applications.Campaigns Namespace


Properties Property

Aptify 5.0 Software Development Kit (SDK)

CampaignListBuilderObject.Properties Property

public AptifyProperties Properties {get;}

Implements

IProcessComponent.

See Also

CampaignListBuilderObject Class | Aptify.Applications.Campaigns Namespace


CampaignListBuilderObject Methods

The methods of the CampaignListBuilderObject class are listed below. For a complete list of CampaignListBuilderObject class members, see the CampaignListBuilderObject Members topic.

Public Instance Methods

BuildCampaignProspectList | This method will build a campaign list for the specified Campaign ID. See the parameter descriptions for details on what each parameter does. As this process progresses the StatusUpdate() event is raised which allows for monitoring of progress and/or cancelling of the process if required. See the StatusUpdate event for details. The function returns True if succesfully completed, False otherwise.
Config | This method must be called before the object has any other methods called.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run | This process component supports running with the following parameters that are documents in the BuildCampaignProspectList method which this ProcessComponent will execute with the provided process component parameters. CampaignID (Required) Long StatusID (Required) Long InitializeList (Optional) Boolean - Defaults to True PreserveManualEntries (Optional) Boolean - Defaults To True The process component returns either "SUCCESS" or "FAILED" as its result code. Check the exception log for any additional details if the process component fails.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnStatusUpdate | This method should be called to raise the StatusUpdate() event. This method can be called by sub-classes to raise the event from the base-class

See Also

CampaignListBuilderObject Class | Aptify.Applications.Campaigns Namespace


CampaignListBuilderObject.BuildCampaignProspectList Method

This method will build a campaign list for the specified Campaign ID. See the parameter descriptions for details on what each parameter does. As this process progresses the StatusUpdate() event is raised which allows for monitoring of progress and/or cancelling of the process if required. See the StatusUpdate event for details. The function returns True if succesfully completed, False otherwise.

public virtual bool BuildCampaignProspectList(
Int64 CampaignID,
Boolean InitializeList,
Boolean PreserveManualEntries,
Int64 StatusID
);

Parameters

CampaignID
Record ID of the Campaign in the Campaigns entity.
InitializeList
If this parameter is set to True, the existing entries in the campaign are cleared before the campaign list is built. If this parameter is set to False, the existing entries are not modified in any way
PreserveManualEntries
This parameter is only used is the InitializeList parameter is set to True. If InitializeList is True and PreserveManualEntries is set to True as well, then the entries that were NOT automatically added to the campaign list previously will be retained. If this parameter is set to False and InitializeList is True, then manual entries will be removed from the list along with previously added automatic entries
StatusID
This is the Status ID value that each Campaign Propsect record will be set to when added to the Campaign as part of this process.

Return Value

Remarks

See Also

CampaignListBuilderObject Class | Aptify.Applications.Campaigns Namespace


CampaignListBuilderObject.Config Method

This method must be called before the object has any other methods called.

public virtual void Config(
AptifyApplication Application
);

Parameters

Application

Implements

IProcessComponent.

Remarks

See Also

CampaignListBuilderObject Class | Aptify.Applications.Campaigns Namespace


CampaignListBuilderObject.OnStatusUpdate Method

This method should be called to raise the StatusUpdate() event. This method can be called by sub-classes to raise the event from the base-class

protected virtual void OnStatusUpdate(
Int32 PercentComplete,
Int32 CurrentItem,
Int32 TotalItems,
ref Boolean& Cancel
);

Parameters

PercentComplete
CurrentItem
TotalItems
Cancel

Remarks

See Also

CampaignListBuilderObject Class | Aptify.Applications.Campaigns Namespace


CampaignListBuilderObject.Run Method

This process component supports running with the following parameters that are documents in the BuildCampaignProspectList method which this ProcessComponent will execute with the provided process component parameters. CampaignID (Required) Long StatusID (Required) Long InitializeList (Optional) Boolean - Defaults to True PreserveManualEntries (Optional) Boolean - Defaults To True The process component returns either "SUCCESS" or "FAILED" as its result code. Check the exception log for any additional details if the process component fails.

public string Run();

Return Value

Implements

IProcessComponent.

Remarks

See Also

CampaignListBuilderObject Class | Aptify.Applications.Campaigns Namespace


CampaignListBuilderObject Events

The events of the CampaignListBuilderObject class are listed below. For a complete list of CampaignListBuilderObject class members, see the CampaignListBuilderObject Members topic.

Public Instance Events

StatusUpdate This event is raised from the BuildCampaignProspectList() method for each item being processed in a list. This event can be listened to for providing status information to the user as well as to cancel the process if required by setting the Cancel parameter of this event to True.

See Also

CampaignListBuilderObject Class | Aptify.Applications.Campaigns Namespace


CampaignListBuilderObject.CampaignListBuilderObject.StatusUpdateEventHandler Event

This event is raised from the BuildCampaignProspectList() method for each item being processed in a list. This event can be listened to for providing status information to the user as well as to cancel the process if required by setting the Cancel parameter of this event to True.

public event CampaignListBuilderObject.StatusUpdateEventHandler StatusUpdate;

Remarks

See Also

CampaignListBuilderObject Class | Aptify.Applications.Campaigns Namespace


CampaignListBuilderObject.StatusUpdateEventHandler Delegate

public delegate void CampaignListBuilderObject.StatusUpdateEventHandler(
Int32 PercentComplete,
Int32 CurrentItem,
Int32 TotalItems,
ref Boolean& Cancel
);

Requirements

Namespace: Aptify.Applications.Campaigns

Assembly: AptifyCampaignListBuilderObject (in AptifyCampaignListBuilderObject.dll)

See Also

Aptify.Applications.Campaigns Namespace


CampaignListBuilderWizard Class

Aptify Campaign List Import Wizard. This GUI component utilizes the CampaignListBuilderObject to perform its underlying operations.

For a list of all members of this type, see CampaignListBuilderWizard Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
CampaignListBuilderWizard

public class CampaignListBuilderWizard : Form, IAptifyAction

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Campaigns

Assembly: AptifyCampaignListBuilderWizard (in AptifyCampaignListBuilderWizard.dll)

See Also

CampaignListBuilderWizard Members | Aptify.Applications.Campaigns Namespace


CampaignListBuilderWizard Members

CampaignListBuilderWizard overview

Public Instance Constructors

CampaignListBuilderWizard Constructor Initializes a new instance of the CampaignListBuilderWizard class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoAction | Overloaded.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Run |
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
m_oEngine |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStatusUpdate |
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CampaignListBuilderWizard Class | Aptify.Applications.Campaigns Namespace


CampaignListBuilderWizard Constructor

Initializes a new instance of the CampaignListBuilderWizard class.

public CampaignListBuilderWizard();

See Also

CampaignListBuilderWizard Class | Aptify.Applications.Campaigns Namespace


CampaignListBuilderWizard Properties

The properties of the CampaignListBuilderWizard class are listed below. For a complete list of CampaignListBuilderWizard class members, see the CampaignListBuilderWizard Members topic.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
m_oEngine |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

CampaignListBuilderWizard Class | Aptify.Applications.Campaigns Namespace


m_oEngine Property

Aptify 5.0 Software Development Kit (SDK)

CampaignListBuilderWizard.m_oEngine Property

protected virtual CampaignListBuilderObject m_oEngine {get; set;}

See Also

CampaignListBuilderWizard Class | Aptify.Applications.Campaigns Namespace


CampaignListBuilderWizard Methods

The methods of the CampaignListBuilderWizard class are listed below. For a complete list of CampaignListBuilderWizard class members, see the CampaignListBuilderWizard Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoAction | Overloaded.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Run |
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStatusUpdate |
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CampaignListBuilderWizard Class | Aptify.Applications.Campaigns Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

CampaignListBuilderWizard.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

CampaignListBuilderWizard Class | Aptify.Applications.Campaigns Namespace


CampaignListBuilderWizard.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

CampaignListBuilderWizard Class | Aptify.Applications.Campaigns Namespace | CampaignListBuilderWizard.Dispose Overload List


DoAction Method

Aptify 5.0 Software Development Kit (SDK)

CampaignListBuilderWizard.DoAction Method

Overload List

public void DoAction(AptifyApplication,Int64);

public void DoAction(AptifyApplication,Int64,Int64);

public void DoAction(AptifyApplication,Int64,Int64,params Object[]);

public void DoAction(AptifyApplication,Int64,params String[]);

See Also

CampaignListBuilderWizard Class | Aptify.Applications.Campaigns Namespace


CampaignListBuilderWizard.DoAction Method (AptifyApplication, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID
);

Implements

IAptifyAction.

See Also

CampaignListBuilderWizard Class | Aptify.Applications.Campaigns Namespace | CampaignListBuilderWizard.DoAction Overload List


CampaignListBuilderWizard.DoAction Method (AptifyApplication, Int64, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID
);

Implements

IAptifyAction.

See Also

CampaignListBuilderWizard Class | Aptify.Applications.Campaigns Namespace | CampaignListBuilderWizard.DoAction Overload List


CampaignListBuilderWizard.DoAction Method (AptifyApplication, Int64, Int64, Object[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID,
params Object[] SelectedItems
);

Implements

IAptifyAction.

See Also

CampaignListBuilderWizard Class | Aptify.Applications.Campaigns Namespace | CampaignListBuilderWizard.DoAction Overload List


CampaignListBuilderWizard.DoAction Method (AptifyApplication, Int64, String[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
params String[] SelectedItems
);

Implements

IAptifyAction.

See Also

CampaignListBuilderWizard Class | Aptify.Applications.Campaigns Namespace | CampaignListBuilderWizard.DoAction Overload List


CampaignListBuilderWizard.OnStatusUpdate Method

protected virtual void OnStatusUpdate(
Int32 PercentComplete,
Int32 CurrentItem,
Int32 TotalItems,
ref Boolean& Cancel
);

See Also

CampaignListBuilderWizard Class | Aptify.Applications.Campaigns Namespace


CampaignListBuilderWizard.Run Method

public virtual bool Run(
Int64 CampaignID
);

See Also

CampaignListBuilderWizard Class | Aptify.Applications.Campaigns Namespace


CampaignSegmentLayout Class

This class implements layout logic for the Windows UI for the Campaign Segments entity.

For a list of all members of this type, see CampaignSegmentLayout Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
CampaignSegmentLayout

public class CampaignSegmentLayout : FormTemplateLayout

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Campaigns

Assembly: CampaignLayoutControls (in CampaignLayoutControls.dll)

See Also

CampaignSegmentLayout Members | Aptify.Applications.Campaigns Namespace


CampaignSegmentLayout Members

CampaignSegmentLayout overview

Public Instance Constructors

CampaignSegmentLayout Constructor Initializes a new instance of the CampaignSegmentLayout class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
m_ctlFilterType |
m_ctlSQLQuery |
m_ctlViewID |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
BindControl | This method handles binding a control reference to a specific field name using the GetFormComponent() method of the base class. The method only attempts to bind the control reference if the control reference is Nothing or its inner control is disposed.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormTemplateLayout) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControls | This method handles binding the controls to their internal protected members.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
On_FilterType_ValueChanged | This member is responsible for processing changes in the Filter Type field value. The default behavior is to disable the SQLQuery field whenever the value is set to "View" and disable the ViewID field whenever the value is seto to "Standard"
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CampaignSegmentLayout Class | Aptify.Applications.Campaigns Namespace


CampaignSegmentLayout Constructor

Initializes a new instance of the CampaignSegmentLayout class.

public CampaignSegmentLayout();

See Also

CampaignSegmentLayout Class | Aptify.Applications.Campaigns Namespace


CampaignSegmentLayout Properties

The properties of the CampaignSegmentLayout class are listed below. For a complete list of CampaignSegmentLayout class members, see the CampaignSegmentLayout Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
m_ctlFilterType |
m_ctlSQLQuery |
m_ctlViewID |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

CampaignSegmentLayout Class | Aptify.Applications.Campaigns Namespace


m_ctlFilterType Property

Aptify 5.0 Software Development Kit (SDK)

CampaignSegmentLayout.m_ctlFilterType Property

protected virtual IAptifyDataFieldControlBase m_ctlFilterType {get; set;}

See Also

CampaignSegmentLayout Class | Aptify.Applications.Campaigns Namespace


m_ctlSQLQuery Property

Aptify 5.0 Software Development Kit (SDK)

CampaignSegmentLayout.m_ctlSQLQuery Property

protected virtual IAptifyDataFieldControlBase m_ctlSQLQuery {get; set;}

See Also

CampaignSegmentLayout Class | Aptify.Applications.Campaigns Namespace


m_ctlViewID Property

Aptify 5.0 Software Development Kit (SDK)

CampaignSegmentLayout.m_ctlViewID Property

protected virtual IAptifyDataFieldControlBase m_ctlViewID {get; set;}

See Also

CampaignSegmentLayout Class | Aptify.Applications.Campaigns Namespace


CampaignSegmentLayout Methods

The methods of the CampaignSegmentLayout class are listed below. For a complete list of CampaignSegmentLayout class members, see the CampaignSegmentLayout Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
BindControl | This method handles binding a control reference to a specific field name using the GetFormComponent() method of the base class. The method only attempts to bind the control reference if the control reference is Nothing or its inner control is disposed.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormTemplateLayout) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControls | This method handles binding the controls to their internal protected members.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
On_FilterType_ValueChanged | This member is responsible for processing changes in the Filter Type field value. The default behavior is to disable the SQLQuery field whenever the value is set to "View" and disable the ViewID field whenever the value is seto to "Standard"
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CampaignSegmentLayout Class | Aptify.Applications.Campaigns Namespace


CampaignSegmentLayout.BindControl Method

This method handles binding a control reference to a specific field name using the GetFormComponent() method of the base class. The method only attempts to bind the control reference if the control reference is Nothing or its inner control is disposed.

protected virtual void BindControl(
ref IAptifyDataFieldControlBase& control,
String FieldName
);

Parameters

control
FieldName

Remarks

See Also

CampaignSegmentLayout Class | Aptify.Applications.Campaigns Namespace


CampaignSegmentLayout.FindControls Method

This method handles binding the controls to their internal protected members.

protected virtual void FindControls();

Remarks

See Also

CampaignSegmentLayout Class | Aptify.Applications.Campaigns Namespace


CampaignSegmentLayout.On_FilterType_ValueChanged Method

This member is responsible for processing changes in the Filter Type field value. The default behavior is to disable the SQLQuery field whenever the value is set to "View" and disable the ViewID field whenever the value is seto to "Standard"

protected virtual void On_FilterType_ValueChanged(
Object sender,
Object OldValue,
Object NewValue
);

Parameters

sender
OldValue
NewValue

Remarks

See Also

CampaignSegmentLayout Class | Aptify.Applications.Campaigns Namespace


CampaignSegmentLayout.OnFormTemplateLoaded Method

protected override void OnFormTemplateLoaded(
FormTemplateLayout.FormTemplateLoadedEventArgs e
);

See Also

CampaignSegmentLayout Class | Aptify.Applications.Campaigns Namespace


CampaignSetupWizard Class

For a list of all members of this type, see CampaignSetupWizard Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
CampaignSetupWizard

public class CampaignSetupWizard : Form, IAptifyAction

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Campaigns

Assembly: AptifyCampaignSetupWizard (in AptifyCampaignSetupWizard.dll)

See Also

CampaignSetupWizard Members | Aptify.Applications.Campaigns Namespace


CampaignSetupWizard Members

CampaignSetupWizard overview

Public Instance Constructors

CampaignSetupWizard Constructor Initializes a new instance of the CampaignSetupWizard class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoAction | Overloaded.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
LoadStatuses |
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CampaignSetupWizard Class | Aptify.Applications.Campaigns Namespace


CampaignSetupWizard Constructor

Initializes a new instance of the CampaignSetupWizard class.

public CampaignSetupWizard();

See Also

CampaignSetupWizard Class | Aptify.Applications.Campaigns Namespace


CampaignSetupWizard Methods

The methods of the CampaignSetupWizard class are listed below. For a complete list of CampaignSetupWizard class members, see the CampaignSetupWizard Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoAction | Overloaded.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
LoadStatuses |
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CampaignSetupWizard Class | Aptify.Applications.Campaigns Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

CampaignSetupWizard.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

CampaignSetupWizard Class | Aptify.Applications.Campaigns Namespace


CampaignSetupWizard.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

CampaignSetupWizard Class | Aptify.Applications.Campaigns Namespace | CampaignSetupWizard.Dispose Overload List


DoAction Method

Aptify 5.0 Software Development Kit (SDK)

CampaignSetupWizard.DoAction Method

Overload List

public void DoAction(AptifyApplication,Int64);

public void DoAction(AptifyApplication,Int64,Int64);

public void DoAction(AptifyApplication,Int64,Int64,params Object[]);

public void DoAction(AptifyApplication,Int64,params String[]);

See Also

CampaignSetupWizard Class | Aptify.Applications.Campaigns Namespace


CampaignSetupWizard.DoAction Method (AptifyApplication, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID
);

Implements

IAptifyAction.

See Also

CampaignSetupWizard Class | Aptify.Applications.Campaigns Namespace | CampaignSetupWizard.DoAction Overload List


CampaignSetupWizard.DoAction Method (AptifyApplication, Int64, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID
);

Implements

IAptifyAction.

See Also

CampaignSetupWizard Class | Aptify.Applications.Campaigns Namespace | CampaignSetupWizard.DoAction Overload List


CampaignSetupWizard.DoAction Method (AptifyApplication, Int64, Int64, Object[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID,
params Object[] SelectedItems
);

Implements

IAptifyAction.

See Also

CampaignSetupWizard Class | Aptify.Applications.Campaigns Namespace | CampaignSetupWizard.DoAction Overload List


CampaignSetupWizard.DoAction Method (AptifyApplication, Int64, String[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
params String[] SelectedItems
);

Implements

IAptifyAction.

See Also

CampaignSetupWizard Class | Aptify.Applications.Campaigns Namespace | CampaignSetupWizard.DoAction Overload List


CampaignSetupWizard.LoadStatuses Method

public bool LoadStatuses();

See Also

CampaignSetupWizard Class | Aptify.Applications.Campaigns Namespace


ICampaignCalculateDiscount Interface

Interface used to create plug-ins for retrieving discounts associated with Campaigns

For a list of all members of this type, see ICampaignCalculateDiscount Members.

public interface ICampaignCalculateDiscount

Remarks

Requirements

Namespace: Aptify.Applications.Campaigns

Assembly: ICampaignCalculateDiscount (in ICampaignCalculateDiscount.dll)

See Also

ICampaignCalculateDiscount Members | Aptify.Applications.Campaigns Namespace


ICampaignCalculateDiscount Members

ICampaignCalculateDiscount overview

Public Instance Methods

Config | Call this function before using any other method on the interface to configure the object for use
GetCampaignPricing | Function will return the campaign discount percentage to be used for the specified product based on the parameters provided

See Also

ICampaignCalculateDiscount Interface | Aptify.Applications.Campaigns Namespace


ICampaignCalculateDiscount Methods

The methods of the ICampaignCalculateDiscount interface are listed below. For a complete list of ICampaignCalculateDiscount interface members, see the ICampaignCalculateDiscount Members topic.

Public Instance Methods

Config | Call this function before using any other method on the interface to configure the object for use
GetCampaignPricing | Function will return the campaign discount percentage to be used for the specified product based on the parameters provided

See Also

ICampaignCalculateDiscount Interface | Aptify.Applications.Campaigns Namespace


ICampaignCalculateDiscount.Config Method

Call this function before using any other method on the interface to configure the object for use

void Config(
AptifyApplication Application
);

Parameters

Application
Aptify Application Required for Use of the Object

Remarks

See Also

ICampaignCalculateDiscount Interface | Aptify.Applications.Campaigns Namespace


ICampaignCalculateDiscount.GetCampaignPricing Method

Function will return the campaign discount percentage to be used for the specified product based on the parameters provided

bool GetCampaignPricing(
Int64 CampaignID,
Int64 MemberTypeID,
Int64 CompanyMemberTypeID,
Int64 ProductID,
Decimal SystemCalculatedPrice,
ref Double& DiscountPercentage,
String OrderDate
);

Parameters

CampaignID
Campaign ID
MemberTypeID
Member Type of the individual on the order
CompanyMemberTypeID
Member Type of the company on the order
ProductID
Product for which pricing discounts are being calculated
SystemCalculatedPrice
Price calculated by standard system pricing model
DiscountPercentage
Output Parameter: Discount Percentage is returned through this parameter
OrderDate
Optional: Date of Order being processed

Return Value

True if operation succeeds, False otherwise

Remarks

See Also

ICampaignCalculateDiscount Interface | Aptify.Applications.Campaigns Namespace


Aptify.Applications.Campaigns.ListImport

Aptify 5.0 Software Development Kit (SDK)

Aptify.Applications.Campaigns.ListImport Namespace

This namespace corresponds to the Campaign List Import wizard provided with the Campaign Management application.

Namespace hierarchy

Classes

Class | Description
CampaignImportMappingControl | Provides a mapping user interface that allows a user to map information from an input format to the import run
CampaignImportWizard | Campaign Import Wizard User Interface Class(Form)
CampaignListImporter | This object provides the default implementation in Aptify CRM for the ICampaignListImporter interface
CampaignListImportShared | Shared utility methods for Campaign List Import Functionality
CampaignListMatch | This object provides the default implementation in Aptify CRM for the ICampaignListMatch interface
CampaignListPost | Class implements the ICampaignListPost interface and provides import list posting functionality.
CampaignMatch | Class used to track information for each potential and absolute campaign match
CampaignMatchCollection | Default implemention for ICampaignMatchCollection
CampaignMatchPostControl | Provides a user interface that allows a user to view matching(partial and absolute), unmatched, and posted records for a given Campaign Import Run record.
CSVTextFileReader | This class provides an implementation for a comma-separated value text file.
DefaultCompanyMatch | Default Aptify Company Matching class for Aptify CRM. This class inherits from RecordMatchBase and simply provides a default implementation for matching company records in the MatchRecord method().
DefaultCompanyPost | This class provides the default posting logic for Aptify CRM for the Company Campaign Import List Type. It is possible to sub-class this class and override various methods to alter the posting logic as required.
DefaultPersonMatch | Default Aptify Person Matching class for Aptify CRM. This class inherits from RecordMatchBase and simply provides a default implementation for matching person records in the MatchRecord method().
DefaultPersonPost | This class provides the default posting logic for Aptify CRM for the Persons Campaign Import List Type. It is possible to sub-class this class and override various methods to alter the posting logic as required.
ExcelFileReader | This class provides an implementation for Microsoft Excel Files. The class imports the first sheet in the workbook provided.
FileReaderBase | This is the base class for reading in any type of file and loading up its contents This class must be inherited from to be used as it does not intrinscially define the type of file in any way. Override this class to implement the file loading and file manipulation implementation. This class provides an implementation of ICampaignListFileReader and the methods of that interface are exposed as Public and Overridable so that sub-classes can alter those interface methods as well as the internal implementation protected methods of this base class.
RecordMatchBase | This class provides base functionality for record matching in the Campaign List Import architecture It requires that it be inherited from for use since the MatchRecord() method of the ICampaignRecordMatch interface is not implemented by this base class. Use this base class for sub-classing to create application specific matching rules.
RecordPostBase | This class provides base functionality for record posting in the Campaign List Import architecture It requires that it be inherited from for use since the PostRecord() method of the ICampaignRecordPost interface is not implemented by this base class. Use this base class for sub-classing to create application specific posting rules.
TabTextFileReader | This class provides an implementation for a tab-separated value text file
TextFileReaderBase | This is the base class for reading in text files and loading up their contents This class must be inherited from to be used as it does not intrinscially define the delimiters and data format for the file. Override this class to specify a delimiter, text separator, or override/augment the base functionality for file parsing in the various methods that are defined in this base class. This class provides an implementation of ICampaignListFileReader and the methods of that interface are exposed as Public and Overridable so that sub-classes can alter those interface methods as well as the internal implementation protected methods of this base class.

Interfaces

Interface | Description
ICampaignListFileReader | Interface to provide plug-in components for the file reading process.
ICampaignListImporter | Interface to provide plug-in for the overall list import process which consists of loading a file, matching data records and then posting those records that have been through the match process succesfully.
ICampaignListMatch | Interface to provide plug-in components for the entire list matching process. To override the individual record posting function as opposed to the overall process, utilize the ICampaignRecordMatch interface/object implementation
ICampaignListPost | Interface to provide plug-in components for the entire list posting process. To override the individual record posting function as opposed to the overall process, utilize the ICampaignRecordPost interface/object implementation
ICampaignMatchCollection | Interface used to create plug-ins for managing a group/collection of potential matches for each record in a list import process
ICampaignRecordMatch | This interface is used to implement plug in components that contain logic for matching a single record against something in the DB
ICampaignRecordPost | Interface used to create plug-ins for posting a single record during the campaign list import process
ICampaignStatusCallback |

Delegates

Delegate | Description
CampaignListImporter.AfterNewDetailRecordEventHandler |
CampaignListImporter.BeforeNewDetailRecordEventHandler |
CampaignListImporter.BeforeSaveNewDetailRecordEventHandler |
ICampaignListFileReader.StatusUpdateEventHandler |
ICampaignListImporter.StatusUpdateEventHandler |
ICampaignListMatch.StatusUpdateEventHandler |
ICampaignListPost.StatusUpdateEventHandler |

Enumerations

Enumeration | Description
CampaignListMatch.EntityMatchType |
ICampaignStatusCallback.ImportPhase |
MatchType |


CampaignImportMappingControl Class

Provides a mapping user interface that allows a user to map information from an input format to the import run

For a list of all members of this type, see CampaignImportMappingControl Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
CampaignImportMappingControl

public class CampaignImportMappingControl : FormComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Campaigns.ListImport

Assembly: AptifyCampaignImportControls (in AptifyCampaignImportControls.dll)

See Also

CampaignImportMappingControl Members | Aptify.Applications.Campaigns.ListImport Namespace


CampaignImportMappingControl Members

CampaignImportMappingControl overview

Public Instance Constructors

CampaignImportMappingControl Constructor Initializes a new instance of the CampaignImportMappingControl class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
Database |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LoadControl |
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormComponent) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
TransferDataToObject |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateContext (inherited from FormComponent) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
ApplySkin |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
GetWritableEntityFields |
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormComponent) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CampaignImportMappingControl Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignImportMappingControl Constructor

Initializes a new instance of the CampaignImportMappingControl class.

public CampaignImportMappingControl();

See Also

CampaignImportMappingControl Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignImportMappingControl Properties

The properties of the CampaignImportMappingControl class are listed below. For a complete list of CampaignImportMappingControl class members, see the CampaignImportMappingControl Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
Database |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateContext (inherited from FormComponent) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

CampaignImportMappingControl Class | Aptify.Applications.Campaigns.ListImport Namespace


Database Property

Aptify 5.0 Software Development Kit (SDK)

CampaignImportMappingControl.Database Property

public virtual String Database {get;}

See Also

CampaignImportMappingControl Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignImportMappingControl Methods

The methods of the CampaignImportMappingControl class are listed below. For a complete list of CampaignImportMappingControl class members, see the CampaignImportMappingControl Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LoadControl |
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormComponent) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
TransferDataToObject |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
ApplySkin |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
GetWritableEntityFields |
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormComponent) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CampaignImportMappingControl Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignImportMappingControl.ApplySkin Method

protected virtual void ApplySkin();

See Also

CampaignImportMappingControl Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignImportMappingControl.Config Method

public void Config(
AptifyApplication ApplicationObject
);

See Also

CampaignImportMappingControl Class | Aptify.Applications.Campaigns.ListImport Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

CampaignImportMappingControl.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

CampaignImportMappingControl Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignImportMappingControl.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

CampaignImportMappingControl Class | Aptify.Applications.Campaigns.ListImport Namespace | CampaignImportMappingControl.Dispose Overload List


CampaignImportMappingControl.GetWritableEntityFields Method

protected virtual List<T> GetWritableEntityFields(
String EntityName
);

See Also

CampaignImportMappingControl Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignImportMappingControl.LoadControl Method

public virtual bool LoadControl(
AptifyGenericEntityBase ImportRun
);

See Also

CampaignImportMappingControl Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignImportMappingControl.OnFormComponentConfig Method

protected override void OnFormComponentConfig(
AptifyFormTemplateContext FormTemplateContext
);

Implements

IFormComponent.

See Also

CampaignImportMappingControl Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignImportMappingControl.OnRefresh Method

protected override void OnRefresh();

Implements

IFormComponent.

See Also

CampaignImportMappingControl Class | Aptify.Applications.Campaigns.ListImport Namespace


OnShow Method

Aptify 5.0 Software Development Kit (SDK)

CampaignImportMappingControl.OnShow Method

Overload List

protected override void OnShow();

protected override void OnShow(Boolean);

See Also

CampaignImportMappingControl Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignImportMappingControl.OnShow Method ()

protected override void OnShow();

Implements

IFormComponent.

See Also

CampaignImportMappingControl Class | Aptify.Applications.Campaigns.ListImport Namespace | CampaignImportMappingControl.OnShow Overload List


CampaignImportMappingControl.OnShow Method (Boolean)

protected override void OnShow(
Boolean Refresh
);

Implements

IFormComponent.

See Also

CampaignImportMappingControl Class | Aptify.Applications.Campaigns.ListImport Namespace | CampaignImportMappingControl.OnShow Overload List


CampaignImportMappingControl.OnTransferDataToObject Method

protected override void OnTransferDataToObject(
ref Boolean& Cancel
);

Implements

IFormComponent.

See Also

CampaignImportMappingControl Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignImportMappingControl.TransferDataToObject Method

public bool TransferDataToObject();

See Also

CampaignImportMappingControl Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignImportWizard Class

Campaign Import Wizard User Interface Class(Form)

For a list of all members of this type, see CampaignImportWizard Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
CampaignImportWizard

public class CampaignImportWizard : Form, IAptifyAction, ICampaignStatusCallback

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Campaigns.ListImport

Assembly: AptifyCampaignImportListWizard (in AptifyCampaignImportListWizard.dll)

See Also

CampaignImportWizard Members | Aptify.Applications.Campaigns.ListImport Namespace


CampaignImportWizard Members

CampaignImportWizard overview

Public Instance Constructors

CampaignImportWizard Constructor Initializes a new instance of the CampaignImportWizard class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoAction | Overloaded.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
StatusUpdate |
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CampaignImportWizard Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignImportWizard Constructor

Initializes a new instance of the CampaignImportWizard class.

public CampaignImportWizard();

See Also

CampaignImportWizard Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignImportWizard Methods

The methods of the CampaignImportWizard class are listed below. For a complete list of CampaignImportWizard class members, see the CampaignImportWizard Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoAction | Overloaded.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
StatusUpdate |
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CampaignImportWizard Class | Aptify.Applications.Campaigns.ListImport Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

CampaignImportWizard.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

CampaignImportWizard Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignImportWizard.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

CampaignImportWizard Class | Aptify.Applications.Campaigns.ListImport Namespace | CampaignImportWizard.Dispose Overload List


DoAction Method

Aptify 5.0 Software Development Kit (SDK)

CampaignImportWizard.DoAction Method

Overload List

public void DoAction(AptifyApplication,Int64);

public void DoAction(AptifyApplication,Int64,Int64);

public void DoAction(AptifyApplication,Int64,Int64,params Object[]);

public void DoAction(AptifyApplication,Int64,params String[]);

See Also

CampaignImportWizard Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignImportWizard.DoAction Method (AptifyApplication, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID
);

Implements

IAptifyAction.

See Also

CampaignImportWizard Class | Aptify.Applications.Campaigns.ListImport Namespace | CampaignImportWizard.DoAction Overload List


CampaignImportWizard.DoAction Method (AptifyApplication, Int64, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID
);

Implements

IAptifyAction.

See Also

CampaignImportWizard Class | Aptify.Applications.Campaigns.ListImport Namespace | CampaignImportWizard.DoAction Overload List


CampaignImportWizard.DoAction Method (AptifyApplication, Int64, Int64, Object[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID,
params Object[] SelectedItems
);

Implements

IAptifyAction.

See Also

CampaignImportWizard Class | Aptify.Applications.Campaigns.ListImport Namespace | CampaignImportWizard.DoAction Overload List


CampaignImportWizard.DoAction Method (AptifyApplication, Int64, String[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
params String[] SelectedItems
);

Implements

IAptifyAction.

See Also

CampaignImportWizard Class | Aptify.Applications.Campaigns.ListImport Namespace | CampaignImportWizard.DoAction Overload List


CampaignImportWizard.StatusUpdate Method

public void StatusUpdate(
ICampaignStatusCallback.ImportPhase Phase,
Int64 RecordNumber,
String RecordName,
Single PercentComplete,
ref Boolean& Cancel
);

Implements

ICampaignStatusCallback.

See Also

CampaignImportWizard Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignListImporter Class

This object provides the default implementation in Aptify CRM for the ICampaignListImporter interface

For a list of all members of this type, see CampaignListImporter Members.

System.Object
CampaignListImporter

public class CampaignListImporter : ICampaignListImporter, IProcessComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Campaigns.ListImport

Assembly: CampaignListImport (in CampaignListImport.dll)

See Also

CampaignListImporter Members | Aptify.Applications.Campaigns.ListImport Namespace


CampaignListImporter Members

CampaignListImporter overview

Public Instance Constructors

CampaignListImporter Constructor Initializes a new instance of the CampaignListImporter class.

Public Instance Properties

Properties

Public Instance Methods

Config |
DoImport | This is the main function in this class that handles the overall import process based on the Import Run ID passed into the function. It is possible to override this function or the components of its execution through other overridable methods of the base class when it is necessary to alter the functionality of the process.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run |
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

AfterNewDetailRecord | This event is raised after a new detail record is succesfully saved in the database by the GE object.
BeforeNewDetailRecord | This event is raised before a new detail record is created in the GE object. To cancel the process, set the Cancel parameter to True
BeforeSaveNewDetailRecord | This event is raised before a new detail record is saved in the database by the GE object. To cancel the process, set the Cancel parameter to True
StatusUpdate |

Protected Instance Methods

AddColumnData | This method is responsible for adding column data to the Import Run Detail Columns sub-type and adds all of the columns specified in the ColumnNames() array that is passed into this method to retrieve the column data from the FileReader object and then adds each of those values into the sub-type. This method assumes that the sub-type CampaignImportRunDetailColumns is blank for the provided DetailGE object.
CreateListDetail | This function is responsible for creating individual Campaign List Import Detail records in the database using the provided DetailGE generic entity object. It is the responsibility of this function to call the NewRecord() and Save() methods of the DetailGE object. This method goes through the following steps: 1) Call OnBeforeNewDetailRecord() which Raises the BeforeNewDetailRecord Event 2) If Step #1 doesn't cancel the process, then create new record in GE and set up all appropriate values in the GE object for the deatil record 3) Call OnBeforeSaveNewDetailRecord() which raises the BeforeSaveNewDetailRecord Event 4) If Step #3 doesn't cancel the process, save the new GE record 5) If the Save is a success, call the OnAfterNewDetailRecord() method which raises the AfterNewDetailRecord event. Use the above information to determine where to implement overriden methods or event handlers that augment/alter the underlying logic of this routine
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetColumnData | This method is responsible for building a string that returns the data that is specified in the collection that is passed in which is a collection of column numbers that are desired for the return string.
LoadFileReaderObject | This method is responsible for loading the file reader object for the specified Import Run. This method also returns the File Type that is being used in the Import Run specified. By default, this method simply loads the meta-data attributes from the Campaign Import File Types entity and loads the plug in object that is listed there for the Object/Class/Assembly fields.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterNewDetailRecord | Refer to the documention on the CreateListDetail() method for information on when this method is called
OnBeforeNewDetailRecord | Refer to the documention on the CreateListDetail() method for information on when this method is called
OnBeforeSaveNewDetailRecord | Refer to the documention on the CreateListDetail() method for information on when this method is called
OnStatusUpdate | This method is called by the list import process during each iteration of loading the file. By default, it calls the StatusCallback object (if provided) and also raises the StatusUpdate event

See Also

CampaignListImporter Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignListImporter Constructor

Initializes a new instance of the CampaignListImporter class.

public CampaignListImporter();

See Also

CampaignListImporter Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignListImporter Properties

The properties of the CampaignListImporter class are listed below. For a complete list of CampaignListImporter class members, see the CampaignListImporter Members topic.

Public Instance Properties

Properties

See Also

CampaignListImporter Class | Aptify.Applications.Campaigns.ListImport Namespace


Properties Property

Aptify 5.0 Software Development Kit (SDK)

CampaignListImporter.Properties Property

public AptifyProperties Properties {get;}

Implements

IProcessComponent.

See Also

CampaignListImporter Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignListImporter Methods

The methods of the CampaignListImporter class are listed below. For a complete list of CampaignListImporter class members, see the CampaignListImporter Members topic.

Public Instance Methods

Config |
DoImport | This is the main function in this class that handles the overall import process based on the Import Run ID passed into the function. It is possible to override this function or the components of its execution through other overridable methods of the base class when it is necessary to alter the functionality of the process.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

AddColumnData | This method is responsible for adding column data to the Import Run Detail Columns sub-type and adds all of the columns specified in the ColumnNames() array that is passed into this method to retrieve the column data from the FileReader object and then adds each of those values into the sub-type. This method assumes that the sub-type CampaignImportRunDetailColumns is blank for the provided DetailGE object.
CreateListDetail | This function is responsible for creating individual Campaign List Import Detail records in the database using the provided DetailGE generic entity object. It is the responsibility of this function to call the NewRecord() and Save() methods of the DetailGE object. This method goes through the following steps: 1) Call OnBeforeNewDetailRecord() which Raises the BeforeNewDetailRecord Event 2) If Step #1 doesn't cancel the process, then create new record in GE and set up all appropriate values in the GE object for the deatil record 3) Call OnBeforeSaveNewDetailRecord() which raises the BeforeSaveNewDetailRecord Event 4) If Step #3 doesn't cancel the process, save the new GE record 5) If the Save is a success, call the OnAfterNewDetailRecord() method which raises the AfterNewDetailRecord event. Use the above information to determine where to implement overriden methods or event handlers that augment/alter the underlying logic of this routine
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetColumnData | This method is responsible for building a string that returns the data that is specified in the collection that is passed in which is a collection of column numbers that are desired for the return string.
LoadFileReaderObject | This method is responsible for loading the file reader object for the specified Import Run. This method also returns the File Type that is being used in the Import Run specified. By default, this method simply loads the meta-data attributes from the Campaign Import File Types entity and loads the plug in object that is listed there for the Object/Class/Assembly fields.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterNewDetailRecord | Refer to the documention on the CreateListDetail() method for information on when this method is called
OnBeforeNewDetailRecord | Refer to the documention on the CreateListDetail() method for information on when this method is called
OnBeforeSaveNewDetailRecord | Refer to the documention on the CreateListDetail() method for information on when this method is called
OnStatusUpdate | This method is called by the list import process during each iteration of loading the file. By default, it calls the StatusCallback object (if provided) and also raises the StatusUpdate event

See Also

CampaignListImporter Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignListImporter.AddColumnData Method

This method is responsible for adding column data to the Import Run Detail Columns sub-type and adds all of the columns specified in the ColumnNames() array that is passed into this method to retrieve the column data from the FileReader object and then adds each of those values into the sub-type. This method assumes that the sub-type CampaignImportRunDetailColumns is blank for the provided DetailGE object.

protected virtual bool AddColumnData(
ICampaignListFileReader FileReader,
AptifyGenericEntityBase DetailGE,
Int64 RowNumber,
List<T> colNames
);

Parameters

FileReader
DetailGE
RowNumber
colNames

Return Value

True if operation succeeds, False otherwise

Remarks

See Also

CampaignListImporter Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignListImporter.Config Method

public virtual void Config(
AptifyApplication Application
);

Implements

IProcessComponent.

See Also

CampaignListImporter Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignListImporter.CreateListDetail Method

This function is responsible for creating individual Campaign List Import Detail records in the database using the provided DetailGE generic entity object. It is the responsibility of this function to call the NewRecord() and Save() methods of the DetailGE object. This method goes through the following steps: 1) Call OnBeforeNewDetailRecord() which Raises the BeforeNewDetailRecord Event 2) If Step #1 doesn't cancel the process, then create new record in GE and set up all appropriate values in the GE object for the deatil record 3) Call OnBeforeSaveNewDetailRecord() which raises the BeforeSaveNewDetailRecord Event 4) If Step #3 doesn't cancel the process, save the new GE record 5) If the Save is a success, call the OnAfterNewDetailRecord() method which raises the AfterNewDetailRecord event. Use the above information to determine where to implement overriden methods or event handlers that augment/alter the underlying logic of this routine

protected virtual bool CreateListDetail(
Int64 ImportRunID,
Int64 RowNumber,
AptifyGenericEntityBase DetailGE,
ICampaignListFileReader FileReader,
List<T> DisplayColumns,
List<T> AllColumns,
ref String& RowName
);

Parameters

ImportRunID
Import Run ID Number
RowNumber
Row Number within the file being imported
DetailGE
Aptify GE Object to be used to create the record in the database
FileReader
ICampaignListFileReader object being used to import the file data
DisplayColumns
Array of Column Names that are being used to create the "Display Name" string for each row that will be presented to the user when reviewing each record
AllColumns
Array of Column Names for all of the columns that are to be imported based on the Import File type definition.
RowName

Return Value

Remarks

See Also

CampaignListImporter Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignListImporter.DoImport Method

This is the main function in this class that handles the overall import process based on the Import Run ID passed into the function. It is possible to override this function or the components of its execution through other overridable methods of the base class when it is necessary to alter the functionality of the process.

public virtual bool DoImport(
Int64 ImportRunID,
ICampaignStatusCallback StatusCallback
);

Parameters

ImportRunID
Campaign Import Run Record ID Number that exists in the database and has been setup with all necessary elements of data
StatusCallback
Optional parameter providing a reference to an object that provides an implementation of ICampaignStatusCallback

Return Value

True if the method completes its operation succesfully, False otherwise (with details in the session exception log)

Implements

ICampaignListImporter.

Remarks

See Also

CampaignListImporter Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignListImporter.GetColumnData Method

This method is responsible for building a string that returns the data that is specified in the collection that is passed in which is a collection of column numbers that are desired for the return string.

protected virtual string GetColumnData(
ICampaignListFileReader FileReader,
List<T> colsToRetrieve
);

Parameters

FileReader
colsToRetrieve

Return Value

Remarks

See Also

CampaignListImporter Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignListImporter.LoadFileReaderObject Method

This method is responsible for loading the file reader object for the specified Import Run. This method also returns the File Type that is being used in the Import Run specified. By default, this method simply loads the meta-data attributes from the Campaign Import File Types entity and loads the plug in object that is listed there for the Object/Class/Assembly fields.

protected virtual ICampaignListFileReader LoadFileReaderObject(
Int64 ImportRunID,
ref Int64& FileTypeID
);

Parameters

ImportRunID
FileTypeID
Out Parameter: specifies the file type used by the Import Run ID specified

Return Value

A reference to the ICampaignListFileReader object or Nothing if the method fails

Remarks

See Also

CampaignListImporter Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignListImporter.OnAfterNewDetailRecord Method

Refer to the documention on the CreateListDetail() method for information on when this method is called

protected virtual void OnAfterNewDetailRecord(
AptifyGenericEntityBase DetailGE
);

Parameters

DetailGE

Remarks

See Also

CampaignListImporter Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignListImporter.OnBeforeNewDetailRecord Method

Refer to the documention on the CreateListDetail() method for information on when this method is called

protected virtual void OnBeforeNewDetailRecord(
AptifyGenericEntityBase DetailGE,
ref Boolean& Cancel
);

Parameters

DetailGE
Cancel

Remarks

See Also

CampaignListImporter Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignListImporter.OnBeforeSaveNewDetailRecord Method

Refer to the documention on the CreateListDetail() method for information on when this method is called

protected virtual void OnBeforeSaveNewDetailRecord(
AptifyGenericEntityBase DetailGE,
ref Boolean& Cancel
);

Parameters

DetailGE
Cancel

Remarks

See Also

CampaignListImporter Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignListImporter.OnStatusUpdate Method

This method is called by the list import process during each iteration of loading the file. By default, it calls the StatusCallback object (if provided) and also raises the StatusUpdate event

protected virtual void OnStatusUpdate(
ICampaignStatusCallback StatusCallback,
Int64 RecordNumber,
String RecordName,
Single PercentComplete,
ref Boolean& Cancel
);

Parameters

StatusCallback
RecordNumber
RecordName
PercentComplete
Cancel

Remarks

See Also

CampaignListImporter Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignListImporter.Run Method

public string Run();

Implements

IProcessComponent.

See Also

CampaignListImporter Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignListImporter Events

The events of the CampaignListImporter class are listed below. For a complete list of CampaignListImporter class members, see the CampaignListImporter Members topic.

Public Instance Events

AfterNewDetailRecord | This event is raised after a new detail record is succesfully saved in the database by the GE object.
BeforeNewDetailRecord | This event is raised before a new detail record is created in the GE object. To cancel the process, set the Cancel parameter to True
BeforeSaveNewDetailRecord | This event is raised before a new detail record is saved in the database by the GE object. To cancel the process, set the Cancel parameter to True
StatusUpdate |

See Also

CampaignListImporter Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignListImporter.CampaignListImporter.AfterNewDetailRecordEventHandler Event

This event is raised after a new detail record is succesfully saved in the database by the GE object.

public event CampaignListImporter.AfterNewDetailRecordEventHandler AfterNewDetailRecord;

Remarks

See Also

CampaignListImporter Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignListImporter.CampaignListImporter.BeforeNewDetailRecordEventHandler Event

This event is raised before a new detail record is created in the GE object. To cancel the process, set the Cancel parameter to True

public event CampaignListImporter.BeforeNewDetailRecordEventHandler BeforeNewDetailRecord;

Remarks

See Also

CampaignListImporter Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignListImporter.CampaignListImporter.BeforeSaveNewDetailRecordEventHandler Event

This event is raised before a new detail record is saved in the database by the GE object. To cancel the process, set the Cancel parameter to True

public event CampaignListImporter.BeforeSaveNewDetailRecordEventHandler BeforeSaveNewDetailRecord;

Remarks

See Also

CampaignListImporter Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignListImporter.ICampaignListImporter.StatusUpdateEventHandler Event

public event ICampaignListImporter.StatusUpdateEventHandler StatusUpdate;

Implements

ICampaignListImporter.

See Also

CampaignListImporter Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignListImporter.AfterNewDetailRecordEventHandler Delegate

public delegate void CampaignListImporter.AfterNewDetailRecordEventHandler(
AptifyGenericEntityBase DetailGE
);

Requirements

Namespace: Aptify.Applications.Campaigns.ListImport

Assembly: CampaignListImport (in CampaignListImport.dll)

See Also

Aptify.Applications.Campaigns.ListImport Namespace


CampaignListImporter.BeforeNewDetailRecordEventHandler Delegate

public delegate void CampaignListImporter.BeforeNewDetailRecordEventHandler(
AptifyGenericEntityBase DetailGE,
ref Boolean& Cancel
);

Requirements

Namespace: Aptify.Applications.Campaigns.ListImport

Assembly: CampaignListImport (in CampaignListImport.dll)

See Also

Aptify.Applications.Campaigns.ListImport Namespace


CampaignListImporter.BeforeSaveNewDetailRecordEventHandler Delegate

public delegate void CampaignListImporter.BeforeSaveNewDetailRecordEventHandler(
AptifyGenericEntityBase DetailGE,
ref Boolean& Cancel
);

Requirements

Namespace: Aptify.Applications.Campaigns.ListImport

Assembly: CampaignListImport (in CampaignListImport.dll)

See Also

Aptify.Applications.Campaigns.ListImport Namespace


CampaignListImportShared Class

Shared utility methods for Campaign List Import Functionality

For a list of all members of this type, see CampaignListImportShared Members.

System.Object
CampaignListImportShared

public class CampaignListImportShared

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Campaigns.ListImport

Assembly: CampaignListImport (in CampaignListImport.dll)

See Also

CampaignListImportShared Members | Aptify.Applications.Campaigns.ListImport Namespace


CampaignListImportShared Members

CampaignListImportShared overview

Public Static Methods

CreateImportRun | Overloaded. This method creates a new GE object for the Campaign Import Runs entity and returns it populated with the parameter values provided. This overload allows you to specify a start date. The other overload uses the current date and time.
GetImportFileTypeEntity | This method is responsible for returning the MappingEntity field from the Campaign Import File Types entity for the provided Campaign Import File Type ID
GetObjectFromRepository | This method will return an object instantiated by looking up entity attributes for the assembly name, object repository location, and class name from entity attributes, instantiate the object and return it.

Public Instance Constructors

CampaignListImportShared Constructor Initializes a new instance of the CampaignListImportShared class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CampaignListImportShared Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignListImportShared Constructor

Initializes a new instance of the CampaignListImportShared class.

public CampaignListImportShared();

See Also

CampaignListImportShared Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignListImportShared Methods

The methods of the CampaignListImportShared class are listed below. For a complete list of CampaignListImportShared class members, see the CampaignListImportShared Members topic.

Public Static Methods

CreateImportRun | Overloaded. This method creates a new GE object for the Campaign Import Runs entity and returns it populated with the parameter values provided. This overload allows you to specify a start date. The other overload uses the current date and time.
GetImportFileTypeEntity | This method is responsible for returning the MappingEntity field from the Campaign Import File Types entity for the provided Campaign Import File Type ID
GetObjectFromRepository | This method will return an object instantiated by looking up entity attributes for the assembly name, object repository location, and class name from entity attributes, instantiate the object and return it.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CampaignListImportShared Class | Aptify.Applications.Campaigns.ListImport Namespace


CreateImportRun Method

Aptify 5.0 Software Development Kit (SDK)

CampaignListImportShared.CreateImportRun Method

This method creates a new GE object for the Campaign Import Runs entity and returns it populated with the parameter values provided.

Overload List

This method creates a new GE object for the Campaign Import Runs entity and returns it populated with the parameter values provided.

public static AptifyGenericEntityBase CreateImportRun(AptifyApplication,Int64,Int64,String,Boolean);

This method creates a new GE object for the Campaign Import Runs entity and returns it populated with the parameter values provided. This overload allows you to specify a start date. The other overload uses the current date and time.

public static AptifyGenericEntityBase CreateImportRun(AptifyApplication,Int64,Int64,String,DateTime,Boolean);

See Also

CampaignListImportShared Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignListImportShared.CreateImportRun Method (AptifyApplication, Int64, Int64, String, Boolean)

This method creates a new GE object for the Campaign Import Runs entity and returns it populated with the parameter values provided.

public static AptifyGenericEntityBase CreateImportRun(
AptifyApplication ApplicationObject,
Int64 ImportFileTypeID,
Int64 CampaignID,
String OriginalFileLocation,
Boolean SaveRecord
);

Parameters

ApplicationObject
ImportFileTypeID
CampaignID
OriginalFileLocation
SaveRecord

Return Value

Remarks

See Also

CampaignListImportShared Class | Aptify.Applications.Campaigns.ListImport Namespace | CampaignListImportShared.CreateImportRun Overload List


CampaignListImportShared.CreateImportRun Method (AptifyApplication, Int64, Int64, String, DateTime, Boolean)

This method creates a new GE object for the Campaign Import Runs entity and returns it populated with the parameter values provided. This overload allows you to specify a start date. The other overload uses the current date and time.

public static AptifyGenericEntityBase CreateImportRun(
AptifyApplication ApplicationObject,
Int64 ImportFileTypeID,
Int64 CampaignID,
String OriginalFileLocation,
DateTime StartDate,
Boolean SaveRecord
);

Parameters

ApplicationObject
ImportFileTypeID
CampaignID
OriginalFileLocation
StartDate
SaveRecord

Return Value

Remarks

See Also

CampaignListImportShared Class | Aptify.Applications.Campaigns.ListImport Namespace | CampaignListImportShared.CreateImportRun Overload List


CampaignListImportShared.GetImportFileTypeEntity Method

This method is responsible for returning the MappingEntity field from the Campaign Import File Types entity for the provided Campaign Import File Type ID

public static string GetImportFileTypeEntity(
AptifyApplication Application,
IAptifyDataAction DataAction,
Int64 FileTypeID
);

Parameters

Application
DataAction
FileTypeID

Return Value

Remarks

See Also

CampaignListImportShared Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignListImportShared.GetObjectFromRepository Method

This method will return an object instantiated by looking up entity attributes for the assembly name, object repository location, and class name from entity attributes, instantiate the object and return it.

public static object GetObjectFromRepository(
AptifyApplication ApplicationObject,
String AssemblyAttribute,
String ObjectAttribute,
String ClassAttribute,
String EntityName
);

Parameters

ApplicationObject
AssemblyAttribute
ObjectAttribute
ClassAttribute
EntityName
If not provided, Campaign Import Runs is used as the default entity for entity attribute lookup

Return Value

Remarks

See Also

CampaignListImportShared Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignListMatch Class

This object provides the default implementation in Aptify CRM for the ICampaignListMatch interface

For a list of all members of this type, see CampaignListMatch Members.

System.Object
CampaignListMatch

public class CampaignListMatch : ICampaignListMatch, IProcessComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Campaigns.ListImport

Assembly: CampaignListImport (in CampaignListImport.dll)

See Also

CampaignListMatch Members | Aptify.Applications.Campaigns.ListImport Namespace


CampaignListMatch Members

CampaignListMatch overview

Public Instance Constructors

CampaignListMatch Constructor Initializes a new instance of the CampaignListMatch class.

Public Instance Properties

Properties

Public Instance Methods

Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MatchImportRunDetails | This method goes through the process of reviewing all of the Campaign Import Run Detail records attached to an import run and attempts to match the records that are either "Unmatched" or "Partial" as status codes This routine leaves alone those that are "Absolute" or "Posted"
Run |
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

StatusUpdate

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetEntityMatchType | Determines the type of entity used for the import run specified.
GetRecordMatchObject | This method will retrieve the match object registered within the Aptify meta-data for this process. The meta-data used includes the RecordMatchObject, RecordMatchClass and RecordMatchAssembly fields in the Campaign Import File Types entity for the file type associated with this import run.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnStatusUpdate | This method is called by the match process during each iteration of matching items. By default, it calls the StatusCallback object (if provided) and also raises the StatusUpdate event

See Also

CampaignListMatch Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignListMatch Constructor

Initializes a new instance of the CampaignListMatch class.

public CampaignListMatch();

See Also

CampaignListMatch Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignListMatch Properties

The properties of the CampaignListMatch class are listed below. For a complete list of CampaignListMatch class members, see the CampaignListMatch Members topic.

Public Instance Properties

Properties

See Also

CampaignListMatch Class | Aptify.Applications.Campaigns.ListImport Namespace


Properties Property

Aptify 5.0 Software Development Kit (SDK)

CampaignListMatch.Properties Property

public AptifyProperties Properties {get;}

Implements

IProcessComponent.

See Also

CampaignListMatch Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignListMatch Methods

The methods of the CampaignListMatch class are listed below. For a complete list of CampaignListMatch class members, see the CampaignListMatch Members topic.

Public Instance Methods

Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MatchImportRunDetails | This method goes through the process of reviewing all of the Campaign Import Run Detail records attached to an import run and attempts to match the records that are either "Unmatched" or "Partial" as status codes This routine leaves alone those that are "Absolute" or "Posted"
Run |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetEntityMatchType | Determines the type of entity used for the import run specified.
GetRecordMatchObject | This method will retrieve the match object registered within the Aptify meta-data for this process. The meta-data used includes the RecordMatchObject, RecordMatchClass and RecordMatchAssembly fields in the Campaign Import File Types entity for the file type associated with this import run.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnStatusUpdate | This method is called by the match process during each iteration of matching items. By default, it calls the StatusCallback object (if provided) and also raises the StatusUpdate event

See Also

CampaignListMatch Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignListMatch.Config Method

public void Config(
AptifyApplication Application
);

Implements

IProcessComponent.

See Also

CampaignListMatch Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignListMatch.GetEntityMatchType Method

Determines the type of entity used for the import run specified.

protected virtual EntityMatchType GetEntityMatchType(
Int64 ImportRunID
);

Return Value

Remarks

See Also

CampaignListMatch Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignListMatch.GetRecordMatchObject Method

This method will retrieve the match object registered within the Aptify meta-data for this process. The meta-data used includes the RecordMatchObject, RecordMatchClass and RecordMatchAssembly fields in the Campaign Import File Types entity for the file type associated with this import run.

protected virtual ICampaignRecordMatch GetRecordMatchObject(
Int64 ImportRunID
);

Return Value

A reference to the object that implements the ICampaignRecordMatch interface

Remarks

See Also

CampaignListMatch Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignListMatch.MatchImportRunDetails Method

This method goes through the process of reviewing all of the Campaign Import Run Detail records attached to an import run and attempts to match the records that are either "Unmatched" or "Partial" as status codes This routine leaves alone those that are "Absolute" or "Posted"

public bool MatchImportRunDetails(
Int64 ImportRunID,
ICampaignStatusCallback StatusCallback
);

Parameters

ImportRunID
StatusCallback

Return Value

Implements

ICampaignListMatch.

Remarks

See Also

CampaignListMatch Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignListMatch.OnStatusUpdate Method

This method is called by the match process during each iteration of matching items. By default, it calls the StatusCallback object (if provided) and also raises the StatusUpdate event

protected virtual void OnStatusUpdate(
ICampaignStatusCallback StatusCallback,
Int64 RecordNumber,
String RecordName,
Single PercentComplete,
ref Boolean& Cancel
);

Parameters

StatusCallback
RecordNumber
RecordName
PercentComplete
Cancel

Remarks

See Also

CampaignListMatch Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignListMatch.Run Method

public string Run();

Implements

IProcessComponent.

See Also

CampaignListMatch Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignListMatch Events

The events of the CampaignListMatch class are listed below. For a complete list of CampaignListMatch class members, see the CampaignListMatch Members topic.

Public Instance Events

StatusUpdate

See Also

CampaignListMatch Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignListMatch.ICampaignListMatch.StatusUpdateEventHandler Event

public event ICampaignListMatch.StatusUpdateEventHandler StatusUpdate;

Implements

ICampaignListMatch.

See Also

CampaignListMatch Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignListMatch.EntityMatchType Enumeration

protected enum CampaignListMatch.EntityMatchType

Members

Member Name | Description
Persons |
Companies |

Requirements

Namespace: Aptify.Applications.Campaigns.ListImport

Assembly: CampaignListImport (in CampaignListImport.dll)

See Also

Aptify.Applications.Campaigns.ListImport Namespace


CampaignListPost Class

Class implements the ICampaignListPost interface and provides import list posting functionality.

For a list of all members of this type, see CampaignListPost Members.

System.Object
CampaignListPost

public class CampaignListPost : ICampaignListPost, IProcessComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Campaigns.ListImport

Assembly: CampaignListImport (in CampaignListImport.dll)

See Also

CampaignListPost Members | Aptify.Applications.Campaigns.ListImport Namespace


CampaignListPost Members

CampaignListPost overview

Public Instance Constructors

CampaignListPost Constructor Initializes a new instance of the CampaignListPost class.

Public Instance Properties

Properties

Public Instance Methods

Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCampaignIDFromImportRunID | This method is responsible for determining the Campaign ID based on the provided Campaign Import Run ID. The default implementation simply runs a query against the database to determine this
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Post |
Run |
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

StatusUpdate

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetRecordPostObject | This method will retrieve the post object registered within the Aptify meta-data for this process. The meta-data used includes the RecordPostObject, RecordPostClass and RecordPostAssembly fields in the Campaign Import File Types entity for the file type associated with this import run.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnStatusUpdate | This method is called by the post process during each iteration of posting items. By default, it calls the StatusCallback object (if provided) and also raises the StatusUpdate event
PostSingleItem | This method is responsible for posting a single record by calling the Post Object provided to the method

See Also

CampaignListPost Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignListPost Constructor

Initializes a new instance of the CampaignListPost class.

public CampaignListPost();

See Also

CampaignListPost Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignListPost Properties

The properties of the CampaignListPost class are listed below. For a complete list of CampaignListPost class members, see the CampaignListPost Members topic.

Public Instance Properties

Properties

See Also

CampaignListPost Class | Aptify.Applications.Campaigns.ListImport Namespace


Properties Property

Aptify 5.0 Software Development Kit (SDK)

CampaignListPost.Properties Property

public AptifyProperties Properties {get;}

Implements

IProcessComponent.

See Also

CampaignListPost Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignListPost Methods

The methods of the CampaignListPost class are listed below. For a complete list of CampaignListPost class members, see the CampaignListPost Members topic.

Public Instance Methods

Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCampaignIDFromImportRunID | This method is responsible for determining the Campaign ID based on the provided Campaign Import Run ID. The default implementation simply runs a query against the database to determine this
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Post |
Run |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetRecordPostObject | This method will retrieve the post object registered within the Aptify meta-data for this process. The meta-data used includes the RecordPostObject, RecordPostClass and RecordPostAssembly fields in the Campaign Import File Types entity for the file type associated with this import run.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnStatusUpdate | This method is called by the post process during each iteration of posting items. By default, it calls the StatusCallback object (if provided) and also raises the StatusUpdate event
PostSingleItem | This method is responsible for posting a single record by calling the Post Object provided to the method

See Also

CampaignListPost Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignListPost.Config Method

public virtual void Config(
AptifyApplication Application
);

Implements

IProcessComponent.

See Also

CampaignListPost Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignListPost.GetCampaignIDFromImportRunID Method

This method is responsible for determining the Campaign ID based on the provided Campaign Import Run ID. The default implementation simply runs a query against the database to determine this

public virtual long GetCampaignIDFromImportRunID(
Int64 ImportRunID
);

Parameters

ImportRunID

Return Value

Remarks

See Also

CampaignListPost Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignListPost.GetRecordPostObject Method

This method will retrieve the post object registered within the Aptify meta-data for this process. The meta-data used includes the RecordPostObject, RecordPostClass and RecordPostAssembly fields in the Campaign Import File Types entity for the file type associated with this import run.

protected virtual ICampaignRecordPost GetRecordPostObject();

Return Value

A reference to the object that implements the ICampaignRecordPost interface

Remarks

See Also

CampaignListPost Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignListPost.OnStatusUpdate Method

This method is called by the post process during each iteration of posting items. By default, it calls the StatusCallback object (if provided) and also raises the StatusUpdate event

protected virtual void OnStatusUpdate(
ICampaignStatusCallback StatusCallback,
Int64 RecordNumber,
String RecordName,
Single PercentComplete,
ref Boolean& Cancel
);

Parameters

StatusCallback
RecordNumber
RecordName
PercentComplete
Cancel

Remarks

See Also

CampaignListPost Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignListPost.Post Method

public virtual bool Post(
Int64 ImportRunID,
ICampaignStatusCallback StatusCallback
);

Implements

ICampaignListPost.

See Also

CampaignListPost Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignListPost.PostSingleItem Method

This method is responsible for posting a single record by calling the Post Object provided to the method

protected virtual bool PostSingleItem(
DataRow dr,
ICampaignRecordPost PostObject
);

Parameters

dr
A data row object representing the data from the Campaign Import Run Details entity to be posted
PostObject
A reference to an object that implements ICampaignRecordPost that will handle the actual posting process

Return Value

Remarks

See Also

CampaignListPost Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignListPost.Run Method

public string Run();

Implements

IProcessComponent.

See Also

CampaignListPost Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignListPost Events

The events of the CampaignListPost class are listed below. For a complete list of CampaignListPost class members, see the CampaignListPost Members topic.

Public Instance Events

StatusUpdate

See Also

CampaignListPost Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignListPost.ICampaignListPost.StatusUpdateEventHandler Event

public event ICampaignListPost.StatusUpdateEventHandler StatusUpdate;

Implements

ICampaignListPost.

See Also

CampaignListPost Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignMatch Class

Class used to track information for each potential and absolute campaign match

For a list of all members of this type, see CampaignMatch Members.

System.Object
CampaignMatch

public class CampaignMatch

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Campaigns.ListImport

Assembly: ICampaignListImport (in ICampaignListImport.dll)

See Also

CampaignMatch Members | Aptify.Applications.Campaigns.ListImport Namespace


CampaignMatch Members

CampaignMatch overview

Public Instance Constructors

CampaignMatch Overloaded. Initializes a new instance of the CampaignMatch class.

Public Instance Fields

RecordID | Record ID that is potentially a match for the given import record
Type | Type of match

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CampaignMatch Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignMatch Constructor

Initializes a new instance of the CampaignMatch class.

Overload List

Initializes a new instance of the CampaignMatch class.

public CampaignMatch();

public CampaignMatch(MatchType);

public CampaignMatch(Int64);

public CampaignMatch(Int64,MatchType);

See Also

CampaignMatch Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignMatch Constructor ()

Initializes a new instance of the CampaignMatch class.

public CampaignMatch();

See Also

CampaignMatch Class | Aptify.Applications.Campaigns.ListImport Namespace | CampaignMatch Constructor Overload List


CampaignMatch Constructor (MatchType)

public CampaignMatch(
MatchType NewType
);

See Also

CampaignMatch Class | Aptify.Applications.Campaigns.ListImport Namespace | CampaignMatch Constructor Overload List


CampaignMatch Constructor (Int64)

public CampaignMatch(
Int64 NewRecordID
);

See Also

CampaignMatch Class | Aptify.Applications.Campaigns.ListImport Namespace | CampaignMatch Constructor Overload List


CampaignMatch Constructor (Int64, MatchType)

public CampaignMatch(
Int64 NewRecordID,
MatchType NewType
);

See Also

CampaignMatch Class | Aptify.Applications.Campaigns.ListImport Namespace | CampaignMatch Constructor Overload List


CampaignMatch Fields

The fields of the CampaignMatch class are listed below. For a complete list of CampaignMatch class members, see the CampaignMatch Members topic.

Public Instance Fields

RecordID | Record ID that is potentially a match for the given import record
Type | Type of match

See Also

CampaignMatch Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignMatch.RecordID Field

Record ID that is potentially a match for the given import record

public RecordID RecordID;

Remarks

See Also

CampaignMatch Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignMatch.Type Field

Type of match

public Type Type;

Remarks

See Also

CampaignMatch Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignMatchCollection Class

Default implemention for ICampaignMatchCollection

For a list of all members of this type, see CampaignMatchCollection Members.

System.Object
SortedList<TKey,TValue>
CampaignMatchCollection

public class CampaignMatchCollection : SortedList<TKey,TValue>, ICampaignMatchCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Campaigns.ListImport

Assembly: ICampaignListImport (in ICampaignListImport.dll)

See Also

CampaignMatchCollection Members | Aptify.Applications.Campaigns.ListImport Namespace


CampaignMatchCollection Members

CampaignMatchCollection overview

Public Instance Constructors

CampaignMatchCollection Constructor Initializes a new instance of the CampaignMatchCollection class.

Public Instance Properties

Capacity (inherited from SortedList<TKey,TValue>) | Gets or sets the number of elements that the SortedList`2 can contain.
Comparer (inherited from SortedList<TKey,TValue>) | Gets the IComparer`1 for the sorted list.
Count (inherited from SortedList<TKey,TValue>) | Gets the number of key/value pairs contained in the SortedList`2.
Item (inherited from SortedList<TKey,TValue>) |
Keys (inherited from SortedList<TKey,TValue>) | Gets a collection containing the keys in the SortedList`2.
Values (inherited from SortedList<TKey,TValue>) | Gets a collection containing the values in the SortedList`2.

Public Instance Methods

Add (inherited from SortedList<TKey,TValue>) |
AddMatch |
Clear (inherited from SortedList<TKey,TValue>) | Removes all elements from the SortedList`2.
ContainsKey (inherited from SortedList<TKey,TValue>) |
ContainsValue (inherited from SortedList<TKey,TValue>) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from SortedList<TKey,TValue>) | Returns an enumerator that iterates through the SortedList`2.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetMatchType |
GetRecordID |
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOfKey (inherited from SortedList<TKey,TValue>) |
IndexOfValue (inherited from SortedList<TKey,TValue>) |
Remove (inherited from SortedList<TKey,TValue>) |
RemoveAt (inherited from SortedList<TKey,TValue>) | Removes the element at the specified index of the SortedList`2.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimExcess (inherited from SortedList<TKey,TValue>) | Sets the capacity to the actual number of elements in the SortedList`2, if that number is less than 90 percent of current capacity.
TryGetValue (inherited from SortedList<TKey,TValue>) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CampaignMatchCollection Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignMatchCollection Constructor

Initializes a new instance of the CampaignMatchCollection class.

public CampaignMatchCollection();

See Also

CampaignMatchCollection Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignMatchCollection Methods

The methods of the CampaignMatchCollection class are listed below. For a complete list of CampaignMatchCollection class members, see the CampaignMatchCollection Members topic.

Public Instance Methods

Add (inherited from SortedList<TKey,TValue>) |
AddMatch |
Clear (inherited from SortedList<TKey,TValue>) | Removes all elements from the SortedList`2.
ContainsKey (inherited from SortedList<TKey,TValue>) |
ContainsValue (inherited from SortedList<TKey,TValue>) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from SortedList<TKey,TValue>) | Returns an enumerator that iterates through the SortedList`2.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetMatchType |
GetRecordID |
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOfKey (inherited from SortedList<TKey,TValue>) |
IndexOfValue (inherited from SortedList<TKey,TValue>) |
Remove (inherited from SortedList<TKey,TValue>) |
RemoveAt (inherited from SortedList<TKey,TValue>) | Removes the element at the specified index of the SortedList`2.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimExcess (inherited from SortedList<TKey,TValue>) | Sets the capacity to the actual number of elements in the SortedList`2, if that number is less than 90 percent of current capacity.
TryGetValue (inherited from SortedList<TKey,TValue>) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CampaignMatchCollection Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignMatchCollection.AddMatch Method

public void AddMatch(
Int64 RecordID,
MatchType Type
);

Implements

ICampaignMatchCollection.

See Also

CampaignMatchCollection Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignMatchCollection.GetMatchType Method

public MatchType GetMatchType(
Int32 Index
);

Implements

ICampaignMatchCollection.

See Also

CampaignMatchCollection Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignMatchCollection.GetRecordID Method

public long GetRecordID(
Int32 Index
);

Implements

ICampaignMatchCollection.

See Also

CampaignMatchCollection Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignMatchPostControl Class

Provides a user interface that allows a user to view matching(partial and absolute), unmatched, and posted records for a given Campaign Import Run record.

For a list of all members of this type, see CampaignMatchPostControl Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
CampaignMatchPostControl

public class CampaignMatchPostControl : FormComponent, ICampaignStatusCallback

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Campaigns.ListImport

Assembly: AptifyCampaignImportControls (in AptifyCampaignImportControls.dll)

See Also

CampaignMatchPostControl Members | Aptify.Applications.Campaigns.ListImport Namespace


CampaignMatchPostControl Members

CampaignMatchPostControl overview

Public Instance Constructors

CampaignMatchPostControl Constructor Initializes a new instance of the CampaignMatchPostControl class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config | When not used on a Form Template, this method must be called before any other member of the class is accessed.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
StatusUpdate |
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateContext (inherited from FormComponent) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
ApplySkin | Set the UI of the control.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetRecordSQL | This method is responsible for returning a SQL statement that will have the set of records that are driven by the user's filter selection in the status frame.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormComponent) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormComponent) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormComponent) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CampaignMatchPostControl Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignMatchPostControl Constructor

Initializes a new instance of the CampaignMatchPostControl class.

public CampaignMatchPostControl();

See Also

CampaignMatchPostControl Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignMatchPostControl Methods

The methods of the CampaignMatchPostControl class are listed below. For a complete list of CampaignMatchPostControl class members, see the CampaignMatchPostControl Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config | When not used on a Form Template, this method must be called before any other member of the class is accessed.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
StatusUpdate |
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
ApplySkin | Set the UI of the control.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetRecordSQL | This method is responsible for returning a SQL statement that will have the set of records that are driven by the user's filter selection in the status frame.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormComponent) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormComponent) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormComponent) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CampaignMatchPostControl Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignMatchPostControl.ApplySkin Method

Set the UI of the control.

protected virtual void ApplySkin();

Remarks

To solve the issue# 7508, Maulik Patel, 10/14/2008

See Also

CampaignMatchPostControl Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignMatchPostControl.Config Method

When not used on a Form Template, this method must be called before any other member of the class is accessed.

public virtual void Config(
AptifyApplication ApplicationObject,
AptifyGenericEntityBase ImportRunGE
);

Parameters

ApplicationObject
ImportRunGE

Remarks

See Also

CampaignMatchPostControl Class | Aptify.Applications.Campaigns.ListImport Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

CampaignMatchPostControl.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

CampaignMatchPostControl Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignMatchPostControl.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

CampaignMatchPostControl Class | Aptify.Applications.Campaigns.ListImport Namespace | CampaignMatchPostControl.Dispose Overload List


CampaignMatchPostControl.GetRecordSQL Method

This method is responsible for returning a SQL statement that will have the set of records that are driven by the user's filter selection in the status frame.

protected virtual string GetRecordSQL();

Return Value

Remarks

See Also

CampaignMatchPostControl Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignMatchPostControl.OnFormComponentConfig Method

protected override void OnFormComponentConfig(
AptifyFormTemplateContext FormTemplateContext
);

Implements

IFormComponent.

See Also

CampaignMatchPostControl Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignMatchPostControl.Refresh Method

public override void Refresh();

See Also

CampaignMatchPostControl Class | Aptify.Applications.Campaigns.ListImport Namespace


CampaignMatchPostControl.StatusUpdate Method

public void StatusUpdate(
ICampaignStatusCallback.ImportPhase Phase,
Int64 RecordNumber,
String RecordName,
Single PercentComplete,
ref Boolean& Cancel
);

Implements

ICampaignStatusCallback.

See Also

CampaignMatchPostControl Class | Aptify.Applications.Campaigns.ListImport Namespace


CSVTextFileReader Class

This class provides an implementation for a comma-separated value text file.

For a list of all members of this type, see CSVTextFileReader Members.

System.Object
FileReaderBase
TextFileReaderBase
CSVTextFileReader

public class CSVTextFileReader : TextFileReaderBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Campaigns.ListImport

Assembly: CampaignListImport (in CampaignListImport.dll)

See Also

CSVTextFileReader Members | Aptify.Applications.Campaigns.ListImport Namespace


CSVTextFileReader Members

CSVTextFileReader overview

Public Instance Constructors

CSVTextFileReader Constructor Initializes a new instance of the CSVTextFileReader class.

Public Instance Properties

Application (inherited from FileReaderBase) | Aptify Application - this property is only available after Config() is called
DataAction (inherited from FileReaderBase) | Aptify Data Action - this property is only available after Config() is called
Database (inherited from FileReaderBase) | Returns the name of the database that the object is connected to based on the Base Database of the Campaigns entity
FileTypeID (inherited from FileReaderBase) | Returns the File Type the file reader is set up for
NumberHeaderLines (inherited from FileReaderBase) | Returns the number of header lines that the file format is expected to have based on the meta-data definition of the Campaign Import File Types entity for the provided File Type ID

Public Instance Methods

CloseFile (inherited from TextFileReaderBase) |
Config (inherited from FileReaderBase) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetColumnCount (inherited from FileReaderBase) |
GetColumnData (inherited from FileReaderBase) |
GetCurrentDataRow (inherited from FileReaderBase) |
GetDataTable (inherited from FileReaderBase) |
GetFullRowData (inherited from TextFileReaderBase) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsBOF (inherited from FileReaderBase) |
IsEOF (inherited from FileReaderBase) |
MoveBack (inherited from FileReaderBase) |
MoveFirst (inherited from FileReaderBase) |
MoveLast (inherited from FileReaderBase) |
MoveNext (inherited from FileReaderBase) |
OpenFile (inherited from TextFileReaderBase) |
ParseRowData (inherited from TextFileReaderBase) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

StatusUpdate (inherited from FileReaderBase)

Protected Instance Fields

m_dtFile (inherited from FileReaderBase) | Represents a data table that is loaded by the class to contain the entire contents of the data file that is being parsed
m_iCurrentRow (inherited from FileReaderBase) | Represents the current row in the data table that the file is pointing to

Protected Instance Properties

ColumnDelimiter |
FileNumber (inherited from TextFileReaderBase) | Returns an integer number greater than zero if a file is currently open and being operated upon. Returns 0 if no file is open
TextSeparator |

Protected Instance Methods

BuildDataTableSchema (inherited from FileReaderBase) | This method is responsible for building the table schema for the file type specified. The base functionality simply loads up one column into the data table schema for each column defined in the Campaign List Import File Types columns
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetDisplayColumns (inherited from FileReaderBase) |
GetNumHeaderLinesFromDB (inherited from FileReaderBase) | This method is responsible for returning the number of header lines for the specified file type from the database definition in the Campaign Import File Types entity. Use this function only if you need to obtain header line information for a file type other than the file type that the base class is already configured for since that information is available in the NumberHeaderLines property in the base class which is loaded at Config() time. This function can also be used to refresh the information from the database.
LoadColumnNames (inherited from FileReaderBase) |
LoadSingleFileLine (inherited from TextFileReaderBase) | This method is responsible for loading up a single file line. It is called by the class to load up each file line and the assumption is that it will load the file line, parse it, and then add the row to the internal data table m_dtFile.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnStatusUpdate (inherited from FileReaderBase) | This method is responsible for raising the StatusUpdate event as well as notifying the call back (if not null) of status updates. Call this method from sub-classes to handle status notifications of both types from a single call

See Also

CSVTextFileReader Class | Aptify.Applications.Campaigns.ListImport Namespace


CSVTextFileReader Constructor

Initializes a new instance of the CSVTextFileReader class.

public CSVTextFileReader();

See Also

CSVTextFileReader Class | Aptify.Applications.Campaigns.ListImport Namespace


CSVTextFileReader Properties

The properties of the CSVTextFileReader class are listed below. For a complete list of CSVTextFileReader class members, see the CSVTextFileReader Members topic.

Public Instance Properties

Application (inherited from FileReaderBase) | Aptify Application - this property is only available after Config() is called
DataAction (inherited from FileReaderBase) | Aptify Data Action - this property is only available after Config() is called
Database (inherited from FileReaderBase) | Returns the name of the database that the object is connected to based on the Base Database of the Campaigns entity
FileTypeID (inherited from FileReaderBase) | Returns the File Type the file reader is set up for
NumberHeaderLines (inherited from FileReaderBase) | Returns the number of header lines that the file format is expected to have based on the meta-data definition of the Campaign Import File Types entity for the provided File Type ID

Protected Instance Properties

ColumnDelimiter |
FileNumber (inherited from TextFileReaderBase) | Returns an integer number greater than zero if a file is currently open and being operated upon. Returns 0 if no file is open
TextSeparator |

See Also

CSVTextFileReader Class | Aptify.Applications.Campaigns.ListImport Namespace


ColumnDelimiter Property

Aptify 5.0 Software Development Kit (SDK)

CSVTextFileReader.ColumnDelimiter Property

protected override String ColumnDelimiter {get;}

See Also

CSVTextFileReader Class | Aptify.Applications.Campaigns.ListImport Namespace


TextSeparator Property

Aptify 5.0 Software Development Kit (SDK)

CSVTextFileReader.TextSeparator Property

protected override String TextSeparator {get;}

See Also

CSVTextFileReader Class | Aptify.Applications.Campaigns.ListImport Namespace


DefaultCompanyMatch Class

Default Aptify Company Matching class for Aptify CRM. This class inherits from RecordMatchBase and simply provides a default implementation for matching company records in the MatchRecord method().

For a list of all members of this type, see DefaultCompanyMatch Members.

System.Object
RecordMatchBase
DefaultCompanyMatch

public class DefaultCompanyMatch : RecordMatchBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Campaigns.ListImport

Assembly: CampaignListImport (in CampaignListImport.dll)

See Also

DefaultCompanyMatch Members | Aptify.Applications.Campaigns.ListImport Namespace


DefaultCompanyMatch Members

DefaultCompanyMatch overview

Public Instance Constructors

DefaultCompanyMatch Constructor Initializes a new instance of the DefaultCompanyMatch class.

Public Instance Methods

Config (inherited from RecordMatchBase) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetFileColumnNameMap (inherited from RecordMatchBase) | This method returns the name of the column in the source file that was mapped to a particular field name in the schema of the entity being imported into.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MatchRecord |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

Application (inherited from RecordMatchBase) | Aptify Application Object
DataAction (inherited from RecordMatchBase) | Aptify Data Action
Database (inherited from RecordMatchBase) | Aptify Base Database for Campaigns (and related) entity.

Protected Instance Methods

ContainsRecordID (inherited from RecordMatchBase) | This method determines if the Record ID specified exists within the collection passed in.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetFieldFromDetailGE (inherited from RecordMatchBase) | This method returns the value of an individual element in the Campaign Import Run Detail Columns sub-type that can be used in the matching process as needed. The default implementation simply scans through the specified sub-type to determine if a value exists that maps to the column that this particular FieldName matches. This method internally uses the GetFileColumnNameMap() method to determine the name of the column in the import source that matches the specified FieldName parameter.
GetMatchSQL | This function returns the SQL statement that will be used to match records for companies in the database. If a sub-class needs to change the logic in the matching SQL statement, override this function only rather than the MatchRecord() function since this function is used by MatchRecord() to get the SQL statement used for matching. The default implementation of this method in the DefaultCompanyMatch class calls the spCampaignCompanyMatch stored procedure which uses Name, City and State to do this work inside the database
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DefaultCompanyMatch Class | Aptify.Applications.Campaigns.ListImport Namespace


DefaultCompanyMatch Constructor

Initializes a new instance of the DefaultCompanyMatch class.

public DefaultCompanyMatch();

See Also

DefaultCompanyMatch Class | Aptify.Applications.Campaigns.ListImport Namespace


DefaultCompanyMatch Methods

The methods of the DefaultCompanyMatch class are listed below. For a complete list of DefaultCompanyMatch class members, see the DefaultCompanyMatch Members topic.

Public Instance Methods

Config (inherited from RecordMatchBase) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetFileColumnNameMap (inherited from RecordMatchBase) | This method returns the name of the column in the source file that was mapped to a particular field name in the schema of the entity being imported into.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MatchRecord |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

ContainsRecordID (inherited from RecordMatchBase) | This method determines if the Record ID specified exists within the collection passed in.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetFieldFromDetailGE (inherited from RecordMatchBase) | This method returns the value of an individual element in the Campaign Import Run Detail Columns sub-type that can be used in the matching process as needed. The default implementation simply scans through the specified sub-type to determine if a value exists that maps to the column that this particular FieldName matches. This method internally uses the GetFileColumnNameMap() method to determine the name of the column in the import source that matches the specified FieldName parameter.
GetMatchSQL | This function returns the SQL statement that will be used to match records for companies in the database. If a sub-class needs to change the logic in the matching SQL statement, override this function only rather than the MatchRecord() function since this function is used by MatchRecord() to get the SQL statement used for matching. The default implementation of this method in the DefaultCompanyMatch class calls the spCampaignCompanyMatch stored procedure which uses Name, City and State to do this work inside the database
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DefaultCompanyMatch Class | Aptify.Applications.Campaigns.ListImport Namespace


DefaultCompanyMatch.GetMatchSQL Method

This function returns the SQL statement that will be used to match records for companies in the database. If a sub-class needs to change the logic in the matching SQL statement, override this function only rather than the MatchRecord() function since this function is used by MatchRecord() to get the SQL statement used for matching. The default implementation of this method in the DefaultCompanyMatch class calls the spCampaignCompanyMatch stored procedure which uses Name, City and State to do this work inside the database

protected virtual string GetMatchSQL(
AptifyGenericEntityBase ImportDetailGE,
AptifyGenericEntityBase ImportRunGE
);

Parameters

ImportDetailGE
Aptify GE Base Class
ImportRunGE

Return Value

Valid SQL statement to use for matching records. Assumes that the SQL returns zero or more records that are absolute or potential matches. The result of the SQL statement must have at least two columns named ID for the Record ID found to be a match and a column named 'Type' which should contain the values 'Absolute' or 'Partial'

Remarks

See Also

DefaultCompanyMatch Class | Aptify.Applications.Campaigns.ListImport Namespace


DefaultCompanyMatch.MatchRecord Method

public override bool MatchRecord(
AptifyGenericEntityBase ImportDetailGE,
AptifyGenericEntityBase ImportRunGE,
ICampaignMatchCollection MatchCollection
);

Implements

ICampaignRecordMatch.

See Also

DefaultCompanyMatch Class | Aptify.Applications.Campaigns.ListImport Namespace


DefaultCompanyPost Class

This class provides the default posting logic for Aptify CRM for the Company Campaign Import List Type. It is possible to sub-class this class and override various methods to alter the posting logic as required.

For a list of all members of this type, see DefaultCompanyPost Members.

System.Object
RecordPostBase
DefaultCompanyPost

public class DefaultCompanyPost : RecordPostBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Campaigns.ListImport

Assembly: CampaignListImport (in CampaignListImport.dll)

See Also

DefaultCompanyPost Members | Aptify.Applications.Campaigns.ListImport Namespace


DefaultCompanyPost Members

DefaultCompanyPost overview

Public Instance Constructors

DefaultCompanyPost Constructor Initializes a new instance of the DefaultCompanyPost class.

Public Instance Methods

Config (inherited from RecordPostBase) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
PostRecord |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Fields

m_lImportRunID

Protected Instance Properties

Application (inherited from RecordPostBase) | Aptify Application Object
DataAction (inherited from RecordPostBase) | Aptify Data Action
Database (inherited from RecordPostBase) | Aptify Base Database for Campaigns (and related) entity.

Protected Instance Methods

ContainsRecordID (inherited from RecordPostBase) | This method determines if the Record ID specified exists within the collection passed in
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetEntityMinimumRecordID (inherited from RecordPostBase) | This method returns the lowest ID value in the entity table provided to the method through the Entity parameter
GetFieldFromDetailGE (inherited from RecordPostBase) | This method returns the value of an individual element in the Campaign Import Run Detail Columns sub-type that can be used in the matching process as needed. The default implementation simply scans through the specified sub-type to determine if the FieldName exists within the ColumnName field in the sub-type
MapCompanyRecordFields | This method is responsible for mapping values from the import run details record into the company record.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DefaultCompanyPost Class | Aptify.Applications.Campaigns.ListImport Namespace


DefaultCompanyPost Constructor

Initializes a new instance of the DefaultCompanyPost class.

public DefaultCompanyPost();

See Also

DefaultCompanyPost Class | Aptify.Applications.Campaigns.ListImport Namespace


DefaultCompanyPost Fields

The fields of the DefaultCompanyPost class are listed below. For a complete list of DefaultCompanyPost class members, see the DefaultCompanyPost Members topic.

Protected Instance Fields

m_lImportRunID

See Also

DefaultCompanyPost Class | Aptify.Applications.Campaigns.ListImport Namespace


DefaultCompanyPost.m_lImportRunID Field

protected m_lImportRunID m_lImportRunID;

See Also

DefaultCompanyPost Class | Aptify.Applications.Campaigns.ListImport Namespace


DefaultCompanyPost Methods

The methods of the DefaultCompanyPost class are listed below. For a complete list of DefaultCompanyPost class members, see the DefaultCompanyPost Members topic.

Public Instance Methods

Config (inherited from RecordPostBase) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
PostRecord |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

ContainsRecordID (inherited from RecordPostBase) | This method determines if the Record ID specified exists within the collection passed in
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetEntityMinimumRecordID (inherited from RecordPostBase) | This method returns the lowest ID value in the entity table provided to the method through the Entity parameter
GetFieldFromDetailGE (inherited from RecordPostBase) | This method returns the value of an individual element in the Campaign Import Run Detail Columns sub-type that can be used in the matching process as needed. The default implementation simply scans through the specified sub-type to determine if the FieldName exists within the ColumnName field in the sub-type
MapCompanyRecordFields | This method is responsible for mapping values from the import run details record into the company record.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DefaultCompanyPost Class | Aptify.Applications.Campaigns.ListImport Namespace


DefaultCompanyPost.MapCompanyRecordFields Method

This method is responsible for mapping values from the import run details record into the company record.

protected virtual void MapCompanyRecordFields(
AptifyGenericEntityBase ImportDetailGE,
AptifyGenericEntityBase CompanyGE
);

Parameters

ImportDetailGE
CompanyGE

Remarks

See Also

DefaultCompanyPost Class | Aptify.Applications.Campaigns.ListImport Namespace


DefaultCompanyPost.PostRecord Method

public override bool PostRecord(
AptifyGenericEntityBase ImportDetailGE,
Int64 CampaignID
);

Implements

ICampaignRecordPost.

See Also

DefaultCompanyPost Class | Aptify.Applications.Campaigns.ListImport Namespace


DefaultPersonMatch Class

Default Aptify Person Matching class for Aptify CRM. This class inherits from RecordMatchBase and simply provides a default implementation for matching person records in the MatchRecord method().

For a list of all members of this type, see DefaultPersonMatch Members.

System.Object
RecordMatchBase
DefaultPersonMatch

public class DefaultPersonMatch : RecordMatchBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Campaigns.ListImport

Assembly: CampaignListImport (in CampaignListImport.dll)

See Also

DefaultPersonMatch Members | Aptify.Applications.Campaigns.ListImport Namespace


DefaultPersonMatch Members

DefaultPersonMatch overview

Public Instance Constructors

DefaultPersonMatch Constructor Initializes a new instance of the DefaultPersonMatch class.

Public Instance Methods

Config (inherited from RecordMatchBase) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetFileColumnNameMap (inherited from RecordMatchBase) | This method returns the name of the column in the source file that was mapped to a particular field name in the schema of the entity being imported into.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MatchRecord |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

Application (inherited from RecordMatchBase) | Aptify Application Object
DataAction (inherited from RecordMatchBase) | Aptify Data Action
Database (inherited from RecordMatchBase) | Aptify Base Database for Campaigns (and related) entity.

Protected Instance Methods

ContainsRecordID (inherited from RecordMatchBase) | This method determines if the Record ID specified exists within the collection passed in.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetFieldFromDetailGE (inherited from RecordMatchBase) | This method returns the value of an individual element in the Campaign Import Run Detail Columns sub-type that can be used in the matching process as needed. The default implementation simply scans through the specified sub-type to determine if a value exists that maps to the column that this particular FieldName matches. This method internally uses the GetFileColumnNameMap() method to determine the name of the column in the import source that matches the specified FieldName parameter.
GetMatchSQL | This function returns the SQL statement that will be used to match records for individuals in the database. If a sub-class needs to change the logic in the matching SQL statement, override this function only rather than the MatchRecord() function since this function is used by MatchRecord() to get the SQL statement used for matching. The default implementation of this method in the DefaultPersonMatch class calls the spCampaignPersonMatch stored procedure which uses FirstName, LastName and Company name to do this work inside the database
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DefaultPersonMatch Class | Aptify.Applications.Campaigns.ListImport Namespace


DefaultPersonMatch Constructor

Initializes a new instance of the DefaultPersonMatch class.

public DefaultPersonMatch();

See Also

DefaultPersonMatch Class | Aptify.Applications.Campaigns.ListImport Namespace


DefaultPersonMatch Methods

The methods of the DefaultPersonMatch class are listed below. For a complete list of DefaultPersonMatch class members, see the DefaultPersonMatch Members topic.

Public Instance Methods

Config (inherited from RecordMatchBase) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetFileColumnNameMap (inherited from RecordMatchBase) | This method returns the name of the column in the source file that was mapped to a particular field name in the schema of the entity being imported into.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MatchRecord |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

ContainsRecordID (inherited from RecordMatchBase) | This method determines if the Record ID specified exists within the collection passed in.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetFieldFromDetailGE (inherited from RecordMatchBase) | This method returns the value of an individual element in the Campaign Import Run Detail Columns sub-type that can be used in the matching process as needed. The default implementation simply scans through the specified sub-type to determine if a value exists that maps to the column that this particular FieldName matches. This method internally uses the GetFileColumnNameMap() method to determine the name of the column in the import source that matches the specified FieldName parameter.
GetMatchSQL | This function returns the SQL statement that will be used to match records for individuals in the database. If a sub-class needs to change the logic in the matching SQL statement, override this function only rather than the MatchRecord() function since this function is used by MatchRecord() to get the SQL statement used for matching. The default implementation of this method in the DefaultPersonMatch class calls the spCampaignPersonMatch stored procedure which uses FirstName, LastName and Company name to do this work inside the database
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DefaultPersonMatch Class | Aptify.Applications.Campaigns.ListImport Namespace


DefaultPersonMatch.GetMatchSQL Method

This function returns the SQL statement that will be used to match records for individuals in the database. If a sub-class needs to change the logic in the matching SQL statement, override this function only rather than the MatchRecord() function since this function is used by MatchRecord() to get the SQL statement used for matching. The default implementation of this method in the DefaultPersonMatch class calls the spCampaignPersonMatch stored procedure which uses FirstName, LastName and Company name to do this work inside the database

protected virtual string GetMatchSQL(
AptifyGenericEntityBase ImportDetailGE,
AptifyGenericEntityBase ImportRunGE
);

Parameters

ImportDetailGE
Aptify GE Base Class
ImportRunGE

Return Value

Valid SQL statement to use for matching records. Assumes that the SQL returns zero or more records that are absolute or potential matches. The result of the SQL statement must have at least two columns named ID for the Record ID found to be a match and a column named 'Type' which should contain the values 'Absolute' or 'Partial'

Remarks

See Also

DefaultPersonMatch Class | Aptify.Applications.Campaigns.ListImport Namespace


DefaultPersonMatch.MatchRecord Method

public override bool MatchRecord(
AptifyGenericEntityBase ImportDetailGE,
AptifyGenericEntityBase ImportRunGE,
ICampaignMatchCollection MatchCollection
);

Implements

ICampaignRecordMatch.

See Also

DefaultPersonMatch Class | Aptify.Applications.Campaigns.ListImport Namespace


DefaultPersonPost Class

This class provides the default posting logic for Aptify CRM for the Persons Campaign Import List Type. It is possible to sub-class this class and override various methods to alter the posting logic as required.

For a list of all members of this type, see DefaultPersonPost Members.

System.Object
RecordPostBase
DefaultPersonPost

public class DefaultPersonPost : RecordPostBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Campaigns.ListImport

Assembly: CampaignListImport (in CampaignListImport.dll)

See Also

DefaultPersonPost Members | Aptify.Applications.Campaigns.ListImport Namespace


DefaultPersonPost Members

DefaultPersonPost overview

Public Instance Constructors

DefaultPersonPost Constructor Initializes a new instance of the DefaultPersonPost class.

Public Instance Methods

Config (inherited from RecordPostBase) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
PostRecord |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Fields

m_lImportRunID

Protected Instance Properties

Application (inherited from RecordPostBase) | Aptify Application Object
DataAction (inherited from RecordPostBase) | Aptify Data Action
Database (inherited from RecordPostBase) | Aptify Base Database for Campaigns (and related) entity.

Protected Instance Methods

ContainsRecordID (inherited from RecordPostBase) | This method determines if the Record ID specified exists within the collection passed in
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetEntityMinimumRecordID (inherited from RecordPostBase) | This method returns the lowest ID value in the entity table provided to the method through the Entity parameter
GetFieldFromDetailGE (inherited from RecordPostBase) | This method returns the value of an individual element in the Campaign Import Run Detail Columns sub-type that can be used in the matching process as needed. The default implementation simply scans through the specified sub-type to determine if the FieldName exists within the ColumnName field in the sub-type
LookupCreateCompanyID | This method is responsible for doing a company lookup and returning a valid company ID. This method is responsible for creating new company records as well if no record is found that matches the company record being passed in. The default logic for this method uses the Company Name, City and State only, however sub-classes can alter this logic to use the fields that they require for specific matching rules as needed.
MapPersonRecordFields | This method is responsible for mapping values from the import run details record into the person record. The last parameter is used to determine if the Name fields should be ignored.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DefaultPersonPost Class | Aptify.Applications.Campaigns.ListImport Namespace


DefaultPersonPost Constructor

Initializes a new instance of the DefaultPersonPost class.

public DefaultPersonPost();

See Also

DefaultPersonPost Class | Aptify.Applications.Campaigns.ListImport Namespace


DefaultPersonPost Fields

The fields of the DefaultPersonPost class are listed below. For a complete list of DefaultPersonPost class members, see the DefaultPersonPost Members topic.

Protected Instance Fields

m_lImportRunID

See Also

DefaultPersonPost Class | Aptify.Applications.Campaigns.ListImport Namespace


DefaultPersonPost.m_lImportRunID Field

protected m_lImportRunID m_lImportRunID;

See Also

DefaultPersonPost Class | Aptify.Applications.Campaigns.ListImport Namespace


DefaultPersonPost Methods

The methods of the DefaultPersonPost class are listed below. For a complete list of DefaultPersonPost class members, see the DefaultPersonPost Members topic.

Public Instance Methods

Config (inherited from RecordPostBase) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
PostRecord |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

ContainsRecordID (inherited from RecordPostBase) | This method determines if the Record ID specified exists within the collection passed in
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetEntityMinimumRecordID (inherited from RecordPostBase) | This method returns the lowest ID value in the entity table provided to the method through the Entity parameter
GetFieldFromDetailGE (inherited from RecordPostBase) | This method returns the value of an individual element in the Campaign Import Run Detail Columns sub-type that can be used in the matching process as needed. The default implementation simply scans through the specified sub-type to determine if the FieldName exists within the ColumnName field in the sub-type
LookupCreateCompanyID | This method is responsible for doing a company lookup and returning a valid company ID. This method is responsible for creating new company records as well if no record is found that matches the company record being passed in. The default logic for this method uses the Company Name, City and State only, however sub-classes can alter this logic to use the fields that they require for specific matching rules as needed.
MapPersonRecordFields | This method is responsible for mapping values from the import run details record into the person record. The last parameter is used to determine if the Name fields should be ignored.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DefaultPersonPost Class | Aptify.Applications.Campaigns.ListImport Namespace


DefaultPersonPost.LookupCreateCompanyID Method

This method is responsible for doing a company lookup and returning a valid company ID. This method is responsible for creating new company records as well if no record is found that matches the company record being passed in. The default logic for this method uses the Company Name, City and State only, however sub-classes can alter this logic to use the fields that they require for specific matching rules as needed.

protected virtual long LookupCreateCompanyID(
String CompanyName,
String City,
String State,
AptifyGenericEntityBase ImportDetailGE
);

Parameters

CompanyName
City
State
ImportDetailGE

Return Value

Remarks

See Also

DefaultPersonPost Class | Aptify.Applications.Campaigns.ListImport Namespace


DefaultPersonPost.MapPersonRecordFields Method

This method is responsible for mapping values from the import run details record into the person record. The last parameter is used to determine if the Name fields should be ignored.

protected virtual void MapPersonRecordFields(
AptifyGenericEntityBase ImportDetailGE,
AptifyGenericEntityBase PersonGE,
Boolean IgnoreNameFields
);

Parameters

ImportDetailGE
PersonGE
IgnoreNameFields
If this parameter is set to True, FirstName, LastName, MiddleName, Title and Company Name will be ignored by the mapping process

Remarks

See Also

DefaultPersonPost Class | Aptify.Applications.Campaigns.ListImport Namespace


DefaultPersonPost.PostRecord Method

public override bool PostRecord(
AptifyGenericEntityBase ImportDetailGE,
Int64 CampaignID
);

Implements

ICampaignRecordPost.

See Also

DefaultPersonPost Class | Aptify.Applications.Campaigns.ListImport Namespace


ExcelFileReader Class

This class provides an implementation for Microsoft Excel Files. The class imports the first sheet in the workbook provided.

For a list of all members of this type, see ExcelFileReader Members.

System.Object
FileReaderBase
ExcelFileReader

public class ExcelFileReader : FileReaderBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Campaigns.ListImport

Assembly: CampaignListImport (in CampaignListImport.dll)

See Also

ExcelFileReader Members | Aptify.Applications.Campaigns.ListImport Namespace


ExcelFileReader Members

ExcelFileReader overview

Public Instance Constructors

ExcelFileReader Constructor Initializes a new instance of the ExcelFileReader class.

Public Instance Properties

Application (inherited from FileReaderBase) | Aptify Application - this property is only available after Config() is called
DataAction (inherited from FileReaderBase) | Aptify Data Action - this property is only available after Config() is called
Database (inherited from FileReaderBase) | Returns the name of the database that the object is connected to based on the Base Database of the Campaigns entity
FileTypeID (inherited from FileReaderBase) | Returns the File Type the file reader is set up for
NumberHeaderLines (inherited from FileReaderBase) | Returns the number of header lines that the file format is expected to have based on the meta-data definition of the Campaign Import File Types entity for the provided File Type ID

Public Instance Methods

CloseFile |
Config (inherited from FileReaderBase) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetColumnCount (inherited from FileReaderBase) |
GetColumnData (inherited from FileReaderBase) |
GetCurrentDataRow (inherited from FileReaderBase) |
GetDataTable (inherited from FileReaderBase) |
GetFullRowData |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsBOF (inherited from FileReaderBase) |
IsEOF (inherited from FileReaderBase) |
MoveBack (inherited from FileReaderBase) |
MoveFirst (inherited from FileReaderBase) |
MoveLast (inherited from FileReaderBase) |
MoveNext (inherited from FileReaderBase) |
OpenFile |
ParseRowData |
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

StatusUpdate (inherited from FileReaderBase)

Protected Instance Fields

m_dtFile (inherited from FileReaderBase) | Represents a data table that is loaded by the class to contain the entire contents of the data file that is being parsed
m_iCurrentRow (inherited from FileReaderBase) | Represents the current row in the data table that the file is pointing to

Protected Instance Methods

BuildDataTableSchema (inherited from FileReaderBase) | This method is responsible for building the table schema for the file type specified. The base functionality simply loads up one column into the data table schema for each column defined in the Campaign List Import File Types columns
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetDisplayColumns (inherited from FileReaderBase) |
GetNumHeaderLinesFromDB (inherited from FileReaderBase) | This method is responsible for returning the number of header lines for the specified file type from the database definition in the Campaign Import File Types entity. Use this function only if you need to obtain header line information for a file type other than the file type that the base class is already configured for since that information is available in the NumberHeaderLines property in the base class which is loaded at Config() time. This function can also be used to refresh the information from the database.
LoadColumnNames (inherited from FileReaderBase) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnStatusUpdate (inherited from FileReaderBase) | This method is responsible for raising the StatusUpdate event as well as notifying the call back (if not null) of status updates. Call this method from sub-classes to handle status notifications of both types from a single call

See Also

ExcelFileReader Class | Aptify.Applications.Campaigns.ListImport Namespace


ExcelFileReader Constructor

Initializes a new instance of the ExcelFileReader class.

public ExcelFileReader();

See Also

ExcelFileReader Class | Aptify.Applications.Campaigns.ListImport Namespace


ExcelFileReader Methods

The methods of the ExcelFileReader class are listed below. For a complete list of ExcelFileReader class members, see the ExcelFileReader Members topic.

Public Instance Methods

CloseFile |
Config (inherited from FileReaderBase) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetColumnCount (inherited from FileReaderBase) |
GetColumnData (inherited from FileReaderBase) |
GetCurrentDataRow (inherited from FileReaderBase) |
GetDataTable (inherited from FileReaderBase) |
GetFullRowData |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsBOF (inherited from FileReaderBase) |
IsEOF (inherited from FileReaderBase) |
MoveBack (inherited from FileReaderBase) |
MoveFirst (inherited from FileReaderBase) |
MoveLast (inherited from FileReaderBase) |
MoveNext (inherited from FileReaderBase) |
OpenFile |
ParseRowData |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

BuildDataTableSchema (inherited from FileReaderBase) | This method is responsible for building the table schema for the file type specified. The base functionality simply loads up one column into the data table schema for each column defined in the Campaign List Import File Types columns
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetDisplayColumns (inherited from FileReaderBase) |
GetNumHeaderLinesFromDB (inherited from FileReaderBase) | This method is responsible for returning the number of header lines for the specified file type from the database definition in the Campaign Import File Types entity. Use this function only if you need to obtain header line information for a file type other than the file type that the base class is already configured for since that information is available in the NumberHeaderLines property in the base class which is loaded at Config() time. This function can also be used to refresh the information from the database.
LoadColumnNames (inherited from FileReaderBase) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnStatusUpdate (inherited from FileReaderBase) | This method is responsible for raising the StatusUpdate event as well as notifying the call back (if not null) of status updates. Call this method from sub-classes to handle status notifications of both types from a single call

See Also

ExcelFileReader Class | Aptify.Applications.Campaigns.ListImport Namespace


ExcelFileReader.CloseFile Method

public override void CloseFile();

Implements

ICampaignListFileReader.

See Also

ExcelFileReader Class | Aptify.Applications.Campaigns.ListImport Namespace


ExcelFileReader.GetFullRowData Method

public override string GetFullRowData();

Implements

ICampaignListFileReader.

See Also

ExcelFileReader Class | Aptify.Applications.Campaigns.ListImport Namespace


ExcelFileReader.OpenFile Method

public override bool OpenFile(
String FileName,
ICampaignStatusCallback StatusCallback
);

Implements

ICampaignListFileReader.

See Also

ExcelFileReader Class | Aptify.Applications.Campaigns.ListImport Namespace


ExcelFileReader.ParseRowData Method

public override DataRow ParseRowData(
String RowData
);

Implements

ICampaignListFileReader.

See Also

ExcelFileReader Class | Aptify.Applications.Campaigns.ListImport Namespace


FileReaderBase Class

This is the base class for reading in any type of file and loading up its contents This class must be inherited from to be used as it does not intrinscially define the type of file in any way. Override this class to implement the file loading and file manipulation implementation. This class provides an implementation of ICampaignListFileReader and the methods of that interface are exposed as Public and Overridable so that sub-classes can alter those interface methods as well as the internal implementation protected methods of this base class.

For a list of all members of this type, see FileReaderBase Members.

System.Object
FileReaderBase
ExcelFileReader
TextFileReaderBase

public class FileReaderBase : ICampaignListFileReader

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Campaigns.ListImport

Assembly: CampaignListImport (in CampaignListImport.dll)

See Also

FileReaderBase Members | Aptify.Applications.Campaigns.ListImport Namespace


FileReaderBase Members

FileReaderBase overview

Public Instance Constructors

FileReaderBase Constructor Initializes a new instance of the FileReaderBase class.

Public Instance Properties

Application | Aptify Application - this property is only available after Config() is called
DataAction | Aptify Data Action - this property is only available after Config() is called
Database | Returns the name of the database that the object is connected to based on the Base Database of the Campaigns entity
FileTypeID | Returns the File Type the file reader is set up for
NumberHeaderLines | Returns the number of header lines that the file format is expected to have based on the meta-data definition of the Campaign Import File Types entity for the provided File Type ID

Public Instance Methods

CloseFile |
Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetColumnCount |
GetColumnData |
GetCurrentDataRow |
GetDataTable |
GetFullRowData |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsBOF |
IsEOF |
MoveBack |
MoveFirst |
MoveLast |
MoveNext |
OpenFile |
ParseRowData |
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

StatusUpdate

Protected Instance Fields

m_dtFile | Represents a data table that is loaded by the class to contain the entire contents of the data file that is being parsed
m_iCurrentRow | Represents the current row in the data table that the file is pointing to

Protected Instance Methods

BuildDataTableSchema | This method is responsible for building the table schema for the file type specified. The base functionality simply loads up one column into the data table schema for each column defined in the Campaign List Import File Types columns
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetDisplayColumns |
GetNumHeaderLinesFromDB | This method is responsible for returning the number of header lines for the specified file type from the database definition in the Campaign Import File Types entity. Use this function only if you need to obtain header line information for a file type other than the file type that the base class is already configured for since that information is available in the NumberHeaderLines property in the base class which is loaded at Config() time. This function can also be used to refresh the information from the database.
LoadColumnNames |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnStatusUpdate | This method is responsible for raising the StatusUpdate event as well as notifying the call back (if not null) of status updates. Call this method from sub-classes to handle status notifications of both types from a single call

See Also

FileReaderBase Class | Aptify.Applications.Campaigns.ListImport Namespace


FileReaderBase Constructor

Initializes a new instance of the FileReaderBase class.

public FileReaderBase();

See Also

FileReaderBase Class | Aptify.Applications.Campaigns.ListImport Namespace


FileReaderBase Fields

The fields of the FileReaderBase class are listed below. For a complete list of FileReaderBase class members, see the FileReaderBase Members topic.

Protected Instance Fields

m_dtFile | Represents a data table that is loaded by the class to contain the entire contents of the data file that is being parsed
m_iCurrentRow | Represents the current row in the data table that the file is pointing to

See Also

FileReaderBase Class | Aptify.Applications.Campaigns.ListImport Namespace


FileReaderBase.m_dtFile Field

Represents a data table that is loaded by the class to contain the entire contents of the data file that is being parsed

protected m_dtFile m_dtFile;

Remarks

See Also

FileReaderBase Class | Aptify.Applications.Campaigns.ListImport Namespace


FileReaderBase.m_iCurrentRow Field

Represents the current row in the data table that the file is pointing to

protected m_iCurrentRow m_iCurrentRow;

Remarks

See Also

FileReaderBase Class | Aptify.Applications.Campaigns.ListImport Namespace


FileReaderBase Properties

The properties of the FileReaderBase class are listed below. For a complete list of FileReaderBase class members, see the FileReaderBase Members topic.

Public Instance Properties

Application | Aptify Application - this property is only available after Config() is called
DataAction | Aptify Data Action - this property is only available after Config() is called
Database | Returns the name of the database that the object is connected to based on the Base Database of the Campaigns entity
FileTypeID | Returns the File Type the file reader is set up for
NumberHeaderLines | Returns the number of header lines that the file format is expected to have based on the meta-data definition of the Campaign Import File Types entity for the provided File Type ID

See Also

FileReaderBase Class | Aptify.Applications.Campaigns.ListImport Namespace


Application Property

Aptify 5.0 Software Development Kit (SDK)

FileReaderBase.Application Property

Aptify Application - this property is only available after Config() is called

public virtual AptifyApplication Application {get;}

Property Value

Remarks

See Also

FileReaderBase Class | Aptify.Applications.Campaigns.ListImport Namespace


DataAction Property

Aptify 5.0 Software Development Kit (SDK)

FileReaderBase.DataAction Property

Aptify Data Action - this property is only available after Config() is called

public virtual DataAction DataAction {get;}

Property Value

Remarks

See Also

FileReaderBase Class | Aptify.Applications.Campaigns.ListImport Namespace


Database Property

Aptify 5.0 Software Development Kit (SDK)

FileReaderBase.Database Property

Returns the name of the database that the object is connected to based on the Base Database of the Campaigns entity

public virtual String Database {get;}

Property Value

Remarks

See Also

FileReaderBase Class | Aptify.Applications.Campaigns.ListImport Namespace


FileTypeID Property

Aptify 5.0 Software Development Kit (SDK)

FileReaderBase.FileTypeID Property

Returns the File Type the file reader is set up for

public virtual Int64 FileTypeID {get;}

Property Value

Remarks

See Also

FileReaderBase Class | Aptify.Applications.Campaigns.ListImport Namespace


NumberHeaderLines Property

Aptify 5.0 Software Development Kit (SDK)

FileReaderBase.NumberHeaderLines Property

Returns the number of header lines that the file format is expected to have based on the meta-data definition of the Campaign Import File Types entity for the provided File Type ID

public virtual Int64 NumberHeaderLines {get;}

Property Value

Remarks

See Also

FileReaderBase Class | Aptify.Applications.Campaigns.ListImport Namespace


FileReaderBase Methods

The methods of the FileReaderBase class are listed below. For a complete list of FileReaderBase class members, see the FileReaderBase Members topic.

Public Instance Methods

CloseFile |
Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetColumnCount |
GetColumnData |
GetCurrentDataRow |
GetDataTable |
GetFullRowData |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsBOF |
IsEOF |
MoveBack |
MoveFirst |
MoveLast |
MoveNext |
OpenFile |
ParseRowData |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

BuildDataTableSchema | This method is responsible for building the table schema for the file type specified. The base functionality simply loads up one column into the data table schema for each column defined in the Campaign List Import File Types columns
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetDisplayColumns |
GetNumHeaderLinesFromDB | This method is responsible for returning the number of header lines for the specified file type from the database definition in the Campaign Import File Types entity. Use this function only if you need to obtain header line information for a file type other than the file type that the base class is already configured for since that information is available in the NumberHeaderLines property in the base class which is loaded at Config() time. This function can also be used to refresh the information from the database.
LoadColumnNames |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnStatusUpdate | This method is responsible for raising the StatusUpdate event as well as notifying the call back (if not null) of status updates. Call this method from sub-classes to handle status notifications of both types from a single call

See Also

FileReaderBase Class | Aptify.Applications.Campaigns.ListImport Namespace


FileReaderBase.BuildDataTableSchema Method

This method is responsible for building the table schema for the file type specified. The base functionality simply loads up one column into the data table schema for each column defined in the Campaign List Import File Types columns

protected virtual DataTable BuildDataTableSchema(
Int64 FileTypeID
);

Parameters

FileTypeID
The Campaign List Import File Type Record ID to be processed

Return Value

Remarks

See Also

FileReaderBase Class | Aptify.Applications.Campaigns.ListImport Namespace


FileReaderBase.CloseFile Method

public abstract void CloseFile();

Implements

ICampaignListFileReader.

See Also

FileReaderBase Class | Aptify.Applications.Campaigns.ListImport Namespace


FileReaderBase.Config Method

public void Config(
AptifyApplication Application,
Int64 FileTypeID
);

Implements

ICampaignListFileReader.

See Also

FileReaderBase Class | Aptify.Applications.Campaigns.ListImport Namespace


FileReaderBase.GetColumnCount Method

public virtual long GetColumnCount();

Implements

ICampaignListFileReader.

See Also

FileReaderBase Class | Aptify.Applications.Campaigns.ListImport Namespace


FileReaderBase.GetColumnData Method

public virtual object GetColumnData(
Int64 Column
);

Implements

ICampaignListFileReader.

See Also

FileReaderBase Class | Aptify.Applications.Campaigns.ListImport Namespace


FileReaderBase.GetCurrentDataRow Method

public virtual DataRow GetCurrentDataRow();

Implements

ICampaignListFileReader.

See Also

FileReaderBase Class | Aptify.Applications.Campaigns.ListImport Namespace


FileReaderBase.GetDataTable Method

public virtual DataTable GetDataTable();

Implements

ICampaignListFileReader.

See Also

FileReaderBase Class | Aptify.Applications.Campaigns.ListImport Namespace


FileReaderBase.GetDisplayColumns Method

protected virtual bool GetDisplayColumns(
Int64 FileTypeID,
List<T> colDisplayColumns
);

Implements

ICampaignListFileReader.

See Also

FileReaderBase Class | Aptify.Applications.Campaigns.ListImport Namespace


FileReaderBase.GetFullRowData Method

public abstract string GetFullRowData();

Implements

ICampaignListFileReader.

See Also

FileReaderBase Class | Aptify.Applications.Campaigns.ListImport Namespace


FileReaderBase.GetNumHeaderLinesFromDB Method

This method is responsible for returning the number of header lines for the specified file type from the database definition in the Campaign Import File Types entity. Use this function only if you need to obtain header line information for a file type other than the file type that the base class is already configured for since that information is available in the NumberHeaderLines property in the base class which is loaded at Config() time. This function can also be used to refresh the information from the database.

protected virtual long GetNumHeaderLinesFromDB(
Int64 FileTypeID,
Boolean Refresh
);

Parameters

FileTypeID
Refresh
Pass in True if you want to force a refresh of the database cache

Return Value

Remarks

See Also

FileReaderBase Class | Aptify.Applications.Campaigns.ListImport Namespace


FileReaderBase.IsBOF Method

public virtual bool IsBOF();

Implements

ICampaignListFileReader.

See Also

FileReaderBase Class | Aptify.Applications.Campaigns.ListImport Namespace


FileReaderBase.IsEOF Method

public virtual bool IsEOF();

Implements

ICampaignListFileReader.

See Also

FileReaderBase Class | Aptify.Applications.Campaigns.ListImport Namespace


FileReaderBase.LoadColumnNames Method

protected virtual bool LoadColumnNames(
Int64 FileTypeID,
ref List`1& colNames
);

Implements

ICampaignListFileReader.

See Also

FileReaderBase Class | Aptify.Applications.Campaigns.ListImport Namespace


FileReaderBase.MoveBack Method

public virtual bool MoveBack();

Implements

ICampaignListFileReader.

See Also

FileReaderBase Class | Aptify.Applications.Campaigns.ListImport Namespace


FileReaderBase.MoveFirst Method

public bool MoveFirst();

Implements

ICampaignListFileReader.

See Also

FileReaderBase Class | Aptify.Applications.Campaigns.ListImport Namespace


FileReaderBase.MoveLast Method

public virtual bool MoveLast();

Implements

ICampaignListFileReader.

See Also

FileReaderBase Class | Aptify.Applications.Campaigns.ListImport Namespace


FileReaderBase.MoveNext Method

public virtual bool MoveNext();

Implements

ICampaignListFileReader.

See Also

FileReaderBase Class | Aptify.Applications.Campaigns.ListImport Namespace


FileReaderBase.OnStatusUpdate Method

This method is responsible for raising the StatusUpdate event as well as notifying the call back (if not null) of status updates. Call this method from sub-classes to handle status notifications of both types from a single call

protected virtual void OnStatusUpdate(
ICampaignStatusCallback StatusUpdate,
ICampaignStatusCallback.ImportPhase Phase,
Int64 RecordNumber,
String RecordName,
Single PercentComplete,
ref Boolean& Cancel
);

Parameters

StatusUpdate
Phase
RecordNumber
RecordName
PercentComplete
Cancel

Remarks

See Also

FileReaderBase Class | Aptify.Applications.Campaigns.ListImport Namespace


FileReaderBase.OpenFile Method

public abstract bool OpenFile(
String FileName,
ICampaignStatusCallback StatusCallback
);

Implements

ICampaignListFileReader.

See Also

FileReaderBase Class | Aptify.Applications.Campaigns.ListImport Namespace


FileReaderBase.ParseRowData Method

public abstract DataRow ParseRowData(
String RowData
);

Implements

ICampaignListFileReader.

See Also

FileReaderBase Class | Aptify.Applications.Campaigns.ListImport Namespace


FileReaderBase Events

The events of the FileReaderBase class are listed below. For a complete list of FileReaderBase class members, see the FileReaderBase Members topic.

Public Instance Events

StatusUpdate

See Also

FileReaderBase Class | Aptify.Applications.Campaigns.ListImport Namespace


FileReaderBase.ICampaignListFileReader.StatusUpdateEventHandler Event

public event ICampaignListFileReader.StatusUpdateEventHandler StatusUpdate;

Implements

ICampaignListFileReader.

See Also

FileReaderBase Class | Aptify.Applications.Campaigns.ListImport Namespace


ICampaignListFileReader Interface

Interface to provide plug-in components for the file reading process.

For a list of all members of this type, see ICampaignListFileReader Members.

public interface ICampaignListFileReader

Types that implement ICampaignListFileReader

Type | Description
CSVTextFileReader | This class provides an implementation for a comma-separated value text file.
ExcelFileReader | This class provides an implementation for Microsoft Excel Files. The class imports the first sheet in the workbook provided.
FileReaderBase | This is the base class for reading in any type of file and loading up its contents This class must be inherited from to be used as it does not intrinscially define the type of file in any way. Override this class to implement the file loading and file manipulation implementation. This class provides an implementation of ICampaignListFileReader and the methods of that interface are exposed as Public and Overridable so that sub-classes can alter those interface methods as well as the internal implementation protected methods of this base class.
TabTextFileReader | This class provides an implementation for a tab-separated value text file
TextFileReaderBase | This is the base class for reading in text files and loading up their contents This class must be inherited from to be used as it does not intrinscially define the delimiters and data format for the file. Override this class to specify a delimiter, text separator, or override/augment the base functionality for file parsing in the various methods that are defined in this base class. This class provides an implementation of ICampaignListFileReader and the methods of that interface are exposed as Public and Overridable so that sub-classes can alter those interface methods as well as the internal implementation protected methods of this base class.

Remarks

Requirements

Namespace: Aptify.Applications.Campaigns.ListImport

Assembly: ICampaignListImport (in ICampaignListImport.dll)

See Also

ICampaignListFileReader Members | Aptify.Applications.Campaigns.ListImport Namespace


ICampaignListFileReader Members

ICampaignListFileReader overview

Public Instance Methods

CloseFile | Closes the internal file pointer. This should be automatically called during the Dispose() method for the class that implements this interface, but should be called before then by the consumer of the class if it is known that the file is no longer going to be used as this will free up system file handles/resources.
Config | Call this function before using any other method on the interface to configure the object for use
GetColumnCount | Returns the number of columns of data in the file provided
GetColumnData | This function returns the value of an individual column in the data for the current row. Column is zero-relative, so the first column is column 0, etc.
GetCurrentDataRow | Returns a DataRow object representing the current row in the file
GetDataTable | This function returns a data table representing the contents of the file specified
GetDisplayColumns | Populates colDisplayColumns with a set of Sequence numbers for the columns that should be used to generate a Display String for each record in the file the Display String is generated by default as the fields in the Campaign Import File Columns sub-type that are marked as ShowInDisplay=1. If no columns are defined in the Campaign Import File Columns entity as ShowInDisplay=1 then the function populates the colDisplayColumns collection with three entries for sequence 0, 1 and 2 as the default to include the first 3 columns in the file as the display. Override this method to alter the way display columns are selected
GetFullRowData | Returns a string representing the entire row of data for the current row in the file
IsBOF | Returns True if the internal row pointer is at the Beginning of File (BOF), False otherwise
IsEOF | Returns True if the internal row pointer is at the End of File (EOF), False otherwise
LoadColumnNames |
MoveBack | Moves the internal row position to the previous row. Returns True if a valid row is in place subsequent to this operation. Returns False is the Beginning of File (BOF) has been reached.
MoveFirst | Moves the internal row position to the first row in the file.
MoveLast | Moves the internal row position to the last row in the file.
MoveNext | Moves the internal row position to the next row. Returns True if a valid row is in place subsequent to this operation. Returns False if the End of File (EOF) has been reached.
OpenFile | OpenFile will open the file specified and internally set up the class to perform any of the other operations required and will set the internal row pointer to the first row in the file
ParseRowData | This function can be used to parse a string that represents data in the format that would be found in the file. This can be used to have an implementor of this interface use its internal algorithm for data parsing to parse any provided string and return a structured DataRow object that is easier to use programatically. For example, this function can be useful for the matching and posting engines once they get the information into the Campaign Import Run Details entity

Public Instance Events

StatusUpdate This event will be fired by the object whenever a certain time period or number of records have gone by in the long running process. The first 3 parameters provide information that can be used to keep the user interface updated on the progress. The last parameter, Cancel, can be used to cancel the long running process. To do so, the object implementing this interface would simply set Cancel to TRUE prior to exiting the function, and the callee would then be required by this interface to abort its operation.

See Also

ICampaignListFileReader Interface | Aptify.Applications.Campaigns.ListImport Namespace


ICampaignListFileReader Methods

The methods of the ICampaignListFileReader interface are listed below. For a complete list of ICampaignListFileReader interface members, see the ICampaignListFileReader Members topic.

Public Instance Methods

CloseFile | Closes the internal file pointer. This should be automatically called during the Dispose() method for the class that implements this interface, but should be called before then by the consumer of the class if it is known that the file is no longer going to be used as this will free up system file handles/resources.
Config | Call this function before using any other method on the interface to configure the object for use
GetColumnCount | Returns the number of columns of data in the file provided
GetColumnData | This function returns the value of an individual column in the data for the current row. Column is zero-relative, so the first column is column 0, etc.
GetCurrentDataRow | Returns a DataRow object representing the current row in the file
GetDataTable | This function returns a data table representing the contents of the file specified
GetDisplayColumns | Populates colDisplayColumns with a set of Sequence numbers for the columns that should be used to generate a Display String for each record in the file the Display String is generated by default as the fields in the Campaign Import File Columns sub-type that are marked as ShowInDisplay=1. If no columns are defined in the Campaign Import File Columns entity as ShowInDisplay=1 then the function populates the colDisplayColumns collection with three entries for sequence 0, 1 and 2 as the default to include the first 3 columns in the file as the display. Override this method to alter the way display columns are selected
GetFullRowData | Returns a string representing the entire row of data for the current row in the file
IsBOF | Returns True if the internal row pointer is at the Beginning of File (BOF), False otherwise
IsEOF | Returns True if the internal row pointer is at the End of File (EOF), False otherwise
LoadColumnNames |
MoveBack | Moves the internal row position to the previous row. Returns True if a valid row is in place subsequent to this operation. Returns False is the Beginning of File (BOF) has been reached.
MoveFirst | Moves the internal row position to the first row in the file.
MoveLast | Moves the internal row position to the last row in the file.
MoveNext | Moves the internal row position to the next row. Returns True if a valid row is in place subsequent to this operation. Returns False if the End of File (EOF) has been reached.
OpenFile | OpenFile will open the file specified and internally set up the class to perform any of the other operations required and will set the internal row pointer to the first row in the file
ParseRowData | This function can be used to parse a string that represents data in the format that would be found in the file. This can be used to have an implementor of this interface use its internal algorithm for data parsing to parse any provided string and return a structured DataRow object that is easier to use programatically. For example, this function can be useful for the matching and posting engines once they get the information into the Campaign Import Run Details entity

See Also

ICampaignListFileReader Interface | Aptify.Applications.Campaigns.ListImport Namespace


ICampaignListFileReader.CloseFile Method

Closes the internal file pointer. This should be automatically called during the Dispose() method for the class that implements this interface, but should be called before then by the consumer of the class if it is known that the file is no longer going to be used as this will free up system file handles/resources.

void CloseFile();

Remarks

See Also

ICampaignListFileReader Interface | Aptify.Applications.Campaigns.ListImport Namespace


ICampaignListFileReader.Config Method

Call this function before using any other method on the interface to configure the object for use

void Config(
AptifyApplication Application,
Int64 FileTypeID
);

Parameters

Application
Aptify Application Required for Use of the Object
FileTypeID
Campaign List Import File Type ID for the file type to be loaeded up

Remarks

See Also

ICampaignListFileReader Interface | Aptify.Applications.Campaigns.ListImport Namespace


ICampaignListFileReader.GetColumnCount Method

Returns the number of columns of data in the file provided

long GetColumnCount();

Return Value

Remarks

See Also

ICampaignListFileReader Interface | Aptify.Applications.Campaigns.ListImport Namespace


ICampaignListFileReader.GetColumnData Method

This function returns the value of an individual column in the data for the current row. Column is zero-relative, so the first column is column 0, etc.

object GetColumnData(
Int64 Column
);

Parameters

Column
Zero-Based Column Sequence To Retrieve Data For

Return Value

Remarks

See Also

ICampaignListFileReader Interface | Aptify.Applications.Campaigns.ListImport Namespace


ICampaignListFileReader.GetCurrentDataRow Method

Returns a DataRow object representing the current row in the file

DataRow GetCurrentDataRow();

Return Value

Remarks

See Also

ICampaignListFileReader Interface | Aptify.Applications.Campaigns.ListImport Namespace


ICampaignListFileReader.GetDataTable Method

This function returns a data table representing the contents of the file specified

DataTable GetDataTable();

Return Value

Remarks

See Also

ICampaignListFileReader Interface | Aptify.Applications.Campaigns.ListImport Namespace


ICampaignListFileReader.GetDisplayColumns Method

Populates colDisplayColumns with a set of Sequence numbers for the columns that should be used to generate a Display String for each record in the file the Display String is generated by default as the fields in the Campaign Import File Columns sub-type that are marked as ShowInDisplay=1. If no columns are defined in the Campaign Import File Columns entity as ShowInDisplay=1 then the function populates the colDisplayColumns collection with three entries for sequence 0, 1 and 2 as the default to include the first 3 columns in the file as the display. Override this method to alter the way display columns are selected

bool GetDisplayColumns(
Int64 FileTypeID,
List<T> colDisplayColumns
);

Parameters

FileTypeID
colDisplayColumns

Return Value

True if function operates succesfully, False otherwise

Remarks

See Also

ICampaignListFileReader Interface | Aptify.Applications.Campaigns.ListImport Namespace


ICampaignListFileReader.GetFullRowData Method

Returns a string representing the entire row of data for the current row in the file

string GetFullRowData();

Return Value

Remarks

See Also

ICampaignListFileReader Interface | Aptify.Applications.Campaigns.ListImport Namespace


ICampaignListFileReader.IsBOF Method

Returns True if the internal row pointer is at the Beginning of File (BOF), False otherwise

bool IsBOF();

Return Value

Remarks

See Also

ICampaignListFileReader Interface | Aptify.Applications.Campaigns.ListImport Namespace


ICampaignListFileReader.IsEOF Method

Returns True if the internal row pointer is at the End of File (EOF), False otherwise

bool IsEOF();

Return Value

Remarks

See Also

ICampaignListFileReader Interface | Aptify.Applications.Campaigns.ListImport Namespace


ICampaignListFileReader.LoadColumnNames Method

bool LoadColumnNames(
Int64 FileTypeID,
ref List`1& colNames
);

See Also

ICampaignListFileReader Interface | Aptify.Applications.Campaigns.ListImport Namespace


ICampaignListFileReader.MoveBack Method

Moves the internal row position to the previous row. Returns True if a valid row is in place subsequent to this operation. Returns False is the Beginning of File (BOF) has been reached.

bool MoveBack();

Return Value

Remarks

See Also

ICampaignListFileReader Interface | Aptify.Applications.Campaigns.ListImport Namespace


ICampaignListFileReader.MoveFirst Method

Moves the internal row position to the first row in the file.

bool MoveFirst();

Return Value

Remarks

See Also

ICampaignListFileReader Interface | Aptify.Applications.Campaigns.ListImport Namespace


ICampaignListFileReader.MoveLast Method

Moves the internal row position to the last row in the file.

bool MoveLast();

Return Value

Remarks

See Also

ICampaignListFileReader Interface | Aptify.Applications.Campaigns.ListImport Namespace


ICampaignListFileReader.MoveNext Method

Moves the internal row position to the next row. Returns True if a valid row is in place subsequent to this operation. Returns False if the End of File (EOF) has been reached.

bool MoveNext();

Return Value

Remarks

See Also

ICampaignListFileReader Interface | Aptify.Applications.Campaigns.ListImport Namespace


ICampaignListFileReader.OpenFile Method

OpenFile will open the file specified and internally set up the class to perform any of the other operations required and will set the internal row pointer to the first row in the file

bool OpenFile(
String FileName,
ICampaignStatusCallback StatusCallback
);

Parameters

FileName
Fully qualfied path name to the file to be imported
StatusCallback
Optional parameter that points to an object that implements ICampaignStatusCallback to retrieve details on the File opening/loading process if it is a long-running task

Return Value

Remarks

See Also

ICampaignListFileReader Interface | Aptify.Applications.Campaigns.ListImport Namespace


ICampaignListFileReader.ParseRowData Method

This function can be used to parse a string that represents data in the format that would be found in the file. This can be used to have an implementor of this interface use its internal algorithm for data parsing to parse any provided string and return a structured DataRow object that is easier to use programatically. For example, this function can be useful for the matching and posting engines once they get the information into the Campaign Import Run Details entity

DataRow ParseRowData(
String RowData
);

Parameters

RowData
String value representing the values that need to be parsed in the same format as would be found inside a file being imported by the object

Return Value

DataRow object representing the string provided

Remarks

See Also

ICampaignListFileReader Interface | Aptify.Applications.Campaigns.ListImport Namespace


ICampaignListFileReader Events

The events of the ICampaignListFileReader interface are listed below. For a complete list of ICampaignListFileReader interface members, see the ICampaignListFileReader Members topic.

Public Instance Events

StatusUpdate This event will be fired by the object whenever a certain time period or number of records have gone by in the long running process. The first 3 parameters provide information that can be used to keep the user interface updated on the progress. The last parameter, Cancel, can be used to cancel the long running process. To do so, the object implementing this interface would simply set Cancel to TRUE prior to exiting the function, and the callee would then be required by this interface to abort its operation.

See Also

ICampaignListFileReader Interface | Aptify.Applications.Campaigns.ListImport Namespace


ICampaignListFileReader.ICampaignListFileReader.StatusUpdateEventHandler Event

This event will be fired by the object whenever a certain time period or number of records have gone by in the long running process. The first 3 parameters provide information that can be used to keep the user interface updated on the progress. The last parameter, Cancel, can be used to cancel the long running process. To do so, the object implementing this interface would simply set Cancel to TRUE prior to exiting the function, and the callee would then be required by this interface to abort its operation.

event ICampaignListFileReader.StatusUpdateEventHandler StatusUpdate;

Remarks

See Also

ICampaignListFileReader Interface | Aptify.Applications.Campaigns.ListImport Namespace


ICampaignListFileReader.StatusUpdateEventHandler Delegate

public delegate void ICampaignListFileReader.StatusUpdateEventHandler(
Int64 RecordNumber,
String RecordName,
Single PercentComplete,
ref Boolean& Cancel
);

Requirements

Namespace: Aptify.Applications.Campaigns.ListImport

Assembly: ICampaignListImport (in ICampaignListImport.dll)

See Also

Aptify.Applications.Campaigns.ListImport Namespace


ICampaignListImporter Interface

Interface to provide plug-in for the overall list import process which consists of loading a file, matching data records and then posting those records that have been through the match process succesfully.

For a list of all members of this type, see ICampaignListImporter Members.

public interface ICampaignListImporter

Types that implement ICampaignListImporter

Type | Description
CampaignListImporter | This object provides the default implementation in Aptify CRM for the ICampaignListImporter interface

Remarks

Requirements

Namespace: Aptify.Applications.Campaigns.ListImport

Assembly: ICampaignListImport (in ICampaignListImport.dll)

See Also

ICampaignListImporter Members | Aptify.Applications.Campaigns.ListImport Namespace


ICampaignListImporter Members

ICampaignListImporter overview

Public Instance Methods

Config | This function must be called before any other method is used on an object implementing this interface. Provides environment/user credential information to the import process.
DoImport | This process starts the import process and returns True if the import is a success, False otherwise. Optionally, a consumer of this interface can retrieve status information from the process by passing in a reference to an object that implements the ICampaignStatusCallback interface, or alternatively listen to the StatusUpdate Event defined in this interface.

Public Instance Events

StatusUpdate This event will be fired by the object whenever a certain time period or number of records have gone by in the long running process. The first 4 parameters provide information that can be used to keep the user interface updated on the progress. The last parameter, Cancel, can be used to cancel the long running process. To do so, the object implementing this interface would simply set Cancel to TRUE prior to exiting the function, and the callee would then be required by this interface to abort its operation.

See Also

ICampaignListImporter Interface | Aptify.Applications.Campaigns.ListImport Namespace


ICampaignListImporter Methods

The methods of the ICampaignListImporter interface are listed below. For a complete list of ICampaignListImporter interface members, see the ICampaignListImporter Members topic.

Public Instance Methods

Config | This function must be called before any other method is used on an object implementing this interface. Provides environment/user credential information to the import process.
DoImport | This process starts the import process and returns True if the import is a success, False otherwise. Optionally, a consumer of this interface can retrieve status information from the process by passing in a reference to an object that implements the ICampaignStatusCallback interface, or alternatively listen to the StatusUpdate Event defined in this interface.

See Also

ICampaignListImporter Interface | Aptify.Applications.Campaigns.ListImport Namespace


ICampaignListImporter.Config Method

This function must be called before any other method is used on an object implementing this interface. Provides environment/user credential information to the import process.

void Config(
AptifyApplication Application
);

Parameters

Application
Required parameter providing the Aptify Application object to the list import object

Remarks

See Also

ICampaignListImporter Interface | Aptify.Applications.Campaigns.ListImport Namespace


ICampaignListImporter.DoImport Method

This process starts the import process and returns True if the import is a success, False otherwise. Optionally, a consumer of this interface can retrieve status information from the process by passing in a reference to an object that implements the ICampaignStatusCallback interface, or alternatively listen to the StatusUpdate Event defined in this interface.

bool DoImport(
Int64 ImportRunID,
ICampaignStatusCallback StatusCallback
);

Parameters

ImportRunID
The import run that should be processed
StatusCallback
Optional reference to an object that implements ICampaignStatusCallback

Return Value

Remarks

See Also

ICampaignListImporter Interface | Aptify.Applications.Campaigns.ListImport Namespace


ICampaignListImporter Events

The events of the ICampaignListImporter interface are listed below. For a complete list of ICampaignListImporter interface members, see the ICampaignListImporter Members topic.

Public Instance Events

StatusUpdate This event will be fired by the object whenever a certain time period or number of records have gone by in the long running process. The first 4 parameters provide information that can be used to keep the user interface updated on the progress. The last parameter, Cancel, can be used to cancel the long running process. To do so, the object implementing this interface would simply set Cancel to TRUE prior to exiting the function, and the callee would then be required by this interface to abort its operation.

See Also

ICampaignListImporter Interface | Aptify.Applications.Campaigns.ListImport Namespace


ICampaignListImporter.ICampaignListImporter.StatusUpdateEventHandler Event

This event will be fired by the object whenever a certain time period or number of records have gone by in the long running process. The first 4 parameters provide information that can be used to keep the user interface updated on the progress. The last parameter, Cancel, can be used to cancel the long running process. To do so, the object implementing this interface would simply set Cancel to TRUE prior to exiting the function, and the callee would then be required by this interface to abort its operation.

event ICampaignListImporter.StatusUpdateEventHandler StatusUpdate;

Remarks

See Also

ICampaignListImporter Interface | Aptify.Applications.Campaigns.ListImport Namespace


ICampaignListImporter.StatusUpdateEventHandler Delegate

public delegate void ICampaignListImporter.StatusUpdateEventHandler(
Int64 RecordNumber,
String RecordName,
Single PercentComplete,
ref Boolean& Cancel
);

Requirements

Namespace: Aptify.Applications.Campaigns.ListImport

Assembly: ICampaignListImport (in ICampaignListImport.dll)

See Also

Aptify.Applications.Campaigns.ListImport Namespace


ICampaignListMatch Interface

Interface to provide plug-in components for the entire list matching process. To override the individual record posting function as opposed to the overall process, utilize the ICampaignRecordMatch interface/object implementation

For a list of all members of this type, see ICampaignListMatch Members.

public interface ICampaignListMatch

Types that implement ICampaignListMatch

Type | Description
CampaignListMatch | This object provides the default implementation in Aptify CRM for the ICampaignListMatch interface

Remarks

Requirements

Namespace: Aptify.Applications.Campaigns.ListImport

Assembly: ICampaignListImport (in ICampaignListImport.dll)

See Also

ICampaignListMatch Members | Aptify.Applications.Campaigns.ListImport Namespace


ICampaignListMatch Members

ICampaignListMatch overview

Public Instance Methods

Config | Call this function before using any other method on the interface to configure the object for use
MatchImportRunDetails | This method allows the caller to match the data from the import run and to receive feedback as it takes place. In addition, the method will abort if the ICampaignStatusCallback implementor passes back a canceling signal in any status call. This method returns TRUE if successful, false otherwise.

Public Instance Events

StatusUpdate This event will be fired by the object whenever a certain time period or number of records have gone by in the long running process. The first 3 parameters provide information that can be used to keep the user interface updated on the progress. The last parameter, Cancel, can be used to cancel the long running process. To do so, the object implementing this interface would simply set Cancel to TRUE prior to exiting the function, and the callee would then be required by this interface to abort its operation.

See Also

ICampaignListMatch Interface | Aptify.Applications.Campaigns.ListImport Namespace


ICampaignListMatch Methods

The methods of the ICampaignListMatch interface are listed below. For a complete list of ICampaignListMatch interface members, see the ICampaignListMatch Members topic.

Public Instance Methods

Config | Call this function before using any other method on the interface to configure the object for use
MatchImportRunDetails | This method allows the caller to match the data from the import run and to receive feedback as it takes place. In addition, the method will abort if the ICampaignStatusCallback implementor passes back a canceling signal in any status call. This method returns TRUE if successful, false otherwise.

See Also

ICampaignListMatch Interface | Aptify.Applications.Campaigns.ListImport Namespace


ICampaignListMatch.Config Method

Call this function before using any other method on the interface to configure the object for use

void Config(
AptifyApplication Application
);

Parameters

Application
Aptify Application Required for Use of the Object

Remarks

See Also

ICampaignListMatch Interface | Aptify.Applications.Campaigns.ListImport Namespace


ICampaignListMatch.MatchImportRunDetails Method

This method allows the caller to match the data from the import run and to receive feedback as it takes place. In addition, the method will abort if the ICampaignStatusCallback implementor passes back a canceling signal in any status call. This method returns TRUE if successful, false otherwise.

bool MatchImportRunDetails(
Int64 ImportRunID,
ICampaignStatusCallback StatusCallback
);

Parameters

ImportRunID
Campaign List Import Run ID for the list to be matched
StatusCallback
Optional parameter pointing to an object that has implemented The ICampaignStatusCallback interface which is used to be notified of progress in the underlying process. Alternatively, the StatusUpdate event on this interface can be listened to for status information

Return Value

Remarks

See Also

ICampaignListMatch Interface | Aptify.Applications.Campaigns.ListImport Namespace


ICampaignListMatch Events

The events of the ICampaignListMatch interface are listed below. For a complete list of ICampaignListMatch interface members, see the ICampaignListMatch Members topic.

Public Instance Events

StatusUpdate This event will be fired by the object whenever a certain time period or number of records have gone by in the long running process. The first 3 parameters provide information that can be used to keep the user interface updated on the progress. The last parameter, Cancel, can be used to cancel the long running process. To do so, the object implementing this interface would simply set Cancel to TRUE prior to exiting the function, and the callee would then be required by this interface to abort its operation.

See Also

ICampaignListMatch Interface | Aptify.Applications.Campaigns.ListImport Namespace


ICampaignListMatch.ICampaignListMatch.StatusUpdateEventHandler Event

This event will be fired by the object whenever a certain time period or number of records have gone by in the long running process. The first 3 parameters provide information that can be used to keep the user interface updated on the progress. The last parameter, Cancel, can be used to cancel the long running process. To do so, the object implementing this interface would simply set Cancel to TRUE prior to exiting the function, and the callee would then be required by this interface to abort its operation.

event ICampaignListMatch.StatusUpdateEventHandler StatusUpdate;

Remarks

See Also

ICampaignListMatch Interface | Aptify.Applications.Campaigns.ListImport Namespace


ICampaignListMatch.StatusUpdateEventHandler Delegate

public delegate void ICampaignListMatch.StatusUpdateEventHandler(
Int64 RecordNumber,
String RecordName,
Single PercentComplete,
ref Boolean& Cancel
);

Requirements

Namespace: Aptify.Applications.Campaigns.ListImport

Assembly: ICampaignListImport (in ICampaignListImport.dll)

See Also

Aptify.Applications.Campaigns.ListImport Namespace


ICampaignListPost Interface

Interface to provide plug-in components for the entire list posting process. To override the individual record posting function as opposed to the overall process, utilize the ICampaignRecordPost interface/object implementation

For a list of all members of this type, see ICampaignListPost Members.

public interface ICampaignListPost

Types that implement ICampaignListPost

Type | Description
CampaignListPost | Class implements the ICampaignListPost interface and provides import list posting functionality.

Remarks

Requirements

Namespace: Aptify.Applications.Campaigns.ListImport

Assembly: ICampaignListImport (in ICampaignListImport.dll)

See Also

ICampaignListPost Members | Aptify.Applications.Campaigns.ListImport Namespace


ICampaignListPost Members

ICampaignListPost overview

Public Instance Methods

Config | Call this function before using any other method on the interface to configure the object for use
Post | This method allows the caller to post the data from the import run and to receive feedback as it takes place. In addition, the method will abort if the ICampaignStatusCallback implementor passes back a canceling signal in any status call. This method returns TRUE if successful, false otherwise.

Public Instance Events

StatusUpdate This event will be fired by the object whenever a certain time period or number of records have gone by in the long running process. The first 3 parameters provide information that can be used to keep the user interface updated on the progress. The last parameter, Cancel, can be used to cancel the long running process. To do so, the object implementing this interface would simply set Cancel to TRUE prior to exiting the function, and the callee would then be required by this interface to abort its operation.

See Also

ICampaignListPost Interface | Aptify.Applications.Campaigns.ListImport Namespace


ICampaignListPost Methods

The methods of the ICampaignListPost interface are listed below. For a complete list of ICampaignListPost interface members, see the ICampaignListPost Members topic.

Public Instance Methods

Config | Call this function before using any other method on the interface to configure the object for use
Post | This method allows the caller to post the data from the import run and to receive feedback as it takes place. In addition, the method will abort if the ICampaignStatusCallback implementor passes back a canceling signal in any status call. This method returns TRUE if successful, false otherwise.

See Also

ICampaignListPost Interface | Aptify.Applications.Campaigns.ListImport Namespace


ICampaignListPost.Config Method

Call this function before using any other method on the interface to configure the object for use

void Config(
AptifyApplication Application
);

Parameters

Application
Aptify Application Required for Use of the Object

Remarks

See Also

ICampaignListPost Interface | Aptify.Applications.Campaigns.ListImport Namespace


ICampaignListPost.Post Method

This method allows the caller to post the data from the import run and to receive feedback as it takes place. In addition, the method will abort if the ICampaignStatusCallback implementor passes back a canceling signal in any status call. This method returns TRUE if successful, false otherwise.

bool Post(
Int64 ImportRunID,
ICampaignStatusCallback StatusCallback
);

Parameters

ImportRunID
Campaign List Import Run ID for the list to be posted
StatusCallback
Optional parameter pointing to an object that has implemented The ICampaignStatusCallback interface which is used to be notified of progress in the underlying process. Alternatively, the StatusUpdate event on this interface can be listened to for status information

Return Value

Remarks

See Also

ICampaignListPost Interface | Aptify.Applications.Campaigns.ListImport Namespace


ICampaignListPost Events

The events of the ICampaignListPost interface are listed below. For a complete list of ICampaignListPost interface members, see the ICampaignListPost Members topic.

Public Instance Events

StatusUpdate This event will be fired by the object whenever a certain time period or number of records have gone by in the long running process. The first 3 parameters provide information that can be used to keep the user interface updated on the progress. The last parameter, Cancel, can be used to cancel the long running process. To do so, the object implementing this interface would simply set Cancel to TRUE prior to exiting the function, and the callee would then be required by this interface to abort its operation.

See Also

ICampaignListPost Interface | Aptify.Applications.Campaigns.ListImport Namespace


ICampaignListPost.ICampaignListPost.StatusUpdateEventHandler Event

This event will be fired by the object whenever a certain time period or number of records have gone by in the long running process. The first 3 parameters provide information that can be used to keep the user interface updated on the progress. The last parameter, Cancel, can be used to cancel the long running process. To do so, the object implementing this interface would simply set Cancel to TRUE prior to exiting the function, and the callee would then be required by this interface to abort its operation.

event ICampaignListPost.StatusUpdateEventHandler StatusUpdate;

Remarks

See Also

ICampaignListPost Interface | Aptify.Applications.Campaigns.ListImport Namespace


ICampaignListPost.StatusUpdateEventHandler Delegate

public delegate void ICampaignListPost.StatusUpdateEventHandler(
Int64 RecordNumber,
String RecordName,
Single PercentComplete,
ref Boolean& Cancel
);

Requirements

Namespace: Aptify.Applications.Campaigns.ListImport

Assembly: ICampaignListImport (in ICampaignListImport.dll)

See Also

Aptify.Applications.Campaigns.ListImport Namespace


ICampaignMatchCollection Interface

Interface used to create plug-ins for managing a group/collection of potential matches for each record in a list import process

For a list of all members of this type, see ICampaignMatchCollection Members.

public interface ICampaignMatchCollection : ICollection, IEnumerable

Types that implement ICampaignMatchCollection

Type | Description
CampaignMatchCollection | Default implemention for ICampaignMatchCollection

Remarks

Requirements

Namespace: Aptify.Applications.Campaigns.ListImport

Assembly: ICampaignListImport (in ICampaignListImport.dll)

See Also

ICampaignMatchCollection Members | Aptify.Applications.Campaigns.ListImport Namespace


ICampaignMatchCollection Members

ICampaignMatchCollection overview

Public Instance Methods

AddMatch | Add a new match record to the collection
GetMatchType | Return the Type of match at the specified index location
GetRecordID | Return the RecordID at the specified index location

See Also

ICampaignMatchCollection Interface | Aptify.Applications.Campaigns.ListImport Namespace


ICampaignMatchCollection Methods

The methods of the ICampaignMatchCollection interface are listed below. For a complete list of ICampaignMatchCollection interface members, see the ICampaignMatchCollection Members topic.

Public Instance Methods

AddMatch | Add a new match record to the collection
GetMatchType | Return the Type of match at the specified index location
GetRecordID | Return the RecordID at the specified index location

See Also

ICampaignMatchCollection Interface | Aptify.Applications.Campaigns.ListImport Namespace


ICampaignMatchCollection.AddMatch Method

Add a new match record to the collection

void AddMatch(
Int64 RecordID,
MatchType Type
);

Parameters

RecordID
Type

Remarks

See Also

ICampaignMatchCollection Interface | Aptify.Applications.Campaigns.ListImport Namespace


ICampaignMatchCollection.GetMatchType Method

Return the Type of match at the specified index location

MatchType GetMatchType(
Int32 Index
);

Parameters

Index

Return Value

Remarks

See Also

ICampaignMatchCollection Interface | Aptify.Applications.Campaigns.ListImport Namespace


ICampaignMatchCollection.GetRecordID Method

Return the RecordID at the specified index location

long GetRecordID(
Int32 Index
);

Parameters

Index

Return Value

Remarks

See Also

ICampaignMatchCollection Interface | Aptify.Applications.Campaigns.ListImport Namespace


ICampaignRecordMatch Interface

This interface is used to implement plug in components that contain logic for matching a single record against something in the DB

For a list of all members of this type, see ICampaignRecordMatch Members.

public interface ICampaignRecordMatch

Types that implement ICampaignRecordMatch

Type | Description
DefaultCompanyMatch | Default Aptify Company Matching class for Aptify CRM. This class inherits from RecordMatchBase and simply provides a default implementation for matching company records in the MatchRecord method().
DefaultPersonMatch | Default Aptify Person Matching class for Aptify CRM. This class inherits from RecordMatchBase and simply provides a default implementation for matching person records in the MatchRecord method().
RecordMatchBase | This class provides base functionality for record matching in the Campaign List Import architecture It requires that it be inherited from for use since the MatchRecord() method of the ICampaignRecordMatch interface is not implemented by this base class. Use this base class for sub-classing to create application specific matching rules.

Remarks

Requirements

Namespace: Aptify.Applications.Campaigns.ListImport

Assembly: ICampaignListImport (in ICampaignListImport.dll)

See Also

ICampaignRecordMatch Members | Aptify.Applications.Campaigns.ListImport Namespace


ICampaignRecordMatch Members

ICampaignRecordMatch overview

Public Instance Methods

Config | Call this function before using any other method on the interface to configure the object for use
MatchRecord | This function is responsible for finding matches for the provided import list detail line item.

See Also

ICampaignRecordMatch Interface | Aptify.Applications.Campaigns.ListImport Namespace


ICampaignRecordMatch Methods

The methods of the ICampaignRecordMatch interface are listed below. For a complete list of ICampaignRecordMatch interface members, see the ICampaignRecordMatch Members topic.

Public Instance Methods

Config | Call this function before using any other method on the interface to configure the object for use
MatchRecord | This function is responsible for finding matches for the provided import list detail line item.

See Also

ICampaignRecordMatch Interface | Aptify.Applications.Campaigns.ListImport Namespace


ICampaignRecordMatch.Config Method

Call this function before using any other method on the interface to configure the object for use

void Config(
AptifyApplication Application
);

Parameters

Application
Aptify Application Required for Use of the Object

Remarks

See Also

ICampaignRecordMatch Interface | Aptify.Applications.Campaigns.ListImport Namespace


ICampaignRecordMatch.MatchRecord Method

This function is responsible for finding matches for the provided import list detail line item.

bool MatchRecord(
AptifyGenericEntityBase ImportDetailGE,
AptifyGenericEntityBase ImportRunGE,
ICampaignMatchCollection MatchCollection
);

Parameters

ImportDetailGE
Aptify Generic Entity Record for the List Import Detail to be matched
ImportRunGE
Aptify Generic Entity Record for the List Import Run record that contains the List Import Detail record
MatchCollection
The collection to add potential and absolute matches to based on the import detail GE record passed in

Return Value

Remarks

See Also

ICampaignRecordMatch Interface | Aptify.Applications.Campaigns.ListImport Namespace


ICampaignRecordPost Interface

Interface used to create plug-ins for posting a single record during the campaign list import process

For a list of all members of this type, see ICampaignRecordPost Members.

public interface ICampaignRecordPost

Types that implement ICampaignRecordPost

Type | Description
DefaultCompanyPost | This class provides the default posting logic for Aptify CRM for the Company Campaign Import List Type. It is possible to sub-class this class and override various methods to alter the posting logic as required.
DefaultPersonPost | This class provides the default posting logic for Aptify CRM for the Persons Campaign Import List Type. It is possible to sub-class this class and override various methods to alter the posting logic as required.
RecordPostBase | This class provides base functionality for record posting in the Campaign List Import architecture It requires that it be inherited from for use since the PostRecord() method of the ICampaignRecordPost interface is not implemented by this base class. Use this base class for sub-classing to create application specific posting rules.

Remarks

Requirements

Namespace: Aptify.Applications.Campaigns.ListImport

Assembly: ICampaignListImport (in ICampaignListImport.dll)

See Also

ICampaignRecordPost Members | Aptify.Applications.Campaigns.ListImport Namespace


ICampaignRecordPost Members

ICampaignRecordPost overview

Public Instance Methods

Config | Call this function before using any other method on the interface to configure the object for use
PostRecord | This method is called once for each detail record in the campaign import list detail for the import run. Implement this method by applying appropriate logic for handing the process of actually "posting" the record into the CRM system including creating/updating Person and/or Company records and making any other necessary changes as appropriate based on the required business logic.

See Also

ICampaignRecordPost Interface | Aptify.Applications.Campaigns.ListImport Namespace


ICampaignRecordPost Methods

The methods of the ICampaignRecordPost interface are listed below. For a complete list of ICampaignRecordPost interface members, see the ICampaignRecordPost Members topic.

Public Instance Methods

Config | Call this function before using any other method on the interface to configure the object for use
PostRecord | This method is called once for each detail record in the campaign import list detail for the import run. Implement this method by applying appropriate logic for handing the process of actually "posting" the record into the CRM system including creating/updating Person and/or Company records and making any other necessary changes as appropriate based on the required business logic.

See Also

ICampaignRecordPost Interface | Aptify.Applications.Campaigns.ListImport Namespace


ICampaignRecordPost.Config Method

Call this function before using any other method on the interface to configure the object for use

void Config(
AptifyApplication Application
);

Parameters

Application
Aptify Application Required for Use of the Object

Remarks

See Also

ICampaignRecordPost Interface | Aptify.Applications.Campaigns.ListImport Namespace


ICampaignRecordPost.PostRecord Method

This method is called once for each detail record in the campaign import list detail for the import run. Implement this method by applying appropriate logic for handing the process of actually "posting" the record into the CRM system including creating/updating Person and/or Company records and making any other necessary changes as appropriate based on the required business logic.

bool PostRecord(
AptifyGenericEntityBase ImportDetailGE,
Int64 CampaignID
);

Parameters

ImportDetailGE
Aptify Generic Entity Record for the List Import Detail to be posted
CampaignID
The Campaign ID that the import is being posted to

Return Value

Remarks

See Also

ICampaignRecordPost Interface | Aptify.Applications.Campaigns.ListImport Namespace


ICampaignStatusCallback Interface

For a list of all members of this type, see ICampaignStatusCallback Members.

public interface ICampaignStatusCallback

Types that implement ICampaignStatusCallback

Type | Description
CampaignImportWizard | Campaign Import Wizard User Interface Class(Form)
CampaignMatchPostControl | Provides a user interface that allows a user to view matching(partial and absolute), unmatched, and posted records for a given Campaign Import Run record.

Requirements

Namespace: Aptify.Applications.Campaigns.ListImport

Assembly: ICampaignListImport (in ICampaignListImport.dll)

See Also

ICampaignStatusCallback Members | Aptify.Applications.Campaigns.ListImport Namespace


ICampaignStatusCallback Members

ICampaignStatusCallback overview

Public Instance Methods

StatusUpdate This method will be called by the Match/Post or other objects that have long running operations whenever a certain time period or number of records have gone by in the long running process. The first 3 parameters provide information that can be used to keep the user interface updated on the progress. The last parameter, Cancel, can be used to cancel the long running process. To do so, the object implementing this interface would simply set Cancel to TRUE prior to exiting the function, and the callee would then be required by this interface to abort its operation.

See Also

ICampaignStatusCallback Interface | Aptify.Applications.Campaigns.ListImport Namespace


ICampaignStatusCallback Methods

The methods of the ICampaignStatusCallback interface are listed below. For a complete list of ICampaignStatusCallback interface members, see the ICampaignStatusCallback Members topic.

Public Instance Methods

StatusUpdate This method will be called by the Match/Post or other objects that have long running operations whenever a certain time period or number of records have gone by in the long running process. The first 3 parameters provide information that can be used to keep the user interface updated on the progress. The last parameter, Cancel, can be used to cancel the long running process. To do so, the object implementing this interface would simply set Cancel to TRUE prior to exiting the function, and the callee would then be required by this interface to abort its operation.

See Also

ICampaignStatusCallback Interface | Aptify.Applications.Campaigns.ListImport Namespace


ICampaignStatusCallback.StatusUpdate Method

This method will be called by the Match/Post or other objects that have long running operations whenever a certain time period or number of records have gone by in the long running process. The first 3 parameters provide information that can be used to keep the user interface updated on the progress. The last parameter, Cancel, can be used to cancel the long running process. To do so, the object implementing this interface would simply set Cancel to TRUE prior to exiting the function, and the callee would then be required by this interface to abort its operation.

void StatusUpdate(
ICampaignStatusCallback.ImportPhase Phase,
Int64 RecordNumber,
String RecordName,
Single PercentComplete,
ref Boolean& Cancel
);

Parameters

Phase
The phase of operation that is being conducted as specified by the enumerated type ImportPhase
RecordNumber
RecordName
PercentComplete
Cancel

Remarks

See Also

ICampaignStatusCallback Interface | Aptify.Applications.Campaigns.ListImport Namespace


ICampaignStatusCallback.ImportPhase Enumeration

public enum ICampaignStatusCallback.ImportPhase

Members

Member Name | Description
LoadingDataFile |
Matching |
Posting |

Requirements

Namespace: Aptify.Applications.Campaigns.ListImport

Assembly: ICampaignListImport (in ICampaignListImport.dll)

See Also

Aptify.Applications.Campaigns.ListImport Namespace


MatchType Enumeration

public enum MatchType

Members

Member Name | Description
MatchPartial |
MatchAbsolute |

Requirements

Namespace: Aptify.Applications.Campaigns.ListImport

Assembly: ICampaignListImport (in ICampaignListImport.dll)

See Also

Aptify.Applications.Campaigns.ListImport Namespace


RecordMatchBase Class

This class provides base functionality for record matching in the Campaign List Import architecture It requires that it be inherited from for use since the MatchRecord() method of the ICampaignRecordMatch interface is not implemented by this base class. Use this base class for sub-classing to create application specific matching rules.

For a list of all members of this type, see RecordMatchBase Members.

System.Object
RecordMatchBase
DefaultCompanyMatch
DefaultPersonMatch

public class RecordMatchBase : ICampaignRecordMatch

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Campaigns.ListImport

Assembly: CampaignListImport (in CampaignListImport.dll)

See Also

RecordMatchBase Members | Aptify.Applications.Campaigns.ListImport Namespace


RecordMatchBase Members

RecordMatchBase overview

Public Instance Constructors

RecordMatchBase Constructor Initializes a new instance of the RecordMatchBase class.

Public Instance Methods

Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetFileColumnNameMap | This method returns the name of the column in the source file that was mapped to a particular field name in the schema of the entity being imported into.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MatchRecord |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

Application | Aptify Application Object
DataAction | Aptify Data Action
Database | Aptify Base Database for Campaigns (and related) entity.

Protected Instance Methods

ContainsRecordID | This method determines if the Record ID specified exists within the collection passed in.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetFieldFromDetailGE | This method returns the value of an individual element in the Campaign Import Run Detail Columns sub-type that can be used in the matching process as needed. The default implementation simply scans through the specified sub-type to determine if a value exists that maps to the column that this particular FieldName matches. This method internally uses the GetFileColumnNameMap() method to determine the name of the column in the import source that matches the specified FieldName parameter.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RecordMatchBase Class | Aptify.Applications.Campaigns.ListImport Namespace


RecordMatchBase Constructor

Initializes a new instance of the RecordMatchBase class.

public RecordMatchBase();

See Also

RecordMatchBase Class | Aptify.Applications.Campaigns.ListImport Namespace


RecordMatchBase Properties

The properties of the RecordMatchBase class are listed below. For a complete list of RecordMatchBase class members, see the RecordMatchBase Members topic.

Protected Instance Properties

Application | Aptify Application Object
DataAction | Aptify Data Action
Database | Aptify Base Database for Campaigns (and related) entity.

See Also

RecordMatchBase Class | Aptify.Applications.Campaigns.ListImport Namespace


Application Property

Aptify 5.0 Software Development Kit (SDK)

RecordMatchBase.Application Property

Aptify Application Object

protected virtual AptifyApplication Application {get;}

Property Value

Remarks

See Also

RecordMatchBase Class | Aptify.Applications.Campaigns.ListImport Namespace


DataAction Property

Aptify 5.0 Software Development Kit (SDK)

RecordMatchBase.DataAction Property

Aptify Data Action

protected virtual DataAction DataAction {get;}

Property Value

Remarks

See Also

RecordMatchBase Class | Aptify.Applications.Campaigns.ListImport Namespace


Database Property

Aptify 5.0 Software Development Kit (SDK)

RecordMatchBase.Database Property

Aptify Base Database for Campaigns (and related) entity.

protected virtual String Database {get;}

Property Value

Remarks

See Also

RecordMatchBase Class | Aptify.Applications.Campaigns.ListImport Namespace


RecordMatchBase Methods

The methods of the RecordMatchBase class are listed below. For a complete list of RecordMatchBase class members, see the RecordMatchBase Members topic.

Public Instance Methods

Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetFileColumnNameMap | This method returns the name of the column in the source file that was mapped to a particular field name in the schema of the entity being imported into.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MatchRecord |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

ContainsRecordID | This method determines if the Record ID specified exists within the collection passed in.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetFieldFromDetailGE | This method returns the value of an individual element in the Campaign Import Run Detail Columns sub-type that can be used in the matching process as needed. The default implementation simply scans through the specified sub-type to determine if a value exists that maps to the column that this particular FieldName matches. This method internally uses the GetFileColumnNameMap() method to determine the name of the column in the import source that matches the specified FieldName parameter.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RecordMatchBase Class | Aptify.Applications.Campaigns.ListImport Namespace


RecordMatchBase.Config Method

public void Config(
AptifyApplication Application
);

Implements

ICampaignRecordMatch.

See Also

RecordMatchBase Class | Aptify.Applications.Campaigns.ListImport Namespace


RecordMatchBase.ContainsRecordID Method

This method determines if the Record ID specified exists within the collection passed in.

protected virtual bool ContainsRecordID(
Int64 RecordID,
CampaignMatchCollection MatchCollection
);

Parameters

RecordID
MatchCollection

Return Value

Remarks

See Also

RecordMatchBase Class | Aptify.Applications.Campaigns.ListImport Namespace


RecordMatchBase.GetFieldFromDetailGE Method

This method returns the value of an individual element in the Campaign Import Run Detail Columns sub-type that can be used in the matching process as needed. The default implementation simply scans through the specified sub-type to determine if a value exists that maps to the column that this particular FieldName matches. This method internally uses the GetFileColumnNameMap() method to determine the name of the column in the import source that matches the specified FieldName parameter.

protected virtual string GetFieldFromDetailGE(
AptifyGenericEntityBase ImportDetailGE,
AptifyGenericEntityBase ImportRunGE,
String FieldName,
ref String& ColumnName
);

Parameters

ImportDetailGE
An Aptify GE Base object for the Campaign Import Run Detail
ImportRunGE
FieldName
ColumnName
IN/OUT: This parameter can be used to provide the name of the column in the import source directly which will result in a bypass of the logic described in this method that would do a lookup on the import source column name based on the FieldName in the destination data. This parameter also provides an OUT parameter value if it is not initially provided and will return the mapping of the FieldName parameter to a ColumnName in the import source.

Return Value

Remarks

See Also

RecordMatchBase Class | Aptify.Applications.Campaigns.ListImport Namespace


RecordMatchBase.GetFileColumnNameMap Method

This method returns the name of the column in the source file that was mapped to a particular field name in the schema of the entity being imported into.

public virtual string GetFileColumnNameMap(
AptifyGenericEntityBase ImportRunGE,
String FieldName
);

Parameters

ImportRunGE
FieldName

Return Value

Remarks

See Also

RecordMatchBase Class | Aptify.Applications.Campaigns.ListImport Namespace


RecordMatchBase.MatchRecord Method

public abstract bool MatchRecord(
AptifyGenericEntityBase ImportDetailGE,
AptifyGenericEntityBase ImportRunGE,
ICampaignMatchCollection MatchCollection
);

Implements

ICampaignRecordMatch.

See Also

RecordMatchBase Class | Aptify.Applications.Campaigns.ListImport Namespace


RecordPostBase Class

This class provides base functionality for record posting in the Campaign List Import architecture It requires that it be inherited from for use since the PostRecord() method of the ICampaignRecordPost interface is not implemented by this base class. Use this base class for sub-classing to create application specific posting rules.

For a list of all members of this type, see RecordPostBase Members.

System.Object
RecordPostBase
DefaultCompanyPost
DefaultPersonPost

public class RecordPostBase : ICampaignRecordPost

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Campaigns.ListImport

Assembly: CampaignListImport (in CampaignListImport.dll)

See Also

RecordPostBase Members | Aptify.Applications.Campaigns.ListImport Namespace


RecordPostBase Members

RecordPostBase overview

Public Instance Constructors

RecordPostBase Constructor Initializes a new instance of the RecordPostBase class.

Public Instance Methods

Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
PostRecord |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

Application | Aptify Application Object
DataAction | Aptify Data Action
Database | Aptify Base Database for Campaigns (and related) entity.

Protected Instance Methods

ContainsRecordID | This method determines if the Record ID specified exists within the collection passed in
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetEntityMinimumRecordID | This method returns the lowest ID value in the entity table provided to the method through the Entity parameter
GetFieldFromDetailGE | This method returns the value of an individual element in the Campaign Import Run Detail Columns sub-type that can be used in the matching process as needed. The default implementation simply scans through the specified sub-type to determine if the FieldName exists within the ColumnName field in the sub-type
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RecordPostBase Class | Aptify.Applications.Campaigns.ListImport Namespace


RecordPostBase Constructor

Initializes a new instance of the RecordPostBase class.

public RecordPostBase();

See Also

RecordPostBase Class | Aptify.Applications.Campaigns.ListImport Namespace


RecordPostBase Properties

The properties of the RecordPostBase class are listed below. For a complete list of RecordPostBase class members, see the RecordPostBase Members topic.

Protected Instance Properties

Application | Aptify Application Object
DataAction | Aptify Data Action
Database | Aptify Base Database for Campaigns (and related) entity.

See Also

RecordPostBase Class | Aptify.Applications.Campaigns.ListImport Namespace


Application Property

Aptify 5.0 Software Development Kit (SDK)

RecordPostBase.Application Property

Aptify Application Object

protected virtual AptifyApplication Application {get;}

Property Value

Remarks

See Also

RecordPostBase Class | Aptify.Applications.Campaigns.ListImport Namespace


DataAction Property

Aptify 5.0 Software Development Kit (SDK)

RecordPostBase.DataAction Property

Aptify Data Action

protected virtual DataAction DataAction {get;}

Property Value

Remarks

See Also

RecordPostBase Class | Aptify.Applications.Campaigns.ListImport Namespace


Database Property

Aptify 5.0 Software Development Kit (SDK)

RecordPostBase.Database Property

Aptify Base Database for Campaigns (and related) entity.

protected virtual String Database {get;}

Property Value

Remarks

See Also

RecordPostBase Class | Aptify.Applications.Campaigns.ListImport Namespace


RecordPostBase Methods

The methods of the RecordPostBase class are listed below. For a complete list of RecordPostBase class members, see the RecordPostBase Members topic.

Public Instance Methods

Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
PostRecord |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

ContainsRecordID | This method determines if the Record ID specified exists within the collection passed in
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetEntityMinimumRecordID | This method returns the lowest ID value in the entity table provided to the method through the Entity parameter
GetFieldFromDetailGE | This method returns the value of an individual element in the Campaign Import Run Detail Columns sub-type that can be used in the matching process as needed. The default implementation simply scans through the specified sub-type to determine if the FieldName exists within the ColumnName field in the sub-type
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RecordPostBase Class | Aptify.Applications.Campaigns.ListImport Namespace


RecordPostBase.Config Method

public void Config(
AptifyApplication Application
);

Implements

ICampaignRecordPost.

See Also

RecordPostBase Class | Aptify.Applications.Campaigns.ListImport Namespace


RecordPostBase.ContainsRecordID Method

This method determines if the Record ID specified exists within the collection passed in

protected virtual bool ContainsRecordID(
Int64 RecordID,
CampaignMatchCollection MatchCollection
);

Parameters

RecordID
MatchCollection

Return Value

Remarks

See Also

RecordPostBase Class | Aptify.Applications.Campaigns.ListImport Namespace


RecordPostBase.GetEntityMinimumRecordID Method

This method returns the lowest ID value in the entity table provided to the method through the Entity parameter

protected virtual long GetEntityMinimumRecordID(
String Entity
);

Parameters

Entity
Entity Name of any Entity within the Aptify environment

Return Value

A positive value if records exist representing the lowest value in the specified entity. If an error occurs, -1 is returned and details will be in the session exception log

Remarks

See Also

RecordPostBase Class | Aptify.Applications.Campaigns.ListImport Namespace


RecordPostBase.GetFieldFromDetailGE Method

This method returns the value of an individual element in the Campaign Import Run Detail Columns sub-type that can be used in the matching process as needed. The default implementation simply scans through the specified sub-type to determine if the FieldName exists within the ColumnName field in the sub-type

protected virtual string GetFieldFromDetailGE(
AptifyGenericEntityBase ImportDetailGE,
String FieldName
);

Parameters

ImportDetailGE
An Aptify GE Base object for the Campaign Import Run Detail
FieldName

Return Value

Remarks

See Also

RecordPostBase Class | Aptify.Applications.Campaigns.ListImport Namespace


RecordPostBase.PostRecord Method

public abstract bool PostRecord(
AptifyGenericEntityBase ImportDetailGE,
Int64 CampaignID
);

Implements

ICampaignRecordPost.

See Also

RecordPostBase Class | Aptify.Applications.Campaigns.ListImport Namespace


TabTextFileReader Class

This class provides an implementation for a tab-separated value text file

For a list of all members of this type, see TabTextFileReader Members.

System.Object
FileReaderBase
TextFileReaderBase
TabTextFileReader

public class TabTextFileReader : TextFileReaderBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Campaigns.ListImport

Assembly: CampaignListImport (in CampaignListImport.dll)

See Also

TabTextFileReader Members | Aptify.Applications.Campaigns.ListImport Namespace


TabTextFileReader Members

TabTextFileReader overview

Public Instance Constructors

TabTextFileReader Constructor Initializes a new instance of the TabTextFileReader class.

Public Instance Properties

Application (inherited from FileReaderBase) | Aptify Application - this property is only available after Config() is called
DataAction (inherited from FileReaderBase) | Aptify Data Action - this property is only available after Config() is called
Database (inherited from FileReaderBase) | Returns the name of the database that the object is connected to based on the Base Database of the Campaigns entity
FileTypeID (inherited from FileReaderBase) | Returns the File Type the file reader is set up for
NumberHeaderLines (inherited from FileReaderBase) | Returns the number of header lines that the file format is expected to have based on the meta-data definition of the Campaign Import File Types entity for the provided File Type ID

Public Instance Methods

CloseFile (inherited from TextFileReaderBase) |
Config (inherited from FileReaderBase) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetColumnCount (inherited from FileReaderBase) |
GetColumnData (inherited from FileReaderBase) |
GetCurrentDataRow (inherited from FileReaderBase) |
GetDataTable (inherited from FileReaderBase) |
GetFullRowData (inherited from TextFileReaderBase) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsBOF (inherited from FileReaderBase) |
IsEOF (inherited from FileReaderBase) |
MoveBack (inherited from FileReaderBase) |
MoveFirst (inherited from FileReaderBase) |
MoveLast (inherited from FileReaderBase) |
MoveNext (inherited from FileReaderBase) |
OpenFile (inherited from TextFileReaderBase) |
ParseRowData (inherited from TextFileReaderBase) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

StatusUpdate (inherited from FileReaderBase)

Protected Instance Fields

m_dtFile (inherited from FileReaderBase) | Represents a data table that is loaded by the class to contain the entire contents of the data file that is being parsed
m_iCurrentRow (inherited from FileReaderBase) | Represents the current row in the data table that the file is pointing to

Protected Instance Properties

ColumnDelimiter |
FileNumber (inherited from TextFileReaderBase) | Returns an integer number greater than zero if a file is currently open and being operated upon. Returns 0 if no file is open
TextSeparator |

Protected Instance Methods

BuildDataTableSchema (inherited from FileReaderBase) | This method is responsible for building the table schema for the file type specified. The base functionality simply loads up one column into the data table schema for each column defined in the Campaign List Import File Types columns
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetDisplayColumns (inherited from FileReaderBase) |
GetNumHeaderLinesFromDB (inherited from FileReaderBase) | This method is responsible for returning the number of header lines for the specified file type from the database definition in the Campaign Import File Types entity. Use this function only if you need to obtain header line information for a file type other than the file type that the base class is already configured for since that information is available in the NumberHeaderLines property in the base class which is loaded at Config() time. This function can also be used to refresh the information from the database.
LoadColumnNames (inherited from FileReaderBase) |
LoadSingleFileLine (inherited from TextFileReaderBase) | This method is responsible for loading up a single file line. It is called by the class to load up each file line and the assumption is that it will load the file line, parse it, and then add the row to the internal data table m_dtFile.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnStatusUpdate (inherited from FileReaderBase) | This method is responsible for raising the StatusUpdate event as well as notifying the call back (if not null) of status updates. Call this method from sub-classes to handle status notifications of both types from a single call

See Also

TabTextFileReader Class | Aptify.Applications.Campaigns.ListImport Namespace


TabTextFileReader Constructor

Initializes a new instance of the TabTextFileReader class.

public TabTextFileReader();

See Also

TabTextFileReader Class | Aptify.Applications.Campaigns.ListImport Namespace


TabTextFileReader Properties

The properties of the TabTextFileReader class are listed below. For a complete list of TabTextFileReader class members, see the TabTextFileReader Members topic.

Public Instance Properties

Application (inherited from FileReaderBase) | Aptify Application - this property is only available after Config() is called
DataAction (inherited from FileReaderBase) | Aptify Data Action - this property is only available after Config() is called
Database (inherited from FileReaderBase) | Returns the name of the database that the object is connected to based on the Base Database of the Campaigns entity
FileTypeID (inherited from FileReaderBase) | Returns the File Type the file reader is set up for
NumberHeaderLines (inherited from FileReaderBase) | Returns the number of header lines that the file format is expected to have based on the meta-data definition of the Campaign Import File Types entity for the provided File Type ID

Protected Instance Properties

ColumnDelimiter |
FileNumber (inherited from TextFileReaderBase) | Returns an integer number greater than zero if a file is currently open and being operated upon. Returns 0 if no file is open
TextSeparator |

See Also

TabTextFileReader Class | Aptify.Applications.Campaigns.ListImport Namespace


ColumnDelimiter Property

Aptify 5.0 Software Development Kit (SDK)

TabTextFileReader.ColumnDelimiter Property

protected override String ColumnDelimiter {get;}

See Also

TabTextFileReader Class | Aptify.Applications.Campaigns.ListImport Namespace


TextSeparator Property

Aptify 5.0 Software Development Kit (SDK)

TabTextFileReader.TextSeparator Property

protected override String TextSeparator {get;}

See Also

TabTextFileReader Class | Aptify.Applications.Campaigns.ListImport Namespace


TextFileReaderBase Class

This is the base class for reading in text files and loading up their contents This class must be inherited from to be used as it does not intrinscially define the delimiters and data format for the file. Override this class to specify a delimiter, text separator, or override/augment the base functionality for file parsing in the various methods that are defined in this base class. This class provides an implementation of ICampaignListFileReader and the methods of that interface are exposed as Public and Overridable so that sub-classes can alter those interface methods as well as the internal implementation protected methods of this base class.

For a list of all members of this type, see TextFileReaderBase Members.

System.Object
FileReaderBase
TextFileReaderBase
CSVTextFileReader
TabTextFileReader

public class TextFileReaderBase : FileReaderBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Campaigns.ListImport

Assembly: CampaignListImport (in CampaignListImport.dll)

See Also

TextFileReaderBase Members | Aptify.Applications.Campaigns.ListImport Namespace


TextFileReaderBase Members

TextFileReaderBase overview

Public Instance Constructors

TextFileReaderBase Constructor Initializes a new instance of the TextFileReaderBase class.

Public Instance Properties

Application (inherited from FileReaderBase) | Aptify Application - this property is only available after Config() is called
DataAction (inherited from FileReaderBase) | Aptify Data Action - this property is only available after Config() is called
Database (inherited from FileReaderBase) | Returns the name of the database that the object is connected to based on the Base Database of the Campaigns entity
FileTypeID (inherited from FileReaderBase) | Returns the File Type the file reader is set up for
NumberHeaderLines (inherited from FileReaderBase) | Returns the number of header lines that the file format is expected to have based on the meta-data definition of the Campaign Import File Types entity for the provided File Type ID

Public Instance Methods

CloseFile |
Config (inherited from FileReaderBase) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetColumnCount (inherited from FileReaderBase) |
GetColumnData (inherited from FileReaderBase) |
GetCurrentDataRow (inherited from FileReaderBase) |
GetDataTable (inherited from FileReaderBase) |
GetFullRowData |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsBOF (inherited from FileReaderBase) |
IsEOF (inherited from FileReaderBase) |
MoveBack (inherited from FileReaderBase) |
MoveFirst (inherited from FileReaderBase) |
MoveLast (inherited from FileReaderBase) |
MoveNext (inherited from FileReaderBase) |
OpenFile |
ParseRowData |
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

StatusUpdate (inherited from FileReaderBase)

Protected Instance Fields

m_dtFile (inherited from FileReaderBase) | Represents a data table that is loaded by the class to contain the entire contents of the data file that is being parsed
m_iCurrentRow (inherited from FileReaderBase) | Represents the current row in the data table that the file is pointing to

Protected Instance Properties

ColumnDelimiter |
FileNumber | Returns an integer number greater than zero if a file is currently open and being operated upon. Returns 0 if no file is open
TextSeparator |

Protected Instance Methods

BuildDataTableSchema (inherited from FileReaderBase) | This method is responsible for building the table schema for the file type specified. The base functionality simply loads up one column into the data table schema for each column defined in the Campaign List Import File Types columns
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetDisplayColumns (inherited from FileReaderBase) |
GetNumHeaderLinesFromDB (inherited from FileReaderBase) | This method is responsible for returning the number of header lines for the specified file type from the database definition in the Campaign Import File Types entity. Use this function only if you need to obtain header line information for a file type other than the file type that the base class is already configured for since that information is available in the NumberHeaderLines property in the base class which is loaded at Config() time. This function can also be used to refresh the information from the database.
LoadColumnNames (inherited from FileReaderBase) |
LoadSingleFileLine | This method is responsible for loading up a single file line. It is called by the class to load up each file line and the assumption is that it will load the file line, parse it, and then add the row to the internal data table m_dtFile.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnStatusUpdate (inherited from FileReaderBase) | This method is responsible for raising the StatusUpdate event as well as notifying the call back (if not null) of status updates. Call this method from sub-classes to handle status notifications of both types from a single call

See Also

TextFileReaderBase Class | Aptify.Applications.Campaigns.ListImport Namespace


TextFileReaderBase Constructor

Initializes a new instance of the TextFileReaderBase class.

public TextFileReaderBase();

See Also

TextFileReaderBase Class | Aptify.Applications.Campaigns.ListImport Namespace


TextFileReaderBase Properties

The properties of the TextFileReaderBase class are listed below. For a complete list of TextFileReaderBase class members, see the TextFileReaderBase Members topic.

Public Instance Properties

Application (inherited from FileReaderBase) | Aptify Application - this property is only available after Config() is called
DataAction (inherited from FileReaderBase) | Aptify Data Action - this property is only available after Config() is called
Database (inherited from FileReaderBase) | Returns the name of the database that the object is connected to based on the Base Database of the Campaigns entity
FileTypeID (inherited from FileReaderBase) | Returns the File Type the file reader is set up for
NumberHeaderLines (inherited from FileReaderBase) | Returns the number of header lines that the file format is expected to have based on the meta-data definition of the Campaign Import File Types entity for the provided File Type ID

Protected Instance Properties

ColumnDelimiter |
FileNumber | Returns an integer number greater than zero if a file is currently open and being operated upon. Returns 0 if no file is open
TextSeparator |

See Also

TextFileReaderBase Class | Aptify.Applications.Campaigns.ListImport Namespace


ColumnDelimiter Property

Aptify 5.0 Software Development Kit (SDK)

TextFileReaderBase.ColumnDelimiter Property

protected abstract String ColumnDelimiter {get;}

See Also

TextFileReaderBase Class | Aptify.Applications.Campaigns.ListImport Namespace


FileNumber Property

Aptify 5.0 Software Development Kit (SDK)

TextFileReaderBase.FileNumber Property

Returns an integer number greater than zero if a file is currently open and being operated upon. Returns 0 if no file is open

protected Int32 FileNumber {get;}

Property Value

Remarks

See Also

TextFileReaderBase Class | Aptify.Applications.Campaigns.ListImport Namespace


TextSeparator Property

Aptify 5.0 Software Development Kit (SDK)

TextFileReaderBase.TextSeparator Property

protected abstract String TextSeparator {get;}

See Also

TextFileReaderBase Class | Aptify.Applications.Campaigns.ListImport Namespace


TextFileReaderBase Methods

The methods of the TextFileReaderBase class are listed below. For a complete list of TextFileReaderBase class members, see the TextFileReaderBase Members topic.

Public Instance Methods

CloseFile |
Config (inherited from FileReaderBase) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetColumnCount (inherited from FileReaderBase) |
GetColumnData (inherited from FileReaderBase) |
GetCurrentDataRow (inherited from FileReaderBase) |
GetDataTable (inherited from FileReaderBase) |
GetFullRowData |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsBOF (inherited from FileReaderBase) |
IsEOF (inherited from FileReaderBase) |
MoveBack (inherited from FileReaderBase) |
MoveFirst (inherited from FileReaderBase) |
MoveLast (inherited from FileReaderBase) |
MoveNext (inherited from FileReaderBase) |
OpenFile |
ParseRowData |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

BuildDataTableSchema (inherited from FileReaderBase) | This method is responsible for building the table schema for the file type specified. The base functionality simply loads up one column into the data table schema for each column defined in the Campaign List Import File Types columns
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetDisplayColumns (inherited from FileReaderBase) |
GetNumHeaderLinesFromDB (inherited from FileReaderBase) | This method is responsible for returning the number of header lines for the specified file type from the database definition in the Campaign Import File Types entity. Use this function only if you need to obtain header line information for a file type other than the file type that the base class is already configured for since that information is available in the NumberHeaderLines property in the base class which is loaded at Config() time. This function can also be used to refresh the information from the database.
LoadColumnNames (inherited from FileReaderBase) |
LoadSingleFileLine | This method is responsible for loading up a single file line. It is called by the class to load up each file line and the assumption is that it will load the file line, parse it, and then add the row to the internal data table m_dtFile.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnStatusUpdate (inherited from FileReaderBase) | This method is responsible for raising the StatusUpdate event as well as notifying the call back (if not null) of status updates. Call this method from sub-classes to handle status notifications of both types from a single call

See Also

TextFileReaderBase Class | Aptify.Applications.Campaigns.ListImport Namespace


TextFileReaderBase.CloseFile Method

public override void CloseFile();

Implements

ICampaignListFileReader.

See Also

TextFileReaderBase Class | Aptify.Applications.Campaigns.ListImport Namespace


TextFileReaderBase.GetFullRowData Method

public override string GetFullRowData();

Implements

ICampaignListFileReader.

See Also

TextFileReaderBase Class | Aptify.Applications.Campaigns.ListImport Namespace


TextFileReaderBase.LoadSingleFileLine Method

This method is responsible for loading up a single file line. It is called by the class to load up each file line and the assumption is that it will load the file line, parse it, and then add the row to the internal data table m_dtFile.

protected virtual void LoadSingleFileLine(
ref Int64& BytesRead
);

Parameters

BytesRead
This is an OUT parameter that returns the number of bytes read in by the single line

Remarks

See Also

TextFileReaderBase Class | Aptify.Applications.Campaigns.ListImport Namespace


TextFileReaderBase.OpenFile Method

public override bool OpenFile(
String FileName,
ICampaignStatusCallback StatusCallback
);

Implements

ICampaignListFileReader.

See Also

TextFileReaderBase Class | Aptify.Applications.Campaigns.ListImport Namespace


TextFileReaderBase.ParseRowData Method

public override DataRow ParseRowData(
String RowData
);

Implements

ICampaignListFileReader.

See Also

TextFileReaderBase Class | Aptify.Applications.Campaigns.ListImport Namespace


Aptify.Applications.CaseManagement

Aptify 5.0 Software Development Kit (SDK)

Aptify.Applications.CaseManagement Namespace

The objects in this namespace implement functionality for Aptify's Case Management application.

Namespace hierarchy

Classes

Class | Description
clsNewCase |
DisableFields |
FindCases |
frmWizard |


clsNewCase Class

For a list of all members of this type, see clsNewCase Members.

System.Object
clsNewCase

public class clsNewCase : IAptifyAction

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.CaseManagement

Assembly: NewCaseWizard (in NewCaseWizard.dll)

See Also

clsNewCase Members | Aptify.Applications.CaseManagement Namespace


clsNewCase Members

clsNewCase overview

Public Instance Constructors

clsNewCase Constructor Initializes a new instance of the clsNewCase class.

Public Instance Methods

DoAction | Overloaded.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

clsNewCase Class | Aptify.Applications.CaseManagement Namespace


clsNewCase Constructor

Initializes a new instance of the clsNewCase class.

public clsNewCase();

See Also

clsNewCase Class | Aptify.Applications.CaseManagement Namespace


clsNewCase Methods

The methods of the clsNewCase class are listed below. For a complete list of clsNewCase class members, see the clsNewCase Members topic.

Public Instance Methods

DoAction | Overloaded.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

clsNewCase Class | Aptify.Applications.CaseManagement Namespace


DoAction Method

Aptify 5.0 Software Development Kit (SDK)

clsNewCase.DoAction Method

Overload List

public void DoAction(AptifyApplication,Int64);

public void DoAction(AptifyApplication,Int64,Int64);

public void DoAction(AptifyApplication,Int64,Int64,params Object[]);

public void DoAction(AptifyApplication,Int64,params String[]);

See Also

clsNewCase Class | Aptify.Applications.CaseManagement Namespace


clsNewCase.DoAction Method (AptifyApplication, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID
);

Implements

IAptifyAction.

See Also

clsNewCase Class | Aptify.Applications.CaseManagement Namespace | clsNewCase.DoAction Overload List


clsNewCase.DoAction Method (AptifyApplication, Int64, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID
);

Implements

IAptifyAction.

See Also

clsNewCase Class | Aptify.Applications.CaseManagement Namespace | clsNewCase.DoAction Overload List


clsNewCase.DoAction Method (AptifyApplication, Int64, Int64, Object[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID,
params Object[] SelectedItems
);

Implements

IAptifyAction.

See Also

clsNewCase Class | Aptify.Applications.CaseManagement Namespace | clsNewCase.DoAction Overload List


clsNewCase.DoAction Method (AptifyApplication, Int64, String[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
params String[] SelectedItems
);

Implements

IAptifyAction.

See Also

clsNewCase Class | Aptify.Applications.CaseManagement Namespace | clsNewCase.DoAction Overload List


DisableFields Class

For a list of all members of this type, see DisableFields Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
DisableFields

public class DisableFields : FormTemplateLayout

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.CaseManagement

Assembly: CaseAssigneePostalCodeLayoutContols (in CaseAssigneePostalCodeLayoutContols.dll)

See Also

DisableFields Members | Aptify.Applications.CaseManagement Namespace


DisableFields Members

DisableFields overview

Public Instance Constructors

DisableFields Constructor Initializes a new instance of the DisableFields class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

DisableFields Class | Aptify.Applications.CaseManagement Namespace


DisableFields Constructor

Initializes a new instance of the DisableFields class.

public DisableFields();

See Also

DisableFields Class | Aptify.Applications.CaseManagement Namespace


DisableFields Methods

The methods of the DisableFields class are listed below. For a complete list of DisableFields class members, see the DisableFields Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

DisableFields Class | Aptify.Applications.CaseManagement Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

DisableFields.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

DisableFields Class | Aptify.Applications.CaseManagement Namespace


DisableFields.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

DisableFields Class | Aptify.Applications.CaseManagement Namespace | DisableFields.Dispose Overload List


DisableFields.OnFormTemplateLoaded Method

protected override void OnFormTemplateLoaded(
FormTemplateLayout.FormTemplateLoadedEventArgs e
);

See Also

DisableFields Class | Aptify.Applications.CaseManagement Namespace


FindCases Class

For a list of all members of this type, see FindCases Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FindCases

public class FindCases : UserControl, IDashboardComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.CaseManagement

Assembly: FindCasesInCaseMgmt (in FindCasesInCaseMgmt.dll)

See Also

FindCases Members | Aptify.Applications.CaseManagement Namespace


FindCases Members

FindCases overview

Public Instance Constructors

FindCases Constructor Initializes a new instance of the FindCases class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ID |
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Properties | Overloaded.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
State |
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

FindCases Class | Aptify.Applications.CaseManagement Namespace


FindCases Constructor

Initializes a new instance of the FindCases class.

public FindCases();

See Also

FindCases Class | Aptify.Applications.CaseManagement Namespace


FindCases Properties

The properties of the FindCases class are listed below. For a complete list of FindCases class members, see the FindCases Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ID |
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Properties | Overloaded.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
State |
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

FindCases Class | Aptify.Applications.CaseManagement Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

FindCases.ID Property

public Int64 ID {get;}

Implements

IDashboardComponent.

See Also

FindCases Class | Aptify.Applications.CaseManagement Namespace


Mode Property

Aptify 5.0 Software Development Kit (SDK)

FindCases.Mode Property

public DashboardMode Mode {get; set;}

Implements

IDashboardComponent.

See Also

FindCases Class | Aptify.Applications.CaseManagement Namespace


Properties Property

Aptify 5.0 Software Development Kit (SDK)

FindCases.Properties Property

new public AptifyProperties Properties {get;}

Implements

IDashboardComponent.

See Also

FindCases Class | Aptify.Applications.CaseManagement Namespace


State Property

Aptify 5.0 Software Development Kit (SDK)

FindCases.State Property

public ComponentState State {get; set;}

Implements

IDashboardComponent.

See Also

FindCases Class | Aptify.Applications.CaseManagement Namespace


FindCases Methods

The methods of the FindCases class are listed below. For a complete list of FindCases class members, see the FindCases Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

FindCases Class | Aptify.Applications.CaseManagement Namespace


FindCases.Config Method

public void Config(
AptifyApplication ApplicationObject,
IDashboardArea Area,
Int64 PartID,
ComponentOrientation Orientation
);

Implements

IDashboardComponent.

See Also

FindCases Class | Aptify.Applications.CaseManagement Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

FindCases.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

FindCases Class | Aptify.Applications.CaseManagement Namespace


FindCases.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

FindCases Class | Aptify.Applications.CaseManagement Namespace | FindCases.Dispose Overload List


frmWizard Class

For a list of all members of this type, see frmWizard Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
frmWizard

public class frmWizard : Form

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.CaseManagement

Assembly: NewCaseWizard (in NewCaseWizard.dll)

See Also

frmWizard Members | Aptify.Applications.CaseManagement Namespace


frmWizard Members

frmWizard overview

Public Instance Constructors

frmWizard Constructor Initializes a new instance of the frmWizard class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

frmWizard Class | Aptify.Applications.CaseManagement Namespace


frmWizard Constructor

Initializes a new instance of the frmWizard class.

public frmWizard();

See Also

frmWizard Class | Aptify.Applications.CaseManagement Namespace


frmWizard Methods

The methods of the frmWizard class are listed below. For a complete list of frmWizard class members, see the frmWizard Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

frmWizard Class | Aptify.Applications.CaseManagement Namespace


frmWizard.Config Method

public void Config(
AptifyApplication ApplicationObject
);

See Also

frmWizard Class | Aptify.Applications.CaseManagement Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

frmWizard.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

frmWizard Class | Aptify.Applications.CaseManagement Namespace


frmWizard.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

frmWizard Class | Aptify.Applications.CaseManagement Namespace | frmWizard.Dispose Overload List


Aptify.Applications.Chapters

Aptify 5.0 Software Development Kit (SDK)

Aptify.Applications.Chapters Namespace

The object in this namespace implements the Chapter Assignment Rules functionality for the Chapter Management add-on application.

Namespace hierarchy

Classes

Class | Description
ChapterAssignmentRules | Implements functionality to automatically determine a chapter for a given person, or order line. Supports both a type-specific interface and also the IProcessComponent interface


ChapterAssignmentRules Class

Implements functionality to automatically determine a chapter for a given person, or order line. Supports both a type-specific interface and also the IProcessComponent interface

For a list of all members of this type, see ChapterAssignmentRules Members.

System.Object
ChapterAssignmentRules

public class ChapterAssignmentRules : IProcessComponent, IChapterAssignmentRules

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Chapters

Assembly: ChapterAssignmentRules (in ChapterAssignmentRules.dll)

See Also

ChapterAssignmentRules Members | Aptify.Applications.Chapters Namespace


ChapterAssignmentRules Members

ChapterAssignmentRules overview

Public Instance Constructors

ChapterAssignmentRules Constructor Initializes a new instance of the ChapterAssignmentRules class.

Public Instance Properties

Application
DataAction
Properties

Public Instance Methods

Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetChapterAssignmentRuleDBObjectName | This method returns the Chapter Assignment Rule DBObject name(name of the stored procedure for the rule) based on the provided RuleID.
GetChapterID | Overloaded. This method returns a ChapterID (Companies.ID value from the database) that is returned based on executing the rule specified by RuleID, which is a record ID from the Chapter Assignment Rules entity.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run | Process Component Input Properties * PersonID OR CompanyID or both must be provided * ChapterAssignmentRuleID OR ChapterAssignmentRuleDBObject must be provided 1) ChapterAssignmentRuleID - Optional - Long - ID of Chapter Assignment Rule to Execute 2) ChapterAssignmentRuleDBObject - Optional - Long - DB Object Name of Chapter Assignment Rule to Execute 3) Product - Required - Long - ID of Product Record 4) PersonID - Optional - Long - ID of Person Record 5) CompanyID - Optional - Long - ID of Company Record 6) EffectiveDate - Optional - Date - defaults to current date if not provided OUTPUT PARAMATERS 1) ChapterID - Long - ID of Company Record for the Chapter to be assigned, or -1 if there is no Chapter for the inputs provided
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ChapterAssignmentRules Class | Aptify.Applications.Chapters Namespace


ChapterAssignmentRules Constructor

Initializes a new instance of the ChapterAssignmentRules class.

public ChapterAssignmentRules();

See Also

ChapterAssignmentRules Class | Aptify.Applications.Chapters Namespace


ChapterAssignmentRules Properties

The properties of the ChapterAssignmentRules class are listed below. For a complete list of ChapterAssignmentRules class members, see the ChapterAssignmentRules Members topic.

Public Instance Properties

Application
DataAction
Properties

See Also

ChapterAssignmentRules Class | Aptify.Applications.Chapters Namespace


Application Property

Aptify 5.0 Software Development Kit (SDK)

ChapterAssignmentRules.Application Property

public virtual AptifyApplication Application {get;}

Implements

IChapterAssignmentRules.

See Also

ChapterAssignmentRules Class | Aptify.Applications.Chapters Namespace


DataAction Property

Aptify 5.0 Software Development Kit (SDK)

ChapterAssignmentRules.DataAction Property

public virtual DataAction DataAction {get;}

Implements

IChapterAssignmentRules.

See Also

ChapterAssignmentRules Class | Aptify.Applications.Chapters Namespace


Properties Property

Aptify 5.0 Software Development Kit (SDK)

ChapterAssignmentRules.Properties Property

public virtual AptifyProperties Properties {get;}

Implements

IProcessComponent.

See Also

ChapterAssignmentRules Class | Aptify.Applications.Chapters Namespace


ChapterAssignmentRules Methods

The methods of the ChapterAssignmentRules class are listed below. For a complete list of ChapterAssignmentRules class members, see the ChapterAssignmentRules Members topic.

Public Instance Methods

Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetChapterAssignmentRuleDBObjectName | This method returns the Chapter Assignment Rule DBObject name(name of the stored procedure for the rule) based on the provided RuleID.
GetChapterID | Overloaded. This method returns a ChapterID (Companies.ID value from the database) that is returned based on executing the rule specified by RuleID, which is a record ID from the Chapter Assignment Rules entity.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run | Process Component Input Properties * PersonID OR CompanyID or both must be provided * ChapterAssignmentRuleID OR ChapterAssignmentRuleDBObject must be provided 1) ChapterAssignmentRuleID - Optional - Long - ID of Chapter Assignment Rule to Execute 2) ChapterAssignmentRuleDBObject - Optional - Long - DB Object Name of Chapter Assignment Rule to Execute 3) Product - Required - Long - ID of Product Record 4) PersonID - Optional - Long - ID of Person Record 5) CompanyID - Optional - Long - ID of Company Record 6) EffectiveDate - Optional - Date - defaults to current date if not provided OUTPUT PARAMATERS 1) ChapterID - Long - ID of Company Record for the Chapter to be assigned, or -1 if there is no Chapter for the inputs provided
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ChapterAssignmentRules Class | Aptify.Applications.Chapters Namespace


ChapterAssignmentRules.Config Method

public virtual void Config(
AptifyApplication ApplicationObject
);

Implements

IChapterAssignmentRules.

See Also

ChapterAssignmentRules Class | Aptify.Applications.Chapters Namespace


ChapterAssignmentRules.GetChapterAssignmentRuleDBObjectName Method

This method returns the Chapter Assignment Rule DBObject name(name of the stored procedure for the rule) based on the provided RuleID.

public virtual string GetChapterAssignmentRuleDBObjectName(
Int64 RuleID,
Boolean Refresh
);

Parameters

RuleID
Refresh
If set to True, the database cache is refreshed

Return Value

Implements

IChapterAssignmentRules.

Remarks

See Also

ChapterAssignmentRules Class | Aptify.Applications.Chapters Namespace


GetChapterID Method

Aptify 5.0 Software Development Kit (SDK)

ChapterAssignmentRules.GetChapterID Method

This method returns a ChapterID (Companies.ID value from the database) that is returned based on executing the rule specified by RuleID, which is a record ID from the Chapter Assignment Rules entity.

Overload List

This method returns a ChapterID (Companies.ID value from the database) that is returned based on executing the rule specified by RuleID, which is a record ID from the Chapter Assignment Rules entity.

public virtual long GetChapterID(Int64,Int64,Int64,Int64,DateTime);

This method returns a ChapterID (Companies.ID value from the database) that is returned based on executing the rule specified by RuleDBObjectName, which is the name of a stored procedure in the database that takes in @ProductID, @PersonID, @CompanyID, and @EffectiveDate and returns a Company ID (or -1) that maps to the Chapter to be assigned. -1 is returned if no chapter is assigned.

public virtual long GetChapterID(String,Int64,Int64,Int64,DateTime);

See Also

ChapterAssignmentRules Class | Aptify.Applications.Chapters Namespace


ChapterAssignmentRules.GetChapterID Method (Int64, Int64, Int64, Int64, DateTime)

This method returns a ChapterID (Companies.ID value from the database) that is returned based on executing the rule specified by RuleID, which is a record ID from the Chapter Assignment Rules entity.

public virtual long GetChapterID(
Int64 RuleID,
Int64 ProductID,
Int64 PersonID,
Int64 CompanyID,
DateTime EffectiveDate
);

Parameters

RuleID
ProductID
PersonID
CompanyID
EffectiveDate

Return Value

Implements

IChapterAssignmentRules.

Remarks

See Also

ChapterAssignmentRules Class | Aptify.Applications.Chapters Namespace | ChapterAssignmentRules.GetChapterID Overload List


ChapterAssignmentRules.GetChapterID Method (String, Int64, Int64, Int64, DateTime)

This method returns a ChapterID (Companies.ID value from the database) that is returned based on executing the rule specified by RuleDBObjectName, which is the name of a stored procedure in the database that takes in @ProductID, @PersonID, @CompanyID, and @EffectiveDate and returns a Company ID (or -1) that maps to the Chapter to be assigned. -1 is returned if no chapter is assigned.

public virtual long GetChapterID(
String RuleDBObjectName,
Int64 ProductID,
Int64 PersonID,
Int64 CompanyID,
DateTime EffectiveDate
);

Parameters

RuleDBObjectName
ProductID
PersonID
CompanyID
EffectiveDate

Return Value

Implements

IChapterAssignmentRules.

Remarks

See Also

ChapterAssignmentRules Class | Aptify.Applications.Chapters Namespace | ChapterAssignmentRules.GetChapterID Overload List


ChapterAssignmentRules.Run Method

Process Component Input Properties * PersonID OR CompanyID or both must be provided * ChapterAssignmentRuleID OR ChapterAssignmentRuleDBObject must be provided 1) ChapterAssignmentRuleID - Optional - Long - ID of Chapter Assignment Rule to Execute 2) ChapterAssignmentRuleDBObject - Optional - Long - DB Object Name of Chapter Assignment Rule to Execute 3) Product - Required - Long - ID of Product Record 4) PersonID - Optional - Long - ID of Person Record 5) CompanyID - Optional - Long - ID of Company Record 6) EffectiveDate - Optional - Date - defaults to current date if not provided OUTPUT PARAMATERS 1) ChapterID - Long - ID of Company Record for the Chapter to be assigned, or -1 if there is no Chapter for the inputs provided

public virtual string Run();

Return Value

SUCCESS or FAILED

Implements

IProcessComponent.

Remarks

See Also

ChapterAssignmentRules Class | Aptify.Applications.Chapters Namespace


Aptify.Applications.Commissions

Aptify 5.0 Software Development Kit (SDK)

Aptify.Applications.Commissions Namespace

The objects in this namespace implement Aptify's Commissions add-on module.

Namespace hierarchy

Classes

Class | Description
CommisionPlanEntity |
CommissionAgmtDetailLayout |
CommissionAgmtDetTierLayout |
CommissionAgreement | This class provides the implementation for business logic for the Commission Agreements entity in the Aptify Commission and Royalty Management system.
CommissionAgreementDetail | This class provides the implementation for business logic for the Commission Agreement Details entity in the Aptify Commission and Royalty Management system.
CommissionAgreementLayout |
CommissionBaseFormula | This class provides the implementation for business logic for the Commission Base Formulas entity in the Aptify Commission and Royalty Management system.
CommissionBaseFormulaViewer |
CommissioniPayDetailsEntity |
CommissionLayoutBase |
CommissionPayDetAdjustmentsLayout |
CommissionPayDetailLayout |
CommissionPayment | This class provides the implementation for business logic for the Commission Payments entity in the Aptify Commission and Royalty Management system.
CommissionPayments | Represents a strongly typed in-memory cache of data.
CommissionPayments.AdjustmentsDataTable | Represents the strongly named DataTable class.
CommissionPayments.AdjustmentsRow | Represents strongly named DataRow class.
CommissionPayments.AdjustmentsRowChangeEvent | Row event argument class
CommissionPayments.PaymentGroupsDataTable | Represents the strongly named DataTable class.
CommissionPayments.PaymentGroupsRow | Represents strongly named DataRow class.
CommissionPayments.PaymentGroupsRowChangeEvent | Row event argument class
CommissionPayments.PaymentsDataTable | Represents the strongly named DataTable class.
CommissionPayments.PaymentsRow | Represents strongly named DataRow class.
CommissionPayments.PaymentsRowChangeEvent | Row event argument class
CommissionPayments.SupplyUserCredentails |
CommissionPayments.UpdaidInvoicesDataTable | Represents the strongly named DataTable class.
CommissionPayments.UpdaidInvoicesRow | Represents strongly named DataRow class.
CommissionPayments.UpdaidInvoicesRowChangeEvent | Row event argument class
CommissionPaymentViewer |
CommissionPaymentViewer.PaymentTreeNode |
CommissionPaymentWizard |
CommissionPaymentWizardObject |
CommissionPaymentWizardObject.CommissionPaymentUpdateEventArgs |
CommissionPaySourceDetailsLayout |
CommissionPlanItemLayout |
CommissionPlanItemsEntity |
CommissionPlanLayout |
CommissionRateScale | This class provides the implementation for business logic for the Commission Rate Scales entity in the Aptify Commission and Royalty Management system.

Structures

Structure | Description
CommissionPaymentWizard.Agreements |
CommissionPaymentWizard.CommPayments |

Delegates

Delegate | Description
CommissionPayments.AdjustmentsRowChangeEventHandler |
CommissionPayments.PaymentGroupsRowChangeEventHandler |
CommissionPayments.PaymentsRowChangeEventHandler |
CommissionPayments.UpdaidInvoicesRowChangeEventHandler |
CommissionPaymentWizardObject.CommissionPaymentUpdateEventHandler |

Enumerations

Enumeration | Description
CommissionPaymentWizardObject.ProgressType |


CommisionPlanEntity Class

For a list of all members of this type, see CommisionPlanEntity Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
CommisionPlanEntity

public class CommisionPlanEntity : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Commissions

Assembly: CommissionPlanEntity (in CommissionPlanEntity.dll)

See Also

CommisionPlanEntity Members | Aptify.Applications.Commissions Namespace


CommisionPlanEntity Members

CommisionPlanEntity overview

Public Instance Constructors

CommisionPlanEntity Constructor Initializes a new instance of the CommisionPlanEntity class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

CommisionPlanEntity Class | Aptify.Applications.Commissions Namespace


CommisionPlanEntity Constructor

Initializes a new instance of the CommisionPlanEntity class.

public CommisionPlanEntity();

See Also

CommisionPlanEntity Class | Aptify.Applications.Commissions Namespace


CommisionPlanEntity Methods

The methods of the CommisionPlanEntity class are listed below. For a complete list of CommisionPlanEntity class members, see the CommisionPlanEntity Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

CommisionPlanEntity Class | Aptify.Applications.Commissions Namespace


Save Method

Aptify 5.0 Software Development Kit (SDK)

CommisionPlanEntity.Save Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Save();

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean);

public override bool Save(Boolean,ref String&);

public override bool Save(Boolean,ref String&,String);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(ref String&);

See Also

CommisionPlanEntity Class | Aptify.Applications.Commissions Namespace


CommisionPlanEntity.Save Method (Boolean, String&)

public override bool Save(
Boolean AllowGUI,
ref String& ErrorString
);

See Also

CommisionPlanEntity Class | Aptify.Applications.Commissions Namespace | CommisionPlanEntity.Save Overload List


CommisionPlanEntity.Save Method (Boolean, String&, String)

public override bool Save(
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

See Also

CommisionPlanEntity Class | Aptify.Applications.Commissions Namespace | CommisionPlanEntity.Save Overload List


CommissionAgmtDetailLayout Class

For a list of all members of this type, see CommissionAgmtDetailLayout Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
CommissionLayoutBase
CommissionAgmtDetailLayout

public class CommissionAgmtDetailLayout : CommissionLayoutBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Commissions

Assembly: CommissionAgreementControls (in CommissionAgreementControls.dll)

See Also

CommissionAgmtDetailLayout Members | Aptify.Applications.Commissions Namespace


CommissionAgmtDetailLayout Members

CommissionAgmtDetailLayout overview

Public Instance Constructors

CommissionAgmtDetailLayout Constructor Initializes a new instance of the CommissionAgmtDetailLayout class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

dlgRateScaleHandler

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AddControlEventHandler (inherited from CommissionLayoutBase) |
AdjustFormScrollbars (inherited from ContainerControl) |
ControlValueChanged |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormTemplateLayout) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindDataControl (inherited from CommissionLayoutBase) |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetControlProperty (inherited from CommissionLayoutBase) |
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded (inherited from FormTemplateLayout) | Raises the FormTemplateLoaded event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad |
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlProperty (inherited from CommissionLayoutBase) | Overloaded.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetPlanItemDisplaySQL |
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CommissionAgmtDetailLayout Class | Aptify.Applications.Commissions Namespace


CommissionAgmtDetailLayout Constructor

Initializes a new instance of the CommissionAgmtDetailLayout class.

public CommissionAgmtDetailLayout();

See Also

CommissionAgmtDetailLayout Class | Aptify.Applications.Commissions Namespace


CommissionAgmtDetailLayout Fields

The fields of the CommissionAgmtDetailLayout class are listed below. For a complete list of CommissionAgmtDetailLayout class members, see the CommissionAgmtDetailLayout Members topic.

Protected Instance Fields

dlgRateScaleHandler

See Also

CommissionAgmtDetailLayout Class | Aptify.Applications.Commissions Namespace


CommissionAgmtDetailLayout.dlgRateScaleHandler Field

protected dlgRateScaleHandler dlgRateScaleHandler;

See Also

CommissionAgmtDetailLayout Class | Aptify.Applications.Commissions Namespace


CommissionAgmtDetailLayout Methods

The methods of the CommissionAgmtDetailLayout class are listed below. For a complete list of CommissionAgmtDetailLayout class members, see the CommissionAgmtDetailLayout Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AddControlEventHandler (inherited from CommissionLayoutBase) |
AdjustFormScrollbars (inherited from ContainerControl) |
ControlValueChanged |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormTemplateLayout) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindDataControl (inherited from CommissionLayoutBase) |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetControlProperty (inherited from CommissionLayoutBase) |
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded (inherited from FormTemplateLayout) | Raises the FormTemplateLoaded event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad |
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlProperty (inherited from CommissionLayoutBase) | Overloaded.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetPlanItemDisplaySQL |
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CommissionAgmtDetailLayout Class | Aptify.Applications.Commissions Namespace


CommissionAgmtDetailLayout.ControlValueChanged Method

protected virtual void ControlValueChanged(
Object sender,
Object OldValue,
Object NewValue
);

See Also

CommissionAgmtDetailLayout Class | Aptify.Applications.Commissions Namespace


CommissionAgmtDetailLayout.OnLoad Method

protected override void OnLoad(
EventArgs e
);

See Also

CommissionAgmtDetailLayout Class | Aptify.Applications.Commissions Namespace


CommissionAgmtDetailLayout.OnRefresh Method

protected override void OnRefresh();

Implements

IFormComponent.

See Also

CommissionAgmtDetailLayout Class | Aptify.Applications.Commissions Namespace


CommissionAgmtDetailLayout.SetPlanItemDisplaySQL Method

protected virtual void SetPlanItemDisplaySQL();

See Also

CommissionAgmtDetailLayout Class | Aptify.Applications.Commissions Namespace


CommissionAgmtDetTierLayout Class

For a list of all members of this type, see CommissionAgmtDetTierLayout Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
CommissionLayoutBase
CommissionAgmtDetTierLayout

public class CommissionAgmtDetTierLayout : CommissionLayoutBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Commissions

Assembly: CommissionAgreementControls (in CommissionAgreementControls.dll)

See Also

CommissionAgmtDetTierLayout Members | Aptify.Applications.Commissions Namespace


CommissionAgmtDetTierLayout Members

CommissionAgmtDetTierLayout overview

Public Instance Constructors

CommissionAgmtDetTierLayout Constructor Initializes a new instance of the CommissionAgmtDetTierLayout class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

dlgOverrideRangeHandler
dlgOverrideRateHandler

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AddControlEventHandler (inherited from CommissionLayoutBase) |
AdjustFormScrollbars (inherited from ContainerControl) |
ControlValueChanged |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormTemplateLayout) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindDataControl (inherited from CommissionLayoutBase) |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetControlProperty (inherited from CommissionLayoutBase) |
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded (inherited from FormTemplateLayout) | Raises the FormTemplateLoaded event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad |
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlDisplay |
SetControlProperty (inherited from CommissionLayoutBase) | Overloaded.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CommissionAgmtDetTierLayout Class | Aptify.Applications.Commissions Namespace


CommissionAgmtDetTierLayout Constructor

Initializes a new instance of the CommissionAgmtDetTierLayout class.

public CommissionAgmtDetTierLayout();

See Also

CommissionAgmtDetTierLayout Class | Aptify.Applications.Commissions Namespace


CommissionAgmtDetTierLayout Fields

The fields of the CommissionAgmtDetTierLayout class are listed below. For a complete list of CommissionAgmtDetTierLayout class members, see the CommissionAgmtDetTierLayout Members topic.

Protected Instance Fields

dlgOverrideRangeHandler
dlgOverrideRateHandler

See Also

CommissionAgmtDetTierLayout Class | Aptify.Applications.Commissions Namespace


CommissionAgmtDetTierLayout.dlgOverrideRangeHandler Field

protected dlgOverrideRangeHandler dlgOverrideRangeHandler;

See Also

CommissionAgmtDetTierLayout Class | Aptify.Applications.Commissions Namespace


CommissionAgmtDetTierLayout.dlgOverrideRateHandler Field

protected dlgOverrideRateHandler dlgOverrideRateHandler;

See Also

CommissionAgmtDetTierLayout Class | Aptify.Applications.Commissions Namespace


CommissionAgmtDetTierLayout Methods

The methods of the CommissionAgmtDetTierLayout class are listed below. For a complete list of CommissionAgmtDetTierLayout class members, see the CommissionAgmtDetTierLayout Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AddControlEventHandler (inherited from CommissionLayoutBase) |
AdjustFormScrollbars (inherited from ContainerControl) |
ControlValueChanged |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormTemplateLayout) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindDataControl (inherited from CommissionLayoutBase) |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetControlProperty (inherited from CommissionLayoutBase) |
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded (inherited from FormTemplateLayout) | Raises the FormTemplateLoaded event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad |
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlDisplay |
SetControlProperty (inherited from CommissionLayoutBase) | Overloaded.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CommissionAgmtDetTierLayout Class | Aptify.Applications.Commissions Namespace


CommissionAgmtDetTierLayout.ControlValueChanged Method

protected virtual void ControlValueChanged(
Object sender,
Object OldValue,
Object NewValue
);

See Also

CommissionAgmtDetTierLayout Class | Aptify.Applications.Commissions Namespace


CommissionAgmtDetTierLayout.OnLoad Method

protected override void OnLoad(
EventArgs e
);

See Also

CommissionAgmtDetTierLayout Class | Aptify.Applications.Commissions Namespace


CommissionAgmtDetTierLayout.OnRefresh Method

protected override void OnRefresh();

Implements

IFormComponent.

See Also

CommissionAgmtDetTierLayout Class | Aptify.Applications.Commissions Namespace


CommissionAgmtDetTierLayout.SetControlDisplay Method

protected virtual void SetControlDisplay();

See Also

CommissionAgmtDetTierLayout Class | Aptify.Applications.Commissions Namespace


CommissionAgreement Class

This class provides the implementation for business logic for the Commission Agreements entity in the Aptify Commission and Royalty Management system.

For a list of all members of this type, see CommissionAgreement Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
CommissionAgreement

public class CommissionAgreement : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Commissions

Assembly: CommissionAgreement (in CommissionAgreement.dll)

See Also

CommissionAgreement Members | Aptify.Applications.Commissions Namespace


CommissionAgreement Members

CommissionAgreement overview

Public Instance Constructors

CommissionAgreement Constructor Initializes a new instance of the CommissionAgreement class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config | Overloaded.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
Database |
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
CheckSubTypeDuplicates | This method determines if a given sub-type has any duplicate records in it. The method utilizes the provides SubTypeName and CompareField parameters to scan the given sub-type and determine if duplicates exist in the field provided by the CompareField parameter.
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
IsAgreementDetailScaleRangeOK | This method determines if the Agreement's Details Sub-Type Scale Range is validated or not by calling the IsTierRangeOK() method for each item in the CommissionAgreementDetails sub-type.
IsTierRangeOk | This method checks to make sure that the tiers within a given Commission Agrement sub-type item have valid rate scales by calling the ValidateRateScaleDetail() method for each item in the CommissionAgmtDetTiers sub-type.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateAgreement | This method is called from Validate() and handles validation of the Commission Agreement.
ValidateRateScaleDetail | This method validates an individual item within the Commission Agreement Detail Tiers sub-type to ensure that it is setup properly. The method returns true if validation is a success, and returns False otherwise with details regarding the validation failure in the ErrorString parameter.
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

CommissionAgreement Class | Aptify.Applications.Commissions Namespace


CommissionAgreement Constructor

Initializes a new instance of the CommissionAgreement class.

public CommissionAgreement();

See Also

CommissionAgreement Class | Aptify.Applications.Commissions Namespace


CommissionAgreement Properties

The properties of the CommissionAgreement class are listed below. For a complete list of CommissionAgreement class members, see the CommissionAgreement Members topic.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
Database |
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

CommissionAgreement Class | Aptify.Applications.Commissions Namespace


Database Property

Aptify 5.0 Software Development Kit (SDK)

CommissionAgreement.Database Property

protected virtual String Database {get;}

See Also

CommissionAgreement Class | Aptify.Applications.Commissions Namespace


CommissionAgreement Methods

The methods of the CommissionAgreement class are listed below. For a complete list of CommissionAgreement class members, see the CommissionAgreement Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config | Overloaded.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
CheckSubTypeDuplicates | This method determines if a given sub-type has any duplicate records in it. The method utilizes the provides SubTypeName and CompareField parameters to scan the given sub-type and determine if duplicates exist in the field provided by the CompareField parameter.
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
IsAgreementDetailScaleRangeOK | This method determines if the Agreement's Details Sub-Type Scale Range is validated or not by calling the IsTierRangeOK() method for each item in the CommissionAgreementDetails sub-type.
IsTierRangeOk | This method checks to make sure that the tiers within a given Commission Agrement sub-type item have valid rate scales by calling the ValidateRateScaleDetail() method for each item in the CommissionAgmtDetTiers sub-type.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateAgreement | This method is called from Validate() and handles validation of the Commission Agreement.
ValidateRateScaleDetail | This method validates an individual item within the Commission Agreement Detail Tiers sub-type to ensure that it is setup properly. The method returns true if validation is a success, and returns False otherwise with details regarding the validation failure in the ErrorString parameter.
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

CommissionAgreement Class | Aptify.Applications.Commissions Namespace


CommissionAgreement.CheckSubTypeDuplicates Method

This method determines if a given sub-type has any duplicate records in it. The method utilizes the provides SubTypeName and CompareField parameters to scan the given sub-type and determine if duplicates exist in the field provided by the CompareField parameter.

protected virtual bool CheckSubTypeDuplicates(
String SubTypeName,
String CompareField,
ref String& DupeList
);

Parameters

SubTypeName
CompareField
DupeList
This optional OUT parameter returns a comma-delimited list of duplicate sequence values in the sub-type, if any are found

Return Value

Remarks

See Also

CommissionAgreement Class | Aptify.Applications.Commissions Namespace


Config Method

Aptify 5.0 Software Development Kit (SDK)

CommissionAgreement.Config Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual void Config(AptifySubTypeBase);

Inherited from AptifyGenericEntity.

public override void Config(AptifySubTypeBase,Int64);

Inherited from AptifyGenericEntityBase.

public virtual void Config(UserCredentials,String);

public override void Config(UserCredentials,String,Int64);

See Also

CommissionAgreement Class | Aptify.Applications.Commissions Namespace


CommissionAgreement.Config Method (UserCredentials, String, Int64)

public override void Config(
UserCredentials UserCredentials,
String EntityName,
Int64 RecordID
);

See Also

CommissionAgreement Class | Aptify.Applications.Commissions Namespace | CommissionAgreement.Config Overload List


CommissionAgreement.IsAgreementDetailScaleRangeOK Method

This method determines if the Agreement's Details Sub-Type Scale Range is validated or not by calling the IsTierRangeOK() method for each item in the CommissionAgreementDetails sub-type.

protected virtual bool IsAgreementDetailScaleRangeOK(
ref String& ErrorString
);

Parameters

ErrorString

Return Value

Remarks

See Also

CommissionAgreement Class | Aptify.Applications.Commissions Namespace


CommissionAgreement.IsTierRangeOk Method

This method checks to make sure that the tiers within a given Commission Agrement sub-type item have valid rate scales by calling the ValidateRateScaleDetail() method for each item in the CommissionAgmtDetTiers sub-type.

protected virtual bool IsTierRangeOk(
AptifyGenericEntityBase AgreementDetailGE,
ref String& ErrorString
);

Parameters

AgreementDetailGE
ErrorString

Return Value

Remarks

See Also

CommissionAgreement Class | Aptify.Applications.Commissions Namespace


Validate Method

Aptify 5.0 Software Development Kit (SDK)

CommissionAgreement.Validate Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Validate();

public override bool Validate(ref String&);

See Also

CommissionAgreement Class | Aptify.Applications.Commissions Namespace


CommissionAgreement.Validate Method (String&)

public override bool Validate(
ref String& ErrorString
);

See Also

CommissionAgreement Class | Aptify.Applications.Commissions Namespace | CommissionAgreement.Validate Overload List


CommissionAgreement.ValidateAgreement Method

This method is called from Validate() and handles validation of the Commission Agreement.

protected virtual string ValidateAgreement();

Return Value

Remarks

See Also

CommissionAgreement Class | Aptify.Applications.Commissions Namespace


CommissionAgreement.ValidateRateScaleDetail Method

This method validates an individual item within the Commission Agreement Detail Tiers sub-type to ensure that it is setup properly. The method returns true if validation is a success, and returns False otherwise with details regarding the validation failure in the ErrorString parameter.

protected virtual bool ValidateRateScaleDetail(
AptifyGenericEntityBase TierItemGE,
Boolean IsLastItem,
ref String& ErrorString,
Boolean DelegateRestToGE
);

Parameters

TierItemGE
IsLastItem
ErrorString
DelegateRestToGE

Return Value

Remarks

See Also

CommissionAgreement Class | Aptify.Applications.Commissions Namespace


CommissionAgreementDetail Class

This class provides the implementation for business logic for the Commission Agreement Details entity in the Aptify Commission and Royalty Management system.

For a list of all members of this type, see CommissionAgreementDetail Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
CommissionAgreementDetail

public class CommissionAgreementDetail : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Commissions

Assembly: CommissionAgreement (in CommissionAgreement.dll)

See Also

CommissionAgreementDetail Members | Aptify.Applications.Commissions Namespace


CommissionAgreementDetail Members

CommissionAgreementDetail overview

Public Instance Constructors

CommissionAgreementDetail Constructor Initializes a new instance of the CommissionAgreementDetail class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue |
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTiersFromRateScale |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateRateScaleItems | This method will validate the Rate Scale Items using the CommissionRateScale object's equivalently named method.
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

CommissionAgreementDetail Class | Aptify.Applications.Commissions Namespace


CommissionAgreementDetail Constructor

Initializes a new instance of the CommissionAgreementDetail class.

public CommissionAgreementDetail();

See Also

CommissionAgreementDetail Class | Aptify.Applications.Commissions Namespace


CommissionAgreementDetail Methods

The methods of the CommissionAgreementDetail class are listed below. For a complete list of CommissionAgreementDetail class members, see the CommissionAgreementDetail Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue |
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTiersFromRateScale |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateRateScaleItems | This method will validate the Rate Scale Items using the CommissionRateScale object's equivalently named method.
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

CommissionAgreementDetail Class | Aptify.Applications.Commissions Namespace


CommissionAgreementDetail.CreateTiersFromRateScale Method

protected virtual bool CreateTiersFromRateScale(
Int64 lRateScaleID
);

See Also

CommissionAgreementDetail Class | Aptify.Applications.Commissions Namespace


CommissionAgreementDetail.SetValue Method

public override void SetValue(
String FieldName,
Object Value
);

See Also

CommissionAgreementDetail Class | Aptify.Applications.Commissions Namespace


Validate Method

Aptify 5.0 Software Development Kit (SDK)

CommissionAgreementDetail.Validate Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Validate();

public override bool Validate(ref String&);

See Also

CommissionAgreementDetail Class | Aptify.Applications.Commissions Namespace


CommissionAgreementDetail.Validate Method (String&)

public override bool Validate(
ref String& ErrorString
);

See Also

CommissionAgreementDetail Class | Aptify.Applications.Commissions Namespace | CommissionAgreementDetail.Validate Overload List


CommissionAgreementDetail.ValidateRateScaleItems Method

This method will validate the Rate Scale Items using the CommissionRateScale object's equivalently named method.

protected virtual bool ValidateRateScaleItems(
ref String& ErrorString
);

Parameters

ErrorString

Return Value

Remarks

See Also

CommissionAgreementDetail Class | Aptify.Applications.Commissions Namespace


CommissionAgreementLayout Class

For a list of all members of this type, see CommissionAgreementLayout Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
CommissionLayoutBase
CommissionAgreementLayout

public class CommissionAgreementLayout : CommissionLayoutBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Commissions

Assembly: CommissionAgreementControls (in CommissionAgreementControls.dll)

See Also

CommissionAgreementLayout Members | Aptify.Applications.Commissions Namespace


CommissionAgreementLayout Members

CommissionAgreementLayout overview

Public Instance Constructors

CommissionAgreementLayout Constructor Initializes a new instance of the CommissionAgreementLayout class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

dlgPlanIDChangedHandler
dlgSalesPersonTypeChangedHandler
dlgStatusChangedHandler

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AddControlEventHandler (inherited from CommissionLayoutBase) |
AdjustFormScrollbars (inherited from ContainerControl) |
ConfigureDisplay |
ControlValueChanged |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormTemplateLayout) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindDataControl (inherited from CommissionLayoutBase) |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetControlProperty (inherited from CommissionLayoutBase) |
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded (inherited from FormTemplateLayout) | Raises the FormTemplateLoaded event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad |
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlProperty (inherited from CommissionLayoutBase) | Overloaded.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetSalesPersonType |
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CommissionAgreementLayout Class | Aptify.Applications.Commissions Namespace


CommissionAgreementLayout Constructor

Initializes a new instance of the CommissionAgreementLayout class.

public CommissionAgreementLayout();

See Also

CommissionAgreementLayout Class | Aptify.Applications.Commissions Namespace


CommissionAgreementLayout Fields

The fields of the CommissionAgreementLayout class are listed below. For a complete list of CommissionAgreementLayout class members, see the CommissionAgreementLayout Members topic.

Protected Instance Fields

dlgPlanIDChangedHandler
dlgSalesPersonTypeChangedHandler
dlgStatusChangedHandler

See Also

CommissionAgreementLayout Class | Aptify.Applications.Commissions Namespace


CommissionAgreementLayout.dlgPlanIDChangedHandler Field

protected dlgPlanIDChangedHandler dlgPlanIDChangedHandler;

See Also

CommissionAgreementLayout Class | Aptify.Applications.Commissions Namespace


CommissionAgreementLayout.dlgSalesPersonTypeChangedHandler Field

protected dlgSalesPersonTypeChangedHandler dlgSalesPersonTypeChangedHandler;

See Also

CommissionAgreementLayout Class | Aptify.Applications.Commissions Namespace


CommissionAgreementLayout.dlgStatusChangedHandler Field

protected dlgStatusChangedHandler dlgStatusChangedHandler;

See Also

CommissionAgreementLayout Class | Aptify.Applications.Commissions Namespace


CommissionAgreementLayout Methods

The methods of the CommissionAgreementLayout class are listed below. For a complete list of CommissionAgreementLayout class members, see the CommissionAgreementLayout Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AddControlEventHandler (inherited from CommissionLayoutBase) |
AdjustFormScrollbars (inherited from ContainerControl) |
ConfigureDisplay |
ControlValueChanged |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormTemplateLayout) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindDataControl (inherited from CommissionLayoutBase) |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetControlProperty (inherited from CommissionLayoutBase) |
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded (inherited from FormTemplateLayout) | Raises the FormTemplateLoaded event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad |
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlProperty (inherited from CommissionLayoutBase) | Overloaded.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetSalesPersonType |
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CommissionAgreementLayout Class | Aptify.Applications.Commissions Namespace


CommissionAgreementLayout.ConfigureDisplay Method

protected virtual void ConfigureDisplay();

See Also

CommissionAgreementLayout Class | Aptify.Applications.Commissions Namespace


CommissionAgreementLayout.ControlValueChanged Method

protected virtual void ControlValueChanged(
Object sender,
Object OldValue,
Object NewValue
);

See Also

CommissionAgreementLayout Class | Aptify.Applications.Commissions Namespace


CommissionAgreementLayout.OnLoad Method

protected override void OnLoad(
EventArgs e
);

See Also

CommissionAgreementLayout Class | Aptify.Applications.Commissions Namespace


CommissionAgreementLayout.OnRefresh Method

protected override void OnRefresh();

Implements

IFormComponent.

See Also

CommissionAgreementLayout Class | Aptify.Applications.Commissions Namespace


CommissionAgreementLayout.SetSalesPersonType Method

protected virtual void SetSalesPersonType();

See Also

CommissionAgreementLayout Class | Aptify.Applications.Commissions Namespace


CommissionBaseFormula Class

This class provides the implementation for business logic for the Commission Base Formulas entity in the Aptify Commission and Royalty Management system.

For a list of all members of this type, see CommissionBaseFormula Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
CommissionBaseFormula

public class CommissionBaseFormula : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Commissions

Assembly: CommissionBaseFormula (in CommissionBaseFormula.dll)

See Also

CommissionBaseFormula Members | Aptify.Applications.Commissions Namespace


CommissionBaseFormula Members

CommissionBaseFormula overview

Public Instance Constructors

CommissionBaseFormula Constructor Initializes a new instance of the CommissionBaseFormula class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config | Overloaded.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
Database |
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
GetCommissionSourceView | This method returns the SQL View name that is associated with the specified Commission Source ID. This method returns the SourceView field from the Commission Sources entity for the record matching the provided Commission Source parameter. This method uses the Aptify DSL Cache by default, unless the CacheSetting parameter is provided with another setting
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
InternalValidate | This method is responsible for the internal validation of the Commission Base Formula entity and checks to make sure the Formula has a valid syntax. In addition, Internal Validate() checks to make sure that the Commission Source selected for the Base Formula is Active.
IsCommissionSourceActive | This method determines if the specified Commission Source record has a status of Active or not. If the status is set to Active, then this method will return True, otherwise, this method will return False.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
RequiredSubTypesExist | This method checks if there are records in the specified sub-type name. If there are records in the specified sub-type name, then the return value will be True, otherwise, the return value will be False.
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateCommissionSourceIsActive | This method checks to see if the commission source is an active commission source by calling the IsCommissionSourceActive() method. This method only checks the commission source active status for situations where the CommissionSourceID is positive and has either changed or in the event of a new record being created.
ValidateFormula | This method is responsible for validating the provided formula and returning an optional error message through the ErrorMessage string, if the formula is not valid.
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

CommissionBaseFormula Class | Aptify.Applications.Commissions Namespace


CommissionBaseFormula Constructor

Initializes a new instance of the CommissionBaseFormula class.

public CommissionBaseFormula();

See Also

CommissionBaseFormula Class | Aptify.Applications.Commissions Namespace


CommissionBaseFormula Properties

The properties of the CommissionBaseFormula class are listed below. For a complete list of CommissionBaseFormula class members, see the CommissionBaseFormula Members topic.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
Database |
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

CommissionBaseFormula Class | Aptify.Applications.Commissions Namespace


Database Property

Aptify 5.0 Software Development Kit (SDK)

CommissionBaseFormula.Database Property

protected virtual String Database {get;}

See Also

CommissionBaseFormula Class | Aptify.Applications.Commissions Namespace


CommissionBaseFormula Methods

The methods of the CommissionBaseFormula class are listed below. For a complete list of CommissionBaseFormula class members, see the CommissionBaseFormula Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config | Overloaded.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
GetCommissionSourceView | This method returns the SQL View name that is associated with the specified Commission Source ID. This method returns the SourceView field from the Commission Sources entity for the record matching the provided Commission Source parameter. This method uses the Aptify DSL Cache by default, unless the CacheSetting parameter is provided with another setting
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
InternalValidate | This method is responsible for the internal validation of the Commission Base Formula entity and checks to make sure the Formula has a valid syntax. In addition, Internal Validate() checks to make sure that the Commission Source selected for the Base Formula is Active.
IsCommissionSourceActive | This method determines if the specified Commission Source record has a status of Active or not. If the status is set to Active, then this method will return True, otherwise, this method will return False.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
RequiredSubTypesExist | This method checks if there are records in the specified sub-type name. If there are records in the specified sub-type name, then the return value will be True, otherwise, the return value will be False.
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateCommissionSourceIsActive | This method checks to see if the commission source is an active commission source by calling the IsCommissionSourceActive() method. This method only checks the commission source active status for situations where the CommissionSourceID is positive and has either changed or in the event of a new record being created.
ValidateFormula | This method is responsible for validating the provided formula and returning an optional error message through the ErrorMessage string, if the formula is not valid.
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

CommissionBaseFormula Class | Aptify.Applications.Commissions Namespace


Config Method

Aptify 5.0 Software Development Kit (SDK)

CommissionBaseFormula.Config Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual void Config(AptifySubTypeBase);

Inherited from AptifyGenericEntity.

public override void Config(AptifySubTypeBase,Int64);

Inherited from AptifyGenericEntityBase.

public virtual void Config(UserCredentials,String);

public override void Config(UserCredentials,String,Int64);

See Also

CommissionBaseFormula Class | Aptify.Applications.Commissions Namespace


CommissionBaseFormula.Config Method (UserCredentials, String, Int64)

public override void Config(
UserCredentials UserCredentials,
String EntityName,
Int64 RecordID
);

See Also

CommissionBaseFormula Class | Aptify.Applications.Commissions Namespace | CommissionBaseFormula.Config Overload List


CommissionBaseFormula.GetCommissionSourceView Method

This method returns the SQL View name that is associated with the specified Commission Source ID. This method returns the SourceView field from the Commission Sources entity for the record matching the provided Commission Source parameter. This method uses the Aptify DSL Cache by default, unless the CacheSetting parameter is provided with another setting

protected virtual string GetCommissionSourceView(
Int64 CommissionSourceID,
IAptifyDataAction.DSLCacheSetting CacheSetting
);

Parameters

CommissionSourceID
CacheSetting

Return Value

Remarks

See Also

CommissionBaseFormula Class | Aptify.Applications.Commissions Namespace


CommissionBaseFormula.InternalValidate Method

This method is responsible for the internal validation of the Commission Base Formula entity and checks to make sure the Formula has a valid syntax. In addition, Internal Validate() checks to make sure that the Commission Source selected for the Base Formula is Active.

protected virtual string InternalValidate(
ref String& ErrorMessage
);

Parameters

ErrorMessage

Return Value

Remarks

See Also

CommissionBaseFormula Class | Aptify.Applications.Commissions Namespace


CommissionBaseFormula.IsCommissionSourceActive Method

This method determines if the specified Commission Source record has a status of Active or not. If the status is set to Active, then this method will return True, otherwise, this method will return False.

protected virtual bool IsCommissionSourceActive(
Int64 CommissionSourceID
);

Parameters

CommissionSourceID

Return Value

Remarks

See Also

CommissionBaseFormula Class | Aptify.Applications.Commissions Namespace


CommissionBaseFormula.RequiredSubTypesExist Method

This method checks if there are records in the specified sub-type name. If there are records in the specified sub-type name, then the return value will be True, otherwise, the return value will be False.

protected virtual bool RequiredSubTypesExist(
String SubTypeName
);

Parameters

SubTypeName

Return Value

Remarks

See Also

CommissionBaseFormula Class | Aptify.Applications.Commissions Namespace


Validate Method

Aptify 5.0 Software Development Kit (SDK)

CommissionBaseFormula.Validate Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Validate();

public override bool Validate(ref String&);

See Also

CommissionBaseFormula Class | Aptify.Applications.Commissions Namespace


CommissionBaseFormula.Validate Method (String&)

public override bool Validate(
ref String& ErrorString
);

See Also

CommissionBaseFormula Class | Aptify.Applications.Commissions Namespace | CommissionBaseFormula.Validate Overload List


CommissionBaseFormula.ValidateCommissionSourceIsActive Method

This method checks to see if the commission source is an active commission source by calling the IsCommissionSourceActive() method. This method only checks the commission source active status for situations where the CommissionSourceID is positive and has either changed or in the event of a new record being created.

protected virtual bool ValidateCommissionSourceIsActive();

Return Value

Remarks

See Also

CommissionBaseFormula Class | Aptify.Applications.Commissions Namespace


CommissionBaseFormula.ValidateFormula Method

This method is responsible for validating the provided formula and returning an optional error message through the ErrorMessage string, if the formula is not valid.

protected virtual bool ValidateFormula(
String FormulaText,
String AggregateFunction,
String SourceTriggerDateField,
String CommissionSourceView,
ref String& ErrorString
);

Parameters

FormulaText
The user-provided Formula Text to use for calculation
AggregateFunction
SourceTriggerDateField
The name of the field provided by the user that is used to trigger commission calculations
CommissionSourceView
The base view in SQL for the Commission Source
ErrorString
Optional OUT Parameter: returns an error message if the method fails

Return Value

Remarks

See Also

CommissionBaseFormula Class | Aptify.Applications.Commissions Namespace


CommissionBaseFormulaViewer Class

For a list of all members of this type, see CommissionBaseFormulaViewer Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
CommissionBaseFormulaViewer

public class CommissionBaseFormulaViewer : Form, IAptifyTopLevelViewer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Commissions

Assembly: CommissionBaseFormulaViewer (in CommissionBaseFormulaViewer.dll)

See Also

CommissionBaseFormulaViewer Members | Aptify.Applications.Commissions Namespace


CommissionBaseFormulaViewer Members

CommissionBaseFormulaViewer overview

Public Instance Constructors

CommissionBaseFormulaViewer Constructor Initializes a new instance of the CommissionBaseFormulaViewer class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config | Overloaded.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
Show1 | Overloaded.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
ShowDialog1 | Overloaded.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

m_arFormula
m_oApp
m_oUserCredentials
mdtSourceView
msFormulaDelimited

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
m_oGE |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
ConfigureDisplay |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
DisableControls |
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InsertNumber |
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CommissionBaseFormulaViewer Class | Aptify.Applications.Commissions Namespace


CommissionBaseFormulaViewer Constructor

Initializes a new instance of the CommissionBaseFormulaViewer class.

public CommissionBaseFormulaViewer();

See Also

CommissionBaseFormulaViewer Class | Aptify.Applications.Commissions Namespace


CommissionBaseFormulaViewer Fields

The fields of the CommissionBaseFormulaViewer class are listed below. For a complete list of CommissionBaseFormulaViewer class members, see the CommissionBaseFormulaViewer Members topic.

Protected Instance Fields

m_arFormula
m_oApp
m_oUserCredentials
mdtSourceView
msFormulaDelimited

See Also

CommissionBaseFormulaViewer Class | Aptify.Applications.Commissions Namespace


CommissionBaseFormulaViewer.m_arFormula Field

protected m_arFormula m_arFormula;

See Also

CommissionBaseFormulaViewer Class | Aptify.Applications.Commissions Namespace


CommissionBaseFormulaViewer.m_oApp Field

protected m_oApp m_oApp;

See Also

CommissionBaseFormulaViewer Class | Aptify.Applications.Commissions Namespace


CommissionBaseFormulaViewer.m_oUserCredentials Field

protected m_oUserCredentials m_oUserCredentials;

See Also

CommissionBaseFormulaViewer Class | Aptify.Applications.Commissions Namespace


CommissionBaseFormulaViewer.mdtSourceView Field

protected mdtSourceView mdtSourceView;

See Also

CommissionBaseFormulaViewer Class | Aptify.Applications.Commissions Namespace


CommissionBaseFormulaViewer.msFormulaDelimited Field

protected msFormulaDelimited msFormulaDelimited;

See Also

CommissionBaseFormulaViewer Class | Aptify.Applications.Commissions Namespace


CommissionBaseFormulaViewer Properties

The properties of the CommissionBaseFormulaViewer class are listed below. For a complete list of CommissionBaseFormulaViewer class members, see the CommissionBaseFormulaViewer Members topic.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
m_oGE |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

CommissionBaseFormulaViewer Class | Aptify.Applications.Commissions Namespace


m_oGE Property

Aptify 5.0 Software Development Kit (SDK)

CommissionBaseFormulaViewer.m_oGE Property

protected virtual AptifyGenericEntityBase m_oGE {get; set;}

See Also

CommissionBaseFormulaViewer Class | Aptify.Applications.Commissions Namespace


CommissionBaseFormulaViewer Methods

The methods of the CommissionBaseFormulaViewer class are listed below. For a complete list of CommissionBaseFormulaViewer class members, see the CommissionBaseFormulaViewer Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config | Overloaded.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
Show1 | Overloaded.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
ShowDialog1 | Overloaded.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
ConfigureDisplay |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
DisableControls |
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InsertNumber |
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CommissionBaseFormulaViewer Class | Aptify.Applications.Commissions Namespace


CommissionBaseFormulaViewer.ApplySkin Method

protected virtual void ApplySkin();

See Also

CommissionBaseFormulaViewer Class | Aptify.Applications.Commissions Namespace


Config Method

Aptify 5.0 Software Development Kit (SDK)

CommissionBaseFormulaViewer.Config Method

Overload List

public void Config(AptifyGenericEntityBase);

public void Config(UserCredentials,String);

public void Config(UserCredentials,String,Int64);

public void Config(UserCredentials,String,String);

See Also

CommissionBaseFormulaViewer Class | Aptify.Applications.Commissions Namespace


CommissionBaseFormulaViewer.Config Method (AptifyGenericEntityBase)

public void Config(
AptifyGenericEntityBase GE
);

Implements

IAptifyTopLevelViewer.

See Also

CommissionBaseFormulaViewer Class | Aptify.Applications.Commissions Namespace | CommissionBaseFormulaViewer.Config Overload List


CommissionBaseFormulaViewer.Config Method (UserCredentials, String)

public void Config(
UserCredentials UserCredentials,
String CmdString
);

Implements

IAptifyTopLevelViewer.

See Also

CommissionBaseFormulaViewer Class | Aptify.Applications.Commissions Namespace | CommissionBaseFormulaViewer.Config Overload List


CommissionBaseFormulaViewer.Config Method (UserCredentials, String, Int64)

public void Config(
UserCredentials UserCredentials,
String EntityName,
Int64 RecordID
);

Implements

IAptifyTopLevelViewer.

See Also

CommissionBaseFormulaViewer Class | Aptify.Applications.Commissions Namespace | CommissionBaseFormulaViewer.Config Overload List


CommissionBaseFormulaViewer.Config Method (UserCredentials, String, String)

public void Config(
UserCredentials UserCredentials,
String EntityName,
String NewRecordParameters
);

Implements

IAptifyTopLevelViewer.

See Also

CommissionBaseFormulaViewer Class | Aptify.Applications.Commissions Namespace | CommissionBaseFormulaViewer.Config Overload List


CommissionBaseFormulaViewer.ConfigureDisplay Method

protected virtual void ConfigureDisplay();

See Also

CommissionBaseFormulaViewer Class | Aptify.Applications.Commissions Namespace


CommissionBaseFormulaViewer.DisableControls Method

protected virtual void DisableControls(
Boolean bEnable
);

See Also

CommissionBaseFormulaViewer Class | Aptify.Applications.Commissions Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

CommissionBaseFormulaViewer.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

CommissionBaseFormulaViewer Class | Aptify.Applications.Commissions Namespace


CommissionBaseFormulaViewer.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

CommissionBaseFormulaViewer Class | Aptify.Applications.Commissions Namespace | CommissionBaseFormulaViewer.Dispose Overload List


CommissionBaseFormulaViewer.InsertNumber Method

protected void InsertNumber();

See Also

CommissionBaseFormulaViewer Class | Aptify.Applications.Commissions Namespace


Show1 Method

Aptify 5.0 Software Development Kit (SDK)

CommissionBaseFormulaViewer.Show1 Method

Overload List

public void Show1();

public void Show1(Form);

See Also

CommissionBaseFormulaViewer Class | Aptify.Applications.Commissions Namespace


CommissionBaseFormulaViewer.Show1 Method ()

public void Show1();

Implements

IAptifyTopLevelViewer.

See Also

CommissionBaseFormulaViewer Class | Aptify.Applications.Commissions Namespace | CommissionBaseFormulaViewer.Show1 Overload List


CommissionBaseFormulaViewer.Show1 Method (Form)

public void Show1(
Form ParentForm
);

Implements

IAptifyTopLevelViewer.

See Also

CommissionBaseFormulaViewer Class | Aptify.Applications.Commissions Namespace | CommissionBaseFormulaViewer.Show1 Overload List


ShowDialog1 Method

Aptify 5.0 Software Development Kit (SDK)

CommissionBaseFormulaViewer.ShowDialog1 Method

Overload List

public DialogResult ShowDialog1();

public DialogResult ShowDialog1(Form);

See Also

CommissionBaseFormulaViewer Class | Aptify.Applications.Commissions Namespace


CommissionBaseFormulaViewer.ShowDialog1 Method ()

public DialogResult ShowDialog1();

Implements

IAptifyTopLevelViewer.

See Also

CommissionBaseFormulaViewer Class | Aptify.Applications.Commissions Namespace | CommissionBaseFormulaViewer.ShowDialog1 Overload List


CommissionBaseFormulaViewer.ShowDialog1 Method (Form)

public DialogResult ShowDialog1(
Form ParentForm
);

Implements

IAptifyTopLevelViewer.

See Also

CommissionBaseFormulaViewer Class | Aptify.Applications.Commissions Namespace | CommissionBaseFormulaViewer.ShowDialog1 Overload List


CommissioniPayDetailsEntity Class

For a list of all members of this type, see CommissioniPayDetailsEntity Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
CommissioniPayDetailsEntity

public class CommissioniPayDetailsEntity : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Commissions

Assembly: CommissionPayment (in CommissionPayment.dll)

See Also

CommissioniPayDetailsEntity Members | Aptify.Applications.Commissions Namespace


CommissioniPayDetailsEntity Members

CommissioniPayDetailsEntity overview

Public Instance Constructors

CommissioniPayDetailsEntity Constructor Initializes a new instance of the CommissioniPayDetailsEntity class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

CommissioniPayDetailsEntity Class | Aptify.Applications.Commissions Namespace


CommissioniPayDetailsEntity Constructor

Initializes a new instance of the CommissioniPayDetailsEntity class.

public CommissioniPayDetailsEntity();

See Also

CommissioniPayDetailsEntity Class | Aptify.Applications.Commissions Namespace


CommissioniPayDetailsEntity Methods

The methods of the CommissioniPayDetailsEntity class are listed below. For a complete list of CommissioniPayDetailsEntity class members, see the CommissioniPayDetailsEntity Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

CommissioniPayDetailsEntity Class | Aptify.Applications.Commissions Namespace


Validate Method

Aptify 5.0 Software Development Kit (SDK)

CommissioniPayDetailsEntity.Validate Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Validate();

public override bool Validate(ref String&);

See Also

CommissioniPayDetailsEntity Class | Aptify.Applications.Commissions Namespace


CommissioniPayDetailsEntity.Validate Method (String&)

public override bool Validate(
ref String& ErrorString
);

See Also

CommissioniPayDetailsEntity Class | Aptify.Applications.Commissions Namespace | CommissioniPayDetailsEntity.Validate Overload List


CommissionLayoutBase Class

For a list of all members of this type, see CommissionLayoutBase Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
CommissionLayoutBase
Derived types

public class CommissionLayoutBase : FormTemplateLayout

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Commissions

Assembly: CommissionLayoutBase (in CommissionLayoutBase.dll)

See Also

CommissionLayoutBase Members | Aptify.Applications.Commissions Namespace


CommissionLayoutBase Members

CommissionLayoutBase overview

Public Instance Constructors

CommissionLayoutBase Constructor Initializes a new instance of the CommissionLayoutBase class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AddControlEventHandler |
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormTemplateLayout) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindDataControl |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetControlProperty |
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded (inherited from FormTemplateLayout) | Raises the FormTemplateLoaded event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlProperty | Overloaded.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CommissionLayoutBase Class | Aptify.Applications.Commissions Namespace


CommissionLayoutBase Constructor

Initializes a new instance of the CommissionLayoutBase class.

public CommissionLayoutBase();

See Also

CommissionLayoutBase Class | Aptify.Applications.Commissions Namespace


CommissionLayoutBase Methods

The methods of the CommissionLayoutBase class are listed below. For a complete list of CommissionLayoutBase class members, see the CommissionLayoutBase Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AddControlEventHandler |
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormTemplateLayout) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindDataControl |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetControlProperty |
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded (inherited from FormTemplateLayout) | Raises the FormTemplateLoaded event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlProperty | Overloaded.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CommissionLayoutBase Class | Aptify.Applications.Commissions Namespace


CommissionLayoutBase.AddControlEventHandler Method

protected bool AddControlEventHandler(
String sFTPName,
String sEventName,
Delegate oHandler
);

See Also

CommissionLayoutBase Class | Aptify.Applications.Commissions Namespace


CommissionLayoutBase.FindDataControl Method

protected virtual IDataControl FindDataControl(
Control oControl
);

See Also

CommissionLayoutBase Class | Aptify.Applications.Commissions Namespace


CommissionLayoutBase.GetControlProperty Method

protected object GetControlProperty(
String sFTPName,
String sPropertyName,
Type tReturnType,
Type[] tParams,
Object oDefault
);

See Also

CommissionLayoutBase Class | Aptify.Applications.Commissions Namespace


SetControlProperty Method

Aptify 5.0 Software Development Kit (SDK)

CommissionLayoutBase.SetControlProperty Method

Overload List

protected bool SetControlProperty(String,String,Object);

protected bool SetControlProperty(String,String,Object,Type,Type[]);

See Also

CommissionLayoutBase Class | Aptify.Applications.Commissions Namespace


CommissionLayoutBase.SetControlProperty Method (String, String, Object)

protected bool SetControlProperty(
String sFTPName,
String sPropertyName,
Object oValue
);

See Also

CommissionLayoutBase Class | Aptify.Applications.Commissions Namespace | CommissionLayoutBase.SetControlProperty Overload List


CommissionLayoutBase.SetControlProperty Method (String, String, Object, Type, Type[])

protected bool SetControlProperty(
String sFTPName,
String sPropertyName,
Object oValue,
Type ReturnType,
Type[] Params
);

See Also

CommissionLayoutBase Class | Aptify.Applications.Commissions Namespace | CommissionLayoutBase.SetControlProperty Overload List


CommissionPayDetAdjustmentsLayout Class

For a list of all members of this type, see CommissionPayDetAdjustmentsLayout Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
CommissionLayoutBase
CommissionPayDetAdjustmentsLayout

public class CommissionPayDetAdjustmentsLayout : CommissionLayoutBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Commissions

Assembly: CommissionPaymentControls (in CommissionPaymentControls.dll)

See Also

CommissionPayDetAdjustmentsLayout Members | Aptify.Applications.Commissions Namespace


CommissionPayDetAdjustmentsLayout Members

CommissionPayDetAdjustmentsLayout overview

Public Instance Constructors

CommissionPayDetAdjustmentsLayout Constructor Initializes a new instance of the CommissionPayDetAdjustmentsLayout class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

dlgSourceName

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AddControlEventHandler (inherited from CommissionLayoutBase) |
AdjustFormScrollbars (inherited from ContainerControl) |
ConfigureDisplay |
ControlValueChanged |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormTemplateLayout) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindDataControl (inherited from CommissionLayoutBase) |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetControlProperty (inherited from CommissionLayoutBase) |
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded (inherited from FormTemplateLayout) | Raises the FormTemplateLoaded event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad |
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlProperty (inherited from CommissionLayoutBase) | Overloaded.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CommissionPayDetAdjustmentsLayout Class | Aptify.Applications.Commissions Namespace


CommissionPayDetAdjustmentsLayout Constructor

Initializes a new instance of the CommissionPayDetAdjustmentsLayout class.

public CommissionPayDetAdjustmentsLayout();

See Also

CommissionPayDetAdjustmentsLayout Class | Aptify.Applications.Commissions Namespace


CommissionPayDetAdjustmentsLayout Fields

The fields of the CommissionPayDetAdjustmentsLayout class are listed below. For a complete list of CommissionPayDetAdjustmentsLayout class members, see the CommissionPayDetAdjustmentsLayout Members topic.

Protected Instance Fields

dlgSourceName

See Also

CommissionPayDetAdjustmentsLayout Class | Aptify.Applications.Commissions Namespace


CommissionPayDetAdjustmentsLayout.dlgSourceName Field

protected dlgSourceName dlgSourceName;

See Also

CommissionPayDetAdjustmentsLayout Class | Aptify.Applications.Commissions Namespace


CommissionPayDetAdjustmentsLayout Methods

The methods of the CommissionPayDetAdjustmentsLayout class are listed below. For a complete list of CommissionPayDetAdjustmentsLayout class members, see the CommissionPayDetAdjustmentsLayout Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AddControlEventHandler (inherited from CommissionLayoutBase) |
AdjustFormScrollbars (inherited from ContainerControl) |
ConfigureDisplay |
ControlValueChanged |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormTemplateLayout) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindDataControl (inherited from CommissionLayoutBase) |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetControlProperty (inherited from CommissionLayoutBase) |
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded (inherited from FormTemplateLayout) | Raises the FormTemplateLoaded event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad |
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlProperty (inherited from CommissionLayoutBase) | Overloaded.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CommissionPayDetAdjustmentsLayout Class | Aptify.Applications.Commissions Namespace


CommissionPayDetAdjustmentsLayout.ConfigureDisplay Method

protected virtual void ConfigureDisplay();

See Also

CommissionPayDetAdjustmentsLayout Class | Aptify.Applications.Commissions Namespace


CommissionPayDetAdjustmentsLayout.ControlValueChanged Method

protected virtual void ControlValueChanged(
Object sender,
Object OldValue,
Object NewValue
);

See Also

CommissionPayDetAdjustmentsLayout Class | Aptify.Applications.Commissions Namespace


CommissionPayDetAdjustmentsLayout.OnLoad Method

protected override void OnLoad(
EventArgs e
);

See Also

CommissionPayDetAdjustmentsLayout Class | Aptify.Applications.Commissions Namespace


CommissionPayDetAdjustmentsLayout.OnRefresh Method

protected override void OnRefresh();

Implements

IFormComponent.

See Also

CommissionPayDetAdjustmentsLayout Class | Aptify.Applications.Commissions Namespace


CommissionPayDetailLayout Class

For a list of all members of this type, see CommissionPayDetailLayout Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
CommissionLayoutBase
CommissionPayDetailLayout

public class CommissionPayDetailLayout : CommissionLayoutBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Commissions

Assembly: CommissionPaymentControls (in CommissionPaymentControls.dll)

See Also

CommissionPayDetailLayout Members | Aptify.Applications.Commissions Namespace


CommissionPayDetailLayout Members

CommissionPayDetailLayout overview

Public Instance Constructors

CommissionPayDetailLayout Constructor Initializes a new instance of the CommissionPayDetailLayout class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetControlState |
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

dlgOrigPayDetail
dlgOrigPayID
dlgProdType
dlgRepType
dlgSalesRepID
msDatabase

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AddControlEventHandler (inherited from CommissionLayoutBase) |
AdjustFormScrollbars (inherited from ContainerControl) |
ConfigureDisplay |
ControlValueChanged |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormTemplateLayout) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindDataControl (inherited from CommissionLayoutBase) |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetControlProperty (inherited from CommissionLayoutBase) |
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded (inherited from FormTemplateLayout) | Raises the FormTemplateLoaded event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad |
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlProperty (inherited from CommissionLayoutBase) | Overloaded.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CommissionPayDetailLayout Class | Aptify.Applications.Commissions Namespace


CommissionPayDetailLayout Constructor

Initializes a new instance of the CommissionPayDetailLayout class.

public CommissionPayDetailLayout();

See Also

CommissionPayDetailLayout Class | Aptify.Applications.Commissions Namespace


CommissionPayDetailLayout Fields

The fields of the CommissionPayDetailLayout class are listed below. For a complete list of CommissionPayDetailLayout class members, see the CommissionPayDetailLayout Members topic.

Protected Instance Fields

dlgOrigPayDetail
dlgOrigPayID
dlgProdType
dlgRepType
dlgSalesRepID
msDatabase

See Also

CommissionPayDetailLayout Class | Aptify.Applications.Commissions Namespace


CommissionPayDetailLayout.dlgOrigPayDetail Field

protected dlgOrigPayDetail dlgOrigPayDetail;

See Also

CommissionPayDetailLayout Class | Aptify.Applications.Commissions Namespace


CommissionPayDetailLayout.dlgOrigPayID Field

protected dlgOrigPayID dlgOrigPayID;

See Also

CommissionPayDetailLayout Class | Aptify.Applications.Commissions Namespace


CommissionPayDetailLayout.dlgProdType Field

protected dlgProdType dlgProdType;

See Also

CommissionPayDetailLayout Class | Aptify.Applications.Commissions Namespace


CommissionPayDetailLayout.dlgRepType Field

protected dlgRepType dlgRepType;

See Also

CommissionPayDetailLayout Class | Aptify.Applications.Commissions Namespace


CommissionPayDetailLayout.dlgSalesRepID Field

protected dlgSalesRepID dlgSalesRepID;

See Also

CommissionPayDetailLayout Class | Aptify.Applications.Commissions Namespace


CommissionPayDetailLayout.msDatabase Field

protected msDatabase msDatabase;

See Also

CommissionPayDetailLayout Class | Aptify.Applications.Commissions Namespace


CommissionPayDetailLayout Methods

The methods of the CommissionPayDetailLayout class are listed below. For a complete list of CommissionPayDetailLayout class members, see the CommissionPayDetailLayout Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetControlState |
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AddControlEventHandler (inherited from CommissionLayoutBase) |
AdjustFormScrollbars (inherited from ContainerControl) |
ConfigureDisplay |
ControlValueChanged |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormTemplateLayout) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindDataControl (inherited from CommissionLayoutBase) |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetControlProperty (inherited from CommissionLayoutBase) |
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded (inherited from FormTemplateLayout) | Raises the FormTemplateLoaded event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad |
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlProperty (inherited from CommissionLayoutBase) | Overloaded.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CommissionPayDetailLayout Class | Aptify.Applications.Commissions Namespace


CommissionPayDetailLayout.ConfigureDisplay Method

protected virtual void ConfigureDisplay();

See Also

CommissionPayDetailLayout Class | Aptify.Applications.Commissions Namespace


CommissionPayDetailLayout.ControlValueChanged Method

protected virtual void ControlValueChanged(
Object sender,
Object OldValue,
Object NewValue
);

See Also

CommissionPayDetailLayout Class | Aptify.Applications.Commissions Namespace


CommissionPayDetailLayout.OnLoad Method

protected override void OnLoad(
EventArgs e
);

See Also

CommissionPayDetailLayout Class | Aptify.Applications.Commissions Namespace


CommissionPayDetailLayout.OnRefresh Method

protected override void OnRefresh();

Implements

IFormComponent.

See Also

CommissionPayDetailLayout Class | Aptify.Applications.Commissions Namespace


CommissionPayDetailLayout.SetControlState Method

public void SetControlState(
Boolean bEnable
);

See Also

CommissionPayDetailLayout Class | Aptify.Applications.Commissions Namespace


CommissionPayment Class

This class provides the implementation for business logic for the Commission Payments entity in the Aptify Commission and Royalty Management system.

For a list of all members of this type, see CommissionPayment Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
CommissionPayment

public class CommissionPayment : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Commissions

Assembly: CommissionPayment (in CommissionPayment.dll)

See Also

CommissionPayment Members | Aptify.Applications.Commissions Namespace


CommissionPayment Members

CommissionPayment overview

Public Instance Constructors

CommissionPayment Constructor Initializes a new instance of the CommissionPayment class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config | Overloaded.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete | Overloaded. This method overrides the base GE Delete method to check to see if any linked adjustments exist that are linked to this Commission Payment record. If there are any, delete is not allowed since the Delete method would invalidate those linked adjustment records. This method uses the spCommissionPaymentLinkedAdjExists stored procedure to check for this condition.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue |
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded. This method adds validation to the base GE validation to ensure that the RangeStartDate field is less than the RangeEndDate field.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
Database |
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
IsFromLessThanToDate | This method checks to see if two dates are set and if so, if DateFrom is Less Than Or Equal To DateTo.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetSubTypeApproved |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

CommissionPayment Class | Aptify.Applications.Commissions Namespace


CommissionPayment Constructor

Initializes a new instance of the CommissionPayment class.

public CommissionPayment();

See Also

CommissionPayment Class | Aptify.Applications.Commissions Namespace


CommissionPayment Properties

The properties of the CommissionPayment class are listed below. For a complete list of CommissionPayment class members, see the CommissionPayment Members topic.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
Database |
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

CommissionPayment Class | Aptify.Applications.Commissions Namespace


Database Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayment.Database Property

protected virtual String Database {get;}

See Also

CommissionPayment Class | Aptify.Applications.Commissions Namespace


CommissionPayment Methods

The methods of the CommissionPayment class are listed below. For a complete list of CommissionPayment class members, see the CommissionPayment Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config | Overloaded.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete | Overloaded. This method overrides the base GE Delete method to check to see if any linked adjustments exist that are linked to this Commission Payment record. If there are any, delete is not allowed since the Delete method would invalidate those linked adjustment records. This method uses the spCommissionPaymentLinkedAdjExists stored procedure to check for this condition.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue |
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded. This method adds validation to the base GE validation to ensure that the RangeStartDate field is less than the RangeEndDate field.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
IsFromLessThanToDate | This method checks to see if two dates are set and if so, if DateFrom is Less Than Or Equal To DateTo.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetSubTypeApproved |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

CommissionPayment Class | Aptify.Applications.Commissions Namespace


Config Method

Aptify 5.0 Software Development Kit (SDK)

CommissionPayment.Config Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual void Config(AptifySubTypeBase);

Inherited from AptifyGenericEntity.

public override void Config(AptifySubTypeBase,Int64);

Inherited from AptifyGenericEntityBase.

public virtual void Config(UserCredentials,String);

public override void Config(UserCredentials,String,Int64);

See Also

CommissionPayment Class | Aptify.Applications.Commissions Namespace


CommissionPayment.Config Method (UserCredentials, String, Int64)

public override void Config(
UserCredentials UserCredentials,
String EntityName,
Int64 RecordID
);

See Also

CommissionPayment Class | Aptify.Applications.Commissions Namespace | CommissionPayment.Config Overload List


Delete Method

Aptify 5.0 Software Development Kit (SDK)

CommissionPayment.Delete Method

This method overrides the base GE Delete method to check to see if any linked adjustments exist that are linked to this Commission Payment record. If there are any, delete is not allowed since the Delete method would invalidate those linked adjustment records. This method uses the spCommissionPaymentLinkedAdjExists stored procedure to check for this condition.

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Delete();

This method overrides the base GE Delete method to check to see if any linked adjustments exist that are linked to this Commission Payment record. If there are any, delete is not allowed since the Delete method would invalidate those linked adjustment records. This method uses the spCommissionPaymentLinkedAdjExists stored procedure to check for this condition.

public override bool Delete(String);

See Also

CommissionPayment Class | Aptify.Applications.Commissions Namespace


CommissionPayment.Delete Method (String)

This method overrides the base GE Delete method to check to see if any linked adjustments exist that are linked to this Commission Payment record. If there are any, delete is not allowed since the Delete method would invalidate those linked adjustment records. This method uses the spCommissionPaymentLinkedAdjExists stored procedure to check for this condition.

public override bool Delete(
String TransactionID
);

Parameters

TransactionID

Return Value

Remarks

See Also

CommissionPayment Class | Aptify.Applications.Commissions Namespace | CommissionPayment.Delete Overload List


CommissionPayment.IsFromLessThanToDate Method

This method checks to see if two dates are set and if so, if DateFrom is Less Than Or Equal To DateTo.

protected virtual bool IsFromLessThanToDate(
Object DateFrom,
Object DateTo
);

Parameters

DateFrom
DateTo

Return Value

Remarks

See Also

CommissionPayment Class | Aptify.Applications.Commissions Namespace


CommissionPayment.SetSubTypeApproved Method

protected virtual bool SetSubTypeApproved(
Boolean bApproved
);

See Also

CommissionPayment Class | Aptify.Applications.Commissions Namespace


CommissionPayment.SetValue Method

public override void SetValue(
String FieldName,
Object Value
);

See Also

CommissionPayment Class | Aptify.Applications.Commissions Namespace


Validate Method

Aptify 5.0 Software Development Kit (SDK)

CommissionPayment.Validate Method

This method adds validation to the base GE validation to ensure that the RangeStartDate field is less than the RangeEndDate field.

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Validate();

This method adds validation to the base GE validation to ensure that the RangeStartDate field is less than the RangeEndDate field.

public override bool Validate(ref String&);

See Also

CommissionPayment Class | Aptify.Applications.Commissions Namespace


CommissionPayment.Validate Method (String&)

This method adds validation to the base GE validation to ensure that the RangeStartDate field is less than the RangeEndDate field.

public override bool Validate(
ref String& ErrorString
);

Parameters

ErrorString

Return Value

Remarks

See Also

CommissionPayment Class | Aptify.Applications.Commissions Namespace | CommissionPayment.Validate Overload List


CommissionPayments Class

Represents a strongly typed in-memory cache of data.

For a list of all members of this type, see CommissionPayments Members.

System.Object
MarshalByValueComponent
DataSet
CommissionPayments

public class CommissionPayments : DataSet

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Commissions

Assembly: CommissionPaymentWizard (in CommissionPaymentWizard.dll)

See Also

CommissionPayments Members | Aptify.Applications.Commissions Namespace


CommissionPayments Members

CommissionPayments overview

Public Static Methods

GetTypedDataSetSchema

Public Instance Constructors

CommissionPayments Overloaded. Initializes a new instance of the CommissionPayments class.

Public Instance Properties

Adjustments |
CaseSensitive (inherited from DataSet) | Gets or sets a value indicating whether string comparisons within DataTable objects are case-sensitive.
Container (inherited from MarshalByValueComponent) | Gets the container for the component.
DataSetName (inherited from DataSet) | Gets or sets the name of the current DataSet.
DefaultViewManager (inherited from DataSet) | Gets a custom view of the data contained in the DataSet to allow filtering, searching, and navigating using a custom DataViewManager.
DesignMode (inherited from MarshalByValueComponent) | Gets a value indicating whether the component is currently in design mode.
EnforceConstraints (inherited from DataSet) | Gets or sets a value indicating whether constraint rules are followed when attempting any update operation.
ExtendedProperties (inherited from DataSet) | Gets the collection of customized user information associated with the DataSet.
HasErrors (inherited from DataSet) | Gets a value indicating whether there are errors in any of the DataTable objects within this DataSet.
IsInitialized (inherited from DataSet) | Gets a value that indicates whether the DataSet is initialized.
Locale (inherited from DataSet) | Gets or sets the locale information used to compare strings within the table.
Namespace (inherited from DataSet) | Gets or sets the namespace of the DataSet.
PaymentGroups |
Payments |
Prefix (inherited from DataSet) | Gets or sets an XML prefix that aliases the namespace of the DataSet.
Relations |
RemotingFormat (inherited from DataSet) | Gets or sets a SerializationFormat for the DataSet used during remoting.
SchemaSerializationMode |
Site (inherited from DataSet) | Gets or sets an ISite for the DataSet.
Tables |
UpdaidInvoices |

Public Instance Methods

AcceptChanges (inherited from DataSet) | Commits all the changes made to this DataSet since it was loaded or since the last time AcceptChanges was called.
BeginInit (inherited from DataSet) | Begins the initialization of a DataSet that is used on a form or used by another component. The initialization occurs at run-time.
Clear (inherited from DataSet) | Clears the DataSet of any data by removing all rows in all tables.
Clone |
Copy (inherited from DataSet) | Copies both the structure and data for this DataSet.
CreateDataReader (inherited from DataSet) | Overloaded. Returns a DataTableReader with one result set per DataTable, in the same sequence as the tables appear in the Tables collection.
Dispose (inherited from MarshalByValueComponent) | Overloaded. Releases all resources used by the MarshalByValueComponent.
EndInit (inherited from DataSet) | Ends the initialization of a DataSet that is used on a form or used by another component. The initialization occurs at run time.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetChanges (inherited from DataSet) | Overloaded. Gets a copy of the DataSet that contains all changes made to it since it was loaded or since AcceptChanges was last called.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from DataSet) | Populates a serialization information object with the data needed to serialize the DataSet.
GetService (inherited from MarshalByValueComponent) | Gets the implementer of the IServiceProvider.
GetType (inherited from Object) | Gets the Type of the current instance.
GetXml (inherited from DataSet) | Returns the XML representation of the data stored in the DataSet.
GetXmlSchema (inherited from DataSet) | Returns the XML Schema for the XML representation of the data stored in the DataSet.
HasChanges (inherited from DataSet) | Overloaded. Gets a value indicating whether the DataSet has changes, including new, deleted, or modified rows.
InferXmlSchema (inherited from DataSet) | Overloaded. Applies the XML schema from the specified XmlReader to the DataSet.
Load (inherited from DataSet) | Overloaded. Fills a DataSet with values from a data source using the supplied IDataReader, using an array of DataTable instances to supply the schema and namespace information.
Merge (inherited from DataSet) | Overloaded. Merges a specified DataSet and its schema into the current DataSet.
ReadXml (inherited from DataSet) | Overloaded. Reads XML schema and data into the DataSet using the specified XmlReader.
ReadXmlSchema (inherited from DataSet) | Overloaded. Reads the XML schema from the specified Stream into the DataSet.
RejectChanges (inherited from DataSet) | Rolls back all the changes made to the DataSet since it was created, or since the last time AcceptChanges was called.
Reset (inherited from DataSet) | Resets the DataSet to its original state. Subclasses should override Reset to restore a DataSet to its original state.
ToString (inherited from MarshalByValueComponent) | Returns a String containing the name of the Component, if any. This method should not be overridden.
WriteXml (inherited from DataSet) | Overloaded. Writes the current data for the DataSet using the specified Stream.
WriteXmlSchema (inherited from DataSet) | Overloaded. Writes the DataSet structure as an XML schema to using the specified Stream object.

Public Instance Events

Disposed (inherited from MarshalByValueComponent) | Adds an event handler to listen to the Disposed event on the component.
Initialized (inherited from DataSet) | Occurs after the DataSet is initialized.
MergeFailed (inherited from DataSet) | Occurs when a target and source DataRow have the same primary key value, and EnforceConstraints is set to true.

Protected Instance Constructors

CommissionPayments Overloaded. Initializes a new instance of the CommissionPayments class.

Protected Instance Properties

Events (inherited from MarshalByValueComponent) Gets the list of event handlers that are attached to this component.

Protected Instance Methods

DetermineSchemaSerializationMode (inherited from DataSet) | Overloaded. Determines the SchemaSerializationMode for a DataSet.
Dispose (inherited from MarshalByValueComponent) | Overloaded. Releases the unmanaged resources used by the MarshalByValueComponent and optionally releases the managed resources.
Finalize (inherited from MarshalByValueComponent) | [To be supplied.]
GetSchemaSerializable |
GetSerializationData (inherited from DataSet) |
InitializeDerivedDataSet |
IsBinarySerialized (inherited from DataSet) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnPropertyChanging (inherited from DataSet) | Raises the OnPropertyChanging event.
OnRemoveRelation (inherited from DataSet) | Occurs when a DataRelation object is removed from a DataTable.
ReadXmlSerializable |
ShouldSerializeRelations |
ShouldSerializeTables |

Protected Internal Instance Methods

OnRemoveTable (inherited from DataSet) | Occurs when a DataTable is removed from a DataSet.
RaisePropertyChanging (inherited from DataSet) | Sends a notification that the specified DataSet property is about to change.

See Also

CommissionPayments Class | Aptify.Applications.Commissions Namespace


CommissionPayments Constructor

Initializes a new instance of the CommissionPayments class.

Overload List

Initializes a new instance of the CommissionPayments class.

public CommissionPayments();

protected CommissionPayments(SerializationInfo,StreamingContext);

See Also

CommissionPayments Class | Aptify.Applications.Commissions Namespace


CommissionPayments Constructor ()

Initializes a new instance of the CommissionPayments class.

public CommissionPayments();

See Also

CommissionPayments Class | Aptify.Applications.Commissions Namespace | CommissionPayments Constructor Overload List


CommissionPayments Constructor (SerializationInfo, StreamingContext)

protected CommissionPayments(
SerializationInfo info,
StreamingContext context
);

See Also

CommissionPayments Class | Aptify.Applications.Commissions Namespace | CommissionPayments Constructor Overload List


CommissionPayments Properties

The properties of the CommissionPayments class are listed below. For a complete list of CommissionPayments class members, see the CommissionPayments Members topic.

Public Instance Properties

Adjustments |
CaseSensitive (inherited from DataSet) | Gets or sets a value indicating whether string comparisons within DataTable objects are case-sensitive.
Container (inherited from MarshalByValueComponent) | Gets the container for the component.
DataSetName (inherited from DataSet) | Gets or sets the name of the current DataSet.
DefaultViewManager (inherited from DataSet) | Gets a custom view of the data contained in the DataSet to allow filtering, searching, and navigating using a custom DataViewManager.
DesignMode (inherited from MarshalByValueComponent) | Gets a value indicating whether the component is currently in design mode.
EnforceConstraints (inherited from DataSet) | Gets or sets a value indicating whether constraint rules are followed when attempting any update operation.
ExtendedProperties (inherited from DataSet) | Gets the collection of customized user information associated with the DataSet.
HasErrors (inherited from DataSet) | Gets a value indicating whether there are errors in any of the DataTable objects within this DataSet.
IsInitialized (inherited from DataSet) | Gets a value that indicates whether the DataSet is initialized.
Locale (inherited from DataSet) | Gets or sets the locale information used to compare strings within the table.
Namespace (inherited from DataSet) | Gets or sets the namespace of the DataSet.
PaymentGroups |
Payments |
Prefix (inherited from DataSet) | Gets or sets an XML prefix that aliases the namespace of the DataSet.
Relations |
RemotingFormat (inherited from DataSet) | Gets or sets a SerializationFormat for the DataSet used during remoting.
SchemaSerializationMode |
Site (inherited from DataSet) | Gets or sets an ISite for the DataSet.
Tables |
UpdaidInvoices |

Protected Instance Properties

Events (inherited from MarshalByValueComponent) Gets the list of event handlers that are attached to this component.

See Also

CommissionPayments Class | Aptify.Applications.Commissions Namespace


Adjustments Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.Adjustments Property

public CommissionPayments.AdjustmentsDataTable Adjustments {get;}

See Also

CommissionPayments Class | Aptify.Applications.Commissions Namespace


PaymentGroups Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.PaymentGroups Property

public CommissionPayments.PaymentGroupsDataTable PaymentGroups {get;}

See Also

CommissionPayments Class | Aptify.Applications.Commissions Namespace


Payments Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.Payments Property

public CommissionPayments.PaymentsDataTable Payments {get;}

See Also

CommissionPayments Class | Aptify.Applications.Commissions Namespace


Relations Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.Relations Property

new public DataRelationCollection Relations {get;}

See Also

CommissionPayments Class | Aptify.Applications.Commissions Namespace


SchemaSerializationMode Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.SchemaSerializationMode Property

public override SchemaSerializationMode SchemaSerializationMode {get; set;}

See Also

CommissionPayments Class | Aptify.Applications.Commissions Namespace


Tables Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.Tables Property

new public DataTableCollection Tables {get;}

See Also

CommissionPayments Class | Aptify.Applications.Commissions Namespace


UpdaidInvoices Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.UpdaidInvoices Property

public CommissionPayments.UpdaidInvoicesDataTable UpdaidInvoices {get;}

See Also

CommissionPayments Class | Aptify.Applications.Commissions Namespace


CommissionPayments Methods

The methods of the CommissionPayments class are listed below. For a complete list of CommissionPayments class members, see the CommissionPayments Members topic.

Public Static Methods

GetTypedDataSetSchema

Public Instance Methods

AcceptChanges (inherited from DataSet) | Commits all the changes made to this DataSet since it was loaded or since the last time AcceptChanges was called.
BeginInit (inherited from DataSet) | Begins the initialization of a DataSet that is used on a form or used by another component. The initialization occurs at run-time.
Clear (inherited from DataSet) | Clears the DataSet of any data by removing all rows in all tables.
Clone |
Copy (inherited from DataSet) | Copies both the structure and data for this DataSet.
CreateDataReader (inherited from DataSet) | Overloaded. Returns a DataTableReader with one result set per DataTable, in the same sequence as the tables appear in the Tables collection.
Dispose (inherited from MarshalByValueComponent) | Overloaded. Releases all resources used by the MarshalByValueComponent.
EndInit (inherited from DataSet) | Ends the initialization of a DataSet that is used on a form or used by another component. The initialization occurs at run time.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetChanges (inherited from DataSet) | Overloaded. Gets a copy of the DataSet that contains all changes made to it since it was loaded or since AcceptChanges was last called.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from DataSet) | Populates a serialization information object with the data needed to serialize the DataSet.
GetService (inherited from MarshalByValueComponent) | Gets the implementer of the IServiceProvider.
GetType (inherited from Object) | Gets the Type of the current instance.
GetXml (inherited from DataSet) | Returns the XML representation of the data stored in the DataSet.
GetXmlSchema (inherited from DataSet) | Returns the XML Schema for the XML representation of the data stored in the DataSet.
HasChanges (inherited from DataSet) | Overloaded. Gets a value indicating whether the DataSet has changes, including new, deleted, or modified rows.
InferXmlSchema (inherited from DataSet) | Overloaded. Applies the XML schema from the specified XmlReader to the DataSet.
Load (inherited from DataSet) | Overloaded. Fills a DataSet with values from a data source using the supplied IDataReader, using an array of DataTable instances to supply the schema and namespace information.
Merge (inherited from DataSet) | Overloaded. Merges a specified DataSet and its schema into the current DataSet.
ReadXml (inherited from DataSet) | Overloaded. Reads XML schema and data into the DataSet using the specified XmlReader.
ReadXmlSchema (inherited from DataSet) | Overloaded. Reads the XML schema from the specified Stream into the DataSet.
RejectChanges (inherited from DataSet) | Rolls back all the changes made to the DataSet since it was created, or since the last time AcceptChanges was called.
Reset (inherited from DataSet) | Resets the DataSet to its original state. Subclasses should override Reset to restore a DataSet to its original state.
ToString (inherited from MarshalByValueComponent) | Returns a String containing the name of the Component, if any. This method should not be overridden.
WriteXml (inherited from DataSet) | Overloaded. Writes the current data for the DataSet using the specified Stream.
WriteXmlSchema (inherited from DataSet) | Overloaded. Writes the DataSet structure as an XML schema to using the specified Stream object.

Protected Instance Methods

DetermineSchemaSerializationMode (inherited from DataSet) | Overloaded. Determines the SchemaSerializationMode for a DataSet.
Dispose (inherited from MarshalByValueComponent) | Overloaded. Releases the unmanaged resources used by the MarshalByValueComponent and optionally releases the managed resources.
Finalize (inherited from MarshalByValueComponent) | [To be supplied.]
GetSchemaSerializable |
GetSerializationData (inherited from DataSet) |
InitializeDerivedDataSet |
IsBinarySerialized (inherited from DataSet) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnPropertyChanging (inherited from DataSet) | Raises the OnPropertyChanging event.
OnRemoveRelation (inherited from DataSet) | Occurs when a DataRelation object is removed from a DataTable.
ReadXmlSerializable |
ShouldSerializeRelations |
ShouldSerializeTables |

Protected Internal Instance Methods

OnRemoveTable (inherited from DataSet) | Occurs when a DataTable is removed from a DataSet.
RaisePropertyChanging (inherited from DataSet) | Sends a notification that the specified DataSet property is about to change.

See Also

CommissionPayments Class | Aptify.Applications.Commissions Namespace


CommissionPayments.Clone Method

public override DataSet Clone();

See Also

CommissionPayments Class | Aptify.Applications.Commissions Namespace


CommissionPayments.GetSchemaSerializable Method

protected override XmlSchema GetSchemaSerializable();

See Also

CommissionPayments Class | Aptify.Applications.Commissions Namespace


CommissionPayments.GetTypedDataSetSchema Method

public static XmlSchemaComplexType GetTypedDataSetSchema(
XmlSchemaSet xs
);

See Also

CommissionPayments Class | Aptify.Applications.Commissions Namespace


CommissionPayments.InitializeDerivedDataSet Method

protected override void InitializeDerivedDataSet();

See Also

CommissionPayments Class | Aptify.Applications.Commissions Namespace


CommissionPayments.ReadXmlSerializable Method

protected override void ReadXmlSerializable(
XmlReader reader
);

See Also

CommissionPayments Class | Aptify.Applications.Commissions Namespace


CommissionPayments.ShouldSerializeRelations Method

protected override bool ShouldSerializeRelations();

See Also

CommissionPayments Class | Aptify.Applications.Commissions Namespace


CommissionPayments.ShouldSerializeTables Method

protected override bool ShouldSerializeTables();

See Also

CommissionPayments Class | Aptify.Applications.Commissions Namespace


CommissionPayments.AdjustmentsDataTable Class

Represents the strongly named DataTable class.

For a list of all members of this type, see CommissionPayments.AdjustmentsDataTable Members.

System.Object
MarshalByValueComponent
DataTable
CommissionPayments.AdjustmentsDataTable

public class CommissionPayments.AdjustmentsDataTable : DataTable, IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Commissions

Assembly: CommissionPaymentWizard (in CommissionPaymentWizard.dll)

See Also

CommissionPayments.AdjustmentsDataTable Members | Aptify.Applications.Commissions Namespace


CommissionPayments.AdjustmentsDataTable Members

CommissionPayments.AdjustmentsDataTable overview

Public Static Methods

GetTypedTableSchema

Public Instance Constructors

CommissionPayments.AdjustmentsDataTable Overloaded. Initializes a new instance of the CommissionPayments.AdjustmentsDataTable class.

Public Instance Properties

AdjustmentColumn |
AdjustmentTypeColumn |
BalanceColumn |
BalanceFactorColumn |
BaseAdjustmentColumn |
CaseSensitive (inherited from DataTable) | Indicates whether string comparisons within the table are case-sensitive.
ChildRelations (inherited from DataTable) | Gets the collection of child relations for this DataTable.
Columns (inherited from DataTable) | Gets the collection of columns that belong to this table.
CommissionPayDetSequenceColumn |
CommissionPaymentIDColumn |
Constraints (inherited from DataTable) | Gets the collection of constraints maintained by this table.
Container (inherited from MarshalByValueComponent) | Gets the container for the component.
Count |
CPSDSequenceColumn |
CurrentBaseColumn |
DataSet (inherited from DataTable) | Gets the DataSet to which this table belongs.
Days_OldColumn |
DefaultView (inherited from DataTable) | Gets a customized view of the table that may include a filtered view, or a cursor position.
DesignMode (inherited from MarshalByValueComponent) | Gets a value indicating whether the component is currently in design mode.
DisplayExpression (inherited from DataTable) | Gets or sets the expression that returns a value used to represent this table in the user interface.
EffectiveRateColumn |
ExtendedProperties (inherited from DataTable) | Gets the collection of customized user information.
HasErrors (inherited from DataTable) | Gets a value indicating whether there are errors in any of the rows in any of the tables of the DataSet to which the table belongs.
IsInitialized (inherited from DataTable) | Gets a value that indicates whether the DataTable is initialized.
Item |
Locale (inherited from DataTable) | Gets or sets the locale information used to compare strings within the table.
MinimumCapacity (inherited from DataTable) | Gets or sets the initial starting size for this table.
Namespace (inherited from DataTable) | Gets or sets the namespace for the XML representation of the data stored in the DataTable.
NewBaseColumn |
ParentRelations (inherited from DataTable) | Gets the collection of parent relations for this DataTable.
PaymentColumn |
PaymentIndexColumn |
Prefix (inherited from DataTable) | Gets or sets the namespace for the XML representation of the data stored in the DataTable.
PrimaryKey (inherited from DataTable) | Gets or sets an array of columns that function as primary keys for the data table.
Prod_ProdCatIDColumn |
ProductColumn |
ProductTypeColumn |
RemotingFormat (inherited from DataTable) | Gets or sets the serialization format.
Rows (inherited from DataTable) | Gets the collection of rows that belong to this table.
SalesRepIDColumn |
SalesRepNameColumn |
SalesRepTypeColumn |
Site (inherited from DataTable) | Gets or sets an ISite for the DataTable.
SourceEntityColumn |
SourceIDColumn |
TableName (inherited from DataTable) | Gets or sets the name of the DataTable.

Public Instance Methods

AcceptChanges (inherited from DataTable) | Commits all the changes made to this table since the last time AcceptChanges was called.
AddAdjustmentsRow | Overloaded.
BeginInit (inherited from DataTable) | Begins the initialization of a DataTable that is used on a form or used by another component. The initialization occurs at runtime.
BeginLoadData (inherited from DataTable) | Turns off notifications, index maintenance, and constraints while loading data.
Clear (inherited from DataTable) | Clears the DataTable of all data.
Clone |
Compute (inherited from DataTable) | Computes the given expression on the current rows that pass the filter criteria.
Copy (inherited from DataTable) | Copies both the structure and data for this DataTable.
CreateDataReader (inherited from DataTable) | Returns a DataTableReader corresponding to the data within this DataTable.
Dispose (inherited from MarshalByValueComponent) | Overloaded. Releases all resources used by the MarshalByValueComponent.
EndInit (inherited from DataTable) | Ends the initialization of a DataTable that is used on a form or used by another component. The initialization occurs at runtime.
EndLoadData (inherited from DataTable) | Turns on notifications, index maintenance, and constraints after loading data.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetChanges (inherited from DataTable) | Overloaded. Gets a copy of the DataTable that contains all changes made to it since it was loaded or AcceptChanges was last called.
GetEnumerator |
GetErrors (inherited from DataTable) | Gets an array of DataRow objects that contain errors.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from DataTable) | Populates a serialization information object with the data needed to serialize the DataTable.
GetService (inherited from MarshalByValueComponent) | Gets the implementer of the IServiceProvider.
GetType (inherited from Object) | Gets the Type of the current instance.
ImportRow (inherited from DataTable) | Copies a DataRow into a DataTable, preserving any property settings, as well as original and current values.
Load (inherited from DataTable) | Overloaded. Fills a DataTable with values from a data source using the supplied IDataReader. If the DataTable already contains rows, the incoming data from the data source is merged with the existing rows.
LoadDataRow (inherited from DataTable) | Overloaded. Finds and updates a specific row. If no matching row is found, a new row is created using the given values.
Merge (inherited from DataTable) | Overloaded. Merge the specified DataTable with the current DataTable.
NewAdjustmentsRow |
NewRow (inherited from DataTable) | Creates a new DataRow with the same schema as the table.
ReadXml (inherited from DataTable) | Overloaded. Reads XML schema and data into the DataTable using the specified Stream.
ReadXmlSchema (inherited from DataTable) | Overloaded. Reads an XML schema into the DataTable using the specified stream.
RejectChanges (inherited from DataTable) | Rolls back all changes that have been made to the table since it was loaded, or the last time AcceptChanges was called.
RemoveAdjustmentsRow |
Reset (inherited from DataTable) | Resets the DataTable to its original state.
Select (inherited from DataTable) | Overloaded. Gets an array of all DataRow objects.
ToString (inherited from DataTable) | Gets the TableName and DisplayExpression, if there is one as a concatenated string.
WriteXml (inherited from DataTable) | Overloaded. Writes the current data, and optionally the schema, for the DataTable using the specified TextWriter and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. To save the data for the table and all its descendants, set the writeHierarchy parameter to true.
WriteXmlSchema (inherited from DataTable) | Overloaded. Writes the current data structure of the DataTable as an XML schema to the specified stream.

Public Instance Events

AdjustmentsRowChanged |
AdjustmentsRowChanging |
AdjustmentsRowDeleted |
AdjustmentsRowDeleting |
ColumnChanged (inherited from DataTable) | Occurs after a value has been changed for the specified DataColumn in a DataRow.
ColumnChanging (inherited from DataTable) | Occurs when a value is being changed for the specified DataColumn in a DataRow.
Disposed (inherited from MarshalByValueComponent) | Adds an event handler to listen to the Disposed event on the component.
Initialized (inherited from DataTable) | Occurs after the DataTable is initialized.
RowChanged (inherited from DataTable) | Occurs after a DataRow has been changed successfully.
RowChanging (inherited from DataTable) | Occurs when a DataRow is changing.
RowDeleted (inherited from DataTable) | Occurs after a row in the table has been deleted.
RowDeleting (inherited from DataTable) | Occurs before a row in the table is about to be deleted.
TableCleared (inherited from DataTable) | Occurs after a DataTable is cleared.
TableClearing (inherited from DataTable) | Occurs when a DataTable is cleared.
TableNewRow (inherited from DataTable) | Occurs when a new DataRow is inserted.

Protected Instance Constructors

CommissionPayments.AdjustmentsDataTable Overloaded. Initializes a new instance of the CommissionPayments.AdjustmentsDataTable class.

Protected Instance Properties

Events (inherited from MarshalByValueComponent) Gets the list of event handlers that are attached to this component.

Protected Instance Methods

CreateInstance |
Dispose (inherited from MarshalByValueComponent) | Overloaded. Releases the unmanaged resources used by the MarshalByValueComponent and optionally releases the managed resources.
Finalize (inherited from MarshalByValueComponent) | [To be supplied.]
GetRowType |
GetSchema (inherited from DataTable) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NewRowFromBuilder |
OnPropertyChanging (inherited from DataTable) | Raises the PropertyChanging event.
OnRemoveColumn (inherited from DataTable) | Notifies the DataTable that a DataColumn is being removed.
OnRowChanged |
OnRowChanging |
OnRowDeleted |
OnRowDeleting |
OnTableCleared (inherited from DataTable) | Raises the TableCleared event.
OnTableClearing (inherited from DataTable) | Raises the TableClearing event.
OnTableNewRow (inherited from DataTable) | Raises the TableNewRow event.
ReadXmlSerializable (inherited from DataTable) |

Protected Internal Instance Fields

fInitInProgress (inherited from DataTable)

Protected Internal Instance Methods

NewRowArray (inherited from DataTable) |
OnColumnChanged (inherited from DataTable) | Raises the ColumnChanged event.
OnColumnChanging (inherited from DataTable) | Raises the ColumnChanging event.

See Also

CommissionPayments.AdjustmentsDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.AdjustmentsDataTable Constructor

Initializes a new instance of the CommissionPayments.AdjustmentsDataTable class.

Overload List

Initializes a new instance of the CommissionPayments.AdjustmentsDataTable class.

public CommissionPayments.AdjustmentsDataTable();

protected CommissionPayments.AdjustmentsDataTable(SerializationInfo,StreamingContext);

See Also

CommissionPayments.AdjustmentsDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.AdjustmentsDataTable Constructor ()

Initializes a new instance of the CommissionPayments.AdjustmentsDataTable class.

public CommissionPayments.AdjustmentsDataTable();

See Also

CommissionPayments.AdjustmentsDataTable Class | Aptify.Applications.Commissions Namespace | CommissionPayments.AdjustmentsDataTable Constructor Overload List


CommissionPayments.AdjustmentsDataTable Constructor (SerializationInfo, StreamingContext)

protected CommissionPayments.AdjustmentsDataTable(
SerializationInfo info,
StreamingContext context
);

See Also

CommissionPayments.AdjustmentsDataTable Class | Aptify.Applications.Commissions Namespace | CommissionPayments.AdjustmentsDataTable Constructor Overload List


CommissionPayments.AdjustmentsDataTable Properties

The properties of the CommissionPayments.AdjustmentsDataTable class are listed below. For a complete list of CommissionPayments.AdjustmentsDataTable class members, see the CommissionPayments.AdjustmentsDataTable Members topic.

Public Instance Properties

AdjustmentColumn |
AdjustmentTypeColumn |
BalanceColumn |
BalanceFactorColumn |
BaseAdjustmentColumn |
CaseSensitive (inherited from DataTable) | Indicates whether string comparisons within the table are case-sensitive.
ChildRelations (inherited from DataTable) | Gets the collection of child relations for this DataTable.
Columns (inherited from DataTable) | Gets the collection of columns that belong to this table.
CommissionPayDetSequenceColumn |
CommissionPaymentIDColumn |
Constraints (inherited from DataTable) | Gets the collection of constraints maintained by this table.
Container (inherited from MarshalByValueComponent) | Gets the container for the component.
Count |
CPSDSequenceColumn |
CurrentBaseColumn |
DataSet (inherited from DataTable) | Gets the DataSet to which this table belongs.
Days_OldColumn |
DefaultView (inherited from DataTable) | Gets a customized view of the table that may include a filtered view, or a cursor position.
DesignMode (inherited from MarshalByValueComponent) | Gets a value indicating whether the component is currently in design mode.
DisplayExpression (inherited from DataTable) | Gets or sets the expression that returns a value used to represent this table in the user interface.
EffectiveRateColumn |
ExtendedProperties (inherited from DataTable) | Gets the collection of customized user information.
HasErrors (inherited from DataTable) | Gets a value indicating whether there are errors in any of the rows in any of the tables of the DataSet to which the table belongs.
IsInitialized (inherited from DataTable) | Gets a value that indicates whether the DataTable is initialized.
Item |
Locale (inherited from DataTable) | Gets or sets the locale information used to compare strings within the table.
MinimumCapacity (inherited from DataTable) | Gets or sets the initial starting size for this table.
Namespace (inherited from DataTable) | Gets or sets the namespace for the XML representation of the data stored in the DataTable.
NewBaseColumn |
ParentRelations (inherited from DataTable) | Gets the collection of parent relations for this DataTable.
PaymentColumn |
PaymentIndexColumn |
Prefix (inherited from DataTable) | Gets or sets the namespace for the XML representation of the data stored in the DataTable.
PrimaryKey (inherited from DataTable) | Gets or sets an array of columns that function as primary keys for the data table.
Prod_ProdCatIDColumn |
ProductColumn |
ProductTypeColumn |
RemotingFormat (inherited from DataTable) | Gets or sets the serialization format.
Rows (inherited from DataTable) | Gets the collection of rows that belong to this table.
SalesRepIDColumn |
SalesRepNameColumn |
SalesRepTypeColumn |
Site (inherited from DataTable) | Gets or sets an ISite for the DataTable.
SourceEntityColumn |
SourceIDColumn |
TableName (inherited from DataTable) | Gets or sets the name of the DataTable.

Protected Instance Properties

Events (inherited from MarshalByValueComponent) Gets the list of event handlers that are attached to this component.

See Also

CommissionPayments.AdjustmentsDataTable Class | Aptify.Applications.Commissions Namespace


AdjustmentColumn Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.AdjustmentsDataTable.AdjustmentColumn Property

public DataColumn AdjustmentColumn {get;}

See Also

CommissionPayments.AdjustmentsDataTable Class | Aptify.Applications.Commissions Namespace


AdjustmentTypeColumn Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.AdjustmentsDataTable.AdjustmentTypeColumn Property

public DataColumn AdjustmentTypeColumn {get;}

See Also

CommissionPayments.AdjustmentsDataTable Class | Aptify.Applications.Commissions Namespace


BalanceColumn Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.AdjustmentsDataTable.BalanceColumn Property

public DataColumn BalanceColumn {get;}

See Also

CommissionPayments.AdjustmentsDataTable Class | Aptify.Applications.Commissions Namespace


BalanceFactorColumn Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.AdjustmentsDataTable.BalanceFactorColumn Property

public DataColumn BalanceFactorColumn {get;}

See Also

CommissionPayments.AdjustmentsDataTable Class | Aptify.Applications.Commissions Namespace


BaseAdjustmentColumn Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.AdjustmentsDataTable.BaseAdjustmentColumn Property

public DataColumn BaseAdjustmentColumn {get;}

See Also

CommissionPayments.AdjustmentsDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayDetSequenceColumn Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.AdjustmentsDataTable.CommissionPayDetSequenceColumn Property

public DataColumn CommissionPayDetSequenceColumn {get;}

See Also

CommissionPayments.AdjustmentsDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPaymentIDColumn Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.AdjustmentsDataTable.CommissionPaymentIDColumn Property

public DataColumn CommissionPaymentIDColumn {get;}

See Also

CommissionPayments.AdjustmentsDataTable Class | Aptify.Applications.Commissions Namespace


Count Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.AdjustmentsDataTable.Count Property

public Int32 Count {get;}

See Also

CommissionPayments.AdjustmentsDataTable Class | Aptify.Applications.Commissions Namespace


CPSDSequenceColumn Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.AdjustmentsDataTable.CPSDSequenceColumn Property

public DataColumn CPSDSequenceColumn {get;}

See Also

CommissionPayments.AdjustmentsDataTable Class | Aptify.Applications.Commissions Namespace


CurrentBaseColumn Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.AdjustmentsDataTable.CurrentBaseColumn Property

public DataColumn CurrentBaseColumn {get;}

See Also

CommissionPayments.AdjustmentsDataTable Class | Aptify.Applications.Commissions Namespace


Days_OldColumn Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.AdjustmentsDataTable.Days_OldColumn Property

public DataColumn Days_OldColumn {get;}

See Also

CommissionPayments.AdjustmentsDataTable Class | Aptify.Applications.Commissions Namespace


EffectiveRateColumn Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.AdjustmentsDataTable.EffectiveRateColumn Property

public DataColumn EffectiveRateColumn {get;}

See Also

CommissionPayments.AdjustmentsDataTable Class | Aptify.Applications.Commissions Namespace


Item Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.AdjustmentsDataTable.Item Property

public CommissionPayments.AdjustmentsRow this[
Int32 index
] {get;}

See Also

CommissionPayments.AdjustmentsDataTable Class | Aptify.Applications.Commissions Namespace


NewBaseColumn Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.AdjustmentsDataTable.NewBaseColumn Property

public DataColumn NewBaseColumn {get;}

See Also

CommissionPayments.AdjustmentsDataTable Class | Aptify.Applications.Commissions Namespace


PaymentColumn Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.AdjustmentsDataTable.PaymentColumn Property

public DataColumn PaymentColumn {get;}

See Also

CommissionPayments.AdjustmentsDataTable Class | Aptify.Applications.Commissions Namespace


PaymentIndexColumn Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.AdjustmentsDataTable.PaymentIndexColumn Property

public DataColumn PaymentIndexColumn {get;}

See Also

CommissionPayments.AdjustmentsDataTable Class | Aptify.Applications.Commissions Namespace


Prod_ProdCatIDColumn Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.AdjustmentsDataTable.Prod_ProdCatIDColumn Property

public DataColumn Prod_ProdCatIDColumn {get;}

See Also

CommissionPayments.AdjustmentsDataTable Class | Aptify.Applications.Commissions Namespace


ProductColumn Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.AdjustmentsDataTable.ProductColumn Property

public DataColumn ProductColumn {get;}

See Also

CommissionPayments.AdjustmentsDataTable Class | Aptify.Applications.Commissions Namespace


ProductTypeColumn Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.AdjustmentsDataTable.ProductTypeColumn Property

public DataColumn ProductTypeColumn {get;}

See Also

CommissionPayments.AdjustmentsDataTable Class | Aptify.Applications.Commissions Namespace


SalesRepIDColumn Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.AdjustmentsDataTable.SalesRepIDColumn Property

public DataColumn SalesRepIDColumn {get;}

See Also

CommissionPayments.AdjustmentsDataTable Class | Aptify.Applications.Commissions Namespace


SalesRepNameColumn Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.AdjustmentsDataTable.SalesRepNameColumn Property

public DataColumn SalesRepNameColumn {get;}

See Also

CommissionPayments.AdjustmentsDataTable Class | Aptify.Applications.Commissions Namespace


SalesRepTypeColumn Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.AdjustmentsDataTable.SalesRepTypeColumn Property

public DataColumn SalesRepTypeColumn {get;}

See Also

CommissionPayments.AdjustmentsDataTable Class | Aptify.Applications.Commissions Namespace


SourceEntityColumn Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.AdjustmentsDataTable.SourceEntityColumn Property

public DataColumn SourceEntityColumn {get;}

See Also

CommissionPayments.AdjustmentsDataTable Class | Aptify.Applications.Commissions Namespace


SourceIDColumn Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.AdjustmentsDataTable.SourceIDColumn Property

public DataColumn SourceIDColumn {get;}

See Also

CommissionPayments.AdjustmentsDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.AdjustmentsDataTable Methods

The methods of the CommissionPayments.AdjustmentsDataTable class are listed below. For a complete list of CommissionPayments.AdjustmentsDataTable class members, see the CommissionPayments.AdjustmentsDataTable Members topic.

Public Static Methods

GetTypedTableSchema

Public Instance Methods

AcceptChanges (inherited from DataTable) | Commits all the changes made to this table since the last time AcceptChanges was called.
AddAdjustmentsRow | Overloaded.
BeginInit (inherited from DataTable) | Begins the initialization of a DataTable that is used on a form or used by another component. The initialization occurs at runtime.
BeginLoadData (inherited from DataTable) | Turns off notifications, index maintenance, and constraints while loading data.
Clear (inherited from DataTable) | Clears the DataTable of all data.
Clone |
Compute (inherited from DataTable) | Computes the given expression on the current rows that pass the filter criteria.
Copy (inherited from DataTable) | Copies both the structure and data for this DataTable.
CreateDataReader (inherited from DataTable) | Returns a DataTableReader corresponding to the data within this DataTable.
Dispose (inherited from MarshalByValueComponent) | Overloaded. Releases all resources used by the MarshalByValueComponent.
EndInit (inherited from DataTable) | Ends the initialization of a DataTable that is used on a form or used by another component. The initialization occurs at runtime.
EndLoadData (inherited from DataTable) | Turns on notifications, index maintenance, and constraints after loading data.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetChanges (inherited from DataTable) | Overloaded. Gets a copy of the DataTable that contains all changes made to it since it was loaded or AcceptChanges was last called.
GetEnumerator |
GetErrors (inherited from DataTable) | Gets an array of DataRow objects that contain errors.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from DataTable) | Populates a serialization information object with the data needed to serialize the DataTable.
GetService (inherited from MarshalByValueComponent) | Gets the implementer of the IServiceProvider.
GetType (inherited from Object) | Gets the Type of the current instance.
ImportRow (inherited from DataTable) | Copies a DataRow into a DataTable, preserving any property settings, as well as original and current values.
Load (inherited from DataTable) | Overloaded. Fills a DataTable with values from a data source using the supplied IDataReader. If the DataTable already contains rows, the incoming data from the data source is merged with the existing rows.
LoadDataRow (inherited from DataTable) | Overloaded. Finds and updates a specific row. If no matching row is found, a new row is created using the given values.
Merge (inherited from DataTable) | Overloaded. Merge the specified DataTable with the current DataTable.
NewAdjustmentsRow |
NewRow (inherited from DataTable) | Creates a new DataRow with the same schema as the table.
ReadXml (inherited from DataTable) | Overloaded. Reads XML schema and data into the DataTable using the specified Stream.
ReadXmlSchema (inherited from DataTable) | Overloaded. Reads an XML schema into the DataTable using the specified stream.
RejectChanges (inherited from DataTable) | Rolls back all changes that have been made to the table since it was loaded, or the last time AcceptChanges was called.
RemoveAdjustmentsRow |
Reset (inherited from DataTable) | Resets the DataTable to its original state.
Select (inherited from DataTable) | Overloaded. Gets an array of all DataRow objects.
ToString (inherited from DataTable) | Gets the TableName and DisplayExpression, if there is one as a concatenated string.
WriteXml (inherited from DataTable) | Overloaded. Writes the current data, and optionally the schema, for the DataTable using the specified TextWriter and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. To save the data for the table and all its descendants, set the writeHierarchy parameter to true.
WriteXmlSchema (inherited from DataTable) | Overloaded. Writes the current data structure of the DataTable as an XML schema to the specified stream.

Protected Instance Methods

CreateInstance |
Dispose (inherited from MarshalByValueComponent) | Overloaded. Releases the unmanaged resources used by the MarshalByValueComponent and optionally releases the managed resources.
Finalize (inherited from MarshalByValueComponent) | [To be supplied.]
GetRowType |
GetSchema (inherited from DataTable) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NewRowFromBuilder |
OnPropertyChanging (inherited from DataTable) | Raises the PropertyChanging event.
OnRemoveColumn (inherited from DataTable) | Notifies the DataTable that a DataColumn is being removed.
OnRowChanged |
OnRowChanging |
OnRowDeleted |
OnRowDeleting |
OnTableCleared (inherited from DataTable) | Raises the TableCleared event.
OnTableClearing (inherited from DataTable) | Raises the TableClearing event.
OnTableNewRow (inherited from DataTable) | Raises the TableNewRow event.
ReadXmlSerializable (inherited from DataTable) |

Protected Internal Instance Methods

NewRowArray (inherited from DataTable) |
OnColumnChanged (inherited from DataTable) | Raises the ColumnChanged event.
OnColumnChanging (inherited from DataTable) | Raises the ColumnChanging event.

See Also

CommissionPayments.AdjustmentsDataTable Class | Aptify.Applications.Commissions Namespace


AddAdjustmentsRow Method

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.AdjustmentsDataTable.AddAdjustmentsRow Method

Overload List

public void AddAdjustmentsRow(CommissionPayments.AdjustmentsRow);

public AdjustmentsRow AddAdjustmentsRow(String,String,String,String,Int64,Decimal,Decimal,Int64,Decimal,Decimal,Int32,Double,Int32,Int32,Int32,String,String,Int64,String,Decimal,Decimal,Int64);

See Also

CommissionPayments.AdjustmentsDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.AdjustmentsDataTable.AddAdjustmentsRow Method (AdjustmentsRow)

public void AddAdjustmentsRow(
CommissionPayments.AdjustmentsRow row
);

See Also

CommissionPayments.AdjustmentsDataTable Class | Aptify.Applications.Commissions Namespace | CommissionPayments.AdjustmentsDataTable.AddAdjustmentsRow Overload List


CommissionPayments.AdjustmentsDataTable.AddAdjustmentsRow Method (String, String, String, String, Int64, Decimal, Decimal, Int64, Decimal, Decimal, Int32, Double, Int32, Int32, Int32, String, String, Int64, String, Decimal, Decimal, Int64)

public AdjustmentsRow AddAdjustmentsRow(
String Payment,
String SalesRepName,
String Product,
String SourceEntity,
Int64 SourceID,
Decimal CurrentBase,
Decimal Balance,
Int64 Days_Old,
Decimal BaseAdjustment,
Decimal NewBase,
Int32 PaymentIndex,
Double BalanceFactor,
Int32 AdjustmentType,
Int32 CommissionPayDetSequence,
Int32 CPSDSequence,
String CommissionPaymentID,
String ProductType,
Int64 Prod_ProdCatID,
String SalesRepType,
Decimal Adjustment,
Decimal EffectiveRate,
Int64 SalesRepID
);

See Also

CommissionPayments.AdjustmentsDataTable Class | Aptify.Applications.Commissions Namespace | CommissionPayments.AdjustmentsDataTable.AddAdjustmentsRow Overload List


CommissionPayments.AdjustmentsDataTable.Clone Method

public override DataTable Clone();

See Also

CommissionPayments.AdjustmentsDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.AdjustmentsDataTable.CreateInstance Method

protected override DataTable CreateInstance();

See Also

CommissionPayments.AdjustmentsDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.AdjustmentsDataTable.GetEnumerator Method

public virtual IEnumerator GetEnumerator();

Implements

IEnumerable.

See Also

CommissionPayments.AdjustmentsDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.AdjustmentsDataTable.GetRowType Method

protected override Type GetRowType();

See Also

CommissionPayments.AdjustmentsDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.AdjustmentsDataTable.GetTypedTableSchema Method

public static XmlSchemaComplexType GetTypedTableSchema(
XmlSchemaSet xs
);

See Also

CommissionPayments.AdjustmentsDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.AdjustmentsDataTable.NewAdjustmentsRow Method

public AdjustmentsRow NewAdjustmentsRow();

See Also

CommissionPayments.AdjustmentsDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.AdjustmentsDataTable.NewRowFromBuilder Method

protected override DataRow NewRowFromBuilder(
DataRowBuilder builder
);

See Also

CommissionPayments.AdjustmentsDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.AdjustmentsDataTable.OnRowChanged Method

protected override void OnRowChanged(
DataRowChangeEventArgs e
);

See Also

CommissionPayments.AdjustmentsDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.AdjustmentsDataTable.OnRowChanging Method

protected override void OnRowChanging(
DataRowChangeEventArgs e
);

See Also

CommissionPayments.AdjustmentsDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.AdjustmentsDataTable.OnRowDeleted Method

protected override void OnRowDeleted(
DataRowChangeEventArgs e
);

See Also

CommissionPayments.AdjustmentsDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.AdjustmentsDataTable.OnRowDeleting Method

protected override void OnRowDeleting(
DataRowChangeEventArgs e
);

See Also

CommissionPayments.AdjustmentsDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.AdjustmentsDataTable.RemoveAdjustmentsRow Method

public void RemoveAdjustmentsRow(
CommissionPayments.AdjustmentsRow row
);

See Also

CommissionPayments.AdjustmentsDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.AdjustmentsDataTable Events

The events of the CommissionPayments.AdjustmentsDataTable class are listed below. For a complete list of CommissionPayments.AdjustmentsDataTable class members, see the CommissionPayments.AdjustmentsDataTable Members topic.

Public Instance Events

AdjustmentsRowChanged |
AdjustmentsRowChanging |
AdjustmentsRowDeleted |
AdjustmentsRowDeleting |
ColumnChanged (inherited from DataTable) | Occurs after a value has been changed for the specified DataColumn in a DataRow.
ColumnChanging (inherited from DataTable) | Occurs when a value is being changed for the specified DataColumn in a DataRow.
Disposed (inherited from MarshalByValueComponent) | Adds an event handler to listen to the Disposed event on the component.
Initialized (inherited from DataTable) | Occurs after the DataTable is initialized.
RowChanged (inherited from DataTable) | Occurs after a DataRow has been changed successfully.
RowChanging (inherited from DataTable) | Occurs when a DataRow is changing.
RowDeleted (inherited from DataTable) | Occurs after a row in the table has been deleted.
RowDeleting (inherited from DataTable) | Occurs before a row in the table is about to be deleted.
TableCleared (inherited from DataTable) | Occurs after a DataTable is cleared.
TableClearing (inherited from DataTable) | Occurs when a DataTable is cleared.
TableNewRow (inherited from DataTable) | Occurs when a new DataRow is inserted.

See Also

CommissionPayments.AdjustmentsDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.AdjustmentsDataTable.CommissionPayments.AdjustmentsRowChangeEventHandler Event

public event CommissionPayments.AdjustmentsRowChangeEventHandler AdjustmentsRowChanged;

See Also

CommissionPayments.AdjustmentsDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.AdjustmentsDataTable.CommissionPayments.AdjustmentsRowChangeEventHandler Event

public event CommissionPayments.AdjustmentsRowChangeEventHandler AdjustmentsRowChanging;

See Also

CommissionPayments.AdjustmentsDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.AdjustmentsDataTable.CommissionPayments.AdjustmentsRowChangeEventHandler Event

public event CommissionPayments.AdjustmentsRowChangeEventHandler AdjustmentsRowDeleted;

See Also

CommissionPayments.AdjustmentsDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.AdjustmentsDataTable.CommissionPayments.AdjustmentsRowChangeEventHandler Event

public event CommissionPayments.AdjustmentsRowChangeEventHandler AdjustmentsRowDeleting;

See Also

CommissionPayments.AdjustmentsDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.AdjustmentsRow Class

Represents strongly named DataRow class.

For a list of all members of this type, see CommissionPayments.AdjustmentsRow Members.

System.Object
DataRow
CommissionPayments.AdjustmentsRow

public class CommissionPayments.AdjustmentsRow : DataRow

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Commissions

Assembly: CommissionPaymentWizard (in CommissionPaymentWizard.dll)

See Also

CommissionPayments.AdjustmentsRow Members | Aptify.Applications.Commissions Namespace


CommissionPayments.AdjustmentsRow Members

CommissionPayments.AdjustmentsRow overview

Public Instance Properties

Adjustment |
AdjustmentType |
Balance |
BalanceFactor |
BaseAdjustment |
CommissionPayDetSequence |
CommissionPaymentID |
CPSDSequence |
CurrentBase |
Days_Old |
EffectiveRate |
HasErrors (inherited from DataRow) | Gets a value that indicates whether there are errors in a row.
Item (inherited from DataRow) | Gets or sets the data stored in the column specified by index.
Item (inherited from DataRow) | Gets or sets the data stored in the column specified by name.
Item (inherited from DataRow) | Gets or sets the data stored in the specified DataColumn.
Item (inherited from DataRow) | Gets the data stored in the column, specified by index and version of the data to retrieve.
Item (inherited from DataRow) | Gets the specified version of data stored in the named column.
Item (inherited from DataRow) | Gets the specified version of data stored in the specified DataColumn.
ItemArray (inherited from DataRow) | Gets or sets all the values for this row through an array.
NewBase |
Payment |
PaymentIndex |
Prod_ProdCatID |
Product |
ProductType |
RowError (inherited from DataRow) | Gets or sets the custom error description for a row.
RowState (inherited from DataRow) | Gets the current state of the row with regard to its relationship to the DataRowCollection.
SalesRepID |
SalesRepName |
SalesRepType |
SourceEntity |
SourceID |
Table (inherited from DataRow) | Gets the DataTable for which this row has a schema.

Public Instance Methods

AcceptChanges (inherited from DataRow) | Commits all the changes made to this row since the last time AcceptChanges was called.
BeginEdit (inherited from DataRow) | Starts an edit operation on a DataRow object.
CancelEdit (inherited from DataRow) | Cancels the current edit on the row.
ClearErrors (inherited from DataRow) | Clears the errors for the row. This includes the RowError and errors set with SetColumnError.
Delete (inherited from DataRow) | Deletes the DataRow.
EndEdit (inherited from DataRow) | Ends the edit occurring on the row.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetChildRows (inherited from DataRow) | Overloaded. Gets the child rows of a DataRow using the specified RelationName of a DataRelation.
GetColumnError (inherited from DataRow) | Overloaded. Gets the error description for the column specified by index.
GetColumnsInError (inherited from DataRow) | Gets an array of columns that have errors.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetParentRow (inherited from DataRow) | Overloaded. Gets the parent row of a DataRow using the specified RelationName of a DataRelation.
GetParentRows (inherited from DataRow) | Overloaded. Gets the parent rows of a DataRow using the specified RelationName of a DataRelation.
GetType (inherited from Object) | Gets the Type of the current instance.
HasVersion (inherited from DataRow) | Gets a value that indicates whether a specified version exists.
IsAdjustmentNull |
IsAdjustmentTypeNull |
IsBalanceFactorNull |
IsBalanceNull |
IsBaseAdjustmentNull |
IsCommissionPayDetSequenceNull |
IsCommissionPaymentIDNull |
IsCPSDSequenceNull |
IsCurrentBaseNull |
IsDays_OldNull |
IsEffectiveRateNull |
IsNewBaseNull |
IsNull (inherited from DataRow) | Overloaded. Gets a value that indicates whether the column at the specified index contains a null value.
IsPaymentIndexNull |
IsPaymentNull |
IsProd_ProdCatIDNull |
IsProductNull |
IsProductTypeNull |
IsSalesRepIDNull |
IsSalesRepNameNull |
IsSalesRepTypeNull |
IsSourceEntityNull |
IsSourceIDNull |
RejectChanges (inherited from DataRow) | Rejects all changes made to the row since AcceptChanges was last called.
SetAdded (inherited from DataRow) | Changes the Rowstate of a DataRow to Added.
SetAdjustmentNull |
SetAdjustmentTypeNull |
SetBalanceFactorNull |
SetBalanceNull |
SetBaseAdjustmentNull |
SetColumnError (inherited from DataRow) | Overloaded. Sets the error description for a column specified by index.
SetCommissionPayDetSequenceNull |
SetCommissionPaymentIDNull |
SetCPSDSequenceNull |
SetCurrentBaseNull |
SetDays_OldNull |
SetEffectiveRateNull |
SetModified (inherited from DataRow) | Changes the Rowstate of a DataRow to Modified.
SetNewBaseNull |
SetParentRow (inherited from DataRow) | Overloaded. Sets the parent row of a DataRow with specified new parent DataRow.
SetPaymentIndexNull |
SetPaymentNull |
SetProd_ProdCatIDNull |
SetProductNull |
SetProductTypeNull |
SetSalesRepIDNull |
SetSalesRepNameNull |
SetSalesRepTypeNull |
SetSourceEntityNull |
SetSourceIDNull |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetNull (inherited from DataRow) | Sets the value of the specified DataColumn to a null value.

See Also

CommissionPayments.AdjustmentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.AdjustmentsRow Properties

The properties of the CommissionPayments.AdjustmentsRow class are listed below. For a complete list of CommissionPayments.AdjustmentsRow class members, see the CommissionPayments.AdjustmentsRow Members topic.

Public Instance Properties

Adjustment |
AdjustmentType |
Balance |
BalanceFactor |
BaseAdjustment |
CommissionPayDetSequence |
CommissionPaymentID |
CPSDSequence |
CurrentBase |
Days_Old |
EffectiveRate |
HasErrors (inherited from DataRow) | Gets a value that indicates whether there are errors in a row.
Item (inherited from DataRow) | Gets or sets the data stored in the column specified by index.
Item (inherited from DataRow) | Gets or sets the data stored in the column specified by name.
Item (inherited from DataRow) | Gets or sets the data stored in the specified DataColumn.
Item (inherited from DataRow) | Gets the data stored in the column, specified by index and version of the data to retrieve.
Item (inherited from DataRow) | Gets the specified version of data stored in the named column.
Item (inherited from DataRow) | Gets the specified version of data stored in the specified DataColumn.
ItemArray (inherited from DataRow) | Gets or sets all the values for this row through an array.
NewBase |
Payment |
PaymentIndex |
Prod_ProdCatID |
Product |
ProductType |
RowError (inherited from DataRow) | Gets or sets the custom error description for a row.
RowState (inherited from DataRow) | Gets the current state of the row with regard to its relationship to the DataRowCollection.
SalesRepID |
SalesRepName |
SalesRepType |
SourceEntity |
SourceID |
Table (inherited from DataRow) | Gets the DataTable for which this row has a schema.

See Also

CommissionPayments.AdjustmentsRow Class | Aptify.Applications.Commissions Namespace


Adjustment Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.AdjustmentsRow.Adjustment Property

public Decimal Adjustment {get; set;}

See Also

CommissionPayments.AdjustmentsRow Class | Aptify.Applications.Commissions Namespace


AdjustmentType Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.AdjustmentsRow.AdjustmentType Property

public Int32 AdjustmentType {get; set;}

See Also

CommissionPayments.AdjustmentsRow Class | Aptify.Applications.Commissions Namespace


Balance Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.AdjustmentsRow.Balance Property

public Decimal Balance {get; set;}

See Also

CommissionPayments.AdjustmentsRow Class | Aptify.Applications.Commissions Namespace


BalanceFactor Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.AdjustmentsRow.BalanceFactor Property

public Double BalanceFactor {get; set;}

See Also

CommissionPayments.AdjustmentsRow Class | Aptify.Applications.Commissions Namespace


BaseAdjustment Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.AdjustmentsRow.BaseAdjustment Property

public Decimal BaseAdjustment {get; set;}

See Also

CommissionPayments.AdjustmentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayDetSequence Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.AdjustmentsRow.CommissionPayDetSequence Property

public Int32 CommissionPayDetSequence {get; set;}

See Also

CommissionPayments.AdjustmentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPaymentID Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.AdjustmentsRow.CommissionPaymentID Property

public String CommissionPaymentID {get; set;}

See Also

CommissionPayments.AdjustmentsRow Class | Aptify.Applications.Commissions Namespace


CPSDSequence Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.AdjustmentsRow.CPSDSequence Property

public Int32 CPSDSequence {get; set;}

See Also

CommissionPayments.AdjustmentsRow Class | Aptify.Applications.Commissions Namespace


CurrentBase Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.AdjustmentsRow.CurrentBase Property

public Decimal CurrentBase {get; set;}

See Also

CommissionPayments.AdjustmentsRow Class | Aptify.Applications.Commissions Namespace


Days_Old Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.AdjustmentsRow.Days_Old Property

public Int64 Days_Old {get; set;}

See Also

CommissionPayments.AdjustmentsRow Class | Aptify.Applications.Commissions Namespace


EffectiveRate Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.AdjustmentsRow.EffectiveRate Property

public Decimal EffectiveRate {get; set;}

See Also

CommissionPayments.AdjustmentsRow Class | Aptify.Applications.Commissions Namespace


NewBase Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.AdjustmentsRow.NewBase Property

public Decimal NewBase {get; set;}

See Also

CommissionPayments.AdjustmentsRow Class | Aptify.Applications.Commissions Namespace


Payment Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.AdjustmentsRow.Payment Property

public String Payment {get; set;}

See Also

CommissionPayments.AdjustmentsRow Class | Aptify.Applications.Commissions Namespace


PaymentIndex Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.AdjustmentsRow.PaymentIndex Property

public Int32 PaymentIndex {get; set;}

See Also

CommissionPayments.AdjustmentsRow Class | Aptify.Applications.Commissions Namespace


Prod_ProdCatID Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.AdjustmentsRow.Prod_ProdCatID Property

public Int64 Prod_ProdCatID {get; set;}

See Also

CommissionPayments.AdjustmentsRow Class | Aptify.Applications.Commissions Namespace


Product Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.AdjustmentsRow.Product Property

public String Product {get; set;}

See Also

CommissionPayments.AdjustmentsRow Class | Aptify.Applications.Commissions Namespace


ProductType Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.AdjustmentsRow.ProductType Property

public String ProductType {get; set;}

See Also

CommissionPayments.AdjustmentsRow Class | Aptify.Applications.Commissions Namespace


SalesRepID Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.AdjustmentsRow.SalesRepID Property

public Int64 SalesRepID {get; set;}

See Also

CommissionPayments.AdjustmentsRow Class | Aptify.Applications.Commissions Namespace


SalesRepName Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.AdjustmentsRow.SalesRepName Property

public String SalesRepName {get; set;}

See Also

CommissionPayments.AdjustmentsRow Class | Aptify.Applications.Commissions Namespace


SalesRepType Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.AdjustmentsRow.SalesRepType Property

public String SalesRepType {get; set;}

See Also

CommissionPayments.AdjustmentsRow Class | Aptify.Applications.Commissions Namespace


SourceEntity Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.AdjustmentsRow.SourceEntity Property

public String SourceEntity {get; set;}

See Also

CommissionPayments.AdjustmentsRow Class | Aptify.Applications.Commissions Namespace


SourceID Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.AdjustmentsRow.SourceID Property

public Int64 SourceID {get; set;}

See Also

CommissionPayments.AdjustmentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.AdjustmentsRow Methods

The methods of the CommissionPayments.AdjustmentsRow class are listed below. For a complete list of CommissionPayments.AdjustmentsRow class members, see the CommissionPayments.AdjustmentsRow Members topic.

Public Instance Methods

AcceptChanges (inherited from DataRow) | Commits all the changes made to this row since the last time AcceptChanges was called.
BeginEdit (inherited from DataRow) | Starts an edit operation on a DataRow object.
CancelEdit (inherited from DataRow) | Cancels the current edit on the row.
ClearErrors (inherited from DataRow) | Clears the errors for the row. This includes the RowError and errors set with SetColumnError.
Delete (inherited from DataRow) | Deletes the DataRow.
EndEdit (inherited from DataRow) | Ends the edit occurring on the row.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetChildRows (inherited from DataRow) | Overloaded. Gets the child rows of a DataRow using the specified RelationName of a DataRelation.
GetColumnError (inherited from DataRow) | Overloaded. Gets the error description for the column specified by index.
GetColumnsInError (inherited from DataRow) | Gets an array of columns that have errors.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetParentRow (inherited from DataRow) | Overloaded. Gets the parent row of a DataRow using the specified RelationName of a DataRelation.
GetParentRows (inherited from DataRow) | Overloaded. Gets the parent rows of a DataRow using the specified RelationName of a DataRelation.
GetType (inherited from Object) | Gets the Type of the current instance.
HasVersion (inherited from DataRow) | Gets a value that indicates whether a specified version exists.
IsAdjustmentNull |
IsAdjustmentTypeNull |
IsBalanceFactorNull |
IsBalanceNull |
IsBaseAdjustmentNull |
IsCommissionPayDetSequenceNull |
IsCommissionPaymentIDNull |
IsCPSDSequenceNull |
IsCurrentBaseNull |
IsDays_OldNull |
IsEffectiveRateNull |
IsNewBaseNull |
IsNull (inherited from DataRow) | Overloaded. Gets a value that indicates whether the column at the specified index contains a null value.
IsPaymentIndexNull |
IsPaymentNull |
IsProd_ProdCatIDNull |
IsProductNull |
IsProductTypeNull |
IsSalesRepIDNull |
IsSalesRepNameNull |
IsSalesRepTypeNull |
IsSourceEntityNull |
IsSourceIDNull |
RejectChanges (inherited from DataRow) | Rejects all changes made to the row since AcceptChanges was last called.
SetAdded (inherited from DataRow) | Changes the Rowstate of a DataRow to Added.
SetAdjustmentNull |
SetAdjustmentTypeNull |
SetBalanceFactorNull |
SetBalanceNull |
SetBaseAdjustmentNull |
SetColumnError (inherited from DataRow) | Overloaded. Sets the error description for a column specified by index.
SetCommissionPayDetSequenceNull |
SetCommissionPaymentIDNull |
SetCPSDSequenceNull |
SetCurrentBaseNull |
SetDays_OldNull |
SetEffectiveRateNull |
SetModified (inherited from DataRow) | Changes the Rowstate of a DataRow to Modified.
SetNewBaseNull |
SetParentRow (inherited from DataRow) | Overloaded. Sets the parent row of a DataRow with specified new parent DataRow.
SetPaymentIndexNull |
SetPaymentNull |
SetProd_ProdCatIDNull |
SetProductNull |
SetProductTypeNull |
SetSalesRepIDNull |
SetSalesRepNameNull |
SetSalesRepTypeNull |
SetSourceEntityNull |
SetSourceIDNull |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetNull (inherited from DataRow) | Sets the value of the specified DataColumn to a null value.

See Also

CommissionPayments.AdjustmentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.AdjustmentsRow.IsAdjustmentNull Method

public bool IsAdjustmentNull();

See Also

CommissionPayments.AdjustmentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.AdjustmentsRow.IsAdjustmentTypeNull Method

public bool IsAdjustmentTypeNull();

See Also

CommissionPayments.AdjustmentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.AdjustmentsRow.IsBalanceFactorNull Method

public bool IsBalanceFactorNull();

See Also

CommissionPayments.AdjustmentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.AdjustmentsRow.IsBalanceNull Method

public bool IsBalanceNull();

See Also

CommissionPayments.AdjustmentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.AdjustmentsRow.IsBaseAdjustmentNull Method

public bool IsBaseAdjustmentNull();

See Also

CommissionPayments.AdjustmentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.AdjustmentsRow.IsCommissionPayDetSequenceNull Method

public bool IsCommissionPayDetSequenceNull();

See Also

CommissionPayments.AdjustmentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.AdjustmentsRow.IsCommissionPaymentIDNull Method

public bool IsCommissionPaymentIDNull();

See Also

CommissionPayments.AdjustmentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.AdjustmentsRow.IsCPSDSequenceNull Method

public bool IsCPSDSequenceNull();

See Also

CommissionPayments.AdjustmentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.AdjustmentsRow.IsCurrentBaseNull Method

public bool IsCurrentBaseNull();

See Also

CommissionPayments.AdjustmentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.AdjustmentsRow.IsDays_OldNull Method

public bool IsDays_OldNull();

See Also

CommissionPayments.AdjustmentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.AdjustmentsRow.IsEffectiveRateNull Method

public bool IsEffectiveRateNull();

See Also

CommissionPayments.AdjustmentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.AdjustmentsRow.IsNewBaseNull Method

public bool IsNewBaseNull();

See Also

CommissionPayments.AdjustmentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.AdjustmentsRow.IsPaymentIndexNull Method

public bool IsPaymentIndexNull();

See Also

CommissionPayments.AdjustmentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.AdjustmentsRow.IsPaymentNull Method

public bool IsPaymentNull();

See Also

CommissionPayments.AdjustmentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.AdjustmentsRow.IsProd_ProdCatIDNull Method

public bool IsProd_ProdCatIDNull();

See Also

CommissionPayments.AdjustmentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.AdjustmentsRow.IsProductNull Method

public bool IsProductNull();

See Also

CommissionPayments.AdjustmentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.AdjustmentsRow.IsProductTypeNull Method

public bool IsProductTypeNull();

See Also

CommissionPayments.AdjustmentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.AdjustmentsRow.IsSalesRepIDNull Method

public bool IsSalesRepIDNull();

See Also

CommissionPayments.AdjustmentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.AdjustmentsRow.IsSalesRepNameNull Method

public bool IsSalesRepNameNull();

See Also

CommissionPayments.AdjustmentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.AdjustmentsRow.IsSalesRepTypeNull Method

public bool IsSalesRepTypeNull();

See Also

CommissionPayments.AdjustmentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.AdjustmentsRow.IsSourceEntityNull Method

public bool IsSourceEntityNull();

See Also

CommissionPayments.AdjustmentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.AdjustmentsRow.IsSourceIDNull Method

public bool IsSourceIDNull();

See Also

CommissionPayments.AdjustmentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.AdjustmentsRow.SetAdjustmentNull Method

public void SetAdjustmentNull();

See Also

CommissionPayments.AdjustmentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.AdjustmentsRow.SetAdjustmentTypeNull Method

public void SetAdjustmentTypeNull();

See Also

CommissionPayments.AdjustmentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.AdjustmentsRow.SetBalanceFactorNull Method

public void SetBalanceFactorNull();

See Also

CommissionPayments.AdjustmentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.AdjustmentsRow.SetBalanceNull Method

public void SetBalanceNull();

See Also

CommissionPayments.AdjustmentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.AdjustmentsRow.SetBaseAdjustmentNull Method

public void SetBaseAdjustmentNull();

See Also

CommissionPayments.AdjustmentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.AdjustmentsRow.SetCommissionPayDetSequenceNull Method

public void SetCommissionPayDetSequenceNull();

See Also

CommissionPayments.AdjustmentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.AdjustmentsRow.SetCommissionPaymentIDNull Method

public void SetCommissionPaymentIDNull();

See Also

CommissionPayments.AdjustmentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.AdjustmentsRow.SetCPSDSequenceNull Method

public void SetCPSDSequenceNull();

See Also

CommissionPayments.AdjustmentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.AdjustmentsRow.SetCurrentBaseNull Method

public void SetCurrentBaseNull();

See Also

CommissionPayments.AdjustmentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.AdjustmentsRow.SetDays_OldNull Method

public void SetDays_OldNull();

See Also

CommissionPayments.AdjustmentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.AdjustmentsRow.SetEffectiveRateNull Method

public void SetEffectiveRateNull();

See Also

CommissionPayments.AdjustmentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.AdjustmentsRow.SetNewBaseNull Method

public void SetNewBaseNull();

See Also

CommissionPayments.AdjustmentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.AdjustmentsRow.SetPaymentIndexNull Method

public void SetPaymentIndexNull();

See Also

CommissionPayments.AdjustmentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.AdjustmentsRow.SetPaymentNull Method

public void SetPaymentNull();

See Also

CommissionPayments.AdjustmentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.AdjustmentsRow.SetProd_ProdCatIDNull Method

public void SetProd_ProdCatIDNull();

See Also

CommissionPayments.AdjustmentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.AdjustmentsRow.SetProductNull Method

public void SetProductNull();

See Also

CommissionPayments.AdjustmentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.AdjustmentsRow.SetProductTypeNull Method

public void SetProductTypeNull();

See Also

CommissionPayments.AdjustmentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.AdjustmentsRow.SetSalesRepIDNull Method

public void SetSalesRepIDNull();

See Also

CommissionPayments.AdjustmentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.AdjustmentsRow.SetSalesRepNameNull Method

public void SetSalesRepNameNull();

See Also

CommissionPayments.AdjustmentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.AdjustmentsRow.SetSalesRepTypeNull Method

public void SetSalesRepTypeNull();

See Also

CommissionPayments.AdjustmentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.AdjustmentsRow.SetSourceEntityNull Method

public void SetSourceEntityNull();

See Also

CommissionPayments.AdjustmentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.AdjustmentsRow.SetSourceIDNull Method

public void SetSourceIDNull();

See Also

CommissionPayments.AdjustmentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.AdjustmentsRowChangeEvent Class

Row event argument class

For a list of all members of this type, see CommissionPayments.AdjustmentsRowChangeEvent Members.

System.Object
EventArgs
CommissionPayments.AdjustmentsRowChangeEvent

public class CommissionPayments.AdjustmentsRowChangeEvent : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Commissions

Assembly: CommissionPaymentWizard (in CommissionPaymentWizard.dll)

See Also

CommissionPayments.AdjustmentsRowChangeEvent Members | Aptify.Applications.Commissions Namespace


CommissionPayments.AdjustmentsRowChangeEvent Members

CommissionPayments.AdjustmentsRowChangeEvent overview

Public Instance Constructors

CommissionPayments.AdjustmentsRowChangeEvent Constructor

Public Instance Properties

Action
Row

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CommissionPayments.AdjustmentsRowChangeEvent Class | Aptify.Applications.Commissions Namespace


CommissionPayments.AdjustmentsRowChangeEvent Constructor

public CommissionPayments.AdjustmentsRowChangeEvent(
CommissionPayments.AdjustmentsRow row,
DataRowAction action
);

See Also

CommissionPayments.AdjustmentsRowChangeEvent Class | Aptify.Applications.Commissions Namespace


CommissionPayments.AdjustmentsRowChangeEvent Properties

The properties of the CommissionPayments.AdjustmentsRowChangeEvent class are listed below. For a complete list of CommissionPayments.AdjustmentsRowChangeEvent class members, see the CommissionPayments.AdjustmentsRowChangeEvent Members topic.

Public Instance Properties

Action
Row

See Also

CommissionPayments.AdjustmentsRowChangeEvent Class | Aptify.Applications.Commissions Namespace


Action Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.AdjustmentsRowChangeEvent.Action Property

public DataRowAction Action {get;}

See Also

CommissionPayments.AdjustmentsRowChangeEvent Class | Aptify.Applications.Commissions Namespace


Row Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.AdjustmentsRowChangeEvent.Row Property

public CommissionPayments.AdjustmentsRow Row {get;}

See Also

CommissionPayments.AdjustmentsRowChangeEvent Class | Aptify.Applications.Commissions Namespace


CommissionPayments.AdjustmentsRowChangeEventHandler Delegate

public delegate void CommissionPayments.AdjustmentsRowChangeEventHandler(
Object sender,
CommissionPayments.AdjustmentsRowChangeEvent e
);

Requirements

Namespace: Aptify.Applications.Commissions

Assembly: CommissionPaymentWizard (in CommissionPaymentWizard.dll)

See Also

Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentGroupsDataTable Class

Represents the strongly named DataTable class.

For a list of all members of this type, see CommissionPayments.PaymentGroupsDataTable Members.

System.Object
MarshalByValueComponent
DataTable
CommissionPayments.PaymentGroupsDataTable

public class CommissionPayments.PaymentGroupsDataTable : DataTable, IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Commissions

Assembly: CommissionPaymentWizard (in CommissionPaymentWizard.dll)

See Also

CommissionPayments.PaymentGroupsDataTable Members | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentGroupsDataTable Members

CommissionPayments.PaymentGroupsDataTable overview

Public Static Methods

GetTypedTableSchema

Public Instance Constructors

CommissionPayments.PaymentGroupsDataTable Overloaded. Initializes a new instance of the CommissionPayments.PaymentGroupsDataTable class.

Public Instance Properties

CaseSensitive (inherited from DataTable) | Indicates whether string comparisons within the table are case-sensitive.
ChildRelations (inherited from DataTable) | Gets the collection of child relations for this DataTable.
Columns (inherited from DataTable) | Gets the collection of columns that belong to this table.
Constraints (inherited from DataTable) | Gets the collection of constraints maintained by this table.
Container (inherited from MarshalByValueComponent) | Gets the container for the component.
Count |
DataSet (inherited from DataTable) | Gets the DataSet to which this table belongs.
DefaultView (inherited from DataTable) | Gets a customized view of the table that may include a filtered view, or a cursor position.
DesignMode (inherited from MarshalByValueComponent) | Gets a value indicating whether the component is currently in design mode.
DisplayExpression (inherited from DataTable) | Gets or sets the expression that returns a value used to represent this table in the user interface.
ExtendedProperties (inherited from DataTable) | Gets the collection of customized user information.
HasErrors (inherited from DataTable) | Gets a value indicating whether there are errors in any of the rows in any of the tables of the DataSet to which the table belongs.
IDColumn |
IsInitialized (inherited from DataTable) | Gets a value that indicates whether the DataTable is initialized.
Item |
Locale (inherited from DataTable) | Gets or sets the locale information used to compare strings within the table.
MinimumCapacity (inherited from DataTable) | Gets or sets the initial starting size for this table.
Namespace (inherited from DataTable) | Gets or sets the namespace for the XML representation of the data stored in the DataTable.
ParentRelations (inherited from DataTable) | Gets the collection of parent relations for this DataTable.
PayeeIDColumn |
PayeeNameColumn |
PayeeTypeColumn |
PaymentIDColumn |
Prefix (inherited from DataTable) | Gets or sets the namespace for the XML representation of the data stored in the DataTable.
PrimaryKey (inherited from DataTable) | Gets or sets an array of columns that function as primary keys for the data table.
RemotingFormat (inherited from DataTable) | Gets or sets the serialization format.
Rows (inherited from DataTable) | Gets the collection of rows that belong to this table.
Site (inherited from DataTable) | Gets or sets an ISite for the DataTable.
TableName (inherited from DataTable) | Gets or sets the name of the DataTable.

Public Instance Methods

AcceptChanges (inherited from DataTable) | Commits all the changes made to this table since the last time AcceptChanges was called.
AddPaymentGroupsRow | Overloaded.
BeginInit (inherited from DataTable) | Begins the initialization of a DataTable that is used on a form or used by another component. The initialization occurs at runtime.
BeginLoadData (inherited from DataTable) | Turns off notifications, index maintenance, and constraints while loading data.
Clear (inherited from DataTable) | Clears the DataTable of all data.
Clone |
Compute (inherited from DataTable) | Computes the given expression on the current rows that pass the filter criteria.
Copy (inherited from DataTable) | Copies both the structure and data for this DataTable.
CreateDataReader (inherited from DataTable) | Returns a DataTableReader corresponding to the data within this DataTable.
Dispose (inherited from MarshalByValueComponent) | Overloaded. Releases all resources used by the MarshalByValueComponent.
EndInit (inherited from DataTable) | Ends the initialization of a DataTable that is used on a form or used by another component. The initialization occurs at runtime.
EndLoadData (inherited from DataTable) | Turns on notifications, index maintenance, and constraints after loading data.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByID |
GetChanges (inherited from DataTable) | Overloaded. Gets a copy of the DataTable that contains all changes made to it since it was loaded or AcceptChanges was last called.
GetEnumerator |
GetErrors (inherited from DataTable) | Gets an array of DataRow objects that contain errors.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from DataTable) | Populates a serialization information object with the data needed to serialize the DataTable.
GetService (inherited from MarshalByValueComponent) | Gets the implementer of the IServiceProvider.
GetType (inherited from Object) | Gets the Type of the current instance.
ImportRow (inherited from DataTable) | Copies a DataRow into a DataTable, preserving any property settings, as well as original and current values.
Load (inherited from DataTable) | Overloaded. Fills a DataTable with values from a data source using the supplied IDataReader. If the DataTable already contains rows, the incoming data from the data source is merged with the existing rows.
LoadDataRow (inherited from DataTable) | Overloaded. Finds and updates a specific row. If no matching row is found, a new row is created using the given values.
Merge (inherited from DataTable) | Overloaded. Merge the specified DataTable with the current DataTable.
NewPaymentGroupsRow |
NewRow (inherited from DataTable) | Creates a new DataRow with the same schema as the table.
ReadXml (inherited from DataTable) | Overloaded. Reads XML schema and data into the DataTable using the specified Stream.
ReadXmlSchema (inherited from DataTable) | Overloaded. Reads an XML schema into the DataTable using the specified stream.
RejectChanges (inherited from DataTable) | Rolls back all changes that have been made to the table since it was loaded, or the last time AcceptChanges was called.
RemovePaymentGroupsRow |
Reset (inherited from DataTable) | Resets the DataTable to its original state.
Select (inherited from DataTable) | Overloaded. Gets an array of all DataRow objects.
ToString (inherited from DataTable) | Gets the TableName and DisplayExpression, if there is one as a concatenated string.
WriteXml (inherited from DataTable) | Overloaded. Writes the current data, and optionally the schema, for the DataTable using the specified TextWriter and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. To save the data for the table and all its descendants, set the writeHierarchy parameter to true.
WriteXmlSchema (inherited from DataTable) | Overloaded. Writes the current data structure of the DataTable as an XML schema to the specified stream.

Public Instance Events

ColumnChanged (inherited from DataTable) | Occurs after a value has been changed for the specified DataColumn in a DataRow.
ColumnChanging (inherited from DataTable) | Occurs when a value is being changed for the specified DataColumn in a DataRow.
Disposed (inherited from MarshalByValueComponent) | Adds an event handler to listen to the Disposed event on the component.
Initialized (inherited from DataTable) | Occurs after the DataTable is initialized.
PaymentGroupsRowChanged |
PaymentGroupsRowChanging |
PaymentGroupsRowDeleted |
PaymentGroupsRowDeleting |
RowChanged (inherited from DataTable) | Occurs after a DataRow has been changed successfully.
RowChanging (inherited from DataTable) | Occurs when a DataRow is changing.
RowDeleted (inherited from DataTable) | Occurs after a row in the table has been deleted.
RowDeleting (inherited from DataTable) | Occurs before a row in the table is about to be deleted.
TableCleared (inherited from DataTable) | Occurs after a DataTable is cleared.
TableClearing (inherited from DataTable) | Occurs when a DataTable is cleared.
TableNewRow (inherited from DataTable) | Occurs when a new DataRow is inserted.

Protected Instance Constructors

CommissionPayments.PaymentGroupsDataTable Overloaded. Initializes a new instance of the CommissionPayments.PaymentGroupsDataTable class.

Protected Instance Properties

Events (inherited from MarshalByValueComponent) Gets the list of event handlers that are attached to this component.

Protected Instance Methods

CreateInstance |
Dispose (inherited from MarshalByValueComponent) | Overloaded. Releases the unmanaged resources used by the MarshalByValueComponent and optionally releases the managed resources.
Finalize (inherited from MarshalByValueComponent) | [To be supplied.]
GetRowType |
GetSchema (inherited from DataTable) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NewRowFromBuilder |
OnPropertyChanging (inherited from DataTable) | Raises the PropertyChanging event.
OnRemoveColumn (inherited from DataTable) | Notifies the DataTable that a DataColumn is being removed.
OnRowChanged |
OnRowChanging |
OnRowDeleted |
OnRowDeleting |
OnTableCleared (inherited from DataTable) | Raises the TableCleared event.
OnTableClearing (inherited from DataTable) | Raises the TableClearing event.
OnTableNewRow (inherited from DataTable) | Raises the TableNewRow event.
ReadXmlSerializable (inherited from DataTable) |

Protected Internal Instance Fields

fInitInProgress (inherited from DataTable)

Protected Internal Instance Methods

NewRowArray (inherited from DataTable) |
OnColumnChanged (inherited from DataTable) | Raises the ColumnChanged event.
OnColumnChanging (inherited from DataTable) | Raises the ColumnChanging event.

See Also

CommissionPayments.PaymentGroupsDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentGroupsDataTable Constructor

Initializes a new instance of the CommissionPayments.PaymentGroupsDataTable class.

Overload List

Initializes a new instance of the CommissionPayments.PaymentGroupsDataTable class.

public CommissionPayments.PaymentGroupsDataTable();

protected CommissionPayments.PaymentGroupsDataTable(SerializationInfo,StreamingContext);

See Also

CommissionPayments.PaymentGroupsDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentGroupsDataTable Constructor ()

Initializes a new instance of the CommissionPayments.PaymentGroupsDataTable class.

public CommissionPayments.PaymentGroupsDataTable();

See Also

CommissionPayments.PaymentGroupsDataTable Class | Aptify.Applications.Commissions Namespace | CommissionPayments.PaymentGroupsDataTable Constructor Overload List


CommissionPayments.PaymentGroupsDataTable Constructor (SerializationInfo, StreamingContext)

protected CommissionPayments.PaymentGroupsDataTable(
SerializationInfo info,
StreamingContext context
);

See Also

CommissionPayments.PaymentGroupsDataTable Class | Aptify.Applications.Commissions Namespace | CommissionPayments.PaymentGroupsDataTable Constructor Overload List


CommissionPayments.PaymentGroupsDataTable Properties

The properties of the CommissionPayments.PaymentGroupsDataTable class are listed below. For a complete list of CommissionPayments.PaymentGroupsDataTable class members, see the CommissionPayments.PaymentGroupsDataTable Members topic.

Public Instance Properties

CaseSensitive (inherited from DataTable) | Indicates whether string comparisons within the table are case-sensitive.
ChildRelations (inherited from DataTable) | Gets the collection of child relations for this DataTable.
Columns (inherited from DataTable) | Gets the collection of columns that belong to this table.
Constraints (inherited from DataTable) | Gets the collection of constraints maintained by this table.
Container (inherited from MarshalByValueComponent) | Gets the container for the component.
Count |
DataSet (inherited from DataTable) | Gets the DataSet to which this table belongs.
DefaultView (inherited from DataTable) | Gets a customized view of the table that may include a filtered view, or a cursor position.
DesignMode (inherited from MarshalByValueComponent) | Gets a value indicating whether the component is currently in design mode.
DisplayExpression (inherited from DataTable) | Gets or sets the expression that returns a value used to represent this table in the user interface.
ExtendedProperties (inherited from DataTable) | Gets the collection of customized user information.
HasErrors (inherited from DataTable) | Gets a value indicating whether there are errors in any of the rows in any of the tables of the DataSet to which the table belongs.
IDColumn |
IsInitialized (inherited from DataTable) | Gets a value that indicates whether the DataTable is initialized.
Item |
Locale (inherited from DataTable) | Gets or sets the locale information used to compare strings within the table.
MinimumCapacity (inherited from DataTable) | Gets or sets the initial starting size for this table.
Namespace (inherited from DataTable) | Gets or sets the namespace for the XML representation of the data stored in the DataTable.
ParentRelations (inherited from DataTable) | Gets the collection of parent relations for this DataTable.
PayeeIDColumn |
PayeeNameColumn |
PayeeTypeColumn |
PaymentIDColumn |
Prefix (inherited from DataTable) | Gets or sets the namespace for the XML representation of the data stored in the DataTable.
PrimaryKey (inherited from DataTable) | Gets or sets an array of columns that function as primary keys for the data table.
RemotingFormat (inherited from DataTable) | Gets or sets the serialization format.
Rows (inherited from DataTable) | Gets the collection of rows that belong to this table.
Site (inherited from DataTable) | Gets or sets an ISite for the DataTable.
TableName (inherited from DataTable) | Gets or sets the name of the DataTable.

Protected Instance Properties

Events (inherited from MarshalByValueComponent) Gets the list of event handlers that are attached to this component.

See Also

CommissionPayments.PaymentGroupsDataTable Class | Aptify.Applications.Commissions Namespace


Count Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.PaymentGroupsDataTable.Count Property

public Int32 Count {get;}

See Also

CommissionPayments.PaymentGroupsDataTable Class | Aptify.Applications.Commissions Namespace


IDColumn Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.PaymentGroupsDataTable.IDColumn Property

public DataColumn IDColumn {get;}

See Also

CommissionPayments.PaymentGroupsDataTable Class | Aptify.Applications.Commissions Namespace


Item Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.PaymentGroupsDataTable.Item Property

public CommissionPayments.PaymentGroupsRow this[
Int32 index
] {get;}

See Also

CommissionPayments.PaymentGroupsDataTable Class | Aptify.Applications.Commissions Namespace


PayeeIDColumn Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.PaymentGroupsDataTable.PayeeIDColumn Property

public DataColumn PayeeIDColumn {get;}

See Also

CommissionPayments.PaymentGroupsDataTable Class | Aptify.Applications.Commissions Namespace


PayeeNameColumn Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.PaymentGroupsDataTable.PayeeNameColumn Property

public DataColumn PayeeNameColumn {get;}

See Also

CommissionPayments.PaymentGroupsDataTable Class | Aptify.Applications.Commissions Namespace


PayeeTypeColumn Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.PaymentGroupsDataTable.PayeeTypeColumn Property

public DataColumn PayeeTypeColumn {get;}

See Also

CommissionPayments.PaymentGroupsDataTable Class | Aptify.Applications.Commissions Namespace


PaymentIDColumn Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.PaymentGroupsDataTable.PaymentIDColumn Property

public DataColumn PaymentIDColumn {get;}

See Also

CommissionPayments.PaymentGroupsDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentGroupsDataTable Methods

The methods of the CommissionPayments.PaymentGroupsDataTable class are listed below. For a complete list of CommissionPayments.PaymentGroupsDataTable class members, see the CommissionPayments.PaymentGroupsDataTable Members topic.

Public Static Methods

GetTypedTableSchema

Public Instance Methods

AcceptChanges (inherited from DataTable) | Commits all the changes made to this table since the last time AcceptChanges was called.
AddPaymentGroupsRow | Overloaded.
BeginInit (inherited from DataTable) | Begins the initialization of a DataTable that is used on a form or used by another component. The initialization occurs at runtime.
BeginLoadData (inherited from DataTable) | Turns off notifications, index maintenance, and constraints while loading data.
Clear (inherited from DataTable) | Clears the DataTable of all data.
Clone |
Compute (inherited from DataTable) | Computes the given expression on the current rows that pass the filter criteria.
Copy (inherited from DataTable) | Copies both the structure and data for this DataTable.
CreateDataReader (inherited from DataTable) | Returns a DataTableReader corresponding to the data within this DataTable.
Dispose (inherited from MarshalByValueComponent) | Overloaded. Releases all resources used by the MarshalByValueComponent.
EndInit (inherited from DataTable) | Ends the initialization of a DataTable that is used on a form or used by another component. The initialization occurs at runtime.
EndLoadData (inherited from DataTable) | Turns on notifications, index maintenance, and constraints after loading data.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByID |
GetChanges (inherited from DataTable) | Overloaded. Gets a copy of the DataTable that contains all changes made to it since it was loaded or AcceptChanges was last called.
GetEnumerator |
GetErrors (inherited from DataTable) | Gets an array of DataRow objects that contain errors.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from DataTable) | Populates a serialization information object with the data needed to serialize the DataTable.
GetService (inherited from MarshalByValueComponent) | Gets the implementer of the IServiceProvider.
GetType (inherited from Object) | Gets the Type of the current instance.
ImportRow (inherited from DataTable) | Copies a DataRow into a DataTable, preserving any property settings, as well as original and current values.
Load (inherited from DataTable) | Overloaded. Fills a DataTable with values from a data source using the supplied IDataReader. If the DataTable already contains rows, the incoming data from the data source is merged with the existing rows.
LoadDataRow (inherited from DataTable) | Overloaded. Finds and updates a specific row. If no matching row is found, a new row is created using the given values.
Merge (inherited from DataTable) | Overloaded. Merge the specified DataTable with the current DataTable.
NewPaymentGroupsRow |
NewRow (inherited from DataTable) | Creates a new DataRow with the same schema as the table.
ReadXml (inherited from DataTable) | Overloaded. Reads XML schema and data into the DataTable using the specified Stream.
ReadXmlSchema (inherited from DataTable) | Overloaded. Reads an XML schema into the DataTable using the specified stream.
RejectChanges (inherited from DataTable) | Rolls back all changes that have been made to the table since it was loaded, or the last time AcceptChanges was called.
RemovePaymentGroupsRow |
Reset (inherited from DataTable) | Resets the DataTable to its original state.
Select (inherited from DataTable) | Overloaded. Gets an array of all DataRow objects.
ToString (inherited from DataTable) | Gets the TableName and DisplayExpression, if there is one as a concatenated string.
WriteXml (inherited from DataTable) | Overloaded. Writes the current data, and optionally the schema, for the DataTable using the specified TextWriter and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. To save the data for the table and all its descendants, set the writeHierarchy parameter to true.
WriteXmlSchema (inherited from DataTable) | Overloaded. Writes the current data structure of the DataTable as an XML schema to the specified stream.

Protected Instance Methods

CreateInstance |
Dispose (inherited from MarshalByValueComponent) | Overloaded. Releases the unmanaged resources used by the MarshalByValueComponent and optionally releases the managed resources.
Finalize (inherited from MarshalByValueComponent) | [To be supplied.]
GetRowType |
GetSchema (inherited from DataTable) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NewRowFromBuilder |
OnPropertyChanging (inherited from DataTable) | Raises the PropertyChanging event.
OnRemoveColumn (inherited from DataTable) | Notifies the DataTable that a DataColumn is being removed.
OnRowChanged |
OnRowChanging |
OnRowDeleted |
OnRowDeleting |
OnTableCleared (inherited from DataTable) | Raises the TableCleared event.
OnTableClearing (inherited from DataTable) | Raises the TableClearing event.
OnTableNewRow (inherited from DataTable) | Raises the TableNewRow event.
ReadXmlSerializable (inherited from DataTable) |

Protected Internal Instance Methods

NewRowArray (inherited from DataTable) |
OnColumnChanged (inherited from DataTable) | Raises the ColumnChanged event.
OnColumnChanging (inherited from DataTable) | Raises the ColumnChanging event.

See Also

CommissionPayments.PaymentGroupsDataTable Class | Aptify.Applications.Commissions Namespace


AddPaymentGroupsRow Method

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.PaymentGroupsDataTable.AddPaymentGroupsRow Method

Overload List

public void AddPaymentGroupsRow(CommissionPayments.PaymentGroupsRow);

public PaymentGroupsRow AddPaymentGroupsRow(Int64,String,String,Int64);

See Also

CommissionPayments.PaymentGroupsDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentGroupsDataTable.AddPaymentGroupsRow Method (PaymentGroupsRow)

public void AddPaymentGroupsRow(
CommissionPayments.PaymentGroupsRow row
);

See Also

CommissionPayments.PaymentGroupsDataTable Class | Aptify.Applications.Commissions Namespace | CommissionPayments.PaymentGroupsDataTable.AddPaymentGroupsRow Overload List


CommissionPayments.PaymentGroupsDataTable.AddPaymentGroupsRow Method (Int64, String, String, Int64)

public PaymentGroupsRow AddPaymentGroupsRow(
Int64 PayeeID,
String PayeeType,
String PayeeName,
Int64 PaymentID
);

See Also

CommissionPayments.PaymentGroupsDataTable Class | Aptify.Applications.Commissions Namespace | CommissionPayments.PaymentGroupsDataTable.AddPaymentGroupsRow Overload List


CommissionPayments.PaymentGroupsDataTable.Clone Method

public override DataTable Clone();

See Also

CommissionPayments.PaymentGroupsDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentGroupsDataTable.CreateInstance Method

protected override DataTable CreateInstance();

See Also

CommissionPayments.PaymentGroupsDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentGroupsDataTable.FindByID Method

public PaymentGroupsRow FindByID(
Int32 ID
);

See Also

CommissionPayments.PaymentGroupsDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentGroupsDataTable.GetEnumerator Method

public virtual IEnumerator GetEnumerator();

Implements

IEnumerable.

See Also

CommissionPayments.PaymentGroupsDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentGroupsDataTable.GetRowType Method

protected override Type GetRowType();

See Also

CommissionPayments.PaymentGroupsDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentGroupsDataTable.GetTypedTableSchema Method

public static XmlSchemaComplexType GetTypedTableSchema(
XmlSchemaSet xs
);

See Also

CommissionPayments.PaymentGroupsDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentGroupsDataTable.NewPaymentGroupsRow Method

public PaymentGroupsRow NewPaymentGroupsRow();

See Also

CommissionPayments.PaymentGroupsDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentGroupsDataTable.NewRowFromBuilder Method

protected override DataRow NewRowFromBuilder(
DataRowBuilder builder
);

See Also

CommissionPayments.PaymentGroupsDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentGroupsDataTable.OnRowChanged Method

protected override void OnRowChanged(
DataRowChangeEventArgs e
);

See Also

CommissionPayments.PaymentGroupsDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentGroupsDataTable.OnRowChanging Method

protected override void OnRowChanging(
DataRowChangeEventArgs e
);

See Also

CommissionPayments.PaymentGroupsDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentGroupsDataTable.OnRowDeleted Method

protected override void OnRowDeleted(
DataRowChangeEventArgs e
);

See Also

CommissionPayments.PaymentGroupsDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentGroupsDataTable.OnRowDeleting Method

protected override void OnRowDeleting(
DataRowChangeEventArgs e
);

See Also

CommissionPayments.PaymentGroupsDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentGroupsDataTable.RemovePaymentGroupsRow Method

public void RemovePaymentGroupsRow(
CommissionPayments.PaymentGroupsRow row
);

See Also

CommissionPayments.PaymentGroupsDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentGroupsDataTable Events

The events of the CommissionPayments.PaymentGroupsDataTable class are listed below. For a complete list of CommissionPayments.PaymentGroupsDataTable class members, see the CommissionPayments.PaymentGroupsDataTable Members topic.

Public Instance Events

ColumnChanged (inherited from DataTable) | Occurs after a value has been changed for the specified DataColumn in a DataRow.
ColumnChanging (inherited from DataTable) | Occurs when a value is being changed for the specified DataColumn in a DataRow.
Disposed (inherited from MarshalByValueComponent) | Adds an event handler to listen to the Disposed event on the component.
Initialized (inherited from DataTable) | Occurs after the DataTable is initialized.
PaymentGroupsRowChanged |
PaymentGroupsRowChanging |
PaymentGroupsRowDeleted |
PaymentGroupsRowDeleting |
RowChanged (inherited from DataTable) | Occurs after a DataRow has been changed successfully.
RowChanging (inherited from DataTable) | Occurs when a DataRow is changing.
RowDeleted (inherited from DataTable) | Occurs after a row in the table has been deleted.
RowDeleting (inherited from DataTable) | Occurs before a row in the table is about to be deleted.
TableCleared (inherited from DataTable) | Occurs after a DataTable is cleared.
TableClearing (inherited from DataTable) | Occurs when a DataTable is cleared.
TableNewRow (inherited from DataTable) | Occurs when a new DataRow is inserted.

See Also

CommissionPayments.PaymentGroupsDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentGroupsDataTable.CommissionPayments.PaymentGroupsRowChangeEventHandler Event

public event CommissionPayments.PaymentGroupsRowChangeEventHandler PaymentGroupsRowChanged;

See Also

CommissionPayments.PaymentGroupsDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentGroupsDataTable.CommissionPayments.PaymentGroupsRowChangeEventHandler Event

public event CommissionPayments.PaymentGroupsRowChangeEventHandler PaymentGroupsRowChanging;

See Also

CommissionPayments.PaymentGroupsDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentGroupsDataTable.CommissionPayments.PaymentGroupsRowChangeEventHandler Event

public event CommissionPayments.PaymentGroupsRowChangeEventHandler PaymentGroupsRowDeleted;

See Also

CommissionPayments.PaymentGroupsDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentGroupsDataTable.CommissionPayments.PaymentGroupsRowChangeEventHandler Event

public event CommissionPayments.PaymentGroupsRowChangeEventHandler PaymentGroupsRowDeleting;

See Also

CommissionPayments.PaymentGroupsDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentGroupsRow Class

Represents strongly named DataRow class.

For a list of all members of this type, see CommissionPayments.PaymentGroupsRow Members.

System.Object
DataRow
CommissionPayments.PaymentGroupsRow

public class CommissionPayments.PaymentGroupsRow : DataRow

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Commissions

Assembly: CommissionPaymentWizard (in CommissionPaymentWizard.dll)

See Also

CommissionPayments.PaymentGroupsRow Members | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentGroupsRow Members

CommissionPayments.PaymentGroupsRow overview

Public Instance Properties

HasErrors (inherited from DataRow) | Gets a value that indicates whether there are errors in a row.
ID |
Item (inherited from DataRow) | Gets or sets the data stored in the column specified by index.
Item (inherited from DataRow) | Gets or sets the data stored in the column specified by name.
Item (inherited from DataRow) | Gets or sets the data stored in the specified DataColumn.
Item (inherited from DataRow) | Gets the data stored in the column, specified by index and version of the data to retrieve.
Item (inherited from DataRow) | Gets the specified version of data stored in the named column.
Item (inherited from DataRow) | Gets the specified version of data stored in the specified DataColumn.
ItemArray (inherited from DataRow) | Gets or sets all the values for this row through an array.
PayeeID |
PayeeName |
PayeeType |
PaymentID |
PaymentsRow |
RowError (inherited from DataRow) | Gets or sets the custom error description for a row.
RowState (inherited from DataRow) | Gets the current state of the row with regard to its relationship to the DataRowCollection.
Table (inherited from DataRow) | Gets the DataTable for which this row has a schema.

Public Instance Methods

AcceptChanges (inherited from DataRow) | Commits all the changes made to this row since the last time AcceptChanges was called.
BeginEdit (inherited from DataRow) | Starts an edit operation on a DataRow object.
CancelEdit (inherited from DataRow) | Cancels the current edit on the row.
ClearErrors (inherited from DataRow) | Clears the errors for the row. This includes the RowError and errors set with SetColumnError.
Delete (inherited from DataRow) | Deletes the DataRow.
EndEdit (inherited from DataRow) | Ends the edit occurring on the row.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetChildRows (inherited from DataRow) | Overloaded. Gets the child rows of a DataRow using the specified RelationName of a DataRelation.
GetColumnError (inherited from DataRow) | Overloaded. Gets the error description for the column specified by index.
GetColumnsInError (inherited from DataRow) | Gets an array of columns that have errors.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetParentRow (inherited from DataRow) | Overloaded. Gets the parent row of a DataRow using the specified RelationName of a DataRelation.
GetParentRows (inherited from DataRow) | Overloaded. Gets the parent rows of a DataRow using the specified RelationName of a DataRelation.
GetType (inherited from Object) | Gets the Type of the current instance.
HasVersion (inherited from DataRow) | Gets a value that indicates whether a specified version exists.
IsNull (inherited from DataRow) | Overloaded. Gets a value that indicates whether the column at the specified index contains a null value.
IsPayeeIDNull |
IsPayeeNameNull |
IsPayeeTypeNull |
IsPaymentIDNull |
RejectChanges (inherited from DataRow) | Rejects all changes made to the row since AcceptChanges was last called.
SetAdded (inherited from DataRow) | Changes the Rowstate of a DataRow to Added.
SetColumnError (inherited from DataRow) | Overloaded. Sets the error description for a column specified by index.
SetModified (inherited from DataRow) | Changes the Rowstate of a DataRow to Modified.
SetParentRow (inherited from DataRow) | Overloaded. Sets the parent row of a DataRow with specified new parent DataRow.
SetPayeeIDNull |
SetPayeeNameNull |
SetPayeeTypeNull |
SetPaymentIDNull |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetNull (inherited from DataRow) | Sets the value of the specified DataColumn to a null value.

See Also

CommissionPayments.PaymentGroupsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentGroupsRow Properties

The properties of the CommissionPayments.PaymentGroupsRow class are listed below. For a complete list of CommissionPayments.PaymentGroupsRow class members, see the CommissionPayments.PaymentGroupsRow Members topic.

Public Instance Properties

HasErrors (inherited from DataRow) | Gets a value that indicates whether there are errors in a row.
ID |
Item (inherited from DataRow) | Gets or sets the data stored in the column specified by index.
Item (inherited from DataRow) | Gets or sets the data stored in the column specified by name.
Item (inherited from DataRow) | Gets or sets the data stored in the specified DataColumn.
Item (inherited from DataRow) | Gets the data stored in the column, specified by index and version of the data to retrieve.
Item (inherited from DataRow) | Gets the specified version of data stored in the named column.
Item (inherited from DataRow) | Gets the specified version of data stored in the specified DataColumn.
ItemArray (inherited from DataRow) | Gets or sets all the values for this row through an array.
PayeeID |
PayeeName |
PayeeType |
PaymentID |
PaymentsRow |
RowError (inherited from DataRow) | Gets or sets the custom error description for a row.
RowState (inherited from DataRow) | Gets the current state of the row with regard to its relationship to the DataRowCollection.
Table (inherited from DataRow) | Gets the DataTable for which this row has a schema.

See Also

CommissionPayments.PaymentGroupsRow Class | Aptify.Applications.Commissions Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.PaymentGroupsRow.ID Property

public Int32 ID {get; set;}

See Also

CommissionPayments.PaymentGroupsRow Class | Aptify.Applications.Commissions Namespace


PayeeID Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.PaymentGroupsRow.PayeeID Property

public Int64 PayeeID {get; set;}

See Also

CommissionPayments.PaymentGroupsRow Class | Aptify.Applications.Commissions Namespace


PayeeName Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.PaymentGroupsRow.PayeeName Property

public String PayeeName {get; set;}

See Also

CommissionPayments.PaymentGroupsRow Class | Aptify.Applications.Commissions Namespace


PayeeType Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.PaymentGroupsRow.PayeeType Property

public String PayeeType {get; set;}

See Also

CommissionPayments.PaymentGroupsRow Class | Aptify.Applications.Commissions Namespace


PaymentID Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.PaymentGroupsRow.PaymentID Property

public Int64 PaymentID {get; set;}

See Also

CommissionPayments.PaymentGroupsRow Class | Aptify.Applications.Commissions Namespace


PaymentsRow Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.PaymentGroupsRow.PaymentsRow Property

public CommissionPayments.PaymentsRow PaymentsRow {get; set;}

See Also

CommissionPayments.PaymentGroupsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentGroupsRow Methods

The methods of the CommissionPayments.PaymentGroupsRow class are listed below. For a complete list of CommissionPayments.PaymentGroupsRow class members, see the CommissionPayments.PaymentGroupsRow Members topic.

Public Instance Methods

AcceptChanges (inherited from DataRow) | Commits all the changes made to this row since the last time AcceptChanges was called.
BeginEdit (inherited from DataRow) | Starts an edit operation on a DataRow object.
CancelEdit (inherited from DataRow) | Cancels the current edit on the row.
ClearErrors (inherited from DataRow) | Clears the errors for the row. This includes the RowError and errors set with SetColumnError.
Delete (inherited from DataRow) | Deletes the DataRow.
EndEdit (inherited from DataRow) | Ends the edit occurring on the row.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetChildRows (inherited from DataRow) | Overloaded. Gets the child rows of a DataRow using the specified RelationName of a DataRelation.
GetColumnError (inherited from DataRow) | Overloaded. Gets the error description for the column specified by index.
GetColumnsInError (inherited from DataRow) | Gets an array of columns that have errors.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetParentRow (inherited from DataRow) | Overloaded. Gets the parent row of a DataRow using the specified RelationName of a DataRelation.
GetParentRows (inherited from DataRow) | Overloaded. Gets the parent rows of a DataRow using the specified RelationName of a DataRelation.
GetType (inherited from Object) | Gets the Type of the current instance.
HasVersion (inherited from DataRow) | Gets a value that indicates whether a specified version exists.
IsNull (inherited from DataRow) | Overloaded. Gets a value that indicates whether the column at the specified index contains a null value.
IsPayeeIDNull |
IsPayeeNameNull |
IsPayeeTypeNull |
IsPaymentIDNull |
RejectChanges (inherited from DataRow) | Rejects all changes made to the row since AcceptChanges was last called.
SetAdded (inherited from DataRow) | Changes the Rowstate of a DataRow to Added.
SetColumnError (inherited from DataRow) | Overloaded. Sets the error description for a column specified by index.
SetModified (inherited from DataRow) | Changes the Rowstate of a DataRow to Modified.
SetParentRow (inherited from DataRow) | Overloaded. Sets the parent row of a DataRow with specified new parent DataRow.
SetPayeeIDNull |
SetPayeeNameNull |
SetPayeeTypeNull |
SetPaymentIDNull |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetNull (inherited from DataRow) | Sets the value of the specified DataColumn to a null value.

See Also

CommissionPayments.PaymentGroupsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentGroupsRow.IsPayeeIDNull Method

public bool IsPayeeIDNull();

See Also

CommissionPayments.PaymentGroupsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentGroupsRow.IsPayeeNameNull Method

public bool IsPayeeNameNull();

See Also

CommissionPayments.PaymentGroupsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentGroupsRow.IsPayeeTypeNull Method

public bool IsPayeeTypeNull();

See Also

CommissionPayments.PaymentGroupsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentGroupsRow.IsPaymentIDNull Method

public bool IsPaymentIDNull();

See Also

CommissionPayments.PaymentGroupsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentGroupsRow.SetPayeeIDNull Method

public void SetPayeeIDNull();

See Also

CommissionPayments.PaymentGroupsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentGroupsRow.SetPayeeNameNull Method

public void SetPayeeNameNull();

See Also

CommissionPayments.PaymentGroupsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentGroupsRow.SetPayeeTypeNull Method

public void SetPayeeTypeNull();

See Also

CommissionPayments.PaymentGroupsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentGroupsRow.SetPaymentIDNull Method

public void SetPaymentIDNull();

See Also

CommissionPayments.PaymentGroupsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentGroupsRowChangeEvent Class

Row event argument class

For a list of all members of this type, see CommissionPayments.PaymentGroupsRowChangeEvent Members.

System.Object
EventArgs
CommissionPayments.PaymentGroupsRowChangeEvent

public class CommissionPayments.PaymentGroupsRowChangeEvent : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Commissions

Assembly: CommissionPaymentWizard (in CommissionPaymentWizard.dll)

See Also

CommissionPayments.PaymentGroupsRowChangeEvent Members | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentGroupsRowChangeEvent Members

CommissionPayments.PaymentGroupsRowChangeEvent overview

Public Instance Constructors

CommissionPayments.PaymentGroupsRowChangeEvent Constructor

Public Instance Properties

Action
Row

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CommissionPayments.PaymentGroupsRowChangeEvent Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentGroupsRowChangeEvent Constructor

public CommissionPayments.PaymentGroupsRowChangeEvent(
CommissionPayments.PaymentGroupsRow row,
DataRowAction action
);

See Also

CommissionPayments.PaymentGroupsRowChangeEvent Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentGroupsRowChangeEvent Properties

The properties of the CommissionPayments.PaymentGroupsRowChangeEvent class are listed below. For a complete list of CommissionPayments.PaymentGroupsRowChangeEvent class members, see the CommissionPayments.PaymentGroupsRowChangeEvent Members topic.

Public Instance Properties

Action
Row

See Also

CommissionPayments.PaymentGroupsRowChangeEvent Class | Aptify.Applications.Commissions Namespace


Action Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.PaymentGroupsRowChangeEvent.Action Property

public DataRowAction Action {get;}

See Also

CommissionPayments.PaymentGroupsRowChangeEvent Class | Aptify.Applications.Commissions Namespace


Row Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.PaymentGroupsRowChangeEvent.Row Property

public CommissionPayments.PaymentGroupsRow Row {get;}

See Also

CommissionPayments.PaymentGroupsRowChangeEvent Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentGroupsRowChangeEventHandler Delegate

public delegate void CommissionPayments.PaymentGroupsRowChangeEventHandler(
Object sender,
CommissionPayments.PaymentGroupsRowChangeEvent e
);

Requirements

Namespace: Aptify.Applications.Commissions

Assembly: CommissionPaymentWizard (in CommissionPaymentWizard.dll)

See Also

Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentsDataTable Class

Represents the strongly named DataTable class.

For a list of all members of this type, see CommissionPayments.PaymentsDataTable Members.

System.Object
MarshalByValueComponent
DataTable
CommissionPayments.PaymentsDataTable

public class CommissionPayments.PaymentsDataTable : DataTable, IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Commissions

Assembly: CommissionPaymentWizard (in CommissionPaymentWizard.dll)

See Also

CommissionPayments.PaymentsDataTable Members | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentsDataTable Members

CommissionPayments.PaymentsDataTable overview

Public Static Methods

GetTypedTableSchema

Public Instance Constructors

CommissionPayments.PaymentsDataTable Overloaded. Initializes a new instance of the CommissionPayments.PaymentsDataTable class.

Public Instance Properties

AgreementEndDateColumn |
AgreementIDColumn |
AgreementStartDateColumn |
CaseSensitive (inherited from DataTable) | Indicates whether string comparisons within the table are case-sensitive.
ChildRelations (inherited from DataTable) | Gets the collection of child relations for this DataTable.
Columns (inherited from DataTable) | Gets the collection of columns that belong to this table.
Constraints (inherited from DataTable) | Gets the collection of constraints maintained by this table.
Container (inherited from MarshalByValueComponent) | Gets the container for the component.
Count |
DataSet (inherited from DataTable) | Gets the DataSet to which this table belongs.
DatePaid |
DefaultView (inherited from DataTable) | Gets a customized view of the table that may include a filtered view, or a cursor position.
DesignMode (inherited from MarshalByValueComponent) | Gets a value indicating whether the component is currently in design mode.
DisplayExpression (inherited from DataTable) | Gets or sets the expression that returns a value used to represent this table in the user interface.
EffectiveDate |
EndDate |
ExtendedProperties (inherited from DataTable) | Gets the collection of customized user information.
GroupIDColumn |
HasErrors (inherited from DataTable) | Gets a value indicating whether there are errors in any of the rows in any of the tables of the DataSet to which the table belongs.
IDColumn |
IsInitialized (inherited from DataTable) | Gets a value that indicates whether the DataTable is initialized.
Item |
Locale (inherited from DataTable) | Gets or sets the locale information used to compare strings within the table.
MinimumCapacity (inherited from DataTable) | Gets or sets the initial starting size for this table.
Namespace (inherited from DataTable) | Gets or sets the namespace for the XML representation of the data stored in the DataTable.
ParentRelations (inherited from DataTable) | Gets the collection of parent relations for this DataTable.
PayeeIDColumn |
PayeeNameColumn |
PayeeTypeColumn |
PlanColumn |
PlanIDColumn |
Prefix (inherited from DataTable) | Gets or sets the namespace for the XML representation of the data stored in the DataTable.
PrimaryKey (inherited from DataTable) | Gets or sets an array of columns that function as primary keys for the data table.
RemotingFormat (inherited from DataTable) | Gets or sets the serialization format.
ReverseUnpaidColumn |
Rows (inherited from DataTable) | Gets the collection of rows that belong to this table.
SalesRep_NameColumn |
SalesRepIDColumn |
Site (inherited from DataTable) | Gets or sets an ISite for the DataTable.
SkipColumn |
StartDate |
TableName (inherited from DataTable) | Gets or sets the name of the DataTable.
UnpaidDaysColumn |

Public Instance Methods

AcceptChanges (inherited from DataTable) | Commits all the changes made to this table since the last time AcceptChanges was called.
AddPaymentsRow | Overloaded.
BeginInit (inherited from DataTable) | Begins the initialization of a DataTable that is used on a form or used by another component. The initialization occurs at runtime.
BeginLoadData (inherited from DataTable) | Turns off notifications, index maintenance, and constraints while loading data.
Clear (inherited from DataTable) | Clears the DataTable of all data.
Clone |
Compute (inherited from DataTable) | Computes the given expression on the current rows that pass the filter criteria.
Copy (inherited from DataTable) | Copies both the structure and data for this DataTable.
CreateDataReader (inherited from DataTable) | Returns a DataTableReader corresponding to the data within this DataTable.
Dispose (inherited from MarshalByValueComponent) | Overloaded. Releases all resources used by the MarshalByValueComponent.
EndInit (inherited from DataTable) | Ends the initialization of a DataTable that is used on a form or used by another component. The initialization occurs at runtime.
EndLoadData (inherited from DataTable) | Turns on notifications, index maintenance, and constraints after loading data.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByID |
GetChanges (inherited from DataTable) | Overloaded. Gets a copy of the DataTable that contains all changes made to it since it was loaded or AcceptChanges was last called.
GetEnumerator |
GetErrors (inherited from DataTable) | Gets an array of DataRow objects that contain errors.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from DataTable) | Populates a serialization information object with the data needed to serialize the DataTable.
GetService (inherited from MarshalByValueComponent) | Gets the implementer of the IServiceProvider.
GetType (inherited from Object) | Gets the Type of the current instance.
ImportRow (inherited from DataTable) | Copies a DataRow into a DataTable, preserving any property settings, as well as original and current values.
Load (inherited from DataTable) | Overloaded. Fills a DataTable with values from a data source using the supplied IDataReader. If the DataTable already contains rows, the incoming data from the data source is merged with the existing rows.
LoadDataRow (inherited from DataTable) | Overloaded. Finds and updates a specific row. If no matching row is found, a new row is created using the given values.
Merge (inherited from DataTable) | Overloaded. Merge the specified DataTable with the current DataTable.
NewPaymentsRow |
NewRow (inherited from DataTable) | Creates a new DataRow with the same schema as the table.
ReadXml (inherited from DataTable) | Overloaded. Reads XML schema and data into the DataTable using the specified Stream.
ReadXmlSchema (inherited from DataTable) | Overloaded. Reads an XML schema into the DataTable using the specified stream.
RejectChanges (inherited from DataTable) | Rolls back all changes that have been made to the table since it was loaded, or the last time AcceptChanges was called.
RemovePaymentsRow |
Reset (inherited from DataTable) | Resets the DataTable to its original state.
Select (inherited from DataTable) | Overloaded. Gets an array of all DataRow objects.
ToString (inherited from DataTable) | Gets the TableName and DisplayExpression, if there is one as a concatenated string.
WriteXml (inherited from DataTable) | Overloaded. Writes the current data, and optionally the schema, for the DataTable using the specified TextWriter and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. To save the data for the table and all its descendants, set the writeHierarchy parameter to true.
WriteXmlSchema (inherited from DataTable) | Overloaded. Writes the current data structure of the DataTable as an XML schema to the specified stream.

Public Instance Events

ColumnChanged (inherited from DataTable) | Occurs after a value has been changed for the specified DataColumn in a DataRow.
ColumnChanging (inherited from DataTable) | Occurs when a value is being changed for the specified DataColumn in a DataRow.
Disposed (inherited from MarshalByValueComponent) | Adds an event handler to listen to the Disposed event on the component.
Initialized (inherited from DataTable) | Occurs after the DataTable is initialized.
PaymentsRowChanged |
PaymentsRowChanging |
PaymentsRowDeleted |
PaymentsRowDeleting |
RowChanged (inherited from DataTable) | Occurs after a DataRow has been changed successfully.
RowChanging (inherited from DataTable) | Occurs when a DataRow is changing.
RowDeleted (inherited from DataTable) | Occurs after a row in the table has been deleted.
RowDeleting (inherited from DataTable) | Occurs before a row in the table is about to be deleted.
TableCleared (inherited from DataTable) | Occurs after a DataTable is cleared.
TableClearing (inherited from DataTable) | Occurs when a DataTable is cleared.
TableNewRow (inherited from DataTable) | Occurs when a new DataRow is inserted.

Protected Instance Constructors

CommissionPayments.PaymentsDataTable Overloaded. Initializes a new instance of the CommissionPayments.PaymentsDataTable class.

Protected Instance Properties

Events (inherited from MarshalByValueComponent) Gets the list of event handlers that are attached to this component.

Protected Instance Methods

CreateInstance |
Dispose (inherited from MarshalByValueComponent) | Overloaded. Releases the unmanaged resources used by the MarshalByValueComponent and optionally releases the managed resources.
Finalize (inherited from MarshalByValueComponent) | [To be supplied.]
GetRowType |
GetSchema (inherited from DataTable) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NewRowFromBuilder |
OnPropertyChanging (inherited from DataTable) | Raises the PropertyChanging event.
OnRemoveColumn (inherited from DataTable) | Notifies the DataTable that a DataColumn is being removed.
OnRowChanged |
OnRowChanging |
OnRowDeleted |
OnRowDeleting |
OnTableCleared (inherited from DataTable) | Raises the TableCleared event.
OnTableClearing (inherited from DataTable) | Raises the TableClearing event.
OnTableNewRow (inherited from DataTable) | Raises the TableNewRow event.
ReadXmlSerializable (inherited from DataTable) |

Protected Internal Instance Fields

fInitInProgress (inherited from DataTable)

Protected Internal Instance Methods

NewRowArray (inherited from DataTable) |
OnColumnChanged (inherited from DataTable) | Raises the ColumnChanged event.
OnColumnChanging (inherited from DataTable) | Raises the ColumnChanging event.

See Also

CommissionPayments.PaymentsDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentsDataTable Constructor

Initializes a new instance of the CommissionPayments.PaymentsDataTable class.

Overload List

Initializes a new instance of the CommissionPayments.PaymentsDataTable class.

public CommissionPayments.PaymentsDataTable();

protected CommissionPayments.PaymentsDataTable(SerializationInfo,StreamingContext);

See Also

CommissionPayments.PaymentsDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentsDataTable Constructor ()

Initializes a new instance of the CommissionPayments.PaymentsDataTable class.

public CommissionPayments.PaymentsDataTable();

See Also

CommissionPayments.PaymentsDataTable Class | Aptify.Applications.Commissions Namespace | CommissionPayments.PaymentsDataTable Constructor Overload List


CommissionPayments.PaymentsDataTable Constructor (SerializationInfo, StreamingContext)

protected CommissionPayments.PaymentsDataTable(
SerializationInfo info,
StreamingContext context
);

See Also

CommissionPayments.PaymentsDataTable Class | Aptify.Applications.Commissions Namespace | CommissionPayments.PaymentsDataTable Constructor Overload List


CommissionPayments.PaymentsDataTable Properties

The properties of the CommissionPayments.PaymentsDataTable class are listed below. For a complete list of CommissionPayments.PaymentsDataTable class members, see the CommissionPayments.PaymentsDataTable Members topic.

Public Instance Properties

AgreementEndDateColumn |
AgreementIDColumn |
AgreementStartDateColumn |
CaseSensitive (inherited from DataTable) | Indicates whether string comparisons within the table are case-sensitive.
ChildRelations (inherited from DataTable) | Gets the collection of child relations for this DataTable.
Columns (inherited from DataTable) | Gets the collection of columns that belong to this table.
Constraints (inherited from DataTable) | Gets the collection of constraints maintained by this table.
Container (inherited from MarshalByValueComponent) | Gets the container for the component.
Count |
DataSet (inherited from DataTable) | Gets the DataSet to which this table belongs.
DatePaid |
DefaultView (inherited from DataTable) | Gets a customized view of the table that may include a filtered view, or a cursor position.
DesignMode (inherited from MarshalByValueComponent) | Gets a value indicating whether the component is currently in design mode.
DisplayExpression (inherited from DataTable) | Gets or sets the expression that returns a value used to represent this table in the user interface.
EffectiveDate |
EndDate |
ExtendedProperties (inherited from DataTable) | Gets the collection of customized user information.
GroupIDColumn |
HasErrors (inherited from DataTable) | Gets a value indicating whether there are errors in any of the rows in any of the tables of the DataSet to which the table belongs.
IDColumn |
IsInitialized (inherited from DataTable) | Gets a value that indicates whether the DataTable is initialized.
Item |
Locale (inherited from DataTable) | Gets or sets the locale information used to compare strings within the table.
MinimumCapacity (inherited from DataTable) | Gets or sets the initial starting size for this table.
Namespace (inherited from DataTable) | Gets or sets the namespace for the XML representation of the data stored in the DataTable.
ParentRelations (inherited from DataTable) | Gets the collection of parent relations for this DataTable.
PayeeIDColumn |
PayeeNameColumn |
PayeeTypeColumn |
PlanColumn |
PlanIDColumn |
Prefix (inherited from DataTable) | Gets or sets the namespace for the XML representation of the data stored in the DataTable.
PrimaryKey (inherited from DataTable) | Gets or sets an array of columns that function as primary keys for the data table.
RemotingFormat (inherited from DataTable) | Gets or sets the serialization format.
ReverseUnpaidColumn |
Rows (inherited from DataTable) | Gets the collection of rows that belong to this table.
SalesRep_NameColumn |
SalesRepIDColumn |
Site (inherited from DataTable) | Gets or sets an ISite for the DataTable.
SkipColumn |
StartDate |
TableName (inherited from DataTable) | Gets or sets the name of the DataTable.
UnpaidDaysColumn |

Protected Instance Properties

Events (inherited from MarshalByValueComponent) Gets the list of event handlers that are attached to this component.

See Also

CommissionPayments.PaymentsDataTable Class | Aptify.Applications.Commissions Namespace


AgreementEndDateColumn Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.PaymentsDataTable.AgreementEndDateColumn Property

public DataColumn AgreementEndDateColumn {get;}

See Also

CommissionPayments.PaymentsDataTable Class | Aptify.Applications.Commissions Namespace


AgreementIDColumn Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.PaymentsDataTable.AgreementIDColumn Property

public DataColumn AgreementIDColumn {get;}

See Also

CommissionPayments.PaymentsDataTable Class | Aptify.Applications.Commissions Namespace


AgreementStartDateColumn Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.PaymentsDataTable.AgreementStartDateColumn Property

public DataColumn AgreementStartDateColumn {get;}

See Also

CommissionPayments.PaymentsDataTable Class | Aptify.Applications.Commissions Namespace


Count Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.PaymentsDataTable.Count Property

public Int32 Count {get;}

See Also

CommissionPayments.PaymentsDataTable Class | Aptify.Applications.Commissions Namespace


DatePaid Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.PaymentsDataTable.DatePaid Property

public DateTime DatePaid {get; set;}

See Also

CommissionPayments.PaymentsDataTable Class | Aptify.Applications.Commissions Namespace


EffectiveDate Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.PaymentsDataTable.EffectiveDate Property

public DateTime EffectiveDate {get; set;}

See Also

CommissionPayments.PaymentsDataTable Class | Aptify.Applications.Commissions Namespace


EndDate Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.PaymentsDataTable.EndDate Property

public DateTime EndDate {get; set;}

See Also

CommissionPayments.PaymentsDataTable Class | Aptify.Applications.Commissions Namespace


GroupIDColumn Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.PaymentsDataTable.GroupIDColumn Property

public DataColumn GroupIDColumn {get;}

See Also

CommissionPayments.PaymentsDataTable Class | Aptify.Applications.Commissions Namespace


IDColumn Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.PaymentsDataTable.IDColumn Property

public DataColumn IDColumn {get;}

See Also

CommissionPayments.PaymentsDataTable Class | Aptify.Applications.Commissions Namespace


Item Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.PaymentsDataTable.Item Property

public CommissionPayments.PaymentsRow this[
Int32 index
] {get;}

See Also

CommissionPayments.PaymentsDataTable Class | Aptify.Applications.Commissions Namespace


PayeeIDColumn Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.PaymentsDataTable.PayeeIDColumn Property

public DataColumn PayeeIDColumn {get;}

See Also

CommissionPayments.PaymentsDataTable Class | Aptify.Applications.Commissions Namespace


PayeeNameColumn Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.PaymentsDataTable.PayeeNameColumn Property

public DataColumn PayeeNameColumn {get;}

See Also

CommissionPayments.PaymentsDataTable Class | Aptify.Applications.Commissions Namespace


PayeeTypeColumn Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.PaymentsDataTable.PayeeTypeColumn Property

public DataColumn PayeeTypeColumn {get;}

See Also

CommissionPayments.PaymentsDataTable Class | Aptify.Applications.Commissions Namespace


PlanColumn Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.PaymentsDataTable.PlanColumn Property

public DataColumn PlanColumn {get;}

See Also

CommissionPayments.PaymentsDataTable Class | Aptify.Applications.Commissions Namespace


PlanIDColumn Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.PaymentsDataTable.PlanIDColumn Property

public DataColumn PlanIDColumn {get;}

See Also

CommissionPayments.PaymentsDataTable Class | Aptify.Applications.Commissions Namespace


ReverseUnpaidColumn Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.PaymentsDataTable.ReverseUnpaidColumn Property

public DataColumn ReverseUnpaidColumn {get;}

See Also

CommissionPayments.PaymentsDataTable Class | Aptify.Applications.Commissions Namespace


SalesRep_NameColumn Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.PaymentsDataTable.SalesRep_NameColumn Property

public DataColumn SalesRep_NameColumn {get;}

See Also

CommissionPayments.PaymentsDataTable Class | Aptify.Applications.Commissions Namespace


SalesRepIDColumn Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.PaymentsDataTable.SalesRepIDColumn Property

public DataColumn SalesRepIDColumn {get;}

See Also

CommissionPayments.PaymentsDataTable Class | Aptify.Applications.Commissions Namespace


SkipColumn Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.PaymentsDataTable.SkipColumn Property

public DataColumn SkipColumn {get;}

See Also

CommissionPayments.PaymentsDataTable Class | Aptify.Applications.Commissions Namespace


StartDate Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.PaymentsDataTable.StartDate Property

public DateTime StartDate {get; set;}

See Also

CommissionPayments.PaymentsDataTable Class | Aptify.Applications.Commissions Namespace


UnpaidDaysColumn Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.PaymentsDataTable.UnpaidDaysColumn Property

public DataColumn UnpaidDaysColumn {get;}

See Also

CommissionPayments.PaymentsDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentsDataTable Methods

The methods of the CommissionPayments.PaymentsDataTable class are listed below. For a complete list of CommissionPayments.PaymentsDataTable class members, see the CommissionPayments.PaymentsDataTable Members topic.

Public Static Methods

GetTypedTableSchema

Public Instance Methods

AcceptChanges (inherited from DataTable) | Commits all the changes made to this table since the last time AcceptChanges was called.
AddPaymentsRow | Overloaded.
BeginInit (inherited from DataTable) | Begins the initialization of a DataTable that is used on a form or used by another component. The initialization occurs at runtime.
BeginLoadData (inherited from DataTable) | Turns off notifications, index maintenance, and constraints while loading data.
Clear (inherited from DataTable) | Clears the DataTable of all data.
Clone |
Compute (inherited from DataTable) | Computes the given expression on the current rows that pass the filter criteria.
Copy (inherited from DataTable) | Copies both the structure and data for this DataTable.
CreateDataReader (inherited from DataTable) | Returns a DataTableReader corresponding to the data within this DataTable.
Dispose (inherited from MarshalByValueComponent) | Overloaded. Releases all resources used by the MarshalByValueComponent.
EndInit (inherited from DataTable) | Ends the initialization of a DataTable that is used on a form or used by another component. The initialization occurs at runtime.
EndLoadData (inherited from DataTable) | Turns on notifications, index maintenance, and constraints after loading data.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByID |
GetChanges (inherited from DataTable) | Overloaded. Gets a copy of the DataTable that contains all changes made to it since it was loaded or AcceptChanges was last called.
GetEnumerator |
GetErrors (inherited from DataTable) | Gets an array of DataRow objects that contain errors.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from DataTable) | Populates a serialization information object with the data needed to serialize the DataTable.
GetService (inherited from MarshalByValueComponent) | Gets the implementer of the IServiceProvider.
GetType (inherited from Object) | Gets the Type of the current instance.
ImportRow (inherited from DataTable) | Copies a DataRow into a DataTable, preserving any property settings, as well as original and current values.
Load (inherited from DataTable) | Overloaded. Fills a DataTable with values from a data source using the supplied IDataReader. If the DataTable already contains rows, the incoming data from the data source is merged with the existing rows.
LoadDataRow (inherited from DataTable) | Overloaded. Finds and updates a specific row. If no matching row is found, a new row is created using the given values.
Merge (inherited from DataTable) | Overloaded. Merge the specified DataTable with the current DataTable.
NewPaymentsRow |
NewRow (inherited from DataTable) | Creates a new DataRow with the same schema as the table.
ReadXml (inherited from DataTable) | Overloaded. Reads XML schema and data into the DataTable using the specified Stream.
ReadXmlSchema (inherited from DataTable) | Overloaded. Reads an XML schema into the DataTable using the specified stream.
RejectChanges (inherited from DataTable) | Rolls back all changes that have been made to the table since it was loaded, or the last time AcceptChanges was called.
RemovePaymentsRow |
Reset (inherited from DataTable) | Resets the DataTable to its original state.
Select (inherited from DataTable) | Overloaded. Gets an array of all DataRow objects.
ToString (inherited from DataTable) | Gets the TableName and DisplayExpression, if there is one as a concatenated string.
WriteXml (inherited from DataTable) | Overloaded. Writes the current data, and optionally the schema, for the DataTable using the specified TextWriter and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. To save the data for the table and all its descendants, set the writeHierarchy parameter to true.
WriteXmlSchema (inherited from DataTable) | Overloaded. Writes the current data structure of the DataTable as an XML schema to the specified stream.

Protected Instance Methods

CreateInstance |
Dispose (inherited from MarshalByValueComponent) | Overloaded. Releases the unmanaged resources used by the MarshalByValueComponent and optionally releases the managed resources.
Finalize (inherited from MarshalByValueComponent) | [To be supplied.]
GetRowType |
GetSchema (inherited from DataTable) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NewRowFromBuilder |
OnPropertyChanging (inherited from DataTable) | Raises the PropertyChanging event.
OnRemoveColumn (inherited from DataTable) | Notifies the DataTable that a DataColumn is being removed.
OnRowChanged |
OnRowChanging |
OnRowDeleted |
OnRowDeleting |
OnTableCleared (inherited from DataTable) | Raises the TableCleared event.
OnTableClearing (inherited from DataTable) | Raises the TableClearing event.
OnTableNewRow (inherited from DataTable) | Raises the TableNewRow event.
ReadXmlSerializable (inherited from DataTable) |

Protected Internal Instance Methods

NewRowArray (inherited from DataTable) |
OnColumnChanged (inherited from DataTable) | Raises the ColumnChanged event.
OnColumnChanging (inherited from DataTable) | Raises the ColumnChanging event.

See Also

CommissionPayments.PaymentsDataTable Class | Aptify.Applications.Commissions Namespace


AddPaymentsRow Method

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.PaymentsDataTable.AddPaymentsRow Method

Overload List

public void AddPaymentsRow(CommissionPayments.PaymentsRow);

public PaymentsRow AddPaymentsRow(Boolean,String,String,Int64,String,String,Int32,Int32,Int32,String,String,String,String,Int32);

See Also

CommissionPayments.PaymentsDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentsDataTable.AddPaymentsRow Method (PaymentsRow)

public void AddPaymentsRow(
CommissionPayments.PaymentsRow row
);

See Also

CommissionPayments.PaymentsDataTable Class | Aptify.Applications.Commissions Namespace | CommissionPayments.PaymentsDataTable.AddPaymentsRow Overload List


CommissionPayments.PaymentsDataTable.AddPaymentsRow Method (Boolean, String, String, Int64, String, String, Int32, Int32, Int32, String, String, String, String, Int32)

public PaymentsRow AddPaymentsRow(
Boolean Skip,
String PayeeName,
String PayeeType,
Int64 AgreementID,
String SalesRep_Name,
String Plan,
Int32 PayeeID,
Int32 SalesRepID,
Int32 PlanID,
String AgreementStartDate,
String AgreementEndDate,
String ReverseUnpaid,
String UnpaidDays,
Int32 GroupID
);

See Also

CommissionPayments.PaymentsDataTable Class | Aptify.Applications.Commissions Namespace | CommissionPayments.PaymentsDataTable.AddPaymentsRow Overload List


CommissionPayments.PaymentsDataTable.Clone Method

public override DataTable Clone();

See Also

CommissionPayments.PaymentsDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentsDataTable.CreateInstance Method

protected override DataTable CreateInstance();

See Also

CommissionPayments.PaymentsDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentsDataTable.FindByID Method

public PaymentsRow FindByID(
Int32 ID
);

See Also

CommissionPayments.PaymentsDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentsDataTable.GetEnumerator Method

public virtual IEnumerator GetEnumerator();

Implements

IEnumerable.

See Also

CommissionPayments.PaymentsDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentsDataTable.GetRowType Method

protected override Type GetRowType();

See Also

CommissionPayments.PaymentsDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentsDataTable.GetTypedTableSchema Method

public static XmlSchemaComplexType GetTypedTableSchema(
XmlSchemaSet xs
);

See Also

CommissionPayments.PaymentsDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentsDataTable.NewPaymentsRow Method

public PaymentsRow NewPaymentsRow();

See Also

CommissionPayments.PaymentsDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentsDataTable.NewRowFromBuilder Method

protected override DataRow NewRowFromBuilder(
DataRowBuilder builder
);

See Also

CommissionPayments.PaymentsDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentsDataTable.OnRowChanged Method

protected override void OnRowChanged(
DataRowChangeEventArgs e
);

See Also

CommissionPayments.PaymentsDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentsDataTable.OnRowChanging Method

protected override void OnRowChanging(
DataRowChangeEventArgs e
);

See Also

CommissionPayments.PaymentsDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentsDataTable.OnRowDeleted Method

protected override void OnRowDeleted(
DataRowChangeEventArgs e
);

See Also

CommissionPayments.PaymentsDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentsDataTable.OnRowDeleting Method

protected override void OnRowDeleting(
DataRowChangeEventArgs e
);

See Also

CommissionPayments.PaymentsDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentsDataTable.RemovePaymentsRow Method

public void RemovePaymentsRow(
CommissionPayments.PaymentsRow row
);

See Also

CommissionPayments.PaymentsDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentsDataTable Events

The events of the CommissionPayments.PaymentsDataTable class are listed below. For a complete list of CommissionPayments.PaymentsDataTable class members, see the CommissionPayments.PaymentsDataTable Members topic.

Public Instance Events

ColumnChanged (inherited from DataTable) | Occurs after a value has been changed for the specified DataColumn in a DataRow.
ColumnChanging (inherited from DataTable) | Occurs when a value is being changed for the specified DataColumn in a DataRow.
Disposed (inherited from MarshalByValueComponent) | Adds an event handler to listen to the Disposed event on the component.
Initialized (inherited from DataTable) | Occurs after the DataTable is initialized.
PaymentsRowChanged |
PaymentsRowChanging |
PaymentsRowDeleted |
PaymentsRowDeleting |
RowChanged (inherited from DataTable) | Occurs after a DataRow has been changed successfully.
RowChanging (inherited from DataTable) | Occurs when a DataRow is changing.
RowDeleted (inherited from DataTable) | Occurs after a row in the table has been deleted.
RowDeleting (inherited from DataTable) | Occurs before a row in the table is about to be deleted.
TableCleared (inherited from DataTable) | Occurs after a DataTable is cleared.
TableClearing (inherited from DataTable) | Occurs when a DataTable is cleared.
TableNewRow (inherited from DataTable) | Occurs when a new DataRow is inserted.

See Also

CommissionPayments.PaymentsDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentsDataTable.CommissionPayments.PaymentsRowChangeEventHandler Event

public event CommissionPayments.PaymentsRowChangeEventHandler PaymentsRowChanged;

See Also

CommissionPayments.PaymentsDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentsDataTable.CommissionPayments.PaymentsRowChangeEventHandler Event

public event CommissionPayments.PaymentsRowChangeEventHandler PaymentsRowChanging;

See Also

CommissionPayments.PaymentsDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentsDataTable.CommissionPayments.PaymentsRowChangeEventHandler Event

public event CommissionPayments.PaymentsRowChangeEventHandler PaymentsRowDeleted;

See Also

CommissionPayments.PaymentsDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentsDataTable.CommissionPayments.PaymentsRowChangeEventHandler Event

public event CommissionPayments.PaymentsRowChangeEventHandler PaymentsRowDeleting;

See Also

CommissionPayments.PaymentsDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentsRow Class

Represents strongly named DataRow class.

For a list of all members of this type, see CommissionPayments.PaymentsRow Members.

System.Object
DataRow
CommissionPayments.PaymentsRow

public class CommissionPayments.PaymentsRow : DataRow

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Commissions

Assembly: CommissionPaymentWizard (in CommissionPaymentWizard.dll)

See Also

CommissionPayments.PaymentsRow Members | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentsRow Members

CommissionPayments.PaymentsRow overview

Public Instance Properties

AgreementEndDate |
AgreementID |
AgreementStartDate |
GroupID |
HasErrors (inherited from DataRow) | Gets a value that indicates whether there are errors in a row.
ID |
Item (inherited from DataRow) | Gets or sets the data stored in the column specified by index.
Item (inherited from DataRow) | Gets or sets the data stored in the column specified by name.
Item (inherited from DataRow) | Gets or sets the data stored in the specified DataColumn.
Item (inherited from DataRow) | Gets the data stored in the column, specified by index and version of the data to retrieve.
Item (inherited from DataRow) | Gets the specified version of data stored in the named column.
Item (inherited from DataRow) | Gets the specified version of data stored in the specified DataColumn.
ItemArray (inherited from DataRow) | Gets or sets all the values for this row through an array.
PayeeID |
PayeeName |
PayeeType |
Plan |
PlanID |
ReverseUnpaid |
RowError (inherited from DataRow) | Gets or sets the custom error description for a row.
RowState (inherited from DataRow) | Gets the current state of the row with regard to its relationship to the DataRowCollection.
SalesRep_Name |
SalesRepID |
Skip |
Table (inherited from DataRow) | Gets the DataTable for which this row has a schema.
UnpaidDays |

Public Instance Methods

AcceptChanges (inherited from DataRow) | Commits all the changes made to this row since the last time AcceptChanges was called.
BeginEdit (inherited from DataRow) | Starts an edit operation on a DataRow object.
CancelEdit (inherited from DataRow) | Cancels the current edit on the row.
ClearErrors (inherited from DataRow) | Clears the errors for the row. This includes the RowError and errors set with SetColumnError.
Delete (inherited from DataRow) | Deletes the DataRow.
EndEdit (inherited from DataRow) | Ends the edit occurring on the row.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetChildRows (inherited from DataRow) | Overloaded. Gets the child rows of a DataRow using the specified RelationName of a DataRelation.
GetColumnError (inherited from DataRow) | Overloaded. Gets the error description for the column specified by index.
GetColumnsInError (inherited from DataRow) | Gets an array of columns that have errors.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetParentRow (inherited from DataRow) | Overloaded. Gets the parent row of a DataRow using the specified RelationName of a DataRelation.
GetParentRows (inherited from DataRow) | Overloaded. Gets the parent rows of a DataRow using the specified RelationName of a DataRelation.
GetPaymentGroupsRows |
GetType (inherited from Object) | Gets the Type of the current instance.
HasVersion (inherited from DataRow) | Gets a value that indicates whether a specified version exists.
IsAgreementEndDateNull |
IsAgreementIDNull |
IsAgreementStartDateNull |
IsGroupIDNull |
IsNull (inherited from DataRow) | Overloaded. Gets a value that indicates whether the column at the specified index contains a null value.
IsPayeeIDNull |
IsPayeeNameNull |
IsPayeeTypeNull |
IsPlanIDNull |
IsPlanNull |
IsReverseUnpaidNull |
IsSalesRep_NameNull |
IsSalesRepIDNull |
IsSkipNull |
IsUnpaidDaysNull |
RejectChanges (inherited from DataRow) | Rejects all changes made to the row since AcceptChanges was last called.
SetAdded (inherited from DataRow) | Changes the Rowstate of a DataRow to Added.
SetAgreementEndDateNull |
SetAgreementIDNull |
SetAgreementStartDateNull |
SetColumnError (inherited from DataRow) | Overloaded. Sets the error description for a column specified by index.
SetGroupIDNull |
SetModified (inherited from DataRow) | Changes the Rowstate of a DataRow to Modified.
SetParentRow (inherited from DataRow) | Overloaded. Sets the parent row of a DataRow with specified new parent DataRow.
SetPayeeIDNull |
SetPayeeNameNull |
SetPayeeTypeNull |
SetPlanIDNull |
SetPlanNull |
SetReverseUnpaidNull |
SetSalesRep_NameNull |
SetSalesRepIDNull |
SetSkipNull |
SetUnpaidDaysNull |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetNull (inherited from DataRow) | Sets the value of the specified DataColumn to a null value.

See Also

CommissionPayments.PaymentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentsRow Properties

The properties of the CommissionPayments.PaymentsRow class are listed below. For a complete list of CommissionPayments.PaymentsRow class members, see the CommissionPayments.PaymentsRow Members topic.

Public Instance Properties

AgreementEndDate |
AgreementID |
AgreementStartDate |
GroupID |
HasErrors (inherited from DataRow) | Gets a value that indicates whether there are errors in a row.
ID |
Item (inherited from DataRow) | Gets or sets the data stored in the column specified by index.
Item (inherited from DataRow) | Gets or sets the data stored in the column specified by name.
Item (inherited from DataRow) | Gets or sets the data stored in the specified DataColumn.
Item (inherited from DataRow) | Gets the data stored in the column, specified by index and version of the data to retrieve.
Item (inherited from DataRow) | Gets the specified version of data stored in the named column.
Item (inherited from DataRow) | Gets the specified version of data stored in the specified DataColumn.
ItemArray (inherited from DataRow) | Gets or sets all the values for this row through an array.
PayeeID |
PayeeName |
PayeeType |
Plan |
PlanID |
ReverseUnpaid |
RowError (inherited from DataRow) | Gets or sets the custom error description for a row.
RowState (inherited from DataRow) | Gets the current state of the row with regard to its relationship to the DataRowCollection.
SalesRep_Name |
SalesRepID |
Skip |
Table (inherited from DataRow) | Gets the DataTable for which this row has a schema.
UnpaidDays |

See Also

CommissionPayments.PaymentsRow Class | Aptify.Applications.Commissions Namespace


AgreementEndDate Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.PaymentsRow.AgreementEndDate Property

public String AgreementEndDate {get; set;}

See Also

CommissionPayments.PaymentsRow Class | Aptify.Applications.Commissions Namespace


AgreementID Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.PaymentsRow.AgreementID Property

public Int64 AgreementID {get; set;}

See Also

CommissionPayments.PaymentsRow Class | Aptify.Applications.Commissions Namespace


AgreementStartDate Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.PaymentsRow.AgreementStartDate Property

public String AgreementStartDate {get; set;}

See Also

CommissionPayments.PaymentsRow Class | Aptify.Applications.Commissions Namespace


GroupID Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.PaymentsRow.GroupID Property

public Int32 GroupID {get; set;}

See Also

CommissionPayments.PaymentsRow Class | Aptify.Applications.Commissions Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.PaymentsRow.ID Property

public Int32 ID {get; set;}

See Also

CommissionPayments.PaymentsRow Class | Aptify.Applications.Commissions Namespace


PayeeID Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.PaymentsRow.PayeeID Property

public Int32 PayeeID {get; set;}

See Also

CommissionPayments.PaymentsRow Class | Aptify.Applications.Commissions Namespace


PayeeName Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.PaymentsRow.PayeeName Property

public String PayeeName {get; set;}

See Also

CommissionPayments.PaymentsRow Class | Aptify.Applications.Commissions Namespace


PayeeType Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.PaymentsRow.PayeeType Property

public String PayeeType {get; set;}

See Also

CommissionPayments.PaymentsRow Class | Aptify.Applications.Commissions Namespace


Plan Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.PaymentsRow.Plan Property

public String Plan {get; set;}

See Also

CommissionPayments.PaymentsRow Class | Aptify.Applications.Commissions Namespace


PlanID Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.PaymentsRow.PlanID Property

public Int32 PlanID {get; set;}

See Also

CommissionPayments.PaymentsRow Class | Aptify.Applications.Commissions Namespace


ReverseUnpaid Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.PaymentsRow.ReverseUnpaid Property

public String ReverseUnpaid {get; set;}

See Also

CommissionPayments.PaymentsRow Class | Aptify.Applications.Commissions Namespace


SalesRep_Name Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.PaymentsRow.SalesRep_Name Property

public String SalesRep_Name {get; set;}

See Also

CommissionPayments.PaymentsRow Class | Aptify.Applications.Commissions Namespace


SalesRepID Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.PaymentsRow.SalesRepID Property

public Int32 SalesRepID {get; set;}

See Also

CommissionPayments.PaymentsRow Class | Aptify.Applications.Commissions Namespace


Skip Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.PaymentsRow.Skip Property

public Boolean Skip {get; set;}

See Also

CommissionPayments.PaymentsRow Class | Aptify.Applications.Commissions Namespace


UnpaidDays Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.PaymentsRow.UnpaidDays Property

public String UnpaidDays {get; set;}

See Also

CommissionPayments.PaymentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentsRow Methods

The methods of the CommissionPayments.PaymentsRow class are listed below. For a complete list of CommissionPayments.PaymentsRow class members, see the CommissionPayments.PaymentsRow Members topic.

Public Instance Methods

AcceptChanges (inherited from DataRow) | Commits all the changes made to this row since the last time AcceptChanges was called.
BeginEdit (inherited from DataRow) | Starts an edit operation on a DataRow object.
CancelEdit (inherited from DataRow) | Cancels the current edit on the row.
ClearErrors (inherited from DataRow) | Clears the errors for the row. This includes the RowError and errors set with SetColumnError.
Delete (inherited from DataRow) | Deletes the DataRow.
EndEdit (inherited from DataRow) | Ends the edit occurring on the row.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetChildRows (inherited from DataRow) | Overloaded. Gets the child rows of a DataRow using the specified RelationName of a DataRelation.
GetColumnError (inherited from DataRow) | Overloaded. Gets the error description for the column specified by index.
GetColumnsInError (inherited from DataRow) | Gets an array of columns that have errors.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetParentRow (inherited from DataRow) | Overloaded. Gets the parent row of a DataRow using the specified RelationName of a DataRelation.
GetParentRows (inherited from DataRow) | Overloaded. Gets the parent rows of a DataRow using the specified RelationName of a DataRelation.
GetPaymentGroupsRows |
GetType (inherited from Object) | Gets the Type of the current instance.
HasVersion (inherited from DataRow) | Gets a value that indicates whether a specified version exists.
IsAgreementEndDateNull |
IsAgreementIDNull |
IsAgreementStartDateNull |
IsGroupIDNull |
IsNull (inherited from DataRow) | Overloaded. Gets a value that indicates whether the column at the specified index contains a null value.
IsPayeeIDNull |
IsPayeeNameNull |
IsPayeeTypeNull |
IsPlanIDNull |
IsPlanNull |
IsReverseUnpaidNull |
IsSalesRep_NameNull |
IsSalesRepIDNull |
IsSkipNull |
IsUnpaidDaysNull |
RejectChanges (inherited from DataRow) | Rejects all changes made to the row since AcceptChanges was last called.
SetAdded (inherited from DataRow) | Changes the Rowstate of a DataRow to Added.
SetAgreementEndDateNull |
SetAgreementIDNull |
SetAgreementStartDateNull |
SetColumnError (inherited from DataRow) | Overloaded. Sets the error description for a column specified by index.
SetGroupIDNull |
SetModified (inherited from DataRow) | Changes the Rowstate of a DataRow to Modified.
SetParentRow (inherited from DataRow) | Overloaded. Sets the parent row of a DataRow with specified new parent DataRow.
SetPayeeIDNull |
SetPayeeNameNull |
SetPayeeTypeNull |
SetPlanIDNull |
SetPlanNull |
SetReverseUnpaidNull |
SetSalesRep_NameNull |
SetSalesRepIDNull |
SetSkipNull |
SetUnpaidDaysNull |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetNull (inherited from DataRow) | Sets the value of the specified DataColumn to a null value.

See Also

CommissionPayments.PaymentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentsRow.GetPaymentGroupsRows Method

public PaymentGroupsRow[] GetPaymentGroupsRows();

See Also

CommissionPayments.PaymentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentsRow.IsAgreementEndDateNull Method

public bool IsAgreementEndDateNull();

See Also

CommissionPayments.PaymentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentsRow.IsAgreementIDNull Method

public bool IsAgreementIDNull();

See Also

CommissionPayments.PaymentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentsRow.IsAgreementStartDateNull Method

public bool IsAgreementStartDateNull();

See Also

CommissionPayments.PaymentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentsRow.IsGroupIDNull Method

public bool IsGroupIDNull();

See Also

CommissionPayments.PaymentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentsRow.IsPayeeIDNull Method

public bool IsPayeeIDNull();

See Also

CommissionPayments.PaymentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentsRow.IsPayeeNameNull Method

public bool IsPayeeNameNull();

See Also

CommissionPayments.PaymentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentsRow.IsPayeeTypeNull Method

public bool IsPayeeTypeNull();

See Also

CommissionPayments.PaymentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentsRow.IsPlanIDNull Method

public bool IsPlanIDNull();

See Also

CommissionPayments.PaymentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentsRow.IsPlanNull Method

public bool IsPlanNull();

See Also

CommissionPayments.PaymentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentsRow.IsReverseUnpaidNull Method

public bool IsReverseUnpaidNull();

See Also

CommissionPayments.PaymentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentsRow.IsSalesRep_NameNull Method

public bool IsSalesRep_NameNull();

See Also

CommissionPayments.PaymentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentsRow.IsSalesRepIDNull Method

public bool IsSalesRepIDNull();

See Also

CommissionPayments.PaymentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentsRow.IsSkipNull Method

public bool IsSkipNull();

See Also

CommissionPayments.PaymentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentsRow.IsUnpaidDaysNull Method

public bool IsUnpaidDaysNull();

See Also

CommissionPayments.PaymentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentsRow.SetAgreementEndDateNull Method

public void SetAgreementEndDateNull();

See Also

CommissionPayments.PaymentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentsRow.SetAgreementIDNull Method

public void SetAgreementIDNull();

See Also

CommissionPayments.PaymentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentsRow.SetAgreementStartDateNull Method

public void SetAgreementStartDateNull();

See Also

CommissionPayments.PaymentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentsRow.SetGroupIDNull Method

public void SetGroupIDNull();

See Also

CommissionPayments.PaymentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentsRow.SetPayeeIDNull Method

public void SetPayeeIDNull();

See Also

CommissionPayments.PaymentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentsRow.SetPayeeNameNull Method

public void SetPayeeNameNull();

See Also

CommissionPayments.PaymentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentsRow.SetPayeeTypeNull Method

public void SetPayeeTypeNull();

See Also

CommissionPayments.PaymentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentsRow.SetPlanIDNull Method

public void SetPlanIDNull();

See Also

CommissionPayments.PaymentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentsRow.SetPlanNull Method

public void SetPlanNull();

See Also

CommissionPayments.PaymentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentsRow.SetReverseUnpaidNull Method

public void SetReverseUnpaidNull();

See Also

CommissionPayments.PaymentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentsRow.SetSalesRep_NameNull Method

public void SetSalesRep_NameNull();

See Also

CommissionPayments.PaymentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentsRow.SetSalesRepIDNull Method

public void SetSalesRepIDNull();

See Also

CommissionPayments.PaymentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentsRow.SetSkipNull Method

public void SetSkipNull();

See Also

CommissionPayments.PaymentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentsRow.SetUnpaidDaysNull Method

public void SetUnpaidDaysNull();

See Also

CommissionPayments.PaymentsRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentsRowChangeEvent Class

Row event argument class

For a list of all members of this type, see CommissionPayments.PaymentsRowChangeEvent Members.

System.Object
EventArgs
CommissionPayments.PaymentsRowChangeEvent

public class CommissionPayments.PaymentsRowChangeEvent : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Commissions

Assembly: CommissionPaymentWizard (in CommissionPaymentWizard.dll)

See Also

CommissionPayments.PaymentsRowChangeEvent Members | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentsRowChangeEvent Members

CommissionPayments.PaymentsRowChangeEvent overview

Public Instance Constructors

CommissionPayments.PaymentsRowChangeEvent Constructor

Public Instance Properties

Action
Row

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CommissionPayments.PaymentsRowChangeEvent Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentsRowChangeEvent Constructor

public CommissionPayments.PaymentsRowChangeEvent(
CommissionPayments.PaymentsRow row,
DataRowAction action
);

See Also

CommissionPayments.PaymentsRowChangeEvent Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentsRowChangeEvent Properties

The properties of the CommissionPayments.PaymentsRowChangeEvent class are listed below. For a complete list of CommissionPayments.PaymentsRowChangeEvent class members, see the CommissionPayments.PaymentsRowChangeEvent Members topic.

Public Instance Properties

Action
Row

See Also

CommissionPayments.PaymentsRowChangeEvent Class | Aptify.Applications.Commissions Namespace


Action Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.PaymentsRowChangeEvent.Action Property

public DataRowAction Action {get;}

See Also

CommissionPayments.PaymentsRowChangeEvent Class | Aptify.Applications.Commissions Namespace


Row Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.PaymentsRowChangeEvent.Row Property

public CommissionPayments.PaymentsRow Row {get;}

See Also

CommissionPayments.PaymentsRowChangeEvent Class | Aptify.Applications.Commissions Namespace


CommissionPayments.PaymentsRowChangeEventHandler Delegate

public delegate void CommissionPayments.PaymentsRowChangeEventHandler(
Object sender,
CommissionPayments.PaymentsRowChangeEvent e
);

Requirements

Namespace: Aptify.Applications.Commissions

Assembly: CommissionPaymentWizard (in CommissionPaymentWizard.dll)

See Also

Aptify.Applications.Commissions Namespace


CommissionPayments.SupplyUserCredentails Class

For a list of all members of this type, see CommissionPayments.SupplyUserCredentails Members.

System.Object
CommissionPayments.SupplyUserCredentails

public class CommissionPayments.SupplyUserCredentails

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Commissions

Assembly: CommissionPaymentWizard (in CommissionPaymentWizard.dll)

See Also

CommissionPayments.SupplyUserCredentails Members | Aptify.Applications.Commissions Namespace


CommissionPayments.SupplyUserCredentails Members

CommissionPayments.SupplyUserCredentails overview

Public Static Properties

UserCredential

Public Instance Constructors

CommissionPayments.SupplyUserCredentails Constructor Initializes a new instance of the CommissionPayments.SupplyUserCredentails class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CommissionPayments.SupplyUserCredentails Class | Aptify.Applications.Commissions Namespace


CommissionPayments.SupplyUserCredentails Constructor

Initializes a new instance of the CommissionPayments.SupplyUserCredentails class.

public CommissionPayments.SupplyUserCredentails();

See Also

CommissionPayments.SupplyUserCredentails Class | Aptify.Applications.Commissions Namespace


CommissionPayments.SupplyUserCredentails Properties

The properties of the CommissionPayments.SupplyUserCredentails class are listed below. For a complete list of CommissionPayments.SupplyUserCredentails class members, see the CommissionPayments.SupplyUserCredentails Members topic.

Public Static Properties

UserCredential

See Also

CommissionPayments.SupplyUserCredentails Class | Aptify.Applications.Commissions Namespace


UserCredential Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.SupplyUserCredentails.UserCredential Property

public static UserCredentials UserCredential {get; set;}

See Also

CommissionPayments.SupplyUserCredentails Class | Aptify.Applications.Commissions Namespace


CommissionPayments.UpdaidInvoicesDataTable Class

Represents the strongly named DataTable class.

For a list of all members of this type, see CommissionPayments.UpdaidInvoicesDataTable Members.

System.Object
MarshalByValueComponent
DataTable
CommissionPayments.UpdaidInvoicesDataTable

public class CommissionPayments.UpdaidInvoicesDataTable : DataTable, IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Commissions

Assembly: CommissionPaymentWizard (in CommissionPaymentWizard.dll)

See Also

CommissionPayments.UpdaidInvoicesDataTable Members | Aptify.Applications.Commissions Namespace


CommissionPayments.UpdaidInvoicesDataTable Members

CommissionPayments.UpdaidInvoicesDataTable overview

Public Static Methods

GetTypedTableSchema

Public Instance Constructors

CommissionPayments.UpdaidInvoicesDataTable Overloaded. Initializes a new instance of the CommissionPayments.UpdaidInvoicesDataTable class.

Public Instance Properties

BalanceColumn |
BalanceFactorColumn |
BaseAdjustmentColumn |
CaseSensitive (inherited from DataTable) | Indicates whether string comparisons within the table are case-sensitive.
ChildRelations (inherited from DataTable) | Gets the collection of child relations for this DataTable.
Columns (inherited from DataTable) | Gets the collection of columns that belong to this table.
Constraints (inherited from DataTable) | Gets the collection of constraints maintained by this table.
Container (inherited from MarshalByValueComponent) | Gets the container for the component.
Count |
CurrentBaseColumn |
DataSet (inherited from DataTable) | Gets the DataSet to which this table belongs.
Days_OldColumn |
DefaultView (inherited from DataTable) | Gets a customized view of the table that may include a filtered view, or a cursor position.
DesignMode (inherited from MarshalByValueComponent) | Gets a value indicating whether the component is currently in design mode.
DisplayExpression (inherited from DataTable) | Gets or sets the expression that returns a value used to represent this table in the user interface.
ExtendedProperties (inherited from DataTable) | Gets the collection of customized user information.
HasErrors (inherited from DataTable) | Gets a value indicating whether there are errors in any of the rows in any of the tables of the DataSet to which the table belongs.
IsInitialized (inherited from DataTable) | Gets a value that indicates whether the DataTable is initialized.
Item |
Locale (inherited from DataTable) | Gets or sets the locale information used to compare strings within the table.
MinimumCapacity (inherited from DataTable) | Gets or sets the initial starting size for this table.
Namespace (inherited from DataTable) | Gets or sets the namespace for the XML representation of the data stored in the DataTable.
NewBaseColumn |
ParentRelations (inherited from DataTable) | Gets the collection of parent relations for this DataTable.
PaymentColumn |
PaymentIndexColumn |
Prefix (inherited from DataTable) | Gets or sets the namespace for the XML representation of the data stored in the DataTable.
PrimaryKey (inherited from DataTable) | Gets or sets an array of columns that function as primary keys for the data table.
ProductColumn |
RemotingFormat (inherited from DataTable) | Gets or sets the serialization format.
Rows (inherited from DataTable) | Gets the collection of rows that belong to this table.
SalesRepNameColumn |
Site (inherited from DataTable) | Gets or sets an ISite for the DataTable.
SourceEntityColumn |
SourceIDColumn |
TableName (inherited from DataTable) | Gets or sets the name of the DataTable.

Public Instance Methods

AcceptChanges (inherited from DataTable) | Commits all the changes made to this table since the last time AcceptChanges was called.
AddUpdaidInvoicesRow | Overloaded.
BeginInit (inherited from DataTable) | Begins the initialization of a DataTable that is used on a form or used by another component. The initialization occurs at runtime.
BeginLoadData (inherited from DataTable) | Turns off notifications, index maintenance, and constraints while loading data.
Clear (inherited from DataTable) | Clears the DataTable of all data.
Clone |
Compute (inherited from DataTable) | Computes the given expression on the current rows that pass the filter criteria.
Copy (inherited from DataTable) | Copies both the structure and data for this DataTable.
CreateDataReader (inherited from DataTable) | Returns a DataTableReader corresponding to the data within this DataTable.
Dispose (inherited from MarshalByValueComponent) | Overloaded. Releases all resources used by the MarshalByValueComponent.
EndInit (inherited from DataTable) | Ends the initialization of a DataTable that is used on a form or used by another component. The initialization occurs at runtime.
EndLoadData (inherited from DataTable) | Turns on notifications, index maintenance, and constraints after loading data.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetChanges (inherited from DataTable) | Overloaded. Gets a copy of the DataTable that contains all changes made to it since it was loaded or AcceptChanges was last called.
GetEnumerator |
GetErrors (inherited from DataTable) | Gets an array of DataRow objects that contain errors.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from DataTable) | Populates a serialization information object with the data needed to serialize the DataTable.
GetService (inherited from MarshalByValueComponent) | Gets the implementer of the IServiceProvider.
GetType (inherited from Object) | Gets the Type of the current instance.
ImportRow (inherited from DataTable) | Copies a DataRow into a DataTable, preserving any property settings, as well as original and current values.
Load (inherited from DataTable) | Overloaded. Fills a DataTable with values from a data source using the supplied IDataReader. If the DataTable already contains rows, the incoming data from the data source is merged with the existing rows.
LoadDataRow (inherited from DataTable) | Overloaded. Finds and updates a specific row. If no matching row is found, a new row is created using the given values.
Merge (inherited from DataTable) | Overloaded. Merge the specified DataTable with the current DataTable.
NewRow (inherited from DataTable) | Creates a new DataRow with the same schema as the table.
NewUpdaidInvoicesRow |
ReadXml (inherited from DataTable) | Overloaded. Reads XML schema and data into the DataTable using the specified Stream.
ReadXmlSchema (inherited from DataTable) | Overloaded. Reads an XML schema into the DataTable using the specified stream.
RejectChanges (inherited from DataTable) | Rolls back all changes that have been made to the table since it was loaded, or the last time AcceptChanges was called.
RemoveUpdaidInvoicesRow |
Reset (inherited from DataTable) | Resets the DataTable to its original state.
Select (inherited from DataTable) | Overloaded. Gets an array of all DataRow objects.
ToString (inherited from DataTable) | Gets the TableName and DisplayExpression, if there is one as a concatenated string.
WriteXml (inherited from DataTable) | Overloaded. Writes the current data, and optionally the schema, for the DataTable using the specified TextWriter and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. To save the data for the table and all its descendants, set the writeHierarchy parameter to true.
WriteXmlSchema (inherited from DataTable) | Overloaded. Writes the current data structure of the DataTable as an XML schema to the specified stream.

Public Instance Events

ColumnChanged (inherited from DataTable) | Occurs after a value has been changed for the specified DataColumn in a DataRow.
ColumnChanging (inherited from DataTable) | Occurs when a value is being changed for the specified DataColumn in a DataRow.
Disposed (inherited from MarshalByValueComponent) | Adds an event handler to listen to the Disposed event on the component.
Initialized (inherited from DataTable) | Occurs after the DataTable is initialized.
RowChanged (inherited from DataTable) | Occurs after a DataRow has been changed successfully.
RowChanging (inherited from DataTable) | Occurs when a DataRow is changing.
RowDeleted (inherited from DataTable) | Occurs after a row in the table has been deleted.
RowDeleting (inherited from DataTable) | Occurs before a row in the table is about to be deleted.
TableCleared (inherited from DataTable) | Occurs after a DataTable is cleared.
TableClearing (inherited from DataTable) | Occurs when a DataTable is cleared.
TableNewRow (inherited from DataTable) | Occurs when a new DataRow is inserted.
UpdaidInvoicesRowChanged |
UpdaidInvoicesRowChanging |
UpdaidInvoicesRowDeleted |
UpdaidInvoicesRowDeleting |

Protected Instance Constructors

CommissionPayments.UpdaidInvoicesDataTable Overloaded. Initializes a new instance of the CommissionPayments.UpdaidInvoicesDataTable class.

Protected Instance Properties

Events (inherited from MarshalByValueComponent) Gets the list of event handlers that are attached to this component.

Protected Instance Methods

CreateInstance |
Dispose (inherited from MarshalByValueComponent) | Overloaded. Releases the unmanaged resources used by the MarshalByValueComponent and optionally releases the managed resources.
Finalize (inherited from MarshalByValueComponent) | [To be supplied.]
GetRowType |
GetSchema (inherited from DataTable) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NewRowFromBuilder |
OnPropertyChanging (inherited from DataTable) | Raises the PropertyChanging event.
OnRemoveColumn (inherited from DataTable) | Notifies the DataTable that a DataColumn is being removed.
OnRowChanged |
OnRowChanging |
OnRowDeleted |
OnRowDeleting |
OnTableCleared (inherited from DataTable) | Raises the TableCleared event.
OnTableClearing (inherited from DataTable) | Raises the TableClearing event.
OnTableNewRow (inherited from DataTable) | Raises the TableNewRow event.
ReadXmlSerializable (inherited from DataTable) |

Protected Internal Instance Fields

fInitInProgress (inherited from DataTable)

Protected Internal Instance Methods

NewRowArray (inherited from DataTable) |
OnColumnChanged (inherited from DataTable) | Raises the ColumnChanged event.
OnColumnChanging (inherited from DataTable) | Raises the ColumnChanging event.

See Also

CommissionPayments.UpdaidInvoicesDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.UpdaidInvoicesDataTable Constructor

Initializes a new instance of the CommissionPayments.UpdaidInvoicesDataTable class.

Overload List

Initializes a new instance of the CommissionPayments.UpdaidInvoicesDataTable class.

public CommissionPayments.UpdaidInvoicesDataTable();

protected CommissionPayments.UpdaidInvoicesDataTable(SerializationInfo,StreamingContext);

See Also

CommissionPayments.UpdaidInvoicesDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.UpdaidInvoicesDataTable Constructor ()

Initializes a new instance of the CommissionPayments.UpdaidInvoicesDataTable class.

public CommissionPayments.UpdaidInvoicesDataTable();

See Also

CommissionPayments.UpdaidInvoicesDataTable Class | Aptify.Applications.Commissions Namespace | CommissionPayments.UpdaidInvoicesDataTable Constructor Overload List


CommissionPayments.UpdaidInvoicesDataTable Constructor (SerializationInfo, StreamingContext)

protected CommissionPayments.UpdaidInvoicesDataTable(
SerializationInfo info,
StreamingContext context
);

See Also

CommissionPayments.UpdaidInvoicesDataTable Class | Aptify.Applications.Commissions Namespace | CommissionPayments.UpdaidInvoicesDataTable Constructor Overload List


CommissionPayments.UpdaidInvoicesDataTable Properties

The properties of the CommissionPayments.UpdaidInvoicesDataTable class are listed below. For a complete list of CommissionPayments.UpdaidInvoicesDataTable class members, see the CommissionPayments.UpdaidInvoicesDataTable Members topic.

Public Instance Properties

BalanceColumn |
BalanceFactorColumn |
BaseAdjustmentColumn |
CaseSensitive (inherited from DataTable) | Indicates whether string comparisons within the table are case-sensitive.
ChildRelations (inherited from DataTable) | Gets the collection of child relations for this DataTable.
Columns (inherited from DataTable) | Gets the collection of columns that belong to this table.
Constraints (inherited from DataTable) | Gets the collection of constraints maintained by this table.
Container (inherited from MarshalByValueComponent) | Gets the container for the component.
Count |
CurrentBaseColumn |
DataSet (inherited from DataTable) | Gets the DataSet to which this table belongs.
Days_OldColumn |
DefaultView (inherited from DataTable) | Gets a customized view of the table that may include a filtered view, or a cursor position.
DesignMode (inherited from MarshalByValueComponent) | Gets a value indicating whether the component is currently in design mode.
DisplayExpression (inherited from DataTable) | Gets or sets the expression that returns a value used to represent this table in the user interface.
ExtendedProperties (inherited from DataTable) | Gets the collection of customized user information.
HasErrors (inherited from DataTable) | Gets a value indicating whether there are errors in any of the rows in any of the tables of the DataSet to which the table belongs.
IsInitialized (inherited from DataTable) | Gets a value that indicates whether the DataTable is initialized.
Item |
Locale (inherited from DataTable) | Gets or sets the locale information used to compare strings within the table.
MinimumCapacity (inherited from DataTable) | Gets or sets the initial starting size for this table.
Namespace (inherited from DataTable) | Gets or sets the namespace for the XML representation of the data stored in the DataTable.
NewBaseColumn |
ParentRelations (inherited from DataTable) | Gets the collection of parent relations for this DataTable.
PaymentColumn |
PaymentIndexColumn |
Prefix (inherited from DataTable) | Gets or sets the namespace for the XML representation of the data stored in the DataTable.
PrimaryKey (inherited from DataTable) | Gets or sets an array of columns that function as primary keys for the data table.
ProductColumn |
RemotingFormat (inherited from DataTable) | Gets or sets the serialization format.
Rows (inherited from DataTable) | Gets the collection of rows that belong to this table.
SalesRepNameColumn |
Site (inherited from DataTable) | Gets or sets an ISite for the DataTable.
SourceEntityColumn |
SourceIDColumn |
TableName (inherited from DataTable) | Gets or sets the name of the DataTable.

Protected Instance Properties

Events (inherited from MarshalByValueComponent) Gets the list of event handlers that are attached to this component.

See Also

CommissionPayments.UpdaidInvoicesDataTable Class | Aptify.Applications.Commissions Namespace


BalanceColumn Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.UpdaidInvoicesDataTable.BalanceColumn Property

public DataColumn BalanceColumn {get;}

See Also

CommissionPayments.UpdaidInvoicesDataTable Class | Aptify.Applications.Commissions Namespace


BalanceFactorColumn Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.UpdaidInvoicesDataTable.BalanceFactorColumn Property

public DataColumn BalanceFactorColumn {get;}

See Also

CommissionPayments.UpdaidInvoicesDataTable Class | Aptify.Applications.Commissions Namespace


BaseAdjustmentColumn Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.UpdaidInvoicesDataTable.BaseAdjustmentColumn Property

public DataColumn BaseAdjustmentColumn {get;}

See Also

CommissionPayments.UpdaidInvoicesDataTable Class | Aptify.Applications.Commissions Namespace


Count Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.UpdaidInvoicesDataTable.Count Property

public Int32 Count {get;}

See Also

CommissionPayments.UpdaidInvoicesDataTable Class | Aptify.Applications.Commissions Namespace


CurrentBaseColumn Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.UpdaidInvoicesDataTable.CurrentBaseColumn Property

public DataColumn CurrentBaseColumn {get;}

See Also

CommissionPayments.UpdaidInvoicesDataTable Class | Aptify.Applications.Commissions Namespace


Days_OldColumn Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.UpdaidInvoicesDataTable.Days_OldColumn Property

public DataColumn Days_OldColumn {get;}

See Also

CommissionPayments.UpdaidInvoicesDataTable Class | Aptify.Applications.Commissions Namespace


Item Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.UpdaidInvoicesDataTable.Item Property

public CommissionPayments.UpdaidInvoicesRow this[
Int32 index
] {get;}

See Also

CommissionPayments.UpdaidInvoicesDataTable Class | Aptify.Applications.Commissions Namespace


NewBaseColumn Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.UpdaidInvoicesDataTable.NewBaseColumn Property

public DataColumn NewBaseColumn {get;}

See Also

CommissionPayments.UpdaidInvoicesDataTable Class | Aptify.Applications.Commissions Namespace


PaymentColumn Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.UpdaidInvoicesDataTable.PaymentColumn Property

public DataColumn PaymentColumn {get;}

See Also

CommissionPayments.UpdaidInvoicesDataTable Class | Aptify.Applications.Commissions Namespace


PaymentIndexColumn Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.UpdaidInvoicesDataTable.PaymentIndexColumn Property

public DataColumn PaymentIndexColumn {get;}

See Also

CommissionPayments.UpdaidInvoicesDataTable Class | Aptify.Applications.Commissions Namespace


ProductColumn Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.UpdaidInvoicesDataTable.ProductColumn Property

public DataColumn ProductColumn {get;}

See Also

CommissionPayments.UpdaidInvoicesDataTable Class | Aptify.Applications.Commissions Namespace


SalesRepNameColumn Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.UpdaidInvoicesDataTable.SalesRepNameColumn Property

public DataColumn SalesRepNameColumn {get;}

See Also

CommissionPayments.UpdaidInvoicesDataTable Class | Aptify.Applications.Commissions Namespace


SourceEntityColumn Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.UpdaidInvoicesDataTable.SourceEntityColumn Property

public DataColumn SourceEntityColumn {get;}

See Also

CommissionPayments.UpdaidInvoicesDataTable Class | Aptify.Applications.Commissions Namespace


SourceIDColumn Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.UpdaidInvoicesDataTable.SourceIDColumn Property

public DataColumn SourceIDColumn {get;}

See Also

CommissionPayments.UpdaidInvoicesDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.UpdaidInvoicesDataTable Methods

The methods of the CommissionPayments.UpdaidInvoicesDataTable class are listed below. For a complete list of CommissionPayments.UpdaidInvoicesDataTable class members, see the CommissionPayments.UpdaidInvoicesDataTable Members topic.

Public Static Methods

GetTypedTableSchema

Public Instance Methods

AcceptChanges (inherited from DataTable) | Commits all the changes made to this table since the last time AcceptChanges was called.
AddUpdaidInvoicesRow | Overloaded.
BeginInit (inherited from DataTable) | Begins the initialization of a DataTable that is used on a form or used by another component. The initialization occurs at runtime.
BeginLoadData (inherited from DataTable) | Turns off notifications, index maintenance, and constraints while loading data.
Clear (inherited from DataTable) | Clears the DataTable of all data.
Clone |
Compute (inherited from DataTable) | Computes the given expression on the current rows that pass the filter criteria.
Copy (inherited from DataTable) | Copies both the structure and data for this DataTable.
CreateDataReader (inherited from DataTable) | Returns a DataTableReader corresponding to the data within this DataTable.
Dispose (inherited from MarshalByValueComponent) | Overloaded. Releases all resources used by the MarshalByValueComponent.
EndInit (inherited from DataTable) | Ends the initialization of a DataTable that is used on a form or used by another component. The initialization occurs at runtime.
EndLoadData (inherited from DataTable) | Turns on notifications, index maintenance, and constraints after loading data.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetChanges (inherited from DataTable) | Overloaded. Gets a copy of the DataTable that contains all changes made to it since it was loaded or AcceptChanges was last called.
GetEnumerator |
GetErrors (inherited from DataTable) | Gets an array of DataRow objects that contain errors.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from DataTable) | Populates a serialization information object with the data needed to serialize the DataTable.
GetService (inherited from MarshalByValueComponent) | Gets the implementer of the IServiceProvider.
GetType (inherited from Object) | Gets the Type of the current instance.
ImportRow (inherited from DataTable) | Copies a DataRow into a DataTable, preserving any property settings, as well as original and current values.
Load (inherited from DataTable) | Overloaded. Fills a DataTable with values from a data source using the supplied IDataReader. If the DataTable already contains rows, the incoming data from the data source is merged with the existing rows.
LoadDataRow (inherited from DataTable) | Overloaded. Finds and updates a specific row. If no matching row is found, a new row is created using the given values.
Merge (inherited from DataTable) | Overloaded. Merge the specified DataTable with the current DataTable.
NewRow (inherited from DataTable) | Creates a new DataRow with the same schema as the table.
NewUpdaidInvoicesRow |
ReadXml (inherited from DataTable) | Overloaded. Reads XML schema and data into the DataTable using the specified Stream.
ReadXmlSchema (inherited from DataTable) | Overloaded. Reads an XML schema into the DataTable using the specified stream.
RejectChanges (inherited from DataTable) | Rolls back all changes that have been made to the table since it was loaded, or the last time AcceptChanges was called.
RemoveUpdaidInvoicesRow |
Reset (inherited from DataTable) | Resets the DataTable to its original state.
Select (inherited from DataTable) | Overloaded. Gets an array of all DataRow objects.
ToString (inherited from DataTable) | Gets the TableName and DisplayExpression, if there is one as a concatenated string.
WriteXml (inherited from DataTable) | Overloaded. Writes the current data, and optionally the schema, for the DataTable using the specified TextWriter and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. To save the data for the table and all its descendants, set the writeHierarchy parameter to true.
WriteXmlSchema (inherited from DataTable) | Overloaded. Writes the current data structure of the DataTable as an XML schema to the specified stream.

Protected Instance Methods

CreateInstance |
Dispose (inherited from MarshalByValueComponent) | Overloaded. Releases the unmanaged resources used by the MarshalByValueComponent and optionally releases the managed resources.
Finalize (inherited from MarshalByValueComponent) | [To be supplied.]
GetRowType |
GetSchema (inherited from DataTable) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NewRowFromBuilder |
OnPropertyChanging (inherited from DataTable) | Raises the PropertyChanging event.
OnRemoveColumn (inherited from DataTable) | Notifies the DataTable that a DataColumn is being removed.
OnRowChanged |
OnRowChanging |
OnRowDeleted |
OnRowDeleting |
OnTableCleared (inherited from DataTable) | Raises the TableCleared event.
OnTableClearing (inherited from DataTable) | Raises the TableClearing event.
OnTableNewRow (inherited from DataTable) | Raises the TableNewRow event.
ReadXmlSerializable (inherited from DataTable) |

Protected Internal Instance Methods

NewRowArray (inherited from DataTable) |
OnColumnChanged (inherited from DataTable) | Raises the ColumnChanged event.
OnColumnChanging (inherited from DataTable) | Raises the ColumnChanging event.

See Also

CommissionPayments.UpdaidInvoicesDataTable Class | Aptify.Applications.Commissions Namespace


AddUpdaidInvoicesRow Method

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.UpdaidInvoicesDataTable.AddUpdaidInvoicesRow Method

Overload List

public void AddUpdaidInvoicesRow(CommissionPayments.UpdaidInvoicesRow);

public UpdaidInvoicesRow AddUpdaidInvoicesRow(String,String,String,String,Int64,Decimal,Decimal,Int64,Decimal,Decimal,Int32,Double);

See Also

CommissionPayments.UpdaidInvoicesDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.UpdaidInvoicesDataTable.AddUpdaidInvoicesRow Method (UpdaidInvoicesRow)

public void AddUpdaidInvoicesRow(
CommissionPayments.UpdaidInvoicesRow row
);

See Also

CommissionPayments.UpdaidInvoicesDataTable Class | Aptify.Applications.Commissions Namespace | CommissionPayments.UpdaidInvoicesDataTable.AddUpdaidInvoicesRow Overload List


CommissionPayments.UpdaidInvoicesDataTable.AddUpdaidInvoicesRow Method (String, String, String, String, Int64, Decimal, Decimal, Int64, Decimal, Decimal, Int32, Double)

public UpdaidInvoicesRow AddUpdaidInvoicesRow(
String Payment,
String SalesRepName,
String Product,
String SourceEntity,
Int64 SourceID,
Decimal CurrentBase,
Decimal Balance,
Int64 Days_Old,
Decimal BaseAdjustment,
Decimal NewBase,
Int32 PaymentIndex,
Double BalanceFactor
);

See Also

CommissionPayments.UpdaidInvoicesDataTable Class | Aptify.Applications.Commissions Namespace | CommissionPayments.UpdaidInvoicesDataTable.AddUpdaidInvoicesRow Overload List


CommissionPayments.UpdaidInvoicesDataTable.Clone Method

public override DataTable Clone();

See Also

CommissionPayments.UpdaidInvoicesDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.UpdaidInvoicesDataTable.CreateInstance Method

protected override DataTable CreateInstance();

See Also

CommissionPayments.UpdaidInvoicesDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.UpdaidInvoicesDataTable.GetEnumerator Method

public virtual IEnumerator GetEnumerator();

Implements

IEnumerable.

See Also

CommissionPayments.UpdaidInvoicesDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.UpdaidInvoicesDataTable.GetRowType Method

protected override Type GetRowType();

See Also

CommissionPayments.UpdaidInvoicesDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.UpdaidInvoicesDataTable.GetTypedTableSchema Method

public static XmlSchemaComplexType GetTypedTableSchema(
XmlSchemaSet xs
);

See Also

CommissionPayments.UpdaidInvoicesDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.UpdaidInvoicesDataTable.NewRowFromBuilder Method

protected override DataRow NewRowFromBuilder(
DataRowBuilder builder
);

See Also

CommissionPayments.UpdaidInvoicesDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.UpdaidInvoicesDataTable.NewUpdaidInvoicesRow Method

public UpdaidInvoicesRow NewUpdaidInvoicesRow();

See Also

CommissionPayments.UpdaidInvoicesDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.UpdaidInvoicesDataTable.OnRowChanged Method

protected override void OnRowChanged(
DataRowChangeEventArgs e
);

See Also

CommissionPayments.UpdaidInvoicesDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.UpdaidInvoicesDataTable.OnRowChanging Method

protected override void OnRowChanging(
DataRowChangeEventArgs e
);

See Also

CommissionPayments.UpdaidInvoicesDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.UpdaidInvoicesDataTable.OnRowDeleted Method

protected override void OnRowDeleted(
DataRowChangeEventArgs e
);

See Also

CommissionPayments.UpdaidInvoicesDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.UpdaidInvoicesDataTable.OnRowDeleting Method

protected override void OnRowDeleting(
DataRowChangeEventArgs e
);

See Also

CommissionPayments.UpdaidInvoicesDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.UpdaidInvoicesDataTable.RemoveUpdaidInvoicesRow Method

public void RemoveUpdaidInvoicesRow(
CommissionPayments.UpdaidInvoicesRow row
);

See Also

CommissionPayments.UpdaidInvoicesDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.UpdaidInvoicesDataTable Events

The events of the CommissionPayments.UpdaidInvoicesDataTable class are listed below. For a complete list of CommissionPayments.UpdaidInvoicesDataTable class members, see the CommissionPayments.UpdaidInvoicesDataTable Members topic.

Public Instance Events

ColumnChanged (inherited from DataTable) | Occurs after a value has been changed for the specified DataColumn in a DataRow.
ColumnChanging (inherited from DataTable) | Occurs when a value is being changed for the specified DataColumn in a DataRow.
Disposed (inherited from MarshalByValueComponent) | Adds an event handler to listen to the Disposed event on the component.
Initialized (inherited from DataTable) | Occurs after the DataTable is initialized.
RowChanged (inherited from DataTable) | Occurs after a DataRow has been changed successfully.
RowChanging (inherited from DataTable) | Occurs when a DataRow is changing.
RowDeleted (inherited from DataTable) | Occurs after a row in the table has been deleted.
RowDeleting (inherited from DataTable) | Occurs before a row in the table is about to be deleted.
TableCleared (inherited from DataTable) | Occurs after a DataTable is cleared.
TableClearing (inherited from DataTable) | Occurs when a DataTable is cleared.
TableNewRow (inherited from DataTable) | Occurs when a new DataRow is inserted.
UpdaidInvoicesRowChanged |
UpdaidInvoicesRowChanging |
UpdaidInvoicesRowDeleted |
UpdaidInvoicesRowDeleting |

See Also

CommissionPayments.UpdaidInvoicesDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.UpdaidInvoicesDataTable.CommissionPayments.UpdaidInvoicesRowChangeEventHandler Event

public event CommissionPayments.UpdaidInvoicesRowChangeEventHandler UpdaidInvoicesRowChanged;

See Also

CommissionPayments.UpdaidInvoicesDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.UpdaidInvoicesDataTable.CommissionPayments.UpdaidInvoicesRowChangeEventHandler Event

public event CommissionPayments.UpdaidInvoicesRowChangeEventHandler UpdaidInvoicesRowChanging;

See Also

CommissionPayments.UpdaidInvoicesDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.UpdaidInvoicesDataTable.CommissionPayments.UpdaidInvoicesRowChangeEventHandler Event

public event CommissionPayments.UpdaidInvoicesRowChangeEventHandler UpdaidInvoicesRowDeleted;

See Also

CommissionPayments.UpdaidInvoicesDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.UpdaidInvoicesDataTable.CommissionPayments.UpdaidInvoicesRowChangeEventHandler Event

public event CommissionPayments.UpdaidInvoicesRowChangeEventHandler UpdaidInvoicesRowDeleting;

See Also

CommissionPayments.UpdaidInvoicesDataTable Class | Aptify.Applications.Commissions Namespace


CommissionPayments.UpdaidInvoicesRow Class

Represents strongly named DataRow class.

For a list of all members of this type, see CommissionPayments.UpdaidInvoicesRow Members.

System.Object
DataRow
CommissionPayments.UpdaidInvoicesRow

public class CommissionPayments.UpdaidInvoicesRow : DataRow

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Commissions

Assembly: CommissionPaymentWizard (in CommissionPaymentWizard.dll)

See Also

CommissionPayments.UpdaidInvoicesRow Members | Aptify.Applications.Commissions Namespace


CommissionPayments.UpdaidInvoicesRow Members

CommissionPayments.UpdaidInvoicesRow overview

Public Instance Properties

Balance |
BalanceFactor |
BaseAdjustment |
CurrentBase |
Days_Old |
HasErrors (inherited from DataRow) | Gets a value that indicates whether there are errors in a row.
Item (inherited from DataRow) | Gets or sets the data stored in the column specified by index.
Item (inherited from DataRow) | Gets or sets the data stored in the column specified by name.
Item (inherited from DataRow) | Gets or sets the data stored in the specified DataColumn.
Item (inherited from DataRow) | Gets the data stored in the column, specified by index and version of the data to retrieve.
Item (inherited from DataRow) | Gets the specified version of data stored in the named column.
Item (inherited from DataRow) | Gets the specified version of data stored in the specified DataColumn.
ItemArray (inherited from DataRow) | Gets or sets all the values for this row through an array.
NewBase |
Payment |
PaymentIndex |
Product |
RowError (inherited from DataRow) | Gets or sets the custom error description for a row.
RowState (inherited from DataRow) | Gets the current state of the row with regard to its relationship to the DataRowCollection.
SalesRepName |
SourceEntity |
SourceID |
Table (inherited from DataRow) | Gets the DataTable for which this row has a schema.

Public Instance Methods

AcceptChanges (inherited from DataRow) | Commits all the changes made to this row since the last time AcceptChanges was called.
BeginEdit (inherited from DataRow) | Starts an edit operation on a DataRow object.
CancelEdit (inherited from DataRow) | Cancels the current edit on the row.
ClearErrors (inherited from DataRow) | Clears the errors for the row. This includes the RowError and errors set with SetColumnError.
Delete (inherited from DataRow) | Deletes the DataRow.
EndEdit (inherited from DataRow) | Ends the edit occurring on the row.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetChildRows (inherited from DataRow) | Overloaded. Gets the child rows of a DataRow using the specified RelationName of a DataRelation.
GetColumnError (inherited from DataRow) | Overloaded. Gets the error description for the column specified by index.
GetColumnsInError (inherited from DataRow) | Gets an array of columns that have errors.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetParentRow (inherited from DataRow) | Overloaded. Gets the parent row of a DataRow using the specified RelationName of a DataRelation.
GetParentRows (inherited from DataRow) | Overloaded. Gets the parent rows of a DataRow using the specified RelationName of a DataRelation.
GetType (inherited from Object) | Gets the Type of the current instance.
HasVersion (inherited from DataRow) | Gets a value that indicates whether a specified version exists.
IsBalanceFactorNull |
IsBalanceNull |
IsBaseAdjustmentNull |
IsCurrentBaseNull |
IsDays_OldNull |
IsNewBaseNull |
IsNull (inherited from DataRow) | Overloaded. Gets a value that indicates whether the column at the specified index contains a null value.
IsPaymentIndexNull |
IsPaymentNull |
IsProductNull |
IsSalesRepNameNull |
IsSourceEntityNull |
IsSourceIDNull |
RejectChanges (inherited from DataRow) | Rejects all changes made to the row since AcceptChanges was last called.
SetAdded (inherited from DataRow) | Changes the Rowstate of a DataRow to Added.
SetBalanceFactorNull |
SetBalanceNull |
SetBaseAdjustmentNull |
SetColumnError (inherited from DataRow) | Overloaded. Sets the error description for a column specified by index.
SetCurrentBaseNull |
SetDays_OldNull |
SetModified (inherited from DataRow) | Changes the Rowstate of a DataRow to Modified.
SetNewBaseNull |
SetParentRow (inherited from DataRow) | Overloaded. Sets the parent row of a DataRow with specified new parent DataRow.
SetPaymentIndexNull |
SetPaymentNull |
SetProductNull |
SetSalesRepNameNull |
SetSourceEntityNull |
SetSourceIDNull |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetNull (inherited from DataRow) | Sets the value of the specified DataColumn to a null value.

See Also

CommissionPayments.UpdaidInvoicesRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.UpdaidInvoicesRow Properties

The properties of the CommissionPayments.UpdaidInvoicesRow class are listed below. For a complete list of CommissionPayments.UpdaidInvoicesRow class members, see the CommissionPayments.UpdaidInvoicesRow Members topic.

Public Instance Properties

Balance |
BalanceFactor |
BaseAdjustment |
CurrentBase |
Days_Old |
HasErrors (inherited from DataRow) | Gets a value that indicates whether there are errors in a row.
Item (inherited from DataRow) | Gets or sets the data stored in the column specified by index.
Item (inherited from DataRow) | Gets or sets the data stored in the column specified by name.
Item (inherited from DataRow) | Gets or sets the data stored in the specified DataColumn.
Item (inherited from DataRow) | Gets the data stored in the column, specified by index and version of the data to retrieve.
Item (inherited from DataRow) | Gets the specified version of data stored in the named column.
Item (inherited from DataRow) | Gets the specified version of data stored in the specified DataColumn.
ItemArray (inherited from DataRow) | Gets or sets all the values for this row through an array.
NewBase |
Payment |
PaymentIndex |
Product |
RowError (inherited from DataRow) | Gets or sets the custom error description for a row.
RowState (inherited from DataRow) | Gets the current state of the row with regard to its relationship to the DataRowCollection.
SalesRepName |
SourceEntity |
SourceID |
Table (inherited from DataRow) | Gets the DataTable for which this row has a schema.

See Also

CommissionPayments.UpdaidInvoicesRow Class | Aptify.Applications.Commissions Namespace


Balance Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.UpdaidInvoicesRow.Balance Property

public Decimal Balance {get; set;}

See Also

CommissionPayments.UpdaidInvoicesRow Class | Aptify.Applications.Commissions Namespace


BalanceFactor Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.UpdaidInvoicesRow.BalanceFactor Property

public Double BalanceFactor {get; set;}

See Also

CommissionPayments.UpdaidInvoicesRow Class | Aptify.Applications.Commissions Namespace


BaseAdjustment Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.UpdaidInvoicesRow.BaseAdjustment Property

public Decimal BaseAdjustment {get; set;}

See Also

CommissionPayments.UpdaidInvoicesRow Class | Aptify.Applications.Commissions Namespace


CurrentBase Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.UpdaidInvoicesRow.CurrentBase Property

public Decimal CurrentBase {get; set;}

See Also

CommissionPayments.UpdaidInvoicesRow Class | Aptify.Applications.Commissions Namespace


Days_Old Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.UpdaidInvoicesRow.Days_Old Property

public Int64 Days_Old {get; set;}

See Also

CommissionPayments.UpdaidInvoicesRow Class | Aptify.Applications.Commissions Namespace


NewBase Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.UpdaidInvoicesRow.NewBase Property

public Decimal NewBase {get; set;}

See Also

CommissionPayments.UpdaidInvoicesRow Class | Aptify.Applications.Commissions Namespace


Payment Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.UpdaidInvoicesRow.Payment Property

public String Payment {get; set;}

See Also

CommissionPayments.UpdaidInvoicesRow Class | Aptify.Applications.Commissions Namespace


PaymentIndex Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.UpdaidInvoicesRow.PaymentIndex Property

public Int32 PaymentIndex {get; set;}

See Also

CommissionPayments.UpdaidInvoicesRow Class | Aptify.Applications.Commissions Namespace


Product Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.UpdaidInvoicesRow.Product Property

public String Product {get; set;}

See Also

CommissionPayments.UpdaidInvoicesRow Class | Aptify.Applications.Commissions Namespace


SalesRepName Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.UpdaidInvoicesRow.SalesRepName Property

public String SalesRepName {get; set;}

See Also

CommissionPayments.UpdaidInvoicesRow Class | Aptify.Applications.Commissions Namespace


SourceEntity Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.UpdaidInvoicesRow.SourceEntity Property

public String SourceEntity {get; set;}

See Also

CommissionPayments.UpdaidInvoicesRow Class | Aptify.Applications.Commissions Namespace


SourceID Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.UpdaidInvoicesRow.SourceID Property

public Int64 SourceID {get; set;}

See Also

CommissionPayments.UpdaidInvoicesRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.UpdaidInvoicesRow Methods

The methods of the CommissionPayments.UpdaidInvoicesRow class are listed below. For a complete list of CommissionPayments.UpdaidInvoicesRow class members, see the CommissionPayments.UpdaidInvoicesRow Members topic.

Public Instance Methods

AcceptChanges (inherited from DataRow) | Commits all the changes made to this row since the last time AcceptChanges was called.
BeginEdit (inherited from DataRow) | Starts an edit operation on a DataRow object.
CancelEdit (inherited from DataRow) | Cancels the current edit on the row.
ClearErrors (inherited from DataRow) | Clears the errors for the row. This includes the RowError and errors set with SetColumnError.
Delete (inherited from DataRow) | Deletes the DataRow.
EndEdit (inherited from DataRow) | Ends the edit occurring on the row.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetChildRows (inherited from DataRow) | Overloaded. Gets the child rows of a DataRow using the specified RelationName of a DataRelation.
GetColumnError (inherited from DataRow) | Overloaded. Gets the error description for the column specified by index.
GetColumnsInError (inherited from DataRow) | Gets an array of columns that have errors.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetParentRow (inherited from DataRow) | Overloaded. Gets the parent row of a DataRow using the specified RelationName of a DataRelation.
GetParentRows (inherited from DataRow) | Overloaded. Gets the parent rows of a DataRow using the specified RelationName of a DataRelation.
GetType (inherited from Object) | Gets the Type of the current instance.
HasVersion (inherited from DataRow) | Gets a value that indicates whether a specified version exists.
IsBalanceFactorNull |
IsBalanceNull |
IsBaseAdjustmentNull |
IsCurrentBaseNull |
IsDays_OldNull |
IsNewBaseNull |
IsNull (inherited from DataRow) | Overloaded. Gets a value that indicates whether the column at the specified index contains a null value.
IsPaymentIndexNull |
IsPaymentNull |
IsProductNull |
IsSalesRepNameNull |
IsSourceEntityNull |
IsSourceIDNull |
RejectChanges (inherited from DataRow) | Rejects all changes made to the row since AcceptChanges was last called.
SetAdded (inherited from DataRow) | Changes the Rowstate of a DataRow to Added.
SetBalanceFactorNull |
SetBalanceNull |
SetBaseAdjustmentNull |
SetColumnError (inherited from DataRow) | Overloaded. Sets the error description for a column specified by index.
SetCurrentBaseNull |
SetDays_OldNull |
SetModified (inherited from DataRow) | Changes the Rowstate of a DataRow to Modified.
SetNewBaseNull |
SetParentRow (inherited from DataRow) | Overloaded. Sets the parent row of a DataRow with specified new parent DataRow.
SetPaymentIndexNull |
SetPaymentNull |
SetProductNull |
SetSalesRepNameNull |
SetSourceEntityNull |
SetSourceIDNull |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetNull (inherited from DataRow) | Sets the value of the specified DataColumn to a null value.

See Also

CommissionPayments.UpdaidInvoicesRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.UpdaidInvoicesRow.IsBalanceFactorNull Method

public bool IsBalanceFactorNull();

See Also

CommissionPayments.UpdaidInvoicesRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.UpdaidInvoicesRow.IsBalanceNull Method

public bool IsBalanceNull();

See Also

CommissionPayments.UpdaidInvoicesRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.UpdaidInvoicesRow.IsBaseAdjustmentNull Method

public bool IsBaseAdjustmentNull();

See Also

CommissionPayments.UpdaidInvoicesRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.UpdaidInvoicesRow.IsCurrentBaseNull Method

public bool IsCurrentBaseNull();

See Also

CommissionPayments.UpdaidInvoicesRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.UpdaidInvoicesRow.IsDays_OldNull Method

public bool IsDays_OldNull();

See Also

CommissionPayments.UpdaidInvoicesRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.UpdaidInvoicesRow.IsNewBaseNull Method

public bool IsNewBaseNull();

See Also

CommissionPayments.UpdaidInvoicesRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.UpdaidInvoicesRow.IsPaymentIndexNull Method

public bool IsPaymentIndexNull();

See Also

CommissionPayments.UpdaidInvoicesRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.UpdaidInvoicesRow.IsPaymentNull Method

public bool IsPaymentNull();

See Also

CommissionPayments.UpdaidInvoicesRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.UpdaidInvoicesRow.IsProductNull Method

public bool IsProductNull();

See Also

CommissionPayments.UpdaidInvoicesRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.UpdaidInvoicesRow.IsSalesRepNameNull Method

public bool IsSalesRepNameNull();

See Also

CommissionPayments.UpdaidInvoicesRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.UpdaidInvoicesRow.IsSourceEntityNull Method

public bool IsSourceEntityNull();

See Also

CommissionPayments.UpdaidInvoicesRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.UpdaidInvoicesRow.IsSourceIDNull Method

public bool IsSourceIDNull();

See Also

CommissionPayments.UpdaidInvoicesRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.UpdaidInvoicesRow.SetBalanceFactorNull Method

public void SetBalanceFactorNull();

See Also

CommissionPayments.UpdaidInvoicesRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.UpdaidInvoicesRow.SetBalanceNull Method

public void SetBalanceNull();

See Also

CommissionPayments.UpdaidInvoicesRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.UpdaidInvoicesRow.SetBaseAdjustmentNull Method

public void SetBaseAdjustmentNull();

See Also

CommissionPayments.UpdaidInvoicesRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.UpdaidInvoicesRow.SetCurrentBaseNull Method

public void SetCurrentBaseNull();

See Also

CommissionPayments.UpdaidInvoicesRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.UpdaidInvoicesRow.SetDays_OldNull Method

public void SetDays_OldNull();

See Also

CommissionPayments.UpdaidInvoicesRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.UpdaidInvoicesRow.SetNewBaseNull Method

public void SetNewBaseNull();

See Also

CommissionPayments.UpdaidInvoicesRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.UpdaidInvoicesRow.SetPaymentIndexNull Method

public void SetPaymentIndexNull();

See Also

CommissionPayments.UpdaidInvoicesRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.UpdaidInvoicesRow.SetPaymentNull Method

public void SetPaymentNull();

See Also

CommissionPayments.UpdaidInvoicesRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.UpdaidInvoicesRow.SetProductNull Method

public void SetProductNull();

See Also

CommissionPayments.UpdaidInvoicesRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.UpdaidInvoicesRow.SetSalesRepNameNull Method

public void SetSalesRepNameNull();

See Also

CommissionPayments.UpdaidInvoicesRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.UpdaidInvoicesRow.SetSourceEntityNull Method

public void SetSourceEntityNull();

See Also

CommissionPayments.UpdaidInvoicesRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.UpdaidInvoicesRow.SetSourceIDNull Method

public void SetSourceIDNull();

See Also

CommissionPayments.UpdaidInvoicesRow Class | Aptify.Applications.Commissions Namespace


CommissionPayments.UpdaidInvoicesRowChangeEvent Class

Row event argument class

For a list of all members of this type, see CommissionPayments.UpdaidInvoicesRowChangeEvent Members.

System.Object
EventArgs
CommissionPayments.UpdaidInvoicesRowChangeEvent

public class CommissionPayments.UpdaidInvoicesRowChangeEvent : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Commissions

Assembly: CommissionPaymentWizard (in CommissionPaymentWizard.dll)

See Also

CommissionPayments.UpdaidInvoicesRowChangeEvent Members | Aptify.Applications.Commissions Namespace


CommissionPayments.UpdaidInvoicesRowChangeEvent Members

CommissionPayments.UpdaidInvoicesRowChangeEvent overview

Public Instance Constructors

CommissionPayments.UpdaidInvoicesRowChangeEvent Constructor

Public Instance Properties

Action
Row

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CommissionPayments.UpdaidInvoicesRowChangeEvent Class | Aptify.Applications.Commissions Namespace


CommissionPayments.UpdaidInvoicesRowChangeEvent Constructor

public CommissionPayments.UpdaidInvoicesRowChangeEvent(
CommissionPayments.UpdaidInvoicesRow row,
DataRowAction action
);

See Also

CommissionPayments.UpdaidInvoicesRowChangeEvent Class | Aptify.Applications.Commissions Namespace


CommissionPayments.UpdaidInvoicesRowChangeEvent Properties

The properties of the CommissionPayments.UpdaidInvoicesRowChangeEvent class are listed below. For a complete list of CommissionPayments.UpdaidInvoicesRowChangeEvent class members, see the CommissionPayments.UpdaidInvoicesRowChangeEvent Members topic.

Public Instance Properties

Action
Row

See Also

CommissionPayments.UpdaidInvoicesRowChangeEvent Class | Aptify.Applications.Commissions Namespace


Action Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.UpdaidInvoicesRowChangeEvent.Action Property

public DataRowAction Action {get;}

See Also

CommissionPayments.UpdaidInvoicesRowChangeEvent Class | Aptify.Applications.Commissions Namespace


Row Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPayments.UpdaidInvoicesRowChangeEvent.Row Property

public CommissionPayments.UpdaidInvoicesRow Row {get;}

See Also

CommissionPayments.UpdaidInvoicesRowChangeEvent Class | Aptify.Applications.Commissions Namespace


CommissionPayments.UpdaidInvoicesRowChangeEventHandler Delegate

public delegate void CommissionPayments.UpdaidInvoicesRowChangeEventHandler(
Object sender,
CommissionPayments.UpdaidInvoicesRowChangeEvent e
);

Requirements

Namespace: Aptify.Applications.Commissions

Assembly: CommissionPaymentWizard (in CommissionPaymentWizard.dll)

See Also

Aptify.Applications.Commissions Namespace


CommissionPaymentViewer Class

For a list of all members of this type, see CommissionPaymentViewer Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
CommissionPaymentViewer

public class CommissionPaymentViewer : Form, IAptifyTopLevelViewer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Commissions

Assembly: CommissionPaymentControls (in CommissionPaymentControls.dll)

See Also

CommissionPaymentViewer Members | Aptify.Applications.Commissions Namespace


CommissionPaymentViewer Members

CommissionPaymentViewer overview

Public Instance Constructors

CommissionPaymentViewer Constructor Initializes a new instance of the CommissionPaymentViewer class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config | Overloaded.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
Show1 | Overloaded.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
ShowDialog1 | Overloaded.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

m_oApp
m_rsSource
m_rsTiers
m_sDatabase
m_sSourceKey
m_sTierKey
mcAdjTotal

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
m_oGE |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
ConfigureDisplay |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CommissionPaymentViewer Class | Aptify.Applications.Commissions Namespace


CommissionPaymentViewer Constructor

Initializes a new instance of the CommissionPaymentViewer class.

public CommissionPaymentViewer();

See Also

CommissionPaymentViewer Class | Aptify.Applications.Commissions Namespace


CommissionPaymentViewer Fields

The fields of the CommissionPaymentViewer class are listed below. For a complete list of CommissionPaymentViewer class members, see the CommissionPaymentViewer Members topic.

Protected Instance Fields

m_oApp
m_rsSource
m_rsTiers
m_sDatabase
m_sSourceKey
m_sTierKey
mcAdjTotal

See Also

CommissionPaymentViewer Class | Aptify.Applications.Commissions Namespace


CommissionPaymentViewer.m_oApp Field

protected m_oApp m_oApp;

See Also

CommissionPaymentViewer Class | Aptify.Applications.Commissions Namespace


CommissionPaymentViewer.m_rsSource Field

protected m_rsSource m_rsSource;

See Also

CommissionPaymentViewer Class | Aptify.Applications.Commissions Namespace


CommissionPaymentViewer.m_rsTiers Field

protected m_rsTiers m_rsTiers;

See Also

CommissionPaymentViewer Class | Aptify.Applications.Commissions Namespace


CommissionPaymentViewer.m_sDatabase Field

protected m_sDatabase m_sDatabase;

See Also

CommissionPaymentViewer Class | Aptify.Applications.Commissions Namespace


CommissionPaymentViewer.m_sSourceKey Field

protected m_sSourceKey m_sSourceKey;

See Also

CommissionPaymentViewer Class | Aptify.Applications.Commissions Namespace


CommissionPaymentViewer.m_sTierKey Field

protected m_sTierKey m_sTierKey;

See Also

CommissionPaymentViewer Class | Aptify.Applications.Commissions Namespace


CommissionPaymentViewer.mcAdjTotal Field

protected mcAdjTotal mcAdjTotal;

See Also

CommissionPaymentViewer Class | Aptify.Applications.Commissions Namespace


CommissionPaymentViewer Properties

The properties of the CommissionPaymentViewer class are listed below. For a complete list of CommissionPaymentViewer class members, see the CommissionPaymentViewer Members topic.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
m_oGE |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

CommissionPaymentViewer Class | Aptify.Applications.Commissions Namespace


m_oGE Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPaymentViewer.m_oGE Property

protected virtual AptifyGenericEntityBase m_oGE {get; set;}

See Also

CommissionPaymentViewer Class | Aptify.Applications.Commissions Namespace


CommissionPaymentViewer Methods

The methods of the CommissionPaymentViewer class are listed below. For a complete list of CommissionPaymentViewer class members, see the CommissionPaymentViewer Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config | Overloaded.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
Show1 | Overloaded.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
ShowDialog1 | Overloaded.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
ConfigureDisplay |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CommissionPaymentViewer Class | Aptify.Applications.Commissions Namespace


CommissionPaymentViewer.ApplySkin Method

protected virtual void ApplySkin();

See Also

CommissionPaymentViewer Class | Aptify.Applications.Commissions Namespace


Config Method

Aptify 5.0 Software Development Kit (SDK)

CommissionPaymentViewer.Config Method

Overload List

public void Config(AptifyGenericEntityBase);

public void Config(UserCredentials,String);

public void Config(UserCredentials,String,Int64);

public void Config(UserCredentials,String,String);

See Also

CommissionPaymentViewer Class | Aptify.Applications.Commissions Namespace


CommissionPaymentViewer.Config Method (AptifyGenericEntityBase)

public void Config(
AptifyGenericEntityBase GE
);

Implements

IAptifyTopLevelViewer.

See Also

CommissionPaymentViewer Class | Aptify.Applications.Commissions Namespace | CommissionPaymentViewer.Config Overload List


CommissionPaymentViewer.Config Method (UserCredentials, String)

public void Config(
UserCredentials UserCredentials,
String CmdString
);

Implements

IAptifyTopLevelViewer.

See Also

CommissionPaymentViewer Class | Aptify.Applications.Commissions Namespace | CommissionPaymentViewer.Config Overload List


CommissionPaymentViewer.Config Method (UserCredentials, String, Int64)

public void Config(
UserCredentials UserCredentials,
String EntityName,
Int64 RecordID
);

Implements

IAptifyTopLevelViewer.

See Also

CommissionPaymentViewer Class | Aptify.Applications.Commissions Namespace | CommissionPaymentViewer.Config Overload List


CommissionPaymentViewer.Config Method (UserCredentials, String, String)

public void Config(
UserCredentials UserCredentials,
String EntityName,
String NewRecordParameters
);

Implements

IAptifyTopLevelViewer.

See Also

CommissionPaymentViewer Class | Aptify.Applications.Commissions Namespace | CommissionPaymentViewer.Config Overload List


CommissionPaymentViewer.ConfigureDisplay Method

protected virtual void ConfigureDisplay();

See Also

CommissionPaymentViewer Class | Aptify.Applications.Commissions Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

CommissionPaymentViewer.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

CommissionPaymentViewer Class | Aptify.Applications.Commissions Namespace


CommissionPaymentViewer.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

CommissionPaymentViewer Class | Aptify.Applications.Commissions Namespace | CommissionPaymentViewer.Dispose Overload List


Show1 Method

Aptify 5.0 Software Development Kit (SDK)

CommissionPaymentViewer.Show1 Method

Overload List

public void Show1();

public void Show1(Form);

See Also

CommissionPaymentViewer Class | Aptify.Applications.Commissions Namespace


CommissionPaymentViewer.Show1 Method ()

public void Show1();

Implements

IAptifyTopLevelViewer.

See Also

CommissionPaymentViewer Class | Aptify.Applications.Commissions Namespace | CommissionPaymentViewer.Show1 Overload List


CommissionPaymentViewer.Show1 Method (Form)

public void Show1(
Form ParentForm
);

Implements

IAptifyTopLevelViewer.

See Also

CommissionPaymentViewer Class | Aptify.Applications.Commissions Namespace | CommissionPaymentViewer.Show1 Overload List


ShowDialog1 Method

Aptify 5.0 Software Development Kit (SDK)

CommissionPaymentViewer.ShowDialog1 Method

Overload List

public DialogResult ShowDialog1();

public DialogResult ShowDialog1(Form);

See Also

CommissionPaymentViewer Class | Aptify.Applications.Commissions Namespace


CommissionPaymentViewer.ShowDialog1 Method ()

public DialogResult ShowDialog1();

Implements

IAptifyTopLevelViewer.

See Also

CommissionPaymentViewer Class | Aptify.Applications.Commissions Namespace | CommissionPaymentViewer.ShowDialog1 Overload List


CommissionPaymentViewer.ShowDialog1 Method (Form)

public DialogResult ShowDialog1(
Form ParentForm
);

Implements

IAptifyTopLevelViewer.

See Also

CommissionPaymentViewer Class | Aptify.Applications.Commissions Namespace | CommissionPaymentViewer.ShowDialog1 Overload List


CommissionPaymentViewer.PaymentTreeNode Class

For a list of all members of this type, see CommissionPaymentViewer.PaymentTreeNode Members.

System.Object
MarshalByRefObject
TreeNode
CommissionPaymentViewer.PaymentTreeNode

protected class CommissionPaymentViewer.PaymentTreeNode : TreeNode

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Commissions

Assembly: CommissionPaymentControls (in CommissionPaymentControls.dll)

See Also

CommissionPaymentViewer.PaymentTreeNode Members | Aptify.Applications.Commissions Namespace


CommissionPaymentViewer.PaymentTreeNode Members

CommissionPaymentViewer.PaymentTreeNode overview

Public Instance Constructors

CommissionPaymentViewer.PaymentTreeNode Overloaded. Initializes a new instance of the CommissionPaymentViewer.PaymentTreeNode class.

Public Instance Properties

AgreementID |
BackColor (inherited from TreeNode) | Gets or sets the background color of the tree node.
Bounds (inherited from TreeNode) | Gets the bounds of the tree node.
Checked (inherited from TreeNode) | Gets or sets a value indicating whether the tree node is in a checked state.
ContextMenu (inherited from TreeNode) | Gets the shortcut menu associated with this tree node.
ContextMenuStrip (inherited from TreeNode) | Gets or sets the shortcut menu associated with this tree node.
FirstNode (inherited from TreeNode) | Gets the first child tree node in the tree node collection.
ForeColor (inherited from TreeNode) | Gets or sets the foreground color of the tree node.
FullPath (inherited from TreeNode) | Gets the path from the root tree node to the current tree node.
Generation |
Handle (inherited from TreeNode) | Gets the handle of the tree node.
ImageIndex (inherited from TreeNode) | Gets or sets the image list index value of the image displayed when the tree node is in the unselected state.
ImageKey (inherited from TreeNode) | Gets or sets the key for the image associated with this tree node when the node is in an unselected state.
Index (inherited from TreeNode) | Gets the position of the tree node in the tree node collection.
IsEditing (inherited from TreeNode) | Gets a value indicating whether the tree node is in an editable state.
IsExpanded (inherited from TreeNode) | Gets a value indicating whether the tree node is in the expanded state.
IsSelected (inherited from TreeNode) | Gets a value indicating whether the tree node is in the selected state.
IsVisible (inherited from TreeNode) | Gets a value indicating whether the tree node is visible or partially visible.
LastNode (inherited from TreeNode) | Gets the last child tree node.
Level (inherited from TreeNode) | Gets the zero-based depth of the tree node in the TreeView control.
Name (inherited from TreeNode) | Gets or sets the name of the tree node.
NextNode (inherited from TreeNode) | Gets the next sibling tree node.
NextVisibleNode (inherited from TreeNode) | Gets the next visible tree node.
NodeFont (inherited from TreeNode) | Gets or sets the font used to display the text on the tree node's label.
Nodes (inherited from TreeNode) | Gets the collection of TreeNode objects assigned to the current tree node.
Parent (inherited from TreeNode) | Gets the parent tree node of the current tree node.
PlanID |
PlanItemID |
PrevNode (inherited from TreeNode) | Gets the previous sibling tree node.
PrevVisibleNode (inherited from TreeNode) | Gets the previous visible tree node.
SalesRepID |
SalesRepNode |
SalesRepType |
SelectedImageIndex (inherited from TreeNode) | Gets or sets the image list index value of the image that is displayed when the tree node is in the selected state.
SelectedImageKey (inherited from TreeNode) | Gets or sets the key of the image displayed in the tree node when it is in a selected state.
StateImageIndex (inherited from TreeNode) | Gets or sets the index of the image used to indicate the state of the TreeNode when the parent TreeView has its CheckBoxes property set to false.
StateImageKey (inherited from TreeNode) | Gets or sets the key of the image used to indicate the state of the TreeNode when the parent TreeView has its CheckBoxes property set to false.
Tag (inherited from TreeNode) | Gets or sets the object that contains data about the tree node.
Text (inherited from TreeNode) | Gets or sets the text displayed in the label of the tree node.
ToolTipText (inherited from TreeNode) | Gets or sets the text that appears when the mouse pointer hovers over a TreeNode.
TreeView (inherited from TreeNode) | Gets the parent tree view that the tree node is assigned to.

Public Instance Methods

BeginEdit (inherited from TreeNode) | Initiates the editing of the tree node label.
Clone (inherited from TreeNode) | Copies the tree node and the entire subtree rooted at this tree node.
Collapse (inherited from TreeNode) | Overloaded. Collapses the TreeNode and optionally collapses its children.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
EndEdit (inherited from TreeNode) | Ends the editing of the tree node label.
EnsureVisible (inherited from TreeNode) | Ensures that the tree node is visible, expanding tree nodes and scrolling the tree view control as necessary.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Expand (inherited from TreeNode) | Expands the tree node.
ExpandAll (inherited from TreeNode) | Expands all the child tree nodes.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNodeCount (inherited from TreeNode) | Returns the number of child tree nodes.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Remove (inherited from TreeNode) | Removes the current tree node from the tree view control.
Toggle (inherited from TreeNode) | Toggles the tree node to either the expanded or collapsed state.
ToString (inherited from TreeNode) |

Protected Instance Methods

Deserialize (inherited from TreeNode) | Loads the state of the TreeNode from the specified SerializationInfo.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
Serialize (inherited from TreeNode) | Saves the state of the TreeNode to the specified SerializationInfo.

See Also

CommissionPaymentViewer.PaymentTreeNode Class | Aptify.Applications.Commissions Namespace


CommissionPaymentViewer.PaymentTreeNode Constructor

Initializes a new instance of the CommissionPaymentViewer.PaymentTreeNode class.

Overload List

Initializes a new instance of the CommissionPaymentViewer.PaymentTreeNode class.

public CommissionPaymentViewer.PaymentTreeNode();

public CommissionPaymentViewer.PaymentTreeNode(String,Int32);

See Also

CommissionPaymentViewer.PaymentTreeNode Class | Aptify.Applications.Commissions Namespace


CommissionPaymentViewer.PaymentTreeNode Constructor ()

Initializes a new instance of the CommissionPaymentViewer.PaymentTreeNode class.

public CommissionPaymentViewer.PaymentTreeNode();

See Also

CommissionPaymentViewer.PaymentTreeNode Class | Aptify.Applications.Commissions Namespace | CommissionPaymentViewer.PaymentTreeNode Constructor Overload List


CommissionPaymentViewer.PaymentTreeNode Constructor (String, Int32)

public CommissionPaymentViewer.PaymentTreeNode(
String Text,
Int32 ImageIndex
);

See Also

CommissionPaymentViewer.PaymentTreeNode Class | Aptify.Applications.Commissions Namespace | CommissionPaymentViewer.PaymentTreeNode Constructor Overload List


CommissionPaymentViewer.PaymentTreeNode Properties

The properties of the CommissionPaymentViewer.PaymentTreeNode class are listed below. For a complete list of CommissionPaymentViewer.PaymentTreeNode class members, see the CommissionPaymentViewer.PaymentTreeNode Members topic.

Public Instance Properties

AgreementID |
BackColor (inherited from TreeNode) | Gets or sets the background color of the tree node.
Bounds (inherited from TreeNode) | Gets the bounds of the tree node.
Checked (inherited from TreeNode) | Gets or sets a value indicating whether the tree node is in a checked state.
ContextMenu (inherited from TreeNode) | Gets the shortcut menu associated with this tree node.
ContextMenuStrip (inherited from TreeNode) | Gets or sets the shortcut menu associated with this tree node.
FirstNode (inherited from TreeNode) | Gets the first child tree node in the tree node collection.
ForeColor (inherited from TreeNode) | Gets or sets the foreground color of the tree node.
FullPath (inherited from TreeNode) | Gets the path from the root tree node to the current tree node.
Generation |
Handle (inherited from TreeNode) | Gets the handle of the tree node.
ImageIndex (inherited from TreeNode) | Gets or sets the image list index value of the image displayed when the tree node is in the unselected state.
ImageKey (inherited from TreeNode) | Gets or sets the key for the image associated with this tree node when the node is in an unselected state.
Index (inherited from TreeNode) | Gets the position of the tree node in the tree node collection.
IsEditing (inherited from TreeNode) | Gets a value indicating whether the tree node is in an editable state.
IsExpanded (inherited from TreeNode) | Gets a value indicating whether the tree node is in the expanded state.
IsSelected (inherited from TreeNode) | Gets a value indicating whether the tree node is in the selected state.
IsVisible (inherited from TreeNode) | Gets a value indicating whether the tree node is visible or partially visible.
LastNode (inherited from TreeNode) | Gets the last child tree node.
Level (inherited from TreeNode) | Gets the zero-based depth of the tree node in the TreeView control.
Name (inherited from TreeNode) | Gets or sets the name of the tree node.
NextNode (inherited from TreeNode) | Gets the next sibling tree node.
NextVisibleNode (inherited from TreeNode) | Gets the next visible tree node.
NodeFont (inherited from TreeNode) | Gets or sets the font used to display the text on the tree node's label.
Nodes (inherited from TreeNode) | Gets the collection of TreeNode objects assigned to the current tree node.
Parent (inherited from TreeNode) | Gets the parent tree node of the current tree node.
PlanID |
PlanItemID |
PrevNode (inherited from TreeNode) | Gets the previous sibling tree node.
PrevVisibleNode (inherited from TreeNode) | Gets the previous visible tree node.
SalesRepID |
SalesRepNode |
SalesRepType |
SelectedImageIndex (inherited from TreeNode) | Gets or sets the image list index value of the image that is displayed when the tree node is in the selected state.
SelectedImageKey (inherited from TreeNode) | Gets or sets the key of the image displayed in the tree node when it is in a selected state.
StateImageIndex (inherited from TreeNode) | Gets or sets the index of the image used to indicate the state of the TreeNode when the parent TreeView has its CheckBoxes property set to false.
StateImageKey (inherited from TreeNode) | Gets or sets the key of the image used to indicate the state of the TreeNode when the parent TreeView has its CheckBoxes property set to false.
Tag (inherited from TreeNode) | Gets or sets the object that contains data about the tree node.
Text (inherited from TreeNode) | Gets or sets the text displayed in the label of the tree node.
ToolTipText (inherited from TreeNode) | Gets or sets the text that appears when the mouse pointer hovers over a TreeNode.
TreeView (inherited from TreeNode) | Gets the parent tree view that the tree node is assigned to.

See Also

CommissionPaymentViewer.PaymentTreeNode Class | Aptify.Applications.Commissions Namespace


AgreementID Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPaymentViewer.PaymentTreeNode.AgreementID Property

public Int64 AgreementID {get; set;}

See Also

CommissionPaymentViewer.PaymentTreeNode Class | Aptify.Applications.Commissions Namespace


Generation Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPaymentViewer.PaymentTreeNode.Generation Property

public Int32 Generation {get; set;}

See Also

CommissionPaymentViewer.PaymentTreeNode Class | Aptify.Applications.Commissions Namespace


PlanID Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPaymentViewer.PaymentTreeNode.PlanID Property

public Int64 PlanID {get; set;}

See Also

CommissionPaymentViewer.PaymentTreeNode Class | Aptify.Applications.Commissions Namespace


PlanItemID Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPaymentViewer.PaymentTreeNode.PlanItemID Property

public Int64 PlanItemID {get; set;}

See Also

CommissionPaymentViewer.PaymentTreeNode Class | Aptify.Applications.Commissions Namespace


SalesRepID Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPaymentViewer.PaymentTreeNode.SalesRepID Property

public Int64 SalesRepID {get; set;}

See Also

CommissionPaymentViewer.PaymentTreeNode Class | Aptify.Applications.Commissions Namespace


SalesRepNode Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPaymentViewer.PaymentTreeNode.SalesRepNode Property

public CommissionPaymentViewer.PaymentTreeNode SalesRepNode {get; set;}

See Also

CommissionPaymentViewer.PaymentTreeNode Class | Aptify.Applications.Commissions Namespace


SalesRepType Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPaymentViewer.PaymentTreeNode.SalesRepType Property

public String SalesRepType {get; set;}

See Also

CommissionPaymentViewer.PaymentTreeNode Class | Aptify.Applications.Commissions Namespace


CommissionPaymentWizard Class

For a list of all members of this type, see CommissionPaymentWizard Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
CommissionPaymentWizard

public class CommissionPaymentWizard : Form, IAptifyAction

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Commissions

Assembly: CommissionPaymentWizard (in CommissionPaymentWizard.dll)

See Also

CommissionPaymentWizard Members | Aptify.Applications.Commissions Namespace


CommissionPaymentWizard Members

CommissionPaymentWizard overview

Public Instance Constructors

CommissionPaymentWizard Constructor Initializes a new instance of the CommissionPaymentWizard class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoAction | Overloaded.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNewPayee |
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

m_oApp

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
m_oWizard |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CommissionPaymentWizard Class | Aptify.Applications.Commissions Namespace


CommissionPaymentWizard Constructor

Initializes a new instance of the CommissionPaymentWizard class.

public CommissionPaymentWizard();

See Also

CommissionPaymentWizard Class | Aptify.Applications.Commissions Namespace


CommissionPaymentWizard Fields

The fields of the CommissionPaymentWizard class are listed below. For a complete list of CommissionPaymentWizard class members, see the CommissionPaymentWizard Members topic.

Protected Instance Fields

m_oApp

See Also

CommissionPaymentWizard Class | Aptify.Applications.Commissions Namespace


CommissionPaymentWizard.m_oApp Field

protected m_oApp m_oApp;

See Also

CommissionPaymentWizard Class | Aptify.Applications.Commissions Namespace


CommissionPaymentWizard Properties

The properties of the CommissionPaymentWizard class are listed below. For a complete list of CommissionPaymentWizard class members, see the CommissionPaymentWizard Members topic.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
m_oWizard |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

CommissionPaymentWizard Class | Aptify.Applications.Commissions Namespace


m_oWizard Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPaymentWizard.m_oWizard Property

protected virtual CommissionPaymentWizardObject m_oWizard {get; set;}

See Also

CommissionPaymentWizard Class | Aptify.Applications.Commissions Namespace


CommissionPaymentWizard Methods

The methods of the CommissionPaymentWizard class are listed below. For a complete list of CommissionPaymentWizard class members, see the CommissionPaymentWizard Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoAction | Overloaded.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNewPayee |
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CommissionPaymentWizard Class | Aptify.Applications.Commissions Namespace


CommissionPaymentWizard.ApplySkin Method

protected virtual void ApplySkin();

See Also

CommissionPaymentWizard Class | Aptify.Applications.Commissions Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

CommissionPaymentWizard.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

CommissionPaymentWizard Class | Aptify.Applications.Commissions Namespace


CommissionPaymentWizard.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

CommissionPaymentWizard Class | Aptify.Applications.Commissions Namespace | CommissionPaymentWizard.Dispose Overload List


DoAction Method

Aptify 5.0 Software Development Kit (SDK)

CommissionPaymentWizard.DoAction Method

Overload List

public void DoAction(AptifyApplication,Int64);

public void DoAction(AptifyApplication,Int64,Int64);

public void DoAction(AptifyApplication,Int64,Int64,params Object[]);

public void DoAction(AptifyApplication,Int64,params String[]);

See Also

CommissionPaymentWizard Class | Aptify.Applications.Commissions Namespace


CommissionPaymentWizard.DoAction Method (AptifyApplication, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID
);

Implements

IAptifyAction.

See Also

CommissionPaymentWizard Class | Aptify.Applications.Commissions Namespace | CommissionPaymentWizard.DoAction Overload List


CommissionPaymentWizard.DoAction Method (AptifyApplication, Int64, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID
);

Implements

IAptifyAction.

See Also

CommissionPaymentWizard Class | Aptify.Applications.Commissions Namespace | CommissionPaymentWizard.DoAction Overload List


CommissionPaymentWizard.DoAction Method (AptifyApplication, Int64, Int64, Object[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID,
params Object[] SelectedItems
);

Implements

IAptifyAction.

See Also

CommissionPaymentWizard Class | Aptify.Applications.Commissions Namespace | CommissionPaymentWizard.DoAction Overload List


CommissionPaymentWizard.DoAction Method (AptifyApplication, Int64, String[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
params String[] SelectedItems
);

Implements

IAptifyAction.

See Also

CommissionPaymentWizard Class | Aptify.Applications.Commissions Namespace | CommissionPaymentWizard.DoAction Overload List


CommissionPaymentWizard.GetNewPayee Method

public bool GetNewPayee(
String sEntity
);

See Also

CommissionPaymentWizard Class | Aptify.Applications.Commissions Namespace


CommissionPaymentWizard.Agreements Structure

For a list of all members of this type, see CommissionPaymentWizard.Agreements Members.

System.Object
ValueType
CommissionPaymentWizard.Agreements

protected struct CommissionPaymentWizard.Agreements

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Commissions

Assembly: CommissionPaymentWizard (in CommissionPaymentWizard.dll)

See Also

CommissionPaymentWizard.Agreements Members | Aptify.Applications.Commissions Namespace


CommissionPaymentWizard.Agreements Members

CommissionPaymentWizard.Agreements overview

Public Instance Fields

EndDate
ID
SalesRepID
StartDate

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

CommissionPaymentWizard.Agreements Structure | Aptify.Applications.Commissions Namespace


CommissionPaymentWizard.Agreements Fields

The fields of the CommissionPaymentWizard.Agreements structure are listed below. For a complete list of CommissionPaymentWizard.Agreements structure members, see the CommissionPaymentWizard.Agreements Members topic.

Public Instance Fields

EndDate
ID
SalesRepID
StartDate

See Also

CommissionPaymentWizard.Agreements Structure | Aptify.Applications.Commissions Namespace


CommissionPaymentWizard.Agreements.EndDate Field

public EndDate EndDate;

See Also

CommissionPaymentWizard.Agreements Class | Aptify.Applications.Commissions Namespace


CommissionPaymentWizard.Agreements.ID Field

public ID ID;

See Also

CommissionPaymentWizard.Agreements Class | Aptify.Applications.Commissions Namespace


CommissionPaymentWizard.Agreements.SalesRepID Field

public SalesRepID SalesRepID;

See Also

CommissionPaymentWizard.Agreements Class | Aptify.Applications.Commissions Namespace


CommissionPaymentWizard.Agreements.StartDate Field

public StartDate StartDate;

See Also

CommissionPaymentWizard.Agreements Class | Aptify.Applications.Commissions Namespace


CommissionPaymentWizard.CommPayments Structure

For a list of all members of this type, see CommissionPaymentWizard.CommPayments Members.

System.Object
ValueType
CommissionPaymentWizard.CommPayments

protected struct CommissionPaymentWizard.CommPayments

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Commissions

Assembly: CommissionPaymentWizard (in CommissionPaymentWizard.dll)

See Also

CommissionPaymentWizard.CommPayments Members | Aptify.Applications.Commissions Namespace


CommissionPaymentWizard.CommPayments Members

CommissionPaymentWizard.CommPayments overview

Public Instance Fields

AgreementID
NextAgmtIndex
Payee
PayeeName
PaymentID
Type

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

CommissionPaymentWizard.CommPayments Structure | Aptify.Applications.Commissions Namespace


CommissionPaymentWizard.CommPayments Fields

The fields of the CommissionPaymentWizard.CommPayments structure are listed below. For a complete list of CommissionPaymentWizard.CommPayments structure members, see the CommissionPaymentWizard.CommPayments Members topic.

Public Instance Fields

AgreementID
NextAgmtIndex
Payee
PayeeName
PaymentID
Type

See Also

CommissionPaymentWizard.CommPayments Structure | Aptify.Applications.Commissions Namespace


CommissionPaymentWizard.CommPayments.AgreementID Field

public AgreementID AgreementID;

See Also

CommissionPaymentWizard.CommPayments Class | Aptify.Applications.Commissions Namespace


CommissionPaymentWizard.CommPayments.NextAgmtIndex Field

public NextAgmtIndex NextAgmtIndex;

See Also

CommissionPaymentWizard.CommPayments Class | Aptify.Applications.Commissions Namespace


CommissionPaymentWizard.CommPayments.Payee Field

public Payee Payee;

See Also

CommissionPaymentWizard.CommPayments Class | Aptify.Applications.Commissions Namespace


CommissionPaymentWizard.CommPayments.PayeeName Field

public PayeeName PayeeName;

See Also

CommissionPaymentWizard.CommPayments Class | Aptify.Applications.Commissions Namespace


CommissionPaymentWizard.CommPayments.PaymentID Field

public PaymentID PaymentID;

See Also

CommissionPaymentWizard.CommPayments Class | Aptify.Applications.Commissions Namespace


CommissionPaymentWizard.CommPayments.Type Field

public Type Type;

See Also

CommissionPaymentWizard.CommPayments Class | Aptify.Applications.Commissions Namespace


CommissionPaymentWizardObject Class

For a list of all members of this type, see CommissionPaymentWizardObject Members.

System.Object
CommissionPaymentWizardObject

public class CommissionPaymentWizardObject : IProcessComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Commissions

Assembly: CommissionPaymentWizard (in CommissionPaymentWizard.dll)

See Also

CommissionPaymentWizardObject Members | Aptify.Applications.Commissions Namespace


CommissionPaymentWizardObject Members

CommissionPaymentWizardObject overview

Public Instance Constructors

CommissionPaymentWizardObject Constructor Initializes a new instance of the CommissionPaymentWizardObject class.

Public Instance Properties

Properties

Public Instance Methods

Config |
DoCommissionCalculation |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run |
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

CommissionPaymentUpdate

Protected Instance Fields

m_dsPayments
m_lNewAdjustmentPayments
m_oApp
m_oProps
m_sDatabase

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CommissionPaymentWizardObject Class | Aptify.Applications.Commissions Namespace


CommissionPaymentWizardObject Constructor

Initializes a new instance of the CommissionPaymentWizardObject class.

public CommissionPaymentWizardObject();

See Also

CommissionPaymentWizardObject Class | Aptify.Applications.Commissions Namespace


CommissionPaymentWizardObject Fields

The fields of the CommissionPaymentWizardObject class are listed below. For a complete list of CommissionPaymentWizardObject class members, see the CommissionPaymentWizardObject Members topic.

Protected Instance Fields

m_dsPayments
m_lNewAdjustmentPayments
m_oApp
m_oProps
m_sDatabase

See Also

CommissionPaymentWizardObject Class | Aptify.Applications.Commissions Namespace


CommissionPaymentWizardObject.m_dsPayments Field

protected m_dsPayments m_dsPayments;

See Also

CommissionPaymentWizardObject Class | Aptify.Applications.Commissions Namespace


CommissionPaymentWizardObject.m_lNewAdjustmentPayments Field

protected m_lNewAdjustmentPayments m_lNewAdjustmentPayments;

See Also

CommissionPaymentWizardObject Class | Aptify.Applications.Commissions Namespace


CommissionPaymentWizardObject.m_oApp Field

protected m_oApp m_oApp;

See Also

CommissionPaymentWizardObject Class | Aptify.Applications.Commissions Namespace


CommissionPaymentWizardObject.m_oProps Field

protected m_oProps m_oProps;

See Also

CommissionPaymentWizardObject Class | Aptify.Applications.Commissions Namespace


CommissionPaymentWizardObject.m_sDatabase Field

protected m_sDatabase m_sDatabase;

See Also

CommissionPaymentWizardObject Class | Aptify.Applications.Commissions Namespace


CommissionPaymentWizardObject Properties

The properties of the CommissionPaymentWizardObject class are listed below. For a complete list of CommissionPaymentWizardObject class members, see the CommissionPaymentWizardObject Members topic.

Public Instance Properties

Properties

See Also

CommissionPaymentWizardObject Class | Aptify.Applications.Commissions Namespace


Properties Property

Aptify 5.0 Software Development Kit (SDK)

CommissionPaymentWizardObject.Properties Property

public AptifyProperties Properties {get;}

Implements

IProcessComponent.

See Also

CommissionPaymentWizardObject Class | Aptify.Applications.Commissions Namespace


CommissionPaymentWizardObject Methods

The methods of the CommissionPaymentWizardObject class are listed below. For a complete list of CommissionPaymentWizardObject class members, see the CommissionPaymentWizardObject Members topic.

Public Instance Methods

Config |
DoCommissionCalculation |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CommissionPaymentWizardObject Class | Aptify.Applications.Commissions Namespace


CommissionPaymentWizardObject.Config Method

public void Config(
AptifyApplication ApplicationObject
);

Implements

IProcessComponent.

See Also

CommissionPaymentWizardObject Class | Aptify.Applications.Commissions Namespace


CommissionPaymentWizardObject.DoCommissionCalculation Method

public string DoCommissionCalculation(
CommissionPayments dsPayments
);

See Also

CommissionPaymentWizardObject Class | Aptify.Applications.Commissions Namespace


CommissionPaymentWizardObject.Run Method

public string Run();

Implements

IProcessComponent.

See Also

CommissionPaymentWizardObject Class | Aptify.Applications.Commissions Namespace


CommissionPaymentWizardObject Events

The events of the CommissionPaymentWizardObject class are listed below. For a complete list of CommissionPaymentWizardObject class members, see the CommissionPaymentWizardObject Members topic.

Public Instance Events

CommissionPaymentUpdate

See Also

CommissionPaymentWizardObject Class | Aptify.Applications.Commissions Namespace


CommissionPaymentWizardObject.CommissionPaymentWizardObject.CommissionPaymentUpdateEventHandler Event

public event CommissionPaymentWizardObject.CommissionPaymentUpdateEventHandler CommissionPaymentUpdate;

See Also

CommissionPaymentWizardObject Class | Aptify.Applications.Commissions Namespace


CommissionPaymentWizardObject.CommissionPaymentUpdateEventArgs Class

For a list of all members of this type, see CommissionPaymentWizardObject.CommissionPaymentUpdateEventArgs Members.

System.Object
EventArgs
CommissionPaymentWizardObject.CommissionPaymentUpdateEventArgs

public class CommissionPaymentWizardObject.CommissionPaymentUpdateEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Commissions

Assembly: CommissionPaymentWizard (in CommissionPaymentWizard.dll)

See Also

CommissionPaymentWizardObject.CommissionPaymentUpdateEventArgs Members | Aptify.Applications.Commissions Namespace


CommissionPaymentWizardObject.CommissionPaymentUpdateEventArgs Members

CommissionPaymentWizardObject.CommissionPaymentUpdateEventArgs overview

Public Instance Constructors

CommissionPaymentWizardObject.CommissionPaymentUpdateEventArgs Overloaded. Initializes a new instance of the CommissionPaymentWizardObject.CommissionPaymentUpdateEventArgs class.

Public Instance Fields

Description
Final
ProgressStep
ProgressType
TotalSteps

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CommissionPaymentWizardObject.CommissionPaymentUpdateEventArgs Class | Aptify.Applications.Commissions Namespace


CommissionPaymentWizardObject.CommissionPaymentUpdateEventArgs Constructor

Initializes a new instance of the CommissionPaymentWizardObject.CommissionPaymentUpdateEventArgs class.

Overload List

Initializes a new instance of the CommissionPaymentWizardObject.CommissionPaymentUpdateEventArgs class.

public CommissionPaymentWizardObject.CommissionPaymentUpdateEventArgs();

public CommissionPaymentWizardObject.CommissionPaymentUpdateEventArgs(Int32,Int32,String);

See Also

CommissionPaymentWizardObject.CommissionPaymentUpdateEventArgs Class | Aptify.Applications.Commissions Namespace


CommissionPaymentWizardObject.CommissionPaymentUpdateEventArgs Constructor ()

Initializes a new instance of the CommissionPaymentWizardObject.CommissionPaymentUpdateEventArgs class.

public CommissionPaymentWizardObject.CommissionPaymentUpdateEventArgs();

See Also

CommissionPaymentWizardObject.CommissionPaymentUpdateEventArgs Class | Aptify.Applications.Commissions Namespace | CommissionPaymentWizardObject.CommissionPaymentUpdateEventArgs Constructor Overload List


CommissionPaymentWizardObject.CommissionPaymentUpdateEventArgs Constructor (Int32, Int32, String)

public CommissionPaymentWizardObject.CommissionPaymentUpdateEventArgs(
Int32 iProgressStep,
Int32 iTotalSteps,
String sDescription
);

See Also

CommissionPaymentWizardObject.CommissionPaymentUpdateEventArgs Class | Aptify.Applications.Commissions Namespace | CommissionPaymentWizardObject.CommissionPaymentUpdateEventArgs Constructor Overload List


CommissionPaymentWizardObject.CommissionPaymentUpdateEventArgs Fields

The fields of the CommissionPaymentWizardObject.CommissionPaymentUpdateEventArgs class are listed below. For a complete list of CommissionPaymentWizardObject.CommissionPaymentUpdateEventArgs class members, see the CommissionPaymentWizardObject.CommissionPaymentUpdateEventArgs Members topic.

Public Instance Fields

Description
Final
ProgressStep
ProgressType
TotalSteps

See Also

CommissionPaymentWizardObject.CommissionPaymentUpdateEventArgs Class | Aptify.Applications.Commissions Namespace


CommissionPaymentWizardObject.CommissionPaymentUpdateEventArgs.Description Field

public Description Description;

See Also

CommissionPaymentWizardObject.CommissionPaymentUpdateEventArgs Class | Aptify.Applications.Commissions Namespace


CommissionPaymentWizardObject.CommissionPaymentUpdateEventArgs.Final Field

public Final Final;

See Also

CommissionPaymentWizardObject.CommissionPaymentUpdateEventArgs Class | Aptify.Applications.Commissions Namespace


CommissionPaymentWizardObject.CommissionPaymentUpdateEventArgs.ProgressStep Field

public ProgressStep ProgressStep;

See Also

CommissionPaymentWizardObject.CommissionPaymentUpdateEventArgs Class | Aptify.Applications.Commissions Namespace


CommissionPaymentWizardObject.CommissionPaymentUpdateEventArgs.ProgressType Field

public ProgressType ProgressType;

See Also

CommissionPaymentWizardObject.CommissionPaymentUpdateEventArgs Class | Aptify.Applications.Commissions Namespace


CommissionPaymentWizardObject.CommissionPaymentUpdateEventArgs.TotalSteps Field

public TotalSteps TotalSteps;

See Also

CommissionPaymentWizardObject.CommissionPaymentUpdateEventArgs Class | Aptify.Applications.Commissions Namespace


CommissionPaymentWizardObject.CommissionPaymentUpdateEventHandler Delegate

public delegate void CommissionPaymentWizardObject.CommissionPaymentUpdateEventHandler(
Object sender,
CommissionPaymentWizardObject.CommissionPaymentUpdateEventArgs e
);

Requirements

Namespace: Aptify.Applications.Commissions

Assembly: CommissionPaymentWizard (in CommissionPaymentWizard.dll)

See Also

Aptify.Applications.Commissions Namespace


CommissionPaymentWizardObject.ProgressType Enumeration

public enum CommissionPaymentWizardObject.ProgressType

Members

Member Name | Description
Payment |
Agreement |
Overall |

Requirements

Namespace: Aptify.Applications.Commissions

Assembly: CommissionPaymentWizard (in CommissionPaymentWizard.dll)

See Also

Aptify.Applications.Commissions Namespace


CommissionPaySourceDetailsLayout Class

For a list of all members of this type, see CommissionPaySourceDetailsLayout Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
CommissionLayoutBase
CommissionPaySourceDetailsLayout

public class CommissionPaySourceDetailsLayout : CommissionLayoutBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Commissions

Assembly: CommissionPaymentControls (in CommissionPaymentControls.dll)

See Also

CommissionPaySourceDetailsLayout Members | Aptify.Applications.Commissions Namespace


CommissionPaySourceDetailsLayout Members

CommissionPaySourceDetailsLayout overview

Public Instance Constructors

CommissionPaySourceDetailsLayout Constructor Initializes a new instance of the CommissionPaySourceDetailsLayout class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AddControlEventHandler (inherited from CommissionLayoutBase) |
AdjustFormScrollbars (inherited from ContainerControl) |
ConfigureDisplay |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
DisableControls |
Dispose (inherited from FormTemplateLayout) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindDataControl (inherited from CommissionLayoutBase) |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetControlProperty (inherited from CommissionLayoutBase) |
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded (inherited from FormTemplateLayout) | Raises the FormTemplateLoaded event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad |
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlProperty (inherited from CommissionLayoutBase) | Overloaded.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CommissionPaySourceDetailsLayout Class | Aptify.Applications.Commissions Namespace


CommissionPaySourceDetailsLayout Constructor

Initializes a new instance of the CommissionPaySourceDetailsLayout class.

public CommissionPaySourceDetailsLayout();

See Also

CommissionPaySourceDetailsLayout Class | Aptify.Applications.Commissions Namespace


CommissionPaySourceDetailsLayout Methods

The methods of the CommissionPaySourceDetailsLayout class are listed below. For a complete list of CommissionPaySourceDetailsLayout class members, see the CommissionPaySourceDetailsLayout Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AddControlEventHandler (inherited from CommissionLayoutBase) |
AdjustFormScrollbars (inherited from ContainerControl) |
ConfigureDisplay |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
DisableControls |
Dispose (inherited from FormTemplateLayout) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindDataControl (inherited from CommissionLayoutBase) |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetControlProperty (inherited from CommissionLayoutBase) |
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded (inherited from FormTemplateLayout) | Raises the FormTemplateLoaded event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad |
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlProperty (inherited from CommissionLayoutBase) | Overloaded.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CommissionPaySourceDetailsLayout Class | Aptify.Applications.Commissions Namespace


CommissionPaySourceDetailsLayout.ConfigureDisplay Method

protected virtual void ConfigureDisplay();

See Also

CommissionPaySourceDetailsLayout Class | Aptify.Applications.Commissions Namespace


CommissionPaySourceDetailsLayout.DisableControls Method

protected virtual void DisableControls(
Control oParent
);

See Also

CommissionPaySourceDetailsLayout Class | Aptify.Applications.Commissions Namespace


CommissionPaySourceDetailsLayout.OnLoad Method

protected override void OnLoad(
EventArgs e
);

See Also

CommissionPaySourceDetailsLayout Class | Aptify.Applications.Commissions Namespace


CommissionPaySourceDetailsLayout.OnRefresh Method

protected override void OnRefresh();

Implements

IFormComponent.

See Also

CommissionPaySourceDetailsLayout Class | Aptify.Applications.Commissions Namespace


CommissionPlanItemLayout Class

For a list of all members of this type, see CommissionPlanItemLayout Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
CommissionLayoutBase
CommissionPlanItemLayout

public class CommissionPlanItemLayout : CommissionLayoutBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Commissions

Assembly: CommissionPlanItemControls (in CommissionPlanItemControls.dll)

See Also

CommissionPlanItemLayout Members | Aptify.Applications.Commissions Namespace


CommissionPlanItemLayout Members

CommissionPlanItemLayout overview

Public Instance Constructors

CommissionPlanItemLayout Constructor Initializes a new instance of the CommissionPlanItemLayout class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

dlgPeriodChanged
dlgPlanIDChanged
dlgTypeChanged

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AddControlEventHandler (inherited from CommissionLayoutBase) |
AdjustFormScrollbars (inherited from ContainerControl) |
ConfigureDisplay |
ControlValueChanged |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormTemplateLayout) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindDataControl (inherited from CommissionLayoutBase) |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetControlProperty (inherited from CommissionLayoutBase) |
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded (inherited from FormTemplateLayout) | Raises the FormTemplateLoaded event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad |
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlProperty (inherited from CommissionLayoutBase) | Overloaded.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CommissionPlanItemLayout Class | Aptify.Applications.Commissions Namespace


CommissionPlanItemLayout Constructor

Initializes a new instance of the CommissionPlanItemLayout class.

public CommissionPlanItemLayout();

See Also

CommissionPlanItemLayout Class | Aptify.Applications.Commissions Namespace


CommissionPlanItemLayout Fields

The fields of the CommissionPlanItemLayout class are listed below. For a complete list of CommissionPlanItemLayout class members, see the CommissionPlanItemLayout Members topic.

Protected Instance Fields

dlgPeriodChanged
dlgPlanIDChanged
dlgTypeChanged

See Also

CommissionPlanItemLayout Class | Aptify.Applications.Commissions Namespace


CommissionPlanItemLayout.dlgPeriodChanged Field

protected dlgPeriodChanged dlgPeriodChanged;

See Also

CommissionPlanItemLayout Class | Aptify.Applications.Commissions Namespace


CommissionPlanItemLayout.dlgPlanIDChanged Field

protected dlgPlanIDChanged dlgPlanIDChanged;

See Also

CommissionPlanItemLayout Class | Aptify.Applications.Commissions Namespace


CommissionPlanItemLayout.dlgTypeChanged Field

protected dlgTypeChanged dlgTypeChanged;

See Also

CommissionPlanItemLayout Class | Aptify.Applications.Commissions Namespace


CommissionPlanItemLayout Methods

The methods of the CommissionPlanItemLayout class are listed below. For a complete list of CommissionPlanItemLayout class members, see the CommissionPlanItemLayout Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AddControlEventHandler (inherited from CommissionLayoutBase) |
AdjustFormScrollbars (inherited from ContainerControl) |
ConfigureDisplay |
ControlValueChanged |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormTemplateLayout) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindDataControl (inherited from CommissionLayoutBase) |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetControlProperty (inherited from CommissionLayoutBase) |
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded (inherited from FormTemplateLayout) | Raises the FormTemplateLoaded event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad |
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlProperty (inherited from CommissionLayoutBase) | Overloaded.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CommissionPlanItemLayout Class | Aptify.Applications.Commissions Namespace


CommissionPlanItemLayout.ConfigureDisplay Method

protected virtual void ConfigureDisplay();

See Also

CommissionPlanItemLayout Class | Aptify.Applications.Commissions Namespace


CommissionPlanItemLayout.ControlValueChanged Method

protected virtual void ControlValueChanged(
Object sender,
Object OldValue,
Object NewValue
);

See Also

CommissionPlanItemLayout Class | Aptify.Applications.Commissions Namespace


CommissionPlanItemLayout.OnLoad Method

protected override void OnLoad(
EventArgs e
);

See Also

CommissionPlanItemLayout Class | Aptify.Applications.Commissions Namespace


CommissionPlanItemLayout.OnRefresh Method

protected override void OnRefresh();

Implements

IFormComponent.

See Also

CommissionPlanItemLayout Class | Aptify.Applications.Commissions Namespace


CommissionPlanItemsEntity Class

For a list of all members of this type, see CommissionPlanItemsEntity Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
CommissionPlanItemsEntity

public class CommissionPlanItemsEntity : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Commissions

Assembly: CommissionPlanItemsEntity (in CommissionPlanItemsEntity.dll)

See Also

CommissionPlanItemsEntity Members | Aptify.Applications.Commissions Namespace


CommissionPlanItemsEntity Members

CommissionPlanItemsEntity overview

Public Instance Constructors

CommissionPlanItemsEntity Constructor Initializes a new instance of the CommissionPlanItemsEntity class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

CommissionPlanItemsEntity Class | Aptify.Applications.Commissions Namespace


CommissionPlanItemsEntity Constructor

Initializes a new instance of the CommissionPlanItemsEntity class.

public CommissionPlanItemsEntity();

See Also

CommissionPlanItemsEntity Class | Aptify.Applications.Commissions Namespace


CommissionPlanItemsEntity Methods

The methods of the CommissionPlanItemsEntity class are listed below. For a complete list of CommissionPlanItemsEntity class members, see the CommissionPlanItemsEntity Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

CommissionPlanItemsEntity Class | Aptify.Applications.Commissions Namespace


Save Method

Aptify 5.0 Software Development Kit (SDK)

CommissionPlanItemsEntity.Save Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Save();

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean,ref String&);

public override bool Save(Boolean,ref String&,String);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(ref String&);

See Also

CommissionPlanItemsEntity Class | Aptify.Applications.Commissions Namespace


CommissionPlanItemsEntity.Save Method (Boolean, String&, String)

public override bool Save(
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

See Also

CommissionPlanItemsEntity Class | Aptify.Applications.Commissions Namespace | CommissionPlanItemsEntity.Save Overload List


CommissionPlanLayout Class

For a list of all members of this type, see CommissionPlanLayout Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
CommissionLayoutBase
CommissionPlanLayout

public class CommissionPlanLayout : CommissionLayoutBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Commissions

Assembly: CommissionPlanLayout (in CommissionPlanLayout.dll)

See Also

CommissionPlanLayout Members | Aptify.Applications.Commissions Namespace


CommissionPlanLayout Members

CommissionPlanLayout overview

Public Instance Constructors

CommissionPlanLayout Constructor Initializes a new instance of the CommissionPlanLayout class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

dlgNameChangedHandler
dlgReverseUnpaidHandler

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AddControlEventHandler (inherited from CommissionLayoutBase) |
AdjustFormScrollbars (inherited from ContainerControl) |
ConfigureDisplay |
ControlLostFocus |
ControlValueChanged |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormTemplateLayout) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindDataControl (inherited from CommissionLayoutBase) |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetControlProperty (inherited from CommissionLayoutBase) |
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded (inherited from FormTemplateLayout) | Raises the FormTemplateLoaded event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad |
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlProperty (inherited from CommissionLayoutBase) | Overloaded.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CommissionPlanLayout Class | Aptify.Applications.Commissions Namespace


CommissionPlanLayout Constructor

Initializes a new instance of the CommissionPlanLayout class.

public CommissionPlanLayout();

See Also

CommissionPlanLayout Class | Aptify.Applications.Commissions Namespace


CommissionPlanLayout Fields

The fields of the CommissionPlanLayout class are listed below. For a complete list of CommissionPlanLayout class members, see the CommissionPlanLayout Members topic.

Protected Instance Fields

dlgNameChangedHandler
dlgReverseUnpaidHandler

See Also

CommissionPlanLayout Class | Aptify.Applications.Commissions Namespace


CommissionPlanLayout.dlgNameChangedHandler Field

protected dlgNameChangedHandler dlgNameChangedHandler;

See Also

CommissionPlanLayout Class | Aptify.Applications.Commissions Namespace


CommissionPlanLayout.dlgReverseUnpaidHandler Field

protected dlgReverseUnpaidHandler dlgReverseUnpaidHandler;

See Also

CommissionPlanLayout Class | Aptify.Applications.Commissions Namespace


CommissionPlanLayout Methods

The methods of the CommissionPlanLayout class are listed below. For a complete list of CommissionPlanLayout class members, see the CommissionPlanLayout Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AddControlEventHandler (inherited from CommissionLayoutBase) |
AdjustFormScrollbars (inherited from ContainerControl) |
ConfigureDisplay |
ControlLostFocus |
ControlValueChanged |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormTemplateLayout) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindDataControl (inherited from CommissionLayoutBase) |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetControlProperty (inherited from CommissionLayoutBase) |
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded (inherited from FormTemplateLayout) | Raises the FormTemplateLoaded event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad |
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlProperty (inherited from CommissionLayoutBase) | Overloaded.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CommissionPlanLayout Class | Aptify.Applications.Commissions Namespace


CommissionPlanLayout.ConfigureDisplay Method

protected virtual void ConfigureDisplay();

See Also

CommissionPlanLayout Class | Aptify.Applications.Commissions Namespace


CommissionPlanLayout.ControlLostFocus Method

protected virtual void ControlLostFocus(
Object sender,
EventArgs e
);

See Also

CommissionPlanLayout Class | Aptify.Applications.Commissions Namespace


CommissionPlanLayout.ControlValueChanged Method

protected virtual void ControlValueChanged(
Object sender,
Object OldValue,
Object NewValue
);

See Also

CommissionPlanLayout Class | Aptify.Applications.Commissions Namespace


CommissionPlanLayout.OnLoad Method

protected override void OnLoad(
EventArgs e
);

See Also

CommissionPlanLayout Class | Aptify.Applications.Commissions Namespace


CommissionPlanLayout.OnRefresh Method

protected override void OnRefresh();

Implements

IFormComponent.

See Also

CommissionPlanLayout Class | Aptify.Applications.Commissions Namespace


CommissionRateScale Class

This class provides the implementation for business logic for the Commission Rate Scales entity in the Aptify Commission and Royalty Management system.

For a list of all members of this type, see CommissionRateScale Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
CommissionRateScale

public class CommissionRateScale : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Commissions

Assembly: CommissionRateScale (in CommissionRateScale.dll)

See Also

CommissionRateScale Members | Aptify.Applications.Commissions Namespace


CommissionRateScale Members

CommissionRateScale overview

Public Instance Constructors

CommissionRateScale Constructor Initializes a new instance of the CommissionRateScale class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError |
LastUserError |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config | Overloaded.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
DoesValueHaveMoreDigitsThanAllowedByCurrencyType | Overloaded. This method is responsible for determining if the provided Value parameter has any more detail than the currency type in use allows. For example, with US Dollar, only two digits after the decimal are allowed. To determine the currency type, this method utilizes the system's "home" or base currency.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetCurrencyTypeNumDigitsAfterDecimal | This method returns the number of digits to use after the decimal for the specified currency type.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetSystemFunctionalCurrencyTypeID | This method returns the ID value of the Currency Types entity record that is marked as the functional currency for the system (using the FunctionalCurrency BIT field in the Currency Types entity).
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded. This method overrides the base GE Save() method and adds functionality that will add any new CommissionRateScaleDetail Records to the related Commission Agreement Links sub-type.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded. Overrides the Base GE Validate() method to add functionality to check to make sure each Rate Scale Item is validated for Rate-Scale specific business logic. This is implemented in the base class by calling the ValidateRateScaleItems() method.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.
ValidateRateScaleItems | This method checks all of the items in the CommissionRateScaleDetail sub-type to make sure that the following conditions are True: For error message we want to check all tiers for correctness 1) Low end of range is smaller than high end of range 2) Only the high end can be blank(meaning unlimited top end) 3) Continuous and overlapping - 1 currency unit (penny in us dollar) difference between the upper end of a tier and the subsequent tier lower end. Examples of valid rate scales: Scale 1: 0- 10% Scale 2: so tier are 0-99.99 0%, 100- 10% Scale 3: so tier are 0-99.99 0%, 100-199.99 10%, 200- 20%

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
Database |
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateAgreementAdditions | This method is called from Save() and is responsible for updating the Commission Agreements entity to add in any new CommmissionRateScaleDetails to the Agreement from the Rate Scale record
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateRateScaleDetail | This method validates an individual rate scale item to make sure that it is consistent with the rules described in the ValidateRateScaleItems() method.
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

CommissionRateScale Class | Aptify.Applications.Commissions Namespace


CommissionRateScale Constructor

Initializes a new instance of the CommissionRateScale class.

public CommissionRateScale();

See Also

CommissionRateScale Class | Aptify.Applications.Commissions Namespace


CommissionRateScale Properties

The properties of the CommissionRateScale class are listed below. For a complete list of CommissionRateScale class members, see the CommissionRateScale Members topic.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError |
LastUserError |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
Database |
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

CommissionRateScale Class | Aptify.Applications.Commissions Namespace


Database Property

Aptify 5.0 Software Development Kit (SDK)

CommissionRateScale.Database Property

protected virtual String Database {get;}

See Also

CommissionRateScale Class | Aptify.Applications.Commissions Namespace


LastError Property

Aptify 5.0 Software Development Kit (SDK)

CommissionRateScale.LastError Property

public override String LastError {get;}

See Also

CommissionRateScale Class | Aptify.Applications.Commissions Namespace


LastUserError Property

Aptify 5.0 Software Development Kit (SDK)

CommissionRateScale.LastUserError Property

public override String LastUserError {get;}

See Also

CommissionRateScale Class | Aptify.Applications.Commissions Namespace


CommissionRateScale Methods

The methods of the CommissionRateScale class are listed below. For a complete list of CommissionRateScale class members, see the CommissionRateScale Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config | Overloaded.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
DoesValueHaveMoreDigitsThanAllowedByCurrencyType | Overloaded. This method is responsible for determining if the provided Value parameter has any more detail than the currency type in use allows. For example, with US Dollar, only two digits after the decimal are allowed. To determine the currency type, this method utilizes the system's "home" or base currency.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetCurrencyTypeNumDigitsAfterDecimal | This method returns the number of digits to use after the decimal for the specified currency type.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetSystemFunctionalCurrencyTypeID | This method returns the ID value of the Currency Types entity record that is marked as the functional currency for the system (using the FunctionalCurrency BIT field in the Currency Types entity).
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded. This method overrides the base GE Save() method and adds functionality that will add any new CommissionRateScaleDetail Records to the related Commission Agreement Links sub-type.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded. Overrides the Base GE Validate() method to add functionality to check to make sure each Rate Scale Item is validated for Rate-Scale specific business logic. This is implemented in the base class by calling the ValidateRateScaleItems() method.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.
ValidateRateScaleItems | This method checks all of the items in the CommissionRateScaleDetail sub-type to make sure that the following conditions are True: For error message we want to check all tiers for correctness 1) Low end of range is smaller than high end of range 2) Only the high end can be blank(meaning unlimited top end) 3) Continuous and overlapping - 1 currency unit (penny in us dollar) difference between the upper end of a tier and the subsequent tier lower end. Examples of valid rate scales: Scale 1: 0- 10% Scale 2: so tier are 0-99.99 0%, 100- 10% Scale 3: so tier are 0-99.99 0%, 100-199.99 10%, 200- 20%

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateAgreementAdditions | This method is called from Save() and is responsible for updating the Commission Agreements entity to add in any new CommmissionRateScaleDetails to the Agreement from the Rate Scale record
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateRateScaleDetail | This method validates an individual rate scale item to make sure that it is consistent with the rules described in the ValidateRateScaleItems() method.
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

CommissionRateScale Class | Aptify.Applications.Commissions Namespace


Config Method

Aptify 5.0 Software Development Kit (SDK)

CommissionRateScale.Config Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual void Config(AptifySubTypeBase);

Inherited from AptifyGenericEntity.

public override void Config(AptifySubTypeBase,Int64);

Inherited from AptifyGenericEntityBase.

public virtual void Config(UserCredentials,String);

public override void Config(UserCredentials,String,Int64);

See Also

CommissionRateScale Class | Aptify.Applications.Commissions Namespace


CommissionRateScale.Config Method (UserCredentials, String, Int64)

public override void Config(
UserCredentials UserCredentials,
String EntityName,
Int64 RecordID
);

See Also

CommissionRateScale Class | Aptify.Applications.Commissions Namespace | CommissionRateScale.Config Overload List


DoesValueHaveMoreDigitsThanAllowedByCurrencyType Method

Aptify 5.0 Software Development Kit (SDK)

CommissionRateScale.DoesValueHaveMoreDigitsThanAllowedByCurrencyType Method

This method is responsible for determining if the provided Value parameter has any more detail than the currency type in use allows. For example, with US Dollar, only two digits after the decimal are allowed. To determine the currency type, this method utilizes the system's "home" or base currency.

Overload List

This method is responsible for determining if the provided Value parameter has any more detail than the currency type in use allows. For example, with US Dollar, only two digits after the decimal are allowed. To determine the currency type, this method utilizes the system's "home" or base currency.

public virtual bool DoesValueHaveMoreDigitsThanAllowedByCurrencyType(Object);

This method is responsible for determining if the provided Value parameter has any more detail than the currency type specified allows.

public virtual bool DoesValueHaveMoreDigitsThanAllowedByCurrencyType(Object,Int64);

See Also

CommissionRateScale Class | Aptify.Applications.Commissions Namespace


CommissionRateScale.DoesValueHaveMoreDigitsThanAllowedByCurrencyType Method (Object)

This method is responsible for determining if the provided Value parameter has any more detail than the currency type in use allows. For example, with US Dollar, only two digits after the decimal are allowed. To determine the currency type, this method utilizes the system's "home" or base currency.

public virtual bool DoesValueHaveMoreDigitsThanAllowedByCurrencyType(
Object Value
);

Parameters

Value

Return Value

Remarks

See Also

CommissionRateScale Class | Aptify.Applications.Commissions Namespace | CommissionRateScale.DoesValueHaveMoreDigitsThanAllowedByCurrencyType Overload List


CommissionRateScale.DoesValueHaveMoreDigitsThanAllowedByCurrencyType Method (Object, Int64)

This method is responsible for determining if the provided Value parameter has any more detail than the currency type specified allows.

public virtual bool DoesValueHaveMoreDigitsThanAllowedByCurrencyType(
Object Value,
Int64 CurrencyTypeID
);

Parameters

Value
CurrencyTypeID

Return Value

Remarks

See Also

CommissionRateScale Class | Aptify.Applications.Commissions Namespace | CommissionRateScale.DoesValueHaveMoreDigitsThanAllowedByCurrencyType Overload List


CommissionRateScale.GetCurrencyTypeNumDigitsAfterDecimal Method

This method returns the number of digits to use after the decimal for the specified currency type.

public virtual int GetCurrencyTypeNumDigitsAfterDecimal(
Int64 CurrencyTypeID,
IAptifyDataAction.DSLCacheSetting CacheSetting
);

Parameters

CurrencyTypeID
CacheSetting

Return Value

Remarks

See Also

CommissionRateScale Class | Aptify.Applications.Commissions Namespace


CommissionRateScale.GetSystemFunctionalCurrencyTypeID Method

This method returns the ID value of the Currency Types entity record that is marked as the functional currency for the system (using the FunctionalCurrency BIT field in the Currency Types entity).

public virtual long GetSystemFunctionalCurrencyTypeID(
IAptifyDataAction.DSLCacheSetting CacheSetting
);

Parameters

CacheSetting

Return Value

Remarks

See Also

CommissionRateScale Class | Aptify.Applications.Commissions Namespace


Save Method

Aptify 5.0 Software Development Kit (SDK)

CommissionRateScale.Save Method

This method overrides the base GE Save() method and adds functionality that will add any new CommissionRateScaleDetail Records to the related Commission Agreement Links sub-type.

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Save();

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean,ref String&);

This method overrides the base GE Save() method and adds functionality that will add any new CommissionRateScaleDetail Records to the related Commission Agreement Links sub-type.

public override bool Save(Boolean,ref String&,String);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(ref String&);

See Also

CommissionRateScale Class | Aptify.Applications.Commissions Namespace


CommissionRateScale.Save Method (Boolean, String&, String)

This method overrides the base GE Save() method and adds functionality that will add any new CommissionRateScaleDetail Records to the related Commission Agreement Links sub-type.

public override bool Save(
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

Parameters

AllowGUI
ErrorString
TransactionID

Return Value

Remarks

See Also

CommissionRateScale Class | Aptify.Applications.Commissions Namespace | CommissionRateScale.Save Overload List


CommissionRateScale.UpdateAgreementAdditions Method

This method is called from Save() and is responsible for updating the Commission Agreements entity to add in any new CommmissionRateScaleDetails to the Agreement from the Rate Scale record

protected virtual bool UpdateAgreementAdditions(
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

Parameters

AllowGUI
ErrorString
TransactionID

Return Value

Remarks

See Also

CommissionRateScale Class | Aptify.Applications.Commissions Namespace


Validate Method

Aptify 5.0 Software Development Kit (SDK)

CommissionRateScale.Validate Method

Overrides the Base GE Validate() method to add functionality to check to make sure each Rate Scale Item is validated for Rate-Scale specific business logic. This is implemented in the base class by calling the ValidateRateScaleItems() method.

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Validate();

Overrides the Base GE Validate() method to add functionality to check to make sure each Rate Scale Item is validated for Rate-Scale specific business logic. This is implemented in the base class by calling the ValidateRateScaleItems() method.

public override bool Validate(ref String&);

See Also

CommissionRateScale Class | Aptify.Applications.Commissions Namespace


CommissionRateScale.Validate Method (String&)

Overrides the Base GE Validate() method to add functionality to check to make sure each Rate Scale Item is validated for Rate-Scale specific business logic. This is implemented in the base class by calling the ValidateRateScaleItems() method.

public override bool Validate(
ref String& ErrorString
);

Parameters

ErrorString

Return Value

Remarks

See Also

CommissionRateScale Class | Aptify.Applications.Commissions Namespace | CommissionRateScale.Validate Overload List


CommissionRateScale.ValidateRateScaleDetail Method

This method validates an individual rate scale item to make sure that it is consistent with the rules described in the ValidateRateScaleItems() method.

protected virtual string ValidateRateScaleDetail(
AptifyGenericEntityBase RateScaleDetailGE,
Boolean IsLastItem,
Int32 Position
);

Parameters

RateScaleDetailGE
IsLastItem
Position

Return Value

Remarks

See Also

CommissionRateScale Class | Aptify.Applications.Commissions Namespace


CommissionRateScale.ValidateRateScaleItems Method

This method checks all of the items in the CommissionRateScaleDetail sub-type to make sure that the following conditions are True: For error message we want to check all tiers for correctness 1) Low end of range is smaller than high end of range 2) Only the high end can be blank(meaning unlimited top end) 3) Continuous and overlapping - 1 currency unit (penny in us dollar) difference between the upper end of a tier and the subsequent tier lower end. Examples of valid rate scales: Scale 1: 0- 10% Scale 2: so tier are 0-99.99 0%, 100- 10% Scale 3: so tier are 0-99.99 0%, 100-199.99 10%, 200- 20%

public virtual bool ValidateRateScaleItems(
AptifySubTypeBase SubType,
ref String& ErrorString
);

Parameters

SubType
ErrorString

Return Value

Remarks

See Also

CommissionRateScale Class | Aptify.Applications.Commissions Namespace


Aptify.Applications.CommiteeTerm

Aptify 5.0 Software Development Kit (SDK)

Aptify.Applications.CommiteeTerm Namespace

The object in this namespace corresponds to the entity object for the CommitteeTermMembers entity.

Namespace hierarchy

Classes

Class | Description
CommiteeTermMemberEntity |


CommiteeTermMemberEntity Class

For a list of all members of this type, see CommiteeTermMemberEntity Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
CommiteeTermMemberEntity

public class CommiteeTermMemberEntity : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.CommiteeTerm

Assembly: CommiteeTermMemberEntity (in CommiteeTermMemberEntity.dll)

See Also

CommiteeTermMemberEntity Members | Aptify.Applications.CommiteeTerm Namespace


CommiteeTermMemberEntity Members

CommiteeTermMemberEntity overview

Public Instance Constructors

CommiteeTermMemberEntity Constructor Initializes a new instance of the CommiteeTermMemberEntity class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord |
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

CommiteeTermMemberEntity Class | Aptify.Applications.CommiteeTerm Namespace


CommiteeTermMemberEntity Constructor

Initializes a new instance of the CommiteeTermMemberEntity class.

public CommiteeTermMemberEntity();

See Also

CommiteeTermMemberEntity Class | Aptify.Applications.CommiteeTerm Namespace


CommiteeTermMemberEntity Methods

The methods of the CommiteeTermMemberEntity class are listed below. For a complete list of CommiteeTermMemberEntity class members, see the CommiteeTermMemberEntity Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord |
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

CommiteeTermMemberEntity Class | Aptify.Applications.CommiteeTerm Namespace


CommiteeTermMemberEntity.NewRecord Method

public override bool NewRecord();

See Also

CommiteeTermMemberEntity Class | Aptify.Applications.CommiteeTerm Namespace


Validate Method

Aptify 5.0 Software Development Kit (SDK)

CommiteeTermMemberEntity.Validate Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Validate();

public override bool Validate(ref String&);

See Also

CommiteeTermMemberEntity Class | Aptify.Applications.CommiteeTerm Namespace


CommiteeTermMemberEntity.Validate Method (String&)

public override bool Validate(
ref String& ErrorString
);

See Also

CommiteeTermMemberEntity Class | Aptify.Applications.CommiteeTerm Namespace | CommiteeTermMemberEntity.Validate Overload List


Aptify.Applications.CommitteeTerm

Aptify 5.0 Software Development Kit (SDK)

Aptify.Applications.CommitteeTerm Namespace

The objects in this namespace implement the entity object for the Committee Terms entity and the Committee Term Renewal wizard.

Namespace hierarchy

Classes

Class | Description
CommitteeRenewalWizardForm |
CommitteeTermsEntity |


CommitteeRenewalWizardForm Class

For a list of all members of this type, see CommitteeRenewalWizardForm Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
CommitteeRenewalWizardForm

public class CommitteeRenewalWizardForm : Form, IAptifyAction

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.CommitteeTerm

Assembly: CommitteeTermRenewalWizard (in CommitteeTermRenewalWizard.dll)

See Also

CommitteeRenewalWizardForm Members | Aptify.Applications.CommitteeTerm Namespace


CommitteeRenewalWizardForm Members

CommitteeRenewalWizardForm overview

Public Instance Constructors

CommitteeRenewalWizardForm Constructor Initializes a new instance of the CommitteeRenewalWizardForm class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoAction | Overloaded.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CommitteeRenewalWizardForm Class | Aptify.Applications.CommitteeTerm Namespace


CommitteeRenewalWizardForm Constructor

Initializes a new instance of the CommitteeRenewalWizardForm class.

public CommitteeRenewalWizardForm();

See Also

CommitteeRenewalWizardForm Class | Aptify.Applications.CommitteeTerm Namespace


CommitteeRenewalWizardForm Methods

The methods of the CommitteeRenewalWizardForm class are listed below. For a complete list of CommitteeRenewalWizardForm class members, see the CommitteeRenewalWizardForm Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoAction | Overloaded.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CommitteeRenewalWizardForm Class | Aptify.Applications.CommitteeTerm Namespace


CommitteeRenewalWizardForm.Config Method

public void Config(
AptifyApplication ApplicationObject
);

See Also

CommitteeRenewalWizardForm Class | Aptify.Applications.CommitteeTerm Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

CommitteeRenewalWizardForm.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

CommitteeRenewalWizardForm Class | Aptify.Applications.CommitteeTerm Namespace


CommitteeRenewalWizardForm.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

CommitteeRenewalWizardForm Class | Aptify.Applications.CommitteeTerm Namespace | CommitteeRenewalWizardForm.Dispose Overload List


DoAction Method

Aptify 5.0 Software Development Kit (SDK)

CommitteeRenewalWizardForm.DoAction Method

Overload List

public void DoAction(AptifyApplication,Int64);

public void DoAction(AptifyApplication,Int64,Int64);

public void DoAction(AptifyApplication,Int64,Int64,params Object[]);

public void DoAction(AptifyApplication,Int64,params String[]);

See Also

CommitteeRenewalWizardForm Class | Aptify.Applications.CommitteeTerm Namespace


CommitteeRenewalWizardForm.DoAction Method (AptifyApplication, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID
);

Implements

IAptifyAction.

See Also

CommitteeRenewalWizardForm Class | Aptify.Applications.CommitteeTerm Namespace | CommitteeRenewalWizardForm.DoAction Overload List


CommitteeRenewalWizardForm.DoAction Method (AptifyApplication, Int64, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID
);

Implements

IAptifyAction.

See Also

CommitteeRenewalWizardForm Class | Aptify.Applications.CommitteeTerm Namespace | CommitteeRenewalWizardForm.DoAction Overload List


CommitteeRenewalWizardForm.DoAction Method (AptifyApplication, Int64, Int64, Object[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID,
params Object[] SelectedItems
);

Implements

IAptifyAction.

See Also

CommitteeRenewalWizardForm Class | Aptify.Applications.CommitteeTerm Namespace | CommitteeRenewalWizardForm.DoAction Overload List


CommitteeRenewalWizardForm.DoAction Method (AptifyApplication, Int64, String[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
params String[] SelectedItems
);

Implements

IAptifyAction.

See Also

CommitteeRenewalWizardForm Class | Aptify.Applications.CommitteeTerm Namespace | CommitteeRenewalWizardForm.DoAction Overload List


CommitteeTermsEntity Class

For a list of all members of this type, see CommitteeTermsEntity Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
CommitteeTermsEntity

public class CommitteeTermsEntity : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.CommitteeTerm

Assembly: CommitteeTermEntityPlugIn (in CommitteeTermEntityPlugIn.dll)

See Also

CommitteeTermsEntity Members | Aptify.Applications.CommitteeTerm Namespace


CommitteeTermsEntity Members

CommitteeTermsEntity overview

Public Instance Constructors

CommitteeTermsEntity Constructor Initializes a new instance of the CommitteeTermsEntity class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load | Overloaded.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

CommitteeTermsEntity Class | Aptify.Applications.CommitteeTerm Namespace


CommitteeTermsEntity Constructor

Initializes a new instance of the CommitteeTermsEntity class.

public CommitteeTermsEntity();

See Also

CommitteeTermsEntity Class | Aptify.Applications.CommitteeTerm Namespace


CommitteeTermsEntity Methods

The methods of the CommitteeTermsEntity class are listed below. For a complete list of CommitteeTermsEntity class members, see the CommitteeTermsEntity Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load | Overloaded.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

CommitteeTermsEntity Class | Aptify.Applications.CommitteeTerm Namespace


Load Method

Aptify 5.0 Software Development Kit (SDK)

CommitteeTermsEntity.Load Method

Overload List

Inherited from AptifyGenericEntity.

public override void Load(DataRow);

Inherited from AptifyGenericEntity.

public override void Load(IDataReader);

Inherited from AptifyGenericEntity.

public override void Load(Int64);

Inherited from AptifyGenericEntityBase.

public virtual void Load(String);

public override void Load(String,Boolean);

See Also

CommitteeTermsEntity Class | Aptify.Applications.CommitteeTerm Namespace


CommitteeTermsEntity.Load Method (String, Boolean)

public override void Load(
String FileName,
Boolean MergeSubTypes
);

See Also

CommitteeTermsEntity Class | Aptify.Applications.CommitteeTerm Namespace | CommitteeTermsEntity.Load Overload List


Save Method

Aptify 5.0 Software Development Kit (SDK)

CommitteeTermsEntity.Save Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Save();

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean,ref String&);

public override bool Save(Boolean,ref String&,String);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(ref String&);

See Also

CommitteeTermsEntity Class | Aptify.Applications.CommitteeTerm Namespace


CommitteeTermsEntity.Save Method (Boolean, String&, String)

public override bool Save(
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

See Also

CommitteeTermsEntity Class | Aptify.Applications.CommitteeTerm Namespace | CommitteeTermsEntity.Save Overload List


Aptify.Applications.Companies

Aptify 5.0 Software Development Kit (SDK)

Aptify.Applications.Companies Namespace

This namespace contains objects related to the Companies service, including the Layout Control for the Companies form template.

Namespace hierarchy

Classes

Class | Description
CompaniesLayout | Contains custom logic used by the Companies Form Template.
CompaniesSpecialFieldTextBox | Used to display special fields for Persons
CompanyFlowDownBase | Base class used by the other company flow down business object classes
CompanySPMLayout |
FlowDownAbbreviatedName | This object handles the flow-down of a name from the Companies Entity Name field into the AbbreviatedName field which is used to store the short/acronym version of a company name. The default functionality in the base class automatically populates this field from the Company Name as long as the Abbreviated Name has not previously been manually overriden by the user (tested by checking the old value of the Name field of the Company against the value of AbbreviatedName using the same Abbreviated Name generation).
FlowDownDirSort | This object handles the flow-down of a name from the Companies Entity Name field into the DirSort field which is used to handle sorting and searching without special characters. The default functionality in the base class automatically populates this field from the Company Name as long as the DirSort has not previously been manually overriden by the user (tested by checking the old value of the Name field of the Company against the value of DirSort). In addition, this object will also auto-populate the DirLetter field with the first character in the Name, using the same logic as described above.


CompaniesLayout Class

Contains custom logic used by the Companies Form Template.

For a list of all members of this type, see CompaniesLayout Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
CompaniesLayout

public class CompaniesLayout : FormTemplateLayout

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Companies

Assembly: AptifyCompaniesGUI (in AptifyCompaniesGUI.dll)

See Also

CompaniesLayout Members | Aptify.Applications.Companies Namespace


CompaniesLayout Members

CompaniesLayout overview

Public Instance Constructors

CompaniesLayout Constructor Initializes a new instance of the CompaniesLayout class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

m_ctlBalanceTotal
m_ctlOrderTotal
m_ctlUSCongress

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
m_fieldUSCongress |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControls | Searches the loaded form template for controls that will be used to handle events.
FindOrderControls |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded | Called when the Companies Form Template has loaded.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnUSCongressAfterValueChanged |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetOrderSummaryCurrencyFormat |
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
TransferParentID | Updates the FormTemplateContext.GE with the Current Value of the Parent ID, If the ParentID control has been found.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CompaniesLayout Class | Aptify.Applications.Companies Namespace


CompaniesLayout Constructor

Initializes a new instance of the CompaniesLayout class.

public CompaniesLayout();

See Also

CompaniesLayout Class | Aptify.Applications.Companies Namespace


CompaniesLayout Fields

The fields of the CompaniesLayout class are listed below. For a complete list of CompaniesLayout class members, see the CompaniesLayout Members topic.

Protected Instance Fields

m_ctlBalanceTotal
m_ctlOrderTotal
m_ctlUSCongress

See Also

CompaniesLayout Class | Aptify.Applications.Companies Namespace


CompaniesLayout.m_ctlBalanceTotal Field

protected m_ctlBalanceTotal m_ctlBalanceTotal;

See Also

CompaniesLayout Class | Aptify.Applications.Companies Namespace


CompaniesLayout.m_ctlOrderTotal Field

protected m_ctlOrderTotal m_ctlOrderTotal;

See Also

CompaniesLayout Class | Aptify.Applications.Companies Namespace


CompaniesLayout.m_ctlUSCongress Field

protected m_ctlUSCongress m_ctlUSCongress;

See Also

CompaniesLayout Class | Aptify.Applications.Companies Namespace


CompaniesLayout Properties

The properties of the CompaniesLayout class are listed below. For a complete list of CompaniesLayout class members, see the CompaniesLayout Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
m_fieldUSCongress |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

CompaniesLayout Class | Aptify.Applications.Companies Namespace


m_fieldUSCongress Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesLayout.m_fieldUSCongress Property

protected virtual AptifyDataFieldBase m_fieldUSCongress {get; set;}

See Also

CompaniesLayout Class | Aptify.Applications.Companies Namespace


CompaniesLayout Methods

The methods of the CompaniesLayout class are listed below. For a complete list of CompaniesLayout class members, see the CompaniesLayout Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControls | Searches the loaded form template for controls that will be used to handle events.
FindOrderControls |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded | Called when the Companies Form Template has loaded.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnUSCongressAfterValueChanged |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetOrderSummaryCurrencyFormat |
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
TransferParentID | Updates the FormTemplateContext.GE with the Current Value of the Parent ID, If the ParentID control has been found.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CompaniesLayout Class | Aptify.Applications.Companies Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

CompaniesLayout.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

CompaniesLayout Class | Aptify.Applications.Companies Namespace


CompaniesLayout.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

CompaniesLayout Class | Aptify.Applications.Companies Namespace | CompaniesLayout.Dispose Overload List


CompaniesLayout.FindControls Method

Searches the loaded form template for controls that will be used to handle events.

protected virtual void FindControls();

Remarks

See Also

CompaniesLayout Class | Aptify.Applications.Companies Namespace


CompaniesLayout.FindOrderControls Method

protected virtual void FindOrderControls();

See Also

CompaniesLayout Class | Aptify.Applications.Companies Namespace


CompaniesLayout.OnFormTemplateLoaded Method

Called when the Companies Form Template has loaded.

protected override void OnFormTemplateLoaded(
FormTemplateLayout.FormTemplateLoadedEventArgs e
);

Parameters

e

See Also

CompaniesLayout Class | Aptify.Applications.Companies Namespace


CompaniesLayout.OnUSCongressAfterValueChanged Method

protected virtual void OnUSCongressAfterValueChanged(
AptifyDataFieldBase sender,
AfterValueChangedEventArgs e
);

See Also

CompaniesLayout Class | Aptify.Applications.Companies Namespace


CompaniesLayout.SetOrderSummaryCurrencyFormat Method

protected virtual void SetOrderSummaryCurrencyFormat();

See Also

CompaniesLayout Class | Aptify.Applications.Companies Namespace


CompaniesLayout.TransferParentID Method

Updates the FormTemplateContext.GE with the Current Value of the Parent ID, If the ParentID control has been found.

protected virtual void TransferParentID();

Remarks

See Also

CompaniesLayout Class | Aptify.Applications.Companies Namespace


CompaniesSpecialFieldTextBox Class

Used to display special fields for Persons

For a list of all members of this type, see CompaniesSpecialFieldTextBox Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
AptifyControlBase
AptifyDataFieldControlBase
AptifyTextBox
CompaniesSpecialFieldTextBox

public class CompaniesSpecialFieldTextBox : AptifyTextBox

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

This will call the Get value from the Companies entity, before the datafield is assigned. This is, because we want to ensure that the fields is there. It Supports the DataField property.

Requirements

Namespace: Aptify.Applications.Companies

Assembly: AptifyCompaniesGUI (in AptifyCompaniesGUI.dll)

See Also

CompaniesSpecialFieldTextBox Members | Aptify.Applications.Companies Namespace


CompaniesSpecialFieldTextBox Members

CompaniesSpecialFieldTextBox overview

Public Instance Constructors

CompaniesSpecialFieldTextBox Constructor Initializes a new instance of the CompaniesSpecialFieldTextBox class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Control (inherited from AptifyControlBase) |
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DataControl (inherited from AptifyControlBase) | Adds a reference to the object for the data control. In the case of it being added, the reference to the bound control base object is added to the data controls collection.
DataField (inherited from AptifyDataFieldControlBase) | This is the field in the GE to whose value read/write operations are applied.
DataSource (inherited from AptifyDataFieldControlBase) |
DisableGeDataTransfer (inherited from AptifyControlBase) | If true, the implementer is required to move the value to/from the bound control to the GE or other data access method.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
FieldHelp (inherited from AptifyControlBase) |
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from AptifyDataFieldControlBase) | The font for the internal control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormatString (inherited from AptifyTextBox) |
FormTemplateContext (inherited from AptifyControlBase) | Returns the reference that if is local that is returned else if a DataControl exists, it is returned.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpObject (inherited from AptifyDataFieldControlBase) | This member is overriden in this class to provide field-level help if available
HelpURL (inherited from AptifyDataFieldControlBase) | This member is overriden in this class to provide field-level help if available
HideSelection (inherited from AptifyTextBox) |
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LabelAutoSize (inherited from AptifyTextBox) |
LabelFont (inherited from AptifyDataFieldControlBase) | The font of the label.
LabelRequiredFont (inherited from AptifyDataFieldControlBase) |
LabelSize (inherited from AptifyDataFieldControlBase) | Size of the label.
LabelText (inherited from AptifyDataFieldControlBase) |
LabelTextAlign (inherited from AptifyDataFieldControlBase) |
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MaxLength (inherited from AptifyTextBox) | The maximum number of characters that the text box will accept.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
MultiLine (inherited from AptifyTextBox) | If set to true, the control allows multiple lines to be inserted.
Name (inherited from Control) | Gets or sets the name of the control.
ObjectRepository (inherited from AptifyControlBase) |
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PasswordChar (inherited from AptifyTextBox) | Shows a different visible character if this is set.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Required (inherited from AptifyDataFieldControlBase) |
RequiredFieldBackColor (inherited from AptifyTextBox) |
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ScrollBars (inherited from AptifyTextBox) | Sets the scroll bars for the text box control.
ShowLabel (inherited from AptifyDataFieldControlBase) |
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from AptifyDataFieldControlBase) | Sets the Value of the control.
TextAlign (inherited from AptifyTextBox) | The alignment of the text within the text box.
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
Value (inherited from AptifyTextBox) |
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BoundControlConfig (inherited from AptifyTextBox) |
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ClearData (inherited from AptifyDataFieldControlBase) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DisplayControlHelp (inherited from AptifyControlBase) | This method will display control-level help information. This method will use the HelpTitle and HelpText overridable members to display the Field Help object from Aptify.Framework.WindowsControls.FieldHelp. If the title and text is desired to be overriden it is not necessary to override this method, rather override the HelpTitle and HelpText properties which are used by this method.
DisplayEntityHelp (inherited from AptifyControlBase) | This method is responsible for displaying the help file to the user and will attempt to provide context sensitive help based on the particular entity being displayed. If no entity-specific help file is available for the user then the standard Aptify Shell.Aptify Help file will be used to display help to the user. Override this method in sub-classes to change the method for displaying help.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetDefaultHelpObject (inherited from AptifyControlBase) | This method returns the default help object file in the Aptify Object repository to be used in the event that no entity-specific file exists
GetEntityFieldSpecificHelpObject (inherited from AptifyDataFieldControlBase) | This method returns the Aptify Object Repository Object location for the help file that is specific to this entity field.
GetEntityFieldSpecificHelpTopicURL (inherited from AptifyDataFieldControlBase) | This method returns the Topic URL location within the help file that is specific to this entity field.
GetEntitySpecificHelpObject (inherited from AptifyControlBase) | This method returns the Aptify Object Repository Object location for the help file that is specific to this entity.
GetEntitySpecificHelpTopicURL (inherited from AptifyControlBase) | This method returns the Topic URL location within the help file that is specific to this entity.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseValueChanged (inherited from AptifyControlBase) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from AptifyDataFieldControlBase) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from AptifyTextBox) | Overloaded.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetExtendedType (inherited from AptifyTextBox) |
SetUserCredential (inherited from AptifyControlBase) |
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
TransferDataToObject (inherited from AptifyDataFieldControlBase) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AfterDisplayEntityHelp (inherited from AptifyControlBase) | This event is fired after the help file is displayed.
AptifyControlBaseTextChanged (inherited from AptifyControlBase) |
AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BeforeDisplayEntityHelp (inherited from AptifyControlBase) | This event is fired before the help file is displayed. To prevent help from being displayed set the Cancel parameter to True.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from AptifyControlBase) |
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from AptifyControlBase) |
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from AptifyControlBase) |
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from AptifyControlBase) |
KeyPress (inherited from AptifyControlBase) |
KeyUp (inherited from AptifyControlBase) |
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from AptifyControlBase) |
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from AptifyControlBase) |
MouseEnter (inherited from AptifyControlBase) |
MouseHover (inherited from AptifyControlBase) |
MouseLeave (inherited from AptifyControlBase) |
MouseMove (inherited from AptifyControlBase) |
MouseUp (inherited from AptifyControlBase) |
MouseWheel (inherited from AptifyControlBase) |
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from AptifyControlBase) |
Validated (inherited from AptifyControlBase) |
Validating (inherited from AptifyControlBase) |
ValueChanged (inherited from AptifyControlBase) |
VisibleChanged (inherited from AptifyControlBase) |

Protected Instance Fields

m_bEdit (inherited from AptifyDataFieldControlBase)
m_bNewTypedValue (inherited from AptifyDataFieldControlBase)
m_bPreConfig (inherited from AptifyDataFieldControlBase)
m_bRead (inherited from AptifyDataFieldControlBase)
m_bRequired (inherited from AptifyDataFieldControlBase)
m_iDataControl (inherited from AptifyControlBase)
m_oAptifyApplication (inherited from AptifyControlBase)
m_oFormTemplateContext (inherited from AptifyControlBase)
m_oUserCredential (inherited from AptifyControlBase)
m_sDataField (inherited from AptifyDataFieldControlBase)

Protected Instance Properties

AptifyApplication (inherited from AptifyControlBase) | Returns an instance of the Aptify Application Object
AptifyMessage (inherited from AptifyDataFieldControlBase) |
AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
CurrencyTypeCache (inherited from AptifyControlBase) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DisplayName (inherited from AptifyControlBase) |
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
ExtendedType (inherited from AptifyTextBox) |
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HelpText (inherited from AptifyControlBase) |
HelpTitle (inherited from AptifyDataFieldControlBase) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
InternalControl (inherited from AptifyControlBase) | Specifies the Main Control of interest in a composite control.
Label (inherited from AptifyDataFieldControlBase) |
m_oInternalControl (inherited from AptifyControlBase) |
MyApplication (inherited from AptifyControlBase) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowDisplayHelpHyperlink (inherited from AptifyControlBase) | This property can be overriden by sub-classes to be able to selectively turn on or off the Display Help hyperlink that appears by default on the FieldHelp object.
UserCredential (inherited from AptifyControlBase) |
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
AptifyControlBaseValueChangedHandler (inherited from AptifyDataFieldControlBase) |
ConfigHelp (inherited from AptifyDataFieldControlBase) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
CreateMessageObjects (inherited from AptifyDataFieldControlBase) |
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from AptifyTextBox) | Overloaded. Releases all resources used by the Component.
DoFormComponentConfig | Configures the Component.
DoFormComponentConfigRunMode (inherited from AptifyTextBox) |
DoPostal_Leave (inherited from AptifyDataFieldControlBase) |
Finalize (inherited from AptifyControlBase) |
FormatValue (inherited from AptifyTextBox) | Formats the Value of the control using the FormatString. If FormatString is blank, the default formatting for the data type will be used. Example: The Default Format String for money is Currency which uses the client's regional format settings for Currency.
FormComponentConfig (inherited from AptifyControlBase) |
FormComponentHide (inherited from AptifyControlBase) |
FormComponentShow (inherited from AptifyControlBase) | Overloaded.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
LookupPostalInfo (inherited from AptifyDataFieldControlBase) |
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from AptifyTextBox) |
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from AptifyTextBox) |
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from AptifyTextBox) |
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RequiredGECheck (inherited from AptifyControlBase) |
RequiredPropertiesCheck (inherited from AptifyControlBase) |
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlMetaData (inherited from AptifyTextBox) |
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetSecurity (inherited from AptifyDataFieldControlBase) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTextAlignByDataType (inherited from AptifyTextBox) | Sets the TextAlign property based on the Data Type of the DataField. Numeric data types are right-aligned. All others are left-aligned. Note: This behavior is currently disabled.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetValueFromGe (inherited from AptifyDataFieldControlBase) |
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Instance Events

PostConfig (inherited from AptifyDataFieldControlBase)
PreConfig (inherited from AptifyDataFieldControlBase)

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.
StopInitialization (inherited from AptifyDataFieldControlBase) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CompaniesSpecialFieldTextBox Class | Aptify.Applications.Companies Namespace


CompaniesSpecialFieldTextBox Constructor

Initializes a new instance of the CompaniesSpecialFieldTextBox class.

public CompaniesSpecialFieldTextBox();

See Also

CompaniesSpecialFieldTextBox Class | Aptify.Applications.Companies Namespace


CompaniesSpecialFieldTextBox Methods

The methods of the CompaniesSpecialFieldTextBox class are listed below. For a complete list of CompaniesSpecialFieldTextBox class members, see the CompaniesSpecialFieldTextBox Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BoundControlConfig (inherited from AptifyTextBox) |
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ClearData (inherited from AptifyDataFieldControlBase) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DisplayControlHelp (inherited from AptifyControlBase) | This method will display control-level help information. This method will use the HelpTitle and HelpText overridable members to display the Field Help object from Aptify.Framework.WindowsControls.FieldHelp. If the title and text is desired to be overriden it is not necessary to override this method, rather override the HelpTitle and HelpText properties which are used by this method.
DisplayEntityHelp (inherited from AptifyControlBase) | This method is responsible for displaying the help file to the user and will attempt to provide context sensitive help based on the particular entity being displayed. If no entity-specific help file is available for the user then the standard Aptify Shell.Aptify Help file will be used to display help to the user. Override this method in sub-classes to change the method for displaying help.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetDefaultHelpObject (inherited from AptifyControlBase) | This method returns the default help object file in the Aptify Object repository to be used in the event that no entity-specific file exists
GetEntityFieldSpecificHelpObject (inherited from AptifyDataFieldControlBase) | This method returns the Aptify Object Repository Object location for the help file that is specific to this entity field.
GetEntityFieldSpecificHelpTopicURL (inherited from AptifyDataFieldControlBase) | This method returns the Topic URL location within the help file that is specific to this entity field.
GetEntitySpecificHelpObject (inherited from AptifyControlBase) | This method returns the Aptify Object Repository Object location for the help file that is specific to this entity.
GetEntitySpecificHelpTopicURL (inherited from AptifyControlBase) | This method returns the Topic URL location within the help file that is specific to this entity.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseValueChanged (inherited from AptifyControlBase) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from AptifyDataFieldControlBase) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from AptifyTextBox) | Overloaded.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetExtendedType (inherited from AptifyTextBox) |
SetUserCredential (inherited from AptifyControlBase) |
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
TransferDataToObject (inherited from AptifyDataFieldControlBase) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
AptifyControlBaseValueChangedHandler (inherited from AptifyDataFieldControlBase) |
ConfigHelp (inherited from AptifyDataFieldControlBase) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
CreateMessageObjects (inherited from AptifyDataFieldControlBase) |
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from AptifyTextBox) | Overloaded. Releases all resources used by the Component.
DoFormComponentConfig | Configures the Component.
DoFormComponentConfigRunMode (inherited from AptifyTextBox) |
DoPostal_Leave (inherited from AptifyDataFieldControlBase) |
Finalize (inherited from AptifyControlBase) |
FormatValue (inherited from AptifyTextBox) | Formats the Value of the control using the FormatString. If FormatString is blank, the default formatting for the data type will be used. Example: The Default Format String for money is Currency which uses the client's regional format settings for Currency.
FormComponentConfig (inherited from AptifyControlBase) |
FormComponentHide (inherited from AptifyControlBase) |
FormComponentShow (inherited from AptifyControlBase) | Overloaded.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
LookupPostalInfo (inherited from AptifyDataFieldControlBase) |
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from AptifyTextBox) |
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from AptifyTextBox) |
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from AptifyTextBox) |
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RequiredGECheck (inherited from AptifyControlBase) |
RequiredPropertiesCheck (inherited from AptifyControlBase) |
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlMetaData (inherited from AptifyTextBox) |
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetSecurity (inherited from AptifyDataFieldControlBase) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTextAlignByDataType (inherited from AptifyTextBox) | Sets the TextAlign property based on the Data Type of the DataField. Numeric data types are right-aligned. All others are left-aligned. Note: This behavior is currently disabled.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetValueFromGe (inherited from AptifyDataFieldControlBase) |
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CompaniesSpecialFieldTextBox Class | Aptify.Applications.Companies Namespace


CompaniesSpecialFieldTextBox.DoFormComponentConfig Method

Configures the Component.

protected override void DoFormComponentConfig(
AptifyFormTemplateContext FormTemplateContext
);

Parameters

FormTemplateContext

Remarks

See Also

CompaniesSpecialFieldTextBox Class | Aptify.Applications.Companies Namespace


CompanyFlowDownBase Class

Base class used by the other company flow down business object classes

For a list of all members of this type, see CompanyFlowDownBase Members.

System.Object
CompanyFlowDownBase
FlowDownAbbreviatedName
FlowDownDirSort

public class CompanyFlowDownBase : IProcessComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Companies

Assembly: CompanyProcessComponents (in CompanyProcessComponents.dll)

See Also

CompanyFlowDownBase Members | Aptify.Applications.Companies Namespace


CompanyFlowDownBase Members

CompanyFlowDownBase overview

Public Instance Constructors

CompanyFlowDownBase Constructor Initializes a new instance of the CompanyFlowDownBase class.

Public Instance Properties

Properties

Public Instance Methods

Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

Application | Returns the Aptify Application object instance
DataAction | Returns an Aptify DataAction object instance
Database | Returns the name of the database that the Order Entry system resides in

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CompanyFlowDownBase Class | Aptify.Applications.Companies Namespace


CompanyFlowDownBase Constructor

Initializes a new instance of the CompanyFlowDownBase class.

public CompanyFlowDownBase();

See Also

CompanyFlowDownBase Class | Aptify.Applications.Companies Namespace


CompanyFlowDownBase Properties

The properties of the CompanyFlowDownBase class are listed below. For a complete list of CompanyFlowDownBase class members, see the CompanyFlowDownBase Members topic.

Public Instance Properties

Properties

Protected Instance Properties

Application | Returns the Aptify Application object instance
DataAction | Returns an Aptify DataAction object instance
Database | Returns the name of the database that the Order Entry system resides in

See Also

CompanyFlowDownBase Class | Aptify.Applications.Companies Namespace


Application Property

Aptify 5.0 Software Development Kit (SDK)

CompanyFlowDownBase.Application Property

Returns the Aptify Application object instance

protected AptifyApplication Application {get;}

Property Value

Remarks

See Also

CompanyFlowDownBase Class | Aptify.Applications.Companies Namespace


DataAction Property

Aptify 5.0 Software Development Kit (SDK)

CompanyFlowDownBase.DataAction Property

Returns an Aptify DataAction object instance

protected DataAction DataAction {get;}

Property Value

Remarks

See Also

CompanyFlowDownBase Class | Aptify.Applications.Companies Namespace


Database Property

Aptify 5.0 Software Development Kit (SDK)

CompanyFlowDownBase.Database Property

Returns the name of the database that the Order Entry system resides in

protected String Database {get;}

Property Value

Remarks

See Also

CompanyFlowDownBase Class | Aptify.Applications.Companies Namespace


Properties Property

Aptify 5.0 Software Development Kit (SDK)

CompanyFlowDownBase.Properties Property

public virtual AptifyProperties Properties {get;}

Implements

IProcessComponent.

See Also

CompanyFlowDownBase Class | Aptify.Applications.Companies Namespace


CompanyFlowDownBase Methods

The methods of the CompanyFlowDownBase class are listed below. For a complete list of CompanyFlowDownBase class members, see the CompanyFlowDownBase Members topic.

Public Instance Methods

Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CompanyFlowDownBase Class | Aptify.Applications.Companies Namespace


CompanyFlowDownBase.Config Method

public virtual void Config(
AptifyApplication ApplicationObject
);

Implements

IProcessComponent.

See Also

CompanyFlowDownBase Class | Aptify.Applications.Companies Namespace


CompanyFlowDownBase.Run Method

public abstract string Run();

Implements

IProcessComponent.

See Also

CompanyFlowDownBase Class | Aptify.Applications.Companies Namespace


CompanySPMLayout Class

For a list of all members of this type, see CompanySPMLayout Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
CompanySPMLayout

public class CompanySPMLayout : FormTemplateLayout

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Companies

Assembly: AptifyCompaniesGUI (in AptifyCompaniesGUI.dll)

See Also

CompanySPMLayout Members | Aptify.Applications.Companies Namespace


CompanySPMLayout Members

CompanySPMLayout overview

Public Instance Constructors

CompanySPMLayout Constructor Initializes a new instance of the CompanySPMLayout class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig |
OnFormTemplateLoaded |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CompanySPMLayout Class | Aptify.Applications.Companies Namespace


CompanySPMLayout Constructor

Initializes a new instance of the CompanySPMLayout class.

public CompanySPMLayout();

See Also

CompanySPMLayout Class | Aptify.Applications.Companies Namespace


CompanySPMLayout Methods

The methods of the CompanySPMLayout class are listed below. For a complete list of CompanySPMLayout class members, see the CompanySPMLayout Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig |
OnFormTemplateLoaded |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CompanySPMLayout Class | Aptify.Applications.Companies Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

CompanySPMLayout.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

CompanySPMLayout Class | Aptify.Applications.Companies Namespace


CompanySPMLayout.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

CompanySPMLayout Class | Aptify.Applications.Companies Namespace | CompanySPMLayout.Dispose Overload List


CompanySPMLayout.OnFormComponentConfig Method

protected override void OnFormComponentConfig(
AptifyFormTemplateContext Context
);

Implements

IFormComponent.

See Also

CompanySPMLayout Class | Aptify.Applications.Companies Namespace


CompanySPMLayout.OnFormTemplateLoaded Method

protected override void OnFormTemplateLoaded(
FormTemplateLayout.FormTemplateLoadedEventArgs e
);

See Also

CompanySPMLayout Class | Aptify.Applications.Companies Namespace


FlowDownAbbreviatedName Class

This object handles the flow-down of a name from the Companies Entity Name field into the AbbreviatedName field which is used to store the short/acronym version of a company name. The default functionality in the base class automatically populates this field from the Company Name as long as the Abbreviated Name has not previously been manually overriden by the user (tested by checking the old value of the Name field of the Company against the value of AbbreviatedName using the same Abbreviated Name generation).

For a list of all members of this type, see FlowDownAbbreviatedName Members.

System.Object
CompanyFlowDownBase
FlowDownAbbreviatedName

public class FlowDownAbbreviatedName : CompanyFlowDownBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Companies

Assembly: CompanyProcessComponents (in CompanyProcessComponents.dll)

See Also

FlowDownAbbreviatedName Members | Aptify.Applications.Companies Namespace


FlowDownAbbreviatedName Members

FlowDownAbbreviatedName overview

Public Instance Constructors

FlowDownAbbreviatedName Constructor Initializes a new instance of the FlowDownAbbreviatedName class.

Public Instance Properties

Properties (inherited from CompanyFlowDownBase)

Public Instance Methods

Config (inherited from CompanyFlowDownBase) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GenerateAbbreviatedName | This method takes in a company name and returns an abbreviated name. The method is internally called from the process component implementation. The default logic in the base class is to take the first letter of each word(as defined by characters separated by spaces, tabs, or non-alphanumeric characters such as commas, periods, etc) and concatenate the capitalized letters into a single string. For example, a company name of American Demonstration Corporation, Inc. would result in a return value of ADCI
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run | Assumed Process Component Input Properties 1) CompanyGE - GE Object for the Company Record Available Output Properties 1) AbbreviatedName - this output property will return the generated Abbreviated Name the object creates
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

Application (inherited from CompanyFlowDownBase) | Returns the Aptify Application object instance
DataAction (inherited from CompanyFlowDownBase) | Returns an Aptify DataAction object instance
Database (inherited from CompanyFlowDownBase) | Returns the name of the database that the Order Entry system resides in

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FlowDownAbbreviatedName Class | Aptify.Applications.Companies Namespace


FlowDownAbbreviatedName Constructor

Initializes a new instance of the FlowDownAbbreviatedName class.

public FlowDownAbbreviatedName();

See Also

FlowDownAbbreviatedName Class | Aptify.Applications.Companies Namespace


FlowDownAbbreviatedName Methods

The methods of the FlowDownAbbreviatedName class are listed below. For a complete list of FlowDownAbbreviatedName class members, see the FlowDownAbbreviatedName Members topic.

Public Instance Methods

Config (inherited from CompanyFlowDownBase) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GenerateAbbreviatedName | This method takes in a company name and returns an abbreviated name. The method is internally called from the process component implementation. The default logic in the base class is to take the first letter of each word(as defined by characters separated by spaces, tabs, or non-alphanumeric characters such as commas, periods, etc) and concatenate the capitalized letters into a single string. For example, a company name of American Demonstration Corporation, Inc. would result in a return value of ADCI
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run | Assumed Process Component Input Properties 1) CompanyGE - GE Object for the Company Record Available Output Properties 1) AbbreviatedName - this output property will return the generated Abbreviated Name the object creates
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FlowDownAbbreviatedName Class | Aptify.Applications.Companies Namespace


FlowDownAbbreviatedName.GenerateAbbreviatedName Method

This method takes in a company name and returns an abbreviated name. The method is internally called from the process component implementation. The default logic in the base class is to take the first letter of each word(as defined by characters separated by spaces, tabs, or non-alphanumeric characters such as commas, periods, etc) and concatenate the capitalized letters into a single string. For example, a company name of American Demonstration Corporation, Inc. would result in a return value of ADCI

public virtual string GenerateAbbreviatedName(
String CompanyName
);

Parameters

CompanyName

Return Value

Remarks

See Also

FlowDownAbbreviatedName Class | Aptify.Applications.Companies Namespace


FlowDownAbbreviatedName.Run Method

Assumed Process Component Input Properties 1) CompanyGE - GE Object for the Company Record Available Output Properties 1) AbbreviatedName - this output property will return the generated Abbreviated Name the object creates

public override string Run();

Return Value

Implements

IProcessComponent.

Remarks

See Also

FlowDownAbbreviatedName Class | Aptify.Applications.Companies Namespace


FlowDownDirSort Class

This object handles the flow-down of a name from the Companies Entity Name field into the DirSort field which is used to handle sorting and searching without special characters. The default functionality in the base class automatically populates this field from the Company Name as long as the DirSort has not previously been manually overriden by the user (tested by checking the old value of the Name field of the Company against the value of DirSort). In addition, this object will also auto-populate the DirLetter field with the first character in the Name, using the same logic as described above.

For a list of all members of this type, see FlowDownDirSort Members.

System.Object
CompanyFlowDownBase
FlowDownDirSort

public class FlowDownDirSort : CompanyFlowDownBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Companies

Assembly: CompanyProcessComponents (in CompanyProcessComponents.dll)

See Also

FlowDownDirSort Members | Aptify.Applications.Companies Namespace


FlowDownDirSort Members

FlowDownDirSort overview

Public Instance Constructors

FlowDownDirSort Constructor Initializes a new instance of the FlowDownDirSort class.

Public Instance Properties

Properties (inherited from CompanyFlowDownBase)

Public Instance Methods

Config (inherited from CompanyFlowDownBase) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run | Assumed Process Component Input Properties 1) CompanyGE - GE Object for the Company Record
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

Application (inherited from CompanyFlowDownBase) | Returns the Aptify Application object instance
DataAction (inherited from CompanyFlowDownBase) | Returns an Aptify DataAction object instance
Database (inherited from CompanyFlowDownBase) | Returns the name of the database that the Order Entry system resides in

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FlowDownDirSort Class | Aptify.Applications.Companies Namespace


FlowDownDirSort Constructor

Initializes a new instance of the FlowDownDirSort class.

public FlowDownDirSort();

See Also

FlowDownDirSort Class | Aptify.Applications.Companies Namespace


FlowDownDirSort Methods

The methods of the FlowDownDirSort class are listed below. For a complete list of FlowDownDirSort class members, see the FlowDownDirSort Members topic.

Public Instance Methods

Config (inherited from CompanyFlowDownBase) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run | Assumed Process Component Input Properties 1) CompanyGE - GE Object for the Company Record
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FlowDownDirSort Class | Aptify.Applications.Companies Namespace


FlowDownDirSort.Run Method

Assumed Process Component Input Properties 1) CompanyGE - GE Object for the Company Record

public override string Run();

Return Value

Implements

IProcessComponent.

Remarks

See Also

FlowDownDirSort Class | Aptify.Applications.Companies Namespace


Aptify.Applications.Companies.CompanyListsControl

Aptify 5.0 Software Development Kit (SDK)

Aptify.Applications.Companies.CompanyListsControl Namespace

This namespace corresponds to the control that appears as the Companies form's Lists tab.

Namespace hierarchy

Classes

Class | Description
CompanyLists |


CompanyLists Class

For a list of all members of this type, see CompanyLists Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
CompanyLists

public class CompanyLists : FormComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Companies.CompanyListsControl

Assembly: CompanyListsControl (in CompanyListsControl.dll)

See Also

CompanyLists Members | Aptify.Applications.Companies.CompanyListsControl Namespace


CompanyLists Members

CompanyLists overview

Public Instance Constructors

CompanyLists Constructor Initializes a new instance of the CompanyLists class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
EntityName | Gets/Sets the value used for Entity to be used by ELV.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormComponent) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateContext (inherited from FormComponent) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig | Initializes the Form Component's properties.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormComponent) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormComponent) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormComponent) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CompanyLists Class | Aptify.Applications.Companies.CompanyListsControl Namespace


CompanyLists Constructor

Initializes a new instance of the CompanyLists class.

public CompanyLists();

See Also

CompanyLists Class | Aptify.Applications.Companies.CompanyListsControl Namespace


CompanyLists Properties

The properties of the CompanyLists class are listed below. For a complete list of CompanyLists class members, see the CompanyLists Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
EntityName | Gets/Sets the value used for Entity to be used by ELV.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateContext (inherited from FormComponent) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

CompanyLists Class | Aptify.Applications.Companies.CompanyListsControl Namespace


EntityName Property

Aptify 5.0 Software Development Kit (SDK)

CompanyLists.EntityName Property

Gets/Sets the value used for Entity to be used by ELV.

public String EntityName {get; set;}

Property Value

Remarks

See Also

CompanyLists Class | Aptify.Applications.Companies.CompanyListsControl Namespace


CompanyLists Methods

The methods of the CompanyLists class are listed below. For a complete list of CompanyLists class members, see the CompanyLists Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormComponent) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig | Initializes the Form Component's properties.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormComponent) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormComponent) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormComponent) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CompanyLists Class | Aptify.Applications.Companies.CompanyListsControl Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

CompanyLists.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

CompanyLists Class | Aptify.Applications.Companies.CompanyListsControl Namespace


CompanyLists.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

CompanyLists Class | Aptify.Applications.Companies.CompanyListsControl Namespace | CompanyLists.Dispose Overload List


CompanyLists.OnFormComponentConfig Method

Initializes the Form Component's properties.

protected override void OnFormComponentConfig(
AptifyFormTemplateContext FormTemplateContext
);

Parameters

FormTemplateContext

Implements

IFormComponent.

Remarks

See Also

CompanyLists Class | Aptify.Applications.Companies.CompanyListsControl Namespace


Aptify.Applications.Companies.CompanyOrdersControl

Aptify 5.0 Software Development Kit (SDK)

Aptify.Applications.Companies.CompanyOrdersControl Namespace

This namespace corresponds to the control that appears as the Companies form's Orders tab.

Namespace hierarchy

Classes

Class | Description
CompanyOrders |


CompanyOrders Class

For a list of all members of this type, see CompanyOrders Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
CompanyOrders

public class CompanyOrders : FormComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Companies.CompanyOrdersControl

Assembly: CompanyOrdersControl (in CompanyOrdersControl.dll)

See Also

CompanyOrders Members | Aptify.Applications.Companies.CompanyOrdersControl Namespace


CompanyOrders Members

CompanyOrders overview

Public Instance Constructors

CompanyOrders Constructor Initializes a new instance of the CompanyOrders class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormComponent) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateContext (inherited from FormComponent) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormComponent) |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormComponent) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormComponent) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CompanyOrders Class | Aptify.Applications.Companies.CompanyOrdersControl Namespace


CompanyOrders Constructor

Initializes a new instance of the CompanyOrders class.

public CompanyOrders();

See Also

CompanyOrders Class | Aptify.Applications.Companies.CompanyOrdersControl Namespace


CompanyOrders Methods

The methods of the CompanyOrders class are listed below. For a complete list of CompanyOrders class members, see the CompanyOrders Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormComponent) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormComponent) |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormComponent) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormComponent) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CompanyOrders Class | Aptify.Applications.Companies.CompanyOrdersControl Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

CompanyOrders.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

CompanyOrders Class | Aptify.Applications.Companies.CompanyOrdersControl Namespace


CompanyOrders.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

CompanyOrders Class | Aptify.Applications.Companies.CompanyOrdersControl Namespace | CompanyOrders.Dispose Overload List


CompanyOrders.OnRefresh Method

protected override void OnRefresh();

Implements

IFormComponent.

See Also

CompanyOrders Class | Aptify.Applications.Companies.CompanyOrdersControl Namespace


Aptify.Applications.CompanyObject

Aptify 5.0 Software Development Kit (SDK)

Aptify.Applications.CompanyObject Namespace

This namespace corresponds to the business logic used by the Companies entity.

Namespace hierarchy

Classes

Class | Description
CompanyObject | Contains logic needed to create, read, update, and delete Company Entity records.
CompanySPMEntity |


CompanyObject Class

Contains logic needed to create, read, update, and delete Company Entity records.

For a list of all members of this type, see CompanyObject Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
CompaniesClass
CompanyObject

public class CompanyObject : CompaniesClass

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.CompanyObject

Assembly: CompanyObject (in CompanyObject.dll)

See Also

CompanyObject Members | Aptify.Applications.CompanyObject Namespace


CompanyObject Members

CompanyObject overview

Public Instance Constructors

CompanyObject Constructor Initializes a new instance of the CompanyObject class.

Public Instance Properties

AbbreviatedName (inherited from CompaniesClass) |
AddressID (inherited from CompaniesClass) |
AddressIDObject (inherited from CompaniesClass) |
AddressLine1 (inherited from CompaniesClass) |
AddressLine2 (inherited from CompaniesClass) |
AddressLine3 (inherited from CompaniesClass) |
AddressLine4 (inherited from CompaniesClass) |
Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
APVendorID (inherited from CompaniesClass) |
Atmosphere (inherited from CompaniesClass) |
BillingAddressID (inherited from CompaniesClass) |
BillingAddressIDObject (inherited from CompaniesClass) |
BillingAddressLine1 (inherited from CompaniesClass) |
BillingAddressLine2 (inherited from CompaniesClass) |
BillingAddressLine3 (inherited from CompaniesClass) |
BillingAddressLine4 (inherited from CompaniesClass) |
BillingCity (inherited from CompaniesClass) |
BillingCountry (inherited from CompaniesClass) |
BillingCounty (inherited from CompaniesClass) |
BillingState (inherited from CompaniesClass) |
BillingTerms (inherited from CompaniesClass) |
BillingZipCode (inherited from CompaniesClass) |
BillingZipCode5Numeric (inherited from CompaniesClass) |
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
City (inherited from CompaniesClass) |
Comments (inherited from CompaniesClass) |
CompanyType (inherited from CompaniesClass) |
CompanyTypeID (inherited from CompaniesClass) |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
Country (inherited from CompaniesClass) |
CountryCodeID (inherited from CompaniesClass) |
County (inherited from CompaniesClass) |
CountyDistrict (inherited from CompaniesClass) |
CreditLimit (inherited from CompaniesClass) |
CreditLimitCurrencyTypeID (inherited from CompaniesClass) |
CreditStatus (inherited from CompaniesClass) |
CreditStatusID (inherited from CompaniesClass) |
CRRT (inherited from CompaniesClass) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DateCreated (inherited from CompaniesClass) |
DateUpdated (inherited from CompaniesClass) |
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DirDescription (inherited from CompaniesClass) |
Directions (inherited from CompaniesClass) |
DirExclude (inherited from CompaniesClass) |
DirLetter (inherited from CompaniesClass) |
DirSort (inherited from CompaniesClass) |
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
DivisionName (inherited from CompaniesClass) |
DnBRating (inherited from CompaniesClass) |
DomainName (inherited from CompaniesClass) |
DuesCategory (inherited from CompaniesClass) |
DuesCategoryID (inherited from CompaniesClass) |
DuesPaidThru (inherited from CompaniesClass) |
EmailExclude (inherited from CompaniesClass) |
EmailPattern (inherited from CompaniesClass) |
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
Established (inherited from CompaniesClass) |
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
FaxExclude (inherited from CompaniesClass) |
FedTaxID (inherited from CompaniesClass) |
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
GLOrderLevel (inherited from CompaniesClass) |
GLOrderLevelID (inherited from CompaniesClass) |
GLPaymentLevel (inherited from CompaniesClass) |
GLPaymentLevelID (inherited from CompaniesClass) |
ID (inherited from CompaniesClass) |
InfoEmail (inherited from CompaniesClass) |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
JobsEmail (inherited from CompaniesClass) |
JoinDate (inherited from CompaniesClass) |
LastDuesAmount (inherited from CompaniesClass) |
LastDuesAmountCurrencyTypeID (inherited from CompaniesClass) |
LastDuesPaymentDate (inherited from CompaniesClass) |
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
MailCode (inherited from CompaniesClass) |
MailExclude (inherited from CompaniesClass) |
MainAccountManager (inherited from CompaniesClass) |
MainAccountManagerID (inherited from CompaniesClass) |
MainAreaCode (inherited from CompaniesClass) |
MainCountryCode (inherited from CompaniesClass) |
MainEmail (inherited from CompaniesClass) |
MainFaxAreaCode (inherited from CompaniesClass) |
MainFaxCountryCode (inherited from CompaniesClass) |
MainFaxID (inherited from CompaniesClass) |
MainFaxIDObject (inherited from CompaniesClass) |
MainFaxNumber (inherited from CompaniesClass) |
MainPhone (inherited from CompaniesClass) |
MainPhoneID (inherited from CompaniesClass) |
MainPhoneIDObject (inherited from CompaniesClass) |
MemberType (inherited from CompaniesClass) |
MemberTypeID (inherited from CompaniesClass) |
Name (inherited from CompaniesClass) |
NumberEmployees (inherited from CompaniesClass) |
OfficeType (inherited from CompaniesClass) |
OldID (inherited from CompaniesClass) |
Organization (inherited from CompaniesClass) |
OrganizationID (inherited from CompaniesClass) |
OwnType (inherited from CompaniesClass) |
Parent (inherited from CompaniesClass) |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentID (inherited from CompaniesClass) |
ParentMemberType (inherited from CompaniesClass) |
ParentMemberTypeID (inherited from CompaniesClass) |
ParentName (inherited from CompaniesClass) |
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
POBox (inherited from CompaniesClass) |
POBoxAddressID (inherited from CompaniesClass) |
POBoxCity (inherited from CompaniesClass) |
POBoxCountry (inherited from CompaniesClass) |
POBoxCounty (inherited from CompaniesClass) |
POBoxLine2 (inherited from CompaniesClass) |
POBoxLine3 (inherited from CompaniesClass) |
POBoxLine4 (inherited from CompaniesClass) |
POBoxState (inherited from CompaniesClass) |
POBoxZipCode (inherited from CompaniesClass) |
POBoxZipCode5Numeric (inherited from CompaniesClass) |
PreferredCurrencyType (inherited from CompaniesClass) |
PreferredCurrencyTypeID (inherited from CompaniesClass) |
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
PrimaryProductCode (inherited from CompaniesClass) |
PrimaryProductCodeID (inherited from CompaniesClass) |
PrimaryShareholder (inherited from CompaniesClass) |
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Revenue (inherited from CompaniesClass) |
RevenueCategory (inherited from CompaniesClass) |
RevenueCategoryID (inherited from CompaniesClass) |
RootCompany (inherited from CompaniesClass) |
RootCompanyID (inherited from CompaniesClass) |
RootMemberType (inherited from CompaniesClass) |
RootMemberTypeID (inherited from CompaniesClass) |
RootName (inherited from CompaniesClass) |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SICCode (inherited from CompaniesClass) |
State (inherited from CompaniesClass) |
StateHouse (inherited from CompaniesClass) |
StateSenate (inherited from CompaniesClass) |
Status (inherited from CompaniesClass) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
TerminationDate (inherited from CompaniesClass) |
UnpubRevenue (inherited from CompaniesClass) |
USCongress (inherited from CompaniesClass) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.
VerifyStatus (inherited from CompaniesClass) |
WebSite (inherited from CompaniesClass) |
WhoCreated (inherited from CompaniesClass) |
WhoUpdated (inherited from CompaniesClass) |
ZipCode (inherited from CompaniesClass) |
ZipCode5Numeric (inherited from CompaniesClass) |

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
CompanyAccountManagers (inherited from CompaniesClass) |
CompanyAccountManagersObject (inherited from CompaniesClass) |
CompanyAddress (inherited from CompaniesClass) |
CompanyAddressObject (inherited from CompaniesClass) |
CompanyPhone (inherited from CompaniesClass) |
CompanyPhoneObject (inherited from CompaniesClass) |
CompanyProductCodes (inherited from CompaniesClass) |
CompanyProductCodesObject (inherited from CompaniesClass) |
CompanyRelationships (inherited from CompaniesClass) |
CompanyRelationshipsObject (inherited from CompaniesClass) |
CompanySavedPaymentMethods (inherited from CompaniesClass) |
CompanySavedPaymentMethodsObject (inherited from CompaniesClass) |
CompanyTaxExemptCodes (inherited from CompaniesClass) |
CompanyTaxExemptCodesObject (inherited from CompaniesClass) |
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. Returns values in the DataField of the entity.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded. ''' Saves the Company Object.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue | Contains custom logic that is used to set values at the GE level.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize |
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

CompanyObject Class | Aptify.Applications.CompanyObject Namespace


CompanyObject Constructor

Initializes a new instance of the CompanyObject class.

public CompanyObject();

See Also

CompanyObject Class | Aptify.Applications.CompanyObject Namespace


CompanyObject Methods

The methods of the CompanyObject class are listed below. For a complete list of CompanyObject class members, see the CompanyObject Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
CompanyAccountManagers (inherited from CompaniesClass) |
CompanyAccountManagersObject (inherited from CompaniesClass) |
CompanyAddress (inherited from CompaniesClass) |
CompanyAddressObject (inherited from CompaniesClass) |
CompanyPhone (inherited from CompaniesClass) |
CompanyPhoneObject (inherited from CompaniesClass) |
CompanyProductCodes (inherited from CompaniesClass) |
CompanyProductCodesObject (inherited from CompaniesClass) |
CompanyRelationships (inherited from CompaniesClass) |
CompanyRelationshipsObject (inherited from CompaniesClass) |
CompanySavedPaymentMethods (inherited from CompaniesClass) |
CompanySavedPaymentMethodsObject (inherited from CompaniesClass) |
CompanyTaxExemptCodes (inherited from CompaniesClass) |
CompanyTaxExemptCodesObject (inherited from CompaniesClass) |
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. Returns values in the DataField of the entity.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded. ''' Saves the Company Object.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue | Contains custom logic that is used to set values at the GE level.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize |
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

CompanyObject Class | Aptify.Applications.CompanyObject Namespace


CompanyObject.Finalize Method

protected override void Finalize();

See Also

CompanyObject Class | Aptify.Applications.CompanyObject Namespace


GetValue Method

Aptify 5.0 Software Development Kit (SDK)

CompanyObject.GetValue Method

Returns values in the DataField of the entity.

Overload List

Returns values in the DataField of the entity.

public override object GetValue(String);

Inherited from AptifyGenericEntityBase.

public virtual object GetValue(String,Boolean);

See Also

CompanyObject Class | Aptify.Applications.CompanyObject Namespace


CompanyObject.GetValue Method (String)

Returns values in the DataField of the entity.

public override object GetValue(
String FieldName
);

Parameters

FieldName

Remarks

Adds specific logic to handle Root MemberType Fields.

See Also

CompanyObject Class | Aptify.Applications.CompanyObject Namespace | CompanyObject.GetValue Overload List


Save Method

Aptify 5.0 Software Development Kit (SDK)

CompanyObject.Save Method

''' Saves the Company Object.

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Save();

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean,ref String&);

''' Saves the Company Object.

public override bool Save(Boolean,ref String&,String);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(ref String&);

See Also

CompanyObject Class | Aptify.Applications.CompanyObject Namespace


CompanyObject.Save Method (Boolean, String&, String)

''' Saves the Company Object.

public override bool Save(
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

Parameters

AllowGUI
ErrorString
TransactionID

Return Value

Remarks

Handles flowdown of TerminationDate to Persons records associated with the company.

See Also

CompanyObject Class | Aptify.Applications.CompanyObject Namespace | CompanyObject.Save Overload List


CompanyObject.SetValue Method

Contains custom logic that is used to set values at the GE level.

public override void SetValue(
String FieldName,
Object Value
);

Parameters

FieldName
Value

Remarks

Provides flowdown logic for addresses when the ParentID is set.

See Also

CompanyObject Class | Aptify.Applications.CompanyObject Namespace


Validate Method

Aptify 5.0 Software Development Kit (SDK)

CompanyObject.Validate Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Validate();

public override bool Validate(ref String&);

See Also

CompanyObject Class | Aptify.Applications.CompanyObject Namespace


CompanyObject.Validate Method (String&)

public override bool Validate(
ref String& ErrorString
);

Parameters

ErrorString

Return Value

Remarks

Adds logic to check for valid Parent company

See Also

CompanyObject Class | Aptify.Applications.CompanyObject Namespace | CompanyObject.Validate Overload List


CompanySPMEntity Class

For a list of all members of this type, see CompanySPMEntity Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
CompanySavedPaymentMethodsClass
CompanySPMEntity

public class CompanySPMEntity : CompanySavedPaymentMethodsClass

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.CompanyObject

Assembly: CompanyObject (in CompanyObject.dll)

See Also

CompanySPMEntity Members | Aptify.Applications.CompanyObject Namespace


CompanySPMEntity Members

CompanySPMEntity overview

Public Instance Constructors

CompanySPMEntity Constructor Initializes a new instance of the CompanySPMEntity class.

Public Instance Properties

ABA (inherited from CompanySavedPaymentMethodsClass) |
AccountNumber (inherited from CompanySavedPaymentMethodsClass) |
Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
Bank (inherited from CompanySavedPaymentMethodsClass) |
BranchName (inherited from CompanySavedPaymentMethodsClass) |
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
CCAccountNumber (inherited from CompanySavedPaymentMethodsClass) |
CCExpireDate (inherited from CompanySavedPaymentMethodsClass) |
CCPartial (inherited from CompanySavedPaymentMethodsClass) |
CompanyID (inherited from CompanySavedPaymentMethodsClass) |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CreditOrderID (inherited from CompanySavedPaymentMethodsClass) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
Description (inherited from CompanySavedPaymentMethodsClass) |
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
DueDate (inherited from CompanySavedPaymentMethodsClass) |
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EndDate (inherited from CompanySavedPaymentMethodsClass) |
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
ID (inherited from CompanySavedPaymentMethodsClass) |
IsActive (inherited from CompanySavedPaymentMethodsClass) |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
Name (inherited from CompanySavedPaymentMethodsClass) |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PaymentInformationID (inherited from CompanySavedPaymentMethodsClass) |
PaymentType (inherited from CompanySavedPaymentMethodsClass) |
PaymentTypeID (inherited from CompanySavedPaymentMethodsClass) |
PONumber (inherited from CompanySavedPaymentMethodsClass) |
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Sequence (inherited from CompanySavedPaymentMethodsClass) |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
StartDate (inherited from CompanySavedPaymentMethodsClass) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
Terms (inherited from CompanySavedPaymentMethodsClass) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

CompanySPMEntity Class | Aptify.Applications.CompanyObject Namespace


CompanySPMEntity Constructor

Initializes a new instance of the CompanySPMEntity class.

public CompanySPMEntity();

See Also

CompanySPMEntity Class | Aptify.Applications.CompanyObject Namespace


CompanySPMEntity Methods

The methods of the CompanySPMEntity class are listed below. For a complete list of CompanySPMEntity class members, see the CompanySPMEntity Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

CompanySPMEntity Class | Aptify.Applications.CompanyObject Namespace


Validate Method

Aptify 5.0 Software Development Kit (SDK)

CompanySPMEntity.Validate Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Validate();

public override bool Validate(ref String&);

See Also

CompanySPMEntity Class | Aptify.Applications.CompanyObject Namespace


CompanySPMEntity.Validate Method (String&)

public override bool Validate(
ref String& ErrorString
);

See Also

CompanySPMEntity Class | Aptify.Applications.CompanyObject Namespace | CompanySPMEntity.Validate Overload List


Aptify.Applications.ContactManagement

Aptify 5.0 Software Development Kit (SDK)

Aptify.Applications.ContactManagement Namespace

The objects in this namespace correspond to Aptify's Contact Log entity and its related functionality.

Namespace hierarchy

Classes

Class | Description
ContactLog | Aptify Contact Log GE Sub-Class Object. Implements Contact Log specific functionality sub-classing the AptifyGenericEntity class.
OutlookContactLogImport | Provides functionality to imports Contact Log records into Aptify from Microsoft Outlook emails. This is a non-visual class that can be used from wizards as well as Process Components.
OutlookContactLogImportWizard | Aptify Outlook Contact Log Import Wizard - uses the OutlookContactLogImport class to import Outlook email into the Aptify Contact Log.

Delegates

Delegate | Description
OutlookContactLogImport.ItemErrorEventHandler |
OutlookContactLogImport.ItemImportedEventHandler |
OutlookContactLogImport.StatusUpdateEventHandler |


ContactLog Class

Aptify Contact Log GE Sub-Class Object. Implements Contact Log specific functionality sub-classing the AptifyGenericEntity class.

For a list of all members of this type, see ContactLog Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
ContactLogClass
ContactLog

public class ContactLog : ContactLogClass

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.ContactManagement

Assembly: ContactLogObject (in ContactLogObject.dll)

See Also

ContactLog Members | Aptify.Applications.ContactManagement Namespace


ContactLog Members

ContactLog overview

Public Instance Constructors

ContactLog Constructor Initializes a new instance of the ContactLog class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
AssignedTo (inherited from ContactLogClass) |
AssignedToID (inherited from ContactLogClass) |
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
Category (inherited from ContactLogClass) |
CategoryID (inherited from ContactLogClass) |
Completed (inherited from ContactLogClass) |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DateCreated (inherited from ContactLogClass) |
DateField (inherited from ContactLogClass) |
DateUpdated (inherited from ContactLogClass) |
DefaultEmployeeLinkID (inherited from ContactLogClass) |
DefaultPersonLinkID (inherited from ContactLogClass) |
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
Description (inherited from ContactLogClass) |
Details (inherited from ContactLogClass) |
Direction (inherited from ContactLogClass) |
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
Forward (inherited from ContactLogClass) |
ForwardID (inherited from ContactLogClass) |
ID (inherited from ContactLogClass) |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
NextContactDate (inherited from ContactLogClass) |
NextContactReason (inherited from ContactLogClass) |
NextContactStatus (inherited from ContactLogClass) |
OwnerID (inherited from ContactLogClass) |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentID (inherited from ContactLogClass) |
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
Priority (inherited from ContactLogClass) |
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
Type (inherited from ContactLogClass) |
TypeID (inherited from ContactLogClass) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.
WhoCreated (inherited from ContactLogClass) |
WhoUpdated (inherited from ContactLogClass) |

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
ContactLogLinks (inherited from ContactLogClass) |
ContactLogLinksObject (inherited from ContactLogClass) |
CreateFileItem | Creates a file in the User's Temp directory under the Aptify folder with the name, Description.sExt. The file contains formatted text that contains information that identifies a resource within Aptify.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord | This base method will override the base functionality to handle the default value for the Date field including both the date and time at the present moment when a new record is added to the database.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded. The Save() method overrides the standard GE Save functionality and adds in capabilities to automatically create new Calendar and/or Task items when a new record is created in the database. Entity Attributes on the Contact Log entity control if Calendar items are created or Task items are created (in the messaging system, such as Outlook, Groupwise, etc). The following entity attributes are supported: AddToCalendar - if this entity attribute is set to 1, an item will be added to the calendar automatically for new contact log records that have a Next Contact Date filled inAddToTasks - if this entity attribute is set to 1, an item will be added to the tasks list(in the messaging system such as Outlook) automatically for new contact log records that have a Next Contact Date filled in
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AddItems | This method is responsible for handling the process of adding new items to the messaging system calendar and/or tasks list. This method is called from the Save() method for new records only.
AddItemToCalendar | This method is reponsible for adding an item to the messaging system's calendar. It is called from the AddItems() method if the Entity Attribute for the Contact Logs entity is set that indicates the system should add calendar entries to the messaging system. See the Save() method for more information on the entity attributes that drive this functionality.
AddItemToTaskList | This method is reponsible for adding an item to the messaging system's task list. It is called from the AddItems() method if the Entity Attribute for the Contact Logs entity is set that indicates the system should add tasks to the messaging system. See the Save() method for more information on the entity attributes that drive this functionality.
AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
DoAddItems | This method determines whether a new external messaging (e.g., Outlook Calendar) item should be created for this contact log. This method should be called prior to Save() as it tests the IsNewRecord property. Only new contact log records and those where a NextContactDate exists should create a message item.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

ContactLog Class | Aptify.Applications.ContactManagement Namespace


ContactLog Constructor

Initializes a new instance of the ContactLog class.

public ContactLog();

See Also

ContactLog Class | Aptify.Applications.ContactManagement Namespace


ContactLog Methods

The methods of the ContactLog class are listed below. For a complete list of ContactLog class members, see the ContactLog Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
ContactLogLinks (inherited from ContactLogClass) |
ContactLogLinksObject (inherited from ContactLogClass) |
CreateFileItem | Creates a file in the User's Temp directory under the Aptify folder with the name, Description.sExt. The file contains formatted text that contains information that identifies a resource within Aptify.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord | This base method will override the base functionality to handle the default value for the Date field including both the date and time at the present moment when a new record is added to the database.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded. The Save() method overrides the standard GE Save functionality and adds in capabilities to automatically create new Calendar and/or Task items when a new record is created in the database. Entity Attributes on the Contact Log entity control if Calendar items are created or Task items are created (in the messaging system, such as Outlook, Groupwise, etc). The following entity attributes are supported: AddToCalendar - if this entity attribute is set to 1, an item will be added to the calendar automatically for new contact log records that have a Next Contact Date filled inAddToTasks - if this entity attribute is set to 1, an item will be added to the tasks list(in the messaging system such as Outlook) automatically for new contact log records that have a Next Contact Date filled in
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AddItems | This method is responsible for handling the process of adding new items to the messaging system calendar and/or tasks list. This method is called from the Save() method for new records only.
AddItemToCalendar | This method is reponsible for adding an item to the messaging system's calendar. It is called from the AddItems() method if the Entity Attribute for the Contact Logs entity is set that indicates the system should add calendar entries to the messaging system. See the Save() method for more information on the entity attributes that drive this functionality.
AddItemToTaskList | This method is reponsible for adding an item to the messaging system's task list. It is called from the AddItems() method if the Entity Attribute for the Contact Logs entity is set that indicates the system should add tasks to the messaging system. See the Save() method for more information on the entity attributes that drive this functionality.
AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
DoAddItems | This method determines whether a new external messaging (e.g., Outlook Calendar) item should be created for this contact log. This method should be called prior to Save() as it tests the IsNewRecord property. Only new contact log records and those where a NextContactDate exists should create a message item.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

ContactLog Class | Aptify.Applications.ContactManagement Namespace


ContactLog.AddItems Method

This method is responsible for handling the process of adding new items to the messaging system calendar and/or tasks list. This method is called from the Save() method for new records only.

protected virtual bool AddItems();

Return Value

Remarks

See Also

ContactLog Class | Aptify.Applications.ContactManagement Namespace


ContactLog.AddItemToCalendar Method

This method is reponsible for adding an item to the messaging system's calendar. It is called from the AddItems() method if the Entity Attribute for the Contact Logs entity is set that indicates the system should add calendar entries to the messaging system. See the Save() method for more information on the entity attributes that drive this functionality.

protected virtual bool AddItemToCalendar();

Return Value

Remarks

See Also

ContactLog Class | Aptify.Applications.ContactManagement Namespace


ContactLog.AddItemToTaskList Method

This method is reponsible for adding an item to the messaging system's task list. It is called from the AddItems() method if the Entity Attribute for the Contact Logs entity is set that indicates the system should add tasks to the messaging system. See the Save() method for more information on the entity attributes that drive this functionality.

protected virtual bool AddItemToTaskList();

Return Value

Remarks

See Also

ContactLog Class | Aptify.Applications.ContactManagement Namespace


ContactLog.CreateFileItem Method

Creates a file in the User's Temp directory under the Aptify folder with the name, Description.sExt. The file contains formatted text that contains information that identifies a resource within Aptify.

public string CreateFileItem(
String sExt,
Int64 lID,
String sEntityName,
String sDescription
);

Parameters

sExt
lID
sEntityName
sDescription

Return Value

Remarks

See Also

ContactLog Class | Aptify.Applications.ContactManagement Namespace


ContactLog.DoAddItems Method

This method determines whether a new external messaging (e.g., Outlook Calendar) item should be created for this contact log. This method should be called prior to Save() as it tests the IsNewRecord property. Only new contact log records and those where a NextContactDate exists should create a message item.

protected virtual bool DoAddItems();

Return Value

True if an external message item can be created for this Contact Log.

Remarks

See Also

ContactLog Class | Aptify.Applications.ContactManagement Namespace


ContactLog.NewRecord Method

This base method will override the base functionality to handle the default value for the Date field including both the date and time at the present moment when a new record is added to the database.

public override bool NewRecord();

Return Value

Remarks

See Also

ContactLog Class | Aptify.Applications.ContactManagement Namespace


Save Method

Aptify 5.0 Software Development Kit (SDK)

ContactLog.Save Method

The Save() method overrides the standard GE Save functionality and adds in capabilities to automatically create new Calendar and/or Task items when a new record is created in the database. Entity Attributes on the Contact Log entity control if Calendar items are created or Task items are created (in the messaging system, such as Outlook, Groupwise, etc). The following entity attributes are supported: AddToCalendar - if this entity attribute is set to 1, an item will be added to the calendar automatically for new contact log records that have a Next Contact Date filled inAddToTasks - if this entity attribute is set to 1, an item will be added to the tasks list(in the messaging system such as Outlook) automatically for new contact log records that have a Next Contact Date filled in

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Save();

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean,ref String&);

The Save() method overrides the standard GE Save functionality and adds in capabilities to automatically create new Calendar and/or Task items when a new record is created in the database. Entity Attributes on the Contact Log entity control if Calendar items are created or Task items are created (in the messaging system, such as Outlook, Groupwise, etc). The following entity attributes are supported: AddToCalendar - if this entity attribute is set to 1, an item will be added to the calendar automatically for new contact log records that have a Next Contact Date filled inAddToTasks - if this entity attribute is set to 1, an item will be added to the tasks list(in the messaging system such as Outlook) automatically for new contact log records that have a Next Contact Date filled in

public override bool Save(Boolean,ref String&,String);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(ref String&);

See Also

ContactLog Class | Aptify.Applications.ContactManagement Namespace


ContactLog.Save Method (Boolean, String&, String)

The Save() method overrides the standard GE Save functionality and adds in capabilities to automatically create new Calendar and/or Task items when a new record is created in the database. Entity Attributes on the Contact Log entity control if Calendar items are created or Task items are created (in the messaging system, such as Outlook, Groupwise, etc). The following entity attributes are supported: AddToCalendar - if this entity attribute is set to 1, an item will be added to the calendar automatically for new contact log records that have a Next Contact Date filled inAddToTasks - if this entity attribute is set to 1, an item will be added to the tasks list(in the messaging system such as Outlook) automatically for new contact log records that have a Next Contact Date filled in

public override bool Save(
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

Parameters

AllowGUI
ErrorString
TransactionID

Return Value

Remarks

See Also

ContactLog Class | Aptify.Applications.ContactManagement Namespace | ContactLog.Save Overload List


Validate Method

Aptify 5.0 Software Development Kit (SDK)

ContactLog.Validate Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Validate();

public override bool Validate(ref String&);

See Also

ContactLog Class | Aptify.Applications.ContactManagement Namespace


ContactLog.Validate Method (String&)

public override bool Validate(
ref String& ErrorString
);

See Also

ContactLog Class | Aptify.Applications.ContactManagement Namespace | ContactLog.Validate Overload List


OutlookContactLogImport Class

Provides functionality to imports Contact Log records into Aptify from Microsoft Outlook emails. This is a non-visual class that can be used from wizards as well as Process Components.

For a list of all members of this type, see OutlookContactLogImport Members.

System.Object
OutlookSynchronizationGlobal
OutlookContactLogImport

public class OutlookContactLogImport : OutlookSynchronizationGlobal, IProcessComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.ContactManagement

Assembly: AptifyOutlookContactLogImport (in AptifyOutlookContactLogImport.dll)

See Also

OutlookContactLogImport Members | Aptify.Applications.ContactManagement Namespace


OutlookContactLogImport Members

OutlookContactLogImport overview

Public Instance Constructors

OutlookContactLogImport Constructor Initializes a new instance of the OutlookContactLogImport class.

Public Instance Properties

Application
CompaniesEntityID
DataAction
EmployeesEntityID
OrganizationsEntityID
PersonsEntityID
Properties

Public Instance Methods

Config |
ConvertOutlookItemsToGeneric | This method will convert an Outlook Items collection into a .NET Generics based List
DoImport | Overloaded. This method will import all of the items in the specified folder in the MailFolderPath parameter and will ignore previously imported mail items and not import those, unless the IgnorePreviouslyImportedItems parameter is set to False, in which case, all items will be imported into new Contact Log records.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCurrentEmployeeID | Returns the ID of the Employees Entity record that is associated with the currently logged in user. This method uses the spGetCurrentEmployeeID stored procedure in the base class implementation
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetMailItems | Overloaded. This method will return a list of outlook Mail Items from the specified folder.
GetType (inherited from Object) | Gets the Type of the current instance.
Run | This process component Run method supports the following properties that are set via the Properties attribute of this class ContactLogTypeID - Long - Required - Contact Log Types Record IDContactLogCategoryID - Long - Required - Contact Log Categories Record IDMailFolderPath - String - Optional - Defaults to "Inbox" - Either "Inbox" or the fully qualified path name to the Outlook Folder containing mail items.StartDate - DateTime - Optional - Start Date Filter - if blank, no start date filter will be appliedEndDate - DateTime - Optional - End Date Filter - if blank, no end date filter will be appliedIgnorePreviouslyImportedItems - Integer - Optional - Defaults to 1, Valid Values are 0 or 1. If set to 0, previously imported items will be imported again, if set to default value of 1, previously imported items will be ignored.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

ItemError | This event is raised from the DoImport() method whenever an item is not imported succesfully.
ItemImported | This event is raised from the DoImport() method whenever an item is succesfully imported
StatusUpdate | This event is raised whenever an item is processed and provides status information about the process as well as the ability to cancel the process by setting the Cancel parameter to True.

Protected Instance Methods

AddLink | This method is responsible for adding a link to the contact log record in the ContactLogLinks sub-type. The method attempts to create a link to either a person or an employee. If the message is from an Employee, a link is created to the employee only. If the message is from an outside Person, a link is created to the Person record as well as the Company record that the person is linked to (if the Person has a CompanyID field filled in).
AddLinkRecord | This method is responsible for adding a specified link to the contact log ContactLogLinks sub-type. The default behavior of the AllowDuplicates parameter is not specified is to NOT allow duplicate links to be created. If AllowDuplicates is set to True, then duplicates are allowed to be in the ContactLogLinks sub-type.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
KillFile | Attempts to delete a file and returns true if the file was deleted
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseItemError | This method is responsible for raising the ItemError event
RaiseItemImported | This method is responsible for raising the ItemImported event
RaiseStatusUpdate | This method is responsible for raising the StatusUpdate event

See Also

OutlookContactLogImport Class | Aptify.Applications.ContactManagement Namespace


OutlookContactLogImport Constructor

Initializes a new instance of the OutlookContactLogImport class.

public OutlookContactLogImport();

See Also

OutlookContactLogImport Class | Aptify.Applications.ContactManagement Namespace


OutlookContactLogImport Properties

The properties of the OutlookContactLogImport class are listed below. For a complete list of OutlookContactLogImport class members, see the OutlookContactLogImport Members topic.

Public Instance Properties

Application
CompaniesEntityID
DataAction
EmployeesEntityID
OrganizationsEntityID
PersonsEntityID
Properties

See Also

OutlookContactLogImport Class | Aptify.Applications.ContactManagement Namespace


Application Property

Aptify 5.0 Software Development Kit (SDK)

OutlookContactLogImport.Application Property

public virtual AptifyApplication Application {get;}

See Also

OutlookContactLogImport Class | Aptify.Applications.ContactManagement Namespace


CompaniesEntityID Property

Aptify 5.0 Software Development Kit (SDK)

OutlookContactLogImport.CompaniesEntityID Property

public virtual Int64 CompaniesEntityID {get;}

See Also

OutlookContactLogImport Class | Aptify.Applications.ContactManagement Namespace


DataAction Property

Aptify 5.0 Software Development Kit (SDK)

OutlookContactLogImport.DataAction Property

public virtual DataAction DataAction {get;}

See Also

OutlookContactLogImport Class | Aptify.Applications.ContactManagement Namespace


EmployeesEntityID Property

Aptify 5.0 Software Development Kit (SDK)

OutlookContactLogImport.EmployeesEntityID Property

public virtual Int64 EmployeesEntityID {get;}

See Also

OutlookContactLogImport Class | Aptify.Applications.ContactManagement Namespace


OrganizationsEntityID Property

Aptify 5.0 Software Development Kit (SDK)

OutlookContactLogImport.OrganizationsEntityID Property

public virtual Int64 OrganizationsEntityID {get;}

See Also

OutlookContactLogImport Class | Aptify.Applications.ContactManagement Namespace


PersonsEntityID Property

Aptify 5.0 Software Development Kit (SDK)

OutlookContactLogImport.PersonsEntityID Property

public virtual Int64 PersonsEntityID {get;}

See Also

OutlookContactLogImport Class | Aptify.Applications.ContactManagement Namespace


Properties Property

Aptify 5.0 Software Development Kit (SDK)

OutlookContactLogImport.Properties Property

public virtual AptifyProperties Properties {get;}

Implements

IProcessComponent.

See Also

OutlookContactLogImport Class | Aptify.Applications.ContactManagement Namespace


OutlookContactLogImport Methods

The methods of the OutlookContactLogImport class are listed below. For a complete list of OutlookContactLogImport class members, see the OutlookContactLogImport Members topic.

Public Instance Methods

Config |
ConvertOutlookItemsToGeneric | This method will convert an Outlook Items collection into a .NET Generics based List
DoImport | Overloaded. This method will import all of the items in the specified folder in the MailFolderPath parameter and will ignore previously imported mail items and not import those, unless the IgnorePreviouslyImportedItems parameter is set to False, in which case, all items will be imported into new Contact Log records.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCurrentEmployeeID | Returns the ID of the Employees Entity record that is associated with the currently logged in user. This method uses the spGetCurrentEmployeeID stored procedure in the base class implementation
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetMailItems | Overloaded. This method will return a list of outlook Mail Items from the specified folder.
GetType (inherited from Object) | Gets the Type of the current instance.
Run | This process component Run method supports the following properties that are set via the Properties attribute of this class ContactLogTypeID - Long - Required - Contact Log Types Record IDContactLogCategoryID - Long - Required - Contact Log Categories Record IDMailFolderPath - String - Optional - Defaults to "Inbox" - Either "Inbox" or the fully qualified path name to the Outlook Folder containing mail items.StartDate - DateTime - Optional - Start Date Filter - if blank, no start date filter will be appliedEndDate - DateTime - Optional - End Date Filter - if blank, no end date filter will be appliedIgnorePreviouslyImportedItems - Integer - Optional - Defaults to 1, Valid Values are 0 or 1. If set to 0, previously imported items will be imported again, if set to default value of 1, previously imported items will be ignored.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

AddLink | This method is responsible for adding a link to the contact log record in the ContactLogLinks sub-type. The method attempts to create a link to either a person or an employee. If the message is from an Employee, a link is created to the employee only. If the message is from an outside Person, a link is created to the Person record as well as the Company record that the person is linked to (if the Person has a CompanyID field filled in).
AddLinkRecord | This method is responsible for adding a specified link to the contact log ContactLogLinks sub-type. The default behavior of the AllowDuplicates parameter is not specified is to NOT allow duplicate links to be created. If AllowDuplicates is set to True, then duplicates are allowed to be in the ContactLogLinks sub-type.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
KillFile | Attempts to delete a file and returns true if the file was deleted
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseItemError | This method is responsible for raising the ItemError event
RaiseItemImported | This method is responsible for raising the ItemImported event
RaiseStatusUpdate | This method is responsible for raising the StatusUpdate event

See Also

OutlookContactLogImport Class | Aptify.Applications.ContactManagement Namespace


OutlookContactLogImport.AddLink Method

This method is responsible for adding a link to the contact log record in the ContactLogLinks sub-type. The method attempts to create a link to either a person or an employee. If the message is from an Employee, a link is created to the employee only. If the message is from an outside Person, a link is created to the Person record as well as the Company record that the person is linked to (if the Person has a CompanyID field filled in).

protected virtual bool AddLink(
String EmailAddress,
String AlternateAddress,
AptifyGenericEntityBase ContactLogGE
);

Return Value

Remarks

See Also

OutlookContactLogImport Class | Aptify.Applications.ContactManagement Namespace


OutlookContactLogImport.AddLinkRecord Method

This method is responsible for adding a specified link to the contact log ContactLogLinks sub-type. The default behavior of the AllowDuplicates parameter is not specified is to NOT allow duplicate links to be created. If AllowDuplicates is set to True, then duplicates are allowed to be in the ContactLogLinks sub-type.

protected virtual void AddLinkRecord(
AptifyGenericEntityBase ContactLogGE,
Int64 EntityID,
Int64 RecordID,
Boolean AllowDuplicates
);

Parameters

ContactLogGE
EntityID
RecordID
AllowDuplicates

Remarks

See Also

OutlookContactLogImport Class | Aptify.Applications.ContactManagement Namespace


OutlookContactLogImport.Config Method

public virtual void Config(
AptifyApplication ApplicationObject
);

Implements

IProcessComponent.

See Also

OutlookContactLogImport Class | Aptify.Applications.ContactManagement Namespace


OutlookContactLogImport.ConvertOutlookItemsToGeneric Method

This method will convert an Outlook Items collection into a .NET Generics based List

public virtual List<T> ConvertOutlookItemsToGeneric(
Items OutlookItems
);

Parameters

OutlookItems

Return Value

Remarks

See Also

OutlookContactLogImport Class | Aptify.Applications.ContactManagement Namespace


DoImport Method

Aptify 5.0 Software Development Kit (SDK)

OutlookContactLogImport.DoImport Method

This method will import all of the items in the specified folder in the MailFolder parameter and will ignore previously imported mail items and not import those, unless the IgnorePreviouslyImportedItems parameter is set to False, in which case, all items will be imported into new Contact Log records.

Overload List

This method will import all of the items in the specified folder in the MailFolder parameter and will ignore previously imported mail items and not import those, unless the IgnorePreviouslyImportedItems parameter is set to False, in which case, all items will be imported into new Contact Log records.

public virtual bool DoImport(Int64,Int64,MAPIFolder,Boolean);

This method will import all of the items in the specified folder in the MailFolder parameter and will ignore previously imported mail items and not import those, unless the IgnorePreviouslyImportedItems parameter is set to False, in which case, all items will be imported into new Contact Log records.

public virtual bool DoImport(Int64,Int64,MAPIFolder,DateTime,DateTime,Boolean);

This method handles the process of importing records from the Outlook Mail Items list into the database as Contact Log records.

public virtual bool DoImport(Int64,Int64,List<T>);

This method will import all of the items in the specified folder in the MailFolderPath parameter and will ignore previously imported mail items and not import those, unless the IgnorePreviouslyImportedItems parameter is set to False, in which case, all items will be imported into new Contact Log records.

public virtual bool DoImport(Int64,Int64,String,Boolean);

This method will import all of the items in the specified folder in the MailFolderPath parameter and will ignore previously imported mail items and not import those, unless the IgnorePreviouslyImportedItems parameter is set to False, in which case, all items will be imported into new Contact Log records.

public virtual bool DoImport(Int64,Int64,String,DateTime,DateTime,Boolean);

See Also

OutlookContactLogImport Class | Aptify.Applications.ContactManagement Namespace


OutlookContactLogImport.DoImport Method (Int64, Int64, MAPIFolder, Boolean)

This method will import all of the items in the specified folder in the MailFolder parameter and will ignore previously imported mail items and not import those, unless the IgnorePreviouslyImportedItems parameter is set to False, in which case, all items will be imported into new Contact Log records.

public virtual bool DoImport(
Int64 ContactLogTypeID,
Int64 ContactLogCategoryID,
MAPIFolder MailFolder,
Boolean IgnorePreviouslyImportedItems
);

Parameters

ContactLogTypeID
ContactLogCategoryID
MailFolder
IgnorePreviouslyImportedItems

Return Value

Remarks

See Also

OutlookContactLogImport Class | Aptify.Applications.ContactManagement Namespace | OutlookContactLogImport.DoImport Overload List


OutlookContactLogImport.DoImport Method (Int64, Int64, MAPIFolder, DateTime, DateTime, Boolean)

This method will import all of the items in the specified folder in the MailFolder parameter and will ignore previously imported mail items and not import those, unless the IgnorePreviouslyImportedItems parameter is set to False, in which case, all items will be imported into new Contact Log records.

public virtual bool DoImport(
Int64 ContactLogTypeID,
Int64 ContactLogCategoryID,
MAPIFolder MailFolder,
DateTime StartDate,
DateTime EndDate,
Boolean IgnorePreviouslyImportedItems
);

Parameters

ContactLogTypeID
ContactLogCategoryID
MailFolder
StartDate
This parameter applies a filter to the Date of the Mail Item. Set to 1/1/1900 if only want to set an end date
EndDate
This parameter applies a filter to the Date of the Mail Item. Set to 1/1/1900 if only want to set a start date
IgnorePreviouslyImportedItems

Return Value

Remarks

See Also

OutlookContactLogImport Class | Aptify.Applications.ContactManagement Namespace | OutlookContactLogImport.DoImport Overload List


OutlookContactLogImport.DoImport Method (Int64, Int64, List<T>)

This method handles the process of importing records from the Outlook Mail Items list into the database as Contact Log records.

public virtual bool DoImport(
Int64 ContactLogTypeID,
Int64 ContactLogCategoryID,
List<T> MailItems
);

Parameters

ContactLogTypeID
ContactLogCategoryID
MailItems

Return Value

Remarks

See Also

OutlookContactLogImport Class | Aptify.Applications.ContactManagement Namespace | OutlookContactLogImport.DoImport Overload List


OutlookContactLogImport.DoImport Method (Int64, Int64, String, Boolean)

This method will import all of the items in the specified folder in the MailFolderPath parameter and will ignore previously imported mail items and not import those, unless the IgnorePreviouslyImportedItems parameter is set to False, in which case, all items will be imported into new Contact Log records.

public virtual bool DoImport(
Int64 ContactLogTypeID,
Int64 ContactLogCategoryID,
String MailFolderPath,
Boolean IgnorePreviouslyImportedItems
);

Parameters

ContactLogTypeID
ContactLogCategoryID
MailFolderPath
IgnorePreviouslyImportedItems

Return Value

Remarks

See Also

OutlookContactLogImport Class | Aptify.Applications.ContactManagement Namespace | OutlookContactLogImport.DoImport Overload List


OutlookContactLogImport.DoImport Method (Int64, Int64, String, DateTime, DateTime, Boolean)

This method will import all of the items in the specified folder in the MailFolderPath parameter and will ignore previously imported mail items and not import those, unless the IgnorePreviouslyImportedItems parameter is set to False, in which case, all items will be imported into new Contact Log records.

public virtual bool DoImport(
Int64 ContactLogTypeID,
Int64 ContactLogCategoryID,
String MailFolderPath,
DateTime StartDate,
DateTime EndDate,
Boolean IgnorePreviouslyImportedItems
);

Parameters

ContactLogTypeID
ContactLogCategoryID
MailFolderPath
StartDate
This parameter applies a filter to the Date of the Mail Item. Set to 1/1/1900 if only want to set an end date
EndDate
This parameter applies a filter to the Date of the Mail Item. Set to 1/1/1900 if only want to set a start date
IgnorePreviouslyImportedItems

Return Value

Remarks

See Also

OutlookContactLogImport Class | Aptify.Applications.ContactManagement Namespace | OutlookContactLogImport.DoImport Overload List


OutlookContactLogImport.GetCurrentEmployeeID Method

Returns the ID of the Employees Entity record that is associated with the currently logged in user. This method uses the spGetCurrentEmployeeID stored procedure in the base class implementation

public virtual long GetCurrentEmployeeID();

Return Value

Remarks

See Also

OutlookContactLogImport Class | Aptify.Applications.ContactManagement Namespace


GetMailItems Method

Aptify 5.0 Software Development Kit (SDK)

OutlookContactLogImport.GetMailItems Method

This method will return a list of outlook Mail Items from the specified folder.

Overload List

This method will return a list of outlook Mail Items from the specified folder.

public virtual Items GetMailItems(MAPIFolder,Boolean);

This method will return a list of outlook Mail Items from the specified folder.

public virtual Items GetMailItems(MAPIFolder,DateTime,DateTime,Boolean);

This method will return a list of outlook Mail Items from the specified folder path.

public virtual Items GetMailItems(String,Boolean);

This method will return a list of outlook Mail Items from the specified folder path.

public virtual Items GetMailItems(String,DateTime,DateTime,Boolean);

See Also

OutlookContactLogImport Class | Aptify.Applications.ContactManagement Namespace


OutlookContactLogImport.GetMailItems Method (MAPIFolder, Boolean)

This method will return a list of outlook Mail Items from the specified folder.

public virtual Items GetMailItems(
MAPIFolder MailFolder,
Boolean IgnorePreviouslyImportedItems
);

Parameters

MailFolder
IgnorePreviouslyImportedItems
If set to True, only those items that have not previously been imported will be included in the returned list, otherwise, all items in the folder will be returned

Return Value

Remarks

See Also

OutlookContactLogImport Class | Aptify.Applications.ContactManagement Namespace | OutlookContactLogImport.GetMailItems Overload List


OutlookContactLogImport.GetMailItems Method (MAPIFolder, DateTime, DateTime, Boolean)

This method will return a list of outlook Mail Items from the specified folder.

public virtual Items GetMailItems(
MAPIFolder MailFolder,
DateTime StartDate,
DateTime EndDate,
Boolean IgnorePreviouslyImportedItems
);

Parameters

MailFolder
StartDate
This parameter applies a filter to the Date of the Mail Item. Set to 1/1/1900 if only want to set an end date
EndDate
This parameter applies a filter to the Date of the Mail Item. Set to 1/1/1900 if only want to set a start date
IgnorePreviouslyImportedItems
If set to True, only those items that have not previously been imported will be included in the returned list, otherwise, all items in the folder will be returned

Return Value

Remarks

See Also

OutlookContactLogImport Class | Aptify.Applications.ContactManagement Namespace | OutlookContactLogImport.GetMailItems Overload List


OutlookContactLogImport.GetMailItems Method (String, Boolean)

This method will return a list of outlook Mail Items from the specified folder path.

public virtual Items GetMailItems(
String MailFolderPath,
Boolean IgnorePreviouslyImportedItems
);

Parameters

MailFolderPath
IgnorePreviouslyImportedItems
If set to True, only those items that have not previously been imported will be included in the returned list, otherwise, all items in the folder will be returned

Return Value

Remarks

See Also

OutlookContactLogImport Class | Aptify.Applications.ContactManagement Namespace | OutlookContactLogImport.GetMailItems Overload List


OutlookContactLogImport.GetMailItems Method (String, DateTime, DateTime, Boolean)

This method will return a list of outlook Mail Items from the specified folder path.

public virtual Items GetMailItems(
String MailFolderPath,
DateTime StartDate,
DateTime EndDate,
Boolean IgnorePreviouslyImportedItems
);

Parameters

MailFolderPath
StartDate
This parameter applies a filter to the Date of the Mail Item. Set to 1/1/1900 if only want to set an end date
EndDate
This parameter applies a filter to the Date of the Mail Item. Set to 1/1/1900 if only want to set a start date
IgnorePreviouslyImportedItems
If set to True, only those items that have not previously been imported will be included in the returned list, otherwise, all items in the folder will be returned

Return Value

Remarks

See Also

OutlookContactLogImport Class | Aptify.Applications.ContactManagement Namespace | OutlookContactLogImport.GetMailItems Overload List


OutlookContactLogImport.KillFile Method

Attempts to delete a file and returns true if the file was deleted

protected virtual bool KillFile(
String FileName,
String ErrorMessage
);

Parameters

FileName
Fully qualified path name
ErrorMessage
If the method fails, this string will contain the message from the File IO exception

Remarks

See Also

OutlookContactLogImport Class | Aptify.Applications.ContactManagement Namespace


OutlookContactLogImport.RaiseItemError Method

This method is responsible for raising the ItemError event

protected virtual void RaiseItemError(
String ItemName,
String ErrorMessage
);

Parameters

ItemName
ErrorMessage

Remarks

See Also

OutlookContactLogImport Class | Aptify.Applications.ContactManagement Namespace


OutlookContactLogImport.RaiseItemImported Method

This method is responsible for raising the ItemImported event

protected virtual void RaiseItemImported(
Int64 ContactLogID,
DateTime ContactLogDate,
String Description,
String Details
);

Parameters

ContactLogID
ContactLogDate
Description
Details

Remarks

See Also

OutlookContactLogImport Class | Aptify.Applications.ContactManagement Namespace


OutlookContactLogImport.RaiseStatusUpdate Method

This method is responsible for raising the StatusUpdate event

protected virtual void RaiseStatusUpdate(
Int32 CurrentItem,
Int32 TotalItems,
ref Boolean& Cancel
);

Parameters

CurrentItem
TotalItems
Cancel

Remarks

See Also

OutlookContactLogImport Class | Aptify.Applications.ContactManagement Namespace


OutlookContactLogImport.Run Method

This process component Run method supports the following properties that are set via the Properties attribute of this class ContactLogTypeID - Long - Required - Contact Log Types Record IDContactLogCategoryID - Long - Required - Contact Log Categories Record IDMailFolderPath - String - Optional - Defaults to "Inbox" - Either "Inbox" or the fully qualified path name to the Outlook Folder containing mail items.StartDate - DateTime - Optional - Start Date Filter - if blank, no start date filter will be appliedEndDate - DateTime - Optional - End Date Filter - if blank, no end date filter will be appliedIgnorePreviouslyImportedItems - Integer - Optional - Defaults to 1, Valid Values are 0 or 1. If set to 0, previously imported items will be imported again, if set to default value of 1, previously imported items will be ignored.

public virtual string Run();

Return Value

Result Codes for this process componont are SUCCESS and FAILED

Implements

IProcessComponent.

Remarks

See Also

OutlookContactLogImport Class | Aptify.Applications.ContactManagement Namespace


OutlookContactLogImport Events

The events of the OutlookContactLogImport class are listed below. For a complete list of OutlookContactLogImport class members, see the OutlookContactLogImport Members topic.

Public Instance Events

ItemError | This event is raised from the DoImport() method whenever an item is not imported succesfully.
ItemImported | This event is raised from the DoImport() method whenever an item is succesfully imported
StatusUpdate | This event is raised whenever an item is processed and provides status information about the process as well as the ability to cancel the process by setting the Cancel parameter to True.

See Also

OutlookContactLogImport Class | Aptify.Applications.ContactManagement Namespace


OutlookContactLogImport.OutlookContactLogImport.ItemErrorEventHandler Event

This event is raised from the DoImport() method whenever an item is not imported succesfully.

public event OutlookContactLogImport.ItemErrorEventHandler ItemError;

Remarks

See Also

OutlookContactLogImport Class | Aptify.Applications.ContactManagement Namespace


OutlookContactLogImport.OutlookContactLogImport.ItemImportedEventHandler Event

This event is raised from the DoImport() method whenever an item is succesfully imported

public event OutlookContactLogImport.ItemImportedEventHandler ItemImported;

Remarks

See Also

OutlookContactLogImport Class | Aptify.Applications.ContactManagement Namespace


OutlookContactLogImport.OutlookContactLogImport.StatusUpdateEventHandler Event

This event is raised whenever an item is processed and provides status information about the process as well as the ability to cancel the process by setting the Cancel parameter to True.

public event OutlookContactLogImport.StatusUpdateEventHandler StatusUpdate;

Remarks

See Also

OutlookContactLogImport Class | Aptify.Applications.ContactManagement Namespace


OutlookContactLogImport.ItemErrorEventHandler Delegate

public delegate void OutlookContactLogImport.ItemErrorEventHandler(
String ItemName,
String ErrorMessage
);

Requirements

Namespace: Aptify.Applications.ContactManagement

Assembly: AptifyOutlookContactLogImport (in AptifyOutlookContactLogImport.dll)

See Also

Aptify.Applications.ContactManagement Namespace


OutlookContactLogImport.ItemImportedEventHandler Delegate

public delegate void OutlookContactLogImport.ItemImportedEventHandler(
Int64 ContactLogID,
DateTime ContactLogDate,
String Description,
String Details
);

Requirements

Namespace: Aptify.Applications.ContactManagement

Assembly: AptifyOutlookContactLogImport (in AptifyOutlookContactLogImport.dll)

See Also

Aptify.Applications.ContactManagement Namespace


OutlookContactLogImport.StatusUpdateEventHandler Delegate

public delegate void OutlookContactLogImport.StatusUpdateEventHandler(
Int32 CurrentItem,
Int32 TotalItems,
ref Boolean& Cancel
);

Requirements

Namespace: Aptify.Applications.ContactManagement

Assembly: AptifyOutlookContactLogImport (in AptifyOutlookContactLogImport.dll)

See Also

Aptify.Applications.ContactManagement Namespace


OutlookContactLogImportWizard Class

Aptify Outlook Contact Log Import Wizard - uses the OutlookContactLogImport class to import Outlook email into the Aptify Contact Log.

For a list of all members of this type, see OutlookContactLogImportWizard Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
OutlookContactLogImportWizard

public class OutlookContactLogImportWizard : Form, IAptifyAction

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.ContactManagement

Assembly: AptifyOutlookContactLogWizard (in AptifyOutlookContactLogWizard.dll)

See Also

OutlookContactLogImportWizard Members | Aptify.Applications.ContactManagement Namespace


OutlookContactLogImportWizard Members

OutlookContactLogImportWizard overview

Public Instance Constructors

OutlookContactLogImportWizard Constructor Initializes a new instance of the OutlookContactLogImportWizard class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoAction | Overloaded.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

OutlookContactLogImportWizard Class | Aptify.Applications.ContactManagement Namespace


OutlookContactLogImportWizard Constructor

Initializes a new instance of the OutlookContactLogImportWizard class.

public OutlookContactLogImportWizard();

See Also

OutlookContactLogImportWizard Class | Aptify.Applications.ContactManagement Namespace


OutlookContactLogImportWizard Methods

The methods of the OutlookContactLogImportWizard class are listed below. For a complete list of OutlookContactLogImportWizard class members, see the OutlookContactLogImportWizard Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoAction | Overloaded.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

OutlookContactLogImportWizard Class | Aptify.Applications.ContactManagement Namespace


OutlookContactLogImportWizard.Config Method

public bool Config(
AptifyApplication Application,
Int64 EntityID,
Int64 ViewID,
params Object[] SelectedItems
);

See Also

OutlookContactLogImportWizard Class | Aptify.Applications.ContactManagement Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

OutlookContactLogImportWizard.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

OutlookContactLogImportWizard Class | Aptify.Applications.ContactManagement Namespace


OutlookContactLogImportWizard.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

OutlookContactLogImportWizard Class | Aptify.Applications.ContactManagement Namespace | OutlookContactLogImportWizard.Dispose Overload List


DoAction Method

Aptify 5.0 Software Development Kit (SDK)

OutlookContactLogImportWizard.DoAction Method

Overload List

public void DoAction(AptifyApplication,Int64);

public void DoAction(AptifyApplication,Int64,Int64);

public void DoAction(AptifyApplication,Int64,Int64,params Object[]);

public void DoAction(AptifyApplication,Int64,params String[]);

See Also

OutlookContactLogImportWizard Class | Aptify.Applications.ContactManagement Namespace


OutlookContactLogImportWizard.DoAction Method (AptifyApplication, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID
);

Implements

IAptifyAction.

See Also

OutlookContactLogImportWizard Class | Aptify.Applications.ContactManagement Namespace | OutlookContactLogImportWizard.DoAction Overload List


OutlookContactLogImportWizard.DoAction Method (AptifyApplication, Int64, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID
);

Implements

IAptifyAction.

See Also

OutlookContactLogImportWizard Class | Aptify.Applications.ContactManagement Namespace | OutlookContactLogImportWizard.DoAction Overload List


OutlookContactLogImportWizard.DoAction Method (AptifyApplication, Int64, Int64, Object[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID,
params Object[] SelectedItems
);

Implements

IAptifyAction.

See Also

OutlookContactLogImportWizard Class | Aptify.Applications.ContactManagement Namespace | OutlookContactLogImportWizard.DoAction Overload List


OutlookContactLogImportWizard.DoAction Method (AptifyApplication, Int64, String[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
params String[] SelectedItems
);

Implements

IAptifyAction.

See Also

OutlookContactLogImportWizard Class | Aptify.Applications.ContactManagement Namespace | OutlookContactLogImportWizard.DoAction Overload List


Aptify.Applications.ContactManagement.WindowsControls

Aptify 5.0 Software Development Kit (SDK)

Aptify.Applications.ContactManagement.WindowsControls Namespace

This namespace corresponds to the presentation layer logic used to display Contact Log record data.

Namespace hierarchy

Classes

Class | Description
ContactLogLayout | Provides presentation layer logic used for Contact Log Entity Top-Level records


ContactLogLayout Class

Provides presentation layer logic used for Contact Log Entity Top-Level records

For a list of all members of this type, see ContactLogLayout Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
ContactLogLayout

public class ContactLogLayout : FormTemplateLayout

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.ContactManagement.WindowsControls

Assembly: ContactLogLayoutControls (in ContactLogLayoutControls.dll)

See Also

ContactLogLayout Members | Aptify.Applications.ContactManagement.WindowsControls Namespace


ContactLogLayout Members

ContactLogLayout overview

Public Instance Constructors

ContactLogLayout Constructor Initializes a new instance of the ContactLogLayout class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
m_ctlContactDate |
m_ctlCreateFollowup |
m_ctlNextContactDate |
m_ctlNextContactReason |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
BindControl | Overloaded. This method handles binding a control reference to a specific field name using the GetFormComponent() method of the base class. The method only attempts to bind the control reference if the control reference is Nothing or its inner control is disposed.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormTemplateLayout) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControls | This method handles binding the controls to their internal protected members.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
LinkExists | This method will determine if the specified EntityID/RecordID pair exists in the ContactLogLinks sub-type of the provided ContactLogGE instance.
LoadParams | This method is called whenever a form template is loaded and is responsible for handling any specialized loading process for form parameters. The default implementation of this method in the ContactLogLayout class parses the parameters and determines if any links have been requested for a new record and if any are found in the parameter list, they are added to the ContactLogLinks sub-type.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
On_CreateFollowup_Click | This method handles the click event for the Create Follow-Up button. The default behavior is to create a new contact log form that is linked back to the current record.
On_NextContactDate_ValueChanged | This method handles the ValueChanged event for the NextContactDate control and by default, calls the SetFollowUpEnabled() method.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded | Contains logic to setup Event handlers for controls on the FormTemplate Layout.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDate | This method is called when the form template loads and is responsible for setting the date field as per the recordID.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetFollowUpEnabled | This method is called when the form template loads and is responsible for setting the enabled attribute of the Create Follow-Up button, which is only enabled if the record has been saved.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ContactLogLayout Class | Aptify.Applications.ContactManagement.WindowsControls Namespace


ContactLogLayout Constructor

Initializes a new instance of the ContactLogLayout class.

public ContactLogLayout();

See Also

ContactLogLayout Class | Aptify.Applications.ContactManagement.WindowsControls Namespace


ContactLogLayout Properties

The properties of the ContactLogLayout class are listed below. For a complete list of ContactLogLayout class members, see the ContactLogLayout Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
m_ctlContactDate |
m_ctlCreateFollowup |
m_ctlNextContactDate |
m_ctlNextContactReason |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

ContactLogLayout Class | Aptify.Applications.ContactManagement.WindowsControls Namespace


m_ctlContactDate Property

Aptify 5.0 Software Development Kit (SDK)

ContactLogLayout.m_ctlContactDate Property

protected virtual IAptifyDataFieldControlBase m_ctlContactDate {get; set;}

See Also

ContactLogLayout Class | Aptify.Applications.ContactManagement.WindowsControls Namespace


m_ctlCreateFollowup Property

Aptify 5.0 Software Development Kit (SDK)

ContactLogLayout.m_ctlCreateFollowup Property

protected virtual IFormComponent m_ctlCreateFollowup {get; set;}

See Also

ContactLogLayout Class | Aptify.Applications.ContactManagement.WindowsControls Namespace


m_ctlNextContactDate Property

Aptify 5.0 Software Development Kit (SDK)

ContactLogLayout.m_ctlNextContactDate Property

protected virtual IAptifyDataFieldControlBase m_ctlNextContactDate {get; set;}

See Also

ContactLogLayout Class | Aptify.Applications.ContactManagement.WindowsControls Namespace


m_ctlNextContactReason Property

Aptify 5.0 Software Development Kit (SDK)

ContactLogLayout.m_ctlNextContactReason Property

protected virtual IAptifyDataFieldControlBase m_ctlNextContactReason {get; set;}

See Also

ContactLogLayout Class | Aptify.Applications.ContactManagement.WindowsControls Namespace


ContactLogLayout Methods

The methods of the ContactLogLayout class are listed below. For a complete list of ContactLogLayout class members, see the ContactLogLayout Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
BindControl | Overloaded. This method handles binding a control reference to a specific field name using the GetFormComponent() method of the base class. The method only attempts to bind the control reference if the control reference is Nothing or its inner control is disposed.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormTemplateLayout) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControls | This method handles binding the controls to their internal protected members.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
LinkExists | This method will determine if the specified EntityID/RecordID pair exists in the ContactLogLinks sub-type of the provided ContactLogGE instance.
LoadParams | This method is called whenever a form template is loaded and is responsible for handling any specialized loading process for form parameters. The default implementation of this method in the ContactLogLayout class parses the parameters and determines if any links have been requested for a new record and if any are found in the parameter list, they are added to the ContactLogLinks sub-type.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
On_CreateFollowup_Click | This method handles the click event for the Create Follow-Up button. The default behavior is to create a new contact log form that is linked back to the current record.
On_NextContactDate_ValueChanged | This method handles the ValueChanged event for the NextContactDate control and by default, calls the SetFollowUpEnabled() method.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded | Contains logic to setup Event handlers for controls on the FormTemplate Layout.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDate | This method is called when the form template loads and is responsible for setting the date field as per the recordID.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetFollowUpEnabled | This method is called when the form template loads and is responsible for setting the enabled attribute of the Create Follow-Up button, which is only enabled if the record has been saved.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ContactLogLayout Class | Aptify.Applications.ContactManagement.WindowsControls Namespace


BindControl Method

Aptify 5.0 Software Development Kit (SDK)

ContactLogLayout.BindControl Method

This method handles binding a control reference to a specific field name using the GetFormComponent() method of the base class. The method only attempts to bind the control reference if the control reference is Nothing or its inner control is disposed.

Overload List

This method handles binding a control reference to a specific field name using the GetFormComponent() method of the base class. The method only attempts to bind the control reference if the control reference is Nothing or its inner control is disposed.

protected virtual void BindControl(ref IAptifyDataFieldControlBase&,String);

This method handles binding a control reference to a specific field name using the GetFormComponent() method of the base class. The method only attempts to bind the control reference if the control reference is Nothing or its inner control is disposed.

protected virtual void BindControl(ref IFormComponent&,String);

See Also

ContactLogLayout Class | Aptify.Applications.ContactManagement.WindowsControls Namespace


ContactLogLayout.BindControl Method (IAptifyDataFieldControlBase&, String)

This method handles binding a control reference to a specific field name using the GetFormComponent() method of the base class. The method only attempts to bind the control reference if the control reference is Nothing or its inner control is disposed.

protected virtual void BindControl(
ref IAptifyDataFieldControlBase& control,
String FieldName
);

Parameters

control
FieldName

Remarks

See Also

ContactLogLayout Class | Aptify.Applications.ContactManagement.WindowsControls Namespace | ContactLogLayout.BindControl Overload List


ContactLogLayout.BindControl Method (IFormComponent&, String)

This method handles binding a control reference to a specific field name using the GetFormComponent() method of the base class. The method only attempts to bind the control reference if the control reference is Nothing or its inner control is disposed.

protected virtual void BindControl(
ref IFormComponent& control,
String FieldName
);

Parameters

control
FieldName

Remarks

See Also

ContactLogLayout Class | Aptify.Applications.ContactManagement.WindowsControls Namespace | ContactLogLayout.BindControl Overload List


ContactLogLayout.FindControls Method

This method handles binding the controls to their internal protected members.

protected virtual void FindControls();

Remarks

See Also

ContactLogLayout Class | Aptify.Applications.ContactManagement.WindowsControls Namespace


ContactLogLayout.LinkExists Method

This method will determine if the specified EntityID/RecordID pair exists in the ContactLogLinks sub-type of the provided ContactLogGE instance.

protected virtual bool LinkExists(
AptifyGenericEntityBase ContactLogGE,
Int64 EntityID,
Int64 RecordID
);

Parameters

ContactLogGE
EntityID
RecordID

Return Value

Remarks

See Also

ContactLogLayout Class | Aptify.Applications.ContactManagement.WindowsControls Namespace


ContactLogLayout.LoadParams Method

This method is called whenever a form template is loaded and is responsible for handling any specialized loading process for form parameters. The default implementation of this method in the ContactLogLayout class parses the parameters and determines if any links have been requested for a new record and if any are found in the parameter list, they are added to the ContactLogLinks sub-type.

protected virtual void LoadParams();

Remarks

See Also

ContactLogLayout Class | Aptify.Applications.ContactManagement.WindowsControls Namespace


ContactLogLayout.On_CreateFollowup_Click Method

This method handles the click event for the Create Follow-Up button. The default behavior is to create a new contact log form that is linked back to the current record.

protected virtual void On_CreateFollowup_Click(
Object sender,
EventArgs e
);

Parameters

sender
e

Remarks

See Also

ContactLogLayout Class | Aptify.Applications.ContactManagement.WindowsControls Namespace


ContactLogLayout.On_NextContactDate_ValueChanged Method

This method handles the ValueChanged event for the NextContactDate control and by default, calls the SetFollowUpEnabled() method.

protected virtual void On_NextContactDate_ValueChanged(
Object sender,
Object OldValue,
Object NewValue
);

Parameters

sender
OldValue
NewValue

Remarks

See Also

ContactLogLayout Class | Aptify.Applications.ContactManagement.WindowsControls Namespace


ContactLogLayout.OnFormTemplateLoaded Method

Contains logic to setup Event handlers for controls on the FormTemplate Layout.

protected override void OnFormTemplateLoaded(
FormTemplateLayout.FormTemplateLoadedEventArgs e
);

Parameters

e

Remarks

See Also

ContactLogLayout Class | Aptify.Applications.ContactManagement.WindowsControls Namespace


ContactLogLayout.OnTransferDataToObject Method

protected override void OnTransferDataToObject(
ref Boolean& Cancel
);

Implements

IFormComponent.

See Also

ContactLogLayout Class | Aptify.Applications.ContactManagement.WindowsControls Namespace


ContactLogLayout.SetDate Method

This method is called when the form template loads and is responsible for setting the date field as per the recordID.

protected virtual void SetDate();

Remarks

See Also

ContactLogLayout Class | Aptify.Applications.ContactManagement.WindowsControls Namespace


ContactLogLayout.SetFollowUpEnabled Method

This method is called when the form template loads and is responsible for setting the enabled attribute of the Create Follow-Up button, which is only enabled if the record has been saved.

protected virtual void SetFollowUpEnabled();

Remarks

See Also

ContactLogLayout Class | Aptify.Applications.ContactManagement.WindowsControls Namespace


Aptify.Applications.CRM

Aptify 5.0 Software Development Kit (SDK)

Aptify.Applications.CRM Namespace

The objects in this namespace correspond to Aptify's Customer Relationship Management functionality, including the Preferred Address logic used to identify a Person's preferred contact information.

Namespace hierarchy

Classes

Class | Description
CompanyDupeCheck | Implements a sample set of logic for duplicate checking for the Companies entity
PersonDupeCheck | Implements a sample set of logic for duplicate checking for the Persons entity
PreferredAddress | Object that handles the logic associated with the preferred address and phone information selection for a person record

Enumerations

Enumeration | Description
PreferredAddress.PreferredAddressType |


CompanyDupeCheck Class

Implements a sample set of logic for duplicate checking for the Companies entity

For a list of all members of this type, see CompanyDupeCheck Members.

System.Object
CompanyDupeCheck

public class CompanyDupeCheck : IAptifyDuplicateCheck

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.CRM

Assembly: AptifyCompanyDupeCheck (in AptifyCompanyDupeCheck.dll)

See Also

CompanyDupeCheck Members | Aptify.Applications.CRM Namespace


CompanyDupeCheck Members

CompanyDupeCheck overview

Public Instance Constructors

CompanyDupeCheck Constructor Initializes a new instance of the CompanyDupeCheck class.

Public Instance Properties

DuplicateMessageObject

Public Instance Methods

CheckForDuplicates |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CompanyDupeCheck Class | Aptify.Applications.CRM Namespace


CompanyDupeCheck Constructor

Initializes a new instance of the CompanyDupeCheck class.

public CompanyDupeCheck();

See Also

CompanyDupeCheck Class | Aptify.Applications.CRM Namespace


CompanyDupeCheck Properties

The properties of the CompanyDupeCheck class are listed below. For a complete list of CompanyDupeCheck class members, see the CompanyDupeCheck Members topic.

Public Instance Properties

DuplicateMessageObject

See Also

CompanyDupeCheck Class | Aptify.Applications.CRM Namespace


DuplicateMessageObject Property

Aptify 5.0 Software Development Kit (SDK)

CompanyDupeCheck.DuplicateMessageObject Property

public IAptifyDuplicateMessage DuplicateMessageObject {get;}

Implements

IAptifyDuplicateCheck.

See Also

CompanyDupeCheck Class | Aptify.Applications.CRM Namespace


CompanyDupeCheck Methods

The methods of the CompanyDupeCheck class are listed below. For a complete list of CompanyDupeCheck class members, see the CompanyDupeCheck Members topic.

Public Instance Methods

CheckForDuplicates |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CompanyDupeCheck Class | Aptify.Applications.CRM Namespace


CompanyDupeCheck.CheckForDuplicates Method

public DuplicateCheckResult CheckForDuplicates(
AptifyGenericEntityBase GE,
ref Int64[]& DuplicateIDs
);

Implements

IAptifyDuplicateCheck.

See Also

CompanyDupeCheck Class | Aptify.Applications.CRM Namespace


PersonDupeCheck Class

Implements a sample set of logic for duplicate checking for the Persons entity

For a list of all members of this type, see PersonDupeCheck Members.

System.Object
PersonDupeCheck

public class PersonDupeCheck : IAptifyDuplicateCheck

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.CRM

Assembly: AptifyPersonDupeCheck (in AptifyPersonDupeCheck.dll)

See Also

PersonDupeCheck Members | Aptify.Applications.CRM Namespace


PersonDupeCheck Members

PersonDupeCheck overview

Public Instance Constructors

PersonDupeCheck Constructor Initializes a new instance of the PersonDupeCheck class.

Public Instance Properties

DuplicateMessageObject

Public Instance Methods

CheckForDuplicates |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PersonDupeCheck Class | Aptify.Applications.CRM Namespace


PersonDupeCheck Constructor

Initializes a new instance of the PersonDupeCheck class.

public PersonDupeCheck();

See Also

PersonDupeCheck Class | Aptify.Applications.CRM Namespace


PersonDupeCheck Properties

The properties of the PersonDupeCheck class are listed below. For a complete list of PersonDupeCheck class members, see the PersonDupeCheck Members topic.

Public Instance Properties

DuplicateMessageObject

See Also

PersonDupeCheck Class | Aptify.Applications.CRM Namespace


DuplicateMessageObject Property

Aptify 5.0 Software Development Kit (SDK)

PersonDupeCheck.DuplicateMessageObject Property

public IAptifyDuplicateMessage DuplicateMessageObject {get;}

Implements

IAptifyDuplicateCheck.

See Also

PersonDupeCheck Class | Aptify.Applications.CRM Namespace


PersonDupeCheck Methods

The methods of the PersonDupeCheck class are listed below. For a complete list of PersonDupeCheck class members, see the PersonDupeCheck Members topic.

Public Instance Methods

CheckForDuplicates |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PersonDupeCheck Class | Aptify.Applications.CRM Namespace


PersonDupeCheck.CheckForDuplicates Method

public DuplicateCheckResult CheckForDuplicates(
AptifyGenericEntityBase GE,
ref Int64[]& DuplicateIDs
);

Implements

IAptifyDuplicateCheck.

See Also

PersonDupeCheck Class | Aptify.Applications.CRM Namespace


PreferredAddress Class

Object that handles the logic associated with the preferred address and phone information selection for a person record

For a list of all members of this type, see PreferredAddress Members.

System.Object
PreferredAddress

public class PreferredAddress

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.CRM

Assembly: PreferredAddress (in PreferredAddress.dll)

See Also

PreferredAddress Members | Aptify.Applications.CRM Namespace


PreferredAddress Members

PreferredAddress overview

Public Instance Constructors

PreferredAddress Constructor Initializes a new instance of the PreferredAddress class.

Public Instance Properties

AddressInfo
PhoneAreaCode
PhoneCountryCode
PhoneExtension
PhoneID
PhoneNumber

Public Instance Methods

Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPreferredAddress | Overloaded.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Fields

m_oPhoneGE

Protected Instance Properties

DataAction

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetDateDrivenPreferred |
GetPhoneAttribute |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PreferredAddress Class | Aptify.Applications.CRM Namespace


PreferredAddress Constructor

Initializes a new instance of the PreferredAddress class.

public PreferredAddress();

See Also

PreferredAddress Class | Aptify.Applications.CRM Namespace


PreferredAddress Fields

The fields of the PreferredAddress class are listed below. For a complete list of PreferredAddress class members, see the PreferredAddress Members topic.

Protected Instance Fields

m_oPhoneGE

See Also

PreferredAddress Class | Aptify.Applications.CRM Namespace


PreferredAddress.m_oPhoneGE Field

protected m_oPhoneGE m_oPhoneGE;

See Also

PreferredAddress Class | Aptify.Applications.CRM Namespace


PreferredAddress Properties

The properties of the PreferredAddress class are listed below. For a complete list of PreferredAddress class members, see the PreferredAddress Members topic.

Public Instance Properties

AddressInfo
PhoneAreaCode
PhoneCountryCode
PhoneExtension
PhoneID
PhoneNumber

Protected Instance Properties

DataAction

See Also

PreferredAddress Class | Aptify.Applications.CRM Namespace


AddressInfo Property

Aptify 5.0 Software Development Kit (SDK)

PreferredAddress.AddressInfo Property

public AddressInfo AddressInfo {get;}

See Also

PreferredAddress Class | Aptify.Applications.CRM Namespace


DataAction Property

Aptify 5.0 Software Development Kit (SDK)

PreferredAddress.DataAction Property

protected DataAction DataAction {get;}

See Also

PreferredAddress Class | Aptify.Applications.CRM Namespace


PhoneAreaCode Property

Aptify 5.0 Software Development Kit (SDK)

PreferredAddress.PhoneAreaCode Property

public virtual String PhoneAreaCode {get;}

See Also

PreferredAddress Class | Aptify.Applications.CRM Namespace


PhoneCountryCode Property

Aptify 5.0 Software Development Kit (SDK)

PreferredAddress.PhoneCountryCode Property

public virtual String PhoneCountryCode {get;}

See Also

PreferredAddress Class | Aptify.Applications.CRM Namespace


PhoneExtension Property

Aptify 5.0 Software Development Kit (SDK)

PreferredAddress.PhoneExtension Property

public virtual String PhoneExtension {get;}

See Also

PreferredAddress Class | Aptify.Applications.CRM Namespace


PhoneID Property

Aptify 5.0 Software Development Kit (SDK)

PreferredAddress.PhoneID Property

public virtual Int64 PhoneID {get;}

See Also

PreferredAddress Class | Aptify.Applications.CRM Namespace


PhoneNumber Property

Aptify 5.0 Software Development Kit (SDK)

PreferredAddress.PhoneNumber Property

public virtual String PhoneNumber {get;}

See Also

PreferredAddress Class | Aptify.Applications.CRM Namespace


PreferredAddress Methods

The methods of the PreferredAddress class are listed below. For a complete list of PreferredAddress class members, see the PreferredAddress Members topic.

Public Instance Methods

Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPreferredAddress | Overloaded.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetDateDrivenPreferred |
GetPhoneAttribute |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PreferredAddress Class | Aptify.Applications.CRM Namespace


PreferredAddress.Config Method

public void Config(
AptifyApplication Application
);

See Also

PreferredAddress Class | Aptify.Applications.CRM Namespace


PreferredAddress.GetDateDrivenPreferred Method

protected virtual long GetDateDrivenPreferred(
Int64 PersonID,
DateTime EffectiveDate,
Int64 DefaultAddressID
);

See Also

PreferredAddress Class | Aptify.Applications.CRM Namespace


PreferredAddress.GetPhoneAttribute Method

protected virtual string GetPhoneAttribute(
String FieldName
);

See Also

PreferredAddress Class | Aptify.Applications.CRM Namespace


GetPreferredAddress Method

Aptify 5.0 Software Development Kit (SDK)

PreferredAddress.GetPreferredAddress Method

Overload List

public virtual AddressInfo GetPreferredAddress(Int64);

public virtual AddressInfo GetPreferredAddress(Int64,DateTime);

public virtual AddressInfo GetPreferredAddress(Int64,DateTime,PreferredAddress.PreferredAddressType);

See Also

PreferredAddress Class | Aptify.Applications.CRM Namespace


PreferredAddress.GetPreferredAddress Method (Int64)

public virtual AddressInfo GetPreferredAddress(
Int64 PersonID
);

See Also

PreferredAddress Class | Aptify.Applications.CRM Namespace | PreferredAddress.GetPreferredAddress Overload List


PreferredAddress.GetPreferredAddress Method (Int64, DateTime)

public virtual AddressInfo GetPreferredAddress(
Int64 PersonID,
DateTime EffectiveDate
);

See Also

PreferredAddress Class | Aptify.Applications.CRM Namespace | PreferredAddress.GetPreferredAddress Overload List


PreferredAddress.GetPreferredAddress Method (Int64, DateTime, PreferredAddressType)

public virtual AddressInfo GetPreferredAddress(
Int64 PersonID,
DateTime EffectiveDate,
PreferredAddress.PreferredAddressType PrefType
);

See Also

PreferredAddress Class | Aptify.Applications.CRM Namespace | PreferredAddress.GetPreferredAddress Overload List


PreferredAddress.PreferredAddressType Enumeration

public enum PreferredAddress.PreferredAddressType

Members

Member Name | Description
Mailing |
Billing |
Shipping |

Requirements

Namespace: Aptify.Applications.CRM

Assembly: PreferredAddress (in PreferredAddress.dll)

See Also

Aptify.Applications.CRM Namespace


Aptify.Applications.Education

Aptify 5.0 Software Development Kit (SDK)

Aptify.Applications.Education Namespace

The objects in this namespace implement Aptify's Education add-on module.

Namespace hierarchy

Classes

Class | Description
AnswerSheet |
AnswerSheetLayout | This class implements layout logic for the Windows UI for the Answer Sheet entity.
CertificatePrintObject |
CertificatePrintWizard | Displays a Wizard that walks users through printng certificates
ClassesLayout |
ClassObject |
ClassRegistrationGE | Aptify Class Registration GE Sub-Class Object
ClassRegistrationWizard | Displays a Wizard that walks users through registering a person for a class
CoursePrerequisite | Structure that stores information about a course prerequisite
CurriculumApplication |
CurriculumApplication.CurriculumCategoryRequirements |
CurriculumApplication.CurriculumCourseRequirements |
CurriculumApplication.StudentCertifications |
CurriculumApplicationControl |
CurriculumCategoryRequirement | Structure that stores information about a category requirement for a given Curriculum definition.
CurriculumCourseRequirement | Structure that stores information about a course requirement for a given Curriculum definition.
EducationManagementScopeFilter |
Exam | This class provides the implementation for base validation functionality for the Exams entity in the Aptify Education Management system.
ScantronImport | This class is responsible for importing data from a scantron file into the Aptify Answer Sheets and Persons entities. The object contains several overridable methods that can be used to configure the business logic of the import process as required.
ScantronImport.PersonFileData | This class is used to carry the information related to a single line of the scantron file that is parsed and put into the related fields in this data structure. The ParseScantronFileLine() method of the ScantronImport class (or its overriden implentations in sub-classes) is responsible for taking in a single line of text from a file and parsing that file line and putting the data into the related data structure.
ScantronImportWizard |
StudentCertification | Structure that stores information about student's classes and certifications

Interfaces

Interface | Description
ICertificatePrint |

Delegates

Delegate | Description
ScantronImport.StatusUpdateEventHandler |

Enumerations

Enumeration | Description
CoursePrerequisite.PrerequisiteStatus |
CoursePrerequisite.PrerequisiteStudentStatus |
CoursePrerequisite.PrerequisiteType |
CurriculumApplication.CurriculumApplicationStatus |
ScantronImport.PersonGender |
ScantronImport.ScantronPersonField | This enumerated type tracks the different fields that exist in the scantron file definition that this object will import by default.
StudentCertification.CertificationStatus |
StudentCertification.RequirementStudentStatus |


AnswerSheet Class

For a list of all members of this type, see AnswerSheet Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
AnswerSheet

public class AnswerSheet : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Education

Assembly: AnswerSheet (in AnswerSheet.dll)

See Also

AnswerSheet Members | Aptify.Applications.Education Namespace


AnswerSheet Members

AnswerSheet overview

Public Instance Constructors

AnswerSheet Constructor Initializes a new instance of the AnswerSheet class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

AnswerSheet Class | Aptify.Applications.Education Namespace


AnswerSheet Constructor

Initializes a new instance of the AnswerSheet class.

public AnswerSheet();

See Also

AnswerSheet Class | Aptify.Applications.Education Namespace


AnswerSheet Methods

The methods of the AnswerSheet class are listed below. For a complete list of AnswerSheet class members, see the AnswerSheet Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

AnswerSheet Class | Aptify.Applications.Education Namespace


Validate Method

Aptify 5.0 Software Development Kit (SDK)

AnswerSheet.Validate Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Validate();

public override bool Validate(ref String&);

See Also

AnswerSheet Class | Aptify.Applications.Education Namespace


AnswerSheet.Validate Method (String&)

public override bool Validate(
ref String& ErrorString
);

See Also

AnswerSheet Class | Aptify.Applications.Education Namespace | AnswerSheet.Validate Overload List


AnswerSheetLayout Class

This class implements layout logic for the Windows UI for the Answer Sheet entity.

For a list of all members of this type, see AnswerSheetLayout Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
AnswerSheetLayout

public class AnswerSheetLayout : FormTemplateLayout

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Education

Assembly: AnswerSheetLayoutControl (in AnswerSheetLayoutControl.dll)

See Also

AnswerSheetLayout Members | Aptify.Applications.Education Namespace


AnswerSheetLayout Members

AnswerSheetLayout overview

Public Instance Constructors

AnswerSheetLayout Constructor Initializes a new instance of the AnswerSheetLayout class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
m_ctlCourseID |
m_ctlCourseName |
m_ctlSchool |
m_ctlType |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
BindControl | This method handles binding a control reference to a specific field name using the GetFormComponent() method of the base class. The method only attempts to bind the control reference if the control reference is Nothing or its inner control is disposed.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControls | This method handles binding the controls to their internal protected members.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
On_CourseID_ValueChanged | This member is responsible for processing changes in the CourseID field value.
On_School_ValueChanged | This member is responsible for processing changes in the School field value.
On_Type_ValueChanged | This member is responsible for processing changes in the Type field value.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

AnswerSheetLayout Class | Aptify.Applications.Education Namespace


AnswerSheetLayout Constructor

Initializes a new instance of the AnswerSheetLayout class.

public AnswerSheetLayout();

See Also

AnswerSheetLayout Class | Aptify.Applications.Education Namespace


AnswerSheetLayout Properties

The properties of the AnswerSheetLayout class are listed below. For a complete list of AnswerSheetLayout class members, see the AnswerSheetLayout Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
m_ctlCourseID |
m_ctlCourseName |
m_ctlSchool |
m_ctlType |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

AnswerSheetLayout Class | Aptify.Applications.Education Namespace


m_ctlCourseID Property

Aptify 5.0 Software Development Kit (SDK)

AnswerSheetLayout.m_ctlCourseID Property

protected virtual IAptifyDataFieldControlBase m_ctlCourseID {get; set;}

See Also

AnswerSheetLayout Class | Aptify.Applications.Education Namespace


m_ctlCourseName Property

Aptify 5.0 Software Development Kit (SDK)

AnswerSheetLayout.m_ctlCourseName Property

protected virtual AptifyDataComboBox m_ctlCourseName {get; set;}

See Also

AnswerSheetLayout Class | Aptify.Applications.Education Namespace


m_ctlSchool Property

Aptify 5.0 Software Development Kit (SDK)

AnswerSheetLayout.m_ctlSchool Property

protected virtual AptifyDataComboBox m_ctlSchool {get; set;}

See Also

AnswerSheetLayout Class | Aptify.Applications.Education Namespace


m_ctlType Property

Aptify 5.0 Software Development Kit (SDK)

AnswerSheetLayout.m_ctlType Property

protected virtual IAptifyDataFieldControlBase m_ctlType {get; set;}

See Also

AnswerSheetLayout Class | Aptify.Applications.Education Namespace


AnswerSheetLayout Methods

The methods of the AnswerSheetLayout class are listed below. For a complete list of AnswerSheetLayout class members, see the AnswerSheetLayout Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
BindControl | This method handles binding a control reference to a specific field name using the GetFormComponent() method of the base class. The method only attempts to bind the control reference if the control reference is Nothing or its inner control is disposed.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControls | This method handles binding the controls to their internal protected members.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
On_CourseID_ValueChanged | This member is responsible for processing changes in the CourseID field value.
On_School_ValueChanged | This member is responsible for processing changes in the School field value.
On_Type_ValueChanged | This member is responsible for processing changes in the Type field value.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

AnswerSheetLayout Class | Aptify.Applications.Education Namespace


AnswerSheetLayout.BindControl Method

This method handles binding a control reference to a specific field name using the GetFormComponent() method of the base class. The method only attempts to bind the control reference if the control reference is Nothing or its inner control is disposed.

protected virtual void BindControl(
ref IAptifyDataFieldControlBase& control,
String FieldName
);

Parameters

control
FieldName

Remarks

See Also

AnswerSheetLayout Class | Aptify.Applications.Education Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

AnswerSheetLayout.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

AnswerSheetLayout Class | Aptify.Applications.Education Namespace


AnswerSheetLayout.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

AnswerSheetLayout Class | Aptify.Applications.Education Namespace | AnswerSheetLayout.Dispose Overload List


AnswerSheetLayout.FindControls Method

This method handles binding the controls to their internal protected members.

protected virtual void FindControls();

Remarks

See Also

AnswerSheetLayout Class | Aptify.Applications.Education Namespace


AnswerSheetLayout.On_CourseID_ValueChanged Method

This member is responsible for processing changes in the CourseID field value.

protected virtual void On_CourseID_ValueChanged(
Object sender,
Object OldValue,
Object NewValue
);

Parameters

sender
OldValue
NewValue

Remarks

See Also

AnswerSheetLayout Class | Aptify.Applications.Education Namespace


AnswerSheetLayout.On_School_ValueChanged Method

This member is responsible for processing changes in the School field value.

protected virtual void On_School_ValueChanged(
Object sender,
Object OldValue,
Object NewValue
);

Parameters

sender
OldValue
NewValue

Remarks

See Also

AnswerSheetLayout Class | Aptify.Applications.Education Namespace


AnswerSheetLayout.On_Type_ValueChanged Method

This member is responsible for processing changes in the Type field value.

protected virtual void On_Type_ValueChanged(
Object sender,
Object OldValue,
Object NewValue
);

Parameters

sender
OldValue
NewValue

Remarks

See Also

AnswerSheetLayout Class | Aptify.Applications.Education Namespace


AnswerSheetLayout.OnFormTemplateLoaded Method

protected override void OnFormTemplateLoaded(
FormTemplateLayout.FormTemplateLoadedEventArgs e
);

See Also

AnswerSheetLayout Class | Aptify.Applications.Education Namespace


CertificatePrintObject Class

For a list of all members of this type, see CertificatePrintObject Members.

System.Object
CertificatePrintObject

public class CertificatePrintObject : IProcessComponent, ICertificatePrint

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Education

Assembly: CertificatePrintObject (in CertificatePrintObject.dll)

See Also

CertificatePrintObject Members | Aptify.Applications.Education Namespace


CertificatePrintObject Members

CertificatePrintObject overview

Public Instance Constructors

CertificatePrintObject Constructor Initializes a new instance of the CertificatePrintObject class.

Public Instance Properties

Application
DataAction
Database
Properties

Public Instance Methods

ClassCertificatesPrinted | This method is responsible for checking to see if the certificates have already been printed for this class.
Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCertifiecateReportLocation | This method is responsible for returning the location of the certificate report for the class
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run |
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateDateCertificatesSent | This method is responsible for updating the DateCertificatesSent field on the class passed in

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CertificatePrintObject Class | Aptify.Applications.Education Namespace


CertificatePrintObject Constructor

Initializes a new instance of the CertificatePrintObject class.

public CertificatePrintObject();

See Also

CertificatePrintObject Class | Aptify.Applications.Education Namespace


CertificatePrintObject Properties

The properties of the CertificatePrintObject class are listed below. For a complete list of CertificatePrintObject class members, see the CertificatePrintObject Members topic.

Public Instance Properties

Application
DataAction
Database
Properties

See Also

CertificatePrintObject Class | Aptify.Applications.Education Namespace


Application Property

Aptify 5.0 Software Development Kit (SDK)

CertificatePrintObject.Application Property

public virtual AptifyApplication Application {get;}

See Also

CertificatePrintObject Class | Aptify.Applications.Education Namespace


DataAction Property

Aptify 5.0 Software Development Kit (SDK)

CertificatePrintObject.DataAction Property

public virtual DataAction DataAction {get;}

See Also

CertificatePrintObject Class | Aptify.Applications.Education Namespace


Database Property

Aptify 5.0 Software Development Kit (SDK)

CertificatePrintObject.Database Property

public virtual String Database {get;}

See Also

CertificatePrintObject Class | Aptify.Applications.Education Namespace


Properties Property

Aptify 5.0 Software Development Kit (SDK)

CertificatePrintObject.Properties Property

public AptifyProperties Properties {get;}

Implements

IProcessComponent.

See Also

CertificatePrintObject Class | Aptify.Applications.Education Namespace


CertificatePrintObject Methods

The methods of the CertificatePrintObject class are listed below. For a complete list of CertificatePrintObject class members, see the CertificatePrintObject Members topic.

Public Instance Methods

ClassCertificatesPrinted | This method is responsible for checking to see if the certificates have already been printed for this class.
Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCertifiecateReportLocation | This method is responsible for returning the location of the certificate report for the class
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run |
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateDateCertificatesSent | This method is responsible for updating the DateCertificatesSent field on the class passed in

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CertificatePrintObject Class | Aptify.Applications.Education Namespace


CertificatePrintObject.ClassCertificatesPrinted Method

This method is responsible for checking to see if the certificates have already been printed for this class.

public bool ClassCertificatesPrinted(
Int64 lClassID
);

Parameters

lClassID

Return Value

True if ceretificates have been printed alread, False otherwise

Implements

ICertificatePrint.

Remarks

See Also

CertificatePrintObject Class | Aptify.Applications.Education Namespace


CertificatePrintObject.Config Method

public void Config(
AptifyApplication ApplicationObject
);

Implements

IProcessComponent.

See Also

CertificatePrintObject Class | Aptify.Applications.Education Namespace


CertificatePrintObject.GetCertifiecateReportLocation Method

This method is responsible for returning the location of the certificate report for the class

public string GetCertifiecateReportLocation(
Int64 lClassID
);

Parameters

lClassID

Return Value

The location in the Object Repository for the certificate report.

Implements

ICertificatePrint.

Remarks

See Also

CertificatePrintObject Class | Aptify.Applications.Education Namespace


CertificatePrintObject.Run Method

public string Run();

Implements

IProcessComponent.

See Also

CertificatePrintObject Class | Aptify.Applications.Education Namespace


CertificatePrintObject.UpdateDateCertificatesSent Method

This method is responsible for updating the DateCertificatesSent field on the class passed in

public void UpdateDateCertificatesSent(
Int64 lClassID
);

Parameters

lClassID
Class ID of the Class to be updated

Implements

ICertificatePrint.

Remarks

See Also

CertificatePrintObject Class | Aptify.Applications.Education Namespace


CertificatePrintWizard Class

Displays a Wizard that walks users through printng certificates

For a list of all members of this type, see CertificatePrintWizard Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
CertificatePrintWizard

public class CertificatePrintWizard : Form, IAptifyAction

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Education

Assembly: AptifyCertificatePrintWizard (in AptifyCertificatePrintWizard.dll)

See Also

CertificatePrintWizard Members | Aptify.Applications.Education Namespace


CertificatePrintWizard Members

CertificatePrintWizard overview

Public Instance Constructors

CertificatePrintWizard Constructor Initializes a new instance of the CertificatePrintWizard class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoAction | Overloaded.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CertificatePrintWizard Class | Aptify.Applications.Education Namespace


CertificatePrintWizard Constructor

Initializes a new instance of the CertificatePrintWizard class.

public CertificatePrintWizard();

See Also

CertificatePrintWizard Class | Aptify.Applications.Education Namespace


CertificatePrintWizard Methods

The methods of the CertificatePrintWizard class are listed below. For a complete list of CertificatePrintWizard class members, see the CertificatePrintWizard Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoAction | Overloaded.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CertificatePrintWizard Class | Aptify.Applications.Education Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

CertificatePrintWizard.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

CertificatePrintWizard Class | Aptify.Applications.Education Namespace


CertificatePrintWizard.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

CertificatePrintWizard Class | Aptify.Applications.Education Namespace | CertificatePrintWizard.Dispose Overload List


DoAction Method

Aptify 5.0 Software Development Kit (SDK)

CertificatePrintWizard.DoAction Method

Overload List

public void DoAction(AptifyApplication,Int64);

public void DoAction(AptifyApplication,Int64,Int64);

Starts the Aptify Certificate Print Wizard.

public void DoAction(AptifyApplication,Int64,Int64,params Object[]);

public void DoAction(AptifyApplication,Int64,params String[]);

See Also

CertificatePrintWizard Class | Aptify.Applications.Education Namespace


CertificatePrintWizard.DoAction Method (AptifyApplication, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID
);

Implements

IAptifyAction.

See Also

CertificatePrintWizard Class | Aptify.Applications.Education Namespace | CertificatePrintWizard.DoAction Overload List


CertificatePrintWizard.DoAction Method (AptifyApplication, Int64, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID
);

Implements

IAptifyAction.

See Also

CertificatePrintWizard Class | Aptify.Applications.Education Namespace | CertificatePrintWizard.DoAction Overload List


CertificatePrintWizard.DoAction Method (AptifyApplication, Int64, Int64, Object[])

Starts the Aptify Certificate Print Wizard.

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID,
params Object[] SelectedItems
);

Parameters

ApplicationObject
A valid AptifyApplication.
EntityID
Not Used
ViewID
Not Used
SelectedItems
Not Used

Implements

IAptifyAction.

Remarks

See Also

CertificatePrintWizard Class | Aptify.Applications.Education Namespace | CertificatePrintWizard.DoAction Overload List


CertificatePrintWizard.DoAction Method (AptifyApplication, Int64, String[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
params String[] SelectedItems
);

Implements

IAptifyAction.

See Also

CertificatePrintWizard Class | Aptify.Applications.Education Namespace | CertificatePrintWizard.DoAction Overload List


ClassesLayout Class

For a list of all members of this type, see ClassesLayout Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
ClassesLayout

public class ClassesLayout : FormTemplateLayout

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Education

Assembly: ClassesGUI (in ClassesGUI.dll)

See Also

ClassesLayout Members | Aptify.Applications.Education Namespace


ClassesLayout Members

ClassesLayout overview

Public Instance Constructors

ClassesLayout Constructor Initializes a new instance of the ClassesLayout class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ClassesLayout Class | Aptify.Applications.Education Namespace


ClassesLayout Constructor

Initializes a new instance of the ClassesLayout class.

public ClassesLayout();

See Also

ClassesLayout Class | Aptify.Applications.Education Namespace


ClassesLayout Methods

The methods of the ClassesLayout class are listed below. For a complete list of ClassesLayout class members, see the ClassesLayout Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ClassesLayout Class | Aptify.Applications.Education Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

ClassesLayout.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

ClassesLayout Class | Aptify.Applications.Education Namespace


ClassesLayout.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

ClassesLayout Class | Aptify.Applications.Education Namespace | ClassesLayout.Dispose Overload List


ClassesLayout.OnFormTemplateLoaded Method

protected override void OnFormTemplateLoaded(
FormTemplateLayout.FormTemplateLoadedEventArgs e
);

See Also

ClassesLayout Class | Aptify.Applications.Education Namespace


ClassObject Class

For a list of all members of this type, see ClassObject Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
ClassObject

public class ClassObject : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Education

Assembly: Class (in Class.dll)

See Also

ClassObject Members | Aptify.Applications.Education Namespace


ClassObject Members

ClassObject overview

Public Instance Constructors

ClassObject Constructor Initializes a new instance of the ClassObject class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
FlowDownCourseParts | This method will override the ClassPartUse sub-type in the current Class record and replace the contents with the contents from the associated course. The CourseID field must be populated before this method is called.
FlowDownCourseWebInfo | This method is called automatically for new records to flow down the following fields from the Course record into the Class where they can then be updated. Override this method in a sub-class to alter the flow-down logic. This method is called automatically from Save() for new records. 1) WebEnabled 2) WebName 3) WebDescription 4) WebDetails 5) ShowInstructorInfo
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded. This method calls the base GE Validate() method and also implements validation that handles the Registered Instructor Required checking. In addition, this method also handles the update of the NumClassMeetings field in the Class entity by computing the number of entries in the ClassSchedule sub-type.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewOrLoadRecord | This method handles the NewRecord() and LoadRecord() events of the GE and the default logic is to turn on the CourseID field events for ValueChanged.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnCourseIDValueChanged | This method handles the event for when the CourseID field changes. The default behavior for this event handler in the base class is to call FlowDownCourseParts() and FlowDownCourseWebInfo() when the object represents a new record.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

ClassObject Class | Aptify.Applications.Education Namespace


ClassObject Constructor

Initializes a new instance of the ClassObject class.

public ClassObject();

See Also

ClassObject Class | Aptify.Applications.Education Namespace


ClassObject Methods

The methods of the ClassObject class are listed below. For a complete list of ClassObject class members, see the ClassObject Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
FlowDownCourseParts | This method will override the ClassPartUse sub-type in the current Class record and replace the contents with the contents from the associated course. The CourseID field must be populated before this method is called.
FlowDownCourseWebInfo | This method is called automatically for new records to flow down the following fields from the Course record into the Class where they can then be updated. Override this method in a sub-class to alter the flow-down logic. This method is called automatically from Save() for new records. 1) WebEnabled 2) WebName 3) WebDescription 4) WebDetails 5) ShowInstructorInfo
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded. This method calls the base GE Validate() method and also implements validation that handles the Registered Instructor Required checking. In addition, this method also handles the update of the NumClassMeetings field in the Class entity by computing the number of entries in the ClassSchedule sub-type.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewOrLoadRecord | This method handles the NewRecord() and LoadRecord() events of the GE and the default logic is to turn on the CourseID field events for ValueChanged.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnCourseIDValueChanged | This method handles the event for when the CourseID field changes. The default behavior for this event handler in the base class is to call FlowDownCourseParts() and FlowDownCourseWebInfo() when the object represents a new record.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

ClassObject Class | Aptify.Applications.Education Namespace


ClassObject.FlowDownCourseParts Method

This method will override the ClassPartUse sub-type in the current Class record and replace the contents with the contents from the associated course. The CourseID field must be populated before this method is called.

public virtual void FlowDownCourseParts();

Remarks

See Also

ClassObject Class | Aptify.Applications.Education Namespace


ClassObject.FlowDownCourseWebInfo Method

This method is called automatically for new records to flow down the following fields from the Course record into the Class where they can then be updated. Override this method in a sub-class to alter the flow-down logic. This method is called automatically from Save() for new records. 1) WebEnabled 2) WebName 3) WebDescription 4) WebDetails 5) ShowInstructorInfo

public virtual void FlowDownCourseWebInfo();

Remarks

See Also

ClassObject Class | Aptify.Applications.Education Namespace


ClassObject.OnAfterNewOrLoadRecord Method

This method handles the NewRecord() and LoadRecord() events of the GE and the default logic is to turn on the CourseID field events for ValueChanged.

protected virtual void OnAfterNewOrLoadRecord(
AptifyGenericEntityBase sender,
EventArgs e
);

Parameters

sender
e

Remarks

See Also

ClassObject Class | Aptify.Applications.Education Namespace


ClassObject.OnCourseIDValueChanged Method

This method handles the event for when the CourseID field changes. The default behavior for this event handler in the base class is to call FlowDownCourseParts() and FlowDownCourseWebInfo() when the object represents a new record.

protected virtual void OnCourseIDValueChanged(
AptifyDataFieldBase sender,
AfterValueChangedEventArgs e
);

Parameters

sender
e

Remarks

See Also

ClassObject Class | Aptify.Applications.Education Namespace


Validate Method

Aptify 5.0 Software Development Kit (SDK)

ClassObject.Validate Method

This method calls the base GE Validate() method and also implements validation that handles the Registered Instructor Required checking. In addition, this method also handles the update of the NumClassMeetings field in the Class entity by computing the number of entries in the ClassSchedule sub-type.

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Validate();

This method calls the base GE Validate() method and also implements validation that handles the Registered Instructor Required checking. In addition, this method also handles the update of the NumClassMeetings field in the Class entity by computing the number of entries in the ClassSchedule sub-type.

public override bool Validate(ref String&);

See Also

ClassObject Class | Aptify.Applications.Education Namespace


ClassObject.Validate Method (String&)

This method calls the base GE Validate() method and also implements validation that handles the Registered Instructor Required checking. In addition, this method also handles the update of the NumClassMeetings field in the Class entity by computing the number of entries in the ClassSchedule sub-type.

public override bool Validate(
ref String& ErrorString
);

Parameters

ErrorString

Return Value

Remarks

See Also

ClassObject Class | Aptify.Applications.Education Namespace | ClassObject.Validate Overload List


ClassRegistrationGE Class

Aptify Class Registration GE Sub-Class Object

For a list of all members of this type, see ClassRegistrationGE Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
ExtendedOrderDetailGE
ClassRegistrationGE

public class ClassRegistrationGE : ExtendedOrderDetailGE

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Education

Assembly: ClassRegistrationGE (in ClassRegistrationGE.dll)

See Also

ClassRegistrationGE Members | Aptify.Applications.Education Namespace


ClassRegistrationGE Members

ClassRegistrationGE overview

Public Instance Constructors

ClassRegistrationGE Constructor Initializes a new instance of the ClassRegistrationGE class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
IsEmbeddedInOrderGE | Returns True if the object is embedded within an order line/order GE, false if accessed directly and not embedded within the Order Entry infrastructure.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
OrderLineGE |
ParentGE (inherited from ExtendedOrderDetailGE) |
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from ExtendedOrderDetailGE) |
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CanCurrentUserOverridePrerequisites | This method is used to determine if the currently logged in user has the rights to override prerequisites for a class registration. By default, this is determined by looking at the Delete permission on the Class Registrations entity. If a user has DELETE permission on the Class Registrations entity, the user is allowed to override the prerequisites requirement. If it is necessary to change the business logic that determines if a user can override prerequisites or not, sub-class this class and override this method placing the appropriate logic in the method override.
CheckCoursePrerequisites | Overloaded. This method checks to see if there are prerequisites for a given course and determines if the provided StudentID has completed each course. The results are returned in a list of Course Prerequisites, if there are any prerequisites for the provided course. If there are no prerequisites for the provided CourseID, Nothing is returned.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
FlowdownForAddCancellationOrderLine |
FlowdownForAddProductToOrder (inherited from ExtendedOrderDetailGE) | Called by the OrdersEntity's AddProduct method. It is designed to be overridden when the extended Order Detail Entity needs to use information from the Order Line or Order to set values or perform other logic when a Product is added to an Order. Overrides of this method should return true if the Product should be added to the Order. A return value of false will abort the Add Product to Order process. The core implementation returns True with no other functionality.
GenerateOrder | Generate an order based on the class registration information.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetClassCourseID | This method returns the Course ID associated with the provided Class ID
GetClassList | This method returns a datatable populated with information on classes that are available for the specified course ID on or after the specified OnOrAfter date and of the Type specified,if provided
GetClassProductID | This method returns the product ID associated with the provided Class ID
GetClassProductType |
GetCoursePrerequisites | This method will return a list of Course ID values that are prerequisites for the specified CourseID
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLastClassRegistrationStatus |
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetMinEmployeeID | This method returns the lowest ID value in the Employees entity.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetPersonCompanyID | This method returns the company ID associated with the provided Person ID
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
HasStudentMetPrerequisites | This method determines if a student has completed the prerequisites for the specified CourseID and returns True if the prerequisites have been met, False otherwise. The base class logic supports course prerequisites of the following types: Prerequisite - Must be completed succesfully before registration is allowedCorequisite - Must be completed or registered/started before registration is allowedOptional - No requirement for registration, but suggested. In the event where a student meets all of the mandatory requirements for the course, but not some of the optional ones the value of True is returned and the UnmetPrerequisites OUT param contains descriptive text that outlines the optional items not met.
Load (inherited from ExtendedOrderDetailGE) | Overloaded.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord | Extends the base NewRecord method by setting the default value for the EnrollmentTypeID value to the lowest EnrollmentType in the database.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveCancellationData (inherited from ExtendedOrderDetailGE) | Called during the Order Save process in the OrdersEntity's SaveCancellationData method. It is designed to be overridden when the extended Order Detail Entity needs to perform some work related to the cancellation of the Order Line. Return True, if the SaveCancellationData method is successful and the Order Save should contain. Return False, if the Order Save process should be aborted. When returning False, use the Error Log and/or the SetLastUeer/SetLastUser error methods to return useful information about the failure. The core implementation returns True with no other functionality.
SaveCancelledData (inherited from ExtendedOrderDetailGE) | Called during the Order Save process in the OrdersEntity's SaveCancellationData method. It is designed to be overridden when the extended Order Detail Entity needs to perform some work related to the the Order Line when the Order status has been changed to Cancelled. This is called to preform special handling on the orderline, if there is a need to changed information after the order status has been changed to cancelled. This allows, for example, the removal of a customer from a meeting detail record.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetExtendedOrderDetailRecordID (inherited from ExtendedOrderDetailGE) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ShouldGenerateOrder | This method is responsible for determining the global behavior for generating orders. The base classes uses the entity attribute on the Class Registrations entity called AutoGenerateOrders. If that entity attribute is set to 1, this method returns true and orders will be generated per the documentation when Status='Registered'. To turn off order generation, set the Entity Attribute mentioned to 0, or override this method in a sub-class to implement custom handling as required. This method will also return false if the class registration is embedded in an order GE, if an order was generated previously, or if the registration status is not set to 'Registered'.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded. If the standard Generic Entity validate returns True, the following additional validation logic is executed: 1. For an existing record, it is not valid to change the Status back to Pending. 2. If the Status is Registered, Course Pre-requisites will be validated. 3. If Payment Information has been specified, it will be validated. 4. If Payment Information has not been specified and the Class Registrations Entity is configured to generate Orders, Payment Information is required.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
FlowDownFromOrderGE | This method will flow down values from the Order GE to auto-populate the Class Registration record with default values. The default logic is to populate the StudentID field with the ShipToID from the Order GE. This is only done if the StudentID field in the Class Registration record was not previously set to a value.
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
GetLowestEnrollmentTypeID | Returns the lowest ID value from the Enrollment Types entity.
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
ResetFieldsLinkedToOrderLine (inherited from ExtendedOrderDetailGE) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

ClassRegistrationGE Class | Aptify.Applications.Education Namespace


ClassRegistrationGE Constructor

Initializes a new instance of the ClassRegistrationGE class.

public ClassRegistrationGE();

See Also

ClassRegistrationGE Class | Aptify.Applications.Education Namespace


ClassRegistrationGE Properties

The properties of the ClassRegistrationGE class are listed below. For a complete list of ClassRegistrationGE class members, see the ClassRegistrationGE Members topic.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
IsEmbeddedInOrderGE | Returns True if the object is embedded within an order line/order GE, false if accessed directly and not embedded within the Order Entry infrastructure.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
OrderLineGE |
ParentGE (inherited from ExtendedOrderDetailGE) |
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from ExtendedOrderDetailGE) |
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

ClassRegistrationGE Class | Aptify.Applications.Education Namespace


IsEmbeddedInOrderGE Property

Aptify 5.0 Software Development Kit (SDK)

ClassRegistrationGE.IsEmbeddedInOrderGE Property

Returns True if the object is embedded within an order line/order GE, false if accessed directly and not embedded within the Order Entry infrastructure.

public virtual Boolean IsEmbeddedInOrderGE {get;}

Property Value

Remarks

See Also

ClassRegistrationGE Class | Aptify.Applications.Education Namespace


OrderLineGE Property

Aptify 5.0 Software Development Kit (SDK)

ClassRegistrationGE.OrderLineGE Property

public override OrderLinesEntity OrderLineGE {get; set;}

See Also

ClassRegistrationGE Class | Aptify.Applications.Education Namespace


ClassRegistrationGE Methods

The methods of the ClassRegistrationGE class are listed below. For a complete list of ClassRegistrationGE class members, see the ClassRegistrationGE Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CanCurrentUserOverridePrerequisites | This method is used to determine if the currently logged in user has the rights to override prerequisites for a class registration. By default, this is determined by looking at the Delete permission on the Class Registrations entity. If a user has DELETE permission on the Class Registrations entity, the user is allowed to override the prerequisites requirement. If it is necessary to change the business logic that determines if a user can override prerequisites or not, sub-class this class and override this method placing the appropriate logic in the method override.
CheckCoursePrerequisites | Overloaded. This method checks to see if there are prerequisites for a given course and determines if the provided StudentID has completed each course. The results are returned in a list of Course Prerequisites, if there are any prerequisites for the provided course. If there are no prerequisites for the provided CourseID, Nothing is returned.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
FlowdownForAddCancellationOrderLine |
FlowdownForAddProductToOrder (inherited from ExtendedOrderDetailGE) | Called by the OrdersEntity's AddProduct method. It is designed to be overridden when the extended Order Detail Entity needs to use information from the Order Line or Order to set values or perform other logic when a Product is added to an Order. Overrides of this method should return true if the Product should be added to the Order. A return value of false will abort the Add Product to Order process. The core implementation returns True with no other functionality.
GenerateOrder | Generate an order based on the class registration information.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetClassCourseID | This method returns the Course ID associated with the provided Class ID
GetClassList | This method returns a datatable populated with information on classes that are available for the specified course ID on or after the specified OnOrAfter date and of the Type specified,if provided
GetClassProductID | This method returns the product ID associated with the provided Class ID
GetClassProductType |
GetCoursePrerequisites | This method will return a list of Course ID values that are prerequisites for the specified CourseID
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLastClassRegistrationStatus |
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetMinEmployeeID | This method returns the lowest ID value in the Employees entity.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetPersonCompanyID | This method returns the company ID associated with the provided Person ID
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
HasStudentMetPrerequisites | This method determines if a student has completed the prerequisites for the specified CourseID and returns True if the prerequisites have been met, False otherwise. The base class logic supports course prerequisites of the following types: Prerequisite - Must be completed succesfully before registration is allowedCorequisite - Must be completed or registered/started before registration is allowedOptional - No requirement for registration, but suggested. In the event where a student meets all of the mandatory requirements for the course, but not some of the optional ones the value of True is returned and the UnmetPrerequisites OUT param contains descriptive text that outlines the optional items not met.
Load (inherited from ExtendedOrderDetailGE) | Overloaded.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord | Extends the base NewRecord method by setting the default value for the EnrollmentTypeID value to the lowest EnrollmentType in the database.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveCancellationData (inherited from ExtendedOrderDetailGE) | Called during the Order Save process in the OrdersEntity's SaveCancellationData method. It is designed to be overridden when the extended Order Detail Entity needs to perform some work related to the cancellation of the Order Line. Return True, if the SaveCancellationData method is successful and the Order Save should contain. Return False, if the Order Save process should be aborted. When returning False, use the Error Log and/or the SetLastUeer/SetLastUser error methods to return useful information about the failure. The core implementation returns True with no other functionality.
SaveCancelledData (inherited from ExtendedOrderDetailGE) | Called during the Order Save process in the OrdersEntity's SaveCancellationData method. It is designed to be overridden when the extended Order Detail Entity needs to perform some work related to the the Order Line when the Order status has been changed to Cancelled. This is called to preform special handling on the orderline, if there is a need to changed information after the order status has been changed to cancelled. This allows, for example, the removal of a customer from a meeting detail record.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetExtendedOrderDetailRecordID (inherited from ExtendedOrderDetailGE) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ShouldGenerateOrder | This method is responsible for determining the global behavior for generating orders. The base classes uses the entity attribute on the Class Registrations entity called AutoGenerateOrders. If that entity attribute is set to 1, this method returns true and orders will be generated per the documentation when Status='Registered'. To turn off order generation, set the Entity Attribute mentioned to 0, or override this method in a sub-class to implement custom handling as required. This method will also return false if the class registration is embedded in an order GE, if an order was generated previously, or if the registration status is not set to 'Registered'.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded. If the standard Generic Entity validate returns True, the following additional validation logic is executed: 1. For an existing record, it is not valid to change the Status back to Pending. 2. If the Status is Registered, Course Pre-requisites will be validated. 3. If Payment Information has been specified, it will be validated. 4. If Payment Information has not been specified and the Class Registrations Entity is configured to generate Orders, Payment Information is required.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
FlowDownFromOrderGE | This method will flow down values from the Order GE to auto-populate the Class Registration record with default values. The default logic is to populate the StudentID field with the ShipToID from the Order GE. This is only done if the StudentID field in the Class Registration record was not previously set to a value.
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
GetLowestEnrollmentTypeID | Returns the lowest ID value from the Enrollment Types entity.
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
ResetFieldsLinkedToOrderLine (inherited from ExtendedOrderDetailGE) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

ClassRegistrationGE Class | Aptify.Applications.Education Namespace


ClassRegistrationGE.CanCurrentUserOverridePrerequisites Method

This method is used to determine if the currently logged in user has the rights to override prerequisites for a class registration. By default, this is determined by looking at the Delete permission on the Class Registrations entity. If a user has DELETE permission on the Class Registrations entity, the user is allowed to override the prerequisites requirement. If it is necessary to change the business logic that determines if a user can override prerequisites or not, sub-class this class and override this method placing the appropriate logic in the method override.

public virtual bool CanCurrentUserOverridePrerequisites();

Return Value

True if the current user is allowed to override course prerequisite requirements for class registrations, False otherwise.

Remarks

See Also

ClassRegistrationGE Class | Aptify.Applications.Education Namespace


CheckCoursePrerequisites Method

Aptify 5.0 Software Development Kit (SDK)

ClassRegistrationGE.CheckCoursePrerequisites Method

This method checks to see if the provided StudentID has completed each course in the Prerequisites parameter. The results are returned in a list. is returned.

Overload List

This method checks to see if the provided StudentID has completed each course in the Prerequisites parameter. The results are returned in a list. is returned.

public virtual List<T> CheckCoursePrerequisites(Int64,List<T>);

This method checks to see if there are prerequisites for a given course and determines if the provided StudentID has completed each course. The results are returned in a list of Course Prerequisites, if there are any prerequisites for the provided course. If there are no prerequisites for the provided CourseID, Nothing is returned.

public virtual List<T> CheckCoursePrerequisites(Int64,Int64);

See Also

ClassRegistrationGE Class | Aptify.Applications.Education Namespace


ClassRegistrationGE.CheckCoursePrerequisites Method (Int64, List<T>)

This method checks to see if the provided StudentID has completed each course in the Prerequisites parameter. The results are returned in a list. is returned.

public virtual List<T> CheckCoursePrerequisites(
Int64 StudentID,
List<T> Prerequisites
);

Parameters

StudentID
Prerequisites

Return Value

Remarks

See Also

ClassRegistrationGE Class | Aptify.Applications.Education Namespace | ClassRegistrationGE.CheckCoursePrerequisites Overload List


ClassRegistrationGE.CheckCoursePrerequisites Method (Int64, Int64)

This method checks to see if there are prerequisites for a given course and determines if the provided StudentID has completed each course. The results are returned in a list of Course Prerequisites, if there are any prerequisites for the provided course. If there are no prerequisites for the provided CourseID, Nothing is returned.

public virtual List<T> CheckCoursePrerequisites(
Int64 CourseID,
Int64 StudentID
);

Parameters

CourseID
StudentID

Return Value

Remarks

See Also

ClassRegistrationGE Class | Aptify.Applications.Education Namespace | ClassRegistrationGE.CheckCoursePrerequisites Overload List


ClassRegistrationGE.FlowdownForAddCancellationOrderLine Method

public override bool FlowdownForAddCancellationOrderLine();

See Also

ClassRegistrationGE Class | Aptify.Applications.Education Namespace


ClassRegistrationGE.FlowDownFromOrderGE Method

This method will flow down values from the Order GE to auto-populate the Class Registration record with default values. The default logic is to populate the StudentID field with the ShipToID from the Order GE. This is only done if the StudentID field in the Class Registration record was not previously set to a value.

protected virtual void FlowDownFromOrderGE();

Remarks

See Also

ClassRegistrationGE Class | Aptify.Applications.Education Namespace


ClassRegistrationGE.GenerateOrder Method

Generate an order based on the class registration information.

public virtual bool GenerateOrder(
ref String& ErrorString
);

Return Value

Remarks

See Also

ClassRegistrationGE Class | Aptify.Applications.Education Namespace


ClassRegistrationGE.GetClassCourseID Method

This method returns the Course ID associated with the provided Class ID

public virtual long GetClassCourseID(
Int64 ClassID
);

Parameters

ClassID

Return Value

Remarks

See Also

ClassRegistrationGE Class | Aptify.Applications.Education Namespace


ClassRegistrationGE.GetClassList Method

This method returns a datatable populated with information on classes that are available for the specified course ID on or after the specified OnOrAfter date and of the Type specified,if provided

public virtual DataTable GetClassList(
Int64 CourseID,
DateTime OnOrAfter,
String ClassType
);

Parameters

CourseID
OnOrAfter
ClassType
If provided, the result is filtered on this class type

Return Value

Remarks

See Also

ClassRegistrationGE Class | Aptify.Applications.Education Namespace


ClassRegistrationGE.GetClassProductID Method

This method returns the product ID associated with the provided Class ID

public virtual long GetClassProductID(
Int64 ClassID
);

Parameters

ClassID

Return Value

Remarks

See Also

ClassRegistrationGE Class | Aptify.Applications.Education Namespace


ClassRegistrationGE.GetClassProductType Method

public virtual string GetClassProductType(
Int64 ProductID
);

See Also

ClassRegistrationGE Class | Aptify.Applications.Education Namespace


ClassRegistrationGE.GetCoursePrerequisites Method

This method will return a list of Course ID values that are prerequisites for the specified CourseID

public virtual List<T> GetCoursePrerequisites(
Int64 CourseID
);

Parameters

CourseID

Return Value

Remarks

See Also

ClassRegistrationGE Class | Aptify.Applications.Education Namespace


ClassRegistrationGE.GetLastClassRegistrationStatus Method

public virtual string GetLastClassRegistrationStatus(
Int64 ClassRegID
);

See Also

ClassRegistrationGE Class | Aptify.Applications.Education Namespace


ClassRegistrationGE.GetLowestEnrollmentTypeID Method

Returns the lowest ID value from the Enrollment Types entity.

protected virtual long GetLowestEnrollmentTypeID();

Return Value

Remarks

See Also

ClassRegistrationGE Class | Aptify.Applications.Education Namespace


ClassRegistrationGE.GetMinEmployeeID Method

This method returns the lowest ID value in the Employees entity.

public virtual long GetMinEmployeeID();

Return Value

Remarks

See Also

ClassRegistrationGE Class | Aptify.Applications.Education Namespace


ClassRegistrationGE.GetPersonCompanyID Method

This method returns the company ID associated with the provided Person ID

public virtual long GetPersonCompanyID(
Int64 PersonID
);

Parameters

PersonID

Return Value

Remarks

See Also

ClassRegistrationGE Class | Aptify.Applications.Education Namespace


ClassRegistrationGE.HasStudentMetPrerequisites Method

This method determines if a student has completed the prerequisites for the specified CourseID and returns True if the prerequisites have been met, False otherwise. The base class logic supports course prerequisites of the following types: Prerequisite - Must be completed succesfully before registration is allowedCorequisite - Must be completed or registered/started before registration is allowedOptional - No requirement for registration, but suggested. In the event where a student meets all of the mandatory requirements for the course, but not some of the optional ones the value of True is returned and the UnmetPrerequisites OUT param contains descriptive text that outlines the optional items not met.

public virtual bool HasStudentMetPrerequisites(
Int64 CourseID,
Int64 StudentID,
ref String& UnmetPrerequisites,
List<T> CoursePrequisites
);

Parameters

CourseID
StudentID
UnmetPrerequisites
Optional: Returns a text description of prerequisite course names that have not been completed by the student. For structured details on course prerequisites use the CheckCoursePrerequisites() method.
CoursePrequisites
Optional: Returns the Course Prerequisite list that contains the details that were analyzed by the method.

Return Value

Remarks

See Also

ClassRegistrationGE Class | Aptify.Applications.Education Namespace


ClassRegistrationGE.NewRecord Method

Extends the base NewRecord method by setting the default value for the EnrollmentTypeID value to the lowest EnrollmentType in the database.

public override bool NewRecord();

Return Value

Remarks

See Also

ClassRegistrationGE Class | Aptify.Applications.Education Namespace


Save Method

Aptify 5.0 Software Development Kit (SDK)

ClassRegistrationGE.Save Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Save();

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean,ref String&);

public override bool Save(Boolean,ref String&,String);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(ref String&);

See Also

ClassRegistrationGE Class | Aptify.Applications.Education Namespace


ClassRegistrationGE.Save Method (Boolean, String&, String)

public override bool Save(
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

See Also

ClassRegistrationGE Class | Aptify.Applications.Education Namespace | ClassRegistrationGE.Save Overload List


ClassRegistrationGE.ShouldGenerateOrder Method

This method is responsible for determining the global behavior for generating orders. The base classes uses the entity attribute on the Class Registrations entity called AutoGenerateOrders. If that entity attribute is set to 1, this method returns true and orders will be generated per the documentation when Status='Registered'. To turn off order generation, set the Entity Attribute mentioned to 0, or override this method in a sub-class to implement custom handling as required. This method will also return false if the class registration is embedded in an order GE, if an order was generated previously, or if the registration status is not set to 'Registered'.

public virtual bool ShouldGenerateOrder();

Return Value

Remarks

See Also

ClassRegistrationGE Class | Aptify.Applications.Education Namespace


Validate Method

Aptify 5.0 Software Development Kit (SDK)

ClassRegistrationGE.Validate Method

If the standard Generic Entity validate returns True, the following additional validation logic is executed: 1. For an existing record, it is not valid to change the Status back to Pending. 2. If the Status is Registered, Course Pre-requisites will be validated. 3. If Payment Information has been specified, it will be validated. 4. If Payment Information has not been specified and the Class Registrations Entity is configured to generate Orders, Payment Information is required.

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Validate();

If the standard Generic Entity validate returns True, the following additional validation logic is executed: 1. For an existing record, it is not valid to change the Status back to Pending. 2. If the Status is Registered, Course Pre-requisites will be validated. 3. If Payment Information has been specified, it will be validated. 4. If Payment Information has not been specified and the Class Registrations Entity is configured to generate Orders, Payment Information is required.

public override bool Validate(ref String&);

See Also

ClassRegistrationGE Class | Aptify.Applications.Education Namespace


ClassRegistrationGE.Validate Method (String&)

If the standard Generic Entity validate returns True, the following additional validation logic is executed: 1. For an existing record, it is not valid to change the Status back to Pending. 2. If the Status is Registered, Course Pre-requisites will be validated. 3. If Payment Information has been specified, it will be validated. 4. If Payment Information has not been specified and the Class Registrations Entity is configured to generate Orders, Payment Information is required.

public override bool Validate(
ref String& ErrorString
);

Parameters

ErrorString

Return Value

Remarks

See Also

ClassRegistrationGE Class | Aptify.Applications.Education Namespace | ClassRegistrationGE.Validate Overload List


ClassRegistrationWizard Class

Displays a Wizard that walks users through registering a person for a class

For a list of all members of this type, see ClassRegistrationWizard Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
ClassRegistrationWizard

public class ClassRegistrationWizard : Form, IAptifyAction

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Education

Assembly: ClassRegistrationWizard (in ClassRegistrationWizard.dll)

See Also

ClassRegistrationWizard Members | Aptify.Applications.Education Namespace


ClassRegistrationWizard Members

ClassRegistrationWizard overview

Public Instance Constructors

ClassRegistrationWizard Constructor Initializes a new instance of the ClassRegistrationWizard class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoAction | Overloaded.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CheckClassSchedule | This method is responsible for checking to see if any classes are available on or after the registration date provided and returns True if one or more classes are available, and returns true if succesful in populating a list of classes to select from.
CheckCourseAndRegistrant | This method is responsible for determining if the course and registrant information that was input by the user is acceptable.
CheckCoursePrerequisites |
CheckCreateOrder |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ClassRegistrationWizard Class | Aptify.Applications.Education Namespace


ClassRegistrationWizard Constructor

Initializes a new instance of the ClassRegistrationWizard class.

public ClassRegistrationWizard();

See Also

ClassRegistrationWizard Class | Aptify.Applications.Education Namespace


ClassRegistrationWizard Methods

The methods of the ClassRegistrationWizard class are listed below. For a complete list of ClassRegistrationWizard class members, see the ClassRegistrationWizard Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoAction | Overloaded.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CheckClassSchedule | This method is responsible for checking to see if any classes are available on or after the registration date provided and returns True if one or more classes are available, and returns true if succesful in populating a list of classes to select from.
CheckCourseAndRegistrant | This method is responsible for determining if the course and registrant information that was input by the user is acceptable.
CheckCoursePrerequisites |
CheckCreateOrder |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ClassRegistrationWizard Class | Aptify.Applications.Education Namespace


ClassRegistrationWizard.ApplySkin Method

protected virtual void ApplySkin();

See Also

ClassRegistrationWizard Class | Aptify.Applications.Education Namespace


ClassRegistrationWizard.CheckClassSchedule Method

This method is responsible for checking to see if any classes are available on or after the registration date provided and returns True if one or more classes are available, and returns true if succesful in populating a list of classes to select from.

protected virtual bool CheckClassSchedule(
DateTime RegistrationDate
);

Parameters

RegistrationDate

Return Value

Remarks

See Also

ClassRegistrationWizard Class | Aptify.Applications.Education Namespace


ClassRegistrationWizard.CheckCourseAndRegistrant Method

This method is responsible for determining if the course and registrant information that was input by the user is acceptable.

protected virtual bool CheckCourseAndRegistrant();

Return Value

Remarks

See Also

ClassRegistrationWizard Class | Aptify.Applications.Education Namespace


ClassRegistrationWizard.CheckCoursePrerequisites Method

protected virtual bool CheckCoursePrerequisites();

See Also

ClassRegistrationWizard Class | Aptify.Applications.Education Namespace


ClassRegistrationWizard.CheckCreateOrder Method

protected virtual void CheckCreateOrder();

See Also

ClassRegistrationWizard Class | Aptify.Applications.Education Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

ClassRegistrationWizard.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

ClassRegistrationWizard Class | Aptify.Applications.Education Namespace


ClassRegistrationWizard.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

ClassRegistrationWizard Class | Aptify.Applications.Education Namespace | ClassRegistrationWizard.Dispose Overload List


DoAction Method

Aptify 5.0 Software Development Kit (SDK)

ClassRegistrationWizard.DoAction Method

Overload List

public void DoAction(AptifyApplication,Int64);

public void DoAction(AptifyApplication,Int64,Int64);

Starts the Aptify Class Registration Wizard.

public void DoAction(AptifyApplication,Int64,Int64,params Object[]);

public void DoAction(AptifyApplication,Int64,params String[]);

See Also

ClassRegistrationWizard Class | Aptify.Applications.Education Namespace


ClassRegistrationWizard.DoAction Method (AptifyApplication, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID
);

Implements

IAptifyAction.

See Also

ClassRegistrationWizard Class | Aptify.Applications.Education Namespace | ClassRegistrationWizard.DoAction Overload List


ClassRegistrationWizard.DoAction Method (AptifyApplication, Int64, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID
);

Implements

IAptifyAction.

See Also

ClassRegistrationWizard Class | Aptify.Applications.Education Namespace | ClassRegistrationWizard.DoAction Overload List


ClassRegistrationWizard.DoAction Method (AptifyApplication, Int64, Int64, Object[])

Starts the Aptify Class Registration Wizard.

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID,
params Object[] SelectedItems
);

Parameters

ApplicationObject
A valid AptifyApplication.
EntityID
Not Used
ViewID
Not Used
SelectedItems
Not Used

Implements

IAptifyAction.

Remarks

See Also

ClassRegistrationWizard Class | Aptify.Applications.Education Namespace | ClassRegistrationWizard.DoAction Overload List


ClassRegistrationWizard.DoAction Method (AptifyApplication, Int64, String[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
params String[] SelectedItems
);

Implements

IAptifyAction.

See Also

ClassRegistrationWizard Class | Aptify.Applications.Education Namespace | ClassRegistrationWizard.DoAction Overload List


CoursePrerequisite Class

Structure that stores information about a course prerequisite

For a list of all members of this type, see CoursePrerequisite Members.

System.Object
CoursePrerequisite

public class CoursePrerequisite

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Education

Assembly: ClassRegistrationGE (in ClassRegistrationGE.dll)

See Also

CoursePrerequisite Members | Aptify.Applications.Education Namespace


CoursePrerequisite Members

CoursePrerequisite overview

Public Instance Constructors

CoursePrerequisite Constructor Initializes a new instance of the CoursePrerequisite class.

Public Instance Fields

CourseID
CourseName
DateCompleted
Status
StudentStatus
Type
Units

Public Instance Properties

ValidationMessage | Returns a validation message, see ValidationResult for more information on this property.
ValidationResult | This method returns True if the student meets the requirements for the specified item, False otherwise. If the method returns False, check the ValidationMessage property for details. When True is returned, there may be text in the ValidationMessage property as well since there maybe optional or co-requisite items that have messages that do not prevent validation but can be useful in presentation to a user or otherwise.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CoursePrerequisite Class | Aptify.Applications.Education Namespace


CoursePrerequisite Constructor

Initializes a new instance of the CoursePrerequisite class.

public CoursePrerequisite();

See Also

CoursePrerequisite Class | Aptify.Applications.Education Namespace


CoursePrerequisite Fields

The fields of the CoursePrerequisite class are listed below. For a complete list of CoursePrerequisite class members, see the CoursePrerequisite Members topic.

Public Instance Fields

CourseID
CourseName
DateCompleted
Status
StudentStatus
Type
Units

See Also

CoursePrerequisite Class | Aptify.Applications.Education Namespace


CoursePrerequisite.CourseID Field

public CourseID CourseID;

See Also

CoursePrerequisite Class | Aptify.Applications.Education Namespace


CoursePrerequisite.CourseName Field

public CourseName CourseName;

See Also

CoursePrerequisite Class | Aptify.Applications.Education Namespace


CoursePrerequisite.DateCompleted Field

public DateCompleted DateCompleted;

See Also

CoursePrerequisite Class | Aptify.Applications.Education Namespace


CoursePrerequisite.Status Field

public Status Status;

See Also

CoursePrerequisite Class | Aptify.Applications.Education Namespace


CoursePrerequisite.StudentStatus Field

public StudentStatus StudentStatus;

See Also

CoursePrerequisite Class | Aptify.Applications.Education Namespace


CoursePrerequisite.Type Field

public Type Type;

See Also

CoursePrerequisite Class | Aptify.Applications.Education Namespace


CoursePrerequisite.Units Field

public Units Units;

See Also

CoursePrerequisite Class | Aptify.Applications.Education Namespace


CoursePrerequisite Properties

The properties of the CoursePrerequisite class are listed below. For a complete list of CoursePrerequisite class members, see the CoursePrerequisite Members topic.

Public Instance Properties

ValidationMessage | Returns a validation message, see ValidationResult for more information on this property.
ValidationResult | This method returns True if the student meets the requirements for the specified item, False otherwise. If the method returns False, check the ValidationMessage property for details. When True is returned, there may be text in the ValidationMessage property as well since there maybe optional or co-requisite items that have messages that do not prevent validation but can be useful in presentation to a user or otherwise.

See Also

CoursePrerequisite Class | Aptify.Applications.Education Namespace


ValidationMessage Property

Aptify 5.0 Software Development Kit (SDK)

CoursePrerequisite.ValidationMessage Property

Returns a validation message, see ValidationResult for more information on this property.

public String ValidationMessage {get;}

Property Value

Remarks

See Also

CoursePrerequisite Class | Aptify.Applications.Education Namespace


ValidationResult Property

Aptify 5.0 Software Development Kit (SDK)

CoursePrerequisite.ValidationResult Property

This method returns True if the student meets the requirements for the specified item, False otherwise. If the method returns False, check the ValidationMessage property for details. When True is returned, there may be text in the ValidationMessage property as well since there maybe optional or co-requisite items that have messages that do not prevent validation but can be useful in presentation to a user or otherwise.

public Boolean ValidationResult {get;}

Property Value

Remarks

See Also

CoursePrerequisite Class | Aptify.Applications.Education Namespace


CoursePrerequisite.PrerequisiteStatus Enumeration

public enum CoursePrerequisite.PrerequisiteStatus

Members

Member Name | Description
Current |
Inactive |

Requirements

Namespace: Aptify.Applications.Education

Assembly: ClassRegistrationGE (in ClassRegistrationGE.dll)

See Also

Aptify.Applications.Education Namespace


CoursePrerequisite.PrerequisiteStudentStatus Enumeration

public enum CoursePrerequisite.PrerequisiteStudentStatus

Members

Member Name | Description
NotStarted |
Registered |
InProgress |
Withdrawal |
Passed |
Failed |

Requirements

Namespace: Aptify.Applications.Education

Assembly: ClassRegistrationGE (in ClassRegistrationGE.dll)

See Also

Aptify.Applications.Education Namespace


CoursePrerequisite.PrerequisiteType Enumeration

public enum CoursePrerequisite.PrerequisiteType

Members

Member Name | Description
Optional |
Prerequisite |
Corequisite |

Requirements

Namespace: Aptify.Applications.Education

Assembly: ClassRegistrationGE (in ClassRegistrationGE.dll)

See Also

Aptify.Applications.Education Namespace


CurriculumApplication Class

For a list of all members of this type, see CurriculumApplication Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
CurriculumApplication

public class CurriculumApplication : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Education

Assembly: CurriculumApplication (in CurriculumApplication.dll)

See Also

CurriculumApplication Members | Aptify.Applications.Education Namespace


CurriculumApplication Members

CurriculumApplication overview

Public Instance Constructors

CurriculumApplication Constructor Initializes a new instance of the CurriculumApplication class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
CategoryRequirements |
Certifications |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CourseRequirements |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
CurriculumName |
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.
ValidationResult | Determines status of curriculum progress.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config | Overloaded.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

bValidated
InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
m_ValidationResult
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
LoadCategoryRequirements |
LoadCertifications |
LoadCurriculumCourseRequirements |
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

Protected Internal Instance Properties

CurriculumSchools

See Also

CurriculumApplication Class | Aptify.Applications.Education Namespace


CurriculumApplication Constructor

Initializes a new instance of the CurriculumApplication class.

public CurriculumApplication();

See Also

CurriculumApplication Class | Aptify.Applications.Education Namespace


CurriculumApplication Fields

The fields of the CurriculumApplication class are listed below. For a complete list of CurriculumApplication class members, see the CurriculumApplication Members topic.

Protected Instance Fields

bValidated
InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
m_ValidationResult
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

See Also

CurriculumApplication Class | Aptify.Applications.Education Namespace


CurriculumApplication.bValidated Field

protected bValidated bValidated;

See Also

CurriculumApplication Class | Aptify.Applications.Education Namespace


CurriculumApplication.m_ValidationResult Field

protected m_ValidationResult m_ValidationResult;

See Also

CurriculumApplication Class | Aptify.Applications.Education Namespace


CurriculumApplication Properties

The properties of the CurriculumApplication class are listed below. For a complete list of CurriculumApplication class members, see the CurriculumApplication Members topic.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
CategoryRequirements |
Certifications |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CourseRequirements |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
CurriculumName |
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.
ValidationResult | Determines status of curriculum progress.

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Internal Instance Properties

CurriculumSchools

See Also

CurriculumApplication Class | Aptify.Applications.Education Namespace


CategoryRequirements Property

Aptify 5.0 Software Development Kit (SDK)

CurriculumApplication.CategoryRequirements Property

public CurriculumApplication.CurriculumCategoryRequirements CategoryRequirements {get;}

See Also

CurriculumApplication Class | Aptify.Applications.Education Namespace


Certifications Property

Aptify 5.0 Software Development Kit (SDK)

CurriculumApplication.Certifications Property

public CurriculumApplication.StudentCertifications Certifications {get;}

See Also

CurriculumApplication Class | Aptify.Applications.Education Namespace


CourseRequirements Property

Aptify 5.0 Software Development Kit (SDK)

CurriculumApplication.CourseRequirements Property

public CurriculumApplication.CurriculumCourseRequirements CourseRequirements {get;}

See Also

CurriculumApplication Class | Aptify.Applications.Education Namespace


CurriculumName Property

Aptify 5.0 Software Development Kit (SDK)

CurriculumApplication.CurriculumName Property

public String CurriculumName {get;}

See Also

CurriculumApplication Class | Aptify.Applications.Education Namespace


CurriculumSchools Property

Aptify 5.0 Software Development Kit (SDK)

CurriculumApplication.CurriculumSchools Property

protected internal AptifyCollection CurriculumSchools {get;}

See Also

CurriculumApplication Class | Aptify.Applications.Education Namespace


ValidationResult Property

Aptify 5.0 Software Development Kit (SDK)

CurriculumApplication.ValidationResult Property

Determines status of curriculum progress.

public virtual CurriculumApplication.CurriculumApplicationStatus ValidationResult {get;}

Property Value

Remarks

See Also

CurriculumApplication Class | Aptify.Applications.Education Namespace


CurriculumApplication Methods

The methods of the CurriculumApplication class are listed below. For a complete list of CurriculumApplication class members, see the CurriculumApplication Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config | Overloaded.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
LoadCategoryRequirements |
LoadCertifications |
LoadCurriculumCourseRequirements |
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

CurriculumApplication Class | Aptify.Applications.Education Namespace


Config Method

Aptify 5.0 Software Development Kit (SDK)

CurriculumApplication.Config Method

Overload List

public void Config(AptifyApplication,Int64,Int64);

Inherited from AptifyGenericEntityBase.

public virtual void Config(AptifySubTypeBase);

Inherited from AptifyGenericEntity.

public override void Config(AptifySubTypeBase,Int64);

Inherited from AptifyGenericEntityBase.

public virtual void Config(UserCredentials,String);

Inherited from AptifyGenericEntity.

public override void Config(UserCredentials,String,Int64);

See Also

CurriculumApplication Class | Aptify.Applications.Education Namespace


CurriculumApplication.Config Method (AptifyApplication, Int64, Int64)

public void Config(
AptifyApplication AptifyApplication,
Int64 CurriculumID,
Int64 PersonID
);

See Also

CurriculumApplication Class | Aptify.Applications.Education Namespace | CurriculumApplication.Config Overload List


CurriculumApplication.LoadCategoryRequirements Method

protected virtual void LoadCategoryRequirements();

See Also

CurriculumApplication Class | Aptify.Applications.Education Namespace


CurriculumApplication.LoadCertifications Method

protected virtual void LoadCertifications();

See Also

CurriculumApplication Class | Aptify.Applications.Education Namespace


CurriculumApplication.LoadCurriculumCourseRequirements Method

protected virtual void LoadCurriculumCourseRequirements();

See Also

CurriculumApplication Class | Aptify.Applications.Education Namespace


CurriculumApplication.CurriculumApplicationStatus Enumeration

public enum CurriculumApplication.CurriculumApplicationStatus

Members

Member Name | Description
Approved |
Denied |
OnHold |
ConditionalApproval |

Requirements

Namespace: Aptify.Applications.Education

Assembly: CurriculumApplication (in CurriculumApplication.dll)

See Also

Aptify.Applications.Education Namespace


CurriculumApplication.CurriculumCategoryRequirements Class

For a list of all members of this type, see CurriculumApplication.CurriculumCategoryRequirements Members.

System.Object
NameObjectCollectionBase
AptifyCollection
CurriculumApplication.CurriculumCategoryRequirements

public class CurriculumApplication.CurriculumCategoryRequirements : AptifyCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Education

Assembly: CurriculumApplication (in CurriculumApplication.dll)

See Also

CurriculumApplication.CurriculumCategoryRequirements Members | Aptify.Applications.Education Namespace


CurriculumApplication.CurriculumCategoryRequirements Members

CurriculumApplication.CurriculumCategoryRequirements overview

Public Instance Properties

Count (inherited from NameObjectCollectionBase) | Gets the number of key/value pairs contained in the NameObjectCollectionBase instance.
Item | Overloaded.
Keys (inherited from NameObjectCollectionBase) | Gets a KeysCollection instance that contains all the keys in the NameObjectCollectionBase instance.

Public Instance Methods

Add | Overloaded.
Clear (inherited from AptifyCollection) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from AptifyCollection) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from NameObjectCollectionBase) | Implements the ISerializable interface and returns the data needed to serialize the NameObjectCollectionBase instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from AptifyCollection) | Gets the index of the item with the specified Key.
Merge (inherited from AptifyCollection) | Allows a user to merge items from another collection to this collection.
OnDeserialization (inherited from NameObjectCollectionBase) | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete.
Remove (inherited from AptifyCollection) | Overloaded.
RemoveAt (inherited from AptifyCollection) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

IsReadOnly (inherited from NameObjectCollectionBase) Gets or sets a value indicating whether the NameObjectCollectionBase instance is read-only.

Protected Instance Methods

BaseAdd (inherited from NameObjectCollectionBase) | Adds an entry with the specified key and value into the NameObjectCollectionBase instance.
BaseClear (inherited from NameObjectCollectionBase) | Removes all entries from the NameObjectCollectionBase instance.
BaseGet (inherited from NameObjectCollectionBase) | Overloaded. Gets the value of the first entry with the specified key from the NameObjectCollectionBase instance.
BaseGetAllKeys (inherited from NameObjectCollectionBase) | Returns a String array that contains all the keys in the NameObjectCollectionBase instance.
BaseGetAllValues (inherited from NameObjectCollectionBase) | Overloaded. Returns an Object array that contains all the values in the NameObjectCollectionBase instance.
BaseGetKey (inherited from NameObjectCollectionBase) | Gets the key of the entry at the specified index of the NameObjectCollectionBase instance.
BaseHasKeys (inherited from NameObjectCollectionBase) | Gets a value indicating whether the NameObjectCollectionBase instance contains entries whose keys are not null.
BaseRemove (inherited from NameObjectCollectionBase) | Removes the entries with the specified key from the NameObjectCollectionBase instance.
BaseRemoveAt (inherited from NameObjectCollectionBase) | Removes the entry at the specified index of the NameObjectCollectionBase instance.
BaseSet (inherited from NameObjectCollectionBase) | Overloaded. Sets the value of the first entry with the specified key in the NameObjectCollectionBase instance, if found; otherwise, adds an entry with the specified key and value into the NameObjectCollectionBase instance.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Constructors

CurriculumApplication.CurriculumCategoryRequirements Constructor Initializes a new instance of the CurriculumApplication.CurriculumCategoryRequirements class.

See Also

CurriculumApplication.CurriculumCategoryRequirements Class | Aptify.Applications.Education Namespace


CurriculumApplication.CurriculumCategoryRequirements Constructor

Initializes a new instance of the CurriculumApplication.CurriculumCategoryRequirements class.

protected internal CurriculumApplication.CurriculumCategoryRequirements();

See Also

CurriculumApplication.CurriculumCategoryRequirements Class | Aptify.Applications.Education Namespace


CurriculumApplication.CurriculumCategoryRequirements Properties

The properties of the CurriculumApplication.CurriculumCategoryRequirements class are listed below. For a complete list of CurriculumApplication.CurriculumCategoryRequirements class members, see the CurriculumApplication.CurriculumCategoryRequirements Members topic.

Public Instance Properties

Count (inherited from NameObjectCollectionBase) | Gets the number of key/value pairs contained in the NameObjectCollectionBase instance.
Item | Overloaded.
Keys (inherited from NameObjectCollectionBase) | Gets a KeysCollection instance that contains all the keys in the NameObjectCollectionBase instance.

Protected Instance Properties

IsReadOnly (inherited from NameObjectCollectionBase) Gets or sets a value indicating whether the NameObjectCollectionBase instance is read-only.

See Also

CurriculumApplication.CurriculumCategoryRequirements Class | Aptify.Applications.Education Namespace


CurriculumCategoryRequirement Property

Aptify 5.0 Software Development Kit (SDK)

CurriculumApplication.CurriculumCategoryRequirements.CurriculumCategoryRequirement Property

Overload List

public virtual CurriculumCategoryRequirement this[Int32] {get; set;}

public virtual CurriculumCategoryRequirement this[String] {get; set;}

See Also

CurriculumApplication.CurriculumCategoryRequirements Class | Aptify.Applications.Education Namespace


Item Property (Int32)

Aptify 5.0 Software Development Kit (SDK)

CurriculumApplication.CurriculumCategoryRequirements.Item Property (Int32)

public virtual CurriculumCategoryRequirement this[
Int32 Index
] {get; set;}

See Also

CurriculumApplication.CurriculumCategoryRequirements Class | Aptify.Applications.Education Namespace | CurriculumApplication.CurriculumCategoryRequirements.CurriculumCategoryRequirement Overload List


Item Property (String)

Aptify 5.0 Software Development Kit (SDK)

CurriculumApplication.CurriculumCategoryRequirements.Item Property (String)

public virtual CurriculumCategoryRequirement this[
String Key
] {get; set;}

See Also

CurriculumApplication.CurriculumCategoryRequirements Class | Aptify.Applications.Education Namespace | CurriculumApplication.CurriculumCategoryRequirements.CurriculumCategoryRequirement Overload List


CurriculumApplication.CurriculumCategoryRequirements Methods

The methods of the CurriculumApplication.CurriculumCategoryRequirements class are listed below. For a complete list of CurriculumApplication.CurriculumCategoryRequirements class members, see the CurriculumApplication.CurriculumCategoryRequirements Members topic.

Public Instance Methods

Add | Overloaded.
Clear (inherited from AptifyCollection) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from AptifyCollection) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from NameObjectCollectionBase) | Implements the ISerializable interface and returns the data needed to serialize the NameObjectCollectionBase instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from AptifyCollection) | Gets the index of the item with the specified Key.
Merge (inherited from AptifyCollection) | Allows a user to merge items from another collection to this collection.
OnDeserialization (inherited from NameObjectCollectionBase) | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete.
Remove (inherited from AptifyCollection) | Overloaded.
RemoveAt (inherited from AptifyCollection) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

BaseAdd (inherited from NameObjectCollectionBase) | Adds an entry with the specified key and value into the NameObjectCollectionBase instance.
BaseClear (inherited from NameObjectCollectionBase) | Removes all entries from the NameObjectCollectionBase instance.
BaseGet (inherited from NameObjectCollectionBase) | Overloaded. Gets the value of the first entry with the specified key from the NameObjectCollectionBase instance.
BaseGetAllKeys (inherited from NameObjectCollectionBase) | Returns a String array that contains all the keys in the NameObjectCollectionBase instance.
BaseGetAllValues (inherited from NameObjectCollectionBase) | Overloaded. Returns an Object array that contains all the values in the NameObjectCollectionBase instance.
BaseGetKey (inherited from NameObjectCollectionBase) | Gets the key of the entry at the specified index of the NameObjectCollectionBase instance.
BaseHasKeys (inherited from NameObjectCollectionBase) | Gets a value indicating whether the NameObjectCollectionBase instance contains entries whose keys are not null.
BaseRemove (inherited from NameObjectCollectionBase) | Removes the entries with the specified key from the NameObjectCollectionBase instance.
BaseRemoveAt (inherited from NameObjectCollectionBase) | Removes the entry at the specified index of the NameObjectCollectionBase instance.
BaseSet (inherited from NameObjectCollectionBase) | Overloaded. Sets the value of the first entry with the specified key in the NameObjectCollectionBase instance, if found; otherwise, adds an entry with the specified key and value into the NameObjectCollectionBase instance.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CurriculumApplication.CurriculumCategoryRequirements Class | Aptify.Applications.Education Namespace


Add Method

Aptify 5.0 Software Development Kit (SDK)

CurriculumApplication.CurriculumCategoryRequirements.Add Method

Overload List

public virtual int Add(CurriculumCategoryRequirement);

public virtual int Add(CurriculumCategoryRequirement,String);

public override int Add(Object);

public override int Add(Object,String);

See Also

CurriculumApplication.CurriculumCategoryRequirements Class | Aptify.Applications.Education Namespace


CurriculumApplication.CurriculumCategoryRequirements.Add Method (CurriculumCategoryRequirement)

public virtual int Add(
CurriculumCategoryRequirement Value
);

See Also

CurriculumApplication.CurriculumCategoryRequirements Class | Aptify.Applications.Education Namespace | CurriculumApplication.CurriculumCategoryRequirements.Add Overload List


CurriculumApplication.CurriculumCategoryRequirements.Add Method (CurriculumCategoryRequirement, String)

public virtual int Add(
CurriculumCategoryRequirement Value,
String Key
);

See Also

CurriculumApplication.CurriculumCategoryRequirements Class | Aptify.Applications.Education Namespace | CurriculumApplication.CurriculumCategoryRequirements.Add Overload List


CurriculumApplication.CurriculumCategoryRequirements.Add Method (Object)

public override int Add(
Object Value
);

See Also

CurriculumApplication.CurriculumCategoryRequirements Class | Aptify.Applications.Education Namespace | CurriculumApplication.CurriculumCategoryRequirements.Add Overload List


CurriculumApplication.CurriculumCategoryRequirements.Add Method (Object, String)

public override int Add(
Object Value,
String Key
);

See Also

CurriculumApplication.CurriculumCategoryRequirements Class | Aptify.Applications.Education Namespace | CurriculumApplication.CurriculumCategoryRequirements.Add Overload List


CurriculumApplication.CurriculumCourseRequirements Class

For a list of all members of this type, see CurriculumApplication.CurriculumCourseRequirements Members.

System.Object
NameObjectCollectionBase
AptifyCollection
CurriculumApplication.CurriculumCourseRequirements

public class CurriculumApplication.CurriculumCourseRequirements : AptifyCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Education

Assembly: CurriculumApplication (in CurriculumApplication.dll)

See Also

CurriculumApplication.CurriculumCourseRequirements Members | Aptify.Applications.Education Namespace


CurriculumApplication.CurriculumCourseRequirements Members

CurriculumApplication.CurriculumCourseRequirements overview

Public Instance Properties

Count (inherited from NameObjectCollectionBase) | Gets the number of key/value pairs contained in the NameObjectCollectionBase instance.
Item | Overloaded.
Keys (inherited from NameObjectCollectionBase) | Gets a KeysCollection instance that contains all the keys in the NameObjectCollectionBase instance.

Public Instance Methods

Add | Overloaded.
Clear (inherited from AptifyCollection) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from AptifyCollection) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from NameObjectCollectionBase) | Implements the ISerializable interface and returns the data needed to serialize the NameObjectCollectionBase instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from AptifyCollection) | Gets the index of the item with the specified Key.
Merge (inherited from AptifyCollection) | Allows a user to merge items from another collection to this collection.
OnDeserialization (inherited from NameObjectCollectionBase) | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete.
Remove (inherited from AptifyCollection) | Overloaded.
RemoveAt (inherited from AptifyCollection) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

IsReadOnly (inherited from NameObjectCollectionBase) Gets or sets a value indicating whether the NameObjectCollectionBase instance is read-only.

Protected Instance Methods

BaseAdd (inherited from NameObjectCollectionBase) | Adds an entry with the specified key and value into the NameObjectCollectionBase instance.
BaseClear (inherited from NameObjectCollectionBase) | Removes all entries from the NameObjectCollectionBase instance.
BaseGet (inherited from NameObjectCollectionBase) | Overloaded. Gets the value of the first entry with the specified key from the NameObjectCollectionBase instance.
BaseGetAllKeys (inherited from NameObjectCollectionBase) | Returns a String array that contains all the keys in the NameObjectCollectionBase instance.
BaseGetAllValues (inherited from NameObjectCollectionBase) | Overloaded. Returns an Object array that contains all the values in the NameObjectCollectionBase instance.
BaseGetKey (inherited from NameObjectCollectionBase) | Gets the key of the entry at the specified index of the NameObjectCollectionBase instance.
BaseHasKeys (inherited from NameObjectCollectionBase) | Gets a value indicating whether the NameObjectCollectionBase instance contains entries whose keys are not null.
BaseRemove (inherited from NameObjectCollectionBase) | Removes the entries with the specified key from the NameObjectCollectionBase instance.
BaseRemoveAt (inherited from NameObjectCollectionBase) | Removes the entry at the specified index of the NameObjectCollectionBase instance.
BaseSet (inherited from NameObjectCollectionBase) | Overloaded. Sets the value of the first entry with the specified key in the NameObjectCollectionBase instance, if found; otherwise, adds an entry with the specified key and value into the NameObjectCollectionBase instance.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Constructors

CurriculumApplication.CurriculumCourseRequirements Constructor Initializes a new instance of the CurriculumApplication.CurriculumCourseRequirements class.

See Also

CurriculumApplication.CurriculumCourseRequirements Class | Aptify.Applications.Education Namespace


CurriculumApplication.CurriculumCourseRequirements Constructor

Initializes a new instance of the CurriculumApplication.CurriculumCourseRequirements class.

protected internal CurriculumApplication.CurriculumCourseRequirements();

See Also

CurriculumApplication.CurriculumCourseRequirements Class | Aptify.Applications.Education Namespace


CurriculumApplication.CurriculumCourseRequirements Properties

The properties of the CurriculumApplication.CurriculumCourseRequirements class are listed below. For a complete list of CurriculumApplication.CurriculumCourseRequirements class members, see the CurriculumApplication.CurriculumCourseRequirements Members topic.

Public Instance Properties

Count (inherited from NameObjectCollectionBase) | Gets the number of key/value pairs contained in the NameObjectCollectionBase instance.
Item | Overloaded.
Keys (inherited from NameObjectCollectionBase) | Gets a KeysCollection instance that contains all the keys in the NameObjectCollectionBase instance.

Protected Instance Properties

IsReadOnly (inherited from NameObjectCollectionBase) Gets or sets a value indicating whether the NameObjectCollectionBase instance is read-only.

See Also

CurriculumApplication.CurriculumCourseRequirements Class | Aptify.Applications.Education Namespace


CurriculumCourseRequirement Property

Aptify 5.0 Software Development Kit (SDK)

CurriculumApplication.CurriculumCourseRequirements.CurriculumCourseRequirement Property

Overload List

public virtual CurriculumCourseRequirement this[Int32] {get; set;}

public virtual CurriculumCourseRequirement this[String] {get; set;}

See Also

CurriculumApplication.CurriculumCourseRequirements Class | Aptify.Applications.Education Namespace


Item Property (Int32)

Aptify 5.0 Software Development Kit (SDK)

CurriculumApplication.CurriculumCourseRequirements.Item Property (Int32)

public virtual CurriculumCourseRequirement this[
Int32 Index
] {get; set;}

See Also

CurriculumApplication.CurriculumCourseRequirements Class | Aptify.Applications.Education Namespace | CurriculumApplication.CurriculumCourseRequirements.CurriculumCourseRequirement Overload List


Item Property (String)

Aptify 5.0 Software Development Kit (SDK)

CurriculumApplication.CurriculumCourseRequirements.Item Property (String)

public virtual CurriculumCourseRequirement this[
String Key
] {get; set;}

See Also

CurriculumApplication.CurriculumCourseRequirements Class | Aptify.Applications.Education Namespace | CurriculumApplication.CurriculumCourseRequirements.CurriculumCourseRequirement Overload List


CurriculumApplication.CurriculumCourseRequirements Methods

The methods of the CurriculumApplication.CurriculumCourseRequirements class are listed below. For a complete list of CurriculumApplication.CurriculumCourseRequirements class members, see the CurriculumApplication.CurriculumCourseRequirements Members topic.

Public Instance Methods

Add | Overloaded.
Clear (inherited from AptifyCollection) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from AptifyCollection) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from NameObjectCollectionBase) | Implements the ISerializable interface and returns the data needed to serialize the NameObjectCollectionBase instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from AptifyCollection) | Gets the index of the item with the specified Key.
Merge (inherited from AptifyCollection) | Allows a user to merge items from another collection to this collection.
OnDeserialization (inherited from NameObjectCollectionBase) | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete.
Remove (inherited from AptifyCollection) | Overloaded.
RemoveAt (inherited from AptifyCollection) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

BaseAdd (inherited from NameObjectCollectionBase) | Adds an entry with the specified key and value into the NameObjectCollectionBase instance.
BaseClear (inherited from NameObjectCollectionBase) | Removes all entries from the NameObjectCollectionBase instance.
BaseGet (inherited from NameObjectCollectionBase) | Overloaded. Gets the value of the first entry with the specified key from the NameObjectCollectionBase instance.
BaseGetAllKeys (inherited from NameObjectCollectionBase) | Returns a String array that contains all the keys in the NameObjectCollectionBase instance.
BaseGetAllValues (inherited from NameObjectCollectionBase) | Overloaded. Returns an Object array that contains all the values in the NameObjectCollectionBase instance.
BaseGetKey (inherited from NameObjectCollectionBase) | Gets the key of the entry at the specified index of the NameObjectCollectionBase instance.
BaseHasKeys (inherited from NameObjectCollectionBase) | Gets a value indicating whether the NameObjectCollectionBase instance contains entries whose keys are not null.
BaseRemove (inherited from NameObjectCollectionBase) | Removes the entries with the specified key from the NameObjectCollectionBase instance.
BaseRemoveAt (inherited from NameObjectCollectionBase) | Removes the entry at the specified index of the NameObjectCollectionBase instance.
BaseSet (inherited from NameObjectCollectionBase) | Overloaded. Sets the value of the first entry with the specified key in the NameObjectCollectionBase instance, if found; otherwise, adds an entry with the specified key and value into the NameObjectCollectionBase instance.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CurriculumApplication.CurriculumCourseRequirements Class | Aptify.Applications.Education Namespace


Add Method

Aptify 5.0 Software Development Kit (SDK)

CurriculumApplication.CurriculumCourseRequirements.Add Method

Overload List

public virtual int Add(CurriculumCourseRequirement);

public virtual int Add(CurriculumCourseRequirement,String);

public override int Add(Object);

public override int Add(Object,String);

See Also

CurriculumApplication.CurriculumCourseRequirements Class | Aptify.Applications.Education Namespace


CurriculumApplication.CurriculumCourseRequirements.Add Method (CurriculumCourseRequirement)

public virtual int Add(
CurriculumCourseRequirement Value
);

See Also

CurriculumApplication.CurriculumCourseRequirements Class | Aptify.Applications.Education Namespace | CurriculumApplication.CurriculumCourseRequirements.Add Overload List


CurriculumApplication.CurriculumCourseRequirements.Add Method (CurriculumCourseRequirement, String)

public virtual int Add(
CurriculumCourseRequirement Value,
String Key
);

See Also

CurriculumApplication.CurriculumCourseRequirements Class | Aptify.Applications.Education Namespace | CurriculumApplication.CurriculumCourseRequirements.Add Overload List


CurriculumApplication.CurriculumCourseRequirements.Add Method (Object)

public override int Add(
Object Value
);

See Also

CurriculumApplication.CurriculumCourseRequirements Class | Aptify.Applications.Education Namespace | CurriculumApplication.CurriculumCourseRequirements.Add Overload List


CurriculumApplication.CurriculumCourseRequirements.Add Method (Object, String)

public override int Add(
Object Value,
String Key
);

See Also

CurriculumApplication.CurriculumCourseRequirements Class | Aptify.Applications.Education Namespace | CurriculumApplication.CurriculumCourseRequirements.Add Overload List


CurriculumApplication.StudentCertifications Class

For a list of all members of this type, see CurriculumApplication.StudentCertifications Members.

System.Object
NameObjectCollectionBase
AptifyCollection
CurriculumApplication.StudentCertifications

public class CurriculumApplication.StudentCertifications : AptifyCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Education

Assembly: CurriculumApplication (in CurriculumApplication.dll)

See Also

CurriculumApplication.StudentCertifications Members | Aptify.Applications.Education Namespace


CurriculumApplication.StudentCertifications Members

CurriculumApplication.StudentCertifications overview

Public Instance Properties

Count (inherited from NameObjectCollectionBase) | Gets the number of key/value pairs contained in the NameObjectCollectionBase instance.
Item | Overloaded.
Keys (inherited from NameObjectCollectionBase) | Gets a KeysCollection instance that contains all the keys in the NameObjectCollectionBase instance.

Public Instance Methods

Add | Overloaded.
Clear (inherited from AptifyCollection) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from AptifyCollection) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from NameObjectCollectionBase) | Implements the ISerializable interface and returns the data needed to serialize the NameObjectCollectionBase instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from AptifyCollection) | Gets the index of the item with the specified Key.
Merge (inherited from AptifyCollection) | Allows a user to merge items from another collection to this collection.
OnDeserialization (inherited from NameObjectCollectionBase) | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete.
Remove (inherited from AptifyCollection) | Overloaded.
RemoveAt (inherited from AptifyCollection) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

IsReadOnly (inherited from NameObjectCollectionBase) Gets or sets a value indicating whether the NameObjectCollectionBase instance is read-only.

Protected Instance Methods

BaseAdd (inherited from NameObjectCollectionBase) | Adds an entry with the specified key and value into the NameObjectCollectionBase instance.
BaseClear (inherited from NameObjectCollectionBase) | Removes all entries from the NameObjectCollectionBase instance.
BaseGet (inherited from NameObjectCollectionBase) | Overloaded. Gets the value of the first entry with the specified key from the NameObjectCollectionBase instance.
BaseGetAllKeys (inherited from NameObjectCollectionBase) | Returns a String array that contains all the keys in the NameObjectCollectionBase instance.
BaseGetAllValues (inherited from NameObjectCollectionBase) | Overloaded. Returns an Object array that contains all the values in the NameObjectCollectionBase instance.
BaseGetKey (inherited from NameObjectCollectionBase) | Gets the key of the entry at the specified index of the NameObjectCollectionBase instance.
BaseHasKeys (inherited from NameObjectCollectionBase) | Gets a value indicating whether the NameObjectCollectionBase instance contains entries whose keys are not null.
BaseRemove (inherited from NameObjectCollectionBase) | Removes the entries with the specified key from the NameObjectCollectionBase instance.
BaseRemoveAt (inherited from NameObjectCollectionBase) | Removes the entry at the specified index of the NameObjectCollectionBase instance.
BaseSet (inherited from NameObjectCollectionBase) | Overloaded. Sets the value of the first entry with the specified key in the NameObjectCollectionBase instance, if found; otherwise, adds an entry with the specified key and value into the NameObjectCollectionBase instance.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Constructors

CurriculumApplication.StudentCertifications Constructor Initializes a new instance of the CurriculumApplication.StudentCertifications class.

See Also

CurriculumApplication.StudentCertifications Class | Aptify.Applications.Education Namespace


CurriculumApplication.StudentCertifications Constructor

Initializes a new instance of the CurriculumApplication.StudentCertifications class.

protected internal CurriculumApplication.StudentCertifications();

See Also

CurriculumApplication.StudentCertifications Class | Aptify.Applications.Education Namespace


CurriculumApplication.StudentCertifications Properties

The properties of the CurriculumApplication.StudentCertifications class are listed below. For a complete list of CurriculumApplication.StudentCertifications class members, see the CurriculumApplication.StudentCertifications Members topic.

Public Instance Properties

Count (inherited from NameObjectCollectionBase) | Gets the number of key/value pairs contained in the NameObjectCollectionBase instance.
Item | Overloaded.
Keys (inherited from NameObjectCollectionBase) | Gets a KeysCollection instance that contains all the keys in the NameObjectCollectionBase instance.

Protected Instance Properties

IsReadOnly (inherited from NameObjectCollectionBase) Gets or sets a value indicating whether the NameObjectCollectionBase instance is read-only.

See Also

CurriculumApplication.StudentCertifications Class | Aptify.Applications.Education Namespace


StudentCertification Property

Aptify 5.0 Software Development Kit (SDK)

CurriculumApplication.StudentCertifications.StudentCertification Property

Overload List

public virtual StudentCertification this[Int32] {get; set;}

public virtual StudentCertification this[String] {get; set;}

See Also

CurriculumApplication.StudentCertifications Class | Aptify.Applications.Education Namespace


Item Property (Int32)

Aptify 5.0 Software Development Kit (SDK)

CurriculumApplication.StudentCertifications.Item Property (Int32)

public virtual StudentCertification this[
Int32 Index
] {get; set;}

See Also

CurriculumApplication.StudentCertifications Class | Aptify.Applications.Education Namespace | CurriculumApplication.StudentCertifications.StudentCertification Overload List


Item Property (String)

Aptify 5.0 Software Development Kit (SDK)

CurriculumApplication.StudentCertifications.Item Property (String)

public virtual StudentCertification this[
String Key
] {get; set;}

See Also

CurriculumApplication.StudentCertifications Class | Aptify.Applications.Education Namespace | CurriculumApplication.StudentCertifications.StudentCertification Overload List


CurriculumApplication.StudentCertifications Methods

The methods of the CurriculumApplication.StudentCertifications class are listed below. For a complete list of CurriculumApplication.StudentCertifications class members, see the CurriculumApplication.StudentCertifications Members topic.

Public Instance Methods

Add | Overloaded.
Clear (inherited from AptifyCollection) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from AptifyCollection) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from NameObjectCollectionBase) | Implements the ISerializable interface and returns the data needed to serialize the NameObjectCollectionBase instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from AptifyCollection) | Gets the index of the item with the specified Key.
Merge (inherited from AptifyCollection) | Allows a user to merge items from another collection to this collection.
OnDeserialization (inherited from NameObjectCollectionBase) | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete.
Remove (inherited from AptifyCollection) | Overloaded.
RemoveAt (inherited from AptifyCollection) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

BaseAdd (inherited from NameObjectCollectionBase) | Adds an entry with the specified key and value into the NameObjectCollectionBase instance.
BaseClear (inherited from NameObjectCollectionBase) | Removes all entries from the NameObjectCollectionBase instance.
BaseGet (inherited from NameObjectCollectionBase) | Overloaded. Gets the value of the first entry with the specified key from the NameObjectCollectionBase instance.
BaseGetAllKeys (inherited from NameObjectCollectionBase) | Returns a String array that contains all the keys in the NameObjectCollectionBase instance.
BaseGetAllValues (inherited from NameObjectCollectionBase) | Overloaded. Returns an Object array that contains all the values in the NameObjectCollectionBase instance.
BaseGetKey (inherited from NameObjectCollectionBase) | Gets the key of the entry at the specified index of the NameObjectCollectionBase instance.
BaseHasKeys (inherited from NameObjectCollectionBase) | Gets a value indicating whether the NameObjectCollectionBase instance contains entries whose keys are not null.
BaseRemove (inherited from NameObjectCollectionBase) | Removes the entries with the specified key from the NameObjectCollectionBase instance.
BaseRemoveAt (inherited from NameObjectCollectionBase) | Removes the entry at the specified index of the NameObjectCollectionBase instance.
BaseSet (inherited from NameObjectCollectionBase) | Overloaded. Sets the value of the first entry with the specified key in the NameObjectCollectionBase instance, if found; otherwise, adds an entry with the specified key and value into the NameObjectCollectionBase instance.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CurriculumApplication.StudentCertifications Class | Aptify.Applications.Education Namespace


Add Method

Aptify 5.0 Software Development Kit (SDK)

CurriculumApplication.StudentCertifications.Add Method

Overload List

public virtual int Add(StudentCertification);

public virtual int Add(StudentCertification,String);

public override int Add(Object);

public override int Add(Object,String);

See Also

CurriculumApplication.StudentCertifications Class | Aptify.Applications.Education Namespace


CurriculumApplication.StudentCertifications.Add Method (StudentCertification)

public virtual int Add(
StudentCertification Value
);

See Also

CurriculumApplication.StudentCertifications Class | Aptify.Applications.Education Namespace | CurriculumApplication.StudentCertifications.Add Overload List


CurriculumApplication.StudentCertifications.Add Method (StudentCertification, String)

public virtual int Add(
StudentCertification Value,
String Key
);

See Also

CurriculumApplication.StudentCertifications Class | Aptify.Applications.Education Namespace | CurriculumApplication.StudentCertifications.Add Overload List


CurriculumApplication.StudentCertifications.Add Method (Object)

public override int Add(
Object Value
);

See Also

CurriculumApplication.StudentCertifications Class | Aptify.Applications.Education Namespace | CurriculumApplication.StudentCertifications.Add Overload List


CurriculumApplication.StudentCertifications.Add Method (Object, String)

public override int Add(
Object Value,
String Key
);

See Also

CurriculumApplication.StudentCertifications Class | Aptify.Applications.Education Namespace | CurriculumApplication.StudentCertifications.Add Overload List


CurriculumApplicationControl Class

For a list of all members of this type, see CurriculumApplicationControl Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
CurriculumApplicationControl

public class CurriculumApplicationControl : FormComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Education

Assembly: CurriculumApplication (in CurriculumApplication.dll)

See Also

CurriculumApplicationControl Members | Aptify.Applications.Education Namespace


CurriculumApplicationControl Members

CurriculumApplicationControl overview

Public Instance Constructors

CurriculumApplicationControl Constructor Initializes a new instance of the CurriculumApplicationControl class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormComponent) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateContext (inherited from FormComponent) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig | Initializes the Form Component's properties.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormComponent) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormComponent) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CurriculumApplicationControl Class | Aptify.Applications.Education Namespace


CurriculumApplicationControl Constructor

Initializes a new instance of the CurriculumApplicationControl class.

public CurriculumApplicationControl();

See Also

CurriculumApplicationControl Class | Aptify.Applications.Education Namespace


CurriculumApplicationControl Methods

The methods of the CurriculumApplicationControl class are listed below. For a complete list of CurriculumApplicationControl class members, see the CurriculumApplicationControl Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormComponent) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig | Initializes the Form Component's properties.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormComponent) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormComponent) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CurriculumApplicationControl Class | Aptify.Applications.Education Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

CurriculumApplicationControl.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

CurriculumApplicationControl Class | Aptify.Applications.Education Namespace


CurriculumApplicationControl.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

CurriculumApplicationControl Class | Aptify.Applications.Education Namespace | CurriculumApplicationControl.Dispose Overload List


CurriculumApplicationControl.OnFormComponentConfig Method

Initializes the Form Component's properties.

protected override void OnFormComponentConfig(
AptifyFormTemplateContext FormTemplateContext
);

Parameters

FormTemplateContext

Implements

IFormComponent.

Remarks

See Also

CurriculumApplicationControl Class | Aptify.Applications.Education Namespace


CurriculumApplicationControl.OnRefresh Method

protected override void OnRefresh();

Implements

IFormComponent.

See Also

CurriculumApplicationControl Class | Aptify.Applications.Education Namespace


OnShow Method

Aptify 5.0 Software Development Kit (SDK)

CurriculumApplicationControl.OnShow Method

Overload List

protected override void OnShow();

Inherited from FormComponent.

protected virtual void OnShow(Boolean);

See Also

CurriculumApplicationControl Class | Aptify.Applications.Education Namespace


CurriculumApplicationControl.OnShow Method ()

protected override void OnShow();

Implements

IFormComponent.

See Also

CurriculumApplicationControl Class | Aptify.Applications.Education Namespace | CurriculumApplicationControl.OnShow Overload List


CurriculumCategoryRequirement Class

Structure that stores information about a category requirement for a given Curriculum definition.

For a list of all members of this type, see CurriculumCategoryRequirement Members.

System.Object
CurriculumCategoryRequirement

public class CurriculumCategoryRequirement

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Education

Assembly: CurriculumApplication (in CurriculumApplication.dll)

See Also

CurriculumCategoryRequirement Members | Aptify.Applications.Education Namespace


CurriculumCategoryRequirement Members

CurriculumCategoryRequirement overview

Public Instance Properties

CourseCategoryID |
CourseCategoryName |
StudentCertifications |
Units |
ValidationResult | Returns count of units completed towards the curriculum category.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Constructors

CurriculumCategoryRequirement Constructor

Protected Internal Instance Fields

m_lCourseCategoryID
m_lCurriculumID
m_lUnits
m_oStudentCertifications
m_sCourseCategoryName

See Also

CurriculumCategoryRequirement Class | Aptify.Applications.Education Namespace


CurriculumCategoryRequirement Constructor

protected internal CurriculumCategoryRequirement(
Int64 CurriculumID
);

See Also

CurriculumCategoryRequirement Class | Aptify.Applications.Education Namespace


CurriculumCategoryRequirement Fields

The fields of the CurriculumCategoryRequirement class are listed below. For a complete list of CurriculumCategoryRequirement class members, see the CurriculumCategoryRequirement Members topic.

Protected Internal Instance Fields

m_lCourseCategoryID
m_lCurriculumID
m_lUnits
m_oStudentCertifications
m_sCourseCategoryName

See Also

CurriculumCategoryRequirement Class | Aptify.Applications.Education Namespace


CurriculumCategoryRequirement.m_lCourseCategoryID Field

protected internal m_lCourseCategoryID m_lCourseCategoryID;

See Also

CurriculumCategoryRequirement Class | Aptify.Applications.Education Namespace


CurriculumCategoryRequirement.m_lCurriculumID Field

protected internal m_lCurriculumID m_lCurriculumID;

See Also

CurriculumCategoryRequirement Class | Aptify.Applications.Education Namespace


CurriculumCategoryRequirement.m_lUnits Field

protected internal m_lUnits m_lUnits;

See Also

CurriculumCategoryRequirement Class | Aptify.Applications.Education Namespace


CurriculumCategoryRequirement.m_oStudentCertifications Field

protected internal m_oStudentCertifications m_oStudentCertifications;

See Also

CurriculumCategoryRequirement Class | Aptify.Applications.Education Namespace


CurriculumCategoryRequirement.m_sCourseCategoryName Field

protected internal m_sCourseCategoryName m_sCourseCategoryName;

See Also

CurriculumCategoryRequirement Class | Aptify.Applications.Education Namespace


CurriculumCategoryRequirement Properties

The properties of the CurriculumCategoryRequirement class are listed below. For a complete list of CurriculumCategoryRequirement class members, see the CurriculumCategoryRequirement Members topic.

Public Instance Properties

CourseCategoryID |
CourseCategoryName |
StudentCertifications |
Units |
ValidationResult | Returns count of units completed towards the curriculum category.

See Also

CurriculumCategoryRequirement Class | Aptify.Applications.Education Namespace


CourseCategoryID Property

Aptify 5.0 Software Development Kit (SDK)

CurriculumCategoryRequirement.CourseCategoryID Property

public Int64 CourseCategoryID {get;}

See Also

CurriculumCategoryRequirement Class | Aptify.Applications.Education Namespace


CourseCategoryName Property

Aptify 5.0 Software Development Kit (SDK)

CurriculumCategoryRequirement.CourseCategoryName Property

public String CourseCategoryName {get;}

See Also

CurriculumCategoryRequirement Class | Aptify.Applications.Education Namespace


StudentCertifications Property

Aptify 5.0 Software Development Kit (SDK)

CurriculumCategoryRequirement.StudentCertifications Property

public CurriculumApplication.StudentCertifications StudentCertifications {get;}

See Also

CurriculumCategoryRequirement Class | Aptify.Applications.Education Namespace


Units Property

Aptify 5.0 Software Development Kit (SDK)

CurriculumCategoryRequirement.Units Property

public Int64 Units {get;}

See Also

CurriculumCategoryRequirement Class | Aptify.Applications.Education Namespace


ValidationResult Property

Aptify 5.0 Software Development Kit (SDK)

CurriculumCategoryRequirement.ValidationResult Property

Returns count of units completed towards the curriculum category.

public virtual Int64 ValidationResult {get;}

Property Value

Remarks

See Also

CurriculumCategoryRequirement Class | Aptify.Applications.Education Namespace


CurriculumCourseRequirement Class

Structure that stores information about a course requirement for a given Curriculum definition.

For a list of all members of this type, see CurriculumCourseRequirement Members.

System.Object
CurriculumCourseRequirement

public class CurriculumCourseRequirement

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Education

Assembly: CurriculumApplication (in CurriculumApplication.dll)

See Also

CurriculumCourseRequirement Members | Aptify.Applications.Education Namespace


CurriculumCourseRequirement Members

CurriculumCourseRequirement overview

Public Instance Properties

CourseID |
CourseName |
CurriculumID |
StudentCertifications |
Units |
ValidationResult | This method returns the RequirementStudentStatus of the most recent instance of a class registration for the course.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Fields

bValidated
m_ValidationResult

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Constructors

CurriculumCourseRequirement Constructor

Protected Internal Instance Fields

m_lCourseID
m_lCurriculumID
m_lUnits
m_oStudentCertifications
m_sCourseName

See Also

CurriculumCourseRequirement Class | Aptify.Applications.Education Namespace


CurriculumCourseRequirement Constructor

protected internal CurriculumCourseRequirement(
Int64 CurriculumID
);

See Also

CurriculumCourseRequirement Class | Aptify.Applications.Education Namespace


CurriculumCourseRequirement Fields

The fields of the CurriculumCourseRequirement class are listed below. For a complete list of CurriculumCourseRequirement class members, see the CurriculumCourseRequirement Members topic.

Protected Instance Fields

bValidated
m_ValidationResult

Protected Internal Instance Fields

m_lCourseID
m_lCurriculumID
m_lUnits
m_oStudentCertifications
m_sCourseName

See Also

CurriculumCourseRequirement Class | Aptify.Applications.Education Namespace


CurriculumCourseRequirement.bValidated Field

protected bValidated bValidated;

See Also

CurriculumCourseRequirement Class | Aptify.Applications.Education Namespace


CurriculumCourseRequirement.m_lCourseID Field

protected internal m_lCourseID m_lCourseID;

See Also

CurriculumCourseRequirement Class | Aptify.Applications.Education Namespace


CurriculumCourseRequirement.m_lCurriculumID Field

protected internal m_lCurriculumID m_lCurriculumID;

See Also

CurriculumCourseRequirement Class | Aptify.Applications.Education Namespace


CurriculumCourseRequirement.m_lUnits Field

protected internal m_lUnits m_lUnits;

See Also

CurriculumCourseRequirement Class | Aptify.Applications.Education Namespace


CurriculumCourseRequirement.m_oStudentCertifications Field

protected internal m_oStudentCertifications m_oStudentCertifications;

See Also

CurriculumCourseRequirement Class | Aptify.Applications.Education Namespace


CurriculumCourseRequirement.m_sCourseName Field

protected internal m_sCourseName m_sCourseName;

See Also

CurriculumCourseRequirement Class | Aptify.Applications.Education Namespace


CurriculumCourseRequirement.m_ValidationResult Field

protected m_ValidationResult m_ValidationResult;

See Also

CurriculumCourseRequirement Class | Aptify.Applications.Education Namespace


CurriculumCourseRequirement Properties

The properties of the CurriculumCourseRequirement class are listed below. For a complete list of CurriculumCourseRequirement class members, see the CurriculumCourseRequirement Members topic.

Public Instance Properties

CourseID |
CourseName |
CurriculumID |
StudentCertifications |
Units |
ValidationResult | This method returns the RequirementStudentStatus of the most recent instance of a class registration for the course.

See Also

CurriculumCourseRequirement Class | Aptify.Applications.Education Namespace


CourseID Property

Aptify 5.0 Software Development Kit (SDK)

CurriculumCourseRequirement.CourseID Property

public Int64 CourseID {get;}

See Also

CurriculumCourseRequirement Class | Aptify.Applications.Education Namespace


CourseName Property

Aptify 5.0 Software Development Kit (SDK)

CurriculumCourseRequirement.CourseName Property

public String CourseName {get;}

See Also

CurriculumCourseRequirement Class | Aptify.Applications.Education Namespace


CurriculumID Property

Aptify 5.0 Software Development Kit (SDK)

CurriculumCourseRequirement.CurriculumID Property

public Int64 CurriculumID {get;}

See Also

CurriculumCourseRequirement Class | Aptify.Applications.Education Namespace


StudentCertifications Property

Aptify 5.0 Software Development Kit (SDK)

CurriculumCourseRequirement.StudentCertifications Property

public CurriculumApplication.StudentCertifications StudentCertifications {get;}

See Also

CurriculumCourseRequirement Class | Aptify.Applications.Education Namespace


Units Property

Aptify 5.0 Software Development Kit (SDK)

CurriculumCourseRequirement.Units Property

public Int64 Units {get;}

See Also

CurriculumCourseRequirement Class | Aptify.Applications.Education Namespace


ValidationResult Property

Aptify 5.0 Software Development Kit (SDK)

CurriculumCourseRequirement.ValidationResult Property

This method returns the RequirementStudentStatus of the most recent instance of a class registration for the course.

public virtual StudentCertification.RequirementStudentStatus ValidationResult {get;}

Property Value

Remarks

See Also

CurriculumCourseRequirement Class | Aptify.Applications.Education Namespace


EducationManagementScopeFilter Class

For a list of all members of this type, see EducationManagementScopeFilter Members.

System.Object
EducationManagementScopeFilter

public class EducationManagementScopeFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Education

Assembly: EducationManagementScopeFilter (in EducationManagementScopeFilter.dll)

See Also

EducationManagementScopeFilter Members | Aptify.Applications.Education Namespace


EducationManagementScopeFilter Members

EducationManagementScopeFilter overview

Public Instance Constructors

EducationManagementScopeFilter Overloaded. Initializes a new instance of the EducationManagementScopeFilter class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
EvaluateCourseFilter | Evaluates the PersonID against all the Course's Filter Rules.
EvaluateCourseFilterByCourseID | Evaluates the PersonID against all the Course's Filter Rules.
EvaluateCurriculumDefinitionFilter | Evaluates the PersonID against all the Curriculum Definitions' Filter Rules.
EvaluateCurriculumDefinitionFilterByCurrDefnID | Evaluates the PersonID against all the Curriculum Definitions' Filter Rules.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

EvaluateCurriculumDefinitionFilterRule | This method is responsible for executing a Curriculum Definitions' filter rule using the FilterRules engine and will return True if the specified Filter Rule Is applicable to the specified set of parameters.
ExecuteCourseFilterRule | This method is responsible for executing a Course's filter rule using the FilterRules engine and will return True if the specified Filter Rule Is applicable to the specified set of parameters.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetEntityInstanceUsedFields |
LoadEntityInstanceData |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EducationManagementScopeFilter Class | Aptify.Applications.Education Namespace


EducationManagementScopeFilter Constructor

Instantiates an object of type EducationManagementScopeFilter. Without passing in an instance of AptifyApplication, this constructor will attempt to create an instance on its own.

Overload List

Instantiates an object of type EducationManagementScopeFilter. Without passing in an instance of AptifyApplication, this constructor will attempt to create an instance on its own.

public EducationManagementScopeFilter();

Instantiates an object of type EducationManagementScopeFilter. Uses the AptifyApplication parameter to access the Aptify Database and Entity metadata.

public EducationManagementScopeFilter(AptifyApplication);

See Also

EducationManagementScopeFilter Class | Aptify.Applications.Education Namespace


EducationManagementScopeFilter Constructor ()

Instantiates an object of type EducationManagementScopeFilter. Without passing in an instance of AptifyApplication, this constructor will attempt to create an instance on its own.

public EducationManagementScopeFilter();

Remarks

See Also

EducationManagementScopeFilter Class | Aptify.Applications.Education Namespace | EducationManagementScopeFilter Constructor Overload List


EducationManagementScopeFilter Constructor (AptifyApplication)

Instantiates an object of type EducationManagementScopeFilter. Uses the AptifyApplication parameter to access the Aptify Database and Entity metadata.

public EducationManagementScopeFilter(
AptifyApplication Application
);

Parameters

Application

Remarks

See Also

EducationManagementScopeFilter Class | Aptify.Applications.Education Namespace | EducationManagementScopeFilter Constructor Overload List


EducationManagementScopeFilter Methods

The methods of the EducationManagementScopeFilter class are listed below. For a complete list of EducationManagementScopeFilter class members, see the EducationManagementScopeFilter Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
EvaluateCourseFilter | Evaluates the PersonID against all the Course's Filter Rules.
EvaluateCourseFilterByCourseID | Evaluates the PersonID against all the Course's Filter Rules.
EvaluateCurriculumDefinitionFilter | Evaluates the PersonID against all the Curriculum Definitions' Filter Rules.
EvaluateCurriculumDefinitionFilterByCurrDefnID | Evaluates the PersonID against all the Curriculum Definitions' Filter Rules.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

EvaluateCurriculumDefinitionFilterRule | This method is responsible for executing a Curriculum Definitions' filter rule using the FilterRules engine and will return True if the specified Filter Rule Is applicable to the specified set of parameters.
ExecuteCourseFilterRule | This method is responsible for executing a Course's filter rule using the FilterRules engine and will return True if the specified Filter Rule Is applicable to the specified set of parameters.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetEntityInstanceUsedFields |
LoadEntityInstanceData |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EducationManagementScopeFilter Class | Aptify.Applications.Education Namespace


EducationManagementScopeFilter.EvaluateCourseFilter Method

Evaluates the PersonID against all the Course's Filter Rules.

public virtual bool EvaluateCourseFilter(
Int64 FilterRuleID,
Int64 PersonID,
Int64 CompanyID
);

Parameters

FilterRuleID
Required field. This should be the FilterRuleID associated with the Course in question.
PersonID
Required field that will be used by the filter rule to determine if the Person is eligible for the Course.
CompanyID
Optional field. Must be the CompanyID that the PersonID is associated with. Will be used if the Filter Rule applies to the Person's Company. If not provided, the Person's CompanyID will be retrieved from the Persons record.

Return Value

True if the Person is qualified to view/use/take the Course. False if the Person is prohibited from the Course based on the Course's Filter Rule.

Remarks

See Also

EducationManagementScopeFilter Class | Aptify.Applications.Education Namespace


EducationManagementScopeFilter.EvaluateCourseFilterByCourseID Method

Evaluates the PersonID against all the Course's Filter Rules.

public virtual bool EvaluateCourseFilterByCourseID(
Int64 CourseID,
Int64 PersonID,
Int64 CompanyID
);

Parameters

CourseID
Required field. This is the Course to compare the PersonID to.
PersonID
Required field that will be used by the Course's filter rule to determine if the Person is eligible for the Course.
CompanyID

Return Value

True if the Person is qualified to view/use/take the Course. False if the Person is prohibited from the Course based on the Course's Filter Rule.

Remarks

See Also

EducationManagementScopeFilter Class | Aptify.Applications.Education Namespace


EducationManagementScopeFilter.EvaluateCurriculumDefinitionFilter Method

Evaluates the PersonID against all the Curriculum Definitions' Filter Rules.

public virtual bool EvaluateCurriculumDefinitionFilter(
Int64 FilterRuleID,
Int64 PersonID,
Int64 CompanyID
);

Parameters

FilterRuleID
Required field. This should be the FilterRuleID associated with the Curriculum Definitions in question.
PersonID
Required field that will be used by the filter rule to determine if the Person is eligible for the Curriculum.
CompanyID
Optional field. Must be the CompanyID that the PersonID is associated with. Will be used if the Filter Rule applies to the Person's Company. If not provided, the Person's CompanyID will be retrieved from the Persons record.

Return Value

True if the Person is qualified to view/use/take the Curriculum. False if the Person is prohibited from the Curriculum based on the Curriculum Definitions' Filter Rule.

Remarks

See Also

EducationManagementScopeFilter Class | Aptify.Applications.Education Namespace


EducationManagementScopeFilter.EvaluateCurriculumDefinitionFilterByCurrDefnID Method

Evaluates the PersonID against all the Curriculum Definitions' Filter Rules.

public virtual bool EvaluateCurriculumDefinitionFilterByCurrDefnID(
Int64 CurrDefnID,
Int64 PersonID,
Int64 CompanyID
);

Parameters

CurrDefnID
Required field. This is the Curriculum Definitions to compare the PersonID to.
PersonID
Required field that will be used by the Curriculum Definitions' filter rule to determine if the Person is eligible for the Curriculum Definitions.
CompanyID

Return Value

True if the Person is qualified to view/use/take the Curriculum Definitions. False if the Person is prohibited from the Curriculum Definitions based on the Curriculum Definitions' Filter Rule.

Remarks

See Also

EducationManagementScopeFilter Class | Aptify.Applications.Education Namespace


EducationManagementScopeFilter.EvaluateCurriculumDefinitionFilterRule Method

This method is responsible for executing a Curriculum Definitions' filter rule using the FilterRules engine and will return True if the specified Filter Rule Is applicable to the specified set of parameters.

protected virtual bool EvaluateCurriculumDefinitionFilterRule(
Int64 lFilterRuleID,
Int64 lPersonID,
Int64 lCompanyID,
Boolean RefreshCache
);

Return Value

Remarks

See Also

EducationManagementScopeFilter Class | Aptify.Applications.Education Namespace


EducationManagementScopeFilter.ExecuteCourseFilterRule Method

This method is responsible for executing a Course's filter rule using the FilterRules engine and will return True if the specified Filter Rule Is applicable to the specified set of parameters.

protected virtual bool ExecuteCourseFilterRule(
Int64 lFilterRuleID,
Int64 lPersonID,
Int64 lCompanyID,
Boolean RefreshCache
);

Return Value

Remarks

See Also

EducationManagementScopeFilter Class | Aptify.Applications.Education Namespace


EducationManagementScopeFilter.GetEntityInstanceUsedFields Method

protected virtual List<T> GetEntityInstanceUsedFields(
String EntityInstance,
FilterRule oFilterRule
);

See Also

EducationManagementScopeFilter Class | Aptify.Applications.Education Namespace


EducationManagementScopeFilter.LoadEntityInstanceData Method

protected virtual DataRow LoadEntityInstanceData(
String EntityInstance,
String EntityName,
Int64 InstanceRecordID,
FilterRule oFilterRule
);

See Also

EducationManagementScopeFilter Class | Aptify.Applications.Education Namespace


Exam Class

This class provides the implementation for base validation functionality for the Exams entity in the Aptify Education Management system.

For a list of all members of this type, see Exam Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
Exam

public class Exam : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Education

Assembly: Exam (in Exam.dll)

See Also

Exam Members | Aptify.Applications.Education Namespace


Exam Members

Exam overview

Public Instance Constructors

Exam Constructor Initializes a new instance of the Exam class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded. This method handles updating the NumberOfQuestions and NumberOfPoints fields which are stored statically in the database in order to improve querying performance since they are not frequently updated, but are queried upon very frequently.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

Exam Class | Aptify.Applications.Education Namespace


Exam Constructor

Initializes a new instance of the Exam class.

public Exam();

See Also

Exam Class | Aptify.Applications.Education Namespace


Exam Methods

The methods of the Exam class are listed below. For a complete list of Exam class members, see the Exam Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded. This method handles updating the NumberOfQuestions and NumberOfPoints fields which are stored statically in the database in order to improve querying performance since they are not frequently updated, but are queried upon very frequently.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

Exam Class | Aptify.Applications.Education Namespace


Save Method

Aptify 5.0 Software Development Kit (SDK)

Exam.Save Method

This method handles updating the NumberOfQuestions and NumberOfPoints fields which are stored statically in the database in order to improve querying performance since they are not frequently updated, but are queried upon very frequently.

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Save();

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean,ref String&);

This method handles updating the NumberOfQuestions and NumberOfPoints fields which are stored statically in the database in order to improve querying performance since they are not frequently updated, but are queried upon very frequently.

public override bool Save(Boolean,ref String&,String);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(ref String&);

See Also

Exam Class | Aptify.Applications.Education Namespace


Exam.Save Method (Boolean, String&, String)

This method handles updating the NumberOfQuestions and NumberOfPoints fields which are stored statically in the database in order to improve querying performance since they are not frequently updated, but are queried upon very frequently.

public override bool Save(
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

Parameters

AllowGUI
ErrorString
TransactionID

Return Value

Remarks

See Also

Exam Class | Aptify.Applications.Education Namespace | Exam.Save Overload List


ICertificatePrint Interface

For a list of all members of this type, see ICertificatePrint Members.

public interface ICertificatePrint

Types that implement ICertificatePrint

Type | Description
CertificatePrintObject |

Requirements

Namespace: Aptify.Applications.Education

Assembly: CertificatePrintObject (in CertificatePrintObject.dll)

See Also

ICertificatePrint Members | Aptify.Applications.Education Namespace


ICertificatePrint Members

ICertificatePrint overview

Public Instance Methods

ClassCertificatesPrinted |
GetCertifiecateReportLocation | This overload will populate the Blocks() property from the provided Blocks parameter
UpdateDateCertificatesSent |

See Also

ICertificatePrint Interface | Aptify.Applications.Education Namespace


ICertificatePrint Methods

The methods of the ICertificatePrint interface are listed below. For a complete list of ICertificatePrint interface members, see the ICertificatePrint Members topic.

Public Instance Methods

ClassCertificatesPrinted |
GetCertifiecateReportLocation | This overload will populate the Blocks() property from the provided Blocks parameter
UpdateDateCertificatesSent |

See Also

ICertificatePrint Interface | Aptify.Applications.Education Namespace


ICertificatePrint.ClassCertificatesPrinted Method

bool ClassCertificatesPrinted(
Int64 lClassID
);

See Also

ICertificatePrint Interface | Aptify.Applications.Education Namespace


ICertificatePrint.GetCertifiecateReportLocation Method

This overload will populate the Blocks() property from the provided Blocks parameter

string GetCertifiecateReportLocation(
Int64 lClassID
);

Return Value

Remarks

See Also

ICertificatePrint Interface | Aptify.Applications.Education Namespace


ICertificatePrint.UpdateDateCertificatesSent Method

void UpdateDateCertificatesSent(
Int64 lClassID
);

See Also

ICertificatePrint Interface | Aptify.Applications.Education Namespace


ScantronImport Class

This class is responsible for importing data from a scantron file into the Aptify Answer Sheets and Persons entities. The object contains several overridable methods that can be used to configure the business logic of the import process as required.

For a list of all members of this type, see ScantronImport Members.

System.Object
ScantronImport

public class ScantronImport : IProcessComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Education

Assembly: ScantronImport (in ScantronImport.dll)

See Also

ScantronImport Members | Aptify.Applications.Education Namespace


ScantronImport Members

ScantronImport overview

Public Instance Constructors

ScantronImport Constructor Initializes a new instance of the ScantronImport class.

Public Instance Properties

Properties

Public Instance Methods

Config | This method must be called before any other member of the object is accessed
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ImportScantronFile | This method will import the specified FileName and create Answer Sheet records (and, if required will create Person records as well for each line in the scantron that doesn't match an existing person using the FindPerson() method within this class).
Run |
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

StatusUpdate This event is raised from within the ImportScantronFile() method and is raised once for each line in the file to provide status update information to the object calling this class as well as to provide for a mechanism to cancel the process while it is executing by setting the Cancel parameter of the event to True.

Protected Instance Methods

CalculateStatus | This method is responsible for determining the status of an answer sheet as either passed or failed based on the type of scoring setup in the exam definition currently being graded. Exams can be graded on a percent score or points score basis as defined in the Exams entity in the PassType field. This method checks the PassType field and then determines based on the PassType if the ActualScore is sufficient to Pass. If so, the value 'Passed' is returned, otherwise the value of 'Failed' is returned.
CreatePersonRecord | This method is responsible for creating a new person record in the database using the information provided in the
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FindPerson | This method is responsible for finding a person in the Persons entity based on the information provided in the FileData class which was parsed from the Scantron file line. The default implementation of this method in the base class calls the spGetPersonBySSN stored procedure in the database to try to match by SSN. If more than one record is returned by this stored procedure, the first to match the exact spelling of the First and Last Name in the FileData class will be used. If nothing matches, -1 is returned. It is possible to override this method in a sub-class of the ScantronImport class to implement a different algorithm for the FindPerson() method.
GetDefaultMemberType | This method is responsible for returning the Member Type ID for the Member Types entity that is to be used as the default for new person records being created. The default implementation of this method uses the spGetPersonMemberTypeID stored procedure in the database.
GradeExam | This method is responsible for grading an examination answer sheet by comparing the answers provided in the Answers parameter to the correct values defined in the exam
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ParseScantronFileLine | This method is responsible for parsing a single line of a Scantron file and populating the realted members of the provided FileData data structure. FileData is an instance of the PersonFileData class that is to be populated by this method based on the data in FileLine.

See Also

ScantronImport Class | Aptify.Applications.Education Namespace


ScantronImport Constructor

Initializes a new instance of the ScantronImport class.

public ScantronImport();

See Also

ScantronImport Class | Aptify.Applications.Education Namespace


ScantronImport Properties

The properties of the ScantronImport class are listed below. For a complete list of ScantronImport class members, see the ScantronImport Members topic.

Public Instance Properties

Properties

See Also

ScantronImport Class | Aptify.Applications.Education Namespace


Properties Property

Aptify 5.0 Software Development Kit (SDK)

ScantronImport.Properties Property

public AptifyProperties Properties {get;}

Implements

IProcessComponent.

See Also

ScantronImport Class | Aptify.Applications.Education Namespace


ScantronImport Methods

The methods of the ScantronImport class are listed below. For a complete list of ScantronImport class members, see the ScantronImport Members topic.

Public Instance Methods

Config | This method must be called before any other member of the object is accessed
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ImportScantronFile | This method will import the specified FileName and create Answer Sheet records (and, if required will create Person records as well for each line in the scantron that doesn't match an existing person using the FindPerson() method within this class).
Run |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CalculateStatus | This method is responsible for determining the status of an answer sheet as either passed or failed based on the type of scoring setup in the exam definition currently being graded. Exams can be graded on a percent score or points score basis as defined in the Exams entity in the PassType field. This method checks the PassType field and then determines based on the PassType if the ActualScore is sufficient to Pass. If so, the value 'Passed' is returned, otherwise the value of 'Failed' is returned.
CreatePersonRecord | This method is responsible for creating a new person record in the database using the information provided in the
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FindPerson | This method is responsible for finding a person in the Persons entity based on the information provided in the FileData class which was parsed from the Scantron file line. The default implementation of this method in the base class calls the spGetPersonBySSN stored procedure in the database to try to match by SSN. If more than one record is returned by this stored procedure, the first to match the exact spelling of the First and Last Name in the FileData class will be used. If nothing matches, -1 is returned. It is possible to override this method in a sub-class of the ScantronImport class to implement a different algorithm for the FindPerson() method.
GetDefaultMemberType | This method is responsible for returning the Member Type ID for the Member Types entity that is to be used as the default for new person records being created. The default implementation of this method uses the spGetPersonMemberTypeID stored procedure in the database.
GradeExam | This method is responsible for grading an examination answer sheet by comparing the answers provided in the Answers parameter to the correct values defined in the exam
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ParseScantronFileLine | This method is responsible for parsing a single line of a Scantron file and populating the realted members of the provided FileData data structure. FileData is an instance of the PersonFileData class that is to be populated by this method based on the data in FileLine.

See Also

ScantronImport Class | Aptify.Applications.Education Namespace


ScantronImport.CalculateStatus Method

This method is responsible for determining the status of an answer sheet as either passed or failed based on the type of scoring setup in the exam definition currently being graded. Exams can be graded on a percent score or points score basis as defined in the Exams entity in the PassType field. This method checks the PassType field and then determines based on the PassType if the ActualScore is sufficient to Pass. If so, the value 'Passed' is returned, otherwise the value of 'Failed' is returned.

protected virtual string CalculateStatus(
Decimal ActualScore,
Decimal TotalExamPoints
);

Parameters

ActualScore
TotalExamPoints

Return Value

Remarks

See Also

ScantronImport Class | Aptify.Applications.Education Namespace


ScantronImport.Config Method

This method must be called before any other member of the object is accessed

public virtual void Config(
AptifyApplication Application
);

Parameters

Application

Implements

IProcessComponent.

Remarks

See Also

ScantronImport Class | Aptify.Applications.Education Namespace


ScantronImport.CreatePersonRecord Method

This method is responsible for creating a new person record in the database using the information provided in the

protected virtual long CreatePersonRecord(
ScantronImport.PersonFileData FileData,
Int64 RecordNumber
);

Parameters

FileData
RecordNumber
The current sequential record number within the import process - used for diagnostic information if the method fails

Return Value

Remarks

See Also

ScantronImport Class | Aptify.Applications.Education Namespace


ScantronImport.FindPerson Method

This method is responsible for finding a person in the Persons entity based on the information provided in the FileData class which was parsed from the Scantron file line. The default implementation of this method in the base class calls the spGetPersonBySSN stored procedure in the database to try to match by SSN. If more than one record is returned by this stored procedure, the first to match the exact spelling of the First and Last Name in the FileData class will be used. If nothing matches, -1 is returned. It is possible to override this method in a sub-class of the ScantronImport class to implement a different algorithm for the FindPerson() method.

protected virtual long FindPerson(
ScantronImport.PersonFileData FileData
);

Parameters

FileData

Return Value

Remarks

See Also

ScantronImport Class | Aptify.Applications.Education Namespace


ScantronImport.GetDefaultMemberType Method

This method is responsible for returning the Member Type ID for the Member Types entity that is to be used as the default for new person records being created. The default implementation of this method uses the spGetPersonMemberTypeID stored procedure in the database.

protected virtual long GetDefaultMemberType();

Return Value

Remarks

See Also

ScantronImport Class | Aptify.Applications.Education Namespace


ScantronImport.GradeExam Method

This method is responsible for grading an examination answer sheet by comparing the answers provided in the Answers parameter to the correct values defined in the exam

protected virtual bool GradeExam(
Int64 PersonID,
Int64 ClassID,
List<T> Answers,
ref Int64& AnswerSheetID,
ref Boolean& Passed,
ref Decimal& PointScore
);

Parameters

PersonID
ClassID
Answers
AnswerSheetID
OUT Parameter: Used to provide the callee the ID of the Answer Sheet that was graded.
Passed
OUT Parameter: Used to provide the callee with information on if the Answer Sheet passed the criteria defined in the Exam definition
PointScore
OUT Parameter: Used to provide the callee with the points score on the exam for the set of answers provided

Return Value

True if succesful, False otherwise

Remarks

See Also

ScantronImport Class | Aptify.Applications.Education Namespace


ScantronImport.ImportScantronFile Method

This method will import the specified FileName and create Answer Sheet records (and, if required will create Person records as well for each line in the scantron that doesn't match an existing person using the FindPerson() method within this class).

public virtual bool ImportScantronFile(
String FileName,
Int64 ClassID,
Int64 ExamID,
ref Int64& RecordsProcessed
);

Parameters

FileName
Fully qualified (including directory information) file name
ClassID
Class Record ID number that the answer sheets are related to
ExamID
Exam Record ID Number that the object is being configured to grade a scantron import file on.
RecordsProcessed

Return Value

Remarks

See Also

ScantronImport Class | Aptify.Applications.Education Namespace


ScantronImport.ParseScantronFileLine Method

This method is responsible for parsing a single line of a Scantron file and populating the realted members of the provided FileData data structure. FileData is an instance of the PersonFileData class that is to be populated by this method based on the data in FileLine.

protected virtual bool ParseScantronFileLine(
String FileLine,
ScantronImport.PersonFileData FileData
);

Parameters

FileLine
FileData

Return Value

True if the operation is a success, False otherwise

Remarks

See Also

ScantronImport Class | Aptify.Applications.Education Namespace


ScantronImport.Run Method

public string Run();

Implements

IProcessComponent.

See Also

ScantronImport Class | Aptify.Applications.Education Namespace


ScantronImport Events

The events of the ScantronImport class are listed below. For a complete list of ScantronImport class members, see the ScantronImport Members topic.

Public Instance Events

StatusUpdate This event is raised from within the ImportScantronFile() method and is raised once for each line in the file to provide status update information to the object calling this class as well as to provide for a mechanism to cancel the process while it is executing by setting the Cancel parameter of the event to True.

See Also

ScantronImport Class | Aptify.Applications.Education Namespace


ScantronImport.ScantronImport.StatusUpdateEventHandler Event

This event is raised from within the ImportScantronFile() method and is raised once for each line in the file to provide status update information to the object calling this class as well as to provide for a mechanism to cancel the process while it is executing by setting the Cancel parameter of the event to True.

public event ScantronImport.StatusUpdateEventHandler StatusUpdate;

Remarks

See Also

ScantronImport Class | Aptify.Applications.Education Namespace


ScantronImport.PersonFileData Class

This class is used to carry the information related to a single line of the scantron file that is parsed and put into the related fields in this data structure. The ParseScantronFileLine() method of the ScantronImport class (or its overriden implentations in sub-classes) is responsible for taking in a single line of text from a file and parsing that file line and putting the data into the related data structure.

For a list of all members of this type, see ScantronImport.PersonFileData Members.

System.Object
ScantronImport.PersonFileData

public class ScantronImport.PersonFileData

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Education

Assembly: ScantronImport (in ScantronImport.dll)

See Also

ScantronImport.PersonFileData Members | Aptify.Applications.Education Namespace


ScantronImport.PersonFileData Members

ScantronImport.PersonFileData overview

Public Instance Constructors

ScantronImport.PersonFileData Constructor Initializes a new instance of the ScantronImport.PersonFileData class.

Public Instance Fields

Address |
Answers | Collection of answers provided that are being imported from the Scantron file format
Attributes | The Attributes member is used to store any number of additional field values (name/value pairs) in a Dictionary collection that can be used for any required purpose.
City |
ExamDate |
FirstName |
Gender |
LastName |
MiddleName |
SSN |
State |
ZipCode |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ScantronImport.PersonFileData Class | Aptify.Applications.Education Namespace


ScantronImport.PersonFileData Constructor

Initializes a new instance of the ScantronImport.PersonFileData class.

public ScantronImport.PersonFileData();

See Also

ScantronImport.PersonFileData Class | Aptify.Applications.Education Namespace


ScantronImport.PersonFileData Fields

The fields of the ScantronImport.PersonFileData class are listed below. For a complete list of ScantronImport.PersonFileData class members, see the ScantronImport.PersonFileData Members topic.

Public Instance Fields

Address |
Answers | Collection of answers provided that are being imported from the Scantron file format
Attributes | The Attributes member is used to store any number of additional field values (name/value pairs) in a Dictionary collection that can be used for any required purpose.
City |
ExamDate |
FirstName |
Gender |
LastName |
MiddleName |
SSN |
State |
ZipCode |

See Also

ScantronImport.PersonFileData Class | Aptify.Applications.Education Namespace


ScantronImport.PersonFileData.Address Field

public Address Address;

See Also

ScantronImport.PersonFileData Class | Aptify.Applications.Education Namespace


ScantronImport.PersonFileData.Answers Field

Collection of answers provided that are being imported from the Scantron file format

public Answers Answers;

Remarks

See Also

ScantronImport.PersonFileData Class | Aptify.Applications.Education Namespace


ScantronImport.PersonFileData.Attributes Field

The Attributes member is used to store any number of additional field values (name/value pairs) in a Dictionary collection that can be used for any required purpose.

public Attributes Attributes;

Remarks

See Also

ScantronImport.PersonFileData Class | Aptify.Applications.Education Namespace


ScantronImport.PersonFileData.City Field

public City City;

See Also

ScantronImport.PersonFileData Class | Aptify.Applications.Education Namespace


ScantronImport.PersonFileData.ExamDate Field

public ExamDate ExamDate;

See Also

ScantronImport.PersonFileData Class | Aptify.Applications.Education Namespace


ScantronImport.PersonFileData.FirstName Field

public FirstName FirstName;

See Also

ScantronImport.PersonFileData Class | Aptify.Applications.Education Namespace


ScantronImport.PersonFileData.Gender Field

public Gender Gender;

See Also

ScantronImport.PersonFileData Class | Aptify.Applications.Education Namespace


ScantronImport.PersonFileData.LastName Field

public LastName LastName;

See Also

ScantronImport.PersonFileData Class | Aptify.Applications.Education Namespace


ScantronImport.PersonFileData.MiddleName Field

public MiddleName MiddleName;

See Also

ScantronImport.PersonFileData Class | Aptify.Applications.Education Namespace


ScantronImport.PersonFileData.SSN Field

public SSN SSN;

See Also

ScantronImport.PersonFileData Class | Aptify.Applications.Education Namespace


ScantronImport.PersonFileData.State Field

public State State;

See Also

ScantronImport.PersonFileData Class | Aptify.Applications.Education Namespace


ScantronImport.PersonFileData.ZipCode Field

public ZipCode ZipCode;

See Also

ScantronImport.PersonFileData Class | Aptify.Applications.Education Namespace


ScantronImport.PersonGender Enumeration

public enum ScantronImport.PersonGender

Members

Member Name | Description
Male |
Female |

Requirements

Namespace: Aptify.Applications.Education

Assembly: ScantronImport (in ScantronImport.dll)

See Also

Aptify.Applications.Education Namespace


ScantronImport.ScantronPersonField Enumeration

This enumerated type tracks the different fields that exist in the scantron file definition that this object will import by default.

public enum ScantronImport.ScantronPersonField

Remarks

Members

Member Name | Description
SSN |
LastName |
FirstName |
MiddleName |
Gender |
Address |
City |
State |
Zip |
ExamDate |
Answers |

Requirements

Namespace: Aptify.Applications.Education

Assembly: ScantronImport (in ScantronImport.dll)

See Also

Aptify.Applications.Education Namespace


ScantronImport.StatusUpdateEventHandler Delegate

public delegate void ScantronImport.StatusUpdateEventHandler(
Int32 PercentComplete,
Int64 RecordNumber,
ref Boolean& Cancel
);

Requirements

Namespace: Aptify.Applications.Education

Assembly: ScantronImport (in ScantronImport.dll)

See Also

Aptify.Applications.Education Namespace


ScantronImportWizard Class

For a list of all members of this type, see ScantronImportWizard Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
ScantronImportWizard

public class ScantronImportWizard : Form, IAptifyAction

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Education

Assembly: AptifyScantronImportWizard (in AptifyScantronImportWizard.dll)

See Also

ScantronImportWizard Members | Aptify.Applications.Education Namespace


ScantronImportWizard Members

ScantronImportWizard overview

Public Instance Constructors

ScantronImportWizard Constructor Initializes a new instance of the ScantronImportWizard class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoAction | Overloaded.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ScantronImportWizard Class | Aptify.Applications.Education Namespace


ScantronImportWizard Constructor

Initializes a new instance of the ScantronImportWizard class.

public ScantronImportWizard();

See Also

ScantronImportWizard Class | Aptify.Applications.Education Namespace


ScantronImportWizard Methods

The methods of the ScantronImportWizard class are listed below. For a complete list of ScantronImportWizard class members, see the ScantronImportWizard Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoAction | Overloaded.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ScantronImportWizard Class | Aptify.Applications.Education Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

ScantronImportWizard.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

ScantronImportWizard Class | Aptify.Applications.Education Namespace


ScantronImportWizard.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

ScantronImportWizard Class | Aptify.Applications.Education Namespace | ScantronImportWizard.Dispose Overload List


DoAction Method

Aptify 5.0 Software Development Kit (SDK)

ScantronImportWizard.DoAction Method

Overload List

public void DoAction(AptifyApplication,Int64);

public void DoAction(AptifyApplication,Int64,Int64);

Starts the Aptify Class Registration Wizard.

public void DoAction(AptifyApplication,Int64,Int64,params Object[]);

public void DoAction(AptifyApplication,Int64,params String[]);

See Also

ScantronImportWizard Class | Aptify.Applications.Education Namespace


ScantronImportWizard.DoAction Method (AptifyApplication, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID
);

Implements

IAptifyAction.

See Also

ScantronImportWizard Class | Aptify.Applications.Education Namespace | ScantronImportWizard.DoAction Overload List


ScantronImportWizard.DoAction Method (AptifyApplication, Int64, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID
);

Implements

IAptifyAction.

See Also

ScantronImportWizard Class | Aptify.Applications.Education Namespace | ScantronImportWizard.DoAction Overload List


ScantronImportWizard.DoAction Method (AptifyApplication, Int64, Int64, Object[])

Starts the Aptify Class Registration Wizard.

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID,
params Object[] SelectedItems
);

Parameters

ApplicationObject
A valid AptifyApplication.
EntityID
Not Used
ViewID
Not Used
SelectedItems
Not Used

Implements

IAptifyAction.

Remarks

See Also

ScantronImportWizard Class | Aptify.Applications.Education Namespace | ScantronImportWizard.DoAction Overload List


ScantronImportWizard.DoAction Method (AptifyApplication, Int64, String[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
params String[] SelectedItems
);

Implements

IAptifyAction.

See Also

ScantronImportWizard Class | Aptify.Applications.Education Namespace | ScantronImportWizard.DoAction Overload List


StudentCertification Class

Structure that stores information about student's classes and certifications

For a list of all members of this type, see StudentCertification Members.

System.Object
StudentCertification

public class StudentCertification

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Education

Assembly: CurriculumApplication (in CurriculumApplication.dll)

See Also

StudentCertification Members | Aptify.Applications.Education Namespace


StudentCertification Members

StudentCertification overview

Public Instance Properties

CertificationID
ClassRegistrationID
CourseCategoryID
CourseCategoryName
CourseID
CourseName
DateAvailable
DateCompleted
DateExpired
DateRegistered
SchoolID
StudentStatus
Units

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetRequirementStudentStatus |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Constructors

StudentCertification Constructor

Protected Internal Instance Fields

m_bSchoolAccredited
m_dDateAvailable
m_dDateCompleted
m_dDateExpired
m_dDateRegistered
m_lCertificationID
m_lClassRegistrationID
m_lCourseCategoryID
m_lCourseID
m_lSchoolID
m_lUnits
m_sCourseCategoryName
m_sCourseName
m_StudentStatus

See Also

StudentCertification Class | Aptify.Applications.Education Namespace


StudentCertification Constructor

protected internal StudentCertification(
Int64 PersonID
);

See Also

StudentCertification Class | Aptify.Applications.Education Namespace


StudentCertification Fields

The fields of the StudentCertification class are listed below. For a complete list of StudentCertification class members, see the StudentCertification Members topic.

Protected Internal Instance Fields

m_bSchoolAccredited
m_dDateAvailable
m_dDateCompleted
m_dDateExpired
m_dDateRegistered
m_lCertificationID
m_lClassRegistrationID
m_lCourseCategoryID
m_lCourseID
m_lSchoolID
m_lUnits
m_sCourseCategoryName
m_sCourseName
m_StudentStatus

See Also

StudentCertification Class | Aptify.Applications.Education Namespace


StudentCertification.m_bSchoolAccredited Field

protected internal m_bSchoolAccredited m_bSchoolAccredited;

See Also

StudentCertification Class | Aptify.Applications.Education Namespace


StudentCertification.m_dDateAvailable Field

protected internal m_dDateAvailable m_dDateAvailable;

See Also

StudentCertification Class | Aptify.Applications.Education Namespace


StudentCertification.m_dDateCompleted Field

protected internal m_dDateCompleted m_dDateCompleted;

See Also

StudentCertification Class | Aptify.Applications.Education Namespace


StudentCertification.m_dDateExpired Field

protected internal m_dDateExpired m_dDateExpired;

See Also

StudentCertification Class | Aptify.Applications.Education Namespace


StudentCertification.m_dDateRegistered Field

protected internal m_dDateRegistered m_dDateRegistered;

See Also

StudentCertification Class | Aptify.Applications.Education Namespace


StudentCertification.m_lCertificationID Field

protected internal m_lCertificationID m_lCertificationID;

See Also

StudentCertification Class | Aptify.Applications.Education Namespace


StudentCertification.m_lClassRegistrationID Field

protected internal m_lClassRegistrationID m_lClassRegistrationID;

See Also

StudentCertification Class | Aptify.Applications.Education Namespace


StudentCertification.m_lCourseCategoryID Field

protected internal m_lCourseCategoryID m_lCourseCategoryID;

See Also

StudentCertification Class | Aptify.Applications.Education Namespace


StudentCertification.m_lCourseID Field

protected internal m_lCourseID m_lCourseID;

See Also

StudentCertification Class | Aptify.Applications.Education Namespace


StudentCertification.m_lSchoolID Field

protected internal m_lSchoolID m_lSchoolID;

See Also

StudentCertification Class | Aptify.Applications.Education Namespace


StudentCertification.m_lUnits Field

protected internal m_lUnits m_lUnits;

See Also

StudentCertification Class | Aptify.Applications.Education Namespace


StudentCertification.m_sCourseCategoryName Field

protected internal m_sCourseCategoryName m_sCourseCategoryName;

See Also

StudentCertification Class | Aptify.Applications.Education Namespace


StudentCertification.m_sCourseName Field

protected internal m_sCourseName m_sCourseName;

See Also

StudentCertification Class | Aptify.Applications.Education Namespace


StudentCertification.m_StudentStatus Field

protected internal m_StudentStatus m_StudentStatus;

See Also

StudentCertification Class | Aptify.Applications.Education Namespace


StudentCertification Properties

The properties of the StudentCertification class are listed below. For a complete list of StudentCertification class members, see the StudentCertification Members topic.

Public Instance Properties

CertificationID
ClassRegistrationID
CourseCategoryID
CourseCategoryName
CourseID
CourseName
DateAvailable
DateCompleted
DateExpired
DateRegistered
SchoolID
StudentStatus
Units

See Also

StudentCertification Class | Aptify.Applications.Education Namespace


CertificationID Property

Aptify 5.0 Software Development Kit (SDK)

StudentCertification.CertificationID Property

public Int64 CertificationID {get;}

See Also

StudentCertification Class | Aptify.Applications.Education Namespace


ClassRegistrationID Property

Aptify 5.0 Software Development Kit (SDK)

StudentCertification.ClassRegistrationID Property

public Int64 ClassRegistrationID {get;}

See Also

StudentCertification Class | Aptify.Applications.Education Namespace


CourseCategoryID Property

Aptify 5.0 Software Development Kit (SDK)

StudentCertification.CourseCategoryID Property

public Int64 CourseCategoryID {get;}

See Also

StudentCertification Class | Aptify.Applications.Education Namespace


CourseCategoryName Property

Aptify 5.0 Software Development Kit (SDK)

StudentCertification.CourseCategoryName Property

public String CourseCategoryName {get;}

See Also

StudentCertification Class | Aptify.Applications.Education Namespace


CourseID Property

Aptify 5.0 Software Development Kit (SDK)

StudentCertification.CourseID Property

public Int64 CourseID {get;}

See Also

StudentCertification Class | Aptify.Applications.Education Namespace


CourseName Property

Aptify 5.0 Software Development Kit (SDK)

StudentCertification.CourseName Property

public String CourseName {get;}

See Also

StudentCertification Class | Aptify.Applications.Education Namespace


DateAvailable Property

Aptify 5.0 Software Development Kit (SDK)

StudentCertification.DateAvailable Property

public DateTime DateAvailable {get;}

See Also

StudentCertification Class | Aptify.Applications.Education Namespace


DateCompleted Property

Aptify 5.0 Software Development Kit (SDK)

StudentCertification.DateCompleted Property

public DateTime DateCompleted {get;}

See Also

StudentCertification Class | Aptify.Applications.Education Namespace


DateExpired Property

Aptify 5.0 Software Development Kit (SDK)

StudentCertification.DateExpired Property

public DateTime DateExpired {get;}

See Also

StudentCertification Class | Aptify.Applications.Education Namespace


DateRegistered Property

Aptify 5.0 Software Development Kit (SDK)

StudentCertification.DateRegistered Property

public DateTime DateRegistered {get;}

See Also

StudentCertification Class | Aptify.Applications.Education Namespace


SchoolID Property

Aptify 5.0 Software Development Kit (SDK)

StudentCertification.SchoolID Property

public Int64 SchoolID {get;}

See Also

StudentCertification Class | Aptify.Applications.Education Namespace


StudentStatus Property

Aptify 5.0 Software Development Kit (SDK)

StudentCertification.StudentStatus Property

public StudentCertification.RequirementStudentStatus StudentStatus {get;}

See Also

StudentCertification Class | Aptify.Applications.Education Namespace


Units Property

Aptify 5.0 Software Development Kit (SDK)

StudentCertification.Units Property

public Int64 Units {get;}

See Also

StudentCertification Class | Aptify.Applications.Education Namespace


StudentCertification Methods

The methods of the StudentCertification class are listed below. For a complete list of StudentCertification class members, see the StudentCertification Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetRequirementStudentStatus |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StudentCertification Class | Aptify.Applications.Education Namespace


StudentCertification.GetRequirementStudentStatus Method

public RequirementStudentStatus GetRequirementStudentStatus(
String Status
);

See Also

StudentCertification Class | Aptify.Applications.Education Namespace


StudentCertification.CertificationStatus Enumeration

public enum StudentCertification.CertificationStatus

Members

Member Name | Description
Declared |
InProgress |
Granted |
Cancelled |
Expired |

Requirements

Namespace: Aptify.Applications.Education

Assembly: CurriculumApplication (in CurriculumApplication.dll)

See Also

Aptify.Applications.Education Namespace


StudentCertification.RequirementStudentStatus Enumeration

public enum StudentCertification.RequirementStudentStatus

Members

Member Name | Description
NotStarted |
Pending |
Registered |
InProgress |
Withdrawal |
Passed |
Failed |
Expired |

Requirements

Namespace: Aptify.Applications.Education

Assembly: CurriculumApplication (in CurriculumApplication.dll)

See Also

Aptify.Applications.Education Namespace


Aptify.Applications.Education.WindowsControls

Aptify 5.0 Software Development Kit (SDK)

Aptify.Applications.Education.WindowsControls Namespace

This namespace corresponds to the presentation layer logic used to display Class Registration record data.

Namespace hierarchy

Classes

Class | Description
ClassRegistrationLayout | This class implements layout logic for the Windows UI for the Class Registrations entity.
ClassRegistrationPaymentLayout |


ClassRegistrationLayout Class

This class implements layout logic for the Windows UI for the Class Registrations entity.

For a list of all members of this type, see ClassRegistrationLayout Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
ClassRegistrationLayout

public class ClassRegistrationLayout : FormTemplateLayout

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Education.WindowsControls

Assembly: ClassRegistrationLayoutControl (in ClassRegistrationLayoutControl.dll)

See Also

ClassRegistrationLayout Members | Aptify.Applications.Education.WindowsControls Namespace


ClassRegistrationLayout Members

ClassRegistrationLayout overview

Public Instance Constructors

ClassRegistrationLayout Constructor Initializes a new instance of the ClassRegistrationLayout class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetClassProductID |
GetClassProductType |
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetTabControl | This method is responsible for finding the tab control within this form template and returning it to the caller
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
IsEmbeddedInOrderEntryUI | This method is responsible for determining if the form template is embedded within the Order Entry UI. If it is, then True is returned, otherwise False is returned.
m_ctlClassID |
m_ctlOrderID |
m_ctlStatus |
m_ctlStudentID |
m_ctlTab |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
BindControl | This method handles binding a control reference to a specific field name using the GetFormComponent() method of the base class. The method only attempts to bind the control reference if the control reference is Nothing or its inner control is disposed.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
FilterClassID | This method establishes a hidden filter on the Class ID link box. The purpose of this filter is to restrict the selection of available classes based on the product specfied in the order line. This method is only functional when the layout control/form template is operating in an embedded mode within the order entry UI.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControls | This method handles binding the controls to their internal protected members.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetInnerTabControl | This method is responsible for returning the inner tab control that is within the form template tab control itself.
GetPaymentTab | This method is responsible for finding the Payment tab on the tab control. This method utilizes the localized culture string, if specified, to find the Payment tab on the control.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTab | This method is responsible for finding the specified tab on the tab control. This method utilizes the localized culture string, if specified, to find the named tab on the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
HideOrderAndPaymentInfo | This method is responsible for hiding order and payment information and is used to hide payment and order details in a class registration when a user is viewing the record from an embedded perspective on an order entry screen. Default behavior in the base class will hide the OrderID field and also hide the Payment tab on the tab control. This method also hides the attachments tab.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ClassRegistrationLayout Class | Aptify.Applications.Education.WindowsControls Namespace


ClassRegistrationLayout Constructor

Initializes a new instance of the ClassRegistrationLayout class.

public ClassRegistrationLayout();

See Also

ClassRegistrationLayout Class | Aptify.Applications.Education.WindowsControls Namespace


ClassRegistrationLayout Properties

The properties of the ClassRegistrationLayout class are listed below. For a complete list of ClassRegistrationLayout class members, see the ClassRegistrationLayout Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
IsEmbeddedInOrderEntryUI | This method is responsible for determining if the form template is embedded within the Order Entry UI. If it is, then True is returned, otherwise False is returned.
m_ctlClassID |
m_ctlOrderID |
m_ctlStatus |
m_ctlStudentID |
m_ctlTab |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

ClassRegistrationLayout Class | Aptify.Applications.Education.WindowsControls Namespace


IsEmbeddedInOrderEntryUI Property

Aptify 5.0 Software Development Kit (SDK)

ClassRegistrationLayout.IsEmbeddedInOrderEntryUI Property

This method is responsible for determining if the form template is embedded within the Order Entry UI. If it is, then True is returned, otherwise False is returned.

protected virtual Boolean IsEmbeddedInOrderEntryUI {get;}

Property Value

Remarks

See Also

ClassRegistrationLayout Class | Aptify.Applications.Education.WindowsControls Namespace


m_ctlClassID Property

Aptify 5.0 Software Development Kit (SDK)

ClassRegistrationLayout.m_ctlClassID Property

protected virtual AptifyLinkBox m_ctlClassID {get; set;}

See Also

ClassRegistrationLayout Class | Aptify.Applications.Education.WindowsControls Namespace


m_ctlOrderID Property

Aptify 5.0 Software Development Kit (SDK)

ClassRegistrationLayout.m_ctlOrderID Property

protected virtual IAptifyDataFieldControlBase m_ctlOrderID {get; set;}

See Also

ClassRegistrationLayout Class | Aptify.Applications.Education.WindowsControls Namespace


m_ctlStatus Property

Aptify 5.0 Software Development Kit (SDK)

ClassRegistrationLayout.m_ctlStatus Property

protected virtual IAptifyDataFieldControlBase m_ctlStatus {get; set;}

See Also

ClassRegistrationLayout Class | Aptify.Applications.Education.WindowsControls Namespace


m_ctlStudentID Property

Aptify 5.0 Software Development Kit (SDK)

ClassRegistrationLayout.m_ctlStudentID Property

protected virtual IAptifyDataFieldControlBase m_ctlStudentID {get; set;}

See Also

ClassRegistrationLayout Class | Aptify.Applications.Education.WindowsControls Namespace


m_ctlTab Property

Aptify 5.0 Software Development Kit (SDK)

ClassRegistrationLayout.m_ctlTab Property

protected virtual IAptifyDataFieldControlBase m_ctlTab {get; set;}

See Also

ClassRegistrationLayout Class | Aptify.Applications.Education.WindowsControls Namespace


ClassRegistrationLayout Methods

The methods of the ClassRegistrationLayout class are listed below. For a complete list of ClassRegistrationLayout class members, see the ClassRegistrationLayout Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetClassProductID |
GetClassProductType |
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetTabControl | This method is responsible for finding the tab control within this form template and returning it to the caller
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
BindControl | This method handles binding a control reference to a specific field name using the GetFormComponent() method of the base class. The method only attempts to bind the control reference if the control reference is Nothing or its inner control is disposed.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
FilterClassID | This method establishes a hidden filter on the Class ID link box. The purpose of this filter is to restrict the selection of available classes based on the product specfied in the order line. This method is only functional when the layout control/form template is operating in an embedded mode within the order entry UI.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControls | This method handles binding the controls to their internal protected members.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetInnerTabControl | This method is responsible for returning the inner tab control that is within the form template tab control itself.
GetPaymentTab | This method is responsible for finding the Payment tab on the tab control. This method utilizes the localized culture string, if specified, to find the Payment tab on the control.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTab | This method is responsible for finding the specified tab on the tab control. This method utilizes the localized culture string, if specified, to find the named tab on the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
HideOrderAndPaymentInfo | This method is responsible for hiding order and payment information and is used to hide payment and order details in a class registration when a user is viewing the record from an embedded perspective on an order entry screen. Default behavior in the base class will hide the OrderID field and also hide the Payment tab on the tab control. This method also hides the attachments tab.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ClassRegistrationLayout Class | Aptify.Applications.Education.WindowsControls Namespace


ClassRegistrationLayout.BindControl Method

This method handles binding a control reference to a specific field name using the GetFormComponent() method of the base class. The method only attempts to bind the control reference if the control reference is Nothing or its inner control is disposed.

protected virtual void BindControl(
ref IAptifyDataFieldControlBase& control,
String FieldName
);

Parameters

control
FieldName

Remarks

See Also

ClassRegistrationLayout Class | Aptify.Applications.Education.WindowsControls Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

ClassRegistrationLayout.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

ClassRegistrationLayout Class | Aptify.Applications.Education.WindowsControls Namespace


ClassRegistrationLayout.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

ClassRegistrationLayout Class | Aptify.Applications.Education.WindowsControls Namespace | ClassRegistrationLayout.Dispose Overload List


ClassRegistrationLayout.FilterClassID Method

This method establishes a hidden filter on the Class ID link box. The purpose of this filter is to restrict the selection of available classes based on the product specfied in the order line. This method is only functional when the layout control/form template is operating in an embedded mode within the order entry UI.

protected virtual void FilterClassID();

Remarks

See Also

ClassRegistrationLayout Class | Aptify.Applications.Education.WindowsControls Namespace


ClassRegistrationLayout.FindControls Method

This method handles binding the controls to their internal protected members.

protected virtual void FindControls();

Remarks

See Also

ClassRegistrationLayout Class | Aptify.Applications.Education.WindowsControls Namespace


ClassRegistrationLayout.GetClassProductID Method

public virtual long GetClassProductID(
Int64 ClassID
);

See Also

ClassRegistrationLayout Class | Aptify.Applications.Education.WindowsControls Namespace


ClassRegistrationLayout.GetClassProductType Method

public virtual string GetClassProductType(
Int64 ProductID
);

See Also

ClassRegistrationLayout Class | Aptify.Applications.Education.WindowsControls Namespace


ClassRegistrationLayout.GetInnerTabControl Method

This method is responsible for returning the inner tab control that is within the form template tab control itself.

protected virtual UltraTabControl GetInnerTabControl();

Return Value

Remarks

See Also

ClassRegistrationLayout Class | Aptify.Applications.Education.WindowsControls Namespace


ClassRegistrationLayout.GetPaymentTab Method

This method is responsible for finding the Payment tab on the tab control. This method utilizes the localized culture string, if specified, to find the Payment tab on the control.

protected virtual UltraTab GetPaymentTab(
String TabName
);

Parameters

TabName
If provided, this provides the base string(which will be localized, when possible) to search for on the tab control

Return Value

Remarks

See Also

ClassRegistrationLayout Class | Aptify.Applications.Education.WindowsControls Namespace


ClassRegistrationLayout.GetTab Method

This method is responsible for finding the specified tab on the tab control. This method utilizes the localized culture string, if specified, to find the named tab on the control.

protected virtual UltraTab GetTab(
String TabName
);

Parameters

TabName

Return Value

Remarks

See Also

ClassRegistrationLayout Class | Aptify.Applications.Education.WindowsControls Namespace


ClassRegistrationLayout.GetTabControl Method

This method is responsible for finding the tab control within this form template and returning it to the caller

public virtual FormTemplateTab GetTabControl();

Return Value

Remarks

See Also

ClassRegistrationLayout Class | Aptify.Applications.Education.WindowsControls Namespace


ClassRegistrationLayout.HideOrderAndPaymentInfo Method

This method is responsible for hiding order and payment information and is used to hide payment and order details in a class registration when a user is viewing the record from an embedded perspective on an order entry screen. Default behavior in the base class will hide the OrderID field and also hide the Payment tab on the tab control. This method also hides the attachments tab.

protected virtual void HideOrderAndPaymentInfo();

Remarks

See Also

ClassRegistrationLayout Class | Aptify.Applications.Education.WindowsControls Namespace


ClassRegistrationLayout.OnFormTemplateLoaded Method

protected override void OnFormTemplateLoaded(
FormTemplateLayout.FormTemplateLoadedEventArgs e
);

See Also

ClassRegistrationLayout Class | Aptify.Applications.Education.WindowsControls Namespace


ClassRegistrationLayout.OnRefresh Method

protected override void OnRefresh();

Implements

IFormComponent.

See Also

ClassRegistrationLayout Class | Aptify.Applications.Education.WindowsControls Namespace


ClassRegistrationPaymentLayout Class

For a list of all members of this type, see ClassRegistrationPaymentLayout Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
ClassRegistrationPaymentLayout

public class ClassRegistrationPaymentLayout : FormTemplateLayout

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Education.WindowsControls

Assembly: ClassRegistrationLayoutControl (in ClassRegistrationLayoutControl.dll)

See Also

ClassRegistrationPaymentLayout Members | Aptify.Applications.Education.WindowsControls Namespace


ClassRegistrationPaymentLayout Members

ClassRegistrationPaymentLayout overview

Public Instance Constructors

ClassRegistrationPaymentLayout Constructor Initializes a new instance of the ClassRegistrationPaymentLayout class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
m_ctlPaymentInformation |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormTemplateLayout) | Overloaded. Releases all resources used by the Component.
EnablePaymentInformationControl | This method disables masking on records in which payment information has not been entered.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetPaymentInformationControl | This method is responsible for finding the PaymentInformation control within this form template and returning it to the caller
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ClassRegistrationPaymentLayout Class | Aptify.Applications.Education.WindowsControls Namespace


ClassRegistrationPaymentLayout Constructor

Initializes a new instance of the ClassRegistrationPaymentLayout class.

public ClassRegistrationPaymentLayout();

See Also

ClassRegistrationPaymentLayout Class | Aptify.Applications.Education.WindowsControls Namespace


ClassRegistrationPaymentLayout Properties

The properties of the ClassRegistrationPaymentLayout class are listed below. For a complete list of ClassRegistrationPaymentLayout class members, see the ClassRegistrationPaymentLayout Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
m_ctlPaymentInformation |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

ClassRegistrationPaymentLayout Class | Aptify.Applications.Education.WindowsControls Namespace


m_ctlPaymentInformation Property

Aptify 5.0 Software Development Kit (SDK)

ClassRegistrationPaymentLayout.m_ctlPaymentInformation Property

protected virtual PaymentInfoControl m_ctlPaymentInformation {get; set;}

See Also

ClassRegistrationPaymentLayout Class | Aptify.Applications.Education.WindowsControls Namespace


ClassRegistrationPaymentLayout Methods

The methods of the ClassRegistrationPaymentLayout class are listed below. For a complete list of ClassRegistrationPaymentLayout class members, see the ClassRegistrationPaymentLayout Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormTemplateLayout) | Overloaded. Releases all resources used by the Component.
EnablePaymentInformationControl | This method disables masking on records in which payment information has not been entered.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetPaymentInformationControl | This method is responsible for finding the PaymentInformation control within this form template and returning it to the caller
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ClassRegistrationPaymentLayout Class | Aptify.Applications.Education.WindowsControls Namespace


ClassRegistrationPaymentLayout.EnablePaymentInformationControl Method

This method disables masking on records in which payment information has not been entered.

protected virtual void EnablePaymentInformationControl();

Remarks

See Also

ClassRegistrationPaymentLayout Class | Aptify.Applications.Education.WindowsControls Namespace


ClassRegistrationPaymentLayout.GetPaymentInformationControl Method

This method is responsible for finding the PaymentInformation control within this form template and returning it to the caller

protected virtual PaymentInfoControl GetPaymentInformationControl();

Return Value

Remarks

See Also

ClassRegistrationPaymentLayout Class | Aptify.Applications.Education.WindowsControls Namespace


ClassRegistrationPaymentLayout.OnFormTemplateLoaded Method

protected override void OnFormTemplateLoaded(
FormTemplateLayout.FormTemplateLoadedEventArgs e
);

See Also

ClassRegistrationPaymentLayout Class | Aptify.Applications.Education.WindowsControls Namespace


Aptify.Applications.ExpoManagement

Aptify 5.0 Software Development Kit (SDK)

Aptify.Applications.ExpoManagement Namespace

The objects in this namespace implement Aptify's Expo Management application.

Namespace hierarchy

Classes

Class | Description
Booth | Contains the Booth information required by both the Drawing object and the VisualFloorplan object.
BoothCombinationWizard |
BoothCombinationWizard.BoothCombinationWizardException |
BoothException |
BoothGeneratorForm |
Booths | Manages a collection of Booth objects.
BoothsLayout |
Floorplan |
FloorplanCopyWizard |
FloorplanCopyWizard.FloorplanCopyWizardException |
FloorplanViewerForm |
InputForm |

Interfaces

Interface | Description
IBooth |
IBooths |
IFloorplan |

Enumerations

Enumeration | Description
IFloorplan.FloorplanCopySettings |


Booth Class

Contains the Booth information required by both the Drawing object and the VisualFloorplan object.

For a list of all members of this type, see Booth Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
Booth

public class Booth : AptifyGenericEntity, IBooth

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

DEVELOPER: Robert Kihm DATE CREATED: 05/21/2001 CALLED BY: CGIVisualFloorplan.VisualFloorplan CGIDrawingVisio2000.Drawing CALLS: IMPLEMENTS: ICGIFloorplanBooth.ICGIBooth IGenericEntityModule.ICGIGenericEntity MODIFICATION HISTORY: MODIFIED BY DATE DETAILS Robert Kihm 12/02/2001 - Transferred to MMSBoothModule Robert Kihm 05/21/2001 - Initial Development

Requirements

Namespace: Aptify.Applications.ExpoManagement

Assembly: BoothObject (in BoothObject.dll)

See Also

Booth Members | Aptify.Applications.ExpoManagement Namespace


Booth Members

Booth overview

Public Instance Constructors

Booth Constructor Initializes a new instance of the Booth class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BoothID |
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CopyBoothID |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
Floorplan |
FoundOnDrawing |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LinkedCompanyName |
LinkedPersonName |
OriginalBoothID |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone | Overloaded.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config | Overloaded.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded.
Delete | Overloaded.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load | Overloaded.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord |
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
CanChangeAgainstFloorplan |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

Booth Class | Aptify.Applications.ExpoManagement Namespace


Booth Constructor

Initializes a new instance of the Booth class.

public Booth();

See Also

Booth Class | Aptify.Applications.ExpoManagement Namespace


Booth Properties

The properties of the Booth class are listed below. For a complete list of Booth class members, see the Booth Members topic.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BoothID |
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CopyBoothID |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
Floorplan |
FoundOnDrawing |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LinkedCompanyName |
LinkedPersonName |
OriginalBoothID |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

Booth Class | Aptify.Applications.ExpoManagement Namespace


BoothID Property

Aptify 5.0 Software Development Kit (SDK)

Booth.BoothID Property

public Int64 BoothID {get; set;}

Implements

IBooth.

See Also

Booth Class | Aptify.Applications.ExpoManagement Namespace


CopyBoothID Property

Aptify 5.0 Software Development Kit (SDK)

Booth.CopyBoothID Property

public Int64 CopyBoothID {get; set;}

Implements

IBooth.

See Also

Booth Class | Aptify.Applications.ExpoManagement Namespace


Floorplan Property

Aptify 5.0 Software Development Kit (SDK)

Booth.Floorplan Property

public IFloorplan Floorplan {get; set;}

Implements

IBooth.

See Also

Booth Class | Aptify.Applications.ExpoManagement Namespace


FoundOnDrawing Property

Aptify 5.0 Software Development Kit (SDK)

Booth.FoundOnDrawing Property

public Boolean FoundOnDrawing {get; set;}

Implements

IBooth.

See Also

Booth Class | Aptify.Applications.ExpoManagement Namespace


LinkedCompanyName Property

Aptify 5.0 Software Development Kit (SDK)

Booth.LinkedCompanyName Property

public String LinkedCompanyName {get;}

Implements

IBooth.

See Also

Booth Class | Aptify.Applications.ExpoManagement Namespace


LinkedPersonName Property

Aptify 5.0 Software Development Kit (SDK)

Booth.LinkedPersonName Property

public String LinkedPersonName {get;}

Implements

IBooth.

See Also

Booth Class | Aptify.Applications.ExpoManagement Namespace


OriginalBoothID Property

Aptify 5.0 Software Development Kit (SDK)

Booth.OriginalBoothID Property

public Int64 OriginalBoothID {get;}

Implements

IBooth.

See Also

Booth Class | Aptify.Applications.ExpoManagement Namespace


Booth Methods

The methods of the Booth class are listed below. For a complete list of Booth class members, see the Booth Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone | Overloaded.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config | Overloaded.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded.
Delete | Overloaded.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load | Overloaded.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord |
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
CanChangeAgainstFloorplan |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

Booth Class | Aptify.Applications.ExpoManagement Namespace


Booth.CanChangeAgainstFloorplan Method

protected virtual bool CanChangeAgainstFloorplan(
Int64 lFloorplanID,
ref String& sFloorplanStatus,
AptifyGenericEntityBase objFloorplanGE
);

See Also

Booth Class | Aptify.Applications.ExpoManagement Namespace


Clone Method

Aptify 5.0 Software Development Kit (SDK)

Booth.Clone Method

Overload List

public override void Clone(AptifyGenericEntityBase);

public override void Clone(AptifyGenericEntityBase,Boolean);

See Also

Booth Class | Aptify.Applications.ExpoManagement Namespace


Booth.Clone Method (AptifyGenericEntityBase)

public override void Clone(
AptifyGenericEntityBase ObjectToClone
);

See Also

Booth Class | Aptify.Applications.ExpoManagement Namespace | Booth.Clone Overload List


Booth.Clone Method (AptifyGenericEntityBase, Boolean)

public override void Clone(
AptifyGenericEntityBase ObjectToClone,
Boolean Merge
);

See Also

Booth Class | Aptify.Applications.ExpoManagement Namespace | Booth.Clone Overload List


Config Method

Aptify 5.0 Software Development Kit (SDK)

Booth.Config Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual void Config(AptifySubTypeBase);

Inherited from AptifyGenericEntity.

public override void Config(AptifySubTypeBase,Int64);

public override void Config(UserCredentials,String);

public override void Config(UserCredentials,String,Int64);

See Also

Booth Class | Aptify.Applications.ExpoManagement Namespace


Booth.Config Method (UserCredentials, String)

public override void Config(
UserCredentials UserCredentials,
String EntityName
);

See Also

Booth Class | Aptify.Applications.ExpoManagement Namespace | Booth.Config Overload List


Booth.Config Method (UserCredentials, String, Int64)

public override void Config(
UserCredentials UserCredentials,
String EntityName,
Int64 RecordID
);

See Also

Booth Class | Aptify.Applications.ExpoManagement Namespace | Booth.Config Overload List


Delete Method

Aptify 5.0 Software Development Kit (SDK)

Booth.Delete Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Delete();

public override bool Delete(String);

See Also

Booth Class | Aptify.Applications.ExpoManagement Namespace


Booth.Delete Method (String)

public override bool Delete(
String TransactionID
);

See Also

Booth Class | Aptify.Applications.ExpoManagement Namespace | Booth.Delete Overload List


GetValue Method

Aptify 5.0 Software Development Kit (SDK)

Booth.GetValue Method

Overload List

public override object GetValue(String);

Inherited from AptifyGenericEntityBase.

public virtual object GetValue(String,Boolean);

See Also

Booth Class | Aptify.Applications.ExpoManagement Namespace


Booth.GetValue Method (String)

public override object GetValue(
String FieldName
);

See Also

Booth Class | Aptify.Applications.ExpoManagement Namespace | Booth.GetValue Overload List


Load Method

Aptify 5.0 Software Development Kit (SDK)

Booth.Load Method

Overload List

Inherited from AptifyGenericEntity.

public override void Load(DataRow);

Inherited from AptifyGenericEntity.

public override void Load(IDataReader);

public override void Load(Int64);

public override void Load(String);

Inherited from AptifyGenericEntity.

public override void Load(String,Boolean);

See Also

Booth Class | Aptify.Applications.ExpoManagement Namespace


Booth.Load Method (Int64)

public override void Load(
Int64 ID
);

See Also

Booth Class | Aptify.Applications.ExpoManagement Namespace | Booth.Load Overload List


Booth.Load Method (String)

public override void Load(
String FileName
);

See Also

Booth Class | Aptify.Applications.ExpoManagement Namespace | Booth.Load Overload List


Booth.NewRecord Method

public override bool NewRecord();

See Also

Booth Class | Aptify.Applications.ExpoManagement Namespace


Save Method

Aptify 5.0 Software Development Kit (SDK)

Booth.Save Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Save();

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean,ref String&);

public override bool Save(Boolean,ref String&,String);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(ref String&);

See Also

Booth Class | Aptify.Applications.ExpoManagement Namespace


Booth.Save Method (Boolean, String&, String)

public override bool Save(
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

See Also

Booth Class | Aptify.Applications.ExpoManagement Namespace | Booth.Save Overload List


BoothCombinationWizard Class

For a list of all members of this type, see BoothCombinationWizard Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
BoothCombinationWizard

public class BoothCombinationWizard : Form, IAptifyAction

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.ExpoManagement

Assembly: AptifyBoothCombinationWizard (in AptifyBoothCombinationWizard.dll)

See Also

BoothCombinationWizard Members | Aptify.Applications.ExpoManagement Namespace


BoothCombinationWizard Members

BoothCombinationWizard overview

Public Instance Constructors

BoothCombinationWizard Constructor Initializes a new instance of the BoothCombinationWizard class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoAction | Overloaded.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

BoothCombinationWizard Class | Aptify.Applications.ExpoManagement Namespace


BoothCombinationWizard Constructor

Initializes a new instance of the BoothCombinationWizard class.

public BoothCombinationWizard();

See Also

BoothCombinationWizard Class | Aptify.Applications.ExpoManagement Namespace


BoothCombinationWizard Methods

The methods of the BoothCombinationWizard class are listed below. For a complete list of BoothCombinationWizard class members, see the BoothCombinationWizard Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoAction | Overloaded.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

BoothCombinationWizard Class | Aptify.Applications.ExpoManagement Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

BoothCombinationWizard.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

BoothCombinationWizard Class | Aptify.Applications.ExpoManagement Namespace


BoothCombinationWizard.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

BoothCombinationWizard Class | Aptify.Applications.ExpoManagement Namespace | BoothCombinationWizard.Dispose Overload List


DoAction Method

Aptify 5.0 Software Development Kit (SDK)

BoothCombinationWizard.DoAction Method

Overload List

public void DoAction(AptifyApplication,Int64);

public void DoAction(AptifyApplication,Int64,Int64);

public void DoAction(AptifyApplication,Int64,Int64,params Object[]);

public void DoAction(AptifyApplication,Int64,params String[]);

See Also

BoothCombinationWizard Class | Aptify.Applications.ExpoManagement Namespace


BoothCombinationWizard.DoAction Method (AptifyApplication, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID
);

Implements

IAptifyAction.

See Also

BoothCombinationWizard Class | Aptify.Applications.ExpoManagement Namespace | BoothCombinationWizard.DoAction Overload List


BoothCombinationWizard.DoAction Method (AptifyApplication, Int64, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID
);

Implements

IAptifyAction.

See Also

BoothCombinationWizard Class | Aptify.Applications.ExpoManagement Namespace | BoothCombinationWizard.DoAction Overload List


BoothCombinationWizard.DoAction Method (AptifyApplication, Int64, Int64, Object[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID,
params Object[] SelectedItems
);

Implements

IAptifyAction.

See Also

BoothCombinationWizard Class | Aptify.Applications.ExpoManagement Namespace | BoothCombinationWizard.DoAction Overload List


BoothCombinationWizard.DoAction Method (AptifyApplication, Int64, String[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
params String[] SelectedItems
);

Implements

IAptifyAction.

See Also

BoothCombinationWizard Class | Aptify.Applications.ExpoManagement Namespace | BoothCombinationWizard.DoAction Overload List


BoothCombinationWizard.BoothCombinationWizardException Class

For a list of all members of this type, see BoothCombinationWizard.BoothCombinationWizardException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
BoothCombinationWizard.BoothCombinationWizardException

public class BoothCombinationWizard.BoothCombinationWizardException : BaseApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.ExpoManagement

Assembly: AptifyBoothCombinationWizard (in AptifyBoothCombinationWizard.dll)

See Also

BoothCombinationWizard.BoothCombinationWizardException Members | Aptify.Applications.ExpoManagement Namespace


BoothCombinationWizard.BoothCombinationWizardException Members

BoothCombinationWizard.BoothCombinationWizardException overview

Public Instance Constructors

BoothCombinationWizard.BoothCombinationWizardException Overloaded. Initializes a new instance of the BoothCombinationWizard.BoothCombinationWizardException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from BaseApplicationException) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BoothCombinationWizard.BoothCombinationWizardException Class | Aptify.Applications.ExpoManagement Namespace


BoothCombinationWizard.BoothCombinationWizardException Constructor

Initializes a new instance of the BoothCombinationWizard.BoothCombinationWizardException class.

Overload List

Initializes a new instance of the BoothCombinationWizard.BoothCombinationWizardException class.

public BoothCombinationWizard.BoothCombinationWizardException();

public BoothCombinationWizard.BoothCombinationWizardException(String);

public BoothCombinationWizard.BoothCombinationWizardException(String,Exception);

See Also

BoothCombinationWizard.BoothCombinationWizardException Class | Aptify.Applications.ExpoManagement Namespace


BoothCombinationWizard.BoothCombinationWizardException Constructor ()

Initializes a new instance of the BoothCombinationWizard.BoothCombinationWizardException class.

public BoothCombinationWizard.BoothCombinationWizardException();

See Also

BoothCombinationWizard.BoothCombinationWizardException Class | Aptify.Applications.ExpoManagement Namespace | BoothCombinationWizard.BoothCombinationWizardException Constructor Overload List


BoothCombinationWizard.BoothCombinationWizardException Constructor (String)

public BoothCombinationWizard.BoothCombinationWizardException(
String Message
);

See Also

BoothCombinationWizard.BoothCombinationWizardException Class | Aptify.Applications.ExpoManagement Namespace | BoothCombinationWizard.BoothCombinationWizardException Constructor Overload List


BoothCombinationWizard.BoothCombinationWizardException Constructor (String, Exception)

public BoothCombinationWizard.BoothCombinationWizardException(
String Message,
Exception InnerException
);

See Also

BoothCombinationWizard.BoothCombinationWizardException Class | Aptify.Applications.ExpoManagement Namespace | BoothCombinationWizard.BoothCombinationWizardException Constructor Overload List


BoothException Class

For a list of all members of this type, see BoothException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
AptifyGenericEntityException
BoothException

public class BoothException : AptifyGenericEntityException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.ExpoManagement

Assembly: BoothObject (in BoothObject.dll)

See Also

BoothException Members | Aptify.Applications.ExpoManagement Namespace


BoothException Members

BoothException overview

Public Instance Constructors

BoothException Overloaded. Initializes a new instance of the BoothException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from AptifyGenericEntityException) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BoothException Class | Aptify.Applications.ExpoManagement Namespace


BoothException Constructor

Overload List

public BoothException(SerializationInfo,StreamingContext);

public BoothException(String);

public BoothException(String,Exception);

See Also

BoothException Class | Aptify.Applications.ExpoManagement Namespace


BoothException Constructor (String)

public BoothException(
String Message
);

See Also

BoothException Class | Aptify.Applications.ExpoManagement Namespace | BoothException Constructor Overload List


BoothException Constructor (String, Exception)

public BoothException(
String Message,
Exception inner
);

See Also

BoothException Class | Aptify.Applications.ExpoManagement Namespace | BoothException Constructor Overload List


BoothException Constructor (SerializationInfo, StreamingContext)

public BoothException(
SerializationInfo info,
StreamingContext context
);

See Also

BoothException Class | Aptify.Applications.ExpoManagement Namespace | BoothException Constructor Overload List


BoothGeneratorForm Class

For a list of all members of this type, see BoothGeneratorForm Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
BoothGeneratorForm

public class BoothGeneratorForm : Form

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.ExpoManagement

Assembly: FloorplanViewer (in FloorplanViewer.dll)

See Also

BoothGeneratorForm Members | Aptify.Applications.ExpoManagement Namespace


BoothGeneratorForm Members

BoothGeneratorForm overview

Public Instance Constructors

BoothGeneratorForm Constructor

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UserCredentials |
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateBooths |
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

BoothGeneratorForm Class | Aptify.Applications.ExpoManagement Namespace


BoothGeneratorForm Constructor

public BoothGeneratorForm(
UserCredentials pUserCredential
);

See Also

BoothGeneratorForm Class | Aptify.Applications.ExpoManagement Namespace


BoothGeneratorForm Properties

The properties of the BoothGeneratorForm class are listed below. For a complete list of BoothGeneratorForm class members, see the BoothGeneratorForm Members topic.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UserCredentials |
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

BoothGeneratorForm Class | Aptify.Applications.ExpoManagement Namespace


UserCredentials Property

Aptify 5.0 Software Development Kit (SDK)

BoothGeneratorForm.UserCredentials Property

public UserCredentials UserCredentials {get; set;}

See Also

BoothGeneratorForm Class | Aptify.Applications.ExpoManagement Namespace


BoothGeneratorForm Methods

The methods of the BoothGeneratorForm class are listed below. For a complete list of BoothGeneratorForm class members, see the BoothGeneratorForm Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateBooths |
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

BoothGeneratorForm Class | Aptify.Applications.ExpoManagement Namespace


BoothGeneratorForm.CreateBooths Method

public bool CreateBooths(
ref IFloorplan& objFloorplan
);

See Also

BoothGeneratorForm Class | Aptify.Applications.ExpoManagement Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

BoothGeneratorForm.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

BoothGeneratorForm Class | Aptify.Applications.ExpoManagement Namespace


BoothGeneratorForm.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

BoothGeneratorForm Class | Aptify.Applications.ExpoManagement Namespace | BoothGeneratorForm.Dispose Overload List


Booths Class

Manages a collection of Booth objects.

For a list of all members of this type, see Booths Members.

System.Object
Booths

public class Booths : IBooths

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

DEVELOPER: Robert Kihm DATE CREATED: 04/23/2001 CALLED BY: CGIVisualFloorplan.VisualFloorplan CGIDrawingVisio2000.Drawing CALLS: ICGIFloorplanBooth.ICGIFloorplan ICGIFloorplanBooth.ICGIBooth IMPLEMENTS: ICGIFloorplanBooth.ICGIBooths MODIFICATION HISTORY: MODIFIED BY DATE DETAILS Robert Kihm 12/02/2001 - Transferred to MMSBoothModule Robert Kihm 04/23/2001 - Initial Development

Requirements

Namespace: Aptify.Applications.ExpoManagement

Assembly: BoothObject (in BoothObject.dll)

See Also

Booths Members | Aptify.Applications.ExpoManagement Namespace


Booths Members

Booths overview

Public Instance Constructors

Booths Constructor Initializes a new instance of the Booths class.

Public Instance Properties

BoothCollection
CopyItem
Count
Floorplan
IsDirty
Item
Units

Public Instance Methods

Add |
Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
LoadByFloorplan |
NewEnum |
Remove |
ToString (inherited from Object) | Returns a String that represents the current Object.
Update |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Booths Class | Aptify.Applications.ExpoManagement Namespace


Booths Constructor

Initializes a new instance of the Booths class.

public Booths();

See Also

Booths Class | Aptify.Applications.ExpoManagement Namespace


Booths Properties

The properties of the Booths class are listed below. For a complete list of Booths class members, see the Booths Members topic.

Public Instance Properties

BoothCollection
CopyItem
Count
Floorplan
IsDirty
Item
Units

See Also

Booths Class | Aptify.Applications.ExpoManagement Namespace


BoothCollection Property

Aptify 5.0 Software Development Kit (SDK)

Booths.BoothCollection Property

public Collection BoothCollection {get;}

Implements

IBooths.

See Also

Booths Class | Aptify.Applications.ExpoManagement Namespace


CopyItem Property

Aptify 5.0 Software Development Kit (SDK)

Booths.CopyItem Property

public IBooth this[
Object vntKey
] {get;}

Implements

IBooths.

See Also

Booths Class | Aptify.Applications.ExpoManagement Namespace


Count Property

Aptify 5.0 Software Development Kit (SDK)

Booths.Count Property

public Int64 Count {get;}

Implements

IBooths.

See Also

Booths Class | Aptify.Applications.ExpoManagement Namespace


Floorplan Property

Aptify 5.0 Software Development Kit (SDK)

Booths.Floorplan Property

public IFloorplan Floorplan {get;}

Implements

IBooths.

See Also

Booths Class | Aptify.Applications.ExpoManagement Namespace


IsDirty Property

Aptify 5.0 Software Development Kit (SDK)

Booths.IsDirty Property

public Boolean IsDirty {get;}

Implements

IBooths.

See Also

Booths Class | Aptify.Applications.ExpoManagement Namespace


Item Property

Aptify 5.0 Software Development Kit (SDK)

Booths.Item Property

public IBooth this[
Object vntKey
] {get;}

Implements

IBooths.

See Also

Booths Class | Aptify.Applications.ExpoManagement Namespace


Units Property

Aptify 5.0 Software Development Kit (SDK)

Booths.Units Property

public Int64 Units {get;}

Implements

IBooths.

See Also

Booths Class | Aptify.Applications.ExpoManagement Namespace


Booths Methods

The methods of the Booths class are listed below. For a complete list of Booths class members, see the Booths Members topic.

Public Instance Methods

Add |
Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
LoadByFloorplan |
NewEnum |
Remove |
ToString (inherited from Object) | Returns a String that represents the current Object.
Update |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Booths Class | Aptify.Applications.ExpoManagement Namespace


Booths.Add Method

public IBooth Add(
ref IBooth& objCopyBooth
);

Implements

IBooths.

See Also

Booths Class | Aptify.Applications.ExpoManagement Namespace


Booths.Config Method

public bool Config(
UserCredentials UserCredentials
);

Implements

IBooths.

See Also

Booths Class | Aptify.Applications.ExpoManagement Namespace


Booths.LoadByFloorplan Method

public bool LoadByFloorplan(
ref IFloorplan& objFloorplan
);

Implements

IBooths.

See Also

Booths Class | Aptify.Applications.ExpoManagement Namespace


Booths.NewEnum Method

public object NewEnum();

Implements

IBooths.

See Also

Booths Class | Aptify.Applications.ExpoManagement Namespace


Booths.Remove Method

public bool Remove(
String vntKey
);

Implements

IBooths.

See Also

Booths Class | Aptify.Applications.ExpoManagement Namespace


Booths.Update Method

public bool Update();

Implements

IBooths.

See Also

Booths Class | Aptify.Applications.ExpoManagement Namespace


BoothsLayout Class

For a list of all members of this type, see BoothsLayout Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
BoothsLayout

public class BoothsLayout : FormTemplateLayout

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.ExpoManagement

Assembly: BoothsLayout (in BoothsLayout.dll)

See Also

BoothsLayout Members | Aptify.Applications.ExpoManagement Namespace


BoothsLayout Members

BoothsLayout overview

Public Instance Constructors

BoothsLayout Constructor Initializes a new instance of the BoothsLayout class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormTemplateLayout) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig |
OnFormTemplateLoaded |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

BoothsLayout Class | Aptify.Applications.ExpoManagement Namespace


BoothsLayout Constructor

Initializes a new instance of the BoothsLayout class.

public BoothsLayout();

See Also

BoothsLayout Class | Aptify.Applications.ExpoManagement Namespace


BoothsLayout Methods

The methods of the BoothsLayout class are listed below. For a complete list of BoothsLayout class members, see the BoothsLayout Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormTemplateLayout) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig |
OnFormTemplateLoaded |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

BoothsLayout Class | Aptify.Applications.ExpoManagement Namespace


BoothsLayout.OnFormComponentConfig Method

protected override void OnFormComponentConfig(
AptifyFormTemplateContext Context
);

Implements

IFormComponent.

See Also

BoothsLayout Class | Aptify.Applications.ExpoManagement Namespace


BoothsLayout.OnFormTemplateLoaded Method

protected override void OnFormTemplateLoaded(
FormTemplateLayout.FormTemplateLoadedEventArgs e
);

See Also

BoothsLayout Class | Aptify.Applications.ExpoManagement Namespace


OnShow Method

Aptify 5.0 Software Development Kit (SDK)

BoothsLayout.OnShow Method

Overload List

Inherited from FormComponent.

protected virtual void OnShow();

protected override void OnShow(Boolean);

See Also

BoothsLayout Class | Aptify.Applications.ExpoManagement Namespace


BoothsLayout.OnShow Method (Boolean)

protected override void OnShow(
Boolean Refresh
);

Implements

IFormComponent.

See Also

BoothsLayout Class | Aptify.Applications.ExpoManagement Namespace | BoothsLayout.OnShow Overload List


Floorplan Class

For a list of all members of this type, see Floorplan Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
Floorplan

public class Floorplan : AptifyGenericEntity, IFloorplan

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.ExpoManagement

Assembly: FloorplanObject (in FloorplanObject.dll)

See Also

Floorplan Members | Aptify.Applications.ExpoManagement Namespace


Floorplan Members

Floorplan overview

Public Instance Constructors

Floorplan Constructor Initializes a new instance of the Floorplan class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BoothCount |
Booths |
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CopyDrawing |
CopyFloorplanID |
CopySettings |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
CustomUI |
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultDrawingObject |
DefaultDrawingStencil |
DefaultDrawingStencilName |
DefaultDrawingTemplate |
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
Drawing |
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
FloorplanStatus |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.
VisualFloorplanObject |

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config | Overloaded.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
DoCopyFloorplan |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenerateBoothName |
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue |
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

Floorplan Class | Aptify.Applications.ExpoManagement Namespace


Floorplan Constructor

Initializes a new instance of the Floorplan class.

public Floorplan();

See Also

Floorplan Class | Aptify.Applications.ExpoManagement Namespace


Floorplan Properties

The properties of the Floorplan class are listed below. For a complete list of Floorplan class members, see the Floorplan Members topic.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BoothCount |
Booths |
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CopyDrawing |
CopyFloorplanID |
CopySettings |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
CustomUI |
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultDrawingObject |
DefaultDrawingStencil |
DefaultDrawingStencilName |
DefaultDrawingTemplate |
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
Drawing |
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
FloorplanStatus |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.
VisualFloorplanObject |

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

Floorplan Class | Aptify.Applications.ExpoManagement Namespace


BoothCount Property

Aptify 5.0 Software Development Kit (SDK)

Floorplan.BoothCount Property

public Int64 BoothCount {get;}

Implements

IFloorplan.

See Also

Floorplan Class | Aptify.Applications.ExpoManagement Namespace


Booths Property

Aptify 5.0 Software Development Kit (SDK)

Floorplan.Booths Property

public IBooths Booths {get;}

Implements

IFloorplan.

See Also

Floorplan Class | Aptify.Applications.ExpoManagement Namespace


CopyDrawing Property

Aptify 5.0 Software Development Kit (SDK)

Floorplan.CopyDrawing Property

public String CopyDrawing {get;}

Implements

IFloorplan.

See Also

Floorplan Class | Aptify.Applications.ExpoManagement Namespace


CopyFloorplanID Property

Aptify 5.0 Software Development Kit (SDK)

Floorplan.CopyFloorplanID Property

public Int64 CopyFloorplanID {get;}

Implements

IFloorplan.

See Also

Floorplan Class | Aptify.Applications.ExpoManagement Namespace


CopySettings Property

Aptify 5.0 Software Development Kit (SDK)

Floorplan.CopySettings Property

public Int64 CopySettings {get; set;}

Implements

IFloorplan.

See Also

Floorplan Class | Aptify.Applications.ExpoManagement Namespace


CustomUI Property

Aptify 5.0 Software Development Kit (SDK)

Floorplan.CustomUI Property

public String CustomUI {get;}

Implements

IFloorplan.

See Also

Floorplan Class | Aptify.Applications.ExpoManagement Namespace


DefaultDrawingObject Property

Aptify 5.0 Software Development Kit (SDK)

Floorplan.DefaultDrawingObject Property

public String DefaultDrawingObject {get;}

Implements

IFloorplan.

See Also

Floorplan Class | Aptify.Applications.ExpoManagement Namespace


DefaultDrawingStencil Property

Aptify 5.0 Software Development Kit (SDK)

Floorplan.DefaultDrawingStencil Property

public String DefaultDrawingStencil {get;}

Implements

IFloorplan.

See Also

Floorplan Class | Aptify.Applications.ExpoManagement Namespace


DefaultDrawingStencilName Property

Aptify 5.0 Software Development Kit (SDK)

Floorplan.DefaultDrawingStencilName Property

public String DefaultDrawingStencilName {get;}

Implements

IFloorplan.

See Also

Floorplan Class | Aptify.Applications.ExpoManagement Namespace


DefaultDrawingTemplate Property

Aptify 5.0 Software Development Kit (SDK)

Floorplan.DefaultDrawingTemplate Property

public String DefaultDrawingTemplate {get;}

Implements

IFloorplan.

See Also

Floorplan Class | Aptify.Applications.ExpoManagement Namespace


Drawing Property

Aptify 5.0 Software Development Kit (SDK)

Floorplan.Drawing Property

public String Drawing {get; set;}

Implements

IFloorplan.

See Also

Floorplan Class | Aptify.Applications.ExpoManagement Namespace


FloorplanStatus Property

Aptify 5.0 Software Development Kit (SDK)

Floorplan.FloorplanStatus Property

public AptifyGenericEntityBase FloorplanStatus {get;}

Implements

IFloorplan.

See Also

Floorplan Class | Aptify.Applications.ExpoManagement Namespace


VisualFloorplanObject Property

Aptify 5.0 Software Development Kit (SDK)

Floorplan.VisualFloorplanObject Property

public String VisualFloorplanObject {get;}

Implements

IFloorplan.

See Also

Floorplan Class | Aptify.Applications.ExpoManagement Namespace


Floorplan Methods

The methods of the Floorplan class are listed below. For a complete list of Floorplan class members, see the Floorplan Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config | Overloaded.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
DoCopyFloorplan |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenerateBoothName |
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue |
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

Floorplan Class | Aptify.Applications.ExpoManagement Namespace


Config Method

Aptify 5.0 Software Development Kit (SDK)

Floorplan.Config Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual void Config(AptifySubTypeBase);

Inherited from AptifyGenericEntity.

public override void Config(AptifySubTypeBase,Int64);

public override void Config(UserCredentials,String);

public override void Config(UserCredentials,String,Int64);

See Also

Floorplan Class | Aptify.Applications.ExpoManagement Namespace


Floorplan.Config Method (UserCredentials, String)

public override void Config(
UserCredentials UserCredentials,
String EntityName
);

See Also

Floorplan Class | Aptify.Applications.ExpoManagement Namespace | Floorplan.Config Overload List


Floorplan.Config Method (UserCredentials, String, Int64)

public override void Config(
UserCredentials UserCredentials,
String EntityName,
Int64 RecordID
);

See Also

Floorplan Class | Aptify.Applications.ExpoManagement Namespace | Floorplan.Config Overload List


Floorplan.DoCopyFloorplan Method

public bool DoCopyFloorplan(
Int64 lCopyFloorplanID
);

Implements

IFloorplan.

See Also

Floorplan Class | Aptify.Applications.ExpoManagement Namespace


Floorplan.GenerateBoothName Method

public string GenerateBoothName();

Implements

IFloorplan.

See Also

Floorplan Class | Aptify.Applications.ExpoManagement Namespace


Floorplan.SetValue Method

public override void SetValue(
String FieldName,
Object Value
);

See Also

Floorplan Class | Aptify.Applications.ExpoManagement Namespace


FloorplanCopyWizard Class

For a list of all members of this type, see FloorplanCopyWizard Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
FloorplanCopyWizard

public class FloorplanCopyWizard : Form, IAptifyAction

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.ExpoManagement

Assembly: AptifyFloorplanCopyWizard (in AptifyFloorplanCopyWizard.dll)

See Also

FloorplanCopyWizard Members | Aptify.Applications.ExpoManagement Namespace


FloorplanCopyWizard Members

FloorplanCopyWizard overview

Public Instance Constructors

FloorplanCopyWizard Constructor Initializes a new instance of the FloorplanCopyWizard class.

Public Instance Fields

OK

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoAction | Overloaded.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

FloorplanCopyWizard Class | Aptify.Applications.ExpoManagement Namespace


FloorplanCopyWizard Constructor

Initializes a new instance of the FloorplanCopyWizard class.

public FloorplanCopyWizard();

See Also

FloorplanCopyWizard Class | Aptify.Applications.ExpoManagement Namespace


FloorplanCopyWizard Fields

The fields of the FloorplanCopyWizard class are listed below. For a complete list of FloorplanCopyWizard class members, see the FloorplanCopyWizard Members topic.

Public Instance Fields

OK

See Also

FloorplanCopyWizard Class | Aptify.Applications.ExpoManagement Namespace


FloorplanCopyWizard.OK Field

public OK OK;

See Also

FloorplanCopyWizard Class | Aptify.Applications.ExpoManagement Namespace


FloorplanCopyWizard Methods

The methods of the FloorplanCopyWizard class are listed below. For a complete list of FloorplanCopyWizard class members, see the FloorplanCopyWizard Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoAction | Overloaded.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

FloorplanCopyWizard Class | Aptify.Applications.ExpoManagement Namespace


FloorplanCopyWizard.Config Method

public bool Config(
ref Boolean& bDisplayError
);

See Also

FloorplanCopyWizard Class | Aptify.Applications.ExpoManagement Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

FloorplanCopyWizard.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

FloorplanCopyWizard Class | Aptify.Applications.ExpoManagement Namespace


FloorplanCopyWizard.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

FloorplanCopyWizard Class | Aptify.Applications.ExpoManagement Namespace | FloorplanCopyWizard.Dispose Overload List


DoAction Method

Aptify 5.0 Software Development Kit (SDK)

FloorplanCopyWizard.DoAction Method

Overload List

public void DoAction(AptifyApplication,Int64);

public void DoAction(AptifyApplication,Int64,Int64);

public void DoAction(AptifyApplication,Int64,Int64,params Object[]);

public void DoAction(AptifyApplication,Int64,params String[]);

See Also

FloorplanCopyWizard Class | Aptify.Applications.ExpoManagement Namespace


FloorplanCopyWizard.DoAction Method (AptifyApplication, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID
);

Implements

IAptifyAction.

See Also

FloorplanCopyWizard Class | Aptify.Applications.ExpoManagement Namespace | FloorplanCopyWizard.DoAction Overload List


FloorplanCopyWizard.DoAction Method (AptifyApplication, Int64, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID
);

Implements

IAptifyAction.

See Also

FloorplanCopyWizard Class | Aptify.Applications.ExpoManagement Namespace | FloorplanCopyWizard.DoAction Overload List


FloorplanCopyWizard.DoAction Method (AptifyApplication, Int64, Int64, Object[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID,
params Object[] SelectedItems
);

Implements

IAptifyAction.

See Also

FloorplanCopyWizard Class | Aptify.Applications.ExpoManagement Namespace | FloorplanCopyWizard.DoAction Overload List


FloorplanCopyWizard.DoAction Method (AptifyApplication, Int64, String[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
params String[] SelectedItems
);

Implements

IAptifyAction.

See Also

FloorplanCopyWizard Class | Aptify.Applications.ExpoManagement Namespace | FloorplanCopyWizard.DoAction Overload List


FloorplanCopyWizard.FloorplanCopyWizardException Class

For a list of all members of this type, see FloorplanCopyWizard.FloorplanCopyWizardException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
FloorplanCopyWizard.FloorplanCopyWizardException

public class FloorplanCopyWizard.FloorplanCopyWizardException : BaseApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.ExpoManagement

Assembly: AptifyFloorplanCopyWizard (in AptifyFloorplanCopyWizard.dll)

See Also

FloorplanCopyWizard.FloorplanCopyWizardException Members | Aptify.Applications.ExpoManagement Namespace


FloorplanCopyWizard.FloorplanCopyWizardException Members

FloorplanCopyWizard.FloorplanCopyWizardException overview

Public Instance Constructors

FloorplanCopyWizard.FloorplanCopyWizardException Overloaded. Initializes a new instance of the FloorplanCopyWizard.FloorplanCopyWizardException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from BaseApplicationException) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FloorplanCopyWizard.FloorplanCopyWizardException Class | Aptify.Applications.ExpoManagement Namespace


FloorplanCopyWizard.FloorplanCopyWizardException Constructor

Initializes a new instance of the FloorplanCopyWizard.FloorplanCopyWizardException class.

Overload List

Initializes a new instance of the FloorplanCopyWizard.FloorplanCopyWizardException class.

public FloorplanCopyWizard.FloorplanCopyWizardException();

public FloorplanCopyWizard.FloorplanCopyWizardException(String);

public FloorplanCopyWizard.FloorplanCopyWizardException(String,Exception);

See Also

FloorplanCopyWizard.FloorplanCopyWizardException Class | Aptify.Applications.ExpoManagement Namespace


FloorplanCopyWizard.FloorplanCopyWizardException Constructor ()

Initializes a new instance of the FloorplanCopyWizard.FloorplanCopyWizardException class.

public FloorplanCopyWizard.FloorplanCopyWizardException();

See Also

FloorplanCopyWizard.FloorplanCopyWizardException Class | Aptify.Applications.ExpoManagement Namespace | FloorplanCopyWizard.FloorplanCopyWizardException Constructor Overload List


FloorplanCopyWizard.FloorplanCopyWizardException Constructor (String)

public FloorplanCopyWizard.FloorplanCopyWizardException(
String Message
);

See Also

FloorplanCopyWizard.FloorplanCopyWizardException Class | Aptify.Applications.ExpoManagement Namespace | FloorplanCopyWizard.FloorplanCopyWizardException Constructor Overload List


FloorplanCopyWizard.FloorplanCopyWizardException Constructor (String, Exception)

public FloorplanCopyWizard.FloorplanCopyWizardException(
String Message,
Exception InnerException
);

See Also

FloorplanCopyWizard.FloorplanCopyWizardException Class | Aptify.Applications.ExpoManagement Namespace | FloorplanCopyWizard.FloorplanCopyWizardException Constructor Overload List


FloorplanViewerForm Class

For a list of all members of this type, see FloorplanViewerForm Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
FloorplanViewerForm

public class FloorplanViewerForm : Form, IAptifyTopLevelViewer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.ExpoManagement

Assembly: FloorplanViewer (in FloorplanViewer.dll)

See Also

FloorplanViewerForm Members | Aptify.Applications.ExpoManagement Namespace


FloorplanViewerForm Members

FloorplanViewerForm overview

Public Instance Constructors

FloorplanViewerForm Constructor Initializes a new instance of the FloorplanViewerForm class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config | Overloaded.
ConfigureControls |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show | Overloaded.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
ShowDialog | Overloaded.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog with the specified owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

FloorplanViewerForm Class | Aptify.Applications.ExpoManagement Namespace


FloorplanViewerForm Constructor

Initializes a new instance of the FloorplanViewerForm class.

public FloorplanViewerForm();

See Also

FloorplanViewerForm Class | Aptify.Applications.ExpoManagement Namespace


FloorplanViewerForm Methods

The methods of the FloorplanViewerForm class are listed below. For a complete list of FloorplanViewerForm class members, see the FloorplanViewerForm Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config | Overloaded.
ConfigureControls |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show | Overloaded.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
ShowDialog | Overloaded.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog with the specified owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

FloorplanViewerForm Class | Aptify.Applications.ExpoManagement Namespace


FloorplanViewerForm.ApplySkin Method

protected virtual void ApplySkin();

See Also

FloorplanViewerForm Class | Aptify.Applications.ExpoManagement Namespace


Config Method

Aptify 5.0 Software Development Kit (SDK)

FloorplanViewerForm.Config Method

Overload List

public void Config(AptifyGenericEntityBase);

public void Config(UserCredentials,String);

public void Config(UserCredentials,String,Int64);

public void Config(UserCredentials,String,String);

See Also

FloorplanViewerForm Class | Aptify.Applications.ExpoManagement Namespace


FloorplanViewerForm.Config Method (AptifyGenericEntityBase)

public void Config(
AptifyGenericEntityBase GE
);

Implements

IAptifyTopLevelViewer.

See Also

FloorplanViewerForm Class | Aptify.Applications.ExpoManagement Namespace | FloorplanViewerForm.Config Overload List


FloorplanViewerForm.Config Method (UserCredentials, String)

public void Config(
UserCredentials UserCredentials,
String CmdString
);

Implements

IAptifyTopLevelViewer.

See Also

FloorplanViewerForm Class | Aptify.Applications.ExpoManagement Namespace | FloorplanViewerForm.Config Overload List


FloorplanViewerForm.Config Method (UserCredentials, String, Int64)

public void Config(
UserCredentials UserCredentials,
String EntityName,
Int64 RecordID
);

Implements

IAptifyTopLevelViewer.

See Also

FloorplanViewerForm Class | Aptify.Applications.ExpoManagement Namespace | FloorplanViewerForm.Config Overload List


FloorplanViewerForm.Config Method (UserCredentials, String, String)

public void Config(
UserCredentials UserCredentials,
String EntityName,
String NewRecordParameters
);

Implements

IAptifyTopLevelViewer.

See Also

FloorplanViewerForm Class | Aptify.Applications.ExpoManagement Namespace | FloorplanViewerForm.Config Overload List


FloorplanViewerForm.ConfigureControls Method

public void ConfigureControls();

See Also

FloorplanViewerForm Class | Aptify.Applications.ExpoManagement Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

FloorplanViewerForm.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

FloorplanViewerForm Class | Aptify.Applications.ExpoManagement Namespace


FloorplanViewerForm.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

FloorplanViewerForm Class | Aptify.Applications.ExpoManagement Namespace | FloorplanViewerForm.Dispose Overload List


Show Method

Aptify 5.0 Software Development Kit (SDK)

FloorplanViewerForm.Show Method

Overload List

new public void Show();

public void Show(Form);

Inherited from Form.

public void Show(IWin32Window);

See Also

FloorplanViewerForm Class | Aptify.Applications.ExpoManagement Namespace


FloorplanViewerForm.Show Method ()

new public void Show();

Implements

IAptifyTopLevelViewer.

See Also

FloorplanViewerForm Class | Aptify.Applications.ExpoManagement Namespace | FloorplanViewerForm.Show Overload List


FloorplanViewerForm.Show Method (Form)

public void Show(
Form ParentForm
);

Implements

IAptifyTopLevelViewer.

See Also

FloorplanViewerForm Class | Aptify.Applications.ExpoManagement Namespace | FloorplanViewerForm.Show Overload List


ShowDialog Method

Aptify 5.0 Software Development Kit (SDK)

FloorplanViewerForm.ShowDialog Method

Overload List

new public DialogResult ShowDialog();

public DialogResult ShowDialog(Form);

Inherited from Form.

public DialogResult ShowDialog(IWin32Window);

See Also

FloorplanViewerForm Class | Aptify.Applications.ExpoManagement Namespace


FloorplanViewerForm.ShowDialog Method ()

new public DialogResult ShowDialog();

Implements

IAptifyTopLevelViewer.

See Also

FloorplanViewerForm Class | Aptify.Applications.ExpoManagement Namespace | FloorplanViewerForm.ShowDialog Overload List


FloorplanViewerForm.ShowDialog Method (Form)

public DialogResult ShowDialog(
Form ParentForm
);

Implements

IAptifyTopLevelViewer.

See Also

FloorplanViewerForm Class | Aptify.Applications.ExpoManagement Namespace | FloorplanViewerForm.ShowDialog Overload List


IBooth Interface

For a list of all members of this type, see IBooth Members.

public interface IBooth

Types that implement IBooth

Type | Description
Booth | Contains the Booth information required by both the Drawing object and the VisualFloorplan object.

Requirements

Namespace: Aptify.Applications.ExpoManagement

Assembly: IFloorplanBooth (in IFloorplanBooth.dll)

See Also

IBooth Members | Aptify.Applications.ExpoManagement Namespace


IBooth Members

IBooth overview

Public Instance Properties

BoothID
CopyBoothID
Floorplan
FoundOnDrawing
LinkedCompanyName
LinkedPersonName
OriginalBoothID

See Also

IBooth Interface | Aptify.Applications.ExpoManagement Namespace


IBooth Properties

The properties of the IBooth interface are listed below. For a complete list of IBooth interface members, see the IBooth Members topic.

Public Instance Properties

BoothID
CopyBoothID
Floorplan
FoundOnDrawing
LinkedCompanyName
LinkedPersonName
OriginalBoothID

See Also

IBooth Interface | Aptify.Applications.ExpoManagement Namespace


BoothID Property

Aptify 5.0 Software Development Kit (SDK)

IBooth.BoothID Property

Int64 BoothID {get; set;}

See Also

IBooth Interface | Aptify.Applications.ExpoManagement Namespace


CopyBoothID Property

Aptify 5.0 Software Development Kit (SDK)

IBooth.CopyBoothID Property

Int64 CopyBoothID {get; set;}

See Also

IBooth Interface | Aptify.Applications.ExpoManagement Namespace


Floorplan Property

Aptify 5.0 Software Development Kit (SDK)

IBooth.Floorplan Property

IFloorplan Floorplan {get; set;}

See Also

IBooth Interface | Aptify.Applications.ExpoManagement Namespace


FoundOnDrawing Property

Aptify 5.0 Software Development Kit (SDK)

IBooth.FoundOnDrawing Property

Boolean FoundOnDrawing {get; set;}

See Also

IBooth Interface | Aptify.Applications.ExpoManagement Namespace


LinkedCompanyName Property

Aptify 5.0 Software Development Kit (SDK)

IBooth.LinkedCompanyName Property

String LinkedCompanyName {get;}

See Also

IBooth Interface | Aptify.Applications.ExpoManagement Namespace


LinkedPersonName Property

Aptify 5.0 Software Development Kit (SDK)

IBooth.LinkedPersonName Property

String LinkedPersonName {get;}

See Also

IBooth Interface | Aptify.Applications.ExpoManagement Namespace


OriginalBoothID Property

Aptify 5.0 Software Development Kit (SDK)

IBooth.OriginalBoothID Property

Int64 OriginalBoothID {get;}

See Also

IBooth Interface | Aptify.Applications.ExpoManagement Namespace


IBooths Interface

For a list of all members of this type, see IBooths Members.

public interface IBooths

Types that implement IBooths

Type | Description
Booths | Manages a collection of Booth objects.

Requirements

Namespace: Aptify.Applications.ExpoManagement

Assembly: IFloorplanBooth (in IFloorplanBooth.dll)

See Also

IBooths Members | Aptify.Applications.ExpoManagement Namespace


IBooths Members

IBooths overview

Public Instance Properties

BoothCollection
CopyItem
Count
Floorplan
IsDirty
Item
Units

Public Instance Methods

Add
Config
LoadByFloorplan
NewEnum
Remove
Update

See Also

IBooths Interface | Aptify.Applications.ExpoManagement Namespace


IBooths Properties

The properties of the IBooths interface are listed below. For a complete list of IBooths interface members, see the IBooths Members topic.

Public Instance Properties

BoothCollection
CopyItem
Count
Floorplan
IsDirty
Item
Units

See Also

IBooths Interface | Aptify.Applications.ExpoManagement Namespace


BoothCollection Property

Aptify 5.0 Software Development Kit (SDK)

IBooths.BoothCollection Property

Collection BoothCollection {get;}

See Also

IBooths Interface | Aptify.Applications.ExpoManagement Namespace


CopyItem Property

Aptify 5.0 Software Development Kit (SDK)

IBooths.CopyItem Property

IBooth this[
Object vntKey
] {get;}

See Also

IBooths Interface | Aptify.Applications.ExpoManagement Namespace


Count Property

Aptify 5.0 Software Development Kit (SDK)

IBooths.Count Property

Int64 Count {get;}

See Also

IBooths Interface | Aptify.Applications.ExpoManagement Namespace


Floorplan Property

Aptify 5.0 Software Development Kit (SDK)

IBooths.Floorplan Property

IFloorplan Floorplan {get;}

See Also

IBooths Interface | Aptify.Applications.ExpoManagement Namespace


IsDirty Property

Aptify 5.0 Software Development Kit (SDK)

IBooths.IsDirty Property

Boolean IsDirty {get;}

See Also

IBooths Interface | Aptify.Applications.ExpoManagement Namespace


Item Property

Aptify 5.0 Software Development Kit (SDK)

IBooths.Item Property

IBooth this[
Object vntKey
] {get;}

See Also

IBooths Interface | Aptify.Applications.ExpoManagement Namespace


Units Property

Aptify 5.0 Software Development Kit (SDK)

IBooths.Units Property

Int64 Units {get;}

See Also

IBooths Interface | Aptify.Applications.ExpoManagement Namespace


IBooths Methods

The methods of the IBooths interface are listed below. For a complete list of IBooths interface members, see the IBooths Members topic.

Public Instance Methods

Add
Config
LoadByFloorplan
NewEnum
Remove
Update

See Also

IBooths Interface | Aptify.Applications.ExpoManagement Namespace


IBooths.Add Method

IBooth Add(
ref IBooth& objCopyBooth
);

See Also

IBooths Interface | Aptify.Applications.ExpoManagement Namespace


IBooths.Config Method

bool Config(
UserCredentials UserCredentials
);

See Also

IBooths Interface | Aptify.Applications.ExpoManagement Namespace


IBooths.LoadByFloorplan Method

bool LoadByFloorplan(
ref IFloorplan& objFloorplan
);

See Also

IBooths Interface | Aptify.Applications.ExpoManagement Namespace


IBooths.NewEnum Method

object NewEnum();

See Also

IBooths Interface | Aptify.Applications.ExpoManagement Namespace


IBooths.Remove Method

bool Remove(
String vntKey
);

See Also

IBooths Interface | Aptify.Applications.ExpoManagement Namespace


IBooths.Update Method

bool Update();

See Also

IBooths Interface | Aptify.Applications.ExpoManagement Namespace


IFloorplan Interface

For a list of all members of this type, see IFloorplan Members.

public interface IFloorplan

Types that implement IFloorplan

Type | Description
Floorplan |

Requirements

Namespace: Aptify.Applications.ExpoManagement

Assembly: IFloorplanBooth (in IFloorplanBooth.dll)

See Also

IFloorplan Members | Aptify.Applications.ExpoManagement Namespace


IFloorplan Members

IFloorplan overview

Public Instance Properties

BoothCount
Booths
CopyDrawing
CopyFloorplanID
CopySettings
CustomUI
DefaultDrawingObject
DefaultDrawingStencil
DefaultDrawingStencilName
DefaultDrawingTemplate
Drawing
FloorplanStatus
VisualFloorplanObject

Public Instance Methods

DoCopyFloorplan
GenerateBoothName

See Also

IFloorplan Interface | Aptify.Applications.ExpoManagement Namespace


IFloorplan Properties

The properties of the IFloorplan interface are listed below. For a complete list of IFloorplan interface members, see the IFloorplan Members topic.

Public Instance Properties

BoothCount
Booths
CopyDrawing
CopyFloorplanID
CopySettings
CustomUI
DefaultDrawingObject
DefaultDrawingStencil
DefaultDrawingStencilName
DefaultDrawingTemplate
Drawing
FloorplanStatus
VisualFloorplanObject

See Also

IFloorplan Interface | Aptify.Applications.ExpoManagement Namespace


BoothCount Property

Aptify 5.0 Software Development Kit (SDK)

IFloorplan.BoothCount Property

Int64 BoothCount {get;}

See Also

IFloorplan Interface | Aptify.Applications.ExpoManagement Namespace


Booths Property

Aptify 5.0 Software Development Kit (SDK)

IFloorplan.Booths Property

IBooths Booths {get;}

See Also

IFloorplan Interface | Aptify.Applications.ExpoManagement Namespace


CopyDrawing Property

Aptify 5.0 Software Development Kit (SDK)

IFloorplan.CopyDrawing Property

String CopyDrawing {get;}

See Also

IFloorplan Interface | Aptify.Applications.ExpoManagement Namespace


CopyFloorplanID Property

Aptify 5.0 Software Development Kit (SDK)

IFloorplan.CopyFloorplanID Property

Int64 CopyFloorplanID {get;}

See Also

IFloorplan Interface | Aptify.Applications.ExpoManagement Namespace


CopySettings Property

Aptify 5.0 Software Development Kit (SDK)

IFloorplan.CopySettings Property

Int64 CopySettings {get; set;}

See Also

IFloorplan Interface | Aptify.Applications.ExpoManagement Namespace


CustomUI Property

Aptify 5.0 Software Development Kit (SDK)

IFloorplan.CustomUI Property

String CustomUI {get;}

See Also

IFloorplan Interface | Aptify.Applications.ExpoManagement Namespace


DefaultDrawingObject Property

Aptify 5.0 Software Development Kit (SDK)

IFloorplan.DefaultDrawingObject Property

String DefaultDrawingObject {get;}

See Also

IFloorplan Interface | Aptify.Applications.ExpoManagement Namespace


DefaultDrawingStencil Property

Aptify 5.0 Software Development Kit (SDK)

IFloorplan.DefaultDrawingStencil Property

String DefaultDrawingStencil {get;}

See Also

IFloorplan Interface | Aptify.Applications.ExpoManagement Namespace


DefaultDrawingStencilName Property

Aptify 5.0 Software Development Kit (SDK)

IFloorplan.DefaultDrawingStencilName Property

String DefaultDrawingStencilName {get;}

See Also

IFloorplan Interface | Aptify.Applications.ExpoManagement Namespace


DefaultDrawingTemplate Property

Aptify 5.0 Software Development Kit (SDK)

IFloorplan.DefaultDrawingTemplate Property

String DefaultDrawingTemplate {get;}

See Also

IFloorplan Interface | Aptify.Applications.ExpoManagement Namespace


Drawing Property

Aptify 5.0 Software Development Kit (SDK)

IFloorplan.Drawing Property

String Drawing {get; set;}

See Also

IFloorplan Interface | Aptify.Applications.ExpoManagement Namespace


FloorplanStatus Property

Aptify 5.0 Software Development Kit (SDK)

IFloorplan.FloorplanStatus Property

AptifyGenericEntityBase FloorplanStatus {get;}

See Also

IFloorplan Interface | Aptify.Applications.ExpoManagement Namespace


VisualFloorplanObject Property

Aptify 5.0 Software Development Kit (SDK)

IFloorplan.VisualFloorplanObject Property

String VisualFloorplanObject {get;}

See Also

IFloorplan Interface | Aptify.Applications.ExpoManagement Namespace


IFloorplan Methods

The methods of the IFloorplan interface are listed below. For a complete list of IFloorplan interface members, see the IFloorplan Members topic.

Public Instance Methods

DoCopyFloorplan
GenerateBoothName

See Also

IFloorplan Interface | Aptify.Applications.ExpoManagement Namespace


IFloorplan.DoCopyFloorplan Method

bool DoCopyFloorplan(
Int64 lCopyFloorplanID
);

See Also

IFloorplan Interface | Aptify.Applications.ExpoManagement Namespace


IFloorplan.GenerateBoothName Method

string GenerateBoothName();

See Also

IFloorplan Interface | Aptify.Applications.ExpoManagement Namespace


IFloorplan.FloorplanCopySettings Enumeration

public enum IFloorplan.FloorplanCopySettings

Members

Member Name | Description
fcsArchitecture |
fcsBoothCombination |
fcsBoothNoCombination |

Requirements

Namespace: Aptify.Applications.ExpoManagement

Assembly: IFloorplanBooth (in IFloorplanBooth.dll)

See Also

Aptify.Applications.ExpoManagement Namespace


InputForm Class

For a list of all members of this type, see InputForm Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
InputForm

public class InputForm : Form

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.ExpoManagement

Assembly: FloorplanViewer (in FloorplanViewer.dll)

See Also

InputForm Members | Aptify.Applications.ExpoManagement Namespace


InputForm Members

InputForm overview

Public Instance Constructors

InputForm Constructor Initializes a new instance of the InputForm class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UserCredential |
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetNumericInput |
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

InputForm Class | Aptify.Applications.ExpoManagement Namespace


InputForm Constructor

Initializes a new instance of the InputForm class.

public InputForm();

See Also

InputForm Class | Aptify.Applications.ExpoManagement Namespace


InputForm Properties

The properties of the InputForm class are listed below. For a complete list of InputForm class members, see the InputForm Members topic.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UserCredential |
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

InputForm Class | Aptify.Applications.ExpoManagement Namespace


UserCredential Property

Aptify 5.0 Software Development Kit (SDK)

InputForm.UserCredential Property

public UserCredentials UserCredential {get; set;}

See Also

InputForm Class | Aptify.Applications.ExpoManagement Namespace


InputForm Methods

The methods of the InputForm class are listed below. For a complete list of InputForm class members, see the InputForm Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetNumericInput |
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

InputForm Class | Aptify.Applications.ExpoManagement Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

InputForm.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

InputForm Class | Aptify.Applications.ExpoManagement Namespace


InputForm.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

InputForm Class | Aptify.Applications.ExpoManagement Namespace | InputForm.Dispose Overload List


InputForm.GetNumericInput Method

public bool GetNumericInput(
String sFormCaption,
String sLabelCaption,
Boolean bAllowDecimal,
Boolean bAllowNegative,
ref Single& vInput
);

See Also

InputForm Class | Aptify.Applications.ExpoManagement Namespace


Aptify.Applications.Expos

Aptify 5.0 Software Development Kit (SDK)

Aptify.Applications.Expos Namespace

The objects in this namespace implement the Priority Points functionality of the Expo Management application.

Namespace hierarchy

Classes

Class | Description
CreatePriorityPoints | Implements a process component that will create priority points for a given order when it ships.
CreatePriorityPoints.ExpoInfo |


CreatePriorityPoints Class

Implements a process component that will create priority points for a given order when it ships.

For a list of all members of this type, see CreatePriorityPoints Members.

System.Object
CreatePriorityPoints

public class CreatePriorityPoints : IProcessComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Expos

Assembly: CreatePriorityPoints (in CreatePriorityPoints.dll)

See Also

CreatePriorityPoints Members | Aptify.Applications.Expos Namespace


CreatePriorityPoints Members

CreatePriorityPoints overview

Public Instance Constructors

CreatePriorityPoints Constructor Initializes a new instance of the CreatePriorityPoints class.

Public Instance Properties

Application
DataAction
Properties

Public Instance Methods

Config |
CreatePriorityPoints | This method will create priority points based on the Order GE provided. The default functionality will loop through each line item in an order and create points for each expo product based on the following logic: 1) Points awarded only if the OrderDate is prior to or on the "PointsDeadline" field of the Expo Or PointsDeadline is not provided 2) Expo.ParticipationPoints is awarded for participating, regardless of booth size 3) Expo.PointsPerUnit is multiplied by the Order Quantity and awarded 4) Expo.MinUnitsForPoints is a requirement if > 0. If > 0 and # points is not at this level, no points awarded
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetExpoInfo | Returns an ExpoInfo class for the given product
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetRootCompanyID | This method determines the root company associated with the specified CompanyID record and returns that value. This method simply selects the RootCompanyID field from the vwCompanies view and returns the value.
GetType (inherited from Object) | Gets the Type of the current instance.
Run | This process component supports the following input properties: 1) OrderGE - Required Generic Entity for Order Result Codes: SUCCESS, FAILED
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
HasCompanyAlreadyOrderedBooth | Following function check if the company has already ordered for the booth before and expo priority points has been calculated for it.
HasCompanyAlreadyOrderedForSameExpo | Following function check if company has already ordered a booth in the expo before or not. returns True if the booth is ordered before.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CreatePriorityPoints Class | Aptify.Applications.Expos Namespace


CreatePriorityPoints Constructor

Initializes a new instance of the CreatePriorityPoints class.

public CreatePriorityPoints();

See Also

CreatePriorityPoints Class | Aptify.Applications.Expos Namespace


CreatePriorityPoints Properties

The properties of the CreatePriorityPoints class are listed below. For a complete list of CreatePriorityPoints class members, see the CreatePriorityPoints Members topic.

Public Instance Properties

Application
DataAction
Properties

See Also

CreatePriorityPoints Class | Aptify.Applications.Expos Namespace


Application Property

Aptify 5.0 Software Development Kit (SDK)

CreatePriorityPoints.Application Property

public virtual AptifyApplication Application {get;}

See Also

CreatePriorityPoints Class | Aptify.Applications.Expos Namespace


DataAction Property

Aptify 5.0 Software Development Kit (SDK)

CreatePriorityPoints.DataAction Property

public virtual DataAction DataAction {get;}

See Also

CreatePriorityPoints Class | Aptify.Applications.Expos Namespace


Properties Property

Aptify 5.0 Software Development Kit (SDK)

CreatePriorityPoints.Properties Property

public AptifyProperties Properties {get;}

Implements

IProcessComponent.

See Also

CreatePriorityPoints Class | Aptify.Applications.Expos Namespace


CreatePriorityPoints Methods

The methods of the CreatePriorityPoints class are listed below. For a complete list of CreatePriorityPoints class members, see the CreatePriorityPoints Members topic.

Public Instance Methods

Config |
CreatePriorityPoints | This method will create priority points based on the Order GE provided. The default functionality will loop through each line item in an order and create points for each expo product based on the following logic: 1) Points awarded only if the OrderDate is prior to or on the "PointsDeadline" field of the Expo Or PointsDeadline is not provided 2) Expo.ParticipationPoints is awarded for participating, regardless of booth size 3) Expo.PointsPerUnit is multiplied by the Order Quantity and awarded 4) Expo.MinUnitsForPoints is a requirement if > 0. If > 0 and # points is not at this level, no points awarded
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetExpoInfo | Returns an ExpoInfo class for the given product
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetRootCompanyID | This method determines the root company associated with the specified CompanyID record and returns that value. This method simply selects the RootCompanyID field from the vwCompanies view and returns the value.
GetType (inherited from Object) | Gets the Type of the current instance.
Run | This process component supports the following input properties: 1) OrderGE - Required Generic Entity for Order Result Codes: SUCCESS, FAILED
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
HasCompanyAlreadyOrderedBooth | Following function check if the company has already ordered for the booth before and expo priority points has been calculated for it.
HasCompanyAlreadyOrderedForSameExpo | Following function check if company has already ordered a booth in the expo before or not. returns True if the booth is ordered before.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CreatePriorityPoints Class | Aptify.Applications.Expos Namespace


CreatePriorityPoints.Config Method

public void Config(
AptifyApplication ApplicationObject
);

Implements

IProcessComponent.

See Also

CreatePriorityPoints Class | Aptify.Applications.Expos Namespace


CreatePriorityPoints.CreatePriorityPoints Method

This method will create priority points based on the Order GE provided. The default functionality will loop through each line item in an order and create points for each expo product based on the following logic: 1) Points awarded only if the OrderDate is prior to or on the "PointsDeadline" field of the Expo Or PointsDeadline is not provided 2) Expo.ParticipationPoints is awarded for participating, regardless of booth size 3) Expo.PointsPerUnit is multiplied by the Order Quantity and awarded 4) Expo.MinUnitsForPoints is a requirement if > 0. If > 0 and # points is not at this level, no points awarded

public virtual bool CreatePriorityPoints(
AptifyGenericEntityBase OrderGE
);

Parameters

OrderGE

Return Value

Remarks

See Also

CreatePriorityPoints Class | Aptify.Applications.Expos Namespace


CreatePriorityPoints.GetExpoInfo Method

Returns an ExpoInfo class for the given product

public virtual ExpoInfo GetExpoInfo(
Int64 ProductID
);

Parameters

ProductID

Return Value

Remarks

See Also

CreatePriorityPoints Class | Aptify.Applications.Expos Namespace


CreatePriorityPoints.GetRootCompanyID Method

This method determines the root company associated with the specified CompanyID record and returns that value. This method simply selects the RootCompanyID field from the vwCompanies view and returns the value.

public virtual long GetRootCompanyID(
Int64 CompanyID
);

Parameters

CompanyID

Return Value

Root Company ID

Remarks

See Also

CreatePriorityPoints Class | Aptify.Applications.Expos Namespace


CreatePriorityPoints.HasCompanyAlreadyOrderedBooth Method

Following function check if the company has already ordered for the booth before and expo priority points has been calculated for it.

protected bool HasCompanyAlreadyOrderedBooth(
Int64 OrderID,
Int64 ProductID
);

Parameters

OrderID
ProductID

Return Value

Remarks

See Also

CreatePriorityPoints Class | Aptify.Applications.Expos Namespace


CreatePriorityPoints.HasCompanyAlreadyOrderedForSameExpo Method

Following function check if company has already ordered a booth in the expo before or not. returns True if the booth is ordered before.

protected bool HasCompanyAlreadyOrderedForSameExpo(
Int64 ProductID,
Int64 ExhibitorID
);

Parameters

ProductID
ExhibitorID

Return Value

Remarks

See Also

CreatePriorityPoints Class | Aptify.Applications.Expos Namespace


CreatePriorityPoints.Run Method

This process component supports the following input properties: 1) OrderGE - Required Generic Entity for Order Result Codes: SUCCESS, FAILED

public string Run();

Return Value

Implements

IProcessComponent.

Remarks

See Also

CreatePriorityPoints Class | Aptify.Applications.Expos Namespace


CreatePriorityPoints.ExpoInfo Class

For a list of all members of this type, see CreatePriorityPoints.ExpoInfo Members.

System.Object
CreatePriorityPoints.ExpoInfo

public class CreatePriorityPoints.ExpoInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Expos

Assembly: CreatePriorityPoints (in CreatePriorityPoints.dll)

See Also

CreatePriorityPoints.ExpoInfo Members | Aptify.Applications.Expos Namespace


CreatePriorityPoints.ExpoInfo Members

CreatePriorityPoints.ExpoInfo overview

Public Instance Constructors

CreatePriorityPoints.ExpoInfo Constructor

Public Instance Properties

DataRow
ExpoID
ExpoName
MinNumUnitsForPoints
ParticipationPoints
PointsDeadline
PointsPerUnit
PriorityPointTypeID
ProductID

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CreatePriorityPoints.ExpoInfo Class | Aptify.Applications.Expos Namespace


CreatePriorityPoints.ExpoInfo Constructor

public CreatePriorityPoints.ExpoInfo(
DataRow ExpoDataRow
);

See Also

CreatePriorityPoints.ExpoInfo Class | Aptify.Applications.Expos Namespace


CreatePriorityPoints.ExpoInfo Properties

The properties of the CreatePriorityPoints.ExpoInfo class are listed below. For a complete list of CreatePriorityPoints.ExpoInfo class members, see the CreatePriorityPoints.ExpoInfo Members topic.

Public Instance Properties

DataRow
ExpoID
ExpoName
MinNumUnitsForPoints
ParticipationPoints
PointsDeadline
PointsPerUnit
PriorityPointTypeID
ProductID

See Also

CreatePriorityPoints.ExpoInfo Class | Aptify.Applications.Expos Namespace


DataRow Property

Aptify 5.0 Software Development Kit (SDK)

CreatePriorityPoints.ExpoInfo.DataRow Property

public DataRow DataRow {get;}

See Also

CreatePriorityPoints.ExpoInfo Class | Aptify.Applications.Expos Namespace


ExpoID Property

Aptify 5.0 Software Development Kit (SDK)

CreatePriorityPoints.ExpoInfo.ExpoID Property

public Int64 ExpoID {get;}

See Also

CreatePriorityPoints.ExpoInfo Class | Aptify.Applications.Expos Namespace


ExpoName Property

Aptify 5.0 Software Development Kit (SDK)

CreatePriorityPoints.ExpoInfo.ExpoName Property

public String ExpoName {get;}

See Also

CreatePriorityPoints.ExpoInfo Class | Aptify.Applications.Expos Namespace


MinNumUnitsForPoints Property

Aptify 5.0 Software Development Kit (SDK)

CreatePriorityPoints.ExpoInfo.MinNumUnitsForPoints Property

public Int32 MinNumUnitsForPoints {get;}

See Also

CreatePriorityPoints.ExpoInfo Class | Aptify.Applications.Expos Namespace


ParticipationPoints Property

Aptify 5.0 Software Development Kit (SDK)

CreatePriorityPoints.ExpoInfo.ParticipationPoints Property

public Decimal ParticipationPoints {get;}

See Also

CreatePriorityPoints.ExpoInfo Class | Aptify.Applications.Expos Namespace


PointsDeadline Property

Aptify 5.0 Software Development Kit (SDK)

CreatePriorityPoints.ExpoInfo.PointsDeadline Property

public DateTime PointsDeadline {get;}

See Also

CreatePriorityPoints.ExpoInfo Class | Aptify.Applications.Expos Namespace


PointsPerUnit Property

Aptify 5.0 Software Development Kit (SDK)

CreatePriorityPoints.ExpoInfo.PointsPerUnit Property

public Decimal PointsPerUnit {get;}

See Also

CreatePriorityPoints.ExpoInfo Class | Aptify.Applications.Expos Namespace


PriorityPointTypeID Property

Aptify 5.0 Software Development Kit (SDK)

CreatePriorityPoints.ExpoInfo.PriorityPointTypeID Property

public Int64 PriorityPointTypeID {get;}

See Also

CreatePriorityPoints.ExpoInfo Class | Aptify.Applications.Expos Namespace


ProductID Property

Aptify 5.0 Software Development Kit (SDK)

CreatePriorityPoints.ExpoInfo.ProductID Property

public Int64 ProductID {get;}

See Also

CreatePriorityPoints.ExpoInfo Class | Aptify.Applications.Expos Namespace


Aptify.Applications.Expos.ExpoCAD

Aptify 5.0 Software Development Kit (SDK)

Aptify.Applications.Expos.ExpoCAD Namespace

The objects in this namespace implement Aptify Expo Management's integration with ExpoCAD.

Namespace hierarchy

Classes

Class | Description
AptifyExpoCAD | This class provides a wrapper around the ExpoCAD API Wrapper class to make it easier to work with from within .NET
AptifyExpoCAD.Booth |
AptifyExpoCAD.Exhibitor |
AptifyExpoCAD.Expo | Functions that are related to the overall event/expo and the ExpoCAD application
AptifyExpoCAD.Expo.ExpoInfo | Basic information retrieval from the EXPOCAD.dbf table
AptifyExpoCAD.Utility |
ExpoCADBooth |
ExpoCADBoothSync | Aptify ExpoCAD Booth Synchronization Object
ExpoCADExpo | Provides implementation of the ExpoCAD integration for the ExpoCAD application


AptifyExpoCAD Class

This class provides a wrapper around the ExpoCAD API Wrapper class to make it easier to work with from within .NET

For a list of all members of this type, see AptifyExpoCAD Members.

System.Object
AptifyExpoCAD

public class AptifyExpoCAD

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Expos.ExpoCAD

Assembly: ExpoCADShared (in ExpoCADShared.dll)

See Also

AptifyExpoCAD Members | Aptify.Applications.Expos.ExpoCAD Namespace


AptifyExpoCAD Members

AptifyExpoCAD overview

Public Static Methods

HideExpoCAD | Hides the ExpoCAD application
LoadExpoCAD | This function will load up ExpoCAD and optionally bring it to the foreground.
ShowExpoCAD | Shows the ExpoCAD application (it must already be loaded, call LoadExpoCAD() to load AND show the application

Public Instance Constructors

AptifyExpoCAD Constructor Initializes a new instance of the AptifyExpoCAD class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyExpoCAD Class | Aptify.Applications.Expos.ExpoCAD Namespace


AptifyExpoCAD Constructor

Initializes a new instance of the AptifyExpoCAD class.

public AptifyExpoCAD();

See Also

AptifyExpoCAD Class | Aptify.Applications.Expos.ExpoCAD Namespace


AptifyExpoCAD Methods

The methods of the AptifyExpoCAD class are listed below. For a complete list of AptifyExpoCAD class members, see the AptifyExpoCAD Members topic.

Public Static Methods

HideExpoCAD | Hides the ExpoCAD application
LoadExpoCAD | This function will load up ExpoCAD and optionally bring it to the foreground.
ShowExpoCAD | Shows the ExpoCAD application (it must already be loaded, call LoadExpoCAD() to load AND show the application

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyExpoCAD Class | Aptify.Applications.Expos.ExpoCAD Namespace


AptifyExpoCAD.HideExpoCAD Method

Hides the ExpoCAD application

public static bool HideExpoCAD();

Return Value

Remarks

See Also

AptifyExpoCAD Class | Aptify.Applications.Expos.ExpoCAD Namespace


AptifyExpoCAD.LoadExpoCAD Method

This function will load up ExpoCAD and optionally bring it to the foreground.

public static bool LoadExpoCAD(
AptifyApplication oApp,
Boolean BringToFront
);

Parameters

oApp
BringToFront
If set to True, will bring ExpoCAD to the foreground with focus

Return Value

Remarks

See Also

AptifyExpoCAD Class | Aptify.Applications.Expos.ExpoCAD Namespace


AptifyExpoCAD.ShowExpoCAD Method

Shows the ExpoCAD application (it must already be loaded, call LoadExpoCAD() to load AND show the application

public static bool ShowExpoCAD();

Return Value

Remarks

See Also

AptifyExpoCAD Class | Aptify.Applications.Expos.ExpoCAD Namespace


AptifyExpoCAD.Booth Class

For a list of all members of this type, see AptifyExpoCAD.Booth Members.

System.Object
AptifyExpoCAD.Booth

public class AptifyExpoCAD.Booth

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Expos.ExpoCAD

Assembly: ExpoCADShared (in ExpoCADShared.dll)

See Also

AptifyExpoCAD.Booth Members | Aptify.Applications.Expos.ExpoCAD Namespace


AptifyExpoCAD.Booth Members

AptifyExpoCAD.Booth overview

Public Static Methods

BoothQuery | Returns information about a booth
GetBoothNumber | Returns the booth number from a booth sequence (1-relative booth sequence)

Public Instance Constructors

AptifyExpoCAD.Booth Constructor Initializes a new instance of the AptifyExpoCAD.Booth class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyExpoCAD.Booth Class | Aptify.Applications.Expos.ExpoCAD Namespace


AptifyExpoCAD.Booth Constructor

Initializes a new instance of the AptifyExpoCAD.Booth class.

public AptifyExpoCAD.Booth();

See Also

AptifyExpoCAD.Booth Class | Aptify.Applications.Expos.ExpoCAD Namespace


AptifyExpoCAD.Booth Methods

The methods of the AptifyExpoCAD.Booth class are listed below. For a complete list of AptifyExpoCAD.Booth class members, see the AptifyExpoCAD.Booth Members topic.

Public Static Methods

BoothQuery | Returns information about a booth
GetBoothNumber | Returns the booth number from a booth sequence (1-relative booth sequence)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyExpoCAD.Booth Class | Aptify.Applications.Expos.ExpoCAD Namespace


AptifyExpoCAD.Booth.BoothQuery Method

Returns information about a booth

public static bool BoothQuery(
String BoothNumber,
ref String& ExhibitorID,
ref String& Status,
ref String& XSize,
ref String& YSize,
ref String& Area
);

Parameters

BoothNumber
ExhibitorID
Status
XSize
YSize
Area

Return Value

Remarks

See Also

AptifyExpoCAD.Booth Class | Aptify.Applications.Expos.ExpoCAD Namespace


AptifyExpoCAD.Booth.GetBoothNumber Method

Returns the booth number from a booth sequence (1-relative booth sequence)

public static string GetBoothNumber(
Int32 BoothSequence
);

Parameters

BoothSequence

Return Value

Remarks

See Also

AptifyExpoCAD.Booth Class | Aptify.Applications.Expos.ExpoCAD Namespace


AptifyExpoCAD.Exhibitor Class

For a list of all members of this type, see AptifyExpoCAD.Exhibitor Members.

System.Object
AptifyExpoCAD.Exhibitor

public class AptifyExpoCAD.Exhibitor

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Expos.ExpoCAD

Assembly: ExpoCADShared (in ExpoCADShared.dll)

See Also

AptifyExpoCAD.Exhibitor Members | Aptify.Applications.Expos.ExpoCAD Namespace


AptifyExpoCAD.Exhibitor Members

AptifyExpoCAD.Exhibitor overview

Public Instance Constructors

AptifyExpoCAD.Exhibitor Constructor Initializes a new instance of the AptifyExpoCAD.Exhibitor class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyExpoCAD.Exhibitor Class | Aptify.Applications.Expos.ExpoCAD Namespace


AptifyExpoCAD.Exhibitor Constructor

Initializes a new instance of the AptifyExpoCAD.Exhibitor class.

public AptifyExpoCAD.Exhibitor();

See Also

AptifyExpoCAD.Exhibitor Class | Aptify.Applications.Expos.ExpoCAD Namespace


AptifyExpoCAD.Expo Class

Functions that are related to the overall event/expo and the ExpoCAD application

For a list of all members of this type, see AptifyExpoCAD.Expo Members.

System.Object
AptifyExpoCAD.Expo

public class AptifyExpoCAD.Expo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Expos.ExpoCAD

Assembly: ExpoCADShared (in ExpoCADShared.dll)

See Also

AptifyExpoCAD.Expo Members | Aptify.Applications.Expos.ExpoCAD Namespace


AptifyExpoCAD.Expo Members

AptifyExpoCAD.Expo overview

Public Static Methods

GetBoothCount | Returns the total number of booths (visible) in the specified ExpoCAD event
GetExpoList | Returns a list of all of the events that are registered in ExpoCAD on the computer
OpenExpo | Opens an ExpoCAD Expo, expocad must be open first

Public Instance Constructors

AptifyExpoCAD.Expo Constructor Initializes a new instance of the AptifyExpoCAD.Expo class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyExpoCAD.Expo Class | Aptify.Applications.Expos.ExpoCAD Namespace


AptifyExpoCAD.Expo Constructor

Initializes a new instance of the AptifyExpoCAD.Expo class.

public AptifyExpoCAD.Expo();

See Also

AptifyExpoCAD.Expo Class | Aptify.Applications.Expos.ExpoCAD Namespace


AptifyExpoCAD.Expo Methods

The methods of the AptifyExpoCAD.Expo class are listed below. For a complete list of AptifyExpoCAD.Expo class members, see the AptifyExpoCAD.Expo Members topic.

Public Static Methods

GetBoothCount | Returns the total number of booths (visible) in the specified ExpoCAD event
GetExpoList | Returns a list of all of the events that are registered in ExpoCAD on the computer
OpenExpo | Opens an ExpoCAD Expo, expocad must be open first

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyExpoCAD.Expo Class | Aptify.Applications.Expos.ExpoCAD Namespace


AptifyExpoCAD.Expo.GetBoothCount Method

Returns the total number of booths (visible) in the specified ExpoCAD event

public static long GetBoothCount(
String EventName,
AptifyApplication oApp
);

Parameters

EventName
oApp

Return Value

Remarks

See Also

AptifyExpoCAD.Expo Class | Aptify.Applications.Expos.ExpoCAD Namespace


AptifyExpoCAD.Expo.GetExpoList Method

Returns a list of all of the events that are registered in ExpoCAD on the computer

public static List<T> GetExpoList(
AptifyApplication oApp
);

Return Value

Remarks

See Also

AptifyExpoCAD.Expo Class | Aptify.Applications.Expos.ExpoCAD Namespace


AptifyExpoCAD.Expo.OpenExpo Method

Opens an ExpoCAD Expo, expocad must be open first

public static bool OpenExpo(
String ExpoName
);

Parameters

ExpoName

Return Value

Remarks

See Also

AptifyExpoCAD.Expo Class | Aptify.Applications.Expos.ExpoCAD Namespace


AptifyExpoCAD.Expo.ExpoInfo Class

Basic information retrieval from the EXPOCAD.dbf table

For a list of all members of this type, see AptifyExpoCAD.Expo.ExpoInfo Members.

System.Object
AptifyExpoCAD.Expo.ExpoInfo

public class AptifyExpoCAD.Expo.ExpoInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Expos.ExpoCAD

Assembly: ExpoCADShared (in ExpoCADShared.dll)

See Also

AptifyExpoCAD.Expo.ExpoInfo Members | Aptify.Applications.Expos.ExpoCAD Namespace


AptifyExpoCAD.Expo.ExpoInfo Members

AptifyExpoCAD.Expo.ExpoInfo overview

Public Instance Constructors

AptifyExpoCAD.Expo.ExpoInfo Constructor Initializes a new instance of the AptifyExpoCAD.Expo.ExpoInfo class.

Public Instance Fields

DatabaseName
Description
Name
ShowDates

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyExpoCAD.Expo.ExpoInfo Class | Aptify.Applications.Expos.ExpoCAD Namespace


AptifyExpoCAD.Expo.ExpoInfo Constructor

Initializes a new instance of the AptifyExpoCAD.Expo.ExpoInfo class.

public AptifyExpoCAD.Expo.ExpoInfo();

See Also

AptifyExpoCAD.Expo.ExpoInfo Class | Aptify.Applications.Expos.ExpoCAD Namespace


AptifyExpoCAD.Expo.ExpoInfo Fields

The fields of the AptifyExpoCAD.Expo.ExpoInfo class are listed below. For a complete list of AptifyExpoCAD.Expo.ExpoInfo class members, see the AptifyExpoCAD.Expo.ExpoInfo Members topic.

Public Instance Fields

DatabaseName
Description
Name
ShowDates

See Also

AptifyExpoCAD.Expo.ExpoInfo Class | Aptify.Applications.Expos.ExpoCAD Namespace


AptifyExpoCAD.Expo.ExpoInfo.DatabaseName Field

public DatabaseName DatabaseName;

See Also

AptifyExpoCAD.Expo.ExpoInfo Class | Aptify.Applications.Expos.ExpoCAD Namespace


AptifyExpoCAD.Expo.ExpoInfo.Description Field

public Description Description;

See Also

AptifyExpoCAD.Expo.ExpoInfo Class | Aptify.Applications.Expos.ExpoCAD Namespace


AptifyExpoCAD.Expo.ExpoInfo.Name Field

public Name Name;

See Also

AptifyExpoCAD.Expo.ExpoInfo Class | Aptify.Applications.Expos.ExpoCAD Namespace


AptifyExpoCAD.Expo.ExpoInfo.ShowDates Field

public ShowDates ShowDates;

See Also

AptifyExpoCAD.Expo.ExpoInfo Class | Aptify.Applications.Expos.ExpoCAD Namespace


AptifyExpoCAD.Utility Class

For a list of all members of this type, see AptifyExpoCAD.Utility Members.

System.Object
AptifyExpoCAD.Utility

public class AptifyExpoCAD.Utility

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Expos.ExpoCAD

Assembly: ExpoCADShared (in ExpoCADShared.dll)

See Also

AptifyExpoCAD.Utility Members | Aptify.Applications.Expos.ExpoCAD Namespace


AptifyExpoCAD.Utility Members

AptifyExpoCAD.Utility overview

Public Static Methods

ConvertExpoCADLength | This method converts ExpoCAD's length strings into decimal values denominated in feet ExpoCAD returns strings that show the # of feet and the # of inches. This in turn converts that to the # of feet in decimal format.
Delay | This method creates a delay equal to the # of seconds passed in
ExecuteScalar | Returns a single value from the specified SQL statement and Path. Uses ADO.NET to open the DBF file format specified Path is the location of the DBF file and the SQL query uses the file name as the table in the FROM clause
GetDatabaseFileNameFromEventName | This function is responsible for retrieving the file name(root) of the expocad DBF file for the specified event name
GetDataTable | Returns a data table from the specified SQL statement and Path. Uses ADO.NET to open the DBF file format specified Path is the location of the DBF file and the SQL query uses the file name as the table in the FROM clause
GetExpoCADBaseDirectory |
GetExpoCADDataDirectory |
GetExpoCADProgramDirectory |

Public Instance Constructors

AptifyExpoCAD.Utility Constructor Initializes a new instance of the AptifyExpoCAD.Utility class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
StripNulls | This function will strip nulls from strings returned from EXPOCAD API if needed
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyExpoCAD.Utility Class | Aptify.Applications.Expos.ExpoCAD Namespace


AptifyExpoCAD.Utility Constructor

Initializes a new instance of the AptifyExpoCAD.Utility class.

public AptifyExpoCAD.Utility();

See Also

AptifyExpoCAD.Utility Class | Aptify.Applications.Expos.ExpoCAD Namespace


AptifyExpoCAD.Utility Methods

The methods of the AptifyExpoCAD.Utility class are listed below. For a complete list of AptifyExpoCAD.Utility class members, see the AptifyExpoCAD.Utility Members topic.

Public Static Methods

ConvertExpoCADLength | This method converts ExpoCAD's length strings into decimal values denominated in feet ExpoCAD returns strings that show the # of feet and the # of inches. This in turn converts that to the # of feet in decimal format.
Delay | This method creates a delay equal to the # of seconds passed in
ExecuteScalar | Returns a single value from the specified SQL statement and Path. Uses ADO.NET to open the DBF file format specified Path is the location of the DBF file and the SQL query uses the file name as the table in the FROM clause
GetDatabaseFileNameFromEventName | This function is responsible for retrieving the file name(root) of the expocad DBF file for the specified event name
GetDataTable | Returns a data table from the specified SQL statement and Path. Uses ADO.NET to open the DBF file format specified Path is the location of the DBF file and the SQL query uses the file name as the table in the FROM clause
GetExpoCADBaseDirectory |
GetExpoCADDataDirectory |
GetExpoCADProgramDirectory |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
StripNulls | This function will strip nulls from strings returned from EXPOCAD API if needed
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyExpoCAD.Utility Class | Aptify.Applications.Expos.ExpoCAD Namespace


AptifyExpoCAD.Utility.ConvertExpoCADLength Method

This method converts ExpoCAD's length strings into decimal values denominated in feet ExpoCAD returns strings that show the # of feet and the # of inches. This in turn converts that to the # of feet in decimal format.

public static decimal ConvertExpoCADLength(
String LengthString
);

Parameters

LengthString

Return Value

Remarks

See Also

AptifyExpoCAD.Utility Class | Aptify.Applications.Expos.ExpoCAD Namespace


AptifyExpoCAD.Utility.Delay Method

This method creates a delay equal to the # of seconds passed in

public static void Delay(
Double PauseSeconds
);

Parameters

PauseSeconds

Remarks

See Also

AptifyExpoCAD.Utility Class | Aptify.Applications.Expos.ExpoCAD Namespace


AptifyExpoCAD.Utility.ExecuteScalar Method

Returns a single value from the specified SQL statement and Path. Uses ADO.NET to open the DBF file format specified Path is the location of the DBF file and the SQL query uses the file name as the table in the FROM clause

public static object ExecuteScalar(
String SQL,
String Path
);

Parameters

SQL
Path

Return Value

Remarks

See Also

AptifyExpoCAD.Utility Class | Aptify.Applications.Expos.ExpoCAD Namespace


AptifyExpoCAD.Utility.GetDatabaseFileNameFromEventName Method

This function is responsible for retrieving the file name(root) of the expocad DBF file for the specified event name

public static string GetDatabaseFileNameFromEventName(
String EventName
);

Parameters

EventName

Return Value

Remarks

See Also

AptifyExpoCAD.Utility Class | Aptify.Applications.Expos.ExpoCAD Namespace


AptifyExpoCAD.Utility.GetDataTable Method

Returns a data table from the specified SQL statement and Path. Uses ADO.NET to open the DBF file format specified Path is the location of the DBF file and the SQL query uses the file name as the table in the FROM clause

public static DataTable GetDataTable(
String SQL,
String Path
);

Parameters

SQL
Path

Return Value

Remarks

See Also

AptifyExpoCAD.Utility Class | Aptify.Applications.Expos.ExpoCAD Namespace


AptifyExpoCAD.Utility.GetExpoCADBaseDirectory Method

public static string GetExpoCADBaseDirectory(
AptifyApplication oApp
);

See Also

AptifyExpoCAD.Utility Class | Aptify.Applications.Expos.ExpoCAD Namespace


AptifyExpoCAD.Utility.GetExpoCADDataDirectory Method

public static string GetExpoCADDataDirectory(
AptifyApplication oApp
);

See Also

AptifyExpoCAD.Utility Class | Aptify.Applications.Expos.ExpoCAD Namespace


AptifyExpoCAD.Utility.GetExpoCADProgramDirectory Method

public static string GetExpoCADProgramDirectory(
AptifyApplication oApp
);

See Also

AptifyExpoCAD.Utility Class | Aptify.Applications.Expos.ExpoCAD Namespace


AptifyExpoCAD.Utility.StripNulls Method

This function will strip nulls from strings returned from EXPOCAD API if needed

public string StripNulls(
String OldString
);

Parameters

OldString

Return Value

Remarks

See Also

AptifyExpoCAD.Utility Class | Aptify.Applications.Expos.ExpoCAD Namespace


ExpoCADBooth Class

For a list of all members of this type, see ExpoCADBooth Members.

System.Object
Booth
ExpoCADBooth

public class ExpoCADBooth : Booth

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Expos.ExpoCAD

Assembly: ExpoCADBoothSynch (in ExpoCADBoothSynch.dll)

See Also

ExpoCADBooth Members | Aptify.Applications.Expos.ExpoCAD Namespace


ExpoCADBooth Members

ExpoCADBooth overview

Public Instance Constructors

ExpoCADBooth Constructor

Public Instance Properties

AptifyBoothID (inherited from Booth) | Sets/Gets the Aptify Booth ID associated with this booth
AptifyExhibitorID (inherited from Booth) |
Area (inherited from Booth) | Returns the calculated area of the booth
BoothName (inherited from Booth) | Sets/Gets the descriptive name associated with this booth.
BoothNumber |
ExhibitorID (inherited from Booth) | Sets/Gets the Floorplan ExhibitorID associated with this booth
Expo (inherited from Booth) | Gets the Expo associated with this booth
Status (inherited from Booth) | Sets/Gets the status of the booth in the terminology of the 3rd party application
XSize (inherited from Booth) | Sets/Gets the X-Dimension of the booth
YSize (inherited from Booth) | Sets/Gets the y-Dimension of the booth

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExpoCADBooth Class | Aptify.Applications.Expos.ExpoCAD Namespace


ExpoCADBooth Constructor

public ExpoCADBooth(
IExpo Expo
);

See Also

ExpoCADBooth Class | Aptify.Applications.Expos.ExpoCAD Namespace


ExpoCADBooth Properties

The properties of the ExpoCADBooth class are listed below. For a complete list of ExpoCADBooth class members, see the ExpoCADBooth Members topic.

Public Instance Properties

AptifyBoothID (inherited from Booth) | Sets/Gets the Aptify Booth ID associated with this booth
AptifyExhibitorID (inherited from Booth) |
Area (inherited from Booth) | Returns the calculated area of the booth
BoothName (inherited from Booth) | Sets/Gets the descriptive name associated with this booth.
BoothNumber |
ExhibitorID (inherited from Booth) | Sets/Gets the Floorplan ExhibitorID associated with this booth
Expo (inherited from Booth) | Gets the Expo associated with this booth
Status (inherited from Booth) | Sets/Gets the status of the booth in the terminology of the 3rd party application
XSize (inherited from Booth) | Sets/Gets the X-Dimension of the booth
YSize (inherited from Booth) | Sets/Gets the y-Dimension of the booth

See Also

ExpoCADBooth Class | Aptify.Applications.Expos.ExpoCAD Namespace


BoothNumber Property

Aptify 5.0 Software Development Kit (SDK)

ExpoCADBooth.BoothNumber Property

public override String BoothNumber {get; set;}

See Also

ExpoCADBooth Class | Aptify.Applications.Expos.ExpoCAD Namespace


ExpoCADBoothSync Class

Aptify ExpoCAD Booth Synchronization Object

For a list of all members of this type, see ExpoCADBoothSync Members.

System.Object
ExpoCADBoothSync

public class ExpoCADBoothSync : IFloorplanIntegration

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Expos.ExpoCAD

Assembly: ExpoCADBoothSynch (in ExpoCADBoothSynch.dll)

See Also

ExpoCADBoothSync Members | Aptify.Applications.Expos.ExpoCAD Namespace


ExpoCADBoothSync Members

ExpoCADBoothSync overview

Public Instance Constructors

ExpoCADBoothSync Constructor Initializes a new instance of the ExpoCADBoothSync class.

Public Instance Properties

Application
DataAction
FloorplanSystemID
Utility

Public Instance Methods

Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetExpo | Overloaded.
GetExpoList |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HideFloorPlanApplication |
LoadFloorplanApplication |
ShowFloorPlan |
ShowFloorPlanApplication |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExpoCADBoothSync Class | Aptify.Applications.Expos.ExpoCAD Namespace


ExpoCADBoothSync Constructor

Initializes a new instance of the ExpoCADBoothSync class.

public ExpoCADBoothSync();

See Also

ExpoCADBoothSync Class | Aptify.Applications.Expos.ExpoCAD Namespace


ExpoCADBoothSync Properties

The properties of the ExpoCADBoothSync class are listed below. For a complete list of ExpoCADBoothSync class members, see the ExpoCADBoothSync Members topic.

Public Instance Properties

Application
DataAction
FloorplanSystemID
Utility

See Also

ExpoCADBoothSync Class | Aptify.Applications.Expos.ExpoCAD Namespace


Application Property

Aptify 5.0 Software Development Kit (SDK)

ExpoCADBoothSync.Application Property

public virtual AptifyApplication Application {get;}

See Also

ExpoCADBoothSync Class | Aptify.Applications.Expos.ExpoCAD Namespace


DataAction Property

Aptify 5.0 Software Development Kit (SDK)

ExpoCADBoothSync.DataAction Property

public virtual DataAction DataAction {get;}

See Also

ExpoCADBoothSync Class | Aptify.Applications.Expos.ExpoCAD Namespace


FloorplanSystemID Property

Aptify 5.0 Software Development Kit (SDK)

ExpoCADBoothSync.FloorplanSystemID Property

public virtual Int64 FloorplanSystemID {get;}

Implements

IFloorplanIntegration.

See Also

ExpoCADBoothSync Class | Aptify.Applications.Expos.ExpoCAD Namespace


Utility Property

Aptify 5.0 Software Development Kit (SDK)

ExpoCADBoothSync.Utility Property

public virtual FloorplanUtility Utility {get;}

See Also

ExpoCADBoothSync Class | Aptify.Applications.Expos.ExpoCAD Namespace


ExpoCADBoothSync Methods

The methods of the ExpoCADBoothSync class are listed below. For a complete list of ExpoCADBoothSync class members, see the ExpoCADBoothSync Members topic.

Public Instance Methods

Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetExpo | Overloaded.
GetExpoList |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HideFloorPlanApplication |
LoadFloorplanApplication |
ShowFloorPlan |
ShowFloorPlanApplication |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExpoCADBoothSync Class | Aptify.Applications.Expos.ExpoCAD Namespace


ExpoCADBoothSync.Config Method

public void Config(
AptifyApplication AptifyApplication,
Int64 FloorplanSystemID
);

Implements

IFloorplanIntegration.

See Also

ExpoCADBoothSync Class | Aptify.Applications.Expos.ExpoCAD Namespace


GetExpo Method

Aptify 5.0 Software Development Kit (SDK)

ExpoCADBoothSync.GetExpo Method

Overload List

public IExpo GetExpo(Int64);

public IExpo GetExpo(String);

See Also

ExpoCADBoothSync Class | Aptify.Applications.Expos.ExpoCAD Namespace


ExpoCADBoothSync.GetExpo Method (Int64)

public IExpo GetExpo(
Int64 AptifyFloorplanID
);

Implements

IFloorplanIntegration.

See Also

ExpoCADBoothSync Class | Aptify.Applications.Expos.ExpoCAD Namespace | ExpoCADBoothSync.GetExpo Overload List


ExpoCADBoothSync.GetExpo Method (String)

public IExpo GetExpo(
String ExpoName
);

Implements

IFloorplanIntegration.

See Also

ExpoCADBoothSync Class | Aptify.Applications.Expos.ExpoCAD Namespace | ExpoCADBoothSync.GetExpo Overload List


ExpoCADBoothSync.GetExpoList Method

public List<T> GetExpoList();

Implements

IFloorplanIntegration.

See Also

ExpoCADBoothSync Class | Aptify.Applications.Expos.ExpoCAD Namespace


ExpoCADBoothSync.HideFloorPlanApplication Method

public bool HideFloorPlanApplication();

Implements

IFloorplanIntegration.

See Also

ExpoCADBoothSync Class | Aptify.Applications.Expos.ExpoCAD Namespace


ExpoCADBoothSync.LoadFloorplanApplication Method

public bool LoadFloorplanApplication();

Implements

IFloorplanIntegration.

See Also

ExpoCADBoothSync Class | Aptify.Applications.Expos.ExpoCAD Namespace


ExpoCADBoothSync.ShowFloorPlan Method

public bool ShowFloorPlan(
Int64 AptifyFloorPlanId
);

Implements

IFloorplanIntegration.

See Also

ExpoCADBoothSync Class | Aptify.Applications.Expos.ExpoCAD Namespace


ExpoCADBoothSync.ShowFloorPlanApplication Method

public bool ShowFloorPlanApplication();

Implements

IFloorplanIntegration.

See Also

ExpoCADBoothSync Class | Aptify.Applications.Expos.ExpoCAD Namespace


ExpoCADExpo Class

Provides implementation of the ExpoCAD integration for the ExpoCAD application

For a list of all members of this type, see ExpoCADExpo Members.

System.Object
ExpoBase
ExpoCADExpo

public class ExpoCADExpo : ExpoBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Expos.ExpoCAD

Assembly: ExpoCADBoothSynch (in ExpoCADBoothSynch.dll)

See Also

ExpoCADExpo Members | Aptify.Applications.Expos.ExpoCAD Namespace


ExpoCADExpo Members

ExpoCADExpo overview

Public Instance Constructors

ExpoCADExpo Constructor Initializes a new instance of the ExpoCADExpo class.

Public Instance Properties

AptifyFloorplanID (inherited from ExpoBase)
Booths
DatabaseName (inherited from ExpoBase)
Description (inherited from ExpoBase)
EndDate (inherited from ExpoBase)
FloorplanExpoID (inherited from ExpoBase)
Name (inherited from ExpoBase)
Showdates (inherited from ExpoBase)
StartDate (inherited from ExpoBase)

Public Instance Methods

AssignBooth |
Config (inherited from ExpoBase) |
Display |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBoothCount |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetSingleBooth | Overloaded.
GetSingleBooth (inherited from ExpoBase) | Overloaded.
GetType (inherited from Object) | Gets the Type of the current instance.
MergedBooths |
ToString (inherited from Object) | Returns a String that represents the current Object.
UnRentBooth |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExpoCADExpo Class | Aptify.Applications.Expos.ExpoCAD Namespace


ExpoCADExpo Constructor

Initializes a new instance of the ExpoCADExpo class.

public ExpoCADExpo();

See Also

ExpoCADExpo Class | Aptify.Applications.Expos.ExpoCAD Namespace


ExpoCADExpo Properties

The properties of the ExpoCADExpo class are listed below. For a complete list of ExpoCADExpo class members, see the ExpoCADExpo Members topic.

Public Instance Properties

AptifyFloorplanID (inherited from ExpoBase)
Booths
DatabaseName (inherited from ExpoBase)
Description (inherited from ExpoBase)
EndDate (inherited from ExpoBase)
FloorplanExpoID (inherited from ExpoBase)
Name (inherited from ExpoBase)
Showdates (inherited from ExpoBase)
StartDate (inherited from ExpoBase)

See Also

ExpoCADExpo Class | Aptify.Applications.Expos.ExpoCAD Namespace


Booths Property

Aptify 5.0 Software Development Kit (SDK)

ExpoCADExpo.Booths Property

public override List<T> this[
Boolean Refresh
] {get;}

Implements

IExpo.

See Also

ExpoCADExpo Class | Aptify.Applications.Expos.ExpoCAD Namespace


ExpoCADExpo Methods

The methods of the ExpoCADExpo class are listed below. For a complete list of ExpoCADExpo class members, see the ExpoCADExpo Members topic.

Public Instance Methods

AssignBooth |
Config (inherited from ExpoBase) |
Display |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBoothCount |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetSingleBooth | Overloaded.
GetSingleBooth (inherited from ExpoBase) | Overloaded.
GetType (inherited from Object) | Gets the Type of the current instance.
MergedBooths |
ToString (inherited from Object) | Returns a String that represents the current Object.
UnRentBooth |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExpoCADExpo Class | Aptify.Applications.Expos.ExpoCAD Namespace


ExpoCADExpo.AssignBooth Method

public override bool AssignBooth(
String BoothNumber,
Int64 ExhibitorID,
String ExhibitorName
);

Implements

IExpo.

See Also

ExpoCADExpo Class | Aptify.Applications.Expos.ExpoCAD Namespace


ExpoCADExpo.Display Method

public override bool Display();

Implements

IExpo.

See Also

ExpoCADExpo Class | Aptify.Applications.Expos.ExpoCAD Namespace


ExpoCADExpo.GetBoothCount Method

public override long GetBoothCount();

Implements

IExpo.

See Also

ExpoCADExpo Class | Aptify.Applications.Expos.ExpoCAD Namespace


GetSingleBooth Method

Aptify 5.0 Software Development Kit (SDK)

ExpoCADExpo.GetSingleBooth Method

Overload List

Inherited from ExpoBase.

public virtual Booth GetSingleBooth(Int64);

public override Booth GetSingleBooth(String);

See Also

ExpoCADExpo Class | Aptify.Applications.Expos.ExpoCAD Namespace


ExpoCADExpo.GetSingleBooth Method (String)

public override Booth GetSingleBooth(
String BoothNumber
);

Implements

IExpo.

See Also

ExpoCADExpo Class | Aptify.Applications.Expos.ExpoCAD Namespace | ExpoCADExpo.GetSingleBooth Overload List


ExpoCADExpo.MergedBooths Method

public override List<T> MergedBooths(
String ExternalFloorplanID
);

Implements

IExpo.

See Also

ExpoCADExpo Class | Aptify.Applications.Expos.ExpoCAD Namespace


ExpoCADExpo.UnRentBooth Method

public override bool UnRentBooth(
String BoothNumber
);

Implements

IExpo.

See Also

ExpoCADExpo Class | Aptify.Applications.Expos.ExpoCAD Namespace


Aptify.Applications.Expos.FloorplanIntegration

Aptify 5.0 Software Development Kit (SDK)

Aptify.Applications.Expos.FloorplanIntegration Namespace

The objects in this namespace corresponds to Aptify's generic implementation for linking third-party floorplan systems, such as ExpoCAD, to Aptify Expo Management.

Namespace hierarchy

Classes

Class | Description
Booth | Booth information class
ExpoBase | Provides base class functionality for each floorplan integration specific class.
ExpoBoothSync | Aptify Generic Booth Synchronization Object
FloorplanUtility | Provides utility methods for accessing floorplan integration classes and other common requirements.
MergedBooths | Merger Booth information class
SyncWizard | Aptify Synchronization Wizard - Synchronizes data from Aptify Expo Floorplans/Booths to a 3rd party floorplanning tool in both directions, using the ExpoBoothSync object.

Interfaces

Interface | Description
IExpo | Functions that are related to the overall event/expo and the floorplan application
IFloorplanIntegration | This interface defines a method for integration with any 3rd party provider of visual floorplan services for Expos. To provide support for a new 3rd party system, create a class that implements this interface. To integrate a 3rd party application into the Aptify Expo Floorplan Integration architecture, it is required to provide a class that implements this interface as well as a class that implements the IExpo interface.

Delegates

Delegate | Description
ExpoBoothSync.StatusUpdateEventHandler |


Booth Class

Booth information class

For a list of all members of this type, see Booth Members.

System.Object
Booth
ExpoCADBooth

public class Booth

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Expos.FloorplanIntegration

Assembly: FloorplanIntegrationBase (in FloorplanIntegrationBase.dll)

See Also

Booth Members | Aptify.Applications.Expos.FloorplanIntegration Namespace


Booth Members

Booth overview

Public Instance Constructors

Booth Constructor

Public Instance Properties

AptifyBoothID | Sets/Gets the Aptify Booth ID associated with this booth
AptifyExhibitorID |
Area | Returns the calculated area of the booth
BoothName | Sets/Gets the descriptive name associated with this booth.
BoothNumber | Sets/Gets the Booth Number that is used within the Floorplan application
ExhibitorID | Sets/Gets the Floorplan ExhibitorID associated with this booth
Expo | Gets the Expo associated with this booth
Status | Sets/Gets the status of the booth in the terminology of the 3rd party application
XSize | Sets/Gets the X-Dimension of the booth
YSize | Sets/Gets the y-Dimension of the booth

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Booth Class | Aptify.Applications.Expos.FloorplanIntegration Namespace


Booth Constructor

public Booth(
IExpo Expo
);

See Also

Booth Class | Aptify.Applications.Expos.FloorplanIntegration Namespace


Booth Properties

The properties of the Booth class are listed below. For a complete list of Booth class members, see the Booth Members topic.

Public Instance Properties

AptifyBoothID | Sets/Gets the Aptify Booth ID associated with this booth
AptifyExhibitorID |
Area | Returns the calculated area of the booth
BoothName | Sets/Gets the descriptive name associated with this booth.
BoothNumber | Sets/Gets the Booth Number that is used within the Floorplan application
ExhibitorID | Sets/Gets the Floorplan ExhibitorID associated with this booth
Expo | Gets the Expo associated with this booth
Status | Sets/Gets the status of the booth in the terminology of the 3rd party application
XSize | Sets/Gets the X-Dimension of the booth
YSize | Sets/Gets the y-Dimension of the booth

See Also

Booth Class | Aptify.Applications.Expos.FloorplanIntegration Namespace


AptifyBoothID Property

Aptify 5.0 Software Development Kit (SDK)

Booth.AptifyBoothID Property

Sets/Gets the Aptify Booth ID associated with this booth

public virtual Int64 AptifyBoothID {get; set;}

Property Value

Remarks

See Also

Booth Class | Aptify.Applications.Expos.FloorplanIntegration Namespace


AptifyExhibitorID Property

Aptify 5.0 Software Development Kit (SDK)

Booth.AptifyExhibitorID Property

public virtual Int64 AptifyExhibitorID {get; set;}

See Also

Booth Class | Aptify.Applications.Expos.FloorplanIntegration Namespace


Area Property

Aptify 5.0 Software Development Kit (SDK)

Booth.Area Property

Returns the calculated area of the booth

public virtual Decimal Area {get;}

Property Value

Remarks

See Also

Booth Class | Aptify.Applications.Expos.FloorplanIntegration Namespace


BoothName Property

Aptify 5.0 Software Development Kit (SDK)

Booth.BoothName Property

Sets/Gets the descriptive name associated with this booth.

public virtual String BoothName {get; set;}

Property Value

Remarks

See Also

Booth Class | Aptify.Applications.Expos.FloorplanIntegration Namespace


BoothNumber Property

Aptify 5.0 Software Development Kit (SDK)

Booth.BoothNumber Property

Sets/Gets the Booth Number that is used within the Floorplan application

public virtual String BoothNumber {get; set;}

Property Value

Remarks

See Also

Booth Class | Aptify.Applications.Expos.FloorplanIntegration Namespace


ExhibitorID Property

Aptify 5.0 Software Development Kit (SDK)

Booth.ExhibitorID Property

Sets/Gets the Floorplan ExhibitorID associated with this booth

public virtual String ExhibitorID {get; set;}

Property Value

Remarks

See Also

Booth Class | Aptify.Applications.Expos.FloorplanIntegration Namespace


Expo Property

Aptify 5.0 Software Development Kit (SDK)

Booth.Expo Property

Gets the Expo associated with this booth

public virtual IExpo Expo {get;}

Property Value

Remarks

See Also

Booth Class | Aptify.Applications.Expos.FloorplanIntegration Namespace


Status Property

Aptify 5.0 Software Development Kit (SDK)

Booth.Status Property

Sets/Gets the status of the booth in the terminology of the 3rd party application

public virtual String Status {get; set;}

Property Value

Remarks

See Also

Booth Class | Aptify.Applications.Expos.FloorplanIntegration Namespace


XSize Property

Aptify 5.0 Software Development Kit (SDK)

Booth.XSize Property

Sets/Gets the X-Dimension of the booth

public virtual Decimal XSize {get; set;}

Property Value

Remarks

See Also

Booth Class | Aptify.Applications.Expos.FloorplanIntegration Namespace


YSize Property

Aptify 5.0 Software Development Kit (SDK)

Booth.YSize Property

Sets/Gets the y-Dimension of the booth

public virtual Decimal YSize {get; set;}

Property Value

Remarks

See Also

Booth Class | Aptify.Applications.Expos.FloorplanIntegration Namespace


ExpoBase Class

Provides base class functionality for each floorplan integration specific class.

For a list of all members of this type, see ExpoBase Members.

System.Object
ExpoBase
ExpoCADExpo

public class ExpoBase : IExpo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Expos.FloorplanIntegration

Assembly: FloorplanIntegrationBase (in FloorplanIntegrationBase.dll)

See Also

ExpoBase Members | Aptify.Applications.Expos.FloorplanIntegration Namespace


ExpoBase Members

ExpoBase overview

Public Instance Constructors

ExpoBase Constructor Initializes a new instance of the ExpoBase class.

Public Instance Properties

AptifyFloorplanID
Booths
DatabaseName
Description
EndDate
FloorplanExpoID
Name
Showdates
StartDate

Public Instance Methods

AssignBooth |
Config |
Display |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBoothCount |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetSingleBooth | Overloaded.
GetType (inherited from Object) | Gets the Type of the current instance.
MergedBooths |
ToString (inherited from Object) | Returns a String that represents the current Object.
UnRentBooth |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExpoBase Class | Aptify.Applications.Expos.FloorplanIntegration Namespace


ExpoBase Constructor

Initializes a new instance of the ExpoBase class.

public ExpoBase();

See Also

ExpoBase Class | Aptify.Applications.Expos.FloorplanIntegration Namespace


ExpoBase Properties

The properties of the ExpoBase class are listed below. For a complete list of ExpoBase class members, see the ExpoBase Members topic.

Public Instance Properties

AptifyFloorplanID
Booths
DatabaseName
Description
EndDate
FloorplanExpoID
Name
Showdates
StartDate

See Also

ExpoBase Class | Aptify.Applications.Expos.FloorplanIntegration Namespace


AptifyFloorplanID Property

Aptify 5.0 Software Development Kit (SDK)

ExpoBase.AptifyFloorplanID Property

public virtual Int64 AptifyFloorplanID {get; set;}

Implements

IExpo.

See Also

ExpoBase Class | Aptify.Applications.Expos.FloorplanIntegration Namespace


Booths Property

Aptify 5.0 Software Development Kit (SDK)

ExpoBase.Booths Property

public abstract List<T> this[
Boolean Refresh
] {get;}

Implements

IExpo.

See Also

ExpoBase Class | Aptify.Applications.Expos.FloorplanIntegration Namespace


DatabaseName Property

Aptify 5.0 Software Development Kit (SDK)

ExpoBase.DatabaseName Property

public virtual String DatabaseName {get; set;}

Implements

IExpo.

See Also

ExpoBase Class | Aptify.Applications.Expos.FloorplanIntegration Namespace


Description Property

Aptify 5.0 Software Development Kit (SDK)

ExpoBase.Description Property

public virtual String Description {get; set;}

Implements

IExpo.

See Also

ExpoBase Class | Aptify.Applications.Expos.FloorplanIntegration Namespace


EndDate Property

Aptify 5.0 Software Development Kit (SDK)

ExpoBase.EndDate Property

public virtual DateTime EndDate {get; set;}

Implements

IExpo.

See Also

ExpoBase Class | Aptify.Applications.Expos.FloorplanIntegration Namespace


FloorplanExpoID Property

Aptify 5.0 Software Development Kit (SDK)

ExpoBase.FloorplanExpoID Property

public virtual String FloorplanExpoID {get; set;}

Implements

IExpo.

See Also

ExpoBase Class | Aptify.Applications.Expos.FloorplanIntegration Namespace


Name Property

Aptify 5.0 Software Development Kit (SDK)

ExpoBase.Name Property

public virtual String Name {get; set;}

Implements

IExpo.

See Also

ExpoBase Class | Aptify.Applications.Expos.FloorplanIntegration Namespace


Showdates Property

Aptify 5.0 Software Development Kit (SDK)

ExpoBase.Showdates Property

public virtual String Showdates {get; set;}

Implements

IExpo.

See Also

ExpoBase Class | Aptify.Applications.Expos.FloorplanIntegration Namespace


StartDate Property

Aptify 5.0 Software Development Kit (SDK)

ExpoBase.StartDate Property

public virtual DateTime StartDate {get; set;}

Implements

IExpo.

See Also

ExpoBase Class | Aptify.Applications.Expos.FloorplanIntegration Namespace


ExpoBase Methods

The methods of the ExpoBase class are listed below. For a complete list of ExpoBase class members, see the ExpoBase Members topic.

Public Instance Methods

AssignBooth |
Config |
Display |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBoothCount |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetSingleBooth | Overloaded.
GetType (inherited from Object) | Gets the Type of the current instance.
MergedBooths |
ToString (inherited from Object) | Returns a String that represents the current Object.
UnRentBooth |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExpoBase Class | Aptify.Applications.Expos.FloorplanIntegration Namespace


ExpoBase.AssignBooth Method

public abstract bool AssignBooth(
String BoothNumber,
Int64 ExhibitorID,
String ExhibitorName
);

Implements

IExpo.

See Also

ExpoBase Class | Aptify.Applications.Expos.FloorplanIntegration Namespace


ExpoBase.Config Method

public virtual void Config(
AptifyApplication Application
);

See Also

ExpoBase Class | Aptify.Applications.Expos.FloorplanIntegration Namespace


ExpoBase.Display Method

public abstract bool Display();

Implements

IExpo.

See Also

ExpoBase Class | Aptify.Applications.Expos.FloorplanIntegration Namespace


ExpoBase.GetBoothCount Method

public virtual long GetBoothCount();

Implements

IExpo.

See Also

ExpoBase Class | Aptify.Applications.Expos.FloorplanIntegration Namespace


GetSingleBooth Method

Aptify 5.0 Software Development Kit (SDK)

ExpoBase.GetSingleBooth Method

Overload List

public virtual Booth GetSingleBooth(Int64);

public virtual Booth GetSingleBooth(String);

See Also

ExpoBase Class | Aptify.Applications.Expos.FloorplanIntegration Namespace


ExpoBase.GetSingleBooth Method (Int64)

public virtual Booth GetSingleBooth(
Int64 AptifyBoothID
);

Implements

IExpo.

See Also

ExpoBase Class | Aptify.Applications.Expos.FloorplanIntegration Namespace | ExpoBase.GetSingleBooth Overload List


ExpoBase.GetSingleBooth Method (String)

public virtual Booth GetSingleBooth(
String BoothNumber
);

Implements

IExpo.

See Also

ExpoBase Class | Aptify.Applications.Expos.FloorplanIntegration Namespace | ExpoBase.GetSingleBooth Overload List


ExpoBase.MergedBooths Method

public abstract List<T> MergedBooths(
String ExternalFloorPlanId
);

Implements

IExpo.

See Also

ExpoBase Class | Aptify.Applications.Expos.FloorplanIntegration Namespace


ExpoBase.UnRentBooth Method

public abstract bool UnRentBooth(
String BoothNumber
);

Implements

IExpo.

See Also

ExpoBase Class | Aptify.Applications.Expos.FloorplanIntegration Namespace


ExpoBoothSync Class

Aptify Generic Booth Synchronization Object

For a list of all members of this type, see ExpoBoothSync Members.

System.Object
ExpoBoothSync

public class ExpoBoothSync : IProcessComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Expos.FloorplanIntegration

Assembly: FloorplanBoothSynch (in FloorplanBoothSynch.dll)

See Also

ExpoBoothSync Members | Aptify.Applications.Expos.FloorplanIntegration Namespace


ExpoBoothSync Members

ExpoBoothSync overview

Public Instance Constructors

ExpoBoothSync Constructor Initializes a new instance of the ExpoBoothSync class.

Public Instance Properties

Application
DataAction
Properties
Utility

Public Instance Methods

CalculateSellingUnits | Returns the # of selling units a booth represents based on the area of the booth and the # of units per sq ft/sq meter based on the floorplan setup.
CheckFloorPlanInstallation |
Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAreaToUnitsRatio | Calculates the ratio of area units(sq ft/sq m) relative to selling units. Calculated as (Floorplan.DefaultWidth*Floorplan.DefaultHeight)/Floorplan.DefaultUnits
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetMergedboothInfo |
GetType (inherited from Object) | Gets the Type of the current instance.
NotifyFloorPlanOfBoothAssignment | This method is responsible for notifying the 3rd party floorplanning tool that a specified booth has been assigned.
NotifyFloorPlanOfBoothUnRent |
Run | Implements IProcessComponent, and supports the following properties 1) Mode - Floorplan or Booth, Floorplan synchronizes an entire floorplan, whereas booth synchronizes only an individual booth 2) FloorplanID - Required For Both Modes 3) BoothID - Optional, The External Floorplan Booth Number, only Required for Mode=Booth 4) PushOnly - Optional, 0 or 1, if set to 1, data is pushed to the External Floorplan, but not pulled back, defaults to 0 Output Properties 1) BoothCount - only applies when Mode=Floorplan Result Codes 1) SUCCESS 2) FAILED
SynchronizeBooths | Synchronizes booths from the Aptify Floorplan and the 3rd party expo floorplan specified by importing booths into Aptify.
SynchronizeSingleBooth | This method will syncrhonize a single booth between Aptify and the 3rd party application
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

StatusUpdate This event is raised each time a booth is processed during a floor plan syncrhonization process. Cancel parameter can be set to True by the code listening to the event to cancel the process.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseStatusUpdate | Sub classes
UpdateFloorplanSyncDate | This method is responsible for updating the LastSynchronizationDate in the Floorplan record in Aptify.

See Also

ExpoBoothSync Class | Aptify.Applications.Expos.FloorplanIntegration Namespace


ExpoBoothSync Constructor

Initializes a new instance of the ExpoBoothSync class.

public ExpoBoothSync();

See Also

ExpoBoothSync Class | Aptify.Applications.Expos.FloorplanIntegration Namespace


ExpoBoothSync Properties

The properties of the ExpoBoothSync class are listed below. For a complete list of ExpoBoothSync class members, see the ExpoBoothSync Members topic.

Public Instance Properties

Application
DataAction
Properties
Utility

See Also

ExpoBoothSync Class | Aptify.Applications.Expos.FloorplanIntegration Namespace


Application Property

Aptify 5.0 Software Development Kit (SDK)

ExpoBoothSync.Application Property

public virtual AptifyApplication Application {get;}

See Also

ExpoBoothSync Class | Aptify.Applications.Expos.FloorplanIntegration Namespace


DataAction Property

Aptify 5.0 Software Development Kit (SDK)

ExpoBoothSync.DataAction Property

public virtual DataAction DataAction {get;}

See Also

ExpoBoothSync Class | Aptify.Applications.Expos.FloorplanIntegration Namespace


Properties Property

Aptify 5.0 Software Development Kit (SDK)

ExpoBoothSync.Properties Property

public AptifyProperties Properties {get;}

Implements

IProcessComponent.

See Also

ExpoBoothSync Class | Aptify.Applications.Expos.FloorplanIntegration Namespace


Utility Property

Aptify 5.0 Software Development Kit (SDK)

ExpoBoothSync.Utility Property

public virtual FloorplanUtility Utility {get;}

See Also

ExpoBoothSync Class | Aptify.Applications.Expos.FloorplanIntegration Namespace


ExpoBoothSync Methods

The methods of the ExpoBoothSync class are listed below. For a complete list of ExpoBoothSync class members, see the ExpoBoothSync Members topic.

Public Instance Methods

CalculateSellingUnits | Returns the # of selling units a booth represents based on the area of the booth and the # of units per sq ft/sq meter based on the floorplan setup.
CheckFloorPlanInstallation |
Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAreaToUnitsRatio | Calculates the ratio of area units(sq ft/sq m) relative to selling units. Calculated as (Floorplan.DefaultWidth*Floorplan.DefaultHeight)/Floorplan.DefaultUnits
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetMergedboothInfo |
GetType (inherited from Object) | Gets the Type of the current instance.
NotifyFloorPlanOfBoothAssignment | This method is responsible for notifying the 3rd party floorplanning tool that a specified booth has been assigned.
NotifyFloorPlanOfBoothUnRent |
Run | Implements IProcessComponent, and supports the following properties 1) Mode - Floorplan or Booth, Floorplan synchronizes an entire floorplan, whereas booth synchronizes only an individual booth 2) FloorplanID - Required For Both Modes 3) BoothID - Optional, The External Floorplan Booth Number, only Required for Mode=Booth 4) PushOnly - Optional, 0 or 1, if set to 1, data is pushed to the External Floorplan, but not pulled back, defaults to 0 Output Properties 1) BoothCount - only applies when Mode=Floorplan Result Codes 1) SUCCESS 2) FAILED
SynchronizeBooths | Synchronizes booths from the Aptify Floorplan and the 3rd party expo floorplan specified by importing booths into Aptify.
SynchronizeSingleBooth | This method will syncrhonize a single booth between Aptify and the 3rd party application
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseStatusUpdate | Sub classes
UpdateFloorplanSyncDate | This method is responsible for updating the LastSynchronizationDate in the Floorplan record in Aptify.

See Also

ExpoBoothSync Class | Aptify.Applications.Expos.FloorplanIntegration Namespace


ExpoBoothSync.CalculateSellingUnits Method

Returns the # of selling units a booth represents based on the area of the booth and the # of units per sq ft/sq meter based on the floorplan setup.

public decimal CalculateSellingUnits(
String AreaUnits,
Decimal AreaToUnitsRatio,
AptifyGenericEntityBase BoothGE
);

Parameters

AreaUnits
AreaToUnitsRatio
BoothGE

Return Value

Remarks

See Also

ExpoBoothSync Class | Aptify.Applications.Expos.FloorplanIntegration Namespace


ExpoBoothSync.CheckFloorPlanInstallation Method

public bool CheckFloorPlanInstallation(
Int64 FloorPlanId
);

See Also

ExpoBoothSync Class | Aptify.Applications.Expos.FloorplanIntegration Namespace


ExpoBoothSync.Config Method

public void Config(
AptifyApplication ApplicationObject
);

Implements

IProcessComponent.

See Also

ExpoBoothSync Class | Aptify.Applications.Expos.FloorplanIntegration Namespace


ExpoBoothSync.GetAreaToUnitsRatio Method

Calculates the ratio of area units(sq ft/sq m) relative to selling units. Calculated as (Floorplan.DefaultWidth*Floorplan.DefaultHeight)/Floorplan.DefaultUnits

public decimal GetAreaToUnitsRatio(
Int64 FloorPlanID
);

Parameters

FloorPlanID

Return Value

Remarks

See Also

ExpoBoothSync Class | Aptify.Applications.Expos.FloorplanIntegration Namespace


ExpoBoothSync.GetMergedboothInfo Method

public virtual bool GetMergedboothInfo(
Int64 AptifyFloorPlanID,
String BoothName
);

See Also

ExpoBoothSync Class | Aptify.Applications.Expos.FloorplanIntegration Namespace


ExpoBoothSync.NotifyFloorPlanOfBoothAssignment Method

This method is responsible for notifying the 3rd party floorplanning tool that a specified booth has been assigned.

public bool NotifyFloorPlanOfBoothAssignment(
IExpo Expo,
DataRow BoothDataRow
);

Parameters

Expo
BoothDataRow
Represents a System.Data.DataRow that contains values for a single row from vwBooths

Return Value

Remarks

See Also

ExpoBoothSync Class | Aptify.Applications.Expos.FloorplanIntegration Namespace


ExpoBoothSync.NotifyFloorPlanOfBoothUnRent Method

public bool NotifyFloorPlanOfBoothUnRent(
IExpo Expo,
DataRow BoothDataRow
);

See Also

ExpoBoothSync Class | Aptify.Applications.Expos.FloorplanIntegration Namespace


ExpoBoothSync.RaiseStatusUpdate Method

Sub classes

protected virtual void RaiseStatusUpdate(
Int64 CurrentBooth,
Int64 TotalBooths,
ref Boolean& Cancel
);

Parameters

CurrentBooth
TotalBooths
Cancel

Remarks

See Also

ExpoBoothSync Class | Aptify.Applications.Expos.FloorplanIntegration Namespace


ExpoBoothSync.Run Method

Implements IProcessComponent, and supports the following properties 1) Mode - Floorplan or Booth, Floorplan synchronizes an entire floorplan, whereas booth synchronizes only an individual booth 2) FloorplanID - Required For Both Modes 3) BoothID - Optional, The External Floorplan Booth Number, only Required for Mode=Booth 4) PushOnly - Optional, 0 or 1, if set to 1, data is pushed to the External Floorplan, but not pulled back, defaults to 0 Output Properties 1) BoothCount - only applies when Mode=Floorplan Result Codes 1) SUCCESS 2) FAILED

public string Run();

Return Value

Implements

IProcessComponent.

Remarks

See Also

ExpoBoothSync Class | Aptify.Applications.Expos.FloorplanIntegration Namespace


ExpoBoothSync.SynchronizeBooths Method

Synchronizes booths from the Aptify Floorplan and the 3rd party expo floorplan specified by importing booths into Aptify.

public virtual bool SynchronizeBooths(
Int64 AptifyFloorPlanID,
Int32 BoothCount,
Boolean PushOnly
);

Parameters

AptifyFloorPlanID
Aptify Floorplans Entity ID value
BoothCount
PushOnly
If set to True, the 3rd party floorplan product receives information about the Booth updates, but Aptify does not pull back data.

Return Value

Remarks

See Also

ExpoBoothSync Class | Aptify.Applications.Expos.FloorplanIntegration Namespace


ExpoBoothSync.SynchronizeSingleBooth Method

This method will syncrhonize a single booth between Aptify and the 3rd party application

public virtual bool SynchronizeSingleBooth(
Booth Booth,
Boolean PushOnly
);

Parameters

Booth
Booth
PushOnly
If set to True, the 3rd party application receives information about the booth sales/cancellations, but Aptify does not pull back data.

Return Value

Remarks

See Also

ExpoBoothSync Class | Aptify.Applications.Expos.FloorplanIntegration Namespace


ExpoBoothSync.UpdateFloorplanSyncDate Method

This method is responsible for updating the LastSynchronizationDate in the Floorplan record in Aptify.

protected virtual bool UpdateFloorplanSyncDate(
Int64 FloorplanID,
DateTime SyncDate
);

Parameters

FloorplanID
SyncDate

Return Value

Remarks

See Also

ExpoBoothSync Class | Aptify.Applications.Expos.FloorplanIntegration Namespace


ExpoBoothSync Events

The events of the ExpoBoothSync class are listed below. For a complete list of ExpoBoothSync class members, see the ExpoBoothSync Members topic.

Public Instance Events

StatusUpdate This event is raised each time a booth is processed during a floor plan syncrhonization process. Cancel parameter can be set to True by the code listening to the event to cancel the process.

See Also

ExpoBoothSync Class | Aptify.Applications.Expos.FloorplanIntegration Namespace


ExpoBoothSync.ExpoBoothSync.StatusUpdateEventHandler Event

This event is raised each time a booth is processed during a floor plan syncrhonization process. Cancel parameter can be set to True by the code listening to the event to cancel the process.

public event ExpoBoothSync.StatusUpdateEventHandler StatusUpdate;

Remarks

See Also

ExpoBoothSync Class | Aptify.Applications.Expos.FloorplanIntegration Namespace


ExpoBoothSync.StatusUpdateEventHandler Delegate

public delegate void ExpoBoothSync.StatusUpdateEventHandler(
Int64 CurrentBooth,
Int64 TotalBooths,
ref Boolean& Cancel
);

Requirements

Namespace: Aptify.Applications.Expos.FloorplanIntegration

Assembly: FloorplanBoothSynch (in FloorplanBoothSynch.dll)

See Also

Aptify.Applications.Expos.FloorplanIntegration Namespace


FloorplanUtility Class

Provides utility methods for accessing floorplan integration classes and other common requirements.

For a list of all members of this type, see FloorplanUtility Members.

System.Object
FloorplanUtility

public class FloorplanUtility

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Expos.FloorplanIntegration

Assembly: FloorplanIntegrationBase (in FloorplanIntegrationBase.dll)

See Also

FloorplanUtility Members | Aptify.Applications.Expos.FloorplanIntegration Namespace


FloorplanUtility Members

FloorplanUtility overview

Public Instance Constructors

FloorplanUtility Constructor Initializes a new instance of the FloorplanUtility class.

Public Instance Properties

Application
DataAction

Public Instance Methods

Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAptifyFloorplanID | Returns the Aptify Floorplan ID for a given external floorplan ID and Floorplan System ID
GetExternalFloorplanID | Returns the external floorplan tool Event Name for a given floorplan
GetFloorplanIntegration | Returns a new instance of the floorplan integration class associated with the specified floorplan
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FloorplanUtility Class | Aptify.Applications.Expos.FloorplanIntegration Namespace


FloorplanUtility Constructor

Initializes a new instance of the FloorplanUtility class.

public FloorplanUtility();

See Also

FloorplanUtility Class | Aptify.Applications.Expos.FloorplanIntegration Namespace


FloorplanUtility Properties

The properties of the FloorplanUtility class are listed below. For a complete list of FloorplanUtility class members, see the FloorplanUtility Members topic.

Public Instance Properties

Application
DataAction

See Also

FloorplanUtility Class | Aptify.Applications.Expos.FloorplanIntegration Namespace


Application Property

Aptify 5.0 Software Development Kit (SDK)

FloorplanUtility.Application Property

public virtual AptifyApplication Application {get;}

See Also

FloorplanUtility Class | Aptify.Applications.Expos.FloorplanIntegration Namespace


DataAction Property

Aptify 5.0 Software Development Kit (SDK)

FloorplanUtility.DataAction Property

public virtual DataAction DataAction {get;}

See Also

FloorplanUtility Class | Aptify.Applications.Expos.FloorplanIntegration Namespace


FloorplanUtility Methods

The methods of the FloorplanUtility class are listed below. For a complete list of FloorplanUtility class members, see the FloorplanUtility Members topic.

Public Instance Methods

Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAptifyFloorplanID | Returns the Aptify Floorplan ID for a given external floorplan ID and Floorplan System ID
GetExternalFloorplanID | Returns the external floorplan tool Event Name for a given floorplan
GetFloorplanIntegration | Returns a new instance of the floorplan integration class associated with the specified floorplan
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FloorplanUtility Class | Aptify.Applications.Expos.FloorplanIntegration Namespace


FloorplanUtility.Config Method

public virtual void Config(
AptifyApplication Application
);

See Also

FloorplanUtility Class | Aptify.Applications.Expos.FloorplanIntegration Namespace


FloorplanUtility.GetAptifyFloorplanID Method

Returns the Aptify Floorplan ID for a given external floorplan ID and Floorplan System ID

public virtual long GetAptifyFloorplanID(
String ExternalFloorplanID,
Int64 FloorplanSystemID
);

Parameters

ExternalFloorplanID
FloorplanSystemID

Return Value

Remarks

See Also

FloorplanUtility Class | Aptify.Applications.Expos.FloorplanIntegration Namespace


FloorplanUtility.GetExternalFloorplanID Method

Returns the external floorplan tool Event Name for a given floorplan

public virtual string GetExternalFloorplanID(
Int64 AptifyFloorplanID
);

Parameters

AptifyFloorplanID

Return Value

Remarks

See Also

FloorplanUtility Class | Aptify.Applications.Expos.FloorplanIntegration Namespace


FloorplanUtility.GetFloorplanIntegration Method

Returns a new instance of the floorplan integration class associated with the specified floorplan

public virtual IFloorplanIntegration GetFloorplanIntegration(
Int64 AptifyFloorplanID
);

Parameters

AptifyFloorplanID

Return Value

Remarks

See Also

FloorplanUtility Class | Aptify.Applications.Expos.FloorplanIntegration Namespace


IExpo Interface

Functions that are related to the overall event/expo and the floorplan application

For a list of all members of this type, see IExpo Members.

public interface IExpo

Types that implement IExpo

Type | Description
ExpoCADExpo | Provides implementation of the ExpoCAD integration for the ExpoCAD application
ExpoBase | Provides base class functionality for each floorplan integration specific class.

Remarks

Requirements

Namespace: Aptify.Applications.Expos.FloorplanIntegration

Assembly: FloorplanIntegrationBase (in FloorplanIntegrationBase.dll)

See Also

IExpo Members | Aptify.Applications.Expos.FloorplanIntegration Namespace


IExpo Members

IExpo overview

Public Instance Properties

AptifyFloorplanID | Aptify Floorplan ID
Booths | Returns a list of all booths within the expo
DatabaseName | Name of the database/file in the 3rd party application
Description | Description of the expo/event within the 3rd party application
EndDate | End date of the expo/event
FloorplanExpoID | Floorplan Application's Expo/Event ID for the Expo
Name | Name of the expo within the 3rd party application
ShowDates | Actual show dates entry in string format of the expo/event
StartDate | Start date of the expo/event

Public Instance Methods

AssignBooth |
Display | Opens the Expo in the visual floorplan application. Implementation class must create this capability in order to make it functional. The functionality is setup to load the 3rd party application first if required and then open a particular expo/event.
GetBoothCount | Returns the number of booths associated with the
GetSingleBooth | Overloaded. Returns a single booth based on a Booth ID
MergedBooths |
UnRentBooth |

See Also

IExpo Interface | Aptify.Applications.Expos.FloorplanIntegration Namespace


IExpo Properties

The properties of the IExpo interface are listed below. For a complete list of IExpo interface members, see the IExpo Members topic.

Public Instance Properties

AptifyFloorplanID | Aptify Floorplan ID
Booths | Returns a list of all booths within the expo
DatabaseName | Name of the database/file in the 3rd party application
Description | Description of the expo/event within the 3rd party application
EndDate | End date of the expo/event
FloorplanExpoID | Floorplan Application's Expo/Event ID for the Expo
Name | Name of the expo within the 3rd party application
ShowDates | Actual show dates entry in string format of the expo/event
StartDate | Start date of the expo/event

See Also

IExpo Interface | Aptify.Applications.Expos.FloorplanIntegration Namespace


AptifyFloorplanID Property

Aptify 5.0 Software Development Kit (SDK)

IExpo.AptifyFloorplanID Property

Aptify Floorplan ID

Int64 AptifyFloorplanID {get; set;}

Remarks

See Also

IExpo Interface | Aptify.Applications.Expos.FloorplanIntegration Namespace


Booths Property

Aptify 5.0 Software Development Kit (SDK)

IExpo.Booths Property

Returns a list of all booths within the expo

List<T> this[
Boolean Refresh
] {get;}

Remarks

See Also

IExpo Interface | Aptify.Applications.Expos.FloorplanIntegration Namespace


DatabaseName Property

Aptify 5.0 Software Development Kit (SDK)

IExpo.DatabaseName Property

Name of the database/file in the 3rd party application

String DatabaseName {get; set;}

Remarks

See Also

IExpo Interface | Aptify.Applications.Expos.FloorplanIntegration Namespace


Description Property

Aptify 5.0 Software Development Kit (SDK)

IExpo.Description Property

Description of the expo/event within the 3rd party application

String Description {get; set;}

Remarks

See Also

IExpo Interface | Aptify.Applications.Expos.FloorplanIntegration Namespace


EndDate Property

Aptify 5.0 Software Development Kit (SDK)

IExpo.EndDate Property

End date of the expo/event

DateTime EndDate {get; set;}

Property Value

Remarks

See Also

IExpo Interface | Aptify.Applications.Expos.FloorplanIntegration Namespace


FloorplanExpoID Property

Aptify 5.0 Software Development Kit (SDK)

IExpo.FloorplanExpoID Property

Floorplan Application's Expo/Event ID for the Expo

String FloorplanExpoID {get; set;}

Remarks

See Also

IExpo Interface | Aptify.Applications.Expos.FloorplanIntegration Namespace


Name Property

Aptify 5.0 Software Development Kit (SDK)

IExpo.Name Property

Name of the expo within the 3rd party application

String Name {get; set;}

Remarks

See Also

IExpo Interface | Aptify.Applications.Expos.FloorplanIntegration Namespace


ShowDates Property

Aptify 5.0 Software Development Kit (SDK)

IExpo.ShowDates Property

Actual show dates entry in string format of the expo/event

String ShowDates {get; set;}

Property Value

Remarks

See Also

IExpo Interface | Aptify.Applications.Expos.FloorplanIntegration Namespace


StartDate Property

Aptify 5.0 Software Development Kit (SDK)

IExpo.StartDate Property

Start date of the expo/event

DateTime StartDate {get; set;}

Property Value

Remarks

See Also

IExpo Interface | Aptify.Applications.Expos.FloorplanIntegration Namespace


IExpo Methods

The methods of the IExpo interface are listed below. For a complete list of IExpo interface members, see the IExpo Members topic.

Public Instance Methods

AssignBooth |
Display | Opens the Expo in the visual floorplan application. Implementation class must create this capability in order to make it functional. The functionality is setup to load the 3rd party application first if required and then open a particular expo/event.
GetBoothCount | Returns the number of booths associated with the
GetSingleBooth | Overloaded. Returns a single booth based on a Booth ID
MergedBooths |
UnRentBooth |

See Also

IExpo Interface | Aptify.Applications.Expos.FloorplanIntegration Namespace


IExpo.AssignBooth Method

bool AssignBooth(
String BoothNumber,
Int64 ExhibitorID,
String ExhibitorName
);

See Also

IExpo Interface | Aptify.Applications.Expos.FloorplanIntegration Namespace


IExpo.Display Method

Opens the Expo in the visual floorplan application. Implementation class must create this capability in order to make it functional. The functionality is setup to load the 3rd party application first if required and then open a particular expo/event.

bool Display();

Return Value

Remarks

See Also

IExpo Interface | Aptify.Applications.Expos.FloorplanIntegration Namespace


IExpo.GetBoothCount Method

Returns the number of booths associated with the

long GetBoothCount();

Return Value

Remarks

See Also

IExpo Interface | Aptify.Applications.Expos.FloorplanIntegration Namespace


GetSingleBooth Method

Aptify 5.0 Software Development Kit (SDK)

IExpo.GetSingleBooth Method

This overload returns a single booth based on the sequence it has within the collection of booths within the expo.

Overload List

This overload returns a single booth based on the sequence it has within the collection of booths within the expo.

Booth GetSingleBooth(Int64);

Returns a single booth based on a Booth ID

Booth GetSingleBooth(String);

See Also

IExpo Interface | Aptify.Applications.Expos.FloorplanIntegration Namespace


IExpo.GetSingleBooth Method (Int64)

This overload returns a single booth based on the sequence it has within the collection of booths within the expo.

Booth GetSingleBooth(
Int64 Sequence
);

Parameters

Sequence

Return Value

Remarks

See Also

IExpo Interface | Aptify.Applications.Expos.FloorplanIntegration Namespace | IExpo.GetSingleBooth Overload List


IExpo.GetSingleBooth Method (String)

Returns a single booth based on a Booth ID

Booth GetSingleBooth(
String BoothID
);

Parameters

BoothID

Return Value

Remarks

See Also

IExpo Interface | Aptify.Applications.Expos.FloorplanIntegration Namespace | IExpo.GetSingleBooth Overload List


IExpo.MergedBooths Method

List<T> MergedBooths(
String ExternalFloorPlanId
);

See Also

IExpo Interface | Aptify.Applications.Expos.FloorplanIntegration Namespace


IExpo.UnRentBooth Method

bool UnRentBooth(
String BoothNumber
);

See Also

IExpo Interface | Aptify.Applications.Expos.FloorplanIntegration Namespace


IFloorplanIntegration Interface

This interface defines a method for integration with any 3rd party provider of visual floorplan services for Expos. To provide support for a new 3rd party system, create a class that implements this interface. To integrate a 3rd party application into the Aptify Expo Floorplan Integration architecture, it is required to provide a class that implements this interface as well as a class that implements the IExpo interface.

For a list of all members of this type, see IFloorplanIntegration Members.

public interface IFloorplanIntegration

Types that implement IFloorplanIntegration

Type | Description
ExpoCADBoothSync | Aptify ExpoCAD Booth Synchronization Object

Remarks

Requirements

Namespace: Aptify.Applications.Expos.FloorplanIntegration

Assembly: FloorplanIntegrationBase (in FloorplanIntegrationBase.dll)

See Also

IFloorplanIntegration Members | Aptify.Applications.Expos.FloorplanIntegration Namespace


IFloorplanIntegration Members

IFloorplanIntegration overview

Public Instance Properties

FloorplanSystemID Returns the Aptify Floorplan Systems entity record ID for the current floorplan integration

Public Instance Methods

Config |
GetExpo | Overloaded. Returns the Expo for the specified Expo Name
GetExpoList | Returns a list of all of the events that are registered in the 3rd party application
HideFloorPlanApplication | Hides the visual floorplan application, must be overriden by each sub-class with 3rd party application specific implementation.
LoadFloorPlanApplication | Loads the 3rd party application, if not already loaded. Does NOT bring it to the foreground.
ShowFloorPlan | Shows the visual floorplan application event, must be overriden by each sub-class with 3rd party application specific implementation.
ShowFloorPlanApplication | Shows the visual floorplan application, must be overriden by each sub-class with 3rd party application specific implementation.

See Also

IFloorplanIntegration Interface | Aptify.Applications.Expos.FloorplanIntegration Namespace


IFloorplanIntegration Properties

The properties of the IFloorplanIntegration interface are listed below. For a complete list of IFloorplanIntegration interface members, see the IFloorplanIntegration Members topic.

Public Instance Properties

FloorplanSystemID Returns the Aptify Floorplan Systems entity record ID for the current floorplan integration

See Also

IFloorplanIntegration Interface | Aptify.Applications.Expos.FloorplanIntegration Namespace


FloorplanSystemID Property

Aptify 5.0 Software Development Kit (SDK)

IFloorplanIntegration.FloorplanSystemID Property

Returns the Aptify Floorplan Systems entity record ID for the current floorplan integration

Int64 FloorplanSystemID {get;}

Property Value

Remarks

See Also

IFloorplanIntegration Interface | Aptify.Applications.Expos.FloorplanIntegration Namespace


IFloorplanIntegration Methods

The methods of the IFloorplanIntegration interface are listed below. For a complete list of IFloorplanIntegration interface members, see the IFloorplanIntegration Members topic.

Public Instance Methods

Config |
GetExpo | Overloaded. Returns the Expo for the specified Expo Name
GetExpoList | Returns a list of all of the events that are registered in the 3rd party application
HideFloorPlanApplication | Hides the visual floorplan application, must be overriden by each sub-class with 3rd party application specific implementation.
LoadFloorPlanApplication | Loads the 3rd party application, if not already loaded. Does NOT bring it to the foreground.
ShowFloorPlan | Shows the visual floorplan application event, must be overriden by each sub-class with 3rd party application specific implementation.
ShowFloorPlanApplication | Shows the visual floorplan application, must be overriden by each sub-class with 3rd party application specific implementation.

See Also

IFloorplanIntegration Interface | Aptify.Applications.Expos.FloorplanIntegration Namespace


IFloorplanIntegration.Config Method

void Config(
AptifyApplication AptifyApplication,
Int64 FloorplanSystemID
);

See Also

IFloorplanIntegration Interface | Aptify.Applications.Expos.FloorplanIntegration Namespace


GetExpo Method

Aptify 5.0 Software Development Kit (SDK)

IFloorplanIntegration.GetExpo Method

Returns the Expo for the specified Aptify Floorplan ID

Overload List

Returns the Expo for the specified Aptify Floorplan ID

IExpo GetExpo(Int64);

Returns the Expo for the specified Expo Name

IExpo GetExpo(String);

See Also

IFloorplanIntegration Interface | Aptify.Applications.Expos.FloorplanIntegration Namespace


IFloorplanIntegration.GetExpo Method (Int64)

Returns the Expo for the specified Aptify Floorplan ID

IExpo GetExpo(
Int64 AptifyFloorplanID
);

Parameters

AptifyFloorplanID

Return Value

Remarks

See Also

IFloorplanIntegration Interface | Aptify.Applications.Expos.FloorplanIntegration Namespace | IFloorplanIntegration.GetExpo Overload List


IFloorplanIntegration.GetExpo Method (String)

Returns the Expo for the specified Expo Name

IExpo GetExpo(
String ExpoName
);

Parameters

ExpoName

Return Value

Remarks

See Also

IFloorplanIntegration Interface | Aptify.Applications.Expos.FloorplanIntegration Namespace | IFloorplanIntegration.GetExpo Overload List


IFloorplanIntegration.GetExpoList Method

Returns a list of all of the events that are registered in the 3rd party application

List<T> GetExpoList();

Return Value

Remarks

See Also

IFloorplanIntegration Interface | Aptify.Applications.Expos.FloorplanIntegration Namespace


IFloorplanIntegration.HideFloorPlanApplication Method

Hides the visual floorplan application, must be overriden by each sub-class with 3rd party application specific implementation.

bool HideFloorPlanApplication();

Return Value

Remarks

See Also

IFloorplanIntegration Interface | Aptify.Applications.Expos.FloorplanIntegration Namespace


IFloorplanIntegration.LoadFloorPlanApplication Method

Loads the 3rd party application, if not already loaded. Does NOT bring it to the foreground.

bool LoadFloorPlanApplication();

Return Value

Remarks

See Also

IFloorplanIntegration Interface | Aptify.Applications.Expos.FloorplanIntegration Namespace


IFloorplanIntegration.ShowFloorPlan Method

Shows the visual floorplan application event, must be overriden by each sub-class with 3rd party application specific implementation.

bool ShowFloorPlan(
Int64 AptifyFloorPlanId
);

Return Value

Remarks

See Also

IFloorplanIntegration Interface | Aptify.Applications.Expos.FloorplanIntegration Namespace


IFloorplanIntegration.ShowFloorPlanApplication Method

Shows the visual floorplan application, must be overriden by each sub-class with 3rd party application specific implementation.

bool ShowFloorPlanApplication();

Return Value

Remarks

See Also

IFloorplanIntegration Interface | Aptify.Applications.Expos.FloorplanIntegration Namespace


MergedBooths Class

Merger Booth information class

For a list of all members of this type, see MergedBooths Members.

System.Object
MergedBooths

public class MergedBooths

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Expos.FloorplanIntegration

Assembly: FloorplanIntegrationBase (in FloorplanIntegrationBase.dll)

See Also

MergedBooths Members | Aptify.Applications.Expos.FloorplanIntegration Namespace


MergedBooths Members

MergedBooths overview

Public Instance Constructors

MergedBooths Constructor Initializes a new instance of the MergedBooths class.

Public Instance Fields

m_sMergedBooth
m_sOriginalBooth

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MergedBooths Class | Aptify.Applications.Expos.FloorplanIntegration Namespace


MergedBooths Constructor

Initializes a new instance of the MergedBooths class.

public MergedBooths();

See Also

MergedBooths Class | Aptify.Applications.Expos.FloorplanIntegration Namespace


MergedBooths Fields

The fields of the MergedBooths class are listed below. For a complete list of MergedBooths class members, see the MergedBooths Members topic.

Public Instance Fields

m_sMergedBooth
m_sOriginalBooth

See Also

MergedBooths Class | Aptify.Applications.Expos.FloorplanIntegration Namespace


MergedBooths.m_sMergedBooth Field

public m_sMergedBooth m_sMergedBooth;

See Also

MergedBooths Class | Aptify.Applications.Expos.FloorplanIntegration Namespace


MergedBooths.m_sOriginalBooth Field

public m_sOriginalBooth m_sOriginalBooth;

See Also

MergedBooths Class | Aptify.Applications.Expos.FloorplanIntegration Namespace


SyncWizard Class

Aptify Synchronization Wizard - Synchronizes data from Aptify Expo Floorplans/Booths to a 3rd party floorplanning tool in both directions, using the ExpoBoothSync object.

For a list of all members of this type, see SyncWizard Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
SyncWizard

public class SyncWizard : Form, IAptifyAction

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Expos.FloorplanIntegration

Assembly: FloorplanBoothSynch (in FloorplanBoothSynch.dll)

See Also

SyncWizard Members | Aptify.Applications.Expos.FloorplanIntegration Namespace


SyncWizard Members

SyncWizard overview

Public Instance Constructors

SyncWizard Constructor Initializes a new instance of the SyncWizard class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoAction | Overloaded.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
LoadExpos | This method loads up the expos that are currently active into the cmbExpos combo box
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

SyncWizard Class | Aptify.Applications.Expos.FloorplanIntegration Namespace


SyncWizard Constructor

Initializes a new instance of the SyncWizard class.

public SyncWizard();

See Also

SyncWizard Class | Aptify.Applications.Expos.FloorplanIntegration Namespace


SyncWizard Methods

The methods of the SyncWizard class are listed below. For a complete list of SyncWizard class members, see the SyncWizard Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoAction | Overloaded.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
LoadExpos | This method loads up the expos that are currently active into the cmbExpos combo box
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

SyncWizard Class | Aptify.Applications.Expos.FloorplanIntegration Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

SyncWizard.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

SyncWizard Class | Aptify.Applications.Expos.FloorplanIntegration Namespace


SyncWizard.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

SyncWizard Class | Aptify.Applications.Expos.FloorplanIntegration Namespace | SyncWizard.Dispose Overload List


DoAction Method

Aptify 5.0 Software Development Kit (SDK)

SyncWizard.DoAction Method

Overload List

public void DoAction(AptifyApplication,Int64);

public void DoAction(AptifyApplication,Int64,Int64);

public void DoAction(AptifyApplication,Int64,Int64,params Object[]);

public void DoAction(AptifyApplication,Int64,params String[]);

See Also

SyncWizard Class | Aptify.Applications.Expos.FloorplanIntegration Namespace


SyncWizard.DoAction Method (AptifyApplication, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID
);

Implements

IAptifyAction.

See Also

SyncWizard Class | Aptify.Applications.Expos.FloorplanIntegration Namespace | SyncWizard.DoAction Overload List


SyncWizard.DoAction Method (AptifyApplication, Int64, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID
);

Implements

IAptifyAction.

See Also

SyncWizard Class | Aptify.Applications.Expos.FloorplanIntegration Namespace | SyncWizard.DoAction Overload List


SyncWizard.DoAction Method (AptifyApplication, Int64, Int64, Object[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID,
params Object[] SelectedItems
);

Implements

IAptifyAction.

See Also

SyncWizard Class | Aptify.Applications.Expos.FloorplanIntegration Namespace | SyncWizard.DoAction Overload List


SyncWizard.DoAction Method (AptifyApplication, Int64, String[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
params String[] SelectedItems
);

Implements

IAptifyAction.

See Also

SyncWizard Class | Aptify.Applications.Expos.FloorplanIntegration Namespace | SyncWizard.DoAction Overload List


SyncWizard.LoadExpos Method

This method loads up the expos that are currently active into the cmbExpos combo box

protected virtual void LoadExpos();

Remarks

See Also

SyncWizard Class | Aptify.Applications.Expos.FloorplanIntegration Namespace


Aptify.Applications.Fundraising

Aptify 5.0 Software Development Kit (SDK)

Aptify.Applications.Fundraising Namespace

The objects in this namespace implement Aptify's Fundraising add-on module.

Namespace hierarchy

Classes

Class | Description
ContributionPaymentObject |
ContributionPaymentWizard |
DonorAdvisedFundAllocation |
DonorAdvisedFundsLayoutControl |
FundraisingCampaignsLayout |
FundSelectorEventArgs |
GrantLayoutControl |
Grants |
Pledge | This class provides the implementation for business logic for the Pledges entity in the Aptify Fundraising Management system.
Pledge.PaymentTypeInfo |
PledgeControlGroup |
PledgeFundSelector |
PledgeLayoutControl |
PledgeMatchingObject |
PledgeMatchingStatus |
PledgeMatchObject |
PledgePaymentSchedule |
PledgePaymentScheduleLayout |
PledgeProgressBar |
Solicitor | This class provides the implementation for business logic for the Fundraising Solicitors entity in the Aptify Fundraising Management system.

Structures

Structure | Description
ContributionPaymentObject.stPledgeAmount |
ContributionPaymentObject.stPledgeHeader |
GroupControl |
Pledge.FundraisingCampaignDiscountRule |
PledgeLayoutControl.PledgeSubTypes |

Delegates

Delegate | Description
Pledge.StatusUpdateEventHandler |
PledgeFundSelector.FundProductAddedEventHandler |

Enumerations

Enumeration | Description
Pledge.PledgeProcessStep | Specifies the current internal process steps that are used with the StatusUpdate Event
Pledge.PledgeTransactionOperation | Enumerated type that specifies the type of operation that the DoSave() method should perform, if any, in addition to the standard save for the pledge data itself.
PledgeMatchObject.CalcTypeConstants |


ContributionPaymentObject Class

For a list of all members of this type, see ContributionPaymentObject Members.

System.Object
ContributionPaymentObject

public class ContributionPaymentObject : IProcessComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Fundraising

Assembly: ContributionPaymentObject (in ContributionPaymentObject.dll)

See Also

ContributionPaymentObject Members | Aptify.Applications.Fundraising Namespace


ContributionPaymentObject Members

ContributionPaymentObject overview

Public Instance Constructors

ContributionPaymentObject Constructor Initializes a new instance of the ContributionPaymentObject class.

Public Instance Properties

Application
DataAction
Database
PaymentInformation
PledgeAmount
PledgeHeader
Properties

Public Instance Methods

Config |
DoApplyPayment |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ContributionPaymentObject Class | Aptify.Applications.Fundraising Namespace


ContributionPaymentObject Constructor

Initializes a new instance of the ContributionPaymentObject class.

public ContributionPaymentObject();

See Also

ContributionPaymentObject Class | Aptify.Applications.Fundraising Namespace


ContributionPaymentObject Properties

The properties of the ContributionPaymentObject class are listed below. For a complete list of ContributionPaymentObject class members, see the ContributionPaymentObject Members topic.

Public Instance Properties

Application
DataAction
Database
PaymentInformation
PledgeAmount
PledgeHeader
Properties

See Also

ContributionPaymentObject Class | Aptify.Applications.Fundraising Namespace


Application Property

Aptify 5.0 Software Development Kit (SDK)

ContributionPaymentObject.Application Property

public virtual AptifyApplication Application {get;}

See Also

ContributionPaymentObject Class | Aptify.Applications.Fundraising Namespace


DataAction Property

Aptify 5.0 Software Development Kit (SDK)

ContributionPaymentObject.DataAction Property

public virtual DataAction DataAction {get;}

See Also

ContributionPaymentObject Class | Aptify.Applications.Fundraising Namespace


Database Property

Aptify 5.0 Software Development Kit (SDK)

ContributionPaymentObject.Database Property

public virtual String Database {get;}

See Also

ContributionPaymentObject Class | Aptify.Applications.Fundraising Namespace


PaymentInformation Property

Aptify 5.0 Software Development Kit (SDK)

ContributionPaymentObject.PaymentInformation Property

public AptifyGenericEntity PaymentInformation {set;}

See Also

ContributionPaymentObject Class | Aptify.Applications.Fundraising Namespace


PledgeAmount Property

Aptify 5.0 Software Development Kit (SDK)

ContributionPaymentObject.PledgeAmount Property

public List<T> PledgeAmount {get;}

See Also

ContributionPaymentObject Class | Aptify.Applications.Fundraising Namespace


PledgeHeader Property

Aptify 5.0 Software Development Kit (SDK)

ContributionPaymentObject.PledgeHeader Property

public ContributionPaymentObject.stPledgeHeader PledgeHeader {set;}

See Also

ContributionPaymentObject Class | Aptify.Applications.Fundraising Namespace


Properties Property

Aptify 5.0 Software Development Kit (SDK)

ContributionPaymentObject.Properties Property

public AptifyProperties Properties {get;}

Implements

IProcessComponent.

See Also

ContributionPaymentObject Class | Aptify.Applications.Fundraising Namespace


ContributionPaymentObject Methods

The methods of the ContributionPaymentObject class are listed below. For a complete list of ContributionPaymentObject class members, see the ContributionPaymentObject Members topic.

Public Instance Methods

Config |
DoApplyPayment |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ContributionPaymentObject Class | Aptify.Applications.Fundraising Namespace


ContributionPaymentObject.Config Method

public void Config(
AptifyApplication ApplicationObject
);

Implements

IProcessComponent.

See Also

ContributionPaymentObject Class | Aptify.Applications.Fundraising Namespace


ContributionPaymentObject.DoApplyPayment Method

public bool DoApplyPayment(
Boolean bCreatePledge
);

See Also

ContributionPaymentObject Class | Aptify.Applications.Fundraising Namespace


ContributionPaymentObject.Run Method

public string Run();

Implements

IProcessComponent.

See Also

ContributionPaymentObject Class | Aptify.Applications.Fundraising Namespace


ContributionPaymentObject.stPledgeAmount Structure

For a list of all members of this type, see ContributionPaymentObject.stPledgeAmount Members.

System.Object
ValueType
ContributionPaymentObject.stPledgeAmount

public struct ContributionPaymentObject.stPledgeAmount

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Fundraising

Assembly: ContributionPaymentObject (in ContributionPaymentObject.dll)

See Also

ContributionPaymentObject.stPledgeAmount Members | Aptify.Applications.Fundraising Namespace


ContributionPaymentObject.stPledgeAmount Members

ContributionPaymentObject.stPledgeAmount overview

Public Instance Fields

dAmount
lOrderID
lPledgeID

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

ContributionPaymentObject.stPledgeAmount Structure | Aptify.Applications.Fundraising Namespace


ContributionPaymentObject.stPledgeAmount Fields

The fields of the ContributionPaymentObject.stPledgeAmount structure are listed below. For a complete list of ContributionPaymentObject.stPledgeAmount structure members, see the ContributionPaymentObject.stPledgeAmount Members topic.

Public Instance Fields

dAmount
lOrderID
lPledgeID

See Also

ContributionPaymentObject.stPledgeAmount Structure | Aptify.Applications.Fundraising Namespace


ContributionPaymentObject.stPledgeAmount.dAmount Field

public dAmount dAmount;

See Also

ContributionPaymentObject.stPledgeAmount Class | Aptify.Applications.Fundraising Namespace


ContributionPaymentObject.stPledgeAmount.lOrderID Field

public lOrderID lOrderID;

See Also

ContributionPaymentObject.stPledgeAmount Class | Aptify.Applications.Fundraising Namespace


ContributionPaymentObject.stPledgeAmount.lPledgeID Field

public lPledgeID lPledgeID;

See Also

ContributionPaymentObject.stPledgeAmount Class | Aptify.Applications.Fundraising Namespace


ContributionPaymentObject.stPledgeHeader Structure

For a list of all members of this type, see ContributionPaymentObject.stPledgeHeader Members.

System.Object
ValueType
ContributionPaymentObject.stPledgeHeader

public struct ContributionPaymentObject.stPledgeHeader

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Fundraising

Assembly: ContributionPaymentObject (in ContributionPaymentObject.dll)

See Also

ContributionPaymentObject.stPledgeHeader Members | Aptify.Applications.Fundraising Namespace


ContributionPaymentObject.stPledgeHeader Members

ContributionPaymentObject.stPledgeHeader overview

Public Instance Fields

dAmount
dDateReceived
IsCorporate
lCampaignID
lCashCtrlBatchID
lCompanyID
lContactID
lContributorID
lEmployeeID
lFundID
lSolicitorID

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

ContributionPaymentObject.stPledgeHeader Structure | Aptify.Applications.Fundraising Namespace


ContributionPaymentObject.stPledgeHeader Fields

The fields of the ContributionPaymentObject.stPledgeHeader structure are listed below. For a complete list of ContributionPaymentObject.stPledgeHeader structure members, see the ContributionPaymentObject.stPledgeHeader Members topic.

Public Instance Fields

dAmount
dDateReceived
IsCorporate
lCampaignID
lCashCtrlBatchID
lCompanyID
lContactID
lContributorID
lEmployeeID
lFundID
lSolicitorID

See Also

ContributionPaymentObject.stPledgeHeader Structure | Aptify.Applications.Fundraising Namespace


ContributionPaymentObject.stPledgeHeader.dAmount Field

public dAmount dAmount;

See Also

ContributionPaymentObject.stPledgeHeader Class | Aptify.Applications.Fundraising Namespace


ContributionPaymentObject.stPledgeHeader.dDateReceived Field

public dDateReceived dDateReceived;

See Also

ContributionPaymentObject.stPledgeHeader Class | Aptify.Applications.Fundraising Namespace


ContributionPaymentObject.stPledgeHeader.IsCorporate Field

public IsCorporate IsCorporate;

See Also

ContributionPaymentObject.stPledgeHeader Class | Aptify.Applications.Fundraising Namespace


ContributionPaymentObject.stPledgeHeader.lCampaignID Field

public lCampaignID lCampaignID;

See Also

ContributionPaymentObject.stPledgeHeader Class | Aptify.Applications.Fundraising Namespace


ContributionPaymentObject.stPledgeHeader.lCashCtrlBatchID Field

public lCashCtrlBatchID lCashCtrlBatchID;

See Also

ContributionPaymentObject.stPledgeHeader Class | Aptify.Applications.Fundraising Namespace


ContributionPaymentObject.stPledgeHeader.lCompanyID Field

public lCompanyID lCompanyID;

See Also

ContributionPaymentObject.stPledgeHeader Class | Aptify.Applications.Fundraising Namespace


ContributionPaymentObject.stPledgeHeader.lContactID Field

public lContactID lContactID;

See Also

ContributionPaymentObject.stPledgeHeader Class | Aptify.Applications.Fundraising Namespace


ContributionPaymentObject.stPledgeHeader.lContributorID Field

public lContributorID lContributorID;

See Also

ContributionPaymentObject.stPledgeHeader Class | Aptify.Applications.Fundraising Namespace


ContributionPaymentObject.stPledgeHeader.lEmployeeID Field

public lEmployeeID lEmployeeID;

See Also

ContributionPaymentObject.stPledgeHeader Class | Aptify.Applications.Fundraising Namespace


ContributionPaymentObject.stPledgeHeader.lFundID Field

public lFundID lFundID;

See Also

ContributionPaymentObject.stPledgeHeader Class | Aptify.Applications.Fundraising Namespace


ContributionPaymentObject.stPledgeHeader.lSolicitorID Field

public lSolicitorID lSolicitorID;

See Also

ContributionPaymentObject.stPledgeHeader Class | Aptify.Applications.Fundraising Namespace


ContributionPaymentWizard Class

For a list of all members of this type, see ContributionPaymentWizard Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
ContributionPaymentWizard

public class ContributionPaymentWizard : Form, IAptifyAction

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Fundraising

Assembly: ContributionPaymentWizard (in ContributionPaymentWizard.dll)

See Also

ContributionPaymentWizard Members | Aptify.Applications.Fundraising Namespace


ContributionPaymentWizard Members

ContributionPaymentWizard overview

Public Instance Constructors

ContributionPaymentWizard Constructor Initializes a new instance of the ContributionPaymentWizard class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoAction | Overloaded.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ContributionPaymentWizard Class | Aptify.Applications.Fundraising Namespace


ContributionPaymentWizard Constructor

Initializes a new instance of the ContributionPaymentWizard class.

public ContributionPaymentWizard();

See Also

ContributionPaymentWizard Class | Aptify.Applications.Fundraising Namespace


ContributionPaymentWizard Methods

The methods of the ContributionPaymentWizard class are listed below. For a complete list of ContributionPaymentWizard class members, see the ContributionPaymentWizard Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoAction | Overloaded.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ContributionPaymentWizard Class | Aptify.Applications.Fundraising Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

ContributionPaymentWizard.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

ContributionPaymentWizard Class | Aptify.Applications.Fundraising Namespace


ContributionPaymentWizard.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

ContributionPaymentWizard Class | Aptify.Applications.Fundraising Namespace | ContributionPaymentWizard.Dispose Overload List


DoAction Method

Aptify 5.0 Software Development Kit (SDK)

ContributionPaymentWizard.DoAction Method

Overload List

public void DoAction(AptifyApplication,Int64);

public void DoAction(AptifyApplication,Int64,Int64);

Starts the Aptify Class Registration Wizard.

public void DoAction(AptifyApplication,Int64,Int64,params Object[]);

public void DoAction(AptifyApplication,Int64,params String[]);

See Also

ContributionPaymentWizard Class | Aptify.Applications.Fundraising Namespace


ContributionPaymentWizard.DoAction Method (AptifyApplication, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID
);

Implements

IAptifyAction.

See Also

ContributionPaymentWizard Class | Aptify.Applications.Fundraising Namespace | ContributionPaymentWizard.DoAction Overload List


ContributionPaymentWizard.DoAction Method (AptifyApplication, Int64, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID
);

Implements

IAptifyAction.

See Also

ContributionPaymentWizard Class | Aptify.Applications.Fundraising Namespace | ContributionPaymentWizard.DoAction Overload List


ContributionPaymentWizard.DoAction Method (AptifyApplication, Int64, Int64, Object[])

Starts the Aptify Class Registration Wizard.

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID,
params Object[] SelectedItems
);

Parameters

ApplicationObject
A valid AptifyApplication.
EntityID
Not Used
ViewID
Not Used
SelectedItems
Not Used

Implements

IAptifyAction.

Remarks

See Also

ContributionPaymentWizard Class | Aptify.Applications.Fundraising Namespace | ContributionPaymentWizard.DoAction Overload List


ContributionPaymentWizard.DoAction Method (AptifyApplication, Int64, String[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
params String[] SelectedItems
);

Implements

IAptifyAction.

See Also

ContributionPaymentWizard Class | Aptify.Applications.Fundraising Namespace | ContributionPaymentWizard.DoAction Overload List


DonorAdvisedFundAllocation Class

For a list of all members of this type, see DonorAdvisedFundAllocation Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
DonorAdvisedFundAllocation

public class DonorAdvisedFundAllocation : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Fundraising

Assembly: DonorAdvisedFundAllocation (in DonorAdvisedFundAllocation.dll)

See Also

DonorAdvisedFundAllocation Members | Aptify.Applications.Fundraising Namespace


DonorAdvisedFundAllocation Members

DonorAdvisedFundAllocation overview

Public Instance Constructors

DonorAdvisedFundAllocation Constructor Initializes a new instance of the DonorAdvisedFundAllocation class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config | Overloaded.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded. This method overrides the save method to allow the creation of scheduled transactions if needed.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

DonorAdvisedFundAllocation Class | Aptify.Applications.Fundraising Namespace


DonorAdvisedFundAllocation Constructor

Initializes a new instance of the DonorAdvisedFundAllocation class.

public DonorAdvisedFundAllocation();

See Also

DonorAdvisedFundAllocation Class | Aptify.Applications.Fundraising Namespace


DonorAdvisedFundAllocation Methods

The methods of the DonorAdvisedFundAllocation class are listed below. For a complete list of DonorAdvisedFundAllocation class members, see the DonorAdvisedFundAllocation Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config | Overloaded.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded. This method overrides the save method to allow the creation of scheduled transactions if needed.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

DonorAdvisedFundAllocation Class | Aptify.Applications.Fundraising Namespace


Config Method

Aptify 5.0 Software Development Kit (SDK)

DonorAdvisedFundAllocation.Config Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual void Config(AptifySubTypeBase);

Inherited from AptifyGenericEntity.

public override void Config(AptifySubTypeBase,Int64);

Inherited from AptifyGenericEntityBase.

public virtual void Config(UserCredentials,String);

public override void Config(UserCredentials,String,Int64);

See Also

DonorAdvisedFundAllocation Class | Aptify.Applications.Fundraising Namespace


DonorAdvisedFundAllocation.Config Method (UserCredentials, String, Int64)

public override void Config(
UserCredentials UserCredentials,
String EntityName,
Int64 RecordID
);

See Also

DonorAdvisedFundAllocation Class | Aptify.Applications.Fundraising Namespace | DonorAdvisedFundAllocation.Config Overload List


Save Method

Aptify 5.0 Software Development Kit (SDK)

DonorAdvisedFundAllocation.Save Method

This method overrides the save method to allow the creation of scheduled transactions if needed.

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Save();

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean,ref String&);

This method overrides the save method to allow the creation of scheduled transactions if needed.

public override bool Save(Boolean,ref String&,String);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(ref String&);

See Also

DonorAdvisedFundAllocation Class | Aptify.Applications.Fundraising Namespace


DonorAdvisedFundAllocation.Save Method (Boolean, String&, String)

This method overrides the save method to allow the creation of scheduled transactions if needed.

public override bool Save(
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

Parameters

AllowGUI
ErrorString
TransactionID

Return Value

Remarks

See Also

DonorAdvisedFundAllocation Class | Aptify.Applications.Fundraising Namespace | DonorAdvisedFundAllocation.Save Overload List


DonorAdvisedFundsLayoutControl Class

For a list of all members of this type, see DonorAdvisedFundsLayoutControl Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
DonorAdvisedFundsLayoutControl

public class DonorAdvisedFundsLayoutControl : FormTemplateLayout

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Fundraising

Assembly: DonorAdvisedFundsControls (in DonorAdvisedFundsControls.dll)

See Also

DonorAdvisedFundsLayoutControl Members | Aptify.Applications.Fundraising Namespace


DonorAdvisedFundsLayoutControl Members

DonorAdvisedFundsLayoutControl overview

Public Instance Constructors

DonorAdvisedFundsLayoutControl Constructor Initializes a new instance of the DonorAdvisedFundsLayoutControl class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

m_lnkCompany

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
m_grpPledgeType |
m_oFormContext |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormTemplateLayout) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControls |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig |
OnFormTemplateLoaded (inherited from FormTemplateLayout) | Raises the FormTemplateLoaded event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad |
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetGroupOptionControlToGE |
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdatePledgeTypeControls |
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

DonorAdvisedFundsLayoutControl Class | Aptify.Applications.Fundraising Namespace


DonorAdvisedFundsLayoutControl Constructor

Initializes a new instance of the DonorAdvisedFundsLayoutControl class.

public DonorAdvisedFundsLayoutControl();

See Also

DonorAdvisedFundsLayoutControl Class | Aptify.Applications.Fundraising Namespace


DonorAdvisedFundsLayoutControl Fields

The fields of the DonorAdvisedFundsLayoutControl class are listed below. For a complete list of DonorAdvisedFundsLayoutControl class members, see the DonorAdvisedFundsLayoutControl Members topic.

Protected Instance Fields

m_lnkCompany

See Also

DonorAdvisedFundsLayoutControl Class | Aptify.Applications.Fundraising Namespace


DonorAdvisedFundsLayoutControl.m_lnkCompany Field

protected m_lnkCompany m_lnkCompany;

See Also

DonorAdvisedFundsLayoutControl Class | Aptify.Applications.Fundraising Namespace


DonorAdvisedFundsLayoutControl Properties

The properties of the DonorAdvisedFundsLayoutControl class are listed below. For a complete list of DonorAdvisedFundsLayoutControl class members, see the DonorAdvisedFundsLayoutControl Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
m_grpPledgeType |
m_oFormContext |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

DonorAdvisedFundsLayoutControl Class | Aptify.Applications.Fundraising Namespace


m_grpPledgeType Property

Aptify 5.0 Software Development Kit (SDK)

DonorAdvisedFundsLayoutControl.m_grpPledgeType Property

protected virtual GroupedOptions m_grpPledgeType {get; set;}

See Also

DonorAdvisedFundsLayoutControl Class | Aptify.Applications.Fundraising Namespace


m_oFormContext Property

Aptify 5.0 Software Development Kit (SDK)

DonorAdvisedFundsLayoutControl.m_oFormContext Property

protected virtual AptifyFormTemplateContext m_oFormContext {get; set;}

See Also

DonorAdvisedFundsLayoutControl Class | Aptify.Applications.Fundraising Namespace


DonorAdvisedFundsLayoutControl Methods

The methods of the DonorAdvisedFundsLayoutControl class are listed below. For a complete list of DonorAdvisedFundsLayoutControl class members, see the DonorAdvisedFundsLayoutControl Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormTemplateLayout) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControls |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig |
OnFormTemplateLoaded (inherited from FormTemplateLayout) | Raises the FormTemplateLoaded event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad |
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetGroupOptionControlToGE |
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdatePledgeTypeControls |
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

DonorAdvisedFundsLayoutControl Class | Aptify.Applications.Fundraising Namespace


DonorAdvisedFundsLayoutControl.FindControls Method

protected virtual void FindControls();

See Also

DonorAdvisedFundsLayoutControl Class | Aptify.Applications.Fundraising Namespace


DonorAdvisedFundsLayoutControl.OnFormComponentConfig Method

protected override void OnFormComponentConfig(
AptifyFormTemplateContext Context
);

Implements

IFormComponent.

See Also

DonorAdvisedFundsLayoutControl Class | Aptify.Applications.Fundraising Namespace


DonorAdvisedFundsLayoutControl.OnLoad Method

protected override void OnLoad(
EventArgs e
);

See Also

DonorAdvisedFundsLayoutControl Class | Aptify.Applications.Fundraising Namespace


DonorAdvisedFundsLayoutControl.OnRefresh Method

protected override void OnRefresh();

Implements

IFormComponent.

See Also

DonorAdvisedFundsLayoutControl Class | Aptify.Applications.Fundraising Namespace


DonorAdvisedFundsLayoutControl.SetGroupOptionControlToGE Method

protected virtual void SetGroupOptionControlToGE(
Boolean bIsCorporateGeValue
);

See Also

DonorAdvisedFundsLayoutControl Class | Aptify.Applications.Fundraising Namespace


DonorAdvisedFundsLayoutControl.UpdatePledgeTypeControls Method

protected virtual void UpdatePledgeTypeControls(
Boolean IsCorporate
);

See Also

DonorAdvisedFundsLayoutControl Class | Aptify.Applications.Fundraising Namespace


FundraisingCampaignsLayout Class

For a list of all members of this type, see FundraisingCampaignsLayout Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
FundraisingCampaignsLayout

public class FundraisingCampaignsLayout : FormTemplateLayout

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Fundraising

Assembly: FundraisingCampaignsControls (in FundraisingCampaignsControls.dll)

See Also

FundraisingCampaignsLayout Members | Aptify.Applications.Fundraising Namespace


FundraisingCampaignsLayout Members

FundraisingCampaignsLayout overview

Public Instance Constructors

FundraisingCampaignsLayout Constructor Default contructor

Public Instance Fields

m_cmbDeductibleType
m_txtDiscountRevenueAfterOneYear
m_txtDiscountRevenueFirstYear
m_txtPercentDeductible
m_txtTargetAmount
m_txtTotalRaised

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
m_chkTaxDeductible |
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
ConfigureControlVisibility | Set the visibility of specific controls on the control. This method will be called as the form is loaded either from cache or for the first time as well as from other control events handled.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormTemplateLayout) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControls | Find controls on the layout control and assign them to the class field variables for use.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded (inherited from FormTemplateLayout) | Raises the FormTemplateLoaded event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad | Called when the layout control is called for the first time and loaded into memory
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh | Typically called when loaded from cache.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

FundraisingCampaignsLayout Class | Aptify.Applications.Fundraising Namespace


FundraisingCampaignsLayout Constructor

Default contructor

public FundraisingCampaignsLayout();

Remarks

See Also

FundraisingCampaignsLayout Class | Aptify.Applications.Fundraising Namespace


FundraisingCampaignsLayout Fields

The fields of the FundraisingCampaignsLayout class are listed below. For a complete list of FundraisingCampaignsLayout class members, see the FundraisingCampaignsLayout Members topic.

Public Instance Fields

m_cmbDeductibleType
m_txtDiscountRevenueAfterOneYear
m_txtDiscountRevenueFirstYear
m_txtPercentDeductible
m_txtTargetAmount
m_txtTotalRaised

See Also

FundraisingCampaignsLayout Class | Aptify.Applications.Fundraising Namespace


FundraisingCampaignsLayout.m_cmbDeductibleType Field

public m_cmbDeductibleType m_cmbDeductibleType;

See Also

FundraisingCampaignsLayout Class | Aptify.Applications.Fundraising Namespace


FundraisingCampaignsLayout.m_txtDiscountRevenueAfterOneYear Field

public m_txtDiscountRevenueAfterOneYear m_txtDiscountRevenueAfterOneYear;

See Also

FundraisingCampaignsLayout Class | Aptify.Applications.Fundraising Namespace


FundraisingCampaignsLayout.m_txtDiscountRevenueFirstYear Field

public m_txtDiscountRevenueFirstYear m_txtDiscountRevenueFirstYear;

See Also

FundraisingCampaignsLayout Class | Aptify.Applications.Fundraising Namespace


FundraisingCampaignsLayout.m_txtPercentDeductible Field

public m_txtPercentDeductible m_txtPercentDeductible;

See Also

FundraisingCampaignsLayout Class | Aptify.Applications.Fundraising Namespace


FundraisingCampaignsLayout.m_txtTargetAmount Field

public m_txtTargetAmount m_txtTargetAmount;

See Also

FundraisingCampaignsLayout Class | Aptify.Applications.Fundraising Namespace


FundraisingCampaignsLayout.m_txtTotalRaised Field

public m_txtTotalRaised m_txtTotalRaised;

See Also

FundraisingCampaignsLayout Class | Aptify.Applications.Fundraising Namespace


FundraisingCampaignsLayout Properties

The properties of the FundraisingCampaignsLayout class are listed below. For a complete list of FundraisingCampaignsLayout class members, see the FundraisingCampaignsLayout Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
m_chkTaxDeductible |
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

FundraisingCampaignsLayout Class | Aptify.Applications.Fundraising Namespace


m_chkTaxDeductible Property

Aptify 5.0 Software Development Kit (SDK)

FundraisingCampaignsLayout.m_chkTaxDeductible Property

public virtual AptifyCheckBox m_chkTaxDeductible {get; set;}

See Also

FundraisingCampaignsLayout Class | Aptify.Applications.Fundraising Namespace


FundraisingCampaignsLayout Methods

The methods of the FundraisingCampaignsLayout class are listed below. For a complete list of FundraisingCampaignsLayout class members, see the FundraisingCampaignsLayout Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
ConfigureControlVisibility | Set the visibility of specific controls on the control. This method will be called as the form is loaded either from cache or for the first time as well as from other control events handled.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormTemplateLayout) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControls | Find controls on the layout control and assign them to the class field variables for use.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded (inherited from FormTemplateLayout) | Raises the FormTemplateLoaded event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad | Called when the layout control is called for the first time and loaded into memory
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh | Typically called when loaded from cache.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

FundraisingCampaignsLayout Class | Aptify.Applications.Fundraising Namespace


FundraisingCampaignsLayout.ConfigureControlVisibility Method

Set the visibility of specific controls on the control. This method will be called as the form is loaded either from cache or for the first time as well as from other control events handled.

protected virtual void ConfigureControlVisibility();

Remarks

See Also

FundraisingCampaignsLayout Class | Aptify.Applications.Fundraising Namespace


FundraisingCampaignsLayout.FindControls Method

Find controls on the layout control and assign them to the class field variables for use.

protected virtual void FindControls();

Remarks

See Also

FundraisingCampaignsLayout Class | Aptify.Applications.Fundraising Namespace


FundraisingCampaignsLayout.OnLoad Method

Called when the layout control is called for the first time and loaded into memory

protected override void OnLoad(
EventArgs e
);

Parameters

e

Remarks

See Also

FundraisingCampaignsLayout Class | Aptify.Applications.Fundraising Namespace


FundraisingCampaignsLayout.OnRefresh Method

Typically called when loaded from cache.

protected override void OnRefresh();

Implements

IFormComponent.

Remarks

See Also

FundraisingCampaignsLayout Class | Aptify.Applications.Fundraising Namespace


FundSelectorEventArgs Class

For a list of all members of this type, see FundSelectorEventArgs Members.

System.Object
EventArgs
FundSelectorEventArgs

public class FundSelectorEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Fundraising

Assembly: PledgeLayoutControls (in PledgeLayoutControls.dll)

See Also

FundSelectorEventArgs Members | Aptify.Applications.Fundraising Namespace


FundSelectorEventArgs Members

FundSelectorEventArgs overview

Public Instance Constructors

FundSelectorEventArgs Overloaded. Initializes a new instance of the FundSelectorEventArgs class.

Public Instance Fields

FundProductID
FundProductName
PledgeAmount

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FundSelectorEventArgs Class | Aptify.Applications.Fundraising Namespace


FundSelectorEventArgs Constructor

Default constructor

Overload List

Default constructor

public FundSelectorEventArgs();

public FundSelectorEventArgs(Int64,Decimal,String);

See Also

FundSelectorEventArgs Class | Aptify.Applications.Fundraising Namespace


FundSelectorEventArgs Constructor ()

Default constructor

public FundSelectorEventArgs();

Remarks

See Also

FundSelectorEventArgs Class | Aptify.Applications.Fundraising Namespace | FundSelectorEventArgs Constructor Overload List


FundSelectorEventArgs Constructor (Int64, Decimal, String)

public FundSelectorEventArgs(
Int64 lProductID,
Decimal dAmount,
String sProductName
);

See Also

FundSelectorEventArgs Class | Aptify.Applications.Fundraising Namespace | FundSelectorEventArgs Constructor Overload List


FundSelectorEventArgs Fields

The fields of the FundSelectorEventArgs class are listed below. For a complete list of FundSelectorEventArgs class members, see the FundSelectorEventArgs Members topic.

Public Instance Fields

FundProductID
FundProductName
PledgeAmount

See Also

FundSelectorEventArgs Class | Aptify.Applications.Fundraising Namespace


FundSelectorEventArgs.FundProductID Field

public FundProductID FundProductID;

See Also

FundSelectorEventArgs Class | Aptify.Applications.Fundraising Namespace


FundSelectorEventArgs.FundProductName Field

public FundProductName FundProductName;

See Also

FundSelectorEventArgs Class | Aptify.Applications.Fundraising Namespace


FundSelectorEventArgs.PledgeAmount Field

public PledgeAmount PledgeAmount;

See Also

FundSelectorEventArgs Class | Aptify.Applications.Fundraising Namespace


GrantLayoutControl Class

For a list of all members of this type, see GrantLayoutControl Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
GrantLayoutControl

public class GrantLayoutControl : FormTemplateLayout

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Fundraising

Assembly: GrantLayoutControls (in GrantLayoutControls.dll)

See Also

GrantLayoutControl Members | Aptify.Applications.Fundraising Namespace


GrantLayoutControl Members

GrantLayoutControl overview

Public Instance Constructors

GrantLayoutControl Constructor Default constructor

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

m_cmbPurposeLocation
m_cmbPurposeType
m_cmbStatus
m_lnkCountry
m_lnkDonorSecondContact
m_lnkGranteeCompany
m_lnkGranteeDirect
m_lnkGranteeExec
m_lnkGranteeFinance
m_lnkMainContact
m_lnkManager
m_txtCashValue
m_txtDonorCredit
m_txtFieldOfService
m_txtGrossValue
m_txtPurposeDetail

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
m_aptDataControl |
m_chkIsOrganization |
m_chkMultipleDonors |
m_lnkParentGrant |
m_tabMain |
m_txtDonationsReceived |
m_txtPledges |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
DisableAllTabControls |
DisableControls |
Dispose (inherited from FormTemplateLayout) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControls |
FindDataControl | This method will obtain a reference to the data control of the form template with the IDataControl interface implementation.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTabByName |
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded (inherited from FormTemplateLayout) | Raises the FormTemplateLoaded event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad |
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecalcGrantAgreement |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ReferenceControl |
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetPurposeMode |
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

GrantLayoutControl Class | Aptify.Applications.Fundraising Namespace


GrantLayoutControl Constructor

Default constructor

public GrantLayoutControl();

Remarks

See Also

GrantLayoutControl Class | Aptify.Applications.Fundraising Namespace


GrantLayoutControl Fields

The fields of the GrantLayoutControl class are listed below. For a complete list of GrantLayoutControl class members, see the GrantLayoutControl Members topic.

Protected Instance Fields

m_cmbPurposeLocation
m_cmbPurposeType
m_cmbStatus
m_lnkCountry
m_lnkDonorSecondContact
m_lnkGranteeCompany
m_lnkGranteeDirect
m_lnkGranteeExec
m_lnkGranteeFinance
m_lnkMainContact
m_lnkManager
m_txtCashValue
m_txtDonorCredit
m_txtFieldOfService
m_txtGrossValue
m_txtPurposeDetail

See Also

GrantLayoutControl Class | Aptify.Applications.Fundraising Namespace


GrantLayoutControl.m_cmbPurposeLocation Field

protected m_cmbPurposeLocation m_cmbPurposeLocation;

See Also

GrantLayoutControl Class | Aptify.Applications.Fundraising Namespace


GrantLayoutControl.m_cmbPurposeType Field

protected m_cmbPurposeType m_cmbPurposeType;

See Also

GrantLayoutControl Class | Aptify.Applications.Fundraising Namespace


GrantLayoutControl.m_cmbStatus Field

protected m_cmbStatus m_cmbStatus;

See Also

GrantLayoutControl Class | Aptify.Applications.Fundraising Namespace


GrantLayoutControl.m_lnkCountry Field

protected m_lnkCountry m_lnkCountry;

See Also

GrantLayoutControl Class | Aptify.Applications.Fundraising Namespace


GrantLayoutControl.m_lnkDonorSecondContact Field

protected m_lnkDonorSecondContact m_lnkDonorSecondContact;

See Also

GrantLayoutControl Class | Aptify.Applications.Fundraising Namespace


GrantLayoutControl.m_lnkGranteeCompany Field

protected m_lnkGranteeCompany m_lnkGranteeCompany;

See Also

GrantLayoutControl Class | Aptify.Applications.Fundraising Namespace


GrantLayoutControl.m_lnkGranteeDirect Field

protected m_lnkGranteeDirect m_lnkGranteeDirect;

See Also

GrantLayoutControl Class | Aptify.Applications.Fundraising Namespace


GrantLayoutControl.m_lnkGranteeExec Field

protected m_lnkGranteeExec m_lnkGranteeExec;

See Also

GrantLayoutControl Class | Aptify.Applications.Fundraising Namespace


GrantLayoutControl.m_lnkGranteeFinance Field

protected m_lnkGranteeFinance m_lnkGranteeFinance;

See Also

GrantLayoutControl Class | Aptify.Applications.Fundraising Namespace


GrantLayoutControl.m_lnkMainContact Field

protected m_lnkMainContact m_lnkMainContact;

See Also

GrantLayoutControl Class | Aptify.Applications.Fundraising Namespace


GrantLayoutControl.m_lnkManager Field

protected m_lnkManager m_lnkManager;

See Also

GrantLayoutControl Class | Aptify.Applications.Fundraising Namespace


GrantLayoutControl.m_txtCashValue Field

protected m_txtCashValue m_txtCashValue;

See Also

GrantLayoutControl Class | Aptify.Applications.Fundraising Namespace


GrantLayoutControl.m_txtDonorCredit Field

protected m_txtDonorCredit m_txtDonorCredit;

See Also

GrantLayoutControl Class | Aptify.Applications.Fundraising Namespace


GrantLayoutControl.m_txtFieldOfService Field

protected m_txtFieldOfService m_txtFieldOfService;

See Also

GrantLayoutControl Class | Aptify.Applications.Fundraising Namespace


GrantLayoutControl.m_txtGrossValue Field

protected m_txtGrossValue m_txtGrossValue;

See Also

GrantLayoutControl Class | Aptify.Applications.Fundraising Namespace


GrantLayoutControl.m_txtPurposeDetail Field

protected m_txtPurposeDetail m_txtPurposeDetail;

See Also

GrantLayoutControl Class | Aptify.Applications.Fundraising Namespace


GrantLayoutControl Properties

The properties of the GrantLayoutControl class are listed below. For a complete list of GrantLayoutControl class members, see the GrantLayoutControl Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
m_aptDataControl |
m_chkIsOrganization |
m_chkMultipleDonors |
m_lnkParentGrant |
m_tabMain |
m_txtDonationsReceived |
m_txtPledges |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

GrantLayoutControl Class | Aptify.Applications.Fundraising Namespace


m_aptDataControl Property

Aptify 5.0 Software Development Kit (SDK)

GrantLayoutControl.m_aptDataControl Property

protected virtual IDataControl m_aptDataControl {get; set;}

See Also

GrantLayoutControl Class | Aptify.Applications.Fundraising Namespace


m_chkIsOrganization Property

Aptify 5.0 Software Development Kit (SDK)

GrantLayoutControl.m_chkIsOrganization Property

protected virtual AptifyCheckBox m_chkIsOrganization {get; set;}

See Also

GrantLayoutControl Class | Aptify.Applications.Fundraising Namespace


m_chkMultipleDonors Property

Aptify 5.0 Software Development Kit (SDK)

GrantLayoutControl.m_chkMultipleDonors Property

protected virtual AptifyCheckBox m_chkMultipleDonors {get; set;}

See Also

GrantLayoutControl Class | Aptify.Applications.Fundraising Namespace


m_lnkParentGrant Property

Aptify 5.0 Software Development Kit (SDK)

GrantLayoutControl.m_lnkParentGrant Property

protected virtual AptifyLinkBox m_lnkParentGrant {get; set;}

See Also

GrantLayoutControl Class | Aptify.Applications.Fundraising Namespace


m_tabMain Property

Aptify 5.0 Software Development Kit (SDK)

GrantLayoutControl.m_tabMain Property

protected virtual UltraTabControl m_tabMain {get; set;}

See Also

GrantLayoutControl Class | Aptify.Applications.Fundraising Namespace


m_txtDonationsReceived Property

Aptify 5.0 Software Development Kit (SDK)

GrantLayoutControl.m_txtDonationsReceived Property

protected virtual AptifyTextBox m_txtDonationsReceived {get; set;}

See Also

GrantLayoutControl Class | Aptify.Applications.Fundraising Namespace


m_txtPledges Property

Aptify 5.0 Software Development Kit (SDK)

GrantLayoutControl.m_txtPledges Property

protected virtual AptifyTextBox m_txtPledges {get; set;}

See Also

GrantLayoutControl Class | Aptify.Applications.Fundraising Namespace


GrantLayoutControl Methods

The methods of the GrantLayoutControl class are listed below. For a complete list of GrantLayoutControl class members, see the GrantLayoutControl Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
DisableAllTabControls |
DisableControls |
Dispose (inherited from FormTemplateLayout) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControls |
FindDataControl | This method will obtain a reference to the data control of the form template with the IDataControl interface implementation.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTabByName |
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded (inherited from FormTemplateLayout) | Raises the FormTemplateLoaded event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad |
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecalcGrantAgreement |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ReferenceControl |
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetPurposeMode |
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

GrantLayoutControl Class | Aptify.Applications.Fundraising Namespace


GrantLayoutControl.DisableAllTabControls Method

protected virtual void DisableAllTabControls(
String sTabName,
Boolean bEnable
);

See Also

GrantLayoutControl Class | Aptify.Applications.Fundraising Namespace


GrantLayoutControl.DisableControls Method

protected virtual void DisableControls(
Boolean bEnable
);

See Also

GrantLayoutControl Class | Aptify.Applications.Fundraising Namespace


GrantLayoutControl.FindControls Method

protected virtual void FindControls();

See Also

GrantLayoutControl Class | Aptify.Applications.Fundraising Namespace


GrantLayoutControl.FindDataControl Method

This method will obtain a reference to the data control of the form template with the IDataControl interface implementation.

protected virtual IDataControl FindDataControl(
Control oControl
);

Parameters

oControl

Return Value

Remarks

See Also

GrantLayoutControl Class | Aptify.Applications.Fundraising Namespace


GrantLayoutControl.GetTabByName Method

protected virtual UltraTab GetTabByName(
String sTabName
);

See Also

GrantLayoutControl Class | Aptify.Applications.Fundraising Namespace


GrantLayoutControl.OnLoad Method

protected override void OnLoad(
EventArgs e
);

See Also

GrantLayoutControl Class | Aptify.Applications.Fundraising Namespace


GrantLayoutControl.OnRefresh Method

protected override void OnRefresh();

Implements

IFormComponent.

See Also

GrantLayoutControl Class | Aptify.Applications.Fundraising Namespace


GrantLayoutControl.RecalcGrantAgreement Method

protected virtual void RecalcGrantAgreement();

See Also

GrantLayoutControl Class | Aptify.Applications.Fundraising Namespace


GrantLayoutControl.ReferenceControl Method

protected virtual Control ReferenceControl(
String sPartName,
Control oLocalControl
);

Parameters

sPartName
oLocalControl

Return Value

Remarks

See Also

GrantLayoutControl Class | Aptify.Applications.Fundraising Namespace


GrantLayoutControl.SetPurposeMode Method

protected void SetPurposeMode(
Boolean bEnable
);

See Also

GrantLayoutControl Class | Aptify.Applications.Fundraising Namespace


Grants Class

For a list of all members of this type, see Grants Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
Grants

public class Grants : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Fundraising

Assembly: Grants (in Grants.dll)

See Also

Grants Members | Aptify.Applications.Fundraising Namespace


Grants Members

Grants overview

Public Instance Constructors

Grants Constructor Initializes a new instance of the Grants class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded. This method overrides the Save function. In the method it is determined if the grant is being cancelled. If so then the CancelGrant method is executed.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue |
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
CanCancelGrant | Determines if the Grant can be cancelled
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

Grants Class | Aptify.Applications.Fundraising Namespace


Grants Constructor

Initializes a new instance of the Grants class.

public Grants();

See Also

Grants Class | Aptify.Applications.Fundraising Namespace


Grants Methods

The methods of the Grants class are listed below. For a complete list of Grants class members, see the Grants Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded. This method overrides the Save function. In the method it is determined if the grant is being cancelled. If so then the CancelGrant method is executed.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue |
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
CanCancelGrant | Determines if the Grant can be cancelled
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

Grants Class | Aptify.Applications.Fundraising Namespace


Grants.CanCancelGrant Method

Determines if the Grant can be cancelled

protected virtual bool CanCancelGrant(
Int64 lGrantID,
ref String& sMessage
);

Parameters

lGrantID
sMessage

Return Value

Remarks

See Also

Grants Class | Aptify.Applications.Fundraising Namespace


Save Method

Aptify 5.0 Software Development Kit (SDK)

Grants.Save Method

This method overrides the Save function. In the method it is determined if the grant is being cancelled. If so then the CancelGrant method is executed.

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Save();

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean,ref String&);

This method overrides the Save function. In the method it is determined if the grant is being cancelled. If so then the CancelGrant method is executed.

public override bool Save(Boolean,ref String&,String);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(ref String&);

See Also

Grants Class | Aptify.Applications.Fundraising Namespace


Grants.Save Method (Boolean, String&, String)

This method overrides the Save function. In the method it is determined if the grant is being cancelled. If so then the CancelGrant method is executed.

public override bool Save(
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

Parameters

AllowGUI
ErrorString
TransactionID

Return Value

Remarks

See Also

Grants Class | Aptify.Applications.Fundraising Namespace | Grants.Save Overload List


Grants.SetValue Method

public override void SetValue(
String FieldName,
Object Value
);

See Also

Grants Class | Aptify.Applications.Fundraising Namespace


GroupControl Structure

For a list of all members of this type, see GroupControl Members.

System.Object
ValueType
GroupControl

public struct GroupControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Fundraising

Assembly: PledgeLayoutControls (in PledgeLayoutControls.dll)

See Also

GroupControl Members | Aptify.Applications.Fundraising Namespace


GroupControl Members

GroupControl overview

Public Instance Constructors

GroupControl Constructor

Public Instance Fields

Control
IsAnchor
Location

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

GroupControl Structure | Aptify.Applications.Fundraising Namespace


GroupControl Constructor

public GroupControl(
Control oControl,
Boolean bIsAnchor,
Point pLocation
);

See Also

GroupControl Structure | Aptify.Applications.Fundraising Namespace


GroupControl Fields

The fields of the GroupControl structure are listed below. For a complete list of GroupControl structure members, see the GroupControl Members topic.

Public Instance Fields

Control
IsAnchor
Location

See Also

GroupControl Structure | Aptify.Applications.Fundraising Namespace


GroupControl.Control Field

public Control Control;

See Also

GroupControl Class | Aptify.Applications.Fundraising Namespace


GroupControl.IsAnchor Field

public IsAnchor IsAnchor;

See Also

GroupControl Class | Aptify.Applications.Fundraising Namespace


GroupControl.Location Field

public Location Location;

See Also

GroupControl Class | Aptify.Applications.Fundraising Namespace


Pledge Class

This class provides the implementation for business logic for the Pledges entity in the Aptify Fundraising Management system.

For a list of all members of this type, see Pledge Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
Pledge

public class Pledge : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Fundraising

Assembly: Pledge (in Pledge.dll)

See Also

Pledge Members | Aptify.Applications.Fundraising Namespace


Pledge Members

Pledge overview

Public Instance Constructors

Pledge Constructor Initializes a new instance of the Pledge class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CancelPledge |
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config | Overloaded.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
CreatePaymentSchedule | This method validates if the payment schedule can be created for the pledge based on the PledgeReceivedDate, StartDate, Amount, and NumberOfPayments fields in the PledgeObject providing non-blank values. If all of these fields are provided, the DoCreatePaymentSchedule() method is called from within the CreatePaymentSchedule() method.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetBaseStageFromID | This method returns the base stage(Verbal, Written) for the given Pledge Stage
GetCampaignDiscountRule | This method returns discount rule information to the calling function about the Fundraising Campaign setup. The information returned is provided for the specified Fundraising Campaign ID (or for the current Fundraising Campaign ID ) if the FundraisingCampaignID is not specified. If this method fails to find information regarding the FundraisingCampaignID it returns the value of Nothing
GetCreditMemoPaymentTypeID | This method returns the lowest Payment Type that has a Base Type (PaymentTypes.Type) of Credit Memo
GetCurrentEmployeeID | This method is responsible for returning the ID from the Employees entity that matches the currently logged in user. This method uses the User Related Entity records functionalty (available in vwUserEntityRelations view) in the Aptify framework to determine if the currently logged-in user has an Employee record attached to it. The method calls the spGetCurrentEmployeeID stored procedure in the database which in turn utilizes the aforementioned meta-data accordingly. If no employee record is found to match the currently logged in user, the value of -1 is returned.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDefaultShipTypeID | This method returns the default Ship Type based on the lowest ID value in the Ship Types entity.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetOrderBalance | This method returns the current balance for a given Order ID
GetOrderPaymentTotal | This method returns the total amount of all payments applied to a given Order ID
GetOrderTotal | This method returns the grand total for a given Order ID
GetOrderTypeIDByName | This method returns the lowest Order Type that has a Name matching the OrderTypeName parameter.
GetPOPaymentTypeID | This method returns the lowest Payment Type that has a Base Type (PaymentTypes.Type) of Purchase Order
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. This method overrides the standard GE class GetValue() method and automatically will recalculate the value of the Amount field whenever Amount is requested from this object. If a pledge has the PledgeType field set to Cash, this functionality utilizes the PledgeFunds sub-type to determine the total amount of the pledge. For any other Pledge types, the value stored in the Amount field in the Pledges entity is directly returned using the base class GetValue() method.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
GetWriteOffPaymentTypeID | This method returns the lowest Payment Type that has a Name that contains the phrase 'Bad Debt'
GetWriteOffPaymentTypeInfo | This method returns payment type information for the Write-Off Payment Type based on the write-off payment type ID. If WriteOffPaymentTypeID is not provided, the lowest ID for a payment type that has a name containing the phrase 'Bad Debt' is returned.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
PopulateGivingCategory | This method populates the "GivingCategory" field in the pledge based upon the amount of the pledge and on the campaign's giving category specifications in the vwFundCampaignGivings view (and related sub-type).
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded. This method overrides the base GE Save so that it may also handle other aspects of saving a pledge such as creating an order, cancellation or other record(s) as required during the save process. At various points throughout the pledge save process, the StatusUpdate() event is raised to provide feedback to the calling object/application which also has the ability to cancel the pledge saving process if needed.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue |
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded. This method overrides the base GE functionality for validation to validate pledge-specific business rules including the validation of In Kind Gifts.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.
WriteOffPledge |

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
StatusUpdate | The event is raised to give a feedback to the user of this object on when internal processes are oCDecing so that status can be provided to the user or logged, if desired. Additionally, whenever this event is raised, the object receiving the event can cancel the process by setting the Cancel parameter to True. This event replaces the Processing event that existed in prior versions of this object (3.x and prior versions)
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
Database |
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
CancelWriteOffPledge | This function will either cancel or write off a pledge. The only difference between doing a cancellation and a write-off is that a cancellation creates a cancellation order and a write-off creates a write-off payment. Other than that, the rest of the process is the same.
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecognitionScheduledTransactions | The purpose of this routine is to create a scheduled transaction stream that recognizes the portion of the revenue that was initially discounted at the time of the pledge, at each expected time of receipt of that payment. So, this method will iterate through all of the PledgePayment records, and for each item, recognize the amount of revenue initially allocated towards UNEARNED, by proportionate share of fund/pledge_amt.
CreateRecord (inherited from AptifyGenericEntity) |
CreateReversalScheduledTransactions | This routine will create the scheduled transaction that will reverse out the the entire amount of the pledge that was discounted. 1. Calculate Total Discount Amount TOTAL_DISCOUNT = PLEDGE_AMT - PLEDGE_PRESENTVALUE 2. Calculate the percent of the TOTAL_DISCOUNT to allocate to each fund with the following formula FUND_DISCOUNT = (FUND_AMT / PLEDGE_AMT) * TOTAL_DISCOUNT Make sure that all FUND_DISCOUNTS add up to TOTAL_DISCOUNT 3. Create a single scheduled transaction record, link it to the order 3.1. For each Fund Discount in Step 2, create a DEBIT/CREDIT pair to reverse out the recognition of the sales for all of the discounted amounts. ACCOUNT DEBIT CREDIT ---------------------------------------------------- SALES FUND_DISCOUNT UNEARNED_INCOME FUND_DISCOUNT The net effect of the above scheduled transaction will be to reverse out the recognition of revenue of the DISCOUNTED portion of the pledge
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
DoCancelPledge | This method is responsible for creating a pledge cancellation and creates a cancellation order. If the RefundPaidAmounts parameter is set to True, amounts already paid under the pledge will be refunded. If this parameter is set to False, amounts already paid under the pledge will NOT be refunded, but the remaining balance of the pledge will be cancelled.
DoCreatePayment | This method is responsible for populating a new Aptify GE object for the payments entity based on the information provided to this method. This method does NOT call the Save() method of the Payment GE object that it returns so calling functions must handle calling Save() after the method returns the GE object and they perform any additional setup on the Payment GE.
DoCreatePaymentSchedule | This method is called from the CreatePaymentSchedule() method when a pledge has the required information needed to create a payment schedule. This method will clear out any entries in the PledgePaymentSchedule sub-type before creating the new entries.
DoWriteOffPledge | This method is responsible for handling the write-off for a pledge
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
GetGiftInKindValue |
GetOrderDecimalField | This method returns a given field value from a specified Order ID in the database. This method always returns the most current data from the database bypassing the Aptify Data Cache.
GetProductGLAccount | This method returns the specified account for a given Product ID
GetProductRevenueAcct | This method returns the Sales account for a given Product ID
GetProductUnearnedAcct | This method returns the Unearned Revenue account for a given Product ID
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
InternalSave | This method is called from the overriden base Save() method and implements the creation of an order record when necessary based on the setup of the Pledge.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecalculateAmount | This method recalculates the value of the Amount field of the Pledge by summing the entire amount of the PledgeFunds sub-type and placing the value in the Amount field.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
ReverseOriginalOrderScheduledTransactions | This method reverses any scheduled transactions that were created by an original order in the pledge during the process of cancellation order creation.
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SaveOrder | This function saves the order to the database. It is only called when the order record needs to be created ( when the Stage changes from 'Verbal' to 'Written' and the PledgeType='Cash' Steps to create order 1) Create Order Object 2) Setup Order Header (Ship To,Bill To, Address Information, Etc.) 3) Setup Order Detail - one line for donation product 4) Setup Payment Schedule - copy pmt schedule from PledgePmtSchedule 5) Save()
SaveScheduledTransactions | This method is responsible for saving scheduled transactions associated with the pledge. This method is called from the SaveOrder() method when required. The base class implementation of this method calls the CreateReversalScheduledTransactions() method and if that is succesful, CreateRecognitionScheduledTransactions() is called.
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupOrderDetail | This method is responsible for creating OrderLines in the provided order object for each item in the PledgeFunds sub-type.
SetupOrderHeader | This method is responsible for setting up the top-level entity data for an order for the pledge object. The IsCancellation parameter specifies if this order header is being created for a pledge cancellation or for a regular order.
SetupPaymentSchedule | This method creates order payment schedule records based on the pledge payment schedule
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateContributionInfo | This method is responsible for validating the contributor data. The base class implements logic that checks the IsCorporate BIT field. If IsCorporate is set to 1, the CompanyID field AND the ContactID fields must both be filled in. If IsCorporate is set to 0, the ContributorID field (link to Persons entity) is required.
ValidateInKindGift | This method will validate the in-kind gift attributes of the pledge. If the pledge type is not set to an in-kind gift, this method will return a value of Nothing. If this pledge type is an in-kind gift, the system will make sure there are no other pledges that are also using the same GiftInKindID that is provided in this pledge.
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

Pledge Class | Aptify.Applications.Fundraising Namespace


Pledge Constructor

Initializes a new instance of the Pledge class.

public Pledge();

See Also

Pledge Class | Aptify.Applications.Fundraising Namespace


Pledge Properties

The properties of the Pledge class are listed below. For a complete list of Pledge class members, see the Pledge Members topic.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
Database |
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

Pledge Class | Aptify.Applications.Fundraising Namespace


Database Property

Aptify 5.0 Software Development Kit (SDK)

Pledge.Database Property

protected virtual String Database {get;}

See Also

Pledge Class | Aptify.Applications.Fundraising Namespace


Pledge Methods

The methods of the Pledge class are listed below. For a complete list of Pledge class members, see the Pledge Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CancelPledge |
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config | Overloaded.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
CreatePaymentSchedule | This method validates if the payment schedule can be created for the pledge based on the PledgeReceivedDate, StartDate, Amount, and NumberOfPayments fields in the PledgeObject providing non-blank values. If all of these fields are provided, the DoCreatePaymentSchedule() method is called from within the CreatePaymentSchedule() method.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetBaseStageFromID | This method returns the base stage(Verbal, Written) for the given Pledge Stage
GetCampaignDiscountRule | This method returns discount rule information to the calling function about the Fundraising Campaign setup. The information returned is provided for the specified Fundraising Campaign ID (or for the current Fundraising Campaign ID ) if the FundraisingCampaignID is not specified. If this method fails to find information regarding the FundraisingCampaignID it returns the value of Nothing
GetCreditMemoPaymentTypeID | This method returns the lowest Payment Type that has a Base Type (PaymentTypes.Type) of Credit Memo
GetCurrentEmployeeID | This method is responsible for returning the ID from the Employees entity that matches the currently logged in user. This method uses the User Related Entity records functionalty (available in vwUserEntityRelations view) in the Aptify framework to determine if the currently logged-in user has an Employee record attached to it. The method calls the spGetCurrentEmployeeID stored procedure in the database which in turn utilizes the aforementioned meta-data accordingly. If no employee record is found to match the currently logged in user, the value of -1 is returned.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDefaultShipTypeID | This method returns the default Ship Type based on the lowest ID value in the Ship Types entity.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetOrderBalance | This method returns the current balance for a given Order ID
GetOrderPaymentTotal | This method returns the total amount of all payments applied to a given Order ID
GetOrderTotal | This method returns the grand total for a given Order ID
GetOrderTypeIDByName | This method returns the lowest Order Type that has a Name matching the OrderTypeName parameter.
GetPOPaymentTypeID | This method returns the lowest Payment Type that has a Base Type (PaymentTypes.Type) of Purchase Order
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. This method overrides the standard GE class GetValue() method and automatically will recalculate the value of the Amount field whenever Amount is requested from this object. If a pledge has the PledgeType field set to Cash, this functionality utilizes the PledgeFunds sub-type to determine the total amount of the pledge. For any other Pledge types, the value stored in the Amount field in the Pledges entity is directly returned using the base class GetValue() method.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
GetWriteOffPaymentTypeID | This method returns the lowest Payment Type that has a Name that contains the phrase 'Bad Debt'
GetWriteOffPaymentTypeInfo | This method returns payment type information for the Write-Off Payment Type based on the write-off payment type ID. If WriteOffPaymentTypeID is not provided, the lowest ID for a payment type that has a name containing the phrase 'Bad Debt' is returned.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
PopulateGivingCategory | This method populates the "GivingCategory" field in the pledge based upon the amount of the pledge and on the campaign's giving category specifications in the vwFundCampaignGivings view (and related sub-type).
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded. This method overrides the base GE Save so that it may also handle other aspects of saving a pledge such as creating an order, cancellation or other record(s) as required during the save process. At various points throughout the pledge save process, the StatusUpdate() event is raised to provide feedback to the calling object/application which also has the ability to cancel the pledge saving process if needed.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue |
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded. This method overrides the base GE functionality for validation to validate pledge-specific business rules including the validation of In Kind Gifts.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.
WriteOffPledge |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
CancelWriteOffPledge | This function will either cancel or write off a pledge. The only difference between doing a cancellation and a write-off is that a cancellation creates a cancellation order and a write-off creates a write-off payment. Other than that, the rest of the process is the same.
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecognitionScheduledTransactions | The purpose of this routine is to create a scheduled transaction stream that recognizes the portion of the revenue that was initially discounted at the time of the pledge, at each expected time of receipt of that payment. So, this method will iterate through all of the PledgePayment records, and for each item, recognize the amount of revenue initially allocated towards UNEARNED, by proportionate share of fund/pledge_amt.
CreateRecord (inherited from AptifyGenericEntity) |
CreateReversalScheduledTransactions | This routine will create the scheduled transaction that will reverse out the the entire amount of the pledge that was discounted. 1. Calculate Total Discount Amount TOTAL_DISCOUNT = PLEDGE_AMT - PLEDGE_PRESENTVALUE 2. Calculate the percent of the TOTAL_DISCOUNT to allocate to each fund with the following formula FUND_DISCOUNT = (FUND_AMT / PLEDGE_AMT) * TOTAL_DISCOUNT Make sure that all FUND_DISCOUNTS add up to TOTAL_DISCOUNT 3. Create a single scheduled transaction record, link it to the order 3.1. For each Fund Discount in Step 2, create a DEBIT/CREDIT pair to reverse out the recognition of the sales for all of the discounted amounts. ACCOUNT DEBIT CREDIT ---------------------------------------------------- SALES FUND_DISCOUNT UNEARNED_INCOME FUND_DISCOUNT The net effect of the above scheduled transaction will be to reverse out the recognition of revenue of the DISCOUNTED portion of the pledge
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
DoCancelPledge | This method is responsible for creating a pledge cancellation and creates a cancellation order. If the RefundPaidAmounts parameter is set to True, amounts already paid under the pledge will be refunded. If this parameter is set to False, amounts already paid under the pledge will NOT be refunded, but the remaining balance of the pledge will be cancelled.
DoCreatePayment | This method is responsible for populating a new Aptify GE object for the payments entity based on the information provided to this method. This method does NOT call the Save() method of the Payment GE object that it returns so calling functions must handle calling Save() after the method returns the GE object and they perform any additional setup on the Payment GE.
DoCreatePaymentSchedule | This method is called from the CreatePaymentSchedule() method when a pledge has the required information needed to create a payment schedule. This method will clear out any entries in the PledgePaymentSchedule sub-type before creating the new entries.
DoWriteOffPledge | This method is responsible for handling the write-off for a pledge
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
GetGiftInKindValue |
GetOrderDecimalField | This method returns a given field value from a specified Order ID in the database. This method always returns the most current data from the database bypassing the Aptify Data Cache.
GetProductGLAccount | This method returns the specified account for a given Product ID
GetProductRevenueAcct | This method returns the Sales account for a given Product ID
GetProductUnearnedAcct | This method returns the Unearned Revenue account for a given Product ID
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
InternalSave | This method is called from the overriden base Save() method and implements the creation of an order record when necessary based on the setup of the Pledge.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecalculateAmount | This method recalculates the value of the Amount field of the Pledge by summing the entire amount of the PledgeFunds sub-type and placing the value in the Amount field.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
ReverseOriginalOrderScheduledTransactions | This method reverses any scheduled transactions that were created by an original order in the pledge during the process of cancellation order creation.
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SaveOrder | This function saves the order to the database. It is only called when the order record needs to be created ( when the Stage changes from 'Verbal' to 'Written' and the PledgeType='Cash' Steps to create order 1) Create Order Object 2) Setup Order Header (Ship To,Bill To, Address Information, Etc.) 3) Setup Order Detail - one line for donation product 4) Setup Payment Schedule - copy pmt schedule from PledgePmtSchedule 5) Save()
SaveScheduledTransactions | This method is responsible for saving scheduled transactions associated with the pledge. This method is called from the SaveOrder() method when required. The base class implementation of this method calls the CreateReversalScheduledTransactions() method and if that is succesful, CreateRecognitionScheduledTransactions() is called.
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupOrderDetail | This method is responsible for creating OrderLines in the provided order object for each item in the PledgeFunds sub-type.
SetupOrderHeader | This method is responsible for setting up the top-level entity data for an order for the pledge object. The IsCancellation parameter specifies if this order header is being created for a pledge cancellation or for a regular order.
SetupPaymentSchedule | This method creates order payment schedule records based on the pledge payment schedule
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateContributionInfo | This method is responsible for validating the contributor data. The base class implements logic that checks the IsCorporate BIT field. If IsCorporate is set to 1, the CompanyID field AND the ContactID fields must both be filled in. If IsCorporate is set to 0, the ContributorID field (link to Persons entity) is required.
ValidateInKindGift | This method will validate the in-kind gift attributes of the pledge. If the pledge type is not set to an in-kind gift, this method will return a value of Nothing. If this pledge type is an in-kind gift, the system will make sure there are no other pledges that are also using the same GiftInKindID that is provided in this pledge.
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

Pledge Class | Aptify.Applications.Fundraising Namespace


Pledge.CancelPledge Method

public virtual bool CancelPledge(
Boolean AllowGUI,
DateTime EffectiveDate,
Boolean RefundPaidAmounts
);

See Also

Pledge Class | Aptify.Applications.Fundraising Namespace


Pledge.CancelWriteOffPledge Method

This function will either cancel or write off a pledge. The only difference between doing a cancellation and a write-off is that a cancellation creates a cancellation order and a write-off creates a write-off payment. Other than that, the rest of the process is the same.

protected virtual bool CancelWriteOffPledge(
Boolean AllowGUI,
Boolean DoWriteOff,
Boolean RefundPaidAmounts,
DateTime EffectiveDate,
Int64 WriteOffPaymentTypeID
);

Parameters

AllowGUI
DoWriteOff
RefundPaidAmounts
EffectiveDate
WriteOffPaymentTypeID

Return Value

Remarks

See Also

Pledge Class | Aptify.Applications.Fundraising Namespace


Config Method

Aptify 5.0 Software Development Kit (SDK)

Pledge.Config Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual void Config(AptifySubTypeBase);

Inherited from AptifyGenericEntity.

public override void Config(AptifySubTypeBase,Int64);

Inherited from AptifyGenericEntityBase.

public virtual void Config(UserCredentials,String);

public override void Config(UserCredentials,String,Int64);

See Also

Pledge Class | Aptify.Applications.Fundraising Namespace


Pledge.Config Method (UserCredentials, String, Int64)

public override void Config(
UserCredentials UserCredentials,
String EntityName,
Int64 RecordID
);

See Also

Pledge Class | Aptify.Applications.Fundraising Namespace | Pledge.Config Overload List


Pledge.CreatePaymentSchedule Method

This method validates if the payment schedule can be created for the pledge based on the PledgeReceivedDate, StartDate, Amount, and NumberOfPayments fields in the PledgeObject providing non-blank values. If all of these fields are provided, the DoCreatePaymentSchedule() method is called from within the CreatePaymentSchedule() method.

public bool CreatePaymentSchedule(
Boolean AllowGUI
);

Parameters

AllowGUI

Return Value

Remarks

See Also

Pledge Class | Aptify.Applications.Fundraising Namespace


Pledge.CreateRecognitionScheduledTransactions Method

The purpose of this routine is to create a scheduled transaction stream that recognizes the portion of the revenue that was initially discounted at the time of the pledge, at each expected time of receipt of that payment. So, this method will iterate through all of the PledgePayment records, and for each item, recognize the amount of revenue initially allocated towards UNEARNED, by proportionate share of fund/pledge_amt.

protected virtual bool CreateRecognitionScheduledTransactions(
Boolean AllowGUI,
Int64 OrderID
);

Parameters

AllowGUI
OrderID

Return Value

Remarks

See Also

Pledge Class | Aptify.Applications.Fundraising Namespace


Pledge.CreateReversalScheduledTransactions Method

This routine will create the scheduled transaction that will reverse out the the entire amount of the pledge that was discounted. 1. Calculate Total Discount Amount TOTAL_DISCOUNT = PLEDGE_AMT - PLEDGE_PRESENTVALUE 2. Calculate the percent of the TOTAL_DISCOUNT to allocate to each fund with the following formula FUND_DISCOUNT = (FUND_AMT / PLEDGE_AMT) * TOTAL_DISCOUNT Make sure that all FUND_DISCOUNTS add up to TOTAL_DISCOUNT 3. Create a single scheduled transaction record, link it to the order 3.1. For each Fund Discount in Step 2, create a DEBIT/CREDIT pair to reverse out the recognition of the sales for all of the discounted amounts. ACCOUNT DEBIT CREDIT ---------------------------------------------------- SALES FUND_DISCOUNT UNEARNED_INCOME FUND_DISCOUNT The net effect of the above scheduled transaction will be to reverse out the recognition of revenue of the DISCOUNTED portion of the pledge

protected virtual bool CreateReversalScheduledTransactions(
Boolean AllowGUI,
Int64 OrderID
);

Parameters

AllowGUI
OrderID

Return Value

Remarks

See Also

Pledge Class | Aptify.Applications.Fundraising Namespace


Pledge.DoCancelPledge Method

This method is responsible for creating a pledge cancellation and creates a cancellation order. If the RefundPaidAmounts parameter is set to True, amounts already paid under the pledge will be refunded. If this parameter is set to False, amounts already paid under the pledge will NOT be refunded, but the remaining balance of the pledge will be cancelled.

protected virtual bool DoCancelPledge(
Boolean AllowGUI,
Boolean RefundPaidAmounts,
DateTime CancellationDate
);

Parameters

AllowGUI
RefundPaidAmounts
CancellationDate

Return Value

Remarks

See Also

Pledge Class | Aptify.Applications.Fundraising Namespace


Pledge.DoCreatePayment Method

This method is responsible for populating a new Aptify GE object for the payments entity based on the information provided to this method. This method does NOT call the Save() method of the Payment GE object that it returns so calling functions must handle calling Save() after the method returns the GE object and they perform any additional setup on the Payment GE.

protected virtual AptifyGenericEntityBase DoCreatePayment(
Boolean AllowGUI,
Int64 PaymentTypeID,
Boolean IsRefund,
DateTime EffectiveDate,
Decimal Amount,
String Comments
);

Parameters

AllowGUI
PaymentTypeID
IsRefund
EffectiveDate
Amount
Comments

Return Value

Remarks

See Also

Pledge Class | Aptify.Applications.Fundraising Namespace


Pledge.DoCreatePaymentSchedule Method

This method is called from the CreatePaymentSchedule() method when a pledge has the required information needed to create a payment schedule. This method will clear out any entries in the PledgePaymentSchedule sub-type before creating the new entries.

protected virtual bool DoCreatePaymentSchedule();

Return Value

Remarks

See Also

Pledge Class | Aptify.Applications.Fundraising Namespace


Pledge.DoWriteOffPledge Method

This method is responsible for handling the write-off for a pledge

protected virtual bool DoWriteOffPledge(
Boolean AllowGUI,
Int64 WriteOffPaymentTypeID,
DateTime EffectiveDate
);

Parameters

AllowGUI
WriteOffPaymentTypeID
EffectiveDate

Return Value

Remarks

See Also

Pledge Class | Aptify.Applications.Fundraising Namespace


Pledge.GetBaseStageFromID Method

This method returns the base stage(Verbal, Written) for the given Pledge Stage

public string GetBaseStageFromID(
Int64 lID
);

Parameters

lID

Return Value

Remarks

See Also

Pledge Class | Aptify.Applications.Fundraising Namespace


Pledge.GetCampaignDiscountRule Method

This method returns discount rule information to the calling function about the Fundraising Campaign setup. The information returned is provided for the specified Fundraising Campaign ID (or for the current Fundraising Campaign ID ) if the FundraisingCampaignID is not specified. If this method fails to find information regarding the FundraisingCampaignID it returns the value of Nothing

public FundraisingCampaignDiscountRule GetCampaignDiscountRule(
Int64 FundraisingCampaignID
);

Parameters

FundraisingCampaignID
Optional Parameter - Fundraising Campaigns.ID value. If not provided, the current CampaignID in the pledge will be used

Return Value

Remarks

See Also

Pledge Class | Aptify.Applications.Fundraising Namespace


Pledge.GetCreditMemoPaymentTypeID Method

This method returns the lowest Payment Type that has a Base Type (PaymentTypes.Type) of Credit Memo

public virtual long GetCreditMemoPaymentTypeID();

Return Value

Remarks

See Also

Pledge Class | Aptify.Applications.Fundraising Namespace


Pledge.GetCurrentEmployeeID Method

This method is responsible for returning the ID from the Employees entity that matches the currently logged in user. This method uses the User Related Entity records functionalty (available in vwUserEntityRelations view) in the Aptify framework to determine if the currently logged-in user has an Employee record attached to it. The method calls the spGetCurrentEmployeeID stored procedure in the database which in turn utilizes the aforementioned meta-data accordingly. If no employee record is found to match the currently logged in user, the value of -1 is returned.

public virtual long GetCurrentEmployeeID();

Return Value

Remarks

See Also

Pledge Class | Aptify.Applications.Fundraising Namespace


Pledge.GetDefaultShipTypeID Method

This method returns the default Ship Type based on the lowest ID value in the Ship Types entity.

public virtual long GetDefaultShipTypeID();

Return Value

Remarks

See Also

Pledge Class | Aptify.Applications.Fundraising Namespace


Pledge.GetGiftInKindValue Method

protected virtual decimal GetGiftInKindValue(
Int64 lGiftInKindID
);

See Also

Pledge Class | Aptify.Applications.Fundraising Namespace


Pledge.GetOrderBalance Method

This method returns the current balance for a given Order ID

public virtual decimal GetOrderBalance(
Int64 OrderID
);

Parameters

OrderID

Return Value

Remarks

See Also

Pledge Class | Aptify.Applications.Fundraising Namespace


Pledge.GetOrderDecimalField Method

This method returns a given field value from a specified Order ID in the database. This method always returns the most current data from the database bypassing the Aptify Data Cache.

protected virtual decimal GetOrderDecimalField(
String FieldName,
Int64 OrderID
);

Return Value

Remarks

See Also

Pledge Class | Aptify.Applications.Fundraising Namespace


Pledge.GetOrderPaymentTotal Method

This method returns the total amount of all payments applied to a given Order ID

public virtual decimal GetOrderPaymentTotal(
Int64 OrderID
);

Parameters

OrderID

Return Value

Remarks

See Also

Pledge Class | Aptify.Applications.Fundraising Namespace


Pledge.GetOrderTotal Method

This method returns the grand total for a given Order ID

public virtual decimal GetOrderTotal(
Int64 OrderID
);

Parameters

OrderID

Return Value

Remarks

See Also

Pledge Class | Aptify.Applications.Fundraising Namespace


Pledge.GetOrderTypeIDByName Method

This method returns the lowest Order Type that has a Name matching the OrderTypeName parameter.

public virtual long GetOrderTypeIDByName(
String OrderTypeName
);

Parameters

OrderTypeName

Return Value

Remarks

See Also

Pledge Class | Aptify.Applications.Fundraising Namespace


Pledge.GetPOPaymentTypeID Method

This method returns the lowest Payment Type that has a Base Type (PaymentTypes.Type) of Purchase Order

public virtual long GetPOPaymentTypeID();

Return Value

Remarks

See Also

Pledge Class | Aptify.Applications.Fundraising Namespace


Pledge.GetProductGLAccount Method

This method returns the specified account for a given Product ID

protected virtual string GetProductGLAccount(
String AccountType,
Int64 ProductID
);

Parameters

AccountType
ProductID

Return Value

Remarks

See Also

Pledge Class | Aptify.Applications.Fundraising Namespace


Pledge.GetProductRevenueAcct Method

This method returns the Sales account for a given Product ID

protected virtual string GetProductRevenueAcct(
Int64 ProductID
);

Parameters

ProductID

Return Value

Remarks

See Also

Pledge Class | Aptify.Applications.Fundraising Namespace


Pledge.GetProductUnearnedAcct Method

This method returns the Unearned Revenue account for a given Product ID

protected virtual string GetProductUnearnedAcct(
Int64 ProductID
);

Parameters

ProductID

Return Value

Remarks

See Also

Pledge Class | Aptify.Applications.Fundraising Namespace


GetValue Method

Aptify 5.0 Software Development Kit (SDK)

Pledge.GetValue Method

This method overrides the standard GE class GetValue() method and automatically will recalculate the value of the Amount field whenever Amount is requested from this object. If a pledge has the PledgeType field set to Cash, this functionality utilizes the PledgeFunds sub-type to determine the total amount of the pledge. For any other Pledge types, the value stored in the Amount field in the Pledges entity is directly returned using the base class GetValue() method.

Overload List

This method overrides the standard GE class GetValue() method and automatically will recalculate the value of the Amount field whenever Amount is requested from this object. If a pledge has the PledgeType field set to Cash, this functionality utilizes the PledgeFunds sub-type to determine the total amount of the pledge. For any other Pledge types, the value stored in the Amount field in the Pledges entity is directly returned using the base class GetValue() method.

public override object GetValue(String);

Inherited from AptifyGenericEntityBase.

public virtual object GetValue(String,Boolean);

See Also

Pledge Class | Aptify.Applications.Fundraising Namespace


Pledge.GetValue Method (String)

This method overrides the standard GE class GetValue() method and automatically will recalculate the value of the Amount field whenever Amount is requested from this object. If a pledge has the PledgeType field set to Cash, this functionality utilizes the PledgeFunds sub-type to determine the total amount of the pledge. For any other Pledge types, the value stored in the Amount field in the Pledges entity is directly returned using the base class GetValue() method.

public override object GetValue(
String FieldName
);

Parameters

FieldName

Return Value

Remarks

See Also

Pledge Class | Aptify.Applications.Fundraising Namespace | Pledge.GetValue Overload List


Pledge.GetWriteOffPaymentTypeID Method

This method returns the lowest Payment Type that has a Name that contains the phrase 'Bad Debt'

public virtual long GetWriteOffPaymentTypeID();

Return Value

Remarks

See Also

Pledge Class | Aptify.Applications.Fundraising Namespace


Pledge.GetWriteOffPaymentTypeInfo Method

This method returns payment type information for the Write-Off Payment Type based on the write-off payment type ID. If WriteOffPaymentTypeID is not provided, the lowest ID for a payment type that has a name containing the phrase 'Bad Debt' is returned.

public virtual PaymentTypeInfo GetWriteOffPaymentTypeInfo(
Int64 WriteOffPaymentTypeID
);

Parameters

WriteOffPaymentTypeID

Return Value

Remarks

See Also

Pledge Class | Aptify.Applications.Fundraising Namespace


Pledge.InternalSave Method

This method is called from the overriden base Save() method and implements the creation of an order record when necessary based on the setup of the Pledge.

protected virtual bool InternalSave(
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID,
ref PledgeTransactionOperation& PledgeOperation
);

Parameters

AllowGUI
ErrorString
TransactionID
PledgeOperation

Return Value

Remarks

See Also

Pledge Class | Aptify.Applications.Fundraising Namespace


Pledge.PopulateGivingCategory Method

This method populates the "GivingCategory" field in the pledge based upon the amount of the pledge and on the campaign's giving category specifications in the vwFundCampaignGivings view (and related sub-type).

public virtual bool PopulateGivingCategory();

Return Value

Remarks

See Also

Pledge Class | Aptify.Applications.Fundraising Namespace


Pledge.RecalculateAmount Method

This method recalculates the value of the Amount field of the Pledge by summing the entire amount of the PledgeFunds sub-type and placing the value in the Amount field.

protected virtual void RecalculateAmount();

Remarks

See Also

Pledge Class | Aptify.Applications.Fundraising Namespace


Pledge.ReverseOriginalOrderScheduledTransactions Method

This method reverses any scheduled transactions that were created by an original order in the pledge during the process of cancellation order creation.

protected virtual bool ReverseOriginalOrderScheduledTransactions(
Boolean AllowGUI,
Int64 OrderID,
Decimal AmountReversed,
DateTime EffectiveDate
);

Parameters

AllowGUI
OrderID
AmountReversed
EffectiveDate

Return Value

Remarks

See Also

Pledge Class | Aptify.Applications.Fundraising Namespace


Save Method

Aptify 5.0 Software Development Kit (SDK)

Pledge.Save Method

This method overrides the base GE Save so that it may also handle other aspects of saving a pledge such as creating an order, cancellation or other record(s) as required during the save process. At various points throughout the pledge save process, the StatusUpdate() event is raised to provide feedback to the calling object/application which also has the ability to cancel the pledge saving process if needed.

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Save();

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean,ref String&);

This method overrides the base GE Save so that it may also handle other aspects of saving a pledge such as creating an order, cancellation or other record(s) as required during the save process. At various points throughout the pledge save process, the StatusUpdate() event is raised to provide feedback to the calling object/application which also has the ability to cancel the pledge saving process if needed.

public override bool Save(Boolean,ref String&,String);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(ref String&);

See Also

Pledge Class | Aptify.Applications.Fundraising Namespace


Pledge.Save Method (Boolean, String&, String)

This method overrides the base GE Save so that it may also handle other aspects of saving a pledge such as creating an order, cancellation or other record(s) as required during the save process. At various points throughout the pledge save process, the StatusUpdate() event is raised to provide feedback to the calling object/application which also has the ability to cancel the pledge saving process if needed.

public override bool Save(
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

Parameters

AllowGUI
ErrorString
TransactionID

Return Value

Remarks

See Also

Pledge Class | Aptify.Applications.Fundraising Namespace | Pledge.Save Overload List


Pledge.SaveOrder Method

This function saves the order to the database. It is only called when the order record needs to be created ( when the Stage changes from 'Verbal' to 'Written' and the PledgeType='Cash' Steps to create order 1) Create Order Object 2) Setup Order Header (Ship To,Bill To, Address Information, Etc.) 3) Setup Order Detail - one line for donation product 4) Setup Payment Schedule - copy pmt schedule from PledgePmtSchedule 5) Save()

protected virtual bool SaveOrder(
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

Parameters

AllowGUI
ErrorString
TransactionID

Return Value

Remarks

See Also

Pledge Class | Aptify.Applications.Fundraising Namespace


Pledge.SaveScheduledTransactions Method

This method is responsible for saving scheduled transactions associated with the pledge. This method is called from the SaveOrder() method when required. The base class implementation of this method calls the CreateReversalScheduledTransactions() method and if that is succesful, CreateRecognitionScheduledTransactions() is called.

protected virtual bool SaveScheduledTransactions(
Boolean AllowGUI,
Int64 OrderID
);

Parameters

AllowGUI
OrderID

Return Value

Remarks

See Also

Pledge Class | Aptify.Applications.Fundraising Namespace


Pledge.SetupOrderDetail Method

This method is responsible for creating OrderLines in the provided order object for each item in the PledgeFunds sub-type.

protected virtual bool SetupOrderDetail(
AptifyGenericEntityBase OrderGE,
Boolean IsCancellation,
Decimal Amount
);

Parameters

OrderGE
IsCancellation
Amount

Return Value

Remarks

See Also

Pledge Class | Aptify.Applications.Fundraising Namespace


Pledge.SetupOrderHeader Method

This method is responsible for setting up the top-level entity data for an order for the pledge object. The IsCancellation parameter specifies if this order header is being created for a pledge cancellation or for a regular order.

protected virtual bool SetupOrderHeader(
ref OrdersEntity& OrderGE,
Boolean IsCancellation
);

Parameters

OrderGE
OUT Parameter: Returns the Order GE Object Created by this method
IsCancellation

Return Value

Remarks

See Also

Pledge Class | Aptify.Applications.Fundraising Namespace


Pledge.SetupPaymentSchedule Method

This method creates order payment schedule records based on the pledge payment schedule

protected virtual bool SetupPaymentSchedule(
AptifyGenericEntityBase OrderGE
);

Parameters

OrderGE

Return Value

Remarks

See Also

Pledge Class | Aptify.Applications.Fundraising Namespace


Pledge.SetValue Method

public override void SetValue(
String FieldName,
Object Value
);

See Also

Pledge Class | Aptify.Applications.Fundraising Namespace


Validate Method

Aptify 5.0 Software Development Kit (SDK)

Pledge.Validate Method

This method overrides the base GE functionality for validation to validate pledge-specific business rules including the validation of In Kind Gifts.

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Validate();

This method overrides the base GE functionality for validation to validate pledge-specific business rules including the validation of In Kind Gifts.

public override bool Validate(ref String&);

See Also

Pledge Class | Aptify.Applications.Fundraising Namespace


Pledge.Validate Method (String&)

This method overrides the base GE functionality for validation to validate pledge-specific business rules including the validation of In Kind Gifts.

public override bool Validate(
ref String& ErrorString
);

Parameters

ErrorString

Return Value

Remarks

See Also

Pledge Class | Aptify.Applications.Fundraising Namespace | Pledge.Validate Overload List


Pledge.ValidateContributionInfo Method

This method is responsible for validating the contributor data. The base class implements logic that checks the IsCorporate BIT field. If IsCorporate is set to 1, the CompanyID field AND the ContactID fields must both be filled in. If IsCorporate is set to 0, the ContributorID field (link to Persons entity) is required.

protected virtual bool ValidateContributionInfo(
ref String& ErrorString
);

Parameters

ErrorString

Return Value

Remarks

See Also

Pledge Class | Aptify.Applications.Fundraising Namespace


Pledge.ValidateInKindGift Method

This method will validate the in-kind gift attributes of the pledge. If the pledge type is not set to an in-kind gift, this method will return a value of Nothing. If this pledge type is an in-kind gift, the system will make sure there are no other pledges that are also using the same GiftInKindID that is provided in this pledge.

protected virtual string ValidateInKindGift();

Return Value

Remarks

See Also

Pledge Class | Aptify.Applications.Fundraising Namespace


Pledge.WriteOffPledge Method

public virtual bool WriteOffPledge(
Boolean AllowGUI,
DateTime EffectiveDate,
Int64 WriteOffPaymentTypeID
);

See Also

Pledge Class | Aptify.Applications.Fundraising Namespace


Pledge Events

The events of the Pledge class are listed below. For a complete list of Pledge class members, see the Pledge Members topic.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
StatusUpdate | The event is raised to give a feedback to the user of this object on when internal processes are oCDecing so that status can be provided to the user or logged, if desired. Additionally, whenever this event is raised, the object receiving the event can cancel the process by setting the Cancel parameter to True. This event replaces the Processing event that existed in prior versions of this object (3.x and prior versions)
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

See Also

Pledge Class | Aptify.Applications.Fundraising Namespace


Pledge.Pledge.StatusUpdateEventHandler Event

The event is raised to give a feedback to the user of this object on when internal processes are oCDecing so that status can be provided to the user or logged, if desired. Additionally, whenever this event is raised, the object receiving the event can cancel the process by setting the Cancel parameter to True. This event replaces the Processing event that existed in prior versions of this object (3.x and prior versions)

public event Pledge.StatusUpdateEventHandler StatusUpdate;

Remarks

See Also

Pledge Class | Aptify.Applications.Fundraising Namespace


Pledge.FundraisingCampaignDiscountRule Structure

For a list of all members of this type, see Pledge.FundraisingCampaignDiscountRule Members.

System.Object
ValueType
Pledge.FundraisingCampaignDiscountRule

public struct Pledge.FundraisingCampaignDiscountRule

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Fundraising

Assembly: Pledge (in Pledge.dll)

See Also

Pledge.FundraisingCampaignDiscountRule Members | Aptify.Applications.Fundraising Namespace


Pledge.FundraisingCampaignDiscountRule Members

Pledge.FundraisingCampaignDiscountRule overview

Public Instance Fields

DiscountAfterFirstYear
DiscountDuringFirstYear
FundraisingCampaignID

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

Pledge.FundraisingCampaignDiscountRule Structure | Aptify.Applications.Fundraising Namespace


Pledge.FundraisingCampaignDiscountRule Fields

The fields of the Pledge.FundraisingCampaignDiscountRule structure are listed below. For a complete list of Pledge.FundraisingCampaignDiscountRule structure members, see the Pledge.FundraisingCampaignDiscountRule Members topic.

Public Instance Fields

DiscountAfterFirstYear
DiscountDuringFirstYear
FundraisingCampaignID

See Also

Pledge.FundraisingCampaignDiscountRule Structure | Aptify.Applications.Fundraising Namespace


Pledge.FundraisingCampaignDiscountRule.DiscountAfterFirstYear Field

public DiscountAfterFirstYear DiscountAfterFirstYear;

See Also

Pledge.FundraisingCampaignDiscountRule Class | Aptify.Applications.Fundraising Namespace


Pledge.FundraisingCampaignDiscountRule.DiscountDuringFirstYear Field

public DiscountDuringFirstYear DiscountDuringFirstYear;

See Also

Pledge.FundraisingCampaignDiscountRule Class | Aptify.Applications.Fundraising Namespace


Pledge.FundraisingCampaignDiscountRule.FundraisingCampaignID Field

public FundraisingCampaignID FundraisingCampaignID;

See Also

Pledge.FundraisingCampaignDiscountRule Class | Aptify.Applications.Fundraising Namespace


Pledge.PaymentTypeInfo Class

For a list of all members of this type, see Pledge.PaymentTypeInfo Members.

System.Object
Pledge.PaymentTypeInfo

public class Pledge.PaymentTypeInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Fundraising

Assembly: Pledge (in Pledge.dll)

See Also

Pledge.PaymentTypeInfo Members | Aptify.Applications.Fundraising Namespace


Pledge.PaymentTypeInfo Members

Pledge.PaymentTypeInfo overview

Public Instance Constructors

Pledge.PaymentTypeInfo Constructor Initializes a new instance of the Pledge.PaymentTypeInfo class.

Public Instance Fields

Description
ID
Name
Type

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Pledge.PaymentTypeInfo Class | Aptify.Applications.Fundraising Namespace


Pledge.PaymentTypeInfo Constructor

Initializes a new instance of the Pledge.PaymentTypeInfo class.

public Pledge.PaymentTypeInfo();

See Also

Pledge.PaymentTypeInfo Class | Aptify.Applications.Fundraising Namespace


Pledge.PaymentTypeInfo Fields

The fields of the Pledge.PaymentTypeInfo class are listed below. For a complete list of Pledge.PaymentTypeInfo class members, see the Pledge.PaymentTypeInfo Members topic.

Public Instance Fields

Description
ID
Name
Type

See Also

Pledge.PaymentTypeInfo Class | Aptify.Applications.Fundraising Namespace


Pledge.PaymentTypeInfo.Description Field

public Description Description;

See Also

Pledge.PaymentTypeInfo Class | Aptify.Applications.Fundraising Namespace


Pledge.PaymentTypeInfo.ID Field

public ID ID;

See Also

Pledge.PaymentTypeInfo Class | Aptify.Applications.Fundraising Namespace


Pledge.PaymentTypeInfo.Name Field

public Name Name;

See Also

Pledge.PaymentTypeInfo Class | Aptify.Applications.Fundraising Namespace


Pledge.PaymentTypeInfo.Type Field

public Type Type;

See Also

Pledge.PaymentTypeInfo Class | Aptify.Applications.Fundraising Namespace


Pledge.PledgeProcessStep Enumeration

Specifies the current internal process steps that are used with the StatusUpdate Event

public enum Pledge.PledgeProcessStep

Remarks

Members

Member Name | Description
PledgeSchedule | Creating the Pledge Schedule
OrderHeader | Creating the Order Header for a pledge
OrderDetail | Creating the Order Detail item(s) for a pledge
OrderPaymentSchedule | Creating Order Payment Schedule Line Items - Synchronizations with Pledge Schedule
SaveOrder | Saving Order
ReversalScheduledTransactions | Creating Reversal Scheduled Transactions
RecognitionScheduledTransactions | Creating Recognition Scheduled Transactions
BeforeSave | Process Step oCDecs immediately before the save process begins for the Pledge record itself
AfterSave | Process step oCDecs immediately after saving the pledge record in the database.
Other | Another step in the process is taking place
ProcessError | An error took place in the process

Requirements

Namespace: Aptify.Applications.Fundraising

Assembly: Pledge (in Pledge.dll)

See Also

Aptify.Applications.Fundraising Namespace


Pledge.PledgeTransactionOperation Enumeration

Enumerated type that specifies the type of operation that the DoSave() method should perform, if any, in addition to the standard save for the pledge data itself.

public enum Pledge.PledgeTransactionOperation

Remarks

Members

Member Name | Description
None |
SaveOrder |
CreateCancellation |
CreateWriteOff |

Requirements

Namespace: Aptify.Applications.Fundraising

Assembly: Pledge (in Pledge.dll)

See Also

Aptify.Applications.Fundraising Namespace


Pledge.StatusUpdateEventHandler Delegate

public delegate void Pledge.StatusUpdateEventHandler(
Pledge.PledgeProcessStep ProcessStep,
Int64 RecordCount,
Int64 CurrentRecord,
String Description,
ref Boolean& Cancel
);

Requirements

Namespace: Aptify.Applications.Fundraising

Assembly: Pledge (in Pledge.dll)

See Also

Aptify.Applications.Fundraising Namespace


PledgeControlGroup Class

For a list of all members of this type, see PledgeControlGroup Members.

System.Object
List<T>
PledgeControlGroup

public class PledgeControlGroup : List<T>

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Fundraising

Assembly: PledgeLayoutControls (in PledgeLayoutControls.dll)

See Also

PledgeControlGroup Members | Aptify.Applications.Fundraising Namespace


PledgeControlGroup Members

PledgeControlGroup overview

Public Instance Constructors

PledgeControlGroup Overloaded. Initializes a new instance of the PledgeControlGroup class.

Public Instance Properties

Capacity (inherited from List<T>) | Gets or sets the total number of elements the internal data structure can hold without resizing.
Count (inherited from List<T>) | Gets the number of elements actually contained in the List`1.
Enable | Gets or sets whether all the controls in the group should be enabled.
Item (inherited from List<T>) | Gets or sets the element at the specified index.
Name | Gets or sets the name of the control group
Visible | Gets or sets whether all the controls in the group should be visible

Public Instance Methods

Add |
AddRange (inherited from List<T>) |
AsReadOnly (inherited from List<T>) | Returns a read-only IList`1 wrapper for the current collection.
BinarySearch (inherited from List<T>) | Overloaded.
Clear (inherited from List<T>) | Removes all elements from the List`1.
Contains (inherited from List<T>) |
ConvertAll (inherited from List<T>) |
CopyTo (inherited from List<T>) | Overloaded.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Exists (inherited from List<T>) |
Find (inherited from List<T>) |
FindAll (inherited from List<T>) |
FindIndex (inherited from List<T>) | Overloaded.
FindLast (inherited from List<T>) |
FindLastIndex (inherited from List<T>) | Overloaded.
ForEach (inherited from List<T>) |
GetEnumerator (inherited from List<T>) | Returns an enumerator that iterates through the List`1.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetRange (inherited from List<T>) | Creates a shallow copy of a range of elements in the source List`1.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from List<T>) | Overloaded.
Insert (inherited from List<T>) |
InsertRange (inherited from List<T>) |
LastIndexOf (inherited from List<T>) | Overloaded.
Remove (inherited from List<T>) |
RemoveAll (inherited from List<T>) |
RemoveAt (inherited from List<T>) | Removes the element at the specified index of the List`1.
RemoveRange (inherited from List<T>) | Removes a range of elements from the List`1.
Reverse (inherited from List<T>) | Overloaded. Reverses the order of the elements in the entire List`1.
Sort (inherited from List<T>) | Overloaded. Sorts the elements in the entire List`1 using the default comparer.
ToArray (inherited from List<T>) | Copies the elements of the List`1 to a new array.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimExcess (inherited from List<T>) | Sets the capacity to the actual number of elements in the List`1, if that number is less than a threshold value.
TrueForAll (inherited from List<T>) |

Protected Instance Fields

m_bEnable
m_bVisible
m_sGroupName

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PledgeControlGroup Class | Aptify.Applications.Fundraising Namespace


PledgeControlGroup Constructor

Default constructor

Overload List

Default constructor

public PledgeControlGroup();

Constructor to set the Group Name

public PledgeControlGroup(String);

See Also

PledgeControlGroup Class | Aptify.Applications.Fundraising Namespace


PledgeControlGroup Constructor ()

Default constructor

public PledgeControlGroup();

Remarks

See Also

PledgeControlGroup Class | Aptify.Applications.Fundraising Namespace | PledgeControlGroup Constructor Overload List


PledgeControlGroup Constructor (String)

Constructor to set the Group Name

public PledgeControlGroup(
String sName
);

Parameters

sName
Name of the Control Group

Remarks

See Also

PledgeControlGroup Class | Aptify.Applications.Fundraising Namespace | PledgeControlGroup Constructor Overload List


PledgeControlGroup Fields

The fields of the PledgeControlGroup class are listed below. For a complete list of PledgeControlGroup class members, see the PledgeControlGroup Members topic.

Protected Instance Fields

m_bEnable
m_bVisible
m_sGroupName

See Also

PledgeControlGroup Class | Aptify.Applications.Fundraising Namespace


PledgeControlGroup.m_bEnable Field

protected m_bEnable m_bEnable;

See Also

PledgeControlGroup Class | Aptify.Applications.Fundraising Namespace


PledgeControlGroup.m_bVisible Field

protected m_bVisible m_bVisible;

See Also

PledgeControlGroup Class | Aptify.Applications.Fundraising Namespace


PledgeControlGroup.m_sGroupName Field

protected m_sGroupName m_sGroupName;

See Also

PledgeControlGroup Class | Aptify.Applications.Fundraising Namespace


PledgeControlGroup Properties

The properties of the PledgeControlGroup class are listed below. For a complete list of PledgeControlGroup class members, see the PledgeControlGroup Members topic.

Public Instance Properties

Capacity (inherited from List<T>) | Gets or sets the total number of elements the internal data structure can hold without resizing.
Count (inherited from List<T>) | Gets the number of elements actually contained in the List`1.
Enable | Gets or sets whether all the controls in the group should be enabled.
Item (inherited from List<T>) | Gets or sets the element at the specified index.
Name | Gets or sets the name of the control group
Visible | Gets or sets whether all the controls in the group should be visible

See Also

PledgeControlGroup Class | Aptify.Applications.Fundraising Namespace


Enable Property

Aptify 5.0 Software Development Kit (SDK)

PledgeControlGroup.Enable Property

Gets or sets whether all the controls in the group should be enabled.

public Boolean Enable {get; set;}

Property Value

True to enable all controls and false to disable.

Remarks

See Also

PledgeControlGroup Class | Aptify.Applications.Fundraising Namespace


Name Property

Aptify 5.0 Software Development Kit (SDK)

PledgeControlGroup.Name Property

Gets or sets the name of the control group

public String Name {get; set;}

Property Value

Name of the control group.

Remarks

See Also

PledgeControlGroup Class | Aptify.Applications.Fundraising Namespace


Visible Property

Aptify 5.0 Software Development Kit (SDK)

PledgeControlGroup.Visible Property

Gets or sets whether all the controls in the group should be visible

public Boolean Visible {get; set;}

Property Value

True to make all controls visible and false to make invisible.

Remarks

See Also

PledgeControlGroup Class | Aptify.Applications.Fundraising Namespace


PledgeControlGroup Methods

The methods of the PledgeControlGroup class are listed below. For a complete list of PledgeControlGroup class members, see the PledgeControlGroup Members topic.

Public Instance Methods

Add |
AddRange (inherited from List<T>) |
AsReadOnly (inherited from List<T>) | Returns a read-only IList`1 wrapper for the current collection.
BinarySearch (inherited from List<T>) | Overloaded.
Clear (inherited from List<T>) | Removes all elements from the List`1.
Contains (inherited from List<T>) |
ConvertAll (inherited from List<T>) |
CopyTo (inherited from List<T>) | Overloaded.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Exists (inherited from List<T>) |
Find (inherited from List<T>) |
FindAll (inherited from List<T>) |
FindIndex (inherited from List<T>) | Overloaded.
FindLast (inherited from List<T>) |
FindLastIndex (inherited from List<T>) | Overloaded.
ForEach (inherited from List<T>) |
GetEnumerator (inherited from List<T>) | Returns an enumerator that iterates through the List`1.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetRange (inherited from List<T>) | Creates a shallow copy of a range of elements in the source List`1.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from List<T>) | Overloaded.
Insert (inherited from List<T>) |
InsertRange (inherited from List<T>) |
LastIndexOf (inherited from List<T>) | Overloaded.
Remove (inherited from List<T>) |
RemoveAll (inherited from List<T>) |
RemoveAt (inherited from List<T>) | Removes the element at the specified index of the List`1.
RemoveRange (inherited from List<T>) | Removes a range of elements from the List`1.
Reverse (inherited from List<T>) | Overloaded. Reverses the order of the elements in the entire List`1.
Sort (inherited from List<T>) | Overloaded. Sorts the elements in the entire List`1 using the default comparer.
ToArray (inherited from List<T>) | Copies the elements of the List`1 to a new array.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimExcess (inherited from List<T>) | Sets the capacity to the actual number of elements in the List`1, if that number is less than a threshold value.
TrueForAll (inherited from List<T>) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PledgeControlGroup Class | Aptify.Applications.Fundraising Namespace


PledgeControlGroup.Add Method

new public void Add(
GroupControl oControl
);

Implements

ICollection<T>.

See Also

PledgeControlGroup Class | Aptify.Applications.Fundraising Namespace


PledgeFundSelector Class

For a list of all members of this type, see PledgeFundSelector Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
PledgeFundSelector

public class PledgeFundSelector : FormComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Fundraising

Assembly: PledgeLayoutControls (in PledgeLayoutControls.dll)

See Also

PledgeFundSelector Members | Aptify.Applications.Fundraising Namespace


PledgeFundSelector Members

PledgeFundSelector overview

Public Instance Constructors

PledgeFundSelector Constructor Default Constructor

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CampaignID | Gets or sets the Campaign ID for this control. Setting the CampaignID will force a reload of the Funds combo box.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormComponent) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FundProductAdded |
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

m_lCampaignID

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateContext (inherited from FormComponent) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
m_oContext |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
ConfigureDataControls |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormComponent) | Overloaded. Releases all resources used by the Component.
EnableControls | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
LoadCampaignFundProducts | Overloaded.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormComponent) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad |
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormComponent) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

PledgeFundSelector Class | Aptify.Applications.Fundraising Namespace


PledgeFundSelector Constructor

Default Constructor

public PledgeFundSelector();

Remarks

See Also

PledgeFundSelector Class | Aptify.Applications.Fundraising Namespace


PledgeFundSelector Fields

The fields of the PledgeFundSelector class are listed below. For a complete list of PledgeFundSelector class members, see the PledgeFundSelector Members topic.

Protected Instance Fields

m_lCampaignID

See Also

PledgeFundSelector Class | Aptify.Applications.Fundraising Namespace


PledgeFundSelector.m_lCampaignID Field

protected m_lCampaignID m_lCampaignID;

See Also

PledgeFundSelector Class | Aptify.Applications.Fundraising Namespace


PledgeFundSelector Properties

The properties of the PledgeFundSelector class are listed below. For a complete list of PledgeFundSelector class members, see the PledgeFundSelector Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CampaignID | Gets or sets the Campaign ID for this control. Setting the CampaignID will force a reload of the Funds combo box.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateContext (inherited from FormComponent) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
m_oContext |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

PledgeFundSelector Class | Aptify.Applications.Fundraising Namespace


CampaignID Property

Aptify 5.0 Software Development Kit (SDK)

PledgeFundSelector.CampaignID Property

Gets or sets the Campaign ID for this control. Setting the CampaignID will force a reload of the Funds combo box.

public Int64 CampaignID {get; set;}

Property Value

The CampaignID of which fund products should be referencing.

Remarks

See Also

PledgeFundSelector Class | Aptify.Applications.Fundraising Namespace


m_oContext Property

Aptify 5.0 Software Development Kit (SDK)

PledgeFundSelector.m_oContext Property

protected virtual AptifyFormTemplateContext m_oContext {get; set;}

See Also

PledgeFundSelector Class | Aptify.Applications.Fundraising Namespace


PledgeFundSelector Methods

The methods of the PledgeFundSelector class are listed below. For a complete list of PledgeFundSelector class members, see the PledgeFundSelector Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormComponent) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
ConfigureDataControls |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormComponent) | Overloaded. Releases all resources used by the Component.
EnableControls | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
LoadCampaignFundProducts | Overloaded.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormComponent) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad |
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormComponent) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

PledgeFundSelector Class | Aptify.Applications.Fundraising Namespace


PledgeFundSelector.ConfigureDataControls Method

protected virtual void ConfigureDataControls();

See Also

PledgeFundSelector Class | Aptify.Applications.Fundraising Namespace


EnableControls Method

Aptify 5.0 Software Development Kit (SDK)

PledgeFundSelector.EnableControls Method

Overload List

protected virtual void EnableControls();

protected virtual void EnableControls(Int64);

See Also

PledgeFundSelector Class | Aptify.Applications.Fundraising Namespace


PledgeFundSelector.EnableControls Method ()

protected virtual void EnableControls();

See Also

PledgeFundSelector Class | Aptify.Applications.Fundraising Namespace | PledgeFundSelector.EnableControls Overload List


PledgeFundSelector.EnableControls Method (Int64)

protected virtual void EnableControls(
Int64 lCampaignID
);

See Also

PledgeFundSelector Class | Aptify.Applications.Fundraising Namespace | PledgeFundSelector.EnableControls Overload List


LoadCampaignFundProducts Method

Aptify 5.0 Software Development Kit (SDK)

PledgeFundSelector.LoadCampaignFundProducts Method

Overload List

protected virtual bool LoadCampaignFundProducts();

protected virtual bool LoadCampaignFundProducts(Int64);

See Also

PledgeFundSelector Class | Aptify.Applications.Fundraising Namespace


PledgeFundSelector.LoadCampaignFundProducts Method ()

protected virtual bool LoadCampaignFundProducts();

See Also

PledgeFundSelector Class | Aptify.Applications.Fundraising Namespace | PledgeFundSelector.LoadCampaignFundProducts Overload List


PledgeFundSelector.LoadCampaignFundProducts Method (Int64)

protected virtual bool LoadCampaignFundProducts(
Int64 lCampaignID
);

See Also

PledgeFundSelector Class | Aptify.Applications.Fundraising Namespace | PledgeFundSelector.LoadCampaignFundProducts Overload List


PledgeFundSelector.OnFormComponentConfig Method

protected override void OnFormComponentConfig(
AptifyFormTemplateContext FormTemplateContext
);

Implements

IFormComponent.

See Also

PledgeFundSelector Class | Aptify.Applications.Fundraising Namespace


PledgeFundSelector.OnLoad Method

protected override void OnLoad(
EventArgs e
);

See Also

PledgeFundSelector Class | Aptify.Applications.Fundraising Namespace


PledgeFundSelector.OnRefresh Method

protected override void OnRefresh();

Implements

IFormComponent.

See Also

PledgeFundSelector Class | Aptify.Applications.Fundraising Namespace


PledgeFundSelector Events

The events of the PledgeFundSelector class are listed below. For a complete list of PledgeFundSelector class members, see the PledgeFundSelector Members topic.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FundProductAdded |
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

PledgeFundSelector Class | Aptify.Applications.Fundraising Namespace


PledgeFundSelector.PledgeFundSelector.FundProductAddedEventHandler Event

public event PledgeFundSelector.FundProductAddedEventHandler FundProductAdded;

See Also

PledgeFundSelector Class | Aptify.Applications.Fundraising Namespace


PledgeFundSelector.FundProductAddedEventHandler Delegate

public delegate void PledgeFundSelector.FundProductAddedEventHandler(
Object sender,
FundSelectorEventArgs e
);

Requirements

Namespace: Aptify.Applications.Fundraising

Assembly: PledgeLayoutControls (in PledgeLayoutControls.dll)

See Also

Aptify.Applications.Fundraising Namespace


PledgeLayoutControl Class

For a list of all members of this type, see PledgeLayoutControl Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
PledgeLayoutControl

public class PledgeLayoutControl : FormTemplateLayout

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Fundraising

Assembly: PledgeLayoutControls (in PledgeLayoutControls.dll)

See Also

PledgeLayoutControl Members | Aptify.Applications.Fundraising Namespace


PledgeLayoutControl Members

PledgeLayoutControl overview

Public Instance Constructors

PledgeLayoutControl Constructor Default constructor

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

m_cmbStage
m_lnkCancelOrderID
m_lnkCompany
m_lnkContact
m_lnkContributor
m_lnkGivingPerson
m_lnkMatchRule
m_lnkPledge
m_lnkSolicitor
m_multCancelComments
m_oCashControlGroup
m_oInKindControlGroup
m_oVolunteerGroup
m_scCurrentFund
m_scSchedEl
m_sCurrencyFormat
m_subGuestList
m_txtDateCancelled
m_txtDiscount
m_txtGivingDescription
m_txtMatchAmount
m_txtNumPayments
m_txtPledgeReceivedDate
m_txtPledgeSentDate
m_txtPmtEndDate
m_txtPmtStartDate
m_txtPresentValue
m_txtTotalBalance
m_txtTotalMatch
m_txtTotalPaid
m_txtVolunteerHours
mProgress

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
m_aptDataControl |
m_btnCreatePmtSchedule |
m_btnGuestAdd |
m_cmbFrequence |
m_cmbGivingType |
m_cmbPledgeType |
m_cmbStatus |
m_FundSelector |
m_grpPledgeType |
m_lnkCampaign |
m_lnkEmployee |
m_lnkGiftInKind |
m_lnkGuest |
m_lnkOrder |
m_oContext |
m_oGivingCategory |
m_oPledge |
m_subFundProducts |
m_subPaymentSchedule |
m_tabMain |
m_tabPages |
m_txtAmount |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
AlignNumericControls |
AssembleFundString |
CalcCustomPresentValue |
CalcCustomPrice |
ChangeFundModification |
ConfigureControlDisplay |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
CreatePmtSchedule |
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
DisableControls |
Dispose (inherited from FormTemplateLayout) | Overloaded. Releases all resources used by the Component.
DoSetAmount |
EnableControls |
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControls |
FindDataControl |
FundExists |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetBaseStageFromStageID |
GetEmployeeIDFromOrder |
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTabByName |
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
HaveDataForWrittenPledge |
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsCustomDate |
IsCustomSchedule |
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
IsNumericDataType |
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig |
OnFormTemplateLoaded (inherited from FormTemplateLayout) | Raises the FormTemplateLoaded event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad |
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ReferenceControl |
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
RefreshValues |
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetCurrencyFormat |
SetCustomFundPrice |
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTabDisplay |
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
SyncSolicitorWCampaign |
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateControlValue |
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


PledgeLayoutControl Constructor

Default constructor

public PledgeLayoutControl();

Remarks

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


PledgeLayoutControl Fields

The fields of the PledgeLayoutControl class are listed below. For a complete list of PledgeLayoutControl class members, see the PledgeLayoutControl Members topic.

Protected Instance Fields

m_cmbStage
m_lnkCancelOrderID
m_lnkCompany
m_lnkContact
m_lnkContributor
m_lnkGivingPerson
m_lnkMatchRule
m_lnkPledge
m_lnkSolicitor
m_multCancelComments
m_oCashControlGroup
m_oInKindControlGroup
m_oVolunteerGroup
m_scCurrentFund
m_scSchedEl
m_sCurrencyFormat
m_subGuestList
m_txtDateCancelled
m_txtDiscount
m_txtGivingDescription
m_txtMatchAmount
m_txtNumPayments
m_txtPledgeReceivedDate
m_txtPledgeSentDate
m_txtPmtEndDate
m_txtPmtStartDate
m_txtPresentValue
m_txtTotalBalance
m_txtTotalMatch
m_txtTotalPaid
m_txtVolunteerHours
mProgress

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


PledgeLayoutControl.m_cmbStage Field

protected m_cmbStage m_cmbStage;

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


PledgeLayoutControl.m_lnkCancelOrderID Field

protected m_lnkCancelOrderID m_lnkCancelOrderID;

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


PledgeLayoutControl.m_lnkCompany Field

protected m_lnkCompany m_lnkCompany;

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


PledgeLayoutControl.m_lnkContact Field

protected m_lnkContact m_lnkContact;

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


PledgeLayoutControl.m_lnkContributor Field

protected m_lnkContributor m_lnkContributor;

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


PledgeLayoutControl.m_lnkGivingPerson Field

protected m_lnkGivingPerson m_lnkGivingPerson;

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


PledgeLayoutControl.m_lnkMatchRule Field

protected m_lnkMatchRule m_lnkMatchRule;

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


PledgeLayoutControl.m_lnkPledge Field

protected m_lnkPledge m_lnkPledge;

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


PledgeLayoutControl.m_lnkSolicitor Field

protected m_lnkSolicitor m_lnkSolicitor;

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


PledgeLayoutControl.m_multCancelComments Field

protected m_multCancelComments m_multCancelComments;

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


PledgeLayoutControl.m_oCashControlGroup Field

protected m_oCashControlGroup m_oCashControlGroup;

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


PledgeLayoutControl.m_oInKindControlGroup Field

protected m_oInKindControlGroup m_oInKindControlGroup;

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


PledgeLayoutControl.m_oVolunteerGroup Field

protected m_oVolunteerGroup m_oVolunteerGroup;

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


PledgeLayoutControl.m_scCurrentFund Field

protected m_scCurrentFund m_scCurrentFund;

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


PledgeLayoutControl.m_scSchedEl Field

protected m_scSchedEl m_scSchedEl;

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


PledgeLayoutControl.m_sCurrencyFormat Field

protected m_sCurrencyFormat m_sCurrencyFormat;

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


PledgeLayoutControl.m_subGuestList Field

protected m_subGuestList m_subGuestList;

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


PledgeLayoutControl.m_txtDateCancelled Field

protected m_txtDateCancelled m_txtDateCancelled;

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


PledgeLayoutControl.m_txtDiscount Field

protected m_txtDiscount m_txtDiscount;

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


PledgeLayoutControl.m_txtGivingDescription Field

protected m_txtGivingDescription m_txtGivingDescription;

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


PledgeLayoutControl.m_txtMatchAmount Field

protected m_txtMatchAmount m_txtMatchAmount;

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


PledgeLayoutControl.m_txtNumPayments Field

protected m_txtNumPayments m_txtNumPayments;

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


PledgeLayoutControl.m_txtPledgeReceivedDate Field

protected m_txtPledgeReceivedDate m_txtPledgeReceivedDate;

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


PledgeLayoutControl.m_txtPledgeSentDate Field

protected m_txtPledgeSentDate m_txtPledgeSentDate;

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


PledgeLayoutControl.m_txtPmtEndDate Field

protected m_txtPmtEndDate m_txtPmtEndDate;

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


PledgeLayoutControl.m_txtPmtStartDate Field

protected m_txtPmtStartDate m_txtPmtStartDate;

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


PledgeLayoutControl.m_txtPresentValue Field

protected m_txtPresentValue m_txtPresentValue;

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


PledgeLayoutControl.m_txtTotalBalance Field

protected m_txtTotalBalance m_txtTotalBalance;

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


PledgeLayoutControl.m_txtTotalMatch Field

protected m_txtTotalMatch m_txtTotalMatch;

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


PledgeLayoutControl.m_txtTotalPaid Field

protected m_txtTotalPaid m_txtTotalPaid;

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


PledgeLayoutControl.m_txtVolunteerHours Field

protected m_txtVolunteerHours m_txtVolunteerHours;

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


PledgeLayoutControl.mProgress Field

protected mProgress mProgress;

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


PledgeLayoutControl Properties

The properties of the PledgeLayoutControl class are listed below. For a complete list of PledgeLayoutControl class members, see the PledgeLayoutControl Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
m_aptDataControl |
m_btnCreatePmtSchedule |
m_btnGuestAdd |
m_cmbFrequence |
m_cmbGivingType |
m_cmbPledgeType |
m_cmbStatus |
m_FundSelector |
m_grpPledgeType |
m_lnkCampaign |
m_lnkEmployee |
m_lnkGiftInKind |
m_lnkGuest |
m_lnkOrder |
m_oContext |
m_oGivingCategory |
m_oPledge |
m_subFundProducts |
m_subPaymentSchedule |
m_tabMain |
m_tabPages |
m_txtAmount |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


m_aptDataControl Property

Aptify 5.0 Software Development Kit (SDK)

PledgeLayoutControl.m_aptDataControl Property

protected virtual IDataControl m_aptDataControl {get; set;}

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


m_btnCreatePmtSchedule Property

Aptify 5.0 Software Development Kit (SDK)

PledgeLayoutControl.m_btnCreatePmtSchedule Property

protected virtual AptifyActiveButton m_btnCreatePmtSchedule {get; set;}

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


m_btnGuestAdd Property

Aptify 5.0 Software Development Kit (SDK)

PledgeLayoutControl.m_btnGuestAdd Property

protected virtual AptifyActiveButton m_btnGuestAdd {get; set;}

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


m_cmbFrequence Property

Aptify 5.0 Software Development Kit (SDK)

PledgeLayoutControl.m_cmbFrequence Property

protected virtual AptifyComboBox m_cmbFrequence {get; set;}

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


m_cmbGivingType Property

Aptify 5.0 Software Development Kit (SDK)

PledgeLayoutControl.m_cmbGivingType Property

protected virtual AptifyComboBox m_cmbGivingType {get; set;}

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


m_cmbPledgeType Property

Aptify 5.0 Software Development Kit (SDK)

PledgeLayoutControl.m_cmbPledgeType Property

protected virtual AptifyComboBox m_cmbPledgeType {get; set;}

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


m_cmbStatus Property

Aptify 5.0 Software Development Kit (SDK)

PledgeLayoutControl.m_cmbStatus Property

protected virtual AptifyComboBox m_cmbStatus {get; set;}

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


m_FundSelector Property

Aptify 5.0 Software Development Kit (SDK)

PledgeLayoutControl.m_FundSelector Property

protected virtual PledgeFundSelector m_FundSelector {get; set;}

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


m_grpPledgeType Property

Aptify 5.0 Software Development Kit (SDK)

PledgeLayoutControl.m_grpPledgeType Property

protected virtual GroupedOptions m_grpPledgeType {get; set;}

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


m_lnkCampaign Property

Aptify 5.0 Software Development Kit (SDK)

PledgeLayoutControl.m_lnkCampaign Property

protected virtual AptifyLinkBox m_lnkCampaign {get; set;}

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


m_lnkEmployee Property

Aptify 5.0 Software Development Kit (SDK)

PledgeLayoutControl.m_lnkEmployee Property

protected virtual AptifyLinkBox m_lnkEmployee {get; set;}

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


m_lnkGiftInKind Property

Aptify 5.0 Software Development Kit (SDK)

PledgeLayoutControl.m_lnkGiftInKind Property

protected virtual AptifyLinkBox m_lnkGiftInKind {get; set;}

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


m_lnkGuest Property

Aptify 5.0 Software Development Kit (SDK)

PledgeLayoutControl.m_lnkGuest Property

protected virtual AptifyLinkBox m_lnkGuest {get; set;}

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


m_lnkOrder Property

Aptify 5.0 Software Development Kit (SDK)

PledgeLayoutControl.m_lnkOrder Property

protected virtual AptifyLinkBox m_lnkOrder {get; set;}

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


m_oContext Property

Aptify 5.0 Software Development Kit (SDK)

PledgeLayoutControl.m_oContext Property

protected virtual AptifyFormTemplateContext m_oContext {get; set;}

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


m_oGivingCategory Property

Aptify 5.0 Software Development Kit (SDK)

PledgeLayoutControl.m_oGivingCategory Property

protected virtual AptifyDataField m_oGivingCategory {get; set;}

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


m_oPledge Property

Aptify 5.0 Software Development Kit (SDK)

PledgeLayoutControl.m_oPledge Property

protected virtual Pledge m_oPledge {get; set;}

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


m_subFundProducts Property

Aptify 5.0 Software Development Kit (SDK)

PledgeLayoutControl.m_subFundProducts Property

protected virtual AptifySubType m_subFundProducts {get; set;}

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


m_subPaymentSchedule Property

Aptify 5.0 Software Development Kit (SDK)

PledgeLayoutControl.m_subPaymentSchedule Property

protected virtual AptifySubType m_subPaymentSchedule {get; set;}

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


m_tabMain Property

Aptify 5.0 Software Development Kit (SDK)

PledgeLayoutControl.m_tabMain Property

protected virtual UltraTabControl m_tabMain {get; set;}

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


m_tabPages Property

Aptify 5.0 Software Development Kit (SDK)

PledgeLayoutControl.m_tabPages Property

protected virtual TabControl m_tabPages {get; set;}

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


m_txtAmount Property

Aptify 5.0 Software Development Kit (SDK)

PledgeLayoutControl.m_txtAmount Property

protected virtual AptifyTextBox m_txtAmount {get; set;}

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


PledgeLayoutControl Methods

The methods of the PledgeLayoutControl class are listed below. For a complete list of PledgeLayoutControl class members, see the PledgeLayoutControl Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
AlignNumericControls |
AssembleFundString |
CalcCustomPresentValue |
CalcCustomPrice |
ChangeFundModification |
ConfigureControlDisplay |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
CreatePmtSchedule |
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
DisableControls |
Dispose (inherited from FormTemplateLayout) | Overloaded. Releases all resources used by the Component.
DoSetAmount |
EnableControls |
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControls |
FindDataControl |
FundExists |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetBaseStageFromStageID |
GetEmployeeIDFromOrder |
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTabByName |
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
HaveDataForWrittenPledge |
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsCustomDate |
IsCustomSchedule |
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
IsNumericDataType |
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig |
OnFormTemplateLoaded (inherited from FormTemplateLayout) | Raises the FormTemplateLoaded event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad |
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ReferenceControl |
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
RefreshValues |
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetCurrencyFormat |
SetCustomFundPrice |
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTabDisplay |
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
SyncSolicitorWCampaign |
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateControlValue |
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


PledgeLayoutControl.AlignNumericControls Method

protected virtual void AlignNumericControls(
Control oParentControl
);

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


PledgeLayoutControl.AssembleFundString Method

protected virtual string AssembleFundString();

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


PledgeLayoutControl.CalcCustomPresentValue Method

protected virtual decimal CalcCustomPresentValue();

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


PledgeLayoutControl.CalcCustomPrice Method

protected virtual decimal CalcCustomPrice(
ref Boolean& bCustom
);

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


PledgeLayoutControl.ChangeFundModification Method

protected virtual bool ChangeFundModification();

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


PledgeLayoutControl.ConfigureControlDisplay Method

protected virtual void ConfigureControlDisplay();

Remarks

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


PledgeLayoutControl.CreatePmtSchedule Method

protected virtual bool CreatePmtSchedule(
Boolean bShowMsg
);

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


PledgeLayoutControl.DisableControls Method

protected virtual void DisableControls();

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


PledgeLayoutControl.DoSetAmount Method

protected virtual void DoSetAmount(
String sAmount,
String sPresentValue
);

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


PledgeLayoutControl.EnableControls Method

protected virtual void EnableControls(
Boolean bEnable
);

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


PledgeLayoutControl.FindControls Method

protected virtual void FindControls();

Remarks

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


PledgeLayoutControl.FindDataControl Method

protected virtual IDataControl FindDataControl(
Control oControl
);

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


PledgeLayoutControl.FundExists Method

protected virtual bool FundExists(
Int64 lFundProductID
);

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


PledgeLayoutControl.GetBaseStageFromStageID Method

protected virtual string GetBaseStageFromStageID(
Int64 lStageID
);

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


PledgeLayoutControl.GetEmployeeIDFromOrder Method

protected virtual long GetEmployeeIDFromOrder(
Int64 lOrderID
);

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


PledgeLayoutControl.GetTabByName Method

protected virtual UltraTab GetTabByName(
String sName
);

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


PledgeLayoutControl.HaveDataForWrittenPledge Method

protected virtual bool HaveDataForWrittenPledge(
ref String& sMessage
);

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


PledgeLayoutControl.IsCustomDate Method

protected bool IsCustomDate(
Int32 iItem,
AptifyGenericEntity oItem
);

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


PledgeLayoutControl.IsCustomSchedule Method

protected virtual bool IsCustomSchedule(
String sMsg
);

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


PledgeLayoutControl.IsNumericDataType Method

protected virtual bool IsNumericDataType(
AptifyDataField oDataField
);

Parameters

oDataField

Return Value

Remarks

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


PledgeLayoutControl.OnFormComponentConfig Method

protected override void OnFormComponentConfig(
AptifyFormTemplateContext Context
);

Implements

IFormComponent.

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


PledgeLayoutControl.OnLoad Method

protected override void OnLoad(
EventArgs e
);

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


PledgeLayoutControl.OnRefresh Method

protected override void OnRefresh();

Implements

IFormComponent.

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


PledgeLayoutControl.ReferenceControl Method

protected virtual Control ReferenceControl(
String sPartName,
Control oLocalControl
);

Parameters

sPartName
oLocalControl

Return Value

Remarks

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


PledgeLayoutControl.RefreshValues Method

protected bool RefreshValues(
Boolean bDeleteSchedule,
Boolean bDeleteFunds,
Boolean bAll
);

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


PledgeLayoutControl.SetCurrencyFormat Method

protected virtual void SetCurrencyFormat();

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


PledgeLayoutControl.SetCustomFundPrice Method

protected virtual decimal SetCustomFundPrice();

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


PledgeLayoutControl.SetTabDisplay Method

protected virtual void SetTabDisplay();

Remarks

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


PledgeLayoutControl.SyncSolicitorWCampaign Method

protected virtual bool SyncSolicitorWCampaign(
Boolean bDisable
);

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


PledgeLayoutControl.UpdateControlValue Method

protected virtual void UpdateControlValue(
AptifyComboBox oComboUpdated
);

See Also

PledgeLayoutControl Class | Aptify.Applications.Fundraising Namespace


PledgeLayoutControl.PledgeSubTypes Structure

For a list of all members of this type, see PledgeLayoutControl.PledgeSubTypes Members.

System.Object
ValueType
PledgeLayoutControl.PledgeSubTypes

protected struct PledgeLayoutControl.PledgeSubTypes

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Fundraising

Assembly: PledgeLayoutControls (in PledgeLayoutControls.dll)

See Also

PledgeLayoutControl.PledgeSubTypes Members | Aptify.Applications.Fundraising Namespace


PledgeLayoutControl.PledgeSubTypes Members

PledgeLayoutControl.PledgeSubTypes overview

Public Instance Constructors

PledgeLayoutControl.PledgeSubTypes Constructor

Public Instance Fields

Sequence
Value
Value1
Value2

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

PledgeLayoutControl.PledgeSubTypes Structure | Aptify.Applications.Fundraising Namespace


PledgeLayoutControl.PledgeSubTypes Constructor

public PledgeLayoutControl.PledgeSubTypes(
Int32 iSequence,
Decimal dValue,
String sValue1,
String sValue2
);

See Also

PledgeLayoutControl.PledgeSubTypes Structure | Aptify.Applications.Fundraising Namespace


PledgeLayoutControl.PledgeSubTypes Fields

The fields of the PledgeLayoutControl.PledgeSubTypes structure are listed below. For a complete list of PledgeLayoutControl.PledgeSubTypes structure members, see the PledgeLayoutControl.PledgeSubTypes Members topic.

Public Instance Fields

Sequence
Value
Value1
Value2

See Also

PledgeLayoutControl.PledgeSubTypes Structure | Aptify.Applications.Fundraising Namespace


PledgeLayoutControl.PledgeSubTypes.Sequence Field

public Sequence Sequence;

See Also

PledgeLayoutControl.PledgeSubTypes Class | Aptify.Applications.Fundraising Namespace


PledgeLayoutControl.PledgeSubTypes.Value Field

public Value Value;

See Also

PledgeLayoutControl.PledgeSubTypes Class | Aptify.Applications.Fundraising Namespace


PledgeLayoutControl.PledgeSubTypes.Value1 Field

public Value1 Value1;

See Also

PledgeLayoutControl.PledgeSubTypes Class | Aptify.Applications.Fundraising Namespace


PledgeLayoutControl.PledgeSubTypes.Value2 Field

public Value2 Value2;

See Also

PledgeLayoutControl.PledgeSubTypes Class | Aptify.Applications.Fundraising Namespace


PledgeMatchingObject Class

For a list of all members of this type, see PledgeMatchingObject Members.

System.Object
PledgeMatchingObject

public class PledgeMatchingObject : IProcessComponent, IAptifyAction, IAptifyViewExtension

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Fundraising

Assembly: PledgeMatchingWizard (in PledgeMatchingWizard.dll)

See Also

PledgeMatchingObject Members | Aptify.Applications.Fundraising Namespace


PledgeMatchingObject Members

PledgeMatchingObject overview

Public Instance Constructors

PledgeMatchingObject Constructor Initializes a new instance of the PledgeMatchingObject class.

Public Instance Properties

Application
ExtensionMenuItem
Properties
ViewPlugIn

Public Instance Methods

Attach |
Config | Overloaded.
DoAction | Overloaded.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute |
GetCurrentEmployeeID | This method is responsible for returning the ID from the Employees entity that matches the currently logged in user. This method uses the User Related Entity records functionalty (available in vwUserEntityRelations view) in the Aptify framework to determine if the currently logged-in user has an Employee record attached to it. The method calls the spGetCurrentEmployeeID stored procedure in the database which in turn utilizes the aforementioned meta-data accordingly. If no employee record is found to match the currently logged in user, the value of -1 is returned.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run |
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

AfterAttach
AfterConfig
AfterExecute
BeforeAttach
BeforeConfig
BeforeExecute

Protected Instance Properties

PledgeMatchingForm Returns the Pledge Matching Status Form (or a derived class if overriden by a sub-class of the PledgeMatching class)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAskUserToRenew | This overridable function is reponsible for asking the user if it is okay to renew the subscriptions. This function is only called by CreateRenewalInvoices() if the ShowGUI parameter is passed into CreateRenewalInvoices as TRUE. If ShowGUI is set to False, this function is never called. Override this function to alter the behavior of the user interfaction for asking for the OK to renew the subscriptions.
OnCanProcessByCancelledByUser | This function is responsible for determining if the process can be cancelled by a user. This function is only called when ShowGUI is set to True when calling the CreateRenewalInvoices() function. The default return value for this function is True
OnHideStatusForm | This function is responsible for hiding the status form and is only called by the CreateRenewalInvoices function when the ShowGUI parameter is passed in as true. If the ShowGUI parameter is False in the CreateRenewalInvoices function, this method is never called. Override this method in a sub-class to alter the handling of the Status Form
OnNotifyUserOfNoSubscriptionsToRenew | This function is responsible for notifying the user that there are no Pledges to renew in the provided view/selection list. The default implementation simply display a message box with that notification. This function is only called if the CreateRenewalInvoices() method is called with ShowGUI set to True
OnNotifyUserOfProcessCancellation | This function is responsible for notifying the user that the renewal process was cancelled. The default implementation simply display a message box with that notification. This function is only called if the CreateRenewalInvoices() method is called with ShowGUI set to True
OnNotifyUserOfProcessCompletion | This function is responsible for notifying the user that the renewal process was completed succesfully. The default implementation simply display a message box with that notification. This function is only called if the CreateRenewalInvoices() method is called with ShowGUI set to True
OnSetStatusFormPercentComplete | This function is responsible for updating the percent complete on the status form being shown. This function is only called by the renewal process if the ShowGUI parameter passed into the CreateRenewalInvoices() method is set to True
OnSetStatusFormText | This function is responsible for setting the text for the caption/title box of the Subscription Status Form. This function should only be called if the ShowGUI parameter is set to True (for the CreateRenewalInvoices() function)
OnShouldProcessBeCancelled | This function is responsible for telling the process if the user cancelled the process (or if the process should be cancelled for any other reason). The user interface aspect of this function should only be tested if the ShowGUI paramter is passed in as true, otherwise this process is running without a user interface and no form should be displayed or tested for values
OnShowStatusForm | This function is responsible for showing the status form and is only called by the CreateRenewalInvoices function when the ShowGUI parameter is passed in as true. If the ShowGUI parameter is False in the CreateRenewalInvoices function, this method is never called. Override this method in a sub-class to alter the handling of the Status Form

See Also

PledgeMatchingObject Class | Aptify.Applications.Fundraising Namespace


PledgeMatchingObject Constructor

Initializes a new instance of the PledgeMatchingObject class.

public PledgeMatchingObject();

See Also

PledgeMatchingObject Class | Aptify.Applications.Fundraising Namespace


PledgeMatchingObject Properties

The properties of the PledgeMatchingObject class are listed below. For a complete list of PledgeMatchingObject class members, see the PledgeMatchingObject Members topic.

Public Instance Properties

Application
ExtensionMenuItem
Properties
ViewPlugIn

Protected Instance Properties

PledgeMatchingForm Returns the Pledge Matching Status Form (or a derived class if overriden by a sub-class of the PledgeMatching class)

See Also

PledgeMatchingObject Class | Aptify.Applications.Fundraising Namespace


Application Property

Aptify 5.0 Software Development Kit (SDK)

PledgeMatchingObject.Application Property

public AptifyApplication Application {get;}

Implements

IAptifyViewExtension.

See Also

PledgeMatchingObject Class | Aptify.Applications.Fundraising Namespace


ExtensionMenuItem Property

Aptify 5.0 Software Development Kit (SDK)

PledgeMatchingObject.ExtensionMenuItem Property

public MenuItem ExtensionMenuItem {get;}

Implements

IAptifyViewExtension.

See Also

PledgeMatchingObject Class | Aptify.Applications.Fundraising Namespace


PledgeMatchingForm Property

Aptify 5.0 Software Development Kit (SDK)

PledgeMatchingObject.PledgeMatchingForm Property

Returns the Pledge Matching Status Form (or a derived class if overriden by a sub-class of the PledgeMatching class)

protected virtual PledgeMatchingStatus PledgeMatchingForm {get;}

Property Value

Returns the Pledge Matching Status Form to be used for displaying status to the user (only when the GUI is to be shown)

Remarks

See Also

PledgeMatchingObject Class | Aptify.Applications.Fundraising Namespace


Properties Property

Aptify 5.0 Software Development Kit (SDK)

PledgeMatchingObject.Properties Property

public AptifyProperties Properties {get;}

Implements

IProcessComponent.

See Also

PledgeMatchingObject Class | Aptify.Applications.Fundraising Namespace


ViewPlugIn Property

Aptify 5.0 Software Development Kit (SDK)

PledgeMatchingObject.ViewPlugIn Property

public IAptifyViewPlugIn ViewPlugIn {get;}

Implements

IAptifyViewExtension.

See Also

PledgeMatchingObject Class | Aptify.Applications.Fundraising Namespace


PledgeMatchingObject Methods

The methods of the PledgeMatchingObject class are listed below. For a complete list of PledgeMatchingObject class members, see the PledgeMatchingObject Members topic.

Public Instance Methods

Attach |
Config | Overloaded.
DoAction | Overloaded.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute |
GetCurrentEmployeeID | This method is responsible for returning the ID from the Employees entity that matches the currently logged in user. This method uses the User Related Entity records functionalty (available in vwUserEntityRelations view) in the Aptify framework to determine if the currently logged-in user has an Employee record attached to it. The method calls the spGetCurrentEmployeeID stored procedure in the database which in turn utilizes the aforementioned meta-data accordingly. If no employee record is found to match the currently logged in user, the value of -1 is returned.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAskUserToRenew | This overridable function is reponsible for asking the user if it is okay to renew the subscriptions. This function is only called by CreateRenewalInvoices() if the ShowGUI parameter is passed into CreateRenewalInvoices as TRUE. If ShowGUI is set to False, this function is never called. Override this function to alter the behavior of the user interfaction for asking for the OK to renew the subscriptions.
OnCanProcessByCancelledByUser | This function is responsible for determining if the process can be cancelled by a user. This function is only called when ShowGUI is set to True when calling the CreateRenewalInvoices() function. The default return value for this function is True
OnHideStatusForm | This function is responsible for hiding the status form and is only called by the CreateRenewalInvoices function when the ShowGUI parameter is passed in as true. If the ShowGUI parameter is False in the CreateRenewalInvoices function, this method is never called. Override this method in a sub-class to alter the handling of the Status Form
OnNotifyUserOfNoSubscriptionsToRenew | This function is responsible for notifying the user that there are no Pledges to renew in the provided view/selection list. The default implementation simply display a message box with that notification. This function is only called if the CreateRenewalInvoices() method is called with ShowGUI set to True
OnNotifyUserOfProcessCancellation | This function is responsible for notifying the user that the renewal process was cancelled. The default implementation simply display a message box with that notification. This function is only called if the CreateRenewalInvoices() method is called with ShowGUI set to True
OnNotifyUserOfProcessCompletion | This function is responsible for notifying the user that the renewal process was completed succesfully. The default implementation simply display a message box with that notification. This function is only called if the CreateRenewalInvoices() method is called with ShowGUI set to True
OnSetStatusFormPercentComplete | This function is responsible for updating the percent complete on the status form being shown. This function is only called by the renewal process if the ShowGUI parameter passed into the CreateRenewalInvoices() method is set to True
OnSetStatusFormText | This function is responsible for setting the text for the caption/title box of the Subscription Status Form. This function should only be called if the ShowGUI parameter is set to True (for the CreateRenewalInvoices() function)
OnShouldProcessBeCancelled | This function is responsible for telling the process if the user cancelled the process (or if the process should be cancelled for any other reason). The user interface aspect of this function should only be tested if the ShowGUI paramter is passed in as true, otherwise this process is running without a user interface and no form should be displayed or tested for values
OnShowStatusForm | This function is responsible for showing the status form and is only called by the CreateRenewalInvoices function when the ShowGUI parameter is passed in as true. If the ShowGUI parameter is False in the CreateRenewalInvoices function, this method is never called. Override this method in a sub-class to alter the handling of the Status Form

See Also

PledgeMatchingObject Class | Aptify.Applications.Fundraising Namespace


PledgeMatchingObject.Attach Method

public void Attach(
MenuItem ExtensionMenuItem
);

Implements

IAptifyViewExtension.

See Also

PledgeMatchingObject Class | Aptify.Applications.Fundraising Namespace


Config Method

Aptify 5.0 Software Development Kit (SDK)

PledgeMatchingObject.Config Method

Overload List

public virtual void Config(AptifyApplication);

public void Config(AptifyApplication,IAptifyViewPlugIn);

See Also

PledgeMatchingObject Class | Aptify.Applications.Fundraising Namespace


PledgeMatchingObject.Config Method (AptifyApplication)

public virtual void Config(
AptifyApplication ApplicationObject
);

Implements

IProcessComponent.

See Also

PledgeMatchingObject Class | Aptify.Applications.Fundraising Namespace | PledgeMatchingObject.Config Overload List


PledgeMatchingObject.Config Method (AptifyApplication, IAptifyViewPlugIn)

public void Config(
AptifyApplication Application,
IAptifyViewPlugIn ViewPlugIn
);

Implements

IAptifyViewExtension.

See Also

PledgeMatchingObject Class | Aptify.Applications.Fundraising Namespace | PledgeMatchingObject.Config Overload List


DoAction Method

Aptify 5.0 Software Development Kit (SDK)

PledgeMatchingObject.DoAction Method

Overload List

public void DoAction(AptifyApplication,Int64);

public void DoAction(AptifyApplication,Int64,Int64);

public void DoAction(AptifyApplication,Int64,Int64,params Object[]);

public void DoAction(AptifyApplication,Int64,params String[]);

See Also

PledgeMatchingObject Class | Aptify.Applications.Fundraising Namespace


PledgeMatchingObject.DoAction Method (AptifyApplication, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID
);

Implements

IAptifyAction.

See Also

PledgeMatchingObject Class | Aptify.Applications.Fundraising Namespace | PledgeMatchingObject.DoAction Overload List


PledgeMatchingObject.DoAction Method (AptifyApplication, Int64, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID
);

Implements

IAptifyAction.

See Also

PledgeMatchingObject Class | Aptify.Applications.Fundraising Namespace | PledgeMatchingObject.DoAction Overload List


PledgeMatchingObject.DoAction Method (AptifyApplication, Int64, Int64, Object[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID,
params Object[] SelectedItems
);

Implements

IAptifyAction.

See Also

PledgeMatchingObject Class | Aptify.Applications.Fundraising Namespace | PledgeMatchingObject.DoAction Overload List


PledgeMatchingObject.DoAction Method (AptifyApplication, Int64, String[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
params String[] SelectedItems
);

Implements

IAptifyAction.

See Also

PledgeMatchingObject Class | Aptify.Applications.Fundraising Namespace | PledgeMatchingObject.DoAction Overload List


PledgeMatchingObject.Execute Method

public void Execute(
MenuItem FunctionMenuItem
);

Implements

IAptifyViewExtension.

See Also

PledgeMatchingObject Class | Aptify.Applications.Fundraising Namespace


PledgeMatchingObject.GetCurrentEmployeeID Method

This method is responsible for returning the ID from the Employees entity that matches the currently logged in user. This method uses the User Related Entity records functionalty (available in vwUserEntityRelations view) in the Aptify framework to determine if the currently logged-in user has an Employee record attached to it. The method calls the spGetCurrentEmployeeID stored procedure in the database which in turn utilizes the aforementioned meta-data accordingly. If no employee record is found to match the currently logged in user, the value of -1 is returned.

public virtual long GetCurrentEmployeeID();

Return Value

Remarks

See Also

PledgeMatchingObject Class | Aptify.Applications.Fundraising Namespace


PledgeMatchingObject.OnAskUserToRenew Method

This overridable function is reponsible for asking the user if it is okay to renew the subscriptions. This function is only called by CreateRenewalInvoices() if the ShowGUI parameter is passed into CreateRenewalInvoices as TRUE. If ShowGUI is set to False, this function is never called. Override this function to alter the behavior of the user interfaction for asking for the OK to renew the subscriptions.

protected virtual bool OnAskUserToRenew(
Int32 SubscriptionCount
);

Parameters

SubscriptionCount
The count of the number of subscriptions to be renewed by the renewal process

Return Value

Remarks

See Also

PledgeMatchingObject Class | Aptify.Applications.Fundraising Namespace


PledgeMatchingObject.OnCanProcessByCancelledByUser Method

This function is responsible for determining if the process can be cancelled by a user. This function is only called when ShowGUI is set to True when calling the CreateRenewalInvoices() function. The default return value for this function is True

protected virtual bool OnCanProcessByCancelledByUser();

Return Value

Remarks

See Also

PledgeMatchingObject Class | Aptify.Applications.Fundraising Namespace


PledgeMatchingObject.OnHideStatusForm Method

This function is responsible for hiding the status form and is only called by the CreateRenewalInvoices function when the ShowGUI parameter is passed in as true. If the ShowGUI parameter is False in the CreateRenewalInvoices function, this method is never called. Override this method in a sub-class to alter the handling of the Status Form

protected virtual void OnHideStatusForm();

Remarks

See Also

PledgeMatchingObject Class | Aptify.Applications.Fundraising Namespace


PledgeMatchingObject.OnNotifyUserOfNoSubscriptionsToRenew Method

This function is responsible for notifying the user that there are no Pledges to renew in the provided view/selection list. The default implementation simply display a message box with that notification. This function is only called if the CreateRenewalInvoices() method is called with ShowGUI set to True

protected virtual void OnNotifyUserOfNoSubscriptionsToRenew();

Remarks

See Also

PledgeMatchingObject Class | Aptify.Applications.Fundraising Namespace


PledgeMatchingObject.OnNotifyUserOfProcessCancellation Method

This function is responsible for notifying the user that the renewal process was cancelled. The default implementation simply display a message box with that notification. This function is only called if the CreateRenewalInvoices() method is called with ShowGUI set to True

protected virtual void OnNotifyUserOfProcessCancellation(
Int32 NumberOfPledgesMatched
);

Remarks

See Also

PledgeMatchingObject Class | Aptify.Applications.Fundraising Namespace


PledgeMatchingObject.OnNotifyUserOfProcessCompletion Method

This function is responsible for notifying the user that the renewal process was completed succesfully. The default implementation simply display a message box with that notification. This function is only called if the CreateRenewalInvoices() method is called with ShowGUI set to True

protected virtual void OnNotifyUserOfProcessCompletion(
Int64 lMatchedRecords,
Int64 lTotalRecords
);

Remarks

See Also

PledgeMatchingObject Class | Aptify.Applications.Fundraising Namespace


PledgeMatchingObject.OnSetStatusFormPercentComplete Method

This function is responsible for updating the percent complete on the status form being shown. This function is only called by the renewal process if the ShowGUI parameter passed into the CreateRenewalInvoices() method is set to True

protected virtual void OnSetStatusFormPercentComplete(
Int32 PercentComplete
);

Parameters

PercentComplete
Value from 0 to 100

Remarks

See Also

PledgeMatchingObject Class | Aptify.Applications.Fundraising Namespace


PledgeMatchingObject.OnSetStatusFormText Method

This function is responsible for setting the text for the caption/title box of the Subscription Status Form. This function should only be called if the ShowGUI parameter is set to True (for the CreateRenewalInvoices() function)

protected virtual void OnSetStatusFormText(
String StatusText
);

Parameters

StatusText
Text to set the Caption of the Status Form to

Remarks

See Also

PledgeMatchingObject Class | Aptify.Applications.Fundraising Namespace


PledgeMatchingObject.OnShouldProcessBeCancelled Method

This function is responsible for telling the process if the user cancelled the process (or if the process should be cancelled for any other reason). The user interface aspect of this function should only be tested if the ShowGUI paramter is passed in as true, otherwise this process is running without a user interface and no form should be displayed or tested for values

protected virtual bool OnShouldProcessBeCancelled(
Boolean ShowGUI
);

Return Value

True if the process should be cancelled, False otherwise

Remarks

See Also

PledgeMatchingObject Class | Aptify.Applications.Fundraising Namespace


PledgeMatchingObject.OnShowStatusForm Method

This function is responsible for showing the status form and is only called by the CreateRenewalInvoices function when the ShowGUI parameter is passed in as true. If the ShowGUI parameter is False in the CreateRenewalInvoices function, this method is never called. Override this method in a sub-class to alter the handling of the Status Form

protected virtual void OnShowStatusForm(
String StatusFormCaption
);

Parameters

StatusFormCaption

Remarks

See Also

PledgeMatchingObject Class | Aptify.Applications.Fundraising Namespace


PledgeMatchingObject.Run Method

public virtual string Run();

Implements

IProcessComponent.

See Also

PledgeMatchingObject Class | Aptify.Applications.Fundraising Namespace


PledgeMatchingObject Events

The events of the PledgeMatchingObject class are listed below. For a complete list of PledgeMatchingObject class members, see the PledgeMatchingObject Members topic.

Public Instance Events

AfterAttach
AfterConfig
AfterExecute
BeforeAttach
BeforeConfig
BeforeExecute

See Also

PledgeMatchingObject Class | Aptify.Applications.Fundraising Namespace


PledgeMatchingObject.IAptifyViewExtension.AfterAttachEventHandler Event

public event IAptifyViewExtension.AfterAttachEventHandler AfterAttach;

Implements

IAptifyViewExtension.

See Also

PledgeMatchingObject Class | Aptify.Applications.Fundraising Namespace


PledgeMatchingObject.IAptifyViewExtension.AfterConfigEventHandler Event

public event IAptifyViewExtension.AfterConfigEventHandler AfterConfig;

Implements

IAptifyViewExtension.

See Also

PledgeMatchingObject Class | Aptify.Applications.Fundraising Namespace


PledgeMatchingObject.IAptifyViewExtension.AfterExecuteEventHandler Event

public event IAptifyViewExtension.AfterExecuteEventHandler AfterExecute;

Implements

IAptifyViewExtension.

See Also

PledgeMatchingObject Class | Aptify.Applications.Fundraising Namespace


PledgeMatchingObject.IAptifyViewExtension.BeforeAttachEventHandler Event

public event IAptifyViewExtension.BeforeAttachEventHandler BeforeAttach;

Implements

IAptifyViewExtension.

See Also

PledgeMatchingObject Class | Aptify.Applications.Fundraising Namespace


PledgeMatchingObject.IAptifyViewExtension.BeforeConfigEventHandler Event

public event IAptifyViewExtension.BeforeConfigEventHandler BeforeConfig;

Implements

IAptifyViewExtension.

See Also

PledgeMatchingObject Class | Aptify.Applications.Fundraising Namespace


PledgeMatchingObject.IAptifyViewExtension.BeforeExecuteEventHandler Event

public event IAptifyViewExtension.BeforeExecuteEventHandler BeforeExecute;

Implements

IAptifyViewExtension.

See Also

PledgeMatchingObject Class | Aptify.Applications.Fundraising Namespace


PledgeMatchingStatus Class

For a list of all members of this type, see PledgeMatchingStatus Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
PledgeMatchingStatus

public class PledgeMatchingStatus : Form

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Fundraising

Assembly: PledgeMatchingWizard (in PledgeMatchingWizard.dll)

See Also

PledgeMatchingStatus Members | Aptify.Applications.Fundraising Namespace


PledgeMatchingStatus Members

PledgeMatchingStatus overview

Public Instance Constructors

PledgeMatchingStatus Constructor Initializes a new instance of the PledgeMatchingStatus class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CancelButtonVisible |
CancelText |
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UserCancelled |
UserCredential |
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

PledgeMatchingStatus Class | Aptify.Applications.Fundraising Namespace


PledgeMatchingStatus Constructor

Initializes a new instance of the PledgeMatchingStatus class.

public PledgeMatchingStatus();

See Also

PledgeMatchingStatus Class | Aptify.Applications.Fundraising Namespace


PledgeMatchingStatus Properties

The properties of the PledgeMatchingStatus class are listed below. For a complete list of PledgeMatchingStatus class members, see the PledgeMatchingStatus Members topic.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CancelButtonVisible |
CancelText |
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UserCancelled |
UserCredential |
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

PledgeMatchingStatus Class | Aptify.Applications.Fundraising Namespace


CancelButtonVisible Property

Aptify 5.0 Software Development Kit (SDK)

PledgeMatchingStatus.CancelButtonVisible Property

public Boolean CancelButtonVisible {get; set;}

See Also

PledgeMatchingStatus Class | Aptify.Applications.Fundraising Namespace


CancelText Property

Aptify 5.0 Software Development Kit (SDK)

PledgeMatchingStatus.CancelText Property

public String CancelText {get; set;}

See Also

PledgeMatchingStatus Class | Aptify.Applications.Fundraising Namespace


UserCancelled Property

Aptify 5.0 Software Development Kit (SDK)

PledgeMatchingStatus.UserCancelled Property

public Boolean UserCancelled {get;}

See Also

PledgeMatchingStatus Class | Aptify.Applications.Fundraising Namespace


UserCredential Property

Aptify 5.0 Software Development Kit (SDK)

PledgeMatchingStatus.UserCredential Property

public UserCredentials UserCredential {get; set;}

See Also

PledgeMatchingStatus Class | Aptify.Applications.Fundraising Namespace


PledgeMatchingStatus Methods

The methods of the PledgeMatchingStatus class are listed below. For a complete list of PledgeMatchingStatus class members, see the PledgeMatchingStatus Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

PledgeMatchingStatus Class | Aptify.Applications.Fundraising Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

PledgeMatchingStatus.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

PledgeMatchingStatus Class | Aptify.Applications.Fundraising Namespace


PledgeMatchingStatus.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

PledgeMatchingStatus Class | Aptify.Applications.Fundraising Namespace | PledgeMatchingStatus.Dispose Overload List


PledgeMatchObject Class

For a list of all members of this type, see PledgeMatchObject Members.

System.Object
PledgeMatchObject

public class PledgeMatchObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Fundraising

Assembly: PledgeMatchObject (in PledgeMatchObject.dll)

See Also

PledgeMatchObject Members | Aptify.Applications.Fundraising Namespace


PledgeMatchObject Members

PledgeMatchObject overview

Public Instance Constructors

PledgeMatchObject Constructor Initializes a new instance of the PledgeMatchObject class.

Public Instance Methods

Config | This method must be called before any other member of the object is accessed
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetMatchingRule |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PledgeMatchObject Class | Aptify.Applications.Fundraising Namespace


PledgeMatchObject Constructor

Initializes a new instance of the PledgeMatchObject class.

public PledgeMatchObject();

See Also

PledgeMatchObject Class | Aptify.Applications.Fundraising Namespace


PledgeMatchObject Methods

The methods of the PledgeMatchObject class are listed below. For a complete list of PledgeMatchObject class members, see the PledgeMatchObject Members topic.

Public Instance Methods

Config | This method must be called before any other member of the object is accessed
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetMatchingRule |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PledgeMatchObject Class | Aptify.Applications.Fundraising Namespace


PledgeMatchObject.Config Method

This method must be called before any other member of the object is accessed

public virtual void Config(
AptifyApplication Application,
AptifyGenericEntityBase oPledge
);

Parameters

Application
oPledge

Remarks

See Also

PledgeMatchObject Class | Aptify.Applications.Fundraising Namespace


PledgeMatchObject.GetMatchingRule Method

public bool GetMatchingRule(
ref Int64& lRuleID,
ref Decimal& cMatchAmountCalc
);

See Also

PledgeMatchObject Class | Aptify.Applications.Fundraising Namespace


PledgeMatchObject.CalcTypeConstants Enumeration

public enum PledgeMatchObject.CalcTypeConstants

Members

Member Name | Description
Percentage |
FixedAmount |
RuleTable |
Manual |
CustomObject |

Requirements

Namespace: Aptify.Applications.Fundraising

Assembly: PledgeMatchObject (in PledgeMatchObject.dll)

See Also

Aptify.Applications.Fundraising Namespace


PledgePaymentSchedule Class

For a list of all members of this type, see PledgePaymentSchedule Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
PledgePaymentSchedule

public class PledgePaymentSchedule : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Fundraising

Assembly: PledgePaymentSchedule (in PledgePaymentSchedule.dll)

See Also

PledgePaymentSchedule Members | Aptify.Applications.Fundraising Namespace


PledgePaymentSchedule Members

PledgePaymentSchedule overview

Public Instance Constructors

PledgePaymentSchedule Constructor Initializes a new instance of the PledgePaymentSchedule class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue |
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

PledgePaymentSchedule Class | Aptify.Applications.Fundraising Namespace


PledgePaymentSchedule Constructor

Initializes a new instance of the PledgePaymentSchedule class.

public PledgePaymentSchedule();

See Also

PledgePaymentSchedule Class | Aptify.Applications.Fundraising Namespace


PledgePaymentSchedule Methods

The methods of the PledgePaymentSchedule class are listed below. For a complete list of PledgePaymentSchedule class members, see the PledgePaymentSchedule Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue |
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

PledgePaymentSchedule Class | Aptify.Applications.Fundraising Namespace


PledgePaymentSchedule.SetValue Method

public override void SetValue(
String FieldName,
Object Value
);

See Also

PledgePaymentSchedule Class | Aptify.Applications.Fundraising Namespace


PledgePaymentScheduleLayout Class

For a list of all members of this type, see PledgePaymentScheduleLayout Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
PledgePaymentScheduleLayout

public class PledgePaymentScheduleLayout : FormTemplateLayout

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Fundraising

Assembly: PledgeLayoutControls (in PledgeLayoutControls.dll)

See Also

PledgePaymentScheduleLayout Members | Aptify.Applications.Fundraising Namespace


PledgePaymentScheduleLayout Members

PledgePaymentScheduleLayout overview

Public Instance Constructors

PledgePaymentScheduleLayout Constructor Initializes a new instance of the PledgePaymentScheduleLayout class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

m_lnkSchedTrans
m_lnPV
m_txtDate

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
m_cmbFunds |
m_datEntity |
m_txtAmount |
m_txtDiscount |
m_txtPV |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormTemplateLayout) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControls |
FindDataControl |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded (inherited from FormTemplateLayout) | Raises the FormTemplateLoaded event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad |
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ReferenceControl |
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlDisplay |
SetDefaultFund |
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetFundValues |
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

PledgePaymentScheduleLayout Class | Aptify.Applications.Fundraising Namespace


PledgePaymentScheduleLayout Constructor

Initializes a new instance of the PledgePaymentScheduleLayout class.

public PledgePaymentScheduleLayout();

See Also

PledgePaymentScheduleLayout Class | Aptify.Applications.Fundraising Namespace


PledgePaymentScheduleLayout Fields

The fields of the PledgePaymentScheduleLayout class are listed below. For a complete list of PledgePaymentScheduleLayout class members, see the PledgePaymentScheduleLayout Members topic.

Protected Instance Fields

m_lnkSchedTrans
m_lnPV
m_txtDate

See Also

PledgePaymentScheduleLayout Class | Aptify.Applications.Fundraising Namespace


PledgePaymentScheduleLayout.m_lnkSchedTrans Field

protected m_lnkSchedTrans m_lnkSchedTrans;

See Also

PledgePaymentScheduleLayout Class | Aptify.Applications.Fundraising Namespace


PledgePaymentScheduleLayout.m_lnPV Field

protected m_lnPV m_lnPV;

See Also

PledgePaymentScheduleLayout Class | Aptify.Applications.Fundraising Namespace


PledgePaymentScheduleLayout.m_txtDate Field

protected m_txtDate m_txtDate;

See Also

PledgePaymentScheduleLayout Class | Aptify.Applications.Fundraising Namespace


PledgePaymentScheduleLayout Properties

The properties of the PledgePaymentScheduleLayout class are listed below. For a complete list of PledgePaymentScheduleLayout class members, see the PledgePaymentScheduleLayout Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
m_cmbFunds |
m_datEntity |
m_txtAmount |
m_txtDiscount |
m_txtPV |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

PledgePaymentScheduleLayout Class | Aptify.Applications.Fundraising Namespace


m_cmbFunds Property

Aptify 5.0 Software Development Kit (SDK)

PledgePaymentScheduleLayout.m_cmbFunds Property

protected virtual AptifyComboBox m_cmbFunds {get; set;}

See Also

PledgePaymentScheduleLayout Class | Aptify.Applications.Fundraising Namespace


m_datEntity Property

Aptify 5.0 Software Development Kit (SDK)

PledgePaymentScheduleLayout.m_datEntity Property

protected virtual IDataControl m_datEntity {get; set;}

See Also

PledgePaymentScheduleLayout Class | Aptify.Applications.Fundraising Namespace


m_txtAmount Property

Aptify 5.0 Software Development Kit (SDK)

PledgePaymentScheduleLayout.m_txtAmount Property

protected virtual AptifyTextBox m_txtAmount {get; set;}

See Also

PledgePaymentScheduleLayout Class | Aptify.Applications.Fundraising Namespace


m_txtDiscount Property

Aptify 5.0 Software Development Kit (SDK)

PledgePaymentScheduleLayout.m_txtDiscount Property

protected virtual AptifyTextBox m_txtDiscount {get; set;}

See Also

PledgePaymentScheduleLayout Class | Aptify.Applications.Fundraising Namespace


m_txtPV Property

Aptify 5.0 Software Development Kit (SDK)

PledgePaymentScheduleLayout.m_txtPV Property

protected virtual AptifyTextBox m_txtPV {get; set;}

See Also

PledgePaymentScheduleLayout Class | Aptify.Applications.Fundraising Namespace


PledgePaymentScheduleLayout Methods

The methods of the PledgePaymentScheduleLayout class are listed below. For a complete list of PledgePaymentScheduleLayout class members, see the PledgePaymentScheduleLayout Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormTemplateLayout) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControls |
FindDataControl |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded (inherited from FormTemplateLayout) | Raises the FormTemplateLoaded event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad |
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ReferenceControl |
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlDisplay |
SetDefaultFund |
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetFundValues |
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

PledgePaymentScheduleLayout Class | Aptify.Applications.Fundraising Namespace


PledgePaymentScheduleLayout.FindControls Method

protected virtual void FindControls();

See Also

PledgePaymentScheduleLayout Class | Aptify.Applications.Fundraising Namespace


PledgePaymentScheduleLayout.FindDataControl Method

protected virtual IDataControl FindDataControl(
Control oControl
);

See Also

PledgePaymentScheduleLayout Class | Aptify.Applications.Fundraising Namespace


PledgePaymentScheduleLayout.OnLoad Method

protected override void OnLoad(
EventArgs e
);

See Also

PledgePaymentScheduleLayout Class | Aptify.Applications.Fundraising Namespace


PledgePaymentScheduleLayout.OnRefresh Method

protected override void OnRefresh();

Implements

IFormComponent.

See Also

PledgePaymentScheduleLayout Class | Aptify.Applications.Fundraising Namespace


PledgePaymentScheduleLayout.ReferenceControl Method

protected virtual Control ReferenceControl(
String sPartName,
Control oLocalControl
);

Parameters

sPartName
oLocalControl

Return Value

Remarks

See Also

PledgePaymentScheduleLayout Class | Aptify.Applications.Fundraising Namespace


PledgePaymentScheduleLayout.SetControlDisplay Method

protected virtual void SetControlDisplay();

See Also

PledgePaymentScheduleLayout Class | Aptify.Applications.Fundraising Namespace


PledgePaymentScheduleLayout.SetDefaultFund Method

protected virtual void SetDefaultFund(
Int32 iIndex
);

See Also

PledgePaymentScheduleLayout Class | Aptify.Applications.Fundraising Namespace


PledgePaymentScheduleLayout.SetFundValues Method

protected virtual void SetFundValues();

See Also

PledgePaymentScheduleLayout Class | Aptify.Applications.Fundraising Namespace


PledgeProgressBar Class

For a list of all members of this type, see PledgeProgressBar Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
PledgeProgressBar

public class PledgeProgressBar : FormComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Fundraising

Assembly: PledgeLayoutControls (in PledgeLayoutControls.dll)

See Also

PledgeProgressBar Members | Aptify.Applications.Fundraising Namespace


PledgeProgressBar Members

PledgeProgressBar overview

Public Instance Constructors

PledgeProgressBar Constructor Initializes a new instance of the PledgeProgressBar class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormComponent) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateContext (inherited from FormComponent) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormComponent) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormComponent) |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormComponent) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormComponent) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormComponent) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

PledgeProgressBar Class | Aptify.Applications.Fundraising Namespace


PledgeProgressBar Constructor

Initializes a new instance of the PledgeProgressBar class.

public PledgeProgressBar();

See Also

PledgeProgressBar Class | Aptify.Applications.Fundraising Namespace


Solicitor Class

This class provides the implementation for business logic for the Fundraising Solicitors entity in the Aptify Fundraising Management system.

For a list of all members of this type, see Solicitor Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
Solicitor

public class Solicitor : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Fundraising

Assembly: Solicitor (in Solicitor.dll)

See Also

Solicitor Members | Aptify.Applications.Fundraising Namespace


Solicitor Members

Solicitor overview

Public Instance Constructors

Solicitor Constructor Initializes a new instance of the Solicitor class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config | Overloaded.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded. This overrides the base GE Validate() to ensure that validation occurs on duplicate prospects and duplicate solicitor assignment using the ValidateDuplicates() method.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
Database |
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
GetDupeProspectIDList | This method checks if the same prospect is listed on the solicitor record more than once and if any such situations exist, the list of such duplicative prospects is returned by this method. If no such duplicate records are found, this method returns Nothing.
GetDupeSolicitors | This method checks for duplicate solicitor records within the same campaign
GetProspectIDList | This method returns a list of the prospects for a given solicitor in a comma delimited list
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
RemoveProspects | This method removes the specified list of prospect ID values from the FundCampaignSolicitorProspect sub-type.
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateDuplicates | This method checks for duplicate Prospects in the same solicitor record as well as duplicate use of the same prospect across multiple solicitor records. If this method finds either/both such scenarios a message is passed back and validation is considered to have failed. If this method does not find either of those scenarios, the value of Nothing is returned.
ValidateProspects | This method determines if any of the prospects on this fundraising solicitor record have been associated with another solicitor for the same campaign. If any other solicitor has the same prospects, the method returns False, otherwise, the method returns True.
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

Solicitor Class | Aptify.Applications.Fundraising Namespace


Solicitor Constructor

Initializes a new instance of the Solicitor class.

public Solicitor();

See Also

Solicitor Class | Aptify.Applications.Fundraising Namespace


Solicitor Properties

The properties of the Solicitor class are listed below. For a complete list of Solicitor class members, see the Solicitor Members topic.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
Database |
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

Solicitor Class | Aptify.Applications.Fundraising Namespace


Database Property

Aptify 5.0 Software Development Kit (SDK)

Solicitor.Database Property

protected virtual String Database {get;}

See Also

Solicitor Class | Aptify.Applications.Fundraising Namespace


Solicitor Methods

The methods of the Solicitor class are listed below. For a complete list of Solicitor class members, see the Solicitor Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config | Overloaded.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded. This overrides the base GE Validate() to ensure that validation occurs on duplicate prospects and duplicate solicitor assignment using the ValidateDuplicates() method.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
GetDupeProspectIDList | This method checks if the same prospect is listed on the solicitor record more than once and if any such situations exist, the list of such duplicative prospects is returned by this method. If no such duplicate records are found, this method returns Nothing.
GetDupeSolicitors | This method checks for duplicate solicitor records within the same campaign
GetProspectIDList | This method returns a list of the prospects for a given solicitor in a comma delimited list
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
RemoveProspects | This method removes the specified list of prospect ID values from the FundCampaignSolicitorProspect sub-type.
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateDuplicates | This method checks for duplicate Prospects in the same solicitor record as well as duplicate use of the same prospect across multiple solicitor records. If this method finds either/both such scenarios a message is passed back and validation is considered to have failed. If this method does not find either of those scenarios, the value of Nothing is returned.
ValidateProspects | This method determines if any of the prospects on this fundraising solicitor record have been associated with another solicitor for the same campaign. If any other solicitor has the same prospects, the method returns False, otherwise, the method returns True.
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

Solicitor Class | Aptify.Applications.Fundraising Namespace


Config Method

Aptify 5.0 Software Development Kit (SDK)

Solicitor.Config Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual void Config(AptifySubTypeBase);

Inherited from AptifyGenericEntity.

public override void Config(AptifySubTypeBase,Int64);

Inherited from AptifyGenericEntityBase.

public virtual void Config(UserCredentials,String);

public override void Config(UserCredentials,String,Int64);

See Also

Solicitor Class | Aptify.Applications.Fundraising Namespace


Solicitor.Config Method (UserCredentials, String, Int64)

public override void Config(
UserCredentials UserCredentials,
String EntityName,
Int64 RecordID
);

See Also

Solicitor Class | Aptify.Applications.Fundraising Namespace | Solicitor.Config Overload List


Solicitor.GetDupeProspectIDList Method

This method checks if the same prospect is listed on the solicitor record more than once and if any such situations exist, the list of such duplicative prospects is returned by this method. If no such duplicate records are found, this method returns Nothing.

protected virtual string GetDupeProspectIDList();

Return Value

Remarks

See Also

Solicitor Class | Aptify.Applications.Fundraising Namespace


Solicitor.GetDupeSolicitors Method

This method checks for duplicate solicitor records within the same campaign

protected virtual string GetDupeSolicitors();

Return Value

Remarks

See Also

Solicitor Class | Aptify.Applications.Fundraising Namespace


Solicitor.GetProspectIDList Method

This method returns a list of the prospects for a given solicitor in a comma delimited list

protected virtual string GetProspectIDList();

Return Value

Remarks

See Also

Solicitor Class | Aptify.Applications.Fundraising Namespace


Solicitor.RemoveProspects Method

This method removes the specified list of prospect ID values from the FundCampaignSolicitorProspect sub-type.

protected virtual bool RemoveProspects(
List<T> IDValuesToRemove
);

Return Value

Remarks

See Also

Solicitor Class | Aptify.Applications.Fundraising Namespace


Save Method

Aptify 5.0 Software Development Kit (SDK)

Solicitor.Save Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Save();

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean,ref String&);

public override bool Save(Boolean,ref String&,String);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(ref String&);

See Also

Solicitor Class | Aptify.Applications.Fundraising Namespace


Solicitor.Save Method (Boolean, String&, String)

public override bool Save(
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

See Also

Solicitor Class | Aptify.Applications.Fundraising Namespace | Solicitor.Save Overload List


Validate Method

Aptify 5.0 Software Development Kit (SDK)

Solicitor.Validate Method

This overrides the base GE Validate() to ensure that validation occurs on duplicate prospects and duplicate solicitor assignment using the ValidateDuplicates() method.

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Validate();

This overrides the base GE Validate() to ensure that validation occurs on duplicate prospects and duplicate solicitor assignment using the ValidateDuplicates() method.

public override bool Validate(ref String&);

See Also

Solicitor Class | Aptify.Applications.Fundraising Namespace


Solicitor.Validate Method (String&)

This overrides the base GE Validate() to ensure that validation occurs on duplicate prospects and duplicate solicitor assignment using the ValidateDuplicates() method.

public override bool Validate(
ref String& ErrorString
);

Parameters

ErrorString

Return Value

Remarks

See Also

Solicitor Class | Aptify.Applications.Fundraising Namespace | Solicitor.Validate Overload List


Solicitor.ValidateDuplicates Method

This method checks for duplicate Prospects in the same solicitor record as well as duplicate use of the same prospect across multiple solicitor records. If this method finds either/both such scenarios a message is passed back and validation is considered to have failed. If this method does not find either of those scenarios, the value of Nothing is returned.

protected virtual string ValidateDuplicates();

Return Value

Remarks

See Also

Solicitor Class | Aptify.Applications.Fundraising Namespace


Solicitor.ValidateProspects Method

This method determines if any of the prospects on this fundraising solicitor record have been associated with another solicitor for the same campaign. If any other solicitor has the same prospects, the method returns False, otherwise, the method returns True.

protected virtual bool ValidateProspects(
Boolean AllowGUI,
List<T> DuplicateProspectIDList
);

Parameters

AllowGUI
DuplicateProspectIDList

Return Value

Remarks

See Also

Solicitor Class | Aptify.Applications.Fundraising Namespace


Aptify.Applications.Housing

Aptify 5.0 Software Development Kit (SDK)

Aptify.Applications.Housing Namespace

This namespace corresponds to Aptify's Housing Management application.

Namespace hierarchy

Classes

Class | Description
AddRoom | Form that allows a user to add rooms to a block
CreateSubBlock | Form that allows a user to add a sub-block to an existing housing room block
Housing | Aptify Housing Object - sub-class of Aptify Generic Entity which implements Housing specific functionality for the Housing entity.
HousingBlock |
HousingBlockRoom |
HousingDashboardControl | Aptify Housing Application main dashboard control that provides a user experience for viewing housing blocks, availability, and filtering capabilities
HousingImportObject | Provides functionality to import data into the Aptify Housing management application from a format that hotels provide after they receive information on individuals that have reserved rooms within a block. This component is usable from both the HousingImportWizard as well as at the object level through the methods provided here. In addition, this object implements IProcessComponent which provides for a Process Component that can be included in Process Flows.
HousingImportWizard | Aptify Housing Import Wizard Form, uses the Housing Import Object to import housing reservation details from hotels after the reservations have been processed.
HousingReservation |
HousingReservationDetail |
HousingReservationGuest |
HousingShared | Contains shared functions that are used by a variety of Housing application components
HousingTransferObject | Provides functionality to export data (transfer data) from the Aptify Housing management application to a format that can be sent to the hotel(s) where room blocks are reserved. This component is usable from both the HousingTransferWizard as well as at the object level through the methods provided here. In addition, this object implements IProcessComponent which provides for a Process Component that can be included in Process Flows.
HousingTransferWizard | Aptify Housing Transfer Wizard Form, uses the Housing Transfer Object to export housing reservation record(s) to hotel formats.
InventoryTransfer | Form that allows a user to transfer room inventory from one block to another
RecordInfo |

Interfaces

Interface | Description
IHousingImport | This interface must be implemented by objects that are used as plug-ins for the Housing Transfers Entity.
IHousingTransfer | This interface is implemented by objects that are plug-ins for the Housing Transfer Types entity

Enumerations

Enumeration | Description
InventoryTransfer.InventoryTransferType |


AddRoom Class

Form that allows a user to add rooms to a block

For a list of all members of this type, see AddRoom Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
AddRoom

public class AddRoom : Form

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Housing

Assembly: AptifyHousingDashboardControl (in AptifyHousingDashboardControl.dll)

See Also

AddRoom Members | Aptify.Applications.Housing Namespace


AddRoom Members

AddRoom overview

Public Instance Constructors

AddRoom Constructor Initializes a new instance of the AddRoom class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
Application |
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction |
Database |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
HousingProductID |
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config | This method must be called before any other member of this class (including ShowDialog()) are accessed.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

AddRoom Class | Aptify.Applications.Housing Namespace


AddRoom Constructor

Initializes a new instance of the AddRoom class.

public AddRoom();

See Also

AddRoom Class | Aptify.Applications.Housing Namespace


AddRoom Properties

The properties of the AddRoom class are listed below. For a complete list of AddRoom class members, see the AddRoom Members topic.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
Application |
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction |
Database |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
HousingProductID |
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

AddRoom Class | Aptify.Applications.Housing Namespace


Application Property

Aptify 5.0 Software Development Kit (SDK)

AddRoom.Application Property

public virtual AptifyApplication Application {get;}

See Also

AddRoom Class | Aptify.Applications.Housing Namespace


DataAction Property

Aptify 5.0 Software Development Kit (SDK)

AddRoom.DataAction Property

public virtual DataAction DataAction {get;}

See Also

AddRoom Class | Aptify.Applications.Housing Namespace


Database Property

Aptify 5.0 Software Development Kit (SDK)

AddRoom.Database Property

public virtual String Database {get;}

See Also

AddRoom Class | Aptify.Applications.Housing Namespace


HousingProductID Property

Aptify 5.0 Software Development Kit (SDK)

AddRoom.HousingProductID Property

public virtual Int64 HousingProductID {get;}

See Also

AddRoom Class | Aptify.Applications.Housing Namespace


AddRoom Methods

The methods of the AddRoom class are listed below. For a complete list of AddRoom class members, see the AddRoom Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config | This method must be called before any other member of this class (including ShowDialog()) are accessed.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

AddRoom Class | Aptify.Applications.Housing Namespace


AddRoom.Config Method

This method must be called before any other member of this class (including ShowDialog()) are accessed.

public virtual void Config(
AptifyApplication Application,
DataAction DataAction,
Int64 HousingProductID
);

Parameters

Application
DataAction
HousingProductID

Remarks

See Also

AddRoom Class | Aptify.Applications.Housing Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

AddRoom.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

AddRoom Class | Aptify.Applications.Housing Namespace


AddRoom.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

AddRoom Class | Aptify.Applications.Housing Namespace | AddRoom.Dispose Overload List


CreateSubBlock Class

Form that allows a user to add a sub-block to an existing housing room block

For a list of all members of this type, see CreateSubBlock Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
CreateSubBlock

public class CreateSubBlock : Form

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Housing

Assembly: AptifyHousingDashboardControl (in AptifyHousingDashboardControl.dll)

See Also

CreateSubBlock Members | Aptify.Applications.Housing Namespace


CreateSubBlock Members

CreateSubBlock overview

Public Instance Constructors

CreateSubBlock Constructor Initializes a new instance of the CreateSubBlock class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
Application |
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction |
Database |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
HousingProductID |
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config | This method must be called before any other member of this class (including ShowDialog()) are accessed.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetBlockRoomID | This method will return a Housing Block Room record ID that matches the provided HousingBlockID, RoomTypeID and RoomDate paramaters.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CreateSubBlock Class | Aptify.Applications.Housing Namespace


CreateSubBlock Constructor

Initializes a new instance of the CreateSubBlock class.

public CreateSubBlock();

See Also

CreateSubBlock Class | Aptify.Applications.Housing Namespace


CreateSubBlock Properties

The properties of the CreateSubBlock class are listed below. For a complete list of CreateSubBlock class members, see the CreateSubBlock Members topic.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
Application |
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction |
Database |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
HousingProductID |
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

CreateSubBlock Class | Aptify.Applications.Housing Namespace


Application Property

Aptify 5.0 Software Development Kit (SDK)

CreateSubBlock.Application Property

public virtual AptifyApplication Application {get;}

See Also

CreateSubBlock Class | Aptify.Applications.Housing Namespace


DataAction Property

Aptify 5.0 Software Development Kit (SDK)

CreateSubBlock.DataAction Property

public virtual DataAction DataAction {get;}

See Also

CreateSubBlock Class | Aptify.Applications.Housing Namespace


Database Property

Aptify 5.0 Software Development Kit (SDK)

CreateSubBlock.Database Property

public virtual String Database {get;}

See Also

CreateSubBlock Class | Aptify.Applications.Housing Namespace


HousingProductID Property

Aptify 5.0 Software Development Kit (SDK)

CreateSubBlock.HousingProductID Property

public virtual Int64 HousingProductID {get;}

See Also

CreateSubBlock Class | Aptify.Applications.Housing Namespace


CreateSubBlock Methods

The methods of the CreateSubBlock class are listed below. For a complete list of CreateSubBlock class members, see the CreateSubBlock Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config | This method must be called before any other member of this class (including ShowDialog()) are accessed.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetBlockRoomID | This method will return a Housing Block Room record ID that matches the provided HousingBlockID, RoomTypeID and RoomDate paramaters.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CreateSubBlock Class | Aptify.Applications.Housing Namespace


CreateSubBlock.Config Method

This method must be called before any other member of this class (including ShowDialog()) are accessed.

public virtual void Config(
AptifyApplication Application,
DataAction DataAction,
Int64 HousingProductID
);

Parameters

Application
DataAction
HousingProductID

Remarks

See Also

CreateSubBlock Class | Aptify.Applications.Housing Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

CreateSubBlock.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

CreateSubBlock Class | Aptify.Applications.Housing Namespace


CreateSubBlock.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

CreateSubBlock Class | Aptify.Applications.Housing Namespace | CreateSubBlock.Dispose Overload List


CreateSubBlock.GetBlockRoomID Method

This method will return a Housing Block Room record ID that matches the provided HousingBlockID, RoomTypeID and RoomDate paramaters.

public virtual long GetBlockRoomID(
Int64 HousingBlockID,
Int64 RoomTypeID,
DateTime RoomDate
);

Parameters

HousingBlockID
RoomTypeID
RoomDate

Return Value

Remarks

See Also

CreateSubBlock Class | Aptify.Applications.Housing Namespace


Housing Class

Aptify Housing Object - sub-class of Aptify Generic Entity which implements Housing specific functionality for the Housing entity.

For a list of all members of this type, see Housing Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
Housing

public class Housing : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Housing

Assembly: AptifyHousingObjects (in AptifyHousingObjects.dll)

See Also

Housing Members | Aptify.Applications.Housing Namespace


Housing Members

Housing overview

Public Instance Constructors

Housing Constructor Initializes a new instance of the Housing class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

AddHousingBlock |
BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
CountHousingBlocks |
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
DeleteHousingBlock |
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetHousingBlock |
GetHousingBlockByID |
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RefreshHousingBlocks |
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

Housing Class | Aptify.Applications.Housing Namespace


Housing Constructor

Initializes a new instance of the Housing class.

public Housing();

See Also

Housing Class | Aptify.Applications.Housing Namespace


Housing Methods

The methods of the Housing class are listed below. For a complete list of Housing class members, see the Housing Members topic.

Public Instance Methods

AddHousingBlock |
BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
CountHousingBlocks |
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
DeleteHousingBlock |
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetHousingBlock |
GetHousingBlockByID |
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RefreshHousingBlocks |
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

Housing Class | Aptify.Applications.Housing Namespace


Housing.AddHousingBlock Method

public AptifyGenericEntityBase AddHousingBlock();

See Also

Housing Class | Aptify.Applications.Housing Namespace


Housing.CountHousingBlocks Method

public long CountHousingBlocks();

See Also

Housing Class | Aptify.Applications.Housing Namespace


Housing.DeleteHousingBlock Method

public bool DeleteHousingBlock(
Int32 Item
);

See Also

Housing Class | Aptify.Applications.Housing Namespace


Housing.GetHousingBlock Method

public AptifyGenericEntityBase GetHousingBlock(
Int32 Item
);

See Also

Housing Class | Aptify.Applications.Housing Namespace


Housing.GetHousingBlockByID Method

public AptifyGenericEntityBase GetHousingBlockByID(
Int64 ID
);

See Also

Housing Class | Aptify.Applications.Housing Namespace


Housing.RefreshHousingBlocks Method

public bool RefreshHousingBlocks();

See Also

Housing Class | Aptify.Applications.Housing Namespace


Save Method

Aptify 5.0 Software Development Kit (SDK)

Housing.Save Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Save();

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean,ref String&);

public override bool Save(Boolean,ref String&,String);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(ref String&);

See Also

Housing Class | Aptify.Applications.Housing Namespace


Housing.Save Method (Boolean, String&, String)

public override bool Save(
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

See Also

Housing Class | Aptify.Applications.Housing Namespace | Housing.Save Overload List


HousingBlock Class

For a list of all members of this type, see HousingBlock Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
HousingBlock

public class HousingBlock : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Housing

Assembly: AptifyHousingObjects (in AptifyHousingObjects.dll)

See Also

HousingBlock Members | Aptify.Applications.Housing Namespace


HousingBlock Members

HousingBlock overview

Public Instance Constructors

HousingBlock Constructor Initializes a new instance of the HousingBlock class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

AddBlockRoom |
BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
CountBlockRooms |
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
DeleteBlockRoom |
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetBlockRoom |
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

HousingBlock Class | Aptify.Applications.Housing Namespace


HousingBlock Constructor

Initializes a new instance of the HousingBlock class.

public HousingBlock();

See Also

HousingBlock Class | Aptify.Applications.Housing Namespace


HousingBlock Methods

The methods of the HousingBlock class are listed below. For a complete list of HousingBlock class members, see the HousingBlock Members topic.

Public Instance Methods

AddBlockRoom |
BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
CountBlockRooms |
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
DeleteBlockRoom |
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetBlockRoom |
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

HousingBlock Class | Aptify.Applications.Housing Namespace


HousingBlock.AddBlockRoom Method

public AptifyGenericEntityBase AddBlockRoom();

See Also

HousingBlock Class | Aptify.Applications.Housing Namespace


HousingBlock.CountBlockRooms Method

public int CountBlockRooms();

See Also

HousingBlock Class | Aptify.Applications.Housing Namespace


HousingBlock.DeleteBlockRoom Method

public bool DeleteBlockRoom(
Int32 Item
);

See Also

HousingBlock Class | Aptify.Applications.Housing Namespace


HousingBlock.GetBlockRoom Method

public AptifyGenericEntityBase GetBlockRoom(
Int32 Item
);

See Also

HousingBlock Class | Aptify.Applications.Housing Namespace


HousingBlockRoom Class

For a list of all members of this type, see HousingBlockRoom Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
HousingBlockRoom

public class HousingBlockRoom : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Housing

Assembly: AptifyHousingObjects (in AptifyHousingObjects.dll)

See Also

HousingBlockRoom Members | Aptify.Applications.Housing Namespace


HousingBlockRoom Members

HousingBlockRoom overview

Public Instance Constructors

HousingBlockRoom Constructor Initializes a new instance of the HousingBlockRoom class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

HousingBlockRoom Class | Aptify.Applications.Housing Namespace


HousingBlockRoom Constructor

Initializes a new instance of the HousingBlockRoom class.

public HousingBlockRoom();

See Also

HousingBlockRoom Class | Aptify.Applications.Housing Namespace


HousingBlockRoom Methods

The methods of the HousingBlockRoom class are listed below. For a complete list of HousingBlockRoom class members, see the HousingBlockRoom Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

HousingBlockRoom Class | Aptify.Applications.Housing Namespace


Save Method

Aptify 5.0 Software Development Kit (SDK)

HousingBlockRoom.Save Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Save();

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean);

public override bool Save(Boolean,ref String&);

Inherited from AptifyGenericEntity.

public override bool Save(Boolean,ref String&,String);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(ref String&);

See Also

HousingBlockRoom Class | Aptify.Applications.Housing Namespace


HousingBlockRoom.Save Method (Boolean, String&)

public override bool Save(
Boolean AllowGUI,
ref String& ErrorString
);

See Also

HousingBlockRoom Class | Aptify.Applications.Housing Namespace | HousingBlockRoom.Save Overload List


Validate Method

Aptify 5.0 Software Development Kit (SDK)

HousingBlockRoom.Validate Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Validate();

public override bool Validate(ref String&);

See Also

HousingBlockRoom Class | Aptify.Applications.Housing Namespace


HousingBlockRoom.Validate Method (String&)

public override bool Validate(
ref String& ErrorString
);

See Also

HousingBlockRoom Class | Aptify.Applications.Housing Namespace | HousingBlockRoom.Validate Overload List


HousingDashboardControl Class

Aptify Housing Application main dashboard control that provides a user experience for viewing housing blocks, availability, and filtering capabilities

For a list of all members of this type, see HousingDashboardControl Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
HousingDashboardControl

public class HousingDashboardControl : UserControl, IDashboardComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Housing

Assembly: AptifyHousingDashboardControl (in AptifyHousingDashboardControl.dll)

See Also

HousingDashboardControl Members | Aptify.Applications.Housing Namespace


HousingDashboardControl Members

HousingDashboardControl overview

Public Instance Constructors

HousingDashboardControl Constructor Initializes a new instance of the HousingDashboardControl class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ID |
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Properties | Overloaded.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
State |
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AddBlocks | This method is responsible for adding block data to the cmbBlock combo box control
AddDayGroup | This method is responsible for adding a group for a given day to the grid the group will be used to contain columns that in turn will display information about available, reserved and total inventory for each block and sub-block.
AdjustFormScrollbars (inherited from ContainerControl) |
ApplySkin |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
CreateHousingBlockSQL | This method is responsible for creating a SQL statement that retunrs Housing Block information for the specified ParentBlockID and the attributes resident in the control values such as cmbRoomType, cmbBlock, etc.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetHousingProducts | This method returns a list of Housing Products.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
LoadDates | This method is responsible for loading columns into the grid based on the dates for the specified Housing Product's Block Start and End dates.
LoadHousingProducts | This method is responsible for loading the specified ComboBox with a list of housing products.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnListenerMessageReceived | This method handles the listening process for messages received for the control. The base class handles this by updating data in the controls, when required based on the type of message received.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

HousingDashboardControl Class | Aptify.Applications.Housing Namespace


HousingDashboardControl Constructor

Initializes a new instance of the HousingDashboardControl class.

public HousingDashboardControl();

See Also

HousingDashboardControl Class | Aptify.Applications.Housing Namespace


HousingDashboardControl Properties

The properties of the HousingDashboardControl class are listed below. For a complete list of HousingDashboardControl class members, see the HousingDashboardControl Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ID |
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Properties | Overloaded.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
State |
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

HousingDashboardControl Class | Aptify.Applications.Housing Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

HousingDashboardControl.ID Property

public Int64 ID {get;}

Implements

IDashboardComponent.

See Also

HousingDashboardControl Class | Aptify.Applications.Housing Namespace


Mode Property

Aptify 5.0 Software Development Kit (SDK)

HousingDashboardControl.Mode Property

public DashboardMode Mode {get; set;}

Implements

IDashboardComponent.

See Also

HousingDashboardControl Class | Aptify.Applications.Housing Namespace


Properties Property

Aptify 5.0 Software Development Kit (SDK)

HousingDashboardControl.Properties Property

new public AptifyProperties Properties {get;}

Implements

IDashboardComponent.

See Also

HousingDashboardControl Class | Aptify.Applications.Housing Namespace


State Property

Aptify 5.0 Software Development Kit (SDK)

HousingDashboardControl.State Property

public ComponentState State {get; set;}

Implements

IDashboardComponent.

See Also

HousingDashboardControl Class | Aptify.Applications.Housing Namespace


HousingDashboardControl Methods

The methods of the HousingDashboardControl class are listed below. For a complete list of HousingDashboardControl class members, see the HousingDashboardControl Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AddBlocks | This method is responsible for adding block data to the cmbBlock combo box control
AddDayGroup | This method is responsible for adding a group for a given day to the grid the group will be used to contain columns that in turn will display information about available, reserved and total inventory for each block and sub-block.
AdjustFormScrollbars (inherited from ContainerControl) |
ApplySkin |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
CreateHousingBlockSQL | This method is responsible for creating a SQL statement that retunrs Housing Block information for the specified ParentBlockID and the attributes resident in the control values such as cmbRoomType, cmbBlock, etc.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetHousingProducts | This method returns a list of Housing Products.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
LoadDates | This method is responsible for loading columns into the grid based on the dates for the specified Housing Product's Block Start and End dates.
LoadHousingProducts | This method is responsible for loading the specified ComboBox with a list of housing products.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnListenerMessageReceived | This method handles the listening process for messages received for the control. The base class handles this by updating data in the controls, when required based on the type of message received.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

HousingDashboardControl Class | Aptify.Applications.Housing Namespace


HousingDashboardControl.AddBlocks Method

This method is responsible for adding block data to the cmbBlock combo box control

protected virtual bool AddBlocks();

Return Value

Remarks

See Also

HousingDashboardControl Class | Aptify.Applications.Housing Namespace


HousingDashboardControl.AddDayGroup Method

This method is responsible for adding a group for a given day to the grid the group will be used to contain columns that in turn will display information about available, reserved and total inventory for each block and sub-block.

protected virtual bool AddDayGroup(
DataTable dt,
DateTime GroupDate
);

Parameters

dt
Datatable to add columns to
GroupDate
The date to add a group for

Return Value

Remarks

See Also

HousingDashboardControl Class | Aptify.Applications.Housing Namespace


HousingDashboardControl.ApplySkin Method

protected virtual void ApplySkin();

See Also

HousingDashboardControl Class | Aptify.Applications.Housing Namespace


HousingDashboardControl.Config Method

public void Config(
AptifyApplication ApplicationObject,
IDashboardArea Area,
Int64 PartID,
ComponentOrientation Orientation
);

Implements

IDashboardComponent.

See Also

HousingDashboardControl Class | Aptify.Applications.Housing Namespace


HousingDashboardControl.CreateHousingBlockSQL Method

This method is responsible for creating a SQL statement that retunrs Housing Block information for the specified ParentBlockID and the attributes resident in the control values such as cmbRoomType, cmbBlock, etc.

protected virtual string CreateHousingBlockSQL(
Int64 ParentBlockID
);

Parameters

ParentBlockID

Return Value

Remarks

See Also

HousingDashboardControl Class | Aptify.Applications.Housing Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

HousingDashboardControl.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

HousingDashboardControl Class | Aptify.Applications.Housing Namespace


HousingDashboardControl.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

HousingDashboardControl Class | Aptify.Applications.Housing Namespace | HousingDashboardControl.Dispose Overload List


HousingDashboardControl.GetHousingProducts Method

This method returns a list of Housing Products.

protected virtual DataTable GetHousingProducts();

Return Value

Remarks

See Also

HousingDashboardControl Class | Aptify.Applications.Housing Namespace


HousingDashboardControl.LoadDates Method

This method is responsible for loading columns into the grid based on the dates for the specified Housing Product's Block Start and End dates.

protected virtual bool LoadDates(
DataTable dt,
DataTable dtDisplay
);

Parameters

dt
dtDisplay

Return Value

Remarks

See Also

HousingDashboardControl Class | Aptify.Applications.Housing Namespace


HousingDashboardControl.LoadHousingProducts Method

This method is responsible for loading the specified ComboBox with a list of housing products.

protected virtual bool LoadHousingProducts(
ComboBox ComboBox
);

Parameters

ComboBox

Remarks

See Also

HousingDashboardControl Class | Aptify.Applications.Housing Namespace


HousingDashboardControl.OnListenerMessageReceived Method

This method handles the listening process for messages received for the control. The base class handles this by updating data in the controls, when required based on the type of message received.

protected virtual void OnListenerMessageReceived(
String Filter,
String Message
);

Parameters

Filter
Message

Remarks

See Also

HousingDashboardControl Class | Aptify.Applications.Housing Namespace


HousingDashboardControl.Refresh Method

public override void Refresh();

See Also

HousingDashboardControl Class | Aptify.Applications.Housing Namespace


HousingImportObject Class

Provides functionality to import data into the Aptify Housing management application from a format that hotels provide after they receive information on individuals that have reserved rooms within a block. This component is usable from both the HousingImportWizard as well as at the object level through the methods provided here. In addition, this object implements IProcessComponent which provides for a Process Component that can be included in Process Flows.

For a list of all members of this type, see HousingImportObject Members.

System.Object
HousingImportObject

public class HousingImportObject : IProcessComponent, IHousingImport

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Housing

Assembly: AptifyHousingImportObject (in AptifyHousingImportObject.dll)

See Also

HousingImportObject Members | Aptify.Applications.Housing Namespace


HousingImportObject Members

HousingImportObject overview

Public Instance Constructors

HousingImportObject Constructor Initializes a new instance of the HousingImportObject class.

Public Instance Properties

Application |
DataAction |
Database |
ImportFiles | List of the files that will be imported
Properties |

Public Instance Methods

Config |
DoImport | Overloaded. This overload of DoImport() will process a comma delimited list of files and import them
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetTransferTypeID | This method returns the HousingTransferTypeID field from the Housing Block record for the provided Housing Block ID.
GetType (inherited from Object) | Gets the Type of the current instance.
LookupGuestRoom | This method will return the GuestID (Person ID) and the Housing Block ID associated with a specific Housing Reservation Detail Record.
Run | This process component supports the following input properties 1) ImportFileList - Required, comma delimited list of file names to import 2) HousingTransferTypeID - Long - Required, Type of Housing Transfer to import
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Fields

m_lHousingTransferTypeID

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RemoveQuotes |

See Also

HousingImportObject Class | Aptify.Applications.Housing Namespace


HousingImportObject Constructor

Initializes a new instance of the HousingImportObject class.

public HousingImportObject();

See Also

HousingImportObject Class | Aptify.Applications.Housing Namespace


HousingImportObject Fields

The fields of the HousingImportObject class are listed below. For a complete list of HousingImportObject class members, see the HousingImportObject Members topic.

Protected Instance Fields

m_lHousingTransferTypeID

See Also

HousingImportObject Class | Aptify.Applications.Housing Namespace


HousingImportObject.m_lHousingTransferTypeID Field

protected m_lHousingTransferTypeID m_lHousingTransferTypeID;

See Also

HousingImportObject Class | Aptify.Applications.Housing Namespace


HousingImportObject Properties

The properties of the HousingImportObject class are listed below. For a complete list of HousingImportObject class members, see the HousingImportObject Members topic.

Public Instance Properties

Application |
DataAction |
Database |
ImportFiles | List of the files that will be imported
Properties |

See Also

HousingImportObject Class | Aptify.Applications.Housing Namespace


Application Property

Aptify 5.0 Software Development Kit (SDK)

HousingImportObject.Application Property

public virtual AptifyApplication Application {get;}

See Also

HousingImportObject Class | Aptify.Applications.Housing Namespace


DataAction Property

Aptify 5.0 Software Development Kit (SDK)

HousingImportObject.DataAction Property

public virtual DataAction DataAction {get;}

See Also

HousingImportObject Class | Aptify.Applications.Housing Namespace


Database Property

Aptify 5.0 Software Development Kit (SDK)

HousingImportObject.Database Property

public virtual String Database {get;}

See Also

HousingImportObject Class | Aptify.Applications.Housing Namespace


ImportFiles Property

Aptify 5.0 Software Development Kit (SDK)

HousingImportObject.ImportFiles Property

List of the files that will be imported

public virtual List<T> ImportFiles {get;}

Property Value

Implements

IHousingImport.

Remarks

See Also

HousingImportObject Class | Aptify.Applications.Housing Namespace


Properties Property

Aptify 5.0 Software Development Kit (SDK)

HousingImportObject.Properties Property

public AptifyProperties Properties {get;}

Implements

IProcessComponent.

See Also

HousingImportObject Class | Aptify.Applications.Housing Namespace


HousingImportObject Methods

The methods of the HousingImportObject class are listed below. For a complete list of HousingImportObject class members, see the HousingImportObject Members topic.

Public Instance Methods

Config |
DoImport | Overloaded. This overload of DoImport() will process a comma delimited list of files and import them
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetTransferTypeID | This method returns the HousingTransferTypeID field from the Housing Block record for the provided Housing Block ID.
GetType (inherited from Object) | Gets the Type of the current instance.
LookupGuestRoom | This method will return the GuestID (Person ID) and the Housing Block ID associated with a specific Housing Reservation Detail Record.
Run | This process component supports the following input properties 1) ImportFileList - Required, comma delimited list of file names to import 2) HousingTransferTypeID - Long - Required, Type of Housing Transfer to import
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RemoveQuotes |

See Also

HousingImportObject Class | Aptify.Applications.Housing Namespace


HousingImportObject.Config Method

public void Config(
AptifyApplication ApplicationObject
);

Implements

IHousingImport.

See Also

HousingImportObject Class | Aptify.Applications.Housing Namespace


DoImport Method

Aptify 5.0 Software Development Kit (SDK)

HousingImportObject.DoImport Method

This routine will process the selected files and import the hotel confirmation numbers into the Housing Reservation Guest records. This overload will use the list of files existing in the ImportFiles() property and perform the import process on each such file.

Overload List

This routine will process the selected files and import the hotel confirmation numbers into the Housing Reservation Guest records. This overload will use the list of files existing in the ImportFiles() property and perform the import process on each such file.

public bool DoImport(Int64);

This overload will process the specified list of import files

public bool DoImport(Int64,List<T>);

This overload of DoImport() will process a comma delimited list of files and import them

public bool DoImport(Int64,String);

See Also

HousingImportObject Class | Aptify.Applications.Housing Namespace


HousingImportObject.DoImport Method (Int64)

This routine will process the selected files and import the hotel confirmation numbers into the Housing Reservation Guest records. This overload will use the list of files existing in the ImportFiles() property and perform the import process on each such file.

public bool DoImport(
Int64 HousingTransferTypeID
);

Parameters

HousingTransferTypeID

Return Value

Implements

IHousingImport.

Remarks

See Also

HousingImportObject Class | Aptify.Applications.Housing Namespace | HousingImportObject.DoImport Overload List


HousingImportObject.DoImport Method (Int64, List<T>)

This overload will process the specified list of import files

public bool DoImport(
Int64 HousingTransferTypeID,
List<T> ImportFiles
);

Parameters

HousingTransferTypeID
ImportFiles

Return Value

Implements

IHousingImport.

Remarks

See Also

HousingImportObject Class | Aptify.Applications.Housing Namespace | HousingImportObject.DoImport Overload List


HousingImportObject.DoImport Method (Int64, String)

This overload of DoImport() will process a comma delimited list of files and import them

public bool DoImport(
Int64 HousingTransferTypeID,
String ImportFileList
);

Parameters

HousingTransferTypeID
ImportFileList

Return Value

Implements

IHousingImport.

Remarks

See Also

HousingImportObject Class | Aptify.Applications.Housing Namespace | HousingImportObject.DoImport Overload List


HousingImportObject.GetTransferTypeID Method

This method returns the HousingTransferTypeID field from the Housing Block record for the provided Housing Block ID.

public virtual long GetTransferTypeID(
Int64 HousingBlockID
);

Parameters

HousingBlockID

Return Value

Implements

IHousingImport.

Remarks

See Also

HousingImportObject Class | Aptify.Applications.Housing Namespace


HousingImportObject.LookupGuestRoom Method

This method will return the GuestID (Person ID) and the Housing Block ID associated with a specific Housing Reservation Detail Record.

public virtual bool LookupGuestRoom(
Int64 DetailID,
ref Int64& GuestID,
ref Int64& BlockID
);

Parameters

DetailID
Housing Reservation Detail Record ID
GuestID
OUT Parameter: Returns the Guest ID( Persons ID Value)
BlockID
OUT Parameter: Returns the Housing Block ID linked to the Housing Reservation Detail Record

Return Value

Implements

IHousingImport.

Remarks

See Also

HousingImportObject Class | Aptify.Applications.Housing Namespace


HousingImportObject.RemoveQuotes Method

protected virtual string RemoveQuotes(
String s
);

See Also

HousingImportObject Class | Aptify.Applications.Housing Namespace


HousingImportObject.Run Method

This process component supports the following input properties 1) ImportFileList - Required, comma delimited list of file names to import 2) HousingTransferTypeID - Long - Required, Type of Housing Transfer to import

public string Run();

Return Value

Implements

IProcessComponent.

Remarks

See Also

HousingImportObject Class | Aptify.Applications.Housing Namespace


HousingImportWizard Class

Aptify Housing Import Wizard Form, uses the Housing Import Object to import housing reservation details from hotels after the reservations have been processed.

For a list of all members of this type, see HousingImportWizard Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
HousingImportWizard

public class HousingImportWizard : Form, IAptifyAction

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Housing

Assembly: AptifyHousingImportWizard (in AptifyHousingImportWizard.dll)

See Also

HousingImportWizard Members | Aptify.Applications.Housing Namespace


HousingImportWizard Members

HousingImportWizard overview

Public Instance Constructors

HousingImportWizard Constructor Initializes a new instance of the HousingImportWizard class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoAction | Overloaded.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DoLocalization |
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

HousingImportWizard Class | Aptify.Applications.Housing Namespace


HousingImportWizard Constructor

Initializes a new instance of the HousingImportWizard class.

public HousingImportWizard();

See Also

HousingImportWizard Class | Aptify.Applications.Housing Namespace


HousingImportWizard Methods

The methods of the HousingImportWizard class are listed below. For a complete list of HousingImportWizard class members, see the HousingImportWizard Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoAction | Overloaded.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DoLocalization |
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

HousingImportWizard Class | Aptify.Applications.Housing Namespace


HousingImportWizard.Config Method

public bool Config(
AptifyApplication Application,
Int64 EntityID,
Int64 ViewID,
params Object[] SelectedItems
);

See Also

HousingImportWizard Class | Aptify.Applications.Housing Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

HousingImportWizard.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

HousingImportWizard Class | Aptify.Applications.Housing Namespace


HousingImportWizard.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

HousingImportWizard Class | Aptify.Applications.Housing Namespace | HousingImportWizard.Dispose Overload List


DoAction Method

Aptify 5.0 Software Development Kit (SDK)

HousingImportWizard.DoAction Method

Overload List

public void DoAction(AptifyApplication,Int64);

public void DoAction(AptifyApplication,Int64,Int64);

public void DoAction(AptifyApplication,Int64,Int64,params Object[]);

public void DoAction(AptifyApplication,Int64,params String[]);

See Also

HousingImportWizard Class | Aptify.Applications.Housing Namespace


HousingImportWizard.DoAction Method (AptifyApplication, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID
);

Implements

IAptifyAction.

See Also

HousingImportWizard Class | Aptify.Applications.Housing Namespace | HousingImportWizard.DoAction Overload List


HousingImportWizard.DoAction Method (AptifyApplication, Int64, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID
);

Implements

IAptifyAction.

See Also

HousingImportWizard Class | Aptify.Applications.Housing Namespace | HousingImportWizard.DoAction Overload List


HousingImportWizard.DoAction Method (AptifyApplication, Int64, Int64, Object[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID,
params Object[] SelectedItems
);

Implements

IAptifyAction.

See Also

HousingImportWizard Class | Aptify.Applications.Housing Namespace | HousingImportWizard.DoAction Overload List


HousingImportWizard.DoAction Method (AptifyApplication, Int64, String[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
params String[] SelectedItems
);

Implements

IAptifyAction.

See Also

HousingImportWizard Class | Aptify.Applications.Housing Namespace | HousingImportWizard.DoAction Overload List


HousingImportWizard.DoLocalization Method

public void DoLocalization();

See Also

HousingImportWizard Class | Aptify.Applications.Housing Namespace


HousingReservation Class

For a list of all members of this type, see HousingReservation Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
ExtendedOrderDetailGE
HousingReservation

public class HousingReservation : ExtendedOrderDetailGE

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Housing

Assembly: AptifyHousingObjects (in AptifyHousingObjects.dll)

See Also

HousingReservation Members | Aptify.Applications.Housing Namespace


HousingReservation Members

HousingReservation overview

Public Instance Constructors

HousingReservation Constructor Initializes a new instance of the HousingReservation class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
OrderLineGE (inherited from ExtendedOrderDetailGE) | The OrderLineGE causes the ExtendedOrderDetailGE object to be created and then passes it a reference to itself. This reference provides access to the Order Line information through the OrderLines Entity object, the Order information.
ParentGE (inherited from ExtendedOrderDetailGE) |
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from ExtendedOrderDetailGE) |
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
FlowdownForAddCancellationOrderLine (inherited from ExtendedOrderDetailGE) | Called by the OrdersEntity's AddCancellationOrderLine method. It is designed to be overridden when the extended Order Detail Entity needs to use information from the Order Line or Order to set values or perform other logic when a Cancellation Order Line is added to an Order. Overrides of this method should return true if the Cancellation Order Line should be added to the Order. A return value of false will abort the Add Cancellation Order Line process. The core implementation returns True with no other functionality.
FlowdownForAddProductToOrder (inherited from ExtendedOrderDetailGE) | Called by the OrdersEntity's AddProduct method. It is designed to be overridden when the extended Order Detail Entity needs to use information from the Order Line or Order to set values or perform other logic when a Product is added to an Order. Overrides of this method should return true if the Product should be added to the Order. A return value of false will abort the Add Product to Order process. The core implementation returns True with no other functionality.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from ExtendedOrderDetailGE) | Overloaded.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from ExtendedOrderDetailGE) |
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from ExtendedOrderDetailGE) | Overloaded. Attempts to save the Current GE data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveCancellationData (inherited from ExtendedOrderDetailGE) | Called during the Order Save process in the OrdersEntity's SaveCancellationData method. It is designed to be overridden when the extended Order Detail Entity needs to perform some work related to the cancellation of the Order Line. Return True, if the SaveCancellationData method is successful and the Order Save should contain. Return False, if the Order Save process should be aborted. When returning False, use the Error Log and/or the SetLastUeer/SetLastUser error methods to return useful information about the failure. The core implementation returns True with no other functionality.
SaveCancelledData (inherited from ExtendedOrderDetailGE) | Called during the Order Save process in the OrdersEntity's SaveCancellationData method. It is designed to be overridden when the extended Order Detail Entity needs to perform some work related to the the Order Line when the Order status has been changed to Cancelled. This is called to preform special handling on the orderline, if there is a need to changed information after the order status has been changed to cancelled. This allows, for example, the removal of a customer from a meeting detail record.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetExtendedOrderDetailRecordID (inherited from ExtendedOrderDetailGE) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
ResetFieldsLinkedToOrderLine (inherited from ExtendedOrderDetailGE) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

HousingReservation Class | Aptify.Applications.Housing Namespace


HousingReservation Constructor

Initializes a new instance of the HousingReservation class.

public HousingReservation();

See Also

HousingReservation Class | Aptify.Applications.Housing Namespace


HousingReservationDetail Class

For a list of all members of this type, see HousingReservationDetail Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
HousingReservationDetail

public class HousingReservationDetail : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Housing

Assembly: AptifyHousingObjects (in AptifyHousingObjects.dll)

See Also

HousingReservationDetail Members | Aptify.Applications.Housing Namespace


HousingReservationDetail Members

HousingReservationDetail overview

Public Instance Constructors

HousingReservationDetail Constructor Initializes a new instance of the HousingReservationDetail class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

HousingReservationDetail Class | Aptify.Applications.Housing Namespace


HousingReservationDetail Constructor

Initializes a new instance of the HousingReservationDetail class.

public HousingReservationDetail();

See Also

HousingReservationDetail Class | Aptify.Applications.Housing Namespace


HousingReservationDetail Methods

The methods of the HousingReservationDetail class are listed below. For a complete list of HousingReservationDetail class members, see the HousingReservationDetail Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

HousingReservationDetail Class | Aptify.Applications.Housing Namespace


Save Method

Aptify 5.0 Software Development Kit (SDK)

HousingReservationDetail.Save Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Save();

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean);

public override bool Save(Boolean,ref String&);

Inherited from AptifyGenericEntity.

public override bool Save(Boolean,ref String&,String);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(ref String&);

See Also

HousingReservationDetail Class | Aptify.Applications.Housing Namespace


HousingReservationDetail.Save Method (Boolean, String&)

public override bool Save(
Boolean AllowGUI,
ref String& ErrorString
);

See Also

HousingReservationDetail Class | Aptify.Applications.Housing Namespace | HousingReservationDetail.Save Overload List


HousingReservationGuest Class

For a list of all members of this type, see HousingReservationGuest Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
ExtendedOrderDetailGE
HousingReservationGuest

public class HousingReservationGuest : ExtendedOrderDetailGE

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Housing

Assembly: AptifyHousingObjects (in AptifyHousingObjects.dll)

See Also

HousingReservationGuest Members | Aptify.Applications.Housing Namespace


HousingReservationGuest Members

HousingReservationGuest overview

Public Instance Constructors

HousingReservationGuest Constructor Initializes a new instance of the HousingReservationGuest class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
OrderLineGE (inherited from ExtendedOrderDetailGE) | The OrderLineGE causes the ExtendedOrderDetailGE object to be created and then passes it a reference to itself. This reference provides access to the Order Line information through the OrderLines Entity object, the Order information.
ParentGE (inherited from ExtendedOrderDetailGE) |
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from ExtendedOrderDetailGE) |
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

AddGuestDetail |
BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
CountGuestDetails |
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
DeleteGuestDetail |
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
FlowdownForAddCancellationOrderLine (inherited from ExtendedOrderDetailGE) | Called by the OrdersEntity's AddCancellationOrderLine method. It is designed to be overridden when the extended Order Detail Entity needs to use information from the Order Line or Order to set values or perform other logic when a Cancellation Order Line is added to an Order. Overrides of this method should return true if the Cancellation Order Line should be added to the Order. A return value of false will abort the Add Cancellation Order Line process. The core implementation returns True with no other functionality.
FlowdownForAddProductToOrder (inherited from ExtendedOrderDetailGE) | Called by the OrdersEntity's AddProduct method. It is designed to be overridden when the extended Order Detail Entity needs to use information from the Order Line or Order to set values or perform other logic when a Product is added to an Order. Overrides of this method should return true if the Product should be added to the Order. A return value of false will abort the Add Product to Order process. The core implementation returns True with no other functionality.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetGuestDetail |
GetGuestDetailByID |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from ExtendedOrderDetailGE) | Overloaded.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from ExtendedOrderDetailGE) |
RefreshGuestDetails |
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveCancellationData (inherited from ExtendedOrderDetailGE) | Called during the Order Save process in the OrdersEntity's SaveCancellationData method. It is designed to be overridden when the extended Order Detail Entity needs to perform some work related to the cancellation of the Order Line. Return True, if the SaveCancellationData method is successful and the Order Save should contain. Return False, if the Order Save process should be aborted. When returning False, use the Error Log and/or the SetLastUeer/SetLastUser error methods to return useful information about the failure. The core implementation returns True with no other functionality.
SaveCancelledData (inherited from ExtendedOrderDetailGE) | Called during the Order Save process in the OrdersEntity's SaveCancellationData method. It is designed to be overridden when the extended Order Detail Entity needs to perform some work related to the the Order Line when the Order status has been changed to Cancelled. This is called to preform special handling on the orderline, if there is a need to changed information after the order status has been changed to cancelled. This allows, for example, the removal of a customer from a meeting detail record.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetExtendedOrderDetailRecordID (inherited from ExtendedOrderDetailGE) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
ResetFieldsLinkedToOrderLine (inherited from ExtendedOrderDetailGE) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

HousingReservationGuest Class | Aptify.Applications.Housing Namespace


HousingReservationGuest Constructor

Initializes a new instance of the HousingReservationGuest class.

public HousingReservationGuest();

See Also

HousingReservationGuest Class | Aptify.Applications.Housing Namespace


HousingReservationGuest Methods

The methods of the HousingReservationGuest class are listed below. For a complete list of HousingReservationGuest class members, see the HousingReservationGuest Members topic.

Public Instance Methods

AddGuestDetail |
BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
CountGuestDetails |
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
DeleteGuestDetail |
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
FlowdownForAddCancellationOrderLine (inherited from ExtendedOrderDetailGE) | Called by the OrdersEntity's AddCancellationOrderLine method. It is designed to be overridden when the extended Order Detail Entity needs to use information from the Order Line or Order to set values or perform other logic when a Cancellation Order Line is added to an Order. Overrides of this method should return true if the Cancellation Order Line should be added to the Order. A return value of false will abort the Add Cancellation Order Line process. The core implementation returns True with no other functionality.
FlowdownForAddProductToOrder (inherited from ExtendedOrderDetailGE) | Called by the OrdersEntity's AddProduct method. It is designed to be overridden when the extended Order Detail Entity needs to use information from the Order Line or Order to set values or perform other logic when a Product is added to an Order. Overrides of this method should return true if the Product should be added to the Order. A return value of false will abort the Add Product to Order process. The core implementation returns True with no other functionality.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetGuestDetail |
GetGuestDetailByID |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from ExtendedOrderDetailGE) | Overloaded.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from ExtendedOrderDetailGE) |
RefreshGuestDetails |
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveCancellationData (inherited from ExtendedOrderDetailGE) | Called during the Order Save process in the OrdersEntity's SaveCancellationData method. It is designed to be overridden when the extended Order Detail Entity needs to perform some work related to the cancellation of the Order Line. Return True, if the SaveCancellationData method is successful and the Order Save should contain. Return False, if the Order Save process should be aborted. When returning False, use the Error Log and/or the SetLastUeer/SetLastUser error methods to return useful information about the failure. The core implementation returns True with no other functionality.
SaveCancelledData (inherited from ExtendedOrderDetailGE) | Called during the Order Save process in the OrdersEntity's SaveCancellationData method. It is designed to be overridden when the extended Order Detail Entity needs to perform some work related to the the Order Line when the Order status has been changed to Cancelled. This is called to preform special handling on the orderline, if there is a need to changed information after the order status has been changed to cancelled. This allows, for example, the removal of a customer from a meeting detail record.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetExtendedOrderDetailRecordID (inherited from ExtendedOrderDetailGE) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
ResetFieldsLinkedToOrderLine (inherited from ExtendedOrderDetailGE) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

HousingReservationGuest Class | Aptify.Applications.Housing Namespace


HousingReservationGuest.AddGuestDetail Method

public AptifyGenericEntityBase AddGuestDetail();

See Also

HousingReservationGuest Class | Aptify.Applications.Housing Namespace


HousingReservationGuest.CountGuestDetails Method

public int CountGuestDetails();

See Also

HousingReservationGuest Class | Aptify.Applications.Housing Namespace


HousingReservationGuest.DeleteGuestDetail Method

public bool DeleteGuestDetail(
Int32 Item
);

See Also

HousingReservationGuest Class | Aptify.Applications.Housing Namespace


HousingReservationGuest.GetGuestDetail Method

public AptifyGenericEntityBase GetGuestDetail(
Int32 Item
);

See Also

HousingReservationGuest Class | Aptify.Applications.Housing Namespace


HousingReservationGuest.GetGuestDetailByID Method

public AptifyGenericEntityBase GetGuestDetailByID(
Int64 ID
);

See Also

HousingReservationGuest Class | Aptify.Applications.Housing Namespace


HousingReservationGuest.RefreshGuestDetails Method

public bool RefreshGuestDetails();

See Also

HousingReservationGuest Class | Aptify.Applications.Housing Namespace


Save Method

Aptify 5.0 Software Development Kit (SDK)

HousingReservationGuest.Save Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Save();

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean,ref String&);

public override bool Save(Boolean,ref String&,String);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(ref String&);

See Also

HousingReservationGuest Class | Aptify.Applications.Housing Namespace


HousingReservationGuest.Save Method (Boolean, String&, String)

public override bool Save(
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

See Also

HousingReservationGuest Class | Aptify.Applications.Housing Namespace | HousingReservationGuest.Save Overload List


HousingShared Class

Contains shared functions that are used by a variety of Housing application components

For a list of all members of this type, see HousingShared Members.

System.Object
HousingShared

public class HousingShared

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Housing

Assembly: AptifyHousingDashboardControl (in AptifyHousingDashboardControl.dll)

See Also

HousingShared Members | Aptify.Applications.Housing Namespace


HousingShared Members

HousingShared overview

Public Static Methods

AddItemToDataTable | This method provides backward compatibility for the COM-based AddItem mode that was supported by the Sheridan DataGrid. Since this feature is no longer used in the .NET UltraWinGrid, we are using a standard data-table underneath the grid and the method provides the functionality to parse an ItemString with a delimiter and apply those attributes to a new datarow. This method adds rows to a data table by splitting the provided string with the Delimiter character and puts in the resulting values into a new datarow that is added to the datatable
CreateUpdateBlockRoomRecord | This method will create or update a HousingBlockRoom record in the database. If there is already a record in the database matching the housing block ID, RoomDate, and RoomTypeID, that record will be used. If not, a new HousingBlock Room record will be created automatically.
LookupHousingBlockRoom | This method looks up a Housing Block Room record in the database and returns the ID value of that record if found. If the record is not found, the value -1 is returned.
ShowAndRecordMessage | This method will show a message to the user based on the provided parameters and will also record the provided message information to the session exception log. 09-15-08 Tamasa, Added an optional parametere for issue 7116

Public Instance Constructors

HousingShared Constructor Initializes a new instance of the HousingShared class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

HousingShared Class | Aptify.Applications.Housing Namespace


HousingShared Constructor

Initializes a new instance of the HousingShared class.

public HousingShared();

See Also

HousingShared Class | Aptify.Applications.Housing Namespace


HousingShared Methods

The methods of the HousingShared class are listed below. For a complete list of HousingShared class members, see the HousingShared Members topic.

Public Static Methods

AddItemToDataTable | This method provides backward compatibility for the COM-based AddItem mode that was supported by the Sheridan DataGrid. Since this feature is no longer used in the .NET UltraWinGrid, we are using a standard data-table underneath the grid and the method provides the functionality to parse an ItemString with a delimiter and apply those attributes to a new datarow. This method adds rows to a data table by splitting the provided string with the Delimiter character and puts in the resulting values into a new datarow that is added to the datatable
CreateUpdateBlockRoomRecord | This method will create or update a HousingBlockRoom record in the database. If there is already a record in the database matching the housing block ID, RoomDate, and RoomTypeID, that record will be used. If not, a new HousingBlock Room record will be created automatically.
LookupHousingBlockRoom | This method looks up a Housing Block Room record in the database and returns the ID value of that record if found. If the record is not found, the value -1 is returned.
ShowAndRecordMessage | This method will show a message to the user based on the provided parameters and will also record the provided message information to the session exception log. 09-15-08 Tamasa, Added an optional parametere for issue 7116

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

HousingShared Class | Aptify.Applications.Housing Namespace


HousingShared.AddItemToDataTable Method

This method provides backward compatibility for the COM-based AddItem mode that was supported by the Sheridan DataGrid. Since this feature is no longer used in the .NET UltraWinGrid, we are using a standard data-table underneath the grid and the method provides the functionality to parse an ItemString with a delimiter and apply those attributes to a new datarow. This method adds rows to a data table by splitting the provided string with the Delimiter character and puts in the resulting values into a new datarow that is added to the datatable

public static DataRow AddItemToDataTable(
DataTable dt,
String ItemString,
Char Delimiter
);

Parameters

dt
ItemString
Delimiter

Return Value

Remarks

See Also

HousingShared Class | Aptify.Applications.Housing Namespace


HousingShared.CreateUpdateBlockRoomRecord Method

This method will create or update a HousingBlockRoom record in the database. If there is already a record in the database matching the housing block ID, RoomDate, and RoomTypeID, that record will be used. If not, a new HousingBlock Room record will be created automatically.

public static long CreateUpdateBlockRoomRecord(
DataAction DataAction,
AptifyApplication Application,
String Database,
Int64 HousingBlockID,
DateTime RoomDate,
Int64 RoomTypeID,
String Price,
Int64 NumRooms,
Boolean AddToCurrentTotal
);

Parameters

DataAction
Application
Database
HousingBlockID
RoomDate
RoomTypeID
Price
NumRooms
AddToCurrentTotal

Return Value

The Record ID of the Housing Block Room record that is created/updated if the method is succesful. If the method is not succesful, -1 is returned

Remarks

See Also

HousingShared Class | Aptify.Applications.Housing Namespace


HousingShared.LookupHousingBlockRoom Method

This method looks up a Housing Block Room record in the database and returns the ID value of that record if found. If the record is not found, the value -1 is returned.

public static long LookupHousingBlockRoom(
DataAction DataAction,
String Database,
Int64 HousingBlockID,
Int64 RoomTypeID,
DateTime RoomDate
);

Parameters

DataAction
Database
HousingBlockID
RoomTypeID
RoomDate

Return Value

Remarks

See Also

HousingShared Class | Aptify.Applications.Housing Namespace


HousingShared.ShowAndRecordMessage Method

This method will show a message to the user based on the provided parameters and will also record the provided message information to the session exception log. 09-15-08 Tamasa, Added an optional parametere for issue 7116

public static void ShowAndRecordMessage(
String Message,
String MoreMessage,
String ApplicationTitle,
UserCredentials UserCredential
);

Parameters

Message
MoreMessage
ApplicationTitle
UserCredential

Remarks

See Also

HousingShared Class | Aptify.Applications.Housing Namespace


HousingTransferObject Class

Provides functionality to export data (transfer data) from the Aptify Housing management application to a format that can be sent to the hotel(s) where room blocks are reserved. This component is usable from both the HousingTransferWizard as well as at the object level through the methods provided here. In addition, this object implements IProcessComponent which provides for a Process Component that can be included in Process Flows.

For a list of all members of this type, see HousingTransferObject Members.

System.Object
HousingTransferObject

public class HousingTransferObject : IProcessComponent, IHousingTransfer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Housing

Assembly: AptifyHousingTransferObject (in AptifyHousingTransferObject.dll)

See Also

HousingTransferObject Members | Aptify.Applications.Housing Namespace


HousingTransferObject Members

HousingTransferObject overview

Public Instance Constructors

HousingTransferObject Constructor Initializes a new instance of the HousingTransferObject class.

Public Instance Properties

Application |
Blocks | List of the Housing Blocks that will be manipulated by the object
DataAction |
Database |
OutputColumns | List of the output columns that will be placed into the output file
Properties |

Public Instance Methods

Config |
DoExport | Overloaded. This overload will populate the Blocks() property from the provided Blocks parameter
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAllHousingProducts | Overloaded. This method returns a data table that contains the ID and Name fields for all of the housing products that are currently available in the system based on the current date.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPOPayTypeID | This method returns the first Purchase Order Payment Type ID in the database
GetTransferTypeID | This method returns the HousingTransferTypeID field from the Housing Block record for the provided Housing Block ID.
GetType (inherited from Object) | Gets the Type of the current instance.
Run | This process component supports the following input properties 1) Path - Required - File Path to export the files to 2) GroupByStatus - Boolean - Optional, Defaults to False - see DoExport() method for details 3) HousingBlockIDList - String - Required - List of Housing Block records by their ID. Comma-delimited list of values to be passed into the DoExport() method
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Fields

m_lHousingTransferTypeID
m_oBlocks
m_oOutputColumns
m_sExportPath

Protected Instance Methods

AddOutputColumn | This method adds an entry to the OutputColumns() property with the provided Column Name
CheckNewFile | This method is responsible for checking to see if a new file needs to be created based on the current status and housing block. If a new file is needed, this method will create the new file and pass back the FileNum to be used by the rest of the methods in the class for outputing data to the file.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetHeaderData | This method is responsible for generating a header line item for the file This method utilizes the OutputColumns() property to iterate through each specified output column in the OutputColumns list and includes the name for each such column in the output string for the header data.
GetLineItemData | This method is responsible for generating a single line of the file output based on the provided data row. This method utilizes the OutputColumns() property to iterate through each specified output column in the OutputColumns list and includes the value for each such column in the output string
GetSelectedBlockList | This method returns a string that contains a comma delimited list of the Block ID values that are stored in the Blocks() property of this object.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetupOutputColumns | This method is responsible for setting up the output columns that will be used for the output of the file data for the export.

See Also

HousingTransferObject Class | Aptify.Applications.Housing Namespace


HousingTransferObject Constructor

Initializes a new instance of the HousingTransferObject class.

public HousingTransferObject();

See Also

HousingTransferObject Class | Aptify.Applications.Housing Namespace


HousingTransferObject Fields

The fields of the HousingTransferObject class are listed below. For a complete list of HousingTransferObject class members, see the HousingTransferObject Members topic.

Protected Instance Fields

m_lHousingTransferTypeID
m_oBlocks
m_oOutputColumns
m_sExportPath

See Also

HousingTransferObject Class | Aptify.Applications.Housing Namespace


HousingTransferObject.m_lHousingTransferTypeID Field

protected m_lHousingTransferTypeID m_lHousingTransferTypeID;

See Also

HousingTransferObject Class | Aptify.Applications.Housing Namespace


HousingTransferObject.m_oBlocks Field

protected m_oBlocks m_oBlocks;

See Also

HousingTransferObject Class | Aptify.Applications.Housing Namespace


HousingTransferObject.m_oOutputColumns Field

protected m_oOutputColumns m_oOutputColumns;

See Also

HousingTransferObject Class | Aptify.Applications.Housing Namespace


HousingTransferObject.m_sExportPath Field

protected m_sExportPath m_sExportPath;

See Also

HousingTransferObject Class | Aptify.Applications.Housing Namespace


HousingTransferObject Properties

The properties of the HousingTransferObject class are listed below. For a complete list of HousingTransferObject class members, see the HousingTransferObject Members topic.

Public Instance Properties

Application |
Blocks | List of the Housing Blocks that will be manipulated by the object
DataAction |
Database |
OutputColumns | List of the output columns that will be placed into the output file
Properties |

See Also

HousingTransferObject Class | Aptify.Applications.Housing Namespace


Application Property

Aptify 5.0 Software Development Kit (SDK)

HousingTransferObject.Application Property

public virtual AptifyApplication Application {get;}

See Also

HousingTransferObject Class | Aptify.Applications.Housing Namespace


Blocks Property

Aptify 5.0 Software Development Kit (SDK)

HousingTransferObject.Blocks Property

List of the Housing Blocks that will be manipulated by the object

public virtual List<T> Blocks {get;}

Property Value

Implements

IHousingTransfer.

Remarks

See Also

HousingTransferObject Class | Aptify.Applications.Housing Namespace


DataAction Property

Aptify 5.0 Software Development Kit (SDK)

HousingTransferObject.DataAction Property

public virtual DataAction DataAction {get;}

See Also

HousingTransferObject Class | Aptify.Applications.Housing Namespace


Database Property

Aptify 5.0 Software Development Kit (SDK)

HousingTransferObject.Database Property

public virtual String Database {get;}

See Also

HousingTransferObject Class | Aptify.Applications.Housing Namespace


OutputColumns Property

Aptify 5.0 Software Development Kit (SDK)

HousingTransferObject.OutputColumns Property

List of the output columns that will be placed into the output file

public virtual List<T> OutputColumns {get;}

Property Value

Implements

IHousingTransfer.

Remarks

See Also

HousingTransferObject Class | Aptify.Applications.Housing Namespace


Properties Property

Aptify 5.0 Software Development Kit (SDK)

HousingTransferObject.Properties Property

public AptifyProperties Properties {get;}

Implements

IProcessComponent.

See Also

HousingTransferObject Class | Aptify.Applications.Housing Namespace


HousingTransferObject Methods

The methods of the HousingTransferObject class are listed below. For a complete list of HousingTransferObject class members, see the HousingTransferObject Members topic.

Public Instance Methods

Config |
DoExport | Overloaded. This overload will populate the Blocks() property from the provided Blocks parameter
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAllHousingProducts | Overloaded. This method returns a data table that contains the ID and Name fields for all of the housing products that are currently available in the system based on the current date.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPOPayTypeID | This method returns the first Purchase Order Payment Type ID in the database
GetTransferTypeID | This method returns the HousingTransferTypeID field from the Housing Block record for the provided Housing Block ID.
GetType (inherited from Object) | Gets the Type of the current instance.
Run | This process component supports the following input properties 1) Path - Required - File Path to export the files to 2) GroupByStatus - Boolean - Optional, Defaults to False - see DoExport() method for details 3) HousingBlockIDList - String - Required - List of Housing Block records by their ID. Comma-delimited list of values to be passed into the DoExport() method
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

AddOutputColumn | This method adds an entry to the OutputColumns() property with the provided Column Name
CheckNewFile | This method is responsible for checking to see if a new file needs to be created based on the current status and housing block. If a new file is needed, this method will create the new file and pass back the FileNum to be used by the rest of the methods in the class for outputing data to the file.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetHeaderData | This method is responsible for generating a header line item for the file This method utilizes the OutputColumns() property to iterate through each specified output column in the OutputColumns list and includes the name for each such column in the output string for the header data.
GetLineItemData | This method is responsible for generating a single line of the file output based on the provided data row. This method utilizes the OutputColumns() property to iterate through each specified output column in the OutputColumns list and includes the value for each such column in the output string
GetSelectedBlockList | This method returns a string that contains a comma delimited list of the Block ID values that are stored in the Blocks() property of this object.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetupOutputColumns | This method is responsible for setting up the output columns that will be used for the output of the file data for the export.

See Also

HousingTransferObject Class | Aptify.Applications.Housing Namespace


HousingTransferObject.AddOutputColumn Method

This method adds an entry to the OutputColumns() property with the provided Column Name

protected virtual void AddOutputColumn(
String ColumnName
);

Parameters

ColumnName

Remarks

See Also

HousingTransferObject Class | Aptify.Applications.Housing Namespace


HousingTransferObject.CheckNewFile Method

This method is responsible for checking to see if a new file needs to be created based on the current status and housing block. If a new file is needed, this method will create the new file and pass back the FileNum to be used by the rest of the methods in the class for outputing data to the file.

protected virtual bool CheckNewFile(
Boolean GroupByStatus,
ref Int64& CurrentHousingBlockID,
ref String& CurrentStatus,
DataRow dr,
ref Int32& FileNum,
ref String& FileName,
String FilePath
);

Parameters

GroupByStatus
CurrentHousingBlockID
CurrentStatus
dr
FileNum
FileName
FilePath

Return Value

Remarks

See Also

HousingTransferObject Class | Aptify.Applications.Housing Namespace


HousingTransferObject.Config Method

public void Config(
AptifyApplication ApplicationObject
);

Implements

IHousingTransfer.

See Also

HousingTransferObject Class | Aptify.Applications.Housing Namespace


DoExport Method

Aptify 5.0 Software Development Kit (SDK)

HousingTransferObject.DoExport Method

This method is responsible for handing the process of creating the export file(s) and outputing data to the file(s). The CheckNewFile() method is called internally in this method in the base class implementation to determine if a new file is needed based on the Housing Room Block being processed. Set the Blocks() property to contain the list of Housing Block ID values that are to be processed by this method before calling this method or call the overload that takes in a list of block id values.

Overload List

This method is responsible for handing the process of creating the export file(s) and outputing data to the file(s). The CheckNewFile() method is called internally in this method in the base class implementation to determine if a new file is needed based on the Housing Room Block being processed. Set the Blocks() property to contain the list of Housing Block ID values that are to be processed by this method before calling this method or call the overload that takes in a list of block id values.

public virtual bool DoExport(String,Boolean);

This overload will populate the Blocks() property from the provided Blocks parameter

public virtual bool DoExport(String,List<T>,Boolean);

This overload will populate the Blocks() property from the provided Blocks parameter

public virtual bool DoExport(String,String,Boolean);

See Also

HousingTransferObject Class | Aptify.Applications.Housing Namespace


HousingTransferObject.DoExport Method (String, Boolean)

This method is responsible for handing the process of creating the export file(s) and outputing data to the file(s). The CheckNewFile() method is called internally in this method in the base class implementation to determine if a new file is needed based on the Housing Room Block being processed. Set the Blocks() property to contain the list of Housing Block ID values that are to be processed by this method before calling this method or call the overload that takes in a list of block id values.

public virtual bool DoExport(
String Path,
Boolean GroupByStatus
);

Parameters

Path
Directory Location for files to be created
GroupByStatus
If this parameter is set to True, then the file output is grouped by the current status of the reservations, otherwise, standard grouping is used

Return Value

True if succesful, False otherwise

Implements

IHousingTransfer.

Remarks

See Also

HousingTransferObject Class | Aptify.Applications.Housing Namespace | HousingTransferObject.DoExport Overload List


HousingTransferObject.DoExport Method (String, List<T>, Boolean)

This overload will populate the Blocks() property from the provided Blocks parameter

public virtual bool DoExport(
String Path,
List<T> Blocks,
Boolean GroupByStatus
);

Parameters

Path
Blocks
GroupByStatus

Return Value

Implements

IHousingTransfer.

Remarks

See Also

HousingTransferObject Class | Aptify.Applications.Housing Namespace | HousingTransferObject.DoExport Overload List


HousingTransferObject.DoExport Method (String, String, Boolean)

This overload will populate the Blocks() property from the provided Blocks parameter

public virtual bool DoExport(
String Path,
String BlockIDList,
Boolean GroupByStatus
);

Parameters

Path
BlockIDList
Comma Delimited List of Housing Block ID values
GroupByStatus

Return Value

Implements

IHousingTransfer.

Remarks

See Also

HousingTransferObject Class | Aptify.Applications.Housing Namespace | HousingTransferObject.DoExport Overload List


GetAllHousingProducts Method

Aptify 5.0 Software Development Kit (SDK)

HousingTransferObject.GetAllHousingProducts Method

This method returns a data table that contains the ID and Name fields for all of the housing products that are currently available in the system based on the current date.

Overload List

This method returns a data table that contains the ID and Name fields for all of the housing products that are currently available in the system based on the current date.

public virtual DataTable GetAllHousingProducts();

This method returns a data table that contains the ID and Name fields for all of the housing products that are currently available in the system based on the EffectiveDate parameter

public virtual DataTable GetAllHousingProducts(DateTime);

See Also

HousingTransferObject Class | Aptify.Applications.Housing Namespace


HousingTransferObject.GetAllHousingProducts Method ()

This method returns a data table that contains the ID and Name fields for all of the housing products that are currently available in the system based on the current date.

public virtual DataTable GetAllHousingProducts();

Return Value

Implements

IHousingTransfer.

Remarks

See Also

HousingTransferObject Class | Aptify.Applications.Housing Namespace | HousingTransferObject.GetAllHousingProducts Overload List


HousingTransferObject.GetAllHousingProducts Method (DateTime)

This method returns a data table that contains the ID and Name fields for all of the housing products that are currently available in the system based on the EffectiveDate parameter

public virtual DataTable GetAllHousingProducts(
DateTime EffectiveDate
);

Return Value

Implements

IHousingTransfer.

Remarks

See Also

HousingTransferObject Class | Aptify.Applications.Housing Namespace | HousingTransferObject.GetAllHousingProducts Overload List


HousingTransferObject.GetHeaderData Method

This method is responsible for generating a header line item for the file This method utilizes the OutputColumns() property to iterate through each specified output column in the OutputColumns list and includes the name for each such column in the output string for the header data.

protected virtual string GetHeaderData();

Return Value

Remarks

See Also

HousingTransferObject Class | Aptify.Applications.Housing Namespace


HousingTransferObject.GetLineItemData Method

This method is responsible for generating a single line of the file output based on the provided data row. This method utilizes the OutputColumns() property to iterate through each specified output column in the OutputColumns list and includes the value for each such column in the output string

protected virtual string GetLineItemData(
DataRow dr
);

Parameters

dr

Return Value

Remarks

See Also

HousingTransferObject Class | Aptify.Applications.Housing Namespace


HousingTransferObject.GetPOPayTypeID Method

This method returns the first Purchase Order Payment Type ID in the database

public virtual long GetPOPayTypeID();

Return Value

Implements

IHousingTransfer.

Remarks

See Also

HousingTransferObject Class | Aptify.Applications.Housing Namespace


HousingTransferObject.GetSelectedBlockList Method

This method returns a string that contains a comma delimited list of the Block ID values that are stored in the Blocks() property of this object.

protected virtual string GetSelectedBlockList();

Return Value

Remarks

See Also

HousingTransferObject Class | Aptify.Applications.Housing Namespace


HousingTransferObject.GetTransferTypeID Method

This method returns the HousingTransferTypeID field from the Housing Block record for the provided Housing Block ID.

public virtual long GetTransferTypeID(
Int64 HousingBlockID
);

Parameters

HousingBlockID

Return Value

Implements

IHousingTransfer.

Remarks

See Also

HousingTransferObject Class | Aptify.Applications.Housing Namespace


HousingTransferObject.Run Method

This process component supports the following input properties 1) Path - Required - File Path to export the files to 2) GroupByStatus - Boolean - Optional, Defaults to False - see DoExport() method for details 3) HousingBlockIDList - String - Required - List of Housing Block records by their ID. Comma-delimited list of values to be passed into the DoExport() method

public string Run();

Return Value

Implements

IProcessComponent.

Remarks

See Also

HousingTransferObject Class | Aptify.Applications.Housing Namespace


HousingTransferObject.SetupOutputColumns Method

This method is responsible for setting up the output columns that will be used for the output of the file data for the export.

protected virtual void SetupOutputColumns();

Remarks

See Also

HousingTransferObject Class | Aptify.Applications.Housing Namespace


HousingTransferWizard Class

Aptify Housing Transfer Wizard Form, uses the Housing Transfer Object to export housing reservation record(s) to hotel formats.

For a list of all members of this type, see HousingTransferWizard Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
HousingTransferWizard

public class HousingTransferWizard : Form, IAptifyAction

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Housing

Assembly: AptifyHousingTransferWizard (in AptifyHousingTransferWizard.dll)

See Also

HousingTransferWizard Members | Aptify.Applications.Housing Namespace


HousingTransferWizard Members

HousingTransferWizard overview

Public Instance Constructors

HousingTransferWizard Constructor Initializes a new instance of the HousingTransferWizard class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoAction | Overloaded.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DoLocalization |
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

HousingTransferWizard Class | Aptify.Applications.Housing Namespace


HousingTransferWizard Constructor

Initializes a new instance of the HousingTransferWizard class.

public HousingTransferWizard();

See Also

HousingTransferWizard Class | Aptify.Applications.Housing Namespace


HousingTransferWizard Methods

The methods of the HousingTransferWizard class are listed below. For a complete list of HousingTransferWizard class members, see the HousingTransferWizard Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoAction | Overloaded.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DoLocalization |
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

HousingTransferWizard Class | Aptify.Applications.Housing Namespace


HousingTransferWizard.ApplySkin Method

protected virtual void ApplySkin();

See Also

HousingTransferWizard Class | Aptify.Applications.Housing Namespace


HousingTransferWizard.Config Method

public bool Config(
AptifyApplication Application,
Int64 EntityID,
Int64 ViewID,
params Object[] SelectedItems
);

See Also

HousingTransferWizard Class | Aptify.Applications.Housing Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

HousingTransferWizard.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

HousingTransferWizard Class | Aptify.Applications.Housing Namespace


HousingTransferWizard.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

HousingTransferWizard Class | Aptify.Applications.Housing Namespace | HousingTransferWizard.Dispose Overload List


DoAction Method

Aptify 5.0 Software Development Kit (SDK)

HousingTransferWizard.DoAction Method

Overload List

public void DoAction(AptifyApplication,Int64);

public void DoAction(AptifyApplication,Int64,Int64);

public void DoAction(AptifyApplication,Int64,Int64,params Object[]);

public void DoAction(AptifyApplication,Int64,params String[]);

See Also

HousingTransferWizard Class | Aptify.Applications.Housing Namespace


HousingTransferWizard.DoAction Method (AptifyApplication, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID
);

Implements

IAptifyAction.

See Also

HousingTransferWizard Class | Aptify.Applications.Housing Namespace | HousingTransferWizard.DoAction Overload List


HousingTransferWizard.DoAction Method (AptifyApplication, Int64, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID
);

Implements

IAptifyAction.

See Also

HousingTransferWizard Class | Aptify.Applications.Housing Namespace | HousingTransferWizard.DoAction Overload List


HousingTransferWizard.DoAction Method (AptifyApplication, Int64, Int64, Object[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID,
params Object[] SelectedItems
);

Implements

IAptifyAction.

See Also

HousingTransferWizard Class | Aptify.Applications.Housing Namespace | HousingTransferWizard.DoAction Overload List


HousingTransferWizard.DoAction Method (AptifyApplication, Int64, String[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
params String[] SelectedItems
);

Implements

IAptifyAction.

See Also

HousingTransferWizard Class | Aptify.Applications.Housing Namespace | HousingTransferWizard.DoAction Overload List


HousingTransferWizard.DoLocalization Method

public void DoLocalization();

See Also

HousingTransferWizard Class | Aptify.Applications.Housing Namespace


IHousingImport Interface

This interface must be implemented by objects that are used as plug-ins for the Housing Transfers Entity.

For a list of all members of this type, see IHousingImport Members.

public interface IHousingImport

Types that implement IHousingImport

Type | Description
HousingImportObject | Provides functionality to import data into the Aptify Housing management application from a format that hotels provide after they receive information on individuals that have reserved rooms within a block. This component is usable from both the HousingImportWizard as well as at the object level through the methods provided here. In addition, this object implements IProcessComponent which provides for a Process Component that can be included in Process Flows.

Remarks

Requirements

Namespace: Aptify.Applications.Housing

Assembly: AptifyHousingImportObject (in AptifyHousingImportObject.dll)

See Also

IHousingImport Members | Aptify.Applications.Housing Namespace


IHousingImport Members

IHousingImport overview

Public Instance Properties

ImportFiles List of the files that will be imported

Public Instance Methods

Config | This method must be called before any other member of the class is called.
DoImport | Overloaded. This overload of DoImport() will process a comma delimited list of files and import them
GetTransferTypeID | This method returns the HousingTransferTypeID field from the Housing Block record for the provided Housing Block ID.
LookupGuestRoom | This method will return the GuestID (Person ID) and the Housing Block ID associated with a specific Housing Reservation Detail Record.

See Also

IHousingImport Interface | Aptify.Applications.Housing Namespace


IHousingImport Properties

The properties of the IHousingImport interface are listed below. For a complete list of IHousingImport interface members, see the IHousingImport Members topic.

Public Instance Properties

ImportFiles List of the files that will be imported

See Also

IHousingImport Interface | Aptify.Applications.Housing Namespace


ImportFiles Property

Aptify 5.0 Software Development Kit (SDK)

IHousingImport.ImportFiles Property

List of the files that will be imported

List<T> ImportFiles {get;}

Property Value

Remarks

See Also

IHousingImport Interface | Aptify.Applications.Housing Namespace


IHousingImport Methods

The methods of the IHousingImport interface are listed below. For a complete list of IHousingImport interface members, see the IHousingImport Members topic.

Public Instance Methods

Config | This method must be called before any other member of the class is called.
DoImport | Overloaded. This overload of DoImport() will process a comma delimited list of files and import them
GetTransferTypeID | This method returns the HousingTransferTypeID field from the Housing Block record for the provided Housing Block ID.
LookupGuestRoom | This method will return the GuestID (Person ID) and the Housing Block ID associated with a specific Housing Reservation Detail Record.

See Also

IHousingImport Interface | Aptify.Applications.Housing Namespace


IHousingImport.Config Method

This method must be called before any other member of the class is called.

void Config(
AptifyApplication ApplicationObject
);

Parameters

ApplicationObject

Remarks

See Also

IHousingImport Interface | Aptify.Applications.Housing Namespace


DoImport Method

Aptify 5.0 Software Development Kit (SDK)

IHousingImport.DoImport Method

This routine will process the selected files and import the hotel confirmation numbers into the Housing Reservation Guest records. This overload will use the list of files existing in the ImportFiles() property and perform the import process on each such file.

Overload List

This routine will process the selected files and import the hotel confirmation numbers into the Housing Reservation Guest records. This overload will use the list of files existing in the ImportFiles() property and perform the import process on each such file.

bool DoImport(Int64);

This overload will process the specified list of import files

bool DoImport(Int64,List<T>);

This overload of DoImport() will process a comma delimited list of files and import them

bool DoImport(Int64,String);

See Also

IHousingImport Interface | Aptify.Applications.Housing Namespace


IHousingImport.DoImport Method (Int64)

This routine will process the selected files and import the hotel confirmation numbers into the Housing Reservation Guest records. This overload will use the list of files existing in the ImportFiles() property and perform the import process on each such file.

bool DoImport(
Int64 HousingTransferTypeID
);

Parameters

HousingTransferTypeID

Return Value

Remarks

See Also

IHousingImport Interface | Aptify.Applications.Housing Namespace | IHousingImport.DoImport Overload List


IHousingImport.DoImport Method (Int64, List<T>)

This overload will process the specified list of import files

bool DoImport(
Int64 HousingTransferTypeID,
List<T> ImportFiles
);

Parameters

HousingTransferTypeID
ImportFiles

Return Value

Remarks

See Also

IHousingImport Interface | Aptify.Applications.Housing Namespace | IHousingImport.DoImport Overload List


IHousingImport.DoImport Method (Int64, String)

This overload of DoImport() will process a comma delimited list of files and import them

bool DoImport(
Int64 HousingTransferTypeID,
String ImportFileList
);

Parameters

HousingTransferTypeID
ImportFileList

Return Value

Remarks

See Also

IHousingImport Interface | Aptify.Applications.Housing Namespace | IHousingImport.DoImport Overload List


IHousingImport.GetTransferTypeID Method

This method returns the HousingTransferTypeID field from the Housing Block record for the provided Housing Block ID.

long GetTransferTypeID(
Int64 HousingBlockID
);

Parameters

HousingBlockID

Return Value

Remarks

See Also

IHousingImport Interface | Aptify.Applications.Housing Namespace


IHousingImport.LookupGuestRoom Method

This method will return the GuestID (Person ID) and the Housing Block ID associated with a specific Housing Reservation Detail Record.

bool LookupGuestRoom(
Int64 DetailID,
ref Int64& GuestID,
ref Int64& BlockID
);

Parameters

DetailID
Housing Reservation Detail Record ID
GuestID
OUT Parameter: Returns the Guest ID( Persons ID Value)
BlockID
OUT Parameter: Returns the Housing Block ID linked to the Housing Reservation Detail Record

Return Value

Remarks

See Also

IHousingImport Interface | Aptify.Applications.Housing Namespace


IHousingTransfer Interface

This interface is implemented by objects that are plug-ins for the Housing Transfer Types entity

For a list of all members of this type, see IHousingTransfer Members.

public interface IHousingTransfer

Types that implement IHousingTransfer

Type | Description
HousingTransferObject | Provides functionality to export data (transfer data) from the Aptify Housing management application to a format that can be sent to the hotel(s) where room blocks are reserved. This component is usable from both the HousingTransferWizard as well as at the object level through the methods provided here. In addition, this object implements IProcessComponent which provides for a Process Component that can be included in Process Flows.

Remarks

Requirements

Namespace: Aptify.Applications.Housing

Assembly: AptifyHousingTransferObject (in AptifyHousingTransferObject.dll)

See Also

IHousingTransfer Members | Aptify.Applications.Housing Namespace


IHousingTransfer Members

IHousingTransfer overview

Public Instance Properties

Blocks | List of the Housing Blocks that will be manipulated by the object
OutputColumns | List of the output columns that will be placed into the output file

Public Instance Methods

Config | This method must be called before any other member of the class is accessed.
DoExport | Overloaded. This overload will populate the Blocks() property from the provided Blocks parameter
GetAllHousingProducts | Overloaded. This method returns a data table that contains the ID and Name fields for all of the housing products that are currently available in the system based on the current date.
GetPOPayTypeID | This method returns the first Purchase Order Payment Type ID in the database
GetTransferTypeID | This method returns the HousingTransferTypeID field from the Housing Block record for the provided Housing Block ID.

See Also

IHousingTransfer Interface | Aptify.Applications.Housing Namespace


IHousingTransfer Properties

The properties of the IHousingTransfer interface are listed below. For a complete list of IHousingTransfer interface members, see the IHousingTransfer Members topic.

Public Instance Properties

Blocks | List of the Housing Blocks that will be manipulated by the object
OutputColumns | List of the output columns that will be placed into the output file

See Also

IHousingTransfer Interface | Aptify.Applications.Housing Namespace


Blocks Property

Aptify 5.0 Software Development Kit (SDK)

IHousingTransfer.Blocks Property

List of the Housing Blocks that will be manipulated by the object

List<T> Blocks {get;}

Property Value

Remarks

See Also

IHousingTransfer Interface | Aptify.Applications.Housing Namespace


OutputColumns Property

Aptify 5.0 Software Development Kit (SDK)

IHousingTransfer.OutputColumns Property

List of the output columns that will be placed into the output file

List<T> OutputColumns {get;}

Property Value

Remarks

See Also

IHousingTransfer Interface | Aptify.Applications.Housing Namespace


IHousingTransfer Methods

The methods of the IHousingTransfer interface are listed below. For a complete list of IHousingTransfer interface members, see the IHousingTransfer Members topic.

Public Instance Methods

Config | This method must be called before any other member of the class is accessed.
DoExport | Overloaded. This overload will populate the Blocks() property from the provided Blocks parameter
GetAllHousingProducts | Overloaded. This method returns a data table that contains the ID and Name fields for all of the housing products that are currently available in the system based on the current date.
GetPOPayTypeID | This method returns the first Purchase Order Payment Type ID in the database
GetTransferTypeID | This method returns the HousingTransferTypeID field from the Housing Block record for the provided Housing Block ID.

See Also

IHousingTransfer Interface | Aptify.Applications.Housing Namespace


IHousingTransfer.Config Method

This method must be called before any other member of the class is accessed.

void Config(
AptifyApplication ApplicationObject
);

Parameters

ApplicationObject

Remarks

See Also

IHousingTransfer Interface | Aptify.Applications.Housing Namespace


DoExport Method

Aptify 5.0 Software Development Kit (SDK)

IHousingTransfer.DoExport Method

This method is responsible for handing the process of creating the export file(s) and outputing data to the file(s). The CheckNewFile() method is called internally in this method in the base class implementation to determine if a new file is needed based on the Housing Room Block being processed. Set the Blocks() property to contain the list of Housing Block ID values that are to be processed by this method before calling this method or call the overload that takes in a list of block id values.

Overload List

This method is responsible for handing the process of creating the export file(s) and outputing data to the file(s). The CheckNewFile() method is called internally in this method in the base class implementation to determine if a new file is needed based on the Housing Room Block being processed. Set the Blocks() property to contain the list of Housing Block ID values that are to be processed by this method before calling this method or call the overload that takes in a list of block id values.

bool DoExport(String,Boolean);

This overload will populate the Blocks() property from the provided Blocks parameter

bool DoExport(String,List<T>,Boolean);

This overload will populate the Blocks() property from the provided Blocks parameter

bool DoExport(String,String,Boolean);

See Also

IHousingTransfer Interface | Aptify.Applications.Housing Namespace


IHousingTransfer.DoExport Method (String, Boolean)

This method is responsible for handing the process of creating the export file(s) and outputing data to the file(s). The CheckNewFile() method is called internally in this method in the base class implementation to determine if a new file is needed based on the Housing Room Block being processed. Set the Blocks() property to contain the list of Housing Block ID values that are to be processed by this method before calling this method or call the overload that takes in a list of block id values.

bool DoExport(
String Path,
Boolean GroupByStatus
);

Parameters

Path
Directory Location for files to be created
GroupByStatus
If this parameter is set to True, then the file output is grouped by the current status of the reservations, otherwise, standard grouping is used

Return Value

True if succesful, False otherwise

Remarks

See Also

IHousingTransfer Interface | Aptify.Applications.Housing Namespace | IHousingTransfer.DoExport Overload List


IHousingTransfer.DoExport Method (String, List<T>, Boolean)

This overload will populate the Blocks() property from the provided Blocks parameter

bool DoExport(
String Path,
List<T> Blocks,
Boolean GroupByStatus
);

Parameters

Path
Blocks
GroupByStatus

Return Value

Remarks

See Also

IHousingTransfer Interface | Aptify.Applications.Housing Namespace | IHousingTransfer.DoExport Overload List


IHousingTransfer.DoExport Method (String, String, Boolean)

This overload will populate the Blocks() property from the provided Blocks parameter

bool DoExport(
String Path,
String BlockIDList,
Boolean GroupByStatus
);

Parameters

Path
BlockIDList
Comma Delimited List of Housing Block ID values
GroupByStatus

Return Value

Remarks

See Also

IHousingTransfer Interface | Aptify.Applications.Housing Namespace | IHousingTransfer.DoExport Overload List


GetAllHousingProducts Method

Aptify 5.0 Software Development Kit (SDK)

IHousingTransfer.GetAllHousingProducts Method

This method returns a data table that contains the ID and Name fields for all of the housing products that are currently available in the system based on the current date.

Overload List

This method returns a data table that contains the ID and Name fields for all of the housing products that are currently available in the system based on the current date.

DataTable GetAllHousingProducts();

This method returns a data table that contains the ID and Name fields for all of the housing products that are currently available in the system based on the EffectiveDate parameter

DataTable GetAllHousingProducts(DateTime);

See Also

IHousingTransfer Interface | Aptify.Applications.Housing Namespace


IHousingTransfer.GetAllHousingProducts Method ()

This method returns a data table that contains the ID and Name fields for all of the housing products that are currently available in the system based on the current date.

DataTable GetAllHousingProducts();

Return Value

Remarks

See Also

IHousingTransfer Interface | Aptify.Applications.Housing Namespace | IHousingTransfer.GetAllHousingProducts Overload List


IHousingTransfer.GetAllHousingProducts Method (DateTime)

This method returns a data table that contains the ID and Name fields for all of the housing products that are currently available in the system based on the EffectiveDate parameter

DataTable GetAllHousingProducts(
DateTime EffectiveDate
);

Return Value

Remarks

See Also

IHousingTransfer Interface | Aptify.Applications.Housing Namespace | IHousingTransfer.GetAllHousingProducts Overload List


IHousingTransfer.GetPOPayTypeID Method

This method returns the first Purchase Order Payment Type ID in the database

long GetPOPayTypeID();

Return Value

Remarks

See Also

IHousingTransfer Interface | Aptify.Applications.Housing Namespace


IHousingTransfer.GetTransferTypeID Method

This method returns the HousingTransferTypeID field from the Housing Block record for the provided Housing Block ID.

long GetTransferTypeID(
Int64 HousingBlockID
);

Parameters

HousingBlockID

Return Value

Remarks

See Also

IHousingTransfer Interface | Aptify.Applications.Housing Namespace


InventoryTransfer Class

Form that allows a user to transfer room inventory from one block to another

For a list of all members of this type, see InventoryTransfer Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
InventoryTransfer

public class InventoryTransfer : Form

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Housing

Assembly: AptifyHousingDashboardControl (in AptifyHousingDashboardControl.dll)

See Also

InventoryTransfer Members | Aptify.Applications.Housing Namespace


InventoryTransfer Members

InventoryTransfer overview

Public Instance Constructors

InventoryTransfer Constructor Initializes a new instance of the InventoryTransfer class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
Application |
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction |
Database |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
HousingProductID |
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config | This method must be called before any other member of this class (including ShowDialog()) are accessed.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetBlockRoomID | This method returns a Housing Block Room record ID that matches the provided Housing Block ID, Room Type ID and Room Date.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetRootBlockID | This method returns the Root Block ID and Root Block Name from a given Housing Block ID.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

InventoryTransfer Class | Aptify.Applications.Housing Namespace


InventoryTransfer Constructor

Initializes a new instance of the InventoryTransfer class.

public InventoryTransfer();

See Also

InventoryTransfer Class | Aptify.Applications.Housing Namespace


InventoryTransfer Properties

The properties of the InventoryTransfer class are listed below. For a complete list of InventoryTransfer class members, see the InventoryTransfer Members topic.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
Application |
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction |
Database |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
HousingProductID |
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

InventoryTransfer Class | Aptify.Applications.Housing Namespace


Application Property

Aptify 5.0 Software Development Kit (SDK)

InventoryTransfer.Application Property

public virtual AptifyApplication Application {get;}

See Also

InventoryTransfer Class | Aptify.Applications.Housing Namespace


DataAction Property

Aptify 5.0 Software Development Kit (SDK)

InventoryTransfer.DataAction Property

public virtual DataAction DataAction {get;}

See Also

InventoryTransfer Class | Aptify.Applications.Housing Namespace


Database Property

Aptify 5.0 Software Development Kit (SDK)

InventoryTransfer.Database Property

public virtual String Database {get;}

See Also

InventoryTransfer Class | Aptify.Applications.Housing Namespace


HousingProductID Property

Aptify 5.0 Software Development Kit (SDK)

InventoryTransfer.HousingProductID Property

public virtual Int64 HousingProductID {get;}

See Also

InventoryTransfer Class | Aptify.Applications.Housing Namespace


InventoryTransfer Methods

The methods of the InventoryTransfer class are listed below. For a complete list of InventoryTransfer class members, see the InventoryTransfer Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config | This method must be called before any other member of this class (including ShowDialog()) are accessed.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetBlockRoomID | This method returns a Housing Block Room record ID that matches the provided Housing Block ID, Room Type ID and Room Date.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetRootBlockID | This method returns the Root Block ID and Root Block Name from a given Housing Block ID.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

InventoryTransfer Class | Aptify.Applications.Housing Namespace


InventoryTransfer.Config Method

This method must be called before any other member of this class (including ShowDialog()) are accessed.

public virtual void Config(
AptifyApplication Application,
DataAction DataAction,
Int64 HousingProductID
);

Parameters

Application
DataAction
HousingProductID

Remarks

See Also

InventoryTransfer Class | Aptify.Applications.Housing Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

InventoryTransfer.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

InventoryTransfer Class | Aptify.Applications.Housing Namespace


InventoryTransfer.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

InventoryTransfer Class | Aptify.Applications.Housing Namespace | InventoryTransfer.Dispose Overload List


InventoryTransfer.GetBlockRoomID Method

This method returns a Housing Block Room record ID that matches the provided Housing Block ID, Room Type ID and Room Date.

public virtual long GetBlockRoomID(
Int64 HousingBlockID,
Int64 RoomTypeID,
DateTime RoomDate
);

Parameters

HousingBlockID
RoomTypeID
RoomDate

Return Value

Remarks

See Also

InventoryTransfer Class | Aptify.Applications.Housing Namespace


InventoryTransfer.GetRootBlockID Method

This method returns the Root Block ID and Root Block Name from a given Housing Block ID.

public virtual long GetRootBlockID(
Int64 BlockID,
ref String& BlockName
);

Parameters

BlockID
BlockName
OUT Parameter: Returns Root Block Name

Return Value

Root Block ID if succesful, -1 if failed

Remarks

See Also

InventoryTransfer Class | Aptify.Applications.Housing Namespace


InventoryTransfer.InventoryTransferType Enumeration

public enum InventoryTransfer.InventoryTransferType

Members

Member Name | Description
From |
To |
Both |

Requirements

Namespace: Aptify.Applications.Housing

Assembly: AptifyHousingDashboardControl (in AptifyHousingDashboardControl.dll)

See Also

Aptify.Applications.Housing Namespace


RecordInfo Class

For a list of all members of this type, see RecordInfo Members.

System.Object
RecordInfo

public class RecordInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Housing

Assembly: AptifyHousingDashboardControl (in AptifyHousingDashboardControl.dll)

See Also

RecordInfo Members | Aptify.Applications.Housing Namespace


RecordInfo Members

RecordInfo overview

Public Instance Constructors

RecordInfo Constructor

Public Instance Properties

ID
Name

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RecordInfo Class | Aptify.Applications.Housing Namespace


RecordInfo Constructor

public RecordInfo(
Int64 ID,
String Name
);

See Also

RecordInfo Class | Aptify.Applications.Housing Namespace


RecordInfo Properties

The properties of the RecordInfo class are listed below. For a complete list of RecordInfo class members, see the RecordInfo Members topic.

Public Instance Properties

ID
Name

See Also

RecordInfo Class | Aptify.Applications.Housing Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

RecordInfo.ID Property

public Int64 ID {get;}

See Also

RecordInfo Class | Aptify.Applications.Housing Namespace


Name Property

Aptify 5.0 Software Development Kit (SDK)

RecordInfo.Name Property

public String Name {get;}

See Also

RecordInfo Class | Aptify.Applications.Housing Namespace


Aptify.Applications.Inventory

Aptify 5.0 Software Development Kit (SDK)

Aptify.Applications.Inventory Namespace

This namespace contains objects related to Inventory Management, including Inventory Location logic, Check Inventory logic, and the Product Inventory Ledger Entry form.

Namespace hierarchy

Classes

Class | Description
InventoryLocationObject |
ProductInventoryLedgerEntry |
ProductInvLedgerEntryGeneral |


InventoryLocationObject Class

For a list of all members of this type, see InventoryLocationObject Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
InventoryLocationObject

public class InventoryLocationObject : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Inventory

Assembly: InventoryLocationObject (in InventoryLocationObject.dll)

See Also

InventoryLocationObject Members | Aptify.Applications.Inventory Namespace


InventoryLocationObject Members

InventoryLocationObject overview

Public Instance Constructors

InventoryLocationObject Constructor Initializes a new instance of the InventoryLocationObject class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

InventoryLocationObject Class | Aptify.Applications.Inventory Namespace


InventoryLocationObject Constructor

Initializes a new instance of the InventoryLocationObject class.

public InventoryLocationObject();

See Also

InventoryLocationObject Class | Aptify.Applications.Inventory Namespace


InventoryLocationObject Methods

The methods of the InventoryLocationObject class are listed below. For a complete list of InventoryLocationObject class members, see the InventoryLocationObject Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

InventoryLocationObject Class | Aptify.Applications.Inventory Namespace


Validate Method

Aptify 5.0 Software Development Kit (SDK)

InventoryLocationObject.Validate Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Validate();

public override bool Validate(ref String&);

See Also

InventoryLocationObject Class | Aptify.Applications.Inventory Namespace


InventoryLocationObject.Validate Method (String&)

public override bool Validate(
ref String& ErrorString
);

See Also

InventoryLocationObject Class | Aptify.Applications.Inventory Namespace | InventoryLocationObject.Validate Overload List


ProductInventoryLedgerEntry Class

For a list of all members of this type, see ProductInventoryLedgerEntry Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
ProductInventoryLedgerEntry

public class ProductInventoryLedgerEntry : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Inventory

Assembly: ProductInventoryLedgerEntryObject (in ProductInventoryLedgerEntryObject.dll)

See Also

ProductInventoryLedgerEntry Members | Aptify.Applications.Inventory Namespace


ProductInventoryLedgerEntry Members

ProductInventoryLedgerEntry overview

Public Instance Constructors

ProductInventoryLedgerEntry Constructor Initializes a new instance of the ProductInventoryLedgerEntry class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

ProductInventoryLedgerEntry Class | Aptify.Applications.Inventory Namespace


ProductInventoryLedgerEntry Constructor

Initializes a new instance of the ProductInventoryLedgerEntry class.

public ProductInventoryLedgerEntry();

See Also

ProductInventoryLedgerEntry Class | Aptify.Applications.Inventory Namespace


ProductInventoryLedgerEntry Methods

The methods of the ProductInventoryLedgerEntry class are listed below. For a complete list of ProductInventoryLedgerEntry class members, see the ProductInventoryLedgerEntry Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

ProductInventoryLedgerEntry Class | Aptify.Applications.Inventory Namespace


Validate Method

Aptify 5.0 Software Development Kit (SDK)

ProductInventoryLedgerEntry.Validate Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Validate();

public override bool Validate(ref String&);

See Also

ProductInventoryLedgerEntry Class | Aptify.Applications.Inventory Namespace


ProductInventoryLedgerEntry.Validate Method (String&)

public override bool Validate(
ref String& ErrorString
);

See Also

ProductInventoryLedgerEntry Class | Aptify.Applications.Inventory Namespace | ProductInventoryLedgerEntry.Validate Overload List


ProductInvLedgerEntryGeneral Class

For a list of all members of this type, see ProductInvLedgerEntryGeneral Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
ProductInvLedgerEntryGeneral

public class ProductInvLedgerEntryGeneral : FormTemplateLayout

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Inventory

Assembly: ProductInvLedgerEntryGUI (in ProductInvLedgerEntryGUI.dll)

See Also

ProductInvLedgerEntryGeneral Members | Aptify.Applications.Inventory Namespace


ProductInvLedgerEntryGeneral Members

ProductInvLedgerEntryGeneral overview

Public Instance Constructors

ProductInvLedgerEntryGeneral Constructor Initializes a new instance of the ProductInvLedgerEntryGeneral class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

m_cmbType
m_EntQuantityBalance
m_ProdInvLedgerEntryGE
m_Quantity
m_QuantityBalance
m_txtDate
m_txtDescription
m_txtUnitCost

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
m_lnkCurrencyTypeID |
m_lnkOriginalPILE |
m_lnkProdInvLedger |
ProductInventoryLedgerEntriesEntity |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormTemplateLayout) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControls |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlVisibility |
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ProductInvLedgerEntryGeneral Class | Aptify.Applications.Inventory Namespace


ProductInvLedgerEntryGeneral Constructor

Initializes a new instance of the ProductInvLedgerEntryGeneral class.

public ProductInvLedgerEntryGeneral();

See Also

ProductInvLedgerEntryGeneral Class | Aptify.Applications.Inventory Namespace


ProductInvLedgerEntryGeneral Fields

The fields of the ProductInvLedgerEntryGeneral class are listed below. For a complete list of ProductInvLedgerEntryGeneral class members, see the ProductInvLedgerEntryGeneral Members topic.

Protected Instance Fields

m_cmbType
m_EntQuantityBalance
m_ProdInvLedgerEntryGE
m_Quantity
m_QuantityBalance
m_txtDate
m_txtDescription
m_txtUnitCost

See Also

ProductInvLedgerEntryGeneral Class | Aptify.Applications.Inventory Namespace


ProductInvLedgerEntryGeneral.m_cmbType Field

protected m_cmbType m_cmbType;

See Also

ProductInvLedgerEntryGeneral Class | Aptify.Applications.Inventory Namespace


ProductInvLedgerEntryGeneral.m_EntQuantityBalance Field

protected m_EntQuantityBalance m_EntQuantityBalance;

See Also

ProductInvLedgerEntryGeneral Class | Aptify.Applications.Inventory Namespace


ProductInvLedgerEntryGeneral.m_ProdInvLedgerEntryGE Field

protected m_ProdInvLedgerEntryGE m_ProdInvLedgerEntryGE;

See Also

ProductInvLedgerEntryGeneral Class | Aptify.Applications.Inventory Namespace


ProductInvLedgerEntryGeneral.m_Quantity Field

protected m_Quantity m_Quantity;

See Also

ProductInvLedgerEntryGeneral Class | Aptify.Applications.Inventory Namespace


ProductInvLedgerEntryGeneral.m_QuantityBalance Field

protected m_QuantityBalance m_QuantityBalance;

See Also

ProductInvLedgerEntryGeneral Class | Aptify.Applications.Inventory Namespace


ProductInvLedgerEntryGeneral.m_txtDate Field

protected m_txtDate m_txtDate;

See Also

ProductInvLedgerEntryGeneral Class | Aptify.Applications.Inventory Namespace


ProductInvLedgerEntryGeneral.m_txtDescription Field

protected m_txtDescription m_txtDescription;

See Also

ProductInvLedgerEntryGeneral Class | Aptify.Applications.Inventory Namespace


ProductInvLedgerEntryGeneral.m_txtUnitCost Field

protected m_txtUnitCost m_txtUnitCost;

See Also

ProductInvLedgerEntryGeneral Class | Aptify.Applications.Inventory Namespace


ProductInvLedgerEntryGeneral Properties

The properties of the ProductInvLedgerEntryGeneral class are listed below. For a complete list of ProductInvLedgerEntryGeneral class members, see the ProductInvLedgerEntryGeneral Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
m_lnkCurrencyTypeID |
m_lnkOriginalPILE |
m_lnkProdInvLedger |
ProductInventoryLedgerEntriesEntity |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

ProductInvLedgerEntryGeneral Class | Aptify.Applications.Inventory Namespace


m_lnkCurrencyTypeID Property

Aptify 5.0 Software Development Kit (SDK)

ProductInvLedgerEntryGeneral.m_lnkCurrencyTypeID Property

protected virtual AptifyLinkBox m_lnkCurrencyTypeID {get; set;}

See Also

ProductInvLedgerEntryGeneral Class | Aptify.Applications.Inventory Namespace


m_lnkOriginalPILE Property

Aptify 5.0 Software Development Kit (SDK)

ProductInvLedgerEntryGeneral.m_lnkOriginalPILE Property

protected virtual AptifyLinkBox m_lnkOriginalPILE {get; set;}

See Also

ProductInvLedgerEntryGeneral Class | Aptify.Applications.Inventory Namespace


m_lnkProdInvLedger Property

Aptify 5.0 Software Development Kit (SDK)

ProductInvLedgerEntryGeneral.m_lnkProdInvLedger Property

protected virtual AptifyLinkBox m_lnkProdInvLedger {get; set;}

See Also

ProductInvLedgerEntryGeneral Class | Aptify.Applications.Inventory Namespace


ProductInventoryLedgerEntriesEntity Property

Aptify 5.0 Software Development Kit (SDK)

ProductInvLedgerEntryGeneral.ProductInventoryLedgerEntriesEntity Property

protected ProductInventoryLedgerEntry ProductInventoryLedgerEntriesEntity {get;}

See Also

ProductInvLedgerEntryGeneral Class | Aptify.Applications.Inventory Namespace


ProductInvLedgerEntryGeneral Methods

The methods of the ProductInvLedgerEntryGeneral class are listed below. For a complete list of ProductInvLedgerEntryGeneral class members, see the ProductInvLedgerEntryGeneral Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormTemplateLayout) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControls |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlVisibility |
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ProductInvLedgerEntryGeneral Class | Aptify.Applications.Inventory Namespace


ProductInvLedgerEntryGeneral.FindControls Method

protected virtual void FindControls(
String FormTemplateLayoutName
);

See Also

ProductInvLedgerEntryGeneral Class | Aptify.Applications.Inventory Namespace


ProductInvLedgerEntryGeneral.OnFormTemplateLoaded Method

protected override void OnFormTemplateLoaded(
FormTemplateLayout.FormTemplateLoadedEventArgs e
);

See Also

ProductInvLedgerEntryGeneral Class | Aptify.Applications.Inventory Namespace


ProductInvLedgerEntryGeneral.OnRefresh Method

protected override void OnRefresh();

Implements

IFormComponent.

See Also

ProductInvLedgerEntryGeneral Class | Aptify.Applications.Inventory Namespace


ProductInvLedgerEntryGeneral.SetControlVisibility Method

protected virtual void SetControlVisibility();

See Also

ProductInvLedgerEntryGeneral Class | Aptify.Applications.Inventory Namespace


Aptify.Applications.InventoryManagement

Aptify 5.0 Software Development Kit (SDK)

Aptify.Applications.InventoryManagement Namespace

This namespace contains objects that correspond to Aptify's standard inventory wizards: the Bulk Inventory Transfer wizard, the Inventory Return wizard, and the Product Cost Adjustment wizard.

Namespace hierarchy

Classes

Class | Description
BulkInventoryTransferWizard |
BulkInventoryTransferWizardException | Thrown when an error occurs during the lifetime of the BulkInventoryTransferWizard.
InventoryControl |
InventoryManager | Provides Inventory Related functionality used by the ProductCostAdjustmentWizardForm.
InventoryReturnWizardException | Thrown when an error occurs in the InventoryReturnWizardForm.
InventoryReturnWizardForm | This class contains the Business logic used during the Inventory Return process.
InventoryTransfer |
InvTransferForm |
ProductCostAdjustmentWizardException | Thrown when an exception occurs during the life time of the ProductCostAdjustmentWizardForm.
ProductCostAdjustmentWizardForm |

Interfaces

Interface | Description
IInventoryManager | Provides Inventory Related functionality used by the ProductCostAdjustmentWizardForm.
IInventoryTransfer |

Delegates

Delegate | Description
InventoryControl.ClickInventoryLocationEventHandler |
InventoryControl.DblClickInventoryLocationEventHandler |
InventoryControl.InventoryLocationSelectedEventHandler |


BulkInventoryTransferWizard Class

For a list of all members of this type, see BulkInventoryTransferWizard Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
BulkInventoryTransferWizard

public class BulkInventoryTransferWizard : Form, IAptifyAction

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.InventoryManagement

Assembly: AptifyBulkInventoryTransferWizard (in AptifyBulkInventoryTransferWizard.dll)

See Also

BulkInventoryTransferWizard Members | Aptify.Applications.InventoryManagement Namespace


BulkInventoryTransferWizard Members

BulkInventoryTransferWizard overview

Public Instance Constructors

BulkInventoryTransferWizard Constructor Initializes a new instance of the BulkInventoryTransferWizard class.

Public Instance Fields

CmDlg1Save
OK
ToolTip

Public Instance Properties

_optInvLoc_0 |
_optInvLoc_1 |
_picPanels_0 |
_picPanels_1 |
_picPanels_2 |
AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
cmdDeselectAll |
cmdPrint |
cmdReset |
cmdSave |
cmdSelectAll |
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
dbgInvLoc |
dbgInvLocUse |
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
frameInvLoc |
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
Label1 |
Label2 |
Label3 |
Label4 |
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
picGraphic |
picOutput |
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
txtOutput |
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |
Wizard |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoAction | Overloaded.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DoLocalization |
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

BulkInventoryTransferWizard Class | Aptify.Applications.InventoryManagement Namespace


BulkInventoryTransferWizard Constructor

Initializes a new instance of the BulkInventoryTransferWizard class.

public BulkInventoryTransferWizard();

See Also

BulkInventoryTransferWizard Class | Aptify.Applications.InventoryManagement Namespace


BulkInventoryTransferWizard Fields

The fields of the BulkInventoryTransferWizard class are listed below. For a complete list of BulkInventoryTransferWizard class members, see the BulkInventoryTransferWizard Members topic.

Public Instance Fields

CmDlg1Save
OK
ToolTip

See Also

BulkInventoryTransferWizard Class | Aptify.Applications.InventoryManagement Namespace


BulkInventoryTransferWizard.CmDlg1Save Field

public CmDlg1Save CmDlg1Save;

See Also

BulkInventoryTransferWizard Class | Aptify.Applications.InventoryManagement Namespace


BulkInventoryTransferWizard.OK Field

public OK OK;

See Also

BulkInventoryTransferWizard Class | Aptify.Applications.InventoryManagement Namespace


BulkInventoryTransferWizard.ToolTip Field

public ToolTip ToolTip;

See Also

BulkInventoryTransferWizard Class | Aptify.Applications.InventoryManagement Namespace


BulkInventoryTransferWizard Properties

The properties of the BulkInventoryTransferWizard class are listed below. For a complete list of BulkInventoryTransferWizard class members, see the BulkInventoryTransferWizard Members topic.

Public Instance Properties

_optInvLoc_0 |
_optInvLoc_1 |
_picPanels_0 |
_picPanels_1 |
_picPanels_2 |
AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
cmdDeselectAll |
cmdPrint |
cmdReset |
cmdSave |
cmdSelectAll |
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
dbgInvLoc |
dbgInvLocUse |
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
frameInvLoc |
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
Label1 |
Label2 |
Label3 |
Label4 |
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
picGraphic |
picOutput |
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
txtOutput |
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |
Wizard |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

BulkInventoryTransferWizard Class | Aptify.Applications.InventoryManagement Namespace


_optInvLoc_0 Property

Aptify 5.0 Software Development Kit (SDK)

BulkInventoryTransferWizard._optInvLoc_0 Property

public virtual RadioButton _optInvLoc_0 {get; set;}

See Also

BulkInventoryTransferWizard Class | Aptify.Applications.InventoryManagement Namespace


_optInvLoc_1 Property

Aptify 5.0 Software Development Kit (SDK)

BulkInventoryTransferWizard._optInvLoc_1 Property

public virtual RadioButton _optInvLoc_1 {get; set;}

See Also

BulkInventoryTransferWizard Class | Aptify.Applications.InventoryManagement Namespace


_picPanels_0 Property

Aptify 5.0 Software Development Kit (SDK)

BulkInventoryTransferWizard._picPanels_0 Property

public virtual Panel _picPanels_0 {get; set;}

See Also

BulkInventoryTransferWizard Class | Aptify.Applications.InventoryManagement Namespace


_picPanels_1 Property

Aptify 5.0 Software Development Kit (SDK)

BulkInventoryTransferWizard._picPanels_1 Property

public virtual Panel _picPanels_1 {get; set;}

See Also

BulkInventoryTransferWizard Class | Aptify.Applications.InventoryManagement Namespace


_picPanels_2 Property

Aptify 5.0 Software Development Kit (SDK)

BulkInventoryTransferWizard._picPanels_2 Property

public virtual Panel _picPanels_2 {get; set;}

See Also

BulkInventoryTransferWizard Class | Aptify.Applications.InventoryManagement Namespace


cmdDeselectAll Property

Aptify 5.0 Software Development Kit (SDK)

BulkInventoryTransferWizard.cmdDeselectAll Property

public virtual Button cmdDeselectAll {get; set;}

See Also

BulkInventoryTransferWizard Class | Aptify.Applications.InventoryManagement Namespace


cmdPrint Property

Aptify 5.0 Software Development Kit (SDK)

BulkInventoryTransferWizard.cmdPrint Property

public virtual Button cmdPrint {get; set;}

See Also

BulkInventoryTransferWizard Class | Aptify.Applications.InventoryManagement Namespace


cmdReset Property

Aptify 5.0 Software Development Kit (SDK)

BulkInventoryTransferWizard.cmdReset Property

public virtual Button cmdReset {get; set;}

See Also

BulkInventoryTransferWizard Class | Aptify.Applications.InventoryManagement Namespace


cmdSave Property

Aptify 5.0 Software Development Kit (SDK)

BulkInventoryTransferWizard.cmdSave Property

public virtual Button cmdSave {get; set;}

See Also

BulkInventoryTransferWizard Class | Aptify.Applications.InventoryManagement Namespace


cmdSelectAll Property

Aptify 5.0 Software Development Kit (SDK)

BulkInventoryTransferWizard.cmdSelectAll Property

public virtual Button cmdSelectAll {get; set;}

See Also

BulkInventoryTransferWizard Class | Aptify.Applications.InventoryManagement Namespace


dbgInvLoc Property

Aptify 5.0 Software Development Kit (SDK)

BulkInventoryTransferWizard.dbgInvLoc Property

public virtual C1FlexGrid dbgInvLoc {get; set;}

See Also

BulkInventoryTransferWizard Class | Aptify.Applications.InventoryManagement Namespace


dbgInvLocUse Property

Aptify 5.0 Software Development Kit (SDK)

BulkInventoryTransferWizard.dbgInvLocUse Property

public virtual C1FlexGrid dbgInvLocUse {get; set;}

See Also

BulkInventoryTransferWizard Class | Aptify.Applications.InventoryManagement Namespace


frameInvLoc Property

Aptify 5.0 Software Development Kit (SDK)

BulkInventoryTransferWizard.frameInvLoc Property

public virtual GroupBox frameInvLoc {get; set;}

See Also

BulkInventoryTransferWizard Class | Aptify.Applications.InventoryManagement Namespace


Label1 Property

Aptify 5.0 Software Development Kit (SDK)

BulkInventoryTransferWizard.Label1 Property

public virtual Label Label1 {get; set;}

See Also

BulkInventoryTransferWizard Class | Aptify.Applications.InventoryManagement Namespace


Label2 Property

Aptify 5.0 Software Development Kit (SDK)

BulkInventoryTransferWizard.Label2 Property

public virtual Label Label2 {get; set;}

See Also

BulkInventoryTransferWizard Class | Aptify.Applications.InventoryManagement Namespace


Label3 Property

Aptify 5.0 Software Development Kit (SDK)

BulkInventoryTransferWizard.Label3 Property

public virtual Label Label3 {get; set;}

See Also

BulkInventoryTransferWizard Class | Aptify.Applications.InventoryManagement Namespace


Label4 Property

Aptify 5.0 Software Development Kit (SDK)

BulkInventoryTransferWizard.Label4 Property

public virtual Label Label4 {get; set;}

See Also

BulkInventoryTransferWizard Class | Aptify.Applications.InventoryManagement Namespace


picGraphic Property

Aptify 5.0 Software Development Kit (SDK)

BulkInventoryTransferWizard.picGraphic Property

public virtual PictureBox picGraphic {get; set;}

See Also

BulkInventoryTransferWizard Class | Aptify.Applications.InventoryManagement Namespace


picOutput Property

Aptify 5.0 Software Development Kit (SDK)

BulkInventoryTransferWizard.picOutput Property

public virtual Panel picOutput {get; set;}

See Also

BulkInventoryTransferWizard Class | Aptify.Applications.InventoryManagement Namespace


txtOutput Property

Aptify 5.0 Software Development Kit (SDK)

BulkInventoryTransferWizard.txtOutput Property

public virtual TextBox txtOutput {get; set;}

See Also

BulkInventoryTransferWizard Class | Aptify.Applications.InventoryManagement Namespace


Wizard Property

Aptify 5.0 Software Development Kit (SDK)

BulkInventoryTransferWizard.Wizard Property

public virtual WizardControl Wizard {get; set;}

See Also

BulkInventoryTransferWizard Class | Aptify.Applications.InventoryManagement Namespace


BulkInventoryTransferWizard Methods

The methods of the BulkInventoryTransferWizard class are listed below. For a complete list of BulkInventoryTransferWizard class members, see the BulkInventoryTransferWizard Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoAction | Overloaded.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DoLocalization |
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

BulkInventoryTransferWizard Class | Aptify.Applications.InventoryManagement Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

BulkInventoryTransferWizard.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

BulkInventoryTransferWizard Class | Aptify.Applications.InventoryManagement Namespace


BulkInventoryTransferWizard.Dispose Method (Boolean)

protected override void Dispose(
Boolean Disposing
);

See Also

BulkInventoryTransferWizard Class | Aptify.Applications.InventoryManagement Namespace | BulkInventoryTransferWizard.Dispose Overload List


DoAction Method

Aptify 5.0 Software Development Kit (SDK)

BulkInventoryTransferWizard.DoAction Method

Overload List

public void DoAction(AptifyApplication,Int64);

public void DoAction(AptifyApplication,Int64,Int64);

public void DoAction(AptifyApplication,Int64,Int64,params Object[]);

public void DoAction(AptifyApplication,Int64,params String[]);

See Also

BulkInventoryTransferWizard Class | Aptify.Applications.InventoryManagement Namespace


BulkInventoryTransferWizard.DoAction Method (AptifyApplication, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID
);

Implements

IAptifyAction.

See Also

BulkInventoryTransferWizard Class | Aptify.Applications.InventoryManagement Namespace | BulkInventoryTransferWizard.DoAction Overload List


BulkInventoryTransferWizard.DoAction Method (AptifyApplication, Int64, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID
);

Implements

IAptifyAction.

See Also

BulkInventoryTransferWizard Class | Aptify.Applications.InventoryManagement Namespace | BulkInventoryTransferWizard.DoAction Overload List


BulkInventoryTransferWizard.DoAction Method (AptifyApplication, Int64, Int64, Object[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID,
params Object[] SelectedItems
);

Implements

IAptifyAction.

See Also

BulkInventoryTransferWizard Class | Aptify.Applications.InventoryManagement Namespace | BulkInventoryTransferWizard.DoAction Overload List


BulkInventoryTransferWizard.DoAction Method (AptifyApplication, Int64, String[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
params String[] SelectedItems
);

Implements

IAptifyAction.

See Also

BulkInventoryTransferWizard Class | Aptify.Applications.InventoryManagement Namespace | BulkInventoryTransferWizard.DoAction Overload List


BulkInventoryTransferWizard.DoLocalization Method

public void DoLocalization();

See Also

BulkInventoryTransferWizard Class | Aptify.Applications.InventoryManagement Namespace


BulkInventoryTransferWizardException Class

Thrown when an error occurs during the lifetime of the BulkInventoryTransferWizard.

For a list of all members of this type, see BulkInventoryTransferWizardException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
BulkInventoryTransferWizardException

public class BulkInventoryTransferWizardException : BaseApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.InventoryManagement

Assembly: AptifyBulkInventoryTransferWizard (in AptifyBulkInventoryTransferWizard.dll)

See Also

BulkInventoryTransferWizardException Members | Aptify.Applications.InventoryManagement Namespace


BulkInventoryTransferWizardException Members

BulkInventoryTransferWizardException overview

Public Instance Constructors

BulkInventoryTransferWizardException Overloaded. Initializes a new instance of the BulkInventoryTransferWizardException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from BaseApplicationException) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BulkInventoryTransferWizardException Class | Aptify.Applications.InventoryManagement Namespace


BulkInventoryTransferWizardException Constructor

Initializes a new instance of the BulkInventoryTransferWizardException class.

Overload List

Initializes a new instance of the BulkInventoryTransferWizardException class.

public BulkInventoryTransferWizardException();

public BulkInventoryTransferWizardException(String);

public BulkInventoryTransferWizardException(String,Exception);

See Also

BulkInventoryTransferWizardException Class | Aptify.Applications.InventoryManagement Namespace


BulkInventoryTransferWizardException Constructor ()

Initializes a new instance of the BulkInventoryTransferWizardException class.

public BulkInventoryTransferWizardException();

See Also

BulkInventoryTransferWizardException Class | Aptify.Applications.InventoryManagement Namespace | BulkInventoryTransferWizardException Constructor Overload List


BulkInventoryTransferWizardException Constructor (String)

public BulkInventoryTransferWizardException(
String Message
);

See Also

BulkInventoryTransferWizardException Class | Aptify.Applications.InventoryManagement Namespace | BulkInventoryTransferWizardException Constructor Overload List


BulkInventoryTransferWizardException Constructor (String, Exception)

public BulkInventoryTransferWizardException(
String Message,
Exception InnerException
);

See Also

BulkInventoryTransferWizardException Class | Aptify.Applications.InventoryManagement Namespace | BulkInventoryTransferWizardException Constructor Overload List


IInventoryManager Interface

Provides Inventory Related functionality used by the ProductCostAdjustmentWizardForm.

For a list of all members of this type, see IInventoryManager Members.

public interface IInventoryManager

Types that implement IInventoryManager

Type | Description
InventoryManager | Provides Inventory Related functionality used by the ProductCostAdjustmentWizardForm.

Remarks

Requirements

Namespace: Aptify.Applications.InventoryManagement

Assembly: AptifyProductCostAdjustmentWizard (in AptifyProductCostAdjustmentWizard.dll)

See Also

IInventoryManager Members | Aptify.Applications.InventoryManagement Namespace


IInventoryManager Members

IInventoryManager overview

Public Instance Methods

Config | Configures the InventoryManager object before it is used.
GenerateUnitCostAdjustment | This is function generates PILE records necessary to change the unit cost of a PILE.

See Also

IInventoryManager Interface | Aptify.Applications.InventoryManagement Namespace


IInventoryManager Methods

The methods of the IInventoryManager interface are listed below. For a complete list of IInventoryManager interface members, see the IInventoryManager Members topic.

Public Instance Methods

Config | Configures the InventoryManager object before it is used.
GenerateUnitCostAdjustment | This is function generates PILE records necessary to change the unit cost of a PILE.

See Also

IInventoryManager Interface | Aptify.Applications.InventoryManagement Namespace


IInventoryManager.Config Method

Configures the InventoryManager object before it is used.

void Config(
AptifyApplication ApplicationObject
);

Parameters

ApplicationObject

Remarks

See Also

IInventoryManager Interface | Aptify.Applications.InventoryManagement Namespace


IInventoryManager.GenerateUnitCostAdjustment Method

This is function generates PILE records necessary to change the unit cost of a PILE.

long[] GenerateUnitCostAdjustment(
Int64 PILEID,
Decimal NewUnitCost,
DateTime EffectiveDate,
Int64 ProductID,
String TransactionID
);

Parameters

PILEID
NewUnitCost
EffectiveDate
ProductID
TransactionID

Return Value

Remarks

The calling code expects 3 ids to be returned in the array. ID(0)=Unit Cost Adjustment Scheduled Transaction,ID(1)=Adjustment Pile,ID(2)=Purchase Pile

See Also

IInventoryManager Interface | Aptify.Applications.InventoryManagement Namespace


IInventoryTransfer Interface

For a list of all members of this type, see IInventoryTransfer Members.

public interface IInventoryTransfer

Types that implement IInventoryTransfer

Type | Description
InventoryTransfer |

Requirements

Namespace: Aptify.Applications.InventoryManagement

Assembly: IInventoryTransfer (in IInventoryTransfer.dll)

See Also

IInventoryTransfer Members | Aptify.Applications.InventoryManagement Namespace


IInventoryTransfer Members

IInventoryTransfer overview

Public Instance Methods

Config
TransferInventory

See Also

IInventoryTransfer Interface | Aptify.Applications.InventoryManagement Namespace


IInventoryTransfer Methods

The methods of the IInventoryTransfer interface are listed below. For a complete list of IInventoryTransfer interface members, see the IInventoryTransfer Members topic.

Public Instance Methods

Config
TransferInventory

See Also

IInventoryTransfer Interface | Aptify.Applications.InventoryManagement Namespace


IInventoryTransfer.Config Method

bool Config(
AptifyApplication ApplicationObject
);

See Also

IInventoryTransfer Interface | Aptify.Applications.InventoryManagement Namespace


IInventoryTransfer.TransferInventory Method

bool TransferInventory(
Int64 InventoryLocationSourceID,
Int64 InventoryLocationDestinationID,
Int64 ProductID,
Double Quantity,
Boolean ShowErrors
);

See Also

IInventoryTransfer Interface | Aptify.Applications.InventoryManagement Namespace


InventoryControl Class

For a list of all members of this type, see InventoryControl Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
InventoryControl

public class InventoryControl : FormComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.InventoryManagement

Assembly: InventoryControl (in InventoryControl.dll)

See Also

InventoryControl Members | Aptify.Applications.InventoryManagement Namespace


InventoryControl Members

InventoryControl overview

Public Instance Constructors

InventoryControl Constructor Initializes a new instance of the InventoryControl class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowFulfillOnly |
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
DoNotAllowTransfer |
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InventoryLocationID |
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
OrganizationFilter |
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductFilter |
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DoPopulateControl |
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClickInventoryLocation |
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
DblClickInventoryLocation |
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
InventoryLocationSelected |
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateContext (inherited from FormComponent) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormComponent) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormComponent) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormComponent) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

InventoryControl Class | Aptify.Applications.InventoryManagement Namespace


InventoryControl Constructor

Initializes a new instance of the InventoryControl class.

public InventoryControl();

See Also

InventoryControl Class | Aptify.Applications.InventoryManagement Namespace


InventoryControl Properties

The properties of the InventoryControl class are listed below. For a complete list of InventoryControl class members, see the InventoryControl Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowFulfillOnly |
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
DoNotAllowTransfer |
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InventoryLocationID |
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
OrganizationFilter |
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductFilter |
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateContext (inherited from FormComponent) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

InventoryControl Class | Aptify.Applications.InventoryManagement Namespace


AllowFulfillOnly Property

Aptify 5.0 Software Development Kit (SDK)

InventoryControl.AllowFulfillOnly Property

public Boolean AllowFulfillOnly {get; set;}

See Also

InventoryControl Class | Aptify.Applications.InventoryManagement Namespace


DoNotAllowTransfer Property

Aptify 5.0 Software Development Kit (SDK)

InventoryControl.DoNotAllowTransfer Property

public Boolean DoNotAllowTransfer {get; set;}

See Also

InventoryControl Class | Aptify.Applications.InventoryManagement Namespace


InventoryLocationID Property

Aptify 5.0 Software Development Kit (SDK)

InventoryControl.InventoryLocationID Property

public Int64 InventoryLocationID {get;}

See Also

InventoryControl Class | Aptify.Applications.InventoryManagement Namespace


OrganizationFilter Property

Aptify 5.0 Software Development Kit (SDK)

InventoryControl.OrganizationFilter Property

public String OrganizationFilter {get; set;}

See Also

InventoryControl Class | Aptify.Applications.InventoryManagement Namespace


ProductFilter Property

Aptify 5.0 Software Development Kit (SDK)

InventoryControl.ProductFilter Property

public String ProductFilter {get; set;}

See Also

InventoryControl Class | Aptify.Applications.InventoryManagement Namespace


InventoryControl Methods

The methods of the InventoryControl class are listed below. For a complete list of InventoryControl class members, see the InventoryControl Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DoPopulateControl |
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormComponent) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormComponent) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormComponent) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

InventoryControl Class | Aptify.Applications.InventoryManagement Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

InventoryControl.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

InventoryControl Class | Aptify.Applications.InventoryManagement Namespace


InventoryControl.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

InventoryControl Class | Aptify.Applications.InventoryManagement Namespace | InventoryControl.Dispose Overload List


InventoryControl.DoPopulateControl Method

public bool DoPopulateControl();

See Also

InventoryControl Class | Aptify.Applications.InventoryManagement Namespace


InventoryControl.OnFormComponentConfig Method

protected override void OnFormComponentConfig(
AptifyFormTemplateContext FormTemplateContext
);

Implements

IFormComponent.

See Also

InventoryControl Class | Aptify.Applications.InventoryManagement Namespace


OnShow Method

Aptify 5.0 Software Development Kit (SDK)

InventoryControl.OnShow Method

Overload List

Inherited from FormComponent.

protected virtual void OnShow();

protected override void OnShow(Boolean);

See Also

InventoryControl Class | Aptify.Applications.InventoryManagement Namespace


InventoryControl.OnShow Method (Boolean)

protected override void OnShow(
Boolean Refresh
);

Implements

IFormComponent.

See Also

InventoryControl Class | Aptify.Applications.InventoryManagement Namespace | InventoryControl.OnShow Overload List


InventoryControl.Refresh Method

public override void Refresh();

See Also

InventoryControl Class | Aptify.Applications.InventoryManagement Namespace


InventoryControl Events

The events of the InventoryControl class are listed below. For a complete list of InventoryControl class members, see the InventoryControl Members topic.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClickInventoryLocation |
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
DblClickInventoryLocation |
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
InventoryLocationSelected |
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

InventoryControl Class | Aptify.Applications.InventoryManagement Namespace


InventoryControl.InventoryControl.ClickInventoryLocationEventHandler Event

public event InventoryControl.ClickInventoryLocationEventHandler ClickInventoryLocation;

See Also

InventoryControl Class | Aptify.Applications.InventoryManagement Namespace


InventoryControl.InventoryControl.DblClickInventoryLocationEventHandler Event

public event InventoryControl.DblClickInventoryLocationEventHandler DblClickInventoryLocation;

See Also

InventoryControl Class | Aptify.Applications.InventoryManagement Namespace


InventoryControl.InventoryControl.InventoryLocationSelectedEventHandler Event

public event InventoryControl.InventoryLocationSelectedEventHandler InventoryLocationSelected;

See Also

InventoryControl Class | Aptify.Applications.InventoryManagement Namespace


InventoryControl.ClickInventoryLocationEventHandler Delegate

public delegate void InventoryControl.ClickInventoryLocationEventHandler();

Requirements

Namespace: Aptify.Applications.InventoryManagement

Assembly: InventoryControl (in InventoryControl.dll)

See Also

Aptify.Applications.InventoryManagement Namespace


InventoryControl.DblClickInventoryLocationEventHandler Delegate

public delegate void InventoryControl.DblClickInventoryLocationEventHandler();

Requirements

Namespace: Aptify.Applications.InventoryManagement

Assembly: InventoryControl (in InventoryControl.dll)

See Also

Aptify.Applications.InventoryManagement Namespace


InventoryControl.InventoryLocationSelectedEventHandler Delegate

public delegate void InventoryControl.InventoryLocationSelectedEventHandler();

Requirements

Namespace: Aptify.Applications.InventoryManagement

Assembly: InventoryControl (in InventoryControl.dll)

See Also

Aptify.Applications.InventoryManagement Namespace


InventoryManager Class

Provides Inventory Related functionality used by the ProductCostAdjustmentWizardForm.

For a list of all members of this type, see InventoryManager Members.

System.Object
InventoryManager

public class InventoryManager : IInventoryManager

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.InventoryManagement

Assembly: AptifyInventoryManagement (in AptifyInventoryManagement.dll)

See Also

InventoryManager Members | Aptify.Applications.InventoryManagement Namespace


InventoryManager Members

InventoryManager overview

Public Instance Constructors

InventoryManager Constructor Initializes a new instance of the InventoryManager class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GenerateUnitCostAdjustment | This is function generates PILE records necessary to change the unit cost of a PILE.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

InventoryManager Class | Aptify.Applications.InventoryManagement Namespace


InventoryManager Constructor

Initializes a new instance of the InventoryManager class.

public InventoryManager();

See Also

InventoryManager Class | Aptify.Applications.InventoryManagement Namespace


InventoryManager Methods

The methods of the InventoryManager class are listed below. For a complete list of InventoryManager class members, see the InventoryManager Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GenerateUnitCostAdjustment | This is function generates PILE records necessary to change the unit cost of a PILE.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

InventoryManager Class | Aptify.Applications.InventoryManagement Namespace


InventoryManager.GenerateUnitCostAdjustment Method

This is function generates PILE records necessary to change the unit cost of a PILE.

public long[] GenerateUnitCostAdjustment(
Int64 PILEID,
Decimal NewUnitCost,
DateTime EffectiveDate,
Int64 ProductID,
String TransactionID
);

Parameters

PILEID
NewUnitCost
EffectiveDate
ProductID
TransactionID

Return Value

returns an array of longs that correspond to the IDs of the new records created for the adjustment. 0=Scheduled Transaction ID,1=Adjustment PILE ID,2= Purchase PILE ID

Implements

IInventoryManager.

Remarks

This includes an adjustment PILE to reduce the number of units in the original PILE where the unit cost will be changed and creating a new PILE with the remaining units in the PILE at the new unit cost. A scheduled transaction will also be generated to adjust COGS and inventory appropriately.

See Also

InventoryManager Class | Aptify.Applications.InventoryManagement Namespace


InventoryReturnWizardException Class

Thrown when an error occurs in the InventoryReturnWizardForm.

For a list of all members of this type, see InventoryReturnWizardException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
InventoryReturnWizardException

public class InventoryReturnWizardException : BaseApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.InventoryManagement

Assembly: AptifyInventoryReturnWizard (in AptifyInventoryReturnWizard.dll)

See Also

InventoryReturnWizardException Members | Aptify.Applications.InventoryManagement Namespace


InventoryReturnWizardException Members

InventoryReturnWizardException overview

Public Instance Constructors

InventoryReturnWizardException Overloaded. Initializes a new instance of the InventoryReturnWizardException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from BaseApplicationException) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

InventoryReturnWizardException Class | Aptify.Applications.InventoryManagement Namespace


InventoryReturnWizardException Constructor

Initializes a new instance of the InventoryReturnWizardException class.

Overload List

Initializes a new instance of the InventoryReturnWizardException class.

public InventoryReturnWizardException();

public InventoryReturnWizardException(String);

public InventoryReturnWizardException(String,Exception);

See Also

InventoryReturnWizardException Class | Aptify.Applications.InventoryManagement Namespace


InventoryReturnWizardException Constructor ()

Initializes a new instance of the InventoryReturnWizardException class.

public InventoryReturnWizardException();

See Also

InventoryReturnWizardException Class | Aptify.Applications.InventoryManagement Namespace | InventoryReturnWizardException Constructor Overload List


InventoryReturnWizardException Constructor (String)

public InventoryReturnWizardException(
String Message
);

See Also

InventoryReturnWizardException Class | Aptify.Applications.InventoryManagement Namespace | InventoryReturnWizardException Constructor Overload List


InventoryReturnWizardException Constructor (String, Exception)

public InventoryReturnWizardException(
String Message,
Exception InnerException
);

See Also

InventoryReturnWizardException Class | Aptify.Applications.InventoryManagement Namespace | InventoryReturnWizardException Constructor Overload List


InventoryReturnWizardForm Class

This class contains the Business logic used during the Inventory Return process.

For a list of all members of this type, see InventoryReturnWizardForm Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
InventoryReturnWizardForm

public class InventoryReturnWizardForm : Form, IAptifyAction

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.InventoryManagement

Assembly: AptifyInventoryReturnWizard (in AptifyInventoryReturnWizard.dll)

See Also

InventoryReturnWizardForm Members | Aptify.Applications.InventoryManagement Namespace


InventoryReturnWizardForm Members

InventoryReturnWizardForm overview

Public Instance Constructors

InventoryReturnWizardForm Constructor Initializes a new instance of the InventoryReturnWizardForm class.

Public Instance Fields

ToolTip1

Public Instance Properties

_picStep_0 |
_picStep_1 |
_picStep_2 |
_picStep_3 |
_picStep_4 |
_picStep_5 |
AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
Image1 |
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
Label1 |
Label10 |
Label2 |
Label3 |
Label4 |
Label5 |
Label6 |
Label7 |
Label8 |
Label9 |
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
lblQuantity |
lblTotalAllocated |
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
lnkProduct |
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
optNo |
optYes |
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
ProgressBar1 |
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
txtQuantity |
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |
Wizard |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoAction | Overloaded.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

InventoryReturnWizardForm Class | Aptify.Applications.InventoryManagement Namespace


InventoryReturnWizardForm Constructor

Initializes a new instance of the InventoryReturnWizardForm class.

public InventoryReturnWizardForm();

See Also

InventoryReturnWizardForm Class | Aptify.Applications.InventoryManagement Namespace


InventoryReturnWizardForm Fields

The fields of the InventoryReturnWizardForm class are listed below. For a complete list of InventoryReturnWizardForm class members, see the InventoryReturnWizardForm Members topic.

Public Instance Fields

ToolTip1

See Also

InventoryReturnWizardForm Class | Aptify.Applications.InventoryManagement Namespace


InventoryReturnWizardForm.ToolTip1 Field

public ToolTip1 ToolTip1;

See Also

InventoryReturnWizardForm Class | Aptify.Applications.InventoryManagement Namespace


InventoryReturnWizardForm Properties

The properties of the InventoryReturnWizardForm class are listed below. For a complete list of InventoryReturnWizardForm class members, see the InventoryReturnWizardForm Members topic.

Public Instance Properties

_picStep_0 |
_picStep_1 |
_picStep_2 |
_picStep_3 |
_picStep_4 |
_picStep_5 |
AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
Image1 |
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
Label1 |
Label10 |
Label2 |
Label3 |
Label4 |
Label5 |
Label6 |
Label7 |
Label8 |
Label9 |
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
lblQuantity |
lblTotalAllocated |
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
lnkProduct |
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
optNo |
optYes |
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
ProgressBar1 |
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
txtQuantity |
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |
Wizard |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

InventoryReturnWizardForm Class | Aptify.Applications.InventoryManagement Namespace


_picStep_0 Property

Aptify 5.0 Software Development Kit (SDK)

InventoryReturnWizardForm._picStep_0 Property

public virtual Panel _picStep_0 {get; set;}

See Also

InventoryReturnWizardForm Class | Aptify.Applications.InventoryManagement Namespace


_picStep_1 Property

Aptify 5.0 Software Development Kit (SDK)

InventoryReturnWizardForm._picStep_1 Property

public virtual Panel _picStep_1 {get; set;}

See Also

InventoryReturnWizardForm Class | Aptify.Applications.InventoryManagement Namespace


_picStep_2 Property

Aptify 5.0 Software Development Kit (SDK)

InventoryReturnWizardForm._picStep_2 Property

public virtual Panel _picStep_2 {get; set;}

See Also

InventoryReturnWizardForm Class | Aptify.Applications.InventoryManagement Namespace


_picStep_3 Property

Aptify 5.0 Software Development Kit (SDK)

InventoryReturnWizardForm._picStep_3 Property

public virtual Panel _picStep_3 {get; set;}

See Also

InventoryReturnWizardForm Class | Aptify.Applications.InventoryManagement Namespace


_picStep_4 Property

Aptify 5.0 Software Development Kit (SDK)

InventoryReturnWizardForm._picStep_4 Property

public virtual Panel _picStep_4 {get; set;}

See Also

InventoryReturnWizardForm Class | Aptify.Applications.InventoryManagement Namespace


_picStep_5 Property

Aptify 5.0 Software Development Kit (SDK)

InventoryReturnWizardForm._picStep_5 Property

public virtual Panel _picStep_5 {get; set;}

See Also

InventoryReturnWizardForm Class | Aptify.Applications.InventoryManagement Namespace


Image1 Property

Aptify 5.0 Software Development Kit (SDK)

InventoryReturnWizardForm.Image1 Property

public virtual PictureBox Image1 {get; set;}

See Also

InventoryReturnWizardForm Class | Aptify.Applications.InventoryManagement Namespace


Label1 Property

Aptify 5.0 Software Development Kit (SDK)

InventoryReturnWizardForm.Label1 Property

public virtual Label Label1 {get; set;}

See Also

InventoryReturnWizardForm Class | Aptify.Applications.InventoryManagement Namespace


Label10 Property

Aptify 5.0 Software Development Kit (SDK)

InventoryReturnWizardForm.Label10 Property

public virtual Label Label10 {get; set;}

See Also

InventoryReturnWizardForm Class | Aptify.Applications.InventoryManagement Namespace


Label2 Property

Aptify 5.0 Software Development Kit (SDK)

InventoryReturnWizardForm.Label2 Property

public virtual Label Label2 {get; set;}

See Also

InventoryReturnWizardForm Class | Aptify.Applications.InventoryManagement Namespace


Label3 Property

Aptify 5.0 Software Development Kit (SDK)

InventoryReturnWizardForm.Label3 Property

public virtual Label Label3 {get; set;}

See Also

InventoryReturnWizardForm Class | Aptify.Applications.InventoryManagement Namespace


Label4 Property

Aptify 5.0 Software Development Kit (SDK)

InventoryReturnWizardForm.Label4 Property

public virtual Label Label4 {get; set;}

See Also

InventoryReturnWizardForm Class | Aptify.Applications.InventoryManagement Namespace


Label5 Property

Aptify 5.0 Software Development Kit (SDK)

InventoryReturnWizardForm.Label5 Property

public virtual Label Label5 {get; set;}

See Also

InventoryReturnWizardForm Class | Aptify.Applications.InventoryManagement Namespace


Label6 Property

Aptify 5.0 Software Development Kit (SDK)

InventoryReturnWizardForm.Label6 Property

public virtual Label Label6 {get; set;}

See Also

InventoryReturnWizardForm Class | Aptify.Applications.InventoryManagement Namespace


Label7 Property

Aptify 5.0 Software Development Kit (SDK)

InventoryReturnWizardForm.Label7 Property

public virtual Label Label7 {get; set;}

See Also

InventoryReturnWizardForm Class | Aptify.Applications.InventoryManagement Namespace


Label8 Property

Aptify 5.0 Software Development Kit (SDK)

InventoryReturnWizardForm.Label8 Property

public virtual Label Label8 {get; set;}

See Also

InventoryReturnWizardForm Class | Aptify.Applications.InventoryManagement Namespace


Label9 Property

Aptify 5.0 Software Development Kit (SDK)

InventoryReturnWizardForm.Label9 Property

public virtual Label Label9 {get; set;}

See Also

InventoryReturnWizardForm Class | Aptify.Applications.InventoryManagement Namespace


lblQuantity Property

Aptify 5.0 Software Development Kit (SDK)

InventoryReturnWizardForm.lblQuantity Property

public virtual Label lblQuantity {get; set;}

See Also

InventoryReturnWizardForm Class | Aptify.Applications.InventoryManagement Namespace


lblTotalAllocated Property

Aptify 5.0 Software Development Kit (SDK)

InventoryReturnWizardForm.lblTotalAllocated Property

public virtual Label lblTotalAllocated {get; set;}

See Also

InventoryReturnWizardForm Class | Aptify.Applications.InventoryManagement Namespace


lnkProduct Property

Aptify 5.0 Software Development Kit (SDK)

InventoryReturnWizardForm.lnkProduct Property

public virtual AptifyLinkBox lnkProduct {get; set;}

See Also

InventoryReturnWizardForm Class | Aptify.Applications.InventoryManagement Namespace


optNo Property

Aptify 5.0 Software Development Kit (SDK)

InventoryReturnWizardForm.optNo Property

public virtual RadioButton optNo {get; set;}

See Also

InventoryReturnWizardForm Class | Aptify.Applications.InventoryManagement Namespace


optYes Property

Aptify 5.0 Software Development Kit (SDK)

InventoryReturnWizardForm.optYes Property

public virtual RadioButton optYes {get; set;}

See Also

InventoryReturnWizardForm Class | Aptify.Applications.InventoryManagement Namespace


ProgressBar1 Property

Aptify 5.0 Software Development Kit (SDK)

InventoryReturnWizardForm.ProgressBar1 Property

public virtual ProgressBar ProgressBar1 {get; set;}

See Also

InventoryReturnWizardForm Class | Aptify.Applications.InventoryManagement Namespace


txtQuantity Property

Aptify 5.0 Software Development Kit (SDK)

InventoryReturnWizardForm.txtQuantity Property

public virtual AptifyTextBox txtQuantity {get; set;}

See Also

InventoryReturnWizardForm Class | Aptify.Applications.InventoryManagement Namespace


Wizard Property

Aptify 5.0 Software Development Kit (SDK)

InventoryReturnWizardForm.Wizard Property

public virtual WizardControl Wizard {get; set;}

See Also

InventoryReturnWizardForm Class | Aptify.Applications.InventoryManagement Namespace


InventoryReturnWizardForm Methods

The methods of the InventoryReturnWizardForm class are listed below. For a complete list of InventoryReturnWizardForm class members, see the InventoryReturnWizardForm Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoAction | Overloaded.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

InventoryReturnWizardForm Class | Aptify.Applications.InventoryManagement Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

InventoryReturnWizardForm.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

InventoryReturnWizardForm Class | Aptify.Applications.InventoryManagement Namespace


InventoryReturnWizardForm.Dispose Method (Boolean)

protected override void Dispose(
Boolean Disposing
);

See Also

InventoryReturnWizardForm Class | Aptify.Applications.InventoryManagement Namespace | InventoryReturnWizardForm.Dispose Overload List


DoAction Method

Aptify 5.0 Software Development Kit (SDK)

InventoryReturnWizardForm.DoAction Method

Overload List

public void DoAction(AptifyApplication,Int64);

public void DoAction(AptifyApplication,Int64,Int64);

public void DoAction(AptifyApplication,Int64,Int64,params Object[]);

public void DoAction(AptifyApplication,Int64,params String[]);

See Also

InventoryReturnWizardForm Class | Aptify.Applications.InventoryManagement Namespace


InventoryReturnWizardForm.DoAction Method (AptifyApplication, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID
);

Implements

IAptifyAction.

See Also

InventoryReturnWizardForm Class | Aptify.Applications.InventoryManagement Namespace | InventoryReturnWizardForm.DoAction Overload List


InventoryReturnWizardForm.DoAction Method (AptifyApplication, Int64, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID
);

Implements

IAptifyAction.

See Also

InventoryReturnWizardForm Class | Aptify.Applications.InventoryManagement Namespace | InventoryReturnWizardForm.DoAction Overload List


InventoryReturnWizardForm.DoAction Method (AptifyApplication, Int64, Int64, Object[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID,
params Object[] SelectedItems
);

Implements

IAptifyAction.

See Also

InventoryReturnWizardForm Class | Aptify.Applications.InventoryManagement Namespace | InventoryReturnWizardForm.DoAction Overload List


InventoryReturnWizardForm.DoAction Method (AptifyApplication, Int64, String[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
params String[] SelectedItems
);

Implements

IAptifyAction.

See Also

InventoryReturnWizardForm Class | Aptify.Applications.InventoryManagement Namespace | InventoryReturnWizardForm.DoAction Overload List


InventoryTransfer Class

For a list of all members of this type, see InventoryTransfer Members.

System.Object
InventoryTransfer

public class InventoryTransfer : IInventoryTransfer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.InventoryManagement

Assembly: InventoryTransferObject (in InventoryTransferObject.dll)

See Also

InventoryTransfer Members | Aptify.Applications.InventoryManagement Namespace


InventoryTransfer Members

InventoryTransfer overview

Public Instance Constructors

InventoryTransfer Constructor Initializes a new instance of the InventoryTransfer class.

Public Instance Methods

Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
TransferInventory |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

InventoryTransfer Class | Aptify.Applications.InventoryManagement Namespace


InventoryTransfer Constructor

Initializes a new instance of the InventoryTransfer class.

public InventoryTransfer();

See Also

InventoryTransfer Class | Aptify.Applications.InventoryManagement Namespace


InventoryTransfer Methods

The methods of the InventoryTransfer class are listed below. For a complete list of InventoryTransfer class members, see the InventoryTransfer Members topic.

Public Instance Methods

Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
TransferInventory |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

InventoryTransfer Class | Aptify.Applications.InventoryManagement Namespace


InventoryTransfer.Config Method

public bool Config(
AptifyApplication ApplicationObject
);

Implements

IInventoryTransfer.

See Also

InventoryTransfer Class | Aptify.Applications.InventoryManagement Namespace


InventoryTransfer.TransferInventory Method

public bool TransferInventory(
Int64 lInvLocationSrcID,
Int64 lInvLocationDestID,
Int64 lProductID,
Double nQuantity,
Boolean bShowErrors
);

Implements

IInventoryTransfer.

See Also

InventoryTransfer Class | Aptify.Applications.InventoryManagement Namespace


InvTransferForm Class

For a list of all members of this type, see InvTransferForm Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
InvTransferForm

public class InvTransferForm : Form

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.InventoryManagement

Assembly: InventoryControl (in InventoryControl.dll)

See Also

InvTransferForm Members | Aptify.Applications.InventoryManagement Namespace


InvTransferForm Members

InvTransferForm overview

Public Instance Constructors

InvTransferForm Constructor Initializes a new instance of the InvTransferForm class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UserCredential |
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DoLocalization |
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetTransferQuantity |
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

InvTransferForm Class | Aptify.Applications.InventoryManagement Namespace


InvTransferForm Constructor

Initializes a new instance of the InvTransferForm class.

public InvTransferForm();

See Also

InvTransferForm Class | Aptify.Applications.InventoryManagement Namespace


InvTransferForm Properties

The properties of the InvTransferForm class are listed below. For a complete list of InvTransferForm class members, see the InvTransferForm Members topic.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UserCredential |
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

InvTransferForm Class | Aptify.Applications.InventoryManagement Namespace


UserCredential Property

Aptify 5.0 Software Development Kit (SDK)

InvTransferForm.UserCredential Property

public UserCredentials UserCredential {get; set;}

See Also

InvTransferForm Class | Aptify.Applications.InventoryManagement Namespace


InvTransferForm Methods

The methods of the InvTransferForm class are listed below. For a complete list of InvTransferForm class members, see the InvTransferForm Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DoLocalization |
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetTransferQuantity |
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

InvTransferForm Class | Aptify.Applications.InventoryManagement Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

InvTransferForm.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

InvTransferForm Class | Aptify.Applications.InventoryManagement Namespace


InvTransferForm.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

InvTransferForm Class | Aptify.Applications.InventoryManagement Namespace | InvTransferForm.Dispose Overload List


InvTransferForm.DoLocalization Method

public void DoLocalization(
UserCredentials pUserCredential
);

See Also

InvTransferForm Class | Aptify.Applications.InventoryManagement Namespace


InvTransferForm.GetTransferQuantity Method

public double GetTransferQuantity(
String sProduct,
String sSource,
String sDest
);

See Also

InvTransferForm Class | Aptify.Applications.InventoryManagement Namespace


ProductCostAdjustmentWizardException Class

Thrown when an exception occurs during the life time of the ProductCostAdjustmentWizardForm.

For a list of all members of this type, see ProductCostAdjustmentWizardException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
ProductCostAdjustmentWizardException

public class ProductCostAdjustmentWizardException : BaseApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.InventoryManagement

Assembly: AptifyProductCostAdjustmentWizard (in AptifyProductCostAdjustmentWizard.dll)

See Also

ProductCostAdjustmentWizardException Members | Aptify.Applications.InventoryManagement Namespace


ProductCostAdjustmentWizardException Members

ProductCostAdjustmentWizardException overview

Public Instance Constructors

ProductCostAdjustmentWizardException Overloaded. Initializes a new instance of the ProductCostAdjustmentWizardException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from BaseApplicationException) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProductCostAdjustmentWizardException Class | Aptify.Applications.InventoryManagement Namespace


ProductCostAdjustmentWizardException Constructor

Initializes a new instance of the ProductCostAdjustmentWizardException class.

Overload List

Initializes a new instance of the ProductCostAdjustmentWizardException class.

public ProductCostAdjustmentWizardException();

public ProductCostAdjustmentWizardException(String);

public ProductCostAdjustmentWizardException(String,Exception);

See Also

ProductCostAdjustmentWizardException Class | Aptify.Applications.InventoryManagement Namespace


ProductCostAdjustmentWizardException Constructor ()

Initializes a new instance of the ProductCostAdjustmentWizardException class.

public ProductCostAdjustmentWizardException();

See Also

ProductCostAdjustmentWizardException Class | Aptify.Applications.InventoryManagement Namespace | ProductCostAdjustmentWizardException Constructor Overload List


ProductCostAdjustmentWizardException Constructor (String)

public ProductCostAdjustmentWizardException(
String Message
);

See Also

ProductCostAdjustmentWizardException Class | Aptify.Applications.InventoryManagement Namespace | ProductCostAdjustmentWizardException Constructor Overload List


ProductCostAdjustmentWizardException Constructor (String, Exception)

public ProductCostAdjustmentWizardException(
String Message,
Exception InnerException
);

See Also

ProductCostAdjustmentWizardException Class | Aptify.Applications.InventoryManagement Namespace | ProductCostAdjustmentWizardException Constructor Overload List


ProductCostAdjustmentWizardForm Class

For a list of all members of this type, see ProductCostAdjustmentWizardForm Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
ProductCostAdjustmentWizardForm

public class ProductCostAdjustmentWizardForm : Form, IAptifyAction

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.InventoryManagement

Assembly: AptifyProductCostAdjustmentWizard (in AptifyProductCostAdjustmentWizard.dll)

See Also

ProductCostAdjustmentWizardForm Members | Aptify.Applications.InventoryManagement Namespace


ProductCostAdjustmentWizardForm Members

ProductCostAdjustmentWizardForm overview

Public Instance Constructors

ProductCostAdjustmentWizardForm Constructor Initializes a new instance of the ProductCostAdjustmentWizardForm class.

Public Instance Fields

ToolTip

Public Instance Properties

_picStep_0 |
_picStep_1 |
_picStep_2 |
_picStep_3 |
_ssTab_TabPage0 |
_ssTab_TabPage1 |
AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
Image1 |
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
Label1 |
Label10 |
Label12 |
Label2 |
Label3 |
Label4 |
Label5 |
Label6 |
Label8 |
Label9 |
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
lblProgress |
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
pgrProgress |
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
ssTab |
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
txtCOGSTotal |
txtInvTotal |
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |
Wizard |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoAction | Overloaded.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ProductCostAdjustmentWizardForm Class | Aptify.Applications.InventoryManagement Namespace


ProductCostAdjustmentWizardForm Constructor

Initializes a new instance of the ProductCostAdjustmentWizardForm class.

public ProductCostAdjustmentWizardForm();

See Also

ProductCostAdjustmentWizardForm Class | Aptify.Applications.InventoryManagement Namespace


ProductCostAdjustmentWizardForm Fields

The fields of the ProductCostAdjustmentWizardForm class are listed below. For a complete list of ProductCostAdjustmentWizardForm class members, see the ProductCostAdjustmentWizardForm Members topic.

Public Instance Fields

ToolTip

See Also

ProductCostAdjustmentWizardForm Class | Aptify.Applications.InventoryManagement Namespace


ProductCostAdjustmentWizardForm.ToolTip Field

public ToolTip ToolTip;

See Also

ProductCostAdjustmentWizardForm Class | Aptify.Applications.InventoryManagement Namespace


ProductCostAdjustmentWizardForm Properties

The properties of the ProductCostAdjustmentWizardForm class are listed below. For a complete list of ProductCostAdjustmentWizardForm class members, see the ProductCostAdjustmentWizardForm Members topic.

Public Instance Properties

_picStep_0 |
_picStep_1 |
_picStep_2 |
_picStep_3 |
_ssTab_TabPage0 |
_ssTab_TabPage1 |
AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
Image1 |
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
Label1 |
Label10 |
Label12 |
Label2 |
Label3 |
Label4 |
Label5 |
Label6 |
Label8 |
Label9 |
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
lblProgress |
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
pgrProgress |
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
ssTab |
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
txtCOGSTotal |
txtInvTotal |
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |
Wizard |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

ProductCostAdjustmentWizardForm Class | Aptify.Applications.InventoryManagement Namespace


_picStep_0 Property

Aptify 5.0 Software Development Kit (SDK)

ProductCostAdjustmentWizardForm._picStep_0 Property

public virtual Panel _picStep_0 {get; set;}

See Also

ProductCostAdjustmentWizardForm Class | Aptify.Applications.InventoryManagement Namespace


_picStep_1 Property

Aptify 5.0 Software Development Kit (SDK)

ProductCostAdjustmentWizardForm._picStep_1 Property

public virtual Panel _picStep_1 {get; set;}

See Also

ProductCostAdjustmentWizardForm Class | Aptify.Applications.InventoryManagement Namespace


_picStep_2 Property

Aptify 5.0 Software Development Kit (SDK)

ProductCostAdjustmentWizardForm._picStep_2 Property

public virtual Panel _picStep_2 {get; set;}

See Also

ProductCostAdjustmentWizardForm Class | Aptify.Applications.InventoryManagement Namespace


_picStep_3 Property

Aptify 5.0 Software Development Kit (SDK)

ProductCostAdjustmentWizardForm._picStep_3 Property

public virtual Panel _picStep_3 {get; set;}

See Also

ProductCostAdjustmentWizardForm Class | Aptify.Applications.InventoryManagement Namespace


_ssTab_TabPage0 Property

Aptify 5.0 Software Development Kit (SDK)

ProductCostAdjustmentWizardForm._ssTab_TabPage0 Property

public virtual TabPage _ssTab_TabPage0 {get; set;}

See Also

ProductCostAdjustmentWizardForm Class | Aptify.Applications.InventoryManagement Namespace


_ssTab_TabPage1 Property

Aptify 5.0 Software Development Kit (SDK)

ProductCostAdjustmentWizardForm._ssTab_TabPage1 Property

public virtual TabPage _ssTab_TabPage1 {get; set;}

See Also

ProductCostAdjustmentWizardForm Class | Aptify.Applications.InventoryManagement Namespace


Image1 Property

Aptify 5.0 Software Development Kit (SDK)

ProductCostAdjustmentWizardForm.Image1 Property

public virtual PictureBox Image1 {get; set;}

See Also

ProductCostAdjustmentWizardForm Class | Aptify.Applications.InventoryManagement Namespace


Label1 Property

Aptify 5.0 Software Development Kit (SDK)

ProductCostAdjustmentWizardForm.Label1 Property

public virtual Label Label1 {get; set;}

See Also

ProductCostAdjustmentWizardForm Class | Aptify.Applications.InventoryManagement Namespace


Label10 Property

Aptify 5.0 Software Development Kit (SDK)

ProductCostAdjustmentWizardForm.Label10 Property

public virtual Label Label10 {get; set;}

See Also

ProductCostAdjustmentWizardForm Class | Aptify.Applications.InventoryManagement Namespace


Label12 Property

Aptify 5.0 Software Development Kit (SDK)

ProductCostAdjustmentWizardForm.Label12 Property

public virtual Label Label12 {get; set;}

See Also

ProductCostAdjustmentWizardForm Class | Aptify.Applications.InventoryManagement Namespace


Label2 Property

Aptify 5.0 Software Development Kit (SDK)

ProductCostAdjustmentWizardForm.Label2 Property

public virtual Label Label2 {get; set;}

See Also

ProductCostAdjustmentWizardForm Class | Aptify.Applications.InventoryManagement Namespace


Label3 Property

Aptify 5.0 Software Development Kit (SDK)

ProductCostAdjustmentWizardForm.Label3 Property

public virtual Label Label3 {get; set;}

See Also

ProductCostAdjustmentWizardForm Class | Aptify.Applications.InventoryManagement Namespace


Label4 Property

Aptify 5.0 Software Development Kit (SDK)

ProductCostAdjustmentWizardForm.Label4 Property

public virtual Label Label4 {get; set;}

See Also

ProductCostAdjustmentWizardForm Class | Aptify.Applications.InventoryManagement Namespace


Label5 Property

Aptify 5.0 Software Development Kit (SDK)

ProductCostAdjustmentWizardForm.Label5 Property

public virtual Label Label5 {get; set;}

See Also

ProductCostAdjustmentWizardForm Class | Aptify.Applications.InventoryManagement Namespace


Label6 Property

Aptify 5.0 Software Development Kit (SDK)

ProductCostAdjustmentWizardForm.Label6 Property

public virtual Label Label6 {get; set;}

See Also

ProductCostAdjustmentWizardForm Class | Aptify.Applications.InventoryManagement Namespace


Label8 Property

Aptify 5.0 Software Development Kit (SDK)

ProductCostAdjustmentWizardForm.Label8 Property

public virtual Label Label8 {get; set;}

See Also

ProductCostAdjustmentWizardForm Class | Aptify.Applications.InventoryManagement Namespace


Label9 Property

Aptify 5.0 Software Development Kit (SDK)

ProductCostAdjustmentWizardForm.Label9 Property

public virtual Label Label9 {get; set;}

See Also

ProductCostAdjustmentWizardForm Class | Aptify.Applications.InventoryManagement Namespace


lblProgress Property

Aptify 5.0 Software Development Kit (SDK)

ProductCostAdjustmentWizardForm.lblProgress Property

public virtual Label lblProgress {get; set;}

See Also

ProductCostAdjustmentWizardForm Class | Aptify.Applications.InventoryManagement Namespace


pgrProgress Property

Aptify 5.0 Software Development Kit (SDK)

ProductCostAdjustmentWizardForm.pgrProgress Property

public virtual ProgressBar pgrProgress {get; set;}

See Also

ProductCostAdjustmentWizardForm Class | Aptify.Applications.InventoryManagement Namespace


ssTab Property

Aptify 5.0 Software Development Kit (SDK)

ProductCostAdjustmentWizardForm.ssTab Property

public virtual TabControl ssTab {get; set;}

See Also

ProductCostAdjustmentWizardForm Class | Aptify.Applications.InventoryManagement Namespace


txtCOGSTotal Property

Aptify 5.0 Software Development Kit (SDK)

ProductCostAdjustmentWizardForm.txtCOGSTotal Property

public virtual TextBox txtCOGSTotal {get; set;}

See Also

ProductCostAdjustmentWizardForm Class | Aptify.Applications.InventoryManagement Namespace


txtInvTotal Property

Aptify 5.0 Software Development Kit (SDK)

ProductCostAdjustmentWizardForm.txtInvTotal Property

public virtual TextBox txtInvTotal {get; set;}

See Also

ProductCostAdjustmentWizardForm Class | Aptify.Applications.InventoryManagement Namespace


Wizard Property

Aptify 5.0 Software Development Kit (SDK)

ProductCostAdjustmentWizardForm.Wizard Property

public virtual WizardControl Wizard {get; set;}

See Also

ProductCostAdjustmentWizardForm Class | Aptify.Applications.InventoryManagement Namespace


ProductCostAdjustmentWizardForm Methods

The methods of the ProductCostAdjustmentWizardForm class are listed below. For a complete list of ProductCostAdjustmentWizardForm class members, see the ProductCostAdjustmentWizardForm Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoAction | Overloaded.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ProductCostAdjustmentWizardForm Class | Aptify.Applications.InventoryManagement Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

ProductCostAdjustmentWizardForm.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

ProductCostAdjustmentWizardForm Class | Aptify.Applications.InventoryManagement Namespace


ProductCostAdjustmentWizardForm.Dispose Method (Boolean)

protected override void Dispose(
Boolean Disposing
);

See Also

ProductCostAdjustmentWizardForm Class | Aptify.Applications.InventoryManagement Namespace | ProductCostAdjustmentWizardForm.Dispose Overload List


DoAction Method

Aptify 5.0 Software Development Kit (SDK)

ProductCostAdjustmentWizardForm.DoAction Method

Overload List

public void DoAction(AptifyApplication,Int64);

public void DoAction(AptifyApplication,Int64,Int64);

public void DoAction(AptifyApplication,Int64,Int64,params Object[]);

public void DoAction(AptifyApplication,Int64,params String[]);

See Also

ProductCostAdjustmentWizardForm Class | Aptify.Applications.InventoryManagement Namespace


ProductCostAdjustmentWizardForm.DoAction Method (AptifyApplication, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID
);

Implements

IAptifyAction.

See Also

ProductCostAdjustmentWizardForm Class | Aptify.Applications.InventoryManagement Namespace | ProductCostAdjustmentWizardForm.DoAction Overload List


ProductCostAdjustmentWizardForm.DoAction Method (AptifyApplication, Int64, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID
);

Implements

IAptifyAction.

See Also

ProductCostAdjustmentWizardForm Class | Aptify.Applications.InventoryManagement Namespace | ProductCostAdjustmentWizardForm.DoAction Overload List


ProductCostAdjustmentWizardForm.DoAction Method (AptifyApplication, Int64, Int64, Object[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID,
params Object[] SelectedItems
);

Implements

IAptifyAction.

See Also

ProductCostAdjustmentWizardForm Class | Aptify.Applications.InventoryManagement Namespace | ProductCostAdjustmentWizardForm.DoAction Overload List


ProductCostAdjustmentWizardForm.DoAction Method (AptifyApplication, Int64, String[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
params String[] SelectedItems
);

Implements

IAptifyAction.

See Also

ProductCostAdjustmentWizardForm Class | Aptify.Applications.InventoryManagement Namespace | ProductCostAdjustmentWizardForm.DoAction Overload List


Aptify.Applications.Marketplace

Aptify 5.0 Software Development Kit (SDK)

Aptify.Applications.Marketplace Namespace

This namespace corresponds to objects used by Apify's Marketplace Listings functionality, which is a feature of the E-Business Suite.

Namespace hierarchy

Classes

Class | Description
ListingTypeCache | Caches Marketplace Listing Types information. Shared, on-demand cache.
ListingTypeData |
MarketplaceListingsEntity |
MarketplaceListingsLayout |

Enumerations

Enumeration | Description
ListingTypeData.ListingTypeStatus |
MarketplaceListingOfferingType |
MarketplaceListingStatus |


ListingTypeCache Class

Caches Marketplace Listing Types information. Shared, on-demand cache.

For a list of all members of this type, see ListingTypeCache Members.

System.Object
ListingTypeCache

public class ListingTypeCache

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Marketplace

Assembly: AptifyMarketplaceListingsEntity (in AptifyMarketplaceListingsEntity.dll)

See Also

ListingTypeCache Members | Aptify.Applications.Marketplace Namespace


ListingTypeCache Members

ListingTypeCache overview

Public Static Methods

Instance

Public Instance Properties

ListingType This method will either return a ListingTypeData object from the cache or, if the cache doesn't contain a ListingTypeData object for the Organization, the information will be retrieved from the database and used to populate a ListingTypeData object which will be added to the cache and returned to the caller.

Public Instance Methods

Clear | Clears the Marketplace Listing Types cache.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
RemoveListingTypeFromCache |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ListingTypeCache Class | Aptify.Applications.Marketplace Namespace


ListingTypeCache Properties

The properties of the ListingTypeCache class are listed below. For a complete list of ListingTypeCache class members, see the ListingTypeCache Members topic.

Public Instance Properties

ListingType This method will either return a ListingTypeData object from the cache or, if the cache doesn't contain a ListingTypeData object for the Organization, the information will be retrieved from the database and used to populate a ListingTypeData object which will be added to the cache and returned to the caller.

See Also

ListingTypeCache Class | Aptify.Applications.Marketplace Namespace


ListingType Property

Aptify 5.0 Software Development Kit (SDK)

ListingTypeCache.ListingType Property

This method will either return a ListingTypeData object from the cache or, if the cache doesn't contain a ListingTypeData object for the Organization, the information will be retrieved from the database and used to populate a ListingTypeData object which will be added to the cache and returned to the caller.

public virtual ListingTypeData this[
Int32 ListingTypeID,
Boolean ForceRefresh
] {get;}

Parameters

ListingTypeID
ForceRefresh

Property Value

Remarks

See Also

ListingTypeCache Class | Aptify.Applications.Marketplace Namespace


ListingTypeCache Methods

The methods of the ListingTypeCache class are listed below. For a complete list of ListingTypeCache class members, see the ListingTypeCache Members topic.

Public Static Methods

Instance

Public Instance Methods

Clear | Clears the Marketplace Listing Types cache.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
RemoveListingTypeFromCache |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ListingTypeCache Class | Aptify.Applications.Marketplace Namespace


ListingTypeCache.Clear Method

Clears the Marketplace Listing Types cache.

public void Clear();

Remarks

See Also

ListingTypeCache Class | Aptify.Applications.Marketplace Namespace


ListingTypeCache.Instance Method

public static ListingTypeCache Instance(
AptifyApplication Application
);

See Also

ListingTypeCache Class | Aptify.Applications.Marketplace Namespace


ListingTypeCache.RemoveListingTypeFromCache Method

public virtual void RemoveListingTypeFromCache(
Int32 ListingTypeID
);

See Also

ListingTypeCache Class | Aptify.Applications.Marketplace Namespace


ListingTypeData Class

For a list of all members of this type, see ListingTypeData Members.

System.Object
ListingTypeData

public class ListingTypeData

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Marketplace

Assembly: AptifyMarketplaceListingsEntity (in AptifyMarketplaceListingsEntity.dll)

See Also

ListingTypeData Members | Aptify.Applications.Marketplace Namespace


ListingTypeData Members

ListingTypeData overview

Public Instance Constructors

ListingTypeData Constructor

Public Instance Properties

Comments
DateAvailable
DaysToHighlight
Description
ID
Name
Product
ProductID
Status
WebDescription
WebName

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ListingTypeData Class | Aptify.Applications.Marketplace Namespace


ListingTypeData Constructor

public ListingTypeData(
DataRow rowListingType
);

See Also

ListingTypeData Class | Aptify.Applications.Marketplace Namespace


ListingTypeData Properties

The properties of the ListingTypeData class are listed below. For a complete list of ListingTypeData class members, see the ListingTypeData Members topic.

Public Instance Properties

Comments
DateAvailable
DaysToHighlight
Description
ID
Name
Product
ProductID
Status
WebDescription
WebName

See Also

ListingTypeData Class | Aptify.Applications.Marketplace Namespace


Comments Property

Aptify 5.0 Software Development Kit (SDK)

ListingTypeData.Comments Property

public String Comments {get;}

See Also

ListingTypeData Class | Aptify.Applications.Marketplace Namespace


DateAvailable Property

Aptify 5.0 Software Development Kit (SDK)

ListingTypeData.DateAvailable Property

public DateTime DateAvailable {get;}

See Also

ListingTypeData Class | Aptify.Applications.Marketplace Namespace


DaysToHighlight Property

Aptify 5.0 Software Development Kit (SDK)

ListingTypeData.DaysToHighlight Property

public Int32 DaysToHighlight {get;}

See Also

ListingTypeData Class | Aptify.Applications.Marketplace Namespace


Description Property

Aptify 5.0 Software Development Kit (SDK)

ListingTypeData.Description Property

public String Description {get;}

See Also

ListingTypeData Class | Aptify.Applications.Marketplace Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

ListingTypeData.ID Property

public Int32 ID {get;}

See Also

ListingTypeData Class | Aptify.Applications.Marketplace Namespace


Name Property

Aptify 5.0 Software Development Kit (SDK)

ListingTypeData.Name Property

public String Name {get;}

See Also

ListingTypeData Class | Aptify.Applications.Marketplace Namespace


Product Property

Aptify 5.0 Software Development Kit (SDK)

ListingTypeData.Product Property

public String Product {get;}

See Also

ListingTypeData Class | Aptify.Applications.Marketplace Namespace


ProductID Property

Aptify 5.0 Software Development Kit (SDK)

ListingTypeData.ProductID Property

public Int64 ProductID {get;}

See Also

ListingTypeData Class | Aptify.Applications.Marketplace Namespace


Status Property

Aptify 5.0 Software Development Kit (SDK)

ListingTypeData.Status Property

public ListingTypeData.ListingTypeStatus Status {get;}

See Also

ListingTypeData Class | Aptify.Applications.Marketplace Namespace


WebDescription Property

Aptify 5.0 Software Development Kit (SDK)

ListingTypeData.WebDescription Property

public String WebDescription {get;}

See Also

ListingTypeData Class | Aptify.Applications.Marketplace Namespace


WebName Property

Aptify 5.0 Software Development Kit (SDK)

ListingTypeData.WebName Property

public String WebName {get;}

See Also

ListingTypeData Class | Aptify.Applications.Marketplace Namespace


ListingTypeData.ListingTypeStatus Enumeration

public enum ListingTypeData.ListingTypeStatus

Members

Member Name | Description
Active |
InActive |

Requirements

Namespace: Aptify.Applications.Marketplace

Assembly: AptifyMarketplaceListingsEntity (in AptifyMarketplaceListingsEntity.dll)

See Also

Aptify.Applications.Marketplace Namespace


MarketplaceListingOfferingType Enumeration

public enum MarketplaceListingOfferingType

Members

Member Name | Description
Product |
Service |
Training |
Other |

Requirements

Namespace: Aptify.Applications.Marketplace

Assembly: AptifyMarketplaceListingsEntity (in AptifyMarketplaceListingsEntity.dll)

See Also

Aptify.Applications.Marketplace Namespace


MarketplaceListingsEntity Class

For a list of all members of this type, see MarketplaceListingsEntity Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
MarketplaceListingsEntity

public class MarketplaceListingsEntity : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Marketplace

Assembly: AptifyMarketplaceListingsEntity (in AptifyMarketplaceListingsEntity.dll)

See Also

MarketplaceListingsEntity Members | Aptify.Applications.Marketplace Namespace


MarketplaceListingsEntity Members

MarketplaceListingsEntity overview

Public Instance Constructors

MarketplaceListingsEntity Constructor Initializes a new instance of the MarketplaceListingsEntity class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
OfferingType |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PreviousStatus |
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
Status |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config | Overloaded.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord |
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded. Saves the Marketplace Listing and, if the Status is changing to Approved from Requested or a new Marketplace Listing is Approved, an Order will be generated based on the information in the Marketplace Listing record.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
ProductPriceObject | Responsible for retrieving and instantiating the core Product Price object. The core Product Price meta-data is defined as a Product Pricing Entity Plug In in the Products Entity.
ProductPricePlugIn | Retrieves the core Product Price Plug In meta-data. The information is retrieved from the Products Entity Plug In, Product Pricing.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DeterminePreferredCurrency | The User's Preferred Currency Type is based on either the Preferred Currency Type of the Company linked to the Person. If the Company does not have a Preferred Currency or the Person does not have a linked Company, the Person's Preferred Currency Type will be used. If the Person does not have a Preferred Currency Type, the system's Functional Currency will be used.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SaveGenerateOrder |
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

MarketplaceListingsEntity Class | Aptify.Applications.Marketplace Namespace


MarketplaceListingsEntity Constructor

Initializes a new instance of the MarketplaceListingsEntity class.

public MarketplaceListingsEntity();

See Also

MarketplaceListingsEntity Class | Aptify.Applications.Marketplace Namespace


MarketplaceListingsEntity Properties

The properties of the MarketplaceListingsEntity class are listed below. For a complete list of MarketplaceListingsEntity class members, see the MarketplaceListingsEntity Members topic.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
OfferingType |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PreviousStatus |
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
Status |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
ProductPriceObject | Responsible for retrieving and instantiating the core Product Price object. The core Product Price meta-data is defined as a Product Pricing Entity Plug In in the Products Entity.
ProductPricePlugIn | Retrieves the core Product Price Plug In meta-data. The information is retrieved from the Products Entity Plug In, Product Pricing.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

MarketplaceListingsEntity Class | Aptify.Applications.Marketplace Namespace


OfferingType Property

Aptify 5.0 Software Development Kit (SDK)

MarketplaceListingsEntity.OfferingType Property

public MarketplaceListingOfferingType OfferingType {get; set;}

See Also

MarketplaceListingsEntity Class | Aptify.Applications.Marketplace Namespace


PreviousStatus Property

Aptify 5.0 Software Development Kit (SDK)

MarketplaceListingsEntity.PreviousStatus Property

public MarketplaceListingStatus PreviousStatus {get;}

See Also

MarketplaceListingsEntity Class | Aptify.Applications.Marketplace Namespace


ProductPriceObject Property

Aptify 5.0 Software Development Kit (SDK)

MarketplaceListingsEntity.ProductPriceObject Property

Responsible for retrieving and instantiating the core Product Price object. The core Product Price meta-data is defined as a Product Pricing Entity Plug In in the Products Entity.

protected IProductPrice ProductPriceObject {get;}

Property Value

Remarks

See Also

MarketplaceListingsEntity Class | Aptify.Applications.Marketplace Namespace


ProductPricePlugIn Property

Aptify 5.0 Software Development Kit (SDK)

MarketplaceListingsEntity.ProductPricePlugIn Property

Retrieves the core Product Price Plug In meta-data. The information is retrieved from the Products Entity Plug In, Product Pricing.

protected virtual ComponentPlugIn ProductPricePlugIn {get;}

Property Value

Remarks

See Also

MarketplaceListingsEntity Class | Aptify.Applications.Marketplace Namespace


Status Property

Aptify 5.0 Software Development Kit (SDK)

MarketplaceListingsEntity.Status Property

public MarketplaceListingStatus Status {get; set;}

See Also

MarketplaceListingsEntity Class | Aptify.Applications.Marketplace Namespace


MarketplaceListingsEntity Methods

The methods of the MarketplaceListingsEntity class are listed below. For a complete list of MarketplaceListingsEntity class members, see the MarketplaceListingsEntity Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config | Overloaded.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord |
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded. Saves the Marketplace Listing and, if the Status is changing to Approved from Requested or a new Marketplace Listing is Approved, an Order will be generated based on the information in the Marketplace Listing record.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DeterminePreferredCurrency | The User's Preferred Currency Type is based on either the Preferred Currency Type of the Company linked to the Person. If the Company does not have a Preferred Currency or the Person does not have a linked Company, the Person's Preferred Currency Type will be used. If the Person does not have a Preferred Currency Type, the system's Functional Currency will be used.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SaveGenerateOrder |
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

MarketplaceListingsEntity Class | Aptify.Applications.Marketplace Namespace


Config Method

Aptify 5.0 Software Development Kit (SDK)

MarketplaceListingsEntity.Config Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual void Config(AptifySubTypeBase);

Inherited from AptifyGenericEntity.

public override void Config(AptifySubTypeBase,Int64);

Inherited from AptifyGenericEntityBase.

public virtual void Config(UserCredentials,String);

public override void Config(UserCredentials,String,Int64);

See Also

MarketplaceListingsEntity Class | Aptify.Applications.Marketplace Namespace


MarketplaceListingsEntity.Config Method (UserCredentials, String, Int64)

public override void Config(
UserCredentials UserCredentials,
String EntityName,
Int64 RecordID
);

See Also

MarketplaceListingsEntity Class | Aptify.Applications.Marketplace Namespace | MarketplaceListingsEntity.Config Overload List


MarketplaceListingsEntity.DeterminePreferredCurrency Method

The User's Preferred Currency Type is based on either the Preferred Currency Type of the Company linked to the Person. If the Company does not have a Preferred Currency or the Person does not have a linked Company, the Person's Preferred Currency Type will be used. If the Person does not have a Preferred Currency Type, the system's Functional Currency will be used.

protected virtual long DeterminePreferredCurrency(
Int64 PersonID,
Int64 CompanyID
);

Remarks

See Also

MarketplaceListingsEntity Class | Aptify.Applications.Marketplace Namespace


MarketplaceListingsEntity.NewRecord Method

public override bool NewRecord();

See Also

MarketplaceListingsEntity Class | Aptify.Applications.Marketplace Namespace


Save Method

Aptify 5.0 Software Development Kit (SDK)

MarketplaceListingsEntity.Save Method

Saves the Marketplace Listing and, if the Status is changing to Approved from Requested or a new Marketplace Listing is Approved, an Order will be generated based on the information in the Marketplace Listing record.

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Save();

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean,ref String&);

Saves the Marketplace Listing and, if the Status is changing to Approved from Requested or a new Marketplace Listing is Approved, an Order will be generated based on the information in the Marketplace Listing record.

public override bool Save(Boolean,ref String&,String);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(ref String&);

See Also

MarketplaceListingsEntity Class | Aptify.Applications.Marketplace Namespace


MarketplaceListingsEntity.Save Method (Boolean, String&, String)

Saves the Marketplace Listing and, if the Status is changing to Approved from Requested or a new Marketplace Listing is Approved, an Order will be generated based on the information in the Marketplace Listing record.

public override bool Save(
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

Parameters

AllowGUI
ErrorString
TransactionID

Return Value

Remarks

See Also

MarketplaceListingsEntity Class | Aptify.Applications.Marketplace Namespace | MarketplaceListingsEntity.Save Overload List


MarketplaceListingsEntity.SaveGenerateOrder Method

protected virtual bool SaveGenerateOrder(
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

See Also

MarketplaceListingsEntity Class | Aptify.Applications.Marketplace Namespace


Validate Method

Aptify 5.0 Software Development Kit (SDK)

MarketplaceListingsEntity.Validate Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Validate();

public override bool Validate(ref String&);

See Also

MarketplaceListingsEntity Class | Aptify.Applications.Marketplace Namespace


MarketplaceListingsEntity.Validate Method (String&)

public override bool Validate(
ref String& ErrorString
);

See Also

MarketplaceListingsEntity Class | Aptify.Applications.Marketplace Namespace | MarketplaceListingsEntity.Validate Overload List


MarketplaceListingsLayout Class

For a list of all members of this type, see MarketplaceListingsLayout Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
MarketplaceListingsLayout

public class MarketplaceListingsLayout : FormTemplateLayout

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Marketplace

Assembly: AptifyMarketplaceListingsUI (in AptifyMarketplaceListingsUI.dll)

See Also

MarketplaceListingsLayout Members | Aptify.Applications.Marketplace Namespace


MarketplaceListingsLayout Members

MarketplaceListingsLayout overview

Public Instance Constructors

MarketplaceListingsLayout Constructor Initializes a new instance of the MarketplaceListingsLayout class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ListingObject |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
ContextGEChanged |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControls |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig |
OnFormTemplateLoaded | Contains logic to setup Event handlers for controls on the FormTemplate Layout.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlVisibility |
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

MarketplaceListingsLayout Class | Aptify.Applications.Marketplace Namespace


MarketplaceListingsLayout Constructor

Initializes a new instance of the MarketplaceListingsLayout class.

public MarketplaceListingsLayout();

See Also

MarketplaceListingsLayout Class | Aptify.Applications.Marketplace Namespace


MarketplaceListingsLayout Properties

The properties of the MarketplaceListingsLayout class are listed below. For a complete list of MarketplaceListingsLayout class members, see the MarketplaceListingsLayout Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ListingObject |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

MarketplaceListingsLayout Class | Aptify.Applications.Marketplace Namespace


ListingObject Property

Aptify 5.0 Software Development Kit (SDK)

MarketplaceListingsLayout.ListingObject Property

protected MarketplaceListingsEntity ListingObject {get;}

See Also

MarketplaceListingsLayout Class | Aptify.Applications.Marketplace Namespace


MarketplaceListingsLayout Methods

The methods of the MarketplaceListingsLayout class are listed below. For a complete list of MarketplaceListingsLayout class members, see the MarketplaceListingsLayout Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
ContextGEChanged |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControls |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig |
OnFormTemplateLoaded | Contains logic to setup Event handlers for controls on the FormTemplate Layout.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlVisibility |
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

MarketplaceListingsLayout Class | Aptify.Applications.Marketplace Namespace


MarketplaceListingsLayout.ContextGEChanged Method

protected virtual void ContextGEChanged(
Object Sender,
AptifyFormTemplateContext.GEChangedArgs e
);

See Also

MarketplaceListingsLayout Class | Aptify.Applications.Marketplace Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

MarketplaceListingsLayout.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

MarketplaceListingsLayout Class | Aptify.Applications.Marketplace Namespace


MarketplaceListingsLayout.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

MarketplaceListingsLayout Class | Aptify.Applications.Marketplace Namespace | MarketplaceListingsLayout.Dispose Overload List


MarketplaceListingsLayout.FindControls Method

protected virtual void FindControls(
String FormTemplateLayoutName
);

See Also

MarketplaceListingsLayout Class | Aptify.Applications.Marketplace Namespace


MarketplaceListingsLayout.OnFormComponentConfig Method

protected override void OnFormComponentConfig(
AptifyFormTemplateContext Context
);

Implements

IFormComponent.

See Also

MarketplaceListingsLayout Class | Aptify.Applications.Marketplace Namespace


MarketplaceListingsLayout.OnFormTemplateLoaded Method

Contains logic to setup Event handlers for controls on the FormTemplate Layout.

protected override void OnFormTemplateLoaded(
FormTemplateLayout.FormTemplateLoadedEventArgs e
);

Parameters

e

Remarks

See Also

MarketplaceListingsLayout Class | Aptify.Applications.Marketplace Namespace


MarketplaceListingsLayout.OnRefresh Method

protected override void OnRefresh();

Implements

IFormComponent.

See Also

MarketplaceListingsLayout Class | Aptify.Applications.Marketplace Namespace


MarketplaceListingsLayout.SetControlVisibility Method

protected void SetControlVisibility();

See Also

MarketplaceListingsLayout Class | Aptify.Applications.Marketplace Namespace


MarketplaceListingStatus Enumeration

public enum MarketplaceListingStatus

Members

Member Name | Description
Requested |
Approved |
Completed |
Cancelled |

Requirements

Namespace: Aptify.Applications.Marketplace

Assembly: AptifyMarketplaceListingsEntity (in AptifyMarketplaceListingsEntity.dll)

See Also

Aptify.Applications.Marketplace Namespace


Aptify.Applications.MeetingManagement

Aptify 5.0 Software Development Kit (SDK)

Aptify.Applications.MeetingManagement Namespace

This namespace corresponds to Aptify's Meeting Management application.

Namespace hierarchy

Classes

Class | Description
CloseMeetingForm | Contains functionality that allows a user to close a meeting.
MeetingsEntity | Contains logic needed to create, read, updated, and delete Meeting entity records.
MeetingsLayout |
StatusForm |

Delegates

Delegate | Description
MeetingsEntity.AfterMeetingAttributeFlowdownEventHandler |
MeetingsEntity.BeforeRemoveAllAttributesAndFlowdownEventHandler |


CloseMeetingForm Class

Contains functionality that allows a user to close a meeting.

For a list of all members of this type, see CloseMeetingForm Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
CloseMeetingForm

public class CloseMeetingForm : Form

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.MeetingManagement

Assembly: AptifyMeetingsGUI (in AptifyMeetingsGUI.dll)

See Also

CloseMeetingForm Members | Aptify.Applications.MeetingManagement Namespace


CloseMeetingForm Members

CloseMeetingForm overview

Public Instance Constructors

CloseMeetingForm Constructor Initializes a new instance of the CloseMeetingForm class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config | Configures the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
SetStatusValue |
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAll | Sets all status in the grid with the provided status.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
ShowStatusSelectionForm | Contains logic to display a mechanism that will let the user select the appropriate Status.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateInformation | Updates the Meeting Attendee Statuses based on data gather from this form.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CloseMeetingForm Class | Aptify.Applications.MeetingManagement Namespace


CloseMeetingForm Constructor

Initializes a new instance of the CloseMeetingForm class.

public CloseMeetingForm();

See Also

CloseMeetingForm Class | Aptify.Applications.MeetingManagement Namespace


CloseMeetingForm Methods

The methods of the CloseMeetingForm class are listed below. For a complete list of CloseMeetingForm class members, see the CloseMeetingForm Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config | Configures the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
SetStatusValue |
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAll | Sets all status in the grid with the provided status.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
ShowStatusSelectionForm | Contains logic to display a mechanism that will let the user select the appropriate Status.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateInformation | Updates the Meeting Attendee Statuses based on data gather from this form.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CloseMeetingForm Class | Aptify.Applications.MeetingManagement Namespace


CloseMeetingForm.Config Method

Configures the form.

public void Config(
AptifyApplication Application,
AptifyGenericEntityBase Meeting
);

Remarks

See Also

CloseMeetingForm Class | Aptify.Applications.MeetingManagement Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

CloseMeetingForm.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

CloseMeetingForm Class | Aptify.Applications.MeetingManagement Namespace


CloseMeetingForm.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

CloseMeetingForm Class | Aptify.Applications.MeetingManagement Namespace | CloseMeetingForm.Dispose Overload List


CloseMeetingForm.SetAll Method

Sets all status in the grid with the provided status.

protected void SetAll(
Int64 StatusID
);

Parameters

StatusID

Remarks

If StatusID < 1 Then nothing will occur.

See Also

CloseMeetingForm Class | Aptify.Applications.MeetingManagement Namespace


CloseMeetingForm.SetStatusValue Method

public void SetStatusValue(
Int64 lRecord,
Int64 lStatusID
);

See Also

CloseMeetingForm Class | Aptify.Applications.MeetingManagement Namespace


CloseMeetingForm.ShowStatusSelectionForm Method

Contains logic to display a mechanism that will let the user select the appropriate Status.

protected void ShowStatusSelectionForm();

Remarks

See Also

CloseMeetingForm Class | Aptify.Applications.MeetingManagement Namespace


CloseMeetingForm.UpdateInformation Method

Updates the Meeting Attendee Statuses based on data gather from this form.

protected bool UpdateInformation();

Return Value

Remarks

See Also

CloseMeetingForm Class | Aptify.Applications.MeetingManagement Namespace


MeetingsEntity Class

Contains logic needed to create, read, updated, and delete Meeting entity records.

For a list of all members of this type, see MeetingsEntity Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
MeetingsEntity

public class MeetingsEntity : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.MeetingManagement

Assembly: AptifyMeetingsEntity (in AptifyMeetingsEntity.dll)

See Also

MeetingsEntity Members | Aptify.Applications.MeetingManagement Namespace


MeetingsEntity Members

MeetingsEntity overview

Public Instance Constructors

MeetingsEntity Constructor Initializes a new instance of the MeetingsEntity class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
HasRegistrations |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config | Overloaded.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
FlowdownMeetingTypeAttributes |
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterMeetingAttributeFlowdown |
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeRemoveAllAttributesAndFlowdown |
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

MeetingsEntity Class | Aptify.Applications.MeetingManagement Namespace


MeetingsEntity Constructor

Initializes a new instance of the MeetingsEntity class.

public MeetingsEntity();

See Also

MeetingsEntity Class | Aptify.Applications.MeetingManagement Namespace


MeetingsEntity Properties

The properties of the MeetingsEntity class are listed below. For a complete list of MeetingsEntity class members, see the MeetingsEntity Members topic.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
HasRegistrations |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

MeetingsEntity Class | Aptify.Applications.MeetingManagement Namespace


HasRegistrations Property

Aptify 5.0 Software Development Kit (SDK)

MeetingsEntity.HasRegistrations Property

public Boolean HasRegistrations {get;}

See Also

MeetingsEntity Class | Aptify.Applications.MeetingManagement Namespace


MeetingsEntity Methods

The methods of the MeetingsEntity class are listed below. For a complete list of MeetingsEntity class members, see the MeetingsEntity Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config | Overloaded.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
FlowdownMeetingTypeAttributes |
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

MeetingsEntity Class | Aptify.Applications.MeetingManagement Namespace


Config Method

Aptify 5.0 Software Development Kit (SDK)

MeetingsEntity.Config Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual void Config(AptifySubTypeBase);

Inherited from AptifyGenericEntity.

public override void Config(AptifySubTypeBase,Int64);

Inherited from AptifyGenericEntityBase.

public virtual void Config(UserCredentials,String);

public override void Config(UserCredentials,String,Int64);

See Also

MeetingsEntity Class | Aptify.Applications.MeetingManagement Namespace


MeetingsEntity.Config Method (UserCredentials, String, Int64)

public override void Config(
UserCredentials UserCredentials,
String EntityName,
Int64 RecordID
);

See Also

MeetingsEntity Class | Aptify.Applications.MeetingManagement Namespace | MeetingsEntity.Config Overload List


MeetingsEntity.FlowdownMeetingTypeAttributes Method

public void FlowdownMeetingTypeAttributes(
Int64 lMeetingTypeID
);

See Also

MeetingsEntity Class | Aptify.Applications.MeetingManagement Namespace


Save Method

Aptify 5.0 Software Development Kit (SDK)

MeetingsEntity.Save Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Save();

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean,ref String&);

public override bool Save(Boolean,ref String&,String);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(ref String&);

See Also

MeetingsEntity Class | Aptify.Applications.MeetingManagement Namespace


MeetingsEntity.Save Method (Boolean, String&, String)

public override bool Save(
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

See Also

MeetingsEntity Class | Aptify.Applications.MeetingManagement Namespace | MeetingsEntity.Save Overload List


Validate Method

Aptify 5.0 Software Development Kit (SDK)

MeetingsEntity.Validate Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Validate();

public override bool Validate(ref String&);

See Also

MeetingsEntity Class | Aptify.Applications.MeetingManagement Namespace


MeetingsEntity.Validate Method (String&)

public override bool Validate(
ref String& ErrorString
);

See Also

MeetingsEntity Class | Aptify.Applications.MeetingManagement Namespace | MeetingsEntity.Validate Overload List


MeetingsEntity Events

The events of the MeetingsEntity class are listed below. For a complete list of MeetingsEntity class members, see the MeetingsEntity Members topic.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterMeetingAttributeFlowdown |
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeRemoveAllAttributesAndFlowdown |
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

See Also

MeetingsEntity Class | Aptify.Applications.MeetingManagement Namespace


MeetingsEntity.MeetingsEntity.AfterMeetingAttributeFlowdownEventHandler Event

public event MeetingsEntity.AfterMeetingAttributeFlowdownEventHandler AfterMeetingAttributeFlowdown;

See Also

MeetingsEntity Class | Aptify.Applications.MeetingManagement Namespace


MeetingsEntity.MeetingsEntity.BeforeRemoveAllAttributesAndFlowdownEventHandler Event

public event MeetingsEntity.BeforeRemoveAllAttributesAndFlowdownEventHandler BeforeRemoveAllAttributesAndFlowdown;

See Also

MeetingsEntity Class | Aptify.Applications.MeetingManagement Namespace


MeetingsEntity.AfterMeetingAttributeFlowdownEventHandler Delegate

public delegate void MeetingsEntity.AfterMeetingAttributeFlowdownEventHandler();

Requirements

Namespace: Aptify.Applications.MeetingManagement

Assembly: AptifyMeetingsEntity (in AptifyMeetingsEntity.dll)

See Also

Aptify.Applications.MeetingManagement Namespace


MeetingsEntity.BeforeRemoveAllAttributesAndFlowdownEventHandler Delegate

public delegate void MeetingsEntity.BeforeRemoveAllAttributesAndFlowdownEventHandler(
Boolean bCancel
);

Requirements

Namespace: Aptify.Applications.MeetingManagement

Assembly: AptifyMeetingsEntity (in AptifyMeetingsEntity.dll)

See Also

Aptify.Applications.MeetingManagement Namespace


MeetingsLayout Class

For a list of all members of this type, see MeetingsLayout Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
MeetingsLayout

public class MeetingsLayout : FormTemplateLayout

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.MeetingManagement

Assembly: AptifyMeetingsGUI (in AptifyMeetingsGUI.dll)

See Also

MeetingsLayout Members | Aptify.Applications.MeetingManagement Namespace


MeetingsLayout Members

MeetingsLayout overview

Public Instance Constructors

MeetingsLayout Constructor Initializes a new instance of the MeetingsLayout class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
AllowGroupsChanged |
CloseMeeting |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindCloseMeetingButton |
FindControls |
FindGroupSizeControls |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

MeetingsLayout Class | Aptify.Applications.MeetingManagement Namespace


MeetingsLayout Constructor

Initializes a new instance of the MeetingsLayout class.

public MeetingsLayout();

See Also

MeetingsLayout Class | Aptify.Applications.MeetingManagement Namespace


MeetingsLayout Methods

The methods of the MeetingsLayout class are listed below. For a complete list of MeetingsLayout class members, see the MeetingsLayout Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
AllowGroupsChanged |
CloseMeeting |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindCloseMeetingButton |
FindControls |
FindGroupSizeControls |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

MeetingsLayout Class | Aptify.Applications.MeetingManagement Namespace


MeetingsLayout.AllowGroupsChanged Method

protected virtual void AllowGroupsChanged();

See Also

MeetingsLayout Class | Aptify.Applications.MeetingManagement Namespace


MeetingsLayout.CloseMeeting Method

protected virtual void CloseMeeting();

See Also

MeetingsLayout Class | Aptify.Applications.MeetingManagement Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

MeetingsLayout.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

MeetingsLayout Class | Aptify.Applications.MeetingManagement Namespace


MeetingsLayout.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

MeetingsLayout Class | Aptify.Applications.MeetingManagement Namespace | MeetingsLayout.Dispose Overload List


MeetingsLayout.FindCloseMeetingButton Method

protected virtual void FindCloseMeetingButton();

See Also

MeetingsLayout Class | Aptify.Applications.MeetingManagement Namespace


MeetingsLayout.FindControls Method

protected virtual void FindControls();

See Also

MeetingsLayout Class | Aptify.Applications.MeetingManagement Namespace


MeetingsLayout.FindGroupSizeControls Method

protected virtual void FindGroupSizeControls();

See Also

MeetingsLayout Class | Aptify.Applications.MeetingManagement Namespace


MeetingsLayout.OnFormTemplateLoaded Method

protected override void OnFormTemplateLoaded(
FormTemplateLayout.FormTemplateLoadedEventArgs e
);

See Also

MeetingsLayout Class | Aptify.Applications.MeetingManagement Namespace


StatusForm Class

For a list of all members of this type, see StatusForm Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
StatusForm

public class StatusForm : Form

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.MeetingManagement

Assembly: AptifyMeetingsGUI (in AptifyMeetingsGUI.dll)

See Also

StatusForm Members | Aptify.Applications.MeetingManagement Namespace


StatusForm Members

StatusForm overview

Public Instance Constructors

StatusForm Constructor Initializes a new instance of the StatusForm class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetStatusID |
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

StatusForm Class | Aptify.Applications.MeetingManagement Namespace


StatusForm Constructor

Initializes a new instance of the StatusForm class.

public StatusForm();

See Also

StatusForm Class | Aptify.Applications.MeetingManagement Namespace


StatusForm Methods

The methods of the StatusForm class are listed below. For a complete list of StatusForm class members, see the StatusForm Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetStatusID |
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

StatusForm Class | Aptify.Applications.MeetingManagement Namespace


StatusForm.Config Method

public void Config(
AptifyApplication Application
);

See Also

StatusForm Class | Aptify.Applications.MeetingManagement Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

StatusForm.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

StatusForm Class | Aptify.Applications.MeetingManagement Namespace


StatusForm.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

StatusForm Class | Aptify.Applications.MeetingManagement Namespace | StatusForm.Dispose Overload List


StatusForm.GetStatusID Method

public long GetStatusID(
UltraDataSource DataSource
);

See Also

StatusForm Class | Aptify.Applications.MeetingManagement Namespace


Aptify.Applications.Meetings

Aptify 5.0 Software Development Kit (SDK)

Aptify.Applications.Meetings Namespace

This namespace contains the Check Inventory class used to manage inventory levels for Meetings product.

Namespace hierarchy

Classes

Class | Description
CheckMeetingInventory | This class inherits from the Aptify.Applications.Inventory.CheckInventory class and implements specialized functionality that is specific to inventory management for products that have a Product Type of 'Meeting'.


CheckMeetingInventory Class

This class inherits from the Aptify.Applications.Inventory.CheckInventory class and implements specialized functionality that is specific to inventory management for products that have a Product Type of 'Meeting'.

For a list of all members of this type, see CheckMeetingInventory Members.

System.Object
CheckInventory
CheckMeetingInventory

public class CheckMeetingInventory : CheckInventory

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Meetings

Assembly: CheckMeetingInventory (in CheckMeetingInventory.dll)

See Also

CheckMeetingInventory Members | Aptify.Applications.Meetings Namespace


CheckMeetingInventory Members

CheckMeetingInventory overview

Public Instance Constructors

CheckMeetingInventory Constructor Initializes a new instance of the CheckMeetingInventory class.

Public Instance Methods

CheckInventory |
Config (inherited from CheckInventory) | Configures the object for use, overridable by sub-classes
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInventoryLocation (inherited from CheckInventory) | This method is responsible for returning an inventory location to use for reserving inventory for a given Product, Quantity and optionally, taking into account a Primary Inventory Location ID. The method returns the Inventory Location ID that should be used given the parameters provided. The default logic implemented by the Check Inventory object is to use the Primary Location ID, if it is provided and it has available inventory. If the Primary Location ID is not provided, the inventory location with the largest amount of available inventory will be used. If This method is overridable by sub-classes so that more specialized inventory reservation algorithms can be created for things such as proximity based inventory reservation (e.g. reserving inventory closest to the customer's ship-to address, etc)
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

Application (inherited from CheckInventory) | Returns Aptify Application Object
DataAction (inherited from CheckInventory) | Returns Aptify Data Action class instance
Database (inherited from CheckInventory) | Returns Aptify Database Name Where Inventory related Entities are stored

Protected Instance Methods

DetermineInventoryStatus (inherited from CheckInventory) | This method is responsible for determining the status of inventory availability for a given item and returns if the inventory available is sufficient or insufficient based on the parameters passed in.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FindReleasedQuantity (inherited from CheckInventory) | This method is responsible for determining the amount of inventory that has been released on the current order by looking for an overall reduction in inventory being used for the current item represented by the OrderDetailGE parameter. This method finds the quantity by looking for the amount that was previously stored in the database for the given order for the product in the current line and comparing it to the total amount of quantity of the product on the order as it exists in the OrderGE provided. The function returns the difference between the persisted quantity(amount the database reflects) and the amount currently in the order as this amount needs to be taken into account as available in the overall calculation of available inventory. This calculation does not take into account inventory location as it is important to review this number globally from a product availability perspective. This method is only applicable for orders that have not yet been shipped as those orders are not allowed to change with respect to quantities, prices, and any other financial data, once marked as shipped.
GenerateInventoryWarning | This method overrides the base class method for the same functionality and provides a meetings-specific message to the user as opposed to the generic inventory terminology that is provided for in the base inventory checking component.
GetInventoryLocationInfo (inherited from CheckInventory) | Returns the appropriate (for the given quantity) inventory location that can be used to reserve inventory for a particular order line. PrimaryLocationID is used as the default location. If there is not sufficient quantity in that location, another location will be chosen.
GetInventoryOnCurrentOrder (inherited from CheckInventory) | This method is responsible for calculating the running total for the same products that exist in the same order. The purpose of the method is to make sure that enough inventory exist to account for the incremental change in the order. For example, if this is a NEW order line, the incremental change is simply the quantity on the order line. If this is an existing order line, the incremental change is the difference between the new quantity and the old quantity. If this is Shipped order, the incremental change is the sum of the all previous order lines' quantities where product and inventory location are the same. If the order is being shipped, we would take into account only lines that are before the shipped line. Lastly, if none of the above conditions are true, every line is taken into account dblQtyNewlyOrdered is a
GetInventoryOnOrderString (inherited from CheckInventory)
GetProductDefaultInvLocation (inherited from CheckInventory) | This function will return the default product inventory location, if one is specified in the product record. Otherwise, it will return the inventory location with the most units. If it can't find any inventory locations at all, then the function will return -1.
GetProductNameFromID (inherited from CheckInventory) | This method is responsible for returning the name of a product based on the Product ID. The Product cache is used to retrieve this information since product names do not change frequently.
GetProductTypeInfoFromProductID | This method is responsible for returning the name and ID of the product type associated with a given product via the ProductTypeID field that exists on the Products entity.
InternalCheckInventory (inherited from CheckInventory)
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CheckMeetingInventory Class | Aptify.Applications.Meetings Namespace


CheckMeetingInventory Constructor

Initializes a new instance of the CheckMeetingInventory class.

public CheckMeetingInventory();

See Also

CheckMeetingInventory Class | Aptify.Applications.Meetings Namespace


CheckMeetingInventory Methods

The methods of the CheckMeetingInventory class are listed below. For a complete list of CheckMeetingInventory class members, see the CheckMeetingInventory Members topic.

Public Instance Methods

CheckInventory |
Config (inherited from CheckInventory) | Configures the object for use, overridable by sub-classes
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInventoryLocation (inherited from CheckInventory) | This method is responsible for returning an inventory location to use for reserving inventory for a given Product, Quantity and optionally, taking into account a Primary Inventory Location ID. The method returns the Inventory Location ID that should be used given the parameters provided. The default logic implemented by the Check Inventory object is to use the Primary Location ID, if it is provided and it has available inventory. If the Primary Location ID is not provided, the inventory location with the largest amount of available inventory will be used. If This method is overridable by sub-classes so that more specialized inventory reservation algorithms can be created for things such as proximity based inventory reservation (e.g. reserving inventory closest to the customer's ship-to address, etc)
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

DetermineInventoryStatus (inherited from CheckInventory) | This method is responsible for determining the status of inventory availability for a given item and returns if the inventory available is sufficient or insufficient based on the parameters passed in.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FindReleasedQuantity (inherited from CheckInventory) | This method is responsible for determining the amount of inventory that has been released on the current order by looking for an overall reduction in inventory being used for the current item represented by the OrderDetailGE parameter. This method finds the quantity by looking for the amount that was previously stored in the database for the given order for the product in the current line and comparing it to the total amount of quantity of the product on the order as it exists in the OrderGE provided. The function returns the difference between the persisted quantity(amount the database reflects) and the amount currently in the order as this amount needs to be taken into account as available in the overall calculation of available inventory. This calculation does not take into account inventory location as it is important to review this number globally from a product availability perspective. This method is only applicable for orders that have not yet been shipped as those orders are not allowed to change with respect to quantities, prices, and any other financial data, once marked as shipped.
GenerateInventoryWarning | This method overrides the base class method for the same functionality and provides a meetings-specific message to the user as opposed to the generic inventory terminology that is provided for in the base inventory checking component.
GetInventoryLocationInfo (inherited from CheckInventory) | Returns the appropriate (for the given quantity) inventory location that can be used to reserve inventory for a particular order line. PrimaryLocationID is used as the default location. If there is not sufficient quantity in that location, another location will be chosen.
GetInventoryOnCurrentOrder (inherited from CheckInventory) | This method is responsible for calculating the running total for the same products that exist in the same order. The purpose of the method is to make sure that enough inventory exist to account for the incremental change in the order. For example, if this is a NEW order line, the incremental change is simply the quantity on the order line. If this is an existing order line, the incremental change is the difference between the new quantity and the old quantity. If this is Shipped order, the incremental change is the sum of the all previous order lines' quantities where product and inventory location are the same. If the order is being shipped, we would take into account only lines that are before the shipped line. Lastly, if none of the above conditions are true, every line is taken into account dblQtyNewlyOrdered is a
GetInventoryOnOrderString (inherited from CheckInventory)
GetProductDefaultInvLocation (inherited from CheckInventory) | This function will return the default product inventory location, if one is specified in the product record. Otherwise, it will return the inventory location with the most units. If it can't find any inventory locations at all, then the function will return -1.
GetProductNameFromID (inherited from CheckInventory) | This method is responsible for returning the name of a product based on the Product ID. The Product cache is used to retrieve this information since product names do not change frequently.
GetProductTypeInfoFromProductID | This method is responsible for returning the name and ID of the product type associated with a given product via the ProductTypeID field that exists on the Products entity.
InternalCheckInventory (inherited from CheckInventory)
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CheckMeetingInventory Class | Aptify.Applications.Meetings Namespace


CheckMeetingInventory.CheckInventory Method (Int64, Decimal, Boolean&, Decimal&, Decimal&, Decimal&, Decimal&, Decimal&, InventoryStatus&, OrderLinesEntity, Boolean, String&)

public override void CheckInventory(
Int64 ProductID,
Decimal Quantity,
ref Boolean& Required,
ref Decimal& QuantityAvailable,
ref Decimal& QuantityOnHand,
ref Decimal& QuantityOnOrder,
ref Decimal& QuantityReserved,
ref Decimal& QuantityShipped,
ref InventoryStatus& Status,
OrderLinesEntity OrderLineGE,
Boolean AllowGUI,
ref String& Message
);

Implements

ICheckInventory.

See Also

CheckMeetingInventory Class | Aptify.Applications.Meetings Namespace | CheckMeetingInventory.CheckInventory Overload List


CheckMeetingInventory.GenerateInventoryWarning Method

This method overrides the base class method for the same functionality and provides a meetings-specific message to the user as opposed to the generic inventory terminology that is provided for in the base inventory checking component.

protected override string GenerateInventoryWarning(
Int64 ProductID,
Decimal QuantityAvailable,
Decimal Quantity,
Decimal QuantityShipped,
Boolean CalculateShippedMode,
Decimal QuantityOnOrder,
OrdersEntity OrderGE,
OrderLinesEntity OrderDetailGE,
ICheckInventory.InventoryStatus Status
);

Parameters

ProductID
QuantityAvailable
Quantity
QuantityShipped
CalculateShippedMode
QuantityOnOrder
OrderGE
OrderDetailGE
Status

Return Value

Remarks

See Also

CheckMeetingInventory Class | Aptify.Applications.Meetings Namespace


CheckMeetingInventory.GetProductTypeInfoFromProductID Method

This method is responsible for returning the name and ID of the product type associated with a given product via the ProductTypeID field that exists on the Products entity.

protected virtual bool GetProductTypeInfoFromProductID(
Int64 ProductID,
ref String& ProductTypeName,
ref Int64& ProductTypeID
);

Parameters

ProductID
ProductTypeName
ProductTypeID

Return Value

Remarks

See Also

CheckMeetingInventory Class | Aptify.Applications.Meetings Namespace


Aptify.Applications.MemberTypes

Aptify 5.0 Software Development Kit (SDK)

Aptify.Applications.MemberTypes Namespace

The object in this namespace corresponds to the entity object for the Member Types entity.

Namespace hierarchy

Classes

Class | Description
MemberTypesEntity | Aptify Task GE Sub-Class Object - Implements Base MemberTypes Functionality This class can be sub-classed to alter the base functionality of the MemberTypes. Also consider implementing


MemberTypesEntity Class

Aptify Task GE Sub-Class Object - Implements Base MemberTypes Functionality This class can be sub-classed to alter the base functionality of the MemberTypes. Also consider implementing

For a list of all members of this type, see MemberTypesEntity Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
MemberTypesEntity

public class MemberTypesEntity : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.MemberTypes

Assembly: MemberTypes (in MemberTypes.dll)

See Also

MemberTypesEntity Members | Aptify.Applications.MemberTypes Namespace


MemberTypesEntity Members

MemberTypesEntity overview

Public Instance Constructors

MemberTypesEntity Constructor Initializes a new instance of the MemberTypesEntity class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

MemberTypesEntity Class | Aptify.Applications.MemberTypes Namespace


MemberTypesEntity Constructor

Initializes a new instance of the MemberTypesEntity class.

public MemberTypesEntity();

See Also

MemberTypesEntity Class | Aptify.Applications.MemberTypes Namespace


MemberTypesEntity Methods

The methods of the MemberTypesEntity class are listed below. For a complete list of MemberTypesEntity class members, see the MemberTypesEntity Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

MemberTypesEntity Class | Aptify.Applications.MemberTypes Namespace


Save Method

Aptify 5.0 Software Development Kit (SDK)

MemberTypesEntity.Save Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Save();

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean,ref String&);

public override bool Save(Boolean,ref String&,String);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(ref String&);

See Also

MemberTypesEntity Class | Aptify.Applications.MemberTypes Namespace


MemberTypesEntity.Save Method (Boolean, String&, String)

public override bool Save(
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

See Also

MemberTypesEntity Class | Aptify.Applications.MemberTypes Namespace | MemberTypesEntity.Save Overload List


Aptify.Applications.Notes

Aptify 5.0 Software Development Kit (SDK)

Aptify.Applications.Notes Namespace

The object in this namespace corresponds to the entity object for the Notes entity.

Namespace hierarchy

Classes

Class | Description
NotesEntity |


NotesEntity Class

For a list of all members of this type, see NotesEntity Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
NotesEntity

public class NotesEntity : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Notes

Assembly: NotesEntity (in NotesEntity.dll)

See Also

NotesEntity Members | Aptify.Applications.Notes Namespace


NotesEntity Members

NotesEntity overview

Public Instance Constructors

NotesEntity Constructor Initializes a new instance of the NotesEntity class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

NotesEntity Class | Aptify.Applications.Notes Namespace


NotesEntity Constructor

Initializes a new instance of the NotesEntity class.

public NotesEntity();

See Also

NotesEntity Class | Aptify.Applications.Notes Namespace


NotesEntity Methods

The methods of the NotesEntity class are listed below. For a complete list of NotesEntity class members, see the NotesEntity Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

NotesEntity Class | Aptify.Applications.Notes Namespace


Save Method

Aptify 5.0 Software Development Kit (SDK)

NotesEntity.Save Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Save();

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean,ref String&);

public override bool Save(Boolean,ref String&,String);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(ref String&);

See Also

NotesEntity Class | Aptify.Applications.Notes Namespace


NotesEntity.Save Method (Boolean, String&, String)

public override bool Save(
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

See Also

NotesEntity Class | Aptify.Applications.Notes Namespace | NotesEntity.Save Overload List


Aptify.Applications.OrderEntry

Aptify 5.0 Software Development Kit (SDK)

Aptify.Applications.OrderEntry Namespace

This namespace contains objects related to Aptify's standard Order Entry system.

Namespace hierarchy

Classes

Class | Description
AfterRowAddedEventArgs |
AfterRowChangedEventArgs |
AfterRowDeletedEventArgs |
BackOrders |
BeforeRowAddedEventArgs |
BeforeRowChangedEventArgs |
BeforeRowDeletedEventArgs |
BeforeUpgradeProductToLatestVersionEventArgs |
BoothInfo |
BulkOrdersGE | Implements a GE sub-class for the Bulk Orders entity to generate orders and manage the workflow around generating orders from the bulk order defintion.
CalculateShippingCost | This object implements the Aptify.Applications.OrderEntry.ICalculateShippingCost interface. The purpose of this component is to return a shipping cost for an order and is designed to be sub-classed to implement any specific functionality required.
CampaignDiscount | Used to return information about the Campaign discount
CancellationWizForm |
CancellationWizObject |
CheckCredit | This object implements the Aptify.Applications.OrderEntry.ICheckCredit interface. The purpose of this component is to check the credit for an order and return the status of that credit check back to the calling object.
CheckInventory | This class is responsible for checking inventory for all types of products. Sub-classes
CheckInventoryOnOrderLineFailedEventArgs |
ComponentPlugIn |
EmployeeOrderPermissionCache | Caches Employee Order Permissions information. Shared, on-demand cache.
EmployeeOrderPermissions |
ExpandKits | This object implements the Aptify.Framework.Applications.OrderEntry.IExpandKits interface. The purpose of this component is to handle the base use cases for expanding kits. This class is designed to be sub-classed as needed for configuration requirements.
ExtendedOrderDetailGE | Extended Order Detail Entities require special handling during the Order Save process to ensure that the proper links are created and maintained. The ExtendedOrderDetailGE class provides that special handling. All Extended Order Detail entities must use this object as the Entity Object.
GenerateCOGS | This object implements the Aptify.Framework.Applications.OrderEntry.IGenerateCOGS interface The purpose of this component is to generate Cost of Goods Sold GL entries for the order when requested by the Order entry system.
GenerateCOGS.CostEntry | This class is used within the CalculateCOGS Class to keep track of entries being created
GenerateStatus |
Hyperlink | A class to be used to show Hyperlink in C1FlexGrid (OrderLines) and process the click on each of item(cell).
IProductPrice.PriceAttribute | Attribute of a price
IProductPrice.PriceInfo | Details on a given price including the price as well as its related attributes
LineShipDialog |
OrderAddressFlowdown | This object implements the Aptify.Framework.Applications.OrderEntry.IOrderAddressFlowdown interface. The purpose of this component is to handle the flow down of information in orders.
OrderAddressInfo |
OrderAddressUtility |
OrderBoothDetailEntity |
OrderCancellationDetail |
OrderComponentPlugInDataException | Thrown when a Plug-In does not provide the appropriate data to retrieve and instantiate the Plug-In. For example: If an Assembly Name or Class Name is defined for a plug-in, both must be defined.
OrderException |
OrderExpoDetailLayout | The class represents the layout control for the Order Booth Detail form.
OrderExtraPayment | Implements a user interface that provides the user the ability to add extra payment information to an order when a credit memo doesn't pay for the entire order balance
OrderGenerateGL | This object implements the Aptify.Applications.Accounting.IGenerateGL interface. The purpose of this component is to generate GL entries for an order
OrderLine |
OrderLineColumn |
OrderLineDetails |
OrderLineInfo |
OrderLinesEntity | Represents the sub-class to AptifyGenericEntity that is used for the OrderLines entity and also implements the ICheckInventory and IProductPrice interfaces.
OrderMeetingDetailEntity |
OrderProductCache | Caches Product and Product Types information used by the Orders objects. Shared, on-demand cache. All Product Types will be downloaded when first accessed for efficiency
OrderRequestedDataNotFound | Thrown when information is requested by the caller but that information could not be found.
OrdersEntity | OrdersEntity is the Generic Entity Sub-Class Object for the Orders Entity in the standard Aptify CRM system. Subclass this class to alter functionality in the standard Aptify OrdersEntity.
OrdersEntity.NoSuccessorProductException | This exception is thrown whenever a product reaches its maximum renewal cycle and has no successor product defined for it
OrdersExtension |
OrderShipmentsEntity |
OrganizationGLAccountNumbers |
PriceSelectionList |
PricingPermissions |
ProductData | Information about a Product that is used by the Order Entry system. This is the object that is stored in the Order Product Cache.
ProductGLAccountNumbers |
ProductPartData |
ProductTypeAttribute |
ProductTypeData |
RelatedProductEventArgs |
RelatedProductInfo | Provides information about a Related Product. Used by the Related Products UI (IRelatedProductsUI) and Object (IRelatedProducts).
RelatedProducts |
RelatedProductsForm |
SalesTaxAmount |
SalesTaxRate |
SalesTaxRateCache |
SalesTaxRateGLAccountCache | Caches Sales Tax Rate GL Account information Shared, on-demand cache.
SalesTaxRateGLAccounts |
SelectCancellationItemDialog |
ShipmentTypeCache | Caches Shipment Types information. Shared, on-demand cache.
ShipmentTypeData | Stores information about a Shipment Types record. Used by the ShipmentTypeCache.
ShipmentTypeGLAccountCache | Caches Sales Tax Rate GL Account information Shared, on-demand cache.
ShipmentTypeGLAccounts |
ShipmentTypeGroupingData |
ShipmentTypeGroupingsEntity |
ShipmentTypeMatrixData |
ShipmentTypeMatrixEntity |
ShipmentTypeMatrixLayout |
ShippingCalculator | This object implements the Aptify.Framework.Applications.Accounting.ISalesTaxRate interface. The purpose of this component is to return a tax rate for a given set of input parameters base currency id.
StatusForm |
TaxAddress |
TotalsChangedEventArgs |
WizardText |

Interfaces

Interface | Description
IBackOrder
ICalculateShippingCost | This interface is NO longer used. Please use "IShippingCalculator" interface instead of this. This interface is used to create plug-in objects that are responsible for calculating the shipping costs for an order. In order to plug-in an object that calculates shipping costs in Aptify Order Entry, either implement a sub-class of the Aptify CalculateShippingCost base shipping class, or implement this interface in any other object. After the implementation of the object is complete, place the Object, Class and Assembly information in the following attributes inside the Aptify Orders Entity: Ship Cost Object - Object Repository PackageName.ObjectName location of the object Ship Cost Class - Fully qualified class name that implements this interface from root namespace down Ship Cost Assembly - Name of assembly where the Ship Cost Class is located
ICampaignCalculateDiscount | Interface used to create plug-ins for retrieving discounts associated with Campaigns
IChapterAssignmentRules | Abstract interface class used for creating plug-ins for the Chapter Assignment Rule functionality. Used by the Orders Entity as a Plug-In type. If creating a new plug-in for Chapter Assignment Rules, it is recommended to sub-class the base ChapterAssignmentRules object that is implemented in the Aptify ChapterAssignmentRules assembly ( within the Aptify.Applications.Chapters namespace ) instead of implementing a new class that directly implements this interface in order to reuse existing functionality in the ChapterAssignmentRules class.
ICheckCredit | This interface is used to create plug-in objects that are responsible for checking credit of companies or individuals on an order. In order to plug-in an object that handles this functionality in Aptify Order Entry, either implement a sub-class of the Aptify CheckCredit base credit checking class, or implement this interface in any other object. After the implementation of the object is complete, place the Object, Class and Assembly information in the following attributes inside the Aptify Orders Entity: Credit Check Object - Object Repository PackageName.ObjectName location of the object Credit Check Class - Fully qualified class name that implements this interface from root namespace down Credit Check Assembly - Name of assembly where the Credit Check Class is located
ICheckInventory | This interface provides for the ability to create plug-in classes that can be used by the rest of the Aptify Order Entry system.
IExpandKits | Interface used to create plug-ins for expanding kits products within the Order Entry system. The order entry system will look for a plug-in that implements this interface within the Aptify Entity model by looking at the following entity attributes and attempting to instantiate an object that is specified as shown in the entity attributes. The specified object must implement IExpandKits. Note that in addition to this abstract interface Aptify provides a default implementation class Aptify.Applications.OrderEntry.ExpandKits which may be subclassed to accomodate unique configuration needs rather than creating entirely new objects that implement this interface directly. Entity Attributes in the Orders Entity Name: "Kit Expansion Object" Location of the object in the Aptify Object Repository. Name: "Kit Expansion Class" Class Name (fully qualified including root namespace) the implements this interface. Default value is Aptify.Applications.OrderEntry.ExpandKits Name "Kit Expansion Assembly" Assembly Name where the above class is located
IExtraPaymentDialog
IGenerateCOGS | This interface is used for plug-ins to create Cost of Goods Sold (COGS) GL entries as needed in different application areas in the Aptify Order Entry system.
ILineShipDialog | Interface used to allow plugin of a Line Shipping Dialog.
IOrderAddressFlowdown | Interface used to create plug-ins for flowing down address and other order information
IProductPrice | Interface used to create plug-ins for retrieving product prices
IRelatedProducts | Related Products Businesss Object Interface. Used by the Entity Plug In Type Orders.Related Products
IRelatedProductsUI | Related Products User Interface. Used by the Entity Plug In Type Orders.Related Products UI
ISalesTax | Interface used to create plug-ins for determining Tax Jurisdictions and performing Sales Tax calculations.
IShippingCalculator | Interface used to create plug-ins for determining the Shipment Type and calculating Shipping Charges, Handling Charges and Shipping Cost.
ISubscriptionSave | Interface used to create plug-ins for saving subscriptions from the Order Entry system. The order entry system will look for a plug-in that implements this interface within the Aptify Entity model by looking at the following entity attributes and attempting to instantiate an object that is specified as shown in the entity attributes. The specified object must implement ISubscriptionSave. Note that in addition to this abstract interface Aptify provides a default implementation class Aptify.Applications.OrderEntry.SubscriptionSave which may be subclassed to accomodate unique configuration needs rather than creating entirely new objects that implement this interface directly. Entity Attributes in the Orders Entity Name: "Subscription Save Object" Location of the subscription save object in the Aptify Object Repository. Name: "Subscription Save Class" Class Name (fully qualified including root namespace) the implements this interface. Default value is Aptify.Applications.OrderEntry.SubscriptionSave Name "Subscription Save Assembly" Assembly Name where the above class is located

Structures

Structure | Description
CheckCredit.Currency |
EmployeeOrderPermissions.ProductCategoryFilter |
GenerateCOGS.Currency |
OrdersEntity.IDandName | A structure that is used for ID and Name.
Weight |

Delegates

Delegate | Description
BulkOrdersGE.StatusUpdateEventHandler |
CancellationWizObject.StatusEventHandler |
CancellationWizObject.TerminateWizardEventHandler |
CancellationWizObject.ValidationErrorFoundEventHandler |
IBackOrder.StatusUpdateEventHandler |
IRelatedProductsUI.AddRelatedProductToOrderEventHandler |
IRelatedProductsUI.UserClosedRelatedProductsUIEventHandler |
ISubscriptionSave.StatusUpdateEventHandler |
OrderLine.AfterRowAddedEventHandler |
OrderLine.AfterRowChangedEventHandler |
OrderLine.AfterRowDeletedEventHandler |
OrderLine.BeforeRowAddedEventHandler |
OrderLine.BeforeRowChangedEventHandler |
OrderLine.BeforeRowDeletedEventHandler |
OrderLine.KitAddedEventHandler |
OrderLine.TotalsChangedEventHandler |
OrderLineDetails.AddButtonClickEventHandler |
OrderLineDetails.AfterRowAddedEventHandler |
OrderLineDetails.AfterRowChangedEventHandler |
OrderLineDetails.AfterRowDeletedEventHandler |
OrderLineDetails.BeforeRowAddedEventHandler |
OrderLineDetails.BeforeRowChangedEventHandler |
OrderLineDetails.BeforeRowDeletedEventHandler |
OrderLineDetails.ProductValueChangedEventHandler |
OrderLineDetails.QuantityChangedEventHandler |
OrderLineDetails.TotalsChangedEventHandler |
OrdersEntity.BeforeUpgradeProductToLatestVersionEventHandler |
OrdersEntity.CheckInventoryOnOrderLineFailedEventHandler |
OrdersEntity.ProcessTerminatedEventHandler |
OrdersEntity.StatusUpdateEventHandler |
OrdersEntity.TotalsUpdatedEventHandler |
PriceSelectionList.PriceListMouseEnterEventHandler |
PriceSelectionList.PriceListMouseLeaveEventHandler |

Enumerations

Enumeration | Description
BoothInfo.BoothSurchargeTypes |
BulkOrdersGE.BulkOrderSourceViewType | Types of views supported by the Bulk Order Import process
EmployeeOrderPermissions.ProductFilterTypes |
ICheckInventory.InventoryStatus |
IProductPrice.PriceOutcome | Indicates the result of functions in this interface
IProductPrice.PriceSourceType | Enum used for tracking the different sources of pricing including standard pricing, rule-based pricing and object-based pricing
OrderLineColumn.TextAlignmentEnum |
OrderLineColumn.TextDirectionEnum |
OrderLineColumn.TextEffectEnum |
OrderLinesEntity.PurchaseTypes |
OrdersEntity.AdditionalPaymentPromptResult |
OrdersEntity.AddressFlowDownTypes |
OrdersEntity.AutoShipmentSetting |
OrdersEntity.AutoShippingAvailabilityTypes |
OrdersEntity.BackOrderARTypes |
OrderStatus | Lists the different Order Status Types defined for Aptify Order Entry
OrderType | This enumerated type has the different possible order types listed in it
PriceBaseType | Price Base Type supports tracking the ability for each price record to have a different pricing calculation type, either a regular price(no calculation), a base price which is used to derive other prices, or a percent of base price which is calculated as a percentage of the base price
PriceRoundingType | Price Rounding Type is used to determine the type of rounding to use for derived pricing (currency derivation and base price/percent of base derivation).
ProductData.CanBeSoldResult |
ProductData.MemberTypePurchaseType |
ProductData.ProductCostMethod |
ProductData.ProductKitType |
ProductData.SubscriptionSuccessionModeOptions | Determines what to do when a succession is to take place, either replace with a fixed product, use a rule to dynamically calculate the successor product, or terminate the subscription.
ProductData.SubscriptionSuccessionTriggerTypeOptions | Type of succession trigger for subscription products
ProductData.WeightUnitsOfMeasure |
ShipmentTypeCalculationType |
ShipmentTypeMatrixData.MatrixCalculationType |
ShipmentTypeMatrixData.MatrixShipToScope |
ShipmentTypeRevenueRecognitionType |


AfterRowAddedEventArgs Class

For a list of all members of this type, see AfterRowAddedEventArgs Members.

System.Object
EventArgs
AfterRowAddedEventArgs

public class AfterRowAddedEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrderLineControl (in AptifyOrderLineControl.dll)

See Also

AfterRowAddedEventArgs Members | Aptify.Applications.OrderEntry Namespace


AfterRowAddedEventArgs Members

AfterRowAddedEventArgs overview

Public Instance Constructors

AfterRowAddedEventArgs Constructor

Public Instance Properties

OrderLine

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AfterRowAddedEventArgs Class | Aptify.Applications.OrderEntry Namespace


AfterRowAddedEventArgs Constructor

public AfterRowAddedEventArgs(
OrderLinesEntity OrderLineGE
);

See Also

AfterRowAddedEventArgs Class | Aptify.Applications.OrderEntry Namespace


AfterRowAddedEventArgs Properties

The properties of the AfterRowAddedEventArgs class are listed below. For a complete list of AfterRowAddedEventArgs class members, see the AfterRowAddedEventArgs Members topic.

Public Instance Properties

OrderLine

See Also

AfterRowAddedEventArgs Class | Aptify.Applications.OrderEntry Namespace


OrderLine Property

Aptify 5.0 Software Development Kit (SDK)

AfterRowAddedEventArgs.OrderLine Property

public OrderLinesEntity OrderLine {get;}

See Also

AfterRowAddedEventArgs Class | Aptify.Applications.OrderEntry Namespace


AfterRowChangedEventArgs Class

For a list of all members of this type, see AfterRowChangedEventArgs Members.

System.Object
EventArgs
AfterRowChangedEventArgs

public class AfterRowChangedEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrderLineControl (in AptifyOrderLineControl.dll)

See Also

AfterRowChangedEventArgs Members | Aptify.Applications.OrderEntry Namespace


AfterRowChangedEventArgs Members

AfterRowChangedEventArgs overview

Public Instance Constructors

AfterRowChangedEventArgs Constructor

Public Instance Properties

OrderLine
Row

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AfterRowChangedEventArgs Class | Aptify.Applications.OrderEntry Namespace


AfterRowChangedEventArgs Constructor

public AfterRowChangedEventArgs(
Int32 Row,
OrderLinesEntity OrderLineGE
);

See Also

AfterRowChangedEventArgs Class | Aptify.Applications.OrderEntry Namespace


AfterRowChangedEventArgs Properties

The properties of the AfterRowChangedEventArgs class are listed below. For a complete list of AfterRowChangedEventArgs class members, see the AfterRowChangedEventArgs Members topic.

Public Instance Properties

OrderLine
Row

See Also

AfterRowChangedEventArgs Class | Aptify.Applications.OrderEntry Namespace


OrderLine Property

Aptify 5.0 Software Development Kit (SDK)

AfterRowChangedEventArgs.OrderLine Property

public OrderLinesEntity OrderLine {get;}

See Also

AfterRowChangedEventArgs Class | Aptify.Applications.OrderEntry Namespace


Row Property

Aptify 5.0 Software Development Kit (SDK)

AfterRowChangedEventArgs.Row Property

public Int32 Row {get;}

See Also

AfterRowChangedEventArgs Class | Aptify.Applications.OrderEntry Namespace


AfterRowDeletedEventArgs Class

For a list of all members of this type, see AfterRowDeletedEventArgs Members.

System.Object
EventArgs
AfterRowDeletedEventArgs

public class AfterRowDeletedEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrderLineControl (in AptifyOrderLineControl.dll)

See Also

AfterRowDeletedEventArgs Members | Aptify.Applications.OrderEntry Namespace


AfterRowDeletedEventArgs Members

AfterRowDeletedEventArgs overview

Public Instance Constructors

AfterRowDeletedEventArgs Constructor

Public Instance Properties

OldRow

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AfterRowDeletedEventArgs Class | Aptify.Applications.OrderEntry Namespace


AfterRowDeletedEventArgs Constructor

public AfterRowDeletedEventArgs(
Int32 OldRow
);

See Also

AfterRowDeletedEventArgs Class | Aptify.Applications.OrderEntry Namespace


AfterRowDeletedEventArgs Properties

The properties of the AfterRowDeletedEventArgs class are listed below. For a complete list of AfterRowDeletedEventArgs class members, see the AfterRowDeletedEventArgs Members topic.

Public Instance Properties

OldRow

See Also

AfterRowDeletedEventArgs Class | Aptify.Applications.OrderEntry Namespace


OldRow Property

Aptify 5.0 Software Development Kit (SDK)

AfterRowDeletedEventArgs.OldRow Property

public Int32 OldRow {get;}

See Also

AfterRowDeletedEventArgs Class | Aptify.Applications.OrderEntry Namespace


BackOrders Class

For a list of all members of this type, see BackOrders Members.

System.Object
BackOrders

public class BackOrders : IBackOrder

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: BackOrders (in BackOrders.dll)

See Also

BackOrders Members | Aptify.Applications.OrderEntry Namespace


BackOrders Members

BackOrders overview

Public Instance Constructors

BackOrders Constructor Initializes a new instance of the BackOrders class.

Public Instance Methods

Configure |
CreateBackOrders |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

StatusUpdate

Protected Instance Methods

AdjustOriginalOrder |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnStatusUpdate |
ProcessBackOrderLine |
RestoreOriginalOrderQuantities | Called when the Original Order Shipment fails. The OrderLine Quantities need to be restored to their pre-adjusted value.
UpdateBackOrder |
UpdateBackOrderKitItems |

See Also

BackOrders Class | Aptify.Applications.OrderEntry Namespace


BackOrders Constructor

Initializes a new instance of the BackOrders class.

public BackOrders();

See Also

BackOrders Class | Aptify.Applications.OrderEntry Namespace


BackOrders Methods

The methods of the BackOrders class are listed below. For a complete list of BackOrders class members, see the BackOrders Members topic.

Public Instance Methods

Configure |
CreateBackOrders |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

AdjustOriginalOrder |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnStatusUpdate |
ProcessBackOrderLine |
RestoreOriginalOrderQuantities | Called when the Original Order Shipment fails. The OrderLine Quantities need to be restored to their pre-adjusted value.
UpdateBackOrder |
UpdateBackOrderKitItems |

See Also

BackOrders Class | Aptify.Applications.OrderEntry Namespace


BackOrders.AdjustOriginalOrder Method

protected virtual void AdjustOriginalOrder(
OrdersEntity OriginalOrderGE
);

See Also

BackOrders Class | Aptify.Applications.OrderEntry Namespace


BackOrders.Configure Method

public bool Configure(
AptifyApplication Application
);

Implements

IBackOrder.

See Also

BackOrders Class | Aptify.Applications.OrderEntry Namespace


BackOrders.CreateBackOrders Method

public bool CreateBackOrders(
OrdersEntity OrderGE,
ref String& ErrorString
);

Implements

IBackOrder.

See Also

BackOrders Class | Aptify.Applications.OrderEntry Namespace


BackOrders.OnStatusUpdate Method

protected virtual void OnStatusUpdate(
String sMessage,
Int32 iProgress
);

See Also

BackOrders Class | Aptify.Applications.OrderEntry Namespace


BackOrders.ProcessBackOrderLine Method

protected virtual OrderLinesEntity ProcessBackOrderLine(
OrdersEntity BackOrderGE,
OrderLinesEntity OriginalOrderLineGE
);

See Also

BackOrders Class | Aptify.Applications.OrderEntry Namespace


BackOrders.RestoreOriginalOrderQuantities Method

Called when the Original Order Shipment fails. The OrderLine Quantities need to be restored to their pre-adjusted value.

protected virtual void RestoreOriginalOrderQuantities(
OrdersEntity OriginalOrderGE
);

Parameters

OriginalOrderGE

Remarks

See Also

BackOrders Class | Aptify.Applications.OrderEntry Namespace


BackOrders.UpdateBackOrder Method

protected virtual void UpdateBackOrder(
OrdersEntity BackOrderGE,
OrderLinesEntity OriginalOrderLineGE
);

See Also

BackOrders Class | Aptify.Applications.OrderEntry Namespace


BackOrders.UpdateBackOrderKitItems Method

protected virtual void UpdateBackOrderKitItems(
OrdersEntity BackOrderGE,
OrderLinesEntity OriginalKitOrderLineGE,
Int32 ParentSequence
);

See Also

BackOrders Class | Aptify.Applications.OrderEntry Namespace


BackOrders Events

The events of the BackOrders class are listed below. For a complete list of BackOrders class members, see the BackOrders Members topic.

Public Instance Events

StatusUpdate

See Also

BackOrders Class | Aptify.Applications.OrderEntry Namespace


BackOrders.IBackOrder.StatusUpdateEventHandler Event

public event IBackOrder.StatusUpdateEventHandler StatusUpdate;

Implements

IBackOrder.

See Also

BackOrders Class | Aptify.Applications.OrderEntry Namespace


BeforeRowAddedEventArgs Class

For a list of all members of this type, see BeforeRowAddedEventArgs Members.

System.Object
EventArgs
CancelEventArgs
BeforeRowAddedEventArgs

public class BeforeRowAddedEventArgs : CancelEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrderLineControl (in AptifyOrderLineControl.dll)

See Also

BeforeRowAddedEventArgs Members | Aptify.Applications.OrderEntry Namespace


BeforeRowAddedEventArgs Members

BeforeRowAddedEventArgs overview

Public Instance Constructors

BeforeRowAddedEventArgs Constructor

Public Instance Properties

Cancel (inherited from CancelEventArgs) | Gets or sets a value indicating whether the event should be canceled.
OrderLine |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BeforeRowAddedEventArgs Class | Aptify.Applications.OrderEntry Namespace


BeforeRowAddedEventArgs Constructor

public BeforeRowAddedEventArgs(
Int32 Row,
OrderLinesEntity OrderLineGE
);

See Also

BeforeRowAddedEventArgs Class | Aptify.Applications.OrderEntry Namespace


BeforeRowAddedEventArgs Properties

The properties of the BeforeRowAddedEventArgs class are listed below. For a complete list of BeforeRowAddedEventArgs class members, see the BeforeRowAddedEventArgs Members topic.

Public Instance Properties

Cancel (inherited from CancelEventArgs) | Gets or sets a value indicating whether the event should be canceled.
OrderLine |

See Also

BeforeRowAddedEventArgs Class | Aptify.Applications.OrderEntry Namespace


OrderLine Property

Aptify 5.0 Software Development Kit (SDK)

BeforeRowAddedEventArgs.OrderLine Property

public OrderLinesEntity OrderLine {get;}

See Also

BeforeRowAddedEventArgs Class | Aptify.Applications.OrderEntry Namespace


BeforeRowChangedEventArgs Class

For a list of all members of this type, see BeforeRowChangedEventArgs Members.

System.Object
EventArgs
CancelEventArgs
BeforeRowChangedEventArgs

public class BeforeRowChangedEventArgs : CancelEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrderLineControl (in AptifyOrderLineControl.dll)

See Also

BeforeRowChangedEventArgs Members | Aptify.Applications.OrderEntry Namespace


BeforeRowChangedEventArgs Members

BeforeRowChangedEventArgs overview

Public Instance Constructors

BeforeRowChangedEventArgs Constructor

Public Instance Properties

Cancel (inherited from CancelEventArgs) | Gets or sets a value indicating whether the event should be canceled.
OrderLine |
Row |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BeforeRowChangedEventArgs Class | Aptify.Applications.OrderEntry Namespace


BeforeRowChangedEventArgs Constructor

public BeforeRowChangedEventArgs(
Int32 Row,
OrderLinesEntity OrderLineGE
);

See Also

BeforeRowChangedEventArgs Class | Aptify.Applications.OrderEntry Namespace


BeforeRowChangedEventArgs Properties

The properties of the BeforeRowChangedEventArgs class are listed below. For a complete list of BeforeRowChangedEventArgs class members, see the BeforeRowChangedEventArgs Members topic.

Public Instance Properties

Cancel (inherited from CancelEventArgs) | Gets or sets a value indicating whether the event should be canceled.
OrderLine |
Row |

See Also

BeforeRowChangedEventArgs Class | Aptify.Applications.OrderEntry Namespace


OrderLine Property

Aptify 5.0 Software Development Kit (SDK)

BeforeRowChangedEventArgs.OrderLine Property

public OrderLinesEntity OrderLine {get;}

See Also

BeforeRowChangedEventArgs Class | Aptify.Applications.OrderEntry Namespace


Row Property

Aptify 5.0 Software Development Kit (SDK)

BeforeRowChangedEventArgs.Row Property

public Int32 Row {get;}

See Also

BeforeRowChangedEventArgs Class | Aptify.Applications.OrderEntry Namespace


BeforeRowDeletedEventArgs Class

For a list of all members of this type, see BeforeRowDeletedEventArgs Members.

System.Object
EventArgs
CancelEventArgs
BeforeRowDeletedEventArgs

public class BeforeRowDeletedEventArgs : CancelEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrderLineControl (in AptifyOrderLineControl.dll)

See Also

BeforeRowDeletedEventArgs Members | Aptify.Applications.OrderEntry Namespace


BeforeRowDeletedEventArgs Members

BeforeRowDeletedEventArgs overview

Public Instance Constructors

BeforeRowDeletedEventArgs Constructor

Public Instance Properties

Cancel (inherited from CancelEventArgs) | Gets or sets a value indicating whether the event should be canceled.
OldRow |
OrderLine |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BeforeRowDeletedEventArgs Class | Aptify.Applications.OrderEntry Namespace


BeforeRowDeletedEventArgs Constructor

public BeforeRowDeletedEventArgs(
Int32 OldRow,
OrderLinesEntity OrderLineGE
);

See Also

BeforeRowDeletedEventArgs Class | Aptify.Applications.OrderEntry Namespace


BeforeRowDeletedEventArgs Properties

The properties of the BeforeRowDeletedEventArgs class are listed below. For a complete list of BeforeRowDeletedEventArgs class members, see the BeforeRowDeletedEventArgs Members topic.

Public Instance Properties

Cancel (inherited from CancelEventArgs) | Gets or sets a value indicating whether the event should be canceled.
OldRow |
OrderLine |

See Also

BeforeRowDeletedEventArgs Class | Aptify.Applications.OrderEntry Namespace


OldRow Property

Aptify 5.0 Software Development Kit (SDK)

BeforeRowDeletedEventArgs.OldRow Property

public Int32 OldRow {get;}

See Also

BeforeRowDeletedEventArgs Class | Aptify.Applications.OrderEntry Namespace


OrderLine Property

Aptify 5.0 Software Development Kit (SDK)

BeforeRowDeletedEventArgs.OrderLine Property

public OrderLinesEntity OrderLine {get;}

See Also

BeforeRowDeletedEventArgs Class | Aptify.Applications.OrderEntry Namespace


BeforeUpgradeProductToLatestVersionEventArgs Class

For a list of all members of this type, see BeforeUpgradeProductToLatestVersionEventArgs Members.

System.Object
EventArgs
CancelEventArgs
BeforeUpgradeProductToLatestVersionEventArgs

public class BeforeUpgradeProductToLatestVersionEventArgs : CancelEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

BeforeUpgradeProductToLatestVersionEventArgs Members | Aptify.Applications.OrderEntry Namespace


BeforeUpgradeProductToLatestVersionEventArgs Members

BeforeUpgradeProductToLatestVersionEventArgs overview

Public Static Properties

UserCredential

Public Instance Constructors

BeforeUpgradeProductToLatestVersionEventArgs Constructor

Public Instance Properties

Cancel (inherited from CancelEventArgs) | Gets or sets a value indicating whether the event should be canceled.
NewVersionProductID |
NewVersionProductName |
OriginalProductID |
OriginalProductName |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BeforeUpgradeProductToLatestVersionEventArgs Class | Aptify.Applications.OrderEntry Namespace


BeforeUpgradeProductToLatestVersionEventArgs Constructor

public BeforeUpgradeProductToLatestVersionEventArgs(
Int64 OriginalProductID,
String OriginalProductName,
Int64 NewVersionProductID,
String NewVersionProductName
);

See Also

BeforeUpgradeProductToLatestVersionEventArgs Class | Aptify.Applications.OrderEntry Namespace


BeforeUpgradeProductToLatestVersionEventArgs Properties

The properties of the BeforeUpgradeProductToLatestVersionEventArgs class are listed below. For a complete list of BeforeUpgradeProductToLatestVersionEventArgs class members, see the BeforeUpgradeProductToLatestVersionEventArgs Members topic.

Public Static Properties

UserCredential

Public Instance Properties

Cancel (inherited from CancelEventArgs) | Gets or sets a value indicating whether the event should be canceled.
NewVersionProductID |
NewVersionProductName |
OriginalProductID |
OriginalProductName |

See Also

BeforeUpgradeProductToLatestVersionEventArgs Class | Aptify.Applications.OrderEntry Namespace


NewVersionProductID Property

Aptify 5.0 Software Development Kit (SDK)

BeforeUpgradeProductToLatestVersionEventArgs.NewVersionProductID Property

public Int64 NewVersionProductID {get; set;}

See Also

BeforeUpgradeProductToLatestVersionEventArgs Class | Aptify.Applications.OrderEntry Namespace


NewVersionProductName Property

Aptify 5.0 Software Development Kit (SDK)

BeforeUpgradeProductToLatestVersionEventArgs.NewVersionProductName Property

public String NewVersionProductName {get; set;}

See Also

BeforeUpgradeProductToLatestVersionEventArgs Class | Aptify.Applications.OrderEntry Namespace


OriginalProductID Property

Aptify 5.0 Software Development Kit (SDK)

BeforeUpgradeProductToLatestVersionEventArgs.OriginalProductID Property

public Int64 OriginalProductID {get;}

See Also

BeforeUpgradeProductToLatestVersionEventArgs Class | Aptify.Applications.OrderEntry Namespace


OriginalProductName Property

Aptify 5.0 Software Development Kit (SDK)

BeforeUpgradeProductToLatestVersionEventArgs.OriginalProductName Property

public String OriginalProductName {get;}

See Also

BeforeUpgradeProductToLatestVersionEventArgs Class | Aptify.Applications.OrderEntry Namespace


UserCredential Property

Aptify 5.0 Software Development Kit (SDK)

BeforeUpgradeProductToLatestVersionEventArgs.UserCredential Property

public static UserCredentials UserCredential {set;}

See Also

BeforeUpgradeProductToLatestVersionEventArgs Class | Aptify.Applications.OrderEntry Namespace


BoothInfo Class

For a list of all members of this type, see BoothInfo Members.

System.Object
BoothInfo

public class BoothInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOBDEntity (in AptifyOBDEntity.dll)

See Also

BoothInfo Members | Aptify.Applications.OrderEntry Namespace


BoothInfo Members

BoothInfo overview

Public Instance Constructors

BoothInfo Constructor Initializes a new instance of the BoothInfo class.

Public Instance Properties

BaseUnitPrice
BoothName
BoothSurcharge
ID
NumUnits
OverrideSurcharge
SurchargePercent
SurchargeType

Public Instance Methods

CalculateBoothUnitPrice |
CalculateSurcharge |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BoothInfo Class | Aptify.Applications.OrderEntry Namespace


BoothInfo Constructor

Initializes a new instance of the BoothInfo class.

public BoothInfo();

See Also

BoothInfo Class | Aptify.Applications.OrderEntry Namespace


BoothInfo Properties

The properties of the BoothInfo class are listed below. For a complete list of BoothInfo class members, see the BoothInfo Members topic.

Public Instance Properties

BaseUnitPrice
BoothName
BoothSurcharge
ID
NumUnits
OverrideSurcharge
SurchargePercent
SurchargeType

See Also

BoothInfo Class | Aptify.Applications.OrderEntry Namespace


BaseUnitPrice Property

Aptify 5.0 Software Development Kit (SDK)

BoothInfo.BaseUnitPrice Property

public Decimal BaseUnitPrice {get; set;}

See Also

BoothInfo Class | Aptify.Applications.OrderEntry Namespace


BoothName Property

Aptify 5.0 Software Development Kit (SDK)

BoothInfo.BoothName Property

public String BoothName {get; set;}

See Also

BoothInfo Class | Aptify.Applications.OrderEntry Namespace


BoothSurcharge Property

Aptify 5.0 Software Development Kit (SDK)

BoothInfo.BoothSurcharge Property

public Decimal BoothSurcharge {get; set;}

See Also

BoothInfo Class | Aptify.Applications.OrderEntry Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

BoothInfo.ID Property

public Int64 ID {get; set;}

See Also

BoothInfo Class | Aptify.Applications.OrderEntry Namespace


NumUnits Property

Aptify 5.0 Software Development Kit (SDK)

BoothInfo.NumUnits Property

public Decimal NumUnits {get; set;}

See Also

BoothInfo Class | Aptify.Applications.OrderEntry Namespace


OverrideSurcharge Property

Aptify 5.0 Software Development Kit (SDK)

BoothInfo.OverrideSurcharge Property

public Boolean OverrideSurcharge {get; set;}

See Also

BoothInfo Class | Aptify.Applications.OrderEntry Namespace


SurchargePercent Property

Aptify 5.0 Software Development Kit (SDK)

BoothInfo.SurchargePercent Property

public Decimal SurchargePercent {get; set;}

See Also

BoothInfo Class | Aptify.Applications.OrderEntry Namespace


SurchargeType Property

Aptify 5.0 Software Development Kit (SDK)

BoothInfo.SurchargeType Property

public BoothInfo.BoothSurchargeTypes SurchargeType {get; set;}

See Also

BoothInfo Class | Aptify.Applications.OrderEntry Namespace


BoothInfo Methods

The methods of the BoothInfo class are listed below. For a complete list of BoothInfo class members, see the BoothInfo Members topic.

Public Instance Methods

CalculateBoothUnitPrice |
CalculateSurcharge |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BoothInfo Class | Aptify.Applications.OrderEntry Namespace


BoothInfo.CalculateBoothUnitPrice Method

public virtual decimal CalculateBoothUnitPrice();

See Also

BoothInfo Class | Aptify.Applications.OrderEntry Namespace


BoothInfo.CalculateSurcharge Method

public decimal CalculateSurcharge();

See Also

BoothInfo Class | Aptify.Applications.OrderEntry Namespace


BoothInfo.BoothSurchargeTypes Enumeration

public enum BoothInfo.BoothSurchargeTypes

Members

Member Name | Description
Flat |
Percentage |

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOBDEntity (in AptifyOBDEntity.dll)

See Also

Aptify.Applications.OrderEntry Namespace


BulkOrdersGE Class

Implements a GE sub-class for the Bulk Orders entity to generate orders and manage the workflow around generating orders from the bulk order defintion.

For a list of all members of this type, see BulkOrdersGE Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
BulkOrdersGE

public class BulkOrdersGE : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: BulkOrdersGE (in BulkOrdersGE.dll)

See Also

BulkOrdersGE Members | Aptify.Applications.OrderEntry Namespace


BulkOrdersGE Members

BulkOrdersGE overview

Public Instance Constructors

BulkOrdersGE Constructor Initializes a new instance of the BulkOrdersGE class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LockedFields | List of locked fields that are not allowed to be changed after the Status is set to Completed or Cancelled.
LockedSubTypes | List of locked sub-types that are not allowed to be changed after the Status is set to Completed or Cancelled.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SavedStatus | Returns the saved state value of the Status field. If the Status field was modified since the last save of the object, the Old Value is returned, otherwise the old value and current value are the same.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

AddCustomer | This method will add a new record to the BulkOrderCustomers sub-type based on the provided input
AreLockedAttributesDirty | This method checks to see if certain fields(see below) and the BulkOrderCustomers and BulkOrderProducts sub-type have been modified. If any of those attributes were modified since the last save, True is returned, otherwise, False is returned. The fields checked are those defined by the LockedFields property.
BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CanLockedAttributesChange | This method determines if locked attributes may be changed or not. By default in the base class this is determined by checking to see if the saved status of the record is Completed or Cancelled, if so, locked attributes may not change.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetCurrentEmployeeID | This function returns the current employee ID, which is the Employees.ID associated with the currently logged in user. If this function does not find an employee record associated with the currently logged in user, it will return -1
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetLowestPaymentTypeID | This method determines the lowest payment type with the specified base type
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
ImportIDList | Overloaded.
ImportView | Overloaded. This method will use the ViewID provided to import the records from the view into the BulkOrderCustomers sub-type. This method will only work for views that are either based on the Companies or Persons entity
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord | Creates a new record in the GE by calling the base GE NewRecord method and sets the default value for CreatedByID to the current employee by calling the GetCurrentEmployeeID method.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded. Overrides the base GE Save() method to automatically generate orders from the bulk order definition whenever the Status is set to "Ready" and the Approval Status is set to "Approved". To change the trigger piont on when the bulk orders are generated, sub-class this class and override the ShouldGenerateOrders() method. Note that this method calls the AptifyGenericEntity.Save() method before calling GenerateOrders()
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue | Sets a field value in the GE Object. This sub-class automatically sets the ApprovedByID field whenever the Status field is changed to "Approved" from another value and the ApprovedByID field is blank. All other functionality is handled by the base class SetValue method.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded. Validates the data in the object. This override tests to make sure data in the Customers sub-type as well as data in key fields has not been edited. This method delegates this determination to the CanLockedAttributesChange method.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
StatusUpdate | This event is raised whenever the object makes status information available to the callee of one of its long running methods. The Cancel parameter can be used to cancel the long running process if the code handling the event sets the value of Cancel=True.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
CustomerHasOverride | This method determines if a given customer in a bulk order has an override in place for a specific Product. If one is found in the BulkOrderCustomerProductOverrides sub-type, the object is returned, otherwise, nothing is returned
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateCustomerOrder | This method is responsible for generating a single order for a given customer based on the information provided in the BulkOrderCustomerGE parameter. The base class implementation calls the SetupOrderHeader(), SetupOrderDetails() methods in that order and then saves the order.
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateOrders | This method is responsible for generating orders from the bulk order definition and is called by the Save() method whenever ShouldGenerateOrders() returns True. This method initially will set the Status to "In Progress", save the record, and then proceed to generate orders based on the Bulk Order definition.
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
GetCompanyContactID | This method returns an ID for the person record to use as the default contact for the company based on the ContactSelectionMode attribute of the Bulk Orders entity.
GetPersonCompanyID | Returns the CompanyID and Company(via the CompanyName OUT parameter) fields from the Persons entity for the specified PersonID record.
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NeedToGenerateCustomerOrder | This method is responsible for determining if it is necessary to generate an order for a particualr bulk order customer. The default behavior in the base class is to return True if the value of the OrderID field in the BulkOrderCustomer GE record is not set (-1), and False otherwise. Override this method to change the behavior on when a customer order is created.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RaiseStatusUpdate | This method raises the StatusUpdate() event in the BulkOrdersGE class. Sub-classes may call this event as required to raise the event in the base class.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupCustomerHeader | This method is called from the SetupOrderHeader() method and is responsible for setting up customer specific header information in the OrderGE.
SetupOrderDetails | This method is responsible for setting up the order details for each individual order created by the bulk order process.
SetupOrderHeader | This method is responsible for setting up the order header for each individual order created by the bulk order process.
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
ShouldGenerateOrders | This method checks to see if the Status="Ready" and the ApprovalStatus="Pending". If that is the case it returns True, otherwise it returns False. To modify the point when orders are generated, sub-class this class and override this function.
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

BulkOrdersGE Class | Aptify.Applications.OrderEntry Namespace


BulkOrdersGE Constructor

Initializes a new instance of the BulkOrdersGE class.

public BulkOrdersGE();

See Also

BulkOrdersGE Class | Aptify.Applications.OrderEntry Namespace


BulkOrdersGE Properties

The properties of the BulkOrdersGE class are listed below. For a complete list of BulkOrdersGE class members, see the BulkOrdersGE Members topic.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LockedFields | List of locked fields that are not allowed to be changed after the Status is set to Completed or Cancelled.
LockedSubTypes | List of locked sub-types that are not allowed to be changed after the Status is set to Completed or Cancelled.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SavedStatus | Returns the saved state value of the Status field. If the Status field was modified since the last save of the object, the Old Value is returned, otherwise the old value and current value are the same.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

BulkOrdersGE Class | Aptify.Applications.OrderEntry Namespace


LockedFields Property

Aptify 5.0 Software Development Kit (SDK)

BulkOrdersGE.LockedFields Property

List of locked fields that are not allowed to be changed after the Status is set to Completed or Cancelled.

public virtual List<T> LockedFields {get;}

Property Value

Remarks

See Also

BulkOrdersGE Class | Aptify.Applications.OrderEntry Namespace


LockedSubTypes Property

Aptify 5.0 Software Development Kit (SDK)

BulkOrdersGE.LockedSubTypes Property

List of locked sub-types that are not allowed to be changed after the Status is set to Completed or Cancelled.

public virtual List<T> LockedSubTypes {get;}

Property Value

Remarks

See Also

BulkOrdersGE Class | Aptify.Applications.OrderEntry Namespace


SavedStatus Property

Aptify 5.0 Software Development Kit (SDK)

BulkOrdersGE.SavedStatus Property

Returns the saved state value of the Status field. If the Status field was modified since the last save of the object, the Old Value is returned, otherwise the old value and current value are the same.

public virtual String SavedStatus {get;}

Property Value

Remarks

See Also

BulkOrdersGE Class | Aptify.Applications.OrderEntry Namespace


BulkOrdersGE Methods

The methods of the BulkOrdersGE class are listed below. For a complete list of BulkOrdersGE class members, see the BulkOrdersGE Members topic.

Public Instance Methods

AddCustomer | This method will add a new record to the BulkOrderCustomers sub-type based on the provided input
AreLockedAttributesDirty | This method checks to see if certain fields(see below) and the BulkOrderCustomers and BulkOrderProducts sub-type have been modified. If any of those attributes were modified since the last save, True is returned, otherwise, False is returned. The fields checked are those defined by the LockedFields property.
BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CanLockedAttributesChange | This method determines if locked attributes may be changed or not. By default in the base class this is determined by checking to see if the saved status of the record is Completed or Cancelled, if so, locked attributes may not change.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetCurrentEmployeeID | This function returns the current employee ID, which is the Employees.ID associated with the currently logged in user. If this function does not find an employee record associated with the currently logged in user, it will return -1
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetLowestPaymentTypeID | This method determines the lowest payment type with the specified base type
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
ImportIDList | Overloaded.
ImportView | Overloaded. This method will use the ViewID provided to import the records from the view into the BulkOrderCustomers sub-type. This method will only work for views that are either based on the Companies or Persons entity
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord | Creates a new record in the GE by calling the base GE NewRecord method and sets the default value for CreatedByID to the current employee by calling the GetCurrentEmployeeID method.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded. Overrides the base GE Save() method to automatically generate orders from the bulk order definition whenever the Status is set to "Ready" and the Approval Status is set to "Approved". To change the trigger piont on when the bulk orders are generated, sub-class this class and override the ShouldGenerateOrders() method. Note that this method calls the AptifyGenericEntity.Save() method before calling GenerateOrders()
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue | Sets a field value in the GE Object. This sub-class automatically sets the ApprovedByID field whenever the Status field is changed to "Approved" from another value and the ApprovedByID field is blank. All other functionality is handled by the base class SetValue method.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded. Validates the data in the object. This override tests to make sure data in the Customers sub-type as well as data in key fields has not been edited. This method delegates this determination to the CanLockedAttributesChange method.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
CustomerHasOverride | This method determines if a given customer in a bulk order has an override in place for a specific Product. If one is found in the BulkOrderCustomerProductOverrides sub-type, the object is returned, otherwise, nothing is returned
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateCustomerOrder | This method is responsible for generating a single order for a given customer based on the information provided in the BulkOrderCustomerGE parameter. The base class implementation calls the SetupOrderHeader(), SetupOrderDetails() methods in that order and then saves the order.
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateOrders | This method is responsible for generating orders from the bulk order definition and is called by the Save() method whenever ShouldGenerateOrders() returns True. This method initially will set the Status to "In Progress", save the record, and then proceed to generate orders based on the Bulk Order definition.
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
GetCompanyContactID | This method returns an ID for the person record to use as the default contact for the company based on the ContactSelectionMode attribute of the Bulk Orders entity.
GetPersonCompanyID | Returns the CompanyID and Company(via the CompanyName OUT parameter) fields from the Persons entity for the specified PersonID record.
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NeedToGenerateCustomerOrder | This method is responsible for determining if it is necessary to generate an order for a particualr bulk order customer. The default behavior in the base class is to return True if the value of the OrderID field in the BulkOrderCustomer GE record is not set (-1), and False otherwise. Override this method to change the behavior on when a customer order is created.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RaiseStatusUpdate | This method raises the StatusUpdate() event in the BulkOrdersGE class. Sub-classes may call this event as required to raise the event in the base class.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupCustomerHeader | This method is called from the SetupOrderHeader() method and is responsible for setting up customer specific header information in the OrderGE.
SetupOrderDetails | This method is responsible for setting up the order details for each individual order created by the bulk order process.
SetupOrderHeader | This method is responsible for setting up the order header for each individual order created by the bulk order process.
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
ShouldGenerateOrders | This method checks to see if the Status="Ready" and the ApprovalStatus="Pending". If that is the case it returns True, otherwise it returns False. To modify the point when orders are generated, sub-class this class and override this function.
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

BulkOrdersGE Class | Aptify.Applications.OrderEntry Namespace


BulkOrdersGE.AddCustomer Method

This method will add a new record to the BulkOrderCustomers sub-type based on the provided input

public virtual AptifyGenericEntityBase AddCustomer(
Int64 CustomerID,
BulkOrdersGE.BulkOrderSourceViewType RecordType
);

Parameters

CustomerID
RecordType

Return Value

Remarks

See Also

BulkOrdersGE Class | Aptify.Applications.OrderEntry Namespace


BulkOrdersGE.AreLockedAttributesDirty Method

This method checks to see if certain fields(see below) and the BulkOrderCustomers and BulkOrderProducts sub-type have been modified. If any of those attributes were modified since the last save, True is returned, otherwise, False is returned. The fields checked are those defined by the LockedFields property.

public virtual bool AreLockedAttributesDirty(
ref String& LockedAttributes
);

Parameters

LockedAttributes
If specified, this field is populated with a list of locked attributes(fields and sub-types)

Return Value

Remarks

See Also

BulkOrdersGE Class | Aptify.Applications.OrderEntry Namespace


BulkOrdersGE.CanLockedAttributesChange Method

This method determines if locked attributes may be changed or not. By default in the base class this is determined by checking to see if the saved status of the record is Completed or Cancelled, if so, locked attributes may not change.

public virtual bool CanLockedAttributesChange();

Return Value

Remarks

See Also

BulkOrdersGE Class | Aptify.Applications.OrderEntry Namespace


BulkOrdersGE.CustomerHasOverride Method

This method determines if a given customer in a bulk order has an override in place for a specific Product. If one is found in the BulkOrderCustomerProductOverrides sub-type, the object is returned, otherwise, nothing is returned

protected virtual AptifyGenericEntityBase CustomerHasOverride(
AptifyGenericEntityBase BulkOrderCustomerGE,
Int64 ProductID
);

Parameters

BulkOrderCustomerGE
ProductID

Return Value

Remarks

See Also

BulkOrdersGE Class | Aptify.Applications.OrderEntry Namespace


BulkOrdersGE.GenerateCustomerOrder Method

This method is responsible for generating a single order for a given customer based on the information provided in the BulkOrderCustomerGE parameter. The base class implementation calls the SetupOrderHeader(), SetupOrderDetails() methods in that order and then saves the order.

protected virtual bool GenerateCustomerOrder(
AptifyGenericEntityBase BulkOrderCustomerGE,
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

Parameters

BulkOrderCustomerGE
GE instance for the current BulkOrderCustomer sub-type record being processed
AllowGUI
ErrorString
TransactionID

Return Value

Remarks

See Also

BulkOrdersGE Class | Aptify.Applications.OrderEntry Namespace


BulkOrdersGE.GenerateOrders Method

This method is responsible for generating orders from the bulk order definition and is called by the Save() method whenever ShouldGenerateOrders() returns True. This method initially will set the Status to "In Progress", save the record, and then proceed to generate orders based on the Bulk Order definition.

protected virtual bool GenerateOrders(
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

Return Value

Remarks

See Also

BulkOrdersGE Class | Aptify.Applications.OrderEntry Namespace


BulkOrdersGE.GetCompanyContactID Method

This method returns an ID for the person record to use as the default contact for the company based on the ContactSelectionMode attribute of the Bulk Orders entity.

protected virtual long GetCompanyContactID(
Int64 CompanyID,
ref String& PersonName
);

Parameters

CompanyID
PersonName
OUT: returns the name of the person specified by the ID value

Return Value

Remarks

See Also

BulkOrdersGE Class | Aptify.Applications.OrderEntry Namespace


BulkOrdersGE.GetCurrentEmployeeID Method

This function returns the current employee ID, which is the Employees.ID associated with the currently logged in user. If this function does not find an employee record associated with the currently logged in user, it will return -1

public virtual long GetCurrentEmployeeID();

Return Value

Remarks

See Also

BulkOrdersGE Class | Aptify.Applications.OrderEntry Namespace


BulkOrdersGE.GetLowestPaymentTypeID Method

This method determines the lowest payment type with the specified base type

public virtual long GetLowestPaymentTypeID(
String BasePaymentType
);

Parameters

BasePaymentType

Return Value

Remarks

See Also

BulkOrdersGE Class | Aptify.Applications.OrderEntry Namespace


BulkOrdersGE.GetPersonCompanyID Method

Returns the CompanyID and Company(via the CompanyName OUT parameter) fields from the Persons entity for the specified PersonID record.

protected virtual long GetPersonCompanyID(
Int64 PersonID,
ref String& CompanyName
);

Parameters

PersonID
CompanyName

Return Value

Remarks

See Also

BulkOrdersGE Class | Aptify.Applications.OrderEntry Namespace


ImportIDList Method

Aptify 5.0 Software Development Kit (SDK)

BulkOrdersGE.ImportIDList Method

Overload List

public virtual bool ImportIDList(List<T>,BulkOrdersGE.BulkOrderSourceViewType);

public virtual bool ImportIDList(String,BulkOrdersGE.BulkOrderSourceViewType);

See Also

BulkOrdersGE Class | Aptify.Applications.OrderEntry Namespace


BulkOrdersGE.ImportIDList Method (List<T>, BulkOrderSourceViewType)

public virtual bool ImportIDList(
List<T> IDList,
BulkOrdersGE.BulkOrderSourceViewType ViewType
);

See Also

BulkOrdersGE Class | Aptify.Applications.OrderEntry Namespace | BulkOrdersGE.ImportIDList Overload List


BulkOrdersGE.ImportIDList Method (String, BulkOrderSourceViewType)

public virtual bool ImportIDList(
String IDList,
BulkOrdersGE.BulkOrderSourceViewType ViewType
);

See Also

BulkOrdersGE Class | Aptify.Applications.OrderEntry Namespace | BulkOrdersGE.ImportIDList Overload List


ImportView Method

Aptify 5.0 Software Development Kit (SDK)

BulkOrdersGE.ImportView Method

This method will use the ViewID provided to import the records from the view into the BulkOrderCustomers sub-type. This method will only work for views that are either based on the Companies or Persons entity

Overload List

This method will use the ViewID provided to import the records from the view into the BulkOrderCustomers sub-type. This method will only work for views that are either based on the Companies or Persons entity

public virtual bool ImportView(Int64);

public virtual bool ImportView(String,BulkOrdersGE.BulkOrderSourceViewType);

See Also

BulkOrdersGE Class | Aptify.Applications.OrderEntry Namespace


BulkOrdersGE.ImportView Method (Int64)

This method will use the ViewID provided to import the records from the view into the BulkOrderCustomers sub-type. This method will only work for views that are either based on the Companies or Persons entity

public virtual bool ImportView(
Int64 ViewID
);

Parameters

ViewID

Return Value

Remarks

See Also

BulkOrdersGE Class | Aptify.Applications.OrderEntry Namespace | BulkOrdersGE.ImportView Overload List


BulkOrdersGE.ImportView Method (String, BulkOrderSourceViewType)

public virtual bool ImportView(
String ViewSQL,
BulkOrdersGE.BulkOrderSourceViewType ViewType
);

See Also

BulkOrdersGE Class | Aptify.Applications.OrderEntry Namespace | BulkOrdersGE.ImportView Overload List


BulkOrdersGE.NeedToGenerateCustomerOrder Method

This method is responsible for determining if it is necessary to generate an order for a particualr bulk order customer. The default behavior in the base class is to return True if the value of the OrderID field in the BulkOrderCustomer GE record is not set (-1), and False otherwise. Override this method to change the behavior on when a customer order is created.

protected virtual bool NeedToGenerateCustomerOrder(
AptifyGenericEntityBase BulkOrderCustomerGE
);

Parameters

BulkOrderCustomerGE

Return Value

Remarks

See Also

BulkOrdersGE Class | Aptify.Applications.OrderEntry Namespace


BulkOrdersGE.NewRecord Method

Creates a new record in the GE by calling the base GE NewRecord method and sets the default value for CreatedByID to the current employee by calling the GetCurrentEmployeeID method.

public override bool NewRecord();

Return Value

Remarks

See Also

BulkOrdersGE Class | Aptify.Applications.OrderEntry Namespace


BulkOrdersGE.RaiseStatusUpdate Method

This method raises the StatusUpdate() event in the BulkOrdersGE class. Sub-classes may call this event as required to raise the event in the base class.

protected virtual void RaiseStatusUpdate(
Int32 CurrentItem,
Int32 TotalItems,
String Message,
ref Boolean& Cancel
);

Parameters

CurrentItem
TotalItems
Message
Cancel

Remarks

See Also

BulkOrdersGE Class | Aptify.Applications.OrderEntry Namespace


Save Method

Aptify 5.0 Software Development Kit (SDK)

BulkOrdersGE.Save Method

Overrides the base GE Save() method to automatically generate orders from the bulk order definition whenever the Status is set to "Ready" and the Approval Status is set to "Approved". To change the trigger piont on when the bulk orders are generated, sub-class this class and override the ShouldGenerateOrders() method. Note that this method calls the AptifyGenericEntity.Save() method before calling GenerateOrders()

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Save();

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean,ref String&);

Overrides the base GE Save() method to automatically generate orders from the bulk order definition whenever the Status is set to "Ready" and the Approval Status is set to "Approved". To change the trigger piont on when the bulk orders are generated, sub-class this class and override the ShouldGenerateOrders() method. Note that this method calls the AptifyGenericEntity.Save() method before calling GenerateOrders()

public override bool Save(Boolean,ref String&,String);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(ref String&);

See Also

BulkOrdersGE Class | Aptify.Applications.OrderEntry Namespace


BulkOrdersGE.Save Method (Boolean, String&, String)

Overrides the base GE Save() method to automatically generate orders from the bulk order definition whenever the Status is set to "Ready" and the Approval Status is set to "Approved". To change the trigger piont on when the bulk orders are generated, sub-class this class and override the ShouldGenerateOrders() method. Note that this method calls the AptifyGenericEntity.Save() method before calling GenerateOrders()

public override bool Save(
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

Parameters

AllowGUI
ErrorString
TransactionID

Return Value

Remarks

See Also

BulkOrdersGE Class | Aptify.Applications.OrderEntry Namespace | BulkOrdersGE.Save Overload List


BulkOrdersGE.SetupCustomerHeader Method

This method is called from the SetupOrderHeader() method and is responsible for setting up customer specific header information in the OrderGE.

protected virtual bool SetupCustomerHeader(
OrdersEntity OrderGE,
AptifyGenericEntityBase BulkOrderCustomerGE
);

Parameters

OrderGE
BulkOrderCustomerGE

Return Value

Remarks

See Also

BulkOrdersGE Class | Aptify.Applications.OrderEntry Namespace


BulkOrdersGE.SetupOrderDetails Method

This method is responsible for setting up the order details for each individual order created by the bulk order process.

protected virtual bool SetupOrderDetails(
OrdersEntity OrderGE,
AptifyGenericEntityBase BulkOrderCustomerGE
);

Parameters

OrderGE
BulkOrderCustomerGE

Return Value

Remarks

See Also

BulkOrdersGE Class | Aptify.Applications.OrderEntry Namespace


BulkOrdersGE.SetupOrderHeader Method

This method is responsible for setting up the order header for each individual order created by the bulk order process.

protected virtual bool SetupOrderHeader(
OrdersEntity OrderGE,
AptifyGenericEntityBase BulkOrderCustomerGE
);

Parameters

OrderGE
BulkOrderCustomerGE

Return Value

Remarks

See Also

BulkOrdersGE Class | Aptify.Applications.OrderEntry Namespace


BulkOrdersGE.SetValue Method

Sets a field value in the GE Object. This sub-class automatically sets the ApprovedByID field whenever the Status field is changed to "Approved" from another value and the ApprovedByID field is blank. All other functionality is handled by the base class SetValue method.

public override void SetValue(
String FieldName,
Object Value
);

Parameters

FieldName
Value

Remarks

See Also

BulkOrdersGE Class | Aptify.Applications.OrderEntry Namespace


BulkOrdersGE.ShouldGenerateOrders Method

This method checks to see if the Status="Ready" and the ApprovalStatus="Pending". If that is the case it returns True, otherwise it returns False. To modify the point when orders are generated, sub-class this class and override this function.

protected virtual bool ShouldGenerateOrders(
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

Return Value

Remarks

See Also

BulkOrdersGE Class | Aptify.Applications.OrderEntry Namespace


Validate Method

Aptify 5.0 Software Development Kit (SDK)

BulkOrdersGE.Validate Method

Validates the data in the object. This override tests to make sure data in the Customers sub-type as well as data in key fields has not been edited. This method delegates this determination to the CanLockedAttributesChange method.

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Validate();

Validates the data in the object. This override tests to make sure data in the Customers sub-type as well as data in key fields has not been edited. This method delegates this determination to the CanLockedAttributesChange method.

public override bool Validate(ref String&);

See Also

BulkOrdersGE Class | Aptify.Applications.OrderEntry Namespace


BulkOrdersGE.Validate Method (String&)

Validates the data in the object. This override tests to make sure data in the Customers sub-type as well as data in key fields has not been edited. This method delegates this determination to the CanLockedAttributesChange method.

public override bool Validate(
ref String& ErrorString
);

Parameters

ErrorString

Return Value

Remarks

See Also

BulkOrdersGE Class | Aptify.Applications.OrderEntry Namespace | BulkOrdersGE.Validate Overload List


BulkOrdersGE Events

The events of the BulkOrdersGE class are listed below. For a complete list of BulkOrdersGE class members, see the BulkOrdersGE Members topic.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
StatusUpdate | This event is raised whenever the object makes status information available to the callee of one of its long running methods. The Cancel parameter can be used to cancel the long running process if the code handling the event sets the value of Cancel=True.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

See Also

BulkOrdersGE Class | Aptify.Applications.OrderEntry Namespace


BulkOrdersGE.BulkOrdersGE.StatusUpdateEventHandler Event

This event is raised whenever the object makes status information available to the callee of one of its long running methods. The Cancel parameter can be used to cancel the long running process if the code handling the event sets the value of Cancel=True.

public event BulkOrdersGE.StatusUpdateEventHandler StatusUpdate;

Remarks

See Also

BulkOrdersGE Class | Aptify.Applications.OrderEntry Namespace


BulkOrdersGE.BulkOrderSourceViewType Enumeration

Types of views supported by the Bulk Order Import process

public enum BulkOrdersGE.BulkOrderSourceViewType

Remarks

Members

Member Name | Description
Persons |
Companies |

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: BulkOrdersGE (in BulkOrdersGE.dll)

See Also

Aptify.Applications.OrderEntry Namespace


BulkOrdersGE.StatusUpdateEventHandler Delegate

public delegate void BulkOrdersGE.StatusUpdateEventHandler(
Int32 CurrentItem,
Int32 TotalItems,
String Message,
ref Boolean& Cancel
);

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: BulkOrdersGE (in BulkOrdersGE.dll)

See Also

Aptify.Applications.OrderEntry Namespace


CalculateShippingCost Class

This object implements the Aptify.Applications.OrderEntry.ICalculateShippingCost interface. The purpose of this component is to return a shipping cost for an order and is designed to be sub-classed to implement any specific functionality required.

For a list of all members of this type, see CalculateShippingCost Members.

System.Object
CalculateShippingCost

public class CalculateShippingCost : ICalculateShippingCost

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: CalculateShippingCost (in CalculateShippingCost.dll)

See Also

CalculateShippingCost Members | Aptify.Applications.OrderEntry Namespace


CalculateShippingCost Members

CalculateShippingCost overview

Public Instance Constructors

CalculateShippingCost Constructor Initializes a new instance of the CalculateShippingCost class.

Public Instance Methods

CalculateShippingCost | The default implementation of Aptify does not provide any logic for calculating shipping costs. To implement a configuration for calculation of shipping cost, sub-class this class and implement your logic in the overriden code for this method
Config | This method must be called before any other member of the class is accessed. The method sets up a Data Action and the Database property which can be used by sub-classes.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

Application | Returns an instance of the Aptify Application Object
DataAction | Returns an instance of the Aptify DataAction class
Database | Returns the database name where the Aptify CRM entities are located

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CalculateShippingCost Class | Aptify.Applications.OrderEntry Namespace


CalculateShippingCost Constructor

Initializes a new instance of the CalculateShippingCost class.

public CalculateShippingCost();

See Also

CalculateShippingCost Class | Aptify.Applications.OrderEntry Namespace


CalculateShippingCost Properties

The properties of the CalculateShippingCost class are listed below. For a complete list of CalculateShippingCost class members, see the CalculateShippingCost Members topic.

Protected Instance Properties

Application | Returns an instance of the Aptify Application Object
DataAction | Returns an instance of the Aptify DataAction class
Database | Returns the database name where the Aptify CRM entities are located

See Also

CalculateShippingCost Class | Aptify.Applications.OrderEntry Namespace


Application Property

Aptify 5.0 Software Development Kit (SDK)

CalculateShippingCost.Application Property

Returns an instance of the Aptify Application Object

protected AptifyApplication Application {get;}

Property Value

Remarks

See Also

CalculateShippingCost Class | Aptify.Applications.OrderEntry Namespace


DataAction Property

Aptify 5.0 Software Development Kit (SDK)

CalculateShippingCost.DataAction Property

Returns an instance of the Aptify DataAction class

protected DataAction DataAction {get;}

Property Value

Remarks

See Also

CalculateShippingCost Class | Aptify.Applications.OrderEntry Namespace


Database Property

Aptify 5.0 Software Development Kit (SDK)

CalculateShippingCost.Database Property

Returns the database name where the Aptify CRM entities are located

protected String Database {get;}

Property Value

Remarks

See Also

CalculateShippingCost Class | Aptify.Applications.OrderEntry Namespace


CalculateShippingCost Methods

The methods of the CalculateShippingCost class are listed below. For a complete list of CalculateShippingCost class members, see the CalculateShippingCost Members topic.

Public Instance Methods

CalculateShippingCost | The default implementation of Aptify does not provide any logic for calculating shipping costs. To implement a configuration for calculation of shipping cost, sub-class this class and implement your logic in the overriden code for this method
Config | This method must be called before any other member of the class is accessed. The method sets up a Data Action and the Database property which can be used by sub-classes.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CalculateShippingCost Class | Aptify.Applications.OrderEntry Namespace


CalculateShippingCost.CalculateShippingCost Method

The default implementation of Aptify does not provide any logic for calculating shipping costs. To implement a configuration for calculation of shipping cost, sub-class this class and implement your logic in the overriden code for this method

public virtual bool CalculateShippingCost(
AptifyGenericEntityBase OrderGE,
ref Decimal& ShippingCost,
ref String& UserMessage
);

Parameters

OrderGE
ShippingCost
UserMessage

Return Value

Implements

ICalculateShippingCost.

Remarks

See Also

CalculateShippingCost Class | Aptify.Applications.OrderEntry Namespace


CalculateShippingCost.Config Method

This method must be called before any other member of the class is accessed. The method sets up a Data Action and the Database property which can be used by sub-classes.

public virtual void Config(
AptifyApplication Application
);

Parameters

Application

Implements

ICalculateShippingCost.

Remarks

See Also

CalculateShippingCost Class | Aptify.Applications.OrderEntry Namespace


CampaignDiscount Class

Used to return information about the Campaign discount

For a list of all members of this type, see CampaignDiscount Members.

System.Object
CampaignDiscount

public class CampaignDiscount

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Made this a class to more easily handle future enhancements to the Campaign Discount functionality.

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

CampaignDiscount Members | Aptify.Applications.OrderEntry Namespace


CampaignDiscount Members

CampaignDiscount overview

Public Instance Constructors

CampaignDiscount Constructor

Public Instance Properties

DiscountPercentage

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CampaignDiscount Class | Aptify.Applications.OrderEntry Namespace


CampaignDiscount Constructor

public CampaignDiscount(
Decimal DiscountPercentage
);

See Also

CampaignDiscount Class | Aptify.Applications.OrderEntry Namespace


CampaignDiscount Properties

The properties of the CampaignDiscount class are listed below. For a complete list of CampaignDiscount class members, see the CampaignDiscount Members topic.

Public Instance Properties

DiscountPercentage

See Also

CampaignDiscount Class | Aptify.Applications.OrderEntry Namespace


DiscountPercentage Property

Aptify 5.0 Software Development Kit (SDK)

CampaignDiscount.DiscountPercentage Property

public Decimal DiscountPercentage {get;}

See Also

CampaignDiscount Class | Aptify.Applications.OrderEntry Namespace


CancellationWizForm Class

For a list of all members of this type, see CancellationWizForm Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
CancellationWizForm

public class CancellationWizForm : Form, IAptifyAction

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: CancellationWizard (in CancellationWizard.dll)

See Also

CancellationWizForm Members | Aptify.Applications.OrderEntry Namespace


CancellationWizForm Members

CancellationWizForm overview

Public Instance Constructors

CancellationWizForm Constructor Initializes a new instance of the CancellationWizForm class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoAction | Overloaded.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetupCancellationFeeGroup |
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CancellationWizForm Class | Aptify.Applications.OrderEntry Namespace


CancellationWizForm Constructor

Initializes a new instance of the CancellationWizForm class.

public CancellationWizForm();

See Also

CancellationWizForm Class | Aptify.Applications.OrderEntry Namespace


CancellationWizForm Methods

The methods of the CancellationWizForm class are listed below. For a complete list of CancellationWizForm class members, see the CancellationWizForm Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoAction | Overloaded.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetupCancellationFeeGroup |
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CancellationWizForm Class | Aptify.Applications.OrderEntry Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

CancellationWizForm.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

CancellationWizForm Class | Aptify.Applications.OrderEntry Namespace


CancellationWizForm.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

CancellationWizForm Class | Aptify.Applications.OrderEntry Namespace | CancellationWizForm.Dispose Overload List


DoAction Method

Aptify 5.0 Software Development Kit (SDK)

CancellationWizForm.DoAction Method

Overload List

public void DoAction(AptifyApplication,Int64);

public void DoAction(AptifyApplication,Int64,Int64);

public void DoAction(AptifyApplication,Int64,Int64,params Object[]);

public void DoAction(AptifyApplication,Int64,params String[]);

See Also

CancellationWizForm Class | Aptify.Applications.OrderEntry Namespace


CancellationWizForm.DoAction Method (AptifyApplication, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID
);

Implements

IAptifyAction.

See Also

CancellationWizForm Class | Aptify.Applications.OrderEntry Namespace | CancellationWizForm.DoAction Overload List


CancellationWizForm.DoAction Method (AptifyApplication, Int64, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID
);

Implements

IAptifyAction.

See Also

CancellationWizForm Class | Aptify.Applications.OrderEntry Namespace | CancellationWizForm.DoAction Overload List


CancellationWizForm.DoAction Method (AptifyApplication, Int64, Int64, Object[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID,
params Object[] SelectedItems
);

Implements

IAptifyAction.

See Also

CancellationWizForm Class | Aptify.Applications.OrderEntry Namespace | CancellationWizForm.DoAction Overload List


CancellationWizForm.DoAction Method (AptifyApplication, Int64, String[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
params String[] SelectedItems
);

Implements

IAptifyAction.

See Also

CancellationWizForm Class | Aptify.Applications.OrderEntry Namespace | CancellationWizForm.DoAction Overload List


CancellationWizForm.SetupCancellationFeeGroup Method

protected void SetupCancellationFeeGroup();

See Also

CancellationWizForm Class | Aptify.Applications.OrderEntry Namespace


CancellationWizObject Class

For a list of all members of this type, see CancellationWizObject Members.

System.Object
CancellationWizObject

public class CancellationWizObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: CancellationWizard (in CancellationWizard.dll)

See Also

CancellationWizObject Members | Aptify.Applications.OrderEntry Namespace


CancellationWizObject Members

CancellationWizObject overview

Public Instance Constructors

CancellationWizObject Constructor

Public Instance Properties

CancellationFee
CancellationFeeProductID
CancellationOrder
CancellationOrderID
CancellationReasonID
CancelledAmount
CurrencyFormatString
EmployeeID
FirstBasePaymentType
FirstPaymentIsInflow
FirstPaymentType
FirstPaymentTypeID
IncludeFee
IsRefund
LastError
OrderLineData
OriginalOrderID
PaidAmount
RefundAmount
RefundShipping
RefundTransNumber
SuccessfulWizardMessage
Title
ViewCancellationOrderMessage
WizardMessages

Public Instance Methods

AddCancellationFee |
CancelOrder |
ConfigureAvailableOrderLines |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetOrderLineGE |
GetType (inherited from Object) | Gets the Type of the current instance.
HasAvailableLines |
InitializeCancellationOrderLines |
InitializeWizard |
LoadOrderInfo |
PaymentCaptureStatus |
ResetVariables |
SetQuantityCancelled |
SetupWizardText |
ToString (inherited from Object) | Returns a String that represents the current Object.
ValidateWizardPageData |

Public Instance Events

Status
TerminateWizard
ValidationErrorFound

Protected Instance Fields

m_bSaveCancelledByUser

Protected Instance Properties

DataAction

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GE_Warning | Handles the GE's Warning event. When a warning is delivered, a Message Box will be displayed to the user. The Message Box' result will be returned. Note: The Message Box will not be displayed if the GE is inside a Transaction.
GetFieldError |
GetPaymentType |
GetPOPaymentType |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnStatus |
OnTerminalWizard |
OnValidationErrorFound |

See Also

CancellationWizObject Class | Aptify.Applications.OrderEntry Namespace


CancellationWizObject Constructor

public CancellationWizObject(
AptifyApplication Application
);

See Also

CancellationWizObject Class | Aptify.Applications.OrderEntry Namespace


CancellationWizObject Fields

The fields of the CancellationWizObject class are listed below. For a complete list of CancellationWizObject class members, see the CancellationWizObject Members topic.

Protected Instance Fields

m_bSaveCancelledByUser

See Also

CancellationWizObject Class | Aptify.Applications.OrderEntry Namespace


CancellationWizObject.m_bSaveCancelledByUser Field

protected m_bSaveCancelledByUser m_bSaveCancelledByUser;

See Also

CancellationWizObject Class | Aptify.Applications.OrderEntry Namespace


CancellationWizObject Properties

The properties of the CancellationWizObject class are listed below. For a complete list of CancellationWizObject class members, see the CancellationWizObject Members topic.

Public Instance Properties

CancellationFee
CancellationFeeProductID
CancellationOrder
CancellationOrderID
CancellationReasonID
CancelledAmount
CurrencyFormatString
EmployeeID
FirstBasePaymentType
FirstPaymentIsInflow
FirstPaymentType
FirstPaymentTypeID
IncludeFee
IsRefund
LastError
OrderLineData
OriginalOrderID
PaidAmount
RefundAmount
RefundShipping
RefundTransNumber
SuccessfulWizardMessage
Title
ViewCancellationOrderMessage
WizardMessages

Protected Instance Properties

DataAction

See Also

CancellationWizObject Class | Aptify.Applications.OrderEntry Namespace


CancellationFee Property

Aptify 5.0 Software Development Kit (SDK)

CancellationWizObject.CancellationFee Property

public Decimal CancellationFee {get; set;}

See Also

CancellationWizObject Class | Aptify.Applications.OrderEntry Namespace


CancellationFeeProductID Property

Aptify 5.0 Software Development Kit (SDK)

CancellationWizObject.CancellationFeeProductID Property

public Int64 CancellationFeeProductID {get; set;}

See Also

CancellationWizObject Class | Aptify.Applications.OrderEntry Namespace


CancellationOrder Property

Aptify 5.0 Software Development Kit (SDK)

CancellationWizObject.CancellationOrder Property

public OrdersEntity CancellationOrder {get;}

See Also

CancellationWizObject Class | Aptify.Applications.OrderEntry Namespace


CancellationOrderID Property

Aptify 5.0 Software Development Kit (SDK)

CancellationWizObject.CancellationOrderID Property

public Int64 CancellationOrderID {get;}

See Also

CancellationWizObject Class | Aptify.Applications.OrderEntry Namespace


CancellationReasonID Property

Aptify 5.0 Software Development Kit (SDK)

CancellationWizObject.CancellationReasonID Property

public Int64 CancellationReasonID {get; set;}

See Also

CancellationWizObject Class | Aptify.Applications.OrderEntry Namespace


CancelledAmount Property

Aptify 5.0 Software Development Kit (SDK)

CancellationWizObject.CancelledAmount Property

public Decimal CancelledAmount {get;}

See Also

CancellationWizObject Class | Aptify.Applications.OrderEntry Namespace


CurrencyFormatString Property

Aptify 5.0 Software Development Kit (SDK)

CancellationWizObject.CurrencyFormatString Property

public String CurrencyFormatString {get;}

See Also

CancellationWizObject Class | Aptify.Applications.OrderEntry Namespace


DataAction Property

Aptify 5.0 Software Development Kit (SDK)

CancellationWizObject.DataAction Property

protected DataAction DataAction {get;}

See Also

CancellationWizObject Class | Aptify.Applications.OrderEntry Namespace


EmployeeID Property

Aptify 5.0 Software Development Kit (SDK)

CancellationWizObject.EmployeeID Property

public Int64 EmployeeID {get; set;}

See Also

CancellationWizObject Class | Aptify.Applications.OrderEntry Namespace


FirstBasePaymentType Property

Aptify 5.0 Software Development Kit (SDK)

CancellationWizObject.FirstBasePaymentType Property

public PaymentsEntity.BasePaymentTypes FirstBasePaymentType {get;}

See Also

CancellationWizObject Class | Aptify.Applications.OrderEntry Namespace


FirstPaymentIsInflow Property

Aptify 5.0 Software Development Kit (SDK)

CancellationWizObject.FirstPaymentIsInflow Property

public Boolean FirstPaymentIsInflow {get;}

See Also

CancellationWizObject Class | Aptify.Applications.OrderEntry Namespace


FirstPaymentType Property

Aptify 5.0 Software Development Kit (SDK)

CancellationWizObject.FirstPaymentType Property

public String FirstPaymentType {get;}

See Also

CancellationWizObject Class | Aptify.Applications.OrderEntry Namespace


FirstPaymentTypeID Property

Aptify 5.0 Software Development Kit (SDK)

CancellationWizObject.FirstPaymentTypeID Property

public Int64 FirstPaymentTypeID {get;}

See Also

CancellationWizObject Class | Aptify.Applications.OrderEntry Namespace


IncludeFee Property

Aptify 5.0 Software Development Kit (SDK)

CancellationWizObject.IncludeFee Property

public Boolean IncludeFee {get; set;}

See Also

CancellationWizObject Class | Aptify.Applications.OrderEntry Namespace


IsRefund Property

Aptify 5.0 Software Development Kit (SDK)

CancellationWizObject.IsRefund Property

public Boolean IsRefund {get; set;}

See Also

CancellationWizObject Class | Aptify.Applications.OrderEntry Namespace


LastError Property

Aptify 5.0 Software Development Kit (SDK)

CancellationWizObject.LastError Property

public String LastError {get;}

See Also

CancellationWizObject Class | Aptify.Applications.OrderEntry Namespace


OrderLineData Property

Aptify 5.0 Software Development Kit (SDK)

CancellationWizObject.OrderLineData Property

public Dictionary<TKey,TValue> OrderLineData {get;}

See Also

CancellationWizObject Class | Aptify.Applications.OrderEntry Namespace


OriginalOrderID Property

Aptify 5.0 Software Development Kit (SDK)

CancellationWizObject.OriginalOrderID Property

public Int64 OriginalOrderID {get; set;}

See Also

CancellationWizObject Class | Aptify.Applications.OrderEntry Namespace


PaidAmount Property

Aptify 5.0 Software Development Kit (SDK)

CancellationWizObject.PaidAmount Property

public Decimal PaidAmount {get;}

See Also

CancellationWizObject Class | Aptify.Applications.OrderEntry Namespace


RefundAmount Property

Aptify 5.0 Software Development Kit (SDK)

CancellationWizObject.RefundAmount Property

public Decimal RefundAmount {get; set;}

See Also

CancellationWizObject Class | Aptify.Applications.OrderEntry Namespace


RefundShipping Property

Aptify 5.0 Software Development Kit (SDK)

CancellationWizObject.RefundShipping Property

public Boolean RefundShipping {get; set;}

See Also

CancellationWizObject Class | Aptify.Applications.OrderEntry Namespace


RefundTransNumber Property

Aptify 5.0 Software Development Kit (SDK)

CancellationWizObject.RefundTransNumber Property

public virtual String RefundTransNumber {get; set;}

See Also

CancellationWizObject Class | Aptify.Applications.OrderEntry Namespace


SuccessfulWizardMessage Property

Aptify 5.0 Software Development Kit (SDK)

CancellationWizObject.SuccessfulWizardMessage Property

public virtual String SuccessfulWizardMessage {get;}

See Also

CancellationWizObject Class | Aptify.Applications.OrderEntry Namespace


Title Property

Aptify 5.0 Software Development Kit (SDK)

CancellationWizObject.Title Property

public String Title {get;}

See Also

CancellationWizObject Class | Aptify.Applications.OrderEntry Namespace


ViewCancellationOrderMessage Property

Aptify 5.0 Software Development Kit (SDK)

CancellationWizObject.ViewCancellationOrderMessage Property

public virtual String ViewCancellationOrderMessage {get;}

See Also

CancellationWizObject Class | Aptify.Applications.OrderEntry Namespace


WizardMessages Property

Aptify 5.0 Software Development Kit (SDK)

CancellationWizObject.WizardMessages Property

public List<T> WizardMessages {get;}

See Also

CancellationWizObject Class | Aptify.Applications.OrderEntry Namespace


CancellationWizObject Methods

The methods of the CancellationWizObject class are listed below. For a complete list of CancellationWizObject class members, see the CancellationWizObject Members topic.

Public Instance Methods

AddCancellationFee |
CancelOrder |
ConfigureAvailableOrderLines |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetOrderLineGE |
GetType (inherited from Object) | Gets the Type of the current instance.
HasAvailableLines |
InitializeCancellationOrderLines |
InitializeWizard |
LoadOrderInfo |
PaymentCaptureStatus |
ResetVariables |
SetQuantityCancelled |
SetupWizardText |
ToString (inherited from Object) | Returns a String that represents the current Object.
ValidateWizardPageData |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GE_Warning | Handles the GE's Warning event. When a warning is delivered, a Message Box will be displayed to the user. The Message Box' result will be returned. Note: The Message Box will not be displayed if the GE is inside a Transaction.
GetFieldError |
GetPaymentType |
GetPOPaymentType |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnStatus |
OnTerminalWizard |
OnValidationErrorFound |

See Also

CancellationWizObject Class | Aptify.Applications.OrderEntry Namespace


CancellationWizObject.AddCancellationFee Method

public void AddCancellationFee(
Int64 ProductID,
ref Decimal& Amount
);

See Also

CancellationWizObject Class | Aptify.Applications.OrderEntry Namespace


CancellationWizObject.CancelOrder Method

public virtual bool CancelOrder();

See Also

CancellationWizObject Class | Aptify.Applications.OrderEntry Namespace


CancellationWizObject.ConfigureAvailableOrderLines Method

public int ConfigureAvailableOrderLines();

See Also

CancellationWizObject Class | Aptify.Applications.OrderEntry Namespace


CancellationWizObject.GE_Warning Method

Handles the GE's Warning event. When a warning is delivered, a Message Box will be displayed to the user. The Message Box' result will be returned. Note: The Message Box will not be displayed if the GE is inside a Transaction.

protected virtual void GE_Warning(
AptifyGenericEntityBase sender,
WarningEventArgs e
);

Parameters

sender
e

Remarks

See Also

CancellationWizObject Class | Aptify.Applications.OrderEntry Namespace


CancellationWizObject.GetFieldError Method

protected virtual string GetFieldError(
String sField
);

See Also

CancellationWizObject Class | Aptify.Applications.OrderEntry Namespace


CancellationWizObject.GetOrderLineGE Method

public virtual AptifyGenericEntityBase GetOrderLineGE(
Int64 lOrderLineID
);

See Also

CancellationWizObject Class | Aptify.Applications.OrderEntry Namespace


CancellationWizObject.GetPaymentType Method

protected virtual string GetPaymentType(
Int64 PaymentTypeID
);

See Also

CancellationWizObject Class | Aptify.Applications.OrderEntry Namespace


CancellationWizObject.GetPOPaymentType Method

protected virtual long GetPOPaymentType();

See Also

CancellationWizObject Class | Aptify.Applications.OrderEntry Namespace


CancellationWizObject.HasAvailableLines Method

public bool HasAvailableLines();

See Also

CancellationWizObject Class | Aptify.Applications.OrderEntry Namespace


CancellationWizObject.InitializeCancellationOrderLines Method

public void InitializeCancellationOrderLines();

See Also

CancellationWizObject Class | Aptify.Applications.OrderEntry Namespace


CancellationWizObject.InitializeWizard Method

public virtual void InitializeWizard();

See Also

CancellationWizObject Class | Aptify.Applications.OrderEntry Namespace


CancellationWizObject.LoadOrderInfo Method

public virtual void LoadOrderInfo();

See Also

CancellationWizObject Class | Aptify.Applications.OrderEntry Namespace


CancellationWizObject.OnStatus Method

protected virtual void OnStatus(
String lMessage,
Int32 iMax,
Int32 iCurrent,
ref Boolean& bCancel
);

See Also

CancellationWizObject Class | Aptify.Applications.OrderEntry Namespace


CancellationWizObject.OnTerminalWizard Method

protected virtual void OnTerminalWizard(
String sErrorMessage,
Boolean bCancel
);

See Also

CancellationWizObject Class | Aptify.Applications.OrderEntry Namespace


CancellationWizObject.OnValidationErrorFound Method

protected virtual void OnValidationErrorFound(
String sErrorMessage,
Boolean bCancel
);

See Also

CancellationWizObject Class | Aptify.Applications.OrderEntry Namespace


CancellationWizObject.PaymentCaptureStatus Method

public bool PaymentCaptureStatus();

See Also

CancellationWizObject Class | Aptify.Applications.OrderEntry Namespace


CancellationWizObject.ResetVariables Method

public virtual void ResetVariables();

See Also

CancellationWizObject Class | Aptify.Applications.OrderEntry Namespace


CancellationWizObject.SetQuantityCancelled Method

public void SetQuantityCancelled(
Int64 lOrderLineID,
Decimal dQuantityCancelled
);

See Also

CancellationWizObject Class | Aptify.Applications.OrderEntry Namespace


CancellationWizObject.SetupWizardText Method

public virtual void SetupWizardText();

See Also

CancellationWizObject Class | Aptify.Applications.OrderEntry Namespace


CancellationWizObject.ValidateWizardPageData Method

public virtual bool ValidateWizardPageData(
Int32 iCurrentPage,
ref String& sError
);

See Also

CancellationWizObject Class | Aptify.Applications.OrderEntry Namespace


CancellationWizObject Events

The events of the CancellationWizObject class are listed below. For a complete list of CancellationWizObject class members, see the CancellationWizObject Members topic.

Public Instance Events

Status
TerminateWizard
ValidationErrorFound

See Also

CancellationWizObject Class | Aptify.Applications.OrderEntry Namespace


CancellationWizObject.CancellationWizObject.StatusEventHandler Event

public event CancellationWizObject.StatusEventHandler Status;

See Also

CancellationWizObject Class | Aptify.Applications.OrderEntry Namespace


CancellationWizObject.CancellationWizObject.TerminateWizardEventHandler Event

public event CancellationWizObject.TerminateWizardEventHandler TerminateWizard;

See Also

CancellationWizObject Class | Aptify.Applications.OrderEntry Namespace


CancellationWizObject.CancellationWizObject.ValidationErrorFoundEventHandler Event

public event CancellationWizObject.ValidationErrorFoundEventHandler ValidationErrorFound;

See Also

CancellationWizObject Class | Aptify.Applications.OrderEntry Namespace


CancellationWizObject.StatusEventHandler Delegate

public delegate void CancellationWizObject.StatusEventHandler(
String Message,
Int32 Max,
Int32 Current
);

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: CancellationWizard (in CancellationWizard.dll)

See Also

Aptify.Applications.OrderEntry Namespace


CancellationWizObject.TerminateWizardEventHandler Delegate

public delegate void CancellationWizObject.TerminateWizardEventHandler(
String ErrorMessage
);

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: CancellationWizard (in CancellationWizard.dll)

See Also

Aptify.Applications.OrderEntry Namespace


CancellationWizObject.ValidationErrorFoundEventHandler Delegate

public delegate void CancellationWizObject.ValidationErrorFoundEventHandler(
String sErrorMessage
);

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: CancellationWizard (in CancellationWizard.dll)

See Also

Aptify.Applications.OrderEntry Namespace


CheckCredit Class

This object implements the Aptify.Applications.OrderEntry.ICheckCredit interface. The purpose of this component is to check the credit for an order and return the status of that credit check back to the calling object.

For a list of all members of this type, see CheckCredit Members.

System.Object
CheckCredit

public class CheckCredit : ICheckCredit, IProcessComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

This is the default implementation of this area of the functionality and can be augmented/overriden by sub-classes of this class that can then be plugged into the Aptify Order Entry system. For information on how to plug-in a sub-class or other object that implements ICheckCredit, review the documentation for the ICheckCredit interface.

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: CheckCredit (in CheckCredit.dll)

See Also

CheckCredit Members | Aptify.Applications.OrderEntry Namespace


CheckCredit Members

CheckCredit overview

Public Instance Constructors

CheckCredit Constructor Initializes a new instance of the CheckCredit class.

Public Instance Properties

Properties

Public Instance Methods

CheckCredit | This is the default implementation of the Check Credit functionality and can be overriden as required by sub-classes.
Config | This method must be called before any other member of the class is accessed. The method sets up a Data Action and the Database property which can be used by sub-classes.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

Application | Returns an instance of the Aptify Application Object
DataAction | Returns an instance of the Aptify DataAction class
Database | Returns the database name where the Aptify CRM entities are located

Protected Instance Methods

BuildUserMessage | Appends a String to an existing user message.
CalculateInitialPayment | This method is responsible for calculating the amount of the initial payment for a given order. By default the method simply returns the amount of the InitialPaymentAmount field in the Orders entity. However, if the order has been saved and the Order Type is Quotation, the amount returned is 0.
CalculateOrderTotal | This method calculates the GRAND TOTAL of the order based on the order lines sub-type.
ConvertToFunctionalCurrency |
DoCompanyCreditLimitCheck | This method is responsible for performing a credit limit check on a company. This function is called by the CheckCredit() method after the company's credit status is checked and ensured to be set to "Approved". This method assumes that the company has an Approved Credit Status so it does not redundantly check it sicne this method is only called in the event that credit is approved. The sole responsibility of this method is to check the credit limit of the company and determine if there is enough credit available to cover the order in question
DoPersonCreditLimitCheck | This method is responsible for performing a credit limit check on a person. This function is called by the CheckCredit() method after the person's credit status is checked and ensured to be set to "Approved". This method assumes that the person has an Approved Credit Status so it does not redundantly check it sicne this method is only called in the event that credit is approved. The sole responsibility of this method is to check the credit limit of the person and determine if there is enough credit available to cover the order in question
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetCompanyCreditLimit | This method is responsible for returning a given company's credit limit. The default implementation of this method calls spGetCompanyCreditLimit in the database. Beginning with Aptify 4.5, this method is obsolete and has been replaced with GetCompanyCreditLimitCurrency.
GetCompanyCreditLimitCurrency | This method is responsible for returning a given company's credit limit, including the limit's Currency Type. The default implementation of this method calls spGetCompanyCreditLimitWithCurrency in the database.
GetCompanyCreditStatus | This method is responsible for returning the Base Credit Status text value for the Bill To Company specified in the provided Order GE that is passed into the function. In addition to returning the status text, this method also returns a Boolean value in the IsCreditApproved OUT parameter to indicate if the Status code returned is Approved or another code. The default implementation of this method simply calls the spGetCompanyBaseCreditStatus stored procedure in the database.
GetExistingCompanyBalance | This method is responsible for returning the balance of all orders that are linked to the specified Company ID (via the Bill To Company ID on an Order) This method excludes the current Order ID since the balance on this order is not finalized yet as it is being evaluated for the credit purposes of this object. Quotations and Cancelled Orders are not included in the Balance calculation. Starting with Aptify 4.5, this method is now obsolete and has been replaced with GetExistingCompanyBalanceCurrency
GetExistingCompanyBalanceCurrency | This method is responsible for returning the balance of all orders that are linked to the specified Company ID (via the Bill To Company ID on an Order) This method excludes the current Order ID since the balance on this order is not finalized yet as it is being evaluated for the credit purposes of this object. Quotations and Cancelled Orders are not included in the Balance calculation.
GetExistingPersonBalance | This method is responsible for returning the balance of all orders that are linked to the specified Person ID (via the Bill To ID on an Order where the Bill To Company ID is not provided) This method excludes the current Order ID since the balance on this order is not finalized yet as it is being evaluated for the credit purposes of this object. Quotations and Cancelled Orders are not included in the Balance. Starting with Aptify 4.5, this method is now obsolete and has been replaced with GetExistingPersonBalanceCurrency
GetExistingPersonBalanceCurrency | This method is responsible for returning the balance of all orders that are linked to the specified Person ID (via the Bill To ID on an Order) This method excludes the current Order ID since the balance on this order is not finalized yet as it is being evaluated for the credit purposes of this object. Quotations and Cancelled Orders are not included in the Balance calculation.
GetOrderPaymentTotal | This method is responsible for returning the sum total of all payments stored in the database that have been applied to the specified Order ID. The default implementation of this method is to simply call the spGetOrderPaymentTotal stored procedure in the database.
GetPersonCreditLimit | This method is responsible for returning a given company's credit limit. The default implementation of this method calls spGetPersonCreditLimit in the database. Beginning with Aptify 4.5, this method is obsolete and has been replaced with GetPersonCreditLimitCurrency.
GetPersonCreditLimitCurrency | This method is responsible for returning a given person's credit limit including the limit's Currency Type. The default implementation of this method calls spGetPersonCreditLimitWithCurrency in the database.
GetPersonCreditStatus | This method is responsible for returning the Base Credit Status text value for the Bill To Person specified in the provided Order GE that is passed into the function. In addition to returning the status text, this method also returns a Boolean value in the IsCreditApproved OUT parameter to indicate if the Status code returned is Approved or another code. The default implementation of this method simply calls the spGetPersonBaseCreditStatus stored procedure in the database.
GetSingleCurrencyCreditMessage |
IsCreditCheckRequired | This method is responsible for determining if a credit check is required or not for the order specified. The logic in the default implementation of this method is to first check the order Type. If the Order Type is not a "Regular Order", this method returns False. Also, if the order status is "Back Ordered" then the function also is skipped internally and returns False.
IsInflowPayment | This method is responsible for determining if the Payment Type associated with the order is an "Inflow" payment type, meaning payment is being received at the time of the order. Credit checks are only required when payment is NOT being received at the time of the order, so this function is checked before credit is checked on the order so as to not unnecessarily check credit when a payment type is being provided that has immediate cash inflow at the time of the order. The default implementation of this method checks the value of the Inflow bit field on the Payment Types entity.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CheckCredit Class | Aptify.Applications.OrderEntry Namespace


CheckCredit Constructor

Initializes a new instance of the CheckCredit class.

public CheckCredit();

See Also

CheckCredit Class | Aptify.Applications.OrderEntry Namespace


CheckCredit Properties

The properties of the CheckCredit class are listed below. For a complete list of CheckCredit class members, see the CheckCredit Members topic.

Public Instance Properties

Properties

Protected Instance Properties

Application | Returns an instance of the Aptify Application Object
DataAction | Returns an instance of the Aptify DataAction class
Database | Returns the database name where the Aptify CRM entities are located

See Also

CheckCredit Class | Aptify.Applications.OrderEntry Namespace


Application Property

Aptify 5.0 Software Development Kit (SDK)

CheckCredit.Application Property

Returns an instance of the Aptify Application Object

protected AptifyApplication Application {get;}

Property Value

Remarks

See Also

CheckCredit Class | Aptify.Applications.OrderEntry Namespace


DataAction Property

Aptify 5.0 Software Development Kit (SDK)

CheckCredit.DataAction Property

Returns an instance of the Aptify DataAction class

protected DataAction DataAction {get;}

Property Value

Remarks

See Also

CheckCredit Class | Aptify.Applications.OrderEntry Namespace


Database Property

Aptify 5.0 Software Development Kit (SDK)

CheckCredit.Database Property

Returns the database name where the Aptify CRM entities are located

protected String Database {get;}

Property Value

Remarks

See Also

CheckCredit Class | Aptify.Applications.OrderEntry Namespace


Properties Property

Aptify 5.0 Software Development Kit (SDK)

CheckCredit.Properties Property

public AptifyProperties Properties {get;}

Implements

IProcessComponent.

See Also

CheckCredit Class | Aptify.Applications.OrderEntry Namespace


CheckCredit Methods

The methods of the CheckCredit class are listed below. For a complete list of CheckCredit class members, see the CheckCredit Members topic.

Public Instance Methods

CheckCredit | This is the default implementation of the Check Credit functionality and can be overriden as required by sub-classes.
Config | This method must be called before any other member of the class is accessed. The method sets up a Data Action and the Database property which can be used by sub-classes.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

BuildUserMessage | Appends a String to an existing user message.
CalculateInitialPayment | This method is responsible for calculating the amount of the initial payment for a given order. By default the method simply returns the amount of the InitialPaymentAmount field in the Orders entity. However, if the order has been saved and the Order Type is Quotation, the amount returned is 0.
CalculateOrderTotal | This method calculates the GRAND TOTAL of the order based on the order lines sub-type.
ConvertToFunctionalCurrency |
DoCompanyCreditLimitCheck | This method is responsible for performing a credit limit check on a company. This function is called by the CheckCredit() method after the company's credit status is checked and ensured to be set to "Approved". This method assumes that the company has an Approved Credit Status so it does not redundantly check it sicne this method is only called in the event that credit is approved. The sole responsibility of this method is to check the credit limit of the company and determine if there is enough credit available to cover the order in question
DoPersonCreditLimitCheck | This method is responsible for performing a credit limit check on a person. This function is called by the CheckCredit() method after the person's credit status is checked and ensured to be set to "Approved". This method assumes that the person has an Approved Credit Status so it does not redundantly check it sicne this method is only called in the event that credit is approved. The sole responsibility of this method is to check the credit limit of the person and determine if there is enough credit available to cover the order in question
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetCompanyCreditLimit | This method is responsible for returning a given company's credit limit. The default implementation of this method calls spGetCompanyCreditLimit in the database. Beginning with Aptify 4.5, this method is obsolete and has been replaced with GetCompanyCreditLimitCurrency.
GetCompanyCreditLimitCurrency | This method is responsible for returning a given company's credit limit, including the limit's Currency Type. The default implementation of this method calls spGetCompanyCreditLimitWithCurrency in the database.
GetCompanyCreditStatus | This method is responsible for returning the Base Credit Status text value for the Bill To Company specified in the provided Order GE that is passed into the function. In addition to returning the status text, this method also returns a Boolean value in the IsCreditApproved OUT parameter to indicate if the Status code returned is Approved or another code. The default implementation of this method simply calls the spGetCompanyBaseCreditStatus stored procedure in the database.
GetExistingCompanyBalance | This method is responsible for returning the balance of all orders that are linked to the specified Company ID (via the Bill To Company ID on an Order) This method excludes the current Order ID since the balance on this order is not finalized yet as it is being evaluated for the credit purposes of this object. Quotations and Cancelled Orders are not included in the Balance calculation. Starting with Aptify 4.5, this method is now obsolete and has been replaced with GetExistingCompanyBalanceCurrency
GetExistingCompanyBalanceCurrency | This method is responsible for returning the balance of all orders that are linked to the specified Company ID (via the Bill To Company ID on an Order) This method excludes the current Order ID since the balance on this order is not finalized yet as it is being evaluated for the credit purposes of this object. Quotations and Cancelled Orders are not included in the Balance calculation.
GetExistingPersonBalance | This method is responsible for returning the balance of all orders that are linked to the specified Person ID (via the Bill To ID on an Order where the Bill To Company ID is not provided) This method excludes the current Order ID since the balance on this order is not finalized yet as it is being evaluated for the credit purposes of this object. Quotations and Cancelled Orders are not included in the Balance. Starting with Aptify 4.5, this method is now obsolete and has been replaced with GetExistingPersonBalanceCurrency
GetExistingPersonBalanceCurrency | This method is responsible for returning the balance of all orders that are linked to the specified Person ID (via the Bill To ID on an Order) This method excludes the current Order ID since the balance on this order is not finalized yet as it is being evaluated for the credit purposes of this object. Quotations and Cancelled Orders are not included in the Balance calculation.
GetOrderPaymentTotal | This method is responsible for returning the sum total of all payments stored in the database that have been applied to the specified Order ID. The default implementation of this method is to simply call the spGetOrderPaymentTotal stored procedure in the database.
GetPersonCreditLimit | This method is responsible for returning a given company's credit limit. The default implementation of this method calls spGetPersonCreditLimit in the database. Beginning with Aptify 4.5, this method is obsolete and has been replaced with GetPersonCreditLimitCurrency.
GetPersonCreditLimitCurrency | This method is responsible for returning a given person's credit limit including the limit's Currency Type. The default implementation of this method calls spGetPersonCreditLimitWithCurrency in the database.
GetPersonCreditStatus | This method is responsible for returning the Base Credit Status text value for the Bill To Person specified in the provided Order GE that is passed into the function. In addition to returning the status text, this method also returns a Boolean value in the IsCreditApproved OUT parameter to indicate if the Status code returned is Approved or another code. The default implementation of this method simply calls the spGetPersonBaseCreditStatus stored procedure in the database.
GetSingleCurrencyCreditMessage |
IsCreditCheckRequired | This method is responsible for determining if a credit check is required or not for the order specified. The logic in the default implementation of this method is to first check the order Type. If the Order Type is not a "Regular Order", this method returns False. Also, if the order status is "Back Ordered" then the function also is skipped internally and returns False.
IsInflowPayment | This method is responsible for determining if the Payment Type associated with the order is an "Inflow" payment type, meaning payment is being received at the time of the order. Credit checks are only required when payment is NOT being received at the time of the order, so this function is checked before credit is checked on the order so as to not unnecessarily check credit when a payment type is being provided that has immediate cash inflow at the time of the order. The default implementation of this method checks the value of the Inflow bit field on the Payment Types entity.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CheckCredit Class | Aptify.Applications.OrderEntry Namespace


CheckCredit.BuildUserMessage Method

Appends a String to an existing user message.

protected virtual string BuildUserMessage(
String UserMessage,
String Addendum
);

Parameters

UserMessage
The current user message.
Addendum
The new string that will be appended the UserMessage.

Return Value

Returns a new user message with the addendum appended to the original user message.

Remarks

If the user message is not empty and does not end with a NewLine, then one will be appended to the user message.

See Also

CheckCredit Class | Aptify.Applications.OrderEntry Namespace


CheckCredit.CalculateInitialPayment Method

This method is responsible for calculating the amount of the initial payment for a given order. By default the method simply returns the amount of the InitialPaymentAmount field in the Orders entity. However, if the order has been saved and the Order Type is Quotation, the amount returned is 0.

protected virtual decimal CalculateInitialPayment(
OrdersEntity OrderGE
);

Parameters

OrderGE

Return Value

Remarks

See Also

CheckCredit Class | Aptify.Applications.OrderEntry Namespace


CheckCredit.CalculateOrderTotal Method

This method calculates the GRAND TOTAL of the order based on the order lines sub-type.

protected virtual decimal CalculateOrderTotal(
OrdersEntity OrderGE
);

Return Value

Remarks

See Also

CheckCredit Class | Aptify.Applications.OrderEntry Namespace


CheckCredit.CheckCredit Method

This is the default implementation of the Check Credit functionality and can be overriden as required by sub-classes.

public virtual bool CheckCredit(
OrdersEntity OrderGE,
ref String& UserMessage
);

Parameters

OrderGE
Order Generic Entity Object
UserMessage
OUT parameter: Will return a message that can be displayed to the user if the function returns false

Return Value

True if the credit is approved, False Otherwise

Implements

ICheckCredit.

Remarks

Instead of overridding the entire class, consider reviewing each of the component methods of the default credit check routine as described here and consider overriding those components individually instead if it is possible to reuse some of the default logic in this base class. The default logic for this method is described below in the following steps: Step 1: Determine if a credit check is required for this order at all. This is done by calling the IsCreditCheckRequiredMethod() Step 2: Determine the Bill To type for the Order - which is either at the company level or at the person level. If BillToCompanyID is not provided to the order, then we must validate credit at the person level. If BillToCompanyID is provided, then we validate credit at the company level. Step 3: Get the credit status of the payee (either person or company) by calling the appropriate method GetPersonCreditStatus() or GetCompanyCreditStatus() Step 4: Call the credit limit function for the appropriate payee type ( DoPersonCreditLimitCheck() or DoCompanyCreditLimitCheck() )

See Also

CheckCredit Class | Aptify.Applications.OrderEntry Namespace


CheckCredit.Config Method

This method must be called before any other member of the class is accessed. The method sets up a Data Action and the Database property which can be used by sub-classes.

public virtual void Config(
AptifyApplication Application
);

Parameters

Application

Implements

IProcessComponent.

Remarks

See Also

CheckCredit Class | Aptify.Applications.OrderEntry Namespace


CheckCredit.ConvertToFunctionalCurrency Method

protected decimal ConvertToFunctionalCurrency(
Decimal dAmount,
OrdersEntity oOrderGE
);

See Also

CheckCredit Class | Aptify.Applications.OrderEntry Namespace


CheckCredit.DoCompanyCreditLimitCheck Method

This method is responsible for performing a credit limit check on a company. This function is called by the CheckCredit() method after the company's credit status is checked and ensured to be set to "Approved". This method assumes that the company has an Approved Credit Status so it does not redundantly check it sicne this method is only called in the event that credit is approved. The sole responsibility of this method is to check the credit limit of the company and determine if there is enough credit available to cover the order in question

protected virtual bool DoCompanyCreditLimitCheck(
OrdersEntity OrderGE,
ref String& UserMessage
);

Parameters

OrderGE
UserMessage

Return Value

True if there is enough credit available to cover the order, False otherwise

Remarks

See Also

CheckCredit Class | Aptify.Applications.OrderEntry Namespace


CheckCredit.DoPersonCreditLimitCheck Method

This method is responsible for performing a credit limit check on a person. This function is called by the CheckCredit() method after the person's credit status is checked and ensured to be set to "Approved". This method assumes that the person has an Approved Credit Status so it does not redundantly check it sicne this method is only called in the event that credit is approved. The sole responsibility of this method is to check the credit limit of the person and determine if there is enough credit available to cover the order in question

protected virtual bool DoPersonCreditLimitCheck(
OrdersEntity OrderGE,
ref String& UserMessage
);

Parameters

OrderGE
UserMessage

Return Value

True if there is enough credit available to cover the order, False otherwise

Remarks

See Also

CheckCredit Class | Aptify.Applications.OrderEntry Namespace


CheckCredit.GetCompanyCreditLimit Method

This method is responsible for returning a given company's credit limit. The default implementation of this method calls spGetCompanyCreditLimit in the database. Beginning with Aptify 4.5, this method is obsolete and has been replaced with GetCompanyCreditLimitCurrency.

protected virtual decimal GetCompanyCreditLimit(
Int64 CompanyID
);

Parameters

CompanyID

Return Value

Remarks

See Also

CheckCredit Class | Aptify.Applications.OrderEntry Namespace


CheckCredit.GetCompanyCreditLimitCurrency Method

This method is responsible for returning a given company's credit limit, including the limit's Currency Type. The default implementation of this method calls spGetCompanyCreditLimitWithCurrency in the database.

protected virtual Currency GetCompanyCreditLimitCurrency(
Int64 CompanyID
);

Parameters

CompanyID

Return Value

Remarks

See Also

CheckCredit Class | Aptify.Applications.OrderEntry Namespace


CheckCredit.GetCompanyCreditStatus Method

This method is responsible for returning the Base Credit Status text value for the Bill To Company specified in the provided Order GE that is passed into the function. In addition to returning the status text, this method also returns a Boolean value in the IsCreditApproved OUT parameter to indicate if the Status code returned is Approved or another code. The default implementation of this method simply calls the spGetCompanyBaseCreditStatus stored procedure in the database.

protected virtual string GetCompanyCreditStatus(
OrdersEntity OrderGE,
ref Boolean& IsCreditApproved,
ref String& UserMessage
);

Parameters

OrderGE
IsCreditApproved
OUT Parameter: Returns True if the Credit is Approved, False otherwise
UserMessage
OUT Parameter: Returns a message to the user indicating the problem with the credit if credit is not approved

Return Value

The Base Credit Status(Text Value) of the Company

Remarks

See Also

CheckCredit Class | Aptify.Applications.OrderEntry Namespace


CheckCredit.GetExistingCompanyBalance Method

This method is responsible for returning the balance of all orders that are linked to the specified Company ID (via the Bill To Company ID on an Order) This method excludes the current Order ID since the balance on this order is not finalized yet as it is being evaluated for the credit purposes of this object. Quotations and Cancelled Orders are not included in the Balance calculation. Starting with Aptify 4.5, this method is now obsolete and has been replaced with GetExistingCompanyBalanceCurrency

protected virtual decimal GetExistingCompanyBalance(
Int64 OrderID,
Int64 CompanyID
);

Parameters

OrderID
CompanyID

Return Value

Balance of all orders other than the one specified in Order ID that are associated with the Company ID via the Bill To Company ID on the Order.

Remarks

See Also

CheckCredit Class | Aptify.Applications.OrderEntry Namespace


CheckCredit.GetExistingCompanyBalanceCurrency Method

This method is responsible for returning the balance of all orders that are linked to the specified Company ID (via the Bill To Company ID on an Order) This method excludes the current Order ID since the balance on this order is not finalized yet as it is being evaluated for the credit purposes of this object. Quotations and Cancelled Orders are not included in the Balance calculation.

protected virtual Currency GetExistingCompanyBalanceCurrency(
Int64 OrderID,
Int64 CompanyID,
Int32 CurrencyTypeID
);

Parameters

OrderID
CompanyID
CurrencyTypeID

Return Value

Balance of all orders other than the one specified in Order ID that are associated with the Company ID via the Bill To Company ID on the Order.

Remarks

See Also

CheckCredit Class | Aptify.Applications.OrderEntry Namespace


CheckCredit.GetExistingPersonBalance Method

This method is responsible for returning the balance of all orders that are linked to the specified Person ID (via the Bill To ID on an Order where the Bill To Company ID is not provided) This method excludes the current Order ID since the balance on this order is not finalized yet as it is being evaluated for the credit purposes of this object. Quotations and Cancelled Orders are not included in the Balance. Starting with Aptify 4.5, this method is now obsolete and has been replaced with GetExistingPersonBalanceCurrency

protected virtual decimal GetExistingPersonBalance(
Int64 OrderID,
Int64 PersonID
);

Parameters

OrderID
PersonID

Return Value

Balance of all orders other than the one specified in Order ID that are associated with the Person ID via the Bill To ID on the Order.

Remarks

See Also

CheckCredit Class | Aptify.Applications.OrderEntry Namespace


CheckCredit.GetExistingPersonBalanceCurrency Method

This method is responsible for returning the balance of all orders that are linked to the specified Person ID (via the Bill To ID on an Order) This method excludes the current Order ID since the balance on this order is not finalized yet as it is being evaluated for the credit purposes of this object. Quotations and Cancelled Orders are not included in the Balance calculation.

protected virtual Currency GetExistingPersonBalanceCurrency(
Int64 OrderID,
Int64 PersonID,
Int32 CurrencyTypeID
);

Parameters

OrderID
PersonID
CurrencyTypeID

Return Value

Balance of all orders other than the one specified in Order ID that are associated with the Company ID via the Bill To Company ID on the Order.

Remarks

See Also

CheckCredit Class | Aptify.Applications.OrderEntry Namespace


CheckCredit.GetOrderPaymentTotal Method

This method is responsible for returning the sum total of all payments stored in the database that have been applied to the specified Order ID. The default implementation of this method is to simply call the spGetOrderPaymentTotal stored procedure in the database.

protected virtual decimal GetOrderPaymentTotal(
Int64 OrderID
);

Parameters

OrderID

Return Value

Remarks

See Also

CheckCredit Class | Aptify.Applications.OrderEntry Namespace


CheckCredit.GetPersonCreditLimit Method

This method is responsible for returning a given company's credit limit. The default implementation of this method calls spGetPersonCreditLimit in the database. Beginning with Aptify 4.5, this method is obsolete and has been replaced with GetPersonCreditLimitCurrency.

protected virtual decimal GetPersonCreditLimit(
Int64 CompanyID
);

Parameters

CompanyID

Return Value

Remarks

See Also

CheckCredit Class | Aptify.Applications.OrderEntry Namespace


CheckCredit.GetPersonCreditLimitCurrency Method

This method is responsible for returning a given person's credit limit including the limit's Currency Type. The default implementation of this method calls spGetPersonCreditLimitWithCurrency in the database.

protected virtual Currency GetPersonCreditLimitCurrency(
Int64 PersonID
);

Parameters

PersonID

Return Value

Remarks

See Also

CheckCredit Class | Aptify.Applications.OrderEntry Namespace


CheckCredit.GetPersonCreditStatus Method

This method is responsible for returning the Base Credit Status text value for the Bill To Person specified in the provided Order GE that is passed into the function. In addition to returning the status text, this method also returns a Boolean value in the IsCreditApproved OUT parameter to indicate if the Status code returned is Approved or another code. The default implementation of this method simply calls the spGetPersonBaseCreditStatus stored procedure in the database.

protected virtual string GetPersonCreditStatus(
OrdersEntity OrderGE,
ref Boolean& IsCreditApproved,
ref String& UserMessage
);

Parameters

OrderGE
IsCreditApproved
OUT Parameter: Returns True if the Credit is Approved, False otherwise
UserMessage
OUT Parameter: Returns a message to the user indicating the problem with the credit if credit is not approved

Return Value

The Base Credit Status(Text Value) of the Person

Remarks

See Also

CheckCredit Class | Aptify.Applications.OrderEntry Namespace


CheckCredit.GetSingleCurrencyCreditMessage Method

protected virtual string GetSingleCurrencyCreditMessage(
String sCustType,
String sCreditLimitCurrencyFormat,
Decimal dLimit,
Decimal dCurrentBalance,
Decimal dAmountOverLimit
);

See Also

CheckCredit Class | Aptify.Applications.OrderEntry Namespace


CheckCredit.IsCreditCheckRequired Method

This method is responsible for determining if a credit check is required or not for the order specified. The logic in the default implementation of this method is to first check the order Type. If the Order Type is not a "Regular Order", this method returns False. Also, if the order status is "Back Ordered" then the function also is skipped internally and returns False.

protected virtual bool IsCreditCheckRequired(
OrdersEntity OrderGE
);

Parameters

OrderGE

Return Value

Remarks

See Also

CheckCredit Class | Aptify.Applications.OrderEntry Namespace


CheckCredit.IsInflowPayment Method

This method is responsible for determining if the Payment Type associated with the order is an "Inflow" payment type, meaning payment is being received at the time of the order. Credit checks are only required when payment is NOT being received at the time of the order, so this function is checked before credit is checked on the order so as to not unnecessarily check credit when a payment type is being provided that has immediate cash inflow at the time of the order. The default implementation of this method checks the value of the Inflow bit field on the Payment Types entity.

protected virtual bool IsInflowPayment(
OrdersEntity OrderGE
);

Parameters

OrderGE

Return Value

True if the Payment Type ID specified in the Order GE object is an Inflow payment type, False otherwise

Remarks

See Also

CheckCredit Class | Aptify.Applications.OrderEntry Namespace


CheckCredit.Run Method

public string Run();

Implements

IProcessComponent.

See Also

CheckCredit Class | Aptify.Applications.OrderEntry Namespace


CheckCredit.Currency Structure

For a list of all members of this type, see CheckCredit.Currency Members.

System.Object
ValueType
CheckCredit.Currency

protected struct CheckCredit.Currency

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: CheckCredit (in CheckCredit.dll)

See Also

CheckCredit.Currency Members | Aptify.Applications.OrderEntry Namespace


CheckCredit.Currency Members

CheckCredit.Currency overview

Public Instance Fields

Amount
CurrencyTypeID

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

CheckCredit.Currency Structure | Aptify.Applications.OrderEntry Namespace


CheckCredit.Currency Fields

The fields of the CheckCredit.Currency structure are listed below. For a complete list of CheckCredit.Currency structure members, see the CheckCredit.Currency Members topic.

Public Instance Fields

Amount
CurrencyTypeID

See Also

CheckCredit.Currency Structure | Aptify.Applications.OrderEntry Namespace


CheckCredit.Currency.Amount Field

public Amount Amount;

See Also

CheckCredit.Currency Class | Aptify.Applications.OrderEntry Namespace


CheckCredit.Currency.CurrencyTypeID Field

public CurrencyTypeID CurrencyTypeID;

See Also

CheckCredit.Currency Class | Aptify.Applications.OrderEntry Namespace


CheckInventory Class

This class is responsible for checking inventory for all types of products. Sub-classes

For a list of all members of this type, see CheckInventory Members.

System.Object
CheckInventory
CheckMeetingInventory

public class CheckInventory : ICheckInventory

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: CheckInventory (in CheckInventory.dll)

See Also

CheckInventory Members | Aptify.Applications.OrderEntry Namespace


CheckInventory Members

CheckInventory overview

Public Instance Constructors

CheckInventory Constructor Initializes a new instance of the CheckInventory class.

Public Instance Methods

CheckInventory |
Config | Configures the object for use, overridable by sub-classes
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInventoryLocation | This method is responsible for returning an inventory location to use for reserving inventory for a given Product, Quantity and optionally, taking into account a Primary Inventory Location ID. The method returns the Inventory Location ID that should be used given the parameters provided. The default logic implemented by the Check Inventory object is to use the Primary Location ID, if it is provided and it has available inventory. If the Primary Location ID is not provided, the inventory location with the largest amount of available inventory will be used. If This method is overridable by sub-classes so that more specialized inventory reservation algorithms can be created for things such as proximity based inventory reservation (e.g. reserving inventory closest to the customer's ship-to address, etc)
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

Application | Returns Aptify Application Object
DataAction | Returns Aptify Data Action class instance
Database | Returns Aptify Database Name Where Inventory related Entities are stored

Protected Instance Methods

DetermineInventoryStatus | This method is responsible for determining the status of inventory availability for a given item and returns if the inventory available is sufficient or insufficient based on the parameters passed in.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FindReleasedQuantity | This method is responsible for determining the amount of inventory that has been released on the current order by looking for an overall reduction in inventory being used for the current item represented by the OrderDetailGE parameter. This method finds the quantity by looking for the amount that was previously stored in the database for the given order for the product in the current line and comparing it to the total amount of quantity of the product on the order as it exists in the OrderGE provided. The function returns the difference between the persisted quantity(amount the database reflects) and the amount currently in the order as this amount needs to be taken into account as available in the overall calculation of available inventory. This calculation does not take into account inventory location as it is important to review this number globally from a product availability perspective. This method is only applicable for orders that have not yet been shipped as those orders are not allowed to change with respect to quantities, prices, and any other financial data, once marked as shipped.
GenerateInventoryWarning | This method is responsible for creating a warning message for presentation to the user if there is insufficient inventory from any ONE inventory location to fulfill an order line. This is a two step process: First, if OVERALL inventory is sufficient, then we give the user a breakdown of the availability by Inventory Location. If overall quantity is not sufficient, then we provide a general warning stating that the order cannot save since not enough is available across all locations.
GetInventoryLocationInfo | Returns the appropriate (for the given quantity) inventory location that can be used to reserve inventory for a particular order line. PrimaryLocationID is used as the default location. If there is not sufficient quantity in that location, another location will be chosen.
GetInventoryOnCurrentOrder | This method is responsible for calculating the running total for the same products that exist in the same order. The purpose of the method is to make sure that enough inventory exist to account for the incremental change in the order. For example, if this is a NEW order line, the incremental change is simply the quantity on the order line. If this is an existing order line, the incremental change is the difference between the new quantity and the old quantity. If this is Shipped order, the incremental change is the sum of the all previous order lines' quantities where product and inventory location are the same. If the order is being shipped, we would take into account only lines that are before the shipped line. Lastly, if none of the above conditions are true, every line is taken into account dblQtyNewlyOrdered is a
GetInventoryOnOrderString
GetProductDefaultInvLocation | This function will return the default product inventory location, if one is specified in the product record. Otherwise, it will return the inventory location with the most units. If it can't find any inventory locations at all, then the function will return -1.
GetProductNameFromID | This method is responsible for returning the name of a product based on the Product ID. The Product cache is used to retrieve this information since product names do not change frequently.
InternalCheckInventory
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CheckInventory Class | Aptify.Applications.OrderEntry Namespace


CheckInventory Constructor

Initializes a new instance of the CheckInventory class.

public CheckInventory();

See Also

CheckInventory Class | Aptify.Applications.OrderEntry Namespace


CheckInventory Properties

The properties of the CheckInventory class are listed below. For a complete list of CheckInventory class members, see the CheckInventory Members topic.

Protected Instance Properties

Application | Returns Aptify Application Object
DataAction | Returns Aptify Data Action class instance
Database | Returns Aptify Database Name Where Inventory related Entities are stored

See Also

CheckInventory Class | Aptify.Applications.OrderEntry Namespace


Application Property

Aptify 5.0 Software Development Kit (SDK)

CheckInventory.Application Property

Returns Aptify Application Object

protected AptifyApplication Application {get;}

Property Value

Remarks

See Also

CheckInventory Class | Aptify.Applications.OrderEntry Namespace


DataAction Property

Aptify 5.0 Software Development Kit (SDK)

CheckInventory.DataAction Property

Returns Aptify Data Action class instance

protected DataAction DataAction {get;}

Property Value

Remarks

See Also

CheckInventory Class | Aptify.Applications.OrderEntry Namespace


Database Property

Aptify 5.0 Software Development Kit (SDK)

CheckInventory.Database Property

Returns Aptify Database Name Where Inventory related Entities are stored

protected String Database {get;}

Property Value

Remarks

See Also

CheckInventory Class | Aptify.Applications.OrderEntry Namespace


CheckInventory Methods

The methods of the CheckInventory class are listed below. For a complete list of CheckInventory class members, see the CheckInventory Members topic.

Public Instance Methods

CheckInventory |
Config | Configures the object for use, overridable by sub-classes
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInventoryLocation | This method is responsible for returning an inventory location to use for reserving inventory for a given Product, Quantity and optionally, taking into account a Primary Inventory Location ID. The method returns the Inventory Location ID that should be used given the parameters provided. The default logic implemented by the Check Inventory object is to use the Primary Location ID, if it is provided and it has available inventory. If the Primary Location ID is not provided, the inventory location with the largest amount of available inventory will be used. If This method is overridable by sub-classes so that more specialized inventory reservation algorithms can be created for things such as proximity based inventory reservation (e.g. reserving inventory closest to the customer's ship-to address, etc)
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

DetermineInventoryStatus | This method is responsible for determining the status of inventory availability for a given item and returns if the inventory available is sufficient or insufficient based on the parameters passed in.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FindReleasedQuantity | This method is responsible for determining the amount of inventory that has been released on the current order by looking for an overall reduction in inventory being used for the current item represented by the OrderDetailGE parameter. This method finds the quantity by looking for the amount that was previously stored in the database for the given order for the product in the current line and comparing it to the total amount of quantity of the product on the order as it exists in the OrderGE provided. The function returns the difference between the persisted quantity(amount the database reflects) and the amount currently in the order as this amount needs to be taken into account as available in the overall calculation of available inventory. This calculation does not take into account inventory location as it is important to review this number globally from a product availability perspective. This method is only applicable for orders that have not yet been shipped as those orders are not allowed to change with respect to quantities, prices, and any other financial data, once marked as shipped.
GenerateInventoryWarning | This method is responsible for creating a warning message for presentation to the user if there is insufficient inventory from any ONE inventory location to fulfill an order line. This is a two step process: First, if OVERALL inventory is sufficient, then we give the user a breakdown of the availability by Inventory Location. If overall quantity is not sufficient, then we provide a general warning stating that the order cannot save since not enough is available across all locations.
GetInventoryLocationInfo | Returns the appropriate (for the given quantity) inventory location that can be used to reserve inventory for a particular order line. PrimaryLocationID is used as the default location. If there is not sufficient quantity in that location, another location will be chosen.
GetInventoryOnCurrentOrder | This method is responsible for calculating the running total for the same products that exist in the same order. The purpose of the method is to make sure that enough inventory exist to account for the incremental change in the order. For example, if this is a NEW order line, the incremental change is simply the quantity on the order line. If this is an existing order line, the incremental change is the difference between the new quantity and the old quantity. If this is Shipped order, the incremental change is the sum of the all previous order lines' quantities where product and inventory location are the same. If the order is being shipped, we would take into account only lines that are before the shipped line. Lastly, if none of the above conditions are true, every line is taken into account dblQtyNewlyOrdered is a
GetInventoryOnOrderString
GetProductDefaultInvLocation | This function will return the default product inventory location, if one is specified in the product record. Otherwise, it will return the inventory location with the most units. If it can't find any inventory locations at all, then the function will return -1.
GetProductNameFromID | This method is responsible for returning the name of a product based on the Product ID. The Product cache is used to retrieve this information since product names do not change frequently.
InternalCheckInventory
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CheckInventory Class | Aptify.Applications.OrderEntry Namespace


CheckInventory.CheckInventory Method

public virtual void CheckInventory(
Int64 ProductID,
Decimal Quantity,
ref Boolean& Required,
ref Decimal& QuantityAvailable,
ref Decimal& QuantityOnHand,
ref Decimal& QuantityOnOrder,
ref Decimal& QuantityReserved,
ref Decimal& QuantityShipped,
ref InventoryStatus& Status,
OrderLinesEntity OrderLineGE,
Boolean AllowGUI,
ref String& Message
);

Implements

ICheckInventory.

See Also

CheckInventory Class | Aptify.Applications.OrderEntry Namespace


CheckInventory.Config Method

Configures the object for use, overridable by sub-classes

public virtual void Config(
AptifyApplication Application
);

Parameters

Application

Implements

ICheckInventory.

Remarks

See Also

CheckInventory Class | Aptify.Applications.OrderEntry Namespace


CheckInventory.DetermineInventoryStatus Method

This method is responsible for determining the status of inventory availability for a given item and returns if the inventory available is sufficient or insufficient based on the parameters passed in.

protected virtual InventoryStatus DetermineInventoryStatus(
Int64 ProductID,
Decimal QuantityAvailable,
Decimal Quantity,
Decimal QuantityShipped,
Boolean CalcShippedMode,
OrdersEntity OrderGE
);

Parameters

ProductID
QuantityAvailable
Quantity
QuantityShipped
CalcShippedMode
OrderGE

Return Value

Remarks

See Also

CheckInventory Class | Aptify.Applications.OrderEntry Namespace


CheckInventory.FindReleasedQuantity Method

This method is responsible for determining the amount of inventory that has been released on the current order by looking for an overall reduction in inventory being used for the current item represented by the OrderDetailGE parameter. This method finds the quantity by looking for the amount that was previously stored in the database for the given order for the product in the current line and comparing it to the total amount of quantity of the product on the order as it exists in the OrderGE provided. The function returns the difference between the persisted quantity(amount the database reflects) and the amount currently in the order as this amount needs to be taken into account as available in the overall calculation of available inventory. This calculation does not take into account inventory location as it is important to review this number globally from a product availability perspective. This method is only applicable for orders that have not yet been shipped as those orders are not allowed to change with respect to quantities, prices, and any other financial data, once marked as shipped.

protected virtual decimal FindReleasedQuantity(
OrderLinesEntity OrderLineGE
);

Parameters

OrderLineGE

Return Value

A quantity value that represents the Old Quantity reserved by the order Less the New Quantity reserved by the order for the product in the OrderDetailGE parameter

Remarks

See Also

CheckInventory Class | Aptify.Applications.OrderEntry Namespace


CheckInventory.GenerateInventoryWarning Method

This method is responsible for creating a warning message for presentation to the user if there is insufficient inventory from any ONE inventory location to fulfill an order line. This is a two step process: First, if OVERALL inventory is sufficient, then we give the user a breakdown of the availability by Inventory Location. If overall quantity is not sufficient, then we provide a general warning stating that the order cannot save since not enough is available across all locations.

protected virtual string GenerateInventoryWarning(
Int64 ProductID,
Decimal QuantityAvailable,
Decimal Quantity,
Decimal QuantityShipped,
Boolean CalculateShippedMode,
Decimal QuantityOnOrder,
OrdersEntity OrderGE,
OrderLinesEntity OrderDetailGE,
ICheckInventory.InventoryStatus Status
);

Parameters

ProductID
QuantityAvailable
Quantity
QuantityShipped
CalculateShippedMode
QuantityOnOrder
OrderGE
OrderDetailGE
Status

Return Value

A message that can be displayed to the user or logged if the operation is running in a silent/Non-UI mode.

Remarks

See Also

CheckInventory Class | Aptify.Applications.OrderEntry Namespace


CheckInventory.GetInventoryLocation Method

This method is responsible for returning an inventory location to use for reserving inventory for a given Product, Quantity and optionally, taking into account a Primary Inventory Location ID. The method returns the Inventory Location ID that should be used given the parameters provided. The default logic implemented by the Check Inventory object is to use the Primary Location ID, if it is provided and it has available inventory. If the Primary Location ID is not provided, the inventory location with the largest amount of available inventory will be used. If This method is overridable by sub-classes so that more specialized inventory reservation algorithms can be created for things such as proximity based inventory reservation (e.g. reserving inventory closest to the customer's ship-to address, etc)

public virtual long GetInventoryLocation(
Int64 ProductID,
Decimal Quantity,
Int64 PrimaryLocationID,
OrderLinesEntity OrderLineGE
);

Parameters

ProductID
Quantity
PrimaryLocationID
OrderLineGE

Return Value

Implements

ICheckInventory.

Remarks

See Also

CheckInventory Class | Aptify.Applications.OrderEntry Namespace


CheckInventory.GetInventoryLocationInfo Method

Returns the appropriate (for the given quantity) inventory location that can be used to reserve inventory for a particular order line. PrimaryLocationID is used as the default location. If there is not sufficient quantity in that location, another location will be chosen.

protected virtual long GetInventoryLocationInfo(
Int64 ProductID,
Decimal Quantity,
Int64 PrimaryLocationID,
ref Decimal& QuantityAvailable,
ref Decimal& QuantityOnHand,
ref Decimal& QuantityReserved,
ref Decimal& QuantityShipped,
ref Boolean& DefaultLocation,
String SkipLocationList
);

Parameters

ProductID
Quantity
PrimaryLocationID
QuantityAvailable
QuantityOnHand
QuantityReserved
QuantityShipped
DefaultLocation
SkipLocationList

Return Value

Remarks

See Also

CheckInventory Class | Aptify.Applications.OrderEntry Namespace


CheckInventory.GetInventoryOnCurrentOrder Method

This method is responsible for calculating the running total for the same products that exist in the same order. The purpose of the method is to make sure that enough inventory exist to account for the incremental change in the order. For example, if this is a NEW order line, the incremental change is simply the quantity on the order line. If this is an existing order line, the incremental change is the difference between the new quantity and the old quantity. If this is Shipped order, the incremental change is the sum of the all previous order lines' quantities where product and inventory location are the same. If the order is being shipped, we would take into account only lines that are before the shipped line. Lastly, if none of the above conditions are true, every line is taken into account dblQtyNewlyOrdered is a

protected virtual bool GetInventoryOnCurrentOrder(
Int64 ProductID,
Decimal Quantity,
OrderLinesEntity OrderLineGE,
ref Decimal& QuantityNewlyOrdered,
ref Decimal& OldQuantity
);

Parameters

ProductID
Quantity
OrderLineGE
QuantityNewlyOrdered
If this amount is negative - the quantity is assumed to be items put back to inventory. If positive, this quantity represents how many actually should be taken out of inventory.
OldQuantity

Return Value

Remarks

See Also

CheckInventory Class | Aptify.Applications.OrderEntry Namespace


CheckInventory.GetInventoryOnOrderString Method

protected string GetInventoryOnOrderString(
Int64 lProductID,
String sIndent
);

See Also

CheckInventory Class | Aptify.Applications.OrderEntry Namespace


CheckInventory.GetProductDefaultInvLocation Method

This function will return the default product inventory location, if one is specified in the product record. Otherwise, it will return the inventory location with the most units. If it can't find any inventory locations at all, then the function will return -1.

protected long GetProductDefaultInvLocation(
Int64 ProductID
);

Parameters

ProductID

Return Value

Remarks

See Also

CheckInventory Class | Aptify.Applications.OrderEntry Namespace


CheckInventory.GetProductNameFromID Method

This method is responsible for returning the name of a product based on the Product ID. The Product cache is used to retrieve this information since product names do not change frequently.

protected string GetProductNameFromID(
Int64 ProductID
);

Parameters

ProductID

Return Value

Remarks

See Also

CheckInventory Class | Aptify.Applications.OrderEntry Namespace


CheckInventory.InternalCheckInventory Method

protected virtual void InternalCheckInventory(
Int64 ProductID,
Decimal Quantity,
ref Boolean& Required,
ref Decimal& QuantityAvailable,
ref Decimal& QuantityOnHand,
ref Decimal& QuantityOnOrder,
ref Decimal& QuantityReserved,
ref Decimal& QuantityShipped,
ref InventoryStatus& Status,
OrderLinesEntity OrderLineGE,
Boolean AllowGUI,
ref String& Message,
String SkipInventoryList,
Int64 NumberAttempts
);

See Also

CheckInventory Class | Aptify.Applications.OrderEntry Namespace


CheckInventoryOnOrderLineFailedEventArgs Class

For a list of all members of this type, see CheckInventoryOnOrderLineFailedEventArgs Members.

System.Object
EventArgs
CheckInventoryOnOrderLineFailedEventArgs

public class CheckInventoryOnOrderLineFailedEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

CheckInventoryOnOrderLineFailedEventArgs Members | Aptify.Applications.OrderEntry Namespace


CheckInventoryOnOrderLineFailedEventArgs Members

CheckInventoryOnOrderLineFailedEventArgs overview

Public Instance Constructors

CheckInventoryOnOrderLineFailedEventArgs Constructor

Public Instance Properties

InventoryStatus
Message
OrderLineGE

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CheckInventoryOnOrderLineFailedEventArgs Class | Aptify.Applications.OrderEntry Namespace


CheckInventoryOnOrderLineFailedEventArgs Constructor

public CheckInventoryOnOrderLineFailedEventArgs(
OrderLinesEntity OrderLineGE,
ICheckInventory.InventoryStatus InventoryStatus,
String Message
);

See Also

CheckInventoryOnOrderLineFailedEventArgs Class | Aptify.Applications.OrderEntry Namespace


CheckInventoryOnOrderLineFailedEventArgs Properties

The properties of the CheckInventoryOnOrderLineFailedEventArgs class are listed below. For a complete list of CheckInventoryOnOrderLineFailedEventArgs class members, see the CheckInventoryOnOrderLineFailedEventArgs Members topic.

Public Instance Properties

InventoryStatus
Message
OrderLineGE

See Also

CheckInventoryOnOrderLineFailedEventArgs Class | Aptify.Applications.OrderEntry Namespace


InventoryStatus Property

Aptify 5.0 Software Development Kit (SDK)

CheckInventoryOnOrderLineFailedEventArgs.InventoryStatus Property

public ICheckInventory.InventoryStatus InventoryStatus {get;}

See Also

CheckInventoryOnOrderLineFailedEventArgs Class | Aptify.Applications.OrderEntry Namespace


Message Property

Aptify 5.0 Software Development Kit (SDK)

CheckInventoryOnOrderLineFailedEventArgs.Message Property

public String Message {get;}

See Also

CheckInventoryOnOrderLineFailedEventArgs Class | Aptify.Applications.OrderEntry Namespace


OrderLineGE Property

Aptify 5.0 Software Development Kit (SDK)

CheckInventoryOnOrderLineFailedEventArgs.OrderLineGE Property

public OrderLinesEntity OrderLineGE {get;}

See Also

CheckInventoryOnOrderLineFailedEventArgs Class | Aptify.Applications.OrderEntry Namespace


ComponentPlugIn Class

For a list of all members of this type, see ComponentPlugIn Members.

System.Object
ComponentPlugIn

public class ComponentPlugIn

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

ComponentPlugIn Members | Aptify.Applications.OrderEntry Namespace


ComponentPlugIn Members

ComponentPlugIn overview

Public Instance Constructors

ComponentPlugIn Constructor Initializes a new instance of the ComponentPlugIn class.

Public Instance Fields

AssemblyName
ClassName
ObjectName

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ComponentPlugIn Class | Aptify.Applications.OrderEntry Namespace


ComponentPlugIn Constructor

Initializes a new instance of the ComponentPlugIn class.

public ComponentPlugIn();

See Also

ComponentPlugIn Class | Aptify.Applications.OrderEntry Namespace


ComponentPlugIn Fields

The fields of the ComponentPlugIn class are listed below. For a complete list of ComponentPlugIn class members, see the ComponentPlugIn Members topic.

Public Instance Fields

AssemblyName
ClassName
ObjectName

See Also

ComponentPlugIn Class | Aptify.Applications.OrderEntry Namespace


ComponentPlugIn.AssemblyName Field

public AssemblyName AssemblyName;

See Also

ComponentPlugIn Class | Aptify.Applications.OrderEntry Namespace


ComponentPlugIn.ClassName Field

public ClassName ClassName;

See Also

ComponentPlugIn Class | Aptify.Applications.OrderEntry Namespace


ComponentPlugIn.ObjectName Field

public ObjectName ObjectName;

See Also

ComponentPlugIn Class | Aptify.Applications.OrderEntry Namespace


EmployeeOrderPermissionCache Class

Caches Employee Order Permissions information. Shared, on-demand cache.

For a list of all members of this type, see EmployeeOrderPermissionCache Members.

System.Object
EmployeeOrderPermissionCache

public class EmployeeOrderPermissionCache

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

EmployeeOrderPermissionCache Members | Aptify.Applications.OrderEntry Namespace


EmployeeOrderPermissionCache Members

EmployeeOrderPermissionCache overview

Public Static Methods

Instance

Public Instance Constructors

EmployeeOrderPermissionCache Constructor

Public Instance Properties

EmployeeOrderPermissions This method will either return an EmployeeOrderPermissions object from the cache. If the cache doesn't contain an EmployeeOrderPermissions object, the information will be retrieved from the database and used to populate an EmployeeOrderPermissions object which will be added to the cache and returned to the caller.

Public Instance Methods

Clear | Clears the Employee Order Permissions cache.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
RemoveEmployeeOrderPermissionsFromCache |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EmployeeOrderPermissionCache Class | Aptify.Applications.OrderEntry Namespace


EmployeeOrderPermissionCache Constructor

public EmployeeOrderPermissionCache(
AptifyApplication Application
);

See Also

EmployeeOrderPermissionCache Class | Aptify.Applications.OrderEntry Namespace


EmployeeOrderPermissionCache Properties

The properties of the EmployeeOrderPermissionCache class are listed below. For a complete list of EmployeeOrderPermissionCache class members, see the EmployeeOrderPermissionCache Members topic.

Public Instance Properties

EmployeeOrderPermissions This method will either return an EmployeeOrderPermissions object from the cache. If the cache doesn't contain an EmployeeOrderPermissions object, the information will be retrieved from the database and used to populate an EmployeeOrderPermissions object which will be added to the cache and returned to the caller.

See Also

EmployeeOrderPermissionCache Class | Aptify.Applications.OrderEntry Namespace


EmployeeOrderPermissions Property

Aptify 5.0 Software Development Kit (SDK)

EmployeeOrderPermissionCache.EmployeeOrderPermissions Property

This method will either return an EmployeeOrderPermissions object from the cache. If the cache doesn't contain an EmployeeOrderPermissions object, the information will be retrieved from the database and used to populate an EmployeeOrderPermissions object which will be added to the cache and returned to the caller.

public virtual EmployeeOrderPermissions this[
Int64 EmployeeID,
Boolean ForceRefresh
] {get;}

Parameters

EmployeeID
ForceRefresh

Property Value

Remarks

See Also

EmployeeOrderPermissionCache Class | Aptify.Applications.OrderEntry Namespace


EmployeeOrderPermissionCache Methods

The methods of the EmployeeOrderPermissionCache class are listed below. For a complete list of EmployeeOrderPermissionCache class members, see the EmployeeOrderPermissionCache Members topic.

Public Static Methods

Instance

Public Instance Methods

Clear | Clears the Employee Order Permissions cache.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
RemoveEmployeeOrderPermissionsFromCache |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EmployeeOrderPermissionCache Class | Aptify.Applications.OrderEntry Namespace


EmployeeOrderPermissionCache.Clear Method

Clears the Employee Order Permissions cache.

public void Clear();

Remarks

See Also

EmployeeOrderPermissionCache Class | Aptify.Applications.OrderEntry Namespace


EmployeeOrderPermissionCache.Instance Method

public static EmployeeOrderPermissionCache Instance(
AptifyApplication Application
);

See Also

EmployeeOrderPermissionCache Class | Aptify.Applications.OrderEntry Namespace


EmployeeOrderPermissionCache.RemoveEmployeeOrderPermissionsFromCache Method

public void RemoveEmployeeOrderPermissionsFromCache(
Int64 EmployeeID
);

See Also

EmployeeOrderPermissionCache Class | Aptify.Applications.OrderEntry Namespace


EmployeeOrderPermissions Class

For a list of all members of this type, see EmployeeOrderPermissions Members.

System.Object
EmployeeOrderPermissions

public class EmployeeOrderPermissions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

EmployeeOrderPermissions Members | Aptify.Applications.OrderEntry Namespace


EmployeeOrderPermissions Members

EmployeeOrderPermissions overview

Public Instance Constructors

EmployeeOrderPermissions Constructor

Public Instance Properties

AllowFree
AllowPriceOverride
AllowPriceSelection
AllowRelatedProductPromptClose
EmployeeID
ExcludeAccountingTab
ExcludePaymentTab
ExcludeShippingTab
ExcludeSubscriptionsTab
ProductCategoryFilters
ProductFilterType

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EmployeeOrderPermissions Class | Aptify.Applications.OrderEntry Namespace


EmployeeOrderPermissions Constructor

public EmployeeOrderPermissions(
DataRow rowEmployeePermissions
);

See Also

EmployeeOrderPermissions Class | Aptify.Applications.OrderEntry Namespace


EmployeeOrderPermissions Properties

The properties of the EmployeeOrderPermissions class are listed below. For a complete list of EmployeeOrderPermissions class members, see the EmployeeOrderPermissions Members topic.

Public Instance Properties

AllowFree
AllowPriceOverride
AllowPriceSelection
AllowRelatedProductPromptClose
EmployeeID
ExcludeAccountingTab
ExcludePaymentTab
ExcludeShippingTab
ExcludeSubscriptionsTab
ProductCategoryFilters
ProductFilterType

See Also

EmployeeOrderPermissions Class | Aptify.Applications.OrderEntry Namespace


AllowFree Property

Aptify 5.0 Software Development Kit (SDK)

EmployeeOrderPermissions.AllowFree Property

public Boolean AllowFree {get;}

See Also

EmployeeOrderPermissions Class | Aptify.Applications.OrderEntry Namespace


AllowPriceOverride Property

Aptify 5.0 Software Development Kit (SDK)

EmployeeOrderPermissions.AllowPriceOverride Property

public Boolean AllowPriceOverride {get;}

See Also

EmployeeOrderPermissions Class | Aptify.Applications.OrderEntry Namespace


AllowPriceSelection Property

Aptify 5.0 Software Development Kit (SDK)

EmployeeOrderPermissions.AllowPriceSelection Property

public Boolean AllowPriceSelection {get;}

See Also

EmployeeOrderPermissions Class | Aptify.Applications.OrderEntry Namespace


AllowRelatedProductPromptClose Property

Aptify 5.0 Software Development Kit (SDK)

EmployeeOrderPermissions.AllowRelatedProductPromptClose Property

public Boolean AllowRelatedProductPromptClose {get;}

See Also

EmployeeOrderPermissions Class | Aptify.Applications.OrderEntry Namespace


EmployeeID Property

Aptify 5.0 Software Development Kit (SDK)

EmployeeOrderPermissions.EmployeeID Property

public Int64 EmployeeID {get;}

See Also

EmployeeOrderPermissions Class | Aptify.Applications.OrderEntry Namespace


ExcludeAccountingTab Property

Aptify 5.0 Software Development Kit (SDK)

EmployeeOrderPermissions.ExcludeAccountingTab Property

public Boolean ExcludeAccountingTab {get;}

See Also

EmployeeOrderPermissions Class | Aptify.Applications.OrderEntry Namespace


ExcludePaymentTab Property

Aptify 5.0 Software Development Kit (SDK)

EmployeeOrderPermissions.ExcludePaymentTab Property

public Boolean ExcludePaymentTab {get;}

See Also

EmployeeOrderPermissions Class | Aptify.Applications.OrderEntry Namespace


ExcludeShippingTab Property

Aptify 5.0 Software Development Kit (SDK)

EmployeeOrderPermissions.ExcludeShippingTab Property

public Boolean ExcludeShippingTab {get;}

See Also

EmployeeOrderPermissions Class | Aptify.Applications.OrderEntry Namespace


ExcludeSubscriptionsTab Property

Aptify 5.0 Software Development Kit (SDK)

EmployeeOrderPermissions.ExcludeSubscriptionsTab Property

public Boolean ExcludeSubscriptionsTab {get;}

See Also

EmployeeOrderPermissions Class | Aptify.Applications.OrderEntry Namespace


ProductCategoryFilters Property

Aptify 5.0 Software Development Kit (SDK)

EmployeeOrderPermissions.ProductCategoryFilters Property

public List<T> ProductCategoryFilters {get;}

See Also

EmployeeOrderPermissions Class | Aptify.Applications.OrderEntry Namespace


ProductFilterType Property

Aptify 5.0 Software Development Kit (SDK)

EmployeeOrderPermissions.ProductFilterType Property

public EmployeeOrderPermissions.ProductFilterTypes ProductFilterType {get;}

See Also

EmployeeOrderPermissions Class | Aptify.Applications.OrderEntry Namespace


EmployeeOrderPermissions.ProductCategoryFilter Structure

For a list of all members of this type, see EmployeeOrderPermissions.ProductCategoryFilter Members.

System.Object
ValueType
EmployeeOrderPermissions.ProductCategoryFilter

public struct EmployeeOrderPermissions.ProductCategoryFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

EmployeeOrderPermissions.ProductCategoryFilter Members | Aptify.Applications.OrderEntry Namespace


EmployeeOrderPermissions.ProductCategoryFilter Members

EmployeeOrderPermissions.ProductCategoryFilter overview

Public Instance Constructors

EmployeeOrderPermissions.ProductCategoryFilter Constructor

Public Instance Fields

IncludeSubCategory
ProductCategoryID

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

EmployeeOrderPermissions.ProductCategoryFilter Structure | Aptify.Applications.OrderEntry Namespace


EmployeeOrderPermissions.ProductCategoryFilter Constructor

public EmployeeOrderPermissions.ProductCategoryFilter(
Int64 lProdCategoryID,
Boolean bIncludeSubCategory
);

See Also

EmployeeOrderPermissions.ProductCategoryFilter Structure | Aptify.Applications.OrderEntry Namespace


EmployeeOrderPermissions.ProductCategoryFilter Fields

The fields of the EmployeeOrderPermissions.ProductCategoryFilter structure are listed below. For a complete list of EmployeeOrderPermissions.ProductCategoryFilter structure members, see the EmployeeOrderPermissions.ProductCategoryFilter Members topic.

Public Instance Fields

IncludeSubCategory
ProductCategoryID

See Also

EmployeeOrderPermissions.ProductCategoryFilter Structure | Aptify.Applications.OrderEntry Namespace


EmployeeOrderPermissions.ProductCategoryFilter.IncludeSubCategory Field

public IncludeSubCategory IncludeSubCategory;

See Also

EmployeeOrderPermissions.ProductCategoryFilter Class | Aptify.Applications.OrderEntry Namespace


EmployeeOrderPermissions.ProductCategoryFilter.ProductCategoryID Field

public ProductCategoryID ProductCategoryID;

See Also

EmployeeOrderPermissions.ProductCategoryFilter Class | Aptify.Applications.OrderEntry Namespace


EmployeeOrderPermissions.ProductFilterTypes Enumeration

public enum EmployeeOrderPermissions.ProductFilterTypes

Members

Member Name | Description
None |
Inclusive |
Exclusive |

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

Aptify.Applications.OrderEntry Namespace


ExpandKits Class

This object implements the Aptify.Framework.Applications.OrderEntry.IExpandKits interface. The purpose of this component is to handle the base use cases for expanding kits. This class is designed to be sub-classed as needed for configuration requirements.

For a list of all members of this type, see ExpandKits Members.

System.Object
ExpandKits

public class ExpandKits : IExpandKits

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: ExpandKits (in ExpandKits.dll)

See Also

ExpandKits Members | Aptify.Applications.OrderEntry Namespace


ExpandKits Members

ExpandKits overview

Public Instance Constructors

ExpandKits Constructor Initializes a new instance of the ExpandKits class.

Public Instance Methods

Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ExpandCancellationKitItem |
ExpandKitItem |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateKitComponentQuantities | This method is responsible for updating all of the components of the specified order detail kit line item and ensuring that the quantities are updated within each component item based on the definition of the kit in the Products entity.

Protected Instance Properties

Application | Returns an instance of the Aptify Application object
DataAction | Returns an instance of the Data Action class
Database | Returns the name of the database where the Orders entity is stored

Protected Instance Methods

AddCancellationComponentLine | This method is called from the ExpandCancellationKitItem() method for each component item within a given kit. The method is responsible for adding the component item to the order with the kit line item as the parent.
AddComponentLine | This method is called from the ExpandKitItem() method for each component item within a given kit. The method is responsible for adding the component item to the order with the kit line item as the parent.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExpandKits Class | Aptify.Applications.OrderEntry Namespace


ExpandKits Constructor

Initializes a new instance of the ExpandKits class.

public ExpandKits();

See Also

ExpandKits Class | Aptify.Applications.OrderEntry Namespace


ExpandKits Properties

The properties of the ExpandKits class are listed below. For a complete list of ExpandKits class members, see the ExpandKits Members topic.

Protected Instance Properties

Application | Returns an instance of the Aptify Application object
DataAction | Returns an instance of the Data Action class
Database | Returns the name of the database where the Orders entity is stored

See Also

ExpandKits Class | Aptify.Applications.OrderEntry Namespace


Application Property

Aptify 5.0 Software Development Kit (SDK)

ExpandKits.Application Property

Returns an instance of the Aptify Application object

protected virtual AptifyApplication Application {get;}

Property Value

Remarks

See Also

ExpandKits Class | Aptify.Applications.OrderEntry Namespace


DataAction Property

Aptify 5.0 Software Development Kit (SDK)

ExpandKits.DataAction Property

Returns an instance of the Data Action class

protected virtual DataAction DataAction {get;}

Property Value

Remarks

See Also

ExpandKits Class | Aptify.Applications.OrderEntry Namespace


Database Property

Aptify 5.0 Software Development Kit (SDK)

ExpandKits.Database Property

Returns the name of the database where the Orders entity is stored

protected virtual String Database {get;}

Property Value

Remarks

See Also

ExpandKits Class | Aptify.Applications.OrderEntry Namespace


ExpandKits Methods

The methods of the ExpandKits class are listed below. For a complete list of ExpandKits class members, see the ExpandKits Members topic.

Public Instance Methods

Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ExpandCancellationKitItem |
ExpandKitItem |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateKitComponentQuantities | This method is responsible for updating all of the components of the specified order detail kit line item and ensuring that the quantities are updated within each component item based on the definition of the kit in the Products entity.

Protected Instance Methods

AddCancellationComponentLine | This method is called from the ExpandCancellationKitItem() method for each component item within a given kit. The method is responsible for adding the component item to the order with the kit line item as the parent.
AddComponentLine | This method is called from the ExpandKitItem() method for each component item within a given kit. The method is responsible for adding the component item to the order with the kit line item as the parent.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExpandKits Class | Aptify.Applications.OrderEntry Namespace


ExpandKits.AddCancellationComponentLine Method

This method is called from the ExpandCancellationKitItem() method for each component item within a given kit. The method is responsible for adding the component item to the order with the kit line item as the parent.

protected virtual OrderLinesEntity AddCancellationComponentLine(
OrdersEntity OrderGE,
Int32 ParentSequence,
Int64 OriginalOrderDetailID,
Int64 ProductID,
String Name,
String Description,
Decimal Quantity,
Decimal PartQuantity
);

Parameters

OrderGE
ParentSequence
OriginalOrderDetailID
ProductID
Name
Description
Quantity
PartQuantity

Return Value

Remarks

See Also

ExpandKits Class | Aptify.Applications.OrderEntry Namespace


ExpandKits.AddComponentLine Method

This method is called from the ExpandKitItem() method for each component item within a given kit. The method is responsible for adding the component item to the order with the kit line item as the parent.

protected virtual OrderLinesEntity AddComponentLine(
OrdersEntity OrderGE,
Int32 ParentSequence,
Int64 ProductID,
String Name,
String Description,
Decimal Quantity,
Decimal PartQuantity
);

Parameters

OrderGE
ParentSequence
ProductID
Name
Description
Quantity
PartQuantity

Return Value

Remarks

See Also

ExpandKits Class | Aptify.Applications.OrderEntry Namespace


ExpandKits.Config Method

public virtual void Config(
AptifyApplication Application
);

Implements

IExpandKits.

See Also

ExpandKits Class | Aptify.Applications.OrderEntry Namespace


ExpandKits.ExpandCancellationKitItem Method

public virtual bool ExpandCancellationKitItem(
OrderLinesEntity OrderDetailGE,
ref List`1& newOrderLines
);

Implements

IExpandKits.

See Also

ExpandKits Class | Aptify.Applications.OrderEntry Namespace


ExpandKits.ExpandKitItem Method

public virtual bool ExpandKitItem(
OrderLinesEntity OrderDetailGE,
ref List`1& newOrderLines
);

Implements

IExpandKits.

See Also

ExpandKits Class | Aptify.Applications.OrderEntry Namespace


ExpandKits.UpdateKitComponentQuantities Method

This method is responsible for updating all of the components of the specified order detail kit line item and ensuring that the quantities are updated within each component item based on the definition of the kit in the Products entity.

public virtual bool UpdateKitComponentQuantities(
OrderLinesEntity OrderDetailGE
);

Parameters

OrderDetailGE

Return Value

Implements

IExpandKits.

Remarks

See Also

ExpandKits Class | Aptify.Applications.OrderEntry Namespace


ExtendedOrderDetailGE Class

Extended Order Detail Entities require special handling during the Order Save process to ensure that the proper links are created and maintained. The ExtendedOrderDetailGE class provides that special handling. All Extended Order Detail entities must use this object as the Entity Object.

For a list of all members of this type, see ExtendedOrderDetailGE Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
ExtendedOrderDetailGE
ClassRegistrationGE
HousingReservation
HousingReservationGuest
OrderBoothDetailEntity
OrderMeetingDetailEntity

public class ExtendedOrderDetailGE : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

ExtendedOrderDetailGE Members | Aptify.Applications.OrderEntry Namespace


ExtendedOrderDetailGE Members

ExtendedOrderDetailGE overview

Public Instance Constructors

ExtendedOrderDetailGE Constructor Initializes a new instance of the ExtendedOrderDetailGE class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
OrderLineGE | The OrderLineGE causes the ExtendedOrderDetailGE object to be created and then passes it a reference to itself. This reference provides access to the Order Line information through the OrderLines Entity object, the Order information.
ParentGE |
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel |
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
FlowdownForAddCancellationOrderLine | Called by the OrdersEntity's AddCancellationOrderLine method. It is designed to be overridden when the extended Order Detail Entity needs to use information from the Order Line or Order to set values or perform other logic when a Cancellation Order Line is added to an Order. Overrides of this method should return true if the Cancellation Order Line should be added to the Order. A return value of false will abort the Add Cancellation Order Line process. The core implementation returns True with no other functionality.
FlowdownForAddProductToOrder | Called by the OrdersEntity's AddProduct method. It is designed to be overridden when the extended Order Detail Entity needs to use information from the Order Line or Order to set values or perform other logic when a Product is added to an Order. Overrides of this method should return true if the Product should be added to the Order. A return value of false will abort the Add Product to Order process. The core implementation returns True with no other functionality.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load | Overloaded.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord |
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveCancellationData | Called during the Order Save process in the OrdersEntity's SaveCancellationData method. It is designed to be overridden when the extended Order Detail Entity needs to perform some work related to the cancellation of the Order Line. Return True, if the SaveCancellationData method is successful and the Order Save should contain. Return False, if the Order Save process should be aborted. When returning False, use the Error Log and/or the SetLastUeer/SetLastUser error methods to return useful information about the failure. The core implementation returns True with no other functionality.
SaveCancelledData | Called during the Order Save process in the OrdersEntity's SaveCancellationData method. It is designed to be overridden when the extended Order Detail Entity needs to perform some work related to the the Order Line when the Order status has been changed to Cancelled. This is called to preform special handling on the orderline, if there is a need to changed information after the order status has been changed to cancelled. This allows, for example, the removal of a customer from a meeting detail record.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetExtendedOrderDetailRecordID |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
ResetFieldsLinkedToOrderLine |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

ExtendedOrderDetailGE Class | Aptify.Applications.OrderEntry Namespace


ExtendedOrderDetailGE Constructor

Initializes a new instance of the ExtendedOrderDetailGE class.

public ExtendedOrderDetailGE();

See Also

ExtendedOrderDetailGE Class | Aptify.Applications.OrderEntry Namespace


ExtendedOrderDetailGE Properties

The properties of the ExtendedOrderDetailGE class are listed below. For a complete list of ExtendedOrderDetailGE class members, see the ExtendedOrderDetailGE Members topic.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
OrderLineGE | The OrderLineGE causes the ExtendedOrderDetailGE object to be created and then passes it a reference to itself. This reference provides access to the Order Line information through the OrderLines Entity object, the Order information.
ParentGE |
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel |
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

ExtendedOrderDetailGE Class | Aptify.Applications.OrderEntry Namespace


OrderLineGE Property

Aptify 5.0 Software Development Kit (SDK)

ExtendedOrderDetailGE.OrderLineGE Property

The OrderLineGE causes the ExtendedOrderDetailGE object to be created and then passes it a reference to itself. This reference provides access to the Order Line information through the OrderLines Entity object, the Order information.

public virtual OrderLinesEntity OrderLineGE {get; set;}

Property Value

Remarks

See Also

ExtendedOrderDetailGE Class | Aptify.Applications.OrderEntry Namespace


ParentGE Property

Aptify 5.0 Software Development Kit (SDK)

ExtendedOrderDetailGE.ParentGE Property

public override AptifyGenericEntityBase ParentGE {get;}

See Also

ExtendedOrderDetailGE Class | Aptify.Applications.OrderEntry Namespace


SubTypeLevel Property

Aptify 5.0 Software Development Kit (SDK)

ExtendedOrderDetailGE.SubTypeLevel Property

public override Byte SubTypeLevel {get;}

See Also

ExtendedOrderDetailGE Class | Aptify.Applications.OrderEntry Namespace


ExtendedOrderDetailGE Methods

The methods of the ExtendedOrderDetailGE class are listed below. For a complete list of ExtendedOrderDetailGE class members, see the ExtendedOrderDetailGE Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
FlowdownForAddCancellationOrderLine | Called by the OrdersEntity's AddCancellationOrderLine method. It is designed to be overridden when the extended Order Detail Entity needs to use information from the Order Line or Order to set values or perform other logic when a Cancellation Order Line is added to an Order. Overrides of this method should return true if the Cancellation Order Line should be added to the Order. A return value of false will abort the Add Cancellation Order Line process. The core implementation returns True with no other functionality.
FlowdownForAddProductToOrder | Called by the OrdersEntity's AddProduct method. It is designed to be overridden when the extended Order Detail Entity needs to use information from the Order Line or Order to set values or perform other logic when a Product is added to an Order. Overrides of this method should return true if the Product should be added to the Order. A return value of false will abort the Add Product to Order process. The core implementation returns True with no other functionality.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load | Overloaded.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord |
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveCancellationData | Called during the Order Save process in the OrdersEntity's SaveCancellationData method. It is designed to be overridden when the extended Order Detail Entity needs to perform some work related to the cancellation of the Order Line. Return True, if the SaveCancellationData method is successful and the Order Save should contain. Return False, if the Order Save process should be aborted. When returning False, use the Error Log and/or the SetLastUeer/SetLastUser error methods to return useful information about the failure. The core implementation returns True with no other functionality.
SaveCancelledData | Called during the Order Save process in the OrdersEntity's SaveCancellationData method. It is designed to be overridden when the extended Order Detail Entity needs to perform some work related to the the Order Line when the Order status has been changed to Cancelled. This is called to preform special handling on the orderline, if there is a need to changed information after the order status has been changed to cancelled. This allows, for example, the removal of a customer from a meeting detail record.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetExtendedOrderDetailRecordID |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
ResetFieldsLinkedToOrderLine |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

ExtendedOrderDetailGE Class | Aptify.Applications.OrderEntry Namespace


ExtendedOrderDetailGE.FlowdownForAddCancellationOrderLine Method

Called by the OrdersEntity's AddCancellationOrderLine method. It is designed to be overridden when the extended Order Detail Entity needs to use information from the Order Line or Order to set values or perform other logic when a Cancellation Order Line is added to an Order. Overrides of this method should return true if the Cancellation Order Line should be added to the Order. A return value of false will abort the Add Cancellation Order Line process. The core implementation returns True with no other functionality.

public virtual bool FlowdownForAddCancellationOrderLine();

Return Value

Returns True in all cases.

Remarks

See Also

ExtendedOrderDetailGE Class | Aptify.Applications.OrderEntry Namespace


ExtendedOrderDetailGE.FlowdownForAddProductToOrder Method

Called by the OrdersEntity's AddProduct method. It is designed to be overridden when the extended Order Detail Entity needs to use information from the Order Line or Order to set values or perform other logic when a Product is added to an Order. Overrides of this method should return true if the Product should be added to the Order. A return value of false will abort the Add Product to Order process. The core implementation returns True with no other functionality.

public virtual bool FlowdownForAddProductToOrder();

Return Value

Returns True in all cases.

Remarks

See Also

ExtendedOrderDetailGE Class | Aptify.Applications.OrderEntry Namespace


Load Method

Aptify 5.0 Software Development Kit (SDK)

ExtendedOrderDetailGE.Load Method

Overload List

public override void Load(DataRow);

public override void Load(IDataReader);

public override void Load(Int64);

Inherited from AptifyGenericEntityBase.

public virtual void Load(String);

public override void Load(String,Boolean);

See Also

ExtendedOrderDetailGE Class | Aptify.Applications.OrderEntry Namespace


ExtendedOrderDetailGE.Load Method (DataRow)

public override void Load(
DataRow DataRow
);

See Also

ExtendedOrderDetailGE Class | Aptify.Applications.OrderEntry Namespace | ExtendedOrderDetailGE.Load Overload List


ExtendedOrderDetailGE.Load Method (IDataReader)

public override void Load(
IDataReader DataReader
);

See Also

ExtendedOrderDetailGE Class | Aptify.Applications.OrderEntry Namespace | ExtendedOrderDetailGE.Load Overload List


ExtendedOrderDetailGE.Load Method (Int64)

public override void Load(
Int64 ID
);

See Also

ExtendedOrderDetailGE Class | Aptify.Applications.OrderEntry Namespace | ExtendedOrderDetailGE.Load Overload List


ExtendedOrderDetailGE.Load Method (String, Boolean)

public override void Load(
String FileName,
Boolean MergeSubTypes
);

See Also

ExtendedOrderDetailGE Class | Aptify.Applications.OrderEntry Namespace | ExtendedOrderDetailGE.Load Overload List


ExtendedOrderDetailGE.NewRecord Method

public override bool NewRecord();

See Also

ExtendedOrderDetailGE Class | Aptify.Applications.OrderEntry Namespace


ExtendedOrderDetailGE.ResetFieldsLinkedToOrderLine Method

protected virtual void ResetFieldsLinkedToOrderLine(
OrderLinesEntity OrderLineGE
);

See Also

ExtendedOrderDetailGE Class | Aptify.Applications.OrderEntry Namespace


Save Method

Aptify 5.0 Software Development Kit (SDK)

ExtendedOrderDetailGE.Save Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Save();

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean,ref String&);

public override bool Save(Boolean,ref String&,String);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(ref String&);

See Also

ExtendedOrderDetailGE Class | Aptify.Applications.OrderEntry Namespace


ExtendedOrderDetailGE.Save Method (Boolean, String&, String)

public override bool Save(
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

See Also

ExtendedOrderDetailGE Class | Aptify.Applications.OrderEntry Namespace | ExtendedOrderDetailGE.Save Overload List


ExtendedOrderDetailGE.SaveCancellationData Method

Called during the Order Save process in the OrdersEntity's SaveCancellationData method. It is designed to be overridden when the extended Order Detail Entity needs to perform some work related to the cancellation of the Order Line. Return True, if the SaveCancellationData method is successful and the Order Save should contain. Return False, if the Order Save process should be aborted. When returning False, use the Error Log and/or the SetLastUeer/SetLastUser error methods to return useful information about the failure. The core implementation returns True with no other functionality.

public virtual bool SaveCancellationData(
Boolean AllowGUI
);

Parameters

AllowGUI

Return Value

Returns True is all cases.

Remarks

See Also

ExtendedOrderDetailGE Class | Aptify.Applications.OrderEntry Namespace


ExtendedOrderDetailGE.SaveCancelledData Method

Called during the Order Save process in the OrdersEntity's SaveCancellationData method. It is designed to be overridden when the extended Order Detail Entity needs to perform some work related to the the Order Line when the Order status has been changed to Cancelled. This is called to preform special handling on the orderline, if there is a need to changed information after the order status has been changed to cancelled. This allows, for example, the removal of a customer from a meeting detail record.

public virtual bool SaveCancelledData(
Boolean AllowGUI
);

Parameters

AllowGUI

Return Value

Returns True is all cases.

Remarks

See Also

ExtendedOrderDetailGE Class | Aptify.Applications.OrderEntry Namespace


ExtendedOrderDetailGE.SetExtendedOrderDetailRecordID Method

public virtual void SetExtendedOrderDetailRecordID(
Int64 RecordID
);

See Also

ExtendedOrderDetailGE Class | Aptify.Applications.OrderEntry Namespace


GenerateCOGS Class

This object implements the Aptify.Framework.Applications.OrderEntry.IGenerateCOGS interface The purpose of this component is to generate Cost of Goods Sold GL entries for the order when requested by the Order entry system.

For a list of all members of this type, see GenerateCOGS Members.

System.Object
GenerateCOGS

public class GenerateCOGS : IGenerateCOGS

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: GenerateCOGS (in GenerateCOGS.dll)

See Also

GenerateCOGS Members | Aptify.Applications.OrderEntry Namespace


GenerateCOGS Members

GenerateCOGS overview

Public Instance Constructors

GenerateCOGS Constructor Initializes a new instance of the GenerateCOGS class.

Public Instance Methods

Config | This method configures the object for use and must be called before any other member of the class is accessed. This method stores the Application object provided for use internally.
CreateInventoryEntries | This method is responsible for generating the appropriate Cost of Goods Sold (COGS) GL entries for a given order. It is assumed by this method that the Order Entry system is only calling this method once per order and that this method is NOT responsible for determining if COGS entries are already in the OrderGLEntry sub-type. That is, the Order will be responsible for clearing out old GL entries as needed before calling this method for each order that requires COGS GL Entry calculation.
CreatePass2SQL |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

Application | Returns the Aptify Application object instance
CostEntries | Returns the internally used collection of CostEntry records
DataAction | Returns an Aptify DataAction object instance
Database | Returns the name of the database that the Order Entry system resides in
FunctionalCurrencyID | Returns the functional Decimal in place - this property is available after Config() is called. In a system that has defined multiple functional currencies, this property is obsolete.
UsedLedgerIDCollection | Returns the collection of Ledger IDs that have been used in the COGS process

Protected Instance Methods

AddGLEntry | This method is called from various places in the class to add line items to the OrderGLEntry sub-type.
CreateCancellationProductCOGSEntries | This method is responsible for creating cancellation COGS entries for a single order line. Rather than allocating inventory from a PILE, we need to return inventory to a PILE that was previously depleted in the original order. This will involve running a query against the OrderInvAllocation where the OrderID = OriginalOrderID.
CreateProductCOGSEntries | This method is responsible for creating Cost Of Goods Sold entries for the product that is in the specified order line of the order.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetFulfillmentQuantityOnHand | This method is responsible for determining the quantity available for a product for all inventory locations that allow direct fulfillment. This function does not take into account inventory locations that do not allow direct fulfillment.
GetOriginalOrderShipDate | This method is responsible for returning the original ship date for a given Order. This method uses caching since it will only be called for orders that are shipped and once an order is shipped, the Ship Date will not change so it is safe to cache and improve performance this way.
GetProductCostPerUnit | This method is responsible for determining the product cost per unit to use for the given order line.
GetProductHistoricalAvgCost | This method is responsible for calculating a product's historical average cost that prevailed on or before the EffectiveDate parameter provided to the function.
GetProductHistoricalAvgCostWithCurrency | This method is responsible for calculating a product's historical average cost that prevailed on or before the EffectiveDate parameter provided to the function.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RegenerateCOGS |
TranslateToOrderCurrency | This method is responsible for translating a nominal amount in one Decimal to units of the order's Decimal at the latest exchange rate. This function is called from a number of areas in the COGS component.

See Also

GenerateCOGS Class | Aptify.Applications.OrderEntry Namespace


GenerateCOGS Constructor

Initializes a new instance of the GenerateCOGS class.

public GenerateCOGS();

See Also

GenerateCOGS Class | Aptify.Applications.OrderEntry Namespace


GenerateCOGS Properties

The properties of the GenerateCOGS class are listed below. For a complete list of GenerateCOGS class members, see the GenerateCOGS Members topic.

Protected Instance Properties

Application | Returns the Aptify Application object instance
CostEntries | Returns the internally used collection of CostEntry records
DataAction | Returns an Aptify DataAction object instance
Database | Returns the name of the database that the Order Entry system resides in
FunctionalCurrencyID | Returns the functional Decimal in place - this property is available after Config() is called. In a system that has defined multiple functional currencies, this property is obsolete.
UsedLedgerIDCollection | Returns the collection of Ledger IDs that have been used in the COGS process

See Also

GenerateCOGS Class | Aptify.Applications.OrderEntry Namespace


Application Property

Aptify 5.0 Software Development Kit (SDK)

GenerateCOGS.Application Property

Returns the Aptify Application object instance

protected AptifyApplication Application {get;}

Property Value

Remarks

See Also

GenerateCOGS Class | Aptify.Applications.OrderEntry Namespace


CostEntries Property

Aptify 5.0 Software Development Kit (SDK)

GenerateCOGS.CostEntries Property

Returns the internally used collection of CostEntry records

protected List<T> CostEntries {get;}

Property Value

Remarks

See Also

GenerateCOGS Class | Aptify.Applications.OrderEntry Namespace


DataAction Property

Aptify 5.0 Software Development Kit (SDK)

GenerateCOGS.DataAction Property

Returns an Aptify DataAction object instance

protected DataAction DataAction {get;}

Property Value

Remarks

See Also

GenerateCOGS Class | Aptify.Applications.OrderEntry Namespace


Database Property

Aptify 5.0 Software Development Kit (SDK)

GenerateCOGS.Database Property

Returns the name of the database that the Order Entry system resides in

protected String Database {get;}

Property Value

Remarks

See Also

GenerateCOGS Class | Aptify.Applications.OrderEntry Namespace


FunctionalCurrencyID Property

Aptify 5.0 Software Development Kit (SDK)

GenerateCOGS.FunctionalCurrencyID Property

Returns the functional Decimal in place - this property is available after Config() is called. In a system that has defined multiple functional currencies, this property is obsolete.

protected Int64 FunctionalCurrencyID {get;}

Property Value

Remarks

See Also

GenerateCOGS Class | Aptify.Applications.OrderEntry Namespace


UsedLedgerIDCollection Property

Aptify 5.0 Software Development Kit (SDK)

GenerateCOGS.UsedLedgerIDCollection Property

Returns the collection of Ledger IDs that have been used in the COGS process

protected List<T> UsedLedgerIDCollection {get;}

Property Value

Remarks

See Also

GenerateCOGS Class | Aptify.Applications.OrderEntry Namespace


GenerateCOGS Methods

The methods of the GenerateCOGS class are listed below. For a complete list of GenerateCOGS class members, see the GenerateCOGS Members topic.

Public Instance Methods

Config | This method configures the object for use and must be called before any other member of the class is accessed. This method stores the Application object provided for use internally.
CreateInventoryEntries | This method is responsible for generating the appropriate Cost of Goods Sold (COGS) GL entries for a given order. It is assumed by this method that the Order Entry system is only calling this method once per order and that this method is NOT responsible for determining if COGS entries are already in the OrderGLEntry sub-type. That is, the Order will be responsible for clearing out old GL entries as needed before calling this method for each order that requires COGS GL Entry calculation.
CreatePass2SQL |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

AddGLEntry | This method is called from various places in the class to add line items to the OrderGLEntry sub-type.
CreateCancellationProductCOGSEntries | This method is responsible for creating cancellation COGS entries for a single order line. Rather than allocating inventory from a PILE, we need to return inventory to a PILE that was previously depleted in the original order. This will involve running a query against the OrderInvAllocation where the OrderID = OriginalOrderID.
CreateProductCOGSEntries | This method is responsible for creating Cost Of Goods Sold entries for the product that is in the specified order line of the order.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetFulfillmentQuantityOnHand | This method is responsible for determining the quantity available for a product for all inventory locations that allow direct fulfillment. This function does not take into account inventory locations that do not allow direct fulfillment.
GetOriginalOrderShipDate | This method is responsible for returning the original ship date for a given Order. This method uses caching since it will only be called for orders that are shipped and once an order is shipped, the Ship Date will not change so it is safe to cache and improve performance this way.
GetProductCostPerUnit | This method is responsible for determining the product cost per unit to use for the given order line.
GetProductHistoricalAvgCost | This method is responsible for calculating a product's historical average cost that prevailed on or before the EffectiveDate parameter provided to the function.
GetProductHistoricalAvgCostWithCurrency | This method is responsible for calculating a product's historical average cost that prevailed on or before the EffectiveDate parameter provided to the function.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RegenerateCOGS |
TranslateToOrderCurrency | This method is responsible for translating a nominal amount in one Decimal to units of the order's Decimal at the latest exchange rate. This function is called from a number of areas in the COGS component.

See Also

GenerateCOGS Class | Aptify.Applications.OrderEntry Namespace


GenerateCOGS.AddGLEntry Method

This method is called from various places in the class to add line items to the OrderGLEntry sub-type.

protected virtual void AddGLEntry(
AptifyGenericEntityBase OrderGE,
String Account,
Decimal Debit,
Decimal Credit,
String Description
);

Parameters

OrderGE
Account
Debit
Credit
Description

Remarks

See Also

GenerateCOGS Class | Aptify.Applications.OrderEntry Namespace


GenerateCOGS.Config Method

This method configures the object for use and must be called before any other member of the class is accessed. This method stores the Application object provided for use internally.

public virtual void Config(
AptifyApplication Application
);

Parameters

Application

Implements

IGenerateCOGS.

Remarks

See Also

GenerateCOGS Class | Aptify.Applications.OrderEntry Namespace


GenerateCOGS.CreateCancellationProductCOGSEntries Method

This method is responsible for creating cancellation COGS entries for a single order line. Rather than allocating inventory from a PILE, we need to return inventory to a PILE that was previously depleted in the original order. This will involve running a query against the OrderInvAllocation where the OrderID = OriginalOrderID.

protected virtual void CreateCancellationProductCOGSEntries(
OrderLinesEntity OrderLineGE,
Int64 OrderLine,
Int64 OrderLevelID
);

Parameters

OrderLineGE
OrderLine
OrderLevelID

Remarks

See Also

GenerateCOGS Class | Aptify.Applications.OrderEntry Namespace


GenerateCOGS.CreateInventoryEntries Method

This method is responsible for generating the appropriate Cost of Goods Sold (COGS) GL entries for a given order. It is assumed by this method that the Order Entry system is only calling this method once per order and that this method is NOT responsible for determining if COGS entries are already in the OrderGLEntry sub-type. That is, the Order will be responsible for clearing out old GL entries as needed before calling this method for each order that requires COGS GL Entry calculation.

public virtual bool CreateInventoryEntries(
OrdersEntity OrderGE
);

Parameters

OrderGE
The Order to generate COGS entries for

Return Value

True if the method is succesful, False otherwise

Implements

IGenerateCOGS.

Remarks

See Also

GenerateCOGS Class | Aptify.Applications.OrderEntry Namespace


GenerateCOGS.CreatePass2SQL Method

public string CreatePass2SQL(
ProductData.ProductCostMethod Method,
Int64 ProductID,
DateTime dDate
);

See Also

GenerateCOGS Class | Aptify.Applications.OrderEntry Namespace


GenerateCOGS.CreateProductCOGSEntries Method

This method is responsible for creating Cost Of Goods Sold entries for the product that is in the specified order line of the order.

protected virtual void CreateProductCOGSEntries(
OrderLinesEntity OrderLineGE,
Int64 OrderLine,
Int64 OrderLevelID
);

Parameters

OrderLineGE
OrderLine
OrderLevelID

Remarks

See Also

GenerateCOGS Class | Aptify.Applications.OrderEntry Namespace


GenerateCOGS.GetFulfillmentQuantityOnHand Method

This method is responsible for determining the quantity available for a product for all inventory locations that allow direct fulfillment. This function does not take into account inventory locations that do not allow direct fulfillment.

protected virtual decimal GetFulfillmentQuantityOnHand(
Int64 ProductID
);

Parameters

ProductID

Return Value

Remarks

See Also

GenerateCOGS Class | Aptify.Applications.OrderEntry Namespace


GenerateCOGS.GetOriginalOrderShipDate Method

This method is responsible for returning the original ship date for a given Order. This method uses caching since it will only be called for orders that are shipped and once an order is shipped, the Ship Date will not change so it is safe to cache and improve performance this way.

protected virtual DateTime GetOriginalOrderShipDate(
Int64 OrderID
);

Parameters

OrderID

Return Value

Remarks

See Also

GenerateCOGS Class | Aptify.Applications.OrderEntry Namespace


GenerateCOGS.GetProductCostPerUnit Method

This method is responsible for determining the product cost per unit to use for the given order line.

protected virtual void GetProductCostPerUnit(
OrderLinesEntity OrderLineGE
);

Parameters

OrderLineGE

Remarks

See Also

GenerateCOGS Class | Aptify.Applications.OrderEntry Namespace


GenerateCOGS.GetProductHistoricalAvgCost Method

This method is responsible for calculating a product's historical average cost that prevailed on or before the EffectiveDate parameter provided to the function.

protected virtual decimal GetProductHistoricalAvgCost(
Int64 ProductID,
DateTime EffectiveDate
);

Parameters

ProductID
EffectiveDate

Return Value

Remarks

See Also

GenerateCOGS Class | Aptify.Applications.OrderEntry Namespace


GenerateCOGS.GetProductHistoricalAvgCostWithCurrency Method

This method is responsible for calculating a product's historical average cost that prevailed on or before the EffectiveDate parameter provided to the function.

protected virtual Currency GetProductHistoricalAvgCostWithCurrency(
Int64 ProductID,
DateTime EffectiveDate
);

Parameters

ProductID
EffectiveDate

Return Value

Remarks

See Also

GenerateCOGS Class | Aptify.Applications.OrderEntry Namespace


GenerateCOGS.RegenerateCOGS Method

protected virtual void RegenerateCOGS(
OrderLinesEntity OrderLineGE,
Int64 OrderLine,
Int64 OrderLevelID
);

See Also

GenerateCOGS Class | Aptify.Applications.OrderEntry Namespace


GenerateCOGS.TranslateToOrderCurrency Method

This method is responsible for translating a nominal amount in one Decimal to units of the order's Decimal at the latest exchange rate. This function is called from a number of areas in the COGS component.

protected virtual void TranslateToOrderCurrency(
OrdersEntity OrderGE,
Decimal NominalAmount,
Int64 NominalCurrencyTypeID,
Int64 OrderCurrencyTypeID,
String Message,
ref Decimal& AdjustedAmount
);

Parameters

OrderGE
NominalAmount
Decimal in units of lNominalCurrencyTypeID
NominalCurrencyTypeID
OrderCurrencyTypeID
Message
User Message if the method returns False
AdjustedAmount
OUT Parameter: Decimal in units of the order's Decimal type

Remarks

See Also

GenerateCOGS Class | Aptify.Applications.OrderEntry Namespace


GenerateCOGS.CostEntry Class

This class is used within the CalculateCOGS Class to keep track of entries being created

For a list of all members of this type, see GenerateCOGS.CostEntry Members.

System.Object
GenerateCOGS.CostEntry

protected class GenerateCOGS.CostEntry

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: GenerateCOGS (in GenerateCOGS.dll)

See Also

GenerateCOGS.CostEntry Members | Aptify.Applications.OrderEntry Namespace


GenerateCOGS.CostEntry Members

GenerateCOGS.CostEntry overview

Public Instance Constructors

GenerateCOGS.CostEntry Constructor Initializes a new instance of the GenerateCOGS.CostEntry class.

Public Instance Fields

CurrencyFormat
CurrencyTradingSymbol
CurrencyTypeID
LedgerEntryID
ProductID
QuantityShipped
UnitCost

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GenerateCOGS.CostEntry Class | Aptify.Applications.OrderEntry Namespace


GenerateCOGS.CostEntry Constructor

Initializes a new instance of the GenerateCOGS.CostEntry class.

public GenerateCOGS.CostEntry();

See Also

GenerateCOGS.CostEntry Class | Aptify.Applications.OrderEntry Namespace


GenerateCOGS.CostEntry Fields

The fields of the GenerateCOGS.CostEntry class are listed below. For a complete list of GenerateCOGS.CostEntry class members, see the GenerateCOGS.CostEntry Members topic.

Public Instance Fields

CurrencyFormat
CurrencyTradingSymbol
CurrencyTypeID
LedgerEntryID
ProductID
QuantityShipped
UnitCost

See Also

GenerateCOGS.CostEntry Class | Aptify.Applications.OrderEntry Namespace


GenerateCOGS.CostEntry.CurrencyFormat Field

public CurrencyFormat CurrencyFormat;

See Also

GenerateCOGS.CostEntry Class | Aptify.Applications.OrderEntry Namespace


GenerateCOGS.CostEntry.CurrencyTradingSymbol Field

public CurrencyTradingSymbol CurrencyTradingSymbol;

See Also

GenerateCOGS.CostEntry Class | Aptify.Applications.OrderEntry Namespace


GenerateCOGS.CostEntry.CurrencyTypeID Field

public CurrencyTypeID CurrencyTypeID;

See Also

GenerateCOGS.CostEntry Class | Aptify.Applications.OrderEntry Namespace


GenerateCOGS.CostEntry.LedgerEntryID Field

public LedgerEntryID LedgerEntryID;

See Also

GenerateCOGS.CostEntry Class | Aptify.Applications.OrderEntry Namespace


GenerateCOGS.CostEntry.ProductID Field

public ProductID ProductID;

See Also

GenerateCOGS.CostEntry Class | Aptify.Applications.OrderEntry Namespace


GenerateCOGS.CostEntry.QuantityShipped Field

public QuantityShipped QuantityShipped;

See Also

GenerateCOGS.CostEntry Class | Aptify.Applications.OrderEntry Namespace


GenerateCOGS.CostEntry.UnitCost Field

public UnitCost UnitCost;

See Also

GenerateCOGS.CostEntry Class | Aptify.Applications.OrderEntry Namespace


GenerateCOGS.Currency Structure

For a list of all members of this type, see GenerateCOGS.Currency Members.

System.Object
ValueType
GenerateCOGS.Currency

protected struct GenerateCOGS.Currency

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: GenerateCOGS (in GenerateCOGS.dll)

See Also

GenerateCOGS.Currency Members | Aptify.Applications.OrderEntry Namespace


GenerateCOGS.Currency Members

GenerateCOGS.Currency overview

Public Instance Fields

Amount
CurrencyTypeID

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

GenerateCOGS.Currency Structure | Aptify.Applications.OrderEntry Namespace


GenerateCOGS.Currency Fields

The fields of the GenerateCOGS.Currency structure are listed below. For a complete list of GenerateCOGS.Currency structure members, see the GenerateCOGS.Currency Members topic.

Public Instance Fields

Amount
CurrencyTypeID

See Also

GenerateCOGS.Currency Structure | Aptify.Applications.OrderEntry Namespace


GenerateCOGS.Currency.Amount Field

public Amount Amount;

See Also

GenerateCOGS.Currency Class | Aptify.Applications.OrderEntry Namespace


GenerateCOGS.Currency.CurrencyTypeID Field

public CurrencyTypeID CurrencyTypeID;

See Also

GenerateCOGS.Currency Class | Aptify.Applications.OrderEntry Namespace


GenerateStatus Class

For a list of all members of this type, see GenerateStatus Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
GenerateStatus

public class GenerateStatus : Form

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: BulkOrdersGE (in BulkOrdersGE.dll)

See Also

GenerateStatus Members | Aptify.Applications.OrderEntry Namespace


GenerateStatus Members

GenerateStatus overview

Public Instance Constructors

GenerateStatus Constructor Initializes a new instance of the GenerateStatus class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

GenerateStatus Class | Aptify.Applications.OrderEntry Namespace


GenerateStatus Constructor

Initializes a new instance of the GenerateStatus class.

public GenerateStatus();

See Also

GenerateStatus Class | Aptify.Applications.OrderEntry Namespace


GenerateStatus Methods

The methods of the GenerateStatus class are listed below. For a complete list of GenerateStatus class members, see the GenerateStatus Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

GenerateStatus Class | Aptify.Applications.OrderEntry Namespace


GenerateStatus.Config Method

public void Config(
BulkOrdersGE GE
);

See Also

GenerateStatus Class | Aptify.Applications.OrderEntry Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

GenerateStatus.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

GenerateStatus Class | Aptify.Applications.OrderEntry Namespace


GenerateStatus.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

GenerateStatus Class | Aptify.Applications.OrderEntry Namespace | GenerateStatus.Dispose Overload List


Hyperlink Class

A class to be used to show Hyperlink in C1FlexGrid (OrderLines) and process the click on each of item(cell).

For a list of all members of this type, see Hyperlink Members.

System.Object
Hyperlink

public class Hyperlink

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrderLineControl (in AptifyOrderLineControl.dll)

See Also

Hyperlink Members | Aptify.Applications.OrderEntry Namespace


Hyperlink Members

Hyperlink overview

Public Instance Constructors

Hyperlink Constructor

Public Instance Properties

Visited Not yet used. But we can use to show whether the hyperlink is already visited or not.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ProcessClick | Process a click of the cell and show the product record form.
ToString | Not yet used. It returns the Text of a Hyperlink.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Hyperlink Class | Aptify.Applications.OrderEntry Namespace


Hyperlink Constructor

public Hyperlink(
String text,
Int64 productID,
AptifyApplication aptifyApplication
);

See Also

Hyperlink Class | Aptify.Applications.OrderEntry Namespace


Hyperlink Properties

The properties of the Hyperlink class are listed below. For a complete list of Hyperlink class members, see the Hyperlink Members topic.

Public Instance Properties

Visited Not yet used. But we can use to show whether the hyperlink is already visited or not.

See Also

Hyperlink Class | Aptify.Applications.OrderEntry Namespace


Visited Property

Aptify 5.0 Software Development Kit (SDK)

Hyperlink.Visited Property

Not yet used. But we can use to show whether the hyperlink is already visited or not.

public Boolean Visited {get;}

Property Value

Remarks

See Also

Hyperlink Class | Aptify.Applications.OrderEntry Namespace


Hyperlink Methods

The methods of the Hyperlink class are listed below. For a complete list of Hyperlink class members, see the Hyperlink Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ProcessClick | Process a click of the cell and show the product record form.
ToString | Not yet used. It returns the Text of a Hyperlink.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Hyperlink Class | Aptify.Applications.OrderEntry Namespace


Hyperlink.ProcessClick Method

Process a click of the cell and show the product record form.

public void ProcessClick();

Remarks

See Also

Hyperlink Class | Aptify.Applications.OrderEntry Namespace


Hyperlink.ToString Method

Not yet used. It returns the Text of a Hyperlink.

public override string ToString();

Return Value

Remarks

See Also

Hyperlink Class | Aptify.Applications.OrderEntry Namespace


IBackOrder Interface

For a list of all members of this type, see IBackOrder Members.

public interface IBackOrder

Types that implement IBackOrder

Type | Description
BackOrders |

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

IBackOrder Members | Aptify.Applications.OrderEntry Namespace


IBackOrder Members

IBackOrder overview

Public Instance Methods

Configure | Method used to configure the Backorder plugin.
CreateBackOrders | Method used to create backorders for unshipped orderlines. Implementation must assume that the order contains lines for which the quantity shipped has been incremented.

Public Instance Events

StatusUpdate Event used to communicate the results of a process back to the calling environment.

See Also

IBackOrder Interface | Aptify.Applications.OrderEntry Namespace


IBackOrder Methods

The methods of the IBackOrder interface are listed below. For a complete list of IBackOrder interface members, see the IBackOrder Members topic.

Public Instance Methods

Configure | Method used to configure the Backorder plugin.
CreateBackOrders | Method used to create backorders for unshipped orderlines. Implementation must assume that the order contains lines for which the quantity shipped has been incremented.

See Also

IBackOrder Interface | Aptify.Applications.OrderEntry Namespace


IBackOrder.Configure Method

Method used to configure the Backorder plugin.

bool Configure(
AptifyApplication Application
);

Parameters

Application
Aptify Application object.

Return Value

Remarks

See Also

IBackOrder Interface | Aptify.Applications.OrderEntry Namespace


IBackOrder.CreateBackOrders Method

Method used to create backorders for unshipped orderlines. Implementation must assume that the order contains lines for which the quantity shipped has been incremented.

bool CreateBackOrders(
OrdersEntity OrderObject,
ref String& ErrorString
);

Parameters

OrderObject
OrdersEntity object to act as the original order.
ErrorString
String used to return any error messages from the backorder process.

Return Value

Remarks

See Also

IBackOrder Interface | Aptify.Applications.OrderEntry Namespace


IBackOrder Events

The events of the IBackOrder interface are listed below. For a complete list of IBackOrder interface members, see the IBackOrder Members topic.

Public Instance Events

StatusUpdate Event used to communicate the results of a process back to the calling environment.

See Also

IBackOrder Interface | Aptify.Applications.OrderEntry Namespace


IBackOrder.IBackOrder.StatusUpdateEventHandler Event

Event used to communicate the results of a process back to the calling environment.

event IBackOrder.StatusUpdateEventHandler StatusUpdate;

Remarks

See Also

IBackOrder Interface | Aptify.Applications.OrderEntry Namespace


IBackOrder.StatusUpdateEventHandler Delegate

public delegate void IBackOrder.StatusUpdateEventHandler(
String Message,
Int32 Progress
);

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

Aptify.Applications.OrderEntry Namespace


ICalculateShippingCost Interface

This interface is NO longer used. Please use "IShippingCalculator" interface instead of this. This interface is used to create plug-in objects that are responsible for calculating the shipping costs for an order. In order to plug-in an object that calculates shipping costs in Aptify Order Entry, either implement a sub-class of the Aptify CalculateShippingCost base shipping class, or implement this interface in any other object. After the implementation of the object is complete, place the Object, Class and Assembly information in the following attributes inside the Aptify Orders Entity: Ship Cost Object - Object Repository PackageName.ObjectName location of the object Ship Cost Class - Fully qualified class name that implements this interface from root namespace down Ship Cost Assembly - Name of assembly where the Ship Cost Class is located

For a list of all members of this type, see ICalculateShippingCost Members.

public interface ICalculateShippingCost

Types that implement ICalculateShippingCost

Type | Description
CalculateShippingCost | This object implements the Aptify.Applications.OrderEntry.ICalculateShippingCost interface. The purpose of this component is to return a shipping cost for an order and is designed to be sub-classed to implement any specific functionality required.

Remarks

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: ICalculateShippingCost (in ICalculateShippingCost.dll)

See Also

ICalculateShippingCost Members | Aptify.Applications.OrderEntry Namespace


ICalculateShippingCost Members

ICalculateShippingCost overview

Public Instance Methods

CalculateShippingCost | This method performs the actual shipping cost calculation for the order that is provided. This method will get called every time an OrderLine is added to an Order, deleted form the order, or if any order line changes, or if the ShipType changes Aptify recommends the use of the Aptify Data Action class that provides for data caching functionality to improve the performance of queries that execute within this object so that database queries are not redundantly rerun on a server for results that do not frequently change.
Config | This method must be called first to provide the shipping cost object the environment and other information that is contained within the Aptify Application object.

See Also

ICalculateShippingCost Interface | Aptify.Applications.OrderEntry Namespace


ICalculateShippingCost Methods

The methods of the ICalculateShippingCost interface are listed below. For a complete list of ICalculateShippingCost interface members, see the ICalculateShippingCost Members topic.

Public Instance Methods

CalculateShippingCost | This method performs the actual shipping cost calculation for the order that is provided. This method will get called every time an OrderLine is added to an Order, deleted form the order, or if any order line changes, or if the ShipType changes Aptify recommends the use of the Aptify Data Action class that provides for data caching functionality to improve the performance of queries that execute within this object so that database queries are not redundantly rerun on a server for results that do not frequently change.
Config | This method must be called first to provide the shipping cost object the environment and other information that is contained within the Aptify Application object.

See Also

ICalculateShippingCost Interface | Aptify.Applications.OrderEntry Namespace


ICalculateShippingCost.CalculateShippingCost Method

This method performs the actual shipping cost calculation for the order that is provided. This method will get called every time an OrderLine is added to an Order, deleted form the order, or if any order line changes, or if the ShipType changes Aptify recommends the use of the Aptify Data Action class that provides for data caching functionality to improve the performance of queries that execute within this object so that database queries are not redundantly rerun on a server for results that do not frequently change.

bool CalculateShippingCost(
AptifyGenericEntityBase OrderGE,
ref Decimal& ShippingCost,
ref String& UserMessage
);

Parameters

OrderGE
This object will be used to access information about the order lines, ship type, etc. The Ship Cost routine can use the information in the order object to determine the amount of shipping costs to apply to the order
ShippingCost
OUT Parameter: This parameter should be used to return the shipping cost that is calculated.
UserMessage
This parameter can be used to return a user message that will be displayed by the user interface that is calling the function, but only if the function returns False.

Return Value

True if the operation is succesful, False Otherwise

Remarks

See Also

ICalculateShippingCost Interface | Aptify.Applications.OrderEntry Namespace


ICalculateShippingCost.Config Method

This method must be called first to provide the shipping cost object the environment and other information that is contained within the Aptify Application object.

void Config(
AptifyApplication Application
);

Parameters

Application

Remarks

See Also

ICalculateShippingCost Interface | Aptify.Applications.OrderEntry Namespace


ICampaignCalculateDiscount Interface

Interface used to create plug-ins for retrieving discounts associated with Campaigns

For a list of all members of this type, see ICampaignCalculateDiscount Members.

public interface ICampaignCalculateDiscount

Types that implement ICampaignCalculateDiscount

Type | Description
CampaignCalculateDiscount | This object implements the Aptify.Framework.Applications.Decimal.ICampaignCalculateDiscount interface. The purpose of this component is to return a discount for the specified set of parameters provided

Remarks

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

ICampaignCalculateDiscount Members | Aptify.Applications.OrderEntry Namespace


ICampaignCalculateDiscount Members

ICampaignCalculateDiscount overview

Public Instance Methods

Config | Call this function before using any other method on the interface to configure the object for use
GetCampaignPricing | Overloaded. Function will return the campaign discount percentage to be used for the specified product based on the parameters provided

See Also

ICampaignCalculateDiscount Interface | Aptify.Applications.OrderEntry Namespace


ICampaignCalculateDiscount Methods

The methods of the ICampaignCalculateDiscount interface are listed below. For a complete list of ICampaignCalculateDiscount interface members, see the ICampaignCalculateDiscount Members topic.

Public Instance Methods

Config | Call this function before using any other method on the interface to configure the object for use
GetCampaignPricing | Overloaded. Function will return the campaign discount percentage to be used for the specified product based on the parameters provided

See Also

ICampaignCalculateDiscount Interface | Aptify.Applications.OrderEntry Namespace


ICampaignCalculateDiscount.Config Method

Call this function before using any other method on the interface to configure the object for use

void Config(
AptifyApplication Application
);

Parameters

Application
Aptify Application Required for Use of the Object

Remarks

See Also

ICampaignCalculateDiscount Interface | Aptify.Applications.OrderEntry Namespace


GetCampaignPricing Method

Aptify 5.0 Software Development Kit (SDK)

ICampaignCalculateDiscount.GetCampaignPricing Method

Function will return the campaign discount percentage to be used for the specified product based on the parameters provided

Overload List

Function will return the campaign discount percentage to be used for the specified product based on the parameters provided

CampaignDiscount GetCampaignPricing(OrderLinesEntity);

Function will return the campaign discount percentage to be used for the specified product based on the parameters provided

CampaignDiscount GetCampaignPricing(Int64,DateTime,Int64,Int64,Int64,Decimal);

See Also

ICampaignCalculateDiscount Interface | Aptify.Applications.OrderEntry Namespace


ICampaignCalculateDiscount.GetCampaignPricing Method (OrderLinesEntity)

Function will return the campaign discount percentage to be used for the specified product based on the parameters provided

CampaignDiscount GetCampaignPricing(
OrderLinesEntity OrderLineGE
);

Parameters

OrderLineGE
OrderLinesEntity object that represents the Order Line with the information that will be used to determine whether or not a campaign discount applies.

Return Value

A CampaignDiscount object populated with the appropriate campaign discount information, if the campaign qualifies based on the information provided. If no qualifying campaign is found, Nothing is returned.

Remarks

See Also

ICampaignCalculateDiscount Interface | Aptify.Applications.OrderEntry Namespace | ICampaignCalculateDiscount.GetCampaignPricing Overload List


ICampaignCalculateDiscount.GetCampaignPricing Method (Int64, DateTime, Int64, Int64, Int64, Decimal)

Function will return the campaign discount percentage to be used for the specified product based on the parameters provided

CampaignDiscount GetCampaignPricing(
Int64 CampaignID,
DateTime OrderDate,
Int64 MemberTypeID,
Int64 CompanyMemberTypeID,
Int64 ProductID,
Decimal SystemCalculatedPrice
);

Parameters

CampaignID
Campaign ID
OrderDate
Date of Order being processed
MemberTypeID
Member Type of the individual on the order
CompanyMemberTypeID
Member Type of the company on the order
ProductID
Product for which pricing discounts are being calculated
SystemCalculatedPrice
Price calculated by standard system pricing model

Return Value

A CampaignDiscount object populated with the appropriate campaign discount information, if the campaign qualifies based on the information provided. If no qualifying campaign is found, Nothing is returned.

Remarks

See Also

ICampaignCalculateDiscount Interface | Aptify.Applications.OrderEntry Namespace | ICampaignCalculateDiscount.GetCampaignPricing Overload List


IChapterAssignmentRules Interface

Abstract interface class used for creating plug-ins for the Chapter Assignment Rule functionality. Used by the Orders Entity as a Plug-In type. If creating a new plug-in for Chapter Assignment Rules, it is recommended to sub-class the base ChapterAssignmentRules object that is implemented in the Aptify ChapterAssignmentRules assembly ( within the Aptify.Applications.Chapters namespace ) instead of implementing a new class that directly implements this interface in order to reuse existing functionality in the ChapterAssignmentRules class.

For a list of all members of this type, see IChapterAssignmentRules Members.

public interface IChapterAssignmentRules

Types that implement IChapterAssignmentRules

Type | Description
ChapterAssignmentRules | Implements functionality to automatically determine a chapter for a given person, or order line. Supports both a type-specific interface and also the IProcessComponent interface

Remarks

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

IChapterAssignmentRules Members | Aptify.Applications.OrderEntry Namespace


IChapterAssignmentRules Members

IChapterAssignmentRules overview

Public Instance Properties

Application | Returns the instance of the ApplicationObject within the class implementing the interface
DataAction | Returns the instance of the DataAction within the class implementing the interface

Public Instance Methods

Config | This method must be called before any other method on the interface is called.
GetChapterAssignmentRuleDBObjectName | This method returns the Chapter Assignment Rule DBObject name(name of the stored procedure for the rule) based on the provided RuleID. If set to True, the database cache is refreshed
GetChapterID | Overloaded. This method returns a ChapterID (Companies.ID value from the database) that is returned based on executing the rule specified by RuleID, which is a record ID from the Chapter Assignment Rules entity.

See Also

IChapterAssignmentRules Interface | Aptify.Applications.OrderEntry Namespace


IChapterAssignmentRules Properties

The properties of the IChapterAssignmentRules interface are listed below. For a complete list of IChapterAssignmentRules interface members, see the IChapterAssignmentRules Members topic.

Public Instance Properties

Application | Returns the instance of the ApplicationObject within the class implementing the interface
DataAction | Returns the instance of the DataAction within the class implementing the interface

See Also

IChapterAssignmentRules Interface | Aptify.Applications.OrderEntry Namespace


Application Property

Aptify 5.0 Software Development Kit (SDK)

IChapterAssignmentRules.Application Property

Returns the instance of the ApplicationObject within the class implementing the interface

AptifyApplication Application {get;}

Property Value

Remarks

See Also

IChapterAssignmentRules Interface | Aptify.Applications.OrderEntry Namespace


DataAction Property

Aptify 5.0 Software Development Kit (SDK)

IChapterAssignmentRules.DataAction Property

Returns the instance of the DataAction within the class implementing the interface

DataAction DataAction {get;}

Property Value

Remarks

See Also

IChapterAssignmentRules Interface | Aptify.Applications.OrderEntry Namespace


IChapterAssignmentRules Methods

The methods of the IChapterAssignmentRules interface are listed below. For a complete list of IChapterAssignmentRules interface members, see the IChapterAssignmentRules Members topic.

Public Instance Methods

Config | This method must be called before any other method on the interface is called.
GetChapterAssignmentRuleDBObjectName | This method returns the Chapter Assignment Rule DBObject name(name of the stored procedure for the rule) based on the provided RuleID. If set to True, the database cache is refreshed
GetChapterID | Overloaded. This method returns a ChapterID (Companies.ID value from the database) that is returned based on executing the rule specified by RuleID, which is a record ID from the Chapter Assignment Rules entity.

See Also

IChapterAssignmentRules Interface | Aptify.Applications.OrderEntry Namespace


IChapterAssignmentRules.Config Method

This method must be called before any other method on the interface is called.

void Config(
AptifyApplication ApplicationObject
);

Parameters

ApplicationObject

Remarks

See Also

IChapterAssignmentRules Interface | Aptify.Applications.OrderEntry Namespace


IChapterAssignmentRules.GetChapterAssignmentRuleDBObjectName Method

This method returns the Chapter Assignment Rule DBObject name(name of the stored procedure for the rule) based on the provided RuleID. If set to True, the database cache is refreshed

string GetChapterAssignmentRuleDBObjectName(
Int64 RuleID,
Boolean Refresh
);

Parameters

RuleID
Refresh

Return Value

Remarks

See Also

IChapterAssignmentRules Interface | Aptify.Applications.OrderEntry Namespace


GetChapterID Method

Aptify 5.0 Software Development Kit (SDK)

IChapterAssignmentRules.GetChapterID Method

This method returns a ChapterID (Companies.ID value from the database) that is returned based on executing the rule specified by RuleID, which is a record ID from the Chapter Assignment Rules entity.

Overload List

This method returns a ChapterID (Companies.ID value from the database) that is returned based on executing the rule specified by RuleID, which is a record ID from the Chapter Assignment Rules entity.

long GetChapterID(Int64,Int64,Int64,Int64,DateTime);

This method returns a ChapterID (Companies.ID value from the database) that is returned based on executing the rule specified by RuleDBObjectName, which is the name of a stored procedure in the database that takes in @ProductID, @PersonID, @CompanyID, and @EffectiveDate and returns a Company ID (or -1) that maps to the Chapter to be assigned. -1 is returned if no chapter is assigned.

long GetChapterID(String,Int64,Int64,Int64,DateTime);

See Also

IChapterAssignmentRules Interface | Aptify.Applications.OrderEntry Namespace


IChapterAssignmentRules.GetChapterID Method (Int64, Int64, Int64, Int64, DateTime)

This method returns a ChapterID (Companies.ID value from the database) that is returned based on executing the rule specified by RuleID, which is a record ID from the Chapter Assignment Rules entity.

long GetChapterID(
Int64 RuleID,
Int64 ProductID,
Int64 PersonID,
Int64 CompanyID,
DateTime EffectiveDate
);

Parameters

RuleID
ProductID
PersonID
CompanyID
EffectiveDate

Return Value

Remarks

See Also

IChapterAssignmentRules Interface | Aptify.Applications.OrderEntry Namespace | IChapterAssignmentRules.GetChapterID Overload List


IChapterAssignmentRules.GetChapterID Method (String, Int64, Int64, Int64, DateTime)

This method returns a ChapterID (Companies.ID value from the database) that is returned based on executing the rule specified by RuleDBObjectName, which is the name of a stored procedure in the database that takes in @ProductID, @PersonID, @CompanyID, and @EffectiveDate and returns a Company ID (or -1) that maps to the Chapter to be assigned. -1 is returned if no chapter is assigned.

long GetChapterID(
String RuleDBObjectName,
Int64 ProductID,
Int64 PersonID,
Int64 CompanyID,
DateTime EffectiveDate
);

Parameters

RuleDBObjectName
ProductID
PersonID
CompanyID
EffectiveDate

Return Value

Remarks

See Also

IChapterAssignmentRules Interface | Aptify.Applications.OrderEntry Namespace | IChapterAssignmentRules.GetChapterID Overload List


ICheckCredit Interface

This interface is used to create plug-in objects that are responsible for checking credit of companies or individuals on an order. In order to plug-in an object that handles this functionality in Aptify Order Entry, either implement a sub-class of the Aptify CheckCredit base credit checking class, or implement this interface in any other object. After the implementation of the object is complete, place the Object, Class and Assembly information in the following attributes inside the Aptify Orders Entity: Credit Check Object - Object Repository PackageName.ObjectName location of the object Credit Check Class - Fully qualified class name that implements this interface from root namespace down Credit Check Assembly - Name of assembly where the Credit Check Class is located

For a list of all members of this type, see ICheckCredit Members.

public interface ICheckCredit

Types that implement ICheckCredit

Type | Description
CheckCredit | This object implements the Aptify.Applications.OrderEntry.ICheckCredit interface. The purpose of this component is to check the credit for an order and return the status of that credit check back to the calling object.

Remarks

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

ICheckCredit Members | Aptify.Applications.OrderEntry Namespace


ICheckCredit Members

ICheckCredit overview

Public Instance Methods

CheckCredit | This function is responsible for actually checking the credit status and limit of a company or individual. Aptify Orders are "Company-Level" orders if there is a BillToCompanyID filled in on the order. If a BillToCompanyID is provided, credit is checked at the company level. If a BillToCompanyID is NOT filled in on the order, credit is checked at the individual level using the person linked to the order by the BillToID field.
Config | This method must be called first to provide the shipping cost object the environment and other information that is contained within the Aptify Application object.

See Also

ICheckCredit Interface | Aptify.Applications.OrderEntry Namespace


ICheckCredit Methods

The methods of the ICheckCredit interface are listed below. For a complete list of ICheckCredit interface members, see the ICheckCredit Members topic.

Public Instance Methods

CheckCredit | This function is responsible for actually checking the credit status and limit of a company or individual. Aptify Orders are "Company-Level" orders if there is a BillToCompanyID filled in on the order. If a BillToCompanyID is provided, credit is checked at the company level. If a BillToCompanyID is NOT filled in on the order, credit is checked at the individual level using the person linked to the order by the BillToID field.
Config | This method must be called first to provide the shipping cost object the environment and other information that is contained within the Aptify Application object.

See Also

ICheckCredit Interface | Aptify.Applications.OrderEntry Namespace


ICheckCredit.CheckCredit Method

This function is responsible for actually checking the credit status and limit of a company or individual. Aptify Orders are "Company-Level" orders if there is a BillToCompanyID filled in on the order. If a BillToCompanyID is provided, credit is checked at the company level. If a BillToCompanyID is NOT filled in on the order, credit is checked at the individual level using the person linked to the order by the BillToID field.

bool CheckCredit(
OrdersEntity OrderGE,
ref String& UserMessage
);

Parameters

OrderGE
Orders Entity Generic Entity Object that contains all information about the order for reviewing the credit requirements inside the object
UserMessage
OUT Parameter: This parameter is used by the object to provide a user message in the event that credit is not approved. This message will be used by the consumer of this object to display user information as appropriate.

Return Value

True if Credit is Approved and the order shoudl be processed, False if the Credit is NOT approved and the order should not be processed.

Remarks

See Also

ICheckCredit Interface | Aptify.Applications.OrderEntry Namespace


ICheckCredit.Config Method

This method must be called first to provide the shipping cost object the environment and other information that is contained within the Aptify Application object.

void Config(
AptifyApplication Application
);

Parameters

Application

Remarks

See Also

ICheckCredit Interface | Aptify.Applications.OrderEntry Namespace


ICheckInventory Interface

This interface provides for the ability to create plug-in classes that can be used by the rest of the Aptify Order Entry system.

For a list of all members of this type, see ICheckInventory Members.

public interface ICheckInventory

Types that implement ICheckInventory

Type | Description
CheckMeetingInventory | This class inherits from the Aptify.Applications.Inventory.CheckInventory class and implements specialized functionality that is specific to inventory management for products that have a Product Type of 'Meeting'.
CheckInventory | This class is responsible for checking inventory for all types of products. Sub-classes
OrderLinesEntity | Represents the sub-class to AptifyGenericEntity that is used for the OrderLines entity and also implements the ICheckInventory and IProductPrice interfaces.

Remarks

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

ICheckInventory Members | Aptify.Applications.OrderEntry Namespace


ICheckInventory Members

ICheckInventory overview

Public Instance Methods

CheckInventory | Checks if inventory is sufficient for the given product and quantity
Config | Call this function once before calling any other function on this interface. This function sets up the inventory checking object with an application reference so that it can bind to the current set of user credentials
GetInventoryLocation | Returns the appropriate inventory location that should be used to reserve inventory for a particular product and quantity specified

See Also

ICheckInventory Interface | Aptify.Applications.OrderEntry Namespace


ICheckInventory Methods

The methods of the ICheckInventory interface are listed below. For a complete list of ICheckInventory interface members, see the ICheckInventory Members topic.

Public Instance Methods

CheckInventory | Checks if inventory is sufficient for the given product and quantity
Config | Call this function once before calling any other function on this interface. This function sets up the inventory checking object with an application reference so that it can bind to the current set of user credentials
GetInventoryLocation | Returns the appropriate inventory location that should be used to reserve inventory for a particular product and quantity specified

See Also

ICheckInventory Interface | Aptify.Applications.OrderEntry Namespace


ICheckInventory.CheckInventory Method

Checks if inventory is sufficient for the given product and quantity

void CheckInventory(
Int64 ProductID,
Decimal Quantity,
ref Boolean& Required,
ref Decimal& QuantityAvailable,
ref Decimal& QuantityOnHand,
ref Decimal& QuantityOnOrder,
ref Decimal& QuantityReserved,
ref Decimal& QuantityShipped,
ref InventoryStatus& Status,
OrderLinesEntity OrderLineGE,
Boolean AllowGUI,
ref String& Message
);

Parameters

ProductID
Product to check inventory of
Quantity
Quantity to check inventory availability
Required
OUT Parameter - True if Inventory is requried for the specified product, False if inventory is NOT requried for the specified product
QuantityAvailable
OUT Parameter - Product quantity available after removing the quantity specified for use in this function in the Quantity parameter
QuantityOnHand
OUT Parameter - Product quantity on hand after removing the quantity specified for use in this function in the Quantity parameter
QuantityOnOrder
OUT Parameter - Product quantity on order
QuantityReserved
OUT Parameter - Product quantity reserved after adding in the quantity specified for use in this function in the Quantity parameter
QuantityShipped
OUT Parameter - Product quantity shipped life-to-date for the specified product
Status
OUT Paramter - Status of inventory based on the requested product and quantity
OrderLineGE
OrderLines Entity Object for the order detail related to this request
AllowGUI
If True, the Inventory Checking component is allowed to interact with the user through the user interface, if False, the inventory checking component may not interact with the user via the user interface and any appropriate messages that are relevant to the process are passed back via the Message parameter
Message
Message returned by the inventory checker that can be used to inform the user as to inventory availability (or lack thereof)

Remarks

See Also

ICheckInventory Interface | Aptify.Applications.OrderEntry Namespace


ICheckInventory.Config Method

Call this function once before calling any other function on this interface. This function sets up the inventory checking object with an application reference so that it can bind to the current set of user credentials

void Config(
AptifyApplication Application
);

Parameters

Application
Aptify Application object

Remarks

See Also

ICheckInventory Interface | Aptify.Applications.OrderEntry Namespace


ICheckInventory.GetInventoryLocation Method

Returns the appropriate inventory location that should be used to reserve inventory for a particular product and quantity specified

long GetInventoryLocation(
Int64 ProductID,
Decimal Quantity,
Int64 PrimaryLocationID,
OrderLinesEntity OrderLineGE
);

Parameters

ProductID
Product to check inventory for
Quantity
Quantity to check availability
PrimaryLocationID
Used as the default location. If there is not sufficient quantity in that location, another location will be chosen.
OrderLineGE
OrderLines Entity Object for the Current Order Detail related to this request

Return Value

The inventory location to use for the specified product and quantity

Remarks

See Also

ICheckInventory Interface | Aptify.Applications.OrderEntry Namespace


ICheckInventory.InventoryStatus Enumeration

public enum ICheckInventory.InventoryStatus

Members

Member Name | Description
Sufficient |
Insufficient |
RequiresMultipleInventoryLocations |

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

Aptify.Applications.OrderEntry Namespace


IExpandKits Interface

Interface used to create plug-ins for expanding kits products within the Order Entry system. The order entry system will look for a plug-in that implements this interface within the Aptify Entity model by looking at the following entity attributes and attempting to instantiate an object that is specified as shown in the entity attributes. The specified object must implement IExpandKits. Note that in addition to this abstract interface Aptify provides a default implementation class Aptify.Applications.OrderEntry.ExpandKits which may be subclassed to accomodate unique configuration needs rather than creating entirely new objects that implement this interface directly. Entity Attributes in the Orders Entity Name: "Kit Expansion Object" Location of the object in the Aptify Object Repository. Name: "Kit Expansion Class" Class Name (fully qualified including root namespace) the implements this interface. Default value is Aptify.Applications.OrderEntry.ExpandKits Name "Kit Expansion Assembly" Assembly Name where the above class is located

For a list of all members of this type, see IExpandKits Members.

public interface IExpandKits

Types that implement IExpandKits

Type | Description
ExpandKits | This object implements the Aptify.Framework.Applications.OrderEntry.IExpandKits interface. The purpose of this component is to handle the base use cases for expanding kits. This class is designed to be sub-classed as needed for configuration requirements.

Remarks

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

IExpandKits Members | Aptify.Applications.OrderEntry Namespace


IExpandKits Members

IExpandKits overview

Public Instance Methods

Config | This method must be called before any other member of the interface is called
ExpandCancellationKitItem |
ExpandKitItem |
UpdateKitComponentQuantities | This method is responsible for updating quantities of a kit line item within an order. The method will update all components of the kit within the order for the specified Order Detail GE.

See Also

IExpandKits Interface | Aptify.Applications.OrderEntry Namespace


IExpandKits Methods

The methods of the IExpandKits interface are listed below. For a complete list of IExpandKits interface members, see the IExpandKits Members topic.

Public Instance Methods

Config | This method must be called before any other member of the interface is called
ExpandCancellationKitItem |
ExpandKitItem |
UpdateKitComponentQuantities | This method is responsible for updating quantities of a kit line item within an order. The method will update all components of the kit within the order for the specified Order Detail GE.

See Also

IExpandKits Interface | Aptify.Applications.OrderEntry Namespace


IExpandKits.Config Method

This method must be called before any other member of the interface is called

void Config(
AptifyApplication Application
);

Parameters

Application

Remarks

See Also

IExpandKits Interface | Aptify.Applications.OrderEntry Namespace


IExpandKits.ExpandCancellationKitItem Method

bool ExpandCancellationKitItem(
OrderLinesEntity OrderDetailGE,
ref List`1& NewOrderLines
);

See Also

IExpandKits Interface | Aptify.Applications.OrderEntry Namespace


IExpandKits.ExpandKitItem Method

bool ExpandKitItem(
OrderLinesEntity OrderDetailGE,
ref List`1& NewOrderLines
);

See Also

IExpandKits Interface | Aptify.Applications.OrderEntry Namespace


IExpandKits.UpdateKitComponentQuantities Method

This method is responsible for updating quantities of a kit line item within an order. The method will update all components of the kit within the order for the specified Order Detail GE.

bool UpdateKitComponentQuantities(
OrderLinesEntity OrderDetailGE
);

Parameters

OrderDetailGE

Return Value

Remarks

See Also

IExpandKits Interface | Aptify.Applications.OrderEntry Namespace


IExtraPaymentDialog Interface

For a list of all members of this type, see IExtraPaymentDialog Members.

public interface IExtraPaymentDialog

Types that implement IExtraPaymentDialog

Type | Description
OrderExtraPayment | Implements a user interface that provides the user the ability to add extra payment information to an order when a credit memo doesn't pay for the entire order balance

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

IExtraPaymentDialog Members | Aptify.Applications.OrderEntry Namespace


IExtraPaymentDialog Members

IExtraPaymentDialog overview

Public Instance Properties

PaymentGE A reference to a Payments Entity object that has been populated with the correct information but not saved. The Order Save process will take this reference and Save the payment during the transaction.

Public Instance Methods

Config | Method implemented to configure the Extra Payment Dialog plugin.
ShowExtraPaymentDialog | Method implemented to display the extra payment dialog.

See Also

IExtraPaymentDialog Interface | Aptify.Applications.OrderEntry Namespace


IExtraPaymentDialog Properties

The properties of the IExtraPaymentDialog interface are listed below. For a complete list of IExtraPaymentDialog interface members, see the IExtraPaymentDialog Members topic.

Public Instance Properties

PaymentGE A reference to a Payments Entity object that has been populated with the correct information but not saved. The Order Save process will take this reference and Save the payment during the transaction.

See Also

IExtraPaymentDialog Interface | Aptify.Applications.OrderEntry Namespace


PaymentGE Property

Aptify 5.0 Software Development Kit (SDK)

IExtraPaymentDialog.PaymentGE Property

A reference to a Payments Entity object that has been populated with the correct information but not saved. The Order Save process will take this reference and Save the payment during the transaction.

PaymentsEntity PaymentGE {get;}

Property Value

Remarks

See Also

IExtraPaymentDialog Interface | Aptify.Applications.OrderEntry Namespace


IExtraPaymentDialog Methods

The methods of the IExtraPaymentDialog interface are listed below. For a complete list of IExtraPaymentDialog interface members, see the IExtraPaymentDialog Members topic.

Public Instance Methods

Config | Method implemented to configure the Extra Payment Dialog plugin.
ShowExtraPaymentDialog | Method implemented to display the extra payment dialog.

See Also

IExtraPaymentDialog Interface | Aptify.Applications.OrderEntry Namespace


IExtraPaymentDialog.Config Method

Method implemented to configure the Extra Payment Dialog plugin.

bool Config(
AptifyApplication Application
);

Parameters

Application
Aptify Application object used to configure the implementing object.

Return Value

Remarks

See Also

IExtraPaymentDialog Interface | Aptify.Applications.OrderEntry Namespace


IExtraPaymentDialog.ShowExtraPaymentDialog Method

Method implemented to display the extra payment dialog.

DialogResult ShowExtraPaymentDialog(
OrdersEntity Order,
Decimal OrderBalance
);

Parameters

Order
Order object passed in to provide access to the relevant data inside the object.
OrderBalance
Balance of the order being passed in.

Return Value

Remarks

See Also

IExtraPaymentDialog Interface | Aptify.Applications.OrderEntry Namespace


IGenerateCOGS Interface

This interface is used for plug-ins to create Cost of Goods Sold (COGS) GL entries as needed in different application areas in the Aptify Order Entry system.

For a list of all members of this type, see IGenerateCOGS Members.

public interface IGenerateCOGS

Types that implement IGenerateCOGS

Type | Description
GenerateCOGS | This object implements the Aptify.Framework.Applications.OrderEntry.IGenerateCOGS interface The purpose of this component is to generate Cost of Goods Sold GL entries for the order when requested by the Order entry system.

Remarks

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: IGenerateCOGS (in IGenerateCOGS.dll)

See Also

IGenerateCOGS Members | Aptify.Applications.OrderEntry Namespace


IGenerateCOGS Members

IGenerateCOGS overview

Public Instance Methods

Config | This method is called first before any other member of this class is used
CreateInventoryEntries | This method is called once per order to generate the inventory related Cost of Goods Sold entries for the order.

See Also

IGenerateCOGS Interface | Aptify.Applications.OrderEntry Namespace


IGenerateCOGS Methods

The methods of the IGenerateCOGS interface are listed below. For a complete list of IGenerateCOGS interface members, see the IGenerateCOGS Members topic.

Public Instance Methods

Config | This method is called first before any other member of this class is used
CreateInventoryEntries | This method is called once per order to generate the inventory related Cost of Goods Sold entries for the order.

See Also

IGenerateCOGS Interface | Aptify.Applications.OrderEntry Namespace


IGenerateCOGS.Config Method

This method is called first before any other member of this class is used

void Config(
AptifyApplication Application
);

Parameters

Application
Aptify Application Object

Remarks

See Also

IGenerateCOGS Interface | Aptify.Applications.OrderEntry Namespace


IGenerateCOGS.CreateInventoryEntries Method

This method is called once per order to generate the inventory related Cost of Goods Sold entries for the order.

bool CreateInventoryEntries(
AptifyGenericEntityBase OrderGE
);

Parameters

OrderGE
The Order Generic Entity Object that requires Cost of Goods Sold Entries to be added

Return Value

Remarks

See Also

IGenerateCOGS Interface | Aptify.Applications.OrderEntry Namespace


ILineShipDialog Interface

Interface used to allow plugin of a Line Shipping Dialog.

For a list of all members of this type, see ILineShipDialog Members.

public interface ILineShipDialog

Types that implement ILineShipDialog

Type | Description
LineShipDialog |

Remarks

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

ILineShipDialog Members | Aptify.Applications.OrderEntry Namespace


ILineShipDialog Members

ILineShipDialog overview

Public Instance Methods

Configure | Method used to configure the LineShipDialog object.
ShowUI | Method used to display the LineShipDialog. Once the user has completed the activity in the dialog, the order lines should be updated appropriately which the quantity shipped and inventory location.

See Also

ILineShipDialog Interface | Aptify.Applications.OrderEntry Namespace


ILineShipDialog Methods

The methods of the ILineShipDialog interface are listed below. For a complete list of ILineShipDialog interface members, see the ILineShipDialog Members topic.

Public Instance Methods

Configure | Method used to configure the LineShipDialog object.
ShowUI | Method used to display the LineShipDialog. Once the user has completed the activity in the dialog, the order lines should be updated appropriately which the quantity shipped and inventory location.

See Also

ILineShipDialog Interface | Aptify.Applications.OrderEntry Namespace


ILineShipDialog.Configure Method

Method used to configure the LineShipDialog object.

bool Configure(
AptifyApplication Application
);

Parameters

Application
AptifyApplication object used to configure the object.

Return Value

Remarks

See Also

ILineShipDialog Interface | Aptify.Applications.OrderEntry Namespace


ILineShipDialog.ShowUI Method

Method used to display the LineShipDialog. Once the user has completed the activity in the dialog, the order lines should be updated appropriately which the quantity shipped and inventory location.

DialogResult ShowUI(
OrdersEntity OrderObject
);

Parameters

OrderObject
OrdersEntity used in the LineShip process.

Return Value

Remarks

The dialog is only responsible for updating quantities. Shipping should not be implemented in this component.

See Also

ILineShipDialog Interface | Aptify.Applications.OrderEntry Namespace


IOrderAddressFlowdown Interface

Interface used to create plug-ins for flowing down address and other order information

For a list of all members of this type, see IOrderAddressFlowdown Members.

public interface IOrderAddressFlowdown

Types that implement IOrderAddressFlowdown

Type | Description
OrderAddressFlowdown | This object implements the Aptify.Framework.Applications.OrderEntry.IOrderAddressFlowdown interface. The purpose of this component is to handle the flow down of information in orders.

Remarks

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: IOrderAddressFlowdown (in IOrderAddressFlowdown.dll)

See Also

IOrderAddressFlowdown Members | Aptify.Applications.OrderEntry Namespace


IOrderAddressFlowdown Members

IOrderAddressFlowdown overview

Public Instance Methods

Config | This method must be called before any other member of the interface is called
DoBillToFlowdown | Handles flow-down of bill to information in the specified order. Returns True if succesful, False otherwise
DoShipToFlowdown | Handles flow-down of ship to information in the specified order. Returns True if succesful, False otherwise

See Also

IOrderAddressFlowdown Interface | Aptify.Applications.OrderEntry Namespace


IOrderAddressFlowdown Methods

The methods of the IOrderAddressFlowdown interface are listed below. For a complete list of IOrderAddressFlowdown interface members, see the IOrderAddressFlowdown Members topic.

Public Instance Methods

Config | This method must be called before any other member of the interface is called
DoBillToFlowdown | Handles flow-down of bill to information in the specified order. Returns True if succesful, False otherwise
DoShipToFlowdown | Handles flow-down of ship to information in the specified order. Returns True if succesful, False otherwise

See Also

IOrderAddressFlowdown Interface | Aptify.Applications.OrderEntry Namespace


IOrderAddressFlowdown.Config Method

This method must be called before any other member of the interface is called

void Config(
AptifyApplication Application
);

Parameters

Application

Remarks

See Also

IOrderAddressFlowdown Interface | Aptify.Applications.OrderEntry Namespace


IOrderAddressFlowdown.DoBillToFlowdown Method

Handles flow-down of bill to information in the specified order. Returns True if succesful, False otherwise

bool DoBillToFlowdown(
AptifyGenericEntityBase OrderGE
);

Parameters

OrderGE

Return Value

Remarks

See Also

IOrderAddressFlowdown Interface | Aptify.Applications.OrderEntry Namespace


IOrderAddressFlowdown.DoShipToFlowdown Method

Handles flow-down of ship to information in the specified order. Returns True if succesful, False otherwise

bool DoShipToFlowdown(
AptifyGenericEntityBase OrderGE
);

Parameters

OrderGE

Return Value

Remarks

See Also

IOrderAddressFlowdown Interface | Aptify.Applications.OrderEntry Namespace


IProductPrice Interface

Interface used to create plug-ins for retrieving product prices

For a list of all members of this type, see IProductPrice Members.

public interface IProductPrice

Types that implement IProductPrice

Type | Description
OrderLinesEntity | Represents the sub-class to AptifyGenericEntity that is used for the OrderLines entity and also implements the ICheckInventory and IProductPrice interfaces.
ProductObject | Product Object is the GE Sub-Class implementation for the Products entity and provides support for extended product types as well as the standard product attribute information.
ProductPrice |

Remarks

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

IProductPrice Members | Aptify.Applications.OrderEntry Namespace


IProductPrice Members

IProductPrice overview

Public Instance Methods

CalculateDerivedPrice | This is a utility function that can be called to employ the standard calculation logic for determining the derived price for a given Base Price and Percent of Base. In addition, if specified, RoundingType and RoundingAmount can be used to round up or down the derived price. Rounding is handled through a call to the RoundPrice() method.
Config |
GetPrice |
GetPricingPermissions |
GetValidPriceList |
RoundPrice | This method handles the rounding process for a decimal price value, rounding type and rounding amount specified. The return value contains the rounded amount.

See Also

IProductPrice Interface | Aptify.Applications.OrderEntry Namespace


IProductPrice Methods

The methods of the IProductPrice interface are listed below. For a complete list of IProductPrice interface members, see the IProductPrice Members topic.

Public Instance Methods

CalculateDerivedPrice | This is a utility function that can be called to employ the standard calculation logic for determining the derived price for a given Base Price and Percent of Base. In addition, if specified, RoundingType and RoundingAmount can be used to round up or down the derived price. Rounding is handled through a call to the RoundPrice() method.
Config |
GetPrice |
GetPricingPermissions |
GetValidPriceList |
RoundPrice | This method handles the rounding process for a decimal price value, rounding type and rounding amount specified. The return value contains the rounded amount.

See Also

IProductPrice Interface | Aptify.Applications.OrderEntry Namespace


IProductPrice.CalculateDerivedPrice Method

This is a utility function that can be called to employ the standard calculation logic for determining the derived price for a given Base Price and Percent of Base. In addition, if specified, RoundingType and RoundingAmount can be used to round up or down the derived price. Rounding is handled through a call to the RoundPrice() method.

decimal CalculateDerivedPrice(
Decimal BasePrice,
Decimal PercentOfBase,
PriceRoundingType RoundingType,
Decimal RoundingAmount
);

Parameters

BasePrice
PercentOfBase
RoundingType
RoundingAmount

Return Value

Remarks

See Also

IProductPrice Interface | Aptify.Applications.OrderEntry Namespace


IProductPrice.Config Method

void Config(
AptifyApplication Application
);

See Also

IProductPrice Interface | Aptify.Applications.OrderEntry Namespace


IProductPrice.GetPrice Method

PriceOutcome GetPrice(
ref PriceInfo& Price,
Int64 ProductID,
Decimal Quantity,
Int64 PersonID,
OrdersEntity OrderGE,
OrderLinesEntity OrderLineGE,
AptifyGenericEntityBase ProductGE,
Int64 CurrencyTypeID,
Int64 DerivedFromCurrencyTypeID,
Boolean CustomPrice
);

See Also

IProductPrice Interface | Aptify.Applications.OrderEntry Namespace


IProductPrice.GetPricingPermissions Method

PricingPermissions GetPricingPermissions(
Int64 ProductID
);

See Also

IProductPrice Interface | Aptify.Applications.OrderEntry Namespace


IProductPrice.GetValidPriceList Method

PriceOutcome GetValidPriceList(
ref PriceInfo& Price,
ref List`1& ValidPrices,
Int64 ProductID,
Int64 PersonID,
Decimal Quantity,
OrdersEntity OrderGE,
OrderLinesEntity OrderLineGE,
AptifyGenericEntityBase ProductGE,
Int64 CurrencyTypeID,
Int64 DerivedFromCurrencyTypeID,
Boolean CustomPrice
);

See Also

IProductPrice Interface | Aptify.Applications.OrderEntry Namespace


IProductPrice.RoundPrice Method

This method handles the rounding process for a decimal price value, rounding type and rounding amount specified. The return value contains the rounded amount.

decimal RoundPrice(
Decimal Price,
PriceRoundingType RoundingType,
Decimal RoundingAmount
);

Parameters

Price
RoundingType
RoundingAmount

Return Value

Remarks

See Also

IProductPrice Interface | Aptify.Applications.OrderEntry Namespace


IProductPrice.PriceAttribute Class

Attribute of a price

For a list of all members of this type, see IProductPrice.PriceAttribute Members.

System.Object
IProductPrice.PriceAttribute

public class IProductPrice.PriceAttribute

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

IProductPrice.PriceAttribute Members | Aptify.Applications.OrderEntry Namespace


IProductPrice.PriceAttribute Members

IProductPrice.PriceAttribute overview

Public Instance Constructors

IProductPrice.PriceAttribute Overloaded. Initializes a new instance of the IProductPrice.PriceAttribute class.

Public Instance Fields

Name | Name of the pricing attribute
Value | Value of the pricing attribute

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

IProductPrice.PriceAttribute Class | Aptify.Applications.OrderEntry Namespace


IProductPrice.PriceAttribute Constructor

Initializes a new instance of the IProductPrice.PriceAttribute class.

Overload List

Initializes a new instance of the IProductPrice.PriceAttribute class.

public IProductPrice.PriceAttribute();

public IProductPrice.PriceAttribute(String,String);

See Also

IProductPrice.PriceAttribute Class | Aptify.Applications.OrderEntry Namespace


IProductPrice.PriceAttribute Constructor ()

Initializes a new instance of the IProductPrice.PriceAttribute class.

public IProductPrice.PriceAttribute();

See Also

IProductPrice.PriceAttribute Class | Aptify.Applications.OrderEntry Namespace | IProductPrice.PriceAttribute Constructor Overload List


IProductPrice.PriceAttribute Constructor (String, String)

public IProductPrice.PriceAttribute(
String Name,
String Value
);

See Also

IProductPrice.PriceAttribute Class | Aptify.Applications.OrderEntry Namespace | IProductPrice.PriceAttribute Constructor Overload List


IProductPrice.PriceAttribute Fields

The fields of the IProductPrice.PriceAttribute class are listed below. For a complete list of IProductPrice.PriceAttribute class members, see the IProductPrice.PriceAttribute Members topic.

Public Instance Fields

Name | Name of the pricing attribute
Value | Value of the pricing attribute

See Also

IProductPrice.PriceAttribute Class | Aptify.Applications.OrderEntry Namespace


IProductPrice.PriceAttribute.Name Field

Name of the pricing attribute

public Name Name;

Remarks

See Also

IProductPrice.PriceAttribute Class | Aptify.Applications.OrderEntry Namespace


IProductPrice.PriceAttribute.Value Field

Value of the pricing attribute

public Value Value;

Remarks

See Also

IProductPrice.PriceAttribute Class | Aptify.Applications.OrderEntry Namespace


IProductPrice.PriceInfo Class

Details on a given price including the price as well as its related attributes

For a list of all members of this type, see IProductPrice.PriceInfo Members.

System.Object
IProductPrice.PriceInfo

public class IProductPrice.PriceInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

IProductPrice.PriceInfo Members | Aptify.Applications.OrderEntry Namespace


IProductPrice.PriceInfo Members

IProductPrice.PriceInfo overview

Public Instance Constructors

IProductPrice.PriceInfo Constructor Initializes a new instance of the IProductPrice.PriceInfo class.

Public Instance Fields

CurrencyType
CurrencyTypeID
IncludesTax
Name
Price
PriceAttributes
SourceType

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

IProductPrice.PriceInfo Class | Aptify.Applications.OrderEntry Namespace


IProductPrice.PriceInfo Constructor

Initializes a new instance of the IProductPrice.PriceInfo class.

public IProductPrice.PriceInfo();

See Also

IProductPrice.PriceInfo Class | Aptify.Applications.OrderEntry Namespace


IProductPrice.PriceInfo Fields

The fields of the IProductPrice.PriceInfo class are listed below. For a complete list of IProductPrice.PriceInfo class members, see the IProductPrice.PriceInfo Members topic.

Public Instance Fields

CurrencyType
CurrencyTypeID
IncludesTax
Name
Price
PriceAttributes
SourceType

See Also

IProductPrice.PriceInfo Class | Aptify.Applications.OrderEntry Namespace


IProductPrice.PriceInfo.CurrencyType Field

public CurrencyType CurrencyType;

See Also

IProductPrice.PriceInfo Class | Aptify.Applications.OrderEntry Namespace


IProductPrice.PriceInfo.CurrencyTypeID Field

public CurrencyTypeID CurrencyTypeID;

See Also

IProductPrice.PriceInfo Class | Aptify.Applications.OrderEntry Namespace


IProductPrice.PriceInfo.IncludesTax Field

public IncludesTax IncludesTax;

See Also

IProductPrice.PriceInfo Class | Aptify.Applications.OrderEntry Namespace


IProductPrice.PriceInfo.Name Field

public Name Name;

See Also

IProductPrice.PriceInfo Class | Aptify.Applications.OrderEntry Namespace


IProductPrice.PriceInfo.Price Field

public Price Price;

See Also

IProductPrice.PriceInfo Class | Aptify.Applications.OrderEntry Namespace


IProductPrice.PriceInfo.PriceAttributes Field

public PriceAttributes PriceAttributes;

See Also

IProductPrice.PriceInfo Class | Aptify.Applications.OrderEntry Namespace


IProductPrice.PriceInfo.SourceType Field

public SourceType SourceType;

See Also

IProductPrice.PriceInfo Class | Aptify.Applications.OrderEntry Namespace


IProductPrice.PriceOutcome Enumeration

Indicates the result of functions in this interface

public enum IProductPrice.PriceOutcome

Remarks

Members

Member Name | Description
Failure | Operation Failed
Exist | Function succeeded, source was found
NotExist | Function succeeded, source was not found

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

Aptify.Applications.OrderEntry Namespace


IProductPrice.PriceSourceType Enumeration

Enum used for tracking the different sources of pricing including standard pricing, rule-based pricing and object-based pricing

public enum IProductPrice.PriceSourceType

Remarks

Members

Member Name | Description
Standard |
PricingRule |
PricingObject |

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

Aptify.Applications.OrderEntry Namespace


IRelatedProducts Interface

Related Products Businesss Object Interface. Used by the Entity Plug In Type Orders.Related Products

For a list of all members of this type, see IRelatedProducts Members.

public interface IRelatedProducts

Types that implement IRelatedProducts

Type | Description
RelatedProducts |

Remarks

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

IRelatedProducts Members | Aptify.Applications.OrderEntry Namespace


IRelatedProducts Members

IRelatedProducts overview

Public Instance Methods

Config | Call this function before using any other method on the interface to configure the object for use
GetRelatedProducts | Overloaded.

See Also

IRelatedProducts Interface | Aptify.Applications.OrderEntry Namespace


IRelatedProducts Methods

The methods of the IRelatedProducts interface are listed below. For a complete list of IRelatedProducts interface members, see the IRelatedProducts Members topic.

Public Instance Methods

Config | Call this function before using any other method on the interface to configure the object for use
GetRelatedProducts | Overloaded.

See Also

IRelatedProducts Interface | Aptify.Applications.OrderEntry Namespace


IRelatedProducts.Config Method

Call this function before using any other method on the interface to configure the object for use

void Config(
AptifyApplication Application
);

Parameters

Application
Aptify Application Required for Use of the Object

Remarks

See Also

IRelatedProducts Interface | Aptify.Applications.OrderEntry Namespace


GetRelatedProducts Method

Aptify 5.0 Software Development Kit (SDK)

IRelatedProducts.GetRelatedProducts Method

Overload List

List<T> GetRelatedProducts(Int64);

List<T> GetRelatedProducts(Int64,Int64);

See Also

IRelatedProducts Interface | Aptify.Applications.OrderEntry Namespace


IRelatedProducts.GetRelatedProducts Method (Int64)

List<T> GetRelatedProducts(
Int64 ProductID
);

See Also

IRelatedProducts Interface | Aptify.Applications.OrderEntry Namespace | IRelatedProducts.GetRelatedProducts Overload List


IRelatedProducts.GetRelatedProducts Method (Int64, Int64)

List<T> GetRelatedProducts(
Int64 ProductID,
Int64 CampaignID
);

See Also

IRelatedProducts Interface | Aptify.Applications.OrderEntry Namespace | IRelatedProducts.GetRelatedProducts Overload List


IRelatedProductsUI Interface

Related Products User Interface. Used by the Entity Plug In Type Orders.Related Products UI

For a list of all members of this type, see IRelatedProductsUI Members.

public interface IRelatedProductsUI

Types that implement IRelatedProductsUI

Type | Description
RelatedProductsForm |

Remarks

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

IRelatedProductsUI Members | Aptify.Applications.OrderEntry Namespace


IRelatedProductsUI Members

IRelatedProductsUI overview

Public Instance Properties

ProductID

Public Instance Methods

Config
DisposeRelatedProducts
HideRelatedProducts
ShowRelatedProducts

Public Instance Events

AddRelatedProductToOrder
UserClosedRelatedProductsUI

See Also

IRelatedProductsUI Interface | Aptify.Applications.OrderEntry Namespace


IRelatedProductsUI Properties

The properties of the IRelatedProductsUI interface are listed below. For a complete list of IRelatedProductsUI interface members, see the IRelatedProductsUI Members topic.

Public Instance Properties

ProductID

See Also

IRelatedProductsUI Interface | Aptify.Applications.OrderEntry Namespace


ProductID Property

Aptify 5.0 Software Development Kit (SDK)

IRelatedProductsUI.ProductID Property

Int64 ProductID {get;}

See Also

IRelatedProductsUI Interface | Aptify.Applications.OrderEntry Namespace


IRelatedProductsUI Methods

The methods of the IRelatedProductsUI interface are listed below. For a complete list of IRelatedProductsUI interface members, see the IRelatedProductsUI Members topic.

Public Instance Methods

Config
DisposeRelatedProducts
HideRelatedProducts
ShowRelatedProducts

See Also

IRelatedProductsUI Interface | Aptify.Applications.OrderEntry Namespace


IRelatedProductsUI.Config Method

void Config(
AptifyApplication Application,
OrderLinesEntity OrderLine,
List<T> RelatedProducts
);

See Also

IRelatedProductsUI Interface | Aptify.Applications.OrderEntry Namespace


IRelatedProductsUI.DisposeRelatedProducts Method

void DisposeRelatedProducts();

See Also

IRelatedProductsUI Interface | Aptify.Applications.OrderEntry Namespace


IRelatedProductsUI.HideRelatedProducts Method

void HideRelatedProducts();

See Also

IRelatedProductsUI Interface | Aptify.Applications.OrderEntry Namespace


IRelatedProductsUI.ShowRelatedProducts Method

void ShowRelatedProducts(
IWin32Window owner,
Point Positition
);

See Also

IRelatedProductsUI Interface | Aptify.Applications.OrderEntry Namespace


IRelatedProductsUI Events

The events of the IRelatedProductsUI interface are listed below. For a complete list of IRelatedProductsUI interface members, see the IRelatedProductsUI Members topic.

Public Instance Events

AddRelatedProductToOrder
UserClosedRelatedProductsUI

See Also

IRelatedProductsUI Interface | Aptify.Applications.OrderEntry Namespace


IRelatedProductsUI.IRelatedProductsUI.AddRelatedProductToOrderEventHandler Event

event IRelatedProductsUI.AddRelatedProductToOrderEventHandler AddRelatedProductToOrder;

Event Data

The event handler receives an argument of type RelatedProductEventArgs containing data related to this event. The following RelatedProductEventArgs properties provide information specific to this event.

Property | Description
OrderLine |
ProductID |
ProductName |
Quantity |

See Also

IRelatedProductsUI Interface | Aptify.Applications.OrderEntry Namespace


IRelatedProductsUI.IRelatedProductsUI.UserClosedRelatedProductsUIEventHandler Event

event IRelatedProductsUI.UserClosedRelatedProductsUIEventHandler UserClosedRelatedProductsUI;

See Also

IRelatedProductsUI Interface | Aptify.Applications.OrderEntry Namespace


IRelatedProductsUI.AddRelatedProductToOrderEventHandler Delegate

public delegate void IRelatedProductsUI.AddRelatedProductToOrderEventHandler(
Object sender,
RelatedProductEventArgs e
);

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

Aptify.Applications.OrderEntry Namespace


IRelatedProductsUI.UserClosedRelatedProductsUIEventHandler Delegate

public delegate void IRelatedProductsUI.UserClosedRelatedProductsUIEventHandler(
Object sender,
CancelEventArgs e
);

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

Aptify.Applications.OrderEntry Namespace


ISalesTax Interface

Interface used to create plug-ins for determining Tax Jurisdictions and performing Sales Tax calculations.

For a list of all members of this type, see ISalesTax Members.

public interface ISalesTax

Types that implement ISalesTax

Type | Description
SalesTax | This object implements the Aptify.Framework.Applications.Accounting.ISalesTaxRate interface. The purpose of this component is to return a tax rate for a given set of input parameters base currency id.

Remarks

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

ISalesTax Members | Aptify.Applications.OrderEntry Namespace


ISalesTax Members

ISalesTax overview

Public Instance Methods

CalculateSalesTax | Overloaded.
CalculateSalesTaxOnShipment |
Config |
DetermineTaxJurisdiction | Overloaded.
GetTaxJurisdictionAndSalesTaxRates | Overloaded.
IsCompanyTaxExempt |
IsPersonTaxExempt |

See Also

ISalesTax Interface | Aptify.Applications.OrderEntry Namespace


ISalesTax Methods

The methods of the ISalesTax interface are listed below. For a complete list of ISalesTax interface members, see the ISalesTax Members topic.

Public Instance Methods

CalculateSalesTax | Overloaded.
CalculateSalesTaxOnShipment |
Config |
DetermineTaxJurisdiction | Overloaded.
GetTaxJurisdictionAndSalesTaxRates | Overloaded.
IsCompanyTaxExempt |
IsPersonTaxExempt |

See Also

ISalesTax Interface | Aptify.Applications.OrderEntry Namespace


CalculateSalesTax Method

Aptify 5.0 Software Development Kit (SDK)

ISalesTax.CalculateSalesTax Method

Overload List

void CalculateSalesTax(OrderLinesEntity);

void CalculateSalesTax(OrdersEntity);

See Also

ISalesTax Interface | Aptify.Applications.OrderEntry Namespace


ISalesTax.CalculateSalesTax Method (OrderLinesEntity)

void CalculateSalesTax(
OrderLinesEntity OrderLineGE
);

See Also

ISalesTax Interface | Aptify.Applications.OrderEntry Namespace | ISalesTax.CalculateSalesTax Overload List


ISalesTax.CalculateSalesTax Method (OrdersEntity)

void CalculateSalesTax(
OrdersEntity OrderGE
);

See Also

ISalesTax Interface | Aptify.Applications.OrderEntry Namespace | ISalesTax.CalculateSalesTax Overload List


ISalesTax.CalculateSalesTaxOnShipment Method

void CalculateSalesTaxOnShipment(
AptifyGenericEntityBase OrderShipmentGE
);

See Also

ISalesTax Interface | Aptify.Applications.OrderEntry Namespace


ISalesTax.Config Method

void Config(
AptifyApplication Application
);

See Also

ISalesTax Interface | Aptify.Applications.OrderEntry Namespace


DetermineTaxJurisdiction Method

Aptify 5.0 Software Development Kit (SDK)

ISalesTax.DetermineTaxJurisdiction Method

Overload List

long DetermineTaxJurisdiction(TaxAddress);

long DetermineTaxJurisdiction(TaxAddress,TaxAddress,TaxAddress);

See Also

ISalesTax Interface | Aptify.Applications.OrderEntry Namespace


ISalesTax.DetermineTaxJurisdiction Method (TaxAddress)

long DetermineTaxJurisdiction(
TaxAddress Address
);

See Also

ISalesTax Interface | Aptify.Applications.OrderEntry Namespace | ISalesTax.DetermineTaxJurisdiction Overload List


ISalesTax.DetermineTaxJurisdiction Method (TaxAddress, TaxAddress, TaxAddress)

long DetermineTaxJurisdiction(
TaxAddress ShipToAddress,
TaxAddress BillToAddress,
TaxAddress SellingLocationAddress
);

See Also

ISalesTax Interface | Aptify.Applications.OrderEntry Namespace | ISalesTax.DetermineTaxJurisdiction Overload List


GetTaxJurisdictionAndSalesTaxRates Method

Aptify 5.0 Software Development Kit (SDK)

ISalesTax.GetTaxJurisdictionAndSalesTaxRates Method

Overload List

void GetTaxJurisdictionAndSalesTaxRates(TaxAddress,TaxAddress,TaxAddress,ref Int64&,ref List`1&);

void GetTaxJurisdictionAndSalesTaxRates(TaxAddress,ref Int64&,ref List`1&);

See Also

ISalesTax Interface | Aptify.Applications.OrderEntry Namespace


ISalesTax.GetTaxJurisdictionAndSalesTaxRates Method (TaxAddress, TaxAddress, TaxAddress, Int64&, List`1&)

void GetTaxJurisdictionAndSalesTaxRates(
TaxAddress ShipToAddress,
TaxAddress BillToAddress,
TaxAddress SellingLocationAddress,
ref Int64& TaxJurisdictionID,
ref List`1& SalesTaxRates
);

See Also

ISalesTax Interface | Aptify.Applications.OrderEntry Namespace | ISalesTax.GetTaxJurisdictionAndSalesTaxRates Overload List


ISalesTax.GetTaxJurisdictionAndSalesTaxRates Method (TaxAddress, Int64&, List`1&)

void GetTaxJurisdictionAndSalesTaxRates(
TaxAddress Address,
ref Int64& TaxJurisdictionID,
ref List`1& SalesTaxRates
);

See Also

ISalesTax Interface | Aptify.Applications.OrderEntry Namespace | ISalesTax.GetTaxJurisdictionAndSalesTaxRates Overload List


ISalesTax.IsCompanyTaxExempt Method

bool IsCompanyTaxExempt(
Int64 CompanyID,
Int64 SalesTaxRateID
);

See Also

ISalesTax Interface | Aptify.Applications.OrderEntry Namespace


ISalesTax.IsPersonTaxExempt Method

bool IsPersonTaxExempt(
Int64 PersonID,
Int64 SalesTaxRateID
);

See Also

ISalesTax Interface | Aptify.Applications.OrderEntry Namespace


IShippingCalculator Interface

Interface used to create plug-ins for determining the Shipment Type and calculating Shipping Charges, Handling Charges and Shipping Cost.

For a list of all members of this type, see IShippingCalculator Members.

public interface IShippingCalculator

Types that implement IShippingCalculator

Type | Description
ShippingCalculator | This object implements the Aptify.Framework.Applications.Accounting.ISalesTaxRate interface. The purpose of this component is to return a tax rate for a given set of input parameters base currency id.

Remarks

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

IShippingCalculator Members | Aptify.Applications.OrderEntry Namespace


IShippingCalculator Members

IShippingCalculator overview

Public Instance Methods

CalculateShipping | Overloaded.
Config |
DetermineShipmentType | Overloaded.

See Also

IShippingCalculator Interface | Aptify.Applications.OrderEntry Namespace


IShippingCalculator Methods

The methods of the IShippingCalculator interface are listed below. For a complete list of IShippingCalculator interface members, see the IShippingCalculator Members topic.

Public Instance Methods

CalculateShipping | Overloaded.
Config |
DetermineShipmentType | Overloaded.

See Also

IShippingCalculator Interface | Aptify.Applications.OrderEntry Namespace


CalculateShipping Method

Aptify 5.0 Software Development Kit (SDK)

IShippingCalculator.CalculateShipping Method

Overload List

void CalculateShipping(OrdersEntity);

void CalculateShipping(OrderShipmentsEntity,IShippingCalculator);

See Also

IShippingCalculator Interface | Aptify.Applications.OrderEntry Namespace


IShippingCalculator.CalculateShipping Method (OrdersEntity)

void CalculateShipping(
OrdersEntity OrderGE
);

See Also

IShippingCalculator Interface | Aptify.Applications.OrderEntry Namespace | IShippingCalculator.CalculateShipping Overload List


IShippingCalculator.CalculateShipping Method (OrderShipmentsEntity, IShippingCalculator)

void CalculateShipping(
OrderShipmentsEntity OrderShipmentGE,
IShippingCalculator ParentCalculator
);

See Also

IShippingCalculator Interface | Aptify.Applications.OrderEntry Namespace | IShippingCalculator.CalculateShipping Overload List


IShippingCalculator.Config Method

void Config(
AptifyApplication Application
);

See Also

IShippingCalculator Interface | Aptify.Applications.OrderEntry Namespace


DetermineShipmentType Method

Aptify 5.0 Software Development Kit (SDK)

IShippingCalculator.DetermineShipmentType Method

Overload List

void DetermineShipmentType(OrderLinesEntity);

void DetermineShipmentType(OrdersEntity);

See Also

IShippingCalculator Interface | Aptify.Applications.OrderEntry Namespace


IShippingCalculator.DetermineShipmentType Method (OrderLinesEntity)

void DetermineShipmentType(
OrderLinesEntity OrderLineGE
);

See Also

IShippingCalculator Interface | Aptify.Applications.OrderEntry Namespace | IShippingCalculator.DetermineShipmentType Overload List


IShippingCalculator.DetermineShipmentType Method (OrdersEntity)

void DetermineShipmentType(
OrdersEntity OrderGE
);

See Also

IShippingCalculator Interface | Aptify.Applications.OrderEntry Namespace | IShippingCalculator.DetermineShipmentType Overload List


ISubscriptionSave Interface

Interface used to create plug-ins for saving subscriptions from the Order Entry system. The order entry system will look for a plug-in that implements this interface within the Aptify Entity model by looking at the following entity attributes and attempting to instantiate an object that is specified as shown in the entity attributes. The specified object must implement ISubscriptionSave. Note that in addition to this abstract interface Aptify provides a default implementation class Aptify.Applications.OrderEntry.SubscriptionSave which may be subclassed to accomodate unique configuration needs rather than creating entirely new objects that implement this interface directly. Entity Attributes in the Orders Entity Name: "Subscription Save Object" Location of the subscription save object in the Aptify Object Repository. Name: "Subscription Save Class" Class Name (fully qualified including root namespace) the implements this interface. Default value is Aptify.Applications.OrderEntry.SubscriptionSave Name "Subscription Save Assembly" Assembly Name where the above class is located

For a list of all members of this type, see ISubscriptionSave Members.

public interface ISubscriptionSave

Remarks

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: ISubscriptionSave (in ISubscriptionSave.dll)

See Also

ISubscriptionSave Members | Aptify.Applications.OrderEntry Namespace


ISubscriptionSave Members

ISubscriptionSave overview

Public Instance Methods

Config | This method must be called before any other member of the interface is called
SaveCancellationSubscriptions | Overloaded. Save cancellation subscriptions for a given Order object.
SaveSubscriptions | Overloaded. Save subscriptions for a given Order object.

Public Instance Events

StatusUpdate This event is raised from the object from the SaveSubscriptions() and SaveCancellationSubscriptions() method calls to provide status update information to the calling object/application as well as the ability to cancel the process using the Cancel OUT parameter provided to this event.

See Also

ISubscriptionSave Interface | Aptify.Applications.OrderEntry Namespace


ISubscriptionSave Methods

The methods of the ISubscriptionSave interface are listed below. For a complete list of ISubscriptionSave interface members, see the ISubscriptionSave Members topic.

Public Instance Methods

Config | This method must be called before any other member of the interface is called
SaveCancellationSubscriptions | Overloaded. Save cancellation subscriptions for a given Order object.
SaveSubscriptions | Overloaded. Save subscriptions for a given Order object.

See Also

ISubscriptionSave Interface | Aptify.Applications.OrderEntry Namespace


ISubscriptionSave.Config Method

This method must be called before any other member of the interface is called

void Config(
AptifyApplication Application
);

Parameters

Application

Remarks

See Also

ISubscriptionSave Interface | Aptify.Applications.OrderEntry Namespace


SaveCancellationSubscriptions Method

Aptify 5.0 Software Development Kit (SDK)

ISubscriptionSave.SaveCancellationSubscriptions Method

Save cancellation subscriptions for a given Order object.

Overload List

Save cancellation subscriptions for a given Order object.

bool SaveCancellationSubscriptions(AptifyGenericEntityBase);

Saves cancellation subscriptions for a given Order object.

bool SaveCancellationSubscriptions(AptifyGenericEntityBase,Boolean);

See Also

ISubscriptionSave Interface | Aptify.Applications.OrderEntry Namespace


ISubscriptionSave.SaveCancellationSubscriptions Method (AptifyGenericEntityBase)

Save cancellation subscriptions for a given Order object.

bool SaveCancellationSubscriptions(
AptifyGenericEntityBase OrderGE
);

Parameters

OrderGE

Return Value

True if succesful, False otherwise

Remarks

See Also

ISubscriptionSave Interface | Aptify.Applications.OrderEntry Namespace | ISubscriptionSave.SaveCancellationSubscriptions Overload List


ISubscriptionSave.SaveCancellationSubscriptions Method (AptifyGenericEntityBase, Boolean)

Saves cancellation subscriptions for a given Order object.

bool SaveCancellationSubscriptions(
AptifyGenericEntityBase OrderGE,
Boolean ShowErrors
);

Parameters

OrderGE
ShowErrors
If set to True, allows the object to display messages to the user when errors occur as well as errors being Thrown for fatal errors. If False, the object displays no GUI and messages are logged to the session exception log and also thrown for fatal errors.

Return Value

True if succesful, False otherwise

Remarks

See Also

ISubscriptionSave Interface | Aptify.Applications.OrderEntry Namespace | ISubscriptionSave.SaveCancellationSubscriptions Overload List


SaveSubscriptions Method

Aptify 5.0 Software Development Kit (SDK)

ISubscriptionSave.SaveSubscriptions Method

Save subscriptions for a given Order object.

Overload List

Save subscriptions for a given Order object.

bool SaveSubscriptions(AptifyGenericEntityBase);

Save subscriptions for a given Order object.

bool SaveSubscriptions(AptifyGenericEntityBase,Boolean);

See Also

ISubscriptionSave Interface | Aptify.Applications.OrderEntry Namespace


ISubscriptionSave.SaveSubscriptions Method (AptifyGenericEntityBase)

Save subscriptions for a given Order object.

bool SaveSubscriptions(
AptifyGenericEntityBase OrderGE
);

Parameters

OrderGE

Return Value

True if succesful, False otherwise

Remarks

See Also

ISubscriptionSave Interface | Aptify.Applications.OrderEntry Namespace | ISubscriptionSave.SaveSubscriptions Overload List


ISubscriptionSave.SaveSubscriptions Method (AptifyGenericEntityBase, Boolean)

Save subscriptions for a given Order object.

bool SaveSubscriptions(
AptifyGenericEntityBase OrderGE,
Boolean ShowErrors
);

Parameters

OrderGE
ShowErrors
If set to True, allows the object to display messages to the user when errors occur as well as errors being Thrown for fatal errors. If False, the object displays no GUI and messages are logged to the session exception log and also thrown for fatal errors.

Return Value

True if succesful, False otherwise

Remarks

See Also

ISubscriptionSave Interface | Aptify.Applications.OrderEntry Namespace | ISubscriptionSave.SaveSubscriptions Overload List


ISubscriptionSave Events

The events of the ISubscriptionSave interface are listed below. For a complete list of ISubscriptionSave interface members, see the ISubscriptionSave Members topic.

Public Instance Events

StatusUpdate This event is raised from the object from the SaveSubscriptions() and SaveCancellationSubscriptions() method calls to provide status update information to the calling object/application as well as the ability to cancel the process using the Cancel OUT parameter provided to this event.

See Also

ISubscriptionSave Interface | Aptify.Applications.OrderEntry Namespace


ISubscriptionSave.ISubscriptionSave.StatusUpdateEventHandler Event

This event is raised from the object from the SaveSubscriptions() and SaveCancellationSubscriptions() method calls to provide status update information to the calling object/application as well as the ability to cancel the process using the Cancel OUT parameter provided to this event.

event ISubscriptionSave.StatusUpdateEventHandler StatusUpdate;

Remarks

See Also

ISubscriptionSave Interface | Aptify.Applications.OrderEntry Namespace


ISubscriptionSave.StatusUpdateEventHandler Delegate

public delegate void ISubscriptionSave.StatusUpdateEventHandler(
Int32 LineNumber,
Int32 PercentComplete,
ref Boolean& Cancel
);

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: ISubscriptionSave (in ISubscriptionSave.dll)

See Also

Aptify.Applications.OrderEntry Namespace


LineShipDialog Class

For a list of all members of this type, see LineShipDialog Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
LineShipDialog

public class LineShipDialog : Form, ILineShipDialog

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: LineShipDialog (in LineShipDialog.dll)

See Also

LineShipDialog Members | Aptify.Applications.OrderEntry Namespace


LineShipDialog Members

LineShipDialog overview

Public Instance Constructors

LineShipDialog Constructor Initializes a new instance of the LineShipDialog class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
KitPartRowBackColor | Property used to alter the color of the background for kit products.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Configure | Method used to configure the dialog. Requires a valid reference to an AptifyApplication object.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
ShowUI | Method used to display the dialog. Returns a value of DialogResult upon completion.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

Application | Reference to the AptifyApplication object.
AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CancelClicked | Called when the user clicks Cancel on the Line Ship Dialog
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetLocationName | Overloaded. Returns the NameWOrg of the Inventory Locaition corresponding to the InventoryLocationID
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
LoadInventoryLocations | Method used to retrieve the inventory locations for a given product from the database and load them into a dropdown which is contained in the grid.
LoadOrderLines | Loads a grid based on the information in the OrderObject.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OKClicked | Called when the user clicks OK on the Line Ship Dialog
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
ShowInventoryLocationEditor | Method used to determine if the inventory location dropdown is appropriate or not. If so, it calls the LoadInventoryLocations method to actually populate the editor.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateKitPartQuantities | Method used to handle updating of kit parts. The quantity for each kit part is managed in this method.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

LineShipDialog Class | Aptify.Applications.OrderEntry Namespace


LineShipDialog Constructor

Initializes a new instance of the LineShipDialog class.

public LineShipDialog();

See Also

LineShipDialog Class | Aptify.Applications.OrderEntry Namespace


LineShipDialog Properties

The properties of the LineShipDialog class are listed below. For a complete list of LineShipDialog class members, see the LineShipDialog Members topic.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
KitPartRowBackColor | Property used to alter the color of the background for kit products.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Protected Instance Properties

Application | Reference to the AptifyApplication object.
AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

LineShipDialog Class | Aptify.Applications.OrderEntry Namespace


Application Property

Aptify 5.0 Software Development Kit (SDK)

LineShipDialog.Application Property

Reference to the AptifyApplication object.

protected virtual AptifyApplication Application {get; set;}

Property Value

Remarks

See Also

LineShipDialog Class | Aptify.Applications.OrderEntry Namespace


KitPartRowBackColor Property

Aptify 5.0 Software Development Kit (SDK)

LineShipDialog.KitPartRowBackColor Property

Property used to alter the color of the background for kit products.

public Color KitPartRowBackColor {get; set;}

Property Value

Remarks

See Also

LineShipDialog Class | Aptify.Applications.OrderEntry Namespace


LineShipDialog Methods

The methods of the LineShipDialog class are listed below. For a complete list of LineShipDialog class members, see the LineShipDialog Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Configure | Method used to configure the dialog. Requires a valid reference to an AptifyApplication object.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
ShowUI | Method used to display the dialog. Returns a value of DialogResult upon completion.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CancelClicked | Called when the user clicks Cancel on the Line Ship Dialog
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetLocationName | Overloaded. Returns the NameWOrg of the Inventory Locaition corresponding to the InventoryLocationID
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
LoadInventoryLocations | Method used to retrieve the inventory locations for a given product from the database and load them into a dropdown which is contained in the grid.
LoadOrderLines | Loads a grid based on the information in the OrderObject.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OKClicked | Called when the user clicks OK on the Line Ship Dialog
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
ShowInventoryLocationEditor | Method used to determine if the inventory location dropdown is appropriate or not. If so, it calls the LoadInventoryLocations method to actually populate the editor.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateKitPartQuantities | Method used to handle updating of kit parts. The quantity for each kit part is managed in this method.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

LineShipDialog Class | Aptify.Applications.OrderEntry Namespace


LineShipDialog.CancelClicked Method

Called when the user clicks Cancel on the Line Ship Dialog

protected virtual bool CancelClicked();

Remarks

Sets the Dialog Result and closes the window.

See Also

LineShipDialog Class | Aptify.Applications.OrderEntry Namespace


LineShipDialog.Configure Method

Method used to configure the dialog. Requires a valid reference to an AptifyApplication object.

public bool Configure(
AptifyApplication Application
);

Parameters

Application

Return Value

Implements

ILineShipDialog.

Remarks

See Also

LineShipDialog Class | Aptify.Applications.OrderEntry Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

LineShipDialog.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

LineShipDialog Class | Aptify.Applications.OrderEntry Namespace


LineShipDialog.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

LineShipDialog Class | Aptify.Applications.OrderEntry Namespace | LineShipDialog.Dispose Overload List


GetLocationName Method

Aptify 5.0 Software Development Kit (SDK)

LineShipDialog.GetLocationName Method

Returns the NameWOrg of the Inventory Locaition corresponding to the InventoryLocationID

Overload List

Returns the NameWOrg of the Inventory Locaition corresponding to the InventoryLocationID

protected virtual string GetLocationName(Int64);

Returns the NameWOrg of the Inventory Locaition corresponding to the InventoryLocationID

protected virtual string GetLocationName(Int64,Int64);

See Also

LineShipDialog Class | Aptify.Applications.OrderEntry Namespace


LineShipDialog.GetLocationName Method (Int64)

Returns the NameWOrg of the Inventory Locaition corresponding to the InventoryLocationID

protected virtual string GetLocationName(
Int64 InventoryLocationID
);

Parameters

InventoryLocationID

Return Value

Remarks

See Also

LineShipDialog Class | Aptify.Applications.OrderEntry Namespace | LineShipDialog.GetLocationName Overload List


LineShipDialog.GetLocationName Method (Int64, Int64)

Returns the NameWOrg of the Inventory Locaition corresponding to the InventoryLocationID

protected virtual string GetLocationName(
Int64 InventoryLocationID,
Int64 ProductID
);

Parameters

InventoryLocationID
ProductID

Return Value

Remarks

If the InventoryLocationId cannot be found, it will return the first inventory Location associated with the ProductID

See Also

LineShipDialog Class | Aptify.Applications.OrderEntry Namespace | LineShipDialog.GetLocationName Overload List


LineShipDialog.LoadInventoryLocations Method

Method used to retrieve the inventory locations for a given product from the database and load them into a dropdown which is contained in the grid.

protected virtual bool LoadInventoryLocations(
Int64 ProductID,
Int64 InventoryLocationID
);

Parameters

ProductID
InventoryLocationID

Return Value

Remarks

See Also

LineShipDialog Class | Aptify.Applications.OrderEntry Namespace


LineShipDialog.LoadOrderLines Method

Loads a grid based on the information in the OrderObject.

protected virtual void LoadOrderLines(
OrdersEntity OrderObject,
C1FlexGrid TargetGrid
);

Parameters

OrderObject
TargetGrid

Remarks

This will only load line items, that have products that allow back orders.

See Also

LineShipDialog Class | Aptify.Applications.OrderEntry Namespace | AllowBackorders


LineShipDialog.OKClicked Method

Called when the user clicks OK on the Line Ship Dialog

protected virtual bool OKClicked(
C1FlexGrid LineShipGrid
);

Remarks

Sets the Dialog Result and closes the window.

See Also

LineShipDialog Class | Aptify.Applications.OrderEntry Namespace


LineShipDialog.ShowInventoryLocationEditor Method

Method used to determine if the inventory location dropdown is appropriate or not. If so, it calls the LoadInventoryLocations method to actually populate the editor.

protected virtual bool ShowInventoryLocationEditor(
Int32 Column,
Int32 Row
);

Parameters

Column
Row

Return Value

Remarks

See Also

LineShipDialog Class | Aptify.Applications.OrderEntry Namespace


LineShipDialog.ShowUI Method

Method used to display the dialog. Returns a value of DialogResult upon completion.

public DialogResult ShowUI(
OrdersEntity OrderObject
);

Parameters

OrderObject

Return Value

Implements

ILineShipDialog.

Remarks

See Also

LineShipDialog Class | Aptify.Applications.OrderEntry Namespace


LineShipDialog.UpdateKitPartQuantities Method

Method used to handle updating of kit parts. The quantity for each kit part is managed in this method.

protected virtual void UpdateKitPartQuantities(
Int32 KitRow,
OrderLinesEntity KitOrderLine
);

Parameters

KitRow
KitOrderLine

Remarks

See Also

LineShipDialog Class | Aptify.Applications.OrderEntry Namespace


OrderAddressFlowdown Class

This object implements the Aptify.Framework.Applications.OrderEntry.IOrderAddressFlowdown interface. The purpose of this component is to handle the flow down of information in orders.

For a list of all members of this type, see OrderAddressFlowdown Members.

System.Object
OrderAddressFlowdown

public class OrderAddressFlowdown : IOrderAddressFlowdown

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: OrderAddressFlowdown (in OrderAddressFlowdown.dll)

See Also

OrderAddressFlowdown Members | Aptify.Applications.OrderEntry Namespace


OrderAddressFlowdown Members

OrderAddressFlowdown overview

Public Instance Constructors

OrderAddressFlowdown Constructor Initializes a new instance of the OrderAddressFlowdown class.

Public Instance Methods

Config |
DoBillToFlowdown | Overloaded.
DoShipToFlowdown | Overloaded.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

Application | Returns an instance of the Aptify Application object
DataAction | Returns an instance of the Data Action class
Database | Returns the name of the database where the Orders entity is stored
PreferredAddress | Returns an instance of the object that handles preferred address selection

Protected Instance Methods

DeterminePreferredCurrency | Sets the Order's Currency Type based on either the Bill To Company's Preferred Currency Type. If the Bill To Company does not have a Preferred Currency Type or the Bill To Company is not specified on the Order, the Bill To Person's Preferred Currency Type will be used. If the Bill To Person does not have a Preferred Currency Type, the Functional Currency of the Order's Organization will be used. If the Organization's Functional Currecy can not be determined, the Order's Order's default value for CurrencyTypeID will be used. If the Order's CurrencyTypeID has no default value, the Order will be set to the system's Functional Currency. Called by the DoBillToFlowdown method
DoLastPaymentInfoFlowdown | This method is responsible for flowing down the last pamyment method from the individual to the order. This method uses the stored procedure spGetPersonLastOrderPaymentInfo to return the Payment Information from the Person's latest Order. Flowdown of Last Payment Method Information will not occur if the Order's Status is Shipped.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

OrderAddressFlowdown Class | Aptify.Applications.OrderEntry Namespace


OrderAddressFlowdown Constructor

Initializes a new instance of the OrderAddressFlowdown class.

public OrderAddressFlowdown();

See Also

OrderAddressFlowdown Class | Aptify.Applications.OrderEntry Namespace


OrderAddressFlowdown Properties

The properties of the OrderAddressFlowdown class are listed below. For a complete list of OrderAddressFlowdown class members, see the OrderAddressFlowdown Members topic.

Protected Instance Properties

Application | Returns an instance of the Aptify Application object
DataAction | Returns an instance of the Data Action class
Database | Returns the name of the database where the Orders entity is stored
PreferredAddress | Returns an instance of the object that handles preferred address selection

See Also

OrderAddressFlowdown Class | Aptify.Applications.OrderEntry Namespace


Application Property

Aptify 5.0 Software Development Kit (SDK)

OrderAddressFlowdown.Application Property

Returns an instance of the Aptify Application object

protected AptifyApplication Application {get;}

Property Value

Remarks

See Also

OrderAddressFlowdown Class | Aptify.Applications.OrderEntry Namespace


DataAction Property

Aptify 5.0 Software Development Kit (SDK)

OrderAddressFlowdown.DataAction Property

Returns an instance of the Data Action class

protected DataAction DataAction {get;}

Property Value

Remarks

See Also

OrderAddressFlowdown Class | Aptify.Applications.OrderEntry Namespace


Database Property

Aptify 5.0 Software Development Kit (SDK)

OrderAddressFlowdown.Database Property

Returns the name of the database where the Orders entity is stored

protected String Database {get;}

Property Value

Remarks

See Also

OrderAddressFlowdown Class | Aptify.Applications.OrderEntry Namespace


PreferredAddress Property

Aptify 5.0 Software Development Kit (SDK)

OrderAddressFlowdown.PreferredAddress Property

Returns an instance of the object that handles preferred address selection

protected PreferredAddress PreferredAddress {get;}

Property Value

Remarks

See Also

OrderAddressFlowdown Class | Aptify.Applications.OrderEntry Namespace


OrderAddressFlowdown Methods

The methods of the OrderAddressFlowdown class are listed below. For a complete list of OrderAddressFlowdown class members, see the OrderAddressFlowdown Members topic.

Public Instance Methods

Config |
DoBillToFlowdown | Overloaded.
DoShipToFlowdown | Overloaded.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

DeterminePreferredCurrency | Sets the Order's Currency Type based on either the Bill To Company's Preferred Currency Type. If the Bill To Company does not have a Preferred Currency Type or the Bill To Company is not specified on the Order, the Bill To Person's Preferred Currency Type will be used. If the Bill To Person does not have a Preferred Currency Type, the Functional Currency of the Order's Organization will be used. If the Organization's Functional Currecy can not be determined, the Order's Order's default value for CurrencyTypeID will be used. If the Order's CurrencyTypeID has no default value, the Order will be set to the system's Functional Currency. Called by the DoBillToFlowdown method
DoLastPaymentInfoFlowdown | This method is responsible for flowing down the last pamyment method from the individual to the order. This method uses the stored procedure spGetPersonLastOrderPaymentInfo to return the Payment Information from the Person's latest Order. Flowdown of Last Payment Method Information will not occur if the Order's Status is Shipped.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

OrderAddressFlowdown Class | Aptify.Applications.OrderEntry Namespace


OrderAddressFlowdown.Config Method

public virtual void Config(
AptifyApplication Application
);

Implements

IOrderAddressFlowdown.

See Also

OrderAddressFlowdown Class | Aptify.Applications.OrderEntry Namespace


OrderAddressFlowdown.DeterminePreferredCurrency Method

Sets the Order's Currency Type based on either the Bill To Company's Preferred Currency Type. If the Bill To Company does not have a Preferred Currency Type or the Bill To Company is not specified on the Order, the Bill To Person's Preferred Currency Type will be used. If the Bill To Person does not have a Preferred Currency Type, the Functional Currency of the Order's Organization will be used. If the Organization's Functional Currecy can not be determined, the Order's Order's default value for CurrencyTypeID will be used. If the Order's CurrencyTypeID has no default value, the Order will be set to the system's Functional Currency. Called by the DoBillToFlowdown method

protected virtual void DeterminePreferredCurrency(
OrdersEntity OrderGE,
Int32 PersonPreferredCurrencyTypeID
);

Parameters

OrderGE
PersonPreferredCurrencyTypeID

Remarks

See Also

OrderAddressFlowdown Class | Aptify.Applications.OrderEntry Namespace


DoBillToFlowdown Method

Aptify 5.0 Software Development Kit (SDK)

OrderAddressFlowdown.DoBillToFlowdown Method

Overload List

public virtual bool DoBillToFlowdown(OrdersEntity);

public virtual bool DoBillToFlowdown(OrdersEntity,Boolean);

See Also

OrderAddressFlowdown Class | Aptify.Applications.OrderEntry Namespace


OrderAddressFlowdown.DoBillToFlowdown Method (OrdersEntity)

public virtual bool DoBillToFlowdown(
OrdersEntity OrderGE
);

Implements

IOrderAddressFlowdown.

See Also

OrderAddressFlowdown Class | Aptify.Applications.OrderEntry Namespace | OrderAddressFlowdown.DoBillToFlowdown Overload List


OrderAddressFlowdown.DoBillToFlowdown Method (OrdersEntity, Boolean)

public virtual bool DoBillToFlowdown(
OrdersEntity OrderGE,
Boolean BlankCompanyOK
);

Implements

IOrderAddressFlowdown.

See Also

OrderAddressFlowdown Class | Aptify.Applications.OrderEntry Namespace | OrderAddressFlowdown.DoBillToFlowdown Overload List


OrderAddressFlowdown.DoLastPaymentInfoFlowdown Method

This method is responsible for flowing down the last pamyment method from the individual to the order. This method uses the stored procedure spGetPersonLastOrderPaymentInfo to return the Payment Information from the Person's latest Order. Flowdown of Last Payment Method Information will not occur if the Order's Status is Shipped.

protected virtual bool DoLastPaymentInfoFlowdown(
AptifyGenericEntityBase OrderGE
);

Parameters

OrderGE

Return Value

Remarks

See Also

OrderAddressFlowdown Class | Aptify.Applications.OrderEntry Namespace


DoShipToFlowdown Method

Aptify 5.0 Software Development Kit (SDK)

OrderAddressFlowdown.DoShipToFlowdown Method

Overload List

public virtual bool DoShipToFlowdown(OrdersEntity);

public virtual bool DoShipToFlowdown(OrdersEntity,Boolean);

See Also

OrderAddressFlowdown Class | Aptify.Applications.OrderEntry Namespace


OrderAddressFlowdown.DoShipToFlowdown Method (OrdersEntity)

public virtual bool DoShipToFlowdown(
OrdersEntity OrderGE
);

Implements

IOrderAddressFlowdown.

See Also

OrderAddressFlowdown Class | Aptify.Applications.OrderEntry Namespace | OrderAddressFlowdown.DoShipToFlowdown Overload List


OrderAddressFlowdown.DoShipToFlowdown Method (OrdersEntity, Boolean)

public virtual bool DoShipToFlowdown(
OrdersEntity OrderGE,
Boolean BlankCompanyOK
);

Implements

IOrderAddressFlowdown.

See Also

OrderAddressFlowdown Class | Aptify.Applications.OrderEntry Namespace | OrderAddressFlowdown.DoShipToFlowdown Overload List


OrderAddressInfo Class

For a list of all members of this type, see OrderAddressInfo Members.

System.Object
AddressInfo
OrderAddressInfo

public class OrderAddressInfo : AddressInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

OrderAddressInfo Members | Aptify.Applications.OrderEntry Namespace


OrderAddressInfo Members

OrderAddressInfo overview

Public Instance Constructors

OrderAddressInfo Constructor

Public Instance Properties

AddressName |
AddressSource |
AptifyCountryID (inherited from AddressInfo) |
Attributes (inherited from AddressInfo) | Property which exposes attributes as key/value pairs. The purpose of this dictionary is to allow additional attributes to be added to the AddressInfo object, such as new fields which have been added to the Addresses entity.
City (inherited from AddressInfo) |
Country (inherited from AddressInfo) |
CountryTelephoneCode (inherited from AddressInfo) |
County (inherited from AddressInfo) |
ID (inherited from AddressInfo) |
ISOCountryCode (inherited from AddressInfo) |
Line1 (inherited from AddressInfo) |
Line2 (inherited from AddressInfo) |
Line3 (inherited from AddressInfo) |
Line4 (inherited from AddressInfo) |
PostalCode (inherited from AddressInfo) |
StateProvince (inherited from AddressInfo) |
SuggestedAddress (inherited from AddressInfo) |
SuggestedAddresses (inherited from AddressInfo) |
SuggestedAddressExists (inherited from AddressInfo) |
USCongress (inherited from AddressInfo) |

Public Instance Methods

AptifyCountryIDExists (inherited from AddressInfo) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAddressVerifySystemID (inherited from AddressInfo) | Returns info class for the Address Verification System to be used for the Aptify Country Code ID specified
GetAddressVerifySystemInfo (inherited from AddressInfo) | Returns info class for the Address Verification System to be used for the CURRENT address(based on country)
GetAptifyCountryIDFromCountryName (inherited from AddressInfo) |
GetAptifyCountryIDFromISOCode (inherited from AddressInfo) |
GetAptifyCountryIDFromTelephoneCode (inherited from AddressInfo) |
GetCountryName (inherited from AddressInfo) | Overloaded.
GetCountryNameFromTelephoneCode (inherited from AddressInfo) |
GetCountyFromPostalCode (inherited from AddressInfo) | Returns the name of a county for a given postal code and ISO Country Code
GetCountyFromZIPCode (inherited from AddressInfo) | Returns the Name of a county within the United States where a particular US Zip Code is located. This function is to be used only for US Zip Codes. For Postal Codes outside of the US, use the GetCountyFromPostalCode function instead.
GetDefaultLabelLines (inherited from AddressInfo) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetISOCode (inherited from AddressInfo) | Overloaded.
GetISOCodeFromTelephoneCode (inherited from AddressInfo) |
GetLabelLinesForCountry (inherited from AddressInfo) | Overloaded.
GetLabelLinesForCountryFromCountryName (inherited from AddressInfo) |
GetLabelText (inherited from AddressInfo) | Returns a single string that contains the text for a label based on the values in the current address info object instance
GetLabelTextLines (inherited from AddressInfo) | Returns a string array with one element for each line that contains the text for a label based on the values in the current address info object instance
GetTelephoneCode (inherited from AddressInfo) | Overloaded.
GetTelephoneCodeFromCountryName (inherited from AddressInfo) |
GetType (inherited from Object) | Gets the Type of the current instance.
LoadFromDataRow (inherited from AddressInfo) | This function sets the values in the Address Info Class Based on Values in the Data Row. The Data Row Object passed in is assumed to be loaded up with a valid record from the Addresses Entity.
LoadFromGE (inherited from AddressInfo) | This function sets the values in the Address Info Class Based on Values in the GE Object. The GE Object passed in is assumed to be loaded up with a valid instance of a Addresses Entity Record.
ParsePopulateString (inherited from AddressInfo) |
SetValuesInGE (inherited from AddressInfo) | This function sets the values in the GE Class passed on based on the valeus that are currently in the Address Info Class. The GE Object passed in is assumed to be loaded up with a valid instance of a Addresses Entity Record.
ToString (inherited from Object) | Returns a String that represents the current Object.
Verify (inherited from AddressInfo) | Verifies the address using the the IAptifyAddressVerify interface and the meta-data in the Address Verification Systems entity

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

OrderAddressInfo Class | Aptify.Applications.OrderEntry Namespace


OrderAddressInfo Constructor

public OrderAddressInfo(
AptifyApplication Application,
DataRow DataRow
);

See Also

OrderAddressInfo Class | Aptify.Applications.OrderEntry Namespace


OrderAddressInfo Properties

The properties of the OrderAddressInfo class are listed below. For a complete list of OrderAddressInfo class members, see the OrderAddressInfo Members topic.

Public Instance Properties

AddressName |
AddressSource |
AptifyCountryID (inherited from AddressInfo) |
Attributes (inherited from AddressInfo) | Property which exposes attributes as key/value pairs. The purpose of this dictionary is to allow additional attributes to be added to the AddressInfo object, such as new fields which have been added to the Addresses entity.
City (inherited from AddressInfo) |
Country (inherited from AddressInfo) |
CountryTelephoneCode (inherited from AddressInfo) |
County (inherited from AddressInfo) |
ID (inherited from AddressInfo) |
ISOCountryCode (inherited from AddressInfo) |
Line1 (inherited from AddressInfo) |
Line2 (inherited from AddressInfo) |
Line3 (inherited from AddressInfo) |
Line4 (inherited from AddressInfo) |
PostalCode (inherited from AddressInfo) |
StateProvince (inherited from AddressInfo) |
SuggestedAddress (inherited from AddressInfo) |
SuggestedAddresses (inherited from AddressInfo) |
SuggestedAddressExists (inherited from AddressInfo) |
USCongress (inherited from AddressInfo) |

See Also

OrderAddressInfo Class | Aptify.Applications.OrderEntry Namespace


AddressName Property

Aptify 5.0 Software Development Kit (SDK)

OrderAddressInfo.AddressName Property

public String AddressName {get; set;}

See Also

OrderAddressInfo Class | Aptify.Applications.OrderEntry Namespace


AddressSource Property

Aptify 5.0 Software Development Kit (SDK)

OrderAddressInfo.AddressSource Property

public String AddressSource {get; set;}

See Also

OrderAddressInfo Class | Aptify.Applications.OrderEntry Namespace


OrderAddressUtility Class

For a list of all members of this type, see OrderAddressUtility Members.

System.Object
OrderAddressUtility

public class OrderAddressUtility

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

OrderAddressUtility Members | Aptify.Applications.OrderEntry Namespace


OrderAddressUtility Members

OrderAddressUtility overview

Public Instance Constructors

OrderAddressUtility Constructor

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
LoadRelatedAddresses |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ProcessRelatedAddressTable |

See Also

OrderAddressUtility Class | Aptify.Applications.OrderEntry Namespace


OrderAddressUtility Constructor

public OrderAddressUtility(
AptifyApplication Application
);

See Also

OrderAddressUtility Class | Aptify.Applications.OrderEntry Namespace


OrderAddressUtility Methods

The methods of the OrderAddressUtility class are listed below. For a complete list of OrderAddressUtility class members, see the OrderAddressUtility Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
LoadRelatedAddresses |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ProcessRelatedAddressTable |

See Also

OrderAddressUtility Class | Aptify.Applications.OrderEntry Namespace


OrderAddressUtility.LoadRelatedAddresses Method

public virtual Dictionary<TKey,TValue> LoadRelatedAddresses(
Int64 BillToID,
Int64 BillToCompanyID,
Int64 ShipToID,
Int64 ShipToCompanyID
);

See Also

OrderAddressUtility Class | Aptify.Applications.OrderEntry Namespace


OrderAddressUtility.ProcessRelatedAddressTable Method

protected virtual void ProcessRelatedAddressTable(
DataTable Table,
String Source,
Dictionary<TKey,TValue> AddressInfos
);

See Also

OrderAddressUtility Class | Aptify.Applications.OrderEntry Namespace


OrderBoothDetailEntity Class

For a list of all members of this type, see OrderBoothDetailEntity Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
ExtendedOrderDetailGE
OrderBoothDetailEntity

public class OrderBoothDetailEntity : ExtendedOrderDetailGE

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOBDEntity (in AptifyOBDEntity.dll)

See Also

OrderBoothDetailEntity Members | Aptify.Applications.OrderEntry Namespace


OrderBoothDetailEntity Members

OrderBoothDetailEntity overview

Public Instance Constructors

OrderBoothDetailEntity Constructor Initializes a new instance of the OrderBoothDetailEntity class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
Booth |
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
OrderLineGE |
ParentGE (inherited from ExtendedOrderDetailGE) |
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from ExtendedOrderDetailGE) |
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config | Overloaded.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete | Overloaded.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
FlowdownForAddCancellationOrderLine |
FlowdownForAddProductToOrder |
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from ExtendedOrderDetailGE) | Overloaded.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LoadBoothInfo | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from ExtendedOrderDetailGE) |
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from ExtendedOrderDetailGE) | Overloaded. Attempts to save the Current GE data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveCancellationData |
SaveCancelledData (inherited from ExtendedOrderDetailGE) | Called during the Order Save process in the OrdersEntity's SaveCancellationData method. It is designed to be overridden when the extended Order Detail Entity needs to perform some work related to the the Order Line when the Order status has been changed to Cancelled. This is called to preform special handling on the orderline, if there is a need to changed information after the order status has been changed to cancelled. This allows, for example, the removal of a customer from a meeting detail record.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetExtendedOrderDetailRecordID (inherited from ExtendedOrderDetailGE) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.
ValidateBoothUnitQty |

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
ResetFieldsLinkedToOrderLine (inherited from ExtendedOrderDetailGE) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

OrderBoothDetailEntity Class | Aptify.Applications.OrderEntry Namespace


OrderBoothDetailEntity Constructor

Initializes a new instance of the OrderBoothDetailEntity class.

public OrderBoothDetailEntity();

See Also

OrderBoothDetailEntity Class | Aptify.Applications.OrderEntry Namespace


OrderBoothDetailEntity Properties

The properties of the OrderBoothDetailEntity class are listed below. For a complete list of OrderBoothDetailEntity class members, see the OrderBoothDetailEntity Members topic.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
Booth |
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
OrderLineGE |
ParentGE (inherited from ExtendedOrderDetailGE) |
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from ExtendedOrderDetailGE) |
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

OrderBoothDetailEntity Class | Aptify.Applications.OrderEntry Namespace


Booth Property

Aptify 5.0 Software Development Kit (SDK)

OrderBoothDetailEntity.Booth Property

public BoothInfo Booth {get;}

See Also

OrderBoothDetailEntity Class | Aptify.Applications.OrderEntry Namespace


OrderLineGE Property

Aptify 5.0 Software Development Kit (SDK)

OrderBoothDetailEntity.OrderLineGE Property

public override OrderLinesEntity OrderLineGE {get; set;}

See Also

OrderBoothDetailEntity Class | Aptify.Applications.OrderEntry Namespace


OrderBoothDetailEntity Methods

The methods of the OrderBoothDetailEntity class are listed below. For a complete list of OrderBoothDetailEntity class members, see the OrderBoothDetailEntity Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config | Overloaded.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete | Overloaded.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
FlowdownForAddCancellationOrderLine |
FlowdownForAddProductToOrder |
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from ExtendedOrderDetailGE) | Overloaded.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LoadBoothInfo | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from ExtendedOrderDetailGE) |
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from ExtendedOrderDetailGE) | Overloaded. Attempts to save the Current GE data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveCancellationData |
SaveCancelledData (inherited from ExtendedOrderDetailGE) | Called during the Order Save process in the OrdersEntity's SaveCancellationData method. It is designed to be overridden when the extended Order Detail Entity needs to perform some work related to the the Order Line when the Order status has been changed to Cancelled. This is called to preform special handling on the orderline, if there is a need to changed information after the order status has been changed to cancelled. This allows, for example, the removal of a customer from a meeting detail record.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetExtendedOrderDetailRecordID (inherited from ExtendedOrderDetailGE) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.
ValidateBoothUnitQty |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
ResetFieldsLinkedToOrderLine (inherited from ExtendedOrderDetailGE) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

OrderBoothDetailEntity Class | Aptify.Applications.OrderEntry Namespace


Config Method

Aptify 5.0 Software Development Kit (SDK)

OrderBoothDetailEntity.Config Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual void Config(AptifySubTypeBase);

Inherited from AptifyGenericEntity.

public override void Config(AptifySubTypeBase,Int64);

Inherited from AptifyGenericEntityBase.

public virtual void Config(UserCredentials,String);

public override void Config(UserCredentials,String,Int64);

See Also

OrderBoothDetailEntity Class | Aptify.Applications.OrderEntry Namespace


OrderBoothDetailEntity.Config Method (UserCredentials, String, Int64)

public override void Config(
UserCredentials UserCredentials,
String EntityName,
Int64 RecordID
);

See Also

OrderBoothDetailEntity Class | Aptify.Applications.OrderEntry Namespace | OrderBoothDetailEntity.Config Overload List


Delete Method

Aptify 5.0 Software Development Kit (SDK)

OrderBoothDetailEntity.Delete Method

Overload List

public override bool Delete();

Inherited from AptifyGenericEntity.

public override bool Delete(String);

See Also

OrderBoothDetailEntity Class | Aptify.Applications.OrderEntry Namespace


OrderBoothDetailEntity.Delete Method ()

public override bool Delete();

See Also

OrderBoothDetailEntity Class | Aptify.Applications.OrderEntry Namespace | OrderBoothDetailEntity.Delete Overload List


OrderBoothDetailEntity.FlowdownForAddCancellationOrderLine Method

public override bool FlowdownForAddCancellationOrderLine();

See Also

OrderBoothDetailEntity Class | Aptify.Applications.OrderEntry Namespace


OrderBoothDetailEntity.FlowdownForAddProductToOrder Method

public override bool FlowdownForAddProductToOrder();

See Also

OrderBoothDetailEntity Class | Aptify.Applications.OrderEntry Namespace


LoadBoothInfo Method

Aptify 5.0 Software Development Kit (SDK)

OrderBoothDetailEntity.LoadBoothInfo Method

Overload List

public void LoadBoothInfo();

public void LoadBoothInfo(Int64);

See Also

OrderBoothDetailEntity Class | Aptify.Applications.OrderEntry Namespace


OrderBoothDetailEntity.LoadBoothInfo Method ()

public void LoadBoothInfo();

See Also

OrderBoothDetailEntity Class | Aptify.Applications.OrderEntry Namespace | OrderBoothDetailEntity.LoadBoothInfo Overload List


OrderBoothDetailEntity.LoadBoothInfo Method (Int64)

public void LoadBoothInfo(
Int64 lBoothID
);

See Also

OrderBoothDetailEntity Class | Aptify.Applications.OrderEntry Namespace | OrderBoothDetailEntity.LoadBoothInfo Overload List


OrderBoothDetailEntity.SaveCancellationData Method

public override bool SaveCancellationData(
Boolean AllowGUI
);

See Also

OrderBoothDetailEntity Class | Aptify.Applications.OrderEntry Namespace


Validate Method

Aptify 5.0 Software Development Kit (SDK)

OrderBoothDetailEntity.Validate Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Validate();

public override bool Validate(ref String&);

See Also

OrderBoothDetailEntity Class | Aptify.Applications.OrderEntry Namespace


OrderBoothDetailEntity.Validate Method (String&)

public override bool Validate(
ref String& ErrorString
);

See Also

OrderBoothDetailEntity Class | Aptify.Applications.OrderEntry Namespace | OrderBoothDetailEntity.Validate Overload List


OrderBoothDetailEntity.ValidateBoothUnitQty Method

public virtual bool ValidateBoothUnitQty(
ref String& ErrorString
);

See Also

OrderBoothDetailEntity Class | Aptify.Applications.OrderEntry Namespace


OrderCancellationDetail Class

For a list of all members of this type, see OrderCancellationDetail Members.

System.Object
OrderCancellationDetail

public class OrderCancellationDetail

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

OrderCancellationDetail Members | Aptify.Applications.OrderEntry Namespace


OrderCancellationDetail Members

OrderCancellationDetail overview

Public Instance Constructors

OrderCancellationDetail Overloaded. Initializes a new instance of the OrderCancellationDetail class.

Public Instance Properties

Discount
OriginalOrderDetailID
Price
ProductID
PurchaseType
QuantityAlreadyCancelled
QuantityAvailableForCancellation
QuantityShipped
RecipientID
ShipToAddressID
ShipToID
ShipTypeID
SubscriptionCopies
TaxIncludedInPrice

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

OrderCancellationDetail Class | Aptify.Applications.OrderEntry Namespace


OrderCancellationDetail Constructor

Overload List

public OrderCancellationDetail(Int64,Int64,Decimal,Decimal,Decimal,Boolean,Decimal,Int32,String,Int64);

public OrderCancellationDetail(Int64,Int64,Decimal,Decimal,Decimal,Boolean,Decimal,Int32,String,Int64,Int64,Int64,Int64);

See Also

OrderCancellationDetail Class | Aptify.Applications.OrderEntry Namespace


OrderCancellationDetail Constructor (Int64, Int64, Decimal, Decimal, Decimal, Boolean, Decimal, Int32, String, Int64)

public OrderCancellationDetail(
Int64 OriginalOrderDetailID,
Int64 ProductID,
Decimal QuantityShipped,
Decimal QuantityAlreadyCancelled,
Decimal Price,
Boolean TaxIncludedInPrice,
Decimal Discount,
Int32 SubscriptionCopies,
String PurchaseType,
Int64 RecipientID
);

See Also

OrderCancellationDetail Class | Aptify.Applications.OrderEntry Namespace | OrderCancellationDetail Constructor Overload List


OrderCancellationDetail Constructor (Int64, Int64, Decimal, Decimal, Decimal, Boolean, Decimal, Int32, String, Int64, Int64, Int64, Int64)

public OrderCancellationDetail(
Int64 OriginalOrderDetailID,
Int64 ProductID,
Decimal QuantityShipped,
Decimal QuantityAlreadyCancelled,
Decimal Price,
Boolean TaxIncludedInPrice,
Decimal Discount,
Int32 SubscriptionCopies,
String PurchaseType,
Int64 RecipientID,
Int64 ShipToID,
Int64 ShipToAddressID,
Int64 ShipTypeID
);

See Also

OrderCancellationDetail Class | Aptify.Applications.OrderEntry Namespace | OrderCancellationDetail Constructor Overload List


OrderCancellationDetail Properties

The properties of the OrderCancellationDetail class are listed below. For a complete list of OrderCancellationDetail class members, see the OrderCancellationDetail Members topic.

Public Instance Properties

Discount
OriginalOrderDetailID
Price
ProductID
PurchaseType
QuantityAlreadyCancelled
QuantityAvailableForCancellation
QuantityShipped
RecipientID
ShipToAddressID
ShipToID
ShipTypeID
SubscriptionCopies
TaxIncludedInPrice

See Also

OrderCancellationDetail Class | Aptify.Applications.OrderEntry Namespace


Discount Property

Aptify 5.0 Software Development Kit (SDK)

OrderCancellationDetail.Discount Property

public Decimal Discount {get;}

See Also

OrderCancellationDetail Class | Aptify.Applications.OrderEntry Namespace


OriginalOrderDetailID Property

Aptify 5.0 Software Development Kit (SDK)

OrderCancellationDetail.OriginalOrderDetailID Property

public Int64 OriginalOrderDetailID {get;}

See Also

OrderCancellationDetail Class | Aptify.Applications.OrderEntry Namespace


Price Property

Aptify 5.0 Software Development Kit (SDK)

OrderCancellationDetail.Price Property

public Decimal Price {get;}

See Also

OrderCancellationDetail Class | Aptify.Applications.OrderEntry Namespace


ProductID Property

Aptify 5.0 Software Development Kit (SDK)

OrderCancellationDetail.ProductID Property

public Int64 ProductID {get;}

See Also

OrderCancellationDetail Class | Aptify.Applications.OrderEntry Namespace


PurchaseType Property

Aptify 5.0 Software Development Kit (SDK)

OrderCancellationDetail.PurchaseType Property

public String PurchaseType {get;}

See Also

OrderCancellationDetail Class | Aptify.Applications.OrderEntry Namespace


QuantityAlreadyCancelled Property

Aptify 5.0 Software Development Kit (SDK)

OrderCancellationDetail.QuantityAlreadyCancelled Property

public Decimal QuantityAlreadyCancelled {get;}

See Also

OrderCancellationDetail Class | Aptify.Applications.OrderEntry Namespace


QuantityAvailableForCancellation Property

Aptify 5.0 Software Development Kit (SDK)

OrderCancellationDetail.QuantityAvailableForCancellation Property

public Decimal QuantityAvailableForCancellation {get;}

See Also

OrderCancellationDetail Class | Aptify.Applications.OrderEntry Namespace


QuantityShipped Property

Aptify 5.0 Software Development Kit (SDK)

OrderCancellationDetail.QuantityShipped Property

public Decimal QuantityShipped {get;}

See Also

OrderCancellationDetail Class | Aptify.Applications.OrderEntry Namespace


RecipientID Property

Aptify 5.0 Software Development Kit (SDK)

OrderCancellationDetail.RecipientID Property

public Int64 RecipientID {get;}

See Also

OrderCancellationDetail Class | Aptify.Applications.OrderEntry Namespace


ShipToAddressID Property

Aptify 5.0 Software Development Kit (SDK)

OrderCancellationDetail.ShipToAddressID Property

public Int64 ShipToAddressID {get;}

See Also

OrderCancellationDetail Class | Aptify.Applications.OrderEntry Namespace


ShipToID Property

Aptify 5.0 Software Development Kit (SDK)

OrderCancellationDetail.ShipToID Property

public Int64 ShipToID {get;}

See Also

OrderCancellationDetail Class | Aptify.Applications.OrderEntry Namespace


ShipTypeID Property

Aptify 5.0 Software Development Kit (SDK)

OrderCancellationDetail.ShipTypeID Property

public Int64 ShipTypeID {get;}

See Also

OrderCancellationDetail Class | Aptify.Applications.OrderEntry Namespace


SubscriptionCopies Property

Aptify 5.0 Software Development Kit (SDK)

OrderCancellationDetail.SubscriptionCopies Property

public Int32 SubscriptionCopies {get;}

See Also

OrderCancellationDetail Class | Aptify.Applications.OrderEntry Namespace


TaxIncludedInPrice Property

Aptify 5.0 Software Development Kit (SDK)

OrderCancellationDetail.TaxIncludedInPrice Property

public Boolean TaxIncludedInPrice {get;}

See Also

OrderCancellationDetail Class | Aptify.Applications.OrderEntry Namespace


OrderComponentPlugInDataException Class

Thrown when a Plug-In does not provide the appropriate data to retrieve and instantiate the Plug-In. For example: If an Assembly Name or Class Name is defined for a plug-in, both must be defined.

For a list of all members of this type, see OrderComponentPlugInDataException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
AptifyGenericEntityException
OrderException
OrderComponentPlugInDataException

public class OrderComponentPlugInDataException : OrderException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

OrderComponentPlugInDataException Members | Aptify.Applications.OrderEntry Namespace


OrderComponentPlugInDataException Members

OrderComponentPlugInDataException overview

Public Instance Constructors

OrderComponentPlugInDataException Overloaded. Initializes a new instance of the OrderComponentPlugInDataException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from AptifyGenericEntityException) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

OrderComponentPlugInDataException Class | Aptify.Applications.OrderEntry Namespace


OrderComponentPlugInDataException Constructor

Overload List

public OrderComponentPlugInDataException(SerializationInfo,StreamingContext);

public OrderComponentPlugInDataException(String);

public OrderComponentPlugInDataException(String,Exception);

See Also

OrderComponentPlugInDataException Class | Aptify.Applications.OrderEntry Namespace


OrderComponentPlugInDataException Constructor (String)

public OrderComponentPlugInDataException(
String Message
);

See Also

OrderComponentPlugInDataException Class | Aptify.Applications.OrderEntry Namespace | OrderComponentPlugInDataException Constructor Overload List


OrderComponentPlugInDataException Constructor (String, Exception)

public OrderComponentPlugInDataException(
String Message,
Exception inner
);

See Also

OrderComponentPlugInDataException Class | Aptify.Applications.OrderEntry Namespace | OrderComponentPlugInDataException Constructor Overload List


OrderComponentPlugInDataException Constructor (SerializationInfo, StreamingContext)

public OrderComponentPlugInDataException(
SerializationInfo info,
StreamingContext context
);

See Also

OrderComponentPlugInDataException Class | Aptify.Applications.OrderEntry Namespace | OrderComponentPlugInDataException Constructor Overload List


OrderException Class

For a list of all members of this type, see OrderException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
AptifyGenericEntityException
OrderException
OrderComponentPlugInDataException
OrderRequestedDataNotFound

public class OrderException : AptifyGenericEntityException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

OrderException Members | Aptify.Applications.OrderEntry Namespace


OrderException Members

OrderException overview

Public Instance Constructors

OrderException Overloaded. Initializes a new instance of the OrderException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from AptifyGenericEntityException) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

OrderException Class | Aptify.Applications.OrderEntry Namespace


OrderException Constructor

Overload List

public OrderException(SerializationInfo,StreamingContext);

public OrderException(String);

public OrderException(String,Exception);

See Also

OrderException Class | Aptify.Applications.OrderEntry Namespace


OrderException Constructor (String)

public OrderException(
String Message
);

See Also

OrderException Class | Aptify.Applications.OrderEntry Namespace | OrderException Constructor Overload List


OrderException Constructor (String, Exception)

public OrderException(
String Message,
Exception inner
);

See Also

OrderException Class | Aptify.Applications.OrderEntry Namespace | OrderException Constructor Overload List


OrderException Constructor (SerializationInfo, StreamingContext)

public OrderException(
SerializationInfo info,
StreamingContext context
);

See Also

OrderException Class | Aptify.Applications.OrderEntry Namespace | OrderException Constructor Overload List


OrderExpoDetailLayout Class

The class represents the layout control for the Order Booth Detail form.

For a list of all members of this type, see OrderExpoDetailLayout Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
OrderExpoDetailLayout

public class OrderExpoDetailLayout : FormTemplateLayout

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: OrderExpoDetailControl (in OrderExpoDetailControl.dll)

See Also

OrderExpoDetailLayout Members | Aptify.Applications.OrderEntry Namespace


OrderExpoDetailLayout Members

OrderExpoDetailLayout overview

Public Instance Constructors

OrderExpoDetailLayout Constructor Initializes a new instance of the OrderExpoDetailLayout class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

m_cmbConfig
m_txtBoothName
m_txtNumUnits
m_txtSurcharge

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
m_cmbFloorplanID |
m_cmdConfigureBooth |
m_lnkBoothID |
m_oOrderBoothDetail |
OrderBoothDetailEntity | Reference to the OrderBoothDetailEntity object, which is a subclass of the GE.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControls |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitializeControls |
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFloorplanClick |
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig |
OnFormTemplateLoaded |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlVisibilityForShippedOrder |
SetControlVisibilityForUnshippedOrder |
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
ValidateBoothUnitQtyUpdate |
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

OrderExpoDetailLayout Class | Aptify.Applications.OrderEntry Namespace


OrderExpoDetailLayout Constructor

Initializes a new instance of the OrderExpoDetailLayout class.

public OrderExpoDetailLayout();

See Also

OrderExpoDetailLayout Class | Aptify.Applications.OrderEntry Namespace


OrderExpoDetailLayout Fields

The fields of the OrderExpoDetailLayout class are listed below. For a complete list of OrderExpoDetailLayout class members, see the OrderExpoDetailLayout Members topic.

Protected Instance Fields

m_cmbConfig
m_txtBoothName
m_txtNumUnits
m_txtSurcharge

See Also

OrderExpoDetailLayout Class | Aptify.Applications.OrderEntry Namespace


OrderExpoDetailLayout.m_cmbConfig Field

protected m_cmbConfig m_cmbConfig;

See Also

OrderExpoDetailLayout Class | Aptify.Applications.OrderEntry Namespace


OrderExpoDetailLayout.m_txtBoothName Field

protected m_txtBoothName m_txtBoothName;

See Also

OrderExpoDetailLayout Class | Aptify.Applications.OrderEntry Namespace


OrderExpoDetailLayout.m_txtNumUnits Field

protected m_txtNumUnits m_txtNumUnits;

See Also

OrderExpoDetailLayout Class | Aptify.Applications.OrderEntry Namespace


OrderExpoDetailLayout.m_txtSurcharge Field

protected m_txtSurcharge m_txtSurcharge;

See Also

OrderExpoDetailLayout Class | Aptify.Applications.OrderEntry Namespace


OrderExpoDetailLayout Properties

The properties of the OrderExpoDetailLayout class are listed below. For a complete list of OrderExpoDetailLayout class members, see the OrderExpoDetailLayout Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
m_cmbFloorplanID |
m_cmdConfigureBooth |
m_lnkBoothID |
m_oOrderBoothDetail |
OrderBoothDetailEntity | Reference to the OrderBoothDetailEntity object, which is a subclass of the GE.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

OrderExpoDetailLayout Class | Aptify.Applications.OrderEntry Namespace


m_cmbFloorplanID Property

Aptify 5.0 Software Development Kit (SDK)

OrderExpoDetailLayout.m_cmbFloorplanID Property

protected virtual AptifyDataComboBox m_cmbFloorplanID {get; set;}

See Also

OrderExpoDetailLayout Class | Aptify.Applications.OrderEntry Namespace


m_cmdConfigureBooth Property

Aptify 5.0 Software Development Kit (SDK)

OrderExpoDetailLayout.m_cmdConfigureBooth Property

protected virtual AptifyActiveButton m_cmdConfigureBooth {get; set;}

See Also

OrderExpoDetailLayout Class | Aptify.Applications.OrderEntry Namespace


m_lnkBoothID Property

Aptify 5.0 Software Development Kit (SDK)

OrderExpoDetailLayout.m_lnkBoothID Property

protected virtual AptifyLinkBox m_lnkBoothID {get; set;}

See Also

OrderExpoDetailLayout Class | Aptify.Applications.OrderEntry Namespace


m_oOrderBoothDetail Property

Aptify 5.0 Software Development Kit (SDK)

OrderExpoDetailLayout.m_oOrderBoothDetail Property

protected virtual OrderBoothDetailEntity m_oOrderBoothDetail {get; set;}

See Also

OrderExpoDetailLayout Class | Aptify.Applications.OrderEntry Namespace


OrderBoothDetailEntity Property

Aptify 5.0 Software Development Kit (SDK)

OrderExpoDetailLayout.OrderBoothDetailEntity Property

Reference to the OrderBoothDetailEntity object, which is a subclass of the GE.

protected OrderBoothDetailEntity OrderBoothDetailEntity {get;}

Property Value

Remarks

See Also

OrderExpoDetailLayout Class | Aptify.Applications.OrderEntry Namespace


OrderExpoDetailLayout Methods

The methods of the OrderExpoDetailLayout class are listed below. For a complete list of OrderExpoDetailLayout class members, see the OrderExpoDetailLayout Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControls |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitializeControls |
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFloorplanClick |
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig |
OnFormTemplateLoaded |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlVisibilityForShippedOrder |
SetControlVisibilityForUnshippedOrder |
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
ValidateBoothUnitQtyUpdate |
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

OrderExpoDetailLayout Class | Aptify.Applications.OrderEntry Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

OrderExpoDetailLayout.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

OrderExpoDetailLayout Class | Aptify.Applications.OrderEntry Namespace


OrderExpoDetailLayout.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

OrderExpoDetailLayout Class | Aptify.Applications.OrderEntry Namespace | OrderExpoDetailLayout.Dispose Overload List


OrderExpoDetailLayout.FindControls Method

protected virtual void FindControls();

See Also

OrderExpoDetailLayout Class | Aptify.Applications.OrderEntry Namespace


OrderExpoDetailLayout.InitializeControls Method

protected void InitializeControls();

See Also

OrderExpoDetailLayout Class | Aptify.Applications.OrderEntry Namespace


OrderExpoDetailLayout.OnFloorplanClick Method

protected virtual void OnFloorplanClick();

See Also

OrderExpoDetailLayout Class | Aptify.Applications.OrderEntry Namespace


OrderExpoDetailLayout.OnFormComponentConfig Method

protected override void OnFormComponentConfig(
AptifyFormTemplateContext Context
);

Implements

IFormComponent.

See Also

OrderExpoDetailLayout Class | Aptify.Applications.OrderEntry Namespace


OrderExpoDetailLayout.OnFormTemplateLoaded Method

protected override void OnFormTemplateLoaded(
FormTemplateLayout.FormTemplateLoadedEventArgs e
);

See Also

OrderExpoDetailLayout Class | Aptify.Applications.OrderEntry Namespace


OrderExpoDetailLayout.OnTransferDataToObject Method

protected override void OnTransferDataToObject(
ref Boolean& Cancel
);

Implements

IFormComponent.

See Also

OrderExpoDetailLayout Class | Aptify.Applications.OrderEntry Namespace


OrderExpoDetailLayout.Refresh Method

public override void Refresh();

See Also

OrderExpoDetailLayout Class | Aptify.Applications.OrderEntry Namespace


OrderExpoDetailLayout.SetControlVisibilityForShippedOrder Method

protected virtual void SetControlVisibilityForShippedOrder();

See Also

OrderExpoDetailLayout Class | Aptify.Applications.OrderEntry Namespace


OrderExpoDetailLayout.SetControlVisibilityForUnshippedOrder Method

protected virtual void SetControlVisibilityForUnshippedOrder();

See Also

OrderExpoDetailLayout Class | Aptify.Applications.OrderEntry Namespace


OrderExpoDetailLayout.ValidateBoothUnitQtyUpdate Method

protected virtual void ValidateBoothUnitQtyUpdate(
Int64 lBoothID,
Object OldValue
);

See Also

OrderExpoDetailLayout Class | Aptify.Applications.OrderEntry Namespace


OrderExtraPayment Class

Implements a user interface that provides the user the ability to add extra payment information to an order when a credit memo doesn't pay for the entire order balance

For a list of all members of this type, see OrderExtraPayment Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
OrderExtraPayment

public class OrderExtraPayment : Form, IExtraPaymentDialog

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrderExtraPayment (in AptifyOrderExtraPayment.dll)

See Also

OrderExtraPayment Members | Aptify.Applications.OrderEntry Namespace


OrderExtraPayment Members

OrderExtraPayment overview

Public Instance Constructors

OrderExtraPayment Constructor Initializes a new instance of the OrderExtraPayment class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PaymentGE |
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
ShowExtraPaymentDialog |
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
PopulateAndValidatePayment |
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

OrderExtraPayment Class | Aptify.Applications.OrderEntry Namespace


OrderExtraPayment Constructor

Initializes a new instance of the OrderExtraPayment class.

public OrderExtraPayment();

See Also

OrderExtraPayment Class | Aptify.Applications.OrderEntry Namespace


OrderExtraPayment Properties

The properties of the OrderExtraPayment class are listed below. For a complete list of OrderExtraPayment class members, see the OrderExtraPayment Members topic.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PaymentGE |
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

OrderExtraPayment Class | Aptify.Applications.OrderEntry Namespace


PaymentGE Property

Aptify 5.0 Software Development Kit (SDK)

OrderExtraPayment.PaymentGE Property

public virtual PaymentsEntity PaymentGE {get;}

Implements

IExtraPaymentDialog.

See Also

OrderExtraPayment Class | Aptify.Applications.OrderEntry Namespace


OrderExtraPayment Methods

The methods of the OrderExtraPayment class are listed below. For a complete list of OrderExtraPayment class members, see the OrderExtraPayment Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
ShowExtraPaymentDialog |
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
PopulateAndValidatePayment |
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

OrderExtraPayment Class | Aptify.Applications.OrderEntry Namespace


OrderExtraPayment.Config Method

public bool Config(
AptifyApplication Application
);

Implements

IExtraPaymentDialog.

See Also

OrderExtraPayment Class | Aptify.Applications.OrderEntry Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

OrderExtraPayment.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

OrderExtraPayment Class | Aptify.Applications.OrderEntry Namespace


OrderExtraPayment.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

OrderExtraPayment Class | Aptify.Applications.OrderEntry Namespace | OrderExtraPayment.Dispose Overload List


OrderExtraPayment.PopulateAndValidatePayment Method

protected virtual bool PopulateAndValidatePayment(
ref String& sError
);

See Also

OrderExtraPayment Class | Aptify.Applications.OrderEntry Namespace


OrderExtraPayment.ShowExtraPaymentDialog Method

public virtual DialogResult ShowExtraPaymentDialog(
OrdersEntity Order,
Decimal OrderBalance
);

Implements

IExtraPaymentDialog.

See Also

OrderExtraPayment Class | Aptify.Applications.OrderEntry Namespace


OrderGenerateGL Class

This object implements the Aptify.Applications.Accounting.IGenerateGL interface. The purpose of this component is to generate GL entries for an order

For a list of all members of this type, see OrderGenerateGL Members.

System.Object
OrderGenerateGL

public class OrderGenerateGL : IGenerateGL

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: OrderGenerateGL (in OrderGenerateGL.dll)

See Also

OrderGenerateGL Members | Aptify.Applications.OrderEntry Namespace


OrderGenerateGL Members

OrderGenerateGL overview

Public Instance Constructors

OrderGenerateGL Constructor Initializes a new instance of the OrderGenerateGL class.

Public Instance Methods

Config | This method configures the object for use and must be called before any other member of the class is accessed. This method stores the Application object provided for use internally as well as stores an internal reference to the Order GE Object passed in which will be used in the context of all of the other members of this class.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GenerateGLEntries | This method is responsible for generating a set of GL entries for the order. The following logic defines how it will generate the entries For Regular Orders DEBIT the appropriate AR Accounts for the total Sales Tax, Shipping, Handling and Sub-Total amounts. CREDIT each Sales(or unearned income) Account for the Gross amount of EACH order line ( sales acct is chosen based on a combination of the orderlevel as well as the Product purchased The Unearned Income account is used for Deferred Income and Cash Basis products DEBIT each Sales Discount Account for the Discount amount of each line DEBIT Cost Of goods sold for the product purchased COGS account, costing based if a COGS acct is provided on product definition - actual, average, LIFO, FIFO supported CREDIT the Inventory Account associated with the the product, if one is provided ---------------------- For Cancellations CREDIT the appropriate AR Accounts DEBIT each Sales Returns Account for the Gross amount of each order line DEBIT each Sales Discount Account for the discount amount of each order line
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
RemoveGLEntries
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

Application | Returns the Aptify Application object instance
DataAction | Returns an Aptify DataAction object instance
Database | Returns the name of the database that the Order Entry system resides in
OrderGE | Returns the internal reference to the instance of the Aptify Generic Entity object for the Order that is being operated on by the class.

Protected Instance Methods

AddGLEntry | This method is responsible for adding a single GL entry to the OrderGLEntry sub-type in the order.
ClearGLEntries | This method is responsible for clearing all of the GL Entries from the OrderGLEntry sub-type
CreateCancellationSalesEntry | This method is responsible for creating the appropriate sales entry for a cancellation line item where the quantity is less than zero. This method is called from the CreateSalesEntries() method once for each line of the order that has a quantity less than zero. The Returns Account will be used if a Returns account is specified in the ProductGLAccounts sub-type. If no Returns Account is specified in the ProductGLAccounts sub-type, the Sales Account will be used with a DEBIT entry to account for the return of the item.
CreateCOGSObject | This method is responsible for creating an instance of an object that implements the IGenerateCOGS interface. By default, this method in the base class implementation will look for the Orders Entity Plug In, Calculate COGS to create the object.
CreateOrderLineEntries | Creates the AR, Sales and Discount entries for OrderLines. Handles Tax Included in the Price situations. AR Account Entry Information If no AR account is defined, the default AR Account will be used. Sales Acocunt Entry Information If the Order Line Quantity is greater than 0 then delegate to CreateRegularSalesEntry. If the Order Line Quantity is less than 0 then delegate to CreateCancellationSalesEntry. Discount Account Entry Information Create a discount entry for each of the lines in the product by determining if a discount has been applied to each order line. If a discount is set, then the method will look up the product discount GL account If there is a discount account setup for the Product, a debit is generated to that account. Otherwise we generate a debit to sales instead which will wash with the sales credit generated by the CreateSalesEntries() method. Note: Discount entries are only created when the discount is being applied to an accrual non-deferred product. If a product is deferred, we recognize the revenue and we also recognize the discount at the scheduled transaction level if a product is cash basis, we recognize the revenue and we recognize the discount when the payment is received. Lastly, we do not create discount entries for products that have a revenue recognition date and are deferring the income to that future date of recognition. In that type of revenue recognition, the scheduled transaction that handles the deferral to sales transfer will also handle the discount entry accordingly.
CreateRegularSalesEntry | This method is responsible for creating the sales GL entry for one order line as passed into the order. This method is only called for positive quantity order lines (e.g. sales, not cancellations). The method will use the following logic based on the revenue recognition requirements of the product. This method will create a CREDIT entry for the GROSS AMOUNT of the Product Line, that is The amount of the line = Quantity * Price, not taking into account any discounts. Discounts are handled through a call to the CreateDiscountEntries() method within this class. In the case where discounts are not separated out (e.g. no Discounts account is specified in the product setup), then the net result will be that the sales account will be credited for the net amount. However, this is done as a post-process through the MergeGLEntries() method and not handled in this method. The account to be used is determined by the revenue recognition model of the product for each line item in the order. For each line item, the following logic is used to determine which account to credit for this entry type: 1) If the product has standard revenue recognition where revenue is to be recognized at the time an Order is shipped, the Sales account from the ProductGLAccounts sub-type will be used. 2) If the product is using Cash Basis Accounting (has the CashBasisAcctg bit field set to 1), then the Unearned Revenue account will be used from the ProductGLAccounts sub-type. 3) If the product is using a term-based deferred revenue model (typically for subscription items) where the IsSubsription BIT field is set to 1 and the DeferredIncome BIT field is also set to 1, then the Deferred Income Account is used from the ProductGLAccounts sub-type. 4) If the product is using a one-time future date-driven deferred revenue model where it is NOT a subscription item and the RevenueRecognitionDate is set on the Product, the Deferred Income account will be used from the ProductGLAccounts sub-type.
CreateSalesTaxARandLiabilityEntries | Creates the AR and Liability entries for Sales Tax Amounts, regardless of whether or not the tax amounts are inclusive. The Order Lines, Shipping and Sales methods will deal with any inclusive amounts.
CreateShippingEntries | This method is responsible for generating GL entries for shipping charges for the order.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetDefaultARAccount | This method is responsible for returning the Default AR Account to use for products that do not have an AR account specified. The default implementation of this method uses the SalesTaxRateGLAccountCache to retrieve the Default AR Account.
GetProductARAccount | This method is responsible for determining the Accounts Receivable (AR) account to use for the given Product and Order Level. If the Product doesn't have an explicit AR account defined, the Default AR Account will be used.
GetTaxARAccount | This method is responsible for determining the Accounts Receivable (AR) account to use for the given Sales Tax Rate. If no AR Account is defined for the Sales Tax Rate, the Default AR Account will be used.
GetTaxPayableAccount | This method is responsible for determining the Accounts Payable account to use for the given Sales Tax Rate.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
MergeGLEntries | This method is responsible for merging together GL Entries that have the same account number so that no single account number is repeated on a given journal entry
ProcessOrderLinesForIncludedTaxes | Iterate through the OrderLines collection looking for any line where TaxIncludedInPrice is true. For those lines, create a temporary field named _xIncludedTax with the Tax Amount that is included in the Extended Price. In addition, process the individual tax records, updating the SalesTaxAmounts entries InclusiveTaxAmountUnresolved. Those values are used to ensure that the proper entries are always made to the accounts, even when rounding is causing the issues.
ProcessOrderShipmentsForIncludedTaxes | Iterate through the OrderShipments collection looking for any shipment where TaxIncludedInCharges is true. For those lines, create a temporary field named _xIncludedTax with the Tax Amount that is included in the Shipping and Handling Charges. In addition, process the individual tax records, updating the SalesTaxAmounts entries InclusiveTaxAmountUnresolved. Those values are used to ensure that the proper entries are always made to the accounts, even when rounding is causing the issues.
ProcessUnresolvedInclusiveTaxAmounts | Verifies that there are no unresolved Inclusive Tax Amounts. If there is one or more unresolved amounts, this method will post the remainders to the last Order Shipment that contains the Sales Tax Rate and where it's tax is included in the Price. If no Order Shipment can resolve the amount, the Order Lines will be processed from last to first until the amount is resolved.

See Also

OrderGenerateGL Class | Aptify.Applications.OrderEntry Namespace


OrderGenerateGL Constructor

Initializes a new instance of the OrderGenerateGL class.

public OrderGenerateGL();

See Also

OrderGenerateGL Class | Aptify.Applications.OrderEntry Namespace


OrderGenerateGL Properties

The properties of the OrderGenerateGL class are listed below. For a complete list of OrderGenerateGL class members, see the OrderGenerateGL Members topic.

Protected Instance Properties

Application | Returns the Aptify Application object instance
DataAction | Returns an Aptify DataAction object instance
Database | Returns the name of the database that the Order Entry system resides in
OrderGE | Returns the internal reference to the instance of the Aptify Generic Entity object for the Order that is being operated on by the class.

See Also

OrderGenerateGL Class | Aptify.Applications.OrderEntry Namespace


Application Property

Aptify 5.0 Software Development Kit (SDK)

OrderGenerateGL.Application Property

Returns the Aptify Application object instance

protected AptifyApplication Application {get;}

Property Value

Remarks

See Also

OrderGenerateGL Class | Aptify.Applications.OrderEntry Namespace


DataAction Property

Aptify 5.0 Software Development Kit (SDK)

OrderGenerateGL.DataAction Property

Returns an Aptify DataAction object instance

protected DataAction DataAction {get;}

Property Value

Remarks

See Also

OrderGenerateGL Class | Aptify.Applications.OrderEntry Namespace


Database Property

Aptify 5.0 Software Development Kit (SDK)

OrderGenerateGL.Database Property

Returns the name of the database that the Order Entry system resides in

protected String Database {get;}

Property Value

Remarks

See Also

OrderGenerateGL Class | Aptify.Applications.OrderEntry Namespace


OrderGE Property

Aptify 5.0 Software Development Kit (SDK)

OrderGenerateGL.OrderGE Property

Returns the internal reference to the instance of the Aptify Generic Entity object for the Order that is being operated on by the class.

protected AptifyGenericEntityBase OrderGE {get;}

Property Value

Remarks

See Also

OrderGenerateGL Class | Aptify.Applications.OrderEntry Namespace


OrderGenerateGL Methods

The methods of the OrderGenerateGL class are listed below. For a complete list of OrderGenerateGL class members, see the OrderGenerateGL Members topic.

Public Instance Methods

Config | This method configures the object for use and must be called before any other member of the class is accessed. This method stores the Application object provided for use internally as well as stores an internal reference to the Order GE Object passed in which will be used in the context of all of the other members of this class.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GenerateGLEntries | This method is responsible for generating a set of GL entries for the order. The following logic defines how it will generate the entries For Regular Orders DEBIT the appropriate AR Accounts for the total Sales Tax, Shipping, Handling and Sub-Total amounts. CREDIT each Sales(or unearned income) Account for the Gross amount of EACH order line ( sales acct is chosen based on a combination of the orderlevel as well as the Product purchased The Unearned Income account is used for Deferred Income and Cash Basis products DEBIT each Sales Discount Account for the Discount amount of each line DEBIT Cost Of goods sold for the product purchased COGS account, costing based if a COGS acct is provided on product definition - actual, average, LIFO, FIFO supported CREDIT the Inventory Account associated with the the product, if one is provided ---------------------- For Cancellations CREDIT the appropriate AR Accounts DEBIT each Sales Returns Account for the Gross amount of each order line DEBIT each Sales Discount Account for the discount amount of each order line
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
RemoveGLEntries
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

AddGLEntry | This method is responsible for adding a single GL entry to the OrderGLEntry sub-type in the order.
ClearGLEntries | This method is responsible for clearing all of the GL Entries from the OrderGLEntry sub-type
CreateCancellationSalesEntry | This method is responsible for creating the appropriate sales entry for a cancellation line item where the quantity is less than zero. This method is called from the CreateSalesEntries() method once for each line of the order that has a quantity less than zero. The Returns Account will be used if a Returns account is specified in the ProductGLAccounts sub-type. If no Returns Account is specified in the ProductGLAccounts sub-type, the Sales Account will be used with a DEBIT entry to account for the return of the item.
CreateCOGSObject | This method is responsible for creating an instance of an object that implements the IGenerateCOGS interface. By default, this method in the base class implementation will look for the Orders Entity Plug In, Calculate COGS to create the object.
CreateOrderLineEntries | Creates the AR, Sales and Discount entries for OrderLines. Handles Tax Included in the Price situations. AR Account Entry Information If no AR account is defined, the default AR Account will be used. Sales Acocunt Entry Information If the Order Line Quantity is greater than 0 then delegate to CreateRegularSalesEntry. If the Order Line Quantity is less than 0 then delegate to CreateCancellationSalesEntry. Discount Account Entry Information Create a discount entry for each of the lines in the product by determining if a discount has been applied to each order line. If a discount is set, then the method will look up the product discount GL account If there is a discount account setup for the Product, a debit is generated to that account. Otherwise we generate a debit to sales instead which will wash with the sales credit generated by the CreateSalesEntries() method. Note: Discount entries are only created when the discount is being applied to an accrual non-deferred product. If a product is deferred, we recognize the revenue and we also recognize the discount at the scheduled transaction level if a product is cash basis, we recognize the revenue and we recognize the discount when the payment is received. Lastly, we do not create discount entries for products that have a revenue recognition date and are deferring the income to that future date of recognition. In that type of revenue recognition, the scheduled transaction that handles the deferral to sales transfer will also handle the discount entry accordingly.
CreateRegularSalesEntry | This method is responsible for creating the sales GL entry for one order line as passed into the order. This method is only called for positive quantity order lines (e.g. sales, not cancellations). The method will use the following logic based on the revenue recognition requirements of the product. This method will create a CREDIT entry for the GROSS AMOUNT of the Product Line, that is The amount of the line = Quantity * Price, not taking into account any discounts. Discounts are handled through a call to the CreateDiscountEntries() method within this class. In the case where discounts are not separated out (e.g. no Discounts account is specified in the product setup), then the net result will be that the sales account will be credited for the net amount. However, this is done as a post-process through the MergeGLEntries() method and not handled in this method. The account to be used is determined by the revenue recognition model of the product for each line item in the order. For each line item, the following logic is used to determine which account to credit for this entry type: 1) If the product has standard revenue recognition where revenue is to be recognized at the time an Order is shipped, the Sales account from the ProductGLAccounts sub-type will be used. 2) If the product is using Cash Basis Accounting (has the CashBasisAcctg bit field set to 1), then the Unearned Revenue account will be used from the ProductGLAccounts sub-type. 3) If the product is using a term-based deferred revenue model (typically for subscription items) where the IsSubsription BIT field is set to 1 and the DeferredIncome BIT field is also set to 1, then the Deferred Income Account is used from the ProductGLAccounts sub-type. 4) If the product is using a one-time future date-driven deferred revenue model where it is NOT a subscription item and the RevenueRecognitionDate is set on the Product, the Deferred Income account will be used from the ProductGLAccounts sub-type.
CreateSalesTaxARandLiabilityEntries | Creates the AR and Liability entries for Sales Tax Amounts, regardless of whether or not the tax amounts are inclusive. The Order Lines, Shipping and Sales methods will deal with any inclusive amounts.
CreateShippingEntries | This method is responsible for generating GL entries for shipping charges for the order.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetDefaultARAccount | This method is responsible for returning the Default AR Account to use for products that do not have an AR account specified. The default implementation of this method uses the SalesTaxRateGLAccountCache to retrieve the Default AR Account.
GetProductARAccount | This method is responsible for determining the Accounts Receivable (AR) account to use for the given Product and Order Level. If the Product doesn't have an explicit AR account defined, the Default AR Account will be used.
GetTaxARAccount | This method is responsible for determining the Accounts Receivable (AR) account to use for the given Sales Tax Rate. If no AR Account is defined for the Sales Tax Rate, the Default AR Account will be used.
GetTaxPayableAccount | This method is responsible for determining the Accounts Payable account to use for the given Sales Tax Rate.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
MergeGLEntries | This method is responsible for merging together GL Entries that have the same account number so that no single account number is repeated on a given journal entry
ProcessOrderLinesForIncludedTaxes | Iterate through the OrderLines collection looking for any line where TaxIncludedInPrice is true. For those lines, create a temporary field named _xIncludedTax with the Tax Amount that is included in the Extended Price. In addition, process the individual tax records, updating the SalesTaxAmounts entries InclusiveTaxAmountUnresolved. Those values are used to ensure that the proper entries are always made to the accounts, even when rounding is causing the issues.
ProcessOrderShipmentsForIncludedTaxes | Iterate through the OrderShipments collection looking for any shipment where TaxIncludedInCharges is true. For those lines, create a temporary field named _xIncludedTax with the Tax Amount that is included in the Shipping and Handling Charges. In addition, process the individual tax records, updating the SalesTaxAmounts entries InclusiveTaxAmountUnresolved. Those values are used to ensure that the proper entries are always made to the accounts, even when rounding is causing the issues.
ProcessUnresolvedInclusiveTaxAmounts | Verifies that there are no unresolved Inclusive Tax Amounts. If there is one or more unresolved amounts, this method will post the remainders to the last Order Shipment that contains the Sales Tax Rate and where it's tax is included in the Price. If no Order Shipment can resolve the amount, the Order Lines will be processed from last to first until the amount is resolved.

See Also

OrderGenerateGL Class | Aptify.Applications.OrderEntry Namespace


OrderGenerateGL.AddGLEntry Method

This method is responsible for adding a single GL entry to the OrderGLEntry sub-type in the order.

protected virtual void AddGLEntry(
String Account,
Decimal Debit,
Decimal Credit,
String Description
);

Parameters

Account
Debit
Credit
Description

Remarks

See Also

OrderGenerateGL Class | Aptify.Applications.OrderEntry Namespace


OrderGenerateGL.ClearGLEntries Method

This method is responsible for clearing all of the GL Entries from the OrderGLEntry sub-type

protected virtual void ClearGLEntries();

Remarks

See Also

OrderGenerateGL Class | Aptify.Applications.OrderEntry Namespace


OrderGenerateGL.Config Method

This method configures the object for use and must be called before any other member of the class is accessed. This method stores the Application object provided for use internally as well as stores an internal reference to the Order GE Object passed in which will be used in the context of all of the other members of this class.

public virtual void Config(
AptifyGenericEntityBase OrderGE,
AptifyApplication Application
);

Parameters

OrderGE
Application

Implements

IGenerateGL.

Remarks

See Also

OrderGenerateGL Class | Aptify.Applications.OrderEntry Namespace


OrderGenerateGL.CreateCancellationSalesEntry Method

This method is responsible for creating the appropriate sales entry for a cancellation line item where the quantity is less than zero. This method is called from the CreateSalesEntries() method once for each line of the order that has a quantity less than zero. The Returns Account will be used if a Returns account is specified in the ProductGLAccounts sub-type. If no Returns Account is specified in the ProductGLAccounts sub-type, the Sales Account will be used with a DEBIT entry to account for the return of the item.

protected virtual void CreateCancellationSalesEntry(
OrderLinesEntity OrderLineGE,
Int32 LineNumber,
Int64 OrderLevelID,
Decimal InclusiveTaxAmount
);

Parameters

OrderLineGE
LineNumber
OrderLevelID
InclusiveTaxAmount

Remarks

See Also

OrderGenerateGL Class | Aptify.Applications.OrderEntry Namespace


OrderGenerateGL.CreateCOGSObject Method

This method is responsible for creating an instance of an object that implements the IGenerateCOGS interface. By default, this method in the base class implementation will look for the Orders Entity Plug In, Calculate COGS to create the object.

protected virtual IGenerateCOGS CreateCOGSObject();

Return Value

Remarks

See Also

OrderGenerateGL Class | Aptify.Applications.OrderEntry Namespace


OrderGenerateGL.CreateOrderLineEntries Method

Creates the AR, Sales and Discount entries for OrderLines. Handles Tax Included in the Price situations. AR Account Entry Information If no AR account is defined, the default AR Account will be used. Sales Acocunt Entry Information If the Order Line Quantity is greater than 0 then delegate to CreateRegularSalesEntry. If the Order Line Quantity is less than 0 then delegate to CreateCancellationSalesEntry. Discount Account Entry Information Create a discount entry for each of the lines in the product by determining if a discount has been applied to each order line. If a discount is set, then the method will look up the product discount GL account If there is a discount account setup for the Product, a debit is generated to that account. Otherwise we generate a debit to sales instead which will wash with the sales credit generated by the CreateSalesEntries() method. Note: Discount entries are only created when the discount is being applied to an accrual non-deferred product. If a product is deferred, we recognize the revenue and we also recognize the discount at the scheduled transaction level if a product is cash basis, we recognize the revenue and we recognize the discount when the payment is received. Lastly, we do not create discount entries for products that have a revenue recognition date and are deferring the income to that future date of recognition. In that type of revenue recognition, the scheduled transaction that handles the deferral to sales transfer will also handle the discount entry accordingly.

protected virtual void CreateOrderLineEntries(
Int64 OrderLevelID
);

Remarks

See Also

OrderGenerateGL Class | Aptify.Applications.OrderEntry Namespace


OrderGenerateGL.CreateRegularSalesEntry Method

This method is responsible for creating the sales GL entry for one order line as passed into the order. This method is only called for positive quantity order lines (e.g. sales, not cancellations). The method will use the following logic based on the revenue recognition requirements of the product. This method will create a CREDIT entry for the GROSS AMOUNT of the Product Line, that is The amount of the line = Quantity * Price, not taking into account any discounts. Discounts are handled through a call to the CreateDiscountEntries() method within this class. In the case where discounts are not separated out (e.g. no Discounts account is specified in the product setup), then the net result will be that the sales account will be credited for the net amount. However, this is done as a post-process through the MergeGLEntries() method and not handled in this method. The account to be used is determined by the revenue recognition model of the product for each line item in the order. For each line item, the following logic is used to determine which account to credit for this entry type: 1) If the product has standard revenue recognition where revenue is to be recognized at the time an Order is shipped, the Sales account from the ProductGLAccounts sub-type will be used. 2) If the product is using Cash Basis Accounting (has the CashBasisAcctg bit field set to 1), then the Unearned Revenue account will be used from the ProductGLAccounts sub-type. 3) If the product is using a term-based deferred revenue model (typically for subscription items) where the IsSubsription BIT field is set to 1 and the DeferredIncome BIT field is also set to 1, then the Deferred Income Account is used from the ProductGLAccounts sub-type. 4) If the product is using a one-time future date-driven deferred revenue model where it is NOT a subscription item and the RevenueRecognitionDate is set on the Product, the Deferred Income account will be used from the ProductGLAccounts sub-type.

protected virtual void CreateRegularSalesEntry(
OrderLinesEntity OrderLineGE,
Int32 LineNumber,
Int64 OrderLevelID,
Decimal InclusiveTaxAmount
);

Parameters

OrderLineGE
LineNumber
OrderLevelID
InclusiveTaxAmount

Remarks

See Also

OrderGenerateGL Class | Aptify.Applications.OrderEntry Namespace


OrderGenerateGL.CreateSalesTaxARandLiabilityEntries Method

Creates the AR and Liability entries for Sales Tax Amounts, regardless of whether or not the tax amounts are inclusive. The Order Lines, Shipping and Sales methods will deal with any inclusive amounts.

protected virtual void CreateSalesTaxARandLiabilityEntries();

Remarks

See Also

OrderGenerateGL Class | Aptify.Applications.OrderEntry Namespace


OrderGenerateGL.CreateShippingEntries Method

This method is responsible for generating GL entries for shipping charges for the order.

protected virtual bool CreateShippingEntries();

Return Value

True if the operation is succesful, False otherwise

Remarks

See Also

OrderGenerateGL Class | Aptify.Applications.OrderEntry Namespace


OrderGenerateGL.GenerateGLEntries Method

This method is responsible for generating a set of GL entries for the order. The following logic defines how it will generate the entries For Regular Orders DEBIT the appropriate AR Accounts for the total Sales Tax, Shipping, Handling and Sub-Total amounts. CREDIT each Sales(or unearned income) Account for the Gross amount of EACH order line ( sales acct is chosen based on a combination of the orderlevel as well as the Product purchased The Unearned Income account is used for Deferred Income and Cash Basis products DEBIT each Sales Discount Account for the Discount amount of each line DEBIT Cost Of goods sold for the product purchased COGS account, costing based if a COGS acct is provided on product definition - actual, average, LIFO, FIFO supported CREDIT the Inventory Account associated with the the product, if one is provided ---------------------- For Cancellations CREDIT the appropriate AR Accounts DEBIT each Sales Returns Account for the Gross amount of each order line DEBIT each Sales Discount Account for the discount amount of each order line

public virtual bool GenerateGLEntries(
Boolean ShowErrors
);

Parameters

ShowErrors
This parameter is ignored, user interaction should be handled by the calling application/object as appropriate

Return Value

True if the operation succeeds, False otherwise

Implements

IGenerateGL.

Remarks

See Also

OrderGenerateGL Class | Aptify.Applications.OrderEntry Namespace


OrderGenerateGL.GetDefaultARAccount Method

This method is responsible for returning the Default AR Account to use for products that do not have an AR account specified. The default implementation of this method uses the SalesTaxRateGLAccountCache to retrieve the Default AR Account.

protected virtual string GetDefaultARAccount();

Return Value

Remarks

See Also

OrderGenerateGL Class | Aptify.Applications.OrderEntry Namespace


OrderGenerateGL.GetProductARAccount Method

This method is responsible for determining the Accounts Receivable (AR) account to use for the given Product and Order Level. If the Product doesn't have an explicit AR account defined, the Default AR Account will be used.

protected virtual string GetProductARAccount(
OrderLinesEntity OrderLineGE,
Int64 OrderLevelID
);

Parameters

OrderLineGE
OrderLevelID

Return Value

Remarks

See Also

OrderGenerateGL Class | Aptify.Applications.OrderEntry Namespace


OrderGenerateGL.GetTaxARAccount Method

This method is responsible for determining the Accounts Receivable (AR) account to use for the given Sales Tax Rate. If no AR Account is defined for the Sales Tax Rate, the Default AR Account will be used.

protected virtual string GetTaxARAccount(
Int64 SalesTaxRateID
);

Parameters

SalesTaxRateID

Return Value

Remarks

See Also

OrderGenerateGL Class | Aptify.Applications.OrderEntry Namespace


OrderGenerateGL.GetTaxPayableAccount Method

This method is responsible for determining the Accounts Payable account to use for the given Sales Tax Rate.

protected virtual string GetTaxPayableAccount(
Int64 SalesTaxRateID
);

Parameters

SalesTaxRateID

Return Value

Remarks

See Also

OrderGenerateGL Class | Aptify.Applications.OrderEntry Namespace


OrderGenerateGL.MergeGLEntries Method

This method is responsible for merging together GL Entries that have the same account number so that no single account number is repeated on a given journal entry

protected virtual bool MergeGLEntries();

Return Value

True if the operation is succesful, False otherwise

Remarks

See Also

OrderGenerateGL Class | Aptify.Applications.OrderEntry Namespace


OrderGenerateGL.ProcessOrderLinesForIncludedTaxes Method

Iterate through the OrderLines collection looking for any line where TaxIncludedInPrice is true. For those lines, create a temporary field named _xIncludedTax with the Tax Amount that is included in the Extended Price. In addition, process the individual tax records, updating the SalesTaxAmounts entries InclusiveTaxAmountUnresolved. Those values are used to ensure that the proper entries are always made to the accounts, even when rounding is causing the issues.

protected virtual void ProcessOrderLinesForIncludedTaxes();

Remarks

See Also

OrderGenerateGL Class | Aptify.Applications.OrderEntry Namespace


OrderGenerateGL.ProcessOrderShipmentsForIncludedTaxes Method

Iterate through the OrderShipments collection looking for any shipment where TaxIncludedInCharges is true. For those lines, create a temporary field named _xIncludedTax with the Tax Amount that is included in the Shipping and Handling Charges. In addition, process the individual tax records, updating the SalesTaxAmounts entries InclusiveTaxAmountUnresolved. Those values are used to ensure that the proper entries are always made to the accounts, even when rounding is causing the issues.

protected virtual void ProcessOrderShipmentsForIncludedTaxes();

Remarks

See Also

OrderGenerateGL Class | Aptify.Applications.OrderEntry Namespace


OrderGenerateGL.ProcessUnresolvedInclusiveTaxAmounts Method

Verifies that there are no unresolved Inclusive Tax Amounts. If there is one or more unresolved amounts, this method will post the remainders to the last Order Shipment that contains the Sales Tax Rate and where it's tax is included in the Price. If no Order Shipment can resolve the amount, the Order Lines will be processed from last to first until the amount is resolved.

protected virtual void ProcessUnresolvedInclusiveTaxAmounts(
Int64 OrderLevelID
);

Remarks

See Also

OrderGenerateGL Class | Aptify.Applications.OrderEntry Namespace


OrderGenerateGL.RemoveGLEntries Method

public virtual bool RemoveGLEntries(
Boolean ShowErrors
);

Implements

IGenerateGL.

See Also

OrderGenerateGL Class | Aptify.Applications.OrderEntry Namespace


OrderLine Class

For a list of all members of this type, see OrderLine Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
AptifyControlBase
OrderLine

public class OrderLine : AptifyControlBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrderLineControl (in AptifyOrderLineControl.dll)

See Also

OrderLine Members | Aptify.Applications.OrderEntry Namespace


OrderLine Members

OrderLine overview

Public Instance Constructors

OrderLine Constructor Initializes a new instance of the OrderLine class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowEditing |
AlternateRowBackColor |
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
Col |
Columns |
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Control (inherited from AptifyControlBase) |
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DataControl (inherited from AptifyControlBase) | Adds a reference to the object for the data control. In the case of it being added, the reference to the bound control base object is added to the data controls collection.
DisableGeDataTransfer (inherited from AptifyControlBase) | If true, the implementer is required to move the value to/from the bound control to the GE or other data access method.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
FieldHelp (inherited from AptifyControlBase) |
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor |
FormTemplateContext (inherited from AptifyControlBase) | Returns the reference that if is local that is returned else if a DataControl exists, it is returned.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpObject (inherited from AptifyControlBase) | This method is responsible for returning the context-specific help Object file location in the Aptify Object repository. The base class implementation returns the entity-level help, if available, and if not, returns the DefaultHelpObject
HelpURL (inherited from AptifyControlBase) | This method is responsible for returning the context-specific help URL file location within the HelpObject to use. The base class implementation returns the entity-level help URL, if available, and if not, returns Nothing, which results in the content page being displayed.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
KitPartRowBackColor |
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Locked |
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
ObjectRepository (inherited from AptifyControlBase) |
OrderLinesGrid |
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Row |
RowBackColor |
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

AddCancellationItem | Overloaded.
AddProduct | Overloaded.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BoundControlConfig (inherited from AptifyControlBase) | Called by the data control to handle security,enable/disable settings, and set the label from data, if necessary. This is implemented by the sub class.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Clear |
ClearData |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DisplayControlHelp (inherited from AptifyControlBase) | This method will display control-level help information. This method will use the HelpTitle and HelpText overridable members to display the Field Help object from Aptify.Framework.WindowsControls.FieldHelp. If the title and text is desired to be overriden it is not necessary to override this method, rather override the HelpTitle and HelpText properties which are used by this method.
DisplayEntityHelp (inherited from AptifyControlBase) | This method is responsible for displaying the help file to the user and will attempt to provide context sensitive help based on the particular entity being displayed. If no entity-specific help file is available for the user then the standard Aptify Shell.Aptify Help file will be used to display help to the user. Override this method in sub-classes to change the method for displaying help.
DisplayOrderLineDetails |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetDefaultHelpObject (inherited from AptifyControlBase) | This method returns the default help object file in the Aptify Object repository to be used in the event that no entity-specific file exists
GetEntitySpecificHelpObject (inherited from AptifyControlBase) | This method returns the Aptify Object Repository Object location for the help file that is specific to this entity.
GetEntitySpecificHelpTopicURL (inherited from AptifyControlBase) | This method returns the Topic URL location within the help file that is specific to this entity.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
HideKitAssemblyRows | Hides assembly rows of the order line control
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseValueChanged (inherited from AptifyControlBase) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetUserCredential (inherited from AptifyControlBase) |
Show (inherited from Control) | Displays the control to the user.
ShowKitAssemblyRows | Shows all rows of the order line control (un-hides the ones that might have been hidden)
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
TransferDataToObject |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AfterDisplayEntityHelp (inherited from AptifyControlBase) | This event is fired after the help file is displayed.
AfterRowAdded |
AfterRowChanged |
AfterRowDeleted |
AptifyControlBaseTextChanged (inherited from AptifyControlBase) |
AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BeforeDisplayEntityHelp (inherited from AptifyControlBase) | This event is fired before the help file is displayed. To prevent help from being displayed set the Cancel parameter to True.
BeforeRowAdded |
BeforeRowChanged |
BeforeRowDeleted |
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from AptifyControlBase) |
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from AptifyControlBase) |
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from AptifyControlBase) |
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from AptifyControlBase) |
KeyPress (inherited from AptifyControlBase) |
KeyUp (inherited from AptifyControlBase) |
KitAdded |
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from AptifyControlBase) |
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from AptifyControlBase) |
MouseEnter (inherited from AptifyControlBase) |
MouseHover (inherited from AptifyControlBase) |
MouseLeave (inherited from AptifyControlBase) |
MouseMove (inherited from AptifyControlBase) |
MouseUp (inherited from AptifyControlBase) |
MouseWheel (inherited from AptifyControlBase) |
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from AptifyControlBase) |
TotalsChanged |
Validated (inherited from AptifyControlBase) |
Validating (inherited from AptifyControlBase) |
ValueChanged (inherited from AptifyControlBase) |
VisibleChanged (inherited from AptifyControlBase) |

Protected Instance Fields

m_bApplyingColumnsToGrid
m_bUserResizedColumns
m_iDataControl (inherited from AptifyControlBase)
m_oAptifyApplication (inherited from AptifyControlBase)
m_oFormTemplateContext (inherited from AptifyControlBase)
m_oUserCredential (inherited from AptifyControlBase)

Protected Instance Properties

AptifyApplication (inherited from AptifyControlBase) | Returns an instance of the Aptify Application Object
AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
CurrencyTypeCache (inherited from AptifyControlBase) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DisplayName (inherited from AptifyControlBase) |
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HelpText (inherited from AptifyControlBase) |
HelpTitle (inherited from AptifyControlBase) | This property is designed to be overriden by subclasses that want to provide a different title. The base class returns "Aptify Help" for this property.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
InternalControl (inherited from AptifyControlBase) | Specifies the Main Control of interest in a composite control.
m_frmRelatedProducts |
m_oInternalControl (inherited from AptifyControlBase) |
MyApplication (inherited from AptifyControlBase) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowDisplayHelpHyperlink (inherited from AptifyControlBase) | This property can be overriden by sub-classes to be able to selectively turn on or off the Display Help hyperlink that appears by default on the FieldHelp object.
UserCredential (inherited from AptifyControlBase) |
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AddLinesToGrid | Uses the given list of OrderLinesEntity objects, to add one new row to the Order Lines grid for each OrderLinesEntity in the list. For each list item, a call is made to the AddLineToGrid method. At the end, a call is made to the RefreshExistingRows method with the row index of the highest row index that existed at the beginning of this method call.
AddLineToGrid |
AdjustFormScrollbars (inherited from ContainerControl) |
ApplyColumnsToGrid |
ApplyCurrencyTypeFormat |
ApplySkin |
ApplyUserColumnSettings |
ConfigHelp (inherited from AptifyControlBase) | This method configures the base FieldHelp object and sets up a default string in the HelpText field. Sub-Classes should override this to implement specific help relevant to their context of use.
ConfigureDefaultColumns |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
DisplayNotEligibleCancellationItemMatchMessage | Displays a Message Box with a message indicating that there is no Order Line on the Orignal Order that will allow a cancellation Order Line to be created for the given Product and Quantity
Dispose | Overloaded.
DoFormComponentConfig |
Finalize (inherited from AptifyControlBase) |
FormComponentConfig (inherited from AptifyControlBase) |
FormComponentHide |
FormComponentShow | Overloaded.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
LoadOrderLines |
LoadProductPriceList |
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged |
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
OrderLinesAfterResizeColumn |
OrderLinesCellButtonClick |
OrderLinesCellButtonClick_Price |
OrderLinesMouseDoubleClick | When the mouse is double-clicked on an Order Line row and the mouse pointer is over cell that does not support editing, the OrderLine Details dialog will be displayed.
OrderLinesMouseHoverCell |
PopulateLineNumbers |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
ProductPriceListExists | Searches the Product Price Lists Dictionary for a matching Product entry. Returns True if a match is found. Otherwise, False is returned.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshExistingRows | Step through each row in the Order Lines grid, starting with the row identified by LastRowIndexToRefresh working down to the first non-fixed row (Row index = 1)
RequiredGECheck (inherited from AptifyControlBase) |
RequiredPropertiesCheck (inherited from AptifyControlBase) |
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
SaveUserColumnSettings |
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SelectCancellationItem |
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetupPriceListDataTable |
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateGridRow |
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
ValidateAndApplyPrice |
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

OrderLine Class | Aptify.Applications.OrderEntry Namespace


OrderLine Constructor

Initializes a new instance of the OrderLine class.

public OrderLine();

See Also

OrderLine Class | Aptify.Applications.OrderEntry Namespace


OrderLine Fields

The fields of the OrderLine class are listed below. For a complete list of OrderLine class members, see the OrderLine Members topic.

Protected Instance Fields

m_bApplyingColumnsToGrid
m_bUserResizedColumns
m_iDataControl (inherited from AptifyControlBase)
m_oAptifyApplication (inherited from AptifyControlBase)
m_oFormTemplateContext (inherited from AptifyControlBase)
m_oUserCredential (inherited from AptifyControlBase)

See Also

OrderLine Class | Aptify.Applications.OrderEntry Namespace


OrderLine.m_bApplyingColumnsToGrid Field

protected m_bApplyingColumnsToGrid m_bApplyingColumnsToGrid;

See Also

OrderLine Class | Aptify.Applications.OrderEntry Namespace


OrderLine.m_bUserResizedColumns Field

protected m_bUserResizedColumns m_bUserResizedColumns;

See Also

OrderLine Class | Aptify.Applications.OrderEntry Namespace


OrderLine Properties

The properties of the OrderLine class are listed below. For a complete list of OrderLine class members, see the OrderLine Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowEditing |
AlternateRowBackColor |
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
Col |
Columns |
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Control (inherited from AptifyControlBase) |
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DataControl (inherited from AptifyControlBase) | Adds a reference to the object for the data control. In the case of it being added, the reference to the bound control base object is added to the data controls collection.
DisableGeDataTransfer (inherited from AptifyControlBase) | If true, the implementer is required to move the value to/from the bound control to the GE or other data access method.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
FieldHelp (inherited from AptifyControlBase) |
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor |
FormTemplateContext (inherited from AptifyControlBase) | Returns the reference that if is local that is returned else if a DataControl exists, it is returned.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpObject (inherited from AptifyControlBase) | This method is responsible for returning the context-specific help Object file location in the Aptify Object repository. The base class implementation returns the entity-level help, if available, and if not, returns the DefaultHelpObject
HelpURL (inherited from AptifyControlBase) | This method is responsible for returning the context-specific help URL file location within the HelpObject to use. The base class implementation returns the entity-level help URL, if available, and if not, returns Nothing, which results in the content page being displayed.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
KitPartRowBackColor |
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Locked |
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
ObjectRepository (inherited from AptifyControlBase) |
OrderLinesGrid |
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Row |
RowBackColor |
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AptifyApplication (inherited from AptifyControlBase) | Returns an instance of the Aptify Application Object
AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
CurrencyTypeCache (inherited from AptifyControlBase) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DisplayName (inherited from AptifyControlBase) |
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HelpText (inherited from AptifyControlBase) |
HelpTitle (inherited from AptifyControlBase) | This property is designed to be overriden by subclasses that want to provide a different title. The base class returns "Aptify Help" for this property.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
InternalControl (inherited from AptifyControlBase) | Specifies the Main Control of interest in a composite control.
m_frmRelatedProducts |
m_oInternalControl (inherited from AptifyControlBase) |
MyApplication (inherited from AptifyControlBase) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowDisplayHelpHyperlink (inherited from AptifyControlBase) | This property can be overriden by sub-classes to be able to selectively turn on or off the Display Help hyperlink that appears by default on the FieldHelp object.
UserCredential (inherited from AptifyControlBase) |
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

OrderLine Class | Aptify.Applications.OrderEntry Namespace


AllowEditing Property

Aptify 5.0 Software Development Kit (SDK)

OrderLine.AllowEditing Property

public virtual Boolean AllowEditing {get; set;}

See Also

OrderLine Class | Aptify.Applications.OrderEntry Namespace


AlternateRowBackColor Property

Aptify 5.0 Software Development Kit (SDK)

OrderLine.AlternateRowBackColor Property

public Color AlternateRowBackColor {get; set;}

See Also

OrderLine Class | Aptify.Applications.OrderEntry Namespace


Col Property

Aptify 5.0 Software Development Kit (SDK)

OrderLine.Col Property

public Int32 Col {get; set;}

See Also

OrderLine Class | Aptify.Applications.OrderEntry Namespace


Columns Property

Aptify 5.0 Software Development Kit (SDK)

OrderLine.Columns Property

public virtual Dictionary<TKey,TValue> Columns {get; set;}

See Also

OrderLine Class | Aptify.Applications.OrderEntry Namespace


ForeColor Property

Aptify 5.0 Software Development Kit (SDK)

OrderLine.ForeColor Property

public override Color ForeColor {get; set;}

See Also

OrderLine Class | Aptify.Applications.OrderEntry Namespace


KitPartRowBackColor Property

Aptify 5.0 Software Development Kit (SDK)

OrderLine.KitPartRowBackColor Property

public Color KitPartRowBackColor {get; set;}

See Also

OrderLine Class | Aptify.Applications.OrderEntry Namespace


Locked Property

Aptify 5.0 Software Development Kit (SDK)

OrderLine.Locked Property

public Boolean Locked {get; set;}

See Also

OrderLine Class | Aptify.Applications.OrderEntry Namespace


m_frmRelatedProducts Property

Aptify 5.0 Software Development Kit (SDK)

OrderLine.m_frmRelatedProducts Property

protected virtual IRelatedProductsUI m_frmRelatedProducts {get; set;}

See Also

OrderLine Class | Aptify.Applications.OrderEntry Namespace


OrderLinesGrid Property

Aptify 5.0 Software Development Kit (SDK)

OrderLine.OrderLinesGrid Property

public virtual C1FlexGrid OrderLinesGrid {get;}

See Also

OrderLine Class | Aptify.Applications.OrderEntry Namespace


Row Property

Aptify 5.0 Software Development Kit (SDK)

OrderLine.Row Property

public Int32 Row {get; set;}

See Also

OrderLine Class | Aptify.Applications.OrderEntry Namespace


RowBackColor Property

Aptify 5.0 Software Development Kit (SDK)

OrderLine.RowBackColor Property

public Color RowBackColor {get; set;}

See Also

OrderLine Class | Aptify.Applications.OrderEntry Namespace


OrderLine Methods

The methods of the OrderLine class are listed below. For a complete list of OrderLine class members, see the OrderLine Members topic.

Public Instance Methods

AddCancellationItem | Overloaded.
AddProduct | Overloaded.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BoundControlConfig (inherited from AptifyControlBase) | Called by the data control to handle security,enable/disable settings, and set the label from data, if necessary. This is implemented by the sub class.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Clear |
ClearData |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DisplayControlHelp (inherited from AptifyControlBase) | This method will display control-level help information. This method will use the HelpTitle and HelpText overridable members to display the Field Help object from Aptify.Framework.WindowsControls.FieldHelp. If the title and text is desired to be overriden it is not necessary to override this method, rather override the HelpTitle and HelpText properties which are used by this method.
DisplayEntityHelp (inherited from AptifyControlBase) | This method is responsible for displaying the help file to the user and will attempt to provide context sensitive help based on the particular entity being displayed. If no entity-specific help file is available for the user then the standard Aptify Shell.Aptify Help file will be used to display help to the user. Override this method in sub-classes to change the method for displaying help.
DisplayOrderLineDetails |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetDefaultHelpObject (inherited from AptifyControlBase) | This method returns the default help object file in the Aptify Object repository to be used in the event that no entity-specific file exists
GetEntitySpecificHelpObject (inherited from AptifyControlBase) | This method returns the Aptify Object Repository Object location for the help file that is specific to this entity.
GetEntitySpecificHelpTopicURL (inherited from AptifyControlBase) | This method returns the Topic URL location within the help file that is specific to this entity.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
HideKitAssemblyRows | Hides assembly rows of the order line control
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseValueChanged (inherited from AptifyControlBase) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetUserCredential (inherited from AptifyControlBase) |
Show (inherited from Control) | Displays the control to the user.
ShowKitAssemblyRows | Shows all rows of the order line control (un-hides the ones that might have been hidden)
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
TransferDataToObject |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AddLinesToGrid | Uses the given list of OrderLinesEntity objects, to add one new row to the Order Lines grid for each OrderLinesEntity in the list. For each list item, a call is made to the AddLineToGrid method. At the end, a call is made to the RefreshExistingRows method with the row index of the highest row index that existed at the beginning of this method call.
AddLineToGrid |
AdjustFormScrollbars (inherited from ContainerControl) |
ApplyColumnsToGrid |
ApplyCurrencyTypeFormat |
ApplySkin |
ApplyUserColumnSettings |
ConfigHelp (inherited from AptifyControlBase) | This method configures the base FieldHelp object and sets up a default string in the HelpText field. Sub-Classes should override this to implement specific help relevant to their context of use.
ConfigureDefaultColumns |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
DisplayNotEligibleCancellationItemMatchMessage | Displays a Message Box with a message indicating that there is no Order Line on the Orignal Order that will allow a cancellation Order Line to be created for the given Product and Quantity
Dispose | Overloaded.
DoFormComponentConfig |
Finalize (inherited from AptifyControlBase) |
FormComponentConfig (inherited from AptifyControlBase) |
FormComponentHide |
FormComponentShow | Overloaded.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
LoadOrderLines |
LoadProductPriceList |
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged |
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
OrderLinesAfterResizeColumn |
OrderLinesCellButtonClick |
OrderLinesCellButtonClick_Price |
OrderLinesMouseDoubleClick | When the mouse is double-clicked on an Order Line row and the mouse pointer is over cell that does not support editing, the OrderLine Details dialog will be displayed.
OrderLinesMouseHoverCell |
PopulateLineNumbers |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
ProductPriceListExists | Searches the Product Price Lists Dictionary for a matching Product entry. Returns True if a match is found. Otherwise, False is returned.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshExistingRows | Step through each row in the Order Lines grid, starting with the row identified by LastRowIndexToRefresh working down to the first non-fixed row (Row index = 1)
RequiredGECheck (inherited from AptifyControlBase) |
RequiredPropertiesCheck (inherited from AptifyControlBase) |
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
SaveUserColumnSettings |
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SelectCancellationItem |
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetupPriceListDataTable |
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateGridRow |
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
ValidateAndApplyPrice |
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

OrderLine Class | Aptify.Applications.OrderEntry Namespace


AddCancellationItem Method

Aptify 5.0 Software Development Kit (SDK)

OrderLine.AddCancellationItem Method

Overload List

public virtual List<T> AddCancellationItem(Int64,Decimal);

public virtual List<T> AddCancellationItem(Int64,Int64,Decimal);

See Also

OrderLine Class | Aptify.Applications.OrderEntry Namespace


OrderLine.AddCancellationItem Method (Int64, Decimal)

public virtual List<T> AddCancellationItem(
Int64 ProductID,
Decimal Quantity
);

See Also

OrderLine Class | Aptify.Applications.OrderEntry Namespace | OrderLine.AddCancellationItem Overload List


OrderLine.AddCancellationItem Method (Int64, Int64, Decimal)

public virtual List<T> AddCancellationItem(
Int64 OriginalOrderDetailID,
Int64 ProductID,
Decimal Quantity
);

See Also

OrderLine Class | Aptify.Applications.OrderEntry Namespace | OrderLine.AddCancellationItem Overload List


OrderLine.AddLinesToGrid Method

Uses the given list of OrderLinesEntity objects, to add one new row to the Order Lines grid for each OrderLinesEntity in the list. For each list item, a call is made to the AddLineToGrid method. At the end, a call is made to the RefreshExistingRows method with the row index of the highest row index that existed at the beginning of this method call.

protected virtual void AddLinesToGrid(
List<T> OrderLines
);

Parameters

OrderLines

Remarks

See Also

OrderLine Class | Aptify.Applications.OrderEntry Namespace


OrderLine.AddLineToGrid Method

protected virtual void AddLineToGrid(
OrderLinesEntity OrderLineGE
);

See Also

OrderLine Class | Aptify.Applications.OrderEntry Namespace


AddProduct Method

Aptify 5.0 Software Development Kit (SDK)

OrderLine.AddProduct Method

Overload List

public virtual List<T> AddProduct(Int64);

public virtual List<T> AddProduct(Int64,Decimal);

See Also

OrderLine Class | Aptify.Applications.OrderEntry Namespace


OrderLine.AddProduct Method (Int64)

public virtual List<T> AddProduct(
Int64 ProductID
);

See Also

OrderLine Class | Aptify.Applications.OrderEntry Namespace | OrderLine.AddProduct Overload List


OrderLine.AddProduct Method (Int64, Decimal)

public virtual List<T> AddProduct(
Int64 ProductID,
Decimal Quantity
);

See Also

OrderLine Class | Aptify.Applications.OrderEntry Namespace | OrderLine.AddProduct Overload List


OrderLine.ApplyColumnsToGrid Method

protected virtual void ApplyColumnsToGrid();

See Also

OrderLine Class | Aptify.Applications.OrderEntry Namespace


OrderLine.ApplyCurrencyTypeFormat Method

protected virtual void ApplyCurrencyTypeFormat();

See Also

OrderLine Class | Aptify.Applications.OrderEntry Namespace


OrderLine.ApplySkin Method

protected virtual void ApplySkin();

See Also

OrderLine Class | Aptify.Applications.OrderEntry Namespace


OrderLine.ApplyUserColumnSettings Method

protected virtual void ApplyUserColumnSettings();

See Also

OrderLine Class | Aptify.Applications.OrderEntry Namespace


OrderLine.Clear Method

public virtual void Clear();

See Also

OrderLine Class | Aptify.Applications.OrderEntry Namespace


OrderLine.ClearData Method

public override void ClearData();

Implements

IAptifyControlBase.

See Also

OrderLine Class | Aptify.Applications.OrderEntry Namespace


OrderLine.ConfigureDefaultColumns Method

protected virtual void ConfigureDefaultColumns();

See Also

OrderLine Class | Aptify.Applications.OrderEntry Namespace


OrderLine.DisplayNotEligibleCancellationItemMatchMessage Method

Displays a Message Box with a message indicating that there is no Order Line on the Orignal Order that will allow a cancellation Order Line to be created for the given Product and Quantity

protected virtual void DisplayNotEligibleCancellationItemMatchMessage(
Int64 ProductID,
Decimal Quantity,
OrdersEntity OrderGE
);

Parameters

ProductID
Quantity
OrderGE

Remarks

See Also

OrderLine Class | Aptify.Applications.OrderEntry Namespace


OrderLine.DisplayOrderLineDetails Method

public virtual void DisplayOrderLineDetails(
Int32 Row
);

See Also

OrderLine Class | Aptify.Applications.OrderEntry Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

OrderLine.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

OrderLine Class | Aptify.Applications.OrderEntry Namespace


OrderLine.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

OrderLine Class | Aptify.Applications.OrderEntry Namespace | OrderLine.Dispose Overload List


OrderLine.DoFormComponentConfig Method

protected override void DoFormComponentConfig(
AptifyFormTemplateContext FormTemplateContext
);

See Also

OrderLine Class | Aptify.Applications.OrderEntry Namespace


OrderLine.FormComponentHide Method

protected override void FormComponentHide();

Implements

IFormComponent.

See Also

OrderLine Class | Aptify.Applications.OrderEntry Namespace


FormComponentShow Method

Aptify 5.0 Software Development Kit (SDK)

OrderLine.FormComponentShow Method

Overload List

protected override void FormComponentShow();

protected override void FormComponentShow(Boolean);

See Also

OrderLine Class | Aptify.Applications.OrderEntry Namespace


OrderLine.FormComponentShow Method ()

protected override void FormComponentShow();

Implements

IFormComponent.

See Also

OrderLine Class | Aptify.Applications.OrderEntry Namespace | OrderLine.FormComponentShow Overload List


OrderLine.FormComponentShow Method (Boolean)

protected override void FormComponentShow(
Boolean Refresh
);

Implements

IFormComponent.

See Also

OrderLine Class | Aptify.Applications.OrderEntry Namespace | OrderLine.FormComponentShow Overload List


OrderLine.HideKitAssemblyRows Method

Hides assembly rows of the order line control

public void HideKitAssemblyRows();

Remarks

See Also

OrderLine Class | Aptify.Applications.OrderEntry Namespace


OrderLine.LoadOrderLines Method

protected virtual void LoadOrderLines();

See Also

OrderLine Class | Aptify.Applications.OrderEntry Namespace


OrderLine.LoadProductPriceList Method

protected virtual void LoadProductPriceList(
OrderLinesEntity OrderLineGE
);

See Also

OrderLine Class | Aptify.Applications.OrderEntry Namespace


OrderLine.OnEnabledChanged Method

protected override void OnEnabledChanged(
EventArgs e
);

See Also

OrderLine Class | Aptify.Applications.OrderEntry Namespace


OrderLine.OrderLinesAfterResizeColumn Method

protected virtual void OrderLinesAfterResizeColumn(
Object sender,
RowColEventArgs e
);

See Also

OrderLine Class | Aptify.Applications.OrderEntry Namespace


OrderLine.OrderLinesCellButtonClick Method

protected virtual void OrderLinesCellButtonClick(
Object sender,
RowColEventArgs e
);

See Also

OrderLine Class | Aptify.Applications.OrderEntry Namespace


OrderLine.OrderLinesCellButtonClick_Price Method

protected virtual void OrderLinesCellButtonClick_Price(
RowColEventArgs e
);

See Also

OrderLine Class | Aptify.Applications.OrderEntry Namespace


OrderLine.OrderLinesMouseDoubleClick Method

When the mouse is double-clicked on an Order Line row and the mouse pointer is over cell that does not support editing, the OrderLine Details dialog will be displayed.

protected virtual void OrderLinesMouseDoubleClick(
Object sender,
MouseEventArgs e
);

Parameters

sender
e

Remarks

See Also

OrderLine Class | Aptify.Applications.OrderEntry Namespace


OrderLine.OrderLinesMouseHoverCell Method

protected virtual void OrderLinesMouseHoverCell(
Object sender,
EventArgs e
);

See Also

OrderLine Class | Aptify.Applications.OrderEntry Namespace


OrderLine.PopulateLineNumbers Method

protected virtual void PopulateLineNumbers();

See Also

OrderLine Class | Aptify.Applications.OrderEntry Namespace


OrderLine.ProductPriceListExists Method

Searches the Product Price Lists Dictionary for a matching Product entry. Returns True if a match is found. Otherwise, False is returned.

protected virtual bool ProductPriceListExists(
Int64 ProductID
);

Parameters

ProductID

Return Value

Remarks

See Also

OrderLine Class | Aptify.Applications.OrderEntry Namespace


OrderLine.Refresh Method

public override void Refresh();

Implements

IFormComponent.

See Also

OrderLine Class | Aptify.Applications.OrderEntry Namespace


OrderLine.RefreshExistingRows Method

Step through each row in the Order Lines grid, starting with the row identified by LastRowIndexToRefresh working down to the first non-fixed row (Row index = 1)

protected virtual void RefreshExistingRows(
Int32 LastRowIndexToRefresh
);

Parameters

LastRowIndexToRefresh

Remarks

See Also

OrderLine Class | Aptify.Applications.OrderEntry Namespace


OrderLine.SaveUserColumnSettings Method

protected virtual void SaveUserColumnSettings();

See Also

OrderLine Class | Aptify.Applications.OrderEntry Namespace


OrderLine.SelectCancellationItem Method

protected virtual OrderCancellationDetail SelectCancellationItem(
List<T> CancellationItems,
Int64 ProductID,
Decimal Quantity,
OrdersEntity OrderGE
);

See Also

OrderLine Class | Aptify.Applications.OrderEntry Namespace


OrderLine.SetupPriceListDataTable Method

protected virtual DataTable SetupPriceListDataTable();

See Also

OrderLine Class | Aptify.Applications.OrderEntry Namespace


OrderLine.ShowKitAssemblyRows Method

Shows all rows of the order line control (un-hides the ones that might have been hidden)

public void ShowKitAssemblyRows();

Remarks

See Also

OrderLine Class | Aptify.Applications.OrderEntry Namespace


OrderLine.TransferDataToObject Method

public override void TransferDataToObject(
ref Boolean& Cancel
);

Implements

IFormComponent.

See Also

OrderLine Class | Aptify.Applications.OrderEntry Namespace


OrderLine.UpdateGridRow Method

protected virtual void UpdateGridRow(
Int32 Row,
OrderLinesEntity OrderLineGE
);

See Also

OrderLine Class | Aptify.Applications.OrderEntry Namespace


OrderLine.ValidateAndApplyPrice Method

protected virtual void ValidateAndApplyPrice(
Int32 Row,
OrderLinesEntity OrderLineGE,
String PriceName,
Decimal Price,
Boolean FromList,
ref Boolean& Cancel
);

Parameters

Row
OrderLineGE
PriceName
Price
FromList
Cancel

Remarks

See Also

OrderLine Class | Aptify.Applications.OrderEntry Namespace


OrderLine Events

The events of the OrderLine class are listed below. For a complete list of OrderLine class members, see the OrderLine Members topic.

Public Instance Events

AfterDisplayEntityHelp (inherited from AptifyControlBase) | This event is fired after the help file is displayed.
AfterRowAdded |
AfterRowChanged |
AfterRowDeleted |
AptifyControlBaseTextChanged (inherited from AptifyControlBase) |
AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BeforeDisplayEntityHelp (inherited from AptifyControlBase) | This event is fired before the help file is displayed. To prevent help from being displayed set the Cancel parameter to True.
BeforeRowAdded |
BeforeRowChanged |
BeforeRowDeleted |
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from AptifyControlBase) |
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from AptifyControlBase) |
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from AptifyControlBase) |
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from AptifyControlBase) |
KeyPress (inherited from AptifyControlBase) |
KeyUp (inherited from AptifyControlBase) |
KitAdded |
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from AptifyControlBase) |
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from AptifyControlBase) |
MouseEnter (inherited from AptifyControlBase) |
MouseHover (inherited from AptifyControlBase) |
MouseLeave (inherited from AptifyControlBase) |
MouseMove (inherited from AptifyControlBase) |
MouseUp (inherited from AptifyControlBase) |
MouseWheel (inherited from AptifyControlBase) |
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from AptifyControlBase) |
TotalsChanged |
Validated (inherited from AptifyControlBase) |
Validating (inherited from AptifyControlBase) |
ValueChanged (inherited from AptifyControlBase) |
VisibleChanged (inherited from AptifyControlBase) |

See Also

OrderLine Class | Aptify.Applications.OrderEntry Namespace


OrderLine.OrderLine.AfterRowAddedEventHandler Event

public event OrderLine.AfterRowAddedEventHandler AfterRowAdded;

Event Data

The event handler receives an argument of type AfterRowAddedEventArgs containing data related to this event. The following AfterRowAddedEventArgs property provides information specific to this event.

Property | Description
OrderLine |

See Also

OrderLine Class | Aptify.Applications.OrderEntry Namespace


OrderLine.OrderLine.AfterRowChangedEventHandler Event

public event OrderLine.AfterRowChangedEventHandler AfterRowChanged;

Event Data

The event handler receives an argument of type AfterRowChangedEventArgs containing data related to this event. The following AfterRowChangedEventArgs properties provide information specific to this event.

Property | Description
OrderLine |
Row |

See Also

OrderLine Class | Aptify.Applications.OrderEntry Namespace


OrderLine.OrderLine.AfterRowDeletedEventHandler Event

public event OrderLine.AfterRowDeletedEventHandler AfterRowDeleted;

Event Data

The event handler receives an argument of type AfterRowDeletedEventArgs containing data related to this event. The following AfterRowDeletedEventArgs property provides information specific to this event.

Property | Description
OldRow |

See Also

OrderLine Class | Aptify.Applications.OrderEntry Namespace


OrderLine.OrderLine.BeforeRowAddedEventHandler Event

public event OrderLine.BeforeRowAddedEventHandler BeforeRowAdded;

Event Data

The event handler receives an argument of type BeforeRowAddedEventArgs containing data related to this event. The following BeforeRowAddedEventArgs properties provide information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.
OrderLine |

See Also

OrderLine Class | Aptify.Applications.OrderEntry Namespace


OrderLine.OrderLine.BeforeRowChangedEventHandler Event

public event OrderLine.BeforeRowChangedEventHandler BeforeRowChanged;

Event Data

The event handler receives an argument of type BeforeRowChangedEventArgs containing data related to this event. The following BeforeRowChangedEventArgs properties provide information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.
OrderLine |
Row |

See Also

OrderLine Class | Aptify.Applications.OrderEntry Namespace


OrderLine.OrderLine.BeforeRowDeletedEventHandler Event

public event OrderLine.BeforeRowDeletedEventHandler BeforeRowDeleted;

Event Data

The event handler receives an argument of type BeforeRowDeletedEventArgs containing data related to this event. The following BeforeRowDeletedEventArgs properties provide information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.
OldRow |
OrderLine |

See Also

OrderLine Class | Aptify.Applications.OrderEntry Namespace


OrderLine.OrderLine.KitAddedEventHandler Event

public event OrderLine.KitAddedEventHandler KitAdded;

See Also

OrderLine Class | Aptify.Applications.OrderEntry Namespace


OrderLine.OrderLine.TotalsChangedEventHandler Event

public event OrderLine.TotalsChangedEventHandler TotalsChanged;

Event Data

The event handler receives an argument of type TotalsChangedEventArgs containing data related to this event. The following TotalsChangedEventArgs properties provide information specific to this event.

Property | Description
DiscountTotal |
GrandTotal |
HandlingCharge |
SalesTax |
ShippingCharge |
SubTotal |

See Also

OrderLine Class | Aptify.Applications.OrderEntry Namespace


OrderLine.AfterRowAddedEventHandler Delegate

public delegate void OrderLine.AfterRowAddedEventHandler(
Object sender,
AfterRowAddedEventArgs e
);

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrderLineControl (in AptifyOrderLineControl.dll)

See Also

Aptify.Applications.OrderEntry Namespace


OrderLine.AfterRowChangedEventHandler Delegate

public delegate void OrderLine.AfterRowChangedEventHandler(
Object sender,
AfterRowChangedEventArgs e
);

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrderLineControl (in AptifyOrderLineControl.dll)

See Also

Aptify.Applications.OrderEntry Namespace


OrderLine.AfterRowDeletedEventHandler Delegate

public delegate void OrderLine.AfterRowDeletedEventHandler(
Object sender,
AfterRowDeletedEventArgs e
);

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrderLineControl (in AptifyOrderLineControl.dll)

See Also

Aptify.Applications.OrderEntry Namespace


OrderLine.BeforeRowAddedEventHandler Delegate

public delegate void OrderLine.BeforeRowAddedEventHandler(
Object sender,
BeforeRowAddedEventArgs e
);

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrderLineControl (in AptifyOrderLineControl.dll)

See Also

Aptify.Applications.OrderEntry Namespace


OrderLine.BeforeRowChangedEventHandler Delegate

public delegate void OrderLine.BeforeRowChangedEventHandler(
Object sender,
BeforeRowChangedEventArgs e
);

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrderLineControl (in AptifyOrderLineControl.dll)

See Also

Aptify.Applications.OrderEntry Namespace


OrderLine.BeforeRowDeletedEventHandler Delegate

public delegate void OrderLine.BeforeRowDeletedEventHandler(
Object sender,
BeforeRowDeletedEventArgs e
);

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrderLineControl (in AptifyOrderLineControl.dll)

See Also

Aptify.Applications.OrderEntry Namespace


OrderLine.KitAddedEventHandler Delegate

public delegate void OrderLine.KitAddedEventHandler();

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrderLineControl (in AptifyOrderLineControl.dll)

See Also

Aptify.Applications.OrderEntry Namespace


OrderLine.TotalsChangedEventHandler Delegate

public delegate void OrderLine.TotalsChangedEventHandler(
Object sender,
TotalsChangedEventArgs e
);

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrderLineControl (in AptifyOrderLineControl.dll)

See Also

Aptify.Applications.OrderEntry Namespace


OrderLineColumn Class

For a list of all members of this type, see OrderLineColumn Members.

System.Object
OrderLineColumn

public class OrderLineColumn

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrderLineControl (in AptifyOrderLineControl.dll)

See Also

OrderLineColumn Members | Aptify.Applications.OrderEntry Namespace


OrderLineColumn Members

OrderLineColumn overview

Public Instance Constructors

OrderLineColumn Overloaded. Initializes a new instance of the OrderLineColumn class.

Public Instance Fields

AllowEditing
AllowResizing
ComboList
Format
TextAlignment
TextAlignmentFixed
TextDirection
TextEffect
Visible
Width
WordWrap

Public Instance Properties

BackColor
Caption
DataField
Font
ForeColor
Name

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

OrderLineColumn Class | Aptify.Applications.OrderEntry Namespace


OrderLineColumn Constructor

Overload List

public OrderLineColumn(AptifyApplication,OrderLine,String);

public OrderLineColumn(AptifyApplication,OrderLine,String,String);

See Also

OrderLineColumn Class | Aptify.Applications.OrderEntry Namespace


OrderLineColumn Constructor (AptifyApplication, OrderLine, String)

public OrderLineColumn(
AptifyApplication Application,
OrderLine OrderLineControl,
String Name
);

See Also

OrderLineColumn Class | Aptify.Applications.OrderEntry Namespace | OrderLineColumn Constructor Overload List


OrderLineColumn Constructor (AptifyApplication, OrderLine, String, String)

public OrderLineColumn(
AptifyApplication Application,
OrderLine OrderLineControl,
String Name,
String DataField
);

See Also

OrderLineColumn Class | Aptify.Applications.OrderEntry Namespace | OrderLineColumn Constructor Overload List


OrderLineColumn Fields

The fields of the OrderLineColumn class are listed below. For a complete list of OrderLineColumn class members, see the OrderLineColumn Members topic.

Public Instance Fields

AllowEditing
AllowResizing
ComboList
Format
TextAlignment
TextAlignmentFixed
TextDirection
TextEffect
Visible
Width
WordWrap

See Also

OrderLineColumn Class | Aptify.Applications.OrderEntry Namespace


OrderLineColumn.AllowEditing Field

public AllowEditing AllowEditing;

See Also

OrderLineColumn Class | Aptify.Applications.OrderEntry Namespace


OrderLineColumn.AllowResizing Field

public AllowResizing AllowResizing;

See Also

OrderLineColumn Class | Aptify.Applications.OrderEntry Namespace


OrderLineColumn.ComboList Field

public ComboList ComboList;

See Also

OrderLineColumn Class | Aptify.Applications.OrderEntry Namespace


OrderLineColumn.Format Field

public Format Format;

See Also

OrderLineColumn Class | Aptify.Applications.OrderEntry Namespace


OrderLineColumn.TextAlignment Field

public TextAlignment TextAlignment;

See Also

OrderLineColumn Class | Aptify.Applications.OrderEntry Namespace


OrderLineColumn.TextAlignmentFixed Field

public TextAlignmentFixed TextAlignmentFixed;

See Also

OrderLineColumn Class | Aptify.Applications.OrderEntry Namespace


OrderLineColumn.TextDirection Field

public TextDirection TextDirection;

See Also

OrderLineColumn Class | Aptify.Applications.OrderEntry Namespace


OrderLineColumn.TextEffect Field

public TextEffect TextEffect;

See Also

OrderLineColumn Class | Aptify.Applications.OrderEntry Namespace


OrderLineColumn.Visible Field

public Visible Visible;

See Also

OrderLineColumn Class | Aptify.Applications.OrderEntry Namespace


OrderLineColumn.Width Field

public Width Width;

See Also

OrderLineColumn Class | Aptify.Applications.OrderEntry Namespace


OrderLineColumn.WordWrap Field

public WordWrap WordWrap;

See Also

OrderLineColumn Class | Aptify.Applications.OrderEntry Namespace


OrderLineColumn Properties

The properties of the OrderLineColumn class are listed below. For a complete list of OrderLineColumn class members, see the OrderLineColumn Members topic.

Public Instance Properties

BackColor
Caption
DataField
Font
ForeColor
Name

See Also

OrderLineColumn Class | Aptify.Applications.OrderEntry Namespace


BackColor Property

Aptify 5.0 Software Development Kit (SDK)

OrderLineColumn.BackColor Property

public Color BackColor {get; set;}

See Also

OrderLineColumn Class | Aptify.Applications.OrderEntry Namespace


Caption Property

Aptify 5.0 Software Development Kit (SDK)

OrderLineColumn.Caption Property

public String Caption {get; set;}

See Also

OrderLineColumn Class | Aptify.Applications.OrderEntry Namespace


DataField Property

Aptify 5.0 Software Development Kit (SDK)

OrderLineColumn.DataField Property

public String DataField {get; set;}

See Also

OrderLineColumn Class | Aptify.Applications.OrderEntry Namespace


Font Property

Aptify 5.0 Software Development Kit (SDK)

OrderLineColumn.Font Property

public Font Font {get; set;}

See Also

OrderLineColumn Class | Aptify.Applications.OrderEntry Namespace


ForeColor Property

Aptify 5.0 Software Development Kit (SDK)

OrderLineColumn.ForeColor Property

public Color ForeColor {get; set;}

See Also

OrderLineColumn Class | Aptify.Applications.OrderEntry Namespace


Name Property

Aptify 5.0 Software Development Kit (SDK)

OrderLineColumn.Name Property

public String Name {get;}

See Also

OrderLineColumn Class | Aptify.Applications.OrderEntry Namespace


OrderLineColumn.TextAlignmentEnum Enumeration

public enum OrderLineColumn.TextAlignmentEnum

Members

Member Name | Description
LeftTop |
LeftCenter |
LeftBottom |
CenterTop |
CenterCenter |
CenterBottom |
RightTop |
RightCenter |
RightBottom |
GeneralTop |
GeneralCenter |
GeneralBottom |

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrderLineControl (in AptifyOrderLineControl.dll)

See Also

Aptify.Applications.OrderEntry Namespace


OrderLineColumn.TextDirectionEnum Enumeration

public enum OrderLineColumn.TextDirectionEnum

Members

Member Name | Description
Normal |
Up |
Down |

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrderLineControl (in AptifyOrderLineControl.dll)

See Also

Aptify.Applications.OrderEntry Namespace


OrderLineColumn.TextEffectEnum Enumeration

public enum OrderLineColumn.TextEffectEnum

Members

Member Name | Description
Flat |
Raised |
Inset |

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrderLineControl (in AptifyOrderLineControl.dll)

See Also

Aptify.Applications.OrderEntry Namespace


OrderLineDetails Class

For a list of all members of this type, see OrderLineDetails Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
AptifyControlBase
OrderLineDetails

public class OrderLineDetails : AptifyControlBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrderLineControl (in AptifyOrderLineControl.dll)

See Also

OrderLineDetails Members | Aptify.Applications.OrderEntry Namespace


OrderLineDetails Members

OrderLineDetails overview

Public Instance Constructors

OrderLineDetails Constructor Initializes a new instance of the OrderLineDetails class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AddButton |
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Control (inherited from AptifyControlBase) |
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DataControl (inherited from AptifyControlBase) | Adds a reference to the object for the data control. In the case of it being added, the reference to the bound control base object is added to the data controls collection.
DisableGeDataTransfer (inherited from AptifyControlBase) | If true, the implementer is required to move the value to/from the bound control to the GE or other data access method.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
ExpandKits |
FieldHelp (inherited from AptifyControlBase) |
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateContext (inherited from AptifyControlBase) | Returns the reference that if is local that is returned else if a DataControl exists, it is returned.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpObject (inherited from AptifyControlBase) | This method is responsible for returning the context-specific help Object file location in the Aptify Object repository. The base class implementation returns the entity-level help, if available, and if not, returns the DefaultHelpObject
HelpURL (inherited from AptifyControlBase) | This method is responsible for returning the context-specific help URL file location within the HelpObject to use. The base class implementation returns the entity-level help URL, if available, and if not, returns Nothing, which results in the content page being displayed.
HideKitDetails |
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
ObjectRepository (inherited from AptifyControlBase) |
OrderLineControl |
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductLinkBox |
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
QuantityLabel |
QuantityText | Obsolete.
QuantityTextEditor |
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BoundControlConfig (inherited from AptifyControlBase) | Called by the data control to handle security,enable/disable settings, and set the label from data, if necessary. This is implemented by the sub class.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ClearData (inherited from AptifyControlBase) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DisplayControlHelp (inherited from AptifyControlBase) | This method will display control-level help information. This method will use the HelpTitle and HelpText overridable members to display the Field Help object from Aptify.Framework.WindowsControls.FieldHelp. If the title and text is desired to be overriden it is not necessary to override this method, rather override the HelpTitle and HelpText properties which are used by this method.
DisplayEntityHelp (inherited from AptifyControlBase) | This method is responsible for displaying the help file to the user and will attempt to provide context sensitive help based on the particular entity being displayed. If no entity-specific help file is available for the user then the standard Aptify Shell.Aptify Help file will be used to display help to the user. Override this method in sub-classes to change the method for displaying help.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetDefaultHelpObject (inherited from AptifyControlBase) | This method returns the default help object file in the Aptify Object repository to be used in the event that no entity-specific file exists
GetEntitySpecificHelpObject (inherited from AptifyControlBase) | This method returns the Aptify Object Repository Object location for the help file that is specific to this entity.
GetEntitySpecificHelpTopicURL (inherited from AptifyControlBase) | This method returns the Topic URL location within the help file that is specific to this entity.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseValueChanged (inherited from AptifyControlBase) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetUserCredential (inherited from AptifyControlBase) |
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
TransferDataToObject |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AddButtonClick |
AfterDisplayEntityHelp (inherited from AptifyControlBase) | This event is fired after the help file is displayed.
AfterRowAdded |
AfterRowChanged |
AfterRowDeleted |
AptifyControlBaseTextChanged (inherited from AptifyControlBase) |
AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BeforeDisplayEntityHelp (inherited from AptifyControlBase) | This event is fired before the help file is displayed. To prevent help from being displayed set the Cancel parameter to True.
BeforeRowAdded |
BeforeRowChanged |
BeforeRowDeleted |
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from AptifyControlBase) |
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from AptifyControlBase) |
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from AptifyControlBase) |
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from AptifyControlBase) |
KeyPress (inherited from AptifyControlBase) |
KeyUp (inherited from AptifyControlBase) |
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from AptifyControlBase) |
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from AptifyControlBase) |
MouseEnter (inherited from AptifyControlBase) |
MouseHover (inherited from AptifyControlBase) |
MouseLeave (inherited from AptifyControlBase) |
MouseMove (inherited from AptifyControlBase) |
MouseUp (inherited from AptifyControlBase) |
MouseWheel (inherited from AptifyControlBase) |
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
ProductValueChanged |
QuantityChanged |
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from AptifyControlBase) |
TotalsChanged |
Validated (inherited from AptifyControlBase) |
Validating (inherited from AptifyControlBase) |
ValueChanged (inherited from AptifyControlBase) |
VisibleChanged (inherited from AptifyControlBase) |

Protected Instance Fields

m_bOrderLineLocked
m_iDataControl (inherited from AptifyControlBase)
m_oAptifyApplication (inherited from AptifyControlBase)
m_oFormTemplateContext (inherited from AptifyControlBase)
m_OrderGE
m_oUserCredential (inherited from AptifyControlBase)

Protected Instance Properties

AptifyApplication (inherited from AptifyControlBase) | Returns an instance of the Aptify Application Object
AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
CurrencyTypeCache (inherited from AptifyControlBase) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DisplayName (inherited from AptifyControlBase) |
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HelpText (inherited from AptifyControlBase) |
HelpTitle (inherited from AptifyControlBase) | This property is designed to be overriden by subclasses that want to provide a different title. The base class returns "Aptify Help" for this property.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
InternalControl (inherited from AptifyControlBase) | Specifies the Main Control of interest in a composite control.
m_oInternalControl (inherited from AptifyControlBase) |
MyApplication (inherited from AptifyControlBase) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowDisplayHelpHyperlink (inherited from AptifyControlBase) | This property can be overriden by sub-classes to be able to selectively turn on or off the Display Help hyperlink that appears by default on the FieldHelp object.
UserCredential (inherited from AptifyControlBase) |
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AddButtonClicked |
AddCancellationItem |
AdjustFormScrollbars (inherited from ContainerControl) |
ConfigHelp (inherited from AptifyControlBase) | This method configures the base FieldHelp object and sets up a default string in the HelpText field. Sub-Classes should override this to implement specific help relevant to their context of use.
ConfigureOrganizationPermissions |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
DoFormComponentConfig |
Finalize (inherited from AptifyControlBase) |
FormComponentConfig (inherited from AptifyControlBase) |
FormComponentHide (inherited from AptifyControlBase) |
FormComponentShow | Overloaded.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RequiredGECheck (inherited from AptifyControlBase) |
RequiredPropertiesCheck (inherited from AptifyControlBase) |
ResetEntryLine |
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

OrderLineDetails Class | Aptify.Applications.OrderEntry Namespace


OrderLineDetails Constructor

Initializes a new instance of the OrderLineDetails class.

public OrderLineDetails();

See Also

OrderLineDetails Class | Aptify.Applications.OrderEntry Namespace


OrderLineDetails Fields

The fields of the OrderLineDetails class are listed below. For a complete list of OrderLineDetails class members, see the OrderLineDetails Members topic.

Protected Instance Fields

m_bOrderLineLocked
m_iDataControl (inherited from AptifyControlBase)
m_oAptifyApplication (inherited from AptifyControlBase)
m_oFormTemplateContext (inherited from AptifyControlBase)
m_OrderGE
m_oUserCredential (inherited from AptifyControlBase)

See Also

OrderLineDetails Class | Aptify.Applications.OrderEntry Namespace


OrderLineDetails.m_bOrderLineLocked Field

protected m_bOrderLineLocked m_bOrderLineLocked;

See Also

OrderLineDetails Class | Aptify.Applications.OrderEntry Namespace


OrderLineDetails.m_OrderGE Field

protected m_OrderGE m_OrderGE;

See Also

OrderLineDetails Class | Aptify.Applications.OrderEntry Namespace


OrderLineDetails Properties

The properties of the OrderLineDetails class are listed below. For a complete list of OrderLineDetails class members, see the OrderLineDetails Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AddButton |
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Control (inherited from AptifyControlBase) |
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DataControl (inherited from AptifyControlBase) | Adds a reference to the object for the data control. In the case of it being added, the reference to the bound control base object is added to the data controls collection.
DisableGeDataTransfer (inherited from AptifyControlBase) | If true, the implementer is required to move the value to/from the bound control to the GE or other data access method.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
ExpandKits |
FieldHelp (inherited from AptifyControlBase) |
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateContext (inherited from AptifyControlBase) | Returns the reference that if is local that is returned else if a DataControl exists, it is returned.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpObject (inherited from AptifyControlBase) | This method is responsible for returning the context-specific help Object file location in the Aptify Object repository. The base class implementation returns the entity-level help, if available, and if not, returns the DefaultHelpObject
HelpURL (inherited from AptifyControlBase) | This method is responsible for returning the context-specific help URL file location within the HelpObject to use. The base class implementation returns the entity-level help URL, if available, and if not, returns Nothing, which results in the content page being displayed.
HideKitDetails |
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
ObjectRepository (inherited from AptifyControlBase) |
OrderLineControl |
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductLinkBox |
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
QuantityLabel |
QuantityText | Obsolete.
QuantityTextEditor |
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AptifyApplication (inherited from AptifyControlBase) | Returns an instance of the Aptify Application Object
AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
CurrencyTypeCache (inherited from AptifyControlBase) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DisplayName (inherited from AptifyControlBase) |
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HelpText (inherited from AptifyControlBase) |
HelpTitle (inherited from AptifyControlBase) | This property is designed to be overriden by subclasses that want to provide a different title. The base class returns "Aptify Help" for this property.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
InternalControl (inherited from AptifyControlBase) | Specifies the Main Control of interest in a composite control.
m_oInternalControl (inherited from AptifyControlBase) |
MyApplication (inherited from AptifyControlBase) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowDisplayHelpHyperlink (inherited from AptifyControlBase) | This property can be overriden by sub-classes to be able to selectively turn on or off the Display Help hyperlink that appears by default on the FieldHelp object.
UserCredential (inherited from AptifyControlBase) |
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

OrderLineDetails Class | Aptify.Applications.OrderEntry Namespace


AddButton Property

Aptify 5.0 Software Development Kit (SDK)

OrderLineDetails.AddButton Property

public AptifyActiveButton AddButton {get;}

See Also

OrderLineDetails Class | Aptify.Applications.OrderEntry Namespace


ExpandKits Property

Aptify 5.0 Software Development Kit (SDK)

OrderLineDetails.ExpandKits Property

public CheckBox ExpandKits {get;}

See Also

OrderLineDetails Class | Aptify.Applications.OrderEntry Namespace


HideKitDetails Property

Aptify 5.0 Software Development Kit (SDK)

OrderLineDetails.HideKitDetails Property

public Boolean HideKitDetails {get; set;}

See Also

OrderLineDetails Class | Aptify.Applications.OrderEntry Namespace


OrderLineControl Property

Aptify 5.0 Software Development Kit (SDK)

OrderLineDetails.OrderLineControl Property

public OrderLine OrderLineControl {get;}

See Also

OrderLineDetails Class | Aptify.Applications.OrderEntry Namespace


ProductLinkBox Property

Aptify 5.0 Software Development Kit (SDK)

OrderLineDetails.ProductLinkBox Property

public AptifyLinkBox ProductLinkBox {get;}

See Also

OrderLineDetails Class | Aptify.Applications.OrderEntry Namespace


QuantityLabel Property

Aptify 5.0 Software Development Kit (SDK)

OrderLineDetails.QuantityLabel Property

public Label QuantityLabel {get;}

See Also

OrderLineDetails Class | Aptify.Applications.OrderEntry Namespace


QuantityText Property

Aptify 5.0 Software Development Kit (SDK)

OrderLineDetails.QuantityText Property

NOTE: This property is now obsolete.

QuantityText has been replaced with QuantityTextEditor. In Aptify 5.0, the internal Text Box for Quantity was replaced with a new control to provide uniform appearance and behavior.

public TextBox QuantityText {get;}

See Also

OrderLineDetails Class | Aptify.Applications.OrderEntry Namespace


QuantityTextEditor Property

Aptify 5.0 Software Development Kit (SDK)

OrderLineDetails.QuantityTextEditor Property

public UltraTextEditor QuantityTextEditor {get;}

See Also

OrderLineDetails Class | Aptify.Applications.OrderEntry Namespace


OrderLineDetails Methods

The methods of the OrderLineDetails class are listed below. For a complete list of OrderLineDetails class members, see the OrderLineDetails Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BoundControlConfig (inherited from AptifyControlBase) | Called by the data control to handle security,enable/disable settings, and set the label from data, if necessary. This is implemented by the sub class.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ClearData (inherited from AptifyControlBase) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DisplayControlHelp (inherited from AptifyControlBase) | This method will display control-level help information. This method will use the HelpTitle and HelpText overridable members to display the Field Help object from Aptify.Framework.WindowsControls.FieldHelp. If the title and text is desired to be overriden it is not necessary to override this method, rather override the HelpTitle and HelpText properties which are used by this method.
DisplayEntityHelp (inherited from AptifyControlBase) | This method is responsible for displaying the help file to the user and will attempt to provide context sensitive help based on the particular entity being displayed. If no entity-specific help file is available for the user then the standard Aptify Shell.Aptify Help file will be used to display help to the user. Override this method in sub-classes to change the method for displaying help.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetDefaultHelpObject (inherited from AptifyControlBase) | This method returns the default help object file in the Aptify Object repository to be used in the event that no entity-specific file exists
GetEntitySpecificHelpObject (inherited from AptifyControlBase) | This method returns the Aptify Object Repository Object location for the help file that is specific to this entity.
GetEntitySpecificHelpTopicURL (inherited from AptifyControlBase) | This method returns the Topic URL location within the help file that is specific to this entity.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseValueChanged (inherited from AptifyControlBase) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetUserCredential (inherited from AptifyControlBase) |
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
TransferDataToObject |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AddButtonClicked |
AddCancellationItem |
AdjustFormScrollbars (inherited from ContainerControl) |
ConfigHelp (inherited from AptifyControlBase) | This method configures the base FieldHelp object and sets up a default string in the HelpText field. Sub-Classes should override this to implement specific help relevant to their context of use.
ConfigureOrganizationPermissions |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
DoFormComponentConfig |
Finalize (inherited from AptifyControlBase) |
FormComponentConfig (inherited from AptifyControlBase) |
FormComponentHide (inherited from AptifyControlBase) |
FormComponentShow | Overloaded.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RequiredGECheck (inherited from AptifyControlBase) |
RequiredPropertiesCheck (inherited from AptifyControlBase) |
ResetEntryLine |
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

OrderLineDetails Class | Aptify.Applications.OrderEntry Namespace


OrderLineDetails.AddButtonClicked Method

protected virtual void AddButtonClicked();

See Also

OrderLineDetails Class | Aptify.Applications.OrderEntry Namespace


OrderLineDetails.AddCancellationItem Method

protected virtual void AddCancellationItem(
Int64 ProductID,
Decimal Quantity
);

See Also

OrderLineDetails Class | Aptify.Applications.OrderEntry Namespace


OrderLineDetails.ConfigureOrganizationPermissions Method

protected virtual void ConfigureOrganizationPermissions();

See Also

OrderLineDetails Class | Aptify.Applications.OrderEntry Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

OrderLineDetails.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

OrderLineDetails Class | Aptify.Applications.OrderEntry Namespace


OrderLineDetails.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

OrderLineDetails Class | Aptify.Applications.OrderEntry Namespace | OrderLineDetails.Dispose Overload List


OrderLineDetails.DoFormComponentConfig Method

protected override void DoFormComponentConfig(
AptifyFormTemplateContext FormTemplateContext
);

See Also

OrderLineDetails Class | Aptify.Applications.OrderEntry Namespace


FormComponentShow Method

Aptify 5.0 Software Development Kit (SDK)

OrderLineDetails.FormComponentShow Method

Overload List

protected override void FormComponentShow();

protected override void FormComponentShow(Boolean);

See Also

OrderLineDetails Class | Aptify.Applications.OrderEntry Namespace


OrderLineDetails.FormComponentShow Method ()

protected override void FormComponentShow();

Implements

IFormComponent.

See Also

OrderLineDetails Class | Aptify.Applications.OrderEntry Namespace | OrderLineDetails.FormComponentShow Overload List


OrderLineDetails.FormComponentShow Method (Boolean)

protected override void FormComponentShow(
Boolean Refresh
);

Implements

IFormComponent.

See Also

OrderLineDetails Class | Aptify.Applications.OrderEntry Namespace | OrderLineDetails.FormComponentShow Overload List


OrderLineDetails.Refresh Method

public override void Refresh();

Implements

IFormComponent.

See Also

OrderLineDetails Class | Aptify.Applications.OrderEntry Namespace


OrderLineDetails.ResetEntryLine Method

protected virtual void ResetEntryLine();

See Also

OrderLineDetails Class | Aptify.Applications.OrderEntry Namespace


OrderLineDetails.TransferDataToObject Method

public override void TransferDataToObject(
ref Boolean& Cancel
);

Implements

IFormComponent.

See Also

OrderLineDetails Class | Aptify.Applications.OrderEntry Namespace


OrderLineDetails Events

The events of the OrderLineDetails class are listed below. For a complete list of OrderLineDetails class members, see the OrderLineDetails Members topic.

Public Instance Events

AddButtonClick |
AfterDisplayEntityHelp (inherited from AptifyControlBase) | This event is fired after the help file is displayed.
AfterRowAdded |
AfterRowChanged |
AfterRowDeleted |
AptifyControlBaseTextChanged (inherited from AptifyControlBase) |
AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BeforeDisplayEntityHelp (inherited from AptifyControlBase) | This event is fired before the help file is displayed. To prevent help from being displayed set the Cancel parameter to True.
BeforeRowAdded |
BeforeRowChanged |
BeforeRowDeleted |
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from AptifyControlBase) |
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from AptifyControlBase) |
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from AptifyControlBase) |
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from AptifyControlBase) |
KeyPress (inherited from AptifyControlBase) |
KeyUp (inherited from AptifyControlBase) |
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from AptifyControlBase) |
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from AptifyControlBase) |
MouseEnter (inherited from AptifyControlBase) |
MouseHover (inherited from AptifyControlBase) |
MouseLeave (inherited from AptifyControlBase) |
MouseMove (inherited from AptifyControlBase) |
MouseUp (inherited from AptifyControlBase) |
MouseWheel (inherited from AptifyControlBase) |
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
ProductValueChanged |
QuantityChanged |
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from AptifyControlBase) |
TotalsChanged |
Validated (inherited from AptifyControlBase) |
Validating (inherited from AptifyControlBase) |
ValueChanged (inherited from AptifyControlBase) |
VisibleChanged (inherited from AptifyControlBase) |

See Also

OrderLineDetails Class | Aptify.Applications.OrderEntry Namespace


OrderLineDetails.OrderLineDetails.AddButtonClickEventHandler Event

public event OrderLineDetails.AddButtonClickEventHandler AddButtonClick;

See Also

OrderLineDetails Class | Aptify.Applications.OrderEntry Namespace


OrderLineDetails.OrderLineDetails.AfterRowAddedEventHandler Event

public event OrderLineDetails.AfterRowAddedEventHandler AfterRowAdded;

Event Data

The event handler receives an argument of type AfterRowAddedEventArgs containing data related to this event. The following AfterRowAddedEventArgs property provides information specific to this event.

Property | Description
OrderLine |

See Also

OrderLineDetails Class | Aptify.Applications.OrderEntry Namespace


OrderLineDetails.OrderLineDetails.AfterRowChangedEventHandler Event

public event OrderLineDetails.AfterRowChangedEventHandler AfterRowChanged;

Event Data

The event handler receives an argument of type AfterRowChangedEventArgs containing data related to this event. The following AfterRowChangedEventArgs properties provide information specific to this event.

Property | Description
OrderLine |
Row |

See Also

OrderLineDetails Class | Aptify.Applications.OrderEntry Namespace


OrderLineDetails.OrderLineDetails.AfterRowDeletedEventHandler Event

public event OrderLineDetails.AfterRowDeletedEventHandler AfterRowDeleted;

Event Data

The event handler receives an argument of type AfterRowDeletedEventArgs containing data related to this event. The following AfterRowDeletedEventArgs property provides information specific to this event.

Property | Description
OldRow |

See Also

OrderLineDetails Class | Aptify.Applications.OrderEntry Namespace


OrderLineDetails.OrderLineDetails.BeforeRowAddedEventHandler Event

public event OrderLineDetails.BeforeRowAddedEventHandler BeforeRowAdded;

Event Data

The event handler receives an argument of type BeforeRowAddedEventArgs containing data related to this event. The following BeforeRowAddedEventArgs properties provide information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.
OrderLine |

See Also

OrderLineDetails Class | Aptify.Applications.OrderEntry Namespace


OrderLineDetails.OrderLineDetails.BeforeRowChangedEventHandler Event

public event OrderLineDetails.BeforeRowChangedEventHandler BeforeRowChanged;

Event Data

The event handler receives an argument of type BeforeRowChangedEventArgs containing data related to this event. The following BeforeRowChangedEventArgs properties provide information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.
OrderLine |
Row |

See Also

OrderLineDetails Class | Aptify.Applications.OrderEntry Namespace


OrderLineDetails.OrderLineDetails.BeforeRowDeletedEventHandler Event

public event OrderLineDetails.BeforeRowDeletedEventHandler BeforeRowDeleted;

Event Data

The event handler receives an argument of type BeforeRowDeletedEventArgs containing data related to this event. The following BeforeRowDeletedEventArgs properties provide information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.
OldRow |
OrderLine |

See Also

OrderLineDetails Class | Aptify.Applications.OrderEntry Namespace


OrderLineDetails.OrderLineDetails.ProductValueChangedEventHandler Event

public event OrderLineDetails.ProductValueChangedEventHandler ProductValueChanged;

See Also

OrderLineDetails Class | Aptify.Applications.OrderEntry Namespace


OrderLineDetails.OrderLineDetails.QuantityChangedEventHandler Event

public event OrderLineDetails.QuantityChangedEventHandler QuantityChanged;

See Also

OrderLineDetails Class | Aptify.Applications.OrderEntry Namespace


OrderLineDetails.OrderLineDetails.TotalsChangedEventHandler Event

public event OrderLineDetails.TotalsChangedEventHandler TotalsChanged;

Event Data

The event handler receives an argument of type TotalsChangedEventArgs containing data related to this event. The following TotalsChangedEventArgs properties provide information specific to this event.

Property | Description
DiscountTotal |
GrandTotal |
HandlingCharge |
SalesTax |
ShippingCharge |
SubTotal |

See Also

OrderLineDetails Class | Aptify.Applications.OrderEntry Namespace


OrderLineDetails.AddButtonClickEventHandler Delegate

public delegate void OrderLineDetails.AddButtonClickEventHandler(
Object sender,
EventArgs e
);

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrderLineControl (in AptifyOrderLineControl.dll)

See Also

Aptify.Applications.OrderEntry Namespace


OrderLineDetails.AfterRowAddedEventHandler Delegate

public delegate void OrderLineDetails.AfterRowAddedEventHandler(
Object sender,
AfterRowAddedEventArgs e
);

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrderLineControl (in AptifyOrderLineControl.dll)

See Also

Aptify.Applications.OrderEntry Namespace


OrderLineDetails.AfterRowChangedEventHandler Delegate

public delegate void OrderLineDetails.AfterRowChangedEventHandler(
Object sender,
AfterRowChangedEventArgs e
);

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrderLineControl (in AptifyOrderLineControl.dll)

See Also

Aptify.Applications.OrderEntry Namespace


OrderLineDetails.AfterRowDeletedEventHandler Delegate

public delegate void OrderLineDetails.AfterRowDeletedEventHandler(
Object sender,
AfterRowDeletedEventArgs e
);

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrderLineControl (in AptifyOrderLineControl.dll)

See Also

Aptify.Applications.OrderEntry Namespace


OrderLineDetails.BeforeRowAddedEventHandler Delegate

public delegate void OrderLineDetails.BeforeRowAddedEventHandler(
Object sender,
BeforeRowAddedEventArgs e
);

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrderLineControl (in AptifyOrderLineControl.dll)

See Also

Aptify.Applications.OrderEntry Namespace


OrderLineDetails.BeforeRowChangedEventHandler Delegate

public delegate void OrderLineDetails.BeforeRowChangedEventHandler(
Object sender,
BeforeRowChangedEventArgs e
);

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrderLineControl (in AptifyOrderLineControl.dll)

See Also

Aptify.Applications.OrderEntry Namespace


OrderLineDetails.BeforeRowDeletedEventHandler Delegate

public delegate void OrderLineDetails.BeforeRowDeletedEventHandler(
Object sender,
BeforeRowDeletedEventArgs e
);

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrderLineControl (in AptifyOrderLineControl.dll)

See Also

Aptify.Applications.OrderEntry Namespace


OrderLineDetails.ProductValueChangedEventHandler Delegate

public delegate void OrderLineDetails.ProductValueChangedEventHandler(
Object sender,
Object OldValue,
Object NewValue
);

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrderLineControl (in AptifyOrderLineControl.dll)

See Also

Aptify.Applications.OrderEntry Namespace


OrderLineDetails.QuantityChangedEventHandler Delegate

public delegate void OrderLineDetails.QuantityChangedEventHandler(
Object sender,
EventArgs e
);

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrderLineControl (in AptifyOrderLineControl.dll)

See Also

Aptify.Applications.OrderEntry Namespace


OrderLineDetails.TotalsChangedEventHandler Delegate

public delegate void OrderLineDetails.TotalsChangedEventHandler(
Object sender,
TotalsChangedEventArgs e
);

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrderLineControl (in AptifyOrderLineControl.dll)

See Also

Aptify.Applications.OrderEntry Namespace


OrderLineInfo Class

For a list of all members of this type, see OrderLineInfo Members.

System.Object
OrderLineInfo

public class OrderLineInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: CancellationWizard (in CancellationWizard.dll)

See Also

OrderLineInfo Members | Aptify.Applications.OrderEntry Namespace


OrderLineInfo Members

OrderLineInfo overview

Public Instance Constructors

OrderLineInfo Constructor

Public Instance Fields

AvailableForCancel
IsCancelled
IsKitProduct
OrderLineID
OrderLineNumber
ParentLineNumber
Price
ProductID
ProductName
Quantity
QuantityAvailableForCancel
QuantityCancelled

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

OrderLineInfo Class | Aptify.Applications.OrderEntry Namespace


OrderLineInfo Constructor

public OrderLineInfo(
Int64 lOrderLineID,
Int32 iLineNumber,
Int32 iParent,
Int64 lProductID,
String sProductName,
Decimal dQuantity,
Boolean bIsKitProduct
);

See Also

OrderLineInfo Class | Aptify.Applications.OrderEntry Namespace


OrderLineInfo Fields

The fields of the OrderLineInfo class are listed below. For a complete list of OrderLineInfo class members, see the OrderLineInfo Members topic.

Public Instance Fields

AvailableForCancel
IsCancelled
IsKitProduct
OrderLineID
OrderLineNumber
ParentLineNumber
Price
ProductID
ProductName
Quantity
QuantityAvailableForCancel
QuantityCancelled

See Also

OrderLineInfo Class | Aptify.Applications.OrderEntry Namespace


OrderLineInfo.AvailableForCancel Field

public AvailableForCancel AvailableForCancel;

See Also

OrderLineInfo Class | Aptify.Applications.OrderEntry Namespace


OrderLineInfo.IsCancelled Field

public IsCancelled IsCancelled;

See Also

OrderLineInfo Class | Aptify.Applications.OrderEntry Namespace


OrderLineInfo.IsKitProduct Field

public IsKitProduct IsKitProduct;

See Also

OrderLineInfo Class | Aptify.Applications.OrderEntry Namespace


OrderLineInfo.OrderLineID Field

public OrderLineID OrderLineID;

See Also

OrderLineInfo Class | Aptify.Applications.OrderEntry Namespace


OrderLineInfo.OrderLineNumber Field

public OrderLineNumber OrderLineNumber;

See Also

OrderLineInfo Class | Aptify.Applications.OrderEntry Namespace


OrderLineInfo.ParentLineNumber Field

public ParentLineNumber ParentLineNumber;

See Also

OrderLineInfo Class | Aptify.Applications.OrderEntry Namespace


OrderLineInfo.Price Field

public Price Price;

See Also

OrderLineInfo Class | Aptify.Applications.OrderEntry Namespace


OrderLineInfo.ProductID Field

public ProductID ProductID;

See Also

OrderLineInfo Class | Aptify.Applications.OrderEntry Namespace


OrderLineInfo.ProductName Field

public ProductName ProductName;

See Also

OrderLineInfo Class | Aptify.Applications.OrderEntry Namespace


OrderLineInfo.Quantity Field

public Quantity Quantity;

See Also

OrderLineInfo Class | Aptify.Applications.OrderEntry Namespace


OrderLineInfo.QuantityAvailableForCancel Field

public QuantityAvailableForCancel QuantityAvailableForCancel;

See Also

OrderLineInfo Class | Aptify.Applications.OrderEntry Namespace


OrderLineInfo.QuantityCancelled Field

public QuantityCancelled QuantityCancelled;

See Also

OrderLineInfo Class | Aptify.Applications.OrderEntry Namespace


OrderLinesEntity Class

Represents the sub-class to AptifyGenericEntity that is used for the OrderLines entity and also implements the ICheckInventory and IProductPrice interfaces.

For a list of all members of this type, see OrderLinesEntity Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
OrderLinesClass
OrderLinesEntity

public class OrderLinesEntity : OrderLinesClass, ICheckInventory, IProductPrice

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

OrderLinesEntity Members | Aptify.Applications.OrderEntry Namespace


OrderLinesEntity Members

OrderLinesEntity overview

Public Instance Constructors

OrderLinesEntity Constructor Initializes a new instance of the OrderLinesEntity class.

Public Instance Properties

AgentOrderNumber (inherited from OrderLinesClass) |
Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
AutoRenew (inherited from OrderLinesClass) |
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
CampaignCodeID | Overloaded.
ChapterID (inherited from OrderLinesClass) |
Comments (inherited from OrderLinesClass) |
CommentsExternal (inherited from OrderLinesClass) |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
Description (inherited from OrderLinesClass) |
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
Discount |
DiscountAmount |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
Extended |
ExtendedAttributeID | Overloaded.
ExtendedOrderDetailEntity |
ExtendedOrderDetailEntityName |
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
GrossDiscount |
GrossRevenue | If the type of the line item is not part of a kit or a kit item itself, then it is simply price * quantity * SubscriptionCopies. If it is part of a kit, or a top-level kit item, a formula must be applied to distribute the kit's Gross Revenue amongst the kit components.
ID (inherited from OrderLinesClass) |
InHonorOfID (inherited from OrderLinesClass) |
InMemoryOfID (inherited from OrderLinesClass) |
InventoryLocationID | Overloaded.
IsBulkSubscription (inherited from OrderLinesClass) |
IsDirty | If the OrderLines record has an Extended Order Detail record and the Extended Order Detail object has been loaded, return the IsDirty property of the OrderLines record or'd with the IsDirty property for the Extended Order Detail record.
IsPartofKit | Uses the ParentSequnce value to determine whether or not the OrderLine is part of a kit. If ParentSequence is a number greater than 0, it is part of a kit.
LastError | Provides the last error information for the OrderLines object. If an Extended Order Detal Object is loaded, any LastError information from that object will be appended and returned.
LastUserError | Provides the last error information for the OrderLines object designed for the user. If an Extended Order Detal Object is loaded, any LastUserError information from that object will be appended and returned.
NotReturnedToStock (inherited from OrderLinesClass) |
OrderID (inherited from OrderLinesClass) |
OriginalOrderDetailID | Overloaded.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentOrdersEntity | Takes the OrderLine's ParentGE property value and casts it to an OrdersEntity object
ParentSequence (inherited from OrderLinesClass) |
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
Price |
PriceName (inherited from OrderLinesClass) |
PriceOverrideComment (inherited from OrderLinesClass) |
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
Product (inherited from OrderLinesClass) |
ProductCache | Returns access to the internal reference to the instance of the OrderProductCache object
ProductData |
ProductID | Overloaded.
ProductType (inherited from OrderLinesClass) |
PurchaseType | Overloaded.
Quantity |
QuantityShipped |
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML | Adds additional information if the orderline is an extended orderline
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RelatedProducts | The list of products related to the current Order Line gathered from the Related Products object's GetRelatedProducts method. If the Related Products functionality is not enabled (Orders Entity Attribute, RelatedProductsEnabled = 0), Nothing will be returned.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Sequence (inherited from OrderLinesClass) |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
ShipToAddressID (inherited from OrderLinesClass) |
ShipToAddrLine1 (inherited from OrderLinesClass) |
ShipToAddrLine2 (inherited from OrderLinesClass) |
ShipToAddrLine3 (inherited from OrderLinesClass) |
ShipToAreaCode (inherited from OrderLinesClass) |
ShipToCity (inherited from OrderLinesClass) |
ShipToCountry (inherited from OrderLinesClass) |
ShipToCountryCode (inherited from OrderLinesClass) |
ShipToCounty (inherited from OrderLinesClass) |
ShipToID (inherited from OrderLinesClass) |
ShipToName (inherited from OrderLinesClass) |
ShipToPhone (inherited from OrderLinesClass) |
ShipToPhoneExtension (inherited from OrderLinesClass) |
ShipToPhoneID (inherited from OrderLinesClass) |
ShipToState (inherited from OrderLinesClass) |
ShipToZipCode (inherited from OrderLinesClass) |
ShipType (inherited from OrderLinesClass) |
ShipTypeID (inherited from OrderLinesClass) |
SubscriberID (inherited from OrderLinesClass) |
SubscriptionCopies (inherited from OrderLinesClass) |
SubscriptionStartDate (inherited from OrderLinesClass) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
Taxable (inherited from OrderLinesClass) |
TaxIncludedInPrice (inherited from OrderLinesClass) |
TaxJurisdiction (inherited from OrderLinesClass) |
TaxJurisdictionID (inherited from OrderLinesClass) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.
UserPricingOverride (inherited from OrderLinesClass) |

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CalculateDerivedPrice |
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
CheckInventory | Retrieves, if necessary, and instantiates the appropriate Check Inventory Plug In, based on the Order Line's Product's Product Type and delegates to that object's CheckInventory method. If AllowGUI is true and
ClearDirtyFlags |
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config | Overloaded.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded.
ConfigCheckInventory | No functionality has been implemented for this method. The Application object will be provided by the object's constructor. This method has been implemented for compatibility with the ICheckInventory interface.
ConfigProductPrice | No functionality has been implemented for this method. The Application object will be provided by the object's constructor. This method has been implemented for compatibility with the IProductPrice interface.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetComponentPartQuantity | Given an Assembly Product and one of its Component Products, the Quantity of the Component Product defined in the Assembly will be returned.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInventoryLocation | Purpose of function is to return the appropriate inventory location that should be used to reserve inventory for a particular order line. Retrieves, if necessary, and instantiates the appropriate Check Inventory Plug In, based on the Order Line's Product's Product Type and delegates to that object's GetInventoryLocation method.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetPrice |
GetPricingPermissions |
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValidPriceList |
GetValue | Overloaded. Deletes to the GE's GetValue unless FieldName is _xOrderStatus or _sOrderDropShip. Both fields are legacy fields that were used to pass information from the Order object to the OrderLines object. Now, each Order Line object has the ability to directly reference the Orders GE via the ParentGE property.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load | Overloaded.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord |
OrderLineTaxes (inherited from OrderLinesClass) |
OrderLineTaxesObject (inherited from OrderLinesClass) |
RollbackRecordID | Override adds support for Extended Order Detail GE, if the Order Line has one. If the ExtendedOrderDetailGE is defined, it's RollbackRecordID method will be called prior to calling the Base Class' RollbackRecordID method.
RollbackTransaction | Override adds support for Extended Order Detail GE, if the Order Line has one. If the ExtendedOrderDetailGE is defined, it's RollbackTransaction method will be called prior to calling the Base Class' RollbackTransaction method.
RoundPrice |
Save | Overloaded.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetProductPrice | Sets the Price on the Order Line
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
Ship | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity) |
m_listRelatedProducts |
m_sTempRecordChangeString (inherited from AptifyGenericEntity) |
m_sTempRecordChangeXML (inherited from AptifyGenericEntity) |
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity) |
OrderLinePriceTriggers | A collection of Field Names that cause

Protected Instance Properties

CheckInventoryObject | Responsible for retrieving and instantiating the correct Check Inventory object for the Product. Product Types can have a specific implementation of the Check Inventory object. If a Product Type does not have a specific Check Inventory Object defined, the core Check Inventory object will be used.
CheckInventoryPlugIn | Retrieves the Check Inventory Plug In meta-data for the current Product's Product Type. The meta-data can come from the Product Type's Attributes (CheckInventoryObject, CheckInventoryAssembly and CheckInventoryClass) or, if those Product Attributes are not defined for the current Product Type, the information is retrieved from the Orders Entity Plug In, Check Inventory.
CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
ProductPriceObject | Responsible for retrieving and instantiating the core Product Price object. The core Product Price meta-data is defined as a Product Pricing Entity Plug In in the Products Entity.
ProductPricePlugIn | Retrieves the core Product Price Plug In meta-data. The information is retrieved from the Products Entity Plug In, Product Pricing.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RelatedProductsEnabled | Core implementation uses the Entity Attribute RelatedProductsEnabled on the Orders Entity. Default to True
RelatedProductsObject |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AddFieldValueChangedEventHandlers | Configures the Fields to fire the ValueChanged events and adds Event Handlers to for the AfterValueChanged event. The core EventHandler is the OrderLinesFields_AfterValueChanged method. The following fields are monitored: ProductID, Quantity, Price, Discount and Subscription Copies.
AfterEmbeddedLoaded |
AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
CalculateExtended | Calculates the Extended amount and uses that value to set the Extended field.
CheckPriceCalculationTrigger | If the Order has not been shipped and the UserPricingOverride flag has not been set, the OrderLinePriceTriggers collection will be evaluated. Changes to the Price If a match to FieldName is found, the Order Line's Price will be recalculated. The FieldNames Price, PriceName, Extended and Quantity are ignored.
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InitializeOrderLineAddressFields |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
LoadProductPriceTriggers | Loads the OrderLinePriceTriggers list with fields from OrderLines that are listed in Filter Rules associated with the current Order Line's Product. If ProductID is not set, the list will be cleared.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
OrderLineAddressFields_AfterValueChanged |
OrderLinesFields_AfterValueChanged |
OrderLinesFields_BeforeValueChanged |
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCampaignPricing |
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupExtendedOrderDetailEntity |
SetupOrderLineProductInfo | Called when the ProductID is set for an OrderLine. This method populates the OrderLine with information about the Product.
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateCancellationOrderLine |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace


OrderLinesEntity Constructor

Initializes a new instance of the OrderLinesEntity class.

public OrderLinesEntity();

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace


OrderLinesEntity Fields

The fields of the OrderLinesEntity class are listed below. For a complete list of OrderLinesEntity class members, see the OrderLinesEntity Members topic.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity) |
m_listRelatedProducts |
m_sTempRecordChangeString (inherited from AptifyGenericEntity) |
m_sTempRecordChangeXML (inherited from AptifyGenericEntity) |
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity) |
OrderLinePriceTriggers | A collection of Field Names that cause

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace


OrderLinesEntity.m_listRelatedProducts Field

protected m_listRelatedProducts m_listRelatedProducts;

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace


OrderLinesEntity.OrderLinePriceTriggers Field

A collection of Field Names that cause

protected OrderLinePriceTriggers OrderLinePriceTriggers;

Remarks

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace


OrderLinesEntity Properties

The properties of the OrderLinesEntity class are listed below. For a complete list of OrderLinesEntity class members, see the OrderLinesEntity Members topic.

Public Instance Properties

AgentOrderNumber (inherited from OrderLinesClass) |
Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
AutoRenew (inherited from OrderLinesClass) |
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
CampaignCodeID | Overloaded.
ChapterID (inherited from OrderLinesClass) |
Comments (inherited from OrderLinesClass) |
CommentsExternal (inherited from OrderLinesClass) |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
Description (inherited from OrderLinesClass) |
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
Discount |
DiscountAmount |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
Extended |
ExtendedAttributeID | Overloaded.
ExtendedOrderDetailEntity |
ExtendedOrderDetailEntityName |
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
GrossDiscount |
GrossRevenue | If the type of the line item is not part of a kit or a kit item itself, then it is simply price * quantity * SubscriptionCopies. If it is part of a kit, or a top-level kit item, a formula must be applied to distribute the kit's Gross Revenue amongst the kit components.
ID (inherited from OrderLinesClass) |
InHonorOfID (inherited from OrderLinesClass) |
InMemoryOfID (inherited from OrderLinesClass) |
InventoryLocationID | Overloaded.
IsBulkSubscription (inherited from OrderLinesClass) |
IsDirty | If the OrderLines record has an Extended Order Detail record and the Extended Order Detail object has been loaded, return the IsDirty property of the OrderLines record or'd with the IsDirty property for the Extended Order Detail record.
IsPartofKit | Uses the ParentSequnce value to determine whether or not the OrderLine is part of a kit. If ParentSequence is a number greater than 0, it is part of a kit.
LastError | Provides the last error information for the OrderLines object. If an Extended Order Detal Object is loaded, any LastError information from that object will be appended and returned.
LastUserError | Provides the last error information for the OrderLines object designed for the user. If an Extended Order Detal Object is loaded, any LastUserError information from that object will be appended and returned.
NotReturnedToStock (inherited from OrderLinesClass) |
OrderID (inherited from OrderLinesClass) |
OriginalOrderDetailID | Overloaded.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentOrdersEntity | Takes the OrderLine's ParentGE property value and casts it to an OrdersEntity object
ParentSequence (inherited from OrderLinesClass) |
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
Price |
PriceName (inherited from OrderLinesClass) |
PriceOverrideComment (inherited from OrderLinesClass) |
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
Product (inherited from OrderLinesClass) |
ProductCache | Returns access to the internal reference to the instance of the OrderProductCache object
ProductData |
ProductID | Overloaded.
ProductType (inherited from OrderLinesClass) |
PurchaseType | Overloaded.
Quantity |
QuantityShipped |
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML | Adds additional information if the orderline is an extended orderline
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RelatedProducts | The list of products related to the current Order Line gathered from the Related Products object's GetRelatedProducts method. If the Related Products functionality is not enabled (Orders Entity Attribute, RelatedProductsEnabled = 0), Nothing will be returned.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Sequence (inherited from OrderLinesClass) |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
ShipToAddressID (inherited from OrderLinesClass) |
ShipToAddrLine1 (inherited from OrderLinesClass) |
ShipToAddrLine2 (inherited from OrderLinesClass) |
ShipToAddrLine3 (inherited from OrderLinesClass) |
ShipToAreaCode (inherited from OrderLinesClass) |
ShipToCity (inherited from OrderLinesClass) |
ShipToCountry (inherited from OrderLinesClass) |
ShipToCountryCode (inherited from OrderLinesClass) |
ShipToCounty (inherited from OrderLinesClass) |
ShipToID (inherited from OrderLinesClass) |
ShipToName (inherited from OrderLinesClass) |
ShipToPhone (inherited from OrderLinesClass) |
ShipToPhoneExtension (inherited from OrderLinesClass) |
ShipToPhoneID (inherited from OrderLinesClass) |
ShipToState (inherited from OrderLinesClass) |
ShipToZipCode (inherited from OrderLinesClass) |
ShipType (inherited from OrderLinesClass) |
ShipTypeID (inherited from OrderLinesClass) |
SubscriberID (inherited from OrderLinesClass) |
SubscriptionCopies (inherited from OrderLinesClass) |
SubscriptionStartDate (inherited from OrderLinesClass) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
Taxable (inherited from OrderLinesClass) |
TaxIncludedInPrice (inherited from OrderLinesClass) |
TaxJurisdiction (inherited from OrderLinesClass) |
TaxJurisdictionID (inherited from OrderLinesClass) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.
UserPricingOverride (inherited from OrderLinesClass) |

Protected Instance Properties

CheckInventoryObject | Responsible for retrieving and instantiating the correct Check Inventory object for the Product. Product Types can have a specific implementation of the Check Inventory object. If a Product Type does not have a specific Check Inventory Object defined, the core Check Inventory object will be used.
CheckInventoryPlugIn | Retrieves the Check Inventory Plug In meta-data for the current Product's Product Type. The meta-data can come from the Product Type's Attributes (CheckInventoryObject, CheckInventoryAssembly and CheckInventoryClass) or, if those Product Attributes are not defined for the current Product Type, the information is retrieved from the Orders Entity Plug In, Check Inventory.
CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
ProductPriceObject | Responsible for retrieving and instantiating the core Product Price object. The core Product Price meta-data is defined as a Product Pricing Entity Plug In in the Products Entity.
ProductPricePlugIn | Retrieves the core Product Price Plug In meta-data. The information is retrieved from the Products Entity Plug In, Product Pricing.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RelatedProductsEnabled | Core implementation uses the Entity Attribute RelatedProductsEnabled on the Orders Entity. Default to True
RelatedProductsObject |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace


CampaignCodeID Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesEntity.CampaignCodeID Property

new public Int64 CampaignCodeID {get; set;}

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace


CheckInventoryObject Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesEntity.CheckInventoryObject Property

Responsible for retrieving and instantiating the correct Check Inventory object for the Product. Product Types can have a specific implementation of the Check Inventory object. If a Product Type does not have a specific Check Inventory Object defined, the core Check Inventory object will be used.

protected ICheckInventory CheckInventoryObject {get;}

Property Value

Remarks

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace


CheckInventoryPlugIn Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesEntity.CheckInventoryPlugIn Property

Retrieves the Check Inventory Plug In meta-data for the current Product's Product Type. The meta-data can come from the Product Type's Attributes (CheckInventoryObject, CheckInventoryAssembly and CheckInventoryClass) or, if those Product Attributes are not defined for the current Product Type, the information is retrieved from the Orders Entity Plug In, Check Inventory.

protected virtual ComponentPlugIn CheckInventoryPlugIn {get;}

Property Value

Remarks

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace


Discount Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesEntity.Discount Property

new public Decimal Discount {get; set;}

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace


DiscountAmount Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesEntity.DiscountAmount Property

new public Decimal DiscountAmount {get;}

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace


Extended Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesEntity.Extended Property

new public Decimal Extended {get;}

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace


ExtendedAttributeID Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesEntity.ExtendedAttributeID Property

new public Int64 ExtendedAttributeID {get; set;}

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace


ExtendedOrderDetailEntity Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesEntity.ExtendedOrderDetailEntity Property

public virtual ExtendedOrderDetailGE ExtendedOrderDetailEntity {get; set;}

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace


ExtendedOrderDetailEntityName Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesEntity.ExtendedOrderDetailEntityName Property

public String ExtendedOrderDetailEntityName {get;}

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace


GrossDiscount Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesEntity.GrossDiscount Property

public virtual Decimal GrossDiscount {get;}

Property Value

Remarks

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace


GrossRevenue Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesEntity.GrossRevenue Property

If the type of the line item is not part of a kit or a kit item itself, then it is simply price * quantity * SubscriptionCopies. If it is part of a kit, or a top-level kit item, a formula must be applied to distribute the kit's Gross Revenue amongst the kit components.

public virtual Decimal GrossRevenue {get;}

Property Value

Remarks

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace


InventoryLocationID Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesEntity.InventoryLocationID Property

new public Int64 InventoryLocationID {get; set;}

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace


IsDirty Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesEntity.IsDirty Property

If the OrderLines record has an Extended Order Detail record and the Extended Order Detail object has been loaded, return the IsDirty property of the OrderLines record or'd with the IsDirty property for the Extended Order Detail record.

public override Boolean IsDirty {get;}

Property Value

Remarks

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace


IsPartofKit Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesEntity.IsPartofKit Property

Uses the ParentSequnce value to determine whether or not the OrderLine is part of a kit. If ParentSequence is a number greater than 0, it is part of a kit.

public virtual Boolean IsPartofKit {get;}

Property Value

Remarks

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace


LastError Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesEntity.LastError Property

Provides the last error information for the OrderLines object. If an Extended Order Detal Object is loaded, any LastError information from that object will be appended and returned.

public override String LastError {get;}

Property Value

Remarks

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace


LastUserError Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesEntity.LastUserError Property

Provides the last error information for the OrderLines object designed for the user. If an Extended Order Detal Object is loaded, any LastUserError information from that object will be appended and returned.

public override String LastUserError {get;}

Property Value

Remarks

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace


OriginalOrderDetailID Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesEntity.OriginalOrderDetailID Property

new public Int64 OriginalOrderDetailID {get; set;}

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace


ParentOrdersEntity Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesEntity.ParentOrdersEntity Property

Takes the OrderLine's ParentGE property value and casts it to an OrdersEntity object

public OrdersEntity ParentOrdersEntity {get;}

Property Value

Remarks

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace


Price Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesEntity.Price Property

new public Decimal Price {get; set;}

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace


ProductCache Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesEntity.ProductCache Property

Returns access to the internal reference to the instance of the OrderProductCache object

public virtual OrderProductCache ProductCache {get;}

Property Value

Remarks

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace


ProductData Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesEntity.ProductData Property

public ProductData ProductData {get;}

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace


ProductID Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesEntity.ProductID Property

new public Int64 ProductID {get; set;}

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace


ProductPriceObject Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesEntity.ProductPriceObject Property

Responsible for retrieving and instantiating the core Product Price object. The core Product Price meta-data is defined as a Product Pricing Entity Plug In in the Products Entity.

protected IProductPrice ProductPriceObject {get;}

Property Value

Remarks

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace


ProductPricePlugIn Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesEntity.ProductPricePlugIn Property

Retrieves the core Product Price Plug In meta-data. The information is retrieved from the Products Entity Plug In, Product Pricing.

protected virtual ComponentPlugIn ProductPricePlugIn {get;}

Property Value

Remarks

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace


PurchaseType Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesEntity.PurchaseType Property

new public OrderLinesEntity.PurchaseTypes PurchaseType {get;}

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace


Quantity Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesEntity.Quantity Property

new public Decimal Quantity {get; set;}

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace


QuantityShipped Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesEntity.QuantityShipped Property

new public Decimal QuantityShipped {get; set;}

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace


RecordChangeXML Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesEntity.RecordChangeXML Property

Adds additional information if the orderline is an extended orderline

public override String RecordChangeXML {get;}

Property Value

Remarks

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace


RelatedProducts Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesEntity.RelatedProducts Property

The list of products related to the current Order Line gathered from the Related Products object's GetRelatedProducts method. If the Related Products functionality is not enabled (Orders Entity Attribute, RelatedProductsEnabled = 0), Nothing will be returned.

public virtual List<T> RelatedProducts {get;}

Property Value

Remarks

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace


RelatedProductsEnabled Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesEntity.RelatedProductsEnabled Property

Core implementation uses the Entity Attribute RelatedProductsEnabled on the Orders Entity. Default to True

protected virtual Boolean RelatedProductsEnabled {get;}

Property Value

Remarks

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace


RelatedProductsObject Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesEntity.RelatedProductsObject Property

protected virtual IRelatedProducts RelatedProductsObject {get;}

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace


OrderLinesEntity Methods

The methods of the OrderLinesEntity class are listed below. For a complete list of OrderLinesEntity class members, see the OrderLinesEntity Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CalculateDerivedPrice |
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
CheckInventory | Retrieves, if necessary, and instantiates the appropriate Check Inventory Plug In, based on the Order Line's Product's Product Type and delegates to that object's CheckInventory method. If AllowGUI is true and
ClearDirtyFlags |
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config | Overloaded.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded.
ConfigCheckInventory | No functionality has been implemented for this method. The Application object will be provided by the object's constructor. This method has been implemented for compatibility with the ICheckInventory interface.
ConfigProductPrice | No functionality has been implemented for this method. The Application object will be provided by the object's constructor. This method has been implemented for compatibility with the IProductPrice interface.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetComponentPartQuantity | Given an Assembly Product and one of its Component Products, the Quantity of the Component Product defined in the Assembly will be returned.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInventoryLocation | Purpose of function is to return the appropriate inventory location that should be used to reserve inventory for a particular order line. Retrieves, if necessary, and instantiates the appropriate Check Inventory Plug In, based on the Order Line's Product's Product Type and delegates to that object's GetInventoryLocation method.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetPrice |
GetPricingPermissions |
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValidPriceList |
GetValue | Overloaded. Deletes to the GE's GetValue unless FieldName is _xOrderStatus or _sOrderDropShip. Both fields are legacy fields that were used to pass information from the Order object to the OrderLines object. Now, each Order Line object has the ability to directly reference the Orders GE via the ParentGE property.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load | Overloaded.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord |
OrderLineTaxes (inherited from OrderLinesClass) |
OrderLineTaxesObject (inherited from OrderLinesClass) |
RollbackRecordID | Override adds support for Extended Order Detail GE, if the Order Line has one. If the ExtendedOrderDetailGE is defined, it's RollbackRecordID method will be called prior to calling the Base Class' RollbackRecordID method.
RollbackTransaction | Override adds support for Extended Order Detail GE, if the Order Line has one. If the ExtendedOrderDetailGE is defined, it's RollbackTransaction method will be called prior to calling the Base Class' RollbackTransaction method.
RoundPrice |
Save | Overloaded.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetProductPrice | Sets the Price on the Order Line
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
Ship | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AddFieldValueChangedEventHandlers | Configures the Fields to fire the ValueChanged events and adds Event Handlers to for the AfterValueChanged event. The core EventHandler is the OrderLinesFields_AfterValueChanged method. The following fields are monitored: ProductID, Quantity, Price, Discount and Subscription Copies.
AfterEmbeddedLoaded |
AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
CalculateExtended | Calculates the Extended amount and uses that value to set the Extended field.
CheckPriceCalculationTrigger | If the Order has not been shipped and the UserPricingOverride flag has not been set, the OrderLinePriceTriggers collection will be evaluated. Changes to the Price If a match to FieldName is found, the Order Line's Price will be recalculated. The FieldNames Price, PriceName, Extended and Quantity are ignored.
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InitializeOrderLineAddressFields |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
LoadProductPriceTriggers | Loads the OrderLinePriceTriggers list with fields from OrderLines that are listed in Filter Rules associated with the current Order Line's Product. If ProductID is not set, the list will be cleared.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
OrderLineAddressFields_AfterValueChanged |
OrderLinesFields_AfterValueChanged |
OrderLinesFields_BeforeValueChanged |
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCampaignPricing |
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupExtendedOrderDetailEntity |
SetupOrderLineProductInfo | Called when the ProductID is set for an OrderLine. This method populates the OrderLine with information about the Product.
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateCancellationOrderLine |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace


OrderLinesEntity.AddFieldValueChangedEventHandlers Method

Configures the Fields to fire the ValueChanged events and adds Event Handlers to for the AfterValueChanged event. The core EventHandler is the OrderLinesFields_AfterValueChanged method. The following fields are monitored: ProductID, Quantity, Price, Discount and Subscription Copies.

protected virtual void AddFieldValueChangedEventHandlers();

Remarks

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace


OrderLinesEntity.AfterEmbeddedLoaded Method

protected virtual void AfterEmbeddedLoaded(
AptifyDataFieldBase sender,
AfterLoadEmbeddedObjectEventArgs e
);

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace


OrderLinesEntity.CalculateDerivedPrice Method

public decimal CalculateDerivedPrice(
Decimal BasePrice,
Decimal PercentOfBase,
PriceRoundingType RoundingType,
Decimal RoundingAmount
);

Implements

IProductPrice.

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace


OrderLinesEntity.CalculateExtended Method

Calculates the Extended amount and uses that value to set the Extended field.

protected virtual void CalculateExtended();

Remarks

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace


OrderLinesEntity.CheckInventory Method

Retrieves, if necessary, and instantiates the appropriate Check Inventory Plug In, based on the Order Line's Product's Product Type and delegates to that object's CheckInventory method. If AllowGUI is true and

public void CheckInventory(
Int64 ProductID,
Decimal Quantity,
ref Boolean& Required,
ref Decimal& QuantityAvailable,
ref Decimal& QuantityOnHand,
ref Decimal& QuantityOnOrder,
ref Decimal& QuantityReserved,
ref Decimal& QuantityShipped,
ref InventoryStatus& Status,
OrderLinesEntity OrderDetailGE,
Boolean AllowGUI,
ref String& Message
);

Parameters

ProductID
Quantity
Required
QuantityAvailable
QuantityOnHand
QuantityOnOrder
QuantityReserved
QuantityShipped
Status
OrderDetailGE
Internal implementation sets this parameter to the current OrderLines object instance (itself).
AllowGUI
Message

Implements

ICheckInventory.

Remarks

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace


OrderLinesEntity.CheckPriceCalculationTrigger Method

If the Order has not been shipped and the UserPricingOverride flag has not been set, the OrderLinePriceTriggers collection will be evaluated. Changes to the Price If a match to FieldName is found, the Order Line's Price will be recalculated. The FieldNames Price, PriceName, Extended and Quantity are ignored.

protected virtual void CheckPriceCalculationTrigger(
String FieldName
);

Remarks

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace


OrderLinesEntity.ClearDirtyFlags Method

public override void ClearDirtyFlags();

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace


Config Method

Aptify 5.0 Software Development Kit (SDK)

OrderLinesEntity.Config Method

Overload List

public override void Config(AptifySubTypeBase);

public override void Config(AptifySubTypeBase,Int64);

Inherited from AptifyGenericEntityBase.

public virtual void Config(UserCredentials,String);

Inherited from AptifyGenericEntity.

public override void Config(UserCredentials,String,Int64);

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace


OrderLinesEntity.Config Method (AptifySubTypeBase)

public override void Config(
AptifySubTypeBase subType
);

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace | OrderLinesEntity.Config Overload List


OrderLinesEntity.Config Method (AptifySubTypeBase, Int64)

public override void Config(
AptifySubTypeBase subType,
Int64 RecordID
);

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace | OrderLinesEntity.Config Overload List


OrderLinesEntity.ConfigCheckInventory Method

No functionality has been implemented for this method. The Application object will be provided by the object's constructor. This method has been implemented for compatibility with the ICheckInventory interface.

public void ConfigCheckInventory(
AptifyApplication Application
);

Parameters

Application

Implements

ICheckInventory.

Remarks

This method does nothing for the OrderLinesEntity object. The Application object will be set in the object's constructor. This method is implemented only for compatibility with the ICheckInventory interface.

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace


OrderLinesEntity.ConfigProductPrice Method

No functionality has been implemented for this method. The Application object will be provided by the object's constructor. This method has been implemented for compatibility with the IProductPrice interface.

public void ConfigProductPrice(
AptifyApplication Application
);

Parameters

Application

Implements

IProductPrice.

Remarks

This method does nothing for the OrderLinesEntity object. The Application object will be set in the object's constructor. This method is implemented only for compatibility with the IProductPrice interface.

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace


OrderLinesEntity.GetComponentPartQuantity Method

Given an Assembly Product and one of its Component Products, the Quantity of the Component Product defined in the Assembly will be returned.

public decimal GetComponentPartQuantity(
Int64 ProductID,
Int64 ComponentProductID
);

Parameters

ProductID
ComponentProductID

Return Value

Remarks

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace


OrderLinesEntity.GetInventoryLocation Method

Purpose of function is to return the appropriate inventory location that should be used to reserve inventory for a particular order line. Retrieves, if necessary, and instantiates the appropriate Check Inventory Plug In, based on the Order Line's Product's Product Type and delegates to that object's GetInventoryLocation method.

public long GetInventoryLocation(
Int64 ProductID,
Decimal Quantity,
Int64 PrimaryLocationID,
OrderLinesEntity OrderDetailGE
);

Parameters

ProductID
Quantity
PrimaryLocationID
The value in this parameter is used as the default location. If there is not sufficient quantity in that location, another location will be chosen.
OrderDetailGE
Internal implementation sets this parameter to the current OrderLines object instance (itself).

Return Value

Implements

ICheckInventory.

Remarks

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace


OrderLinesEntity.GetPrice Method

public PriceOutcome GetPrice(
ref PriceInfo& Price,
Int64 ProductID,
Decimal Quantity,
Int64 PersonID,
OrdersEntity OrderGE,
OrderLinesEntity OrderLineGE,
AptifyGenericEntityBase ProductGE,
Int64 CurrencyTypeID,
Int64 DerivedFromCurrencyTypeID,
Boolean CustomPrice
);

Parameters

Price
ProductID
Quantity
PersonID
OrderGE
Internal implementation sets this parameter to the current OrderLines object's ParentOrdersEntity value.
OrderLineGE
Internal implementation sets this parameter to the current OrderLines object instance (itself).
ProductGE
CurrencyTypeID
DerivedFromCurrencyTypeID
CustomPrice

Return Value

Implements

IProductPrice.

Remarks

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace


OrderLinesEntity.GetPricingPermissions Method

public PricingPermissions GetPricingPermissions(
Int64 ProductID
);

Implements

IProductPrice.

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace


OrderLinesEntity.GetValidPriceList Method

public PriceOutcome GetValidPriceList(
ref PriceInfo& Price,
ref List`1& ValidPrices,
Int64 ProductID,
Int64 PersonID,
Decimal Quantity,
OrdersEntity OrderGE,
OrderLinesEntity OrderLineGE,
AptifyGenericEntityBase ProductGE,
Int64 CurrencyTypeID,
Int64 DerivedFromCurrencyTypeID,
Boolean CustomPrice
);

Implements

IProductPrice.

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace


GetValue Method

Aptify 5.0 Software Development Kit (SDK)

OrderLinesEntity.GetValue Method

Deletes to the GE's GetValue unless FieldName is _xOrderStatus or _sOrderDropShip. Both fields are legacy fields that were used to pass information from the Order object to the OrderLines object. Now, each Order Line object has the ability to directly reference the Orders GE via the ParentGE property.

Overload List

Deletes to the GE's GetValue unless FieldName is _xOrderStatus or _sOrderDropShip. Both fields are legacy fields that were used to pass information from the Order object to the OrderLines object. Now, each Order Line object has the ability to directly reference the Orders GE via the ParentGE property.

public override object GetValue(String);

Inherited from AptifyGenericEntityBase.

public virtual object GetValue(String,Boolean);

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace


OrderLinesEntity.GetValue Method (String)

Deletes to the GE's GetValue unless FieldName is _xOrderStatus or _sOrderDropShip. Both fields are legacy fields that were used to pass information from the Order object to the OrderLines object. Now, each Order Line object has the ability to directly reference the Orders GE via the ParentGE property.

public override object GetValue(
String FieldName
);

Parameters

FieldName

Return Value

Remarks

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace | OrderLinesEntity.GetValue Overload List


OrderLinesEntity.InitializeOrderLineAddressFields Method

protected virtual void InitializeOrderLineAddressFields();

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace


Load Method

Aptify 5.0 Software Development Kit (SDK)

OrderLinesEntity.Load Method

Overload List

public override void Load(DataRow);

public override void Load(IDataReader);

public override void Load(Int64);

Inherited from AptifyGenericEntityBase.

public virtual void Load(String);

public override void Load(String,Boolean);

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace


OrderLinesEntity.Load Method (DataRow)

public override void Load(
DataRow DataRow
);

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace | OrderLinesEntity.Load Overload List


OrderLinesEntity.Load Method (IDataReader)

public override void Load(
IDataReader DataReader
);

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace | OrderLinesEntity.Load Overload List


OrderLinesEntity.Load Method (Int64)

public override void Load(
Int64 ID
);

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace | OrderLinesEntity.Load Overload List


OrderLinesEntity.Load Method (String, Boolean)

public override void Load(
String FileName,
Boolean MergeSubTypes
);

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace | OrderLinesEntity.Load Overload List


OrderLinesEntity.LoadProductPriceTriggers Method

Loads the OrderLinePriceTriggers list with fields from OrderLines that are listed in Filter Rules associated with the current Order Line's Product. If ProductID is not set, the list will be cleared.

protected virtual void LoadProductPriceTriggers();

Remarks

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace


OrderLinesEntity.NewRecord Method

public override bool NewRecord();

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace


OrderLinesEntity.OrderLineAddressFields_AfterValueChanged Method

protected virtual void OrderLineAddressFields_AfterValueChanged(
AptifyDataFieldBase sender,
AfterValueChangedEventArgs e
);

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace


OrderLinesEntity.OrderLinesFields_AfterValueChanged Method

protected virtual void OrderLinesFields_AfterValueChanged(
AptifyDataFieldBase sender,
AfterValueChangedEventArgs e
);

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace


OrderLinesEntity.OrderLinesFields_BeforeValueChanged Method

protected virtual void OrderLinesFields_BeforeValueChanged(
AptifyDataFieldBase sender,
BeforeValueChangedEventArgs e
);

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace


OrderLinesEntity.RestoreCopiedFields Method

protected override void RestoreCopiedFields();

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace


OrderLinesEntity.RollbackRecordID Method

Override adds support for Extended Order Detail GE, if the Order Line has one. If the ExtendedOrderDetailGE is defined, it's RollbackRecordID method will be called prior to calling the Base Class' RollbackRecordID method.

public override void RollbackRecordID();

Remarks

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace


OrderLinesEntity.RollbackTransaction Method

Override adds support for Extended Order Detail GE, if the Order Line has one. If the ExtendedOrderDetailGE is defined, it's RollbackTransaction method will be called prior to calling the Base Class' RollbackTransaction method.

public override bool RollbackTransaction();

Return Value

Remarks

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace


OrderLinesEntity.RoundPrice Method

public decimal RoundPrice(
Decimal Price,
PriceRoundingType RoundingType,
Decimal RoundingAmount
);

Implements

IProductPrice.

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace


Save Method

Aptify 5.0 Software Development Kit (SDK)

OrderLinesEntity.Save Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Save();

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean,ref String&);

public override bool Save(Boolean,ref String&,String);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(ref String&);

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace


OrderLinesEntity.Save Method (Boolean, String&, String)

public override bool Save(
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace | OrderLinesEntity.Save Overload List


OrderLinesEntity.SetCampaignPricing Method

protected virtual void SetCampaignPricing();

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace


OrderLinesEntity.SetProductPrice Method

Sets the Price on the Order Line

public virtual void SetProductPrice();

Remarks

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace


OrderLinesEntity.SetupExtendedOrderDetailEntity Method

protected virtual void SetupExtendedOrderDetailEntity();

Remarks

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace


OrderLinesEntity.SetupOrderLineProductInfo Method

Called when the ProductID is set for an OrderLine. This method populates the OrderLine with information about the Product.

protected virtual void SetupOrderLineProductInfo();

Remarks

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace


Ship Method

Aptify 5.0 Software Development Kit (SDK)

OrderLinesEntity.Ship Method

Overload List

public virtual bool Ship();

public virtual bool Ship(Boolean);

public virtual bool Ship(Decimal);

public virtual bool Ship(Decimal,Int64);

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace


OrderLinesEntity.Ship Method ()

public virtual bool Ship();

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace | OrderLinesEntity.Ship Overload List


OrderLinesEntity.Ship Method (Boolean)

public virtual bool Ship(
Boolean ConsumeAvailableQuantity
);

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace | OrderLinesEntity.Ship Overload List


OrderLinesEntity.Ship Method (Decimal)

public virtual bool Ship(
Decimal ShipQuantity
);

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace | OrderLinesEntity.Ship Overload List


OrderLinesEntity.Ship Method (Decimal, Int64)

public virtual bool Ship(
Decimal ShipQuantity,
Int64 InventoryLocationID
);

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace | OrderLinesEntity.Ship Overload List


Validate Method

Aptify 5.0 Software Development Kit (SDK)

OrderLinesEntity.Validate Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Validate();

public override bool Validate(ref String&);

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace


OrderLinesEntity.Validate Method (String&)

public override bool Validate(
ref String& ErrorString
);

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace | OrderLinesEntity.Validate Overload List


OrderLinesEntity.ValidateCancellationOrderLine Method

protected virtual bool ValidateCancellationOrderLine(
ref String& ErrorString
);

See Also

OrderLinesEntity Class | Aptify.Applications.OrderEntry Namespace


OrderLinesEntity.PurchaseTypes Enumeration

public enum OrderLinesEntity.PurchaseTypes

Members

Member Name | Description
Company |
Individual |

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

Aptify.Applications.OrderEntry Namespace


OrderMeetingDetailEntity Class

For a list of all members of this type, see OrderMeetingDetailEntity Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
ExtendedOrderDetailGE
OrderMeetingDetailEntity

public class OrderMeetingDetailEntity : ExtendedOrderDetailGE

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOMDEntity (in AptifyOMDEntity.dll)

See Also

OrderMeetingDetailEntity Members | Aptify.Applications.OrderEntry Namespace


OrderMeetingDetailEntity Members

OrderMeetingDetailEntity overview

Public Instance Constructors

OrderMeetingDetailEntity Constructor Initializes a new instance of the OrderMeetingDetailEntity class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
OrderLineGE (inherited from ExtendedOrderDetailGE) | The OrderLineGE causes the ExtendedOrderDetailGE object to be created and then passes it a reference to itself. This reference provides access to the Order Line information through the OrderLines Entity object, the Order information.
ParentGE (inherited from ExtendedOrderDetailGE) |
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from ExtendedOrderDetailGE) |
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config | Overloaded.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete | Overloaded.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
FlowdownForAddCancellationOrderLine |
FlowdownForAddProductToOrder |
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from ExtendedOrderDetailGE) | Overloaded.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from ExtendedOrderDetailGE) |
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveCancellationData |
SaveCancelledData | Save CancelledData will allow for the update to the meetings order line to update the participants status to cancelled.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetExtendedOrderDetailRecordID (inherited from ExtendedOrderDetailGE) |
SetMeetingQuantities | Overloaded. Update the Meeting Quanities, works only with Cancelled status currently.
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
m_fieldStatusID |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
ResetFieldsLinkedToOrderLine (inherited from ExtendedOrderDetailGE) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

OrderMeetingDetailEntity Class | Aptify.Applications.OrderEntry Namespace


OrderMeetingDetailEntity Constructor

Initializes a new instance of the OrderMeetingDetailEntity class.

public OrderMeetingDetailEntity();

See Also

OrderMeetingDetailEntity Class | Aptify.Applications.OrderEntry Namespace


OrderMeetingDetailEntity Properties

The properties of the OrderMeetingDetailEntity class are listed below. For a complete list of OrderMeetingDetailEntity class members, see the OrderMeetingDetailEntity Members topic.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
OrderLineGE (inherited from ExtendedOrderDetailGE) | The OrderLineGE causes the ExtendedOrderDetailGE object to be created and then passes it a reference to itself. This reference provides access to the Order Line information through the OrderLines Entity object, the Order information.
ParentGE (inherited from ExtendedOrderDetailGE) |
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from ExtendedOrderDetailGE) |
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
m_fieldStatusID |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

OrderMeetingDetailEntity Class | Aptify.Applications.OrderEntry Namespace


m_fieldStatusID Property

Aptify 5.0 Software Development Kit (SDK)

OrderMeetingDetailEntity.m_fieldStatusID Property

protected virtual AptifyDataFieldBase m_fieldStatusID {get; set;}

See Also

OrderMeetingDetailEntity Class | Aptify.Applications.OrderEntry Namespace


OrderMeetingDetailEntity Methods

The methods of the OrderMeetingDetailEntity class are listed below. For a complete list of OrderMeetingDetailEntity class members, see the OrderMeetingDetailEntity Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config | Overloaded.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete | Overloaded.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
FlowdownForAddCancellationOrderLine |
FlowdownForAddProductToOrder |
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from ExtendedOrderDetailGE) | Overloaded.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from ExtendedOrderDetailGE) |
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveCancellationData |
SaveCancelledData | Save CancelledData will allow for the update to the meetings order line to update the participants status to cancelled.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetExtendedOrderDetailRecordID (inherited from ExtendedOrderDetailGE) |
SetMeetingQuantities | Overloaded. Update the Meeting Quanities, works only with Cancelled status currently.
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
ResetFieldsLinkedToOrderLine (inherited from ExtendedOrderDetailGE) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

OrderMeetingDetailEntity Class | Aptify.Applications.OrderEntry Namespace


Config Method

Aptify 5.0 Software Development Kit (SDK)

OrderMeetingDetailEntity.Config Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual void Config(AptifySubTypeBase);

Inherited from AptifyGenericEntity.

public override void Config(AptifySubTypeBase,Int64);

Inherited from AptifyGenericEntityBase.

public virtual void Config(UserCredentials,String);

public override void Config(UserCredentials,String,Int64);

See Also

OrderMeetingDetailEntity Class | Aptify.Applications.OrderEntry Namespace


OrderMeetingDetailEntity.Config Method (UserCredentials, String, Int64)

public override void Config(
UserCredentials UserCredentials,
String EntityName,
Int64 RecordID
);

See Also

OrderMeetingDetailEntity Class | Aptify.Applications.OrderEntry Namespace | OrderMeetingDetailEntity.Config Overload List


Delete Method

Aptify 5.0 Software Development Kit (SDK)

OrderMeetingDetailEntity.Delete Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Delete();

public override bool Delete(String);

See Also

OrderMeetingDetailEntity Class | Aptify.Applications.OrderEntry Namespace


OrderMeetingDetailEntity.Delete Method (String)

public override bool Delete(
String TransactionID
);

See Also

OrderMeetingDetailEntity Class | Aptify.Applications.OrderEntry Namespace | OrderMeetingDetailEntity.Delete Overload List


OrderMeetingDetailEntity.FlowdownForAddCancellationOrderLine Method

public override bool FlowdownForAddCancellationOrderLine();

See Also

OrderMeetingDetailEntity Class | Aptify.Applications.OrderEntry Namespace


OrderMeetingDetailEntity.FlowdownForAddProductToOrder Method

public override bool FlowdownForAddProductToOrder();

See Also

OrderMeetingDetailEntity Class | Aptify.Applications.OrderEntry Namespace


Save Method

Aptify 5.0 Software Development Kit (SDK)

OrderMeetingDetailEntity.Save Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Save();

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean,ref String&);

public override bool Save(Boolean,ref String&,String);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(ref String&);

See Also

OrderMeetingDetailEntity Class | Aptify.Applications.OrderEntry Namespace


OrderMeetingDetailEntity.Save Method (Boolean, String&, String)

public override bool Save(
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

See Also

OrderMeetingDetailEntity Class | Aptify.Applications.OrderEntry Namespace | OrderMeetingDetailEntity.Save Overload List


OrderMeetingDetailEntity.SaveCancellationData Method

public override bool SaveCancellationData(
Boolean AllowGUI
);

See Also

OrderMeetingDetailEntity Class | Aptify.Applications.OrderEntry Namespace


OrderMeetingDetailEntity.SaveCancelledData Method

Save CancelledData will allow for the update to the meetings order line to update the participants status to cancelled.

public override bool SaveCancelledData(
Boolean AllowGUI
);

Parameters

AllowGUI

Return Value

Remarks

See Also

OrderMeetingDetailEntity Class | Aptify.Applications.OrderEntry Namespace


SetMeetingQuantities Method

Aptify 5.0 Software Development Kit (SDK)

OrderMeetingDetailEntity.SetMeetingQuantities Method

Overload List

public virtual void SetMeetingQuantities();

Update the Meeting Quanities, works only with Cancelled status currently.

public virtual void SetMeetingQuantities(String);

See Also

OrderMeetingDetailEntity Class | Aptify.Applications.OrderEntry Namespace


OrderMeetingDetailEntity.SetMeetingQuantities Method ()

public virtual void SetMeetingQuantities();

See Also

OrderMeetingDetailEntity Class | Aptify.Applications.OrderEntry Namespace | OrderMeetingDetailEntity.SetMeetingQuantities Overload List


OrderMeetingDetailEntity.SetMeetingQuantities Method (String)

Update the Meeting Quanities, works only with Cancelled status currently.

public virtual void SetMeetingQuantities(
String MeetingStatus
);

Parameters

MeetingStatus

Remarks

See Also

OrderMeetingDetailEntity Class | Aptify.Applications.OrderEntry Namespace | OrderMeetingDetailEntity.SetMeetingQuantities Overload List


Validate Method

Aptify 5.0 Software Development Kit (SDK)

OrderMeetingDetailEntity.Validate Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Validate();

public override bool Validate(ref String&);

See Also

OrderMeetingDetailEntity Class | Aptify.Applications.OrderEntry Namespace


OrderMeetingDetailEntity.Validate Method (String&)

public override bool Validate(
ref String& ErrorString
);

See Also

OrderMeetingDetailEntity Class | Aptify.Applications.OrderEntry Namespace | OrderMeetingDetailEntity.Validate Overload List


OrderProductCache Class

Caches Product and Product Types information used by the Orders objects. Shared, on-demand cache. All Product Types will be downloaded when first accessed for efficiency

For a list of all members of this type, see OrderProductCache Members.

System.Object
OrderProductCache

public class OrderProductCache

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

OrderProductCache Members | Aptify.Applications.OrderEntry Namespace


OrderProductCache Members

OrderProductCache overview

Public Static Methods

Instance

Public Instance Constructors

OrderProductCache Constructor

Public Instance Properties

CurrencyTypeCacheInstance |
Product | This method will either return a ProductData object from the cache. If the cache doesn't contain a ProductData object, the information will be retrieved from the database and used to populate a ProductData object which will be added to the cache and returned to the caller.
ProductType | This method will return the ProductTypeData object that holds the information for the Product Types record with an ID equal to the value in the ProductTypeID parameter. The information is returned from the cache. If the cache is not yet loaded, it will be loaded.
ProductTypeImages | Loads a Dictionary with an icon image for each Product Type.

Public Instance Methods

ClearProductCache |
ClearProductTypeCache |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
RemoveProductFromCache |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

OrderProductCache Class | Aptify.Applications.OrderEntry Namespace


OrderProductCache Constructor

public OrderProductCache(
AptifyApplication Application
);

See Also

OrderProductCache Class | Aptify.Applications.OrderEntry Namespace


OrderProductCache Properties

The properties of the OrderProductCache class are listed below. For a complete list of OrderProductCache class members, see the OrderProductCache Members topic.

Public Instance Properties

CurrencyTypeCacheInstance |
Product | This method will either return a ProductData object from the cache. If the cache doesn't contain a ProductData object, the information will be retrieved from the database and used to populate a ProductData object which will be added to the cache and returned to the caller.
ProductType | This method will return the ProductTypeData object that holds the information for the Product Types record with an ID equal to the value in the ProductTypeID parameter. The information is returned from the cache. If the cache is not yet loaded, it will be loaded.
ProductTypeImages | Loads a Dictionary with an icon image for each Product Type.

See Also

OrderProductCache Class | Aptify.Applications.OrderEntry Namespace


CurrencyTypeCacheInstance Property

Aptify 5.0 Software Development Kit (SDK)

OrderProductCache.CurrencyTypeCacheInstance Property

public CurrencyTypeCache CurrencyTypeCacheInstance {get;}

See Also

OrderProductCache Class | Aptify.Applications.OrderEntry Namespace


Product Property

Aptify 5.0 Software Development Kit (SDK)

OrderProductCache.Product Property

This method will either return a ProductData object from the cache. If the cache doesn't contain a ProductData object, the information will be retrieved from the database and used to populate a ProductData object which will be added to the cache and returned to the caller.

public virtual ProductData this[
Int64 ProductID,
Boolean ForceRefresh
] {get;}

Parameters

ProductID
ForceRefresh

Property Value

Remarks

See Also

OrderProductCache Class | Aptify.Applications.OrderEntry Namespace


ProductType Property

Aptify 5.0 Software Development Kit (SDK)

OrderProductCache.ProductType Property

This method will return the ProductTypeData object that holds the information for the Product Types record with an ID equal to the value in the ProductTypeID parameter. The information is returned from the cache. If the cache is not yet loaded, it will be loaded.

public virtual ProductTypeData this[
Int64 ProductTypeID
] {get;}

Parameters

ProductTypeID

Property Value

Remarks

See Also

OrderProductCache Class | Aptify.Applications.OrderEntry Namespace


ProductTypeImages Property

Aptify 5.0 Software Development Kit (SDK)

OrderProductCache.ProductTypeImages Property

Loads a Dictionary with an icon image for each Product Type.

public virtual Dictionary<TKey,TValue> ProductTypeImages {get;}

Property Value

Remarks

See Also

OrderProductCache Class | Aptify.Applications.OrderEntry Namespace


OrderProductCache Methods

The methods of the OrderProductCache class are listed below. For a complete list of OrderProductCache class members, see the OrderProductCache Members topic.

Public Static Methods

Instance

Public Instance Methods

ClearProductCache |
ClearProductTypeCache |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
RemoveProductFromCache |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

OrderProductCache Class | Aptify.Applications.OrderEntry Namespace


OrderProductCache.ClearProductCache Method

public virtual void ClearProductCache();

See Also

OrderProductCache Class | Aptify.Applications.OrderEntry Namespace


OrderProductCache.ClearProductTypeCache Method

public virtual void ClearProductTypeCache();

See Also

OrderProductCache Class | Aptify.Applications.OrderEntry Namespace


OrderProductCache.Instance Method

public static OrderProductCache Instance(
AptifyApplication Application
);

See Also

OrderProductCache Class | Aptify.Applications.OrderEntry Namespace


OrderProductCache.RemoveProductFromCache Method

public virtual void RemoveProductFromCache(
Int64 ProductID
);

See Also

OrderProductCache Class | Aptify.Applications.OrderEntry Namespace


OrderRequestedDataNotFound Class

Thrown when information is requested by the caller but that information could not be found.

For a list of all members of this type, see OrderRequestedDataNotFound Members.

System.Object
Exception
ApplicationException
BaseApplicationException
AptifyGenericEntityException
OrderException
OrderRequestedDataNotFound

public class OrderRequestedDataNotFound : OrderException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

OrderRequestedDataNotFound Members | Aptify.Applications.OrderEntry Namespace


OrderRequestedDataNotFound Members

OrderRequestedDataNotFound overview

Public Instance Constructors

OrderRequestedDataNotFound Overloaded. Initializes a new instance of the OrderRequestedDataNotFound class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from AptifyGenericEntityException) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

OrderRequestedDataNotFound Class | Aptify.Applications.OrderEntry Namespace


OrderRequestedDataNotFound Constructor

Overload List

public OrderRequestedDataNotFound(SerializationInfo,StreamingContext);

public OrderRequestedDataNotFound(String);

public OrderRequestedDataNotFound(String,Exception);

See Also

OrderRequestedDataNotFound Class | Aptify.Applications.OrderEntry Namespace


OrderRequestedDataNotFound Constructor (String)

public OrderRequestedDataNotFound(
String Message
);

See Also

OrderRequestedDataNotFound Class | Aptify.Applications.OrderEntry Namespace | OrderRequestedDataNotFound Constructor Overload List


OrderRequestedDataNotFound Constructor (String, Exception)

public OrderRequestedDataNotFound(
String Message,
Exception inner
);

See Also

OrderRequestedDataNotFound Class | Aptify.Applications.OrderEntry Namespace | OrderRequestedDataNotFound Constructor Overload List


OrderRequestedDataNotFound Constructor (SerializationInfo, StreamingContext)

public OrderRequestedDataNotFound(
SerializationInfo info,
StreamingContext context
);

See Also

OrderRequestedDataNotFound Class | Aptify.Applications.OrderEntry Namespace | OrderRequestedDataNotFound Constructor Overload List


OrdersEntity Class

OrdersEntity is the Generic Entity Sub-Class Object for the Orders Entity in the standard Aptify CRM system. Subclass this class to alter functionality in the standard Aptify OrdersEntity.

For a list of all members of this type, see OrdersEntity Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
OrdersClass
OrdersEntity

public class OrdersEntity : OrdersClass

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

OrdersEntity Members | Aptify.Applications.OrderEntry Namespace


OrdersEntity Members

OrdersEntity overview

Public Instance Constructors

OrdersEntity Constructor Initializes a new instance of the OrdersEntity class.

Public Instance Properties

ABA (inherited from OrdersClass) |
AccountName (inherited from OrdersClass) |
AccountNumber (inherited from OrdersClass) |
Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
ArrivalDate (inherited from OrdersClass) |
AvailableForShipping | Overloaded.
BackOrderARFlag |
Balance (inherited from OrdersClass) |
Bank (inherited from OrdersClass) |
BasePaymentType (inherited from OrdersClass) |
Batched |
BatchID (inherited from OrdersClass) |
BillToAddressID (inherited from OrdersClass) |
BillToAddressIDObject (inherited from OrdersClass) |
BillToAddrLine1 (inherited from OrdersClass) |
BillToAddrLine2 (inherited from OrdersClass) |
BillToAddrLine3 (inherited from OrdersClass) |
BillToAreaCode (inherited from OrdersClass) |
BillToCity (inherited from OrdersClass) |
BillToCompany (inherited from OrdersClass) |
BillToCompanyID | Overloaded.
BillToCountry (inherited from OrdersClass) |
BillToCountryCode (inherited from OrdersClass) |
BillToCountryCodeID (inherited from OrdersClass) |
BillToCounty (inherited from OrdersClass) |
BillToEmail (inherited from OrdersClass) |
BillToID | Overloaded.
BillToName (inherited from OrdersClass) |
BillToPhone (inherited from OrdersClass) |
BillToPhoneExtension (inherited from OrdersClass) |
BillToPhoneID (inherited from OrdersClass) |
BillToPhoneIDObject (inherited from OrdersClass) |
BillToSameAsShipTo (inherited from OrdersClass) |
BillToState (inherited from OrdersClass) |
BillToZipCode (inherited from OrdersClass) |
BranchName (inherited from OrdersClass) |
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
CALC_AdjustedTotal (inherited from OrdersClass) |
CALC_Discount (inherited from OrdersClass) |
CALC_GrandTotal (inherited from OrdersClass) |
CALC_HandlingCharge (inherited from OrdersClass) |
CALC_LineCount (inherited from OrdersClass) |
CALC_PaymentTotal (inherited from OrdersClass) |
CALC_SalesTax (inherited from OrdersClass) |
CALC_ShippingCharge (inherited from OrdersClass) |
CALC_ShippingExpense (inherited from OrdersClass) |
CALC_SubTotal (inherited from OrdersClass) |
CALC_TaxableTotal (inherited from OrdersClass) |
CalculateShippingOnLineAdd |
CalculateTaxOnLineAdd |
CampaignCodeID | Overloaded.
CampaignCodeName (inherited from OrdersClass) |
CancellationReasonID (inherited from OrdersClass) |
CashCtrlBatchID (inherited from OrdersClass) |
CCAccountNumber (inherited from OrdersClass) |
CCAuthCode (inherited from OrdersClass) |
CCExpireDate (inherited from OrdersClass) |
CCPartial (inherited from OrdersClass) |
CCSecurityNumber (inherited from OrdersClass) |
ChapterAssignmentObject | The internal instance of the object implementing IChapterAssignmentRules that is being used by the order. This object is demand-loaded the first time it is accessed. The object is defined by the Orders Entity Chapter Assignment Rules plug-in.
CheckNumber (inherited from OrdersClass) |
Comments (inherited from OrdersClass) |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CreditOrderID (inherited from OrdersClass) |
CurrencySpotRateObject |
CurrencyType (inherited from OrdersClass) |
CurrencyTypeFormat | Returns the Currency Type's FormatString value. If no matching Currency Type is found, the property returns "Currency", which will use the local system's Regional Currency format.
CurrencyTypeID |
CurrencyTypeNumberOfDecimalPlaces | Returns the Currency Type's Number of Digits after the Decimal value for the Order's Currency Type. If no matching Currency Type is found, the property returns 2.
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
CustomerMemberType | Overloaded.
CustShipAcctNum (inherited from OrdersClass) |
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DateCreated (inherited from OrdersClass) |
DateUpdated (inherited from OrdersClass) |
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DepositDate (inherited from OrdersClass) |
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
DropShip |
DueDate (inherited from OrdersClass) |
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
Employee (inherited from OrdersClass) |
EmployeeID (inherited from OrdersClass) |
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
FunctionalCurrencyTypeID | Returns the Functional Currency of the Organization associated with the Order.
GrandTotal (inherited from OrdersClass) |
HoldUntil (inherited from OrdersClass) |
ID (inherited from OrdersClass) |
InitialPaymentAmount (inherited from OrdersClass) |
InvoiceMessage (inherited from OrdersClass) |
InvoiceNumber (inherited from OrdersClass) |
IsCancelling | Used to determine whether or not the Order is currently being cancelled. Current criteria checks whether or not the OrderStatusID is dirty and that the current value of OrderStatusID is Shipped (3).
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
isSaving | This property will let/set the boolean value that will determine wheter record is being saved now.
IsShipping | Used to determine whether or not the Order is currently shipping. Current criteria checks whether or not the OrderStatusID is dirty and that the current value of OrderStatusID is Shipped (2).
KitExpansionObject |
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
Line1_ProductCategory (inherited from OrdersClass) |
Line1_ProductID (inherited from OrdersClass) |
Line1_ProductName (inherited from OrdersClass) |
OldOrderStatus | Provides a way to get the Order's Status at the time the GE object was loaded.
OrderDate |
OrderLevel (inherited from OrdersClass) |
OrderLevelID (inherited from OrdersClass) |
OrderSource (inherited from OrdersClass) |
OrderSourceID (inherited from OrdersClass) |
OrderStatus | Overloaded. Provides a way to get and set an Order's Status by using an Enumerated Type (OrderStatus). The OrderStatusID values control certain aspects of the Orders Entity object. Only the values listed in the Enumerated Type have meaning.
OrderStatusID (inherited from OrdersClass) |
OrderType | Overloaded.
OrderTypeID (inherited from OrdersClass) |
Organization (inherited from OrdersClass) |
OrganizationID (inherited from OrdersClass) |
OriginalOrderID | Overloaded.
OverrideShippingCalc (inherited from OrdersClass) |
PackingSlipsPrinted (inherited from OrdersClass) |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PaymentCashControlBatchID |
PaymentInformationID (inherited from OrdersClass) |
PaymentScheduleOptions (inherited from OrdersClass) |
PayType (inherited from OrdersClass) |
PayTypeID (inherited from OrdersClass) |
PONumber (inherited from OrdersClass) |
PreferredAddress | Returns an instance of the Preferred Address Object, which is recorded as a Persons Entity Plug-In.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
PromiseDate (inherited from OrdersClass) |
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
ReferralListID (inherited from OrdersClass) |
ReferredBy (inherited from OrdersClass) |
ReferredByID (inherited from OrdersClass) |
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
ReturnShippingCharge (inherited from OrdersClass) |
SalesRep (inherited from OrdersClass) |
SalesRepID (inherited from OrdersClass) |
SalesTaxAmounts | Contains a dictionary of the total Sales Tax amounts, grouped by SalesTaxRateID. Each value has been rounded to the appropriate number of decimal places, based on the Order's Currency Type.
SalesTaxObject | The internal instance of the object implementing ISalesTax that is being used by the order. This object is demand-loaded the first time it is accessed. The object is defined by the Orders Entity Sales Tax plug-in.
SalesTaxRate (inherited from OrdersClass) |
SalesTaxRateID (inherited from OrdersClass) |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
ShipCharge (inherited from OrdersClass) |
ShipDate (inherited from OrdersClass) |
ShipExpense (inherited from OrdersClass) |
ShippedBy (inherited from OrdersClass) |
ShippedByID (inherited from OrdersClass) |
ShipToAddressID (inherited from OrdersClass) |
ShipToAddressIDObject (inherited from OrdersClass) |
ShipToAddrLine1 (inherited from OrdersClass) |
ShipToAddrLine2 (inherited from OrdersClass) |
ShipToAddrLine3 (inherited from OrdersClass) |
ShipToAreaCode (inherited from OrdersClass) |
ShipToCity (inherited from OrdersClass) |
ShipToCompany (inherited from OrdersClass) |
ShipToCompanyID | Overloaded.
ShipToCountry (inherited from OrdersClass) |
ShipToCountryCode (inherited from OrdersClass) |
ShipToCountryCodeID (inherited from OrdersClass) |
ShipToCounty (inherited from OrdersClass) |
ShipToEmail (inherited from OrdersClass) |
ShipToID | Overloaded.
ShipToName (inherited from OrdersClass) |
ShipToPhone (inherited from OrdersClass) |
ShipToPhoneExtension (inherited from OrdersClass) |
ShipToPhoneID (inherited from OrdersClass) |
ShipToPhoneIDObject (inherited from OrdersClass) |
ShipToState (inherited from OrdersClass) |
ShipToZipCode (inherited from OrdersClass) |
ShipTrackingNum (inherited from OrdersClass) |
ShipType (inherited from OrdersClass) |
ShipTypeID (inherited from OrdersClass) |
SubscriptionDateObject |
SubscriptionID (inherited from OrdersClass) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
SuspendOrderTotalsCalculation |
TaxJurisdiction (inherited from OrdersClass) |
TaxJurisdictionID (inherited from OrdersClass) |
Terms (inherited from OrdersClass) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.
WhoCreated (inherited from OrdersClass) |
WhoUpdated (inherited from OrdersClass) |

Public Instance Methods

AddCancellationOrderLine | Overloaded.
AddProduct | Overloaded. Adds a Product to the Order. Product must be available for sale. This overload results in the default quantity of either 1 or the minimum purchase quantity for the Product, whichever is greater. This overload also uses the newest version of a given product as its default behavior. The other overloads of this method allow more control over those default behaviors.
BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CalculateOrderLinesGrossRevenue | Calculates the Gross Revenue and Gross Discount amounts for each Order Line. Includes logic to handle the distribution of Revenue amongst Kit parts.
CalculateOrderTotals | Overloaded. Calculates the summary Order totals, including the calculation of Tax and Shipping on the Order.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
CheckOrderLineInventory | Called when a Product is added to an Order and when the Quantity (>0) of an existing Order Line is updated. If the available inventory is not sufficient or the inventory check fails, the OnCheckInventoryOnOrderLineFailed method is called.
CheckSuccessionFixedTerm | This method is responsible for determining if the fixed term associated with the Product.SubscriptionMaxDuration has been reached. Product.SubscriptionMaxDuration specifies the maximum duration of a subscription for the specified product denominated in units based on the Product.SubscriptionType. For example, if a product has an monthly subscription frequency, the Product.SubscriptionMaxDuration refers to the number of months that a subscription may go for. In this instance, if the field was populated with a value of 36, it implies that a monthly subscription may only be renewed for a total duration of 3 years.
CheckSuccessionTriggerRule | This method is responsible for checking to see if the specified product is ready to be replaced by a succession product by executing a rule in the database. If the rule returns 1, this function will return True, otherwise this function returns False. If this function returns True, it means that the product specified by the Product parameter to this function may not be added and must be succeeded by another product.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config | Overloaded.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
CreateBackorders |
Delete | Overloaded. Verifies that the Order has not be Batched or Shipped before deleting.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
FlowdownCustomerAddresses | Overloaded.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetNewInvoiceNumber |
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetOrderBalance | Overloaded.
GetOrderTotal | Overloaded.
GetPotentialCancellationOrderLines | Overloaded.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetSubscriptionIDAndStartDate | This method returns the Subscription ID of an existing subscription record in the database for the specified Product ID, Person ID and Company ID combination. For individual subscriptions, pass leave the CompanyID at its default value of -1. For Company subscriptions, provide both PersonID and CompanyID. If no existing subscription is found, -1 is returned.
GetSuccessionProductByRule | This method is responsible for executing the succession product rule associated with the specified product for the given order. This rule is called only when a product is determined to be in line for a successor product
GetSuccessorProductID | This method is responsible for determining the successor product ID to use for the Product specified in the Product parameter.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. Uses the Generic Entity's GetValue functionality except when a field that begins with BillTo and the BillToSameAsShipTo flag is true. In those cases, the BillTo* fields will return the corresponding ShipTo* field value. The exception to this is the BillToSameAsShipTo field, which does not have a corresponding ShipTo field.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load | Overloaded.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data from a field with the supplied ID.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord |
OKToModifyOrder | Calls protected methods OKToModifyBatchedOrder and OKToModifyShippedOrder, where appropriate.
OrderCurrencySpotRate (inherited from OrdersClass) |
OrderCurrencySpotRateObject (inherited from OrdersClass) |
OrderGLEntry (inherited from OrdersClass) |
OrderGLEntryObject (inherited from OrdersClass) |
OrderInvAllocation (inherited from OrdersClass) |
OrderInvAllocationObject (inherited from OrdersClass) |
OrderLines (inherited from OrdersClass) |
OrderLinesObject (inherited from OrdersClass) |
OrderPaymentSchedule (inherited from OrdersClass) |
OrderPaymentScheduleObject (inherited from OrdersClass) |
OrderShipments (inherited from OrdersClass) |
OrderShipmentsObject (inherited from OrdersClass) |
RemoveOrderLine | Removes an Order Line from the Order. Handles Kit Products as well by removing the Kit Parts. If the Orders Entity Attribute, RecalculateOrderLinesAfterRemove, exists and have a value of 1, the remaining Order Lines' prices will be recaculated after the remove.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetBillingAddress |
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetCustomerData | Method utilized by the order UI to configure various customer data based on a number of rules.
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetShippingAddress |
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ShipAvailableLines | Overloaded.
ShipEntireOrder | Overloaded.
ShipPartialOrder | This method is used by the Backorders process when the BackOrderARFlag is OriginalOrder(0). With this setting, the Original
ShouldUseSuccessorProduct | This method is only relevant for Subscription products. This method is responsible for determining if a successor product should be used for a given selected product. If the rules for this particular product require a successor product be automatically used whenever certain successor conditions are met, the order entry system will automatically swap the selected product with its successor product.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeUpgradeProductToLatestVersion |
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
CheckInventoryOnOrderLineFailed |
ProcessTerminated |
StatusUpdate |
TotalsUpdated |
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_bAdjustExistingPayment
m_bAllowZeroInitialPaymentOnCreditMemo
m_bExtraPaymentDialogWasDisplayed
m_bSuspendOrderTotalsCalculation
m_ExtraPaymentGE
m_iOrderPaymentLine
m_OrderPaymentGE
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

AddressFlowDownObject | Returns an instance of the Order Address Flowdown object.
AutoShipSetting | If the AutoShipSetting has not been specified, retreive the setting from the Orders Entity Attribute, AutoShipNonFulfillmentProducts. If the Attribute value is 0, the AutoShipSetting is Disabled. If the Attribute value is 1, the AutoShipSetting is Enabled but Autoshipment requires confirmation from the User before it will be shipped. Confirmation will only be retrrieved if the Save method's AllowGUI parameter is True. If the Attribute value is 2, the AutoShipSetting is Enabled and no confirmation is required from the User. In this case, a qualifying Order will be Shipped during the Order Save process. If the Attribute doesn't exist or the value is something other than what is listed above, the AutoShipSetting is Disabled.
BackOrderPlugin |
CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
CreditCheckObject |
ExtraPaymentDialog |
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
LineShipDialogPlugin |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SaveSubsObject |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
ShippingCalculatorObject |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AddFieldValueChangedEventHandlers | Configures the Fields to fire the ValueChanged events and adds Event Handlers to for the AfterValueChanged event. The core EventHandler is the OrderLinesFields_AfterValueChanged method. The following fields are monitored: ProductID, Quantity, Price, Discount and Subscription Copies.
AddProductSetProductPrice | Calculates the Price for a new Order Line. Performs validation based on the value of Orders Entity Attribute, OrderLinePriceRequirement. Supported Settings: - NotRequired: A defined Price is not required for an Order Line. If a Price is not found, a zero price will be used. This behaviour matches the behavior in previous versions of the application and it is the default behavior. - WarningDefaultNotRequired: If a defined Price is not found because it does not exist or an error occurred, a GE Warning event will be raised with the default set to not required. A return value of Yes will be treated as NotRequired. A return value of No will be treated as Required. If no event handler exists, it will behave as NotRequired. - WarningDefaultRequired: If a defined Price is not found because it does not exist or an error occurred, a GE Warning event will be raised with the default set to not required. A return value of Yes will be treated as NotRequired. A return value of No will be treated as Required. If no event handler exists, it will behave as Required. - Required: A defined Price is required. If one is not found, this method will return False and the Order Line will not be added to the Order. - RequiredIfNoOverride: A defined Price is required, unless the Order Line / User is allowed to override the Price and/or allow the Order Line to be free. Called from the AddProduct method
AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase)
AssignChapter | This method assigns a value to the ChapterID field in the specified order line object. The base class functionality uses the Chapter Assignment Rules plug-in to perform this calculation. This method should only be called if the ChapterAssignmentRuleID for the product placed in the order line is > 0.
AutoShipOrder
BroadcastChange (inherited from AptifyGenericEntity)
CalculateKitGrossRevenue
CalculateOrderBalance | Calculates the Order Balance based on a provided order total.
CalculateSalesTax | Update and, optionally, calculate the Sales Tax for the Order.
CalculateShippingAndHandling | Update, and optional, calculate the Shipping and Handling charges for the Order.
CalculateStandardLineGrossRevenue
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase)
CloneSubType (inherited from AptifyGenericEntity)
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreatePayment
CreateRecord (inherited from AptifyGenericEntity)
CreateSubTypeRecord (inherited from AptifyGenericEntity)
CreateTopLevelRecord (inherited from AptifyGenericEntity)
DebitMatchesCredit | Verify that the sum of the Credit and Debit amounts for the OrderGLEntry records match.
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase)
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo
DoPrintOrder
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FindInitialPayment | Finds Payment record that exactly matches order's initial Payment Information.
FindPayment
FinishTransaction (inherited from AptifyGenericEntity)
FinishTransactionSubType (inherited from AptifyGenericEntity)
FinishTransactionTopLevel (inherited from AptifyGenericEntity)
FireEvent (inherited from AptifyGenericEntity)
FireValidationEvent (inherited from AptifyGenericEntity)
FlowdownCCBDepositDate | Given a valid Cash Control Batch ID, retrieve the Cash Control Batch's DepositDate and use it to populate the Order's DepositDate. Calls the stored procedure spGetBatchDepositDate, setting the @BatchID parameter to the value in CashControlBatchID. If the stored procedure returns a valid Date, the Order's DepositDate field is set to the value of the first record's first field.
FormatDateTimeForSQL | Given a DateTime value, convert it to a string that will be understood by SQL Server regardless of the current regional date settings.
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity)
GenerateCreateSQL (inherited from AptifyGenericEntity)
GenerateDeleteSQL (inherited from AptifyGenericEntity)
GenerateFieldSQL (inherited from AptifyGenericEntity)
GenerateGLEntries
GenerateInvoiceNumber | Generates the InvoiceNumber value for an Order, if the Orders Entity is configured for generating Invoice Numbers. The Orders Entity Attributes GenerateInvoiceNumber and GenerateInvoiceNumberStoredProcedure control the Invoice Number generation functionality. GenerateInvoiceNumber must be True or a non-zero numeric value and GenerateInvoiceNumberStoredProcedure must specify a stored procedure in the same database as the Orders Entity. If these conditions are not met, the Invoice Number will not be generated and the method will return an empty string. When Invoice Number generation is properly configured, the stored procedure defined in GenerateInvoiceNumberStoredProcedure will be called and the first record's first field value will be returned, if found. If not, an empty string is returned.
GenerateUpdateSQL (inherited from AptifyGenericEntity)
GESave
GetPersonCompanyID | Obsolete.
GetPersonCompanyIDAndName | Returns the Company ID and Name for a given Person ID. Uses the stored procedure, spGetCompanyIDAndNameForPerson.
GetSubscriberCompanyID | This method is responsible for returning the ID of the Company this is used to populate the Subscription's SubscriberCompanyID. The SubscriberCompanyID indicates the Company that is both the Subscriber and Recipient for a Subscription. There is an Entity Attribute on the Subscriptions Entity, SubscriberCompanyBehavior, that affects the behavior in this method. If the Entity Attribute does not exist or has a value of Order, the Order's ShipToCompanyID will be returned, if the Order's ShipToCompanyID is greater than 0. If the Order's ShipToCompanyID is less than or equal to 0 or the SubscriberCompanyBehavior Attribute value is Person, call the GetPersonCompanyID method to retrieve the CompanyID based on the PersonID parameter value.
GetSuccessionProductDates | This method is responsible for determining the start date to use for a successor product when a successor product is going to replace a previously selected product.
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase)
InitializeInternalVariables | Initializes the protected variables to match the field values of the current Order. For new records: the EmployeeID will be set to the currently logged in User's Employee ID and the InvoiceNumber will be generated (if configured). The Order's Organization can also be populated with the call to InitializeOrganizationID.
InitializeOrderAddressFieldVariables
InitializeOrganizationID | Used to set the Order's OrganizationID for a new Order. The core implementation uses the Taken By Employee's OrganizationID. Called by InitializeInternalVariables method for new Orders.
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity)
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OKToModifyBatchedOrder
OKToModifyShippedOrder
OkToRecalcTotals | Is it OK to recalculate the Order Totals? Core implementation returns True if the Order hasn't already been shipped. Called by CalculateOrderTotals method.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeUpgradeProductToLatestVersion
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnCheckInventoryOnOrderLineFailed
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
OrderAddressFields_AfterValueChanged
OrdersFields_AfterValueChanged
PromptForAdditionalPayment
RecordVersionInfo (inherited from AptifyGenericEntity)
RefreshLinkedFields (inherited from AptifyGenericEntity)
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase)
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity)
RestoreCopiedFields (inherited from AptifyGenericEntity)
RollbackEmbeddedObjects (inherited from AptifyGenericEntity)
SaveCancellationData
SaveCancellationSubscriptions
SaveCheckInventory | Called from the Save method when the Order is being shipped.
SaveCreateOrderCurrencySpotRates | If the System's functional currency differs from the functional currency of the order, then the spot rate will be recorded because a foreign currency gain or loss may need to be recorded at a later point. Called from the Save method when the Order is being shipped.
SaveDateChanges
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SaveGLEntries
SavePayments
SavePermitChanges | Additional validation in the Save method. If AllowGUI is true, any failure will be displayed to the user in a message box. This function checks to make sure order isn't batched or shipped, and if it is checks appropriate fields to see whether changes can be saved.
SaveProcessSubscriptions
SaveRevRecognitionScheduledTransactions | Creates the scheduled transaction groups needed to move funds from the deferred income account to the sales account on the revenue recognition date. Processes each Order Line and determines which are impacted by revenue recognition date. Creates a scheduled transaction group record for each impacted Order Line.
SaveScheduledTransactionGroups | Creates scheduled transaction group records. A scheduled transaction group is created for each order line for a product requiring deferred income. During the batching process, each scheduled transaction group record is expanded to each of the individual scheduled transactions using the data in the record.
SaveSetDepositDate
SaveSubscriptions
SetCurrentTransactionID (inherited from AptifyGenericEntityBase)
SetIsShipping
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase)
SetupTransaction (inherited from AptifyGenericEntity)
SetupTransactionSubType (inherited from AptifyGenericEntity)
SetupTransactionTopLevel (inherited from AptifyGenericEntity)
ShowMessageBox | Overloaded.
UpdateInventory
UpdatePayment
UpdatePaymentObject
UpdateRecord (inherited from AptifyGenericEntity)
ValidateCancellationCreditCard | This function is called to validate the credit card that is being used to cancel an Order.
ValidateCancellationOrder | Called by the Validate routine when the Order is a Cancellation Order. (OrderTypeID=3) Validates that the Order's OriginalOrderID has been set, that the Quantity returned doesn't exceed the Quantity Shipped on the Original Order and that the returned products were on the Original Order. Note that this method assumes that the Order is a Cancellation Order.
ValidateCancellationQuantity | Validate that the quantity returned does not exceed the Original Order's quantity shipped. Called by the ValidateCancellationOrder method.
ValidateCheckCredit
ValidateCreditMemoOwnership | Responsible for determining whether or not the Credit Memo can be used as a Payment for the current based on the ownership of the Credit Memo. Called within the default implementation of ValidatePaymentInformation. Default implementation calls Aptify.Applications.OrderEntry.Payments.PaymentsEntity.ValidateCreditMemoOwnershipShared
ValidateExistingPayment
ValidateOrderLines | Validates information related to the OrderLines Sub-Type. Called by the Validate method Validation Rules: 1. An Order must have at least one Order Line. 2. Cancellation Order Lines must have a quantity less than 0. 3. Regular Order Lines must have a quantity greater than or equal to 0. A quantity of 0 is valid for items being backordered.
ValidatePaymentInformation | Validate that the Payment information and Credit Check is valid. Called by the Validate method when a Payment is being saved by the Order.
ValidateQuotationOrder | Called by the Validate routine when the Order is a Quotation Order. (OrderTypeID=4) Validates that the Order's Status is Taken (1) or Cancelled (4). Note that this method assumes that the Order is a Quotation.
ValidateRefund
ValidateShipToLocation | Validate the Order's Ship To Location, if the Orders Entity is configured to validate the Ship To location. The Orders Entity Attribute ValidateShipToLocation controls the configuration. ValidateShipToLocation must be True or a non-zero numeric value in order to turn on Ship To Location validation. Based on the Ship To information, determine whether or not it is valid for the current Order. The current implementation passes the Order's ShipToCountry to the stored procedure, spIsARestrictedCountry. If the ShipToCountry matches an entry in the Restricted Countries list, the Ship To information is not valid.
ValidateSubTypes (inherited from AptifyGenericEntityBase)
VerifyObject (inherited from AptifyGenericEntity)

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity Constructor

Initializes a new instance of the OrdersEntity class.

public OrdersEntity();

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity Fields

The fields of the OrdersEntity class are listed below. For a complete list of OrdersEntity class members, see the OrdersEntity Members topic.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_bAdjustExistingPayment
m_bAllowZeroInitialPaymentOnCreditMemo
m_bExtraPaymentDialogWasDisplayed
m_bSuspendOrderTotalsCalculation
m_ExtraPaymentGE
m_iOrderPaymentLine
m_OrderPaymentGE
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.m_bAdjustExistingPayment Field

protected m_bAdjustExistingPayment m_bAdjustExistingPayment;

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.m_bAllowZeroInitialPaymentOnCreditMemo Field

protected m_bAllowZeroInitialPaymentOnCreditMemo m_bAllowZeroInitialPaymentOnCreditMemo;

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.m_bExtraPaymentDialogWasDisplayed Field

protected m_bExtraPaymentDialogWasDisplayed m_bExtraPaymentDialogWasDisplayed;

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.m_bSuspendOrderTotalsCalculation Field

protected m_bSuspendOrderTotalsCalculation m_bSuspendOrderTotalsCalculation;

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.m_ExtraPaymentGE Field

protected m_ExtraPaymentGE m_ExtraPaymentGE;

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.m_iOrderPaymentLine Field

protected m_iOrderPaymentLine m_iOrderPaymentLine;

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.m_OrderPaymentGE Field

protected m_OrderPaymentGE m_OrderPaymentGE;

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity Properties

The properties of the OrdersEntity class are listed below. For a complete list of OrdersEntity class members, see the OrdersEntity Members topic.

Public Instance Properties

ABA (inherited from OrdersClass) |
AccountName (inherited from OrdersClass) |
AccountNumber (inherited from OrdersClass) |
Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
ArrivalDate (inherited from OrdersClass) |
AvailableForShipping | Overloaded.
BackOrderARFlag |
Balance (inherited from OrdersClass) |
Bank (inherited from OrdersClass) |
BasePaymentType (inherited from OrdersClass) |
Batched |
BatchID (inherited from OrdersClass) |
BillToAddressID (inherited from OrdersClass) |
BillToAddressIDObject (inherited from OrdersClass) |
BillToAddrLine1 (inherited from OrdersClass) |
BillToAddrLine2 (inherited from OrdersClass) |
BillToAddrLine3 (inherited from OrdersClass) |
BillToAreaCode (inherited from OrdersClass) |
BillToCity (inherited from OrdersClass) |
BillToCompany (inherited from OrdersClass) |
BillToCompanyID | Overloaded.
BillToCountry (inherited from OrdersClass) |
BillToCountryCode (inherited from OrdersClass) |
BillToCountryCodeID (inherited from OrdersClass) |
BillToCounty (inherited from OrdersClass) |
BillToEmail (inherited from OrdersClass) |
BillToID | Overloaded.
BillToName (inherited from OrdersClass) |
BillToPhone (inherited from OrdersClass) |
BillToPhoneExtension (inherited from OrdersClass) |
BillToPhoneID (inherited from OrdersClass) |
BillToPhoneIDObject (inherited from OrdersClass) |
BillToSameAsShipTo (inherited from OrdersClass) |
BillToState (inherited from OrdersClass) |
BillToZipCode (inherited from OrdersClass) |
BranchName (inherited from OrdersClass) |
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
CALC_AdjustedTotal (inherited from OrdersClass) |
CALC_Discount (inherited from OrdersClass) |
CALC_GrandTotal (inherited from OrdersClass) |
CALC_HandlingCharge (inherited from OrdersClass) |
CALC_LineCount (inherited from OrdersClass) |
CALC_PaymentTotal (inherited from OrdersClass) |
CALC_SalesTax (inherited from OrdersClass) |
CALC_ShippingCharge (inherited from OrdersClass) |
CALC_ShippingExpense (inherited from OrdersClass) |
CALC_SubTotal (inherited from OrdersClass) |
CALC_TaxableTotal (inherited from OrdersClass) |
CalculateShippingOnLineAdd |
CalculateTaxOnLineAdd |
CampaignCodeID | Overloaded.
CampaignCodeName (inherited from OrdersClass) |
CancellationReasonID (inherited from OrdersClass) |
CashCtrlBatchID (inherited from OrdersClass) |
CCAccountNumber (inherited from OrdersClass) |
CCAuthCode (inherited from OrdersClass) |
CCExpireDate (inherited from OrdersClass) |
CCPartial (inherited from OrdersClass) |
CCSecurityNumber (inherited from OrdersClass) |
ChapterAssignmentObject | The internal instance of the object implementing IChapterAssignmentRules that is being used by the order. This object is demand-loaded the first time it is accessed. The object is defined by the Orders Entity Chapter Assignment Rules plug-in.
CheckNumber (inherited from OrdersClass) |
Comments (inherited from OrdersClass) |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CreditOrderID (inherited from OrdersClass) |
CurrencySpotRateObject |
CurrencyType (inherited from OrdersClass) |
CurrencyTypeFormat | Returns the Currency Type's FormatString value. If no matching Currency Type is found, the property returns "Currency", which will use the local system's Regional Currency format.
CurrencyTypeID |
CurrencyTypeNumberOfDecimalPlaces | Returns the Currency Type's Number of Digits after the Decimal value for the Order's Currency Type. If no matching Currency Type is found, the property returns 2.
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
CustomerMemberType | Overloaded.
CustShipAcctNum (inherited from OrdersClass) |
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DateCreated (inherited from OrdersClass) |
DateUpdated (inherited from OrdersClass) |
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DepositDate (inherited from OrdersClass) |
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
DropShip |
DueDate (inherited from OrdersClass) |
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
Employee (inherited from OrdersClass) |
EmployeeID (inherited from OrdersClass) |
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
FunctionalCurrencyTypeID | Returns the Functional Currency of the Organization associated with the Order.
GrandTotal (inherited from OrdersClass) |
HoldUntil (inherited from OrdersClass) |
ID (inherited from OrdersClass) |
InitialPaymentAmount (inherited from OrdersClass) |
InvoiceMessage (inherited from OrdersClass) |
InvoiceNumber (inherited from OrdersClass) |
IsCancelling | Used to determine whether or not the Order is currently being cancelled. Current criteria checks whether or not the OrderStatusID is dirty and that the current value of OrderStatusID is Shipped (3).
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
isSaving | This property will let/set the boolean value that will determine wheter record is being saved now.
IsShipping | Used to determine whether or not the Order is currently shipping. Current criteria checks whether or not the OrderStatusID is dirty and that the current value of OrderStatusID is Shipped (2).
KitExpansionObject |
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
Line1_ProductCategory (inherited from OrdersClass) |
Line1_ProductID (inherited from OrdersClass) |
Line1_ProductName (inherited from OrdersClass) |
OldOrderStatus | Provides a way to get the Order's Status at the time the GE object was loaded.
OrderDate |
OrderLevel (inherited from OrdersClass) |
OrderLevelID (inherited from OrdersClass) |
OrderSource (inherited from OrdersClass) |
OrderSourceID (inherited from OrdersClass) |
OrderStatus | Overloaded. Provides a way to get and set an Order's Status by using an Enumerated Type (OrderStatus). The OrderStatusID values control certain aspects of the Orders Entity object. Only the values listed in the Enumerated Type have meaning.
OrderStatusID (inherited from OrdersClass) |
OrderType | Overloaded.
OrderTypeID (inherited from OrdersClass) |
Organization (inherited from OrdersClass) |
OrganizationID (inherited from OrdersClass) |
OriginalOrderID | Overloaded.
OverrideShippingCalc (inherited from OrdersClass) |
PackingSlipsPrinted (inherited from OrdersClass) |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PaymentCashControlBatchID |
PaymentInformationID (inherited from OrdersClass) |
PaymentScheduleOptions (inherited from OrdersClass) |
PayType (inherited from OrdersClass) |
PayTypeID (inherited from OrdersClass) |
PONumber (inherited from OrdersClass) |
PreferredAddress | Returns an instance of the Preferred Address Object, which is recorded as a Persons Entity Plug-In.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
PromiseDate (inherited from OrdersClass) |
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
ReferralListID (inherited from OrdersClass) |
ReferredBy (inherited from OrdersClass) |
ReferredByID (inherited from OrdersClass) |
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
ReturnShippingCharge (inherited from OrdersClass) |
SalesRep (inherited from OrdersClass) |
SalesRepID (inherited from OrdersClass) |
SalesTaxAmounts | Contains a dictionary of the total Sales Tax amounts, grouped by SalesTaxRateID. Each value has been rounded to the appropriate number of decimal places, based on the Order's Currency Type.
SalesTaxObject | The internal instance of the object implementing ISalesTax that is being used by the order. This object is demand-loaded the first time it is accessed. The object is defined by the Orders Entity Sales Tax plug-in.
SalesTaxRate (inherited from OrdersClass) |
SalesTaxRateID (inherited from OrdersClass) |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
ShipCharge (inherited from OrdersClass) |
ShipDate (inherited from OrdersClass) |
ShipExpense (inherited from OrdersClass) |
ShippedBy (inherited from OrdersClass) |
ShippedByID (inherited from OrdersClass) |
ShipToAddressID (inherited from OrdersClass) |
ShipToAddressIDObject (inherited from OrdersClass) |
ShipToAddrLine1 (inherited from OrdersClass) |
ShipToAddrLine2 (inherited from OrdersClass) |
ShipToAddrLine3 (inherited from OrdersClass) |
ShipToAreaCode (inherited from OrdersClass) |
ShipToCity (inherited from OrdersClass) |
ShipToCompany (inherited from OrdersClass) |
ShipToCompanyID | Overloaded.
ShipToCountry (inherited from OrdersClass) |
ShipToCountryCode (inherited from OrdersClass) |
ShipToCountryCodeID (inherited from OrdersClass) |
ShipToCounty (inherited from OrdersClass) |
ShipToEmail (inherited from OrdersClass) |
ShipToID | Overloaded.
ShipToName (inherited from OrdersClass) |
ShipToPhone (inherited from OrdersClass) |
ShipToPhoneExtension (inherited from OrdersClass) |
ShipToPhoneID (inherited from OrdersClass) |
ShipToPhoneIDObject (inherited from OrdersClass) |
ShipToState (inherited from OrdersClass) |
ShipToZipCode (inherited from OrdersClass) |
ShipTrackingNum (inherited from OrdersClass) |
ShipType (inherited from OrdersClass) |
ShipTypeID (inherited from OrdersClass) |
SubscriptionDateObject |
SubscriptionID (inherited from OrdersClass) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
SuspendOrderTotalsCalculation |
TaxJurisdiction (inherited from OrdersClass) |
TaxJurisdictionID (inherited from OrdersClass) |
Terms (inherited from OrdersClass) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.
WhoCreated (inherited from OrdersClass) |
WhoUpdated (inherited from OrdersClass) |

Protected Instance Properties

AddressFlowDownObject | Returns an instance of the Order Address Flowdown object.
AutoShipSetting | If the AutoShipSetting has not been specified, retreive the setting from the Orders Entity Attribute, AutoShipNonFulfillmentProducts. If the Attribute value is 0, the AutoShipSetting is Disabled. If the Attribute value is 1, the AutoShipSetting is Enabled but Autoshipment requires confirmation from the User before it will be shipped. Confirmation will only be retrrieved if the Save method's AllowGUI parameter is True. If the Attribute value is 2, the AutoShipSetting is Enabled and no confirmation is required from the User. In this case, a qualifying Order will be Shipped during the Order Save process. If the Attribute doesn't exist or the value is something other than what is listed above, the AutoShipSetting is Disabled.
BackOrderPlugin |
CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
CreditCheckObject |
ExtraPaymentDialog |
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
LineShipDialogPlugin |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SaveSubsObject |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
ShippingCalculatorObject |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


AddressFlowDownObject Property

Aptify 5.0 Software Development Kit (SDK)

OrdersEntity.AddressFlowDownObject Property

Returns an instance of the Order Address Flowdown object.

protected IOrderAddressFlowdown AddressFlowDownObject {get;}

Property Value

Remarks

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


AutoShipSetting Property

Aptify 5.0 Software Development Kit (SDK)

OrdersEntity.AutoShipSetting Property

If the AutoShipSetting has not been specified, retreive the setting from the Orders Entity Attribute, AutoShipNonFulfillmentProducts. If the Attribute value is 0, the AutoShipSetting is Disabled. If the Attribute value is 1, the AutoShipSetting is Enabled but Autoshipment requires confirmation from the User before it will be shipped. Confirmation will only be retrrieved if the Save method's AllowGUI parameter is True. If the Attribute value is 2, the AutoShipSetting is Enabled and no confirmation is required from the User. In this case, a qualifying Order will be Shipped during the Order Save process. If the Attribute doesn't exist or the value is something other than what is listed above, the AutoShipSetting is Disabled.

protected virtual OrdersEntity.AutoShipmentSetting AutoShipSetting {get;}

Property Value

Remarks

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.AutoShippingAvailabilityTypes Property

Aptify 5.0 Software Development Kit (SDK)

OrdersEntity.OrdersEntity.AutoShippingAvailabilityTypes Property

Overload List

public OrdersEntity.AutoShippingAvailabilityTypes AvailableForShipping {get;}

public OrdersEntity.AutoShippingAvailabilityTypes this[Boolean] {get;}

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


AvailableForShipping Property

Aptify 5.0 Software Development Kit (SDK)

OrdersEntity.AvailableForShipping Property

public OrdersEntity.AutoShippingAvailabilityTypes AvailableForShipping {get;}

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace | OrdersEntity.OrdersEntity.AutoShippingAvailabilityTypes Overload List


AvailableForShipping Property (Boolean)

Aptify 5.0 Software Development Kit (SDK)

OrdersEntity.AvailableForShipping Property (Boolean)

public OrdersEntity.AutoShippingAvailabilityTypes this[
Boolean CheckInventory
] {get;}

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace | OrdersEntity.OrdersEntity.AutoShippingAvailabilityTypes Overload List


BackOrderARFlag Property

Aptify 5.0 Software Development Kit (SDK)

OrdersEntity.BackOrderARFlag Property

public OrdersEntity.BackOrderARTypes BackOrderARFlag {get;}

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


BackOrderPlugin Property

Aptify 5.0 Software Development Kit (SDK)

OrdersEntity.BackOrderPlugin Property

protected IBackOrder BackOrderPlugin {get;}

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


Batched Property

Aptify 5.0 Software Development Kit (SDK)

OrdersEntity.Batched Property

public Boolean Batched {get;}

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


BillToCompanyID Property

Aptify 5.0 Software Development Kit (SDK)

OrdersEntity.BillToCompanyID Property

new public Int64 BillToCompanyID {get; set;}

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


BillToID Property

Aptify 5.0 Software Development Kit (SDK)

OrdersEntity.BillToID Property

new public Int64 BillToID {get; set;}

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


CalculateShippingOnLineAdd Property

Aptify 5.0 Software Development Kit (SDK)

OrdersEntity.CalculateShippingOnLineAdd Property

public Boolean CalculateShippingOnLineAdd {get;}

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


CalculateTaxOnLineAdd Property

Aptify 5.0 Software Development Kit (SDK)

OrdersEntity.CalculateTaxOnLineAdd Property

public Boolean CalculateTaxOnLineAdd {get;}

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


CampaignCodeID Property

Aptify 5.0 Software Development Kit (SDK)

OrdersEntity.CampaignCodeID Property

new public Int64 CampaignCodeID {get; set;}

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


ChapterAssignmentObject Property

Aptify 5.0 Software Development Kit (SDK)

OrdersEntity.ChapterAssignmentObject Property

The internal instance of the object implementing IChapterAssignmentRules that is being used by the order. This object is demand-loaded the first time it is accessed. The object is defined by the Orders Entity Chapter Assignment Rules plug-in.

public virtual IChapterAssignmentRules ChapterAssignmentObject {get;}

Property Value

Remarks

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


CreditCheckObject Property

Aptify 5.0 Software Development Kit (SDK)

OrdersEntity.CreditCheckObject Property

protected ICheckCredit CreditCheckObject {get;}

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


CurrencySpotRateObject Property

Aptify 5.0 Software Development Kit (SDK)

OrdersEntity.CurrencySpotRateObject Property

public ISpotRate CurrencySpotRateObject {get;}

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


CurrencyTypeFormat Property

Aptify 5.0 Software Development Kit (SDK)

OrdersEntity.CurrencyTypeFormat Property

Returns the Currency Type's FormatString value. If no matching Currency Type is found, the property returns "Currency", which will use the local system's Regional Currency format.

public String CurrencyTypeFormat {get;}

Property Value

Remarks

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


CurrencyTypeID Property

Aptify 5.0 Software Development Kit (SDK)

OrdersEntity.CurrencyTypeID Property

new public Int32 CurrencyTypeID {get; set;}

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


CurrencyTypeNumberOfDecimalPlaces Property

Aptify 5.0 Software Development Kit (SDK)

OrdersEntity.CurrencyTypeNumberOfDecimalPlaces Property

Returns the Currency Type's Number of Digits after the Decimal value for the Order's Currency Type. If no matching Currency Type is found, the property returns 2.

public Int32 CurrencyTypeNumberOfDecimalPlaces {get;}

Property Value

Remarks

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


String Property

Aptify 5.0 Software Development Kit (SDK)

OrdersEntity.String Property

Overload List

public virtual String CustomerMemberType {get;}

public virtual String this[Boolean] {get;}

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


CustomerMemberType Property

Aptify 5.0 Software Development Kit (SDK)

OrdersEntity.CustomerMemberType Property

public virtual String CustomerMemberType {get;}

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace | OrdersEntity.String Overload List


CustomerMemberType Property (Boolean)

Aptify 5.0 Software Development Kit (SDK)

OrdersEntity.CustomerMemberType Property (Boolean)

public virtual String this[
Boolean ForceRefresh
] {get;}

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace | OrdersEntity.String Overload List


DropShip Property

Aptify 5.0 Software Development Kit (SDK)

OrdersEntity.DropShip Property

new public Boolean DropShip {get; set;}

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


ExtraPaymentDialog Property

Aptify 5.0 Software Development Kit (SDK)

OrdersEntity.ExtraPaymentDialog Property

protected IExtraPaymentDialog ExtraPaymentDialog {get;}

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


FunctionalCurrencyTypeID Property

Aptify 5.0 Software Development Kit (SDK)

OrdersEntity.FunctionalCurrencyTypeID Property

Returns the Functional Currency of the Organization associated with the Order.

public Int32 FunctionalCurrencyTypeID {get;}

Property Value

Remarks

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


IsCancelling Property

Aptify 5.0 Software Development Kit (SDK)

OrdersEntity.IsCancelling Property

Used to determine whether or not the Order is currently being cancelled. Current criteria checks whether or not the OrderStatusID is dirty and that the current value of OrderStatusID is Shipped (3).

public virtual Boolean IsCancelling {get;}

Property Value

Remarks

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


isSaving Property

Aptify 5.0 Software Development Kit (SDK)

OrdersEntity.isSaving Property

This property will let/set the boolean value that will determine wheter record is being saved now.

public Boolean isSaving {get; set;}

Remarks

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


IsShipping Property

Aptify 5.0 Software Development Kit (SDK)

OrdersEntity.IsShipping Property

Used to determine whether or not the Order is currently shipping. Current criteria checks whether or not the OrderStatusID is dirty and that the current value of OrderStatusID is Shipped (2).

public virtual Boolean IsShipping {get;}

Property Value

Remarks

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


KitExpansionObject Property

Aptify 5.0 Software Development Kit (SDK)

OrdersEntity.KitExpansionObject Property

public virtual IExpandKits KitExpansionObject {get;}

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


LineShipDialogPlugin Property

Aptify 5.0 Software Development Kit (SDK)

OrdersEntity.LineShipDialogPlugin Property

protected ILineShipDialog LineShipDialogPlugin {get;}

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OldOrderStatus Property

Aptify 5.0 Software Development Kit (SDK)

OrdersEntity.OldOrderStatus Property

Provides a way to get the Order's Status at the time the GE object was loaded.

public OrderStatus OldOrderStatus {get;}

Property Value

Remarks

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrderDate Property

Aptify 5.0 Software Development Kit (SDK)

OrdersEntity.OrderDate Property

new public DateTime OrderDate {get; set;}

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrderStatus Property

Aptify 5.0 Software Development Kit (SDK)

OrdersEntity.OrderStatus Property

Provides a way to get and set an Order's Status by using an Enumerated Type (OrderStatus). The OrderStatusID values control certain aspects of the Orders Entity object. Only the values listed in the Enumerated Type have meaning.

new public OrderStatus OrderStatus {get; set;}

Property Value

Remarks

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrderType Property

Aptify 5.0 Software Development Kit (SDK)

OrdersEntity.OrderType Property

new public OrderType OrderType {get; set;}

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OriginalOrderID Property

Aptify 5.0 Software Development Kit (SDK)

OrdersEntity.OriginalOrderID Property

new public Int64 OriginalOrderID {get; set;}

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


PaymentCashControlBatchID Property

Aptify 5.0 Software Development Kit (SDK)

OrdersEntity.PaymentCashControlBatchID Property

public Int64 PaymentCashControlBatchID {get; set;}

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


PreferredAddress Property

Aptify 5.0 Software Development Kit (SDK)

OrdersEntity.PreferredAddress Property

Returns an instance of the Preferred Address Object, which is recorded as a Persons Entity Plug-In.

public PreferredAddress PreferredAddress {get;}

Property Value

Remarks

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


SalesTaxAmounts Property

Aptify 5.0 Software Development Kit (SDK)

OrdersEntity.SalesTaxAmounts Property

Contains a dictionary of the total Sales Tax amounts, grouped by SalesTaxRateID. Each value has been rounded to the appropriate number of decimal places, based on the Order's Currency Type.

public virtual Dictionary<TKey,TValue> SalesTaxAmounts {get;}

Property Value

Remarks

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


SalesTaxObject Property

Aptify 5.0 Software Development Kit (SDK)

OrdersEntity.SalesTaxObject Property

The internal instance of the object implementing ISalesTax that is being used by the order. This object is demand-loaded the first time it is accessed. The object is defined by the Orders Entity Sales Tax plug-in.

public virtual ISalesTax SalesTaxObject {get;}

Property Value

Remarks

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


SaveSubsObject Property

Aptify 5.0 Software Development Kit (SDK)

OrdersEntity.SaveSubsObject Property

protected ISubscriptionSave SaveSubsObject {get;}

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


ShippingCalculatorObject Property

Aptify 5.0 Software Development Kit (SDK)

OrdersEntity.ShippingCalculatorObject Property

protected IShippingCalculator ShippingCalculatorObject {get;}

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


ShipToCompanyID Property

Aptify 5.0 Software Development Kit (SDK)

OrdersEntity.ShipToCompanyID Property

new public Int64 ShipToCompanyID {get; set;}

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


ShipToID Property

Aptify 5.0 Software Development Kit (SDK)

OrdersEntity.ShipToID Property

new public Int64 ShipToID {get; set;}

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


SubscriptionDateObject Property

Aptify 5.0 Software Development Kit (SDK)

OrdersEntity.SubscriptionDateObject Property

public virtual ISubscriptionDate SubscriptionDateObject {get;}

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


SuspendOrderTotalsCalculation Property

Aptify 5.0 Software Development Kit (SDK)

OrdersEntity.SuspendOrderTotalsCalculation Property

public Boolean SuspendOrderTotalsCalculation {get; set;}

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity Methods

The methods of the OrdersEntity class are listed below. For a complete list of OrdersEntity class members, see the OrdersEntity Members topic.

Public Instance Methods

AddCancellationOrderLine | Overloaded.
AddProduct | Overloaded. Adds a Product to the Order. Product must be available for sale. This overload results in the default quantity of either 1 or the minimum purchase quantity for the Product, whichever is greater. This overload also uses the newest version of a given product as its default behavior. The other overloads of this method allow more control over those default behaviors.
BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CalculateOrderLinesGrossRevenue | Calculates the Gross Revenue and Gross Discount amounts for each Order Line. Includes logic to handle the distribution of Revenue amongst Kit parts.
CalculateOrderTotals | Overloaded. Calculates the summary Order totals, including the calculation of Tax and Shipping on the Order.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
CheckOrderLineInventory | Called when a Product is added to an Order and when the Quantity (>0) of an existing Order Line is updated. If the available inventory is not sufficient or the inventory check fails, the OnCheckInventoryOnOrderLineFailed method is called.
CheckSuccessionFixedTerm | This method is responsible for determining if the fixed term associated with the Product.SubscriptionMaxDuration has been reached. Product.SubscriptionMaxDuration specifies the maximum duration of a subscription for the specified product denominated in units based on the Product.SubscriptionType. For example, if a product has an monthly subscription frequency, the Product.SubscriptionMaxDuration refers to the number of months that a subscription may go for. In this instance, if the field was populated with a value of 36, it implies that a monthly subscription may only be renewed for a total duration of 3 years.
CheckSuccessionTriggerRule | This method is responsible for checking to see if the specified product is ready to be replaced by a succession product by executing a rule in the database. If the rule returns 1, this function will return True, otherwise this function returns False. If this function returns True, it means that the product specified by the Product parameter to this function may not be added and must be succeeded by another product.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config | Overloaded.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
CreateBackorders |
Delete | Overloaded. Verifies that the Order has not be Batched or Shipped before deleting.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
FlowdownCustomerAddresses | Overloaded.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetNewInvoiceNumber |
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetOrderBalance | Overloaded.
GetOrderTotal | Overloaded.
GetPotentialCancellationOrderLines | Overloaded.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetSubscriptionIDAndStartDate | This method returns the Subscription ID of an existing subscription record in the database for the specified Product ID, Person ID and Company ID combination. For individual subscriptions, pass leave the CompanyID at its default value of -1. For Company subscriptions, provide both PersonID and CompanyID. If no existing subscription is found, -1 is returned.
GetSuccessionProductByRule | This method is responsible for executing the succession product rule associated with the specified product for the given order. This rule is called only when a product is determined to be in line for a successor product
GetSuccessorProductID | This method is responsible for determining the successor product ID to use for the Product specified in the Product parameter.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. Uses the Generic Entity's GetValue functionality except when a field that begins with BillTo and the BillToSameAsShipTo flag is true. In those cases, the BillTo* fields will return the corresponding ShipTo* field value. The exception to this is the BillToSameAsShipTo field, which does not have a corresponding ShipTo field.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load | Overloaded.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data from a field with the supplied ID.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord |
OKToModifyOrder | Calls protected methods OKToModifyBatchedOrder and OKToModifyShippedOrder, where appropriate.
OrderCurrencySpotRate (inherited from OrdersClass) |
OrderCurrencySpotRateObject (inherited from OrdersClass) |
OrderGLEntry (inherited from OrdersClass) |
OrderGLEntryObject (inherited from OrdersClass) |
OrderInvAllocation (inherited from OrdersClass) |
OrderInvAllocationObject (inherited from OrdersClass) |
OrderLines (inherited from OrdersClass) |
OrderLinesObject (inherited from OrdersClass) |
OrderPaymentSchedule (inherited from OrdersClass) |
OrderPaymentScheduleObject (inherited from OrdersClass) |
OrderShipments (inherited from OrdersClass) |
OrderShipmentsObject (inherited from OrdersClass) |
RemoveOrderLine | Removes an Order Line from the Order. Handles Kit Products as well by removing the Kit Parts. If the Orders Entity Attribute, RecalculateOrderLinesAfterRemove, exists and have a value of 1, the remaining Order Lines' prices will be recaculated after the remove.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetBillingAddress |
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetCustomerData | Method utilized by the order UI to configure various customer data based on a number of rules.
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetShippingAddress |
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ShipAvailableLines | Overloaded.
ShipEntireOrder | Overloaded.
ShipPartialOrder | This method is used by the Backorders process when the BackOrderARFlag is OriginalOrder(0). With this setting, the Original
ShouldUseSuccessorProduct | This method is only relevant for Subscription products. This method is responsible for determining if a successor product should be used for a given selected product. If the rules for this particular product require a successor product be automatically used whenever certain successor conditions are met, the order entry system will automatically swap the selected product with its successor product.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AddFieldValueChangedEventHandlers | Configures the Fields to fire the ValueChanged events and adds Event Handlers to for the AfterValueChanged event. The core EventHandler is the OrderLinesFields_AfterValueChanged method. The following fields are monitored: ProductID, Quantity, Price, Discount and Subscription Copies.
AddProductSetProductPrice | Calculates the Price for a new Order Line. Performs validation based on the value of Orders Entity Attribute, OrderLinePriceRequirement. Supported Settings: - NotRequired: A defined Price is not required for an Order Line. If a Price is not found, a zero price will be used. This behaviour matches the behavior in previous versions of the application and it is the default behavior. - WarningDefaultNotRequired: If a defined Price is not found because it does not exist or an error occurred, a GE Warning event will be raised with the default set to not required. A return value of Yes will be treated as NotRequired. A return value of No will be treated as Required. If no event handler exists, it will behave as NotRequired. - WarningDefaultRequired: If a defined Price is not found because it does not exist or an error occurred, a GE Warning event will be raised with the default set to not required. A return value of Yes will be treated as NotRequired. A return value of No will be treated as Required. If no event handler exists, it will behave as Required. - Required: A defined Price is required. If one is not found, this method will return False and the Order Line will not be added to the Order. - RequiredIfNoOverride: A defined Price is required, unless the Order Line / User is allowed to override the Price and/or allow the Order Line to be free. Called from the AddProduct method
AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase)
AssignChapter | This method assigns a value to the ChapterID field in the specified order line object. The base class functionality uses the Chapter Assignment Rules plug-in to perform this calculation. This method should only be called if the ChapterAssignmentRuleID for the product placed in the order line is > 0.
AutoShipOrder
BroadcastChange (inherited from AptifyGenericEntity)
CalculateKitGrossRevenue
CalculateOrderBalance | Calculates the Order Balance based on a provided order total.
CalculateSalesTax | Update and, optionally, calculate the Sales Tax for the Order.
CalculateShippingAndHandling | Update, and optional, calculate the Shipping and Handling charges for the Order.
CalculateStandardLineGrossRevenue
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase)
CloneSubType (inherited from AptifyGenericEntity)
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreatePayment
CreateRecord (inherited from AptifyGenericEntity)
CreateSubTypeRecord (inherited from AptifyGenericEntity)
CreateTopLevelRecord (inherited from AptifyGenericEntity)
DebitMatchesCredit | Verify that the sum of the Credit and Debit amounts for the OrderGLEntry records match.
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase)
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo
DoPrintOrder
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FindInitialPayment | Finds Payment record that exactly matches order's initial Payment Information.
FindPayment
FinishTransaction (inherited from AptifyGenericEntity)
FinishTransactionSubType (inherited from AptifyGenericEntity)
FinishTransactionTopLevel (inherited from AptifyGenericEntity)
FireEvent (inherited from AptifyGenericEntity)
FireValidationEvent (inherited from AptifyGenericEntity)
FlowdownCCBDepositDate | Given a valid Cash Control Batch ID, retrieve the Cash Control Batch's DepositDate and use it to populate the Order's DepositDate. Calls the stored procedure spGetBatchDepositDate, setting the @BatchID parameter to the value in CashControlBatchID. If the stored procedure returns a valid Date, the Order's DepositDate field is set to the value of the first record's first field.
FormatDateTimeForSQL | Given a DateTime value, convert it to a string that will be understood by SQL Server regardless of the current regional date settings.
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity)
GenerateCreateSQL (inherited from AptifyGenericEntity)
GenerateDeleteSQL (inherited from AptifyGenericEntity)
GenerateFieldSQL (inherited from AptifyGenericEntity)
GenerateGLEntries
GenerateInvoiceNumber | Generates the InvoiceNumber value for an Order, if the Orders Entity is configured for generating Invoice Numbers. The Orders Entity Attributes GenerateInvoiceNumber and GenerateInvoiceNumberStoredProcedure control the Invoice Number generation functionality. GenerateInvoiceNumber must be True or a non-zero numeric value and GenerateInvoiceNumberStoredProcedure must specify a stored procedure in the same database as the Orders Entity. If these conditions are not met, the Invoice Number will not be generated and the method will return an empty string. When Invoice Number generation is properly configured, the stored procedure defined in GenerateInvoiceNumberStoredProcedure will be called and the first record's first field value will be returned, if found. If not, an empty string is returned.
GenerateUpdateSQL (inherited from AptifyGenericEntity)
GESave
GetPersonCompanyID | Obsolete.
GetPersonCompanyIDAndName | Returns the Company ID and Name for a given Person ID. Uses the stored procedure, spGetCompanyIDAndNameForPerson.
GetSubscriberCompanyID | This method is responsible for returning the ID of the Company this is used to populate the Subscription's SubscriberCompanyID. The SubscriberCompanyID indicates the Company that is both the Subscriber and Recipient for a Subscription. There is an Entity Attribute on the Subscriptions Entity, SubscriberCompanyBehavior, that affects the behavior in this method. If the Entity Attribute does not exist or has a value of Order, the Order's ShipToCompanyID will be returned, if the Order's ShipToCompanyID is greater than 0. If the Order's ShipToCompanyID is less than or equal to 0 or the SubscriberCompanyBehavior Attribute value is Person, call the GetPersonCompanyID method to retrieve the CompanyID based on the PersonID parameter value.
GetSuccessionProductDates | This method is responsible for determining the start date to use for a successor product when a successor product is going to replace a previously selected product.
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase)
InitializeInternalVariables | Initializes the protected variables to match the field values of the current Order. For new records: the EmployeeID will be set to the currently logged in User's Employee ID and the InvoiceNumber will be generated (if configured). The Order's Organization can also be populated with the call to InitializeOrganizationID.
InitializeOrderAddressFieldVariables
InitializeOrganizationID | Used to set the Order's OrganizationID for a new Order. The core implementation uses the Taken By Employee's OrganizationID. Called by InitializeInternalVariables method for new Orders.
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity)
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OKToModifyBatchedOrder
OKToModifyShippedOrder
OkToRecalcTotals | Is it OK to recalculate the Order Totals? Core implementation returns True if the Order hasn't already been shipped. Called by CalculateOrderTotals method.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeUpgradeProductToLatestVersion
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnCheckInventoryOnOrderLineFailed
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
OrderAddressFields_AfterValueChanged
OrdersFields_AfterValueChanged
PromptForAdditionalPayment
RecordVersionInfo (inherited from AptifyGenericEntity)
RefreshLinkedFields (inherited from AptifyGenericEntity)
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase)
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity)
RestoreCopiedFields (inherited from AptifyGenericEntity)
RollbackEmbeddedObjects (inherited from AptifyGenericEntity)
SaveCancellationData
SaveCancellationSubscriptions
SaveCheckInventory | Called from the Save method when the Order is being shipped.
SaveCreateOrderCurrencySpotRates | If the System's functional currency differs from the functional currency of the order, then the spot rate will be recorded because a foreign currency gain or loss may need to be recorded at a later point. Called from the Save method when the Order is being shipped.
SaveDateChanges
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SaveGLEntries
SavePayments
SavePermitChanges | Additional validation in the Save method. If AllowGUI is true, any failure will be displayed to the user in a message box. This function checks to make sure order isn't batched or shipped, and if it is checks appropriate fields to see whether changes can be saved.
SaveProcessSubscriptions
SaveRevRecognitionScheduledTransactions | Creates the scheduled transaction groups needed to move funds from the deferred income account to the sales account on the revenue recognition date. Processes each Order Line and determines which are impacted by revenue recognition date. Creates a scheduled transaction group record for each impacted Order Line.
SaveScheduledTransactionGroups | Creates scheduled transaction group records. A scheduled transaction group is created for each order line for a product requiring deferred income. During the batching process, each scheduled transaction group record is expanded to each of the individual scheduled transactions using the data in the record.
SaveSetDepositDate
SaveSubscriptions
SetCurrentTransactionID (inherited from AptifyGenericEntityBase)
SetIsShipping
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase)
SetupTransaction (inherited from AptifyGenericEntity)
SetupTransactionSubType (inherited from AptifyGenericEntity)
SetupTransactionTopLevel (inherited from AptifyGenericEntity)
ShowMessageBox | Overloaded.
UpdateInventory
UpdatePayment
UpdatePaymentObject
UpdateRecord (inherited from AptifyGenericEntity)
ValidateCancellationCreditCard | This function is called to validate the credit card that is being used to cancel an Order.
ValidateCancellationOrder | Called by the Validate routine when the Order is a Cancellation Order. (OrderTypeID=3) Validates that the Order's OriginalOrderID has been set, that the Quantity returned doesn't exceed the Quantity Shipped on the Original Order and that the returned products were on the Original Order. Note that this method assumes that the Order is a Cancellation Order.
ValidateCancellationQuantity | Validate that the quantity returned does not exceed the Original Order's quantity shipped. Called by the ValidateCancellationOrder method.
ValidateCheckCredit
ValidateCreditMemoOwnership | Responsible for determining whether or not the Credit Memo can be used as a Payment for the current based on the ownership of the Credit Memo. Called within the default implementation of ValidatePaymentInformation. Default implementation calls Aptify.Applications.OrderEntry.Payments.PaymentsEntity.ValidateCreditMemoOwnershipShared
ValidateExistingPayment
ValidateOrderLines | Validates information related to the OrderLines Sub-Type. Called by the Validate method Validation Rules: 1. An Order must have at least one Order Line. 2. Cancellation Order Lines must have a quantity less than 0. 3. Regular Order Lines must have a quantity greater than or equal to 0. A quantity of 0 is valid for items being backordered.
ValidatePaymentInformation | Validate that the Payment information and Credit Check is valid. Called by the Validate method when a Payment is being saved by the Order.
ValidateQuotationOrder | Called by the Validate routine when the Order is a Quotation Order. (OrderTypeID=4) Validates that the Order's Status is Taken (1) or Cancelled (4). Note that this method assumes that the Order is a Quotation.
ValidateRefund
ValidateShipToLocation | Validate the Order's Ship To Location, if the Orders Entity is configured to validate the Ship To location. The Orders Entity Attribute ValidateShipToLocation controls the configuration. ValidateShipToLocation must be True or a non-zero numeric value in order to turn on Ship To Location validation. Based on the Ship To information, determine whether or not it is valid for the current Order. The current implementation passes the Order's ShipToCountry to the stored procedure, spIsARestrictedCountry. If the ShipToCountry matches an entry in the Restricted Countries list, the Ship To information is not valid.
ValidateSubTypes (inherited from AptifyGenericEntityBase)
VerifyObject (inherited from AptifyGenericEntity)

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


AddCancellationOrderLine Method

Aptify 5.0 Software Development Kit (SDK)

OrdersEntity.AddCancellationOrderLine Method

Overload List

public virtual List<T> AddCancellationOrderLine(OrderCancellationDetail,Decimal);

public virtual List<T> AddCancellationOrderLine(Int64,Decimal);

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.AddCancellationOrderLine Method (OrderCancellationDetail, Decimal)

public virtual List<T> AddCancellationOrderLine(
OrderCancellationDetail cancellationDetail,
Decimal CancellationQuantity
);

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace | OrdersEntity.AddCancellationOrderLine Overload List


OrdersEntity.AddCancellationOrderLine Method (Int64, Decimal)

public virtual List<T> AddCancellationOrderLine(
Int64 OriginalOrderDetailID,
Decimal CancellationQuantity
);

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace | OrdersEntity.AddCancellationOrderLine Overload List


OrdersEntity.AddFieldValueChangedEventHandlers Method

Configures the Fields to fire the ValueChanged events and adds Event Handlers to for the AfterValueChanged event. The core EventHandler is the OrderLinesFields_AfterValueChanged method. The following fields are monitored: ProductID, Quantity, Price, Discount and Subscription Copies.

protected virtual void AddFieldValueChangedEventHandlers();

Remarks

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


AddProduct Method

Aptify 5.0 Software Development Kit (SDK)

OrdersEntity.AddProduct Method

Adds a Product to the Order. Product must be available for sale. This overload results in the default quantity of either 1 or the minimum purchase quantity for the Product, whichever is greater. This overload also uses the newest version of a given product as its default behavior. The other overloads of this method allow more control over those default behaviors.

Overload List

Adds a Product to the Order. Product must be available for sale. This overload results in the default quantity of either 1 or the minimum purchase quantity for the Product, whichever is greater. This overload also uses the newest version of a given product as its default behavior. The other overloads of this method allow more control over those default behaviors.

public virtual List<T> AddProduct(Int64);

Adds a Product to the Order. Product must be available for sale. With no Quantity specified a default Quantity of 1 or the minimum purchase quantity for the Product, whichever is greater. This overload allows you to specify if a new version of the product should be used if available.

public virtual List<T> AddProduct(Int64,Boolean);

Adds a Product to the Order. Product must be available for sale. This overload allows you to specify a quantity and always uses the latest version of a given product

public virtual List<T> AddProduct(Int64,Decimal);

Adds a Product to the Order. Product must be available for sale. This overload allows you to specify a quantity and also specify if the latest version of the product should be used or not.

public virtual List<T> AddProduct(Int64,Decimal,Boolean);

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.AddProduct Method (Int64)

Adds a Product to the Order. Product must be available for sale. This overload results in the default quantity of either 1 or the minimum purchase quantity for the Product, whichever is greater. This overload also uses the newest version of a given product as its default behavior. The other overloads of this method allow more control over those default behaviors.

public virtual List<T> AddProduct(
Int64 ProductID
);

Parameters

ProductID

Return Value

Remarks

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace | OrdersEntity.AddProduct Overload List


OrdersEntity.AddProduct Method (Int64, Boolean)

Adds a Product to the Order. Product must be available for sale. With no Quantity specified a default Quantity of 1 or the minimum purchase quantity for the Product, whichever is greater. This overload allows you to specify if a new version of the product should be used if available.

public virtual List<T> AddProduct(
Int64 ProductID,
Boolean UpgradeProductToLatestVersion
);

Parameters

ProductID
UpgradeProductToLatestVersion

Return Value

Remarks

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace | OrdersEntity.AddProduct Overload List


OrdersEntity.AddProduct Method (Int64, Decimal)

Adds a Product to the Order. Product must be available for sale. This overload allows you to specify a quantity and always uses the latest version of a given product

public virtual List<T> AddProduct(
Int64 ProductID,
Decimal Quantity
);

Parameters

ProductID
Quantity

Return Value

Remarks

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace | OrdersEntity.AddProduct Overload List


OrdersEntity.AddProduct Method (Int64, Decimal, Boolean)

Adds a Product to the Order. Product must be available for sale. This overload allows you to specify a quantity and also specify if the latest version of the product should be used or not.

public virtual List<T> AddProduct(
Int64 ProductID,
Decimal Quantity,
Boolean UpgradeProductToLatestVersion
);

Parameters

ProductID
Quantity
UpgradeProductToLatestVersion

Return Value

Remarks

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace | OrdersEntity.AddProduct Overload List


OrdersEntity.AddProductSetProductPrice Method

Calculates the Price for a new Order Line. Performs validation based on the value of Orders Entity Attribute, OrderLinePriceRequirement. Supported Settings: - NotRequired: A defined Price is not required for an Order Line. If a Price is not found, a zero price will be used. This behaviour matches the behavior in previous versions of the application and it is the default behavior. - WarningDefaultNotRequired: If a defined Price is not found because it does not exist or an error occurred, a GE Warning event will be raised with the default set to not required. A return value of Yes will be treated as NotRequired. A return value of No will be treated as Required. If no event handler exists, it will behave as NotRequired. - WarningDefaultRequired: If a defined Price is not found because it does not exist or an error occurred, a GE Warning event will be raised with the default set to not required. A return value of Yes will be treated as NotRequired. A return value of No will be treated as Required. If no event handler exists, it will behave as Required. - Required: A defined Price is required. If one is not found, this method will return False and the Order Line will not be added to the Order. - RequiredIfNoOverride: A defined Price is required, unless the Order Line / User is allowed to override the Price and/or allow the Order Line to be free. Called from the AddProduct method

protected virtual bool AddProductSetProductPrice(
OrderLinesEntity newOrderLine
);

Parameters

newOrderLine

Return Value

Remarks

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.AssignChapter Method

This method assigns a value to the ChapterID field in the specified order line object. The base class functionality uses the Chapter Assignment Rules plug-in to perform this calculation. This method should only be called if the ChapterAssignmentRuleID for the product placed in the order line is > 0.

protected virtual long AssignChapter(
ProductData Product,
OrderLinesEntity OrderLine
);

Parameters

Product
OrderLine

Return Value

Chapter ID(Companies entity record ID) or -1 if not set

Remarks

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.AutoShipOrder Method

protected virtual void AutoShipOrder(
Boolean AllowGUI
);

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.CalculateKitGrossRevenue Method

protected virtual void CalculateKitGrossRevenue(
OrderLinesEntity KitOrderLineGE
);

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.CalculateOrderBalance Method

Calculates the Order Balance based on a provided order total.

protected virtual void CalculateOrderBalance(
Decimal OrderTotal
);

Parameters

OrderTotal
Should be the most recently calculated Order Grand Total, including Tax and Shipping etc.

Remarks

This method will update the Balance and the CALC_PaymentTotal fields.

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.CalculateOrderLinesGrossRevenue Method

Calculates the Gross Revenue and Gross Discount amounts for each Order Line. Includes logic to handle the distribution of Revenue amongst Kit parts.

public virtual void CalculateOrderLinesGrossRevenue();

Remarks

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


CalculateOrderTotals Method

Aptify 5.0 Software Development Kit (SDK)

OrdersEntity.CalculateOrderTotals Method

Calculates the summary Order totals, including the calculation of Tax and Shipping on the Order.

Overload List

Calculates the summary Order totals, including the calculation of Tax and Shipping on the Order.

public virtual void CalculateOrderTotals();

public virtual void CalculateOrderTotals(Boolean,Boolean);

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.CalculateOrderTotals Method ()

Calculates the summary Order totals, including the calculation of Tax and Shipping on the Order.

public virtual void CalculateOrderTotals();

Remarks

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace | OrdersEntity.CalculateOrderTotals Overload List


OrdersEntity.CalculateOrderTotals Method (Boolean, Boolean)

public virtual void CalculateOrderTotals(
Boolean CalculateTax,
Boolean CalculateShipping
);

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace | OrdersEntity.CalculateOrderTotals Overload List


OrdersEntity.CalculateSalesTax Method

Update and, optionally, calculate the Sales Tax for the Order.

protected virtual void CalculateSalesTax(
Boolean Calculate,
ref Decimal& OrderSubTotal
);

Parameters

Calculate
If true, the Sales Tax calculation will be executed and the results aggregated and applied to CALC_SalesTax. If false, the existing Sales Tax amounts will only be aggregrated and applied to CALC_SalesTax
OrderSubTotal

Remarks

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.CalculateShippingAndHandling Method

Update, and optional, calculate the Shipping and Handling charges for the Order.

protected virtual void CalculateShippingAndHandling(
Boolean Calculate
);

Parameters

Calculate
If true, the Shipping and Handling calculations will be executed and the results aggregated and applied to CALC_ShippingCharge, CALC_ShippingCost, CALC_HandlingCharge, ShipCharge and ShipExpense. If false, the existing Sales Tax amounts will only be aggregrated and applied to fields listed above.

Remarks

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.CalculateStandardLineGrossRevenue Method

protected virtual void CalculateStandardLineGrossRevenue(
OrderLinesEntity OrderLineGE
);

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.CheckOrderLineInventory Method

Called when a Product is added to an Order and when the Quantity (>0) of an existing Order Line is updated. If the available inventory is not sufficient or the inventory check fails, the OnCheckInventoryOnOrderLineFailed method is called.

public virtual void CheckOrderLineInventory(
OrderLinesEntity OrderLineGE
);

Parameters

OrderLineGE

Remarks

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.CheckSuccessionFixedTerm Method

This method is responsible for determining if the fixed term associated with the Product.SubscriptionMaxDuration has been reached. Product.SubscriptionMaxDuration specifies the maximum duration of a subscription for the specified product denominated in units based on the Product.SubscriptionType. For example, if a product has an monthly subscription frequency, the Product.SubscriptionMaxDuration refers to the number of months that a subscription may go for. In this instance, if the field was populated with a value of 36, it implies that a monthly subscription may only be renewed for a total duration of 3 years.

public virtual bool CheckSuccessionFixedTerm(
ProductData Product,
ref DateTime& NewStartDate,
ref DateTime& NewEndDate
);

Parameters

Product
NewStartDate
NewEndDate

Return Value

Remarks

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.CheckSuccessionTriggerRule Method

This method is responsible for checking to see if the specified product is ready to be replaced by a succession product by executing a rule in the database. If the rule returns 1, this function will return True, otherwise this function returns False. If this function returns True, it means that the product specified by the Product parameter to this function may not be added and must be succeeded by another product.

public virtual bool CheckSuccessionTriggerRule(
ProductData Product,
ref DateTime& NewStartDate,
ref DateTime& NewEndDate
);

Parameters

Product
NewStartDate
NewEndDate

Return Value

Remarks

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


Config Method

Aptify 5.0 Software Development Kit (SDK)

OrdersEntity.Config Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual void Config(AptifySubTypeBase);

Inherited from AptifyGenericEntity.

public override void Config(AptifySubTypeBase,Int64);

Inherited from AptifyGenericEntityBase.

public virtual void Config(UserCredentials,String);

public override void Config(UserCredentials,String,Int64);

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.Config Method (UserCredentials, String, Int64)

public override void Config(
UserCredentials UserCredentials,
String EntityName,
Int64 RecordID
);

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace | OrdersEntity.Config Overload List


OrdersEntity.CreateBackorders Method

public virtual bool CreateBackorders();

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.CreatePayment Method

protected bool CreatePayment(
PaymentsEntity PaymentGE,
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.DebitMatchesCredit Method

Verify that the sum of the Credit and Debit amounts for the OrderGLEntry records match.

protected virtual bool DebitMatchesCredit();

Return Value

Returns true if the sum of the Credit and Debit amounts match. Otherwise, returns false.

Remarks

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


Delete Method

Aptify 5.0 Software Development Kit (SDK)

OrdersEntity.Delete Method

Verifies that the Order has not be Batched or Shipped before deleting.

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Delete();

Verifies that the Order has not be Batched or Shipped before deleting.

public override bool Delete(String);

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.Delete Method (String)

Verifies that the Order has not be Batched or Shipped before deleting.

public override bool Delete(
String TransactionID
);

Parameters

TransactionID

Return Value

Remarks

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace | OrdersEntity.Delete Overload List


OrdersEntity.DistributeNewSubTypeRecordInfo Method

protected override void DistributeNewSubTypeRecordInfo(
AptifySubTypes SubTypesToProcess,
DataTable dtSubTypeInfo
);

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.DoPrintOrder Method

protected virtual bool DoPrintOrder(
Boolean AllowGUI
);

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.FindInitialPayment Method

Finds Payment record that exactly matches order's initial Payment Information.

protected virtual long FindInitialPayment();

Return Value

Record ID of matching initial Payment record.

Remarks

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.FindPayment Method

protected virtual long FindPayment();

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.FlowdownCCBDepositDate Method

Given a valid Cash Control Batch ID, retrieve the Cash Control Batch's DepositDate and use it to populate the Order's DepositDate. Calls the stored procedure spGetBatchDepositDate, setting the @BatchID parameter to the value in CashControlBatchID. If the stored procedure returns a valid Date, the Order's DepositDate field is set to the value of the first record's first field.

protected virtual void FlowdownCCBDepositDate(
Int64 CashControlBatchID
);

Parameters

CashControlBatchID
ID of a Cash Control Batch record.

Remarks

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


FlowdownCustomerAddresses Method

Aptify 5.0 Software Development Kit (SDK)

OrdersEntity.FlowdownCustomerAddresses Method

Overload List

public virtual bool FlowdownCustomerAddresses(OrdersEntity.AddressFlowDownTypes);

Calls out to the Order Address Flowdown object to update the Order object with information from the Bill To and/or Ship To Persons and Companies.

public virtual bool FlowdownCustomerAddresses(OrdersEntity.AddressFlowDownTypes,Boolean);

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.FlowdownCustomerAddresses Method (AddressFlowDownTypes)

public virtual bool FlowdownCustomerAddresses(
OrdersEntity.AddressFlowDownTypes FlowdownType
);

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace | OrdersEntity.FlowdownCustomerAddresses Overload List


OrdersEntity.FlowdownCustomerAddresses Method (AddressFlowDownTypes, Boolean)

Calls out to the Order Address Flowdown object to update the Order object with information from the Bill To and/or Ship To Persons and Companies.

public virtual bool FlowdownCustomerAddresses(
OrdersEntity.AddressFlowDownTypes FlowdownType,
Boolean BlankCompanyOK
);

Parameters

FlowdownType
BlankCompanyOK
Set to True when only the Company information has changed. This allows a Bill To or Ship To Company to be cleared from the Order without causing the flowdown to reset the Bill To or Ship To Company with the Bill To or Ship To Person's Company.

Return Value

Remarks

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace | OrdersEntity.FlowdownCustomerAddresses Overload List


OrdersEntity.FormatDateTimeForSQL Method

Given a DateTime value, convert it to a string that will be understood by SQL Server regardless of the current regional date settings.

protected virtual string FormatDateTimeForSQL(
DateTime dtValue
);

Parameters

dtValue

Return Value

Remarks

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.GenerateGLEntries Method

protected virtual bool GenerateGLEntries(
Boolean bSubTypesChanged,
Boolean bShowErrors
);

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.GenerateInvoiceNumber Method

Generates the InvoiceNumber value for an Order, if the Orders Entity is configured for generating Invoice Numbers. The Orders Entity Attributes GenerateInvoiceNumber and GenerateInvoiceNumberStoredProcedure control the Invoice Number generation functionality. GenerateInvoiceNumber must be True or a non-zero numeric value and GenerateInvoiceNumberStoredProcedure must specify a stored procedure in the same database as the Orders Entity. If these conditions are not met, the Invoice Number will not be generated and the method will return an empty string. When Invoice Number generation is properly configured, the stored procedure defined in GenerateInvoiceNumberStoredProcedure will be called and the first record's first field value will be returned, if found. If not, an empty string is returned.

protected virtual string GenerateInvoiceNumber();

Return Value

An Invoice Number for the Order or an Empty string.

Remarks

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.GESave Method

protected virtual bool GESave(
Boolean AllowGUI,
Boolean SavePayment,
ref String& ErrorString,
String TransactionID
);

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.GetNewInvoiceNumber Method

public virtual string GetNewInvoiceNumber();

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


GetOrderBalance Method

Aptify 5.0 Software Development Kit (SDK)

OrdersEntity.GetOrderBalance Method

Overload List

public virtual decimal GetOrderBalance();

public virtual decimal GetOrderBalance(Int64);

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.GetOrderBalance Method ()

public virtual decimal GetOrderBalance();

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace | OrdersEntity.GetOrderBalance Overload List


OrdersEntity.GetOrderBalance Method (Int64)

public virtual decimal GetOrderBalance(
Int64 lID
);

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace | OrdersEntity.GetOrderBalance Overload List


GetOrderTotal Method

Aptify 5.0 Software Development Kit (SDK)

OrdersEntity.GetOrderTotal Method

Overload List

public virtual decimal GetOrderTotal();

public virtual decimal GetOrderTotal(Int64);

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.GetOrderTotal Method ()

public virtual decimal GetOrderTotal();

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace | OrdersEntity.GetOrderTotal Overload List


OrdersEntity.GetOrderTotal Method (Int64)

public virtual decimal GetOrderTotal(
Int64 OrderID
);

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace | OrdersEntity.GetOrderTotal Overload List


OrdersEntity.GetPersonCompanyID Method

NOTE: This method is now obsolete.

Method has been replaced with GetPersonCompanyIDAndName

protected virtual long GetPersonCompanyID(
Int64 lPersonID
);

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.GetPersonCompanyIDAndName Method

Returns the Company ID and Name for a given Person ID. Uses the stored procedure, spGetCompanyIDAndNameForPerson.

protected virtual IDandName GetPersonCompanyIDAndName(
Int64 lPersonID
);

Parameters

lPersonID

Return Value

Remarks

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


GetPotentialCancellationOrderLines Method

Aptify 5.0 Software Development Kit (SDK)

OrdersEntity.GetPotentialCancellationOrderLines Method

Overload List

public virtual List<T> GetPotentialCancellationOrderLines(Int64);

public virtual List<T> GetPotentialCancellationOrderLines(Int64,Decimal);

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.GetPotentialCancellationOrderLines Method (Int64)

public virtual List<T> GetPotentialCancellationOrderLines(
Int64 ProductID
);

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace | OrdersEntity.GetPotentialCancellationOrderLines Overload List


OrdersEntity.GetPotentialCancellationOrderLines Method (Int64, Decimal)

public virtual List<T> GetPotentialCancellationOrderLines(
Int64 ProductID,
Decimal CancellationQuantity
);

Parameters

ProductID
CancellationQuantity

Return Value

Remarks

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace | OrdersEntity.GetPotentialCancellationOrderLines Overload List


OrdersEntity.GetSubscriberCompanyID Method

This method is responsible for returning the ID of the Company this is used to populate the Subscription's SubscriberCompanyID. The SubscriberCompanyID indicates the Company that is both the Subscriber and Recipient for a Subscription. There is an Entity Attribute on the Subscriptions Entity, SubscriberCompanyBehavior, that affects the behavior in this method. If the Entity Attribute does not exist or has a value of Order, the Order's ShipToCompanyID will be returned, if the Order's ShipToCompanyID is greater than 0. If the Order's ShipToCompanyID is less than or equal to 0 or the SubscriberCompanyBehavior Attribute value is Person, call the GetPersonCompanyID method to retrieve the CompanyID based on the PersonID parameter value.

protected virtual long GetSubscriberCompanyID(
OrderLinesEntity OrderLineGE,
Int64 PersonID
);

Parameters

OrderLineGE
OrderLines Entity object for the Order Line being processed.
PersonID
ID of the Person representing the Subscription's Recipient

Return Value

ID of the Subscriber (and Recipient) Company for a Company-based Subscription

Remarks

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.GetSubscriptionIDAndStartDate Method

This method returns the Subscription ID of an existing subscription record in the database for the specified Product ID, Person ID and Company ID combination. For individual subscriptions, pass leave the CompanyID at its default value of -1. For Company subscriptions, provide both PersonID and CompanyID. If no existing subscription is found, -1 is returned.

public virtual long GetSubscriptionIDAndStartDate(
Int64 ProductID,
Int64 SubscriberID,
Int64 SubscriberCompanyID,
Int64 ChapterID,
Boolean CheckCompanyAndPersonSubscriptions,
ref DateTime& StartDate,
ref DateTime& EndDate
);

Parameters

ProductID
SubscriberID
ID of the Person Record
SubscriberCompanyID
ID of the Company Record
ChapterID
CheckCompanyAndPersonSubscriptions
StartDate
EndDate

Return Value

Remarks

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.GetSuccessionProductByRule Method

This method is responsible for executing the succession product rule associated with the specified product for the given order. This rule is called only when a product is determined to be in line for a successor product

public virtual long GetSuccessionProductByRule(
ProductData Product,
DateTime NewStartDate,
DateTime NewEndDate
);

Parameters

Product
NewStartDate
NewEndDate

Return Value

Remarks

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.GetSuccessionProductDates Method

This method is responsible for determining the start date to use for a successor product when a successor product is going to replace a previously selected product.

protected virtual bool GetSuccessionProductDates(
ProductData Product,
ref DateTime& StartDate,
ref DateTime& EndDate,
ref DateTime& OriginalStartDate,
ref DateTime& CurrentEndDate
);

Return Value

Remarks

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.GetSuccessorProductID Method

This method is responsible for determining the successor product ID to use for the Product specified in the Product parameter.

public virtual long GetSuccessorProductID(
ProductData Product,
DateTime NewStartDate,
DateTime NewEndDate
);

Parameters

Product
NewStartDate
NewEndDate

Return Value

Remarks

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


GetValue Method

Aptify 5.0 Software Development Kit (SDK)

OrdersEntity.GetValue Method

Uses the Generic Entity's GetValue functionality except when a field that begins with BillTo and the BillToSameAsShipTo flag is true. In those cases, the BillTo* fields will return the corresponding ShipTo* field value. The exception to this is the BillToSameAsShipTo field, which does not have a corresponding ShipTo field.

Overload List

Inherited from AptifyGenericEntityBase.

public virtual object GetValue(String);

Uses the Generic Entity's GetValue functionality except when a field that begins with BillTo and the BillToSameAsShipTo flag is true. In those cases, the BillTo* fields will return the corresponding ShipTo* field value. The exception to this is the BillToSameAsShipTo field, which does not have a corresponding ShipTo field.

public override object GetValue(String,Boolean);

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.GetValue Method (String, Boolean)

Uses the Generic Entity's GetValue functionality except when a field that begins with BillTo and the BillToSameAsShipTo flag is true. In those cases, the BillTo* fields will return the corresponding ShipTo* field value. The exception to this is the BillToSameAsShipTo field, which does not have a corresponding ShipTo field.

public override object GetValue(
String FieldName,
Boolean ForceRefresh
);

Parameters

FieldName
ForceRefresh

Return Value

Remarks

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace | OrdersEntity.GetValue Overload List


OrdersEntity.InitializeInternalVariables Method

Initializes the protected variables to match the field values of the current Order. For new records: the EmployeeID will be set to the currently logged in User's Employee ID and the InvoiceNumber will be generated (if configured). The Order's Organization can also be populated with the call to InitializeOrganizationID.

protected virtual void InitializeInternalVariables(
Boolean NewRecord
);

Parameters

NewRecord
When true, variables will be initialized for a new record. When false, variables will be initialized for an existing record.

Remarks

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.InitializeOrderAddressFieldVariables Method

protected virtual void InitializeOrderAddressFieldVariables(
OrdersEntity.AddressFlowDownTypes FlowdownType
);

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.InitializeOrganizationID Method

Used to set the Order's OrganizationID for a new Order. The core implementation uses the Taken By Employee's OrganizationID. Called by InitializeInternalVariables method for new Orders.

protected virtual void InitializeOrganizationID();

Remarks

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


Load Method

Aptify 5.0 Software Development Kit (SDK)

OrdersEntity.Load Method

Overload List

public override void Load(DataRow);

public override void Load(IDataReader);

public override void Load(Int64);

public override void Load(String);

Inherited from AptifyGenericEntity.

public override void Load(String,Boolean);

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.Load Method (DataRow)

public override void Load(
DataRow DataRow
);

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace | OrdersEntity.Load Overload List


OrdersEntity.Load Method (IDataReader)

public override void Load(
IDataReader DataReader
);

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace | OrdersEntity.Load Overload List


OrdersEntity.Load Method (Int64)

public override void Load(
Int64 ID
);

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace | OrdersEntity.Load Overload List


OrdersEntity.Load Method (String)

public override void Load(
String FileName
);

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace | OrdersEntity.Load Overload List


OrdersEntity.NewRecord Method

public override bool NewRecord();

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.OKToModifyBatchedOrder Method

protected virtual bool OKToModifyBatchedOrder();

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.OKToModifyOrder Method

Calls protected methods OKToModifyBatchedOrder and OKToModifyShippedOrder, where appropriate.

public virtual bool OKToModifyOrder();

Return Value

Returns True, if it is OK to modify the Order with the current changes. Returns False, if the current changes are not permitted based on the current state of the Order.

Remarks

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.OKToModifyShippedOrder Method

protected virtual bool OKToModifyShippedOrder();

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.OkToRecalcTotals Method

Is it OK to recalculate the Order Totals? Core implementation returns True if the Order hasn't already been shipped. Called by CalculateOrderTotals method.

protected virtual bool OkToRecalcTotals();

Return Value

True if the Order Totals should be recalculated. If not, returns False.

Remarks

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.OnBeforeUpgradeProductToLatestVersion Method

protected void OnBeforeUpgradeProductToLatestVersion(
OrdersEntity sender,
BeforeUpgradeProductToLatestVersionEventArgs e
);

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.OnCheckInventoryOnOrderLineFailed Method

protected void OnCheckInventoryOnOrderLineFailed(
OrdersEntity sender,
CheckInventoryOnOrderLineFailedEventArgs e
);

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.OrderAddressFields_AfterValueChanged Method

protected virtual void OrderAddressFields_AfterValueChanged(
AptifyDataFieldBase sender,
AfterValueChangedEventArgs e
);

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.OrdersFields_AfterValueChanged Method

protected virtual void OrdersFields_AfterValueChanged(
AptifyDataFieldBase sender,
AfterValueChangedEventArgs e
);

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.PromptForAdditionalPayment Method

protected virtual AdditionalPaymentPromptResult PromptForAdditionalPayment();

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.RemoveOrderLine Method

Removes an Order Line from the Order. Handles Kit Products as well by removing the Kit Parts. If the Orders Entity Attribute, RecalculateOrderLinesAfterRemove, exists and have a value of 1, the remaining Order Lines' prices will be recaculated after the remove.

public virtual bool RemoveOrderLine(
OrderLinesEntity OrderLineGE
);

Parameters

OrderLineGE

Return Value

Remarks

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


Save Method

Aptify 5.0 Software Development Kit (SDK)

OrdersEntity.Save Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Save();

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean,ref String&);

public override bool Save(Boolean,ref String&,String);

public bool Save(Boolean,ref String&,String,Boolean);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(ref String&);

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.Save Method (Boolean, String&, String)

public override bool Save(
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace | OrdersEntity.Save Overload List


OrdersEntity.Save Method (Boolean, String&, String, Boolean)

public bool Save(
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID,
Boolean SavePayment
);

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace | OrdersEntity.Save Overload List


OrdersEntity.SaveCancellationData Method

protected virtual bool SaveCancellationData(
Boolean AllowGUI
);

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.SaveCancellationSubscriptions Method

protected bool SaveCancellationSubscriptions(
Boolean AllowGUI
);

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.SaveCheckInventory Method

Called from the Save method when the Order is being shipped.

protected virtual bool SaveCheckInventory(
Boolean AllowGUI
);

Parameters

AllowGUI

Return Value

True on success. Otherwise, returns False.

Remarks

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.SaveCreateOrderCurrencySpotRates Method

If the System's functional currency differs from the functional currency of the order, then the spot rate will be recorded because a foreign currency gain or loss may need to be recorded at a later point. Called from the Save method when the Order is being shipped.

protected virtual bool SaveCreateOrderCurrencySpotRates();

Return Value

True on success. Otherwise, returns False.

Remarks

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.SaveDateChanges Method

protected bool SaveDateChanges(
Boolean AllowGUI
);

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.SaveGLEntries Method

protected bool SaveGLEntries(
Boolean SubTypesChanged,
Boolean AllowGUI
);

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.SavePayments Method

protected virtual bool SavePayments(
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.SavePermitChanges Method

Additional validation in the Save method. If AllowGUI is true, any failure will be displayed to the user in a message box. This function checks to make sure order isn't batched or shipped, and if it is checks appropriate fields to see whether changes can be saved.

protected bool SavePermitChanges(
Boolean AllowGUI
);

Parameters

AllowGUI
When True, the method can display user interface if the Order can not be saved. When False, the error is logged.

Return Value

Remarks

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.SaveProcessSubscriptions Method

protected virtual bool SaveProcessSubscriptions(
Boolean AllowGUI
);

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.SaveRevRecognitionScheduledTransactions Method

Creates the scheduled transaction groups needed to move funds from the deferred income account to the sales account on the revenue recognition date. Processes each Order Line and determines which are impacted by revenue recognition date. Creates a scheduled transaction group record for each impacted Order Line.

protected virtual void SaveRevRecognitionScheduledTransactions();

Remarks

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.SaveScheduledTransactionGroups Method

Creates scheduled transaction group records. A scheduled transaction group is created for each order line for a product requiring deferred income. During the batching process, each scheduled transaction group record is expanded to each of the individual scheduled transactions using the data in the record.

protected virtual void SaveScheduledTransactionGroups(
String TransactionID
);

Remarks

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.SaveSetDepositDate Method

protected virtual void SaveSetDepositDate();

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.SaveSubscriptions Method

protected bool SaveSubscriptions(
Boolean AllowGUI
);

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.SetBillingAddress Method

public virtual void SetBillingAddress(
AddressInfo AddressInfo
);

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.SetCustomerData Method

Method utilized by the order UI to configure various customer data based on a number of rules.

public virtual void SetCustomerData(
Int64 ShipToID,
Int64 ShipToCompanyID,
Int64 BillToID,
Int64 BillToCompanyID
);

Parameters

ShipToID
ShipToCompanyID
BillToID
BillToCompanyID

Remarks

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.SetIsShipping Method

protected virtual void SetIsShipping(
Boolean IsShipping
);

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.SetShippingAddress Method

public virtual void SetShippingAddress(
AddressInfo AddressInfo
);

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


ShipAvailableLines Method

Aptify 5.0 Software Development Kit (SDK)

OrdersEntity.ShipAvailableLines Method

Overload List

public virtual bool ShipAvailableLines(Boolean);

public virtual bool ShipAvailableLines(Boolean,Boolean);

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.ShipAvailableLines Method (Boolean)

public virtual bool ShipAvailableLines(
Boolean ExcludeFulfillmentItems
);

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace | OrdersEntity.ShipAvailableLines Overload List


OrdersEntity.ShipAvailableLines Method (Boolean, Boolean)

public virtual bool ShipAvailableLines(
Boolean ExcludeFulfillmentItems,
Boolean AllowGUI
);

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace | OrdersEntity.ShipAvailableLines Overload List


ShipEntireOrder Method

Aptify 5.0 Software Development Kit (SDK)

OrdersEntity.ShipEntireOrder Method

Overload List

public virtual bool ShipEntireOrder();

public virtual bool ShipEntireOrder(Boolean);

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.ShipEntireOrder Method ()

public virtual bool ShipEntireOrder();

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace | OrdersEntity.ShipEntireOrder Overload List


OrdersEntity.ShipEntireOrder Method (Boolean)

public virtual bool ShipEntireOrder(
Boolean AllowGUI
);

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace | OrdersEntity.ShipEntireOrder Overload List


OrdersEntity.ShipPartialOrder Method

This method is used by the Backorders process when the BackOrderARFlag is OriginalOrder(0). With this setting, the Original

public virtual bool ShipPartialOrder(
Boolean AllowGUI
);

Parameters

AllowGUI

Return Value

Remarks

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.ShouldUseSuccessorProduct Method

This method is only relevant for Subscription products. This method is responsible for determining if a successor product should be used for a given selected product. If the rules for this particular product require a successor product be automatically used whenever certain successor conditions are met, the order entry system will automatically swap the selected product with its successor product.

public virtual long ShouldUseSuccessorProduct(
Int64 ProductID,
ref DateTime& NewStartDate,
ref DateTime& NewEndDate
);

Parameters

ProductID
NewStartDate
This parameter returns the NEW start date that should be used for a new subscription for a successor product subscription. This parameter is only used when the function returns a value > 0
NewEndDate

Return Value

If a successor product is found for the ProductID parameter its Product ID value is returned, otherwise -1 is returned

Remarks

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


ShowMessageBox Method

Aptify 5.0 Software Development Kit (SDK)

OrdersEntity.ShowMessageBox Method

Overload List

protected virtual void ShowMessageBox(String,String);

protected virtual void ShowMessageBox(String,String,String);

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.ShowMessageBox Method (String, String)

protected virtual void ShowMessageBox(
String sMessage,
String sMoreMessage
);

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace | OrdersEntity.ShowMessageBox Overload List


OrdersEntity.ShowMessageBox Method (String, String, String)

protected virtual void ShowMessageBox(
String sMessage,
String sMoreMessage,
String sTitle
);

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace | OrdersEntity.ShowMessageBox Overload List


OrdersEntity.UpdateInventory Method

protected bool UpdateInventory(
Boolean bShowErrors
);

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.UpdatePayment Method

protected virtual bool UpdatePayment(
PaymentsEntity PaymentGE,
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.UpdatePaymentObject Method

protected virtual bool UpdatePaymentObject(
PaymentsEntity oPayment,
Int32 iLine,
String TransactionID
);

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


Validate Method

Aptify 5.0 Software Development Kit (SDK)

OrdersEntity.Validate Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Validate();

public override bool Validate(ref String&);

public virtual bool Validate(ref String&,Boolean);

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.Validate Method (String&)

public override bool Validate(
ref String& ErrorString
);

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace | OrdersEntity.Validate Overload List


OrdersEntity.Validate Method (String&, Boolean)

public virtual bool Validate(
ref String& ErrorString,
Boolean SavePayment
);

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace | OrdersEntity.Validate Overload List


OrdersEntity.ValidateCancellationCreditCard Method

This function is called to validate the credit card that is being used to cancel an Order.

protected virtual bool ValidateCancellationCreditCard();

Return Value

Remarks

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.ValidateCancellationOrder Method

Called by the Validate routine when the Order is a Cancellation Order. (OrderTypeID=3) Validates that the Order's OriginalOrderID has been set, that the Quantity returned doesn't exceed the Quantity Shipped on the Original Order and that the returned products were on the Original Order. Note that this method assumes that the Order is a Cancellation Order.

protected virtual bool ValidateCancellationOrder(
ref String& ErrorString
);

Parameters

ErrorString
When the method returns false, this parameter will be populated with information about the failure.

Return Value

True if the Quotation Order is valid. Otherwise, returns false.

Remarks

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.ValidateCancellationQuantity Method

Validate that the quantity returned does not exceed the Original Order's quantity shipped. Called by the ValidateCancellationOrder method.

protected virtual bool ValidateCancellationQuantity(
ref String& ErrorString
);

Parameters

ErrorString

Return Value

True if the quantities being returned are valid. Otherwise, returns false.

Remarks

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.ValidateCheckCredit Method

protected virtual bool ValidateCheckCredit(
ref String& ErrorString
);

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.ValidateCreditMemoOwnership Method

Responsible for determining whether or not the Credit Memo can be used as a Payment for the current based on the ownership of the Credit Memo. Called within the default implementation of ValidatePaymentInformation. Default implementation calls Aptify.Applications.OrderEntry.Payments.PaymentsEntity.ValidateCreditMemoOwnershipShared

protected virtual bool ValidateCreditMemoOwnership(
ref String& sError
);

Parameters

sError

Return Value

Remarks

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.ValidateExistingPayment Method

protected virtual bool ValidateExistingPayment(
ref String& ErrorString
);

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.ValidateOrderLines Method

Validates information related to the OrderLines Sub-Type. Called by the Validate method Validation Rules: 1. An Order must have at least one Order Line. 2. Cancellation Order Lines must have a quantity less than 0. 3. Regular Order Lines must have a quantity greater than or equal to 0. A quantity of 0 is valid for items being backordered.

protected virtual bool ValidateOrderLines(
ref String& ErrorString
);

Parameters

ErrorString

Return Value

Remarks

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.ValidatePaymentInformation Method

Validate that the Payment information and Credit Check is valid. Called by the Validate method when a Payment is being saved by the Order.

protected virtual bool ValidatePaymentInformation(
ref String& ErrorString
);

Parameters

ErrorString

Return Value

True if the Payment information is valid. Otherwise, returns false.

Remarks

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.ValidateQuotationOrder Method

Called by the Validate routine when the Order is a Quotation Order. (OrderTypeID=4) Validates that the Order's Status is Taken (1) or Cancelled (4). Note that this method assumes that the Order is a Quotation.

protected virtual bool ValidateQuotationOrder(
ref String& ErrorString
);

Parameters

ErrorString
When the method returns false, this parameter will be populated with information about the failure.

Return Value

True if the Quotation Order is valid. Otherwise, returns false.

Remarks

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.ValidateRefund Method

protected virtual bool ValidateRefund(
PaymentsEntity.BasePaymentTypes BasePaymentType,
ref String& ErrorString
);

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.ValidateShipToLocation Method

Validate the Order's Ship To Location, if the Orders Entity is configured to validate the Ship To location. The Orders Entity Attribute ValidateShipToLocation controls the configuration. ValidateShipToLocation must be True or a non-zero numeric value in order to turn on Ship To Location validation. Based on the Ship To information, determine whether or not it is valid for the current Order. The current implementation passes the Order's ShipToCountry to the stored procedure, spIsARestrictedCountry. If the ShipToCountry matches an entry in the Restricted Countries list, the Ship To information is not valid.

protected virtual bool ValidateShipToLocation(
ref String& ErrorString
);

Parameters

ErrorString
When the method returns False, the FailureMessage is populated with a message indicating the failure. This message will be appended to the Validation Error String.

Return Value

Returns True if it is valid to Ship the Order based on the current Ship To information. Otherwise, returns False. Returning False will prevent the Order from saving until the problem is corrected.

Remarks

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity Events

The events of the OrdersEntity class are listed below. For a complete list of OrdersEntity class members, see the OrdersEntity Members topic.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeUpgradeProductToLatestVersion |
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
CheckInventoryOnOrderLineFailed |
ProcessTerminated |
StatusUpdate |
TotalsUpdated |
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.OrdersEntity.BeforeUpgradeProductToLatestVersionEventHandler Event

public event OrdersEntity.BeforeUpgradeProductToLatestVersionEventHandler BeforeUpgradeProductToLatestVersion;

Event Data

The event handler receives an argument of type BeforeUpgradeProductToLatestVersionEventArgs containing data related to this event. The following BeforeUpgradeProductToLatestVersionEventArgs properties provide information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.
NewVersionProductID |
NewVersionProductName |
OriginalProductID |
OriginalProductName |
UserCredential |

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.OrdersEntity.CheckInventoryOnOrderLineFailedEventHandler Event

public event OrdersEntity.CheckInventoryOnOrderLineFailedEventHandler CheckInventoryOnOrderLineFailed;

Event Data

The event handler receives an argument of type CheckInventoryOnOrderLineFailedEventArgs containing data related to this event. The following CheckInventoryOnOrderLineFailedEventArgs properties provide information specific to this event.

Property | Description
InventoryStatus |
Message |
OrderLineGE |

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.OrdersEntity.ProcessTerminatedEventHandler Event

public event OrdersEntity.ProcessTerminatedEventHandler ProcessTerminated;

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.OrdersEntity.StatusUpdateEventHandler Event

public event OrdersEntity.StatusUpdateEventHandler StatusUpdate;

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.OrdersEntity.TotalsUpdatedEventHandler Event

public event OrdersEntity.TotalsUpdatedEventHandler TotalsUpdated;

See Also

OrdersEntity Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.AdditionalPaymentPromptResult Enumeration

protected enum OrdersEntity.AdditionalPaymentPromptResult

Members

Member Name | Description
Success |
Failure |
LeaveBalance |

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

Aptify.Applications.OrderEntry Namespace


OrdersEntity.AddressFlowDownTypes Enumeration

public enum OrdersEntity.AddressFlowDownTypes

Members

Member Name | Description
BillToAddress |
ShipToAddress |
Both |

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

Aptify.Applications.OrderEntry Namespace


OrdersEntity.AutoShipmentSetting Enumeration

protected enum OrdersEntity.AutoShipmentSetting

Members

Member Name | Description
Unspecified |
Disabled |
EnabledWithConfirmation |
EnabledNoConfirmation |

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

Aptify.Applications.OrderEntry Namespace


OrdersEntity.AutoShippingAvailabilityTypes Enumeration

public enum OrdersEntity.AutoShippingAvailabilityTypes

Members

Member Name | Description
FullOrder |
PartialOrder |
NotAvailable |

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

Aptify.Applications.OrderEntry Namespace


OrdersEntity.BackOrderARTypes Enumeration

public enum OrdersEntity.BackOrderARTypes

Members

Member Name | Description
OriginalOrder |
BackOrders |
Payment |
UnSet |
BadValue |

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

Aptify.Applications.OrderEntry Namespace


OrdersEntity.BeforeUpgradeProductToLatestVersionEventHandler Delegate

public delegate void OrdersEntity.BeforeUpgradeProductToLatestVersionEventHandler(
OrdersEntity sender,
BeforeUpgradeProductToLatestVersionEventArgs e
);

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

Aptify.Applications.OrderEntry Namespace


OrdersEntity.CheckInventoryOnOrderLineFailedEventHandler Delegate

public delegate void OrdersEntity.CheckInventoryOnOrderLineFailedEventHandler(
OrdersEntity sender,
CheckInventoryOnOrderLineFailedEventArgs e
);

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

Aptify.Applications.OrderEntry Namespace


OrdersEntity.IDandName Structure

A structure that is used for ID and Name.

For a list of all members of this type, see OrdersEntity.IDandName Members.

System.Object
ValueType
OrdersEntity.IDandName

public struct OrdersEntity.IDandName

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

OrdersEntity.IDandName Members | Aptify.Applications.OrderEntry Namespace


OrdersEntity.IDandName Members

OrdersEntity.IDandName overview

Public Instance Fields

ID
Name

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

OrdersEntity.IDandName Structure | Aptify.Applications.OrderEntry Namespace


OrdersEntity.IDandName Fields

The fields of the OrdersEntity.IDandName structure are listed below. For a complete list of OrdersEntity.IDandName structure members, see the OrdersEntity.IDandName Members topic.

Public Instance Fields

ID
Name

See Also

OrdersEntity.IDandName Structure | Aptify.Applications.OrderEntry Namespace


OrdersEntity.IDandName.ID Field

public ID ID;

See Also

OrdersEntity.IDandName Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.IDandName.Name Field

public Name Name;

See Also

OrdersEntity.IDandName Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.NoSuccessorProductException Class

This exception is thrown whenever a product reaches its maximum renewal cycle and has no successor product defined for it

For a list of all members of this type, see OrdersEntity.NoSuccessorProductException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
OrdersEntity.NoSuccessorProductException

public class OrdersEntity.NoSuccessorProductException : BaseApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

OrdersEntity.NoSuccessorProductException Members | Aptify.Applications.OrderEntry Namespace


OrdersEntity.NoSuccessorProductException Members

OrdersEntity.NoSuccessorProductException overview

Public Instance Constructors

OrdersEntity.NoSuccessorProductException Constructor

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from BaseApplicationException) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

OrdersEntity.NoSuccessorProductException Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.NoSuccessorProductException Constructor

public OrdersEntity.NoSuccessorProductException(
String Message
);

See Also

OrdersEntity.NoSuccessorProductException Class | Aptify.Applications.OrderEntry Namespace


OrdersEntity.ProcessTerminatedEventHandler Delegate

public delegate void OrdersEntity.ProcessTerminatedEventHandler(
Boolean WasSuccessful
);

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

Aptify.Applications.OrderEntry Namespace


OrdersEntity.StatusUpdateEventHandler Delegate

public delegate void OrdersEntity.StatusUpdateEventHandler(
String Message,
Int32 Progess
);

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

Aptify.Applications.OrderEntry Namespace


OrdersEntity.TotalsUpdatedEventHandler Delegate

public delegate void OrdersEntity.TotalsUpdatedEventHandler();

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

Aptify.Applications.OrderEntry Namespace


OrdersExtension Class

For a list of all members of this type, see OrdersExtension Members.

System.Object
OrdersExtension

public class OrdersExtension : IAptifyViewExtension

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersExtension (in AptifyOrdersExtension.dll)

See Also

OrdersExtension Members | Aptify.Applications.OrderEntry Namespace


OrdersExtension Members

OrdersExtension overview

Public Instance Constructors

OrdersExtension Constructor Initializes a new instance of the OrdersExtension class.

Public Instance Properties

Application
ExtensionMenuItem
ViewPlugIn

Public Instance Methods

Attach |
Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

AfterAttach
AfterConfig
AfterExecute
BeforeAttach
BeforeConfig
BeforeExecute

Protected Instance Methods

CreateBackOrder | Creates a Back Order for a single order.
CreateOrderBatch | Creates an order batch.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ShipOrders | Ships selected orders that have not already been shipped.

See Also

OrdersExtension Class | Aptify.Applications.OrderEntry Namespace


OrdersExtension Constructor

Initializes a new instance of the OrdersExtension class.

public OrdersExtension();

See Also

OrdersExtension Class | Aptify.Applications.OrderEntry Namespace


OrdersExtension Properties

The properties of the OrdersExtension class are listed below. For a complete list of OrdersExtension class members, see the OrdersExtension Members topic.

Public Instance Properties

Application
ExtensionMenuItem
ViewPlugIn

See Also

OrdersExtension Class | Aptify.Applications.OrderEntry Namespace


Application Property

Aptify 5.0 Software Development Kit (SDK)

OrdersExtension.Application Property

public AptifyApplication Application {get;}

Implements

IAptifyViewExtension.

See Also

OrdersExtension Class | Aptify.Applications.OrderEntry Namespace


ExtensionMenuItem Property

Aptify 5.0 Software Development Kit (SDK)

OrdersExtension.ExtensionMenuItem Property

public MenuItem ExtensionMenuItem {get;}

Implements

IAptifyViewExtension.

See Also

OrdersExtension Class | Aptify.Applications.OrderEntry Namespace


ViewPlugIn Property

Aptify 5.0 Software Development Kit (SDK)

OrdersExtension.ViewPlugIn Property

public IAptifyViewPlugIn ViewPlugIn {get;}

Implements

IAptifyViewExtension.

See Also

OrdersExtension Class | Aptify.Applications.OrderEntry Namespace


OrdersExtension Methods

The methods of the OrdersExtension class are listed below. For a complete list of OrdersExtension class members, see the OrdersExtension Members topic.

Public Instance Methods

Attach |
Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CreateBackOrder | Creates a Back Order for a single order.
CreateOrderBatch | Creates an order batch.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ShipOrders | Ships selected orders that have not already been shipped.

See Also

OrdersExtension Class | Aptify.Applications.OrderEntry Namespace


OrdersExtension.Attach Method

public void Attach(
MenuItem ExtensionMenuItem
);

Implements

IAptifyViewExtension.

See Also

OrdersExtension Class | Aptify.Applications.OrderEntry Namespace


OrdersExtension.Config Method

public void Config(
AptifyApplication Application,
IAptifyViewPlugIn ViewPlugIn
);

Implements

IAptifyViewExtension.

See Also

OrdersExtension Class | Aptify.Applications.OrderEntry Namespace


OrdersExtension.CreateBackOrder Method

Creates a Back Order for a single order.

protected virtual void CreateBackOrder();

Remarks

See Also

OrdersExtension Class | Aptify.Applications.OrderEntry Namespace


OrdersExtension.CreateOrderBatch Method

Creates an order batch.

protected virtual void CreateOrderBatch();

Remarks

See Also

OrdersExtension Class | Aptify.Applications.OrderEntry Namespace


OrdersExtension.Execute Method

public void Execute(
MenuItem FunctionMenuItem
);

Implements

IAptifyViewExtension.

See Also

OrdersExtension Class | Aptify.Applications.OrderEntry Namespace


OrdersExtension.ShipOrders Method

Ships selected orders that have not already been shipped.

protected virtual void ShipOrders();

Remarks

See Also

OrdersExtension Class | Aptify.Applications.OrderEntry Namespace


OrdersExtension Events

The events of the OrdersExtension class are listed below. For a complete list of OrdersExtension class members, see the OrdersExtension Members topic.

Public Instance Events

AfterAttach
AfterConfig
AfterExecute
BeforeAttach
BeforeConfig
BeforeExecute

See Also

OrdersExtension Class | Aptify.Applications.OrderEntry Namespace


OrdersExtension.IAptifyViewExtension.AfterAttachEventHandler Event

public event IAptifyViewExtension.AfterAttachEventHandler AfterAttach;

Implements

IAptifyViewExtension.

See Also

OrdersExtension Class | Aptify.Applications.OrderEntry Namespace


OrdersExtension.IAptifyViewExtension.AfterConfigEventHandler Event

public event IAptifyViewExtension.AfterConfigEventHandler AfterConfig;

Implements

IAptifyViewExtension.

See Also

OrdersExtension Class | Aptify.Applications.OrderEntry Namespace


OrdersExtension.IAptifyViewExtension.AfterExecuteEventHandler Event

public event IAptifyViewExtension.AfterExecuteEventHandler AfterExecute;

Implements

IAptifyViewExtension.

See Also

OrdersExtension Class | Aptify.Applications.OrderEntry Namespace


OrdersExtension.IAptifyViewExtension.BeforeAttachEventHandler Event

public event IAptifyViewExtension.BeforeAttachEventHandler BeforeAttach;

Implements

IAptifyViewExtension.

See Also

OrdersExtension Class | Aptify.Applications.OrderEntry Namespace


OrdersExtension.IAptifyViewExtension.BeforeConfigEventHandler Event

public event IAptifyViewExtension.BeforeConfigEventHandler BeforeConfig;

Implements

IAptifyViewExtension.

See Also

OrdersExtension Class | Aptify.Applications.OrderEntry Namespace


OrdersExtension.IAptifyViewExtension.BeforeExecuteEventHandler Event

public event IAptifyViewExtension.BeforeExecuteEventHandler BeforeExecute;

Implements

IAptifyViewExtension.

See Also

OrdersExtension Class | Aptify.Applications.OrderEntry Namespace


OrderShipmentsEntity Class

For a list of all members of this type, see OrderShipmentsEntity Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
OrderShipmentsClass
OrderShipmentsEntity

public class OrderShipmentsEntity : OrderShipmentsClass

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

OrderShipmentsEntity Members | Aptify.Applications.OrderEntry Namespace


OrderShipmentsEntity Members

OrderShipmentsEntity overview

Public Instance Constructors

OrderShipmentsEntity Constructor Initializes a new instance of the OrderShipmentsEntity class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
CustShippingAcctNum (inherited from OrderShipmentsClass) |
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
HandlingCharge (inherited from OrderShipmentsClass) |
ID (inherited from OrderShipmentsClass) |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
OrderID (inherited from OrderShipmentsClass) |
OverrideHandlingCalc (inherited from OrderShipmentsClass) |
OverrideShippingCalc (inherited from OrderShipmentsClass) |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentOrdersEntity | Takes the OrderLine's ParentGE property value and casts it to an OrdersEntity object
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Sequence (inherited from OrderShipmentsClass) |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
ShipmentTypeGrouping (inherited from OrderShipmentsClass) |
ShipmentTypeGroupingID (inherited from OrderShipmentsClass) |
ShipmentTypeMatrix (inherited from OrderShipmentsClass) |
ShipmentTypeMatrixID (inherited from OrderShipmentsClass) |
ShippingCharge (inherited from OrderShipmentsClass) |
ShippingCost (inherited from OrderShipmentsClass) |
ShipTo (inherited from OrderShipmentsClass) |
ShipToAddressID (inherited from OrderShipmentsClass) |
ShipToAddressIDObject (inherited from OrderShipmentsClass) |
ShipToID (inherited from OrderShipmentsClass) |
ShipTrackingNum (inherited from OrderShipmentsClass) |
ShipType (inherited from OrderShipmentsClass) |
ShipTypeID (inherited from OrderShipmentsClass) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
TaxIncludedInCharges (inherited from OrderShipmentsClass) |
TaxJurisdiction (inherited from OrderShipmentsClass) |
TaxJurisdictionID (inherited from OrderShipmentsClass) |
TotalQuantity |
TotalWeight | Overloaded.
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.
WeightUnits (inherited from OrderShipmentsClass) |

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config | Overloaded.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
OrderShipmentTaxes (inherited from OrderShipmentsClass) |
OrderShipmentTaxesObject (inherited from OrderShipmentsClass) |
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded. Before the Sub-Type record is saved, the ShipToAddressID must be synchronized with the ShipToAddressID of a matching Order Ship To Address or an Order Line Ship To Address.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AddFieldValueChangedEventHandlers |
AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
OrderShipmentsFields_AfterValueChanged |
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

OrderShipmentsEntity Class | Aptify.Applications.OrderEntry Namespace


OrderShipmentsEntity Constructor

Initializes a new instance of the OrderShipmentsEntity class.

public OrderShipmentsEntity();

See Also

OrderShipmentsEntity Class | Aptify.Applications.OrderEntry Namespace


OrderShipmentsEntity Properties

The properties of the OrderShipmentsEntity class are listed below. For a complete list of OrderShipmentsEntity class members, see the OrderShipmentsEntity Members topic.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
CustShippingAcctNum (inherited from OrderShipmentsClass) |
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
HandlingCharge (inherited from OrderShipmentsClass) |
ID (inherited from OrderShipmentsClass) |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
OrderID (inherited from OrderShipmentsClass) |
OverrideHandlingCalc (inherited from OrderShipmentsClass) |
OverrideShippingCalc (inherited from OrderShipmentsClass) |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentOrdersEntity | Takes the OrderLine's ParentGE property value and casts it to an OrdersEntity object
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Sequence (inherited from OrderShipmentsClass) |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
ShipmentTypeGrouping (inherited from OrderShipmentsClass) |
ShipmentTypeGroupingID (inherited from OrderShipmentsClass) |
ShipmentTypeMatrix (inherited from OrderShipmentsClass) |
ShipmentTypeMatrixID (inherited from OrderShipmentsClass) |
ShippingCharge (inherited from OrderShipmentsClass) |
ShippingCost (inherited from OrderShipmentsClass) |
ShipTo (inherited from OrderShipmentsClass) |
ShipToAddressID (inherited from OrderShipmentsClass) |
ShipToAddressIDObject (inherited from OrderShipmentsClass) |
ShipToID (inherited from OrderShipmentsClass) |
ShipTrackingNum (inherited from OrderShipmentsClass) |
ShipType (inherited from OrderShipmentsClass) |
ShipTypeID (inherited from OrderShipmentsClass) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
TaxIncludedInCharges (inherited from OrderShipmentsClass) |
TaxJurisdiction (inherited from OrderShipmentsClass) |
TaxJurisdictionID (inherited from OrderShipmentsClass) |
TotalQuantity |
TotalWeight | Overloaded.
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.
WeightUnits (inherited from OrderShipmentsClass) |

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

OrderShipmentsEntity Class | Aptify.Applications.OrderEntry Namespace


ParentOrdersEntity Property

Aptify 5.0 Software Development Kit (SDK)

OrderShipmentsEntity.ParentOrdersEntity Property

Takes the OrderLine's ParentGE property value and casts it to an OrdersEntity object

public OrdersEntity ParentOrdersEntity {get;}

Property Value

Remarks

See Also

OrderShipmentsEntity Class | Aptify.Applications.OrderEntry Namespace


TotalQuantity Property

Aptify 5.0 Software Development Kit (SDK)

OrderShipmentsEntity.TotalQuantity Property

new public virtual Decimal TotalQuantity {get; set;}

See Also

OrderShipmentsEntity Class | Aptify.Applications.OrderEntry Namespace


TotalWeight Property

Aptify 5.0 Software Development Kit (SDK)

OrderShipmentsEntity.TotalWeight Property

new public virtual Weight TotalWeight {get; set;}

See Also

OrderShipmentsEntity Class | Aptify.Applications.OrderEntry Namespace


OrderShipmentsEntity Methods

The methods of the OrderShipmentsEntity class are listed below. For a complete list of OrderShipmentsEntity class members, see the OrderShipmentsEntity Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config | Overloaded.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
OrderShipmentTaxes (inherited from OrderShipmentsClass) |
OrderShipmentTaxesObject (inherited from OrderShipmentsClass) |
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded. Before the Sub-Type record is saved, the ShipToAddressID must be synchronized with the ShipToAddressID of a matching Order Ship To Address or an Order Line Ship To Address.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AddFieldValueChangedEventHandlers |
AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
OrderShipmentsFields_AfterValueChanged |
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

OrderShipmentsEntity Class | Aptify.Applications.OrderEntry Namespace


OrderShipmentsEntity.AddFieldValueChangedEventHandlers Method

protected virtual void AddFieldValueChangedEventHandlers();

See Also

OrderShipmentsEntity Class | Aptify.Applications.OrderEntry Namespace


Config Method

Aptify 5.0 Software Development Kit (SDK)

OrderShipmentsEntity.Config Method

Overload List

public override void Config(AptifySubTypeBase);

public override void Config(AptifySubTypeBase,Int64);

Inherited from AptifyGenericEntityBase.

public virtual void Config(UserCredentials,String);

Inherited from AptifyGenericEntity.

public override void Config(UserCredentials,String,Int64);

See Also

OrderShipmentsEntity Class | Aptify.Applications.OrderEntry Namespace


OrderShipmentsEntity.Config Method (AptifySubTypeBase)

public override void Config(
AptifySubTypeBase subType
);

See Also

OrderShipmentsEntity Class | Aptify.Applications.OrderEntry Namespace | OrderShipmentsEntity.Config Overload List


OrderShipmentsEntity.Config Method (AptifySubTypeBase, Int64)

public override void Config(
AptifySubTypeBase subType,
Int64 RecordID
);

See Also

OrderShipmentsEntity Class | Aptify.Applications.OrderEntry Namespace | OrderShipmentsEntity.Config Overload List


OrderShipmentsEntity.OrderShipmentsFields_AfterValueChanged Method

protected virtual void OrderShipmentsFields_AfterValueChanged(
AptifyDataFieldBase sender,
AfterValueChangedEventArgs e
);

See Also

OrderShipmentsEntity Class | Aptify.Applications.OrderEntry Namespace


Save Method

Aptify 5.0 Software Development Kit (SDK)

OrderShipmentsEntity.Save Method

Before the Sub-Type record is saved, the ShipToAddressID must be synchronized with the ShipToAddressID of a matching Order Ship To Address or an Order Line Ship To Address.

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Save();

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean,ref String&);

Before the Sub-Type record is saved, the ShipToAddressID must be synchronized with the ShipToAddressID of a matching Order Ship To Address or an Order Line Ship To Address.

public override bool Save(Boolean,ref String&,String);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(ref String&);

See Also

OrderShipmentsEntity Class | Aptify.Applications.OrderEntry Namespace


OrderShipmentsEntity.Save Method (Boolean, String&, String)

Before the Sub-Type record is saved, the ShipToAddressID must be synchronized with the ShipToAddressID of a matching Order Ship To Address or an Order Line Ship To Address.

public override bool Save(
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

Parameters

AllowGUI
ErrorString
TransactionID

Return Value

Remarks

See Also

OrderShipmentsEntity Class | Aptify.Applications.OrderEntry Namespace | OrderShipmentsEntity.Save Overload List


Validate Method

Aptify 5.0 Software Development Kit (SDK)

OrderShipmentsEntity.Validate Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Validate();

public override bool Validate(ref String&);

See Also

OrderShipmentsEntity Class | Aptify.Applications.OrderEntry Namespace


OrderShipmentsEntity.Validate Method (String&)

public override bool Validate(
ref String& ErrorString
);

See Also

OrderShipmentsEntity Class | Aptify.Applications.OrderEntry Namespace | OrderShipmentsEntity.Validate Overload List


OrderStatus Enumeration

Lists the different Order Status Types defined for Aptify Order Entry

public enum OrderStatus

Remarks

Members

Member Name | Description
Unspecified |
Unknown |
Taken |
Shipped |
BackOrdered |
Cancelled |

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

Aptify.Applications.OrderEntry Namespace


OrderType Enumeration

This enumerated type has the different possible order types listed in it

public enum OrderType

Remarks

Members

Member Name | Description
Unspecified |
Unknown |
Regular |
BackOrder |
Cancellation |
Quotation |

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

Aptify.Applications.OrderEntry Namespace


OrganizationGLAccountNumbers Class

For a list of all members of this type, see OrganizationGLAccountNumbers Members.

System.Object
OrganizationGLAccountNumbers

public class OrganizationGLAccountNumbers

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

OrganizationGLAccountNumbers Members | Aptify.Applications.OrderEntry Namespace


OrganizationGLAccountNumbers Members

OrganizationGLAccountNumbers overview

Public Instance Properties

AR
COGS
DamagedReturns
Deferred
Discounts
GLOrderLevel
Inventory
Returns
Sales
UnearnedRevenue

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

OrganizationGLAccountNumbers Class | Aptify.Applications.OrderEntry Namespace


OrganizationGLAccountNumbers Properties

The properties of the OrganizationGLAccountNumbers class are listed below. For a complete list of OrganizationGLAccountNumbers class members, see the OrganizationGLAccountNumbers Members topic.

Public Instance Properties

AR
COGS
DamagedReturns
Deferred
Discounts
GLOrderLevel
Inventory
Returns
Sales
UnearnedRevenue

See Also

OrganizationGLAccountNumbers Class | Aptify.Applications.OrderEntry Namespace


AR Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationGLAccountNumbers.AR Property

public String AR {get;}

See Also

OrganizationGLAccountNumbers Class | Aptify.Applications.OrderEntry Namespace


COGS Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationGLAccountNumbers.COGS Property

public String COGS {get;}

See Also

OrganizationGLAccountNumbers Class | Aptify.Applications.OrderEntry Namespace


DamagedReturns Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationGLAccountNumbers.DamagedReturns Property

public String DamagedReturns {get;}

See Also

OrganizationGLAccountNumbers Class | Aptify.Applications.OrderEntry Namespace


Deferred Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationGLAccountNumbers.Deferred Property

public String Deferred {get;}

See Also

OrganizationGLAccountNumbers Class | Aptify.Applications.OrderEntry Namespace


Discounts Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationGLAccountNumbers.Discounts Property

public String Discounts {get;}

See Also

OrganizationGLAccountNumbers Class | Aptify.Applications.OrderEntry Namespace


GLOrderLevel Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationGLAccountNumbers.GLOrderLevel Property

public Int64 GLOrderLevel {get;}

See Also

OrganizationGLAccountNumbers Class | Aptify.Applications.OrderEntry Namespace


Inventory Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationGLAccountNumbers.Inventory Property

public String Inventory {get;}

See Also

OrganizationGLAccountNumbers Class | Aptify.Applications.OrderEntry Namespace


Returns Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationGLAccountNumbers.Returns Property

public String Returns {get;}

See Also

OrganizationGLAccountNumbers Class | Aptify.Applications.OrderEntry Namespace


Sales Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationGLAccountNumbers.Sales Property

public String Sales {get;}

See Also

OrganizationGLAccountNumbers Class | Aptify.Applications.OrderEntry Namespace


UnearnedRevenue Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationGLAccountNumbers.UnearnedRevenue Property

public String UnearnedRevenue {get;}

See Also

OrganizationGLAccountNumbers Class | Aptify.Applications.OrderEntry Namespace


PriceBaseType Enumeration

Price Base Type supports tracking the ability for each price record to have a different pricing calculation type, either a regular price(no calculation), a base price which is used to derive other prices, or a percent of base price which is calculated as a percentage of the base price

public enum PriceBaseType

Remarks

Members

Member Name | Description
Regular |
BasePrice |
PercentOfBase |

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

Aptify.Applications.OrderEntry Namespace


PriceRoundingType Enumeration

Price Rounding Type is used to determine the type of rounding to use for derived pricing (currency derivation and base price/percent of base derivation).

public enum PriceRoundingType

Remarks

Members

Member Name | Description
None |
Neutral | Neutral rounding results in rounding up if the number is >= than half towards the next increment, or rounding down if the number is less than half way towards the next increment based on the Rounding Amount(increment)
Up | Always round up
Down | Always round down

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

Aptify.Applications.OrderEntry Namespace


PriceSelectionList Class

For a list of all members of this type, see PriceSelectionList Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
PriceSelectionList

public class PriceSelectionList : Form, ISupportInitialize

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrderLineControl (in AptifyOrderLineControl.dll)

See Also

PriceSelectionList Members | Aptify.Applications.OrderEntry Namespace


PriceSelectionList Members

PriceSelectionList overview

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
Col |
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
Row |
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInit |
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInit |
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
PriceListMouseEnter |
PriceListMouseLeave |
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
ConfigureProductPriceList |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

PriceSelectionList Class | Aptify.Applications.OrderEntry Namespace


PriceSelectionList Properties

The properties of the PriceSelectionList class are listed below. For a complete list of PriceSelectionList class members, see the PriceSelectionList Members topic.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
Col |
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
Row |
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

PriceSelectionList Class | Aptify.Applications.OrderEntry Namespace


Col Property

Aptify 5.0 Software Development Kit (SDK)

PriceSelectionList.Col Property

public Int32 Col {get;}

See Also

PriceSelectionList Class | Aptify.Applications.OrderEntry Namespace


Row Property

Aptify 5.0 Software Development Kit (SDK)

PriceSelectionList.Row Property

public Int32 Row {get;}

See Also

PriceSelectionList Class | Aptify.Applications.OrderEntry Namespace


PriceSelectionList Methods

The methods of the PriceSelectionList class are listed below. For a complete list of PriceSelectionList class members, see the PriceSelectionList Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInit |
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInit |
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
ConfigureProductPriceList |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

PriceSelectionList Class | Aptify.Applications.OrderEntry Namespace


PriceSelectionList.ApplySkin Method

protected virtual void ApplySkin();

See Also

PriceSelectionList Class | Aptify.Applications.OrderEntry Namespace


PriceSelectionList.BeginInit Method

public void BeginInit();

Implements

ISupportInitialize.

See Also

PriceSelectionList Class | Aptify.Applications.OrderEntry Namespace


PriceSelectionList.ConfigureProductPriceList Method

protected virtual void ConfigureProductPriceList(
DataTable PriceList,
OrderLinesEntity OrderLineGE
);

See Also

PriceSelectionList Class | Aptify.Applications.OrderEntry Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

PriceSelectionList.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

PriceSelectionList Class | Aptify.Applications.OrderEntry Namespace


PriceSelectionList.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

PriceSelectionList Class | Aptify.Applications.OrderEntry Namespace | PriceSelectionList.Dispose Overload List


PriceSelectionList.EndInit Method

public void EndInit();

Implements

ISupportInitialize.

See Also

PriceSelectionList Class | Aptify.Applications.OrderEntry Namespace


PriceSelectionList Events

The events of the PriceSelectionList class are listed below. For a complete list of PriceSelectionList class members, see the PriceSelectionList Members topic.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
PriceListMouseEnter |
PriceListMouseLeave |
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

PriceSelectionList Class | Aptify.Applications.OrderEntry Namespace


PriceSelectionList.PriceSelectionList.PriceListMouseEnterEventHandler Event

public event PriceSelectionList.PriceListMouseEnterEventHandler PriceListMouseEnter;

See Also

PriceSelectionList Class | Aptify.Applications.OrderEntry Namespace


PriceSelectionList.PriceSelectionList.PriceListMouseLeaveEventHandler Event

public event PriceSelectionList.PriceListMouseLeaveEventHandler PriceListMouseLeave;

See Also

PriceSelectionList Class | Aptify.Applications.OrderEntry Namespace


PriceSelectionList.PriceListMouseEnterEventHandler Delegate

public delegate void PriceSelectionList.PriceListMouseEnterEventHandler(
Object sender,
EventArgs e
);

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrderLineControl (in AptifyOrderLineControl.dll)

See Also

Aptify.Applications.OrderEntry Namespace


PriceSelectionList.PriceListMouseLeaveEventHandler Delegate

public delegate void PriceSelectionList.PriceListMouseLeaveEventHandler(
Object sender,
EventArgs e
);

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrderLineControl (in AptifyOrderLineControl.dll)

See Also

Aptify.Applications.OrderEntry Namespace


PricingPermissions Class

For a list of all members of this type, see PricingPermissions Members.

System.Object
PricingPermissions

public class PricingPermissions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

PricingPermissions Members | Aptify.Applications.OrderEntry Namespace


PricingPermissions Members

PricingPermissions overview

Public Instance Constructors

PricingPermissions Constructor

Public Instance Properties

AllowFree
AllowPriceOverride
AllowPriceSelection

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PricingPermissions Class | Aptify.Applications.OrderEntry Namespace


PricingPermissions Constructor

public PricingPermissions(
Boolean AllowFree,
Boolean AllowPriceOverride,
Boolean AllowPriceSelection
);

See Also

PricingPermissions Class | Aptify.Applications.OrderEntry Namespace


PricingPermissions Properties

The properties of the PricingPermissions class are listed below. For a complete list of PricingPermissions class members, see the PricingPermissions Members topic.

Public Instance Properties

AllowFree
AllowPriceOverride
AllowPriceSelection

See Also

PricingPermissions Class | Aptify.Applications.OrderEntry Namespace


AllowFree Property

Aptify 5.0 Software Development Kit (SDK)

PricingPermissions.AllowFree Property

public Boolean AllowFree {get;}

See Also

PricingPermissions Class | Aptify.Applications.OrderEntry Namespace


AllowPriceOverride Property

Aptify 5.0 Software Development Kit (SDK)

PricingPermissions.AllowPriceOverride Property

public Boolean AllowPriceOverride {get;}

See Also

PricingPermissions Class | Aptify.Applications.OrderEntry Namespace


AllowPriceSelection Property

Aptify 5.0 Software Development Kit (SDK)

PricingPermissions.AllowPriceSelection Property

public Boolean AllowPriceSelection {get;}

See Also

PricingPermissions Class | Aptify.Applications.OrderEntry Namespace


ProductData Class

Information about a Product that is used by the Order Entry system. This is the object that is stored in the Order Product Cache.

For a list of all members of this type, see ProductData Members.

System.Object
ProductData

public class ProductData

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

10/9/06 RJK - Added MemberTypeID and MemberTypeDefaultPurchaseType properties for adding functionality to Member Types.DefaultType. 2/6/07 AN - Added attributes for SubscriptionSuccessor functionality 9/11/07 RJK - Added OrganizationID

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

ProductData Members | Aptify.Applications.OrderEntry Namespace


ProductData Members

ProductData overview

Public Instance Properties

AllowBackorders |
AllowFree |
AllowPriceOverride |
AllowPriceSelection |
AvailableUntil |
CalculateCOGS |
CategoryID |
ChapterAssignmentDBObjectName | This property returns the name of the Database Object (stored procedure) that is used for calculating the chapter auto assignment rules. This property only returns a value if the ChapterAutoAssignmentRuleID property returns a value > 0
ChapterAssignmentRuleID | Returns the Chapter Auto Assignment Rule ID associated with this product, -1 is returned if no Chapter Auto Assignment Rule ID is associated with this product.
CostMethod |
DateAvailable |
DefaultDuesProduct |
DefaultInventoryLocationID |
DeferredIncome |
Description |
DistributionTypeID |
DropShip |
GetValue | Generic GetValue property that accepts the name of a Field in the Products Entity and returns the value. This can be used to retrieve field values that do not have explicit property definitions.
ID |
IncludeInShippingCalculation |
IsCashBasis |
IsDeferredSubscription | A Product is a deferred subscription it is is both a Subscription and has it's Deferred Income flag checked.
IsDiscontinued |
IsInventoryRequired |
IsKitProduct |
IsProductCurrentlySold |
IsSubscription |
IsTaxable |
KitType |
LatestProductVersionID |
MemberTypeDefaultPurchaseType |
MemberTypeID |
MinPrice | Retrieves the minumum selling price for the Product in the Currency specified by the CurrencyTypeID parameter. Minimum Price is stored in the Functional Currency of the Product's Organization. If the CurrencyTypeID is different than the Organization's Functional Currency, a Currency conversion will take place and the result will be returned.
MinSellingUnits |
Name |
OrganizationID | Returns the OrganizationID associated with this product.
ProductGLAccount | Given a Type and GL Order Level, return the appropriate GL Account Number. If the GLOrderLevelID is -1, then the first glAccount of this type is returned.
ProductGLAccounts | Given a GL Order Level, retrieve and return the appropriate GL Accounts for the Product.
ProductIssues | Returns the value of the SubscriptionIssues field in the Products entity. This field indicates the number of issues of a subscription product a purchaser receives when purchasing a quantity of 1 of the product in order entry. For example, if SubscriptionIssues was set to 12 and the purchaser was buying a quantity of 1 of this product, they would receive 12 issues of the product. This field is only appplicable to Subscription products and returns 0 if it is called for a non-subscription product.
ProductParts |
ProductType |
ProductTypeData | Returns a ProductTypeData object from the Product Types cache based on the Product's ProductTypeID
ProductTypeID |
QuantityAvailable | Overloaded.
RequiresFulfillment |
RevenueRecognitionDate |
SubscriptionDaysPerIssue | Returns the number of days between issues of a subscription. Standard values for Annually, Quarterly, Monthly, Weekly and Daily are: Annual - 360Quarterly - 90Monthly - 30Weekly - 7Daily - 1
SubscriptionIssues | Identical to ProductIssues property.
SubscriptionMaxDuration |
SubscriptionSuccessionMode |
SubscriptionSuccessionProductID |
SubscriptionSuccessionProductRuleID |
SubscriptionSuccessionTriggerRuleID |
SubscriptionSuccessionTriggerType |
TopLevelItem |
UnitWeight |
Weight |
WeightUnits |

Public Instance Methods

CanBeSold | Validates that the Product can be sold based on the criteria specified on the Product's record and the Order Date.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
UseProductRevenueRecognitionDate | This method is responsible for determining if the product specified requires a date-specific revenue recognition model. This is frequently used for meetings and expos and other product types that are sold prior to their date of oCDecence and therefore require deferral of revenue until that future point in time. The following logic is used in the default implementation of this method: If the product is not a deferred income product and does not use cash basis accounting, then check the revenue recognition date. If it is valid, then populate RevenueRecognitionDate (OUTPUT Param) and return True. Otherwise, return False.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
LoadChapterAssignmentData | This method is responsible for loading up data (invoked by the constructor) for Chapter Auto Assignment information
LoadSubscriptionSuccessionData | This method is responsible for loading up data (invoked by the constructor) for Subscription Succession information
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProductData Class | Aptify.Applications.OrderEntry Namespace


ProductData Properties

The properties of the ProductData class are listed below. For a complete list of ProductData class members, see the ProductData Members topic.

Public Instance Properties

AllowBackorders |
AllowFree |
AllowPriceOverride |
AllowPriceSelection |
AvailableUntil |
CalculateCOGS |
CategoryID |
ChapterAssignmentDBObjectName | This property returns the name of the Database Object (stored procedure) that is used for calculating the chapter auto assignment rules. This property only returns a value if the ChapterAutoAssignmentRuleID property returns a value > 0
ChapterAssignmentRuleID | Returns the Chapter Auto Assignment Rule ID associated with this product, -1 is returned if no Chapter Auto Assignment Rule ID is associated with this product.
CostMethod |
DateAvailable |
DefaultDuesProduct |
DefaultInventoryLocationID |
DeferredIncome |
Description |
DistributionTypeID |
DropShip |
GetValue | Generic GetValue property that accepts the name of a Field in the Products Entity and returns the value. This can be used to retrieve field values that do not have explicit property definitions.
ID |
IncludeInShippingCalculation |
IsCashBasis |
IsDeferredSubscription | A Product is a deferred subscription it is is both a Subscription and has it's Deferred Income flag checked.
IsDiscontinued |
IsInventoryRequired |
IsKitProduct |
IsProductCurrentlySold |
IsSubscription |
IsTaxable |
KitType |
LatestProductVersionID |
MemberTypeDefaultPurchaseType |
MemberTypeID |
MinPrice | Retrieves the minumum selling price for the Product in the Currency specified by the CurrencyTypeID parameter. Minimum Price is stored in the Functional Currency of the Product's Organization. If the CurrencyTypeID is different than the Organization's Functional Currency, a Currency conversion will take place and the result will be returned.
MinSellingUnits |
Name |
OrganizationID | Returns the OrganizationID associated with this product.
ProductGLAccount | Given a Type and GL Order Level, return the appropriate GL Account Number. If the GLOrderLevelID is -1, then the first glAccount of this type is returned.
ProductGLAccounts | Given a GL Order Level, retrieve and return the appropriate GL Accounts for the Product.
ProductIssues | Returns the value of the SubscriptionIssues field in the Products entity. This field indicates the number of issues of a subscription product a purchaser receives when purchasing a quantity of 1 of the product in order entry. For example, if SubscriptionIssues was set to 12 and the purchaser was buying a quantity of 1 of this product, they would receive 12 issues of the product. This field is only appplicable to Subscription products and returns 0 if it is called for a non-subscription product.
ProductParts |
ProductType |
ProductTypeData | Returns a ProductTypeData object from the Product Types cache based on the Product's ProductTypeID
ProductTypeID |
QuantityAvailable | Overloaded.
RequiresFulfillment |
RevenueRecognitionDate |
SubscriptionDaysPerIssue | Returns the number of days between issues of a subscription. Standard values for Annually, Quarterly, Monthly, Weekly and Daily are: Annual - 360Quarterly - 90Monthly - 30Weekly - 7Daily - 1
SubscriptionIssues | Identical to ProductIssues property.
SubscriptionMaxDuration |
SubscriptionSuccessionMode |
SubscriptionSuccessionProductID |
SubscriptionSuccessionProductRuleID |
SubscriptionSuccessionTriggerRuleID |
SubscriptionSuccessionTriggerType |
TopLevelItem |
UnitWeight |
Weight |
WeightUnits |

See Also

ProductData Class | Aptify.Applications.OrderEntry Namespace


AllowBackorders Property

Aptify 5.0 Software Development Kit (SDK)

ProductData.AllowBackorders Property

public Boolean AllowBackorders {get;}

See Also

ProductData Class | Aptify.Applications.OrderEntry Namespace


AllowFree Property

Aptify 5.0 Software Development Kit (SDK)

ProductData.AllowFree Property

public Boolean AllowFree {get;}

See Also

ProductData Class | Aptify.Applications.OrderEntry Namespace


AllowPriceOverride Property

Aptify 5.0 Software Development Kit (SDK)

ProductData.AllowPriceOverride Property

public Boolean AllowPriceOverride {get;}

See Also

ProductData Class | Aptify.Applications.OrderEntry Namespace


AllowPriceSelection Property

Aptify 5.0 Software Development Kit (SDK)

ProductData.AllowPriceSelection Property

public Boolean AllowPriceSelection {get;}

See Also

ProductData Class | Aptify.Applications.OrderEntry Namespace


AvailableUntil Property

Aptify 5.0 Software Development Kit (SDK)

ProductData.AvailableUntil Property

public DateTime AvailableUntil {get;}

See Also

ProductData Class | Aptify.Applications.OrderEntry Namespace


CalculateCOGS Property

Aptify 5.0 Software Development Kit (SDK)

ProductData.CalculateCOGS Property

public Boolean CalculateCOGS {get;}

See Also

ProductData Class | Aptify.Applications.OrderEntry Namespace


CategoryID Property

Aptify 5.0 Software Development Kit (SDK)

ProductData.CategoryID Property

public Int64 CategoryID {get;}

See Also

ProductData Class | Aptify.Applications.OrderEntry Namespace


ChapterAssignmentDBObjectName Property

Aptify 5.0 Software Development Kit (SDK)

ProductData.ChapterAssignmentDBObjectName Property

This property returns the name of the Database Object (stored procedure) that is used for calculating the chapter auto assignment rules. This property only returns a value if the ChapterAutoAssignmentRuleID property returns a value > 0

public String ChapterAssignmentDBObjectName {get;}

Property Value

Remarks

See Also

ProductData Class | Aptify.Applications.OrderEntry Namespace


ChapterAssignmentRuleID Property

Aptify 5.0 Software Development Kit (SDK)

ProductData.ChapterAssignmentRuleID Property

Returns the Chapter Auto Assignment Rule ID associated with this product, -1 is returned if no Chapter Auto Assignment Rule ID is associated with this product.

public Int64 ChapterAssignmentRuleID {get;}

Property Value

Remarks

See Also

ProductData Class | Aptify.Applications.OrderEntry Namespace


CostMethod Property

Aptify 5.0 Software Development Kit (SDK)

ProductData.CostMethod Property

public ProductData.ProductCostMethod CostMethod {get;}

See Also

ProductData Class | Aptify.Applications.OrderEntry Namespace


DateAvailable Property

Aptify 5.0 Software Development Kit (SDK)

ProductData.DateAvailable Property

public DateTime DateAvailable {get;}

See Also

ProductData Class | Aptify.Applications.OrderEntry Namespace


DefaultDuesProduct Property

Aptify 5.0 Software Development Kit (SDK)

ProductData.DefaultDuesProduct Property

public Boolean DefaultDuesProduct {get;}

See Also

ProductData Class | Aptify.Applications.OrderEntry Namespace


DefaultInventoryLocationID Property

Aptify 5.0 Software Development Kit (SDK)

ProductData.DefaultInventoryLocationID Property

public Int64 DefaultInventoryLocationID {get;}

See Also

ProductData Class | Aptify.Applications.OrderEntry Namespace


DeferredIncome Property

Aptify 5.0 Software Development Kit (SDK)

ProductData.DeferredIncome Property

public Boolean DeferredIncome {get;}

See Also

ProductData Class | Aptify.Applications.OrderEntry Namespace


Description Property

Aptify 5.0 Software Development Kit (SDK)

ProductData.Description Property

public String Description {get;}

See Also

ProductData Class | Aptify.Applications.OrderEntry Namespace


DistributionTypeID Property

Aptify 5.0 Software Development Kit (SDK)

ProductData.DistributionTypeID Property

public Int32 DistributionTypeID {get;}

See Also

ProductData Class | Aptify.Applications.OrderEntry Namespace


DropShip Property

Aptify 5.0 Software Development Kit (SDK)

ProductData.DropShip Property

public Boolean DropShip {get;}

See Also

ProductData Class | Aptify.Applications.OrderEntry Namespace


GetValue Property

Aptify 5.0 Software Development Kit (SDK)

ProductData.GetValue Property

Generic GetValue property that accepts the name of a Field in the Products Entity and returns the value. This can be used to retrieve field values that do not have explicit property definitions.

public Object this[
String FieldName
] {get;}

Parameters

FieldName

Property Value

Remarks

See Also

ProductData Class | Aptify.Applications.OrderEntry Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

ProductData.ID Property

public Int64 ID {get;}

See Also

ProductData Class | Aptify.Applications.OrderEntry Namespace


IncludeInShippingCalculation Property

Aptify 5.0 Software Development Kit (SDK)

ProductData.IncludeInShippingCalculation Property

public Boolean IncludeInShippingCalculation {get;}

See Also

ProductData Class | Aptify.Applications.OrderEntry Namespace


IsCashBasis Property

Aptify 5.0 Software Development Kit (SDK)

ProductData.IsCashBasis Property

public Boolean IsCashBasis {get;}

See Also

ProductData Class | Aptify.Applications.OrderEntry Namespace


IsDeferredSubscription Property

Aptify 5.0 Software Development Kit (SDK)

ProductData.IsDeferredSubscription Property

A Product is a deferred subscription it is is both a Subscription and has it's Deferred Income flag checked.

public Boolean IsDeferredSubscription {get;}

Property Value

Remarks

See Also

ProductData Class | Aptify.Applications.OrderEntry Namespace


IsDiscontinued Property

Aptify 5.0 Software Development Kit (SDK)

ProductData.IsDiscontinued Property

public Boolean IsDiscontinued {get;}

See Also

ProductData Class | Aptify.Applications.OrderEntry Namespace


IsInventoryRequired Property

Aptify 5.0 Software Development Kit (SDK)

ProductData.IsInventoryRequired Property

public Boolean IsInventoryRequired {get;}

See Also

ProductData Class | Aptify.Applications.OrderEntry Namespace


IsKitProduct Property

Aptify 5.0 Software Development Kit (SDK)

ProductData.IsKitProduct Property

public Boolean IsKitProduct {get;}

See Also

ProductData Class | Aptify.Applications.OrderEntry Namespace


IsProductCurrentlySold Property

Aptify 5.0 Software Development Kit (SDK)

ProductData.IsProductCurrentlySold Property

public Boolean IsProductCurrentlySold {get;}

See Also

ProductData Class | Aptify.Applications.OrderEntry Namespace


IsSubscription Property

Aptify 5.0 Software Development Kit (SDK)

ProductData.IsSubscription Property

public Boolean IsSubscription {get;}

See Also

ProductData Class | Aptify.Applications.OrderEntry Namespace


IsTaxable Property

Aptify 5.0 Software Development Kit (SDK)

ProductData.IsTaxable Property

public Boolean IsTaxable {get;}

See Also

ProductData Class | Aptify.Applications.OrderEntry Namespace


KitType Property

Aptify 5.0 Software Development Kit (SDK)

ProductData.KitType Property

public ProductData.ProductKitType KitType {get;}

See Also

ProductData Class | Aptify.Applications.OrderEntry Namespace


LatestProductVersionID Property

Aptify 5.0 Software Development Kit (SDK)

ProductData.LatestProductVersionID Property

public Int64 LatestProductVersionID {get;}

See Also

ProductData Class | Aptify.Applications.OrderEntry Namespace


MemberTypeDefaultPurchaseType Property

Aptify 5.0 Software Development Kit (SDK)

ProductData.MemberTypeDefaultPurchaseType Property

public ProductData.MemberTypePurchaseType MemberTypeDefaultPurchaseType {get;}

See Also

ProductData Class | Aptify.Applications.OrderEntry Namespace


MemberTypeID Property

Aptify 5.0 Software Development Kit (SDK)

ProductData.MemberTypeID Property

public Int32 MemberTypeID {get;}

See Also

ProductData Class | Aptify.Applications.OrderEntry Namespace


MinPrice Property

Aptify 5.0 Software Development Kit (SDK)

ProductData.MinPrice Property

Retrieves the minumum selling price for the Product in the Currency specified by the CurrencyTypeID parameter. Minimum Price is stored in the Functional Currency of the Product's Organization. If the CurrencyTypeID is different than the Organization's Functional Currency, a Currency conversion will take place and the result will be returned.

public Decimal this[
Int64 CurrencyTypeID
] {get;}

Parameters

CurrencyTypeID

Property Value

Remarks

See Also

ProductData Class | Aptify.Applications.OrderEntry Namespace


MinSellingUnits Property

Aptify 5.0 Software Development Kit (SDK)

ProductData.MinSellingUnits Property

public Decimal MinSellingUnits {get;}

See Also

ProductData Class | Aptify.Applications.OrderEntry Namespace


Name Property

Aptify 5.0 Software Development Kit (SDK)

ProductData.Name Property

public String Name {get;}

See Also

ProductData Class | Aptify.Applications.OrderEntry Namespace


OrganizationID Property

Aptify 5.0 Software Development Kit (SDK)

ProductData.OrganizationID Property

Returns the OrganizationID associated with this product.

public Int64 OrganizationID {get;}

Property Value

Remarks

See Also

ProductData Class | Aptify.Applications.OrderEntry Namespace


ProductGLAccount Property

Aptify 5.0 Software Development Kit (SDK)

ProductData.ProductGLAccount Property

Given a Type and GL Order Level, return the appropriate GL Account Number. If the GLOrderLevelID is -1, then the first glAccount of this type is returned.

public String this[
String Type,
Int64 GLOrderLevelID
] {get;}

Parameters

Type
GLOrderLevelID

Property Value

Remarks

See Also

ProductData Class | Aptify.Applications.OrderEntry Namespace


ProductGLAccounts Property

Aptify 5.0 Software Development Kit (SDK)

ProductData.ProductGLAccounts Property

Given a GL Order Level, retrieve and return the appropriate GL Accounts for the Product.

public ProductGLAccountNumbers this[
Int64 GLOrderLevelID
] {get;}

Parameters

GLOrderLevelID

Property Value

Remarks

See Also

ProductData Class | Aptify.Applications.OrderEntry Namespace


ProductIssues Property

Aptify 5.0 Software Development Kit (SDK)

ProductData.ProductIssues Property

Returns the value of the SubscriptionIssues field in the Products entity. This field indicates the number of issues of a subscription product a purchaser receives when purchasing a quantity of 1 of the product in order entry. For example, if SubscriptionIssues was set to 12 and the purchaser was buying a quantity of 1 of this product, they would receive 12 issues of the product. This field is only appplicable to Subscription products and returns 0 if it is called for a non-subscription product.

public Int32 ProductIssues {get;}

Property Value

Remarks

See Also

ProductData Class | Aptify.Applications.OrderEntry Namespace


ProductParts Property

Aptify 5.0 Software Development Kit (SDK)

ProductData.ProductParts Property

public List<T> ProductParts {get;}

See Also

ProductData Class | Aptify.Applications.OrderEntry Namespace


ProductType Property

Aptify 5.0 Software Development Kit (SDK)

ProductData.ProductType Property

public String ProductType {get;}

See Also

ProductData Class | Aptify.Applications.OrderEntry Namespace


ProductTypeData Property

Aptify 5.0 Software Development Kit (SDK)

ProductData.ProductTypeData Property

Returns a ProductTypeData object from the Product Types cache based on the Product's ProductTypeID

public ProductTypeData ProductTypeData {get;}

Property Value

Remarks

See Also

ProductData Class | Aptify.Applications.OrderEntry Namespace


ProductTypeID Property

Aptify 5.0 Software Development Kit (SDK)

ProductData.ProductTypeID Property

public Int64 ProductTypeID {get;}

See Also

ProductData Class | Aptify.Applications.OrderEntry Namespace


Decimal Property

Aptify 5.0 Software Development Kit (SDK)

ProductData.Decimal Property

Overload List

public Decimal QuantityAvailable {get;}

public Decimal this[Boolean] {get;}

See Also

ProductData Class | Aptify.Applications.OrderEntry Namespace


QuantityAvailable Property

Aptify 5.0 Software Development Kit (SDK)

ProductData.QuantityAvailable Property

public Decimal QuantityAvailable {get;}

See Also

ProductData Class | Aptify.Applications.OrderEntry Namespace | ProductData.Decimal Overload List


QuantityAvailable Property (Boolean)

Aptify 5.0 Software Development Kit (SDK)

ProductData.QuantityAvailable Property (Boolean)

public Decimal this[
Boolean Refresh
] {get;}

See Also

ProductData Class | Aptify.Applications.OrderEntry Namespace | ProductData.Decimal Overload List


RequiresFulfillment Property

Aptify 5.0 Software Development Kit (SDK)

ProductData.RequiresFulfillment Property

public Boolean RequiresFulfillment {get;}

See Also

ProductData Class | Aptify.Applications.OrderEntry Namespace


RevenueRecognitionDate Property

Aptify 5.0 Software Development Kit (SDK)

ProductData.RevenueRecognitionDate Property

public DateTime RevenueRecognitionDate {get;}

See Also

ProductData Class | Aptify.Applications.OrderEntry Namespace


SubscriptionDaysPerIssue Property

Aptify 5.0 Software Development Kit (SDK)

ProductData.SubscriptionDaysPerIssue Property

Returns the number of days between issues of a subscription. Standard values for Annually, Quarterly, Monthly, Weekly and Daily are: Annual - 360Quarterly - 90Monthly - 30Weekly - 7Daily - 1

public Int32 SubscriptionDaysPerIssue {get;}

Property Value

Remarks

See Also

ProductData Class | Aptify.Applications.OrderEntry Namespace


SubscriptionIssues Property

Aptify 5.0 Software Development Kit (SDK)

ProductData.SubscriptionIssues Property

Identical to ProductIssues property.

public Int32 SubscriptionIssues {get;}

Property Value

Remarks

AN: Added on 2/6/07 for consistency with field names

See Also

ProductData Class | Aptify.Applications.OrderEntry Namespace


SubscriptionMaxDuration Property

Aptify 5.0 Software Development Kit (SDK)

ProductData.SubscriptionMaxDuration Property

public virtual Decimal SubscriptionMaxDuration {get;}

See Also

ProductData Class | Aptify.Applications.OrderEntry Namespace


SubscriptionSuccessionMode Property

Aptify 5.0 Software Development Kit (SDK)

ProductData.SubscriptionSuccessionMode Property

public virtual ProductData.SubscriptionSuccessionModeOptions SubscriptionSuccessionMode {get;}

See Also

ProductData Class | Aptify.Applications.OrderEntry Namespace


SubscriptionSuccessionProductID Property

Aptify 5.0 Software Development Kit (SDK)

ProductData.SubscriptionSuccessionProductID Property

public virtual Int64 SubscriptionSuccessionProductID {get;}

See Also

ProductData Class | Aptify.Applications.OrderEntry Namespace


SubscriptionSuccessionProductRuleID Property

Aptify 5.0 Software Development Kit (SDK)

ProductData.SubscriptionSuccessionProductRuleID Property

public virtual Int64 SubscriptionSuccessionProductRuleID {get;}

See Also

ProductData Class | Aptify.Applications.OrderEntry Namespace


SubscriptionSuccessionTriggerRuleID Property

Aptify 5.0 Software Development Kit (SDK)

ProductData.SubscriptionSuccessionTriggerRuleID Property

public virtual Int64 SubscriptionSuccessionTriggerRuleID {get;}

See Also

ProductData Class | Aptify.Applications.OrderEntry Namespace


SubscriptionSuccessionTriggerType Property

Aptify 5.0 Software Development Kit (SDK)

ProductData.SubscriptionSuccessionTriggerType Property

public virtual ProductData.SubscriptionSuccessionTriggerTypeOptions SubscriptionSuccessionTriggerType {get;}

See Also

ProductData Class | Aptify.Applications.OrderEntry Namespace


TopLevelItem Property

Aptify 5.0 Software Development Kit (SDK)

ProductData.TopLevelItem Property

public Boolean TopLevelItem {get;}

See Also

ProductData Class | Aptify.Applications.OrderEntry Namespace


UnitWeight Property

Aptify 5.0 Software Development Kit (SDK)

ProductData.UnitWeight Property

public Decimal UnitWeight {get;}

See Also

ProductData Class | Aptify.Applications.OrderEntry Namespace


Weight Property

Aptify 5.0 Software Development Kit (SDK)

ProductData.Weight Property

public Weight Weight {get;}

See Also

ProductData Class | Aptify.Applications.OrderEntry Namespace


WeightUnits Property

Aptify 5.0 Software Development Kit (SDK)

ProductData.WeightUnits Property

public ProductData.WeightUnitsOfMeasure WeightUnits {get;}

See Also

ProductData Class | Aptify.Applications.OrderEntry Namespace


ProductData Methods

The methods of the ProductData class are listed below. For a complete list of ProductData class members, see the ProductData Members topic.

Public Instance Methods

CanBeSold | Validates that the Product can be sold based on the criteria specified on the Product's record and the Order Date.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
UseProductRevenueRecognitionDate | This method is responsible for determining if the product specified requires a date-specific revenue recognition model. This is frequently used for meetings and expos and other product types that are sold prior to their date of oCDecence and therefore require deferral of revenue until that future point in time. The following logic is used in the default implementation of this method: If the product is not a deferred income product and does not use cash basis accounting, then check the revenue recognition date. If it is valid, then populate RevenueRecognitionDate (OUTPUT Param) and return True. Otherwise, return False.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
LoadChapterAssignmentData | This method is responsible for loading up data (invoked by the constructor) for Chapter Auto Assignment information
LoadSubscriptionSuccessionData | This method is responsible for loading up data (invoked by the constructor) for Subscription Succession information
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProductData Class | Aptify.Applications.OrderEntry Namespace


ProductData.CanBeSold Method

Validates that the Product can be sold based on the criteria specified on the Product's record and the Order Date.

public CanBeSoldResult CanBeSold(
DateTime OrderDate
);

Parameters

OrderDate

Return Value

Remarks

See Also

ProductData Class | Aptify.Applications.OrderEntry Namespace


ProductData.LoadChapterAssignmentData Method

This method is responsible for loading up data (invoked by the constructor) for Chapter Auto Assignment information

protected virtual void LoadChapterAssignmentData(
DataRow rowProduct
);

Parameters

rowProduct

Remarks

See Also

ProductData Class | Aptify.Applications.OrderEntry Namespace


ProductData.LoadSubscriptionSuccessionData Method

This method is responsible for loading up data (invoked by the constructor) for Subscription Succession information

protected virtual void LoadSubscriptionSuccessionData(
DataRow rowProduct
);

Parameters

rowProduct

Remarks

See Also

ProductData Class | Aptify.Applications.OrderEntry Namespace


ProductData.UseProductRevenueRecognitionDate Method

This method is responsible for determining if the product specified requires a date-specific revenue recognition model. This is frequently used for meetings and expos and other product types that are sold prior to their date of oCDecence and therefore require deferral of revenue until that future point in time. The following logic is used in the default implementation of this method: If the product is not a deferred income product and does not use cash basis accounting, then check the revenue recognition date. If it is valid, then populate RevenueRecognitionDate (OUTPUT Param) and return True. Otherwise, return False.

public bool UseProductRevenueRecognitionDate(
DateTime OrderDate,
ref DateTime& RevenueRecognitionDate
);

Parameters

OrderDate
RevenueRecognitionDate
OUT Parameter: Revenue Recognition Date for the product, only provided if this product has one time date-driven revenue recognition

Return Value

True if the product uses one-time date driven revenue recognition, False otherwise

Remarks

See Also

ProductData Class | Aptify.Applications.OrderEntry Namespace


ProductData.CanBeSoldResult Enumeration

public enum ProductData.CanBeSoldResult

Members

Member Name | Description
Saleable |
NotCurrentlySold |
NotATopLevelProduct |
OutsideAvailableDateRange |

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

Aptify.Applications.OrderEntry Namespace


ProductData.MemberTypePurchaseType Enumeration

public enum ProductData.MemberTypePurchaseType

Members

Member Name | Description
NotSet |
Individual |
Company |

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

Aptify.Applications.OrderEntry Namespace


ProductData.ProductCostMethod Enumeration

public enum ProductData.ProductCostMethod

Members

Member Name | Description
Average |
LIFO |
FIFO |

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

Aptify.Applications.OrderEntry Namespace


ProductData.ProductKitType Enumeration

public enum ProductData.ProductKitType

Members

Member Name | Description
StandardProduct |
KitProduct |
ProductGroup |

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

Aptify.Applications.OrderEntry Namespace


ProductData.SubscriptionSuccessionModeOptions Enumeration

Determines what to do when a succession is to take place, either replace with a fixed product, use a rule to dynamically calculate the successor product, or terminate the subscription.

public enum ProductData.SubscriptionSuccessionModeOptions

Remarks

Members

Member Name | Description
FixedProduct | Product to be used as successor product is defined in the SubscriptionSuccessionProductID field
Rule | Product to be used as successor product selected dynamically based on the attached rule
Termination | Termination of subscription takes place after number of terms is exceeded

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

Aptify.Applications.OrderEntry Namespace


ProductData.SubscriptionSuccessionTriggerTypeOptions Enumeration

Type of succession trigger for subscription products

public enum ProductData.SubscriptionSuccessionTriggerTypeOptions

Remarks

Members

Member Name | Description
None | No succession requirements for the product
FixedTerm | Succession occurs automatically after a fixed term
Rule | Succession occurs based on when the rule attached to the product specifies that it should occur

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

Aptify.Applications.OrderEntry Namespace


ProductData.WeightUnitsOfMeasure Enumeration

public enum ProductData.WeightUnitsOfMeasure

Members

Member Name | Description
Pounds |
Ounces |
Kilograms |
Grams |
Unknown |

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

Aptify.Applications.OrderEntry Namespace


ProductGLAccountNumbers Class

For a list of all members of this type, see ProductGLAccountNumbers Members.

System.Object
ProductGLAccountNumbers

public class ProductGLAccountNumbers

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

ProductGLAccountNumbers Members | Aptify.Applications.OrderEntry Namespace


ProductGLAccountNumbers Members

ProductGLAccountNumbers overview

Public Instance Properties

AR
COGS
DamagedReturns
Deferred
Discounts
GLOrderLevel
Inventory
Returns
Sales
UnearnedRevenue

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProductGLAccountNumbers Class | Aptify.Applications.OrderEntry Namespace


ProductGLAccountNumbers Properties

The properties of the ProductGLAccountNumbers class are listed below. For a complete list of ProductGLAccountNumbers class members, see the ProductGLAccountNumbers Members topic.

Public Instance Properties

AR
COGS
DamagedReturns
Deferred
Discounts
GLOrderLevel
Inventory
Returns
Sales
UnearnedRevenue

See Also

ProductGLAccountNumbers Class | Aptify.Applications.OrderEntry Namespace


AR Property

Aptify 5.0 Software Development Kit (SDK)

ProductGLAccountNumbers.AR Property

public String AR {get;}

See Also

ProductGLAccountNumbers Class | Aptify.Applications.OrderEntry Namespace


COGS Property

Aptify 5.0 Software Development Kit (SDK)

ProductGLAccountNumbers.COGS Property

public String COGS {get;}

See Also

ProductGLAccountNumbers Class | Aptify.Applications.OrderEntry Namespace


DamagedReturns Property

Aptify 5.0 Software Development Kit (SDK)

ProductGLAccountNumbers.DamagedReturns Property

public String DamagedReturns {get;}

See Also

ProductGLAccountNumbers Class | Aptify.Applications.OrderEntry Namespace


Deferred Property

Aptify 5.0 Software Development Kit (SDK)

ProductGLAccountNumbers.Deferred Property

public String Deferred {get;}

See Also

ProductGLAccountNumbers Class | Aptify.Applications.OrderEntry Namespace


Discounts Property

Aptify 5.0 Software Development Kit (SDK)

ProductGLAccountNumbers.Discounts Property

public String Discounts {get;}

See Also

ProductGLAccountNumbers Class | Aptify.Applications.OrderEntry Namespace


GLOrderLevel Property

Aptify 5.0 Software Development Kit (SDK)

ProductGLAccountNumbers.GLOrderLevel Property

public Int64 GLOrderLevel {get;}

See Also

ProductGLAccountNumbers Class | Aptify.Applications.OrderEntry Namespace


Inventory Property

Aptify 5.0 Software Development Kit (SDK)

ProductGLAccountNumbers.Inventory Property

public String Inventory {get;}

See Also

ProductGLAccountNumbers Class | Aptify.Applications.OrderEntry Namespace


Returns Property

Aptify 5.0 Software Development Kit (SDK)

ProductGLAccountNumbers.Returns Property

public String Returns {get;}

See Also

ProductGLAccountNumbers Class | Aptify.Applications.OrderEntry Namespace


Sales Property

Aptify 5.0 Software Development Kit (SDK)

ProductGLAccountNumbers.Sales Property

public String Sales {get;}

See Also

ProductGLAccountNumbers Class | Aptify.Applications.OrderEntry Namespace


UnearnedRevenue Property

Aptify 5.0 Software Development Kit (SDK)

ProductGLAccountNumbers.UnearnedRevenue Property

public String UnearnedRevenue {get;}

See Also

ProductGLAccountNumbers Class | Aptify.Applications.OrderEntry Namespace


ProductPartData Class

For a list of all members of this type, see ProductPartData Members.

System.Object
ProductPartData

public class ProductPartData

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

ProductPartData Members | Aptify.Applications.OrderEntry Namespace


ProductPartData Members

ProductPartData overview

Public Instance Properties

PctOfRevenue
Quantity
SubProductData
SubProductID
SubProductName

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProductPartData Class | Aptify.Applications.OrderEntry Namespace


ProductPartData Properties

The properties of the ProductPartData class are listed below. For a complete list of ProductPartData class members, see the ProductPartData Members topic.

Public Instance Properties

PctOfRevenue
Quantity
SubProductData
SubProductID
SubProductName

See Also

ProductPartData Class | Aptify.Applications.OrderEntry Namespace


PctOfRevenue Property

Aptify 5.0 Software Development Kit (SDK)

ProductPartData.PctOfRevenue Property

public Decimal PctOfRevenue {get;}

See Also

ProductPartData Class | Aptify.Applications.OrderEntry Namespace


Quantity Property

Aptify 5.0 Software Development Kit (SDK)

ProductPartData.Quantity Property

public Decimal Quantity {get;}

See Also

ProductPartData Class | Aptify.Applications.OrderEntry Namespace


SubProductData Property

Aptify 5.0 Software Development Kit (SDK)

ProductPartData.SubProductData Property

public ProductData SubProductData {get;}

See Also

ProductPartData Class | Aptify.Applications.OrderEntry Namespace


SubProductID Property

Aptify 5.0 Software Development Kit (SDK)

ProductPartData.SubProductID Property

public Int64 SubProductID {get;}

See Also

ProductPartData Class | Aptify.Applications.OrderEntry Namespace


SubProductName Property

Aptify 5.0 Software Development Kit (SDK)

ProductPartData.SubProductName Property

public String SubProductName {get;}

See Also

ProductPartData Class | Aptify.Applications.OrderEntry Namespace


ProductTypeAttribute Class

For a list of all members of this type, see ProductTypeAttribute Members.

System.Object
ProductTypeAttribute

public class ProductTypeAttribute

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

ProductTypeAttribute Members | Aptify.Applications.OrderEntry Namespace


ProductTypeAttribute Members

ProductTypeAttribute overview

Public Instance Properties

Description
Name
Value

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProductTypeAttribute Class | Aptify.Applications.OrderEntry Namespace


ProductTypeAttribute Properties

The properties of the ProductTypeAttribute class are listed below. For a complete list of ProductTypeAttribute class members, see the ProductTypeAttribute Members topic.

Public Instance Properties

Description
Name
Value

See Also

ProductTypeAttribute Class | Aptify.Applications.OrderEntry Namespace


Description Property

Aptify 5.0 Software Development Kit (SDK)

ProductTypeAttribute.Description Property

public String Description {get;}

See Also

ProductTypeAttribute Class | Aptify.Applications.OrderEntry Namespace


Name Property

Aptify 5.0 Software Development Kit (SDK)

ProductTypeAttribute.Name Property

public String Name {get;}

See Also

ProductTypeAttribute Class | Aptify.Applications.OrderEntry Namespace


Value Property

Aptify 5.0 Software Development Kit (SDK)

ProductTypeAttribute.Value Property

public String Value {get;}

See Also

ProductTypeAttribute Class | Aptify.Applications.OrderEntry Namespace


ProductTypeData Class

For a list of all members of this type, see ProductTypeData Members.

System.Object
ProductTypeData

public class ProductTypeData

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

ProductTypeData Members | Aptify.Applications.OrderEntry Namespace


ProductTypeData Members

ProductTypeData overview

Public Instance Properties

Attributes
ExtendedOrderDetailEntity
ExtendedProductEntity
ExtendedProductLinkedField
ID
Name

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProductTypeData Class | Aptify.Applications.OrderEntry Namespace


ProductTypeData Properties

The properties of the ProductTypeData class are listed below. For a complete list of ProductTypeData class members, see the ProductTypeData Members topic.

Public Instance Properties

Attributes
ExtendedOrderDetailEntity
ExtendedProductEntity
ExtendedProductLinkedField
ID
Name

See Also

ProductTypeData Class | Aptify.Applications.OrderEntry Namespace


Attributes Property

Aptify 5.0 Software Development Kit (SDK)

ProductTypeData.Attributes Property

public Dictionary<TKey,TValue> Attributes {get;}

See Also

ProductTypeData Class | Aptify.Applications.OrderEntry Namespace


ExtendedOrderDetailEntity Property

Aptify 5.0 Software Development Kit (SDK)

ProductTypeData.ExtendedOrderDetailEntity Property

public String ExtendedOrderDetailEntity {get;}

See Also

ProductTypeData Class | Aptify.Applications.OrderEntry Namespace


ExtendedProductEntity Property

Aptify 5.0 Software Development Kit (SDK)

ProductTypeData.ExtendedProductEntity Property

public String ExtendedProductEntity {get;}

See Also

ProductTypeData Class | Aptify.Applications.OrderEntry Namespace


ExtendedProductLinkedField Property

Aptify 5.0 Software Development Kit (SDK)

ProductTypeData.ExtendedProductLinkedField Property

public String ExtendedProductLinkedField {get;}

See Also

ProductTypeData Class | Aptify.Applications.OrderEntry Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

ProductTypeData.ID Property

public Int64 ID {get;}

See Also

ProductTypeData Class | Aptify.Applications.OrderEntry Namespace


Name Property

Aptify 5.0 Software Development Kit (SDK)

ProductTypeData.Name Property

public String Name {get;}

See Also

ProductTypeData Class | Aptify.Applications.OrderEntry Namespace


RelatedProductEventArgs Class

For a list of all members of this type, see RelatedProductEventArgs Members.

System.Object
EventArgs
RelatedProductEventArgs

public class RelatedProductEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

RelatedProductEventArgs Members | Aptify.Applications.OrderEntry Namespace


RelatedProductEventArgs Members

RelatedProductEventArgs overview

Public Instance Constructors

RelatedProductEventArgs Overloaded. Initializes a new instance of the RelatedProductEventArgs class.

Public Instance Properties

OrderLine
ProductID
ProductName
Quantity

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RelatedProductEventArgs Class | Aptify.Applications.OrderEntry Namespace


RelatedProductEventArgs Constructor

Overload List

public RelatedProductEventArgs(OrderLinesEntity,Int64,String);

public RelatedProductEventArgs(OrderLinesEntity,Int64,String,Decimal);

See Also

RelatedProductEventArgs Class | Aptify.Applications.OrderEntry Namespace


RelatedProductEventArgs Constructor (OrderLinesEntity, Int64, String)

public RelatedProductEventArgs(
OrderLinesEntity OrderLine,
Int64 ProductID,
String ProductName
);

See Also

RelatedProductEventArgs Class | Aptify.Applications.OrderEntry Namespace | RelatedProductEventArgs Constructor Overload List


RelatedProductEventArgs Constructor (OrderLinesEntity, Int64, String, Decimal)

public RelatedProductEventArgs(
OrderLinesEntity OrderLine,
Int64 ProductID,
String ProductName,
Decimal Quantity
);

See Also

RelatedProductEventArgs Class | Aptify.Applications.OrderEntry Namespace | RelatedProductEventArgs Constructor Overload List


RelatedProductEventArgs Properties

The properties of the RelatedProductEventArgs class are listed below. For a complete list of RelatedProductEventArgs class members, see the RelatedProductEventArgs Members topic.

Public Instance Properties

OrderLine
ProductID
ProductName
Quantity

See Also

RelatedProductEventArgs Class | Aptify.Applications.OrderEntry Namespace


OrderLine Property

Aptify 5.0 Software Development Kit (SDK)

RelatedProductEventArgs.OrderLine Property

public OrderLinesEntity OrderLine {get;}

See Also

RelatedProductEventArgs Class | Aptify.Applications.OrderEntry Namespace


ProductID Property

Aptify 5.0 Software Development Kit (SDK)

RelatedProductEventArgs.ProductID Property

public Int64 ProductID {get;}

See Also

RelatedProductEventArgs Class | Aptify.Applications.OrderEntry Namespace


ProductName Property

Aptify 5.0 Software Development Kit (SDK)

RelatedProductEventArgs.ProductName Property

public String ProductName {get;}

See Also

RelatedProductEventArgs Class | Aptify.Applications.OrderEntry Namespace


Quantity Property

Aptify 5.0 Software Development Kit (SDK)

RelatedProductEventArgs.Quantity Property

public Decimal Quantity {get;}

See Also

RelatedProductEventArgs Class | Aptify.Applications.OrderEntry Namespace


RelatedProductInfo Class

Provides information about a Related Product. Used by the Related Products UI (IRelatedProductsUI) and Object (IRelatedProducts).

For a list of all members of this type, see RelatedProductInfo Members.

System.Object
RelatedProductInfo

public class RelatedProductInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

RelatedProductInfo Members | Aptify.Applications.OrderEntry Namespace


RelatedProductInfo Members

RelatedProductInfo overview

Public Instance Constructors

RelatedProductInfo Constructor

Public Instance Properties

ID
ProductData
ProductID
ProductName
PromptText
RelationshipType
RelationshipTypeID

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RelatedProductInfo Class | Aptify.Applications.OrderEntry Namespace


RelatedProductInfo Constructor

public RelatedProductInfo(
Int64 ID,
Int64 ProductID,
ProductData Product,
Int32 RelationshipTypeID,
String RelationshipType,
String PromptText
);

See Also

RelatedProductInfo Class | Aptify.Applications.OrderEntry Namespace


RelatedProductInfo Properties

The properties of the RelatedProductInfo class are listed below. For a complete list of RelatedProductInfo class members, see the RelatedProductInfo Members topic.

Public Instance Properties

ID
ProductData
ProductID
ProductName
PromptText
RelationshipType
RelationshipTypeID

See Also

RelatedProductInfo Class | Aptify.Applications.OrderEntry Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

RelatedProductInfo.ID Property

public Int64 ID {get;}

See Also

RelatedProductInfo Class | Aptify.Applications.OrderEntry Namespace


ProductData Property

Aptify 5.0 Software Development Kit (SDK)

RelatedProductInfo.ProductData Property

public ProductData ProductData {get;}

See Also

RelatedProductInfo Class | Aptify.Applications.OrderEntry Namespace


ProductID Property

Aptify 5.0 Software Development Kit (SDK)

RelatedProductInfo.ProductID Property

public Int64 ProductID {get;}

See Also

RelatedProductInfo Class | Aptify.Applications.OrderEntry Namespace


ProductName Property

Aptify 5.0 Software Development Kit (SDK)

RelatedProductInfo.ProductName Property

public String ProductName {get;}

See Also

RelatedProductInfo Class | Aptify.Applications.OrderEntry Namespace


PromptText Property

Aptify 5.0 Software Development Kit (SDK)

RelatedProductInfo.PromptText Property

public String PromptText {get;}

See Also

RelatedProductInfo Class | Aptify.Applications.OrderEntry Namespace


RelationshipType Property

Aptify 5.0 Software Development Kit (SDK)

RelatedProductInfo.RelationshipType Property

public String RelationshipType {get;}

See Also

RelatedProductInfo Class | Aptify.Applications.OrderEntry Namespace


RelationshipTypeID Property

Aptify 5.0 Software Development Kit (SDK)

RelatedProductInfo.RelationshipTypeID Property

public Int32 RelationshipTypeID {get;}

See Also

RelatedProductInfo Class | Aptify.Applications.OrderEntry Namespace


RelatedProducts Class

For a list of all members of this type, see RelatedProducts Members.

System.Object
RelatedProducts

public class RelatedProducts : IRelatedProducts

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

RelatedProducts Members | Aptify.Applications.OrderEntry Namespace


RelatedProducts Members

RelatedProducts overview

Public Instance Constructors

RelatedProducts Constructor Initializes a new instance of the RelatedProducts class.

Public Instance Methods

Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetRelatedProducts | Overloaded.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RelatedProducts Class | Aptify.Applications.OrderEntry Namespace


RelatedProducts Constructor

Initializes a new instance of the RelatedProducts class.

public RelatedProducts();

See Also

RelatedProducts Class | Aptify.Applications.OrderEntry Namespace


RelatedProducts Methods

The methods of the RelatedProducts class are listed below. For a complete list of RelatedProducts class members, see the RelatedProducts Members topic.

Public Instance Methods

Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetRelatedProducts | Overloaded.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RelatedProducts Class | Aptify.Applications.OrderEntry Namespace


RelatedProducts.Config Method

public void Config(
AptifyApplication Application
);

Implements

IRelatedProducts.

See Also

RelatedProducts Class | Aptify.Applications.OrderEntry Namespace


GetRelatedProducts Method

Aptify 5.0 Software Development Kit (SDK)

RelatedProducts.GetRelatedProducts Method

Overload List

public List<T> GetRelatedProducts(Int64);

Returns the related products with AutoPrompt=1. The core implementation calls the stored procedure defined in the Orders Entity Attribute, RelatedProductsStoredProcedure. If the attribute does not exist or its value is blank, the stored procedure spGetRelatedProducts will be used. spGetRelatedProducts only returns those Related Products that are active for the current date and have an AutoPrompt value of 1. CampaignID is not used in the core implementation.

public List<T> GetRelatedProducts(Int64,Int64);

See Also

RelatedProducts Class | Aptify.Applications.OrderEntry Namespace


RelatedProducts.GetRelatedProducts Method (Int64)

public List<T> GetRelatedProducts(
Int64 ProductID
);

Implements

IRelatedProducts.

See Also

RelatedProducts Class | Aptify.Applications.OrderEntry Namespace | RelatedProducts.GetRelatedProducts Overload List


RelatedProducts.GetRelatedProducts Method (Int64, Int64)

Returns the related products with AutoPrompt=1. The core implementation calls the stored procedure defined in the Orders Entity Attribute, RelatedProductsStoredProcedure. If the attribute does not exist or its value is blank, the stored procedure spGetRelatedProducts will be used. spGetRelatedProducts only returns those Related Products that are active for the current date and have an AutoPrompt value of 1. CampaignID is not used in the core implementation.

public List<T> GetRelatedProducts(
Int64 ProductID,
Int64 CampaignID
);

Parameters

ProductID
CampaignID

Return Value

Implements

IRelatedProducts.

Remarks

See Also

RelatedProducts Class | Aptify.Applications.OrderEntry Namespace | RelatedProducts.GetRelatedProducts Overload List


RelatedProductsForm Class

For a list of all members of this type, see RelatedProductsForm Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
RelatedProductsForm

public class RelatedProductsForm : Form, IRelatedProductsUI

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrderLineControl (in AptifyOrderLineControl.dll)

See Also

RelatedProductsForm Members | Aptify.Applications.OrderEntry Namespace


RelatedProductsForm Members

RelatedProductsForm overview

Public Instance Constructors

RelatedProductsForm Constructor Initializes a new instance of the RelatedProductsForm class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductID |
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DisposeRelatedProducts |
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
HideRelatedProducts |
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
ShowRelatedProducts |
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AddRelatedProductToOrder |
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
UserClosedRelatedProductsUI |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CheckRelatedProductPromptClosePermissions |
ConfigureRelatedProductsGrid |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
LoadRelatedProductsGrid |
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAddRelatedProductToOrder |
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RelatedProductsCellButtonClick |
RelatedProductsMouseClick |
RelatedProductsMouseHoverCell |
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

RelatedProductsForm Class | Aptify.Applications.OrderEntry Namespace


RelatedProductsForm Constructor

Initializes a new instance of the RelatedProductsForm class.

public RelatedProductsForm();

See Also

RelatedProductsForm Class | Aptify.Applications.OrderEntry Namespace


RelatedProductsForm Properties

The properties of the RelatedProductsForm class are listed below. For a complete list of RelatedProductsForm class members, see the RelatedProductsForm Members topic.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductID |
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

RelatedProductsForm Class | Aptify.Applications.OrderEntry Namespace


ProductID Property

Aptify 5.0 Software Development Kit (SDK)

RelatedProductsForm.ProductID Property

public Int64 ProductID {get;}

Implements

IRelatedProductsUI.

See Also

RelatedProductsForm Class | Aptify.Applications.OrderEntry Namespace


RelatedProductsForm Methods

The methods of the RelatedProductsForm class are listed below. For a complete list of RelatedProductsForm class members, see the RelatedProductsForm Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DisposeRelatedProducts |
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
HideRelatedProducts |
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
ShowRelatedProducts |
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CheckRelatedProductPromptClosePermissions |
ConfigureRelatedProductsGrid |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
LoadRelatedProductsGrid |
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAddRelatedProductToOrder |
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RelatedProductsCellButtonClick |
RelatedProductsMouseClick |
RelatedProductsMouseHoverCell |
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

RelatedProductsForm Class | Aptify.Applications.OrderEntry Namespace


RelatedProductsForm.ApplySkin Method

protected virtual void ApplySkin();

See Also

RelatedProductsForm Class | Aptify.Applications.OrderEntry Namespace


RelatedProductsForm.CheckRelatedProductPromptClosePermissions Method

protected virtual bool CheckRelatedProductPromptClosePermissions();

See Also

RelatedProductsForm Class | Aptify.Applications.OrderEntry Namespace


RelatedProductsForm.Config Method

public virtual void Config(
AptifyApplication Application,
OrderLinesEntity OrderLine,
List<T> RelatedProducts
);

Implements

IRelatedProductsUI.

See Also

RelatedProductsForm Class | Aptify.Applications.OrderEntry Namespace


RelatedProductsForm.ConfigureRelatedProductsGrid Method

protected virtual void ConfigureRelatedProductsGrid();

See Also

RelatedProductsForm Class | Aptify.Applications.OrderEntry Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

RelatedProductsForm.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

RelatedProductsForm Class | Aptify.Applications.OrderEntry Namespace


RelatedProductsForm.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

RelatedProductsForm Class | Aptify.Applications.OrderEntry Namespace | RelatedProductsForm.Dispose Overload List


RelatedProductsForm.DisposeRelatedProducts Method

public virtual void DisposeRelatedProducts();

Implements

IRelatedProductsUI.

See Also

RelatedProductsForm Class | Aptify.Applications.OrderEntry Namespace


RelatedProductsForm.HideRelatedProducts Method

public virtual void HideRelatedProducts();

Implements

IRelatedProductsUI.

See Also

RelatedProductsForm Class | Aptify.Applications.OrderEntry Namespace


RelatedProductsForm.LoadRelatedProductsGrid Method

protected virtual void LoadRelatedProductsGrid(
List<T> RelatedProducts
);

See Also

RelatedProductsForm Class | Aptify.Applications.OrderEntry Namespace


RelatedProductsForm.OnAddRelatedProductToOrder Method

protected virtual void OnAddRelatedProductToOrder(
RelatedProductEventArgs e
);

See Also

RelatedProductsForm Class | Aptify.Applications.OrderEntry Namespace


RelatedProductsForm.RelatedProductsCellButtonClick Method

protected virtual void RelatedProductsCellButtonClick(
Object sender,
RowColEventArgs e
);

See Also

RelatedProductsForm Class | Aptify.Applications.OrderEntry Namespace


RelatedProductsForm.RelatedProductsMouseClick Method

protected virtual void RelatedProductsMouseClick(
Object sender,
MouseEventArgs e
);

See Also

RelatedProductsForm Class | Aptify.Applications.OrderEntry Namespace


RelatedProductsForm.RelatedProductsMouseHoverCell Method

protected virtual void RelatedProductsMouseHoverCell(
Object sender,
EventArgs e
);

See Also

RelatedProductsForm Class | Aptify.Applications.OrderEntry Namespace


RelatedProductsForm.ShowRelatedProducts Method

public virtual void ShowRelatedProducts(
IWin32Window owner,
Point Position
);

Implements

IRelatedProductsUI.

See Also

RelatedProductsForm Class | Aptify.Applications.OrderEntry Namespace


RelatedProductsForm Events

The events of the RelatedProductsForm class are listed below. For a complete list of RelatedProductsForm class members, see the RelatedProductsForm Members topic.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AddRelatedProductToOrder |
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
UserClosedRelatedProductsUI |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

RelatedProductsForm Class | Aptify.Applications.OrderEntry Namespace


RelatedProductsForm.IRelatedProductsUI.AddRelatedProductToOrderEventHandler Event

public event IRelatedProductsUI.AddRelatedProductToOrderEventHandler AddRelatedProductToOrder;

Event Data

The event handler receives an argument of type RelatedProductEventArgs containing data related to this event. The following RelatedProductEventArgs properties provide information specific to this event.

Property | Description
OrderLine |
ProductID |
ProductName |
Quantity |

Implements

IRelatedProductsUI.

See Also

RelatedProductsForm Class | Aptify.Applications.OrderEntry Namespace


RelatedProductsForm.IRelatedProductsUI.UserClosedRelatedProductsUIEventHandler Event

public event IRelatedProductsUI.UserClosedRelatedProductsUIEventHandler UserClosedRelatedProductsUI;

Implements

IRelatedProductsUI.

See Also

RelatedProductsForm Class | Aptify.Applications.OrderEntry Namespace


SalesTaxAmount Class

For a list of all members of this type, see SalesTaxAmount Members.

System.Object
SalesTaxAmount

public class SalesTaxAmount

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

SalesTaxAmount Members | Aptify.Applications.OrderEntry Namespace


SalesTaxAmount Members

SalesTaxAmount overview

Public Instance Constructors

SalesTaxAmount Constructor

Public Instance Properties

InclusiveTaxAmount
InclusiveTaxAmountForSubTotal
InclusiveTaxAmountUnresolved
SalesTaxRateID
TaxAmount

Public Instance Methods

AddTaxAmount |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
RoundAmounts |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SalesTaxAmount Class | Aptify.Applications.OrderEntry Namespace


SalesTaxAmount Constructor

public SalesTaxAmount(
Int64 SalesTaxRateID
);

See Also

SalesTaxAmount Class | Aptify.Applications.OrderEntry Namespace


SalesTaxAmount Properties

The properties of the SalesTaxAmount class are listed below. For a complete list of SalesTaxAmount class members, see the SalesTaxAmount Members topic.

Public Instance Properties

InclusiveTaxAmount
InclusiveTaxAmountForSubTotal
InclusiveTaxAmountUnresolved
SalesTaxRateID
TaxAmount

See Also

SalesTaxAmount Class | Aptify.Applications.OrderEntry Namespace


InclusiveTaxAmount Property

Aptify 5.0 Software Development Kit (SDK)

SalesTaxAmount.InclusiveTaxAmount Property

public Decimal InclusiveTaxAmount {get;}

See Also

SalesTaxAmount Class | Aptify.Applications.OrderEntry Namespace


InclusiveTaxAmountForSubTotal Property

Aptify 5.0 Software Development Kit (SDK)

SalesTaxAmount.InclusiveTaxAmountForSubTotal Property

public Decimal InclusiveTaxAmountForSubTotal {get;}

See Also

SalesTaxAmount Class | Aptify.Applications.OrderEntry Namespace


InclusiveTaxAmountUnresolved Property

Aptify 5.0 Software Development Kit (SDK)

SalesTaxAmount.InclusiveTaxAmountUnresolved Property

public Decimal InclusiveTaxAmountUnresolved {get; set;}

See Also

SalesTaxAmount Class | Aptify.Applications.OrderEntry Namespace


SalesTaxRateID Property

Aptify 5.0 Software Development Kit (SDK)

SalesTaxAmount.SalesTaxRateID Property

public Int64 SalesTaxRateID {get;}

See Also

SalesTaxAmount Class | Aptify.Applications.OrderEntry Namespace


TaxAmount Property

Aptify 5.0 Software Development Kit (SDK)

SalesTaxAmount.TaxAmount Property

public Decimal TaxAmount {get;}

See Also

SalesTaxAmount Class | Aptify.Applications.OrderEntry Namespace


SalesTaxAmount Methods

The methods of the SalesTaxAmount class are listed below. For a complete list of SalesTaxAmount class members, see the SalesTaxAmount Members topic.

Public Instance Methods

AddTaxAmount |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
RoundAmounts |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SalesTaxAmount Class | Aptify.Applications.OrderEntry Namespace


SalesTaxAmount.AddTaxAmount Method

public void AddTaxAmount(
Decimal TaxAmount,
Boolean Inclusive,
Boolean ReflectInSubtotal
);

See Also

SalesTaxAmount Class | Aptify.Applications.OrderEntry Namespace


SalesTaxAmount.RoundAmounts Method

public void RoundAmounts(
Int32 NumberOfDigitsAfterDecimal
);

See Also

SalesTaxAmount Class | Aptify.Applications.OrderEntry Namespace


SalesTaxRate Class

For a list of all members of this type, see SalesTaxRate Members.

System.Object
SalesTaxRate

public class SalesTaxRate

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

SalesTaxRate Members | Aptify.Applications.OrderEntry Namespace


SalesTaxRate Members

SalesTaxRate overview

Public Instance Constructors

SalesTaxRate Constructor

Public Instance Properties

ApplyOrderLinesFilterRule
ApplyOrderShipmentsFilterRule
DisplayName
EndDate
Exempt
ID
IncludeParentTaxesInCalculation
Name
OrderLinesFilterRuleID
OrderShipmentsFilterRuleID
OverrideParentTaxRates
Qualified
Rate
StartDate
StopAccumulation
TaxJurisdictionID
TaxOnHandling
TaxOnShipping

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SalesTaxRate Class | Aptify.Applications.OrderEntry Namespace


SalesTaxRate Constructor

public SalesTaxRate(
DataRow row
);

See Also

SalesTaxRate Class | Aptify.Applications.OrderEntry Namespace


SalesTaxRate Properties

The properties of the SalesTaxRate class are listed below. For a complete list of SalesTaxRate class members, see the SalesTaxRate Members topic.

Public Instance Properties

ApplyOrderLinesFilterRule
ApplyOrderShipmentsFilterRule
DisplayName
EndDate
Exempt
ID
IncludeParentTaxesInCalculation
Name
OrderLinesFilterRuleID
OrderShipmentsFilterRuleID
OverrideParentTaxRates
Qualified
Rate
StartDate
StopAccumulation
TaxJurisdictionID
TaxOnHandling
TaxOnShipping

See Also

SalesTaxRate Class | Aptify.Applications.OrderEntry Namespace


ApplyOrderLinesFilterRule Property

Aptify 5.0 Software Development Kit (SDK)

SalesTaxRate.ApplyOrderLinesFilterRule Property

public Boolean ApplyOrderLinesFilterRule {get;}

See Also

SalesTaxRate Class | Aptify.Applications.OrderEntry Namespace


ApplyOrderShipmentsFilterRule Property

Aptify 5.0 Software Development Kit (SDK)

SalesTaxRate.ApplyOrderShipmentsFilterRule Property

public Boolean ApplyOrderShipmentsFilterRule {get;}

See Also

SalesTaxRate Class | Aptify.Applications.OrderEntry Namespace


DisplayName Property

Aptify 5.0 Software Development Kit (SDK)

SalesTaxRate.DisplayName Property

public String DisplayName {get;}

See Also

SalesTaxRate Class | Aptify.Applications.OrderEntry Namespace


EndDate Property

Aptify 5.0 Software Development Kit (SDK)

SalesTaxRate.EndDate Property

public DateTime EndDate {get;}

See Also

SalesTaxRate Class | Aptify.Applications.OrderEntry Namespace


Exempt Property

Aptify 5.0 Software Development Kit (SDK)

SalesTaxRate.Exempt Property

public Boolean Exempt {get; set;}

See Also

SalesTaxRate Class | Aptify.Applications.OrderEntry Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

SalesTaxRate.ID Property

public Int64 ID {get;}

See Also

SalesTaxRate Class | Aptify.Applications.OrderEntry Namespace


IncludeParentTaxesInCalculation Property

Aptify 5.0 Software Development Kit (SDK)

SalesTaxRate.IncludeParentTaxesInCalculation Property

public Boolean IncludeParentTaxesInCalculation {get;}

See Also

SalesTaxRate Class | Aptify.Applications.OrderEntry Namespace


Name Property

Aptify 5.0 Software Development Kit (SDK)

SalesTaxRate.Name Property

public String Name {get;}

See Also

SalesTaxRate Class | Aptify.Applications.OrderEntry Namespace


OrderLinesFilterRuleID Property

Aptify 5.0 Software Development Kit (SDK)

SalesTaxRate.OrderLinesFilterRuleID Property

public Int64 OrderLinesFilterRuleID {get;}

See Also

SalesTaxRate Class | Aptify.Applications.OrderEntry Namespace


OrderShipmentsFilterRuleID Property

Aptify 5.0 Software Development Kit (SDK)

SalesTaxRate.OrderShipmentsFilterRuleID Property

public Int64 OrderShipmentsFilterRuleID {get;}

See Also

SalesTaxRate Class | Aptify.Applications.OrderEntry Namespace


OverrideParentTaxRates Property

Aptify 5.0 Software Development Kit (SDK)

SalesTaxRate.OverrideParentTaxRates Property

public Boolean OverrideParentTaxRates {get;}

See Also

SalesTaxRate Class | Aptify.Applications.OrderEntry Namespace


Qualified Property

Aptify 5.0 Software Development Kit (SDK)

SalesTaxRate.Qualified Property

public Boolean Qualified {get; set;}

See Also

SalesTaxRate Class | Aptify.Applications.OrderEntry Namespace


Rate Property

Aptify 5.0 Software Development Kit (SDK)

SalesTaxRate.Rate Property

public Decimal Rate {get;}

See Also

SalesTaxRate Class | Aptify.Applications.OrderEntry Namespace


StartDate Property

Aptify 5.0 Software Development Kit (SDK)

SalesTaxRate.StartDate Property

public DateTime StartDate {get;}

See Also

SalesTaxRate Class | Aptify.Applications.OrderEntry Namespace


StopAccumulation Property

Aptify 5.0 Software Development Kit (SDK)

SalesTaxRate.StopAccumulation Property

public Boolean StopAccumulation {get;}

See Also

SalesTaxRate Class | Aptify.Applications.OrderEntry Namespace


TaxJurisdictionID Property

Aptify 5.0 Software Development Kit (SDK)

SalesTaxRate.TaxJurisdictionID Property

public Int64 TaxJurisdictionID {get;}

See Also

SalesTaxRate Class | Aptify.Applications.OrderEntry Namespace


TaxOnHandling Property

Aptify 5.0 Software Development Kit (SDK)

SalesTaxRate.TaxOnHandling Property

public Boolean TaxOnHandling {get;}

See Also

SalesTaxRate Class | Aptify.Applications.OrderEntry Namespace


TaxOnShipping Property

Aptify 5.0 Software Development Kit (SDK)

SalesTaxRate.TaxOnShipping Property

public Boolean TaxOnShipping {get;}

See Also

SalesTaxRate Class | Aptify.Applications.OrderEntry Namespace


SalesTaxRateCache Class

For a list of all members of this type, see SalesTaxRateCache Members.

System.Object
SalesTaxRateCache

public class SalesTaxRateCache

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

SalesTaxRateCache Members | Aptify.Applications.OrderEntry Namespace


SalesTaxRateCache Members

SalesTaxRateCache overview

Public Static Methods

Instance

Public Instance Properties

SalesTaxRate

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SalesTaxRateCache Class | Aptify.Applications.OrderEntry Namespace


SalesTaxRateCache Properties

The properties of the SalesTaxRateCache class are listed below. For a complete list of SalesTaxRateCache class members, see the SalesTaxRateCache Members topic.

Public Instance Properties

SalesTaxRate

See Also

SalesTaxRateCache Class | Aptify.Applications.OrderEntry Namespace


SalesTaxRate Property

Aptify 5.0 Software Development Kit (SDK)

SalesTaxRateCache.SalesTaxRate Property

public SalesTaxRate this[
Int64 SalesTaxRateID
] {get;}

See Also

SalesTaxRateCache Class | Aptify.Applications.OrderEntry Namespace


SalesTaxRateCache Methods

The methods of the SalesTaxRateCache class are listed below. For a complete list of SalesTaxRateCache class members, see the SalesTaxRateCache Members topic.

Public Static Methods

Instance

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SalesTaxRateCache Class | Aptify.Applications.OrderEntry Namespace


SalesTaxRateCache.Instance Method

public static SalesTaxRateCache Instance(
AptifyApplication Application
);

See Also

SalesTaxRateCache Class | Aptify.Applications.OrderEntry Namespace


SalesTaxRateGLAccountCache Class

Caches Sales Tax Rate GL Account information Shared, on-demand cache.

For a list of all members of this type, see SalesTaxRateGLAccountCache Members.

System.Object
SalesTaxRateGLAccountCache

public class SalesTaxRateGLAccountCache

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

SalesTaxRateGLAccountCache Members | Aptify.Applications.OrderEntry Namespace


SalesTaxRateGLAccountCache Members

SalesTaxRateGLAccountCache overview

Public Static Methods

Instance

Public Instance Constructors

SalesTaxRateGLAccountCache Constructor

Public Instance Properties

DefaultARAccount |
SalesTaxGLAccounts | This method will return a SalesTaxRateGLAccounts object from the cache. If the cache doesn't contain a SalesTaxRateGLAccounts object, the information will be retrieved from the database and used to populate a SalesTaxRateGLAccounts object which will be added to the cache and returned to the caller.

Public Instance Methods

Clear | Clears the Sales Tax Rate GL Accounts cache.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
RemoveSalesTaxRateFromCache |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SalesTaxRateGLAccountCache Class | Aptify.Applications.OrderEntry Namespace


SalesTaxRateGLAccountCache Constructor

public SalesTaxRateGLAccountCache(
AptifyApplication Application
);

See Also

SalesTaxRateGLAccountCache Class | Aptify.Applications.OrderEntry Namespace


SalesTaxRateGLAccountCache Properties

The properties of the SalesTaxRateGLAccountCache class are listed below. For a complete list of SalesTaxRateGLAccountCache class members, see the SalesTaxRateGLAccountCache Members topic.

Public Instance Properties

DefaultARAccount |
SalesTaxGLAccounts | This method will return a SalesTaxRateGLAccounts object from the cache. If the cache doesn't contain a SalesTaxRateGLAccounts object, the information will be retrieved from the database and used to populate a SalesTaxRateGLAccounts object which will be added to the cache and returned to the caller.

See Also

SalesTaxRateGLAccountCache Class | Aptify.Applications.OrderEntry Namespace


DefaultARAccount Property

Aptify 5.0 Software Development Kit (SDK)

SalesTaxRateGLAccountCache.DefaultARAccount Property

public virtual String DefaultARAccount {get;}

See Also

SalesTaxRateGLAccountCache Class | Aptify.Applications.OrderEntry Namespace


SalesTaxGLAccounts Property

Aptify 5.0 Software Development Kit (SDK)

SalesTaxRateGLAccountCache.SalesTaxGLAccounts Property

This method will return a SalesTaxRateGLAccounts object from the cache. If the cache doesn't contain a SalesTaxRateGLAccounts object, the information will be retrieved from the database and used to populate a SalesTaxRateGLAccounts object which will be added to the cache and returned to the caller.

public virtual SalesTaxRateGLAccounts this[
Int64 SalesTaxRateID,
Boolean ForceRefresh
] {get;}

Parameters

SalesTaxRateID
ForceRefresh

Property Value

Remarks

See Also

SalesTaxRateGLAccountCache Class | Aptify.Applications.OrderEntry Namespace


SalesTaxRateGLAccountCache Methods

The methods of the SalesTaxRateGLAccountCache class are listed below. For a complete list of SalesTaxRateGLAccountCache class members, see the SalesTaxRateGLAccountCache Members topic.

Public Static Methods

Instance

Public Instance Methods

Clear | Clears the Sales Tax Rate GL Accounts cache.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
RemoveSalesTaxRateFromCache |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SalesTaxRateGLAccountCache Class | Aptify.Applications.OrderEntry Namespace


SalesTaxRateGLAccountCache.Clear Method

Clears the Sales Tax Rate GL Accounts cache.

public void Clear();

Remarks

See Also

SalesTaxRateGLAccountCache Class | Aptify.Applications.OrderEntry Namespace


SalesTaxRateGLAccountCache.Instance Method

public static SalesTaxRateGLAccountCache Instance(
AptifyApplication Application
);

See Also

SalesTaxRateGLAccountCache Class | Aptify.Applications.OrderEntry Namespace


SalesTaxRateGLAccountCache.RemoveSalesTaxRateFromCache Method

public void RemoveSalesTaxRateFromCache(
Int64 SalesTaxRateID
);

See Also

SalesTaxRateGLAccountCache Class | Aptify.Applications.OrderEntry Namespace


SalesTaxRateGLAccounts Class

For a list of all members of this type, see SalesTaxRateGLAccounts Members.

System.Object
SalesTaxRateGLAccounts

public class SalesTaxRateGLAccounts

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

SalesTaxRateGLAccounts Members | Aptify.Applications.OrderEntry Namespace


SalesTaxRateGLAccounts Members

SalesTaxRateGLAccounts overview

Public Instance Constructors

SalesTaxRateGLAccounts Constructor

Public Instance Properties

ID
IsCashBasis
Payable
Receivable
Unearned

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SalesTaxRateGLAccounts Class | Aptify.Applications.OrderEntry Namespace


SalesTaxRateGLAccounts Constructor

public SalesTaxRateGLAccounts(
DataRow row
);

See Also

SalesTaxRateGLAccounts Class | Aptify.Applications.OrderEntry Namespace


SalesTaxRateGLAccounts Properties

The properties of the SalesTaxRateGLAccounts class are listed below. For a complete list of SalesTaxRateGLAccounts class members, see the SalesTaxRateGLAccounts Members topic.

Public Instance Properties

ID
IsCashBasis
Payable
Receivable
Unearned

See Also

SalesTaxRateGLAccounts Class | Aptify.Applications.OrderEntry Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

SalesTaxRateGLAccounts.ID Property

public Int64 ID {get;}

See Also

SalesTaxRateGLAccounts Class | Aptify.Applications.OrderEntry Namespace


IsCashBasis Property

Aptify 5.0 Software Development Kit (SDK)

SalesTaxRateGLAccounts.IsCashBasis Property

public Boolean IsCashBasis {get;}

See Also

SalesTaxRateGLAccounts Class | Aptify.Applications.OrderEntry Namespace


Payable Property

Aptify 5.0 Software Development Kit (SDK)

SalesTaxRateGLAccounts.Payable Property

public String Payable {get;}

See Also

SalesTaxRateGLAccounts Class | Aptify.Applications.OrderEntry Namespace


Receivable Property

Aptify 5.0 Software Development Kit (SDK)

SalesTaxRateGLAccounts.Receivable Property

public String Receivable {get;}

See Also

SalesTaxRateGLAccounts Class | Aptify.Applications.OrderEntry Namespace


Unearned Property

Aptify 5.0 Software Development Kit (SDK)

SalesTaxRateGLAccounts.Unearned Property

public String Unearned {get;}

See Also

SalesTaxRateGLAccounts Class | Aptify.Applications.OrderEntry Namespace


SelectCancellationItemDialog Class

For a list of all members of this type, see SelectCancellationItemDialog Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
SelectCancellationItemDialog

public class SelectCancellationItemDialog : Form

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrderLineControl (in AptifyOrderLineControl.dll)

See Also

SelectCancellationItemDialog Members | Aptify.Applications.OrderEntry Namespace


SelectCancellationItemDialog Members

SelectCancellationItemDialog overview

Public Instance Constructors

SelectCancellationItemDialog Constructor Initializes a new instance of the SelectCancellationItemDialog class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UserCredentials |
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectCancellationItem |
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

CancelQuantityCaption
CurrencyFormat
DiscountCaption
m_oOrigOrder
m_OrderGE
m_oUC
OriginalOrderDetailIDCaption
OriginalOrderIDCaption
PriceCaption
ProductIDCaption
QuantityAlreadyCancelledCaption
QuantityAvailableForCancellationCaption
QuantityShippedCaption

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
ClickOK |
ConfigureGrid | Configures the grid that displays the Original Order Lines. This method clears the grid and creates the columns in the grid.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
DisplayOrderLineDetail | Overloaded. Displays a read-only dialog of the Order Line Viewer. Retrieves the Original Order Detail ID from the currently selected grid row.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
GridRowDoubleClicked |
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
LoadGrid | Loads the grid with the list of OrderCancellationDetail objects.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

SelectCancellationItemDialog Class | Aptify.Applications.OrderEntry Namespace


SelectCancellationItemDialog Constructor

Initializes a new instance of the SelectCancellationItemDialog class.

public SelectCancellationItemDialog();

See Also

SelectCancellationItemDialog Class | Aptify.Applications.OrderEntry Namespace


SelectCancellationItemDialog Fields

The fields of the SelectCancellationItemDialog class are listed below. For a complete list of SelectCancellationItemDialog class members, see the SelectCancellationItemDialog Members topic.

Protected Instance Fields

CancelQuantityCaption
CurrencyFormat
DiscountCaption
m_oOrigOrder
m_OrderGE
m_oUC
OriginalOrderDetailIDCaption
OriginalOrderIDCaption
PriceCaption
ProductIDCaption
QuantityAlreadyCancelledCaption
QuantityAvailableForCancellationCaption
QuantityShippedCaption

See Also

SelectCancellationItemDialog Class | Aptify.Applications.OrderEntry Namespace


SelectCancellationItemDialog.CancelQuantityCaption Field

protected CancelQuantityCaption CancelQuantityCaption;

See Also

SelectCancellationItemDialog Class | Aptify.Applications.OrderEntry Namespace


SelectCancellationItemDialog.CurrencyFormat Field

protected CurrencyFormat CurrencyFormat;

See Also

SelectCancellationItemDialog Class | Aptify.Applications.OrderEntry Namespace


SelectCancellationItemDialog.DiscountCaption Field

protected DiscountCaption DiscountCaption;

See Also

SelectCancellationItemDialog Class | Aptify.Applications.OrderEntry Namespace


SelectCancellationItemDialog.m_oOrigOrder Field

protected m_oOrigOrder m_oOrigOrder;

See Also

SelectCancellationItemDialog Class | Aptify.Applications.OrderEntry Namespace


SelectCancellationItemDialog.m_OrderGE Field

protected m_OrderGE m_OrderGE;

See Also

SelectCancellationItemDialog Class | Aptify.Applications.OrderEntry Namespace


SelectCancellationItemDialog.m_oUC Field

protected m_oUC m_oUC;

See Also

SelectCancellationItemDialog Class | Aptify.Applications.OrderEntry Namespace


SelectCancellationItemDialog.OriginalOrderDetailIDCaption Field

protected OriginalOrderDetailIDCaption OriginalOrderDetailIDCaption;

See Also

SelectCancellationItemDialog Class | Aptify.Applications.OrderEntry Namespace


SelectCancellationItemDialog.OriginalOrderIDCaption Field

protected OriginalOrderIDCaption OriginalOrderIDCaption;

See Also

SelectCancellationItemDialog Class | Aptify.Applications.OrderEntry Namespace


SelectCancellationItemDialog.PriceCaption Field

protected PriceCaption PriceCaption;

See Also

SelectCancellationItemDialog Class | Aptify.Applications.OrderEntry Namespace


SelectCancellationItemDialog.ProductIDCaption Field

protected ProductIDCaption ProductIDCaption;

See Also

SelectCancellationItemDialog Class | Aptify.Applications.OrderEntry Namespace


SelectCancellationItemDialog.QuantityAlreadyCancelledCaption Field

protected QuantityAlreadyCancelledCaption QuantityAlreadyCancelledCaption;

See Also

SelectCancellationItemDialog Class | Aptify.Applications.OrderEntry Namespace


SelectCancellationItemDialog.QuantityAvailableForCancellationCaption Field

protected QuantityAvailableForCancellationCaption QuantityAvailableForCancellationCaption;

See Also

SelectCancellationItemDialog Class | Aptify.Applications.OrderEntry Namespace


SelectCancellationItemDialog.QuantityShippedCaption Field

protected QuantityShippedCaption QuantityShippedCaption;

See Also

SelectCancellationItemDialog Class | Aptify.Applications.OrderEntry Namespace


SelectCancellationItemDialog Properties

The properties of the SelectCancellationItemDialog class are listed below. For a complete list of SelectCancellationItemDialog class members, see the SelectCancellationItemDialog Members topic.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UserCredentials |
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

SelectCancellationItemDialog Class | Aptify.Applications.OrderEntry Namespace


UserCredentials Property

Aptify 5.0 Software Development Kit (SDK)

SelectCancellationItemDialog.UserCredentials Property

public UserCredentials UserCredentials {get; set;}

See Also

SelectCancellationItemDialog Class | Aptify.Applications.OrderEntry Namespace


SelectCancellationItemDialog Methods

The methods of the SelectCancellationItemDialog class are listed below. For a complete list of SelectCancellationItemDialog class members, see the SelectCancellationItemDialog Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectCancellationItem |
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
ClickOK |
ConfigureGrid | Configures the grid that displays the Original Order Lines. This method clears the grid and creates the columns in the grid.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
DisplayOrderLineDetail | Overloaded. Displays a read-only dialog of the Order Line Viewer. Retrieves the Original Order Detail ID from the currently selected grid row.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
GridRowDoubleClicked |
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
LoadGrid | Loads the grid with the list of OrderCancellationDetail objects.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

SelectCancellationItemDialog Class | Aptify.Applications.OrderEntry Namespace


SelectCancellationItemDialog.ApplySkin Method

protected virtual void ApplySkin();

See Also

SelectCancellationItemDialog Class | Aptify.Applications.OrderEntry Namespace


SelectCancellationItemDialog.ClickOK Method

protected virtual void ClickOK();

See Also

SelectCancellationItemDialog Class | Aptify.Applications.OrderEntry Namespace


SelectCancellationItemDialog.ConfigureGrid Method

Configures the grid that displays the Original Order Lines. This method clears the grid and creates the columns in the grid.

protected virtual void ConfigureGrid();

Remarks

See Also

SelectCancellationItemDialog Class | Aptify.Applications.OrderEntry Namespace


DisplayOrderLineDetail Method

Aptify 5.0 Software Development Kit (SDK)

SelectCancellationItemDialog.DisplayOrderLineDetail Method

Displays a read-only dialog of the Order Line Viewer. Retrieves the Original Order Detail ID from the currently selected grid row.

Overload List

Displays a read-only dialog of the Order Line Viewer. Retrieves the Original Order Detail ID from the currently selected grid row.

protected virtual void DisplayOrderLineDetail();

protected virtual void DisplayOrderLineDetail(Int32);

Displays a read-only dialog of the Order Line Viewer.

protected virtual void DisplayOrderLineDetail(Int64);

See Also

SelectCancellationItemDialog Class | Aptify.Applications.OrderEntry Namespace


SelectCancellationItemDialog.DisplayOrderLineDetail Method ()

Displays a read-only dialog of the Order Line Viewer. Retrieves the Original Order Detail ID from the currently selected grid row.

protected virtual void DisplayOrderLineDetail();

Remarks

See Also

SelectCancellationItemDialog Class | Aptify.Applications.OrderEntry Namespace | SelectCancellationItemDialog.DisplayOrderLineDetail Overload List


SelectCancellationItemDialog.DisplayOrderLineDetail Method (Int32)

protected virtual void DisplayOrderLineDetail(
Int32 Row
);

See Also

SelectCancellationItemDialog Class | Aptify.Applications.OrderEntry Namespace | SelectCancellationItemDialog.DisplayOrderLineDetail Overload List


SelectCancellationItemDialog.DisplayOrderLineDetail Method (Int64)

Displays a read-only dialog of the Order Line Viewer.

protected virtual void DisplayOrderLineDetail(
Int64 OriginalOrderDetailID
);

Remarks

See Also

SelectCancellationItemDialog Class | Aptify.Applications.OrderEntry Namespace | SelectCancellationItemDialog.DisplayOrderLineDetail Overload List


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

SelectCancellationItemDialog.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

SelectCancellationItemDialog Class | Aptify.Applications.OrderEntry Namespace


SelectCancellationItemDialog.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

SelectCancellationItemDialog Class | Aptify.Applications.OrderEntry Namespace | SelectCancellationItemDialog.Dispose Overload List


SelectCancellationItemDialog.GridRowDoubleClicked Method

protected virtual void GridRowDoubleClicked(
Int32 Row
);

See Also

SelectCancellationItemDialog Class | Aptify.Applications.OrderEntry Namespace


SelectCancellationItemDialog.LoadGrid Method

Loads the grid with the list of OrderCancellationDetail objects.

protected virtual void LoadGrid(
List<T> CancellationItems
);

Parameters

CancellationItems

Remarks

See Also

SelectCancellationItemDialog Class | Aptify.Applications.OrderEntry Namespace


SelectCancellationItemDialog.SelectCancellationItem Method

public virtual OrderCancellationDetail SelectCancellationItem(
List<T> CancellationItems,
Int64 ProductID,
Decimal Quantity,
OrdersEntity OrderGE,
IWin32Window owner
);

See Also

SelectCancellationItemDialog Class | Aptify.Applications.OrderEntry Namespace


ShipmentTypeCache Class

Caches Shipment Types information. Shared, on-demand cache.

For a list of all members of this type, see ShipmentTypeCache Members.

System.Object
ShipmentTypeCache

public class ShipmentTypeCache

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyShippingCalculator (in AptifyShippingCalculator.dll)

See Also

ShipmentTypeCache Members | Aptify.Applications.OrderEntry Namespace


ShipmentTypeCache Members

ShipmentTypeCache overview

Public Static Methods

Instance

Public Instance Properties

ShipmentType This method will either return a ShipmentTypeData object from the cache. If the cache doesn't contain a ShipmentTypeData object, the information will be retrieved from the database and used to populate a ShipmentTypeData object which will be added to the cache and returned to the caller.

Public Instance Methods

Clear | Clears the Shipment Types cache.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetShipmentTypeGroupings |
GetShipmentTypeMatrixByCurrencyType | Overloaded.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ShipmentTypeCache Class | Aptify.Applications.OrderEntry Namespace


ShipmentTypeCache Properties

The properties of the ShipmentTypeCache class are listed below. For a complete list of ShipmentTypeCache class members, see the ShipmentTypeCache Members topic.

Public Instance Properties

ShipmentType This method will either return a ShipmentTypeData object from the cache. If the cache doesn't contain a ShipmentTypeData object, the information will be retrieved from the database and used to populate a ShipmentTypeData object which will be added to the cache and returned to the caller.

See Also

ShipmentTypeCache Class | Aptify.Applications.OrderEntry Namespace


ShipmentType Property

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeCache.ShipmentType Property

This method will either return a ShipmentTypeData object from the cache. If the cache doesn't contain a ShipmentTypeData object, the information will be retrieved from the database and used to populate a ShipmentTypeData object which will be added to the cache and returned to the caller.

public ShipmentTypeData this[
Int32 ShipmentTypeID
] {get;}

Parameters

ShipmentTypeID

Property Value

Remarks

See Also

ShipmentTypeCache Class | Aptify.Applications.OrderEntry Namespace


ShipmentTypeCache Methods

The methods of the ShipmentTypeCache class are listed below. For a complete list of ShipmentTypeCache class members, see the ShipmentTypeCache Members topic.

Public Static Methods

Instance

Public Instance Methods

Clear | Clears the Shipment Types cache.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetShipmentTypeGroupings |
GetShipmentTypeMatrixByCurrencyType | Overloaded.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ShipmentTypeCache Class | Aptify.Applications.OrderEntry Namespace


ShipmentTypeCache.Clear Method

Clears the Shipment Types cache.

public void Clear();

Remarks

See Also

ShipmentTypeCache Class | Aptify.Applications.OrderEntry Namespace


ShipmentTypeCache.GetShipmentTypeGroupings Method

public List<T> GetShipmentTypeGroupings(
ShipmentTypeData ShipmentType
);

See Also

ShipmentTypeCache Class | Aptify.Applications.OrderEntry Namespace


GetShipmentTypeMatrixByCurrencyType Method

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeCache.GetShipmentTypeMatrixByCurrencyType Method

Overload List

public List<T> GetShipmentTypeMatrixByCurrencyType(ShipmentTypeData,Int32);

public List<T> GetShipmentTypeMatrixByCurrencyType(ShipmentTypeData,Int32,ShipmentTypeMatrixData);

See Also

ShipmentTypeCache Class | Aptify.Applications.OrderEntry Namespace


ShipmentTypeCache.GetShipmentTypeMatrixByCurrencyType Method (ShipmentTypeData, Int32)

public List<T> GetShipmentTypeMatrixByCurrencyType(
ShipmentTypeData ShipmentType,
Int32 CurrencyTypeID
);

See Also

ShipmentTypeCache Class | Aptify.Applications.OrderEntry Namespace | ShipmentTypeCache.GetShipmentTypeMatrixByCurrencyType Overload List


ShipmentTypeCache.GetShipmentTypeMatrixByCurrencyType Method (ShipmentTypeData, Int32, ShipmentTypeMatrixData)

public List<T> GetShipmentTypeMatrixByCurrencyType(
ShipmentTypeData ShipmentType,
Int32 CurrencyTypeID,
ShipmentTypeMatrixData ParentMatrix
);

See Also

ShipmentTypeCache Class | Aptify.Applications.OrderEntry Namespace | ShipmentTypeCache.GetShipmentTypeMatrixByCurrencyType Overload List


ShipmentTypeCache.Instance Method

public static ShipmentTypeCache Instance(
AptifyApplication Application
);

See Also

ShipmentTypeCache Class | Aptify.Applications.OrderEntry Namespace


ShipmentTypeCalculationType Enumeration

public enum ShipmentTypeCalculationType

Members

Member Name | Description
Standard |
PlugIn |

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyShippingCalculator (in AptifyShippingCalculator.dll)

See Also

Aptify.Applications.OrderEntry Namespace


ShipmentTypeData Class

Stores information about a Shipment Types record. Used by the ShipmentTypeCache.

For a list of all members of this type, see ShipmentTypeData Members.

System.Object
ShipmentTypeData

public class ShipmentTypeData

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyShippingCalculator (in AptifyShippingCalculator.dll)

See Also

ShipmentTypeData Members | Aptify.Applications.OrderEntry Namespace


ShipmentTypeData Members

ShipmentTypeData overview

Public Instance Constructors

ShipmentTypeData Constructor

Public Instance Properties

CalculationType |
CalculationTypeText |
Description |
GLExpenseAccount |
GLIncomeAccount |
GLPayableAccount |
GLReceivableAccount |
GLUnearnedAccount |
Groupings | Returns the list of ShipmentTypeGrouping objects for the current Shipment Type.
ID |
Matrix | Returns the list of top level Shipment Type Matrix records for the current Shipment Type and filtered records for the current Shipment Type.
Name |
PackageTrackingURL |
RevenueRecognition |
RevenueRecognitionText |
ShipmentTypeCalcAssemblyName |
ShipmentTypeCalcClassName |
ShipmentTypeCalcObject |
Shipper |
ShipperID |
WebServiceURL |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ShipmentTypeData Class | Aptify.Applications.OrderEntry Namespace


ShipmentTypeData Constructor

public ShipmentTypeData(
ShipmentTypeCache CacheInstance,
DataRow rowShipmentType
);

See Also

ShipmentTypeData Class | Aptify.Applications.OrderEntry Namespace


ShipmentTypeData Properties

The properties of the ShipmentTypeData class are listed below. For a complete list of ShipmentTypeData class members, see the ShipmentTypeData Members topic.

Public Instance Properties

CalculationType |
CalculationTypeText |
Description |
GLExpenseAccount |
GLIncomeAccount |
GLPayableAccount |
GLReceivableAccount |
GLUnearnedAccount |
Groupings | Returns the list of ShipmentTypeGrouping objects for the current Shipment Type.
ID |
Matrix | Returns the list of top level Shipment Type Matrix records for the current Shipment Type and filtered records for the current Shipment Type.
Name |
PackageTrackingURL |
RevenueRecognition |
RevenueRecognitionText |
ShipmentTypeCalcAssemblyName |
ShipmentTypeCalcClassName |
ShipmentTypeCalcObject |
Shipper |
ShipperID |
WebServiceURL |

See Also

ShipmentTypeData Class | Aptify.Applications.OrderEntry Namespace


CalculationType Property

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeData.CalculationType Property

public ShipmentTypeCalculationType CalculationType {get;}

See Also

ShipmentTypeData Class | Aptify.Applications.OrderEntry Namespace


CalculationTypeText Property

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeData.CalculationTypeText Property

public String CalculationTypeText {get;}

See Also

ShipmentTypeData Class | Aptify.Applications.OrderEntry Namespace


Description Property

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeData.Description Property

public String Description {get;}

See Also

ShipmentTypeData Class | Aptify.Applications.OrderEntry Namespace


GLExpenseAccount Property

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeData.GLExpenseAccount Property

public String GLExpenseAccount {get;}

See Also

ShipmentTypeData Class | Aptify.Applications.OrderEntry Namespace


GLIncomeAccount Property

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeData.GLIncomeAccount Property

public String GLIncomeAccount {get;}

See Also

ShipmentTypeData Class | Aptify.Applications.OrderEntry Namespace


GLPayableAccount Property

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeData.GLPayableAccount Property

public String GLPayableAccount {get;}

See Also

ShipmentTypeData Class | Aptify.Applications.OrderEntry Namespace


GLReceivableAccount Property

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeData.GLReceivableAccount Property

public String GLReceivableAccount {get;}

See Also

ShipmentTypeData Class | Aptify.Applications.OrderEntry Namespace


GLUnearnedAccount Property

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeData.GLUnearnedAccount Property

public String GLUnearnedAccount {get;}

See Also

ShipmentTypeData Class | Aptify.Applications.OrderEntry Namespace


Groupings Property

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeData.Groupings Property

Returns the list of ShipmentTypeGrouping objects for the current Shipment Type.

public List<T> Groupings {get;}

Property Value

Remarks

See Also

ShipmentTypeData Class | Aptify.Applications.OrderEntry Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeData.ID Property

public Int32 ID {get;}

See Also

ShipmentTypeData Class | Aptify.Applications.OrderEntry Namespace


Matrix Property

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeData.Matrix Property

Returns the list of top level Shipment Type Matrix records for the current Shipment Type and filtered records for the current Shipment Type.

public List<T> this[
Int32 CurrencyTypeID
] {get;}

Property Value

Remarks

See Also

ShipmentTypeData Class | Aptify.Applications.OrderEntry Namespace


Name Property

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeData.Name Property

public String Name {get;}

See Also

ShipmentTypeData Class | Aptify.Applications.OrderEntry Namespace


PackageTrackingURL Property

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeData.PackageTrackingURL Property

public String PackageTrackingURL {get;}

See Also

ShipmentTypeData Class | Aptify.Applications.OrderEntry Namespace


RevenueRecognition Property

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeData.RevenueRecognition Property

public ShipmentTypeRevenueRecognitionType RevenueRecognition {get;}

See Also

ShipmentTypeData Class | Aptify.Applications.OrderEntry Namespace


RevenueRecognitionText Property

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeData.RevenueRecognitionText Property

public String RevenueRecognitionText {get;}

See Also

ShipmentTypeData Class | Aptify.Applications.OrderEntry Namespace


ShipmentTypeCalcAssemblyName Property

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeData.ShipmentTypeCalcAssemblyName Property

public String ShipmentTypeCalcAssemblyName {get;}

See Also

ShipmentTypeData Class | Aptify.Applications.OrderEntry Namespace


ShipmentTypeCalcClassName Property

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeData.ShipmentTypeCalcClassName Property

public String ShipmentTypeCalcClassName {get;}

See Also

ShipmentTypeData Class | Aptify.Applications.OrderEntry Namespace


ShipmentTypeCalcObject Property

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeData.ShipmentTypeCalcObject Property

public String ShipmentTypeCalcObject {get;}

See Also

ShipmentTypeData Class | Aptify.Applications.OrderEntry Namespace


Shipper Property

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeData.Shipper Property

public String Shipper {get;}

See Also

ShipmentTypeData Class | Aptify.Applications.OrderEntry Namespace


ShipperID Property

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeData.ShipperID Property

public Int64 ShipperID {get;}

See Also

ShipmentTypeData Class | Aptify.Applications.OrderEntry Namespace


WebServiceURL Property

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeData.WebServiceURL Property

public String WebServiceURL {get;}

See Also

ShipmentTypeData Class | Aptify.Applications.OrderEntry Namespace


ShipmentTypeGLAccountCache Class

Caches Sales Tax Rate GL Account information Shared, on-demand cache.

For a list of all members of this type, see ShipmentTypeGLAccountCache Members.

System.Object
ShipmentTypeGLAccountCache

public class ShipmentTypeGLAccountCache

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

ShipmentTypeGLAccountCache Members | Aptify.Applications.OrderEntry Namespace


ShipmentTypeGLAccountCache Members

ShipmentTypeGLAccountCache overview

Public Static Methods

Instance

Public Instance Constructors

ShipmentTypeGLAccountCache Constructor

Public Instance Properties

DefaultARAccount |
ShipmentTypeGLAccounts | This method will return a ShipmentTypeGLAccounts object from the cache. If the cache doesn't contain a ShipmentTypeGLAccounts object, the information will be retrieved from the database and used to populate a ShipmentTypeGLAccounts object which will be added to the cache and returned to the caller.

Public Instance Methods

Clear | Clears the Shipment Types GL Accounts cache.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
RemoveShipmentTypeFromCache |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ShipmentTypeGLAccountCache Class | Aptify.Applications.OrderEntry Namespace


ShipmentTypeGLAccountCache Constructor

public ShipmentTypeGLAccountCache(
AptifyApplication Application
);

See Also

ShipmentTypeGLAccountCache Class | Aptify.Applications.OrderEntry Namespace


ShipmentTypeGLAccountCache Properties

The properties of the ShipmentTypeGLAccountCache class are listed below. For a complete list of ShipmentTypeGLAccountCache class members, see the ShipmentTypeGLAccountCache Members topic.

Public Instance Properties

DefaultARAccount |
ShipmentTypeGLAccounts | This method will return a ShipmentTypeGLAccounts object from the cache. If the cache doesn't contain a ShipmentTypeGLAccounts object, the information will be retrieved from the database and used to populate a ShipmentTypeGLAccounts object which will be added to the cache and returned to the caller.

See Also

ShipmentTypeGLAccountCache Class | Aptify.Applications.OrderEntry Namespace


DefaultARAccount Property

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeGLAccountCache.DefaultARAccount Property

public virtual String DefaultARAccount {get;}

See Also

ShipmentTypeGLAccountCache Class | Aptify.Applications.OrderEntry Namespace


ShipmentTypeGLAccounts Property

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeGLAccountCache.ShipmentTypeGLAccounts Property

This method will return a ShipmentTypeGLAccounts object from the cache. If the cache doesn't contain a ShipmentTypeGLAccounts object, the information will be retrieved from the database and used to populate a ShipmentTypeGLAccounts object which will be added to the cache and returned to the caller.

public virtual ShipmentTypeGLAccounts this[
Int64 ShipmentTypeID,
Boolean ForceRefresh
] {get;}

Parameters

ShipmentTypeID
ForceRefresh

Property Value

Remarks

See Also

ShipmentTypeGLAccountCache Class | Aptify.Applications.OrderEntry Namespace


ShipmentTypeGLAccountCache Methods

The methods of the ShipmentTypeGLAccountCache class are listed below. For a complete list of ShipmentTypeGLAccountCache class members, see the ShipmentTypeGLAccountCache Members topic.

Public Static Methods

Instance

Public Instance Methods

Clear | Clears the Shipment Types GL Accounts cache.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
RemoveShipmentTypeFromCache |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ShipmentTypeGLAccountCache Class | Aptify.Applications.OrderEntry Namespace


ShipmentTypeGLAccountCache.Clear Method

Clears the Shipment Types GL Accounts cache.

public void Clear();

Remarks

See Also

ShipmentTypeGLAccountCache Class | Aptify.Applications.OrderEntry Namespace


ShipmentTypeGLAccountCache.Instance Method

public static ShipmentTypeGLAccountCache Instance(
AptifyApplication Application
);

See Also

ShipmentTypeGLAccountCache Class | Aptify.Applications.OrderEntry Namespace


ShipmentTypeGLAccountCache.RemoveShipmentTypeFromCache Method

public void RemoveShipmentTypeFromCache(
Int64 ShipmentTypeID
);

See Also

ShipmentTypeGLAccountCache Class | Aptify.Applications.OrderEntry Namespace


ShipmentTypeGLAccounts Class

For a list of all members of this type, see ShipmentTypeGLAccounts Members.

System.Object
ShipmentTypeGLAccounts

public class ShipmentTypeGLAccounts

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

ShipmentTypeGLAccounts Members | Aptify.Applications.OrderEntry Namespace


ShipmentTypeGLAccounts Members

ShipmentTypeGLAccounts overview

Public Instance Constructors

ShipmentTypeGLAccounts Constructor

Public Instance Properties

Expense
ID
Income
IsCashBasis
Payable
Receivable
Unearned

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ShipmentTypeGLAccounts Class | Aptify.Applications.OrderEntry Namespace


ShipmentTypeGLAccounts Constructor

public ShipmentTypeGLAccounts(
DataRow row
);

See Also

ShipmentTypeGLAccounts Class | Aptify.Applications.OrderEntry Namespace


ShipmentTypeGLAccounts Properties

The properties of the ShipmentTypeGLAccounts class are listed below. For a complete list of ShipmentTypeGLAccounts class members, see the ShipmentTypeGLAccounts Members topic.

Public Instance Properties

Expense
ID
Income
IsCashBasis
Payable
Receivable
Unearned

See Also

ShipmentTypeGLAccounts Class | Aptify.Applications.OrderEntry Namespace


Expense Property

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeGLAccounts.Expense Property

public String Expense {get;}

See Also

ShipmentTypeGLAccounts Class | Aptify.Applications.OrderEntry Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeGLAccounts.ID Property

public Int64 ID {get;}

See Also

ShipmentTypeGLAccounts Class | Aptify.Applications.OrderEntry Namespace


Income Property

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeGLAccounts.Income Property

public String Income {get;}

See Also

ShipmentTypeGLAccounts Class | Aptify.Applications.OrderEntry Namespace


IsCashBasis Property

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeGLAccounts.IsCashBasis Property

public Boolean IsCashBasis {get;}

See Also

ShipmentTypeGLAccounts Class | Aptify.Applications.OrderEntry Namespace


Payable Property

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeGLAccounts.Payable Property

public String Payable {get;}

See Also

ShipmentTypeGLAccounts Class | Aptify.Applications.OrderEntry Namespace


Receivable Property

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeGLAccounts.Receivable Property

public String Receivable {get;}

See Also

ShipmentTypeGLAccounts Class | Aptify.Applications.OrderEntry Namespace


Unearned Property

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeGLAccounts.Unearned Property

public String Unearned {get;}

See Also

ShipmentTypeGLAccounts Class | Aptify.Applications.OrderEntry Namespace


ShipmentTypeGroupingData Class

For a list of all members of this type, see ShipmentTypeGroupingData Members.

System.Object
ShipmentTypeGroupingData

public class ShipmentTypeGroupingData

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyShippingCalculator (in AptifyShippingCalculator.dll)

See Also

ShipmentTypeGroupingData Members | Aptify.Applications.OrderEntry Namespace


ShipmentTypeGroupingData Members

ShipmentTypeGroupingData overview

Public Instance Constructors

ShipmentTypeGroupingData Constructor

Public Instance Properties

Description
FilterRuleID
ID
IsActive
Name
ShipmentType
ShipTypeID

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ShipmentTypeGroupingData Class | Aptify.Applications.OrderEntry Namespace


ShipmentTypeGroupingData Constructor

public ShipmentTypeGroupingData(
ShipmentTypeData ShipmentType,
DataRow rowShipmentTypeGrouping
);

See Also

ShipmentTypeGroupingData Class | Aptify.Applications.OrderEntry Namespace


ShipmentTypeGroupingData Properties

The properties of the ShipmentTypeGroupingData class are listed below. For a complete list of ShipmentTypeGroupingData class members, see the ShipmentTypeGroupingData Members topic.

Public Instance Properties

Description
FilterRuleID
ID
IsActive
Name
ShipmentType
ShipTypeID

See Also

ShipmentTypeGroupingData Class | Aptify.Applications.OrderEntry Namespace


Description Property

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeGroupingData.Description Property

public String Description {get;}

See Also

ShipmentTypeGroupingData Class | Aptify.Applications.OrderEntry Namespace


FilterRuleID Property

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeGroupingData.FilterRuleID Property

public Int32 FilterRuleID {get;}

See Also

ShipmentTypeGroupingData Class | Aptify.Applications.OrderEntry Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeGroupingData.ID Property

public Int32 ID {get;}

See Also

ShipmentTypeGroupingData Class | Aptify.Applications.OrderEntry Namespace


IsActive Property

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeGroupingData.IsActive Property

public Boolean IsActive {get;}

See Also

ShipmentTypeGroupingData Class | Aptify.Applications.OrderEntry Namespace


Name Property

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeGroupingData.Name Property

public String Name {get;}

See Also

ShipmentTypeGroupingData Class | Aptify.Applications.OrderEntry Namespace


ShipmentType Property

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeGroupingData.ShipmentType Property

public ShipmentTypeData ShipmentType {get;}

See Also

ShipmentTypeGroupingData Class | Aptify.Applications.OrderEntry Namespace


ShipTypeID Property

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeGroupingData.ShipTypeID Property

public Int32 ShipTypeID {get;}

See Also

ShipmentTypeGroupingData Class | Aptify.Applications.OrderEntry Namespace


ShipmentTypeGroupingsEntity Class

For a list of all members of this type, see ShipmentTypeGroupingsEntity Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
ShipmentTypeGroupingsEntity

public class ShipmentTypeGroupingsEntity : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyShipmentTypesEntity (in AptifyShipmentTypesEntity.dll)

See Also

ShipmentTypeGroupingsEntity Members | Aptify.Applications.OrderEntry Namespace


ShipmentTypeGroupingsEntity Members

ShipmentTypeGroupingsEntity overview

Public Instance Constructors

ShipmentTypeGroupingsEntity Constructor Initializes a new instance of the ShipmentTypeGroupingsEntity class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded. This method overrides the base functionality to ensure that if the ShipmentTypeGroupings has a filter rule setup, that the Shipment Grouping filter rule is named appropriately.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

ShipmentTypeGroupingsEntity Class | Aptify.Applications.OrderEntry Namespace


ShipmentTypeGroupingsEntity Constructor

Initializes a new instance of the ShipmentTypeGroupingsEntity class.

public ShipmentTypeGroupingsEntity();

See Also

ShipmentTypeGroupingsEntity Class | Aptify.Applications.OrderEntry Namespace


ShipmentTypeGroupingsEntity Methods

The methods of the ShipmentTypeGroupingsEntity class are listed below. For a complete list of ShipmentTypeGroupingsEntity class members, see the ShipmentTypeGroupingsEntity Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded. This method overrides the base functionality to ensure that if the ShipmentTypeGroupings has a filter rule setup, that the Shipment Grouping filter rule is named appropriately.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

ShipmentTypeGroupingsEntity Class | Aptify.Applications.OrderEntry Namespace


Save Method

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeGroupingsEntity.Save Method

This method overrides the base functionality to ensure that if the ShipmentTypeGroupings has a filter rule setup, that the Shipment Grouping filter rule is named appropriately.

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Save();

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean,ref String&);

This method overrides the base functionality to ensure that if the ShipmentTypeGroupings has a filter rule setup, that the Shipment Grouping filter rule is named appropriately.

public override bool Save(Boolean,ref String&,String);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(ref String&);

See Also

ShipmentTypeGroupingsEntity Class | Aptify.Applications.OrderEntry Namespace


ShipmentTypeGroupingsEntity.Save Method (Boolean, String&, String)

This method overrides the base functionality to ensure that if the ShipmentTypeGroupings has a filter rule setup, that the Shipment Grouping filter rule is named appropriately.

public override bool Save(
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

Parameters

AllowGUI
ErrorString
TransactionID

Return Value

Remarks

See Also

ShipmentTypeGroupingsEntity Class | Aptify.Applications.OrderEntry Namespace | ShipmentTypeGroupingsEntity.Save Overload List


ShipmentTypeMatrixData Class

For a list of all members of this type, see ShipmentTypeMatrixData Members.

System.Object
ShipmentTypeMatrixData

public class ShipmentTypeMatrixData

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyShippingCalculator (in AptifyShippingCalculator.dll)

See Also

ShipmentTypeMatrixData Members | Aptify.Applications.OrderEntry Namespace


ShipmentTypeMatrixData Members

ShipmentTypeMatrixData overview

Public Instance Constructors

ShipmentTypeMatrixData Constructor

Public Instance Properties

CalculationType |
ChargesIncludeTax |
Children | Returns the Tax Jurisdictions that are the children of the current Tax Jurisdiction. Child Tax Jurisdictions have a ParentID equal to the current record's ID.
City |
Comments |
CountryID |
County |
CurrencyTypeID |
HandlingCharge |
HasChildren |
ID |
Name |
ParentMatrix |
PostalCode |
QuantityLowerBound |
QuantityUpperBound |
Scope |
ShipmentType |
ShippingCharge |
ShippingCost |
ShipTypeID |
UseQuantity |
UseShipToLocation |
UseWeight |
WeightLowerBound |
WeightUpperBound |

Public Instance Methods

AddressMatch | Returns whether or not the Ship To Address information qualifies for the current Matrix entry.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ShipmentTypeMatrixData Class | Aptify.Applications.OrderEntry Namespace


ShipmentTypeMatrixData Constructor

public ShipmentTypeMatrixData(
ShipmentTypeCache CacheInstance,
Int32 CurrencyTypeID,
ShipmentTypeData ShipmentType,
ShipmentTypeMatrixData ParentMatrix,
DataRow rowMatrix
);

See Also

ShipmentTypeMatrixData Class | Aptify.Applications.OrderEntry Namespace


ShipmentTypeMatrixData Properties

The properties of the ShipmentTypeMatrixData class are listed below. For a complete list of ShipmentTypeMatrixData class members, see the ShipmentTypeMatrixData Members topic.

Public Instance Properties

CalculationType |
ChargesIncludeTax |
Children | Returns the Tax Jurisdictions that are the children of the current Tax Jurisdiction. Child Tax Jurisdictions have a ParentID equal to the current record's ID.
City |
Comments |
CountryID |
County |
CurrencyTypeID |
HandlingCharge |
HasChildren |
ID |
Name |
ParentMatrix |
PostalCode |
QuantityLowerBound |
QuantityUpperBound |
Scope |
ShipmentType |
ShippingCharge |
ShippingCost |
ShipTypeID |
UseQuantity |
UseShipToLocation |
UseWeight |
WeightLowerBound |
WeightUpperBound |

See Also

ShipmentTypeMatrixData Class | Aptify.Applications.OrderEntry Namespace


CalculationType Property

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeMatrixData.CalculationType Property

public ShipmentTypeMatrixData.MatrixCalculationType CalculationType {get;}

See Also

ShipmentTypeMatrixData Class | Aptify.Applications.OrderEntry Namespace


ChargesIncludeTax Property

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeMatrixData.ChargesIncludeTax Property

public Boolean ChargesIncludeTax {get;}

See Also

ShipmentTypeMatrixData Class | Aptify.Applications.OrderEntry Namespace


Children Property

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeMatrixData.Children Property

Returns the Tax Jurisdictions that are the children of the current Tax Jurisdiction. Child Tax Jurisdictions have a ParentID equal to the current record's ID.

public List<T> Children {get;}

Property Value

Remarks

See Also

ShipmentTypeMatrixData Class | Aptify.Applications.OrderEntry Namespace


City Property

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeMatrixData.City Property

public String City {get;}

See Also

ShipmentTypeMatrixData Class | Aptify.Applications.OrderEntry Namespace


Comments Property

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeMatrixData.Comments Property

public String Comments {get;}

See Also

ShipmentTypeMatrixData Class | Aptify.Applications.OrderEntry Namespace


CountryID Property

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeMatrixData.CountryID Property

public Int32 CountryID {get;}

See Also

ShipmentTypeMatrixData Class | Aptify.Applications.OrderEntry Namespace


County Property

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeMatrixData.County Property

public String County {get;}

See Also

ShipmentTypeMatrixData Class | Aptify.Applications.OrderEntry Namespace


CurrencyTypeID Property

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeMatrixData.CurrencyTypeID Property

public Int32 CurrencyTypeID {get;}

See Also

ShipmentTypeMatrixData Class | Aptify.Applications.OrderEntry Namespace


HandlingCharge Property

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeMatrixData.HandlingCharge Property

public Decimal HandlingCharge {get;}

See Also

ShipmentTypeMatrixData Class | Aptify.Applications.OrderEntry Namespace


HasChildren Property

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeMatrixData.HasChildren Property

public Boolean HasChildren {get;}

See Also

ShipmentTypeMatrixData Class | Aptify.Applications.OrderEntry Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeMatrixData.ID Property

public Int32 ID {get;}

See Also

ShipmentTypeMatrixData Class | Aptify.Applications.OrderEntry Namespace


Name Property

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeMatrixData.Name Property

public String Name {get;}

See Also

ShipmentTypeMatrixData Class | Aptify.Applications.OrderEntry Namespace


ParentMatrix Property

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeMatrixData.ParentMatrix Property

public ShipmentTypeMatrixData ParentMatrix {get;}

See Also

ShipmentTypeMatrixData Class | Aptify.Applications.OrderEntry Namespace


PostalCode Property

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeMatrixData.PostalCode Property

public String PostalCode {get;}

See Also

ShipmentTypeMatrixData Class | Aptify.Applications.OrderEntry Namespace


QuantityLowerBound Property

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeMatrixData.QuantityLowerBound Property

public Decimal QuantityLowerBound {get;}

See Also

ShipmentTypeMatrixData Class | Aptify.Applications.OrderEntry Namespace


QuantityUpperBound Property

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeMatrixData.QuantityUpperBound Property

public Decimal QuantityUpperBound {get;}

See Also

ShipmentTypeMatrixData Class | Aptify.Applications.OrderEntry Namespace


Scope Property

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeMatrixData.Scope Property

public ShipmentTypeMatrixData.MatrixShipToScope Scope {get;}

See Also

ShipmentTypeMatrixData Class | Aptify.Applications.OrderEntry Namespace


ShipmentType Property

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeMatrixData.ShipmentType Property

public ShipmentTypeData ShipmentType {get;}

See Also

ShipmentTypeMatrixData Class | Aptify.Applications.OrderEntry Namespace


ShippingCharge Property

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeMatrixData.ShippingCharge Property

public Decimal ShippingCharge {get;}

See Also

ShipmentTypeMatrixData Class | Aptify.Applications.OrderEntry Namespace


ShippingCost Property

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeMatrixData.ShippingCost Property

public Decimal ShippingCost {get;}

See Also

ShipmentTypeMatrixData Class | Aptify.Applications.OrderEntry Namespace


ShipTypeID Property

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeMatrixData.ShipTypeID Property

public Int32 ShipTypeID {get;}

See Also

ShipmentTypeMatrixData Class | Aptify.Applications.OrderEntry Namespace


UseQuantity Property

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeMatrixData.UseQuantity Property

public Boolean UseQuantity {get;}

See Also

ShipmentTypeMatrixData Class | Aptify.Applications.OrderEntry Namespace


UseShipToLocation Property

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeMatrixData.UseShipToLocation Property

public Boolean UseShipToLocation {get;}

See Also

ShipmentTypeMatrixData Class | Aptify.Applications.OrderEntry Namespace


UseWeight Property

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeMatrixData.UseWeight Property

public Boolean UseWeight {get;}

See Also

ShipmentTypeMatrixData Class | Aptify.Applications.OrderEntry Namespace


WeightLowerBound Property

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeMatrixData.WeightLowerBound Property

public Weight WeightLowerBound {get;}

See Also

ShipmentTypeMatrixData Class | Aptify.Applications.OrderEntry Namespace


WeightUpperBound Property

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeMatrixData.WeightUpperBound Property

public Weight WeightUpperBound {get;}

See Also

ShipmentTypeMatrixData Class | Aptify.Applications.OrderEntry Namespace


ShipmentTypeMatrixData Methods

The methods of the ShipmentTypeMatrixData class are listed below. For a complete list of ShipmentTypeMatrixData class members, see the ShipmentTypeMatrixData Members topic.

Public Instance Methods

AddressMatch | Returns whether or not the Ship To Address information qualifies for the current Matrix entry.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ShipmentTypeMatrixData Class | Aptify.Applications.OrderEntry Namespace


ShipmentTypeMatrixData.AddressMatch Method

Returns whether or not the Ship To Address information qualifies for the current Matrix entry.

public bool AddressMatch(
TaxAddress ShipToAddress
);

Parameters

ShipToAddress

Return Value

Returns true if the Address match the Matrix definition. Otherwise, returns false.

Remarks

See Also

ShipmentTypeMatrixData Class | Aptify.Applications.OrderEntry Namespace


ShipmentTypeMatrixData.MatrixCalculationType Enumeration

public enum ShipmentTypeMatrixData.MatrixCalculationType

Members

Member Name | Description
ActualValue |
PerUnit |

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyShippingCalculator (in AptifyShippingCalculator.dll)

See Also

Aptify.Applications.OrderEntry Namespace


ShipmentTypeMatrixData.MatrixShipToScope Enumeration

public enum ShipmentTypeMatrixData.MatrixShipToScope

Members

Member Name | Description
Country |
StateProvince |
County |
City |
PostalCode |

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyShippingCalculator (in AptifyShippingCalculator.dll)

See Also

Aptify.Applications.OrderEntry Namespace


ShipmentTypeMatrixEntity Class

For a list of all members of this type, see ShipmentTypeMatrixEntity Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
ShipmentTypeMatrixEntity

public class ShipmentTypeMatrixEntity : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyShipmentTypesEntity (in AptifyShipmentTypesEntity.dll)

See Also

ShipmentTypeMatrixEntity Members | Aptify.Applications.OrderEntry Namespace


ShipmentTypeMatrixEntity Members

ShipmentTypeMatrixEntity overview

Public Instance Constructors

ShipmentTypeMatrixEntity Constructor Initializes a new instance of the ShipmentTypeMatrixEntity class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrencyTypeFormat | Returns the Currency Type's FormatString value. If no matching Currency Type is found, the property returns "Currency", which will use the local system's Regional Currency format.
CurrencyTypeID |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded. This method overrides the base functionality to ensure that if the ShipmentTypeMatrix has a filter rule setup, that the Shipping Charge filter rule is named appropriately.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

ShipmentTypeMatrixEntity Class | Aptify.Applications.OrderEntry Namespace


ShipmentTypeMatrixEntity Constructor

Initializes a new instance of the ShipmentTypeMatrixEntity class.

public ShipmentTypeMatrixEntity();

See Also

ShipmentTypeMatrixEntity Class | Aptify.Applications.OrderEntry Namespace


ShipmentTypeMatrixEntity Properties

The properties of the ShipmentTypeMatrixEntity class are listed below. For a complete list of ShipmentTypeMatrixEntity class members, see the ShipmentTypeMatrixEntity Members topic.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrencyTypeFormat | Returns the Currency Type's FormatString value. If no matching Currency Type is found, the property returns "Currency", which will use the local system's Regional Currency format.
CurrencyTypeID |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

ShipmentTypeMatrixEntity Class | Aptify.Applications.OrderEntry Namespace


CurrencyTypeFormat Property

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeMatrixEntity.CurrencyTypeFormat Property

Returns the Currency Type's FormatString value. If no matching Currency Type is found, the property returns "Currency", which will use the local system's Regional Currency format.

public String CurrencyTypeFormat {get;}

Property Value

Remarks

See Also

ShipmentTypeMatrixEntity Class | Aptify.Applications.OrderEntry Namespace


CurrencyTypeID Property

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeMatrixEntity.CurrencyTypeID Property

public Int32 CurrencyTypeID {get; set;}

See Also

ShipmentTypeMatrixEntity Class | Aptify.Applications.OrderEntry Namespace


ShipmentTypeMatrixEntity Methods

The methods of the ShipmentTypeMatrixEntity class are listed below. For a complete list of ShipmentTypeMatrixEntity class members, see the ShipmentTypeMatrixEntity Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded. This method overrides the base functionality to ensure that if the ShipmentTypeMatrix has a filter rule setup, that the Shipping Charge filter rule is named appropriately.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

ShipmentTypeMatrixEntity Class | Aptify.Applications.OrderEntry Namespace


Save Method

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeMatrixEntity.Save Method

This method overrides the base functionality to ensure that if the ShipmentTypeMatrix has a filter rule setup, that the Shipping Charge filter rule is named appropriately.

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Save();

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean,ref String&);

This method overrides the base functionality to ensure that if the ShipmentTypeMatrix has a filter rule setup, that the Shipping Charge filter rule is named appropriately.

public override bool Save(Boolean,ref String&,String);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(ref String&);

See Also

ShipmentTypeMatrixEntity Class | Aptify.Applications.OrderEntry Namespace


ShipmentTypeMatrixEntity.Save Method (Boolean, String&, String)

This method overrides the base functionality to ensure that if the ShipmentTypeMatrix has a filter rule setup, that the Shipping Charge filter rule is named appropriately.

public override bool Save(
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

Parameters

AllowGUI
ErrorString
TransactionID

Return Value

Remarks

See Also

ShipmentTypeMatrixEntity Class | Aptify.Applications.OrderEntry Namespace | ShipmentTypeMatrixEntity.Save Overload List


Validate Method

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeMatrixEntity.Validate Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Validate();

public override bool Validate(ref String&);

See Also

ShipmentTypeMatrixEntity Class | Aptify.Applications.OrderEntry Namespace


ShipmentTypeMatrixEntity.Validate Method (String&)

public override bool Validate(
ref String& ErrorString
);

See Also

ShipmentTypeMatrixEntity Class | Aptify.Applications.OrderEntry Namespace | ShipmentTypeMatrixEntity.Validate Overload List


ShipmentTypeMatrixLayout Class

For a list of all members of this type, see ShipmentTypeMatrixLayout Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
ShipmentTypeMatrixLayout

public class ShipmentTypeMatrixLayout : FormTemplateLayout

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: ShipmentTypesControls (in ShipmentTypesControls.dll)

See Also

ShipmentTypeMatrixLayout Members | Aptify.Applications.OrderEntry Namespace


ShipmentTypeMatrixLayout Members

ShipmentTypeMatrixLayout overview

Public Instance Constructors

ShipmentTypeMatrixLayout Constructor Initializes a new instance of the ShipmentTypeMatrixLayout class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

m_ShipmentTypeMatrixGE
m_txtHandlingCharge
m_txtShippingCharge
m_txtShippingCost

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
m_chkUseQuantity |
m_chkUseShipToLocation |
m_chkUseWeight |
m_ctlShipToCountryID |
m_lnkCurrencyTypeID |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShipmentTypeMatrixEntity |
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControls |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded | Contains logic to setup Event handlers for controls on the FormTemplate Layout.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetCurrencyFormat |
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlVisibility |
SetControlVisibilityQuantity |
SetControlVisibilityShipTo |
SetControlVisibilityWeight |
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ShipmentTypeMatrixLayout Class | Aptify.Applications.OrderEntry Namespace


ShipmentTypeMatrixLayout Constructor

Initializes a new instance of the ShipmentTypeMatrixLayout class.

public ShipmentTypeMatrixLayout();

See Also

ShipmentTypeMatrixLayout Class | Aptify.Applications.OrderEntry Namespace


ShipmentTypeMatrixLayout Fields

The fields of the ShipmentTypeMatrixLayout class are listed below. For a complete list of ShipmentTypeMatrixLayout class members, see the ShipmentTypeMatrixLayout Members topic.

Protected Instance Fields

m_ShipmentTypeMatrixGE
m_txtHandlingCharge
m_txtShippingCharge
m_txtShippingCost

See Also

ShipmentTypeMatrixLayout Class | Aptify.Applications.OrderEntry Namespace


ShipmentTypeMatrixLayout.m_ShipmentTypeMatrixGE Field

protected m_ShipmentTypeMatrixGE m_ShipmentTypeMatrixGE;

See Also

ShipmentTypeMatrixLayout Class | Aptify.Applications.OrderEntry Namespace


ShipmentTypeMatrixLayout.m_txtHandlingCharge Field

protected m_txtHandlingCharge m_txtHandlingCharge;

See Also

ShipmentTypeMatrixLayout Class | Aptify.Applications.OrderEntry Namespace


ShipmentTypeMatrixLayout.m_txtShippingCharge Field

protected m_txtShippingCharge m_txtShippingCharge;

See Also

ShipmentTypeMatrixLayout Class | Aptify.Applications.OrderEntry Namespace


ShipmentTypeMatrixLayout.m_txtShippingCost Field

protected m_txtShippingCost m_txtShippingCost;

See Also

ShipmentTypeMatrixLayout Class | Aptify.Applications.OrderEntry Namespace


ShipmentTypeMatrixLayout Properties

The properties of the ShipmentTypeMatrixLayout class are listed below. For a complete list of ShipmentTypeMatrixLayout class members, see the ShipmentTypeMatrixLayout Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
m_chkUseQuantity |
m_chkUseShipToLocation |
m_chkUseWeight |
m_ctlShipToCountryID |
m_lnkCurrencyTypeID |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShipmentTypeMatrixEntity |
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

ShipmentTypeMatrixLayout Class | Aptify.Applications.OrderEntry Namespace


m_chkUseQuantity Property

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeMatrixLayout.m_chkUseQuantity Property

protected virtual AptifyCheckBox m_chkUseQuantity {get; set;}

See Also

ShipmentTypeMatrixLayout Class | Aptify.Applications.OrderEntry Namespace


m_chkUseShipToLocation Property

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeMatrixLayout.m_chkUseShipToLocation Property

protected virtual AptifyCheckBox m_chkUseShipToLocation {get; set;}

See Also

ShipmentTypeMatrixLayout Class | Aptify.Applications.OrderEntry Namespace


m_chkUseWeight Property

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeMatrixLayout.m_chkUseWeight Property

protected virtual AptifyCheckBox m_chkUseWeight {get; set;}

See Also

ShipmentTypeMatrixLayout Class | Aptify.Applications.OrderEntry Namespace


m_ctlShipToCountryID Property

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeMatrixLayout.m_ctlShipToCountryID Property

protected virtual AptifyLinkBox m_ctlShipToCountryID {get; set;}

See Also

ShipmentTypeMatrixLayout Class | Aptify.Applications.OrderEntry Namespace


m_lnkCurrencyTypeID Property

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeMatrixLayout.m_lnkCurrencyTypeID Property

protected virtual AptifyLinkBox m_lnkCurrencyTypeID {get; set;}

See Also

ShipmentTypeMatrixLayout Class | Aptify.Applications.OrderEntry Namespace


ShipmentTypeMatrixEntity Property

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeMatrixLayout.ShipmentTypeMatrixEntity Property

protected ShipmentTypeMatrixEntity ShipmentTypeMatrixEntity {get;}

See Also

ShipmentTypeMatrixLayout Class | Aptify.Applications.OrderEntry Namespace


ShipmentTypeMatrixLayout Methods

The methods of the ShipmentTypeMatrixLayout class are listed below. For a complete list of ShipmentTypeMatrixLayout class members, see the ShipmentTypeMatrixLayout Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControls |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded | Contains logic to setup Event handlers for controls on the FormTemplate Layout.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetCurrencyFormat |
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlVisibility |
SetControlVisibilityQuantity |
SetControlVisibilityShipTo |
SetControlVisibilityWeight |
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ShipmentTypeMatrixLayout Class | Aptify.Applications.OrderEntry Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

ShipmentTypeMatrixLayout.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

ShipmentTypeMatrixLayout Class | Aptify.Applications.OrderEntry Namespace


ShipmentTypeMatrixLayout.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

ShipmentTypeMatrixLayout Class | Aptify.Applications.OrderEntry Namespace | ShipmentTypeMatrixLayout.Dispose Overload List


ShipmentTypeMatrixLayout.FindControls Method

protected virtual void FindControls(
String FormTemplateLayoutName
);

See Also

ShipmentTypeMatrixLayout Class | Aptify.Applications.OrderEntry Namespace


ShipmentTypeMatrixLayout.OnFormTemplateLoaded Method

Contains logic to setup Event handlers for controls on the FormTemplate Layout.

protected override void OnFormTemplateLoaded(
FormTemplateLayout.FormTemplateLoadedEventArgs e
);

Parameters

e

Remarks

See Also

ShipmentTypeMatrixLayout Class | Aptify.Applications.OrderEntry Namespace


ShipmentTypeMatrixLayout.OnRefresh Method

protected override void OnRefresh();

Implements

IFormComponent.

See Also

ShipmentTypeMatrixLayout Class | Aptify.Applications.OrderEntry Namespace


ShipmentTypeMatrixLayout.ResetCurrencyFormat Method

protected virtual void ResetCurrencyFormat();

See Also

ShipmentTypeMatrixLayout Class | Aptify.Applications.OrderEntry Namespace


ShipmentTypeMatrixLayout.SetControlVisibility Method

protected virtual void SetControlVisibility();

See Also

ShipmentTypeMatrixLayout Class | Aptify.Applications.OrderEntry Namespace


ShipmentTypeMatrixLayout.SetControlVisibilityQuantity Method

protected virtual void SetControlVisibilityQuantity(
Boolean Enabled
);

See Also

ShipmentTypeMatrixLayout Class | Aptify.Applications.OrderEntry Namespace


ShipmentTypeMatrixLayout.SetControlVisibilityShipTo Method

protected virtual void SetControlVisibilityShipTo(
Boolean Enabled
);

See Also

ShipmentTypeMatrixLayout Class | Aptify.Applications.OrderEntry Namespace


ShipmentTypeMatrixLayout.SetControlVisibilityWeight Method

protected virtual void SetControlVisibilityWeight(
Boolean Enabled
);

See Also

ShipmentTypeMatrixLayout Class | Aptify.Applications.OrderEntry Namespace


ShipmentTypeRevenueRecognitionType Enumeration

public enum ShipmentTypeRevenueRecognitionType

Members

Member Name | Description
Accural |
Cash |

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyShippingCalculator (in AptifyShippingCalculator.dll)

See Also

Aptify.Applications.OrderEntry Namespace


ShippingCalculator Class

This object implements the Aptify.Framework.Applications.Accounting.ISalesTaxRate interface. The purpose of this component is to return a tax rate for a given set of input parameters base currency id.

For a list of all members of this type, see ShippingCalculator Members.

System.Object
ShippingCalculator

public class ShippingCalculator : IShippingCalculator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyShippingCalculator (in AptifyShippingCalculator.dll)

See Also

ShippingCalculator Members | Aptify.Applications.OrderEntry Namespace


ShippingCalculator Members

ShippingCalculator overview

Public Instance Constructors

ShippingCalculator Constructor Initializes a new instance of the ShippingCalculator class.

Public Instance Methods

CalculateShipping |
Config |
DetermineShipmentType | Overloaded. Used to determine the Shipment Type to use for the the Order. This method can be used to select a shipment type based on the contents of the Order. In the core implementation, there is no logic to determine the Shipment Type. The Order's Shipment Type is set based on the Default Value stored in the ShipTypeID.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CalculateOrderShipment | Processes a single Order Shipment to determine the qualifying Shipment Type Matrix and to use that Matrix entry to set the Shipping Cost, Shipping Charge and Handling Charge
CalculateOrderShipment_PlugIn | Calculation is to be performed by a Shipping Calculator plug-in. This method is responsible for ensuring that the plug-in is available, instantiated and then the calculation is delegated to that component.
CalculateOrderShipment_Standard |
CalculateOrderShipments |
CheckForQuantityMatch | Determines whether or not a Quantity comparison is necessary. If not, True is returned. If a Quantity match is necessary, the Quantity comparison will be performed and the result will be returned. Note: The Quantity Lower Bound is inclusive. However, the Quantity Upper Bound is not inclusive. An upper bound value of 5 will not match if the Total Quantity of the Order Shipment is 5. Total Quantities less than 5 will be matched. This provides more improved range definitions. Example: 1 to 5, 5 to 10, etc. '''
CheckForShipToAddressMatch |
CheckForWeightMatch | Determines whether or not a Weight comparison is necessary. If not, True is returned. If a Weight match is necessary, the Quantity comparison will be performed and the result will be returned. Note: The Weight Lower Bound is inclusive. However, the Weight Upper Bound is not inclusive. An upper bound value of 5 will not match if the Total Weight of the Order Shipment is 5. Total Weights less than 5 will be matched. This provides more improved range definitions. Example: 1 to 5, 5 to 10, etc. '''
DetermineOrderLineShipmentGrouping | Takes the current Order Line and determines what, if any, Shipment Type Grouping applies.
DetermineOrderShipmentMatrix | Retrieves and processes the Shipment Type Matrix records, comparing the Matrix Entry requirements to the Order Shipment until a match is found. When a match is found and the match has no children, that match will be returned. If the match has children, the children will be processed to look for a match. If no match is found, the ParentMatrixEntry value will be returned as the best match.
ExecuteShipmentGroupingFilterRule |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetEntityInstanceUsedFields |
LoadEntityInstanceData |
LoadOrderEntityInstanceData | This method pulls the required elements from the OrderGE as opposed to going to the database since the Order GE data is live.
LoadOrderLineEntityInstanceData | This method pulls the required elements from the OrderLineGE as opposed to going to the database since the OrderLine GE data is live.
LoadProductInstanceData | This method pulls the required elements from the ProductData cache as opposed to going to the database since the Product data is live.
LoadShipmentTypeGroupingInstanceData | This method pulls the required elements from the ShipmentTypeGrouping cache as opposed to going to the database since the ShipmentTypeGrouping data is live.
LoadShipmentTypeInstanceData | This method pulls the required elements from the ShipmentType cache as opposed to going to the database since the ShipmentType data is live.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PopulateOrderShipments | Process the Order Lines and create one OrderShipment GE for each ShipTo and ShipToAddress combination. Use the DetermineShipmentType method to set ShipTypeID for each OrderShipment.

See Also

ShippingCalculator Class | Aptify.Applications.OrderEntry Namespace


ShippingCalculator Constructor

Initializes a new instance of the ShippingCalculator class.

public ShippingCalculator();

See Also

ShippingCalculator Class | Aptify.Applications.OrderEntry Namespace


ShippingCalculator Methods

The methods of the ShippingCalculator class are listed below. For a complete list of ShippingCalculator class members, see the ShippingCalculator Members topic.

Public Instance Methods

CalculateShipping |
Config |
DetermineShipmentType | Overloaded. Used to determine the Shipment Type to use for the the Order. This method can be used to select a shipment type based on the contents of the Order. In the core implementation, there is no logic to determine the Shipment Type. The Order's Shipment Type is set based on the Default Value stored in the ShipTypeID.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CalculateOrderShipment | Processes a single Order Shipment to determine the qualifying Shipment Type Matrix and to use that Matrix entry to set the Shipping Cost, Shipping Charge and Handling Charge
CalculateOrderShipment_PlugIn | Calculation is to be performed by a Shipping Calculator plug-in. This method is responsible for ensuring that the plug-in is available, instantiated and then the calculation is delegated to that component.
CalculateOrderShipment_Standard |
CalculateOrderShipments |
CheckForQuantityMatch | Determines whether or not a Quantity comparison is necessary. If not, True is returned. If a Quantity match is necessary, the Quantity comparison will be performed and the result will be returned. Note: The Quantity Lower Bound is inclusive. However, the Quantity Upper Bound is not inclusive. An upper bound value of 5 will not match if the Total Quantity of the Order Shipment is 5. Total Quantities less than 5 will be matched. This provides more improved range definitions. Example: 1 to 5, 5 to 10, etc. '''
CheckForShipToAddressMatch |
CheckForWeightMatch | Determines whether or not a Weight comparison is necessary. If not, True is returned. If a Weight match is necessary, the Quantity comparison will be performed and the result will be returned. Note: The Weight Lower Bound is inclusive. However, the Weight Upper Bound is not inclusive. An upper bound value of 5 will not match if the Total Weight of the Order Shipment is 5. Total Weights less than 5 will be matched. This provides more improved range definitions. Example: 1 to 5, 5 to 10, etc. '''
DetermineOrderLineShipmentGrouping | Takes the current Order Line and determines what, if any, Shipment Type Grouping applies.
DetermineOrderShipmentMatrix | Retrieves and processes the Shipment Type Matrix records, comparing the Matrix Entry requirements to the Order Shipment until a match is found. When a match is found and the match has no children, that match will be returned. If the match has children, the children will be processed to look for a match. If no match is found, the ParentMatrixEntry value will be returned as the best match.
ExecuteShipmentGroupingFilterRule |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetEntityInstanceUsedFields |
LoadEntityInstanceData |
LoadOrderEntityInstanceData | This method pulls the required elements from the OrderGE as opposed to going to the database since the Order GE data is live.
LoadOrderLineEntityInstanceData | This method pulls the required elements from the OrderLineGE as opposed to going to the database since the OrderLine GE data is live.
LoadProductInstanceData | This method pulls the required elements from the ProductData cache as opposed to going to the database since the Product data is live.
LoadShipmentTypeGroupingInstanceData | This method pulls the required elements from the ShipmentTypeGrouping cache as opposed to going to the database since the ShipmentTypeGrouping data is live.
LoadShipmentTypeInstanceData | This method pulls the required elements from the ShipmentType cache as opposed to going to the database since the ShipmentType data is live.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PopulateOrderShipments | Process the Order Lines and create one OrderShipment GE for each ShipTo and ShipToAddress combination. Use the DetermineShipmentType method to set ShipTypeID for each OrderShipment.

See Also

ShippingCalculator Class | Aptify.Applications.OrderEntry Namespace


ShippingCalculator.CalculateOrderShipment Method

Processes a single Order Shipment to determine the qualifying Shipment Type Matrix and to use that Matrix entry to set the Shipping Cost, Shipping Charge and Handling Charge

protected virtual void CalculateOrderShipment(
OrderShipmentsEntity OrderShipmentGE
);

Parameters

OrderShipmentGE

Remarks

See Also

ShippingCalculator Class | Aptify.Applications.OrderEntry Namespace


ShippingCalculator.CalculateOrderShipment_PlugIn Method

Calculation is to be performed by a Shipping Calculator plug-in. This method is responsible for ensuring that the plug-in is available, instantiated and then the calculation is delegated to that component.

protected virtual void CalculateOrderShipment_PlugIn(
OrderShipmentsEntity OrderShipmentGE,
ShipmentTypeData ShipmentType
);

Parameters

OrderShipmentGE
ShipmentType

Remarks

See Also

ShippingCalculator Class | Aptify.Applications.OrderEntry Namespace


ShippingCalculator.CalculateOrderShipment_Standard Method

protected virtual void CalculateOrderShipment_Standard(
OrderShipmentsEntity OrderShipmentGE,
IShippingCalculator ParentCalculator
);

Implements

IShippingCalculator.

See Also

ShippingCalculator Class | Aptify.Applications.OrderEntry Namespace


ShippingCalculator.CalculateOrderShipments Method

protected virtual void CalculateOrderShipments(
OrdersEntity OrderGE
);

See Also

ShippingCalculator Class | Aptify.Applications.OrderEntry Namespace


ShippingCalculator.CalculateShipping Method

public virtual void CalculateShipping(
OrdersEntity OrderGE
);

Implements

IShippingCalculator.

See Also

ShippingCalculator Class | Aptify.Applications.OrderEntry Namespace


ShippingCalculator.CheckForQuantityMatch Method

Determines whether or not a Quantity comparison is necessary. If not, True is returned. If a Quantity match is necessary, the Quantity comparison will be performed and the result will be returned. Note: The Quantity Lower Bound is inclusive. However, the Quantity Upper Bound is not inclusive. An upper bound value of 5 will not match if the Total Quantity of the Order Shipment is 5. Total Quantities less than 5 will be matched. This provides more improved range definitions. Example: 1 to 5, 5 to 10, etc. '''

protected virtual bool CheckForQuantityMatch(
OrderShipmentsEntity OrderShipmentGE,
ShipmentTypeMatrixData MatrixEntry
);

Parameters

OrderShipmentGE
MatrixEntry

Return Value

Remarks

The Total Quantity is taken as an absolute value to accomidate refunding Shipping.

See Also

ShippingCalculator Class | Aptify.Applications.OrderEntry Namespace


ShippingCalculator.CheckForShipToAddressMatch Method

protected virtual bool CheckForShipToAddressMatch(
OrderShipmentsEntity OrderShipmentGE,
ShipmentTypeMatrixData MatrixEntry
);

See Also

ShippingCalculator Class | Aptify.Applications.OrderEntry Namespace


ShippingCalculator.CheckForWeightMatch Method

Determines whether or not a Weight comparison is necessary. If not, True is returned. If a Weight match is necessary, the Quantity comparison will be performed and the result will be returned. Note: The Weight Lower Bound is inclusive. However, the Weight Upper Bound is not inclusive. An upper bound value of 5 will not match if the Total Weight of the Order Shipment is 5. Total Weights less than 5 will be matched. This provides more improved range definitions. Example: 1 to 5, 5 to 10, etc. '''

protected virtual bool CheckForWeightMatch(
OrderShipmentsEntity OrderShipmentGE,
ShipmentTypeMatrixData MatrixEntry
);

Parameters

OrderShipmentGE
MatrixEntry

Return Value

Remarks

Weight is compared to the absolute value to allow for return of shipping charges

See Also

ShippingCalculator Class | Aptify.Applications.OrderEntry Namespace


ShippingCalculator.Config Method

public virtual void Config(
AptifyApplication Application
);

Implements

IShippingCalculator.

See Also

ShippingCalculator Class | Aptify.Applications.OrderEntry Namespace


ShippingCalculator.DetermineOrderLineShipmentGrouping Method

Takes the current Order Line and determines what, if any, Shipment Type Grouping applies.

protected virtual int DetermineOrderLineShipmentGrouping(
OrderLinesEntity OrderLineGE,
ShipmentTypeData ShipmentType
);

Parameters

OrderLineGE
ShipmentType

Return Value

Remarks

See Also

ShippingCalculator Class | Aptify.Applications.OrderEntry Namespace


ShippingCalculator.DetermineOrderShipmentMatrix Method

Retrieves and processes the Shipment Type Matrix records, comparing the Matrix Entry requirements to the Order Shipment until a match is found. When a match is found and the match has no children, that match will be returned. If the match has children, the children will be processed to look for a match. If no match is found, the ParentMatrixEntry value will be returned as the best match.

protected virtual ShipmentTypeMatrixData DetermineOrderShipmentMatrix(
OrderShipmentsEntity OrderShipmentGE,
ShipmentTypeData ShipmentType,
ShipmentTypeMatrixData ParentMatrixEntry
);

Parameters

OrderShipmentGE
ShipmentType
ParentMatrixEntry

Remarks

See Also

ShippingCalculator Class | Aptify.Applications.OrderEntry Namespace


DetermineShipmentType Method

Aptify 5.0 Software Development Kit (SDK)

ShippingCalculator.DetermineShipmentType Method

Used to determine the Shipment Type to use for the Order Shipment. If a Shipment Type has already been specified, it will be used. If not, the Shipment Type defined at the Order level will be used.

Overload List

Used to determine the Shipment Type to use for the Order Shipment. If a Shipment Type has already been specified, it will be used. If not, the Shipment Type defined at the Order level will be used.

public virtual void DetermineShipmentType(OrderLinesEntity);

Used to determine the Shipment Type to use for the the Order. This method can be used to select a shipment type based on the contents of the Order. In the core implementation, there is no logic to determine the Shipment Type. The Order's Shipment Type is set based on the Default Value stored in the ShipTypeID.

public virtual void DetermineShipmentType(OrdersEntity);

See Also

ShippingCalculator Class | Aptify.Applications.OrderEntry Namespace


ShippingCalculator.DetermineShipmentType Method (OrderLinesEntity)

Used to determine the Shipment Type to use for the Order Shipment. If a Shipment Type has already been specified, it will be used. If not, the Shipment Type defined at the Order level will be used.

public virtual void DetermineShipmentType(
OrderLinesEntity OrderLineGE
);

Parameters

OrderLineGE

Implements

IShippingCalculator.

Remarks

See Also

ShippingCalculator Class | Aptify.Applications.OrderEntry Namespace | ShippingCalculator.DetermineShipmentType Overload List


ShippingCalculator.DetermineShipmentType Method (OrdersEntity)

Used to determine the Shipment Type to use for the the Order. This method can be used to select a shipment type based on the contents of the Order. In the core implementation, there is no logic to determine the Shipment Type. The Order's Shipment Type is set based on the Default Value stored in the ShipTypeID.

public virtual void DetermineShipmentType(
OrdersEntity OrderGE
);

Parameters

OrderGE

Implements

IShippingCalculator.

Remarks

See Also

ShippingCalculator Class | Aptify.Applications.OrderEntry Namespace | ShippingCalculator.DetermineShipmentType Overload List


ShippingCalculator.ExecuteShipmentGroupingFilterRule Method

protected virtual bool ExecuteShipmentGroupingFilterRule(
ShipmentTypeGroupingData Grouping,
OrderLinesEntity OrderLineGE,
Boolean RefreshCache
);

See Also

ShippingCalculator Class | Aptify.Applications.OrderEntry Namespace


ShippingCalculator.GetEntityInstanceUsedFields Method

protected virtual List<T> GetEntityInstanceUsedFields(
String EntityInstance,
FilterRule oFilterRule
);

See Also

ShippingCalculator Class | Aptify.Applications.OrderEntry Namespace


ShippingCalculator.LoadEntityInstanceData Method

protected virtual DataRow LoadEntityInstanceData(
String EntityInstance,
String EntityName,
Int64 InstanceRecordID,
FilterRule oFilterRule
);

See Also

ShippingCalculator Class | Aptify.Applications.OrderEntry Namespace


ShippingCalculator.LoadOrderEntityInstanceData Method

This method pulls the required elements from the OrderGE as opposed to going to the database since the Order GE data is live.

protected virtual DataRow LoadOrderEntityInstanceData(
AptifyGenericEntityBase OrderGE,
FilterRule oFilterRule
);

Parameters

OrderGE
oFilterRule

Return Value

Remarks

See Also

ShippingCalculator Class | Aptify.Applications.OrderEntry Namespace


ShippingCalculator.LoadOrderLineEntityInstanceData Method

This method pulls the required elements from the OrderLineGE as opposed to going to the database since the OrderLine GE data is live.

protected virtual DataRow LoadOrderLineEntityInstanceData(
OrderLinesEntity OrderLineGE,
FilterRule oFilterRule
);

Parameters

OrderLineGE
oFilterRule

Return Value

Remarks

See Also

ShippingCalculator Class | Aptify.Applications.OrderEntry Namespace


ShippingCalculator.LoadProductInstanceData Method

This method pulls the required elements from the ProductData cache as opposed to going to the database since the Product data is live.

protected virtual DataRow LoadProductInstanceData(
ProductData productData,
FilterRule oFilterRule
);

Parameters

productData
oFilterRule

Return Value

Remarks

See Also

ShippingCalculator Class | Aptify.Applications.OrderEntry Namespace


ShippingCalculator.LoadShipmentTypeGroupingInstanceData Method

This method pulls the required elements from the ShipmentTypeGrouping cache as opposed to going to the database since the ShipmentTypeGrouping data is live.

protected virtual DataRow LoadShipmentTypeGroupingInstanceData(
ShipmentTypeGroupingData Grouping,
FilterRule oFilterRule
);

Parameters

Grouping
oFilterRule

Return Value

Remarks

See Also

ShippingCalculator Class | Aptify.Applications.OrderEntry Namespace


ShippingCalculator.LoadShipmentTypeInstanceData Method

This method pulls the required elements from the ShipmentType cache as opposed to going to the database since the ShipmentType data is live.

protected virtual DataRow LoadShipmentTypeInstanceData(
ShipmentTypeData ShipmentType,
FilterRule oFilterRule
);

Parameters

ShipmentType
oFilterRule

Return Value

Remarks

See Also

ShippingCalculator Class | Aptify.Applications.OrderEntry Namespace


ShippingCalculator.PopulateOrderShipments Method

Process the Order Lines and create one OrderShipment GE for each ShipTo and ShipToAddress combination. Use the DetermineShipmentType method to set ShipTypeID for each OrderShipment.

protected virtual void PopulateOrderShipments(
OrdersEntity OrderGE
);

Remarks

See Also

ShippingCalculator Class | Aptify.Applications.OrderEntry Namespace


StatusForm Class

For a list of all members of this type, see StatusForm Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
StatusForm

public class StatusForm : Form

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersExtension (in AptifyOrdersExtension.dll)

See Also

StatusForm Members | Aptify.Applications.OrderEntry Namespace


StatusForm Members

StatusForm overview

Public Instance Constructors

StatusForm Constructor Initializes a new instance of the StatusForm class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DoLocalization |
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
UpdateStatus | Overloaded.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

StatusForm Class | Aptify.Applications.OrderEntry Namespace


StatusForm Constructor

Initializes a new instance of the StatusForm class.

public StatusForm();

See Also

StatusForm Class | Aptify.Applications.OrderEntry Namespace


StatusForm Methods

The methods of the StatusForm class are listed below. For a complete list of StatusForm class members, see the StatusForm Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DoLocalization |
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
UpdateStatus | Overloaded.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

StatusForm Class | Aptify.Applications.OrderEntry Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

StatusForm.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

StatusForm Class | Aptify.Applications.OrderEntry Namespace


StatusForm.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

StatusForm Class | Aptify.Applications.OrderEntry Namespace | StatusForm.Dispose Overload List


StatusForm.DoLocalization Method

public void DoLocalization(
UserCredentials oUserCredential
);

See Also

StatusForm Class | Aptify.Applications.OrderEntry Namespace


UpdateStatus Method

Aptify 5.0 Software Development Kit (SDK)

StatusForm.UpdateStatus Method

Overload List

public void UpdateStatus(Int32);

public void UpdateStatus(String);

public void UpdateStatus(String,Int32);

public void UpdateStatus(String,Int32,Int32);

See Also

StatusForm Class | Aptify.Applications.OrderEntry Namespace


StatusForm.UpdateStatus Method (Int32)

public void UpdateStatus(
Int32 iVal
);

See Also

StatusForm Class | Aptify.Applications.OrderEntry Namespace | StatusForm.UpdateStatus Overload List


StatusForm.UpdateStatus Method (String)

public void UpdateStatus(
String sMessage
);

See Also

StatusForm Class | Aptify.Applications.OrderEntry Namespace | StatusForm.UpdateStatus Overload List


StatusForm.UpdateStatus Method (String, Int32)

public void UpdateStatus(
String sMessage,
Int32 iVal
);

See Also

StatusForm Class | Aptify.Applications.OrderEntry Namespace | StatusForm.UpdateStatus Overload List


StatusForm.UpdateStatus Method (String, Int32, Int32)

public void UpdateStatus(
String sMessage,
Int32 iVal,
Int32 iMax
);

See Also

StatusForm Class | Aptify.Applications.OrderEntry Namespace | StatusForm.UpdateStatus Overload List


TaxAddress Class

For a list of all members of this type, see TaxAddress Members.

System.Object
TaxAddress

public class TaxAddress

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

TaxAddress Members | Aptify.Applications.OrderEntry Namespace


TaxAddress Members

TaxAddress overview

Public Static Operators

Equality Operator
Inequality Operator

Public Instance Constructors

TaxAddress Constructor Initializes a new instance of the TaxAddress class.

Public Instance Properties

City
CountryID
County
PostalCode
StateProvince

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SetFromAptifyAddress |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TaxAddress Class | Aptify.Applications.OrderEntry Namespace


TaxAddress Constructor

Initializes a new instance of the TaxAddress class.

public TaxAddress();

See Also

TaxAddress Class | Aptify.Applications.OrderEntry Namespace


TaxAddress Properties

The properties of the TaxAddress class are listed below. For a complete list of TaxAddress class members, see the TaxAddress Members topic.

Public Instance Properties

City
CountryID
County
PostalCode
StateProvince

See Also

TaxAddress Class | Aptify.Applications.OrderEntry Namespace


City Property

Aptify 5.0 Software Development Kit (SDK)

TaxAddress.City Property

public String City {get; set;}

See Also

TaxAddress Class | Aptify.Applications.OrderEntry Namespace


CountryID Property

Aptify 5.0 Software Development Kit (SDK)

TaxAddress.CountryID Property

public Int32 CountryID {get; set;}

See Also

TaxAddress Class | Aptify.Applications.OrderEntry Namespace


County Property

Aptify 5.0 Software Development Kit (SDK)

TaxAddress.County Property

public String County {get; set;}

See Also

TaxAddress Class | Aptify.Applications.OrderEntry Namespace


PostalCode Property

Aptify 5.0 Software Development Kit (SDK)

TaxAddress.PostalCode Property

public String PostalCode {get; set;}

See Also

TaxAddress Class | Aptify.Applications.OrderEntry Namespace


StateProvince Property

Aptify 5.0 Software Development Kit (SDK)

TaxAddress.StateProvince Property

public String StateProvince {get; set;}

See Also

TaxAddress Class | Aptify.Applications.OrderEntry Namespace


TaxAddress Methods

The methods of the TaxAddress class are listed below. For a complete list of TaxAddress class members, see the TaxAddress Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SetFromAptifyAddress |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TaxAddress Class | Aptify.Applications.OrderEntry Namespace


TaxAddress.SetFromAptifyAddress Method

public void SetFromAptifyAddress(
AptifyGenericEntityBase AddressGE
);

See Also

TaxAddress Class | Aptify.Applications.OrderEntry Namespace


TaxAddress Operators

The operators of the TaxAddress class are listed below. For a complete list of TaxAddress class members, see the TaxAddress Members topic.

Public Static Operators

Equality Operator
Inequality Operator

See Also

TaxAddress Class | TaxAddress Members | Aptify.Applications.OrderEntry Namespace


TaxAddress Equality Operator

public static bool operator ==(
TaxAddress a,
Object b
);

See Also

TaxAddress Class | Aptify.Applications.OrderEntry Namespace


TaxAddress Inequality Operator

public static bool operator !=(
TaxAddress a,
Object b
);

See Also

TaxAddress Class | Aptify.Applications.OrderEntry Namespace


TotalsChangedEventArgs Class

For a list of all members of this type, see TotalsChangedEventArgs Members.

System.Object
EventArgs
TotalsChangedEventArgs

public class TotalsChangedEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrderLineControl (in AptifyOrderLineControl.dll)

See Also

TotalsChangedEventArgs Members | Aptify.Applications.OrderEntry Namespace


TotalsChangedEventArgs Members

TotalsChangedEventArgs overview

Public Instance Constructors

TotalsChangedEventArgs Constructor

Public Instance Properties

DiscountTotal
GrandTotal
HandlingCharge
SalesTax
ShippingCharge
SubTotal

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TotalsChangedEventArgs Class | Aptify.Applications.OrderEntry Namespace


TotalsChangedEventArgs Constructor

public TotalsChangedEventArgs(
Decimal SubTotal,
Decimal ShippingCharge,
Decimal HandlingCharge,
Decimal SalesTax,
Decimal DiscountTotal,
Decimal GrandTotal
);

See Also

TotalsChangedEventArgs Class | Aptify.Applications.OrderEntry Namespace


TotalsChangedEventArgs Properties

The properties of the TotalsChangedEventArgs class are listed below. For a complete list of TotalsChangedEventArgs class members, see the TotalsChangedEventArgs Members topic.

Public Instance Properties

DiscountTotal
GrandTotal
HandlingCharge
SalesTax
ShippingCharge
SubTotal

See Also

TotalsChangedEventArgs Class | Aptify.Applications.OrderEntry Namespace


DiscountTotal Property

Aptify 5.0 Software Development Kit (SDK)

TotalsChangedEventArgs.DiscountTotal Property

public Decimal DiscountTotal {get;}

See Also

TotalsChangedEventArgs Class | Aptify.Applications.OrderEntry Namespace


GrandTotal Property

Aptify 5.0 Software Development Kit (SDK)

TotalsChangedEventArgs.GrandTotal Property

public Decimal GrandTotal {get;}

See Also

TotalsChangedEventArgs Class | Aptify.Applications.OrderEntry Namespace


HandlingCharge Property

Aptify 5.0 Software Development Kit (SDK)

TotalsChangedEventArgs.HandlingCharge Property

public Decimal HandlingCharge {get;}

See Also

TotalsChangedEventArgs Class | Aptify.Applications.OrderEntry Namespace


SalesTax Property

Aptify 5.0 Software Development Kit (SDK)

TotalsChangedEventArgs.SalesTax Property

public Decimal SalesTax {get;}

See Also

TotalsChangedEventArgs Class | Aptify.Applications.OrderEntry Namespace


ShippingCharge Property

Aptify 5.0 Software Development Kit (SDK)

TotalsChangedEventArgs.ShippingCharge Property

public Decimal ShippingCharge {get;}

See Also

TotalsChangedEventArgs Class | Aptify.Applications.OrderEntry Namespace


SubTotal Property

Aptify 5.0 Software Development Kit (SDK)

TotalsChangedEventArgs.SubTotal Property

public Decimal SubTotal {get;}

See Also

TotalsChangedEventArgs Class | Aptify.Applications.OrderEntry Namespace


Weight Structure

For a list of all members of this type, see Weight Members.

System.Object
ValueType
Weight

public struct Weight

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

Weight Members | Aptify.Applications.OrderEntry Namespace


Weight Members

Weight overview

Public Static Fields

m_oUserCredential

Public Static Methods

ConvertValue

Public Static Operators

Addition Operator
Subtraction Operator

Public Instance Constructors

Weight Overloaded. Initializes a new instance of the Weight class.

Public Instance Properties

Units |
Value | Overloaded.

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

Weight Structure | Aptify.Applications.OrderEntry Namespace


Weight Constructor

Overload List

public Weight(Decimal);

public Weight(Decimal,ProductData.WeightUnitsOfMeasure);

See Also

Weight Structure | Aptify.Applications.OrderEntry Namespace


Weight Constructor (Decimal)

public Weight(
Decimal Value
);

See Also

Weight Structure | Aptify.Applications.OrderEntry Namespace | Weight Constructor Overload List


Weight Constructor (Decimal, WeightUnitsOfMeasure)

public Weight(
Decimal Weight,
ProductData.WeightUnitsOfMeasure Units
);

See Also

Weight Structure | Aptify.Applications.OrderEntry Namespace | Weight Constructor Overload List


Weight Fields

The fields of the Weight structure are listed below. For a complete list of Weight structure members, see the Weight Members topic.

Public Static Fields

m_oUserCredential

See Also

Weight Structure | Aptify.Applications.OrderEntry Namespace


Weight.m_oUserCredential Field

public static m_oUserCredential m_oUserCredential;

See Also

Weight Class | Aptify.Applications.OrderEntry Namespace


Weight Properties

The properties of the Weight structure are listed below. For a complete list of Weight structure members, see the Weight Members topic.

Public Instance Properties

Units |
Value | Overloaded.

See Also

Weight Structure | Aptify.Applications.OrderEntry Namespace


Units Property

Aptify 5.0 Software Development Kit (SDK)

Weight.Units Property

public ProductData.WeightUnitsOfMeasure Units {get;}

See Also

Weight Structure | Aptify.Applications.OrderEntry Namespace


Decimal Property

Aptify 5.0 Software Development Kit (SDK)

Weight.Decimal Property

Overload List

public Decimal Value {get;}

public Decimal this[ProductData.WeightUnitsOfMeasure] {get;}

See Also

Weight Structure | Aptify.Applications.OrderEntry Namespace


Value Property

Aptify 5.0 Software Development Kit (SDK)

Weight.Value Property

public Decimal Value {get;}

See Also

Weight Structure | Aptify.Applications.OrderEntry Namespace | Weight.Decimal Overload List


Value Property (WeightUnitsOfMeasure)

Aptify 5.0 Software Development Kit (SDK)

Weight.Value Property (WeightUnitsOfMeasure)

public Decimal this[
ProductData.WeightUnitsOfMeasure RequestedUnits
] {get;}

See Also

Weight Structure | Aptify.Applications.OrderEntry Namespace | Weight.Decimal Overload List


Weight Methods

The methods of the Weight structure are listed below. For a complete list of Weight structure members, see the Weight Members topic.

Public Static Methods

ConvertValue

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

Weight Structure | Aptify.Applications.OrderEntry Namespace


Weight.ConvertValue Method

public static decimal ConvertValue(
Decimal ValueToConvert,
ProductData.WeightUnitsOfMeasure CurrentUnits,
ProductData.WeightUnitsOfMeasure NewUnits
);

See Also

Weight Structure | Aptify.Applications.OrderEntry Namespace


Weight Operators

The operators of the Weight structure are listed below. For a complete list of Weight structure members, see the Weight Members topic.

Public Static Operators

Addition Operator
Subtraction Operator

See Also

Weight Structure | Weight Members | Aptify.Applications.OrderEntry Namespace


Weight Addition Operator

public static Weight operator +(
Weight a,
Object b
);

See Also

Weight Structure | Aptify.Applications.OrderEntry Namespace


Weight Subtraction Operator

public static Weight operator -(
Weight a,
Object b
);

See Also

Weight Structure | Aptify.Applications.OrderEntry Namespace


WizardText Class

For a list of all members of this type, see WizardText Members.

System.Object
WizardText

public class WizardText

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry

Assembly: CancellationWizard (in CancellationWizard.dll)

See Also

WizardText Members | Aptify.Applications.OrderEntry Namespace


WizardText Members

WizardText overview

Public Instance Constructors

WizardText Constructor

Public Instance Fields

PageText
PageTitle

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

WizardText Class | Aptify.Applications.OrderEntry Namespace


WizardText Constructor

public WizardText(
String sPageTitle,
String sPageText
);

See Also

WizardText Class | Aptify.Applications.OrderEntry Namespace


WizardText Fields

The fields of the WizardText class are listed below. For a complete list of WizardText class members, see the WizardText Members topic.

Public Instance Fields

PageText
PageTitle

See Also

WizardText Class | Aptify.Applications.OrderEntry Namespace


WizardText.PageText Field

public PageText PageText;

See Also

WizardText Class | Aptify.Applications.OrderEntry Namespace


WizardText.PageTitle Field

public PageTitle PageTitle;

See Also

WizardText Class | Aptify.Applications.OrderEntry Namespace


Aptify.Applications.OrderEntry.Payments

Aptify 5.0 Software Development Kit (SDK)

Aptify.Applications.OrderEntry.Payments Namespace

The objects in this namespace corresponds to Aptify's Payment processing functionality.

Namespace hierarchy

Classes

Class | Description
ButtonFormComponent |
CaptureWizForm |
CaptureWizObject |
CaptureWizObject.MerchantAccount |
ElectronicPaymentAuthorizationParams | This class is used to contain all of the data used to perform the various types of payment authorizations used by the most common payment verification data providers.
ElectronicPaymentBase |
ElectronicPaymentCaptureParams |
ElectronicPaymentSample |
Extension |
PaymentAuthorizationsLayout |
PaymentGenerateGL | This object implements the Aptify.Applications.Accounting.IGenerateGL interface. The purpose of this component is to generate GL entries for a payment
PaymentGenerateGL.GLEntry |
PaymentGenerateGL.OrderInfo | This class is used within the PaymentGenerateGL class to keep track of order information
PaymentGenerateGL.QueryResult | This class is used within the PaymentGenerateGL to store the results of queries on the order entry database.
PaymentGLEntriesLayout |
PaymentLayout |
PaymentLines |
PaymentLinesEntity |
PaymentLinesLayout |
PaymentsEntity |
PaymentsEntity.PaymentBatchInfo |
PaymentsEntity.PaymentOrderInfo |
PaymentSTLayoutBase |
PaymentSTLayoutBase.OrderLayoutCurrencyControls |
Status |

Delegates

Delegate | Description
ButtonFormComponent.ButtonClickEventHandler |
CaptureWizObject.AfterCapturePaymentEventHandler |
CaptureWizObject.AfterCapturePaymentFailedEventHandler |
CaptureWizObject.BeforeCapturePaymentEventHandler |
CaptureWizObject.BeforeStartCaptureProcessEventHandler |
CaptureWizObject.StatusEventHandler |
CaptureWizObject.TerminateWizardEventHandler |
PaymentsEntity.PaymentStateChangeEventHandler |
PaymentsEntity.ProgressUpdateEventHandler |

Enumerations

Enumeration | Description
ElectronicPaymentBase.ACHAccountTypes |
ElectronicPaymentBase.AuthorizationTypes |
ElectronicPaymentBase.ConnectionStatusTypes |
ElectronicPaymentBase.CreditCardValidationTypes |
ElectronicPaymentBase.ElectronicPaymentResults | Indicates the results of a payment verification.
ElectronicPaymentBase.FraudCheckLevels |
ElectronicPaymentBase.MessageTypes |
ElectronicPaymentBase.TenderTypes |
PaymentGenerateGL.InterCompanyAccountType |
PaymentGenerateGL.NormalBalanceType |
PaymentGenerateGL.QueryResultType |
PaymentLinesEntity.AppliesToType |
PaymentsEntity.BasePaymentTypes |
PaymentsEntity.PaymentAppliesToType |
PaymentsEntity.PaymentOrderInfo.OrderTypes |
PaymentsEntity.PaymentStatusType |
Status.StatusPopupStyle |


ButtonFormComponent Class

For a list of all members of this type, see ButtonFormComponent Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
ButtonFormComponent

public class ButtonFormComponent : FormComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry.Payments

Assembly: PaymentGUI (in PaymentGUI.dll)

See Also

ButtonFormComponent Members | Aptify.Applications.OrderEntry.Payments Namespace


ButtonFormComponent Members

ButtonFormComponent overview

Public Instance Constructors

ButtonFormComponent Constructor Initializes a new instance of the ButtonFormComponent class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
ButtonKey |
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormComponent) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
ButtonClick |
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateContext (inherited from FormComponent) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormComponent) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormComponent) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormComponent) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ButtonFormComponent Class | Aptify.Applications.OrderEntry.Payments Namespace


ButtonFormComponent Constructor

Initializes a new instance of the ButtonFormComponent class.

public ButtonFormComponent();

See Also

ButtonFormComponent Class | Aptify.Applications.OrderEntry.Payments Namespace


ButtonFormComponent Properties

The properties of the ButtonFormComponent class are listed below. For a complete list of ButtonFormComponent class members, see the ButtonFormComponent Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
ButtonKey |
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateContext (inherited from FormComponent) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

ButtonFormComponent Class | Aptify.Applications.OrderEntry.Payments Namespace


ButtonKey Property

Aptify 5.0 Software Development Kit (SDK)

ButtonFormComponent.ButtonKey Property

public String ButtonKey {get; set;}

See Also

ButtonFormComponent Class | Aptify.Applications.OrderEntry.Payments Namespace


ButtonFormComponent Methods

The methods of the ButtonFormComponent class are listed below. For a complete list of ButtonFormComponent class members, see the ButtonFormComponent Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormComponent) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormComponent) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormComponent) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormComponent) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ButtonFormComponent Class | Aptify.Applications.OrderEntry.Payments Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

ButtonFormComponent.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

ButtonFormComponent Class | Aptify.Applications.OrderEntry.Payments Namespace


ButtonFormComponent.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

ButtonFormComponent Class | Aptify.Applications.OrderEntry.Payments Namespace | ButtonFormComponent.Dispose Overload List


ButtonFormComponent.OnFormComponentConfig Method

protected override void OnFormComponentConfig(
AptifyFormTemplateContext FormTemplateContext
);

Implements

IFormComponent.

See Also

ButtonFormComponent Class | Aptify.Applications.OrderEntry.Payments Namespace


ButtonFormComponent Events

The events of the ButtonFormComponent class are listed below. For a complete list of ButtonFormComponent class members, see the ButtonFormComponent Members topic.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
ButtonClick |
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

ButtonFormComponent Class | Aptify.Applications.OrderEntry.Payments Namespace


ButtonFormComponent.ButtonFormComponent.ButtonClickEventHandler Event

public event ButtonFormComponent.ButtonClickEventHandler ButtonClick;

See Also

ButtonFormComponent Class | Aptify.Applications.OrderEntry.Payments Namespace


ButtonFormComponent.ButtonClickEventHandler Delegate

public delegate void ButtonFormComponent.ButtonClickEventHandler();

Requirements

Namespace: Aptify.Applications.OrderEntry.Payments

Assembly: PaymentGUI (in PaymentGUI.dll)

See Also

Aptify.Applications.OrderEntry.Payments Namespace


CaptureWizForm Class

For a list of all members of this type, see CaptureWizForm Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
CaptureWizForm

public class CaptureWizForm : Form, IAptifyAction

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry.Payments

Assembly: CaptureWizard (in CaptureWizard.dll)

See Also

CaptureWizForm Members | Aptify.Applications.OrderEntry.Payments Namespace


CaptureWizForm Members

CaptureWizForm overview

Public Instance Constructors

CaptureWizForm Constructor Initializes a new instance of the CaptureWizForm class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoAction | Overloaded.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CaptureWizForm Class | Aptify.Applications.OrderEntry.Payments Namespace


CaptureWizForm Constructor

Initializes a new instance of the CaptureWizForm class.

public CaptureWizForm();

See Also

CaptureWizForm Class | Aptify.Applications.OrderEntry.Payments Namespace


CaptureWizForm Methods

The methods of the CaptureWizForm class are listed below. For a complete list of CaptureWizForm class members, see the CaptureWizForm Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoAction | Overloaded.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CaptureWizForm Class | Aptify.Applications.OrderEntry.Payments Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

CaptureWizForm.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

CaptureWizForm Class | Aptify.Applications.OrderEntry.Payments Namespace


CaptureWizForm.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

CaptureWizForm Class | Aptify.Applications.OrderEntry.Payments Namespace | CaptureWizForm.Dispose Overload List


DoAction Method

Aptify 5.0 Software Development Kit (SDK)

CaptureWizForm.DoAction Method

Overload List

public void DoAction(AptifyApplication,Int64);

public void DoAction(AptifyApplication,Int64,Int64);

public void DoAction(AptifyApplication,Int64,Int64,params Object[]);

public void DoAction(AptifyApplication,Int64,params String[]);

See Also

CaptureWizForm Class | Aptify.Applications.OrderEntry.Payments Namespace


CaptureWizForm.DoAction Method (AptifyApplication, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID
);

Implements

IAptifyAction.

See Also

CaptureWizForm Class | Aptify.Applications.OrderEntry.Payments Namespace | CaptureWizForm.DoAction Overload List


CaptureWizForm.DoAction Method (AptifyApplication, Int64, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID
);

Implements

IAptifyAction.

See Also

CaptureWizForm Class | Aptify.Applications.OrderEntry.Payments Namespace | CaptureWizForm.DoAction Overload List


CaptureWizForm.DoAction Method (AptifyApplication, Int64, Int64, Object[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID,
params Object[] SelectedItems
);

Implements

IAptifyAction.

See Also

CaptureWizForm Class | Aptify.Applications.OrderEntry.Payments Namespace | CaptureWizForm.DoAction Overload List


CaptureWizForm.DoAction Method (AptifyApplication, Int64, String[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
params String[] SelectedItems
);

Implements

IAptifyAction.

See Also

CaptureWizForm Class | Aptify.Applications.OrderEntry.Payments Namespace | CaptureWizForm.DoAction Overload List


CaptureWizObject Class

For a list of all members of this type, see CaptureWizObject Members.

System.Object
CaptureWizObject

public class CaptureWizObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry.Payments

Assembly: CaptureWizard (in CaptureWizard.dll)

See Also

CaptureWizObject Members | Aptify.Applications.OrderEntry.Payments Namespace


CaptureWizObject Members

CaptureWizObject overview

Public Instance Constructors

CaptureWizObject Constructor Initializes a new instance of the CaptureWizObject class.

Public Instance Fields

m_sDatabase
m_sEntity
m_sMerchantFilter

Public Instance Properties

ExcludeData
HasQualifiedPayments
IncludeData

Public Instance Methods

BetterInStr |
CapturePayments |
Configure |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEPaymentCaptureObject |
GetFormatString | Overloaded.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
GetViewFilter |
MinNot |
ModifyViewSQL |
ReplaceCRLF |
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

AfterCapturePayment
AfterCapturePaymentFailed
BeforeCapturePayment
BeforeStartCaptureProcess
Status
TerminateWizard

Protected Instance Properties

DataAction
ExcludePayments
IncludedPayments

Protected Instance Methods

ConfigureMerchantAccounts |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCapturePayment |
OnAfterCapturePaymentFailed |
OnBeforeCapturePayment |
OnBeforeStartCaptureProcess |
OnStatus |
UpdatePaymentRecord |

See Also

CaptureWizObject Class | Aptify.Applications.OrderEntry.Payments Namespace


CaptureWizObject Constructor

Initializes a new instance of the CaptureWizObject class.

public CaptureWizObject();

See Also

CaptureWizObject Class | Aptify.Applications.OrderEntry.Payments Namespace


CaptureWizObject Fields

The fields of the CaptureWizObject class are listed below. For a complete list of CaptureWizObject class members, see the CaptureWizObject Members topic.

Public Instance Fields

m_sDatabase
m_sEntity
m_sMerchantFilter

See Also

CaptureWizObject Class | Aptify.Applications.OrderEntry.Payments Namespace


CaptureWizObject.m_sDatabase Field

public m_sDatabase m_sDatabase;

See Also

CaptureWizObject Class | Aptify.Applications.OrderEntry.Payments Namespace


CaptureWizObject.m_sEntity Field

public m_sEntity m_sEntity;

See Also

CaptureWizObject Class | Aptify.Applications.OrderEntry.Payments Namespace


CaptureWizObject.m_sMerchantFilter Field

public m_sMerchantFilter m_sMerchantFilter;

See Also

CaptureWizObject Class | Aptify.Applications.OrderEntry.Payments Namespace


CaptureWizObject Properties

The properties of the CaptureWizObject class are listed below. For a complete list of CaptureWizObject class members, see the CaptureWizObject Members topic.

Public Instance Properties

ExcludeData
HasQualifiedPayments
IncludeData

Protected Instance Properties

DataAction
ExcludePayments
IncludedPayments

See Also

CaptureWizObject Class | Aptify.Applications.OrderEntry.Payments Namespace


DataAction Property

Aptify 5.0 Software Development Kit (SDK)

CaptureWizObject.DataAction Property

protected DataAction DataAction {get;}

See Also

CaptureWizObject Class | Aptify.Applications.OrderEntry.Payments Namespace


ExcludeData Property

Aptify 5.0 Software Development Kit (SDK)

CaptureWizObject.ExcludeData Property

public DataTable ExcludeData {get;}

See Also

CaptureWizObject Class | Aptify.Applications.OrderEntry.Payments Namespace


ExcludePayments Property

Aptify 5.0 Software Development Kit (SDK)

CaptureWizObject.ExcludePayments Property

protected DataTable ExcludePayments {get;}

See Also

CaptureWizObject Class | Aptify.Applications.OrderEntry.Payments Namespace


HasQualifiedPayments Property

Aptify 5.0 Software Development Kit (SDK)

CaptureWizObject.HasQualifiedPayments Property

public Boolean HasQualifiedPayments {get;}

See Also

CaptureWizObject Class | Aptify.Applications.OrderEntry.Payments Namespace


IncludeData Property

Aptify 5.0 Software Development Kit (SDK)

CaptureWizObject.IncludeData Property

public DataTable IncludeData {get;}

See Also

CaptureWizObject Class | Aptify.Applications.OrderEntry.Payments Namespace


IncludedPayments Property

Aptify 5.0 Software Development Kit (SDK)

CaptureWizObject.IncludedPayments Property

protected DataTable IncludedPayments {get;}

See Also

CaptureWizObject Class | Aptify.Applications.OrderEntry.Payments Namespace


CaptureWizObject Methods

The methods of the CaptureWizObject class are listed below. For a complete list of CaptureWizObject class members, see the CaptureWizObject Members topic.

Public Instance Methods

BetterInStr |
CapturePayments |
Configure |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEPaymentCaptureObject |
GetFormatString | Overloaded.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
GetViewFilter |
MinNot |
ModifyViewSQL |
ReplaceCRLF |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

ConfigureMerchantAccounts |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCapturePayment |
OnAfterCapturePaymentFailed |
OnBeforeCapturePayment |
OnBeforeStartCaptureProcess |
OnStatus |
UpdatePaymentRecord |

See Also

CaptureWizObject Class | Aptify.Applications.OrderEntry.Payments Namespace


CaptureWizObject.BetterInStr Method

public object BetterInStr(
String sStr,
String sTerm,
Int64 iType
);

See Also

CaptureWizObject Class | Aptify.Applications.OrderEntry.Payments Namespace


CaptureWizObject.CapturePayments Method

public bool CapturePayments();

See Also

CaptureWizObject Class | Aptify.Applications.OrderEntry.Payments Namespace


CaptureWizObject.Configure Method

public void Configure(
AptifyApplication Application,
Int64 lViewID
);

See Also

CaptureWizObject Class | Aptify.Applications.OrderEntry.Payments Namespace


CaptureWizObject.ConfigureMerchantAccounts Method

protected virtual Dictionary<TKey,TValue> ConfigureMerchantAccounts();

See Also

CaptureWizObject Class | Aptify.Applications.OrderEntry.Payments Namespace


CaptureWizObject.GetEPaymentCaptureObject Method

public ElectronicPaymentBase GetEPaymentCaptureObject(
Int64 lMerchantAcctID
);

See Also

CaptureWizObject Class | Aptify.Applications.OrderEntry.Payments Namespace


GetFormatString Method

Aptify 5.0 Software Development Kit (SDK)

CaptureWizObject.GetFormatString Method

Overload List

public string GetFormatString();

public string GetFormatString(Int64);

See Also

CaptureWizObject Class | Aptify.Applications.OrderEntry.Payments Namespace


CaptureWizObject.GetFormatString Method ()

public string GetFormatString();

See Also

CaptureWizObject Class | Aptify.Applications.OrderEntry.Payments Namespace | CaptureWizObject.GetFormatString Overload List


CaptureWizObject.GetFormatString Method (Int64)

public string GetFormatString(
Int64 lCurrencyTypeID
);

See Also

CaptureWizObject Class | Aptify.Applications.OrderEntry.Payments Namespace | CaptureWizObject.GetFormatString Overload List


CaptureWizObject.GetViewFilter Method

public string GetViewFilter(
String sViewSQL
);

See Also

CaptureWizObject Class | Aptify.Applications.OrderEntry.Payments Namespace


CaptureWizObject.MinNot Method

public long MinNot(
Int64 iNot,
Int64 iOne,
Int64 iTwo
);

See Also

CaptureWizObject Class | Aptify.Applications.OrderEntry.Payments Namespace


CaptureWizObject.ModifyViewSQL Method

public string ModifyViewSQL(
String sSQL,
Boolean bExclude
);

See Also

CaptureWizObject Class | Aptify.Applications.OrderEntry.Payments Namespace


CaptureWizObject.OnAfterCapturePayment Method

protected virtual void OnAfterCapturePayment(
Int64 lPaymentID,
Decimal dAmount,
String sResultReference,
ref Boolean& bCancel
);

See Also

CaptureWizObject Class | Aptify.Applications.OrderEntry.Payments Namespace


CaptureWizObject.OnAfterCapturePaymentFailed Method

protected virtual void OnAfterCapturePaymentFailed(
Int64 lPaymentID,
String sErrMsg
);

See Also

CaptureWizObject Class | Aptify.Applications.OrderEntry.Payments Namespace


CaptureWizObject.OnBeforeCapturePayment Method

protected virtual void OnBeforeCapturePayment(
Int64 lPaymentID,
ref Boolean& bCancel
);

See Also

CaptureWizObject Class | Aptify.Applications.OrderEntry.Payments Namespace


CaptureWizObject.OnBeforeStartCaptureProcess Method

protected virtual void OnBeforeStartCaptureProcess(
Boolean bCancel
);

See Also

CaptureWizObject Class | Aptify.Applications.OrderEntry.Payments Namespace


CaptureWizObject.OnStatus Method

protected virtual void OnStatus(
String lMessage,
Int32 iMax,
Int32 iCurrent,
ref Boolean& bCancel
);

See Also

CaptureWizObject Class | Aptify.Applications.OrderEntry.Payments Namespace


CaptureWizObject.ReplaceCRLF Method

public string ReplaceCRLF(
String sIn
);

See Also

CaptureWizObject Class | Aptify.Applications.OrderEntry.Payments Namespace


CaptureWizObject.UpdatePaymentRecord Method

protected void UpdatePaymentRecord(
Int64 PaymentID,
String AuthCode,
String ReferenceNumber,
Decimal Amount,
String ResultRefNumber,
Int64 MerchantAccountID
);

See Also

CaptureWizObject Class | Aptify.Applications.OrderEntry.Payments Namespace


CaptureWizObject Events

The events of the CaptureWizObject class are listed below. For a complete list of CaptureWizObject class members, see the CaptureWizObject Members topic.

Public Instance Events

AfterCapturePayment
AfterCapturePaymentFailed
BeforeCapturePayment
BeforeStartCaptureProcess
Status
TerminateWizard

See Also

CaptureWizObject Class | Aptify.Applications.OrderEntry.Payments Namespace


CaptureWizObject.CaptureWizObject.AfterCapturePaymentEventHandler Event

public event CaptureWizObject.AfterCapturePaymentEventHandler AfterCapturePayment;

See Also

CaptureWizObject Class | Aptify.Applications.OrderEntry.Payments Namespace


CaptureWizObject.CaptureWizObject.AfterCapturePaymentFailedEventHandler Event

public event CaptureWizObject.AfterCapturePaymentFailedEventHandler AfterCapturePaymentFailed;

See Also

CaptureWizObject Class | Aptify.Applications.OrderEntry.Payments Namespace


CaptureWizObject.CaptureWizObject.BeforeCapturePaymentEventHandler Event

public event CaptureWizObject.BeforeCapturePaymentEventHandler BeforeCapturePayment;

See Also

CaptureWizObject Class | Aptify.Applications.OrderEntry.Payments Namespace


CaptureWizObject.CaptureWizObject.BeforeStartCaptureProcessEventHandler Event

public event CaptureWizObject.BeforeStartCaptureProcessEventHandler BeforeStartCaptureProcess;

See Also

CaptureWizObject Class | Aptify.Applications.OrderEntry.Payments Namespace


CaptureWizObject.CaptureWizObject.StatusEventHandler Event

public event CaptureWizObject.StatusEventHandler Status;

See Also

CaptureWizObject Class | Aptify.Applications.OrderEntry.Payments Namespace


CaptureWizObject.CaptureWizObject.TerminateWizardEventHandler Event

public event CaptureWizObject.TerminateWizardEventHandler TerminateWizard;

See Also

CaptureWizObject Class | Aptify.Applications.OrderEntry.Payments Namespace


CaptureWizObject.AfterCapturePaymentEventHandler Delegate

public delegate void CaptureWizObject.AfterCapturePaymentEventHandler(
Int64 PaymentID,
Decimal Amount,
String ResultReference
);

Requirements

Namespace: Aptify.Applications.OrderEntry.Payments

Assembly: CaptureWizard (in CaptureWizard.dll)

See Also

Aptify.Applications.OrderEntry.Payments Namespace


CaptureWizObject.AfterCapturePaymentFailedEventHandler Delegate

public delegate void CaptureWizObject.AfterCapturePaymentFailedEventHandler(
Int64 PaymentID,
String ErrorMessage
);

Requirements

Namespace: Aptify.Applications.OrderEntry.Payments

Assembly: CaptureWizard (in CaptureWizard.dll)

See Also

Aptify.Applications.OrderEntry.Payments Namespace


CaptureWizObject.BeforeCapturePaymentEventHandler Delegate

public delegate void CaptureWizObject.BeforeCapturePaymentEventHandler(
Int64 PaymentID
);

Requirements

Namespace: Aptify.Applications.OrderEntry.Payments

Assembly: CaptureWizard (in CaptureWizard.dll)

See Also

Aptify.Applications.OrderEntry.Payments Namespace


CaptureWizObject.BeforeStartCaptureProcessEventHandler Delegate

public delegate void CaptureWizObject.BeforeStartCaptureProcessEventHandler();

Requirements

Namespace: Aptify.Applications.OrderEntry.Payments

Assembly: CaptureWizard (in CaptureWizard.dll)

See Also

Aptify.Applications.OrderEntry.Payments Namespace


CaptureWizObject.MerchantAccount Class

For a list of all members of this type, see CaptureWizObject.MerchantAccount Members.

System.Object
CaptureWizObject.MerchantAccount

protected class CaptureWizObject.MerchantAccount

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry.Payments

Assembly: CaptureWizard (in CaptureWizard.dll)

See Also

CaptureWizObject.MerchantAccount Members | Aptify.Applications.OrderEntry.Payments Namespace


CaptureWizObject.MerchantAccount Members

CaptureWizObject.MerchantAccount overview

Public Instance Constructors

CaptureWizObject.MerchantAccount Constructor Initializes a new instance of the CaptureWizObject.MerchantAccount class.

Public Instance Fields

bUseCGIRef
EPayObject
lCurrTypeID
lMerchantID
lPayTypeID
sName

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CaptureWizObject.MerchantAccount Class | Aptify.Applications.OrderEntry.Payments Namespace


CaptureWizObject.MerchantAccount Constructor

Initializes a new instance of the CaptureWizObject.MerchantAccount class.

public CaptureWizObject.MerchantAccount();

See Also

CaptureWizObject.MerchantAccount Class | Aptify.Applications.OrderEntry.Payments Namespace


CaptureWizObject.MerchantAccount Fields

The fields of the CaptureWizObject.MerchantAccount class are listed below. For a complete list of CaptureWizObject.MerchantAccount class members, see the CaptureWizObject.MerchantAccount Members topic.

Public Instance Fields

bUseCGIRef
EPayObject
lCurrTypeID
lMerchantID
lPayTypeID
sName

See Also

CaptureWizObject.MerchantAccount Class | Aptify.Applications.OrderEntry.Payments Namespace


CaptureWizObject.MerchantAccount.bUseCGIRef Field

public bUseCGIRef bUseCGIRef;

See Also

CaptureWizObject.MerchantAccount Class | Aptify.Applications.OrderEntry.Payments Namespace


CaptureWizObject.MerchantAccount.EPayObject Field

public EPayObject EPayObject;

See Also

CaptureWizObject.MerchantAccount Class | Aptify.Applications.OrderEntry.Payments Namespace


CaptureWizObject.MerchantAccount.lCurrTypeID Field

public lCurrTypeID lCurrTypeID;

See Also

CaptureWizObject.MerchantAccount Class | Aptify.Applications.OrderEntry.Payments Namespace


CaptureWizObject.MerchantAccount.lMerchantID Field

public lMerchantID lMerchantID;

See Also

CaptureWizObject.MerchantAccount Class | Aptify.Applications.OrderEntry.Payments Namespace


CaptureWizObject.MerchantAccount.lPayTypeID Field

public lPayTypeID lPayTypeID;

See Also

CaptureWizObject.MerchantAccount Class | Aptify.Applications.OrderEntry.Payments Namespace


CaptureWizObject.MerchantAccount.sName Field

public sName sName;

See Also

CaptureWizObject.MerchantAccount Class | Aptify.Applications.OrderEntry.Payments Namespace


CaptureWizObject.StatusEventHandler Delegate

public delegate void CaptureWizObject.StatusEventHandler(
String Message,
Int32 Max,
Int32 Current
);

Requirements

Namespace: Aptify.Applications.OrderEntry.Payments

Assembly: CaptureWizard (in CaptureWizard.dll)

See Also

Aptify.Applications.OrderEntry.Payments Namespace


CaptureWizObject.TerminateWizardEventHandler Delegate

public delegate void CaptureWizObject.TerminateWizardEventHandler(
String ErrorMessage
);

Requirements

Namespace: Aptify.Applications.OrderEntry.Payments

Assembly: CaptureWizard (in CaptureWizard.dll)

See Also

Aptify.Applications.OrderEntry.Payments Namespace


ElectronicPaymentAuthorizationParams Class

This class is used to contain all of the data used to perform the various types of payment authorizations used by the most common payment verification data providers.

For a list of all members of this type, see ElectronicPaymentAuthorizationParams Members.

System.Object
ElectronicPaymentAuthorizationParams

public class ElectronicPaymentAuthorizationParams

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.OrderEntry.Payments

Assembly: Payments (in Payments.dll)

See Also

ElectronicPaymentAuthorizationParams Members | Aptify.Applications.OrderEntry.Payments Namespace


ElectronicPaymentAuthorizationParams Members

ElectronicPaymentAuthorizationParams overview

Public Instance Constructors

ElectronicPaymentAuthorizationParams Constructor Initializes a new instance of the ElectronicPaymentAuthorizationParams class.

Public Instance Properties

ACHAccountType | Gets or sets the Automated Clearing House (ACH) type for the authorization.
AmountToAuthorize | Gets or sets the amount to authorize. This will be the total payment amount less any amounts previously captured.
AptifyMerchantID | Gets or sets the Aptify Merchant record ID for this verification.
AuthorizationType | Gets or sets the type of authorization procedure to perform.
AVSThreshold | Gets or sets the AVS Threshold for rejecting of accepting an authorization.
FraudCheckLevel | Gets or sets the Fraud Check Level to use for the authorization.
FraudThreshold | Gets or sets the Fraud Check Level Threshold for rejecting or accepting an authorization.
IsCorporate | Gets or sets whether the credit card to be authorized is a corporate card.
IsCredit | Gets or sets whether this authorization is requested for a credit transaction instead of a debit.
IsRegisteredWebCustomer |
IsVoiceAuthorization | Gets or sets whether this is a voice authorization.
MerchantName | Gets or sets the name of the merchant record for this verification.
OriginalProcessorRefNumber | Gets or sets the original processor reference number in an electronic verification transaction. This is used to send the original processor reference number for a refund transaction.
Payment | Gets or sets the Aptify Payment object to be authorized.
TenderType | Gets or sets the tender type for the current transaction.
TransactionDescription | Gets or sets the description of the transaction returned by the verification provider.
UseAVS | Gets or sets whether the authorization uses the verification provider's Address Verification Service (AVS).
UseCVV2 | Gets or sets whether to perform a Card Verification Value (CVV2) check on the payment verification.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ElectronicPaymentAuthorizationParams Class | Aptify.Applications.OrderEntry.Payments Namespace


ElectronicPaymentAuthorizationParams Constructor

Initializes a new instance of the ElectronicPaymentAuthorizationParams class.

public ElectronicPaymentAuthorizationParams();

See Also

ElectronicPaymentAuthorizationParams Class | Aptify.Applications.OrderEntry.Payments Namespace


ElectronicPaymentAuthorizationParams Properties

The properties of the ElectronicPaymentAuthorizationParams class are listed below. For a complete list of ElectronicPaymentAuthorizationParams class members, see the ElectronicPaymentAuthorizationParams Members topic.

Public Instance Properties

ACHAccountType | Gets or sets the Automated Clearing House (ACH) type for the authorization.
AmountToAuthorize | Gets or sets the amount to authorize. This will be the total payment amount less any amounts previously captured.
AptifyMerchantID | Gets or sets the Aptify Merchant record ID for this verification.
AuthorizationType | Gets or sets the type of authorization procedure to perform.
AVSThreshold | Gets or sets the AVS Threshold for rejecting of accepting an authorization.
FraudCheckLevel | Gets or sets the Fraud Check Level to use for the authorization.
FraudThreshold | Gets or sets the Fraud Check Level Threshold for rejecting or accepting an authorization.
IsCorporate | Gets or sets whether the credit card to be authorized is a corporate card.
IsCredit | Gets or sets whether this authorization is requested for a credit transaction instead of a debit.
IsRegisteredWebCustomer |
IsVoiceAuthorization | Gets or sets whether this is a voice authorization.
MerchantName | Gets or sets the name of the merchant record for this verification.
OriginalProcessorRefNumber | Gets or sets the original processor reference number in an electronic verification transaction. This is used to send the original processor reference number for a refund transaction.
Payment | Gets or sets the Aptify Payment object to be authorized.
TenderType | Gets or sets the tender type for the current transaction.
TransactionDescription | Gets or sets the description of the transaction returned by the verification provider.
UseAVS | Gets or sets whether the authorization uses the verification provider's Address Verification Service (AVS).
UseCVV2 | Gets or sets whether to perform a Card Verification Value (CVV2) check on the payment verification.

See Also

ElectronicPaymentAuthorizationParams Class | Aptify.Applications.OrderEntry.Payments Namespace


ACHAccountType Property

Aptify 5.0 Software Development Kit (SDK)

ElectronicPaymentAuthorizationParams.ACHAccountType Property

Gets or sets the Automated Clearing House (ACH) type for the authorization.

public ElectronicPaymentBase.ACHAccountTypes ACHAccountType {get; set;}

Property Value

ACHAccountTypes enumeration value.

Remarks

See Also

ElectronicPaymentAuthorizationParams Class | Aptify.Applications.OrderEntry.Payments Namespace


AmountToAuthorize Property

Aptify 5.0 Software Development Kit (SDK)

ElectronicPaymentAuthorizationParams.AmountToAuthorize Property

Gets or sets the amount to authorize. This will be the total payment amount less any amounts previously captured.

public Double AmountToAuthorize {get; set;}

Property Value

Remarks

See Also

ElectronicPaymentAuthorizationParams Class | Aptify.Applications.OrderEntry.Payments Namespace


AptifyMerchantID Property

Aptify 5.0 Software Development Kit (SDK)

ElectronicPaymentAuthorizationParams.AptifyMerchantID Property

Gets or sets the Aptify Merchant record ID for this verification.

public Int32 AptifyMerchantID {get; set;}

Property Value

Integer reflecting the Aptify Merchant ID.

Remarks

See Also

ElectronicPaymentAuthorizationParams Class | Aptify.Applications.OrderEntry.Payments Namespace


AuthorizationType Property

Aptify 5.0 Software Development Kit (SDK)

ElectronicPaymentAuthorizationParams.AuthorizationType Property

Gets or sets the type of authorization procedure to perform.

public ElectronicPaymentBase.AuthorizationTypes AuthorizationType {get; set;}

Property Value

AuthorizationTypes enumeration value.

Remarks

See Also

ElectronicPaymentAuthorizationParams Class | Aptify.Applications.OrderEntry.Payments Namespace


AVSThreshold Property

Aptify 5.0 Software Development Kit (SDK)

ElectronicPaymentAuthorizationParams.AVSThreshold Property

Gets or sets the AVS Threshold for rejecting of accepting an authorization.

public Int32 AVSThreshold {get; set;}

Property Value

Remarks

See Also

ElectronicPaymentAuthorizationParams Class | Aptify.Applications.OrderEntry.Payments Namespace


FraudCheckLevel Property

Aptify 5.0 Software Development Kit (SDK)

ElectronicPaymentAuthorizationParams.FraudCheckLevel Property

Gets or sets the Fraud Check Level to use for the authorization.

public ElectronicPaymentBase.FraudCheckLevels FraudCheckLevel {get; set;}

Property Value

FraudCheckLevel enumeration value to use.

Remarks

See Also

ElectronicPaymentAuthorizationParams Class | Aptify.Applications.OrderEntry.Payments Namespace


FraudThreshold Property

Aptify 5.0 Software Development Kit (SDK)

ElectronicPaymentAuthorizationParams.FraudThreshold Property

Gets or sets the Fraud Check Level Threshold for rejecting or accepting an authorization.

public Int32 FraudThreshold {get; set;}

Property Value

Remarks

See Also

ElectronicPaymentAuthorizationParams Class | Aptify.Applications.OrderEntry.Payments Namespace


IsCorporate Property

Aptify 5.0 Software Development Kit (SDK)

ElectronicPaymentAuthorizationParams.IsCorporate Property

Gets or sets whether the credit card to be authorized is a corporate card.

public Boolean IsCorporate {get; set;}

Property Value

True if this is a corporate card.

Remarks

See Also

ElectronicPaymentAuthorizationParams Class | Aptify.Applications.OrderEntry.Payments Namespace


IsCredit Property

Aptify 5.0 Software Development Kit (SDK)

ElectronicPaymentAuthorizationParams.IsCredit Property

Gets or sets whether this authorization is requested for a credit transaction instead of a debit.

public Boolean IsCredit {get; set;}

Property Value

True if this is a credit.

Remarks

See Also

ElectronicPaymentAuthorizationParams Class | Aptify.Applications.OrderEntry.Payments Namespace


IsRegisteredWebCustomer Property

Aptify 5.0 Software Development Kit (SDK)

ElectronicPaymentAuthorizationParams.IsRegisteredWebCustomer Property

public Boolean IsRegisteredWebCustomer {get; set;}

Property Value

Remarks

See Also

ElectronicPaymentAuthorizationParams Class | Aptify.Applications.OrderEntry.Payments Namespace


IsVoiceAuthorization Property

Aptify 5.0 Software Development Kit (SDK)

ElectronicPaymentAuthorizationParams.IsVoiceAuthorization Property

Gets or sets whether this is a voice authorization.

public Boolean IsVoiceAuthorization {get; set;}

Property Value

True if this is a voice authorization.

Remarks

See Also

ElectronicPaymentAuthorizationParams Class | Aptify.Applications.OrderEntry.Payments Namespace


MerchantName Property

Aptify 5.0 Software Development Kit (SDK)

ElectronicPaymentAuthorizationParams.MerchantName Property

Gets or sets the name of the merchant record for this verification.

public String MerchantName {get; set;}

Property Value

String representing the merchant name.

Remarks

See Also

ElectronicPaymentAuthorizationParams Class | Aptify.Applications.OrderEntry.Payments Namespace


OriginalProcessorRefNumber Property

Aptify 5.0 Software Development Kit (SDK)

ElectronicPaymentAuthorizationParams.OriginalProcessorRefNumber Property

Gets or sets the original processor reference number in an electronic verification transaction. This is used to send the original processor reference number for a refund transaction.

public String OriginalProcessorRefNumber {get; set;}

Property Value

The transaction processor reference number of the previously authorized transaction.

Remarks

See Also

ElectronicPaymentAuthorizationParams Class | Aptify.Applications.OrderEntry.Payments Namespace


Payment Property

Aptify 5.0 Software Development Kit (SDK)

ElectronicPaymentAuthorizationParams.Payment Property

Gets or sets the Aptify Payment object to be authorized.

public AptifyGenericEntityBase Payment {get; set;}

Property Value

An Aptify GenericEntityBase object of the Payment object.

Remarks

See Also

ElectronicPaymentAuthorizationParams Class | Aptify.Applications.OrderEntry.Payments Namespace


TenderType Property

Aptify 5.0 Software Development Kit (SDK)

ElectronicPaymentAuthorizationParams.TenderType Property

Gets or sets the tender type for the current transaction.

public ElectronicPaymentBase.TenderTypes TenderType {get; set;}

Property Value

Remarks

See Also

ElectronicPaymentAuthorizationParams Class | Aptify.Applications.OrderEntry.Payments Namespace


TransactionDescription Property

Aptify 5.0 Software Development Kit (SDK)

ElectronicPaymentAuthorizationParams.TransactionDescription Property

Gets or sets the description of the transaction returned by the verification provider.

public String TransactionDescription {get; set;}

Property Value

Transaction Description String

Remarks

See Also

ElectronicPaymentAuthorizationParams Class | Aptify.Applications.OrderEntry.Payments Namespace


UseAVS Property

Aptify 5.0 Software Development Kit (SDK)

ElectronicPaymentAuthorizationParams.UseAVS Property

Gets or sets whether the authorization uses the verification provider's Address Verification Service (AVS).

public Boolean UseAVS {get; set;}

Property Value

True to use Address Verification Service

Remarks

See Also

ElectronicPaymentAuthorizationParams Class | Aptify.Applications.OrderEntry.Payments Namespace


UseCVV2 Property

Aptify 5.0 Software Development Kit (SDK)

ElectronicPaymentAuthorizationParams.UseCVV2 Property

Gets or sets whether to perform a Card Verification Value (CVV2) check on the payment verification.

public Boolean UseCVV2 {get; set;}

Property Value

Remarks

See Also

ElectronicPaymentAuthorizationParams Class | Aptify.Applications.OrderEntry.Payments Namespace


ElectronicPaymentBase Class

For a list of all members of this type, see ElectronicPaymentBase Members.

System.Object
ElectronicPaymentBase
ElectronicPaymentSample
ElectronicPaymentVerisign

public class ElectronicPaymentBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry.Payments

Assembly: Payments (in Payments.dll)

See Also

ElectronicPaymentBase Members | Aptify.Applications.OrderEntry.Payments Namespace


ElectronicPaymentBase Members

ElectronicPaymentBase overview

Public Instance Constructors

ElectronicPaymentBase Constructor Initializes a new instance of the ElectronicPaymentBase class.

Public Instance Properties

AptifyReferenceNumber | Gets the Aptify generated reference number generated for the transaction.
AuthorizationCode | Gets the authroization code returned by the provider to reference the specific authorization instance.
ComponentInfo |
ReferenceNumber | Gets the provider generated transaction reference number generated for the authorization.
VoiceOverrideCode |

Public Instance Methods

CapturePayment | Overloaded. This method performs a Payment Capture of a previously authorized transaction. This overloaded method accepts an amount to be captured. This overload is deprecated to the CapturePayment(ElectronicPaymentAuthorizationParams) method which accepts an ElectronicPaymentAuthorizationParams object containing the required data for payment verification. This object can be obtained by calling the SetVerificationData method in this class which collects the necessary data for verification sheltering calling objects from having to supply the correct data. When using this overloaded method, the calling object must ensure the appropriate parameters have been using the SetMerchantConfigValue method.
CheckConnection |
Config | Configure the object with the necessary data to work with Aptify
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAuthorization | Overloaded. Method requests an authorization from an electronic payment provider.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetMerchantConfigValue | Returns the a value from the Merchant Dictionary object based on the submitted sKey.
GetMessage |
GetSoftFailureScore |
GetType (inherited from Object) | Gets the Type of the current instance.
SetMerchantConfigValue | Sets a merchant configuration value to a protected Dictionary object to store configuration name/value pairs to provide the specific merchant account information to connect and authenticate with the service provider.
SetPaymentVerificationData | This method must be called prior to calling an electronic verification function and is responsible for collecting the required data from Aptify for use in an electronic verification.
ToString (inherited from Object) | Returns a String that represents the current Object.
VoidAuthorization | Overloaded. This method is deprecated to the VoidAuthorization overloaded method accepting the ElectronicPaymentCaptureParams parameter.

Protected Instance Fields

m_FraudMappings
m_iAuthCode
m_MerchantValues
m_Messages
m_PaymentDB
m_sAptifyReferenceNumber
m_SoftFailureScores
m_sReferenceNumber

Protected Instance Properties

Application
TransactionDescription

Protected Instance Methods

CalculateAVSScore |
CalculateCVV2Score |
CalculateFraudScore |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAmountNotAuthorized | This method returns the amount, from the Payment object that can be authorized or captured. This will typically be the total amount of the Payment less any amounts previously captured.
GetFraudMappingValue | This method retrieves a Fraud Mapping value.
GetMerchantFraudMappings | This method retrieves any fraud mappings set for the current transaction.
GetOrderSpecificAuthorizationType | The purpose of this method is to get the order specific authorization type. This is determined by examining the products on the order. If any of the products on the order require inventory, then the authorization type will be AuthOnly. Otherwise, the authorization type will be AuthCapture.
GetPaymentOrderData | This method is responsible for getting Order information from the first Payment Line on the payment to be authorized. This method will return a data table with the information from the related order.
LUHNCheck | This method applies the Luhn algorithm to a credit card number to determine its validity
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetAuthorizationType | This method converts the string field value from the Merchant Account record to the AuthorizationTypes enumeration. Override this method if the behavior of translating the field string value to the enumeration type needs to change. This method will throw an exception if there is not matching enumeration type.
SetFraudCheckLevelType | This method converts the string field value from the Merchant Account record to the FraudCheckLevel enumeration. Override this method if the behavior of translating the field string value to the enumeration type needs to change. This method will throw an exception if there is not matching enumeration type.
SetMessage |
SetSoftFailureScore |
SetTenderType | This method converts the string field value from the Merchant Account Payment Type record to the TenderType enumeration. Override this method if the behavior of translating the field string value to the enumeration type needs to change. This method will throw an exception if there is not matching enumeration type.
ValidateCreditCardData | This method peforms multiple validations on credit card data in the payment object based on the flags passed in with the tValidateTypes parameters and will return a string consisting of the credit card number. This method requires the m_Payment member to be instantiated and will throw an exception if is it Nothing.

See Also

ElectronicPaymentBase Class | Aptify.Applications.OrderEntry.Payments Namespace


ElectronicPaymentBase Constructor

Initializes a new instance of the ElectronicPaymentBase class.

public ElectronicPaymentBase();

See Also

ElectronicPaymentBase Class | Aptify.Applications.OrderEntry.Payments Namespace


ElectronicPaymentBase Fields

The fields of the ElectronicPaymentBase class are listed below. For a complete list of ElectronicPaymentBase class members, see the ElectronicPaymentBase Members topic.

Protected Instance Fields

m_FraudMappings
m_iAuthCode
m_MerchantValues
m_Messages
m_PaymentDB
m_sAptifyReferenceNumber
m_SoftFailureScores
m_sReferenceNumber

See Also

ElectronicPaymentBase Class | Aptify.Applications.OrderEntry.Payments Namespace


ElectronicPaymentBase.m_FraudMappings Field

protected m_FraudMappings m_FraudMappings;

See Also

ElectronicPaymentBase Class | Aptify.Applications.OrderEntry.Payments Namespace


ElectronicPaymentBase.m_iAuthCode Field

protected m_iAuthCode m_iAuthCode;

See Also

ElectronicPaymentBase Class | Aptify.Applications.OrderEntry.Payments Namespace


ElectronicPaymentBase.m_MerchantValues Field

protected m_MerchantValues m_MerchantValues;

See Also

ElectronicPaymentBase Class | Aptify.Applications.OrderEntry.Payments Namespace


ElectronicPaymentBase.m_Messages Field

protected m_Messages m_Messages;

See Also

ElectronicPaymentBase Class | Aptify.Applications.OrderEntry.Payments Namespace


ElectronicPaymentBase.m_PaymentDB Field

protected m_PaymentDB m_PaymentDB;

See Also

ElectronicPaymentBase Class | Aptify.Applications.OrderEntry.Payments Namespace


ElectronicPaymentBase.m_sAptifyReferenceNumber Field

protected m_sAptifyReferenceNumber m_sAptifyReferenceNumber;

See Also

ElectronicPaymentBase Class | Aptify.Applications.OrderEntry.Payments Namespace


ElectronicPaymentBase.m_SoftFailureScores Field

protected m_SoftFailureScores m_SoftFailureScores;

See Also

ElectronicPaymentBase Class | Aptify.Applications.OrderEntry.Payments Namespace


ElectronicPaymentBase.m_sReferenceNumber Field

protected m_sReferenceNumber m_sReferenceNumber;

See Also

ElectronicPaymentBase Class | Aptify.Applications.OrderEntry.Payments Namespace


ElectronicPaymentBase Properties

The properties of the ElectronicPaymentBase class are listed below. For a complete list of ElectronicPaymentBase class members, see the ElectronicPaymentBase Members topic.

Public Instance Properties

AptifyReferenceNumber | Gets the Aptify generated reference number generated for the transaction.
AuthorizationCode | Gets the authroization code returned by the provider to reference the specific authorization instance.
ComponentInfo |
ReferenceNumber | Gets the provider generated transaction reference number generated for the authorization.
VoiceOverrideCode |

Protected Instance Properties

Application
TransactionDescription

See Also

ElectronicPaymentBase Class | Aptify.Applications.OrderEntry.Payments Namespace


Application Property

Aptify 5.0 Software Development Kit (SDK)

ElectronicPaymentBase.Application Property

protected AptifyApplication Application {get;}

See Also

ElectronicPaymentBase Class | Aptify.Applications.OrderEntry.Payments Namespace


AptifyReferenceNumber Property

Aptify 5.0 Software Development Kit (SDK)

ElectronicPaymentBase.AptifyReferenceNumber Property

Gets the Aptify generated reference number generated for the transaction.

public virtual String AptifyReferenceNumber {get;}

Property Value

Remarks

See Also

ElectronicPaymentBase Class | Aptify.Applications.OrderEntry.Payments Namespace


AuthorizationCode Property

Aptify 5.0 Software Development Kit (SDK)

ElectronicPaymentBase.AuthorizationCode Property

Gets the authroization code returned by the provider to reference the specific authorization instance.

public virtual String AuthorizationCode {get;}

Property Value

String reflecting the authorization code.

Remarks

See Also

ElectronicPaymentBase Class | Aptify.Applications.OrderEntry.Payments Namespace


ComponentInfo Property

Aptify 5.0 Software Development Kit (SDK)

ElectronicPaymentBase.ComponentInfo Property

public abstract String ComponentInfo {get;}

See Also

ElectronicPaymentBase Class | Aptify.Applications.OrderEntry.Payments Namespace


ReferenceNumber Property

Aptify 5.0 Software Development Kit (SDK)

ElectronicPaymentBase.ReferenceNumber Property

Gets the provider generated transaction reference number generated for the authorization.

public virtual String ReferenceNumber {get;}

Property Value

Aptify reference number.

Remarks

See Also

ElectronicPaymentBase Class | Aptify.Applications.OrderEntry.Payments Namespace


TransactionDescription Property

Aptify 5.0 Software Development Kit (SDK)

ElectronicPaymentBase.TransactionDescription Property

protected virtual String TransactionDescription {get; set;}

See Also

ElectronicPaymentBase Class | Aptify.Applications.OrderEntry.Payments Namespace


VoiceOverrideCode Property

Aptify 5.0 Software Development Kit (SDK)

ElectronicPaymentBase.VoiceOverrideCode Property

public abstract String VoiceOverrideCode {get;}

See Also

ElectronicPaymentBase Class | Aptify.Applications.OrderEntry.Payments Namespace


ElectronicPaymentBase Methods

The methods of the ElectronicPaymentBase class are listed below. For a complete list of ElectronicPaymentBase class members, see the ElectronicPaymentBase Members topic.

Public Instance Methods

CapturePayment | Overloaded. This method performs a Payment Capture of a previously authorized transaction. This overloaded method accepts an amount to be captured. This overload is deprecated to the CapturePayment(ElectronicPaymentAuthorizationParams) method which accepts an ElectronicPaymentAuthorizationParams object containing the required data for payment verification. This object can be obtained by calling the SetVerificationData method in this class which collects the necessary data for verification sheltering calling objects from having to supply the correct data. When using this overloaded method, the calling object must ensure the appropriate parameters have been using the SetMerchantConfigValue method.
CheckConnection |
Config | Configure the object with the necessary data to work with Aptify
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAuthorization | Overloaded. Method requests an authorization from an electronic payment provider.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetMerchantConfigValue | Returns the a value from the Merchant Dictionary object based on the submitted sKey.
GetMessage |
GetSoftFailureScore |
GetType (inherited from Object) | Gets the Type of the current instance.
SetMerchantConfigValue | Sets a merchant configuration value to a protected Dictionary object to store configuration name/value pairs to provide the specific merchant account information to connect and authenticate with the service provider.
SetPaymentVerificationData | This method must be called prior to calling an electronic verification function and is responsible for collecting the required data from Aptify for use in an electronic verification.
ToString (inherited from Object) | Returns a String that represents the current Object.
VoidAuthorization | Overloaded. This method is deprecated to the VoidAuthorization overloaded method accepting the ElectronicPaymentCaptureParams parameter.

Protected Instance Methods

CalculateAVSScore |
CalculateCVV2Score |
CalculateFraudScore |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAmountNotAuthorized | This method returns the amount, from the Payment object that can be authorized or captured. This will typically be the total amount of the Payment less any amounts previously captured.
GetFraudMappingValue | This method retrieves a Fraud Mapping value.
GetMerchantFraudMappings | This method retrieves any fraud mappings set for the current transaction.
GetOrderSpecificAuthorizationType | The purpose of this method is to get the order specific authorization type. This is determined by examining the products on the order. If any of the products on the order require inventory, then the authorization type will be AuthOnly. Otherwise, the authorization type will be AuthCapture.
GetPaymentOrderData | This method is responsible for getting Order information from the first Payment Line on the payment to be authorized. This method will return a data table with the information from the related order.
LUHNCheck | This method applies the Luhn algorithm to a credit card number to determine its validity
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetAuthorizationType | This method converts the string field value from the Merchant Account record to the AuthorizationTypes enumeration. Override this method if the behavior of translating the field string value to the enumeration type needs to change. This method will throw an exception if there is not matching enumeration type.
SetFraudCheckLevelType | This method converts the string field value from the Merchant Account record to the FraudCheckLevel enumeration. Override this method if the behavior of translating the field string value to the enumeration type needs to change. This method will throw an exception if there is not matching enumeration type.
SetMessage |
SetSoftFailureScore |
SetTenderType | This method converts the string field value from the Merchant Account Payment Type record to the TenderType enumeration. Override this method if the behavior of translating the field string value to the enumeration type needs to change. This method will throw an exception if there is not matching enumeration type.
ValidateCreditCardData | This method peforms multiple validations on credit card data in the payment object based on the flags passed in with the tValidateTypes parameters and will return a string consisting of the credit card number. This method requires the m_Payment member to be instantiated and will throw an exception if is it Nothing.

See Also

ElectronicPaymentBase Class | Aptify.Applications.OrderEntry.Payments Namespace


ElectronicPaymentBase.CalculateAVSScore Method

protected virtual int CalculateAVSScore(
String sProcessorValue,
ref String& sProcessorMessage
);

See Also

ElectronicPaymentBase Class | Aptify.Applications.OrderEntry.Payments Namespace


ElectronicPaymentBase.CalculateCVV2Score Method

protected virtual int CalculateCVV2Score(
String sProcessorValue,
ref String& sProcessorMessage
);

See Also

ElectronicPaymentBase Class | Aptify.Applications.OrderEntry.Payments Namespace


ElectronicPaymentBase.CalculateFraudScore Method

protected virtual int CalculateFraudScore(
String sProcessorValue,
ref String& sProcessorMessage
);

See Also

ElectronicPaymentBase Class | Aptify.Applications.OrderEntry.Payments Namespace


CapturePayment Method

Aptify 5.0 Software Development Kit (SDK)

ElectronicPaymentBase.CapturePayment Method

This method performs a Payment Capture of a previously authorized transaction.

Overload List

This method performs a Payment Capture of a previously authorized transaction.

public abstract ElectronicPaymentResults CapturePayment(ElectronicPaymentCaptureParams,ref String&,ref String&);

This method performs a Payment Capture of a previously authorized transaction. This overload is deprecated to the CapturePayment(ElectronicPaymentAuthorizationParams) method which accepts an ElectronicPaymentAuthorizationParams object containing the required data for payment verification. This object can be obtained by calling the SetVerificationData method in this class which collects the necessary data for verification sheltering calling objects from having to supply the correct data. When using this overloaded method, the calling object must ensure the appropriate parameters have been using the SetMerchantConfigValue method.

public virtual ElectronicPaymentResults CapturePayment(String,ref String&,ref String&);

This method performs a Payment Capture of a previously authorized transaction. This overloaded method accepts an amount to be captured. This overload is deprecated to the CapturePayment(ElectronicPaymentAuthorizationParams) method which accepts an ElectronicPaymentAuthorizationParams object containing the required data for payment verification. This object can be obtained by calling the SetVerificationData method in this class which collects the necessary data for verification sheltering calling objects from having to supply the correct data. When using this overloaded method, the calling object must ensure the appropriate parameters have been using the SetMerchantConfigValue method.

public virtual ElectronicPaymentResults CapturePayment(String,ref String&,ref String&,Double);

See Also

ElectronicPaymentBase Class | Aptify.Applications.OrderEntry.Payments Namespace


ElectronicPaymentBase.CapturePayment Method (ElectronicPaymentCaptureParams, String&, String&)

This method performs a Payment Capture of a previously authorized transaction.

public abstract ElectronicPaymentResults CapturePayment(
ElectronicPaymentCaptureParams oCapParams,
ref String& sAuthCode,
ref String& sResultRefNum
);

Parameters

oCapParams
sAuthCode
sResultRefNum

Return Value

Remarks

See Also

ElectronicPaymentBase Class | Aptify.Applications.OrderEntry.Payments Namespace | ElectronicPaymentBase.CapturePayment Overload List


ElectronicPaymentBase.CapturePayment Method (String, String&, String&)

This method performs a Payment Capture of a previously authorized transaction. This overload is deprecated to the CapturePayment(ElectronicPaymentAuthorizationParams) method which accepts an ElectronicPaymentAuthorizationParams object containing the required data for payment verification. This object can be obtained by calling the SetVerificationData method in this class which collects the necessary data for verification sheltering calling objects from having to supply the correct data. When using this overloaded method, the calling object must ensure the appropriate parameters have been using the SetMerchantConfigValue method.

public virtual ElectronicPaymentResults CapturePayment(
String sReferenceNumber,
ref String& sAuthCode,
ref String& sResultRefNum
);

Parameters

sReferenceNumber
Reference number of the previously authorized transaction.
sAuthCode
The authorization code returned by the capture.
sResultRefNum
The Aptify reference number returned by the capture.

Return Value

Returns an ElectronicPaymentResult enumeration value reflecting the result of the provider capture.

Remarks

See Also

ElectronicPaymentBase Class | Aptify.Applications.OrderEntry.Payments Namespace | ElectronicPaymentBase.CapturePayment Overload List


ElectronicPaymentBase.CapturePayment Method (String, String&, String&, Double)

This method performs a Payment Capture of a previously authorized transaction. This overloaded method accepts an amount to be captured. This overload is deprecated to the CapturePayment(ElectronicPaymentAuthorizationParams) method which accepts an ElectronicPaymentAuthorizationParams object containing the required data for payment verification. This object can be obtained by calling the SetVerificationData method in this class which collects the necessary data for verification sheltering calling objects from having to supply the correct data. When using this overloaded method, the calling object must ensure the appropriate parameters have been using the SetMerchantConfigValue method.

public virtual ElectronicPaymentResults CapturePayment(
String sReferenceNumber,
ref String& sAuthCode,
ref String& sResultRefNum,
Double cAmount
);

Parameters

sReferenceNumber
Reference number of the previously authorized transaction.
sAuthCode
The authorization code returned by the capture.
sResultRefNum
The Aptify reference number returned by the capture.
cAmount
The amount to be captured.

Return Value

Returns an ElectronicPaymentResult enumeration value reflecting the result of the provider capture.

Remarks

See Also

ElectronicPaymentBase Class | Aptify.Applications.OrderEntry.Payments Namespace | ElectronicPaymentBase.CapturePayment Overload List


ElectronicPaymentBase.CheckConnection Method

public abstract ConnectionStatusTypes CheckConnection();

See Also

ElectronicPaymentBase Class | Aptify.Applications.OrderEntry.Payments Namespace


ElectronicPaymentBase.Config Method

Configure the object with the necessary data to work with Aptify

public virtual bool Config(
AptifyApplication Application
);

Parameters

Application
A reference to the Aptify Application object.

Return Value

True if the method completed without errors.

Remarks

See Also

ElectronicPaymentBase Class | Aptify.Applications.OrderEntry.Payments Namespace


ElectronicPaymentBase.GetAmountNotAuthorized Method

This method returns the amount, from the Payment object that can be authorized or captured. This will typically be the total amount of the Payment less any amounts previously captured.

protected virtual double GetAmountNotAuthorized(
PaymentsEntity oPayment
);

Parameters

oPayment
Payment to be verified.

Return Value

Amount that can be authorized or captured.

Remarks

See Also

ElectronicPaymentBase Class | Aptify.Applications.OrderEntry.Payments Namespace


GetAuthorization Method

Aptify 5.0 Software Development Kit (SDK)

ElectronicPaymentBase.GetAuthorization Method

Method requests an authorization from an electronic payment provider.

Overload List

Method requests an authorization from an electronic payment provider.

public abstract ElectronicPaymentResults GetAuthorization(ElectronicPaymentAuthorizationParams);

NOTE: This method is to be deprecated. Use the GetAuthorization method with the ElectronicPaymentAuthorizationParameters Method requests an authorization from an electronic payment provider. This overloaded method provides for a simple authorization providing only the minimal required paramters to made an authorization.

public ElectronicPaymentResults GetAuthorization(AptifyGenericEntityBase,ref String&,ref String&,ElectronicPaymentBase.AuthorizationTypes,String);

NOTE: This method is to be deprecated. Use the GetAuthorization method with the ElectronicPaymentAuthorizationParameters Method requests an authorization from an electronic payment provider. This overloaded method is provided for voice authorizations.

public ElectronicPaymentResults GetAuthorization(AptifyGenericEntityBase,ref String&,ref String&,ElectronicPaymentBase.AuthorizationTypes,String,Boolean);

NOTE: This method is to be deprecated. Use the GetAuthorization method with the ElectronicPaymentAuthorizationParameters Method requests an authorization from an electronic payment provider. Overload with AVS and FRAUD

public ElectronicPaymentResults GetAuthorization(AptifyGenericEntityBase,ref String&,ref String&,ElectronicPaymentBase.AuthorizationTypes,String,Boolean,ElectronicPaymentBase.FraudCheckLevels);

NOTE: This method is to be deprecated. Use the GetAuthorization method with the ElectronicPaymentAuthorizationParameters Method requests an authorization from an electronic payment provider. This is a full method overload to provide all possible data used to make an authorization.

public ElectronicPaymentResults GetAuthorization(AptifyGenericEntityBase,ref String&,ref String&,ElectronicPaymentBase.AuthorizationTypes,String,Boolean,Boolean,Boolean,ElectronicPaymentBase.FraudCheckLevels,ElectronicPaymentBase.ACHAccountTypes,Boolean);

See Also

ElectronicPaymentBase Class | Aptify.Applications.OrderEntry.Payments Namespace


ElectronicPaymentBase.GetAuthorization Method (ElectronicPaymentAuthorizationParams)

Method requests an authorization from an electronic payment provider.

public abstract ElectronicPaymentResults GetAuthorization(
ElectronicPaymentAuthorizationParams oAuthorizationParameters
);

Parameters

oAuthorizationParameters
Authorization Parameters to be used by the payment verification provider to authorize the payment.

Return Value

Returns an ElectronicPaymentResult enumeration value reflecting the result of the provider authorization.

Remarks

See Also

ElectronicPaymentBase Class | Aptify.Applications.OrderEntry.Payments Namespace | ElectronicPaymentBase.GetAuthorization Overload List


ElectronicPaymentBase.GetAuthorization Method (AptifyGenericEntityBase, String&, String&, AuthorizationTypes, String)

NOTE: This method is to be deprecated. Use the GetAuthorization method with the ElectronicPaymentAuthorizationParameters Method requests an authorization from an electronic payment provider. This overloaded method provides for a simple authorization providing only the minimal required paramters to made an authorization.

public ElectronicPaymentResults GetAuthorization(
AptifyGenericEntityBase oPayment,
ref String& sAuthCode,
ref String& sReferenceNumber,
ElectronicPaymentBase.AuthorizationTypes iAuthType,
String sTransactionDescription
);

Parameters

oPayment
The Aptify Payment object to get authorized.
sAuthCode
The authorization code returned by the provider to reference the specific authorization instance.
sReferenceNumber
Aptify referenece number passed to the service provider
iAuthType
The type of authorization to perform.
sTransactionDescription

Return Value

Returns an ElectronicPaymentResult enumeration value reflecting the result of the provider authorization.

Remarks

See Also

ElectronicPaymentBase Class | Aptify.Applications.OrderEntry.Payments Namespace | ElectronicPaymentBase.GetAuthorization Overload List


ElectronicPaymentBase.GetAuthorization Method (AptifyGenericEntityBase, String&, String&, AuthorizationTypes, String, Boolean)

NOTE: This method is to be deprecated. Use the GetAuthorization method with the ElectronicPaymentAuthorizationParameters Method requests an authorization from an electronic payment provider. This overloaded method is provided for voice authorizations.

public ElectronicPaymentResults GetAuthorization(
AptifyGenericEntityBase oPayment,
ref String& sAuthCode,
ref String& sReferenceNumber,
ElectronicPaymentBase.AuthorizationTypes iAuthType,
String sTransactionDescription,
Boolean bIsVoiceAuthorization
);

Parameters

oPayment
The Aptify Payment object to get authorized.
sAuthCode
The authorization code returned by the provider to reference the specific authorization instance.
sReferenceNumber
Aptify referenece number passed to the service provider
iAuthType
The type of authorization to perform.
sTransactionDescription
bIsVoiceAuthorization

Return Value

Returns an ElectronicPaymentResult enumeration value reflecting the result of the provider authorization.

Remarks

See Also

ElectronicPaymentBase Class | Aptify.Applications.OrderEntry.Payments Namespace | ElectronicPaymentBase.GetAuthorization Overload List


ElectronicPaymentBase.GetAuthorization Method (AptifyGenericEntityBase, String&, String&, AuthorizationTypes, String, Boolean, FraudCheckLevels)

NOTE: This method is to be deprecated. Use the GetAuthorization method with the ElectronicPaymentAuthorizationParameters Method requests an authorization from an electronic payment provider. Overload with AVS and FRAUD

public ElectronicPaymentResults GetAuthorization(
AptifyGenericEntityBase oPayment,
ref String& sAuthCode,
ref String& sReferenceNumber,
ElectronicPaymentBase.AuthorizationTypes iAuthType,
String sTransactionDescription,
Boolean bDoAVSCheck,
ElectronicPaymentBase.FraudCheckLevels iFraudCheckLevel
);

Parameters

oPayment
The Aptify Payment object to get authorized.
sAuthCode
The authorization code returned by the provider to reference the specific authorization instance.
sReferenceNumber
Aptify referenece number passed to the service provider
iAuthType
The type of authorization to perform.
sTransactionDescription
bDoAVSCheck
True to indicate to the provider to perform address verification.
iFraudCheckLevel
The fraud check level to perform on the authorization.

Return Value

Remarks

See Also

ElectronicPaymentBase Class | Aptify.Applications.OrderEntry.Payments Namespace | ElectronicPaymentBase.GetAuthorization Overload List


ElectronicPaymentBase.GetAuthorization Method (AptifyGenericEntityBase, String&, String&, AuthorizationTypes, String, Boolean, Boolean, Boolean, FraudCheckLevels, ACHAccountTypes, Boolean)

NOTE: This method is to be deprecated. Use the GetAuthorization method with the ElectronicPaymentAuthorizationParameters Method requests an authorization from an electronic payment provider. This is a full method overload to provide all possible data used to make an authorization.

public ElectronicPaymentResults GetAuthorization(
AptifyGenericEntityBase oPayment,
ref String& sAuthCode,
ref String& sReferenceNumber,
ElectronicPaymentBase.AuthorizationTypes iAuthType,
String sTransactionDescription,
Boolean bUseAVS,
Boolean bIsCorporate,
Boolean bIsRegWebCust,
ElectronicPaymentBase.FraudCheckLevels iFraudCheckLevel,
ElectronicPaymentBase.ACHAccountTypes iACHAcctType,
Boolean bIsVoiceAuthorization
);

Parameters

oPayment
The Aptify Payment object to get authorized.
sAuthCode
The authroization code returned by the provider to reference the specific authorization instance.
sReferenceNumber
Aptify referenece number passed to the service provider
iAuthType
The type of authorization to perform.
sTransactionDescription
bUseAVS
Specify true to force the provider to use their Address Verication Service.
bIsCorporate
True if the credit card to be authorized is a corporate card.
bIsRegWebCust
iFraudCheckLevel
Specify the fraud check level for the current authorization.
iACHAcctType
Automated Clearing House Account Type.
bIsVoiceAuthorization
True if the authorization is a voice authorization.

Return Value

Returns an ElectronicPaymentResult enumeration value reflecting the result of the provider authorization.

Remarks

See Also

ElectronicPaymentBase Class | Aptify.Applications.OrderEntry.Payments Namespace | ElectronicPaymentBase.GetAuthorization Overload List


ElectronicPaymentBase.GetFraudMappingValue Method

This method retrieves a Fraud Mapping value.

protected virtual string GetFraudMappingValue(
String sMerchID,
String sSeq,
Int64 lEntityID,
String sEntityField,
String sRelOrdersField,
Int64 lOrderID,
Boolean bUseValues
);

Parameters

sMerchID
sSeq
lEntityID
sEntityField
sRelOrdersField
lOrderID
bUseValues

Return Value

Remarks

See Also

ElectronicPaymentBase Class | Aptify.Applications.OrderEntry.Payments Namespace


ElectronicPaymentBase.GetMerchantConfigValue Method

Returns the a value from the Merchant Dictionary object based on the submitted sKey.

public virtual string GetMerchantConfigValue(
String sKey
);

Parameters

sKey
Key in the Dictionary object of which to return its corresponding value.

Return Value

Value of the sKey in the Merchant Dictionary object.

Remarks

See Also

ElectronicPaymentBase Class | Aptify.Applications.OrderEntry.Payments Namespace


ElectronicPaymentBase.GetMerchantFraudMappings Method

This method retrieves any fraud mappings set for the current transaction.

protected virtual bool GetMerchantFraudMappings(
Int64 lMerchantAccountID,
Int64 lOrderID
);

Parameters

lMerchantAccountID
The MerchantAccountID from which the Fraud Mappings need to be retrieved.
lOrderID
The OrderID of the Payment to be verified.

Return Value

True if the FraudMappings were retrieve successfully.

Remarks

See Also

ElectronicPaymentBase Class | Aptify.Applications.OrderEntry.Payments Namespace


ElectronicPaymentBase.GetMessage Method

public virtual string GetMessage(
ElectronicPaymentBase.MessageTypes iMessageKey
);

See Also

ElectronicPaymentBase Class | Aptify.Applications.OrderEntry.Payments Namespace


ElectronicPaymentBase.GetOrderSpecificAuthorizationType Method

The purpose of this method is to get the order specific authorization type. This is determined by examining the products on the order. If any of the products on the order require inventory, then the authorization type will be AuthOnly. Otherwise, the authorization type will be AuthCapture.

protected virtual AuthorizationTypes GetOrderSpecificAuthorizationType(
PaymentsEntity oPayment
);

Parameters

oPayment
Payment object of which the authorization type is to be determined.

Return Value

The order specific authorization type

Remarks

See Also

ElectronicPaymentBase Class | Aptify.Applications.OrderEntry.Payments Namespace


ElectronicPaymentBase.GetPaymentOrderData Method

This method is responsible for getting Order information from the first Payment Line on the payment to be authorized. This method will return a data table with the information from the related order.

protected virtual DataTable GetPaymentOrderData(
PaymentsEntity oPayment
);

Parameters

oPayment
Payment object used to look up the Order information being requested.

Return Value

DataTable with Order information used for extended payment authorization.

Remarks

See Also

ElectronicPaymentBase Class | Aptify.Applications.OrderEntry.Payments Namespace


ElectronicPaymentBase.GetSoftFailureScore Method

public virtual int GetSoftFailureScore(
ElectronicPaymentBase.MessageTypes MessageKey
);

See Also

ElectronicPaymentBase Class | Aptify.Applications.OrderEntry.Payments Namespace


ElectronicPaymentBase.LUHNCheck Method

This method applies the Luhn algorithm to a credit card number to determine its validity

protected virtual bool LUHNCheck(
String sCCNumber
);

Parameters

sCCNumber
The credit card number to check.

Return Value

True if the credit card number passes the Luhn algorithm test

Remarks

See Also

ElectronicPaymentBase Class | Aptify.Applications.OrderEntry.Payments Namespace


ElectronicPaymentBase.SetAuthorizationType Method

This method converts the string field value from the Merchant Account record to the AuthorizationTypes enumeration. Override this method if the behavior of translating the field string value to the enumeration type needs to change. This method will throw an exception if there is not matching enumeration type.

protected virtual AuthorizationTypes SetAuthorizationType(
String sAuthType
);

Parameters

sAuthType
The value represented in the AuthType field of the Merchant Account record.

Return Value

Matching AuthorizationTypes enumeration

Remarks

See Also

ElectronicPaymentBase Class | Aptify.Applications.OrderEntry.Payments Namespace


ElectronicPaymentBase.SetFraudCheckLevelType Method

This method converts the string field value from the Merchant Account record to the FraudCheckLevel enumeration. Override this method if the behavior of translating the field string value to the enumeration type needs to change. This method will throw an exception if there is not matching enumeration type.

protected virtual FraudCheckLevels SetFraudCheckLevelType(
String sFraudType
);

Parameters

sFraudType
The value represented in the FraudCheckLevel field of the Merchant Account record.

Return Value

Matching FraudCheckLevel enumeration

Remarks

See Also

ElectronicPaymentBase Class | Aptify.Applications.OrderEntry.Payments Namespace


ElectronicPaymentBase.SetMerchantConfigValue Method

Sets a merchant configuration value to a protected Dictionary object to store configuration name/value pairs to provide the specific merchant account information to connect and authenticate with the service provider.

public virtual void SetMerchantConfigValue(
String sConfigKey,
String sConfigValue
);

Parameters

sConfigKey
Configuration key name to add to the Dictionary object
sConfigValue
Configuration value of the sConfigKey to add to the Dictionary object.

Remarks

See Also

ElectronicPaymentBase Class | Aptify.Applications.OrderEntry.Payments Namespace


ElectronicPaymentBase.SetMessage Method

protected virtual void SetMessage(
ElectronicPaymentBase.MessageTypes iMessageKey,
String sMessage
);

See Also

ElectronicPaymentBase Class | Aptify.Applications.OrderEntry.Payments Namespace


ElectronicPaymentBase.SetPaymentVerificationData Method

This method must be called prior to calling an electronic verification function and is responsible for collecting the required data from Aptify for use in an electronic verification.

public virtual bool SetPaymentVerificationData(
PaymentsEntity oPayment,
DataSet dsMerchantConfig,
ref ElectronicPaymentAuthorizationParams& oAuthParams
);

Parameters

oPayment
Payment generic entity object reflecting the payment to be verified.
dsMerchantConfig
This data set must contain data populated from the spGetMerchantConfigFromPayType and spGetRelatedMerchantAccountAttribute stored procedures.
oAuthParams

Return Value

True if the appropriate payment data has been collected.

Remarks

See Also

ElectronicPaymentBase Class | Aptify.Applications.OrderEntry.Payments Namespace


ElectronicPaymentBase.SetSoftFailureScore Method

protected virtual void SetSoftFailureScore(
ElectronicPaymentBase.MessageTypes MessageKey,
Int32 Score
);

See Also

ElectronicPaymentBase Class | Aptify.Applications.OrderEntry.Payments Namespace


ElectronicPaymentBase.SetTenderType Method

This method converts the string field value from the Merchant Account Payment Type record to the TenderType enumeration. Override this method if the behavior of translating the field string value to the enumeration type needs to change. This method will throw an exception if there is not matching enumeration type.

protected virtual TenderTypes SetTenderType(
String sTenderType
);

Parameters

sTenderType
The value represented in the TenderType field of the Merchant Account Payment Type record.

Return Value

Matching Tender Type enumeration

Remarks

See Also

ElectronicPaymentBase Class | Aptify.Applications.OrderEntry.Payments Namespace


ElectronicPaymentBase.ValidateCreditCardData Method

This method peforms multiple validations on credit card data in the payment object based on the flags passed in with the tValidateTypes parameters and will return a string consisting of the credit card number. This method requires the m_Payment member to be instantiated and will throw an exception if is it Nothing.

protected virtual bool ValidateCreditCardData(
PaymentsEntity oPayment,
ElectronicPaymentBase.CreditCardValidationTypes tValidateTypes,
ref String& sCCNumber
);

Parameters

oPayment
tValidateTypes
The types of validation to perform.
sCCNumber
The credit card number from the payment object.

Return Value

True if the card passes the validation specified.

Remarks

See Also

ElectronicPaymentBase Class | Aptify.Applications.OrderEntry.Payments Namespace


VoidAuthorization Method

Aptify 5.0 Software Development Kit (SDK)

ElectronicPaymentBase.VoidAuthorization Method

Overload List

public abstract ElectronicPaymentResults VoidAuthorization(ElectronicPaymentCaptureParams,String,ref String&,ref String&);

This method is deprecated to the VoidAuthorization overloaded method accepting the ElectronicPaymentCaptureParams parameter.

public virtual ElectronicPaymentResults VoidAuthorization(Double,String,String,ref String&,ref String&);

See Also

ElectronicPaymentBase Class | Aptify.Applications.OrderEntry.Payments Namespace


ElectronicPaymentBase.VoidAuthorization Method (ElectronicPaymentCaptureParams, String, String&, String&)

public abstract ElectronicPaymentResults VoidAuthorization(
ElectronicPaymentCaptureParams oCaptureParams,
String sApplicationRefNum,
ref String& sAuthCode,
ref String& sResultRefNum
);

See Also

ElectronicPaymentBase Class | Aptify.Applications.OrderEntry.Payments Namespace | ElectronicPaymentBase.VoidAuthorization Overload List


ElectronicPaymentBase.VoidAuthorization Method (Double, String, String, String&, String&)

This method is deprecated to the VoidAuthorization overloaded method accepting the ElectronicPaymentCaptureParams parameter.

public virtual ElectronicPaymentResults VoidAuthorization(
Double cAmount,
String sApplicationRefNum,
String sProcessorRefNum,
ref String& sAuthCode,
ref String& sResultRefNum
);

Parameters

cAmount
sApplicationRefNum
sProcessorRefNum
sAuthCode
sResultRefNum

Return Value

Remarks

See Also

ElectronicPaymentBase Class | Aptify.Applications.OrderEntry.Payments Namespace | ElectronicPaymentBase.VoidAuthorization Overload List


ElectronicPaymentBase.ACHAccountTypes Enumeration

public enum ElectronicPaymentBase.ACHAccountTypes

Members

Member Name | Description
NotApplicable |
Savings |
Checking |
Other |

Requirements

Namespace: Aptify.Applications.OrderEntry.Payments

Assembly: Payments (in Payments.dll)

See Also

Aptify.Applications.OrderEntry.Payments Namespace


ElectronicPaymentBase.AuthorizationTypes Enumeration

public enum ElectronicPaymentBase.AuthorizationTypes

Members

Member Name | Description
AuthOnly |
AuthCapture |
OrderSpecific |

Requirements

Namespace: Aptify.Applications.OrderEntry.Payments

Assembly: Payments (in Payments.dll)

See Also

Aptify.Applications.OrderEntry.Payments Namespace


ElectronicPaymentBase.ConnectionStatusTypes Enumeration

public enum ElectronicPaymentBase.ConnectionStatusTypes

Members

Member Name | Description
Unknown |
Up |
Suspect |
ExpectDelay |
Down |
MisConfigured |

Requirements

Namespace: Aptify.Applications.OrderEntry.Payments

Assembly: Payments (in Payments.dll)

See Also

Aptify.Applications.OrderEntry.Payments Namespace


ElectronicPaymentBase.CreditCardValidationTypes Enumeration

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

public enum ElectronicPaymentBase.CreditCardValidationTypes

Members

Member Name | Description | Value
LuhnCheck |  | 1
ExpirationDate |  | 2

Requirements

Namespace: Aptify.Applications.OrderEntry.Payments

Assembly: Payments (in Payments.dll)

See Also

Aptify.Applications.OrderEntry.Payments Namespace


ElectronicPaymentBase.ElectronicPaymentResults Enumeration

Indicates the results of a payment verification.

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

public enum ElectronicPaymentBase.ElectronicPaymentResults

Remarks

Members

Member Name | Description | Value
Failed | A failed status will prevent the Payment from being saved. | 1
Passed | A passed status will allow the Payment to save with an Authorization Record indicating a successful authorization of funds on the payment amount when the authorization took place. | 2
RequiresIntervention | A Requires Intervention status will allow the Payment to be saved but place the Payment in a Pending status and update the Status Information Message field with a message from the payment verification provider. | 4
ErrorMessage | Indicates that there is an error message associated with this result. This can be combined with other values in this enumeration. | 8
AuthMessage | Indicates that there is an authorization message associated with this result. This can be combined with other values in this enumeration. | 16
AVSMessage | Indicatees that there is an Address Verification Message associated with this result. This can be combined with other values in this enumeration. | 32
FraudMessage | Indicates that there is a Fraud Message associated with this result. This can be combined with other values in this enumeration. | 64
CVV2Message | Indicates that there is a Credit Card Verification message associated with this result. This can be combined with other values in this enumeration. | 128

Requirements

Namespace: Aptify.Applications.OrderEntry.Payments

Assembly: Payments (in Payments.dll)

See Also

Aptify.Applications.OrderEntry.Payments Namespace


ElectronicPaymentBase.FraudCheckLevels Enumeration

public enum ElectronicPaymentBase.FraudCheckLevels

Members

Member Name | Description
Off |
Low |
Medium |
High |

Requirements

Namespace: Aptify.Applications.OrderEntry.Payments

Assembly: Payments (in Payments.dll)

See Also

Aptify.Applications.OrderEntry.Payments Namespace


ElectronicPaymentBase.MessageTypes Enumeration

public enum ElectronicPaymentBase.MessageTypes

Members

Member Name | Description
ErrorMessage |
AuthWarningMessage |
AVSMessage |
FraudMessage |
SecurityNumberMessage |
CaptureMessage |
SoftFailureScore |
OtherMessage |

Requirements

Namespace: Aptify.Applications.OrderEntry.Payments

Assembly: Payments (in Payments.dll)

See Also

Aptify.Applications.OrderEntry.Payments Namespace


ElectronicPaymentBase.TenderTypes Enumeration

public enum ElectronicPaymentBase.TenderTypes

Members

Member Name | Description
ACH |
Cash |
CreditCard |
DebitCard |
ElectronicCheck |
PurchasingCard |

Requirements

Namespace: Aptify.Applications.OrderEntry.Payments

Assembly: Payments (in Payments.dll)

See Also

Aptify.Applications.OrderEntry.Payments Namespace


ElectronicPaymentCaptureParams Class

For a list of all members of this type, see ElectronicPaymentCaptureParams Members.

System.Object
ElectronicPaymentCaptureParams

public class ElectronicPaymentCaptureParams

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry.Payments

Assembly: Payments (in Payments.dll)

See Also

ElectronicPaymentCaptureParams Members | Aptify.Applications.OrderEntry.Payments Namespace


ElectronicPaymentCaptureParams Members

ElectronicPaymentCaptureParams overview

Public Instance Constructors

ElectronicPaymentCaptureParams Constructor Initializes a new instance of the ElectronicPaymentCaptureParams class.

Public Instance Properties

NewCaptureAmount | Gets or sets the original reference number in an electronic verification transaction. This is typically used for transactions on previously authorized transactions such as a capture or void.
OriginalReferenceNumber | Gets or sets the original reference number in an electronic verification transaction. This is typically used for transactions on previously authorized transactions such as a capture or void.
TenderType | Gets or sets the tender type for the current transaction.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ElectronicPaymentCaptureParams Class | Aptify.Applications.OrderEntry.Payments Namespace


ElectronicPaymentCaptureParams Constructor

Initializes a new instance of the ElectronicPaymentCaptureParams class.

public ElectronicPaymentCaptureParams();

See Also

ElectronicPaymentCaptureParams Class | Aptify.Applications.OrderEntry.Payments Namespace


ElectronicPaymentCaptureParams Properties

The properties of the ElectronicPaymentCaptureParams class are listed below. For a complete list of ElectronicPaymentCaptureParams class members, see the ElectronicPaymentCaptureParams Members topic.

Public Instance Properties

NewCaptureAmount | Gets or sets the original reference number in an electronic verification transaction. This is typically used for transactions on previously authorized transactions such as a capture or void.
OriginalReferenceNumber | Gets or sets the original reference number in an electronic verification transaction. This is typically used for transactions on previously authorized transactions such as a capture or void.
TenderType | Gets or sets the tender type for the current transaction.

See Also

ElectronicPaymentCaptureParams Class | Aptify.Applications.OrderEntry.Payments Namespace


NewCaptureAmount Property

Aptify 5.0 Software Development Kit (SDK)

ElectronicPaymentCaptureParams.NewCaptureAmount Property

Gets or sets the original reference number in an electronic verification transaction. This is typically used for transactions on previously authorized transactions such as a capture or void.

public Double NewCaptureAmount {get; set;}

Property Value

The transaction reference number of the previously authorized transaction.

Remarks

See Also

ElectronicPaymentCaptureParams Class | Aptify.Applications.OrderEntry.Payments Namespace


OriginalReferenceNumber Property

Aptify 5.0 Software Development Kit (SDK)

ElectronicPaymentCaptureParams.OriginalReferenceNumber Property

Gets or sets the original reference number in an electronic verification transaction. This is typically used for transactions on previously authorized transactions such as a capture or void.

public String OriginalReferenceNumber {get; set;}

Property Value

The transaction reference number of the previously authorized transaction.

Remarks

See Also

ElectronicPaymentCaptureParams Class | Aptify.Applications.OrderEntry.Payments Namespace


TenderType Property

Aptify 5.0 Software Development Kit (SDK)

ElectronicPaymentCaptureParams.TenderType Property

Gets or sets the tender type for the current transaction.

public ElectronicPaymentBase.TenderTypes TenderType {get; set;}

Property Value

Remarks

See Also

ElectronicPaymentCaptureParams Class | Aptify.Applications.OrderEntry.Payments Namespace


ElectronicPaymentSample Class

For a list of all members of this type, see ElectronicPaymentSample Members.

System.Object
ElectronicPaymentBase
ElectronicPaymentSample

public class ElectronicPaymentSample : ElectronicPaymentBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry.Payments

Assembly: Payments (in Payments.dll)

See Also

ElectronicPaymentSample Members | Aptify.Applications.OrderEntry.Payments Namespace


ElectronicPaymentSample Members

ElectronicPaymentSample overview

Public Instance Constructors

ElectronicPaymentSample Constructor Initializes a new instance of the ElectronicPaymentSample class.

Public Instance Properties

AptifyReferenceNumber (inherited from ElectronicPaymentBase) | Gets the Aptify generated reference number generated for the transaction.
AuthorizationCode (inherited from ElectronicPaymentBase) | Gets the authroization code returned by the provider to reference the specific authorization instance.
ComponentInfo |
ReferenceNumber (inherited from ElectronicPaymentBase) | Gets the provider generated transaction reference number generated for the authorization.
VoiceOverrideCode |

Public Instance Methods

CapturePayment | Overloaded.
CheckConnection |
Config (inherited from ElectronicPaymentBase) | Configure the object with the necessary data to work with Aptify
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAuthorization | Overloaded.
GetAuthorization (inherited from ElectronicPaymentBase) | Overloaded. Method requests an authorization from an electronic payment provider.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetMerchantConfigValue (inherited from ElectronicPaymentBase) | Returns the a value from the Merchant Dictionary object based on the submitted sKey.
GetMessage (inherited from ElectronicPaymentBase) |
GetSoftFailureScore (inherited from ElectronicPaymentBase) |
GetType (inherited from Object) | Gets the Type of the current instance.
SetMerchantConfigValue (inherited from ElectronicPaymentBase) | Sets a merchant configuration value to a protected Dictionary object to store configuration name/value pairs to provide the specific merchant account information to connect and authenticate with the service provider.
SetPaymentVerificationData (inherited from ElectronicPaymentBase) | This method must be called prior to calling an electronic verification function and is responsible for collecting the required data from Aptify for use in an electronic verification.
ToString (inherited from Object) | Returns a String that represents the current Object.
VoidAuthorization | Overloaded.

Protected Instance Fields

m_FraudMappings (inherited from ElectronicPaymentBase)
m_iAuthCode (inherited from ElectronicPaymentBase)
m_MerchantValues (inherited from ElectronicPaymentBase)
m_Messages (inherited from ElectronicPaymentBase)
m_PaymentDB (inherited from ElectronicPaymentBase)
m_sAptifyReferenceNumber (inherited from ElectronicPaymentBase)
m_SoftFailureScores (inherited from ElectronicPaymentBase)
m_sReferenceNumber (inherited from ElectronicPaymentBase)

Protected Instance Properties

Application (inherited from ElectronicPaymentBase)
TransactionDescription (inherited from ElectronicPaymentBase)

Protected Instance Methods

CalculateAVSScore (inherited from ElectronicPaymentBase) |
CalculateCVV2Score (inherited from ElectronicPaymentBase) |
CalculateFraudScore (inherited from ElectronicPaymentBase) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAmountNotAuthorized (inherited from ElectronicPaymentBase) | This method returns the amount, from the Payment object that can be authorized or captured. This will typically be the total amount of the Payment less any amounts previously captured.
GetFraudMappingValue (inherited from ElectronicPaymentBase) | This method retrieves a Fraud Mapping value.
GetMerchantFraudMappings (inherited from ElectronicPaymentBase) | This method retrieves any fraud mappings set for the current transaction.
GetOrderSpecificAuthorizationType (inherited from ElectronicPaymentBase) | The purpose of this method is to get the order specific authorization type. This is determined by examining the products on the order. If any of the products on the order require inventory, then the authorization type will be AuthOnly. Otherwise, the authorization type will be AuthCapture.
GetPaymentOrderData (inherited from ElectronicPaymentBase) | This method is responsible for getting Order information from the first Payment Line on the payment to be authorized. This method will return a data table with the information from the related order.
LUHNCheck (inherited from ElectronicPaymentBase) | This method applies the Luhn algorithm to a credit card number to determine its validity
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetAuthorizationType (inherited from ElectronicPaymentBase) | This method converts the string field value from the Merchant Account record to the AuthorizationTypes enumeration. Override this method if the behavior of translating the field string value to the enumeration type needs to change. This method will throw an exception if there is not matching enumeration type.
SetFraudCheckLevelType (inherited from ElectronicPaymentBase) | This method converts the string field value from the Merchant Account record to the FraudCheckLevel enumeration. Override this method if the behavior of translating the field string value to the enumeration type needs to change. This method will throw an exception if there is not matching enumeration type.
SetMessage (inherited from ElectronicPaymentBase) |
SetSoftFailureScore (inherited from ElectronicPaymentBase) |
SetTenderType (inherited from ElectronicPaymentBase) | This method converts the string field value from the Merchant Account Payment Type record to the TenderType enumeration. Override this method if the behavior of translating the field string value to the enumeration type needs to change. This method will throw an exception if there is not matching enumeration type.
ValidateCreditCardData (inherited from ElectronicPaymentBase) | This method peforms multiple validations on credit card data in the payment object based on the flags passed in with the tValidateTypes parameters and will return a string consisting of the credit card number. This method requires the m_Payment member to be instantiated and will throw an exception if is it Nothing.

See Also

ElectronicPaymentSample Class | Aptify.Applications.OrderEntry.Payments Namespace


ElectronicPaymentSample Constructor

Initializes a new instance of the ElectronicPaymentSample class.

public ElectronicPaymentSample();

See Also

ElectronicPaymentSample Class | Aptify.Applications.OrderEntry.Payments Namespace


ElectronicPaymentSample Properties

The properties of the ElectronicPaymentSample class are listed below. For a complete list of ElectronicPaymentSample class members, see the ElectronicPaymentSample Members topic.

Public Instance Properties

AptifyReferenceNumber (inherited from ElectronicPaymentBase) | Gets the Aptify generated reference number generated for the transaction.
AuthorizationCode (inherited from ElectronicPaymentBase) | Gets the authroization code returned by the provider to reference the specific authorization instance.
ComponentInfo |
ReferenceNumber (inherited from ElectronicPaymentBase) | Gets the provider generated transaction reference number generated for the authorization.
VoiceOverrideCode |

Protected Instance Properties

Application (inherited from ElectronicPaymentBase)
TransactionDescription (inherited from ElectronicPaymentBase)

See Also

ElectronicPaymentSample Class | Aptify.Applications.OrderEntry.Payments Namespace


ComponentInfo Property

Aptify 5.0 Software Development Kit (SDK)

ElectronicPaymentSample.ComponentInfo Property

public override String ComponentInfo {get;}

See Also

ElectronicPaymentSample Class | Aptify.Applications.OrderEntry.Payments Namespace


VoiceOverrideCode Property

Aptify 5.0 Software Development Kit (SDK)

ElectronicPaymentSample.VoiceOverrideCode Property

public override String VoiceOverrideCode {get;}

See Also

ElectronicPaymentSample Class | Aptify.Applications.OrderEntry.Payments Namespace


ElectronicPaymentSample Methods

The methods of the ElectronicPaymentSample class are listed below. For a complete list of ElectronicPaymentSample class members, see the ElectronicPaymentSample Members topic.

Public Instance Methods

CapturePayment | Overloaded.
CheckConnection |
Config (inherited from ElectronicPaymentBase) | Configure the object with the necessary data to work with Aptify
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAuthorization | Overloaded.
GetAuthorization (inherited from ElectronicPaymentBase) | Overloaded. Method requests an authorization from an electronic payment provider.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetMerchantConfigValue (inherited from ElectronicPaymentBase) | Returns the a value from the Merchant Dictionary object based on the submitted sKey.
GetMessage (inherited from ElectronicPaymentBase) |
GetSoftFailureScore (inherited from ElectronicPaymentBase) |
GetType (inherited from Object) | Gets the Type of the current instance.
SetMerchantConfigValue (inherited from ElectronicPaymentBase) | Sets a merchant configuration value to a protected Dictionary object to store configuration name/value pairs to provide the specific merchant account information to connect and authenticate with the service provider.
SetPaymentVerificationData (inherited from ElectronicPaymentBase) | This method must be called prior to calling an electronic verification function and is responsible for collecting the required data from Aptify for use in an electronic verification.
ToString (inherited from Object) | Returns a String that represents the current Object.
VoidAuthorization | Overloaded.

Protected Instance Methods

CalculateAVSScore (inherited from ElectronicPaymentBase) |
CalculateCVV2Score (inherited from ElectronicPaymentBase) |
CalculateFraudScore (inherited from ElectronicPaymentBase) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAmountNotAuthorized (inherited from ElectronicPaymentBase) | This method returns the amount, from the Payment object that can be authorized or captured. This will typically be the total amount of the Payment less any amounts previously captured.
GetFraudMappingValue (inherited from ElectronicPaymentBase) | This method retrieves a Fraud Mapping value.
GetMerchantFraudMappings (inherited from ElectronicPaymentBase) | This method retrieves any fraud mappings set for the current transaction.
GetOrderSpecificAuthorizationType (inherited from ElectronicPaymentBase) | The purpose of this method is to get the order specific authorization type. This is determined by examining the products on the order. If any of the products on the order require inventory, then the authorization type will be AuthOnly. Otherwise, the authorization type will be AuthCapture.
GetPaymentOrderData (inherited from ElectronicPaymentBase) | This method is responsible for getting Order information from the first Payment Line on the payment to be authorized. This method will return a data table with the information from the related order.
LUHNCheck (inherited from ElectronicPaymentBase) | This method applies the Luhn algorithm to a credit card number to determine its validity
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetAuthorizationType (inherited from ElectronicPaymentBase) | This method converts the string field value from the Merchant Account record to the AuthorizationTypes enumeration. Override this method if the behavior of translating the field string value to the enumeration type needs to change. This method will throw an exception if there is not matching enumeration type.
SetFraudCheckLevelType (inherited from ElectronicPaymentBase) | This method converts the string field value from the Merchant Account record to the FraudCheckLevel enumeration. Override this method if the behavior of translating the field string value to the enumeration type needs to change. This method will throw an exception if there is not matching enumeration type.
SetMessage (inherited from ElectronicPaymentBase) |
SetSoftFailureScore (inherited from ElectronicPaymentBase) |
SetTenderType (inherited from ElectronicPaymentBase) | This method converts the string field value from the Merchant Account Payment Type record to the TenderType enumeration. Override this method if the behavior of translating the field string value to the enumeration type needs to change. This method will throw an exception if there is not matching enumeration type.
ValidateCreditCardData (inherited from ElectronicPaymentBase) | This method peforms multiple validations on credit card data in the payment object based on the flags passed in with the tValidateTypes parameters and will return a string consisting of the credit card number. This method requires the m_Payment member to be instantiated and will throw an exception if is it Nothing.

See Also

ElectronicPaymentSample Class | Aptify.Applications.OrderEntry.Payments Namespace


CapturePayment Method

Aptify 5.0 Software Development Kit (SDK)

ElectronicPaymentSample.CapturePayment Method

Overload List

public override ElectronicPaymentResults CapturePayment(ElectronicPaymentCaptureParams,ref String&,ref String&);

public override ElectronicPaymentResults CapturePayment(String,ref String&,ref String&);

This sample Capture Payment method will succeed if the cAmount submitted is other than 87.65.

public override ElectronicPaymentResults CapturePayment(String,ref String&,ref String&,Double);

See Also

ElectronicPaymentSample Class | Aptify.Applications.OrderEntry.Payments Namespace


ElectronicPaymentSample.CapturePayment Method (ElectronicPaymentCaptureParams, String&, String&)

public override ElectronicPaymentResults CapturePayment(
ElectronicPaymentCaptureParams oCapParams,
ref String& sAuthCode,
ref String& sResultRefNum
);

See Also

ElectronicPaymentSample Class | Aptify.Applications.OrderEntry.Payments Namespace | ElectronicPaymentSample.CapturePayment Overload List


ElectronicPaymentSample.CapturePayment Method (String, String&, String&)

public override ElectronicPaymentResults CapturePayment(
String sReferenceNumber,
ref String& sAuthCode,
ref String& sResultRefNum
);

See Also

ElectronicPaymentSample Class | Aptify.Applications.OrderEntry.Payments Namespace | ElectronicPaymentSample.CapturePayment Overload List


ElectronicPaymentSample.CapturePayment Method (String, String&, String&, Double)

This sample Capture Payment method will succeed if the cAmount submitted is other than 87.65.

public override ElectronicPaymentResults CapturePayment(
String sReferenceNumber,
ref String& sAuthCode,
ref String& sResultRefNum,
Double cAmount
);

Parameters

sReferenceNumber
sAuthCode
sResultRefNum
cAmount

Return Value

Remarks

See Also

ElectronicPaymentSample Class | Aptify.Applications.OrderEntry.Payments Namespace | ElectronicPaymentSample.CapturePayment Overload List


ElectronicPaymentSample.CheckConnection Method

public override ConnectionStatusTypes CheckConnection();

See Also

ElectronicPaymentSample Class | Aptify.Applications.OrderEntry.Payments Namespace


GetAuthorization Method

Aptify 5.0 Software Development Kit (SDK)

ElectronicPaymentSample.GetAuthorization Method

Overload List

public override ElectronicPaymentResults GetAuthorization(ElectronicPaymentAuthorizationParams);

Inherited from ElectronicPaymentBase.

public ElectronicPaymentResults GetAuthorization(AptifyGenericEntityBase,ref String&,ref String&,ElectronicPaymentBase.AuthorizationTypes,String);

Inherited from ElectronicPaymentBase.

public ElectronicPaymentResults GetAuthorization(AptifyGenericEntityBase,ref String&,ref String&,ElectronicPaymentBase.AuthorizationTypes,String,Boolean);

Inherited from ElectronicPaymentBase.

public ElectronicPaymentResults GetAuthorization(AptifyGenericEntityBase,ref String&,ref String&,ElectronicPaymentBase.AuthorizationTypes,String,Boolean,ElectronicPaymentBase.FraudCheckLevels);

Inherited from ElectronicPaymentBase.

public ElectronicPaymentResults GetAuthorization(AptifyGenericEntityBase,ref String&,ref String&,ElectronicPaymentBase.AuthorizationTypes,String,Boolean,Boolean,Boolean,ElectronicPaymentBase.FraudCheckLevels,ElectronicPaymentBase.ACHAccountTypes,Boolean);

See Also

ElectronicPaymentSample Class | Aptify.Applications.OrderEntry.Payments Namespace


ElectronicPaymentSample.GetAuthorization Method (ElectronicPaymentAuthorizationParams)

public override ElectronicPaymentResults GetAuthorization(
ElectronicPaymentAuthorizationParams oAuthorizationParameters
);

See Also

ElectronicPaymentSample Class | Aptify.Applications.OrderEntry.Payments Namespace | ElectronicPaymentSample.GetAuthorization Overload List


VoidAuthorization Method

Aptify 5.0 Software Development Kit (SDK)

ElectronicPaymentSample.VoidAuthorization Method

Overload List

public override ElectronicPaymentResults VoidAuthorization(ElectronicPaymentCaptureParams,String,ref String&,ref String&);

public override ElectronicPaymentResults VoidAuthorization(Double,String,String,ref String&,ref String&);

See Also

ElectronicPaymentSample Class | Aptify.Applications.OrderEntry.Payments Namespace


ElectronicPaymentSample.VoidAuthorization Method (ElectronicPaymentCaptureParams, String, String&, String&)

public override ElectronicPaymentResults VoidAuthorization(
ElectronicPaymentCaptureParams oCaptureParams,
String sApplicationRefNum,
ref String& sAuthCode,
ref String& sResultRefNum
);

See Also

ElectronicPaymentSample Class | Aptify.Applications.OrderEntry.Payments Namespace | ElectronicPaymentSample.VoidAuthorization Overload List


ElectronicPaymentSample.VoidAuthorization Method (Double, String, String, String&, String&)

public override ElectronicPaymentResults VoidAuthorization(
Double cAmount,
String sApplicationRefNum,
String sProcessorRefNum,
ref String& sAuthCode,
ref String& sResultRefNum
);

See Also

ElectronicPaymentSample Class | Aptify.Applications.OrderEntry.Payments Namespace | ElectronicPaymentSample.VoidAuthorization Overload List


Extension Class

For a list of all members of this type, see Extension Members.

System.Object
Extension

public class Extension : IAptifyViewExtension

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry.Payments

Assembly: PaymentExtension (in PaymentExtension.dll)

See Also

Extension Members | Aptify.Applications.OrderEntry.Payments Namespace


Extension Members

Extension overview

Public Instance Constructors

Extension Constructor Initializes a new instance of the Extension class.

Public Instance Properties

Application
ExtensionMenuItem
ViewPlugIn

Public Instance Methods

Attach |
Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

AfterAttach
AfterConfig
AfterExecute
BeforeAttach
BeforeConfig
BeforeExecute

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetWizardInstance |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Extension Class | Aptify.Applications.OrderEntry.Payments Namespace


Extension Constructor

Initializes a new instance of the Extension class.

public Extension();

See Also

Extension Class | Aptify.Applications.OrderEntry.Payments Namespace


Extension Properties

The properties of the Extension class are listed below. For a complete list of Extension class members, see the Extension Members topic.

Public Instance Properties

Application
ExtensionMenuItem
ViewPlugIn

See Also

Extension Class | Aptify.Applications.OrderEntry.Payments Namespace


Application Property

Aptify 5.0 Software Development Kit (SDK)

Extension.Application Property

public AptifyApplication Application {get;}

Implements

IAptifyViewExtension.

See Also

Extension Class | Aptify.Applications.OrderEntry.Payments Namespace


ExtensionMenuItem Property

Aptify 5.0 Software Development Kit (SDK)

Extension.ExtensionMenuItem Property

public MenuItem ExtensionMenuItem {get;}

Implements

IAptifyViewExtension.

See Also

Extension Class | Aptify.Applications.OrderEntry.Payments Namespace


ViewPlugIn Property

Aptify 5.0 Software Development Kit (SDK)

Extension.ViewPlugIn Property

public IAptifyViewPlugIn ViewPlugIn {get;}

Implements

IAptifyViewExtension.

See Also

Extension Class | Aptify.Applications.OrderEntry.Payments Namespace


Extension Methods

The methods of the Extension class are listed below. For a complete list of Extension class members, see the Extension Members topic.

Public Instance Methods

Attach |
Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetWizardInstance |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Extension Class | Aptify.Applications.OrderEntry.Payments Namespace


Extension.Attach Method

public void Attach(
MenuItem ExtensionMenuItem
);

Implements

IAptifyViewExtension.

See Also

Extension Class | Aptify.Applications.OrderEntry.Payments Namespace


Extension.Config Method

public void Config(
AptifyApplication Application,
IAptifyViewPlugIn ViewPlugIn
);

Implements

IAptifyViewExtension.

See Also

Extension Class | Aptify.Applications.OrderEntry.Payments Namespace


Extension.Execute Method

public void Execute(
MenuItem FunctionMenuItem
);

Implements

IAptifyViewExtension.

See Also

Extension Class | Aptify.Applications.OrderEntry.Payments Namespace


Extension.GetWizardInstance Method

protected IAptifyAction GetWizardInstance(
String sEntity,
String sActionName
);

See Also

Extension Class | Aptify.Applications.OrderEntry.Payments Namespace


Extension Events

The events of the Extension class are listed below. For a complete list of Extension class members, see the Extension Members topic.

Public Instance Events

AfterAttach
AfterConfig
AfterExecute
BeforeAttach
BeforeConfig
BeforeExecute

See Also

Extension Class | Aptify.Applications.OrderEntry.Payments Namespace


Extension.IAptifyViewExtension.AfterAttachEventHandler Event

public event IAptifyViewExtension.AfterAttachEventHandler AfterAttach;

Implements

IAptifyViewExtension.

See Also

Extension Class | Aptify.Applications.OrderEntry.Payments Namespace


Extension.IAptifyViewExtension.AfterConfigEventHandler Event

public event IAptifyViewExtension.AfterConfigEventHandler AfterConfig;

Implements

IAptifyViewExtension.

See Also

Extension Class | Aptify.Applications.OrderEntry.Payments Namespace


Extension.IAptifyViewExtension.AfterExecuteEventHandler Event

public event IAptifyViewExtension.AfterExecuteEventHandler AfterExecute;

Implements

IAptifyViewExtension.

See Also

Extension Class | Aptify.Applications.OrderEntry.Payments Namespace


Extension.IAptifyViewExtension.BeforeAttachEventHandler Event

public event IAptifyViewExtension.BeforeAttachEventHandler BeforeAttach;

Implements

IAptifyViewExtension.

See Also

Extension Class | Aptify.Applications.OrderEntry.Payments Namespace


Extension.IAptifyViewExtension.BeforeConfigEventHandler Event

public event IAptifyViewExtension.BeforeConfigEventHandler BeforeConfig;

Implements

IAptifyViewExtension.

See Also

Extension Class | Aptify.Applications.OrderEntry.Payments Namespace


Extension.IAptifyViewExtension.BeforeExecuteEventHandler Event

public event IAptifyViewExtension.BeforeExecuteEventHandler BeforeExecute;

Implements

IAptifyViewExtension.

See Also

Extension Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentAuthorizationsLayout Class

For a list of all members of this type, see PaymentAuthorizationsLayout Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
PaymentSTLayoutBase
PaymentAuthorizationsLayout

public class PaymentAuthorizationsLayout : PaymentSTLayoutBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry.Payments

Assembly: PaymentGUI (in PaymentGUI.dll)

See Also

PaymentAuthorizationsLayout Members | Aptify.Applications.OrderEntry.Payments Namespace


PaymentAuthorizationsLayout Members

PaymentAuthorizationsLayout overview

Public Instance Constructors

PaymentAuthorizationsLayout Constructor Initializes a new instance of the PaymentAuthorizationsLayout class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

m_txtAmount

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
PaymentGE (inherited from PaymentSTLayoutBase) |
PaymentSTGE (inherited from PaymentSTLayoutBase) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
EnableDisableControl (inherited from PaymentSTLayoutBase) | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControls |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitializeControls |
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from PaymentSTLayoutBase) |
OnFormTemplateLoaded |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

PaymentAuthorizationsLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentAuthorizationsLayout Constructor

Initializes a new instance of the PaymentAuthorizationsLayout class.

public PaymentAuthorizationsLayout();

See Also

PaymentAuthorizationsLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentAuthorizationsLayout Fields

The fields of the PaymentAuthorizationsLayout class are listed below. For a complete list of PaymentAuthorizationsLayout class members, see the PaymentAuthorizationsLayout Members topic.

Protected Instance Fields

m_txtAmount

See Also

PaymentAuthorizationsLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentAuthorizationsLayout.m_txtAmount Field

protected m_txtAmount m_txtAmount;

See Also

PaymentAuthorizationsLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentAuthorizationsLayout Methods

The methods of the PaymentAuthorizationsLayout class are listed below. For a complete list of PaymentAuthorizationsLayout class members, see the PaymentAuthorizationsLayout Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
EnableDisableControl (inherited from PaymentSTLayoutBase) | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControls |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitializeControls |
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from PaymentSTLayoutBase) |
OnFormTemplateLoaded |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

PaymentAuthorizationsLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

PaymentAuthorizationsLayout.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

PaymentAuthorizationsLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentAuthorizationsLayout.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

PaymentAuthorizationsLayout Class | Aptify.Applications.OrderEntry.Payments Namespace | PaymentAuthorizationsLayout.Dispose Overload List


PaymentAuthorizationsLayout.FindControls Method

protected virtual void FindControls();

See Also

PaymentAuthorizationsLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentAuthorizationsLayout.InitializeControls Method

protected void InitializeControls();

See Also

PaymentAuthorizationsLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentAuthorizationsLayout.OnFormTemplateLoaded Method

protected override void OnFormTemplateLoaded(
FormTemplateLayout.FormTemplateLoadedEventArgs e
);

See Also

PaymentAuthorizationsLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGenerateGL Class

This object implements the Aptify.Applications.Accounting.IGenerateGL interface. The purpose of this component is to generate GL entries for a payment

For a list of all members of this type, see PaymentGenerateGL Members.

System.Object
PaymentGenerateGL

public class PaymentGenerateGL : IProcessComponent, IGenerateGL

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.OrderEntry.Payments

Assembly: PaymentGenerateGL (in PaymentGenerateGL.dll)

See Also

PaymentGenerateGL Members | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGenerateGL Members

PaymentGenerateGL overview

Public Instance Constructors

PaymentGenerateGL Constructor Initializes a new instance of the PaymentGenerateGL class.

Public Instance Properties

IsConfigured
Properties

Public Instance Methods

Config | Overloaded. This method configures the object for use and must be called before any other member of the class is accessed. This method stores the Application object provided for use internally as well as stores an internal reference to the Order GE Object passed in which will be used in the context of all of the other members of this class.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GenerateGLEntries | This method is responsible for generating a set of GL entries for the payment. The following generalized logic defines how it will generate the entries. DEBIT the cash account associated with the payment type and payment level combination CREDIT the ar account(s) associated with the product(s) in the order(s) on the payment this is either the default AR Account, or the ar account associated with each product For each product, if the product sale is recognized on cash basis, recognize the product sale via the following DEBIT the Unearned income account CREDIT the Sales account Finally, if the service charge field is not blank on the Payment Type selected, create a debit to the service charge GL account and credit cash for the amount of the service charge. This is used if a company gets charged a fee for processing a transaction such as wire transfer or credit card. It doesn't affect the amount of the payment, but it just offsets the GL cash receipts, so the payment amount doesn't change at all, but the GL entries reflect it correctly for expense accrual purposes.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
RemoveGLEntries
Run
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

Application | Returns the Aptify Application object instance
DataAction | Returns an Aptify DataAction object instance
Database | Returns the name of the database that the Order Entry system resides in
PaymentGE | Returns the internal reference to the instance of the Aptify Generic Entity object for the Payment that is being operated on by the class.

Protected Instance Methods

AddDueToDueFromEntry | This method is responsible for determining if DueTo/DueFrom GL entries are required (only required if cash received by an organization is derived from an order where one or more items on that order were linked to another organization record).
AddGLEntry | This method adds a line to the PaymentGLEntry sub-type based on the provided parameter information
ClearGLEntries | This method is responsible for clearing all of the GL entries within the payment. The default implentation clears out the PaymentGLEntry sub-type.
CompareDebitsAndCredits | Adds all of the Debit entries and all of the Credit entries and then subtracts Credits from Debits. The difference is returned. A value of 0 indicates that the GL Entries are balanced.
CreateCashARandRevenueGLEntries | This method is responsible for determining how much to debit the Cash account, credit each AR account using the following logic and, if necessary, back out the Unearned Revenue and transfer it into the Sales account. For each payment line: If the Line Number field has a value in it, then, this is a link to the Sequence of the Order Detail if the line number field has a value, then the user is SPECIFICALLY stating that this payment line is to apply ONLY to the GL AR Account for the product in that line. If the line number field does NOT have a value in it, then the user is specifying either a partial or a full payment on the ENTIRE order. This means that we have to apply the $ to both the AR associated with the line items, as well as the AR associated with the order lines. We do that by calculating a ratio of the percentage of payment, and applying it evenly against the totals for the order. The same logic is used for the cash based revenue recognition as well.
CreateCashGLEntries | This method is responsible for creating the Cash Debit for inflow payments and Cash Credit for Refunds
CreateLineNumberRevEntry |
CreateServiceChargeGLEntries | This method is responsible for creating the GL entries associated with the service charge for this payment, if a service charge has been applied. The logic in the base class is to generate a DEBIT to the ServiceChargeGL Account and a credit to cash, if the ServiceChargeGLAccount and the ServiceCharge fields are not blank.
CreateShippingHandlingRevenueEntry |
CreateTaxLiabilityEntry |
DoDebitsEqualCredits | This method is responsible for checking whether debit and credit amounts are equal. If debits = credits, this method returns True, otherwise returns False
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetCashAccount | This method is responsible for determining the cash account to use for the payment. The default implementation calls spGetGLCashAccount in the database to make this determination and passed in information from the payment that was provided in the Config() method.
GetDefaultARAccount | This method is responsible for returning the Default AR Account to use for products that do not have an AR account specified. The default implementation of this method uses the Sales Tax Rate GL Account Cache object's DefaultARAccount property.
GetGLAccountOrganizationID | This method is responsible for returning the Organization ID linked to the specified GL Account. The base class implementation of this method calls the spGetGLAccountOrgID stored procedure in the database.
GetInterCompanyGLAccount | This method is responsible for returning a GL account for the combination of the two provided Organization ID numbers for either Due To or Due From entry types as requested by the Type parameter. The default logic for this method in the base class is to execute the spGetInterCompanyGLAccount stored procedure in the database.
GetOrganizationAdjustmentGLAccount | Given an OrganizationID, return the Organizations GL Account for Currency Adjustments/Write Offs
GetOrganizationName | This method is responsible for returning the name of an Organization record from the database for a given Organization ID number.
GetProductARAccount | This method is responsible for determining the Accounts Receivable (AR) account to use for the given Product and Order Level. If ProductID is not passed in, the method will return the Default AR Account by calling the GetDefaultARAccount() method.
GetProductSalesAccount | This method is responsible for determining the Sales account to use for the given Product and Order Level.
GetProductUnearnedAccount | This method is responsible for determining the Unearned account to use for the given Product and Order Level. If ProductID is not passed in, or there is no unearned account associated with the product, the method will return -1.
GetSalesTaxRateARAccount |
GetServiceChargeLiabilityAccount | This method is responsible for determining the service charge liability account to be used for a particular payment type provided by the PaymentTypeID parameter.
GetServiceChargeMethod | This method is responsible for determining the method of service charge application for a given payment type.
GetShipTypeARAccount |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
MergeGLEntries | This method is responsible for merging together GL Entries that have the same account number so that no single account number is repeated on a given journal entry
NeedToGenerate | This function returns True if the Payment information that was changed require GL Entry generation. Some Payment information can change that will not affect GL Entries
RecalcPaymentTotal | This method recalculates the payment total (CALC_Total) and Conversion Adjustment Amount Total (CALC_ConversionAdjustmentAmount) by summing the PaymentLines sub-type

See Also

PaymentGenerateGL Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGenerateGL Constructor

Initializes a new instance of the PaymentGenerateGL class.

public PaymentGenerateGL();

See Also

PaymentGenerateGL Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGenerateGL Properties

The properties of the PaymentGenerateGL class are listed below. For a complete list of PaymentGenerateGL class members, see the PaymentGenerateGL Members topic.

Public Instance Properties

IsConfigured
Properties

Protected Instance Properties

Application | Returns the Aptify Application object instance
DataAction | Returns an Aptify DataAction object instance
Database | Returns the name of the database that the Order Entry system resides in
PaymentGE | Returns the internal reference to the instance of the Aptify Generic Entity object for the Payment that is being operated on by the class.

See Also

PaymentGenerateGL Class | Aptify.Applications.OrderEntry.Payments Namespace


Application Property

Aptify 5.0 Software Development Kit (SDK)

PaymentGenerateGL.Application Property

Returns the Aptify Application object instance

protected AptifyApplication Application {get;}

Property Value

Remarks

See Also

PaymentGenerateGL Class | Aptify.Applications.OrderEntry.Payments Namespace


DataAction Property

Aptify 5.0 Software Development Kit (SDK)

PaymentGenerateGL.DataAction Property

Returns an Aptify DataAction object instance

protected DataAction DataAction {get;}

Property Value

Remarks

See Also

PaymentGenerateGL Class | Aptify.Applications.OrderEntry.Payments Namespace


Database Property

Aptify 5.0 Software Development Kit (SDK)

PaymentGenerateGL.Database Property

Returns the name of the database that the Order Entry system resides in

protected String Database {get;}

Property Value

Remarks

See Also

PaymentGenerateGL Class | Aptify.Applications.OrderEntry.Payments Namespace


IsConfigured Property

Aptify 5.0 Software Development Kit (SDK)

PaymentGenerateGL.IsConfigured Property

public virtual Boolean IsConfigured {get;}

See Also

PaymentGenerateGL Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGE Property

Aptify 5.0 Software Development Kit (SDK)

PaymentGenerateGL.PaymentGE Property

Returns the internal reference to the instance of the Aptify Generic Entity object for the Payment that is being operated on by the class.

protected AptifyGenericEntityBase PaymentGE {get;}

Property Value

Remarks

See Also

PaymentGenerateGL Class | Aptify.Applications.OrderEntry.Payments Namespace


Properties Property

Aptify 5.0 Software Development Kit (SDK)

PaymentGenerateGL.Properties Property

public AptifyProperties Properties {get;}

Implements

IProcessComponent.

See Also

PaymentGenerateGL Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGenerateGL Methods

The methods of the PaymentGenerateGL class are listed below. For a complete list of PaymentGenerateGL class members, see the PaymentGenerateGL Members topic.

Public Instance Methods

Config | Overloaded. This method configures the object for use and must be called before any other member of the class is accessed. This method stores the Application object provided for use internally as well as stores an internal reference to the Order GE Object passed in which will be used in the context of all of the other members of this class.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GenerateGLEntries | This method is responsible for generating a set of GL entries for the payment. The following generalized logic defines how it will generate the entries. DEBIT the cash account associated with the payment type and payment level combination CREDIT the ar account(s) associated with the product(s) in the order(s) on the payment this is either the default AR Account, or the ar account associated with each product For each product, if the product sale is recognized on cash basis, recognize the product sale via the following DEBIT the Unearned income account CREDIT the Sales account Finally, if the service charge field is not blank on the Payment Type selected, create a debit to the service charge GL account and credit cash for the amount of the service charge. This is used if a company gets charged a fee for processing a transaction such as wire transfer or credit card. It doesn't affect the amount of the payment, but it just offsets the GL cash receipts, so the payment amount doesn't change at all, but the GL entries reflect it correctly for expense accrual purposes.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
RemoveGLEntries
Run
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

AddDueToDueFromEntry | This method is responsible for determining if DueTo/DueFrom GL entries are required (only required if cash received by an organization is derived from an order where one or more items on that order were linked to another organization record).
AddGLEntry | This method adds a line to the PaymentGLEntry sub-type based on the provided parameter information
ClearGLEntries | This method is responsible for clearing all of the GL entries within the payment. The default implentation clears out the PaymentGLEntry sub-type.
CompareDebitsAndCredits | Adds all of the Debit entries and all of the Credit entries and then subtracts Credits from Debits. The difference is returned. A value of 0 indicates that the GL Entries are balanced.
CreateCashARandRevenueGLEntries | This method is responsible for determining how much to debit the Cash account, credit each AR account using the following logic and, if necessary, back out the Unearned Revenue and transfer it into the Sales account. For each payment line: If the Line Number field has a value in it, then, this is a link to the Sequence of the Order Detail if the line number field has a value, then the user is SPECIFICALLY stating that this payment line is to apply ONLY to the GL AR Account for the product in that line. If the line number field does NOT have a value in it, then the user is specifying either a partial or a full payment on the ENTIRE order. This means that we have to apply the $ to both the AR associated with the line items, as well as the AR associated with the order lines. We do that by calculating a ratio of the percentage of payment, and applying it evenly against the totals for the order. The same logic is used for the cash based revenue recognition as well.
CreateCashGLEntries | This method is responsible for creating the Cash Debit for inflow payments and Cash Credit for Refunds
CreateLineNumberRevEntry |
CreateServiceChargeGLEntries | This method is responsible for creating the GL entries associated with the service charge for this payment, if a service charge has been applied. The logic in the base class is to generate a DEBIT to the ServiceChargeGL Account and a credit to cash, if the ServiceChargeGLAccount and the ServiceCharge fields are not blank.
CreateShippingHandlingRevenueEntry |
CreateTaxLiabilityEntry |
DoDebitsEqualCredits | This method is responsible for checking whether debit and credit amounts are equal. If debits = credits, this method returns True, otherwise returns False
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetCashAccount | This method is responsible for determining the cash account to use for the payment. The default implementation calls spGetGLCashAccount in the database to make this determination and passed in information from the payment that was provided in the Config() method.
GetDefaultARAccount | This method is responsible for returning the Default AR Account to use for products that do not have an AR account specified. The default implementation of this method uses the Sales Tax Rate GL Account Cache object's DefaultARAccount property.
GetGLAccountOrganizationID | This method is responsible for returning the Organization ID linked to the specified GL Account. The base class implementation of this method calls the spGetGLAccountOrgID stored procedure in the database.
GetInterCompanyGLAccount | This method is responsible for returning a GL account for the combination of the two provided Organization ID numbers for either Due To or Due From entry types as requested by the Type parameter. The default logic for this method in the base class is to execute the spGetInterCompanyGLAccount stored procedure in the database.
GetOrganizationAdjustmentGLAccount | Given an OrganizationID, return the Organizations GL Account for Currency Adjustments/Write Offs
GetOrganizationName | This method is responsible for returning the name of an Organization record from the database for a given Organization ID number.
GetProductARAccount | This method is responsible for determining the Accounts Receivable (AR) account to use for the given Product and Order Level. If ProductID is not passed in, the method will return the Default AR Account by calling the GetDefaultARAccount() method.
GetProductSalesAccount | This method is responsible for determining the Sales account to use for the given Product and Order Level.
GetProductUnearnedAccount | This method is responsible for determining the Unearned account to use for the given Product and Order Level. If ProductID is not passed in, or there is no unearned account associated with the product, the method will return -1.
GetSalesTaxRateARAccount |
GetServiceChargeLiabilityAccount | This method is responsible for determining the service charge liability account to be used for a particular payment type provided by the PaymentTypeID parameter.
GetServiceChargeMethod | This method is responsible for determining the method of service charge application for a given payment type.
GetShipTypeARAccount |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
MergeGLEntries | This method is responsible for merging together GL Entries that have the same account number so that no single account number is repeated on a given journal entry
NeedToGenerate | This function returns True if the Payment information that was changed require GL Entry generation. Some Payment information can change that will not affect GL Entries
RecalcPaymentTotal | This method recalculates the payment total (CALC_Total) and Conversion Adjustment Amount Total (CALC_ConversionAdjustmentAmount) by summing the PaymentLines sub-type

See Also

PaymentGenerateGL Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGenerateGL.AddDueToDueFromEntry Method

This method is responsible for determining if DueTo/DueFrom GL entries are required (only required if cash received by an organization is derived from an order where one or more items on that order were linked to another organization record).

protected virtual bool AddDueToDueFromEntry(
Decimal Amount,
Int64 CashOrganizationID,
String ARAccount
);

Parameters

Amount
CashOrganizationID
ARAccount
GL Account used for A/R

Return Value

Remarks

See Also

PaymentGenerateGL Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGenerateGL.AddGLEntry Method

This method adds a line to the PaymentGLEntry sub-type based on the provided parameter information

protected virtual void AddGLEntry(
String Account,
Decimal Debit,
Decimal Credit,
String Description
);

Parameters

Account
Debit
Credit
Description

Remarks

See Also

PaymentGenerateGL Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGenerateGL.ClearGLEntries Method

This method is responsible for clearing all of the GL entries within the payment. The default implentation clears out the PaymentGLEntry sub-type.

protected virtual void ClearGLEntries();

Remarks

See Also

PaymentGenerateGL Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGenerateGL.CompareDebitsAndCredits Method

Adds all of the Debit entries and all of the Credit entries and then subtracts Credits from Debits. The difference is returned. A value of 0 indicates that the GL Entries are balanced.

protected decimal CompareDebitsAndCredits();

Return Value

Remarks

See Also

PaymentGenerateGL Class | Aptify.Applications.OrderEntry.Payments Namespace


Config Method

Aptify 5.0 Software Development Kit (SDK)

PaymentGenerateGL.Config Method

Overload List

public void Config(AptifyApplication);

This method configures the object for use and must be called before any other member of the class is accessed. This method stores the Application object provided for use internally as well as stores an internal reference to the Order GE Object passed in which will be used in the context of all of the other members of this class.

public virtual void Config(AptifyGenericEntityBase,AptifyApplication);

See Also

PaymentGenerateGL Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGenerateGL.Config Method (AptifyApplication)

public void Config(
AptifyApplication ApplicationObject
);

Implements

IProcessComponent.

See Also

PaymentGenerateGL Class | Aptify.Applications.OrderEntry.Payments Namespace | PaymentGenerateGL.Config Overload List


PaymentGenerateGL.Config Method (AptifyGenericEntityBase, AptifyApplication)

This method configures the object for use and must be called before any other member of the class is accessed. This method stores the Application object provided for use internally as well as stores an internal reference to the Order GE Object passed in which will be used in the context of all of the other members of this class.

public virtual void Config(
AptifyGenericEntityBase PaymentGE,
AptifyApplication Application
);

Parameters

PaymentGE
Application

Implements

IGenerateGL.

Remarks

See Also

PaymentGenerateGL Class | Aptify.Applications.OrderEntry.Payments Namespace | PaymentGenerateGL.Config Overload List


PaymentGenerateGL.CreateCashARandRevenueGLEntries Method

This method is responsible for determining how much to debit the Cash account, credit each AR account using the following logic and, if necessary, back out the Unearned Revenue and transfer it into the Sales account. For each payment line: If the Line Number field has a value in it, then, this is a link to the Sequence of the Order Detail if the line number field has a value, then the user is SPECIFICALLY stating that this payment line is to apply ONLY to the GL AR Account for the product in that line. If the line number field does NOT have a value in it, then the user is specifying either a partial or a full payment on the ENTIRE order. This means that we have to apply the $ to both the AR associated with the line items, as well as the AR associated with the order lines. We do that by calculating a ratio of the percentage of payment, and applying it evenly against the totals for the order. The same logic is used for the cash based revenue recognition as well.

protected virtual bool CreateCashARandRevenueGLEntries();

Return Value

True if the operation is succesful, False otherwise

Remarks

See Also

PaymentGenerateGL Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGenerateGL.CreateCashGLEntries Method

This method is responsible for creating the Cash Debit for inflow payments and Cash Credit for Refunds

protected virtual bool CreateCashGLEntries();

Return Value

True if operation is succesful, False otherwise

Remarks

See Also

PaymentGenerateGL Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGenerateGL.CreateLineNumberRevEntry Method

protected virtual bool CreateLineNumberRevEntry(
Int64 OrderID,
Int64 OrderLevelID,
Int64 OrderDetailID,
Int32 Sequence,
Int64 ProductID,
Decimal Amount,
Decimal DiscountAmount
);

See Also

PaymentGenerateGL Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGenerateGL.CreateServiceChargeGLEntries Method

This method is responsible for creating the GL entries associated with the service charge for this payment, if a service charge has been applied. The logic in the base class is to generate a DEBIT to the ServiceChargeGL Account and a credit to cash, if the ServiceChargeGLAccount and the ServiceCharge fields are not blank.

protected virtual bool CreateServiceChargeGLEntries();

Return Value

True if the operation is a success, False otherwise

Remarks

See Also

PaymentGenerateGL Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGenerateGL.CreateShippingHandlingRevenueEntry Method

protected virtual bool CreateShippingHandlingRevenueEntry(
Int64 OrderID,
Int64 ShipTypeID,
Decimal Amount
);

See Also

PaymentGenerateGL Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGenerateGL.CreateTaxLiabilityEntry Method

protected virtual bool CreateTaxLiabilityEntry(
Int64 OrderID,
Int64 SalesTaxRateID,
Decimal Amount
);

See Also

PaymentGenerateGL Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGenerateGL.DoDebitsEqualCredits Method

This method is responsible for checking whether debit and credit amounts are equal. If debits = credits, this method returns True, otherwise returns False

protected virtual bool DoDebitsEqualCredits();

Return Value

Remarks

See Also

PaymentGenerateGL Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGenerateGL.GenerateGLEntries Method

This method is responsible for generating a set of GL entries for the payment. The following generalized logic defines how it will generate the entries. DEBIT the cash account associated with the payment type and payment level combination CREDIT the ar account(s) associated with the product(s) in the order(s) on the payment this is either the default AR Account, or the ar account associated with each product For each product, if the product sale is recognized on cash basis, recognize the product sale via the following DEBIT the Unearned income account CREDIT the Sales account Finally, if the service charge field is not blank on the Payment Type selected, create a debit to the service charge GL account and credit cash for the amount of the service charge. This is used if a company gets charged a fee for processing a transaction such as wire transfer or credit card. It doesn't affect the amount of the payment, but it just offsets the GL cash receipts, so the payment amount doesn't change at all, but the GL entries reflect it correctly for expense accrual purposes.

public virtual bool GenerateGLEntries(
Boolean ShowErrors
);

Parameters

ShowErrors
This parameter is ignored, user interaction should be handled by the calling application/object as appropriate

Return Value

True if the operation succeeds, False otherwise

Implements

IGenerateGL.

Remarks

See Also

PaymentGenerateGL Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGenerateGL.GetCashAccount Method

This method is responsible for determining the cash account to use for the payment. The default implementation calls spGetGLCashAccount in the database to make this determination and passed in information from the payment that was provided in the Config() method.

protected virtual string GetCashAccount(
Boolean ForceRefresh
);

Parameters

ForceRefresh

Return Value

Remarks

See Also

PaymentGenerateGL Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGenerateGL.GetDefaultARAccount Method

This method is responsible for returning the Default AR Account to use for products that do not have an AR account specified. The default implementation of this method uses the Sales Tax Rate GL Account Cache object's DefaultARAccount property.

protected virtual string GetDefaultARAccount();

Return Value

Remarks

See Also

PaymentGenerateGL Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGenerateGL.GetGLAccountOrganizationID Method

This method is responsible for returning the Organization ID linked to the specified GL Account. The base class implementation of this method calls the spGetGLAccountOrgID stored procedure in the database.

protected virtual long GetGLAccountOrganizationID(
String GLAccount
);

Parameters

GLAccount

Return Value

Organization ID that is linked to the GL Account specified

Remarks

See Also

PaymentGenerateGL Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGenerateGL.GetInterCompanyGLAccount Method

This method is responsible for returning a GL account for the combination of the two provided Organization ID numbers for either Due To or Due From entry types as requested by the Type parameter. The default logic for this method in the base class is to execute the spGetInterCompanyGLAccount stored procedure in the database.

protected virtual string GetInterCompanyGLAccount(
Int64 OrganizationID,
Int64 RelatedOrganizationID,
PaymentGenerateGL.InterCompanyAccountType Type
);

Parameters

OrganizationID
RelatedOrganizationID
Type

Return Value

Remarks

See Also

PaymentGenerateGL Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGenerateGL.GetOrganizationAdjustmentGLAccount Method

Given an OrganizationID, return the Organizations GL Account for Currency Adjustments/Write Offs

protected virtual string GetOrganizationAdjustmentGLAccount(
Int64 OrganizationID
);

Parameters

OrganizationID

Return Value

Remarks

See Also

PaymentGenerateGL Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGenerateGL.GetOrganizationName Method

This method is responsible for returning the name of an Organization record from the database for a given Organization ID number.

protected virtual string GetOrganizationName(
Int64 OrganizationID
);

Parameters

OrganizationID

Return Value

Remarks

See Also

PaymentGenerateGL Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGenerateGL.GetProductARAccount Method

This method is responsible for determining the Accounts Receivable (AR) account to use for the given Product and Order Level. If ProductID is not passed in, the method will return the Default AR Account by calling the GetDefaultARAccount() method.

protected virtual string GetProductARAccount(
Int64 ProductID,
Int64 OrderLevelID
);

Parameters

ProductID
OrderLevelID

Return Value

Remarks

See Also

PaymentGenerateGL Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGenerateGL.GetProductSalesAccount Method

This method is responsible for determining the Sales account to use for the given Product and Order Level.

protected virtual string GetProductSalesAccount(
Int64 ProductID,
Int64 OrderLevelID
);

Parameters

ProductID
ID of the product
OrderLevelID

Return Value

Returns the Sales Account number for the product, or nothing if there is no Sales account available.

Remarks

If the Product ID is not passed in, or is less then zero, an ArgumentOutOfRangeException will be published and nothing will be returned.

See Also

PaymentGenerateGL Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGenerateGL.GetProductUnearnedAccount Method

This method is responsible for determining the Unearned account to use for the given Product and Order Level. If ProductID is not passed in, or there is no unearned account associated with the product, the method will return -1.

protected virtual string GetProductUnearnedAccount(
Int64 ProductID,
Int64 OrderLevelID
);

Parameters

ProductID
ID of the product
OrderLevelID

Return Value

Returns the Unearned Account number for a product.

Remarks

See Also

PaymentGenerateGL Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGenerateGL.GetSalesTaxRateARAccount Method

protected virtual string GetSalesTaxRateARAccount(
Int64 SalesTaxRateID
);

See Also

PaymentGenerateGL Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGenerateGL.GetServiceChargeLiabilityAccount Method

This method is responsible for determining the service charge liability account to be used for a particular payment type provided by the PaymentTypeID parameter.

protected virtual string GetServiceChargeLiabilityAccount(
Int64 PaymentTypeID
);

Parameters

PaymentTypeID

Return Value

Remarks

See Also

PaymentGenerateGL Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGenerateGL.GetServiceChargeMethod Method

This method is responsible for determining the method of service charge application for a given payment type.

protected virtual string GetServiceChargeMethod(
Int64 PaymentTypeID
);

Parameters

PaymentTypeID

Return Value

Remarks

See Also

PaymentGenerateGL Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGenerateGL.GetShipTypeARAccount Method

protected virtual string GetShipTypeARAccount(
Int64 ShipTypeID
);

See Also

PaymentGenerateGL Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGenerateGL.MergeGLEntries Method

This method is responsible for merging together GL Entries that have the same account number so that no single account number is repeated on a given journal entry

protected virtual bool MergeGLEntries();

Return Value

True if the operation is succesful, False otherwise

Remarks

See Also

PaymentGenerateGL Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGenerateGL.NeedToGenerate Method

This function returns True if the Payment information that was changed require GL Entry generation. Some Payment information can change that will not affect GL Entries

protected virtual bool NeedToGenerate();

Return Value

Remarks

See Also

PaymentGenerateGL Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGenerateGL.RecalcPaymentTotal Method

This method recalculates the payment total (CALC_Total) and Conversion Adjustment Amount Total (CALC_ConversionAdjustmentAmount) by summing the PaymentLines sub-type

protected virtual decimal RecalcPaymentTotal();

Return Value

Remarks

See Also

PaymentGenerateGL Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGenerateGL.RemoveGLEntries Method

public virtual bool RemoveGLEntries(
Boolean ShowErrors
);

Implements

IGenerateGL.

See Also

PaymentGenerateGL Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGenerateGL.Run Method

public string Run();

Implements

IProcessComponent.

See Also

PaymentGenerateGL Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGenerateGL.GLEntry Class

For a list of all members of this type, see PaymentGenerateGL.GLEntry Members.

System.Object
PaymentGenerateGL.GLEntry

protected class PaymentGenerateGL.GLEntry

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry.Payments

Assembly: PaymentGenerateGL (in PaymentGenerateGL.dll)

See Also

PaymentGenerateGL.GLEntry Members | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGenerateGL.GLEntry Members

PaymentGenerateGL.GLEntry overview

Public Instance Constructors

PaymentGenerateGL.GLEntry Constructor

Public Instance Properties

Balance
GLAccount

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
PostCredit |
PostDebit |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PaymentGenerateGL.GLEntry Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGenerateGL.GLEntry Constructor

public PaymentGenerateGL.GLEntry(
String GLAccount,
PaymentGenerateGL.NormalBalanceType NormalBalance,
Decimal OpeningBalance
);

See Also

PaymentGenerateGL.GLEntry Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGenerateGL.GLEntry Properties

The properties of the PaymentGenerateGL.GLEntry class are listed below. For a complete list of PaymentGenerateGL.GLEntry class members, see the PaymentGenerateGL.GLEntry Members topic.

Public Instance Properties

Balance
GLAccount

See Also

PaymentGenerateGL.GLEntry Class | Aptify.Applications.OrderEntry.Payments Namespace


Balance Property

Aptify 5.0 Software Development Kit (SDK)

PaymentGenerateGL.GLEntry.Balance Property

public Decimal Balance {get;}

See Also

PaymentGenerateGL.GLEntry Class | Aptify.Applications.OrderEntry.Payments Namespace


GLAccount Property

Aptify 5.0 Software Development Kit (SDK)

PaymentGenerateGL.GLEntry.GLAccount Property

public String GLAccount {get;}

See Also

PaymentGenerateGL.GLEntry Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGenerateGL.GLEntry Methods

The methods of the PaymentGenerateGL.GLEntry class are listed below. For a complete list of PaymentGenerateGL.GLEntry class members, see the PaymentGenerateGL.GLEntry Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
PostCredit |
PostDebit |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PaymentGenerateGL.GLEntry Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGenerateGL.GLEntry.PostCredit Method

public void PostCredit(
Decimal CreditAmount
);

See Also

PaymentGenerateGL.GLEntry Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGenerateGL.GLEntry.PostDebit Method

public void PostDebit(
Decimal DebitAmount
);

See Also

PaymentGenerateGL.GLEntry Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGenerateGL.InterCompanyAccountType Enumeration

public enum PaymentGenerateGL.InterCompanyAccountType

Members

Member Name | Description
DueTo |
DueFrom |

Requirements

Namespace: Aptify.Applications.OrderEntry.Payments

Assembly: PaymentGenerateGL (in PaymentGenerateGL.dll)

See Also

Aptify.Applications.OrderEntry.Payments Namespace


PaymentGenerateGL.NormalBalanceType Enumeration

public enum PaymentGenerateGL.NormalBalanceType

Members

Member Name | Description
Debit |
Credit |

Requirements

Namespace: Aptify.Applications.OrderEntry.Payments

Assembly: PaymentGenerateGL (in PaymentGenerateGL.dll)

See Also

Aptify.Applications.OrderEntry.Payments Namespace


PaymentGenerateGL.OrderInfo Class

This class is used within the PaymentGenerateGL class to keep track of order information

For a list of all members of this type, see PaymentGenerateGL.OrderInfo Members.

System.Object
PaymentGenerateGL.OrderInfo

protected class PaymentGenerateGL.OrderInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.OrderEntry.Payments

Assembly: PaymentGenerateGL (in PaymentGenerateGL.dll)

See Also

PaymentGenerateGL.OrderInfo Members | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGenerateGL.OrderInfo Members

PaymentGenerateGL.OrderInfo overview

Public Instance Constructors

PaymentGenerateGL.OrderInfo Constructor Initializes a new instance of the PaymentGenerateGL.OrderInfo class.

Public Instance Properties

OrderBalance
OrderID
OrderLevelID
OrderLine
OrderLineCount
OrderTotal
OrganizationID

Public Instance Methods

ApplyPayment |
Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
TransferCurrentPaymentToHistory | Takes a the current Payment Amount, reverses it and applies it as an Historical Payment. This is done affect the GL Entries have been created for the current Payment.

Protected Instance Fields

m_colOrderLines
m_cOrderBalance
m_cOrderTotal
m_iCurrencyTypeID
m_lOrderID
m_lOrderLevelID
m_lOrganizationID
m_lPaymentID
m_oApp
m_oDA
m_sDatabase

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
LoadOrderInformation |
LoadPaymentInformation |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PaymentGenerateGL.OrderInfo Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGenerateGL.OrderInfo Constructor

Initializes a new instance of the PaymentGenerateGL.OrderInfo class.

public PaymentGenerateGL.OrderInfo();

See Also

PaymentGenerateGL.OrderInfo Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGenerateGL.OrderInfo Fields

The fields of the PaymentGenerateGL.OrderInfo class are listed below. For a complete list of PaymentGenerateGL.OrderInfo class members, see the PaymentGenerateGL.OrderInfo Members topic.

Protected Instance Fields

m_colOrderLines
m_cOrderBalance
m_cOrderTotal
m_iCurrencyTypeID
m_lOrderID
m_lOrderLevelID
m_lOrganizationID
m_lPaymentID
m_oApp
m_oDA
m_sDatabase

See Also

PaymentGenerateGL.OrderInfo Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGenerateGL.OrderInfo.m_colOrderLines Field

protected m_colOrderLines m_colOrderLines;

See Also

PaymentGenerateGL.OrderInfo Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGenerateGL.OrderInfo.m_cOrderBalance Field

protected m_cOrderBalance m_cOrderBalance;

See Also

PaymentGenerateGL.OrderInfo Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGenerateGL.OrderInfo.m_cOrderTotal Field

protected m_cOrderTotal m_cOrderTotal;

See Also

PaymentGenerateGL.OrderInfo Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGenerateGL.OrderInfo.m_iCurrencyTypeID Field

protected m_iCurrencyTypeID m_iCurrencyTypeID;

See Also

PaymentGenerateGL.OrderInfo Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGenerateGL.OrderInfo.m_lOrderID Field

protected m_lOrderID m_lOrderID;

See Also

PaymentGenerateGL.OrderInfo Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGenerateGL.OrderInfo.m_lOrderLevelID Field

protected m_lOrderLevelID m_lOrderLevelID;

See Also

PaymentGenerateGL.OrderInfo Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGenerateGL.OrderInfo.m_lOrganizationID Field

protected m_lOrganizationID m_lOrganizationID;

See Also

PaymentGenerateGL.OrderInfo Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGenerateGL.OrderInfo.m_lPaymentID Field

protected m_lPaymentID m_lPaymentID;

See Also

PaymentGenerateGL.OrderInfo Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGenerateGL.OrderInfo.m_oApp Field

protected m_oApp m_oApp;

See Also

PaymentGenerateGL.OrderInfo Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGenerateGL.OrderInfo.m_oDA Field

protected m_oDA m_oDA;

See Also

PaymentGenerateGL.OrderInfo Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGenerateGL.OrderInfo.m_sDatabase Field

protected m_sDatabase m_sDatabase;

See Also

PaymentGenerateGL.OrderInfo Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGenerateGL.OrderInfo Properties

The properties of the PaymentGenerateGL.OrderInfo class are listed below. For a complete list of PaymentGenerateGL.OrderInfo class members, see the PaymentGenerateGL.OrderInfo Members topic.

Public Instance Properties

OrderBalance
OrderID
OrderLevelID
OrderLine
OrderLineCount
OrderTotal
OrganizationID

See Also

PaymentGenerateGL.OrderInfo Class | Aptify.Applications.OrderEntry.Payments Namespace


OrderBalance Property

Aptify 5.0 Software Development Kit (SDK)

PaymentGenerateGL.OrderInfo.OrderBalance Property

public virtual Decimal OrderBalance {get;}

See Also

PaymentGenerateGL.OrderInfo Class | Aptify.Applications.OrderEntry.Payments Namespace


OrderID Property

Aptify 5.0 Software Development Kit (SDK)

PaymentGenerateGL.OrderInfo.OrderID Property

public virtual Int64 OrderID {get;}

See Also

PaymentGenerateGL.OrderInfo Class | Aptify.Applications.OrderEntry.Payments Namespace


OrderLevelID Property

Aptify 5.0 Software Development Kit (SDK)

PaymentGenerateGL.OrderInfo.OrderLevelID Property

public virtual Int64 OrderLevelID {get;}

See Also

PaymentGenerateGL.OrderInfo Class | Aptify.Applications.OrderEntry.Payments Namespace


OrderLine Property

Aptify 5.0 Software Development Kit (SDK)

PaymentGenerateGL.OrderInfo.OrderLine Property

public virtual PaymentGenerateGL.QueryResult this[
String Key
] {get;}

See Also

PaymentGenerateGL.OrderInfo Class | Aptify.Applications.OrderEntry.Payments Namespace


OrderLineCount Property

Aptify 5.0 Software Development Kit (SDK)

PaymentGenerateGL.OrderInfo.OrderLineCount Property

public virtual Int32 OrderLineCount {get;}

See Also

PaymentGenerateGL.OrderInfo Class | Aptify.Applications.OrderEntry.Payments Namespace


OrderTotal Property

Aptify 5.0 Software Development Kit (SDK)

PaymentGenerateGL.OrderInfo.OrderTotal Property

public virtual Decimal OrderTotal {get;}

See Also

PaymentGenerateGL.OrderInfo Class | Aptify.Applications.OrderEntry.Payments Namespace


OrganizationID Property

Aptify 5.0 Software Development Kit (SDK)

PaymentGenerateGL.OrderInfo.OrganizationID Property

public virtual Int64 OrganizationID {get;}

See Also

PaymentGenerateGL.OrderInfo Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGenerateGL.OrderInfo Methods

The methods of the PaymentGenerateGL.OrderInfo class are listed below. For a complete list of PaymentGenerateGL.OrderInfo class members, see the PaymentGenerateGL.OrderInfo Members topic.

Public Instance Methods

ApplyPayment |
Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
TransferCurrentPaymentToHistory | Takes a the current Payment Amount, reverses it and applies it as an Historical Payment. This is done affect the GL Entries have been created for the current Payment.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
LoadOrderInformation |
LoadPaymentInformation |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PaymentGenerateGL.OrderInfo Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGenerateGL.OrderInfo.ApplyPayment Method

public bool ApplyPayment(
PaymentLinesEntity.AppliesToType AppliesTo,
Decimal Amount,
Int64 OrderDetailID
);

See Also

PaymentGenerateGL.OrderInfo Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGenerateGL.OrderInfo.Config Method

public bool Config(
AptifyApplication Application,
DataAction DataAction,
String Database,
Int64 OrderID,
Int64 PaymentID
);

See Also

PaymentGenerateGL.OrderInfo Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGenerateGL.OrderInfo.LoadOrderInformation Method

protected virtual bool LoadOrderInformation();

See Also

PaymentGenerateGL.OrderInfo Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGenerateGL.OrderInfo.LoadPaymentInformation Method

protected bool LoadPaymentInformation();

See Also

PaymentGenerateGL.OrderInfo Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGenerateGL.OrderInfo.TransferCurrentPaymentToHistory Method

Takes a the current Payment Amount, reverses it and applies it as an Historical Payment. This is done affect the GL Entries have been created for the current Payment.

public void TransferCurrentPaymentToHistory();

Remarks

See Also

PaymentGenerateGL.OrderInfo Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGenerateGL.QueryResult Class

This class is used within the PaymentGenerateGL to store the results of queries on the order entry database.

For a list of all members of this type, see PaymentGenerateGL.QueryResult Members.

System.Object
PaymentGenerateGL.QueryResult

protected class PaymentGenerateGL.QueryResult

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.OrderEntry.Payments

Assembly: PaymentGenerateGL (in PaymentGenerateGL.dll)

See Also

PaymentGenerateGL.QueryResult Members | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGenerateGL.QueryResult Members

PaymentGenerateGL.QueryResult overview

Public Instance Constructors

PaymentGenerateGL.QueryResult Overloaded. Initializes a new instance of the PaymentGenerateGL.QueryResult class.

Public Instance Properties

AttributeID | ProductID for OrderLine items. ShipTypeID for Shipping and Handling items. SalesTaxRateID for Tax items.
Balance |
Discount |
HistoricalPaymentAmountApplied | Amount of an Historical (not the current) Payment applied to this item. Updated by the ApplyHistoricalPayment method
HistoricalSalesDiscountApplied | Amount of the Historical Payment applied to the Sales Discount amount for the item. This property is valid only for Order Lines. Updated by the ApplyHistoricalPayment method
InclusiveTaxAmount |
OrderDetailID |
PaymentAmountApplied | Amount of the Payment applied to this item. Updated by the ApplyPayment method
Price |
Quantity |
SalesDiscountApplied | Amount of the Payment applied to the Sales Discount amount for the item. This property is valid only for Order Lines. Updated by the ApplyPayment method
Sequence |
Total |
Type |

Public Instance Methods

ApplyInclusiveTaxAmount |
ApplyPayment |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PaymentGenerateGL.QueryResult Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGenerateGL.QueryResult Constructor

Constructor for creating an Order Lines item.

Overload List

public PaymentGenerateGL.QueryResult(PaymentGenerateGL.QueryResultType,Int64,Decimal);

Constructor for creating an Order Lines item.

public PaymentGenerateGL.QueryResult(Int64,Int32,Int64,Decimal,Decimal,Decimal);

See Also

PaymentGenerateGL.QueryResult Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGenerateGL.QueryResult Constructor (Int64, Int32, Int64, Decimal, Decimal, Decimal)

Constructor for creating an Order Lines item.

public PaymentGenerateGL.QueryResult(
Int64 OrderDetailID,
Int32 Sequence,
Int64 ProductID,
Decimal Price,
Decimal Quantity,
Decimal Discount
);

Parameters

OrderDetailID
Sequence
ProductID
Price
Quantity
Discount

Remarks

See Also

PaymentGenerateGL.QueryResult Class | Aptify.Applications.OrderEntry.Payments Namespace | PaymentGenerateGL.QueryResult Constructor Overload List


PaymentGenerateGL.QueryResult Constructor (QueryResultType, Int64, Decimal)

public PaymentGenerateGL.QueryResult(
PaymentGenerateGL.QueryResultType qrType,
Int64 AttributeID,
Decimal Total
);

See Also

PaymentGenerateGL.QueryResult Class | Aptify.Applications.OrderEntry.Payments Namespace | PaymentGenerateGL.QueryResult Constructor Overload List


PaymentGenerateGL.QueryResult Properties

The properties of the PaymentGenerateGL.QueryResult class are listed below. For a complete list of PaymentGenerateGL.QueryResult class members, see the PaymentGenerateGL.QueryResult Members topic.

Public Instance Properties

AttributeID | ProductID for OrderLine items. ShipTypeID for Shipping and Handling items. SalesTaxRateID for Tax items.
Balance |
Discount |
HistoricalPaymentAmountApplied | Amount of an Historical (not the current) Payment applied to this item. Updated by the ApplyHistoricalPayment method
HistoricalSalesDiscountApplied | Amount of the Historical Payment applied to the Sales Discount amount for the item. This property is valid only for Order Lines. Updated by the ApplyHistoricalPayment method
InclusiveTaxAmount |
OrderDetailID |
PaymentAmountApplied | Amount of the Payment applied to this item. Updated by the ApplyPayment method
Price |
Quantity |
SalesDiscountApplied | Amount of the Payment applied to the Sales Discount amount for the item. This property is valid only for Order Lines. Updated by the ApplyPayment method
Sequence |
Total |
Type |

See Also

PaymentGenerateGL.QueryResult Class | Aptify.Applications.OrderEntry.Payments Namespace


AttributeID Property

Aptify 5.0 Software Development Kit (SDK)

PaymentGenerateGL.QueryResult.AttributeID Property

ProductID for OrderLine items. ShipTypeID for Shipping and Handling items. SalesTaxRateID for Tax items.

public Int64 AttributeID {get;}

Property Value

Remarks

See Also

PaymentGenerateGL.QueryResult Class | Aptify.Applications.OrderEntry.Payments Namespace


Balance Property

Aptify 5.0 Software Development Kit (SDK)

PaymentGenerateGL.QueryResult.Balance Property

public Decimal Balance {get;}

See Also

PaymentGenerateGL.QueryResult Class | Aptify.Applications.OrderEntry.Payments Namespace


Discount Property

Aptify 5.0 Software Development Kit (SDK)

PaymentGenerateGL.QueryResult.Discount Property

public Decimal Discount {get;}

See Also

PaymentGenerateGL.QueryResult Class | Aptify.Applications.OrderEntry.Payments Namespace


HistoricalPaymentAmountApplied Property

Aptify 5.0 Software Development Kit (SDK)

PaymentGenerateGL.QueryResult.HistoricalPaymentAmountApplied Property

Amount of an Historical (not the current) Payment applied to this item. Updated by the ApplyHistoricalPayment method

public Decimal HistoricalPaymentAmountApplied {get;}

Property Value

Remarks

See Also

PaymentGenerateGL.QueryResult Class | Aptify.Applications.OrderEntry.Payments Namespace


HistoricalSalesDiscountApplied Property

Aptify 5.0 Software Development Kit (SDK)

PaymentGenerateGL.QueryResult.HistoricalSalesDiscountApplied Property

Amount of the Historical Payment applied to the Sales Discount amount for the item. This property is valid only for Order Lines. Updated by the ApplyHistoricalPayment method

public Decimal HistoricalSalesDiscountApplied {get;}

Property Value

Remarks

See Also

PaymentGenerateGL.QueryResult Class | Aptify.Applications.OrderEntry.Payments Namespace


InclusiveTaxAmount Property

Aptify 5.0 Software Development Kit (SDK)

PaymentGenerateGL.QueryResult.InclusiveTaxAmount Property

public Decimal InclusiveTaxAmount {get;}

See Also

PaymentGenerateGL.QueryResult Class | Aptify.Applications.OrderEntry.Payments Namespace


OrderDetailID Property

Aptify 5.0 Software Development Kit (SDK)

PaymentGenerateGL.QueryResult.OrderDetailID Property

public Int64 OrderDetailID {get;}

See Also

PaymentGenerateGL.QueryResult Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentAmountApplied Property

Aptify 5.0 Software Development Kit (SDK)

PaymentGenerateGL.QueryResult.PaymentAmountApplied Property

Amount of the Payment applied to this item. Updated by the ApplyPayment method

public Decimal PaymentAmountApplied {get;}

Property Value

Remarks

See Also

PaymentGenerateGL.QueryResult Class | Aptify.Applications.OrderEntry.Payments Namespace


Price Property

Aptify 5.0 Software Development Kit (SDK)

PaymentGenerateGL.QueryResult.Price Property

public Decimal Price {get;}

See Also

PaymentGenerateGL.QueryResult Class | Aptify.Applications.OrderEntry.Payments Namespace


Quantity Property

Aptify 5.0 Software Development Kit (SDK)

PaymentGenerateGL.QueryResult.Quantity Property

public Decimal Quantity {get;}

See Also

PaymentGenerateGL.QueryResult Class | Aptify.Applications.OrderEntry.Payments Namespace


SalesDiscountApplied Property

Aptify 5.0 Software Development Kit (SDK)

PaymentGenerateGL.QueryResult.SalesDiscountApplied Property

Amount of the Payment applied to the Sales Discount amount for the item. This property is valid only for Order Lines. Updated by the ApplyPayment method

public Decimal SalesDiscountApplied {get;}

Property Value

Remarks

See Also

PaymentGenerateGL.QueryResult Class | Aptify.Applications.OrderEntry.Payments Namespace


Sequence Property

Aptify 5.0 Software Development Kit (SDK)

PaymentGenerateGL.QueryResult.Sequence Property

public Int32 Sequence {get;}

See Also

PaymentGenerateGL.QueryResult Class | Aptify.Applications.OrderEntry.Payments Namespace


Total Property

Aptify 5.0 Software Development Kit (SDK)

PaymentGenerateGL.QueryResult.Total Property

public Decimal Total {get;}

See Also

PaymentGenerateGL.QueryResult Class | Aptify.Applications.OrderEntry.Payments Namespace


Type Property

Aptify 5.0 Software Development Kit (SDK)

PaymentGenerateGL.QueryResult.Type Property

public PaymentGenerateGL.QueryResultType Type {get;}

See Also

PaymentGenerateGL.QueryResult Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGenerateGL.QueryResult Methods

The methods of the PaymentGenerateGL.QueryResult class are listed below. For a complete list of PaymentGenerateGL.QueryResult class members, see the PaymentGenerateGL.QueryResult Members topic.

Public Instance Methods

ApplyInclusiveTaxAmount |
ApplyPayment |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PaymentGenerateGL.QueryResult Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGenerateGL.QueryResult.ApplyInclusiveTaxAmount Method

public void ApplyInclusiveTaxAmount(
Decimal Amount
);

See Also

PaymentGenerateGL.QueryResult Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGenerateGL.QueryResult.ApplyPayment Method

public bool ApplyPayment(
Decimal Amount
);

See Also

PaymentGenerateGL.QueryResult Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGenerateGL.QueryResultType Enumeration

protected enum PaymentGenerateGL.QueryResultType

Members

Member Name | Description
OrderLine |
Shipping |
Handling |
Tax |

Requirements

Namespace: Aptify.Applications.OrderEntry.Payments

Assembly: PaymentGenerateGL (in PaymentGenerateGL.dll)

See Also

Aptify.Applications.OrderEntry.Payments Namespace


PaymentGLEntriesLayout Class

For a list of all members of this type, see PaymentGLEntriesLayout Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
PaymentSTLayoutBase
PaymentGLEntriesLayout

public class PaymentGLEntriesLayout : PaymentSTLayoutBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry.Payments

Assembly: PaymentGUI (in PaymentGUI.dll)

See Also

PaymentGLEntriesLayout Members | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGLEntriesLayout Members

PaymentGLEntriesLayout overview

Public Instance Constructors

PaymentGLEntriesLayout Constructor Initializes a new instance of the PaymentGLEntriesLayout class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

m_txtCreditAmount
m_txtDebitAmount

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
PaymentGE (inherited from PaymentSTLayoutBase) |
PaymentSTGE (inherited from PaymentSTLayoutBase) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
EnableDisableControl (inherited from PaymentSTLayoutBase) | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControls |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitializeControls |
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from PaymentSTLayoutBase) |
OnFormTemplateLoaded |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

PaymentGLEntriesLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGLEntriesLayout Constructor

Initializes a new instance of the PaymentGLEntriesLayout class.

public PaymentGLEntriesLayout();

See Also

PaymentGLEntriesLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGLEntriesLayout Fields

The fields of the PaymentGLEntriesLayout class are listed below. For a complete list of PaymentGLEntriesLayout class members, see the PaymentGLEntriesLayout Members topic.

Protected Instance Fields

m_txtCreditAmount
m_txtDebitAmount

See Also

PaymentGLEntriesLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGLEntriesLayout.m_txtCreditAmount Field

protected m_txtCreditAmount m_txtCreditAmount;

See Also

PaymentGLEntriesLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGLEntriesLayout.m_txtDebitAmount Field

protected m_txtDebitAmount m_txtDebitAmount;

See Also

PaymentGLEntriesLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGLEntriesLayout Methods

The methods of the PaymentGLEntriesLayout class are listed below. For a complete list of PaymentGLEntriesLayout class members, see the PaymentGLEntriesLayout Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
EnableDisableControl (inherited from PaymentSTLayoutBase) | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControls |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitializeControls |
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from PaymentSTLayoutBase) |
OnFormTemplateLoaded |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

PaymentGLEntriesLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

PaymentGLEntriesLayout.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

PaymentGLEntriesLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGLEntriesLayout.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

PaymentGLEntriesLayout Class | Aptify.Applications.OrderEntry.Payments Namespace | PaymentGLEntriesLayout.Dispose Overload List


PaymentGLEntriesLayout.FindControls Method

protected virtual void FindControls();

See Also

PaymentGLEntriesLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGLEntriesLayout.InitializeControls Method

protected void InitializeControls();

See Also

PaymentGLEntriesLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGLEntriesLayout.OnFormTemplateLoaded Method

protected override void OnFormTemplateLoaded(
FormTemplateLayout.FormTemplateLoadedEventArgs e
);

See Also

PaymentGLEntriesLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentLayout Class

For a list of all members of this type, see PaymentLayout Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
PaymentLayout

public class PaymentLayout : FormTemplateLayout

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry.Payments

Assembly: PaymentGUI (in PaymentGUI.dll)

See Also

PaymentLayout Members | Aptify.Applications.OrderEntry.Payments Namespace


PaymentLayout Members

PaymentLayout overview

Public Instance Constructors

PaymentLayout Constructor Initializes a new instance of the PaymentLayout class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

IsLoading
m_chkIsRefund
m_cmbServChargeAcct
m_lnkOrganizationID
m_txtBatchID
m_txtDepositDate
m_txtEffectiveDate
m_txtPaymentDate
m_txtPaymentStatusInfo
m_txtServiceCharge

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
m_aptGLEntries |
m_aptPaymentInfo |
m_aptPaymentLines |
m_btnInvoiceNum |
m_btnOrderNum |
m_btnOrderSearch |
m_cmbCurrencyType |
m_cmbPaymentLevel |
m_cmbPaymentStatus |
m_lnkCashControlID |
m_lnkCompanyID |
m_lnkEmployeeID |
m_lnkPersonID |
m_stAuthorizations |
MyAction |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
ConfigureControlsForBatched | Method used to configure visibility and enablement of controls when payment is batched.
ConfigureControlsForException | Method used to configure visibility and enablement of controls when payment is an exception.
ConfigureControlsForPending | Method used to configure visibility and enablement of controls when payment is not posted.
ConfigureControlsForPosted | Method used to configure visibility and enablement of controls when payment is posted.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
DisableControls | Overloaded.
Dispose | Overloaded.
EnableAllControls |
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindTopAreaControls |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
HasAutoOrderPaymentLine | This method checks to see if a Payment Line already exists with the OrderID submitted and returns true.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDataControlBeforeParams | Used to handle the Data Control's BeforeParams event. This method parses the Params string to remove fields that are not supported as New Record Parameters. Unsupported Fields: BatchID, CashCtrlBatchID, PaymentStatusID
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded | Contains logic to setup Event handlers for controls on the FormTemplate Layout.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

PaymentLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentLayout Constructor

Initializes a new instance of the PaymentLayout class.

public PaymentLayout();

See Also

PaymentLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentLayout Fields

The fields of the PaymentLayout class are listed below. For a complete list of PaymentLayout class members, see the PaymentLayout Members topic.

Protected Instance Fields

IsLoading
m_chkIsRefund
m_cmbServChargeAcct
m_lnkOrganizationID
m_txtBatchID
m_txtDepositDate
m_txtEffectiveDate
m_txtPaymentDate
m_txtPaymentStatusInfo
m_txtServiceCharge

See Also

PaymentLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentLayout.IsLoading Field

protected IsLoading IsLoading;

See Also

PaymentLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentLayout.m_chkIsRefund Field

protected m_chkIsRefund m_chkIsRefund;

See Also

PaymentLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentLayout.m_cmbServChargeAcct Field

protected m_cmbServChargeAcct m_cmbServChargeAcct;

See Also

PaymentLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentLayout.m_lnkOrganizationID Field

protected m_lnkOrganizationID m_lnkOrganizationID;

See Also

PaymentLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentLayout.m_txtBatchID Field

protected m_txtBatchID m_txtBatchID;

See Also

PaymentLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentLayout.m_txtDepositDate Field

protected m_txtDepositDate m_txtDepositDate;

See Also

PaymentLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentLayout.m_txtEffectiveDate Field

protected m_txtEffectiveDate m_txtEffectiveDate;

See Also

PaymentLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentLayout.m_txtPaymentDate Field

protected m_txtPaymentDate m_txtPaymentDate;

See Also

PaymentLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentLayout.m_txtPaymentStatusInfo Field

protected m_txtPaymentStatusInfo m_txtPaymentStatusInfo;

See Also

PaymentLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentLayout.m_txtServiceCharge Field

protected m_txtServiceCharge m_txtServiceCharge;

See Also

PaymentLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentLayout Properties

The properties of the PaymentLayout class are listed below. For a complete list of PaymentLayout class members, see the PaymentLayout Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
m_aptGLEntries |
m_aptPaymentInfo |
m_aptPaymentLines |
m_btnInvoiceNum |
m_btnOrderNum |
m_btnOrderSearch |
m_cmbCurrencyType |
m_cmbPaymentLevel |
m_cmbPaymentStatus |
m_lnkCashControlID |
m_lnkCompanyID |
m_lnkEmployeeID |
m_lnkPersonID |
m_stAuthorizations |
MyAction |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

PaymentLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


m_aptGLEntries Property

Aptify 5.0 Software Development Kit (SDK)

PaymentLayout.m_aptGLEntries Property

protected virtual GLEntriesControl m_aptGLEntries {get; set;}

See Also

PaymentLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


m_aptPaymentInfo Property

Aptify 5.0 Software Development Kit (SDK)

PaymentLayout.m_aptPaymentInfo Property

protected virtual PaymentInfoControl m_aptPaymentInfo {get; set;}

See Also

PaymentLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


m_aptPaymentLines Property

Aptify 5.0 Software Development Kit (SDK)

PaymentLayout.m_aptPaymentLines Property

protected virtual PaymentLines m_aptPaymentLines {get; set;}

See Also

PaymentLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


m_btnInvoiceNum Property

Aptify 5.0 Software Development Kit (SDK)

PaymentLayout.m_btnInvoiceNum Property

protected virtual ButtonFormComponent m_btnInvoiceNum {get; set;}

See Also

PaymentLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


m_btnOrderNum Property

Aptify 5.0 Software Development Kit (SDK)

PaymentLayout.m_btnOrderNum Property

protected virtual ButtonFormComponent m_btnOrderNum {get; set;}

See Also

PaymentLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


m_btnOrderSearch Property

Aptify 5.0 Software Development Kit (SDK)

PaymentLayout.m_btnOrderSearch Property

protected virtual ButtonFormComponent m_btnOrderSearch {get; set;}

See Also

PaymentLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


m_cmbCurrencyType Property

Aptify 5.0 Software Development Kit (SDK)

PaymentLayout.m_cmbCurrencyType Property

protected virtual AptifyDataComboBox m_cmbCurrencyType {get; set;}

See Also

PaymentLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


m_cmbPaymentLevel Property

Aptify 5.0 Software Development Kit (SDK)

PaymentLayout.m_cmbPaymentLevel Property

protected virtual AptifyDataComboBox m_cmbPaymentLevel {get; set;}

See Also

PaymentLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


m_cmbPaymentStatus Property

Aptify 5.0 Software Development Kit (SDK)

PaymentLayout.m_cmbPaymentStatus Property

protected virtual AptifyDataComboBox m_cmbPaymentStatus {get; set;}

See Also

PaymentLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


m_lnkCashControlID Property

Aptify 5.0 Software Development Kit (SDK)

PaymentLayout.m_lnkCashControlID Property

protected virtual AptifyLinkBox m_lnkCashControlID {get; set;}

See Also

PaymentLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


m_lnkCompanyID Property

Aptify 5.0 Software Development Kit (SDK)

PaymentLayout.m_lnkCompanyID Property

protected virtual AptifyLinkBox m_lnkCompanyID {get; set;}

See Also

PaymentLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


m_lnkEmployeeID Property

Aptify 5.0 Software Development Kit (SDK)

PaymentLayout.m_lnkEmployeeID Property

protected virtual AptifyLinkBox m_lnkEmployeeID {get; set;}

See Also

PaymentLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


m_lnkPersonID Property

Aptify 5.0 Software Development Kit (SDK)

PaymentLayout.m_lnkPersonID Property

protected virtual AptifyLinkBox m_lnkPersonID {get; set;}

See Also

PaymentLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


m_stAuthorizations Property

Aptify 5.0 Software Development Kit (SDK)

PaymentLayout.m_stAuthorizations Property

protected virtual AptifySubType m_stAuthorizations {get; set;}

See Also

PaymentLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


MyAction Property

Aptify 5.0 Software Development Kit (SDK)

PaymentLayout.MyAction Property

protected DataAction MyAction {get;}

See Also

PaymentLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentLayout Methods

The methods of the PaymentLayout class are listed below. For a complete list of PaymentLayout class members, see the PaymentLayout Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
ConfigureControlsForBatched | Method used to configure visibility and enablement of controls when payment is batched.
ConfigureControlsForException | Method used to configure visibility and enablement of controls when payment is an exception.
ConfigureControlsForPending | Method used to configure visibility and enablement of controls when payment is not posted.
ConfigureControlsForPosted | Method used to configure visibility and enablement of controls when payment is posted.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
DisableControls | Overloaded.
Dispose | Overloaded.
EnableAllControls |
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindTopAreaControls |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
HasAutoOrderPaymentLine | This method checks to see if a Payment Line already exists with the OrderID submitted and returns true.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDataControlBeforeParams | Used to handle the Data Control's BeforeParams event. This method parses the Params string to remove fields that are not supported as New Record Parameters. Unsupported Fields: BatchID, CashCtrlBatchID, PaymentStatusID
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded | Contains logic to setup Event handlers for controls on the FormTemplate Layout.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

PaymentLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentLayout.ConfigureControlsForBatched Method

Method used to configure visibility and enablement of controls when payment is batched.

protected void ConfigureControlsForBatched();

Remarks

See Also

PaymentLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentLayout.ConfigureControlsForException Method

Method used to configure visibility and enablement of controls when payment is an exception.

protected void ConfigureControlsForException();

Remarks

See Also

PaymentLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentLayout.ConfigureControlsForPending Method

Method used to configure visibility and enablement of controls when payment is not posted.

protected void ConfigureControlsForPending();

Remarks

See Also

PaymentLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentLayout.ConfigureControlsForPosted Method

Method used to configure visibility and enablement of controls when payment is posted.

protected void ConfigureControlsForPosted();

Remarks

See Also

PaymentLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


DisableControls Method

Aptify 5.0 Software Development Kit (SDK)

PaymentLayout.DisableControls Method

Overload List

protected void DisableControls();

protected void DisableControls(Boolean);

See Also

PaymentLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentLayout.DisableControls Method ()

protected void DisableControls();

See Also

PaymentLayout Class | Aptify.Applications.OrderEntry.Payments Namespace | PaymentLayout.DisableControls Overload List


PaymentLayout.DisableControls Method (Boolean)

protected void DisableControls(
Boolean ExcludeStatusField
);

See Also

PaymentLayout Class | Aptify.Applications.OrderEntry.Payments Namespace | PaymentLayout.DisableControls Overload List


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

PaymentLayout.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

PaymentLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentLayout.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

PaymentLayout Class | Aptify.Applications.OrderEntry.Payments Namespace | PaymentLayout.Dispose Overload List


PaymentLayout.EnableAllControls Method

protected void EnableAllControls();

See Also

PaymentLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentLayout.FindTopAreaControls Method

protected void FindTopAreaControls(
String FormTemplateLayoutName
);

See Also

PaymentLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentLayout.HasAutoOrderPaymentLine Method

This method checks to see if a Payment Line already exists with the OrderID submitted and returns true.

protected virtual bool HasAutoOrderPaymentLine(
Int64 lOrderID
);

Return Value

True if Payment Line with Order ID exists

Remarks

See Also

PaymentLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentLayout.OnDataControlBeforeParams Method

Used to handle the Data Control's BeforeParams event. This method parses the Params string to remove fields that are not supported as New Record Parameters. Unsupported Fields: BatchID, CashCtrlBatchID, PaymentStatusID

protected virtual void OnDataControlBeforeParams(
ref String& Params,
ref Boolean& Cancel
);

Parameters

Params
Cancel

Remarks

See Also

PaymentLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentLayout.OnFormTemplateLoaded Method

Contains logic to setup Event handlers for controls on the FormTemplate Layout.

protected override void OnFormTemplateLoaded(
FormTemplateLayout.FormTemplateLoadedEventArgs e
);

Parameters

e

Remarks

See Also

PaymentLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentLayout.OnRefresh Method

protected override void OnRefresh();

Implements

IFormComponent.

See Also

PaymentLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentLayout.OnTransferDataToObject Method

protected override void OnTransferDataToObject(
ref Boolean& Cancel
);

Implements

IFormComponent.

See Also

PaymentLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentLines Class

For a list of all members of this type, see PaymentLines Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
PaymentLines

public class PaymentLines : FormComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry.Payments

Assembly: PaymentGUI (in PaymentGUI.dll)

See Also

PaymentLines Members | Aptify.Applications.OrderEntry.Payments Namespace


PaymentLines Members

PaymentLines overview

Public Instance Constructors

PaymentLines Constructor Initializes a new instance of the PaymentLines class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BatchIDLabel |
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RecalculateTotal |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateContext (inherited from FormComponent) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormComponent) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormComponent) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormComponent) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecalcTotal | Method used to force the recalculation of data in
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

PaymentLines Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentLines Constructor

Initializes a new instance of the PaymentLines class.

public PaymentLines();

See Also

PaymentLines Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentLines Properties

The properties of the PaymentLines class are listed below. For a complete list of PaymentLines class members, see the PaymentLines Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BatchIDLabel |
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateContext (inherited from FormComponent) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

PaymentLines Class | Aptify.Applications.OrderEntry.Payments Namespace


BatchIDLabel Property

Aptify 5.0 Software Development Kit (SDK)

PaymentLines.BatchIDLabel Property

public String BatchIDLabel {get; set;}

See Also

PaymentLines Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentLines Methods

The methods of the PaymentLines class are listed below. For a complete list of PaymentLines class members, see the PaymentLines Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RecalculateTotal |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormComponent) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormComponent) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormComponent) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecalcTotal | Method used to force the recalculation of data in
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

PaymentLines Class | Aptify.Applications.OrderEntry.Payments Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

PaymentLines.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

PaymentLines Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentLines.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

PaymentLines Class | Aptify.Applications.OrderEntry.Payments Namespace | PaymentLines.Dispose Overload List


PaymentLines.OnFormComponentConfig Method

protected override void OnFormComponentConfig(
AptifyFormTemplateContext FormTemplateContext
);

Implements

IFormComponent.

See Also

PaymentLines Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentLines.RecalcTotal Method

Method used to force the recalculation of data in

protected void RecalcTotal();

Remarks

See Also

PaymentLines Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentLines.RecalculateTotal Method

public void RecalculateTotal();

See Also

PaymentLines Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentLines.Refresh Method

public override void Refresh();

See Also

PaymentLines Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentLinesEntity Class

For a list of all members of this type, see PaymentLinesEntity Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
PaymentLinesClass
PaymentLinesEntity

public class PaymentLinesEntity : PaymentLinesClass

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry.Payments

Assembly: Payments (in Payments.dll)

See Also

PaymentLinesEntity Members | Aptify.Applications.OrderEntry.Payments Namespace


PaymentLinesEntity Members

PaymentLinesEntity overview

Public Instance Constructors

PaymentLinesEntity Constructor Initializes a new instance of the PaymentLinesEntity class.

Public Instance Properties

Amount |
AmountCurrencyType (inherited from PaymentLinesClass) |
AmountCurrencyTypeFormat | Returns the Currency Type's FormatString value. If no matching Currency Type is found, the property returns "Currency", which will use the local system's Regional Currency format.
AmountCurrencyTypeID |
Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
AppliesTo | Overloaded.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
Comments (inherited from PaymentLinesClass) |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
ConversionAdjustmentAmount |
ConversionCurrencySpotRate | Overloaded.
ConversionCurrencySpotRateID | Overloaded.
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
ID (inherited from PaymentLinesClass) |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
IsShipping (inherited from PaymentLinesClass) |
IsTax (inherited from PaymentLinesClass) |
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LineNumber (inherited from PaymentLinesClass) |
OrderDetailID | Overloaded.
OrderID | Overloaded.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentPaymentsEntityObject |
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PaymentAmount |
PaymentID (inherited from PaymentLinesClass) |
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Sequence (inherited from PaymentLinesClass) |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord |
OnPaymentCurrencyTypeIDChanged | Called by the PaymentsEntity's OnCurrencyTypeIDChanged. The default implementation keeps the Amount value constant, sets the ConversionAdjustmentAmount to 0 and calculates the PaymentAmount according to the appropriate Spot Rate.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded. Executes the Generic Entity's Validate method. If the record is valid, additional validation, specific to Payments Lines is executed. Additional Validation: If AppliesTo is Order Line, OrderDetailID is a required field. If AppliesTo is Order Line, OrderDetailID must be specified and it must match an Order Line on the Order specified in the OrderID field.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InitializeInternalVariables | Initializes the protected variables to match the field values of the current PaymentLine.
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterAmountCurrencyTypeIDValueChanged | Called when the AmountCurrencyTypeID field's AfterValueChanged event is caught. Calls PropulateConversionSpotRate method.
OnAfterAmountValueChanged | When the Amount is changed, this method will calculate the PaymentAmount using the ConversionSpotRate and ConversionAdjustmentAmount
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterConversionAdjustmentAmountValueChanged |
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterOrderIDValueChanged | When the OrderID value changed to an existing Order, set the AmountCurencyTypeID to the Orders.CurrencyTypeID.
OnAfterPaymentAmountValueChanged |
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
PopulateConversionSpotRate | When the AmountCurrencyTypeID value is changed and it does not match the Payments.CurrencyTypeID then the ConversionCurrencySpotRateID needs to be set based on the Currency Types and Payments.PaymentDate.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

PaymentLinesEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentLinesEntity Constructor

Initializes a new instance of the PaymentLinesEntity class.

public PaymentLinesEntity();

See Also

PaymentLinesEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentLinesEntity Properties

The properties of the PaymentLinesEntity class are listed below. For a complete list of PaymentLinesEntity class members, see the PaymentLinesEntity Members topic.

Public Instance Properties

Amount |
AmountCurrencyType (inherited from PaymentLinesClass) |
AmountCurrencyTypeFormat | Returns the Currency Type's FormatString value. If no matching Currency Type is found, the property returns "Currency", which will use the local system's Regional Currency format.
AmountCurrencyTypeID |
Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
AppliesTo | Overloaded.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
Comments (inherited from PaymentLinesClass) |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
ConversionAdjustmentAmount |
ConversionCurrencySpotRate | Overloaded.
ConversionCurrencySpotRateID | Overloaded.
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
ID (inherited from PaymentLinesClass) |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
IsShipping (inherited from PaymentLinesClass) |
IsTax (inherited from PaymentLinesClass) |
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LineNumber (inherited from PaymentLinesClass) |
OrderDetailID | Overloaded.
OrderID | Overloaded.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentPaymentsEntityObject |
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PaymentAmount |
PaymentID (inherited from PaymentLinesClass) |
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Sequence (inherited from PaymentLinesClass) |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

PaymentLinesEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


Amount Property

Aptify 5.0 Software Development Kit (SDK)

PaymentLinesEntity.Amount Property

new public Decimal Amount {get; set;}

See Also

PaymentLinesEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


AmountCurrencyTypeFormat Property

Aptify 5.0 Software Development Kit (SDK)

PaymentLinesEntity.AmountCurrencyTypeFormat Property

Returns the Currency Type's FormatString value. If no matching Currency Type is found, the property returns "Currency", which will use the local system's Regional Currency format.

public String AmountCurrencyTypeFormat {get;}

Property Value

Remarks

See Also

PaymentLinesEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


AmountCurrencyTypeID Property

Aptify 5.0 Software Development Kit (SDK)

PaymentLinesEntity.AmountCurrencyTypeID Property

new public Int32 AmountCurrencyTypeID {get; set;}

See Also

PaymentLinesEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


AppliesTo Property

Aptify 5.0 Software Development Kit (SDK)

PaymentLinesEntity.AppliesTo Property

new public PaymentLinesEntity.AppliesToType AppliesTo {get; set;}

See Also

PaymentLinesEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


ConversionAdjustmentAmount Property

Aptify 5.0 Software Development Kit (SDK)

PaymentLinesEntity.ConversionAdjustmentAmount Property

new public Decimal ConversionAdjustmentAmount {get; set;}

See Also

PaymentLinesEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


ConversionCurrencySpotRate Property

Aptify 5.0 Software Development Kit (SDK)

PaymentLinesEntity.ConversionCurrencySpotRate Property

new public Decimal ConversionCurrencySpotRate {get;}

See Also

PaymentLinesEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


ConversionCurrencySpotRateID Property

Aptify 5.0 Software Development Kit (SDK)

PaymentLinesEntity.ConversionCurrencySpotRateID Property

new public Int64 ConversionCurrencySpotRateID {get; set;}

See Also

PaymentLinesEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


OrderDetailID Property

Aptify 5.0 Software Development Kit (SDK)

PaymentLinesEntity.OrderDetailID Property

new public Int64 OrderDetailID {get; set;}

See Also

PaymentLinesEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


OrderID Property

Aptify 5.0 Software Development Kit (SDK)

PaymentLinesEntity.OrderID Property

new public Int64 OrderID {get; set;}

See Also

PaymentLinesEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


ParentPaymentsEntityObject Property

Aptify 5.0 Software Development Kit (SDK)

PaymentLinesEntity.ParentPaymentsEntityObject Property

public PaymentsEntity ParentPaymentsEntityObject {get;}

See Also

PaymentLinesEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentAmount Property

Aptify 5.0 Software Development Kit (SDK)

PaymentLinesEntity.PaymentAmount Property

new public Decimal PaymentAmount {get; set;}

See Also

PaymentLinesEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentLinesEntity Methods

The methods of the PaymentLinesEntity class are listed below. For a complete list of PaymentLinesEntity class members, see the PaymentLinesEntity Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord |
OnPaymentCurrencyTypeIDChanged | Called by the PaymentsEntity's OnCurrencyTypeIDChanged. The default implementation keeps the Amount value constant, sets the ConversionAdjustmentAmount to 0 and calculates the PaymentAmount according to the appropriate Spot Rate.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded. Executes the Generic Entity's Validate method. If the record is valid, additional validation, specific to Payments Lines is executed. Additional Validation: If AppliesTo is Order Line, OrderDetailID is a required field. If AppliesTo is Order Line, OrderDetailID must be specified and it must match an Order Line on the Order specified in the OrderID field.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InitializeInternalVariables | Initializes the protected variables to match the field values of the current PaymentLine.
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterAmountCurrencyTypeIDValueChanged | Called when the AmountCurrencyTypeID field's AfterValueChanged event is caught. Calls PropulateConversionSpotRate method.
OnAfterAmountValueChanged | When the Amount is changed, this method will calculate the PaymentAmount using the ConversionSpotRate and ConversionAdjustmentAmount
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterConversionAdjustmentAmountValueChanged |
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterOrderIDValueChanged | When the OrderID value changed to an existing Order, set the AmountCurencyTypeID to the Orders.CurrencyTypeID.
OnAfterPaymentAmountValueChanged |
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
PopulateConversionSpotRate | When the AmountCurrencyTypeID value is changed and it does not match the Payments.CurrencyTypeID then the ConversionCurrencySpotRateID needs to be set based on the Currency Types and Payments.PaymentDate.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

PaymentLinesEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentLinesEntity.InitializeInternalVariables Method

Initializes the protected variables to match the field values of the current PaymentLine.

protected virtual void InitializeInternalVariables(
Boolean NewRecord
);

Parameters

NewRecord

Remarks

See Also

PaymentLinesEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


Load Method

Aptify 5.0 Software Development Kit (SDK)

PaymentLinesEntity.Load Method

Overload List

public override void Load(DataRow);

public override void Load(IDataReader);

public override void Load(Int64);

public override void Load(String);

public override void Load(String,Boolean);

See Also

PaymentLinesEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentLinesEntity.Load Method (DataRow)

public override void Load(
DataRow DataRow
);

See Also

PaymentLinesEntity Class | Aptify.Applications.OrderEntry.Payments Namespace | PaymentLinesEntity.Load Overload List


PaymentLinesEntity.Load Method (IDataReader)

public override void Load(
IDataReader DataReader
);

See Also

PaymentLinesEntity Class | Aptify.Applications.OrderEntry.Payments Namespace | PaymentLinesEntity.Load Overload List


PaymentLinesEntity.Load Method (Int64)

public override void Load(
Int64 ID
);

See Also

PaymentLinesEntity Class | Aptify.Applications.OrderEntry.Payments Namespace | PaymentLinesEntity.Load Overload List


PaymentLinesEntity.Load Method (String)

public override void Load(
String FileName
);

See Also

PaymentLinesEntity Class | Aptify.Applications.OrderEntry.Payments Namespace | PaymentLinesEntity.Load Overload List


PaymentLinesEntity.Load Method (String, Boolean)

public override void Load(
String FileName,
Boolean MergeSubTypes
);

See Also

PaymentLinesEntity Class | Aptify.Applications.OrderEntry.Payments Namespace | PaymentLinesEntity.Load Overload List


PaymentLinesEntity.NewRecord Method

public override bool NewRecord();

See Also

PaymentLinesEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentLinesEntity.OnAfterAmountCurrencyTypeIDValueChanged Method

Called when the AmountCurrencyTypeID field's AfterValueChanged event is caught. Calls PropulateConversionSpotRate method.

protected virtual void OnAfterAmountCurrencyTypeIDValueChanged(
AptifyDataFieldBase sender,
AfterValueChangedEventArgs e
);

Parameters

sender
e

Remarks

See Also

PaymentLinesEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentLinesEntity.OnAfterAmountValueChanged Method

When the Amount is changed, this method will calculate the PaymentAmount using the ConversionSpotRate and ConversionAdjustmentAmount

protected virtual void OnAfterAmountValueChanged(
AptifyDataFieldBase sender,
AfterValueChangedEventArgs e
);

Parameters

sender
e

Remarks

See Also

PaymentLinesEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentLinesEntity.OnAfterConversionAdjustmentAmountValueChanged Method

protected virtual void OnAfterConversionAdjustmentAmountValueChanged(
AptifyDataFieldBase sender,
AfterValueChangedEventArgs e
);

See Also

PaymentLinesEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentLinesEntity.OnAfterOrderIDValueChanged Method

When the OrderID value changed to an existing Order, set the AmountCurencyTypeID to the Orders.CurrencyTypeID.

protected virtual void OnAfterOrderIDValueChanged(
AptifyDataFieldBase sender,
AfterValueChangedEventArgs e
);

Parameters

sender
e

Remarks

See Also

PaymentLinesEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentLinesEntity.OnAfterPaymentAmountValueChanged Method

protected virtual void OnAfterPaymentAmountValueChanged(
AptifyDataFieldBase sender,
AfterValueChangedEventArgs e
);

See Also

PaymentLinesEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentLinesEntity.OnPaymentCurrencyTypeIDChanged Method

Called by the PaymentsEntity's OnCurrencyTypeIDChanged. The default implementation keeps the Amount value constant, sets the ConversionAdjustmentAmount to 0 and calculates the PaymentAmount according to the appropriate Spot Rate.

public virtual void OnPaymentCurrencyTypeIDChanged();

Remarks

See Also

PaymentLinesEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentLinesEntity.PopulateConversionSpotRate Method

When the AmountCurrencyTypeID value is changed and it does not match the Payments.CurrencyTypeID then the ConversionCurrencySpotRateID needs to be set based on the Currency Types and Payments.PaymentDate.

protected virtual void PopulateConversionSpotRate();

Remarks

See Also

PaymentLinesEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


Validate Method

Aptify 5.0 Software Development Kit (SDK)

PaymentLinesEntity.Validate Method

Executes the Generic Entity's Validate method. If the record is valid, additional validation, specific to Payments Lines is executed. Additional Validation: If AppliesTo is Order Line, OrderDetailID is a required field. If AppliesTo is Order Line, OrderDetailID must be specified and it must match an Order Line on the Order specified in the OrderID field.

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Validate();

Executes the Generic Entity's Validate method. If the record is valid, additional validation, specific to Payments Lines is executed. Additional Validation: If AppliesTo is Order Line, OrderDetailID is a required field. If AppliesTo is Order Line, OrderDetailID must be specified and it must match an Order Line on the Order specified in the OrderID field.

public override bool Validate(ref String&);

See Also

PaymentLinesEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentLinesEntity.Validate Method (String&)

Executes the Generic Entity's Validate method. If the record is valid, additional validation, specific to Payments Lines is executed. Additional Validation: If AppliesTo is Order Line, OrderDetailID is a required field. If AppliesTo is Order Line, OrderDetailID must be specified and it must match an Order Line on the Order specified in the OrderID field.

public override bool Validate(
ref String& ErrorString
);

Parameters

ErrorString

Return Value

Remarks

See Also

PaymentLinesEntity Class | Aptify.Applications.OrderEntry.Payments Namespace | PaymentLinesEntity.Validate Overload List


PaymentLinesEntity.AppliesToType Enumeration

public enum PaymentLinesEntity.AppliesToType

Members

Member Name | Description
EntireOrder |
OrderLine |
Shipping |
Handling |
Tax |
NewOrder |

Requirements

Namespace: Aptify.Applications.OrderEntry.Payments

Assembly: Payments (in Payments.dll)

See Also

Aptify.Applications.OrderEntry.Payments Namespace


PaymentLinesLayout Class

For a list of all members of this type, see PaymentLinesLayout Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
PaymentSTLayoutBase
PaymentLinesLayout

public class PaymentLinesLayout : PaymentSTLayoutBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry.Payments

Assembly: PaymentGUI (in PaymentGUI.dll)

See Also

PaymentLinesLayout Members | Aptify.Applications.OrderEntry.Payments Namespace


PaymentLinesLayout Members

PaymentLinesLayout overview

Public Instance Constructors

PaymentLinesLayout Constructor Initializes a new instance of the PaymentLinesLayout class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

m_bPaymentIsBatched
m_chkConversionAdjustment
m_lnkConversionCurrencySpotRateID

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
m_cmbAppliesTo |
m_cmbOrderLinesID |
m_lnkAmountCurrencyTypeID |
m_lnkOrderID |
m_txtAmount |
m_txtConversionAdjustmentAmount |
m_txtPaymentAmount |
PaymentGE (inherited from PaymentSTLayoutBase) |
PaymentSTGE (inherited from PaymentSTLayoutBase) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
EnableDisableControl (inherited from PaymentSTLayoutBase) | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControls |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitializeControls |
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAppliesToValueChanged |
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from PaymentSTLayoutBase) |
OnFormTemplateLoaded |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetMultiCurrencyFieldsVisibility |
SetOrderLineIDVisibility |
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

PaymentLinesLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentLinesLayout Constructor

Initializes a new instance of the PaymentLinesLayout class.

public PaymentLinesLayout();

See Also

PaymentLinesLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentLinesLayout Fields

The fields of the PaymentLinesLayout class are listed below. For a complete list of PaymentLinesLayout class members, see the PaymentLinesLayout Members topic.

Protected Instance Fields

m_bPaymentIsBatched
m_chkConversionAdjustment
m_lnkConversionCurrencySpotRateID

See Also

PaymentLinesLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentLinesLayout.m_bPaymentIsBatched Field

protected m_bPaymentIsBatched m_bPaymentIsBatched;

See Also

PaymentLinesLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentLinesLayout.m_chkConversionAdjustment Field

protected m_chkConversionAdjustment m_chkConversionAdjustment;

See Also

PaymentLinesLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentLinesLayout.m_lnkConversionCurrencySpotRateID Field

protected m_lnkConversionCurrencySpotRateID m_lnkConversionCurrencySpotRateID;

See Also

PaymentLinesLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentLinesLayout Properties

The properties of the PaymentLinesLayout class are listed below. For a complete list of PaymentLinesLayout class members, see the PaymentLinesLayout Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
m_cmbAppliesTo |
m_cmbOrderLinesID |
m_lnkAmountCurrencyTypeID |
m_lnkOrderID |
m_txtAmount |
m_txtConversionAdjustmentAmount |
m_txtPaymentAmount |
PaymentGE (inherited from PaymentSTLayoutBase) |
PaymentSTGE (inherited from PaymentSTLayoutBase) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

PaymentLinesLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


m_cmbAppliesTo Property

Aptify 5.0 Software Development Kit (SDK)

PaymentLinesLayout.m_cmbAppliesTo Property

protected virtual AptifyComboBox m_cmbAppliesTo {get; set;}

See Also

PaymentLinesLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


m_cmbOrderLinesID Property

Aptify 5.0 Software Development Kit (SDK)

PaymentLinesLayout.m_cmbOrderLinesID Property

protected virtual AptifyDataComboBox m_cmbOrderLinesID {get; set;}

See Also

PaymentLinesLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


m_lnkAmountCurrencyTypeID Property

Aptify 5.0 Software Development Kit (SDK)

PaymentLinesLayout.m_lnkAmountCurrencyTypeID Property

protected virtual AptifyLinkBox m_lnkAmountCurrencyTypeID {get; set;}

See Also

PaymentLinesLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


m_lnkOrderID Property

Aptify 5.0 Software Development Kit (SDK)

PaymentLinesLayout.m_lnkOrderID Property

protected virtual AptifyLinkBox m_lnkOrderID {get; set;}

See Also

PaymentLinesLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


m_txtAmount Property

Aptify 5.0 Software Development Kit (SDK)

PaymentLinesLayout.m_txtAmount Property

protected virtual AptifyTextBox m_txtAmount {get; set;}

See Also

PaymentLinesLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


m_txtConversionAdjustmentAmount Property

Aptify 5.0 Software Development Kit (SDK)

PaymentLinesLayout.m_txtConversionAdjustmentAmount Property

protected virtual AptifyTextBox m_txtConversionAdjustmentAmount {get; set;}

See Also

PaymentLinesLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


m_txtPaymentAmount Property

Aptify 5.0 Software Development Kit (SDK)

PaymentLinesLayout.m_txtPaymentAmount Property

protected virtual AptifyTextBox m_txtPaymentAmount {get; set;}

See Also

PaymentLinesLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentLinesLayout Methods

The methods of the PaymentLinesLayout class are listed below. For a complete list of PaymentLinesLayout class members, see the PaymentLinesLayout Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
EnableDisableControl (inherited from PaymentSTLayoutBase) | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControls |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitializeControls |
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAppliesToValueChanged |
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from PaymentSTLayoutBase) |
OnFormTemplateLoaded |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetMultiCurrencyFieldsVisibility |
SetOrderLineIDVisibility |
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

PaymentLinesLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

PaymentLinesLayout.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

PaymentLinesLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentLinesLayout.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

PaymentLinesLayout Class | Aptify.Applications.OrderEntry.Payments Namespace | PaymentLinesLayout.Dispose Overload List


PaymentLinesLayout.FindControls Method

protected virtual void FindControls();

See Also

PaymentLinesLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentLinesLayout.InitializeControls Method

protected virtual void InitializeControls();

See Also

PaymentLinesLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentLinesLayout.OnAppliesToValueChanged Method

protected void OnAppliesToValueChanged(
Object sender,
Object OldValue,
Object NewValue
);

See Also

PaymentLinesLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentLinesLayout.OnFormTemplateLoaded Method

protected override void OnFormTemplateLoaded(
FormTemplateLayout.FormTemplateLoadedEventArgs e
);

See Also

PaymentLinesLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentLinesLayout.OnTransferDataToObject Method

protected override void OnTransferDataToObject(
ref Boolean& Cancel
);

Implements

IFormComponent.

See Also

PaymentLinesLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentLinesLayout.SetMultiCurrencyFieldsVisibility Method

protected virtual void SetMultiCurrencyFieldsVisibility();

See Also

PaymentLinesLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentLinesLayout.SetOrderLineIDVisibility Method

protected virtual void SetOrderLineIDVisibility(
Boolean bInitialize
);

See Also

PaymentLinesLayout Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity Class

For a list of all members of this type, see PaymentsEntity Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
PaymentsClass
PaymentsEntity

public class PaymentsEntity : PaymentsClass

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.OrderEntry.Payments

Assembly: Payments (in Payments.dll)

See Also

PaymentsEntity Members | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity Members

PaymentsEntity overview

Public Static Methods

GetBasePaymentTypeShared | Function used to return the base payment type for a payment type.
GetCreditMemoTypeID | Function used to return the payment type ID for the Credit Memo payment type.
GetPaymentOriginalOrderIDs | Get the Original Order ID for the cancellation order.
GetPurchaseOrderTypeID | Function used to return the payment type ID for the Purchase Order payment type.
GetRefundVoucherTypeID | Overloaded. Function used to return the payment type ID for the Refund Voucher payment type. This method does not specify the ID of the original Payment Type. When it is not specified, the default Refund Voucher Payment Type will be returned.
IsInflowPayment | Function used to determine if the provided payment type is an inflow payment type or not.
PaymentCaptureStatus | Check whether payment of the order is captured or not.
ValidateCreditMemoOwnershipShared | Function used to validate the source of a credit memo. Credit memos may only be used on subsequent orders where the billing information matches the original credit order.

Public Instance Constructors

PaymentsEntity Constructor Initializes a new instance of the PaymentsEntity class.

Public Instance Properties

ABA (inherited from PaymentsClass) |
AccountName (inherited from PaymentsClass) |
AccountNumber (inherited from PaymentsClass) |
APExportRunID (inherited from PaymentsClass) |
APImportRunID (inherited from PaymentsClass) |
Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
Bank (inherited from PaymentsClass) |
BatchID (inherited from PaymentsClass) |
BranchName (inherited from PaymentsClass) |
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
CALC_Amount (inherited from PaymentsClass) |
CALC_ConversionAdjustmentAmount (inherited from PaymentsClass) |
CashCtrlBatchID (inherited from PaymentsClass) |
CCAccountNumber (inherited from PaymentsClass) |
CCAuthCode (inherited from PaymentsClass) |
CCAuthType (inherited from PaymentsClass) |
CCExpireDate (inherited from PaymentsClass) |
CCPartial (inherited from PaymentsClass) |
CCSecurityNumber | Property that is used to incorporate the Credit Card Security Number into payment saves. This explicit property maps to the GE field "_xCCSecurityNumber".
CheckNumber (inherited from PaymentsClass) |
Comments (inherited from PaymentsClass) |
CompanyID (inherited from PaymentsClass) |
CompanyName (inherited from PaymentsClass) |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CreditOrderID (inherited from PaymentsClass) |
CurrencySpotRateID (inherited from PaymentsClass) |
CurrencyType (inherited from PaymentsClass) |
CurrencyTypeFormat | Returns the Currency Type's FormatString value. If no matching Currency Type is found, the property returns "Currency", which will use the local system's Regional Currency format.
CurrencyTypeID |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DateCreated (inherited from PaymentsClass) |
DateExportedToAP (inherited from PaymentsClass) |
DateImportedFromAP (inherited from PaymentsClass) |
DateUpdated (inherited from PaymentsClass) |
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DepositDate (inherited from PaymentsClass) |
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EffectiveDate (inherited from PaymentsClass) |
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
Employee (inherited from PaymentsClass) |
EmployeeID (inherited from PaymentsClass) |
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
FunctionalCurrencyTypeID | Returns the Functional Currency of the Organization associated with the Payment.
ID (inherited from PaymentsClass) |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
IsPosting |
IsRefund (inherited from PaymentsClass) |
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
MySpotRateObject |
Organization (inherited from PaymentsClass) |
OrganizationID | Overloaded.
PaidBy (inherited from PaymentsClass) |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PaymentAmount (inherited from PaymentsClass) |
PaymentDate (inherited from PaymentsClass) |
PaymentDB |
PaymentInformationID (inherited from PaymentsClass) |
PaymentLevel (inherited from PaymentsClass) |
PaymentLevelID (inherited from PaymentsClass) |
PaymentStatus |
PaymentStatusID (inherited from PaymentsClass) |
PaymentStatusInfo (inherited from PaymentsClass) |
PaymentType (inherited from PaymentsClass) |
PaymentTypeID (inherited from PaymentsClass) |
PersonID (inherited from PaymentsClass) |
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RefundCheckNumber (inherited from PaymentsClass) |
RefundPaidDate (inherited from PaymentsClass) |
RefundPayeeName (inherited from PaymentsClass) |
RefundReason (inherited from PaymentsClass) |
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
ServiceCharge (inherited from PaymentsClass) |
ServiceChargeGLAccount (inherited from PaymentsClass) |
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
Status (inherited from PaymentsClass) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
Type (inherited from PaymentsClass) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.
WhoCreated (inherited from PaymentsClass) |
WhoUpdated (inherited from PaymentsClass) |

Public Instance Methods

BatchPayment | Overloaded.
BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
CheckForQuotationOrders | Method that determines if the orders can be auto converted or not, based on a number of rules: 1) If the field overload "_xConvertQuotesToRegularOrder" = 1 then returns TRUE 2) If the field overload "_xConvertQuotesToRegularOrder" = 0 then returns FALSE 3) If neither 1 nor 2 is TRUE and AllowGUI = FALSE, then returns TRUE 4) If neither 1 nor 2 is TRUE and AllowGUI = TRUE, then raise the Warning event.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone | Overloaded.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
ConfigurePaymentFromOrder | Method used to configure the payment based on an existing order.
CopyPaymentInfoToOrder |
Delete | Overloaded.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
DoCCBDepositDateFlowdown |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetBasePaymentType | Overloaded.
GetBatchInfo | This method returns the formatted Batch Info for display on the Payment Form.
GetCurrentEmployeeID |
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
HoldPayment | Overloaded.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord |
OKToModifyBatchedPayment |
OKToModifyCashBatchedPayment |
PaymentAuthorizations (inherited from PaymentsClass) |
PaymentAuthorizationsObject (inherited from PaymentsClass) |
PaymentContainsCancelledOrders |
PaymentGLEntry (inherited from PaymentsClass) |
PaymentGLEntryObject (inherited from PaymentsClass) |
PaymentLines (inherited from PaymentsClass) |
PaymentLinesObject (inherited from PaymentsClass) |
PostPayment | Overloaded.
RecalcTotal |
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetCustomerData |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue |
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
UserPermissionCheck |
Validate | Overloaded. Validate method is executed prior to save. All payment validation is initiated here. The order of validation is as follows: 1) Verify payment status specifics. 2) Verify the payment is not batched. 3) Check for at least one payment line. 4) Verify that GL entries balance. 5) Verify payment type specifics. 6) Verify refund information. 7) Verify cash control batch information 8) Verify payment and order currency type match.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.
ValidatePaymentType | Method used to process the payment-type validation. Delegates actual validation to type-specific validation methods.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
PaymentStateChange |
ProgressUpdate |
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_bInSave
m_Orders
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

BatchInfo | Property used to provide batch information for a payment.
CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsCaptured | Property that determines if the payment has been captured or not.
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
PaymentOrders |
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AddPaymentLineToCancelCreditBalance |
AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
AuthorizeElectronicPayment |
AutoApplyServiceCharge |
BroadcastChange (inherited from AptifyGenericEntity) |
CheckShouldGenerateGLEntries | Method which is used to determine if GL entries should be generated for this payment.
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
ConvertQuotationOrders | If any of the orders contained in the payment lines are Quotation orders, those Orders will be converted to Regular orders if the temporary field _xConvertQuotesToRegularOrder exists on the Payment and its value is non-zero. If not, the Payment will not save because Quotations may not have an associated Posted Payment.
ConvertSingleQuotationOrder |
CopyPaymentToConvertedOrder |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateNewOrders | Processes the PaymentLines records. For each Payment Line where AppliesTo = New Order, a new Order will be created using the information on the Payment and Payment Line. Order's OrderDate will be set to Payments.PaymentDate Order's ShipToID and BillToID will be set to Payments.PersonID Order's ShipToCompanyID and BillToCompanyID will be set to Payments.CompanyID Order's EmployeeID will be set to Payments.EmployeeID Order's OrganizationID will be set to Payments.OrganizationID Add the Product returned by GetCreditMemoProductID to the Order with a Quantity of 1. Save the Order and Ship the Order.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
CreditMemoAvailableAmount |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateGLEntries | Method that generates GL Entries by delegating to the Generate GL Entries component.
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
GetCreditMemoProductID | Returns the Product ID that will be added to an Order that is created in the CreateNewOrders method.
GetCurrencySpotRate |
GetValidateCreditMemoAttribute |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InitializeCurrencyTypeID | Responsible for ensuring that the CurrencyTypeID DataField has its ValueChanged Event set to fire.
InitializeOrganizationID | Used to set the Payment's OrganizationID for a new Payment. The core implementation uses the Taken By Employee's OrganizationID. Called by NewRecord method and when the EmployeeID's value is changed.
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
InternalValidate |
IsCashBatchApproved | Overloaded.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnCurrencyTypeIDChanged | Called when the CurrencyTypeID's AfterValueChanged event is caught. The default implementation iterates through the PaymentLines SubType record collection calling OnPaymentCurrencyTypeIDChanged.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
PaymentAmountDirty | Method used to determine if the amount of the payment has changed.
PaymentAmountHigher |
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
RemoveGLEntries | Method that removes GL entries by delegating to the Generate GL Entries component.
RemovePaymentLineToUndoCreditBalance |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetOrganizationID | Called by the Save method if the OrganizationID has not been set. If the Payment has a PaymentLine with an OrderID, the Order's OrganizationID will be used to set the OrganzationID. Otherwise, the DefaultOrganzationID defined as an Organizations' Entity Attribute will be used.
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateACHType | Method used to validate ACH type payments.
ValidateCanDelete | Method used to determine if a Payment Record can be deleted.
ValidateCheckType | Method used to validate Check type payments.
ValidateCreditCardType | Method used to validate Credit Card type payments.
ValidateCreditMemoOwnership |
ValidateCreditMemoType | Method used to validate Credit Memo type payments.
ValidatePaymentCashControl | Method used to validate Payment membership in a Cash Control Batch.
ValidatePaymentGLEntries | Method used to validate GL Entries associated with a payment.
ValidatePaymentLines | Method used to validate payment lines.
ValidatePaymentNotBatched |
ValidatePaymentOrders | Method responsible for validating information about the linked orders.
ValidatePaymentStatus | Method used to provide validation of payment statuses. Delegates to status-specific methods.
ValidatePOType | Method used to validate Purchase Order type payments.
ValidateRefund | Method used to validate refunds.
ValidateStatusBatched | Method used to validate if a payment can be moved to a status of Batched.
ValidateStatusException | Method used to validate if a payment can be moved to a status of Exception.
ValidateStatusOnHold | Method used to validate if a payment can be moved to a status of On Hold.
ValidateStatusPending | Method used to validate if a payment can be moved to a status of Pending.
ValidateStatusPosted | Method used to validate if a payment can be moved to a status of Posted.
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity Constructor

Initializes a new instance of the PaymentsEntity class.

public PaymentsEntity();

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity Fields

The fields of the PaymentsEntity class are listed below. For a complete list of PaymentsEntity class members, see the PaymentsEntity Members topic.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_bInSave
m_Orders
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.m_bInSave Field

protected m_bInSave m_bInSave;

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.m_Orders Field

protected m_Orders m_Orders;

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity Properties

The properties of the PaymentsEntity class are listed below. For a complete list of PaymentsEntity class members, see the PaymentsEntity Members topic.

Public Instance Properties

ABA (inherited from PaymentsClass) |
AccountName (inherited from PaymentsClass) |
AccountNumber (inherited from PaymentsClass) |
APExportRunID (inherited from PaymentsClass) |
APImportRunID (inherited from PaymentsClass) |
Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
Bank (inherited from PaymentsClass) |
BatchID (inherited from PaymentsClass) |
BranchName (inherited from PaymentsClass) |
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
CALC_Amount (inherited from PaymentsClass) |
CALC_ConversionAdjustmentAmount (inherited from PaymentsClass) |
CashCtrlBatchID (inherited from PaymentsClass) |
CCAccountNumber (inherited from PaymentsClass) |
CCAuthCode (inherited from PaymentsClass) |
CCAuthType (inherited from PaymentsClass) |
CCExpireDate (inherited from PaymentsClass) |
CCPartial (inherited from PaymentsClass) |
CCSecurityNumber | Property that is used to incorporate the Credit Card Security Number into payment saves. This explicit property maps to the GE field "_xCCSecurityNumber".
CheckNumber (inherited from PaymentsClass) |
Comments (inherited from PaymentsClass) |
CompanyID (inherited from PaymentsClass) |
CompanyName (inherited from PaymentsClass) |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CreditOrderID (inherited from PaymentsClass) |
CurrencySpotRateID (inherited from PaymentsClass) |
CurrencyType (inherited from PaymentsClass) |
CurrencyTypeFormat | Returns the Currency Type's FormatString value. If no matching Currency Type is found, the property returns "Currency", which will use the local system's Regional Currency format.
CurrencyTypeID |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DateCreated (inherited from PaymentsClass) |
DateExportedToAP (inherited from PaymentsClass) |
DateImportedFromAP (inherited from PaymentsClass) |
DateUpdated (inherited from PaymentsClass) |
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DepositDate (inherited from PaymentsClass) |
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EffectiveDate (inherited from PaymentsClass) |
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
Employee (inherited from PaymentsClass) |
EmployeeID (inherited from PaymentsClass) |
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
FunctionalCurrencyTypeID | Returns the Functional Currency of the Organization associated with the Payment.
ID (inherited from PaymentsClass) |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
IsPosting |
IsRefund (inherited from PaymentsClass) |
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
MySpotRateObject |
Organization (inherited from PaymentsClass) |
OrganizationID | Overloaded.
PaidBy (inherited from PaymentsClass) |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PaymentAmount (inherited from PaymentsClass) |
PaymentDate (inherited from PaymentsClass) |
PaymentDB |
PaymentInformationID (inherited from PaymentsClass) |
PaymentLevel (inherited from PaymentsClass) |
PaymentLevelID (inherited from PaymentsClass) |
PaymentStatus |
PaymentStatusID (inherited from PaymentsClass) |
PaymentStatusInfo (inherited from PaymentsClass) |
PaymentType (inherited from PaymentsClass) |
PaymentTypeID (inherited from PaymentsClass) |
PersonID (inherited from PaymentsClass) |
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RefundCheckNumber (inherited from PaymentsClass) |
RefundPaidDate (inherited from PaymentsClass) |
RefundPayeeName (inherited from PaymentsClass) |
RefundReason (inherited from PaymentsClass) |
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
ServiceCharge (inherited from PaymentsClass) |
ServiceChargeGLAccount (inherited from PaymentsClass) |
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
Status (inherited from PaymentsClass) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
Type (inherited from PaymentsClass) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.
WhoCreated (inherited from PaymentsClass) |
WhoUpdated (inherited from PaymentsClass) |

Protected Instance Properties

BatchInfo | Property used to provide batch information for a payment.
CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsCaptured | Property that determines if the payment has been captured or not.
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
PaymentOrders |
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


BatchInfo Property

Aptify 5.0 Software Development Kit (SDK)

PaymentsEntity.BatchInfo Property

Property used to provide batch information for a payment.

protected virtual PaymentsEntity.PaymentBatchInfo BatchInfo {get;}

Remarks

''' Rules: 1) if batchid >0 then lock everything 2) if status = batched and batchid >0 then batched

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


CCSecurityNumber Property

Aptify 5.0 Software Development Kit (SDK)

PaymentsEntity.CCSecurityNumber Property

Property that is used to incorporate the Credit Card Security Number into payment saves. This explicit property maps to the GE field "_xCCSecurityNumber".

new public String CCSecurityNumber {get; set;}

Property Value

Remarks

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


CurrencyTypeFormat Property

Aptify 5.0 Software Development Kit (SDK)

PaymentsEntity.CurrencyTypeFormat Property

Returns the Currency Type's FormatString value. If no matching Currency Type is found, the property returns "Currency", which will use the local system's Regional Currency format.

public String CurrencyTypeFormat {get;}

Property Value

Remarks

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


CurrencyTypeID Property

Aptify 5.0 Software Development Kit (SDK)

PaymentsEntity.CurrencyTypeID Property

new public Int32 CurrencyTypeID {get; set;}

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


FunctionalCurrencyTypeID Property

Aptify 5.0 Software Development Kit (SDK)

PaymentsEntity.FunctionalCurrencyTypeID Property

Returns the Functional Currency of the Organization associated with the Payment.

public Int32 FunctionalCurrencyTypeID {get;}

Property Value

Remarks

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


IsCaptured Property

Aptify 5.0 Software Development Kit (SDK)

PaymentsEntity.IsCaptured Property

Property that determines if the payment has been captured or not.

protected virtual Boolean IsCaptured {get;}

Remarks

RULES: 1) Determines if ccauthcode is populated 2) Determines if the authtype is "CAPTURED" or not.

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


IsPosting Property

Aptify 5.0 Software Development Kit (SDK)

PaymentsEntity.IsPosting Property

public Boolean IsPosting {get;}

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


MySpotRateObject Property

Aptify 5.0 Software Development Kit (SDK)

PaymentsEntity.MySpotRateObject Property

public ISpotRate MySpotRateObject {get;}

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


OrganizationID Property

Aptify 5.0 Software Development Kit (SDK)

PaymentsEntity.OrganizationID Property

new public Int64 OrganizationID {get; set;}

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentDB Property

Aptify 5.0 Software Development Kit (SDK)

PaymentsEntity.PaymentDB Property

public String PaymentDB {get;}

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentOrders Property

Aptify 5.0 Software Development Kit (SDK)

PaymentsEntity.PaymentOrders Property

protected Dictionary<TKey,TValue> PaymentOrders {get;}

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentStatus Property

Aptify 5.0 Software Development Kit (SDK)

PaymentsEntity.PaymentStatus Property

public PaymentsEntity.PaymentStatusType PaymentStatus {get; set;}

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity Methods

The methods of the PaymentsEntity class are listed below. For a complete list of PaymentsEntity class members, see the PaymentsEntity Members topic.

Public Static Methods

GetBasePaymentTypeShared | Function used to return the base payment type for a payment type.
GetCreditMemoTypeID | Function used to return the payment type ID for the Credit Memo payment type.
GetPaymentOriginalOrderIDs | Get the Original Order ID for the cancellation order.
GetPurchaseOrderTypeID | Function used to return the payment type ID for the Purchase Order payment type.
GetRefundVoucherTypeID | Overloaded. Function used to return the payment type ID for the Refund Voucher payment type. This method does not specify the ID of the original Payment Type. When it is not specified, the default Refund Voucher Payment Type will be returned.
IsInflowPayment | Function used to determine if the provided payment type is an inflow payment type or not.
PaymentCaptureStatus | Check whether payment of the order is captured or not.
ValidateCreditMemoOwnershipShared | Function used to validate the source of a credit memo. Credit memos may only be used on subsequent orders where the billing information matches the original credit order.

Public Instance Methods

BatchPayment | Overloaded.
BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
CheckForQuotationOrders | Method that determines if the orders can be auto converted or not, based on a number of rules: 1) If the field overload "_xConvertQuotesToRegularOrder" = 1 then returns TRUE 2) If the field overload "_xConvertQuotesToRegularOrder" = 0 then returns FALSE 3) If neither 1 nor 2 is TRUE and AllowGUI = FALSE, then returns TRUE 4) If neither 1 nor 2 is TRUE and AllowGUI = TRUE, then raise the Warning event.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone | Overloaded.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
ConfigurePaymentFromOrder | Method used to configure the payment based on an existing order.
CopyPaymentInfoToOrder |
Delete | Overloaded.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
DoCCBDepositDateFlowdown |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetBasePaymentType | Overloaded.
GetBatchInfo | This method returns the formatted Batch Info for display on the Payment Form.
GetCurrentEmployeeID |
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
HoldPayment | Overloaded.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord |
OKToModifyBatchedPayment |
OKToModifyCashBatchedPayment |
PaymentAuthorizations (inherited from PaymentsClass) |
PaymentAuthorizationsObject (inherited from PaymentsClass) |
PaymentContainsCancelledOrders |
PaymentGLEntry (inherited from PaymentsClass) |
PaymentGLEntryObject (inherited from PaymentsClass) |
PaymentLines (inherited from PaymentsClass) |
PaymentLinesObject (inherited from PaymentsClass) |
PostPayment | Overloaded.
RecalcTotal |
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetCustomerData |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue |
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
UserPermissionCheck |
Validate | Overloaded. Validate method is executed prior to save. All payment validation is initiated here. The order of validation is as follows: 1) Verify payment status specifics. 2) Verify the payment is not batched. 3) Check for at least one payment line. 4) Verify that GL entries balance. 5) Verify payment type specifics. 6) Verify refund information. 7) Verify cash control batch information 8) Verify payment and order currency type match.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.
ValidatePaymentType | Method used to process the payment-type validation. Delegates actual validation to type-specific validation methods.

Protected Instance Methods

AddPaymentLineToCancelCreditBalance |
AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
AuthorizeElectronicPayment |
AutoApplyServiceCharge |
BroadcastChange (inherited from AptifyGenericEntity) |
CheckShouldGenerateGLEntries | Method which is used to determine if GL entries should be generated for this payment.
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
ConvertQuotationOrders | If any of the orders contained in the payment lines are Quotation orders, those Orders will be converted to Regular orders if the temporary field _xConvertQuotesToRegularOrder exists on the Payment and its value is non-zero. If not, the Payment will not save because Quotations may not have an associated Posted Payment.
ConvertSingleQuotationOrder |
CopyPaymentToConvertedOrder |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateNewOrders | Processes the PaymentLines records. For each Payment Line where AppliesTo = New Order, a new Order will be created using the information on the Payment and Payment Line. Order's OrderDate will be set to Payments.PaymentDate Order's ShipToID and BillToID will be set to Payments.PersonID Order's ShipToCompanyID and BillToCompanyID will be set to Payments.CompanyID Order's EmployeeID will be set to Payments.EmployeeID Order's OrganizationID will be set to Payments.OrganizationID Add the Product returned by GetCreditMemoProductID to the Order with a Quantity of 1. Save the Order and Ship the Order.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
CreditMemoAvailableAmount |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateGLEntries | Method that generates GL Entries by delegating to the Generate GL Entries component.
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
GetCreditMemoProductID | Returns the Product ID that will be added to an Order that is created in the CreateNewOrders method.
GetCurrencySpotRate |
GetValidateCreditMemoAttribute |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InitializeCurrencyTypeID | Responsible for ensuring that the CurrencyTypeID DataField has its ValueChanged Event set to fire.
InitializeOrganizationID | Used to set the Payment's OrganizationID for a new Payment. The core implementation uses the Taken By Employee's OrganizationID. Called by NewRecord method and when the EmployeeID's value is changed.
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
InternalValidate |
IsCashBatchApproved | Overloaded.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnCurrencyTypeIDChanged | Called when the CurrencyTypeID's AfterValueChanged event is caught. The default implementation iterates through the PaymentLines SubType record collection calling OnPaymentCurrencyTypeIDChanged.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
PaymentAmountDirty | Method used to determine if the amount of the payment has changed.
PaymentAmountHigher |
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
RemoveGLEntries | Method that removes GL entries by delegating to the Generate GL Entries component.
RemovePaymentLineToUndoCreditBalance |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetOrganizationID | Called by the Save method if the OrganizationID has not been set. If the Payment has a PaymentLine with an OrderID, the Order's OrganizationID will be used to set the OrganzationID. Otherwise, the DefaultOrganzationID defined as an Organizations' Entity Attribute will be used.
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateACHType | Method used to validate ACH type payments.
ValidateCanDelete | Method used to determine if a Payment Record can be deleted.
ValidateCheckType | Method used to validate Check type payments.
ValidateCreditCardType | Method used to validate Credit Card type payments.
ValidateCreditMemoOwnership |
ValidateCreditMemoType | Method used to validate Credit Memo type payments.
ValidatePaymentCashControl | Method used to validate Payment membership in a Cash Control Batch.
ValidatePaymentGLEntries | Method used to validate GL Entries associated with a payment.
ValidatePaymentLines | Method used to validate payment lines.
ValidatePaymentNotBatched |
ValidatePaymentOrders | Method responsible for validating information about the linked orders.
ValidatePaymentStatus | Method used to provide validation of payment statuses. Delegates to status-specific methods.
ValidatePOType | Method used to validate Purchase Order type payments.
ValidateRefund | Method used to validate refunds.
ValidateStatusBatched | Method used to validate if a payment can be moved to a status of Batched.
ValidateStatusException | Method used to validate if a payment can be moved to a status of Exception.
ValidateStatusOnHold | Method used to validate if a payment can be moved to a status of On Hold.
ValidateStatusPending | Method used to validate if a payment can be moved to a status of Pending.
ValidateStatusPosted | Method used to validate if a payment can be moved to a status of Posted.
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.AddPaymentLineToCancelCreditBalance Method

protected virtual bool AddPaymentLineToCancelCreditBalance(
ref String& sError
);

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.AuthorizeElectronicPayment Method

protected virtual bool AuthorizeElectronicPayment(
Boolean bPaymentAmountDirty,
Int64 lOriginalID,
Boolean bShowErrors,
ref String& sCCErrorString,
ref String& ErrorString
);

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.AutoApplyServiceCharge Method

protected virtual bool AutoApplyServiceCharge();

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


BatchPayment Method

Aptify 5.0 Software Development Kit (SDK)

PaymentsEntity.BatchPayment Method

Overload List

public virtual bool BatchPayment(Int64,ref String&);

public virtual bool BatchPayment(Int64,ref String&,Boolean);

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.BatchPayment Method (Int64, String&)

public virtual bool BatchPayment(
Int64 lBatchID,
ref String& sError
);

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace | PaymentsEntity.BatchPayment Overload List


PaymentsEntity.BatchPayment Method (Int64, String&, Boolean)

public virtual bool BatchPayment(
Int64 lBatchID,
ref String& sError,
Boolean AllowGUI
);

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace | PaymentsEntity.BatchPayment Overload List


PaymentsEntity.CheckForQuotationOrders Method

Method that determines if the orders can be auto converted or not, based on a number of rules: 1) If the field overload "_xConvertQuotesToRegularOrder" = 1 then returns TRUE 2) If the field overload "_xConvertQuotesToRegularOrder" = 0 then returns FALSE 3) If neither 1 nor 2 is TRUE and AllowGUI = FALSE, then returns TRUE 4) If neither 1 nor 2 is TRUE and AllowGUI = TRUE, then raise the Warning event.

public virtual bool CheckForQuotationOrders(
ref String& ErrorString
);

Return Value

Remarks

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.CheckShouldGenerateGLEntries Method

Method which is used to determine if GL entries should be generated for this payment.

protected virtual bool CheckShouldGenerateGLEntries();

Return Value

Remarks

Rules: 1) Payment must be posted for GL entries to be created.

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


Clone Method

Aptify 5.0 Software Development Kit (SDK)

PaymentsEntity.Clone Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual void Clone(AptifyGenericEntityBase);

public override void Clone(AptifyGenericEntityBase,Boolean);

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.Clone Method (AptifyGenericEntityBase, Boolean)

public override void Clone(
AptifyGenericEntityBase ObjectToClone,
Boolean Merge
);

Parameters

ObjectToClone
Merge

Remarks

RULES: 1) reset BatchID = -1 2) reset CashControlBatchID ONLY IF the cash control batch is previously approved.

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace | PaymentsEntity.Clone Overload List


PaymentsEntity.ConfigurePaymentFromOrder Method

Method used to configure the payment based on an existing order.

public void ConfigurePaymentFromOrder(
Boolean AllowGUI,
Int64 lOrderID,
String sInvoiceNum
);

Parameters

AllowGUI
Specifies if the order
lOrderID
sInvoiceNum

Remarks

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.ConvertQuotationOrders Method

If any of the orders contained in the payment lines are Quotation orders, those Orders will be converted to Regular orders if the temporary field _xConvertQuotesToRegularOrder exists on the Payment and its value is non-zero. If not, the Payment will not save because Quotations may not have an associated Posted Payment.

protected virtual bool ConvertQuotationOrders(
ref String& ErrorString
);

Parameters

ErrorString

Return Value

Remarks

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.ConvertSingleQuotationOrder Method

protected virtual bool ConvertSingleQuotationOrder(
Int64 OrderID,
ref String& ErrorString
);

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.CopyPaymentInfoToOrder Method

public virtual bool CopyPaymentInfoToOrder(
ref AptifyGenericEntityBase& OrderObject
);

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.CopyPaymentToConvertedOrder Method

protected virtual bool CopyPaymentToConvertedOrder(
AptifyGenericEntityBase OrderObject
);

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.CreateNewOrders Method

Processes the PaymentLines records. For each Payment Line where AppliesTo = New Order, a new Order will be created using the information on the Payment and Payment Line. Order's OrderDate will be set to Payments.PaymentDate Order's ShipToID and BillToID will be set to Payments.PersonID Order's ShipToCompanyID and BillToCompanyID will be set to Payments.CompanyID Order's EmployeeID will be set to Payments.EmployeeID Order's OrganizationID will be set to Payments.OrganizationID Add the Product returned by GetCreditMemoProductID to the Order with a Quantity of 1. Save the Order and Ship the Order.

protected virtual bool CreateNewOrders(
ref String& ErrorString,
String TransactionID
);

Parameters

ErrorString
TransactionID

Return Value

Remarks

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.CreditMemoAvailableAmount Method

protected virtual decimal CreditMemoAvailableAmount(
Int64 CreditMemoID,
ref String& sError
);

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


Delete Method

Aptify 5.0 Software Development Kit (SDK)

PaymentsEntity.Delete Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Delete();

public override bool Delete(String);

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.Delete Method (String)

public override bool Delete(
String TransactionID
);

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace | PaymentsEntity.Delete Overload List


PaymentsEntity.DoCCBDepositDateFlowdown Method

public bool DoCCBDepositDateFlowdown(
Int64 lCashControlBatchID
);

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.GenerateGLEntries Method

Method that generates GL Entries by delegating to the Generate GL Entries component.

protected virtual bool GenerateGLEntries(
Boolean AllowGUI
);

Parameters

AllowGUI

Return Value

Remarks

Determines if the correct payment state has been achieved and then delegates to the Generate GL entries plugin component.

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


GetBasePaymentType Method

Aptify 5.0 Software Development Kit (SDK)

PaymentsEntity.GetBasePaymentType Method

Overload List

public virtual BasePaymentTypes GetBasePaymentType();

public virtual BasePaymentTypes GetBasePaymentType(Int64);

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.GetBasePaymentType Method ()

public virtual BasePaymentTypes GetBasePaymentType();

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace | PaymentsEntity.GetBasePaymentType Overload List


PaymentsEntity.GetBasePaymentType Method (Int64)

public virtual BasePaymentTypes GetBasePaymentType(
Int64 TypeID
);

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace | PaymentsEntity.GetBasePaymentType Overload List


PaymentsEntity.GetBasePaymentTypeShared Method

Function used to return the base payment type for a payment type.

public static BasePaymentTypes GetBasePaymentTypeShared(
AptifyApplication Application,
Int64 PaymentTypeID
);

Parameters

Application
Application object reference for current AptifyApplication
PaymentTypeID
ID of the Payment Type.

Return Value

Member of BasePaymentTypes enumeration.

Remarks

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.GetBatchInfo Method

This method returns the formatted Batch Info for display on the Payment Form.

public virtual string GetBatchInfo();

Remarks

Currently, the info is displayed as "Batch ID: [ID#] ([Effective Date])"

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.GetCreditMemoProductID Method

Returns the Product ID that will be added to an Order that is created in the CreateNewOrders method.

protected virtual long GetCreditMemoProductID(
OrdersEntity OrderObject
);

Parameters

OrderObject

Return Value

Remarks

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.GetCreditMemoTypeID Method

Function used to return the payment type ID for the Credit Memo payment type.

public static long GetCreditMemoTypeID(
AptifyApplication Application
);

Parameters

Application

Return Value

Remarks

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.GetCurrencySpotRate Method

protected virtual bool GetCurrencySpotRate(
ref String& sError
);

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.GetCurrentEmployeeID Method

public virtual long GetCurrentEmployeeID(
Boolean SetValueInObject
);

Return Value

Remarks

This method used to use the order object to retrieve the employee id...seems like overkill and not very lightweight.

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.GetPaymentOriginalOrderIDs Method

Get the Original Order ID for the cancellation order.

public static List<T> GetPaymentOriginalOrderIDs(
ref AptifyGenericEntityBase& OPaymentGE,
AptifyApplication Application
);

Parameters

OPaymentGE
Application

Return Value

Remarks

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.GetPurchaseOrderTypeID Method

Function used to return the payment type ID for the Purchase Order payment type.

public static long GetPurchaseOrderTypeID(
AptifyApplication Application
);

Parameters

Application

Return Value

Remarks

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


GetRefundVoucherTypeID Method

Aptify 5.0 Software Development Kit (SDK)

PaymentsEntity.GetRefundVoucherTypeID Method

Function used to return the payment type ID for the Refund Voucher payment type. This method does not specify the ID of the original Payment Type. When it is not specified, the default Refund Voucher Payment Type will be returned.

Overload List

Function used to return the payment type ID for the Refund Voucher payment type. This method does not specify the ID of the original Payment Type. When it is not specified, the default Refund Voucher Payment Type will be returned.

public static long GetRefundVoucherTypeID(AptifyApplication);

Function used to return the payment type ID for the Refund Voucher payment type that maps to the Original Payment Type. If the OriginalPaymentTypeID is less than or equal to 0, the default Refund Voucher Payment Type ID will be returned. The Default Refund Voucher Payment Type ID is returned from the stored procedure, spGetRefundVoucherTypeID. If the OriginalPaymentTypeID is greater than 0, the method will return the value in the Payment Type's RefundVoucherPaymentTypeID field, if it is specified. If the Original Payment Type does not specify a Refund Voucher Payment Type, the OriginalPaymentTypeID will be returned.

public static long GetRefundVoucherTypeID(AptifyApplication,Int64);

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.GetRefundVoucherTypeID Method (AptifyApplication)

Function used to return the payment type ID for the Refund Voucher payment type. This method does not specify the ID of the original Payment Type. When it is not specified, the default Refund Voucher Payment Type will be returned.

public static long GetRefundVoucherTypeID(
AptifyApplication Application
);

Parameters

Application

Return Value

Remarks

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace | PaymentsEntity.GetRefundVoucherTypeID Overload List


PaymentsEntity.GetRefundVoucherTypeID Method (AptifyApplication, Int64)

Function used to return the payment type ID for the Refund Voucher payment type that maps to the Original Payment Type. If the OriginalPaymentTypeID is less than or equal to 0, the default Refund Voucher Payment Type ID will be returned. The Default Refund Voucher Payment Type ID is returned from the stored procedure, spGetRefundVoucherTypeID. If the OriginalPaymentTypeID is greater than 0, the method will return the value in the Payment Type's RefundVoucherPaymentTypeID field, if it is specified. If the Original Payment Type does not specify a Refund Voucher Payment Type, the OriginalPaymentTypeID will be returned.

public static long GetRefundVoucherTypeID(
AptifyApplication Application,
Int64 OriginalPaymentTypeID
);

Parameters

Application
OriginalPaymentTypeID

Return Value

Remarks

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace | PaymentsEntity.GetRefundVoucherTypeID Overload List


PaymentsEntity.GetValidateCreditMemoAttribute Method

protected bool GetValidateCreditMemoAttribute();

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


HoldPayment Method

Aptify 5.0 Software Development Kit (SDK)

PaymentsEntity.HoldPayment Method

Overload List

public virtual bool HoldPayment(ref String&);

public virtual bool HoldPayment(ref String&,Boolean);

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.HoldPayment Method (String&)

public virtual bool HoldPayment(
ref String& sError
);

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace | PaymentsEntity.HoldPayment Overload List


PaymentsEntity.HoldPayment Method (String&, Boolean)

public virtual bool HoldPayment(
ref String& sError,
Boolean AllowGUI
);

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace | PaymentsEntity.HoldPayment Overload List


PaymentsEntity.InitializeCurrencyTypeID Method

Responsible for ensuring that the CurrencyTypeID DataField has its ValueChanged Event set to fire.

protected virtual void InitializeCurrencyTypeID();

Remarks

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.InitializeOrganizationID Method

Used to set the Payment's OrganizationID for a new Payment. The core implementation uses the Taken By Employee's OrganizationID. Called by NewRecord method and when the EmployeeID's value is changed.

protected virtual void InitializeOrganizationID();

Remarks

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.InternalValidate Method

protected virtual bool InternalValidate(
ref String& sError,
Boolean bPreSave
);

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


IsCashBatchApproved Method

Aptify 5.0 Software Development Kit (SDK)

PaymentsEntity.IsCashBatchApproved Method

Overload List

protected virtual bool IsCashBatchApproved();

protected virtual bool IsCashBatchApproved(Int64);

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.IsCashBatchApproved Method ()

protected virtual bool IsCashBatchApproved();

Return Value

Remarks

Use this overload when you are verifying the the status of the current cash control batch.

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace | PaymentsEntity.IsCashBatchApproved Overload List


PaymentsEntity.IsCashBatchApproved Method (Int64)

protected virtual bool IsCashBatchApproved(
Int64 lCashControlBatchID
);

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace | PaymentsEntity.IsCashBatchApproved Overload List


PaymentsEntity.IsInflowPayment Method

Function used to determine if the provided payment type is an inflow payment type or not.

public static bool IsInflowPayment(
AptifyApplication Application,
Int64 PaymentTypeID
);

Parameters

Application
PaymentTypeID

Return Value

Remarks

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.NewRecord Method

public override bool NewRecord();

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.OKToModifyBatchedPayment Method

public virtual bool OKToModifyBatchedPayment();

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.OKToModifyCashBatchedPayment Method

public virtual bool OKToModifyCashBatchedPayment();

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.OnCurrencyTypeIDChanged Method

Called when the CurrencyTypeID's AfterValueChanged event is caught. The default implementation iterates through the PaymentLines SubType record collection calling OnPaymentCurrencyTypeIDChanged.

protected virtual void OnCurrencyTypeIDChanged(
AptifyDataFieldBase sender,
AfterValueChangedEventArgs e
);

Parameters

sender
e

Remarks

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.PaymentAmountDirty Method

Method used to determine if the amount of the payment has changed.

protected virtual bool PaymentAmountDirty();

Return Value

Remarks

Rules: 1) True if new record 2) True if any amount on any payment line has changed

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.PaymentAmountHigher Method

protected virtual bool PaymentAmountHigher();

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.PaymentCaptureStatus Method

Check whether payment of the order is captured or not.

public static bool PaymentCaptureStatus(
AptifyApplication Application,
Int64 OriginalOrderID,
ref AptifyGenericEntityBase& PaymentGE,
ref String& sError
);

Parameters

Application
OriginalOrderID
PaymentGE
sError

Return Value

Remarks

To solve issue# 4558, Maulik Patel, 10/15/2008

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.PaymentContainsCancelledOrders Method

public virtual bool PaymentContainsCancelledOrders();

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PostPayment Method

Aptify 5.0 Software Development Kit (SDK)

PaymentsEntity.PostPayment Method

Overload List

public virtual bool PostPayment(ref String&);

public virtual bool PostPayment(ref String&,Boolean);

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.PostPayment Method (String&)

public virtual bool PostPayment(
ref String& sError
);

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace | PaymentsEntity.PostPayment Overload List


PaymentsEntity.PostPayment Method (String&, Boolean)

public virtual bool PostPayment(
ref String& sError,
Boolean AllowGUI
);

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace | PaymentsEntity.PostPayment Overload List


PaymentsEntity.RecalcTotal Method

public virtual decimal RecalcTotal();

Return Value

Remarks

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.RemoveGLEntries Method

Method that removes GL entries by delegating to the Generate GL Entries component.

protected virtual bool RemoveGLEntries(
Boolean AllowGUI
);

Parameters

AllowGUI

Return Value

Remarks

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.RemovePaymentLineToUndoCreditBalance Method

protected virtual bool RemovePaymentLineToUndoCreditBalance(
ref String& sError
);

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


Save Method

Aptify 5.0 Software Development Kit (SDK)

PaymentsEntity.Save Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Save();

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean);

public virtual bool Save(Boolean,Boolean,Boolean,ref String&,String);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean,ref String&);

public override bool Save(Boolean,ref String&,String);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(ref String&);

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.Save Method (Boolean, Boolean, Boolean, String&, String)

public virtual bool Save(
Boolean AllowGUI,
Boolean CheckOrderType,
Boolean ForceValidate,
ref String& ErrorString,
String TransactionID
);

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace | PaymentsEntity.Save Overload List


PaymentsEntity.Save Method (Boolean, String&, String)

public override bool Save(
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace | PaymentsEntity.Save Overload List


PaymentsEntity.SetCustomerData Method

public void SetCustomerData(
Int64 PersonID,
Int64 CompanyID
);

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.SetOrganizationID Method

Called by the Save method if the OrganizationID has not been set. If the Payment has a PaymentLine with an OrderID, the Order's OrganizationID will be used to set the OrganzationID. Otherwise, the DefaultOrganzationID defined as an Organizations' Entity Attribute will be used.

protected virtual void SetOrganizationID();

Remarks

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.SetValue Method

public override void SetValue(
String FieldName,
Object Value
);

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.UserPermissionCheck Method

public bool UserPermissionCheck();

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


Validate Method

Aptify 5.0 Software Development Kit (SDK)

PaymentsEntity.Validate Method

Validate method is executed prior to save. All payment validation is initiated here. The order of validation is as follows: 1) Verify payment status specifics. 2) Verify the payment is not batched. 3) Check for at least one payment line. 4) Verify that GL entries balance. 5) Verify payment type specifics. 6) Verify refund information. 7) Verify cash control batch information 8) Verify payment and order currency type match.

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Validate();

Validate method is executed prior to save. All payment validation is initiated here. The order of validation is as follows: 1) Verify payment status specifics. 2) Verify the payment is not batched. 3) Check for at least one payment line. 4) Verify that GL entries balance. 5) Verify payment type specifics. 6) Verify refund information. 7) Verify cash control batch information 8) Verify payment and order currency type match.

public override bool Validate(ref String&);

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.Validate Method (String&)

Validate method is executed prior to save. All payment validation is initiated here. The order of validation is as follows: 1) Verify payment status specifics. 2) Verify the payment is not batched. 3) Check for at least one payment line. 4) Verify that GL entries balance. 5) Verify payment type specifics. 6) Verify refund information. 7) Verify cash control batch information 8) Verify payment and order currency type match.

public override bool Validate(
ref String& ErrorString
);

Parameters

ErrorString
Output parameter used to return validation error messages.

Return Value

Remarks

This method completes only the validation up to the point of initial failure. It then returns the appropriate error message.

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace | PaymentsEntity.Validate Overload List


PaymentsEntity.ValidateACHType Method

Method used to validate ACH type payments.

protected virtual bool ValidateACHType(
ref String& sError
);

Parameters

sError
Output parameter used to return validation error messages.

Return Value

Remarks

Rules: 1) AccountName is required. 2) AccountNumber is required. 3) Bank is required. 4) CheckNumber is required.

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.ValidateCanDelete Method

Method used to determine if a Payment Record can be deleted.

protected virtual bool ValidateCanDelete(
ref String& sError
);

Parameters

sError
Output parameter used to return validation error messages.

Return Value

Returns TRUE if the payment can be deleted and FALSE if not.

Remarks

Rules: 1) Can't delete if part of an approved cash batch 2) Can't delete if it's batched 3) Can't delete if it's captured

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.ValidateCheckType Method

Method used to validate Check type payments.

protected virtual bool ValidateCheckType(
ref String& sError
);

Parameters

sError
Output parameter used to return validation error messages.

Return Value

Remarks

Requires: CheckNumber

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.ValidateCreditCardType Method

Method used to validate Credit Card type payments.

protected virtual bool ValidateCreditCardType(
ref String& sError
);

Parameters

sError
Output parameter used to return validation error messages.

Return Value

Remarks

Required: CCAccountNumber CCExpireDate

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.ValidateCreditMemoOwnership Method

protected virtual bool ValidateCreditMemoOwnership(
ref String& sError
);

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.ValidateCreditMemoOwnershipShared Method

Function used to validate the source of a credit memo. Credit memos may only be used on subsequent orders where the billing information matches the original credit order.

public static bool ValidateCreditMemoOwnershipShared(
AptifyApplication Application,
Int64 lCreditOrderID,
Int64 lPersonID,
Int64 lCompanyID
);

Parameters

Application
lCreditOrderID
lPersonID
lCompanyID

Return Value

Remarks

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.ValidateCreditMemoType Method

Method used to validate Credit Memo type payments.

protected virtual bool ValidateCreditMemoType(
ref String& sError
);

Parameters

sError
Output parameter used to return validation error messages.

Return Value

Remarks

Rules: 1) Total net amount of the order must be zero 2) Ownership of the credit memo must be the same customer 3) Credit Order ID must be included 4) Credit Memo Cannot Pay for an order with itself

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.ValidatePaymentCashControl Method

Method used to validate Payment membership in a Cash Control Batch.

protected virtual bool ValidatePaymentCashControl(
ref String& sError
);

Parameters

sError

Return Value

Remarks

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.ValidatePaymentGLEntries Method

Method used to validate GL Entries associated with a payment.

protected virtual bool ValidatePaymentGLEntries(
ref String& sError
);

Parameters

sError
Output parameter used to return validation error messages.

Return Value

Remarks

Rules: 1) Credit Totals = Debit Totals

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.ValidatePaymentLines Method

Method used to validate payment lines.

protected virtual bool ValidatePaymentLines(
ref String& sError
);

Parameters

sError
Output parameter used to return validation error messages.

Return Value

Remarks

Rules: 1) Payment must include at least one payment line. 2) Payment must include lines with non-zero amounts.

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.ValidatePaymentNotBatched Method

protected virtual bool ValidatePaymentNotBatched(
ref String& sError
);

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.ValidatePaymentOrders Method

Method responsible for validating information about the linked orders.

protected virtual bool ValidatePaymentOrders(
ref String& sError
);

Parameters

sError

Return Value

Remarks

Rules: 1) Validates correct order types and matching order currency types.

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.ValidatePaymentStatus Method

Method used to provide validation of payment statuses. Delegates to status-specific methods.

protected virtual bool ValidatePaymentStatus(
ref String& sError
);

Parameters

sError
Output parameter used to return validation error messages.

Return Value

Remarks

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.ValidatePaymentType Method

Method used to process the payment-type validation. Delegates actual validation to type-specific validation methods.

public virtual bool ValidatePaymentType(
ref String& sError
);

Parameters

sError
Output parameter used to return validation error messages.

Return Value

Remarks

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.ValidatePOType Method

Method used to validate Purchase Order type payments.

protected virtual bool ValidatePOType(
ref String& sError
);

Parameters

sError

Return Value

Remarks

Rules: 1) PONumber field can't be blank.

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.ValidateRefund Method

Method used to validate refunds.

protected virtual bool ValidateRefund(
ref String& sError
);

Parameters

sError

Return Value

Remarks

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.ValidateStatusBatched Method

Method used to validate if a payment can be moved to a status of Batched.

protected virtual bool ValidateStatusBatched(
PaymentsEntity.PaymentStatusType OldStatus,
ref String& sError
);

Parameters

OldStatus
sError
Output parameter used to return validation error messages.

Return Value

Remarks

Rules: 1) Only can be batched if not already batched 2) Only can be batched if currently posted. Other previous statusus are not valid. 3) BatchID must be provided for payments to be batched.

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.ValidateStatusException Method

Method used to validate if a payment can be moved to a status of Exception.

protected virtual bool ValidateStatusException(
PaymentsEntity.PaymentStatusType OldStatus,
ref String& sError
);

Parameters

OldStatus
sError
Output parameter used to return validation error messages.

Return Value

Remarks

Rules: 1) Only pending and on hold payment statuses can be changed to exception.

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.ValidateStatusOnHold Method

Method used to validate if a payment can be moved to a status of On Hold.

protected virtual bool ValidateStatusOnHold(
PaymentsEntity.PaymentStatusType OldStatus,
ref String& sError
);

Parameters

OldStatus
sError
Output parameter used to return validation error messages.

Return Value

Remarks

Rules: 1) Only pending and exception payment statuses can be changed to on hold.

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.ValidateStatusPending Method

Method used to validate if a payment can be moved to a status of Pending.

protected virtual bool ValidateStatusPending(
PaymentsEntity.PaymentStatusType OldStatus,
ref String& sError
);

Parameters

OldStatus
sError
Output parameter used to return validation error messages.

Return Value

Remarks

Rules: 1) Only new payments can have a status of pending. The status cannot be changed to pending from another status, if the payment has previously been saved.

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.ValidateStatusPosted Method

Method used to validate if a payment can be moved to a status of Posted.

protected virtual bool ValidateStatusPosted(
PaymentsEntity.PaymentStatusType OldStatus,
ref String& sError
);

Parameters

OldStatus
sError
Output parameter used to return validation error messages.

Return Value

Remarks

Rules: 1) Only Pending, OnHold or Exception payments can be posted.

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity Events

The events of the PaymentsEntity class are listed below. For a complete list of PaymentsEntity class members, see the PaymentsEntity Members topic.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
PaymentStateChange |
ProgressUpdate |
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.PaymentsEntity.PaymentStateChangeEventHandler Event

public event PaymentsEntity.PaymentStateChangeEventHandler PaymentStateChange;

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.PaymentsEntity.ProgressUpdateEventHandler Event

public event PaymentsEntity.ProgressUpdateEventHandler ProgressUpdate;

See Also

PaymentsEntity Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.BasePaymentTypes Enumeration

public enum PaymentsEntity.BasePaymentTypes

Members

Member Name | Description
CreditMemo |
Check |
CreditCard |
ACH |
PurchaseOrder |
RefundVoucher |
Cash |
Unknown |

Requirements

Namespace: Aptify.Applications.OrderEntry.Payments

Assembly: Payments (in Payments.dll)

See Also

Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.PaymentAppliesToType Enumeration

public enum PaymentsEntity.PaymentAppliesToType

Members

Member Name | Description
EntireOrder |
OrderLine |
Tax |
Shipping |
Handling |

Requirements

Namespace: Aptify.Applications.OrderEntry.Payments

Assembly: Payments (in Payments.dll)

See Also

Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.PaymentBatchInfo Class

For a list of all members of this type, see PaymentsEntity.PaymentBatchInfo Members.

System.Object
PaymentsEntity.PaymentBatchInfo

public class PaymentsEntity.PaymentBatchInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry.Payments

Assembly: Payments (in Payments.dll)

See Also

PaymentsEntity.PaymentBatchInfo Members | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.PaymentBatchInfo Members

PaymentsEntity.PaymentBatchInfo overview

Public Instance Constructors

PaymentsEntity.PaymentBatchInfo Constructor

Public Instance Properties

BatchID
IsBatched

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PaymentsEntity.PaymentBatchInfo Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.PaymentBatchInfo Constructor

public PaymentsEntity.PaymentBatchInfo(
Int64 BatchID
);

See Also

PaymentsEntity.PaymentBatchInfo Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.PaymentBatchInfo Properties

The properties of the PaymentsEntity.PaymentBatchInfo class are listed below. For a complete list of PaymentsEntity.PaymentBatchInfo class members, see the PaymentsEntity.PaymentBatchInfo Members topic.

Public Instance Properties

BatchID
IsBatched

See Also

PaymentsEntity.PaymentBatchInfo Class | Aptify.Applications.OrderEntry.Payments Namespace


BatchID Property

Aptify 5.0 Software Development Kit (SDK)

PaymentsEntity.PaymentBatchInfo.BatchID Property

public Int64 BatchID {get;}

See Also

PaymentsEntity.PaymentBatchInfo Class | Aptify.Applications.OrderEntry.Payments Namespace


IsBatched Property

Aptify 5.0 Software Development Kit (SDK)

PaymentsEntity.PaymentBatchInfo.IsBatched Property

public Boolean IsBatched {get;}

See Also

PaymentsEntity.PaymentBatchInfo Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.PaymentOrderInfo Class

For a list of all members of this type, see PaymentsEntity.PaymentOrderInfo Members.

System.Object
PaymentsEntity.PaymentOrderInfo

public class PaymentsEntity.PaymentOrderInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry.Payments

Assembly: Payments (in Payments.dll)

See Also

PaymentsEntity.PaymentOrderInfo Members | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.PaymentOrderInfo Members

PaymentsEntity.PaymentOrderInfo overview

Public Instance Constructors

PaymentsEntity.PaymentOrderInfo Constructor

Public Instance Properties

CurrencyTypeID
OrderID
OrderStatusID
OrderType

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PaymentsEntity.PaymentOrderInfo Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.PaymentOrderInfo Constructor

public PaymentsEntity.PaymentOrderInfo(
Int64 OrderID,
Int64 OrderTypeID,
Int64 CurrencyTypeID,
Int64 OrderStatusID
);

See Also

PaymentsEntity.PaymentOrderInfo Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.PaymentOrderInfo Properties

The properties of the PaymentsEntity.PaymentOrderInfo class are listed below. For a complete list of PaymentsEntity.PaymentOrderInfo class members, see the PaymentsEntity.PaymentOrderInfo Members topic.

Public Instance Properties

CurrencyTypeID
OrderID
OrderStatusID
OrderType

See Also

PaymentsEntity.PaymentOrderInfo Class | Aptify.Applications.OrderEntry.Payments Namespace


CurrencyTypeID Property

Aptify 5.0 Software Development Kit (SDK)

PaymentsEntity.PaymentOrderInfo.CurrencyTypeID Property

public Int64 CurrencyTypeID {get;}

See Also

PaymentsEntity.PaymentOrderInfo Class | Aptify.Applications.OrderEntry.Payments Namespace


OrderID Property

Aptify 5.0 Software Development Kit (SDK)

PaymentsEntity.PaymentOrderInfo.OrderID Property

public Int64 OrderID {get;}

See Also

PaymentsEntity.PaymentOrderInfo Class | Aptify.Applications.OrderEntry.Payments Namespace


OrderStatusID Property

Aptify 5.0 Software Development Kit (SDK)

PaymentsEntity.PaymentOrderInfo.OrderStatusID Property

public Int64 OrderStatusID {get;}

See Also

PaymentsEntity.PaymentOrderInfo Class | Aptify.Applications.OrderEntry.Payments Namespace


OrderType Property

Aptify 5.0 Software Development Kit (SDK)

PaymentsEntity.PaymentOrderInfo.OrderType Property

public PaymentsEntity.PaymentOrderInfo.OrderTypes OrderType {get; set;}

See Also

PaymentsEntity.PaymentOrderInfo Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.PaymentOrderInfo.OrderTypes Enumeration

public enum PaymentsEntity.PaymentOrderInfo.OrderTypes

Members

Member Name | Description
Regular |
BackOrder |
Cancellation |
Quotation |

Requirements

Namespace: Aptify.Applications.OrderEntry.Payments

Assembly: Payments (in Payments.dll)

See Also

Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.PaymentStateChangeEventHandler Delegate

public delegate void PaymentsEntity.PaymentStateChangeEventHandler(
String sOldStatus,
String sNewStatus
);

Requirements

Namespace: Aptify.Applications.OrderEntry.Payments

Assembly: Payments (in Payments.dll)

See Also

Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.PaymentStatusType Enumeration

public enum PaymentsEntity.PaymentStatusType

Members

Member Name | Description
Invalid |
Pending |
Posted |
Batched |
OnHold |
Exception |

Requirements

Namespace: Aptify.Applications.OrderEntry.Payments

Assembly: Payments (in Payments.dll)

See Also

Aptify.Applications.OrderEntry.Payments Namespace


PaymentsEntity.ProgressUpdateEventHandler Delegate

public delegate void PaymentsEntity.ProgressUpdateEventHandler(
String sMessage,
Boolean bUseProgressBar,
Int32 iMax,
Int32 iCurrent
);

Requirements

Namespace: Aptify.Applications.OrderEntry.Payments

Assembly: Payments (in Payments.dll)

See Also

Aptify.Applications.OrderEntry.Payments Namespace


PaymentSTLayoutBase Class

For a list of all members of this type, see PaymentSTLayoutBase Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
PaymentSTLayoutBase
PaymentAuthorizationsLayout
PaymentGLEntriesLayout
PaymentLinesLayout

public class PaymentSTLayoutBase : FormTemplateLayout

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry.Payments

Assembly: PaymentGUI (in PaymentGUI.dll)

See Also

PaymentSTLayoutBase Members | Aptify.Applications.OrderEntry.Payments Namespace


PaymentSTLayoutBase Members

PaymentSTLayoutBase overview

Public Instance Constructors

PaymentSTLayoutBase Constructor Initializes a new instance of the PaymentSTLayoutBase class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
PaymentGE |
PaymentSTGE |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
EnableDisableControl | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig |
OnFormTemplateLoaded |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

PaymentSTLayoutBase Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentSTLayoutBase Constructor

Initializes a new instance of the PaymentSTLayoutBase class.

public PaymentSTLayoutBase();

See Also

PaymentSTLayoutBase Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentSTLayoutBase Properties

The properties of the PaymentSTLayoutBase class are listed below. For a complete list of PaymentSTLayoutBase class members, see the PaymentSTLayoutBase Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
PaymentGE |
PaymentSTGE |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

PaymentSTLayoutBase Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentGE Property

Aptify 5.0 Software Development Kit (SDK)

PaymentSTLayoutBase.PaymentGE Property

protected PaymentsEntity PaymentGE {get;}

See Also

PaymentSTLayoutBase Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentSTGE Property

Aptify 5.0 Software Development Kit (SDK)

PaymentSTLayoutBase.PaymentSTGE Property

protected AptifyGenericEntityBase PaymentSTGE {get;}

See Also

PaymentSTLayoutBase Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentSTLayoutBase Methods

The methods of the PaymentSTLayoutBase class are listed below. For a complete list of PaymentSTLayoutBase class members, see the PaymentSTLayoutBase Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
EnableDisableControl | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig |
OnFormTemplateLoaded |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

PaymentSTLayoutBase Class | Aptify.Applications.OrderEntry.Payments Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

PaymentSTLayoutBase.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

PaymentSTLayoutBase Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentSTLayoutBase.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

PaymentSTLayoutBase Class | Aptify.Applications.OrderEntry.Payments Namespace | PaymentSTLayoutBase.Dispose Overload List


EnableDisableControl Method

Aptify 5.0 Software Development Kit (SDK)

PaymentSTLayoutBase.EnableDisableControl Method

Overload List

protected virtual void EnableDisableControl(Boolean,Control,Boolean);

protected virtual void EnableDisableControl(Control,Boolean,Boolean);

See Also

PaymentSTLayoutBase Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentSTLayoutBase.EnableDisableControl Method (Boolean, Control, Boolean)

protected virtual void EnableDisableControl(
Boolean bOverrideDefault,
Control oControl,
Boolean bEnable
);

See Also

PaymentSTLayoutBase Class | Aptify.Applications.OrderEntry.Payments Namespace | PaymentSTLayoutBase.EnableDisableControl Overload List


PaymentSTLayoutBase.EnableDisableControl Method (Control, Boolean, Boolean)

protected virtual void EnableDisableControl(
Control oControl,
Boolean bEnable,
Boolean bIncludeChildren
);

See Also

PaymentSTLayoutBase Class | Aptify.Applications.OrderEntry.Payments Namespace | PaymentSTLayoutBase.EnableDisableControl Overload List


PaymentSTLayoutBase.OnFormComponentConfig Method

protected override void OnFormComponentConfig(
AptifyFormTemplateContext Context
);

Implements

IFormComponent.

See Also

PaymentSTLayoutBase Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentSTLayoutBase.OnFormTemplateLoaded Method

protected override void OnFormTemplateLoaded(
FormTemplateLayout.FormTemplateLoadedEventArgs e
);

See Also

PaymentSTLayoutBase Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentSTLayoutBase.OrderLayoutCurrencyControls Class

For a list of all members of this type, see PaymentSTLayoutBase.OrderLayoutCurrencyControls Members.

System.Object
PaymentSTLayoutBase.OrderLayoutCurrencyControls

public class PaymentSTLayoutBase.OrderLayoutCurrencyControls

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry.Payments

Assembly: PaymentGUI (in PaymentGUI.dll)

See Also

PaymentSTLayoutBase.OrderLayoutCurrencyControls Members | Aptify.Applications.OrderEntry.Payments Namespace


PaymentSTLayoutBase.OrderLayoutCurrencyControls Members

PaymentSTLayoutBase.OrderLayoutCurrencyControls overview

Public Instance Constructors

PaymentSTLayoutBase.OrderLayoutCurrencyControls Constructor

Public Instance Fields

m_oControl
m_sName

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PaymentSTLayoutBase.OrderLayoutCurrencyControls Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentSTLayoutBase.OrderLayoutCurrencyControls Constructor

public PaymentSTLayoutBase.OrderLayoutCurrencyControls(
String sName,
IFormComponent oControl
);

See Also

PaymentSTLayoutBase.OrderLayoutCurrencyControls Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentSTLayoutBase.OrderLayoutCurrencyControls Fields

The fields of the PaymentSTLayoutBase.OrderLayoutCurrencyControls class are listed below. For a complete list of PaymentSTLayoutBase.OrderLayoutCurrencyControls class members, see the PaymentSTLayoutBase.OrderLayoutCurrencyControls Members topic.

Public Instance Fields

m_oControl
m_sName

See Also

PaymentSTLayoutBase.OrderLayoutCurrencyControls Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentSTLayoutBase.OrderLayoutCurrencyControls.m_oControl Field

public m_oControl m_oControl;

See Also

PaymentSTLayoutBase.OrderLayoutCurrencyControls Class | Aptify.Applications.OrderEntry.Payments Namespace


PaymentSTLayoutBase.OrderLayoutCurrencyControls.m_sName Field

public m_sName m_sName;

See Also

PaymentSTLayoutBase.OrderLayoutCurrencyControls Class | Aptify.Applications.OrderEntry.Payments Namespace


Status Class

For a list of all members of this type, see Status Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
Status

public class Status : Form

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry.Payments

Assembly: PaymentGUI (in PaymentGUI.dll)

See Also

Status Members | Aptify.Applications.OrderEntry.Payments Namespace


Status Members

Status overview

Public Instance Constructors

Status Constructor Initializes a new instance of the Status class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MessageHistory |
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PopupStyle |
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
UpdateStatus | Overloaded.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

Status Class | Aptify.Applications.OrderEntry.Payments Namespace


Status Constructor

Initializes a new instance of the Status class.

public Status();

See Also

Status Class | Aptify.Applications.OrderEntry.Payments Namespace


Status Properties

The properties of the Status class are listed below. For a complete list of Status class members, see the Status Members topic.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MessageHistory |
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PopupStyle |
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

Status Class | Aptify.Applications.OrderEntry.Payments Namespace


MessageHistory Property

Aptify 5.0 Software Development Kit (SDK)

Status.MessageHistory Property

public String MessageHistory {get;}

See Also

Status Class | Aptify.Applications.OrderEntry.Payments Namespace


PopupStyle Property

Aptify 5.0 Software Development Kit (SDK)

Status.PopupStyle Property

public Status.StatusPopupStyle PopupStyle {get; set;}

See Also

Status Class | Aptify.Applications.OrderEntry.Payments Namespace


Status Methods

The methods of the Status class are listed below. For a complete list of Status class members, see the Status Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
UpdateStatus | Overloaded.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

Status Class | Aptify.Applications.OrderEntry.Payments Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

Status.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

Status Class | Aptify.Applications.OrderEntry.Payments Namespace


Status.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

Status Class | Aptify.Applications.OrderEntry.Payments Namespace | Status.Dispose Overload List


UpdateStatus Method

Aptify 5.0 Software Development Kit (SDK)

Status.UpdateStatus Method

Overload List

public void UpdateStatus(Int32,Int32);

public void UpdateStatus(String);

public void UpdateStatus(String,Int32,Int32);

See Also

Status Class | Aptify.Applications.OrderEntry.Payments Namespace


Status.UpdateStatus Method (Int32, Int32)

public void UpdateStatus(
Int32 iProgress,
Int32 iMax
);

See Also

Status Class | Aptify.Applications.OrderEntry.Payments Namespace | Status.UpdateStatus Overload List


Status.UpdateStatus Method (String)

public void UpdateStatus(
String sMessage
);

See Also

Status Class | Aptify.Applications.OrderEntry.Payments Namespace | Status.UpdateStatus Overload List


Status.UpdateStatus Method (String, Int32, Int32)

public void UpdateStatus(
String sMessage,
Int32 iProgress,
Int32 iMax
);

See Also

Status Class | Aptify.Applications.OrderEntry.Payments Namespace | Status.UpdateStatus Overload List


Status.StatusPopupStyle Enumeration

public enum Status.StatusPopupStyle

Members

Member Name | Description
MessageOnly |
ProgressBarOnly |
MessageAndProgressBar |
MessageAndInfiniteStatus |

Requirements

Namespace: Aptify.Applications.OrderEntry.Payments

Assembly: PaymentGUI (in PaymentGUI.dll)

See Also

Aptify.Applications.OrderEntry.Payments Namespace


Aptify.Applications.OrderEntry.Payments.ElectronicPaymentVerisign

Aptify 5.0 Software Development Kit (SDK)

Aptify.Applications.OrderEntry.Payments.ElectronicPaymentVerisign Namespace

This namespace corresponds to Aptify's integration with VeriSign PayFlow Pro to authorize and capture electronic payments. Note that an organization needs to configure a Merchant Accounts record that references the functionality in this namespace and the corresponding assembly. See the Aptify 4.0 Accounting and Financial Systems Integration Guide for more information.

Namespace hierarchy

Classes

Class | Description
ElectronicPaymentVerisign | This class extends the Aptify ElectronicPaymentBase object to implement EPayments for use with PayPal


ElectronicPaymentVerisign Class

This class extends the Aptify ElectronicPaymentBase object to implement EPayments for use with PayPal

For a list of all members of this type, see ElectronicPaymentVerisign Members.

System.Object
ElectronicPaymentBase
ElectronicPaymentVerisign

public class ElectronicPaymentVerisign : ElectronicPaymentBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.OrderEntry.Payments.ElectronicPaymentVerisign

Assembly: ElectronicPaymentVerisign (in ElectronicPaymentVerisign.dll)

See Also

ElectronicPaymentVerisign Members | Aptify.Applications.OrderEntry.Payments.ElectronicPaymentVerisign Namespace


ElectronicPaymentVerisign Members

ElectronicPaymentVerisign overview

Public Instance Constructors

ElectronicPaymentVerisign Constructor Initializes a new instance of the ElectronicPaymentVerisign class.

Public Instance Properties

AptifyReferenceNumber (inherited from ElectronicPaymentBase) | Gets the Aptify generated reference number generated for the transaction.
AuthorizationCode (inherited from ElectronicPaymentBase) | Gets the authroization code returned by the provider to reference the specific authorization instance.
ComponentInfo |
ReferenceNumber (inherited from ElectronicPaymentBase) | Gets the provider generated transaction reference number generated for the authorization.
VoiceOverrideCode |

Public Instance Methods

CapturePayment | Overloaded. This function has been deprecated to the CapturePayment overloaded method using the ElectronicPaymentCaptureParams parameter. This function is used for legacy purposes
CheckConnection |
Config (inherited from ElectronicPaymentBase) | Configure the object with the necessary data to work with Aptify
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAuthorization | Overloaded.
GetAuthorization (inherited from ElectronicPaymentBase) | Overloaded. Method requests an authorization from an electronic payment provider.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetMerchantConfigValue (inherited from ElectronicPaymentBase) | Returns the a value from the Merchant Dictionary object based on the submitted sKey.
GetMessage (inherited from ElectronicPaymentBase) |
GetSoftFailureScore (inherited from ElectronicPaymentBase) |
GetType (inherited from Object) | Gets the Type of the current instance.
SetMerchantConfigValue (inherited from ElectronicPaymentBase) | Sets a merchant configuration value to a protected Dictionary object to store configuration name/value pairs to provide the specific merchant account information to connect and authenticate with the service provider.
SetPaymentVerificationData (inherited from ElectronicPaymentBase) | This method must be called prior to calling an electronic verification function and is responsible for collecting the required data from Aptify for use in an electronic verification.
ToString (inherited from Object) | Returns a String that represents the current Object.
VoidAuthorization | Overloaded. This method voids a transaction with PayPal.
VoidAuthorization (inherited from ElectronicPaymentBase) | Overloaded. This method is deprecated to the VoidAuthorization overloaded method accepting the ElectronicPaymentCaptureParams parameter.

Protected Instance Fields

m_FraudMappings (inherited from ElectronicPaymentBase)
m_iAuthCode (inherited from ElectronicPaymentBase)
m_MerchantValues (inherited from ElectronicPaymentBase)
m_Messages (inherited from ElectronicPaymentBase)
m_PaymentDB (inherited from ElectronicPaymentBase)
m_sAptifyReferenceNumber (inherited from ElectronicPaymentBase)
m_SoftFailureScores (inherited from ElectronicPaymentBase)
m_sReferenceNumber (inherited from ElectronicPaymentBase)
m_sVoiceCode

Protected Instance Properties

Application (inherited from ElectronicPaymentBase)
TransactionDescription (inherited from ElectronicPaymentBase)

Protected Instance Methods

CalculateAVSScore | This method transforms the PayPal fraud score into the standard 1-10 Aptify scale. The following translation is performed on the returned values from PayPal on the concatenation of Address and Zip code, respectively: - XX, XY, YX returns 3 - YY returns 10 - NY returns 7 - NN returns 5
CalculateCVV2Score |
CalculateFraudScore | This method transforms the PayPal fraud score into the standard 1-10 Aptify scale. Since PayPal's fraud score range is from 1-199, we simply divide the result by 10.
CheckCertPath | This method checks for the Environment Variable "PFPRO_CERT_PATH" to the location of the certification file required by PayPal
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FormatExpirationDate | This method formats a credit card expiration date for submission to PayPal.
GetAmountNotAuthorized (inherited from ElectronicPaymentBase) | This method returns the amount, from the Payment object that can be authorized or captured. This will typically be the total amount of the Payment less any amounts previously captured.
GetConnectionString |
GetFraudMappingValue (inherited from ElectronicPaymentBase) | This method retrieves a Fraud Mapping value.
GetMerchantFraudMappings (inherited from ElectronicPaymentBase) | This method retrieves any fraud mappings set for the current transaction.
GetOrderSpecificAuthorizationType (inherited from ElectronicPaymentBase) | The purpose of this method is to get the order specific authorization type. This is determined by examining the products on the order. If any of the products on the order require inventory, then the authorization type will be AuthOnly. Otherwise, the authorization type will be AuthCapture.
GetPaymentOrderData (inherited from ElectronicPaymentBase) | This method is responsible for getting Order information from the first Payment Line on the payment to be authorized. This method will return a data table with the information from the related order.
GetVeriSignAuthType |
InitializeVeriSignConfigurationString | This method creates a new StringBuilder object to be used for building the PayPal configuration string for processing transactions with PayPal. This method will also add the connection specific parameters to the string.
LUHNCheck (inherited from ElectronicPaymentBase) | This method applies the Luhn algorithm to a credit card number to determine its validity
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ParseVerisignResults | This method takes the Verisign return string from a transaction and parses the results into a Dictionary object.
PerformTransactionInquiry |
ProcessVeriSignTransaction |
SetAuthorizationType (inherited from ElectronicPaymentBase) | This method converts the string field value from the Merchant Account record to the AuthorizationTypes enumeration. Override this method if the behavior of translating the field string value to the enumeration type needs to change. This method will throw an exception if there is not matching enumeration type.
SetFraudCheckLevelType (inherited from ElectronicPaymentBase) | This method converts the string field value from the Merchant Account record to the FraudCheckLevel enumeration. Override this method if the behavior of translating the field string value to the enumeration type needs to change. This method will throw an exception if there is not matching enumeration type.
SetMessage (inherited from ElectronicPaymentBase) |
SetSoftFailureScore (inherited from ElectronicPaymentBase) |
SetTenderType (inherited from ElectronicPaymentBase) | This method converts the string field value from the Merchant Account Payment Type record to the TenderType enumeration. Override this method if the behavior of translating the field string value to the enumeration type needs to change. This method will throw an exception if there is not matching enumeration type.
ValidateCreditCardData (inherited from ElectronicPaymentBase) | This method peforms multiple validations on credit card data in the payment object based on the flags passed in with the tValidateTypes parameters and will return a string consisting of the credit card number. This method requires the m_Payment member to be instantiated and will throw an exception if is it Nothing.
ValidateMerchantValues | This method is resonsible for ensuring that the minimum number of merchant parameters have been supplied to connect to PayPal to perform an authorization or capture.

See Also

ElectronicPaymentVerisign Class | Aptify.Applications.OrderEntry.Payments.ElectronicPaymentVerisign Namespace


ElectronicPaymentVerisign Constructor

Initializes a new instance of the ElectronicPaymentVerisign class.

public ElectronicPaymentVerisign();

See Also

ElectronicPaymentVerisign Class | Aptify.Applications.OrderEntry.Payments.ElectronicPaymentVerisign Namespace


ElectronicPaymentVerisign Fields

The fields of the ElectronicPaymentVerisign class are listed below. For a complete list of ElectronicPaymentVerisign class members, see the ElectronicPaymentVerisign Members topic.

Protected Instance Fields

m_FraudMappings (inherited from ElectronicPaymentBase)
m_iAuthCode (inherited from ElectronicPaymentBase)
m_MerchantValues (inherited from ElectronicPaymentBase)
m_Messages (inherited from ElectronicPaymentBase)
m_PaymentDB (inherited from ElectronicPaymentBase)
m_sAptifyReferenceNumber (inherited from ElectronicPaymentBase)
m_SoftFailureScores (inherited from ElectronicPaymentBase)
m_sReferenceNumber (inherited from ElectronicPaymentBase)
m_sVoiceCode

See Also

ElectronicPaymentVerisign Class | Aptify.Applications.OrderEntry.Payments.ElectronicPaymentVerisign Namespace


ElectronicPaymentVerisign.m_sVoiceCode Field

protected m_sVoiceCode m_sVoiceCode;

See Also

ElectronicPaymentVerisign Class | Aptify.Applications.OrderEntry.Payments.ElectronicPaymentVerisign Namespace


ElectronicPaymentVerisign Properties

The properties of the ElectronicPaymentVerisign class are listed below. For a complete list of ElectronicPaymentVerisign class members, see the ElectronicPaymentVerisign Members topic.

Public Instance Properties

AptifyReferenceNumber (inherited from ElectronicPaymentBase) | Gets the Aptify generated reference number generated for the transaction.
AuthorizationCode (inherited from ElectronicPaymentBase) | Gets the authroization code returned by the provider to reference the specific authorization instance.
ComponentInfo |
ReferenceNumber (inherited from ElectronicPaymentBase) | Gets the provider generated transaction reference number generated for the authorization.
VoiceOverrideCode |

Protected Instance Properties

Application (inherited from ElectronicPaymentBase)
TransactionDescription (inherited from ElectronicPaymentBase)

See Also

ElectronicPaymentVerisign Class | Aptify.Applications.OrderEntry.Payments.ElectronicPaymentVerisign Namespace


ComponentInfo Property

Aptify 5.0 Software Development Kit (SDK)

ElectronicPaymentVerisign.ComponentInfo Property

public override String ComponentInfo {get;}

See Also

ElectronicPaymentVerisign Class | Aptify.Applications.OrderEntry.Payments.ElectronicPaymentVerisign Namespace


VoiceOverrideCode Property

Aptify 5.0 Software Development Kit (SDK)

ElectronicPaymentVerisign.VoiceOverrideCode Property

public override String VoiceOverrideCode {get;}

See Also

ElectronicPaymentVerisign Class | Aptify.Applications.OrderEntry.Payments.ElectronicPaymentVerisign Namespace


ElectronicPaymentVerisign Methods

The methods of the ElectronicPaymentVerisign class are listed below. For a complete list of ElectronicPaymentVerisign class members, see the ElectronicPaymentVerisign Members topic.

Public Instance Methods

CapturePayment | Overloaded. This function has been deprecated to the CapturePayment overloaded method using the ElectronicPaymentCaptureParams parameter. This function is used for legacy purposes
CheckConnection |
Config (inherited from ElectronicPaymentBase) | Configure the object with the necessary data to work with Aptify
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAuthorization | Overloaded.
GetAuthorization (inherited from ElectronicPaymentBase) | Overloaded. Method requests an authorization from an electronic payment provider.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetMerchantConfigValue (inherited from ElectronicPaymentBase) | Returns the a value from the Merchant Dictionary object based on the submitted sKey.
GetMessage (inherited from ElectronicPaymentBase) |
GetSoftFailureScore (inherited from ElectronicPaymentBase) |
GetType (inherited from Object) | Gets the Type of the current instance.
SetMerchantConfigValue (inherited from ElectronicPaymentBase) | Sets a merchant configuration value to a protected Dictionary object to store configuration name/value pairs to provide the specific merchant account information to connect and authenticate with the service provider.
SetPaymentVerificationData (inherited from ElectronicPaymentBase) | This method must be called prior to calling an electronic verification function and is responsible for collecting the required data from Aptify for use in an electronic verification.
ToString (inherited from Object) | Returns a String that represents the current Object.
VoidAuthorization | Overloaded. This method voids a transaction with PayPal.
VoidAuthorization (inherited from ElectronicPaymentBase) | Overloaded. This method is deprecated to the VoidAuthorization overloaded method accepting the ElectronicPaymentCaptureParams parameter.

Protected Instance Methods

CalculateAVSScore | This method transforms the PayPal fraud score into the standard 1-10 Aptify scale. The following translation is performed on the returned values from PayPal on the concatenation of Address and Zip code, respectively: - XX, XY, YX returns 3 - YY returns 10 - NY returns 7 - NN returns 5
CalculateCVV2Score |
CalculateFraudScore | This method transforms the PayPal fraud score into the standard 1-10 Aptify scale. Since PayPal's fraud score range is from 1-199, we simply divide the result by 10.
CheckCertPath | This method checks for the Environment Variable "PFPRO_CERT_PATH" to the location of the certification file required by PayPal
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FormatExpirationDate | This method formats a credit card expiration date for submission to PayPal.
GetAmountNotAuthorized (inherited from ElectronicPaymentBase) | This method returns the amount, from the Payment object that can be authorized or captured. This will typically be the total amount of the Payment less any amounts previously captured.
GetConnectionString |
GetFraudMappingValue (inherited from ElectronicPaymentBase) | This method retrieves a Fraud Mapping value.
GetMerchantFraudMappings (inherited from ElectronicPaymentBase) | This method retrieves any fraud mappings set for the current transaction.
GetOrderSpecificAuthorizationType (inherited from ElectronicPaymentBase) | The purpose of this method is to get the order specific authorization type. This is determined by examining the products on the order. If any of the products on the order require inventory, then the authorization type will be AuthOnly. Otherwise, the authorization type will be AuthCapture.
GetPaymentOrderData (inherited from ElectronicPaymentBase) | This method is responsible for getting Order information from the first Payment Line on the payment to be authorized. This method will return a data table with the information from the related order.
GetVeriSignAuthType |
InitializeVeriSignConfigurationString | This method creates a new StringBuilder object to be used for building the PayPal configuration string for processing transactions with PayPal. This method will also add the connection specific parameters to the string.
LUHNCheck (inherited from ElectronicPaymentBase) | This method applies the Luhn algorithm to a credit card number to determine its validity
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ParseVerisignResults | This method takes the Verisign return string from a transaction and parses the results into a Dictionary object.
PerformTransactionInquiry |
ProcessVeriSignTransaction |
SetAuthorizationType (inherited from ElectronicPaymentBase) | This method converts the string field value from the Merchant Account record to the AuthorizationTypes enumeration. Override this method if the behavior of translating the field string value to the enumeration type needs to change. This method will throw an exception if there is not matching enumeration type.
SetFraudCheckLevelType (inherited from ElectronicPaymentBase) | This method converts the string field value from the Merchant Account record to the FraudCheckLevel enumeration. Override this method if the behavior of translating the field string value to the enumeration type needs to change. This method will throw an exception if there is not matching enumeration type.
SetMessage (inherited from ElectronicPaymentBase) |
SetSoftFailureScore (inherited from ElectronicPaymentBase) |
SetTenderType (inherited from ElectronicPaymentBase) | This method converts the string field value from the Merchant Account Payment Type record to the TenderType enumeration. Override this method if the behavior of translating the field string value to the enumeration type needs to change. This method will throw an exception if there is not matching enumeration type.
ValidateCreditCardData (inherited from ElectronicPaymentBase) | This method peforms multiple validations on credit card data in the payment object based on the flags passed in with the tValidateTypes parameters and will return a string consisting of the credit card number. This method requires the m_Payment member to be instantiated and will throw an exception if is it Nothing.
ValidateMerchantValues | This method is resonsible for ensuring that the minimum number of merchant parameters have been supplied to connect to PayPal to perform an authorization or capture.

See Also

ElectronicPaymentVerisign Class | Aptify.Applications.OrderEntry.Payments.ElectronicPaymentVerisign Namespace


ElectronicPaymentVerisign.CalculateAVSScore Method

This method transforms the PayPal fraud score into the standard 1-10 Aptify scale. The following translation is performed on the returned values from PayPal on the concatenation of Address and Zip code, respectively: - XX, XY, YX returns 3 - YY returns 10 - NY returns 7 - NN returns 5

protected override int CalculateAVSScore(
String sProcessorValue,
ref String& sProcessorMessage
);

Parameters

sProcessorValue
The concatenation of the Address and Zip returned values for AVS
sProcessorMessage
Message returned by this method, if any.

Return Value

Translated AVS Score in Aptify Scale

Remarks

See Also

ElectronicPaymentVerisign Class | Aptify.Applications.OrderEntry.Payments.ElectronicPaymentVerisign Namespace


ElectronicPaymentVerisign.CalculateCVV2Score Method

protected override int CalculateCVV2Score(
String sProcessorValue,
ref String& sProcessorMessage
);

See Also

ElectronicPaymentVerisign Class | Aptify.Applications.OrderEntry.Payments.ElectronicPaymentVerisign Namespace


ElectronicPaymentVerisign.CalculateFraudScore Method

This method transforms the PayPal fraud score into the standard 1-10 Aptify scale. Since PayPal's fraud score range is from 1-199, we simply divide the result by 10.

protected override int CalculateFraudScore(
String sProcessorValue,
ref String& sProcessorMessage
);

Parameters

sProcessorValue
The fraud value returned by PayPal to be evaluated.
sProcessorMessage
Message returned by this method, if any.

Return Value

Translated FraudScore value in Aptify scale.

Remarks

See Also

ElectronicPaymentVerisign Class | Aptify.Applications.OrderEntry.Payments.ElectronicPaymentVerisign Namespace


CapturePayment Method

Aptify 5.0 Software Development Kit (SDK)

ElectronicPaymentVerisign.CapturePayment Method

Overload List

public override ElectronicPaymentResults CapturePayment(ElectronicPaymentCaptureParams,ref String&,ref String&);

This function has been deprecated to the CapturePayment overloaded method using the ElectronicPaymentCaptureParams parameter. This function is used for legacy purposes

public override ElectronicPaymentResults CapturePayment(String,ref String&,ref String&);

This function has been deprecated to the CapturePayment overloaded method using the ElectronicPaymentCaptureParams parameter. This function is used for legacy purposes

public override ElectronicPaymentResults CapturePayment(String,ref String&,ref String&,Double);

See Also

ElectronicPaymentVerisign Class | Aptify.Applications.OrderEntry.Payments.ElectronicPaymentVerisign Namespace


ElectronicPaymentVerisign.CapturePayment Method (ElectronicPaymentCaptureParams, String&, String&)

public override ElectronicPaymentResults CapturePayment(
ElectronicPaymentCaptureParams oCapParams,
ref String& sAuthCode,
ref String& sResultRefNum
);

Parameters

oCapParams
sAuthCode
sResultRefNum

Return Value

Remarks

See Also

ElectronicPaymentVerisign Class | Aptify.Applications.OrderEntry.Payments.ElectronicPaymentVerisign Namespace | ElectronicPaymentVerisign.CapturePayment Overload List


ElectronicPaymentVerisign.CapturePayment Method (String, String&, String&)

This function has been deprecated to the CapturePayment overloaded method using the ElectronicPaymentCaptureParams parameter. This function is used for legacy purposes

public override ElectronicPaymentResults CapturePayment(
String sReferenceNumber,
ref String& sAuthCode,
ref String& sResultRefNum
);

Parameters

sReferenceNumber
Previously authorized transaction number from PayPal
sAuthCode
Authorization Code returned from PayPal
sResultRefNum
PayPal reference number to identify delayed capture transaction.

Return Value

Remarks

See Also

ElectronicPaymentVerisign Class | Aptify.Applications.OrderEntry.Payments.ElectronicPaymentVerisign Namespace | ElectronicPaymentVerisign.CapturePayment Overload List


ElectronicPaymentVerisign.CapturePayment Method (String, String&, String&, Double)

This function has been deprecated to the CapturePayment overloaded method using the ElectronicPaymentCaptureParams parameter. This function is used for legacy purposes

public override ElectronicPaymentResults CapturePayment(
String sReferenceNumber,
ref String& sAuthCode,
ref String& sResultRefNum,
Double cAmount
);

Parameters

sReferenceNumber
Previously authorized transaction number from PayPal
sAuthCode
Authorization Code returned from PayPal
sResultRefNum
PayPal reference number to identify delayed capture transaction.
cAmount

Return Value

Remarks

See Also

ElectronicPaymentVerisign Class | Aptify.Applications.OrderEntry.Payments.ElectronicPaymentVerisign Namespace | ElectronicPaymentVerisign.CapturePayment Overload List


ElectronicPaymentVerisign.CheckCertPath Method

This method checks for the Environment Variable "PFPRO_CERT_PATH" to the location of the certification file required by PayPal

protected virtual bool CheckCertPath(
ref String& sErrorMessage
);

Parameters

sErrorMessage
Message returned by the method if the method fails

Return Value

True if the environmental path exists

Remarks

See Also

ElectronicPaymentVerisign Class | Aptify.Applications.OrderEntry.Payments.ElectronicPaymentVerisign Namespace


ElectronicPaymentVerisign.CheckConnection Method

public override ConnectionStatusTypes CheckConnection();

See Also

ElectronicPaymentVerisign Class | Aptify.Applications.OrderEntry.Payments.ElectronicPaymentVerisign Namespace


ElectronicPaymentVerisign.FormatExpirationDate Method

This method formats a credit card expiration date for submission to PayPal.

protected virtual string FormatExpirationDate(
DateTime dDate
);

Parameters

dDate
The expiration date to be formatted.

Return Value

String reflecting the expiration date in a format for submitting to PayPal.

Remarks

See Also

ElectronicPaymentVerisign Class | Aptify.Applications.OrderEntry.Payments.ElectronicPaymentVerisign Namespace


GetAuthorization Method

Aptify 5.0 Software Development Kit (SDK)

ElectronicPaymentVerisign.GetAuthorization Method

Overload List

public override ElectronicPaymentResults GetAuthorization(ElectronicPaymentAuthorizationParams);

Inherited from ElectronicPaymentBase.

public ElectronicPaymentResults GetAuthorization(AptifyGenericEntityBase,ref String&,ref String&,ElectronicPaymentBase.AuthorizationTypes,String);

Inherited from ElectronicPaymentBase.

public ElectronicPaymentResults GetAuthorization(AptifyGenericEntityBase,ref String&,ref String&,ElectronicPaymentBase.AuthorizationTypes,String,Boolean);

Inherited from ElectronicPaymentBase.

public ElectronicPaymentResults GetAuthorization(AptifyGenericEntityBase,ref String&,ref String&,ElectronicPaymentBase.AuthorizationTypes,String,Boolean,ElectronicPaymentBase.FraudCheckLevels);

Inherited from ElectronicPaymentBase.

public ElectronicPaymentResults GetAuthorization(AptifyGenericEntityBase,ref String&,ref String&,ElectronicPaymentBase.AuthorizationTypes,String,Boolean,Boolean,Boolean,ElectronicPaymentBase.FraudCheckLevels,ElectronicPaymentBase.ACHAccountTypes,Boolean);

See Also

ElectronicPaymentVerisign Class | Aptify.Applications.OrderEntry.Payments.ElectronicPaymentVerisign Namespace


ElectronicPaymentVerisign.GetAuthorization Method (ElectronicPaymentAuthorizationParams)

public override ElectronicPaymentResults GetAuthorization(
ElectronicPaymentAuthorizationParams oAuthorizationParameters
);

See Also

ElectronicPaymentVerisign Class | Aptify.Applications.OrderEntry.Payments.ElectronicPaymentVerisign Namespace | ElectronicPaymentVerisign.GetAuthorization Overload List


ElectronicPaymentVerisign.GetConnectionString Method

protected virtual string GetConnectionString();

See Also

ElectronicPaymentVerisign Class | Aptify.Applications.OrderEntry.Payments.ElectronicPaymentVerisign Namespace


ElectronicPaymentVerisign.GetVeriSignAuthType Method

protected virtual string GetVeriSignAuthType(
ElectronicPaymentBase.AuthorizationTypes tAuthType,
ref Boolean& bIsVoiceAuth
);

See Also

ElectronicPaymentVerisign Class | Aptify.Applications.OrderEntry.Payments.ElectronicPaymentVerisign Namespace


ElectronicPaymentVerisign.InitializeVeriSignConfigurationString Method

This method creates a new StringBuilder object to be used for building the PayPal configuration string for processing transactions with PayPal. This method will also add the connection specific parameters to the string.

protected virtual StringBuilder InitializeVeriSignConfigurationString(
String sFormat
);

Parameters

sFormat
The format template string used to add parameter segments to the string. This should follow the String.Format function format and be preceeded with the PayPal parameters delimiter (e.g., "{0}={1}" for name/value pairs).

Return Value

StringBuilder object initialized for communicating with PayPal.

Remarks

See Also

ElectronicPaymentVerisign Class | Aptify.Applications.OrderEntry.Payments.ElectronicPaymentVerisign Namespace


ElectronicPaymentVerisign.ParseVerisignResults Method

This method takes the Verisign return string from a transaction and parses the results into a Dictionary object.

protected virtual Dictionary<TKey,TValue> ParseVerisignResults(
String sResult
);

Parameters

sResult
PayPal return string.

Return Value

Dictionary object containing the PayPal results.

Remarks

See Also

ElectronicPaymentVerisign Class | Aptify.Applications.OrderEntry.Payments.ElectronicPaymentVerisign Namespace


ElectronicPaymentVerisign.PerformTransactionInquiry Method

protected virtual Dictionary<TKey,TValue> PerformTransactionInquiry(
String sOriginalReferenceNumber,
ElectronicPaymentBase.TenderTypes tTenderType
);

See Also

ElectronicPaymentVerisign Class | Aptify.Applications.OrderEntry.Payments.ElectronicPaymentVerisign Namespace


ElectronicPaymentVerisign.ProcessVeriSignTransaction Method

protected virtual bool ProcessVeriSignTransaction(
String sTransactionString,
ref Dictionary`2& dTransResult
);

See Also

ElectronicPaymentVerisign Class | Aptify.Applications.OrderEntry.Payments.ElectronicPaymentVerisign Namespace


ElectronicPaymentVerisign.ValidateMerchantValues Method

This method is resonsible for ensuring that the minimum number of merchant parameters have been supplied to connect to PayPal to perform an authorization or capture.

protected virtual bool ValidateMerchantValues(
ref String& sMessage
);

Parameters

sMessage
Contains a message containing a description of the missing merchant parameters, if any.

Return Value

True if all the required parameters are present. If false, check the sMessage parameter.

Remarks

See Also

ElectronicPaymentVerisign Class | Aptify.Applications.OrderEntry.Payments.ElectronicPaymentVerisign Namespace


VoidAuthorization Method

Aptify 5.0 Software Development Kit (SDK)

ElectronicPaymentVerisign.VoidAuthorization Method

This method voids a transaction with PayPal.

Overload List

This method voids a transaction with PayPal.

public override ElectronicPaymentResults VoidAuthorization(ElectronicPaymentCaptureParams,String,ref String&,ref String&);

Inherited from ElectronicPaymentBase.

public virtual ElectronicPaymentResults VoidAuthorization(Double,String,String,ref String&,ref String&);

See Also

ElectronicPaymentVerisign Class | Aptify.Applications.OrderEntry.Payments.ElectronicPaymentVerisign Namespace


ElectronicPaymentVerisign.VoidAuthorization Method (ElectronicPaymentCaptureParams, String, String&, String&)

This method voids a transaction with PayPal.

public override ElectronicPaymentResults VoidAuthorization(
ElectronicPaymentCaptureParams oCaptureParams,
String sApplicationRefNum,
ref String& sAuthCode,
ref String& sResultRefNum
);

Parameters

oCaptureParams
Capture Parameters object used to capture the previously authorized transaction.
sApplicationRefNum
The Aptify reference number.
sAuthCode
The authorization code provided by Verisign resulting from the transaction.
sResultRefNum
PayPal transaction reference number for the void transaction

Return Value

Electronic payment results reflecting the result of the void transaction.

Remarks

See Also

ElectronicPaymentVerisign Class | Aptify.Applications.OrderEntry.Payments.ElectronicPaymentVerisign Namespace | ElectronicPaymentVerisign.VoidAuthorization Overload List


Aptify.Applications.OrderEntry.Payments.Exceptions

Aptify 5.0 Software Development Kit (SDK)

Aptify.Applications.OrderEntry.Payments.Exceptions Namespace

This namespace contains the functionality that handles the possible exceptions related to the Payments functionality.

Namespace hierarchy

Classes

Class | Description
EPaymentException |
PaymentException |
PaymentGLException |


EPaymentException Class

For a list of all members of this type, see EPaymentException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
EPaymentException

public class EPaymentException : BaseApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry.Payments.Exceptions

Assembly: Payments (in Payments.dll)

See Also

EPaymentException Members | Aptify.Applications.OrderEntry.Payments.Exceptions Namespace


EPaymentException Members

EPaymentException overview

Public Instance Constructors

EPaymentException Constructor

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message |
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from BaseApplicationException) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EPaymentException Class | Aptify.Applications.OrderEntry.Payments.Exceptions Namespace


EPaymentException Constructor

public EPaymentException(
String sMessage
);

See Also

EPaymentException Class | Aptify.Applications.OrderEntry.Payments.Exceptions Namespace


EPaymentException Properties

The properties of the EPaymentException class are listed below. For a complete list of EPaymentException class members, see the EPaymentException Members topic.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message |
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

See Also

EPaymentException Class | Aptify.Applications.OrderEntry.Payments.Exceptions Namespace


Message Property

Aptify 5.0 Software Development Kit (SDK)

EPaymentException.Message Property

public override String Message {get;}

See Also

EPaymentException Class | Aptify.Applications.OrderEntry.Payments.Exceptions Namespace


PaymentException Class

For a list of all members of this type, see PaymentException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
PaymentException

public class PaymentException : BaseApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry.Payments.Exceptions

Assembly: Payments (in Payments.dll)

See Also

PaymentException Members | Aptify.Applications.OrderEntry.Payments.Exceptions Namespace


PaymentException Members

PaymentException overview

Public Instance Constructors

PaymentException Constructor

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message |
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from BaseApplicationException) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PaymentException Class | Aptify.Applications.OrderEntry.Payments.Exceptions Namespace


PaymentException Constructor

public PaymentException(
String sMessage
);

See Also

PaymentException Class | Aptify.Applications.OrderEntry.Payments.Exceptions Namespace


PaymentException Properties

The properties of the PaymentException class are listed below. For a complete list of PaymentException class members, see the PaymentException Members topic.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message |
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

See Also

PaymentException Class | Aptify.Applications.OrderEntry.Payments.Exceptions Namespace


Message Property

Aptify 5.0 Software Development Kit (SDK)

PaymentException.Message Property

public override String Message {get;}

See Also

PaymentException Class | Aptify.Applications.OrderEntry.Payments.Exceptions Namespace


PaymentGLException Class

For a list of all members of this type, see PaymentGLException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
PaymentGLException

public class PaymentGLException : BaseApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry.Payments.Exceptions

Assembly: Payments (in Payments.dll)

See Also

PaymentGLException Members | Aptify.Applications.OrderEntry.Payments.Exceptions Namespace


PaymentGLException Members

PaymentGLException overview

Public Instance Constructors

PaymentGLException Constructor

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message |
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from BaseApplicationException) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PaymentGLException Class | Aptify.Applications.OrderEntry.Payments.Exceptions Namespace


PaymentGLException Constructor

public PaymentGLException(
String sMessage
);

See Also

PaymentGLException Class | Aptify.Applications.OrderEntry.Payments.Exceptions Namespace


PaymentGLException Properties

The properties of the PaymentGLException class are listed below. For a complete list of PaymentGLException class members, see the PaymentGLException Members topic.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message |
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

See Also

PaymentGLException Class | Aptify.Applications.OrderEntry.Payments.Exceptions Namespace


Message Property

Aptify 5.0 Software Development Kit (SDK)

PaymentGLException.Message Property

public override String Message {get;}

See Also

PaymentGLException Class | Aptify.Applications.OrderEntry.Payments.Exceptions Namespace


Aptify.Applications.OrderEntry.Subscriptions

Aptify 5.0 Software Development Kit (SDK)

Aptify.Applications.OrderEntry.Subscriptions Namespace

This namespace corresponds to the functionality that handles subscription generation when an order contains a subscription product.

Namespace hierarchy

Classes

Class | Description
SubscriptionDate | This object implements the ISubscriptionDate interface to provide the default implementation for the Aptify CRM Suite for calculating dates for subscriptions.
SubscriptionSave | This object implements the Aptify.Framework.Applications.OrderEntry.ISubscriptionSasve interface. The purpose of this component is to handle the base use cases for saving subscriptions from an order and a cancellation order. This class is designed to be sub-classed as needed for configuration needs.

Interfaces

Interface | Description
ISubscriptionDate | This interface is used to provide the ability to plug in objects that handle the requirements for subscription start date and subscription issue date calculation. This new interface starting in Aptify 4.0, consolidates 3 interfaces from prior versions, the ICGISubsCalc, ICGISubsStart and ICGISubsStart2. All 3 of these prior interfaces map to methods on this new interface
ISubscriptionSave | Interface used to create plug-ins for saving subscriptions from the Order Entry system. The order entry system will look for a plug-in that implements this interface within the Aptify Entity model by looking at the following entity attributes and attempting to instantiate an object that is specified as shown in the entity attributes. The specified object must implement ISubscriptionSave. Note that in addition to this abstract interface Aptify provides a default implementation class Aptify.Applications.OrderEntry.SubscriptionSave which may be subclassed to accomodate unique configuration needs rather than creating entirely new objects that implement this interface directly. Entity Attributes in the Orders Entity Name: "Subscription Save Object" Location of the subscription save object in the Aptify Object Repository. Name: "Subscription Save Class" Class Name (fully qualified including root namespace) the implements this interface. Default value is Aptify.Applications.OrderEntry.SubscriptionSave Name "Subscription Save Assembly" Assembly Name where the above class is located

Delegates

Delegate | Description
ISubscriptionSave.StatusUpdateEventHandler |

Enumerations

Enumeration | Description
SubscriptionSave.PurchaseType | Enumeration of subscription purchase types


ISubscriptionDate Interface

This interface is used to provide the ability to plug in objects that handle the requirements for subscription start date and subscription issue date calculation. This new interface starting in Aptify 4.0, consolidates 3 interfaces from prior versions, the ICGISubsCalc, ICGISubsStart and ICGISubsStart2. All 3 of these prior interfaces map to methods on this new interface

For a list of all members of this type, see ISubscriptionDate Members.

public interface ISubscriptionDate

Types that implement ISubscriptionDate

Type | Description
SubscriptionDate | This object implements the ISubscriptionDate interface to provide the default implementation for the Aptify CRM Suite for calculating dates for subscriptions.

Remarks

Requirements

Namespace: Aptify.Applications.OrderEntry.Subscriptions

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

ISubscriptionDate Members | Aptify.Applications.OrderEntry.Subscriptions Namespace


ISubscriptionDate Members

ISubscriptionDate overview

Public Instance Methods

Config | Call this function once before using to configure it for use with the application object required
GetIssueDate | Overloaded. This function returns the number of Days, Weeks and Months to increment a subscription start date by and also returns the issue date
GetSubsStartDate | Overloaded. This method returns the start date calculated by the object for the subscriber, product combination provided. The OUT Parameter Subscription Start Date returns the start date calculated.

See Also

ISubscriptionDate Interface | Aptify.Applications.OrderEntry.Subscriptions Namespace


ISubscriptionDate Methods

The methods of the ISubscriptionDate interface are listed below. For a complete list of ISubscriptionDate interface members, see the ISubscriptionDate Members topic.

Public Instance Methods

Config | Call this function once before using to configure it for use with the application object required
GetIssueDate | Overloaded. This function returns the number of Days, Weeks and Months to increment a subscription start date by and also returns the issue date
GetSubsStartDate | Overloaded. This method returns the start date calculated by the object for the subscriber, product combination provided. The OUT Parameter Subscription Start Date returns the start date calculated.

See Also

ISubscriptionDate Interface | Aptify.Applications.OrderEntry.Subscriptions Namespace


ISubscriptionDate.Config Method

Call this function once before using to configure it for use with the application object required

void Config(
AptifyApplication Application
);

Parameters

Application
Required Parameter - Aptify Application Object

Remarks

Added for v4.0 to allow for more robust functionality inside plug-in objects

See Also

ISubscriptionDate Interface | Aptify.Applications.OrderEntry.Subscriptions Namespace


GetIssueDate Method

Aptify 5.0 Software Development Kit (SDK)

ISubscriptionDate.GetIssueDate Method

This function returns the number of Days, Weeks and Months to increment a subscription start date by and also returns the issue date

Overload List

This function returns the number of Days, Weeks and Months to increment a subscription start date by and also returns the issue date

DateTime GetIssueDate(Int64,Int64,ref DateTime&,ref Int64&,ref Int64&,ref Int64&);

This is the overloaded version that passes in the Subscription ID as well as the standard input parameters. This function returns the number of Days, Weeks and Months to increment a subscription start date by and also returns the issue date

DateTime GetIssueDate(Int64,Int64,Int64,Int64,ref DateTime&,ref Int64&,ref Int64&,ref Int64&);

See Also

ISubscriptionDate Interface | Aptify.Applications.OrderEntry.Subscriptions Namespace


ISubscriptionDate.GetIssueDate Method (Int64, Int64, DateTime&, Int64&, Int64&, Int64&)

This function returns the number of Days, Weeks and Months to increment a subscription start date by and also returns the issue date

DateTime GetIssueDate(
Int64 DaysPerIssue,
Int64 IssueNum,
ref DateTime& StartDate,
ref Int64& Months,
ref Int64& Weeks,
ref Int64& Days
);

Parameters

DaysPerIssue
IssueNum
StartDate
Months
Weeks
Days

Return Value

Remarks

See Also

ISubscriptionDate Interface | Aptify.Applications.OrderEntry.Subscriptions Namespace | ISubscriptionDate.GetIssueDate Overload List


ISubscriptionDate.GetIssueDate Method (Int64, Int64, Int64, Int64, DateTime&, Int64&, Int64&, Int64&)

This is the overloaded version that passes in the Subscription ID as well as the standard input parameters. This function returns the number of Days, Weeks and Months to increment a subscription start date by and also returns the issue date

DateTime GetIssueDate(
Int64 OrderID,
Int64 ProductID,
Int64 DaysPerIssue,
Int64 IssueNum,
ref DateTime& StartDate,
ref Int64& Months,
ref Int64& Weeks,
ref Int64& Days
);

Parameters

OrderID
ProductID
DaysPerIssue
IssueNum
StartDate
Months
Weeks
Days

Return Value

Remarks

See Also

ISubscriptionDate Interface | Aptify.Applications.OrderEntry.Subscriptions Namespace | ISubscriptionDate.GetIssueDate Overload List


GetSubsStartDate Method

Aptify 5.0 Software Development Kit (SDK)

ISubscriptionDate.GetSubsStartDate Method

This method returns the start date calculated by the object for any number of attributes since the OrderDetailGE and OrderGE are passed in. The OUT Parameter Subscription Start Date returns the start date calculated.

Overload List

This method returns the start date calculated by the object for any number of attributes since the OrderDetailGE and OrderGE are passed in. The OUT Parameter Subscription Start Date returns the start date calculated.

bool GetSubsStartDate(OrdersEntity,OrderLinesEntity,Int64,Int64,Int64,DateTime,ref DateTime&);

Uses the Subscription to retrieve the Start Date. The Start Date is returned in the SubscriptionStartDate parameter.

bool GetSubsStartDate(Int64,ref DateTime&);

This method returns the start date calculated by the object for the subscriber, product combination provided. The OUT Parameter Subscription Start Date returns the start date calculated.

bool GetSubsStartDate(Int64,Int64,DateTime,ref DateTime&);

This method returns the start date calculated by the object for the subscriber, subscriber company and product combination provided. The OUT Parameter Subscription Start Date returns the start date calculated.

bool GetSubsStartDate(Int64,Int64,Int64,DateTime,ref DateTime&);

See Also

ISubscriptionDate Interface | Aptify.Applications.OrderEntry.Subscriptions Namespace


ISubscriptionDate.GetSubsStartDate Method (OrdersEntity, OrderLinesEntity, Int64, Int64, Int64, DateTime, DateTime&)

This method returns the start date calculated by the object for any number of attributes since the OrderDetailGE and OrderGE are passed in. The OUT Parameter Subscription Start Date returns the start date calculated.

bool GetSubsStartDate(
OrdersEntity OrderGE,
OrderLinesEntity OrderLineGE,
Int64 SubscriberID,
Int64 SubscriberCompanyID,
Int64 ProductID,
DateTime OrderDate,
ref DateTime& SubscriptionStartDate
);

Parameters

OrderGE
OrderLineGE
SubscriberID
SubscriberCompanyID
ProductID
OrderDate
SubscriptionStartDate
OUT Parameter: Returns the Start Date Calculated By The Object

Return Value

Remarks

See Also

ISubscriptionDate Interface | Aptify.Applications.OrderEntry.Subscriptions Namespace | ISubscriptionDate.GetSubsStartDate Overload List


ISubscriptionDate.GetSubsStartDate Method (Int64, DateTime&)

Uses the Subscription to retrieve the Start Date. The Start Date is returned in the SubscriptionStartDate parameter.

bool GetSubsStartDate(
Int64 SubscriptionID,
ref DateTime& SubscriptionStartDate
);

Parameters

SubscriptionID
SubscriptionStartDate

Return Value

Remarks

See Also

ISubscriptionDate Interface | Aptify.Applications.OrderEntry.Subscriptions Namespace | ISubscriptionDate.GetSubsStartDate Overload List


ISubscriptionDate.GetSubsStartDate Method (Int64, Int64, DateTime, DateTime&)

This method returns the start date calculated by the object for the subscriber, product combination provided. The OUT Parameter Subscription Start Date returns the start date calculated.

bool GetSubsStartDate(
Int64 SubscriberID,
Int64 ProductID,
DateTime OrderDate,
ref DateTime& SubscriptionStartDate
);

Parameters

SubscriberID
ProductID
OrderDate
SubscriptionStartDate
OUT Parameter: Returns the Start Date Calculated By The Object

Return Value

True if method is succesful, False otherwise

Remarks

See Also

ISubscriptionDate Interface | Aptify.Applications.OrderEntry.Subscriptions Namespace | ISubscriptionDate.GetSubsStartDate Overload List


ISubscriptionDate.GetSubsStartDate Method (Int64, Int64, Int64, DateTime, DateTime&)

This method returns the start date calculated by the object for the subscriber, subscriber company and product combination provided. The OUT Parameter Subscription Start Date returns the start date calculated.

bool GetSubsStartDate(
Int64 SubscriberID,
Int64 SubscriberCompanyID,
Int64 ProductID,
DateTime OrderDate,
ref DateTime& SubscriptionStartDate
);

Parameters

SubscriberID
SubscriberCompanyID
ProductID
OrderDate
SubscriptionStartDate
OUT Parameter: Returns the Start Date Calculated By The Object

Return Value

True if method is succesful, False otherwise

Remarks

See Also

ISubscriptionDate Interface | Aptify.Applications.OrderEntry.Subscriptions Namespace | ISubscriptionDate.GetSubsStartDate Overload List


ISubscriptionSave Interface

Interface used to create plug-ins for saving subscriptions from the Order Entry system. The order entry system will look for a plug-in that implements this interface within the Aptify Entity model by looking at the following entity attributes and attempting to instantiate an object that is specified as shown in the entity attributes. The specified object must implement ISubscriptionSave. Note that in addition to this abstract interface Aptify provides a default implementation class Aptify.Applications.OrderEntry.SubscriptionSave which may be subclassed to accomodate unique configuration needs rather than creating entirely new objects that implement this interface directly. Entity Attributes in the Orders Entity Name: "Subscription Save Object" Location of the subscription save object in the Aptify Object Repository. Name: "Subscription Save Class" Class Name (fully qualified including root namespace) the implements this interface. Default value is Aptify.Applications.OrderEntry.SubscriptionSave Name "Subscription Save Assembly" Assembly Name where the above class is located

For a list of all members of this type, see ISubscriptionSave Members.

public interface ISubscriptionSave

Types that implement ISubscriptionSave

Type | Description
SubscriptionSave | This object implements the Aptify.Framework.Applications.OrderEntry.ISubscriptionSasve interface. The purpose of this component is to handle the base use cases for saving subscriptions from an order and a cancellation order. This class is designed to be sub-classed as needed for configuration needs.

Remarks

Requirements

Namespace: Aptify.Applications.OrderEntry.Subscriptions

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

ISubscriptionSave Members | Aptify.Applications.OrderEntry.Subscriptions Namespace


ISubscriptionSave Members

ISubscriptionSave overview

Public Instance Methods

Config | This method must be called before any other member of the interface is called
SaveCancellationSubscriptions | Overloaded. Save cancellation subscriptions for a given Order object.
SaveSubscriptions | Overloaded. Save subscriptions for a given Order object.

Public Instance Events

StatusUpdate This event is raised from the object from the SaveSubscriptions() and SaveCancellationSubscriptions() method calls to provide status update information to the calling object/application as well as the ability to cancel the process using the Cancel OUT parameter provided to this event.

See Also

ISubscriptionSave Interface | Aptify.Applications.OrderEntry.Subscriptions Namespace


ISubscriptionSave Methods

The methods of the ISubscriptionSave interface are listed below. For a complete list of ISubscriptionSave interface members, see the ISubscriptionSave Members topic.

Public Instance Methods

Config | This method must be called before any other member of the interface is called
SaveCancellationSubscriptions | Overloaded. Save cancellation subscriptions for a given Order object.
SaveSubscriptions | Overloaded. Save subscriptions for a given Order object.

See Also

ISubscriptionSave Interface | Aptify.Applications.OrderEntry.Subscriptions Namespace


ISubscriptionSave.Config Method

This method must be called before any other member of the interface is called

void Config(
AptifyApplication Application
);

Parameters

Application

Remarks

See Also

ISubscriptionSave Interface | Aptify.Applications.OrderEntry.Subscriptions Namespace


SaveCancellationSubscriptions Method

Aptify 5.0 Software Development Kit (SDK)

ISubscriptionSave.SaveCancellationSubscriptions Method

Save cancellation subscriptions for a given Order object.

Overload List

Save cancellation subscriptions for a given Order object.

bool SaveCancellationSubscriptions(OrdersEntity);

Saves cancellation subscriptions for a given Order object.

bool SaveCancellationSubscriptions(OrdersEntity,Boolean);

See Also

ISubscriptionSave Interface | Aptify.Applications.OrderEntry.Subscriptions Namespace


ISubscriptionSave.SaveCancellationSubscriptions Method (OrdersEntity)

Save cancellation subscriptions for a given Order object.

bool SaveCancellationSubscriptions(
OrdersEntity OrderGE
);

Parameters

OrderGE

Return Value

True if succesful, False otherwise

Remarks

See Also

ISubscriptionSave Interface | Aptify.Applications.OrderEntry.Subscriptions Namespace | ISubscriptionSave.SaveCancellationSubscriptions Overload List


ISubscriptionSave.SaveCancellationSubscriptions Method (OrdersEntity, Boolean)

Saves cancellation subscriptions for a given Order object.

bool SaveCancellationSubscriptions(
OrdersEntity OrderGE,
Boolean AllowGUI
);

Parameters

OrderGE
AllowGUI
If set to True, allows the object to display messages to the user when errors occur as well as errors being Thrown for fatal errors. If False, the object displays no GUI and messages are logged to the session exception log and also thrown for fatal errors.

Return Value

True if succesful, False otherwise

Remarks

See Also

ISubscriptionSave Interface | Aptify.Applications.OrderEntry.Subscriptions Namespace | ISubscriptionSave.SaveCancellationSubscriptions Overload List


SaveSubscriptions Method

Aptify 5.0 Software Development Kit (SDK)

ISubscriptionSave.SaveSubscriptions Method

Save subscriptions for a given Order object.

Overload List

Save subscriptions for a given Order object.

bool SaveSubscriptions(OrdersEntity);

Save subscriptions for a given Order object.

bool SaveSubscriptions(OrdersEntity,Boolean);

See Also

ISubscriptionSave Interface | Aptify.Applications.OrderEntry.Subscriptions Namespace


ISubscriptionSave.SaveSubscriptions Method (OrdersEntity)

Save subscriptions for a given Order object.

bool SaveSubscriptions(
OrdersEntity OrderGE
);

Parameters

OrderGE

Return Value

True if succesful, False otherwise

Remarks

See Also

ISubscriptionSave Interface | Aptify.Applications.OrderEntry.Subscriptions Namespace | ISubscriptionSave.SaveSubscriptions Overload List


ISubscriptionSave.SaveSubscriptions Method (OrdersEntity, Boolean)

Save subscriptions for a given Order object.

bool SaveSubscriptions(
OrdersEntity OrderGE,
Boolean AllowGUI
);

Parameters

OrderGE
AllowGUI
If set to True, allows the object to display messages to the user when errors occur as well as errors being Thrown for fatal errors. If False, the object displays no GUI and messages are logged to the session exception log and also thrown for fatal errors.

Return Value

True if succesful, False otherwise

Remarks

See Also

ISubscriptionSave Interface | Aptify.Applications.OrderEntry.Subscriptions Namespace | ISubscriptionSave.SaveSubscriptions Overload List


ISubscriptionSave Events

The events of the ISubscriptionSave interface are listed below. For a complete list of ISubscriptionSave interface members, see the ISubscriptionSave Members topic.

Public Instance Events

StatusUpdate This event is raised from the object from the SaveSubscriptions() and SaveCancellationSubscriptions() method calls to provide status update information to the calling object/application as well as the ability to cancel the process using the Cancel OUT parameter provided to this event.

See Also

ISubscriptionSave Interface | Aptify.Applications.OrderEntry.Subscriptions Namespace


ISubscriptionSave.ISubscriptionSave.StatusUpdateEventHandler Event

This event is raised from the object from the SaveSubscriptions() and SaveCancellationSubscriptions() method calls to provide status update information to the calling object/application as well as the ability to cancel the process using the Cancel OUT parameter provided to this event.

event ISubscriptionSave.StatusUpdateEventHandler StatusUpdate;

Remarks

See Also

ISubscriptionSave Interface | Aptify.Applications.OrderEntry.Subscriptions Namespace


ISubscriptionSave.StatusUpdateEventHandler Delegate

public delegate void ISubscriptionSave.StatusUpdateEventHandler(
Int32 LineNumber,
Int32 PercentComplete,
ref Boolean& Cancel
);

Requirements

Namespace: Aptify.Applications.OrderEntry.Subscriptions

Assembly: AptifyOrdersEntity (in AptifyOrdersEntity.dll)

See Also

Aptify.Applications.OrderEntry.Subscriptions Namespace


SubscriptionDate Class

This object implements the ISubscriptionDate interface to provide the default implementation for the Aptify CRM Suite for calculating dates for subscriptions.

For a list of all members of this type, see SubscriptionDate Members.

System.Object
SubscriptionDate

public class SubscriptionDate : ISubscriptionDate

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.OrderEntry.Subscriptions

Assembly: SubscriptionDate (in SubscriptionDate.dll)

See Also

SubscriptionDate Members | Aptify.Applications.OrderEntry.Subscriptions Namespace


SubscriptionDate Members

SubscriptionDate overview

Public Instance Constructors

SubscriptionDate Constructor Initializes a new instance of the SubscriptionDate class.

Public Instance Methods

Config | Call this method before calling any other method on this object
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetIssueDate | Overloaded.
GetSubsStartDate | Overloaded.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

Application | Returns Aptify Application instance
DataAction | Returns an instance of the DataAction class
Database | Returns the name of the database where the Aptify Subscriptions Entity is located.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetCompanyJoinDate | Returns a company's join date from the JoinDate field in the Companies Entity Returns 1/1/1900 as the default date value if there is no join date
GetPersonJoinDate | Returns a person's join date from the JoinDate field in the Persons Entity Returns 1/1/1900 as the default date value if there is no join date
GetStartDateFromJoinDate |
GetStartDateFromProduct | This method is responsible for determining if there is a start date defined at the Product level. If there is no start date associated with the Product (Calendar-year based subscription) then this function will do nothing
GetStartDateFromSubPurchase | This method is responsible for retrieving the subscription start date from the end date of the latest subscription purchase
GetStartDateFromSubscription | This method is responsible for retrieving the subscription start date from the end date of an existing subscription.
IsDuesProduct | This method returns True if ProductID is a dues product and returns False is ProductID is NOT a dues product
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SubscriptionDate Class | Aptify.Applications.OrderEntry.Subscriptions Namespace


SubscriptionDate Constructor

Initializes a new instance of the SubscriptionDate class.

public SubscriptionDate();

See Also

SubscriptionDate Class | Aptify.Applications.OrderEntry.Subscriptions Namespace


SubscriptionDate Properties

The properties of the SubscriptionDate class are listed below. For a complete list of SubscriptionDate class members, see the SubscriptionDate Members topic.

Protected Instance Properties

Application | Returns Aptify Application instance
DataAction | Returns an instance of the DataAction class
Database | Returns the name of the database where the Aptify Subscriptions Entity is located.

See Also

SubscriptionDate Class | Aptify.Applications.OrderEntry.Subscriptions Namespace


Application Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionDate.Application Property

Returns Aptify Application instance

protected AptifyApplication Application {get;}

Property Value

Remarks

See Also

SubscriptionDate Class | Aptify.Applications.OrderEntry.Subscriptions Namespace


DataAction Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionDate.DataAction Property

Returns an instance of the DataAction class

protected virtual DataAction DataAction {get;}

Property Value

Remarks

See Also

SubscriptionDate Class | Aptify.Applications.OrderEntry.Subscriptions Namespace


Database Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionDate.Database Property

Returns the name of the database where the Aptify Subscriptions Entity is located.

protected virtual String Database {get;}

Property Value

Remarks

See Also

SubscriptionDate Class | Aptify.Applications.OrderEntry.Subscriptions Namespace


SubscriptionDate Methods

The methods of the SubscriptionDate class are listed below. For a complete list of SubscriptionDate class members, see the SubscriptionDate Members topic.

Public Instance Methods

Config | Call this method before calling any other method on this object
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetIssueDate | Overloaded.
GetSubsStartDate | Overloaded.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetCompanyJoinDate | Returns a company's join date from the JoinDate field in the Companies Entity Returns 1/1/1900 as the default date value if there is no join date
GetPersonJoinDate | Returns a person's join date from the JoinDate field in the Persons Entity Returns 1/1/1900 as the default date value if there is no join date
GetStartDateFromJoinDate |
GetStartDateFromProduct | This method is responsible for determining if there is a start date defined at the Product level. If there is no start date associated with the Product (Calendar-year based subscription) then this function will do nothing
GetStartDateFromSubPurchase | This method is responsible for retrieving the subscription start date from the end date of the latest subscription purchase
GetStartDateFromSubscription | This method is responsible for retrieving the subscription start date from the end date of an existing subscription.
IsDuesProduct | This method returns True if ProductID is a dues product and returns False is ProductID is NOT a dues product
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SubscriptionDate Class | Aptify.Applications.OrderEntry.Subscriptions Namespace


SubscriptionDate.Config Method

Call this method before calling any other method on this object

public virtual void Config(
AptifyApplication Application
);

Parameters

Application

Implements

ISubscriptionDate.

Remarks

See Also

SubscriptionDate Class | Aptify.Applications.OrderEntry.Subscriptions Namespace


SubscriptionDate.GetCompanyJoinDate Method

Returns a company's join date from the JoinDate field in the Companies Entity Returns 1/1/1900 as the default date value if there is no join date

protected virtual DateTime GetCompanyJoinDate(
Int64 CompanyID
);

Parameters

CompanyID

Return Value

Remarks

See Also

SubscriptionDate Class | Aptify.Applications.OrderEntry.Subscriptions Namespace


GetIssueDate Method

Aptify 5.0 Software Development Kit (SDK)

SubscriptionDate.GetIssueDate Method

Overload List

public virtual DateTime GetIssueDate(Int64,Int64,ref DateTime&,ref Int64&,ref Int64&,ref Int64&);

public virtual DateTime GetIssueDate(Int64,Int64,Int64,Int64,ref DateTime&,ref Int64&,ref Int64&,ref Int64&);

See Also

SubscriptionDate Class | Aptify.Applications.OrderEntry.Subscriptions Namespace


SubscriptionDate.GetIssueDate Method (Int64, Int64, DateTime&, Int64&, Int64&, Int64&)

public virtual DateTime GetIssueDate(
Int64 DaysPerIssue,
Int64 IssueNum,
ref DateTime& StartDate,
ref Int64& Months,
ref Int64& Weeks,
ref Int64& Days
);

Implements

ISubscriptionDate.

See Also

SubscriptionDate Class | Aptify.Applications.OrderEntry.Subscriptions Namespace | SubscriptionDate.GetIssueDate Overload List


SubscriptionDate.GetIssueDate Method (Int64, Int64, Int64, Int64, DateTime&, Int64&, Int64&, Int64&)

public virtual DateTime GetIssueDate(
Int64 OrderID,
Int64 ProductID,
Int64 DaysPerIssue,
Int64 IssueNum,
ref DateTime& StartDate,
ref Int64& Months,
ref Int64& Weeks,
ref Int64& Days
);

Implements

ISubscriptionDate.

See Also

SubscriptionDate Class | Aptify.Applications.OrderEntry.Subscriptions Namespace | SubscriptionDate.GetIssueDate Overload List


SubscriptionDate.GetPersonJoinDate Method

Returns a person's join date from the JoinDate field in the Persons Entity Returns 1/1/1900 as the default date value if there is no join date

protected virtual DateTime GetPersonJoinDate(
Int64 PersonID
);

Parameters

PersonID

Return Value

Remarks

See Also

SubscriptionDate Class | Aptify.Applications.OrderEntry.Subscriptions Namespace


SubscriptionDate.GetStartDateFromJoinDate Method

protected virtual bool GetStartDateFromJoinDate(
Int64 SubscriberID,
Int64 SubscriberCompanyID,
ref DateTime& StartDate
);

See Also

SubscriptionDate Class | Aptify.Applications.OrderEntry.Subscriptions Namespace


SubscriptionDate.GetStartDateFromProduct Method

This method is responsible for determining if there is a start date defined at the Product level. If there is no start date associated with the Product (Calendar-year based subscription) then this function will do nothing

protected virtual bool GetStartDateFromProduct(
Int64 ProductID,
DateTime OrderDate,
ref DateTime& StartDate
);

Parameters

ProductID
OrderDate
StartDate
OUT Parameter: Subscription Start Date from Products Entity

Return Value

Remarks

See Also

SubscriptionDate Class | Aptify.Applications.OrderEntry.Subscriptions Namespace


SubscriptionDate.GetStartDateFromSubPurchase Method

This method is responsible for retrieving the subscription start date from the end date of the latest subscription purchase

protected virtual bool GetStartDateFromSubPurchase(
Int64 SubscriptionID,
ref DateTime& StartDate
);

Parameters

SubscriptionID
StartDate

Return Value

Remarks

See Also

SubscriptionDate Class | Aptify.Applications.OrderEntry.Subscriptions Namespace


SubscriptionDate.GetStartDateFromSubscription Method

This method is responsible for retrieving the subscription start date from the end date of an existing subscription.

protected virtual bool GetStartDateFromSubscription(
Int64 SubscriberID,
Int64 SubscriberCompanyID,
Int64 ProductID,
ref DateTime& StartDate
);

Parameters

SubscriberID
SubscriberCompanyID
ProductID
StartDate

Return Value

Remarks

See Also

SubscriptionDate Class | Aptify.Applications.OrderEntry.Subscriptions Namespace


GetSubsStartDate Method

Aptify 5.0 Software Development Kit (SDK)

SubscriptionDate.GetSubsStartDate Method

Overload List

public virtual bool GetSubsStartDate(OrdersEntity,OrderLinesEntity,Int64,Int64,Int64,DateTime,ref DateTime&);

public virtual bool GetSubsStartDate(Int64,ref DateTime&);

public virtual bool GetSubsStartDate(Int64,Int64,DateTime,ref DateTime&);

public virtual bool GetSubsStartDate(Int64,Int64,Int64,DateTime,ref DateTime&);

See Also

SubscriptionDate Class | Aptify.Applications.OrderEntry.Subscriptions Namespace


SubscriptionDate.GetSubsStartDate Method (OrdersEntity, OrderLinesEntity, Int64, Int64, Int64, DateTime, DateTime&)

public virtual bool GetSubsStartDate(
OrdersEntity OrderGE,
OrderLinesEntity OrderLineGE,
Int64 SubscriberID,
Int64 SubscriberCompanyID,
Int64 ProductID,
DateTime OrderDate,
ref DateTime& SubscriptionStartDate
);

Implements

ISubscriptionDate.

See Also

SubscriptionDate Class | Aptify.Applications.OrderEntry.Subscriptions Namespace | SubscriptionDate.GetSubsStartDate Overload List


SubscriptionDate.GetSubsStartDate Method (Int64, DateTime&)

public virtual bool GetSubsStartDate(
Int64 SubscriptionID,
ref DateTime& SubscriptionStartDate
);

Implements

ISubscriptionDate.

See Also

SubscriptionDate Class | Aptify.Applications.OrderEntry.Subscriptions Namespace | SubscriptionDate.GetSubsStartDate Overload List


SubscriptionDate.GetSubsStartDate Method (Int64, Int64, DateTime, DateTime&)

public virtual bool GetSubsStartDate(
Int64 SubscriberID,
Int64 ProductID,
DateTime OrderDate,
ref DateTime& SubscriptionStartDate
);

Implements

ISubscriptionDate.

See Also

SubscriptionDate Class | Aptify.Applications.OrderEntry.Subscriptions Namespace | SubscriptionDate.GetSubsStartDate Overload List


SubscriptionDate.GetSubsStartDate Method (Int64, Int64, Int64, DateTime, DateTime&)

public virtual bool GetSubsStartDate(
Int64 SubscriberID,
Int64 SubscriberCompanyID,
Int64 ProductID,
DateTime OrderDate,
ref DateTime& SubscriptionStartDate
);

Implements

ISubscriptionDate.

See Also

SubscriptionDate Class | Aptify.Applications.OrderEntry.Subscriptions Namespace | SubscriptionDate.GetSubsStartDate Overload List


SubscriptionDate.IsDuesProduct Method

This method returns True if ProductID is a dues product and returns False is ProductID is NOT a dues product

protected virtual bool IsDuesProduct(
Int64 ProductID
);

Parameters

ProductID

Return Value

Remarks

See Also

SubscriptionDate Class | Aptify.Applications.OrderEntry.Subscriptions Namespace


SubscriptionSave Class

This object implements the Aptify.Framework.Applications.OrderEntry.ISubscriptionSasve interface. The purpose of this component is to handle the base use cases for saving subscriptions from an order and a cancellation order. This class is designed to be sub-classed as needed for configuration needs.

For a list of all members of this type, see SubscriptionSave Members.

System.Object
SubscriptionSave

public class SubscriptionSave : ISubscriptionSave

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.OrderEntry.Subscriptions

Assembly: SubscriptionSave (in SubscriptionSave.dll)

See Also

SubscriptionSave Members | Aptify.Applications.OrderEntry.Subscriptions Namespace


SubscriptionSave Members

SubscriptionSave overview

Public Instance Constructors

SubscriptionSave Constructor Initializes a new instance of the SubscriptionSave class.

Public Instance Methods

Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SaveCancellationSubscriptions | Overloaded.
SaveSubscriptions | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

StatusUpdate

Protected Instance Properties

Application | Returns an instance of the Aptify Application object
DataAction | Returns an instance of the Data Action class
Database | Returns the name of the database where the Orders entity is stored

Protected Instance Methods

AddAutoRenewal |
AddSubscriptionPurchase |
CreateSubscription | This method is responsible for creating a new Subscription GE object and populating it from the OrderGE, OrderDetailGE, SubscriberID, and RecipientCompanyID parameters
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FindSubscriptionPurchase | This method is responsible for finding a subscription purchase within a given subscription that is linked to the provided Order ID. The method iterates through each SubscriptionPurchase within the provided SubscriptionGE object and if it finds a match for the provided OrderID then it returns it. Otherwise, the method returns Nothing.
GetBalanceQuantity | This method is used to return the Balance Quantity for a subscription cancellation for a given order line
GetCancelledIssues |
GetChapterID | This method is responsible for determining the Chapter ID for the given Order Detail line item the default logic is to check to see if there is a ChapterID populated in the OrderLine entity (ChapterID field) and if there is NOT, then return -1
GetCompanyJoinDate | This method is responsible for returning the join date associated with the provided PersonID. The default implementation calls the spGetPersonJoinDate in the database.
GetCompanySubscriptionID | This method determines if a company (CompanyID) and recipient (RecipientID) specified has an existing subscription for the specified product (ProductID). If there is a subscription associated with the combination of those parameters, the SubscriptionID is returned. If no such subscription exists, the value of -1 is returned. The implementation of this method in the base class uses the spFindIndividualSubscription stored procedure in the database.
GetIndividualSubscriptionID | This method determines if a person specified (SubscriberID) has an existing subscription for the specified product (ProductID). If there is a subscription associated with the combination of those parameters, the SubscriptionID is returned. If no such subscription exists, the value of -1 is returned. The implementation of this method in the base class uses the spFindIndividualSubscription stored procedure in the database.
GetPersonCompanyID | This method is responsible for determining the Company ID associated with a given individual. The default implementation of this method uses the spGetPerson stored procedure and returns the CompanyID field on the Person record. Starting with Aptify 4.5 SP2, this method is called when the Subscription's Entity Attribute, SubscriberCompanyBehavior, is Person, or when the Entity Attribute value is Order and the Order does not specify a Ship To Company.
GetPersonJoinDate | This method is responsible for returning the join date associated with the provided PersonID. The default implementation calls the spGetPersonJoinDate in the database.
GetProductDistributionTypeID | This method is responsible for returning the Distribution Type ID associated with a given product
GetProductIssueDays | This method is responsible for returning the number of days that are associated as an interval between each issue of the specified product. The default implementation of this method in the base class executes the spGetProductIssueDays stored procedure in the database to handle the logic.
GetProductIssues | This method is responsible for returning the number of issues that are defined in the Product record. The default implementation of this method in the base class uses the OrderProductCache to retrieve the number of issues. For subscription products, this value will always be > 0.
GetPurchaseType | Overloaded. This method is responsible for returning an enumerated type that represents the type of purchase for a given Order Line. Purchase type can be either individual level or company level.
GetRecipientID | This method is responsible for determining the Recipient Person for the given Order Detail line item the default logic is to check to see if there is a recipient defined at the Order Detail level (SubscriberID on the OrderDetail) and if there is NOT, then use the Ship To from the Order level
GetSubscriberCompanyID | This method is responsible for returning the ID of the Company this is used to populate the Subscription's SubscriberCompanyID. The SubscriberCompanyID indicates the Company that is both the Subscriber and Recipient for a Subscription. There is an Entity Attribute on the Subscriptions Entity, SubscriberCompanyBehavior, that affects the behavior in this method. If the Entity Attribute does not exist or has a value of Order, the Order's ShipToCompanyID will be returned, if the Order's ShipToCompanyID is greater than 0. If the Order's ShipToCompanyID is less than or equal to 0 or the SubscriberCompanyBehavior Attribute value is Person, call the GetPersonCompanyID method to retrieve the CompanyID based on the PersonID parameter value.
GetSubscriptionID | This method is responsible for determining the Subscription ID to use for a given Order Detail line item. Subscription may or may not exist that matches the information in the Order Detail. Subscriptions are either Company level or Individual Level. This method checks the Purchase Type and the RecipientCompanyID and if RecipientCompanyID > 0 and PurchaseType=Company then the method calls the GetCompanySubscriptionID() method, otherwise the GetIndividualSubscriptionID() method is called.
GetSubscriptionPurchaseStartDate | This method is responsible for determining the start date for an individual subscription purchase within a subscription using the Original Order Detail ID. If no match is found, the Order Date is returned.
GetSubscriptionStartDate | Overloaded. This method is responsible for determining the start date for a subscription. It attempts to call the GetSubsStartDate() method in the object that implements ISubscriptionDate. If that method fails then an exception is thrown to the calling function
GetSubscriptionStatusID | This method is responsible for returning the ID value associated with the Subscription Status name specified in the Status parameter. If a record is not found that matches the specified status name, the value in DefaultValue is returned. The implementation of this method in the base class uses the spGetSubsStatusID stored procedure. Since the Subscription Status entity rarely changes, this method uses caching by default to improve performance.
HandleSubscriptionPurchase | This method is responsible for handling the subscription purchase aspects of creating/updating a subscription. The method's basic logic is to determine if a SubscriptionPurchase exists in the provided Subscription that matches the OrderGE.RecordID. If a SubscriptionPurchase does exist, it is updated. If a SubscriptionPurchase does not exist, one is added for this order
IsDuesProduct | This method is responsible for determining if the specified ProductID is a 'Dues' Product meaning that the DefaultDuesProduct BIT field on the Product entity is set to 1. This method executes the spGetDefaultDuesProductFromProduct stored procedure to determine the result.
LoadAndUpdateSubscriptionHeader | This method is responsible for loading a subscription and updating the basic header information in the Subscription entity top-level and then returning it.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnStatusUpdate | This method is responsible for raising the StatusUpdate event and is called from within the SubscriptionSave() method for each iteration through the OrderGE Sub-Type for OrderLines
SaveOrderDetailSubscription | This method is called once for each Order Detail within the order from the SaveSubscriptions() method and is responsible for saving subscriptions associated with a single order line. The basic process is to determine if subscriptions are required for the order detail, and if so, to either renew an existing subscription that matches the Recipient information and Product information in the Order Detail GE, or to create a new subscription.
SetCompanyJoinDate | This method is responsible for setting the join date field in the Company record to the provided value.
SetPersonJoinDate | This method is responsible for setting the join date field in the Person record to the provided value.
SetSubscriptionPurchaseAttributes | This method is responsbile for setting up the attributes on a Subscription Purchase based on the provided information related to the number of issues, start date, end date, etc.
UpdateCompanyJoinDate | This method is called from the UpdateJoinDate() method whenever a company level join date needs to be update. This method is responsible for checking the current join date of the company and then updating it as appropriate.
UpdateJoinDate | This method is responsible for updating the join date information at the company or person level. First, this method will only update the join date if the subscription has one and ONLY one subscription purchase (as join dates should not be updated for renewals). This method then calls IsDuesProduct() to determine if an update to the join date is requried or note. If it is, then the method updates either the person or company linked to the subscription. If SubscriberCompanyID is set then, the Company Join date will be updated, otherwise the Person join date will be updated using UpdateCompanyJoinDate() and UpdatePersonJoinDate() methods respectively.
UpdateOriginalOrderSubsPurchase | This method is responsible for updating the subscription purchase for the original order ID provided in the Subscription GE to the new number of issues specified in the provided parameter by setting the end-date of the subscription purchase appropriately.
UpdatePersonJoinDate | This method is called from the UpdateJoinDate() method whenever a person level join date needs to be update. This method is responsible for checking the current join date of the person and then updating it as appropriate.

See Also

SubscriptionSave Class | Aptify.Applications.OrderEntry.Subscriptions Namespace


SubscriptionSave Constructor

Initializes a new instance of the SubscriptionSave class.

public SubscriptionSave();

See Also

SubscriptionSave Class | Aptify.Applications.OrderEntry.Subscriptions Namespace


SubscriptionSave Properties

The properties of the SubscriptionSave class are listed below. For a complete list of SubscriptionSave class members, see the SubscriptionSave Members topic.

Protected Instance Properties

Application | Returns an instance of the Aptify Application object
DataAction | Returns an instance of the Data Action class
Database | Returns the name of the database where the Orders entity is stored

See Also

SubscriptionSave Class | Aptify.Applications.OrderEntry.Subscriptions Namespace


Application Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionSave.Application Property

Returns an instance of the Aptify Application object

protected virtual AptifyApplication Application {get;}

Property Value

Remarks

See Also

SubscriptionSave Class | Aptify.Applications.OrderEntry.Subscriptions Namespace


DataAction Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionSave.DataAction Property

Returns an instance of the Data Action class

protected virtual DataAction DataAction {get;}

Property Value

Remarks

See Also

SubscriptionSave Class | Aptify.Applications.OrderEntry.Subscriptions Namespace


Database Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionSave.Database Property

Returns the name of the database where the Orders entity is stored

protected virtual String Database {get;}

Property Value

Remarks

See Also

SubscriptionSave Class | Aptify.Applications.OrderEntry.Subscriptions Namespace


SubscriptionSave Methods

The methods of the SubscriptionSave class are listed below. For a complete list of SubscriptionSave class members, see the SubscriptionSave Members topic.

Public Instance Methods

Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SaveCancellationSubscriptions | Overloaded.
SaveSubscriptions | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

AddAutoRenewal |
AddSubscriptionPurchase |
CreateSubscription | This method is responsible for creating a new Subscription GE object and populating it from the OrderGE, OrderDetailGE, SubscriberID, and RecipientCompanyID parameters
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FindSubscriptionPurchase | This method is responsible for finding a subscription purchase within a given subscription that is linked to the provided Order ID. The method iterates through each SubscriptionPurchase within the provided SubscriptionGE object and if it finds a match for the provided OrderID then it returns it. Otherwise, the method returns Nothing.
GetBalanceQuantity | This method is used to return the Balance Quantity for a subscription cancellation for a given order line
GetCancelledIssues |
GetChapterID | This method is responsible for determining the Chapter ID for the given Order Detail line item the default logic is to check to see if there is a ChapterID populated in the OrderLine entity (ChapterID field) and if there is NOT, then return -1
GetCompanyJoinDate | This method is responsible for returning the join date associated with the provided PersonID. The default implementation calls the spGetPersonJoinDate in the database.
GetCompanySubscriptionID | This method determines if a company (CompanyID) and recipient (RecipientID) specified has an existing subscription for the specified product (ProductID). If there is a subscription associated with the combination of those parameters, the SubscriptionID is returned. If no such subscription exists, the value of -1 is returned. The implementation of this method in the base class uses the spFindIndividualSubscription stored procedure in the database.
GetIndividualSubscriptionID | This method determines if a person specified (SubscriberID) has an existing subscription for the specified product (ProductID). If there is a subscription associated with the combination of those parameters, the SubscriptionID is returned. If no such subscription exists, the value of -1 is returned. The implementation of this method in the base class uses the spFindIndividualSubscription stored procedure in the database.
GetPersonCompanyID | This method is responsible for determining the Company ID associated with a given individual. The default implementation of this method uses the spGetPerson stored procedure and returns the CompanyID field on the Person record. Starting with Aptify 4.5 SP2, this method is called when the Subscription's Entity Attribute, SubscriberCompanyBehavior, is Person, or when the Entity Attribute value is Order and the Order does not specify a Ship To Company.
GetPersonJoinDate | This method is responsible for returning the join date associated with the provided PersonID. The default implementation calls the spGetPersonJoinDate in the database.
GetProductDistributionTypeID | This method is responsible for returning the Distribution Type ID associated with a given product
GetProductIssueDays | This method is responsible for returning the number of days that are associated as an interval between each issue of the specified product. The default implementation of this method in the base class executes the spGetProductIssueDays stored procedure in the database to handle the logic.
GetProductIssues | This method is responsible for returning the number of issues that are defined in the Product record. The default implementation of this method in the base class uses the OrderProductCache to retrieve the number of issues. For subscription products, this value will always be > 0.
GetPurchaseType | Overloaded. This method is responsible for returning an enumerated type that represents the type of purchase for a given Order Line. Purchase type can be either individual level or company level.
GetRecipientID | This method is responsible for determining the Recipient Person for the given Order Detail line item the default logic is to check to see if there is a recipient defined at the Order Detail level (SubscriberID on the OrderDetail) and if there is NOT, then use the Ship To from the Order level
GetSubscriberCompanyID | This method is responsible for returning the ID of the Company this is used to populate the Subscription's SubscriberCompanyID. The SubscriberCompanyID indicates the Company that is both the Subscriber and Recipient for a Subscription. There is an Entity Attribute on the Subscriptions Entity, SubscriberCompanyBehavior, that affects the behavior in this method. If the Entity Attribute does not exist or has a value of Order, the Order's ShipToCompanyID will be returned, if the Order's ShipToCompanyID is greater than 0. If the Order's ShipToCompanyID is less than or equal to 0 or the SubscriberCompanyBehavior Attribute value is Person, call the GetPersonCompanyID method to retrieve the CompanyID based on the PersonID parameter value.
GetSubscriptionID | This method is responsible for determining the Subscription ID to use for a given Order Detail line item. Subscription may or may not exist that matches the information in the Order Detail. Subscriptions are either Company level or Individual Level. This method checks the Purchase Type and the RecipientCompanyID and if RecipientCompanyID > 0 and PurchaseType=Company then the method calls the GetCompanySubscriptionID() method, otherwise the GetIndividualSubscriptionID() method is called.
GetSubscriptionPurchaseStartDate | This method is responsible for determining the start date for an individual subscription purchase within a subscription using the Original Order Detail ID. If no match is found, the Order Date is returned.
GetSubscriptionStartDate | Overloaded. This method is responsible for determining the start date for a subscription. It attempts to call the GetSubsStartDate() method in the object that implements ISubscriptionDate. If that method fails then an exception is thrown to the calling function
GetSubscriptionStatusID | This method is responsible for returning the ID value associated with the Subscription Status name specified in the Status parameter. If a record is not found that matches the specified status name, the value in DefaultValue is returned. The implementation of this method in the base class uses the spGetSubsStatusID stored procedure. Since the Subscription Status entity rarely changes, this method uses caching by default to improve performance.
HandleSubscriptionPurchase | This method is responsible for handling the subscription purchase aspects of creating/updating a subscription. The method's basic logic is to determine if a SubscriptionPurchase exists in the provided Subscription that matches the OrderGE.RecordID. If a SubscriptionPurchase does exist, it is updated. If a SubscriptionPurchase does not exist, one is added for this order
IsDuesProduct | This method is responsible for determining if the specified ProductID is a 'Dues' Product meaning that the DefaultDuesProduct BIT field on the Product entity is set to 1. This method executes the spGetDefaultDuesProductFromProduct stored procedure to determine the result.
LoadAndUpdateSubscriptionHeader | This method is responsible for loading a subscription and updating the basic header information in the Subscription entity top-level and then returning it.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnStatusUpdate | This method is responsible for raising the StatusUpdate event and is called from within the SubscriptionSave() method for each iteration through the OrderGE Sub-Type for OrderLines
SaveOrderDetailSubscription | This method is called once for each Order Detail within the order from the SaveSubscriptions() method and is responsible for saving subscriptions associated with a single order line. The basic process is to determine if subscriptions are required for the order detail, and if so, to either renew an existing subscription that matches the Recipient information and Product information in the Order Detail GE, or to create a new subscription.
SetCompanyJoinDate | This method is responsible for setting the join date field in the Company record to the provided value.
SetPersonJoinDate | This method is responsible for setting the join date field in the Person record to the provided value.
SetSubscriptionPurchaseAttributes | This method is responsbile for setting up the attributes on a Subscription Purchase based on the provided information related to the number of issues, start date, end date, etc.
UpdateCompanyJoinDate | This method is called from the UpdateJoinDate() method whenever a company level join date needs to be update. This method is responsible for checking the current join date of the company and then updating it as appropriate.
UpdateJoinDate | This method is responsible for updating the join date information at the company or person level. First, this method will only update the join date if the subscription has one and ONLY one subscription purchase (as join dates should not be updated for renewals). This method then calls IsDuesProduct() to determine if an update to the join date is requried or note. If it is, then the method updates either the person or company linked to the subscription. If SubscriberCompanyID is set then, the Company Join date will be updated, otherwise the Person join date will be updated using UpdateCompanyJoinDate() and UpdatePersonJoinDate() methods respectively.
UpdateOriginalOrderSubsPurchase | This method is responsible for updating the subscription purchase for the original order ID provided in the Subscription GE to the new number of issues specified in the provided parameter by setting the end-date of the subscription purchase appropriately.
UpdatePersonJoinDate | This method is called from the UpdateJoinDate() method whenever a person level join date needs to be update. This method is responsible for checking the current join date of the person and then updating it as appropriate.

See Also

SubscriptionSave Class | Aptify.Applications.OrderEntry.Subscriptions Namespace


SubscriptionSave.AddAutoRenewal Method

protected virtual bool AddAutoRenewal(
AptifyGenericEntityBase SubscriptionGE,
Boolean AutoRenew,
DateTime StartDate,
DateTime EndDate,
OrderLinesEntity OrderLineGE
);

See Also

SubscriptionSave Class | Aptify.Applications.OrderEntry.Subscriptions Namespace


SubscriptionSave.AddSubscriptionPurchase Method

protected virtual AptifyGenericEntityBase AddSubscriptionPurchase(
AptifyGenericEntityBase SubscriptionGE,
OrdersEntity OrderGE,
DateTime StartDate,
Int64 NumCopies
);

See Also

SubscriptionSave Class | Aptify.Applications.OrderEntry.Subscriptions Namespace


SubscriptionSave.Config Method

public void Config(
AptifyApplication Application
);

Implements

ISubscriptionSave.

See Also

SubscriptionSave Class | Aptify.Applications.OrderEntry.Subscriptions Namespace


SubscriptionSave.CreateSubscription Method

This method is responsible for creating a new Subscription GE object and populating it from the OrderGE, OrderDetailGE, SubscriberID, and RecipientCompanyID parameters

protected virtual AptifyGenericEntityBase CreateSubscription(
Int64 SubscriberID,
Int64 RecipientCompanyID,
SubscriptionSave.PurchaseType PurchaseType,
OrderLinesEntity OrderLineGE
);

Parameters

SubscriberID
RecipientCompanyID
PurchaseType
OrderLineGE

Return Value

A Subscription GE object if the method is succesful, Nothing otherwise

Remarks

See Also

SubscriptionSave Class | Aptify.Applications.OrderEntry.Subscriptions Namespace


SubscriptionSave.FindSubscriptionPurchase Method

This method is responsible for finding a subscription purchase within a given subscription that is linked to the provided Order ID. The method iterates through each SubscriptionPurchase within the provided SubscriptionGE object and if it finds a match for the provided OrderID then it returns it. Otherwise, the method returns Nothing.

protected virtual AptifyGenericEntityBase FindSubscriptionPurchase(
AptifyGenericEntityBase SubscriptionGE,
Int64 OrderID
);

Parameters

SubscriptionGE
OrderID

Return Value

Remarks

See Also

SubscriptionSave Class | Aptify.Applications.OrderEntry.Subscriptions Namespace


SubscriptionSave.GetBalanceQuantity Method

This method is used to return the Balance Quantity for a subscription cancellation for a given order line

protected virtual decimal GetBalanceQuantity(
OrderLinesEntity OrderLineGE,
Int64 RecipientID,
SubscriptionSave.PurchaseType PurchaseType
);

Parameters

OrderLineGE
RecipientID
PurchaseType

Return Value

Remarks

Joshua Grippo 06/18/2003 Issue 2260 Made modifications to account for the recipientID and the purchaseType '''''''''''''''''''''''''''''

See Also

SubscriptionSave Class | Aptify.Applications.OrderEntry.Subscriptions Namespace


SubscriptionSave.GetCancelledIssues Method

protected virtual long GetCancelledIssues(
OrderLinesEntity OrderLineGE,
ref Decimal& OriginalQuantity,
Int64 RecipientID,
SubscriptionSave.PurchaseType PurchaseType,
Boolean ShowErrors
);

See Also

SubscriptionSave Class | Aptify.Applications.OrderEntry.Subscriptions Namespace


SubscriptionSave.GetChapterID Method

This method is responsible for determining the Chapter ID for the given Order Detail line item the default logic is to check to see if there is a ChapterID populated in the OrderLine entity (ChapterID field) and if there is NOT, then return -1

protected virtual long GetChapterID(
OrderLinesEntity OrderLineGE
);

Parameters

OrderLineGE

Return Value

Remarks

See Also

SubscriptionSave Class | Aptify.Applications.OrderEntry.Subscriptions Namespace


SubscriptionSave.GetCompanyJoinDate Method

This method is responsible for returning the join date associated with the provided PersonID. The default implementation calls the spGetPersonJoinDate in the database.

protected virtual DateTime GetCompanyJoinDate(
Int64 CompanyID
);

Parameters

CompanyID

Return Value

Remarks

See Also

SubscriptionSave Class | Aptify.Applications.OrderEntry.Subscriptions Namespace


SubscriptionSave.GetCompanySubscriptionID Method

This method determines if a company (CompanyID) and recipient (RecipientID) specified has an existing subscription for the specified product (ProductID). If there is a subscription associated with the combination of those parameters, the SubscriptionID is returned. If no such subscription exists, the value of -1 is returned. The implementation of this method in the base class uses the spFindIndividualSubscription stored procedure in the database.

protected virtual long GetCompanySubscriptionID(
Int64 CompanyID,
Int64 ProductID,
Int64 RecipientID,
Int64 ChapterID
);

Parameters

CompanyID
ProductID
RecipientID
ChapterID

Return Value

Remarks

See Also

SubscriptionSave Class | Aptify.Applications.OrderEntry.Subscriptions Namespace


SubscriptionSave.GetIndividualSubscriptionID Method

This method determines if a person specified (SubscriberID) has an existing subscription for the specified product (ProductID). If there is a subscription associated with the combination of those parameters, the SubscriptionID is returned. If no such subscription exists, the value of -1 is returned. The implementation of this method in the base class uses the spFindIndividualSubscription stored procedure in the database.

protected virtual long GetIndividualSubscriptionID(
Int64 SubscriberID,
Int64 ProductID,
Int64 ChapterID
);

Parameters

SubscriberID
ProductID
ChapterID

Return Value

Remarks

See Also

SubscriptionSave Class | Aptify.Applications.OrderEntry.Subscriptions Namespace


SubscriptionSave.GetPersonCompanyID Method

This method is responsible for determining the Company ID associated with a given individual. The default implementation of this method uses the spGetPerson stored procedure and returns the CompanyID field on the Person record. Starting with Aptify 4.5 SP2, this method is called when the Subscription's Entity Attribute, SubscriberCompanyBehavior, is Person, or when the Entity Attribute value is Order and the Order does not specify a Ship To Company.

protected virtual long GetPersonCompanyID(
Int64 PersonID
);

Parameters

PersonID

Return Value

Remarks

See Also

SubscriptionSave Class | Aptify.Applications.OrderEntry.Subscriptions Namespace


SubscriptionSave.GetPersonJoinDate Method

This method is responsible for returning the join date associated with the provided PersonID. The default implementation calls the spGetPersonJoinDate in the database.

protected virtual DateTime GetPersonJoinDate(
Int64 PersonID
);

Parameters

PersonID

Return Value

Remarks

See Also

SubscriptionSave Class | Aptify.Applications.OrderEntry.Subscriptions Namespace


SubscriptionSave.GetProductDistributionTypeID Method

This method is responsible for returning the Distribution Type ID associated with a given product

protected virtual int GetProductDistributionTypeID(
OrderLinesEntity OrderLineGE
);

Parameters

OrderLineGE

Return Value

Remarks

See Also

SubscriptionSave Class | Aptify.Applications.OrderEntry.Subscriptions Namespace


SubscriptionSave.GetProductIssueDays Method

This method is responsible for returning the number of days that are associated as an interval between each issue of the specified product. The default implementation of this method in the base class executes the spGetProductIssueDays stored procedure in the database to handle the logic.

protected virtual long GetProductIssueDays(
OrderLinesEntity OrderLineGE
);

Parameters

OrderLineGE

Return Value

Remarks

See Also

SubscriptionSave Class | Aptify.Applications.OrderEntry.Subscriptions Namespace


SubscriptionSave.GetProductIssues Method

This method is responsible for returning the number of issues that are defined in the Product record. The default implementation of this method in the base class uses the OrderProductCache to retrieve the number of issues. For subscription products, this value will always be > 0.

protected virtual long GetProductIssues(
OrderLinesEntity OrderLineGE
);

Parameters

OrderLineGE

Return Value

Remarks

See Also

SubscriptionSave Class | Aptify.Applications.OrderEntry.Subscriptions Namespace


GetPurchaseType Method

Aptify 5.0 Software Development Kit (SDK)

SubscriptionSave.GetPurchaseType Method

This method is responsible for returning an enumerated type that represents the type of purchase for a given Order Line. Purchase type can be either individual level or company level.

Overload List

This method is responsible for returning an enumerated type that represents the type of purchase for a given Order Line. Purchase type can be either individual level or company level.

protected virtual PurchaseType GetPurchaseType(AptifyGenericEntityBase);

This method is responsible for returning an enumerated type that represents the type of purchase for a given string value purchase type. Purchase type can be either individual level or company level.

protected virtual PurchaseType GetPurchaseType(String);

See Also

SubscriptionSave Class | Aptify.Applications.OrderEntry.Subscriptions Namespace


SubscriptionSave.GetPurchaseType Method (AptifyGenericEntityBase)

This method is responsible for returning an enumerated type that represents the type of purchase for a given Order Line. Purchase type can be either individual level or company level.

protected virtual PurchaseType GetPurchaseType(
AptifyGenericEntityBase OrderDetailGE
);

Parameters

OrderDetailGE

Return Value

Remarks

See Also

SubscriptionSave Class | Aptify.Applications.OrderEntry.Subscriptions Namespace | SubscriptionSave.GetPurchaseType Overload List


SubscriptionSave.GetPurchaseType Method (String)

This method is responsible for returning an enumerated type that represents the type of purchase for a given string value purchase type. Purchase type can be either individual level or company level.

protected virtual PurchaseType GetPurchaseType(
String PurchaseTypeString
);

Parameters

PurchaseTypeString

Return Value

Remarks

See Also

SubscriptionSave Class | Aptify.Applications.OrderEntry.Subscriptions Namespace | SubscriptionSave.GetPurchaseType Overload List


SubscriptionSave.GetRecipientID Method

This method is responsible for determining the Recipient Person for the given Order Detail line item the default logic is to check to see if there is a recipient defined at the Order Detail level (SubscriberID on the OrderDetail) and if there is NOT, then use the Ship To from the Order level

protected virtual long GetRecipientID(
OrderLinesEntity OrderLineGE
);

Parameters

OrderLineGE

Return Value

Remarks

See Also

SubscriptionSave Class | Aptify.Applications.OrderEntry.Subscriptions Namespace


SubscriptionSave.GetSubscriberCompanyID Method

This method is responsible for returning the ID of the Company this is used to populate the Subscription's SubscriberCompanyID. The SubscriberCompanyID indicates the Company that is both the Subscriber and Recipient for a Subscription. There is an Entity Attribute on the Subscriptions Entity, SubscriberCompanyBehavior, that affects the behavior in this method. If the Entity Attribute does not exist or has a value of Order, the Order's ShipToCompanyID will be returned, if the Order's ShipToCompanyID is greater than 0. If the Order's ShipToCompanyID is less than or equal to 0 or the SubscriberCompanyBehavior Attribute value is Person, call the GetPersonCompanyID method to retrieve the CompanyID based on the PersonID parameter value.

protected virtual long GetSubscriberCompanyID(
OrderLinesEntity OrderLineGE,
Int64 PersonID
);

Parameters

OrderLineGE
OrderLines Entity object for the Order Line being processed.
PersonID
ID of the Person representing the Subscription's Recipient

Return Value

ID of the Subscriber (and Recipient) Company for a Company-based Subscription

Remarks

See Also

SubscriptionSave Class | Aptify.Applications.OrderEntry.Subscriptions Namespace


SubscriptionSave.GetSubscriptionID Method

This method is responsible for determining the Subscription ID to use for a given Order Detail line item. Subscription may or may not exist that matches the information in the Order Detail. Subscriptions are either Company level or Individual Level. This method checks the Purchase Type and the RecipientCompanyID and if RecipientCompanyID > 0 and PurchaseType=Company then the method calls the GetCompanySubscriptionID() method, otherwise the GetIndividualSubscriptionID() method is called.

protected virtual long GetSubscriptionID(
OrderLinesEntity OrderLineGE,
Int64 RecipientID,
Int64 RecipientCompanyID,
SubscriptionSave.PurchaseType PurchaseType,
Int64 ChapterID
);

Parameters

OrderLineGE
RecipientID
Person ID
RecipientCompanyID
Company ID
PurchaseType
ChapterID
Chapter ID for the subscription

Return Value

The subscription ID to renew, if found, or the value -1 if no subscription is found that matches the provided parameters

Remarks

See Also

SubscriptionSave Class | Aptify.Applications.OrderEntry.Subscriptions Namespace


SubscriptionSave.GetSubscriptionPurchaseStartDate Method

This method is responsible for determining the start date for an individual subscription purchase within a subscription using the Original Order Detail ID. If no match is found, the Order Date is returned.

protected virtual DateTime GetSubscriptionPurchaseStartDate(
AptifyGenericEntityBase SubscriptionGE,
OrderLinesEntity OrderLineGE
);

Parameters

SubscriptionGE
OrderLineGE

Return Value

Remarks

See Also

SubscriptionSave Class | Aptify.Applications.OrderEntry.Subscriptions Namespace


GetSubscriptionStartDate Method

Aptify 5.0 Software Development Kit (SDK)

SubscriptionSave.GetSubscriptionStartDate Method

Overload List

protected virtual DateTime GetSubscriptionStartDate(Int64,OrderLinesEntity);

This method is responsible for determining the start date for a subscription. It attempts to call the GetSubsStartDate() method in the object that implements ISubscriptionDate. If that method fails then an exception is thrown to the calling function

protected virtual DateTime GetSubscriptionStartDate(Int64,Int64,OrderLinesEntity);

See Also

SubscriptionSave Class | Aptify.Applications.OrderEntry.Subscriptions Namespace


SubscriptionSave.GetSubscriptionStartDate Method (Int64, OrderLinesEntity)

protected virtual DateTime GetSubscriptionStartDate(
Int64 SubscriptionID,
OrderLinesEntity OrderLineGE
);

See Also

SubscriptionSave Class | Aptify.Applications.OrderEntry.Subscriptions Namespace | SubscriptionSave.GetSubscriptionStartDate Overload List


SubscriptionSave.GetSubscriptionStartDate Method (Int64, Int64, OrderLinesEntity)

This method is responsible for determining the start date for a subscription. It attempts to call the GetSubsStartDate() method in the object that implements ISubscriptionDate. If that method fails then an exception is thrown to the calling function

protected virtual DateTime GetSubscriptionStartDate(
Int64 SubscriberID,
Int64 SubscriberCompanyID,
OrderLinesEntity OrderLineGE
);

Parameters

SubscriberID
SubscriberCompanyID
OrderLineGE

Return Value

Remarks

See Also

SubscriptionSave Class | Aptify.Applications.OrderEntry.Subscriptions Namespace | SubscriptionSave.GetSubscriptionStartDate Overload List


SubscriptionSave.GetSubscriptionStatusID Method

This method is responsible for returning the ID value associated with the Subscription Status name specified in the Status parameter. If a record is not found that matches the specified status name, the value in DefaultValue is returned. The implementation of this method in the base class uses the spGetSubsStatusID stored procedure. Since the Subscription Status entity rarely changes, this method uses caching by default to improve performance.

protected virtual long GetSubscriptionStatusID(
String Status,
Int64 DefaultValue
);

Parameters

Status
DefaultValue

Return Value

Remarks

See Also

SubscriptionSave Class | Aptify.Applications.OrderEntry.Subscriptions Namespace


SubscriptionSave.HandleSubscriptionPurchase Method

This method is responsible for handling the subscription purchase aspects of creating/updating a subscription. The method's basic logic is to determine if a SubscriptionPurchase exists in the provided Subscription that matches the OrderGE.RecordID. If a SubscriptionPurchase does exist, it is updated. If a SubscriptionPurchase does not exist, one is added for this order

protected virtual void HandleSubscriptionPurchase(
Int64 SubscriberID,
Int64 SubscriberCompanyID,
AptifyGenericEntityBase SubscriptionGE,
OrderLinesEntity OrderLineGE,
Int64 NumIssues,
Int64 NumCopies,
ref DateTime& StartDate
);

Parameters

SubscriberID
SubscriberCompanyID
SubscriptionGE
OrderLineGE
NumIssues
NumCopies
StartDate

Remarks

See Also

SubscriptionSave Class | Aptify.Applications.OrderEntry.Subscriptions Namespace


SubscriptionSave.IsDuesProduct Method

This method is responsible for determining if the specified ProductID is a 'Dues' Product meaning that the DefaultDuesProduct BIT field on the Product entity is set to 1. This method executes the spGetDefaultDuesProductFromProduct stored procedure to determine the result.

protected virtual bool IsDuesProduct(
Int64 ProductID
);

Parameters

ProductID

Return Value

Remarks

See Also

SubscriptionSave Class | Aptify.Applications.OrderEntry.Subscriptions Namespace


SubscriptionSave.LoadAndUpdateSubscriptionHeader Method

This method is responsible for loading a subscription and updating the basic header information in the Subscription entity top-level and then returning it.

protected virtual AptifyGenericEntityBase LoadAndUpdateSubscriptionHeader(
SubscriptionSave.PurchaseType PurchaseType,
Int64 SubscriptionID,
Int64 SubscriberID
);

Parameters

PurchaseType
SubscriptionID
SubscriberID

Return Value

A Subscription GE object if the method is succesful, Nothing otherwise

Remarks

See Also

SubscriptionSave Class | Aptify.Applications.OrderEntry.Subscriptions Namespace


SubscriptionSave.OnStatusUpdate Method

This method is responsible for raising the StatusUpdate event and is called from within the SubscriptionSave() method for each iteration through the OrderGE Sub-Type for OrderLines

protected virtual void OnStatusUpdate(
Int32 LineNumber,
Int32 PercentComplete,
ref Boolean& Cancel
);

Parameters

LineNumber
PercentComplete
Cancel

Remarks

See Also

SubscriptionSave Class | Aptify.Applications.OrderEntry.Subscriptions Namespace


SaveCancellationSubscriptions Method

Aptify 5.0 Software Development Kit (SDK)

SubscriptionSave.SaveCancellationSubscriptions Method

Overload List

public virtual bool SaveCancellationSubscriptions(OrdersEntity);

public virtual bool SaveCancellationSubscriptions(OrdersEntity,Boolean);

See Also

SubscriptionSave Class | Aptify.Applications.OrderEntry.Subscriptions Namespace


SubscriptionSave.SaveCancellationSubscriptions Method (OrdersEntity)

public virtual bool SaveCancellationSubscriptions(
OrdersEntity OrderGE
);

Implements

ISubscriptionSave.

See Also

SubscriptionSave Class | Aptify.Applications.OrderEntry.Subscriptions Namespace | SubscriptionSave.SaveCancellationSubscriptions Overload List


SubscriptionSave.SaveCancellationSubscriptions Method (OrdersEntity, Boolean)

public virtual bool SaveCancellationSubscriptions(
OrdersEntity OrderGE,
Boolean ShowErrors
);

Implements

ISubscriptionSave.

See Also

SubscriptionSave Class | Aptify.Applications.OrderEntry.Subscriptions Namespace | SubscriptionSave.SaveCancellationSubscriptions Overload List


SubscriptionSave.SaveOrderDetailSubscription Method

This method is called once for each Order Detail within the order from the SaveSubscriptions() method and is responsible for saving subscriptions associated with a single order line. The basic process is to determine if subscriptions are required for the order detail, and if so, to either renew an existing subscription that matches the Recipient information and Product information in the Order Detail GE, or to create a new subscription.

protected virtual bool SaveOrderDetailSubscription(
OrderLinesEntity OrderLineGE,
Boolean AllowGUI
);

Parameters

OrderLineGE
AllowGUI
If this parameter is set to True, the object will display error messages to the user. If this is set to False, no messages will be displayed to the user

Return Value

True if succesful, False otherwise

Remarks

See Also

SubscriptionSave Class | Aptify.Applications.OrderEntry.Subscriptions Namespace


SaveSubscriptions Method

Aptify 5.0 Software Development Kit (SDK)

SubscriptionSave.SaveSubscriptions Method

Overload List

public virtual bool SaveSubscriptions(OrdersEntity);

This method is resopnsible for handling subscription creation and renewal based on the following set of rules. The methods that are called from within this object can be directly called and/or overriden as required for configuration purposes. This method iterates through all of the order lines within the the provided OrderGE and will call the SaveOrderDetailSubscription() for each line item in the order.

public virtual bool SaveSubscriptions(OrdersEntity,Boolean);

See Also

SubscriptionSave Class | Aptify.Applications.OrderEntry.Subscriptions Namespace


SubscriptionSave.SaveSubscriptions Method (OrdersEntity)

public virtual bool SaveSubscriptions(
OrdersEntity OrderGE
);

Implements

ISubscriptionSave.

See Also

SubscriptionSave Class | Aptify.Applications.OrderEntry.Subscriptions Namespace | SubscriptionSave.SaveSubscriptions Overload List


SubscriptionSave.SaveSubscriptions Method (OrdersEntity, Boolean)

This method is resopnsible for handling subscription creation and renewal based on the following set of rules. The methods that are called from within this object can be directly called and/or overriden as required for configuration purposes. This method iterates through all of the order lines within the the provided OrderGE and will call the SaveOrderDetailSubscription() for each line item in the order.

public virtual bool SaveSubscriptions(
OrdersEntity OrderGE,
Boolean ShowErrors
);

Parameters

OrderGE
ShowErrors
If this parameter is set to True, the object will display error messages to the user. If this is set to False, no messages will be displayed to the user

Return Value

True if the method is a success, False otherwise

Implements

ISubscriptionSave.

Remarks

See Also

SubscriptionSave Class | Aptify.Applications.OrderEntry.Subscriptions Namespace | SubscriptionSave.SaveSubscriptions Overload List


SubscriptionSave.SetCompanyJoinDate Method

This method is responsible for setting the join date field in the Company record to the provided value.

protected virtual bool SetCompanyJoinDate(
Int64 CompanyID,
DateTime JoinDate
);

Parameters

CompanyID
JoinDate

Return Value

Remarks

See Also

SubscriptionSave Class | Aptify.Applications.OrderEntry.Subscriptions Namespace


SubscriptionSave.SetPersonJoinDate Method

This method is responsible for setting the join date field in the Person record to the provided value.

protected virtual bool SetPersonJoinDate(
Int64 PersonID,
DateTime JoinDate
);

Parameters

PersonID
JoinDate

Return Value

Remarks

See Also

SubscriptionSave Class | Aptify.Applications.OrderEntry.Subscriptions Namespace


SubscriptionSave.SetSubscriptionPurchaseAttributes Method

This method is responsbile for setting up the attributes on a Subscription Purchase based on the provided information related to the number of issues, start date, end date, etc.

protected virtual void SetSubscriptionPurchaseAttributes(
AptifyGenericEntityBase SubscriptionPurchaseGE,
Int64 NumIssues,
DateTime StartDate,
DateTime EndDate,
OrderLinesEntity OrderLineGE
);

Parameters

SubscriptionPurchaseGE
NumIssues
StartDate
EndDate
OrderLineGE

Remarks

See Also

SubscriptionSave Class | Aptify.Applications.OrderEntry.Subscriptions Namespace


SubscriptionSave.UpdateCompanyJoinDate Method

This method is called from the UpdateJoinDate() method whenever a company level join date needs to be update. This method is responsible for checking the current join date of the company and then updating it as appropriate.

protected virtual void UpdateCompanyJoinDate(
AptifyGenericEntityBase SubscriptionGE,
AptifyGenericEntityBase OrderGE,
DateTime StartDate
);

Parameters

SubscriptionGE
OrderGE
StartDate

Remarks

See Also

SubscriptionSave Class | Aptify.Applications.OrderEntry.Subscriptions Namespace


SubscriptionSave.UpdateJoinDate Method

This method is responsible for updating the join date information at the company or person level. First, this method will only update the join date if the subscription has one and ONLY one subscription purchase (as join dates should not be updated for renewals). This method then calls IsDuesProduct() to determine if an update to the join date is requried or note. If it is, then the method updates either the person or company linked to the subscription. If SubscriberCompanyID is set then, the Company Join date will be updated, otherwise the Person join date will be updated using UpdateCompanyJoinDate() and UpdatePersonJoinDate() methods respectively.

protected virtual void UpdateJoinDate(
AptifyGenericEntityBase SubscriptionGE,
AptifyGenericEntityBase OrderGE,
DateTime StartDate
);

Parameters

SubscriptionGE
OrderGE
StartDate
Start Date of the Subscription GE being passed in

Remarks

See Also

SubscriptionSave Class | Aptify.Applications.OrderEntry.Subscriptions Namespace


SubscriptionSave.UpdateOriginalOrderSubsPurchase Method

This method is responsible for updating the subscription purchase for the original order ID provided in the Subscription GE to the new number of issues specified in the provided parameter by setting the end-date of the subscription purchase appropriately.

protected virtual bool UpdateOriginalOrderSubsPurchase(
AptifyGenericEntityBase SubscriptionGE,
OrderLinesEntity OrderLineGE,
Int64 NewNumIssues
);

Parameters

SubscriptionGE
OrderLineGE
NewNumIssues

Return Value

True if succesful, False otherwise

Remarks

See Also

SubscriptionSave Class | Aptify.Applications.OrderEntry.Subscriptions Namespace


SubscriptionSave.UpdatePersonJoinDate Method

This method is called from the UpdateJoinDate() method whenever a person level join date needs to be update. This method is responsible for checking the current join date of the person and then updating it as appropriate.

protected virtual void UpdatePersonJoinDate(
AptifyGenericEntityBase SubscriptionGE,
AptifyGenericEntityBase OrderGE,
DateTime StartDate
);

Parameters

SubscriptionGE
OrderGE
StartDate

Remarks

See Also

SubscriptionSave Class | Aptify.Applications.OrderEntry.Subscriptions Namespace


SubscriptionSave Events

The events of the SubscriptionSave class are listed below. For a complete list of SubscriptionSave class members, see the SubscriptionSave Members topic.

Public Instance Events

StatusUpdate

See Also

SubscriptionSave Class | Aptify.Applications.OrderEntry.Subscriptions Namespace


SubscriptionSave.ISubscriptionSave.StatusUpdateEventHandler Event

public event ISubscriptionSave.StatusUpdateEventHandler StatusUpdate;

Implements

ISubscriptionSave.

See Also

SubscriptionSave Class | Aptify.Applications.OrderEntry.Subscriptions Namespace


SubscriptionSave.PurchaseType Enumeration

Enumeration of subscription purchase types

public enum SubscriptionSave.PurchaseType

Remarks

Members

Member Name | Description
Individual |
Company |

Requirements

Namespace: Aptify.Applications.OrderEntry.Subscriptions

Assembly: SubscriptionSave (in SubscriptionSave.dll)

See Also

Aptify.Applications.OrderEntry.Subscriptions Namespace


Aptify.Applications.OrderEntry.WindowsControls

Aptify 5.0 Software Development Kit (SDK)

Aptify.Applications.OrderEntry.WindowsControls Namespace

This namespace contains the objects that define the appearance of the Orders form.

Namespace hierarchy

Classes

Class | Description
AddressSelector
BulkOrderCustomers | Implements a grid control for viewing/editing the BulkOrderCustomers sub-type and easily changing defaults/overrides for each customer
BulkOrderCustomersLayout
BulkOrdersWizard | Implements a wizard UI that allows a user to create new bulk orders and import views of persons and/or companies into the BulkOrderCustomers sub-type.
ColorPicker
InvoiceMessage
OrderGLEntryLayout
OrderLayout
OrderLines | Order Line Control Base Class
OrderLinesExtender
OrderLinesLayout
OrderLineTaxesLayout
OrderMain | This class is intended to be used as the main display Form Component for display an Order. The class in turn displays 3 templates within it. The class will seek out a Form Template for Orders.TopArea, Orders.BottomArea and Orders.MiddleArea to place into its three pane areas. User Level Templates are looked at first that derive from the Global templates with those names, Group level templates are then looked at and finally global level usage scope templates are looked at. Furthermore, the Rank field is evaluated in selecting the appropriate template to display for a given area. To plug in form templates for the Top, Middle and Bottom Areas, make sure the following attributes are set in the Form Templates Entity. NOTE: You can change the Names of the below Form Templates, however the Entity Attributes corresponding to those names in the Orders entity need to be updated as well. 1) Top Area (Global Template) Entity: Orders Name: Orders.TopArea UsageScope: Global Rank: 0 2) Middle Area (Global Template) Entity: Orders Name: Orders.MiddleArea UsageScope: Global Rank: 0 3) Bottom Area (Global Template) Entity: Orders Name: Orders.BottomArea UsageScope: Global Rank: 0 For Group/User level usage scope templates, they can be named anything but must be derived from the Global Template settings using the BaseTemplateID field
OrderMeetingDetailLayout
OrderPaymentsLayout
OrderShipmentsLayout
OrderShipmentTaxesLayout
OrderSTLayoutBase
OrderTextButton
SessionInfo
SessionsControl
SessionsUtility
ShippingHandlingDetailsForm
TaxDetailsForm
TaxDetailsForm.SalesTaxInfo

Delegates

Delegate | Description
AddressSelector.AddressSelectedEventHandler |
OrderTextButton.ExtendedButtonClickEventHandler |


AddressSelector Class

For a list of all members of this type, see AddressSelector Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
AddressSelector

public class AddressSelector : FormComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry.WindowsControls

Assembly: OrderControls (in OrderControls.dll)

See Also

AddressSelector Members | Aptify.Applications.OrderEntry.WindowsControls Namespace


AddressSelector Members

AddressSelector overview

Public Instance Constructors

AddressSelector Constructor Initializes a new instance of the AddressSelector class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AddressInfo |
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LoadRelatedAddresses |
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormComponent) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AddressSelected |
AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateContext (inherited from FormComponent) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetImageFromRepository |
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormComponent) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormComponent) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

AddressSelector Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


AddressSelector Constructor

Initializes a new instance of the AddressSelector class.

public AddressSelector();

See Also

AddressSelector Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


AddressSelector Properties

The properties of the AddressSelector class are listed below. For a complete list of AddressSelector class members, see the AddressSelector Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AddressInfo |
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateContext (inherited from FormComponent) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

AddressSelector Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


AddressInfo Property

Aptify 5.0 Software Development Kit (SDK)

AddressSelector.AddressInfo Property

public AddressInfo AddressInfo {get;}

See Also

AddressSelector Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


AddressSelector Methods

The methods of the AddressSelector class are listed below. For a complete list of AddressSelector class members, see the AddressSelector Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LoadRelatedAddresses |
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormComponent) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetImageFromRepository |
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormComponent) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormComponent) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

AddressSelector Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

AddressSelector.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

AddressSelector Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


AddressSelector.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

AddressSelector Class | Aptify.Applications.OrderEntry.WindowsControls Namespace | AddressSelector.Dispose Overload List


AddressSelector.GetImageFromRepository Method

protected virtual Image GetImageFromRepository(
AptifyObjectRepository ObjRep,
String RepositoryLocation
);

See Also

AddressSelector Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


AddressSelector.LoadRelatedAddresses Method

public virtual void LoadRelatedAddresses(
Int64 BillToID,
Int64 BillToCompanyID,
Int64 ShipToID,
Int64 ShipToCompanyID
);

See Also

AddressSelector Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


AddressSelector.OnFormComponentConfig Method

protected override void OnFormComponentConfig(
AptifyFormTemplateContext FormTemplateContext
);

Implements

IFormComponent.

See Also

AddressSelector Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


AddressSelector.OnRefresh Method

protected override void OnRefresh();

Implements

IFormComponent.

See Also

AddressSelector Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


AddressSelector Events

The events of the AddressSelector class are listed below. For a complete list of AddressSelector class members, see the AddressSelector Members topic.

Public Instance Events

AddressSelected |
AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

AddressSelector Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


AddressSelector.AddressSelector.AddressSelectedEventHandler Event

public event AddressSelector.AddressSelectedEventHandler AddressSelected;

See Also

AddressSelector Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


AddressSelector.AddressSelectedEventHandler Delegate

public delegate void AddressSelector.AddressSelectedEventHandler(
AddressInfo SelectedAddressInfo
);

Requirements

Namespace: Aptify.Applications.OrderEntry.WindowsControls

Assembly: OrderControls (in OrderControls.dll)

See Also

Aptify.Applications.OrderEntry.WindowsControls Namespace


BulkOrderCustomers Class

Implements a grid control for viewing/editing the BulkOrderCustomers sub-type and easily changing defaults/overrides for each customer

For a list of all members of this type, see BulkOrderCustomers Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
AptifyControlBase
BulkOrderCustomers

public class BulkOrderCustomers : AptifyControlBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.OrderEntry.WindowsControls

Assembly: BulkOrdersControls (in BulkOrdersControls.dll)

See Also

BulkOrderCustomers Members | Aptify.Applications.OrderEntry.WindowsControls Namespace


BulkOrderCustomers Members

BulkOrderCustomers overview

Protected Static Fields

c_sProductIDPrefix

Public Instance Constructors

BulkOrderCustomers Constructor Initializes a new instance of the BulkOrderCustomers class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Control (inherited from AptifyControlBase) |
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DataControl (inherited from AptifyControlBase) | Adds a reference to the object for the data control. In the case of it being added, the reference to the bound control base object is added to the data controls collection.
DisableGeDataTransfer (inherited from AptifyControlBase) | If true, the implementer is required to move the value to/from the bound control to the GE or other data access method.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
FieldHelp (inherited from AptifyControlBase) |
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateContext (inherited from AptifyControlBase) | Returns the reference that if is local that is returned else if a DataControl exists, it is returned.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpObject (inherited from AptifyControlBase) | This method is responsible for returning the context-specific help Object file location in the Aptify Object repository. The base class implementation returns the entity-level help, if available, and if not, returns the DefaultHelpObject
HelpURL (inherited from AptifyControlBase) | This method is responsible for returning the context-specific help URL file location within the HelpObject to use. The base class implementation returns the entity-level help URL, if available, and if not, returns Nothing, which results in the content page being displayed.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
ObjectRepository (inherited from AptifyControlBase) |
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BoundControlConfig |
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ClearData (inherited from AptifyControlBase) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DisplayControlHelp (inherited from AptifyControlBase) | This method will display control-level help information. This method will use the HelpTitle and HelpText overridable members to display the Field Help object from Aptify.Framework.WindowsControls.FieldHelp. If the title and text is desired to be overriden it is not necessary to override this method, rather override the HelpTitle and HelpText properties which are used by this method.
DisplayEntityHelp (inherited from AptifyControlBase) | This method is responsible for displaying the help file to the user and will attempt to provide context sensitive help based on the particular entity being displayed. If no entity-specific help file is available for the user then the standard Aptify Shell.Aptify Help file will be used to display help to the user. Override this method in sub-classes to change the method for displaying help.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DoLocalization |
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetDefaultHelpObject (inherited from AptifyControlBase) | This method returns the default help object file in the Aptify Object repository to be used in the event that no entity-specific file exists
GetEntitySpecificHelpObject (inherited from AptifyControlBase) | This method returns the Aptify Object Repository Object location for the help file that is specific to this entity.
GetEntitySpecificHelpTopicURL (inherited from AptifyControlBase) | This method returns the Topic URL location within the help file that is specific to this entity.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseValueChanged (inherited from AptifyControlBase) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from AptifyControlBase) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetUserCredential (inherited from AptifyControlBase) |
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
TransferDataToObject (inherited from AptifyControlBase) | Implemented by the sub class to transfer data from the control to the Generic Entity (GE) or some other data access tool.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AfterDisplayEntityHelp (inherited from AptifyControlBase) | This event is fired after the help file is displayed.
AptifyControlBaseTextChanged (inherited from AptifyControlBase) |
AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BeforeDisplayEntityHelp (inherited from AptifyControlBase) | This event is fired before the help file is displayed. To prevent help from being displayed set the Cancel parameter to True.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from AptifyControlBase) |
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from AptifyControlBase) |
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from AptifyControlBase) |
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from AptifyControlBase) |
KeyPress (inherited from AptifyControlBase) |
KeyUp (inherited from AptifyControlBase) |
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from AptifyControlBase) |
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from AptifyControlBase) |
MouseEnter (inherited from AptifyControlBase) |
MouseHover (inherited from AptifyControlBase) |
MouseLeave (inherited from AptifyControlBase) |
MouseMove (inherited from AptifyControlBase) |
MouseUp (inherited from AptifyControlBase) |
MouseWheel (inherited from AptifyControlBase) |
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from AptifyControlBase) |
Validated (inherited from AptifyControlBase) |
Validating (inherited from AptifyControlBase) |
ValueChanged (inherited from AptifyControlBase) |
VisibleChanged (inherited from AptifyControlBase) |

Protected Instance Fields

m_iDataControl (inherited from AptifyControlBase)
m_oAptifyApplication (inherited from AptifyControlBase)
m_oFormTemplateContext (inherited from AptifyControlBase)
m_oUserCredential (inherited from AptifyControlBase)

Protected Instance Properties

AptifyApplication (inherited from AptifyControlBase) | Returns an instance of the Aptify Application Object
AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
CurrencyTypeCache (inherited from AptifyControlBase) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DisplayName (inherited from AptifyControlBase) |
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HelpText (inherited from AptifyControlBase) |
HelpTitle (inherited from AptifyControlBase) | This property is designed to be overriden by subclasses that want to provide a different title. The base class returns "Aptify Help" for this property.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
InternalControl (inherited from AptifyControlBase) | Specifies the Main Control of interest in a composite control.
m_oInternalControl (inherited from AptifyControlBase) |
MyApplication (inherited from AptifyControlBase) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowDisplayHelpHyperlink (inherited from AptifyControlBase) | This property can be overriden by sub-classes to be able to selectively turn on or off the Display Help hyperlink that appears by default on the FieldHelp object.
UserCredential (inherited from AptifyControlBase) |
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
ConfigColumns | This method is responsible for loading up columns based on the products that are specified in the BulkOrderProducts sub-type
ConfigHelp (inherited from AptifyControlBase) | This method configures the base FieldHelp object and sets up a default string in the HelpText field. Sub-Classes should override this to implement specific help relevant to their context of use.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from AptifyControlBase) | Overloaded. Releases all resources used by the Component.
DoFormComponentConfig (inherited from AptifyControlBase) |
Finalize (inherited from AptifyControlBase) |
FormComponentConfig (inherited from AptifyControlBase) |
FormComponentHide (inherited from AptifyControlBase) |
FormComponentShow (inherited from AptifyControlBase) | Overloaded.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetCurrentRowCustomerGE | This method returns the GE object representing the current customer record selected
GetProductIDFromColumn | This method returns the product id corresponding to a specific column
GetRowCustomerGE | This method returns the GE object representing the specified row number
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
LoadCustomers | This method loads up customer data into the grid
LoadSingleCustomerRow |
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnGridAfterEdit | This method is responsible for updating the GE data within the BulkOrderCustomers entity whenever a user changes a cell. The default behavior is to test the quantity value entered against the default quantity for the product, and if it is the same, make sure no BulkOrderCustomerProductOverrides record exists. If the quantity is different from the default quantity, then a BulkOrderCustomerProductOverrides record is created/updated in order to track the different quantity required for the specific customer
OnGridDoubleClick | This method handles the grid double click event and the default behavior is to display the sub-type dialog
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RequiredGECheck (inherited from AptifyControlBase) |
RequiredPropertiesCheck (inherited from AptifyControlBase) |
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

BulkOrderCustomers Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


BulkOrderCustomers Constructor

Initializes a new instance of the BulkOrderCustomers class.

public BulkOrderCustomers();

See Also

BulkOrderCustomers Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


BulkOrderCustomers Fields

The fields of the BulkOrderCustomers class are listed below. For a complete list of BulkOrderCustomers class members, see the BulkOrderCustomers Members topic.

Protected Static Fields

c_sProductIDPrefix

Protected Instance Fields

m_iDataControl (inherited from AptifyControlBase)
m_oAptifyApplication (inherited from AptifyControlBase)
m_oFormTemplateContext (inherited from AptifyControlBase)
m_oUserCredential (inherited from AptifyControlBase)

See Also

BulkOrderCustomers Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


BulkOrderCustomers.c_sProductIDPrefix Field

protected const c_sProductIDPrefix c_sProductIDPrefix = "ProductID_";

See Also

BulkOrderCustomers Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


BulkOrderCustomers Methods

The methods of the BulkOrderCustomers class are listed below. For a complete list of BulkOrderCustomers class members, see the BulkOrderCustomers Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BoundControlConfig |
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ClearData (inherited from AptifyControlBase) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DisplayControlHelp (inherited from AptifyControlBase) | This method will display control-level help information. This method will use the HelpTitle and HelpText overridable members to display the Field Help object from Aptify.Framework.WindowsControls.FieldHelp. If the title and text is desired to be overriden it is not necessary to override this method, rather override the HelpTitle and HelpText properties which are used by this method.
DisplayEntityHelp (inherited from AptifyControlBase) | This method is responsible for displaying the help file to the user and will attempt to provide context sensitive help based on the particular entity being displayed. If no entity-specific help file is available for the user then the standard Aptify Shell.Aptify Help file will be used to display help to the user. Override this method in sub-classes to change the method for displaying help.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DoLocalization |
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetDefaultHelpObject (inherited from AptifyControlBase) | This method returns the default help object file in the Aptify Object repository to be used in the event that no entity-specific file exists
GetEntitySpecificHelpObject (inherited from AptifyControlBase) | This method returns the Aptify Object Repository Object location for the help file that is specific to this entity.
GetEntitySpecificHelpTopicURL (inherited from AptifyControlBase) | This method returns the Topic URL location within the help file that is specific to this entity.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseValueChanged (inherited from AptifyControlBase) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from AptifyControlBase) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetUserCredential (inherited from AptifyControlBase) |
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
TransferDataToObject (inherited from AptifyControlBase) | Implemented by the sub class to transfer data from the control to the Generic Entity (GE) or some other data access tool.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
ConfigColumns | This method is responsible for loading up columns based on the products that are specified in the BulkOrderProducts sub-type
ConfigHelp (inherited from AptifyControlBase) | This method configures the base FieldHelp object and sets up a default string in the HelpText field. Sub-Classes should override this to implement specific help relevant to their context of use.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from AptifyControlBase) | Overloaded. Releases all resources used by the Component.
DoFormComponentConfig (inherited from AptifyControlBase) |
Finalize (inherited from AptifyControlBase) |
FormComponentConfig (inherited from AptifyControlBase) |
FormComponentHide (inherited from AptifyControlBase) |
FormComponentShow (inherited from AptifyControlBase) | Overloaded.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetCurrentRowCustomerGE | This method returns the GE object representing the current customer record selected
GetProductIDFromColumn | This method returns the product id corresponding to a specific column
GetRowCustomerGE | This method returns the GE object representing the specified row number
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
LoadCustomers | This method loads up customer data into the grid
LoadSingleCustomerRow |
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnGridAfterEdit | This method is responsible for updating the GE data within the BulkOrderCustomers entity whenever a user changes a cell. The default behavior is to test the quantity value entered against the default quantity for the product, and if it is the same, make sure no BulkOrderCustomerProductOverrides record exists. If the quantity is different from the default quantity, then a BulkOrderCustomerProductOverrides record is created/updated in order to track the different quantity required for the specific customer
OnGridDoubleClick | This method handles the grid double click event and the default behavior is to display the sub-type dialog
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RequiredGECheck (inherited from AptifyControlBase) |
RequiredPropertiesCheck (inherited from AptifyControlBase) |
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

BulkOrderCustomers Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


BulkOrderCustomers.BoundControlConfig Method

public override void BoundControlConfig();

Implements

IAptifyControlBase.

See Also

BulkOrderCustomers Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


BulkOrderCustomers.ConfigColumns Method

This method is responsible for loading up columns based on the products that are specified in the BulkOrderProducts sub-type

protected virtual void ConfigColumns();

Remarks

See Also

BulkOrderCustomers Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


BulkOrderCustomers.DoLocalization Method

public void DoLocalization();

See Also

BulkOrderCustomers Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


BulkOrderCustomers.GetCurrentRowCustomerGE Method

This method returns the GE object representing the current customer record selected

protected virtual AptifyGenericEntityBase GetCurrentRowCustomerGE();

Return Value

Remarks

See Also

BulkOrderCustomers Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


BulkOrderCustomers.GetProductIDFromColumn Method

This method returns the product id corresponding to a specific column

protected virtual long GetProductIDFromColumn(
Int32 ColumnNum
);

Parameters

ColumnNum

Return Value

Remarks

See Also

BulkOrderCustomers Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


BulkOrderCustomers.GetRowCustomerGE Method

This method returns the GE object representing the specified row number

protected virtual AptifyGenericEntityBase GetRowCustomerGE(
Int32 Row
);

Return Value

Remarks

See Also

BulkOrderCustomers Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


BulkOrderCustomers.LoadCustomers Method

This method loads up customer data into the grid

protected virtual void LoadCustomers();

Remarks

See Also

BulkOrderCustomers Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


BulkOrderCustomers.LoadSingleCustomerRow Method

protected virtual void LoadSingleCustomerRow(
Row GridRow,
AptifyGenericEntityBase CustomerGE
);

See Also

BulkOrderCustomers Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


BulkOrderCustomers.OnGridAfterEdit Method

This method is responsible for updating the GE data within the BulkOrderCustomers entity whenever a user changes a cell. The default behavior is to test the quantity value entered against the default quantity for the product, and if it is the same, make sure no BulkOrderCustomerProductOverrides record exists. If the quantity is different from the default quantity, then a BulkOrderCustomerProductOverrides record is created/updated in order to track the different quantity required for the specific customer

protected virtual void OnGridAfterEdit(
Object sender,
RowColEventArgs e
);

Parameters

sender
e

Remarks

See Also

BulkOrderCustomers Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


BulkOrderCustomers.OnGridDoubleClick Method

This method handles the grid double click event and the default behavior is to display the sub-type dialog

protected virtual void OnGridDoubleClick(
Object sender,
EventArgs e
);

Parameters

sender
e

Remarks

See Also

BulkOrderCustomers Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


BulkOrderCustomersLayout Class

For a list of all members of this type, see BulkOrderCustomersLayout Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
BulkOrderCustomersLayout

public class BulkOrderCustomersLayout : FormTemplateLayout

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry.WindowsControls

Assembly: BulkOrdersControls (in BulkOrdersControls.dll)

See Also

BulkOrderCustomersLayout Members | Aptify.Applications.OrderEntry.WindowsControls Namespace


BulkOrderCustomersLayout Members

BulkOrderCustomersLayout overview

Public Instance Constructors

BulkOrderCustomersLayout Constructor Initializes a new instance of the BulkOrderCustomersLayout class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
m_aptPaymentInfo |
m_cmbBulkOrderCustomerStatus |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormTemplateLayout) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControls |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetPaymentInfoControlVisibility |
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

BulkOrderCustomersLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


BulkOrderCustomersLayout Constructor

Initializes a new instance of the BulkOrderCustomersLayout class.

public BulkOrderCustomersLayout();

See Also

BulkOrderCustomersLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


BulkOrderCustomersLayout Properties

The properties of the BulkOrderCustomersLayout class are listed below. For a complete list of BulkOrderCustomersLayout class members, see the BulkOrderCustomersLayout Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
m_aptPaymentInfo |
m_cmbBulkOrderCustomerStatus |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

BulkOrderCustomersLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


m_aptPaymentInfo Property

Aptify 5.0 Software Development Kit (SDK)

BulkOrderCustomersLayout.m_aptPaymentInfo Property

protected virtual PaymentInfoControl m_aptPaymentInfo {get; set;}

See Also

BulkOrderCustomersLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


m_cmbBulkOrderCustomerStatus Property

Aptify 5.0 Software Development Kit (SDK)

BulkOrderCustomersLayout.m_cmbBulkOrderCustomerStatus Property

protected virtual AptifyComboBox m_cmbBulkOrderCustomerStatus {get; set;}

See Also

BulkOrderCustomersLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


BulkOrderCustomersLayout Methods

The methods of the BulkOrderCustomersLayout class are listed below. For a complete list of BulkOrderCustomersLayout class members, see the BulkOrderCustomersLayout Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormTemplateLayout) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControls |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetPaymentInfoControlVisibility |
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

BulkOrderCustomersLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


BulkOrderCustomersLayout.FindControls Method

protected virtual void FindControls(
String FormTemplateLayoutName
);

See Also

BulkOrderCustomersLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


BulkOrderCustomersLayout.OnFormTemplateLoaded Method

protected override void OnFormTemplateLoaded(
FormTemplateLayout.FormTemplateLoadedEventArgs e
);

See Also

BulkOrderCustomersLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


BulkOrderCustomersLayout.SetPaymentInfoControlVisibility Method

protected void SetPaymentInfoControlVisibility();

See Also

BulkOrderCustomersLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


BulkOrdersWizard Class

Implements a wizard UI that allows a user to create new bulk orders and import views of persons and/or companies into the BulkOrderCustomers sub-type.

For a list of all members of this type, see BulkOrdersWizard Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
BulkOrdersWizard

public class BulkOrdersWizard : Form, IAptifyAction

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.OrderEntry.WindowsControls

Assembly: BulkOrdersWizard (in BulkOrdersWizard.dll)

See Also

BulkOrdersWizard Members | Aptify.Applications.OrderEntry.WindowsControls Namespace


BulkOrdersWizard Members

BulkOrdersWizard overview

Public Instance Constructors

BulkOrdersWizard Constructor Initializes a new instance of the BulkOrdersWizard class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoAction | Overloaded.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

BulkOrdersWizard Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


BulkOrdersWizard Constructor

Initializes a new instance of the BulkOrdersWizard class.

public BulkOrdersWizard();

See Also

BulkOrdersWizard Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


BulkOrdersWizard Methods

The methods of the BulkOrdersWizard class are listed below. For a complete list of BulkOrdersWizard class members, see the BulkOrdersWizard Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoAction | Overloaded.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

BulkOrdersWizard Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

BulkOrdersWizard.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

BulkOrdersWizard Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


BulkOrdersWizard.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

BulkOrdersWizard Class | Aptify.Applications.OrderEntry.WindowsControls Namespace | BulkOrdersWizard.Dispose Overload List


DoAction Method

Aptify 5.0 Software Development Kit (SDK)

BulkOrdersWizard.DoAction Method

Overload List

public void DoAction(AptifyApplication,Int64);

public void DoAction(AptifyApplication,Int64,Int64);

public void DoAction(AptifyApplication,Int64,Int64,params Object[]);

public void DoAction(AptifyApplication,Int64,params String[]);

See Also

BulkOrdersWizard Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


BulkOrdersWizard.DoAction Method (AptifyApplication, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID
);

Implements

IAptifyAction.

See Also

BulkOrdersWizard Class | Aptify.Applications.OrderEntry.WindowsControls Namespace | BulkOrdersWizard.DoAction Overload List


BulkOrdersWizard.DoAction Method (AptifyApplication, Int64, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID
);

Implements

IAptifyAction.

See Also

BulkOrdersWizard Class | Aptify.Applications.OrderEntry.WindowsControls Namespace | BulkOrdersWizard.DoAction Overload List


BulkOrdersWizard.DoAction Method (AptifyApplication, Int64, Int64, Object[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID,
params Object[] SelectedItems
);

Implements

IAptifyAction.

See Also

BulkOrdersWizard Class | Aptify.Applications.OrderEntry.WindowsControls Namespace | BulkOrdersWizard.DoAction Overload List


BulkOrdersWizard.DoAction Method (AptifyApplication, Int64, String[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
params String[] SelectedItems
);

Implements

IAptifyAction.

See Also

BulkOrdersWizard Class | Aptify.Applications.OrderEntry.WindowsControls Namespace | BulkOrdersWizard.DoAction Overload List


ColorPicker Class

For a list of all members of this type, see ColorPicker Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
ColorPicker

public class ColorPicker : FormComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry.WindowsControls

Assembly: ColorPickerControls (in ColorPickerControls.dll)

See Also

ColorPicker Members | Aptify.Applications.OrderEntry.WindowsControls Namespace


ColorPicker Members

ColorPicker overview

Public Instance Constructors

ColorPicker Constructor Initializes a new instance of the ColorPicker class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateContext (inherited from FormComponent) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormComponent) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormComponent) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ColorPicker Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


ColorPicker Constructor

Initializes a new instance of the ColorPicker class.

public ColorPicker();

See Also

ColorPicker Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


ColorPicker Methods

The methods of the ColorPicker class are listed below. For a complete list of ColorPicker class members, see the ColorPicker Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormComponent) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormComponent) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ColorPicker Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

ColorPicker.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

ColorPicker Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


ColorPicker.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

ColorPicker Class | Aptify.Applications.OrderEntry.WindowsControls Namespace | ColorPicker.Dispose Overload List


ColorPicker.OnFormComponentConfig Method

protected override void OnFormComponentConfig(
AptifyFormTemplateContext FormTemplateContext
);

Implements

IFormComponent.

See Also

ColorPicker Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


ColorPicker.OnTransferDataToObject Method

protected override void OnTransferDataToObject(
ref Boolean& Cancel
);

Implements

IFormComponent.

See Also

ColorPicker Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


ColorPicker.Refresh Method

public override void Refresh();

See Also

ColorPicker Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


InvoiceMessage Class

For a list of all members of this type, see InvoiceMessage Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
InvoiceMessage

public class InvoiceMessage : FormComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry.WindowsControls

Assembly: AptifyInvoiceMessageControl (in AptifyInvoiceMessageControl.dll)

See Also

InvoiceMessage Members | Aptify.Applications.OrderEntry.WindowsControls Namespace


InvoiceMessage Members

InvoiceMessage overview

Public Instance Constructors

InvoiceMessage Constructor Initializes a new instance of the InvoiceMessage class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDirectEdit | Determines if a user will be able to edit the InvoiceMessage text by typing.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text | Sets the Text in the Textbox portion of the InvoiceMessage.
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormComponent) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateContext (inherited from FormComponent) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
ClearAllLines | Clears all of the lines that were added to the textbox.
ClearLine | Clears the last line that was entered into the text box.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
ExtendedOnFormComponentConfig | Contains logic specific to configuring this implementation of the FormComponent class.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvoiceMessageSelected | Occurs when an Invoice Message is selected.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
LoadMessages | Loads a dataset of messages and binds them to the Datasource used by the combobox
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormComponent) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormComponent) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject | Transfers the data from the text box to the DataField of the GE.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

InvoiceMessage Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


InvoiceMessage Constructor

Initializes a new instance of the InvoiceMessage class.

public InvoiceMessage();

See Also

InvoiceMessage Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


InvoiceMessage Properties

The properties of the InvoiceMessage class are listed below. For a complete list of InvoiceMessage class members, see the InvoiceMessage Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDirectEdit | Determines if a user will be able to edit the InvoiceMessage text by typing.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text | Sets the Text in the Textbox portion of the InvoiceMessage.
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateContext (inherited from FormComponent) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

InvoiceMessage Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


AllowDirectEdit Property

Aptify 5.0 Software Development Kit (SDK)

InvoiceMessage.AllowDirectEdit Property

Determines if a user will be able to edit the InvoiceMessage text by typing.

public virtual Boolean AllowDirectEdit {get; set;}

Property Value

Remarks

See Also

InvoiceMessage Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


Text Property

Aptify 5.0 Software Development Kit (SDK)

InvoiceMessage.Text Property

Sets the Text in the Textbox portion of the InvoiceMessage.

public override String Text {get; set;}

Property Value

Remarks

See Also

InvoiceMessage Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


InvoiceMessage Methods

The methods of the InvoiceMessage class are listed below. For a complete list of InvoiceMessage class members, see the InvoiceMessage Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormComponent) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
ClearAllLines | Clears all of the lines that were added to the textbox.
ClearLine | Clears the last line that was entered into the text box.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
ExtendedOnFormComponentConfig | Contains logic specific to configuring this implementation of the FormComponent class.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvoiceMessageSelected | Occurs when an Invoice Message is selected.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
LoadMessages | Loads a dataset of messages and binds them to the Datasource used by the combobox
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormComponent) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormComponent) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject | Transfers the data from the text box to the DataField of the GE.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

InvoiceMessage Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


InvoiceMessage.ClearAllLines Method

Clears all of the lines that were added to the textbox.

protected virtual void ClearAllLines();

Remarks

See Also

InvoiceMessage Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


InvoiceMessage.ClearLine Method

Clears the last line that was entered into the text box.

protected virtual void ClearLine();

Remarks

It finds the last new line character and clears everything after that. If it does not find the new line character, then it clears the entire text box.

See Also

InvoiceMessage Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

InvoiceMessage.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

InvoiceMessage Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


InvoiceMessage.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

InvoiceMessage Class | Aptify.Applications.OrderEntry.WindowsControls Namespace | InvoiceMessage.Dispose Overload List


InvoiceMessage.ExtendedOnFormComponentConfig Method

Contains logic specific to configuring this implementation of the FormComponent class.

protected virtual void ExtendedOnFormComponentConfig(
AptifyFormTemplateContext FormTemplateContext
);

Parameters

FormTemplateContext

Remarks

See Also

InvoiceMessage Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


InvoiceMessage.InvoiceMessageSelected Method

Occurs when an Invoice Message is selected.

protected virtual void InvoiceMessageSelected();

Remarks

See Also

InvoiceMessage Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


InvoiceMessage.LoadMessages Method

Loads a dataset of messages and binds them to the Datasource used by the combobox

protected virtual void LoadMessages();

Remarks

See Also

InvoiceMessage Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


InvoiceMessage.OnFormComponentConfig Method

protected override void OnFormComponentConfig(
AptifyFormTemplateContext FormTemplateContext
);

Implements

IFormComponent.

See Also

InvoiceMessage Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


InvoiceMessage.OnTransferDataToObject Method

Transfers the data from the text box to the DataField of the GE.

protected override void OnTransferDataToObject(
ref Boolean& Cancel
);

Parameters

Cancel

Implements

IFormComponent.

Remarks

See Also

InvoiceMessage Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderGLEntryLayout Class

For a list of all members of this type, see OrderGLEntryLayout Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
OrderSTLayoutBase
OrderGLEntryLayout

public class OrderGLEntryLayout : OrderSTLayoutBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry.WindowsControls

Assembly: OrderControls (in OrderControls.dll)

See Also

OrderGLEntryLayout Members | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderGLEntryLayout Members

OrderGLEntryLayout overview

Public Instance Constructors

OrderGLEntryLayout Constructor Initializes a new instance of the OrderGLEntryLayout class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

m_chkCustom
m_cmbGLAccount
m_txtCredit
m_txtDebit

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
OrderGE (inherited from OrderSTLayoutBase) |
OrderSTGE (inherited from OrderSTLayoutBase) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
EnableDisableControl (inherited from OrderSTLayoutBase) | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControls |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitializeObjects (inherited from OrderSTLayoutBase) |
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from OrderSTLayoutBase) |
OnFormTemplateLoaded |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlBehavior |
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

OrderGLEntryLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderGLEntryLayout Constructor

Initializes a new instance of the OrderGLEntryLayout class.

public OrderGLEntryLayout();

See Also

OrderGLEntryLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderGLEntryLayout Fields

The fields of the OrderGLEntryLayout class are listed below. For a complete list of OrderGLEntryLayout class members, see the OrderGLEntryLayout Members topic.

Protected Instance Fields

m_chkCustom
m_cmbGLAccount
m_txtCredit
m_txtDebit

See Also

OrderGLEntryLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderGLEntryLayout.m_chkCustom Field

protected m_chkCustom m_chkCustom;

See Also

OrderGLEntryLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderGLEntryLayout.m_cmbGLAccount Field

protected m_cmbGLAccount m_cmbGLAccount;

See Also

OrderGLEntryLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderGLEntryLayout.m_txtCredit Field

protected m_txtCredit m_txtCredit;

See Also

OrderGLEntryLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderGLEntryLayout.m_txtDebit Field

protected m_txtDebit m_txtDebit;

See Also

OrderGLEntryLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderGLEntryLayout Methods

The methods of the OrderGLEntryLayout class are listed below. For a complete list of OrderGLEntryLayout class members, see the OrderGLEntryLayout Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
EnableDisableControl (inherited from OrderSTLayoutBase) | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControls |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitializeObjects (inherited from OrderSTLayoutBase) |
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from OrderSTLayoutBase) |
OnFormTemplateLoaded |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlBehavior |
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

OrderGLEntryLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

OrderGLEntryLayout.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

OrderGLEntryLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderGLEntryLayout.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

OrderGLEntryLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace | OrderGLEntryLayout.Dispose Overload List


OrderGLEntryLayout.FindControls Method

protected void FindControls(
String FormTemplateLayoutName
);

See Also

OrderGLEntryLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderGLEntryLayout.OnFormTemplateLoaded Method

protected override void OnFormTemplateLoaded(
FormTemplateLayout.FormTemplateLoadedEventArgs e
);

See Also

OrderGLEntryLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderGLEntryLayout.SetControlBehavior Method

protected virtual void SetControlBehavior();

See Also

OrderGLEntryLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLayout Class

For a list of all members of this type, see OrderLayout Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
OrderLayout

public class OrderLayout : FormTemplateLayout

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry.WindowsControls

Assembly: OrderControls (in OrderControls.dll)

See Also

OrderLayout Members | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLayout Members

OrderLayout overview

Public Instance Constructors

OrderLayout Constructor Initializes a new instance of the OrderLayout class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

IsLoading
m_ArrivalDate
m_cmbPaymentScheduleOptions
m_CustomerShippingAcct
m_dcbCancellationReasonID
m_DropShipped
m_HoldUntil
m_labBatchID
m_labBatchLabel
m_labMemberType
m_PromisedOn
m_ShipDate
m_TrackingNumber
m_txtBalance
m_txtShipExpense
m_txtSubTotal
m_txtTotal

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
IsNewRecord | Property indicating if the record is new or not.
LineShipDialogPlugin |
m_Address |
m_aptAddressSelector |
m_aptPaymentInfo |
m_chkBillToSameAsShipTo |
m_cmbCurrencyType |
m_cmbOrderLevel |
m_cmbOrderSource |
m_cmbOrderStatus |
m_cmbOrderType |
m_cmdShipOrder |
m_elvCancellations |
m_elvDeferredIncome |
m_elvMarkToMarket |
m_elvPayments |
m_lnkBillToCompanyID |
m_lnkBillToID |
m_lnkCampaignID |
m_lnkCashControlID |
m_lnkEmployeeID |
m_lnkOrganizationID |
m_lnkOriginalOrderID |
m_lnkSalesRepID |
m_lnkShipToCompanyID |
m_lnkShipToID |
m_OrderLines |
m_Phone |
m_ReturnShippingCharge |
m_ShippedBy |
m_ShipType |
m_txtHandling |
m_txtInitialPayAmount |
m_txtOrderDate |
m_txtShipping |
m_txtTax |
MyAction |
OrdersEntity | Reference to the OrdersEntity object being represented by the OrderLayout control
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
ConfigureControlsForBatched | Method used to configure visibility and enablement of controls when payment is batched.
ContextGEChanged |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
EnableAllControls | Enables all controls on the Orders Form.
EnableDisableCurrencyTypeControl |
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControls |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitializeControls |
InitializeFieldObjects | Method used to initialize all data field objects being used to capture specific field change events.
InitializePayTypeFieldObject | Method used to initialize the PayTypeID data field object.
InitialPaymentAmountChanged |
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MatchesOrderCompany | Method used to indicate if the ID being passed in matches either the BillTo or ShipTo Company from the order.
MatchesOrderPerson | Method used to indicate is the ID being passed in matches either the BillTo or ShipTo Person from the order.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDataControlBeforeParams | Used to handle the Data Control's BeforeParams event. This method parses the Params string to remove fields that are not supported as New Record Parameters. Unsupported Fields: BatchID, CashCtrlBatchID, OrderStatusID
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig |
OnFormTemplateLoaded | Contains logic to setup Event handlers for controls on the FormTemplate Layout.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad |
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshAddressSelector | Refreshes the address selector control on the order form.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
RefreshTotalsControls | Method used to refresh all of the totals controls.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlVisibility | Method used to set overall visibility of controls. Delegates to other visibility methods which are type and status specific.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetShippingAndTaxVisibility | Method used to configure the shipping and tax controls for visibility.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetupOrderTextButton | Overloaded. This method is used to format OrderTextLink controls requiring currency type formatting.
SetVisibilityForExistingRecord | which sets the visibility of controls when the order is not new, irrespective of status or type.
SetVisibleControlsForBackorderedOrder | which sets the visibility of controls when the order is backordered.
SetVisibleControlsForCancelledOrder | which sets the visibility of controls when the order is cancelled.
SetVisibleControlsForNewOrder | which sets the visibility of controls when the order is new.
SetVisibleControlsForShippedOrder | Method which sets the visibility of controls when the order is shipped.
SetVisibleControlsForTakenOrder | which sets the visibility of controls when the order is taken but not shipped.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
ShipOrder | Method used to process the shipping request via the order status combo box.
ShowHandlingDetails | Method used to raise the Shipping and Handling Details form.
ShowPartialShipmentDialogAndCreateBackorders | Method which invokes the Line Shipment Dialog and Creates Backorders.
ShowShippingDetails | Method used to raise the Shipping and Handling Details form.
ShowTaxDetails | Method used to raise the Tax Details form.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLayout Constructor

Initializes a new instance of the OrderLayout class.

public OrderLayout();

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLayout Fields

The fields of the OrderLayout class are listed below. For a complete list of OrderLayout class members, see the OrderLayout Members topic.

Protected Instance Fields

IsLoading
m_ArrivalDate
m_cmbPaymentScheduleOptions
m_CustomerShippingAcct
m_dcbCancellationReasonID
m_DropShipped
m_HoldUntil
m_labBatchID
m_labBatchLabel
m_labMemberType
m_PromisedOn
m_ShipDate
m_TrackingNumber
m_txtBalance
m_txtShipExpense
m_txtSubTotal
m_txtTotal

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLayout.IsLoading Field

protected IsLoading IsLoading;

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLayout.m_ArrivalDate Field

protected m_ArrivalDate m_ArrivalDate;

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLayout.m_cmbPaymentScheduleOptions Field

protected m_cmbPaymentScheduleOptions m_cmbPaymentScheduleOptions;

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLayout.m_CustomerShippingAcct Field

protected m_CustomerShippingAcct m_CustomerShippingAcct;

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLayout.m_dcbCancellationReasonID Field

protected m_dcbCancellationReasonID m_dcbCancellationReasonID;

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLayout.m_DropShipped Field

protected m_DropShipped m_DropShipped;

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLayout.m_HoldUntil Field

protected m_HoldUntil m_HoldUntil;

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLayout.m_labBatchID Field

protected m_labBatchID m_labBatchID;

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLayout.m_labBatchLabel Field

protected m_labBatchLabel m_labBatchLabel;

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLayout.m_labMemberType Field

protected m_labMemberType m_labMemberType;

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLayout.m_PromisedOn Field

protected m_PromisedOn m_PromisedOn;

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLayout.m_ShipDate Field

protected m_ShipDate m_ShipDate;

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLayout.m_TrackingNumber Field

protected m_TrackingNumber m_TrackingNumber;

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLayout.m_txtBalance Field

protected m_txtBalance m_txtBalance;

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLayout.m_txtShipExpense Field

protected m_txtShipExpense m_txtShipExpense;

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLayout.m_txtSubTotal Field

protected m_txtSubTotal m_txtSubTotal;

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLayout.m_txtTotal Field

protected m_txtTotal m_txtTotal;

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLayout Properties

The properties of the OrderLayout class are listed below. For a complete list of OrderLayout class members, see the OrderLayout Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
IsNewRecord | Property indicating if the record is new or not.
LineShipDialogPlugin |
m_Address |
m_aptAddressSelector |
m_aptPaymentInfo |
m_chkBillToSameAsShipTo |
m_cmbCurrencyType |
m_cmbOrderLevel |
m_cmbOrderSource |
m_cmbOrderStatus |
m_cmbOrderType |
m_cmdShipOrder |
m_elvCancellations |
m_elvDeferredIncome |
m_elvMarkToMarket |
m_elvPayments |
m_lnkBillToCompanyID |
m_lnkBillToID |
m_lnkCampaignID |
m_lnkCashControlID |
m_lnkEmployeeID |
m_lnkOrganizationID |
m_lnkOriginalOrderID |
m_lnkSalesRepID |
m_lnkShipToCompanyID |
m_lnkShipToID |
m_OrderLines |
m_Phone |
m_ReturnShippingCharge |
m_ShippedBy |
m_ShipType |
m_txtHandling |
m_txtInitialPayAmount |
m_txtOrderDate |
m_txtShipping |
m_txtTax |
MyAction |
OrdersEntity | Reference to the OrdersEntity object being represented by the OrderLayout control
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


IsNewRecord Property

Aptify 5.0 Software Development Kit (SDK)

OrderLayout.IsNewRecord Property

Property indicating if the record is new or not.

protected virtual Boolean IsNewRecord {get;}

Property Value

Remarks

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


LineShipDialogPlugin Property

Aptify 5.0 Software Development Kit (SDK)

OrderLayout.LineShipDialogPlugin Property

protected ILineShipDialog LineShipDialogPlugin {get;}

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


m_Address Property

Aptify 5.0 Software Development Kit (SDK)

OrderLayout.m_Address Property

protected virtual Addresses m_Address {get; set;}

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


m_aptAddressSelector Property

Aptify 5.0 Software Development Kit (SDK)

OrderLayout.m_aptAddressSelector Property

protected virtual AddressSelector m_aptAddressSelector {get; set;}

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


m_aptPaymentInfo Property

Aptify 5.0 Software Development Kit (SDK)

OrderLayout.m_aptPaymentInfo Property

protected virtual PaymentInfoControl m_aptPaymentInfo {get; set;}

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


m_chkBillToSameAsShipTo Property

Aptify 5.0 Software Development Kit (SDK)

OrderLayout.m_chkBillToSameAsShipTo Property

protected virtual AptifyCheckBox m_chkBillToSameAsShipTo {get; set;}

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


m_cmbCurrencyType Property

Aptify 5.0 Software Development Kit (SDK)

OrderLayout.m_cmbCurrencyType Property

protected virtual AptifyDataComboBox m_cmbCurrencyType {get; set;}

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


m_cmbOrderLevel Property

Aptify 5.0 Software Development Kit (SDK)

OrderLayout.m_cmbOrderLevel Property

protected virtual AptifyDataComboBox m_cmbOrderLevel {get; set;}

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


m_cmbOrderSource Property

Aptify 5.0 Software Development Kit (SDK)

OrderLayout.m_cmbOrderSource Property

protected virtual AptifyDataComboBox m_cmbOrderSource {get; set;}

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


m_cmbOrderStatus Property

Aptify 5.0 Software Development Kit (SDK)

OrderLayout.m_cmbOrderStatus Property

protected virtual AptifyDataComboBox m_cmbOrderStatus {get; set;}

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


m_cmbOrderType Property

Aptify 5.0 Software Development Kit (SDK)

OrderLayout.m_cmbOrderType Property

protected virtual AptifyDataComboBox m_cmbOrderType {get; set;}

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


m_cmdShipOrder Property

Aptify 5.0 Software Development Kit (SDK)

OrderLayout.m_cmdShipOrder Property

protected virtual AptifyActiveButton m_cmdShipOrder {get; set;}

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


m_elvCancellations Property

Aptify 5.0 Software Development Kit (SDK)

OrderLayout.m_elvCancellations Property

protected virtual EntityListView m_elvCancellations {get; set;}

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


m_elvDeferredIncome Property

Aptify 5.0 Software Development Kit (SDK)

OrderLayout.m_elvDeferredIncome Property

protected virtual EntityListView m_elvDeferredIncome {get; set;}

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


m_elvMarkToMarket Property

Aptify 5.0 Software Development Kit (SDK)

OrderLayout.m_elvMarkToMarket Property

protected virtual EntityListView m_elvMarkToMarket {get; set;}

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


m_elvPayments Property

Aptify 5.0 Software Development Kit (SDK)

OrderLayout.m_elvPayments Property

protected virtual EntityListView m_elvPayments {get; set;}

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


m_lnkBillToCompanyID Property

Aptify 5.0 Software Development Kit (SDK)

OrderLayout.m_lnkBillToCompanyID Property

protected virtual AptifyLinkBox m_lnkBillToCompanyID {get; set;}

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


m_lnkBillToID Property

Aptify 5.0 Software Development Kit (SDK)

OrderLayout.m_lnkBillToID Property

protected virtual AptifyLinkBox m_lnkBillToID {get; set;}

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


m_lnkCampaignID Property

Aptify 5.0 Software Development Kit (SDK)

OrderLayout.m_lnkCampaignID Property

protected virtual AptifyLinkBox m_lnkCampaignID {get; set;}

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


m_lnkCashControlID Property

Aptify 5.0 Software Development Kit (SDK)

OrderLayout.m_lnkCashControlID Property

protected virtual AptifyLinkBox m_lnkCashControlID {get; set;}

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


m_lnkEmployeeID Property

Aptify 5.0 Software Development Kit (SDK)

OrderLayout.m_lnkEmployeeID Property

protected virtual AptifyLinkBox m_lnkEmployeeID {get; set;}

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


m_lnkOrganizationID Property

Aptify 5.0 Software Development Kit (SDK)

OrderLayout.m_lnkOrganizationID Property

protected virtual AptifyLinkBox m_lnkOrganizationID {get; set;}

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


m_lnkOriginalOrderID Property

Aptify 5.0 Software Development Kit (SDK)

OrderLayout.m_lnkOriginalOrderID Property

protected virtual AptifyLinkBox m_lnkOriginalOrderID {get; set;}

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


m_lnkSalesRepID Property

Aptify 5.0 Software Development Kit (SDK)

OrderLayout.m_lnkSalesRepID Property

protected virtual AptifyLinkBox m_lnkSalesRepID {get; set;}

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


m_lnkShipToCompanyID Property

Aptify 5.0 Software Development Kit (SDK)

OrderLayout.m_lnkShipToCompanyID Property

protected virtual AptifyLinkBox m_lnkShipToCompanyID {get; set;}

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


m_lnkShipToID Property

Aptify 5.0 Software Development Kit (SDK)

OrderLayout.m_lnkShipToID Property

protected virtual AptifyLinkBox m_lnkShipToID {get; set;}

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


m_OrderLines Property

Aptify 5.0 Software Development Kit (SDK)

OrderLayout.m_OrderLines Property

protected virtual Control m_OrderLines {get; set;}

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


m_Phone Property

Aptify 5.0 Software Development Kit (SDK)

OrderLayout.m_Phone Property

protected virtual Phones m_Phone {get; set;}

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


m_ReturnShippingCharge Property

Aptify 5.0 Software Development Kit (SDK)

OrderLayout.m_ReturnShippingCharge Property

protected virtual AptifyCheckBox m_ReturnShippingCharge {get; set;}

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


m_ShippedBy Property

Aptify 5.0 Software Development Kit (SDK)

OrderLayout.m_ShippedBy Property

protected virtual AptifyLinkBox m_ShippedBy {get; set;}

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


m_ShipType Property

Aptify 5.0 Software Development Kit (SDK)

OrderLayout.m_ShipType Property

protected virtual AptifyDataComboBox m_ShipType {get; set;}

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


m_txtHandling Property

Aptify 5.0 Software Development Kit (SDK)

OrderLayout.m_txtHandling Property

protected virtual OrderTextButton m_txtHandling {get; set;}

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


m_txtInitialPayAmount Property

Aptify 5.0 Software Development Kit (SDK)

OrderLayout.m_txtInitialPayAmount Property

protected virtual AptifyTextBox m_txtInitialPayAmount {get; set;}

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


m_txtOrderDate Property

Aptify 5.0 Software Development Kit (SDK)

OrderLayout.m_txtOrderDate Property

protected virtual AptifyTextBox m_txtOrderDate {get; set;}

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


m_txtShipping Property

Aptify 5.0 Software Development Kit (SDK)

OrderLayout.m_txtShipping Property

protected virtual OrderTextButton m_txtShipping {get; set;}

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


m_txtTax Property

Aptify 5.0 Software Development Kit (SDK)

OrderLayout.m_txtTax Property

protected virtual OrderTextButton m_txtTax {get; set;}

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


MyAction Property

Aptify 5.0 Software Development Kit (SDK)

OrderLayout.MyAction Property

protected DataAction MyAction {get;}

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrdersEntity Property

Aptify 5.0 Software Development Kit (SDK)

OrderLayout.OrdersEntity Property

Reference to the OrdersEntity object being represented by the OrderLayout control

protected OrdersEntity OrdersEntity {get;}

Property Value

Remarks

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLayout Methods

The methods of the OrderLayout class are listed below. For a complete list of OrderLayout class members, see the OrderLayout Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
ConfigureControlsForBatched | Method used to configure visibility and enablement of controls when payment is batched.
ContextGEChanged |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
EnableAllControls | Enables all controls on the Orders Form.
EnableDisableCurrencyTypeControl |
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControls |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitializeControls |
InitializeFieldObjects | Method used to initialize all data field objects being used to capture specific field change events.
InitializePayTypeFieldObject | Method used to initialize the PayTypeID data field object.
InitialPaymentAmountChanged |
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MatchesOrderCompany | Method used to indicate if the ID being passed in matches either the BillTo or ShipTo Company from the order.
MatchesOrderPerson | Method used to indicate is the ID being passed in matches either the BillTo or ShipTo Person from the order.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDataControlBeforeParams | Used to handle the Data Control's BeforeParams event. This method parses the Params string to remove fields that are not supported as New Record Parameters. Unsupported Fields: BatchID, CashCtrlBatchID, OrderStatusID
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig |
OnFormTemplateLoaded | Contains logic to setup Event handlers for controls on the FormTemplate Layout.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad |
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshAddressSelector | Refreshes the address selector control on the order form.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
RefreshTotalsControls | Method used to refresh all of the totals controls.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlVisibility | Method used to set overall visibility of controls. Delegates to other visibility methods which are type and status specific.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetShippingAndTaxVisibility | Method used to configure the shipping and tax controls for visibility.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetupOrderTextButton | Overloaded. This method is used to format OrderTextLink controls requiring currency type formatting.
SetVisibilityForExistingRecord | which sets the visibility of controls when the order is not new, irrespective of status or type.
SetVisibleControlsForBackorderedOrder | which sets the visibility of controls when the order is backordered.
SetVisibleControlsForCancelledOrder | which sets the visibility of controls when the order is cancelled.
SetVisibleControlsForNewOrder | which sets the visibility of controls when the order is new.
SetVisibleControlsForShippedOrder | Method which sets the visibility of controls when the order is shipped.
SetVisibleControlsForTakenOrder | which sets the visibility of controls when the order is taken but not shipped.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
ShipOrder | Method used to process the shipping request via the order status combo box.
ShowHandlingDetails | Method used to raise the Shipping and Handling Details form.
ShowPartialShipmentDialogAndCreateBackorders | Method which invokes the Line Shipment Dialog and Creates Backorders.
ShowShippingDetails | Method used to raise the Shipping and Handling Details form.
ShowTaxDetails | Method used to raise the Tax Details form.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLayout.ConfigureControlsForBatched Method

Method used to configure visibility and enablement of controls when payment is batched.

protected void ConfigureControlsForBatched();

Remarks

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLayout.ContextGEChanged Method

protected virtual void ContextGEChanged(
Object Sender,
AptifyFormTemplateContext.GEChangedArgs e
);

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

OrderLayout.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLayout.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace | OrderLayout.Dispose Overload List


OrderLayout.EnableAllControls Method

Enables all controls on the Orders Form.

protected virtual void EnableAllControls();

Remarks

If new controls are added to the form, they should be added to this list.

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLayout.EnableDisableCurrencyTypeControl Method

protected virtual void EnableDisableCurrencyTypeControl();

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLayout.FindControls Method

protected virtual void FindControls(
String FormTemplateLayoutName
);

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLayout.InitializeControls Method

protected virtual void InitializeControls();

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLayout.InitializeFieldObjects Method

Method used to initialize all data field objects being used to capture specific field change events.

protected virtual void InitializeFieldObjects();

Remarks

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLayout.InitializePayTypeFieldObject Method

Method used to initialize the PayTypeID data field object.

protected virtual void InitializePayTypeFieldObject();

Remarks

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLayout.InitialPaymentAmountChanged Method

protected virtual void InitialPaymentAmountChanged();

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLayout.MatchesOrderCompany Method

Method used to indicate if the ID being passed in matches either the BillTo or ShipTo Company from the order.

protected virtual bool MatchesOrderCompany(
String sID
);

Parameters

sID

Return Value

Remarks

Used in the GE messaging implementation on the form.

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLayout.MatchesOrderPerson Method

Method used to indicate is the ID being passed in matches either the BillTo or ShipTo Person from the order.

protected virtual bool MatchesOrderPerson(
String sID
);

Parameters

sID

Return Value

Remarks

Used in the GE messaging implementation on the form.

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLayout.OnDataControlBeforeParams Method

Used to handle the Data Control's BeforeParams event. This method parses the Params string to remove fields that are not supported as New Record Parameters. Unsupported Fields: BatchID, CashCtrlBatchID, OrderStatusID

protected virtual void OnDataControlBeforeParams(
ref String& Params,
ref Boolean& Cancel
);

Parameters

Params
Cancel

Remarks

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLayout.OnFormComponentConfig Method

protected override void OnFormComponentConfig(
AptifyFormTemplateContext Context
);

Implements

IFormComponent.

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLayout.OnFormTemplateLoaded Method

Contains logic to setup Event handlers for controls on the FormTemplate Layout.

protected override void OnFormTemplateLoaded(
FormTemplateLayout.FormTemplateLoadedEventArgs e
);

Parameters

e

Remarks

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLayout.OnLoad Method

protected override void OnLoad(
EventArgs e
);

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLayout.OnRefresh Method

protected override void OnRefresh();

Implements

IFormComponent.

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OnShow Method

Aptify 5.0 Software Development Kit (SDK)

OrderLayout.OnShow Method

Overload List

protected override void OnShow();

protected override void OnShow(Boolean);

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLayout.OnShow Method ()

protected override void OnShow();

Implements

IFormComponent.

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace | OrderLayout.OnShow Overload List


OrderLayout.OnShow Method (Boolean)

protected override void OnShow(
Boolean Refresh
);

Implements

IFormComponent.

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace | OrderLayout.OnShow Overload List


OrderLayout.OnTransferDataToObject Method

protected override void OnTransferDataToObject(
ref Boolean& Cancel
);

Implements

IFormComponent.

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLayout.RefreshAddressSelector Method

Refreshes the address selector control on the order form.

protected void RefreshAddressSelector();

Remarks

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLayout.RefreshTotalsControls Method

Method used to refresh all of the totals controls.

protected virtual void RefreshTotalsControls();

Remarks

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLayout.SetControlVisibility Method

Method used to set overall visibility of controls. Delegates to other visibility methods which are type and status specific.

protected virtual void SetControlVisibility();

Remarks

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLayout.SetShippingAndTaxVisibility Method

Method used to configure the shipping and tax controls for visibility.

protected virtual void SetShippingAndTaxVisibility();

Remarks

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


SetupOrderTextButton Method

Aptify 5.0 Software Development Kit (SDK)

OrderLayout.SetupOrderTextButton Method

This method is used to format OrderTextLink controls requiring currency type formatting.

Overload List

This method is used to format OrderTextLink controls requiring currency type formatting.

protected virtual void SetupOrderTextButton(OrderTextButton,String);

This method is used to format OrderTextLink controls requiring currency type formatting.

protected virtual void SetupOrderTextButton(OrderTextButton,String,String);

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLayout.SetupOrderTextButton Method (OrderTextButton, String)

This method is used to format OrderTextLink controls requiring currency type formatting.

protected virtual void SetupOrderTextButton(
OrderTextButton TLControl,
String sFormatString
);

Parameters

TLControl
sFormatString

Remarks

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace | OrderLayout.SetupOrderTextButton Overload List


OrderLayout.SetupOrderTextButton Method (OrderTextButton, String, String)

This method is used to format OrderTextLink controls requiring currency type formatting.

protected virtual void SetupOrderTextButton(
OrderTextButton TLControl,
String sFormatString,
String sToolTipText
);

Parameters

TLControl
sFormatString
sToolTipText

Remarks

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace | OrderLayout.SetupOrderTextButton Overload List


OrderLayout.SetVisibilityForExistingRecord Method

which sets the visibility of controls when the order is not new, irrespective of status or type.

protected virtual void SetVisibilityForExistingRecord();

Remarks

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLayout.SetVisibleControlsForBackorderedOrder Method

which sets the visibility of controls when the order is backordered.

protected virtual void SetVisibleControlsForBackorderedOrder();

Remarks

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLayout.SetVisibleControlsForCancelledOrder Method

which sets the visibility of controls when the order is cancelled.

protected virtual void SetVisibleControlsForCancelledOrder();

Remarks

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLayout.SetVisibleControlsForNewOrder Method

which sets the visibility of controls when the order is new.

protected virtual void SetVisibleControlsForNewOrder();

Remarks

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLayout.SetVisibleControlsForShippedOrder Method

Method which sets the visibility of controls when the order is shipped.

protected virtual void SetVisibleControlsForShippedOrder();

Remarks

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLayout.SetVisibleControlsForTakenOrder Method

which sets the visibility of controls when the order is taken but not shipped.

protected virtual void SetVisibleControlsForTakenOrder();

Remarks

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLayout.ShipOrder Method

Method used to process the shipping request via the order status combo box.

protected virtual void ShipOrder();

Remarks

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLayout.ShowHandlingDetails Method

Method used to raise the Shipping and Handling Details form.

protected virtual void ShowHandlingDetails(
OrdersEntity OrderObject
);

Parameters

OrderObject

Remarks

Aptify 4.0 stock functionality is identical to ShowShippingDetails.

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLayout.ShowPartialShipmentDialogAndCreateBackorders Method

Method which invokes the Line Shipment Dialog and Creates Backorders.

protected virtual bool ShowPartialShipmentDialogAndCreateBackorders();

Return Value

Remarks

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLayout.ShowShippingDetails Method

Method used to raise the Shipping and Handling Details form.

protected virtual void ShowShippingDetails(
OrdersEntity OrderObject
);

Parameters

OrderObject

Remarks

Aptify 4.0 stock functionality is identical to ShowHandlingDetails.

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLayout.ShowTaxDetails Method

Method used to raise the Tax Details form.

protected virtual void ShowTaxDetails(
OrdersEntity OrderObject
);

Parameters

OrderObject

Remarks

See Also

OrderLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLines Class

Order Line Control Base Class

For a list of all members of this type, see OrderLines Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
OrderLines

public class OrderLines : FormComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.OrderEntry.WindowsControls

Assembly: OrderControls (in OrderControls.dll)

See Also

OrderLines Members | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLines Members

OrderLines overview

Public Instance Constructors

OrderLines Constructor Initializes a new instance of the OrderLines class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormComponent) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateContext (inherited from FormComponent) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormComponent) |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormComponent) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormComponent) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormComponent) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

OrderLines Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLines Constructor

Initializes a new instance of the OrderLines class.

public OrderLines();

See Also

OrderLines Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLines Methods

The methods of the OrderLines class are listed below. For a complete list of OrderLines class members, see the OrderLines Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormComponent) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormComponent) |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormComponent) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormComponent) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormComponent) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

OrderLines Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

OrderLines.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

OrderLines Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLines.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

OrderLines Class | Aptify.Applications.OrderEntry.WindowsControls Namespace | OrderLines.Dispose Overload List


OrderLinesExtender Class

For a list of all members of this type, see OrderLinesExtender Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
OrderLinesExtender

public class OrderLinesExtender : FormComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry.WindowsControls

Assembly: OrderControls (in OrderControls.dll)

See Also

OrderLinesExtender Members | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLinesExtender Members

OrderLinesExtender overview

Public Instance Constructors

OrderLinesExtender Constructor Initializes a new instance of the OrderLinesExtender class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormComponent) |
ReInitComponent |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetupOrderDetailType | This function sets up an extra tab for additional product-level attributes based on the product type.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ConfiguredWithNonExtendedOrderLine |
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateContext (inherited from FormComponent) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormComponent) |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormComponent) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormComponent) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormComponent) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

OrderLinesExtender Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLinesExtender Constructor

Initializes a new instance of the OrderLinesExtender class.

public OrderLinesExtender();

See Also

OrderLinesExtender Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLinesExtender Methods

The methods of the OrderLinesExtender class are listed below. For a complete list of OrderLinesExtender class members, see the OrderLinesExtender Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormComponent) |
ReInitComponent |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetupOrderDetailType | This function sets up an extra tab for additional product-level attributes based on the product type.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormComponent) |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormComponent) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormComponent) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormComponent) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

OrderLinesExtender Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

OrderLinesExtender.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

OrderLinesExtender Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLinesExtender.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

OrderLinesExtender Class | Aptify.Applications.OrderEntry.WindowsControls Namespace | OrderLinesExtender.Dispose Overload List


OrderLinesExtender.ReInitComponent Method

public void ReInitComponent();

See Also

OrderLinesExtender Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLinesExtender.SetupOrderDetailType Method

This function sets up an extra tab for additional product-level attributes based on the product type.

public void SetupOrderDetailType(
AptifyGenericEntityBase GE
);

Parameters

GE

Remarks

See Also

OrderLinesExtender Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLinesExtender Events

The events of the OrderLinesExtender class are listed below. For a complete list of OrderLinesExtender class members, see the OrderLinesExtender Members topic.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ConfiguredWithNonExtendedOrderLine |
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

OrderLinesExtender Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLinesExtender.EventHandler Event

public event EventHandler ConfiguredWithNonExtendedOrderLine;

See Also

OrderLinesExtender Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLinesLayout Class

For a list of all members of this type, see OrderLinesLayout Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
OrderSTLayoutBase
OrderLinesLayout

public class OrderLinesLayout : OrderSTLayoutBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry.WindowsControls

Assembly: OrderControls (in OrderControls.dll)

See Also

OrderLinesLayout Members | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLinesLayout Members

OrderLinesLayout overview

Public Instance Constructors

OrderLinesLayout Constructor Initializes a new instance of the OrderLinesLayout class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

m_aptAddress
m_chkNotReturned

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
m_aptOrderLineExtender |
m_lnkCampaignCodeID |
m_lnkShipToID |
m_txtDiscount |
m_txtPrice |
m_txtQTY |
OrderGE (inherited from OrderSTLayoutBase) |
OrderSTGE (inherited from OrderSTLayoutBase) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
EnableDisableControl (inherited from OrderSTLayoutBase) | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControls |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitializeControls |
InitializeObjects (inherited from OrderSTLayoutBase) |
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig |
OnFormTemplateLoaded |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlVisibilityForShippedOrder |
SetControlVisibilityForUnshippedOrder |
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetupExtendedTab |
SetupSubscriptionTab |
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
ValidateAndReturnValidatedPrice |
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

OrderLinesLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLinesLayout Constructor

Initializes a new instance of the OrderLinesLayout class.

public OrderLinesLayout();

See Also

OrderLinesLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLinesLayout Fields

The fields of the OrderLinesLayout class are listed below. For a complete list of OrderLinesLayout class members, see the OrderLinesLayout Members topic.

Protected Instance Fields

m_aptAddress
m_chkNotReturned

See Also

OrderLinesLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLinesLayout.m_aptAddress Field

protected m_aptAddress m_aptAddress;

See Also

OrderLinesLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLinesLayout.m_chkNotReturned Field

protected m_chkNotReturned m_chkNotReturned;

See Also

OrderLinesLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLinesLayout Properties

The properties of the OrderLinesLayout class are listed below. For a complete list of OrderLinesLayout class members, see the OrderLinesLayout Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
m_aptOrderLineExtender |
m_lnkCampaignCodeID |
m_lnkShipToID |
m_txtDiscount |
m_txtPrice |
m_txtQTY |
OrderGE (inherited from OrderSTLayoutBase) |
OrderSTGE (inherited from OrderSTLayoutBase) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

OrderLinesLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


m_aptOrderLineExtender Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesLayout.m_aptOrderLineExtender Property

protected virtual OrderLinesExtender m_aptOrderLineExtender {get; set;}

See Also

OrderLinesLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


m_lnkCampaignCodeID Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesLayout.m_lnkCampaignCodeID Property

protected virtual AptifyLinkBox m_lnkCampaignCodeID {get; set;}

See Also

OrderLinesLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


m_lnkShipToID Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesLayout.m_lnkShipToID Property

protected virtual AptifyLinkBox m_lnkShipToID {get; set;}

See Also

OrderLinesLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


m_txtDiscount Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesLayout.m_txtDiscount Property

protected virtual AptifyTextBox m_txtDiscount {get; set;}

See Also

OrderLinesLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


m_txtPrice Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesLayout.m_txtPrice Property

protected virtual AptifyTextBox m_txtPrice {get; set;}

See Also

OrderLinesLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


m_txtQTY Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesLayout.m_txtQTY Property

protected virtual AptifyTextBox m_txtQTY {get; set;}

See Also

OrderLinesLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLinesLayout Methods

The methods of the OrderLinesLayout class are listed below. For a complete list of OrderLinesLayout class members, see the OrderLinesLayout Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
EnableDisableControl (inherited from OrderSTLayoutBase) | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControls |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitializeControls |
InitializeObjects (inherited from OrderSTLayoutBase) |
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig |
OnFormTemplateLoaded |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlVisibilityForShippedOrder |
SetControlVisibilityForUnshippedOrder |
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetupExtendedTab |
SetupSubscriptionTab |
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
ValidateAndReturnValidatedPrice |
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

OrderLinesLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

OrderLinesLayout.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

OrderLinesLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLinesLayout.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

OrderLinesLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace | OrderLinesLayout.Dispose Overload List


OrderLinesLayout.FindControls Method

protected virtual void FindControls();

See Also

OrderLinesLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLinesLayout.InitializeControls Method

protected void InitializeControls();

See Also

OrderLinesLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLinesLayout.OnFormComponentConfig Method

protected override void OnFormComponentConfig(
AptifyFormTemplateContext Context
);

Implements

IFormComponent.

See Also

OrderLinesLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLinesLayout.OnFormTemplateLoaded Method

protected override void OnFormTemplateLoaded(
FormTemplateLayout.FormTemplateLoadedEventArgs e
);

See Also

OrderLinesLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLinesLayout.SetControlVisibilityForShippedOrder Method

protected virtual void SetControlVisibilityForShippedOrder();

See Also

OrderLinesLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLinesLayout.SetControlVisibilityForUnshippedOrder Method

protected virtual void SetControlVisibilityForUnshippedOrder();

See Also

OrderLinesLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLinesLayout.SetupExtendedTab Method

protected void SetupExtendedTab();

See Also

OrderLinesLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLinesLayout.SetupSubscriptionTab Method

protected void SetupSubscriptionTab();

See Also

OrderLinesLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLinesLayout.ValidateAndReturnValidatedPrice Method

protected virtual decimal ValidateAndReturnValidatedPrice(
Decimal Price
);

See Also

OrderLinesLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLineTaxesLayout Class

For a list of all members of this type, see OrderLineTaxesLayout Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
OrderSTLayoutBase
OrderLineTaxesLayout

public class OrderLineTaxesLayout : OrderSTLayoutBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry.WindowsControls

Assembly: OrderControls (in OrderControls.dll)

See Also

OrderLineTaxesLayout Members | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLineTaxesLayout Members

OrderLineTaxesLayout overview

Public Instance Constructors

OrderLineTaxesLayout Constructor Initializes a new instance of the OrderLineTaxesLayout class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

m_txtTax
m_txtTaxableAmount

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
OrderGE (inherited from OrderSTLayoutBase) |
OrderSTGE (inherited from OrderSTLayoutBase) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
EnableDisableControl (inherited from OrderSTLayoutBase) | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControls |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitializeControls |
InitializeObjects (inherited from OrderSTLayoutBase) |
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from OrderSTLayoutBase) |
OnFormTemplateLoaded |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlVisibilityForShippedOrder |
SetControlVisibilityForUnshippedOrder |
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

OrderLineTaxesLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLineTaxesLayout Constructor

Initializes a new instance of the OrderLineTaxesLayout class.

public OrderLineTaxesLayout();

See Also

OrderLineTaxesLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLineTaxesLayout Fields

The fields of the OrderLineTaxesLayout class are listed below. For a complete list of OrderLineTaxesLayout class members, see the OrderLineTaxesLayout Members topic.

Protected Instance Fields

m_txtTax
m_txtTaxableAmount

See Also

OrderLineTaxesLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLineTaxesLayout.m_txtTax Field

protected m_txtTax m_txtTax;

See Also

OrderLineTaxesLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLineTaxesLayout.m_txtTaxableAmount Field

protected m_txtTaxableAmount m_txtTaxableAmount;

See Also

OrderLineTaxesLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLineTaxesLayout Methods

The methods of the OrderLineTaxesLayout class are listed below. For a complete list of OrderLineTaxesLayout class members, see the OrderLineTaxesLayout Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
EnableDisableControl (inherited from OrderSTLayoutBase) | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControls |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitializeControls |
InitializeObjects (inherited from OrderSTLayoutBase) |
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from OrderSTLayoutBase) |
OnFormTemplateLoaded |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlVisibilityForShippedOrder |
SetControlVisibilityForUnshippedOrder |
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

OrderLineTaxesLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

OrderLineTaxesLayout.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

OrderLineTaxesLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLineTaxesLayout.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

OrderLineTaxesLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace | OrderLineTaxesLayout.Dispose Overload List


OrderLineTaxesLayout.FindControls Method

protected virtual void FindControls();

See Also

OrderLineTaxesLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLineTaxesLayout.InitializeControls Method

protected void InitializeControls();

See Also

OrderLineTaxesLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLineTaxesLayout.OnFormTemplateLoaded Method

protected override void OnFormTemplateLoaded(
FormTemplateLayout.FormTemplateLoadedEventArgs e
);

See Also

OrderLineTaxesLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLineTaxesLayout.SetControlVisibilityForShippedOrder Method

protected virtual void SetControlVisibilityForShippedOrder();

See Also

OrderLineTaxesLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLineTaxesLayout.SetControlVisibilityForUnshippedOrder Method

protected virtual void SetControlVisibilityForUnshippedOrder();

See Also

OrderLineTaxesLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderMain Class

This class is intended to be used as the main display Form Component for display an Order. The class in turn displays 3 templates within it. The class will seek out a Form Template for Orders.TopArea, Orders.BottomArea and Orders.MiddleArea to place into its three pane areas. User Level Templates are looked at first that derive from the Global templates with those names, Group level templates are then looked at and finally global level usage scope templates are looked at. Furthermore, the Rank field is evaluated in selecting the appropriate template to display for a given area. To plug in form templates for the Top, Middle and Bottom Areas, make sure the following attributes are set in the Form Templates Entity. NOTE: You can change the Names of the below Form Templates, however the Entity Attributes corresponding to those names in the Orders entity need to be updated as well. 1) Top Area (Global Template) Entity: Orders Name: Orders.TopArea UsageScope: Global Rank: 0 2) Middle Area (Global Template) Entity: Orders Name: Orders.MiddleArea UsageScope: Global Rank: 0 3) Bottom Area (Global Template) Entity: Orders Name: Orders.BottomArea UsageScope: Global Rank: 0 For Group/User level usage scope templates, they can be named anything but must be derived from the Global Template settings using the BaseTemplateID field

For a list of all members of this type, see OrderMain Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
OrderMain

public class OrderMain : FormComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry.WindowsControls

Assembly: OrderControls (in OrderControls.dll)

See Also

OrderMain Members | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderMain Members

OrderMain overview

Public Instance Constructors

OrderMain Constructor Initializes a new instance of the OrderMain class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
BottomArea | This member returns a reference to the Bottom Area Form Template Layout (or sub-class)
BottomAreaFormTemplateName | This property returns the name of the Form Template to look for for the Bottom Area. Sub-classes can override this property to change the behavior of the method. The default behavior is for the system to look at the Entity Attribute called BottomAreaFormTemplateName within the Orders Entity.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
Database | This member returns the name of the database where the Orders entity is located
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MiddleArea | This member returns a reference to the Middle Area Form Template Layout (or sub-class)
MiddleAreaFormTemplateName | This property returns the name of the Form Template to look for for the Middle Area. Sub-classes can override this property to change the behavior of the method. The default behavior is for the system to look at the Entity Attribute called MiddleAreaFormTemplateName within the Orders Entity.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
ObjectRepository | This member returns an instance of the Aptify Object Repository object. The first time this member is accessed, a new object repository instance will be created automatically.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopArea | This member returns a reference to the Top Area Form Template Layout (or sub-class)
TopAreaFormTemplateName | This property returns the name of the Form Template to look for for the Top Area. Sub-classes can override this property to change the behavior of the method. The default behavior is for the system to look at the Entity Attribute called TopAreaFormTemplateName within the Orders Entity.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
GetUserValue | This method returns a user profile value from the database. Use it to determine user preferences using Application ID and Sequence parameters. If the User Value is not found, the DefaultValue parameter is returned.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormComponent) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetUserValue | This method is responsible for saving a user profile value into the database for the specified Application ID and Sequence provided. If there is an existing Application ID and Sequence matching for the current user, that row is updated, otherwise a new row in the UserValues entity is created.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultBottomAreaHeight |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMiddleAreaHeight |
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DefaultTopAreaHeight |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateContext (inherited from FormComponent) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
ApplySkin |
ConfigureOrganizationPermissions |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAreaHeight | This method returns a value for the area height. The possible values for AttributeName are OrderFormTopAreaHeight, OrderFormMiddleAreaHeight, and OrderFormBottomAreaHeight. First, the function tries to get user-specific values if they have been saved. If not, entity attributes by the same name as the above mentioned Attribute Names in the Orders entity will be checked. If for some reason, those entity attributes are not there, the default values will be those compiled into the default object setup. Override this method to alter the logic for calculating the default height for any or all of the panes.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormTemplateID |
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
GetUserValueDataTable | This method returns a datatable with a row of data representing a user profile value from the database. If a row is not found matching the specified ApplicationID and Sequence, Nothing is returned.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
LoadAreaTemplate | This method is responsible for loading up a specific area (such as Top Area, Bottom Area, Middle Area) with a specific control and adding it to the control passed in as AreaParent. This method will add the control (using specialized Form Template Layout information if the Form Template for the area specifies a special layout class in its meta-data definition), and dock the newly instantiated control to fill the AreaParent control.
LoadInputProperties | This method is responsible for loading the input properties for the control. The base class has support for the following Input Properties: TopAreaVisible - 1/0 BottomAreaVisible - 1/0
LoadOrderForm | This method is responsible for loading up the order form and is called once per control lifecycle from the OnFormComponentConfig() method.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
On_AfterSplitterDrag | This method handles the AfterSplitterDrag event which occurs whenever the user changes the size of a splitter window. When this happens, persist the user preferences to the database
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormComponent) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormComponent) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetupPaneSizes | This method is responsible for setting up the sizes of the docking panes based on the user's prior saved values, if any. If the user has never modified the layout before, default values are pulled from the Entity Attributes: OrderFormTopAreaHeight, OrderFormMiddleAreaHeight,OrderFormBottomAreaHeight
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

OrderMain Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderMain Constructor

Initializes a new instance of the OrderMain class.

public OrderMain();

See Also

OrderMain Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderMain Properties

The properties of the OrderMain class are listed below. For a complete list of OrderMain class members, see the OrderMain Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
BottomArea | This member returns a reference to the Bottom Area Form Template Layout (or sub-class)
BottomAreaFormTemplateName | This property returns the name of the Form Template to look for for the Bottom Area. Sub-classes can override this property to change the behavior of the method. The default behavior is for the system to look at the Entity Attribute called BottomAreaFormTemplateName within the Orders Entity.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
Database | This member returns the name of the database where the Orders entity is located
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MiddleArea | This member returns a reference to the Middle Area Form Template Layout (or sub-class)
MiddleAreaFormTemplateName | This property returns the name of the Form Template to look for for the Middle Area. Sub-classes can override this property to change the behavior of the method. The default behavior is for the system to look at the Entity Attribute called MiddleAreaFormTemplateName within the Orders Entity.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
ObjectRepository | This member returns an instance of the Aptify Object Repository object. The first time this member is accessed, a new object repository instance will be created automatically.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopArea | This member returns a reference to the Top Area Form Template Layout (or sub-class)
TopAreaFormTemplateName | This property returns the name of the Form Template to look for for the Top Area. Sub-classes can override this property to change the behavior of the method. The default behavior is for the system to look at the Entity Attribute called TopAreaFormTemplateName within the Orders Entity.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultBottomAreaHeight |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMiddleAreaHeight |
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DefaultTopAreaHeight |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateContext (inherited from FormComponent) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

OrderMain Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


BottomArea Property

Aptify 5.0 Software Development Kit (SDK)

OrderMain.BottomArea Property

This member returns a reference to the Bottom Area Form Template Layout (or sub-class)

public virtual FormTemplateLayout BottomArea {get;}

Property Value

Remarks

See Also

OrderMain Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


BottomAreaFormTemplateName Property

Aptify 5.0 Software Development Kit (SDK)

OrderMain.BottomAreaFormTemplateName Property

This property returns the name of the Form Template to look for for the Bottom Area. Sub-classes can override this property to change the behavior of the method. The default behavior is for the system to look at the Entity Attribute called BottomAreaFormTemplateName within the Orders Entity.

public virtual String BottomAreaFormTemplateName {get;}

Property Value

Remarks

See Also

OrderMain Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


Database Property

Aptify 5.0 Software Development Kit (SDK)

OrderMain.Database Property

This member returns the name of the database where the Orders entity is located

public virtual String Database {get;}

Property Value

Remarks

See Also

OrderMain Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


DefaultBottomAreaHeight Property

Aptify 5.0 Software Development Kit (SDK)

OrderMain.DefaultBottomAreaHeight Property

protected virtual Int32 DefaultBottomAreaHeight {get;}

See Also

OrderMain Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


DefaultMiddleAreaHeight Property

Aptify 5.0 Software Development Kit (SDK)

OrderMain.DefaultMiddleAreaHeight Property

protected virtual Int32 DefaultMiddleAreaHeight {get;}

See Also

OrderMain Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


DefaultTopAreaHeight Property

Aptify 5.0 Software Development Kit (SDK)

OrderMain.DefaultTopAreaHeight Property

protected virtual Int32 DefaultTopAreaHeight {get;}

See Also

OrderMain Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


MiddleArea Property

Aptify 5.0 Software Development Kit (SDK)

OrderMain.MiddleArea Property

This member returns a reference to the Middle Area Form Template Layout (or sub-class)

public virtual FormTemplateLayout MiddleArea {get;}

Property Value

Remarks

See Also

OrderMain Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


MiddleAreaFormTemplateName Property

Aptify 5.0 Software Development Kit (SDK)

OrderMain.MiddleAreaFormTemplateName Property

This property returns the name of the Form Template to look for for the Middle Area. Sub-classes can override this property to change the behavior of the method. The default behavior is for the system to look at the Entity Attribute called MiddleAreaFormTemplateName within the Orders Entity.

public virtual String MiddleAreaFormTemplateName {get;}

Property Value

Remarks

See Also

OrderMain Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


ObjectRepository Property

Aptify 5.0 Software Development Kit (SDK)

OrderMain.ObjectRepository Property

This member returns an instance of the Aptify Object Repository object. The first time this member is accessed, a new object repository instance will be created automatically.

public virtual AptifyObjectRepository ObjectRepository {get;}

Property Value

Remarks

See Also

OrderMain Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


TopArea Property

Aptify 5.0 Software Development Kit (SDK)

OrderMain.TopArea Property

This member returns a reference to the Top Area Form Template Layout (or sub-class)

public virtual FormTemplateLayout TopArea {get;}

Property Value

Remarks

See Also

OrderMain Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


TopAreaFormTemplateName Property

Aptify 5.0 Software Development Kit (SDK)

OrderMain.TopAreaFormTemplateName Property

This property returns the name of the Form Template to look for for the Top Area. Sub-classes can override this property to change the behavior of the method. The default behavior is for the system to look at the Entity Attribute called TopAreaFormTemplateName within the Orders Entity.

public virtual String TopAreaFormTemplateName {get;}

Property Value

Remarks

See Also

OrderMain Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderMain Methods

The methods of the OrderMain class are listed below. For a complete list of OrderMain class members, see the OrderMain Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
GetUserValue | This method returns a user profile value from the database. Use it to determine user preferences using Application ID and Sequence parameters. If the User Value is not found, the DefaultValue parameter is returned.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormComponent) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetUserValue | This method is responsible for saving a user profile value into the database for the specified Application ID and Sequence provided. If there is an existing Application ID and Sequence matching for the current user, that row is updated, otherwise a new row in the UserValues entity is created.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
ApplySkin |
ConfigureOrganizationPermissions |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAreaHeight | This method returns a value for the area height. The possible values for AttributeName are OrderFormTopAreaHeight, OrderFormMiddleAreaHeight, and OrderFormBottomAreaHeight. First, the function tries to get user-specific values if they have been saved. If not, entity attributes by the same name as the above mentioned Attribute Names in the Orders entity will be checked. If for some reason, those entity attributes are not there, the default values will be those compiled into the default object setup. Override this method to alter the logic for calculating the default height for any or all of the panes.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormTemplateID |
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
GetUserValueDataTable | This method returns a datatable with a row of data representing a user profile value from the database. If a row is not found matching the specified ApplicationID and Sequence, Nothing is returned.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
LoadAreaTemplate | This method is responsible for loading up a specific area (such as Top Area, Bottom Area, Middle Area) with a specific control and adding it to the control passed in as AreaParent. This method will add the control (using specialized Form Template Layout information if the Form Template for the area specifies a special layout class in its meta-data definition), and dock the newly instantiated control to fill the AreaParent control.
LoadInputProperties | This method is responsible for loading the input properties for the control. The base class has support for the following Input Properties: TopAreaVisible - 1/0 BottomAreaVisible - 1/0
LoadOrderForm | This method is responsible for loading up the order form and is called once per control lifecycle from the OnFormComponentConfig() method.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
On_AfterSplitterDrag | This method handles the AfterSplitterDrag event which occurs whenever the user changes the size of a splitter window. When this happens, persist the user preferences to the database
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormComponent) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormComponent) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetupPaneSizes | This method is responsible for setting up the sizes of the docking panes based on the user's prior saved values, if any. If the user has never modified the layout before, default values are pulled from the Entity Attributes: OrderFormTopAreaHeight, OrderFormMiddleAreaHeight,OrderFormBottomAreaHeight
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

OrderMain Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderMain.ApplySkin Method

protected virtual void ApplySkin();

See Also

OrderMain Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderMain.ConfigureOrganizationPermissions Method

protected virtual void ConfigureOrganizationPermissions();

See Also

OrderMain Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

OrderMain.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

OrderMain Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderMain.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

OrderMain Class | Aptify.Applications.OrderEntry.WindowsControls Namespace | OrderMain.Dispose Overload List


OrderMain.GetAreaHeight Method

This method returns a value for the area height. The possible values for AttributeName are OrderFormTopAreaHeight, OrderFormMiddleAreaHeight, and OrderFormBottomAreaHeight. First, the function tries to get user-specific values if they have been saved. If not, entity attributes by the same name as the above mentioned Attribute Names in the Orders entity will be checked. If for some reason, those entity attributes are not there, the default values will be those compiled into the default object setup. Override this method to alter the logic for calculating the default height for any or all of the panes.

protected virtual int GetAreaHeight(
String AttributeName,
Int32 DefaultValue
);

Parameters

AttributeName
DefaultValue

Return Value

Remarks

See Also

OrderMain Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderMain.GetFormTemplateID Method

protected virtual long GetFormTemplateID(
String EntityName,
String UsageScope,
String TemplateName
);

See Also

OrderMain Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderMain.GetUserValue Method

This method returns a user profile value from the database. Use it to determine user preferences using Application ID and Sequence parameters. If the User Value is not found, the DefaultValue parameter is returned.

public virtual string GetUserValue(
Int64 ApplicationID,
Int64 Sequence,
String Name,
String DefaultValue
);

Parameters

ApplicationID
Sequence
Name
DefaultValue

Return Value

Remarks

See Also

OrderMain Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderMain.GetUserValueDataTable Method

This method returns a datatable with a row of data representing a user profile value from the database. If a row is not found matching the specified ApplicationID and Sequence, Nothing is returned.

protected virtual DataTable GetUserValueDataTable(
Int64 ApplicationID,
Int64 Sequence,
String Name
);

Parameters

ApplicationID
Sequence
Name

Return Value

Remarks

See Also

OrderMain Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderMain.LoadAreaTemplate Method

This method is responsible for loading up a specific area (such as Top Area, Bottom Area, Middle Area) with a specific control and adding it to the control passed in as AreaParent. This method will add the control (using specialized Form Template Layout information if the Form Template for the area specifies a special layout class in its meta-data definition), and dock the newly instantiated control to fill the AreaParent control.

protected virtual void LoadAreaTemplate(
Control AreaParent,
ref FormTemplateLayout& FormTemplateLayoutControl,
String AreaName
);

Parameters

AreaParent
FormTemplateLayoutControl
AreaName

Remarks

See Also

OrderMain Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderMain.LoadInputProperties Method

This method is responsible for loading the input properties for the control. The base class has support for the following Input Properties: TopAreaVisible - 1/0 BottomAreaVisible - 1/0

protected virtual void LoadInputProperties();

Remarks

See Also

OrderMain Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderMain.LoadOrderForm Method

This method is responsible for loading up the order form and is called once per control lifecycle from the OnFormComponentConfig() method.

protected virtual void LoadOrderForm();

Remarks

See Also

OrderMain Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderMain.On_AfterSplitterDrag Method

This method handles the AfterSplitterDrag event which occurs whenever the user changes the size of a splitter window. When this happens, persist the user preferences to the database

protected virtual void On_AfterSplitterDrag(
Object sender,
PanesEventArgs e
);

Parameters

sender
e

Remarks

See Also

OrderMain Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderMain.OnFormComponentConfig Method

protected override void OnFormComponentConfig(
AptifyFormTemplateContext FormTemplateContext
);

Implements

IFormComponent.

See Also

OrderMain Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderMain.OnRefresh Method

protected override void OnRefresh();

Implements

IFormComponent.

See Also

OrderMain Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderMain.SetupPaneSizes Method

This method is responsible for setting up the sizes of the docking panes based on the user's prior saved values, if any. If the user has never modified the layout before, default values are pulled from the Entity Attributes: OrderFormTopAreaHeight, OrderFormMiddleAreaHeight,OrderFormBottomAreaHeight

protected virtual void SetupPaneSizes();

Remarks

See Also

OrderMain Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderMain.SetUserValue Method

This method is responsible for saving a user profile value into the database for the specified Application ID and Sequence provided. If there is an existing Application ID and Sequence matching for the current user, that row is updated, otherwise a new row in the UserValues entity is created.

public virtual bool SetUserValue(
Int64 ApplicationID,
Int64 Sequence,
String Name,
String Value
);

Parameters

ApplicationID
Sequence
Name
Value

Return Value

Remarks

See Also

OrderMain Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderMeetingDetailLayout Class

For a list of all members of this type, see OrderMeetingDetailLayout Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
OrderMeetingDetailLayout

public class OrderMeetingDetailLayout : FormTemplateLayout

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry.WindowsControls

Assembly: AptifyOMDControls (in AptifyOMDControls.dll)

See Also

OrderMeetingDetailLayout Members | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderMeetingDetailLayout Members

OrderMeetingDetailLayout overview

Public Instance Constructors

OrderMeetingDetailLayout Constructor Initializes a new instance of the OrderMeetingDetailLayout class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

m_aptSessions
m_txtCancelDate

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
ExtendedOrderLineGE |
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
m_chkIsExhibitor |
m_cmbBoothID |
m_cmbStatusID |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
EnableDisableControl |
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControls |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitializeControls |
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig |
OnFormTemplateLoaded |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoothComboData |
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlVisibilityForShippedOrder |
SetControlVisibilityForUnshippedOrder |
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

OrderMeetingDetailLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderMeetingDetailLayout Constructor

Initializes a new instance of the OrderMeetingDetailLayout class.

public OrderMeetingDetailLayout();

See Also

OrderMeetingDetailLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderMeetingDetailLayout Fields

The fields of the OrderMeetingDetailLayout class are listed below. For a complete list of OrderMeetingDetailLayout class members, see the OrderMeetingDetailLayout Members topic.

Protected Instance Fields

m_aptSessions
m_txtCancelDate

See Also

OrderMeetingDetailLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderMeetingDetailLayout.m_aptSessions Field

protected m_aptSessions m_aptSessions;

See Also

OrderMeetingDetailLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderMeetingDetailLayout.m_txtCancelDate Field

protected m_txtCancelDate m_txtCancelDate;

See Also

OrderMeetingDetailLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderMeetingDetailLayout Properties

The properties of the OrderMeetingDetailLayout class are listed below. For a complete list of OrderMeetingDetailLayout class members, see the OrderMeetingDetailLayout Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
ExtendedOrderLineGE |
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
m_chkIsExhibitor |
m_cmbBoothID |
m_cmbStatusID |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

OrderMeetingDetailLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


ExtendedOrderLineGE Property

Aptify 5.0 Software Development Kit (SDK)

OrderMeetingDetailLayout.ExtendedOrderLineGE Property

protected ExtendedOrderDetailGE ExtendedOrderLineGE {get;}

See Also

OrderMeetingDetailLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


m_chkIsExhibitor Property

Aptify 5.0 Software Development Kit (SDK)

OrderMeetingDetailLayout.m_chkIsExhibitor Property

protected virtual AptifyCheckBox m_chkIsExhibitor {get; set;}

See Also

OrderMeetingDetailLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


m_cmbBoothID Property

Aptify 5.0 Software Development Kit (SDK)

OrderMeetingDetailLayout.m_cmbBoothID Property

protected virtual AptifyDataComboBox m_cmbBoothID {get; set;}

See Also

OrderMeetingDetailLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


m_cmbStatusID Property

Aptify 5.0 Software Development Kit (SDK)

OrderMeetingDetailLayout.m_cmbStatusID Property

protected virtual AptifyDataComboBox m_cmbStatusID {get; set;}

See Also

OrderMeetingDetailLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderMeetingDetailLayout Methods

The methods of the OrderMeetingDetailLayout class are listed below. For a complete list of OrderMeetingDetailLayout class members, see the OrderMeetingDetailLayout Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
EnableDisableControl |
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControls |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitializeControls |
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig |
OnFormTemplateLoaded |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoothComboData |
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlVisibilityForShippedOrder |
SetControlVisibilityForUnshippedOrder |
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

OrderMeetingDetailLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

OrderMeetingDetailLayout.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

OrderMeetingDetailLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderMeetingDetailLayout.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

OrderMeetingDetailLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace | OrderMeetingDetailLayout.Dispose Overload List


OrderMeetingDetailLayout.EnableDisableControl Method

protected virtual void EnableDisableControl(
Control oControl,
Boolean bEnable,
Boolean bIncludeChildren
);

See Also

OrderMeetingDetailLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderMeetingDetailLayout.FindControls Method

protected virtual void FindControls();

See Also

OrderMeetingDetailLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderMeetingDetailLayout.InitializeControls Method

protected void InitializeControls();

See Also

OrderMeetingDetailLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderMeetingDetailLayout.OnFormComponentConfig Method

protected override void OnFormComponentConfig(
AptifyFormTemplateContext Context
);

Implements

IFormComponent.

See Also

OrderMeetingDetailLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderMeetingDetailLayout.OnFormTemplateLoaded Method

protected override void OnFormTemplateLoaded(
FormTemplateLayout.FormTemplateLoadedEventArgs e
);

See Also

OrderMeetingDetailLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderMeetingDetailLayout.SetBoothComboData Method

protected virtual void SetBoothComboData();

See Also

OrderMeetingDetailLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderMeetingDetailLayout.SetControlVisibilityForShippedOrder Method

protected virtual void SetControlVisibilityForShippedOrder();

See Also

OrderMeetingDetailLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderMeetingDetailLayout.SetControlVisibilityForUnshippedOrder Method

protected virtual void SetControlVisibilityForUnshippedOrder();

See Also

OrderMeetingDetailLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderPaymentsLayout Class

For a list of all members of this type, see OrderPaymentsLayout Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
OrderSTLayoutBase
OrderPaymentsLayout

public class OrderPaymentsLayout : OrderSTLayoutBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry.WindowsControls

Assembly: OrderControls (in OrderControls.dll)

See Also

OrderPaymentsLayout Members | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderPaymentsLayout Members

OrderPaymentsLayout overview

Public Instance Constructors

OrderPaymentsLayout Constructor Initializes a new instance of the OrderPaymentsLayout class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

m_txtAmount

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
OrderGE (inherited from OrderSTLayoutBase) |
OrderSTGE (inherited from OrderSTLayoutBase) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
EnableDisableControl (inherited from OrderSTLayoutBase) | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControls |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitializeControls |
InitializeObjects (inherited from OrderSTLayoutBase) |
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from OrderSTLayoutBase) |
OnFormTemplateLoaded |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlVisibilityForShippedOrder |
SetControlVisibilityForUnshippedOrder |
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

OrderPaymentsLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderPaymentsLayout Constructor

Initializes a new instance of the OrderPaymentsLayout class.

public OrderPaymentsLayout();

See Also

OrderPaymentsLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderPaymentsLayout Fields

The fields of the OrderPaymentsLayout class are listed below. For a complete list of OrderPaymentsLayout class members, see the OrderPaymentsLayout Members topic.

Protected Instance Fields

m_txtAmount

See Also

OrderPaymentsLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderPaymentsLayout.m_txtAmount Field

protected m_txtAmount m_txtAmount;

See Also

OrderPaymentsLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderPaymentsLayout Methods

The methods of the OrderPaymentsLayout class are listed below. For a complete list of OrderPaymentsLayout class members, see the OrderPaymentsLayout Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
EnableDisableControl (inherited from OrderSTLayoutBase) | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControls |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitializeControls |
InitializeObjects (inherited from OrderSTLayoutBase) |
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from OrderSTLayoutBase) |
OnFormTemplateLoaded |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlVisibilityForShippedOrder |
SetControlVisibilityForUnshippedOrder |
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

OrderPaymentsLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

OrderPaymentsLayout.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

OrderPaymentsLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderPaymentsLayout.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

OrderPaymentsLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace | OrderPaymentsLayout.Dispose Overload List


OrderPaymentsLayout.FindControls Method

protected virtual void FindControls();

See Also

OrderPaymentsLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderPaymentsLayout.InitializeControls Method

protected void InitializeControls();

See Also

OrderPaymentsLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderPaymentsLayout.OnFormTemplateLoaded Method

protected override void OnFormTemplateLoaded(
FormTemplateLayout.FormTemplateLoadedEventArgs e
);

See Also

OrderPaymentsLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderPaymentsLayout.SetControlVisibilityForShippedOrder Method

protected virtual void SetControlVisibilityForShippedOrder();

See Also

OrderPaymentsLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderPaymentsLayout.SetControlVisibilityForUnshippedOrder Method

protected virtual void SetControlVisibilityForUnshippedOrder();

See Also

OrderPaymentsLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderShipmentsLayout Class

For a list of all members of this type, see OrderShipmentsLayout Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
OrderSTLayoutBase
OrderShipmentsLayout

public class OrderShipmentsLayout : OrderSTLayoutBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry.WindowsControls

Assembly: OrderControls (in OrderControls.dll)

See Also

OrderShipmentsLayout Members | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderShipmentsLayout Members

OrderShipmentsLayout overview

Public Instance Constructors

OrderShipmentsLayout Constructor Initializes a new instance of the OrderShipmentsLayout class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

m_ctlCustShippingAcctNum
m_ctlOverrideHandlingCalc
m_ctlOverrideShippingCalc
m_ctlShipmentTypeGroupingID
m_ctlShipmentTypeMatrixID
m_ctlShipToID
m_ctlShipTrackingNum
m_ctlShipTypeID
m_ctlTaxIncludedInCharges
m_ctlTaxJurisdictionID
m_ctlTotalQuantity
m_ctlTotalWeight
m_ctlWeightUnits
m_txtHandlingCharge
m_txtShippingCharge
m_txtShippingCost

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
m_stOrderShipmentTaxes |
OrderGE (inherited from OrderSTLayoutBase) |
OrderSTGE (inherited from OrderSTLayoutBase) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
EnableDisableControl (inherited from OrderSTLayoutBase) | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControls |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetSubTypeControl | This method is responsible for finding a sub-type control within the form template based on the name of the Sub Type.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitializeControls |
InitializeObjects (inherited from OrderSTLayoutBase) |
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from OrderSTLayoutBase) |
OnFormTemplateLoaded |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlVisibilityForShippedOrder |
SetControlVisibilityForUnshippedOrder |
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

OrderShipmentsLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderShipmentsLayout Constructor

Initializes a new instance of the OrderShipmentsLayout class.

public OrderShipmentsLayout();

See Also

OrderShipmentsLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderShipmentsLayout Fields

The fields of the OrderShipmentsLayout class are listed below. For a complete list of OrderShipmentsLayout class members, see the OrderShipmentsLayout Members topic.

Protected Instance Fields

m_ctlCustShippingAcctNum
m_ctlOverrideHandlingCalc
m_ctlOverrideShippingCalc
m_ctlShipmentTypeGroupingID
m_ctlShipmentTypeMatrixID
m_ctlShipToID
m_ctlShipTrackingNum
m_ctlShipTypeID
m_ctlTaxIncludedInCharges
m_ctlTaxJurisdictionID
m_ctlTotalQuantity
m_ctlTotalWeight
m_ctlWeightUnits
m_txtHandlingCharge
m_txtShippingCharge
m_txtShippingCost

See Also

OrderShipmentsLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderShipmentsLayout.m_ctlCustShippingAcctNum Field

protected m_ctlCustShippingAcctNum m_ctlCustShippingAcctNum;

See Also

OrderShipmentsLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderShipmentsLayout.m_ctlOverrideHandlingCalc Field

protected m_ctlOverrideHandlingCalc m_ctlOverrideHandlingCalc;

See Also

OrderShipmentsLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderShipmentsLayout.m_ctlOverrideShippingCalc Field

protected m_ctlOverrideShippingCalc m_ctlOverrideShippingCalc;

See Also

OrderShipmentsLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderShipmentsLayout.m_ctlShipmentTypeGroupingID Field

protected m_ctlShipmentTypeGroupingID m_ctlShipmentTypeGroupingID;

See Also

OrderShipmentsLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderShipmentsLayout.m_ctlShipmentTypeMatrixID Field

protected m_ctlShipmentTypeMatrixID m_ctlShipmentTypeMatrixID;

See Also

OrderShipmentsLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderShipmentsLayout.m_ctlShipToID Field

protected m_ctlShipToID m_ctlShipToID;

See Also

OrderShipmentsLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderShipmentsLayout.m_ctlShipTrackingNum Field

protected m_ctlShipTrackingNum m_ctlShipTrackingNum;

See Also

OrderShipmentsLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderShipmentsLayout.m_ctlShipTypeID Field

protected m_ctlShipTypeID m_ctlShipTypeID;

See Also

OrderShipmentsLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderShipmentsLayout.m_ctlTaxIncludedInCharges Field

protected m_ctlTaxIncludedInCharges m_ctlTaxIncludedInCharges;

See Also

OrderShipmentsLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderShipmentsLayout.m_ctlTaxJurisdictionID Field

protected m_ctlTaxJurisdictionID m_ctlTaxJurisdictionID;

See Also

OrderShipmentsLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderShipmentsLayout.m_ctlTotalQuantity Field

protected m_ctlTotalQuantity m_ctlTotalQuantity;

See Also

OrderShipmentsLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderShipmentsLayout.m_ctlTotalWeight Field

protected m_ctlTotalWeight m_ctlTotalWeight;

See Also

OrderShipmentsLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderShipmentsLayout.m_ctlWeightUnits Field

protected m_ctlWeightUnits m_ctlWeightUnits;

See Also

OrderShipmentsLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderShipmentsLayout.m_txtHandlingCharge Field

protected m_txtHandlingCharge m_txtHandlingCharge;

See Also

OrderShipmentsLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderShipmentsLayout.m_txtShippingCharge Field

protected m_txtShippingCharge m_txtShippingCharge;

See Also

OrderShipmentsLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderShipmentsLayout.m_txtShippingCost Field

protected m_txtShippingCost m_txtShippingCost;

See Also

OrderShipmentsLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderShipmentsLayout Properties

The properties of the OrderShipmentsLayout class are listed below. For a complete list of OrderShipmentsLayout class members, see the OrderShipmentsLayout Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
m_stOrderShipmentTaxes |
OrderGE (inherited from OrderSTLayoutBase) |
OrderSTGE (inherited from OrderSTLayoutBase) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

OrderShipmentsLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


m_stOrderShipmentTaxes Property

Aptify 5.0 Software Development Kit (SDK)

OrderShipmentsLayout.m_stOrderShipmentTaxes Property

protected virtual AptifySubType m_stOrderShipmentTaxes {get; set;}

See Also

OrderShipmentsLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderShipmentsLayout Methods

The methods of the OrderShipmentsLayout class are listed below. For a complete list of OrderShipmentsLayout class members, see the OrderShipmentsLayout Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
EnableDisableControl (inherited from OrderSTLayoutBase) | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControls |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetSubTypeControl | This method is responsible for finding a sub-type control within the form template based on the name of the Sub Type.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitializeControls |
InitializeObjects (inherited from OrderSTLayoutBase) |
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from OrderSTLayoutBase) |
OnFormTemplateLoaded |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlVisibilityForShippedOrder |
SetControlVisibilityForUnshippedOrder |
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

OrderShipmentsLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

OrderShipmentsLayout.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

OrderShipmentsLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderShipmentsLayout.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

OrderShipmentsLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace | OrderShipmentsLayout.Dispose Overload List


OrderShipmentsLayout.FindControls Method

protected virtual void FindControls();

See Also

OrderShipmentsLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderShipmentsLayout.GetSubTypeControl Method

This method is responsible for finding a sub-type control within the form template based on the name of the Sub Type.

protected virtual AptifySubType GetSubTypeControl(
Control ParentControl,
String SubTypeName
);

Parameters

ParentControl
SubTypeName

Return Value

Remarks

See Also

OrderShipmentsLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderShipmentsLayout.InitializeControls Method

protected void InitializeControls();

See Also

OrderShipmentsLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderShipmentsLayout.OnFormTemplateLoaded Method

protected override void OnFormTemplateLoaded(
FormTemplateLayout.FormTemplateLoadedEventArgs e
);

See Also

OrderShipmentsLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderShipmentsLayout.OnTransferDataToObject Method

protected override void OnTransferDataToObject(
ref Boolean& Cancel
);

Implements

IFormComponent.

See Also

OrderShipmentsLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderShipmentsLayout.SetControlVisibilityForShippedOrder Method

protected virtual void SetControlVisibilityForShippedOrder();

See Also

OrderShipmentsLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderShipmentsLayout.SetControlVisibilityForUnshippedOrder Method

protected virtual void SetControlVisibilityForUnshippedOrder();

See Also

OrderShipmentsLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderShipmentTaxesLayout Class

For a list of all members of this type, see OrderShipmentTaxesLayout Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
OrderSTLayoutBase
OrderShipmentTaxesLayout

public class OrderShipmentTaxesLayout : OrderSTLayoutBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry.WindowsControls

Assembly: OrderControls (in OrderControls.dll)

See Also

OrderShipmentTaxesLayout Members | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderShipmentTaxesLayout Members

OrderShipmentTaxesLayout overview

Public Instance Constructors

OrderShipmentTaxesLayout Constructor Initializes a new instance of the OrderShipmentTaxesLayout class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

m_txtTax
m_txtTaxableAmount

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
OrderGE (inherited from OrderSTLayoutBase) |
OrderSTGE (inherited from OrderSTLayoutBase) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
EnableDisableControl (inherited from OrderSTLayoutBase) | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControls |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitializeControls |
InitializeObjects (inherited from OrderSTLayoutBase) |
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from OrderSTLayoutBase) |
OnFormTemplateLoaded |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlVisibilityForShippedOrder |
SetControlVisibilityForUnshippedOrder |
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

OrderShipmentTaxesLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderShipmentTaxesLayout Constructor

Initializes a new instance of the OrderShipmentTaxesLayout class.

public OrderShipmentTaxesLayout();

See Also

OrderShipmentTaxesLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderShipmentTaxesLayout Fields

The fields of the OrderShipmentTaxesLayout class are listed below. For a complete list of OrderShipmentTaxesLayout class members, see the OrderShipmentTaxesLayout Members topic.

Protected Instance Fields

m_txtTax
m_txtTaxableAmount

See Also

OrderShipmentTaxesLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderShipmentTaxesLayout.m_txtTax Field

protected m_txtTax m_txtTax;

See Also

OrderShipmentTaxesLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderShipmentTaxesLayout.m_txtTaxableAmount Field

protected m_txtTaxableAmount m_txtTaxableAmount;

See Also

OrderShipmentTaxesLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderShipmentTaxesLayout Methods

The methods of the OrderShipmentTaxesLayout class are listed below. For a complete list of OrderShipmentTaxesLayout class members, see the OrderShipmentTaxesLayout Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
EnableDisableControl (inherited from OrderSTLayoutBase) | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControls |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitializeControls |
InitializeObjects (inherited from OrderSTLayoutBase) |
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from OrderSTLayoutBase) |
OnFormTemplateLoaded |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlVisibilityForShippedOrder |
SetControlVisibilityForUnshippedOrder |
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

OrderShipmentTaxesLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

OrderShipmentTaxesLayout.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

OrderShipmentTaxesLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderShipmentTaxesLayout.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

OrderShipmentTaxesLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace | OrderShipmentTaxesLayout.Dispose Overload List


OrderShipmentTaxesLayout.FindControls Method

protected virtual void FindControls();

See Also

OrderShipmentTaxesLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderShipmentTaxesLayout.InitializeControls Method

protected void InitializeControls();

See Also

OrderShipmentTaxesLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderShipmentTaxesLayout.OnFormTemplateLoaded Method

protected override void OnFormTemplateLoaded(
FormTemplateLayout.FormTemplateLoadedEventArgs e
);

See Also

OrderShipmentTaxesLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderShipmentTaxesLayout.SetControlVisibilityForShippedOrder Method

protected virtual void SetControlVisibilityForShippedOrder();

See Also

OrderShipmentTaxesLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderShipmentTaxesLayout.SetControlVisibilityForUnshippedOrder Method

protected virtual void SetControlVisibilityForUnshippedOrder();

See Also

OrderShipmentTaxesLayout Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderSTLayoutBase Class

For a list of all members of this type, see OrderSTLayoutBase Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
OrderSTLayoutBase
Derived types

public class OrderSTLayoutBase : FormTemplateLayout

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry.WindowsControls

Assembly: OrderControls (in OrderControls.dll)

See Also

OrderSTLayoutBase Members | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderSTLayoutBase Members

OrderSTLayoutBase overview

Public Instance Constructors

OrderSTLayoutBase Constructor Initializes a new instance of the OrderSTLayoutBase class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
OrderGE |
OrderSTGE |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
EnableDisableControl | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitializeObjects |
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig |
OnFormTemplateLoaded |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

OrderSTLayoutBase Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderSTLayoutBase Constructor

Initializes a new instance of the OrderSTLayoutBase class.

public OrderSTLayoutBase();

See Also

OrderSTLayoutBase Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderSTLayoutBase Properties

The properties of the OrderSTLayoutBase class are listed below. For a complete list of OrderSTLayoutBase class members, see the OrderSTLayoutBase Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
OrderGE |
OrderSTGE |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

OrderSTLayoutBase Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderGE Property

Aptify 5.0 Software Development Kit (SDK)

OrderSTLayoutBase.OrderGE Property

protected OrdersEntity OrderGE {get;}

See Also

OrderSTLayoutBase Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderSTGE Property

Aptify 5.0 Software Development Kit (SDK)

OrderSTLayoutBase.OrderSTGE Property

protected AptifyGenericEntityBase OrderSTGE {get;}

See Also

OrderSTLayoutBase Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderSTLayoutBase Methods

The methods of the OrderSTLayoutBase class are listed below. For a complete list of OrderSTLayoutBase class members, see the OrderSTLayoutBase Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
EnableDisableControl | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitializeObjects |
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig |
OnFormTemplateLoaded |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

OrderSTLayoutBase Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

OrderSTLayoutBase.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

OrderSTLayoutBase Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderSTLayoutBase.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

OrderSTLayoutBase Class | Aptify.Applications.OrderEntry.WindowsControls Namespace | OrderSTLayoutBase.Dispose Overload List


EnableDisableControl Method

Aptify 5.0 Software Development Kit (SDK)

OrderSTLayoutBase.EnableDisableControl Method

Overload List

protected virtual void EnableDisableControl(Boolean,Control,Boolean);

protected virtual void EnableDisableControl(Control,Boolean);

protected virtual void EnableDisableControl(Control,Boolean,Boolean);

See Also

OrderSTLayoutBase Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderSTLayoutBase.EnableDisableControl Method (Boolean, Control, Boolean)

protected virtual void EnableDisableControl(
Boolean bOverrideDefault,
Control oControl,
Boolean bEnable
);

See Also

OrderSTLayoutBase Class | Aptify.Applications.OrderEntry.WindowsControls Namespace | OrderSTLayoutBase.EnableDisableControl Overload List


OrderSTLayoutBase.EnableDisableControl Method (Control, Boolean)

protected virtual void EnableDisableControl(
Control oControl,
Boolean bEnable
);

See Also

OrderSTLayoutBase Class | Aptify.Applications.OrderEntry.WindowsControls Namespace | OrderSTLayoutBase.EnableDisableControl Overload List


OrderSTLayoutBase.EnableDisableControl Method (Control, Boolean, Boolean)

protected virtual void EnableDisableControl(
Control oControl,
Boolean bEnable,
Boolean bIncludeChildren
);

See Also

OrderSTLayoutBase Class | Aptify.Applications.OrderEntry.WindowsControls Namespace | OrderSTLayoutBase.EnableDisableControl Overload List


OrderSTLayoutBase.InitializeObjects Method

protected virtual void InitializeObjects();

See Also

OrderSTLayoutBase Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderSTLayoutBase.OnFormComponentConfig Method

protected override void OnFormComponentConfig(
AptifyFormTemplateContext Context
);

Implements

IFormComponent.

See Also

OrderSTLayoutBase Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderSTLayoutBase.OnFormTemplateLoaded Method

protected override void OnFormTemplateLoaded(
FormTemplateLayout.FormTemplateLoadedEventArgs e
);

See Also

OrderSTLayoutBase Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderTextButton Class

For a list of all members of this type, see OrderTextButton Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
OrderTextButton

public class OrderTextButton : FormComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry.WindowsControls

Assembly: OrderControls (in OrderControls.dll)

See Also

OrderTextButton Members | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderTextButton Members

OrderTextButton overview

Public Instance Constructors

OrderTextButton Constructor Initializes a new instance of the OrderTextButton class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
ButtonText |
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
ExtendedButtonEnabled |
ExtendedButtonVisible |
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormatString |
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LabelSize |
LabelText |
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
TextControlEnabled |
ToolTipText |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormComponent) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
ExtendedButtonClick |
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateContext (inherited from FormComponent) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormComponent) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormComponent) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormComponent) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

OrderTextButton Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderTextButton Constructor

Initializes a new instance of the OrderTextButton class.

public OrderTextButton();

See Also

OrderTextButton Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderTextButton Properties

The properties of the OrderTextButton class are listed below. For a complete list of OrderTextButton class members, see the OrderTextButton Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
ButtonText |
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
ExtendedButtonEnabled |
ExtendedButtonVisible |
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormatString |
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LabelSize |
LabelText |
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
TextControlEnabled |
ToolTipText |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateContext (inherited from FormComponent) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

OrderTextButton Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


ButtonText Property

Aptify 5.0 Software Development Kit (SDK)

OrderTextButton.ButtonText Property

public String ButtonText {get; set;}

See Also

OrderTextButton Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


ExtendedButtonEnabled Property

Aptify 5.0 Software Development Kit (SDK)

OrderTextButton.ExtendedButtonEnabled Property

public Boolean ExtendedButtonEnabled {get; set;}

See Also

OrderTextButton Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


ExtendedButtonVisible Property

Aptify 5.0 Software Development Kit (SDK)

OrderTextButton.ExtendedButtonVisible Property

public Boolean ExtendedButtonVisible {get; set;}

See Also

OrderTextButton Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


FormatString Property

Aptify 5.0 Software Development Kit (SDK)

OrderTextButton.FormatString Property

public String FormatString {get; set;}

See Also

OrderTextButton Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


LabelSize Property

Aptify 5.0 Software Development Kit (SDK)

OrderTextButton.LabelSize Property

public Int32 LabelSize {get; set;}

See Also

OrderTextButton Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


LabelText Property

Aptify 5.0 Software Development Kit (SDK)

OrderTextButton.LabelText Property

public String LabelText {get; set;}

See Also

OrderTextButton Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


TextControlEnabled Property

Aptify 5.0 Software Development Kit (SDK)

OrderTextButton.TextControlEnabled Property

public Boolean TextControlEnabled {get; set;}

See Also

OrderTextButton Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


ToolTipText Property

Aptify 5.0 Software Development Kit (SDK)

OrderTextButton.ToolTipText Property

public String ToolTipText {get; set;}

See Also

OrderTextButton Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderTextButton Methods

The methods of the OrderTextButton class are listed below. For a complete list of OrderTextButton class members, see the OrderTextButton Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormComponent) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormComponent) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormComponent) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormComponent) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

OrderTextButton Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

OrderTextButton.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

OrderTextButton Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderTextButton.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

OrderTextButton Class | Aptify.Applications.OrderEntry.WindowsControls Namespace | OrderTextButton.Dispose Overload List


OrderTextButton.OnFormComponentConfig Method

protected override void OnFormComponentConfig(
AptifyFormTemplateContext FormTemplateContext
);

Implements

IFormComponent.

See Also

OrderTextButton Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderTextButton Events

The events of the OrderTextButton class are listed below. For a complete list of OrderTextButton class members, see the OrderTextButton Members topic.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
ExtendedButtonClick |
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

OrderTextButton Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderTextButton.OrderTextButton.ExtendedButtonClickEventHandler Event

public event OrderTextButton.ExtendedButtonClickEventHandler ExtendedButtonClick;

See Also

OrderTextButton Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderTextButton.ExtendedButtonClickEventHandler Delegate

public delegate void OrderTextButton.ExtendedButtonClickEventHandler();

Requirements

Namespace: Aptify.Applications.OrderEntry.WindowsControls

Assembly: OrderControls (in OrderControls.dll)

See Also

Aptify.Applications.OrderEntry.WindowsControls Namespace


SessionInfo Class

For a list of all members of this type, see SessionInfo Members.

System.Object
SessionInfo

public class SessionInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry.WindowsControls

Assembly: AptifyOMDControls (in AptifyOMDControls.dll)

See Also

SessionInfo Members | Aptify.Applications.OrderEntry.WindowsControls Namespace


SessionInfo Members

SessionInfo overview

Public Instance Constructors

SessionInfo Constructor Initializes a new instance of the SessionInfo class.

Public Instance Properties

Description
EndDate
IsRegistered
MemberPrice
Name
NonMemberPrice
ProductID
SessionID
StartDate
WasRegistered

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SessionInfo Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


SessionInfo Constructor

Initializes a new instance of the SessionInfo class.

public SessionInfo();

See Also

SessionInfo Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


SessionInfo Properties

The properties of the SessionInfo class are listed below. For a complete list of SessionInfo class members, see the SessionInfo Members topic.

Public Instance Properties

Description
EndDate
IsRegistered
MemberPrice
Name
NonMemberPrice
ProductID
SessionID
StartDate
WasRegistered

See Also

SessionInfo Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


Description Property

Aptify 5.0 Software Development Kit (SDK)

SessionInfo.Description Property

public String Description {get; set;}

See Also

SessionInfo Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


EndDate Property

Aptify 5.0 Software Development Kit (SDK)

SessionInfo.EndDate Property

public DateTime EndDate {get; set;}

See Also

SessionInfo Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


IsRegistered Property

Aptify 5.0 Software Development Kit (SDK)

SessionInfo.IsRegistered Property

public Boolean IsRegistered {get; set;}

See Also

SessionInfo Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


MemberPrice Property

Aptify 5.0 Software Development Kit (SDK)

SessionInfo.MemberPrice Property

public Decimal MemberPrice {get; set;}

See Also

SessionInfo Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


Name Property

Aptify 5.0 Software Development Kit (SDK)

SessionInfo.Name Property

public String Name {get; set;}

See Also

SessionInfo Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


NonMemberPrice Property

Aptify 5.0 Software Development Kit (SDK)

SessionInfo.NonMemberPrice Property

public Decimal NonMemberPrice {get; set;}

See Also

SessionInfo Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


ProductID Property

Aptify 5.0 Software Development Kit (SDK)

SessionInfo.ProductID Property

public Int64 ProductID {get; set;}

See Also

SessionInfo Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


SessionID Property

Aptify 5.0 Software Development Kit (SDK)

SessionInfo.SessionID Property

public Int64 SessionID {get; set;}

See Also

SessionInfo Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


StartDate Property

Aptify 5.0 Software Development Kit (SDK)

SessionInfo.StartDate Property

public DateTime StartDate {get; set;}

See Also

SessionInfo Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


WasRegistered Property

Aptify 5.0 Software Development Kit (SDK)

SessionInfo.WasRegistered Property

public Boolean WasRegistered {get; set;}

See Also

SessionInfo Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


SessionsControl Class

For a list of all members of this type, see SessionsControl Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
SessionsControl

public class SessionsControl : FormComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry.WindowsControls

Assembly: AptifyOMDControls (in AptifyOMDControls.dll)

See Also

SessionsControl Members | Aptify.Applications.OrderEntry.WindowsControls Namespace


SessionsControl Members

SessionsControl overview

Public Instance Constructors

SessionsControl Constructor Initializes a new instance of the SessionsControl class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrencyFormatString |
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormComponent) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateContext (inherited from FormComponent) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormComponent) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

SessionsControl Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


SessionsControl Constructor

Initializes a new instance of the SessionsControl class.

public SessionsControl();

See Also

SessionsControl Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


SessionsControl Properties

The properties of the SessionsControl class are listed below. For a complete list of SessionsControl class members, see the SessionsControl Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrencyFormatString |
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateContext (inherited from FormComponent) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

SessionsControl Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


CurrencyFormatString Property

Aptify 5.0 Software Development Kit (SDK)

SessionsControl.CurrencyFormatString Property

public String CurrencyFormatString {get; set;}

See Also

SessionsControl Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


SessionsControl Methods

The methods of the SessionsControl class are listed below. For a complete list of SessionsControl class members, see the SessionsControl Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormComponent) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormComponent) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

SessionsControl Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

SessionsControl.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

SessionsControl Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


SessionsControl.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

SessionsControl Class | Aptify.Applications.OrderEntry.WindowsControls Namespace | SessionsControl.Dispose Overload List


SessionsControl.OnFormComponentConfig Method

protected override void OnFormComponentConfig(
AptifyFormTemplateContext FormTemplateContext
);

Implements

IFormComponent.

See Also

SessionsControl Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


SessionsControl.OnRefresh Method

protected override void OnRefresh();

Implements

IFormComponent.

See Also

SessionsControl Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OnShow Method

Aptify 5.0 Software Development Kit (SDK)

SessionsControl.OnShow Method

Overload List

protected override void OnShow();

Inherited from FormComponent.

protected virtual void OnShow(Boolean);

See Also

SessionsControl Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


SessionsControl.OnShow Method ()

protected override void OnShow();

Implements

IFormComponent.

See Also

SessionsControl Class | Aptify.Applications.OrderEntry.WindowsControls Namespace | SessionsControl.OnShow Overload List


SessionsControl.OnTransferDataToObject Method

protected override void OnTransferDataToObject(
ref Boolean& Cancel
);

Implements

IFormComponent.

See Also

SessionsControl Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


SessionsUtility Class

For a list of all members of this type, see SessionsUtility Members.

System.Object
SessionsUtility

public class SessionsUtility

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry.WindowsControls

Assembly: AptifyOMDControls (in AptifyOMDControls.dll)

See Also

SessionsUtility Members | Aptify.Applications.OrderEntry.WindowsControls Namespace


SessionsUtility Members

SessionsUtility overview

Public Instance Constructors

SessionsUtility Constructor

Public Instance Properties

OrderLineGE
OrderMeetingDetail
Sessions
UseMemberPrices

Public Instance Methods

CopyData |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
LoadSessions | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

DataAction
MeetingBasePrice

Protected Instance Methods

CalculateSessionTotal |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetCheckedItems |

See Also

SessionsUtility Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


SessionsUtility Constructor

public SessionsUtility(
AptifyApplication Application
);

See Also

SessionsUtility Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


SessionsUtility Properties

The properties of the SessionsUtility class are listed below. For a complete list of SessionsUtility class members, see the SessionsUtility Members topic.

Public Instance Properties

OrderLineGE
OrderMeetingDetail
Sessions
UseMemberPrices

Protected Instance Properties

DataAction
MeetingBasePrice

See Also

SessionsUtility Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


DataAction Property

Aptify 5.0 Software Development Kit (SDK)

SessionsUtility.DataAction Property

protected DataAction DataAction {get;}

See Also

SessionsUtility Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


MeetingBasePrice Property

Aptify 5.0 Software Development Kit (SDK)

SessionsUtility.MeetingBasePrice Property

protected Decimal MeetingBasePrice {get;}

See Also

SessionsUtility Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderLineGE Property

Aptify 5.0 Software Development Kit (SDK)

SessionsUtility.OrderLineGE Property

public OrderLinesEntity OrderLineGE {get;}

See Also

SessionsUtility Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


OrderMeetingDetail Property

Aptify 5.0 Software Development Kit (SDK)

SessionsUtility.OrderMeetingDetail Property

public OrderMeetingDetailEntity OrderMeetingDetail {get; set;}

See Also

SessionsUtility Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


Sessions Property

Aptify 5.0 Software Development Kit (SDK)

SessionsUtility.Sessions Property

public Dictionary<TKey,TValue> Sessions {get;}

See Also

SessionsUtility Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


UseMemberPrices Property

Aptify 5.0 Software Development Kit (SDK)

SessionsUtility.UseMemberPrices Property

public Boolean UseMemberPrices {get; set;}

See Also

SessionsUtility Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


SessionsUtility Methods

The methods of the SessionsUtility class are listed below. For a complete list of SessionsUtility class members, see the SessionsUtility Members topic.

Public Instance Methods

CopyData |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
LoadSessions | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CalculateSessionTotal |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetCheckedItems |

See Also

SessionsUtility Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


SessionsUtility.CalculateSessionTotal Method

protected decimal CalculateSessionTotal();

See Also

SessionsUtility Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


SessionsUtility.CopyData Method

public virtual bool CopyData();

See Also

SessionsUtility Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


LoadSessions Method

Aptify 5.0 Software Development Kit (SDK)

SessionsUtility.LoadSessions Method

Overload List

public virtual void LoadSessions();

public virtual void LoadSessions(Int64);

See Also

SessionsUtility Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


SessionsUtility.LoadSessions Method ()

public virtual void LoadSessions();

See Also

SessionsUtility Class | Aptify.Applications.OrderEntry.WindowsControls Namespace | SessionsUtility.LoadSessions Overload List


SessionsUtility.LoadSessions Method (Int64)

public virtual void LoadSessions(
Int64 lProductID
);

See Also

SessionsUtility Class | Aptify.Applications.OrderEntry.WindowsControls Namespace | SessionsUtility.LoadSessions Overload List


SessionsUtility.SetCheckedItems Method

protected void SetCheckedItems();

See Also

SessionsUtility Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


ShippingHandlingDetailsForm Class

For a list of all members of this type, see ShippingHandlingDetailsForm Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
ShippingHandlingDetailsForm

public class ShippingHandlingDetailsForm : Form

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry.WindowsControls

Assembly: OrderControls (in OrderControls.dll)

See Also

ShippingHandlingDetailsForm Members | Aptify.Applications.OrderEntry.WindowsControls Namespace


ShippingHandlingDetailsForm Members

ShippingHandlingDetailsForm overview

Public Instance Constructors

ShippingHandlingDetailsForm Constructor

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrencyTypeFormat |
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ShippingHandlingDetailsForm Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


ShippingHandlingDetailsForm Constructor

public ShippingHandlingDetailsForm(
IDataControl DataControl
);

See Also

ShippingHandlingDetailsForm Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


ShippingHandlingDetailsForm Properties

The properties of the ShippingHandlingDetailsForm class are listed below. For a complete list of ShippingHandlingDetailsForm class members, see the ShippingHandlingDetailsForm Members topic.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrencyTypeFormat |
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

ShippingHandlingDetailsForm Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


CurrencyTypeFormat Property

Aptify 5.0 Software Development Kit (SDK)

ShippingHandlingDetailsForm.CurrencyTypeFormat Property

public String CurrencyTypeFormat {get; set;}

See Also

ShippingHandlingDetailsForm Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


ShippingHandlingDetailsForm Methods

The methods of the ShippingHandlingDetailsForm class are listed below. For a complete list of ShippingHandlingDetailsForm class members, see the ShippingHandlingDetailsForm Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ShippingHandlingDetailsForm Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


ShippingHandlingDetailsForm.ApplySkin Method

protected virtual void ApplySkin();

See Also

ShippingHandlingDetailsForm Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

ShippingHandlingDetailsForm.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

ShippingHandlingDetailsForm Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


ShippingHandlingDetailsForm.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

ShippingHandlingDetailsForm Class | Aptify.Applications.OrderEntry.WindowsControls Namespace | ShippingHandlingDetailsForm.Dispose Overload List


TaxDetailsForm Class

For a list of all members of this type, see TaxDetailsForm Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
TaxDetailsForm

public class TaxDetailsForm : Form

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry.WindowsControls

Assembly: OrderControls (in OrderControls.dll)

See Also

TaxDetailsForm Members | Aptify.Applications.OrderEntry.WindowsControls Namespace


TaxDetailsForm Members

TaxDetailsForm overview

Public Instance Constructors

TaxDetailsForm Constructor

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

TaxDetailsForm Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


TaxDetailsForm Constructor

public TaxDetailsForm(
AptifyApplication Application,
OrdersEntity OrdersEntityObject
);

See Also

TaxDetailsForm Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


TaxDetailsForm Methods

The methods of the TaxDetailsForm class are listed below. For a complete list of TaxDetailsForm class members, see the TaxDetailsForm Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

TaxDetailsForm Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


TaxDetailsForm.ApplySkin Method

protected virtual void ApplySkin();

See Also

TaxDetailsForm Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

TaxDetailsForm.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

TaxDetailsForm Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


TaxDetailsForm.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

TaxDetailsForm Class | Aptify.Applications.OrderEntry.WindowsControls Namespace | TaxDetailsForm.Dispose Overload List


TaxDetailsForm.SalesTaxInfo Class

For a list of all members of this type, see TaxDetailsForm.SalesTaxInfo Members.

System.Object
TaxDetailsForm.SalesTaxInfo

public class TaxDetailsForm.SalesTaxInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.OrderEntry.WindowsControls

Assembly: OrderControls (in OrderControls.dll)

See Also

TaxDetailsForm.SalesTaxInfo Members | Aptify.Applications.OrderEntry.WindowsControls Namespace


TaxDetailsForm.SalesTaxInfo Members

TaxDetailsForm.SalesTaxInfo overview

Public Instance Constructors

TaxDetailsForm.SalesTaxInfo Constructor Initializes a new instance of the TaxDetailsForm.SalesTaxInfo class.

Public Instance Properties

Jurisdiction
Rate
RateName
SalesTaxAmount
TaxExempted

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TaxDetailsForm.SalesTaxInfo Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


TaxDetailsForm.SalesTaxInfo Constructor

Initializes a new instance of the TaxDetailsForm.SalesTaxInfo class.

public TaxDetailsForm.SalesTaxInfo();

See Also

TaxDetailsForm.SalesTaxInfo Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


TaxDetailsForm.SalesTaxInfo Properties

The properties of the TaxDetailsForm.SalesTaxInfo class are listed below. For a complete list of TaxDetailsForm.SalesTaxInfo class members, see the TaxDetailsForm.SalesTaxInfo Members topic.

Public Instance Properties

Jurisdiction
Rate
RateName
SalesTaxAmount
TaxExempted

See Also

TaxDetailsForm.SalesTaxInfo Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


Jurisdiction Property

Aptify 5.0 Software Development Kit (SDK)

TaxDetailsForm.SalesTaxInfo.Jurisdiction Property

public String Jurisdiction {get; set;}

See Also

TaxDetailsForm.SalesTaxInfo Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


Rate Property

Aptify 5.0 Software Development Kit (SDK)

TaxDetailsForm.SalesTaxInfo.Rate Property

public Decimal Rate {get; set;}

See Also

TaxDetailsForm.SalesTaxInfo Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


RateName Property

Aptify 5.0 Software Development Kit (SDK)

TaxDetailsForm.SalesTaxInfo.RateName Property

public String RateName {get; set;}

See Also

TaxDetailsForm.SalesTaxInfo Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


SalesTaxAmount Property

Aptify 5.0 Software Development Kit (SDK)

TaxDetailsForm.SalesTaxInfo.SalesTaxAmount Property

public SalesTaxAmount SalesTaxAmount {get; set;}

See Also

TaxDetailsForm.SalesTaxInfo Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


TaxExempted Property

Aptify 5.0 Software Development Kit (SDK)

TaxDetailsForm.SalesTaxInfo.TaxExempted Property

public String TaxExempted {get; set;}

See Also

TaxDetailsForm.SalesTaxInfo Class | Aptify.Applications.OrderEntry.WindowsControls Namespace


Aptify.Applications.Organization

Aptify 5.0 Software Development Kit (SDK)

Aptify.Applications.Organization Namespace

This namespace defines the logic and form template used by the Organizations entity.

Namespace hierarchy

Classes

Class | Description
OrganizationLayout |
OrganizationObject |


OrganizationLayout Class

For a list of all members of this type, see OrganizationLayout Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
OrganizationLayout

public class OrganizationLayout : FormTemplateLayout

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Organization

Assembly: OrganizationLayout (in OrganizationLayout.dll)

See Also

OrganizationLayout Members | Aptify.Applications.Organization Namespace


OrganizationLayout Members

OrganizationLayout overview

Public Instance Constructors

OrganizationLayout Constructor Initializes a new instance of the OrganizationLayout class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

OrganizationLayout Class | Aptify.Applications.Organization Namespace


OrganizationLayout Constructor

Initializes a new instance of the OrganizationLayout class.

public OrganizationLayout();

See Also

OrganizationLayout Class | Aptify.Applications.Organization Namespace


OrganizationLayout Methods

The methods of the OrganizationLayout class are listed below. For a complete list of OrganizationLayout class members, see the OrganizationLayout Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

OrganizationLayout Class | Aptify.Applications.Organization Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

OrganizationLayout.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

OrganizationLayout Class | Aptify.Applications.Organization Namespace


OrganizationLayout.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

OrganizationLayout Class | Aptify.Applications.Organization Namespace | OrganizationLayout.Dispose Overload List


OrganizationLayout.OnFormTemplateLoaded Method

protected override void OnFormTemplateLoaded(
FormTemplateLayout.FormTemplateLoadedEventArgs e
);

See Also

OrganizationLayout Class | Aptify.Applications.Organization Namespace


OrganizationObject Class

For a list of all members of this type, see OrganizationObject Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
OrganizationsClass
OrganizationObject

public class OrganizationObject : OrganizationsClass

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Organization

Assembly: OrganizationObject (in OrganizationObject.dll)

See Also

OrganizationObject Members | Aptify.Applications.Organization Namespace


OrganizationObject Members

OrganizationObject overview

Public Instance Constructors

OrganizationObject Constructor Initializes a new instance of the OrganizationObject class.

Public Instance Properties

AddressID (inherited from OrganizationsClass) |
AddressIDObject (inherited from OrganizationsClass) |
AddressLine1 (inherited from OrganizationsClass) |
AddressLine2 (inherited from OrganizationsClass) |
AddressLine3 (inherited from OrganizationsClass) |
AddressLine4 (inherited from OrganizationsClass) |
AllowFree (inherited from OrganizationsClass) |
AllowPriceOverride (inherited from OrganizationsClass) |
AllowPriceSelection (inherited from OrganizationsClass) |
AllowRelatedProductPromptClose (inherited from OrganizationsClass) |
Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BillingAddressID (inherited from OrganizationsClass) |
BillingAddressIDObject (inherited from OrganizationsClass) |
BillingAddressLine1 (inherited from OrganizationsClass) |
BillingAddressLine2 (inherited from OrganizationsClass) |
BillingAddressLine3 (inherited from OrganizationsClass) |
BillingAddressLine4 (inherited from OrganizationsClass) |
BillingCity (inherited from OrganizationsClass) |
BillingCountry (inherited from OrganizationsClass) |
BillingCounty (inherited from OrganizationsClass) |
BillingPostalCode (inherited from OrganizationsClass) |
BillingState (inherited from OrganizationsClass) |
BillingStateProvince (inherited from OrganizationsClass) |
BillingTerms (inherited from OrganizationsClass) |
BillingZipCode (inherited from OrganizationsClass) |
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
City (inherited from OrganizationsClass) |
Comments (inherited from OrganizationsClass) |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
ConversionAdjustmentGLAccount (inherited from OrganizationsClass) |
Country (inherited from OrganizationsClass) |
County (inherited from OrganizationsClass) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DateCreated (inherited from OrganizationsClass) |
DateUpdated (inherited from OrganizationsClass) |
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
Directions (inherited from OrganizationsClass) |
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
Established (inherited from OrganizationsClass) |
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExchangeRateGainGLAccount (inherited from OrganizationsClass) |
ExchangeRateLossGLAccount (inherited from OrganizationsClass) |
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
FedTaxID (inherited from OrganizationsClass) |
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
FiscalYearEnd (inherited from OrganizationsClass) |
FunctionalCurrencyType (inherited from OrganizationsClass) |
FunctionalCurrencyTypeID (inherited from OrganizationsClass) |
GenerateInterCompanyEntries (inherited from OrganizationsClass) |
ID (inherited from OrganizationsClass) |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
MainAreaCode (inherited from OrganizationsClass) |
MainCountryCode (inherited from OrganizationsClass) |
MainEmail (inherited from OrganizationsClass) |
MainFaxAreaCode (inherited from OrganizationsClass) |
MainFaxCountryCode (inherited from OrganizationsClass) |
MainFaxExtension (inherited from OrganizationsClass) |
MainFaxID (inherited from OrganizationsClass) |
MainFaxIDObject (inherited from OrganizationsClass) |
MainFaxNumber (inherited from OrganizationsClass) |
MainPhone (inherited from OrganizationsClass) |
MainPhoneExtension (inherited from OrganizationsClass) |
MainPhoneID (inherited from OrganizationsClass) |
MainPhoneIDObject (inherited from OrganizationsClass) |
Name (inherited from OrganizationsClass) |
NumberEmployees (inherited from OrganizationsClass) |
OwnType (inherited from OrganizationsClass) |
Parent (inherited from OrganizationsClass) |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentID (inherited from OrganizationsClass) |
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PostalCode (inherited from OrganizationsClass) |
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
PrimaryShareholder (inherited from OrganizationsClass) |
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Revenue (inherited from OrganizationsClass) |
RootOrganization (inherited from OrganizationsClass) |
RootOrganizationID (inherited from OrganizationsClass) |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
State (inherited from OrganizationsClass) |
StateProvince (inherited from OrganizationsClass) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.
WebSite (inherited from OrganizationsClass) |
WhoCreated (inherited from OrganizationsClass) |
WhoUpdated (inherited from OrganizationsClass) |
ZipCode (inherited from OrganizationsClass) |

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
OrganizationAddresses (inherited from OrganizationsClass) |
OrganizationAddressesObject (inherited from OrganizationsClass) |
OrganizationGLAccounts (inherited from OrganizationsClass) |
OrganizationGLAccountsObject (inherited from OrganizationsClass) |
OrganizationInterCompanyGL (inherited from OrganizationsClass) |
OrganizationInterCompanyGLObject (inherited from OrganizationsClass) |
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue | Updates values in the DataField of the entity.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

OrganizationObject Class | Aptify.Applications.Organization Namespace


OrganizationObject Constructor

Initializes a new instance of the OrganizationObject class.

public OrganizationObject();

See Also

OrganizationObject Class | Aptify.Applications.Organization Namespace


OrganizationObject Methods

The methods of the OrganizationObject class are listed below. For a complete list of OrganizationObject class members, see the OrganizationObject Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
OrganizationAddresses (inherited from OrganizationsClass) |
OrganizationAddressesObject (inherited from OrganizationsClass) |
OrganizationGLAccounts (inherited from OrganizationsClass) |
OrganizationGLAccountsObject (inherited from OrganizationsClass) |
OrganizationInterCompanyGL (inherited from OrganizationsClass) |
OrganizationInterCompanyGLObject (inherited from OrganizationsClass) |
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue | Updates values in the DataField of the entity.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

OrganizationObject Class | Aptify.Applications.Organization Namespace


OrganizationObject.SetValue Method

Updates values in the DataField of the entity.

public override void SetValue(
String FieldName,
Object Value
);

Parameters

FieldName
Value

Remarks

Adds specific logic to flow down the address when the parent organization is changed.

See Also

OrganizationObject Class | Aptify.Applications.Organization Namespace


Aptify.Applications.PersonCompanies.PersonCompaniesLayout

Aptify 5.0 Software Development Kit (SDK)

Aptify.Applications.PersonCompanies.PersonCompaniesLayout Namespace

This namespace defines the appearance of the PersonCompanies sub-type form, which can be accessed from a Persons record's Companies tab.

Namespace hierarchy

Classes

Class | Description
PersonCompaniesFormLayout |


PersonCompaniesFormLayout Class

For a list of all members of this type, see PersonCompaniesFormLayout Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
PersonCompaniesFormLayout

public class PersonCompaniesFormLayout : FormTemplateLayout

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.PersonCompanies.PersonCompaniesLayout

Assembly: PersonCompaniesLayout (in PersonCompaniesLayout.dll)

See Also

PersonCompaniesFormLayout Members | Aptify.Applications.PersonCompanies.PersonCompaniesLayout Namespace


PersonCompaniesFormLayout Members

PersonCompaniesFormLayout overview

Public Instance Constructors

PersonCompaniesFormLayout Constructor Initializes a new instance of the PersonCompaniesFormLayout class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CompanyIDChanged | Encapsulates logic that is triggered when the GUI changes the CompanyID.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

PersonCompaniesFormLayout Class | Aptify.Applications.PersonCompanies.PersonCompaniesLayout Namespace


PersonCompaniesFormLayout Constructor

Initializes a new instance of the PersonCompaniesFormLayout class.

public PersonCompaniesFormLayout();

See Also

PersonCompaniesFormLayout Class | Aptify.Applications.PersonCompanies.PersonCompaniesLayout Namespace


PersonCompaniesFormLayout Methods

The methods of the PersonCompaniesFormLayout class are listed below. For a complete list of PersonCompaniesFormLayout class members, see the PersonCompaniesFormLayout Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CompanyIDChanged | Encapsulates logic that is triggered when the GUI changes the CompanyID.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

PersonCompaniesFormLayout Class | Aptify.Applications.PersonCompanies.PersonCompaniesLayout Namespace


PersonCompaniesFormLayout.CompanyIDChanged Method

Encapsulates logic that is triggered when the GUI changes the CompanyID.

protected virtual void CompanyIDChanged(
Object OldValue,
Object NewValue
);

Parameters

OldValue
NewValue

Remarks

See Also

PersonCompaniesFormLayout Class | Aptify.Applications.PersonCompanies.PersonCompaniesLayout Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

PersonCompaniesFormLayout.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

PersonCompaniesFormLayout Class | Aptify.Applications.PersonCompanies.PersonCompaniesLayout Namespace


PersonCompaniesFormLayout.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

PersonCompaniesFormLayout Class | Aptify.Applications.PersonCompanies.PersonCompaniesLayout Namespace | PersonCompaniesFormLayout.Dispose Overload List


PersonCompaniesFormLayout.OnFormTemplateLoaded Method

protected override void OnFormTemplateLoaded(
FormTemplateLayout.FormTemplateLoadedEventArgs e
);

See Also

PersonCompaniesFormLayout Class | Aptify.Applications.PersonCompanies.PersonCompaniesLayout Namespace


Aptify.Applications.Persons

Aptify 5.0 Software Development Kit (SDK)

Aptify.Applications.Persons Namespace

This namespace defines the logic and form template used by the Persons entity.

Namespace hierarchy

Classes

Class | Description
AddCommitteesButton | Invokes a specified IAddPersonsToCommittees object.
CommitteeTermsMemberList | Allows a persons Committe Term Membership.
OutlookSynchronizationGlobal | Provides functionality to synchronize Microsoft Outlook Contact Records with Aptify Person Records. This is a global class that has a number of shared methods for interacting with the Microsoft Outlook application through the Primary Interop Assembly provided by Microsoft for the Office.Outlook namespace.
OutlookSyncWizard | Aptify Outlook Contact Syncrhonization Wizard
PersonCompaniesEntity | Provides custom business logic for the PersonCompanies entity.
PersonDuesTypeDropdownList | A combo box with the values Individual and Company.
PersonExtension | Used to extend the context menu in displayed in Person Views.
PersonsEntity | Provides business logic needed to Create, Read, Update, and Delete Persons records.
PersonsLayout | Provides presentation layer logic used for Persons records.
PersonSPMEntity |
PersonSPMLayout |
PersonsRankSliderBar | Allows a user to assign a rank to a person by moving a slider bar.
PersonsSpecialFieldTextBox | Used to display special fields for Persons.
SelectSingleCommitteeTermForm | Allows a user to select a single Committee Term that will have a Member added to it.
SyncContact | This class is responsible for synchronizing a specific Outlook Contact with a specific Aptify Person record.
SyncFolder | This class implements IProcessComponent and handles the process of synchronizing a specific Outlook Folder with the Aptify Persons entity.
SyncView | This class is responsible for synchronizing a specific view of Person records with a specified Outlook Folder.


AddCommitteesButton Class

Invokes a specified IAddPersonsToCommittees object.

For a list of all members of this type, see AddCommitteesButton Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
AddCommitteesButton

public class AddCommitteesButton : FormComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

The following Input Properties exist: Text,Object,Assembly,Class.

Requirements

Namespace: Aptify.Applications.Persons

Assembly: AptifyPersonsGUI (in AptifyPersonsGUI.dll)

See Also

AddCommitteesButton Members | Aptify.Applications.Persons Namespace


AddCommitteesButton Members

AddCommitteesButton overview

Public Instance Constructors

AddCommitteesButton Constructor Initializes a new instance of the AddCommitteesButton class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormComponent) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
CommitteeTermsAdded | Raised after the Button is clicked and Committe Terms are successfully added
CommitteeTermsAddFailed | Raised after the Button is clicked and Committe Terms are not successfully added.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

m_sAssembly
m_sClass
m_sObject

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateContext (inherited from FormComponent) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormComponent) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormComponent) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormComponent) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

AddCommitteesButton Class | Aptify.Applications.Persons Namespace


AddCommitteesButton Constructor

Initializes a new instance of the AddCommitteesButton class.

public AddCommitteesButton();

See Also

AddCommitteesButton Class | Aptify.Applications.Persons Namespace


AddCommitteesButton Fields

The fields of the AddCommitteesButton class are listed below. For a complete list of AddCommitteesButton class members, see the AddCommitteesButton Members topic.

Protected Instance Fields

m_sAssembly
m_sClass
m_sObject

See Also

AddCommitteesButton Class | Aptify.Applications.Persons Namespace


AddCommitteesButton.m_sAssembly Field

protected m_sAssembly m_sAssembly;

See Also

AddCommitteesButton Class | Aptify.Applications.Persons Namespace


AddCommitteesButton.m_sClass Field

protected m_sClass m_sClass;

See Also

AddCommitteesButton Class | Aptify.Applications.Persons Namespace


AddCommitteesButton.m_sObject Field

protected m_sObject m_sObject;

See Also

AddCommitteesButton Class | Aptify.Applications.Persons Namespace


AddCommitteesButton Methods

The methods of the AddCommitteesButton class are listed below. For a complete list of AddCommitteesButton class members, see the AddCommitteesButton Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormComponent) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormComponent) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormComponent) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormComponent) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

AddCommitteesButton Class | Aptify.Applications.Persons Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

AddCommitteesButton.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

AddCommitteesButton Class | Aptify.Applications.Persons Namespace


AddCommitteesButton.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

AddCommitteesButton Class | Aptify.Applications.Persons Namespace | AddCommitteesButton.Dispose Overload List


AddCommitteesButton.OnFormComponentConfig Method

protected override void OnFormComponentConfig(
AptifyFormTemplateContext FormTemplateContext
);

Implements

IFormComponent.

See Also

AddCommitteesButton Class | Aptify.Applications.Persons Namespace


AddCommitteesButton Events

The events of the AddCommitteesButton class are listed below. For a complete list of AddCommitteesButton class members, see the AddCommitteesButton Members topic.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
CommitteeTermsAdded | Raised after the Button is clicked and Committe Terms are successfully added
CommitteeTermsAddFailed | Raised after the Button is clicked and Committe Terms are not successfully added.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

AddCommitteesButton Class | Aptify.Applications.Persons Namespace


AddCommitteesButton.EventHandler Event

Raised after the Button is clicked and Committe Terms are successfully added

public event EventHandler CommitteeTermsAdded;

Remarks

See Also

AddCommitteesButton Class | Aptify.Applications.Persons Namespace


AddCommitteesButton.EventHandler Event

Raised after the Button is clicked and Committe Terms are not successfully added.

public event EventHandler CommitteeTermsAddFailed;

Remarks

See Also

AddCommitteesButton Class | Aptify.Applications.Persons Namespace


CommitteeTermsMemberList Class

Allows a persons Committe Term Membership.

For a list of all members of this type, see CommitteeTermsMemberList Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
CommitteeTermsMemberList

public class CommitteeTermsMemberList : FormComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Persons

Assembly: AptifyPersonsGUI (in AptifyPersonsGUI.dll)

See Also

CommitteeTermsMemberList Members | Aptify.Applications.Persons Namespace


CommitteeTermsMemberList Members

CommitteeTermsMemberList overview

Public Instance Constructors

CommitteeTermsMemberList Constructor Initializes a new instance of the CommitteeTermsMemberList class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateContext (inherited from FormComponent) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AddRecord |
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DeleteRecord | Logic that gets executed when a Term Meber needs to be Deleted.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig | Configures the form component.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormComponent) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormComponent) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormComponent) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
SaveRecord | Logic that gets executed when a Term Meber needs to be edited.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CommitteeTermsMemberList Class | Aptify.Applications.Persons Namespace


CommitteeTermsMemberList Constructor

Initializes a new instance of the CommitteeTermsMemberList class.

public CommitteeTermsMemberList();

See Also

CommitteeTermsMemberList Class | Aptify.Applications.Persons Namespace


CommitteeTermsMemberList Methods

The methods of the CommitteeTermsMemberList class are listed below. For a complete list of CommitteeTermsMemberList class members, see the CommitteeTermsMemberList Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AddRecord |
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DeleteRecord | Logic that gets executed when a Term Meber needs to be Deleted.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig | Configures the form component.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormComponent) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormComponent) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormComponent) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
SaveRecord | Logic that gets executed when a Term Meber needs to be edited.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CommitteeTermsMemberList Class | Aptify.Applications.Persons Namespace


CommitteeTermsMemberList.AddRecord Method

protected virtual void AddRecord();

See Also

CommitteeTermsMemberList Class | Aptify.Applications.Persons Namespace


CommitteeTermsMemberList.DeleteRecord Method

Logic that gets executed when a Term Meber needs to be Deleted.

protected virtual void DeleteRecord();

Remarks

See Also

CommitteeTermsMemberList Class | Aptify.Applications.Persons Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

CommitteeTermsMemberList.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

CommitteeTermsMemberList Class | Aptify.Applications.Persons Namespace


CommitteeTermsMemberList.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

CommitteeTermsMemberList Class | Aptify.Applications.Persons Namespace | CommitteeTermsMemberList.Dispose Overload List


CommitteeTermsMemberList.OnFormComponentConfig Method

Configures the form component.

protected override void OnFormComponentConfig(
AptifyFormTemplateContext FormTemplateContext
);

Parameters

FormTemplateContext

Implements

IFormComponent.

Remarks

Tells the list to start loading the members.

See Also

CommitteeTermsMemberList Class | Aptify.Applications.Persons Namespace


CommitteeTermsMemberList.Refresh Method

public override void Refresh();

See Also

CommitteeTermsMemberList Class | Aptify.Applications.Persons Namespace


CommitteeTermsMemberList.SaveRecord Method

Logic that gets executed when a Term Meber needs to be edited.

protected virtual void SaveRecord(
Int64 TermID,
Int64 TermMemberID
);

Remarks

See Also

CommitteeTermsMemberList Class | Aptify.Applications.Persons Namespace


OutlookSynchronizationGlobal Class

Provides functionality to synchronize Microsoft Outlook Contact Records with Aptify Person Records. This is a global class that has a number of shared methods for interacting with the Microsoft Outlook application through the Primary Interop Assembly provided by Microsoft for the Office.Outlook namespace.

For a list of all members of this type, see OutlookSynchronizationGlobal Members.

System.Object
OutlookSynchronizationGlobal
OutlookContactLogImport

public class OutlookSynchronizationGlobal

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Persons

Assembly: AptifyPersonsOutlookSynchronization (in AptifyPersonsOutlookSynchronization.dll)

See Also

OutlookSynchronizationGlobal Members | Aptify.Applications.Persons Namespace


OutlookSynchronizationGlobal Members

OutlookSynchronizationGlobal overview

Public Static Properties

OutlookApplication | Returns a reference to the Outlook Application Object
OutlookNameSpace | Returns a reference to the primary Outlook Namespace for the MAPI namespace

Public Static Methods

GetOutlookFolderByName Overloaded. Returns a reference to the Outlook Folder Object based on the provided parameters

Public Instance Constructors

OutlookSynchronizationGlobal Constructor Initializes a new instance of the OutlookSynchronizationGlobal class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

OutlookSynchronizationGlobal Class | Aptify.Applications.Persons Namespace


OutlookSynchronizationGlobal Constructor

Initializes a new instance of the OutlookSynchronizationGlobal class.

public OutlookSynchronizationGlobal();

See Also

OutlookSynchronizationGlobal Class | Aptify.Applications.Persons Namespace


OutlookSynchronizationGlobal Properties

The properties of the OutlookSynchronizationGlobal class are listed below. For a complete list of OutlookSynchronizationGlobal class members, see the OutlookSynchronizationGlobal Members topic.

Public Static Properties

OutlookApplication | Returns a reference to the Outlook Application Object
OutlookNameSpace | Returns a reference to the primary Outlook Namespace for the MAPI namespace

See Also

OutlookSynchronizationGlobal Class | Aptify.Applications.Persons Namespace


OutlookApplication Property

Aptify 5.0 Software Development Kit (SDK)

OutlookSynchronizationGlobal.OutlookApplication Property

Returns a reference to the Outlook Application Object

public static Application OutlookApplication {get;}

Property Value

Remarks

See Also

OutlookSynchronizationGlobal Class | Aptify.Applications.Persons Namespace


OutlookNameSpace Property

Aptify 5.0 Software Development Kit (SDK)

OutlookSynchronizationGlobal.OutlookNameSpace Property

Returns a reference to the primary Outlook Namespace for the MAPI namespace

public static NameSpace OutlookNameSpace {get;}

Property Value

Remarks

See Also

OutlookSynchronizationGlobal Class | Aptify.Applications.Persons Namespace


OutlookSynchronizationGlobal Methods

The methods of the OutlookSynchronizationGlobal class are listed below. For a complete list of OutlookSynchronizationGlobal class members, see the OutlookSynchronizationGlobal Members topic.

Public Static Methods

GetOutlookFolderByName Overloaded. Returns a reference to the Outlook Folder Object based on the provided parameters

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

OutlookSynchronizationGlobal Class | Aptify.Applications.Persons Namespace


GetOutlookFolderByName Method

Aptify 5.0 Software Development Kit (SDK)

OutlookSynchronizationGlobal.GetOutlookFolderByName Method

Returns a reference to the Outlook Folder Object based on the provided parameters

Overload List

Returns a reference to the Outlook Folder Object based on the provided parameters

public static MAPIFolder GetOutlookFolderByName(UserCredentials,String,MAPIFolder,Label);

public static MAPIFolder GetOutlookFolderByName(String,MAPIFolder,Label);

See Also

OutlookSynchronizationGlobal Class | Aptify.Applications.Persons Namespace


OutlookSynchronizationGlobal.GetOutlookFolderByName Method (UserCredentials, String, MAPIFolder, Label)

Returns a reference to the Outlook Folder Object based on the provided parameters

public static MAPIFolder GetOutlookFolderByName(
UserCredentials pUserCredential,
String FolderName,
MAPIFolder ParentFolder,
Label StatusLabel
);

Parameters

pUserCredential
FolderName
ParentFolder
StatusLabel

Return Value

Remarks

See Also

OutlookSynchronizationGlobal Class | Aptify.Applications.Persons Namespace | OutlookSynchronizationGlobal.GetOutlookFolderByName Overload List


OutlookSynchronizationGlobal.GetOutlookFolderByName Method (String, MAPIFolder, Label)

public static MAPIFolder GetOutlookFolderByName(
String foldername,
MAPIFolder parentfolder,
Label statuslabel
);

See Also

OutlookSynchronizationGlobal Class | Aptify.Applications.Persons Namespace | OutlookSynchronizationGlobal.GetOutlookFolderByName Overload List


OutlookSyncWizard Class

Aptify Outlook Contact Syncrhonization Wizard

For a list of all members of this type, see OutlookSyncWizard Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
OutlookSyncWizard

public class OutlookSyncWizard : Form, IAptifyAction

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Persons

Assembly: AptifyOutlookSyncWizard (in AptifyOutlookSyncWizard.dll)

See Also

OutlookSyncWizard Members | Aptify.Applications.Persons Namespace


OutlookSyncWizard Members

OutlookSyncWizard overview

Public Instance Constructors

OutlookSyncWizard Constructor Initializes a new instance of the OutlookSyncWizard class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoAction | Overloaded.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DoLocalization |
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

OutlookSyncWizard Class | Aptify.Applications.Persons Namespace


OutlookSyncWizard Constructor

Initializes a new instance of the OutlookSyncWizard class.

public OutlookSyncWizard();

See Also

OutlookSyncWizard Class | Aptify.Applications.Persons Namespace


OutlookSyncWizard Methods

The methods of the OutlookSyncWizard class are listed below. For a complete list of OutlookSyncWizard class members, see the OutlookSyncWizard Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoAction | Overloaded.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DoLocalization |
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

OutlookSyncWizard Class | Aptify.Applications.Persons Namespace


OutlookSyncWizard.Config Method

public bool Config(
AptifyApplication Application,
Int64 EntityID,
Int64 ViewID,
params Object[] SelectedItems
);

See Also

OutlookSyncWizard Class | Aptify.Applications.Persons Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

OutlookSyncWizard.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

OutlookSyncWizard Class | Aptify.Applications.Persons Namespace


OutlookSyncWizard.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

OutlookSyncWizard Class | Aptify.Applications.Persons Namespace | OutlookSyncWizard.Dispose Overload List


DoAction Method

Aptify 5.0 Software Development Kit (SDK)

OutlookSyncWizard.DoAction Method

Overload List

public void DoAction(AptifyApplication,Int64);

public void DoAction(AptifyApplication,Int64,Int64);

public void DoAction(AptifyApplication,Int64,Int64,params Object[]);

public void DoAction(AptifyApplication,Int64,params String[]);

See Also

OutlookSyncWizard Class | Aptify.Applications.Persons Namespace


OutlookSyncWizard.DoAction Method (AptifyApplication, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID
);

Implements

IAptifyAction.

See Also

OutlookSyncWizard Class | Aptify.Applications.Persons Namespace | OutlookSyncWizard.DoAction Overload List


OutlookSyncWizard.DoAction Method (AptifyApplication, Int64, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID
);

Implements

IAptifyAction.

See Also

OutlookSyncWizard Class | Aptify.Applications.Persons Namespace | OutlookSyncWizard.DoAction Overload List


OutlookSyncWizard.DoAction Method (AptifyApplication, Int64, Int64, Object[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID,
params Object[] SelectedItems
);

Implements

IAptifyAction.

See Also

OutlookSyncWizard Class | Aptify.Applications.Persons Namespace | OutlookSyncWizard.DoAction Overload List


OutlookSyncWizard.DoAction Method (AptifyApplication, Int64, String[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
params String[] SelectedItems
);

Implements

IAptifyAction.

See Also

OutlookSyncWizard Class | Aptify.Applications.Persons Namespace | OutlookSyncWizard.DoAction Overload List


OutlookSyncWizard.DoLocalization Method

public void DoLocalization();

See Also

OutlookSyncWizard Class | Aptify.Applications.Persons Namespace


PersonCompaniesEntity Class

Provides custom business logic for the PersonCompanies entity.

For a list of all members of this type, see PersonCompaniesEntity Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
PersonCompanyFunctionsClass
PersonCompaniesEntity

public class PersonCompaniesEntity : PersonCompanyFunctionsClass

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Persons

Assembly: AptifyPersonCompaniesEntity (in AptifyPersonCompaniesEntity.dll)

See Also

PersonCompaniesEntity Members | Aptify.Applications.Persons Namespace


PersonCompaniesEntity Members

PersonCompaniesEntity overview

Public Instance Constructors

PersonCompaniesEntity Constructor Initializes a new instance of the PersonCompaniesEntity class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
Comments (inherited from PersonCompanyFunctionsClass) |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EndDate (inherited from PersonCompanyFunctionsClass) |
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
FunctionID (inherited from PersonCompanyFunctionsClass) |
FunctionID_Name (inherited from PersonCompanyFunctionsClass) |
ID (inherited from PersonCompanyFunctionsClass) |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PerCoSequence (inherited from PersonCompanyFunctionsClass) |
PersonCompanyID (inherited from PersonCompanyFunctionsClass) |
PersonID (inherited from PersonCompanyFunctionsClass) |
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Sequence (inherited from PersonCompanyFunctionsClass) |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
StartDate (inherited from PersonCompanyFunctionsClass) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue | Provides Custom Business Logic for the SetValue Member.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateContactInfoFromCompany |
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

PersonCompaniesEntity Class | Aptify.Applications.Persons Namespace


PersonCompaniesEntity Constructor

Initializes a new instance of the PersonCompaniesEntity class.

public PersonCompaniesEntity();

See Also

PersonCompaniesEntity Class | Aptify.Applications.Persons Namespace


PersonCompaniesEntity Methods

The methods of the PersonCompaniesEntity class are listed below. For a complete list of PersonCompaniesEntity class members, see the PersonCompaniesEntity Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue | Provides Custom Business Logic for the SetValue Member.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateContactInfoFromCompany |
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

PersonCompaniesEntity Class | Aptify.Applications.Persons Namespace


PersonCompaniesEntity.SetValue Method

Provides Custom Business Logic for the SetValue Member.

public override void SetValue(
String FieldName,
Object Value
);

Parameters

FieldName
Value

Remarks

See Also

PersonCompaniesEntity Class | Aptify.Applications.Persons Namespace


PersonCompaniesEntity.UpdateContactInfoFromCompany Method

public void UpdateContactInfoFromCompany(
Int64 CompanyID
);

See Also

PersonCompaniesEntity Class | Aptify.Applications.Persons Namespace


PersonDuesTypeDropdownList Class

A combo box with the values Individual and Company.

For a list of all members of this type, see PersonDuesTypeDropdownList Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
PersonDuesTypeDropdownList

public class PersonDuesTypeDropdownList : FormComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Individual or Company can be made culture aware by adding Base strings and local strings in the Culture Strings service.

Requirements

Namespace: Aptify.Applications.Persons

Assembly: AptifyPersonsGUI (in AptifyPersonsGUI.dll)

See Also

PersonDuesTypeDropdownList Members | Aptify.Applications.Persons Namespace


PersonDuesTypeDropdownList Members

PersonDuesTypeDropdownList overview

Public Instance Constructors

PersonDuesTypeDropdownList Constructor Initializes a new instance of the PersonDuesTypeDropdownList class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
SelectedItem | Lets a developer access the SelectedItem in the drop down list.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormComponent) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SelectedIndexChanged | Signals that the drop down list box's SelectedIndex has changed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateContext (inherited from FormComponent) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig | Populates the combo box with Culture Aware Items.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormComponent) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormComponent) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormComponent) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

PersonDuesTypeDropdownList Class | Aptify.Applications.Persons Namespace


PersonDuesTypeDropdownList Constructor

Initializes a new instance of the PersonDuesTypeDropdownList class.

public PersonDuesTypeDropdownList();

See Also

PersonDuesTypeDropdownList Class | Aptify.Applications.Persons Namespace


PersonDuesTypeDropdownList Properties

The properties of the PersonDuesTypeDropdownList class are listed below. For a complete list of PersonDuesTypeDropdownList class members, see the PersonDuesTypeDropdownList Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
SelectedItem | Lets a developer access the SelectedItem in the drop down list.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateContext (inherited from FormComponent) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

PersonDuesTypeDropdownList Class | Aptify.Applications.Persons Namespace


SelectedItem Property

Aptify 5.0 Software Development Kit (SDK)

PersonDuesTypeDropdownList.SelectedItem Property

Lets a developer access the SelectedItem in the drop down list.

public ListItem SelectedItem {get; set;}

Property Value

Remarks

The ListItem.Data portion will equal "Individual" or "Company". The ListItem.Text will be the Local String version of the ListItem.Text.

See Also

PersonDuesTypeDropdownList Class | Aptify.Applications.Persons Namespace


PersonDuesTypeDropdownList Methods

The methods of the PersonDuesTypeDropdownList class are listed below. For a complete list of PersonDuesTypeDropdownList class members, see the PersonDuesTypeDropdownList Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormComponent) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig | Populates the combo box with Culture Aware Items.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormComponent) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormComponent) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormComponent) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

PersonDuesTypeDropdownList Class | Aptify.Applications.Persons Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

PersonDuesTypeDropdownList.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

PersonDuesTypeDropdownList Class | Aptify.Applications.Persons Namespace


PersonDuesTypeDropdownList.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

PersonDuesTypeDropdownList Class | Aptify.Applications.Persons Namespace | PersonDuesTypeDropdownList.Dispose Overload List


PersonDuesTypeDropdownList.OnFormComponentConfig Method

Populates the combo box with Culture Aware Items.

protected override void OnFormComponentConfig(
AptifyFormTemplateContext FormTemplateContext
);

Parameters

FormTemplateContext

Implements

IFormComponent.

Remarks

See Also

PersonDuesTypeDropdownList Class | Aptify.Applications.Persons Namespace


PersonDuesTypeDropdownList Events

The events of the PersonDuesTypeDropdownList class are listed below. For a complete list of PersonDuesTypeDropdownList class members, see the PersonDuesTypeDropdownList Members topic.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SelectedIndexChanged | Signals that the drop down list box's SelectedIndex has changed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

PersonDuesTypeDropdownList Class | Aptify.Applications.Persons Namespace


PersonDuesTypeDropdownList.EventHandler Event

Signals that the drop down list box's SelectedIndex has changed.

public event EventHandler SelectedIndexChanged;

Remarks

See Also

PersonDuesTypeDropdownList Class | Aptify.Applications.Persons Namespace


PersonExtension Class

Used to extend the context menu in displayed in Person Views.

For a list of all members of this type, see PersonExtension Members.

System.Object
PersonExtension

public class PersonExtension : IAptifyViewExtension

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Persons

Assembly: AptifyPersonsEntity (in AptifyPersonsEntity.dll)

See Also

PersonExtension Members | Aptify.Applications.Persons Namespace


PersonExtension Members

PersonExtension overview

Public Instance Constructors

PersonExtension Constructor Initializes a new instance of the PersonExtension class.

Public Instance Properties

Application
ExtensionMenuItem
ViewPlugIn

Public Instance Methods

Attach |
Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

AfterAttach
AfterConfig
AfterExecute
BeforeAttach
BeforeConfig
BeforeExecute

Protected Instance Methods

CreateContactLog | This method is responsible for creating a new contact log record with the provided parameters as attributes of the new contact log record.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetContactLogType |
GetEmployeeIDFromUserID |
GetLowestEntityRecordID | This method will return the lowest record ID in the specified entity.
GetPersonCompanyID |
GetPersonFullName | Returns the NameWCompany field from the Persons entity for the specified Person ID record.
LeftVoiceMail | Can be overriden to provide custom logic for leaving a voice mail.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RecordPhoneCall | Can be overriden to provide custom logic for recording a phone call.

See Also

PersonExtension Class | Aptify.Applications.Persons Namespace


PersonExtension Constructor

Initializes a new instance of the PersonExtension class.

public PersonExtension();

See Also

PersonExtension Class | Aptify.Applications.Persons Namespace


PersonExtension Properties

The properties of the PersonExtension class are listed below. For a complete list of PersonExtension class members, see the PersonExtension Members topic.

Public Instance Properties

Application
ExtensionMenuItem
ViewPlugIn

See Also

PersonExtension Class | Aptify.Applications.Persons Namespace


Application Property

Aptify 5.0 Software Development Kit (SDK)

PersonExtension.Application Property

public AptifyApplication Application {get;}

Implements

IAptifyViewExtension.

See Also

PersonExtension Class | Aptify.Applications.Persons Namespace


ExtensionMenuItem Property

Aptify 5.0 Software Development Kit (SDK)

PersonExtension.ExtensionMenuItem Property

public MenuItem ExtensionMenuItem {get;}

Implements

IAptifyViewExtension.

See Also

PersonExtension Class | Aptify.Applications.Persons Namespace


ViewPlugIn Property

Aptify 5.0 Software Development Kit (SDK)

PersonExtension.ViewPlugIn Property

public IAptifyViewPlugIn ViewPlugIn {get;}

Implements

IAptifyViewExtension.

See Also

PersonExtension Class | Aptify.Applications.Persons Namespace


PersonExtension Methods

The methods of the PersonExtension class are listed below. For a complete list of PersonExtension class members, see the PersonExtension Members topic.

Public Instance Methods

Attach |
Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CreateContactLog | This method is responsible for creating a new contact log record with the provided parameters as attributes of the new contact log record.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetContactLogType |
GetEmployeeIDFromUserID |
GetLowestEntityRecordID | This method will return the lowest record ID in the specified entity.
GetPersonCompanyID |
GetPersonFullName | Returns the NameWCompany field from the Persons entity for the specified Person ID record.
LeftVoiceMail | Can be overriden to provide custom logic for leaving a voice mail.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RecordPhoneCall | Can be overriden to provide custom logic for recording a phone call.

See Also

PersonExtension Class | Aptify.Applications.Persons Namespace


PersonExtension.Attach Method

public void Attach(
MenuItem ExtensionMenuItem
);

Implements

IAptifyViewExtension.

See Also

PersonExtension Class | Aptify.Applications.Persons Namespace


PersonExtension.Config Method

public void Config(
AptifyApplication Application,
IAptifyViewPlugIn ViewPlugIn
);

Implements

IAptifyViewExtension.

See Also

PersonExtension Class | Aptify.Applications.Persons Namespace


PersonExtension.CreateContactLog Method

This method is responsible for creating a new contact log record with the provided parameters as attributes of the new contact log record.

protected virtual long CreateContactLog(
String Description,
Int64 TypeID,
Int64 CategoryID,
Boolean Complete
);

Parameters

Description
TypeID
If set to -1, the default value at the entity level is used, if no entity default exists, the lowest value in the Contact Log Types entity is used.
CategoryID
If set to -1, the default value at the entity level is used, if no entity default exists, the lowest value in the Contact Log Categories entity is used.
Complete

Return Value

Remarks

See Also

PersonExtension Class | Aptify.Applications.Persons Namespace


PersonExtension.Execute Method

public void Execute(
MenuItem FunctionMenuItem
);

Implements

IAptifyViewExtension.

See Also

PersonExtension Class | Aptify.Applications.Persons Namespace


PersonExtension.GetContactLogType Method

protected virtual long GetContactLogType(
String Type
);

See Also

PersonExtension Class | Aptify.Applications.Persons Namespace


PersonExtension.GetEmployeeIDFromUserID Method

protected virtual long GetEmployeeIDFromUserID(
Int64 UserID
);

See Also

PersonExtension Class | Aptify.Applications.Persons Namespace


PersonExtension.GetLowestEntityRecordID Method

This method will return the lowest record ID in the specified entity.

protected virtual long GetLowestEntityRecordID(
String Entity
);

Parameters

Entity

Return Value

Remarks

See Also

PersonExtension Class | Aptify.Applications.Persons Namespace


PersonExtension.GetPersonCompanyID Method

protected virtual long GetPersonCompanyID(
Int64 PersonID
);

See Also

PersonExtension Class | Aptify.Applications.Persons Namespace


PersonExtension.GetPersonFullName Method

Returns the NameWCompany field from the Persons entity for the specified Person ID record.

protected virtual string GetPersonFullName(
Int64 PersonID
);

Parameters

PersonID

Return Value

Remarks

See Also

PersonExtension Class | Aptify.Applications.Persons Namespace


PersonExtension.LeftVoiceMail Method

Can be overriden to provide custom logic for leaving a voice mail.

protected virtual void LeftVoiceMail();

Remarks

See Also

PersonExtension Class | Aptify.Applications.Persons Namespace


PersonExtension.RecordPhoneCall Method

Can be overriden to provide custom logic for recording a phone call.

protected virtual void RecordPhoneCall();

Remarks

See Also

PersonExtension Class | Aptify.Applications.Persons Namespace


PersonExtension Events

The events of the PersonExtension class are listed below. For a complete list of PersonExtension class members, see the PersonExtension Members topic.

Public Instance Events

AfterAttach
AfterConfig
AfterExecute
BeforeAttach
BeforeConfig
BeforeExecute

See Also

PersonExtension Class | Aptify.Applications.Persons Namespace


PersonExtension.IAptifyViewExtension.AfterAttachEventHandler Event

public event IAptifyViewExtension.AfterAttachEventHandler AfterAttach;

Implements

IAptifyViewExtension.

See Also

PersonExtension Class | Aptify.Applications.Persons Namespace


PersonExtension.IAptifyViewExtension.AfterConfigEventHandler Event

public event IAptifyViewExtension.AfterConfigEventHandler AfterConfig;

Implements

IAptifyViewExtension.

See Also

PersonExtension Class | Aptify.Applications.Persons Namespace


PersonExtension.IAptifyViewExtension.AfterExecuteEventHandler Event

public event IAptifyViewExtension.AfterExecuteEventHandler AfterExecute;

Implements

IAptifyViewExtension.

See Also

PersonExtension Class | Aptify.Applications.Persons Namespace


PersonExtension.IAptifyViewExtension.BeforeAttachEventHandler Event

public event IAptifyViewExtension.BeforeAttachEventHandler BeforeAttach;

Implements

IAptifyViewExtension.

See Also

PersonExtension Class | Aptify.Applications.Persons Namespace


PersonExtension.IAptifyViewExtension.BeforeConfigEventHandler Event

public event IAptifyViewExtension.BeforeConfigEventHandler BeforeConfig;

Implements

IAptifyViewExtension.

See Also

PersonExtension Class | Aptify.Applications.Persons Namespace


PersonExtension.IAptifyViewExtension.BeforeExecuteEventHandler Event

public event IAptifyViewExtension.BeforeExecuteEventHandler BeforeExecute;

Implements

IAptifyViewExtension.

See Also

PersonExtension Class | Aptify.Applications.Persons Namespace


PersonsEntity Class

Provides business logic needed to Create, Read, Update, and Delete Persons records.

For a list of all members of this type, see PersonsEntity Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
PersonsClass
PersonsEntity

public class PersonsEntity : PersonsClass

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Persons

Assembly: AptifyPersonsEntity (in AptifyPersonsEntity.dll)

See Also

PersonsEntity Members | Aptify.Applications.Persons Namespace


PersonsEntity Members

PersonsEntity overview

Public Instance Constructors

PersonsEntity Constructor Initializes a new instance of the PersonsEntity class.

Public Instance Properties

AddressID (inherited from PersonsClass) |
AddressIDObject (inherited from PersonsClass) |
AddressLine1 (inherited from PersonsClass) |
AddressLine2 (inherited from PersonsClass) |
AddressLine3 (inherited from PersonsClass) |
AddressLine4 (inherited from PersonsClass) |
Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
APVendorID (inherited from PersonsClass) |
AssistantsAreaCode (inherited from PersonsClass) |
AssistantsCountryCode (inherited from PersonsClass) |
AssistantsExtension (inherited from PersonsClass) |
AssistantsName (inherited from PersonsClass) |
AssistantsPhone (inherited from PersonsClass) |
AssistantsPhoneID (inherited from PersonsClass) |
Atmosphere (inherited from PersonsClass) |
BillingAddressID (inherited from PersonsClass) |
BillingAddressLine1 (inherited from PersonsClass) |
BillingAddressLine2 (inherited from PersonsClass) |
BillingAddressLine3 (inherited from PersonsClass) |
BillingAddressLine4 (inherited from PersonsClass) |
BillingCity (inherited from PersonsClass) |
BillingCountry (inherited from PersonsClass) |
BillingCounty (inherited from PersonsClass) |
BillingState (inherited from PersonsClass) |
BillingTerms (inherited from PersonsClass) |
BillingZipCode (inherited from PersonsClass) |
Birthday (inherited from PersonsClass) |
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
CellAreaCode (inherited from PersonsClass) |
CellCountryCode (inherited from PersonsClass) |
CellPhone (inherited from PersonsClass) |
CellPhoneID (inherited from PersonsClass) |
City (inherited from PersonsClass) |
CoMemberType (inherited from PersonsClass) |
Comments (inherited from PersonsClass) |
Company (inherited from PersonsClass) |
CompanyDuesPaidThru (inherited from PersonsClass) |
CompanyID (inherited from PersonsClass) |
CompanyJoinDate (inherited from PersonsClass) |
CompanyLastDuesAmount (inherited from PersonsClass) |
CompanyLastDuesAmountCurrencyTypeID (inherited from PersonsClass) |
CompanyLastDuesPaymentDate (inherited from PersonsClass) |
CompanyMemberType (inherited from PersonsClass) |
CompanyMemberTypeID (inherited from PersonsClass) |
CompanyName (inherited from PersonsClass) |
CompanyTerminationDate (inherited from PersonsClass) |
ContactManagerID (inherited from PersonsClass) |
ContactRank (inherited from PersonsClass) |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
Country (inherited from PersonsClass) |
CountryCodeID (inherited from PersonsClass) |
County (inherited from PersonsClass) |
CountyDistrict (inherited from PersonsClass) |
CreditLimit (inherited from PersonsClass) |
CreditLimitCurrencyTypeID (inherited from PersonsClass) |
CreditStatusID (inherited from PersonsClass) |
CRRT (inherited from PersonsClass) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DateCreated (inherited from PersonsClass) |
DateUpdated (inherited from PersonsClass) |
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
Department (inherited from PersonsClass) |
Directions (inherited from PersonsClass) |
DirExclude (inherited from PersonsClass) |
DirRank (inherited from PersonsClass) |
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
DuesPaidThru (inherited from PersonsClass) |
Email (inherited from PersonsClass) |
Email1 (inherited from PersonsClass) |
Email2 (inherited from PersonsClass) |
Email3 (inherited from PersonsClass) |
EmailExclude (inherited from PersonsClass) |
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
FaxAreaCode (inherited from PersonsClass) |
FaxCountryCode (inherited from PersonsClass) |
FaxExclude (inherited from PersonsClass) |
FaxID (inherited from PersonsClass) |
FaxPhone (inherited from PersonsClass) |
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
FirstLast (inherited from PersonsClass) |
FirstName (inherited from PersonsClass) |
FunctionalTitle (inherited from PersonsClass) |
Gender (inherited from PersonsClass) |
GLOrderLevelID (inherited from PersonsClass) |
GLPaymentLevelID (inherited from PersonsClass) |
HomeAddressID (inherited from PersonsClass) |
HomeAddressLine1 (inherited from PersonsClass) |
HomeAddressLine2 (inherited from PersonsClass) |
HomeAddressLine3 (inherited from PersonsClass) |
HomeAddressLine4 (inherited from PersonsClass) |
HomeAreaCode (inherited from PersonsClass) |
HomeCity (inherited from PersonsClass) |
HomeCountry (inherited from PersonsClass) |
HomeCountryCode (inherited from PersonsClass) |
HomeCounty (inherited from PersonsClass) |
HomePhone (inherited from PersonsClass) |
HomePhoneID (inherited from PersonsClass) |
HomeState (inherited from PersonsClass) |
HomeZipCode (inherited from PersonsClass) |
ID (inherited from PersonsClass) |
ImportantDate1 (inherited from PersonsClass) |
ImportantDate2 (inherited from PersonsClass) |
ImportantDate3 (inherited from PersonsClass) |
ImportantDescription1 (inherited from PersonsClass) |
ImportantDescription2 (inherited from PersonsClass) |
ImportantDescription3 (inherited from PersonsClass) |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
JoinDate (inherited from PersonsClass) |
Kids (inherited from PersonsClass) |
LastDuesAmount (inherited from PersonsClass) |
LastDuesAmountCurrencyTypeID (inherited from PersonsClass) |
LastDuesPaymentDate (inherited from PersonsClass) |
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastName (inherited from PersonsClass) |
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
MailCode (inherited from PersonsClass) |
MailExclude (inherited from PersonsClass) |
MainAccountManager (inherited from PersonsClass) |
MainAccountManagerName (inherited from PersonsClass) |
MemberType (inherited from PersonsClass) |
MemberTypeID (inherited from PersonsClass) |
MiddleName (inherited from PersonsClass) |
NameWCompany (inherited from PersonsClass) |
NextContactDate (inherited from PersonsClass) |
Nickname (inherited from PersonsClass) |
OldCompanyID (inherited from PersonsClass) |
OldID (inherited from PersonsClass) |
OrganizationID (inherited from PersonsClass) |
PagerAreaCode (inherited from PersonsClass) |
PagerCountryCode (inherited from PersonsClass) |
PagerPhone (inherited from PersonsClass) |
PagerPhoneID (inherited from PersonsClass) |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
Phone (inherited from PersonsClass) |
PhoneAreaCode (inherited from PersonsClass) |
PhoneCountryCode (inherited from PersonsClass) |
PhoneExtension (inherited from PersonsClass) |
PhoneID (inherited from PersonsClass) |
PhoneIDObject (inherited from PersonsClass) |
POBox (inherited from PersonsClass) |
POBoxAddressID (inherited from PersonsClass) |
POBoxCity (inherited from PersonsClass) |
POBoxCountry (inherited from PersonsClass) |
POBoxCounty (inherited from PersonsClass) |
POBoxLine2 (inherited from PersonsClass) |
POBoxLine3 (inherited from PersonsClass) |
POBoxLine4 (inherited from PersonsClass) |
POBoxState (inherited from PersonsClass) |
POBoxZipCode (inherited from PersonsClass) |
PrefCommMethodID (inherited from PersonsClass) |
PreferredAddress (inherited from PersonsClass) |
PreferredBillingAddress (inherited from PersonsClass) |
PreferredCurrencyTypeID (inherited from PersonsClass) |
PreferredShippingAddress (inherited from PersonsClass) |
Prefix (inherited from PersonsClass) |
PrimaryFunction (inherited from PersonsClass) |
PrimaryFunctionID (inherited from PersonsClass) |
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
Ranking (inherited from PersonsClass) |
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
ReferralType (inherited from PersonsClass) |
ReferredBy (inherited from PersonsClass) |
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SocialSecurity (inherited from PersonsClass) |
SpouseName (inherited from PersonsClass) |
State (inherited from PersonsClass) |
StateHouse (inherited from PersonsClass) |
StateSenate (inherited from PersonsClass) |
Status (inherited from PersonsClass) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
Suffix (inherited from PersonsClass) |
Supervisor (inherited from PersonsClass) |
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
TerminationDate (inherited from PersonsClass) |
Title (inherited from PersonsClass) |
USCongress (inherited from PersonsClass) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.
VerifyStatus (inherited from PersonsClass) |
WebSite (inherited from PersonsClass) |
WhoCreated (inherited from PersonsClass) |
WhoUpdated (inherited from PersonsClass) |
ZipCode (inherited from PersonsClass) |
ZipCode5Numeric (inherited from PersonsClass) |

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDefaultAcctMgr | Returns the EmployeeID associated with this user if it exists
GetDependencies | Overloaded.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetPersonDefMemTypeID | Returns the Default Member Type for this person.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. Wraps base functionality, GetValue, with additional logic.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load | Overloaded.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
PersonAccountManagers (inherited from PersonsClass) |
PersonAccountManagersObject (inherited from PersonsClass) |
PersonAddress (inherited from PersonsClass) |
PersonAddressObject (inherited from PersonsClass) |
PersonCompanies (inherited from PersonsClass) |
PersonCompaniesObject (inherited from PersonsClass) |
PersonEducation (inherited from PersonsClass) |
PersonEducationObject (inherited from PersonsClass) |
PersonFunctions (inherited from PersonsClass) |
PersonFunctionsObject (inherited from PersonsClass) |
PersonPhone (inherited from PersonsClass) |
PersonPhoneObject (inherited from PersonsClass) |
PersonRelationships (inherited from PersonsClass) |
PersonRelationshipsObject (inherited from PersonsClass) |
PersonSavedPaymentMethods (inherited from PersonsClass) |
PersonSavedPaymentMethodsObject (inherited from PersonsClass) |
PersonTaxExemptCodes (inherited from PersonsClass) |
PersonTaxExemptCodesObject (inherited from PersonsClass) |
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue |
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateContactInfoFromCompany |
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded. Performs data validation for Person Entity records.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

PersonsEntity Class | Aptify.Applications.Persons Namespace


PersonsEntity Constructor

Initializes a new instance of the PersonsEntity class.

public PersonsEntity();

See Also

PersonsEntity Class | Aptify.Applications.Persons Namespace


PersonsEntity Methods

The methods of the PersonsEntity class are listed below. For a complete list of PersonsEntity class members, see the PersonsEntity Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDefaultAcctMgr | Returns the EmployeeID associated with this user if it exists
GetDependencies | Overloaded.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetPersonDefMemTypeID | Returns the Default Member Type for this person.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. Wraps base functionality, GetValue, with additional logic.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load | Overloaded.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
PersonAccountManagers (inherited from PersonsClass) |
PersonAccountManagersObject (inherited from PersonsClass) |
PersonAddress (inherited from PersonsClass) |
PersonAddressObject (inherited from PersonsClass) |
PersonCompanies (inherited from PersonsClass) |
PersonCompaniesObject (inherited from PersonsClass) |
PersonEducation (inherited from PersonsClass) |
PersonEducationObject (inherited from PersonsClass) |
PersonFunctions (inherited from PersonsClass) |
PersonFunctionsObject (inherited from PersonsClass) |
PersonPhone (inherited from PersonsClass) |
PersonPhoneObject (inherited from PersonsClass) |
PersonRelationships (inherited from PersonsClass) |
PersonRelationshipsObject (inherited from PersonsClass) |
PersonSavedPaymentMethods (inherited from PersonsClass) |
PersonSavedPaymentMethodsObject (inherited from PersonsClass) |
PersonTaxExemptCodes (inherited from PersonsClass) |
PersonTaxExemptCodesObject (inherited from PersonsClass) |
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue |
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateContactInfoFromCompany |
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded. Performs data validation for Person Entity records.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

PersonsEntity Class | Aptify.Applications.Persons Namespace


PersonsEntity.GetDefaultAcctMgr Method

Returns the EmployeeID associated with this user if it exists

public long GetDefaultAcctMgr();

Return Value

Remarks

See Also

PersonsEntity Class | Aptify.Applications.Persons Namespace


GetDependencies Method

Aptify 5.0 Software Development Kit (SDK)

PersonsEntity.GetDependencies Method

Overload List

Inherited from AptifyGenericEntity.

public override EntityDependenciesBase GetDependencies();

public override bool GetDependencies(ref AptifyGenericEntityBase[]&);

See Also

PersonsEntity Class | Aptify.Applications.Persons Namespace


PersonsEntity.GetDependencies Method (AptifyGenericEntityBase[]&)

public override bool GetDependencies(
ref AptifyGenericEntityBase[]& GEs
);

See Also

PersonsEntity Class | Aptify.Applications.Persons Namespace | PersonsEntity.GetDependencies Overload List


PersonsEntity.GetPersonDefMemTypeID Method

Returns the Default Member Type for this person.

public long GetPersonDefMemTypeID();

Return Value

Remarks

Returns -1 if non default member type exists.

See Also

PersonsEntity Class | Aptify.Applications.Persons Namespace


GetValue Method

Aptify 5.0 Software Development Kit (SDK)

PersonsEntity.GetValue Method

Wraps base functionality, GetValue, with additional logic.

Overload List

Wraps base functionality, GetValue, with additional logic.

public override object GetValue(String);

Inherited from AptifyGenericEntityBase.

public virtual object GetValue(String,Boolean);

See Also

PersonsEntity Class | Aptify.Applications.Persons Namespace


PersonsEntity.GetValue Method (String)

Wraps base functionality, GetValue, with additional logic.

public override object GetValue(
String FieldName
);

Parameters

FieldName

Return Value

Remarks

RootCompanyMemberType and CoMemberType are fields that are only simulated by the GE.

See Also

PersonsEntity Class | Aptify.Applications.Persons Namespace | PersonsEntity.GetValue Overload List


Load Method

Aptify 5.0 Software Development Kit (SDK)

PersonsEntity.Load Method

Overload List

Inherited from AptifyGenericEntity.

public override void Load(DataRow);

Inherited from AptifyGenericEntity.

public override void Load(IDataReader);

Inherited from AptifyGenericEntity.

public override void Load(Int64);

Inherited from AptifyGenericEntityBase.

public virtual void Load(String);

public override void Load(String,Boolean);

See Also

PersonsEntity Class | Aptify.Applications.Persons Namespace


PersonsEntity.Load Method (String, Boolean)

public override void Load(
String FileName,
Boolean MergeSubTypes
);

See Also

PersonsEntity Class | Aptify.Applications.Persons Namespace | PersonsEntity.Load Overload List


Save Method

Aptify 5.0 Software Development Kit (SDK)

PersonsEntity.Save Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Save();

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean,ref String&);

public override bool Save(Boolean,ref String&,String);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(ref String&);

See Also

PersonsEntity Class | Aptify.Applications.Persons Namespace


PersonsEntity.Save Method (Boolean, String&, String)

public override bool Save(
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

See Also

PersonsEntity Class | Aptify.Applications.Persons Namespace | PersonsEntity.Save Overload List


PersonsEntity.SetValue Method

public override void SetValue(
String FieldName,
Object Value
);

Remarks

Adds specific logic to flow down the work address when the organization is changed.

See Also

PersonsEntity Class | Aptify.Applications.Persons Namespace


PersonsEntity.UpdateContactInfoFromCompany Method

public virtual void UpdateContactInfoFromCompany(
Int64 CompanyID
);

See Also

PersonsEntity Class | Aptify.Applications.Persons Namespace


Validate Method

Aptify 5.0 Software Development Kit (SDK)

PersonsEntity.Validate Method

Performs data validation for Person Entity records.

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Validate();

Performs data validation for Person Entity records.

public override bool Validate(ref String&);

See Also

PersonsEntity Class | Aptify.Applications.Persons Namespace


PersonsEntity.Validate Method (String&)

Performs data validation for Person Entity records.

public override bool Validate(
ref String& ErrorString
);

Parameters

ErrorString

Return Value

Remarks

  • The primary Function has been added as a PersonFunction record. If it has not been, it is automatically added.

See Also

PersonsEntity Class | Aptify.Applications.Persons Namespace | PersonsEntity.Validate Overload List


PersonsLayout Class

Provides presentation layer logic used for Persons records.

For a list of all members of this type, see PersonsLayout Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
PersonsLayout

public class PersonsLayout : FormTemplateLayout

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Persons

Assembly: AptifyPersonsGUI (in AptifyPersonsGUI.dll)

See Also

PersonsLayout Members | Aptify.Applications.Persons Namespace


PersonsLayout Members

PersonsLayout overview

Public Instance Constructors

PersonsLayout Constructor Initializes a new instance of the PersonsLayout class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

dicCurrentControlRecordIDs
m_bTransferringDataToObject
m_ctlAddress
m_ctlBalanceTotal
m_ctlCommitteeTermList
m_ctlCompanyDuesPaidThru
m_ctlCompanyDuesPaymentDate
m_ctlCompanyJoinDate
m_ctlCompanyLastDuesAmount
m_ctlCompanyTerminationDate
m_ctlDuesPaidThru
m_ctlDuesPaymentDate
m_ctlJoinDate
m_ctlLastDuesAmount
m_ctlListsView
m_ctlOrderTotal
m_ctlRecipientView
m_ctlSubscriberView
m_ctlTerminationDate
m_ctlUSCongress

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
m_ctlCommitteeTermAddButton |
m_ctlCompanysID |
m_ctlDuesTypeList |
m_ctlFunctionsCombo |
m_ctlFunctionsMultiEntityGrid |
m_ctlListViewOptions |
m_ctlPreferredAddress |
m_ctlPreferredBillingAddress |
m_ctlPreferredShippingAddress |
m_ctlSubscriptionViewOptions |
m_fieldUSCongress |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindAddressControls |
FindCompanyDuesControls |
FindDuesControls |
FindFunctionControls |
FindIndividualDuesControls |
FindListControls |
FindOrderControls |
FindSubscriptionControls |
FindTermMemberControls |
FlowDownAddressFromCompany |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetListWhereSQL |
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetSubscriptionWhereSQL |
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
LocalizePreferredAddressesDropDown | To Solve issue# 6975. Localize Display Text of Preferred Address, Preferred Billing Address and Preferred Shipping Address. So that value stored in Database will not be changed and works properly.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded | Contains logic to setup Event handlers for controls on the FormTemplate Layout.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject |
OnUSCongressAfterValueChanged |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
RefreshCommitteeTermMembersList |
RefreshFunctionsSubType |
RefreshListViews | Overloaded.
RefreshPrimaryFunction | Resets the Primary Function Drop Down if the ID doesn't exist in the functions sub-type
RefreshSubscriptionViews | Overloaded.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SelectAddress |
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetOrderSummaryCurrencyFormat |
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCompanyDuesControls |
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SetVisibleIndividualDuesControls |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
ToggleVisibility |
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

PersonsLayout Class | Aptify.Applications.Persons Namespace


PersonsLayout Constructor

Initializes a new instance of the PersonsLayout class.

public PersonsLayout();

See Also

PersonsLayout Class | Aptify.Applications.Persons Namespace


PersonsLayout Fields

The fields of the PersonsLayout class are listed below. For a complete list of PersonsLayout class members, see the PersonsLayout Members topic.

Protected Instance Fields

dicCurrentControlRecordIDs
m_bTransferringDataToObject
m_ctlAddress
m_ctlBalanceTotal
m_ctlCommitteeTermList
m_ctlCompanyDuesPaidThru
m_ctlCompanyDuesPaymentDate
m_ctlCompanyJoinDate
m_ctlCompanyLastDuesAmount
m_ctlCompanyTerminationDate
m_ctlDuesPaidThru
m_ctlDuesPaymentDate
m_ctlJoinDate
m_ctlLastDuesAmount
m_ctlListsView
m_ctlOrderTotal
m_ctlRecipientView
m_ctlSubscriberView
m_ctlTerminationDate
m_ctlUSCongress

See Also

PersonsLayout Class | Aptify.Applications.Persons Namespace


PersonsLayout.dicCurrentControlRecordIDs Field

protected dicCurrentControlRecordIDs dicCurrentControlRecordIDs;

See Also

PersonsLayout Class | Aptify.Applications.Persons Namespace


PersonsLayout.m_bTransferringDataToObject Field

protected m_bTransferringDataToObject m_bTransferringDataToObject;

See Also

PersonsLayout Class | Aptify.Applications.Persons Namespace


PersonsLayout.m_ctlAddress Field

protected m_ctlAddress m_ctlAddress;

See Also

PersonsLayout Class | Aptify.Applications.Persons Namespace


PersonsLayout.m_ctlBalanceTotal Field

protected m_ctlBalanceTotal m_ctlBalanceTotal;

See Also

PersonsLayout Class | Aptify.Applications.Persons Namespace


PersonsLayout.m_ctlCommitteeTermList Field

protected m_ctlCommitteeTermList m_ctlCommitteeTermList;

See Also

PersonsLayout Class | Aptify.Applications.Persons Namespace


PersonsLayout.m_ctlCompanyDuesPaidThru Field

protected m_ctlCompanyDuesPaidThru m_ctlCompanyDuesPaidThru;

See Also

PersonsLayout Class | Aptify.Applications.Persons Namespace


PersonsLayout.m_ctlCompanyDuesPaymentDate Field

protected m_ctlCompanyDuesPaymentDate m_ctlCompanyDuesPaymentDate;

See Also

PersonsLayout Class | Aptify.Applications.Persons Namespace


PersonsLayout.m_ctlCompanyJoinDate Field

protected m_ctlCompanyJoinDate m_ctlCompanyJoinDate;

See Also

PersonsLayout Class | Aptify.Applications.Persons Namespace


PersonsLayout.m_ctlCompanyLastDuesAmount Field

protected m_ctlCompanyLastDuesAmount m_ctlCompanyLastDuesAmount;

See Also

PersonsLayout Class | Aptify.Applications.Persons Namespace


PersonsLayout.m_ctlCompanyTerminationDate Field

protected m_ctlCompanyTerminationDate m_ctlCompanyTerminationDate;

See Also

PersonsLayout Class | Aptify.Applications.Persons Namespace


PersonsLayout.m_ctlDuesPaidThru Field

protected m_ctlDuesPaidThru m_ctlDuesPaidThru;

See Also

PersonsLayout Class | Aptify.Applications.Persons Namespace


PersonsLayout.m_ctlDuesPaymentDate Field

protected m_ctlDuesPaymentDate m_ctlDuesPaymentDate;

See Also

PersonsLayout Class | Aptify.Applications.Persons Namespace


PersonsLayout.m_ctlJoinDate Field

protected m_ctlJoinDate m_ctlJoinDate;

See Also

PersonsLayout Class | Aptify.Applications.Persons Namespace


PersonsLayout.m_ctlLastDuesAmount Field

protected m_ctlLastDuesAmount m_ctlLastDuesAmount;

See Also

PersonsLayout Class | Aptify.Applications.Persons Namespace


PersonsLayout.m_ctlListsView Field

protected m_ctlListsView m_ctlListsView;

See Also

PersonsLayout Class | Aptify.Applications.Persons Namespace


PersonsLayout.m_ctlOrderTotal Field

protected m_ctlOrderTotal m_ctlOrderTotal;

See Also

PersonsLayout Class | Aptify.Applications.Persons Namespace


PersonsLayout.m_ctlRecipientView Field

protected m_ctlRecipientView m_ctlRecipientView;

See Also

PersonsLayout Class | Aptify.Applications.Persons Namespace


PersonsLayout.m_ctlSubscriberView Field

protected m_ctlSubscriberView m_ctlSubscriberView;

See Also

PersonsLayout Class | Aptify.Applications.Persons Namespace


PersonsLayout.m_ctlTerminationDate Field

protected m_ctlTerminationDate m_ctlTerminationDate;

See Also

PersonsLayout Class | Aptify.Applications.Persons Namespace


PersonsLayout.m_ctlUSCongress Field

protected m_ctlUSCongress m_ctlUSCongress;

See Also

PersonsLayout Class | Aptify.Applications.Persons Namespace


PersonsLayout Properties

The properties of the PersonsLayout class are listed below. For a complete list of PersonsLayout class members, see the PersonsLayout Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
m_ctlCommitteeTermAddButton |
m_ctlCompanysID |
m_ctlDuesTypeList |
m_ctlFunctionsCombo |
m_ctlFunctionsMultiEntityGrid |
m_ctlListViewOptions |
m_ctlPreferredAddress |
m_ctlPreferredBillingAddress |
m_ctlPreferredShippingAddress |
m_ctlSubscriptionViewOptions |
m_fieldUSCongress |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

PersonsLayout Class | Aptify.Applications.Persons Namespace


m_ctlCommitteeTermAddButton Property

Aptify 5.0 Software Development Kit (SDK)

PersonsLayout.m_ctlCommitteeTermAddButton Property

protected virtual AddCommitteesButton m_ctlCommitteeTermAddButton {get; set;}

See Also

PersonsLayout Class | Aptify.Applications.Persons Namespace


m_ctlCompanysID Property

Aptify 5.0 Software Development Kit (SDK)

PersonsLayout.m_ctlCompanysID Property

protected virtual IAptifyDataFieldControlBase m_ctlCompanysID {get; set;}

See Also

PersonsLayout Class | Aptify.Applications.Persons Namespace


m_ctlDuesTypeList Property

Aptify 5.0 Software Development Kit (SDK)

PersonsLayout.m_ctlDuesTypeList Property

protected virtual PersonDuesTypeDropdownList m_ctlDuesTypeList {get; set;}

See Also

PersonsLayout Class | Aptify.Applications.Persons Namespace


m_ctlFunctionsCombo Property

Aptify 5.0 Software Development Kit (SDK)

PersonsLayout.m_ctlFunctionsCombo Property

protected virtual AptifyDataComboBox m_ctlFunctionsCombo {get; set;}

See Also

PersonsLayout Class | Aptify.Applications.Persons Namespace


m_ctlFunctionsMultiEntityGrid Property

Aptify 5.0 Software Development Kit (SDK)

PersonsLayout.m_ctlFunctionsMultiEntityGrid Property

protected virtual MultiEntityGrid m_ctlFunctionsMultiEntityGrid {get; set;}

See Also

PersonsLayout Class | Aptify.Applications.Persons Namespace


m_ctlListViewOptions Property

Aptify 5.0 Software Development Kit (SDK)

PersonsLayout.m_ctlListViewOptions Property

protected virtual GroupedOptions m_ctlListViewOptions {get; set;}

See Also

PersonsLayout Class | Aptify.Applications.Persons Namespace


m_ctlPreferredAddress Property

Aptify 5.0 Software Development Kit (SDK)

PersonsLayout.m_ctlPreferredAddress Property

protected virtual AptifyComboBox m_ctlPreferredAddress {get; set;}

See Also

PersonsLayout Class | Aptify.Applications.Persons Namespace


m_ctlPreferredBillingAddress Property

Aptify 5.0 Software Development Kit (SDK)

PersonsLayout.m_ctlPreferredBillingAddress Property

protected virtual AptifyComboBox m_ctlPreferredBillingAddress {get; set;}

See Also

PersonsLayout Class | Aptify.Applications.Persons Namespace


m_ctlPreferredShippingAddress Property

Aptify 5.0 Software Development Kit (SDK)

PersonsLayout.m_ctlPreferredShippingAddress Property

protected virtual AptifyComboBox m_ctlPreferredShippingAddress {get; set;}

See Also

PersonsLayout Class | Aptify.Applications.Persons Namespace


m_ctlSubscriptionViewOptions Property

Aptify 5.0 Software Development Kit (SDK)

PersonsLayout.m_ctlSubscriptionViewOptions Property

protected virtual GroupedOptions m_ctlSubscriptionViewOptions {get; set;}

See Also

PersonsLayout Class | Aptify.Applications.Persons Namespace


m_fieldUSCongress Property

Aptify 5.0 Software Development Kit (SDK)

PersonsLayout.m_fieldUSCongress Property

protected virtual AptifyDataFieldBase m_fieldUSCongress {get; set;}

See Also

PersonsLayout Class | Aptify.Applications.Persons Namespace


PersonsLayout Methods

The methods of the PersonsLayout class are listed below. For a complete list of PersonsLayout class members, see the PersonsLayout Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindAddressControls |
FindCompanyDuesControls |
FindDuesControls |
FindFunctionControls |
FindIndividualDuesControls |
FindListControls |
FindOrderControls |
FindSubscriptionControls |
FindTermMemberControls |
FlowDownAddressFromCompany |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetListWhereSQL |
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetSubscriptionWhereSQL |
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
LocalizePreferredAddressesDropDown | To Solve issue# 6975. Localize Display Text of Preferred Address, Preferred Billing Address and Preferred Shipping Address. So that value stored in Database will not be changed and works properly.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded | Contains logic to setup Event handlers for controls on the FormTemplate Layout.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject |
OnUSCongressAfterValueChanged |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
RefreshCommitteeTermMembersList |
RefreshFunctionsSubType |
RefreshListViews | Overloaded.
RefreshPrimaryFunction | Resets the Primary Function Drop Down if the ID doesn't exist in the functions sub-type
RefreshSubscriptionViews | Overloaded.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SelectAddress |
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetOrderSummaryCurrencyFormat |
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCompanyDuesControls |
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SetVisibleIndividualDuesControls |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
ToggleVisibility |
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

PersonsLayout Class | Aptify.Applications.Persons Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

PersonsLayout.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

PersonsLayout Class | Aptify.Applications.Persons Namespace


PersonsLayout.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

PersonsLayout Class | Aptify.Applications.Persons Namespace | PersonsLayout.Dispose Overload List


PersonsLayout.FindAddressControls Method

protected void FindAddressControls();

See Also

PersonsLayout Class | Aptify.Applications.Persons Namespace


PersonsLayout.FindCompanyDuesControls Method

protected void FindCompanyDuesControls();

See Also

PersonsLayout Class | Aptify.Applications.Persons Namespace


PersonsLayout.FindDuesControls Method

protected void FindDuesControls();

See Also

PersonsLayout Class | Aptify.Applications.Persons Namespace


PersonsLayout.FindFunctionControls Method

protected void FindFunctionControls();

See Also

PersonsLayout Class | Aptify.Applications.Persons Namespace


PersonsLayout.FindIndividualDuesControls Method

protected void FindIndividualDuesControls();

See Also

PersonsLayout Class | Aptify.Applications.Persons Namespace


PersonsLayout.FindListControls Method

protected void FindListControls();

See Also

PersonsLayout Class | Aptify.Applications.Persons Namespace


PersonsLayout.FindOrderControls Method

protected virtual void FindOrderControls();

See Also

PersonsLayout Class | Aptify.Applications.Persons Namespace


PersonsLayout.FindSubscriptionControls Method

protected void FindSubscriptionControls();

See Also

PersonsLayout Class | Aptify.Applications.Persons Namespace


PersonsLayout.FindTermMemberControls Method

protected void FindTermMemberControls();

See Also

PersonsLayout Class | Aptify.Applications.Persons Namespace


PersonsLayout.FlowDownAddressFromCompany Method

protected void FlowDownAddressFromCompany(
Object NewValue
);

See Also

PersonsLayout Class | Aptify.Applications.Persons Namespace


PersonsLayout.GetListWhereSQL Method

protected string GetListWhereSQL(
String SelectedOption
);

See Also

PersonsLayout Class | Aptify.Applications.Persons Namespace


PersonsLayout.GetSubscriptionWhereSQL Method

protected string GetSubscriptionWhereSQL(
String ViewOption
);

See Also

PersonsLayout Class | Aptify.Applications.Persons Namespace


PersonsLayout.LocalizePreferredAddressesDropDown Method

To Solve issue# 6975. Localize Display Text of Preferred Address, Preferred Billing Address and Preferred Shipping Address. So that value stored in Database will not be changed and works properly.

protected void LocalizePreferredAddressesDropDown();

Remarks

See Also

PersonsLayout Class | Aptify.Applications.Persons Namespace


PersonsLayout.OnFormTemplateLoaded Method

Contains logic to setup Event handlers for controls on the FormTemplate Layout.

protected override void OnFormTemplateLoaded(
FormTemplateLayout.FormTemplateLoadedEventArgs e
);

Parameters

e

Remarks

See Also

PersonsLayout Class | Aptify.Applications.Persons Namespace


PersonsLayout.OnRefresh Method

protected override void OnRefresh();

Implements

IFormComponent.

See Also

PersonsLayout Class | Aptify.Applications.Persons Namespace


OnShow Method

Aptify 5.0 Software Development Kit (SDK)

PersonsLayout.OnShow Method

Overload List

Inherited from FormComponent.

protected virtual void OnShow();

protected override void OnShow(Boolean);

See Also

PersonsLayout Class | Aptify.Applications.Persons Namespace


PersonsLayout.OnShow Method (Boolean)

protected override void OnShow(
Boolean Refresh
);

Implements

IFormComponent.

See Also

PersonsLayout Class | Aptify.Applications.Persons Namespace | PersonsLayout.OnShow Overload List


PersonsLayout.OnTransferDataToObject Method

protected override void OnTransferDataToObject(
ref Boolean& Cancel
);

Implements

IFormComponent.

See Also

PersonsLayout Class | Aptify.Applications.Persons Namespace


PersonsLayout.OnUSCongressAfterValueChanged Method

protected virtual void OnUSCongressAfterValueChanged(
AptifyDataFieldBase sender,
AfterValueChangedEventArgs e
);

See Also

PersonsLayout Class | Aptify.Applications.Persons Namespace


PersonsLayout.RefreshCommitteeTermMembersList Method

protected void RefreshCommitteeTermMembersList(
Boolean ForceRefresh
);

See Also

PersonsLayout Class | Aptify.Applications.Persons Namespace


PersonsLayout.RefreshFunctionsSubType Method

protected void RefreshFunctionsSubType();

See Also

PersonsLayout Class | Aptify.Applications.Persons Namespace


RefreshListViews Method

Aptify 5.0 Software Development Kit (SDK)

PersonsLayout.RefreshListViews Method

Overload List

protected void RefreshListViews();

protected void RefreshListViews(String);

See Also

PersonsLayout Class | Aptify.Applications.Persons Namespace


PersonsLayout.RefreshListViews Method ()

protected void RefreshListViews();

See Also

PersonsLayout Class | Aptify.Applications.Persons Namespace | PersonsLayout.RefreshListViews Overload List


PersonsLayout.RefreshListViews Method (String)

protected void RefreshListViews(
String SelectedOption
);

See Also

PersonsLayout Class | Aptify.Applications.Persons Namespace | PersonsLayout.RefreshListViews Overload List


PersonsLayout.RefreshPrimaryFunction Method

Resets the Primary Function Drop Down if the ID doesn't exist in the functions sub-type

protected void RefreshPrimaryFunction();

Remarks

See Also

PersonsLayout Class | Aptify.Applications.Persons Namespace


RefreshSubscriptionViews Method

Aptify 5.0 Software Development Kit (SDK)

PersonsLayout.RefreshSubscriptionViews Method

Overload List

protected void RefreshSubscriptionViews();

protected void RefreshSubscriptionViews(String);

See Also

PersonsLayout Class | Aptify.Applications.Persons Namespace


PersonsLayout.RefreshSubscriptionViews Method ()

protected void RefreshSubscriptionViews();

See Also

PersonsLayout Class | Aptify.Applications.Persons Namespace | PersonsLayout.RefreshSubscriptionViews Overload List


PersonsLayout.RefreshSubscriptionViews Method (String)

protected void RefreshSubscriptionViews(
String SelectedOption
);

See Also

PersonsLayout Class | Aptify.Applications.Persons Namespace | PersonsLayout.RefreshSubscriptionViews Overload List


PersonsLayout.SelectAddress Method

protected void SelectAddress();

See Also

PersonsLayout Class | Aptify.Applications.Persons Namespace


PersonsLayout.SetOrderSummaryCurrencyFormat Method

protected virtual void SetOrderSummaryCurrencyFormat();

See Also

PersonsLayout Class | Aptify.Applications.Persons Namespace


PersonsLayout.SetVisibleCompanyDuesControls Method

protected void SetVisibleCompanyDuesControls(
Boolean Visible
);

See Also

PersonsLayout Class | Aptify.Applications.Persons Namespace


PersonsLayout.SetVisibleIndividualDuesControls Method

protected void SetVisibleIndividualDuesControls(
Boolean Visible
);

See Also

PersonsLayout Class | Aptify.Applications.Persons Namespace


PersonsLayout.ToggleVisibility Method

protected void ToggleVisibility();

See Also

PersonsLayout Class | Aptify.Applications.Persons Namespace


PersonSPMEntity Class

For a list of all members of this type, see PersonSPMEntity Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
PersonSavedPaymentMethodsClass
PersonSPMEntity

public class PersonSPMEntity : PersonSavedPaymentMethodsClass

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Persons

Assembly: AptifyPersonsEntity (in AptifyPersonsEntity.dll)

See Also

PersonSPMEntity Members | Aptify.Applications.Persons Namespace


PersonSPMEntity Members

PersonSPMEntity overview

Public Instance Constructors

PersonSPMEntity Constructor Initializes a new instance of the PersonSPMEntity class.

Public Instance Properties

ABA (inherited from PersonSavedPaymentMethodsClass) |
AccountNumber (inherited from PersonSavedPaymentMethodsClass) |
Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
Bank (inherited from PersonSavedPaymentMethodsClass) |
BranchName (inherited from PersonSavedPaymentMethodsClass) |
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
CCAccountNumber (inherited from PersonSavedPaymentMethodsClass) |
CCExpireDate (inherited from PersonSavedPaymentMethodsClass) |
CCPartial (inherited from PersonSavedPaymentMethodsClass) |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CreditOrderID (inherited from PersonSavedPaymentMethodsClass) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
Description (inherited from PersonSavedPaymentMethodsClass) |
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
DueDate (inherited from PersonSavedPaymentMethodsClass) |
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EndDate (inherited from PersonSavedPaymentMethodsClass) |
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
ID (inherited from PersonSavedPaymentMethodsClass) |
IsActive (inherited from PersonSavedPaymentMethodsClass) |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
Name (inherited from PersonSavedPaymentMethodsClass) |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PaymentInformationID (inherited from PersonSavedPaymentMethodsClass) |
PaymentType (inherited from PersonSavedPaymentMethodsClass) |
PaymentTypeID (inherited from PersonSavedPaymentMethodsClass) |
PersonID (inherited from PersonSavedPaymentMethodsClass) |
PONumber (inherited from PersonSavedPaymentMethodsClass) |
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Sequence (inherited from PersonSavedPaymentMethodsClass) |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
StartDate (inherited from PersonSavedPaymentMethodsClass) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
Terms (inherited from PersonSavedPaymentMethodsClass) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

PersonSPMEntity Class | Aptify.Applications.Persons Namespace


PersonSPMEntity Constructor

Initializes a new instance of the PersonSPMEntity class.

public PersonSPMEntity();

See Also

PersonSPMEntity Class | Aptify.Applications.Persons Namespace


PersonSPMEntity Methods

The methods of the PersonSPMEntity class are listed below. For a complete list of PersonSPMEntity class members, see the PersonSPMEntity Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

PersonSPMEntity Class | Aptify.Applications.Persons Namespace


Validate Method

Aptify 5.0 Software Development Kit (SDK)

PersonSPMEntity.Validate Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Validate();

public override bool Validate(ref String&);

See Also

PersonSPMEntity Class | Aptify.Applications.Persons Namespace


PersonSPMEntity.Validate Method (String&)

public override bool Validate(
ref String& ErrorString
);

See Also

PersonSPMEntity Class | Aptify.Applications.Persons Namespace | PersonSPMEntity.Validate Overload List


PersonSPMLayout Class

For a list of all members of this type, see PersonSPMLayout Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
PersonSPMLayout

public class PersonSPMLayout : FormTemplateLayout

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Persons

Assembly: AptifyPersonsGUI (in AptifyPersonsGUI.dll)

See Also

PersonSPMLayout Members | Aptify.Applications.Persons Namespace


PersonSPMLayout Members

PersonSPMLayout overview

Public Instance Constructors

PersonSPMLayout Constructor Initializes a new instance of the PersonSPMLayout class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

m_aptPaymentInfo

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig |
OnFormTemplateLoaded |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow | Overloaded.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

PersonSPMLayout Class | Aptify.Applications.Persons Namespace


PersonSPMLayout Constructor

Initializes a new instance of the PersonSPMLayout class.

public PersonSPMLayout();

See Also

PersonSPMLayout Class | Aptify.Applications.Persons Namespace


PersonSPMLayout Fields

The fields of the PersonSPMLayout class are listed below. For a complete list of PersonSPMLayout class members, see the PersonSPMLayout Members topic.

Protected Instance Fields

m_aptPaymentInfo

See Also

PersonSPMLayout Class | Aptify.Applications.Persons Namespace


PersonSPMLayout.m_aptPaymentInfo Field

protected m_aptPaymentInfo m_aptPaymentInfo;

See Also

PersonSPMLayout Class | Aptify.Applications.Persons Namespace


PersonSPMLayout Methods

The methods of the PersonSPMLayout class are listed below. For a complete list of PersonSPMLayout class members, see the PersonSPMLayout Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig |
OnFormTemplateLoaded |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow | Overloaded.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

PersonSPMLayout Class | Aptify.Applications.Persons Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

PersonSPMLayout.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

PersonSPMLayout Class | Aptify.Applications.Persons Namespace


PersonSPMLayout.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

PersonSPMLayout Class | Aptify.Applications.Persons Namespace | PersonSPMLayout.Dispose Overload List


PersonSPMLayout.OnFormComponentConfig Method

protected override void OnFormComponentConfig(
AptifyFormTemplateContext Context
);

Implements

IFormComponent.

See Also

PersonSPMLayout Class | Aptify.Applications.Persons Namespace


PersonSPMLayout.OnFormTemplateLoaded Method

protected override void OnFormTemplateLoaded(
FormTemplateLayout.FormTemplateLoadedEventArgs e
);

See Also

PersonSPMLayout Class | Aptify.Applications.Persons Namespace


PersonSPMLayout.OnRefresh Method

protected override void OnRefresh();

Implements

IFormComponent.

See Also

PersonSPMLayout Class | Aptify.Applications.Persons Namespace


OnShow Method

Aptify 5.0 Software Development Kit (SDK)

PersonSPMLayout.OnShow Method

Overload List

protected override void OnShow();

Inherited from FormTemplateLayout.

protected override void OnShow(Boolean);

See Also

PersonSPMLayout Class | Aptify.Applications.Persons Namespace


PersonSPMLayout.OnShow Method ()

protected override void OnShow();

Implements

IFormComponent.

See Also

PersonSPMLayout Class | Aptify.Applications.Persons Namespace | PersonSPMLayout.OnShow Overload List


PersonsRankSliderBar Class

Allows a user to assign a rank to a person by moving a slider bar.

For a list of all members of this type, see PersonsRankSliderBar Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
AptifyControlBase
AptifyDataFieldControlBase
PersonsRankSliderBar

public class PersonsRankSliderBar : AptifyDataFieldControlBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Persons

Assembly: AptifyPersonsGUI (in AptifyPersonsGUI.dll)

See Also

PersonsRankSliderBar Members | Aptify.Applications.Persons Namespace


PersonsRankSliderBar Members

PersonsRankSliderBar overview

Public Instance Constructors

PersonsRankSliderBar Constructor Initializes a new instance of the PersonsRankSliderBar class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Control (inherited from AptifyControlBase) |
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DataControl (inherited from AptifyControlBase) | Adds a reference to the object for the data control. In the case of it being added, the reference to the bound control base object is added to the data controls collection.
DataField (inherited from AptifyDataFieldControlBase) | This is the field in the GE to whose value read/write operations are applied.
DataSource (inherited from AptifyDataFieldControlBase) |
DisableGeDataTransfer (inherited from AptifyControlBase) | If true, the implementer is required to move the value to/from the bound control to the GE or other data access method.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
FieldHelp (inherited from AptifyControlBase) |
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from AptifyDataFieldControlBase) | The font for the internal control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateContext (inherited from AptifyControlBase) | Returns the reference that if is local that is returned else if a DataControl exists, it is returned.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpObject (inherited from AptifyDataFieldControlBase) | This member is overriden in this class to provide field-level help if available
HelpURL (inherited from AptifyDataFieldControlBase) | This member is overriden in this class to provide field-level help if available
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LabelFont (inherited from AptifyDataFieldControlBase) | The font of the label.
LabelRequiredFont (inherited from AptifyDataFieldControlBase) |
LabelSize (inherited from AptifyDataFieldControlBase) | Size of the label.
LabelText (inherited from AptifyDataFieldControlBase) |
LabelTextAlign (inherited from AptifyDataFieldControlBase) |
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
ObjectRepository (inherited from AptifyControlBase) |
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Required (inherited from AptifyDataFieldControlBase) |
RequiredFieldBackColor (inherited from AptifyDataFieldControlBase) |
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ShowLabel (inherited from AptifyDataFieldControlBase) |
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from AptifyDataFieldControlBase) | Sets the Value of the control.
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
Value | Gets\Sets the Value of the Slider Bar.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BoundControlConfig (inherited from AptifyDataFieldControlBase) | Configures the bound control to be used with the DataControl
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ClearData (inherited from AptifyDataFieldControlBase) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DisplayControlHelp (inherited from AptifyControlBase) | This method will display control-level help information. This method will use the HelpTitle and HelpText overridable members to display the Field Help object from Aptify.Framework.WindowsControls.FieldHelp. If the title and text is desired to be overriden it is not necessary to override this method, rather override the HelpTitle and HelpText properties which are used by this method.
DisplayEntityHelp (inherited from AptifyControlBase) | This method is responsible for displaying the help file to the user and will attempt to provide context sensitive help based on the particular entity being displayed. If no entity-specific help file is available for the user then the standard Aptify Shell.Aptify Help file will be used to display help to the user. Override this method in sub-classes to change the method for displaying help.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetDefaultHelpObject (inherited from AptifyControlBase) | This method returns the default help object file in the Aptify Object repository to be used in the event that no entity-specific file exists
GetEntityFieldSpecificHelpObject (inherited from AptifyDataFieldControlBase) | This method returns the Aptify Object Repository Object location for the help file that is specific to this entity field.
GetEntityFieldSpecificHelpTopicURL (inherited from AptifyDataFieldControlBase) | This method returns the Topic URL location within the help file that is specific to this entity field.
GetEntitySpecificHelpObject (inherited from AptifyControlBase) | This method returns the Aptify Object Repository Object location for the help file that is specific to this entity.
GetEntitySpecificHelpTopicURL (inherited from AptifyControlBase) | This method returns the Topic URL location within the help file that is specific to this entity.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseValueChanged (inherited from AptifyControlBase) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from AptifyDataFieldControlBase) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetUserCredential (inherited from AptifyControlBase) |
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
TransferDataToObject (inherited from AptifyDataFieldControlBase) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AfterDisplayEntityHelp (inherited from AptifyControlBase) | This event is fired after the help file is displayed.
AptifyControlBaseTextChanged (inherited from AptifyControlBase) |
AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BeforeDisplayEntityHelp (inherited from AptifyControlBase) | This event is fired before the help file is displayed. To prevent help from being displayed set the Cancel parameter to True.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from AptifyControlBase) |
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from AptifyControlBase) |
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from AptifyControlBase) |
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from AptifyControlBase) |
KeyPress (inherited from AptifyControlBase) |
KeyUp (inherited from AptifyControlBase) |
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from AptifyControlBase) |
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from AptifyControlBase) |
MouseEnter (inherited from AptifyControlBase) |
MouseHover (inherited from AptifyControlBase) |
MouseLeave (inherited from AptifyControlBase) |
MouseMove (inherited from AptifyControlBase) |
MouseUp (inherited from AptifyControlBase) |
MouseWheel (inherited from AptifyControlBase) |
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from AptifyControlBase) |
Validated (inherited from AptifyControlBase) |
Validating (inherited from AptifyControlBase) |
ValueChanged (inherited from AptifyControlBase) |
VisibleChanged (inherited from AptifyControlBase) |

Protected Instance Fields

m_bEdit (inherited from AptifyDataFieldControlBase)
m_bNewTypedValue (inherited from AptifyDataFieldControlBase)
m_bPreConfig (inherited from AptifyDataFieldControlBase)
m_bRead (inherited from AptifyDataFieldControlBase)
m_bRequired (inherited from AptifyDataFieldControlBase)
m_iDataControl (inherited from AptifyControlBase)
m_oAptifyApplication (inherited from AptifyControlBase)
m_oFormTemplateContext (inherited from AptifyControlBase)
m_oUserCredential (inherited from AptifyControlBase)
m_sDataField (inherited from AptifyDataFieldControlBase)

Protected Instance Properties

AptifyApplication (inherited from AptifyControlBase) | Returns an instance of the Aptify Application Object
AptifyMessage (inherited from AptifyDataFieldControlBase) |
AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
CurrencyTypeCache (inherited from AptifyControlBase) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DisplayName (inherited from AptifyControlBase) |
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
ExtendedType (inherited from AptifyDataFieldControlBase) |
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HelpText (inherited from AptifyControlBase) |
HelpTitle (inherited from AptifyDataFieldControlBase) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
InternalControl |
Label (inherited from AptifyDataFieldControlBase) |
m_oInternalControl (inherited from AptifyControlBase) |
MyApplication (inherited from AptifyControlBase) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowDisplayHelpHyperlink (inherited from AptifyControlBase) | This property can be overriden by sub-classes to be able to selectively turn on or off the Display Help hyperlink that appears by default on the FieldHelp object.
UserCredential (inherited from AptifyControlBase) |
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
AptifyControlBaseValueChangedHandler (inherited from AptifyDataFieldControlBase) |
ConfigHelp (inherited from AptifyDataFieldControlBase) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
CreateMessageObjects (inherited from AptifyDataFieldControlBase) |
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
DoFormComponentConfig (inherited from AptifyDataFieldControlBase) |
DoFormComponentConfigRunMode (inherited from AptifyDataFieldControlBase) |
DoPostal_Leave (inherited from AptifyDataFieldControlBase) |
Finalize (inherited from AptifyControlBase) |
FormComponentConfig (inherited from AptifyControlBase) |
FormComponentHide (inherited from AptifyControlBase) |
FormComponentShow (inherited from AptifyControlBase) | Overloaded.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
LookupPostalInfo (inherited from AptifyDataFieldControlBase) |
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RequiredGECheck (inherited from AptifyControlBase) |
RequiredPropertiesCheck (inherited from AptifyControlBase) |
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlMetaData (inherited from AptifyDataFieldControlBase) |
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetSecurity (inherited from AptifyDataFieldControlBase) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetValueFromGe (inherited from AptifyDataFieldControlBase) |
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Instance Events

PostConfig (inherited from AptifyDataFieldControlBase)
PreConfig (inherited from AptifyDataFieldControlBase)

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.
StopInitialization (inherited from AptifyDataFieldControlBase) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

PersonsRankSliderBar Class | Aptify.Applications.Persons Namespace


PersonsRankSliderBar Constructor

Initializes a new instance of the PersonsRankSliderBar class.

public PersonsRankSliderBar();

See Also

PersonsRankSliderBar Class | Aptify.Applications.Persons Namespace


PersonsRankSliderBar Properties

The properties of the PersonsRankSliderBar class are listed below. For a complete list of PersonsRankSliderBar class members, see the PersonsRankSliderBar Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Control (inherited from AptifyControlBase) |
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DataControl (inherited from AptifyControlBase) | Adds a reference to the object for the data control. In the case of it being added, the reference to the bound control base object is added to the data controls collection.
DataField (inherited from AptifyDataFieldControlBase) | This is the field in the GE to whose value read/write operations are applied.
DataSource (inherited from AptifyDataFieldControlBase) |
DisableGeDataTransfer (inherited from AptifyControlBase) | If true, the implementer is required to move the value to/from the bound control to the GE or other data access method.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
FieldHelp (inherited from AptifyControlBase) |
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from AptifyDataFieldControlBase) | The font for the internal control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateContext (inherited from AptifyControlBase) | Returns the reference that if is local that is returned else if a DataControl exists, it is returned.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpObject (inherited from AptifyDataFieldControlBase) | This member is overriden in this class to provide field-level help if available
HelpURL (inherited from AptifyDataFieldControlBase) | This member is overriden in this class to provide field-level help if available
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LabelFont (inherited from AptifyDataFieldControlBase) | The font of the label.
LabelRequiredFont (inherited from AptifyDataFieldControlBase) |
LabelSize (inherited from AptifyDataFieldControlBase) | Size of the label.
LabelText (inherited from AptifyDataFieldControlBase) |
LabelTextAlign (inherited from AptifyDataFieldControlBase) |
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
ObjectRepository (inherited from AptifyControlBase) |
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Required (inherited from AptifyDataFieldControlBase) |
RequiredFieldBackColor (inherited from AptifyDataFieldControlBase) |
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ShowLabel (inherited from AptifyDataFieldControlBase) |
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from AptifyDataFieldControlBase) | Sets the Value of the control.
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
Value | Gets\Sets the Value of the Slider Bar.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AptifyApplication (inherited from AptifyControlBase) | Returns an instance of the Aptify Application Object
AptifyMessage (inherited from AptifyDataFieldControlBase) |
AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
CurrencyTypeCache (inherited from AptifyControlBase) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DisplayName (inherited from AptifyControlBase) |
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
ExtendedType (inherited from AptifyDataFieldControlBase) |
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HelpText (inherited from AptifyControlBase) |
HelpTitle (inherited from AptifyDataFieldControlBase) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
InternalControl |
Label (inherited from AptifyDataFieldControlBase) |
m_oInternalControl (inherited from AptifyControlBase) |
MyApplication (inherited from AptifyControlBase) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowDisplayHelpHyperlink (inherited from AptifyControlBase) | This property can be overriden by sub-classes to be able to selectively turn on or off the Display Help hyperlink that appears by default on the FieldHelp object.
UserCredential (inherited from AptifyControlBase) |
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.
StopInitialization (inherited from AptifyDataFieldControlBase) |

See Also

PersonsRankSliderBar Class | Aptify.Applications.Persons Namespace


InternalControl Property

Aptify 5.0 Software Development Kit (SDK)

PersonsRankSliderBar.InternalControl Property

protected override Control InternalControl {get; set;}

See Also

PersonsRankSliderBar Class | Aptify.Applications.Persons Namespace


Value Property

Aptify 5.0 Software Development Kit (SDK)

PersonsRankSliderBar.Value Property

Gets\Sets the Value of the Slider Bar.

public override Object Value {get; set;}

Property Value

Implements

IAptifyDataFieldControlBase.

Remarks

See Also

PersonsRankSliderBar Class | Aptify.Applications.Persons Namespace


PersonsRankSliderBar Methods

The methods of the PersonsRankSliderBar class are listed below. For a complete list of PersonsRankSliderBar class members, see the PersonsRankSliderBar Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BoundControlConfig (inherited from AptifyDataFieldControlBase) | Configures the bound control to be used with the DataControl
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ClearData (inherited from AptifyDataFieldControlBase) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DisplayControlHelp (inherited from AptifyControlBase) | This method will display control-level help information. This method will use the HelpTitle and HelpText overridable members to display the Field Help object from Aptify.Framework.WindowsControls.FieldHelp. If the title and text is desired to be overriden it is not necessary to override this method, rather override the HelpTitle and HelpText properties which are used by this method.
DisplayEntityHelp (inherited from AptifyControlBase) | This method is responsible for displaying the help file to the user and will attempt to provide context sensitive help based on the particular entity being displayed. If no entity-specific help file is available for the user then the standard Aptify Shell.Aptify Help file will be used to display help to the user. Override this method in sub-classes to change the method for displaying help.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetDefaultHelpObject (inherited from AptifyControlBase) | This method returns the default help object file in the Aptify Object repository to be used in the event that no entity-specific file exists
GetEntityFieldSpecificHelpObject (inherited from AptifyDataFieldControlBase) | This method returns the Aptify Object Repository Object location for the help file that is specific to this entity field.
GetEntityFieldSpecificHelpTopicURL (inherited from AptifyDataFieldControlBase) | This method returns the Topic URL location within the help file that is specific to this entity field.
GetEntitySpecificHelpObject (inherited from AptifyControlBase) | This method returns the Aptify Object Repository Object location for the help file that is specific to this entity.
GetEntitySpecificHelpTopicURL (inherited from AptifyControlBase) | This method returns the Topic URL location within the help file that is specific to this entity.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseValueChanged (inherited from AptifyControlBase) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from AptifyDataFieldControlBase) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetUserCredential (inherited from AptifyControlBase) |
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
TransferDataToObject (inherited from AptifyDataFieldControlBase) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
AptifyControlBaseValueChangedHandler (inherited from AptifyDataFieldControlBase) |
ConfigHelp (inherited from AptifyDataFieldControlBase) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
CreateMessageObjects (inherited from AptifyDataFieldControlBase) |
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
DoFormComponentConfig (inherited from AptifyDataFieldControlBase) |
DoFormComponentConfigRunMode (inherited from AptifyDataFieldControlBase) |
DoPostal_Leave (inherited from AptifyDataFieldControlBase) |
Finalize (inherited from AptifyControlBase) |
FormComponentConfig (inherited from AptifyControlBase) |
FormComponentHide (inherited from AptifyControlBase) |
FormComponentShow (inherited from AptifyControlBase) | Overloaded.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
LookupPostalInfo (inherited from AptifyDataFieldControlBase) |
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RequiredGECheck (inherited from AptifyControlBase) |
RequiredPropertiesCheck (inherited from AptifyControlBase) |
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlMetaData (inherited from AptifyDataFieldControlBase) |
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetSecurity (inherited from AptifyDataFieldControlBase) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetValueFromGe (inherited from AptifyDataFieldControlBase) |
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

PersonsRankSliderBar Class | Aptify.Applications.Persons Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

PersonsRankSliderBar.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

PersonsRankSliderBar Class | Aptify.Applications.Persons Namespace


PersonsRankSliderBar.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

PersonsRankSliderBar Class | Aptify.Applications.Persons Namespace | PersonsRankSliderBar.Dispose Overload List


PersonsSpecialFieldTextBox Class

Used to display special fields for Persons.

For a list of all members of this type, see PersonsSpecialFieldTextBox Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
AptifyControlBase
AptifyDataFieldControlBase
AptifyTextBox
PersonsSpecialFieldTextBox

public class PersonsSpecialFieldTextBox : AptifyTextBox

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

This will call the Get value from the Persons entity, before the datafield is assigned. This is, because we want to ensure that the fields is there. It Supports the DataField property.

Requirements

Namespace: Aptify.Applications.Persons

Assembly: AptifyPersonsGUI (in AptifyPersonsGUI.dll)

See Also

PersonsSpecialFieldTextBox Members | Aptify.Applications.Persons Namespace


PersonsSpecialFieldTextBox Members

PersonsSpecialFieldTextBox overview

Public Instance Constructors

PersonsSpecialFieldTextBox Constructor Initializes a new instance of the PersonsSpecialFieldTextBox class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Control (inherited from AptifyControlBase) |
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DataControl (inherited from AptifyControlBase) | Adds a reference to the object for the data control. In the case of it being added, the reference to the bound control base object is added to the data controls collection.
DataField (inherited from AptifyDataFieldControlBase) | This is the field in the GE to whose value read/write operations are applied.
DataSource (inherited from AptifyDataFieldControlBase) |
DisableGeDataTransfer (inherited from AptifyControlBase) | If true, the implementer is required to move the value to/from the bound control to the GE or other data access method.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
FieldHelp (inherited from AptifyControlBase) |
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from AptifyDataFieldControlBase) | The font for the internal control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormatString (inherited from AptifyTextBox) |
FormTemplateContext (inherited from AptifyControlBase) | Returns the reference that if is local that is returned else if a DataControl exists, it is returned.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpObject (inherited from AptifyDataFieldControlBase) | This member is overriden in this class to provide field-level help if available
HelpURL (inherited from AptifyDataFieldControlBase) | This member is overriden in this class to provide field-level help if available
HideSelection (inherited from AptifyTextBox) |
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LabelAutoSize (inherited from AptifyTextBox) |
LabelFont (inherited from AptifyDataFieldControlBase) | The font of the label.
LabelRequiredFont (inherited from AptifyDataFieldControlBase) |
LabelSize (inherited from AptifyDataFieldControlBase) | Size of the label.
LabelText (inherited from AptifyDataFieldControlBase) |
LabelTextAlign (inherited from AptifyDataFieldControlBase) |
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MaxLength (inherited from AptifyTextBox) | The maximum number of characters that the text box will accept.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
MultiLine (inherited from AptifyTextBox) | If set to true, the control allows multiple lines to be inserted.
Name (inherited from Control) | Gets or sets the name of the control.
ObjectRepository (inherited from AptifyControlBase) |
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PasswordChar (inherited from AptifyTextBox) | Shows a different visible character if this is set.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Required (inherited from AptifyDataFieldControlBase) |
RequiredFieldBackColor (inherited from AptifyTextBox) |
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ScrollBars (inherited from AptifyTextBox) | Sets the scroll bars for the text box control.
ShowLabel (inherited from AptifyDataFieldControlBase) |
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from AptifyDataFieldControlBase) | Sets the Value of the control.
TextAlign (inherited from AptifyTextBox) | The alignment of the text within the text box.
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
Value (inherited from AptifyTextBox) |
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BoundControlConfig (inherited from AptifyTextBox) |
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ClearData (inherited from AptifyDataFieldControlBase) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DisplayControlHelp (inherited from AptifyControlBase) | This method will display control-level help information. This method will use the HelpTitle and HelpText overridable members to display the Field Help object from Aptify.Framework.WindowsControls.FieldHelp. If the title and text is desired to be overriden it is not necessary to override this method, rather override the HelpTitle and HelpText properties which are used by this method.
DisplayEntityHelp (inherited from AptifyControlBase) | This method is responsible for displaying the help file to the user and will attempt to provide context sensitive help based on the particular entity being displayed. If no entity-specific help file is available for the user then the standard Aptify Shell.Aptify Help file will be used to display help to the user. Override this method in sub-classes to change the method for displaying help.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetDefaultHelpObject (inherited from AptifyControlBase) | This method returns the default help object file in the Aptify Object repository to be used in the event that no entity-specific file exists
GetEntityFieldSpecificHelpObject (inherited from AptifyDataFieldControlBase) | This method returns the Aptify Object Repository Object location for the help file that is specific to this entity field.
GetEntityFieldSpecificHelpTopicURL (inherited from AptifyDataFieldControlBase) | This method returns the Topic URL location within the help file that is specific to this entity field.
GetEntitySpecificHelpObject (inherited from AptifyControlBase) | This method returns the Aptify Object Repository Object location for the help file that is specific to this entity.
GetEntitySpecificHelpTopicURL (inherited from AptifyControlBase) | This method returns the Topic URL location within the help file that is specific to this entity.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseValueChanged (inherited from AptifyControlBase) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from AptifyDataFieldControlBase) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from AptifyTextBox) | Overloaded.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetExtendedType (inherited from AptifyTextBox) |
SetUserCredential (inherited from AptifyControlBase) |
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
TransferDataToObject (inherited from AptifyDataFieldControlBase) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AfterDisplayEntityHelp (inherited from AptifyControlBase) | This event is fired after the help file is displayed.
AptifyControlBaseTextChanged (inherited from AptifyControlBase) |
AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BeforeDisplayEntityHelp (inherited from AptifyControlBase) | This event is fired before the help file is displayed. To prevent help from being displayed set the Cancel parameter to True.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from AptifyControlBase) |
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from AptifyControlBase) |
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from AptifyControlBase) |
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from AptifyControlBase) |
KeyPress (inherited from AptifyControlBase) |
KeyUp (inherited from AptifyControlBase) |
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from AptifyControlBase) |
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from AptifyControlBase) |
MouseEnter (inherited from AptifyControlBase) |
MouseHover (inherited from AptifyControlBase) |
MouseLeave (inherited from AptifyControlBase) |
MouseMove (inherited from AptifyControlBase) |
MouseUp (inherited from AptifyControlBase) |
MouseWheel (inherited from AptifyControlBase) |
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from AptifyControlBase) |
Validated (inherited from AptifyControlBase) |
Validating (inherited from AptifyControlBase) |
ValueChanged (inherited from AptifyControlBase) |
VisibleChanged (inherited from AptifyControlBase) |

Protected Instance Fields

m_bEdit (inherited from AptifyDataFieldControlBase)
m_bNewTypedValue (inherited from AptifyDataFieldControlBase)
m_bPreConfig (inherited from AptifyDataFieldControlBase)
m_bRead (inherited from AptifyDataFieldControlBase)
m_bRequired (inherited from AptifyDataFieldControlBase)
m_iDataControl (inherited from AptifyControlBase)
m_oAptifyApplication (inherited from AptifyControlBase)
m_oFormTemplateContext (inherited from AptifyControlBase)
m_oUserCredential (inherited from AptifyControlBase)
m_sDataField (inherited from AptifyDataFieldControlBase)

Protected Instance Properties

AptifyApplication (inherited from AptifyControlBase) | Returns an instance of the Aptify Application Object
AptifyMessage (inherited from AptifyDataFieldControlBase) |
AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
CurrencyTypeCache (inherited from AptifyControlBase) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DisplayName (inherited from AptifyControlBase) |
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
ExtendedType (inherited from AptifyTextBox) |
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HelpText (inherited from AptifyControlBase) |
HelpTitle (inherited from AptifyDataFieldControlBase) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
InternalControl (inherited from AptifyControlBase) | Specifies the Main Control of interest in a composite control.
Label (inherited from AptifyDataFieldControlBase) |
m_oInternalControl (inherited from AptifyControlBase) |
MyApplication (inherited from AptifyControlBase) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowDisplayHelpHyperlink (inherited from AptifyControlBase) | This property can be overriden by sub-classes to be able to selectively turn on or off the Display Help hyperlink that appears by default on the FieldHelp object.
UserCredential (inherited from AptifyControlBase) |
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
AptifyControlBaseValueChangedHandler (inherited from AptifyDataFieldControlBase) |
ConfigHelp (inherited from AptifyDataFieldControlBase) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
CreateMessageObjects (inherited from AptifyDataFieldControlBase) |
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
DoFormComponentConfig | Configures the Component.
DoFormComponentConfigRunMode (inherited from AptifyTextBox) |
DoPostal_Leave (inherited from AptifyDataFieldControlBase) |
Finalize (inherited from AptifyControlBase) |
FormatValue (inherited from AptifyTextBox) | Formats the Value of the control using the FormatString. If FormatString is blank, the default formatting for the data type will be used. Example: The Default Format String for money is Currency which uses the client's regional format settings for Currency.
FormComponentConfig (inherited from AptifyControlBase) |
FormComponentHide (inherited from AptifyControlBase) |
FormComponentShow (inherited from AptifyControlBase) | Overloaded.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
LookupPostalInfo (inherited from AptifyDataFieldControlBase) |
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from AptifyTextBox) |
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from AptifyTextBox) |
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from AptifyTextBox) |
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RequiredGECheck (inherited from AptifyControlBase) |
RequiredPropertiesCheck (inherited from AptifyControlBase) |
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlMetaData (inherited from AptifyTextBox) |
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetSecurity (inherited from AptifyDataFieldControlBase) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTextAlignByDataType (inherited from AptifyTextBox) | Sets the TextAlign property based on the Data Type of the DataField. Numeric data types are right-aligned. All others are left-aligned. Note: This behavior is currently disabled.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetValueFromGe (inherited from AptifyDataFieldControlBase) |
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Instance Events

PostConfig (inherited from AptifyDataFieldControlBase)
PreConfig (inherited from AptifyDataFieldControlBase)

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.
StopInitialization (inherited from AptifyDataFieldControlBase) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

PersonsSpecialFieldTextBox Class | Aptify.Applications.Persons Namespace


PersonsSpecialFieldTextBox Constructor

Initializes a new instance of the PersonsSpecialFieldTextBox class.

public PersonsSpecialFieldTextBox();

See Also

PersonsSpecialFieldTextBox Class | Aptify.Applications.Persons Namespace


PersonsSpecialFieldTextBox Methods

The methods of the PersonsSpecialFieldTextBox class are listed below. For a complete list of PersonsSpecialFieldTextBox class members, see the PersonsSpecialFieldTextBox Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BoundControlConfig (inherited from AptifyTextBox) |
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ClearData (inherited from AptifyDataFieldControlBase) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DisplayControlHelp (inherited from AptifyControlBase) | This method will display control-level help information. This method will use the HelpTitle and HelpText overridable members to display the Field Help object from Aptify.Framework.WindowsControls.FieldHelp. If the title and text is desired to be overriden it is not necessary to override this method, rather override the HelpTitle and HelpText properties which are used by this method.
DisplayEntityHelp (inherited from AptifyControlBase) | This method is responsible for displaying the help file to the user and will attempt to provide context sensitive help based on the particular entity being displayed. If no entity-specific help file is available for the user then the standard Aptify Shell.Aptify Help file will be used to display help to the user. Override this method in sub-classes to change the method for displaying help.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetDefaultHelpObject (inherited from AptifyControlBase) | This method returns the default help object file in the Aptify Object repository to be used in the event that no entity-specific file exists
GetEntityFieldSpecificHelpObject (inherited from AptifyDataFieldControlBase) | This method returns the Aptify Object Repository Object location for the help file that is specific to this entity field.
GetEntityFieldSpecificHelpTopicURL (inherited from AptifyDataFieldControlBase) | This method returns the Topic URL location within the help file that is specific to this entity field.
GetEntitySpecificHelpObject (inherited from AptifyControlBase) | This method returns the Aptify Object Repository Object location for the help file that is specific to this entity.
GetEntitySpecificHelpTopicURL (inherited from AptifyControlBase) | This method returns the Topic URL location within the help file that is specific to this entity.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseValueChanged (inherited from AptifyControlBase) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from AptifyDataFieldControlBase) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from AptifyTextBox) | Overloaded.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetExtendedType (inherited from AptifyTextBox) |
SetUserCredential (inherited from AptifyControlBase) |
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
TransferDataToObject (inherited from AptifyDataFieldControlBase) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
AptifyControlBaseValueChangedHandler (inherited from AptifyDataFieldControlBase) |
ConfigHelp (inherited from AptifyDataFieldControlBase) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
CreateMessageObjects (inherited from AptifyDataFieldControlBase) |
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
DoFormComponentConfig | Configures the Component.
DoFormComponentConfigRunMode (inherited from AptifyTextBox) |
DoPostal_Leave (inherited from AptifyDataFieldControlBase) |
Finalize (inherited from AptifyControlBase) |
FormatValue (inherited from AptifyTextBox) | Formats the Value of the control using the FormatString. If FormatString is blank, the default formatting for the data type will be used. Example: The Default Format String for money is Currency which uses the client's regional format settings for Currency.
FormComponentConfig (inherited from AptifyControlBase) |
FormComponentHide (inherited from AptifyControlBase) |
FormComponentShow (inherited from AptifyControlBase) | Overloaded.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
LookupPostalInfo (inherited from AptifyDataFieldControlBase) |
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from AptifyTextBox) |
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from AptifyTextBox) |
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from AptifyTextBox) |
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RequiredGECheck (inherited from AptifyControlBase) |
RequiredPropertiesCheck (inherited from AptifyControlBase) |
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlMetaData (inherited from AptifyTextBox) |
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetSecurity (inherited from AptifyDataFieldControlBase) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTextAlignByDataType (inherited from AptifyTextBox) | Sets the TextAlign property based on the Data Type of the DataField. Numeric data types are right-aligned. All others are left-aligned. Note: This behavior is currently disabled.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetValueFromGe (inherited from AptifyDataFieldControlBase) |
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

PersonsSpecialFieldTextBox Class | Aptify.Applications.Persons Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

PersonsSpecialFieldTextBox.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

PersonsSpecialFieldTextBox Class | Aptify.Applications.Persons Namespace


PersonsSpecialFieldTextBox.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

PersonsSpecialFieldTextBox Class | Aptify.Applications.Persons Namespace | PersonsSpecialFieldTextBox.Dispose Overload List


PersonsSpecialFieldTextBox.DoFormComponentConfig Method

Configures the Component.

protected override void DoFormComponentConfig(
AptifyFormTemplateContext FormTemplateContext
);

Parameters

FormTemplateContext

Remarks

Forces the GE to load the root company member type as a field, RootCompanyMemberType and then assigns the data field.

See Also

PersonsSpecialFieldTextBox Class | Aptify.Applications.Persons Namespace


SelectSingleCommitteeTermForm Class

Allows a user to select a single Committee Term that will have a Member added to it.

For a list of all members of this type, see SelectSingleCommitteeTermForm Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
SelectSingleCommitteeTermForm

public class SelectSingleCommitteeTermForm : Form

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Persons

Assembly: AptifyPersonsGUI (in AptifyPersonsGUI.dll)

See Also

SelectSingleCommitteeTermForm Members | Aptify.Applications.Persons Namespace


SelectSingleCommitteeTermForm Members

SelectSingleCommitteeTermForm overview

Public Instance Constructors

SelectSingleCommitteeTermForm Constructor Initializes a new instance of the SelectSingleCommitteeTermForm class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
TermID | Gets the currently selected TermID
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TermSelected | Raised when a Term is selected.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTermSelected |
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

SelectSingleCommitteeTermForm Class | Aptify.Applications.Persons Namespace


SelectSingleCommitteeTermForm Constructor

Initializes a new instance of the SelectSingleCommitteeTermForm class.

public SelectSingleCommitteeTermForm();

See Also

SelectSingleCommitteeTermForm Class | Aptify.Applications.Persons Namespace


SelectSingleCommitteeTermForm Properties

The properties of the SelectSingleCommitteeTermForm class are listed below. For a complete list of SelectSingleCommitteeTermForm class members, see the SelectSingleCommitteeTermForm Members topic.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
TermID | Gets the currently selected TermID
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

SelectSingleCommitteeTermForm Class | Aptify.Applications.Persons Namespace


TermID Property

Aptify 5.0 Software Development Kit (SDK)

SelectSingleCommitteeTermForm.TermID Property

Gets the currently selected TermID

public Int64 TermID {get;}

Property Value

Remarks

See Also

SelectSingleCommitteeTermForm Class | Aptify.Applications.Persons Namespace


SelectSingleCommitteeTermForm Methods

The methods of the SelectSingleCommitteeTermForm class are listed below. For a complete list of SelectSingleCommitteeTermForm class members, see the SelectSingleCommitteeTermForm Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTermSelected |
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

SelectSingleCommitteeTermForm Class | Aptify.Applications.Persons Namespace


SelectSingleCommitteeTermForm.ApplySkin Method

protected virtual void ApplySkin();

See Also

SelectSingleCommitteeTermForm Class | Aptify.Applications.Persons Namespace


SelectSingleCommitteeTermForm.Config Method

public void Config(
UserCredentials UserCredential
);

See Also

SelectSingleCommitteeTermForm Class | Aptify.Applications.Persons Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

SelectSingleCommitteeTermForm.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

SelectSingleCommitteeTermForm Class | Aptify.Applications.Persons Namespace


SelectSingleCommitteeTermForm.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

SelectSingleCommitteeTermForm Class | Aptify.Applications.Persons Namespace | SelectSingleCommitteeTermForm.Dispose Overload List


SelectSingleCommitteeTermForm.OnClosing Method

protected override void OnClosing(
CancelEventArgs e
);

See Also

SelectSingleCommitteeTermForm Class | Aptify.Applications.Persons Namespace


SelectSingleCommitteeTermForm.OnTermSelected Method

protected void OnTermSelected(
Int64 ID
);

See Also

SelectSingleCommitteeTermForm Class | Aptify.Applications.Persons Namespace


SelectSingleCommitteeTermForm Events

The events of the SelectSingleCommitteeTermForm class are listed below. For a complete list of SelectSingleCommitteeTermForm class members, see the SelectSingleCommitteeTermForm Members topic.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TermSelected | Raised when a Term is selected.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

SelectSingleCommitteeTermForm Class | Aptify.Applications.Persons Namespace


SelectSingleCommitteeTermForm.Action<T> Event

Raised when a Term is selected.

public event Action<T> TermSelected;

Remarks

See Also

SelectSingleCommitteeTermForm Class | Aptify.Applications.Persons Namespace


SyncContact Class

This class is responsible for synchronizing a specific Outlook Contact with a specific Aptify Person record.

For a list of all members of this type, see SyncContact Members.

System.Object
SyncContact

public class SyncContact : IProcessComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Persons

Assembly: AptifyPersonsOutlookSynchronization (in AptifyPersonsOutlookSynchronization.dll)

See Also

SyncContact Members | Aptify.Applications.Persons Namespace


SyncContact Members

SyncContact overview

Public Instance Constructors

SyncContact Constructor Initializes a new instance of the SyncContact class.

Public Instance Properties

PhoneMaxLength
Properties

Public Instance Methods

Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ParseAddress | This method is responsible for parsing the specified full address into its component parts, returning Address Line 1 through 4 as appropriate. Override this method to alter the parsing logic for contact addresses.
ParseTelephoneNumber | This method is responsible for parsing the phone number provided through the FullPhone parameter into its component parts. Override this method in a sub-class to alter the base logic for parsing phone numbers.
Run | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FindContactByEntryID | This method is responsible for looking up an Outlook Contact record/object based on the specified EntryID and StoreID parameters
FindContactByScan | This method is responsible for scanning all of the contacts within the specified Outlook Folder and returning a matching Person ID if the Person ID value provided matches the CustomerID field in MS Outlook.
FindCreateContact | This method will attempt to find a specified outlook contact in the Outlook application, first by doing a lookup, second by attempting to do a scan operation, and lastly, by creating a new contact in Outlook if required.
GetMinRecordID | This method is responsible for returning the lowest value ID number from the specified View name, where the View Name is assumed to be a valid SQL View in the database.
MapCompany | This method is responsible for finding a company record that matches the Person's company information and if one is not found, to create a new company record that matches the Person. In either case, the CompanyID field in the Person GE Object should be set.
MapContactToPerson | This method is responsible for mapping data from the PersonGE object from the Aptify database into the Outlook Contact object.
MapPersonToContact | This method is responsible for setting up the Person GE object to contain the same values as the Outlook component, mapping those values from Outlook's contact object into the Person GE fields
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SyncContactToPerson | This method is responsible for updating the Aptify database from the contact record stored in Microsoft Outlook.
SyncPersonToContact | This method is responsible for synchronizing an item in Microsoft Outlook from the data within a specified Person record in the Aptify database.

See Also

SyncContact Class | Aptify.Applications.Persons Namespace


SyncContact Constructor

Initializes a new instance of the SyncContact class.

public SyncContact();

See Also

SyncContact Class | Aptify.Applications.Persons Namespace


SyncContact Properties

The properties of the SyncContact class are listed below. For a complete list of SyncContact class members, see the SyncContact Members topic.

Public Instance Properties

PhoneMaxLength
Properties

See Also

SyncContact Class | Aptify.Applications.Persons Namespace


PhoneMaxLength Property

Aptify 5.0 Software Development Kit (SDK)

SyncContact.PhoneMaxLength Property

public virtual Int32 PhoneMaxLength {get;}

See Also

SyncContact Class | Aptify.Applications.Persons Namespace


Properties Property

Aptify 5.0 Software Development Kit (SDK)

SyncContact.Properties Property

public AptifyProperties Properties {get;}

Implements

IProcessComponent.

See Also

SyncContact Class | Aptify.Applications.Persons Namespace


SyncContact Methods

The methods of the SyncContact class are listed below. For a complete list of SyncContact class members, see the SyncContact Members topic.

Public Instance Methods

Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ParseAddress | This method is responsible for parsing the specified full address into its component parts, returning Address Line 1 through 4 as appropriate. Override this method to alter the parsing logic for contact addresses.
ParseTelephoneNumber | This method is responsible for parsing the phone number provided through the FullPhone parameter into its component parts. Override this method in a sub-class to alter the base logic for parsing phone numbers.
Run | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FindContactByEntryID | This method is responsible for looking up an Outlook Contact record/object based on the specified EntryID and StoreID parameters
FindContactByScan | This method is responsible for scanning all of the contacts within the specified Outlook Folder and returning a matching Person ID if the Person ID value provided matches the CustomerID field in MS Outlook.
FindCreateContact | This method will attempt to find a specified outlook contact in the Outlook application, first by doing a lookup, second by attempting to do a scan operation, and lastly, by creating a new contact in Outlook if required.
GetMinRecordID | This method is responsible for returning the lowest value ID number from the specified View name, where the View Name is assumed to be a valid SQL View in the database.
MapCompany | This method is responsible for finding a company record that matches the Person's company information and if one is not found, to create a new company record that matches the Person. In either case, the CompanyID field in the Person GE Object should be set.
MapContactToPerson | This method is responsible for mapping data from the PersonGE object from the Aptify database into the Outlook Contact object.
MapPersonToContact | This method is responsible for setting up the Person GE object to contain the same values as the Outlook component, mapping those values from Outlook's contact object into the Person GE fields
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SyncContactToPerson | This method is responsible for updating the Aptify database from the contact record stored in Microsoft Outlook.
SyncPersonToContact | This method is responsible for synchronizing an item in Microsoft Outlook from the data within a specified Person record in the Aptify database.

See Also

SyncContact Class | Aptify.Applications.Persons Namespace


SyncContact.Config Method

public void Config(
AptifyApplication ApplicationObject
);

Implements

IProcessComponent.

See Also

SyncContact Class | Aptify.Applications.Persons Namespace


SyncContact.FindContactByEntryID Method

This method is responsible for looking up an Outlook Contact record/object based on the specified EntryID and StoreID parameters

protected virtual ContactItem FindContactByEntryID(
String EntryID,
String StoreID
);

Parameters

EntryID
StoreID

Return Value

Remarks

See Also

SyncContact Class | Aptify.Applications.Persons Namespace


SyncContact.FindContactByScan Method

This method is responsible for scanning all of the contacts within the specified Outlook Folder and returning a matching Person ID if the Person ID value provided matches the CustomerID field in MS Outlook.

protected virtual ContactItem FindContactByScan(
Int64 PersonID,
MAPIFolder OutlookFolder
);

Parameters

PersonID
OutlookFolder

Return Value

Remarks

See Also

SyncContact Class | Aptify.Applications.Persons Namespace


SyncContact.FindCreateContact Method

This method will attempt to find a specified outlook contact in the Outlook application, first by doing a lookup, second by attempting to do a scan operation, and lastly, by creating a new contact in Outlook if required.

protected virtual ContactItem FindCreateContact(
String EntryID,
String StoreID,
Int64 PersonID,
MAPIFolder OutlookFolder
);

Parameters

EntryID
StoreID
PersonID
OutlookFolder

Return Value

Remarks

See Also

SyncContact Class | Aptify.Applications.Persons Namespace


SyncContact.GetMinRecordID Method

This method is responsible for returning the lowest value ID number from the specified View name, where the View Name is assumed to be a valid SQL View in the database.

protected virtual long GetMinRecordID(
String ViewName
);

Parameters

ViewName

Return Value

Remarks

See Also

SyncContact Class | Aptify.Applications.Persons Namespace


SyncContact.MapCompany Method

This method is responsible for finding a company record that matches the Person's company information and if one is not found, to create a new company record that matches the Person. In either case, the CompanyID field in the Person GE Object should be set.

protected virtual bool MapCompany(
AptifyGenericEntityBase PersonGE,
ContactItem Contact
);

Parameters

PersonGE
Contact

Return Value

Remarks

See Also

SyncContact Class | Aptify.Applications.Persons Namespace


SyncContact.MapContactToPerson Method

This method is responsible for mapping data from the PersonGE object from the Aptify database into the Outlook Contact object.

protected virtual bool MapContactToPerson(
ContactItem Contact,
AptifyGenericEntityBase PersonGE
);

Parameters

Contact
PersonGE

Return Value

Remarks

See Also

SyncContact Class | Aptify.Applications.Persons Namespace


SyncContact.MapPersonToContact Method

This method is responsible for setting up the Person GE object to contain the same values as the Outlook component, mapping those values from Outlook's contact object into the Person GE fields

protected virtual bool MapPersonToContact(
AptifyGenericEntityBase PersonGE,
ContactItem Contact
);

Parameters

PersonGE
Contact

Return Value

Remarks

See Also

SyncContact Class | Aptify.Applications.Persons Namespace


SyncContact.ParseAddress Method

This method is responsible for parsing the specified full address into its component parts, returning Address Line 1 through 4 as appropriate. Override this method to alter the parsing logic for contact addresses.

public virtual bool ParseAddress(
String FullAddress,
ref String& AddressLine1,
ref String& AddressLine2,
ref String& AddressLine3,
ref String& AddressLine4
);

Parameters

FullAddress
AddressLine1
AddressLine2
AddressLine3
AddressLine4

Return Value

True if succesful, False otherwise

Remarks

See Also

SyncContact Class | Aptify.Applications.Persons Namespace


SyncContact.ParseTelephoneNumber Method

This method is responsible for parsing the phone number provided through the FullPhone parameter into its component parts. Override this method in a sub-class to alter the base logic for parsing phone numbers.

public virtual bool ParseTelephoneNumber(
String FullPhone,
ref String& CountryCode,
ref String& AreaCode,
ref String& Phone,
ref String& PhoneExtension
);

Parameters

FullPhone
CountryCode
AreaCode
Phone
PhoneExtension

Return Value

Remarks

See Also

SyncContact Class | Aptify.Applications.Persons Namespace


Run Method

Aptify 5.0 Software Development Kit (SDK)

SyncContact.Run Method

Overload List

public string Run();

public string Run(ref String&);

See Also

SyncContact Class | Aptify.Applications.Persons Namespace


SyncContact.Run Method ()

public string Run();

Implements

IProcessComponent.

See Also

SyncContact Class | Aptify.Applications.Persons Namespace | SyncContact.Run Overload List


SyncContact.Run Method (String&)

public string Run(
ref String& ErrorString
);

See Also

SyncContact Class | Aptify.Applications.Persons Namespace | SyncContact.Run Overload List


SyncContact.SyncContactToPerson Method

This method is responsible for updating the Aptify database from the contact record stored in Microsoft Outlook.

protected virtual bool SyncContactToPerson(
String OutlookContactID,
ref String& ErrorString
);

Return Value

Remarks

See Also

SyncContact Class | Aptify.Applications.Persons Namespace


SyncContact.SyncPersonToContact Method

This method is responsible for synchronizing an item in Microsoft Outlook from the data within a specified Person record in the Aptify database.

protected virtual bool SyncPersonToContact(
Int64 PersonID,
ref String& ErrorString
);

Return Value

Remarks

See Also

SyncContact Class | Aptify.Applications.Persons Namespace


SyncFolder Class

This class implements IProcessComponent and handles the process of synchronizing a specific Outlook Folder with the Aptify Persons entity.

For a list of all members of this type, see SyncFolder Members.

System.Object
SyncFolder

public class SyncFolder : IProcessComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Persons

Assembly: AptifyPersonsOutlookSynchronization (in AptifyPersonsOutlookSynchronization.dll)

See Also

SyncFolder Members | Aptify.Applications.Persons Namespace


SyncFolder Members

SyncFolder overview

Public Instance Constructors

SyncFolder Constructor Initializes a new instance of the SyncFolder class.

Public Instance Properties

Properties

Public Instance Methods

Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run | Overloaded. Runs the operation, returns a result code, and any errors via the OUT Parameter, ErrorString
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SyncFolder Class | Aptify.Applications.Persons Namespace


SyncFolder Constructor

Initializes a new instance of the SyncFolder class.

public SyncFolder();

See Also

SyncFolder Class | Aptify.Applications.Persons Namespace


SyncFolder Properties

The properties of the SyncFolder class are listed below. For a complete list of SyncFolder class members, see the SyncFolder Members topic.

Public Instance Properties

Properties

See Also

SyncFolder Class | Aptify.Applications.Persons Namespace


Properties Property

Aptify 5.0 Software Development Kit (SDK)

SyncFolder.Properties Property

public AptifyProperties Properties {get;}

Implements

IProcessComponent.

See Also

SyncFolder Class | Aptify.Applications.Persons Namespace


SyncFolder Methods

The methods of the SyncFolder class are listed below. For a complete list of SyncFolder class members, see the SyncFolder Members topic.

Public Instance Methods

Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run | Overloaded. Runs the operation, returns a result code, and any errors via the OUT Parameter, ErrorString
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SyncFolder Class | Aptify.Applications.Persons Namespace


SyncFolder.Config Method

public void Config(
AptifyApplication ApplicationObject
);

Implements

IProcessComponent.

See Also

SyncFolder Class | Aptify.Applications.Persons Namespace


Run Method

Aptify 5.0 Software Development Kit (SDK)

SyncFolder.Run Method

Overload List

public string Run();

Runs the operation, returns a result code, and any errors via the OUT Parameter, ErrorString

public string Run(ref String&);

See Also

SyncFolder Class | Aptify.Applications.Persons Namespace


SyncFolder.Run Method ()

public string Run();

Implements

IProcessComponent.

See Also

SyncFolder Class | Aptify.Applications.Persons Namespace | SyncFolder.Run Overload List


SyncFolder.Run Method (String&)

Runs the operation, returns a result code, and any errors via the OUT Parameter, ErrorString

public string Run(
ref String& ErrorString
);

Parameters

ErrorString

Return Value

Remarks

See Also

SyncFolder Class | Aptify.Applications.Persons Namespace | SyncFolder.Run Overload List


SyncView Class

This class is responsible for synchronizing a specific view of Person records with a specified Outlook Folder.

For a list of all members of this type, see SyncView Members.

System.Object
SyncView

public class SyncView : IProcessComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Persons

Assembly: AptifyPersonsOutlookSynchronization (in AptifyPersonsOutlookSynchronization.dll)

See Also

SyncView Members | Aptify.Applications.Persons Namespace


SyncView Members

SyncView overview

Public Instance Constructors

SyncView Constructor Initializes a new instance of the SyncView class.

Public Instance Properties

Properties

Public Instance Methods

Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SyncView Class | Aptify.Applications.Persons Namespace


SyncView Constructor

Initializes a new instance of the SyncView class.

public SyncView();

See Also

SyncView Class | Aptify.Applications.Persons Namespace


SyncView Properties

The properties of the SyncView class are listed below. For a complete list of SyncView class members, see the SyncView Members topic.

Public Instance Properties

Properties

See Also

SyncView Class | Aptify.Applications.Persons Namespace


Properties Property

Aptify 5.0 Software Development Kit (SDK)

SyncView.Properties Property

public AptifyProperties Properties {get;}

Implements

IProcessComponent.

See Also

SyncView Class | Aptify.Applications.Persons Namespace


SyncView Methods

The methods of the SyncView class are listed below. For a complete list of SyncView class members, see the SyncView Members topic.

Public Instance Methods

Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SyncView Class | Aptify.Applications.Persons Namespace


SyncView.Config Method

public void Config(
AptifyApplication ApplicationObject
);

Implements

IProcessComponent.

See Also

SyncView Class | Aptify.Applications.Persons Namespace


SyncView.Run Method

public string Run();

Implements

IProcessComponent.

See Also

SyncView Class | Aptify.Applications.Persons Namespace


Aptify.Applications.Persons.Committees

Aptify 5.0 Software Development Kit (SDK)

Aptify.Applications.Persons.Committees Namespace

This namespace defines the Add Person to Committees wizard, which can be launched from the Persons service.

Namespace hierarchy

Classes

Class | Description
AddPersonException | Thrown when there is a problem adding a person to a Committee.
AddPersonToCommittees | This class provides both type-specific methods and IProcessComponent methods for adding person record(s) to one or more commmittee terms. This object is used by the Add Person to Committees GUI for both adding single and multiple individuals to a committee record. This object can be used programatically via the type-specific methods as well as through process pipeline through the IProcessComponent support. See the Run() method on this class for details on the Input Properties and Output Properties provided through the Process Component members.
AddPersonToCommitteesUI | This class is used to implement the entity action (wizard) that will allow a user to add one or more people from a view to one or more committee terms in one step. This class is also used from the Add To Committees Button that is part of the Persons User Interface form for the Committees tab of the Persons form.
CommitteeAddResultsForm | Used to display result from a multiple committee add.
CommitteeSelection | Instantiates and displays a version of CommitteeSelectionForm.
CommitteeTermMemberInfo | This class is used to encapsulate information about a given committee term member's attributes.
CommitteeTermNomineeInfo | This class is used to encapsulate information about a given committee term nominee's attributes.

Interfaces

Interface | Description
IAddPersonsToCommittees | Interface used to Add Persons to Committees.

Delegates

Delegate | Description
AddPersonToCommittees.StatusUpdateEventHandler |


AddPersonException Class

Thrown when there is a problem adding a person to a Committee.

For a list of all members of this type, see AddPersonException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
AddPersonException

public class AddPersonException : BaseApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Persons.Committees

Assembly: AddPersonToCommitteesUI (in AddPersonToCommitteesUI.dll)

See Also

AddPersonException Members | Aptify.Applications.Persons.Committees Namespace


AddPersonException Members

AddPersonException overview

Public Instance Constructors

AddPersonException Overloaded. Initializes a new instance of the AddPersonException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from BaseApplicationException) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AddPersonException Class | Aptify.Applications.Persons.Committees Namespace


AddPersonException Constructor

Initializes a new instance of the AddPersonException class.

Overload List

Initializes a new instance of the AddPersonException class.

public AddPersonException();

public AddPersonException(String);

public AddPersonException(String,Exception);

See Also

AddPersonException Class | Aptify.Applications.Persons.Committees Namespace


AddPersonException Constructor ()

Initializes a new instance of the AddPersonException class.

public AddPersonException();

See Also

AddPersonException Class | Aptify.Applications.Persons.Committees Namespace | AddPersonException Constructor Overload List


AddPersonException Constructor (String)

public AddPersonException(
String Message
);

See Also

AddPersonException Class | Aptify.Applications.Persons.Committees Namespace | AddPersonException Constructor Overload List


AddPersonException Constructor (String, Exception)

public AddPersonException(
String Message,
Exception InnerException
);

See Also

AddPersonException Class | Aptify.Applications.Persons.Committees Namespace | AddPersonException Constructor Overload List


AddPersonToCommittees Class

This class provides both type-specific methods and IProcessComponent methods for adding person record(s) to one or more commmittee terms. This object is used by the Add Person to Committees GUI for both adding single and multiple individuals to a committee record. This object can be used programatically via the type-specific methods as well as through process pipeline through the IProcessComponent support. See the Run() method on this class for details on the Input Properties and Output Properties provided through the Process Component members.

For a list of all members of this type, see AddPersonToCommittees Members.

System.Object
AddPersonToCommittees

public class AddPersonToCommittees : IProcessComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Persons.Committees

Assembly: AddPersonToCommittees (in AddPersonToCommittees.dll)

See Also

AddPersonToCommittees Members | Aptify.Applications.Persons.Committees Namespace


AddPersonToCommittees Members

AddPersonToCommittees overview

Public Instance Constructors

AddPersonToCommittees Constructor Initializes a new instance of the AddPersonToCommittees class.

Public Instance Properties

Application |
DataAction |
Properties | Aptify Properties Collection - only used when the IProcessComponent interface is utilized

Public Instance Methods

AddAsNomineeToCommitteeTerm | Overloaded. This overload will add multiple individuals to a specified committee term based on a comma delimited list of person id values provided in the PersonIDs parameter
AddPersonsAsNomineeToCommitteeTerms | Overloaded.
AddPersonsToCommitteeTerm | Overloaded. This overload will add multiple individuals to a specified committee term based on a comma delimited list of person id values provided in the PersonIDs parameter
AddPersonsToCommitteeTerms | Overloaded. This method will add the specified list of persons to the list of committee terms and will set all of the new records to the Rank and VotingMember attributes specified in the two parameters provided. If it is necessary to control different Rank and VotingMember settings on a per-committee term basis, use one of the overloads that allows you to pass in a CommitteeTermMemberInfo class where you can control those settings on a per-term basis.
AddPersonToCommitteeTerm | This method will add the specified individual Person ID to the Committee Term with the options specified in the TermInfo class. The results text will provide user-oriented feedback as to the results of the operation.
Config | This method must be called before any other member of this class is accessed
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCommitteeTermName | This method will return the record name of a committee term record based on the provided Committee Term ID value.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run | This method provides the IProcessComponent inteface Run() capability and handles the process of adding Person record(s) to Committee Term(s). The following Input Properties are supported PersonIDList (Required) - Comma Delimited List of Person Record ID values that are to be operated onCommitteeTermIDList (Required) - Comma Delimited List of Committee Term ID values that people are to be added to from the PersonIDList propertyRank - (Optional, Defaults to 1) - Integer Value - This rank will be applied to all new records added to the Committee Terms for the individuals listed in the PersonIDList propertyVotingMember - (Optional, Defaults to 0, Possible Values of 0 and 1) - Integer Value - This voting member status (0-Non Voting, 1-Voting) will be applied to all new records added to the Committee Terms for the individuals listed in the PersonIDList propertyAllowDuplicates - (Optional, Defaults to 0, Possible Values of 0 and 1) - Integer Value - This input property determines if duplicate member records are allowed in a given committee term. If this property is set to 0, duplicates will not be allowed. If it is set to 1, duplicates will be allowed The following Output Properties are supported Results - Text String - Indicates the Results of the Operation in a user-readable format The following Result Codes are posssible SUCCESSFAILED
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

StatusUpdate This event is raised whenever a process completes an iteration in a long running process such as the AddPersonsToCommitteeTerms() method. This event allows the consumer of this object to cancel the operation by setting the Cancel OUT parameter to True.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseStatusUpdate | This method is provided to allow sub-classes to Raise the Base-Class StatusUpdate event when required.

See Also

AddPersonToCommittees Class | Aptify.Applications.Persons.Committees Namespace


AddPersonToCommittees Constructor

Initializes a new instance of the AddPersonToCommittees class.

public AddPersonToCommittees();

See Also

AddPersonToCommittees Class | Aptify.Applications.Persons.Committees Namespace


AddPersonToCommittees Properties

The properties of the AddPersonToCommittees class are listed below. For a complete list of AddPersonToCommittees class members, see the AddPersonToCommittees Members topic.

Public Instance Properties

Application |
DataAction |
Properties | Aptify Properties Collection - only used when the IProcessComponent interface is utilized

See Also

AddPersonToCommittees Class | Aptify.Applications.Persons.Committees Namespace


Application Property

Aptify 5.0 Software Development Kit (SDK)

AddPersonToCommittees.Application Property

public virtual AptifyApplication Application {get;}

See Also

AddPersonToCommittees Class | Aptify.Applications.Persons.Committees Namespace


DataAction Property

Aptify 5.0 Software Development Kit (SDK)

AddPersonToCommittees.DataAction Property

public virtual DataAction DataAction {get;}

See Also

AddPersonToCommittees Class | Aptify.Applications.Persons.Committees Namespace


Properties Property

Aptify 5.0 Software Development Kit (SDK)

AddPersonToCommittees.Properties Property

Aptify Properties Collection - only used when the IProcessComponent interface is utilized

public virtual AptifyProperties Properties {get;}

Property Value

Implements

IProcessComponent.

Remarks

See Also

AddPersonToCommittees Class | Aptify.Applications.Persons.Committees Namespace


AddPersonToCommittees Methods

The methods of the AddPersonToCommittees class are listed below. For a complete list of AddPersonToCommittees class members, see the AddPersonToCommittees Members topic.

Public Instance Methods

AddAsNomineeToCommitteeTerm | Overloaded. This overload will add multiple individuals to a specified committee term based on a comma delimited list of person id values provided in the PersonIDs parameter
AddPersonsAsNomineeToCommitteeTerms | Overloaded.
AddPersonsToCommitteeTerm | Overloaded. This overload will add multiple individuals to a specified committee term based on a comma delimited list of person id values provided in the PersonIDs parameter
AddPersonsToCommitteeTerms | Overloaded. This method will add the specified list of persons to the list of committee terms and will set all of the new records to the Rank and VotingMember attributes specified in the two parameters provided. If it is necessary to control different Rank and VotingMember settings on a per-committee term basis, use one of the overloads that allows you to pass in a CommitteeTermMemberInfo class where you can control those settings on a per-term basis.
AddPersonToCommitteeTerm | This method will add the specified individual Person ID to the Committee Term with the options specified in the TermInfo class. The results text will provide user-oriented feedback as to the results of the operation.
Config | This method must be called before any other member of this class is accessed
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCommitteeTermName | This method will return the record name of a committee term record based on the provided Committee Term ID value.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run | This method provides the IProcessComponent inteface Run() capability and handles the process of adding Person record(s) to Committee Term(s). The following Input Properties are supported PersonIDList (Required) - Comma Delimited List of Person Record ID values that are to be operated onCommitteeTermIDList (Required) - Comma Delimited List of Committee Term ID values that people are to be added to from the PersonIDList propertyRank - (Optional, Defaults to 1) - Integer Value - This rank will be applied to all new records added to the Committee Terms for the individuals listed in the PersonIDList propertyVotingMember - (Optional, Defaults to 0, Possible Values of 0 and 1) - Integer Value - This voting member status (0-Non Voting, 1-Voting) will be applied to all new records added to the Committee Terms for the individuals listed in the PersonIDList propertyAllowDuplicates - (Optional, Defaults to 0, Possible Values of 0 and 1) - Integer Value - This input property determines if duplicate member records are allowed in a given committee term. If this property is set to 0, duplicates will not be allowed. If it is set to 1, duplicates will be allowed The following Output Properties are supported Results - Text String - Indicates the Results of the Operation in a user-readable format The following Result Codes are posssible SUCCESSFAILED
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseStatusUpdate | This method is provided to allow sub-classes to Raise the Base-Class StatusUpdate event when required.

See Also

AddPersonToCommittees Class | Aptify.Applications.Persons.Committees Namespace


AddAsNomineeToCommitteeTerm Method

Aptify 5.0 Software Development Kit (SDK)

AddPersonToCommittees.AddAsNomineeToCommitteeTerm Method

This method will add the specified individual Person ID to the Committee Term with the options specified in the TermInfo class. The results text will provide user-oriented feedback as to the results of the operation.

Overload List

This method will add the specified individual Person ID to the Committee Term with the options specified in the TermInfo class. The results text will provide user-oriented feedback as to the results of the operation.

public virtual bool AddAsNomineeToCommitteeTerm(CommitteeTermNomineeInfo,Int64,Boolean,ref String&);

This overload will add multiple individuals to a specified committee term based on a comma delimited list of person id values provided in the PersonIDs parameter

public virtual bool AddAsNomineeToCommitteeTerm(CommitteeTermNomineeInfo,String,Boolean,ref String&);

See Also

AddPersonToCommittees Class | Aptify.Applications.Persons.Committees Namespace


AddPersonToCommittees.AddAsNomineeToCommitteeTerm Method (CommitteeTermNomineeInfo, Int64, Boolean, String&)

This method will add the specified individual Person ID to the Committee Term with the options specified in the TermInfo class. The results text will provide user-oriented feedback as to the results of the operation.

public virtual bool AddAsNomineeToCommitteeTerm(
CommitteeTermNomineeInfo TermInfo,
Int64 PersonID,
Boolean AllowDuplicates,
ref String& Results
);

Parameters

TermInfo
Committee Term information
PersonID
The ID of the Person record to be added to the specified committee term as a Nominee
AllowDuplicates
If set to True, this method will allow individuals (nominees) to be added to the same committee term more than once
Results

Return Value

True if the operation was a success, False otherwise

Remarks

See Also

AddPersonToCommittees Class | Aptify.Applications.Persons.Committees Namespace | AddPersonToCommittees.AddAsNomineeToCommitteeTerm Overload List


AddPersonToCommittees.AddAsNomineeToCommitteeTerm Method (CommitteeTermNomineeInfo, String, Boolean, String&)

This overload will add multiple individuals to a specified committee term based on a comma delimited list of person id values provided in the PersonIDs parameter

public virtual bool AddAsNomineeToCommitteeTerm(
CommitteeTermNomineeInfo TermInfo,
String PersonIDs,
Boolean AllowDuplicates,
ref String& Results
);

Parameters

TermInfo
PersonIDs
AllowDuplicates
Results

Return Value

Remarks

See Also

AddPersonToCommittees Class | Aptify.Applications.Persons.Committees Namespace | AddPersonToCommittees.AddAsNomineeToCommitteeTerm Overload List


AddPersonsAsNomineeToCommitteeTerms Method

Aptify 5.0 Software Development Kit (SDK)

AddPersonToCommittees.AddPersonsAsNomineeToCommitteeTerms Method

This overload will add multiple individuals to a specified committee term based on a List of Person Record ID values (long integers) in the PersonIDs parameter

Overload List

This overload will add multiple individuals to a specified committee term based on a List of Person Record ID values (long integers) in the PersonIDs parameter

public virtual bool AddPersonsAsNomineeToCommitteeTerms(CommitteeTermNomineeInfo,List<T>,Boolean,ref String&);

public virtual bool AddPersonsAsNomineeToCommitteeTerms(CommitteeTermNomineeInfo[],List<T>,Boolean,ref String&);

This overload will add multiple individuals to a specified committee term based on an array of Person Record ID values (long integers) provided by the PersonIDs parameter

public virtual bool AddPersonsAsNomineeToCommitteeTerms(CommitteeTermNomineeInfo[],Int64[],Boolean,ref String&);

public virtual bool AddPersonsAsNomineeToCommitteeTerms(CommitteeTermNomineeInfo[],String,Boolean,ref String&);

public virtual bool AddPersonsAsNomineeToCommitteeTerms(List<T>,List<T>,Boolean,ref String&);

public virtual bool AddPersonsAsNomineeToCommitteeTerms(List<T>,Int64[],Boolean,ref String&);

public virtual bool AddPersonsAsNomineeToCommitteeTerms(List<T>,String,Boolean,ref String&);

This method will add the specified list of persons to the list of committee terms and will set all of the new records to the Type and status attributes specified in the two parameters provided.

public virtual bool AddPersonsAsNomineeToCommitteeTerms(String,String,String,String,Boolean,ref String&);

See Also

AddPersonToCommittees Class | Aptify.Applications.Persons.Committees Namespace


AddPersonToCommittees.AddPersonsAsNomineeToCommitteeTerms Method (CommitteeTermNomineeInfo, List<T>, Boolean, String&)

This overload will add multiple individuals to a specified committee term based on a List of Person Record ID values (long integers) in the PersonIDs parameter

public virtual bool AddPersonsAsNomineeToCommitteeTerms(
CommitteeTermNomineeInfo TermInfo,
List<T> PersonIDs,
Boolean AllowDuplicates,
ref String& Results
);

Parameters

TermInfo
PersonIDs
AllowDuplicates
Results

Return Value

Remarks

See Also

AddPersonToCommittees Class | Aptify.Applications.Persons.Committees Namespace | AddPersonToCommittees.AddPersonsAsNomineeToCommitteeTerms Overload List


AddPersonToCommittees.AddPersonsAsNomineeToCommitteeTerms Method (CommitteeTermNomineeInfo[], List<T>, Boolean, String&)

public virtual bool AddPersonsAsNomineeToCommitteeTerms(
CommitteeTermNomineeInfo[] TermsInfo,
List<T> Persons,
Boolean AllowDuplicates,
ref String& Results
);

See Also

AddPersonToCommittees Class | Aptify.Applications.Persons.Committees Namespace | AddPersonToCommittees.AddPersonsAsNomineeToCommitteeTerms Overload List


AddPersonToCommittees.AddPersonsAsNomineeToCommitteeTerms Method (CommitteeTermNomineeInfo[], Int64[], Boolean, String&)

This overload will add multiple individuals to a specified committee term based on an array of Person Record ID values (long integers) provided by the PersonIDs parameter

public virtual bool AddPersonsAsNomineeToCommitteeTerms(
CommitteeTermNomineeInfo[] TermsNomineeInfo,
Int64[] Persons,
Boolean AllowDuplicates,
ref String& Results
);

Parameters

TermsNomineeInfo
Persons
AllowDuplicates
Results

Return Value

Remarks

See Also

AddPersonToCommittees Class | Aptify.Applications.Persons.Committees Namespace | AddPersonToCommittees.AddPersonsAsNomineeToCommitteeTerms Overload List


AddPersonToCommittees.AddPersonsAsNomineeToCommitteeTerms Method (CommitteeTermNomineeInfo[], String, Boolean, String&)

public virtual bool AddPersonsAsNomineeToCommitteeTerms(
CommitteeTermNomineeInfo[] TermsInfo,
String PersonIDList,
Boolean AllowDuplicates,
ref String& Results
);

See Also

AddPersonToCommittees Class | Aptify.Applications.Persons.Committees Namespace | AddPersonToCommittees.AddPersonsAsNomineeToCommitteeTerms Overload List


AddPersonToCommittees.AddPersonsAsNomineeToCommitteeTerms Method (List<T>, List<T>, Boolean, String&)

public virtual bool AddPersonsAsNomineeToCommitteeTerms(
List<T> TermsInfo,
List<T> Persons,
Boolean AllowDuplicates,
ref String& Results
);

See Also

AddPersonToCommittees Class | Aptify.Applications.Persons.Committees Namespace | AddPersonToCommittees.AddPersonsAsNomineeToCommitteeTerms Overload List


AddPersonToCommittees.AddPersonsAsNomineeToCommitteeTerms Method (List<T>, Int64[], Boolean, String&)

public virtual bool AddPersonsAsNomineeToCommitteeTerms(
List<T> TermsInfo,
Int64[] Persons,
Boolean AllowDuplicates,
ref String& Results
);

See Also

AddPersonToCommittees Class | Aptify.Applications.Persons.Committees Namespace | AddPersonToCommittees.AddPersonsAsNomineeToCommitteeTerms Overload List


AddPersonToCommittees.AddPersonsAsNomineeToCommitteeTerms Method (List<T>, String, Boolean, String&)

public virtual bool AddPersonsAsNomineeToCommitteeTerms(
List<T> TermsInfo,
String PersonIDList,
Boolean AllowDuplicates,
ref String& Results
);

See Also

AddPersonToCommittees Class | Aptify.Applications.Persons.Committees Namespace | AddPersonToCommittees.AddPersonsAsNomineeToCommitteeTerms Overload List


AddPersonToCommittees.AddPersonsAsNomineeToCommitteeTerms Method (String, String, String, String, Boolean, String&)

This method will add the specified list of persons to the list of committee terms and will set all of the new records to the Type and status attributes specified in the two parameters provided.

public virtual bool AddPersonsAsNomineeToCommitteeTerms(
String TermIDList,
String PersonIDList,
String Type,
String Status,
Boolean AllowDuplicates,
ref String& Results
);

Parameters

TermIDList
PersonIDList
Type
Type to use for all individuals being added to committees
Status
Nominee's status to use for all individuals being added to committees
AllowDuplicates
Results

Return Value

Remarks

See Also

AddPersonToCommittees Class | Aptify.Applications.Persons.Committees Namespace | AddPersonToCommittees.AddPersonsAsNomineeToCommitteeTerms Overload List


AddPersonsToCommitteeTerm Method

Aptify 5.0 Software Development Kit (SDK)

AddPersonToCommittees.AddPersonsToCommitteeTerm Method

This overload will add multiple individuals to a specified committee term based on a List of Person Record ID values (long integers) in the PersonIDs parameter

Overload List

This overload will add multiple individuals to a specified committee term based on a List of Person Record ID values (long integers) in the PersonIDs parameter

public virtual bool AddPersonsToCommitteeTerm(CommitteeTermMemberInfo,List<T>,Boolean,ref String&);

This overload will add multiple individuals to a specified committee term based on an array of Person Record ID values (long integers) provided by the PersonIDs parameter

public virtual bool AddPersonsToCommitteeTerm(CommitteeTermMemberInfo,Int64[],Boolean,ref String&);

This overload will add multiple individuals to a specified committee term based on a comma delimited list of person id values provided in the PersonIDs parameter

public virtual bool AddPersonsToCommitteeTerm(CommitteeTermMemberInfo,String,Boolean,ref String&);

This overload will add multiple individuals to a specified committee term based on an array of Person Record ID values (long integers) provided by the PersonIDs parameter

public virtual bool AddPersonsToCommitteeTerm(CommitteeTermNomineeInfo,Int64[],Boolean,ref String&);

See Also

AddPersonToCommittees Class | Aptify.Applications.Persons.Committees Namespace


AddPersonToCommittees.AddPersonsToCommitteeTerm Method (CommitteeTermMemberInfo, List<T>, Boolean, String&)

This overload will add multiple individuals to a specified committee term based on a List of Person Record ID values (long integers) in the PersonIDs parameter

public virtual bool AddPersonsToCommitteeTerm(
CommitteeTermMemberInfo TermInfo,
List<T> PersonIDs,
Boolean AllowDuplicates,
ref String& Results
);

Parameters

TermInfo
PersonIDs
AllowDuplicates
Results

Return Value

Remarks

See Also

AddPersonToCommittees Class | Aptify.Applications.Persons.Committees Namespace | AddPersonToCommittees.AddPersonsToCommitteeTerm Overload List


AddPersonToCommittees.AddPersonsToCommitteeTerm Method (CommitteeTermMemberInfo, Int64[], Boolean, String&)

This overload will add multiple individuals to a specified committee term based on an array of Person Record ID values (long integers) provided by the PersonIDs parameter

public virtual bool AddPersonsToCommitteeTerm(
CommitteeTermMemberInfo TermInfo,
Int64[] PersonIDs,
Boolean AllowDuplicates,
ref String& Results
);

Parameters

TermInfo
PersonIDs
AllowDuplicates
Results

Return Value

Remarks

See Also

AddPersonToCommittees Class | Aptify.Applications.Persons.Committees Namespace | AddPersonToCommittees.AddPersonsToCommitteeTerm Overload List


AddPersonToCommittees.AddPersonsToCommitteeTerm Method (CommitteeTermMemberInfo, String, Boolean, String&)

This overload will add multiple individuals to a specified committee term based on a comma delimited list of person id values provided in the PersonIDs parameter

public virtual bool AddPersonsToCommitteeTerm(
CommitteeTermMemberInfo TermInfo,
String PersonIDs,
Boolean AllowDuplicates,
ref String& Results
);

Parameters

TermInfo
PersonIDs
AllowDuplicates
Results

Return Value

Remarks

See Also

AddPersonToCommittees Class | Aptify.Applications.Persons.Committees Namespace | AddPersonToCommittees.AddPersonsToCommitteeTerm Overload List


AddPersonToCommittees.AddPersonsToCommitteeTerm Method (CommitteeTermNomineeInfo, Int64[], Boolean, String&)

This overload will add multiple individuals to a specified committee term based on an array of Person Record ID values (long integers) provided by the PersonIDs parameter

public virtual bool AddPersonsToCommitteeTerm(
CommitteeTermNomineeInfo TermInfo,
Int64[] PersonIDs,
Boolean AllowDuplicates,
ref String& Results
);

Parameters

TermInfo
PersonIDs
AllowDuplicates
Results

Return Value

Remarks

See Also

AddPersonToCommittees Class | Aptify.Applications.Persons.Committees Namespace | AddPersonToCommittees.AddPersonsToCommitteeTerm Overload List


AddPersonsToCommitteeTerms Method

Aptify 5.0 Software Development Kit (SDK)

AddPersonToCommittees.AddPersonsToCommitteeTerms Method

Overload List

public virtual bool AddPersonsToCommitteeTerms(CommitteeTermMemberInfo[],List<T>,Boolean,ref String&);

public virtual bool AddPersonsToCommitteeTerms(CommitteeTermMemberInfo[],Int64[],Boolean,ref String&);

public virtual bool AddPersonsToCommitteeTerms(CommitteeTermMemberInfo[],String,Boolean,ref String&);

public virtual bool AddPersonsToCommitteeTerms(List<T>,List<T>,Boolean,ref String&);

public virtual bool AddPersonsToCommitteeTerms(List<T>,Int64[],Boolean,ref String&);

public virtual bool AddPersonsToCommitteeTerms(List<T>,String,Boolean,ref String&);

This method will add the specified list of persons to the list of committee terms and will set all of the new records to the Rank and VotingMember attributes specified in the two parameters provided. If it is necessary to control different Rank and VotingMember settings on a per-committee term basis, use one of the overloads that allows you to pass in a CommitteeTermMemberInfo class where you can control those settings on a per-term basis.

public virtual bool AddPersonsToCommitteeTerms(String,String,Int32,Boolean,Boolean,ref String&);

See Also

AddPersonToCommittees Class | Aptify.Applications.Persons.Committees Namespace


AddPersonToCommittees.AddPersonsToCommitteeTerms Method (CommitteeTermMemberInfo[], List<T>, Boolean, String&)

public virtual bool AddPersonsToCommitteeTerms(
CommitteeTermMemberInfo[] TermsInfo,
List<T> Persons,
Boolean AllowDuplicates,
ref String& Results
);

See Also

AddPersonToCommittees Class | Aptify.Applications.Persons.Committees Namespace | AddPersonToCommittees.AddPersonsToCommitteeTerms Overload List


AddPersonToCommittees.AddPersonsToCommitteeTerms Method (CommitteeTermMemberInfo[], Int64[], Boolean, String&)

public virtual bool AddPersonsToCommitteeTerms(
CommitteeTermMemberInfo[] TermsInfo,
Int64[] Persons,
Boolean AllowDuplicates,
ref String& Results
);

See Also

AddPersonToCommittees Class | Aptify.Applications.Persons.Committees Namespace | AddPersonToCommittees.AddPersonsToCommitteeTerms Overload List


AddPersonToCommittees.AddPersonsToCommitteeTerms Method (CommitteeTermMemberInfo[], String, Boolean, String&)

public virtual bool AddPersonsToCommitteeTerms(
CommitteeTermMemberInfo[] TermsInfo,
String PersonIDList,
Boolean AllowDuplicates,
ref String& Results
);

See Also

AddPersonToCommittees Class | Aptify.Applications.Persons.Committees Namespace | AddPersonToCommittees.AddPersonsToCommitteeTerms Overload List


AddPersonToCommittees.AddPersonsToCommitteeTerms Method (List<T>, List<T>, Boolean, String&)

public virtual bool AddPersonsToCommitteeTerms(
List<T> TermsInfo,
List<T> Persons,
Boolean AllowDuplicates,
ref String& Results
);

See Also

AddPersonToCommittees Class | Aptify.Applications.Persons.Committees Namespace | AddPersonToCommittees.AddPersonsToCommitteeTerms Overload List


AddPersonToCommittees.AddPersonsToCommitteeTerms Method (List<T>, Int64[], Boolean, String&)

public virtual bool AddPersonsToCommitteeTerms(
List<T> TermsInfo,
Int64[] Persons,
Boolean AllowDuplicates,
ref String& Results
);

See Also

AddPersonToCommittees Class | Aptify.Applications.Persons.Committees Namespace | AddPersonToCommittees.AddPersonsToCommitteeTerms Overload List


AddPersonToCommittees.AddPersonsToCommitteeTerms Method (List<T>, String, Boolean, String&)

public virtual bool AddPersonsToCommitteeTerms(
List<T> TermsInfo,
String PersonIDList,
Boolean AllowDuplicates,
ref String& Results
);

See Also

AddPersonToCommittees Class | Aptify.Applications.Persons.Committees Namespace | AddPersonToCommittees.AddPersonsToCommitteeTerms Overload List


AddPersonToCommittees.AddPersonsToCommitteeTerms Method (String, String, Int32, Boolean, Boolean, String&)

This method will add the specified list of persons to the list of committee terms and will set all of the new records to the Rank and VotingMember attributes specified in the two parameters provided. If it is necessary to control different Rank and VotingMember settings on a per-committee term basis, use one of the overloads that allows you to pass in a CommitteeTermMemberInfo class where you can control those settings on a per-term basis.

public virtual bool AddPersonsToCommitteeTerms(
String TermIDList,
String PersonIDList,
Int32 Rank,
Boolean VotingMember,
Boolean AllowDuplicates,
ref String& Results
);

Parameters

TermIDList
PersonIDList
Rank
Rank to use for all individuals being added to committees
VotingMember
Voting Member status to use for all individuals being added to committees
AllowDuplicates
Results

Return Value

Remarks

See Also

AddPersonToCommittees Class | Aptify.Applications.Persons.Committees Namespace | AddPersonToCommittees.AddPersonsToCommitteeTerms Overload List


AddPersonToCommittees.AddPersonToCommitteeTerm Method

This method will add the specified individual Person ID to the Committee Term with the options specified in the TermInfo class. The results text will provide user-oriented feedback as to the results of the operation.

public virtual bool AddPersonToCommitteeTerm(
CommitteeTermMemberInfo TermInfo,
Int64 PersonID,
Boolean AllowDuplicates,
ref String& Results
);

Parameters

TermInfo
Committee Term information
PersonID
The ID of the Person record to be added to the specified committee term
AllowDuplicates
If set to True, this method will allow individuals to be added to the same committee term more than once
Results

Return Value

True if the operation was a success, False otherwise

Remarks

See Also

AddPersonToCommittees Class | Aptify.Applications.Persons.Committees Namespace


AddPersonToCommittees.Config Method

This method must be called before any other member of this class is accessed

public virtual void Config(
AptifyApplication ApplicationObject
);

Parameters

ApplicationObject

Implements

IProcessComponent.

Remarks

See Also

AddPersonToCommittees Class | Aptify.Applications.Persons.Committees Namespace


AddPersonToCommittees.GetCommitteeTermName Method

This method will return the record name of a committee term record based on the provided Committee Term ID value.

public virtual string GetCommitteeTermName(
Int64 CommitteeTermID
);

Parameters

CommitteeTermID

Return Value

Remarks

See Also

AddPersonToCommittees Class | Aptify.Applications.Persons.Committees Namespace


AddPersonToCommittees.RaiseStatusUpdate Method

This method is provided to allow sub-classes to Raise the Base-Class StatusUpdate event when required.

protected virtual void RaiseStatusUpdate(
String Message,
Int32 PercentComplete,
ref Boolean& Cancel
);

Parameters

Message
PercentComplete
Cancel

Remarks

See Also

AddPersonToCommittees Class | Aptify.Applications.Persons.Committees Namespace


AddPersonToCommittees.Run Method

This method provides the IProcessComponent inteface Run() capability and handles the process of adding Person record(s) to Committee Term(s). The following Input Properties are supported PersonIDList (Required) - Comma Delimited List of Person Record ID values that are to be operated onCommitteeTermIDList (Required) - Comma Delimited List of Committee Term ID values that people are to be added to from the PersonIDList propertyRank - (Optional, Defaults to 1) - Integer Value - This rank will be applied to all new records added to the Committee Terms for the individuals listed in the PersonIDList propertyVotingMember - (Optional, Defaults to 0, Possible Values of 0 and 1) - Integer Value - This voting member status (0-Non Voting, 1-Voting) will be applied to all new records added to the Committee Terms for the individuals listed in the PersonIDList propertyAllowDuplicates - (Optional, Defaults to 0, Possible Values of 0 and 1) - Integer Value - This input property determines if duplicate member records are allowed in a given committee term. If this property is set to 0, duplicates will not be allowed. If it is set to 1, duplicates will be allowed The following Output Properties are supported Results - Text String - Indicates the Results of the Operation in a user-readable format The following Result Codes are posssible SUCCESSFAILED

public virtual string Run();

Return Value

Either "FAILED" or "SUCCESS"

Implements

IProcessComponent.

Remarks

See Also

AddPersonToCommittees Class | Aptify.Applications.Persons.Committees Namespace


AddPersonToCommittees Events

The events of the AddPersonToCommittees class are listed below. For a complete list of AddPersonToCommittees class members, see the AddPersonToCommittees Members topic.

Public Instance Events

StatusUpdate This event is raised whenever a process completes an iteration in a long running process such as the AddPersonsToCommitteeTerms() method. This event allows the consumer of this object to cancel the operation by setting the Cancel OUT parameter to True.

See Also

AddPersonToCommittees Class | Aptify.Applications.Persons.Committees Namespace


AddPersonToCommittees.AddPersonToCommittees.StatusUpdateEventHandler Event

This event is raised whenever a process completes an iteration in a long running process such as the AddPersonsToCommitteeTerms() method. This event allows the consumer of this object to cancel the operation by setting the Cancel OUT parameter to True.

public event AddPersonToCommittees.StatusUpdateEventHandler StatusUpdate;

Remarks

See Also

AddPersonToCommittees Class | Aptify.Applications.Persons.Committees Namespace


AddPersonToCommittees.StatusUpdateEventHandler Delegate

public delegate void AddPersonToCommittees.StatusUpdateEventHandler(
String Message,
Int32 PercentComplete,
ref Boolean& Cancel
);

Requirements

Namespace: Aptify.Applications.Persons.Committees

Assembly: AddPersonToCommittees (in AddPersonToCommittees.dll)

See Also

Aptify.Applications.Persons.Committees Namespace


AddPersonToCommitteesUI Class

This class is used to implement the entity action (wizard) that will allow a user to add one or more people from a view to one or more committee terms in one step. This class is also used from the Add To Committees Button that is part of the Persons User Interface form for the Committees tab of the Persons form.

For a list of all members of this type, see AddPersonToCommitteesUI Members.

System.Object
AddPersonToCommitteesUI

public class AddPersonToCommitteesUI : IAptifyAction

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Persons.Committees

Assembly: AddPersonToCommitteesUI (in AddPersonToCommitteesUI.dll)

See Also

AddPersonToCommitteesUI Members | Aptify.Applications.Persons.Committees Namespace


AddPersonToCommitteesUI Members

AddPersonToCommitteesUI overview

Public Instance Constructors

AddPersonToCommitteesUI Constructor Initializes a new instance of the AddPersonToCommitteesUI class.

Public Instance Methods

DoAction | Overloaded.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AddPersonToCommitteesUI Class | Aptify.Applications.Persons.Committees Namespace


AddPersonToCommitteesUI Constructor

Initializes a new instance of the AddPersonToCommitteesUI class.

public AddPersonToCommitteesUI();

See Also

AddPersonToCommitteesUI Class | Aptify.Applications.Persons.Committees Namespace


AddPersonToCommitteesUI Methods

The methods of the AddPersonToCommitteesUI class are listed below. For a complete list of AddPersonToCommitteesUI class members, see the AddPersonToCommitteesUI Members topic.

Public Instance Methods

DoAction | Overloaded.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AddPersonToCommitteesUI Class | Aptify.Applications.Persons.Committees Namespace


DoAction Method

Aptify 5.0 Software Development Kit (SDK)

AddPersonToCommitteesUI.DoAction Method

Overload List

public void DoAction(AptifyApplication,Int64);

public void DoAction(AptifyApplication,Int64,Int64);

public void DoAction(AptifyApplication,Int64,Int64,params Object[]);

public void DoAction(AptifyApplication,Int64,params String[]);

See Also

AddPersonToCommitteesUI Class | Aptify.Applications.Persons.Committees Namespace


AddPersonToCommitteesUI.DoAction Method (AptifyApplication, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID
);

Implements

IAptifyAction.

See Also

AddPersonToCommitteesUI Class | Aptify.Applications.Persons.Committees Namespace | AddPersonToCommitteesUI.DoAction Overload List


AddPersonToCommitteesUI.DoAction Method (AptifyApplication, Int64, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID
);

Implements

IAptifyAction.

See Also

AddPersonToCommitteesUI Class | Aptify.Applications.Persons.Committees Namespace | AddPersonToCommitteesUI.DoAction Overload List


AddPersonToCommitteesUI.DoAction Method (AptifyApplication, Int64, Int64, Object[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID,
params Object[] SelectedItems
);

Implements

IAptifyAction.

See Also

AddPersonToCommitteesUI Class | Aptify.Applications.Persons.Committees Namespace | AddPersonToCommitteesUI.DoAction Overload List


AddPersonToCommitteesUI.DoAction Method (AptifyApplication, Int64, String[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
params String[] SelectedItems
);

Implements

IAptifyAction.

See Also

AddPersonToCommitteesUI Class | Aptify.Applications.Persons.Committees Namespace | AddPersonToCommitteesUI.DoAction Overload List


CommitteeAddResultsForm Class

Used to display result from a multiple committee add.

For a list of all members of this type, see CommitteeAddResultsForm Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
CommitteeAddResultsForm

public class CommitteeAddResultsForm : Form

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Persons.Committees

Assembly: AddPersonToCommitteesUI (in AddPersonToCommitteesUI.dll)

See Also

CommitteeAddResultsForm Members | Aptify.Applications.Persons.Committees Namespace


CommitteeAddResultsForm Members

CommitteeAddResultsForm overview

Public Instance Constructors

CommitteeAddResultsForm Constructor Initializes a new instance of the CommitteeAddResultsForm class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CommitteeAddResultsForm Class | Aptify.Applications.Persons.Committees Namespace


CommitteeAddResultsForm Constructor

Initializes a new instance of the CommitteeAddResultsForm class.

public CommitteeAddResultsForm();

See Also

CommitteeAddResultsForm Class | Aptify.Applications.Persons.Committees Namespace


CommitteeAddResultsForm Methods

The methods of the CommitteeAddResultsForm class are listed below. For a complete list of CommitteeAddResultsForm class members, see the CommitteeAddResultsForm Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CommitteeAddResultsForm Class | Aptify.Applications.Persons.Committees Namespace


CommitteeAddResultsForm.ApplySkin Method

protected virtual void ApplySkin();

See Also

CommitteeAddResultsForm Class | Aptify.Applications.Persons.Committees Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

CommitteeAddResultsForm.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

CommitteeAddResultsForm Class | Aptify.Applications.Persons.Committees Namespace


CommitteeAddResultsForm.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

CommitteeAddResultsForm Class | Aptify.Applications.Persons.Committees Namespace | CommitteeAddResultsForm.Dispose Overload List


CommitteeSelection Class

Instantiates and displays a version of CommitteeSelectionForm.

For a list of all members of this type, see CommitteeSelection Members.

System.Object
CommitteeSelection

public class CommitteeSelection : IAddPersonsToCommittees

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Persons.Committees

Assembly: AddPersonToCommitteesUI (in AddPersonToCommitteesUI.dll)

See Also

CommitteeSelection Members | Aptify.Applications.Persons.Committees Namespace


CommitteeSelection Members

CommitteeSelection overview

Public Instance Constructors

CommitteeSelection Constructor Initializes a new instance of the CommitteeSelection class.

Public Instance Methods

Add | Overloaded. Displays a Modal Version of the CommitteeSelectionForm with no Owner.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CommitteeSelection Class | Aptify.Applications.Persons.Committees Namespace


CommitteeSelection Constructor

Initializes a new instance of the CommitteeSelection class.

public CommitteeSelection();

See Also

CommitteeSelection Class | Aptify.Applications.Persons.Committees Namespace


CommitteeSelection Methods

The methods of the CommitteeSelection class are listed below. For a complete list of CommitteeSelection class members, see the CommitteeSelection Members topic.

Public Instance Methods

Add | Overloaded. Displays a Modal Version of the CommitteeSelectionForm with no Owner.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CommitteeSelection Class | Aptify.Applications.Persons.Committees Namespace


Add Method

Aptify 5.0 Software Development Kit (SDK)

CommitteeSelection.Add Method

Displays a Modal Version of the CommitteeSelectionForm with no Owner.

Overload List

Displays a Modal Version of the CommitteeSelectionForm with no Owner.

public void Add(AptifyApplication,params Int64[]);

Displays a Modal Version of the CommitteeSelectionForm with the specified owner.

public void Add(AptifyApplication,IWin32Window,params Int64[]);

See Also

CommitteeSelection Class | Aptify.Applications.Persons.Committees Namespace


CommitteeSelection.Add Method (AptifyApplication, Int64[])

Displays a Modal Version of the CommitteeSelectionForm with no Owner.

public void Add(
AptifyApplication ApplicationObject,
params Int64[] Persons
);

Parameters

ApplicationObject
Persons

Implements

IAddPersonsToCommittees.

Remarks

See Also

CommitteeSelection Class | Aptify.Applications.Persons.Committees Namespace | CommitteeSelection.Add Overload List


CommitteeSelection.Add Method (AptifyApplication, IWin32Window, Int64[])

Displays a Modal Version of the CommitteeSelectionForm with the specified owner.

public void Add(
AptifyApplication ApplicationObject,
IWin32Window Owner,
params Int64[] Persons
);

Parameters

ApplicationObject
Owner
Persons

Implements

IAddPersonsToCommittees.

Remarks

See Also

CommitteeSelection Class | Aptify.Applications.Persons.Committees Namespace | CommitteeSelection.Add Overload List


CommitteeTermMemberInfo Class

This class is used to encapsulate information about a given committee term member's attributes.

For a list of all members of this type, see CommitteeTermMemberInfo Members.

System.Object
CommitteeTermMemberInfo

public class CommitteeTermMemberInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Persons.Committees

Assembly: AddPersonToCommittees (in AddPersonToCommittees.dll)

See Also

CommitteeTermMemberInfo Members | Aptify.Applications.Persons.Committees Namespace


CommitteeTermMemberInfo Members

CommitteeTermMemberInfo overview

Public Instance Constructors

CommitteeTermMemberInfo Overloaded. Initializes a new instance of the CommitteeTermMemberInfo class.

Public Instance Properties

CommitteeTermID
CommitteeTermName
Rank
VotingMember

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CommitteeTermMemberInfo Class | Aptify.Applications.Persons.Committees Namespace


CommitteeTermMemberInfo Constructor

This overload instantiates the class and sets the Rank property to a default value of 1 and the Voting Member attribute to a default value of False.

Overload List

This overload instantiates the class and sets the Rank property to a default value of 1 and the Voting Member attribute to a default value of False.

public CommitteeTermMemberInfo(Int64,String);

public CommitteeTermMemberInfo(Int64,String,Int32,Boolean);

See Also

CommitteeTermMemberInfo Class | Aptify.Applications.Persons.Committees Namespace


CommitteeTermMemberInfo Constructor (Int64, String)

This overload instantiates the class and sets the Rank property to a default value of 1 and the Voting Member attribute to a default value of False.

public CommitteeTermMemberInfo(
Int64 CommitteeTermID,
String CommitteeTermName
);

Parameters

CommitteeTermID
CommitteeTermName

Remarks

See Also

CommitteeTermMemberInfo Class | Aptify.Applications.Persons.Committees Namespace | CommitteeTermMemberInfo Constructor Overload List


CommitteeTermMemberInfo Constructor (Int64, String, Int32, Boolean)

public CommitteeTermMemberInfo(
Int64 CommitteeTermID,
String CommitteeTermName,
Int32 Rank,
Boolean VotingMember
);

See Also

CommitteeTermMemberInfo Class | Aptify.Applications.Persons.Committees Namespace | CommitteeTermMemberInfo Constructor Overload List


CommitteeTermMemberInfo Properties

The properties of the CommitteeTermMemberInfo class are listed below. For a complete list of CommitteeTermMemberInfo class members, see the CommitteeTermMemberInfo Members topic.

Public Instance Properties

CommitteeTermID
CommitteeTermName
Rank
VotingMember

See Also

CommitteeTermMemberInfo Class | Aptify.Applications.Persons.Committees Namespace


CommitteeTermID Property

Aptify 5.0 Software Development Kit (SDK)

CommitteeTermMemberInfo.CommitteeTermID Property

public virtual Int64 CommitteeTermID {get; set;}

See Also

CommitteeTermMemberInfo Class | Aptify.Applications.Persons.Committees Namespace


CommitteeTermName Property

Aptify 5.0 Software Development Kit (SDK)

CommitteeTermMemberInfo.CommitteeTermName Property

public virtual String CommitteeTermName {get; set;}

See Also

CommitteeTermMemberInfo Class | Aptify.Applications.Persons.Committees Namespace


Rank Property

Aptify 5.0 Software Development Kit (SDK)

CommitteeTermMemberInfo.Rank Property

public virtual Int32 Rank {get; set;}

See Also

CommitteeTermMemberInfo Class | Aptify.Applications.Persons.Committees Namespace


VotingMember Property

Aptify 5.0 Software Development Kit (SDK)

CommitteeTermMemberInfo.VotingMember Property

public virtual Boolean VotingMember {get; set;}

See Also

CommitteeTermMemberInfo Class | Aptify.Applications.Persons.Committees Namespace


CommitteeTermNomineeInfo Class

This class is used to encapsulate information about a given committee term nominee's attributes.

For a list of all members of this type, see CommitteeTermNomineeInfo Members.

System.Object
CommitteeTermNomineeInfo

public class CommitteeTermNomineeInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Persons.Committees

Assembly: AddPersonToCommittees (in AddPersonToCommittees.dll)

See Also

CommitteeTermNomineeInfo Members | Aptify.Applications.Persons.Committees Namespace


CommitteeTermNomineeInfo Members

CommitteeTermNomineeInfo overview

Public Instance Constructors

CommitteeTermNomineeInfo Overloaded. Initializes a new instance of the CommitteeTermNomineeInfo class.

Public Instance Properties

CommitteeTermID
CommitteeTermName
Status
Type

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CommitteeTermNomineeInfo Class | Aptify.Applications.Persons.Committees Namespace


CommitteeTermNomineeInfo Constructor

This overload instantiates the class and sets the Type property to a default value of "Applicant" and the Status attribute to a default value of "Pending".

Overload List

This overload instantiates the class and sets the Type property to a default value of "Applicant" and the Status attribute to a default value of "Pending".

public CommitteeTermNomineeInfo(Int64,String);

public CommitteeTermNomineeInfo(Int64,String,String,String);

See Also

CommitteeTermNomineeInfo Class | Aptify.Applications.Persons.Committees Namespace


CommitteeTermNomineeInfo Constructor (Int64, String)

This overload instantiates the class and sets the Type property to a default value of "Applicant" and the Status attribute to a default value of "Pending".

public CommitteeTermNomineeInfo(
Int64 CommitteeTermID,
String CommitteeTermName
);

Parameters

CommitteeTermID
CommitteeTermName

Remarks

See Also

CommitteeTermNomineeInfo Class | Aptify.Applications.Persons.Committees Namespace | CommitteeTermNomineeInfo Constructor Overload List


CommitteeTermNomineeInfo Constructor (Int64, String, String, String)

public CommitteeTermNomineeInfo(
Int64 CommitteeTermID,
String CommitteeTermName,
String Type,
String Status
);

See Also

CommitteeTermNomineeInfo Class | Aptify.Applications.Persons.Committees Namespace | CommitteeTermNomineeInfo Constructor Overload List


CommitteeTermNomineeInfo Properties

The properties of the CommitteeTermNomineeInfo class are listed below. For a complete list of CommitteeTermNomineeInfo class members, see the CommitteeTermNomineeInfo Members topic.

Public Instance Properties

CommitteeTermID
CommitteeTermName
Status
Type

See Also

CommitteeTermNomineeInfo Class | Aptify.Applications.Persons.Committees Namespace


CommitteeTermID Property

Aptify 5.0 Software Development Kit (SDK)

CommitteeTermNomineeInfo.CommitteeTermID Property

public virtual Int64 CommitteeTermID {get; set;}

See Also

CommitteeTermNomineeInfo Class | Aptify.Applications.Persons.Committees Namespace


CommitteeTermName Property

Aptify 5.0 Software Development Kit (SDK)

CommitteeTermNomineeInfo.CommitteeTermName Property

public virtual String CommitteeTermName {get; set;}

See Also

CommitteeTermNomineeInfo Class | Aptify.Applications.Persons.Committees Namespace


Status Property

Aptify 5.0 Software Development Kit (SDK)

CommitteeTermNomineeInfo.Status Property

public virtual String Status {get; set;}

See Also

CommitteeTermNomineeInfo Class | Aptify.Applications.Persons.Committees Namespace


Type Property

Aptify 5.0 Software Development Kit (SDK)

CommitteeTermNomineeInfo.Type Property

public virtual String Type {get; set;}

See Also

CommitteeTermNomineeInfo Class | Aptify.Applications.Persons.Committees Namespace


IAddPersonsToCommittees Interface

Interface used to Add Persons to Committees.

For a list of all members of this type, see IAddPersonsToCommittees Members.

public interface IAddPersonsToCommittees

Types that implement IAddPersonsToCommittees

Type | Description
CommitteeSelection | Instantiates and displays a version of CommitteeSelectionForm.

Remarks

This Interface should be implemented by an object that can perform the steps needed to add Persons to a Committees.

Requirements

Namespace: Aptify.Applications.Persons.Committees

Assembly: AddPersonToCommitteesUI (in AddPersonToCommitteesUI.dll)

See Also

IAddPersonsToCommittees Members | Aptify.Applications.Persons.Committees Namespace


IAddPersonsToCommittees Members

IAddPersonsToCommittees overview

Public Instance Methods

Add Overloaded. Adds one or more Persons to one or more Committees. A GUI should be displayed for selection purposes.

See Also

IAddPersonsToCommittees Interface | Aptify.Applications.Persons.Committees Namespace


IAddPersonsToCommittees Methods

The methods of the IAddPersonsToCommittees interface are listed below. For a complete list of IAddPersonsToCommittees interface members, see the IAddPersonsToCommittees Members topic.

Public Instance Methods

Add Overloaded. Adds one or more Persons to one or more Committees. A GUI should be displayed for selection purposes.

See Also

IAddPersonsToCommittees Interface | Aptify.Applications.Persons.Committees Namespace


Add Method

Aptify 5.0 Software Development Kit (SDK)

IAddPersonsToCommittees.Add Method

Adds one or more Persons to one or more Committees. A GUI should be displayed for selection purposes.

Overload List

Adds one or more Persons to one or more Committees. A GUI should be displayed for selection purposes.

void Add(AptifyApplication,params Int64[]);

Adds one or more Persons to one or more Committees. A GUI should be displayed for selection purposes.

void Add(AptifyApplication,IWin32Window,params Int64[]);

See Also

IAddPersonsToCommittees Interface | Aptify.Applications.Persons.Committees Namespace


IAddPersonsToCommittees.Add Method (AptifyApplication, Int64[])

Adds one or more Persons to one or more Committees. A GUI should be displayed for selection purposes.

void Add(
AptifyApplication ApplicationObject,
params Int64[] Persons
);

Parameters

ApplicationObject
Persons
An array of Long Integer values that represent the IDs of the people that will be added to committees.

Remarks

Exceptions

Exception Type | Condition
AddPersonException | Thrown if there is a problem adding one or more Persons to one or more Committees.

See Also

IAddPersonsToCommittees Interface | Aptify.Applications.Persons.Committees Namespace | IAddPersonsToCommittees.Add Overload List


IAddPersonsToCommittees.Add Method (AptifyApplication, IWin32Window, Int64[])

Adds one or more Persons to one or more Committees. A GUI should be displayed for selection purposes.

void Add(
AptifyApplication ApplicationObject,
IWin32Window Owner,
params Int64[] Persons
);

Parameters

ApplicationObject
Owner
An IWin32Window that will be used as an owner for any displayed GUI.
Persons
An array of Longs that represent the IDs of the people that will be added to committees.

Exceptions

Exception Type | Condition
AddPersonException | Thrown if there is a problem adding one or more Persons to one or more Committees.

See Also

IAddPersonsToCommittees Interface | Aptify.Applications.Persons.Committees Namespace | IAddPersonsToCommittees.Add Overload List


Aptify.Applications.Persons.WebAccess

Aptify 5.0 Software Development Kit (SDK)

Aptify.Applications.Persons.WebAccess Namespace

This namespace corresponds to objects that provide a Web implementation of Persons Windows controls for use in Aptify Web Access.

Namespace hierarchy

Classes

Class | Description
CommitteeTermsMemberList | Aptify CommitteeTermsMemberList ASP.NET Server Control. The current version of this control only supports reading data.
PersonCompaniesWebLayout |
PersonsWebLayout |


CommitteeTermsMemberList Class

Aptify CommitteeTermsMemberList ASP.NET Server Control. The current version of this control only supports reading data.

For a list of all members of this type, see CommitteeTermsMemberList Members.

System.Object
Control
WebControl
CompositeControl
WebFormComponentBase
WebDataFieldFormComponentBase
CommitteeTermsMemberList

public class CommitteeTermsMemberList : WebDataFieldFormComponentBase, ICallbackEventHandler

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Persons.WebAccess

Assembly: AptifyPersonsWebGUI (in AptifyPersonsWebGUI.dll)

See Also

CommitteeTermsMemberList Members | Aptify.Applications.Persons.WebAccess Namespace


CommitteeTermsMemberList Members

CommitteeTermsMemberList overview

Public Instance Constructors

CommitteeTermsMemberList Constructor Initializes a new instance of the CommitteeTermsMemberList class.

Public Instance Properties

AccessKey (inherited from WebControl) | Gets or sets the access key that allows you to quickly navigate to the Web server control.
Application (inherited from WebFormComponentBase) | Returns an instance of the AptifyApplication object
AppRelativeTemplateSourceDirectory (inherited from Control) | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control.
Attributes (inherited from WebControl) | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control.
BackColor (inherited from WebControl) | Gets or sets the background color of the Web server control.
BindingContainer (inherited from Control) | Gets the control that contains this control's data binding.
BorderColor (inherited from WebControl) | Gets or sets the border color of the Web control.
BorderStyle (inherited from WebControl) | Gets or sets the border style of the Web server control.
BorderWidth (inherited from WebControl) | Gets or sets the border width of the Web server control.
ClientID (inherited from Control) | Gets the server control identifier generated by ASP.NET.
Control (inherited from WebFormComponentBase) |
Controls (inherited from CompositeControl) | Gets a ControlCollection object that represents the child controls in a CompositeControl.
ControlStyle (inherited from WebControl) | Gets the style of the Web server control. This property is used primarily by control developers.
ControlStyleCreated (inherited from WebControl) | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers.
CssClass (inherited from WebControl) | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.
DataAction (inherited from WebFormComponentBase) | Returns an instance of the Aptify DataAction object
DataControl (inherited from WebFormComponentBase) | Adds a reference to the object for the data control. In the case of it being added, the reference to the bound control base object is added to the data controls collection.
DataField (inherited from WebDataFieldFormComponentBase) |
DeferredLoading | This property determines if the control will load only upon the first time it is focused upon, as opposed to being pre-loaded on the server. If this property is set to True, instead of rendering any content upon its initial load, it will simply emit a small client side element that when first focused on, will create an inline frame to display the view.
DisableGEDataTransfer (inherited from WebFormComponentBase) |
Edit (inherited from WebDataFieldFormComponentBase) |
Enabled (inherited from WebDataFieldFormComponentBase) |
EnableTheming (inherited from WebControl) | Gets or sets a value indicating whether themes apply to this control.
EnableViewState (inherited from Control) | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client.
FillHeight (inherited from WebFormComponentBase) | Determines if the control will fill the parent container's height at run time on the client-side (done via client-side Java Script). Maps to the fillHeight run-time HTML element attribute.
FillHeightMargin (inherited from WebFormComponentBase) | This property is only used if FillHeight is set to True. If FillHeight is set to True, this property determines the margin to use on the bottom side of the control when filling the container's height. This property specifies the number of pixels of space to be left on the bottom side of the control between the control's edge and the container's edge.
FillIgnoreChildren (inherited from WebFormComponentBase) | Determines if the control's children will be evaluated for resizing or not. The default value for this property is True, which results in the children of the control NOT being evaluated for resizing. Sub-classes can override this as required, as can individual instances of the class being used at run-time or design-time. It is important to leave this property set to True as much as possible as it reduces run-time resizing overhead.
FillWidth (inherited from WebFormComponentBase) | Determines if the control will fill the parent container's width at run time on the client-side (done via client-side Java Script). Maps to the fillWidth run-time HTML element attribute.
FillWidthMargin (inherited from WebFormComponentBase) | This property is only used if FillWidth is set to True. If FillWidth is set to True, this property determines the margin to use on the right side of the control when filling the container's width. This property specifies the number of pixels of space to be left on the right side of the control between the control's edge and the container's edge.
Font (inherited from WebDataFieldFormComponentBase) |
ForeColor (inherited from WebControl) | Gets or sets the foreground color (typically the color of the text) of the Web server control.
FormTemplateContext (inherited from WebFormComponentBase) |
HasAttributes (inherited from WebControl) | Gets a value indicating whether the control has attributes set.
Height (inherited from WebControl) | Gets or sets the height of the Web server control.
ID (inherited from Control) | Gets or sets the programmatic identifier assigned to the server control.
LabelFont (inherited from WebDataFieldFormComponentBase) |
LabelRequiredFont (inherited from WebDataFieldFormComponentBase) |
LabelText (inherited from WebDataFieldFormComponentBase) |
LabelTextAlign (inherited from WebDataFieldFormComponentBase) |
LabelWidth (inherited from WebDataFieldFormComponentBase) |
MaxHeight |
NamingContainer (inherited from Control) | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value.
Page (inherited from Control) | Gets a reference to the Page instance that contains the server control.
Parent (inherited from Control) | Gets a reference to the server control's parent control in the page control hierarchy.
Read (inherited from WebDataFieldFormComponentBase) |
Required (inherited from WebDataFieldFormComponentBase) |
ShowLabel (inherited from WebDataFieldFormComponentBase) |
Site (inherited from Control) | Gets information about the container that hosts the current control when rendered on a design surface.
SkinID (inherited from WebControl) | Gets or sets the skin to apply to the control.
Style (inherited from WebControl) | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control.
TabIndex (inherited from WebControl) | Gets or sets the tab index of the Web server control.
TemplateControl (inherited from Control) | Gets or sets a reference to the template that contains this control.
TemplateSourceDirectory (inherited from Control) | Gets the virtual directory of the Page or UserControl that contains the current server control.
Text |
ToolTip (inherited from WebControl) | Gets or sets the text displayed when the mouse pointer hovers over the Web server control.
UniqueID (inherited from Control) | Gets the unique, hierarchically qualified identifier for the server control.
Value (inherited from WebDataFieldFormComponentBase) |
Visible (inherited from Control) | Gets or sets a value that indicates whether a server control is rendered as UI on the page.
Width (inherited from WebControl) | Gets or sets the width of the Web server control.

Public Instance Methods

ApplyStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers.
ApplyStyleSheetSkin (inherited from Control) | Applies the style properties defined in the page style sheet to the control.
ClearData (inherited from WebFormComponentBase) |
CopyBaseAttributes (inherited from WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers.
DataBind (inherited from CompositeControl) | Overloaded. Binds a data source to the CompositeControl and all its child controls.
Dispose (inherited from Control) | Enables a server control to perform final clean up before it is released from memory.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindControl (inherited from Control) | Overloaded. Searches the current naming container for a server control with the specified id parameter.
Focus (inherited from Control) | Sets input focus to a control.
FormComponentConfig |
GetCallbackResult | This method is required by ICallbackEventHandler. Result of the Callback gets sent back to the Client-side function by this method. The JavaScript function can be modified to do whatever is necessary with the results.
GetClientCulture (inherited from WebFormComponentBase) | Returns the culture for the client browser based on the first language in the Request.UserLanguages() array
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from WebFormComponentBase) |
GetType (inherited from Object) | Gets the Type of the current instance.
HasControls (inherited from Control) | Determines if the server control contains any child controls.
Hide (inherited from WebFormComponentBase) |
MergeStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers.
RaiseCallbackEvent | This method is required by ICallbackEventHandler. This method is the server-side of the asynchronous callback event. Here is where all the functionality is defined for what to do on a Callback.
Refresh | Overrides Refresh to handle setting control enabled bits right before rendering occurs
RenderBeginTag (inherited from WebControl) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers.
RenderControl (inherited from Control) | Overloaded. Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
RenderEndTag (inherited from WebControl) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers.
ResolveClientUrl (inherited from Control) | Gets a URL that can be used by the browser.
ResolveUrl (inherited from Control) | Converts a URL into one that is usable on the requesting client.
SaveRecord | Logic that gets executed when a Term Member needs to be edited.
SetRenderMethodDelegate (inherited from Control) | Assigns an event handler delegate to render the server control and its content into its parent control.
SetUserCredential (inherited from WebFormComponentBase) |
Show (inherited from WebFormComponentBase) | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.
TransferDataToObject (inherited from WebDataFieldFormComponentBase) |

Public Instance Events

DataBinding (inherited from WebFormComponentBase)
Disposed (inherited from WebFormComponentBase)
Init (inherited from WebFormComponentBase)
Load (inherited from WebFormComponentBase)
PreRender (inherited from WebFormComponentBase)
Unload (inherited from WebFormComponentBase)
ValueChanged (inherited from WebFormComponentBase)

Protected Instance Fields

m_bEdit (inherited from WebDataFieldFormComponentBase)
m_bPreConfig (inherited from WebDataFieldFormComponentBase)
m_bRead (inherited from WebDataFieldFormComponentBase)
m_bRequired (inherited from WebDataFieldFormComponentBase)
m_sDataField (inherited from WebDataFieldFormComponentBase)

Protected Instance Properties

Adapter (inherited from Control) | Gets the browser-specific adapter for the control.
ChildControlsCreated (inherited from Control) | Gets a value that indicates whether the server control's child controls have been created.
ClientIDSeparator (inherited from Control) | Gets a character value representing the separator character used in the ClientID property.
ContainerTable (inherited from WebDataFieldFormComponentBase) |
ControlCell (inherited from WebDataFieldFormComponentBase) |
ErrorLabel (inherited from WebFormComponentBase) | This label is an internal feature of the base class that can be used by sub-classes to display error messages to the user when required. Set the ErrorLabel.Visible = True first, and then set the ErrorLabel.Text to the appropriate message for the user.
Events (inherited from Control) | Gets a list of event handler delegates for the control. This property is read-only.
ExtendedType (inherited from WebDataFieldFormComponentBase) |
ExtenderCell (inherited from WebDataFieldFormComponentBase) |
HasChildViewState (inherited from Control) | Gets a value indicating whether the current server control's child controls have any saved view-state settings.
IdSeparator (inherited from Control) | Gets the character used to separate control identifiers.
InternalControl (inherited from WebDataFieldFormComponentBase) |
IsTrackingViewState (inherited from Control) | Gets a value that indicates whether the server control is saving changes to its view state.
LabelCell (inherited from WebDataFieldFormComponentBase) |
LabelControl (inherited from WebDataFieldFormComponentBase) |
LoadViewStateByID (inherited from Control) | Gets a value indicating whether the control participates in loading its view state by ID instead of index.
MyApplication (inherited from WebFormComponentBase) |
OldValue (inherited from WebDataFieldFormComponentBase) |
TagKey (inherited from WebControl) | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers.
TagName (inherited from WebControl) | Gets the name of the control tag. This property is used primarily by control developers.
UserCredential (inherited from WebFormComponentBase) |
ViewState (inherited from Control) | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page.
ViewStateIgnoresCase (inherited from Control) | Gets a value that indicates whether the StateBag object is case-insensitive.

Protected Instance Methods

AddAttributesToRender (inherited from WebControl) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers.
AddParsedSubObject (inherited from Control) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object.
AddRecord |
BuildGrid | This method is responsible for building the grid data source and binding to it based on the information inside the sub-type that this sub-type control is bound to
BuildProfileTree (inherited from Control) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page.
ClearChildControlState (inherited from Control) | Deletes the control-state information for the server control's child controls.
ClearChildState (inherited from Control) | Deletes the view-state and control-state information for all the server control's child controls.
ClearChildViewState (inherited from Control) | Deletes the view-state information for all the server control's child controls.
CreateChildControls |
CreateControlCollection (inherited from Control) | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control.
CreateControlStyle (inherited from WebControl) | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers.
DataBind (inherited from Control) | Overloaded. Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.
DataBindChildren (inherited from Control) | Binds a data source to the server control's child controls.
DeleteRecord | Logic that gets executed when a Term Member needs to be Deleted.
EnsureChildControls (inherited from Control) | Determines whether the server control contains child controls. If it does not, it creates child controls.
EnsureID (inherited from Control) | Creates an identifier for controls that do not have an identifier assigned.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FindControl (inherited from Control) | Overloaded. Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl method.
GetClientDateFormat (inherited from WebFormComponentBase) | Returns a string showing the preferred date format for the connected user.
GetClientTimeFormat (inherited from WebFormComponentBase) | Returns a string showing the preferred time format for the connected user.
GetDesignModeState (inherited from Control) | Gets design-time data for a control.
GetNextPixelParent (inherited from WebDataFieldFormComponentBase) | This method attempts to go up the control hierarchy until the next parent control is found that has a pixel-based width/height.
GetProperty (inherited from WebFormComponentBase) | Overloaded.
GetStandardWidthMargin (inherited from WebDataFieldFormComponentBase) | Returns the standard calculation result for the width margin to use on controls that are set to fill the parent's width. Override this method to adjust the width margins for specific controls.
GetUserCredentialsFromSession (inherited from WebFormComponentBase) | Returns a User Credentials object from the Session State, if available. This is used when ViewState is not yet recreated, or during Callback when ViewState is unavailable
HasEvents (inherited from Control) | Returns a value indicating whether events are registered for the control or any child controls.
InitializeGridLevel |
InitializeGridProperties | This method is called when the grid's properties need to be initialized
IsLiteralContent (inherited from Control) | Determines if the server control holds only literal content.
LoadViewState (inherited from WebDataFieldFormComponentBase) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnBubbleEvent (inherited from Control) | Determines whether the event for the server control is passed up the page's UI server control hierarchy.
OnDataBinding (inherited from Control) | Raises the DataBinding event.
OnInit (inherited from WebFormComponentBase) |
OnPreRender (inherited from WebDataFieldFormComponentBase) | Overriden version of OnPreRender(), calls base OnPreRender() and calls SetupInternalControlSizing() to ensure controls are sized properly.
RaiseBubbleEvent (inherited from Control) | Assigns any sources of the event and its information to the control's parent.
RaiseValueChanged (inherited from WebFormComponentBase) |
RecreateChildControls (inherited from CompositeControl) | Recreates the child controls n a control derived from CompositeControl.
Render (inherited from WebDataFieldFormComponentBase) |
RenderControl (inherited from Control) | Overloaded. Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.
RequiredGECheck (inherited from WebFormComponentBase) |
RequiredPropertiesCheck (inherited from WebDataFieldFormComponentBase) |
ResolveAdapter (inherited from Control) | Gets the control adapter responsible for rendering the specified control.
SaveViewState (inherited from WebDataFieldFormComponentBase) |
SetControlMetaData (inherited from WebDataFieldFormComponentBase) |
SetDesignModeState (inherited from Control) | Sets design-time data for a control.
SetExclusions (inherited from WebDataFieldFormComponentBase) |
SetSecurity (inherited from WebDataFieldFormComponentBase) |
SetupClientHandlers | This method is responsible for setting up the Callback functionality. Currently, this is being used for deleting SubType records. The Result and Error JavaScript functions are defined in WebSubType.js, while the Callback and Delete button's click event are setup below.
SetupControlCellPadding (inherited from WebDataFieldFormComponentBase) | This method is responsible for setting up padding for the control cell within the Data Field Control so that the internal control is not clipped.
SetupInternalControlSizing (inherited from WebDataFieldFormComponentBase) | This method handles the general setup of internal control component sizing and can be overriden as required by subclasses to handle specialized sizing/layout requirements.
SetupLabelText (inherited from WebDataFieldFormComponentBase) | This method internally sets the label caption. If a value of Nothing/Null or a blank string is provided to this method, the internal meta-data for the field is used instead. In addition, this method will automatically map a field's culture in order to change the display name based on the culture of the field if necessary, but that is only done if the LabelCaption parameter exactly matches the DisplayName of the field. Override this method to change the base functionality.
SetValueFromGE (inherited from WebDataFieldFormComponentBase) |
TrackViewState (inherited from WebControl) | Causes the control to track changes to its view state so they can be stored in the object's ViewState property.

Protected Instance Events

PostConfig (inherited from WebDataFieldFormComponentBase)
PreConfig (inherited from WebDataFieldFormComponentBase)

Protected Internal Instance Properties

Context (inherited from Control) | Gets the HttpContext object associated with the server control for the current Web request.
DesignMode (inherited from Control) | Gets a value indicating whether a control is being used on a design surface.
IsChildControlStateCleared (inherited from Control) | Gets a value indicating whether controls contained within this control have control state.
IsEnabled (inherited from WebControl) | Gets a value indicating whether the control is enabled.
IsViewStateEnabled (inherited from Control) | Gets a value indicating whether view state is enabled for this control.
StopInitialization (inherited from WebDataFieldFormComponentBase) |

Protected Internal Instance Methods

AddedControl (inherited from Control) | Called after a child control is added to the Controls collection of the Control object.
LoadControlState (inherited from Control) | Restores control-state information from a previous page request that was saved by the SaveControlState method.
MapPathSecure (inherited from Control) | Retrieves the physical path that a virtual path, either absolute or relative, maps to.
OnLoad (inherited from Control) | Raises the Load event.
OnUnload (inherited from Control) | Raises the Unload event.
OpenFile (inherited from Control) | Gets a Stream used to read a file.
RemovedControl (inherited from Control) | Called after a control is removed from the Controls collection of another control.
RenderChildren (inherited from Control) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client.
RenderContents (inherited from WebControl) | Renders the contents of the control to the specified writer. This method is used primarily by control developers.
SaveControlState (inherited from Control) | Saves any server control state changes that have occurred since the time the page was posted back to the server.

See Also

CommitteeTermsMemberList Class | Aptify.Applications.Persons.WebAccess Namespace


CommitteeTermsMemberList Constructor

Initializes a new instance of the CommitteeTermsMemberList class.

public CommitteeTermsMemberList();

See Also

CommitteeTermsMemberList Class | Aptify.Applications.Persons.WebAccess Namespace


CommitteeTermsMemberList Properties

The properties of the CommitteeTermsMemberList class are listed below. For a complete list of CommitteeTermsMemberList class members, see the CommitteeTermsMemberList Members topic.

Public Instance Properties

AccessKey (inherited from WebControl) | Gets or sets the access key that allows you to quickly navigate to the Web server control.
Application (inherited from WebFormComponentBase) | Returns an instance of the AptifyApplication object
AppRelativeTemplateSourceDirectory (inherited from Control) | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control.
Attributes (inherited from WebControl) | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control.
BackColor (inherited from WebControl) | Gets or sets the background color of the Web server control.
BindingContainer (inherited from Control) | Gets the control that contains this control's data binding.
BorderColor (inherited from WebControl) | Gets or sets the border color of the Web control.
BorderStyle (inherited from WebControl) | Gets or sets the border style of the Web server control.
BorderWidth (inherited from WebControl) | Gets or sets the border width of the Web server control.
ClientID (inherited from Control) | Gets the server control identifier generated by ASP.NET.
Control (inherited from WebFormComponentBase) |
Controls (inherited from CompositeControl) | Gets a ControlCollection object that represents the child controls in a CompositeControl.
ControlStyle (inherited from WebControl) | Gets the style of the Web server control. This property is used primarily by control developers.
ControlStyleCreated (inherited from WebControl) | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers.
CssClass (inherited from WebControl) | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.
DataAction (inherited from WebFormComponentBase) | Returns an instance of the Aptify DataAction object
DataControl (inherited from WebFormComponentBase) | Adds a reference to the object for the data control. In the case of it being added, the reference to the bound control base object is added to the data controls collection.
DataField (inherited from WebDataFieldFormComponentBase) |
DeferredLoading | This property determines if the control will load only upon the first time it is focused upon, as opposed to being pre-loaded on the server. If this property is set to True, instead of rendering any content upon its initial load, it will simply emit a small client side element that when first focused on, will create an inline frame to display the view.
DisableGEDataTransfer (inherited from WebFormComponentBase) |
Edit (inherited from WebDataFieldFormComponentBase) |
Enabled (inherited from WebDataFieldFormComponentBase) |
EnableTheming (inherited from WebControl) | Gets or sets a value indicating whether themes apply to this control.
EnableViewState (inherited from Control) | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client.
FillHeight (inherited from WebFormComponentBase) | Determines if the control will fill the parent container's height at run time on the client-side (done via client-side Java Script). Maps to the fillHeight run-time HTML element attribute.
FillHeightMargin (inherited from WebFormComponentBase) | This property is only used if FillHeight is set to True. If FillHeight is set to True, this property determines the margin to use on the bottom side of the control when filling the container's height. This property specifies the number of pixels of space to be left on the bottom side of the control between the control's edge and the container's edge.
FillIgnoreChildren (inherited from WebFormComponentBase) | Determines if the control's children will be evaluated for resizing or not. The default value for this property is True, which results in the children of the control NOT being evaluated for resizing. Sub-classes can override this as required, as can individual instances of the class being used at run-time or design-time. It is important to leave this property set to True as much as possible as it reduces run-time resizing overhead.
FillWidth (inherited from WebFormComponentBase) | Determines if the control will fill the parent container's width at run time on the client-side (done via client-side Java Script). Maps to the fillWidth run-time HTML element attribute.
FillWidthMargin (inherited from WebFormComponentBase) | This property is only used if FillWidth is set to True. If FillWidth is set to True, this property determines the margin to use on the right side of the control when filling the container's width. This property specifies the number of pixels of space to be left on the right side of the control between the control's edge and the container's edge.
Font (inherited from WebDataFieldFormComponentBase) |
ForeColor (inherited from WebControl) | Gets or sets the foreground color (typically the color of the text) of the Web server control.
FormTemplateContext (inherited from WebFormComponentBase) |
HasAttributes (inherited from WebControl) | Gets a value indicating whether the control has attributes set.
Height (inherited from WebControl) | Gets or sets the height of the Web server control.
ID (inherited from Control) | Gets or sets the programmatic identifier assigned to the server control.
LabelFont (inherited from WebDataFieldFormComponentBase) |
LabelRequiredFont (inherited from WebDataFieldFormComponentBase) |
LabelText (inherited from WebDataFieldFormComponentBase) |
LabelTextAlign (inherited from WebDataFieldFormComponentBase) |
LabelWidth (inherited from WebDataFieldFormComponentBase) |
MaxHeight |
NamingContainer (inherited from Control) | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value.
Page (inherited from Control) | Gets a reference to the Page instance that contains the server control.
Parent (inherited from Control) | Gets a reference to the server control's parent control in the page control hierarchy.
Read (inherited from WebDataFieldFormComponentBase) |
Required (inherited from WebDataFieldFormComponentBase) |
ShowLabel (inherited from WebDataFieldFormComponentBase) |
Site (inherited from Control) | Gets information about the container that hosts the current control when rendered on a design surface.
SkinID (inherited from WebControl) | Gets or sets the skin to apply to the control.
Style (inherited from WebControl) | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control.
TabIndex (inherited from WebControl) | Gets or sets the tab index of the Web server control.
TemplateControl (inherited from Control) | Gets or sets a reference to the template that contains this control.
TemplateSourceDirectory (inherited from Control) | Gets the virtual directory of the Page or UserControl that contains the current server control.
Text |
ToolTip (inherited from WebControl) | Gets or sets the text displayed when the mouse pointer hovers over the Web server control.
UniqueID (inherited from Control) | Gets the unique, hierarchically qualified identifier for the server control.
Value (inherited from WebDataFieldFormComponentBase) |
Visible (inherited from Control) | Gets or sets a value that indicates whether a server control is rendered as UI on the page.
Width (inherited from WebControl) | Gets or sets the width of the Web server control.

Protected Instance Properties

Adapter (inherited from Control) | Gets the browser-specific adapter for the control.
ChildControlsCreated (inherited from Control) | Gets a value that indicates whether the server control's child controls have been created.
ClientIDSeparator (inherited from Control) | Gets a character value representing the separator character used in the ClientID property.
ContainerTable (inherited from WebDataFieldFormComponentBase) |
ControlCell (inherited from WebDataFieldFormComponentBase) |
ErrorLabel (inherited from WebFormComponentBase) | This label is an internal feature of the base class that can be used by sub-classes to display error messages to the user when required. Set the ErrorLabel.Visible = True first, and then set the ErrorLabel.Text to the appropriate message for the user.
Events (inherited from Control) | Gets a list of event handler delegates for the control. This property is read-only.
ExtendedType (inherited from WebDataFieldFormComponentBase) |
ExtenderCell (inherited from WebDataFieldFormComponentBase) |
HasChildViewState (inherited from Control) | Gets a value indicating whether the current server control's child controls have any saved view-state settings.
IdSeparator (inherited from Control) | Gets the character used to separate control identifiers.
InternalControl (inherited from WebDataFieldFormComponentBase) |
IsTrackingViewState (inherited from Control) | Gets a value that indicates whether the server control is saving changes to its view state.
LabelCell (inherited from WebDataFieldFormComponentBase) |
LabelControl (inherited from WebDataFieldFormComponentBase) |
LoadViewStateByID (inherited from Control) | Gets a value indicating whether the control participates in loading its view state by ID instead of index.
MyApplication (inherited from WebFormComponentBase) |
OldValue (inherited from WebDataFieldFormComponentBase) |
TagKey (inherited from WebControl) | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers.
TagName (inherited from WebControl) | Gets the name of the control tag. This property is used primarily by control developers.
UserCredential (inherited from WebFormComponentBase) |
ViewState (inherited from Control) | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page.
ViewStateIgnoresCase (inherited from Control) | Gets a value that indicates whether the StateBag object is case-insensitive.

Protected Internal Instance Properties

Context (inherited from Control) | Gets the HttpContext object associated with the server control for the current Web request.
DesignMode (inherited from Control) | Gets a value indicating whether a control is being used on a design surface.
IsChildControlStateCleared (inherited from Control) | Gets a value indicating whether controls contained within this control have control state.
IsEnabled (inherited from WebControl) | Gets a value indicating whether the control is enabled.
IsViewStateEnabled (inherited from Control) | Gets a value indicating whether view state is enabled for this control.
StopInitialization (inherited from WebDataFieldFormComponentBase) |

See Also

CommitteeTermsMemberList Class | Aptify.Applications.Persons.WebAccess Namespace


DeferredLoading Property

Aptify 5.0 Software Development Kit (SDK)

CommitteeTermsMemberList.DeferredLoading Property

This property determines if the control will load only upon the first time it is focused upon, as opposed to being pre-loaded on the server. If this property is set to True, instead of rendering any content upon its initial load, it will simply emit a small client side element that when first focused on, will create an inline frame to display the view.

public virtual Boolean DeferredLoading {get; set;}

Property Value

Remarks

See Also

CommitteeTermsMemberList Class | Aptify.Applications.Persons.WebAccess Namespace


MaxHeight Property

Aptify 5.0 Software Development Kit (SDK)

CommitteeTermsMemberList.MaxHeight Property

public override Int32 MaxHeight {get;}

See Also

CommitteeTermsMemberList Class | Aptify.Applications.Persons.WebAccess Namespace


Text Property

Aptify 5.0 Software Development Kit (SDK)

CommitteeTermsMemberList.Text Property

public override String Text {get; set;}

See Also

CommitteeTermsMemberList Class | Aptify.Applications.Persons.WebAccess Namespace


CommitteeTermsMemberList Methods

The methods of the CommitteeTermsMemberList class are listed below. For a complete list of CommitteeTermsMemberList class members, see the CommitteeTermsMemberList Members topic.

Public Instance Methods

ApplyStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers.
ApplyStyleSheetSkin (inherited from Control) | Applies the style properties defined in the page style sheet to the control.
ClearData (inherited from WebFormComponentBase) |
CopyBaseAttributes (inherited from WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers.
DataBind (inherited from CompositeControl) | Overloaded. Binds a data source to the CompositeControl and all its child controls.
Dispose (inherited from Control) | Enables a server control to perform final clean up before it is released from memory.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindControl (inherited from Control) | Overloaded. Searches the current naming container for a server control with the specified id parameter.
Focus (inherited from Control) | Sets input focus to a control.
FormComponentConfig |
GetCallbackResult | This method is required by ICallbackEventHandler. Result of the Callback gets sent back to the Client-side function by this method. The JavaScript function can be modified to do whatever is necessary with the results.
GetClientCulture (inherited from WebFormComponentBase) | Returns the culture for the client browser based on the first language in the Request.UserLanguages() array
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from WebFormComponentBase) |
GetType (inherited from Object) | Gets the Type of the current instance.
HasControls (inherited from Control) | Determines if the server control contains any child controls.
Hide (inherited from WebFormComponentBase) |
MergeStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers.
RaiseCallbackEvent | This method is required by ICallbackEventHandler. This method is the server-side of the asynchronous callback event. Here is where all the functionality is defined for what to do on a Callback.
Refresh | Overrides Refresh to handle setting control enabled bits right before rendering occurs
RenderBeginTag (inherited from WebControl) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers.
RenderControl (inherited from Control) | Overloaded. Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
RenderEndTag (inherited from WebControl) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers.
ResolveClientUrl (inherited from Control) | Gets a URL that can be used by the browser.
ResolveUrl (inherited from Control) | Converts a URL into one that is usable on the requesting client.
SaveRecord | Logic that gets executed when a Term Member needs to be edited.
SetRenderMethodDelegate (inherited from Control) | Assigns an event handler delegate to render the server control and its content into its parent control.
SetUserCredential (inherited from WebFormComponentBase) |
Show (inherited from WebFormComponentBase) | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.
TransferDataToObject (inherited from WebDataFieldFormComponentBase) |

Protected Instance Methods

AddAttributesToRender (inherited from WebControl) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers.
AddParsedSubObject (inherited from Control) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object.
AddRecord |
BuildGrid | This method is responsible for building the grid data source and binding to it based on the information inside the sub-type that this sub-type control is bound to
BuildProfileTree (inherited from Control) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page.
ClearChildControlState (inherited from Control) | Deletes the control-state information for the server control's child controls.
ClearChildState (inherited from Control) | Deletes the view-state and control-state information for all the server control's child controls.
ClearChildViewState (inherited from Control) | Deletes the view-state information for all the server control's child controls.
CreateChildControls |
CreateControlCollection (inherited from Control) | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control.
CreateControlStyle (inherited from WebControl) | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers.
DataBind (inherited from Control) | Overloaded. Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.
DataBindChildren (inherited from Control) | Binds a data source to the server control's child controls.
DeleteRecord | Logic that gets executed when a Term Member needs to be Deleted.
EnsureChildControls (inherited from Control) | Determines whether the server control contains child controls. If it does not, it creates child controls.
EnsureID (inherited from Control) | Creates an identifier for controls that do not have an identifier assigned.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FindControl (inherited from Control) | Overloaded. Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl method.
GetClientDateFormat (inherited from WebFormComponentBase) | Returns a string showing the preferred date format for the connected user.
GetClientTimeFormat (inherited from WebFormComponentBase) | Returns a string showing the preferred time format for the connected user.
GetDesignModeState (inherited from Control) | Gets design-time data for a control.
GetNextPixelParent (inherited from WebDataFieldFormComponentBase) | This method attempts to go up the control hierarchy until the next parent control is found that has a pixel-based width/height.
GetProperty (inherited from WebFormComponentBase) | Overloaded.
GetStandardWidthMargin (inherited from WebDataFieldFormComponentBase) | Returns the standard calculation result for the width margin to use on controls that are set to fill the parent's width. Override this method to adjust the width margins for specific controls.
GetUserCredentialsFromSession (inherited from WebFormComponentBase) | Returns a User Credentials object from the Session State, if available. This is used when ViewState is not yet recreated, or during Callback when ViewState is unavailable
HasEvents (inherited from Control) | Returns a value indicating whether events are registered for the control or any child controls.
InitializeGridLevel |
InitializeGridProperties | This method is called when the grid's properties need to be initialized
IsLiteralContent (inherited from Control) | Determines if the server control holds only literal content.
LoadViewState (inherited from WebDataFieldFormComponentBase) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnBubbleEvent (inherited from Control) | Determines whether the event for the server control is passed up the page's UI server control hierarchy.
OnDataBinding (inherited from Control) | Raises the DataBinding event.
OnInit (inherited from WebFormComponentBase) |
OnPreRender (inherited from WebDataFieldFormComponentBase) | Overriden version of OnPreRender(), calls base OnPreRender() and calls SetupInternalControlSizing() to ensure controls are sized properly.
RaiseBubbleEvent (inherited from Control) | Assigns any sources of the event and its information to the control's parent.
RaiseValueChanged (inherited from WebFormComponentBase) |
RecreateChildControls (inherited from CompositeControl) | Recreates the child controls n a control derived from CompositeControl.
Render (inherited from WebDataFieldFormComponentBase) |
RenderControl (inherited from Control) | Overloaded. Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.
RequiredGECheck (inherited from WebFormComponentBase) |
RequiredPropertiesCheck (inherited from WebDataFieldFormComponentBase) |
ResolveAdapter (inherited from Control) | Gets the control adapter responsible for rendering the specified control.
SaveViewState (inherited from WebDataFieldFormComponentBase) |
SetControlMetaData (inherited from WebDataFieldFormComponentBase) |
SetDesignModeState (inherited from Control) | Sets design-time data for a control.
SetExclusions (inherited from WebDataFieldFormComponentBase) |
SetSecurity (inherited from WebDataFieldFormComponentBase) |
SetupClientHandlers | This method is responsible for setting up the Callback functionality. Currently, this is being used for deleting SubType records. The Result and Error JavaScript functions are defined in WebSubType.js, while the Callback and Delete button's click event are setup below.
SetupControlCellPadding (inherited from WebDataFieldFormComponentBase) | This method is responsible for setting up padding for the control cell within the Data Field Control so that the internal control is not clipped.
SetupInternalControlSizing (inherited from WebDataFieldFormComponentBase) | This method handles the general setup of internal control component sizing and can be overriden as required by subclasses to handle specialized sizing/layout requirements.
SetupLabelText (inherited from WebDataFieldFormComponentBase) | This method internally sets the label caption. If a value of Nothing/Null or a blank string is provided to this method, the internal meta-data for the field is used instead. In addition, this method will automatically map a field's culture in order to change the display name based on the culture of the field if necessary, but that is only done if the LabelCaption parameter exactly matches the DisplayName of the field. Override this method to change the base functionality.
SetValueFromGE (inherited from WebDataFieldFormComponentBase) |
TrackViewState (inherited from WebControl) | Causes the control to track changes to its view state so they can be stored in the object's ViewState property.

Protected Internal Instance Methods

AddedControl (inherited from Control) | Called after a child control is added to the Controls collection of the Control object.
LoadControlState (inherited from Control) | Restores control-state information from a previous page request that was saved by the SaveControlState method.
MapPathSecure (inherited from Control) | Retrieves the physical path that a virtual path, either absolute or relative, maps to.
OnLoad (inherited from Control) | Raises the Load event.
OnUnload (inherited from Control) | Raises the Unload event.
OpenFile (inherited from Control) | Gets a Stream used to read a file.
RemovedControl (inherited from Control) | Called after a control is removed from the Controls collection of another control.
RenderChildren (inherited from Control) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client.
RenderContents (inherited from WebControl) | Renders the contents of the control to the specified writer. This method is used primarily by control developers.
SaveControlState (inherited from Control) | Saves any server control state changes that have occurred since the time the page was posted back to the server.

See Also

CommitteeTermsMemberList Class | Aptify.Applications.Persons.WebAccess Namespace


CommitteeTermsMemberList.AddRecord Method

protected virtual void AddRecord(
AptifyGenericEntityBase TermGE,
AptifyGenericEntityBase NewTermMemberGE
);

See Also

CommitteeTermsMemberList Class | Aptify.Applications.Persons.WebAccess Namespace


CommitteeTermsMemberList.BuildGrid Method

This method is responsible for building the grid data source and binding to it based on the information inside the sub-type that this sub-type control is bound to

protected virtual void BuildGrid();

Remarks

See Also

CommitteeTermsMemberList Class | Aptify.Applications.Persons.WebAccess Namespace


CommitteeTermsMemberList.CreateChildControls Method

protected override void CreateChildControls();

See Also

CommitteeTermsMemberList Class | Aptify.Applications.Persons.WebAccess Namespace


CommitteeTermsMemberList.DeleteRecord Method

Logic that gets executed when a Term Member needs to be Deleted.

protected virtual void DeleteRecord();

Remarks

See Also

CommitteeTermsMemberList Class | Aptify.Applications.Persons.WebAccess Namespace


CommitteeTermsMemberList.FormComponentConfig Method

public override void FormComponentConfig(
AptifyFormTemplateContext FormTemplateContext
);

Implements

IWebFormComponent.

See Also

CommitteeTermsMemberList Class | Aptify.Applications.Persons.WebAccess Namespace


CommitteeTermsMemberList.GetCallbackResult Method

This method is required by ICallbackEventHandler. Result of the Callback gets sent back to the Client-side function by this method. The JavaScript function can be modified to do whatever is necessary with the results.

public string GetCallbackResult();

Return Value

Implements

ICallbackEventHandler.

Remarks

See Also

CommitteeTermsMemberList Class | Aptify.Applications.Persons.WebAccess Namespace


CommitteeTermsMemberList.InitializeGridLevel Method

protected virtual void InitializeGridLevel();

See Also

CommitteeTermsMemberList Class | Aptify.Applications.Persons.WebAccess Namespace


CommitteeTermsMemberList.InitializeGridProperties Method

This method is called when the grid's properties need to be initialized

protected virtual void InitializeGridProperties();

Remarks

See Also

CommitteeTermsMemberList Class | Aptify.Applications.Persons.WebAccess Namespace


CommitteeTermsMemberList.RaiseCallbackEvent Method

This method is required by ICallbackEventHandler. This method is the server-side of the asynchronous callback event. Here is where all the functionality is defined for what to do on a Callback.

public void RaiseCallbackEvent(
String eventArgument
);

Parameters

eventArgument
eventArgument is a string defined on the JavaScript side. This string must be delimited by the '|' (pipe) character. The first parameter in this string should be the identifier used to determine what action to take. For example, 'DELETE' is passed in as the first parameter in this string for SubType record deletion.

Implements

ICallbackEventHandler.

Remarks

Currently, the Callback is only setup to handle SubType record deletion. This method maintains a session variable of all the records that are to be deleted when the TopLevel entity is saved. WebDataControl has been modified to check this session variable on Save. The RaiseCallbackEvent can be further extended to handle other callbacks.

See Also

CommitteeTermsMemberList Class | Aptify.Applications.Persons.WebAccess Namespace


CommitteeTermsMemberList.Refresh Method

Overrides Refresh to handle setting control enabled bits right before rendering occurs

public override void Refresh();

Implements

IWebFormComponent.

Remarks

See Also

CommitteeTermsMemberList Class | Aptify.Applications.Persons.WebAccess Namespace


CommitteeTermsMemberList.SaveRecord Method

Logic that gets executed when a Term Member needs to be edited.

public virtual string SaveRecord(
AptifyGenericEntityBase TermGE,
AptifyGenericEntityBase NewTermMemberGE,
AptifyGenericEntityBase OldTermMemberGE
);

Remarks

See Also

CommitteeTermsMemberList Class | Aptify.Applications.Persons.WebAccess Namespace


CommitteeTermsMemberList.SetupClientHandlers Method

This method is responsible for setting up the Callback functionality. Currently, this is being used for deleting SubType records. The Result and Error JavaScript functions are defined in WebSubType.js, while the Callback and Delete button's click event are setup below.

protected virtual void SetupClientHandlers();

Remarks

See Also

CommitteeTermsMemberList Class | Aptify.Applications.Persons.WebAccess Namespace


PersonCompaniesWebLayout Class

For a list of all members of this type, see PersonCompaniesWebLayout Members.

System.Object
Control
WebControl
CompositeControl
WebFormTemplateLayout
PersonCompaniesWebLayout

public class PersonCompaniesWebLayout : WebFormTemplateLayout

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Persons.WebAccess

Assembly: AptifyPersonCompaniesWebGUI (in AptifyPersonCompaniesWebGUI.dll)

See Also

PersonCompaniesWebLayout Members | Aptify.Applications.Persons.WebAccess Namespace


PersonCompaniesWebLayout Members

PersonCompaniesWebLayout overview

Public Instance Constructors

PersonCompaniesWebLayout Constructor Initializes a new instance of the PersonCompaniesWebLayout class.

Public Instance Properties

AccessKey (inherited from WebControl) | Gets or sets the access key that allows you to quickly navigate to the Web server control.
ApplicationObject (inherited from WebFormTemplateLayout) | Returns an instance of the AptifyApplication class
AppRelativeTemplateSourceDirectory (inherited from Control) | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control.
Attributes (inherited from WebControl) | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control.
BackColor (inherited from WebControl) | Gets or sets the background color of the Web server control.
BindingContainer (inherited from Control) | Gets the control that contains this control's data binding.
BorderColor (inherited from WebControl) | Gets or sets the border color of the Web control.
BorderStyle (inherited from WebControl) | Gets or sets the border style of the Web server control.
BorderWidth (inherited from WebControl) | Gets or sets the border width of the Web server control.
ClientID (inherited from Control) | Gets the server control identifier generated by ASP.NET.
Control (inherited from WebFormTemplateLayout) |
Controls (inherited from CompositeControl) | Gets a ControlCollection object that represents the child controls in a CompositeControl.
ControlStyle (inherited from WebControl) | Gets the style of the Web server control. This property is used primarily by control developers.
ControlStyleCreated (inherited from WebControl) | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers.
CssClass (inherited from WebControl) | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.
Enabled (inherited from WebControl) | Gets or sets a value indicating whether the Web server control is enabled.
EnableTheming (inherited from WebControl) | Gets or sets a value indicating whether themes apply to this control.
EnableViewState (inherited from Control) | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client.
FillHeight (inherited from WebFormTemplateLayout) | This property determines if this element will automatically fill the height of the document window in the browser. The default value is False. Set this value to True in order to ensure proper sizing of the Form Template Layout control and its child controls
FillHeightMargin (inherited from WebFormTemplateLayout) | Only used if FillHeight=True, Specifies the number of pixels of space to between the bottom of the control and its parent's bottom edge
FillWidth (inherited from WebFormTemplateLayout) | This property determines if this element will automatically fill the width of the document window in the browser. The default value is False. Set this value to True in order to ensure proper sizing of the Form Template Layout control and its child controls
FillWidthMargin (inherited from WebFormTemplateLayout) | Only used if FillWidth=True, Specifies the number of pixles of space to leave at the right of the control between its right side and the right of its parent control
Font (inherited from WebControl) | Gets the font properties associated with the Web server control.
ForeColor (inherited from WebControl) | Gets or sets the foreground color (typically the color of the text) of the Web server control.
FormTemplateContext (inherited from WebFormTemplateLayout) |
FormTemplateID (inherited from WebFormTemplateLayout) |
FormTemplateMetaData (inherited from WebFormTemplateLayout) | Returns the meta-data for the currently loaded form template. This property is only available after FormComponentConfig() has been called.
HasAttributes (inherited from WebControl) | Gets a value indicating whether the control has attributes set.
Height (inherited from WebControl) | Gets or sets the height of the Web server control.
ID (inherited from Control) | Gets or sets the programmatic identifier assigned to the server control.
LeftOffset (inherited from WebFormTemplateLayout) |
NamingContainer (inherited from Control) | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value.
Page (inherited from Control) | Gets a reference to the Page instance that contains the server control.
Parent (inherited from Control) | Gets a reference to the server control's parent control in the page control hierarchy.
RefreshDatabase (inherited from WebFormTemplateLayout) | Determines if the Form Template Cache will be reloaded or not, Defaults to False
Site (inherited from Control) | Gets information about the container that hosts the current control when rendered on a design surface.
SkinID (inherited from WebControl) | Gets or sets the skin to apply to the control.
Style (inherited from WebControl) | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control.
TabIndex (inherited from WebControl) | Gets or sets the tab index of the Web server control.
TemplateControl (inherited from Control) | Gets or sets a reference to the template that contains this control.
TemplateSourceDirectory (inherited from Control) | Gets the virtual directory of the Page or UserControl that contains the current server control.
ToolTip (inherited from WebControl) | Gets or sets the text displayed when the mouse pointer hovers over the Web server control.
TopOffset (inherited from WebFormTemplateLayout) |
UniqueID (inherited from Control) | Gets the unique, hierarchically qualified identifier for the server control.
Visible (inherited from Control) | Gets or sets a value that indicates whether a server control is rendered as UI on the page.
Width (inherited from WebControl) | Gets or sets the width of the Web server control.

Public Instance Methods

ApplyStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers.
ApplyStyleSheetSkin (inherited from Control) | Applies the style properties defined in the page style sheet to the control.
CopyBaseAttributes (inherited from WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers.
DataBind (inherited from CompositeControl) | Overloaded. Binds a data source to the CompositeControl and all its child controls.
Dispose (inherited from Control) | Enables a server control to perform final clean up before it is released from memory.
DoControlLoading (inherited from WebFormTemplateLayout) | This method loads controls from the Form Template Layout meta-data definition
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindControl (inherited from Control) | Overloaded. Searches the current naming container for a server control with the specified id parameter.
Focus (inherited from Control) | Sets input focus to a control.
FormComponentConfig |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from WebFormTemplateLayout) |
GetType (inherited from Object) | Gets the Type of the current instance.
HasControls (inherited from Control) | Determines if the server control contains any child controls.
Hide (inherited from WebFormTemplateLayout) |
MergeStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers.
Refresh (inherited from WebFormTemplateLayout) |
RenderBeginTag (inherited from WebControl) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers.
RenderControl (inherited from Control) | Overloaded. Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
RenderEndTag (inherited from WebControl) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers.
ResolveClientUrl (inherited from Control) | Gets a URL that can be used by the browser.
ResolveUrl (inherited from Control) | Converts a URL into one that is usable on the requesting client.
SetRenderMethodDelegate (inherited from Control) | Assigns an event handler delegate to render the server control and its content into its parent control.
Show (inherited from WebFormTemplateLayout) | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.
TransferDataToObject (inherited from WebFormTemplateLayout) |

Public Instance Events

DataBinding (inherited from WebFormTemplateLayout)
Disposed (inherited from WebFormTemplateLayout)
Init (inherited from WebFormTemplateLayout)
Load (inherited from WebFormTemplateLayout)
PreRender (inherited from WebFormTemplateLayout)
Unload (inherited from WebFormTemplateLayout)
ValueChanged (inherited from WebFormTemplateLayout)

Protected Instance Fields

m_bFillHeight (inherited from WebFormTemplateLayout)
m_bFillWidth (inherited from WebFormTemplateLayout)
m_iFillHeightMargin (inherited from WebFormTemplateLayout)
m_iFillWidthMargin (inherited from WebFormTemplateLayout)

Protected Instance Properties

Adapter (inherited from Control) | Gets the browser-specific adapter for the control.
ChildControlsCreated (inherited from Control) | Gets a value that indicates whether the server control's child controls have been created.
ClientIDSeparator (inherited from Control) | Gets a character value representing the separator character used in the ClientID property.
Events (inherited from Control) | Gets a list of event handler delegates for the control. This property is read-only.
HasChildViewState (inherited from Control) | Gets a value indicating whether the current server control's child controls have any saved view-state settings.
IdSeparator (inherited from Control) | Gets the character used to separate control identifiers.
IsTrackingViewState (inherited from Control) | Gets a value that indicates whether the server control is saving changes to its view state.
LoadViewStateByID (inherited from Control) | Gets a value indicating whether the control participates in loading its view state by ID instead of index.
TagKey (inherited from WebControl) | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers.
TagName (inherited from WebControl) | Gets the name of the control tag. This property is used primarily by control developers.
ViewState (inherited from Control) | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page.
ViewStateIgnoresCase (inherited from Control) | Gets a value that indicates whether the StateBag object is case-insensitive.

Protected Instance Methods

AddAttributesToRender (inherited from WebControl) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers.
AddParsedSubObject (inherited from Control) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object.
BuildProfileTree (inherited from Control) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page.
ClearChildControlState (inherited from Control) | Deletes the control-state information for the server control's child controls.
ClearChildState (inherited from Control) | Deletes the view-state and control-state information for all the server control's child controls.
ClearChildViewState (inherited from Control) | Deletes the view-state information for all the server control's child controls.
CreateChildControls |
CreateControlCollection (inherited from Control) | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control.
CreateControlStyle (inherited from WebControl) | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers.
DataBind (inherited from Control) | Overloaded. Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.
DataBindChildren (inherited from Control) | Binds a data source to the server control's child controls.
EnableFormComponent (inherited from WebFormTemplateLayout) | This method is responsible for enabling or disabling the specified control based on the name of the component or the data field. Internally implemented by calling GetFormComponent()
EnsureChildControls (inherited from Control) | Determines whether the server control contains child controls. If it does not, it creates child controls.
EnsureID (inherited from Control) | Creates an identifier for controls that do not have an identifier assigned.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FindControl (inherited from Control) | Overloaded. Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl method.
GetDesignModeState (inherited from Control) | Gets design-time data for a control.
GetFormComponent (inherited from WebFormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
HasEvents (inherited from Control) | Returns a value indicating whether events are registered for the control or any child controls.
IsFormComponent (inherited from WebFormTemplateLayout) | This method determines if the provided component is a valid Aptify Form Component, which is determined by checking to see if any of the following conditions is True: 1) Derived from WebFormCompnentBase 2) Implements IWebFormComponent 3) Derived from WebFormTemplateLayout 4) Derived from WebFormTemplateTab
IsLiteralContent (inherited from Control) | Determines if the server control holds only literal content.
LoadViewState (inherited from WebControl) | Restores view-state information from a previous request that was saved with the SaveViewState method.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnBubbleEvent (inherited from Control) | Determines whether the event for the server control is passed up the page's UI server control hierarchy.
OnDataBinding (inherited from Control) | Raises the DataBinding event.
OnInit (inherited from WebFormTemplateLayout) |
RaiseBubbleEvent (inherited from Control) | Assigns any sources of the event and its information to the control's parent.
ReconstituteComponentCollection (inherited from WebFormTemplateLayout) | This method will rebuild the internal Form Component collection from the ASP.NET control hierarchy.
RecreateChildControls (inherited from CompositeControl) | Recreates the child controls n a control derived from CompositeControl.
RenderControl (inherited from Control) | Overloaded. Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.
ResolveAdapter (inherited from Control) | Gets the control adapter responsible for rendering the specified control.
SaveViewState (inherited from WebControl) | Saves any state that was modified after the TrackViewState method was invoked.
SetDesignModeState (inherited from Control) | Sets design-time data for a control.
TrackViewState (inherited from WebControl) | Causes the control to track changes to its view state so they can be stored in the object's ViewState property.

Protected Internal Instance Properties

Context (inherited from Control) | Gets the HttpContext object associated with the server control for the current Web request.
DesignMode (inherited from Control) | Gets a value indicating whether a control is being used on a design surface.
IsChildControlStateCleared (inherited from Control) | Gets a value indicating whether controls contained within this control have control state.
IsEnabled (inherited from WebControl) | Gets a value indicating whether the control is enabled.
IsViewStateEnabled (inherited from Control) | Gets a value indicating whether view state is enabled for this control.

Protected Internal Instance Methods

AddedControl (inherited from Control) | Called after a child control is added to the Controls collection of the Control object.
LoadControlState (inherited from Control) | Restores control-state information from a previous page request that was saved by the SaveControlState method.
MapPathSecure (inherited from Control) | Retrieves the physical path that a virtual path, either absolute or relative, maps to.
OnLoad (inherited from Control) | Raises the Load event.
OnPreRender (inherited from Control) | Raises the PreRender event.
OnUnload (inherited from Control) | Raises the Unload event.
OpenFile (inherited from Control) | Gets a Stream used to read a file.
RemovedControl (inherited from Control) | Called after a control is removed from the Controls collection of another control.
Render (inherited from CompositeControl) | Writes the CompositeControl content to the specified HtmlTextWriter object, for display on the client.
RenderChildren (inherited from Control) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client.
RenderContents (inherited from WebControl) | Renders the contents of the control to the specified writer. This method is used primarily by control developers.
SaveControlState (inherited from Control) | Saves any server control state changes that have occurred since the time the page was posted back to the server.

See Also

PersonCompaniesWebLayout Class | Aptify.Applications.Persons.WebAccess Namespace


PersonCompaniesWebLayout Constructor

Initializes a new instance of the PersonCompaniesWebLayout class.

public PersonCompaniesWebLayout();

See Also

PersonCompaniesWebLayout Class | Aptify.Applications.Persons.WebAccess Namespace


PersonCompaniesWebLayout Methods

The methods of the PersonCompaniesWebLayout class are listed below. For a complete list of PersonCompaniesWebLayout class members, see the PersonCompaniesWebLayout Members topic.

Public Instance Methods

ApplyStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers.
ApplyStyleSheetSkin (inherited from Control) | Applies the style properties defined in the page style sheet to the control.
CopyBaseAttributes (inherited from WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers.
DataBind (inherited from CompositeControl) | Overloaded. Binds a data source to the CompositeControl and all its child controls.
Dispose (inherited from Control) | Enables a server control to perform final clean up before it is released from memory.
DoControlLoading (inherited from WebFormTemplateLayout) | This method loads controls from the Form Template Layout meta-data definition
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindControl (inherited from Control) | Overloaded. Searches the current naming container for a server control with the specified id parameter.
Focus (inherited from Control) | Sets input focus to a control.
FormComponentConfig |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from WebFormTemplateLayout) |
GetType (inherited from Object) | Gets the Type of the current instance.
HasControls (inherited from Control) | Determines if the server control contains any child controls.
Hide (inherited from WebFormTemplateLayout) |
MergeStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers.
Refresh (inherited from WebFormTemplateLayout) |
RenderBeginTag (inherited from WebControl) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers.
RenderControl (inherited from Control) | Overloaded. Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
RenderEndTag (inherited from WebControl) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers.
ResolveClientUrl (inherited from Control) | Gets a URL that can be used by the browser.
ResolveUrl (inherited from Control) | Converts a URL into one that is usable on the requesting client.
SetRenderMethodDelegate (inherited from Control) | Assigns an event handler delegate to render the server control and its content into its parent control.
Show (inherited from WebFormTemplateLayout) | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.
TransferDataToObject (inherited from WebFormTemplateLayout) |

Protected Instance Methods

AddAttributesToRender (inherited from WebControl) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers.
AddParsedSubObject (inherited from Control) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object.
BuildProfileTree (inherited from Control) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page.
ClearChildControlState (inherited from Control) | Deletes the control-state information for the server control's child controls.
ClearChildState (inherited from Control) | Deletes the view-state and control-state information for all the server control's child controls.
ClearChildViewState (inherited from Control) | Deletes the view-state information for all the server control's child controls.
CreateChildControls |
CreateControlCollection (inherited from Control) | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control.
CreateControlStyle (inherited from WebControl) | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers.
DataBind (inherited from Control) | Overloaded. Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.
DataBindChildren (inherited from Control) | Binds a data source to the server control's child controls.
EnableFormComponent (inherited from WebFormTemplateLayout) | This method is responsible for enabling or disabling the specified control based on the name of the component or the data field. Internally implemented by calling GetFormComponent()
EnsureChildControls (inherited from Control) | Determines whether the server control contains child controls. If it does not, it creates child controls.
EnsureID (inherited from Control) | Creates an identifier for controls that do not have an identifier assigned.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FindControl (inherited from Control) | Overloaded. Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl method.
GetDesignModeState (inherited from Control) | Gets design-time data for a control.
GetFormComponent (inherited from WebFormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
HasEvents (inherited from Control) | Returns a value indicating whether events are registered for the control or any child controls.
IsFormComponent (inherited from WebFormTemplateLayout) | This method determines if the provided component is a valid Aptify Form Component, which is determined by checking to see if any of the following conditions is True: 1) Derived from WebFormCompnentBase 2) Implements IWebFormComponent 3) Derived from WebFormTemplateLayout 4) Derived from WebFormTemplateTab
IsLiteralContent (inherited from Control) | Determines if the server control holds only literal content.
LoadViewState (inherited from WebControl) | Restores view-state information from a previous request that was saved with the SaveViewState method.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnBubbleEvent (inherited from Control) | Determines whether the event for the server control is passed up the page's UI server control hierarchy.
OnDataBinding (inherited from Control) | Raises the DataBinding event.
OnInit (inherited from WebFormTemplateLayout) |
RaiseBubbleEvent (inherited from Control) | Assigns any sources of the event and its information to the control's parent.
ReconstituteComponentCollection (inherited from WebFormTemplateLayout) | This method will rebuild the internal Form Component collection from the ASP.NET control hierarchy.
RecreateChildControls (inherited from CompositeControl) | Recreates the child controls n a control derived from CompositeControl.
RenderControl (inherited from Control) | Overloaded. Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.
ResolveAdapter (inherited from Control) | Gets the control adapter responsible for rendering the specified control.
SaveViewState (inherited from WebControl) | Saves any state that was modified after the TrackViewState method was invoked.
SetDesignModeState (inherited from Control) | Sets design-time data for a control.
TrackViewState (inherited from WebControl) | Causes the control to track changes to its view state so they can be stored in the object's ViewState property.

Protected Internal Instance Methods

AddedControl (inherited from Control) | Called after a child control is added to the Controls collection of the Control object.
LoadControlState (inherited from Control) | Restores control-state information from a previous page request that was saved by the SaveControlState method.
MapPathSecure (inherited from Control) | Retrieves the physical path that a virtual path, either absolute or relative, maps to.
OnLoad (inherited from Control) | Raises the Load event.
OnPreRender (inherited from Control) | Raises the PreRender event.
OnUnload (inherited from Control) | Raises the Unload event.
OpenFile (inherited from Control) | Gets a Stream used to read a file.
RemovedControl (inherited from Control) | Called after a control is removed from the Controls collection of another control.
Render (inherited from CompositeControl) | Writes the CompositeControl content to the specified HtmlTextWriter object, for display on the client.
RenderChildren (inherited from Control) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client.
RenderContents (inherited from WebControl) | Renders the contents of the control to the specified writer. This method is used primarily by control developers.
SaveControlState (inherited from Control) | Saves any server control state changes that have occurred since the time the page was posted back to the server.

See Also

PersonCompaniesWebLayout Class | Aptify.Applications.Persons.WebAccess Namespace


PersonCompaniesWebLayout.CreateChildControls Method

protected override void CreateChildControls();

See Also

PersonCompaniesWebLayout Class | Aptify.Applications.Persons.WebAccess Namespace


PersonCompaniesWebLayout.FormComponentConfig Method

public override void FormComponentConfig(
AptifyFormTemplateContext FormTemplateContext
);

Implements

IWebFormComponent.

See Also

PersonCompaniesWebLayout Class | Aptify.Applications.Persons.WebAccess Namespace


PersonsWebLayout Class

For a list of all members of this type, see PersonsWebLayout Members.

System.Object
Control
WebControl
CompositeControl
WebFormTemplateLayout
PersonsWebLayout

public class PersonsWebLayout : WebFormTemplateLayout

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Persons.WebAccess

Assembly: AptifyPersonsWebGUI (in AptifyPersonsWebGUI.dll)

See Also

PersonsWebLayout Members | Aptify.Applications.Persons.WebAccess Namespace


PersonsWebLayout Members

PersonsWebLayout overview

Public Instance Constructors

PersonsWebLayout Constructor Initializes a new instance of the PersonsWebLayout class.

Public Instance Properties

AccessKey (inherited from WebControl) | Gets or sets the access key that allows you to quickly navigate to the Web server control.
ApplicationObject (inherited from WebFormTemplateLayout) | Returns an instance of the AptifyApplication class
AppRelativeTemplateSourceDirectory (inherited from Control) | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control.
Attributes (inherited from WebControl) | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control.
BackColor (inherited from WebControl) | Gets or sets the background color of the Web server control.
BindingContainer (inherited from Control) | Gets the control that contains this control's data binding.
BorderColor (inherited from WebControl) | Gets or sets the border color of the Web control.
BorderStyle (inherited from WebControl) | Gets or sets the border style of the Web server control.
BorderWidth (inherited from WebControl) | Gets or sets the border width of the Web server control.
ClientID (inherited from Control) | Gets the server control identifier generated by ASP.NET.
Control (inherited from WebFormTemplateLayout) |
Controls (inherited from CompositeControl) | Gets a ControlCollection object that represents the child controls in a CompositeControl.
ControlStyle (inherited from WebControl) | Gets the style of the Web server control. This property is used primarily by control developers.
ControlStyleCreated (inherited from WebControl) | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers.
CssClass (inherited from WebControl) | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.
Enabled (inherited from WebControl) | Gets or sets a value indicating whether the Web server control is enabled.
EnableTheming (inherited from WebControl) | Gets or sets a value indicating whether themes apply to this control.
EnableViewState (inherited from Control) | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client.
FillHeight (inherited from WebFormTemplateLayout) | This property determines if this element will automatically fill the height of the document window in the browser. The default value is False. Set this value to True in order to ensure proper sizing of the Form Template Layout control and its child controls
FillHeightMargin (inherited from WebFormTemplateLayout) | Only used if FillHeight=True, Specifies the number of pixels of space to between the bottom of the control and its parent's bottom edge
FillWidth (inherited from WebFormTemplateLayout) | This property determines if this element will automatically fill the width of the document window in the browser. The default value is False. Set this value to True in order to ensure proper sizing of the Form Template Layout control and its child controls
FillWidthMargin (inherited from WebFormTemplateLayout) | Only used if FillWidth=True, Specifies the number of pixles of space to leave at the right of the control between its right side and the right of its parent control
Font (inherited from WebControl) | Gets the font properties associated with the Web server control.
ForeColor (inherited from WebControl) | Gets or sets the foreground color (typically the color of the text) of the Web server control.
FormTemplateContext (inherited from WebFormTemplateLayout) |
FormTemplateID (inherited from WebFormTemplateLayout) |
FormTemplateMetaData (inherited from WebFormTemplateLayout) | Returns the meta-data for the currently loaded form template. This property is only available after FormComponentConfig() has been called.
HasAttributes (inherited from WebControl) | Gets a value indicating whether the control has attributes set.
Height (inherited from WebControl) | Gets or sets the height of the Web server control.
ID (inherited from Control) | Gets or sets the programmatic identifier assigned to the server control.
LeftOffset (inherited from WebFormTemplateLayout) |
NamingContainer (inherited from Control) | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value.
Page (inherited from Control) | Gets a reference to the Page instance that contains the server control.
Parent (inherited from Control) | Gets a reference to the server control's parent control in the page control hierarchy.
RefreshDatabase (inherited from WebFormTemplateLayout) | Determines if the Form Template Cache will be reloaded or not, Defaults to False
Site (inherited from Control) | Gets information about the container that hosts the current control when rendered on a design surface.
SkinID (inherited from WebControl) | Gets or sets the skin to apply to the control.
Style (inherited from WebControl) | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control.
TabIndex (inherited from WebControl) | Gets or sets the tab index of the Web server control.
TemplateControl (inherited from Control) | Gets or sets a reference to the template that contains this control.
TemplateSourceDirectory (inherited from Control) | Gets the virtual directory of the Page or UserControl that contains the current server control.
ToolTip (inherited from WebControl) | Gets or sets the text displayed when the mouse pointer hovers over the Web server control.
TopOffset (inherited from WebFormTemplateLayout) |
UniqueID (inherited from Control) | Gets the unique, hierarchically qualified identifier for the server control.
Visible (inherited from Control) | Gets or sets a value that indicates whether a server control is rendered as UI on the page.
Width (inherited from WebControl) | Gets or sets the width of the Web server control.

Public Instance Methods

ApplyStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers.
ApplyStyleSheetSkin (inherited from Control) | Applies the style properties defined in the page style sheet to the control.
CopyBaseAttributes (inherited from WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers.
DataBind (inherited from CompositeControl) | Overloaded. Binds a data source to the CompositeControl and all its child controls.
Dispose (inherited from Control) | Enables a server control to perform final clean up before it is released from memory.
DoControlLoading (inherited from WebFormTemplateLayout) | This method loads controls from the Form Template Layout meta-data definition
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindControl (inherited from Control) | Overloaded. Searches the current naming container for a server control with the specified id parameter.
Focus (inherited from Control) | Sets input focus to a control.
FormComponentConfig |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from WebFormTemplateLayout) |
GetType (inherited from Object) | Gets the Type of the current instance.
HasControls (inherited from Control) | Determines if the server control contains any child controls.
Hide (inherited from WebFormTemplateLayout) |
MergeStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers.
Refresh |
RenderBeginTag (inherited from WebControl) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers.
RenderControl (inherited from Control) | Overloaded. Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
RenderEndTag (inherited from WebControl) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers.
ResolveClientUrl (inherited from Control) | Gets a URL that can be used by the browser.
ResolveUrl (inherited from Control) | Converts a URL into one that is usable on the requesting client.
SetRenderMethodDelegate (inherited from Control) | Assigns an event handler delegate to render the server control and its content into its parent control.
Show | Overloaded.
Show (inherited from WebFormTemplateLayout) | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.
TransferDataToObject (inherited from WebFormTemplateLayout) |

Public Instance Events

DataBinding (inherited from WebFormTemplateLayout)
Disposed (inherited from WebFormTemplateLayout)
Init (inherited from WebFormTemplateLayout)
Load (inherited from WebFormTemplateLayout)
PreRender (inherited from WebFormTemplateLayout)
Unload (inherited from WebFormTemplateLayout)
ValueChanged (inherited from WebFormTemplateLayout)

Protected Instance Fields

m_bFillHeight (inherited from WebFormTemplateLayout)
m_bFillWidth (inherited from WebFormTemplateLayout)
m_iFillHeightMargin (inherited from WebFormTemplateLayout)
m_iFillWidthMargin (inherited from WebFormTemplateLayout)

Protected Instance Properties

Adapter (inherited from Control) | Gets the browser-specific adapter for the control.
ChildControlsCreated (inherited from Control) | Gets a value that indicates whether the server control's child controls have been created.
ClientIDSeparator (inherited from Control) | Gets a character value representing the separator character used in the ClientID property.
Events (inherited from Control) | Gets a list of event handler delegates for the control. This property is read-only.
HasChildViewState (inherited from Control) | Gets a value indicating whether the current server control's child controls have any saved view-state settings.
IdSeparator (inherited from Control) | Gets the character used to separate control identifiers.
IsTrackingViewState (inherited from Control) | Gets a value that indicates whether the server control is saving changes to its view state.
LoadViewStateByID (inherited from Control) | Gets a value indicating whether the control participates in loading its view state by ID instead of index.
TagKey (inherited from WebControl) | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers.
TagName (inherited from WebControl) | Gets the name of the control tag. This property is used primarily by control developers.
ViewState (inherited from Control) | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page.
ViewStateIgnoresCase (inherited from Control) | Gets a value that indicates whether the StateBag object is case-insensitive.

Protected Instance Methods

AddAttributesToRender (inherited from WebControl) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers.
AddParsedSubObject (inherited from Control) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object.
BuildProfileTree (inherited from Control) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page.
ClearChildControlState (inherited from Control) | Deletes the control-state information for the server control's child controls.
ClearChildState (inherited from Control) | Deletes the view-state and control-state information for all the server control's child controls.
ClearChildViewState (inherited from Control) | Deletes the view-state information for all the server control's child controls.
CreateChildControls |
CreateControlCollection (inherited from Control) | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control.
CreateControlStyle (inherited from WebControl) | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers.
DataBind (inherited from Control) | Overloaded. Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.
DataBindChildren (inherited from Control) | Binds a data source to the server control's child controls.
EnableFormComponent (inherited from WebFormTemplateLayout) | This method is responsible for enabling or disabling the specified control based on the name of the component or the data field. Internally implemented by calling GetFormComponent()
EnsureChildControls (inherited from Control) | Determines whether the server control contains child controls. If it does not, it creates child controls.
EnsureID (inherited from Control) | Creates an identifier for controls that do not have an identifier assigned.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FindControl (inherited from Control) | Overloaded. Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl method.
GetDesignModeState (inherited from Control) | Gets design-time data for a control.
GetFormComponent (inherited from WebFormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
HasEvents (inherited from Control) | Returns a value indicating whether events are registered for the control or any child controls.
IsFormComponent (inherited from WebFormTemplateLayout) | This method determines if the provided component is a valid Aptify Form Component, which is determined by checking to see if any of the following conditions is True: 1) Derived from WebFormCompnentBase 2) Implements IWebFormComponent 3) Derived from WebFormTemplateLayout 4) Derived from WebFormTemplateTab
IsLiteralContent (inherited from Control) | Determines if the server control holds only literal content.
LoadViewState (inherited from WebControl) | Restores view-state information from a previous request that was saved with the SaveViewState method.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnBubbleEvent (inherited from Control) | Determines whether the event for the server control is passed up the page's UI server control hierarchy.
OnDataBinding (inherited from Control) | Raises the DataBinding event.
OnInit (inherited from WebFormTemplateLayout) |
RaiseBubbleEvent (inherited from Control) | Assigns any sources of the event and its information to the control's parent.
ReconstituteComponentCollection (inherited from WebFormTemplateLayout) | This method will rebuild the internal Form Component collection from the ASP.NET control hierarchy.
RecreateChildControls (inherited from CompositeControl) | Recreates the child controls n a control derived from CompositeControl.
RenderControl (inherited from Control) | Overloaded. Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.
ResolveAdapter (inherited from Control) | Gets the control adapter responsible for rendering the specified control.
SaveViewState (inherited from WebControl) | Saves any state that was modified after the TrackViewState method was invoked.
SelectAddress |
SetDesignModeState (inherited from Control) | Sets design-time data for a control.
TrackViewState (inherited from WebControl) | Causes the control to track changes to its view state so they can be stored in the object's ViewState property.

Protected Internal Instance Properties

Context (inherited from Control) | Gets the HttpContext object associated with the server control for the current Web request.
DesignMode (inherited from Control) | Gets a value indicating whether a control is being used on a design surface.
IsChildControlStateCleared (inherited from Control) | Gets a value indicating whether controls contained within this control have control state.
IsEnabled (inherited from WebControl) | Gets a value indicating whether the control is enabled.
IsViewStateEnabled (inherited from Control) | Gets a value indicating whether view state is enabled for this control.

Protected Internal Instance Methods

AddedControl (inherited from Control) | Called after a child control is added to the Controls collection of the Control object.
LoadControlState (inherited from Control) | Restores control-state information from a previous page request that was saved by the SaveControlState method.
MapPathSecure (inherited from Control) | Retrieves the physical path that a virtual path, either absolute or relative, maps to.
OnLoad (inherited from Control) | Raises the Load event.
OnPreRender (inherited from Control) | Raises the PreRender event.
OnUnload (inherited from Control) | Raises the Unload event.
OpenFile (inherited from Control) | Gets a Stream used to read a file.
RemovedControl (inherited from Control) | Called after a control is removed from the Controls collection of another control.
Render (inherited from CompositeControl) | Writes the CompositeControl content to the specified HtmlTextWriter object, for display on the client.
RenderChildren (inherited from Control) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client.
RenderContents (inherited from WebControl) | Renders the contents of the control to the specified writer. This method is used primarily by control developers.
SaveControlState (inherited from Control) | Saves any server control state changes that have occurred since the time the page was posted back to the server.

See Also

PersonsWebLayout Class | Aptify.Applications.Persons.WebAccess Namespace


PersonsWebLayout Constructor

Initializes a new instance of the PersonsWebLayout class.

public PersonsWebLayout();

See Also

PersonsWebLayout Class | Aptify.Applications.Persons.WebAccess Namespace


PersonsWebLayout Methods

The methods of the PersonsWebLayout class are listed below. For a complete list of PersonsWebLayout class members, see the PersonsWebLayout Members topic.

Public Instance Methods

ApplyStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers.
ApplyStyleSheetSkin (inherited from Control) | Applies the style properties defined in the page style sheet to the control.
CopyBaseAttributes (inherited from WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers.
DataBind (inherited from CompositeControl) | Overloaded. Binds a data source to the CompositeControl and all its child controls.
Dispose (inherited from Control) | Enables a server control to perform final clean up before it is released from memory.
DoControlLoading (inherited from WebFormTemplateLayout) | This method loads controls from the Form Template Layout meta-data definition
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindControl (inherited from Control) | Overloaded. Searches the current naming container for a server control with the specified id parameter.
Focus (inherited from Control) | Sets input focus to a control.
FormComponentConfig |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from WebFormTemplateLayout) |
GetType (inherited from Object) | Gets the Type of the current instance.
HasControls (inherited from Control) | Determines if the server control contains any child controls.
Hide (inherited from WebFormTemplateLayout) |
MergeStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers.
Refresh |
RenderBeginTag (inherited from WebControl) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers.
RenderControl (inherited from Control) | Overloaded. Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
RenderEndTag (inherited from WebControl) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers.
ResolveClientUrl (inherited from Control) | Gets a URL that can be used by the browser.
ResolveUrl (inherited from Control) | Converts a URL into one that is usable on the requesting client.
SetRenderMethodDelegate (inherited from Control) | Assigns an event handler delegate to render the server control and its content into its parent control.
Show | Overloaded.
Show (inherited from WebFormTemplateLayout) | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.
TransferDataToObject (inherited from WebFormTemplateLayout) |

Protected Instance Methods

AddAttributesToRender (inherited from WebControl) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers.
AddParsedSubObject (inherited from Control) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object.
BuildProfileTree (inherited from Control) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page.
ClearChildControlState (inherited from Control) | Deletes the control-state information for the server control's child controls.
ClearChildState (inherited from Control) | Deletes the view-state and control-state information for all the server control's child controls.
ClearChildViewState (inherited from Control) | Deletes the view-state information for all the server control's child controls.
CreateChildControls |
CreateControlCollection (inherited from Control) | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control.
CreateControlStyle (inherited from WebControl) | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers.
DataBind (inherited from Control) | Overloaded. Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.
DataBindChildren (inherited from Control) | Binds a data source to the server control's child controls.
EnableFormComponent (inherited from WebFormTemplateLayout) | This method is responsible for enabling or disabling the specified control based on the name of the component or the data field. Internally implemented by calling GetFormComponent()
EnsureChildControls (inherited from Control) | Determines whether the server control contains child controls. If it does not, it creates child controls.
EnsureID (inherited from Control) | Creates an identifier for controls that do not have an identifier assigned.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FindControl (inherited from Control) | Overloaded. Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl method.
GetDesignModeState (inherited from Control) | Gets design-time data for a control.
GetFormComponent (inherited from WebFormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
HasEvents (inherited from Control) | Returns a value indicating whether events are registered for the control or any child controls.
IsFormComponent (inherited from WebFormTemplateLayout) | This method determines if the provided component is a valid Aptify Form Component, which is determined by checking to see if any of the following conditions is True: 1) Derived from WebFormCompnentBase 2) Implements IWebFormComponent 3) Derived from WebFormTemplateLayout 4) Derived from WebFormTemplateTab
IsLiteralContent (inherited from Control) | Determines if the server control holds only literal content.
LoadViewState (inherited from WebControl) | Restores view-state information from a previous request that was saved with the SaveViewState method.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnBubbleEvent (inherited from Control) | Determines whether the event for the server control is passed up the page's UI server control hierarchy.
OnDataBinding (inherited from Control) | Raises the DataBinding event.
OnInit (inherited from WebFormTemplateLayout) |
RaiseBubbleEvent (inherited from Control) | Assigns any sources of the event and its information to the control's parent.
ReconstituteComponentCollection (inherited from WebFormTemplateLayout) | This method will rebuild the internal Form Component collection from the ASP.NET control hierarchy.
RecreateChildControls (inherited from CompositeControl) | Recreates the child controls n a control derived from CompositeControl.
RenderControl (inherited from Control) | Overloaded. Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.
ResolveAdapter (inherited from Control) | Gets the control adapter responsible for rendering the specified control.
SaveViewState (inherited from WebControl) | Saves any state that was modified after the TrackViewState method was invoked.
SelectAddress |
SetDesignModeState (inherited from Control) | Sets design-time data for a control.
TrackViewState (inherited from WebControl) | Causes the control to track changes to its view state so they can be stored in the object's ViewState property.

Protected Internal Instance Methods

AddedControl (inherited from Control) | Called after a child control is added to the Controls collection of the Control object.
LoadControlState (inherited from Control) | Restores control-state information from a previous page request that was saved by the SaveControlState method.
MapPathSecure (inherited from Control) | Retrieves the physical path that a virtual path, either absolute or relative, maps to.
OnLoad (inherited from Control) | Raises the Load event.
OnPreRender (inherited from Control) | Raises the PreRender event.
OnUnload (inherited from Control) | Raises the Unload event.
OpenFile (inherited from Control) | Gets a Stream used to read a file.
RemovedControl (inherited from Control) | Called after a control is removed from the Controls collection of another control.
Render (inherited from CompositeControl) | Writes the CompositeControl content to the specified HtmlTextWriter object, for display on the client.
RenderChildren (inherited from Control) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client.
RenderContents (inherited from WebControl) | Renders the contents of the control to the specified writer. This method is used primarily by control developers.
SaveControlState (inherited from Control) | Saves any server control state changes that have occurred since the time the page was posted back to the server.

See Also

PersonsWebLayout Class | Aptify.Applications.Persons.WebAccess Namespace


PersonsWebLayout.CreateChildControls Method

protected override void CreateChildControls();

See Also

PersonsWebLayout Class | Aptify.Applications.Persons.WebAccess Namespace


PersonsWebLayout.FormComponentConfig Method

public override void FormComponentConfig(
AptifyFormTemplateContext FormTemplateContext
);

Implements

IWebFormComponent.

See Also

PersonsWebLayout Class | Aptify.Applications.Persons.WebAccess Namespace


PersonsWebLayout.Refresh Method

public override void Refresh();

Implements

IWebFormComponent.

See Also

PersonsWebLayout Class | Aptify.Applications.Persons.WebAccess Namespace


PersonsWebLayout.SelectAddress Method

protected void SelectAddress();

See Also

PersonsWebLayout Class | Aptify.Applications.Persons.WebAccess Namespace


Show Method

Aptify 5.0 Software Development Kit (SDK)

PersonsWebLayout.Show Method

Overload List

Inherited from WebFormTemplateLayout.

public virtual void Show();

public override void Show(Boolean);

See Also

PersonsWebLayout Class | Aptify.Applications.Persons.WebAccess Namespace


PersonsWebLayout.Show Method (Boolean)

public override void Show(
Boolean Refresh
);

Implements

IWebFormComponent.

See Also

PersonsWebLayout Class | Aptify.Applications.Persons.WebAccess Namespace | PersonsWebLayout.Show Overload List


Aptify.Applications.ProductSetup

Aptify 5.0 Software Development Kit (SDK)

Aptify.Applications.ProductSetup Namespace

This namespace contains objects related to Aptify's standard Product Setup and Maintenance functionality, including product pricing.

Namespace hierarchy

Classes

Class | Description
NewProductVersionWizard | This wizard walks a user through the process of creating a new version of a particular product.
NewProductVersionWizard.NewProductVersionWizardException | This exception is thrown when errors occur within the New Product Version Wizard
PricingRuleResult | Returns the results of executing the pricing rule.
PricingRuleScriptEngine | Contains the logic used by the pricing object to execute Pricing Rules.
PricingRuleScriptEngineException | Thrown when there is a problem executing or obtaining a pricing rule.
ProductCategory |
ProductObject | Product Object is the GE Sub-Class implementation for the Products entity and provides support for extended product types as well as the standard product attribute information.
ProductPartsEntity | Product Parts Entity is the GE Sub-Class implementation for the ProductParts sub-type entity and provides support for managing assembly parts.
ProductPrice |
ProductPrice.PricingDeterminant |
ProductPriceCurrencyTypeMismatchException | Raised when the Price is returned with a different Currency Type then what was requested. This can occur when a price is provided by a Pricing Object or Pricing Rule.
ProductPriceException |
ProductPriceObject | Product Price Object is the GE Sub-Class implementation for the ProductPrices sub-type entity and provides support for managing base prices and derived prices.

Delegates

Delegate | Description
ProductCategory.AfterFlowDownPricingObjectInfoEventHandler |
ProductCategory.BeforeFlowDownPricingObjectInfoEventHandler |
ProductObject.AfterGLAccountsFlowDownEventHandler |
ProductObject.BeforeGLAccountsFlowDownEventHandler |

Enumerations

Enumeration | Description
ProductPrice.PricingType |


NewProductVersionWizard Class

This wizard walks a user through the process of creating a new version of a particular product.

For a list of all members of this type, see NewProductVersionWizard Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
NewProductVersionWizard

public class NewProductVersionWizard : Form, IAptifyAction

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.ProductSetup

Assembly: AptifyNewProductVersionWizard (in AptifyNewProductVersionWizard.dll)

See Also

NewProductVersionWizard Members | Aptify.Applications.ProductSetup Namespace


NewProductVersionWizard Members

NewProductVersionWizard overview

Public Instance Constructors

NewProductVersionWizard Constructor Initializes a new instance of the NewProductVersionWizard class.

Public Instance Properties

_lblDate_0 |
_lblDate_1 |
_Steps_0 |
_Steps_1 |
_Steps_2 |
_Steps_3 |
_Steps_4 |
_Steps_5 |
_Steps_6 |
AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
lblAccount |
lblFinal |
lblGridVersion |
lblInventory |
lblPrice |
lblSelectProduct |
lblSpecifyName |
lblSpecifyVersion |
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
optNo |
optYes |
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Timer1 |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoAction | Overloaded.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FulfillStandingOrders | Method used to fulfill standing orders based on the new product that was created.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStandingOrderFulfillStatusUpdate | Method that exposes the status update for standing order fulfillment so that a developer can capture the event in a subclass and act on it, if so desired.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

NewProductVersionWizard Class | Aptify.Applications.ProductSetup Namespace


NewProductVersionWizard Constructor

Initializes a new instance of the NewProductVersionWizard class.

public NewProductVersionWizard();

See Also

NewProductVersionWizard Class | Aptify.Applications.ProductSetup Namespace


NewProductVersionWizard Properties

The properties of the NewProductVersionWizard class are listed below. For a complete list of NewProductVersionWizard class members, see the NewProductVersionWizard Members topic.

Public Instance Properties

_lblDate_0 |
_lblDate_1 |
_Steps_0 |
_Steps_1 |
_Steps_2 |
_Steps_3 |
_Steps_4 |
_Steps_5 |
_Steps_6 |
AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
lblAccount |
lblFinal |
lblGridVersion |
lblInventory |
lblPrice |
lblSelectProduct |
lblSpecifyName |
lblSpecifyVersion |
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
optNo |
optYes |
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Timer1 |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

NewProductVersionWizard Class | Aptify.Applications.ProductSetup Namespace


_lblDate_0 Property

Aptify 5.0 Software Development Kit (SDK)

NewProductVersionWizard._lblDate_0 Property

public virtual Label _lblDate_0 {get; set;}

See Also

NewProductVersionWizard Class | Aptify.Applications.ProductSetup Namespace


_lblDate_1 Property

Aptify 5.0 Software Development Kit (SDK)

NewProductVersionWizard._lblDate_1 Property

public virtual Label _lblDate_1 {get; set;}

See Also

NewProductVersionWizard Class | Aptify.Applications.ProductSetup Namespace


_Steps_0 Property

Aptify 5.0 Software Development Kit (SDK)

NewProductVersionWizard._Steps_0 Property

public virtual Label _Steps_0 {get; set;}

See Also

NewProductVersionWizard Class | Aptify.Applications.ProductSetup Namespace


_Steps_1 Property

Aptify 5.0 Software Development Kit (SDK)

NewProductVersionWizard._Steps_1 Property

public virtual Label _Steps_1 {get; set;}

See Also

NewProductVersionWizard Class | Aptify.Applications.ProductSetup Namespace


_Steps_2 Property

Aptify 5.0 Software Development Kit (SDK)

NewProductVersionWizard._Steps_2 Property

public virtual Label _Steps_2 {get; set;}

See Also

NewProductVersionWizard Class | Aptify.Applications.ProductSetup Namespace


_Steps_3 Property

Aptify 5.0 Software Development Kit (SDK)

NewProductVersionWizard._Steps_3 Property

public virtual Label _Steps_3 {get; set;}

See Also

NewProductVersionWizard Class | Aptify.Applications.ProductSetup Namespace


_Steps_4 Property

Aptify 5.0 Software Development Kit (SDK)

NewProductVersionWizard._Steps_4 Property

public virtual Label _Steps_4 {get; set;}

See Also

NewProductVersionWizard Class | Aptify.Applications.ProductSetup Namespace


_Steps_5 Property

Aptify 5.0 Software Development Kit (SDK)

NewProductVersionWizard._Steps_5 Property

public virtual Label _Steps_5 {get; set;}

See Also

NewProductVersionWizard Class | Aptify.Applications.ProductSetup Namespace


_Steps_6 Property

Aptify 5.0 Software Development Kit (SDK)

NewProductVersionWizard._Steps_6 Property

public virtual Label _Steps_6 {get; set;}

See Also

NewProductVersionWizard Class | Aptify.Applications.ProductSetup Namespace


lblAccount Property

Aptify 5.0 Software Development Kit (SDK)

NewProductVersionWizard.lblAccount Property

public virtual Label lblAccount {get; set;}

See Also

NewProductVersionWizard Class | Aptify.Applications.ProductSetup Namespace


lblFinal Property

Aptify 5.0 Software Development Kit (SDK)

NewProductVersionWizard.lblFinal Property

public virtual Label lblFinal {get; set;}

See Also

NewProductVersionWizard Class | Aptify.Applications.ProductSetup Namespace


lblGridVersion Property

Aptify 5.0 Software Development Kit (SDK)

NewProductVersionWizard.lblGridVersion Property

public virtual Label lblGridVersion {get; set;}

See Also

NewProductVersionWizard Class | Aptify.Applications.ProductSetup Namespace


lblInventory Property

Aptify 5.0 Software Development Kit (SDK)

NewProductVersionWizard.lblInventory Property

public virtual Label lblInventory {get; set;}

See Also

NewProductVersionWizard Class | Aptify.Applications.ProductSetup Namespace


lblPrice Property

Aptify 5.0 Software Development Kit (SDK)

NewProductVersionWizard.lblPrice Property

public virtual Label lblPrice {get; set;}

See Also

NewProductVersionWizard Class | Aptify.Applications.ProductSetup Namespace


lblSelectProduct Property

Aptify 5.0 Software Development Kit (SDK)

NewProductVersionWizard.lblSelectProduct Property

public virtual Label lblSelectProduct {get; set;}

See Also

NewProductVersionWizard Class | Aptify.Applications.ProductSetup Namespace


lblSpecifyName Property

Aptify 5.0 Software Development Kit (SDK)

NewProductVersionWizard.lblSpecifyName Property

public virtual Label lblSpecifyName {get; set;}

See Also

NewProductVersionWizard Class | Aptify.Applications.ProductSetup Namespace


lblSpecifyVersion Property

Aptify 5.0 Software Development Kit (SDK)

NewProductVersionWizard.lblSpecifyVersion Property

public virtual Label lblSpecifyVersion {get; set;}

See Also

NewProductVersionWizard Class | Aptify.Applications.ProductSetup Namespace


optNo Property

Aptify 5.0 Software Development Kit (SDK)

NewProductVersionWizard.optNo Property

public virtual RadioButton optNo {get; set;}

See Also

NewProductVersionWizard Class | Aptify.Applications.ProductSetup Namespace


optYes Property

Aptify 5.0 Software Development Kit (SDK)

NewProductVersionWizard.optYes Property

public virtual RadioButton optYes {get; set;}

See Also

NewProductVersionWizard Class | Aptify.Applications.ProductSetup Namespace


Timer1 Property

Aptify 5.0 Software Development Kit (SDK)

NewProductVersionWizard.Timer1 Property

public virtual Timer Timer1 {get; set;}

See Also

NewProductVersionWizard Class | Aptify.Applications.ProductSetup Namespace


NewProductVersionWizard Methods

The methods of the NewProductVersionWizard class are listed below. For a complete list of NewProductVersionWizard class members, see the NewProductVersionWizard Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoAction | Overloaded.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FulfillStandingOrders | Method used to fulfill standing orders based on the new product that was created.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStandingOrderFulfillStatusUpdate | Method that exposes the status update for standing order fulfillment so that a developer can capture the event in a subclass and act on it, if so desired.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

NewProductVersionWizard Class | Aptify.Applications.ProductSetup Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

NewProductVersionWizard.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

NewProductVersionWizard Class | Aptify.Applications.ProductSetup Namespace


NewProductVersionWizard.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

NewProductVersionWizard Class | Aptify.Applications.ProductSetup Namespace | NewProductVersionWizard.Dispose Overload List


DoAction Method

Aptify 5.0 Software Development Kit (SDK)

NewProductVersionWizard.DoAction Method

Overload List

public void DoAction(AptifyApplication,Int64);

public void DoAction(AptifyApplication,Int64,Int64);

public void DoAction(AptifyApplication,Int64,Int64,params Object[]);

public void DoAction(AptifyApplication,Int64,params String[]);

See Also

NewProductVersionWizard Class | Aptify.Applications.ProductSetup Namespace


NewProductVersionWizard.DoAction Method (AptifyApplication, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID
);

Implements

IAptifyAction.

See Also

NewProductVersionWizard Class | Aptify.Applications.ProductSetup Namespace | NewProductVersionWizard.DoAction Overload List


NewProductVersionWizard.DoAction Method (AptifyApplication, Int64, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID
);

Implements

IAptifyAction.

See Also

NewProductVersionWizard Class | Aptify.Applications.ProductSetup Namespace | NewProductVersionWizard.DoAction Overload List


NewProductVersionWizard.DoAction Method (AptifyApplication, Int64, Int64, Object[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID,
params Object[] SelectedItems
);

Implements

IAptifyAction.

See Also

NewProductVersionWizard Class | Aptify.Applications.ProductSetup Namespace | NewProductVersionWizard.DoAction Overload List


NewProductVersionWizard.DoAction Method (AptifyApplication, Int64, String[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
params String[] SelectedItems
);

Implements

IAptifyAction.

See Also

NewProductVersionWizard Class | Aptify.Applications.ProductSetup Namespace | NewProductVersionWizard.DoAction Overload List


NewProductVersionWizard.FulfillStandingOrders Method

Method used to fulfill standing orders based on the new product that was created.

protected virtual bool FulfillStandingOrders(
Int64 lProductID
);

Parameters

lProductID

Return Value

Remarks

See Also

NewProductVersionWizard Class | Aptify.Applications.ProductSetup Namespace


NewProductVersionWizard.OnStandingOrderFulfillStatusUpdate Method

Method that exposes the status update for standing order fulfillment so that a developer can capture the event in a subclass and act on it, if so desired.

protected virtual void OnStandingOrderFulfillStatusUpdate(
String Message,
Int32 PercentComplete,
ref Boolean& Cancel
);

Parameters

Message
PercentComplete
Cancel

Remarks

See Also

NewProductVersionWizard Class | Aptify.Applications.ProductSetup Namespace


NewProductVersionWizard.NewProductVersionWizardException Class

This exception is thrown when errors occur within the New Product Version Wizard

For a list of all members of this type, see NewProductVersionWizard.NewProductVersionWizardException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
NewProductVersionWizard.NewProductVersionWizardException

public class NewProductVersionWizard.NewProductVersionWizardException : BaseApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.ProductSetup

Assembly: AptifyNewProductVersionWizard (in AptifyNewProductVersionWizard.dll)

See Also

NewProductVersionWizard.NewProductVersionWizardException Members | Aptify.Applications.ProductSetup Namespace


NewProductVersionWizard.NewProductVersionWizardException Members

NewProductVersionWizard.NewProductVersionWizardException overview

Public Instance Constructors

NewProductVersionWizard.NewProductVersionWizardException Overloaded. Initializes a new instance of the NewProductVersionWizard.NewProductVersionWizardException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from BaseApplicationException) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NewProductVersionWizard.NewProductVersionWizardException Class | Aptify.Applications.ProductSetup Namespace


NewProductVersionWizard.NewProductVersionWizardException Constructor

Initializes a new instance of the NewProductVersionWizard.NewProductVersionWizardException class.

Overload List

Initializes a new instance of the NewProductVersionWizard.NewProductVersionWizardException class.

public NewProductVersionWizard.NewProductVersionWizardException();

public NewProductVersionWizard.NewProductVersionWizardException(String);

public NewProductVersionWizard.NewProductVersionWizardException(String,Exception);

See Also

NewProductVersionWizard.NewProductVersionWizardException Class | Aptify.Applications.ProductSetup Namespace


NewProductVersionWizard.NewProductVersionWizardException Constructor ()

Initializes a new instance of the NewProductVersionWizard.NewProductVersionWizardException class.

public NewProductVersionWizard.NewProductVersionWizardException();

See Also

NewProductVersionWizard.NewProductVersionWizardException Class | Aptify.Applications.ProductSetup Namespace | NewProductVersionWizard.NewProductVersionWizardException Constructor Overload List


NewProductVersionWizard.NewProductVersionWizardException Constructor (String)

public NewProductVersionWizard.NewProductVersionWizardException(
String Message
);

See Also

NewProductVersionWizard.NewProductVersionWizardException Class | Aptify.Applications.ProductSetup Namespace | NewProductVersionWizard.NewProductVersionWizardException Constructor Overload List


NewProductVersionWizard.NewProductVersionWizardException Constructor (String, Exception)

public NewProductVersionWizard.NewProductVersionWizardException(
String Message,
Exception InnerException
);

See Also

NewProductVersionWizard.NewProductVersionWizardException Class | Aptify.Applications.ProductSetup Namespace | NewProductVersionWizard.NewProductVersionWizardException Constructor Overload List


PricingRuleResult Class

Returns the results of executing the pricing rule.

For a list of all members of this type, see PricingRuleResult Members.

System.Object
PricingRuleResult

public class PricingRuleResult

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.ProductSetup

Assembly: ProductPrice (in ProductPrice.dll)

See Also

PricingRuleResult Members | Aptify.Applications.ProductSetup Namespace


PricingRuleResult Members

PricingRuleResult overview

Public Instance Constructors

PricingRuleResult Constructor Initializes a new instance of the PricingRuleResult class.

Public Instance Properties

Message | Allows the Rule to return a message as a result of the execution.
Outcome | Used by the Script Engine to add insight as to why something may have failed.
Success | Used to signal if the Rule that was used was successfull in determining a price.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PricingRuleResult Class | Aptify.Applications.ProductSetup Namespace


PricingRuleResult Constructor

Initializes a new instance of the PricingRuleResult class.

public PricingRuleResult();

See Also

PricingRuleResult Class | Aptify.Applications.ProductSetup Namespace


PricingRuleResult Properties

The properties of the PricingRuleResult class are listed below. For a complete list of PricingRuleResult class members, see the PricingRuleResult Members topic.

Public Instance Properties

Message | Allows the Rule to return a message as a result of the execution.
Outcome | Used by the Script Engine to add insight as to why something may have failed.
Success | Used to signal if the Rule that was used was successfull in determining a price.

See Also

PricingRuleResult Class | Aptify.Applications.ProductSetup Namespace


Message Property

Aptify 5.0 Software Development Kit (SDK)

PricingRuleResult.Message Property

Allows the Rule to return a message as a result of the execution.

public String Message {get; set;}

Property Value

Remarks

See Also

PricingRuleResult Class | Aptify.Applications.ProductSetup Namespace


Outcome Property

Aptify 5.0 Software Development Kit (SDK)

PricingRuleResult.Outcome Property

Used by the Script Engine to add insight as to why something may have failed.

public IProductPrice.PriceOutcome Outcome {get; set;}

Property Value

Remarks

See Also

PricingRuleResult Class | Aptify.Applications.ProductSetup Namespace


Success Property

Aptify 5.0 Software Development Kit (SDK)

PricingRuleResult.Success Property

Used to signal if the Rule that was used was successfull in determining a price.

public Boolean Success {get; set;}

Property Value

Remarks

See Also

PricingRuleResult Class | Aptify.Applications.ProductSetup Namespace


PricingRuleScriptEngine Class

Contains the logic used by the pricing object to execute Pricing Rules.

For a list of all members of this type, see PricingRuleScriptEngine Members.

System.Object
PricingRuleScriptEngine

public class PricingRuleScriptEngine

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.ProductSetup

Assembly: ProductPrice (in ProductPrice.dll)

See Also

PricingRuleScriptEngine Members | Aptify.Applications.ProductSetup Namespace


PricingRuleScriptEngine Members

PricingRuleScriptEngine overview

Public Instance Constructors

PricingRuleScriptEngine Constructor Initializes a new instance of the PricingRuleScriptEngine class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPrice |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

ExecuteScript | This function will Initialize the Script Engine Based on the [Pricing Rule] Script Type.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PricingRuleScriptEngine Class | Aptify.Applications.ProductSetup Namespace


PricingRuleScriptEngine Constructor

Initializes a new instance of the PricingRuleScriptEngine class.

public PricingRuleScriptEngine();

See Also

PricingRuleScriptEngine Class | Aptify.Applications.ProductSetup Namespace


PricingRuleScriptEngine Methods

The methods of the PricingRuleScriptEngine class are listed below. For a complete list of PricingRuleScriptEngine class members, see the PricingRuleScriptEngine Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPrice |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

ExecuteScript | This function will Initialize the Script Engine Based on the [Pricing Rule] Script Type.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PricingRuleScriptEngine Class | Aptify.Applications.ProductSetup Namespace


PricingRuleScriptEngine.ExecuteScript Method

This function will Initialize the Script Engine Based on the [Pricing Rule] Script Type.

protected virtual PricingRuleResult ExecuteScript(
String ScriptToExecute
);

Parameters

ScriptToExecute
Ad-Hoc VB Script

Return Value

This will return an instantiated PricingRuleResult that contains the result of the script execution.

Remarks

If you want to use a Script Type other than [Pricing Rule], then this should be overriden. This can also be overriden if you would like multiple script types to be run.

See Also

PricingRuleScriptEngine Class | Aptify.Applications.ProductSetup Namespace


PricingRuleScriptEngine.GetPrice Method

public PricingRuleResult GetPrice(
AptifyApplication ApplicationObject,
Int64 RuleID,
ref PriceInfo& Price,
Int64 ProductID,
Decimal Quantity,
Int64 PersonID,
OrdersEntity OrderGE,
OrderLinesEntity OrderLineGE,
AptifyGenericEntityBase ProductGE,
Int64 CurrencyTypeID,
Int64 DerivedFromCurrencyTypeID,
Boolean CustomPrice
);

See Also

PricingRuleScriptEngine Class | Aptify.Applications.ProductSetup Namespace


PricingRuleScriptEngineException Class

Thrown when there is a problem executing or obtaining a pricing rule.

For a list of all members of this type, see PricingRuleScriptEngineException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
PricingRuleScriptEngineException

public class PricingRuleScriptEngineException : BaseApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.ProductSetup

Assembly: ProductPrice (in ProductPrice.dll)

See Also

PricingRuleScriptEngineException Members | Aptify.Applications.ProductSetup Namespace


PricingRuleScriptEngineException Members

PricingRuleScriptEngineException overview

Public Instance Constructors

PricingRuleScriptEngineException Overloaded. Initializes a new instance of the PricingRuleScriptEngineException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from BaseApplicationException) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PricingRuleScriptEngineException Class | Aptify.Applications.ProductSetup Namespace


PricingRuleScriptEngineException Constructor

Initializes a new instance of the PricingRuleScriptEngineException class.

Overload List

Initializes a new instance of the PricingRuleScriptEngineException class.

public PricingRuleScriptEngineException();

public PricingRuleScriptEngineException(String);

public PricingRuleScriptEngineException(String,Exception);

See Also

PricingRuleScriptEngineException Class | Aptify.Applications.ProductSetup Namespace


PricingRuleScriptEngineException Constructor ()

Initializes a new instance of the PricingRuleScriptEngineException class.

public PricingRuleScriptEngineException();

See Also

PricingRuleScriptEngineException Class | Aptify.Applications.ProductSetup Namespace | PricingRuleScriptEngineException Constructor Overload List


PricingRuleScriptEngineException Constructor (String)

public PricingRuleScriptEngineException(
String Message
);

See Also

PricingRuleScriptEngineException Class | Aptify.Applications.ProductSetup Namespace | PricingRuleScriptEngineException Constructor Overload List


PricingRuleScriptEngineException Constructor (String, Exception)

public PricingRuleScriptEngineException(
String Message,
Exception InnerException
);

See Also

PricingRuleScriptEngineException Class | Aptify.Applications.ProductSetup Namespace | PricingRuleScriptEngineException Constructor Overload List


ProductCategory Class

For a list of all members of this type, see ProductCategory Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
ProductCategory

public class ProductCategory : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.ProductSetup

Assembly: ProductCategoryObject (in ProductCategoryObject.dll)

See Also

ProductCategory Members | Aptify.Applications.ProductSetup Namespace


ProductCategory Members

ProductCategory overview

Public Instance Constructors

ProductCategory Constructor Initializes a new instance of the ProductCategory class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config | Overloaded.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetCustomPricingObjectInfo | This method is responsible for getting information from a given Product Category regarding custom pricing object information at the category level.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterFlowDownPricingObjectInfo | This event is raised after the flow-down of pricing object information which includes PricingObject, PricingClass and PricingAssembly.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeFlowDownPricingObjectInfo | This event is raised before the flow-down of pricing object information(which includes PricingObject, PricingClass and PricingAssembly) occurs. The Cancel parameter of this event allows the listener of this event to cancel the flow-down of the pricing object information to the object.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
m_fieldParentID |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InitializeFields | Method used to initialize any field objects which we need to hook up to event handlers
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnFlowDownCustomPricingObjectInfo | This method is responsible for handling the flow-down of custom pricing object info (PricingObject/PricingClass/PricingAssembly) from the Parent Category. This method is called automatically whenever the ParentID is changed via the SetValue() method.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

ProductCategory Class | Aptify.Applications.ProductSetup Namespace


ProductCategory Constructor

Initializes a new instance of the ProductCategory class.

public ProductCategory();

See Also

ProductCategory Class | Aptify.Applications.ProductSetup Namespace


ProductCategory Properties

The properties of the ProductCategory class are listed below. For a complete list of ProductCategory class members, see the ProductCategory Members topic.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
m_fieldParentID |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

ProductCategory Class | Aptify.Applications.ProductSetup Namespace


m_fieldParentID Property

Aptify 5.0 Software Development Kit (SDK)

ProductCategory.m_fieldParentID Property

protected virtual AptifyDataFieldBase m_fieldParentID {get; set;}

See Also

ProductCategory Class | Aptify.Applications.ProductSetup Namespace


ProductCategory Methods

The methods of the ProductCategory class are listed below. For a complete list of ProductCategory class members, see the ProductCategory Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config | Overloaded.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetCustomPricingObjectInfo | This method is responsible for getting information from a given Product Category regarding custom pricing object information at the category level.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InitializeFields | Method used to initialize any field objects which we need to hook up to event handlers
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnFlowDownCustomPricingObjectInfo | This method is responsible for handling the flow-down of custom pricing object info (PricingObject/PricingClass/PricingAssembly) from the Parent Category. This method is called automatically whenever the ParentID is changed via the SetValue() method.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

ProductCategory Class | Aptify.Applications.ProductSetup Namespace


Config Method

Aptify 5.0 Software Development Kit (SDK)

ProductCategory.Config Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual void Config(AptifySubTypeBase);

Inherited from AptifyGenericEntity.

public override void Config(AptifySubTypeBase,Int64);

Inherited from AptifyGenericEntityBase.

public virtual void Config(UserCredentials,String);

public override void Config(UserCredentials,String,Int64);

See Also

ProductCategory Class | Aptify.Applications.ProductSetup Namespace


ProductCategory.Config Method (UserCredentials, String, Int64)

public override void Config(
UserCredentials UserCredentials,
String EntityName,
Int64 RecordID
);

See Also

ProductCategory Class | Aptify.Applications.ProductSetup Namespace | ProductCategory.Config Overload List


ProductCategory.GetCustomPricingObjectInfo Method

This method is responsible for getting information from a given Product Category regarding custom pricing object information at the category level.

public virtual bool GetCustomPricingObjectInfo(
Int64 ProductCategoryID,
ref String& ObjectLocation,
ref String& ClassName,
ref String& AssemblyName
);

Parameters

ProductCategoryID
ObjectLocation
ClassName
AssemblyName

Return Value

Remarks

See Also

ProductCategory Class | Aptify.Applications.ProductSetup Namespace


ProductCategory.InitializeFields Method

Method used to initialize any field objects which we need to hook up to event handlers

protected virtual void InitializeFields();

Remarks

See Also

ProductCategory Class | Aptify.Applications.ProductSetup Namespace


ProductCategory.OnFlowDownCustomPricingObjectInfo Method

This method is responsible for handling the flow-down of custom pricing object info (PricingObject/PricingClass/PricingAssembly) from the Parent Category. This method is called automatically whenever the ParentID is changed via the SetValue() method.

protected virtual void OnFlowDownCustomPricingObjectInfo(
Int64 NewParentID
);

Parameters

NewParentID
New Product Category Parent ID that is to be used to retrieve flow-down information

Remarks

See Also

ProductCategory Class | Aptify.Applications.ProductSetup Namespace


Validate Method

Aptify 5.0 Software Development Kit (SDK)

ProductCategory.Validate Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Validate();

public override bool Validate(ref String&);

See Also

ProductCategory Class | Aptify.Applications.ProductSetup Namespace


ProductCategory.Validate Method (String&)

public override bool Validate(
ref String& ErrorString
);

See Also

ProductCategory Class | Aptify.Applications.ProductSetup Namespace | ProductCategory.Validate Overload List


ProductCategory Events

The events of the ProductCategory class are listed below. For a complete list of ProductCategory class members, see the ProductCategory Members topic.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterFlowDownPricingObjectInfo | This event is raised after the flow-down of pricing object information which includes PricingObject, PricingClass and PricingAssembly.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeFlowDownPricingObjectInfo | This event is raised before the flow-down of pricing object information(which includes PricingObject, PricingClass and PricingAssembly) occurs. The Cancel parameter of this event allows the listener of this event to cancel the flow-down of the pricing object information to the object.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

See Also

ProductCategory Class | Aptify.Applications.ProductSetup Namespace


ProductCategory.ProductCategory.AfterFlowDownPricingObjectInfoEventHandler Event

This event is raised after the flow-down of pricing object information which includes PricingObject, PricingClass and PricingAssembly.

public event ProductCategory.AfterFlowDownPricingObjectInfoEventHandler AfterFlowDownPricingObjectInfo;

Remarks

See Also

ProductCategory Class | Aptify.Applications.ProductSetup Namespace


ProductCategory.ProductCategory.BeforeFlowDownPricingObjectInfoEventHandler Event

This event is raised before the flow-down of pricing object information(which includes PricingObject, PricingClass and PricingAssembly) occurs. The Cancel parameter of this event allows the listener of this event to cancel the flow-down of the pricing object information to the object.

public event ProductCategory.BeforeFlowDownPricingObjectInfoEventHandler BeforeFlowDownPricingObjectInfo;

Remarks

See Also

ProductCategory Class | Aptify.Applications.ProductSetup Namespace


ProductCategory.AfterFlowDownPricingObjectInfoEventHandler Delegate

public delegate void ProductCategory.AfterFlowDownPricingObjectInfoEventHandler();

Requirements

Namespace: Aptify.Applications.ProductSetup

Assembly: ProductCategoryObject (in ProductCategoryObject.dll)

See Also

Aptify.Applications.ProductSetup Namespace


ProductCategory.BeforeFlowDownPricingObjectInfoEventHandler Delegate

public delegate void ProductCategory.BeforeFlowDownPricingObjectInfoEventHandler(
String ObjectName,
String ClassName,
String AssemblyName,
ref Boolean& Cancel
);

Requirements

Namespace: Aptify.Applications.ProductSetup

Assembly: ProductCategoryObject (in ProductCategoryObject.dll)

See Also

Aptify.Applications.ProductSetup Namespace


ProductObject Class

Product Object is the GE Sub-Class implementation for the Products entity and provides support for extended product types as well as the standard product attribute information.

For a list of all members of this type, see ProductObject Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
ProductObject

public class ProductObject : AptifyGenericEntity, IProductPrice

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.ProductSetup

Assembly: ProductObject (in ProductObject.dll)

See Also

ProductObject Members | Aptify.Applications.ProductSetup Namespace


ProductObject Members

ProductObject overview

Public Instance Constructors

ProductObject Constructor Initializes a new instance of the ProductObject class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtendedProductObject | This method returns a GE object for the extended product object, if the current product type ID has an extended product object defined. If not, Nothing is returned.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
GetExtendedProductEntity |
GetExtendedProductLinkedField |
IsDirty | This property overrides the base class IsDirty() property to check to see if the Product object is dirty as well as checking the Extended Product Object, if it exists
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
ProductKitType | Gets/Sets the current ProductKitTypeID using the enumerated type ProductData.ProductKitType.
ProductPriceObject | This method returns the Product Pricing Object to be used for calculating product prices. This method will automatically instantiate the product pricing object to be used based on the setup of the system. See the SetupProductPricingObject() method for more details
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML | This method overrides the base class RecordChangeXML property and appends the ReocrdChangeXML from the extended product object, if applicable to the current product.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CalculateDerivedPrice | This is a utility function that can be called to employ the standard calculation logic for determining the derived price for a given Base Price and Percent of Base. In addition, if specified, RoundingType and RoundingAmount can be used to round up or down the derived price. Rounding is handled through a call to the RoundPrice() method.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone | Overloaded. This method overrides the base Clone() method and supports cloning the extended product object as well, if it is applicable to the current product.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config | Overloaded.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete | Overloaded. This method overrides the base GE Delete() and also handles the delete of the extended product object related to the Product if an extended product object exists.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Expo | This is a legacy function that is supported for backwards compatibility. Use the GetExtendedProductObject() method to retrieve the extended product object in a generic manner.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
FlowDownGLAccounts | This method is responsible for handling the process of flowing down GL accounts from the product category level to the product level. It clears out any GL accounts that may exist within the Product and replaces them with those in the Product Category.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetBasePrice | This method is responsible for determining the base price for a product in a given Currency Type. The base price is returned through the OUT Parameter Price. The return value of the function is TRUE if a base price was found, otherwise, False is returned if the function does not find a "Base" price defined in the product.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies | Overloaded. This method overrides the base class GetDependencies() method and adds in the dependency information for the extended product object, if one exists for the instance of the Product Object.
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetObjectPrice | Overloaded.
GetPrice | Overloaded.
GetPricingPermissions |
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetRootCategoryName | This method is responsible for retrieving the name of a root category for a given Product Category ID
GetTablePrice | Overloaded.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValidPriceList |
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Housing | This is a legacy function that is supported for backwards compatibility. Use the GetExtendedProductObject() method to retrieve the extended product object in a generic manner.
Load | Overloaded.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Meeting | This is a legacy function that is supported for backwards compatibility. Use the GetExtendedProductObject() method to retrieve the extended product object in a generic manner.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord |
ProductOrganizationHasGL | This method will give return true if the Organization accociated with this Product (or default Organization if not listed) has the GLType listed
ProductPriceConfig |
Publication | This is a legacy function that is supported for backwards compatibility. Use the GetExtendedProductObject() method to retrieve the extended product object in a generic manner.
RecalculateProductPrices | This method will recalculate the prices in the ProductPrices sub-type based on the Base Price and Percent of Base Price Definitions.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
RoundPrice | This method handles the rounding process for a decimal price value, rounding type and rounding amount specified. The return value contains the rounded amount.
Save | Overloaded. This method overrides the base Save() method to handle the process of saving both the Products entity and the contained Extended Product Object as required.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue | Overloaded.
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue |
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateDerivedPrices | This method is responsible for updating all of the prices within the ProductPrices sub-type with new price information based on whenever the Base Price has changed
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
UpdateInventoryQuantities | This method is responsible for updating the inventory quantity information in the object based on information stored in the database. The default implementation of this method uses the spGetProduct stored procedure to retrieve the current inventory quantity information.
Validate | Overloaded. This method overrides the base Validate() method to add in validation for the Extended Product Object if an Extended Product Object exists for the instance of the Product object.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterGLAccountsFlowDown | This event is raised after GL Accounts flow down into the product from the category level which happens when the CategoryID field in the object is set via SetValue()
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeGLAccountsFlowDown | This event is raised before GL Accounts flow down into the product from the category, which happens when the CategoryID field in the object is set via SetValue()
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
ProductTypeID | Gets/Sets the current product type ID.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase)
BroadcastChange (inherited from AptifyGenericEntity)
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase)
CloneSubType (inherited from AptifyGenericEntity)
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity)
CreateSubTypeRecord (inherited from AptifyGenericEntity)
CreateTopLevelRecord (inherited from AptifyGenericEntity)
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase)
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity)
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity)
FinishTransactionSubType (inherited from AptifyGenericEntity)
FinishTransactionTopLevel (inherited from AptifyGenericEntity)
FireEvent (inherited from AptifyGenericEntity)
FireValidationEvent (inherited from AptifyGenericEntity)
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity)
GenerateCreateSQL (inherited from AptifyGenericEntity)
GenerateDeleteSQL (inherited from AptifyGenericEntity)
GenerateFieldSQL (inherited from AptifyGenericEntity)
GenerateUpdateSQL (inherited from AptifyGenericEntity)
GetExtendedInfoField | This method returns the field name that is used to for extended product information which is stored in the EntityAttributes for the Products entity. This is done by calling the spGetExtendedInfoField stored procedure.
GetPersonMemberTypes | This method is responsible for returning the member types at the person and company level for a given individual Person ID
GetRootCategory | This method is responsible for returning the name of the Root Product Category associated with the specified Product Category ID. In addition, it optionally returns, via the RootCategoryID parameter, the RootCategoryID value.
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase)
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
IsExpo | This is a legacy function that is supported for backwards compatibility. Use the GetProductTypeID method to determine product type in a generic manner.
IsHousing | This is a legacy function that is supported for backwards compatibility. Use the GetProductTypeID method to determine product type in a generic manner.
IsMeeting | This is a legacy function that is supported for backwards compatibility. Use the GetProductTypeID method to determine product type in a generic manner.
IsPublication | This is a legacy function that is supported for backwards compatibility. Use the GetProductTypeID method to determine product type in a generic manner.
MakeFieldsCopy (inherited from AptifyGenericEntity)
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
PriceOnlyInTable | This method determines if the price is setup in the table only. If a custom pricing object or product-level pricing rule is in place for this product, this method will return False. Otherwise, the function will return True since the product is driven by table-level pricing.
RecordVersionInfo (inherited from AptifyGenericEntity)
RefreshLinkedFields (inherited from AptifyGenericEntity)
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase)
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity)
ResetProductType | This method is responsible for reseting the Extended Product Type, which sets the internal Extended Product Object reference to Nothing and then calls the SetupProductType() method.
RestoreCopiedFields (inherited from AptifyGenericEntity)
RollbackEmbeddedObjects (inherited from AptifyGenericEntity)
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase)
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetProductTypeID | This method is responsible for internally configuring the product object for the specified Product Type ID. The primary purpose behind this is to call the SetupProductType() method after checking to make sure that the Product Type ID is different than what was previously in place for the Product Type ID inside this class instance. If the Product Type ID provided to this method is different than the current Product Type ID, then SetupProductType() is called from this method.
SetRecordID (inherited from AptifyGenericEntityBase)
SetupProductPricingObject | This method is responsible for retrieving and instantiating the product pricing object that is to be used within the system. The default behavior for this method is to use entity attributes stored within the Products entity to retrieve a component that implements the IProductPrice interface and then store a reference to that class instance internally which can be retrieved through the ProductPriceObject property of this class. The entity attributes used by the base implementation of this method are as follows: ProductPricingObject - Aptify object repository location ProductPricingClass - Fully qualified (from root namespace down) name of class ProductPricingAssembly - Name of assembly
SetupProductType | This method is responsible for setting up the internal variables inside this class that represent the "Extended Product Type".
SetupTransaction (inherited from AptifyGenericEntity)
SetupTransactionSubType (inherited from AptifyGenericEntity)
SetupTransactionTopLevel (inherited from AptifyGenericEntity)
UpdateProductCategoryID | This method is called from within the overriden SetValue() method whenever the Product Category linked to the product (through the CategoryID field) is changed. This method is only called when the value has been changed. The base class implementation of this method determines if there are any ProductGLAccounts in the ProductGLAccounts sub-type and if not, then it will flow-down the GL Accounts from the ProductCategory provided. Before the GL Account flow-down occurs, the BeforeGLAccountFlowDown() Event is Raised which provides the container of this object the opportunity to cancel the process. If ProductGLAccounts are already in the Product then the event is also fired, however, the default mode is that the GL Accounts will NOT flow down if there is already data in there. It is possible for the container of the object to implement user-interactivity to determine if the flow-down should occur or to implement other logic as required. In addition to the above, this method also handles updating the ProductTypeID as well as flowing down custom pricing object information, if any exists at the category level.
UpdateRecord (inherited from AptifyGenericEntity)
ValidateDropShipField | Verifies whether user can update the value of Drop Ship field of product
ValidateGLAccounts | Verfies that the Product has all GL Accounts that it will require for proper usage.
ValidateSubTypes (inherited from AptifyGenericEntityBase)
VerifyObject (inherited from AptifyGenericEntity)

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace


ProductObject Constructor

Initializes a new instance of the ProductObject class.

public ProductObject();

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace


ProductObject Properties

The properties of the ProductObject class are listed below. For a complete list of ProductObject class members, see the ProductObject Members topic.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtendedProductObject | This method returns a GE object for the extended product object, if the current product type ID has an extended product object defined. If not, Nothing is returned.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
GetExtendedProductEntity |
GetExtendedProductLinkedField |
IsDirty | This property overrides the base class IsDirty() property to check to see if the Product object is dirty as well as checking the Extended Product Object, if it exists
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
ProductKitType | Gets/Sets the current ProductKitTypeID using the enumerated type ProductData.ProductKitType.
ProductPriceObject | This method returns the Product Pricing Object to be used for calculating product prices. This method will automatically instantiate the product pricing object to be used based on the setup of the system. See the SetupProductPricingObject() method for more details
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML | This method overrides the base class RecordChangeXML property and appends the ReocrdChangeXML from the extended product object, if applicable to the current product.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
ProductTypeID | Gets/Sets the current product type ID.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace


ExtendedProductObject Property

Aptify 5.0 Software Development Kit (SDK)

ProductObject.ExtendedProductObject Property

This method returns a GE object for the extended product object, if the current product type ID has an extended product object defined. If not, Nothing is returned.

public virtual AptifyGenericEntityBase ExtendedProductObject {get;}

Property Value

Remarks

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace


GetExtendedProductEntity Property

Aptify 5.0 Software Development Kit (SDK)

ProductObject.GetExtendedProductEntity Property

public virtual String GetExtendedProductEntity {get;}

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace


GetExtendedProductLinkedField Property

Aptify 5.0 Software Development Kit (SDK)

ProductObject.GetExtendedProductLinkedField Property

public virtual String GetExtendedProductLinkedField {get;}

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace


IsDirty Property

Aptify 5.0 Software Development Kit (SDK)

ProductObject.IsDirty Property

This property overrides the base class IsDirty() property to check to see if the Product object is dirty as well as checking the Extended Product Object, if it exists

public override Boolean IsDirty {get;}

Property Value

Remarks

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace


ProductKitType Property

Aptify 5.0 Software Development Kit (SDK)

ProductObject.ProductKitType Property

Gets/Sets the current ProductKitTypeID using the enumerated type ProductData.ProductKitType.

public virtual ProductData.ProductKitType ProductKitType {get; set;}

Property Value

Remarks

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace


ProductPriceObject Property

Aptify 5.0 Software Development Kit (SDK)

ProductObject.ProductPriceObject Property

This method returns the Product Pricing Object to be used for calculating product prices. This method will automatically instantiate the product pricing object to be used based on the setup of the system. See the SetupProductPricingObject() method for more details

public virtual IProductPrice ProductPriceObject {get;}

Property Value

Remarks

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace


ProductTypeID Property

Aptify 5.0 Software Development Kit (SDK)

ProductObject.ProductTypeID Property

Gets/Sets the current product type ID.

protected virtual Int64 ProductTypeID {get; set;}

Property Value

Remarks

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace


RecordChangeXML Property

Aptify 5.0 Software Development Kit (SDK)

ProductObject.RecordChangeXML Property

This method overrides the base class RecordChangeXML property and appends the ReocrdChangeXML from the extended product object, if applicable to the current product.

public override String RecordChangeXML {get;}

Property Value

Remarks

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace


ProductObject Methods

The methods of the ProductObject class are listed below. For a complete list of ProductObject class members, see the ProductObject Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CalculateDerivedPrice | This is a utility function that can be called to employ the standard calculation logic for determining the derived price for a given Base Price and Percent of Base. In addition, if specified, RoundingType and RoundingAmount can be used to round up or down the derived price. Rounding is handled through a call to the RoundPrice() method.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone | Overloaded. This method overrides the base Clone() method and supports cloning the extended product object as well, if it is applicable to the current product.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config | Overloaded.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete | Overloaded. This method overrides the base GE Delete() and also handles the delete of the extended product object related to the Product if an extended product object exists.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Expo | This is a legacy function that is supported for backwards compatibility. Use the GetExtendedProductObject() method to retrieve the extended product object in a generic manner.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
FlowDownGLAccounts | This method is responsible for handling the process of flowing down GL accounts from the product category level to the product level. It clears out any GL accounts that may exist within the Product and replaces them with those in the Product Category.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetBasePrice | This method is responsible for determining the base price for a product in a given Currency Type. The base price is returned through the OUT Parameter Price. The return value of the function is TRUE if a base price was found, otherwise, False is returned if the function does not find a "Base" price defined in the product.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies | Overloaded. This method overrides the base class GetDependencies() method and adds in the dependency information for the extended product object, if one exists for the instance of the Product Object.
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetObjectPrice | Overloaded.
GetPrice | Overloaded.
GetPricingPermissions |
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetRootCategoryName | This method is responsible for retrieving the name of a root category for a given Product Category ID
GetTablePrice | Overloaded.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValidPriceList |
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Housing | This is a legacy function that is supported for backwards compatibility. Use the GetExtendedProductObject() method to retrieve the extended product object in a generic manner.
Load | Overloaded.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Meeting | This is a legacy function that is supported for backwards compatibility. Use the GetExtendedProductObject() method to retrieve the extended product object in a generic manner.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord |
ProductOrganizationHasGL | This method will give return true if the Organization accociated with this Product (or default Organization if not listed) has the GLType listed
ProductPriceConfig |
Publication | This is a legacy function that is supported for backwards compatibility. Use the GetExtendedProductObject() method to retrieve the extended product object in a generic manner.
RecalculateProductPrices | This method will recalculate the prices in the ProductPrices sub-type based on the Base Price and Percent of Base Price Definitions.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
RoundPrice | This method handles the rounding process for a decimal price value, rounding type and rounding amount specified. The return value contains the rounded amount.
Save | Overloaded. This method overrides the base Save() method to handle the process of saving both the Products entity and the contained Extended Product Object as required.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue | Overloaded.
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue |
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateDerivedPrices | This method is responsible for updating all of the prices within the ProductPrices sub-type with new price information based on whenever the Base Price has changed
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
UpdateInventoryQuantities | This method is responsible for updating the inventory quantity information in the object based on information stored in the database. The default implementation of this method uses the spGetProduct stored procedure to retrieve the current inventory quantity information.
Validate | Overloaded. This method overrides the base Validate() method to add in validation for the Extended Product Object if an Extended Product Object exists for the instance of the Product object.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase)
BroadcastChange (inherited from AptifyGenericEntity)
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase)
CloneSubType (inherited from AptifyGenericEntity)
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity)
CreateSubTypeRecord (inherited from AptifyGenericEntity)
CreateTopLevelRecord (inherited from AptifyGenericEntity)
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase)
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity)
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity)
FinishTransactionSubType (inherited from AptifyGenericEntity)
FinishTransactionTopLevel (inherited from AptifyGenericEntity)
FireEvent (inherited from AptifyGenericEntity)
FireValidationEvent (inherited from AptifyGenericEntity)
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity)
GenerateCreateSQL (inherited from AptifyGenericEntity)
GenerateDeleteSQL (inherited from AptifyGenericEntity)
GenerateFieldSQL (inherited from AptifyGenericEntity)
GenerateUpdateSQL (inherited from AptifyGenericEntity)
GetExtendedInfoField | This method returns the field name that is used to for extended product information which is stored in the EntityAttributes for the Products entity. This is done by calling the spGetExtendedInfoField stored procedure.
GetPersonMemberTypes | This method is responsible for returning the member types at the person and company level for a given individual Person ID
GetRootCategory | This method is responsible for returning the name of the Root Product Category associated with the specified Product Category ID. In addition, it optionally returns, via the RootCategoryID parameter, the RootCategoryID value.
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase)
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
IsExpo | This is a legacy function that is supported for backwards compatibility. Use the GetProductTypeID method to determine product type in a generic manner.
IsHousing | This is a legacy function that is supported for backwards compatibility. Use the GetProductTypeID method to determine product type in a generic manner.
IsMeeting | This is a legacy function that is supported for backwards compatibility. Use the GetProductTypeID method to determine product type in a generic manner.
IsPublication | This is a legacy function that is supported for backwards compatibility. Use the GetProductTypeID method to determine product type in a generic manner.
MakeFieldsCopy (inherited from AptifyGenericEntity)
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
PriceOnlyInTable | This method determines if the price is setup in the table only. If a custom pricing object or product-level pricing rule is in place for this product, this method will return False. Otherwise, the function will return True since the product is driven by table-level pricing.
RecordVersionInfo (inherited from AptifyGenericEntity)
RefreshLinkedFields (inherited from AptifyGenericEntity)
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase)
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity)
ResetProductType | This method is responsible for reseting the Extended Product Type, which sets the internal Extended Product Object reference to Nothing and then calls the SetupProductType() method.
RestoreCopiedFields (inherited from AptifyGenericEntity)
RollbackEmbeddedObjects (inherited from AptifyGenericEntity)
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase)
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetProductTypeID | This method is responsible for internally configuring the product object for the specified Product Type ID. The primary purpose behind this is to call the SetupProductType() method after checking to make sure that the Product Type ID is different than what was previously in place for the Product Type ID inside this class instance. If the Product Type ID provided to this method is different than the current Product Type ID, then SetupProductType() is called from this method.
SetRecordID (inherited from AptifyGenericEntityBase)
SetupProductPricingObject | This method is responsible for retrieving and instantiating the product pricing object that is to be used within the system. The default behavior for this method is to use entity attributes stored within the Products entity to retrieve a component that implements the IProductPrice interface and then store a reference to that class instance internally which can be retrieved through the ProductPriceObject property of this class. The entity attributes used by the base implementation of this method are as follows: ProductPricingObject - Aptify object repository location ProductPricingClass - Fully qualified (from root namespace down) name of class ProductPricingAssembly - Name of assembly
SetupProductType | This method is responsible for setting up the internal variables inside this class that represent the "Extended Product Type".
SetupTransaction (inherited from AptifyGenericEntity)
SetupTransactionSubType (inherited from AptifyGenericEntity)
SetupTransactionTopLevel (inherited from AptifyGenericEntity)
UpdateProductCategoryID | This method is called from within the overriden SetValue() method whenever the Product Category linked to the product (through the CategoryID field) is changed. This method is only called when the value has been changed. The base class implementation of this method determines if there are any ProductGLAccounts in the ProductGLAccounts sub-type and if not, then it will flow-down the GL Accounts from the ProductCategory provided. Before the GL Account flow-down occurs, the BeforeGLAccountFlowDown() Event is Raised which provides the container of this object the opportunity to cancel the process. If ProductGLAccounts are already in the Product then the event is also fired, however, the default mode is that the GL Accounts will NOT flow down if there is already data in there. It is possible for the container of the object to implement user-interactivity to determine if the flow-down should occur or to implement other logic as required. In addition to the above, this method also handles updating the ProductTypeID as well as flowing down custom pricing object information, if any exists at the category level.
UpdateRecord (inherited from AptifyGenericEntity)
ValidateDropShipField | Verifies whether user can update the value of Drop Ship field of product
ValidateGLAccounts | Verfies that the Product has all GL Accounts that it will require for proper usage.
ValidateSubTypes (inherited from AptifyGenericEntityBase)
VerifyObject (inherited from AptifyGenericEntity)

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace


ProductObject.CalculateDerivedPrice Method

This is a utility function that can be called to employ the standard calculation logic for determining the derived price for a given Base Price and Percent of Base. In addition, if specified, RoundingType and RoundingAmount can be used to round up or down the derived price. Rounding is handled through a call to the RoundPrice() method.

public virtual decimal CalculateDerivedPrice(
Decimal BasePrice,
Decimal PercentOfBase,
PriceRoundingType RoundingType,
Decimal RoundingAmount
);

Parameters

BasePrice
PercentOfBase
RoundingType
RoundingAmount

Return Value

Implements

IProductPrice.

Remarks

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace


Clone Method

Aptify 5.0 Software Development Kit (SDK)

ProductObject.Clone Method

This method overrides the base Clone() method and supports cloning the extended product object as well, if it is applicable to the current product.

Overload List

Inherited from AptifyGenericEntityBase.

public virtual void Clone(AptifyGenericEntityBase);

This method overrides the base Clone() method and supports cloning the extended product object as well, if it is applicable to the current product.

public override void Clone(AptifyGenericEntityBase,Boolean);

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace


ProductObject.Clone Method (AptifyGenericEntityBase, Boolean)

This method overrides the base Clone() method and supports cloning the extended product object as well, if it is applicable to the current product.

public override void Clone(
AptifyGenericEntityBase ObjectToClone,
Boolean Merge
);

Parameters

ObjectToClone
Merge

Remarks

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace | ProductObject.Clone Overload List


Config Method

Aptify 5.0 Software Development Kit (SDK)

ProductObject.Config Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual void Config(AptifySubTypeBase);

Inherited from AptifyGenericEntity.

public override void Config(AptifySubTypeBase,Int64);

Inherited from AptifyGenericEntityBase.

public virtual void Config(UserCredentials,String);

public override void Config(UserCredentials,String,Int64);

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace


ProductObject.Config Method (UserCredentials, String, Int64)

public override void Config(
UserCredentials UserCredentials,
String EntityName,
Int64 RecordID
);

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace | ProductObject.Config Overload List


Delete Method

Aptify 5.0 Software Development Kit (SDK)

ProductObject.Delete Method

This method overrides the base GE Delete() and also handles the delete of the extended product object related to the Product if an extended product object exists.

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Delete();

This method overrides the base GE Delete() and also handles the delete of the extended product object related to the Product if an extended product object exists.

public override bool Delete(String);

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace


ProductObject.Delete Method (String)

This method overrides the base GE Delete() and also handles the delete of the extended product object related to the Product if an extended product object exists.

public override bool Delete(
String TransactionID
);

Parameters

TransactionID

Return Value

Remarks

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace | ProductObject.Delete Overload List


ProductObject.Expo Method

This is a legacy function that is supported for backwards compatibility. Use the GetExtendedProductObject() method to retrieve the extended product object in a generic manner.

public AptifyGenericEntityBase Expo();

Return Value

Remarks

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace


ProductObject.FlowDownGLAccounts Method

This method is responsible for handling the process of flowing down GL accounts from the product category level to the product level. It clears out any GL accounts that may exist within the Product and replaces them with those in the Product Category.

public virtual bool FlowDownGLAccounts(
Int64 ProductCategoryID
);

Parameters

ProductCategoryID

Return Value

Remarks

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace


ProductObject.GetBasePrice Method

This method is responsible for determining the base price for a product in a given Currency Type. The base price is returned through the OUT Parameter Price. The return value of the function is TRUE if a base price was found, otherwise, False is returned if the function does not find a "Base" price defined in the product.

public virtual bool GetBasePrice(
Int64 CurrencyTypeID,
ref Decimal& BasePrice
);

Parameters

CurrencyTypeID
BasePrice
OUT Paramater: Returns the base price if found

Return Value

True if succesful, False otherwise

Remarks

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace


GetDependencies Method

Aptify 5.0 Software Development Kit (SDK)

ProductObject.GetDependencies Method

This method overrides the base class GetDependencies() method and adds in the dependency information for the extended product object, if one exists for the instance of the Product Object.

Overload List

This method overrides the base class GetDependencies() method and adds in the dependency information for the extended product object, if one exists for the instance of the Product Object.

public override EntityDependenciesBase GetDependencies();

This method overrides the base class GetDependencies() method and adds in the dependency information for the extended product object, if one exists for the instance of the Product Object.

public override bool GetDependencies(ref AptifyGenericEntityBase[]&);

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace


ProductObject.GetDependencies Method ()

This method overrides the base class GetDependencies() method and adds in the dependency information for the extended product object, if one exists for the instance of the Product Object.

public override EntityDependenciesBase GetDependencies();

Return Value

Remarks

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace | ProductObject.GetDependencies Overload List


ProductObject.GetDependencies Method (AptifyGenericEntityBase[]&)

This method overrides the base class GetDependencies() method and adds in the dependency information for the extended product object, if one exists for the instance of the Product Object.

public override bool GetDependencies(
ref AptifyGenericEntityBase[]& GEs
);

Parameters

GEs

Return Value

Remarks

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace | ProductObject.GetDependencies Overload List


ProductObject.GetExtendedInfoField Method

This method returns the field name that is used to for extended product information which is stored in the EntityAttributes for the Products entity. This is done by calling the spGetExtendedInfoField stored procedure.

protected virtual string GetExtendedInfoField();

Return Value

Remarks

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace


GetObjectPrice Method

Aptify 5.0 Software Development Kit (SDK)

ProductObject.GetObjectPrice Method

Overload List

public virtual decimal GetObjectPrice(Int64);

This is a convenience function that returns the default price for the current product for a given person and currency type using a pricing object. This method only works for products that have a pricing object setup. Use the IProductPrice object that is returned by the ProductPriceObject member of this class for the full functionality of product pricing.

public virtual decimal GetObjectPrice(Int64,Int64);

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace


ProductObject.GetObjectPrice Method (Int64)

public virtual decimal GetObjectPrice(
Int64 PersonID
);

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace | ProductObject.GetObjectPrice Overload List


ProductObject.GetObjectPrice Method (Int64, Int64)

This is a convenience function that returns the default price for the current product for a given person and currency type using a pricing object. This method only works for products that have a pricing object setup. Use the IProductPrice object that is returned by the ProductPriceObject member of this class for the full functionality of product pricing.

public virtual decimal GetObjectPrice(
Int64 PersonID,
Int64 CurrencyTypeID
);

Parameters

PersonID
CurrencyTypeID

Return Value

Remarks

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace | ProductObject.GetObjectPrice Overload List


ProductObject.GetPersonMemberTypes Method

This method is responsible for returning the member types at the person and company level for a given individual Person ID

protected virtual bool GetPersonMemberTypes(
Int64 PersonID,
ref Int64& PersonMemberTypeID,
ref Int64& CompanyMemberTypeID
);

Parameters

PersonID
PersonMemberTypeID
CompanyMemberTypeID

Return Value

Remarks

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace


GetPrice Method

Aptify 5.0 Software Development Kit (SDK)

ProductObject.GetPrice Method

Overload List

public PriceOutcome GetPrice(ref PriceInfo&,Int64,Decimal,Int64,OrdersEntity,OrderLinesEntity,AptifyGenericEntityBase,Int64,Int64,Boolean);

public virtual decimal GetPrice(Int64);

This is a convenience function that returns the default price for the current product for a given person and currency type. Use the IProductPrice object that is returned by the ProductPriceObject member of this class for the full functionality of product pricing.

public virtual decimal GetPrice(Int64,Int64);

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace


ProductObject.GetPrice Method (PriceInfo&, Int64, Decimal, Int64, OrdersEntity, OrderLinesEntity, AptifyGenericEntityBase, Int64, Int64, Boolean)

public PriceOutcome GetPrice(
ref PriceInfo& Price,
Int64 ProductID,
Decimal Quantity,
Int64 PersonID,
OrdersEntity OrderGE,
OrderLinesEntity OrderLineGE,
AptifyGenericEntityBase ProductGE,
Int64 CurrencyTypeID,
Int64 DerivedFromCurrencyTypeID,
Boolean CustomPrice
);

Implements

IProductPrice.

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace | ProductObject.GetPrice Overload List


ProductObject.GetPrice Method (Int64)

public virtual decimal GetPrice(
Int64 PersonID
);

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace | ProductObject.GetPrice Overload List


ProductObject.GetPrice Method (Int64, Int64)

This is a convenience function that returns the default price for the current product for a given person and currency type. Use the IProductPrice object that is returned by the ProductPriceObject member of this class for the full functionality of product pricing.

public virtual decimal GetPrice(
Int64 PersonID,
Int64 CurrencyTypeID
);

Parameters

PersonID
CurrencyTypeID

Return Value

Remarks

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace | ProductObject.GetPrice Overload List


ProductObject.GetPricingPermissions Method

public PricingPermissions GetPricingPermissions(
Int64 ProductID
);

Implements

IProductPrice.

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace


ProductObject.GetRootCategory Method

This method is responsible for returning the name of the Root Product Category associated with the specified Product Category ID. In addition, it optionally returns, via the RootCategoryID parameter, the RootCategoryID value.

protected virtual string GetRootCategory(
Int64 ProductCategoryID,
ref Int64& RootCategoryID
);

Parameters

ProductCategoryID
RootCategoryID
OUT Parameter

Return Value

Remarks

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace


ProductObject.GetRootCategoryName Method

This method is responsible for retrieving the name of a root category for a given Product Category ID

public virtual string GetRootCategoryName(
Int64 ProductCategoryID
);

Parameters

ProductCategoryID

Return Value

Remarks

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace


GetTablePrice Method

Aptify 5.0 Software Development Kit (SDK)

ProductObject.GetTablePrice Method

Overload List

public virtual decimal GetTablePrice(Int64);

This is a convenience function that returns the default price for the current product for a given person and currency type using a pricing object. This method only works for products that use table-based pricing(e.g. do not have pricing objects). Use the IProductPrice object that is returned by the ProductPriceObject member of this class for the full functionality of product pricing.

public virtual decimal GetTablePrice(Int64,Int64);

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace


ProductObject.GetTablePrice Method (Int64)

public virtual decimal GetTablePrice(
Int64 PersonID
);

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace | ProductObject.GetTablePrice Overload List


ProductObject.GetTablePrice Method (Int64, Int64)

This is a convenience function that returns the default price for the current product for a given person and currency type using a pricing object. This method only works for products that use table-based pricing(e.g. do not have pricing objects). Use the IProductPrice object that is returned by the ProductPriceObject member of this class for the full functionality of product pricing.

public virtual decimal GetTablePrice(
Int64 PersonID,
Int64 CurrencyTypeID
);

Parameters

PersonID
CurrencyTypeID

Return Value

Remarks

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace | ProductObject.GetTablePrice Overload List


ProductObject.GetValidPriceList Method

public PriceOutcome GetValidPriceList(
ref PriceInfo& Price,
ref List`1& ValidPrices,
Int64 ProductID,
Int64 PersonID,
Decimal Quantity,
OrdersEntity OrderGE,
OrderLinesEntity OrderLineGE,
AptifyGenericEntityBase ProductGE,
Int64 CurrencyTypeID,
Int64 DerivedFromCurrencyTypeID,
Boolean CustomPrice
);

Implements

IProductPrice.

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace


ProductObject.Housing Method

This is a legacy function that is supported for backwards compatibility. Use the GetExtendedProductObject() method to retrieve the extended product object in a generic manner.

public AptifyGenericEntityBase Housing();

Return Value

Remarks

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace


ProductObject.IsExpo Method

This is a legacy function that is supported for backwards compatibility. Use the GetProductTypeID method to determine product type in a generic manner.

protected virtual bool IsExpo();

Return Value

Remarks

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace


ProductObject.IsHousing Method

This is a legacy function that is supported for backwards compatibility. Use the GetProductTypeID method to determine product type in a generic manner.

protected virtual bool IsHousing();

Return Value

Remarks

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace


ProductObject.IsMeeting Method

This is a legacy function that is supported for backwards compatibility. Use the GetProductTypeID method to determine product type in a generic manner.

protected virtual bool IsMeeting();

Return Value

Remarks

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace


ProductObject.IsPublication Method

This is a legacy function that is supported for backwards compatibility. Use the GetProductTypeID method to determine product type in a generic manner.

protected virtual bool IsPublication();

Return Value

Remarks

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace


Load Method

Aptify 5.0 Software Development Kit (SDK)

ProductObject.Load Method

Overload List

public override void Load(DataRow);

public override void Load(IDataReader);

public override void Load(Int64);

Inherited from AptifyGenericEntityBase.

public virtual void Load(String);

public override void Load(String,Boolean);

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace


ProductObject.Load Method (DataRow)

public override void Load(
DataRow DataRow
);

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace | ProductObject.Load Overload List


ProductObject.Load Method (IDataReader)

public override void Load(
IDataReader DataReader
);

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace | ProductObject.Load Overload List


ProductObject.Load Method (Int64)

public override void Load(
Int64 ID
);

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace | ProductObject.Load Overload List


ProductObject.Load Method (String, Boolean)

public override void Load(
String FileName,
Boolean MergeSubTypes
);

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace | ProductObject.Load Overload List


ProductObject.Meeting Method

This is a legacy function that is supported for backwards compatibility. Use the GetExtendedProductObject() method to retrieve the extended product object in a generic manner.

public AptifyGenericEntityBase Meeting();

Return Value

Remarks

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace


ProductObject.NewRecord Method

public override bool NewRecord();

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace


ProductObject.PriceOnlyInTable Method

This method determines if the price is setup in the table only. If a custom pricing object or product-level pricing rule is in place for this product, this method will return False. Otherwise, the function will return True since the product is driven by table-level pricing.

protected virtual bool PriceOnlyInTable();

Return Value

Remarks

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace


ProductObject.ProductOrganizationHasGL Method

This method will give return true if the Organization accociated with this Product (or default Organization if not listed) has the GLType listed

public virtual bool ProductOrganizationHasGL(
String GLType
);

Parameters

GLType
GL Type by name

Return Value

Returns True if the Organization has a GL Account for the Type supplied.

Remarks

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace


ProductObject.ProductPriceConfig Method

public void ProductPriceConfig(
AptifyApplication Application
);

Implements

IProductPrice.

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace


ProductObject.Publication Method

This is a legacy function that is supported for backwards compatibility. Use the GetExtendedProductObject() method to retrieve the extended product object in a generic manner.

public AptifyGenericEntityBase Publication();

Return Value

Remarks

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace


ProductObject.RecalculateProductPrices Method

This method will recalculate the prices in the ProductPrices sub-type based on the Base Price and Percent of Base Price Definitions.

public virtual void RecalculateProductPrices();

Remarks

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace


ProductObject.ResetProductType Method

This method is responsible for reseting the Extended Product Type, which sets the internal Extended Product Object reference to Nothing and then calls the SetupProductType() method.

protected virtual void ResetProductType();

Remarks

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace


ProductObject.RoundPrice Method

This method handles the rounding process for a decimal price value, rounding type and rounding amount specified. The return value contains the rounded amount.

public virtual decimal RoundPrice(
Decimal Price,
PriceRoundingType RoundingType,
Decimal RoundingAmount
);

Parameters

Price
RoundingType
RoundingAmount

Return Value

Implements

IProductPrice.

Remarks

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace


Save Method

Aptify 5.0 Software Development Kit (SDK)

ProductObject.Save Method

This method overrides the base Save() method to handle the process of saving both the Products entity and the contained Extended Product Object as required.

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Save();

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean,ref String&);

This method overrides the base Save() method to handle the process of saving both the Products entity and the contained Extended Product Object as required.

public override bool Save(Boolean,ref String&,String);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(ref String&);

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace


ProductObject.Save Method (Boolean, String&, String)

This method overrides the base Save() method to handle the process of saving both the Products entity and the contained Extended Product Object as required.

public override bool Save(
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

Parameters

AllowGUI
ErrorString
TransactionID

Return Value

Remarks

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace | ProductObject.Save Overload List


SetAddValue Method

Aptify 5.0 Software Development Kit (SDK)

ProductObject.SetAddValue Method

Overload List

public override void SetAddValue(String,Object);

Inherited from AptifyGenericEntity.

public override void SetAddValue(String,String,Object);

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace


ProductObject.SetAddValue Method (String, Object)

public override void SetAddValue(
String FieldName,
Object Value
);

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace | ProductObject.SetAddValue Overload List


ProductObject.SetProductTypeID Method

This method is responsible for internally configuring the product object for the specified Product Type ID. The primary purpose behind this is to call the SetupProductType() method after checking to make sure that the Product Type ID is different than what was previously in place for the Product Type ID inside this class instance. If the Product Type ID provided to this method is different than the current Product Type ID, then SetupProductType() is called from this method.

protected virtual void SetProductTypeID(
Int64 ProductTypeID
);

Parameters

ProductTypeID

Remarks

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace


ProductObject.SetupProductPricingObject Method

This method is responsible for retrieving and instantiating the product pricing object that is to be used within the system. The default behavior for this method is to use entity attributes stored within the Products entity to retrieve a component that implements the IProductPrice interface and then store a reference to that class instance internally which can be retrieved through the ProductPriceObject property of this class. The entity attributes used by the base implementation of this method are as follows: ProductPricingObject - Aptify object repository location ProductPricingClass - Fully qualified (from root namespace down) name of class ProductPricingAssembly - Name of assembly

protected virtual bool SetupProductPricingObject();

Return Value

Remarks

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace


ProductObject.SetupProductType Method

This method is responsible for setting up the internal variables inside this class that represent the "Extended Product Type".

protected virtual bool SetupProductType(
Int64 ProductTypeID
);

Return Value

Remarks

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace


ProductObject.SetValue Method

public override void SetValue(
String FieldName,
Object Value
);

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace


ProductObject.UpdateDerivedPrices Method

This method is responsible for updating all of the prices within the ProductPrices sub-type with new price information based on whenever the Base Price has changed

public virtual void UpdateDerivedPrices(
Int64 CurrencyTypeID,
Decimal NewBasePrice
);

Remarks

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace


ProductObject.UpdateInventoryQuantities Method

This method is responsible for updating the inventory quantity information in the object based on information stored in the database. The default implementation of this method uses the spGetProduct stored procedure to retrieve the current inventory quantity information.

public virtual bool UpdateInventoryQuantities();

Return Value

Remarks

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace


ProductObject.UpdateProductCategoryID Method

This method is called from within the overriden SetValue() method whenever the Product Category linked to the product (through the CategoryID field) is changed. This method is only called when the value has been changed. The base class implementation of this method determines if there are any ProductGLAccounts in the ProductGLAccounts sub-type and if not, then it will flow-down the GL Accounts from the ProductCategory provided. Before the GL Account flow-down occurs, the BeforeGLAccountFlowDown() Event is Raised which provides the container of this object the opportunity to cancel the process. If ProductGLAccounts are already in the Product then the event is also fired, however, the default mode is that the GL Accounts will NOT flow down if there is already data in there. It is possible for the container of the object to implement user-interactivity to determine if the flow-down should occur or to implement other logic as required. In addition to the above, this method also handles updating the ProductTypeID as well as flowing down custom pricing object information, if any exists at the category level.

protected virtual void UpdateProductCategoryID(
Int64 NewCategoryID
);

Parameters

NewCategoryID

Remarks

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace


Validate Method

Aptify 5.0 Software Development Kit (SDK)

ProductObject.Validate Method

This method overrides the base Validate() method to add in validation for the Extended Product Object if an Extended Product Object exists for the instance of the Product object.

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Validate();

This method overrides the base Validate() method to add in validation for the Extended Product Object if an Extended Product Object exists for the instance of the Product object.

public override bool Validate(ref String&);

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace


ProductObject.Validate Method (String&)

This method overrides the base Validate() method to add in validation for the Extended Product Object if an Extended Product Object exists for the instance of the Product object.

public override bool Validate(
ref String& ErrorString
);

Parameters

ErrorString

Return Value

Remarks

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace | ProductObject.Validate Overload List


ProductObject.ValidateDropShipField Method

Verifies whether user can update the value of Drop Ship field of product

protected virtual string ValidateDropShipField(
String ErrorString
);

Parameters

ErrorString

Return Value

error string if not validated. Otherwise empty string

Remarks

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace


ProductObject.ValidateGLAccounts Method

Verfies that the Product has all GL Accounts that it will require for proper usage.

protected virtual string ValidateGLAccounts(
String ErrorString
);

Parameters

ErrorString
An existing ErrorString.

Return Value

The empty string if the GL Accounts were validated. The error string if validation failed.

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace


ProductObject Events

The events of the ProductObject class are listed below. For a complete list of ProductObject class members, see the ProductObject Members topic.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterGLAccountsFlowDown | This event is raised after GL Accounts flow down into the product from the category level which happens when the CategoryID field in the object is set via SetValue()
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeGLAccountsFlowDown | This event is raised before GL Accounts flow down into the product from the category, which happens when the CategoryID field in the object is set via SetValue()
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace


ProductObject.ProductObject.AfterGLAccountsFlowDownEventHandler Event

This event is raised after GL Accounts flow down into the product from the category level which happens when the CategoryID field in the object is set via SetValue()

public event ProductObject.AfterGLAccountsFlowDownEventHandler AfterGLAccountsFlowDown;

Remarks

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace


ProductObject.ProductObject.BeforeGLAccountsFlowDownEventHandler Event

This event is raised before GL Accounts flow down into the product from the category, which happens when the CategoryID field in the object is set via SetValue()

public event ProductObject.BeforeGLAccountsFlowDownEventHandler BeforeGLAccountsFlowDown;

Remarks

See Also

ProductObject Class | Aptify.Applications.ProductSetup Namespace


ProductObject.AfterGLAccountsFlowDownEventHandler Delegate

public delegate void ProductObject.AfterGLAccountsFlowDownEventHandler();

Requirements

Namespace: Aptify.Applications.ProductSetup

Assembly: ProductObject (in ProductObject.dll)

See Also

Aptify.Applications.ProductSetup Namespace


ProductObject.BeforeGLAccountsFlowDownEventHandler Delegate

public delegate void ProductObject.BeforeGLAccountsFlowDownEventHandler(
ref Boolean& Cancel
);

Requirements

Namespace: Aptify.Applications.ProductSetup

Assembly: ProductObject (in ProductObject.dll)

See Also

Aptify.Applications.ProductSetup Namespace


ProductPartsEntity Class

Product Parts Entity is the GE Sub-Class implementation for the ProductParts sub-type entity and provides support for managing assembly parts.

For a list of all members of this type, see ProductPartsEntity Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
ProductPartsEntity

public class ProductPartsEntity : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.ProductSetup

Assembly: ProductObject (in ProductObject.dll)

See Also

ProductPartsEntity Members | Aptify.Applications.ProductSetup Namespace


ProductPartsEntity Members

ProductPartsEntity overview

Public Instance Constructors

ProductPartsEntity Constructor Initializes a new instance of the ProductPartsEntity class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentProductObject | Takes the ProductPrice's ParentGE property value and casts it to a ProductObject object
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded. Performs standard validation and, if that is successful, validates that the Sub Product is not the Parent Product and that, if the Parent Product is a Kit, that the Sub Product is not a kit.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

ProductPartsEntity Class | Aptify.Applications.ProductSetup Namespace


ProductPartsEntity Constructor

Initializes a new instance of the ProductPartsEntity class.

public ProductPartsEntity();

See Also

ProductPartsEntity Class | Aptify.Applications.ProductSetup Namespace


ProductPartsEntity Properties

The properties of the ProductPartsEntity class are listed below. For a complete list of ProductPartsEntity class members, see the ProductPartsEntity Members topic.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentProductObject | Takes the ProductPrice's ParentGE property value and casts it to a ProductObject object
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

ProductPartsEntity Class | Aptify.Applications.ProductSetup Namespace


ParentProductObject Property

Aptify 5.0 Software Development Kit (SDK)

ProductPartsEntity.ParentProductObject Property

Takes the ProductPrice's ParentGE property value and casts it to a ProductObject object

public ProductObject ParentProductObject {get;}

Property Value

Remarks

See Also

ProductPartsEntity Class | Aptify.Applications.ProductSetup Namespace


ProductPartsEntity Methods

The methods of the ProductPartsEntity class are listed below. For a complete list of ProductPartsEntity class members, see the ProductPartsEntity Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded. Performs standard validation and, if that is successful, validates that the Sub Product is not the Parent Product and that, if the Parent Product is a Kit, that the Sub Product is not a kit.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

ProductPartsEntity Class | Aptify.Applications.ProductSetup Namespace


Validate Method

Aptify 5.0 Software Development Kit (SDK)

ProductPartsEntity.Validate Method

Performs standard validation and, if that is successful, validates that the Sub Product is not the Parent Product and that, if the Parent Product is a Kit, that the Sub Product is not a kit.

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Validate();

Performs standard validation and, if that is successful, validates that the Sub Product is not the Parent Product and that, if the Parent Product is a Kit, that the Sub Product is not a kit.

public override bool Validate(ref String&);

See Also

ProductPartsEntity Class | Aptify.Applications.ProductSetup Namespace


ProductPartsEntity.Validate Method (String&)

Performs standard validation and, if that is successful, validates that the Sub Product is not the Parent Product and that, if the Parent Product is a Kit, that the Sub Product is not a kit.

public override bool Validate(
ref String& ErrorString
);

Parameters

ErrorString

Return Value

Remarks

See Also

ProductPartsEntity Class | Aptify.Applications.ProductSetup Namespace | ProductPartsEntity.Validate Overload List


ProductPrice Class

For a list of all members of this type, see ProductPrice Members.

System.Object
ProductPrice

public class ProductPrice : IProductPrice

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.ProductSetup

Assembly: ProductPrice (in ProductPrice.dll)

See Also

ProductPrice Members | Aptify.Applications.ProductSetup Namespace


ProductPrice Members

ProductPrice overview

Public Instance Constructors

ProductPrice Constructor Initializes a new instance of the ProductPrice class.

Public Instance Methods

CalculateDerivedPrice | This is a utility function that can be called to employ the standard calculation logic for determining the derived price for a given Base Price and Percent of Base. In addition, if specified, RoundingType and RoundingAmount can be used to round up or down the derived price. Rounding is handled through a call to the RoundPrice() method.
Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPrice |
GetPricingPermissions | This method returns the product pricing permissions that are defined at the Product level
GetType (inherited from Object) | Gets the Type of the current instance.
GetValidPriceList |
RoundPrice | This method handles the rounding process for a decimal price value, rounding type and rounding amount specified. The return value contains the rounded amount.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CurrencySpotRateRetrieval | This method is called when required by the object internally to setup the spot rate object.
FunctionalCurrencyTypeID | Overloaded. Returns the sytem Functional Currency ID. In a system with multiple Functional Currencies, this method is not appropriate and the FunctionalCurrencyTypeID property that accepts the OrganizationID should be used.
RuleEngine |

Protected Instance Methods

ExecutePriceFilterRule | This method is responsible for executing a pricing filter rule using the FilterRules engine and will return True if the specified Filter Rule Is applicable to the specified set of parameters.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetCalculatedUnitPrice |
GetCustomPrice | This method is called from GetPrice() whenever a product is set up with a Custom Pricing Object
GetDefaultPrice |
GetEntityInstanceUsedFields |
GetMemberInfo | Retrieve the Member Type ID and Name for a given Person and Company. If CompanyID is less than or equal to 0, it is assumed that the Company was not provided and that the Person's CompanyID should be used to retrieve the Company Member Type information. Note that a Person does not have to be linked to a Company. In that case, CompanyMemberTypeID will be set to -1 and CompanyMemberType will be set to an empty string. Core implementation uses the stored procedure spGetPersonAndCompanyMemberTypeInfo.
GetObjectByEntityAttribute | This utility method creates an object and returns it based on specified entity attributes.
GetPriceByRule | This method is called from GetPrice() whenever a price needs to be derived through a Pricing Rule at the Product level.
GetPricingRuleText | This is a utility method that returns the Rule Text from a given Pricing Rule ID
GetProductLevelPricingRule | This method retrieves the Pricing Rule ID that is associated with the specified Product ID and returns the value via the PricingRuleID OUT Parameter.
LoadBillToCompanyEntityInstanceData |
LoadBillToPersonEntityInstanceData |
LoadEntityInstanceData |
LoadOrderEntityInstanceData | This method pulls the required elements from the OrderGE as opposed to going to the database since the Order GE data is live.
LoadOrderLineEntityInstanceData | This method pulls the required elements from the OrderLineGE as opposed to going to the database since the OrderLine GE data is live.
LoadProductEntityInstanceData |
LoadShipToCompanyEntityInstanceData |
LoadShipToPersonEntityInstanceData |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetDefaults |

See Also

ProductPrice Class | Aptify.Applications.ProductSetup Namespace


ProductPrice Constructor

Initializes a new instance of the ProductPrice class.

public ProductPrice();

See Also

ProductPrice Class | Aptify.Applications.ProductSetup Namespace


ProductPrice Properties

The properties of the ProductPrice class are listed below. For a complete list of ProductPrice class members, see the ProductPrice Members topic.

Protected Instance Properties

CurrencySpotRateRetrieval | This method is called when required by the object internally to setup the spot rate object.
FunctionalCurrencyTypeID | Overloaded. Returns the sytem Functional Currency ID. In a system with multiple Functional Currencies, this method is not appropriate and the FunctionalCurrencyTypeID property that accepts the OrganizationID should be used.
RuleEngine |

See Also

ProductPrice Class | Aptify.Applications.ProductSetup Namespace


CurrencySpotRateRetrieval Property

Aptify 5.0 Software Development Kit (SDK)

ProductPrice.CurrencySpotRateRetrieval Property

This method is called when required by the object internally to setup the spot rate object.

protected virtual ISpotRate CurrencySpotRateRetrieval {get;}

Remarks

See Also

ProductPrice Class | Aptify.Applications.ProductSetup Namespace


Int32 Property

Aptify 5.0 Software Development Kit (SDK)

ProductPrice.Int32 Property

Returns the sytem Functional Currency ID. In a system with multiple Functional Currencies, this method is not appropriate and the FunctionalCurrencyTypeID property that accepts the OrganizationID should be used.

Overload List

Returns the sytem Functional Currency ID. In a system with multiple Functional Currencies, this method is not appropriate and the FunctionalCurrencyTypeID property that accepts the OrganizationID should be used.

protected Int32 FunctionalCurrencyTypeID {get;}

Given an Organization ID, return that Organization's Functional Currency Type ID.

protected virtual Int32 this[Int64] {get;}

See Also

ProductPrice Class | Aptify.Applications.ProductSetup Namespace


FunctionalCurrencyTypeID Property

Aptify 5.0 Software Development Kit (SDK)

ProductPrice.FunctionalCurrencyTypeID Property

Returns the sytem Functional Currency ID. In a system with multiple Functional Currencies, this method is not appropriate and the FunctionalCurrencyTypeID property that accepts the OrganizationID should be used.

protected Int32 FunctionalCurrencyTypeID {get;}

Property Value

Remarks

See Also

ProductPrice Class | Aptify.Applications.ProductSetup Namespace | ProductPrice.Int32 Overload List


FunctionalCurrencyTypeID Property (Int64)

Aptify 5.0 Software Development Kit (SDK)

ProductPrice.FunctionalCurrencyTypeID Property (Int64)

Given an Organization ID, return that Organization's Functional Currency Type ID.

protected virtual Int32 this[
Int64 OrganizationID
] {get;}

Parameters

OrganizationID

Property Value

Remarks

See Also

ProductPrice Class | Aptify.Applications.ProductSetup Namespace | ProductPrice.Int32 Overload List


RuleEngine Property

Aptify 5.0 Software Development Kit (SDK)

ProductPrice.RuleEngine Property

protected virtual PricingRuleScriptEngine RuleEngine {get;}

See Also

ProductPrice Class | Aptify.Applications.ProductSetup Namespace


ProductPrice Methods

The methods of the ProductPrice class are listed below. For a complete list of ProductPrice class members, see the ProductPrice Members topic.

Public Instance Methods

CalculateDerivedPrice | This is a utility function that can be called to employ the standard calculation logic for determining the derived price for a given Base Price and Percent of Base. In addition, if specified, RoundingType and RoundingAmount can be used to round up or down the derived price. Rounding is handled through a call to the RoundPrice() method.
Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPrice |
GetPricingPermissions | This method returns the product pricing permissions that are defined at the Product level
GetType (inherited from Object) | Gets the Type of the current instance.
GetValidPriceList |
RoundPrice | This method handles the rounding process for a decimal price value, rounding type and rounding amount specified. The return value contains the rounded amount.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

ExecutePriceFilterRule | This method is responsible for executing a pricing filter rule using the FilterRules engine and will return True if the specified Filter Rule Is applicable to the specified set of parameters.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetCalculatedUnitPrice |
GetCustomPrice | This method is called from GetPrice() whenever a product is set up with a Custom Pricing Object
GetDefaultPrice |
GetEntityInstanceUsedFields |
GetMemberInfo | Retrieve the Member Type ID and Name for a given Person and Company. If CompanyID is less than or equal to 0, it is assumed that the Company was not provided and that the Person's CompanyID should be used to retrieve the Company Member Type information. Note that a Person does not have to be linked to a Company. In that case, CompanyMemberTypeID will be set to -1 and CompanyMemberType will be set to an empty string. Core implementation uses the stored procedure spGetPersonAndCompanyMemberTypeInfo.
GetObjectByEntityAttribute | This utility method creates an object and returns it based on specified entity attributes.
GetPriceByRule | This method is called from GetPrice() whenever a price needs to be derived through a Pricing Rule at the Product level.
GetPricingRuleText | This is a utility method that returns the Rule Text from a given Pricing Rule ID
GetProductLevelPricingRule | This method retrieves the Pricing Rule ID that is associated with the specified Product ID and returns the value via the PricingRuleID OUT Parameter.
LoadBillToCompanyEntityInstanceData |
LoadBillToPersonEntityInstanceData |
LoadEntityInstanceData |
LoadOrderEntityInstanceData | This method pulls the required elements from the OrderGE as opposed to going to the database since the Order GE data is live.
LoadOrderLineEntityInstanceData | This method pulls the required elements from the OrderLineGE as opposed to going to the database since the OrderLine GE data is live.
LoadProductEntityInstanceData |
LoadShipToCompanyEntityInstanceData |
LoadShipToPersonEntityInstanceData |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetDefaults |

See Also

ProductPrice Class | Aptify.Applications.ProductSetup Namespace


ProductPrice.CalculateDerivedPrice Method

This is a utility function that can be called to employ the standard calculation logic for determining the derived price for a given Base Price and Percent of Base. In addition, if specified, RoundingType and RoundingAmount can be used to round up or down the derived price. Rounding is handled through a call to the RoundPrice() method.

public virtual decimal CalculateDerivedPrice(
Decimal BasePrice,
Decimal PercentOfBase,
PriceRoundingType RoundingType,
Decimal RoundingAmount
);

Parameters

BasePrice
PercentOfBase
RoundingType
RoundingAmount

Return Value

Implements

IProductPrice.

Remarks

See Also

ProductPrice Class | Aptify.Applications.ProductSetup Namespace


ProductPrice.Config Method

public void Config(
AptifyApplication Application
);

Implements

IProductPrice.

See Also

ProductPrice Class | Aptify.Applications.ProductSetup Namespace


ProductPrice.ExecutePriceFilterRule Method

This method is responsible for executing a pricing filter rule using the FilterRules engine and will return True if the specified Filter Rule Is applicable to the specified set of parameters.

protected virtual bool ExecutePriceFilterRule(
Int64 FilterRuleID,
Int64 ProductID,
AptifyGenericEntityBase OrderGE,
AptifyGenericEntityBase OrderLineGE,
Boolean RefreshCache
);

Return Value

Remarks

See Also

ProductPrice Class | Aptify.Applications.ProductSetup Namespace


ProductPrice.GetCalculatedUnitPrice Method

protected virtual PriceOutcome GetCalculatedUnitPrice(
Int64 PersonID,
ProductData Product,
Int64 MemberTypeID,
Int64 CompanyMemberTypeID,
Decimal Quantity,
DateTime OrderDate,
ref PriceInfo& Price,
Int64 CurrencyTypeID,
AptifyGenericEntityBase ProductGE,
OrdersEntity OrderGE,
OrderLinesEntity OrderLineGE,
Int32 RecursionLevel
);

See Also

ProductPrice Class | Aptify.Applications.ProductSetup Namespace


ProductPrice.GetCustomPrice Method

This method is called from GetPrice() whenever a product is set up with a Custom Pricing Object

protected virtual PriceOutcome GetCustomPrice(
ref PriceInfo& Price,
Int64 CurrencyTypeID,
ProductData Product,
Decimal Quantity,
Int64 PersonID,
OrdersEntity OrderGE,
OrderLinesEntity OrderLineGE,
AptifyGenericEntityBase ProductGE,
Int64 DerivedFromCurrencyTypeID,
ref Boolean& CustomPrice
);

Parameters

Price
CurrencyTypeID
Product
Quantity
PersonID
OrderGE
OrderLineGE
ProductGE
DerivedFromCurrencyTypeID
CustomPrice

Return Value

Remarks

See Also

ProductPrice Class | Aptify.Applications.ProductSetup Namespace


ProductPrice.GetDefaultPrice Method

protected virtual PriceOutcome GetDefaultPrice(
ProductData Product,
DateTime OrderDate,
Int64 CurrencyTypeID,
Decimal Quantity,
Int64 PersonID,
ref PriceInfo& Price,
AptifyGenericEntityBase ProductGE,
OrdersEntity OrderGE,
OrderLinesEntity OrderLineGE,
Int32 RecursionLevel
);

See Also

ProductPrice Class | Aptify.Applications.ProductSetup Namespace


ProductPrice.GetEntityInstanceUsedFields Method

protected virtual List<T> GetEntityInstanceUsedFields(
String EntityInstance,
FilterRule oFilterRule
);

See Also

ProductPrice Class | Aptify.Applications.ProductSetup Namespace


ProductPrice.GetMemberInfo Method

Retrieve the Member Type ID and Name for a given Person and Company. If CompanyID is less than or equal to 0, it is assumed that the Company was not provided and that the Person's CompanyID should be used to retrieve the Company Member Type information. Note that a Person does not have to be linked to a Company. In that case, CompanyMemberTypeID will be set to -1 and CompanyMemberType will be set to an empty string. Core implementation uses the stored procedure spGetPersonAndCompanyMemberTypeInfo.

protected virtual void GetMemberInfo(
Int64 PersonID,
Int64 CompanyID,
ref Int64& MemberTypeID,
ref Int64& CompanyMemberTypeID,
ref String& MemberType,
ref String& CompanyMemberType
);

Parameters

PersonID
CompanyID
MemberTypeID
CompanyMemberTypeID
MemberType
CompanyMemberType

Remarks

See Also

ProductPrice Class | Aptify.Applications.ProductSetup Namespace


ProductPrice.GetObjectByEntityAttribute Method

This utility method creates an object and returns it based on specified entity attributes.

protected virtual object GetObjectByEntityAttribute(
String Entity,
String ObjectRepositoryLocation,
String ClassName,
String AssemblyName
);

Parameters

Entity
ObjectRepositoryLocation
ClassName
AssemblyName

Return Value

Remarks

See Also

ProductPrice Class | Aptify.Applications.ProductSetup Namespace


ProductPrice.GetPrice Method

public PriceOutcome GetPrice(
ref PriceInfo& Price,
Int64 ProductID,
Decimal Quantity,
Int64 PersonID,
OrdersEntity OrderGE,
OrderLinesEntity OrderLineGE,
AptifyGenericEntityBase ProductGE,
Int64 CurrencyTypeID,
Int64 DerivedFromCurrencyTypeID,
Boolean CustomPrice
);

Implements

IProductPrice.

See Also

ProductPrice Class | Aptify.Applications.ProductSetup Namespace


ProductPrice.GetPriceByRule Method

This method is called from GetPrice() whenever a price needs to be derived through a Pricing Rule at the Product level.

protected virtual PriceOutcome GetPriceByRule(
ref PriceInfo& Price,
Int64 CurrencyTypeID,
Int64 PricingRuleID,
ProductData Product,
Decimal Quantity,
Int64 PersonID,
AptifyGenericEntityBase ProductGE,
OrdersEntity OrderGE,
OrderLinesEntity OrderLineGE
);

Parameters

Price
CurrencyTypeID
PricingRuleID
Product
Quantity
PersonID
ProductGE
OrderGE
OrderLineGE

Return Value

Remarks

See Also

ProductPrice Class | Aptify.Applications.ProductSetup Namespace


ProductPrice.GetPricingPermissions Method

This method returns the product pricing permissions that are defined at the Product level

public PricingPermissions GetPricingPermissions(
Int64 ProductID
);

Parameters

ProductID

Return Value

A PricingPermissions object populated with the current user's pricing permissions for the current product.

Implements

IProductPrice.

Remarks

See Also

ProductPrice Class | Aptify.Applications.ProductSetup Namespace


ProductPrice.GetPricingRuleText Method

This is a utility method that returns the Rule Text from a given Pricing Rule ID

protected virtual PriceOutcome GetPricingRuleText(
Int64 PricingRuleID,
ref String& RuleText
);

Parameters

PricingRuleID
RuleText

Return Value

Remarks

See Also

ProductPrice Class | Aptify.Applications.ProductSetup Namespace


ProductPrice.GetProductLevelPricingRule Method

This method retrieves the Pricing Rule ID that is associated with the specified Product ID and returns the value via the PricingRuleID OUT Parameter.

protected virtual PriceOutcome GetProductLevelPricingRule(
ProductData Product,
ref Int64& PricingRuleID
);

Parameters

Product
PricingRuleID

Return Value

Remarks

See Also

ProductPrice Class | Aptify.Applications.ProductSetup Namespace


ProductPrice.GetValidPriceList Method

public PriceOutcome GetValidPriceList(
ref PriceInfo& Price,
ref List`1& ValidPrices,
Int64 ProductID,
Int64 PersonID,
Decimal Quantity,
OrdersEntity OrderGE,
OrderLinesEntity OrderLineGE,
AptifyGenericEntityBase ProductGE,
Int64 CurrencyTypeID,
Int64 DerivedFromCurrencyTypeID,
Boolean CustomPrice
);

Implements

IProductPrice.

See Also

ProductPrice Class | Aptify.Applications.ProductSetup Namespace


ProductPrice.LoadBillToCompanyEntityInstanceData Method

protected virtual DataRow LoadBillToCompanyEntityInstanceData(
AptifyGenericEntityBase OrderGE,
FilterRule oFilterRule
);

See Also

ProductPrice Class | Aptify.Applications.ProductSetup Namespace


ProductPrice.LoadBillToPersonEntityInstanceData Method

protected virtual DataRow LoadBillToPersonEntityInstanceData(
AptifyGenericEntityBase OrderGE,
FilterRule oFilterRule
);

See Also

ProductPrice Class | Aptify.Applications.ProductSetup Namespace


ProductPrice.LoadEntityInstanceData Method

protected virtual DataRow LoadEntityInstanceData(
String EntityInstance,
String EntityName,
Int64 InstanceRecordID,
FilterRule oFilterRule
);

See Also

ProductPrice Class | Aptify.Applications.ProductSetup Namespace


ProductPrice.LoadOrderEntityInstanceData Method

This method pulls the required elements from the OrderGE as opposed to going to the database since the Order GE data is live.

protected virtual DataRow LoadOrderEntityInstanceData(
AptifyGenericEntityBase OrderGE,
FilterRule oFilterRule
);

Parameters

OrderGE
oFilterRule

Return Value

Remarks

See Also

ProductPrice Class | Aptify.Applications.ProductSetup Namespace


ProductPrice.LoadOrderLineEntityInstanceData Method

This method pulls the required elements from the OrderLineGE as opposed to going to the database since the OrderLine GE data is live.

protected virtual DataRow LoadOrderLineEntityInstanceData(
AptifyGenericEntityBase OrderLineGE,
FilterRule oFilterRule
);

Parameters

OrderLineGE
oFilterRule

Return Value

Remarks

See Also

ProductPrice Class | Aptify.Applications.ProductSetup Namespace


ProductPrice.LoadProductEntityInstanceData Method

protected virtual DataRow LoadProductEntityInstanceData(
Int64 ProductID,
FilterRule oFilterRule
);

See Also

ProductPrice Class | Aptify.Applications.ProductSetup Namespace


ProductPrice.LoadShipToCompanyEntityInstanceData Method

protected virtual DataRow LoadShipToCompanyEntityInstanceData(
AptifyGenericEntityBase OrderGE,
FilterRule oFilterRule
);

See Also

ProductPrice Class | Aptify.Applications.ProductSetup Namespace


ProductPrice.LoadShipToPersonEntityInstanceData Method

protected virtual DataRow LoadShipToPersonEntityInstanceData(
AptifyGenericEntityBase OrderGE,
AptifyGenericEntityBase OrderLineGE,
FilterRule oFilterRule
);

See Also

ProductPrice Class | Aptify.Applications.ProductSetup Namespace


ProductPrice.RoundPrice Method

This method handles the rounding process for a decimal price value, rounding type and rounding amount specified. The return value contains the rounded amount.

public virtual decimal RoundPrice(
Decimal Price,
PriceRoundingType RoundingType,
Decimal RoundingAmount
);

Parameters

Price
RoundingType
RoundingAmount

Return Value

Implements

IProductPrice.

Remarks

See Also

ProductPrice Class | Aptify.Applications.ProductSetup Namespace


ProductPrice.SetDefaults Method

protected virtual void SetDefaults(
OrderLinesEntity OrderLineGE,
OrdersEntity OrderGE,
ref DateTime& OrderDate,
ref Int64& PersonID,
ref Decimal& Quantity
);

See Also

ProductPrice Class | Aptify.Applications.ProductSetup Namespace


ProductPrice.PricingDeterminant Class

For a list of all members of this type, see ProductPrice.PricingDeterminant Members.

System.Object
ProductPrice.PricingDeterminant

protected class ProductPrice.PricingDeterminant

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.ProductSetup

Assembly: ProductPrice (in ProductPrice.dll)

See Also

ProductPrice.PricingDeterminant Members | Aptify.Applications.ProductSetup Namespace


ProductPrice.PricingDeterminant Members

ProductPrice.PricingDeterminant overview

Public Instance Constructors

ProductPrice.PricingDeterminant Constructor Initializes a new instance of the ProductPrice.PricingDeterminant class.

Public Instance Fields

DeterminantID
Name
Outcome
Price
PriceIncludesTax
PricingType

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProductPrice.PricingDeterminant Class | Aptify.Applications.ProductSetup Namespace


ProductPrice.PricingDeterminant Constructor

Initializes a new instance of the ProductPrice.PricingDeterminant class.

public ProductPrice.PricingDeterminant();

See Also

ProductPrice.PricingDeterminant Class | Aptify.Applications.ProductSetup Namespace


ProductPrice.PricingDeterminant Fields

The fields of the ProductPrice.PricingDeterminant class are listed below. For a complete list of ProductPrice.PricingDeterminant class members, see the ProductPrice.PricingDeterminant Members topic.

Public Instance Fields

DeterminantID
Name
Outcome
Price
PriceIncludesTax
PricingType

See Also

ProductPrice.PricingDeterminant Class | Aptify.Applications.ProductSetup Namespace


ProductPrice.PricingDeterminant.DeterminantID Field

public DeterminantID DeterminantID;

See Also

ProductPrice.PricingDeterminant Class | Aptify.Applications.ProductSetup Namespace


ProductPrice.PricingDeterminant.Name Field

public Name Name;

See Also

ProductPrice.PricingDeterminant Class | Aptify.Applications.ProductSetup Namespace


ProductPrice.PricingDeterminant.Outcome Field

public Outcome Outcome;

See Also

ProductPrice.PricingDeterminant Class | Aptify.Applications.ProductSetup Namespace


ProductPrice.PricingDeterminant.Price Field

public Price Price;

See Also

ProductPrice.PricingDeterminant Class | Aptify.Applications.ProductSetup Namespace


ProductPrice.PricingDeterminant.PriceIncludesTax Field

public PriceIncludesTax PriceIncludesTax;

See Also

ProductPrice.PricingDeterminant Class | Aptify.Applications.ProductSetup Namespace


ProductPrice.PricingDeterminant.PricingType Field

public PricingType PricingType;

See Also

ProductPrice.PricingDeterminant Class | Aptify.Applications.ProductSetup Namespace


ProductPrice.PricingType Enumeration

protected enum ProductPrice.PricingType

Members

Member Name | Description
PTConstant |
PTObject |
PTRule |
PTDerivedCurrency |

Requirements

Namespace: Aptify.Applications.ProductSetup

Assembly: ProductPrice (in ProductPrice.dll)

See Also

Aptify.Applications.ProductSetup Namespace


ProductPriceCurrencyTypeMismatchException Class

Raised when the Price is returned with a different Currency Type then what was requested. This can occur when a price is provided by a Pricing Object or Pricing Rule.

For a list of all members of this type, see ProductPriceCurrencyTypeMismatchException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
ProductPriceException
ProductPriceCurrencyTypeMismatchException

public class ProductPriceCurrencyTypeMismatchException : ProductPriceException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.ProductSetup

Assembly: ProductPrice (in ProductPrice.dll)

See Also

ProductPriceCurrencyTypeMismatchException Members | Aptify.Applications.ProductSetup Namespace


ProductPriceCurrencyTypeMismatchException Members

ProductPriceCurrencyTypeMismatchException overview

Public Instance Constructors

ProductPriceCurrencyTypeMismatchException Overloaded. Initializes a new instance of the ProductPriceCurrencyTypeMismatchException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
CurrencyTypeIDRequested |
CurrencyTypeIDReturned |
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from BaseApplicationException) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProductPriceCurrencyTypeMismatchException Class | Aptify.Applications.ProductSetup Namespace


ProductPriceCurrencyTypeMismatchException Constructor

Overload List

public ProductPriceCurrencyTypeMismatchException(Int32,Int32,Exception);

public ProductPriceCurrencyTypeMismatchException(Int64,Int64);

public ProductPriceCurrencyTypeMismatchException(SerializationInfo,StreamingContext);

See Also

ProductPriceCurrencyTypeMismatchException Class | Aptify.Applications.ProductSetup Namespace


ProductPriceCurrencyTypeMismatchException Constructor (Int64, Int64)

public ProductPriceCurrencyTypeMismatchException(
Int64 CurrencyTypeIDRequested,
Int64 CurrencyTypeIDReturned
);

See Also

ProductPriceCurrencyTypeMismatchException Class | Aptify.Applications.ProductSetup Namespace | ProductPriceCurrencyTypeMismatchException Constructor Overload List


ProductPriceCurrencyTypeMismatchException Constructor (Int32, Int32, Exception)

public ProductPriceCurrencyTypeMismatchException(
Int32 CurrencyTypeIDRequested,
Int32 CurrencyTypeIDReturned,
Exception inner
);

See Also

ProductPriceCurrencyTypeMismatchException Class | Aptify.Applications.ProductSetup Namespace | ProductPriceCurrencyTypeMismatchException Constructor Overload List


ProductPriceCurrencyTypeMismatchException Constructor (SerializationInfo, StreamingContext)

public ProductPriceCurrencyTypeMismatchException(
SerializationInfo info,
StreamingContext context
);

See Also

ProductPriceCurrencyTypeMismatchException Class | Aptify.Applications.ProductSetup Namespace | ProductPriceCurrencyTypeMismatchException Constructor Overload List


ProductPriceCurrencyTypeMismatchException Properties

The properties of the ProductPriceCurrencyTypeMismatchException class are listed below. For a complete list of ProductPriceCurrencyTypeMismatchException class members, see the ProductPriceCurrencyTypeMismatchException Members topic.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
CurrencyTypeIDRequested |
CurrencyTypeIDReturned |
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

See Also

ProductPriceCurrencyTypeMismatchException Class | Aptify.Applications.ProductSetup Namespace


CurrencyTypeIDRequested Property

Aptify 5.0 Software Development Kit (SDK)

ProductPriceCurrencyTypeMismatchException.CurrencyTypeIDRequested Property

public Int32 CurrencyTypeIDRequested {get;}

See Also

ProductPriceCurrencyTypeMismatchException Class | Aptify.Applications.ProductSetup Namespace


CurrencyTypeIDReturned Property

Aptify 5.0 Software Development Kit (SDK)

ProductPriceCurrencyTypeMismatchException.CurrencyTypeIDReturned Property

public Int32 CurrencyTypeIDReturned {get;}

See Also

ProductPriceCurrencyTypeMismatchException Class | Aptify.Applications.ProductSetup Namespace


ProductPriceException Class

For a list of all members of this type, see ProductPriceException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
ProductPriceException
ProductPriceCurrencyTypeMismatchException

public class ProductPriceException : BaseApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.ProductSetup

Assembly: ProductPrice (in ProductPrice.dll)

See Also

ProductPriceException Members | Aptify.Applications.ProductSetup Namespace


ProductPriceException Members

ProductPriceException overview

Public Instance Constructors

ProductPriceException Overloaded. Initializes a new instance of the ProductPriceException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from BaseApplicationException) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProductPriceException Class | Aptify.Applications.ProductSetup Namespace


ProductPriceException Constructor

Overload List

public ProductPriceException(SerializationInfo,StreamingContext);

public ProductPriceException(String);

public ProductPriceException(String,Exception);

See Also

ProductPriceException Class | Aptify.Applications.ProductSetup Namespace


ProductPriceException Constructor (String)

public ProductPriceException(
String Message
);

See Also

ProductPriceException Class | Aptify.Applications.ProductSetup Namespace | ProductPriceException Constructor Overload List


ProductPriceException Constructor (String, Exception)

public ProductPriceException(
String Message,
Exception inner
);

See Also

ProductPriceException Class | Aptify.Applications.ProductSetup Namespace | ProductPriceException Constructor Overload List


ProductPriceException Constructor (SerializationInfo, StreamingContext)

public ProductPriceException(
SerializationInfo info,
StreamingContext context
);

See Also

ProductPriceException Class | Aptify.Applications.ProductSetup Namespace | ProductPriceException Constructor Overload List


ProductPriceObject Class

Product Price Object is the GE Sub-Class implementation for the ProductPrices sub-type entity and provides support for managing base prices and derived prices.

For a list of all members of this type, see ProductPriceObject Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
ProductPriceObject

public class ProductPriceObject : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.ProductSetup

Assembly: ProductObject (in ProductObject.dll)

See Also

ProductPriceObject Members | Aptify.Applications.ProductSetup Namespace


ProductPriceObject Members

ProductPriceObject overview

Public Instance Constructors

ProductPriceObject Constructor Initializes a new instance of the ProductPriceObject class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrencyTypeID |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentProductObject | Takes the ProductPrice's ParentGE property value and casts it to a ProductObject object
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PriceType |
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RoundingType |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
NotifyProductGEOfBasePriceChange | This method is responsible for notifying the parent GE(Product object) that the base price has changed. It is called from within SetValue whenever the price has chagned and the current ProductPrice record is set to Type of Base Price
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded. This method overrides the base functionality to ensure that if the product price has a filter rule setup, that the product price filter rule is named appropriately.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue | This method overrides the base functionality to automatically handle updating base prices as well as percent of base prices.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateDerivedPrice | This method is responsible for updating the price within the price record, but only if the type field is set to "Percent Of Base". This method first checks the current price type and if it is set to Percent of Base, then it updates its internal Price field based on the PercentOfBase and the New Base Price parameter
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded. In addition to the core validation provided by the GE, this method ensures that only one Base Price per Currency Type per Product is allowed.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

ProductPriceObject Class | Aptify.Applications.ProductSetup Namespace


ProductPriceObject Constructor

Initializes a new instance of the ProductPriceObject class.

public ProductPriceObject();

See Also

ProductPriceObject Class | Aptify.Applications.ProductSetup Namespace


ProductPriceObject Properties

The properties of the ProductPriceObject class are listed below. For a complete list of ProductPriceObject class members, see the ProductPriceObject Members topic.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrencyTypeID |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentProductObject | Takes the ProductPrice's ParentGE property value and casts it to a ProductObject object
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PriceType |
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RoundingType |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

ProductPriceObject Class | Aptify.Applications.ProductSetup Namespace


CurrencyTypeID Property

Aptify 5.0 Software Development Kit (SDK)

ProductPriceObject.CurrencyTypeID Property

public Int64 CurrencyTypeID {get;}

See Also

ProductPriceObject Class | Aptify.Applications.ProductSetup Namespace


ParentProductObject Property

Aptify 5.0 Software Development Kit (SDK)

ProductPriceObject.ParentProductObject Property

Takes the ProductPrice's ParentGE property value and casts it to a ProductObject object

public ProductObject ParentProductObject {get;}

Property Value

Remarks

See Also

ProductPriceObject Class | Aptify.Applications.ProductSetup Namespace


PriceType Property

Aptify 5.0 Software Development Kit (SDK)

ProductPriceObject.PriceType Property

public virtual PriceBaseType PriceType {get; set;}

See Also

ProductPriceObject Class | Aptify.Applications.ProductSetup Namespace


RoundingType Property

Aptify 5.0 Software Development Kit (SDK)

ProductPriceObject.RoundingType Property

public virtual PriceRoundingType RoundingType {get; set;}

See Also

ProductPriceObject Class | Aptify.Applications.ProductSetup Namespace


ProductPriceObject Methods

The methods of the ProductPriceObject class are listed below. For a complete list of ProductPriceObject class members, see the ProductPriceObject Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
NotifyProductGEOfBasePriceChange | This method is responsible for notifying the parent GE(Product object) that the base price has changed. It is called from within SetValue whenever the price has chagned and the current ProductPrice record is set to Type of Base Price
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded. This method overrides the base functionality to ensure that if the product price has a filter rule setup, that the product price filter rule is named appropriately.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue | This method overrides the base functionality to automatically handle updating base prices as well as percent of base prices.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateDerivedPrice | This method is responsible for updating the price within the price record, but only if the type field is set to "Percent Of Base". This method first checks the current price type and if it is set to Percent of Base, then it updates its internal Price field based on the PercentOfBase and the New Base Price parameter
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded. In addition to the core validation provided by the GE, this method ensures that only one Base Price per Currency Type per Product is allowed.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

ProductPriceObject Class | Aptify.Applications.ProductSetup Namespace


ProductPriceObject.NotifyProductGEOfBasePriceChange Method

This method is responsible for notifying the parent GE(Product object) that the base price has changed. It is called from within SetValue whenever the price has chagned and the current ProductPrice record is set to Type of Base Price

public virtual void NotifyProductGEOfBasePriceChange(
Int64 CurrencyTypeID,
Decimal NewBasePrice
);

Remarks

See Also

ProductPriceObject Class | Aptify.Applications.ProductSetup Namespace


Save Method

Aptify 5.0 Software Development Kit (SDK)

ProductPriceObject.Save Method

This method overrides the base functionality to ensure that if the product price has a filter rule setup, that the product price filter rule is named appropriately.

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Save();

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean,ref String&);

This method overrides the base functionality to ensure that if the product price has a filter rule setup, that the product price filter rule is named appropriately.

public override bool Save(Boolean,ref String&,String);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(ref String&);

See Also

ProductPriceObject Class | Aptify.Applications.ProductSetup Namespace


ProductPriceObject.Save Method (Boolean, String&, String)

This method overrides the base functionality to ensure that if the product price has a filter rule setup, that the product price filter rule is named appropriately.

public override bool Save(
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

Parameters

AllowGUI
ErrorString
TransactionID

Return Value

Remarks

See Also

ProductPriceObject Class | Aptify.Applications.ProductSetup Namespace | ProductPriceObject.Save Overload List


ProductPriceObject.SetValue Method

This method overrides the base functionality to automatically handle updating base prices as well as percent of base prices.

public override void SetValue(
String FieldName,
Object Value
);

Parameters

FieldName
Value

Remarks

See Also

ProductPriceObject Class | Aptify.Applications.ProductSetup Namespace


ProductPriceObject.UpdateDerivedPrice Method

This method is responsible for updating the price within the price record, but only if the type field is set to "Percent Of Base". This method first checks the current price type and if it is set to Percent of Base, then it updates its internal Price field based on the PercentOfBase and the New Base Price parameter

public virtual void UpdateDerivedPrice(
Decimal NewBasePrice
);

Parameters

NewBasePrice

Remarks

See Also

ProductPriceObject Class | Aptify.Applications.ProductSetup Namespace


Validate Method

Aptify 5.0 Software Development Kit (SDK)

ProductPriceObject.Validate Method

In addition to the core validation provided by the GE, this method ensures that only one Base Price per Currency Type per Product is allowed.

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Validate();

In addition to the core validation provided by the GE, this method ensures that only one Base Price per Currency Type per Product is allowed.

public override bool Validate(ref String&);

See Also

ProductPriceObject Class | Aptify.Applications.ProductSetup Namespace


ProductPriceObject.Validate Method (String&)

In addition to the core validation provided by the GE, this method ensures that only one Base Price per Currency Type per Product is allowed.

public override bool Validate(
ref String& ErrorString
);

Parameters

ErrorString

Return Value

Remarks

See Also

ProductPriceObject Class | Aptify.Applications.ProductSetup Namespace | ProductPriceObject.Validate Overload List


Aptify.Applications.ProductSetup.WebAccess

Aptify 5.0 Software Development Kit (SDK)

Aptify.Applications.ProductSetup.WebAccess Namespace

This namespace contains the Web Layout Control for the Products form used by Aptify Web Access (AWA).

Namespace hierarchy

Classes

Class | Description
ProductLayoutControl | ASP.NET Server control sub-class for the Aptify CRM Products Entity.
WebExtendedProduct |


ProductLayoutControl Class

ASP.NET Server control sub-class for the Aptify CRM Products Entity.

For a list of all members of this type, see ProductLayoutControl Members.

System.Object
Control
WebControl
CompositeControl
WebFormTemplateLayout
ProductLayoutControl

public class ProductLayoutControl : WebFormTemplateLayout, ICallbackEventHandler

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.ProductSetup.WebAccess

Assembly: ProductsAWAGUI (in ProductsAWAGUI.dll)

See Also

ProductLayoutControl Members | Aptify.Applications.ProductSetup.WebAccess Namespace


ProductLayoutControl Members

ProductLayoutControl overview

Public Instance Constructors

ProductLayoutControl Constructor Initializes a new instance of the ProductLayoutControl class.

Public Instance Properties

AccessKey (inherited from WebControl) | Gets or sets the access key that allows you to quickly navigate to the Web server control.
ApplicationObject (inherited from WebFormTemplateLayout) | Returns an instance of the AptifyApplication class
AppRelativeTemplateSourceDirectory (inherited from Control) | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control.
Attributes (inherited from WebControl) | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control.
BackColor (inherited from WebControl) | Gets or sets the background color of the Web server control.
BindingContainer (inherited from Control) | Gets the control that contains this control's data binding.
BorderColor (inherited from WebControl) | Gets or sets the border color of the Web control.
BorderStyle (inherited from WebControl) | Gets or sets the border style of the Web server control.
BorderWidth (inherited from WebControl) | Gets or sets the border width of the Web server control.
ClientID (inherited from Control) | Gets the server control identifier generated by ASP.NET.
Control (inherited from WebFormTemplateLayout) |
Controls (inherited from CompositeControl) | Gets a ControlCollection object that represents the child controls in a CompositeControl.
ControlStyle (inherited from WebControl) | Gets the style of the Web server control. This property is used primarily by control developers.
ControlStyleCreated (inherited from WebControl) | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers.
CssClass (inherited from WebControl) | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.
Enabled (inherited from WebControl) | Gets or sets a value indicating whether the Web server control is enabled.
EnableTheming (inherited from WebControl) | Gets or sets a value indicating whether themes apply to this control.
EnableViewState (inherited from Control) | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client.
FillHeight (inherited from WebFormTemplateLayout) | This property determines if this element will automatically fill the height of the document window in the browser. The default value is False. Set this value to True in order to ensure proper sizing of the Form Template Layout control and its child controls
FillHeightMargin (inherited from WebFormTemplateLayout) | Only used if FillHeight=True, Specifies the number of pixels of space to between the bottom of the control and its parent's bottom edge
FillWidth (inherited from WebFormTemplateLayout) | This property determines if this element will automatically fill the width of the document window in the browser. The default value is False. Set this value to True in order to ensure proper sizing of the Form Template Layout control and its child controls
FillWidthMargin (inherited from WebFormTemplateLayout) | Only used if FillWidth=True, Specifies the number of pixles of space to leave at the right of the control between its right side and the right of its parent control
Font (inherited from WebControl) | Gets the font properties associated with the Web server control.
ForeColor (inherited from WebControl) | Gets or sets the foreground color (typically the color of the text) of the Web server control.
FormTemplateContext (inherited from WebFormTemplateLayout) |
FormTemplateID (inherited from WebFormTemplateLayout) |
FormTemplateMetaData (inherited from WebFormTemplateLayout) | Returns the meta-data for the currently loaded form template. This property is only available after FormComponentConfig() has been called.
HasAttributes (inherited from WebControl) | Gets a value indicating whether the control has attributes set.
Height (inherited from WebControl) | Gets or sets the height of the Web server control.
ID (inherited from Control) | Gets or sets the programmatic identifier assigned to the server control.
LeftOffset (inherited from WebFormTemplateLayout) |
NamingContainer (inherited from Control) | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value.
Page (inherited from Control) | Gets a reference to the Page instance that contains the server control.
Parent (inherited from Control) | Gets a reference to the server control's parent control in the page control hierarchy.
RefreshDatabase (inherited from WebFormTemplateLayout) | Determines if the Form Template Cache will be reloaded or not, Defaults to False
Site (inherited from Control) | Gets information about the container that hosts the current control when rendered on a design surface.
SkinID (inherited from WebControl) | Gets or sets the skin to apply to the control.
Style (inherited from WebControl) | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control.
TabIndex (inherited from WebControl) | Gets or sets the tab index of the Web server control.
TemplateControl (inherited from Control) | Gets or sets a reference to the template that contains this control.
TemplateSourceDirectory (inherited from Control) | Gets the virtual directory of the Page or UserControl that contains the current server control.
ToolTip (inherited from WebControl) | Gets or sets the text displayed when the mouse pointer hovers over the Web server control.
TopOffset (inherited from WebFormTemplateLayout) |
UniqueID (inherited from Control) | Gets the unique, hierarchically qualified identifier for the server control.
Visible (inherited from Control) | Gets or sets a value that indicates whether a server control is rendered as UI on the page.
Width (inherited from WebControl) | Gets or sets the width of the Web server control.

Public Instance Methods

ApplyStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers.
ApplyStyleSheetSkin (inherited from Control) | Applies the style properties defined in the page style sheet to the control.
CopyBaseAttributes (inherited from WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers.
DataBind (inherited from CompositeControl) | Overloaded. Binds a data source to the CompositeControl and all its child controls.
Dispose (inherited from Control) | Enables a server control to perform final clean up before it is released from memory.
DoControlLoading (inherited from WebFormTemplateLayout) | This method loads controls from the Form Template Layout meta-data definition
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindControl (inherited from Control) | Overloaded. Searches the current naming container for a server control with the specified id parameter.
Focus (inherited from Control) | Sets input focus to a control.
FormComponentConfig (inherited from WebFormTemplateLayout) |
GetCallbackResult | This method is required by ICallbackEventHandler. Result of the Callback gets sent back to the Client-side function by this method. The JavaScript function can be modified to do whatever is necessary with the results.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from WebFormTemplateLayout) |
GetType (inherited from Object) | Gets the Type of the current instance.
HasControls (inherited from Control) | Determines if the server control contains any child controls.
Hide (inherited from WebFormTemplateLayout) |
MergeStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers.
RaiseCallbackEvent | This method is required by ICallbackEventHandler. This method is the server-side of the asynchronous callback event. Here is where all the functionality is defined for what to do on a Callback.
Refresh | Overrides Refresh to handle setting control enabled bits right before rendering occurs
RenderBeginTag (inherited from WebControl) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers.
RenderControl (inherited from Control) | Overloaded. Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
RenderEndTag (inherited from WebControl) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers.
ResolveClientUrl (inherited from Control) | Gets a URL that can be used by the browser.
ResolveUrl (inherited from Control) | Converts a URL into one that is usable on the requesting client.
SetRenderMethodDelegate (inherited from Control) | Assigns an event handler delegate to render the server control and its content into its parent control.
Show (inherited from WebFormTemplateLayout) | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.
TransferDataToObject (inherited from WebFormTemplateLayout) |

Public Instance Events

DataBinding (inherited from WebFormTemplateLayout)
Disposed (inherited from WebFormTemplateLayout)
Init (inherited from WebFormTemplateLayout)
Load (inherited from WebFormTemplateLayout)
PreRender (inherited from WebFormTemplateLayout)
Unload (inherited from WebFormTemplateLayout)
ValueChanged (inherited from WebFormTemplateLayout)

Protected Instance Fields

m_bFillHeight (inherited from WebFormTemplateLayout)
m_bFillWidth (inherited from WebFormTemplateLayout)
m_iFillHeightMargin (inherited from WebFormTemplateLayout)
m_iFillWidthMargin (inherited from WebFormTemplateLayout)

Protected Instance Properties

Adapter (inherited from Control) | Gets the browser-specific adapter for the control.
ChildControlsCreated (inherited from Control) | Gets a value that indicates whether the server control's child controls have been created.
ClientIDSeparator (inherited from Control) | Gets a character value representing the separator character used in the ClientID property.
Events (inherited from Control) | Gets a list of event handler delegates for the control. This property is read-only.
HasChildViewState (inherited from Control) | Gets a value indicating whether the current server control's child controls have any saved view-state settings.
IdSeparator (inherited from Control) | Gets the character used to separate control identifiers.
IsTrackingViewState (inherited from Control) | Gets a value that indicates whether the server control is saving changes to its view state.
LoadViewStateByID (inherited from Control) | Gets a value indicating whether the control participates in loading its view state by ID instead of index.
TagKey (inherited from WebControl) | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers.
TagName (inherited from WebControl) | Gets the name of the control tag. This property is used primarily by control developers.
ViewState (inherited from Control) | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page.
ViewStateIgnoresCase (inherited from Control) | Gets a value that indicates whether the StateBag object is case-insensitive.

Protected Instance Methods

AddAttributesToRender (inherited from WebControl) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers.
AddParsedSubObject (inherited from Control) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object.
BuildProfileTree (inherited from Control) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page.
ClearChildControlState (inherited from Control) | Deletes the control-state information for the server control's child controls.
ClearChildState (inherited from Control) | Deletes the view-state and control-state information for all the server control's child controls.
ClearChildViewState (inherited from Control) | Deletes the view-state information for all the server control's child controls.
CreateChildControls |
CreateControlCollection (inherited from Control) | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control.
CreateControlStyle (inherited from WebControl) | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers.
DataBind (inherited from Control) | Overloaded. Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.
DataBindChildren (inherited from Control) | Binds a data source to the server control's child controls.
EnableFormComponent (inherited from WebFormTemplateLayout) | This method is responsible for enabling or disabling the specified control based on the name of the component or the data field. Internally implemented by calling GetFormComponent()
EnsureChildControls (inherited from Control) | Determines whether the server control contains child controls. If it does not, it creates child controls.
EnsureID (inherited from Control) | Creates an identifier for controls that do not have an identifier assigned.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FindControl (inherited from Control) | Overloaded. Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl method.
GetDesignModeState (inherited from Control) | Gets design-time data for a control.
GetFormComponent (inherited from WebFormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
HasEvents (inherited from Control) | Returns a value indicating whether events are registered for the control or any child controls.
IsFormComponent (inherited from WebFormTemplateLayout) | This method determines if the provided component is a valid Aptify Form Component, which is determined by checking to see if any of the following conditions is True: 1) Derived from WebFormCompnentBase 2) Implements IWebFormComponent 3) Derived from WebFormTemplateLayout 4) Derived from WebFormTemplateTab
IsLiteralContent (inherited from Control) | Determines if the server control holds only literal content.
LoadViewState (inherited from WebControl) | Restores view-state information from a previous request that was saved with the SaveViewState method.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnBubbleEvent (inherited from Control) | Determines whether the event for the server control is passed up the page's UI server control hierarchy.
OnDataBinding (inherited from Control) | Raises the DataBinding event.
OnInit (inherited from WebFormTemplateLayout) |
OnLoad |
RaiseBubbleEvent (inherited from Control) | Assigns any sources of the event and its information to the control's parent.
ReconstituteComponentCollection (inherited from WebFormTemplateLayout) | This method will rebuild the internal Form Component collection from the ASP.NET control hierarchy.
RecreateChildControls (inherited from CompositeControl) | Recreates the child controls n a control derived from CompositeControl.
RenderControl (inherited from Control) | Overloaded. Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.
ResolveAdapter (inherited from Control) | Gets the control adapter responsible for rendering the specified control.
SaveViewState (inherited from WebControl) | Saves any state that was modified after the TrackViewState method was invoked.
SetControlsEnabled | This member is responsible for setting control enabled bits on the server side. It is called from the Refresh() method.
SetDesignModeState (inherited from Control) | Sets design-time data for a control.
SetupClientHandlers | This method is responsible for setting up the Callback functionality. Currently, this is being used for retriving Type related to category selected. The Result and Error JavaScript functions are defined in RegisterJavaScripts sub.
TrackViewState (inherited from WebControl) | Causes the control to track changes to its view state so they can be stored in the object's ViewState property.

Protected Internal Instance Properties

Context (inherited from Control) | Gets the HttpContext object associated with the server control for the current Web request.
DesignMode (inherited from Control) | Gets a value indicating whether a control is being used on a design surface.
IsChildControlStateCleared (inherited from Control) | Gets a value indicating whether controls contained within this control have control state.
IsEnabled (inherited from WebControl) | Gets a value indicating whether the control is enabled.
IsViewStateEnabled (inherited from Control) | Gets a value indicating whether view state is enabled for this control.

Protected Internal Instance Methods

AddedControl (inherited from Control) | Called after a child control is added to the Controls collection of the Control object.
LoadControlState (inherited from Control) | Restores control-state information from a previous page request that was saved by the SaveControlState method.
MapPathSecure (inherited from Control) | Retrieves the physical path that a virtual path, either absolute or relative, maps to.
OnPreRender (inherited from Control) | Raises the PreRender event.
OnUnload (inherited from Control) | Raises the Unload event.
OpenFile (inherited from Control) | Gets a Stream used to read a file.
RemovedControl (inherited from Control) | Called after a control is removed from the Controls collection of another control.
Render (inherited from CompositeControl) | Writes the CompositeControl content to the specified HtmlTextWriter object, for display on the client.
RenderChildren (inherited from Control) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client.
RenderContents (inherited from WebControl) | Renders the contents of the control to the specified writer. This method is used primarily by control developers.
SaveControlState (inherited from Control) | Saves any server control state changes that have occurred since the time the page was posted back to the server.

See Also

ProductLayoutControl Class | Aptify.Applications.ProductSetup.WebAccess Namespace


ProductLayoutControl Constructor

Initializes a new instance of the ProductLayoutControl class.

public ProductLayoutControl();

See Also

ProductLayoutControl Class | Aptify.Applications.ProductSetup.WebAccess Namespace


ProductLayoutControl Methods

The methods of the ProductLayoutControl class are listed below. For a complete list of ProductLayoutControl class members, see the ProductLayoutControl Members topic.

Public Instance Methods

ApplyStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers.
ApplyStyleSheetSkin (inherited from Control) | Applies the style properties defined in the page style sheet to the control.
CopyBaseAttributes (inherited from WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers.
DataBind (inherited from CompositeControl) | Overloaded. Binds a data source to the CompositeControl and all its child controls.
Dispose (inherited from Control) | Enables a server control to perform final clean up before it is released from memory.
DoControlLoading (inherited from WebFormTemplateLayout) | This method loads controls from the Form Template Layout meta-data definition
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindControl (inherited from Control) | Overloaded. Searches the current naming container for a server control with the specified id parameter.
Focus (inherited from Control) | Sets input focus to a control.
FormComponentConfig (inherited from WebFormTemplateLayout) |
GetCallbackResult | This method is required by ICallbackEventHandler. Result of the Callback gets sent back to the Client-side function by this method. The JavaScript function can be modified to do whatever is necessary with the results.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from WebFormTemplateLayout) |
GetType (inherited from Object) | Gets the Type of the current instance.
HasControls (inherited from Control) | Determines if the server control contains any child controls.
Hide (inherited from WebFormTemplateLayout) |
MergeStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers.
RaiseCallbackEvent | This method is required by ICallbackEventHandler. This method is the server-side of the asynchronous callback event. Here is where all the functionality is defined for what to do on a Callback.
Refresh | Overrides Refresh to handle setting control enabled bits right before rendering occurs
RenderBeginTag (inherited from WebControl) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers.
RenderControl (inherited from Control) | Overloaded. Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
RenderEndTag (inherited from WebControl) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers.
ResolveClientUrl (inherited from Control) | Gets a URL that can be used by the browser.
ResolveUrl (inherited from Control) | Converts a URL into one that is usable on the requesting client.
SetRenderMethodDelegate (inherited from Control) | Assigns an event handler delegate to render the server control and its content into its parent control.
Show (inherited from WebFormTemplateLayout) | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.
TransferDataToObject (inherited from WebFormTemplateLayout) |

Protected Instance Methods

AddAttributesToRender (inherited from WebControl) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers.
AddParsedSubObject (inherited from Control) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object.
BuildProfileTree (inherited from Control) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page.
ClearChildControlState (inherited from Control) | Deletes the control-state information for the server control's child controls.
ClearChildState (inherited from Control) | Deletes the view-state and control-state information for all the server control's child controls.
ClearChildViewState (inherited from Control) | Deletes the view-state information for all the server control's child controls.
CreateChildControls |
CreateControlCollection (inherited from Control) | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control.
CreateControlStyle (inherited from WebControl) | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers.
DataBind (inherited from Control) | Overloaded. Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.
DataBindChildren (inherited from Control) | Binds a data source to the server control's child controls.
EnableFormComponent (inherited from WebFormTemplateLayout) | This method is responsible for enabling or disabling the specified control based on the name of the component or the data field. Internally implemented by calling GetFormComponent()
EnsureChildControls (inherited from Control) | Determines whether the server control contains child controls. If it does not, it creates child controls.
EnsureID (inherited from Control) | Creates an identifier for controls that do not have an identifier assigned.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FindControl (inherited from Control) | Overloaded. Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl method.
GetDesignModeState (inherited from Control) | Gets design-time data for a control.
GetFormComponent (inherited from WebFormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
HasEvents (inherited from Control) | Returns a value indicating whether events are registered for the control or any child controls.
IsFormComponent (inherited from WebFormTemplateLayout) | This method determines if the provided component is a valid Aptify Form Component, which is determined by checking to see if any of the following conditions is True: 1) Derived from WebFormCompnentBase 2) Implements IWebFormComponent 3) Derived from WebFormTemplateLayout 4) Derived from WebFormTemplateTab
IsLiteralContent (inherited from Control) | Determines if the server control holds only literal content.
LoadViewState (inherited from WebControl) | Restores view-state information from a previous request that was saved with the SaveViewState method.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnBubbleEvent (inherited from Control) | Determines whether the event for the server control is passed up the page's UI server control hierarchy.
OnDataBinding (inherited from Control) | Raises the DataBinding event.
OnInit (inherited from WebFormTemplateLayout) |
OnLoad |
RaiseBubbleEvent (inherited from Control) | Assigns any sources of the event and its information to the control's parent.
ReconstituteComponentCollection (inherited from WebFormTemplateLayout) | This method will rebuild the internal Form Component collection from the ASP.NET control hierarchy.
RecreateChildControls (inherited from CompositeControl) | Recreates the child controls n a control derived from CompositeControl.
RenderControl (inherited from Control) | Overloaded. Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.
ResolveAdapter (inherited from Control) | Gets the control adapter responsible for rendering the specified control.
SaveViewState (inherited from WebControl) | Saves any state that was modified after the TrackViewState method was invoked.
SetControlsEnabled | This member is responsible for setting control enabled bits on the server side. It is called from the Refresh() method.
SetDesignModeState (inherited from Control) | Sets design-time data for a control.
SetupClientHandlers | This method is responsible for setting up the Callback functionality. Currently, this is being used for retriving Type related to category selected. The Result and Error JavaScript functions are defined in RegisterJavaScripts sub.
TrackViewState (inherited from WebControl) | Causes the control to track changes to its view state so they can be stored in the object's ViewState property.

Protected Internal Instance Methods

AddedControl (inherited from Control) | Called after a child control is added to the Controls collection of the Control object.
LoadControlState (inherited from Control) | Restores control-state information from a previous page request that was saved by the SaveControlState method.
MapPathSecure (inherited from Control) | Retrieves the physical path that a virtual path, either absolute or relative, maps to.
OnPreRender (inherited from Control) | Raises the PreRender event.
OnUnload (inherited from Control) | Raises the Unload event.
OpenFile (inherited from Control) | Gets a Stream used to read a file.
RemovedControl (inherited from Control) | Called after a control is removed from the Controls collection of another control.
Render (inherited from CompositeControl) | Writes the CompositeControl content to the specified HtmlTextWriter object, for display on the client.
RenderChildren (inherited from Control) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client.
RenderContents (inherited from WebControl) | Renders the contents of the control to the specified writer. This method is used primarily by control developers.
SaveControlState (inherited from Control) | Saves any server control state changes that have occurred since the time the page was posted back to the server.

See Also

ProductLayoutControl Class | Aptify.Applications.ProductSetup.WebAccess Namespace


ProductLayoutControl.CreateChildControls Method

protected override void CreateChildControls();

See Also

ProductLayoutControl Class | Aptify.Applications.ProductSetup.WebAccess Namespace


ProductLayoutControl.GetCallbackResult Method

This method is required by ICallbackEventHandler. Result of the Callback gets sent back to the Client-side function by this method. The JavaScript function can be modified to do whatever is necessary with the results.

public string GetCallbackResult();

Return Value

Implements

ICallbackEventHandler.

Remarks

See Also

ProductLayoutControl Class | Aptify.Applications.ProductSetup.WebAccess Namespace


ProductLayoutControl.OnLoad Method

protected override void OnLoad(
EventArgs e
);

See Also

ProductLayoutControl Class | Aptify.Applications.ProductSetup.WebAccess Namespace


ProductLayoutControl.RaiseCallbackEvent Method

This method is required by ICallbackEventHandler. This method is the server-side of the asynchronous callback event. Here is where all the functionality is defined for what to do on a Callback.

public void RaiseCallbackEvent(
String eventArgument
);

Parameters

eventArgument
eventArgument is a string defined on the JavaScript side. This string must be delimited by the '|' (pipe) character. The first parameter in this string should be the identifier used to determine what action to take. For example, 'CATEGORYTOTYPE' is passed in as the first parameter in this string for getting Type using the CategoryID .

Implements

ICallbackEventHandler.

Remarks

Currently, the Callback is only setup to find and change the Type on the webpage. This method retrives the DefaultProductType from the Database and returns the value to client side.The RaiseCallbackEvent can be further extended to handle other callbacks.

See Also

ProductLayoutControl Class | Aptify.Applications.ProductSetup.WebAccess Namespace


ProductLayoutControl.Refresh Method

Overrides Refresh to handle setting control enabled bits right before rendering occurs

public override void Refresh();

Implements

IWebFormComponent.

Remarks

See Also

ProductLayoutControl Class | Aptify.Applications.ProductSetup.WebAccess Namespace


ProductLayoutControl.SetControlsEnabled Method

This member is responsible for setting control enabled bits on the server side. It is called from the Refresh() method.

protected virtual void SetControlsEnabled();

Remarks

See Also

ProductLayoutControl Class | Aptify.Applications.ProductSetup.WebAccess Namespace


ProductLayoutControl.SetupClientHandlers Method

This method is responsible for setting up the Callback functionality. Currently, this is being used for retriving Type related to category selected. The Result and Error JavaScript functions are defined in RegisterJavaScripts sub.

protected virtual void SetupClientHandlers();

Remarks

See Also

ProductLayoutControl Class | Aptify.Applications.ProductSetup.WebAccess Namespace


WebExtendedProduct Class

For a list of all members of this type, see WebExtendedProduct Members.

System.Object
Control
WebControl
CompositeControl
WebFormComponentBase
WebDataFieldFormComponentBase
WebExtendedProduct

public class WebExtendedProduct : WebDataFieldFormComponentBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.ProductSetup.WebAccess

Assembly: ProductsAWAGUI (in ProductsAWAGUI.dll)

See Also

WebExtendedProduct Members | Aptify.Applications.ProductSetup.WebAccess Namespace


WebExtendedProduct Members

WebExtendedProduct overview

Public Instance Constructors

WebExtendedProduct Constructor Initializes a new instance of the WebExtendedProduct class.

Public Instance Properties

AccessKey (inherited from WebControl) | Gets or sets the access key that allows you to quickly navigate to the Web server control.
Application (inherited from WebFormComponentBase) | Returns an instance of the AptifyApplication object
AppRelativeTemplateSourceDirectory (inherited from Control) | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control.
Attributes (inherited from WebControl) | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control.
BackColor (inherited from WebControl) | Gets or sets the background color of the Web server control.
BindingContainer (inherited from Control) | Gets the control that contains this control's data binding.
BorderColor (inherited from WebControl) | Gets or sets the border color of the Web control.
BorderStyle (inherited from WebControl) | Gets or sets the border style of the Web server control.
BorderWidth (inherited from WebControl) | Gets or sets the border width of the Web server control.
ClientID (inherited from Control) | Gets the server control identifier generated by ASP.NET.
Control (inherited from WebFormComponentBase) |
Controls (inherited from CompositeControl) | Gets a ControlCollection object that represents the child controls in a CompositeControl.
ControlStyle (inherited from WebControl) | Gets the style of the Web server control. This property is used primarily by control developers.
ControlStyleCreated (inherited from WebControl) | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers.
CssClass (inherited from WebControl) | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.
DataAction (inherited from WebFormComponentBase) | Returns an instance of the Aptify DataAction object
DataControl (inherited from WebFormComponentBase) | Adds a reference to the object for the data control. In the case of it being added, the reference to the bound control base object is added to the data controls collection.
DataField (inherited from WebDataFieldFormComponentBase) |
DisableGEDataTransfer (inherited from WebFormComponentBase) |
Edit (inherited from WebDataFieldFormComponentBase) |
Enabled (inherited from WebDataFieldFormComponentBase) |
EnableTheming (inherited from WebControl) | Gets or sets a value indicating whether themes apply to this control.
EnableViewState (inherited from Control) | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client.
FillHeight (inherited from WebFormComponentBase) | Determines if the control will fill the parent container's height at run time on the client-side (done via client-side Java Script). Maps to the fillHeight run-time HTML element attribute.
FillHeightMargin (inherited from WebFormComponentBase) | This property is only used if FillHeight is set to True. If FillHeight is set to True, this property determines the margin to use on the bottom side of the control when filling the container's height. This property specifies the number of pixels of space to be left on the bottom side of the control between the control's edge and the container's edge.
FillIgnoreChildren (inherited from WebFormComponentBase) | Determines if the control's children will be evaluated for resizing or not. The default value for this property is True, which results in the children of the control NOT being evaluated for resizing. Sub-classes can override this as required, as can individual instances of the class being used at run-time or design-time. It is important to leave this property set to True as much as possible as it reduces run-time resizing overhead.
FillWidth (inherited from WebFormComponentBase) | Determines if the control will fill the parent container's width at run time on the client-side (done via client-side Java Script). Maps to the fillWidth run-time HTML element attribute.
FillWidthMargin (inherited from WebFormComponentBase) | This property is only used if FillWidth is set to True. If FillWidth is set to True, this property determines the margin to use on the right side of the control when filling the container's width. This property specifies the number of pixels of space to be left on the right side of the control between the control's edge and the container's edge.
Font (inherited from WebDataFieldFormComponentBase) |
ForeColor (inherited from WebControl) | Gets or sets the foreground color (typically the color of the text) of the Web server control.
FormTemplateContext (inherited from WebFormComponentBase) |
HasAttributes (inherited from WebControl) | Gets a value indicating whether the control has attributes set.
Height (inherited from WebControl) | Gets or sets the height of the Web server control.
ID (inherited from Control) | Gets or sets the programmatic identifier assigned to the server control.
LabelFont (inherited from WebDataFieldFormComponentBase) |
LabelRequiredFont (inherited from WebDataFieldFormComponentBase) |
LabelText (inherited from WebDataFieldFormComponentBase) |
LabelTextAlign (inherited from WebDataFieldFormComponentBase) |
LabelWidth (inherited from WebDataFieldFormComponentBase) |
MaxHeight (inherited from WebDataFieldFormComponentBase) | This property is overridable by each control to set its maximum height for resizing
NamingContainer (inherited from Control) | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value.
Page (inherited from Control) | Gets a reference to the Page instance that contains the server control.
Parent (inherited from Control) | Gets a reference to the server control's parent control in the page control hierarchy.
Read (inherited from WebDataFieldFormComponentBase) |
Required (inherited from WebDataFieldFormComponentBase) |
ShowLabel (inherited from WebDataFieldFormComponentBase) |
Site (inherited from Control) | Gets information about the container that hosts the current control when rendered on a design surface.
SkinID (inherited from WebControl) | Gets or sets the skin to apply to the control.
Style (inherited from WebControl) | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control.
TabIndex (inherited from WebControl) | Gets or sets the tab index of the Web server control.
TemplateControl (inherited from Control) | Gets or sets a reference to the template that contains this control.
TemplateSourceDirectory (inherited from Control) | Gets the virtual directory of the Page or UserControl that contains the current server control.
Text (inherited from WebDataFieldFormComponentBase) |
ToolTip (inherited from WebControl) | Gets or sets the text displayed when the mouse pointer hovers over the Web server control.
UniqueID (inherited from Control) | Gets the unique, hierarchically qualified identifier for the server control.
Value (inherited from WebDataFieldFormComponentBase) |
Visible (inherited from Control) | Gets or sets a value that indicates whether a server control is rendered as UI on the page.
Width (inherited from WebControl) | Gets or sets the width of the Web server control.

Public Instance Methods

ApplyStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers.
ApplyStyleSheetSkin (inherited from Control) | Applies the style properties defined in the page style sheet to the control.
ClearData (inherited from WebFormComponentBase) |
CopyBaseAttributes (inherited from WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers.
DataBind (inherited from CompositeControl) | Overloaded. Binds a data source to the CompositeControl and all its child controls.
Dispose (inherited from Control) | Enables a server control to perform final clean up before it is released from memory.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindControl (inherited from Control) | Overloaded. Searches the current naming container for a server control with the specified id parameter.
Focus (inherited from Control) | Sets input focus to a control.
FormComponentConfig (inherited from WebDataFieldFormComponentBase) |
GetClientCulture (inherited from WebFormComponentBase) | Returns the culture for the client browser based on the first language in the Request.UserLanguages() array
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from WebFormComponentBase) |
GetType (inherited from Object) | Gets the Type of the current instance.
HasControls (inherited from Control) | Determines if the server control contains any child controls.
Hide (inherited from WebFormComponentBase) |
MergeStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers.
Refresh (inherited from WebDataFieldFormComponentBase) |
RenderBeginTag (inherited from WebControl) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers.
RenderControl (inherited from Control) | Overloaded. Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
RenderEndTag (inherited from WebControl) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers.
ResolveClientUrl (inherited from Control) | Gets a URL that can be used by the browser.
ResolveUrl (inherited from Control) | Converts a URL into one that is usable on the requesting client.
SetRenderMethodDelegate (inherited from Control) | Assigns an event handler delegate to render the server control and its content into its parent control.
SetupProductType | This function sets up an extra tab for additional product-level attributes based on the product type.
SetUserCredential (inherited from WebFormComponentBase) |
Show (inherited from WebFormComponentBase) | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.
TransferDataToObject (inherited from WebDataFieldFormComponentBase) |

Public Instance Events

ConfigedWithNonExtendedProduct
DataBinding (inherited from WebFormComponentBase)
Disposed (inherited from WebFormComponentBase)
Init (inherited from WebFormComponentBase)
Load (inherited from WebFormComponentBase)
PreRender (inherited from WebFormComponentBase)
Unload (inherited from WebFormComponentBase)
ValueChanged (inherited from WebFormComponentBase)

Protected Instance Fields

m_bEdit (inherited from WebDataFieldFormComponentBase)
m_bPreConfig (inherited from WebDataFieldFormComponentBase)
m_bRead (inherited from WebDataFieldFormComponentBase)
m_bRequired (inherited from WebDataFieldFormComponentBase)
m_sDataField (inherited from WebDataFieldFormComponentBase)

Protected Instance Properties

Adapter (inherited from Control) | Gets the browser-specific adapter for the control.
ChildControlsCreated (inherited from Control) | Gets a value that indicates whether the server control's child controls have been created.
ClientIDSeparator (inherited from Control) | Gets a character value representing the separator character used in the ClientID property.
ContainerTable (inherited from WebDataFieldFormComponentBase) |
ControlCell (inherited from WebDataFieldFormComponentBase) |
ErrorLabel (inherited from WebFormComponentBase) | This label is an internal feature of the base class that can be used by sub-classes to display error messages to the user when required. Set the ErrorLabel.Visible = True first, and then set the ErrorLabel.Text to the appropriate message for the user.
Events (inherited from Control) | Gets a list of event handler delegates for the control. This property is read-only.
ExtendedType (inherited from WebDataFieldFormComponentBase) |
ExtenderCell (inherited from WebDataFieldFormComponentBase) |
HasChildViewState (inherited from Control) | Gets a value indicating whether the current server control's child controls have any saved view-state settings.
IdSeparator (inherited from Control) | Gets the character used to separate control identifiers.
InternalControl (inherited from WebDataFieldFormComponentBase) |
IsTrackingViewState (inherited from Control) | Gets a value that indicates whether the server control is saving changes to its view state.
LabelCell (inherited from WebDataFieldFormComponentBase) |
LabelControl (inherited from WebDataFieldFormComponentBase) |
LoadViewStateByID (inherited from Control) | Gets a value indicating whether the control participates in loading its view state by ID instead of index.
MyApplication (inherited from WebFormComponentBase) |
OldValue (inherited from WebDataFieldFormComponentBase) |
TagKey (inherited from WebControl) | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers.
TagName (inherited from WebControl) | Gets the name of the control tag. This property is used primarily by control developers.
UserCredential (inherited from WebFormComponentBase) |
ViewState (inherited from Control) | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page.
ViewStateIgnoresCase (inherited from Control) | Gets a value that indicates whether the StateBag object is case-insensitive.

Protected Instance Methods

AddAttributesToRender (inherited from WebControl) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers.
AddParsedSubObject (inherited from Control) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object.
BuildProfileTree (inherited from Control) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page.
ClearChildControlState (inherited from Control) | Deletes the control-state information for the server control's child controls.
ClearChildState (inherited from Control) | Deletes the view-state and control-state information for all the server control's child controls.
ClearChildViewState (inherited from Control) | Deletes the view-state information for all the server control's child controls.
CreateChildControls |
CreateControlCollection (inherited from Control) | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control.
CreateControlStyle (inherited from WebControl) | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers.
DataBind (inherited from Control) | Overloaded. Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.
DataBindChildren (inherited from Control) | Binds a data source to the server control's child controls.
EnsureChildControls (inherited from Control) | Determines whether the server control contains child controls. If it does not, it creates child controls.
EnsureID (inherited from Control) | Creates an identifier for controls that do not have an identifier assigned.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FindControl (inherited from Control) | Overloaded. Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl method.
GetClientDateFormat (inherited from WebFormComponentBase) | Returns a string showing the preferred date format for the connected user.
GetClientTimeFormat (inherited from WebFormComponentBase) | Returns a string showing the preferred time format for the connected user.
GetDesignModeState (inherited from Control) | Gets design-time data for a control.
GetNextPixelParent (inherited from WebDataFieldFormComponentBase) | This method attempts to go up the control hierarchy until the next parent control is found that has a pixel-based width/height.
GetProperty (inherited from WebFormComponentBase) | Overloaded.
GetStandardWidthMargin (inherited from WebDataFieldFormComponentBase) | Returns the standard calculation result for the width margin to use on controls that are set to fill the parent's width. Override this method to adjust the width margins for specific controls.
GetUserCredentialsFromSession (inherited from WebFormComponentBase) | Returns a User Credentials object from the Session State, if available. This is used when ViewState is not yet recreated, or during Callback when ViewState is unavailable
HasEvents (inherited from Control) | Returns a value indicating whether events are registered for the control or any child controls.
IsLiteralContent (inherited from Control) | Determines if the server control holds only literal content.
LoadViewState (inherited from WebDataFieldFormComponentBase) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnBubbleEvent (inherited from Control) | Determines whether the event for the server control is passed up the page's UI server control hierarchy.
OnDataBinding (inherited from Control) | Raises the DataBinding event.
OnInit (inherited from WebFormComponentBase) |
OnPreRender |
RaiseBubbleEvent (inherited from Control) | Assigns any sources of the event and its information to the control's parent.
RaiseValueChanged (inherited from WebFormComponentBase) |
RecreateChildControls (inherited from CompositeControl) | Recreates the child controls n a control derived from CompositeControl.
Render (inherited from WebDataFieldFormComponentBase) |
RenderControl (inherited from Control) | Overloaded. Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.
RequiredGECheck (inherited from WebFormComponentBase) |
RequiredPropertiesCheck (inherited from WebDataFieldFormComponentBase) |
ResolveAdapter (inherited from Control) | Gets the control adapter responsible for rendering the specified control.
SaveViewState (inherited from WebDataFieldFormComponentBase) |
SetControlMetaData (inherited from WebDataFieldFormComponentBase) |
SetDesignModeState (inherited from Control) | Sets design-time data for a control.
SetExclusions (inherited from WebDataFieldFormComponentBase) |
SetSecurity (inherited from WebDataFieldFormComponentBase) |
SetupControlCellPadding (inherited from WebDataFieldFormComponentBase) | This method is responsible for setting up padding for the control cell within the Data Field Control so that the internal control is not clipped.
SetupInternalControlSizing (inherited from WebDataFieldFormComponentBase) | This method handles the general setup of internal control component sizing and can be overriden as required by subclasses to handle specialized sizing/layout requirements.
SetupLabelText (inherited from WebDataFieldFormComponentBase) | This method internally sets the label caption. If a value of Nothing/Null or a blank string is provided to this method, the internal meta-data for the field is used instead. In addition, this method will automatically map a field's culture in order to change the display name based on the culture of the field if necessary, but that is only done if the LabelCaption parameter exactly matches the DisplayName of the field. Override this method to change the base functionality.
SetValueFromGE (inherited from WebDataFieldFormComponentBase) |
TrackViewState (inherited from WebControl) | Causes the control to track changes to its view state so they can be stored in the object's ViewState property.

Protected Instance Events

PostConfig (inherited from WebDataFieldFormComponentBase)
PreConfig (inherited from WebDataFieldFormComponentBase)

Protected Internal Instance Properties

Context (inherited from Control) | Gets the HttpContext object associated with the server control for the current Web request.
DesignMode (inherited from Control) | Gets a value indicating whether a control is being used on a design surface.
IsChildControlStateCleared (inherited from Control) | Gets a value indicating whether controls contained within this control have control state.
IsEnabled (inherited from WebControl) | Gets a value indicating whether the control is enabled.
IsViewStateEnabled (inherited from Control) | Gets a value indicating whether view state is enabled for this control.
StopInitialization (inherited from WebDataFieldFormComponentBase) |

Protected Internal Instance Methods

AddedControl (inherited from Control) | Called after a child control is added to the Controls collection of the Control object.
LoadControlState (inherited from Control) | Restores control-state information from a previous page request that was saved by the SaveControlState method.
MapPathSecure (inherited from Control) | Retrieves the physical path that a virtual path, either absolute or relative, maps to.
OnLoad (inherited from Control) | Raises the Load event.
OnUnload (inherited from Control) | Raises the Unload event.
OpenFile (inherited from Control) | Gets a Stream used to read a file.
RemovedControl (inherited from Control) | Called after a control is removed from the Controls collection of another control.
RenderChildren (inherited from Control) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client.
RenderContents (inherited from WebControl) | Renders the contents of the control to the specified writer. This method is used primarily by control developers.
SaveControlState (inherited from Control) | Saves any server control state changes that have occurred since the time the page was posted back to the server.

See Also

WebExtendedProduct Class | Aptify.Applications.ProductSetup.WebAccess Namespace


WebExtendedProduct Constructor

Initializes a new instance of the WebExtendedProduct class.

public WebExtendedProduct();

See Also

WebExtendedProduct Class | Aptify.Applications.ProductSetup.WebAccess Namespace


WebExtendedProduct Methods

The methods of the WebExtendedProduct class are listed below. For a complete list of WebExtendedProduct class members, see the WebExtendedProduct Members topic.

Public Instance Methods

ApplyStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers.
ApplyStyleSheetSkin (inherited from Control) | Applies the style properties defined in the page style sheet to the control.
ClearData (inherited from WebFormComponentBase) |
CopyBaseAttributes (inherited from WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers.
DataBind (inherited from CompositeControl) | Overloaded. Binds a data source to the CompositeControl and all its child controls.
Dispose (inherited from Control) | Enables a server control to perform final clean up before it is released from memory.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindControl (inherited from Control) | Overloaded. Searches the current naming container for a server control with the specified id parameter.
Focus (inherited from Control) | Sets input focus to a control.
FormComponentConfig (inherited from WebDataFieldFormComponentBase) |
GetClientCulture (inherited from WebFormComponentBase) | Returns the culture for the client browser based on the first language in the Request.UserLanguages() array
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from WebFormComponentBase) |
GetType (inherited from Object) | Gets the Type of the current instance.
HasControls (inherited from Control) | Determines if the server control contains any child controls.
Hide (inherited from WebFormComponentBase) |
MergeStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers.
Refresh (inherited from WebDataFieldFormComponentBase) |
RenderBeginTag (inherited from WebControl) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers.
RenderControl (inherited from Control) | Overloaded. Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
RenderEndTag (inherited from WebControl) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers.
ResolveClientUrl (inherited from Control) | Gets a URL that can be used by the browser.
ResolveUrl (inherited from Control) | Converts a URL into one that is usable on the requesting client.
SetRenderMethodDelegate (inherited from Control) | Assigns an event handler delegate to render the server control and its content into its parent control.
SetupProductType | This function sets up an extra tab for additional product-level attributes based on the product type.
SetUserCredential (inherited from WebFormComponentBase) |
Show (inherited from WebFormComponentBase) | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.
TransferDataToObject (inherited from WebDataFieldFormComponentBase) |

Protected Instance Methods

AddAttributesToRender (inherited from WebControl) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers.
AddParsedSubObject (inherited from Control) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object.
BuildProfileTree (inherited from Control) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page.
ClearChildControlState (inherited from Control) | Deletes the control-state information for the server control's child controls.
ClearChildState (inherited from Control) | Deletes the view-state and control-state information for all the server control's child controls.
ClearChildViewState (inherited from Control) | Deletes the view-state information for all the server control's child controls.
CreateChildControls |
CreateControlCollection (inherited from Control) | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control.
CreateControlStyle (inherited from WebControl) | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers.
DataBind (inherited from Control) | Overloaded. Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.
DataBindChildren (inherited from Control) | Binds a data source to the server control's child controls.
EnsureChildControls (inherited from Control) | Determines whether the server control contains child controls. If it does not, it creates child controls.
EnsureID (inherited from Control) | Creates an identifier for controls that do not have an identifier assigned.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FindControl (inherited from Control) | Overloaded. Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl method.
GetClientDateFormat (inherited from WebFormComponentBase) | Returns a string showing the preferred date format for the connected user.
GetClientTimeFormat (inherited from WebFormComponentBase) | Returns a string showing the preferred time format for the connected user.
GetDesignModeState (inherited from Control) | Gets design-time data for a control.
GetNextPixelParent (inherited from WebDataFieldFormComponentBase) | This method attempts to go up the control hierarchy until the next parent control is found that has a pixel-based width/height.
GetProperty (inherited from WebFormComponentBase) | Overloaded.
GetStandardWidthMargin (inherited from WebDataFieldFormComponentBase) | Returns the standard calculation result for the width margin to use on controls that are set to fill the parent's width. Override this method to adjust the width margins for specific controls.
GetUserCredentialsFromSession (inherited from WebFormComponentBase) | Returns a User Credentials object from the Session State, if available. This is used when ViewState is not yet recreated, or during Callback when ViewState is unavailable
HasEvents (inherited from Control) | Returns a value indicating whether events are registered for the control or any child controls.
IsLiteralContent (inherited from Control) | Determines if the server control holds only literal content.
LoadViewState (inherited from WebDataFieldFormComponentBase) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnBubbleEvent (inherited from Control) | Determines whether the event for the server control is passed up the page's UI server control hierarchy.
OnDataBinding (inherited from Control) | Raises the DataBinding event.
OnInit (inherited from WebFormComponentBase) |
OnPreRender |
RaiseBubbleEvent (inherited from Control) | Assigns any sources of the event and its information to the control's parent.
RaiseValueChanged (inherited from WebFormComponentBase) |
RecreateChildControls (inherited from CompositeControl) | Recreates the child controls n a control derived from CompositeControl.
Render (inherited from WebDataFieldFormComponentBase) |
RenderControl (inherited from Control) | Overloaded. Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.
RequiredGECheck (inherited from WebFormComponentBase) |
RequiredPropertiesCheck (inherited from WebDataFieldFormComponentBase) |
ResolveAdapter (inherited from Control) | Gets the control adapter responsible for rendering the specified control.
SaveViewState (inherited from WebDataFieldFormComponentBase) |
SetControlMetaData (inherited from WebDataFieldFormComponentBase) |
SetDesignModeState (inherited from Control) | Sets design-time data for a control.
SetExclusions (inherited from WebDataFieldFormComponentBase) |
SetSecurity (inherited from WebDataFieldFormComponentBase) |
SetupControlCellPadding (inherited from WebDataFieldFormComponentBase) | This method is responsible for setting up padding for the control cell within the Data Field Control so that the internal control is not clipped.
SetupInternalControlSizing (inherited from WebDataFieldFormComponentBase) | This method handles the general setup of internal control component sizing and can be overriden as required by subclasses to handle specialized sizing/layout requirements.
SetupLabelText (inherited from WebDataFieldFormComponentBase) | This method internally sets the label caption. If a value of Nothing/Null or a blank string is provided to this method, the internal meta-data for the field is used instead. In addition, this method will automatically map a field's culture in order to change the display name based on the culture of the field if necessary, but that is only done if the LabelCaption parameter exactly matches the DisplayName of the field. Override this method to change the base functionality.
SetValueFromGE (inherited from WebDataFieldFormComponentBase) |
TrackViewState (inherited from WebControl) | Causes the control to track changes to its view state so they can be stored in the object's ViewState property.

Protected Internal Instance Methods

AddedControl (inherited from Control) | Called after a child control is added to the Controls collection of the Control object.
LoadControlState (inherited from Control) | Restores control-state information from a previous page request that was saved by the SaveControlState method.
MapPathSecure (inherited from Control) | Retrieves the physical path that a virtual path, either absolute or relative, maps to.
OnLoad (inherited from Control) | Raises the Load event.
OnUnload (inherited from Control) | Raises the Unload event.
OpenFile (inherited from Control) | Gets a Stream used to read a file.
RemovedControl (inherited from Control) | Called after a control is removed from the Controls collection of another control.
RenderChildren (inherited from Control) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client.
RenderContents (inherited from WebControl) | Renders the contents of the control to the specified writer. This method is used primarily by control developers.
SaveControlState (inherited from Control) | Saves any server control state changes that have occurred since the time the page was posted back to the server.

See Also

WebExtendedProduct Class | Aptify.Applications.ProductSetup.WebAccess Namespace


WebExtendedProduct.CreateChildControls Method

protected override void CreateChildControls();

See Also

WebExtendedProduct Class | Aptify.Applications.ProductSetup.WebAccess Namespace


WebExtendedProduct.OnPreRender Method

protected override void OnPreRender(
EventArgs e
);

See Also

WebExtendedProduct Class | Aptify.Applications.ProductSetup.WebAccess Namespace


WebExtendedProduct.SetupProductType Method

This function sets up an extra tab for additional product-level attributes based on the product type.

public void SetupProductType(
AptifyGenericEntityBase GE
);

Parameters

GE

Remarks

See Also

WebExtendedProduct Class | Aptify.Applications.ProductSetup.WebAccess Namespace


WebExtendedProduct Events

The events of the WebExtendedProduct class are listed below. For a complete list of WebExtendedProduct class members, see the WebExtendedProduct Members topic.

Public Instance Events

ConfigedWithNonExtendedProduct
DataBinding (inherited from WebFormComponentBase)
Disposed (inherited from WebFormComponentBase)
Init (inherited from WebFormComponentBase)
Load (inherited from WebFormComponentBase)
PreRender (inherited from WebFormComponentBase)
Unload (inherited from WebFormComponentBase)
ValueChanged (inherited from WebFormComponentBase)

Protected Instance Events

PostConfig (inherited from WebDataFieldFormComponentBase)
PreConfig (inherited from WebDataFieldFormComponentBase)

See Also

WebExtendedProduct Class | Aptify.Applications.ProductSetup.WebAccess Namespace


WebExtendedProduct.EventHandler Event

public event EventHandler ConfigedWithNonExtendedProduct;

See Also

WebExtendedProduct Class | Aptify.Applications.ProductSetup.WebAccess Namespace


Aptify.Applications.ProductSetup.WindowsControls

Aptify 5.0 Software Development Kit (SDK)

Aptify.Applications.ProductSetup.WindowsControls Namespace

This namespace contains objects that corresponds to the form templates for the Products, Product Categories, and ProductPrices entities.

Namespace hierarchy

Classes

Class | Description
ExtendedProduct |
ProductCategoryLayout | Provides presentation layer logic used for Product Categories Entity Top-Level records
ProductLayout | Provides presentation layer logic used for Products Entity Top-Level records
ProductPriceLayout | Provides presentation layer logic used for ProductPrices Sub-Type Entity records


ExtendedProduct Class

For a list of all members of this type, see ExtendedProduct Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
ExtendedProduct

public class ExtendedProduct : FormComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.ProductSetup.WindowsControls

Assembly: ProductLayoutControls (in ProductLayoutControls.dll)

See Also

ExtendedProduct Members | Aptify.Applications.ProductSetup.WindowsControls Namespace


ExtendedProduct Members

ExtendedProduct overview

Public Instance Constructors

ExtendedProduct Constructor Initializes a new instance of the ExtendedProduct class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsProductTypeSet |
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormComponent) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetupProductType | This function sets up an extra tab for additional product-level attributes based on the product type.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ConfigedWithNonExtendedProduct |
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateContext (inherited from FormComponent) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormComponent) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormComponent) |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormComponent) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormComponent) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormComponent) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ExtendedProduct Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


ExtendedProduct Constructor

Initializes a new instance of the ExtendedProduct class.

public ExtendedProduct();

See Also

ExtendedProduct Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


ExtendedProduct Properties

The properties of the ExtendedProduct class are listed below. For a complete list of ExtendedProduct class members, see the ExtendedProduct Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsProductTypeSet |
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateContext (inherited from FormComponent) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

ExtendedProduct Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


IsProductTypeSet Property

Aptify 5.0 Software Development Kit (SDK)

ExtendedProduct.IsProductTypeSet Property

public Boolean IsProductTypeSet {get; set;}

See Also

ExtendedProduct Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


ExtendedProduct Methods

The methods of the ExtendedProduct class are listed below. For a complete list of ExtendedProduct class members, see the ExtendedProduct Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormComponent) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetupProductType | This function sets up an extra tab for additional product-level attributes based on the product type.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormComponent) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormComponent) |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormComponent) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormComponent) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormComponent) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ExtendedProduct Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


ExtendedProduct.SetupProductType Method

This function sets up an extra tab for additional product-level attributes based on the product type.

public void SetupProductType(
AptifyGenericEntityBase GE
);

Parameters

GE

Remarks

See Also

ExtendedProduct Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


ExtendedProduct Events

The events of the ExtendedProduct class are listed below. For a complete list of ExtendedProduct class members, see the ExtendedProduct Members topic.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ConfigedWithNonExtendedProduct |
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

ExtendedProduct Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


ExtendedProduct.EventHandler Event

public event EventHandler ConfigedWithNonExtendedProduct;

See Also

ExtendedProduct Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


ProductCategoryLayout Class

Provides presentation layer logic used for Product Categories Entity Top-Level records

For a list of all members of this type, see ProductCategoryLayout Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
ProductCategoryLayout

public class ProductCategoryLayout : FormTemplateLayout

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.ProductSetup.WindowsControls

Assembly: ProductCategoryLayoutControls (in ProductCategoryLayoutControls.dll)

See Also

ProductCategoryLayout Members | Aptify.Applications.ProductSetup.WindowsControls Namespace


ProductCategoryLayout Members

ProductCategoryLayout overview

Public Instance Constructors

ProductCategoryLayout Constructor Initializes a new instance of the ProductCategoryLayout class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
m_ctlDescription |
m_ctlName |
m_ctlParentID |
m_ctlPricingAssembly |
m_ctlPricingClass |
m_ctlPricingObject |
m_ctlWebDescription |
m_ctlWebName |
m_oProductCategory |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
BindControl | This method handles binding a control reference to a specific field name using the GetFormComponent() method of the base class. The method only attempts to bind the control reference if the control reference is Nothing or its inner control is disposed.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormTemplateLayout) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindGeneralControls | This method is responsible for binding general controls. In particuar, it handles binding the m_ctlProductTypeID data field that is then set to enabled/disabled based on if this is a new record. Type ID can only be set on New Records.
FindWebControls | This method handles binding the web related controls to their internal protected members.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
On_AfterFlowDownPricingObjectInfo | This event is raised after the flow-down process is completed and the base class default implementation is to update the UI controls for PricingObject, PricingClass and PricingAssembly, if those controls have been loaded previously.
On_BeforeFlowDownPricingObjectInfo | This method is responsible for listening for the BeforeFlowDownPricingInfo event from the product object which occurs as a result of a change in the ParentID value. When this event occurs, the base class implementation of this method is to check to see if the values that are about to flow-down are different than those in the user interface currently or not. If they are different, the user is prompted to determine if they want to allow the flow-down or not. If the values are not different, the user is not prompted.
On_Description_ValueChanged | This method is responsible for responding to the Description of the Product Category changing and the default behavior flows down the changes to the WebDescription
On_Name_ValueChanged | This method is responsible for responding to the Name of the Product changing and the default behavior flows down the changes to the WebName
On_ParentID_ValueChanged | This method is responsible for responding to the situation when the Parent ID of the product category changes. This method in the base class implementation simply calls the SetValue() method in the ProductCategoryObject for the ParentID field with the value from the ParentID control. In turn, the Product Category determines if it needs to flow-down information or not from the parent. If so, the BeforeFlowDownPricingObjectInfo event is raised and this class captures that event in the On_BeforeFlowDownPricingObjectInfo overridable method. That method in turn handles prompting the user and asking if the user wishes to proceed with the flow-down. Lastly, if the user accepts the flow-down, the Product Category Object performs the flowdown and then fires the AfterFlowDownPricingObjectInfo event. This class listens to that event through the overridable On_AfterFlowDownPricingObjectInfo method and updates the UI as needed in that method.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded | Contains logic to setup Event handlers for controls on the FormTemplate Layout.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ProductCategoryLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


ProductCategoryLayout Constructor

Initializes a new instance of the ProductCategoryLayout class.

public ProductCategoryLayout();

See Also

ProductCategoryLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


ProductCategoryLayout Properties

The properties of the ProductCategoryLayout class are listed below. For a complete list of ProductCategoryLayout class members, see the ProductCategoryLayout Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
m_ctlDescription |
m_ctlName |
m_ctlParentID |
m_ctlPricingAssembly |
m_ctlPricingClass |
m_ctlPricingObject |
m_ctlWebDescription |
m_ctlWebName |
m_oProductCategory |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

ProductCategoryLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


m_ctlDescription Property

Aptify 5.0 Software Development Kit (SDK)

ProductCategoryLayout.m_ctlDescription Property

protected virtual IAptifyDataFieldControlBase m_ctlDescription {get; set;}

See Also

ProductCategoryLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


m_ctlName Property

Aptify 5.0 Software Development Kit (SDK)

ProductCategoryLayout.m_ctlName Property

protected virtual IAptifyDataFieldControlBase m_ctlName {get; set;}

See Also

ProductCategoryLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


m_ctlParentID Property

Aptify 5.0 Software Development Kit (SDK)

ProductCategoryLayout.m_ctlParentID Property

protected virtual IAptifyDataFieldControlBase m_ctlParentID {get; set;}

See Also

ProductCategoryLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


m_ctlPricingAssembly Property

Aptify 5.0 Software Development Kit (SDK)

ProductCategoryLayout.m_ctlPricingAssembly Property

protected virtual IAptifyDataFieldControlBase m_ctlPricingAssembly {get; set;}

See Also

ProductCategoryLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


m_ctlPricingClass Property

Aptify 5.0 Software Development Kit (SDK)

ProductCategoryLayout.m_ctlPricingClass Property

protected virtual IAptifyDataFieldControlBase m_ctlPricingClass {get; set;}

See Also

ProductCategoryLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


m_ctlPricingObject Property

Aptify 5.0 Software Development Kit (SDK)

ProductCategoryLayout.m_ctlPricingObject Property

protected virtual IAptifyDataFieldControlBase m_ctlPricingObject {get; set;}

See Also

ProductCategoryLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


m_ctlWebDescription Property

Aptify 5.0 Software Development Kit (SDK)

ProductCategoryLayout.m_ctlWebDescription Property

protected virtual IAptifyDataFieldControlBase m_ctlWebDescription {get; set;}

See Also

ProductCategoryLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


m_ctlWebName Property

Aptify 5.0 Software Development Kit (SDK)

ProductCategoryLayout.m_ctlWebName Property

protected virtual IAptifyDataFieldControlBase m_ctlWebName {get; set;}

See Also

ProductCategoryLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


m_oProductCategory Property

Aptify 5.0 Software Development Kit (SDK)

ProductCategoryLayout.m_oProductCategory Property

protected virtual ProductCategory m_oProductCategory {get; set;}

See Also

ProductCategoryLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


ProductCategoryLayout Methods

The methods of the ProductCategoryLayout class are listed below. For a complete list of ProductCategoryLayout class members, see the ProductCategoryLayout Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
BindControl | This method handles binding a control reference to a specific field name using the GetFormComponent() method of the base class. The method only attempts to bind the control reference if the control reference is Nothing or its inner control is disposed.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormTemplateLayout) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindGeneralControls | This method is responsible for binding general controls. In particuar, it handles binding the m_ctlProductTypeID data field that is then set to enabled/disabled based on if this is a new record. Type ID can only be set on New Records.
FindWebControls | This method handles binding the web related controls to their internal protected members.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
On_AfterFlowDownPricingObjectInfo | This event is raised after the flow-down process is completed and the base class default implementation is to update the UI controls for PricingObject, PricingClass and PricingAssembly, if those controls have been loaded previously.
On_BeforeFlowDownPricingObjectInfo | This method is responsible for listening for the BeforeFlowDownPricingInfo event from the product object which occurs as a result of a change in the ParentID value. When this event occurs, the base class implementation of this method is to check to see if the values that are about to flow-down are different than those in the user interface currently or not. If they are different, the user is prompted to determine if they want to allow the flow-down or not. If the values are not different, the user is not prompted.
On_Description_ValueChanged | This method is responsible for responding to the Description of the Product Category changing and the default behavior flows down the changes to the WebDescription
On_Name_ValueChanged | This method is responsible for responding to the Name of the Product changing and the default behavior flows down the changes to the WebName
On_ParentID_ValueChanged | This method is responsible for responding to the situation when the Parent ID of the product category changes. This method in the base class implementation simply calls the SetValue() method in the ProductCategoryObject for the ParentID field with the value from the ParentID control. In turn, the Product Category determines if it needs to flow-down information or not from the parent. If so, the BeforeFlowDownPricingObjectInfo event is raised and this class captures that event in the On_BeforeFlowDownPricingObjectInfo overridable method. That method in turn handles prompting the user and asking if the user wishes to proceed with the flow-down. Lastly, if the user accepts the flow-down, the Product Category Object performs the flowdown and then fires the AfterFlowDownPricingObjectInfo event. This class listens to that event through the overridable On_AfterFlowDownPricingObjectInfo method and updates the UI as needed in that method.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded | Contains logic to setup Event handlers for controls on the FormTemplate Layout.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ProductCategoryLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


ProductCategoryLayout.BindControl Method

This method handles binding a control reference to a specific field name using the GetFormComponent() method of the base class. The method only attempts to bind the control reference if the control reference is Nothing or its inner control is disposed.

protected virtual void BindControl(
ref IAptifyDataFieldControlBase& control,
String FieldName
);

Parameters

control
FieldName

Remarks

See Also

ProductCategoryLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


ProductCategoryLayout.FindGeneralControls Method

This method is responsible for binding general controls. In particuar, it handles binding the m_ctlProductTypeID data field that is then set to enabled/disabled based on if this is a new record. Type ID can only be set on New Records.

protected virtual void FindGeneralControls();

Remarks

See Also

ProductCategoryLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


ProductCategoryLayout.FindWebControls Method

This method handles binding the web related controls to their internal protected members.

protected virtual void FindWebControls();

Remarks

See Also

ProductCategoryLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


ProductCategoryLayout.On_AfterFlowDownPricingObjectInfo Method

This event is raised after the flow-down process is completed and the base class default implementation is to update the UI controls for PricingObject, PricingClass and PricingAssembly, if those controls have been loaded previously.

protected virtual void On_AfterFlowDownPricingObjectInfo();

Remarks

See Also

ProductCategoryLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


ProductCategoryLayout.On_BeforeFlowDownPricingObjectInfo Method

This method is responsible for listening for the BeforeFlowDownPricingInfo event from the product object which occurs as a result of a change in the ParentID value. When this event occurs, the base class implementation of this method is to check to see if the values that are about to flow-down are different than those in the user interface currently or not. If they are different, the user is prompted to determine if they want to allow the flow-down or not. If the values are not different, the user is not prompted.

protected virtual void On_BeforeFlowDownPricingObjectInfo(
String ObjectName,
String ClassName,
String AssemblyName,
ref Boolean& Cancel
);

Parameters

ObjectName
ClassName
AssemblyName
Cancel

Remarks

See Also

ProductCategoryLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


ProductCategoryLayout.On_Description_ValueChanged Method

This method is responsible for responding to the Description of the Product Category changing and the default behavior flows down the changes to the WebDescription

protected virtual void On_Description_ValueChanged(
Object sender,
Object OldValue,
Object NewValue
);

Parameters

sender
OldValue
NewValue

Remarks

See Also

ProductCategoryLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


ProductCategoryLayout.On_Name_ValueChanged Method

This method is responsible for responding to the Name of the Product changing and the default behavior flows down the changes to the WebName

protected virtual void On_Name_ValueChanged(
Object sender,
Object OldValue,
Object NewValue
);

Parameters

sender
OldValue
NewValue

Remarks

See Also

ProductCategoryLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


ProductCategoryLayout.On_ParentID_ValueChanged Method

This method is responsible for responding to the situation when the Parent ID of the product category changes. This method in the base class implementation simply calls the SetValue() method in the ProductCategoryObject for the ParentID field with the value from the ParentID control. In turn, the Product Category determines if it needs to flow-down information or not from the parent. If so, the BeforeFlowDownPricingObjectInfo event is raised and this class captures that event in the On_BeforeFlowDownPricingObjectInfo overridable method. That method in turn handles prompting the user and asking if the user wishes to proceed with the flow-down. Lastly, if the user accepts the flow-down, the Product Category Object performs the flowdown and then fires the AfterFlowDownPricingObjectInfo event. This class listens to that event through the overridable On_AfterFlowDownPricingObjectInfo method and updates the UI as needed in that method.

protected virtual void On_ParentID_ValueChanged(
Object sender,
Object OldValue,
Object NewValue
);

Parameters

sender
OldValue
NewValue

Remarks

See Also

ProductCategoryLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


ProductCategoryLayout.OnFormTemplateLoaded Method

Contains logic to setup Event handlers for controls on the FormTemplate Layout.

protected override void OnFormTemplateLoaded(
FormTemplateLayout.FormTemplateLoadedEventArgs e
);

Parameters

e

Remarks

See Also

ProductCategoryLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


ProductCategoryLayout.OnRefresh Method

protected override void OnRefresh();

Implements

IFormComponent.

See Also

ProductCategoryLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


ProductLayout Class

Provides presentation layer logic used for Products Entity Top-Level records

For a list of all members of this type, see ProductLayout Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
ProductLayout

public class ProductLayout : FormTemplateLayout

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.ProductSetup.WindowsControls

Assembly: ProductLayoutControls (in ProductLayoutControls.dll)

See Also

ProductLayout Members | Aptify.Applications.ProductSetup.WindowsControls Namespace


ProductLayout Members

ProductLayout overview

Public Instance Constructors

ProductLayout Constructor Initializes a new instance of the ProductLayout class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Fields

m_stProductParts

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
m_ctlCalculateCOGS |
m_ctlCategoryID |
m_ctlCostMethod |
m_ctlDefaultDuesProduct |
m_ctlDeferredIncome |
m_ctlDescription |
m_ctlDistributionTypeID |
m_ctlDropShip |
m_ctlExtendedProduct |
m_ctlGracePeriod |
m_ctlIsSubscription |
m_ctlMemberTypeID |
m_ctlName |
m_ctlPricingAssembly |
m_ctlPricingClass |
m_ctlPricingObject |
m_ctlProductGLAccounts |
m_ctlProductKitTypeID |
m_ctlProductPrices |
m_ctlProductTypeID |
m_ctlRequireInventory |
m_ctlSubscriptionIssues |
m_ctlSubscriptionStartDate |
m_ctlSubscriptionTypeID |
m_ctlSubsTurnoverDate |
m_ctlSuccession |
m_ctlSuccessionMaxDuration |
m_ctlSuccessionMode |
m_ctlSuccessionProduct |
m_ctlSuccessionProductRule |
m_ctlSuccessionTriggerRule |
m_ctlSuccessionTriggerType |
m_ctlTaxable |
m_ctlUseAssemblyInventory |
m_ctlWebDescription |
m_ctlWebEnabled |
m_ctlWebName |
m_ctlWebPageType |
m_ctlWebTemplateID |
m_oProductObject |
m_txtMinPrice |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
BindControl | This method handles binding a control reference to a specific field name using the GetFormComponent() method of the base class. The method only attempts to bind the control reference if the control reference is Nothing or its inner control is disposed.
ConfigureAssemblyControls | Sets the enabled status for the COGS check box control and other related controls.
ConfigureInventoryControls | Sets the enabled status for the COGS check box control and other related controls.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormTemplateLayout) | Overloaded. Releases all resources used by the Component.
DropShipChanged | This Method is called the value of the drop shipped value changes.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindAssemblyControls | This method is responsible for binding assembly related controls.
FindExtendedProductControls |
FindGeneralControls | This method is responsible for binding general controls. In particuar, it handles binding the m_ctlProductTypeID data field that is then set to enabled/disabled based on if this is a new record. Type ID can only be set on New Records.
FindInventoryControls | This method is responsible for binding inventory related controls.
FindPriceControls | This method is responsible for binding price related controls.
FindSubscriptionControls | This method handles binding the subscription related controls to their internal protected members.
FindSuccessionControls | This method is responsible for binding price related controls.
FindWebControls | This method handles binding the web related controls to their internal protected members.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetSubTypeControl | This method is responsible for finding a sub-type control within the form template based on the name of the Sub Type.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
On_CalculateCOGS_ValueChanged | This method is responsible for handling the event when the CalculateCOGS field changes its value
On_CategoryID_ValueChanged | This method is responsible for responding to the situation when the Category ID of the product changes.
On_DefaultDuesProduct_ValueChanged | This method is responsible for handling changes in value to the Default Dues Product check box field. If this box is set the Member Type ID field should be enabled, otherwise disabled.
On_Description_ValueChanged | This method is responsible for responding to the Description of the Product changing and the default behavior flows down the changes to the WebDescription
On_IsSubscription_ValueChanged | This method handles the event when the IsSubscription bit field changes value
On_Name_ValueChanged | This method is responsible for responding to the Name of the Product changing and the default behavior flows down the changes to the WebName
On_ProductObject_AfterGLAccountsFlowDown | This method resonds to the AfterGLAccountsFlowDown() event raised from the product object and updates the ProductGLAccounts sub-type if it is loaded.
On_ProductObject_BeforeGLAccountsFlowDown | This method is responsible for responding to the BeforeGLAccountsFlowDown event in the ProductObject which takes place whenever the Product
On_SuccessionMode_ValueChanged |
On_SuccessionTriggerType_ValueChanged |
On_WebPageType_ValueChanged | This method is responsible for responding to changes in the WebPageType field's value.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded | Contains logic to setup Event handlers for controls on the FormTemplate Layout.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
ProductTypeIDChanged |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDefaultProductType | This method is responsible for setting the product type control to the lowest available product type based on ID. In the base class, this method is called from the FindGeneralControls() method whenever a new record is being loaded and when there is no entity-defined default value for the product type.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetDistributionTypeIDDefault | This method is responsible for setting the defalt distribution type id at run time. This only does something if the Distribution Type ID is not set in the entity definition.
SetMemberTypeIDDefault | This method is responsible for setting the default member type id at run time. This only does something if the Member Type ID is not set in the entity definition.
SetNumericFieldValueDefault | This is a utility method that is called to set default values into controls OR the GE object if the control is not loaded yet. This method sets the value of the field to the minimum ID value within the entity specified.
SetRunTimeDefaults | This method is responsible for setting default values for required fields such as Distribution Type at run time if there are no defaults set at design time in the entity model.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetupExtendedTab |
SetupSubscriptionControls |
SetupSuccessionModeControls |
SetupSuccessionTriggerControls |
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


ProductLayout Constructor

Initializes a new instance of the ProductLayout class.

public ProductLayout();

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


ProductLayout Fields

The fields of the ProductLayout class are listed below. For a complete list of ProductLayout class members, see the ProductLayout Members topic.

Protected Instance Fields

m_stProductParts

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


ProductLayout.m_stProductParts Field

protected m_stProductParts m_stProductParts;

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


ProductLayout Properties

The properties of the ProductLayout class are listed below. For a complete list of ProductLayout class members, see the ProductLayout Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
m_ctlCalculateCOGS |
m_ctlCategoryID |
m_ctlCostMethod |
m_ctlDefaultDuesProduct |
m_ctlDeferredIncome |
m_ctlDescription |
m_ctlDistributionTypeID |
m_ctlDropShip |
m_ctlExtendedProduct |
m_ctlGracePeriod |
m_ctlIsSubscription |
m_ctlMemberTypeID |
m_ctlName |
m_ctlPricingAssembly |
m_ctlPricingClass |
m_ctlPricingObject |
m_ctlProductGLAccounts |
m_ctlProductKitTypeID |
m_ctlProductPrices |
m_ctlProductTypeID |
m_ctlRequireInventory |
m_ctlSubscriptionIssues |
m_ctlSubscriptionStartDate |
m_ctlSubscriptionTypeID |
m_ctlSubsTurnoverDate |
m_ctlSuccession |
m_ctlSuccessionMaxDuration |
m_ctlSuccessionMode |
m_ctlSuccessionProduct |
m_ctlSuccessionProductRule |
m_ctlSuccessionTriggerRule |
m_ctlSuccessionTriggerType |
m_ctlTaxable |
m_ctlUseAssemblyInventory |
m_ctlWebDescription |
m_ctlWebEnabled |
m_ctlWebName |
m_ctlWebPageType |
m_ctlWebTemplateID |
m_oProductObject |
m_txtMinPrice |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


m_ctlCalculateCOGS Property

Aptify 5.0 Software Development Kit (SDK)

ProductLayout.m_ctlCalculateCOGS Property

protected virtual IAptifyDataFieldControlBase m_ctlCalculateCOGS {get; set;}

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


m_ctlCategoryID Property

Aptify 5.0 Software Development Kit (SDK)

ProductLayout.m_ctlCategoryID Property

protected virtual IAptifyDataFieldControlBase m_ctlCategoryID {get; set;}

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


m_ctlCostMethod Property

Aptify 5.0 Software Development Kit (SDK)

ProductLayout.m_ctlCostMethod Property

protected virtual IAptifyDataFieldControlBase m_ctlCostMethod {get; set;}

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


m_ctlDefaultDuesProduct Property

Aptify 5.0 Software Development Kit (SDK)

ProductLayout.m_ctlDefaultDuesProduct Property

protected virtual IAptifyDataFieldControlBase m_ctlDefaultDuesProduct {get; set;}

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


m_ctlDeferredIncome Property

Aptify 5.0 Software Development Kit (SDK)

ProductLayout.m_ctlDeferredIncome Property

protected virtual IAptifyDataFieldControlBase m_ctlDeferredIncome {get; set;}

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


m_ctlDescription Property

Aptify 5.0 Software Development Kit (SDK)

ProductLayout.m_ctlDescription Property

protected virtual IAptifyDataFieldControlBase m_ctlDescription {get; set;}

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


m_ctlDistributionTypeID Property

Aptify 5.0 Software Development Kit (SDK)

ProductLayout.m_ctlDistributionTypeID Property

protected virtual IAptifyDataFieldControlBase m_ctlDistributionTypeID {get; set;}

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


m_ctlDropShip Property

Aptify 5.0 Software Development Kit (SDK)

ProductLayout.m_ctlDropShip Property

protected virtual IAptifyDataFieldControlBase m_ctlDropShip {get; set;}

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


m_ctlExtendedProduct Property

Aptify 5.0 Software Development Kit (SDK)

ProductLayout.m_ctlExtendedProduct Property

protected virtual ExtendedProduct m_ctlExtendedProduct {get; set;}

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


m_ctlGracePeriod Property

Aptify 5.0 Software Development Kit (SDK)

ProductLayout.m_ctlGracePeriod Property

protected virtual IAptifyDataFieldControlBase m_ctlGracePeriod {get; set;}

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


m_ctlIsSubscription Property

Aptify 5.0 Software Development Kit (SDK)

ProductLayout.m_ctlIsSubscription Property

protected virtual IAptifyDataFieldControlBase m_ctlIsSubscription {get; set;}

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


m_ctlMemberTypeID Property

Aptify 5.0 Software Development Kit (SDK)

ProductLayout.m_ctlMemberTypeID Property

protected virtual IAptifyDataFieldControlBase m_ctlMemberTypeID {get; set;}

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


m_ctlName Property

Aptify 5.0 Software Development Kit (SDK)

ProductLayout.m_ctlName Property

protected virtual IAptifyDataFieldControlBase m_ctlName {get; set;}

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


m_ctlPricingAssembly Property

Aptify 5.0 Software Development Kit (SDK)

ProductLayout.m_ctlPricingAssembly Property

protected virtual IAptifyDataFieldControlBase m_ctlPricingAssembly {get; set;}

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


m_ctlPricingClass Property

Aptify 5.0 Software Development Kit (SDK)

ProductLayout.m_ctlPricingClass Property

protected virtual IAptifyDataFieldControlBase m_ctlPricingClass {get; set;}

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


m_ctlPricingObject Property

Aptify 5.0 Software Development Kit (SDK)

ProductLayout.m_ctlPricingObject Property

protected virtual IAptifyDataFieldControlBase m_ctlPricingObject {get; set;}

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


m_ctlProductGLAccounts Property

Aptify 5.0 Software Development Kit (SDK)

ProductLayout.m_ctlProductGLAccounts Property

protected virtual AptifySubType m_ctlProductGLAccounts {get; set;}

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


m_ctlProductKitTypeID Property

Aptify 5.0 Software Development Kit (SDK)

ProductLayout.m_ctlProductKitTypeID Property

protected virtual IAptifyDataFieldControlBase m_ctlProductKitTypeID {get; set;}

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


m_ctlProductPrices Property

Aptify 5.0 Software Development Kit (SDK)

ProductLayout.m_ctlProductPrices Property

protected virtual AptifySubType m_ctlProductPrices {get; set;}

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


m_ctlProductTypeID Property

Aptify 5.0 Software Development Kit (SDK)

ProductLayout.m_ctlProductTypeID Property

protected virtual IAptifyDataFieldControlBase m_ctlProductTypeID {get; set;}

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


m_ctlRequireInventory Property

Aptify 5.0 Software Development Kit (SDK)

ProductLayout.m_ctlRequireInventory Property

protected virtual IAptifyDataFieldControlBase m_ctlRequireInventory {get; set;}

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


m_ctlSubscriptionIssues Property

Aptify 5.0 Software Development Kit (SDK)

ProductLayout.m_ctlSubscriptionIssues Property

protected virtual IAptifyDataFieldControlBase m_ctlSubscriptionIssues {get; set;}

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


m_ctlSubscriptionStartDate Property

Aptify 5.0 Software Development Kit (SDK)

ProductLayout.m_ctlSubscriptionStartDate Property

protected virtual IAptifyDataFieldControlBase m_ctlSubscriptionStartDate {get; set;}

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


m_ctlSubscriptionTypeID Property

Aptify 5.0 Software Development Kit (SDK)

ProductLayout.m_ctlSubscriptionTypeID Property

protected virtual IAptifyDataFieldControlBase m_ctlSubscriptionTypeID {get; set;}

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


m_ctlSubsTurnoverDate Property

Aptify 5.0 Software Development Kit (SDK)

ProductLayout.m_ctlSubsTurnoverDate Property

protected virtual IAptifyDataFieldControlBase m_ctlSubsTurnoverDate {get; set;}

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


m_ctlSuccession Property

Aptify 5.0 Software Development Kit (SDK)

ProductLayout.m_ctlSuccession Property

protected virtual AptifySubType m_ctlSuccession {get; set;}

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


m_ctlSuccessionMaxDuration Property

Aptify 5.0 Software Development Kit (SDK)

ProductLayout.m_ctlSuccessionMaxDuration Property

protected virtual IAptifyDataFieldControlBase m_ctlSuccessionMaxDuration {get; set;}

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


m_ctlSuccessionMode Property

Aptify 5.0 Software Development Kit (SDK)

ProductLayout.m_ctlSuccessionMode Property

protected virtual IAptifyDataFieldControlBase m_ctlSuccessionMode {get; set;}

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


m_ctlSuccessionProduct Property

Aptify 5.0 Software Development Kit (SDK)

ProductLayout.m_ctlSuccessionProduct Property

protected virtual IAptifyDataFieldControlBase m_ctlSuccessionProduct {get; set;}

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


m_ctlSuccessionProductRule Property

Aptify 5.0 Software Development Kit (SDK)

ProductLayout.m_ctlSuccessionProductRule Property

protected virtual IAptifyDataFieldControlBase m_ctlSuccessionProductRule {get; set;}

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


m_ctlSuccessionTriggerRule Property

Aptify 5.0 Software Development Kit (SDK)

ProductLayout.m_ctlSuccessionTriggerRule Property

protected virtual IAptifyDataFieldControlBase m_ctlSuccessionTriggerRule {get; set;}

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


m_ctlSuccessionTriggerType Property

Aptify 5.0 Software Development Kit (SDK)

ProductLayout.m_ctlSuccessionTriggerType Property

protected virtual IAptifyDataFieldControlBase m_ctlSuccessionTriggerType {get; set;}

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


m_ctlTaxable Property

Aptify 5.0 Software Development Kit (SDK)

ProductLayout.m_ctlTaxable Property

protected virtual IAptifyDataFieldControlBase m_ctlTaxable {get; set;}

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


m_ctlUseAssemblyInventory Property

Aptify 5.0 Software Development Kit (SDK)

ProductLayout.m_ctlUseAssemblyInventory Property

protected virtual IAptifyDataFieldControlBase m_ctlUseAssemblyInventory {get; set;}

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


m_ctlWebDescription Property

Aptify 5.0 Software Development Kit (SDK)

ProductLayout.m_ctlWebDescription Property

protected virtual IAptifyDataFieldControlBase m_ctlWebDescription {get; set;}

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


m_ctlWebEnabled Property

Aptify 5.0 Software Development Kit (SDK)

ProductLayout.m_ctlWebEnabled Property

protected virtual IAptifyDataFieldControlBase m_ctlWebEnabled {get; set;}

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


m_ctlWebName Property

Aptify 5.0 Software Development Kit (SDK)

ProductLayout.m_ctlWebName Property

protected virtual IAptifyDataFieldControlBase m_ctlWebName {get; set;}

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


m_ctlWebPageType Property

Aptify 5.0 Software Development Kit (SDK)

ProductLayout.m_ctlWebPageType Property

protected virtual IAptifyDataFieldControlBase m_ctlWebPageType {get; set;}

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


m_ctlWebTemplateID Property

Aptify 5.0 Software Development Kit (SDK)

ProductLayout.m_ctlWebTemplateID Property

protected virtual IAptifyDataFieldControlBase m_ctlWebTemplateID {get; set;}

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


m_oProductObject Property

Aptify 5.0 Software Development Kit (SDK)

ProductLayout.m_oProductObject Property

protected virtual ProductObject m_oProductObject {get; set;}

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


m_txtMinPrice Property

Aptify 5.0 Software Development Kit (SDK)

ProductLayout.m_txtMinPrice Property

protected virtual AptifyTextBox m_txtMinPrice {get; set;}

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


ProductLayout Methods

The methods of the ProductLayout class are listed below. For a complete list of ProductLayout class members, see the ProductLayout Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
BindControl | This method handles binding a control reference to a specific field name using the GetFormComponent() method of the base class. The method only attempts to bind the control reference if the control reference is Nothing or its inner control is disposed.
ConfigureAssemblyControls | Sets the enabled status for the COGS check box control and other related controls.
ConfigureInventoryControls | Sets the enabled status for the COGS check box control and other related controls.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormTemplateLayout) | Overloaded. Releases all resources used by the Component.
DropShipChanged | This Method is called the value of the drop shipped value changes.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindAssemblyControls | This method is responsible for binding assembly related controls.
FindExtendedProductControls |
FindGeneralControls | This method is responsible for binding general controls. In particuar, it handles binding the m_ctlProductTypeID data field that is then set to enabled/disabled based on if this is a new record. Type ID can only be set on New Records.
FindInventoryControls | This method is responsible for binding inventory related controls.
FindPriceControls | This method is responsible for binding price related controls.
FindSubscriptionControls | This method handles binding the subscription related controls to their internal protected members.
FindSuccessionControls | This method is responsible for binding price related controls.
FindWebControls | This method handles binding the web related controls to their internal protected members.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetSubTypeControl | This method is responsible for finding a sub-type control within the form template based on the name of the Sub Type.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
On_CalculateCOGS_ValueChanged | This method is responsible for handling the event when the CalculateCOGS field changes its value
On_CategoryID_ValueChanged | This method is responsible for responding to the situation when the Category ID of the product changes.
On_DefaultDuesProduct_ValueChanged | This method is responsible for handling changes in value to the Default Dues Product check box field. If this box is set the Member Type ID field should be enabled, otherwise disabled.
On_Description_ValueChanged | This method is responsible for responding to the Description of the Product changing and the default behavior flows down the changes to the WebDescription
On_IsSubscription_ValueChanged | This method handles the event when the IsSubscription bit field changes value
On_Name_ValueChanged | This method is responsible for responding to the Name of the Product changing and the default behavior flows down the changes to the WebName
On_ProductObject_AfterGLAccountsFlowDown | This method resonds to the AfterGLAccountsFlowDown() event raised from the product object and updates the ProductGLAccounts sub-type if it is loaded.
On_ProductObject_BeforeGLAccountsFlowDown | This method is responsible for responding to the BeforeGLAccountsFlowDown event in the ProductObject which takes place whenever the Product
On_SuccessionMode_ValueChanged |
On_SuccessionTriggerType_ValueChanged |
On_WebPageType_ValueChanged | This method is responsible for responding to changes in the WebPageType field's value.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded | Contains logic to setup Event handlers for controls on the FormTemplate Layout.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
ProductTypeIDChanged |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDefaultProductType | This method is responsible for setting the product type control to the lowest available product type based on ID. In the base class, this method is called from the FindGeneralControls() method whenever a new record is being loaded and when there is no entity-defined default value for the product type.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetDistributionTypeIDDefault | This method is responsible for setting the defalt distribution type id at run time. This only does something if the Distribution Type ID is not set in the entity definition.
SetMemberTypeIDDefault | This method is responsible for setting the default member type id at run time. This only does something if the Member Type ID is not set in the entity definition.
SetNumericFieldValueDefault | This is a utility method that is called to set default values into controls OR the GE object if the control is not loaded yet. This method sets the value of the field to the minimum ID value within the entity specified.
SetRunTimeDefaults | This method is responsible for setting default values for required fields such as Distribution Type at run time if there are no defaults set at design time in the entity model.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetupExtendedTab |
SetupSubscriptionControls |
SetupSuccessionModeControls |
SetupSuccessionTriggerControls |
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


ProductLayout.BindControl Method

This method handles binding a control reference to a specific field name using the GetFormComponent() method of the base class. The method only attempts to bind the control reference if the control reference is Nothing or its inner control is disposed.

protected virtual void BindControl(
ref IAptifyDataFieldControlBase& control,
String FieldName
);

Parameters

control
FieldName

Remarks

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


ProductLayout.ConfigureAssemblyControls Method

Sets the enabled status for the COGS check box control and other related controls.

protected virtual void ConfigureAssemblyControls();

Remarks

This method is called from the OnFormTemplateLoaded() method to check to see if the CalculateCOGS bit is set in the saved database record and if so it disables the field in the UI since CalculateCOGS can not be turned off once it is turned on. In order for COGs to be turned on RequireInventory must be on. If COGS is on, then we will disable RequireInventory as well.

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


ProductLayout.ConfigureInventoryControls Method

Sets the enabled status for the COGS check box control and other related controls.

protected virtual void ConfigureInventoryControls();

Remarks

This method is called from the OnFormTemplateLoaded() method to check to see if the CalculateCOGS bit is set in the saved database record and if so it disables the field in the UI since CalculateCOGS can not be turned off once it is turned on. In order for COGs to be turned on RequireInventory must be on. If COGS is on, then we will disable RequireInventory as well.

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


ProductLayout.DropShipChanged Method

This Method is called the value of the drop shipped value changes.

protected void DropShipChanged(
Boolean DropShip
);

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


ProductLayout.FindAssemblyControls Method

This method is responsible for binding assembly related controls.

protected virtual void FindAssemblyControls();

Remarks

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


ProductLayout.FindExtendedProductControls Method

protected virtual void FindExtendedProductControls();

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


ProductLayout.FindGeneralControls Method

This method is responsible for binding general controls. In particuar, it handles binding the m_ctlProductTypeID data field that is then set to enabled/disabled based on if this is a new record. Type ID can only be set on New Records.

protected virtual void FindGeneralControls();

Remarks

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


ProductLayout.FindInventoryControls Method

This method is responsible for binding inventory related controls.

protected virtual void FindInventoryControls();

Remarks

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


ProductLayout.FindPriceControls Method

This method is responsible for binding price related controls.

protected virtual void FindPriceControls();

Remarks

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


ProductLayout.FindSubscriptionControls Method

This method handles binding the subscription related controls to their internal protected members.

protected virtual void FindSubscriptionControls();

Remarks

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


ProductLayout.FindSuccessionControls Method

This method is responsible for binding price related controls.

protected virtual void FindSuccessionControls();

Remarks

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


ProductLayout.FindWebControls Method

This method handles binding the web related controls to their internal protected members.

protected virtual void FindWebControls();

Remarks

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


ProductLayout.GetSubTypeControl Method

This method is responsible for finding a sub-type control within the form template based on the name of the Sub Type.

protected virtual AptifySubType GetSubTypeControl(
Control ParentControl,
String SubTypeName
);

Parameters

ParentControl
SubTypeName

Return Value

Remarks

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


ProductLayout.On_CalculateCOGS_ValueChanged Method

This method is responsible for handling the event when the CalculateCOGS field changes its value

protected virtual void On_CalculateCOGS_ValueChanged(
Object sender,
Object OldValue,
Object NewValue
);

Parameters

sender
OldValue
NewValue

Remarks

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


ProductLayout.On_CategoryID_ValueChanged Method

This method is responsible for responding to the situation when the Category ID of the product changes.

protected virtual void On_CategoryID_ValueChanged(
Object sender,
Object OldValue,
Object NewValue
);

Parameters

sender
OldValue
NewValue

Remarks

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


ProductLayout.On_DefaultDuesProduct_ValueChanged Method

This method is responsible for handling changes in value to the Default Dues Product check box field. If this box is set the Member Type ID field should be enabled, otherwise disabled.

protected virtual void On_DefaultDuesProduct_ValueChanged(
Object sender,
Object OldValue,
Object NewValue
);

Parameters

sender
OldValue
NewValue

Remarks

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


ProductLayout.On_Description_ValueChanged Method

This method is responsible for responding to the Description of the Product changing and the default behavior flows down the changes to the WebDescription

protected virtual void On_Description_ValueChanged(
Object sender,
Object OldValue,
Object NewValue
);

Parameters

sender
OldValue
NewValue

Remarks

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


ProductLayout.On_IsSubscription_ValueChanged Method

This method handles the event when the IsSubscription bit field changes value

protected virtual void On_IsSubscription_ValueChanged(
Object sender,
Object OldValue,
Object NewValue
);

Parameters

sender
OldValue
NewValue

Remarks

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


ProductLayout.On_Name_ValueChanged Method

This method is responsible for responding to the Name of the Product changing and the default behavior flows down the changes to the WebName

protected virtual void On_Name_ValueChanged(
Object sender,
Object OldValue,
Object NewValue
);

Parameters

sender
OldValue
NewValue

Remarks

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


ProductLayout.On_ProductObject_AfterGLAccountsFlowDown Method

This method resonds to the AfterGLAccountsFlowDown() event raised from the product object and updates the ProductGLAccounts sub-type if it is loaded.

protected virtual void On_ProductObject_AfterGLAccountsFlowDown();

Remarks

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


ProductLayout.On_ProductObject_BeforeGLAccountsFlowDown Method

This method is responsible for responding to the BeforeGLAccountsFlowDown event in the ProductObject which takes place whenever the Product

protected virtual void On_ProductObject_BeforeGLAccountsFlowDown(
ref Boolean& Cancel
);

Parameters

Cancel

Remarks

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


ProductLayout.On_SuccessionMode_ValueChanged Method

protected virtual void On_SuccessionMode_ValueChanged(
Object sender,
Object OldValue,
Object NewValue
);

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


ProductLayout.On_SuccessionTriggerType_ValueChanged Method

protected virtual void On_SuccessionTriggerType_ValueChanged(
Object sender,
Object OldValue,
Object NewValue
);

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


ProductLayout.On_WebPageType_ValueChanged Method

This method is responsible for responding to changes in the WebPageType field's value.

protected virtual void On_WebPageType_ValueChanged(
Object sender,
Object OldValue,
Object NewValue
);

Parameters

sender
OldValue
NewValue

Remarks

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


ProductLayout.OnFormTemplateLoaded Method

Contains logic to setup Event handlers for controls on the FormTemplate Layout.

protected override void OnFormTemplateLoaded(
FormTemplateLayout.FormTemplateLoadedEventArgs e
);

Parameters

e

Remarks

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


ProductLayout.ProductTypeIDChanged Method

protected void ProductTypeIDChanged();

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


ProductLayout.SetDefaultProductType Method

This method is responsible for setting the product type control to the lowest available product type based on ID. In the base class, this method is called from the FindGeneralControls() method whenever a new record is being loaded and when there is no entity-defined default value for the product type.

protected virtual void SetDefaultProductType();

Remarks

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


ProductLayout.SetDistributionTypeIDDefault Method

This method is responsible for setting the defalt distribution type id at run time. This only does something if the Distribution Type ID is not set in the entity definition.

protected virtual void SetDistributionTypeIDDefault();

Remarks

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


ProductLayout.SetMemberTypeIDDefault Method

This method is responsible for setting the default member type id at run time. This only does something if the Member Type ID is not set in the entity definition.

protected virtual void SetMemberTypeIDDefault();

Remarks

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


ProductLayout.SetNumericFieldValueDefault Method

This is a utility method that is called to set default values into controls OR the GE object if the control is not loaded yet. This method sets the value of the field to the minimum ID value within the entity specified.

protected virtual void SetNumericFieldValueDefault(
String FieldName,
IAptifyDataFieldControlBase Control,
String Entity,
IAptifyDataAction.DSLCacheSetting CacheSetting
);

Parameters

FieldName
Control
Entity
Entity to retrieve the MINIMUM ID value from to populate into the control/field value
CacheSetting

Remarks

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


ProductLayout.SetRunTimeDefaults Method

This method is responsible for setting default values for required fields such as Distribution Type at run time if there are no defaults set at design time in the entity model.

protected virtual void SetRunTimeDefaults();

Remarks

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


ProductLayout.SetupExtendedTab Method

protected void SetupExtendedTab();

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


ProductLayout.SetupSubscriptionControls Method

protected void SetupSubscriptionControls();

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


ProductLayout.SetupSuccessionModeControls Method

protected void SetupSuccessionModeControls();

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


ProductLayout.SetupSuccessionTriggerControls Method

protected void SetupSuccessionTriggerControls();

See Also

ProductLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


ProductPriceLayout Class

Provides presentation layer logic used for ProductPrices Sub-Type Entity records

For a list of all members of this type, see ProductPriceLayout Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
ProductPriceLayout

public class ProductPriceLayout : FormTemplateLayout

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.ProductSetup.WindowsControls

Assembly: ProductLayoutControls (in ProductLayoutControls.dll)

See Also

ProductPriceLayout Members | Aptify.Applications.ProductSetup.WindowsControls Namespace


ProductPriceLayout Members

ProductPriceLayout overview

Public Instance Constructors

ProductPriceLayout Constructor Initializes a new instance of the ProductPriceLayout class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
m_ctlApplyFilterRule |
m_ctlCurrencyTypeID |
m_ctlDerivedFromCurrencyTypeID |
m_ctlFilterRule |
m_ctlPercentOfBase |
m_ctlPrice |
m_ctlRoundingAmount |
m_ctlRoundingType |
m_ctlType |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
BindControl | This method handles binding a control reference to a specific field name using the GetFormComponent() method of the base class. The method only attempts to bind the control reference if the control reference is Nothing or its inner control is disposed.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormTemplateLayout) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControls | This method handles binding the controls to their internal protected members.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
On_ApplyFilterRule_ValueChanged | This method is responsible for responding to the event whenever the ApplyFilterRule field changes value and disables the Filter Rule control whenever ApplyFilterRule=False.
On_CurrencyTypeID_ValueChanged | When the Currency Type is changed in the control, it is sent to the Entity object so that other controls can be notified of the Currency Type change and react accordingly.
On_DerivedFromCurrencyTypeID_ValueChanged | This method handles the event when the value of the DerivedFromCurrencyTypeID field changes and calls the SetRoundingEnabled() method to ensure that rounding is only enabled when appropriate.
On_PercentOfBase_ValueChanged | This method is responsible for handling changes to the PercentOfBase field. The default implementation calculates the new price based on the Base price in the entity. This is actually done in the underlying GE object for the Product Price, but is called from the UI at this point to provide more interactivity to the user when the PercentOfBase field is updated. The method calls the GetBasePrice() method of the Aptify.Applications.ProductSetup.ProductObject class (or its sub-class that is in place for the Products entity).
On_RoundingType_ValueChanged | This method is responsible for handling the rounding type field changing. The default implementation disables the Rounding Amount field whenever the RoundingType=None
On_Type_ValueChanged | This method handles the event when the value of the ProductPrices.Type field changes and disables the PercentOfBase field whenever the Type is not equal to 'Percent Of Base'.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded | Contains logic to setup Event handlers for controls on the FormTemplate Layout.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetRoundingEnabled | This method is responsible for enabling/disabling the rounding type and rounding amount fields. Rounding Type and Rounding Amount are only available when either the Price Type is "Percent of Base" or if the price is derived from another currency.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateDerivedPrice | This method is responsible for updating the derived price and is called in the default implementation from value change events for PercentOfBase, RoundingType and RoundingAmount. The method calls the CalculateDerivedPrice() method in the ProductPriceObject to perform the calculation.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ProductPriceLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


ProductPriceLayout Constructor

Initializes a new instance of the ProductPriceLayout class.

public ProductPriceLayout();

See Also

ProductPriceLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


ProductPriceLayout Properties

The properties of the ProductPriceLayout class are listed below. For a complete list of ProductPriceLayout class members, see the ProductPriceLayout Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
m_ctlApplyFilterRule |
m_ctlCurrencyTypeID |
m_ctlDerivedFromCurrencyTypeID |
m_ctlFilterRule |
m_ctlPercentOfBase |
m_ctlPrice |
m_ctlRoundingAmount |
m_ctlRoundingType |
m_ctlType |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

ProductPriceLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


m_ctlApplyFilterRule Property

Aptify 5.0 Software Development Kit (SDK)

ProductPriceLayout.m_ctlApplyFilterRule Property

protected virtual IAptifyDataFieldControlBase m_ctlApplyFilterRule {get; set;}

See Also

ProductPriceLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


m_ctlCurrencyTypeID Property

Aptify 5.0 Software Development Kit (SDK)

ProductPriceLayout.m_ctlCurrencyTypeID Property

protected virtual IAptifyDataFieldControlBase m_ctlCurrencyTypeID {get; set;}

See Also

ProductPriceLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


m_ctlDerivedFromCurrencyTypeID Property

Aptify 5.0 Software Development Kit (SDK)

ProductPriceLayout.m_ctlDerivedFromCurrencyTypeID Property

protected virtual IAptifyDataFieldControlBase m_ctlDerivedFromCurrencyTypeID {get; set;}

See Also

ProductPriceLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


m_ctlFilterRule Property

Aptify 5.0 Software Development Kit (SDK)

ProductPriceLayout.m_ctlFilterRule Property

protected virtual Control m_ctlFilterRule {get; set;}

See Also

ProductPriceLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


m_ctlPercentOfBase Property

Aptify 5.0 Software Development Kit (SDK)

ProductPriceLayout.m_ctlPercentOfBase Property

protected virtual IAptifyDataFieldControlBase m_ctlPercentOfBase {get; set;}

See Also

ProductPriceLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


m_ctlPrice Property

Aptify 5.0 Software Development Kit (SDK)

ProductPriceLayout.m_ctlPrice Property

protected virtual IAptifyDataFieldControlBase m_ctlPrice {get; set;}

See Also

ProductPriceLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


m_ctlRoundingAmount Property

Aptify 5.0 Software Development Kit (SDK)

ProductPriceLayout.m_ctlRoundingAmount Property

protected virtual IAptifyDataFieldControlBase m_ctlRoundingAmount {get; set;}

See Also

ProductPriceLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


m_ctlRoundingType Property

Aptify 5.0 Software Development Kit (SDK)

ProductPriceLayout.m_ctlRoundingType Property

protected virtual IAptifyDataFieldControlBase m_ctlRoundingType {get; set;}

See Also

ProductPriceLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


m_ctlType Property

Aptify 5.0 Software Development Kit (SDK)

ProductPriceLayout.m_ctlType Property

protected virtual IAptifyDataFieldControlBase m_ctlType {get; set;}

See Also

ProductPriceLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


ProductPriceLayout Methods

The methods of the ProductPriceLayout class are listed below. For a complete list of ProductPriceLayout class members, see the ProductPriceLayout Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
BindControl | This method handles binding a control reference to a specific field name using the GetFormComponent() method of the base class. The method only attempts to bind the control reference if the control reference is Nothing or its inner control is disposed.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormTemplateLayout) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControls | This method handles binding the controls to their internal protected members.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
On_ApplyFilterRule_ValueChanged | This method is responsible for responding to the event whenever the ApplyFilterRule field changes value and disables the Filter Rule control whenever ApplyFilterRule=False.
On_CurrencyTypeID_ValueChanged | When the Currency Type is changed in the control, it is sent to the Entity object so that other controls can be notified of the Currency Type change and react accordingly.
On_DerivedFromCurrencyTypeID_ValueChanged | This method handles the event when the value of the DerivedFromCurrencyTypeID field changes and calls the SetRoundingEnabled() method to ensure that rounding is only enabled when appropriate.
On_PercentOfBase_ValueChanged | This method is responsible for handling changes to the PercentOfBase field. The default implementation calculates the new price based on the Base price in the entity. This is actually done in the underlying GE object for the Product Price, but is called from the UI at this point to provide more interactivity to the user when the PercentOfBase field is updated. The method calls the GetBasePrice() method of the Aptify.Applications.ProductSetup.ProductObject class (or its sub-class that is in place for the Products entity).
On_RoundingType_ValueChanged | This method is responsible for handling the rounding type field changing. The default implementation disables the Rounding Amount field whenever the RoundingType=None
On_Type_ValueChanged | This method handles the event when the value of the ProductPrices.Type field changes and disables the PercentOfBase field whenever the Type is not equal to 'Percent Of Base'.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded | Contains logic to setup Event handlers for controls on the FormTemplate Layout.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetRoundingEnabled | This method is responsible for enabling/disabling the rounding type and rounding amount fields. Rounding Type and Rounding Amount are only available when either the Price Type is "Percent of Base" or if the price is derived from another currency.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateDerivedPrice | This method is responsible for updating the derived price and is called in the default implementation from value change events for PercentOfBase, RoundingType and RoundingAmount. The method calls the CalculateDerivedPrice() method in the ProductPriceObject to perform the calculation.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ProductPriceLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


ProductPriceLayout.BindControl Method

This method handles binding a control reference to a specific field name using the GetFormComponent() method of the base class. The method only attempts to bind the control reference if the control reference is Nothing or its inner control is disposed.

protected virtual void BindControl(
ref IAptifyDataFieldControlBase& control,
String FieldName
);

Parameters

control
FieldName

Remarks

See Also

ProductPriceLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


ProductPriceLayout.FindControls Method

This method handles binding the controls to their internal protected members.

protected virtual void FindControls();

Remarks

See Also

ProductPriceLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


ProductPriceLayout.On_ApplyFilterRule_ValueChanged Method

This method is responsible for responding to the event whenever the ApplyFilterRule field changes value and disables the Filter Rule control whenever ApplyFilterRule=False.

protected virtual void On_ApplyFilterRule_ValueChanged(
Object sender,
Object OldValue,
Object NewValue
);

Parameters

sender
OldValue
NewValue

Remarks

See Also

ProductPriceLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


ProductPriceLayout.On_CurrencyTypeID_ValueChanged Method

When the Currency Type is changed in the control, it is sent to the Entity object so that other controls can be notified of the Currency Type change and react accordingly.

protected virtual void On_CurrencyTypeID_ValueChanged(
Object sender,
Object OldValue,
Object NewValue
);

Parameters

sender
OldValue
NewValue

Remarks

See Also

ProductPriceLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


ProductPriceLayout.On_DerivedFromCurrencyTypeID_ValueChanged Method

This method handles the event when the value of the DerivedFromCurrencyTypeID field changes and calls the SetRoundingEnabled() method to ensure that rounding is only enabled when appropriate.

protected virtual void On_DerivedFromCurrencyTypeID_ValueChanged(
Object sender,
Object OldValue,
Object NewValue
);

Parameters

sender
OldValue
NewValue

Remarks

See Also

ProductPriceLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


ProductPriceLayout.On_PercentOfBase_ValueChanged Method

This method is responsible for handling changes to the PercentOfBase field. The default implementation calculates the new price based on the Base price in the entity. This is actually done in the underlying GE object for the Product Price, but is called from the UI at this point to provide more interactivity to the user when the PercentOfBase field is updated. The method calls the GetBasePrice() method of the Aptify.Applications.ProductSetup.ProductObject class (or its sub-class that is in place for the Products entity).

protected virtual void On_PercentOfBase_ValueChanged(
Object sender,
Object OldValue,
Object NewValue
);

Parameters

sender
OldValue
NewValue

Remarks

See Also

ProductPriceLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


ProductPriceLayout.On_RoundingType_ValueChanged Method

This method is responsible for handling the rounding type field changing. The default implementation disables the Rounding Amount field whenever the RoundingType=None

protected virtual void On_RoundingType_ValueChanged(
Object sender,
Object OldValue,
Object NewValue
);

Parameters

sender
OldValue
NewValue

Remarks

See Also

ProductPriceLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


ProductPriceLayout.On_Type_ValueChanged Method

This method handles the event when the value of the ProductPrices.Type field changes and disables the PercentOfBase field whenever the Type is not equal to 'Percent Of Base'.

protected virtual void On_Type_ValueChanged(
Object sender,
Object OldValue,
Object NewValue
);

Parameters

sender
OldValue
NewValue

Remarks

See Also

ProductPriceLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


ProductPriceLayout.OnFormTemplateLoaded Method

Contains logic to setup Event handlers for controls on the FormTemplate Layout.

protected override void OnFormTemplateLoaded(
FormTemplateLayout.FormTemplateLoadedEventArgs e
);

Parameters

e

Remarks

See Also

ProductPriceLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


ProductPriceLayout.SetRoundingEnabled Method

This method is responsible for enabling/disabling the rounding type and rounding amount fields. Rounding Type and Rounding Amount are only available when either the Price Type is "Percent of Base" or if the price is derived from another currency.

protected virtual void SetRoundingEnabled(
ref Boolean& Enabled
);

Parameters

Enabled
OUT Parameter: Returns True if rounding is enabled, False otherwise

Remarks

See Also

ProductPriceLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


ProductPriceLayout.UpdateDerivedPrice Method

This method is responsible for updating the derived price and is called in the default implementation from value change events for PercentOfBase, RoundingType and RoundingAmount. The method calls the CalculateDerivedPrice() method in the ProductPriceObject to perform the calculation.

protected virtual void UpdateDerivedPrice();

Remarks

See Also

ProductPriceLayout Class | Aptify.Applications.ProductSetup.WindowsControls Namespace


Aptify.Applications.SalesForceAutomation

Aptify 5.0 Software Development Kit (SDK)

Aptify.Applications.SalesForceAutomation Namespace

The objects in this namespace implement functionality used by Aptify's Sales Force Automation application.

Namespace hierarchy

Classes

Class | Description
OpportunityHistoryGenerator | Implements functionality to automatically generate history records in the OpportunityHistory sub-type whenever changes are made to an Opportunity Record that justify a history record being created. The logic in this class utilizes Process Component Input Properties(or parameters to the type-specific functions) to determine which fields in the Opportunity Record being modified will drive the creation of an OpportunityHistory sub-type record being created. This process component is designed to be called from the BeforeSave() event for the Opportunities entity.
SelectReferralRequestVendors | Implements functionality to automatically generate ReferralRequestVendor sub-type records based on the type of referral request. When a referral request has QualificationMode="Open" and the Status="Pending", this process component will automatically maintain the list of records in the ReferralRequestVendors sub-type.


OpportunityHistoryGenerator Class

Implements functionality to automatically generate history records in the OpportunityHistory sub-type whenever changes are made to an Opportunity Record that justify a history record being created. The logic in this class utilizes Process Component Input Properties(or parameters to the type-specific functions) to determine which fields in the Opportunity Record being modified will drive the creation of an OpportunityHistory sub-type record being created. This process component is designed to be called from the BeforeSave() event for the Opportunities entity.

For a list of all members of this type, see OpportunityHistoryGenerator Members.

System.Object
OpportunityHistoryGenerator

public class OpportunityHistoryGenerator : IProcessComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.SalesForceAutomation

Assembly: OpportunityProcessComponents (in OpportunityProcessComponents.dll)

See Also

OpportunityHistoryGenerator Members | Aptify.Applications.SalesForceAutomation Namespace


OpportunityHistoryGenerator Members

OpportunityHistoryGenerator overview

Public Instance Constructors

OpportunityHistoryGenerator Constructor Initializes a new instance of the OpportunityHistoryGenerator class.

Public Instance Properties

Application
Properties

Public Instance Methods

CheckOpportunityForChangesToTriggerFields | Overloaded. This method will determine if any of the fields in the TriggerFields parameter in the provided Opportunity GE object have changed. If any of those fields have changed, True is returned, otherwise, False is returned.
Config |
CreateOpportunityHistoryRecord | This member will create a new record in the OpportunityHistory sub-type based on the current values for fields that map from the Opportunity record into the OpportunityHistory record. The default logic in the base class will iterate through all fields in the OpportunityHistory schema and automatically copy the current values into the appropriate fields(matched on field name with same fields in the Opportunity record).
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GenerateOpportunityHistory | Overloaded. This method will generate an opportunity history record if any changes to the Opportunity GE qualify the record for history creation. The default logic in the base class is to see if any of the fields provided in the TriggerFields parameter have changed or if the record is new and TriggerOnNew is true. If either fields have changed that result in history being required, or if a new record when TriggerOnNew is true, then an opportunity history record is created using the CreateOpportunityHistoryRecord() member.
GetCurrentEmployeeID | Returns the ID of the record in the Employees entity that is associated with the current user.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run | Process Component Input Properties 1) OpportunityGE - GE Object for the Opportunity Record 2) TriggerFieldList - Optional - Comma Delimited List of field names that will be used to drive when history records are created. If not specified, the HistoryTriggerFieldList entity attribute in the Opportunities entity will be used. 3) TriggerOnNew - Optional - Boolean Value - If set to True, a history record will be created whenever a new Opportunity is created, if not specified, True is assumed 4) UpdatedByID - Optional - Long Value - If set to an integer value > 0, this value will be used for the UpdatedByID field value in the new opportunity history record, if a record is created. Process Component Output Properties 1) OpportunityHistoryCreated - Set to True if a record was created in the OpportunityHistory sub-type, False otherwise
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

OpportunityHistoryGenerator Class | Aptify.Applications.SalesForceAutomation Namespace


OpportunityHistoryGenerator Constructor

Initializes a new instance of the OpportunityHistoryGenerator class.

public OpportunityHistoryGenerator();

See Also

OpportunityHistoryGenerator Class | Aptify.Applications.SalesForceAutomation Namespace


OpportunityHistoryGenerator Properties

The properties of the OpportunityHistoryGenerator class are listed below. For a complete list of OpportunityHistoryGenerator class members, see the OpportunityHistoryGenerator Members topic.

Public Instance Properties

Application
Properties

See Also

OpportunityHistoryGenerator Class | Aptify.Applications.SalesForceAutomation Namespace


Application Property

Aptify 5.0 Software Development Kit (SDK)

OpportunityHistoryGenerator.Application Property

public virtual AptifyApplication Application {get;}

See Also

OpportunityHistoryGenerator Class | Aptify.Applications.SalesForceAutomation Namespace


Properties Property

Aptify 5.0 Software Development Kit (SDK)

OpportunityHistoryGenerator.Properties Property

public virtual AptifyProperties Properties {get;}

Implements

IProcessComponent.

See Also

OpportunityHistoryGenerator Class | Aptify.Applications.SalesForceAutomation Namespace


OpportunityHistoryGenerator Methods

The methods of the OpportunityHistoryGenerator class are listed below. For a complete list of OpportunityHistoryGenerator class members, see the OpportunityHistoryGenerator Members topic.

Public Instance Methods

CheckOpportunityForChangesToTriggerFields | Overloaded. This method will determine if any of the fields in the TriggerFields parameter in the provided Opportunity GE object have changed. If any of those fields have changed, True is returned, otherwise, False is returned.
Config |
CreateOpportunityHistoryRecord | This member will create a new record in the OpportunityHistory sub-type based on the current values for fields that map from the Opportunity record into the OpportunityHistory record. The default logic in the base class will iterate through all fields in the OpportunityHistory schema and automatically copy the current values into the appropriate fields(matched on field name with same fields in the Opportunity record).
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GenerateOpportunityHistory | Overloaded. This method will generate an opportunity history record if any changes to the Opportunity GE qualify the record for history creation. The default logic in the base class is to see if any of the fields provided in the TriggerFields parameter have changed or if the record is new and TriggerOnNew is true. If either fields have changed that result in history being required, or if a new record when TriggerOnNew is true, then an opportunity history record is created using the CreateOpportunityHistoryRecord() member.
GetCurrentEmployeeID | Returns the ID of the record in the Employees entity that is associated with the current user.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run | Process Component Input Properties 1) OpportunityGE - GE Object for the Opportunity Record 2) TriggerFieldList - Optional - Comma Delimited List of field names that will be used to drive when history records are created. If not specified, the HistoryTriggerFieldList entity attribute in the Opportunities entity will be used. 3) TriggerOnNew - Optional - Boolean Value - If set to True, a history record will be created whenever a new Opportunity is created, if not specified, True is assumed 4) UpdatedByID - Optional - Long Value - If set to an integer value > 0, this value will be used for the UpdatedByID field value in the new opportunity history record, if a record is created. Process Component Output Properties 1) OpportunityHistoryCreated - Set to True if a record was created in the OpportunityHistory sub-type, False otherwise
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

OpportunityHistoryGenerator Class | Aptify.Applications.SalesForceAutomation Namespace


CheckOpportunityForChangesToTriggerFields Method

Aptify 5.0 Software Development Kit (SDK)

OpportunityHistoryGenerator.CheckOpportunityForChangesToTriggerFields Method

This method will determine if any of the fields in the TriggerFields parameter in the provided Opportunity GE object have changed. If any of those fields have changed, True is returned, otherwise, False is returned.

Overload List

This method will determine if any of the fields in the TriggerFields parameter in the provided Opportunity GE object have changed. If any of those fields have changed, True is returned, otherwise, False is returned.

public virtual bool CheckOpportunityForChangesToTriggerFields(AptifyGenericEntityBase,List<T>);

This method will determine if any of the fields in the TriggerFields parameter in the provided Opportunity GE object have changed. If any of those fields have changed, True is returned, otherwise, False is returned.

public virtual bool CheckOpportunityForChangesToTriggerFields(AptifyGenericEntityBase,String[]);

See Also

OpportunityHistoryGenerator Class | Aptify.Applications.SalesForceAutomation Namespace


OpportunityHistoryGenerator.CheckOpportunityForChangesToTriggerFields Method (AptifyGenericEntityBase, List<T>)

This method will determine if any of the fields in the TriggerFields parameter in the provided Opportunity GE object have changed. If any of those fields have changed, True is returned, otherwise, False is returned.

public virtual bool CheckOpportunityForChangesToTriggerFields(
AptifyGenericEntityBase OpportunityGE,
List<T> TriggerFields
);

Parameters

OpportunityGE
TriggerFields

Return Value

Remarks

See Also

OpportunityHistoryGenerator Class | Aptify.Applications.SalesForceAutomation Namespace | OpportunityHistoryGenerator.CheckOpportunityForChangesToTriggerFields Overload List


OpportunityHistoryGenerator.CheckOpportunityForChangesToTriggerFields Method (AptifyGenericEntityBase, String[])

This method will determine if any of the fields in the TriggerFields parameter in the provided Opportunity GE object have changed. If any of those fields have changed, True is returned, otherwise, False is returned.

public virtual bool CheckOpportunityForChangesToTriggerFields(
AptifyGenericEntityBase OpportunityGE,
String[] TriggerFields
);

Parameters

OpportunityGE
TriggerFields

Return Value

Remarks

See Also

OpportunityHistoryGenerator Class | Aptify.Applications.SalesForceAutomation Namespace | OpportunityHistoryGenerator.CheckOpportunityForChangesToTriggerFields Overload List


OpportunityHistoryGenerator.Config Method

public virtual void Config(
AptifyApplication ApplicationObject
);

Implements

IProcessComponent.

See Also

OpportunityHistoryGenerator Class | Aptify.Applications.SalesForceAutomation Namespace


OpportunityHistoryGenerator.CreateOpportunityHistoryRecord Method

This member will create a new record in the OpportunityHistory sub-type based on the current values for fields that map from the Opportunity record into the OpportunityHistory record. The default logic in the base class will iterate through all fields in the OpportunityHistory schema and automatically copy the current values into the appropriate fields(matched on field name with same fields in the Opportunity record).

public virtual bool CreateOpportunityHistoryRecord(
AptifyGenericEntityBase OpportunityGE,
ref Int64& UpdatedByID
);

Parameters

OpportunityGE
UpdatedByID
Optional IN/OUT Parameter: Provide this value to set the UpdatedByID field in the new history record. The OUT value will provide the current employee ID if the IN value is =-1

Return Value

Remarks

See Also

OpportunityHistoryGenerator Class | Aptify.Applications.SalesForceAutomation Namespace


GenerateOpportunityHistory Method

Aptify 5.0 Software Development Kit (SDK)

OpportunityHistoryGenerator.GenerateOpportunityHistory Method

This method will generate an opportunity history record if any changes to the Opportunity GE qualify the record for history creation. The default logic in the base class is to see if any of the fields provided in the TriggerFields parameter have changed or if the record is new and TriggerOnNew is true. If either fields have changed that result in history being required, or if a new record when TriggerOnNew is true, then an opportunity history record is created using the CreateOpportunityHistoryRecord() member.

Overload List

This method will generate an opportunity history record if any changes to the Opportunity GE qualify the record for history creation. The default logic in the base class is to see if any of the fields provided in the TriggerFields parameter have changed or if the record is new and TriggerOnNew is true. If either fields have changed that result in history being required, or if a new record when TriggerOnNew is true, then an opportunity history record is created using the CreateOpportunityHistoryRecord() member.

public virtual bool GenerateOpportunityHistory(AptifyGenericEntityBase,List<T>,Boolean,ref Boolean&,ref Int64&);

This method will generate an opportunity history record if any changes to the Opportunity GE qualify the record for history creation. The default logic in the base class is to see if any of the fields provided in the TriggerFields parameter have changed or if the record is new and TriggerOnNew is true. If either fields have changed that result in history being required, or if a new record when TriggerOnNew is true, then an opportunity history record is created using the CreateOpportunityHistoryRecord() member.

public virtual bool GenerateOpportunityHistory(AptifyGenericEntityBase,String[],Boolean,ref Boolean&,ref Int64&);

See Also

OpportunityHistoryGenerator Class | Aptify.Applications.SalesForceAutomation Namespace


OpportunityHistoryGenerator.GenerateOpportunityHistory Method (AptifyGenericEntityBase, List<T>, Boolean, Boolean&, Int64&)

This method will generate an opportunity history record if any changes to the Opportunity GE qualify the record for history creation. The default logic in the base class is to see if any of the fields provided in the TriggerFields parameter have changed or if the record is new and TriggerOnNew is true. If either fields have changed that result in history being required, or if a new record when TriggerOnNew is true, then an opportunity history record is created using the CreateOpportunityHistoryRecord() member.

public virtual bool GenerateOpportunityHistory(
AptifyGenericEntityBase OpportunityGE,
List<T> TriggerFields,
Boolean TriggerOnNew,
ref Boolean& HistoryCreated,
ref Int64& UpdatedByID
);

Parameters

OpportunityGE
Aptify GE object for the opportunity record.
TriggerFields
Fields that are checked to determine if a history record is required
TriggerOnNew
If set to true(default), creates a new history record when a new opportunity record is being created.
HistoryCreated
OUT Paramater: Returns True if a history record was actually inserted, False otherwise.
UpdatedByID

Return Value

Remarks

See Also

OpportunityHistoryGenerator Class | Aptify.Applications.SalesForceAutomation Namespace | OpportunityHistoryGenerator.GenerateOpportunityHistory Overload List


OpportunityHistoryGenerator.GenerateOpportunityHistory Method (AptifyGenericEntityBase, String[], Boolean, Boolean&, Int64&)

This method will generate an opportunity history record if any changes to the Opportunity GE qualify the record for history creation. The default logic in the base class is to see if any of the fields provided in the TriggerFields parameter have changed or if the record is new and TriggerOnNew is true. If either fields have changed that result in history being required, or if a new record when TriggerOnNew is true, then an opportunity history record is created using the CreateOpportunityHistoryRecord() member.

public virtual bool GenerateOpportunityHistory(
AptifyGenericEntityBase OpportunityGE,
String[] TriggerFields,
Boolean TriggerOnNew,
ref Boolean& HistoryCreated,
ref Int64& UpdatedByID
);

Parameters

OpportunityGE
Aptify GE object for the opportunity record.
TriggerFields
Fields that are checked to determine if a history record is required
TriggerOnNew
If set to true(default), creates a new history record when a new opportunity record is being created.
HistoryCreated
OUT Paramater: Returns True if a history record was actually inserted, False otherwise.
UpdatedByID

Return Value

Remarks

See Also

OpportunityHistoryGenerator Class | Aptify.Applications.SalesForceAutomation Namespace | OpportunityHistoryGenerator.GenerateOpportunityHistory Overload List


OpportunityHistoryGenerator.GetCurrentEmployeeID Method

Returns the ID of the record in the Employees entity that is associated with the current user.

public virtual long GetCurrentEmployeeID();

Return Value

Remarks

See Also

OpportunityHistoryGenerator Class | Aptify.Applications.SalesForceAutomation Namespace


OpportunityHistoryGenerator.Run Method

Process Component Input Properties 1) OpportunityGE - GE Object for the Opportunity Record 2) TriggerFieldList - Optional - Comma Delimited List of field names that will be used to drive when history records are created. If not specified, the HistoryTriggerFieldList entity attribute in the Opportunities entity will be used. 3) TriggerOnNew - Optional - Boolean Value - If set to True, a history record will be created whenever a new Opportunity is created, if not specified, True is assumed 4) UpdatedByID - Optional - Long Value - If set to an integer value > 0, this value will be used for the UpdatedByID field value in the new opportunity history record, if a record is created. Process Component Output Properties 1) OpportunityHistoryCreated - Set to True if a record was created in the OpportunityHistory sub-type, False otherwise

public virtual string Run();

Return Value

SUCCESS or FAILED

Implements

IProcessComponent.

Remarks

See Also

OpportunityHistoryGenerator Class | Aptify.Applications.SalesForceAutomation Namespace


SelectReferralRequestVendors Class

Implements functionality to automatically generate ReferralRequestVendor sub-type records based on the type of referral request. When a referral request has QualificationMode="Open" and the Status="Pending", this process component will automatically maintain the list of records in the ReferralRequestVendors sub-type.

For a list of all members of this type, see SelectReferralRequestVendors Members.

System.Object
SelectReferralRequestVendors

public class SelectReferralRequestVendors : IProcessComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.SalesForceAutomation

Assembly: ReferralRequestProcessComponents (in ReferralRequestProcessComponents.dll)

See Also

SelectReferralRequestVendors Members | Aptify.Applications.SalesForceAutomation Namespace


SelectReferralRequestVendors Members

SelectReferralRequestVendors overview

Public Instance Constructors

SelectReferralRequestVendors Constructor Initializes a new instance of the SelectReferralRequestVendors class.

Public Instance Properties

Application
DataAction
Properties

Public Instance Methods

Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run | Process Component Input Properties 1) ReferralRequestGE - Required - GE Object for the Referral Request Record 2) FilterSQL - Optional - This is a SQL expression that will be used to match company records beyond the topic code matching algorithm that is native to this object. Use this parameter to add additional filtering logic for the selection of company records. 3) DeleteExistingVendors - Optional - Defaults to True, if set to true, will remove existing vendors (non generated) from a referral request while adding new ones, otherwise, existing ones are not removed.
ShouldUpdateVendorList | This overridable method is responsible for determining if the component should update the ReferralRequestVendors sub-type. The default logic in the base class for this component is to check the Status field of the record and the QualificationMode. If Status=Pending and QualificationMode=Open, the ReferralRequestVendors sub-type should be updated in the default logic and this method will return True.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateVendorList | Overloaded. This method is responsible for managing the ReferralRequestVendors sub-type within a Referral Request record. Whenever this method is called, all records within the ReferralRequestVendors sub-type that have the IsGenerated Field=1 will be removed. The records will be replaced with company records that match the topic codes specified for the Referral Request. The MatchingMode field is used to determine if all or any of the Topic Codes must be matched. If ReferralRequest.MatchingMode=Partial any one (or more) topic code(s) must match on the company records being selected to receive the request. If ReferralRequest.MatchingMode=Complete all topic codes that are associated with the Referral Request must be linked to a company in order to be selected. This overload deletes existing vendors first, call the other overload that has an additional parameter called DeleteExistingVendors if you need to prevent such removal from occuring.

Protected Instance Methods

ApplyFilter | This method will apply the specified filter sql to the provided company id list. CompanyIDList will be modified, as required to REMOVE any records that are in the list that do not match the provided FilterSQL
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RefreshLinkedFields |

See Also

SelectReferralRequestVendors Class | Aptify.Applications.SalesForceAutomation Namespace


SelectReferralRequestVendors Constructor

Initializes a new instance of the SelectReferralRequestVendors class.

public SelectReferralRequestVendors();

See Also

SelectReferralRequestVendors Class | Aptify.Applications.SalesForceAutomation Namespace


SelectReferralRequestVendors Properties

The properties of the SelectReferralRequestVendors class are listed below. For a complete list of SelectReferralRequestVendors class members, see the SelectReferralRequestVendors Members topic.

Public Instance Properties

Application
DataAction
Properties

See Also

SelectReferralRequestVendors Class | Aptify.Applications.SalesForceAutomation Namespace


Application Property

Aptify 5.0 Software Development Kit (SDK)

SelectReferralRequestVendors.Application Property

public virtual AptifyApplication Application {get;}

See Also

SelectReferralRequestVendors Class | Aptify.Applications.SalesForceAutomation Namespace


DataAction Property

Aptify 5.0 Software Development Kit (SDK)

SelectReferralRequestVendors.DataAction Property

public virtual DataAction DataAction {get;}

See Also

SelectReferralRequestVendors Class | Aptify.Applications.SalesForceAutomation Namespace


Properties Property

Aptify 5.0 Software Development Kit (SDK)

SelectReferralRequestVendors.Properties Property

public virtual AptifyProperties Properties {get;}

Implements

IProcessComponent.

See Also

SelectReferralRequestVendors Class | Aptify.Applications.SalesForceAutomation Namespace


SelectReferralRequestVendors Methods

The methods of the SelectReferralRequestVendors class are listed below. For a complete list of SelectReferralRequestVendors class members, see the SelectReferralRequestVendors Members topic.

Public Instance Methods

Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run | Process Component Input Properties 1) ReferralRequestGE - Required - GE Object for the Referral Request Record 2) FilterSQL - Optional - This is a SQL expression that will be used to match company records beyond the topic code matching algorithm that is native to this object. Use this parameter to add additional filtering logic for the selection of company records. 3) DeleteExistingVendors - Optional - Defaults to True, if set to true, will remove existing vendors (non generated) from a referral request while adding new ones, otherwise, existing ones are not removed.
ShouldUpdateVendorList | This overridable method is responsible for determining if the component should update the ReferralRequestVendors sub-type. The default logic in the base class for this component is to check the Status field of the record and the QualificationMode. If Status=Pending and QualificationMode=Open, the ReferralRequestVendors sub-type should be updated in the default logic and this method will return True.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateVendorList | Overloaded. This method is responsible for managing the ReferralRequestVendors sub-type within a Referral Request record. Whenever this method is called, all records within the ReferralRequestVendors sub-type that have the IsGenerated Field=1 will be removed. The records will be replaced with company records that match the topic codes specified for the Referral Request. The MatchingMode field is used to determine if all or any of the Topic Codes must be matched. If ReferralRequest.MatchingMode=Partial any one (or more) topic code(s) must match on the company records being selected to receive the request. If ReferralRequest.MatchingMode=Complete all topic codes that are associated with the Referral Request must be linked to a company in order to be selected. This overload deletes existing vendors first, call the other overload that has an additional parameter called DeleteExistingVendors if you need to prevent such removal from occuring.

Protected Instance Methods

ApplyFilter | This method will apply the specified filter sql to the provided company id list. CompanyIDList will be modified, as required to REMOVE any records that are in the list that do not match the provided FilterSQL
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RefreshLinkedFields |

See Also

SelectReferralRequestVendors Class | Aptify.Applications.SalesForceAutomation Namespace


SelectReferralRequestVendors.ApplyFilter Method

This method will apply the specified filter sql to the provided company id list. CompanyIDList will be modified, as required to REMOVE any records that are in the list that do not match the provided FilterSQL

protected virtual void ApplyFilter(
List<T> CompanyList,
String FilterSQL
);

Parameters

CompanyList
FilterSQL

Remarks

See Also

SelectReferralRequestVendors Class | Aptify.Applications.SalesForceAutomation Namespace


SelectReferralRequestVendors.Config Method

public virtual void Config(
AptifyApplication ApplicationObject
);

Implements

IProcessComponent.

See Also

SelectReferralRequestVendors Class | Aptify.Applications.SalesForceAutomation Namespace


SelectReferralRequestVendors.RefreshLinkedFields Method

protected void RefreshLinkedFields(
ref AptifyGenericEntityBase& GE,
ref AptifyDataFieldBase& oFKeyField,
ref ArrayList& arrFieldList
);

See Also

SelectReferralRequestVendors Class | Aptify.Applications.SalesForceAutomation Namespace


SelectReferralRequestVendors.Run Method

Process Component Input Properties 1) ReferralRequestGE - Required - GE Object for the Referral Request Record 2) FilterSQL - Optional - This is a SQL expression that will be used to match company records beyond the topic code matching algorithm that is native to this object. Use this parameter to add additional filtering logic for the selection of company records. 3) DeleteExistingVendors - Optional - Defaults to True, if set to true, will remove existing vendors (non generated) from a referral request while adding new ones, otherwise, existing ones are not removed.

public virtual string Run();

Return Value

SUCCESS or FAILED

Implements

IProcessComponent.

Remarks

See Also

SelectReferralRequestVendors Class | Aptify.Applications.SalesForceAutomation Namespace


SelectReferralRequestVendors.ShouldUpdateVendorList Method

This overridable method is responsible for determining if the component should update the ReferralRequestVendors sub-type. The default logic in the base class for this component is to check the Status field of the record and the QualificationMode. If Status=Pending and QualificationMode=Open, the ReferralRequestVendors sub-type should be updated in the default logic and this method will return True.

public virtual bool ShouldUpdateVendorList(
AptifyGenericEntityBase ReferralRequestGE
);

Parameters

ReferralRequestGE

Return Value

Remarks

See Also

SelectReferralRequestVendors Class | Aptify.Applications.SalesForceAutomation Namespace


UpdateVendorList Method

Aptify 5.0 Software Development Kit (SDK)

SelectReferralRequestVendors.UpdateVendorList Method

This method is responsible for managing the ReferralRequestVendors sub-type within a Referral Request record. Whenever this method is called, all records within the ReferralRequestVendors sub-type that have the IsGenerated Field=1 will be removed. The records will be replaced with company records that match the topic codes specified for the Referral Request. The MatchingMode field is used to determine if all or any of the Topic Codes must be matched. If ReferralRequest.MatchingMode=Partial any one (or more) topic code(s) must match on the company records being selected to receive the request. If ReferralRequest.MatchingMode=Complete all topic codes that are associated with the Referral Request must be linked to a company in order to be selected. This overload deletes existing vendors first, call the other overload that has an additional parameter called DeleteExistingVendors if you need to prevent such removal from occuring.

Overload List

This method is responsible for managing the ReferralRequestVendors sub-type within a Referral Request record. Whenever this method is called, all records within the ReferralRequestVendors sub-type that have the IsGenerated Field=1 will be removed. The records will be replaced with company records that match the topic codes specified for the Referral Request. The MatchingMode field is used to determine if all or any of the Topic Codes must be matched. If ReferralRequest.MatchingMode=Partial any one (or more) topic code(s) must match on the company records being selected to receive the request. If ReferralRequest.MatchingMode=Complete all topic codes that are associated with the Referral Request must be linked to a company in order to be selected. This overload deletes existing vendors first, call the other overload that has an additional parameter called DeleteExistingVendors if you need to prevent such removal from occuring.

public virtual bool UpdateVendorList(AptifyGenericEntityBase,Boolean,String);

This method is responsible for managing the ReferralRequestVendors sub-type within a Referral Request record. Whenever this method is called, all records within the ReferralRequestVendors sub-type that have the IsGenerated Field=1 will be removed. The records will be replaced with company records that match the topic codes specified for the Referral Request. The MatchingMode field is used to determine if all or any of the Topic Codes must be matched. If ReferralRequest.MatchingMode=Partial any one (or more) topic code(s) must match on the company records being selected to receive the request. If ReferralRequest.MatchingMode=Complete all topic codes that are associated with the Referral Request must be linked to a company in order to be selected. This overload deletes existing vendors first, call the other overload that has an additional parameter called DeleteExistingVendors if you need to prevent such removal from occuring.

public virtual bool UpdateVendorList(AptifyGenericEntityBase,String);

See Also

SelectReferralRequestVendors Class | Aptify.Applications.SalesForceAutomation Namespace


SelectReferralRequestVendors.UpdateVendorList Method (AptifyGenericEntityBase, Boolean, String)

This method is responsible for managing the ReferralRequestVendors sub-type within a Referral Request record. Whenever this method is called, all records within the ReferralRequestVendors sub-type that have the IsGenerated Field=1 will be removed. The records will be replaced with company records that match the topic codes specified for the Referral Request. The MatchingMode field is used to determine if all or any of the Topic Codes must be matched. If ReferralRequest.MatchingMode=Partial any one (or more) topic code(s) must match on the company records being selected to receive the request. If ReferralRequest.MatchingMode=Complete all topic codes that are associated with the Referral Request must be linked to a company in order to be selected. This overload deletes existing vendors first, call the other overload that has an additional parameter called DeleteExistingVendors if you need to prevent such removal from occuring.

public virtual bool UpdateVendorList(
AptifyGenericEntityBase ReferralRequestGE,
Boolean DeleteExistingVendors,
String FilterSQL
);

Parameters

ReferralRequestGE
DeleteExistingVendors
If set to True, existing vendors will be removed(unless not generated), otherwise, they will not be removed
FilterSQL
If provided, this Filter will be attached

Return Value

Remarks

See Also

SelectReferralRequestVendors Class | Aptify.Applications.SalesForceAutomation Namespace | SelectReferralRequestVendors.UpdateVendorList Overload List


SelectReferralRequestVendors.UpdateVendorList Method (AptifyGenericEntityBase, String)

This method is responsible for managing the ReferralRequestVendors sub-type within a Referral Request record. Whenever this method is called, all records within the ReferralRequestVendors sub-type that have the IsGenerated Field=1 will be removed. The records will be replaced with company records that match the topic codes specified for the Referral Request. The MatchingMode field is used to determine if all or any of the Topic Codes must be matched. If ReferralRequest.MatchingMode=Partial any one (or more) topic code(s) must match on the company records being selected to receive the request. If ReferralRequest.MatchingMode=Complete all topic codes that are associated with the Referral Request must be linked to a company in order to be selected. This overload deletes existing vendors first, call the other overload that has an additional parameter called DeleteExistingVendors if you need to prevent such removal from occuring.

public virtual bool UpdateVendorList(
AptifyGenericEntityBase ReferralRequestGE,
String FilterSQL
);

Parameters

ReferralRequestGE
FilterSQL
If provided, this Filter will be attached

Return Value

Remarks

See Also

SelectReferralRequestVendors Class | Aptify.Applications.SalesForceAutomation Namespace | SelectReferralRequestVendors.UpdateVendorList Overload List


Aptify.Applications.Subscriptions

Aptify 5.0 Software Development Kit (SDK)

Aptify.Applications.Subscriptions Namespace

This namespace contains objects related to Aptify's standard Subscription Management functionality, including subscription fulfillment and renewals.

Namespace hierarchy

Classes

Class | Description
GetDateForm |
SubscriptionEntity | This object serves as the Subscriptions Generic Entity Object.
SubscriptionFulfillment | This class is used to fulfill a subscription with information from the Subscription Fulfillment entity. It builds a recipient list for a fulfillment and can produce output in the form of a report, mailing labels or an output file that has e-mail addresses or fax numbers.
SubscriptionFulfillmentsEntity |
SubscriptionRenewal | This class is responsible for renewing subscriptions and supports execution through an Action interface, view extension as well as a Process Component. This component can be used with its type-specific members as well.
SubscriptionRenewalStatus |

Interfaces

Interface | Description
ISubscriptionDate | This interface is used to provide the ability to plug in objects that handle the requirements for subscription start date and subscription issue date calculation. This new interface starting in Aptify 4.0, consolidates 3 interfaces from prior versions, the ICGISubsCalc, ICGISubsStart and ICGISubsStart2. All 3 of these prior interfaces map to methods on this new interface
ISubscriptionFulfillment | Interface used to create plug-ins for fulfilling subscriptions

Delegates

Delegate | Description
ISubscriptionFulfillment.ProgressUpdateEventHandler |

Enumerations

Enumeration | Description
FulfillmentOperation |
FulfillmentOutputType |
SubscriptionFulfillmentsEntity.RecipTypeCheck |


FulfillmentOperation Enumeration

public enum FulfillmentOperation

Members

Member Name | Description
CreateRecipientList |
BuildDeliveryLog |
OutputRecipientList |
CompleteFulfillment |

Requirements

Namespace: Aptify.Applications.Subscriptions

Assembly: SubscriptionFulfillmentInterface (in SubscriptionFulfillmentInterface.dll)

See Also

Aptify.Applications.Subscriptions Namespace


FulfillmentOutputType Enumeration

public enum FulfillmentOutputType

Members

Member Name | Description
NoOutput |
Email |
Fax |
MailingLabels |
Report |

Requirements

Namespace: Aptify.Applications.Subscriptions

Assembly: SubscriptionFulfillmentInterface (in SubscriptionFulfillmentInterface.dll)

See Also

Aptify.Applications.Subscriptions Namespace


GetDateForm Class

For a list of all members of this type, see GetDateForm Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
GetDateForm

public class GetDateForm : Form

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Subscriptions

Assembly: SubscriptionRenewal (in SubscriptionRenewal.dll)

See Also

GetDateForm Members | Aptify.Applications.Subscriptions Namespace


GetDateForm Members

GetDateForm overview

Public Instance Constructors

GetDateForm Constructor

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DateEntered |
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

GetDateForm Class | Aptify.Applications.Subscriptions Namespace


GetDateForm Constructor

public GetDateForm(
UserCredentials UserCredential
);

See Also

GetDateForm Class | Aptify.Applications.Subscriptions Namespace


GetDateForm Properties

The properties of the GetDateForm class are listed below. For a complete list of GetDateForm class members, see the GetDateForm Members topic.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DateEntered |
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

GetDateForm Class | Aptify.Applications.Subscriptions Namespace


DateEntered Property

Aptify 5.0 Software Development Kit (SDK)

GetDateForm.DateEntered Property

public DateTime DateEntered {get; set;}

See Also

GetDateForm Class | Aptify.Applications.Subscriptions Namespace


GetDateForm Methods

The methods of the GetDateForm class are listed below. For a complete list of GetDateForm class members, see the GetDateForm Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

GetDateForm Class | Aptify.Applications.Subscriptions Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

GetDateForm.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

GetDateForm Class | Aptify.Applications.Subscriptions Namespace


GetDateForm.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

GetDateForm Class | Aptify.Applications.Subscriptions Namespace | GetDateForm.Dispose Overload List


ISubscriptionDate Interface

This interface is used to provide the ability to plug in objects that handle the requirements for subscription start date and subscription issue date calculation. This new interface starting in Aptify 4.0, consolidates 3 interfaces from prior versions, the ICGISubsCalc, ICGISubsStart and ICGISubsStart2. All 3 of these prior interfaces map to methods on this new interface

For a list of all members of this type, see ISubscriptionDate Members.

public interface ISubscriptionDate

Remarks

Requirements

Namespace: Aptify.Applications.Subscriptions

Assembly: ISubscriptionDate (in ISubscriptionDate.dll)

See Also

ISubscriptionDate Members | Aptify.Applications.Subscriptions Namespace


ISubscriptionDate Members

ISubscriptionDate overview

Public Instance Methods

Config | Call this function once before using to configure it for use with the application object required
GetIssueDate | Overloaded. This function returns the number of Days, Weeks and Months to increment a subscription start date by and also returns the issue date
GetSubsStartDate | Overloaded. This method returns the start date calculated by the object for the subscriber, product combination provided. The OUT Parameter Subscription Start Date returns the start date calculated.

See Also

ISubscriptionDate Interface | Aptify.Applications.Subscriptions Namespace


ISubscriptionDate Methods

The methods of the ISubscriptionDate interface are listed below. For a complete list of ISubscriptionDate interface members, see the ISubscriptionDate Members topic.

Public Instance Methods

Config | Call this function once before using to configure it for use with the application object required
GetIssueDate | Overloaded. This function returns the number of Days, Weeks and Months to increment a subscription start date by and also returns the issue date
GetSubsStartDate | Overloaded. This method returns the start date calculated by the object for the subscriber, product combination provided. The OUT Parameter Subscription Start Date returns the start date calculated.

See Also

ISubscriptionDate Interface | Aptify.Applications.Subscriptions Namespace


ISubscriptionDate.Config Method

Call this function once before using to configure it for use with the application object required

void Config(
AptifyApplication Application
);

Parameters

Application
Required Parameter - Aptify Application Object

Remarks

Added for v4.0 to allow for more robust functionality inside plug-in objects

See Also

ISubscriptionDate Interface | Aptify.Applications.Subscriptions Namespace


GetIssueDate Method

Aptify 5.0 Software Development Kit (SDK)

ISubscriptionDate.GetIssueDate Method

This function returns the number of Days, Weeks and Months to increment a subscription start date by and also returns the issue date

Overload List

This function returns the number of Days, Weeks and Months to increment a subscription start date by and also returns the issue date

DateTime GetIssueDate(Int64,Int64,ref DateTime&,ref Int64&,ref Int64&,ref Int64&);

This is the overloaded version that passes in the Subscription ID as well as the standard input parameters. This function returns the number of Days, Weeks and Months to increment a subscription start date by and also returns the issue date

DateTime GetIssueDate(Int64,Int64,Int64,Int64,ref DateTime&,ref Int64&,ref Int64&,ref Int64&);

See Also

ISubscriptionDate Interface | Aptify.Applications.Subscriptions Namespace


ISubscriptionDate.GetIssueDate Method (Int64, Int64, DateTime&, Int64&, Int64&, Int64&)

This function returns the number of Days, Weeks and Months to increment a subscription start date by and also returns the issue date

DateTime GetIssueDate(
Int64 DaysPerIssue,
Int64 IssueNum,
ref DateTime& StartDate,
ref Int64& Months,
ref Int64& Weeks,
ref Int64& Days
);

Parameters

DaysPerIssue
IssueNum
StartDate
Months
Weeks
Days

Return Value

Remarks

See Also

ISubscriptionDate Interface | Aptify.Applications.Subscriptions Namespace | ISubscriptionDate.GetIssueDate Overload List


ISubscriptionDate.GetIssueDate Method (Int64, Int64, Int64, Int64, DateTime&, Int64&, Int64&, Int64&)

This is the overloaded version that passes in the Subscription ID as well as the standard input parameters. This function returns the number of Days, Weeks and Months to increment a subscription start date by and also returns the issue date

DateTime GetIssueDate(
Int64 OrderID,
Int64 ProductID,
Int64 DaysPerIssue,
Int64 IssueNum,
ref DateTime& StartDate,
ref Int64& Months,
ref Int64& Weeks,
ref Int64& Days
);

Parameters

OrderID
ProductID
DaysPerIssue
IssueNum
StartDate
Months
Weeks
Days

Return Value

Remarks

See Also

ISubscriptionDate Interface | Aptify.Applications.Subscriptions Namespace | ISubscriptionDate.GetIssueDate Overload List


GetSubsStartDate Method

Aptify 5.0 Software Development Kit (SDK)

ISubscriptionDate.GetSubsStartDate Method

This method returns the start date calculated by the object for any number of attributes since the OrderDetailGE and OrderGE are passed in. The OUT Parameter Subscription Start Date returns the start date calculated.

Overload List

This method returns the start date calculated by the object for any number of attributes since the OrderDetailGE and OrderGE are passed in. The OUT Parameter Subscription Start Date returns the start date calculated.

bool GetSubsStartDate(AptifyGenericEntityBase,AptifyGenericEntityBase,Int64,Int64,Int64,DateTime,ref DateTime&);

This method returns the start date calculated by the object for the subscriber, product combination provided. The OUT Parameter Subscription Start Date returns the start date calculated.

bool GetSubsStartDate(Int64,Int64,DateTime,ref DateTime&);

This method returns the start date calculated by the object for the subscriber, subscriber company and product combination provided. The OUT Parameter Subscription Start Date returns the start date calculated.

bool GetSubsStartDate(Int64,Int64,Int64,DateTime,ref DateTime&);

See Also

ISubscriptionDate Interface | Aptify.Applications.Subscriptions Namespace


ISubscriptionDate.GetSubsStartDate Method (AptifyGenericEntityBase, AptifyGenericEntityBase, Int64, Int64, Int64, DateTime, DateTime&)

This method returns the start date calculated by the object for any number of attributes since the OrderDetailGE and OrderGE are passed in. The OUT Parameter Subscription Start Date returns the start date calculated.

bool GetSubsStartDate(
AptifyGenericEntityBase OrderGE,
AptifyGenericEntityBase OrderLineGE,
Int64 SubscriberID,
Int64 SubscriberCompanyID,
Int64 ProductID,
DateTime OrderDate,
ref DateTime& SubscriptionStartDate
);

Parameters

OrderGE
OrderLineGE
SubscriberID
SubscriberCompanyID
ProductID
OrderDate
SubscriptionStartDate
OUT Parameter: Returns the Start Date Calculated By The Object

Return Value

Remarks

See Also

ISubscriptionDate Interface | Aptify.Applications.Subscriptions Namespace | ISubscriptionDate.GetSubsStartDate Overload List


ISubscriptionDate.GetSubsStartDate Method (Int64, Int64, DateTime, DateTime&)

This method returns the start date calculated by the object for the subscriber, product combination provided. The OUT Parameter Subscription Start Date returns the start date calculated.

bool GetSubsStartDate(
Int64 SubscriberID,
Int64 ProductID,
DateTime OrderDate,
ref DateTime& SubscriptionStartDate
);

Parameters

SubscriberID
ProductID
OrderDate
SubscriptionStartDate
OUT Parameter: Returns the Start Date Calculated By The Object

Return Value

True if method is succesful, False otherwise

Remarks

See Also

ISubscriptionDate Interface | Aptify.Applications.Subscriptions Namespace | ISubscriptionDate.GetSubsStartDate Overload List


ISubscriptionDate.GetSubsStartDate Method (Int64, Int64, Int64, DateTime, DateTime&)

This method returns the start date calculated by the object for the subscriber, subscriber company and product combination provided. The OUT Parameter Subscription Start Date returns the start date calculated.

bool GetSubsStartDate(
Int64 SubscriberID,
Int64 SubscriberCompanyID,
Int64 ProductID,
DateTime OrderDate,
ref DateTime& SubscriptionStartDate
);

Parameters

SubscriberID
SubscriberCompanyID
ProductID
OrderDate
SubscriptionStartDate
OUT Parameter: Returns the Start Date Calculated By The Object

Return Value

True if method is succesful, False otherwise

Remarks

See Also

ISubscriptionDate Interface | Aptify.Applications.Subscriptions Namespace | ISubscriptionDate.GetSubsStartDate Overload List


ISubscriptionFulfillment Interface

Interface used to create plug-ins for fulfilling subscriptions

For a list of all members of this type, see ISubscriptionFulfillment Members.

public interface ISubscriptionFulfillment

Types that implement ISubscriptionFulfillment

Type | Description
SubscriptionFulfillment | This class is used to fulfill a subscription with information from the Subscription Fulfillment entity. It builds a recipient list for a fulfillment and can produce output in the form of a report, mailing labels or an output file that has e-mail addresses or fax numbers.

Remarks

Requirements

Namespace: Aptify.Applications.Subscriptions

Assembly: SubscriptionFulfillmentInterface (in SubscriptionFulfillmentInterface.dll)

See Also

ISubscriptionFulfillment Members | Aptify.Applications.Subscriptions Namespace


ISubscriptionFulfillment Members

ISubscriptionFulfillment overview

Public Instance Properties

Count
RecipientList

Public Instance Methods

BeginTrans
CommitTrans
Config
DoFulfillment
RollbackTrans

Public Instance Events

ProgressUpdate

See Also

ISubscriptionFulfillment Interface | Aptify.Applications.Subscriptions Namespace


ISubscriptionFulfillment Properties

The properties of the ISubscriptionFulfillment interface are listed below. For a complete list of ISubscriptionFulfillment interface members, see the ISubscriptionFulfillment Members topic.

Public Instance Properties

Count
RecipientList

See Also

ISubscriptionFulfillment Interface | Aptify.Applications.Subscriptions Namespace


Count Property

Aptify 5.0 Software Development Kit (SDK)

ISubscriptionFulfillment.Count Property

Int64 Count {get;}

See Also

ISubscriptionFulfillment Interface | Aptify.Applications.Subscriptions Namespace


RecipientList Property

Aptify 5.0 Software Development Kit (SDK)

ISubscriptionFulfillment.RecipientList Property

DataTable RecipientList {get;}

See Also

ISubscriptionFulfillment Interface | Aptify.Applications.Subscriptions Namespace


ISubscriptionFulfillment Methods

The methods of the ISubscriptionFulfillment interface are listed below. For a complete list of ISubscriptionFulfillment interface members, see the ISubscriptionFulfillment Members topic.

Public Instance Methods

BeginTrans
CommitTrans
Config
DoFulfillment
RollbackTrans

See Also

ISubscriptionFulfillment Interface | Aptify.Applications.Subscriptions Namespace


ISubscriptionFulfillment.BeginTrans Method

bool BeginTrans();

See Also

ISubscriptionFulfillment Interface | Aptify.Applications.Subscriptions Namespace


ISubscriptionFulfillment.CommitTrans Method

bool CommitTrans();

See Also

ISubscriptionFulfillment Interface | Aptify.Applications.Subscriptions Namespace


ISubscriptionFulfillment.Config Method

void Config(
AptifyApplication ApplicationObject
);

See Also

ISubscriptionFulfillment Interface | Aptify.Applications.Subscriptions Namespace


ISubscriptionFulfillment.DoFulfillment Method

bool DoFulfillment(
Int64 FulfillmentID,
Int64 SubscriptionProductID,
DateTime DistributionDate,
String Volume,
String Issue,
FulfillmentOperation Operation,
FulfillmentOutputType OutputType,
String OutputFilename
);

See Also

ISubscriptionFulfillment Interface | Aptify.Applications.Subscriptions Namespace


ISubscriptionFulfillment.RollbackTrans Method

bool RollbackTrans();

See Also

ISubscriptionFulfillment Interface | Aptify.Applications.Subscriptions Namespace


ISubscriptionFulfillment Events

The events of the ISubscriptionFulfillment interface are listed below. For a complete list of ISubscriptionFulfillment interface members, see the ISubscriptionFulfillment Members topic.

Public Instance Events

ProgressUpdate

See Also

ISubscriptionFulfillment Interface | Aptify.Applications.Subscriptions Namespace


ISubscriptionFulfillment.ISubscriptionFulfillment.ProgressUpdateEventHandler Event

event ISubscriptionFulfillment.ProgressUpdateEventHandler ProgressUpdate;

See Also

ISubscriptionFulfillment Interface | Aptify.Applications.Subscriptions Namespace


ISubscriptionFulfillment.ProgressUpdateEventHandler Delegate

public delegate void ISubscriptionFulfillment.ProgressUpdateEventHandler(
Int32 CurrentPercent,
Int32 PercentChanged
);

Requirements

Namespace: Aptify.Applications.Subscriptions

Assembly: SubscriptionFulfillmentInterface (in SubscriptionFulfillmentInterface.dll)

See Also

Aptify.Applications.Subscriptions Namespace


SubscriptionEntity Class

This object serves as the Subscriptions Generic Entity Object.

For a list of all members of this type, see SubscriptionEntity Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
SubscriptionsClass
SubscriptionEntity

public class SubscriptionEntity : SubscriptionsClass

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Subscriptions

Assembly: SubscriptionEntity (in SubscriptionEntity.dll)

See Also

SubscriptionEntity Members | Aptify.Applications.Subscriptions Namespace


SubscriptionEntity Members

SubscriptionEntity overview

Public Instance Constructors

SubscriptionEntity Constructor Initializes a new instance of the SubscriptionEntity class.

Public Instance Properties

Agency (inherited from SubscriptionsClass) |
AgentID (inherited from SubscriptionsClass) |
AgentOrderNumber (inherited from SubscriptionsClass) |
Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
AutoRenew (inherited from SubscriptionsClass) |
AutoRenewStandingOrderID (inherited from SubscriptionsClass) |
BaseIssuesSent (inherited from SubscriptionsClass) |
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
CALC_EndDate (inherited from SubscriptionsClass) |
CALC_IssuesPurchased (inherited from SubscriptionsClass) |
CALC_IssuesSent (inherited from SubscriptionsClass) |
CALC_NumPurchases (inherited from SubscriptionsClass) |
CALC_StartDate (inherited from SubscriptionsClass) |
Campaign (inherited from SubscriptionsClass) |
CampaignID (inherited from SubscriptionsClass) |
CancelComments (inherited from SubscriptionsClass) |
CancelReason (inherited from SubscriptionsClass) |
CancelReasonID (inherited from SubscriptionsClass) |
ChapterID (inherited from SubscriptionsClass) |
Comments (inherited from SubscriptionsClass) |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DateCreated (inherited from SubscriptionsClass) |
DateUpdated (inherited from SubscriptionsClass) |
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
DistributionType (inherited from SubscriptionsClass) |
DistributionTypeID (inherited from SubscriptionsClass) |
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EndDate (inherited from SubscriptionsClass) |
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
ID (inherited from SubscriptionsClass) |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
IssuesLeft (inherited from SubscriptionsClass) |
IssuesPurchased (inherited from SubscriptionsClass) |
IssuesSent (inherited from SubscriptionsClass) |
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
Product (inherited from SubscriptionsClass) |
ProductID (inherited from SubscriptionsClass) |
Purchases (inherited from SubscriptionsClass) |
Quantity (inherited from SubscriptionsClass) |
Recipient (inherited from SubscriptionsClass) |
RecipientCompany (inherited from SubscriptionsClass) |
RecipientID (inherited from SubscriptionsClass) |
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
ReferredBy (inherited from SubscriptionsClass) |
ReferredByID (inherited from SubscriptionsClass) |
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
ShipToID (inherited from SubscriptionsClass) |
StartDate (inherited from SubscriptionsClass) |
Status (inherited from SubscriptionsClass) |
StatusID (inherited from SubscriptionsClass) |
Subscriber (inherited from SubscriptionsClass) |
SubscriberCompany (inherited from SubscriptionsClass) |
SubscriberCompanyID (inherited from SubscriptionsClass) |
SubscriberID (inherited from SubscriptionsClass) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.
WhoCreated (inherited from SubscriptionsClass) |
WhoUpdated (inherited from SubscriptionsClass) |

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config | Overloaded.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded. Saves the Subscriptions Object.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
SubscriptionDeliveryLog (inherited from SubscriptionsClass) |
SubscriptionDeliveryLogObject (inherited from SubscriptionsClass) |
SubscriptionDeliverySchedule (inherited from SubscriptionsClass) |
SubscriptionDeliveryScheduleObject (inherited from SubscriptionsClass) |
SubscriptionPurchases (inherited from SubscriptionsClass) |
SubscriptionPurchasesObject (inherited from SubscriptionsClass) |
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
GetSubscriptionStatusID | This method is responsible for returning the ID value associated with the Subscription Status name specified in the Status parameter. If a record is not found that matches the specified status name, the value in DefaultValue is returned. The implementation of this method in the base class uses the spGetSubsStatusID stored procedure. Since the Subscription Status entity rarely changes, this method uses caching by default to improve performance.
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

SubscriptionEntity Class | Aptify.Applications.Subscriptions Namespace


SubscriptionEntity Constructor

Initializes a new instance of the SubscriptionEntity class.

public SubscriptionEntity();

See Also

SubscriptionEntity Class | Aptify.Applications.Subscriptions Namespace


SubscriptionEntity Methods

The methods of the SubscriptionEntity class are listed below. For a complete list of SubscriptionEntity class members, see the SubscriptionEntity Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config | Overloaded.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded. Saves the Subscriptions Object.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
SubscriptionDeliveryLog (inherited from SubscriptionsClass) |
SubscriptionDeliveryLogObject (inherited from SubscriptionsClass) |
SubscriptionDeliverySchedule (inherited from SubscriptionsClass) |
SubscriptionDeliveryScheduleObject (inherited from SubscriptionsClass) |
SubscriptionPurchases (inherited from SubscriptionsClass) |
SubscriptionPurchasesObject (inherited from SubscriptionsClass) |
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
GetSubscriptionStatusID | This method is responsible for returning the ID value associated with the Subscription Status name specified in the Status parameter. If a record is not found that matches the specified status name, the value in DefaultValue is returned. The implementation of this method in the base class uses the spGetSubsStatusID stored procedure. Since the Subscription Status entity rarely changes, this method uses caching by default to improve performance.
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

SubscriptionEntity Class | Aptify.Applications.Subscriptions Namespace


Config Method

Aptify 5.0 Software Development Kit (SDK)

SubscriptionEntity.Config Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual void Config(AptifySubTypeBase);

Inherited from AptifyGenericEntity.

public override void Config(AptifySubTypeBase,Int64);

Inherited from AptifyGenericEntityBase.

public virtual void Config(UserCredentials,String);

public override void Config(UserCredentials,String,Int64);

See Also

SubscriptionEntity Class | Aptify.Applications.Subscriptions Namespace


SubscriptionEntity.Config Method (UserCredentials, String, Int64)

public override void Config(
UserCredentials UserCredentials,
String EntityName,
Int64 RecordID
);

See Also

SubscriptionEntity Class | Aptify.Applications.Subscriptions Namespace | SubscriptionEntity.Config Overload List


SubscriptionEntity.GetSubscriptionStatusID Method

This method is responsible for returning the ID value associated with the Subscription Status name specified in the Status parameter. If a record is not found that matches the specified status name, the value in DefaultValue is returned. The implementation of this method in the base class uses the spGetSubsStatusID stored procedure. Since the Subscription Status entity rarely changes, this method uses caching by default to improve performance.

protected virtual long GetSubscriptionStatusID(
String Status,
Int64 DefaultValue
);

Parameters

Status
DefaultValue

Return Value

Remarks

See Also

SubscriptionEntity Class | Aptify.Applications.Subscriptions Namespace


Save Method

Aptify 5.0 Software Development Kit (SDK)

SubscriptionEntity.Save Method

Saves the Subscriptions Object.

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Save();

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean,ref String&);

Saves the Subscriptions Object.

public override bool Save(Boolean,ref String&,String);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(ref String&);

See Also

SubscriptionEntity Class | Aptify.Applications.Subscriptions Namespace


SubscriptionEntity.Save Method (Boolean, String&, String)

Saves the Subscriptions Object.

public override bool Save(
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

Parameters

AllowGUI
ErrorString
TransactionID

Return Value

Remarks

See Also

SubscriptionEntity Class | Aptify.Applications.Subscriptions Namespace | SubscriptionEntity.Save Overload List


SubscriptionFulfillment Class

This class is used to fulfill a subscription with information from the Subscription Fulfillment entity. It builds a recipient list for a fulfillment and can produce output in the form of a report, mailing labels or an output file that has e-mail addresses or fax numbers.

For a list of all members of this type, see SubscriptionFulfillment Members.

System.Object
SubscriptionFulfillment

public class SubscriptionFulfillment : ISubscriptionFulfillment

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

This object can store state between calls to DoFulfillment. The state is used to cache the Recipient List Data Table. However, if the developer does not want to hold the state, the Fulfillment process will still work but the Data Table will have to be retrieved again in some cases since it is a state-based object

Requirements

Namespace: Aptify.Applications.Subscriptions

Assembly: SubscriptionFulfillment (in SubscriptionFulfillment.dll)

See Also

SubscriptionFulfillment Members | Aptify.Applications.Subscriptions Namespace


SubscriptionFulfillment Members

SubscriptionFulfillment overview

Public Instance Constructors

SubscriptionFulfillment Constructor Initializes a new instance of the SubscriptionFulfillment class.

Public Instance Properties

Count
RecipientList

Public Instance Methods

BeginTrans |
CommitTrans |
Config |
DoFulfillment |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
RollbackTrans |
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

ProgressUpdate

Protected Instance Methods

BuildDeliveryLog |
DoEmailOutput |
DoFaxOutput |
DoReportOutput |
Finalize |
FormatSQLDate |
FormatSQLString |
GetRecipientList |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SubscriptionFulfillment Class | Aptify.Applications.Subscriptions Namespace


SubscriptionFulfillment Constructor

Initializes a new instance of the SubscriptionFulfillment class.

public SubscriptionFulfillment();

See Also

SubscriptionFulfillment Class | Aptify.Applications.Subscriptions Namespace


SubscriptionFulfillment Properties

The properties of the SubscriptionFulfillment class are listed below. For a complete list of SubscriptionFulfillment class members, see the SubscriptionFulfillment Members topic.

Public Instance Properties

Count
RecipientList

See Also

SubscriptionFulfillment Class | Aptify.Applications.Subscriptions Namespace


Count Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionFulfillment.Count Property

public Int64 Count {get;}

Implements

ISubscriptionFulfillment.

See Also

SubscriptionFulfillment Class | Aptify.Applications.Subscriptions Namespace


RecipientList Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionFulfillment.RecipientList Property

public DataTable RecipientList {get;}

Implements

ISubscriptionFulfillment.

See Also

SubscriptionFulfillment Class | Aptify.Applications.Subscriptions Namespace


SubscriptionFulfillment Methods

The methods of the SubscriptionFulfillment class are listed below. For a complete list of SubscriptionFulfillment class members, see the SubscriptionFulfillment Members topic.

Public Instance Methods

BeginTrans |
CommitTrans |
Config |
DoFulfillment |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
RollbackTrans |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

BuildDeliveryLog |
DoEmailOutput |
DoFaxOutput |
DoReportOutput |
Finalize |
FormatSQLDate |
FormatSQLString |
GetRecipientList |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SubscriptionFulfillment Class | Aptify.Applications.Subscriptions Namespace


SubscriptionFulfillment.BeginTrans Method

public bool BeginTrans();

Implements

ISubscriptionFulfillment.

See Also

SubscriptionFulfillment Class | Aptify.Applications.Subscriptions Namespace


SubscriptionFulfillment.BuildDeliveryLog Method

protected virtual bool BuildDeliveryLog();

See Also

SubscriptionFulfillment Class | Aptify.Applications.Subscriptions Namespace


SubscriptionFulfillment.CommitTrans Method

public bool CommitTrans();

Implements

ISubscriptionFulfillment.

See Also

SubscriptionFulfillment Class | Aptify.Applications.Subscriptions Namespace


SubscriptionFulfillment.Config Method

public void Config(
AptifyApplication Application
);

Implements

ISubscriptionFulfillment.

See Also

SubscriptionFulfillment Class | Aptify.Applications.Subscriptions Namespace


SubscriptionFulfillment.DoEmailOutput Method

protected virtual bool DoEmailOutput(
String OutputFilename
);

See Also

SubscriptionFulfillment Class | Aptify.Applications.Subscriptions Namespace


SubscriptionFulfillment.DoFaxOutput Method

protected virtual bool DoFaxOutput(
String OutputFilename
);

See Also

SubscriptionFulfillment Class | Aptify.Applications.Subscriptions Namespace


SubscriptionFulfillment.DoFulfillment Method

public bool DoFulfillment(
Int64 FulfillmentID,
Int64 SubscriptionProductID,
DateTime DistributionDate,
String Volume,
String Issue,
FulfillmentOperation Operation,
FulfillmentOutputType OutputType,
String OutputFilename
);

Implements

ISubscriptionFulfillment.

See Also

SubscriptionFulfillment Class | Aptify.Applications.Subscriptions Namespace


SubscriptionFulfillment.DoReportOutput Method

protected virtual bool DoReportOutput(
String sReportType
);

See Also

SubscriptionFulfillment Class | Aptify.Applications.Subscriptions Namespace


SubscriptionFulfillment.Finalize Method

protected override void Finalize();

See Also

SubscriptionFulfillment Class | Aptify.Applications.Subscriptions Namespace


SubscriptionFulfillment.FormatSQLDate Method

protected string FormatSQLDate(
String sDate
);

See Also

SubscriptionFulfillment Class | Aptify.Applications.Subscriptions Namespace


SubscriptionFulfillment.FormatSQLString Method

protected string FormatSQLString(
String sSQLString
);

See Also

SubscriptionFulfillment Class | Aptify.Applications.Subscriptions Namespace


SubscriptionFulfillment.GetRecipientList Method

protected virtual bool GetRecipientList();

See Also

SubscriptionFulfillment Class | Aptify.Applications.Subscriptions Namespace


SubscriptionFulfillment.RollbackTrans Method

public bool RollbackTrans();

Implements

ISubscriptionFulfillment.

See Also

SubscriptionFulfillment Class | Aptify.Applications.Subscriptions Namespace


SubscriptionFulfillment Events

The events of the SubscriptionFulfillment class are listed below. For a complete list of SubscriptionFulfillment class members, see the SubscriptionFulfillment Members topic.

Public Instance Events

ProgressUpdate

See Also

SubscriptionFulfillment Class | Aptify.Applications.Subscriptions Namespace


SubscriptionFulfillment.ISubscriptionFulfillment.ProgressUpdateEventHandler Event

public event ISubscriptionFulfillment.ProgressUpdateEventHandler ProgressUpdate;

Implements

ISubscriptionFulfillment.

See Also

SubscriptionFulfillment Class | Aptify.Applications.Subscriptions Namespace


SubscriptionFulfillmentsEntity Class

For a list of all members of this type, see SubscriptionFulfillmentsEntity Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
SubscriptionFulfillmentsEntity

public class SubscriptionFulfillmentsEntity : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Subscriptions

Assembly: SubscriptionFulfillment (in SubscriptionFulfillment.dll)

See Also

SubscriptionFulfillmentsEntity Members | Aptify.Applications.Subscriptions Namespace


SubscriptionFulfillmentsEntity Members

SubscriptionFulfillmentsEntity overview

Public Instance Constructors

SubscriptionFulfillmentsEntity Constructor Initializes a new instance of the SubscriptionFulfillmentsEntity class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
FulfillmentObject |
IncludesEmail | Property which returns a boolean indicating if Email recipients are included in a fulfillment run.
IncludesFax | Property which returns a boolean indicating if Fax recipients are included in a fulfillment run.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
CheckForEmailAndFaxRecips | Method used to determine if Email and/or Fax distribution types are present in a fulfillment run.
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

SubscriptionFulfillmentsEntity Class | Aptify.Applications.Subscriptions Namespace


SubscriptionFulfillmentsEntity Constructor

Initializes a new instance of the SubscriptionFulfillmentsEntity class.

public SubscriptionFulfillmentsEntity();

See Also

SubscriptionFulfillmentsEntity Class | Aptify.Applications.Subscriptions Namespace


SubscriptionFulfillmentsEntity Properties

The properties of the SubscriptionFulfillmentsEntity class are listed below. For a complete list of SubscriptionFulfillmentsEntity class members, see the SubscriptionFulfillmentsEntity Members topic.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
FulfillmentObject |
IncludesEmail | Property which returns a boolean indicating if Email recipients are included in a fulfillment run.
IncludesFax | Property which returns a boolean indicating if Fax recipients are included in a fulfillment run.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

SubscriptionFulfillmentsEntity Class | Aptify.Applications.Subscriptions Namespace


FulfillmentObject Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionFulfillmentsEntity.FulfillmentObject Property

public ISubscriptionFulfillment FulfillmentObject {get;}

See Also

SubscriptionFulfillmentsEntity Class | Aptify.Applications.Subscriptions Namespace


IncludesEmail Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionFulfillmentsEntity.IncludesEmail Property

Property which returns a boolean indicating if Email recipients are included in a fulfillment run.

public SubscriptionFulfillmentsEntity.RecipTypeCheck IncludesEmail {get;}

Property Value

Remarks

See Also

SubscriptionFulfillmentsEntity Class | Aptify.Applications.Subscriptions Namespace


IncludesFax Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionFulfillmentsEntity.IncludesFax Property

Property which returns a boolean indicating if Fax recipients are included in a fulfillment run.

public SubscriptionFulfillmentsEntity.RecipTypeCheck IncludesFax {get;}

Property Value

Remarks

See Also

SubscriptionFulfillmentsEntity Class | Aptify.Applications.Subscriptions Namespace


SubscriptionFulfillmentsEntity Methods

The methods of the SubscriptionFulfillmentsEntity class are listed below. For a complete list of SubscriptionFulfillmentsEntity class members, see the SubscriptionFulfillmentsEntity Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
CheckForEmailAndFaxRecips | Method used to determine if Email and/or Fax distribution types are present in a fulfillment run.
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

SubscriptionFulfillmentsEntity Class | Aptify.Applications.Subscriptions Namespace


SubscriptionFulfillmentsEntity.CheckForEmailAndFaxRecips Method

Method used to determine if Email and/or Fax distribution types are present in a fulfillment run.

protected void CheckForEmailAndFaxRecips();

Remarks

See Also

SubscriptionFulfillmentsEntity Class | Aptify.Applications.Subscriptions Namespace


SubscriptionFulfillmentsEntity.RecipTypeCheck Enumeration

public enum SubscriptionFulfillmentsEntity.RecipTypeCheck

Members

Member Name | Description
Yes |
No |
NotConfigured |

Requirements

Namespace: Aptify.Applications.Subscriptions

Assembly: SubscriptionFulfillment (in SubscriptionFulfillment.dll)

See Also

Aptify.Applications.Subscriptions Namespace


SubscriptionRenewal Class

This class is responsible for renewing subscriptions and supports execution through an Action interface, view extension as well as a Process Component. This component can be used with its type-specific members as well.

For a list of all members of this type, see SubscriptionRenewal Members.

System.Object
SubscriptionRenewal

public class SubscriptionRenewal : IProcessComponent, IAptifyAction, IAptifyViewExtension

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Subscriptions

Assembly: SubscriptionRenewal (in SubscriptionRenewal.dll)

See Also

SubscriptionRenewal Members | Aptify.Applications.Subscriptions Namespace


SubscriptionRenewal Members

SubscriptionRenewal overview

Public Instance Constructors

SubscriptionRenewal Constructor Initializes a new instance of the SubscriptionRenewal class.

Public Instance Properties

Application |
ExtensionMenuItem |
ProductGEObjectCache | This property is used to provide functionality for a cache of Product GE objects. The purpose of this is to make the renewal process much faster since Product GE objects require overhead to load and are often reused many times during a subscription renewal cycle. This cache automatically will load a new product GE object for the specified ProductID if it has not previously been loaded and will return the existing product GE object from cache if it has already been loaded
Properties |
ViewPlugIn |

Public Instance Methods

Attach |
Config | Overloaded.
DoAction | Overloaded.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ParseString |
Run |
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

AfterAttach
AfterConfig
AfterExecute
BeforeAttach
BeforeConfig
BeforeExecute

Protected Instance Fields

m_bAllowGUI

Protected Instance Properties

PreferredAddressObject | Returns an instance of the object that handles preferred address selection
SubscriptionStatusForm | Returns the Subscription Status Form (or a derived class if overriden by a sub-class of the SubscriptionRenewal class)

Protected Instance Methods

DoCreateRenewalInvoices | Creates renewal invoices (Quotation Orders) for the specified data set either specified via the Selection List of Subscription ID values or the View ID which is assumed to be a valid view of Subscriptions that are to be renewed by this process.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetDefaultDueDate | This function is responsible for calculating the default due date for the subscriptions being renewed. The base class calculates this by simply adding one month to the current date. Override this function to alter the default due date function.
GetDefaultShipTypeID | This function returns the Ship Type ID that will be used on the renewal subscriptions. By default, this function returns the lowest ID from the Ship Types entity in the system. Override this method to alter the Ship Type ID that is used for the renewal orders that are created by the subscription renewal process.
GetEmployeeID | This function returns the Employee ID that will be used on the renewal subscriptions for the Taken By field. By default, this function returns the Employee ID related to the Aptify User ID from the UserCredentials inside the Application object passed into the Config() method of this class. Override this method to alter the Employee ID that is used for the Taken By field for the renewal orders that are created by the subscription renewal process.
GetListTypeID | Returns the List Type ID associated with a given List ID
GetPersonInfo | This function is responsible for determining the order level and company ID associated with an individual. The default implementation of this method in the base class simply returns the GLOrderLevelID field and CompanyID field from the Person table for the given PersonID. To alter the functionality, override this method in a sub-class and implement the logic desired.
GetPurchaseOrderPaymentTypeID | This function returns the Payment Type ID that will be used on the renewal subscriptions. By default, this function returns the ID from the spGetPurchaseOrderPayTypeID stored procedure. Override this method to alter the Payment Type ID that is used for the renewal orders that are created by the subscription renewal process.
GetRenewalOrderSourceID | This function returns the Order Source ID that will be used on the renewal subscriptions. By default, this function returns the lowest Order Source in the system. Override this method to alter the Order Source ID that is used for the renewal orders that are created by the subscription renewal process.
GetRenewalOrderStatusID | This function returns the Order Status ID that will be used on the renewal subscriptions. By default, this function returns the ID for the Taken Order Status Type. Override this method to alter the Order Status ID that is used for the renewal orders that are created by the subscription renewal process. If you are using the default logic and are setting the Order Type to Quotation, this is the only valid Order Status that can be set. However, in the event that Orders are being set to an Order Type of Regular Order, it maybe desirable to set the Status to Shipped immediately upon the renewal process occuring. Review the Aptify product documentation for details on the Order Status types of Taken and Shipped for more details on how this process can be implemented.
GetRenewalOrderTypeID | This function returns the Order Type ID that will be used on the renewal subscriptions. By default, this function returns 4, which corresponds to the Quotation Order Type(Pro Forma). Override this method to alter the Order Type ID that is used for the renewal orders that are created by the subscription renewal process. For example, if it is desired to have the Renewals immediately become regular orders, this function can be overriden to return the appropriate Order Type ID for Regular Orders
GetRenewalSelectClause | This function is responsiable for returning the SELECT clause for the Renewal SQL Statement. By Default it returns ID, ProductID, SubscriberID, Quantity, ShipToID, SubscriberCompanyID, NumCopies (from most recent renewal), and SubscriberDefaultCurrencyTypeID. If you would like to get more information back for the process while overriding one of the other functions in this object in a sub-class, override this method and add additional fields to the SELECT clause. DO NOT REMOVE the existing fields from this select clause as doing so will break the functionality of the base class as other functions assume those fields exist in the data-table/data-row returned by this SQL statement
GetRenewalSQL | This function returns the SQL statement that is used to create the list of subscriptions that need to be renewed.
GetScalarLong | Returns a scalar long value from a SQL statement, assumes SQL statement will produce a single value in a single row
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAskUserForDueDate | Ask the user for the due date to use for the subscriptions that are being renewed. This function is only called if the CreateRenewalInvoices() function is called with ShowGUI set to True. If ShowGUI is set to false, then this function is never called and GetDefaultDueDate() is called.
OnAskUserToRenew | This overridable function is reponsible for asking the user if it is okay to renew the subscriptions. This function is only called by CreateRenewalInvoices() if the ShowGUI parameter is passed into CreateRenewalInvoices as TRUE. If ShowGUI is set to False, this function is never called. Override this function to alter the behavior of the user interfaction for asking for the OK to renew the subscriptions.
OnCanProcessByCancelledByUser | This function is responsible for determining if the process can be cancelled by a user. This function is only called when ShowGUI is set to True when calling the CreateRenewalInvoices() function. The default return value for this function is True
OnHideStatusForm | This function is responsible for hiding the status form and is only called by the CreateRenewalInvoices function when the ShowGUI parameter is passed in as true. If the ShowGUI parameter is False in the CreateRenewalInvoices function, this method is never called. Override this method in a sub-class to alter the handling of the Status Form
OnNotifyUserOfNoSubscriptionsToRenew | This function is responsible for notifying the user that there are no subscriptions to renew in the provided view/selection list. The default implementation simply display a message box with that notification. This function is only called if the CreateRenewalInvoices() method is called with ShowGUI set to True
OnNotifyUserOfProcessCancellation | This function is responsible for notifying the user that the renewal process was cancelled. The default implementation simply display a message box with that notification. This function is only called if the CreateRenewalInvoices() method is called with ShowGUI set to True
OnNotifyUserOfProcessCompletion | This function is responsible for notifying the user that the renewal process was completed succesfully. The default implementation simply display a message box with that notification. This function is only called if the CreateRenewalInvoices() method is called with ShowGUI set to True
OnSaveOrder | This method is called whenever the process deteremines that it needs to save an order. Override it when it is necessary to add pre/post logic to the Order Save or alter the Order.Save logic itself
OnSetStatusFormPercentComplete | This function is responsible for updating the percent complete on the status form being shown. This function is only called by the renewal process if the ShowGUI parameter passed into the CreateRenewalInvoices() method is set to True
OnSetStatusFormText | This function is responsible for setting the text for the caption/title box of the Subscription Status Form. This function should only be called if the ShowGUI parameter is set to True (for the CreateRenewalInvoices() function)
OnSetupOrderHeader | This function is called whenever a new order is needed in the CreateRenewalInvoices() process. The standard logic in the base class is to call this for each distinct SubscriberID so that multiple subscriptions for the same subscriber are grouped on the same order.
OnShouldProcessBeCancelled | This function is responsible for telling the process if the user cancelled the process (or if the process should be cancelled for any other reason). The user interface aspect of this function should only be tested if the ShowGUI paramter is passed in as true, otherwise this process is running without a user interface and no form should be displayed or tested for values
OnShowStatusForm | This function is responsible for showing the status form and is only called by the CreateRenewalInvoices function when the ShowGUI parameter is passed in as true. If the ShowGUI parameter is False in the CreateRenewalInvoices function, this method is never called. Override this method in a sub-class to alter the handling of the Status Form
RenewSingleSubscription | This method is responsible for renewing each individual subscription within the process of renewing a group of subscriptions. Override this function if the entire process of renewing a single subscription needs to be altered or pre/post processed.

See Also

SubscriptionRenewal Class | Aptify.Applications.Subscriptions Namespace


SubscriptionRenewal Constructor

Initializes a new instance of the SubscriptionRenewal class.

public SubscriptionRenewal();

See Also

SubscriptionRenewal Class | Aptify.Applications.Subscriptions Namespace


SubscriptionRenewal Fields

The fields of the SubscriptionRenewal class are listed below. For a complete list of SubscriptionRenewal class members, see the SubscriptionRenewal Members topic.

Protected Instance Fields

m_bAllowGUI

See Also

SubscriptionRenewal Class | Aptify.Applications.Subscriptions Namespace


SubscriptionRenewal.m_bAllowGUI Field

protected m_bAllowGUI m_bAllowGUI;

See Also

SubscriptionRenewal Class | Aptify.Applications.Subscriptions Namespace


SubscriptionRenewal Properties

The properties of the SubscriptionRenewal class are listed below. For a complete list of SubscriptionRenewal class members, see the SubscriptionRenewal Members topic.

Public Instance Properties

Application |
ExtensionMenuItem |
ProductGEObjectCache | This property is used to provide functionality for a cache of Product GE objects. The purpose of this is to make the renewal process much faster since Product GE objects require overhead to load and are often reused many times during a subscription renewal cycle. This cache automatically will load a new product GE object for the specified ProductID if it has not previously been loaded and will return the existing product GE object from cache if it has already been loaded
Properties |
ViewPlugIn |

Protected Instance Properties

PreferredAddressObject | Returns an instance of the object that handles preferred address selection
SubscriptionStatusForm | Returns the Subscription Status Form (or a derived class if overriden by a sub-class of the SubscriptionRenewal class)

See Also

SubscriptionRenewal Class | Aptify.Applications.Subscriptions Namespace


Application Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionRenewal.Application Property

public AptifyApplication Application {get;}

Implements

IAptifyViewExtension.

See Also

SubscriptionRenewal Class | Aptify.Applications.Subscriptions Namespace


ExtensionMenuItem Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionRenewal.ExtensionMenuItem Property

public MenuItem ExtensionMenuItem {get;}

Implements

IAptifyViewExtension.

See Also

SubscriptionRenewal Class | Aptify.Applications.Subscriptions Namespace


PreferredAddressObject Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionRenewal.PreferredAddressObject Property

Returns an instance of the object that handles preferred address selection

protected PreferredAddress PreferredAddressObject {get;}

Property Value

Remarks

See Also

SubscriptionRenewal Class | Aptify.Applications.Subscriptions Namespace


ProductGEObjectCache Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionRenewal.ProductGEObjectCache Property

This property is used to provide functionality for a cache of Product GE objects. The purpose of this is to make the renewal process much faster since Product GE objects require overhead to load and are often reused many times during a subscription renewal cycle. This cache automatically will load a new product GE object for the specified ProductID if it has not previously been loaded and will return the existing product GE object from cache if it has already been loaded

public virtual AptifyGenericEntityBase this[
Int64 ProductID
] {get;}

Parameters

ProductID
Product ID to return the Product GE for

Property Value

Remarks

See Also

SubscriptionRenewal Class | Aptify.Applications.Subscriptions Namespace


Properties Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionRenewal.Properties Property

public AptifyProperties Properties {get;}

Implements

IProcessComponent.

See Also

SubscriptionRenewal Class | Aptify.Applications.Subscriptions Namespace


SubscriptionStatusForm Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionRenewal.SubscriptionStatusForm Property

Returns the Subscription Status Form (or a derived class if overriden by a sub-class of the SubscriptionRenewal class)

protected virtual SubscriptionRenewalStatus SubscriptionStatusForm {get;}

Property Value

Returns the Subscription Status Form to be used for displaying status to the user (only when the GUI is to be shown)

Remarks

See Also

SubscriptionRenewal Class | Aptify.Applications.Subscriptions Namespace


ViewPlugIn Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionRenewal.ViewPlugIn Property

public IAptifyViewPlugIn ViewPlugIn {get;}

Implements

IAptifyViewExtension.

See Also

SubscriptionRenewal Class | Aptify.Applications.Subscriptions Namespace


SubscriptionRenewal Methods

The methods of the SubscriptionRenewal class are listed below. For a complete list of SubscriptionRenewal class members, see the SubscriptionRenewal Members topic.

Public Instance Methods

Attach |
Config | Overloaded.
DoAction | Overloaded.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ParseString |
Run |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

DoCreateRenewalInvoices | Creates renewal invoices (Quotation Orders) for the specified data set either specified via the Selection List of Subscription ID values or the View ID which is assumed to be a valid view of Subscriptions that are to be renewed by this process.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetDefaultDueDate | This function is responsible for calculating the default due date for the subscriptions being renewed. The base class calculates this by simply adding one month to the current date. Override this function to alter the default due date function.
GetDefaultShipTypeID | This function returns the Ship Type ID that will be used on the renewal subscriptions. By default, this function returns the lowest ID from the Ship Types entity in the system. Override this method to alter the Ship Type ID that is used for the renewal orders that are created by the subscription renewal process.
GetEmployeeID | This function returns the Employee ID that will be used on the renewal subscriptions for the Taken By field. By default, this function returns the Employee ID related to the Aptify User ID from the UserCredentials inside the Application object passed into the Config() method of this class. Override this method to alter the Employee ID that is used for the Taken By field for the renewal orders that are created by the subscription renewal process.
GetListTypeID | Returns the List Type ID associated with a given List ID
GetPersonInfo | This function is responsible for determining the order level and company ID associated with an individual. The default implementation of this method in the base class simply returns the GLOrderLevelID field and CompanyID field from the Person table for the given PersonID. To alter the functionality, override this method in a sub-class and implement the logic desired.
GetPurchaseOrderPaymentTypeID | This function returns the Payment Type ID that will be used on the renewal subscriptions. By default, this function returns the ID from the spGetPurchaseOrderPayTypeID stored procedure. Override this method to alter the Payment Type ID that is used for the renewal orders that are created by the subscription renewal process.
GetRenewalOrderSourceID | This function returns the Order Source ID that will be used on the renewal subscriptions. By default, this function returns the lowest Order Source in the system. Override this method to alter the Order Source ID that is used for the renewal orders that are created by the subscription renewal process.
GetRenewalOrderStatusID | This function returns the Order Status ID that will be used on the renewal subscriptions. By default, this function returns the ID for the Taken Order Status Type. Override this method to alter the Order Status ID that is used for the renewal orders that are created by the subscription renewal process. If you are using the default logic and are setting the Order Type to Quotation, this is the only valid Order Status that can be set. However, in the event that Orders are being set to an Order Type of Regular Order, it maybe desirable to set the Status to Shipped immediately upon the renewal process occuring. Review the Aptify product documentation for details on the Order Status types of Taken and Shipped for more details on how this process can be implemented.
GetRenewalOrderTypeID | This function returns the Order Type ID that will be used on the renewal subscriptions. By default, this function returns 4, which corresponds to the Quotation Order Type(Pro Forma). Override this method to alter the Order Type ID that is used for the renewal orders that are created by the subscription renewal process. For example, if it is desired to have the Renewals immediately become regular orders, this function can be overriden to return the appropriate Order Type ID for Regular Orders
GetRenewalSelectClause | This function is responsiable for returning the SELECT clause for the Renewal SQL Statement. By Default it returns ID, ProductID, SubscriberID, Quantity, ShipToID, SubscriberCompanyID, NumCopies (from most recent renewal), and SubscriberDefaultCurrencyTypeID. If you would like to get more information back for the process while overriding one of the other functions in this object in a sub-class, override this method and add additional fields to the SELECT clause. DO NOT REMOVE the existing fields from this select clause as doing so will break the functionality of the base class as other functions assume those fields exist in the data-table/data-row returned by this SQL statement
GetRenewalSQL | This function returns the SQL statement that is used to create the list of subscriptions that need to be renewed.
GetScalarLong | Returns a scalar long value from a SQL statement, assumes SQL statement will produce a single value in a single row
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAskUserForDueDate | Ask the user for the due date to use for the subscriptions that are being renewed. This function is only called if the CreateRenewalInvoices() function is called with ShowGUI set to True. If ShowGUI is set to false, then this function is never called and GetDefaultDueDate() is called.
OnAskUserToRenew | This overridable function is reponsible for asking the user if it is okay to renew the subscriptions. This function is only called by CreateRenewalInvoices() if the ShowGUI parameter is passed into CreateRenewalInvoices as TRUE. If ShowGUI is set to False, this function is never called. Override this function to alter the behavior of the user interfaction for asking for the OK to renew the subscriptions.
OnCanProcessByCancelledByUser | This function is responsible for determining if the process can be cancelled by a user. This function is only called when ShowGUI is set to True when calling the CreateRenewalInvoices() function. The default return value for this function is True
OnHideStatusForm | This function is responsible for hiding the status form and is only called by the CreateRenewalInvoices function when the ShowGUI parameter is passed in as true. If the ShowGUI parameter is False in the CreateRenewalInvoices function, this method is never called. Override this method in a sub-class to alter the handling of the Status Form
OnNotifyUserOfNoSubscriptionsToRenew | This function is responsible for notifying the user that there are no subscriptions to renew in the provided view/selection list. The default implementation simply display a message box with that notification. This function is only called if the CreateRenewalInvoices() method is called with ShowGUI set to True
OnNotifyUserOfProcessCancellation | This function is responsible for notifying the user that the renewal process was cancelled. The default implementation simply display a message box with that notification. This function is only called if the CreateRenewalInvoices() method is called with ShowGUI set to True
OnNotifyUserOfProcessCompletion | This function is responsible for notifying the user that the renewal process was completed succesfully. The default implementation simply display a message box with that notification. This function is only called if the CreateRenewalInvoices() method is called with ShowGUI set to True
OnSaveOrder | This method is called whenever the process deteremines that it needs to save an order. Override it when it is necessary to add pre/post logic to the Order Save or alter the Order.Save logic itself
OnSetStatusFormPercentComplete | This function is responsible for updating the percent complete on the status form being shown. This function is only called by the renewal process if the ShowGUI parameter passed into the CreateRenewalInvoices() method is set to True
OnSetStatusFormText | This function is responsible for setting the text for the caption/title box of the Subscription Status Form. This function should only be called if the ShowGUI parameter is set to True (for the CreateRenewalInvoices() function)
OnSetupOrderHeader | This function is called whenever a new order is needed in the CreateRenewalInvoices() process. The standard logic in the base class is to call this for each distinct SubscriberID so that multiple subscriptions for the same subscriber are grouped on the same order.
OnShouldProcessBeCancelled | This function is responsible for telling the process if the user cancelled the process (or if the process should be cancelled for any other reason). The user interface aspect of this function should only be tested if the ShowGUI paramter is passed in as true, otherwise this process is running without a user interface and no form should be displayed or tested for values
OnShowStatusForm | This function is responsible for showing the status form and is only called by the CreateRenewalInvoices function when the ShowGUI parameter is passed in as true. If the ShowGUI parameter is False in the CreateRenewalInvoices function, this method is never called. Override this method in a sub-class to alter the handling of the Status Form
RenewSingleSubscription | This method is responsible for renewing each individual subscription within the process of renewing a group of subscriptions. Override this function if the entire process of renewing a single subscription needs to be altered or pre/post processed.

See Also

SubscriptionRenewal Class | Aptify.Applications.Subscriptions Namespace


SubscriptionRenewal.Attach Method

public void Attach(
MenuItem ExtensionMenuItem
);

Implements

IAptifyViewExtension.

See Also

SubscriptionRenewal Class | Aptify.Applications.Subscriptions Namespace


Config Method

Aptify 5.0 Software Development Kit (SDK)

SubscriptionRenewal.Config Method

Overload List

public virtual void Config(AptifyApplication);

public void Config(AptifyApplication,IAptifyViewPlugIn);

See Also

SubscriptionRenewal Class | Aptify.Applications.Subscriptions Namespace


SubscriptionRenewal.Config Method (AptifyApplication)

public virtual void Config(
AptifyApplication ApplicationObject
);

Implements

IProcessComponent.

See Also

SubscriptionRenewal Class | Aptify.Applications.Subscriptions Namespace | SubscriptionRenewal.Config Overload List


SubscriptionRenewal.Config Method (AptifyApplication, IAptifyViewPlugIn)

public void Config(
AptifyApplication Application,
IAptifyViewPlugIn ViewPlugIn
);

Implements

IAptifyViewExtension.

See Also

SubscriptionRenewal Class | Aptify.Applications.Subscriptions Namespace | SubscriptionRenewal.Config Overload List


DoAction Method

Aptify 5.0 Software Development Kit (SDK)

SubscriptionRenewal.DoAction Method

Overload List

public void DoAction(AptifyApplication,Int64);

public void DoAction(AptifyApplication,Int64,Int64);

public void DoAction(AptifyApplication,Int64,Int64,params Object[]);

public void DoAction(AptifyApplication,Int64,params String[]);

See Also

SubscriptionRenewal Class | Aptify.Applications.Subscriptions Namespace


SubscriptionRenewal.DoAction Method (AptifyApplication, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID
);

Implements

IAptifyAction.

See Also

SubscriptionRenewal Class | Aptify.Applications.Subscriptions Namespace | SubscriptionRenewal.DoAction Overload List


SubscriptionRenewal.DoAction Method (AptifyApplication, Int64, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID
);

Implements

IAptifyAction.

See Also

SubscriptionRenewal Class | Aptify.Applications.Subscriptions Namespace | SubscriptionRenewal.DoAction Overload List


SubscriptionRenewal.DoAction Method (AptifyApplication, Int64, Int64, Object[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID,
params Object[] SelectedItems
);

Implements

IAptifyAction.

See Also

SubscriptionRenewal Class | Aptify.Applications.Subscriptions Namespace | SubscriptionRenewal.DoAction Overload List


SubscriptionRenewal.DoAction Method (AptifyApplication, Int64, String[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
params String[] SelectedItems
);

Implements

IAptifyAction.

See Also

SubscriptionRenewal Class | Aptify.Applications.Subscriptions Namespace | SubscriptionRenewal.DoAction Overload List


SubscriptionRenewal.DoCreateRenewalInvoices Method

Creates renewal invoices (Quotation Orders) for the specified data set either specified via the Selection List of Subscription ID values or the View ID which is assumed to be a valid view of Subscriptions that are to be renewed by this process.

protected virtual void DoCreateRenewalInvoices(
Boolean ShowGUI,
Object[] SelectedItems,
Int64 ViewID,
ref Int64& RenewalCount
);

Parameters

ShowGUI
Should the User Interface Be Used or Not
SelectedItems
Optional Array of Selected Records To Use in the Renewal
ViewID
View of subscriptions to be used for the renewal
RenewalCount
OUT Paramater: Optional parameter that returns the number of subscriptions that were renewed

Remarks

See Also

SubscriptionRenewal Class | Aptify.Applications.Subscriptions Namespace


SubscriptionRenewal.Execute Method

public void Execute(
MenuItem FunctionMenuItem
);

Implements

IAptifyViewExtension.

See Also

SubscriptionRenewal Class | Aptify.Applications.Subscriptions Namespace


SubscriptionRenewal.GetDefaultDueDate Method

This function is responsible for calculating the default due date for the subscriptions being renewed. The base class calculates this by simply adding one month to the current date. Override this function to alter the default due date function.

protected virtual DateTime GetDefaultDueDate();

Return Value

A valid due date for renewal invoices

Remarks

See Also

SubscriptionRenewal Class | Aptify.Applications.Subscriptions Namespace


SubscriptionRenewal.GetDefaultShipTypeID Method

This function returns the Ship Type ID that will be used on the renewal subscriptions. By default, this function returns the lowest ID from the Ship Types entity in the system. Override this method to alter the Ship Type ID that is used for the renewal orders that are created by the subscription renewal process.

protected virtual long GetDefaultShipTypeID();

Return Value

A valid ID from the Ship Types entity

Remarks

See Also

SubscriptionRenewal Class | Aptify.Applications.Subscriptions Namespace


SubscriptionRenewal.GetEmployeeID Method

This function returns the Employee ID that will be used on the renewal subscriptions for the Taken By field. By default, this function returns the Employee ID related to the Aptify User ID from the UserCredentials inside the Application object passed into the Config() method of this class. Override this method to alter the Employee ID that is used for the Taken By field for the renewal orders that are created by the subscription renewal process.

protected virtual long GetEmployeeID();

Return Value

A valid Employee ID from the Employees entity

Remarks

See Also

SubscriptionRenewal Class | Aptify.Applications.Subscriptions Namespace


SubscriptionRenewal.GetListTypeID Method

Returns the List Type ID associated with a given List ID

protected virtual long GetListTypeID(
Int64 ListID
);

Parameters

ListID
The List ID to check the List Type ID for

Return Value

The List Type ID associated with the paramter ListID

Remarks

See Also

SubscriptionRenewal Class | Aptify.Applications.Subscriptions Namespace


SubscriptionRenewal.GetPersonInfo Method

This function is responsible for determining the order level and company ID associated with an individual. The default implementation of this method in the base class simply returns the GLOrderLevelID field and CompanyID field from the Person table for the given PersonID. To alter the functionality, override this method in a sub-class and implement the logic desired.

protected virtual bool GetPersonInfo(
Int64 PersonID,
ref Int64& OrderLevelID,
ref Int64& CompanyID
);

Parameters

PersonID
Person ID to return the Order Level ID and Company ID information for
OrderLevelID
OUT Parameter: Order Level ID to use for renewal orders
CompanyID
OUT Parameter: Company ID to associate with the individual Person ID passed in

Return Value

Remarks

See Also

SubscriptionRenewal Class | Aptify.Applications.Subscriptions Namespace


SubscriptionRenewal.GetPurchaseOrderPaymentTypeID Method

This function returns the Payment Type ID that will be used on the renewal subscriptions. By default, this function returns the ID from the spGetPurchaseOrderPayTypeID stored procedure. Override this method to alter the Payment Type ID that is used for the renewal orders that are created by the subscription renewal process.

protected virtual long GetPurchaseOrderPaymentTypeID();

Return Value

A valid ID from the Payment Types entity for Purchase Orders, if multiple Payment Types exist that have PO as type, the lowest ID value is returned

Remarks

See Also

SubscriptionRenewal Class | Aptify.Applications.Subscriptions Namespace


SubscriptionRenewal.GetRenewalOrderSourceID Method

This function returns the Order Source ID that will be used on the renewal subscriptions. By default, this function returns the lowest Order Source in the system. Override this method to alter the Order Source ID that is used for the renewal orders that are created by the subscription renewal process.

protected virtual long GetRenewalOrderSourceID();

Return Value

A valid ID from the Order Sources entity

Remarks

See Also

SubscriptionRenewal Class | Aptify.Applications.Subscriptions Namespace


SubscriptionRenewal.GetRenewalOrderStatusID Method

This function returns the Order Status ID that will be used on the renewal subscriptions. By default, this function returns the ID for the Taken Order Status Type. Override this method to alter the Order Status ID that is used for the renewal orders that are created by the subscription renewal process. If you are using the default logic and are setting the Order Type to Quotation, this is the only valid Order Status that can be set. However, in the event that Orders are being set to an Order Type of Regular Order, it maybe desirable to set the Status to Shipped immediately upon the renewal process occuring. Review the Aptify product documentation for details on the Order Status types of Taken and Shipped for more details on how this process can be implemented.

protected virtual long GetRenewalOrderStatusID();

Return Value

A valid ID from the Order Status entity

Remarks

See Also

SubscriptionRenewal Class | Aptify.Applications.Subscriptions Namespace


SubscriptionRenewal.GetRenewalOrderTypeID Method

This function returns the Order Type ID that will be used on the renewal subscriptions. By default, this function returns 4, which corresponds to the Quotation Order Type(Pro Forma). Override this method to alter the Order Type ID that is used for the renewal orders that are created by the subscription renewal process. For example, if it is desired to have the Renewals immediately become regular orders, this function can be overriden to return the appropriate Order Type ID for Regular Orders

protected virtual long GetRenewalOrderTypeID();

Return Value

A valid ID from the Order Types entity

Remarks

See Also

SubscriptionRenewal Class | Aptify.Applications.Subscriptions Namespace


SubscriptionRenewal.GetRenewalSelectClause Method

This function is responsiable for returning the SELECT clause for the Renewal SQL Statement. By Default it returns ID, ProductID, SubscriberID, Quantity, ShipToID, SubscriberCompanyID, NumCopies (from most recent renewal), and SubscriberDefaultCurrencyTypeID. If you would like to get more information back for the process while overriding one of the other functions in this object in a sub-class, override this method and add additional fields to the SELECT clause. DO NOT REMOVE the existing fields from this select clause as doing so will break the functionality of the base class as other functions assume those fields exist in the data-table/data-row returned by this SQL statement

protected virtual string GetRenewalSelectClause();

Return Value

Valid SQL SELECT Clause (including the keyword SELECT prefixing the clause itself)

Remarks

See Also

SubscriptionRenewal Class | Aptify.Applications.Subscriptions Namespace


SubscriptionRenewal.GetRenewalSQL Method

This function returns the SQL statement that is used to create the list of subscriptions that need to be renewed.

protected virtual string GetRenewalSQL(
Int64 ViewID,
Object[] SelectedItems,
ref Boolean& IsPromptedView
);

Parameters

ViewID
The View ID to base the renewal query on
SelectedItems
An optional list of subscription ID values that should be used to return the list of subscriptions to renew
IsPromptedView
OUT Parameter: The function sets this value to true if this is a prompted view, false otherwise

Return Value

SQL statement to be executed by the object to get the list of subscriptions to be renewed

Remarks

See Also

SubscriptionRenewal Class | Aptify.Applications.Subscriptions Namespace


SubscriptionRenewal.GetScalarLong Method

Returns a scalar long value from a SQL statement, assumes SQL statement will produce a single value in a single row

protected virtual long GetScalarLong(
String SQL,
IAptifyDataAction.DSLCacheSetting CacheSetting,
Int64 DefaultValue
);

Parameters

SQL
SQL Statement to Execute
CacheSetting
Cache Setting To Use
DefaultValue
Default Value to Return if Query Fails or Returns No Value

Return Value

Remarks

See Also

SubscriptionRenewal Class | Aptify.Applications.Subscriptions Namespace


SubscriptionRenewal.OnAskUserForDueDate Method

Ask the user for the due date to use for the subscriptions that are being renewed. This function is only called if the CreateRenewalInvoices() function is called with ShowGUI set to True. If ShowGUI is set to false, then this function is never called and GetDefaultDueDate() is called.

protected virtual DateTime OnAskUserForDueDate(
DateTime DefaultDueDate
);

Parameters

DefaultDueDate
Default Due Date to use for prompting the user. This parameter is passed on based on the result of the GetDefaultDueDate() method

Return Value

The Due Date selected by the user. If the user cancels the operation this function throws an exception

Remarks

See Also

SubscriptionRenewal Class | Aptify.Applications.Subscriptions Namespace


SubscriptionRenewal.OnAskUserToRenew Method

This overridable function is reponsible for asking the user if it is okay to renew the subscriptions. This function is only called by CreateRenewalInvoices() if the ShowGUI parameter is passed into CreateRenewalInvoices as TRUE. If ShowGUI is set to False, this function is never called. Override this function to alter the behavior of the user interfaction for asking for the OK to renew the subscriptions.

protected virtual bool OnAskUserToRenew(
Int32 SubscriptionCount
);

Parameters

SubscriptionCount
The count of the number of subscriptions to be renewed by the renewal process

Return Value

Remarks

See Also

SubscriptionRenewal Class | Aptify.Applications.Subscriptions Namespace


SubscriptionRenewal.OnCanProcessByCancelledByUser Method

This function is responsible for determining if the process can be cancelled by a user. This function is only called when ShowGUI is set to True when calling the CreateRenewalInvoices() function. The default return value for this function is True

protected virtual bool OnCanProcessByCancelledByUser();

Return Value

Remarks

See Also

SubscriptionRenewal Class | Aptify.Applications.Subscriptions Namespace


SubscriptionRenewal.OnHideStatusForm Method

This function is responsible for hiding the status form and is only called by the CreateRenewalInvoices function when the ShowGUI parameter is passed in as true. If the ShowGUI parameter is False in the CreateRenewalInvoices function, this method is never called. Override this method in a sub-class to alter the handling of the Status Form

protected virtual void OnHideStatusForm();

Remarks

See Also

SubscriptionRenewal Class | Aptify.Applications.Subscriptions Namespace


SubscriptionRenewal.OnNotifyUserOfNoSubscriptionsToRenew Method

This function is responsible for notifying the user that there are no subscriptions to renew in the provided view/selection list. The default implementation simply display a message box with that notification. This function is only called if the CreateRenewalInvoices() method is called with ShowGUI set to True

protected virtual void OnNotifyUserOfNoSubscriptionsToRenew();

Remarks

See Also

SubscriptionRenewal Class | Aptify.Applications.Subscriptions Namespace


SubscriptionRenewal.OnNotifyUserOfProcessCancellation Method

This function is responsible for notifying the user that the renewal process was cancelled. The default implementation simply display a message box with that notification. This function is only called if the CreateRenewalInvoices() method is called with ShowGUI set to True

protected virtual void OnNotifyUserOfProcessCancellation(
Int32 NumberOfRenewalsCreated
);

Remarks

See Also

SubscriptionRenewal Class | Aptify.Applications.Subscriptions Namespace


SubscriptionRenewal.OnNotifyUserOfProcessCompletion Method

This function is responsible for notifying the user that the renewal process was completed succesfully. The default implementation simply display a message box with that notification. This function is only called if the CreateRenewalInvoices() method is called with ShowGUI set to True

protected virtual void OnNotifyUserOfProcessCompletion();

Remarks

See Also

SubscriptionRenewal Class | Aptify.Applications.Subscriptions Namespace


SubscriptionRenewal.OnSaveOrder Method

This method is called whenever the process deteremines that it needs to save an order. Override it when it is necessary to add pre/post logic to the Order Save or alter the Order.Save logic itself

protected virtual bool OnSaveOrder(
AptifyGenericEntityBase OrderGE,
Boolean ShowGUI
);

Parameters

OrderGE
Aptify Generic Entity Base Object for the Order to be saved
ShowGUI
Show the GUI if needed if this is set to True, if set to False

Return Value

True if the order is saved correctly, false otherwise

Remarks

See Also

SubscriptionRenewal Class | Aptify.Applications.Subscriptions Namespace


SubscriptionRenewal.OnSetStatusFormPercentComplete Method

This function is responsible for updating the percent complete on the status form being shown. This function is only called by the renewal process if the ShowGUI parameter passed into the CreateRenewalInvoices() method is set to True

protected virtual void OnSetStatusFormPercentComplete(
Int32 PercentComplete
);

Parameters

PercentComplete
Value from 0 to 100

Remarks

See Also

SubscriptionRenewal Class | Aptify.Applications.Subscriptions Namespace


SubscriptionRenewal.OnSetStatusFormText Method

This function is responsible for setting the text for the caption/title box of the Subscription Status Form. This function should only be called if the ShowGUI parameter is set to True (for the CreateRenewalInvoices() function)

protected virtual void OnSetStatusFormText(
String StatusText
);

Parameters

StatusText
Text to set the Caption of the Status Form to

Remarks

See Also

SubscriptionRenewal Class | Aptify.Applications.Subscriptions Namespace


SubscriptionRenewal.OnSetupOrderHeader Method

This function is called whenever a new order is needed in the CreateRenewalInvoices() process. The standard logic in the base class is to call this for each distinct SubscriberID so that multiple subscriptions for the same subscriber are grouped on the same order.

protected virtual OrdersEntity OnSetupOrderHeader(
DataRow dr,
DateTime DueDate,
Int64 SubscriberID,
Int64 EmployeeID,
Int64 PayTypeID,
Int64 ShipTypeID,
Int64 OrderTypeID,
Int64 OrderSourceID,
Int64 OrderStatusID
);

Parameters

dr
This is a DataRow object containing information about the Subscription that is being renewed. This data is used to create the order object and its Order Master/Header information
DueDate
Due date to use for the order
SubscriberID
The Subscriber ID for the subscription
EmployeeID
Employee ID to use for the Taken By (Orders.EmployeeID) field
PayTypeID
Payment Type to use
ShipTypeID
Shipment Type to use
OrderTypeID
Order Type to use
OrderSourceID
Order Source to use
OrderStatusID
Order Status to use

Return Value

A valid AptifyGenericEntityBase(or derived) object for an Order

Remarks

See Also

SubscriptionRenewal Class | Aptify.Applications.Subscriptions Namespace


SubscriptionRenewal.OnShouldProcessBeCancelled Method

This function is responsible for telling the process if the user cancelled the process (or if the process should be cancelled for any other reason). The user interface aspect of this function should only be tested if the ShowGUI paramter is passed in as true, otherwise this process is running without a user interface and no form should be displayed or tested for values

protected virtual bool OnShouldProcessBeCancelled(
Boolean ShowGUI
);

Return Value

True if the process should be cancelled, False otherwise

Remarks

See Also

SubscriptionRenewal Class | Aptify.Applications.Subscriptions Namespace


SubscriptionRenewal.OnShowStatusForm Method

This function is responsible for showing the status form and is only called by the CreateRenewalInvoices function when the ShowGUI parameter is passed in as true. If the ShowGUI parameter is False in the CreateRenewalInvoices function, this method is never called. Override this method in a sub-class to alter the handling of the Status Form

protected virtual void OnShowStatusForm(
String StatusFormCaption
);

Parameters

StatusFormCaption

Remarks

See Also

SubscriptionRenewal Class | Aptify.Applications.Subscriptions Namespace


SubscriptionRenewal.ParseString Method

public void ParseString(
String sStr,
String sDelim,
String[] sArr
);

See Also

SubscriptionRenewal Class | Aptify.Applications.Subscriptions Namespace


SubscriptionRenewal.RenewSingleSubscription Method

This method is responsible for renewing each individual subscription within the process of renewing a group of subscriptions. Override this function if the entire process of renewing a single subscription needs to be altered or pre/post processed.

protected virtual void RenewSingleSubscription(
DataRow dr,
OrdersEntity OrderGE,
Int64 SubscriberID,
Boolean ShowGUI
);

Parameters

dr
The data row containing information about the single subscription to be renewed The columns that exist within the DataRow passed in include ProductID, ID of the Subscription,
OrderGE
Use this Order GE object to create a line item for the subscription renewal, the Order GE is created by the calling function and is either a single order per subscription, or groups subscriptions by the Bill To/Subscriber ID
SubscriberID
The SubscriberID for the subscription to be created
ShowGUI
True if any GUI elements be shown to the user, False otherwise

Remarks

See Also

SubscriptionRenewal Class | Aptify.Applications.Subscriptions Namespace


SubscriptionRenewal.Run Method

public virtual string Run();

Implements

IProcessComponent.

See Also

SubscriptionRenewal Class | Aptify.Applications.Subscriptions Namespace


SubscriptionRenewal Events

The events of the SubscriptionRenewal class are listed below. For a complete list of SubscriptionRenewal class members, see the SubscriptionRenewal Members topic.

Public Instance Events

AfterAttach
AfterConfig
AfterExecute
BeforeAttach
BeforeConfig
BeforeExecute

See Also

SubscriptionRenewal Class | Aptify.Applications.Subscriptions Namespace


SubscriptionRenewal.IAptifyViewExtension.AfterAttachEventHandler Event

public event IAptifyViewExtension.AfterAttachEventHandler AfterAttach;

Implements

IAptifyViewExtension.

See Also

SubscriptionRenewal Class | Aptify.Applications.Subscriptions Namespace


SubscriptionRenewal.IAptifyViewExtension.AfterConfigEventHandler Event

public event IAptifyViewExtension.AfterConfigEventHandler AfterConfig;

Implements

IAptifyViewExtension.

See Also

SubscriptionRenewal Class | Aptify.Applications.Subscriptions Namespace


SubscriptionRenewal.IAptifyViewExtension.AfterExecuteEventHandler Event

public event IAptifyViewExtension.AfterExecuteEventHandler AfterExecute;

Implements

IAptifyViewExtension.

See Also

SubscriptionRenewal Class | Aptify.Applications.Subscriptions Namespace


SubscriptionRenewal.IAptifyViewExtension.BeforeAttachEventHandler Event

public event IAptifyViewExtension.BeforeAttachEventHandler BeforeAttach;

Implements

IAptifyViewExtension.

See Also

SubscriptionRenewal Class | Aptify.Applications.Subscriptions Namespace


SubscriptionRenewal.IAptifyViewExtension.BeforeConfigEventHandler Event

public event IAptifyViewExtension.BeforeConfigEventHandler BeforeConfig;

Implements

IAptifyViewExtension.

See Also

SubscriptionRenewal Class | Aptify.Applications.Subscriptions Namespace


SubscriptionRenewal.IAptifyViewExtension.BeforeExecuteEventHandler Event

public event IAptifyViewExtension.BeforeExecuteEventHandler BeforeExecute;

Implements

IAptifyViewExtension.

See Also

SubscriptionRenewal Class | Aptify.Applications.Subscriptions Namespace


SubscriptionRenewalStatus Class

For a list of all members of this type, see SubscriptionRenewalStatus Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
SubscriptionRenewalStatus

public class SubscriptionRenewalStatus : Form

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Subscriptions

Assembly: SubscriptionRenewal (in SubscriptionRenewal.dll)

See Also

SubscriptionRenewalStatus Members | Aptify.Applications.Subscriptions Namespace


SubscriptionRenewalStatus Members

SubscriptionRenewalStatus overview

Public Instance Constructors

SubscriptionRenewalStatus Constructor Initializes a new instance of the SubscriptionRenewalStatus class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CancelButtonVisible |
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UserCancelled |
UserCredentials |
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DoLocalization |
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

SubscriptionRenewalStatus Class | Aptify.Applications.Subscriptions Namespace


SubscriptionRenewalStatus Constructor

Initializes a new instance of the SubscriptionRenewalStatus class.

public SubscriptionRenewalStatus();

See Also

SubscriptionRenewalStatus Class | Aptify.Applications.Subscriptions Namespace


SubscriptionRenewalStatus Properties

The properties of the SubscriptionRenewalStatus class are listed below. For a complete list of SubscriptionRenewalStatus class members, see the SubscriptionRenewalStatus Members topic.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CancelButtonVisible |
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UserCancelled |
UserCredentials |
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

SubscriptionRenewalStatus Class | Aptify.Applications.Subscriptions Namespace


CancelButtonVisible Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionRenewalStatus.CancelButtonVisible Property

public Boolean CancelButtonVisible {get; set;}

See Also

SubscriptionRenewalStatus Class | Aptify.Applications.Subscriptions Namespace


UserCancelled Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionRenewalStatus.UserCancelled Property

public Boolean UserCancelled {get;}

See Also

SubscriptionRenewalStatus Class | Aptify.Applications.Subscriptions Namespace


UserCredentials Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionRenewalStatus.UserCredentials Property

public UserCredentials UserCredentials {get; set;}

See Also

SubscriptionRenewalStatus Class | Aptify.Applications.Subscriptions Namespace


SubscriptionRenewalStatus Methods

The methods of the SubscriptionRenewalStatus class are listed below. For a complete list of SubscriptionRenewalStatus class members, see the SubscriptionRenewalStatus Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DoLocalization |
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

SubscriptionRenewalStatus Class | Aptify.Applications.Subscriptions Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

SubscriptionRenewalStatus.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

SubscriptionRenewalStatus Class | Aptify.Applications.Subscriptions Namespace


SubscriptionRenewalStatus.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

SubscriptionRenewalStatus Class | Aptify.Applications.Subscriptions Namespace | SubscriptionRenewalStatus.Dispose Overload List


SubscriptionRenewalStatus.DoLocalization Method

public void DoLocalization();

See Also

SubscriptionRenewalStatus Class | Aptify.Applications.Subscriptions Namespace


Aptify.Applications.Subscriptions.WindowsControls

Aptify 5.0 Software Development Kit (SDK)

Aptify.Applications.Subscriptions.WindowsControls Namespace

This namespace contains an object that defines the appearance of the Subscriptions entity's form template.

Namespace hierarchy

Classes

Class | Description
SubscriptionFulfillmentOutput | Provides presentation layer functionality for Subscription Fulfillment output tab.
SubscriptionFulfillmentRecipients | Provides presentation layer functionality for Subscription Fulfillment recipients tab.
SubscriptionFulfillmentsLayout |
SubscriptionLayout | Provides presentation layer logic used for Subscriptions Entity Top-Level records
SubsFulfillBase | Base class for all subscription fulfillment UI controls


SubscriptionFulfillmentOutput Class

Provides presentation layer functionality for Subscription Fulfillment output tab.

For a list of all members of this type, see SubscriptionFulfillmentOutput Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
SubsFulfillBase
SubscriptionFulfillmentOutput

public class SubscriptionFulfillmentOutput : SubsFulfillBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Subscriptions.WindowsControls

Assembly: SubscriptionFulfillmentControls (in SubscriptionFulfillmentControls.dll)

See Also

SubscriptionFulfillmentOutput Members | Aptify.Applications.Subscriptions.WindowsControls Namespace


SubscriptionFulfillmentOutput Members

SubscriptionFulfillmentOutput overview

Public Instance Constructors

SubscriptionFulfillmentOutput Constructor Initializes a new instance of the SubscriptionFulfillmentOutput class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormComponent) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
Database (inherited from SubsFulfillBase) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateContext (inherited from FormComponent) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
m_oSubsFulfill (inherited from SubsFulfillBase) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
SubscriptionFulfillmentsEntity (inherited from SubsFulfillBase) |
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
DoCopyToClipboard | This method is responsible for copying the data from the email and fax areas of this fulfillment to the clipboard
DoEmailOutput | This method is responsible for outputing the information for email recipients to a file.
DoFaxOutput | This method is responsible for outputing the information for email recipients to a file.
DoSubcriptionFulfillmentReport | This method is responsible for running the subscription fulfillment report for the specified Subscription Fulfillment record.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
Initialize (inherited from SubsFulfillBase) |
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
On_EmailFile_Click | This method handles the button click event for the email output text box file selection button
On_FaxFile_Click | This method handles the button click event for the fax output text box file selection button
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from SubsFulfillBase) |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormComponent) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSubscriptionFulfillmentProgressUpdate (inherited from SubsFulfillBase) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormComponent) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

SubscriptionFulfillmentOutput Class | Aptify.Applications.Subscriptions.WindowsControls Namespace


SubscriptionFulfillmentOutput Constructor

Initializes a new instance of the SubscriptionFulfillmentOutput class.

public SubscriptionFulfillmentOutput();

See Also

SubscriptionFulfillmentOutput Class | Aptify.Applications.Subscriptions.WindowsControls Namespace


SubscriptionFulfillmentOutput Methods

The methods of the SubscriptionFulfillmentOutput class are listed below. For a complete list of SubscriptionFulfillmentOutput class members, see the SubscriptionFulfillmentOutput Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormComponent) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
DoCopyToClipboard | This method is responsible for copying the data from the email and fax areas of this fulfillment to the clipboard
DoEmailOutput | This method is responsible for outputing the information for email recipients to a file.
DoFaxOutput | This method is responsible for outputing the information for email recipients to a file.
DoSubcriptionFulfillmentReport | This method is responsible for running the subscription fulfillment report for the specified Subscription Fulfillment record.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
Initialize (inherited from SubsFulfillBase) |
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
On_EmailFile_Click | This method handles the button click event for the email output text box file selection button
On_FaxFile_Click | This method handles the button click event for the fax output text box file selection button
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from SubsFulfillBase) |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormComponent) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSubscriptionFulfillmentProgressUpdate (inherited from SubsFulfillBase) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormComponent) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

SubscriptionFulfillmentOutput Class | Aptify.Applications.Subscriptions.WindowsControls Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

SubscriptionFulfillmentOutput.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

SubscriptionFulfillmentOutput Class | Aptify.Applications.Subscriptions.WindowsControls Namespace


SubscriptionFulfillmentOutput.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

SubscriptionFulfillmentOutput Class | Aptify.Applications.Subscriptions.WindowsControls Namespace | SubscriptionFulfillmentOutput.Dispose Overload List


SubscriptionFulfillmentOutput.DoCopyToClipboard Method

This method is responsible for copying the data from the email and fax areas of this fulfillment to the clipboard

protected virtual void DoCopyToClipboard();

Remarks

See Also

SubscriptionFulfillmentOutput Class | Aptify.Applications.Subscriptions.WindowsControls Namespace


SubscriptionFulfillmentOutput.DoEmailOutput Method

This method is responsible for outputing the information for email recipients to a file.

protected virtual bool DoEmailOutput(
Boolean AllowGUI
);

Parameters

AllowGUI
If this parameter is set to True, the method displays a message based on success or failure.

Remarks

See Also

SubscriptionFulfillmentOutput Class | Aptify.Applications.Subscriptions.WindowsControls Namespace


SubscriptionFulfillmentOutput.DoFaxOutput Method

This method is responsible for outputing the information for email recipients to a file.

protected virtual bool DoFaxOutput(
Boolean AllowGUI
);

Parameters

AllowGUI
If this parameter is set to True, the method displays a message based on success or failure.

Remarks

See Also

SubscriptionFulfillmentOutput Class | Aptify.Applications.Subscriptions.WindowsControls Namespace


SubscriptionFulfillmentOutput.DoSubcriptionFulfillmentReport Method

This method is responsible for running the subscription fulfillment report for the specified Subscription Fulfillment record.

protected virtual void DoSubcriptionFulfillmentReport(
Int64 SubscriptionFulfillmentID
);

Parameters

SubscriptionFulfillmentID

Remarks

See Also

SubscriptionFulfillmentOutput Class | Aptify.Applications.Subscriptions.WindowsControls Namespace


SubscriptionFulfillmentOutput.On_EmailFile_Click Method

This method handles the button click event for the email output text box file selection button

protected virtual void On_EmailFile_Click(
Object sender,
EventArgs e
);

Parameters

sender
e

Remarks

See Also

SubscriptionFulfillmentOutput Class | Aptify.Applications.Subscriptions.WindowsControls Namespace


SubscriptionFulfillmentOutput.On_FaxFile_Click Method

This method handles the button click event for the fax output text box file selection button

protected virtual void On_FaxFile_Click(
Object sender,
EventArgs e
);

Parameters

sender
e

Remarks

See Also

SubscriptionFulfillmentOutput Class | Aptify.Applications.Subscriptions.WindowsControls Namespace


SubscriptionFulfillmentOutput.OnRefresh Method

protected override void OnRefresh();

Implements

IFormComponent.

See Also

SubscriptionFulfillmentOutput Class | Aptify.Applications.Subscriptions.WindowsControls Namespace


SubscriptionFulfillmentRecipients Class

Provides presentation layer functionality for Subscription Fulfillment recipients tab.

For a list of all members of this type, see SubscriptionFulfillmentRecipients Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
SubsFulfillBase
SubscriptionFulfillmentRecipients

public class SubscriptionFulfillmentRecipients : SubsFulfillBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Subscriptions.WindowsControls

Assembly: SubscriptionFulfillmentControls (in SubscriptionFulfillmentControls.dll)

See Also

SubscriptionFulfillmentRecipients Members | Aptify.Applications.Subscriptions.WindowsControls Namespace


SubscriptionFulfillmentRecipients Members

SubscriptionFulfillmentRecipients overview

Public Instance Constructors

SubscriptionFulfillmentRecipients Constructor Initializes a new instance of the SubscriptionFulfillmentRecipients class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormComponent) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
Database (inherited from SubsFulfillBase) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateContext (inherited from FormComponent) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
m_oSubsFulfill (inherited from SubsFulfillBase) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
SubscriptionFulfillmentsEntity (inherited from SubsFulfillBase) |
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
ApplySkin |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormComponent) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
Initialize |
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormComponent) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSubscriptionFulfillmentProgressUpdate |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormComponent) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

SubscriptionFulfillmentRecipients Class | Aptify.Applications.Subscriptions.WindowsControls Namespace


SubscriptionFulfillmentRecipients Constructor

Initializes a new instance of the SubscriptionFulfillmentRecipients class.

public SubscriptionFulfillmentRecipients();

See Also

SubscriptionFulfillmentRecipients Class | Aptify.Applications.Subscriptions.WindowsControls Namespace


SubscriptionFulfillmentRecipients Methods

The methods of the SubscriptionFulfillmentRecipients class are listed below. For a complete list of SubscriptionFulfillmentRecipients class members, see the SubscriptionFulfillmentRecipients Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormComponent) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
ApplySkin |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormComponent) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
Initialize |
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormComponent) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSubscriptionFulfillmentProgressUpdate |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormComponent) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

SubscriptionFulfillmentRecipients Class | Aptify.Applications.Subscriptions.WindowsControls Namespace


SubscriptionFulfillmentRecipients.ApplySkin Method

protected virtual void ApplySkin();

See Also

SubscriptionFulfillmentRecipients Class | Aptify.Applications.Subscriptions.WindowsControls Namespace


SubscriptionFulfillmentRecipients.Initialize Method

protected override void Initialize();

See Also

SubscriptionFulfillmentRecipients Class | Aptify.Applications.Subscriptions.WindowsControls Namespace


SubscriptionFulfillmentRecipients.OnFormComponentConfig Method

protected override void OnFormComponentConfig(
AptifyFormTemplateContext FormTemplateContext
);

Implements

IFormComponent.

See Also

SubscriptionFulfillmentRecipients Class | Aptify.Applications.Subscriptions.WindowsControls Namespace


SubscriptionFulfillmentRecipients.OnRefresh Method

protected override void OnRefresh();

Implements

IFormComponent.

See Also

SubscriptionFulfillmentRecipients Class | Aptify.Applications.Subscriptions.WindowsControls Namespace


SubscriptionFulfillmentRecipients.OnSubscriptionFulfillmentProgressUpdate Method

protected override void OnSubscriptionFulfillmentProgressUpdate(
Int32 CurrentPercent,
Int32 PercentChanged
);

See Also

SubscriptionFulfillmentRecipients Class | Aptify.Applications.Subscriptions.WindowsControls Namespace


SubscriptionFulfillmentsLayout Class

For a list of all members of this type, see SubscriptionFulfillmentsLayout Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
SubscriptionFulfillmentsLayout

public class SubscriptionFulfillmentsLayout : FormTemplateLayout

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Subscriptions.WindowsControls

Assembly: SubscriptionFulfillmentControls (in SubscriptionFulfillmentControls.dll)

See Also

SubscriptionFulfillmentsLayout Members | Aptify.Applications.Subscriptions.WindowsControls Namespace


SubscriptionFulfillmentsLayout Members

SubscriptionFulfillmentsLayout overview

Public Instance Constructors

SubscriptionFulfillmentsLayout Constructor Initializes a new instance of the SubscriptionFulfillmentsLayout class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControls |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
Initialize |
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig |
OnFormTemplateLoaded |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

SubscriptionFulfillmentsLayout Class | Aptify.Applications.Subscriptions.WindowsControls Namespace


SubscriptionFulfillmentsLayout Constructor

Initializes a new instance of the SubscriptionFulfillmentsLayout class.

public SubscriptionFulfillmentsLayout();

See Also

SubscriptionFulfillmentsLayout Class | Aptify.Applications.Subscriptions.WindowsControls Namespace


SubscriptionFulfillmentsLayout Methods

The methods of the SubscriptionFulfillmentsLayout class are listed below. For a complete list of SubscriptionFulfillmentsLayout class members, see the SubscriptionFulfillmentsLayout Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControls |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
Initialize |
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig |
OnFormTemplateLoaded |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

SubscriptionFulfillmentsLayout Class | Aptify.Applications.Subscriptions.WindowsControls Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

SubscriptionFulfillmentsLayout.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

SubscriptionFulfillmentsLayout Class | Aptify.Applications.Subscriptions.WindowsControls Namespace


SubscriptionFulfillmentsLayout.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

SubscriptionFulfillmentsLayout Class | Aptify.Applications.Subscriptions.WindowsControls Namespace | SubscriptionFulfillmentsLayout.Dispose Overload List


SubscriptionFulfillmentsLayout.FindControls Method

protected virtual void FindControls();

See Also

SubscriptionFulfillmentsLayout Class | Aptify.Applications.Subscriptions.WindowsControls Namespace


SubscriptionFulfillmentsLayout.Initialize Method

protected virtual void Initialize();

See Also

SubscriptionFulfillmentsLayout Class | Aptify.Applications.Subscriptions.WindowsControls Namespace


SubscriptionFulfillmentsLayout.OnFormComponentConfig Method

protected override void OnFormComponentConfig(
AptifyFormTemplateContext Context
);

Implements

IFormComponent.

See Also

SubscriptionFulfillmentsLayout Class | Aptify.Applications.Subscriptions.WindowsControls Namespace


SubscriptionFulfillmentsLayout.OnFormTemplateLoaded Method

protected override void OnFormTemplateLoaded(
FormTemplateLayout.FormTemplateLoadedEventArgs e
);

See Also

SubscriptionFulfillmentsLayout Class | Aptify.Applications.Subscriptions.WindowsControls Namespace


SubscriptionFulfillmentsLayout.OnRefresh Method

protected override void OnRefresh();

Implements

IFormComponent.

See Also

SubscriptionFulfillmentsLayout Class | Aptify.Applications.Subscriptions.WindowsControls Namespace


SubscriptionLayout Class

Provides presentation layer logic used for Subscriptions Entity Top-Level records

For a list of all members of this type, see SubscriptionLayout Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
SubscriptionLayout

public class SubscriptionLayout : FormTemplateLayout

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Subscriptions.WindowsControls

Assembly: SubscriptionLayoutControls (in SubscriptionLayoutControls.dll)

See Also

SubscriptionLayout Members | Aptify.Applications.Subscriptions.WindowsControls Namespace


SubscriptionLayout Members

SubscriptionLayout overview

Public Instance Constructors

SubscriptionLayout Constructor Initializes a new instance of the SubscriptionLayout class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveStatusID | This property returns the status ID that represents an Active subscription. The default behavior in the base class is to return the value of 1.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelledStatusID | This property returns the status ID that represents a Cancelled subscription. The default behavior in the base class is to return the value of 2.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
ExpiredStatusID | This property returns the status ID that represents an Expired Subscription. The default behavior in the base class is to return the value of 3.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
NotCancelledCancelReasonID | This method is responsible for returning the value in the Cancellation Reasons entiyt that corresponds to "Not Cancelled". The default behavior in the base class is to return the value of 1.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
m_ctlAutoRenew |
m_ctlAutoRenewStandingOrderID |
m_ctlCancelReasonID |
m_ctlQuantity |
m_ctlStatus |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
BindControl | This method handles binding a control reference to a specific field name using the GetFormComponent() method of the base class. The method only attempts to bind the control reference if the control reference is Nothing or its inner control is disposed.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormTemplateLayout) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControls | This method handles binding the controls to their internal protected members.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetDefaultCancellationReason | This method is responsible for returning the "Default" cancellation reason to be used when cancelling a subscription. The default behavior in the base class attempts to find a subscription cancellation reason record in the Subscription Cancellation Reasons entity that matches the Name='Other'. If nothing is found, the minimum value in the Subscription Cancellation Reasons entity is returned.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
On_AutoRenew_ValueChanged | This method is responsible for handing the ValueChanged event in the Auto Renew control and disables/enables the AutoRenewStandingOrderID control so that it is only available if Auto Renew is turned on.
On_Status_ValueChanged | This method is responsible for responding to the ValueChanged event in the Status control on the layout and validates the user input.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded | Contains logic to setup Event handlers for controls on the FormTemplate Layout.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStatusEnabled | This method is called when the form template loads and is responsible for setting the status field enabled attribute based on the existing status. The default behavior of this method is to check to see if the StatusID=3 (Expired) and if so, disable the status box since the user is not allowed to manually change the status of a subscription once it is set to Expired in the UI.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

SubscriptionLayout Class | Aptify.Applications.Subscriptions.WindowsControls Namespace


SubscriptionLayout Constructor

Initializes a new instance of the SubscriptionLayout class.

public SubscriptionLayout();

See Also

SubscriptionLayout Class | Aptify.Applications.Subscriptions.WindowsControls Namespace


SubscriptionLayout Properties

The properties of the SubscriptionLayout class are listed below. For a complete list of SubscriptionLayout class members, see the SubscriptionLayout Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveStatusID | This property returns the status ID that represents an Active subscription. The default behavior in the base class is to return the value of 1.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelledStatusID | This property returns the status ID that represents a Cancelled subscription. The default behavior in the base class is to return the value of 2.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
ExpiredStatusID | This property returns the status ID that represents an Expired Subscription. The default behavior in the base class is to return the value of 3.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
NotCancelledCancelReasonID | This method is responsible for returning the value in the Cancellation Reasons entiyt that corresponds to "Not Cancelled". The default behavior in the base class is to return the value of 1.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
m_ctlAutoRenew |
m_ctlAutoRenewStandingOrderID |
m_ctlCancelReasonID |
m_ctlQuantity |
m_ctlStatus |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

SubscriptionLayout Class | Aptify.Applications.Subscriptions.WindowsControls Namespace


ActiveStatusID Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionLayout.ActiveStatusID Property

This property returns the status ID that represents an Active subscription. The default behavior in the base class is to return the value of 1.

public virtual Int64 ActiveStatusID {get;}

Property Value

Remarks

See Also

SubscriptionLayout Class | Aptify.Applications.Subscriptions.WindowsControls Namespace


CancelledStatusID Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionLayout.CancelledStatusID Property

This property returns the status ID that represents a Cancelled subscription. The default behavior in the base class is to return the value of 2.

public virtual Int64 CancelledStatusID {get;}

Property Value

Remarks

See Also

SubscriptionLayout Class | Aptify.Applications.Subscriptions.WindowsControls Namespace


ExpiredStatusID Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionLayout.ExpiredStatusID Property

This property returns the status ID that represents an Expired Subscription. The default behavior in the base class is to return the value of 3.

public virtual Int64 ExpiredStatusID {get;}

Property Value

Remarks

See Also

SubscriptionLayout Class | Aptify.Applications.Subscriptions.WindowsControls Namespace


m_ctlAutoRenew Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionLayout.m_ctlAutoRenew Property

protected virtual IAptifyDataFieldControlBase m_ctlAutoRenew {get; set;}

See Also

SubscriptionLayout Class | Aptify.Applications.Subscriptions.WindowsControls Namespace


m_ctlAutoRenewStandingOrderID Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionLayout.m_ctlAutoRenewStandingOrderID Property

protected virtual IAptifyDataFieldControlBase m_ctlAutoRenewStandingOrderID {get; set;}

See Also

SubscriptionLayout Class | Aptify.Applications.Subscriptions.WindowsControls Namespace


m_ctlCancelReasonID Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionLayout.m_ctlCancelReasonID Property

protected virtual IAptifyDataFieldControlBase m_ctlCancelReasonID {get; set;}

See Also

SubscriptionLayout Class | Aptify.Applications.Subscriptions.WindowsControls Namespace


m_ctlQuantity Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionLayout.m_ctlQuantity Property

protected virtual IAptifyDataFieldControlBase m_ctlQuantity {get; set;}

See Also

SubscriptionLayout Class | Aptify.Applications.Subscriptions.WindowsControls Namespace


m_ctlStatus Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionLayout.m_ctlStatus Property

protected virtual IAptifyDataFieldControlBase m_ctlStatus {get; set;}

See Also

SubscriptionLayout Class | Aptify.Applications.Subscriptions.WindowsControls Namespace


NotCancelledCancelReasonID Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionLayout.NotCancelledCancelReasonID Property

This method is responsible for returning the value in the Cancellation Reasons entiyt that corresponds to "Not Cancelled". The default behavior in the base class is to return the value of 1.

public virtual Int64 NotCancelledCancelReasonID {get;}

Property Value

Remarks

See Also

SubscriptionLayout Class | Aptify.Applications.Subscriptions.WindowsControls Namespace


SubscriptionLayout Methods

The methods of the SubscriptionLayout class are listed below. For a complete list of SubscriptionLayout class members, see the SubscriptionLayout Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
BindControl | This method handles binding a control reference to a specific field name using the GetFormComponent() method of the base class. The method only attempts to bind the control reference if the control reference is Nothing or its inner control is disposed.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormTemplateLayout) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControls | This method handles binding the controls to their internal protected members.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetDefaultCancellationReason | This method is responsible for returning the "Default" cancellation reason to be used when cancelling a subscription. The default behavior in the base class attempts to find a subscription cancellation reason record in the Subscription Cancellation Reasons entity that matches the Name='Other'. If nothing is found, the minimum value in the Subscription Cancellation Reasons entity is returned.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
On_AutoRenew_ValueChanged | This method is responsible for handing the ValueChanged event in the Auto Renew control and disables/enables the AutoRenewStandingOrderID control so that it is only available if Auto Renew is turned on.
On_Status_ValueChanged | This method is responsible for responding to the ValueChanged event in the Status control on the layout and validates the user input.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded | Contains logic to setup Event handlers for controls on the FormTemplate Layout.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStatusEnabled | This method is called when the form template loads and is responsible for setting the status field enabled attribute based on the existing status. The default behavior of this method is to check to see if the StatusID=3 (Expired) and if so, disable the status box since the user is not allowed to manually change the status of a subscription once it is set to Expired in the UI.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

SubscriptionLayout Class | Aptify.Applications.Subscriptions.WindowsControls Namespace


SubscriptionLayout.BindControl Method

This method handles binding a control reference to a specific field name using the GetFormComponent() method of the base class. The method only attempts to bind the control reference if the control reference is Nothing or its inner control is disposed.

protected virtual void BindControl(
ref IAptifyDataFieldControlBase& control,
String FieldName
);

Parameters

control
FieldName

Remarks

See Also

SubscriptionLayout Class | Aptify.Applications.Subscriptions.WindowsControls Namespace


SubscriptionLayout.FindControls Method

This method handles binding the controls to their internal protected members.

protected virtual void FindControls();

Remarks

See Also

SubscriptionLayout Class | Aptify.Applications.Subscriptions.WindowsControls Namespace


SubscriptionLayout.GetDefaultCancellationReason Method

This method is responsible for returning the "Default" cancellation reason to be used when cancelling a subscription. The default behavior in the base class attempts to find a subscription cancellation reason record in the Subscription Cancellation Reasons entity that matches the Name='Other'. If nothing is found, the minimum value in the Subscription Cancellation Reasons entity is returned.

protected virtual long GetDefaultCancellationReason();

Return Value

Remarks

See Also

SubscriptionLayout Class | Aptify.Applications.Subscriptions.WindowsControls Namespace


SubscriptionLayout.On_AutoRenew_ValueChanged Method

This method is responsible for handing the ValueChanged event in the Auto Renew control and disables/enables the AutoRenewStandingOrderID control so that it is only available if Auto Renew is turned on.

protected virtual void On_AutoRenew_ValueChanged(
Object sender,
Object OldValue,
Object NewValue
);

Parameters

sender
OldValue
NewValue

Remarks

See Also

SubscriptionLayout Class | Aptify.Applications.Subscriptions.WindowsControls Namespace


SubscriptionLayout.On_Status_ValueChanged Method

This method is responsible for responding to the ValueChanged event in the Status control on the layout and validates the user input.

protected virtual void On_Status_ValueChanged(
Object sender,
Object OldValue,
Object NewValue
);

Parameters

sender
OldValue
NewValue

Remarks

See Also

SubscriptionLayout Class | Aptify.Applications.Subscriptions.WindowsControls Namespace


SubscriptionLayout.OnFormTemplateLoaded Method

Contains logic to setup Event handlers for controls on the FormTemplate Layout.

protected override void OnFormTemplateLoaded(
FormTemplateLayout.FormTemplateLoadedEventArgs e
);

Parameters

e

Remarks

See Also

SubscriptionLayout Class | Aptify.Applications.Subscriptions.WindowsControls Namespace


SubscriptionLayout.SetStatusEnabled Method

This method is called when the form template loads and is responsible for setting the status field enabled attribute based on the existing status. The default behavior of this method is to check to see if the StatusID=3 (Expired) and if so, disable the status box since the user is not allowed to manually change the status of a subscription once it is set to Expired in the UI.

protected virtual void SetStatusEnabled();

Remarks

See Also

SubscriptionLayout Class | Aptify.Applications.Subscriptions.WindowsControls Namespace


SubsFulfillBase Class

Base class for all subscription fulfillment UI controls

For a list of all members of this type, see SubsFulfillBase Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
SubsFulfillBase
SubscriptionFulfillmentOutput
SubscriptionFulfillmentRecipients

public class SubsFulfillBase : FormComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Subscriptions.WindowsControls

Assembly: SubscriptionFulfillmentControls (in SubscriptionFulfillmentControls.dll)

See Also

SubsFulfillBase Members | Aptify.Applications.Subscriptions.WindowsControls Namespace


SubsFulfillBase Members

SubsFulfillBase overview

Public Instance Constructors

SubsFulfillBase Constructor Initializes a new instance of the SubsFulfillBase class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormComponent) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
Database |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateContext (inherited from FormComponent) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
m_oSubsFulfill |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
SubscriptionFulfillmentsEntity |
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormComponent) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
Initialize |
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormComponent) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormComponent) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSubscriptionFulfillmentProgressUpdate |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormComponent) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

SubsFulfillBase Class | Aptify.Applications.Subscriptions.WindowsControls Namespace


SubsFulfillBase Constructor

Initializes a new instance of the SubsFulfillBase class.

public SubsFulfillBase();

See Also

SubsFulfillBase Class | Aptify.Applications.Subscriptions.WindowsControls Namespace


SubsFulfillBase Properties

The properties of the SubsFulfillBase class are listed below. For a complete list of SubsFulfillBase class members, see the SubsFulfillBase Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
Database |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateContext (inherited from FormComponent) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
m_oSubsFulfill |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
SubscriptionFulfillmentsEntity |
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

SubsFulfillBase Class | Aptify.Applications.Subscriptions.WindowsControls Namespace


Database Property

Aptify 5.0 Software Development Kit (SDK)

SubsFulfillBase.Database Property

protected virtual String Database {get;}

See Also

SubsFulfillBase Class | Aptify.Applications.Subscriptions.WindowsControls Namespace


m_oSubsFulfill Property

Aptify 5.0 Software Development Kit (SDK)

SubsFulfillBase.m_oSubsFulfill Property

protected virtual ISubscriptionFulfillment m_oSubsFulfill {get; set;}

See Also

SubsFulfillBase Class | Aptify.Applications.Subscriptions.WindowsControls Namespace


SubscriptionFulfillmentsEntity Property

Aptify 5.0 Software Development Kit (SDK)

SubsFulfillBase.SubscriptionFulfillmentsEntity Property

protected SubscriptionFulfillmentsEntity SubscriptionFulfillmentsEntity {get;}

See Also

SubsFulfillBase Class | Aptify.Applications.Subscriptions.WindowsControls Namespace


SubsFulfillBase Methods

The methods of the SubsFulfillBase class are listed below. For a complete list of SubsFulfillBase class members, see the SubsFulfillBase Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormComponent) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormComponent) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
Initialize |
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormComponent) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormComponent) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSubscriptionFulfillmentProgressUpdate |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormComponent) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

SubsFulfillBase Class | Aptify.Applications.Subscriptions.WindowsControls Namespace


SubsFulfillBase.Initialize Method

protected virtual void Initialize();

See Also

SubsFulfillBase Class | Aptify.Applications.Subscriptions.WindowsControls Namespace


SubsFulfillBase.OnFormComponentConfig Method

protected override void OnFormComponentConfig(
AptifyFormTemplateContext FormTemplateContext
);

Implements

IFormComponent.

See Also

SubsFulfillBase Class | Aptify.Applications.Subscriptions.WindowsControls Namespace


SubsFulfillBase.OnSubscriptionFulfillmentProgressUpdate Method

protected virtual void OnSubscriptionFulfillmentProgressUpdate(
Int32 CurrentPercent,
Int32 PercentChanged
);

See Also

SubsFulfillBase Class | Aptify.Applications.Subscriptions.WindowsControls Namespace


Aptify.Applications.Tasks

Aptify 5.0 Software Development Kit (SDK)

Aptify.Applications.Tasks Namespace

This namespace defines Aptify's Tasks managment functionality.

Namespace hierarchy

Classes

Class | Description
TaskLayout | Provides presentation layer logic used for Tasks Entity records
TasksEntity | Aptify Task GE Sub-Class Object - Implements Base Task Functionality including execution of process flows as required based on the Task Type. This class can be sub-classed to alter the base functionality of the Task Management system. Also consider implementing Process Flows that are bound to changes in Status in the Task Types entity(under the Task Type Actions sub-type) as that model is implemented in this base Task class already.
TaskTypeActionLayout |

Structures

Structure | Description
TasksEntity.StatusListItem |


TaskLayout Class

Provides presentation layer logic used for Tasks Entity records

For a list of all members of this type, see TaskLayout Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
TaskLayout

public class TaskLayout : FormTemplateLayout

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Tasks

Assembly: TaskLayoutControls (in TaskLayoutControls.dll)

See Also

TaskLayout Members | Aptify.Applications.Tasks Namespace


TaskLayout Members

TaskLayout overview

Public Instance Constructors

TaskLayout Constructor Initializes a new instance of the TaskLayout class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetCurrentStatus | This method returns the current status of the loaded task
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetTaskTypeID | This method returns the TypeID for the loaded task
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
IsTaskClosed | This method determines if the task is currently closed or not by determining, based on the Task Type, if the status currently selected is a status that is marked as Closed in the TaskTypePossibleStatus entity.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
m_ctlActualHours |
m_ctlActualHoursRollup |
m_ctlAssignedBy |
m_ctlAssignedTo |
m_ctlDateAssigned |
m_ctlDateCompleted |
m_ctlDateDue |
m_ctlDateStarted |
m_ctlEstHours |
m_ctlEstHoursRollup |
m_ctlPercentComplete |
m_ctlPriority |
m_ctlStatus |
m_ctlType |
m_oTask |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormTemplateLayout) | Overloaded. Releases all resources used by the Component.
EnableControl | This method does a check to see if the DataFieldControl parameter and its .Control member are not null (and the control is not disposed) and if so, enables or disables the control on the basis of the Enable parameter's value.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControls | This method handles binding the controls to their internal protected members.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
LinkExists | This method will determine if the specified EntityID/RecordID pair exists in the TaskLinks sub-type of the provided TaskGE instance.
LoadParams | This method is called whenever a form template is loaded and is responsible for handling any specialized loading process for form parameters. The default implementation of this method in the TaskLayout class parses the parameters and determines if any links have been requested for a new record and if any are found in the parameter list, they are added to the TaskLinks sub-type.
LoadStatusValues | This method loads the Status combo box with the relevant status types based on the Task Type selected The Status values are retrieved from the underlying Task GE object's StatusList property which can be refreshed using the Task object's LoadTaskTypeStatus method and passing in the task type.
m_ctlType_ValueChanged |
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded | Contains logic to setup Event handlers for controls on the FormTemplate Layout.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

TaskLayout Class | Aptify.Applications.Tasks Namespace


TaskLayout Constructor

Initializes a new instance of the TaskLayout class.

public TaskLayout();

See Also

TaskLayout Class | Aptify.Applications.Tasks Namespace


TaskLayout Properties

The properties of the TaskLayout class are listed below. For a complete list of TaskLayout class members, see the TaskLayout Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
m_ctlActualHours |
m_ctlActualHoursRollup |
m_ctlAssignedBy |
m_ctlAssignedTo |
m_ctlDateAssigned |
m_ctlDateCompleted |
m_ctlDateDue |
m_ctlDateStarted |
m_ctlEstHours |
m_ctlEstHoursRollup |
m_ctlPercentComplete |
m_ctlPriority |
m_ctlStatus |
m_ctlType |
m_oTask |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

TaskLayout Class | Aptify.Applications.Tasks Namespace


m_ctlActualHours Property

Aptify 5.0 Software Development Kit (SDK)

TaskLayout.m_ctlActualHours Property

protected virtual AptifyTextBox m_ctlActualHours {get; set;}

See Also

TaskLayout Class | Aptify.Applications.Tasks Namespace


m_ctlActualHoursRollup Property

Aptify 5.0 Software Development Kit (SDK)

TaskLayout.m_ctlActualHoursRollup Property

protected virtual AptifyTextBox m_ctlActualHoursRollup {get; set;}

See Also

TaskLayout Class | Aptify.Applications.Tasks Namespace


m_ctlAssignedBy Property

Aptify 5.0 Software Development Kit (SDK)

TaskLayout.m_ctlAssignedBy Property

protected virtual AptifyLinkBox m_ctlAssignedBy {get; set;}

See Also

TaskLayout Class | Aptify.Applications.Tasks Namespace


m_ctlAssignedTo Property

Aptify 5.0 Software Development Kit (SDK)

TaskLayout.m_ctlAssignedTo Property

protected virtual AptifyLinkBox m_ctlAssignedTo {get; set;}

See Also

TaskLayout Class | Aptify.Applications.Tasks Namespace


m_ctlDateAssigned Property

Aptify 5.0 Software Development Kit (SDK)

TaskLayout.m_ctlDateAssigned Property

protected virtual AptifyTextBox m_ctlDateAssigned {get; set;}

See Also

TaskLayout Class | Aptify.Applications.Tasks Namespace


m_ctlDateCompleted Property

Aptify 5.0 Software Development Kit (SDK)

TaskLayout.m_ctlDateCompleted Property

protected virtual AptifyTextBox m_ctlDateCompleted {get; set;}

See Also

TaskLayout Class | Aptify.Applications.Tasks Namespace


m_ctlDateDue Property

Aptify 5.0 Software Development Kit (SDK)

TaskLayout.m_ctlDateDue Property

protected virtual AptifyTextBox m_ctlDateDue {get; set;}

See Also

TaskLayout Class | Aptify.Applications.Tasks Namespace


m_ctlDateStarted Property

Aptify 5.0 Software Development Kit (SDK)

TaskLayout.m_ctlDateStarted Property

protected virtual AptifyTextBox m_ctlDateStarted {get; set;}

See Also

TaskLayout Class | Aptify.Applications.Tasks Namespace


m_ctlEstHours Property

Aptify 5.0 Software Development Kit (SDK)

TaskLayout.m_ctlEstHours Property

protected virtual AptifyTextBox m_ctlEstHours {get; set;}

See Also

TaskLayout Class | Aptify.Applications.Tasks Namespace


m_ctlEstHoursRollup Property

Aptify 5.0 Software Development Kit (SDK)

TaskLayout.m_ctlEstHoursRollup Property

protected virtual AptifyTextBox m_ctlEstHoursRollup {get; set;}

See Also

TaskLayout Class | Aptify.Applications.Tasks Namespace


m_ctlPercentComplete Property

Aptify 5.0 Software Development Kit (SDK)

TaskLayout.m_ctlPercentComplete Property

protected virtual AptifyTextBox m_ctlPercentComplete {get; set;}

See Also

TaskLayout Class | Aptify.Applications.Tasks Namespace


m_ctlPriority Property

Aptify 5.0 Software Development Kit (SDK)

TaskLayout.m_ctlPriority Property

protected virtual AptifyComboBox m_ctlPriority {get; set;}

See Also

TaskLayout Class | Aptify.Applications.Tasks Namespace


m_ctlStatus Property

Aptify 5.0 Software Development Kit (SDK)

TaskLayout.m_ctlStatus Property

protected virtual AptifyComboBox m_ctlStatus {get; set;}

See Also

TaskLayout Class | Aptify.Applications.Tasks Namespace


m_ctlType Property

Aptify 5.0 Software Development Kit (SDK)

TaskLayout.m_ctlType Property

protected virtual AptifyLinkBox m_ctlType {get; set;}

See Also

TaskLayout Class | Aptify.Applications.Tasks Namespace


m_oTask Property

Aptify 5.0 Software Development Kit (SDK)

TaskLayout.m_oTask Property

protected virtual TasksEntity m_oTask {get; set;}

See Also

TaskLayout Class | Aptify.Applications.Tasks Namespace


TaskLayout Methods

The methods of the TaskLayout class are listed below. For a complete list of TaskLayout class members, see the TaskLayout Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetCurrentStatus | This method returns the current status of the loaded task
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetTaskTypeID | This method returns the TypeID for the loaded task
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
IsTaskClosed | This method determines if the task is currently closed or not by determining, based on the Task Type, if the status currently selected is a status that is marked as Closed in the TaskTypePossibleStatus entity.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormTemplateLayout) | Overloaded. Releases all resources used by the Component.
EnableControl | This method does a check to see if the DataFieldControl parameter and its .Control member are not null (and the control is not disposed) and if so, enables or disables the control on the basis of the Enable parameter's value.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControls | This method handles binding the controls to their internal protected members.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
LinkExists | This method will determine if the specified EntityID/RecordID pair exists in the TaskLinks sub-type of the provided TaskGE instance.
LoadParams | This method is called whenever a form template is loaded and is responsible for handling any specialized loading process for form parameters. The default implementation of this method in the TaskLayout class parses the parameters and determines if any links have been requested for a new record and if any are found in the parameter list, they are added to the TaskLinks sub-type.
LoadStatusValues | This method loads the Status combo box with the relevant status types based on the Task Type selected The Status values are retrieved from the underlying Task GE object's StatusList property which can be refreshed using the Task object's LoadTaskTypeStatus method and passing in the task type.
m_ctlType_ValueChanged |
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded | Contains logic to setup Event handlers for controls on the FormTemplate Layout.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

TaskLayout Class | Aptify.Applications.Tasks Namespace


TaskLayout.EnableControl Method

This method does a check to see if the DataFieldControl parameter and its .Control member are not null (and the control is not disposed) and if so, enables or disables the control on the basis of the Enable parameter's value.

protected virtual void EnableControl(
AptifyControlBase DataFieldControl,
Boolean Enable
);

Parameters

DataFieldControl
The control who's Enabled property to set.
Enable
Whether the control should be enabled or disabled.

Remarks

See Also

TaskLayout Class | Aptify.Applications.Tasks Namespace


TaskLayout.FindControls Method

This method handles binding the controls to their internal protected members.

protected virtual void FindControls();

Remarks

See Also

TaskLayout Class | Aptify.Applications.Tasks Namespace


TaskLayout.GetCurrentStatus Method

This method returns the current status of the loaded task

public virtual string GetCurrentStatus();

Return Value

Remarks

See Also

TaskLayout Class | Aptify.Applications.Tasks Namespace


TaskLayout.GetTaskTypeID Method

This method returns the TypeID for the loaded task

public virtual long GetTaskTypeID();

Return Value

Remarks

See Also

TaskLayout Class | Aptify.Applications.Tasks Namespace


TaskLayout.IsTaskClosed Method

This method determines if the task is currently closed or not by determining, based on the Task Type, if the status currently selected is a status that is marked as Closed in the TaskTypePossibleStatus entity.

public virtual bool IsTaskClosed();

Return Value

Remarks

See Also

TaskLayout Class | Aptify.Applications.Tasks Namespace


TaskLayout.LinkExists Method

This method will determine if the specified EntityID/RecordID pair exists in the TaskLinks sub-type of the provided TaskGE instance.

protected virtual bool LinkExists(
AptifyGenericEntityBase TaskGE,
Int64 EntityID,
Int64 RecordID
);

Parameters

TaskGE
EntityID
RecordID

Return Value

Remarks

See Also

TaskLayout Class | Aptify.Applications.Tasks Namespace


TaskLayout.LoadParams Method

This method is called whenever a form template is loaded and is responsible for handling any specialized loading process for form parameters. The default implementation of this method in the TaskLayout class parses the parameters and determines if any links have been requested for a new record and if any are found in the parameter list, they are added to the TaskLinks sub-type.

protected virtual void LoadParams();

Remarks

See Also

TaskLayout Class | Aptify.Applications.Tasks Namespace


TaskLayout.LoadStatusValues Method

This method loads the Status combo box with the relevant status types based on the Task Type selected The Status values are retrieved from the underlying Task GE object's StatusList property which can be refreshed using the Task object's LoadTaskTypeStatus method and passing in the task type.

protected virtual void LoadStatusValues(
Int64 lTaskTypeID
);

Parameters

lTaskTypeID
The TaskTypeID from which the Status values should be retrieved.

Remarks

The TaskTypeID is added to the combo box's Tag property to compare to the submitted TaskTypeID to prevent reloading the same task types.

See Also

TaskLayout Class | Aptify.Applications.Tasks Namespace


TaskLayout.m_ctlType_ValueChanged Method

protected virtual void m_ctlType_ValueChanged(
Object sender,
Object OldValue,
Object NewValue
);

See Also

TaskLayout Class | Aptify.Applications.Tasks Namespace


TaskLayout.OnFormTemplateLoaded Method

Contains logic to setup Event handlers for controls on the FormTemplate Layout.

protected override void OnFormTemplateLoaded(
FormTemplateLayout.FormTemplateLoadedEventArgs e
);

Parameters

e

Remarks

See Also

TaskLayout Class | Aptify.Applications.Tasks Namespace


TasksEntity Class

Aptify Task GE Sub-Class Object - Implements Base Task Functionality including execution of process flows as required based on the Task Type. This class can be sub-classed to alter the base functionality of the Task Management system. Also consider implementing Process Flows that are bound to changes in Status in the Task Types entity(under the Task Type Actions sub-type) as that model is implemented in this base Task class already.

For a list of all members of this type, see TasksEntity Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
TasksEntity

public class TasksEntity : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Applications.Tasks

Assembly: Tasks (in Tasks.dll)

See Also

TasksEntity Members | Aptify.Applications.Tasks Namespace


TasksEntity Members

TasksEntity overview

Public Instance Constructors

TasksEntity Constructor Initializes a new instance of the TasksEntity class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
Database | This property returns the database name that is the base database for the Tasks entity
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
StatusList |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LoadTaskTypeStatus |
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded. This method overrides the AptifyGenericEntity Save() method to add in functionality specific to the Tasks object for managing task type action process flows and also handle updates to the Status field based on the PercentComplete field. If PercentComplete is >= 100%, and the Status field is not set to a Completed status (Based on the Task Type Possible Status sub-type), the routine will update the Status to the first "Completed" status on the Task Type Possible Status list for the Task Type of the Task. This is done by calling a method called SetTaskComplete() which can be overriden if needed to implement other/added functional requirements.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue |
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_dStatusList
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase)
BroadcastChange (inherited from AptifyGenericEntity)
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase)
CloneSubType (inherited from AptifyGenericEntity)
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity)
CreateSubTypeRecord (inherited from AptifyGenericEntity)
CreateTopLevelRecord (inherited from AptifyGenericEntity)
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase)
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity)
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity)
FinishTransactionSubType (inherited from AptifyGenericEntity)
FinishTransactionTopLevel (inherited from AptifyGenericEntity)
FireEvent (inherited from AptifyGenericEntity)
FireValidationEvent (inherited from AptifyGenericEntity)
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity)
GenerateCreateSQL (inherited from AptifyGenericEntity)
GenerateDeleteSQL (inherited from AptifyGenericEntity)
GenerateFieldSQL (inherited from AptifyGenericEntity)
GenerateUpdateSQL (inherited from AptifyGenericEntity)
GetSQLResults This method returns a scalar string value based on a SQL statement that is passed in The assumption is that the SQL parameter is a SQL statement that will execute and return a single row and single column that is then cast to a string and retured. This function also performs the replacement of special Aptify markup characters that can be used in process flows to replace values in static strings with values from the Context Object. For example, a static string may have one or more occurences of syntax where a context object variable is enclosed in
<%ContextVariable%>
tags as shown here. For example, if a context object variable was called "MyVariable", that variable could be included in static values by defining a static value such as "This is my variable:
<%MyVariable%>
". To implement this functionality, the GetSQLResults() method will call the ReplaceMarkup() method before executing the SQL provided to it. ReplaceMarkup() handles the replacement of context object variables with the specialized mark-up tags mentioned here.
GetTaskTypeActionSQL | This method is responsible for retuning the SQL statement that will be used to determine what action to take, if any, for the type of change that has occured to this task based on the definition in the Task Type Actions sub-type. The default implementation of this method in the Task class is to execute the spGetTaskTypeActionByStatus stored procedure in the database using the passed in parameters.
GetTaskTypeClosedStatus | This method is responsible for returning the FIRST Possible status value from the Task Type Possible Status sub-type for the given Task Type ID that has the IsClosed field is set to 1. This is used to automatically mark a task as closed when its percent complete hits 100%. This method is not called if the Task Status is already Closed, meaning that if a sub-class, object consumer, or user sets the Status of the task to a status code that is marked as IsClosed=1 before calling Save, this functionality will never be executed as it is not needed at that point.
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase)
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
IsStatusClosed | This function is responsible for determining if the provided Status is marked as "Closed" inside the Task Type Possible Status sub-type. The default implementation of this method simply executes a query in the database to determine the value of the IsClosed bit value in the TaskTypePossibleStatus sub-type entity.
MakeFieldsCopy (inherited from AptifyGenericEntity)
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
ProcessTaskAction | This method is responsible for processing a task action whenever a change occurs in the status of a task. By default, the class implements functionality that will execute a specified process flow (from the TaskTypeActions sub-type). Override this method if it becomes necessary to alter the above mentioned functionality.
RecordVersionInfo (inherited from AptifyGenericEntity)
RefreshLinkedFields (inherited from AptifyGenericEntity)
ReplaceMarkup | This method is responsible for replacing markup tags <%MarkupTag%> as described in the method description of GetSQLResults(). If bSQL is True, the replaced markup will be wrapped in single quotes.
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase)
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity)
RestoreCopiedFields (inherited from AptifyGenericEntity)
RollbackEmbeddedObjects (inherited from AptifyGenericEntity)
RunProcess | This method is responsible for executing a process flow as specified by the Process Flow ID and the Task Type Action GE object as provided. This method is called by the ProcessTaskAction() method in the default implementation of the ProcessTaskAction() method. Override this method if you need to alter the functionality that is related to running the process flow for a task type change.
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase)
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase)
SetTaskComplete | This method is responsible for setting the task as "Complete". This is called from the Save() method when a situation is detected that the PercentComplete was set to a value >= 100 and the current status in the Task is not a "Closed" task as defined in the Task Type Possible Status sub-type. The default implementation of this method simply sets the PercentComplete to 100 and will set the
SetupInputProperties | This method is responsible for setting up the input properties in the context object based on the input map that is provided in the Task Type Action object. The Task Type Action uses the input map that is specified in the TaskTypeActions sub-type and that input map is mapped at run-time with values as appropriate from the run-time environment.
SetupTransaction (inherited from AptifyGenericEntity)
SetupTransactionSubType (inherited from AptifyGenericEntity)
SetupTransactionTopLevel (inherited from AptifyGenericEntity)
UpdateRecord (inherited from AptifyGenericEntity)
ValidateSubTypes (inherited from AptifyGenericEntityBase)
VerifyObject (inherited from AptifyGenericEntity)

See Also

TasksEntity Class | Aptify.Applications.Tasks Namespace


TasksEntity Constructor

Initializes a new instance of the TasksEntity class.

public TasksEntity();

See Also

TasksEntity Class | Aptify.Applications.Tasks Namespace


TasksEntity Fields

The fields of the TasksEntity class are listed below. For a complete list of TasksEntity class members, see the TasksEntity Members topic.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_dStatusList
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

See Also

TasksEntity Class | Aptify.Applications.Tasks Namespace


TasksEntity.m_dStatusList Field

protected m_dStatusList m_dStatusList;

See Also

TasksEntity Class | Aptify.Applications.Tasks Namespace


TasksEntity Properties

The properties of the TasksEntity class are listed below. For a complete list of TasksEntity class members, see the TasksEntity Members topic.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
Database | This property returns the database name that is the base database for the Tasks entity
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
StatusList |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

TasksEntity Class | Aptify.Applications.Tasks Namespace


Database Property

Aptify 5.0 Software Development Kit (SDK)

TasksEntity.Database Property

This property returns the database name that is the base database for the Tasks entity

public virtual String Database {get;}

Property Value

Remarks

See Also

TasksEntity Class | Aptify.Applications.Tasks Namespace


StatusList Property

Aptify 5.0 Software Development Kit (SDK)

TasksEntity.StatusList Property

public Dictionary<TKey,TValue> StatusList {get;}

See Also

TasksEntity Class | Aptify.Applications.Tasks Namespace


TasksEntity Methods

The methods of the TasksEntity class are listed below. For a complete list of TasksEntity class members, see the TasksEntity Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LoadTaskTypeStatus |
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded. This method overrides the AptifyGenericEntity Save() method to add in functionality specific to the Tasks object for managing task type action process flows and also handle updates to the Status field based on the PercentComplete field. If PercentComplete is >= 100%, and the Status field is not set to a Completed status (Based on the Task Type Possible Status sub-type), the routine will update the Status to the first "Completed" status on the Task Type Possible Status list for the Task Type of the Task. This is done by calling a method called SetTaskComplete() which can be overriden if needed to implement other/added functional requirements.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue |
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase)
BroadcastChange (inherited from AptifyGenericEntity)
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase)
CloneSubType (inherited from AptifyGenericEntity)
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity)
CreateSubTypeRecord (inherited from AptifyGenericEntity)
CreateTopLevelRecord (inherited from AptifyGenericEntity)
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase)
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity)
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity)
FinishTransactionSubType (inherited from AptifyGenericEntity)
FinishTransactionTopLevel (inherited from AptifyGenericEntity)
FireEvent (inherited from AptifyGenericEntity)
FireValidationEvent (inherited from AptifyGenericEntity)
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity)
GenerateCreateSQL (inherited from AptifyGenericEntity)
GenerateDeleteSQL (inherited from AptifyGenericEntity)
GenerateFieldSQL (inherited from AptifyGenericEntity)
GenerateUpdateSQL (inherited from AptifyGenericEntity)
GetSQLResults This method returns a scalar string value based on a SQL statement that is passed in The assumption is that the SQL parameter is a SQL statement that will execute and return a single row and single column that is then cast to a string and retured. This function also performs the replacement of special Aptify markup characters that can be used in process flows to replace values in static strings with values from the Context Object. For example, a static string may have one or more occurences of syntax where a context object variable is enclosed in
<%ContextVariable%>
tags as shown here. For example, if a context object variable was called "MyVariable", that variable could be included in static values by defining a static value such as "This is my variable:
<%MyVariable%>
". To implement this functionality, the GetSQLResults() method will call the ReplaceMarkup() method before executing the SQL provided to it. ReplaceMarkup() handles the replacement of context object variables with the specialized mark-up tags mentioned here.
GetTaskTypeActionSQL | This method is responsible for retuning the SQL statement that will be used to determine what action to take, if any, for the type of change that has occured to this task based on the definition in the Task Type Actions sub-type. The default implementation of this method in the Task class is to execute the spGetTaskTypeActionByStatus stored procedure in the database using the passed in parameters.
GetTaskTypeClosedStatus | This method is responsible for returning the FIRST Possible status value from the Task Type Possible Status sub-type for the given Task Type ID that has the IsClosed field is set to 1. This is used to automatically mark a task as closed when its percent complete hits 100%. This method is not called if the Task Status is already Closed, meaning that if a sub-class, object consumer, or user sets the Status of the task to a status code that is marked as IsClosed=1 before calling Save, this functionality will never be executed as it is not needed at that point.
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase)
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
IsStatusClosed | This function is responsible for determining if the provided Status is marked as "Closed" inside the Task Type Possible Status sub-type. The default implementation of this method simply executes a query in the database to determine the value of the IsClosed bit value in the TaskTypePossibleStatus sub-type entity.
MakeFieldsCopy (inherited from AptifyGenericEntity)
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
ProcessTaskAction | This method is responsible for processing a task action whenever a change occurs in the status of a task. By default, the class implements functionality that will execute a specified process flow (from the TaskTypeActions sub-type). Override this method if it becomes necessary to alter the above mentioned functionality.
RecordVersionInfo (inherited from AptifyGenericEntity)
RefreshLinkedFields (inherited from AptifyGenericEntity)
ReplaceMarkup | This method is responsible for replacing markup tags <%MarkupTag%> as described in the method description of GetSQLResults(). If bSQL is True, the replaced markup will be wrapped in single quotes.
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase)
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity)
RestoreCopiedFields (inherited from AptifyGenericEntity)
RollbackEmbeddedObjects (inherited from AptifyGenericEntity)
RunProcess | This method is responsible for executing a process flow as specified by the Process Flow ID and the Task Type Action GE object as provided. This method is called by the ProcessTaskAction() method in the default implementation of the ProcessTaskAction() method. Override this method if you need to alter the functionality that is related to running the process flow for a task type change.
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase)
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase)
SetTaskComplete | This method is responsible for setting the task as "Complete". This is called from the Save() method when a situation is detected that the PercentComplete was set to a value >= 100 and the current status in the Task is not a "Closed" task as defined in the Task Type Possible Status sub-type. The default implementation of this method simply sets the PercentComplete to 100 and will set the
SetupInputProperties | This method is responsible for setting up the input properties in the context object based on the input map that is provided in the Task Type Action object. The Task Type Action uses the input map that is specified in the TaskTypeActions sub-type and that input map is mapped at run-time with values as appropriate from the run-time environment.
SetupTransaction (inherited from AptifyGenericEntity)
SetupTransactionSubType (inherited from AptifyGenericEntity)
SetupTransactionTopLevel (inherited from AptifyGenericEntity)
UpdateRecord (inherited from AptifyGenericEntity)
ValidateSubTypes (inherited from AptifyGenericEntityBase)
VerifyObject (inherited from AptifyGenericEntity)

See Also

TasksEntity Class | Aptify.Applications.Tasks Namespace


TasksEntity.GetSQLResults Method

This method returns a scalar string value based on a SQL statement that is passed in The assumption is that the SQL parameter is a SQL statement that will execute and return a single row and single column that is then cast to a string and retured. This function also performs the replacement of special Aptify markup characters that can be used in process flows to replace values in static strings with values from the Context Object. For example, a static string may have one or more occurences of syntax where a context object variable is enclosed in

<%ContextVariable%>
tags as shown here. For example, if a context object variable was called "MyVariable", that variable could be included in static values by defining a static value such as "This is my variable:
<%MyVariable%>
". To implement this functionality, the GetSQLResults() method will call the ReplaceMarkup() method before executing the SQL provided to it. ReplaceMarkup() handles the replacement of context object variables with the specialized mark-up tags mentioned here.

protected virtual string GetSQLResults(
String SQL,
Boolean RefreshCache
);

Parameters

SQL
RefreshCache

Return Value

Remarks

See Also

TasksEntity Class | Aptify.Applications.Tasks Namespace


TasksEntity.GetTaskTypeActionSQL Method

This method is responsible for retuning the SQL statement that will be used to determine what action to take, if any, for the type of change that has occured to this task based on the definition in the Task Type Actions sub-type. The default implementation of this method in the Task class is to execute the spGetTaskTypeActionByStatus stored procedure in the database using the passed in parameters.

protected virtual string GetTaskTypeActionSQL(
Int64 TaskTypeID,
String Status,
String PriorStatus
);

Parameters

TaskTypeID
Status
PriorStatus

Return Value

Valid SQL Statement

Remarks

See Also

TasksEntity Class | Aptify.Applications.Tasks Namespace


TasksEntity.GetTaskTypeClosedStatus Method

This method is responsible for returning the FIRST Possible status value from the Task Type Possible Status sub-type for the given Task Type ID that has the IsClosed field is set to 1. This is used to automatically mark a task as closed when its percent complete hits 100%. This method is not called if the Task Status is already Closed, meaning that if a sub-class, object consumer, or user sets the Status of the task to a status code that is marked as IsClosed=1 before calling Save, this functionality will never be executed as it is not needed at that point.

protected virtual string GetTaskTypeClosedStatus(
Int64 TaskTypeID
);

Parameters

TaskTypeID

Return Value

Remarks

See Also

TasksEntity Class | Aptify.Applications.Tasks Namespace


TasksEntity.IsStatusClosed Method

This function is responsible for determining if the provided Status is marked as "Closed" inside the Task Type Possible Status sub-type. The default implementation of this method simply executes a query in the database to determine the value of the IsClosed bit value in the TaskTypePossibleStatus sub-type entity.

protected virtual bool IsStatusClosed(
Int64 TaskTypeID,
String Status
);

Parameters

TaskTypeID
Status

Return Value

True if the Status is marked with IsClosed=1, False otherwise

Remarks

See Also

TasksEntity Class | Aptify.Applications.Tasks Namespace


TasksEntity.LoadTaskTypeStatus Method

public virtual bool LoadTaskTypeStatus(
Int64 lTaskTypeID
);

See Also

TasksEntity Class | Aptify.Applications.Tasks Namespace


TasksEntity.ProcessTaskAction Method

This method is responsible for processing a task action whenever a change occurs in the status of a task. By default, the class implements functionality that will execute a specified process flow (from the TaskTypeActions sub-type). Override this method if it becomes necessary to alter the above mentioned functionality.

protected virtual bool ProcessTaskAction(
String PriorStatus
);

Parameters

PriorStatus
The prior status of the task. This information is used to determine which Task Action to executed based on the TaskTypeActions sub-type in the Aptify database.

Return Value

Remarks

See Also

TasksEntity Class | Aptify.Applications.Tasks Namespace


TasksEntity.ReplaceMarkup Method

This method is responsible for replacing markup tags <%MarkupTag%> as described in the method description of GetSQLResults(). If bSQL is True, the replaced markup will be wrapped in single quotes.

protected virtual string ReplaceMarkup(
String StringInput,
Boolean bSQL
);

Parameters

StringInput
The string to search for markups within
bSQL
Boolean value flagging if the passed string, StringInput is a SQL statement or not.

Return Value

A string that no longer has the markups in it where the markups are replaced by the values of the markup tags that exist at run-time in the context object

Remarks

See Also

TasksEntity Class | Aptify.Applications.Tasks Namespace


TasksEntity.RunProcess Method

This method is responsible for executing a process flow as specified by the Process Flow ID and the Task Type Action GE object as provided. This method is called by the ProcessTaskAction() method in the default implementation of the ProcessTaskAction() method. Override this method if you need to alter the functionality that is related to running the process flow for a task type change.

protected virtual bool RunProcess(
Int64 ProcessFlowID,
AptifyGenericEntityBase TaskTypeAction
);

Parameters

ProcessFlowID
TaskTypeAction

Return Value

True if the process executes succesfully, False otherwise

Remarks

See Also

TasksEntity Class | Aptify.Applications.Tasks Namespace


Save Method

Aptify 5.0 Software Development Kit (SDK)

TasksEntity.Save Method

This method overrides the AptifyGenericEntity Save() method to add in functionality specific to the Tasks object for managing task type action process flows and also handle updates to the Status field based on the PercentComplete field. If PercentComplete is >= 100%, and the Status field is not set to a Completed status (Based on the Task Type Possible Status sub-type), the routine will update the Status to the first "Completed" status on the Task Type Possible Status list for the Task Type of the Task. This is done by calling a method called SetTaskComplete() which can be overriden if needed to implement other/added functional requirements.

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Save();

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean,ref String&);

This method overrides the AptifyGenericEntity Save() method to add in functionality specific to the Tasks object for managing task type action process flows and also handle updates to the Status field based on the PercentComplete field. If PercentComplete is >= 100%, and the Status field is not set to a Completed status (Based on the Task Type Possible Status sub-type), the routine will update the Status to the first "Completed" status on the Task Type Possible Status list for the Task Type of the Task. This is done by calling a method called SetTaskComplete() which can be overriden if needed to implement other/added functional requirements.

public override bool Save(Boolean,ref String&,String);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(ref String&);

See Also

TasksEntity Class | Aptify.Applications.Tasks Namespace


TasksEntity.Save Method (Boolean, String&, String)

This method overrides the AptifyGenericEntity Save() method to add in functionality specific to the Tasks object for managing task type action process flows and also handle updates to the Status field based on the PercentComplete field. If PercentComplete is >= 100%, and the Status field is not set to a Completed status (Based on the Task Type Possible Status sub-type), the routine will update the Status to the first "Completed" status on the Task Type Possible Status list for the Task Type of the Task. This is done by calling a method called SetTaskComplete() which can be overriden if needed to implement other/added functional requirements.

public override bool Save(
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

Parameters

AllowGUI
ErrorString
TransactionID

Return Value

Remarks

See Also

TasksEntity Class | Aptify.Applications.Tasks Namespace | TasksEntity.Save Overload List


TasksEntity.SetTaskComplete Method

This method is responsible for setting the task as "Complete". This is called from the Save() method when a situation is detected that the PercentComplete was set to a value >= 100 and the current status in the Task is not a "Closed" task as defined in the Task Type Possible Status sub-type. The default implementation of this method simply sets the PercentComplete to 100 and will set the

protected virtual void SetTaskComplete();

Remarks

See Also

TasksEntity Class | Aptify.Applications.Tasks Namespace


TasksEntity.SetupInputProperties Method

This method is responsible for setting up the input properties in the context object based on the input map that is provided in the Task Type Action object. The Task Type Action uses the input map that is specified in the TaskTypeActions sub-type and that input map is mapped at run-time with values as appropriate from the run-time environment.

protected virtual bool SetupInputProperties(
AptifyGenericEntityBase TaskTypeAction,
AptifyContext ContextObject
);

Parameters

TaskTypeAction
ContextObject

Return Value

Remarks

See Also

TasksEntity Class | Aptify.Applications.Tasks Namespace


TasksEntity.SetValue Method

public override void SetValue(
String FieldName,
Object Value
);

See Also

TasksEntity Class | Aptify.Applications.Tasks Namespace


TasksEntity.StatusListItem Structure

For a list of all members of this type, see TasksEntity.StatusListItem Members.

System.Object
ValueType
TasksEntity.StatusListItem

public struct TasksEntity.StatusListItem

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Tasks

Assembly: Tasks (in Tasks.dll)

See Also

TasksEntity.StatusListItem Members | Aptify.Applications.Tasks Namespace


TasksEntity.StatusListItem Members

TasksEntity.StatusListItem overview

Public Instance Constructors

TasksEntity.StatusListItem Constructor

Public Instance Fields

Description
IsClosed
Sequence
Status
TaskTypeID

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

TasksEntity.StatusListItem Structure | Aptify.Applications.Tasks Namespace


TasksEntity.StatusListItem Constructor

public TasksEntity.StatusListItem(
Int64 lTaskTypeID,
String sStatus,
Boolean bClosed
);

See Also

TasksEntity.StatusListItem Structure | Aptify.Applications.Tasks Namespace


TasksEntity.StatusListItem Fields

The fields of the TasksEntity.StatusListItem structure are listed below. For a complete list of TasksEntity.StatusListItem structure members, see the TasksEntity.StatusListItem Members topic.

Public Instance Fields

Description
IsClosed
Sequence
Status
TaskTypeID

See Also

TasksEntity.StatusListItem Structure | Aptify.Applications.Tasks Namespace


TasksEntity.StatusListItem.Description Field

public Description Description;

See Also

TasksEntity.StatusListItem Class | Aptify.Applications.Tasks Namespace


TasksEntity.StatusListItem.IsClosed Field

public IsClosed IsClosed;

See Also

TasksEntity.StatusListItem Class | Aptify.Applications.Tasks Namespace


TasksEntity.StatusListItem.Sequence Field

public Sequence Sequence;

See Also

TasksEntity.StatusListItem Class | Aptify.Applications.Tasks Namespace


TasksEntity.StatusListItem.Status Field

public Status Status;

See Also

TasksEntity.StatusListItem Class | Aptify.Applications.Tasks Namespace


TasksEntity.StatusListItem.TaskTypeID Field

public TaskTypeID TaskTypeID;

See Also

TasksEntity.StatusListItem Class | Aptify.Applications.Tasks Namespace


TaskTypeActionLayout Class

For a list of all members of this type, see TaskTypeActionLayout Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
TaskTypeActionLayout

public class TaskTypeActionLayout : FormTemplateLayout

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Applications.Tasks

Assembly: TaskLayoutControls (in TaskLayoutControls.dll)

See Also

TaskTypeActionLayout Members | Aptify.Applications.Tasks Namespace


TaskTypeActionLayout Members

TaskTypeActionLayout overview

Public Instance Constructors

TaskTypeActionLayout Constructor Initializes a new instance of the TaskTypeActionLayout class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
m_cmbPriorStatus |
m_cmbStatus |
m_lnkProcessFlow |
m_oDataControl |
m_oInputMap |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormTemplateLayout) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControls |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitializeInputMap | Initialize the input map when the form is loaded.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
LoadInputMapFromProcessFlow |
LoadStatusCombo |
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded | Contains logic to setup Event handlers for controls on the FormTemplate Layout.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

TaskTypeActionLayout Class | Aptify.Applications.Tasks Namespace


TaskTypeActionLayout Constructor

Initializes a new instance of the TaskTypeActionLayout class.

public TaskTypeActionLayout();

See Also

TaskTypeActionLayout Class | Aptify.Applications.Tasks Namespace


TaskTypeActionLayout Properties

The properties of the TaskTypeActionLayout class are listed below. For a complete list of TaskTypeActionLayout class members, see the TaskTypeActionLayout Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
m_cmbPriorStatus |
m_cmbStatus |
m_lnkProcessFlow |
m_oDataControl |
m_oInputMap |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

TaskTypeActionLayout Class | Aptify.Applications.Tasks Namespace


m_cmbPriorStatus Property

Aptify 5.0 Software Development Kit (SDK)

TaskTypeActionLayout.m_cmbPriorStatus Property

protected virtual AptifyComboBox m_cmbPriorStatus {get; set;}

See Also

TaskTypeActionLayout Class | Aptify.Applications.Tasks Namespace


m_cmbStatus Property

Aptify 5.0 Software Development Kit (SDK)

TaskTypeActionLayout.m_cmbStatus Property

protected virtual AptifyComboBox m_cmbStatus {get; set;}

See Also

TaskTypeActionLayout Class | Aptify.Applications.Tasks Namespace


m_lnkProcessFlow Property

Aptify 5.0 Software Development Kit (SDK)

TaskTypeActionLayout.m_lnkProcessFlow Property

protected virtual AptifyLinkBox m_lnkProcessFlow {get; set;}

See Also

TaskTypeActionLayout Class | Aptify.Applications.Tasks Namespace


m_oDataControl Property

Aptify 5.0 Software Development Kit (SDK)

TaskTypeActionLayout.m_oDataControl Property

protected virtual AptifyDataControl m_oDataControl {get; set;}

See Also

TaskTypeActionLayout Class | Aptify.Applications.Tasks Namespace


m_oInputMap Property

Aptify 5.0 Software Development Kit (SDK)

TaskTypeActionLayout.m_oInputMap Property

protected virtual InputMap m_oInputMap {get; set;}

See Also

TaskTypeActionLayout Class | Aptify.Applications.Tasks Namespace


TaskTypeActionLayout Methods

The methods of the TaskTypeActionLayout class are listed below. For a complete list of TaskTypeActionLayout class members, see the TaskTypeActionLayout Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from FormTemplateLayout) | Overloaded. Releases all resources used by the Component.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FindControls |
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitializeInputMap | Initialize the input map when the form is loaded.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
LoadInputMapFromProcessFlow |
LoadStatusCombo |
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded | Contains logic to setup Event handlers for controls on the FormTemplate Layout.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

TaskTypeActionLayout Class | Aptify.Applications.Tasks Namespace


TaskTypeActionLayout.FindControls Method

protected virtual void FindControls();

See Also

TaskTypeActionLayout Class | Aptify.Applications.Tasks Namespace


TaskTypeActionLayout.InitializeInputMap Method

Initialize the input map when the form is loaded.

protected virtual void InitializeInputMap();

Remarks

See Also

TaskTypeActionLayout Class | Aptify.Applications.Tasks Namespace


TaskTypeActionLayout.LoadInputMapFromProcessFlow Method

protected virtual bool LoadInputMapFromProcessFlow(
Int64 lProcessFlowID
);

See Also

TaskTypeActionLayout Class | Aptify.Applications.Tasks Namespace


TaskTypeActionLayout.LoadStatusCombo Method

protected virtual void LoadStatusCombo(
ref AptifyComboBox& StatusCombo
);

See Also

TaskTypeActionLayout Class | Aptify.Applications.Tasks Namespace


TaskTypeActionLayout.OnFormTemplateLoaded Method

Contains logic to setup Event handlers for controls on the FormTemplate Layout.

protected override void OnFormTemplateLoaded(
FormTemplateLayout.FormTemplateLoadedEventArgs e
);

Parameters

e

Remarks

See Also

TaskTypeActionLayout Class | Aptify.Applications.Tasks Namespace


Aptify.Framework.AcctMgrTransferPFComp

Aptify 5.0 Software Development Kit (SDK)

Aptify.Framework.AcctMgrTransferPFComp Namespace

This namespace corresponds to objects used by the Aptify Account Manager Transfer metadata wizard.

Namespace hierarchy

Classes

Class | Description
AcctMgrTransferPFComp |


AcctMgrTransferPFComp Class

For a list of all members of this type, see AcctMgrTransferPFComp Members.

System.Object
AcctMgrTransferPFComp

public class AcctMgrTransferPFComp : IProcessComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.AcctMgrTransferPFComp

Assembly: AcctMgrTransferPFComp (in AcctMgrTransferPFComp.dll)

See Also

AcctMgrTransferPFComp Members | Aptify.Framework.AcctMgrTransferPFComp Namespace


AcctMgrTransferPFComp Members

AcctMgrTransferPFComp overview

Public Instance Constructors

AcctMgrTransferPFComp Constructor Initializes a new instance of the AcctMgrTransferPFComp class.

Public Instance Properties

DataAction | Returns Data Action object.
Properties | Returns properties in this process flow.

Public Instance Methods

Config | Set application object here.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run | This will transfer accounts from one Account Manager to another. Any Company record that is present in the view and that belongs to the old Account Manager will be switched to the new Account Manager. The following Entities may be modified by this Wizard: Companies, CompanyAccountManagers, Contact Logs, Persons, PersonAccountManagers, and Opportunities
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AcctMgrTransferPFComp Class | Aptify.Framework.AcctMgrTransferPFComp Namespace


AcctMgrTransferPFComp Constructor

Initializes a new instance of the AcctMgrTransferPFComp class.

public AcctMgrTransferPFComp();

See Also

AcctMgrTransferPFComp Class | Aptify.Framework.AcctMgrTransferPFComp Namespace


AcctMgrTransferPFComp Properties

The properties of the AcctMgrTransferPFComp class are listed below. For a complete list of AcctMgrTransferPFComp class members, see the AcctMgrTransferPFComp Members topic.

Public Instance Properties

DataAction | Returns Data Action object.
Properties | Returns properties in this process flow.

See Also

AcctMgrTransferPFComp Class | Aptify.Framework.AcctMgrTransferPFComp Namespace


DataAction Property

Aptify 5.0 Software Development Kit (SDK)

AcctMgrTransferPFComp.DataAction Property

Returns Data Action object.

public DataAction DataAction {get;}

Property Value

Remarks

See Also

AcctMgrTransferPFComp Class | Aptify.Framework.AcctMgrTransferPFComp Namespace


Properties Property

Aptify 5.0 Software Development Kit (SDK)

AcctMgrTransferPFComp.Properties Property

Returns properties in this process flow.

public AptifyProperties Properties {get;}

Property Value

Implements

IProcessComponent.

Remarks

See Also

AcctMgrTransferPFComp Class | Aptify.Framework.AcctMgrTransferPFComp Namespace


AcctMgrTransferPFComp Methods

The methods of the AcctMgrTransferPFComp class are listed below. For a complete list of AcctMgrTransferPFComp class members, see the AcctMgrTransferPFComp Members topic.

Public Instance Methods

Config | Set application object here.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run | This will transfer accounts from one Account Manager to another. Any Company record that is present in the view and that belongs to the old Account Manager will be switched to the new Account Manager. The following Entities may be modified by this Wizard: Companies, CompanyAccountManagers, Contact Logs, Persons, PersonAccountManagers, and Opportunities
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AcctMgrTransferPFComp Class | Aptify.Framework.AcctMgrTransferPFComp Namespace


AcctMgrTransferPFComp.Config Method

Set application object here.

public void Config(
AptifyApplication ApplicationObject
);

Parameters

ApplicationObject

Implements

IProcessComponent.

Remarks

See Also

AcctMgrTransferPFComp Class | Aptify.Framework.AcctMgrTransferPFComp Namespace


AcctMgrTransferPFComp.Run Method

This will transfer accounts from one Account Manager to another. Any Company record that is present in the view and that belongs to the old Account Manager will be switched to the new Account Manager. The following Entities may be modified by this Wizard: Companies, CompanyAccountManagers, Contact Logs, Persons, PersonAccountManagers, and Opportunities

public string Run();

Return Value

Implements

IProcessComponent.

Remarks

See Also

AcctMgrTransferPFComp Class | Aptify.Framework.AcctMgrTransferPFComp Namespace


Aptify.Framework.Administration

Aptify 5.0 Software Development Kit (SDK)

Aptify.Framework.Administration Namespace

This namespace contains objects related to Aptify's Virtual Entity wizard.

Namespace hierarchy

Classes

Class | Description
DB | Provides utility functions for reading the contents of a system database catalog in SQL Server
DBCache | Provides a cache of information about a specific
DBColumn | Provides information about a column in a table or view in SQL Server including mapping the specific data type to one of a smaller number of base types
DBTableOrView | Class provides information about a table or view in a database
VirtualEntityCreator | Utility to create new entities in the Aptify Platform that are Virtual (meaning the data is not physically stored in a native-Aptify data entity, but is linked in from any other data source). This functionality is used by the Aptify VirtualEntityWizard to provide a user interface for administrators that wish to create new entities that bind in non-Aptify data.
VirtualEntityWizard | This wizard provides a user interface to the VirtualEntityCreator object which in turns provides the underlying functionality to create new virtual entities within the Aptify platform based on the provided parameters.

Enumerations

Enumeration | Description
DBColumnBaseType | Enumerates the possible base types for a system column
TableOrView | Two possible values, table or view


DB Class

Provides utility functions for reading the contents of a system database catalog in SQL Server

For a list of all members of this type, see DB Members.

System.Object
DB

public class DB

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.Administration

Assembly: AptifyVirtualEntityWizard (in AptifyVirtualEntityWizard.dll)

See Also

DB Members | Aptify.Framework.Administration Namespace


DB Members

DB overview

Public Instance Constructors

DB Constructor

Public Instance Properties

Name
Tables

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DB Class | Aptify.Framework.Administration Namespace


DB Constructor

public DB(
String Name,
DataAction DataAction
);

See Also

DB Class | Aptify.Framework.Administration Namespace


DB Properties

The properties of the DB class are listed below. For a complete list of DB class members, see the DB Members topic.

Public Instance Properties

Name
Tables

See Also

DB Class | Aptify.Framework.Administration Namespace


Name Property

Aptify 5.0 Software Development Kit (SDK)

DB.Name Property

public String Name {get;}

See Also

DB Class | Aptify.Framework.Administration Namespace


Tables Property

Aptify 5.0 Software Development Kit (SDK)

DB.Tables Property

public Dictionary<TKey,TValue> this[
Boolean Refresh
] {get;}

See Also

DB Class | Aptify.Framework.Administration Namespace


DBCache Class

Provides a cache of information about a specific

For a list of all members of this type, see DBCache Members.

System.Object
DBCache

public class DBCache

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.Administration

Assembly: AptifyVirtualEntityWizard (in AptifyVirtualEntityWizard.dll)

See Also

DBCache Members | Aptify.Framework.Administration Namespace


DBCache Members

DBCache overview

Public Static Methods

Instance

Public Instance Constructors

DBCache Constructor

Public Instance Properties

Databases

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDatabase |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DBCache Class | Aptify.Framework.Administration Namespace


DBCache Constructor

public DBCache(
DataAction DataAction
);

See Also

DBCache Class | Aptify.Framework.Administration Namespace


DBCache Properties

The properties of the DBCache class are listed below. For a complete list of DBCache class members, see the DBCache Members topic.

Public Instance Properties

Databases

See Also

DBCache Class | Aptify.Framework.Administration Namespace


Databases Property

Aptify 5.0 Software Development Kit (SDK)

DBCache.Databases Property

public Dictionary<TKey,TValue> this[
Boolean Refresh
] {get;}

See Also

DBCache Class | Aptify.Framework.Administration Namespace


DBCache Methods

The methods of the DBCache class are listed below. For a complete list of DBCache class members, see the DBCache Members topic.

Public Static Methods

Instance

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDatabase |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DBCache Class | Aptify.Framework.Administration Namespace


DBCache.GetDatabase Method

public DB GetDatabase(
String Name,
Boolean Refresh
);

See Also

DBCache Class | Aptify.Framework.Administration Namespace


DBCache.Instance Method

public static DBCache Instance(
DataAction DataAction
);

See Also

DBCache Class | Aptify.Framework.Administration Namespace


DBColumn Class

Provides information about a column in a table or view in SQL Server including mapping the specific data type to one of a smaller number of base types

For a list of all members of this type, see DBColumn Members.

System.Object
DBColumn

public class DBColumn

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.Administration

Assembly: AptifyVirtualEntityWizard (in AptifyVirtualEntityWizard.dll)

See Also

DBColumn Members | Aptify.Framework.Administration Namespace


DBColumn Members

DBColumn overview

Public Instance Properties

BaseType
FieldSize
Name
SQLDataType
TableOrView

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DBColumn Class | Aptify.Framework.Administration Namespace


DBColumn Properties

The properties of the DBColumn class are listed below. For a complete list of DBColumn class members, see the DBColumn Members topic.

Public Instance Properties

BaseType
FieldSize
Name
SQLDataType
TableOrView

See Also

DBColumn Class | Aptify.Framework.Administration Namespace


BaseType Property

Aptify 5.0 Software Development Kit (SDK)

DBColumn.BaseType Property

public DBColumnBaseType BaseType {get;}

See Also

DBColumn Class | Aptify.Framework.Administration Namespace


FieldSize Property

Aptify 5.0 Software Development Kit (SDK)

DBColumn.FieldSize Property

public Int32 FieldSize {get;}

See Also

DBColumn Class | Aptify.Framework.Administration Namespace


Name Property

Aptify 5.0 Software Development Kit (SDK)

DBColumn.Name Property

public String Name {get;}

See Also

DBColumn Class | Aptify.Framework.Administration Namespace


SQLDataType Property

Aptify 5.0 Software Development Kit (SDK)

DBColumn.SQLDataType Property

public String SQLDataType {get;}

See Also

DBColumn Class | Aptify.Framework.Administration Namespace


TableOrView Property

Aptify 5.0 Software Development Kit (SDK)

DBColumn.TableOrView Property

public DBTableOrView TableOrView {get;}

See Also

DBColumn Class | Aptify.Framework.Administration Namespace


DBColumnBaseType Enumeration

Enumerates the possible base types for a system column

public enum DBColumnBaseType

Remarks

Members

Member Name | Description
Text |
Integer |
Decimal |
DateTime |
Bit |
Binary |
Unknown |

Requirements

Namespace: Aptify.Framework.Administration

Assembly: AptifyVirtualEntityWizard (in AptifyVirtualEntityWizard.dll)

See Also

Aptify.Framework.Administration Namespace


DBTableOrView Class

Class provides information about a table or view in a database

For a list of all members of this type, see DBTableOrView Members.

System.Object
DBTableOrView

public class DBTableOrView

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.Administration

Assembly: AptifyVirtualEntityWizard (in AptifyVirtualEntityWizard.dll)

See Also

DBTableOrView Members | Aptify.Framework.Administration Namespace


DBTableOrView Members

DBTableOrView overview

Public Instance Properties

Columns
Database
Name
Type

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DBTableOrView Class | Aptify.Framework.Administration Namespace


DBTableOrView Properties

The properties of the DBTableOrView class are listed below. For a complete list of DBTableOrView class members, see the DBTableOrView Members topic.

Public Instance Properties

Columns
Database
Name
Type

See Also

DBTableOrView Class | Aptify.Framework.Administration Namespace


Columns Property

Aptify 5.0 Software Development Kit (SDK)

DBTableOrView.Columns Property

public Dictionary<TKey,TValue> this[
Boolean Refresh
] {get;}

See Also

DBTableOrView Class | Aptify.Framework.Administration Namespace


Database Property

Aptify 5.0 Software Development Kit (SDK)

DBTableOrView.Database Property

public DB Database {get;}

See Also

DBTableOrView Class | Aptify.Framework.Administration Namespace


Name Property

Aptify 5.0 Software Development Kit (SDK)

DBTableOrView.Name Property

public String Name {get;}

See Also

DBTableOrView Class | Aptify.Framework.Administration Namespace


Type Property

Aptify 5.0 Software Development Kit (SDK)

DBTableOrView.Type Property

public TableOrView Type {get;}

See Also

DBTableOrView Class | Aptify.Framework.Administration Namespace


TableOrView Enumeration

Two possible values, table or view

public enum TableOrView

Remarks

Members

Member Name | Description
Table |
View |

Requirements

Namespace: Aptify.Framework.Administration

Assembly: AptifyVirtualEntityWizard (in AptifyVirtualEntityWizard.dll)

See Also

Aptify.Framework.Administration Namespace


VirtualEntityCreator Class

Utility to create new entities in the Aptify Platform that are Virtual (meaning the data is not physically stored in a native-Aptify data entity, but is linked in from any other data source). This functionality is used by the Aptify VirtualEntityWizard to provide a user interface for administrators that wish to create new entities that bind in non-Aptify data.

For a list of all members of this type, see VirtualEntityCreator Members.

System.Object
VirtualEntityCreator

public class VirtualEntityCreator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.Administration

Assembly: AptifyVirtualEntityWizard (in AptifyVirtualEntityWizard.dll)

See Also

VirtualEntityCreator Members | Aptify.Framework.Administration Namespace


VirtualEntityCreator Members

VirtualEntityCreator overview

Public Instance Constructors

VirtualEntityCreator Overloaded. Initializes a new instance of the VirtualEntityCreator class.

Public Instance Methods

CreateVirtualEntity | This method will create a new Entity definition in the entities database based on the information provided to this method. This method sets up a new entity object using the AptifyGenericEntity and then calls CreateBaseView(), CreateSPGet() and CreateEntityFields() in that order. Each of those methods can be overriden in sub-classes.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CreateBaseView | This method is responsible for creating a base view for the virtual entity.
CreateEntityFields | This method will create entity fields in the entity based on the fields in the underlying table. The first field specified is always the primary key field, which will be called 'ID' in all cases.
CreateSingleEntityField | This method is responsible for adding a single field to the entity object based on the information provided in the database column. If the FieldName parameter is provided, that parameter overrides the name information provided in the DBColumn.
CreateSPGet | This method will create a new stored procedure DB Object in Aptify that will be used for retrieving single records for the specified entity. The default logic is to simply create a "SELECT * FROM BaseDatabase..BaseView" type of SQL string.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetTableFields | This method returns a comma delimited list of the fields in the specified table, excluding the specified field.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

VirtualEntityCreator Class | Aptify.Framework.Administration Namespace


VirtualEntityCreator Constructor

Overload List

public VirtualEntityCreator(AptifyApplication);

public VirtualEntityCreator(AptifyApplication,DataAction);

See Also

VirtualEntityCreator Class | Aptify.Framework.Administration Namespace


VirtualEntityCreator Constructor (AptifyApplication)

public VirtualEntityCreator(
AptifyApplication Application
);

See Also

VirtualEntityCreator Class | Aptify.Framework.Administration Namespace | VirtualEntityCreator Constructor Overload List


VirtualEntityCreator Constructor (AptifyApplication, DataAction)

public VirtualEntityCreator(
AptifyApplication Application,
DataAction DataAction
);

See Also

VirtualEntityCreator Class | Aptify.Framework.Administration Namespace | VirtualEntityCreator Constructor Overload List


VirtualEntityCreator Methods

The methods of the VirtualEntityCreator class are listed below. For a complete list of VirtualEntityCreator class members, see the VirtualEntityCreator Members topic.

Public Instance Methods

CreateVirtualEntity | This method will create a new Entity definition in the entities database based on the information provided to this method. This method sets up a new entity object using the AptifyGenericEntity and then calls CreateBaseView(), CreateSPGet() and CreateEntityFields() in that order. Each of those methods can be overriden in sub-classes.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CreateBaseView | This method is responsible for creating a base view for the virtual entity.
CreateEntityFields | This method will create entity fields in the entity based on the fields in the underlying table. The first field specified is always the primary key field, which will be called 'ID' in all cases.
CreateSingleEntityField | This method is responsible for adding a single field to the entity object based on the information provided in the database column. If the FieldName parameter is provided, that parameter overrides the name information provided in the DBColumn.
CreateSPGet | This method will create a new stored procedure DB Object in Aptify that will be used for retrieving single records for the specified entity. The default logic is to simply create a "SELECT * FROM BaseDatabase..BaseView" type of SQL string.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetTableFields | This method returns a comma delimited list of the fields in the specified table, excluding the specified field.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

VirtualEntityCreator Class | Aptify.Framework.Administration Namespace


VirtualEntityCreator.CreateBaseView Method

This method is responsible for creating a base view for the virtual entity.

protected virtual bool CreateBaseView(
String DataLocationDatabase,
String BaseDatabase,
String BaseViewName,
String UnderlyingTableName,
String PKeyField,
AptifyGenericEntityBase EntityObject
);

Parameters

DataLocationDatabase
BaseDatabase
BaseViewName
UnderlyingTableName
PKeyField
EntityObject

Return Value

Remarks

See Also

VirtualEntityCreator Class | Aptify.Framework.Administration Namespace


VirtualEntityCreator.CreateEntityFields Method

This method will create entity fields in the entity based on the fields in the underlying table. The first field specified is always the primary key field, which will be called 'ID' in all cases.

protected virtual bool CreateEntityFields(
String DataLocationDatabase,
String BaseViewName,
String UnderlyingTableName,
String PKeyField,
AptifyGenericEntityBase EntityObject
);

Parameters

DataLocationDatabase
BaseViewName
UnderlyingTableName
PKeyField
EntityObject

Return Value

Remarks

See Also

VirtualEntityCreator Class | Aptify.Framework.Administration Namespace


VirtualEntityCreator.CreateSingleEntityField Method

This method is responsible for adding a single field to the entity object based on the information provided in the database column. If the FieldName parameter is provided, that parameter overrides the name information provided in the DBColumn.

protected virtual bool CreateSingleEntityField(
AptifyGenericEntityBase EntityObject,
DBColumn DBCol,
String FieldName
);

Parameters

EntityObject
DBCol
FieldName

Return Value

Remarks

See Also

VirtualEntityCreator Class | Aptify.Framework.Administration Namespace


VirtualEntityCreator.CreateSPGet Method

This method will create a new stored procedure DB Object in Aptify that will be used for retrieving single records for the specified entity. The default logic is to simply create a "SELECT * FROM BaseDatabase..BaseView" type of SQL string.

protected virtual bool CreateSPGet(
String DataLocationDatabase,
String spGetSPName,
String BaseDatabase,
String BaseViewName,
String UnderlyingTableName,
String PKeyField,
AptifyGenericEntityBase EntityObject
);

Parameters

DataLocationDatabase
spGetSPName
BaseDatabase
BaseViewName
UnderlyingTableName
PKeyField
EntityObject

Return Value

True if succesful, False otherwise

Remarks

See Also

VirtualEntityCreator Class | Aptify.Framework.Administration Namespace


VirtualEntityCreator.CreateVirtualEntity Method

This method will create a new Entity definition in the entities database based on the information provided to this method. This method sets up a new entity object using the AptifyGenericEntity and then calls CreateBaseView(), CreateSPGet() and CreateEntityFields() in that order. Each of those methods can be overriden in sub-classes.

public virtual bool CreateVirtualEntity(
String DataLocationDatabase,
String EntityName,
String PKeyField,
String DisplayName,
String BaseDatabase,
String UnderlyingTable,
String BaseView,
String spGetSPName,
String Description,
ref Int64& EntityID
);

Parameters

DataLocationDatabase
SQL Server Database Name where
EntityName
Name of the new entity
PKeyField
Name of the field to use as the primary key. If this field is not named 'ID' a new field called 'ID' will be created and this field will be aliased into the new field (but still included in the entity definition with its original name as well)
DisplayName
Display Name for the new entity
BaseDatabase
Location where the base view will be created>
UnderlyingTable
Name of the table or view that contains the underlying data that will be selected into the generated base view
BaseView
Name of base view to generate for the entity
spGetSPName
Name of the stored procedure to generate for getting a single record from the entity
Description
Optional: Description for the entity
EntityID
Optional OUT Parameter: Returns the ID of the newly created Entity Record, if succesful

Return Value

True if succesful, False otherwise

Remarks

See Also

VirtualEntityCreator Class | Aptify.Framework.Administration Namespace


VirtualEntityCreator.GetTableFields Method

This method returns a comma delimited list of the fields in the specified table, excluding the specified field.

protected string GetTableFields(
String Database,
String Table,
String FieldToExclude
);

Parameters

Database
Table
FieldToExclude

Return Value

Remarks

See Also

VirtualEntityCreator Class | Aptify.Framework.Administration Namespace


VirtualEntityWizard Class

This wizard provides a user interface to the VirtualEntityCreator object which in turns provides the underlying functionality to create new virtual entities within the Aptify platform based on the provided parameters.

For a list of all members of this type, see VirtualEntityWizard Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
VirtualEntityWizard

public class VirtualEntityWizard : Form, IAptifyAction

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.Administration

Assembly: AptifyVirtualEntityWizard (in AptifyVirtualEntityWizard.dll)

See Also

VirtualEntityWizard Members | Aptify.Framework.Administration Namespace | VirtualEntityCreator


VirtualEntityWizard Members

VirtualEntityWizard overview

Public Instance Constructors

VirtualEntityWizard Constructor Initializes a new instance of the VirtualEntityWizard class.

Public Instance Properties

_picPanels_0 |
_picPanels_2 |
_picPanels_3 |
_picPanels_4 |
AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
chkDispEntity |
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
cmbBaseDatabase |
cmbDatabase |
cmbPKey |
cmbTable |
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
Label1 |
Label10 |
Label11 |
Label12 |
Label14 |
Label2 |
Label3 |
Label4 |
Label5 |
Label6 |
Label7 |
Label8 |
Label9 |
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
lblStep1 |
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Panel1 |
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
txtBaseView |
txtDescription |
txtDisplayName |
txtName |
txtSPGetRecord |
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoAction | Overloaded.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
LoadDatabases |
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

VirtualEntityWizard Class | Aptify.Framework.Administration Namespace | VirtualEntityCreator


VirtualEntityWizard Constructor

Initializes a new instance of the VirtualEntityWizard class.

public VirtualEntityWizard();

See Also

VirtualEntityWizard Class | Aptify.Framework.Administration Namespace


VirtualEntityWizard Properties

The properties of the VirtualEntityWizard class are listed below. For a complete list of VirtualEntityWizard class members, see the VirtualEntityWizard Members topic.

Public Instance Properties

_picPanels_0 |
_picPanels_2 |
_picPanels_3 |
_picPanels_4 |
AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
chkDispEntity |
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
cmbBaseDatabase |
cmbDatabase |
cmbPKey |
cmbTable |
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
Label1 |
Label10 |
Label11 |
Label12 |
Label14 |
Label2 |
Label3 |
Label4 |
Label5 |
Label6 |
Label7 |
Label8 |
Label9 |
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
lblStep1 |
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Panel1 |
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
txtBaseView |
txtDescription |
txtDisplayName |
txtName |
txtSPGetRecord |
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

VirtualEntityWizard Class | Aptify.Framework.Administration Namespace | VirtualEntityCreator


_picPanels_0 Property

Aptify 5.0 Software Development Kit (SDK)

VirtualEntityWizard._picPanels_0 Property

public virtual Panel _picPanels_0 {get; set;}

See Also

VirtualEntityWizard Class | Aptify.Framework.Administration Namespace


_picPanels_2 Property

Aptify 5.0 Software Development Kit (SDK)

VirtualEntityWizard._picPanels_2 Property

public virtual Panel _picPanels_2 {get; set;}

See Also

VirtualEntityWizard Class | Aptify.Framework.Administration Namespace


_picPanels_3 Property

Aptify 5.0 Software Development Kit (SDK)

VirtualEntityWizard._picPanels_3 Property

public virtual Panel _picPanels_3 {get; set;}

See Also

VirtualEntityWizard Class | Aptify.Framework.Administration Namespace


_picPanels_4 Property

Aptify 5.0 Software Development Kit (SDK)

VirtualEntityWizard._picPanels_4 Property

public virtual Panel _picPanels_4 {get; set;}

See Also

VirtualEntityWizard Class | Aptify.Framework.Administration Namespace


chkDispEntity Property

Aptify 5.0 Software Development Kit (SDK)

VirtualEntityWizard.chkDispEntity Property

public virtual CheckBox chkDispEntity {get; set;}

See Also

VirtualEntityWizard Class | Aptify.Framework.Administration Namespace


cmbBaseDatabase Property

Aptify 5.0 Software Development Kit (SDK)

VirtualEntityWizard.cmbBaseDatabase Property

public virtual ComboBox cmbBaseDatabase {get; set;}

See Also

VirtualEntityWizard Class | Aptify.Framework.Administration Namespace


cmbDatabase Property

Aptify 5.0 Software Development Kit (SDK)

VirtualEntityWizard.cmbDatabase Property

public virtual ComboBox cmbDatabase {get; set;}

See Also

VirtualEntityWizard Class | Aptify.Framework.Administration Namespace


cmbPKey Property

Aptify 5.0 Software Development Kit (SDK)

VirtualEntityWizard.cmbPKey Property

public virtual ComboBox cmbPKey {get; set;}

See Also

VirtualEntityWizard Class | Aptify.Framework.Administration Namespace


cmbTable Property

Aptify 5.0 Software Development Kit (SDK)

VirtualEntityWizard.cmbTable Property

public virtual ComboBox cmbTable {get; set;}

See Also

VirtualEntityWizard Class | Aptify.Framework.Administration Namespace


Label1 Property

Aptify 5.0 Software Development Kit (SDK)

VirtualEntityWizard.Label1 Property

public virtual Label Label1 {get; set;}

See Also

VirtualEntityWizard Class | Aptify.Framework.Administration Namespace


Label10 Property

Aptify 5.0 Software Development Kit (SDK)

VirtualEntityWizard.Label10 Property

public virtual Label Label10 {get; set;}

See Also

VirtualEntityWizard Class | Aptify.Framework.Administration Namespace


Label11 Property

Aptify 5.0 Software Development Kit (SDK)

VirtualEntityWizard.Label11 Property

public virtual Label Label11 {get; set;}

See Also

VirtualEntityWizard Class | Aptify.Framework.Administration Namespace


Label12 Property

Aptify 5.0 Software Development Kit (SDK)

VirtualEntityWizard.Label12 Property

public virtual Label Label12 {get; set;}

See Also

VirtualEntityWizard Class | Aptify.Framework.Administration Namespace


Label14 Property

Aptify 5.0 Software Development Kit (SDK)

VirtualEntityWizard.Label14 Property

public virtual Label Label14 {get; set;}

See Also

VirtualEntityWizard Class | Aptify.Framework.Administration Namespace


Label2 Property

Aptify 5.0 Software Development Kit (SDK)

VirtualEntityWizard.Label2 Property

public virtual Label Label2 {get; set;}

See Also

VirtualEntityWizard Class | Aptify.Framework.Administration Namespace


Label3 Property

Aptify 5.0 Software Development Kit (SDK)

VirtualEntityWizard.Label3 Property

public virtual Label Label3 {get; set;}

See Also

VirtualEntityWizard Class | Aptify.Framework.Administration Namespace


Label4 Property

Aptify 5.0 Software Development Kit (SDK)

VirtualEntityWizard.Label4 Property

public virtual Label Label4 {get; set;}

See Also

VirtualEntityWizard Class | Aptify.Framework.Administration Namespace


Label5 Property

Aptify 5.0 Software Development Kit (SDK)

VirtualEntityWizard.Label5 Property

public virtual Label Label5 {get; set;}

See Also

VirtualEntityWizard Class | Aptify.Framework.Administration Namespace


Label6 Property

Aptify 5.0 Software Development Kit (SDK)

VirtualEntityWizard.Label6 Property

public virtual Label Label6 {get; set;}

See Also

VirtualEntityWizard Class | Aptify.Framework.Administration Namespace


Label7 Property

Aptify 5.0 Software Development Kit (SDK)

VirtualEntityWizard.Label7 Property

public virtual Label Label7 {get; set;}

See Also

VirtualEntityWizard Class | Aptify.Framework.Administration Namespace


Label8 Property

Aptify 5.0 Software Development Kit (SDK)

VirtualEntityWizard.Label8 Property

public virtual Label Label8 {get; set;}

See Also

VirtualEntityWizard Class | Aptify.Framework.Administration Namespace


Label9 Property

Aptify 5.0 Software Development Kit (SDK)

VirtualEntityWizard.Label9 Property

public virtual Label Label9 {get; set;}

See Also

VirtualEntityWizard Class | Aptify.Framework.Administration Namespace


lblStep1 Property

Aptify 5.0 Software Development Kit (SDK)

VirtualEntityWizard.lblStep1 Property

public virtual Label lblStep1 {get; set;}

See Also

VirtualEntityWizard Class | Aptify.Framework.Administration Namespace


Panel1 Property

Aptify 5.0 Software Development Kit (SDK)

VirtualEntityWizard.Panel1 Property

public virtual Panel Panel1 {get; set;}

See Also

VirtualEntityWizard Class | Aptify.Framework.Administration Namespace


txtBaseView Property

Aptify 5.0 Software Development Kit (SDK)

VirtualEntityWizard.txtBaseView Property

public virtual TextBox txtBaseView {get; set;}

See Also

VirtualEntityWizard Class | Aptify.Framework.Administration Namespace


txtDescription Property

Aptify 5.0 Software Development Kit (SDK)

VirtualEntityWizard.txtDescription Property

public virtual TextBox txtDescription {get; set;}

See Also

VirtualEntityWizard Class | Aptify.Framework.Administration Namespace


txtDisplayName Property

Aptify 5.0 Software Development Kit (SDK)

VirtualEntityWizard.txtDisplayName Property

public virtual TextBox txtDisplayName {get; set;}

See Also

VirtualEntityWizard Class | Aptify.Framework.Administration Namespace


txtName Property

Aptify 5.0 Software Development Kit (SDK)

VirtualEntityWizard.txtName Property

public virtual TextBox txtName {get; set;}

See Also

VirtualEntityWizard Class | Aptify.Framework.Administration Namespace


txtSPGetRecord Property

Aptify 5.0 Software Development Kit (SDK)

VirtualEntityWizard.txtSPGetRecord Property

public virtual TextBox txtSPGetRecord {get; set;}

See Also

VirtualEntityWizard Class | Aptify.Framework.Administration Namespace


VirtualEntityWizard Methods

The methods of the VirtualEntityWizard class are listed below. For a complete list of VirtualEntityWizard class members, see the VirtualEntityWizard Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoAction | Overloaded.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
LoadDatabases |
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

VirtualEntityWizard Class | Aptify.Framework.Administration Namespace | VirtualEntityCreator


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

VirtualEntityWizard.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

VirtualEntityWizard Class | Aptify.Framework.Administration Namespace


VirtualEntityWizard.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

VirtualEntityWizard Class | Aptify.Framework.Administration Namespace | VirtualEntityWizard.Dispose Overload List


DoAction Method

Aptify 5.0 Software Development Kit (SDK)

VirtualEntityWizard.DoAction Method

Overload List

public void DoAction(AptifyApplication,Int64);

public void DoAction(AptifyApplication,Int64,Int64);

public void DoAction(AptifyApplication,Int64,Int64,params Object[]);

public void DoAction(AptifyApplication,Int64,params String[]);

See Also

VirtualEntityWizard Class | Aptify.Framework.Administration Namespace


VirtualEntityWizard.DoAction Method (AptifyApplication, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID
);

Implements

IAptifyAction.

See Also

VirtualEntityWizard Class | Aptify.Framework.Administration Namespace | VirtualEntityWizard.DoAction Overload List


VirtualEntityWizard.DoAction Method (AptifyApplication, Int64, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID
);

Implements

IAptifyAction.

See Also

VirtualEntityWizard Class | Aptify.Framework.Administration Namespace | VirtualEntityWizard.DoAction Overload List


VirtualEntityWizard.DoAction Method (AptifyApplication, Int64, Int64, Object[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID,
params Object[] SelectedItems
);

Implements

IAptifyAction.

See Also

VirtualEntityWizard Class | Aptify.Framework.Administration Namespace | VirtualEntityWizard.DoAction Overload List


VirtualEntityWizard.DoAction Method (AptifyApplication, Int64, String[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
params String[] SelectedItems
);

Implements

IAptifyAction.

See Also

VirtualEntityWizard Class | Aptify.Framework.Administration Namespace | VirtualEntityWizard.DoAction Overload List


VirtualEntityWizard.LoadDatabases Method

protected virtual bool LoadDatabases(
ComboBox cmb,
Boolean Refresh
);

See Also

VirtualEntityWizard Class | Aptify.Framework.Administration Namespace


Aptify.Framework.Application

Aptify 5.0 Software Development Kit (SDK)

Aptify.Framework.Application Namespace

The objects in this namespace provide a set of utility functions that are used primarily to access metadata associated with entities. This includes information about attachments, entity actions, entity attributes, views, sub-types, and other entity metadata. Many of the methods provided by the classes in this namespace are convenient substitutes for common SQL queries. For example, rather than writing a SQL query to obtain the Entity ID of the Dashboards entity, a developer can use the GetEntityID method of the AptifyApplication class. In addition to convenience, the use of the Aptify.Framework.Application objects enforces consistency on development activities by providing a common set of functions that all developers can use from any project.

Namespace hierarchy

Classes

Class | Description
ApplicationServicesForm |
ApplicationsForm |
AptifyApplication | Main object for retrieving a GE, meta data, views, plug ins, and displaying records. This object is the focal point for data and visual interaction with the application. It is responsible for loading the appropriate customized objects based upon their meta data. It provides the basis for using the supporting objects that provide greater detail. It is a source for application meta data. It is a utility object. It is a class factory for building Generic Entity objects. Note that it provides similar functionality to the Data Browser Information Object (DMInfo) provided in prior versions of the product.
AptifyApplication.ApplicationInfo | Application Information
AptifyApplicationEntityPermissionsRetrievalException | Unable to retrieve the data from the database for the entity permissions.
AptifyApplicationException |
AptifyApplicationInvalidCommandStringException | Thrown when the command variable is not valid (i.e., a record ID for an open command type is not numeric).
AptifyApplicationInvalidCommandTypeException | Thrown when a command passed in on a command string is not valid.
AptifyApplicationInvalidEntityException | Thrown when an entity is not found.
AptifyApplicationInvalidViewException | Thrown when an entity view is not found.
AptifyAttachmentCategories | A collection of AptifyAttachmentCategory objects. AptifyAttachmentCategories is a collection of Aptify attachments. It inherits AptifyAttachmentCategory.
AptifyAttachmentCategory | An object the represents a grouping of attachments. AptifyAttachmentCategory is a data-only object. All properties access data members in the class.
AptifyAttachments | Object used to manage a record's attachments.
AptifyCollection |
AptifyConfigurationOptions | Configuration Options Dialog Box
AptifyContext |
AptifyEntityDependencyGetFailureException | Error fetching dependency data or data is of invalid type.
AptifyEntityPermissionDeniedException |
AptifyEntityPlugInMissingDataException | Error fetching plug in data or data is of invalid type.
AptifyMessage |
AptifyMessageBox | Aptify's standard message box for displaying messages to users. The Show Method is overloaded to enable the display of both a short and long message as well as to override the standard title.
AptifyMessageCoordinator |
AptifyProperties |
CommandParser | An object that builds a command string based on the provided properties, including entity name/command type, and record ID. A string parsing object that returns the actions of the system, entity name, and record ID.
Constants |
CreationException | This exception is throw when the InstanceCreator cannot create an instance.
CurrencyTypeCache | Caches Currency Types information. Shared, on-demand cache.
CurrencyTypeData |
DSNUtility |
EntityAction | An object that represents the action wizards configured for a given entity. These are configured in the EntityActions subtype of Entities.
EntityActions | A collection of entity action objects.
EntityAttribute | An object that represents a single name value pair that can be reused at the entity level.
EntityAttributes | A collection of EntityAttribute objects.
EntityAttributeValueList | A collection of pre-set name value pairs that can be used to control which values are possible for an entity attribute.
EntityConstraint | This class is used to hold all of the entity constraints associated with an entity.
EntityDependencies | This is a collection of entity dependent objects. For the most part, it is a basic implementation of a collection.
EntityFieldPermissions | Provides a collection that allows for individuals to get permissions for a given entity field. This is a list of entity field permissions. This object is not created directly. Its data can be retrieved off of the AptifyDataField object.
EntityInfo | Provides the base object that brings together an application object, user credentials, entity level and field level data, plug ins, and actions.
EntityPlugIns |
EntityPropertiesForm |
EntityRecordHistoryForm |
Equality | Contains functionality that can be used to generically compare two objects for equality.
FindConstants |
GenericFind |
GenericFindBase |
GenericFindConfigurationException |
InfiniteStatusForm |
InstanceCreator | Class used to instantiate late bound objects.
ListItem |
ListItem<KeyType,DataType> | Used to represent any Keyed Object.
MathFunctions | Contains
ReservedSQLParser |
ShowDependenciesForm | This form will display a list of record dependencies that exist for a given entity record. Record dependencies are determined using the GetEntityDependencies() method on the Application Object. In addition, this class provides a constructor where a custom defined set of dependencies can be provided.
SQLClause | This class represents a Clause or "section" of a SQL Statement. For example, the SELECT Clause, FROM clause, WHERE Clause, ORDER BY Clause, etc
SQLStatement | Utility class for parsing SELECT statements, breaks up the statement into various clauses to simplify parsing.
Status | Used to represent the status of a current task.
StatusChangedEventArgs | The base object returned from the StatusChangedEventHandler
SubView | A data-only object that provides information regarding a subview. When a user displays hierarchies in a view, the system displays the sub-type or related record information in a subview.
SubViews | Provides a basic implementation of a collection for subview objects.
UtilityConstants |
ViewField | ViewField is a data-only object that contains field information.
ViewFields | ViewFields is a collection of ViewField objects.
ViewInfo | A data-only object that can be retrieved from the Aptify application object that contains a view's properties. ViewInfo is a data-only object. All properties access data members in the class.
WeakReference<ItemType> | This Subclasses WeakReference`1 as a Generic.

Interfaces

Interface | Description
IAptifyAction | The IAptifyAction interface must be implemented by all Aptify Wizards that are configured using the EntityActions Subtype.
IAptifyObjectViewer | Defines Method and Properties for an object that needs to display Generic Entity Object viewer.
IAptifyViewDialog |
IStatus | This interface should be implemented by objects that can raise status events as they process.

Structures

Structure | Description
ApplicationServicesForm.oApplicationUserInfo |
ApplicationsForm.oApplicationInfo |
CommandStringParameter |
EntityAttributePossibleValue |
EntityFieldPermission |
EntityPermissions |
EntityPlugIn |
EntityStoredProcedures |
ViewInfo.ViewEmailRecipient |

Delegates

Delegate | Description
AptifyAttachments.StatusUpdateEventHandler |
AptifyMessage.MessageReceivedEventHandler |
StatusChangedEventHandler | Used to send status updates from long running processes.

Enumerations

Enumeration | Description
AptifyApplication.ApplicationStatus |
AptifyDataFieldType |
AttachmentOperation |
AttachmentSubOperation |
EntityPermissionType |
EntityPlugInType |
FindMode |
ReservedSQLParser.SQLTokenType |
SQLClauseType | Different types of SQL Clauses such as SELECT, WHERE, etc.
SQLPageMethod | This enumerated type tracks the different methods of creating Paging SQL to turn a SELECT statement into a page-based SQL call.
ViewFieldAlignment |
ViewFieldBorderStyle |
ViewFieldFormatCategory |
ViewFieldFormatNegativeNum |
ViewInfo.ViewAutoRefreshMode |
ViewInfo.ViewEmailRecipientType |
ViewInfo.ViewOutputMode |
ViewInfo.ViewOutputType |


ApplicationServicesForm Class

For a list of all members of this type, see ApplicationServicesForm Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
ApplicationServicesForm

public class ApplicationServicesForm : Form

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyApplication (in AptifyApplication.dll)

See Also

ApplicationServicesForm Members | Aptify.Framework.Application Namespace


ApplicationServicesForm Members

ApplicationServicesForm overview

Public Instance Constructors

ApplicationServicesForm Constructor Initializes a new instance of the ApplicationServicesForm class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationID |
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UserEntitys |
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ApplicationServicesForm Class | Aptify.Framework.Application Namespace


ApplicationServicesForm Constructor

Initializes a new instance of the ApplicationServicesForm class.

public ApplicationServicesForm();

See Also

ApplicationServicesForm Class | Aptify.Framework.Application Namespace


ApplicationServicesForm Properties

The properties of the ApplicationServicesForm class are listed below. For a complete list of ApplicationServicesForm class members, see the ApplicationServicesForm Members topic.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationID |
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UserEntitys |
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

ApplicationServicesForm Class | Aptify.Framework.Application Namespace


ApplicationID Property

Aptify 5.0 Software Development Kit (SDK)

ApplicationServicesForm.ApplicationID Property

public Int64 ApplicationID {get;}

See Also

ApplicationServicesForm Class | Aptify.Framework.Application Namespace


UserEntitys Property

Aptify 5.0 Software Development Kit (SDK)

ApplicationServicesForm.UserEntitys Property

public oApplicationUserInfo[] UserEntitys {get;}

See Also

ApplicationServicesForm Class | Aptify.Framework.Application Namespace


ApplicationServicesForm Methods

The methods of the ApplicationServicesForm class are listed below. For a complete list of ApplicationServicesForm class members, see the ApplicationServicesForm Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ApplicationServicesForm Class | Aptify.Framework.Application Namespace


ApplicationServicesForm.Config Method

public void Config(
AptifyApplication Application,
Int64 ApplicationID
);

See Also

ApplicationServicesForm Class | Aptify.Framework.Application Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

ApplicationServicesForm.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

ApplicationServicesForm Class | Aptify.Framework.Application Namespace


ApplicationServicesForm.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

ApplicationServicesForm Class | Aptify.Framework.Application Namespace | ApplicationServicesForm.Dispose Overload List


ApplicationServicesForm.OnResize Method

protected override void OnResize(
EventArgs e
);

See Also

ApplicationServicesForm Class | Aptify.Framework.Application Namespace


ApplicationServicesForm.oApplicationUserInfo Structure

For a list of all members of this type, see ApplicationServicesForm.oApplicationUserInfo Members.

System.Object
ValueType
ApplicationServicesForm.oApplicationUserInfo

public struct ApplicationServicesForm.oApplicationUserInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyApplication (in AptifyApplication.dll)

See Also

ApplicationServicesForm.oApplicationUserInfo Members | Aptify.Framework.Application Namespace


ApplicationServicesForm.oApplicationUserInfo Members

ApplicationServicesForm.oApplicationUserInfo overview

Public Instance Fields

bInRibbon
i64ServiceID

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

ApplicationServicesForm.oApplicationUserInfo Structure | Aptify.Framework.Application Namespace


ApplicationServicesForm.oApplicationUserInfo Fields

The fields of the ApplicationServicesForm.oApplicationUserInfo structure are listed below. For a complete list of ApplicationServicesForm.oApplicationUserInfo structure members, see the ApplicationServicesForm.oApplicationUserInfo Members topic.

Public Instance Fields

bInRibbon
i64ServiceID

See Also

ApplicationServicesForm.oApplicationUserInfo Structure | Aptify.Framework.Application Namespace


ApplicationServicesForm.oApplicationUserInfo.bInRibbon Field

public bInRibbon bInRibbon;

See Also

ApplicationServicesForm.oApplicationUserInfo Class | Aptify.Framework.Application Namespace


ApplicationServicesForm.oApplicationUserInfo.i64ServiceID Field

public i64ServiceID i64ServiceID;

See Also

ApplicationServicesForm.oApplicationUserInfo Class | Aptify.Framework.Application Namespace


ApplicationsForm Class

For a list of all members of this type, see ApplicationsForm Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
ApplicationsForm

public class ApplicationsForm : Form

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyApplication (in AptifyApplication.dll)

See Also

ApplicationsForm Members | Aptify.Framework.Application Namespace


ApplicationsForm Members

ApplicationsForm overview

Public Instance Constructors

ApplicationsForm Constructor Initializes a new instance of the ApplicationsForm class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationIDs |
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ApplicationsForm Class | Aptify.Framework.Application Namespace


ApplicationsForm Constructor

Initializes a new instance of the ApplicationsForm class.

public ApplicationsForm();

See Also

ApplicationsForm Class | Aptify.Framework.Application Namespace


ApplicationsForm Properties

The properties of the ApplicationsForm class are listed below. For a complete list of ApplicationsForm class members, see the ApplicationsForm Members topic.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationIDs |
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

ApplicationsForm Class | Aptify.Framework.Application Namespace


ApplicationIDs Property

Aptify 5.0 Software Development Kit (SDK)

ApplicationsForm.ApplicationIDs Property

public oApplicationInfo[] ApplicationIDs {get;}

See Also

ApplicationsForm Class | Aptify.Framework.Application Namespace


ApplicationsForm Methods

The methods of the ApplicationsForm class are listed below. For a complete list of ApplicationsForm class members, see the ApplicationsForm Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ApplicationsForm Class | Aptify.Framework.Application Namespace


ApplicationsForm.Config Method

public void Config(
AptifyApplication Application
);

See Also

ApplicationsForm Class | Aptify.Framework.Application Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

ApplicationsForm.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

ApplicationsForm Class | Aptify.Framework.Application Namespace


ApplicationsForm.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

ApplicationsForm Class | Aptify.Framework.Application Namespace | ApplicationsForm.Dispose Overload List


ApplicationsForm.OnResize Method

protected override void OnResize(
EventArgs e
);

See Also

ApplicationsForm Class | Aptify.Framework.Application Namespace


ApplicationsForm.oApplicationInfo Structure

For a list of all members of this type, see ApplicationsForm.oApplicationInfo Members.

System.Object
ValueType
ApplicationsForm.oApplicationInfo

public struct ApplicationsForm.oApplicationInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyApplication (in AptifyApplication.dll)

See Also

ApplicationsForm.oApplicationInfo Members | Aptify.Framework.Application Namespace


ApplicationsForm.oApplicationInfo Members

ApplicationsForm.oApplicationInfo overview

Public Instance Fields

bInAppTool
bInRibbon
i64ApplicationID

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

ApplicationsForm.oApplicationInfo Structure | Aptify.Framework.Application Namespace


ApplicationsForm.oApplicationInfo Fields

The fields of the ApplicationsForm.oApplicationInfo structure are listed below. For a complete list of ApplicationsForm.oApplicationInfo structure members, see the ApplicationsForm.oApplicationInfo Members topic.

Public Instance Fields

bInAppTool
bInRibbon
i64ApplicationID

See Also

ApplicationsForm.oApplicationInfo Structure | Aptify.Framework.Application Namespace


ApplicationsForm.oApplicationInfo.bInAppTool Field

public bInAppTool bInAppTool;

See Also

ApplicationsForm.oApplicationInfo Class | Aptify.Framework.Application Namespace


ApplicationsForm.oApplicationInfo.bInRibbon Field

public bInRibbon bInRibbon;

See Also

ApplicationsForm.oApplicationInfo Class | Aptify.Framework.Application Namespace


ApplicationsForm.oApplicationInfo.i64ApplicationID Field

public i64ApplicationID i64ApplicationID;

See Also

ApplicationsForm.oApplicationInfo Class | Aptify.Framework.Application Namespace


AptifyApplication Class

Main object for retrieving a GE, meta data, views, plug ins, and displaying records. This object is the focal point for data and visual interaction with the application. It is responsible for loading the appropriate customized objects based upon their meta data. It provides the basis for using the supporting objects that provide greater detail. It is a source for application meta data. It is a utility object. It is a class factory for building Generic Entity objects. Note that it provides similar functionality to the Data Browser Information Object (DMInfo) provided in prior versions of the product.

For a list of all members of this type, see AptifyApplication Members.

System.Object
AptifyApplication

public class AptifyApplication

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

Dim oApp As New Aptify.Framework.Application.AptifyApplication

For Each sEntityName As String In oApp.GetEntityList
    Dim sEntityDB As String = oApp.GetEntityBaseDatabase(sEntityName)
    Debug.WriteLine(sEntityDB)
Next

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyApplication (in AptifyApplication.dll)

See Also

AptifyApplication Members | Aptify.Framework.Application Namespace


AptifyApplication Members

AptifyApplication overview

Public Static Methods

GetRegistryValue | Returns a single value from the registry.
LogWrite | Writes a value to a specified log file.

Public Instance Constructors

AptifyApplication Overloaded. Initializes a new instance of the AptifyApplication class.

Public Instance Properties

Command | The command object is used as a flexible mechanism that allows developers to pass information around from object to object.
CommandString | The command string is used to quickly populate the Command Property.
Entity | Overloaded. Retrieves an EntityInfo object corresponding to the requested Entity Name.
GetEntityFieldList | Overloaded. Returns an array of all of the field names for the specified entity.
GetEntityList | Returns an array of all of the top level entities.
GlobalBroadcastChangeFlag |
GlobalContext | Acts as a central repository for information that needs to be shared across objects in the same Application. This is because the GlobalContext object is shared across all Application Objects.
GlobalFireEventsFlag |
GlobalMessageCoordinator | This is a shortcut property to the MessageCoordinator that is associated with the GlobalContext. This means that all listeners associated with the MessageCoordinator can possibly hear all of the messages passed in the system.
ReservedSQLParser | Allows a developer to determine if a SQL statement or SQL keyword contain reserved words.
UserCredentials | This is an instance level Property that gives a developer access to the Application Object's UserCredential. The UserCredential property is populated from an existing UserCredential or it creates a new one when the Application's Instance is created.
View | Retrieves an ViewInfo object corresponding to the requested View ID.

Public Instance Methods

CreateInstanceFromRepository |
DeleteEntityRecord | Overloaded. Deletes an existing Entity record.
DeleteEntityRecords | Overloaded. Deletes existing Entity records.
DisplayApplicationsDialog | Overloaded. Displays a list of available applications.
DisplayApplicationServicesDialog | Overloaded. Displays a list of available services for an application.
DisplayConfigurationOptions | Overloaded. This method will display a configuration options dialog box to the user
DisplayEntityFindDialog | Overloaded. Opens a Find dialog for the specified entity.
DisplayEntityPopupList | This method displays a popup window containing a number of records (the records are displayed in an Entity List View control).
DisplayEntityProperties | Overloaded. Displays the Service Properties dialog.
DisplayEntityRecord | Overloaded. Opens an existing record in its form/form template.
DisplayEntityRecordDialog | Overloaded. Opens an existing record in its form/form template in dialog mode.
DisplayFindItems | Overloaded. Open the Find Items dialog box for the specified entity.
DisplayNewEntityRecord | Overloaded. Opens a new entity record.
DisplayNewViewDialog | Overloaded. Opens a new Views record in a dialog form for the specified entity.
DisplayReadOnlyObjectViewerDialog | Overloaded. Opens a record in ReadOnly mode in the Object Viewer.
DisplaySubTypeEntityRecordDialog | Overloaded. Opens an existing SubType record in its form/form template.
DisplayViewRecordDialog | Overloaded. Opens a view record in a dialog form.
EntityRecordExists | Overloaded. This method does checks to see if the specified record ID exists in the entity defined by the EntityName parameter. If it does the method returns True, otherwise it returns False.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetApplicationInfo | This method returns an APplicationInfo structure that carries the commonly required application information
GetDefaultFormIcon | Returns the Default Form Icon to be used for Branding Purpose. EntityName.
GetEntityAttachmentPermissions | Returns the permissions the user has for this entity.
GetEntityAttribute | Overloaded. This method retrieves the value associated with an entity attribute.
GetEntityBaseDatabase | Overloaded. Returns the name of the base database based on the EntityName.
GetEntityBaseTable | Overloaded. Returns the name of the base table based on the EntityName.
GetEntityBaseView | Overloaded. Returns the Name of an Entity's base view.
GetEntityDependencies | Overloaded. Returns a collection that has a list of records that depend on this record.
GetEntityID | Returns the EntityID based on the EntityName.
GetEntityName | Overloaded. This will return the Entity Name that was specified in the command object or through a commandstring.
GetEntityObject | Returns a configured instance of an Entity's wrapper.
GetEntityPermissions | Overloaded. Returns the permissions the user has for this entity.
GetEntityPlugIn | Overloaded. Returns a custom plug-in assembly.
GetEntityRecordIDFromRecordName | Overloaded. This method returns the record ID for a specified record given an Entity Name and the Record Name.
GetEntityRecordName | Overloaded. This method returns the record name for a specified Entity and record ID.
GetEntityStoredProcedures | Overloaded. Returns the collection of stored procedure names a user has for an entity.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
GetUserValue | This method returns a user profile value from the database. Use it to determine user preferences using Application ID and Sequence parameters. If the User Value is not found, the DefaultValue parameter is returned.
LoadBrandIcon | Overloaded. Replaces the Form Icon with default Icon or Branding Icon as per requirement.
PrintEntityRecord | Overloaded. Prints a given record in an entity.
PrintRecordset | Allows for the printing of a SQL statement that returns a single record set.
PrintView | Allows for printing records from the view.
RefreshEntityMetaData | Flushes the cache of entity meta data and re-retrieves.
SetUserValue | This method is responsible for saving a user profile value into the database for the specified Application ID and Sequence provided. If there is an existing Application ID and Sequence matching for the current user, that row is updated, otherwise a new row in the UserValues entity is created.
ShowEntityDependencies | Overloaded. Shows a collection that has a list of records that depend on this record.
ShowRecordHistory | Overloaded. Displays a list of record changes.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetUserValueDataTable | This method returns a datatable with a row of data representing a user profile value from the database. If a row is not found matching the specified ApplicationID and Sequence, Nothing is returned.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace


AptifyApplication Constructor

Allows the system to provide the user credentials and to not set the credentials as the default credential.

Overload List

Allows the system to provide the user credentials and to not set the credentials as the default credential.

public AptifyApplication();

Allows the system to provide the user credentials and does not set them as the default credential.

public AptifyApplication(UserCredentials);

Allows the user to specify the UserCredential to use and whether or not the system should set this credential as the default credential.

public AptifyApplication(UserCredentials,Boolean);

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace


AptifyApplication Constructor ()

Allows the system to provide the user credentials and to not set the credentials as the default credential.

public AptifyApplication();

Remarks

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication Constructor Overload List


AptifyApplication Constructor (UserCredentials)

Allows the system to provide the user credentials and does not set them as the default credential.

public AptifyApplication(
UserCredentials UserCredentials
);

Parameters

UserCredentials
An instantiated UserCredentials object.

Remarks

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication Constructor Overload List


AptifyApplication Constructor (UserCredentials, Boolean)

Allows the user to specify the UserCredential to use and whether or not the system should set this credential as the default credential.

public AptifyApplication(
UserCredentials UserCredentials,
Boolean bSetDefault
);

Parameters

UserCredentials
An instantiated UserCredentials object.
bSetDefault
True if you would like the UserCredentials to be used as the default.

Remarks

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication Constructor Overload List


AptifyApplication Properties

The properties of the AptifyApplication class are listed below. For a complete list of AptifyApplication class members, see the AptifyApplication Members topic.

Public Instance Properties

Command | The command object is used as a flexible mechanism that allows developers to pass information around from object to object.
CommandString | The command string is used to quickly populate the Command Property.
Entity | Overloaded. Retrieves an EntityInfo object corresponding to the requested Entity Name.
GetEntityFieldList | Overloaded. Returns an array of all of the field names for the specified entity.
GetEntityList | Returns an array of all of the top level entities.
GlobalBroadcastChangeFlag |
GlobalContext | Acts as a central repository for information that needs to be shared across objects in the same Application. This is because the GlobalContext object is shared across all Application Objects.
GlobalFireEventsFlag |
GlobalMessageCoordinator | This is a shortcut property to the MessageCoordinator that is associated with the GlobalContext. This means that all listeners associated with the MessageCoordinator can possibly hear all of the messages passed in the system.
ReservedSQLParser | Allows a developer to determine if a SQL statement or SQL keyword contain reserved words.
UserCredentials | This is an instance level Property that gives a developer access to the Application Object's UserCredential. The UserCredential property is populated from an existing UserCredential or it creates a new one when the Application's Instance is created.
View | Retrieves an ViewInfo object corresponding to the requested View ID.

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace


Command Property

Aptify 5.0 Software Development Kit (SDK)

AptifyApplication.Command Property

The command object is used as a flexible mechanism that allows developers to pass information around from object to object.

public CommandParser Command {get;}

Property Value

An instantiated CommandParser

Remarks

Example

    Dim oApplication As New Aptify.Framework.Application.AptifyApplication

    oApplication.Command.CommandType = "Open"
    oApplication.Command.EntityName = "Entities"
    oApplication.Command.RecordID = 80

    System.Windows.Forms.MessageBox.Show(oApplication.Command.CommandString())

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace


CommandString Property

Aptify 5.0 Software Development Kit (SDK)

AptifyApplication.CommandString Property

The command string is used to quickly populate the Command Property.

public String CommandString {get; set;}

Property Value

A Command string that will be parsed by a command parser.

Remarks

Example

Dim oApplication As New Aptify.Framework.Application.AptifyApplication

oApplication.CommandString = "Entities|OPEN:80"
System.Windows.Forms.MessageBox.Show(oApplication.Command.EntityName)

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace


EntityInfo Property

Aptify 5.0 Software Development Kit (SDK)

AptifyApplication.EntityInfo Property

Retrieves an EntityInfo object corresponding to the requested Entity ID.

Overload List

Retrieves an EntityInfo object corresponding to the requested Entity ID.

public EntityInfo this[Int64] {get;}

Retrieves an EntityInfo object corresponding to the requested Entity Name.

public EntityInfo this[String] {get;}

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace


Entity Property (Int64)

Aptify 5.0 Software Development Kit (SDK)

AptifyApplication.Entity Property (Int64)

Retrieves an EntityInfo object corresponding to the requested Entity ID.

public EntityInfo this[
Int64 EntityID
] {get;}

Parameters

EntityID
The ID value for an existing Entity.

Property Value

If an Entity with EntityID is found then an EntityInfo object will be returned. If not then a null value will be returned.

Remarks

This property caches data as it retrieves it so subsequent calls to retrieve the same entity are quick.

Example

    Dim oApplication As New Aptify.Framework.Application.AptifyApplication

    Dim oEntityInfo As Aptify.Framework.Application.EntityInfo

    oEntityInfo = oApplication.Entity(235) ' 235 is a sample for whatever the Entity ID actually might be

    If Not oEntityInfo Is Nothing Then
         'the entity was found
    Else
         'the entity was not found
    End If

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.EntityInfo Overload List


Entity Property (String)

Aptify 5.0 Software Development Kit (SDK)

AptifyApplication.Entity Property (String)

Retrieves an EntityInfo object corresponding to the requested Entity Name.

public EntityInfo this[
String EntityName
] {get;}

Parameters

EntityName
A name of an existing Entity. The empty string will never be a valid entity name.

Property Value

If an Entity with EntityName is found then an EntityInfo object will be returned. If not then a null value will be returned.

Remarks

This property caches data as it retrieves it so subsequent calls to retrieve the same entity are quick.

Example

    Dim oApplication As New Aptify.Framework.Application.AptifyApplication

    Dim oEntityInfo As Aptify.Framework.Application.EntityInfo

    oEntityInfo = oApplication.Entity("Entities")

    If Not oEntityInfo Is Nothing Then
         'the entity was found
    Else
         'the entity was not found
    End If

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.EntityInfo Overload List


String[] Property

Aptify 5.0 Software Development Kit (SDK)

AptifyApplication.String[] Property

Returns an array of all of the field names for the specified entity.

Overload List

Returns an array of all of the field names for the specified entity.

public String[] this[Int64] {get;}

Returns an array of all of the field names for the specified entity.

public String[] this[String] {get;}

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace


GetEntityFieldList Property (Int64)

Aptify 5.0 Software Development Kit (SDK)

AptifyApplication.GetEntityFieldList Property (Int64)

Returns an array of all of the field names for the specified entity.

public String[] this[
Int64 ID
] {get;}

Parameters

ID

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.String[] Overload List


GetEntityFieldList Property (String)

Aptify 5.0 Software Development Kit (SDK)

AptifyApplication.GetEntityFieldList Property (String)

Returns an array of all of the field names for the specified entity.

public String[] this[
String Name
] {get;}

Parameters

Name

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.String[] Overload List


GetEntityList Property

Aptify 5.0 Software Development Kit (SDK)

AptifyApplication.GetEntityList Property

Returns an array of all of the top level entities.

public String[] GetEntityList {get;}

Property Value

Returns an array of all of the top level entities.

Example

Dim oApplication As New Aptify.Framework.Application.AptifyApplication

Dim arrEntities() As String = oApplication.GetEntityList()
For Each sName As String In arrEntities
    'do something with the entity name
Next

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace


GlobalBroadcastChangeFlag Property

Aptify 5.0 Software Development Kit (SDK)

AptifyApplication.GlobalBroadcastChangeFlag Property

public Boolean GlobalBroadcastChangeFlag {get; set;}

Property Value

Remarks

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace


GlobalContext Property

Aptify 5.0 Software Development Kit (SDK)

AptifyApplication.GlobalContext Property

Acts as a central repository for information that needs to be shared across objects in the same Application. This is because the GlobalContext object is shared across all Application Objects.

public AptifyContext GlobalContext {get;}

Property Value

The Global Aptify Context

Remarks

Example

    Dim oApplication As New Aptify.Framework.Application.AptifyApplication

    'Add a Temp value to the global context's properties
    oApplication.GlobalContext.Properties.Add("Value", "Key")

    'we should consume this value somewhere else in the program
    Dim sValue As String
    sValue = CStr(oApplication.GlobalContext.Properties.Item("Key"))

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace


GlobalFireEventsFlag Property

Aptify 5.0 Software Development Kit (SDK)

AptifyApplication.GlobalFireEventsFlag Property

public Boolean GlobalFireEventsFlag {get; set;}

Property Value

Remarks

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace


GlobalMessageCoordinator Property

Aptify 5.0 Software Development Kit (SDK)

AptifyApplication.GlobalMessageCoordinator Property

This is a shortcut property to the MessageCoordinator that is associated with the GlobalContext. This means that all listeners associated with the MessageCoordinator can possibly hear all of the messages passed in the system.

public AptifyMessageCoordinator GlobalMessageCoordinator {get;}

Property Value

Remarks

Example

 Dim oApplication As New Aptify.Framework.Application.AptifyApplication

 System.Windows.Forms.MessageBox.Show(CStr(oApplication.GlobalMessageCoordinator.ListenerCount))

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace


ReservedSQLParser Property

Aptify 5.0 Software Development Kit (SDK)

AptifyApplication.ReservedSQLParser Property

Allows a developer to determine if a SQL statement or SQL keyword contain reserved words.

public ReservedSQLParser ReservedSQLParser {get;}

Example

Dim oApplication As New Aptify.Framework.Application.AptifyApplication

Windows.Forms.MessageBox.Show(CStr(oApplication.ReservedSQLParser.IsReservedWord("Select")))
Windows.Forms.MessageBox.Show(CStr(oApplication.ReservedSQLParser.IsReservedWord("Hello")))
Windows.Forms.MessageBox.Show(CStr(oApplication.ReservedSQLParser.TokenType("Select").ToString))
Windows.Forms.MessageBox.Show(CStr(oApplication.ReservedSQLParser.TokenType("Hello").ToString))
Windows.Forms.MessageBox.Show(CStr(oApplication.ReservedSQLParser.TokenType("Select * from aptify..vwEntities").ToString))

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace


UserCredentials Property

Aptify 5.0 Software Development Kit (SDK)

AptifyApplication.UserCredentials Property

This is an instance level Property that gives a developer access to the Application Object's UserCredential. The UserCredential property is populated from an existing UserCredential or it creates a new one when the Application's Instance is created.

public UserCredentials UserCredentials {get;}

Property Value

An instantiated User Credential.

Remarks

If you need access to a UserCredentials Object, Aptify recommends that this property be used to create one.

Example

Dim oApplication As New Aptify.Framework.Application.AptifyApplication

System.Windows.Forms.MessageBox.Show(oApplication.UserCredentials.EntitiesDatabase)

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace


View Property

Aptify 5.0 Software Development Kit (SDK)

AptifyApplication.View Property

Retrieves an ViewInfo object corresponding to the requested View ID.

public ViewInfo this[
Int64 ViewID,
Boolean ForceRefresh
] {get;}

Parameters

ViewID
The Id of the View record that should be returned
ForceRefresh
If this is true then the cache will be bypassed and refreshed.

Property Value

If an Entity with ViewID is found then an ViewInfo object will be returned. If not, then a null value will be returned.

Remarks

This property will only return a user defined view, it does not return items that are defined as views in DBObjects. This property caches data as it retrieves it so subsequent calls to retrieve the same View are quick. The Force Refresh parameter allows the user to force the Application object to go to the database and get the view, refreshing the viewinfo cache when it is finished.

Example

    Dim oApplication As New Aptify.Framework.Application.AptifyApplication

    Dim oViewInfo As Aptify.Framework.Application.ViewInfo

    Dim lViewID As Long = oApplication.GetEntityRecordIDFromRecordName("Views", "All Views")

    oViewInfo = oApplication.View(lViewID)
    System.Windows.Forms.MessageBox.Show(oViewInfo.ViewSQL)

    'This is what happens if you try to return a system view.
    '        lViewID = oApplication.GetEntityRecordIDFromRecordName("Database Objects", oApplication.GetEntityBaseView("Entities"))
    '        oViewInfo = oApplication.View(lViewID)
    '        System.Windows.Forms.MessageBox.Show(oViewInfo.ViewSQL)

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace


AptifyApplication Methods

The methods of the AptifyApplication class are listed below. For a complete list of AptifyApplication class members, see the AptifyApplication Members topic.

Public Static Methods

GetRegistryValue | Returns a single value from the registry.
LogWrite | Writes a value to a specified log file.

Public Instance Methods

CreateInstanceFromRepository |
DeleteEntityRecord | Overloaded. Deletes an existing Entity record.
DeleteEntityRecords | Overloaded. Deletes existing Entity records.
DisplayApplicationsDialog | Overloaded. Displays a list of available applications.
DisplayApplicationServicesDialog | Overloaded. Displays a list of available services for an application.
DisplayConfigurationOptions | Overloaded. This method will display a configuration options dialog box to the user
DisplayEntityFindDialog | Overloaded. Opens a Find dialog for the specified entity.
DisplayEntityPopupList | This method displays a popup window containing a number of records (the records are displayed in an Entity List View control).
DisplayEntityProperties | Overloaded. Displays the Service Properties dialog.
DisplayEntityRecord | Overloaded. Opens an existing record in its form/form template.
DisplayEntityRecordDialog | Overloaded. Opens an existing record in its form/form template in dialog mode.
DisplayFindItems | Overloaded. Open the Find Items dialog box for the specified entity.
DisplayNewEntityRecord | Overloaded. Opens a new entity record.
DisplayNewViewDialog | Overloaded. Opens a new Views record in a dialog form for the specified entity.
DisplayReadOnlyObjectViewerDialog | Overloaded. Opens a record in ReadOnly mode in the Object Viewer.
DisplaySubTypeEntityRecordDialog | Overloaded. Opens an existing SubType record in its form/form template.
DisplayViewRecordDialog | Overloaded. Opens a view record in a dialog form.
EntityRecordExists | Overloaded. This method does checks to see if the specified record ID exists in the entity defined by the EntityName parameter. If it does the method returns True, otherwise it returns False.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetApplicationInfo | This method returns an APplicationInfo structure that carries the commonly required application information
GetDefaultFormIcon | Returns the Default Form Icon to be used for Branding Purpose. EntityName.
GetEntityAttachmentPermissions | Returns the permissions the user has for this entity.
GetEntityAttribute | Overloaded. This method retrieves the value associated with an entity attribute.
GetEntityBaseDatabase | Overloaded. Returns the name of the base database based on the EntityName.
GetEntityBaseTable | Overloaded. Returns the name of the base table based on the EntityName.
GetEntityBaseView | Overloaded. Returns the Name of an Entity's base view.
GetEntityDependencies | Overloaded. Returns a collection that has a list of records that depend on this record.
GetEntityID | Returns the EntityID based on the EntityName.
GetEntityName | Overloaded. This will return the Entity Name that was specified in the command object or through a commandstring.
GetEntityObject | Returns a configured instance of an Entity's wrapper.
GetEntityPermissions | Overloaded. Returns the permissions the user has for this entity.
GetEntityPlugIn | Overloaded. Returns a custom plug-in assembly.
GetEntityRecordIDFromRecordName | Overloaded. This method returns the record ID for a specified record given an Entity Name and the Record Name.
GetEntityRecordName | Overloaded. This method returns the record name for a specified Entity and record ID.
GetEntityStoredProcedures | Overloaded. Returns the collection of stored procedure names a user has for an entity.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
GetUserValue | This method returns a user profile value from the database. Use it to determine user preferences using Application ID and Sequence parameters. If the User Value is not found, the DefaultValue parameter is returned.
LoadBrandIcon | Overloaded. Replaces the Form Icon with default Icon or Branding Icon as per requirement.
PrintEntityRecord | Overloaded. Prints a given record in an entity.
PrintRecordset | Allows for the printing of a SQL statement that returns a single record set.
PrintView | Allows for printing records from the view.
RefreshEntityMetaData | Flushes the cache of entity meta data and re-retrieves.
SetUserValue | This method is responsible for saving a user profile value into the database for the specified Application ID and Sequence provided. If there is an existing Application ID and Sequence matching for the current user, that row is updated, otherwise a new row in the UserValues entity is created.
ShowEntityDependencies | Overloaded. Shows a collection that has a list of records that depend on this record.
ShowRecordHistory | Overloaded. Displays a list of record changes.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetUserValueDataTable | This method returns a datatable with a row of data representing a user profile value from the database. If a row is not found matching the specified ApplicationID and Sequence, Nothing is returned.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace


AptifyApplication.CreateInstanceFromRepository Method

public object CreateInstanceFromRepository(
String ObjectRepositoryObject,
String AssemblyName,
String TypeName
);

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace


DeleteEntityRecord Method

Aptify 5.0 Software Development Kit (SDK)

AptifyApplication.DeleteEntityRecord Method

Deletes an existing Entity record.

Overload List

Deletes an existing Entity record.

public bool DeleteEntityRecord(String,Int64);

Deletes an existing Entity record.

public bool DeleteEntityRecord(String,Int64,ref String&);

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace


AptifyApplication.DeleteEntityRecord Method (String, Int64)

Deletes an existing Entity record.

public bool DeleteEntityRecord(
String EntityName,
Int64 RecordID
);

Parameters

EntityName
The name of the entity for which the record is to be deleted.
RecordID
The ID of the record that is to be deleted.

Return Value

True if the record was succesfully deleted. False if the record was not deleted.

Remarks

If the record was not deleted then LastUserError

Example

'this example requires a reference to the AptifyGenericEntityBase assembly
Dim oApplication As New Aptify.Framework.Application.AptifyApplication
Dim oGE As Aptify.Framework.BusinessLogic.GenericEntity.AptifyGenericEntityBase

oGE = oApplication.GetEntityObject("Culture String Categories", -1)
oGE.SetValue("Name", "Test")
oGE.Save()
If oGE.Save(True) Then
    oApplication.DeleteEntityRecord("Culture String Categories", oGE.RecordID)
End If

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.DeleteEntityRecord Overload List


AptifyApplication.DeleteEntityRecord Method (String, Int64, String&)

Deletes an existing Entity record.

public bool DeleteEntityRecord(
String EntityName,
Int64 RecordID,
ref String& ErrorString
);

Parameters

EntityName
The name of the entity for which the record is to be deleted.
RecordID
The ID of the record that is to be deleted.
ErrorString
If an error occurs then this parameter will be populated with its message.

Return Value

True if the record was succesfully deleted. False if the record was not deleted.

Remarks

If the record was not deleted then LastUserError

Example

'this example requires a reference to the AptifyGenericEntityBase assembly
Dim oApplication As New Aptify.Framework.Application.AptifyApplication
Dim oGE As Aptify.Framework.BusinessLogic.GenericEntity.AptifyGenericEntityBase

oGE = oApplication.GetEntityObject("Culture String Categories", -1)
oGE.SetValue("Name", "Test")
oGE.Save()

If oGE.Save(True) Then
    Dim sError As String
    If Not oApplication.DeleteEntityRecord("Culture String Categories", oGE.RecordID, sError) Then
        Windows.Forms.MessageBox.Show(sError, "Error Box", MessageBoxButtons.OK, MessageBoxIcon.Error)
    End If
End If

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.DeleteEntityRecord Overload List


DeleteEntityRecords Method

Aptify 5.0 Software Development Kit (SDK)

AptifyApplication.DeleteEntityRecords Method

Deletes existing Entity records.

Overload List

Deletes existing Entity records.

public void DeleteEntityRecords(String,Int64[],ref String&);

Deletes existing Entity records.

public void DeleteEntityRecords(String,String);

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace


AptifyApplication.DeleteEntityRecords Method (String, Int64[], String&)

Deletes existing Entity records.

public void DeleteEntityRecords(
String EntityName,
Int64[] RecordIDs,
ref String& ErrorString
);

Parameters

EntityName
The name of the entity for which the record is to be deleted.
RecordIDs
An Array of Int64, that contains all of the IDs that are to be deleted. RecordIDs cannot be null.
ErrorString
If an error occurs then this parameter will be populated with its message.

Remarks

Example

'this example requires a reference to the AptifyGenericEntityBase assembly
Dim oApplication As New Aptify.Framework.Application.AptifyApplication
Dim oGE As Aptify.Framework.BusinessLogic.GenericEntity.AptifyGenericEntityBase

oGE = oApplication.GetEntityObject("Culture String Categories", -1)
oGE.SetValue("Name", "Test")
oGE.Save()

If oGE.Save(True) Then
    Try
        oApplication.DeleteEntityRecords("Culture String Categories", New Long() {oGE.RecordID}, Nothing)
    Catch ex As Aptify.Framework.BusinessLogic.GenericEntity.AptifyGenericEntityRecordNotFoundException
        Windows.Forms.MessageBox.Show(ex.Message, "Error Box", MessageBoxButtons.OK, MessageBoxIcon.Error)
    End Try
End If

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.DeleteEntityRecords Overload List


AptifyApplication.DeleteEntityRecords Method (String, String)

Deletes existing Entity records.

public void DeleteEntityRecords(
String EntityName,
String SQL
);

Parameters

EntityName
The name of the entity for which the record is to be deleted.
SQL
A SQL Statement that will identify the records to be deleted.

Remarks

This method has not been implemented yet.

Exceptions

Exception Type | Condition
NotImplementedException | This is always thrown.

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.DeleteEntityRecords Overload List


DisplayApplicationsDialog Method

Aptify 5.0 Software Development Kit (SDK)

AptifyApplication.DisplayApplicationsDialog Method

Displays a list of available applications.

Overload List

Displays a list of available applications.

public DialogResult DisplayApplicationsDialog();

Displays a list of available applications.

public DialogResult DisplayApplicationsDialog(Form);

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace


AptifyApplication.DisplayApplicationsDialog Method ()

Displays a list of available applications.

public DialogResult DisplayApplicationsDialog();

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.DisplayApplicationsDialog Overload List


AptifyApplication.DisplayApplicationsDialog Method (Form)

Displays a list of available applications.

public DialogResult DisplayApplicationsDialog(
Form parentForm
);

Parameters

parentForm

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.DisplayApplicationsDialog Overload List


DisplayApplicationServicesDialog Method

Aptify 5.0 Software Development Kit (SDK)

AptifyApplication.DisplayApplicationServicesDialog Method

Displays a list of available services for an application.

Overload List

Displays a list of available services for an application.

public DialogResult DisplayApplicationServicesDialog(Int64);

Displays a list of available services for an application.

public DialogResult DisplayApplicationServicesDialog(Int64,Form);

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace


AptifyApplication.DisplayApplicationServicesDialog Method (Int64)

Displays a list of available services for an application.

public DialogResult DisplayApplicationServicesDialog(
Int64 ApplicationID
);

Parameters

ApplicationID

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.DisplayApplicationServicesDialog Overload List


AptifyApplication.DisplayApplicationServicesDialog Method (Int64, Form)

Displays a list of available services for an application.

public DialogResult DisplayApplicationServicesDialog(
Int64 ApplicationID,
Form parentForm
);

Parameters

ApplicationID
parentForm

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.DisplayApplicationServicesDialog Overload List


DisplayConfigurationOptions Method

Aptify 5.0 Software Development Kit (SDK)

AptifyApplication.DisplayConfigurationOptions Method

This method will display a configuration options dialog box to the user

Overload List

This method will display a configuration options dialog box to the user

public virtual void DisplayConfigurationOptions();

public virtual void DisplayConfigurationOptions(Form);

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace


AptifyApplication.DisplayConfigurationOptions Method ()

This method will display a configuration options dialog box to the user

public virtual void DisplayConfigurationOptions();

Remarks

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.DisplayConfigurationOptions Overload List


AptifyApplication.DisplayConfigurationOptions Method (Form)

public virtual void DisplayConfigurationOptions(
Form ParentForm
);

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.DisplayConfigurationOptions Overload List


DisplayEntityFindDialog Method

Aptify 5.0 Software Development Kit (SDK)

AptifyApplication.DisplayEntityFindDialog Method

Opens a Find dialog for the specified entity.

Overload List

Opens a Find dialog for the specified entity.

public long DisplayEntityFindDialog(String);

Opens a Find dialog for the specified entity.

public long DisplayEntityFindDialog(String,String);

public long DisplayEntityFindDialog(String,String,String,ref String&);

Opens a Find dialog for the specified entity.

public long DisplayEntityFindDialog(String,String,String,ref String&,Form);

public long DisplayEntityFindDialog(String,String,Form);

public long DisplayEntityFindDialog(String,Form);

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace


AptifyApplication.DisplayEntityFindDialog Method (String)

Opens a Find dialog for the specified entity.

public long DisplayEntityFindDialog(
String EntityName
);

Parameters

EntityName
Name of the entity.

Return Value

Returns the ID of the item that is selected in the Find dialog.

Remarks

For this method, the records that match the search criteria are displayed in the Find dialog's Results tab. This is the method that the system uses when the Find dialog is opened from a record (by clicking the Find button or selecting Find from a record's right-click context menu). The system uses DisplayFindItems Method if the Find operation is launched from the Find Items icon in the Service and View Toolbar or from the Find Items option in the Folder List's context menu.

Example

Dim ID as long = MyApplication.DisplayEntityFindDialog ("Orders")

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.DisplayEntityFindDialog Overload List


AptifyApplication.DisplayEntityFindDialog Method (String, String)

Opens a Find dialog for the specified entity.

public long DisplayEntityFindDialog(
String EntityName,
String HiddenFilter
);

Parameters

EntityName
Name of the entity.
HiddenFilter
T-SQL to be added to narrow the possible search results.

Return Value

Returns the ID of the item that is selected in the Find dialog.

Remarks

For this method, the records that match the search criteria are displayed in the Find dialog's Results tab. This is the method that the system uses when the Find dialog is opened from a record (by clicking the Find button or selecting Find from a record's right-click context menu). The system uses DisplayFindItems Method if the Find operation is launched from the Find Items icon in the Service and View Toolbar or from the Find Items option in the Folder List's context menu.

Example

Dim oApplication As New Aptify.Framework.Application.AptifyApplication
Dim sDisp As String
oApplication.DisplayEntityFindDialog("Culture String Categories", "not id = 0")

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.DisplayEntityFindDialog Overload List


AptifyApplication.DisplayEntityFindDialog Method (String, String, String, String&)

public long DisplayEntityFindDialog(
String EntityName,
String SearchString,
String HiddenFilter,
ref String& RecordDisplayName
);

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.DisplayEntityFindDialog Overload List


AptifyApplication.DisplayEntityFindDialog Method (String, String, String, String&, Form)

Opens a Find dialog for the specified entity.

public long DisplayEntityFindDialog(
String EntityName,
String SearchString,
String HiddenFilter,
ref String& RecordDisplayName,
Form ParentForm
);

Parameters

EntityName
Name of the entity.
SearchString
String to narrow the search results. The base implementation makes this value the value that would occur in the entity's name field.
HiddenFilter
T-SQL to be added to narrow the possible search results.
RecordDisplayName
Field that is displayed to the user.
ParentForm

Return Value

Returns the ID of the item that is selected in the Find dialog.

Remarks

For this method, the records that match the search criteria are displayed in the Find dialog's Results tab. This is the method that the system uses when the Find dialog is opened from a record (by clicking the Find button or selecting Find from a record's right-click context menu). The system uses DisplayFindItems Method if the Find operation is launched from the Find Items icon in the Service and View Toolbar or from the Find Items option in the Folder List's context menu.

Example

Dim oApplication As New Aptify.Framework.Application.AptifyApplication
Dim sDisp As String
oApplication.DisplayEntityFindDialog("Culture String Categories", "French", "id=80", sDisp)

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.DisplayEntityFindDialog Overload List


AptifyApplication.DisplayEntityFindDialog Method (String, String, Form)

public long DisplayEntityFindDialog(
String EntityName,
String HiddenFilter,
Form ParentForm
);

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.DisplayEntityFindDialog Overload List


AptifyApplication.DisplayEntityFindDialog Method (String, Form)

public long DisplayEntityFindDialog(
String EntityName,
Form ParentForm
);

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.DisplayEntityFindDialog Overload List


AptifyApplication.DisplayEntityPopupList Method

This method displays a popup window containing a number of records (the records are displayed in an Entity List View control).

public void DisplayEntityPopupList(
String EntityName,
String Caption,
ref Int64[]& IDs
);

Parameters

EntityName
Name of the entity.
Caption
Parent caption of the dialog form.
IDs
An array of IDs. This parameter must contain at least one ID.

Remarks

The entity and records that will be displayed are specified through the EntityName and IDs parameters to this method. This method is a convenient alternative to constructing a popup viewer form manually. The IDs Parameter cannot be null and must contain at least one ID.

Example

Dim oApplication As New Aptify.Framework.Application.AptifyApplication
oApplication.DisplayEntityPopupList("Culture String Categories", "Culture String Category Caption", New Long() {2, 5, 7, 23})

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace


DisplayEntityProperties Method

Aptify 5.0 Software Development Kit (SDK)

AptifyApplication.DisplayEntityProperties Method

Displays the Service Properties dialog.

Overload List

Displays the Service Properties dialog.

public void DisplayEntityProperties(Int64);

public void DisplayEntityProperties(Int64,Form);

Displays the Service Properties dialog.

public void DisplayEntityProperties(String);

public void DisplayEntityProperties(String,Form);

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace


AptifyApplication.DisplayEntityProperties Method (Int64)

Displays the Service Properties dialog.

public void DisplayEntityProperties(
Int64 EntityID
);

Parameters

EntityID
Id of the Entity.

Remarks

This dialog appears when a user right-clicks a service in the Folder List and selects Properties from the context menu. This dialog displays general information about the entity, including the fields that exist in the entity, recent user activity (list of records created, modified, etc.), and a list of deleted records.

Example

Dim oApplication As New Aptify.Framework.Application.AptifyApplication
oApplication.DisplayEntityProperties(80)

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.DisplayEntityProperties Overload List


AptifyApplication.DisplayEntityProperties Method (Int64, Form)

public void DisplayEntityProperties(
Int64 EntityID,
Form ParentForm
);

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.DisplayEntityProperties Overload List


AptifyApplication.DisplayEntityProperties Method (String)

Displays the Service Properties dialog.

public void DisplayEntityProperties(
String EntityName
);

Parameters

EntityName
Name of the Entity.

Remarks

This dialog appears when a user right-clicks a service in the Folder List and selects Properties from the context menu. This dialog displays general information about the entity, including the fields that exist in the entity, recent user activity (list of records created, modified, etc.), and a list of deleted records.

Example

Dim oApplication As New Aptify.Framework.Application.AptifyApplication
oApplication.DisplayEntityProperties("Entities")

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.DisplayEntityProperties Overload List


AptifyApplication.DisplayEntityProperties Method (String, Form)

public void DisplayEntityProperties(
String EntityName,
Form ParentForm
);

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.DisplayEntityProperties Overload List


DisplayEntityRecord Method

Aptify 5.0 Software Development Kit (SDK)

AptifyApplication.DisplayEntityRecord Method

Opens an existing record in its form/form template.

Overload List

Opens an existing record in its form/form template.

public void DisplayEntityRecord(AptifyGenericEntityBase);

Opens an existing record in its form/form template.

public void DisplayEntityRecord(AptifyGenericEntityBase,Boolean);

Opens an existing record in its form/form template.

public void DisplayEntityRecord(AptifyGenericEntityBase,Boolean,Form);

Opens an existing record in its form/form template.

public void DisplayEntityRecord(String,Int64);

Opens an existing record in its form/form template.

public void DisplayEntityRecord(String,Int64,Boolean);

public void DisplayEntityRecord(String,Int64,Boolean,Form);

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace


AptifyApplication.DisplayEntityRecord Method (AptifyGenericEntityBase)

Opens an existing record in its form/form template.

public void DisplayEntityRecord(
AptifyGenericEntityBase GE
);

Parameters

GE
An object that represents a record in the database.

Remarks

NOT IMPLEMENTED

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.DisplayEntityRecord Overload List


AptifyApplication.DisplayEntityRecord Method (AptifyGenericEntityBase, Boolean)

Opens an existing record in its form/form template.

public void DisplayEntityRecord(
AptifyGenericEntityBase GE,
Boolean UseObjectViewer
);

Parameters

GE
An object that represents a record in the database.
UseObjectViewer
Open up the record in the object viewer. Defaults to false.

Remarks

NOT IMPLEMENTED (If UseObjectBrowser is false.)

Example

    Dim oApplication As New Aptify.Framework.Application.AptifyApplication
    Dim oGE As Aptify.Framework.BusinessLogic.GenericEntity.AptifyGenericEntityBase

    oGE = oApplication.GetEntityObject("Entities", 80)

    'This displays the object viewer and it works
    oApplication.DisplayEntityRecord(oGE, True)

    'This throws a method not implemented
    oApplication.DisplayEntityRecord(oGE, False)

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.DisplayEntityRecord Overload List


AptifyApplication.DisplayEntityRecord Method (AptifyGenericEntityBase, Boolean, Form)

Opens an existing record in its form/form template.

public void DisplayEntityRecord(
AptifyGenericEntityBase GE,
Boolean UseObjectViewer,
Form parentForm
);

Parameters

GE
An object that represents a record in the database.
UseObjectViewer
Open up the record in the object viewer. Defaults to false.
parentForm
Handle to parent window.

Remarks

NOT IMPLEMENTED (If UseObjectBrowser is false.)

Example

    Dim oApplication As New Aptify.Framework.Application.AptifyApplication
    Dim oGE As Aptify.Framework.BusinessLogic.GenericEntity.AptifyGenericEntityBase

    oGE = oApplication.GetEntityObject("Entities", 80)

    'This displays the object viewer and it works
    oApplication.DisplayEntityRecord(oGE, True, Me)

    'This throws a method not implemented
    oApplication.DisplayEntityRecord(oGE, False, Me)

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.DisplayEntityRecord Overload List


AptifyApplication.DisplayEntityRecord Method (String, Int64)

Opens an existing record in its form/form template.

public void DisplayEntityRecord(
String EntityName,
Int64 RecordID
);

Parameters

EntityName
Name of the entity.
RecordID
Primary key of the record.

Example

    Dim oApplication As New Aptify.Framework.Application.AptifyApplication
    oApplication.DisplayEntityRecord("Entities", 80)

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.DisplayEntityRecord Overload List


AptifyApplication.DisplayEntityRecord Method (String, Int64, Boolean)

Opens an existing record in its form/form template.

public void DisplayEntityRecord(
String EntityName,
Int64 RecordID,
Boolean UseObjectViewer
);

Parameters

EntityName
Name of the entity.
RecordID
Primary key of the record.
UseObjectViewer
Open up the record in the object viewer.

Example

    Dim oApplication As New Aptify.Framework.Application.AptifyApplication

    oApplication.DisplayEntityRecord("Entities", 80, True)

    oApplication.DisplayEntityRecord("Entities", 80, False)

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.DisplayEntityRecord Overload List


AptifyApplication.DisplayEntityRecord Method (String, Int64, Boolean, Form)

public void DisplayEntityRecord(
String EntityName,
Int64 RecordID,
Boolean UseObjectViewer,
Form ParentForm
);

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.DisplayEntityRecord Overload List


DisplayEntityRecordDialog Method

Aptify 5.0 Software Development Kit (SDK)

AptifyApplication.DisplayEntityRecordDialog Method

Opens an existing record in its form/form template in dialog mode.

Overload List

Opens an existing record in its form/form template in dialog mode.

public DialogResult DisplayEntityRecordDialog(AptifyGenericEntityBase);

Opens an existing record in its form/form template in dialog mode.

public DialogResult DisplayEntityRecordDialog(AptifyGenericEntityBase,Boolean);

Opens an existing record in its form/form template in dialog mode.

public DialogResult DisplayEntityRecordDialog(AptifyGenericEntityBase,Boolean,Form);

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace


AptifyApplication.DisplayEntityRecordDialog Method (AptifyGenericEntityBase)

Opens an existing record in its form/form template in dialog mode.

public DialogResult DisplayEntityRecordDialog(
AptifyGenericEntityBase GE
);

Parameters

GE
An object that represents a record in the database.

Remarks

NOT IMPLEMENTED

Example

    Dim oApplication As New Aptify.Framework.Application.AptifyApplication
    Dim oGE As Aptify.Framework.BusinessLogic.GenericEntity.AptifyGenericEntityBase

    oGE = oApplication.GetEntityObject("Entities", 80)

    'This is not implemented
    If oApplication.DisplayEntityRecordDialog(oGE) = DialogResult.OK Then
        'do some processing
    End If

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.DisplayEntityRecordDialog Overload List


AptifyApplication.DisplayEntityRecordDialog Method (AptifyGenericEntityBase, Boolean)

Opens an existing record in its form/form template in dialog mode.

public DialogResult DisplayEntityRecordDialog(
AptifyGenericEntityBase GE,
Boolean UseObjectViewer
);

Parameters

GE
An object that represents a record in the database.
UseObjectViewer
Open up the record in the object viewer. Defaults to false.

Remarks

NOT IMPLEMENTED

Example

    Dim oApplication As New Aptify.Framework.Application.AptifyApplication
    Dim oGE As Aptify.Framework.BusinessLogic.GenericEntity.AptifyGenericEntityBase

    oGE = oApplication.GetEntityObject("Entities", 80)

    'This is not implemented
    If oApplication.DisplayEntityRecordDialog(oGE, False) = DialogResult.OK Then
        'do some processing
    End If

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.DisplayEntityRecordDialog Overload List


AptifyApplication.DisplayEntityRecordDialog Method (AptifyGenericEntityBase, Boolean, Form)

Opens an existing record in its form/form template in dialog mode.

public DialogResult DisplayEntityRecordDialog(
AptifyGenericEntityBase GE,
Boolean UseObjectViewer,
Form parentForm
);

Parameters

GE
An object that represents a record in the database.
UseObjectViewer
Open up the record in the object viewer. Defaults to false.
parentForm
Handle to parent window.

Remarks

NOT IMPLEMENTED (If UseObjectBrowser is false.)

Example

    Dim oApplication As New Aptify.Framework.Application.AptifyApplication
    Dim oGE As Aptify.Framework.BusinessLogic.GenericEntity.AptifyGenericEntityBase

    oGE = oApplication.GetEntityObject("Entities", 80)

    'This is implemented
    If oApplication.DisplayEntityRecordDialog(oGE, True, Me) = DialogResult.OK Then
        'Do some Processing
    End If

    'This is not implemented
    If oApplication.DisplayEntityRecordDialog(oGE, False, Me) = DialogResult.OK Then
        'do some processing
    End If

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.DisplayEntityRecordDialog Overload List


DisplayFindItems Method

Aptify 5.0 Software Development Kit (SDK)

AptifyApplication.DisplayFindItems Method

Open the Find Items dialog box for the specified entity.

Overload List

Open the Find Items dialog box for the specified entity.

public void DisplayFindItems(Int64);

public void DisplayFindItems(Int64,Form);

Open the Find Items dialog box for the specified entity.

public void DisplayFindItems(String);

public void DisplayFindItems(String,Form);

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace


AptifyApplication.DisplayFindItems Method (Int64)

Open the Find Items dialog box for the specified entity.

public void DisplayFindItems(
Int64 EntityID
);

Parameters

EntityID
ID of the entity.

Remarks

For this method, the records that match the search criteria are displayed in a new ELV window. This is the method that the system uses when the Find dialog is opened from the Find Items icon in the Service and View Toolbar or from the Find Items option in the Folder List's context menu. The system uses the DisplayEntityFindDialog Method when the Find dialog is opened from a record (by clicking the Find button or selecting Find from a record's right-click context menu).

Example

Dim oApplication As New Aptify.Framework.Application.AptifyApplication
oApplication.DisplayFindItems(80)

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.DisplayFindItems Overload List


AptifyApplication.DisplayFindItems Method (Int64, Form)

public void DisplayFindItems(
Int64 EntityID,
Form ParentForm
);

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.DisplayFindItems Overload List


AptifyApplication.DisplayFindItems Method (String)

Open the Find Items dialog box for the specified entity.

public void DisplayFindItems(
String EntityName
);

Parameters

EntityName
Name of the entity.

Remarks

For this method, the records that match the search criteria are displayed in a new ELV window. This is the method that the system uses when the Find dialog is opened from the Find Items icon in the Service and View Toolbar or from the Find Items option in the Folder List's context menu. The system uses the DisplayEntityFindDialog Method when the Find dialog is opened from a record (by clicking the Find button or selecting Find from a record's right-click context menu).

Example

Dim oApplication As New Aptify.Framework.Application.AptifyApplication
oApplication.DisplayFindItems("Entities")

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.DisplayFindItems Overload List


AptifyApplication.DisplayFindItems Method (String, Form)

public void DisplayFindItems(
String EntityName,
Form ParentForm
);

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.DisplayFindItems Overload List


DisplayNewEntityRecord Method

Aptify 5.0 Software Development Kit (SDK)

AptifyApplication.DisplayNewEntityRecord Method

Opens a new entity record.

Overload List

Opens a new entity record.

public void DisplayNewEntityRecord(String,String);

Opens a new entity record.

public void DisplayNewEntityRecord(String,String,Boolean);

public void DisplayNewEntityRecord(String,String,Boolean,Form);

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace


AptifyApplication.DisplayNewEntityRecord Method (String, String)

Opens a new entity record.

public void DisplayNewEntityRecord(
String EntityName,
String NewRecordParameters
);

Parameters

EntityName
Name of the entity.
NewRecordParameters
Default setup parameters for opening an entity record.

Example

Dim oApplication As New Aptify.Framework.Application.AptifyApplication
oApplication.DisplayNewEntityRecord("Entities", Nothing)

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.DisplayNewEntityRecord Overload List


AptifyApplication.DisplayNewEntityRecord Method (String, String, Boolean)

Opens a new entity record.

public void DisplayNewEntityRecord(
String EntityName,
String NewRecordParameters,
Boolean UseObjectViewer
);

Parameters

EntityName
Name of the entity.
NewRecordParameters
Default setup parameters for opening an entity record.
UseObjectViewer
Open up the record in the object viewer. Defaults to false.

Example

Dim oApplication As New Aptify.Framework.Application.AptifyApplication

oApplication.DisplayNewEntityRecord("Entities", Nothing, False)
oApplication.DisplayNewEntityRecord("Entities", Nothing, True)

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.DisplayNewEntityRecord Overload List


AptifyApplication.DisplayNewEntityRecord Method (String, String, Boolean, Form)

public void DisplayNewEntityRecord(
String EntityName,
String NewRecordParameters,
Boolean UseObjectViewer,
Form ParentForm
);

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.DisplayNewEntityRecord Overload List


DisplayNewViewDialog Method

Aptify 5.0 Software Development Kit (SDK)

AptifyApplication.DisplayNewViewDialog Method

Opens a new Views record in a dialog form for the specified entity.

Overload List

Opens a new Views record in a dialog form for the specified entity.

public DialogResult DisplayNewViewDialog(Int64,Int64,ref AptifyGenericEntityBase&);

public DialogResult DisplayNewViewDialog(Int64,Int64,ref AptifyGenericEntityBase&,Form);

Opens a new Views record in a dialog form for the specified entity.

public DialogResult DisplayNewViewDialog(String,Int64,ref AptifyGenericEntityBase&);

public DialogResult DisplayNewViewDialog(String,Int64,ref AptifyGenericEntityBase&,Form);

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace


AptifyApplication.DisplayNewViewDialog Method (Int64, Int64, AptifyGenericEntityBase&)

Opens a new Views record in a dialog form for the specified entity.

public DialogResult DisplayNewViewDialog(
Int64 EntityID,
Int64 ViewCategoryID,
ref AptifyGenericEntityBase& ViewGE
);

Parameters

EntityID
The Id of the entity.
ViewCategoryID
Category classification ID.
ViewGE
GE Object that has the view included.

Example

Dim oApplication As New Aptify.Framework.Application.AptifyApplication
Dim geView As Aptify.Framework.BusinessLogic.GenericEntity.AptifyGenericEntityBase
If oApplication.DisplayNewViewDialog(80, -1, geView) = DialogResult.OK Then
    'do some processing, you should have a valid geView instance now
End If

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.DisplayNewViewDialog Overload List


AptifyApplication.DisplayNewViewDialog Method (Int64, Int64, AptifyGenericEntityBase&, Form)

public DialogResult DisplayNewViewDialog(
Int64 EntityID,
Int64 ViewCategoryID,
ref AptifyGenericEntityBase& ViewGE,
Form ParentForm
);

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.DisplayNewViewDialog Overload List


AptifyApplication.DisplayNewViewDialog Method (String, Int64, AptifyGenericEntityBase&)

Opens a new Views record in a dialog form for the specified entity.

public DialogResult DisplayNewViewDialog(
String EntityName,
Int64 ViewCategoryID,
ref AptifyGenericEntityBase& ViewGE
);

Parameters

EntityName
The name of the entity.
ViewCategoryID
Category classification ID.
ViewGE
GE Object that has the view included.

Example

Dim oApplication As New Aptify.Framework.Application.AptifyApplication
Dim geView As Aptify.Framework.BusinessLogic.GenericEntity.AptifyGenericEntityBase
If oApplication.DisplayNewViewDialog("Entities", -1, geView) = DialogResult.OK Then
    'do some processing, you should have a valid geView instance now
End If

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.DisplayNewViewDialog Overload List


AptifyApplication.DisplayNewViewDialog Method (String, Int64, AptifyGenericEntityBase&, Form)

public DialogResult DisplayNewViewDialog(
String EntityName,
Int64 ViewCategoryID,
ref AptifyGenericEntityBase& ViewGE,
Form ParentForm
);

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.DisplayNewViewDialog Overload List


DisplayReadOnlyObjectViewerDialog Method

Aptify 5.0 Software Development Kit (SDK)

AptifyApplication.DisplayReadOnlyObjectViewerDialog Method

Opens a record in ReadOnly mode in the Object Viewer.

Overload List

Opens a record in ReadOnly mode in the Object Viewer.

public void DisplayReadOnlyObjectViewerDialog(AptifyGenericEntityBase);

Opens a record in ReadOnly mode in the Object Viewer.

public void DisplayReadOnlyObjectViewerDialog(AptifyGenericEntityBase,Form);

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace


AptifyApplication.DisplayReadOnlyObjectViewerDialog Method (AptifyGenericEntityBase)

Opens a record in ReadOnly mode in the Object Viewer.

public void DisplayReadOnlyObjectViewerDialog(
AptifyGenericEntityBase GE
);

Parameters

GE
An object that represents a record in the database.

Remarks

The Object Viewer is another way to access data within a record besides an entity's form template. Using the Object Viewer, a user may see all data contained in all fields in the table on which the record is based, not just the data that is displayed on the regular form. Most of this data may also be updated at this level, including ID fields. The only fields which may not be edited are virtual fields and linked fields. See the Aptify Administration Guide for more information on the Object Viewer.

Example

Dim oApplication As New Aptify.Framework.Application.AptifyApplication
Dim ge As Aptify.Framework.BusinessLogic.GenericEntity.AptifyGenericEntityBase
ge = oApplication.GetEntityObject("Entities", 80)
oApplication.DisplayReadOnlyObjectViewerDialog(ge)

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.DisplayReadOnlyObjectViewerDialog Overload List


AptifyApplication.DisplayReadOnlyObjectViewerDialog Method (AptifyGenericEntityBase, Form)

Opens a record in ReadOnly mode in the Object Viewer.

public void DisplayReadOnlyObjectViewerDialog(
AptifyGenericEntityBase GE,
Form parentForm
);

Parameters

GE
An object that represents a record in the database.
parentForm
Handle to parent window.

Remarks

The Object Viewer is another way to access data within a record besides an entity's form template. Using the Object Viewer, a user may see all data contained in all fields in the table on which the record is based, not just the data that is displayed on the regular form. Most of this data may also be updated at this level, including ID fields. The only fields which may not be edited are virtual fields and linked fields. See the Aptify Administration Guide for more information on the Object Viewer.

Example

Dim oApplication As New Aptify.Framework.Application.AptifyApplication
Dim ge As Aptify.Framework.BusinessLogic.GenericEntity.AptifyGenericEntityBase

ge = oApplication.GetEntityObject("Entities", 80)
oApplication.DisplayReadOnlyObjectViewerDialog(ge, Me))

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.DisplayReadOnlyObjectViewerDialog Overload List


DisplaySubTypeEntityRecordDialog Method

Aptify 5.0 Software Development Kit (SDK)

AptifyApplication.DisplaySubTypeEntityRecordDialog Method

Opens an existing SubType record in its form/form template.

Overload List

Opens an existing SubType record in its form/form template.

public DialogResult DisplaySubTypeEntityRecordDialog(AptifyGenericEntityBase,String);

Opens an existing SubType record in its form/form template.

public DialogResult DisplaySubTypeEntityRecordDialog(AptifyGenericEntityBase,String,String);

Opens an existing SubType record in its form/form template.

public DialogResult DisplaySubTypeEntityRecordDialog(AptifyGenericEntityBase,String,String,Form);

Opens an existing SubType record in its form/form template.

public DialogResult DisplaySubTypeEntityRecordDialog(AptifyGenericEntityBase,String,Form);

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace


AptifyApplication.DisplaySubTypeEntityRecordDialog Method (AptifyGenericEntityBase, String)

Opens an existing SubType record in its form/form template.

public DialogResult DisplaySubTypeEntityRecordDialog(
AptifyGenericEntityBase subTypeGE,
String Caption
);

Parameters

subTypeGE
An object that represents a record in the database.
Caption
Caption on the form.

Example

    Dim oApplication As New Aptify.Framework.Application.AptifyApplication
    Dim geEntity As Aptify.Framework.BusinessLogic.GenericEntity.AptifyGenericEntityBase
    Dim geField As Aptify.Framework.BusinessLogic.GenericEntity.AptifyGenericEntityBase

    geEntity = oApplication.GetEntityObject("Entities", 80)
    geField = geEntity.SubTypes("EntityFields").Item(0)

    If oApplication.DisplaySubTypeEntityRecordDialog(geField, "A Field") = DialogResult.OK Then
        'do some processing work here
    End If

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.DisplaySubTypeEntityRecordDialog Overload List


AptifyApplication.DisplaySubTypeEntityRecordDialog Method (AptifyGenericEntityBase, String, String)

Opens an existing SubType record in its form/form template.

public DialogResult DisplaySubTypeEntityRecordDialog(
AptifyGenericEntityBase subTypeGE,
String CmdString,
String Caption
);

Parameters

subTypeGE
An object that represents a record in the database.
CmdString
Command String that gives open information.
Caption
Caption on the form.

Example

Dim oApplication As New Aptify.Framework.Application.AptifyApplication
Dim geEntity As Aptify.Framework.BusinessLogic.GenericEntity.AptifyGenericEntityBase
Dim geField As Aptify.Framework.BusinessLogic.GenericEntity.AptifyGenericEntityBase

geEntity = oApplication.GetEntityObject("Entities", 80)
geField = geEntity.SubTypes("EntityFields").Item(0)

If oApplication.DisplaySubTypeEntityRecordDialog(geField, "", "A Field") = DialogResult.OK Then
    'do some processing work here
End If

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.DisplaySubTypeEntityRecordDialog Overload List


AptifyApplication.DisplaySubTypeEntityRecordDialog Method (AptifyGenericEntityBase, String, String, Form)

Opens an existing SubType record in its form/form template.

public DialogResult DisplaySubTypeEntityRecordDialog(
AptifyGenericEntityBase subTypeGE,
String CmdString,
String Caption,
Form parentForm
);

Parameters

subTypeGE
An object that represents a record in the database.
CmdString
Command String that gives open information.
Caption
Caption on the form.
parentForm
Handle to parent window.

Example

Dim oApplication As New Aptify.Framework.Application.AptifyApplication
Dim geEntity As Aptify.Framework.BusinessLogic.GenericEntity.AptifyGenericEntityBase
Dim geField As Aptify.Framework.BusinessLogic.GenericEntity.AptifyGenericEntityBase

geEntity = oApplication.GetEntityObject("Entities", 80)
geField = geEntity.SubTypes("EntityFields").Item(0)

If oApplication.DisplaySubTypeEntityRecordDialog(geField, "", "A Field", Me) = DialogResult.OK Then
    'do some processing work here
End If

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.DisplaySubTypeEntityRecordDialog Overload List


AptifyApplication.DisplaySubTypeEntityRecordDialog Method (AptifyGenericEntityBase, String, Form)

Opens an existing SubType record in its form/form template.

public DialogResult DisplaySubTypeEntityRecordDialog(
AptifyGenericEntityBase subTypeGE,
String Caption,
Form parentForm
);

Parameters

subTypeGE
An object that represents a record in the database.
Caption
Caption on the form.
parentForm
Handle to parent window.

Example

Dim oApplication As New Aptify.Framework.Application.AptifyApplication
Dim geEntity As Aptify.Framework.BusinessLogic.GenericEntity.AptifyGenericEntityBase
Dim geField As Aptify.Framework.BusinessLogic.GenericEntity.AptifyGenericEntityBase

geEntity = oApplication.GetEntityObject("Entities", 80)
geField = geEntity.SubTypes("EntityFields").Item(0)

If oApplication.DisplaySubTypeEntityRecordDialog(geField, "A Field",Me) = DialogResult.OK Then
   'do some processing work here
End If

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.DisplaySubTypeEntityRecordDialog Overload List


DisplayViewRecordDialog Method

Aptify 5.0 Software Development Kit (SDK)

AptifyApplication.DisplayViewRecordDialog Method

Opens a view record in a dialog form.

Overload List

Opens a view record in a dialog form.

public DialogResult DisplayViewRecordDialog(Int64,ref AptifyGenericEntityBase&);

public DialogResult DisplayViewRecordDialog(Int64,ref AptifyGenericEntityBase&,Form);

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace


AptifyApplication.DisplayViewRecordDialog Method (Int64, AptifyGenericEntityBase&)

Opens a view record in a dialog form.

public DialogResult DisplayViewRecordDialog(
Int64 ViewID,
ref AptifyGenericEntityBase& ViewGE
);

Parameters

ViewID
Primary Key of the View
ViewGE
GE Object that has the view included.

Example

Dim oApplication As New Aptify.Framework.Application.AptifyApplication
Dim geView As Aptify.Framework.BusinessLogic.GenericEntity.AptifyGenericEntityBase
If oApplication.DisplayViewRecordDialog(80, geView) = DialogResult.OK Then
    'do some processing, you should have a valid geView instance now
End If

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.DisplayViewRecordDialog Overload List


AptifyApplication.DisplayViewRecordDialog Method (Int64, AptifyGenericEntityBase&, Form)

public DialogResult DisplayViewRecordDialog(
Int64 ViewID,
ref AptifyGenericEntityBase& ViewGE,
Form ParentForm
);

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.DisplayViewRecordDialog Overload List


EntityRecordExists Method

Aptify 5.0 Software Development Kit (SDK)

AptifyApplication.EntityRecordExists Method

This method does checks to see if the specified record ID exists in the entity defined by the EntityName parameter. If it does the method returns True, otherwise it returns False.

Overload List

This method does checks to see if the specified record ID exists in the entity defined by the EntityName parameter. If it does the method returns True, otherwise it returns False.

public virtual bool EntityRecordExists(Int64,Int64);

This method does checks to see if the specified record ID exists in the entity defined by the EntityName parameter. If it does the method returns True, otherwise it returns False.

public virtual bool EntityRecordExists(String,Int64);

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace


AptifyApplication.EntityRecordExists Method (Int64, Int64)

This method does checks to see if the specified record ID exists in the entity defined by the EntityName parameter. If it does the method returns True, otherwise it returns False.

public virtual bool EntityRecordExists(
Int64 EntityID,
Int64 RecordID
);

Parameters

EntityID
RecordID

Return Value

Remarks

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.EntityRecordExists Overload List


AptifyApplication.EntityRecordExists Method (String, Int64)

This method does checks to see if the specified record ID exists in the entity defined by the EntityName parameter. If it does the method returns True, otherwise it returns False.

public virtual bool EntityRecordExists(
String EntityName,
Int64 RecordID
);

Parameters

EntityName
RecordID

Return Value

Remarks

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.EntityRecordExists Overload List


AptifyApplication.GetApplicationInfo Method

This method returns an APplicationInfo structure that carries the commonly required application information

public ApplicationInfo GetApplicationInfo(
Int64 ApplicationID
);

Parameters

ApplicationID

Return Value

Remarks

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace


AptifyApplication.GetDefaultFormIcon Method

Returns the Default Form Icon to be used for Branding Purpose. EntityName.

public string GetDefaultFormIcon(
String EntityName
);

Parameters

EntityName
The Name of the default Entity for which we are loading the Form. For Default application Form this field will be blank.

Return Value

Returns the Path from where to pick the Icon. In case the Icon path is not found will return Blank. EntityID

Remarks

Example

Dim oApplication As New Aptify.Framework.Application.AptifyApplication
Dim sResult As String

sResult = oApplication.GetDefaultFormIcon("Persons")

if Len(sResult) > 0 then
    Me.Icon = Icon(sResult)
end if

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace


AptifyApplication.GetEntityAttachmentPermissions Method

Returns the permissions the user has for this entity.

public EntityPermissions GetEntityAttachmentPermissions(
String EntityName,
Int64 CategoryID
);

Parameters

EntityName
Name of the Entity.
CategoryID

Return Value

Returns the permissions the user has for this entity.

Example

 Dim oApplication As New Aptify.Framework.Application.AptifyApplication

 Dim oPermissions As Aptify.Framework.Application.GetEntityAttachmentPermissions

 oPermissions = oApplication.GetEntityAttachmentPermissions("Entities", -1)

 If oPermissions.Read = Aptify.Framework.Application.EntityPermissionType.Allow Then
     'we can read so do some processing
 End If

 If oPermissions.Create = Aptify.Framework.Application.EntityPermissionType.Allow Then
     'we can create so do some processing
 End If

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace


GetEntityAttribute Method

Aptify 5.0 Software Development Kit (SDK)

AptifyApplication.GetEntityAttribute Method

This method retrieves the value associated with an entity attribute.

Overload List

This method retrieves the value associated with an entity attribute.

public string GetEntityAttribute(Int64,String);

This method retrieves the value associated with an entity attribute.

public string GetEntityAttribute(String,String);

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace


AptifyApplication.GetEntityAttribute Method (Int64, String)

This method retrieves the value associated with an entity attribute.

public string GetEntityAttribute(
Int64 EntityID,
String AttributeName
);

Parameters

EntityID
ID of the Entity
AttributeName
Name of the Attribute

Return Value

A string with the Entity Attribute. Null string if it is not found.

Remarks

Entity attributes enable developers to associate name/value pairs with a particular entity, thereby providing more generic configurability. Entity attributes are used within the Aptify framework as a way of storing values that may be configured or changed by the administrator. For example, the SupportsPacking attribute specified whether or not an entity's records can be packed using the Data Packer (when set to 1, an entity supports packing; when set to 0 or not configured, the entity does not support packing).

Example

Dim oApplication As New Aptify.Framework.Application.AptifyApplication
Dim sResult As String
sResult = oApplication.GetEntityAttribute(79, "SupportsPacking")

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.GetEntityAttribute Overload List


AptifyApplication.GetEntityAttribute Method (String, String)

This method retrieves the value associated with an entity attribute.

public string GetEntityAttribute(
String EntityName,
String AttributeName
);

Parameters

EntityName
Name of the Entity
AttributeName
Name of the Attribute

Return Value

A string with the Entity Attribute. Null string if it is not found.

Remarks

Entity attributes enable developers to associate name/value pairs with a particular entity, thereby providing more generic configurability. Entity attributes are used within the Aptify framework as a way of storing values that may be configured or changed by the administrator. For example, the SupportsPacking attribute specified whether or not an entity's records can be packed using the Data Packer (when set to 1, an entity supports packing; when set to 0 or not configured, the entity does not support packing).

Example

Dim oApplication As New Aptify.Framework.Application.AptifyApplication
Dim sResult As String
sResult = oApplication.GetEntityAttribute("Views", "SupportsPacking")

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.GetEntityAttribute Overload List


GetEntityBaseDatabase Method

Aptify 5.0 Software Development Kit (SDK)

AptifyApplication.GetEntityBaseDatabase Method

Returns the name of the base database based on the EntityID.

Overload List

Returns the name of the base database based on the EntityID.

public string GetEntityBaseDatabase(Int64);

Returns the name of the base database based on the EntityName.

public string GetEntityBaseDatabase(String);

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace


AptifyApplication.GetEntityBaseDatabase Method (Int64)

Returns the name of the base database based on the EntityID.

public string GetEntityBaseDatabase(
Int64 EntityID
);

Parameters

EntityID
The ID of an existing entity.

Return Value

Returns the name of the base database based on the EntityID

Remarks

Example

Dim oApplication As New Aptify.Framework.Application.AptifyApplication
Dim sResult As String

sResult = oApplication.GetEntityBaseDatabase(80)

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.GetEntityBaseDatabase Overload List


AptifyApplication.GetEntityBaseDatabase Method (String)

Returns the name of the base database based on the EntityName.

public string GetEntityBaseDatabase(
String EntityName
);

Parameters

EntityName
The name of an existing entity.

Return Value

Returns the name of the base database based on the EntityName

Remarks

Example

Dim oApplication As New Aptify.Framework.Application.AptifyApplication
Dim sResult As String

sResult = oApplication.GetEntityBaseDatabase("Entities")

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.GetEntityBaseDatabase Overload List


GetEntityBaseTable Method

Aptify 5.0 Software Development Kit (SDK)

AptifyApplication.GetEntityBaseTable Method

Returns the name of the base table based on the EntityID.

Overload List

Returns the name of the base table based on the EntityID.

public string GetEntityBaseTable(Int64);

Returns the name of the base table based on the EntityName.

public string GetEntityBaseTable(String);

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace


AptifyApplication.GetEntityBaseTable Method (Int64)

Returns the name of the base table based on the EntityID.

public string GetEntityBaseTable(
Int64 EntityID
);

Parameters

EntityID
The ID of an existing entity.

Return Value

Returns the name of the base table based on the EntityID

Remarks

Example

Dim oApplication As New Aptify.Framework.Application.AptifyApplication
Dim sResult As String

sResult = oApplication.GetEntityBaseTable(80)

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.GetEntityBaseTable Overload List


AptifyApplication.GetEntityBaseTable Method (String)

Returns the name of the base table based on the EntityName.

public string GetEntityBaseTable(
String EntityName
);

Parameters

EntityName
The name of an existing entity.

Return Value

Returns the name of the base table based on the EntityName

Remarks

Example

Dim oApplication As New Aptify.Framework.Application.AptifyApplication
Dim sResult As String

sResult = oApplication.GetEntityBaseTable("Entities")

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.GetEntityBaseTable Overload List


GetEntityBaseView Method

Aptify 5.0 Software Development Kit (SDK)

AptifyApplication.GetEntityBaseView Method

Returns the Name of an Entity's base view.

Overload List

Returns the Name of an Entity's base view.

public string GetEntityBaseView(Int64);

Returns the Name of an Entity's base view.

public string GetEntityBaseView(String);

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace


AptifyApplication.GetEntityBaseView Method (Int64)

Returns the Name of an Entity's base view.

public string GetEntityBaseView(
Int64 EntityID
);

Parameters

EntityID
The ID of an existing Entity.

Return Value

Returns the Name of an Entity's base view. If the EntityID does not exist then the null string is returned.

Remarks

Example

Dim oApplication As New Aptify.Framework.Application.AptifyApplication
Dim sResult As String

sResult = oApplication.GetEntityBaseView(80)

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.GetEntityBaseView Overload List


AptifyApplication.GetEntityBaseView Method (String)

Returns the Name of an Entity's base view.

public string GetEntityBaseView(
String EntityName
);

Parameters

EntityName
The name of an existing Entity.

Return Value

Returns the Name of an Entity's base view. If the EntityName does not exist then the null string is returned.

Remarks

Example

Dim oApplication As New Aptify.Framework.Application.AptifyApplication
Dim sResult As String

sResult = oApplication.GetEntityBaseView("Entities")

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.GetEntityBaseView Overload List


GetEntityDependencies Method

Aptify 5.0 Software Development Kit (SDK)

AptifyApplication.GetEntityDependencies Method

Returns a collection that has a list of records that depend on this record.

Overload List

Returns a collection that has a list of records that depend on this record.

public EntityDependenciesBase GetEntityDependencies(String,Int64);

Returns a collection that has a list of records that depend on this record.

public EntityDependenciesBase GetEntityDependencies(String,Int64,String);

Returns a collection that has a list of records that depend on this record.

public EntityDependenciesBase GetEntityDependencies(String,Int64,String,Boolean,Boolean,String);

Returns a collection that has a list of records that depend on this record.

public EntityDependenciesBase GetEntityDependencies(String,Int64,String,Boolean,String);

Returns a collection that has a list of records that depend on this record.

public EntityDependenciesBase GetEntityDependencies(String,Int64,String,String);

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace


AptifyApplication.GetEntityDependencies Method (String, Int64)

Returns a collection that has a list of records that depend on this record.

public EntityDependenciesBase GetEntityDependencies(
String EntityName,
Int64 RecordID
);

Parameters

EntityName
The name of the entity
RecordID
The Id of the record

Return Value

Returns a collection that has a list of records that depend on this record.

Example

Dim oApplication As New Aptify.Framework.Application.AptifyApplication
Dim oResult As Aptify.Framework.BusinessLogic.GenericEntity.EntityDependenciesBase
oResult = oApplication.GetEntityDependencies("Entities", 80)

For Each oDependant As Aptify.Framework.BusinessLogic.GenericEntity.EntityDependant In oResult
    'process each dependant
Next

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.GetEntityDependencies Overload List


AptifyApplication.GetEntityDependencies Method (String, Int64, String)

Returns a collection that has a list of records that depend on this record.

public EntityDependenciesBase GetEntityDependencies(
String EntityName,
Int64 RecordID,
String TransactionID
);

Parameters

EntityName
The name of the entity
RecordID
The Id of the record
TransactionID
To retrieve the list in a transaction, provide a transactionID

Return Value

Returns a collection that has a list of records that depend on this record.

Example

Dim oApplication As New Aptify.Framework.Application.AptifyApplication
Dim oResult As Aptify.Framework.BusinessLogic.GenericEntity.EntityDependenciesBase
oResult = oApplication.GetEntityDependencies("Entities", 80, Nothing)

For Each oDependant As Aptify.Framework.BusinessLogic.GenericEntity.EntityDependant In oResult
    'process each dependant
Next

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.GetEntityDependencies Overload List


AptifyApplication.GetEntityDependencies Method (String, Int64, String, Boolean, Boolean, String)

Returns a collection that has a list of records that depend on this record.

public EntityDependenciesBase GetEntityDependencies(
String EntityName,
Int64 RecordID,
String TransactionID,
Boolean ExcludeForeignKeys,
Boolean OnlyExistenceCheck,
String DependenciesTableName
);

Parameters

EntityName
The name of the entity
RecordID
The Id of the record
TransactionID
To retrieve the list in a transaction, provide a transactionID
ExcludeForeignKeys
Determines whether or not the Dependencies returned will exclude links that have a Foreign Key relationship with the record. Excluding Foreign Keys can reduce significantly the time required to retrieve the dependencies.
OnlyExistenceCheck
If true, the method is being used to determine whether or not any dependencies exist. In this case, the dependency check will stop after the first dependency is found. If false, all of the qualifying dependencies will be returned.
DependenciesTableName
The name of the table that contains supplemental dependency information. This table is used to store information about dependencies when records are being deleted.

Return Value

Returns a collection that has a list of records that depend on this record.

Example

Dim oApplication As New Aptify.Framework.Application.AptifyApplication
Dim oResult As Aptify.Framework.BusinessLogic.GenericEntity.EntityDependenciesBase
oResult = oApplication.GetEntityDependencies("Entities", 80, Nothing, True, True, "#DependencyCheckEntityRecordData")

If oResult.Count > 0 then
    'At least one dependency exists.
End if

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.GetEntityDependencies Overload List


AptifyApplication.GetEntityDependencies Method (String, Int64, String, Boolean, String)

Returns a collection that has a list of records that depend on this record.

public EntityDependenciesBase GetEntityDependencies(
String EntityName,
Int64 RecordID,
String TransactionID,
Boolean ExcludeForeignKeys,
String DependenciesTableName
);

Parameters

EntityName
The name of the entity
RecordID
The Id of the record
TransactionID
To retrieve the list in a transaction, provide a transactionID
ExcludeForeignKeys
Determines whether or not the Dependencies returned will exclude links that have a Foreign Key relationship with the record. Excluding Foreign Keys can reduce significantly the time required to retrieve the dependencies.
DependenciesTableName
The name of the table that contains supplemental dependency information. This table is used to store information about dependencies when records are being deleted.

Return Value

Returns a collection that has a list of records that depend on this record.

Example

Dim oApplication As New Aptify.Framework.Application.AptifyApplication
Dim oResult As Aptify.Framework.BusinessLogic.GenericEntity.EntityDependenciesBase
oResult = oApplication.GetEntityDependencies("Entities", 80, Nothing, True, "#DependencyCheckEntityRecordData")

For Each oDependant As Aptify.Framework.BusinessLogic.GenericEntity.EntityDependant In oResult
    'process each dependant
Next

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.GetEntityDependencies Overload List


AptifyApplication.GetEntityDependencies Method (String, Int64, String, String)

Returns a collection that has a list of records that depend on this record.

public EntityDependenciesBase GetEntityDependencies(
String EntityName,
Int64 RecordID,
String TransactionID,
String DependenciesTableName
);

Parameters

EntityName
The name of the entity
RecordID
The Id of the record
TransactionID
To retrieve the list in a transaction, provide a transactionID
DependenciesTableName
The name of the table that contains supplemental dependency information. This table is used to store information about dependencies when records are being deleted.

Return Value

Returns a collection that has a list of records that depend on this record.

Example

Dim oApplication As New Aptify.Framework.Application.AptifyApplication
Dim oResult As Aptify.Framework.BusinessLogic.GenericEntity.EntityDependenciesBase
oResult = oApplication.GetEntityDependencies("Entities", 80, Nothing, "#DependencyCheckEntityRecordData")

For Each oDependant As Aptify.Framework.BusinessLogic.GenericEntity.EntityDependant In oResult
    'process each dependant
Next

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.GetEntityDependencies Overload List


AptifyApplication.GetEntityID Method

Returns the EntityID based on the EntityName.

public long GetEntityID(
String EntityName
);

Parameters

EntityName
The name of the Entity for which the ID should be returned.

Return Value

Returns the EntityID based on the EntityName.

Remarks

Example

Dim oApplication As New Aptify.Framework.Application.AptifyApplication
Dim lID As Long = oApplication.GetEntityID("Entities")

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace


GetEntityName Method

Aptify 5.0 Software Development Kit (SDK)

AptifyApplication.GetEntityName Method

This will return the Entity Name that was specified in the command object or through a commandstring.

Overload List

This will return the Entity Name that was specified in the command object or through a commandstring.

public string GetEntityName();

Returns the entity name based on the EntityID.

public string GetEntityName(Int64);

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace


AptifyApplication.GetEntityName Method ()

This will return the Entity Name that was specified in the command object or through a commandstring.

public string GetEntityName();

Return Value

This will return the name of an Entity

Remarks

If neither property has been accessed, then an AptifyApplicationException exception will be thrown.

Example

     Dim oApplication As New Aptify.Framework.Application.AptifyApplication

     oApplication.Command.EntityName = "Entities"

     Dim sName As String = oApplication.GetEntityName()

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.GetEntityName Overload List


AptifyApplication.GetEntityName Method (Int64)

Returns the entity name based on the EntityID.

public string GetEntityName(
Int64 EntityID
);

Parameters

EntityID
The ID of the an existing Entity.

Return Value

Returns the entity name based on the EntityID. If the ID does not exist then the empty string is returned.

Remarks

Example

Dim oApplication As New Aptify.Framework.Application.AptifyApplication
Dim sName As String = oApplication.GetEntityName(80)

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.GetEntityName Overload List


AptifyApplication.GetEntityObject Method

Returns a configured instance of an Entity's wrapper.

public AptifyGenericEntityBase GetEntityObject(
String EntityName,
Int64 RecordID
);

Parameters

EntityName
The name of an existing entity.
RecordID
The ID of an existing record to be loaded. -1 will return a new record.

Return Value

Returns a configured instance of an Entity's wrapper.

Remarks

This method is a class factory for generating a configured GE. The resulting object is an instance of a wrapper object or the core object, depending on how the Entity is configured.

Example

Dim oApplication As New Aptify.Framework.Application.AptifyApplication
Dim geCultureString As Aptify.Framework.BusinessLogic.GenericEntity.AptifyGenericEntityBase

geCultureString = oApplication.GetEntityObject("Culture Strings", -1)

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace


GetEntityPermissions Method

Aptify 5.0 Software Development Kit (SDK)

AptifyApplication.GetEntityPermissions Method

Returns the permissions the user has for this entity.

Overload List

Returns the permissions the user has for this entity.

public EntityPermissions GetEntityPermissions(Int64);

Returns the permissions the user has for this entity.

public EntityPermissions GetEntityPermissions(String);

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace


AptifyApplication.GetEntityPermissions Method (Int64)

Returns the permissions the user has for this entity.

public EntityPermissions GetEntityPermissions(
Int64 EntityID
);

Parameters

EntityID
ID of the Entity.

Return Value

Returns the permissions the user has for this entity.

Example

 Dim oApplication As New Aptify.Framework.Application.AptifyApplication

 Dim oPermissions As Aptify.Framework.Application.EntityPermissions

 oPermissions = oApplication.GetEntityPermissions(80)

 If oPermissions.Read = Aptify.Framework.Application.EntityPermissionType.Allow Then
     'we can read so do some processing
 End If

 If oPermissions.Create = Aptify.Framework.Application.EntityPermissionType.Allow Then
     'we can create so do some processing
 End If

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.GetEntityPermissions Overload List


AptifyApplication.GetEntityPermissions Method (String)

Returns the permissions the user has for this entity.

public EntityPermissions GetEntityPermissions(
String EntityName
);

Parameters

EntityName
Name of the Entity.

Return Value

Returns the permissions the user has for this entity.

Example

 Dim oApplication As New Aptify.Framework.Application.AptifyApplication

 Dim oPermissions As Aptify.Framework.Application.EntityPermissions

 oPermissions = oApplication.GetEntityPermissions("Entities")

 If oPermissions.Read = Aptify.Framework.Application.EntityPermissionType.Allow Then
     'we can read so do some processing
 End If

 If oPermissions.Create = Aptify.Framework.Application.EntityPermissionType.Allow Then
     'we can create so do some processing
 End If

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.GetEntityPermissions Overload List


GetEntityPlugIn Method

Aptify 5.0 Software Development Kit (SDK)

AptifyApplication.GetEntityPlugIn Method

Returns a custom plug-in assembly.

Overload List

Returns a custom plug-in assembly.

public EntityPlugIn GetEntityPlugIn(Int64,EntityPlugInType);

Returns a custom plug-in assembly.

public EntityPlugIn GetEntityPlugIn(Int64,EntityPlugInType,Boolean);

public EntityPlugIn GetEntityPlugIn(Int64,String,Boolean);

Returns a custom plug-in assembly.

public EntityPlugIn GetEntityPlugIn(String,EntityPlugInType);

Returns a custom plug-in assembly.

public EntityPlugIn GetEntityPlugIn(String,EntityPlugInType,Boolean);

public EntityPlugIn GetEntityPlugIn(String,String,Boolean);

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace


AptifyApplication.GetEntityPlugIn Method (Int64, EntityPlugInType)

Returns a custom plug-in assembly.

public EntityPlugIn GetEntityPlugIn(
Int64 EntityID,
EntityPlugInType PlugInType
);

Parameters

EntityID
ID of the Entity.
PlugInType
Structure of object types that the assembly supports.

Return Value

Returns a custom plug-in assembly.

Remarks

An organization can configure an entity to use a specially designed form or functionality. To implement this specialized behavior, a developer creates a .NET assembly that defines the entity's extended functionality. These assemblies are then stored in the Object Repository and are added to the entity on the Plug-Ins tab. The entity uses the plug-ins specified on this tab to override standard functionality with the functionality specified in one or more plug-ins. Typical plug-ins include a specialized form (Viewer plug-in), business logic (Entity plug-in), duplicate record checking process (Duplicate Check type), context menu (Extension plug-in), record verification process (Verification plug-in), Find dialog (Find plug-in), and merging logic (Merge plug-in). See the Aptify Adminstration Guide for more information.

Example

 Dim oApplication As New Aptify.Framework.Application.AptifyApplication

 Dim oPlugIn As Aptify.Framework.Application.EntityPlugIn
 oPlugIn = oApplication.GetEntityPlugIn(80, Aptify.Framework.Application.EntityPlugInType.Viewer)

 Dim oObject As Object
 oObject = Aptify.Framework.Application.InstanceCreator.CreateInstance(oPlugIn.AssemblyName, oPlugIn.ClassName)

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.GetEntityPlugIn Overload List


AptifyApplication.GetEntityPlugIn Method (Int64, EntityPlugInType, Boolean)

Returns a custom plug-in assembly.

public EntityPlugIn GetEntityPlugIn(
Int64 EntityID,
EntityPlugInType PlugInType,
Boolean DownloadObject
);

Parameters

EntityID
ID of the Entity.
PlugInType
Structure of object types that the assembly supports.
DownloadObject
Tells the caller to download the object from the repository.

Return Value

Returns a custom plug-in assembly.

Remarks

An organization can configure an entity to use a specially designed form or functionality. To implement this specialized behavior, a developer creates a .NET assembly that defines the entity's extended functionality. These assemblies are then stored in the Object Repository and are added to the entity on the Plug-Ins tab. The entity uses the plug-ins specified on this tab to override standard functionality with the functionality specified in one or more plug-ins. Typical plug-ins include a specialized form (Viewer plug-in), business logic (Entity plug-in), duplicate record checking process (Duplicate Check type), context menu (Extension plug-in), record verification process (Verification plug-in), Find dialog (Find plug-in), and merging logic (Merge plug-in). See the Aptify Adminstration Guide for more information.

Example

 Dim oApplication As New Aptify.Framework.Application.AptifyApplication

 Dim oPlugIn As Aptify.Framework.Application.EntityPlugIn
 oPlugIn = oApplication.GetEntityPlugIn(80, Aptify.Framework.Application.EntityPlugInType.Viewer, True)

 Dim oObject As Object
 oObject = Aptify.Framework.Application.InstanceCreator.CreateInstance(oPlugIn.AssemblyName, oPlugIn.ClassName)

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.GetEntityPlugIn Overload List


AptifyApplication.GetEntityPlugIn Method (Int64, String, Boolean)

public EntityPlugIn GetEntityPlugIn(
Int64 EntityID,
String PlugInTypeName,
Boolean DownloadObject
);

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.GetEntityPlugIn Overload List


AptifyApplication.GetEntityPlugIn Method (String, EntityPlugInType)

Returns a custom plug-in assembly.

public EntityPlugIn GetEntityPlugIn(
String EntityName,
EntityPlugInType PlugInType
);

Parameters

EntityName
Name of the Entity.
PlugInType
Structure of object types that the assembly supports.

Return Value

Returns a custom plug-in assembly.

Remarks

An organization can configure an entity to use a specially designed form or functionality. To implement this specialized behavior, a developer creates a .NET assembly that defines the entity's extended functionality. These assemblies are then stored in the Object Repository and are added to the entity on the Plug-Ins tab. The entity uses the plug-ins specified on this tab to override standard functionality with the functionality specified in one or more plug-ins. Typical plug-ins include a specialized form (Viewer plug-in), business logic (Entity plug-in), duplicate record checking process (Duplicate Check type), context menu (Extension plug-in), record verification process (Verification plug-in), Find dialog (Find plug-in), and merging logic (Merge plug-in). See the Aptify Adminstration Guide for more information.

Example

 Dim oApplication As New Aptify.Framework.Application.AptifyApplication

 Dim oPlugIn As Aptify.Framework.Application.EntityPlugIn
 oPlugIn = oApplication.GetEntityPlugIn("Entities", Aptify.Framework.Application.EntityPlugInType.Viewer)

 Dim oObject As Object
 oObject = Aptify.Framework.Application.InstanceCreator.CreateInstance(oPlugIn.AssemblyName, oPlugIn.ClassName)

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.GetEntityPlugIn Overload List


AptifyApplication.GetEntityPlugIn Method (String, EntityPlugInType, Boolean)

Returns a custom plug-in assembly.

public EntityPlugIn GetEntityPlugIn(
String EntityName,
EntityPlugInType PlugInType,
Boolean DownloadObject
);

Parameters

EntityName
Name of the Entity.
PlugInType
Structure of object types that the assembly supports.
DownloadObject
Tells the caller to download the object from the repository.

Return Value

Returns a custom plug-in assembly.

Remarks

An organization can configure an entity to use a specially designed form or functionality. To implement this specialized behavior, a developer creates a .NET assembly that defines the entity's extended functionality. These assemblies are then stored in the Object Repository and are added to the entity on the Plug-Ins tab. The entity uses the plug-ins specified on this tab to override standard functionality with the functionality specified in one or more plug-ins. Typical plug-ins include a specialized form (Viewer plug-in), business logic (Entity plug-in), duplicate record checking process (Duplicate Check type), context menu (Extension plug-in), record verification process (Verification plug-in), Find dialog (Find plug-in), and merging logic (Merge plug-in). See the Aptify Adminstration Guide for more information.

Example

 Dim oApplication As New Aptify.Framework.Application.AptifyApplication

 Dim oPlugIn As Aptify.Framework.Application.EntityPlugIn
 oPlugIn = oApplication.GetEntityPlugIn("Entities", Aptify.Framework.Application.EntityPlugInType.Viewer, True)

 Dim oObject As Object
 oObject = Aptify.Framework.Application.InstanceCreator.CreateInstance(oPlugIn.AssemblyName, oPlugIn.ClassName)

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.GetEntityPlugIn Overload List


AptifyApplication.GetEntityPlugIn Method (String, String, Boolean)

public EntityPlugIn GetEntityPlugIn(
String EntityName,
String PlugInTypeName,
Boolean DownloadObject
);

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.GetEntityPlugIn Overload List


GetEntityRecordIDFromRecordName Method

Aptify 5.0 Software Development Kit (SDK)

AptifyApplication.GetEntityRecordIDFromRecordName Method

This method returns the record ID for a specified record given an Entity Name and the Record Name.

Overload List

This method returns the record ID for a specified record given an Entity Name and the Record Name.

public long GetEntityRecordIDFromRecordName(Int64,String);

This method returns the record ID for a specified record given an Entity Name and the Record Name.

public long GetEntityRecordIDFromRecordName(String,String);

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace


AptifyApplication.GetEntityRecordIDFromRecordName Method (Int64, String)

This method returns the record ID for a specified record given an Entity Name and the Record Name.

public long GetEntityRecordIDFromRecordName(
Int64 EntityID,
String RecordName
);

Parameters

EntityID
The ID of the entity
RecordName
The name of the record

Return Value

This method returns the record ID for a specified record given an Entity Name and the Record Name.

Remarks

The record name is the value of the field that has been marked as "IsName" within the entity. The method returns a blank string if no match is found. Note that not all entities have a field designated as "IsName." For entities without an IsName field, the method also returns a blank string.

Example

Dim oApplication As New Aptify.Framework.Application.AptifyApplication
Dim lResult As Long = oApplication.GetEntityRecordIDFromRecordName(80, "Views")

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.GetEntityRecordIDFromRecordName Overload List


AptifyApplication.GetEntityRecordIDFromRecordName Method (String, String)

This method returns the record ID for a specified record given an Entity Name and the Record Name.

public long GetEntityRecordIDFromRecordName(
String EntityName,
String RecordName
);

Parameters

EntityName
The name of the entity
RecordName
The name of the record

Return Value

This method returns the record ID for a specified record given an Entity Name and the Record Name.

Remarks

The record name is the value of the field that has been marked as "IsName" within the entity. The method returns a blank string if no match is found. Note that not all entities have a field designated as "IsName." For entities without an IsName field, the method also returns a blank string.

Example

Dim oApplication As New Aptify.Framework.Application.AptifyApplication
Dim lResult As Long = oApplication.GetEntityRecordIDFromRecordName("Entities", "Views")

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.GetEntityRecordIDFromRecordName Overload List


GetEntityRecordName Method

Aptify 5.0 Software Development Kit (SDK)

AptifyApplication.GetEntityRecordName Method

This method returns the record name for a specified Entity and record ID.

Overload List

This method returns the record name for a specified Entity and record ID.

public string GetEntityRecordName(Int64,Int64);

This method returns the record name for a specified Entity and record ID.

public string GetEntityRecordName(String,Int64);

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace


AptifyApplication.GetEntityRecordName Method (Int64, Int64)

This method returns the record name for a specified Entity and record ID.

public string GetEntityRecordName(
Int64 EntityID,
Int64 RecordID
);

Parameters

EntityID
The ID of the Entity
RecordID
The ID of the record.

Return Value

This method returns the record name for a specified Entity and record ID.

Remarks

The record name is the value of the field that has been marked as "IsName" within the entity. The method returns a blank string if no match is found. Note that not all entities have a field designated as "IsName." For entities without an IsName field, the method also returns a blank string.

Example

Dim oApplication As New Aptify.Framework.Application.AptifyApplication
Dim sResult As String = oApplication.GetEntityRecordName(80, 79)

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.GetEntityRecordName Overload List


AptifyApplication.GetEntityRecordName Method (String, Int64)

This method returns the record name for a specified Entity and record ID.

public string GetEntityRecordName(
String EntityName,
Int64 RecordID
);

Parameters

EntityName
The name of the Entity
RecordID
The id of the record.

Return Value

This method returns the record name for a specified Entity and record ID.

Remarks

The record name is the value of the field that has been marked as "IsName" within the entity. The method returns a blank string if no match is found. Note that not all entities have a field designated as "IsName." For entities without an IsName field, the method also returns a blank string.

Example

Dim oApplication As New Aptify.Framework.Application.AptifyApplication
Dim sResult As String = oApplication.GetEntityRecordName("Entities", 79)

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.GetEntityRecordName Overload List


GetEntityStoredProcedures Method

Aptify 5.0 Software Development Kit (SDK)

AptifyApplication.GetEntityStoredProcedures Method

Returns the collection of stored procedure names a user has for an entity.

Overload List

Returns the collection of stored procedure names a user has for an entity.

public EntityStoredProcedures GetEntityStoredProcedures(Int64);

Returns the collection of stored procedure names a user has for an entity.

public EntityStoredProcedures GetEntityStoredProcedures(String);

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace


AptifyApplication.GetEntityStoredProcedures Method (Int64)

Returns the collection of stored procedure names a user has for an entity.

public EntityStoredProcedures GetEntityStoredProcedures(
Int64 EntityID
);

Parameters

EntityID
The ID of the Entity.

Return Value

Returns the collection of stored procedure names a user has for an entity.

Example

Dim oApplication As New Aptify.Framework.Application.AptifyApplication
Dim oProcs As Aptify.Framework.Application.EntityStoredProcedures
oProcs = oApplication.GetEntityStoredProcedures(80)

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.GetEntityStoredProcedures Overload List


AptifyApplication.GetEntityStoredProcedures Method (String)

Returns the collection of stored procedure names a user has for an entity.

public EntityStoredProcedures GetEntityStoredProcedures(
String EntityName
);

Parameters

EntityName
The Name of the Entity.

Return Value

Returns the collection of stored procedure names a user has for an entity.

Example

Dim oApplication As New Aptify.Framework.Application.AptifyApplication
Dim oProcs As Aptify.Framework.Application.EntityStoredProcedures
oProcs = oApplication.GetEntityStoredProcedures("Entities")

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.GetEntityStoredProcedures Overload List


AptifyApplication.GetRegistryValue Method

Returns a single value from the registry.

public static string GetRegistryValue(
RegistryKey Root,
String SubKey,
String Value
);

Parameters

Root
Base registry key opened.
SubKey
The Key Path that should be opened, including subkeys.
Value
The name of the registry value that should be retrieved.

Return Value

Example

Dim oApplication As New Aptify.Framework.Application.AptifyApplication
Dim sValue As String
sValue = oApplication.GetRegistryValue(Microsoft.Win32.Registry.CurrentUser, "Control Panel\Current", "Color Schemes")

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace


AptifyApplication.GetUserValue Method

This method returns a user profile value from the database. Use it to determine user preferences using Application ID and Sequence parameters. If the User Value is not found, the DefaultValue parameter is returned.

public virtual string GetUserValue(
Int64 ApplicationID,
Int64 Sequence,
String Name,
String DefaultValue
);

Parameters

ApplicationID
Sequence
Name
DefaultValue

Return Value

Remarks

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace


AptifyApplication.GetUserValueDataTable Method

This method returns a datatable with a row of data representing a user profile value from the database. If a row is not found matching the specified ApplicationID and Sequence, Nothing is returned.

protected virtual DataTable GetUserValueDataTable(
Int64 ApplicationID,
Int64 Sequence,
String Name
);

Parameters

ApplicationID
Sequence
Name

Return Value

Remarks

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace


LoadBrandIcon Method

Aptify 5.0 Software Development Kit (SDK)

AptifyApplication.LoadBrandIcon Method

Replaces the Form Icon with default Icon or Branding Icon as per requirement.

Overload List

Replaces the Form Icon with default Icon or Branding Icon as per requirement.

public void LoadBrandIcon(ref Icon&,String);

Replaces the Form Icon with default Icon or Branding Icon as per requirement.

public void LoadBrandIcon(ref Form&,String);

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace


AptifyApplication.LoadBrandIcon Method (Icon&, String)

Replaces the Form Icon with default Icon or Branding Icon as per requirement.

public void LoadBrandIcon(
ref Icon& TargetIcon,
String EntityName
);

Parameters

TargetIcon
Icon that needs to be reloaded the Icon is to be loaded
EntityName
Name of the Entity for which the form is loaded. In case the Form is not Framework then EntityName is Blank.

Remarks

This is used to replace the Icon on the Form for Branding Purpose. The Icon will be loaded as per the Entity Icon set in case of entities like Persons, Companies. For Entities without any Icon specified Branding Icon will be displayed. In case branding Icon is not available then the Icon already set will remain.

Example

MyApp.LoadBrandIcon(Me, "Persons")

OR

MyApp.LoadBrandIcon(Me)

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.LoadBrandIcon Overload List


AptifyApplication.LoadBrandIcon Method (Form&, String)

Replaces the Form Icon with default Icon or Branding Icon as per requirement.

public void LoadBrandIcon(
ref Form& Target,
String EntityName
);

Parameters

Target
Form on which the Icon is to be loaded
EntityName
Name of the Entity for which the form is loaded. In case the Form is not Framework then EntityName is Blank.

Remarks

This is used to replace the Icon on the Form for Branding Purpose. The Icon will be loaded as per the Entity Icon set in case of entities like Persons, Companies. For Entities without any Icon specified Branding Icon will be displayed. In case branding Icon is not available then the Icon already set will remain.

Example

MyApp.LoadBrandIcon(Me, "Persons")

OR

MyApp.LoadBrandIcon(Me)

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.LoadBrandIcon Overload List


AptifyApplication.LogWrite Method

Writes a value to a specified log file.

public static void LogWrite(
String ModuleName,
Boolean Success,
String Params,
Single ElapsedTime
);

Parameters

ModuleName
Success
Params
ElapsedTime

Remarks

This used to do a check to see if log write was enabled. This was set at the entity level. Entity will have to be responsible for checking its log write status. Aptify recommends that you publish a custom exception type as a replacement for this method.

Example

MyApp.LogWrite("MyClass", true, "a=3", Now)

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace


PrintEntityRecord Method

Aptify 5.0 Software Development Kit (SDK)

AptifyApplication.PrintEntityRecord Method

Prints a given record in an entity.

Overload List

Prints a given record in an entity.

public void PrintEntityRecord(String,Int64);

Prints a given record in an entity.

public void PrintEntityRecord(String,Int64,Boolean);

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace


AptifyApplication.PrintEntityRecord Method (String, Int64)

Prints a given record in an entity.

public void PrintEntityRecord(
String EntityName,
Int64 RecordID
);

Parameters

EntityName
The name of the entity.
RecordID
The record Id of the entity.

Example

Dim oApplication As New Aptify.Framework.Application.AptifyApplication
oApplication.PrintEntityRecord("Entities", 80)

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.PrintEntityRecord Overload List


AptifyApplication.PrintEntityRecord Method (String, Int64, Boolean)

Prints a given record in an entity.

public void PrintEntityRecord(
String EntityName,
Int64 RecordID,
Boolean ShowBlankFields
);

Parameters

EntityName
The name of the entity.
RecordID
The record Id of the entity.
ShowBlankFields
True to show fields that are null

Example

Dim oApplication As New Aptify.Framework.Application.AptifyApplication
oApplication.PrintEntityRecord("Entities", 80,true)

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.PrintEntityRecord Overload List


AptifyApplication.PrintRecordset Method

Allows for the printing of a SQL statement that returns a single record set.

public void PrintRecordset(
String SQL,
Boolean NewPageEachRecord,
Boolean Landscape,
Int16 NumCopies,
String Printer,
Boolean ShowBlankFields
);

Parameters

SQL
T-SQL to retrieve the recordset.
NewPageEachRecord
Boolean value indicating if each record is on a new page.
Landscape
Boolean value if true prints in landscape.
NumCopies
Number of paper copies to print.
Printer
Name of the printer.
ShowBlankFields
Show blank records.

Example

MyApp.PrintRecordSet ("select * from vwEntities", false, false, true, 1, "default", false)

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace


AptifyApplication.PrintView Method

Allows for printing records from the view.

public void PrintView(
Int64 ViewID,
String ViewSQL,
String Printer,
Boolean Landscape,
Int16 NumCopies
);

Parameters

ViewID
Id of the view to get records from.
ViewSQL
TSQL to retrieve the recordset.
Printer
The name of the printer.
Landscape
Boolean value, if true prints in landscape.
NumCopies
The number of copies to print.

Example

MyApp.PrintView ("select * from vwEntities", false, false, true, 1, "default", false)

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace


AptifyApplication.RefreshEntityMetaData Method

Flushes the cache of entity meta data and re-retrieves.

public void RefreshEntityMetaData();

Example

Dim oApplication As New Aptify.Framework.Application.AptifyApplication
oApplication.RefreshEntityMetaData()

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace


AptifyApplication.SetUserValue Method

This method is responsible for saving a user profile value into the database for the specified Application ID and Sequence provided. If there is an existing Application ID and Sequence matching for the current user, that row is updated, otherwise a new row in the UserValues entity is created.

public virtual bool SetUserValue(
Int64 ApplicationID,
Int64 Sequence,
String Name,
String Value
);

Parameters

ApplicationID
Sequence
Name
Value

Return Value

Remarks

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace


ShowEntityDependencies Method

Aptify 5.0 Software Development Kit (SDK)

AptifyApplication.ShowEntityDependencies Method

Shows a collection that has a list of records that depend on this record.

Overload List

Shows a collection that has a list of records that depend on this record.

public void ShowEntityDependencies(EntityDependenciesBase);

public void ShowEntityDependencies(EntityDependenciesBase,Form);

Shows a collection that has a list of records that depend on this record.

public void ShowEntityDependencies(Int64,Int64);

public void ShowEntityDependencies(Int64,Int64,Form);

Shows a collection that has a list of records that depend on this record.

public void ShowEntityDependencies(String,Int64);

public void ShowEntityDependencies(String,Int64,Form);

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace


AptifyApplication.ShowEntityDependencies Method (EntityDependenciesBase)

Shows a collection that has a list of records that depend on this record.

public void ShowEntityDependencies(
EntityDependenciesBase Dependencies
);

Parameters

Dependencies
A collection of dependent records to display.

Example

Dim oApplication As New Aptify.Framework.Application.AptifyApplication
Dim oDeps As Aptify.Framework.BusinessLogic.GenericEntity.EntityDependenciesBase
oDeps = oApplication.GetEntityDependencies("Entities", 80)
oApplication.ShowEntityDependencies(oDeps)

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.ShowEntityDependencies Overload List


AptifyApplication.ShowEntityDependencies Method (EntityDependenciesBase, Form)

public void ShowEntityDependencies(
EntityDependenciesBase Dependencies,
Form ParentForm
);

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.ShowEntityDependencies Overload List


AptifyApplication.ShowEntityDependencies Method (Int64, Int64)

Shows a collection that has a list of records that depend on this record.

public void ShowEntityDependencies(
Int64 EntityID,
Int64 RecordID
);

Parameters

EntityID
Unique ID of the entity.
RecordID
A record ID.

Example

Dim oApplication As New Aptify.Framework.Application.AptifyApplication
oApplication.ShowEntityDependencies(80, 80)

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.ShowEntityDependencies Overload List


AptifyApplication.ShowEntityDependencies Method (Int64, Int64, Form)

public void ShowEntityDependencies(
Int64 EntityID,
Int64 RecordID,
Form ParentForm
);

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.ShowEntityDependencies Overload List


AptifyApplication.ShowEntityDependencies Method (String, Int64)

Shows a collection that has a list of records that depend on this record.

public void ShowEntityDependencies(
String EntityName,
Int64 RecordID
);

Parameters

EntityName
Unique name of the entity.
RecordID
A record ID.

Example

Dim oApplication As New Aptify.Framework.Application.AptifyApplication
oApplication.ShowEntityDependencies("Entities", 80)

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.ShowEntityDependencies Overload List


AptifyApplication.ShowEntityDependencies Method (String, Int64, Form)

public void ShowEntityDependencies(
String EntityName,
Int64 RecordID,
Form ParentForm
);

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.ShowEntityDependencies Overload List


ShowRecordHistory Method

Aptify 5.0 Software Development Kit (SDK)

AptifyApplication.ShowRecordHistory Method

Displays a list of record changes.

Overload List

Displays a list of record changes.

public bool ShowRecordHistory(Int64,Int64);

public bool ShowRecordHistory(Int64,Int64,Form);

Displays a list of record changes.

public bool ShowRecordHistory(String,Int64);

public bool ShowRecordHistory(String,Int64,Form);

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace


AptifyApplication.ShowRecordHistory Method (Int64, Int64)

Displays a list of record changes.

public bool ShowRecordHistory(
Int64 EntityID,
Int64 RecordID
);

Parameters

EntityID
Primary key of the entity.
RecordID
Primary key of the record.

Example

Dim oApplication As New Aptify.Framework.Application.AptifyApplication
oApplication.ShowRecordHistory(80, 80)

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.ShowRecordHistory Overload List


AptifyApplication.ShowRecordHistory Method (Int64, Int64, Form)

public bool ShowRecordHistory(
Int64 EntityID,
Int64 RecordID,
Form ParentForm
);

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.ShowRecordHistory Overload List


AptifyApplication.ShowRecordHistory Method (String, Int64)

Displays a list of record changes.

public bool ShowRecordHistory(
String EntityName,
Int64 RecordID
);

Parameters

EntityName
Name of the Entity.
RecordID
Primary key of the record.

Example

Dim oApplication As New Aptify.Framework.Application.AptifyApplication
oApplication.ShowRecordHistory("Entities", 80)

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.ShowRecordHistory Overload List


AptifyApplication.ShowRecordHistory Method (String, Int64, Form)

public bool ShowRecordHistory(
String EntityName,
Int64 RecordID,
Form ParentForm
);

See Also

AptifyApplication Class | Aptify.Framework.Application Namespace | AptifyApplication.ShowRecordHistory Overload List


AptifyApplication.ApplicationInfo Class

Application Information

For a list of all members of this type, see AptifyApplication.ApplicationInfo Members.

System.Object
AptifyApplication.ApplicationInfo

public class AptifyApplication.ApplicationInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyApplication (in AptifyApplication.dll)

See Also

AptifyApplication.ApplicationInfo Members | Aptify.Framework.Application Namespace


AptifyApplication.ApplicationInfo Members

AptifyApplication.ApplicationInfo overview

Public Instance Properties

Description
DisplayCultureStringID
DisplayName
DisplayNameWithCulture
HelpObject
HelpURL
Icon
IconLarge
ID
Name
ParentID
Status

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyApplication.ApplicationInfo Class | Aptify.Framework.Application Namespace


AptifyApplication.ApplicationInfo Properties

The properties of the AptifyApplication.ApplicationInfo class are listed below. For a complete list of AptifyApplication.ApplicationInfo class members, see the AptifyApplication.ApplicationInfo Members topic.

Public Instance Properties

Description
DisplayCultureStringID
DisplayName
DisplayNameWithCulture
HelpObject
HelpURL
Icon
IconLarge
ID
Name
ParentID
Status

See Also

AptifyApplication.ApplicationInfo Class | Aptify.Framework.Application Namespace


Description Property

Aptify 5.0 Software Development Kit (SDK)

AptifyApplication.ApplicationInfo.Description Property

public String Description {get;}

See Also

AptifyApplication.ApplicationInfo Class | Aptify.Framework.Application Namespace


DisplayCultureStringID Property

Aptify 5.0 Software Development Kit (SDK)

AptifyApplication.ApplicationInfo.DisplayCultureStringID Property

public Int64 DisplayCultureStringID {get;}

See Also

AptifyApplication.ApplicationInfo Class | Aptify.Framework.Application Namespace


DisplayName Property

Aptify 5.0 Software Development Kit (SDK)

AptifyApplication.ApplicationInfo.DisplayName Property

public String DisplayName {get;}

See Also

AptifyApplication.ApplicationInfo Class | Aptify.Framework.Application Namespace


DisplayNameWithCulture Property

Aptify 5.0 Software Development Kit (SDK)

AptifyApplication.ApplicationInfo.DisplayNameWithCulture Property

public String DisplayNameWithCulture {get;}

See Also

AptifyApplication.ApplicationInfo Class | Aptify.Framework.Application Namespace


HelpObject Property

Aptify 5.0 Software Development Kit (SDK)

AptifyApplication.ApplicationInfo.HelpObject Property

public String HelpObject {get;}

See Also

AptifyApplication.ApplicationInfo Class | Aptify.Framework.Application Namespace


HelpURL Property

Aptify 5.0 Software Development Kit (SDK)

AptifyApplication.ApplicationInfo.HelpURL Property

public String HelpURL {get;}

See Also

AptifyApplication.ApplicationInfo Class | Aptify.Framework.Application Namespace


Icon Property

Aptify 5.0 Software Development Kit (SDK)

AptifyApplication.ApplicationInfo.Icon Property

public String Icon {get;}

See Also

AptifyApplication.ApplicationInfo Class | Aptify.Framework.Application Namespace


IconLarge Property

Aptify 5.0 Software Development Kit (SDK)

AptifyApplication.ApplicationInfo.IconLarge Property

public String IconLarge {get;}

See Also

AptifyApplication.ApplicationInfo Class | Aptify.Framework.Application Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

AptifyApplication.ApplicationInfo.ID Property

public Int64 ID {get;}

See Also

AptifyApplication.ApplicationInfo Class | Aptify.Framework.Application Namespace


Name Property

Aptify 5.0 Software Development Kit (SDK)

AptifyApplication.ApplicationInfo.Name Property

public String Name {get;}

See Also

AptifyApplication.ApplicationInfo Class | Aptify.Framework.Application Namespace


ParentID Property

Aptify 5.0 Software Development Kit (SDK)

AptifyApplication.ApplicationInfo.ParentID Property

public Int64 ParentID {get;}

See Also

AptifyApplication.ApplicationInfo Class | Aptify.Framework.Application Namespace


Status Property

Aptify 5.0 Software Development Kit (SDK)

AptifyApplication.ApplicationInfo.Status Property

public AptifyApplication.ApplicationStatus Status {get;}

See Also

AptifyApplication.ApplicationInfo Class | Aptify.Framework.Application Namespace


AptifyApplication.ApplicationStatus Enumeration

public enum AptifyApplication.ApplicationStatus

Members

Member Name | Description
Inactive |
Active |

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyApplication (in AptifyApplication.dll)

See Also

Aptify.Framework.Application Namespace


AptifyApplicationEntityPermissionsRetrievalException Class

Unable to retrieve the data from the database for the entity permissions.

For a list of all members of this type, see AptifyApplicationEntityPermissionsRetrievalException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
AptifyApplicationException
AptifyApplicationEntityPermissionsRetrievalException

public class AptifyApplicationEntityPermissionsRetrievalException : AptifyApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyApplication (in AptifyApplication.dll)

See Also

AptifyApplicationEntityPermissionsRetrievalException Members | Aptify.Framework.Application Namespace


AptifyApplicationEntityPermissionsRetrievalException Members

AptifyApplicationEntityPermissionsRetrievalException overview

Public Instance Constructors

AptifyApplicationEntityPermissionsRetrievalException Overloaded. Initializes a new instance of the AptifyApplicationEntityPermissionsRetrievalException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Constructors

AptifyApplicationEntityPermissionsRetrievalException Overloaded. Initializes a new instance of the AptifyApplicationEntityPermissionsRetrievalException class.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyApplicationEntityPermissionsRetrievalException Class | Aptify.Framework.Application Namespace


AptifyApplicationEntityPermissionsRetrievalException Constructor

Overload List

protected AptifyApplicationEntityPermissionsRetrievalException(SerializationInfo,StreamingContext);

public AptifyApplicationEntityPermissionsRetrievalException(String,Int64);

See Also

AptifyApplicationEntityPermissionsRetrievalException Class | Aptify.Framework.Application Namespace


AptifyApplicationEntityPermissionsRetrievalException Constructor (String, Int64)

public AptifyApplicationEntityPermissionsRetrievalException(
String EntityName,
Int64 AptifyUserID
);

See Also

AptifyApplicationEntityPermissionsRetrievalException Class | Aptify.Framework.Application Namespace | AptifyApplicationEntityPermissionsRetrievalException Constructor Overload List


AptifyApplicationEntityPermissionsRetrievalException Constructor (SerializationInfo, StreamingContext)

protected AptifyApplicationEntityPermissionsRetrievalException(
SerializationInfo info,
StreamingContext context
);

See Also

AptifyApplicationEntityPermissionsRetrievalException Class | Aptify.Framework.Application Namespace | AptifyApplicationEntityPermissionsRetrievalException Constructor Overload List


AptifyApplicationEntityPermissionsRetrievalException Methods

The methods of the AptifyApplicationEntityPermissionsRetrievalException class are listed below. For a complete list of AptifyApplicationEntityPermissionsRetrievalException class members, see the AptifyApplicationEntityPermissionsRetrievalException Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyApplicationEntityPermissionsRetrievalException Class | Aptify.Framework.Application Namespace


AptifyApplicationEntityPermissionsRetrievalException.GetObjectData Method

public override void GetObjectData(
SerializationInfo info,
StreamingContext context
);

Implements

ISerializable.

See Also

AptifyApplicationEntityPermissionsRetrievalException Class | Aptify.Framework.Application Namespace


AptifyApplicationException Class

For a list of all members of this type, see AptifyApplicationException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
AptifyApplicationException
Derived types

public class AptifyApplicationException : BaseApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyApplication (in AptifyApplication.dll)

See Also

AptifyApplicationException Members | Aptify.Framework.Application Namespace


AptifyApplicationException Members

AptifyApplicationException overview

Public Instance Constructors

AptifyApplicationException Overloaded. Initializes a new instance of the AptifyApplicationException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Constructors

AptifyApplicationException Overloaded. Initializes a new instance of the AptifyApplicationException class.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyApplicationException Class | Aptify.Framework.Application Namespace


AptifyApplicationException Constructor

Overload List

public AptifyApplicationException(Int32,Int32,String);

public AptifyApplicationException(Int32,Int32,String,Exception);

protected AptifyApplicationException(SerializationInfo,StreamingContext);

public AptifyApplicationException(String);

public AptifyApplicationException(String,Exception);

See Also

AptifyApplicationException Class | Aptify.Framework.Application Namespace


AptifyApplicationException Constructor (String)

public AptifyApplicationException(
String Message
);

See Also

AptifyApplicationException Class | Aptify.Framework.Application Namespace | AptifyApplicationException Constructor Overload List


AptifyApplicationException Constructor (String, Exception)

public AptifyApplicationException(
String Message,
Exception inner
);

See Also

AptifyApplicationException Class | Aptify.Framework.Application Namespace | AptifyApplicationException Constructor Overload List


AptifyApplicationException Constructor (Int32, Int32, String)

public AptifyApplicationException(
Int32 ErrorNumber,
Int32 Severity,
String Message
);

See Also

AptifyApplicationException Class | Aptify.Framework.Application Namespace | AptifyApplicationException Constructor Overload List


AptifyApplicationException Constructor (Int32, Int32, String, Exception)

public AptifyApplicationException(
Int32 ErrorNumber,
Int32 Severity,
String Message,
Exception inner
);

See Also

AptifyApplicationException Class | Aptify.Framework.Application Namespace | AptifyApplicationException Constructor Overload List


AptifyApplicationException Constructor (SerializationInfo, StreamingContext)

protected AptifyApplicationException(
SerializationInfo info,
StreamingContext context
);

See Also

AptifyApplicationException Class | Aptify.Framework.Application Namespace | AptifyApplicationException Constructor Overload List


AptifyApplicationException Methods

The methods of the AptifyApplicationException class are listed below. For a complete list of AptifyApplicationException class members, see the AptifyApplicationException Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyApplicationException Class | Aptify.Framework.Application Namespace


AptifyApplicationException.GetObjectData Method

public override void GetObjectData(
SerializationInfo info,
StreamingContext context
);

Implements

ISerializable.

See Also

AptifyApplicationException Class | Aptify.Framework.Application Namespace


AptifyApplicationInvalidCommandStringException Class

Thrown when the command variable is not valid (i.e., a record ID for an open command type is not numeric).

For a list of all members of this type, see AptifyApplicationInvalidCommandStringException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
AptifyApplicationException
AptifyApplicationInvalidCommandStringException

public class AptifyApplicationInvalidCommandStringException : AptifyApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyApplication (in AptifyApplication.dll)

See Also

AptifyApplicationInvalidCommandStringException Members | Aptify.Framework.Application Namespace


AptifyApplicationInvalidCommandStringException Members

AptifyApplicationInvalidCommandStringException overview

Public Instance Constructors

AptifyApplicationInvalidCommandStringException Overloaded. Initializes a new instance of the AptifyApplicationInvalidCommandStringException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Constructors

AptifyApplicationInvalidCommandStringException Overloaded. Initializes a new instance of the AptifyApplicationInvalidCommandStringException class.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyApplicationInvalidCommandStringException Class | Aptify.Framework.Application Namespace


AptifyApplicationInvalidCommandStringException Constructor

Overload List

protected AptifyApplicationInvalidCommandStringException(SerializationInfo,StreamingContext);

public AptifyApplicationInvalidCommandStringException(String);

See Also

AptifyApplicationInvalidCommandStringException Class | Aptify.Framework.Application Namespace


AptifyApplicationInvalidCommandStringException Constructor (String)

public AptifyApplicationInvalidCommandStringException(
String CommandString
);

See Also

AptifyApplicationInvalidCommandStringException Class | Aptify.Framework.Application Namespace | AptifyApplicationInvalidCommandStringException Constructor Overload List


AptifyApplicationInvalidCommandStringException Constructor (SerializationInfo, StreamingContext)

protected AptifyApplicationInvalidCommandStringException(
SerializationInfo info,
StreamingContext context
);

See Also

AptifyApplicationInvalidCommandStringException Class | Aptify.Framework.Application Namespace | AptifyApplicationInvalidCommandStringException Constructor Overload List


AptifyApplicationInvalidCommandStringException Methods

The methods of the AptifyApplicationInvalidCommandStringException class are listed below. For a complete list of AptifyApplicationInvalidCommandStringException class members, see the AptifyApplicationInvalidCommandStringException Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyApplicationInvalidCommandStringException Class | Aptify.Framework.Application Namespace


AptifyApplicationInvalidCommandStringException.GetObjectData Method

public override void GetObjectData(
SerializationInfo info,
StreamingContext context
);

Implements

ISerializable.

See Also

AptifyApplicationInvalidCommandStringException Class | Aptify.Framework.Application Namespace


AptifyApplicationInvalidCommandTypeException Class

Thrown when a command passed in on a command string is not valid.

For a list of all members of this type, see AptifyApplicationInvalidCommandTypeException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
AptifyApplicationException
AptifyApplicationInvalidCommandTypeException

public class AptifyApplicationInvalidCommandTypeException : AptifyApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyApplication (in AptifyApplication.dll)

See Also

AptifyApplicationInvalidCommandTypeException Members | Aptify.Framework.Application Namespace


AptifyApplicationInvalidCommandTypeException Members

AptifyApplicationInvalidCommandTypeException overview

Public Instance Constructors

AptifyApplicationInvalidCommandTypeException Overloaded. Initializes a new instance of the AptifyApplicationInvalidCommandTypeException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Constructors

AptifyApplicationInvalidCommandTypeException Overloaded. Initializes a new instance of the AptifyApplicationInvalidCommandTypeException class.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyApplicationInvalidCommandTypeException Class | Aptify.Framework.Application Namespace


AptifyApplicationInvalidCommandTypeException Constructor

Overload List

protected AptifyApplicationInvalidCommandTypeException(SerializationInfo,StreamingContext);

public AptifyApplicationInvalidCommandTypeException(String);

See Also

AptifyApplicationInvalidCommandTypeException Class | Aptify.Framework.Application Namespace


AptifyApplicationInvalidCommandTypeException Constructor (String)

public AptifyApplicationInvalidCommandTypeException(
String CommandType
);

See Also

AptifyApplicationInvalidCommandTypeException Class | Aptify.Framework.Application Namespace | AptifyApplicationInvalidCommandTypeException Constructor Overload List


AptifyApplicationInvalidCommandTypeException Constructor (SerializationInfo, StreamingContext)

protected AptifyApplicationInvalidCommandTypeException(
SerializationInfo info,
StreamingContext context
);

See Also

AptifyApplicationInvalidCommandTypeException Class | Aptify.Framework.Application Namespace | AptifyApplicationInvalidCommandTypeException Constructor Overload List


AptifyApplicationInvalidCommandTypeException Methods

The methods of the AptifyApplicationInvalidCommandTypeException class are listed below. For a complete list of AptifyApplicationInvalidCommandTypeException class members, see the AptifyApplicationInvalidCommandTypeException Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyApplicationInvalidCommandTypeException Class | Aptify.Framework.Application Namespace


AptifyApplicationInvalidCommandTypeException.GetObjectData Method

public override void GetObjectData(
SerializationInfo info,
StreamingContext context
);

Implements

ISerializable.

See Also

AptifyApplicationInvalidCommandTypeException Class | Aptify.Framework.Application Namespace


AptifyApplicationInvalidEntityException Class

Thrown when an entity is not found.

For a list of all members of this type, see AptifyApplicationInvalidEntityException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
AptifyApplicationException
AptifyApplicationInvalidEntityException

public class AptifyApplicationInvalidEntityException : AptifyApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyApplication (in AptifyApplication.dll)

See Also

AptifyApplicationInvalidEntityException Members | Aptify.Framework.Application Namespace


AptifyApplicationInvalidEntityException Members

AptifyApplicationInvalidEntityException overview

Public Instance Constructors

AptifyApplicationInvalidEntityException Overloaded. Initializes a new instance of the AptifyApplicationInvalidEntityException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Constructors

AptifyApplicationInvalidEntityException Overloaded. Initializes a new instance of the AptifyApplicationInvalidEntityException class.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyApplicationInvalidEntityException Class | Aptify.Framework.Application Namespace


AptifyApplicationInvalidEntityException Constructor

Overload List

public AptifyApplicationInvalidEntityException(Int64);

protected AptifyApplicationInvalidEntityException(SerializationInfo,StreamingContext);

public AptifyApplicationInvalidEntityException(String);

See Also

AptifyApplicationInvalidEntityException Class | Aptify.Framework.Application Namespace


AptifyApplicationInvalidEntityException Constructor (Int64)

public AptifyApplicationInvalidEntityException(
Int64 EntityID
);

See Also

AptifyApplicationInvalidEntityException Class | Aptify.Framework.Application Namespace | AptifyApplicationInvalidEntityException Constructor Overload List


AptifyApplicationInvalidEntityException Constructor (String)

public AptifyApplicationInvalidEntityException(
String EntityName
);

See Also

AptifyApplicationInvalidEntityException Class | Aptify.Framework.Application Namespace | AptifyApplicationInvalidEntityException Constructor Overload List


AptifyApplicationInvalidEntityException Constructor (SerializationInfo, StreamingContext)

protected AptifyApplicationInvalidEntityException(
SerializationInfo info,
StreamingContext context
);

See Also

AptifyApplicationInvalidEntityException Class | Aptify.Framework.Application Namespace | AptifyApplicationInvalidEntityException Constructor Overload List


AptifyApplicationInvalidEntityException Methods

The methods of the AptifyApplicationInvalidEntityException class are listed below. For a complete list of AptifyApplicationInvalidEntityException class members, see the AptifyApplicationInvalidEntityException Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyApplicationInvalidEntityException Class | Aptify.Framework.Application Namespace


AptifyApplicationInvalidEntityException.GetObjectData Method

public override void GetObjectData(
SerializationInfo info,
StreamingContext context
);

Implements

ISerializable.

See Also

AptifyApplicationInvalidEntityException Class | Aptify.Framework.Application Namespace


AptifyApplicationInvalidViewException Class

Thrown when an entity view is not found.

For a list of all members of this type, see AptifyApplicationInvalidViewException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
AptifyApplicationException
AptifyApplicationInvalidViewException

public class AptifyApplicationInvalidViewException : AptifyApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyApplication (in AptifyApplication.dll)

See Also

AptifyApplicationInvalidViewException Members | Aptify.Framework.Application Namespace


AptifyApplicationInvalidViewException Members

AptifyApplicationInvalidViewException overview

Public Instance Constructors

AptifyApplicationInvalidViewException Overloaded. Initializes a new instance of the AptifyApplicationInvalidViewException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Constructors

AptifyApplicationInvalidViewException Overloaded. Initializes a new instance of the AptifyApplicationInvalidViewException class.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyApplicationInvalidViewException Class | Aptify.Framework.Application Namespace


AptifyApplicationInvalidViewException Constructor

Overload List

public AptifyApplicationInvalidViewException(Int64);

protected AptifyApplicationInvalidViewException(SerializationInfo,StreamingContext);

See Also

AptifyApplicationInvalidViewException Class | Aptify.Framework.Application Namespace


AptifyApplicationInvalidViewException Constructor (Int64)

public AptifyApplicationInvalidViewException(
Int64 ViewID
);

See Also

AptifyApplicationInvalidViewException Class | Aptify.Framework.Application Namespace | AptifyApplicationInvalidViewException Constructor Overload List


AptifyApplicationInvalidViewException Constructor (SerializationInfo, StreamingContext)

protected AptifyApplicationInvalidViewException(
SerializationInfo info,
StreamingContext context
);

See Also

AptifyApplicationInvalidViewException Class | Aptify.Framework.Application Namespace | AptifyApplicationInvalidViewException Constructor Overload List


AptifyApplicationInvalidViewException Methods

The methods of the AptifyApplicationInvalidViewException class are listed below. For a complete list of AptifyApplicationInvalidViewException class members, see the AptifyApplicationInvalidViewException Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyApplicationInvalidViewException Class | Aptify.Framework.Application Namespace


AptifyApplicationInvalidViewException.GetObjectData Method

public override void GetObjectData(
SerializationInfo info,
StreamingContext context
);

Implements

ISerializable.

See Also

AptifyApplicationInvalidViewException Class | Aptify.Framework.Application Namespace


AptifyAttachmentCategories Class

A collection of AptifyAttachmentCategory objects. AptifyAttachmentCategories is a collection of Aptify attachments. It inherits AptifyAttachmentCategory.

For a list of all members of this type, see AptifyAttachmentCategories Members.

System.Object
NameObjectCollectionBase
AptifyCollection
AptifyAttachmentCategories

public class AptifyAttachmentCategories : AptifyCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyApplication (in AptifyApplication.dll)

See Also

AptifyAttachmentCategories Members | Aptify.Framework.Application Namespace


AptifyAttachmentCategories Members

AptifyAttachmentCategories overview

Public Instance Properties

Count (inherited from NameObjectCollectionBase) | Gets the number of key/value pairs contained in the NameObjectCollectionBase instance.
EntityID | Primary key of the entity.
EntityName | Name of the entity.
Item | Overloaded. Identifies an Attachment in the collection.
Keys (inherited from NameObjectCollectionBase) | Gets a KeysCollection instance that contains all the keys in the NameObjectCollectionBase instance.
ParentCategory |

Public Instance Methods

Add | Overloaded.
Clear (inherited from AptifyCollection) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from AptifyCollection) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from NameObjectCollectionBase) | Implements the ISerializable interface and returns the data needed to serialize the NameObjectCollectionBase instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from AptifyCollection) | Gets the index of the item with the specified Key.
Merge (inherited from AptifyCollection) | Allows a user to merge items from another collection to this collection.
OnDeserialization (inherited from NameObjectCollectionBase) | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete.
Remove (inherited from AptifyCollection) | Overloaded.
RemoveAt (inherited from AptifyCollection) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

IsReadOnly (inherited from NameObjectCollectionBase) Gets or sets a value indicating whether the NameObjectCollectionBase instance is read-only.

Protected Instance Methods

BaseAdd (inherited from NameObjectCollectionBase) | Adds an entry with the specified key and value into the NameObjectCollectionBase instance.
BaseClear (inherited from NameObjectCollectionBase) | Removes all entries from the NameObjectCollectionBase instance.
BaseGet (inherited from NameObjectCollectionBase) | Overloaded. Gets the value of the first entry with the specified key from the NameObjectCollectionBase instance.
BaseGetAllKeys (inherited from NameObjectCollectionBase) | Returns a String array that contains all the keys in the NameObjectCollectionBase instance.
BaseGetAllValues (inherited from NameObjectCollectionBase) | Overloaded. Returns an Object array that contains all the values in the NameObjectCollectionBase instance.
BaseGetKey (inherited from NameObjectCollectionBase) | Gets the key of the entry at the specified index of the NameObjectCollectionBase instance.
BaseHasKeys (inherited from NameObjectCollectionBase) | Gets a value indicating whether the NameObjectCollectionBase instance contains entries whose keys are not null.
BaseRemove (inherited from NameObjectCollectionBase) | Removes the entries with the specified key from the NameObjectCollectionBase instance.
BaseRemoveAt (inherited from NameObjectCollectionBase) | Removes the entry at the specified index of the NameObjectCollectionBase instance.
BaseSet (inherited from NameObjectCollectionBase) | Overloaded. Sets the value of the first entry with the specified key in the NameObjectCollectionBase instance, if found; otherwise, adds an entry with the specified key and value into the NameObjectCollectionBase instance.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyAttachmentCategories Class | Aptify.Framework.Application Namespace


AptifyAttachmentCategories Properties

The properties of the AptifyAttachmentCategories class are listed below. For a complete list of AptifyAttachmentCategories class members, see the AptifyAttachmentCategories Members topic.

Public Instance Properties

Count (inherited from NameObjectCollectionBase) | Gets the number of key/value pairs contained in the NameObjectCollectionBase instance.
EntityID | Primary key of the entity.
EntityName | Name of the entity.
Item | Overloaded. Identifies an Attachment in the collection.
Keys (inherited from NameObjectCollectionBase) | Gets a KeysCollection instance that contains all the keys in the NameObjectCollectionBase instance.
ParentCategory |

Protected Instance Properties

IsReadOnly (inherited from NameObjectCollectionBase) Gets or sets a value indicating whether the NameObjectCollectionBase instance is read-only.

See Also

AptifyAttachmentCategories Class | Aptify.Framework.Application Namespace


EntityID Property

Aptify 5.0 Software Development Kit (SDK)

AptifyAttachmentCategories.EntityID Property

Primary key of the entity.

public Int64 EntityID {get;}

Property Value

Remarks

See Also

AptifyAttachmentCategories Class | Aptify.Framework.Application Namespace


EntityName Property

Aptify 5.0 Software Development Kit (SDK)

AptifyAttachmentCategories.EntityName Property

Name of the entity.

public String EntityName {get;}

Property Value

Remarks

See Also

AptifyAttachmentCategories Class | Aptify.Framework.Application Namespace


AptifyAttachmentCategory Property

Aptify 5.0 Software Development Kit (SDK)

AptifyAttachmentCategories.AptifyAttachmentCategory Property

Identifies an Attachment in the collection.

Overload List

Identifies an Attachment in the collection.

public AptifyAttachmentCategory this[Int32] {get; set;}

Identifies an Attachment in the collection.

public AptifyAttachmentCategory this[String] {get; set;}

See Also

AptifyAttachmentCategories Class | Aptify.Framework.Application Namespace


Item Property (Int32)

Aptify 5.0 Software Development Kit (SDK)

AptifyAttachmentCategories.Item Property (Int32)

Identifies an Attachment in the collection.

public AptifyAttachmentCategory this[
Int32 Index
] {get; set;}

Parameters

Index

Property Value

Remarks

See Also

AptifyAttachmentCategories Class | Aptify.Framework.Application Namespace | AptifyAttachmentCategories.AptifyAttachmentCategory Overload List


Item Property (String)

Aptify 5.0 Software Development Kit (SDK)

AptifyAttachmentCategories.Item Property (String)

Identifies an Attachment in the collection.

public AptifyAttachmentCategory this[
String Key
] {get; set;}

Parameters

Key

Property Value

Remarks

See Also

AptifyAttachmentCategories Class | Aptify.Framework.Application Namespace | AptifyAttachmentCategories.AptifyAttachmentCategory Overload List


ParentCategory Property

Aptify 5.0 Software Development Kit (SDK)

AptifyAttachmentCategories.ParentCategory Property

public AptifyAttachmentCategory ParentCategory {get;}

See Also

AptifyAttachmentCategories Class | Aptify.Framework.Application Namespace


AptifyAttachmentCategories Methods

The methods of the AptifyAttachmentCategories class are listed below. For a complete list of AptifyAttachmentCategories class members, see the AptifyAttachmentCategories Members topic.

Public Instance Methods

Add | Overloaded.
Clear (inherited from AptifyCollection) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from AptifyCollection) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from NameObjectCollectionBase) | Implements the ISerializable interface and returns the data needed to serialize the NameObjectCollectionBase instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from AptifyCollection) | Gets the index of the item with the specified Key.
Merge (inherited from AptifyCollection) | Allows a user to merge items from another collection to this collection.
OnDeserialization (inherited from NameObjectCollectionBase) | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete.
Remove (inherited from AptifyCollection) | Overloaded.
RemoveAt (inherited from AptifyCollection) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

BaseAdd (inherited from NameObjectCollectionBase) | Adds an entry with the specified key and value into the NameObjectCollectionBase instance.
BaseClear (inherited from NameObjectCollectionBase) | Removes all entries from the NameObjectCollectionBase instance.
BaseGet (inherited from NameObjectCollectionBase) | Overloaded. Gets the value of the first entry with the specified key from the NameObjectCollectionBase instance.
BaseGetAllKeys (inherited from NameObjectCollectionBase) | Returns a String array that contains all the keys in the NameObjectCollectionBase instance.
BaseGetAllValues (inherited from NameObjectCollectionBase) | Overloaded. Returns an Object array that contains all the values in the NameObjectCollectionBase instance.
BaseGetKey (inherited from NameObjectCollectionBase) | Gets the key of the entry at the specified index of the NameObjectCollectionBase instance.
BaseHasKeys (inherited from NameObjectCollectionBase) | Gets a value indicating whether the NameObjectCollectionBase instance contains entries whose keys are not null.
BaseRemove (inherited from NameObjectCollectionBase) | Removes the entries with the specified key from the NameObjectCollectionBase instance.
BaseRemoveAt (inherited from NameObjectCollectionBase) | Removes the entry at the specified index of the NameObjectCollectionBase instance.
BaseSet (inherited from NameObjectCollectionBase) | Overloaded. Sets the value of the first entry with the specified key in the NameObjectCollectionBase instance, if found; otherwise, adds an entry with the specified key and value into the NameObjectCollectionBase instance.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyAttachmentCategories Class | Aptify.Framework.Application Namespace


Add Method

Aptify 5.0 Software Development Kit (SDK)

AptifyAttachmentCategories.Add Method

Overload List

public int Add(AptifyAttachmentCategory);

public int Add(AptifyAttachmentCategory,String);

public int Add(Int64,String,String,Boolean);

public override int Add(Object);

public override int Add(Object,String);

See Also

AptifyAttachmentCategories Class | Aptify.Framework.Application Namespace


AptifyAttachmentCategories.Add Method (AptifyAttachmentCategory)

public int Add(
AptifyAttachmentCategory Value
);

See Also

AptifyAttachmentCategories Class | Aptify.Framework.Application Namespace | AptifyAttachmentCategories.Add Overload List


AptifyAttachmentCategories.Add Method (AptifyAttachmentCategory, String)

public int Add(
AptifyAttachmentCategory Value,
String Key
);

See Also

AptifyAttachmentCategories Class | Aptify.Framework.Application Namespace | AptifyAttachmentCategories.Add Overload List


AptifyAttachmentCategories.Add Method (Int64, String, String, Boolean)

public int Add(
Int64 ID,
String Name,
String Description,
Boolean TrackVersions
);

See Also

AptifyAttachmentCategories Class | Aptify.Framework.Application Namespace | AptifyAttachmentCategories.Add Overload List


AptifyAttachmentCategories.Add Method (Object)

public override int Add(
Object Value
);

See Also

AptifyAttachmentCategories Class | Aptify.Framework.Application Namespace | AptifyAttachmentCategories.Add Overload List


AptifyAttachmentCategories.Add Method (Object, String)

public override int Add(
Object Value,
String Key
);

See Also

AptifyAttachmentCategories Class | Aptify.Framework.Application Namespace | AptifyAttachmentCategories.Add Overload List


AptifyAttachmentCategory Class

An object the represents a grouping of attachments. AptifyAttachmentCategory is a data-only object. All properties access data members in the class.

For a list of all members of this type, see AptifyAttachmentCategory Members.

System.Object
AptifyAttachmentCategory

public class AptifyAttachmentCategory

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyApplication (in AptifyApplication.dll)

See Also

AptifyAttachmentCategory Members | Aptify.Framework.Application Namespace


AptifyAttachmentCategory Members

AptifyAttachmentCategory overview

Public Instance Constructors

AptifyAttachmentCategory Constructor

Public Instance Properties

Children | A collection of Aptify attachments that are children of the attachment category.
Description | A text description of the category for the user.
ID | Primary key of the category.
Name | Unique name of the application category.
ParentCollection | A collection of Aptify attachments that are parents of the attachment category.
ParentID | Foreign key of the parent. -1 if it does not have a parent.
TrackVersions | If true, the changes made to the category are tracked using the Record History functionality.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyAttachmentCategory Class | Aptify.Framework.Application Namespace


AptifyAttachmentCategory Constructor

public AptifyAttachmentCategory(
Int64 ID,
Int64 ParentCategoryID,
String Name,
String Description,
Boolean TrackVersions
);

See Also

AptifyAttachmentCategory Class | Aptify.Framework.Application Namespace


AptifyAttachmentCategory Properties

The properties of the AptifyAttachmentCategory class are listed below. For a complete list of AptifyAttachmentCategory class members, see the AptifyAttachmentCategory Members topic.

Public Instance Properties

Children | A collection of Aptify attachments that are children of the attachment category.
Description | A text description of the category for the user.
ID | Primary key of the category.
Name | Unique name of the application category.
ParentCollection | A collection of Aptify attachments that are parents of the attachment category.
ParentID | Foreign key of the parent. -1 if it does not have a parent.
TrackVersions | If true, the changes made to the category are tracked using the Record History functionality.

See Also

AptifyAttachmentCategory Class | Aptify.Framework.Application Namespace


Children Property

Aptify 5.0 Software Development Kit (SDK)

AptifyAttachmentCategory.Children Property

A collection of Aptify attachments that are children of the attachment category.

public AptifyAttachmentCategories Children {get;}

Property Value

Remarks

See Also

AptifyAttachmentCategory Class | Aptify.Framework.Application Namespace


Description Property

Aptify 5.0 Software Development Kit (SDK)

AptifyAttachmentCategory.Description Property

A text description of the category for the user.

public String Description {get; set;}

Property Value

Remarks

See Also

AptifyAttachmentCategory Class | Aptify.Framework.Application Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

AptifyAttachmentCategory.ID Property

Primary key of the category.

public Int64 ID {get;}

Property Value

Remarks

See Also

AptifyAttachmentCategory Class | Aptify.Framework.Application Namespace


Name Property

Aptify 5.0 Software Development Kit (SDK)

AptifyAttachmentCategory.Name Property

Unique name of the application category.

public String Name {get; set;}

Property Value

Remarks

See Also

AptifyAttachmentCategory Class | Aptify.Framework.Application Namespace


ParentCollection Property

Aptify 5.0 Software Development Kit (SDK)

AptifyAttachmentCategory.ParentCollection Property

A collection of Aptify attachments that are parents of the attachment category.

public AptifyAttachmentCategories ParentCollection {get;}

Property Value

Remarks

See Also

AptifyAttachmentCategory Class | Aptify.Framework.Application Namespace


ParentID Property

Aptify 5.0 Software Development Kit (SDK)

AptifyAttachmentCategory.ParentID Property

Foreign key of the parent. -1 if it does not have a parent.

public Int64 ParentID {get;}

Property Value

Remarks

See Also

AptifyAttachmentCategory Class | Aptify.Framework.Application Namespace


TrackVersions Property

Aptify 5.0 Software Development Kit (SDK)

AptifyAttachmentCategory.TrackVersions Property

If true, the changes made to the category are tracked using the Record History functionality.

public Boolean TrackVersions {get; set;}

Property Value

Remarks

See Also

AptifyAttachmentCategory Class | Aptify.Framework.Application Namespace


AptifyAttachments Class

Object used to manage a record's attachments.

For a list of all members of this type, see AptifyAttachments Members.

System.Object
AptifyAttachments

public class AptifyAttachments

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyApplication (in AptifyApplication.dll)

See Also

AptifyAttachments Members | Aptify.Framework.Application Namespace


AptifyAttachments Members

AptifyAttachments overview

Public Instance Constructors

AptifyAttachments Overloaded. Initializes a new instance of the AptifyAttachments class.

Public Instance Properties

Attachments
AttachmentsByCategory
CategoryFilter
Entity
EntityID
RecordID
RecordName
UserCredentials

Public Instance Methods

AddAttachment | Overloaded. Add a file attachment to the object.
DeleteAttachment | Deletes the reference to the attachment, not the file itself.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAllCategories | Returns a collection of all of the attachment categories.
GetAttachmentFile | Overloaded. Opens a file attachment.
GetCategory | Returns a category for a given attachment.
GetChildCategories | Returns a collection of all of the attachment categories that are a children to this ID.
GetFileAssociatedProgram | Returns the program that has been assigned to open for this file extension.
GetFileExtension | Given a File, return the file's extension.
GetFileNameFromFile | Returns the file name from a fully qualified path.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
KillFile | Physically deletes a file from disk.
OpenAttachment | Opens a file using the application assigned to the file extension.
Refresh | Re-retrieves the list of record attachments.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateFile | Changes the file with the new file.

Public Instance Events

StatusUpdate

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyAttachments Class | Aptify.Framework.Application Namespace


AptifyAttachments Constructor

Overload List

public AptifyAttachments(AptifyApplication,String,Int64);

public AptifyAttachments(AptifyApplication,String,Int64,String);

public AptifyAttachments(UserCredentials,String,Int64);

public AptifyAttachments(UserCredentials,String,Int64,String);

See Also

AptifyAttachments Class | Aptify.Framework.Application Namespace


AptifyAttachments Constructor (AptifyApplication, String, Int64)

public AptifyAttachments(
AptifyApplication Application,
String EntityName,
Int64 RecordID
);

See Also

AptifyAttachments Class | Aptify.Framework.Application Namespace | AptifyAttachments Constructor Overload List


AptifyAttachments Constructor (AptifyApplication, String, Int64, String)

public AptifyAttachments(
AptifyApplication Application,
String EntityName,
Int64 RecordID,
String RecordName
);

See Also

AptifyAttachments Class | Aptify.Framework.Application Namespace | AptifyAttachments Constructor Overload List


AptifyAttachments Constructor (UserCredentials, String, Int64)

public AptifyAttachments(
UserCredentials UserCredentials,
String EntityName,
Int64 RecordID
);

See Also

AptifyAttachments Class | Aptify.Framework.Application Namespace | AptifyAttachments Constructor Overload List


AptifyAttachments Constructor (UserCredentials, String, Int64, String)

public AptifyAttachments(
UserCredentials UserCredentials,
String EntityName,
Int64 RecordID,
String RecordName
);

See Also

AptifyAttachments Class | Aptify.Framework.Application Namespace | AptifyAttachments Constructor Overload List


AptifyAttachments Properties

The properties of the AptifyAttachments class are listed below. For a complete list of AptifyAttachments class members, see the AptifyAttachments Members topic.

Public Instance Properties

Attachments
AttachmentsByCategory
CategoryFilter
Entity
EntityID
RecordID
RecordName
UserCredentials

See Also

AptifyAttachments Class | Aptify.Framework.Application Namespace


Attachments Property

Aptify 5.0 Software Development Kit (SDK)

AptifyAttachments.Attachments Property

public DataTable Attachments {get;}

See Also

AptifyAttachments Class | Aptify.Framework.Application Namespace


AttachmentsByCategory Property

Aptify 5.0 Software Development Kit (SDK)

AptifyAttachments.AttachmentsByCategory Property

public DataRow[] this[
Int64 CategoryID
] {get;}

See Also

AptifyAttachments Class | Aptify.Framework.Application Namespace


CategoryFilter Property

Aptify 5.0 Software Development Kit (SDK)

AptifyAttachments.CategoryFilter Property

public Int64 CategoryFilter {get; set;}

See Also

AptifyAttachments Class | Aptify.Framework.Application Namespace


Entity Property

Aptify 5.0 Software Development Kit (SDK)

AptifyAttachments.Entity Property

public String Entity {get;}

See Also

AptifyAttachments Class | Aptify.Framework.Application Namespace


EntityID Property

Aptify 5.0 Software Development Kit (SDK)

AptifyAttachments.EntityID Property

public Int64 EntityID {get;}

See Also

AptifyAttachments Class | Aptify.Framework.Application Namespace


RecordID Property

Aptify 5.0 Software Development Kit (SDK)

AptifyAttachments.RecordID Property

public Int64 RecordID {get;}

See Also

AptifyAttachments Class | Aptify.Framework.Application Namespace


RecordName Property

Aptify 5.0 Software Development Kit (SDK)

AptifyAttachments.RecordName Property

public String RecordName {get;}

See Also

AptifyAttachments Class | Aptify.Framework.Application Namespace


UserCredentials Property

Aptify 5.0 Software Development Kit (SDK)

AptifyAttachments.UserCredentials Property

public UserCredentials UserCredentials {get;}

See Also

AptifyAttachments Class | Aptify.Framework.Application Namespace


AptifyAttachments Methods

The methods of the AptifyAttachments class are listed below. For a complete list of AptifyAttachments class members, see the AptifyAttachments Members topic.

Public Instance Methods

AddAttachment | Overloaded. Add a file attachment to the object.
DeleteAttachment | Deletes the reference to the attachment, not the file itself.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAllCategories | Returns a collection of all of the attachment categories.
GetAttachmentFile | Overloaded. Opens a file attachment.
GetCategory | Returns a category for a given attachment.
GetChildCategories | Returns a collection of all of the attachment categories that are a children to this ID.
GetFileAssociatedProgram | Returns the program that has been assigned to open for this file extension.
GetFileExtension | Given a File, return the file's extension.
GetFileNameFromFile | Returns the file name from a fully qualified path.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
KillFile | Physically deletes a file from disk.
OpenAttachment | Opens a file using the application assigned to the file extension.
Refresh | Re-retrieves the list of record attachments.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateFile | Changes the file with the new file.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyAttachments Class | Aptify.Framework.Application Namespace


AddAttachment Method

Aptify 5.0 Software Development Kit (SDK)

AptifyAttachments.AddAttachment Method

Add a file attachment to the object.

Overload List

Add a file attachment to the object.

public bool AddAttachment(String,Int64,String);

Add a file attachment to the object.

public bool AddAttachment(String,String);

See Also

AptifyAttachments Class | Aptify.Framework.Application Namespace


AptifyAttachments.AddAttachment Method (String, Int64, String)

Add a file attachment to the object.

public bool AddAttachment(
String File,
Int64 CategoryID,
String Description
);

Parameters

File
CategoryID
Description

Return Value

Remarks

See Also

AptifyAttachments Class | Aptify.Framework.Application Namespace | AptifyAttachments.AddAttachment Overload List


AptifyAttachments.AddAttachment Method (String, String)

Add a file attachment to the object.

public bool AddAttachment(
String File,
String Description
);

Parameters

File
Description

Return Value

Remarks

Adds attachment with -1 as category ID.

See Also

AptifyAttachments Class | Aptify.Framework.Application Namespace | AptifyAttachments.AddAttachment Overload List


AptifyAttachments.DeleteAttachment Method

Deletes the reference to the attachment, not the file itself.

public bool DeleteAttachment(
Int64 ID
);

Parameters

ID

See Also

AptifyAttachments Class | Aptify.Framework.Application Namespace


AptifyAttachments.GetAllCategories Method

Returns a collection of all of the attachment categories.

public AptifyAttachmentCategories GetAllCategories();

Return Value

Remarks

See Also

AptifyAttachments Class | Aptify.Framework.Application Namespace


GetAttachmentFile Method

Aptify 5.0 Software Development Kit (SDK)

AptifyAttachments.GetAttachmentFile Method

Opens a file attachment.

Overload List

Opens a file attachment.

public string GetAttachmentFile(Int64);

Opens a file attachment.

public string GetAttachmentFile(Int64,String);

See Also

AptifyAttachments Class | Aptify.Framework.Application Namespace


AptifyAttachments.GetAttachmentFile Method (Int64)

Opens a file attachment.

public string GetAttachmentFile(
Int64 ID
);

Parameters

ID

Return Value

The name of the File, including the path.

Remarks

The attachment can also be stored on the local file system.

See Also

AptifyAttachments Class | Aptify.Framework.Application Namespace | AptifyAttachments.GetAttachmentFile Overload List


AptifyAttachments.GetAttachmentFile Method (Int64, String)

Opens a file attachment.

public string GetAttachmentFile(
Int64 ID,
String LocalFileName
);

Parameters

ID
LocalFileName

Return Value

The name of the File, including the path.

Remarks

The attachment can also be stored on the local file system.

See Also

AptifyAttachments Class | Aptify.Framework.Application Namespace | AptifyAttachments.GetAttachmentFile Overload List


AptifyAttachments.GetCategory Method

Returns a category for a given attachment.

public AptifyAttachmentCategory GetCategory(
Int64 AttachmentID
);

Parameters

AttachmentID

Return Value

Remarks

See Also

AptifyAttachments Class | Aptify.Framework.Application Namespace


AptifyAttachments.GetChildCategories Method

Returns a collection of all of the attachment categories that are a children to this ID.

public AptifyAttachmentCategories GetChildCategories(
Int64 ParentCategoryID
);

Parameters

ParentCategoryID

Return Value

Remarks

See Also

AptifyAttachments Class | Aptify.Framework.Application Namespace


AptifyAttachments.GetFileAssociatedProgram Method

Returns the program that has been assigned to open for this file extension.

public string GetFileAssociatedProgram(
String File
);

Parameters

File

See Also

AptifyAttachments Class | Aptify.Framework.Application Namespace


AptifyAttachments.GetFileExtension Method

Given a File, return the file's extension.

public string GetFileExtension(
String file
);

Parameters

file

Return Value

Remarks

See Also

AptifyAttachments Class | Aptify.Framework.Application Namespace


AptifyAttachments.GetFileNameFromFile Method

Returns the file name from a fully qualified path.

public string GetFileNameFromFile(
String sFile
);

Parameters

sFile

Return Value

Returns the file name from a fully qualified path.

See Also

AptifyAttachments Class | Aptify.Framework.Application Namespace


AptifyAttachments.KillFile Method

Physically deletes a file from disk.

public bool KillFile(
String File
);

Parameters

File

Return Value

Remarks

Aptify recommends the use of Delete.

See Also

AptifyAttachments Class | Aptify.Framework.Application Namespace


AptifyAttachments.OpenAttachment Method

Opens a file using the application assigned to the file extension.

public bool OpenAttachment(
Int64 ID
);

Parameters

ID

See Also

AptifyAttachments Class | Aptify.Framework.Application Namespace


AptifyAttachments.Refresh Method

Re-retrieves the list of record attachments.

public void Refresh();

See Also

AptifyAttachments Class | Aptify.Framework.Application Namespace


AptifyAttachments.UpdateFile Method

Changes the file with the new file.

public bool UpdateFile(
Int64 ID,
String File
);

Parameters

ID
File

See Also

AptifyAttachments Class | Aptify.Framework.Application Namespace


AptifyAttachments Events

The events of the AptifyAttachments class are listed below. For a complete list of AptifyAttachments class members, see the AptifyAttachments Members topic.

Public Instance Events

StatusUpdate

See Also

AptifyAttachments Class | Aptify.Framework.Application Namespace


AptifyAttachments.AptifyAttachments.StatusUpdateEventHandler Event

public event AptifyAttachments.StatusUpdateEventHandler StatusUpdate;

See Also

AptifyAttachments Class | Aptify.Framework.Application Namespace


AptifyAttachments.StatusUpdateEventHandler Delegate

public delegate void AptifyAttachments.StatusUpdateEventHandler(
AttachmentOperation Operation,
AttachmentSubOperation SubOperation,
Int32 PercentComplete
);

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyApplication (in AptifyApplication.dll)

See Also

Aptify.Framework.Application Namespace


AptifyCollection Class

For a list of all members of this type, see AptifyCollection Members.

System.Object
NameObjectCollectionBase
AptifyCollection
Derived types

public class AptifyCollection : NameObjectCollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyUtility (in AptifyUtility.dll)

See Also

AptifyCollection Members | Aptify.Framework.Application Namespace


AptifyCollection Members

AptifyCollection overview

Public Instance Constructors

AptifyCollection Overloaded. Initializes a new instance of the AptifyCollection class.

Public Instance Properties

Count (inherited from NameObjectCollectionBase) | Gets the number of key/value pairs contained in the NameObjectCollectionBase instance.
Item | Overloaded.
Keys (inherited from NameObjectCollectionBase) | Gets a KeysCollection instance that contains all the keys in the NameObjectCollectionBase instance.

Public Instance Methods

Add | Overloaded. Allows a user to add a Value to the Collection.
Clear |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from NameObjectCollectionBase) | Implements the ISerializable interface and returns the data needed to serialize the NameObjectCollectionBase instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Gets the index of the item with the specified Key.
Merge | Allows a user to merge items from another collection to this collection.
OnDeserialization (inherited from NameObjectCollectionBase) | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete.
Remove | Overloaded.
RemoveAt |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

IsReadOnly (inherited from NameObjectCollectionBase) Gets or sets a value indicating whether the NameObjectCollectionBase instance is read-only.

Protected Instance Methods

BaseAdd (inherited from NameObjectCollectionBase) | Adds an entry with the specified key and value into the NameObjectCollectionBase instance.
BaseClear (inherited from NameObjectCollectionBase) | Removes all entries from the NameObjectCollectionBase instance.
BaseGet (inherited from NameObjectCollectionBase) | Overloaded. Gets the value of the first entry with the specified key from the NameObjectCollectionBase instance.
BaseGetAllKeys (inherited from NameObjectCollectionBase) | Returns a String array that contains all the keys in the NameObjectCollectionBase instance.
BaseGetAllValues (inherited from NameObjectCollectionBase) | Overloaded. Returns an Object array that contains all the values in the NameObjectCollectionBase instance.
BaseGetKey (inherited from NameObjectCollectionBase) | Gets the key of the entry at the specified index of the NameObjectCollectionBase instance.
BaseHasKeys (inherited from NameObjectCollectionBase) | Gets a value indicating whether the NameObjectCollectionBase instance contains entries whose keys are not null.
BaseRemove (inherited from NameObjectCollectionBase) | Removes the entries with the specified key from the NameObjectCollectionBase instance.
BaseRemoveAt (inherited from NameObjectCollectionBase) | Removes the entry at the specified index of the NameObjectCollectionBase instance.
BaseSet (inherited from NameObjectCollectionBase) | Overloaded. Sets the value of the first entry with the specified key in the NameObjectCollectionBase instance, if found; otherwise, adds an entry with the specified key and value into the NameObjectCollectionBase instance.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyCollection Class | Aptify.Framework.Application Namespace


AptifyCollection Constructor

Initializes a new instance of the AptifyCollection class.

Overload List

Initializes a new instance of the AptifyCollection class.

public AptifyCollection();

public AptifyCollection(Int32);

See Also

AptifyCollection Class | Aptify.Framework.Application Namespace


AptifyCollection Constructor ()

Initializes a new instance of the AptifyCollection class.

public AptifyCollection();

See Also

AptifyCollection Class | Aptify.Framework.Application Namespace | AptifyCollection Constructor Overload List


AptifyCollection Constructor (Int32)

public AptifyCollection(
Int32 capacity
);

See Also

AptifyCollection Class | Aptify.Framework.Application Namespace | AptifyCollection Constructor Overload List


AptifyCollection Properties

The properties of the AptifyCollection class are listed below. For a complete list of AptifyCollection class members, see the AptifyCollection Members topic.

Public Instance Properties

Count (inherited from NameObjectCollectionBase) | Gets the number of key/value pairs contained in the NameObjectCollectionBase instance.
Item | Overloaded.
Keys (inherited from NameObjectCollectionBase) | Gets a KeysCollection instance that contains all the keys in the NameObjectCollectionBase instance.

Protected Instance Properties

IsReadOnly (inherited from NameObjectCollectionBase) Gets or sets a value indicating whether the NameObjectCollectionBase instance is read-only.

See Also

AptifyCollection Class | Aptify.Framework.Application Namespace


Object Property

Aptify 5.0 Software Development Kit (SDK)

AptifyCollection.Object Property

Overload List

public virtual Object this[Int32] {get; set;}

public virtual Object this[String] {get; set;}

See Also

AptifyCollection Class | Aptify.Framework.Application Namespace


Item Property (Int32)

Aptify 5.0 Software Development Kit (SDK)

AptifyCollection.Item Property (Int32)

public virtual Object this[
Int32 Index
] {get; set;}

See Also

AptifyCollection Class | Aptify.Framework.Application Namespace | AptifyCollection.Object Overload List


Item Property (String)

Aptify 5.0 Software Development Kit (SDK)

AptifyCollection.Item Property (String)

public virtual Object this[
String Key
] {get; set;}

See Also

AptifyCollection Class | Aptify.Framework.Application Namespace | AptifyCollection.Object Overload List


AptifyCollection Methods

The methods of the AptifyCollection class are listed below. For a complete list of AptifyCollection class members, see the AptifyCollection Members topic.

Public Instance Methods

Add | Overloaded. Allows a user to add a Value to the Collection.
Clear |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from NameObjectCollectionBase) | Implements the ISerializable interface and returns the data needed to serialize the NameObjectCollectionBase instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Gets the index of the item with the specified Key.
Merge | Allows a user to merge items from another collection to this collection.
OnDeserialization (inherited from NameObjectCollectionBase) | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete.
Remove | Overloaded.
RemoveAt |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

BaseAdd (inherited from NameObjectCollectionBase) | Adds an entry with the specified key and value into the NameObjectCollectionBase instance.
BaseClear (inherited from NameObjectCollectionBase) | Removes all entries from the NameObjectCollectionBase instance.
BaseGet (inherited from NameObjectCollectionBase) | Overloaded. Gets the value of the first entry with the specified key from the NameObjectCollectionBase instance.
BaseGetAllKeys (inherited from NameObjectCollectionBase) | Returns a String array that contains all the keys in the NameObjectCollectionBase instance.
BaseGetAllValues (inherited from NameObjectCollectionBase) | Overloaded. Returns an Object array that contains all the values in the NameObjectCollectionBase instance.
BaseGetKey (inherited from NameObjectCollectionBase) | Gets the key of the entry at the specified index of the NameObjectCollectionBase instance.
BaseHasKeys (inherited from NameObjectCollectionBase) | Gets a value indicating whether the NameObjectCollectionBase instance contains entries whose keys are not null.
BaseRemove (inherited from NameObjectCollectionBase) | Removes the entries with the specified key from the NameObjectCollectionBase instance.
BaseRemoveAt (inherited from NameObjectCollectionBase) | Removes the entry at the specified index of the NameObjectCollectionBase instance.
BaseSet (inherited from NameObjectCollectionBase) | Overloaded. Sets the value of the first entry with the specified key in the NameObjectCollectionBase instance, if found; otherwise, adds an entry with the specified key and value into the NameObjectCollectionBase instance.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyCollection Class | Aptify.Framework.Application Namespace


Add Method

Aptify 5.0 Software Development Kit (SDK)

AptifyCollection.Add Method

Allows a user to add a Value to the Collection.

Overload List

Allows a user to add a Value to the Collection.

public virtual int Add(Object);

Allows a user to add a Value to the Collection.

public virtual int Add(Object,String);

See Also

AptifyCollection Class | Aptify.Framework.Application Namespace


AptifyCollection.Add Method (Object)

Allows a user to add a Value to the Collection.

public virtual int Add(
Object Value
);

Parameters

Value

Return Value

The index that the value was added at.

Remarks

This item will only be able to be refered to by it's index.

See Also

AptifyCollection Class | Aptify.Framework.Application Namespace | AptifyCollection.Add Overload List


AptifyCollection.Add Method (Object, String)

Allows a user to add a Value to the Collection.

public virtual int Add(
Object Value,
String Key
);

Parameters

Value
The value that this item represents.
Key
The text based key that can be used to retrieve the added Value.

Return Value

The index that the value was added at.

Remarks

Note the position of Value and Key, this was done for VB 6 compatibility.

See Also

AptifyCollection Class | Aptify.Framework.Application Namespace | AptifyCollection.Add Overload List


AptifyCollection.Clear Method

public virtual void Clear();

See Also

AptifyCollection Class | Aptify.Framework.Application Namespace


AptifyCollection.GetEnumerator Method

new public IEnumerator GetEnumerator();

Implements

IEnumerable.

See Also

AptifyCollection Class | Aptify.Framework.Application Namespace


AptifyCollection.IndexOf Method

Gets the index of the item with the specified Key.

public virtual int IndexOf(
String Key
);

Parameters

Key
The Key of the item to retrieve. The Key is not sensitive to case.

Return Value

The index of the item with the given Key, -1 if the item does not exist.

Remarks

This function assumes that the Keys collection contains unique values, we therefore return the index of the first instance is found. The search is case sensitive.

See Also

AptifyCollection Class | Aptify.Framework.Application Namespace


AptifyCollection.Merge Method

Allows a user to merge items from another collection to this collection.

public virtual void Merge(
AptifyCollection ItemsToMerge,
Boolean OverwriteMatchingProperties
);

Parameters

ItemsToMerge
A collection to merge with the current collection
OverwriteMatchingProperties
Set to true if a matching Key should be overwritten by the Value in the ItemsToMerge parameter.

Remarks

See Also

AptifyCollection Class | Aptify.Framework.Application Namespace


Remove Method

Aptify 5.0 Software Development Kit (SDK)

AptifyCollection.Remove Method

Overload List

public virtual void Remove(Int32);

public virtual void Remove(String);

See Also

AptifyCollection Class | Aptify.Framework.Application Namespace


AptifyCollection.Remove Method (Int32)

public virtual void Remove(
Int32 Index
);

See Also

AptifyCollection Class | Aptify.Framework.Application Namespace | AptifyCollection.Remove Overload List


AptifyCollection.Remove Method (String)

public virtual void Remove(
String Key
);

See Also

AptifyCollection Class | Aptify.Framework.Application Namespace | AptifyCollection.Remove Overload List


AptifyCollection.RemoveAt Method

public virtual void RemoveAt(
Int32 Index
);

See Also

AptifyCollection Class | Aptify.Framework.Application Namespace


AptifyConfigurationOptions Class

Configuration Options Dialog Box

For a list of all members of this type, see AptifyConfigurationOptions Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
AptifyConfigurationOptions

public class AptifyConfigurationOptions : Form

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyApplication (in AptifyApplication.dll)

See Also

AptifyConfigurationOptions Members | Aptify.Framework.Application Namespace


AptifyConfigurationOptions Members

AptifyConfigurationOptions overview

Public Instance Constructors

AptifyConfigurationOptions Constructor Initializes a new instance of the AptifyConfigurationOptions class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

AptifyConfigurationOptions Class | Aptify.Framework.Application Namespace


AptifyConfigurationOptions Constructor

Initializes a new instance of the AptifyConfigurationOptions class.

public AptifyConfigurationOptions();

See Also

AptifyConfigurationOptions Class | Aptify.Framework.Application Namespace


AptifyConfigurationOptions Methods

The methods of the AptifyConfigurationOptions class are listed below. For a complete list of AptifyConfigurationOptions class members, see the AptifyConfigurationOptions Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

AptifyConfigurationOptions Class | Aptify.Framework.Application Namespace


AptifyConfigurationOptions.Config Method

public void Config(
AptifyApplication Application
);

See Also

AptifyConfigurationOptions Class | Aptify.Framework.Application Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

AptifyConfigurationOptions.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

AptifyConfigurationOptions Class | Aptify.Framework.Application Namespace


AptifyConfigurationOptions.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

AptifyConfigurationOptions Class | Aptify.Framework.Application Namespace | AptifyConfigurationOptions.Dispose Overload List


AptifyContext Class

For a list of all members of this type, see AptifyContext Members.

System.Object
AptifyContext
AptifyFormTemplateContext
WebFormTemplateContext
AptifyFormTemplateContext

public class AptifyContext

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyUtility (in AptifyUtility.dll)

See Also

AptifyContext Members | Aptify.Framework.Application Namespace


AptifyContext Members

AptifyContext overview

Public Instance Constructors

AptifyContext Overloaded. Initializes a new instance of the AptifyContext class.

Public Instance Properties

Coordinator
Properties

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyContext Class | Aptify.Framework.Application Namespace


AptifyContext Constructor

Initializes a new instance of the AptifyContext class.

Overload List

Initializes a new instance of the AptifyContext class.

public AptifyContext();

public AptifyContext(AptifyMessageCoordinator);

See Also

AptifyContext Class | Aptify.Framework.Application Namespace


AptifyContext Constructor ()

Initializes a new instance of the AptifyContext class.

public AptifyContext();

See Also

AptifyContext Class | Aptify.Framework.Application Namespace | AptifyContext Constructor Overload List


AptifyContext Constructor (AptifyMessageCoordinator)

public AptifyContext(
AptifyMessageCoordinator Coordinator
);

See Also

AptifyContext Class | Aptify.Framework.Application Namespace | AptifyContext Constructor Overload List


AptifyContext Properties

The properties of the AptifyContext class are listed below. For a complete list of AptifyContext class members, see the AptifyContext Members topic.

Public Instance Properties

Coordinator
Properties

See Also

AptifyContext Class | Aptify.Framework.Application Namespace


Coordinator Property

Aptify 5.0 Software Development Kit (SDK)

AptifyContext.Coordinator Property

public AptifyMessageCoordinator Coordinator {get;}

See Also

AptifyContext Class | Aptify.Framework.Application Namespace


Properties Property

Aptify 5.0 Software Development Kit (SDK)

AptifyContext.Properties Property

public AptifyProperties Properties {get;}

See Also

AptifyContext Class | Aptify.Framework.Application Namespace


AptifyDataFieldType Enumeration

public enum AptifyDataFieldType

Members

Member Name | Description
Number |
Character |
DateTime |
Time |

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyApplication (in AptifyApplication.dll)

See Also

Aptify.Framework.Application Namespace


AptifyEntityDependencyGetFailureException Class

Error fetching dependency data or data is of invalid type.

For a list of all members of this type, see AptifyEntityDependencyGetFailureException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
AptifyApplicationException
AptifyEntityDependencyGetFailureException

public class AptifyEntityDependencyGetFailureException : AptifyApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyApplication (in AptifyApplication.dll)

See Also

AptifyEntityDependencyGetFailureException Members | Aptify.Framework.Application Namespace


AptifyEntityDependencyGetFailureException Members

AptifyEntityDependencyGetFailureException overview

Public Instance Constructors

AptifyEntityDependencyGetFailureException Overloaded. Initializes a new instance of the AptifyEntityDependencyGetFailureException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Constructors

AptifyEntityDependencyGetFailureException Overloaded. Initializes a new instance of the AptifyEntityDependencyGetFailureException class.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyEntityDependencyGetFailureException Class | Aptify.Framework.Application Namespace


AptifyEntityDependencyGetFailureException Constructor

Overload List

public AptifyEntityDependencyGetFailureException(Int32,Int32,String);

public AptifyEntityDependencyGetFailureException(Int32,Int32,String,Exception);

protected AptifyEntityDependencyGetFailureException(SerializationInfo,StreamingContext);

public AptifyEntityDependencyGetFailureException(String);

public AptifyEntityDependencyGetFailureException(String,Exception);

See Also

AptifyEntityDependencyGetFailureException Class | Aptify.Framework.Application Namespace


AptifyEntityDependencyGetFailureException Constructor (String)

public AptifyEntityDependencyGetFailureException(
String Message
);

See Also

AptifyEntityDependencyGetFailureException Class | Aptify.Framework.Application Namespace | AptifyEntityDependencyGetFailureException Constructor Overload List


AptifyEntityDependencyGetFailureException Constructor (String, Exception)

public AptifyEntityDependencyGetFailureException(
String Message,
Exception inner
);

See Also

AptifyEntityDependencyGetFailureException Class | Aptify.Framework.Application Namespace | AptifyEntityDependencyGetFailureException Constructor Overload List


AptifyEntityDependencyGetFailureException Constructor (Int32, Int32, String)

public AptifyEntityDependencyGetFailureException(
Int32 ErrorNumber,
Int32 Severity,
String Message
);

See Also

AptifyEntityDependencyGetFailureException Class | Aptify.Framework.Application Namespace | AptifyEntityDependencyGetFailureException Constructor Overload List


AptifyEntityDependencyGetFailureException Constructor (Int32, Int32, String, Exception)

public AptifyEntityDependencyGetFailureException(
Int32 ErrorNumber,
Int32 Severity,
String Message,
Exception inner
);

See Also

AptifyEntityDependencyGetFailureException Class | Aptify.Framework.Application Namespace | AptifyEntityDependencyGetFailureException Constructor Overload List


AptifyEntityDependencyGetFailureException Constructor (SerializationInfo, StreamingContext)

protected AptifyEntityDependencyGetFailureException(
SerializationInfo info,
StreamingContext context
);

See Also

AptifyEntityDependencyGetFailureException Class | Aptify.Framework.Application Namespace | AptifyEntityDependencyGetFailureException Constructor Overload List


AptifyEntityDependencyGetFailureException Methods

The methods of the AptifyEntityDependencyGetFailureException class are listed below. For a complete list of AptifyEntityDependencyGetFailureException class members, see the AptifyEntityDependencyGetFailureException Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyEntityDependencyGetFailureException Class | Aptify.Framework.Application Namespace


AptifyEntityDependencyGetFailureException.GetObjectData Method

public override void GetObjectData(
SerializationInfo info,
StreamingContext context
);

Implements

ISerializable.

See Also

AptifyEntityDependencyGetFailureException Class | Aptify.Framework.Application Namespace


AptifyEntityPermissionDeniedException Class

For a list of all members of this type, see AptifyEntityPermissionDeniedException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
AptifyApplicationException
AptifyEntityPermissionDeniedException

public class AptifyEntityPermissionDeniedException : AptifyApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyApplication (in AptifyApplication.dll)

See Also

AptifyEntityPermissionDeniedException Members | Aptify.Framework.Application Namespace


AptifyEntityPermissionDeniedException Members

AptifyEntityPermissionDeniedException overview

Public Instance Constructors

AptifyEntityPermissionDeniedException Overloaded. Initializes a new instance of the AptifyEntityPermissionDeniedException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Constructors

AptifyEntityPermissionDeniedException Overloaded. Initializes a new instance of the AptifyEntityPermissionDeniedException class.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyEntityPermissionDeniedException Class | Aptify.Framework.Application Namespace


AptifyEntityPermissionDeniedException Constructor

Overload List

protected AptifyEntityPermissionDeniedException(SerializationInfo,StreamingContext);

public AptifyEntityPermissionDeniedException(String,Int64,String);

public AptifyEntityPermissionDeniedException(String,Int64,String,Exception);

See Also

AptifyEntityPermissionDeniedException Class | Aptify.Framework.Application Namespace


AptifyEntityPermissionDeniedException Constructor (String, Int64, String)

public AptifyEntityPermissionDeniedException(
String EntityName,
Int64 AptifyUserID,
String PermissionRequested
);

See Also

AptifyEntityPermissionDeniedException Class | Aptify.Framework.Application Namespace | AptifyEntityPermissionDeniedException Constructor Overload List


AptifyEntityPermissionDeniedException Constructor (String, Int64, String, Exception)

public AptifyEntityPermissionDeniedException(
String EntityName,
Int64 AptifyUserID,
String PermissionRequested,
Exception inner
);

See Also

AptifyEntityPermissionDeniedException Class | Aptify.Framework.Application Namespace | AptifyEntityPermissionDeniedException Constructor Overload List


AptifyEntityPermissionDeniedException Constructor (SerializationInfo, StreamingContext)

protected AptifyEntityPermissionDeniedException(
SerializationInfo info,
StreamingContext context
);

See Also

AptifyEntityPermissionDeniedException Class | Aptify.Framework.Application Namespace | AptifyEntityPermissionDeniedException Constructor Overload List


AptifyEntityPermissionDeniedException Methods

The methods of the AptifyEntityPermissionDeniedException class are listed below. For a complete list of AptifyEntityPermissionDeniedException class members, see the AptifyEntityPermissionDeniedException Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyEntityPermissionDeniedException Class | Aptify.Framework.Application Namespace


AptifyEntityPermissionDeniedException.GetObjectData Method

public override void GetObjectData(
SerializationInfo info,
StreamingContext context
);

Implements

ISerializable.

See Also

AptifyEntityPermissionDeniedException Class | Aptify.Framework.Application Namespace


AptifyEntityPlugInMissingDataException Class

Error fetching plug in data or data is of invalid type.

For a list of all members of this type, see AptifyEntityPlugInMissingDataException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
AptifyApplicationException
AptifyEntityPlugInMissingDataException

public class AptifyEntityPlugInMissingDataException : AptifyApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyApplication (in AptifyApplication.dll)

See Also

AptifyEntityPlugInMissingDataException Members | Aptify.Framework.Application Namespace


AptifyEntityPlugInMissingDataException Members

AptifyEntityPlugInMissingDataException overview

Public Instance Constructors

AptifyEntityPlugInMissingDataException Overloaded. Initializes a new instance of the AptifyEntityPlugInMissingDataException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
AssemblyName |
ClassName |
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Entity |
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
PlugInType |
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Constructors

AptifyEntityPlugInMissingDataException Overloaded. Initializes a new instance of the AptifyEntityPlugInMissingDataException class.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyEntityPlugInMissingDataException Class | Aptify.Framework.Application Namespace


AptifyEntityPlugInMissingDataException Constructor

Overload List

protected AptifyEntityPlugInMissingDataException(SerializationInfo,StreamingContext);

public AptifyEntityPlugInMissingDataException(String,EntityPlugInType,String,String);

public AptifyEntityPlugInMissingDataException(String,EntityPlugInType,String,String,Exception);

See Also

AptifyEntityPlugInMissingDataException Class | Aptify.Framework.Application Namespace


AptifyEntityPlugInMissingDataException Constructor (String, EntityPlugInType, String, String)

public AptifyEntityPlugInMissingDataException(
String EntityName,
EntityPlugInType PlugInType,
String AssemblyName,
String ClassName
);

See Also

AptifyEntityPlugInMissingDataException Class | Aptify.Framework.Application Namespace | AptifyEntityPlugInMissingDataException Constructor Overload List


AptifyEntityPlugInMissingDataException Constructor (String, EntityPlugInType, String, String, Exception)

public AptifyEntityPlugInMissingDataException(
String EntityName,
EntityPlugInType PlugInType,
String AssemblyName,
String ClassName,
Exception inner
);

See Also

AptifyEntityPlugInMissingDataException Class | Aptify.Framework.Application Namespace | AptifyEntityPlugInMissingDataException Constructor Overload List


AptifyEntityPlugInMissingDataException Constructor (SerializationInfo, StreamingContext)

protected AptifyEntityPlugInMissingDataException(
SerializationInfo info,
StreamingContext context
);

See Also

AptifyEntityPlugInMissingDataException Class | Aptify.Framework.Application Namespace | AptifyEntityPlugInMissingDataException Constructor Overload List


AptifyEntityPlugInMissingDataException Properties

The properties of the AptifyEntityPlugInMissingDataException class are listed below. For a complete list of AptifyEntityPlugInMissingDataException class members, see the AptifyEntityPlugInMissingDataException Members topic.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
AssemblyName |
ClassName |
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Entity |
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
PlugInType |
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

See Also

AptifyEntityPlugInMissingDataException Class | Aptify.Framework.Application Namespace


AssemblyName Property

Aptify 5.0 Software Development Kit (SDK)

AptifyEntityPlugInMissingDataException.AssemblyName Property

public String AssemblyName {get;}

See Also

AptifyEntityPlugInMissingDataException Class | Aptify.Framework.Application Namespace


ClassName Property

Aptify 5.0 Software Development Kit (SDK)

AptifyEntityPlugInMissingDataException.ClassName Property

public String ClassName {get;}

See Also

AptifyEntityPlugInMissingDataException Class | Aptify.Framework.Application Namespace


Entity Property

Aptify 5.0 Software Development Kit (SDK)

AptifyEntityPlugInMissingDataException.Entity Property

public String Entity {get;}

See Also

AptifyEntityPlugInMissingDataException Class | Aptify.Framework.Application Namespace


PlugInType Property

Aptify 5.0 Software Development Kit (SDK)

AptifyEntityPlugInMissingDataException.PlugInType Property

public EntityPlugInType PlugInType {get;}

See Also

AptifyEntityPlugInMissingDataException Class | Aptify.Framework.Application Namespace


AptifyEntityPlugInMissingDataException Methods

The methods of the AptifyEntityPlugInMissingDataException class are listed below. For a complete list of AptifyEntityPlugInMissingDataException class members, see the AptifyEntityPlugInMissingDataException Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyEntityPlugInMissingDataException Class | Aptify.Framework.Application Namespace


AptifyEntityPlugInMissingDataException.GetObjectData Method

public override void GetObjectData(
SerializationInfo info,
StreamingContext context
);

Implements

ISerializable.

See Also

AptifyEntityPlugInMissingDataException Class | Aptify.Framework.Application Namespace


AptifyMessage Class

For a list of all members of this type, see AptifyMessage Members.

System.Object
AptifyMessage

public class AptifyMessage

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyUtility (in AptifyUtility.dll)

See Also

AptifyMessage Members | Aptify.Framework.Application Namespace


AptifyMessage Members

AptifyMessage overview

Public Instance Constructors

AptifyMessage Constructor Initializes a new instance of the AptifyMessage class.

Public Instance Methods

AddFilter |
ClearFilters |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter |
RemoveFilter |
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

MessageReceived

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyMessage Class | Aptify.Framework.Application Namespace


AptifyMessage Constructor

Initializes a new instance of the AptifyMessage class.

public AptifyMessage();

See Also

AptifyMessage Class | Aptify.Framework.Application Namespace


AptifyMessage Methods

The methods of the AptifyMessage class are listed below. For a complete list of AptifyMessage class members, see the AptifyMessage Members topic.

Public Instance Methods

AddFilter |
ClearFilters |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter |
RemoveFilter |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyMessage Class | Aptify.Framework.Application Namespace


AptifyMessage.AddFilter Method

public void AddFilter(
String Filter
);

See Also

AptifyMessage Class | Aptify.Framework.Application Namespace


AptifyMessage.ClearFilters Method

public void ClearFilters();

See Also

AptifyMessage Class | Aptify.Framework.Application Namespace


AptifyMessage.HasFilter Method

public bool HasFilter(
String Filter
);

See Also

AptifyMessage Class | Aptify.Framework.Application Namespace


AptifyMessage.RemoveFilter Method

public void RemoveFilter(
String Filter
);

See Also

AptifyMessage Class | Aptify.Framework.Application Namespace


AptifyMessage Events

The events of the AptifyMessage class are listed below. For a complete list of AptifyMessage class members, see the AptifyMessage Members topic.

Public Instance Events

MessageReceived

See Also

AptifyMessage Class | Aptify.Framework.Application Namespace


AptifyMessage.AptifyMessage.MessageReceivedEventHandler Event

public event AptifyMessage.MessageReceivedEventHandler MessageReceived;

See Also

AptifyMessage Class | Aptify.Framework.Application Namespace


AptifyMessage.MessageReceivedEventHandler Delegate

public delegate void AptifyMessage.MessageReceivedEventHandler(
String Filter,
String Message
);

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyUtility (in AptifyUtility.dll)

See Also

Aptify.Framework.Application Namespace


AptifyMessageBox Class

Aptify's standard message box for displaying messages to users. The Show Method is overloaded to enable the display of both a short and long message as well as to override the standard title.

For a list of all members of this type, see AptifyMessageBox Members.

System.Object
AptifyMessageBox

public class AptifyMessageBox

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyUtility (in AptifyUtility.dll)

See Also

AptifyMessageBox Members | Aptify.Framework.Application Namespace


AptifyMessageBox Members

AptifyMessageBox overview

Public Static Properties

TitleText | The Default text to use for the Form's Title is returned. This value can be specified in Metadata by an Attribute in the Applicaitons entity. The Attribute named "DefaultFormTitle" is checked. If an attribute exists, the value is used for the form's title, else "Aptify" is used.
Currency | Will get and set Current Currency.

Public Static Methods

CultureMsgBox | Overloaded. This method will automatically convert the Prompt and Title to the local culture of the user if a matching culture string is found for the text in the Prompt and Title parameters.
LogMessage | Utility method that logs the specified message to the Aptify error log
Show | Overloaded. Displays the Message variable only, no additional "more" message is avialable
ShowInputBox | Overloaded. Delegates to ShowInputBox method with 3 parameters. Title and DefaultResponse are sent as an empty string.
ShowMsgBox | Overloaded. Aptify utility for displaying message boxes to the user, utilizes the standard windows message box. For the Aptify double-text (message/more-message) message box, use the Show() method.

Protected Static Methods

ReplaceRegularExpressions

Public Instance Constructors

AptifyMessageBox Constructor Initializes a new instance of the AptifyMessageBox class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyMessageBox Class | Aptify.Framework.Application Namespace


AptifyMessageBox Constructor

Initializes a new instance of the AptifyMessageBox class.

public AptifyMessageBox();

See Also

AptifyMessageBox Class | Aptify.Framework.Application Namespace


AptifyMessageBox Properties

The properties of the AptifyMessageBox class are listed below. For a complete list of AptifyMessageBox class members, see the AptifyMessageBox Members topic.

Public Static Properties

TitleText | The Default text to use for the Form's Title is returned. This value can be specified in Metadata by an Attribute in the Applicaitons entity. The Attribute named "DefaultFormTitle" is checked. If an attribute exists, the value is used for the form's title, else "Aptify" is used.
Currency | Will get and set Current Currency.

See Also

AptifyMessageBox Class | Aptify.Framework.Application Namespace


Currency Property

Aptify 5.0 Software Development Kit (SDK)

AptifyMessageBox.Currency Property

Will get and set Current Currency.

public static String Currency {get; set;}

Property Value

Remarks

See Also

AptifyMessageBox Class | Aptify.Framework.Application Namespace


TitleText Property

Aptify 5.0 Software Development Kit (SDK)

AptifyMessageBox.TitleText Property

The Default text to use for the Form's Title is returned. This value can be specified in Metadata by an Attribute in the Applicaitons entity. The Attribute named "DefaultFormTitle" is checked. If an attribute exists, the value is used for the form's title, else "Aptify" is used.

public static String TitleText {get;}

Remarks

Applications Attribute named DefaultFormTitle can be used to define a custom form title.

See Also

AptifyMessageBox Class | Aptify.Framework.Application Namespace


AptifyMessageBox Methods

The methods of the AptifyMessageBox class are listed below. For a complete list of AptifyMessageBox class members, see the AptifyMessageBox Members topic.

Public Static Methods

CultureMsgBox | Overloaded. This method will automatically convert the Prompt and Title to the local culture of the user if a matching culture string is found for the text in the Prompt and Title parameters.
LogMessage | Utility method that logs the specified message to the Aptify error log
Show | Overloaded. Displays the Message variable only, no additional "more" message is avialable
ShowInputBox | Overloaded. Delegates to ShowInputBox method with 3 parameters. Title and DefaultResponse are sent as an empty string.
ShowMsgBox | Overloaded. Aptify utility for displaying message boxes to the user, utilizes the standard windows message box. For the Aptify double-text (message/more-message) message box, use the Show() method.

Protected Static Methods

ReplaceRegularExpressions

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyMessageBox Class | Aptify.Framework.Application Namespace


CultureMsgBox Method

Aptify 5.0 Software Development Kit (SDK)

AptifyMessageBox.CultureMsgBox Method

This method will automatically convert the Prompt and Title to the local culture of the user if a matching culture string is found for the text in the Prompt and Title parameters.

Overload List

This method will automatically convert the Prompt and Title to the local culture of the user if a matching culture string is found for the text in the Prompt and Title parameters.

public static MsgBoxResult CultureMsgBox(String,UserCredentials,MsgBoxStyle,String,String[]);

public static MsgBoxResult CultureMsgBox(String,UserCredentials,Form,MsgBoxStyle,String,String[]);

This method will automatically convert the Prompt and Title to the local culture of the user if a matching culture string is found for the text in the Prompt and Title parameters.

public static MsgBoxResult CultureMsgBox(String,String,UserCredentials,MsgBoxStyle,String,String,String[]);

public static MsgBoxResult CultureMsgBox(String,String,UserCredentials,Form,MsgBoxStyle,String,String,String[]);

See Also

AptifyMessageBox Class | Aptify.Framework.Application Namespace


AptifyMessageBox.CultureMsgBox Method (String, UserCredentials, MsgBoxStyle, String, String[])

This method will automatically convert the Prompt and Title to the local culture of the user if a matching culture string is found for the text in the Prompt and Title parameters.

public static MsgBoxResult CultureMsgBox(
String Prompt,
UserCredentials UserCredentials,
MsgBoxStyle Buttons,
String Title,
String[] params
);

Parameters

Prompt
UserCredentials
The logged in User's Credentials. These would be used to localize the buttons on this message box.
Buttons
Title
Text to be displayed in the title bar of the window.
params

Return Value

Remarks

See Also

AptifyMessageBox Class | Aptify.Framework.Application Namespace | AptifyMessageBox.CultureMsgBox Overload List


AptifyMessageBox.CultureMsgBox Method (String, UserCredentials, Form, MsgBoxStyle, String, String[])

public static MsgBoxResult CultureMsgBox(
String Prompt,
UserCredentials UserCredentials,
Form ParentForm,
MsgBoxStyle Buttons,
String Title,
String[] params
);

See Also

AptifyMessageBox Class | Aptify.Framework.Application Namespace | AptifyMessageBox.CultureMsgBox Overload List


AptifyMessageBox.CultureMsgBox Method (String, String, UserCredentials, MsgBoxStyle, String, String, String[])

This method will automatically convert the Prompt and Title to the local culture of the user if a matching culture string is found for the text in the Prompt and Title parameters.

public static MsgBoxResult CultureMsgBox(
String CultureStringName,
String BaseString,
UserCredentials UserCredentials,
MsgBoxStyle Buttons,
String Title,
String TitleCultureStringName,
String[] params
);

Parameters

CultureStringName
BaseString
UserCredentials
The logged in User's Credentials. These would be used to localize the buttons on this message box.
Buttons
Title
Text to be displayed in the title bar of the window.
TitleCultureStringName
params

Return Value

Remarks

See Also

AptifyMessageBox Class | Aptify.Framework.Application Namespace | AptifyMessageBox.CultureMsgBox Overload List


AptifyMessageBox.CultureMsgBox Method (String, String, UserCredentials, Form, MsgBoxStyle, String, String, String[])

public static MsgBoxResult CultureMsgBox(
String CultureStringName,
String BaseString,
UserCredentials UserCredentials,
Form ParentForm,
MsgBoxStyle Buttons,
String Title,
String TitleCultureStringName,
String[] params
);

See Also

AptifyMessageBox Class | Aptify.Framework.Application Namespace | AptifyMessageBox.CultureMsgBox Overload List


AptifyMessageBox.LogMessage Method

Utility method that logs the specified message to the Aptify error log

public static void LogMessage(
String Message,
String MoreMessage,
String Title
);

Parameters

Message
Primary message displayed to the user.
MoreMessage
Additional details that can be viewed by the user in a separate text box that is expanded by a 'More' button.
Title
Text to be displayed in the title bar of the window.

Remarks

See Also

AptifyMessageBox Class | Aptify.Framework.Application Namespace


AptifyMessageBox.ReplaceRegularExpressions Method

protected static string ReplaceRegularExpressions(
String sString,
params String[] params
);

See Also

AptifyMessageBox Class | Aptify.Framework.Application Namespace


Show Method

Aptify 5.0 Software Development Kit (SDK)

AptifyMessageBox.Show Method

Displays the Message variable only, no additional "more" message is avialable

Overload List

Displays the Message variable only, no additional "more" message is avialable

public static void Show(String);

Displays the Message and MoreMessage. The MoreMessage is only displayed if it is not an empty string as well as being a different string value than Message.

public static void Show(String,String);

Displays the Message and MoreMessage. The MoreMessage is only displayed if it is not an empty string as well as being a different string value than Message. Also overrides the Title of the message box if Title is a non-empty string.

public static void Show(String,String,String);

Displays the Message and MoreMessage. The MoreMessage is only displayed if it is not an empty string as well as being a different string value than Message. Also overrides the Title of the message box if Title is a non-empty string.

public static void Show(String,String,String,UserCredentials);

See Also

AptifyMessageBox Class | Aptify.Framework.Application Namespace


AptifyMessageBox.Show Method (String)

Displays the Message variable only, no additional "more" message is avialable

public static void Show(
String Message
);

Parameters

Message
Primary message displayed to the user.

Remarks

See Also

AptifyMessageBox Class | Aptify.Framework.Application Namespace | AptifyMessageBox.Show Overload List


AptifyMessageBox.Show Method (String, String)

Displays the Message and MoreMessage. The MoreMessage is only displayed if it is not an empty string as well as being a different string value than Message.

public static void Show(
String Message,
String MoreMessage
);

Parameters

Message
Primary message displayed to the user.
MoreMessage
Additional details that can be viewed by the user in a separate text box that is expanded by a 'More' button.

Remarks

See Also

AptifyMessageBox Class | Aptify.Framework.Application Namespace | AptifyMessageBox.Show Overload List


AptifyMessageBox.Show Method (String, String, String)

Displays the Message and MoreMessage. The MoreMessage is only displayed if it is not an empty string as well as being a different string value than Message. Also overrides the Title of the message box if Title is a non-empty string.

public static void Show(
String Message,
String MoreMessage,
String Title
);

Parameters

Message
Primary message displayed to the user.
MoreMessage
Additional details that can be viewed by the user in a separate text box that is expanded by a 'More' button.
Title
Text to be displayed in the title bar of the window.

Remarks

See Also

AptifyMessageBox Class | Aptify.Framework.Application Namespace | AptifyMessageBox.Show Overload List


AptifyMessageBox.Show Method (String, String, String, UserCredentials)

Displays the Message and MoreMessage. The MoreMessage is only displayed if it is not an empty string as well as being a different string value than Message. Also overrides the Title of the message box if Title is a non-empty string.

public static void Show(
String Message,
String MoreMessage,
String Title,
UserCredentials UserCredentials
);

Parameters

Message
Primary message displayed to the user.
MoreMessage
Additional details that can be viewed by the user in a separate text box that is expanded by a 'More' button.
Title
Text to be displayed in the title bar of the window.
UserCredentials
The logged in User's Credentials. These would be used to localize the buttons on this message box.

Remarks

See Also

AptifyMessageBox Class | Aptify.Framework.Application Namespace | AptifyMessageBox.Show Overload List


ShowInputBox Method

Aptify 5.0 Software Development Kit (SDK)

AptifyMessageBox.ShowInputBox Method

Aptify utility for displaying an Input Box to ther user, utlizes the standard Windows Input Box.

Overload List

Aptify utility for displaying an Input Box to ther user, utlizes the standard Windows Input Box.

public static string ShowInputBox(UserCredentials,String,String,String);

Delegates to ShowInputBox method with 3 parameters. Title and DefaultResponse are sent as an empty string.

public static string ShowInputBox(String);

Delegates to ShowInputBox method with 3 parameters. DefaultResponse is sent as an empty string.

public static string ShowInputBox(String,String);

Aptify utility for displaying an Input Box to ther user, utlizes the standard Windows Input Box.

public static string ShowInputBox(String,String,String);

See Also

AptifyMessageBox Class | Aptify.Framework.Application Namespace


AptifyMessageBox.ShowInputBox Method (UserCredentials, String, String, String)

Aptify utility for displaying an Input Box to ther user, utlizes the standard Windows Input Box.

public static string ShowInputBox(
UserCredentials uc,
String Prompt,
String Title,
String DefaultResponse
);

Parameters

uc
The logged in User's Credentials. These would be used to localize the buttons on this message box.
Prompt
Title
Text to be displayed in the title bar of the window.
DefaultResponse

Return Value

Remarks

See Also

AptifyMessageBox Class | Aptify.Framework.Application Namespace | AptifyMessageBox.ShowInputBox Overload List


AptifyMessageBox.ShowInputBox Method (String)

Delegates to ShowInputBox method with 3 parameters. Title and DefaultResponse are sent as an empty string.

public static string ShowInputBox(
String Prompt
);

Parameters

Prompt

Return Value

Remarks

See Also

AptifyMessageBox Class | Aptify.Framework.Application Namespace | AptifyMessageBox.ShowInputBox Overload List


AptifyMessageBox.ShowInputBox Method (String, String)

Delegates to ShowInputBox method with 3 parameters. DefaultResponse is sent as an empty string.

public static string ShowInputBox(
String Prompt,
String Title
);

Parameters

Prompt
Title
Text to be displayed in the title bar of the window.

Return Value

Remarks

See Also

AptifyMessageBox Class | Aptify.Framework.Application Namespace | AptifyMessageBox.ShowInputBox Overload List


AptifyMessageBox.ShowInputBox Method (String, String, String)

Aptify utility for displaying an Input Box to ther user, utlizes the standard Windows Input Box.

public static string ShowInputBox(
String Prompt,
String Title,
String DefaultResponse
);

Parameters

Prompt
Title
Text to be displayed in the title bar of the window.
DefaultResponse

Return Value

Remarks

See Also

AptifyMessageBox Class | Aptify.Framework.Application Namespace | AptifyMessageBox.ShowInputBox Overload List


ShowMsgBox Method

Aptify 5.0 Software Development Kit (SDK)

AptifyMessageBox.ShowMsgBox Method

Aptify utility for displaying message boxes to the user, utilizes the standard windows message box. For the Aptify double-text (message/more-message) message box, use the Show() method.

Overload List

Aptify utility for displaying message boxes to the user, utilizes the standard windows message box. For the Aptify double-text (message/more-message) message box, use the Show() method.

public static MsgBoxResult ShowMsgBox(UserCredentials,String,MsgBoxStyle,String);

public static MsgBoxResult ShowMsgBox(UserCredentials,String,Form,MsgBoxStyle,String);

Aptify utility for displaying message boxes to the user, utilizes the standard windows message box. For the Aptify double-text (message/more-message) message box, use the Show() method.

public static MsgBoxResult ShowMsgBox(String,MsgBoxStyle,String);

See Also

AptifyMessageBox Class | Aptify.Framework.Application Namespace | Show()


AptifyMessageBox.ShowMsgBox Method (UserCredentials, String, MsgBoxStyle, String)

Aptify utility for displaying message boxes to the user, utilizes the standard windows message box. For the Aptify double-text (message/more-message) message box, use the Show() method.

public static MsgBoxResult ShowMsgBox(
UserCredentials uc,
String Prompt,
MsgBoxStyle Buttons,
String Title
);

Parameters

uc
Prompt
Buttons
Title
Text to be displayed in the title bar of the window.

Return Value

Remarks

See Also

AptifyMessageBox Class | Aptify.Framework.Application Namespace | AptifyMessageBox.ShowMsgBox Overload List | Show()


AptifyMessageBox.ShowMsgBox Method (UserCredentials, String, Form, MsgBoxStyle, String)

public static MsgBoxResult ShowMsgBox(
UserCredentials uc,
String Prompt,
Form ParentForm,
MsgBoxStyle Buttons,
String Title
);

See Also

AptifyMessageBox Class | Aptify.Framework.Application Namespace | AptifyMessageBox.ShowMsgBox Overload List


AptifyMessageBox.ShowMsgBox Method (String, MsgBoxStyle, String)

Aptify utility for displaying message boxes to the user, utilizes the standard windows message box. For the Aptify double-text (message/more-message) message box, use the Show() method.

public static MsgBoxResult ShowMsgBox(
String Prompt,
MsgBoxStyle Buttons,
String Title
);

Parameters

Prompt
Buttons
Title
Text to be displayed in the title bar of the window.

Return Value

Remarks

See Also

AptifyMessageBox Class | Aptify.Framework.Application Namespace | AptifyMessageBox.ShowMsgBox Overload List | Show()


AptifyMessageCoordinator Class

For a list of all members of this type, see AptifyMessageCoordinator Members.

System.Object
AptifyMessageCoordinator

public class AptifyMessageCoordinator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyUtility (in AptifyUtility.dll)

See Also

AptifyMessageCoordinator Members | Aptify.Framework.Application Namespace


AptifyMessageCoordinator Members

AptifyMessageCoordinator overview

Public Instance Properties

ListenerCount

Public Instance Methods

ClearListeners |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
RegisterListener |
SendMessage |
ToString (inherited from Object) | Returns a String that represents the current Object.
UnRegisterListener |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyMessageCoordinator Class | Aptify.Framework.Application Namespace


AptifyMessageCoordinator Properties

The properties of the AptifyMessageCoordinator class are listed below. For a complete list of AptifyMessageCoordinator class members, see the AptifyMessageCoordinator Members topic.

Public Instance Properties

ListenerCount

See Also

AptifyMessageCoordinator Class | Aptify.Framework.Application Namespace


ListenerCount Property

Aptify 5.0 Software Development Kit (SDK)

AptifyMessageCoordinator.ListenerCount Property

public Int32 ListenerCount {get;}

See Also

AptifyMessageCoordinator Class | Aptify.Framework.Application Namespace


AptifyMessageCoordinator Methods

The methods of the AptifyMessageCoordinator class are listed below. For a complete list of AptifyMessageCoordinator class members, see the AptifyMessageCoordinator Members topic.

Public Instance Methods

ClearListeners |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
RegisterListener |
SendMessage |
ToString (inherited from Object) | Returns a String that represents the current Object.
UnRegisterListener |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyMessageCoordinator Class | Aptify.Framework.Application Namespace


AptifyMessageCoordinator.ClearListeners Method

public void ClearListeners();

See Also

AptifyMessageCoordinator Class | Aptify.Framework.Application Namespace


AptifyMessageCoordinator.RegisterListener Method

public void RegisterListener(
AptifyMessage listener
);

See Also

AptifyMessageCoordinator Class | Aptify.Framework.Application Namespace


AptifyMessageCoordinator.SendMessage Method

public void SendMessage(
AptifyMessage Source,
String Filter,
String MessageText
);

See Also

AptifyMessageCoordinator Class | Aptify.Framework.Application Namespace


AptifyMessageCoordinator.UnRegisterListener Method

public void UnRegisterListener(
AptifyMessage listener
);

See Also

AptifyMessageCoordinator Class | Aptify.Framework.Application Namespace


AptifyProperties Class

For a list of all members of this type, see AptifyProperties Members.

System.Object
NameObjectCollectionBase
AptifyCollection
AptifyProperties

public class AptifyProperties : AptifyCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyUtility (in AptifyUtility.dll)

See Also

AptifyProperties Members | Aptify.Framework.Application Namespace


AptifyProperties Members

AptifyProperties overview

Public Instance Constructors

AptifyProperties Constructor Initializes a new instance of the AptifyProperties class.

Public Instance Properties

Count (inherited from NameObjectCollectionBase) | Gets the number of key/value pairs contained in the NameObjectCollectionBase instance.
Item (inherited from AptifyCollection) |
Item (inherited from AptifyCollection) |
Keys (inherited from NameObjectCollectionBase) | Gets a KeysCollection instance that contains all the keys in the NameObjectCollectionBase instance.

Public Instance Methods

Add | Overloaded.
Add (inherited from AptifyCollection) | Overloaded. Allows a user to add a Value to the Collection.
AddProperty |
Clear (inherited from AptifyCollection) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from AptifyCollection) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetName |
GetObjectData (inherited from NameObjectCollectionBase) | Implements the ISerializable interface and returns the data needed to serialize the NameObjectCollectionBase instance.
GetProperty |
GetPropertyByIndex |
GetPropertyIndex |
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from AptifyCollection) | Gets the index of the item with the specified Key.
Merge (inherited from AptifyCollection) | Allows a user to merge items from another collection to this collection.
OnDeserialization (inherited from NameObjectCollectionBase) | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete.
Remove (inherited from AptifyCollection) | Overloaded.
RemoveAt (inherited from AptifyCollection) |
SetProperty |
SetPropertyByIndex |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

IsReadOnly (inherited from NameObjectCollectionBase) Gets or sets a value indicating whether the NameObjectCollectionBase instance is read-only.

Protected Instance Methods

BaseAdd (inherited from NameObjectCollectionBase) | Adds an entry with the specified key and value into the NameObjectCollectionBase instance.
BaseClear (inherited from NameObjectCollectionBase) | Removes all entries from the NameObjectCollectionBase instance.
BaseGet (inherited from NameObjectCollectionBase) | Overloaded. Gets the value of the first entry with the specified key from the NameObjectCollectionBase instance.
BaseGetAllKeys (inherited from NameObjectCollectionBase) | Returns a String array that contains all the keys in the NameObjectCollectionBase instance.
BaseGetAllValues (inherited from NameObjectCollectionBase) | Overloaded. Returns an Object array that contains all the values in the NameObjectCollectionBase instance.
BaseGetKey (inherited from NameObjectCollectionBase) | Gets the key of the entry at the specified index of the NameObjectCollectionBase instance.
BaseHasKeys (inherited from NameObjectCollectionBase) | Gets a value indicating whether the NameObjectCollectionBase instance contains entries whose keys are not null.
BaseRemove (inherited from NameObjectCollectionBase) | Removes the entries with the specified key from the NameObjectCollectionBase instance.
BaseRemoveAt (inherited from NameObjectCollectionBase) | Removes the entry at the specified index of the NameObjectCollectionBase instance.
BaseSet (inherited from NameObjectCollectionBase) | Overloaded. Sets the value of the first entry with the specified key in the NameObjectCollectionBase instance, if found; otherwise, adds an entry with the specified key and value into the NameObjectCollectionBase instance.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyProperties Class | Aptify.Framework.Application Namespace


AptifyProperties Constructor

Initializes a new instance of the AptifyProperties class.

public AptifyProperties();

See Also

AptifyProperties Class | Aptify.Framework.Application Namespace


AptifyProperties Methods

The methods of the AptifyProperties class are listed below. For a complete list of AptifyProperties class members, see the AptifyProperties Members topic.

Public Instance Methods

Add | Overloaded.
Add (inherited from AptifyCollection) | Overloaded. Allows a user to add a Value to the Collection.
AddProperty |
Clear (inherited from AptifyCollection) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from AptifyCollection) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetName |
GetObjectData (inherited from NameObjectCollectionBase) | Implements the ISerializable interface and returns the data needed to serialize the NameObjectCollectionBase instance.
GetProperty |
GetPropertyByIndex |
GetPropertyIndex |
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from AptifyCollection) | Gets the index of the item with the specified Key.
Merge (inherited from AptifyCollection) | Allows a user to merge items from another collection to this collection.
OnDeserialization (inherited from NameObjectCollectionBase) | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete.
Remove (inherited from AptifyCollection) | Overloaded.
RemoveAt (inherited from AptifyCollection) |
SetProperty |
SetPropertyByIndex |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

BaseAdd (inherited from NameObjectCollectionBase) | Adds an entry with the specified key and value into the NameObjectCollectionBase instance.
BaseClear (inherited from NameObjectCollectionBase) | Removes all entries from the NameObjectCollectionBase instance.
BaseGet (inherited from NameObjectCollectionBase) | Overloaded. Gets the value of the first entry with the specified key from the NameObjectCollectionBase instance.
BaseGetAllKeys (inherited from NameObjectCollectionBase) | Returns a String array that contains all the keys in the NameObjectCollectionBase instance.
BaseGetAllValues (inherited from NameObjectCollectionBase) | Overloaded. Returns an Object array that contains all the values in the NameObjectCollectionBase instance.
BaseGetKey (inherited from NameObjectCollectionBase) | Gets the key of the entry at the specified index of the NameObjectCollectionBase instance.
BaseHasKeys (inherited from NameObjectCollectionBase) | Gets a value indicating whether the NameObjectCollectionBase instance contains entries whose keys are not null.
BaseRemove (inherited from NameObjectCollectionBase) | Removes the entries with the specified key from the NameObjectCollectionBase instance.
BaseRemoveAt (inherited from NameObjectCollectionBase) | Removes the entry at the specified index of the NameObjectCollectionBase instance.
BaseSet (inherited from NameObjectCollectionBase) | Overloaded. Sets the value of the first entry with the specified key in the NameObjectCollectionBase instance, if found; otherwise, adds an entry with the specified key and value into the NameObjectCollectionBase instance.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyProperties Class | Aptify.Framework.Application Namespace


Add Method

Aptify 5.0 Software Development Kit (SDK)

AptifyProperties.Add Method

Overload List

public override int Add(Object);

Inherited from AptifyCollection.

public virtual int Add(Object,String);

See Also

AptifyProperties Class | Aptify.Framework.Application Namespace


AptifyProperties.Add Method (Object)

public override int Add(
Object Value
);

See Also

AptifyProperties Class | Aptify.Framework.Application Namespace | AptifyProperties.Add Overload List


AptifyProperties.AddProperty Method

public virtual void AddProperty(
String Name,
Object Value
);

See Also

AptifyProperties Class | Aptify.Framework.Application Namespace


AptifyProperties.GetName Method

public virtual string GetName(
Int32 Index
);

See Also

AptifyProperties Class | Aptify.Framework.Application Namespace


AptifyProperties.GetProperty Method

public virtual object GetProperty(
String Name
);

See Also

AptifyProperties Class | Aptify.Framework.Application Namespace


AptifyProperties.GetPropertyByIndex Method

public virtual object GetPropertyByIndex(
Int32 Index
);

See Also

AptifyProperties Class | Aptify.Framework.Application Namespace


AptifyProperties.GetPropertyIndex Method

public virtual int GetPropertyIndex(
String Name
);

See Also

AptifyProperties Class | Aptify.Framework.Application Namespace


AptifyProperties.SetProperty Method

public virtual void SetProperty(
String Name,
Object Value
);

See Also

AptifyProperties Class | Aptify.Framework.Application Namespace


AptifyProperties.SetPropertyByIndex Method

public virtual void SetPropertyByIndex(
Int32 Index,
Object Value
);

See Also

AptifyProperties Class | Aptify.Framework.Application Namespace


AttachmentOperation Enumeration

public enum AttachmentOperation

Members

Member Name | Description
AddAttachment |
OpenAttachment |
UpdateAttachment |
DeleteAttachment |

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyApplication (in AptifyApplication.dll)

See Also

Aptify.Framework.Application Namespace


AttachmentSubOperation Enumeration

public enum AttachmentSubOperation

Members

Member Name | Description
ProcessingAttachment |
RetrieveAttachmentFromDB |
StoreAttachmentInDB |
ReadAttachmentFromFile |
WriteAttachmentToFile |

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyApplication (in AptifyApplication.dll)

See Also

Aptify.Framework.Application Namespace


CommandParser Class

An object that builds a command string based on the provided properties, including entity name/command type, and record ID. A string parsing object that returns the actions of the system, entity name, and record ID.

For a list of all members of this type, see CommandParser Members.

System.Object
CommandParser

public class CommandParser

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyApplication (in AptifyApplication.dll)

See Also

CommandParser Members | Aptify.Framework.Application Namespace


CommandParser Members

CommandParser overview

Public Instance Properties

CommandString |
CommandType | Action that has been parsed in the command. Supported values are OPEN, PRINT, and PARAMS.
EntityName | Unique name of the entity that has been parsed.
Parameters | A collection of items that are additional parameters to the entity.
ParameterString |
RecordID | Unique identifier of the record.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CommandParser Class | Aptify.Framework.Application Namespace


CommandParser Properties

The properties of the CommandParser class are listed below. For a complete list of CommandParser class members, see the CommandParser Members topic.

Public Instance Properties

CommandString |
CommandType | Action that has been parsed in the command. Supported values are OPEN, PRINT, and PARAMS.
EntityName | Unique name of the entity that has been parsed.
Parameters | A collection of items that are additional parameters to the entity.
ParameterString |
RecordID | Unique identifier of the record.

See Also

CommandParser Class | Aptify.Framework.Application Namespace


CommandString Property

Aptify 5.0 Software Development Kit (SDK)

CommandParser.CommandString Property

public String CommandString {get;}

See Also

CommandParser Class | Aptify.Framework.Application Namespace


CommandType Property

Aptify 5.0 Software Development Kit (SDK)

CommandParser.CommandType Property

Action that has been parsed in the command. Supported values are OPEN, PRINT, and PARAMS.

public String CommandType {get; set;}

Property Value

Remarks

See Also

CommandParser Class | Aptify.Framework.Application Namespace


EntityName Property

Aptify 5.0 Software Development Kit (SDK)

CommandParser.EntityName Property

Unique name of the entity that has been parsed.

public String EntityName {get; set;}

Property Value

Remarks

See Also

CommandParser Class | Aptify.Framework.Application Namespace


Parameters Property

Aptify 5.0 Software Development Kit (SDK)

CommandParser.Parameters Property

A collection of items that are additional parameters to the entity.

public AptifyCollection Parameters {get;}

Property Value

Remarks

See Also

CommandParser Class | Aptify.Framework.Application Namespace


ParameterString Property

Aptify 5.0 Software Development Kit (SDK)

CommandParser.ParameterString Property

public String ParameterString {get;}

See Also

CommandParser Class | Aptify.Framework.Application Namespace


RecordID Property

Aptify 5.0 Software Development Kit (SDK)

CommandParser.RecordID Property

Unique identifier of the record.

public Int64 RecordID {get; set;}

Property Value

Remarks

See Also

CommandParser Class | Aptify.Framework.Application Namespace


CommandStringParameter Structure

For a list of all members of this type, see CommandStringParameter Members.

System.Object
ValueType
CommandStringParameter

public struct CommandStringParameter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyApplication (in AptifyApplication.dll)

See Also

CommandStringParameter Members | Aptify.Framework.Application Namespace


CommandStringParameter Members

CommandStringParameter overview

Public Instance Fields

Name
Value

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

CommandStringParameter Structure | Aptify.Framework.Application Namespace


CommandStringParameter Fields

The fields of the CommandStringParameter structure are listed below. For a complete list of CommandStringParameter structure members, see the CommandStringParameter Members topic.

Public Instance Fields

Name
Value

See Also

CommandStringParameter Structure | Aptify.Framework.Application Namespace


CommandStringParameter.Name Field

public Name Name;

See Also

CommandStringParameter Class | Aptify.Framework.Application Namespace


CommandStringParameter.Value Field

public Value Value;

See Also

CommandStringParameter Class | Aptify.Framework.Application Namespace


Constants Class

For a list of all members of this type, see Constants Members.

System.Object
Constants

public class Constants

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyApplication (in AptifyApplication.dll)

See Also

Constants Members | Aptify.Framework.Application Namespace


Constants Members

Constants overview

Public Static Fields

CANNOT_CREATE_APPLICATION
COMMAND_STRING_NO_ENTITY
COMMAND_STRING_NOT_SPECIFIED
DEPENDENCY_ENTITY_CAPTION
DEPENDENCY_FIELD_CAPTION
DEPENDENCY_HAS_DEPENDENCIES_CAPTION
DEPENDENCY_RECORD_ID_CAPTION
DEPENDENCY_SUBTYPE_CAPTION
DISPLAY_SUBTYPE_DIALOG_PARAMETER_ERROR
EMPTY_STRING_ERROR
ENTITY_DEPENDENCY_FAILURE
ENTITY_DEPENDENCY_TOPIC_CODE_FAILURE
ENTITY_PERMISSION_DENIED
ENTITY_PERMISSIONS_RETRIEVAL_FAILURE
ENTITY_PLUG_IN_MISSING_ASSEMBLY
ENTITY_PLUG_IN_MISSING_CLASS
ENTITY_PLUG_IN_TYPE_DATA
ENTITY_PLUG_IN_TYPE_DUPLICATE_CHECK
ENTITY_PLUG_IN_TYPE_EXTENSION
ENTITY_PLUG_IN_TYPE_FIND
ENTITY_PLUG_IN_TYPE_MERGE
ENTITY_PLUG_IN_TYPE_UNKNOWN
ENTITY_PLUG_IN_TYPE_VERIFICATION
ENTITY_PLUG_IN_TYPE_VIEWER
FIND_ERROR
FIND_ERROR_CAPTION
FIND_NO_RECORDS
FIND_RESULTS_CAPTION
FORM_TEMPLATE_HOST_ASSEMBLY
FORM_TEMPLATE_HOST_TYPE
GENERIC_ENTITY_ASSEMBLY
GENERIC_ENTITY_TYPE
GENERIC_FIND_ASSEMBLY
GENERIC_FIND_TYPE
INVALID_COMMAND_STRING
INVALID_COMMAND_TYPE
INVALID_ENTITY_ID
INVALID_ENTITY_NAME
INVALID_VIEW_ID
KEY_NOT_IN_COLLECTION
MESSAGE_BOX_CAPTION
NUMBER_LESS_THAN_ONE_ERROR
PERMISSION_CREATE
PERMISSION_DELETE
PERMISSION_EDIT
PERMISSION_MERGE
PERMISSION_OBJECT_VIEWER
PERMISSION_READ
RECORD_HISTORY_CHANGES_CAPTION
RECORD_HISTORY_COMMENTS_CAPTION
RECORD_HISTORY_CONFIRM_RESTORE
RECORD_HISTORY_DATE_UPDATED_CAPTION
RECORD_HISTORY_MSG_BOX_CAPTION
RECORD_HISTORY_NO_PERMISSION_MESSAGE
RECORD_HISTORY_SHOW_ERROR_MESSAGE
RECORD_HISTORY_VERSION_CAPTION
RECORD_HISTORY_WHO_UPDATED_CAPTION
RECORD_PERMISSION_DENIED
VALUE_TYPE_MISMATCH
VIEW_FORM_CAPTION_CREATE
VIEW_FORM_CAPTION_LOAD
VIEWER_FAILURE

Public Static Properties

RecordHistoryMsgBoxCaption |
RecordHistoryNoPermissionMessage |
RecordHistoryShowErrorMessage |
ViewFormCaptionCreate |
ViewFormCaptionLoad |
CannotCreateApplicationMessage |
InvalidEntityMessage | Overloaded.
EmptyStringErrorMessage |
NumberLessThanOneErrorMessage |
InvalidViewIDMessage |
InvalidCommandType |
InvalidCommandString |
CommandStringNotSpecifiedMessage |
CommandStringNoEntityMessage |
KeyNotInCollectionMessage |
ValueTypeMismatchMessage |
EntityPermissionsRetrievalFailureMessage |
EntityDependencyTopicCodeFailureMessage |
EntityDependencyFailureMessage |
EntityPlugInTypeText |
EntityPlugInMissingDataMessage |
UserCredentials |

Public Static Methods

DependencyCaptionMessage
EntityPermissionDeniedException
FindErrorCaption
FindErrorMessage
FindNoRecordsMessage
FindResultsCaption
GetDisplaySubTypeDialogParameterErrorMessage
GetResourceString
MessageBoxCaption
RecordHistoryCaptionMessage
RecordHistoryConfirmRestoreMessage
RecordPermissionDeniedMessage
ViewerFailureMessage

Public Instance Constructors

Constants Constructor Initializes a new instance of the Constants class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants Constructor

Initializes a new instance of the Constants class.

public Constants();

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants Fields

The fields of the Constants class are listed below. For a complete list of Constants class members, see the Constants Members topic.

Public Static Fields

CANNOT_CREATE_APPLICATION
COMMAND_STRING_NO_ENTITY
COMMAND_STRING_NOT_SPECIFIED
DEPENDENCY_ENTITY_CAPTION
DEPENDENCY_FIELD_CAPTION
DEPENDENCY_HAS_DEPENDENCIES_CAPTION
DEPENDENCY_RECORD_ID_CAPTION
DEPENDENCY_SUBTYPE_CAPTION
DISPLAY_SUBTYPE_DIALOG_PARAMETER_ERROR
EMPTY_STRING_ERROR
ENTITY_DEPENDENCY_FAILURE
ENTITY_DEPENDENCY_TOPIC_CODE_FAILURE
ENTITY_PERMISSION_DENIED
ENTITY_PERMISSIONS_RETRIEVAL_FAILURE
ENTITY_PLUG_IN_MISSING_ASSEMBLY
ENTITY_PLUG_IN_MISSING_CLASS
ENTITY_PLUG_IN_TYPE_DATA
ENTITY_PLUG_IN_TYPE_DUPLICATE_CHECK
ENTITY_PLUG_IN_TYPE_EXTENSION
ENTITY_PLUG_IN_TYPE_FIND
ENTITY_PLUG_IN_TYPE_MERGE
ENTITY_PLUG_IN_TYPE_UNKNOWN
ENTITY_PLUG_IN_TYPE_VERIFICATION
ENTITY_PLUG_IN_TYPE_VIEWER
FIND_ERROR
FIND_ERROR_CAPTION
FIND_NO_RECORDS
FIND_RESULTS_CAPTION
FORM_TEMPLATE_HOST_ASSEMBLY
FORM_TEMPLATE_HOST_TYPE
GENERIC_ENTITY_ASSEMBLY
GENERIC_ENTITY_TYPE
GENERIC_FIND_ASSEMBLY
GENERIC_FIND_TYPE
INVALID_COMMAND_STRING
INVALID_COMMAND_TYPE
INVALID_ENTITY_ID
INVALID_ENTITY_NAME
INVALID_VIEW_ID
KEY_NOT_IN_COLLECTION
MESSAGE_BOX_CAPTION
NUMBER_LESS_THAN_ONE_ERROR
PERMISSION_CREATE
PERMISSION_DELETE
PERMISSION_EDIT
PERMISSION_MERGE
PERMISSION_OBJECT_VIEWER
PERMISSION_READ
RECORD_HISTORY_CHANGES_CAPTION
RECORD_HISTORY_COMMENTS_CAPTION
RECORD_HISTORY_CONFIRM_RESTORE
RECORD_HISTORY_DATE_UPDATED_CAPTION
RECORD_HISTORY_MSG_BOX_CAPTION
RECORD_HISTORY_NO_PERMISSION_MESSAGE
RECORD_HISTORY_SHOW_ERROR_MESSAGE
RECORD_HISTORY_VERSION_CAPTION
RECORD_HISTORY_WHO_UPDATED_CAPTION
RECORD_PERMISSION_DENIED
VALUE_TYPE_MISMATCH
VIEW_FORM_CAPTION_CREATE
VIEW_FORM_CAPTION_LOAD
VIEWER_FAILURE

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants.CANNOT_CREATE_APPLICATION Field

public const CANNOT_CREATE_APPLICATION CANNOT_CREATE_APPLICATION = "CANNOT_CREATE_APPLICATION";

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants.COMMAND_STRING_NO_ENTITY Field

public const COMMAND_STRING_NO_ENTITY COMMAND_STRING_NO_ENTITY = "COMMAND_STRING_NO_ENTITY";

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants.COMMAND_STRING_NOT_SPECIFIED Field

public const COMMAND_STRING_NOT_SPECIFIED COMMAND_STRING_NOT_SPECIFIED = "COMMAND_STRING_NOT_SPECIFIED";

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants.DEPENDENCY_ENTITY_CAPTION Field

public const DEPENDENCY_ENTITY_CAPTION DEPENDENCY_ENTITY_CAPTION = "DEPENDENCY_ENTITY_CAPTION";

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants.DEPENDENCY_FIELD_CAPTION Field

public const DEPENDENCY_FIELD_CAPTION DEPENDENCY_FIELD_CAPTION = "DEPENDENCY_FIELD_CAPTION";

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants.DEPENDENCY_HAS_DEPENDENCIES_CAPTION Field

public const DEPENDENCY_HAS_DEPENDENCIES_CAPTION DEPENDENCY_HAS_DEPENDENCIES_CAPTION = "DEPENDENCY_HAS_DEPENDENCIES_CAPTION";

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants.DEPENDENCY_RECORD_ID_CAPTION Field

public const DEPENDENCY_RECORD_ID_CAPTION DEPENDENCY_RECORD_ID_CAPTION = "DEPENDENCY_RECORD_ID_CAPTION";

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants.DEPENDENCY_SUBTYPE_CAPTION Field

public const DEPENDENCY_SUBTYPE_CAPTION DEPENDENCY_SUBTYPE_CAPTION = "DEPENDENCY_SUBTYPE_CAPTION";

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants.DISPLAY_SUBTYPE_DIALOG_PARAMETER_ERROR Field

public const DISPLAY_SUBTYPE_DIALOG_PARAMETER_ERROR DISPLAY_SUBTYPE_DIALOG_PARAMETER_ERROR = "DISPLAY_SUBTYPE_DIALOG_PARAMETER_ERROR";

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants.EMPTY_STRING_ERROR Field

public const EMPTY_STRING_ERROR EMPTY_STRING_ERROR = "EMPTY_STRING_ERROR";

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants.ENTITY_DEPENDENCY_FAILURE Field

public const ENTITY_DEPENDENCY_FAILURE ENTITY_DEPENDENCY_FAILURE = "ENTITY_DEPENDENCY_FAILURE";

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants.ENTITY_DEPENDENCY_TOPIC_CODE_FAILURE Field

public const ENTITY_DEPENDENCY_TOPIC_CODE_FAILURE ENTITY_DEPENDENCY_TOPIC_CODE_FAILURE = "ENTITY_DEPENDENCY_TOPIC_CODE_FAILURE";

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants.ENTITY_PERMISSION_DENIED Field

public const ENTITY_PERMISSION_DENIED ENTITY_PERMISSION_DENIED = "ENTITY_PERMISSION_DENIED";

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants.ENTITY_PERMISSIONS_RETRIEVAL_FAILURE Field

public const ENTITY_PERMISSIONS_RETRIEVAL_FAILURE ENTITY_PERMISSIONS_RETRIEVAL_FAILURE = "ENTITY_PERMISSIONS_RETRIEVAL_FAILURE";

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants.ENTITY_PLUG_IN_MISSING_ASSEMBLY Field

public const ENTITY_PLUG_IN_MISSING_ASSEMBLY ENTITY_PLUG_IN_MISSING_ASSEMBLY = "ENTITY_PLUG_IN_MISSING_ASSEMBLY";

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants.ENTITY_PLUG_IN_MISSING_CLASS Field

public const ENTITY_PLUG_IN_MISSING_CLASS ENTITY_PLUG_IN_MISSING_CLASS = "ENTITY_PLUG_IN_MISSING_CLASS";

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants.ENTITY_PLUG_IN_TYPE_DATA Field

public const ENTITY_PLUG_IN_TYPE_DATA ENTITY_PLUG_IN_TYPE_DATA = "ENTITY_PLUG_IN_TYPE_DATA";

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants.ENTITY_PLUG_IN_TYPE_DUPLICATE_CHECK Field

public const ENTITY_PLUG_IN_TYPE_DUPLICATE_CHECK ENTITY_PLUG_IN_TYPE_DUPLICATE_CHECK = "ENTITY_PLUG_IN_TYPE_DUPLICATE_CHECK";

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants.ENTITY_PLUG_IN_TYPE_EXTENSION Field

public const ENTITY_PLUG_IN_TYPE_EXTENSION ENTITY_PLUG_IN_TYPE_EXTENSION = "ENTITY_PLUG_IN_TYPE_EXTENSION";

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants.ENTITY_PLUG_IN_TYPE_FIND Field

public const ENTITY_PLUG_IN_TYPE_FIND ENTITY_PLUG_IN_TYPE_FIND = "ENTITY_PLUG_IN_TYPE_FIND";

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants.ENTITY_PLUG_IN_TYPE_MERGE Field

public const ENTITY_PLUG_IN_TYPE_MERGE ENTITY_PLUG_IN_TYPE_MERGE = "ENTITY_PLUG_IN_TYPE_MERGE";

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants.ENTITY_PLUG_IN_TYPE_UNKNOWN Field

public const ENTITY_PLUG_IN_TYPE_UNKNOWN ENTITY_PLUG_IN_TYPE_UNKNOWN = "ENTITY_PLUG_IN_TYPE_UNKNOWN";

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants.ENTITY_PLUG_IN_TYPE_VERIFICATION Field

public const ENTITY_PLUG_IN_TYPE_VERIFICATION ENTITY_PLUG_IN_TYPE_VERIFICATION = "ENTITY_PLUG_IN_TYPE_VERIFICATION";

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants.ENTITY_PLUG_IN_TYPE_VIEWER Field

public const ENTITY_PLUG_IN_TYPE_VIEWER ENTITY_PLUG_IN_TYPE_VIEWER = "ENTITY_PLUG_IN_TYPE_VIEWER";

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants.FIND_ERROR Field

public const FIND_ERROR FIND_ERROR = "FIND_ERROR";

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants.FIND_ERROR_CAPTION Field

public const FIND_ERROR_CAPTION FIND_ERROR_CAPTION = "FIND_ERROR_CAPTION";

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants.FIND_NO_RECORDS Field

public const FIND_NO_RECORDS FIND_NO_RECORDS = "FIND_NO_RECORDS";

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants.FIND_RESULTS_CAPTION Field

public const FIND_RESULTS_CAPTION FIND_RESULTS_CAPTION = "FIND_RESULTS_CAPTION";

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants.FORM_TEMPLATE_HOST_ASSEMBLY Field

public const FORM_TEMPLATE_HOST_ASSEMBLY FORM_TEMPLATE_HOST_ASSEMBLY = "AptifyFormTemplateHost";

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants.FORM_TEMPLATE_HOST_TYPE Field

public const FORM_TEMPLATE_HOST_TYPE FORM_TEMPLATE_HOST_TYPE = "Aptify.Framework.WindowsForms.AptifyFormTemplateHost";

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants.GENERIC_ENTITY_ASSEMBLY Field

public const GENERIC_ENTITY_ASSEMBLY GENERIC_ENTITY_ASSEMBLY = "AptifyGenericEntity";

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants.GENERIC_ENTITY_TYPE Field

public const GENERIC_ENTITY_TYPE GENERIC_ENTITY_TYPE = "Aptify.Framework.BusinessLogic.GenericEntity.AptifyGenericEntity";

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants.GENERIC_FIND_ASSEMBLY Field

public const GENERIC_FIND_ASSEMBLY GENERIC_FIND_ASSEMBLY = "AptifyGenericFind";

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants.GENERIC_FIND_TYPE Field

public const GENERIC_FIND_TYPE GENERIC_FIND_TYPE = "Aptify.Framework.Application.GenericFind";

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants.INVALID_COMMAND_STRING Field

public const INVALID_COMMAND_STRING INVALID_COMMAND_STRING = "INVALID_COMMAND_STRING";

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants.INVALID_COMMAND_TYPE Field

public const INVALID_COMMAND_TYPE INVALID_COMMAND_TYPE = "INVALID_COMMAND_TYPE";

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants.INVALID_ENTITY_ID Field

public const INVALID_ENTITY_ID INVALID_ENTITY_ID = "INVALID_ENTITY_ID";

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants.INVALID_ENTITY_NAME Field

public const INVALID_ENTITY_NAME INVALID_ENTITY_NAME = "INVALID_ENTITY_NAME";

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants.INVALID_VIEW_ID Field

public const INVALID_VIEW_ID INVALID_VIEW_ID = "INVALID_VIEW_ID";

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants.KEY_NOT_IN_COLLECTION Field

public const KEY_NOT_IN_COLLECTION KEY_NOT_IN_COLLECTION = "KEY_NOT_IN_COLLECTION";

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants.MESSAGE_BOX_CAPTION Field

public const MESSAGE_BOX_CAPTION MESSAGE_BOX_CAPTION = "MESSAGE_BOX_CAPTION";

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants.NUMBER_LESS_THAN_ONE_ERROR Field

public const NUMBER_LESS_THAN_ONE_ERROR NUMBER_LESS_THAN_ONE_ERROR = "NUMBER_LESS_THAN_ONE_ERROR";

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants.PERMISSION_CREATE Field

public const PERMISSION_CREATE PERMISSION_CREATE = "PERMISSION_CREATE";

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants.PERMISSION_DELETE Field

public const PERMISSION_DELETE PERMISSION_DELETE = "PERMISSION_DELETE";

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants.PERMISSION_EDIT Field

public const PERMISSION_EDIT PERMISSION_EDIT = "PERMISSION_EDIT";

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants.PERMISSION_MERGE Field

public const PERMISSION_MERGE PERMISSION_MERGE = "PERMISSION_MERGE";

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants.PERMISSION_OBJECT_VIEWER Field

public const PERMISSION_OBJECT_VIEWER PERMISSION_OBJECT_VIEWER = "PERMISSION_OBJECT_VIEWER";

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants.PERMISSION_READ Field

public const PERMISSION_READ PERMISSION_READ = "PERMISSION_READ";

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants.RECORD_HISTORY_CHANGES_CAPTION Field

public const RECORD_HISTORY_CHANGES_CAPTION RECORD_HISTORY_CHANGES_CAPTION = "RECORD_HISTORY_CHANGES_CAPTION";

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants.RECORD_HISTORY_COMMENTS_CAPTION Field

public const RECORD_HISTORY_COMMENTS_CAPTION RECORD_HISTORY_COMMENTS_CAPTION = "RECORD_HISTORY_COMMENTS_CAPTION";

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants.RECORD_HISTORY_CONFIRM_RESTORE Field

public const RECORD_HISTORY_CONFIRM_RESTORE RECORD_HISTORY_CONFIRM_RESTORE = "RECORD_HISTORY_CONFIRM_RESTORE";

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants.RECORD_HISTORY_DATE_UPDATED_CAPTION Field

public const RECORD_HISTORY_DATE_UPDATED_CAPTION RECORD_HISTORY_DATE_UPDATED_CAPTION = "RECORD_HISTORY_DATE_UPDATED_CAPTION";

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants.RECORD_HISTORY_MSG_BOX_CAPTION Field

public const RECORD_HISTORY_MSG_BOX_CAPTION RECORD_HISTORY_MSG_BOX_CAPTION = "RECORD_HISTORY_MSG_BOX_CAPTION";

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants.RECORD_HISTORY_NO_PERMISSION_MESSAGE Field

public const RECORD_HISTORY_NO_PERMISSION_MESSAGE RECORD_HISTORY_NO_PERMISSION_MESSAGE = "RECORD_HISTORY_NO_PERMISSION_MESSAGE";

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants.RECORD_HISTORY_SHOW_ERROR_MESSAGE Field

public const RECORD_HISTORY_SHOW_ERROR_MESSAGE RECORD_HISTORY_SHOW_ERROR_MESSAGE = "RECORD_HISTORY_SHOW_ERROR_MESSAGE";

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants.RECORD_HISTORY_VERSION_CAPTION Field

public const RECORD_HISTORY_VERSION_CAPTION RECORD_HISTORY_VERSION_CAPTION = "RECORD_HISTORY_VERSION_CAPTION";

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants.RECORD_HISTORY_WHO_UPDATED_CAPTION Field

public const RECORD_HISTORY_WHO_UPDATED_CAPTION RECORD_HISTORY_WHO_UPDATED_CAPTION = "RECORD_HISTORY_WHO_UPDATED_CAPTION";

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants.RECORD_PERMISSION_DENIED Field

public const RECORD_PERMISSION_DENIED RECORD_PERMISSION_DENIED = "RECORD_PERMISSION_DENIED";

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants.VALUE_TYPE_MISMATCH Field

public const VALUE_TYPE_MISMATCH VALUE_TYPE_MISMATCH = "VALUE_TYPE_MISMATCH";

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants.VIEW_FORM_CAPTION_CREATE Field

public const VIEW_FORM_CAPTION_CREATE VIEW_FORM_CAPTION_CREATE = "VIEW_FORM_CAPTION_CREATE";

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants.VIEW_FORM_CAPTION_LOAD Field

public const VIEW_FORM_CAPTION_LOAD VIEW_FORM_CAPTION_LOAD = "VIEW_FORM_CAPTION_LOAD";

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants.VIEWER_FAILURE Field

public const VIEWER_FAILURE VIEWER_FAILURE = "VIEWER_FAILURE";

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants Properties

The properties of the Constants class are listed below. For a complete list of Constants class members, see the Constants Members topic.

Public Static Properties

RecordHistoryMsgBoxCaption |
RecordHistoryNoPermissionMessage |
RecordHistoryShowErrorMessage |
ViewFormCaptionCreate |
ViewFormCaptionLoad |
CannotCreateApplicationMessage |
InvalidEntityMessage | Overloaded.
EmptyStringErrorMessage |
NumberLessThanOneErrorMessage |
InvalidViewIDMessage |
InvalidCommandType |
InvalidCommandString |
CommandStringNotSpecifiedMessage |
CommandStringNoEntityMessage |
KeyNotInCollectionMessage |
ValueTypeMismatchMessage |
EntityPermissionsRetrievalFailureMessage |
EntityDependencyTopicCodeFailureMessage |
EntityDependencyFailureMessage |
EntityPlugInTypeText |
EntityPlugInMissingDataMessage |
UserCredentials |

See Also

Constants Class | Aptify.Framework.Application Namespace


CannotCreateApplicationMessage Property

Aptify 5.0 Software Development Kit (SDK)

Constants.CannotCreateApplicationMessage Property

public static String CannotCreateApplicationMessage {get;}

See Also

Constants Class | Aptify.Framework.Application Namespace


CommandStringNoEntityMessage Property

Aptify 5.0 Software Development Kit (SDK)

Constants.CommandStringNoEntityMessage Property

public static String this[
String Method
] {get;}

See Also

Constants Class | Aptify.Framework.Application Namespace


CommandStringNotSpecifiedMessage Property

Aptify 5.0 Software Development Kit (SDK)

Constants.CommandStringNotSpecifiedMessage Property

public static String this[
String Method
] {get;}

See Also

Constants Class | Aptify.Framework.Application Namespace


EmptyStringErrorMessage Property

Aptify 5.0 Software Development Kit (SDK)

Constants.EmptyStringErrorMessage Property

public static String this[
String ParameterName
] {get;}

See Also

Constants Class | Aptify.Framework.Application Namespace


EntityDependencyFailureMessage Property

Aptify 5.0 Software Development Kit (SDK)

Constants.EntityDependencyFailureMessage Property

public static String this[
String EntityName,
Int64 RecordID
] {get;}

See Also

Constants Class | Aptify.Framework.Application Namespace


EntityDependencyTopicCodeFailureMessage Property

Aptify 5.0 Software Development Kit (SDK)

Constants.EntityDependencyTopicCodeFailureMessage Property

public static String this[
String EntityName,
Int64 RecordID
] {get;}

See Also

Constants Class | Aptify.Framework.Application Namespace


EntityPermissionsRetrievalFailureMessage Property

Aptify 5.0 Software Development Kit (SDK)

Constants.EntityPermissionsRetrievalFailureMessage Property

public static String this[
String EntityName,
Int64 AptifyUserID
] {get;}

See Also

Constants Class | Aptify.Framework.Application Namespace


EntityPlugInMissingDataMessage Property

Aptify 5.0 Software Development Kit (SDK)

Constants.EntityPlugInMissingDataMessage Property

public static String this[
String EntityName,
EntityPlugInType PlugInType,
String AssemblyName,
String ClassName
] {get;}

See Also

Constants Class | Aptify.Framework.Application Namespace


EntityPlugInTypeText Property

Aptify 5.0 Software Development Kit (SDK)

Constants.EntityPlugInTypeText Property

public static String this[
EntityPlugInType PlugInType
] {get;}

See Also

Constants Class | Aptify.Framework.Application Namespace


InvalidCommandString Property

Aptify 5.0 Software Development Kit (SDK)

Constants.InvalidCommandString Property

public static String this[
String CommandString
] {get;}

See Also

Constants Class | Aptify.Framework.Application Namespace


InvalidCommandType Property

Aptify 5.0 Software Development Kit (SDK)

Constants.InvalidCommandType Property

public static String this[
String CommandType
] {get;}

See Also

Constants Class | Aptify.Framework.Application Namespace


String Property

Aptify 5.0 Software Development Kit (SDK)

Constants.String Property

Overload List

public static String this[Int64] {get;}

public static String this[String] {get;}

See Also

Constants Class | Aptify.Framework.Application Namespace


InvalidEntityMessage Property (Int64)

Aptify 5.0 Software Development Kit (SDK)

Constants.InvalidEntityMessage Property (Int64)

public static String this[
Int64 EntityID
] {get;}

See Also

Constants Class | Aptify.Framework.Application Namespace | Constants.String Overload List


InvalidEntityMessage Property (String)

Aptify 5.0 Software Development Kit (SDK)

Constants.InvalidEntityMessage Property (String)

public static String this[
String EntityName
] {get;}

See Also

Constants Class | Aptify.Framework.Application Namespace | Constants.String Overload List


InvalidViewIDMessage Property

Aptify 5.0 Software Development Kit (SDK)

Constants.InvalidViewIDMessage Property

public static String this[
Int64 ViewID
] {get;}

See Also

Constants Class | Aptify.Framework.Application Namespace


KeyNotInCollectionMessage Property

Aptify 5.0 Software Development Kit (SDK)

Constants.KeyNotInCollectionMessage Property

public static String KeyNotInCollectionMessage {get;}

See Also

Constants Class | Aptify.Framework.Application Namespace


NumberLessThanOneErrorMessage Property

Aptify 5.0 Software Development Kit (SDK)

Constants.NumberLessThanOneErrorMessage Property

public static String this[
String ParameterName,
String ParameterValue
] {get;}

See Also

Constants Class | Aptify.Framework.Application Namespace


RecordHistoryMsgBoxCaption Property

Aptify 5.0 Software Development Kit (SDK)

Constants.RecordHistoryMsgBoxCaption Property

public static String RecordHistoryMsgBoxCaption {get;}

See Also

Constants Class | Aptify.Framework.Application Namespace


RecordHistoryNoPermissionMessage Property

Aptify 5.0 Software Development Kit (SDK)

Constants.RecordHistoryNoPermissionMessage Property

public static String RecordHistoryNoPermissionMessage {get;}

See Also

Constants Class | Aptify.Framework.Application Namespace


RecordHistoryShowErrorMessage Property

Aptify 5.0 Software Development Kit (SDK)

Constants.RecordHistoryShowErrorMessage Property

public static String RecordHistoryShowErrorMessage {get;}

See Also

Constants Class | Aptify.Framework.Application Namespace


UserCredentials Property

Aptify 5.0 Software Development Kit (SDK)

Constants.UserCredentials Property

public static UserCredentials UserCredentials {set;}

See Also

Constants Class | Aptify.Framework.Application Namespace


ValueTypeMismatchMessage Property

Aptify 5.0 Software Development Kit (SDK)

Constants.ValueTypeMismatchMessage Property

public static String this[
String DataType
] {get;}

See Also

Constants Class | Aptify.Framework.Application Namespace


ViewFormCaptionCreate Property

Aptify 5.0 Software Development Kit (SDK)

Constants.ViewFormCaptionCreate Property

public static String ViewFormCaptionCreate {get;}

See Also

Constants Class | Aptify.Framework.Application Namespace


ViewFormCaptionLoad Property

Aptify 5.0 Software Development Kit (SDK)

Constants.ViewFormCaptionLoad Property

public static String this[
String ViewName
] {get;}

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants Methods

The methods of the Constants class are listed below. For a complete list of Constants class members, see the Constants Members topic.

Public Static Methods

DependencyCaptionMessage
EntityPermissionDeniedException
FindErrorCaption
FindErrorMessage
FindNoRecordsMessage
FindResultsCaption
GetDisplaySubTypeDialogParameterErrorMessage
GetResourceString
MessageBoxCaption
RecordHistoryCaptionMessage
RecordHistoryConfirmRestoreMessage
RecordPermissionDeniedMessage
ViewerFailureMessage

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants.DependencyCaptionMessage Method

public static string DependencyCaptionMessage(
String Field
);

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants.EntityPermissionDeniedException Method

public static string EntityPermissionDeniedException(
String EntityName,
Int64 AptifyUserID,
String PermissionRequested
);

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants.FindErrorCaption Method

public static string FindErrorCaption();

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants.FindErrorMessage Method

public static string FindErrorMessage();

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants.FindNoRecordsMessage Method

public static string FindNoRecordsMessage();

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants.FindResultsCaption Method

public static string FindResultsCaption(
String EntityDisplayName
);

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants.GetDisplaySubTypeDialogParameterErrorMessage Method

public static string GetDisplaySubTypeDialogParameterErrorMessage();

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants.GetResourceString Method

public static string GetResourceString(
String ResourceKey
);

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants.MessageBoxCaption Method

public static string MessageBoxCaption();

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants.RecordHistoryCaptionMessage Method

public static string RecordHistoryCaptionMessage(
String Field
);

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants.RecordHistoryConfirmRestoreMessage Method

public static string RecordHistoryConfirmRestoreMessage(
DateTime DateUpdated
);

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants.RecordPermissionDeniedMessage Method

public static string RecordPermissionDeniedMessage(
String EntityName,
String PermissionRequested
);

See Also

Constants Class | Aptify.Framework.Application Namespace


Constants.ViewerFailureMessage Method

public static string ViewerFailureMessage(
String EntityName
);

See Also

Constants Class | Aptify.Framework.Application Namespace


CreationException Class

This exception is throw when the InstanceCreator cannot create an instance.

For a list of all members of this type, see CreationException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
CreationException

public class CreationException : BaseApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyUtility (in AptifyUtility.dll)

See Also

CreationException Members | Aptify.Framework.Application Namespace


CreationException Members

CreationException overview

Public Instance Constructors

CreationException Overloaded. Initializes a new instance of the CreationException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
FromCOMException |
FromNameException |
FromPathException |
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CreationException Class | Aptify.Framework.Application Namespace


CreationException Constructor

Overload List

public CreationException(SerializationInfo,StreamingContext);

public CreationException(String);

public CreationException(String,Exception);

public CreationException(String,Exception,Exception,Exception);

See Also

CreationException Class | Aptify.Framework.Application Namespace


CreationException Constructor (String)

public CreationException(
String Message
);

See Also

CreationException Class | Aptify.Framework.Application Namespace | CreationException Constructor Overload List


CreationException Constructor (String, Exception)

public CreationException(
String Message,
Exception InnerException
);

See Also

CreationException Class | Aptify.Framework.Application Namespace | CreationException Constructor Overload List


CreationException Constructor (String, Exception, Exception, Exception)

public CreationException(
String Message,
Exception FromNameException,
Exception FromPathException,
Exception FromCOMException
);

See Also

CreationException Class | Aptify.Framework.Application Namespace | CreationException Constructor Overload List


CreationException Constructor (SerializationInfo, StreamingContext)

public CreationException(
SerializationInfo Info,
StreamingContext Context
);

See Also

CreationException Class | Aptify.Framework.Application Namespace | CreationException Constructor Overload List


CreationException Properties

The properties of the CreationException class are listed below. For a complete list of CreationException class members, see the CreationException Members topic.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
FromCOMException |
FromNameException |
FromPathException |
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

See Also

CreationException Class | Aptify.Framework.Application Namespace


FromCOMException Property

Aptify 5.0 Software Development Kit (SDK)

CreationException.FromCOMException Property

public Exception FromCOMException {get;}

See Also

CreationException Class | Aptify.Framework.Application Namespace


FromNameException Property

Aptify 5.0 Software Development Kit (SDK)

CreationException.FromNameException Property

public Exception FromNameException {get;}

See Also

CreationException Class | Aptify.Framework.Application Namespace


FromPathException Property

Aptify 5.0 Software Development Kit (SDK)

CreationException.FromPathException Property

public Exception FromPathException {get;}

See Also

CreationException Class | Aptify.Framework.Application Namespace


CreationException Methods

The methods of the CreationException class are listed below. For a complete list of CreationException class members, see the CreationException Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CreationException Class | Aptify.Framework.Application Namespace


CreationException.GetObjectData Method

public override void GetObjectData(
SerializationInfo Info,
StreamingContext Context
);

Implements

ISerializable.

See Also

CreationException Class | Aptify.Framework.Application Namespace


CurrencyTypeCache Class

Caches Currency Types information. Shared, on-demand cache.

For a list of all members of this type, see CurrencyTypeCache Members.

System.Object
CurrencyTypeCache

public class CurrencyTypeCache

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyApplication (in AptifyApplication.dll)

See Also

CurrencyTypeCache Members | Aptify.Framework.Application Namespace


CurrencyTypeCache Members

CurrencyTypeCache overview

Public Static Methods

Instance

Public Instance Constructors

CurrencyTypeCache Constructor

Public Instance Properties

CurrencyType | This method will either return a CurrencyTypeData object from the cache. If the cache doesn't contain a CurrencyTypeData object, the information will be retrieved from the database and used to populate a CurrencyTypeData object which will be added to the cache and returned to the caller.
FunctionalCurrencyType | Overloaded. Returns the system's Functional Currency. Starting with 4.0 SP3, the system's Functional Currency has been deprecated and replaced with Functional Currency defined at the Organization level.
MaxNumDigitsAfterDecimal | Returns the maximum value of NumDigitsAfterDecimal for all Currency Types records in the system.
MultipleCurrenciesInUse | Returns True if more than one Currency Types record exists.

Public Instance Methods

Clear | Clears the Currency Types cache.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
RemoveCurrencyTypeFromCache |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CurrencyTypeCache Class | Aptify.Framework.Application Namespace


CurrencyTypeCache Constructor

public CurrencyTypeCache(
AptifyApplication Application
);

See Also

CurrencyTypeCache Class | Aptify.Framework.Application Namespace


CurrencyTypeCache Properties

The properties of the CurrencyTypeCache class are listed below. For a complete list of CurrencyTypeCache class members, see the CurrencyTypeCache Members topic.

Public Instance Properties

CurrencyType | This method will either return a CurrencyTypeData object from the cache. If the cache doesn't contain a CurrencyTypeData object, the information will be retrieved from the database and used to populate a CurrencyTypeData object which will be added to the cache and returned to the caller.
FunctionalCurrencyType | Overloaded. Returns the system's Functional Currency. Starting with 4.0 SP3, the system's Functional Currency has been deprecated and replaced with Functional Currency defined at the Organization level.
MaxNumDigitsAfterDecimal | Returns the maximum value of NumDigitsAfterDecimal for all Currency Types records in the system.
MultipleCurrenciesInUse | Returns True if more than one Currency Types record exists.

See Also

CurrencyTypeCache Class | Aptify.Framework.Application Namespace


CurrencyType Property

Aptify 5.0 Software Development Kit (SDK)

CurrencyTypeCache.CurrencyType Property

This method will either return a CurrencyTypeData object from the cache. If the cache doesn't contain a CurrencyTypeData object, the information will be retrieved from the database and used to populate a CurrencyTypeData object which will be added to the cache and returned to the caller.

public virtual CurrencyTypeData this[
Int32 CurrencyTypeID,
Boolean ForceRefresh
] {get;}

Parameters

CurrencyTypeID
ForceRefresh

Property Value

Remarks

See Also

CurrencyTypeCache Class | Aptify.Framework.Application Namespace


CurrencyTypeData Property

Aptify 5.0 Software Development Kit (SDK)

CurrencyTypeCache.CurrencyTypeData Property

Returns the system's Functional Currency. Starting with 4.0 SP3, the system's Functional Currency has been deprecated and replaced with Functional Currency defined at the Organization level.

Overload List

Returns the system's Functional Currency. Starting with 4.0 SP3, the system's Functional Currency has been deprecated and replaced with Functional Currency defined at the Organization level.

public virtual CurrencyTypeData FunctionalCurrencyType {get;}

Returns the Organization's Functional Currency Type. If OrganizationID is less than or equal to 0, the system's Functional Currency Type is returned.

public virtual CurrencyTypeData this[Int64] {get;}

See Also

CurrencyTypeCache Class | Aptify.Framework.Application Namespace


FunctionalCurrencyType Property

Aptify 5.0 Software Development Kit (SDK)

CurrencyTypeCache.FunctionalCurrencyType Property

Returns the system's Functional Currency. Starting with 4.0 SP3, the system's Functional Currency has been deprecated and replaced with Functional Currency defined at the Organization level.

public virtual CurrencyTypeData FunctionalCurrencyType {get;}

Property Value

Remarks

See Also

CurrencyTypeCache Class | Aptify.Framework.Application Namespace | CurrencyTypeCache.CurrencyTypeData Overload List


FunctionalCurrencyType Property (Int64)

Aptify 5.0 Software Development Kit (SDK)

CurrencyTypeCache.FunctionalCurrencyType Property (Int64)

Returns the Organization's Functional Currency Type. If OrganizationID is less than or equal to 0, the system's Functional Currency Type is returned.

public virtual CurrencyTypeData this[
Int64 OrganizationID
] {get;}

Parameters

OrganizationID

Property Value

Remarks

See Also

CurrencyTypeCache Class | Aptify.Framework.Application Namespace | CurrencyTypeCache.CurrencyTypeData Overload List


MaxNumDigitsAfterDecimal Property

Aptify 5.0 Software Development Kit (SDK)

CurrencyTypeCache.MaxNumDigitsAfterDecimal Property

Returns the maximum value of NumDigitsAfterDecimal for all Currency Types records in the system.

public virtual Int32 MaxNumDigitsAfterDecimal {get;}

Property Value

Remarks

See Also

CurrencyTypeCache Class | Aptify.Framework.Application Namespace


MultipleCurrenciesInUse Property

Aptify 5.0 Software Development Kit (SDK)

CurrencyTypeCache.MultipleCurrenciesInUse Property

Returns True if more than one Currency Types record exists.

public virtual Boolean MultipleCurrenciesInUse {get;}

Property Value

Remarks

See Also

CurrencyTypeCache Class | Aptify.Framework.Application Namespace


CurrencyTypeCache Methods

The methods of the CurrencyTypeCache class are listed below. For a complete list of CurrencyTypeCache class members, see the CurrencyTypeCache Members topic.

Public Static Methods

Instance

Public Instance Methods

Clear | Clears the Currency Types cache.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
RemoveCurrencyTypeFromCache |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CurrencyTypeCache Class | Aptify.Framework.Application Namespace


CurrencyTypeCache.Clear Method

Clears the Currency Types cache.

public void Clear();

Remarks

See Also

CurrencyTypeCache Class | Aptify.Framework.Application Namespace


CurrencyTypeCache.Instance Method

public static CurrencyTypeCache Instance(
AptifyApplication Application
);

See Also

CurrencyTypeCache Class | Aptify.Framework.Application Namespace


CurrencyTypeCache.RemoveCurrencyTypeFromCache Method

public void RemoveCurrencyTypeFromCache(
Int32 CurrencyTypeID
);

See Also

CurrencyTypeCache Class | Aptify.Framework.Application Namespace


CurrencyTypeData Class

For a list of all members of this type, see CurrencyTypeData Members.

System.Object
CurrencyTypeData

public class CurrencyTypeData

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyApplication (in AptifyApplication.dll)

See Also

CurrencyTypeData Members | Aptify.Framework.Application Namespace


CurrencyTypeData Members

CurrencyTypeData overview

Public Instance Constructors

CurrencyTypeData Constructor Caches Currency Type information used by the Orders objects. Shared, on-demand cache.

Public Instance Properties

Country
CountryID
CurrencySymbol
ExchangeRateGainGLAcct
ExchangeRateLossGLAcct
FormatString
FunctionalCurrency
GeneralLedgerDelimiter
GeneralLedgerSegment
ID
Name
NumDigitsAfterDecimal
TradingSymbol

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CurrencyTypeData Class | Aptify.Framework.Application Namespace


CurrencyTypeData Constructor

Caches Currency Type information used by the Orders objects. Shared, on-demand cache.

public CurrencyTypeData(
DataRow rowCurrencyType
);

Parameters

rowCurrencyType
The values in this object are used to configure the CurrencyTypeData properties. Must contain all of the fields in the core Currency Types Entity definition except RecentSpotRate.

Remarks

See Also

CurrencyTypeData Class | Aptify.Framework.Application Namespace


CurrencyTypeData Properties

The properties of the CurrencyTypeData class are listed below. For a complete list of CurrencyTypeData class members, see the CurrencyTypeData Members topic.

Public Instance Properties

Country
CountryID
CurrencySymbol
ExchangeRateGainGLAcct
ExchangeRateLossGLAcct
FormatString
FunctionalCurrency
GeneralLedgerDelimiter
GeneralLedgerSegment
ID
Name
NumDigitsAfterDecimal
TradingSymbol

See Also

CurrencyTypeData Class | Aptify.Framework.Application Namespace


Country Property

Aptify 5.0 Software Development Kit (SDK)

CurrencyTypeData.Country Property

public String Country {get;}

See Also

CurrencyTypeData Class | Aptify.Framework.Application Namespace


CountryID Property

Aptify 5.0 Software Development Kit (SDK)

CurrencyTypeData.CountryID Property

public Int32 CountryID {get;}

See Also

CurrencyTypeData Class | Aptify.Framework.Application Namespace


CurrencySymbol Property

Aptify 5.0 Software Development Kit (SDK)

CurrencyTypeData.CurrencySymbol Property

public String CurrencySymbol {get;}

See Also

CurrencyTypeData Class | Aptify.Framework.Application Namespace


ExchangeRateGainGLAcct Property

Aptify 5.0 Software Development Kit (SDK)

CurrencyTypeData.ExchangeRateGainGLAcct Property

public String ExchangeRateGainGLAcct {get;}

See Also

CurrencyTypeData Class | Aptify.Framework.Application Namespace


ExchangeRateLossGLAcct Property

Aptify 5.0 Software Development Kit (SDK)

CurrencyTypeData.ExchangeRateLossGLAcct Property

public String ExchangeRateLossGLAcct {get;}

See Also

CurrencyTypeData Class | Aptify.Framework.Application Namespace


FormatString Property

Aptify 5.0 Software Development Kit (SDK)

CurrencyTypeData.FormatString Property

public String FormatString {get;}

See Also

CurrencyTypeData Class | Aptify.Framework.Application Namespace


FunctionalCurrency Property

Aptify 5.0 Software Development Kit (SDK)

CurrencyTypeData.FunctionalCurrency Property

public Boolean FunctionalCurrency {get;}

See Also

CurrencyTypeData Class | Aptify.Framework.Application Namespace


GeneralLedgerDelimiter Property

Aptify 5.0 Software Development Kit (SDK)

CurrencyTypeData.GeneralLedgerDelimiter Property

public String GeneralLedgerDelimiter {get;}

See Also

CurrencyTypeData Class | Aptify.Framework.Application Namespace


GeneralLedgerSegment Property

Aptify 5.0 Software Development Kit (SDK)

CurrencyTypeData.GeneralLedgerSegment Property

public String GeneralLedgerSegment {get;}

See Also

CurrencyTypeData Class | Aptify.Framework.Application Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

CurrencyTypeData.ID Property

public Int32 ID {get;}

See Also

CurrencyTypeData Class | Aptify.Framework.Application Namespace


Name Property

Aptify 5.0 Software Development Kit (SDK)

CurrencyTypeData.Name Property

public String Name {get;}

See Also

CurrencyTypeData Class | Aptify.Framework.Application Namespace


NumDigitsAfterDecimal Property

Aptify 5.0 Software Development Kit (SDK)

CurrencyTypeData.NumDigitsAfterDecimal Property

public Int32 NumDigitsAfterDecimal {get;}

See Also

CurrencyTypeData Class | Aptify.Framework.Application Namespace


TradingSymbol Property

Aptify 5.0 Software Development Kit (SDK)

CurrencyTypeData.TradingSymbol Property

public String TradingSymbol {get;}

See Also

CurrencyTypeData Class | Aptify.Framework.Application Namespace


DSNUtility Class

For a list of all members of this type, see DSNUtility Members.

System.Object
DSNUtility

public class DSNUtility

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyUtility (in AptifyUtility.dll)

See Also

DSNUtility Members | Aptify.Framework.Application Namespace


DSNUtility Members

DSNUtility overview

Public Static Fields

DSN_ATTRIBUTE
DSN_DRIVER_TYPE_ATTRIBUTE
SQL_SERVER_DRIVER_ATTRIBUTE

Public Static Properties

DefaultDSN
DefaultDriver
DefaultDriverType

Public Static Methods

SaveUserDSN

Public Instance Constructors

DSNUtility Constructor Initializes a new instance of the DSNUtility class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DSNUtility Class | Aptify.Framework.Application Namespace


DSNUtility Constructor

Initializes a new instance of the DSNUtility class.

public DSNUtility();

See Also

DSNUtility Class | Aptify.Framework.Application Namespace


DSNUtility Fields

The fields of the DSNUtility class are listed below. For a complete list of DSNUtility class members, see the DSNUtility Members topic.

Public Static Fields

DSN_ATTRIBUTE
DSN_DRIVER_TYPE_ATTRIBUTE
SQL_SERVER_DRIVER_ATTRIBUTE

See Also

DSNUtility Class | Aptify.Framework.Application Namespace


DSNUtility.DSN_ATTRIBUTE Field

public const DSN_ATTRIBUTE DSN_ATTRIBUTE = "AptifyDSN";

See Also

DSNUtility Class | Aptify.Framework.Application Namespace


DSNUtility.DSN_DRIVER_TYPE_ATTRIBUTE Field

public const DSN_DRIVER_TYPE_ATTRIBUTE DSN_DRIVER_TYPE_ATTRIBUTE = "DSNDriverType";

See Also

DSNUtility Class | Aptify.Framework.Application Namespace


DSNUtility.SQL_SERVER_DRIVER_ATTRIBUTE Field

public const SQL_SERVER_DRIVER_ATTRIBUTE SQL_SERVER_DRIVER_ATTRIBUTE = "DSNSQLServerDriver";

See Also

DSNUtility Class | Aptify.Framework.Application Namespace


DSNUtility Properties

The properties of the DSNUtility class are listed below. For a complete list of DSNUtility class members, see the DSNUtility Members topic.

Public Static Properties

DefaultDSN
DefaultDriver
DefaultDriverType

See Also

DSNUtility Class | Aptify.Framework.Application Namespace


DefaultDriver Property

Aptify 5.0 Software Development Kit (SDK)

DSNUtility.DefaultDriver Property

public static String DefaultDriver {get;}

See Also

DSNUtility Class | Aptify.Framework.Application Namespace


DefaultDriverType Property

Aptify 5.0 Software Development Kit (SDK)

DSNUtility.DefaultDriverType Property

public static String DefaultDriverType {get;}

See Also

DSNUtility Class | Aptify.Framework.Application Namespace


DefaultDSN Property

Aptify 5.0 Software Development Kit (SDK)

DSNUtility.DefaultDSN Property

public static String DefaultDSN {get;}

See Also

DSNUtility Class | Aptify.Framework.Application Namespace


DSNUtility Methods

The methods of the DSNUtility class are listed below. For a complete list of DSNUtility class members, see the DSNUtility Members topic.

Public Static Methods

SaveUserDSN

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DSNUtility Class | Aptify.Framework.Application Namespace


DSNUtility.SaveUserDSN Method

public static void SaveUserDSN(
String Name,
String Driver,
String DriverType,
String Server,
String Database,
String UserName,
Boolean Trusted
);

See Also

DSNUtility Class | Aptify.Framework.Application Namespace


EntityAction Class

An object that represents the action wizards configured for a given entity. These are configured in the EntityActions subtype of Entities.

For a list of all members of this type, see EntityAction Members.

System.Object
EntityAction

public class EntityAction

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

A data-only object that returns all of the information stored in the system regarding an entity action in order for it to function.

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyApplication (in AptifyApplication.dll)

See Also

EntityAction Members | Aptify.Framework.Application Namespace


EntityAction Members

EntityAction overview

Public Instance Properties

ActionObject | Returns an instantiated Action object. Ensures that the latest version of the Action Assembly downloaded from the Object Repository.
AssemblyName | Name of the assembly the action object resides in.
ClassName | Name of the class that implements the action.
Description | Text-based description.
EntityID | Primary key of the entity.
Icon | Icon associated with the action.
Name | Unique name of the action.
NameCultureStringID | Culture String ID which will work for Name
ObjectName | Name of the object in the Object Repository.
RunFromEntityBrowser | Reports whether this action can be run from an entity browser.
RunFromPromptedView | Reports whether this action can be run from a prompted view.
RunFromTemporaryView | Reports whether this action can be run from a temporary view.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EntityAction Class | Aptify.Framework.Application Namespace


EntityAction Properties

The properties of the EntityAction class are listed below. For a complete list of EntityAction class members, see the EntityAction Members topic.

Public Instance Properties

ActionObject | Returns an instantiated Action object. Ensures that the latest version of the Action Assembly downloaded from the Object Repository.
AssemblyName | Name of the assembly the action object resides in.
ClassName | Name of the class that implements the action.
Description | Text-based description.
EntityID | Primary key of the entity.
Icon | Icon associated with the action.
Name | Unique name of the action.
NameCultureStringID | Culture String ID which will work for Name
ObjectName | Name of the object in the Object Repository.
RunFromEntityBrowser | Reports whether this action can be run from an entity browser.
RunFromPromptedView | Reports whether this action can be run from a prompted view.
RunFromTemporaryView | Reports whether this action can be run from a temporary view.

See Also

EntityAction Class | Aptify.Framework.Application Namespace


ActionObject Property

Aptify 5.0 Software Development Kit (SDK)

EntityAction.ActionObject Property

Returns an instantiated Action object. Ensures that the latest version of the Action Assembly downloaded from the Object Repository.

public IAptifyAction ActionObject {get;}

Property Value

Remarks

See Also

EntityAction Class | Aptify.Framework.Application Namespace


AssemblyName Property

Aptify 5.0 Software Development Kit (SDK)

EntityAction.AssemblyName Property

Name of the assembly the action object resides in.

public String AssemblyName {get;}

Property Value

Remarks

See Also

EntityAction Class | Aptify.Framework.Application Namespace


ClassName Property

Aptify 5.0 Software Development Kit (SDK)

EntityAction.ClassName Property

Name of the class that implements the action.

public String ClassName {get;}

Property Value

Remarks

See Also

EntityAction Class | Aptify.Framework.Application Namespace


Description Property

Aptify 5.0 Software Development Kit (SDK)

EntityAction.Description Property

Text-based description.

public String Description {get;}

Property Value

Remarks

See Also

EntityAction Class | Aptify.Framework.Application Namespace


EntityID Property

Aptify 5.0 Software Development Kit (SDK)

EntityAction.EntityID Property

Primary key of the entity.

public Int64 EntityID {get;}

Property Value

Remarks

See Also

EntityAction Class | Aptify.Framework.Application Namespace


Icon Property

Aptify 5.0 Software Development Kit (SDK)

EntityAction.Icon Property

Icon associated with the action.

public String Icon {get;}

Remarks

See Also

EntityAction Class | Aptify.Framework.Application Namespace


Name Property

Aptify 5.0 Software Development Kit (SDK)

EntityAction.Name Property

Unique name of the action.

public String Name {get;}

Property Value

Remarks

See Also

EntityAction Class | Aptify.Framework.Application Namespace


NameCultureStringID Property

Aptify 5.0 Software Development Kit (SDK)

EntityAction.NameCultureStringID Property

Culture String ID which will work for Name

public Int64 NameCultureStringID {get;}

Property Value

Remarks

See Also

EntityAction Class | Aptify.Framework.Application Namespace


ObjectName Property

Aptify 5.0 Software Development Kit (SDK)

EntityAction.ObjectName Property

Name of the object in the Object Repository.

public String ObjectName {get;}

Property Value

Remarks

See Also

EntityAction Class | Aptify.Framework.Application Namespace


RunFromEntityBrowser Property

Aptify 5.0 Software Development Kit (SDK)

EntityAction.RunFromEntityBrowser Property

Reports whether this action can be run from an entity browser.

public Boolean RunFromEntityBrowser {get;}

Remarks

See Also

EntityAction Class | Aptify.Framework.Application Namespace


RunFromPromptedView Property

Aptify 5.0 Software Development Kit (SDK)

EntityAction.RunFromPromptedView Property

Reports whether this action can be run from a prompted view.

public Boolean RunFromPromptedView {get;}

Remarks

See Also

EntityAction Class | Aptify.Framework.Application Namespace


RunFromTemporaryView Property

Aptify 5.0 Software Development Kit (SDK)

EntityAction.RunFromTemporaryView Property

Reports whether this action can be run from a temporary view.

public Boolean RunFromTemporaryView {get;}

Remarks

See Also

EntityAction Class | Aptify.Framework.Application Namespace


EntityActions Class

A collection of entity action objects.

For a list of all members of this type, see EntityActions Members.

System.Object
NameObjectCollectionBase
AptifyCollection
EntityActions

public class EntityActions : AptifyCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Object provides a standard implementation of a collection for entity actions. Data can be retrieved using either each action or an index with a count.

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyApplication (in AptifyApplication.dll)

See Also

EntityActions Members | Aptify.Framework.Application Namespace


EntityActions Members

EntityActions overview

Public Instance Properties

Application |
Count (inherited from NameObjectCollectionBase) | Gets the number of key/value pairs contained in the NameObjectCollectionBase instance.
EntityID |
Item | Overloaded.
Keys (inherited from NameObjectCollectionBase) | Gets a KeysCollection instance that contains all the keys in the NameObjectCollectionBase instance.

Public Instance Methods

Add | Overloaded.
Clear (inherited from AptifyCollection) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from AptifyCollection) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from NameObjectCollectionBase) | Implements the ISerializable interface and returns the data needed to serialize the NameObjectCollectionBase instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from AptifyCollection) | Gets the index of the item with the specified Key.
Merge (inherited from AptifyCollection) | Allows a user to merge items from another collection to this collection.
OnDeserialization (inherited from NameObjectCollectionBase) | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete.
Remove (inherited from AptifyCollection) | Overloaded.
RemoveAt (inherited from AptifyCollection) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

IsReadOnly (inherited from NameObjectCollectionBase) Gets or sets a value indicating whether the NameObjectCollectionBase instance is read-only.

Protected Instance Methods

BaseAdd (inherited from NameObjectCollectionBase) | Adds an entry with the specified key and value into the NameObjectCollectionBase instance.
BaseClear (inherited from NameObjectCollectionBase) | Removes all entries from the NameObjectCollectionBase instance.
BaseGet (inherited from NameObjectCollectionBase) | Overloaded. Gets the value of the first entry with the specified key from the NameObjectCollectionBase instance.
BaseGetAllKeys (inherited from NameObjectCollectionBase) | Returns a String array that contains all the keys in the NameObjectCollectionBase instance.
BaseGetAllValues (inherited from NameObjectCollectionBase) | Overloaded. Returns an Object array that contains all the values in the NameObjectCollectionBase instance.
BaseGetKey (inherited from NameObjectCollectionBase) | Gets the key of the entry at the specified index of the NameObjectCollectionBase instance.
BaseHasKeys (inherited from NameObjectCollectionBase) | Gets a value indicating whether the NameObjectCollectionBase instance contains entries whose keys are not null.
BaseRemove (inherited from NameObjectCollectionBase) | Removes the entries with the specified key from the NameObjectCollectionBase instance.
BaseRemoveAt (inherited from NameObjectCollectionBase) | Removes the entry at the specified index of the NameObjectCollectionBase instance.
BaseSet (inherited from NameObjectCollectionBase) | Overloaded. Sets the value of the first entry with the specified key in the NameObjectCollectionBase instance, if found; otherwise, adds an entry with the specified key and value into the NameObjectCollectionBase instance.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EntityActions Class | Aptify.Framework.Application Namespace


EntityActions Properties

The properties of the EntityActions class are listed below. For a complete list of EntityActions class members, see the EntityActions Members topic.

Public Instance Properties

Application |
Count (inherited from NameObjectCollectionBase) | Gets the number of key/value pairs contained in the NameObjectCollectionBase instance.
EntityID |
Item | Overloaded.
Keys (inherited from NameObjectCollectionBase) | Gets a KeysCollection instance that contains all the keys in the NameObjectCollectionBase instance.

Protected Instance Properties

IsReadOnly (inherited from NameObjectCollectionBase) Gets or sets a value indicating whether the NameObjectCollectionBase instance is read-only.

See Also

EntityActions Class | Aptify.Framework.Application Namespace


Application Property

Aptify 5.0 Software Development Kit (SDK)

EntityActions.Application Property

public AptifyApplication Application {get;}

See Also

EntityActions Class | Aptify.Framework.Application Namespace


EntityID Property

Aptify 5.0 Software Development Kit (SDK)

EntityActions.EntityID Property

public Int64 EntityID {get;}

See Also

EntityActions Class | Aptify.Framework.Application Namespace


EntityAction Property

Aptify 5.0 Software Development Kit (SDK)

EntityActions.EntityAction Property

Overload List

public EntityAction this[Int32] {get; set;}

public EntityAction this[String] {get; set;}

See Also

EntityActions Class | Aptify.Framework.Application Namespace


Item Property (Int32)

Aptify 5.0 Software Development Kit (SDK)

EntityActions.Item Property (Int32)

public EntityAction this[
Int32 Index
] {get; set;}

See Also

EntityActions Class | Aptify.Framework.Application Namespace | EntityActions.EntityAction Overload List


Item Property (String)

Aptify 5.0 Software Development Kit (SDK)

EntityActions.Item Property (String)

public EntityAction this[
String Key
] {get; set;}

See Also

EntityActions Class | Aptify.Framework.Application Namespace | EntityActions.EntityAction Overload List


EntityActions Methods

The methods of the EntityActions class are listed below. For a complete list of EntityActions class members, see the EntityActions Members topic.

Public Instance Methods

Add | Overloaded.
Clear (inherited from AptifyCollection) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from AptifyCollection) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from NameObjectCollectionBase) | Implements the ISerializable interface and returns the data needed to serialize the NameObjectCollectionBase instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from AptifyCollection) | Gets the index of the item with the specified Key.
Merge (inherited from AptifyCollection) | Allows a user to merge items from another collection to this collection.
OnDeserialization (inherited from NameObjectCollectionBase) | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete.
Remove (inherited from AptifyCollection) | Overloaded.
RemoveAt (inherited from AptifyCollection) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

BaseAdd (inherited from NameObjectCollectionBase) | Adds an entry with the specified key and value into the NameObjectCollectionBase instance.
BaseClear (inherited from NameObjectCollectionBase) | Removes all entries from the NameObjectCollectionBase instance.
BaseGet (inherited from NameObjectCollectionBase) | Overloaded. Gets the value of the first entry with the specified key from the NameObjectCollectionBase instance.
BaseGetAllKeys (inherited from NameObjectCollectionBase) | Returns a String array that contains all the keys in the NameObjectCollectionBase instance.
BaseGetAllValues (inherited from NameObjectCollectionBase) | Overloaded. Returns an Object array that contains all the values in the NameObjectCollectionBase instance.
BaseGetKey (inherited from NameObjectCollectionBase) | Gets the key of the entry at the specified index of the NameObjectCollectionBase instance.
BaseHasKeys (inherited from NameObjectCollectionBase) | Gets a value indicating whether the NameObjectCollectionBase instance contains entries whose keys are not null.
BaseRemove (inherited from NameObjectCollectionBase) | Removes the entries with the specified key from the NameObjectCollectionBase instance.
BaseRemoveAt (inherited from NameObjectCollectionBase) | Removes the entry at the specified index of the NameObjectCollectionBase instance.
BaseSet (inherited from NameObjectCollectionBase) | Overloaded. Sets the value of the first entry with the specified key in the NameObjectCollectionBase instance, if found; otherwise, adds an entry with the specified key and value into the NameObjectCollectionBase instance.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EntityActions Class | Aptify.Framework.Application Namespace


Add Method

Aptify 5.0 Software Development Kit (SDK)

EntityActions.Add Method

Overload List

public virtual int Add(EntityAction);

public virtual int Add(EntityAction,String);

public override int Add(Object);

public override int Add(Object,String);

See Also

EntityActions Class | Aptify.Framework.Application Namespace


EntityActions.Add Method (EntityAction)

public virtual int Add(
EntityAction Value
);

See Also

EntityActions Class | Aptify.Framework.Application Namespace | EntityActions.Add Overload List


EntityActions.Add Method (EntityAction, String)

public virtual int Add(
EntityAction Value,
String Key
);

See Also

EntityActions Class | Aptify.Framework.Application Namespace | EntityActions.Add Overload List


EntityActions.Add Method (Object)

public override int Add(
Object Value
);

See Also

EntityActions Class | Aptify.Framework.Application Namespace | EntityActions.Add Overload List


EntityActions.Add Method (Object, String)

public override int Add(
Object Value,
String Key
);

See Also

EntityActions Class | Aptify.Framework.Application Namespace | EntityActions.Add Overload List


EntityAttribute Class

An object that represents a single name value pair that can be reused at the entity level.

For a list of all members of this type, see EntityAttribute Members.

System.Object
EntityAttribute

public class EntityAttribute

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Data-only object that returns information regarding the name value pair of entity information.

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyApplication (in AptifyApplication.dll)

See Also

EntityAttribute Members | Aptify.Framework.Application Namespace


EntityAttribute Members

EntityAttribute overview

Public Instance Properties

Description | Description of the attribute.
MustBeInValueList | If true, value must be from provided pick list.
Name | Key name of the attribute.
Value | Value of the attribute.
ValueList | List of items that are available for selection.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EntityAttribute Class | Aptify.Framework.Application Namespace


EntityAttribute Properties

The properties of the EntityAttribute class are listed below. For a complete list of EntityAttribute class members, see the EntityAttribute Members topic.

Public Instance Properties

Description | Description of the attribute.
MustBeInValueList | If true, value must be from provided pick list.
Name | Key name of the attribute.
Value | Value of the attribute.
ValueList | List of items that are available for selection.

See Also

EntityAttribute Class | Aptify.Framework.Application Namespace


Description Property

Aptify 5.0 Software Development Kit (SDK)

EntityAttribute.Description Property

Description of the attribute.

public String Description {get;}

Remarks

See Also

EntityAttribute Class | Aptify.Framework.Application Namespace


MustBeInValueList Property

Aptify 5.0 Software Development Kit (SDK)

EntityAttribute.MustBeInValueList Property

If true, value must be from provided pick list.

public Boolean MustBeInValueList {get;}

Remarks

See Also

EntityAttribute Class | Aptify.Framework.Application Namespace


Name Property

Aptify 5.0 Software Development Kit (SDK)

EntityAttribute.Name Property

Key name of the attribute.

public String Name {get;}

Remarks

See Also

EntityAttribute Class | Aptify.Framework.Application Namespace


Value Property

Aptify 5.0 Software Development Kit (SDK)

EntityAttribute.Value Property

Value of the attribute.

public String Value {get;}

Remarks

See Also

EntityAttribute Class | Aptify.Framework.Application Namespace


ValueList Property

Aptify 5.0 Software Development Kit (SDK)

EntityAttribute.ValueList Property

List of items that are available for selection.

public EntityAttributeValueList ValueList {get;}

Remarks

See Also

EntityAttribute Class | Aptify.Framework.Application Namespace


EntityAttributePossibleValue Structure

For a list of all members of this type, see EntityAttributePossibleValue Members.

System.Object
ValueType
EntityAttributePossibleValue

public struct EntityAttributePossibleValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyApplication (in AptifyApplication.dll)

See Also

EntityAttributePossibleValue Members | Aptify.Framework.Application Namespace


EntityAttributePossibleValue Members

EntityAttributePossibleValue overview

Public Instance Fields

Description
Value

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

EntityAttributePossibleValue Structure | Aptify.Framework.Application Namespace


EntityAttributePossibleValue Fields

The fields of the EntityAttributePossibleValue structure are listed below. For a complete list of EntityAttributePossibleValue structure members, see the EntityAttributePossibleValue Members topic.

Public Instance Fields

Description
Value

See Also

EntityAttributePossibleValue Structure | Aptify.Framework.Application Namespace


EntityAttributePossibleValue.Description Field

public Description Description;

See Also

EntityAttributePossibleValue Class | Aptify.Framework.Application Namespace


EntityAttributePossibleValue.Value Field

public Value Value;

See Also

EntityAttributePossibleValue Class | Aptify.Framework.Application Namespace


EntityAttributes Class

A collection of EntityAttribute objects.

For a list of all members of this type, see EntityAttributes Members.

System.Object
NameObjectCollectionBase
AptifyCollection
EntityAttributes

public class EntityAttributes : AptifyCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

This object allows for a list that can be added to and removed from entity attribute objects that belong at the entity level.

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyApplication (in AptifyApplication.dll)

See Also

EntityAttributes Members | Aptify.Framework.Application Namespace


EntityAttributes Members

EntityAttributes overview

Public Instance Properties

Count (inherited from NameObjectCollectionBase) | Gets the number of key/value pairs contained in the NameObjectCollectionBase instance.
Item | Overloaded.
Keys (inherited from NameObjectCollectionBase) | Gets a KeysCollection instance that contains all the keys in the NameObjectCollectionBase instance.

Public Instance Methods

Add | Overloaded.
Clear (inherited from AptifyCollection) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from AptifyCollection) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from NameObjectCollectionBase) | Implements the ISerializable interface and returns the data needed to serialize the NameObjectCollectionBase instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from AptifyCollection) | Gets the index of the item with the specified Key.
Merge (inherited from AptifyCollection) | Allows a user to merge items from another collection to this collection.
OnDeserialization (inherited from NameObjectCollectionBase) | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete.
Remove (inherited from AptifyCollection) | Overloaded.
RemoveAt (inherited from AptifyCollection) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

IsReadOnly (inherited from NameObjectCollectionBase) Gets or sets a value indicating whether the NameObjectCollectionBase instance is read-only.

Protected Instance Methods

BaseAdd (inherited from NameObjectCollectionBase) | Adds an entry with the specified key and value into the NameObjectCollectionBase instance.
BaseClear (inherited from NameObjectCollectionBase) | Removes all entries from the NameObjectCollectionBase instance.
BaseGet (inherited from NameObjectCollectionBase) | Overloaded. Gets the value of the first entry with the specified key from the NameObjectCollectionBase instance.
BaseGetAllKeys (inherited from NameObjectCollectionBase) | Returns a String array that contains all the keys in the NameObjectCollectionBase instance.
BaseGetAllValues (inherited from NameObjectCollectionBase) | Overloaded. Returns an Object array that contains all the values in the NameObjectCollectionBase instance.
BaseGetKey (inherited from NameObjectCollectionBase) | Gets the key of the entry at the specified index of the NameObjectCollectionBase instance.
BaseHasKeys (inherited from NameObjectCollectionBase) | Gets a value indicating whether the NameObjectCollectionBase instance contains entries whose keys are not null.
BaseRemove (inherited from NameObjectCollectionBase) | Removes the entries with the specified key from the NameObjectCollectionBase instance.
BaseRemoveAt (inherited from NameObjectCollectionBase) | Removes the entry at the specified index of the NameObjectCollectionBase instance.
BaseSet (inherited from NameObjectCollectionBase) | Overloaded. Sets the value of the first entry with the specified key in the NameObjectCollectionBase instance, if found; otherwise, adds an entry with the specified key and value into the NameObjectCollectionBase instance.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EntityAttributes Class | Aptify.Framework.Application Namespace


EntityAttributes Properties

The properties of the EntityAttributes class are listed below. For a complete list of EntityAttributes class members, see the EntityAttributes Members topic.

Public Instance Properties

Count (inherited from NameObjectCollectionBase) | Gets the number of key/value pairs contained in the NameObjectCollectionBase instance.
Item | Overloaded.
Keys (inherited from NameObjectCollectionBase) | Gets a KeysCollection instance that contains all the keys in the NameObjectCollectionBase instance.

Protected Instance Properties

IsReadOnly (inherited from NameObjectCollectionBase) Gets or sets a value indicating whether the NameObjectCollectionBase instance is read-only.

See Also

EntityAttributes Class | Aptify.Framework.Application Namespace


EntityAttribute Property

Aptify 5.0 Software Development Kit (SDK)

EntityAttributes.EntityAttribute Property

Overload List

public EntityAttribute this[Int32] {get; set;}

public EntityAttribute this[String] {get; set;}

See Also

EntityAttributes Class | Aptify.Framework.Application Namespace


Item Property (Int32)

Aptify 5.0 Software Development Kit (SDK)

EntityAttributes.Item Property (Int32)

public EntityAttribute this[
Int32 Index
] {get; set;}

See Also

EntityAttributes Class | Aptify.Framework.Application Namespace | EntityAttributes.EntityAttribute Overload List


Item Property (String)

Aptify 5.0 Software Development Kit (SDK)

EntityAttributes.Item Property (String)

public EntityAttribute this[
String Key
] {get; set;}

See Also

EntityAttributes Class | Aptify.Framework.Application Namespace | EntityAttributes.EntityAttribute Overload List


EntityAttributes Methods

The methods of the EntityAttributes class are listed below. For a complete list of EntityAttributes class members, see the EntityAttributes Members topic.

Public Instance Methods

Add | Overloaded.
Clear (inherited from AptifyCollection) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from AptifyCollection) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from NameObjectCollectionBase) | Implements the ISerializable interface and returns the data needed to serialize the NameObjectCollectionBase instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from AptifyCollection) | Gets the index of the item with the specified Key.
Merge (inherited from AptifyCollection) | Allows a user to merge items from another collection to this collection.
OnDeserialization (inherited from NameObjectCollectionBase) | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete.
Remove (inherited from AptifyCollection) | Overloaded.
RemoveAt (inherited from AptifyCollection) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

BaseAdd (inherited from NameObjectCollectionBase) | Adds an entry with the specified key and value into the NameObjectCollectionBase instance.
BaseClear (inherited from NameObjectCollectionBase) | Removes all entries from the NameObjectCollectionBase instance.
BaseGet (inherited from NameObjectCollectionBase) | Overloaded. Gets the value of the first entry with the specified key from the NameObjectCollectionBase instance.
BaseGetAllKeys (inherited from NameObjectCollectionBase) | Returns a String array that contains all the keys in the NameObjectCollectionBase instance.
BaseGetAllValues (inherited from NameObjectCollectionBase) | Overloaded. Returns an Object array that contains all the values in the NameObjectCollectionBase instance.
BaseGetKey (inherited from NameObjectCollectionBase) | Gets the key of the entry at the specified index of the NameObjectCollectionBase instance.
BaseHasKeys (inherited from NameObjectCollectionBase) | Gets a value indicating whether the NameObjectCollectionBase instance contains entries whose keys are not null.
BaseRemove (inherited from NameObjectCollectionBase) | Removes the entries with the specified key from the NameObjectCollectionBase instance.
BaseRemoveAt (inherited from NameObjectCollectionBase) | Removes the entry at the specified index of the NameObjectCollectionBase instance.
BaseSet (inherited from NameObjectCollectionBase) | Overloaded. Sets the value of the first entry with the specified key in the NameObjectCollectionBase instance, if found; otherwise, adds an entry with the specified key and value into the NameObjectCollectionBase instance.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EntityAttributes Class | Aptify.Framework.Application Namespace


Add Method

Aptify 5.0 Software Development Kit (SDK)

EntityAttributes.Add Method

Overload List

public virtual int Add(EntityAttribute);

public virtual int Add(EntityAttribute,String);

public override int Add(Object);

public override int Add(Object,String);

See Also

EntityAttributes Class | Aptify.Framework.Application Namespace


EntityAttributes.Add Method (EntityAttribute)

public virtual int Add(
EntityAttribute Value
);

See Also

EntityAttributes Class | Aptify.Framework.Application Namespace | EntityAttributes.Add Overload List


EntityAttributes.Add Method (EntityAttribute, String)

public virtual int Add(
EntityAttribute Value,
String Key
);

See Also

EntityAttributes Class | Aptify.Framework.Application Namespace | EntityAttributes.Add Overload List


EntityAttributes.Add Method (Object)

public override int Add(
Object Value
);

See Also

EntityAttributes Class | Aptify.Framework.Application Namespace | EntityAttributes.Add Overload List


EntityAttributes.Add Method (Object, String)

public override int Add(
Object Value,
String Key
);

See Also

EntityAttributes Class | Aptify.Framework.Application Namespace | EntityAttributes.Add Overload List


EntityAttributeValueList Class

A collection of pre-set name value pairs that can be used to control which values are possible for an entity attribute.

For a list of all members of this type, see EntityAttributeValueList Members.

System.Object
NameObjectCollectionBase
AptifyCollection
EntityAttributeValueList

public class EntityAttributeValueList : AptifyCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

This is used to control which items are included in the list or provides a pre-set list of available values for an entity attribute.

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyApplication (in AptifyApplication.dll)

See Also

EntityAttributeValueList Members | Aptify.Framework.Application Namespace


EntityAttributeValueList Members

EntityAttributeValueList overview

Public Instance Constructors

EntityAttributeValueList Constructor Initializes a new instance of the EntityAttributeValueList class.

Public Instance Properties

Count (inherited from NameObjectCollectionBase) | Gets the number of key/value pairs contained in the NameObjectCollectionBase instance.
Item | Overloaded.
Keys (inherited from NameObjectCollectionBase) | Gets a KeysCollection instance that contains all the keys in the NameObjectCollectionBase instance.

Public Instance Methods

Add | Overloaded.
Clear (inherited from AptifyCollection) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from AptifyCollection) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from NameObjectCollectionBase) | Implements the ISerializable interface and returns the data needed to serialize the NameObjectCollectionBase instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from AptifyCollection) | Gets the index of the item with the specified Key.
Merge (inherited from AptifyCollection) | Allows a user to merge items from another collection to this collection.
OnDeserialization (inherited from NameObjectCollectionBase) | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete.
Remove (inherited from AptifyCollection) | Overloaded.
RemoveAt (inherited from AptifyCollection) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

IsReadOnly (inherited from NameObjectCollectionBase) Gets or sets a value indicating whether the NameObjectCollectionBase instance is read-only.

Protected Instance Methods

BaseAdd (inherited from NameObjectCollectionBase) | Adds an entry with the specified key and value into the NameObjectCollectionBase instance.
BaseClear (inherited from NameObjectCollectionBase) | Removes all entries from the NameObjectCollectionBase instance.
BaseGet (inherited from NameObjectCollectionBase) | Overloaded. Gets the value of the first entry with the specified key from the NameObjectCollectionBase instance.
BaseGetAllKeys (inherited from NameObjectCollectionBase) | Returns a String array that contains all the keys in the NameObjectCollectionBase instance.
BaseGetAllValues (inherited from NameObjectCollectionBase) | Overloaded. Returns an Object array that contains all the values in the NameObjectCollectionBase instance.
BaseGetKey (inherited from NameObjectCollectionBase) | Gets the key of the entry at the specified index of the NameObjectCollectionBase instance.
BaseHasKeys (inherited from NameObjectCollectionBase) | Gets a value indicating whether the NameObjectCollectionBase instance contains entries whose keys are not null.
BaseRemove (inherited from NameObjectCollectionBase) | Removes the entries with the specified key from the NameObjectCollectionBase instance.
BaseRemoveAt (inherited from NameObjectCollectionBase) | Removes the entry at the specified index of the NameObjectCollectionBase instance.
BaseSet (inherited from NameObjectCollectionBase) | Overloaded. Sets the value of the first entry with the specified key in the NameObjectCollectionBase instance, if found; otherwise, adds an entry with the specified key and value into the NameObjectCollectionBase instance.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EntityAttributeValueList Class | Aptify.Framework.Application Namespace


EntityAttributeValueList Constructor

Initializes a new instance of the EntityAttributeValueList class.

public EntityAttributeValueList();

See Also

EntityAttributeValueList Class | Aptify.Framework.Application Namespace


EntityAttributeValueList Properties

The properties of the EntityAttributeValueList class are listed below. For a complete list of EntityAttributeValueList class members, see the EntityAttributeValueList Members topic.

Public Instance Properties

Count (inherited from NameObjectCollectionBase) | Gets the number of key/value pairs contained in the NameObjectCollectionBase instance.
Item | Overloaded.
Keys (inherited from NameObjectCollectionBase) | Gets a KeysCollection instance that contains all the keys in the NameObjectCollectionBase instance.

Protected Instance Properties

IsReadOnly (inherited from NameObjectCollectionBase) Gets or sets a value indicating whether the NameObjectCollectionBase instance is read-only.

See Also

EntityAttributeValueList Class | Aptify.Framework.Application Namespace


Item Property

Aptify 5.0 Software Development Kit (SDK)

EntityAttributeValueList.Item Property

public EntityAttributePossibleValue this[
Int32 Index
] {get; set;}

See Also

EntityAttributeValueList Class | Aptify.Framework.Application Namespace


EntityAttributeValueList Methods

The methods of the EntityAttributeValueList class are listed below. For a complete list of EntityAttributeValueList class members, see the EntityAttributeValueList Members topic.

Public Instance Methods

Add | Overloaded.
Clear (inherited from AptifyCollection) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from AptifyCollection) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from NameObjectCollectionBase) | Implements the ISerializable interface and returns the data needed to serialize the NameObjectCollectionBase instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from AptifyCollection) | Gets the index of the item with the specified Key.
Merge (inherited from AptifyCollection) | Allows a user to merge items from another collection to this collection.
OnDeserialization (inherited from NameObjectCollectionBase) | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete.
Remove (inherited from AptifyCollection) | Overloaded.
RemoveAt (inherited from AptifyCollection) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

BaseAdd (inherited from NameObjectCollectionBase) | Adds an entry with the specified key and value into the NameObjectCollectionBase instance.
BaseClear (inherited from NameObjectCollectionBase) | Removes all entries from the NameObjectCollectionBase instance.
BaseGet (inherited from NameObjectCollectionBase) | Overloaded. Gets the value of the first entry with the specified key from the NameObjectCollectionBase instance.
BaseGetAllKeys (inherited from NameObjectCollectionBase) | Returns a String array that contains all the keys in the NameObjectCollectionBase instance.
BaseGetAllValues (inherited from NameObjectCollectionBase) | Overloaded. Returns an Object array that contains all the values in the NameObjectCollectionBase instance.
BaseGetKey (inherited from NameObjectCollectionBase) | Gets the key of the entry at the specified index of the NameObjectCollectionBase instance.
BaseHasKeys (inherited from NameObjectCollectionBase) | Gets a value indicating whether the NameObjectCollectionBase instance contains entries whose keys are not null.
BaseRemove (inherited from NameObjectCollectionBase) | Removes the entries with the specified key from the NameObjectCollectionBase instance.
BaseRemoveAt (inherited from NameObjectCollectionBase) | Removes the entry at the specified index of the NameObjectCollectionBase instance.
BaseSet (inherited from NameObjectCollectionBase) | Overloaded. Sets the value of the first entry with the specified key in the NameObjectCollectionBase instance, if found; otherwise, adds an entry with the specified key and value into the NameObjectCollectionBase instance.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EntityAttributeValueList Class | Aptify.Framework.Application Namespace


Add Method

Aptify 5.0 Software Development Kit (SDK)

EntityAttributeValueList.Add Method

Overload List

public int Add(EntityAttributePossibleValue);

public int Add(EntityAttributePossibleValue,String);

public override int Add(Object);

public override int Add(Object,String);

See Also

EntityAttributeValueList Class | Aptify.Framework.Application Namespace


EntityAttributeValueList.Add Method (EntityAttributePossibleValue)

public int Add(
EntityAttributePossibleValue Value
);

See Also

EntityAttributeValueList Class | Aptify.Framework.Application Namespace | EntityAttributeValueList.Add Overload List


EntityAttributeValueList.Add Method (EntityAttributePossibleValue, String)

public int Add(
EntityAttributePossibleValue Value,
String Key
);

See Also

EntityAttributeValueList Class | Aptify.Framework.Application Namespace | EntityAttributeValueList.Add Overload List


EntityAttributeValueList.Add Method (Object)

public override int Add(
Object Value
);

See Also

EntityAttributeValueList Class | Aptify.Framework.Application Namespace | EntityAttributeValueList.Add Overload List


EntityAttributeValueList.Add Method (Object, String)

public override int Add(
Object Value,
String Key
);

See Also

EntityAttributeValueList Class | Aptify.Framework.Application Namespace | EntityAttributeValueList.Add Overload List


EntityConstraint Class

This class is used to hold all of the entity constraints associated with an entity.

For a list of all members of this type, see EntityConstraint Members.

System.Object
EntityConstraint

public class EntityConstraint

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyApplication (in AptifyApplication.dll)

See Also

EntityConstraint Members | Aptify.Framework.Application Namespace


EntityConstraint Members

EntityConstraint overview

Public Instance Constructors

EntityConstraint Constructor Initializes a new instance of the EntityConstraint class.

Public Instance Fields

ConstraintText | The ConstraintText associated with an entity constraint.
FailureMessage | The failure text associated with an entity constraint.
Name | The name of an entity constraint.
NameInDatabase | The name of entity constraint as it exists in the database.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EntityConstraint Class | Aptify.Framework.Application Namespace


EntityConstraint Constructor

Initializes a new instance of the EntityConstraint class.

public EntityConstraint();

See Also

EntityConstraint Class | Aptify.Framework.Application Namespace


EntityConstraint Fields

The fields of the EntityConstraint class are listed below. For a complete list of EntityConstraint class members, see the EntityConstraint Members topic.

Public Instance Fields

ConstraintText | The ConstraintText associated with an entity constraint.
FailureMessage | The failure text associated with an entity constraint.
Name | The name of an entity constraint.
NameInDatabase | The name of entity constraint as it exists in the database.

See Also

EntityConstraint Class | Aptify.Framework.Application Namespace


EntityConstraint.ConstraintText Field

The ConstraintText associated with an entity constraint.

public ConstraintText ConstraintText;

Remarks

See Also

EntityConstraint Class | Aptify.Framework.Application Namespace


EntityConstraint.FailureMessage Field

The failure text associated with an entity constraint.

public FailureMessage FailureMessage;

Remarks

See Also

EntityConstraint Class | Aptify.Framework.Application Namespace


EntityConstraint.Name Field

The name of an entity constraint.

public Name Name;

Remarks

See Also

EntityConstraint Class | Aptify.Framework.Application Namespace


EntityConstraint.NameInDatabase Field

The name of entity constraint as it exists in the database.

public NameInDatabase NameInDatabase;

Remarks

See Also

EntityConstraint Class | Aptify.Framework.Application Namespace


EntityDependencies Class

This is a collection of entity dependent objects. For the most part, it is a basic implementation of a collection.

For a list of all members of this type, see EntityDependencies Members.

System.Object
NameObjectCollectionBase
AptifyCollection
EntityDependenciesBase
EntityDependencies

public class EntityDependencies : EntityDependenciesBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyApplication (in AptifyApplication.dll)

See Also

EntityDependencies Members | Aptify.Framework.Application Namespace


EntityDependencies Members

EntityDependencies overview

Public Instance Properties

Count (inherited from NameObjectCollectionBase) | Gets the number of key/value pairs contained in the NameObjectCollectionBase instance.
Entity |
ExistenceCheck |
ForeignKeysExcluded |
Item (inherited from EntityDependenciesBase) |
Item (inherited from EntityDependenciesBase) |
Keys (inherited from NameObjectCollectionBase) | Gets a KeysCollection instance that contains all the keys in the NameObjectCollectionBase instance.
RecordID |

Public Instance Methods

Add (inherited from EntityDependenciesBase) | Overloaded.
Clear (inherited from AptifyCollection) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from AptifyCollection) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from NameObjectCollectionBase) | Implements the ISerializable interface and returns the data needed to serialize the NameObjectCollectionBase instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from AptifyCollection) | Gets the index of the item with the specified Key.
Merge (inherited from AptifyCollection) | Allows a user to merge items from another collection to this collection.
OnDeserialization (inherited from NameObjectCollectionBase) | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete.
Remove (inherited from AptifyCollection) | Overloaded.
RemoveAt (inherited from AptifyCollection) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

IsReadOnly (inherited from NameObjectCollectionBase) Gets or sets a value indicating whether the NameObjectCollectionBase instance is read-only.

Protected Instance Methods

BaseAdd (inherited from NameObjectCollectionBase) | Adds an entry with the specified key and value into the NameObjectCollectionBase instance.
BaseClear (inherited from NameObjectCollectionBase) | Removes all entries from the NameObjectCollectionBase instance.
BaseGet (inherited from NameObjectCollectionBase) | Overloaded. Gets the value of the first entry with the specified key from the NameObjectCollectionBase instance.
BaseGetAllKeys (inherited from NameObjectCollectionBase) | Returns a String array that contains all the keys in the NameObjectCollectionBase instance.
BaseGetAllValues (inherited from NameObjectCollectionBase) | Overloaded. Returns an Object array that contains all the values in the NameObjectCollectionBase instance.
BaseGetKey (inherited from NameObjectCollectionBase) | Gets the key of the entry at the specified index of the NameObjectCollectionBase instance.
BaseHasKeys (inherited from NameObjectCollectionBase) | Gets a value indicating whether the NameObjectCollectionBase instance contains entries whose keys are not null.
BaseRemove (inherited from NameObjectCollectionBase) | Removes the entries with the specified key from the NameObjectCollectionBase instance.
BaseRemoveAt (inherited from NameObjectCollectionBase) | Removes the entry at the specified index of the NameObjectCollectionBase instance.
BaseSet (inherited from NameObjectCollectionBase) | Overloaded. Sets the value of the first entry with the specified key in the NameObjectCollectionBase instance, if found; otherwise, adds an entry with the specified key and value into the NameObjectCollectionBase instance.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EntityDependencies Class | Aptify.Framework.Application Namespace


EntityDependencies Properties

The properties of the EntityDependencies class are listed below. For a complete list of EntityDependencies class members, see the EntityDependencies Members topic.

Public Instance Properties

Count (inherited from NameObjectCollectionBase) | Gets the number of key/value pairs contained in the NameObjectCollectionBase instance.
Entity |
ExistenceCheck |
ForeignKeysExcluded |
Item (inherited from EntityDependenciesBase) |
Item (inherited from EntityDependenciesBase) |
Keys (inherited from NameObjectCollectionBase) | Gets a KeysCollection instance that contains all the keys in the NameObjectCollectionBase instance.
RecordID |

Protected Instance Properties

IsReadOnly (inherited from NameObjectCollectionBase) Gets or sets a value indicating whether the NameObjectCollectionBase instance is read-only.

See Also

EntityDependencies Class | Aptify.Framework.Application Namespace


Entity Property

Aptify 5.0 Software Development Kit (SDK)

EntityDependencies.Entity Property

public override String Entity {get;}

See Also

EntityDependencies Class | Aptify.Framework.Application Namespace


ExistenceCheck Property

Aptify 5.0 Software Development Kit (SDK)

EntityDependencies.ExistenceCheck Property

public override Boolean ExistenceCheck {get;}

See Also

EntityDependencies Class | Aptify.Framework.Application Namespace


ForeignKeysExcluded Property

Aptify 5.0 Software Development Kit (SDK)

EntityDependencies.ForeignKeysExcluded Property

public override Boolean ForeignKeysExcluded {get;}

See Also

EntityDependencies Class | Aptify.Framework.Application Namespace


RecordID Property

Aptify 5.0 Software Development Kit (SDK)

EntityDependencies.RecordID Property

public override Int64 RecordID {get;}

See Also

EntityDependencies Class | Aptify.Framework.Application Namespace


EntityFieldPermission Structure

For a list of all members of this type, see EntityFieldPermission Members.

System.Object
ValueType
EntityFieldPermission

public struct EntityFieldPermission

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyApplication (in AptifyApplication.dll)

See Also

EntityFieldPermission Members | Aptify.Framework.Application Namespace


EntityFieldPermission Members

EntityFieldPermission overview

Public Instance Fields

Edit
Field
InPlaceEdit
Read

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

EntityFieldPermission Structure | Aptify.Framework.Application Namespace


EntityFieldPermission Fields

The fields of the EntityFieldPermission structure are listed below. For a complete list of EntityFieldPermission structure members, see the EntityFieldPermission Members topic.

Public Instance Fields

Edit
Field
InPlaceEdit
Read

See Also

EntityFieldPermission Structure | Aptify.Framework.Application Namespace


EntityFieldPermission.Edit Field

public Edit Edit;

See Also

EntityFieldPermission Class | Aptify.Framework.Application Namespace


EntityFieldPermission.Field Field

public Field Field;

See Also

EntityFieldPermission Class | Aptify.Framework.Application Namespace


EntityFieldPermission.InPlaceEdit Field

public InPlaceEdit InPlaceEdit;

See Also

EntityFieldPermission Class | Aptify.Framework.Application Namespace


EntityFieldPermission.Read Field

public Read Read;

See Also

EntityFieldPermission Class | Aptify.Framework.Application Namespace


EntityFieldPermissions Class

Provides a collection that allows for individuals to get permissions for a given entity field. This is a list of entity field permissions. This object is not created directly. Its data can be retrieved off of the AptifyDataField object.

For a list of all members of this type, see EntityFieldPermissions Members.

System.Object
NameObjectCollectionBase
AptifyCollection
EntityFieldPermissions

public class EntityFieldPermissions : AptifyCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyApplication (in AptifyApplication.dll)

See Also

EntityFieldPermissions Members | Aptify.Framework.Application Namespace


EntityFieldPermissions Members

EntityFieldPermissions overview

Public Instance Properties

AptifyUserID |
Count (inherited from NameObjectCollectionBase) | Gets the number of key/value pairs contained in the NameObjectCollectionBase instance.
EntityID |
Item | Overloaded.
Keys (inherited from NameObjectCollectionBase) | Gets a KeysCollection instance that contains all the keys in the NameObjectCollectionBase instance.

Public Instance Methods

Add | Overloaded.
Clear (inherited from AptifyCollection) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from AptifyCollection) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from NameObjectCollectionBase) | Implements the ISerializable interface and returns the data needed to serialize the NameObjectCollectionBase instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from AptifyCollection) | Gets the index of the item with the specified Key.
Merge (inherited from AptifyCollection) | Allows a user to merge items from another collection to this collection.
OnDeserialization (inherited from NameObjectCollectionBase) | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete.
Remove (inherited from AptifyCollection) | Overloaded.
RemoveAt (inherited from AptifyCollection) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

IsReadOnly (inherited from NameObjectCollectionBase) Gets or sets a value indicating whether the NameObjectCollectionBase instance is read-only.

Protected Instance Methods

BaseAdd (inherited from NameObjectCollectionBase) | Adds an entry with the specified key and value into the NameObjectCollectionBase instance.
BaseClear (inherited from NameObjectCollectionBase) | Removes all entries from the NameObjectCollectionBase instance.
BaseGet (inherited from NameObjectCollectionBase) | Overloaded. Gets the value of the first entry with the specified key from the NameObjectCollectionBase instance.
BaseGetAllKeys (inherited from NameObjectCollectionBase) | Returns a String array that contains all the keys in the NameObjectCollectionBase instance.
BaseGetAllValues (inherited from NameObjectCollectionBase) | Overloaded. Returns an Object array that contains all the values in the NameObjectCollectionBase instance.
BaseGetKey (inherited from NameObjectCollectionBase) | Gets the key of the entry at the specified index of the NameObjectCollectionBase instance.
BaseHasKeys (inherited from NameObjectCollectionBase) | Gets a value indicating whether the NameObjectCollectionBase instance contains entries whose keys are not null.
BaseRemove (inherited from NameObjectCollectionBase) | Removes the entries with the specified key from the NameObjectCollectionBase instance.
BaseRemoveAt (inherited from NameObjectCollectionBase) | Removes the entry at the specified index of the NameObjectCollectionBase instance.
BaseSet (inherited from NameObjectCollectionBase) | Overloaded. Sets the value of the first entry with the specified key in the NameObjectCollectionBase instance, if found; otherwise, adds an entry with the specified key and value into the NameObjectCollectionBase instance.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EntityFieldPermissions Class | Aptify.Framework.Application Namespace


EntityFieldPermissions Properties

The properties of the EntityFieldPermissions class are listed below. For a complete list of EntityFieldPermissions class members, see the EntityFieldPermissions Members topic.

Public Instance Properties

AptifyUserID |
Count (inherited from NameObjectCollectionBase) | Gets the number of key/value pairs contained in the NameObjectCollectionBase instance.
EntityID |
Item | Overloaded.
Keys (inherited from NameObjectCollectionBase) | Gets a KeysCollection instance that contains all the keys in the NameObjectCollectionBase instance.

Protected Instance Properties

IsReadOnly (inherited from NameObjectCollectionBase) Gets or sets a value indicating whether the NameObjectCollectionBase instance is read-only.

See Also

EntityFieldPermissions Class | Aptify.Framework.Application Namespace


AptifyUserID Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldPermissions.AptifyUserID Property

public Int64 AptifyUserID {get;}

See Also

EntityFieldPermissions Class | Aptify.Framework.Application Namespace


EntityID Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldPermissions.EntityID Property

public Int64 EntityID {get;}

See Also

EntityFieldPermissions Class | Aptify.Framework.Application Namespace


EntityFieldPermission Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldPermissions.EntityFieldPermission Property

Overload List

public EntityFieldPermission this[Int32] {get; set;}

public EntityFieldPermission this[String] {get; set;}

See Also

EntityFieldPermissions Class | Aptify.Framework.Application Namespace


Item Property (Int32)

Aptify 5.0 Software Development Kit (SDK)

EntityFieldPermissions.Item Property (Int32)

public EntityFieldPermission this[
Int32 Index
] {get; set;}

See Also

EntityFieldPermissions Class | Aptify.Framework.Application Namespace | EntityFieldPermissions.EntityFieldPermission Overload List


Item Property (String)

Aptify 5.0 Software Development Kit (SDK)

EntityFieldPermissions.Item Property (String)

public EntityFieldPermission this[
String Key
] {get; set;}

See Also

EntityFieldPermissions Class | Aptify.Framework.Application Namespace | EntityFieldPermissions.EntityFieldPermission Overload List


EntityFieldPermissions Methods

The methods of the EntityFieldPermissions class are listed below. For a complete list of EntityFieldPermissions class members, see the EntityFieldPermissions Members topic.

Public Instance Methods

Add | Overloaded.
Clear (inherited from AptifyCollection) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from AptifyCollection) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from NameObjectCollectionBase) | Implements the ISerializable interface and returns the data needed to serialize the NameObjectCollectionBase instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from AptifyCollection) | Gets the index of the item with the specified Key.
Merge (inherited from AptifyCollection) | Allows a user to merge items from another collection to this collection.
OnDeserialization (inherited from NameObjectCollectionBase) | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete.
Remove (inherited from AptifyCollection) | Overloaded.
RemoveAt (inherited from AptifyCollection) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

BaseAdd (inherited from NameObjectCollectionBase) | Adds an entry with the specified key and value into the NameObjectCollectionBase instance.
BaseClear (inherited from NameObjectCollectionBase) | Removes all entries from the NameObjectCollectionBase instance.
BaseGet (inherited from NameObjectCollectionBase) | Overloaded. Gets the value of the first entry with the specified key from the NameObjectCollectionBase instance.
BaseGetAllKeys (inherited from NameObjectCollectionBase) | Returns a String array that contains all the keys in the NameObjectCollectionBase instance.
BaseGetAllValues (inherited from NameObjectCollectionBase) | Overloaded. Returns an Object array that contains all the values in the NameObjectCollectionBase instance.
BaseGetKey (inherited from NameObjectCollectionBase) | Gets the key of the entry at the specified index of the NameObjectCollectionBase instance.
BaseHasKeys (inherited from NameObjectCollectionBase) | Gets a value indicating whether the NameObjectCollectionBase instance contains entries whose keys are not null.
BaseRemove (inherited from NameObjectCollectionBase) | Removes the entries with the specified key from the NameObjectCollectionBase instance.
BaseRemoveAt (inherited from NameObjectCollectionBase) | Removes the entry at the specified index of the NameObjectCollectionBase instance.
BaseSet (inherited from NameObjectCollectionBase) | Overloaded. Sets the value of the first entry with the specified key in the NameObjectCollectionBase instance, if found; otherwise, adds an entry with the specified key and value into the NameObjectCollectionBase instance.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EntityFieldPermissions Class | Aptify.Framework.Application Namespace


Add Method

Aptify 5.0 Software Development Kit (SDK)

EntityFieldPermissions.Add Method

Overload List

public int Add(EntityFieldPermission);

public int Add(EntityFieldPermission,String);

public override int Add(Object);

public override int Add(Object,String);

See Also

EntityFieldPermissions Class | Aptify.Framework.Application Namespace


EntityFieldPermissions.Add Method (EntityFieldPermission)

public int Add(
EntityFieldPermission Value
);

See Also

EntityFieldPermissions Class | Aptify.Framework.Application Namespace | EntityFieldPermissions.Add Overload List


EntityFieldPermissions.Add Method (EntityFieldPermission, String)

public int Add(
EntityFieldPermission Value,
String Key
);

See Also

EntityFieldPermissions Class | Aptify.Framework.Application Namespace | EntityFieldPermissions.Add Overload List


EntityFieldPermissions.Add Method (Object)

public override int Add(
Object Value
);

See Also

EntityFieldPermissions Class | Aptify.Framework.Application Namespace | EntityFieldPermissions.Add Overload List


EntityFieldPermissions.Add Method (Object, String)

public override int Add(
Object Value,
String Key
);

See Also

EntityFieldPermissions Class | Aptify.Framework.Application Namespace | EntityFieldPermissions.Add Overload List


EntityInfo Class

Provides the base object that brings together an application object, user credentials, entity level and field level data, plug ins, and actions.

For a list of all members of this type, see EntityInfo Members.

System.Object
EntityInfo

public class EntityInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyApplication (in AptifyApplication.dll)

See Also

EntityInfo Members | Aptify.Framework.Application Namespace


EntityInfo Members

EntityInfo overview

Public Instance Properties

Application | Application object that allows you to retrieve additional information about an entity or to return an entity object itself.
BaseDatabase | The base database that has the entity base view.
BaseTable | The base table for the entity.
BaseView | The base view that has all of the entity information.
DisplayName | The user friendly name of the entity.
DisplayNameWCulture | Overloaded.
EntityAttributes | Returns a list of entity attributes.
EntityID | Primary key of the entity.
EntityMetaData | Returns the collection of entity and field meta data information.
EntityName | Unique entity text string name.
EntityPlugIns | Returns a list of entity plug ins.
GetSPDeleteRelated |
Icon | Returns the entity's icon object repository location in PackageName.ObjectName format
IsSubType | If True, the entity is a SubType; if False, entity is a top-level entity.
NameField |
spAddToList | Stored procedure to add an item to a list in an entity.
spCreate | Stored procedure to create an entity record.
spDeleteRelated |
spDeleteSingle | Stored procedure to deletes an entity record.
spGetDependants | Stored procedure to list dependent records.
spGetRelated | Overloaded.
spGetSingle | Stored procedure to return a single record.
spRelinkDependencies | Stored procedure to reconnect entity records back together.
spUpdate | Stored procedure to update an entity record.
StoredProcedures | An object that has all of the Create, Read, Update, Delete and Fetch stored procedures for a given entity. This can be retrieved through base properties as well.

Public Instance Methods

DeleteEntityRecord | Delete a single entity record.
DeleteEntityRecords | Overloaded. Delete multiple entity records.
DisplayEntityFindDialog | Overloaded.
DisplayEntityProperties | Overloaded.
DisplayEntityRecord | Overloaded.
DisplayEntityRecordDialog | Overloaded.
DisplayNewEntityRecord | Overloaded.
DisplayNewViewDialog | Overloaded. Opens a new view dialog form in dialog mode.
DisplaySubTypeEntityRecordDialog | Overloaded.
EntityActions | Returns a collection of actions that can be taken against a given entity.
EntityRecordExists | This method does checks to see if the specified record ID exists in the entity defined by the EntityName parameter. If it does the method returns True, otherwise it returns False.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAttachmentPermissions | Returns an Entity Attachment Permissions object that describes the current user's permissions for this entity. If the Category ID is provided, then the permissions will consider the Category Attachment permissions.
GetAvailableViewFields | A list of fields from the View's Base View
GetDefaultViewFields | Overloaded. A list of entity fields that appear in an entity's view by default. Uses the Entity's BaseView
GetEntityConstraints | This returns a Case Insensitive Hashtable that contains information about active entity constraints.
GetEntityDependencies | Overloaded.
GetEntityFieldDisplayName | Returns the display name of the field.
GetEntityObject | Returns a Generic Entity object based upon the Record ID.
GetEntityPlugIn | Overloaded. Retrieve an entity plug in based upon its type.
GetEntityRecordName | Returns a record name for a given entity record.
GetFieldPermissions | Returns an object that reports the permissions that the user has for an entity's fields.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPermissions | Returns an EntityPermissions object that describes the current user's permissions for this entity.
GetRecordIDFromRecordName |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EntityInfo Class | Aptify.Framework.Application Namespace


EntityInfo Properties

The properties of the EntityInfo class are listed below. For a complete list of EntityInfo class members, see the EntityInfo Members topic.

Public Instance Properties

Application | Application object that allows you to retrieve additional information about an entity or to return an entity object itself.
BaseDatabase | The base database that has the entity base view.
BaseTable | The base table for the entity.
BaseView | The base view that has all of the entity information.
DisplayName | The user friendly name of the entity.
DisplayNameWCulture | Overloaded.
EntityAttributes | Returns a list of entity attributes.
EntityID | Primary key of the entity.
EntityMetaData | Returns the collection of entity and field meta data information.
EntityName | Unique entity text string name.
EntityPlugIns | Returns a list of entity plug ins.
GetSPDeleteRelated |
Icon | Returns the entity's icon object repository location in PackageName.ObjectName format
IsSubType | If True, the entity is a SubType; if False, entity is a top-level entity.
NameField |
spAddToList | Stored procedure to add an item to a list in an entity.
spCreate | Stored procedure to create an entity record.
spDeleteRelated |
spDeleteSingle | Stored procedure to deletes an entity record.
spGetDependants | Stored procedure to list dependent records.
spGetRelated | Overloaded.
spGetSingle | Stored procedure to return a single record.
spRelinkDependencies | Stored procedure to reconnect entity records back together.
spUpdate | Stored procedure to update an entity record.
StoredProcedures | An object that has all of the Create, Read, Update, Delete and Fetch stored procedures for a given entity. This can be retrieved through base properties as well.

See Also

EntityInfo Class | Aptify.Framework.Application Namespace


Application Property

Aptify 5.0 Software Development Kit (SDK)

EntityInfo.Application Property

Application object that allows you to retrieve additional information about an entity or to return an entity object itself.

public AptifyApplication Application {get;}

Remarks

See Also

EntityInfo Class | Aptify.Framework.Application Namespace


BaseDatabase Property

Aptify 5.0 Software Development Kit (SDK)

EntityInfo.BaseDatabase Property

The base database that has the entity base view.

public String BaseDatabase {get;}

Remarks

See Also

EntityInfo Class | Aptify.Framework.Application Namespace


BaseTable Property

Aptify 5.0 Software Development Kit (SDK)

EntityInfo.BaseTable Property

The base table for the entity.

public String BaseTable {get;}

Remarks

See Also

EntityInfo Class | Aptify.Framework.Application Namespace


BaseView Property

Aptify 5.0 Software Development Kit (SDK)

EntityInfo.BaseView Property

The base view that has all of the entity information.

public String BaseView {get;}

Remarks

See Also

EntityInfo Class | Aptify.Framework.Application Namespace


DisplayName Property

Aptify 5.0 Software Development Kit (SDK)

EntityInfo.DisplayName Property

The user friendly name of the entity.

public String DisplayName {get;}

Remarks

See Also

EntityInfo Class | Aptify.Framework.Application Namespace


String Property

Aptify 5.0 Software Development Kit (SDK)

EntityInfo.String Property

Overload List

public virtual String DisplayNameWCulture {get;}

public virtual String this[Boolean] {get;}

public virtual String this[Int64] {get;}

public virtual String this[Int64, Boolean] {get;}

See Also

EntityInfo Class | Aptify.Framework.Application Namespace


DisplayNameWCulture Property

Aptify 5.0 Software Development Kit (SDK)

EntityInfo.DisplayNameWCulture Property

public virtual String DisplayNameWCulture {get;}

See Also

EntityInfo Class | Aptify.Framework.Application Namespace | EntityInfo.String Overload List


DisplayNameWCulture Property (Boolean)

Aptify 5.0 Software Development Kit (SDK)

EntityInfo.DisplayNameWCulture Property (Boolean)

public virtual String this[
Boolean AutoMapDisplayName
] {get;}

See Also

EntityInfo Class | Aptify.Framework.Application Namespace | EntityInfo.String Overload List


DisplayNameWCulture Property (Int64)

Aptify 5.0 Software Development Kit (SDK)

EntityInfo.DisplayNameWCulture Property (Int64)

public virtual String this[
Int64 CultureID
] {get;}

See Also

EntityInfo Class | Aptify.Framework.Application Namespace | EntityInfo.String Overload List


DisplayNameWCulture Property (Int64, Boolean)

Aptify 5.0 Software Development Kit (SDK)

EntityInfo.DisplayNameWCulture Property (Int64, Boolean)

public virtual String this[
Int64 CultureID,
Boolean AutoMapDisplayName
] {get;}

See Also

EntityInfo Class | Aptify.Framework.Application Namespace | EntityInfo.String Overload List


EntityAttributes Property

Aptify 5.0 Software Development Kit (SDK)

EntityInfo.EntityAttributes Property

Returns a list of entity attributes.

public EntityAttributes EntityAttributes {get;}

Remarks

See Also

EntityInfo Class | Aptify.Framework.Application Namespace


EntityID Property

Aptify 5.0 Software Development Kit (SDK)

EntityInfo.EntityID Property

Primary key of the entity.

public Int64 EntityID {get;}

Remarks

See Also

EntityInfo Class | Aptify.Framework.Application Namespace


EntityMetaData Property

Aptify 5.0 Software Development Kit (SDK)

EntityInfo.EntityMetaData Property

Returns the collection of entity and field meta data information.

public EntityLevelMetaData EntityMetaData {get;}

Remarks

See Also

EntityInfo Class | Aptify.Framework.Application Namespace


EntityName Property

Aptify 5.0 Software Development Kit (SDK)

EntityInfo.EntityName Property

Unique entity text string name.

public String EntityName {get;}

Remarks

See Also

EntityInfo Class | Aptify.Framework.Application Namespace


EntityPlugIns Property

Aptify 5.0 Software Development Kit (SDK)

EntityInfo.EntityPlugIns Property

Returns a list of entity plug ins.

public EntityPlugIns EntityPlugIns {get;}

Remarks

See Also

EntityInfo Class | Aptify.Framework.Application Namespace


GetSPDeleteRelated Property

Aptify 5.0 Software Development Kit (SDK)

EntityInfo.GetSPDeleteRelated Property

public String this[
Int64 ParentEntityID
] {get;}

See Also

EntityInfo Class | Aptify.Framework.Application Namespace


Icon Property

Aptify 5.0 Software Development Kit (SDK)

EntityInfo.Icon Property

Returns the entity's icon object repository location in PackageName.ObjectName format

public String Icon {get;}

Remarks

See Also

EntityInfo Class | Aptify.Framework.Application Namespace


IsSubType Property

Aptify 5.0 Software Development Kit (SDK)

EntityInfo.IsSubType Property

If True, the entity is a SubType; if False, entity is a top-level entity.

public Boolean IsSubType {get;}

Remarks

See Also

EntityInfo Class | Aptify.Framework.Application Namespace


NameField Property

Aptify 5.0 Software Development Kit (SDK)

EntityInfo.NameField Property

public String NameField {get;}

See Also

EntityInfo Class | Aptify.Framework.Application Namespace


spAddToList Property

Aptify 5.0 Software Development Kit (SDK)

EntityInfo.spAddToList Property

Stored procedure to add an item to a list in an entity.

public String spAddToList {get;}

Property Value

Remarks

See Also

EntityInfo Class | Aptify.Framework.Application Namespace


spCreate Property

Aptify 5.0 Software Development Kit (SDK)

EntityInfo.spCreate Property

Stored procedure to create an entity record.

public String spCreate {get;}

Remarks

See Also

EntityInfo Class | Aptify.Framework.Application Namespace


spDeleteRelated Property

Aptify 5.0 Software Development Kit (SDK)

EntityInfo.spDeleteRelated Property

public String this[
String ParentEntityName
] {get;}

See Also

EntityInfo Class | Aptify.Framework.Application Namespace


spDeleteSingle Property

Aptify 5.0 Software Development Kit (SDK)

EntityInfo.spDeleteSingle Property

Stored procedure to deletes an entity record.

public String spDeleteSingle {get;}

Property Value

Remarks

See Also

EntityInfo Class | Aptify.Framework.Application Namespace


spGetDependants Property

Aptify 5.0 Software Development Kit (SDK)

EntityInfo.spGetDependants Property

Stored procedure to list dependent records.

public String spGetDependants {get;}

Property Value

Remarks

See Also

EntityInfo Class | Aptify.Framework.Application Namespace


String Property

Aptify 5.0 Software Development Kit (SDK)

EntityInfo.String Property

Overload List

public String this[Int64] {get;}

public String this[String] {get;}

See Also

EntityInfo Class | Aptify.Framework.Application Namespace


spGetRelated Property (Int64)

Aptify 5.0 Software Development Kit (SDK)

EntityInfo.spGetRelated Property (Int64)

public String this[
Int64 ParentEntityID
] {get;}

See Also

EntityInfo Class | Aptify.Framework.Application Namespace | EntityInfo.String Overload List


spGetRelated Property (String)

Aptify 5.0 Software Development Kit (SDK)

EntityInfo.spGetRelated Property (String)

public String this[
String ParentEntityName
] {get;}

See Also

EntityInfo Class | Aptify.Framework.Application Namespace | EntityInfo.String Overload List


spGetSingle Property

Aptify 5.0 Software Development Kit (SDK)

EntityInfo.spGetSingle Property

Stored procedure to return a single record.

public String spGetSingle {get;}

Remarks

See Also

EntityInfo Class | Aptify.Framework.Application Namespace


spRelinkDependencies Property

Aptify 5.0 Software Development Kit (SDK)

EntityInfo.spRelinkDependencies Property

Stored procedure to reconnect entity records back together.

public String spRelinkDependencies {get;}

Property Value

Remarks

See Also

EntityInfo Class | Aptify.Framework.Application Namespace


spUpdate Property

Aptify 5.0 Software Development Kit (SDK)

EntityInfo.spUpdate Property

Stored procedure to update an entity record.

public String spUpdate {get;}

Property Value

Remarks

See Also

EntityInfo Class | Aptify.Framework.Application Namespace


StoredProcedures Property

Aptify 5.0 Software Development Kit (SDK)

EntityInfo.StoredProcedures Property

An object that has all of the Create, Read, Update, Delete and Fetch stored procedures for a given entity. This can be retrieved through base properties as well.

public EntityStoredProcedures StoredProcedures {get;}

Remarks

See Also

EntityInfo Class | Aptify.Framework.Application Namespace


EntityInfo Methods

The methods of the EntityInfo class are listed below. For a complete list of EntityInfo class members, see the EntityInfo Members topic.

Public Instance Methods

DeleteEntityRecord | Delete a single entity record.
DeleteEntityRecords | Overloaded. Delete multiple entity records.
DisplayEntityFindDialog | Overloaded.
DisplayEntityProperties | Overloaded.
DisplayEntityRecord | Overloaded.
DisplayEntityRecordDialog | Overloaded.
DisplayNewEntityRecord | Overloaded.
DisplayNewViewDialog | Overloaded. Opens a new view dialog form in dialog mode.
DisplaySubTypeEntityRecordDialog | Overloaded.
EntityActions | Returns a collection of actions that can be taken against a given entity.
EntityRecordExists | This method does checks to see if the specified record ID exists in the entity defined by the EntityName parameter. If it does the method returns True, otherwise it returns False.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAttachmentPermissions | Returns an Entity Attachment Permissions object that describes the current user's permissions for this entity. If the Category ID is provided, then the permissions will consider the Category Attachment permissions.
GetAvailableViewFields | A list of fields from the View's Base View
GetDefaultViewFields | Overloaded. A list of entity fields that appear in an entity's view by default. Uses the Entity's BaseView
GetEntityConstraints | This returns a Case Insensitive Hashtable that contains information about active entity constraints.
GetEntityDependencies | Overloaded.
GetEntityFieldDisplayName | Returns the display name of the field.
GetEntityObject | Returns a Generic Entity object based upon the Record ID.
GetEntityPlugIn | Overloaded. Retrieve an entity plug in based upon its type.
GetEntityRecordName | Returns a record name for a given entity record.
GetFieldPermissions | Returns an object that reports the permissions that the user has for an entity's fields.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPermissions | Returns an EntityPermissions object that describes the current user's permissions for this entity.
GetRecordIDFromRecordName |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EntityInfo Class | Aptify.Framework.Application Namespace


EntityInfo.DeleteEntityRecord Method

Delete a single entity record.

public bool DeleteEntityRecord(
Int64 RecordID,
ref String& ErrorString
);

Parameters

RecordID
ErrorString

See Also

EntityInfo Class | Aptify.Framework.Application Namespace


DeleteEntityRecords Method

Aptify 5.0 Software Development Kit (SDK)

EntityInfo.DeleteEntityRecords Method

Delete multiple entity records.

Overload List

Delete multiple entity records.

public void DeleteEntityRecords(Int64[],ref String&);

Delete multiple entity records. Not Implemented

public void DeleteEntityRecords(String);

See Also

EntityInfo Class | Aptify.Framework.Application Namespace


EntityInfo.DeleteEntityRecords Method (Int64[], String&)

Delete multiple entity records.

public void DeleteEntityRecords(
Int64[] RecordIDs,
ref String& ErrorString
);

Parameters

RecordIDs
ErrorString

See Also

EntityInfo Class | Aptify.Framework.Application Namespace | EntityInfo.DeleteEntityRecords Overload List


EntityInfo.DeleteEntityRecords Method (String)

Delete multiple entity records. Not Implemented

public void DeleteEntityRecords(
String SQL
);

Parameters

SQL

Remarks

NOT IMPLEMENTED

Exceptions

Exception Type | Condition
NotImplementedException | Always thrown

See Also

EntityInfo Class | Aptify.Framework.Application Namespace | EntityInfo.DeleteEntityRecords Overload List


DisplayEntityFindDialog Method

Aptify 5.0 Software Development Kit (SDK)

EntityInfo.DisplayEntityFindDialog Method

Overload List

public long DisplayEntityFindDialog(String,String,ref String&);

public long DisplayEntityFindDialog(String,String,ref String&,Form);

See Also

EntityInfo Class | Aptify.Framework.Application Namespace


EntityInfo.DisplayEntityFindDialog Method (String, String, String&)

public long DisplayEntityFindDialog(
String SearchString,
String HiddenFilter,
ref String& DisplayName
);

See Also

EntityInfo Class | Aptify.Framework.Application Namespace | EntityInfo.DisplayEntityFindDialog Overload List


EntityInfo.DisplayEntityFindDialog Method (String, String, String&, Form)

public long DisplayEntityFindDialog(
String SearchString,
String HiddenFilter,
ref String& DisplayName,
Form ParentForm
);

See Also

EntityInfo Class | Aptify.Framework.Application Namespace | EntityInfo.DisplayEntityFindDialog Overload List


DisplayEntityProperties Method

Aptify 5.0 Software Development Kit (SDK)

EntityInfo.DisplayEntityProperties Method

Overload List

public void DisplayEntityProperties();

public void DisplayEntityProperties(Form);

See Also

EntityInfo Class | Aptify.Framework.Application Namespace


EntityInfo.DisplayEntityProperties Method ()

public void DisplayEntityProperties();

See Also

EntityInfo Class | Aptify.Framework.Application Namespace | EntityInfo.DisplayEntityProperties Overload List


EntityInfo.DisplayEntityProperties Method (Form)

public void DisplayEntityProperties(
Form ParentForm
);

See Also

EntityInfo Class | Aptify.Framework.Application Namespace | EntityInfo.DisplayEntityProperties Overload List


DisplayEntityRecord Method

Aptify 5.0 Software Development Kit (SDK)

EntityInfo.DisplayEntityRecord Method

Overload List

public void DisplayEntityRecord(AptifyGenericEntityBase);

public void DisplayEntityRecord(AptifyGenericEntityBase,Boolean);

public void DisplayEntityRecord(AptifyGenericEntityBase,Boolean,Form);

public void DisplayEntityRecord(Int64);

public void DisplayEntityRecord(Int64,Boolean);

public void DisplayEntityRecord(Int64,Boolean,Form);

public void DisplayEntityRecord(Int64,Form);

See Also

EntityInfo Class | Aptify.Framework.Application Namespace


EntityInfo.DisplayEntityRecord Method (AptifyGenericEntityBase)

public void DisplayEntityRecord(
AptifyGenericEntityBase GE
);

See Also

EntityInfo Class | Aptify.Framework.Application Namespace | EntityInfo.DisplayEntityRecord Overload List


EntityInfo.DisplayEntityRecord Method (AptifyGenericEntityBase, Boolean)

public void DisplayEntityRecord(
AptifyGenericEntityBase GE,
Boolean UseObjectViewer
);

See Also

EntityInfo Class | Aptify.Framework.Application Namespace | EntityInfo.DisplayEntityRecord Overload List


EntityInfo.DisplayEntityRecord Method (AptifyGenericEntityBase, Boolean, Form)

public void DisplayEntityRecord(
AptifyGenericEntityBase GE,
Boolean UseObjectViewer,
Form parentForm
);

See Also

EntityInfo Class | Aptify.Framework.Application Namespace | EntityInfo.DisplayEntityRecord Overload List


EntityInfo.DisplayEntityRecord Method (Int64)

public void DisplayEntityRecord(
Int64 RecordID
);

See Also

EntityInfo Class | Aptify.Framework.Application Namespace | EntityInfo.DisplayEntityRecord Overload List


EntityInfo.DisplayEntityRecord Method (Int64, Boolean)

public void DisplayEntityRecord(
Int64 RecordID,
Boolean UseObjectViewer
);

See Also

EntityInfo Class | Aptify.Framework.Application Namespace | EntityInfo.DisplayEntityRecord Overload List


EntityInfo.DisplayEntityRecord Method (Int64, Boolean, Form)

public void DisplayEntityRecord(
Int64 RecordID,
Boolean UseObjectViewer,
Form parentForm
);

See Also

EntityInfo Class | Aptify.Framework.Application Namespace | EntityInfo.DisplayEntityRecord Overload List


EntityInfo.DisplayEntityRecord Method (Int64, Form)

public void DisplayEntityRecord(
Int64 RecordID,
Form parentForm
);

See Also

EntityInfo Class | Aptify.Framework.Application Namespace | EntityInfo.DisplayEntityRecord Overload List


DisplayEntityRecordDialog Method

Aptify 5.0 Software Development Kit (SDK)

EntityInfo.DisplayEntityRecordDialog Method

Overload List

public DialogResult DisplayEntityRecordDialog(AptifyGenericEntityBase);

public DialogResult DisplayEntityRecordDialog(AptifyGenericEntityBase,Boolean);

Opens an existing record in its form/form template in dialog mode.

public DialogResult DisplayEntityRecordDialog(AptifyGenericEntityBase,Boolean,Form);

See Also

EntityInfo Class | Aptify.Framework.Application Namespace


EntityInfo.DisplayEntityRecordDialog Method (AptifyGenericEntityBase)

public DialogResult DisplayEntityRecordDialog(
AptifyGenericEntityBase GE
);

See Also

EntityInfo Class | Aptify.Framework.Application Namespace | EntityInfo.DisplayEntityRecordDialog Overload List


EntityInfo.DisplayEntityRecordDialog Method (AptifyGenericEntityBase, Boolean)

public DialogResult DisplayEntityRecordDialog(
AptifyGenericEntityBase GE,
Boolean UseObjectViewer
);

See Also

EntityInfo Class | Aptify.Framework.Application Namespace | EntityInfo.DisplayEntityRecordDialog Overload List


EntityInfo.DisplayEntityRecordDialog Method (AptifyGenericEntityBase, Boolean, Form)

Opens an existing record in its form/form template in dialog mode.

public DialogResult DisplayEntityRecordDialog(
AptifyGenericEntityBase GE,
Boolean UseObjectViewer,
Form parentForm
);

Parameters

GE
UseObjectViewer
parentForm

Return Value

Remarks

See Also

EntityInfo Class | Aptify.Framework.Application Namespace | EntityInfo.DisplayEntityRecordDialog Overload List


DisplayNewEntityRecord Method

Aptify 5.0 Software Development Kit (SDK)

EntityInfo.DisplayNewEntityRecord Method

Overload List

public void DisplayNewEntityRecord();

public void DisplayNewEntityRecord(Boolean);

public void DisplayNewEntityRecord(Boolean,Form);

public void DisplayNewEntityRecord(String);

public void DisplayNewEntityRecord(String,Boolean);

Opens a new entity record.

public void DisplayNewEntityRecord(String,Boolean,Form);

public void DisplayNewEntityRecord(String,Form);

public void DisplayNewEntityRecord(Form);

See Also

EntityInfo Class | Aptify.Framework.Application Namespace


EntityInfo.DisplayNewEntityRecord Method ()

public void DisplayNewEntityRecord();

See Also

EntityInfo Class | Aptify.Framework.Application Namespace | EntityInfo.DisplayNewEntityRecord Overload List


EntityInfo.DisplayNewEntityRecord Method (Boolean)

public void DisplayNewEntityRecord(
Boolean UseObjectViewer
);

See Also

EntityInfo Class | Aptify.Framework.Application Namespace | EntityInfo.DisplayNewEntityRecord Overload List


EntityInfo.DisplayNewEntityRecord Method (Boolean, Form)

public void DisplayNewEntityRecord(
Boolean UseObjectViewer,
Form parentForm
);

See Also

EntityInfo Class | Aptify.Framework.Application Namespace | EntityInfo.DisplayNewEntityRecord Overload List


EntityInfo.DisplayNewEntityRecord Method (String)

public void DisplayNewEntityRecord(
String NewRecordParameters
);

See Also

EntityInfo Class | Aptify.Framework.Application Namespace | EntityInfo.DisplayNewEntityRecord Overload List


EntityInfo.DisplayNewEntityRecord Method (String, Boolean)

public void DisplayNewEntityRecord(
String NewRecordParameters,
Boolean UseObjectViewer
);

See Also

EntityInfo Class | Aptify.Framework.Application Namespace | EntityInfo.DisplayNewEntityRecord Overload List


EntityInfo.DisplayNewEntityRecord Method (String, Boolean, Form)

Opens a new entity record.

public void DisplayNewEntityRecord(
String NewRecordParameters,
Boolean UseObjectViewer,
Form parentForm
);

Parameters

NewRecordParameters
UseObjectViewer
parentForm

See Also

EntityInfo Class | Aptify.Framework.Application Namespace | EntityInfo.DisplayNewEntityRecord Overload List


EntityInfo.DisplayNewEntityRecord Method (String, Form)

public void DisplayNewEntityRecord(
String NewRecordParameters,
Form parentForm
);

See Also

EntityInfo Class | Aptify.Framework.Application Namespace | EntityInfo.DisplayNewEntityRecord Overload List


EntityInfo.DisplayNewEntityRecord Method (Form)

public void DisplayNewEntityRecord(
Form parentForm
);

See Also

EntityInfo Class | Aptify.Framework.Application Namespace | EntityInfo.DisplayNewEntityRecord Overload List


DisplayNewViewDialog Method

Aptify 5.0 Software Development Kit (SDK)

EntityInfo.DisplayNewViewDialog Method

Opens a new view dialog form in dialog mode.

Overload List

Opens a new view dialog form in dialog mode.

public DialogResult DisplayNewViewDialog(Int64,ref AptifyGenericEntityBase&);

Opens a new view dialog form in dialog mode.

public DialogResult DisplayNewViewDialog(Int64,ref AptifyGenericEntityBase&,Form);

See Also

EntityInfo Class | Aptify.Framework.Application Namespace


EntityInfo.DisplayNewViewDialog Method (Int64, AptifyGenericEntityBase&)

Opens a new view dialog form in dialog mode.

public DialogResult DisplayNewViewDialog(
Int64 ViewCategoryID,
ref AptifyGenericEntityBase& ViewGE
);

Parameters

ViewCategoryID
ViewGE

See Also

EntityInfo Class | Aptify.Framework.Application Namespace | EntityInfo.DisplayNewViewDialog Overload List


EntityInfo.DisplayNewViewDialog Method (Int64, AptifyGenericEntityBase&, Form)

Opens a new view dialog form in dialog mode.

public DialogResult DisplayNewViewDialog(
Int64 ViewCategoryID,
ref AptifyGenericEntityBase& ViewGE,
Form ParentForm
);

Parameters

ViewCategoryID
ViewGE
ParentForm

Return Value

Remarks

See Also

EntityInfo Class | Aptify.Framework.Application Namespace | EntityInfo.DisplayNewViewDialog Overload List


DisplaySubTypeEntityRecordDialog Method

Aptify 5.0 Software Development Kit (SDK)

EntityInfo.DisplaySubTypeEntityRecordDialog Method

Overload List

public DialogResult DisplaySubTypeEntityRecordDialog(AptifyGenericEntityBase,String);

public DialogResult DisplaySubTypeEntityRecordDialog(AptifyGenericEntityBase,String,String);

Opens a subtype existing record in its form/form template.

public DialogResult DisplaySubTypeEntityRecordDialog(AptifyGenericEntityBase,String,String,Form);

public DialogResult DisplaySubTypeEntityRecordDialog(AptifyGenericEntityBase,String,Form);

See Also

EntityInfo Class | Aptify.Framework.Application Namespace


EntityInfo.DisplaySubTypeEntityRecordDialog Method (AptifyGenericEntityBase, String)

public DialogResult DisplaySubTypeEntityRecordDialog(
AptifyGenericEntityBase subTypeGE,
String Caption
);

See Also

EntityInfo Class | Aptify.Framework.Application Namespace | EntityInfo.DisplaySubTypeEntityRecordDialog Overload List


EntityInfo.DisplaySubTypeEntityRecordDialog Method (AptifyGenericEntityBase, String, String)

public DialogResult DisplaySubTypeEntityRecordDialog(
AptifyGenericEntityBase subTypeGE,
String CmdString,
String Caption
);

See Also

EntityInfo Class | Aptify.Framework.Application Namespace | EntityInfo.DisplaySubTypeEntityRecordDialog Overload List


EntityInfo.DisplaySubTypeEntityRecordDialog Method (AptifyGenericEntityBase, String, String, Form)

Opens a subtype existing record in its form/form template.

public DialogResult DisplaySubTypeEntityRecordDialog(
AptifyGenericEntityBase subTypeGE,
String CmdString,
String Caption,
Form parentForm
);

Parameters

subTypeGE
CmdString
Caption
parentForm

Return Value

Remarks

See Also

EntityInfo Class | Aptify.Framework.Application Namespace | EntityInfo.DisplaySubTypeEntityRecordDialog Overload List


EntityInfo.DisplaySubTypeEntityRecordDialog Method (AptifyGenericEntityBase, String, Form)

public DialogResult DisplaySubTypeEntityRecordDialog(
AptifyGenericEntityBase subTypeGE,
String Caption,
Form parentForm
);

See Also

EntityInfo Class | Aptify.Framework.Application Namespace | EntityInfo.DisplaySubTypeEntityRecordDialog Overload List


EntityInfo.EntityActions Method

Returns a collection of actions that can be taken against a given entity.

public EntityActions EntityActions();

See Also

EntityInfo Class | Aptify.Framework.Application Namespace


EntityInfo.EntityRecordExists Method

This method does checks to see if the specified record ID exists in the entity defined by the EntityName parameter. If it does the method returns True, otherwise it returns False.

public virtual bool EntityRecordExists(
Int64 RecordID
);

Parameters

RecordID

Return Value

Remarks

See Also

EntityInfo Class | Aptify.Framework.Application Namespace


EntityInfo.GetAttachmentPermissions Method

Returns an Entity Attachment Permissions object that describes the current user's permissions for this entity. If the Category ID is provided, then the permissions will consider the Category Attachment permissions.

public EntityPermissions GetAttachmentPermissions(
Int64 CategoryID
);

See Also

EntityInfo Class | Aptify.Framework.Application Namespace


EntityInfo.GetAvailableViewFields Method

A list of fields from the View's Base View

public ViewFields GetAvailableViewFields(
String EntityBaseViewName
);

Return Value

Remarks

See Also

EntityInfo Class | Aptify.Framework.Application Namespace


GetDefaultViewFields Method

Aptify 5.0 Software Development Kit (SDK)

EntityInfo.GetDefaultViewFields Method

A list of entity fields that appear in an entity's view by default. Uses the Entity's BaseView

Overload List

A list of entity fields that appear in an entity's view by default. Uses the Entity's BaseView

public ViewFields GetDefaultViewFields();

A list of Fields in the View's Base View that appear in an entity's view by default. If EntityBaseViewName is blank, the Entity's BaseView is used. Otherwise, the EntityBaseView's information will be used.

public ViewFields GetDefaultViewFields(String);

See Also

EntityInfo Class | Aptify.Framework.Application Namespace


EntityInfo.GetDefaultViewFields Method ()

A list of entity fields that appear in an entity's view by default. Uses the Entity's BaseView

public ViewFields GetDefaultViewFields();

See Also

EntityInfo Class | Aptify.Framework.Application Namespace | EntityInfo.GetDefaultViewFields Overload List


EntityInfo.GetDefaultViewFields Method (String)

A list of Fields in the View's Base View that appear in an entity's view by default. If EntityBaseViewName is blank, the Entity's BaseView is used. Otherwise, the EntityBaseView's information will be used.

public ViewFields GetDefaultViewFields(
String EntityBaseViewName
);

Return Value

Remarks

See Also

EntityInfo Class | Aptify.Framework.Application Namespace | EntityInfo.GetDefaultViewFields Overload List


EntityInfo.GetEntityConstraints Method

This returns a Case Insensitive Hashtable that contains information about active entity constraints.

public EntityConstraint[] GetEntityConstraints();

Return Value

Remarks

The key is the entity name, the value is currently the FailureMessage

See Also

EntityInfo Class | Aptify.Framework.Application Namespace


GetEntityDependencies Method

Aptify 5.0 Software Development Kit (SDK)

EntityInfo.GetEntityDependencies Method

Overload List

public EntityDependenciesBase GetEntityDependencies(Int64);

Returns a collection that has a list of records that depend on this record.

public EntityDependenciesBase GetEntityDependencies(Int64,String);

public EntityDependenciesBase GetEntityDependencies(Int64,String,Boolean,Boolean,String);

public EntityDependenciesBase GetEntityDependencies(Int64,String,Boolean,String);

public EntityDependenciesBase GetEntityDependencies(Int64,String,String);

See Also

EntityInfo Class | Aptify.Framework.Application Namespace


EntityInfo.GetEntityDependencies Method (Int64)

public EntityDependenciesBase GetEntityDependencies(
Int64 RecordID
);

See Also

EntityInfo Class | Aptify.Framework.Application Namespace | EntityInfo.GetEntityDependencies Overload List


EntityInfo.GetEntityDependencies Method (Int64, String)

Returns a collection that has a list of records that depend on this record.

public EntityDependenciesBase GetEntityDependencies(
Int64 RecordID,
String TransactionID
);

Parameters

RecordID
TransactionID

Return Value

Remarks

See Also

EntityInfo Class | Aptify.Framework.Application Namespace | EntityInfo.GetEntityDependencies Overload List


EntityInfo.GetEntityDependencies Method (Int64, String, Boolean, Boolean, String)

public EntityDependenciesBase GetEntityDependencies(
Int64 RecordID,
String TransactionID,
Boolean ExcludeForeignKeys,
Boolean OnlyExistenceCheck,
String DependenciesTableName
);

See Also

EntityInfo Class | Aptify.Framework.Application Namespace | EntityInfo.GetEntityDependencies Overload List


EntityInfo.GetEntityDependencies Method (Int64, String, Boolean, String)

public EntityDependenciesBase GetEntityDependencies(
Int64 RecordID,
String TransactionID,
Boolean ExcludeForeignKeys,
String DependenciesTableName
);

See Also

EntityInfo Class | Aptify.Framework.Application Namespace | EntityInfo.GetEntityDependencies Overload List


EntityInfo.GetEntityDependencies Method (Int64, String, String)

public EntityDependenciesBase GetEntityDependencies(
Int64 RecordID,
String TransactionID,
String DependenciesTableName
);

See Also

EntityInfo Class | Aptify.Framework.Application Namespace | EntityInfo.GetEntityDependencies Overload List


EntityInfo.GetEntityFieldDisplayName Method

Returns the display name of the field.

public string GetEntityFieldDisplayName(
String FieldName
);

Parameters

FieldName

See Also

EntityInfo Class | Aptify.Framework.Application Namespace


EntityInfo.GetEntityObject Method

Returns a Generic Entity object based upon the Record ID.

public AptifyGenericEntityBase GetEntityObject(
Int64 RecordID
);

Parameters

RecordID

See Also

EntityInfo Class | Aptify.Framework.Application Namespace


GetEntityPlugIn Method

Aptify 5.0 Software Development Kit (SDK)

EntityInfo.GetEntityPlugIn Method

Retrieve an entity plug in based upon its type.

Overload List

Retrieve an entity plug in based upon its type.

public EntityPlugIn GetEntityPlugIn(EntityPlugInType,Boolean);

Accepts the name of the Entity Plug In Type to retrieve. This is used to support the Other Entity Plug In Type. If no match is found, an empty EntityPlugIn object is returned.

public EntityPlugIn GetEntityPlugIn(String,Boolean);

See Also

EntityInfo Class | Aptify.Framework.Application Namespace


EntityInfo.GetEntityPlugIn Method (EntityPlugInType, Boolean)

Retrieve an entity plug in based upon its type.

public EntityPlugIn GetEntityPlugIn(
EntityPlugInType PlugInType,
Boolean DownloadObject
);

Parameters

PlugInType
DownloadObject

Return Value

Retrieve an entity plug in based upon its type

Remarks

An organization can configure an entity to use a specially designed form or functionality. To implement this specialized behavior, a developer creates a .NET assembly that defines the entity's extended functionality. These assemblies are then stored in the Object Repository and are added to the entity on the Plug-Ins tab. The entity uses the plug-ins specified on this tab to override standard functionality with the functionality specified in one or more plug-ins. Typical plug-ins include a specialized form (Viewer plug-in), business logic (Entity plug-in), duplicate record checking process (Duplicate Check type), context menu (Extension plug-in), record verification process (Verification plug-in), Find dialog (Find plug-in), and merging logic (Merge plug-in).

See Also

EntityInfo Class | Aptify.Framework.Application Namespace | EntityInfo.GetEntityPlugIn Overload List


EntityInfo.GetEntityPlugIn Method (String, Boolean)

Accepts the name of the Entity Plug In Type to retrieve. This is used to support the Other Entity Plug In Type. If no match is found, an empty EntityPlugIn object is returned.

public EntityPlugIn GetEntityPlugIn(
String PlugInTypeName,
Boolean DownloadObject
);

Parameters

PlugInTypeName
DownloadObject

Return Value

Remarks

See Also

EntityInfo Class | Aptify.Framework.Application Namespace | EntityInfo.GetEntityPlugIn Overload List


EntityInfo.GetEntityRecordName Method

Returns a record name for a given entity record.

public string GetEntityRecordName(
Int64 RecordID
);

Parameters

RecordID

See Also

EntityInfo Class | Aptify.Framework.Application Namespace


EntityInfo.GetFieldPermissions Method

Returns an object that reports the permissions that the user has for an entity's fields.

public EntityFieldPermissions GetFieldPermissions();

See Also

EntityInfo Class | Aptify.Framework.Application Namespace


EntityInfo.GetPermissions Method

Returns an EntityPermissions object that describes the current user's permissions for this entity.

public EntityPermissions GetPermissions();

See Also

EntityInfo Class | Aptify.Framework.Application Namespace


EntityInfo.GetRecordIDFromRecordName Method

public long GetRecordIDFromRecordName(
String RecordName
);

See Also

EntityInfo Class | Aptify.Framework.Application Namespace


EntityPermissions Structure

For a list of all members of this type, see EntityPermissions Members.

System.Object
ValueType
EntityPermissions

public struct EntityPermissions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyApplication (in AptifyApplication.dll)

See Also

EntityPermissions Members | Aptify.Framework.Application Namespace


EntityPermissions Members

EntityPermissions overview

Public Instance Fields

AllowInPlaceEditing
Create
Delete
Edit
Merge
ObjectViewer
Read

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

EntityPermissions Structure | Aptify.Framework.Application Namespace


EntityPermissions Fields

The fields of the EntityPermissions structure are listed below. For a complete list of EntityPermissions structure members, see the EntityPermissions Members topic.

Public Instance Fields

AllowInPlaceEditing
Create
Delete
Edit
Merge
ObjectViewer
Read

See Also

EntityPermissions Structure | Aptify.Framework.Application Namespace


EntityPermissions.AllowInPlaceEditing Field

public AllowInPlaceEditing AllowInPlaceEditing;

See Also

EntityPermissions Class | Aptify.Framework.Application Namespace


EntityPermissions.Create Field

public Create Create;

See Also

EntityPermissions Class | Aptify.Framework.Application Namespace


EntityPermissions.Delete Field

public Delete Delete;

See Also

EntityPermissions Class | Aptify.Framework.Application Namespace


EntityPermissions.Edit Field

public Edit Edit;

See Also

EntityPermissions Class | Aptify.Framework.Application Namespace


EntityPermissions.Merge Field

public Merge Merge;

See Also

EntityPermissions Class | Aptify.Framework.Application Namespace


EntityPermissions.ObjectViewer Field

public ObjectViewer ObjectViewer;

See Also

EntityPermissions Class | Aptify.Framework.Application Namespace


EntityPermissions.Read Field

public Read Read;

See Also

EntityPermissions Class | Aptify.Framework.Application Namespace


EntityPermissionType Enumeration

public enum EntityPermissionType

Members

Member Name | Description
NotSet |
Allow |
Conditional |
Deny |

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyApplication (in AptifyApplication.dll)

See Also

Aptify.Framework.Application Namespace


EntityPlugIn Structure

For a list of all members of this type, see EntityPlugIn Members.

System.Object
ValueType
EntityPlugIn

public struct EntityPlugIn

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyApplication (in AptifyApplication.dll)

See Also

EntityPlugIn Members | Aptify.Framework.Application Namespace


EntityPlugIn Members

EntityPlugIn overview

Public Instance Fields

AssemblyName
ClassName
ObjectName
ObjectTypeID
PlugInType
PlugInTypeName

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

EntityPlugIn Structure | Aptify.Framework.Application Namespace


EntityPlugIn Fields

The fields of the EntityPlugIn structure are listed below. For a complete list of EntityPlugIn structure members, see the EntityPlugIn Members topic.

Public Instance Fields

AssemblyName
ClassName
ObjectName
ObjectTypeID
PlugInType
PlugInTypeName

See Also

EntityPlugIn Structure | Aptify.Framework.Application Namespace


EntityPlugIn.AssemblyName Field

public AssemblyName AssemblyName;

See Also

EntityPlugIn Class | Aptify.Framework.Application Namespace


EntityPlugIn.ClassName Field

public ClassName ClassName;

See Also

EntityPlugIn Class | Aptify.Framework.Application Namespace


EntityPlugIn.ObjectName Field

public ObjectName ObjectName;

See Also

EntityPlugIn Class | Aptify.Framework.Application Namespace


EntityPlugIn.ObjectTypeID Field

public ObjectTypeID ObjectTypeID;

See Also

EntityPlugIn Class | Aptify.Framework.Application Namespace


EntityPlugIn.PlugInType Field

public PlugInType PlugInType;

See Also

EntityPlugIn Class | Aptify.Framework.Application Namespace


EntityPlugIn.PlugInTypeName Field

public PlugInTypeName PlugInTypeName;

See Also

EntityPlugIn Class | Aptify.Framework.Application Namespace


EntityPlugIns Class

For a list of all members of this type, see EntityPlugIns Members.

System.Object
NameObjectCollectionBase
AptifyCollection
EntityPlugIns

public class EntityPlugIns : AptifyCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyApplication (in AptifyApplication.dll)

See Also

EntityPlugIns Members | Aptify.Framework.Application Namespace


EntityPlugIns Members

EntityPlugIns overview

Public Instance Properties

Count (inherited from NameObjectCollectionBase) | Gets the number of key/value pairs contained in the NameObjectCollectionBase instance.
Item | Overloaded.
Keys (inherited from NameObjectCollectionBase) | Gets a KeysCollection instance that contains all the keys in the NameObjectCollectionBase instance.

Public Instance Methods

Add | Overloaded.
Clear (inherited from AptifyCollection) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from AptifyCollection) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from NameObjectCollectionBase) | Implements the ISerializable interface and returns the data needed to serialize the NameObjectCollectionBase instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from AptifyCollection) | Gets the index of the item with the specified Key.
Merge (inherited from AptifyCollection) | Allows a user to merge items from another collection to this collection.
OnDeserialization (inherited from NameObjectCollectionBase) | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete.
Remove (inherited from AptifyCollection) | Overloaded.
RemoveAt (inherited from AptifyCollection) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

IsReadOnly (inherited from NameObjectCollectionBase) Gets or sets a value indicating whether the NameObjectCollectionBase instance is read-only.

Protected Instance Methods

BaseAdd (inherited from NameObjectCollectionBase) | Adds an entry with the specified key and value into the NameObjectCollectionBase instance.
BaseClear (inherited from NameObjectCollectionBase) | Removes all entries from the NameObjectCollectionBase instance.
BaseGet (inherited from NameObjectCollectionBase) | Overloaded. Gets the value of the first entry with the specified key from the NameObjectCollectionBase instance.
BaseGetAllKeys (inherited from NameObjectCollectionBase) | Returns a String array that contains all the keys in the NameObjectCollectionBase instance.
BaseGetAllValues (inherited from NameObjectCollectionBase) | Overloaded. Returns an Object array that contains all the values in the NameObjectCollectionBase instance.
BaseGetKey (inherited from NameObjectCollectionBase) | Gets the key of the entry at the specified index of the NameObjectCollectionBase instance.
BaseHasKeys (inherited from NameObjectCollectionBase) | Gets a value indicating whether the NameObjectCollectionBase instance contains entries whose keys are not null.
BaseRemove (inherited from NameObjectCollectionBase) | Removes the entries with the specified key from the NameObjectCollectionBase instance.
BaseRemoveAt (inherited from NameObjectCollectionBase) | Removes the entry at the specified index of the NameObjectCollectionBase instance.
BaseSet (inherited from NameObjectCollectionBase) | Overloaded. Sets the value of the first entry with the specified key in the NameObjectCollectionBase instance, if found; otherwise, adds an entry with the specified key and value into the NameObjectCollectionBase instance.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EntityPlugIns Class | Aptify.Framework.Application Namespace


EntityPlugIns Properties

The properties of the EntityPlugIns class are listed below. For a complete list of EntityPlugIns class members, see the EntityPlugIns Members topic.

Public Instance Properties

Count (inherited from NameObjectCollectionBase) | Gets the number of key/value pairs contained in the NameObjectCollectionBase instance.
Item | Overloaded.
Keys (inherited from NameObjectCollectionBase) | Gets a KeysCollection instance that contains all the keys in the NameObjectCollectionBase instance.

Protected Instance Properties

IsReadOnly (inherited from NameObjectCollectionBase) Gets or sets a value indicating whether the NameObjectCollectionBase instance is read-only.

See Also

EntityPlugIns Class | Aptify.Framework.Application Namespace


EntityPlugIn Property

Aptify 5.0 Software Development Kit (SDK)

EntityPlugIns.EntityPlugIn Property

Overload List

public EntityPlugIn this[Int32] {get; set;}

public EntityPlugIn this[String] {get; set;}

See Also

EntityPlugIns Class | Aptify.Framework.Application Namespace


Item Property (Int32)

Aptify 5.0 Software Development Kit (SDK)

EntityPlugIns.Item Property (Int32)

public EntityPlugIn this[
Int32 Index
] {get; set;}

See Also

EntityPlugIns Class | Aptify.Framework.Application Namespace | EntityPlugIns.EntityPlugIn Overload List


Item Property (String)

Aptify 5.0 Software Development Kit (SDK)

EntityPlugIns.Item Property (String)

public EntityPlugIn this[
String Key
] {get; set;}

See Also

EntityPlugIns Class | Aptify.Framework.Application Namespace | EntityPlugIns.EntityPlugIn Overload List


EntityPlugIns Methods

The methods of the EntityPlugIns class are listed below. For a complete list of EntityPlugIns class members, see the EntityPlugIns Members topic.

Public Instance Methods

Add | Overloaded.
Clear (inherited from AptifyCollection) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from AptifyCollection) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from NameObjectCollectionBase) | Implements the ISerializable interface and returns the data needed to serialize the NameObjectCollectionBase instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from AptifyCollection) | Gets the index of the item with the specified Key.
Merge (inherited from AptifyCollection) | Allows a user to merge items from another collection to this collection.
OnDeserialization (inherited from NameObjectCollectionBase) | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete.
Remove (inherited from AptifyCollection) | Overloaded.
RemoveAt (inherited from AptifyCollection) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

BaseAdd (inherited from NameObjectCollectionBase) | Adds an entry with the specified key and value into the NameObjectCollectionBase instance.
BaseClear (inherited from NameObjectCollectionBase) | Removes all entries from the NameObjectCollectionBase instance.
BaseGet (inherited from NameObjectCollectionBase) | Overloaded. Gets the value of the first entry with the specified key from the NameObjectCollectionBase instance.
BaseGetAllKeys (inherited from NameObjectCollectionBase) | Returns a String array that contains all the keys in the NameObjectCollectionBase instance.
BaseGetAllValues (inherited from NameObjectCollectionBase) | Overloaded. Returns an Object array that contains all the values in the NameObjectCollectionBase instance.
BaseGetKey (inherited from NameObjectCollectionBase) | Gets the key of the entry at the specified index of the NameObjectCollectionBase instance.
BaseHasKeys (inherited from NameObjectCollectionBase) | Gets a value indicating whether the NameObjectCollectionBase instance contains entries whose keys are not null.
BaseRemove (inherited from NameObjectCollectionBase) | Removes the entries with the specified key from the NameObjectCollectionBase instance.
BaseRemoveAt (inherited from NameObjectCollectionBase) | Removes the entry at the specified index of the NameObjectCollectionBase instance.
BaseSet (inherited from NameObjectCollectionBase) | Overloaded. Sets the value of the first entry with the specified key in the NameObjectCollectionBase instance, if found; otherwise, adds an entry with the specified key and value into the NameObjectCollectionBase instance.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EntityPlugIns Class | Aptify.Framework.Application Namespace


Add Method

Aptify 5.0 Software Development Kit (SDK)

EntityPlugIns.Add Method

Overload List

public int Add(EntityPlugIn);

public int Add(EntityPlugIn,String);

public override int Add(Object);

public override int Add(Object,String);

See Also

EntityPlugIns Class | Aptify.Framework.Application Namespace


EntityPlugIns.Add Method (EntityPlugIn)

public int Add(
EntityPlugIn Value
);

See Also

EntityPlugIns Class | Aptify.Framework.Application Namespace | EntityPlugIns.Add Overload List


EntityPlugIns.Add Method (EntityPlugIn, String)

public int Add(
EntityPlugIn Value,
String Key
);

See Also

EntityPlugIns Class | Aptify.Framework.Application Namespace | EntityPlugIns.Add Overload List


EntityPlugIns.Add Method (Object)

public override int Add(
Object Value
);

See Also

EntityPlugIns Class | Aptify.Framework.Application Namespace | EntityPlugIns.Add Overload List


EntityPlugIns.Add Method (Object, String)

public override int Add(
Object Value,
String Key
);

See Also

EntityPlugIns Class | Aptify.Framework.Application Namespace | EntityPlugIns.Add Overload List


EntityPlugInType Enumeration

public enum EntityPlugInType

Members

Member Name | Description
Viewer |
Entity |
DuplicateCheck |
Extension |
Verification |
Find |
Merge |
Other |

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyApplication (in AptifyApplication.dll)

See Also

Aptify.Framework.Application Namespace


EntityPropertiesForm Class

For a list of all members of this type, see EntityPropertiesForm Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
EntityPropertiesForm

public class EntityPropertiesForm : Form

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyApplication (in AptifyApplication.dll)

See Also

EntityPropertiesForm Members | Aptify.Framework.Application Namespace


EntityPropertiesForm Members

EntityPropertiesForm overview

Public Instance Constructors

EntityPropertiesForm Constructor Initializes a new instance of the EntityPropertiesForm class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

EntityPropertiesForm Class | Aptify.Framework.Application Namespace


EntityPropertiesForm Constructor

Initializes a new instance of the EntityPropertiesForm class.

public EntityPropertiesForm();

See Also

EntityPropertiesForm Class | Aptify.Framework.Application Namespace


EntityPropertiesForm Methods

The methods of the EntityPropertiesForm class are listed below. For a complete list of EntityPropertiesForm class members, see the EntityPropertiesForm Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

EntityPropertiesForm Class | Aptify.Framework.Application Namespace


EntityPropertiesForm.Config Method

public void Config(
AptifyApplication AptifyApplication,
Int64 EntityID
);

See Also

EntityPropertiesForm Class | Aptify.Framework.Application Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

EntityPropertiesForm.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

EntityPropertiesForm Class | Aptify.Framework.Application Namespace


EntityPropertiesForm.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

EntityPropertiesForm Class | Aptify.Framework.Application Namespace | EntityPropertiesForm.Dispose Overload List


EntityRecordHistoryForm Class

For a list of all members of this type, see EntityRecordHistoryForm Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
EntityRecordHistoryForm

public class EntityRecordHistoryForm : Form

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyApplication (in AptifyApplication.dll)

See Also

EntityRecordHistoryForm Members | Aptify.Framework.Application Namespace


EntityRecordHistoryForm Members

EntityRecordHistoryForm overview

Public Instance Constructors

EntityRecordHistoryForm Constructor Initializes a new instance of the EntityRecordHistoryForm class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
RestoredVersion |
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

EntityRecordHistoryForm Class | Aptify.Framework.Application Namespace


EntityRecordHistoryForm Constructor

Initializes a new instance of the EntityRecordHistoryForm class.

public EntityRecordHistoryForm();

See Also

EntityRecordHistoryForm Class | Aptify.Framework.Application Namespace


EntityRecordHistoryForm Properties

The properties of the EntityRecordHistoryForm class are listed below. For a complete list of EntityRecordHistoryForm class members, see the EntityRecordHistoryForm Members topic.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
RestoredVersion |
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

EntityRecordHistoryForm Class | Aptify.Framework.Application Namespace


RestoredVersion Property

Aptify 5.0 Software Development Kit (SDK)

EntityRecordHistoryForm.RestoredVersion Property

public Int32 RestoredVersion {get;}

See Also

EntityRecordHistoryForm Class | Aptify.Framework.Application Namespace


EntityRecordHistoryForm Methods

The methods of the EntityRecordHistoryForm class are listed below. For a complete list of EntityRecordHistoryForm class members, see the EntityRecordHistoryForm Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

EntityRecordHistoryForm Class | Aptify.Framework.Application Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

EntityRecordHistoryForm.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

EntityRecordHistoryForm Class | Aptify.Framework.Application Namespace


EntityRecordHistoryForm.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

EntityRecordHistoryForm Class | Aptify.Framework.Application Namespace | EntityRecordHistoryForm.Dispose Overload List


EntityStoredProcedures Structure

For a list of all members of this type, see EntityStoredProcedures Members.

System.Object
ValueType
EntityStoredProcedures

public struct EntityStoredProcedures

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyApplication (in AptifyApplication.dll)

See Also

EntityStoredProcedures Members | Aptify.Framework.Application Namespace


EntityStoredProcedures Members

EntityStoredProcedures overview

Public Instance Fields

spAddToList
spCreate
spDeleteRelated
spDeleteSingle
spGetDependants
spGetRelated
spGetSingle
spRelinkDependants
spUpdate

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

EntityStoredProcedures Structure | Aptify.Framework.Application Namespace


EntityStoredProcedures Fields

The fields of the EntityStoredProcedures structure are listed below. For a complete list of EntityStoredProcedures structure members, see the EntityStoredProcedures Members topic.

Public Instance Fields

spAddToList
spCreate
spDeleteRelated
spDeleteSingle
spGetDependants
spGetRelated
spGetSingle
spRelinkDependants
spUpdate

See Also

EntityStoredProcedures Structure | Aptify.Framework.Application Namespace


EntityStoredProcedures.spAddToList Field

public spAddToList spAddToList;

See Also

EntityStoredProcedures Class | Aptify.Framework.Application Namespace


EntityStoredProcedures.spCreate Field

public spCreate spCreate;

See Also

EntityStoredProcedures Class | Aptify.Framework.Application Namespace


EntityStoredProcedures.spDeleteRelated Field

public spDeleteRelated spDeleteRelated;

See Also

EntityStoredProcedures Class | Aptify.Framework.Application Namespace


EntityStoredProcedures.spDeleteSingle Field

public spDeleteSingle spDeleteSingle;

See Also

EntityStoredProcedures Class | Aptify.Framework.Application Namespace


EntityStoredProcedures.spGetDependants Field

public spGetDependants spGetDependants;

See Also

EntityStoredProcedures Class | Aptify.Framework.Application Namespace


EntityStoredProcedures.spGetRelated Field

public spGetRelated spGetRelated;

See Also

EntityStoredProcedures Class | Aptify.Framework.Application Namespace


EntityStoredProcedures.spGetSingle Field

public spGetSingle spGetSingle;

See Also

EntityStoredProcedures Class | Aptify.Framework.Application Namespace


EntityStoredProcedures.spRelinkDependants Field

public spRelinkDependants spRelinkDependants;

See Also

EntityStoredProcedures Class | Aptify.Framework.Application Namespace


EntityStoredProcedures.spUpdate Field

public spUpdate spUpdate;

See Also

EntityStoredProcedures Class | Aptify.Framework.Application Namespace


Equality Class

Contains functionality that can be used to generically compare two objects for equality.

For a list of all members of this type, see Equality Members.

System.Object
Equality

public class Equality

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Under general comparison circumstances, Aptify regards booleans to be true if and only if they have the same numeric, string value. Therefore -1 and 1 are not considered equal boolean values. An attempt to cast to a boolean value will occur if one of the values is a boolen type or contains the value true or false and they are considered equal as strings.

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyUtility (in AptifyUtility.dll)

See Also

Equality Members | Aptify.Framework.Application Namespace


Equality Members

Equality overview

Public Static Methods

Equals Overloaded. Compares two objects for equality.

Public Instance Constructors

Equality Constructor Initializes a new instance of the Equality class.

Public Instance Methods

Equals (inherited from Object) | Overloaded. Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Equality Class | Aptify.Framework.Application Namespace


Equality Constructor

Initializes a new instance of the Equality class.

public Equality();

See Also

Equality Class | Aptify.Framework.Application Namespace


Equality Methods

The methods of the Equality class are listed below. For a complete list of Equality class members, see the Equality Members topic.

Public Static Methods

Equals Overloaded. Compares two objects for equality.

Public Instance Methods

Equals (inherited from Object) | Overloaded. Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Equality Class | Aptify.Framework.Application Namespace


Equals Method

Aptify 5.0 Software Development Kit (SDK)

Equality.Equals Method

Determines boolean equality.

Overload List

Determines boolean equality.

public static bool Equals(Boolean,Boolean);

Determines Date Equality.

public static bool Equals(DateTime,DateTime);

Determines Double Equality.

public static bool Equals(Double,Double);

Determines Integer Equality

public static bool Equals(Int32,Int32);

Determines Long Equality

public static bool Equals(Int64,Int64);

Inherited from Object.

public virtual bool Equals(Object);

Compares two objects for equality.

new public static bool Equals(Object,Object);

Compares two objects for equality.

public static bool Equals(Object,Object,Boolean,Boolean);

Compares two strings for equality.

public static bool Equals(String,String);

Compares two strings for equality.

public static bool Equals(String,String,Boolean,Boolean,Boolean);

See Also

Equality Class | Aptify.Framework.Application Namespace


Equality.Equals Method (Boolean, Boolean)

Determines boolean equality.

public static bool Equals(
Boolean Boolean1,
Boolean Boolean2
);

Parameters

Boolean1
Boolean2

Return Value

Remarks

In this case any non zero numeric values will be considered equal.

See Also

Equality Class | Aptify.Framework.Application Namespace | Equality.Equals Overload List


Equality.Equals Method (DateTime, DateTime)

Determines Date Equality.

public static bool Equals(
DateTime Date1,
DateTime Date2
);

Parameters

Date1
Date2

Return Value

Remarks

See Also

Equality Class | Aptify.Framework.Application Namespace | Equality.Equals Overload List


Equality.Equals Method (Double, Double)

Determines Double Equality.

public static bool Equals(
Double Double1,
Double Double2
);

Parameters

Double1
Double2

Return Value

Remarks

See Also

Equality Class | Aptify.Framework.Application Namespace | Equality.Equals Overload List


Equality.Equals Method (Int32, Int32)

Determines Integer Equality

public static bool Equals(
Int32 Integer1,
Int32 Integer2
);

Parameters

Integer1
Integer2

Return Value

Remarks

See Also

Equality Class | Aptify.Framework.Application Namespace | Equality.Equals Overload List


Equality.Equals Method (Int64, Int64)

Determines Long Equality

public static bool Equals(
Int64 Long1,
Int64 Long2
);

Parameters

Long1
Long2

Return Value

Remarks

See Also

Equality Class | Aptify.Framework.Application Namespace | Equality.Equals Overload List


Equality.Equals Method (Object, Object)

Compares two objects for equality.

new public static bool Equals(
Object Object1,
Object Object2
);

Parameters

Object1
An object to check for Equality.
Object2
An object to check for Equality.

Return Value

True if the objects can be considered equal. False if the objects cannot be considered equal.

Remarks

This will only be called if the objects are different types or an explicit Overload for that type has not been provided.

See Also

Equality Class | Aptify.Framework.Application Namespace | Equality.Equals Overload List


Equality.Equals Method (Object, Object, Boolean, Boolean)

Compares two objects for equality.

public static bool Equals(
Object Object1,
Object Object2,
Boolean IgnoreCase,
Boolean Trim
);

Parameters

Object1
An object to check for Equality.
Object2
An object to check for Equality.
IgnoreCase
If the objects are compared as strings, then do a case insensitive comparison.
Trim
If the objects are compared as strings, then do compare the strings after they have been trimmed.

Return Value

True if the objects can be considered equal. False if the objects cannot be considered equal.

Remarks

See Also

Equality Class | Aptify.Framework.Application Namespace | Equality.Equals Overload List


Equality.Equals Method (String, String)

Compares two strings for equality.

public static bool Equals(
String String1,
String String2
);

Parameters

String1
A string to check for Equality.
String2
A string to check for Equality.

Return Value

True if the objects can be considered equal. False if the objects cannot be considered equal.

Remarks

This will do a case insensitive comparison on trimmed strings, it will not attempt to cast strings to different types for performance reasons.

See Also

Equality Class | Aptify.Framework.Application Namespace | Equality.Equals Overload List


Equality.Equals Method (String, String, Boolean, Boolean, Boolean)

Compares two strings for equality.

public static bool Equals(
String String1,
String String2,
Boolean IgnoreCase,
Boolean Trim,
Boolean PerformConvertComparison
);

Parameters

String1
A string to check for Equality.
String2
A string to check for Equality.
IgnoreCase
Forces a case insensitive comparison.
Trim
Forces a compare on the strings after they have been trimmed.
PerformConvertComparison
If the strings are not considered equal at first then we will attempt to do comparisons with basic Type Conversion.

Return Value

True if the objects can be considered equal. False if the objects cannot be considered equal.

See Also

Equality Class | Aptify.Framework.Application Namespace | Equality.Equals Overload List


FindConstants Class

For a list of all members of this type, see FindConstants Members.

System.Object
FindConstants

public class FindConstants

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyGenericFind (in AptifyGenericFind.dll)

See Also

FindConstants Members | Aptify.Framework.Application Namespace


FindConstants Members

FindConstants overview

Public Static Methods

FindSelectMessage
GenericFindConfigurationMessage
GetAptifyFindCaption
GetFindRequiresFilterCaption
GetFindResultsErrorMessage
GetNoRecordsFoundMessage
GetResourceString

Public Instance Constructors

FindConstants Constructor Initializes a new instance of the FindConstants class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FindConstants Class | Aptify.Framework.Application Namespace


FindConstants Constructor

Initializes a new instance of the FindConstants class.

public FindConstants();

See Also

FindConstants Class | Aptify.Framework.Application Namespace


FindConstants Methods

The methods of the FindConstants class are listed below. For a complete list of FindConstants class members, see the FindConstants Members topic.

Public Static Methods

FindSelectMessage
GenericFindConfigurationMessage
GetAptifyFindCaption
GetFindRequiresFilterCaption
GetFindResultsErrorMessage
GetNoRecordsFoundMessage
GetResourceString

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FindConstants Class | Aptify.Framework.Application Namespace


FindConstants.FindSelectMessage Method

public static string FindSelectMessage();

See Also

FindConstants Class | Aptify.Framework.Application Namespace


FindConstants.GenericFindConfigurationMessage Method

public static string GenericFindConfigurationMessage(
UserCredentials UserCredentials,
String EntityName
);

See Also

FindConstants Class | Aptify.Framework.Application Namespace


FindConstants.GetAptifyFindCaption Method

public static string GetAptifyFindCaption();

See Also

FindConstants Class | Aptify.Framework.Application Namespace


FindConstants.GetFindRequiresFilterCaption Method

public static string GetFindRequiresFilterCaption();

See Also

FindConstants Class | Aptify.Framework.Application Namespace


FindConstants.GetFindResultsErrorMessage Method

public static string GetFindResultsErrorMessage();

See Also

FindConstants Class | Aptify.Framework.Application Namespace


FindConstants.GetNoRecordsFoundMessage Method

public static string GetNoRecordsFoundMessage();

See Also

FindConstants Class | Aptify.Framework.Application Namespace


FindConstants.GetResourceString Method

public static string GetResourceString(
String ResourceKey
);

See Also

FindConstants Class | Aptify.Framework.Application Namespace


FindMode Enumeration

public enum FindMode

Members

Member Name | Description
ShowResults |
GenerateSQL |

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyGenericFindBase (in AptifyGenericFindBase.dll)

See Also

Aptify.Framework.Application Namespace


GenericFind Class

For a list of all members of this type, see GenericFind Members.

System.Object
GenericFindBase
GenericFind

public class GenericFind : GenericFindBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyGenericFind (in AptifyGenericFind.dll)

See Also

GenericFind Members | Aptify.Framework.Application Namespace


GenericFind Members

GenericFind overview

Public Instance Constructors

GenericFind Constructor Initializes a new instance of the GenericFind class.

Public Instance Properties

SelectedID
SelectedName
SQL

Public Instance Methods

Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByName | Overloaded.
FindByName (inherited from GenericFindBase) | Overloaded.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ShowDialog | Overloaded.
ShowDialog (inherited from GenericFindBase) | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GenericFind Class | Aptify.Framework.Application Namespace


GenericFind Constructor

Initializes a new instance of the GenericFind class.

public GenericFind();

See Also

GenericFind Class | Aptify.Framework.Application Namespace


GenericFind Properties

The properties of the GenericFind class are listed below. For a complete list of GenericFind class members, see the GenericFind Members topic.

Public Instance Properties

SelectedID
SelectedName
SQL

See Also

GenericFind Class | Aptify.Framework.Application Namespace


SelectedID Property

Aptify 5.0 Software Development Kit (SDK)

GenericFind.SelectedID Property

public override Int64 SelectedID {get;}

See Also

GenericFind Class | Aptify.Framework.Application Namespace


SelectedName Property

Aptify 5.0 Software Development Kit (SDK)

GenericFind.SelectedName Property

public override String SelectedName {get;}

See Also

GenericFind Class | Aptify.Framework.Application Namespace


SQL Property

Aptify 5.0 Software Development Kit (SDK)

GenericFind.SQL Property

public override String SQL {get;}

See Also

GenericFind Class | Aptify.Framework.Application Namespace


GenericFind Methods

The methods of the GenericFind class are listed below. For a complete list of GenericFind class members, see the GenericFind Members topic.

Public Instance Methods

Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByName | Overloaded.
FindByName (inherited from GenericFindBase) | Overloaded.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ShowDialog | Overloaded.
ShowDialog (inherited from GenericFindBase) | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GenericFind Class | Aptify.Framework.Application Namespace


GenericFind.Config Method

public override void Config(
UserCredentials UserCredentials,
String EntityName,
FindMode Mode
);

See Also

GenericFind Class | Aptify.Framework.Application Namespace


FindByName Method

Aptify 5.0 Software Development Kit (SDK)

GenericFind.FindByName Method

Overload List

Inherited from GenericFindBase.

public virtual long FindByName(String,ref String&);

public override long FindByName(String,ref String&,String);

public override long FindByName(String,ref String&,String,Form);

Inherited from GenericFindBase.

public virtual long FindByName(String,ref String&,Form);

See Also

GenericFind Class | Aptify.Framework.Application Namespace


GenericFind.FindByName Method (String, String&, String)

public override long FindByName(
String NameToFind,
ref String& DisplayNameResult,
String HiddenWhereClause
);

See Also

GenericFind Class | Aptify.Framework.Application Namespace | GenericFind.FindByName Overload List


GenericFind.FindByName Method (String, String&, String, Form)

public override long FindByName(
String NameToFind,
ref String& DisplayNameResult,
String HiddenWhereClause,
Form ParentForm
);

See Also

GenericFind Class | Aptify.Framework.Application Namespace | GenericFind.FindByName Overload List


ShowDialog Method

Aptify 5.0 Software Development Kit (SDK)

GenericFind.ShowDialog Method

Overload List

Inherited from GenericFindBase.

public virtual DialogResult ShowDialog();

public override DialogResult ShowDialog(String);

public override DialogResult ShowDialog(String,Form);

Inherited from GenericFindBase.

public virtual DialogResult ShowDialog(Form);

See Also

GenericFind Class | Aptify.Framework.Application Namespace


GenericFind.ShowDialog Method (String)

public override DialogResult ShowDialog(
String HiddenWhereClause
);

See Also

GenericFind Class | Aptify.Framework.Application Namespace | GenericFind.ShowDialog Overload List


GenericFind.ShowDialog Method (String, Form)

public override DialogResult ShowDialog(
String HiddenWhereClause,
Form ParentForm
);

See Also

GenericFind Class | Aptify.Framework.Application Namespace | GenericFind.ShowDialog Overload List


GenericFindBase Class

For a list of all members of this type, see GenericFindBase Members.

System.Object
GenericFindBase
GenericFind

public class GenericFindBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyGenericFindBase (in AptifyGenericFindBase.dll)

See Also

GenericFindBase Members | Aptify.Framework.Application Namespace


GenericFindBase Members

GenericFindBase overview

Public Instance Constructors

GenericFindBase Constructor Initializes a new instance of the GenericFindBase class.

Public Instance Properties

SelectedID
SelectedName
SQL

Public Instance Methods

Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByName | Overloaded.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ShowDialog | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GenericFindBase Class | Aptify.Framework.Application Namespace


GenericFindBase Constructor

Initializes a new instance of the GenericFindBase class.

public GenericFindBase();

See Also

GenericFindBase Class | Aptify.Framework.Application Namespace


GenericFindBase Properties

The properties of the GenericFindBase class are listed below. For a complete list of GenericFindBase class members, see the GenericFindBase Members topic.

Public Instance Properties

SelectedID
SelectedName
SQL

See Also

GenericFindBase Class | Aptify.Framework.Application Namespace


SelectedID Property

Aptify 5.0 Software Development Kit (SDK)

GenericFindBase.SelectedID Property

public abstract Int64 SelectedID {get;}

See Also

GenericFindBase Class | Aptify.Framework.Application Namespace


SelectedName Property

Aptify 5.0 Software Development Kit (SDK)

GenericFindBase.SelectedName Property

public abstract String SelectedName {get;}

See Also

GenericFindBase Class | Aptify.Framework.Application Namespace


SQL Property

Aptify 5.0 Software Development Kit (SDK)

GenericFindBase.SQL Property

public abstract String SQL {get;}

See Also

GenericFindBase Class | Aptify.Framework.Application Namespace


GenericFindBase Methods

The methods of the GenericFindBase class are listed below. For a complete list of GenericFindBase class members, see the GenericFindBase Members topic.

Public Instance Methods

Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindByName | Overloaded.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ShowDialog | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GenericFindBase Class | Aptify.Framework.Application Namespace


GenericFindBase.Config Method

public abstract void Config(
UserCredentials UserCredentials,
String EntityName,
FindMode Mode
);

See Also

GenericFindBase Class | Aptify.Framework.Application Namespace


FindByName Method

Aptify 5.0 Software Development Kit (SDK)

GenericFindBase.FindByName Method

Overload List

public virtual long FindByName(String,ref String&);

public abstract long FindByName(String,ref String&,String);

public virtual long FindByName(String,ref String&,String,Form);

public virtual long FindByName(String,ref String&,Form);

See Also

GenericFindBase Class | Aptify.Framework.Application Namespace


GenericFindBase.FindByName Method (String, String&)

public virtual long FindByName(
String NameToFind,
ref String& DisplayNameResult
);

See Also

GenericFindBase Class | Aptify.Framework.Application Namespace | GenericFindBase.FindByName Overload List


GenericFindBase.FindByName Method (String, String&, String)

public abstract long FindByName(
String NameToFind,
ref String& DisplayNameResult,
String HiddenWhereClause
);

See Also

GenericFindBase Class | Aptify.Framework.Application Namespace | GenericFindBase.FindByName Overload List


GenericFindBase.FindByName Method (String, String&, String, Form)

public virtual long FindByName(
String NameToFind,
ref String& DisplayNameResult,
String HiddenWhereClause,
Form ParentForm
);

Parameters

NameToFind
DisplayNameResult
HiddenWhereClause
ParentForm

Return Value

Remarks

Added for Aptify 5.0. Couldn't make it MustOverride because it would break compatibility. For the same reason, the base implementation of this method delegates to the original must override version. The standard implementation of AptifyGenericFind will override this method.

See Also

GenericFindBase Class | Aptify.Framework.Application Namespace | GenericFindBase.FindByName Overload List


GenericFindBase.FindByName Method (String, String&, Form)

public virtual long FindByName(
String NameToFind,
ref String& DisplayNameResult,
Form ParentForm
);

See Also

GenericFindBase Class | Aptify.Framework.Application Namespace | GenericFindBase.FindByName Overload List


ShowDialog Method

Aptify 5.0 Software Development Kit (SDK)

GenericFindBase.ShowDialog Method

Overload List

public virtual DialogResult ShowDialog();

public abstract DialogResult ShowDialog(String);

public virtual DialogResult ShowDialog(String,Form);

public virtual DialogResult ShowDialog(Form);

See Also

GenericFindBase Class | Aptify.Framework.Application Namespace


GenericFindBase.ShowDialog Method ()

public virtual DialogResult ShowDialog();

See Also

GenericFindBase Class | Aptify.Framework.Application Namespace | GenericFindBase.ShowDialog Overload List


GenericFindBase.ShowDialog Method (String)

public abstract DialogResult ShowDialog(
String HiddenWhereClause
);

See Also

GenericFindBase Class | Aptify.Framework.Application Namespace | GenericFindBase.ShowDialog Overload List


GenericFindBase.ShowDialog Method (String, Form)

public virtual DialogResult ShowDialog(
String HiddenWhereClause,
Form ParentForm
);

Parameters

HiddenWhereClause
ParentForm

Return Value

Remarks

Added for Aptify 5.0. Couldn't make it MustOverride because it would break compatibility. For the same reason, the base implementation of this method delegates to the original must override version. The standard implementation of AptifyGenericFind will override this method.

See Also

GenericFindBase Class | Aptify.Framework.Application Namespace | GenericFindBase.ShowDialog Overload List


GenericFindBase.ShowDialog Method (Form)

public virtual DialogResult ShowDialog(
Form ParentForm
);

See Also

GenericFindBase Class | Aptify.Framework.Application Namespace | GenericFindBase.ShowDialog Overload List


GenericFindConfigurationException Class

For a list of all members of this type, see GenericFindConfigurationException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
GenericFindConfigurationException

public class GenericFindConfigurationException : BaseApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyGenericFind (in AptifyGenericFind.dll)

See Also

GenericFindConfigurationException Members | Aptify.Framework.Application Namespace


GenericFindConfigurationException Members

GenericFindConfigurationException overview

Public Instance Constructors

GenericFindConfigurationException Overloaded. Initializes a new instance of the GenericFindConfigurationException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Constructors

GenericFindConfigurationException Overloaded. Initializes a new instance of the GenericFindConfigurationException class.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GenericFindConfigurationException Class | Aptify.Framework.Application Namespace


GenericFindConfigurationException Constructor

Overload List

public GenericFindConfigurationException(UserCredentials,String);

public GenericFindConfigurationException(UserCredentials,String,Exception);

protected GenericFindConfigurationException(SerializationInfo,StreamingContext);

See Also

GenericFindConfigurationException Class | Aptify.Framework.Application Namespace


GenericFindConfigurationException Constructor (UserCredentials, String)

public GenericFindConfigurationException(
UserCredentials UserCredentials,
String EntityName
);

See Also

GenericFindConfigurationException Class | Aptify.Framework.Application Namespace | GenericFindConfigurationException Constructor Overload List


GenericFindConfigurationException Constructor (UserCredentials, String, Exception)

public GenericFindConfigurationException(
UserCredentials UserCredentials,
String EntityName,
Exception inner
);

See Also

GenericFindConfigurationException Class | Aptify.Framework.Application Namespace | GenericFindConfigurationException Constructor Overload List


GenericFindConfigurationException Constructor (SerializationInfo, StreamingContext)

protected GenericFindConfigurationException(
SerializationInfo info,
StreamingContext context
);

See Also

GenericFindConfigurationException Class | Aptify.Framework.Application Namespace | GenericFindConfigurationException Constructor Overload List


GenericFindConfigurationException Methods

The methods of the GenericFindConfigurationException class are listed below. For a complete list of GenericFindConfigurationException class members, see the GenericFindConfigurationException Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GenericFindConfigurationException Class | Aptify.Framework.Application Namespace


GenericFindConfigurationException.GetObjectData Method

public override void GetObjectData(
SerializationInfo info,
StreamingContext context
);

Implements

ISerializable.

See Also

GenericFindConfigurationException Class | Aptify.Framework.Application Namespace


IAptifyAction Interface

The IAptifyAction interface must be implemented by all Aptify Wizards that are configured using the EntityActions Subtype.

For a list of all members of this type, see IAptifyAction Members.

public interface IAptifyAction

Types that implement IAptifyAction

Type | Description
ExportWizard | Aptify AP Export Wizard
ImportWizard | Aptify AP Import Wizard
BatchWizard |
MarkToMarketWizard |
ExpandScheduledTransactions | Written by Ravi Nagarajan, October 13, 1999 The purpose of this object is to review Scheduled Transaction Group records in the database and create the associated scheduled transaction records based on the group attributes. This process was introduced starting with the 1.20 build to improve the speed of the order entry system. Rather than generating individual scheduled transaction records during the Order save process, we create a single record per order line from which we can later generate the individual scheduled transaction records.
InvoiceConsolidationWizard | User Interface Wizard for consolidation of invoices/payments/balances on an account. This wizard uses the InvoiceConsolidation object to perform the business logic for the user's selections.
LockBoxWizard | Displays a Wizard that walks users through importing a Lock Box File.
StandingOrderFulfillmentWizard | Aptify Standing Order Fulfillment Wizard GUI Class
AddToCampaign |
CampaignListBuilderWizard | Aptify Campaign List Import Wizard. This GUI component utilizes the CampaignListBuilderObject to perform its underlying operations.
CampaignSetupWizard |
CampaignImportWizard | Campaign Import Wizard User Interface Class(Form)
clsNewCase |
CommissionPaymentWizard |
CommitteeRenewalWizardForm |
OutlookContactLogImportWizard | Aptify Outlook Contact Log Import Wizard - uses the OutlookContactLogImport class to import Outlook email into the Aptify Contact Log.
CertificatePrintWizard | Displays a Wizard that walks users through printng certificates
ClassRegistrationWizard | Displays a Wizard that walks users through registering a person for a class
ScantronImportWizard |
BoothCombinationWizard |
FloorplanCopyWizard |
SyncWizard | Aptify Synchronization Wizard - Synchronizes data from Aptify Expo Floorplans/Booths to a 3rd party floorplanning tool in both directions, using the ExpoBoothSync object.
ContributionPaymentWizard |
PledgeMatchingObject |
HousingImportWizard | Aptify Housing Import Wizard Form, uses the Housing Import Object to import housing reservation details from hotels after the reservations have been processed.
HousingTransferWizard | Aptify Housing Transfer Wizard Form, uses the Housing Transfer Object to export housing reservation record(s) to hotel formats.
BulkInventoryTransferWizard |
InventoryReturnWizardForm | This class contains the Business logic used during the Inventory Return process.
ProductCostAdjustmentWizardForm |
CancellationWizForm |
CaptureWizForm |
BulkOrdersWizard | Implements a wizard UI that allows a user to create new bulk orders and import views of persons and/or companies into the BulkOrderCustomers sub-type.
AddPersonToCommitteesUI | This class is used to implement the entity action (wizard) that will allow a user to add one or more people from a view to one or more committee terms in one step. This class is also used from the Add To Committees Button that is part of the Persons User Interface form for the Committees tab of the Persons form.
OutlookSyncWizard | Aptify Outlook Contact Syncrhonization Wizard
NewProductVersionWizard | This wizard walks a user through the process of creating a new version of a particular product.
SubscriptionRenewal | This class is responsible for renewing subscriptions and supports execution through an Action interface, view extension as well as a Process Component. This component can be used with its type-specific members as well.
VirtualEntityWizard | This wizard provides a user interface to the VirtualEntityCreator object which in turns provides the underlying functionality to create new virtual entities within the Aptify platform based on the provided parameters.
EntityBulkOperationsWizardForm | Provides the user interface for the standard Aptify Entity Bulk Operations Wizard.
ServiceGeneratorForm |
ProcessFlowDebugRun | Debugger Class for Aptify Process Flows
DataPackerWizardForm | Provides the user interface for the standard Aptify Entity Data Packer Wizard.
DataUnpackerWizardForm | Provides the user interface for the standard Aptify Entity Data Unacker Wizard.
EntityPackerAction | Provides the user interface for the standard Aptify Entity Packer Wizard.
EntityPackerGUI |
FormTemplateCopier |
GenericImportGUI | Provides the user interface for the standard Aptify Generic Import Process Wizard.
GenericWizardGUI | This class implements the IAptifyAction interface and is responsible for loading the Generic Wizard form
TopicCodeSynchronizationForm |
UserSynchronizationForm |
frmScheduleMessage |
TemplateWizardForm | Provides the user interface for the standard Aptify Word Template Wizard.
SampleDataLoaderWizard | Class provides a user interface to load sample data from a sample database. This user interface utilizes the SampleDataLoader class to handle the actual process of loading sample data.
PubWizardForm |
SubscribeWizardForm |
SynchWizardForm |
ExportWizardForm | Provides Wizard functionality needed to export a View to Excel.

Remarks

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyApplication (in AptifyApplication.dll)

See Also

IAptifyAction Members | Aptify.Framework.Application Namespace


IAptifyAction Members

IAptifyAction overview

Public Instance Methods

DoAction Overloaded. The DoAction method is responsible for executing whatever code is placed in the function. In most cases, a developer will construct a set of private functions within the same class to accomplish the objectives of the wizard.

See Also

IAptifyAction Interface | Aptify.Framework.Application Namespace


IAptifyAction Methods

The methods of the IAptifyAction interface are listed below. For a complete list of IAptifyAction interface members, see the IAptifyAction Members topic.

Public Instance Methods

DoAction Overloaded. The DoAction method is responsible for executing whatever code is placed in the function. In most cases, a developer will construct a set of private functions within the same class to accomplish the objectives of the wizard.

See Also

IAptifyAction Interface | Aptify.Framework.Application Namespace


DoAction Method

Aptify 5.0 Software Development Kit (SDK)

IAptifyAction.DoAction Method

The DoAction method is responsible for executing whatever code is placed in the function. In most cases, a developer will construct a set of private functions within the same class to accomplish the objectives of the wizard.

Overload List

The DoAction method is responsible for executing whatever code is placed in the function. In most cases, a developer will construct a set of private functions within the same class to accomplish the objectives of the wizard.

void DoAction(AptifyApplication,Int64);

The DoAction method is responsible for executing whatever code is placed in the function. In most cases, a developer will construct a set of private functions within the same class to accomplish the objectives of the wizard.

void DoAction(AptifyApplication,Int64,Int64);

The DoAction method is responsible for executing whatever code is placed in the function. In most cases, a developer will construct a set of private functions within the same class to accomplish the objectives of the wizard.

void DoAction(AptifyApplication,Int64,Int64,params Object[]);

The DoAction method is responsible for executing whatever code is placed in the function. In most cases, a developer will construct a set of private functions within the same class to accomplish the objectives of the wizard.

void DoAction(AptifyApplication,Int64,params String[]);

See Also

IAptifyAction Interface | Aptify.Framework.Application Namespace


IAptifyAction.DoAction Method (AptifyApplication, Int64)

The DoAction method is responsible for executing whatever code is placed in the function. In most cases, a developer will construct a set of private functions within the same class to accomplish the objectives of the wizard.

void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID
);

Parameters

ApplicationObject
Aptify Application Object.
EntityID
Wizards are designed to operate on records in a particular entity. The EntityID passed into the DoAction function specifies which entity is being referenced.

Remarks

See Also

IAptifyAction Interface | Aptify.Framework.Application Namespace | IAptifyAction.DoAction Overload List


IAptifyAction.DoAction Method (AptifyApplication, Int64, Int64)

The DoAction method is responsible for executing whatever code is placed in the function. In most cases, a developer will construct a set of private functions within the same class to accomplish the objectives of the wizard.

void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID
);

Parameters

ApplicationObject
Aptify Application Object.
EntityID
Wizards are designed to operate on records in a particular entity. The EntityID passed into the DoAction function specifies which entity is being referenced.
ViewID
Primary key of the view from which the wizard was run.

Remarks

See Also

IAptifyAction Interface | Aptify.Framework.Application Namespace | IAptifyAction.DoAction Overload List


IAptifyAction.DoAction Method (AptifyApplication, Int64, Int64, Object[])

The DoAction method is responsible for executing whatever code is placed in the function. In most cases, a developer will construct a set of private functions within the same class to accomplish the objectives of the wizard.

void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID,
params Object[] SelectedItems
);

Parameters

ApplicationObject
Aptify Application Object.
EntityID
Wizards are designed to operate on records in a particular entity. The EntityID passed into the DoAction function specifies which entity is being referenced.
ViewID
Primary key of the view from which the wizard was run.
SelectedItems
Array list of the IDs of the records that were selected in the view when the wizard button was clicked.

Remarks

See Also

IAptifyAction Interface | Aptify.Framework.Application Namespace | IAptifyAction.DoAction Overload List


IAptifyAction.DoAction Method (AptifyApplication, Int64, String[])

The DoAction method is responsible for executing whatever code is placed in the function. In most cases, a developer will construct a set of private functions within the same class to accomplish the objectives of the wizard.

void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
params String[] SelectedItems
);

Parameters

ApplicationObject
Aptify Application Object.
EntityID
Wizards are designed to operate on records in a particular entity. The EntityID passed into the DoAction function specifies which entity is being referenced.
SelectedItems
Array list of the IDs of the records that were selected in the view when the wizard button was clicked.

Remarks

See Also

IAptifyAction Interface | Aptify.Framework.Application Namespace | IAptifyAction.DoAction Overload List


IAptifyObjectViewer Interface

Defines Method and Properties for an object that needs to display Generic Entity Object viewer.

For a list of all members of this type, see IAptifyObjectViewer Members.

public interface IAptifyObjectViewer

Types that implement IAptifyObjectViewer

Type | Description
ObjectViewer |

Remarks

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyApplication (in AptifyApplication.dll)

See Also

IAptifyObjectViewer Members | Aptify.Framework.Application Namespace


IAptifyObjectViewer Members

IAptifyObjectViewer overview

Public Instance Properties

EntityName | Name of the entity object.
RecordID | Record ID of the entity object.

Public Instance Methods

DisplayViewer | Displays the viewer form and returns the user selection like OK, CANCEL etc.
EntitySaved |
Show | Displays the viewer form in non-modal mode.
ShowDialog | Overloaded. Displays the viewer form in modal mode.
ShowReadOnlyDialog | Overloaded. Displays the viewer form in read only mode. User cannot make any changes to the form data.

See Also

IAptifyObjectViewer Interface | Aptify.Framework.Application Namespace


IAptifyObjectViewer Properties

The properties of the IAptifyObjectViewer interface are listed below. For a complete list of IAptifyObjectViewer interface members, see the IAptifyObjectViewer Members topic.

Public Instance Properties

EntityName | Name of the entity object.
RecordID | Record ID of the entity object.

See Also

IAptifyObjectViewer Interface | Aptify.Framework.Application Namespace


EntityName Property

Aptify 5.0 Software Development Kit (SDK)

IAptifyObjectViewer.EntityName Property

Name of the entity object.

String EntityName {get; set;}

Property Value

Remarks

See Also

IAptifyObjectViewer Interface | Aptify.Framework.Application Namespace


RecordID Property

Aptify 5.0 Software Development Kit (SDK)

IAptifyObjectViewer.RecordID Property

Record ID of the entity object.

Int64 RecordID {get; set;}

Property Value

Remarks

See Also

IAptifyObjectViewer Interface | Aptify.Framework.Application Namespace


IAptifyObjectViewer Methods

The methods of the IAptifyObjectViewer interface are listed below. For a complete list of IAptifyObjectViewer interface members, see the IAptifyObjectViewer Members topic.

Public Instance Methods

DisplayViewer | Displays the viewer form and returns the user selection like OK, CANCEL etc.
EntitySaved |
Show | Displays the viewer form in non-modal mode.
ShowDialog | Overloaded. Displays the viewer form in modal mode.
ShowReadOnlyDialog | Overloaded. Displays the viewer form in read only mode. User cannot make any changes to the form data.

See Also

IAptifyObjectViewer Interface | Aptify.Framework.Application Namespace


IAptifyObjectViewer.DisplayViewer Method

Displays the viewer form and returns the user selection like OK, CANCEL etc.

DialogResult DisplayViewer(
ref AptifyGenericEntityBase& GE,
Boolean ShowDialog,
Form parentForm
);

Parameters

GE
A valid instantiated Aptify Generic Entity object.
ShowDialog
Flag indicating if the viewer need to be displayed as modal form.
parentForm
A valid reference to parent form object of the viewer.

Return Value

Remarks

See Also

IAptifyObjectViewer Interface | Aptify.Framework.Application Namespace


IAptifyObjectViewer.EntitySaved Method

void EntitySaved(
Int64 RecordID
);

See Also

IAptifyObjectViewer Interface | Aptify.Framework.Application Namespace


IAptifyObjectViewer.Show Method

Displays the viewer form in non-modal mode.

void Show(
ref AptifyGenericEntityBase& GE
);

Parameters

GE
A valid instantiated Aptify Generic Entity object.

Remarks

See Also

IAptifyObjectViewer Interface | Aptify.Framework.Application Namespace


ShowDialog Method

Aptify 5.0 Software Development Kit (SDK)

IAptifyObjectViewer.ShowDialog Method

Displays the viewer form in modal mode.

Overload List

Displays the viewer form in modal mode.

DialogResult ShowDialog(ref AptifyGenericEntityBase&);

Displays the viewer form in modal mode.

DialogResult ShowDialog(ref AptifyGenericEntityBase&,Form);

See Also

IAptifyObjectViewer Interface | Aptify.Framework.Application Namespace


IAptifyObjectViewer.ShowDialog Method (AptifyGenericEntityBase&)

Displays the viewer form in modal mode.

DialogResult ShowDialog(
ref AptifyGenericEntityBase& GE
);

Parameters

GE
A valid instantiated Aptify Generic Entity object.

Return Value

Remarks

See Also

IAptifyObjectViewer Interface | Aptify.Framework.Application Namespace | IAptifyObjectViewer.ShowDialog Overload List


IAptifyObjectViewer.ShowDialog Method (AptifyGenericEntityBase&, Form)

Displays the viewer form in modal mode.

DialogResult ShowDialog(
ref AptifyGenericEntityBase& GE,
Form parentForm
);

Parameters

GE
A valid instantiated Aptify Generic Entity object.
parentForm
A valid reference to parent form object of the viewer.

Return Value

Remarks

See Also

IAptifyObjectViewer Interface | Aptify.Framework.Application Namespace | IAptifyObjectViewer.ShowDialog Overload List


ShowReadOnlyDialog Method

Aptify 5.0 Software Development Kit (SDK)

IAptifyObjectViewer.ShowReadOnlyDialog Method

Displays the viewer form in read only mode. User cannot make any changes to the form data.

Overload List

Displays the viewer form in read only mode. User cannot make any changes to the form data.

void ShowReadOnlyDialog(AptifyGenericEntityBase);

Displays the viewer form in read only mode. User cannot make any changes to the form data.

void ShowReadOnlyDialog(AptifyGenericEntityBase,Form);

See Also

IAptifyObjectViewer Interface | Aptify.Framework.Application Namespace


IAptifyObjectViewer.ShowReadOnlyDialog Method (AptifyGenericEntityBase)

Displays the viewer form in read only mode. User cannot make any changes to the form data.

void ShowReadOnlyDialog(
AptifyGenericEntityBase GE
);

Parameters

GE
A valid instantiated Aptify Generic Entity object.

Remarks

See Also

IAptifyObjectViewer Interface | Aptify.Framework.Application Namespace | IAptifyObjectViewer.ShowReadOnlyDialog Overload List


IAptifyObjectViewer.ShowReadOnlyDialog Method (AptifyGenericEntityBase, Form)

Displays the viewer form in read only mode. User cannot make any changes to the form data.

void ShowReadOnlyDialog(
AptifyGenericEntityBase GE,
Form parentForm
);

Parameters

GE
A valid instantiated Aptify Generic Entity object.
parentForm
A valid reference to parent form object of the viewer.

Remarks

See Also

IAptifyObjectViewer Interface | Aptify.Framework.Application Namespace | IAptifyObjectViewer.ShowReadOnlyDialog Overload List


IAptifyViewDialog Interface

For a list of all members of this type, see IAptifyViewDialog Members.

public interface IAptifyViewDialog

Types that implement IAptifyViewDialog

Type | Description
ViewsDialog | Aptify View Properties Dialog

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyApplication (in AptifyApplication.dll)

See Also

IAptifyViewDialog Members | Aptify.Framework.Application Namespace


IAptifyViewDialog Members

IAptifyViewDialog overview

Public Instance Properties

ViewsEntityObject

Public Instance Methods

LoadView |
NewView | Overloaded.
ShowViewsDialog | Overloaded.

See Also

IAptifyViewDialog Interface | Aptify.Framework.Application Namespace


IAptifyViewDialog Properties

The properties of the IAptifyViewDialog interface are listed below. For a complete list of IAptifyViewDialog interface members, see the IAptifyViewDialog Members topic.

Public Instance Properties

ViewsEntityObject

See Also

IAptifyViewDialog Interface | Aptify.Framework.Application Namespace


ViewsEntityObject Property

Aptify 5.0 Software Development Kit (SDK)

IAptifyViewDialog.ViewsEntityObject Property

AptifyGenericEntityBase ViewsEntityObject {get;}

See Also

IAptifyViewDialog Interface | Aptify.Framework.Application Namespace


IAptifyViewDialog Methods

The methods of the IAptifyViewDialog interface are listed below. For a complete list of IAptifyViewDialog interface members, see the IAptifyViewDialog Members topic.

Public Instance Methods

LoadView |
NewView | Overloaded.
ShowViewsDialog | Overloaded.

See Also

IAptifyViewDialog Interface | Aptify.Framework.Application Namespace


IAptifyViewDialog.LoadView Method

void LoadView(
AptifyApplication Application,
Int64 ViewID
);

See Also

IAptifyViewDialog Interface | Aptify.Framework.Application Namespace


NewView Method

Aptify 5.0 Software Development Kit (SDK)

IAptifyViewDialog.NewView Method

Overload List

void NewView(AptifyApplication,Int64);

void NewView(AptifyApplication,Int64,Int64);

See Also

IAptifyViewDialog Interface | Aptify.Framework.Application Namespace


IAptifyViewDialog.NewView Method (AptifyApplication, Int64)

void NewView(
AptifyApplication Application,
Int64 EntityID
);

See Also

IAptifyViewDialog Interface | Aptify.Framework.Application Namespace | IAptifyViewDialog.NewView Overload List


IAptifyViewDialog.NewView Method (AptifyApplication, Int64, Int64)

void NewView(
AptifyApplication Application,
Int64 EntityID,
Int64 ViewCategoryID
);

See Also

IAptifyViewDialog Interface | Aptify.Framework.Application Namespace | IAptifyViewDialog.NewView Overload List


ShowViewsDialog Method

Aptify 5.0 Software Development Kit (SDK)

IAptifyViewDialog.ShowViewsDialog Method

Overload List

DialogResult ShowViewsDialog();

DialogResult ShowViewsDialog(IWin32Window);

See Also

IAptifyViewDialog Interface | Aptify.Framework.Application Namespace


IAptifyViewDialog.ShowViewsDialog Method ()

DialogResult ShowViewsDialog();

See Also

IAptifyViewDialog Interface | Aptify.Framework.Application Namespace | IAptifyViewDialog.ShowViewsDialog Overload List


IAptifyViewDialog.ShowViewsDialog Method (IWin32Window)

DialogResult ShowViewsDialog(
IWin32Window owner
);

See Also

IAptifyViewDialog Interface | Aptify.Framework.Application Namespace | IAptifyViewDialog.ShowViewsDialog Overload List


InfiniteStatusForm Class

For a list of all members of this type, see InfiniteStatusForm Members.

System.Object
InfiniteStatusForm

public class InfiniteStatusForm

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyUtility (in AptifyUtility.dll)

See Also

InfiniteStatusForm Members | Aptify.Framework.Application Namespace


InfiniteStatusForm Members

InfiniteStatusForm overview

Public Instance Constructors

InfiniteStatusForm Constructor Initializes a new instance of the InfiniteStatusForm class.

Public Instance Properties

ShowInTaskBar
Text
TopMost

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
StartRun |
StopRun |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

InfiniteStatusForm Class | Aptify.Framework.Application Namespace


InfiniteStatusForm Constructor

Initializes a new instance of the InfiniteStatusForm class.

public InfiniteStatusForm();

See Also

InfiniteStatusForm Class | Aptify.Framework.Application Namespace


InfiniteStatusForm Properties

The properties of the InfiniteStatusForm class are listed below. For a complete list of InfiniteStatusForm class members, see the InfiniteStatusForm Members topic.

Public Instance Properties

ShowInTaskBar
Text
TopMost

See Also

InfiniteStatusForm Class | Aptify.Framework.Application Namespace


ShowInTaskBar Property

Aptify 5.0 Software Development Kit (SDK)

InfiniteStatusForm.ShowInTaskBar Property

public Boolean ShowInTaskBar {get; set;}

See Also

InfiniteStatusForm Class | Aptify.Framework.Application Namespace


Text Property

Aptify 5.0 Software Development Kit (SDK)

InfiniteStatusForm.Text Property

public String Text {get; set;}

See Also

InfiniteStatusForm Class | Aptify.Framework.Application Namespace


TopMost Property

Aptify 5.0 Software Development Kit (SDK)

InfiniteStatusForm.TopMost Property

public Boolean TopMost {get; set;}

See Also

InfiniteStatusForm Class | Aptify.Framework.Application Namespace


InfiniteStatusForm Methods

The methods of the InfiniteStatusForm class are listed below. For a complete list of InfiniteStatusForm class members, see the InfiniteStatusForm Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
StartRun |
StopRun |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

InfiniteStatusForm Class | Aptify.Framework.Application Namespace


InfiniteStatusForm.StartRun Method

public void StartRun();

See Also

InfiniteStatusForm Class | Aptify.Framework.Application Namespace


InfiniteStatusForm.StopRun Method

public void StopRun();

See Also

InfiniteStatusForm Class | Aptify.Framework.Application Namespace


InstanceCreator Class

Class used to instantiate late bound objects.

For a list of all members of this type, see InstanceCreator Members.

System.Object
InstanceCreator

public class InstanceCreator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

The InstanceCreator was designed to consolidate all of the functionality needed to dynamically create instances of needed types. All late bound instantiations should be created through this object. Currently all of its members are static, therefore the InstanceCreator does not need to be instantiated.

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyUtility (in AptifyUtility.dll)

See Also

InstanceCreator Members | Aptify.Framework.Application Namespace


InstanceCreator Members

InstanceCreator overview

Public Static Properties

CreateInstanceFromName | Overloaded. This method will attempt to dynamically create an instance of a .Net Type from an assembly with the specified name.
CreateInstanceFromPath | Overloaded.
CreateInstance |
CreateCOMInstance |

Public Instance Constructors

InstanceCreator Constructor Initializes a new instance of the InstanceCreator class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

InstanceCreator Class | Aptify.Framework.Application Namespace


InstanceCreator Constructor

Initializes a new instance of the InstanceCreator class.

public InstanceCreator();

See Also

InstanceCreator Class | Aptify.Framework.Application Namespace


InstanceCreator Properties

The properties of the InstanceCreator class are listed below. For a complete list of InstanceCreator class members, see the InstanceCreator Members topic.

Public Static Properties

CreateInstanceFromName | Overloaded. This method will attempt to dynamically create an instance of a .Net Type from an assembly with the specified name.
CreateInstanceFromPath | Overloaded.
CreateInstance |
CreateCOMInstance |

See Also

InstanceCreator Class | Aptify.Framework.Application Namespace


CreateCOMInstance Property

Aptify 5.0 Software Development Kit (SDK)

InstanceCreator.CreateCOMInstance Property

public static Object this[
String AssemblyName,
String TypeName
] {get;}

See Also

InstanceCreator Class | Aptify.Framework.Application Namespace


CreateInstance Property

Aptify 5.0 Software Development Kit (SDK)

InstanceCreator.CreateInstance Property

public static Object this[
String AssemblyInfo,
String TypeName
] {get;}

See Also

InstanceCreator Class | Aptify.Framework.Application Namespace


Object Property

Aptify 5.0 Software Development Kit (SDK)

InstanceCreator.Object Property

This method will attempt to dynamically create an instance of a .Net Type from an assembly with the specified name.

Overload List

This method will attempt to dynamically create an instance of a .Net Type from an assembly with the specified name.

public static Object this[String, String] {get;}

public static Object this[String, String, Boolean] {get;}

See Also

InstanceCreator Class | Aptify.Framework.Application Namespace


CreateInstanceFromName Property (String, String)

Aptify 5.0 Software Development Kit (SDK)

InstanceCreator.CreateInstanceFromName Property (String, String)

This method will attempt to dynamically create an instance of a .Net Type from an assembly with the specified name.

public static Object this[
String AssemblyName,
String TypeName
] {get;}

Parameters

AssemblyName
TypeName

Remarks

This call is case insensitive.

See Also

InstanceCreator Class | Aptify.Framework.Application Namespace | InstanceCreator.Object Overload List


CreateInstanceFromName Property (String, String, Boolean)

Aptify 5.0 Software Development Kit (SDK)

InstanceCreator.CreateInstanceFromName Property (String, String, Boolean)

public static Object this[
String AssemblyName,
String TypeName,
Boolean IgnoreCase
] {get;}

See Also

InstanceCreator Class | Aptify.Framework.Application Namespace | InstanceCreator.Object Overload List


Object Property

Aptify 5.0 Software Development Kit (SDK)

InstanceCreator.Object Property

Overload List

public static Object this[String, String] {get;}

This method will attempt to dynamically create an instance of a .Net Type from an assembly with the specified path.

public static Object this[String, String, Boolean] {get;}

See Also

InstanceCreator Class | Aptify.Framework.Application Namespace


CreateInstanceFromPath Property (String, String)

Aptify 5.0 Software Development Kit (SDK)

InstanceCreator.CreateInstanceFromPath Property (String, String)

public static Object this[
String AssemblyName,
String TypeName
] {get;}

See Also

InstanceCreator Class | Aptify.Framework.Application Namespace | InstanceCreator.Object Overload List


CreateInstanceFromPath Property (String, String, Boolean)

Aptify 5.0 Software Development Kit (SDK)

InstanceCreator.CreateInstanceFromPath Property (String, String, Boolean)

This method will attempt to dynamically create an instance of a .Net Type from an assembly with the specified path.

public static Object this[
String AssemblyName,
String TypeName,
Boolean IgnoreCase
] {get;}

Parameters

AssemblyName
TypeName
IgnoreCase

Property Value

Remarks

This call is case insensitive.

See Also

InstanceCreator Class | Aptify.Framework.Application Namespace | InstanceCreator.Object Overload List


IStatus Interface

This interface should be implemented by objects that can raise status events as they process.

For a list of all members of this type, see IStatus Members.

Aptify.Framework.Application.IStatus
IEntityBulkOperationProcessor
IMessageEngine

public interface IStatus

Types that implement IStatus

Type | Description
BaseFieldsEntity | Provides additional functionality required during the save of an Aptify Base Fields entity record.
EntityBulkOperationProcess | The standard Aptify implementation of the IEntityBulkOperationProcessor interface.
MessageEngine | The standard Aptify implementation of IMessageEngine. The implementation of IProcessComponent is for use with the [Send Message Run] process flow.

Remarks

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyUtility (in AptifyUtility.dll)

See Also

IStatus Members | Aptify.Framework.Application Namespace


IStatus Members

IStatus overview

Public Instance Properties

Status The current status of the operation.

Public Instance Events

Canceled | If the Run method is successfully canceled then this event will be raised.
Finished | This event is raised when the Run method has completed.
StatusChanged |

See Also

IStatus Interface | Aptify.Framework.Application Namespace


IStatus Properties

The properties of the IStatus interface are listed below. For a complete list of IStatus interface members, see the IStatus Members topic.

Public Instance Properties

Status The current status of the operation.

See Also

IStatus Interface | Aptify.Framework.Application Namespace


Status Property

Aptify 5.0 Software Development Kit (SDK)

IStatus.Status Property

The current status of the operation.

Status Status {get;}

Property Value

Remarks

See Also

IStatus Interface | Aptify.Framework.Application Namespace


IStatus Events

The events of the IStatus interface are listed below. For a complete list of IStatus interface members, see the IStatus Members topic.

Public Instance Events

Canceled | If the Run method is successfully canceled then this event will be raised.
Finished | This event is raised when the Run method has completed.
StatusChanged |

See Also

IStatus Interface | Aptify.Framework.Application Namespace


IStatus.EventHandler Event

If the Run method is successfully canceled then this event will be raised.

event EventHandler Canceled;

Remarks

See Also

IStatus Interface | Aptify.Framework.Application Namespace


IStatus.EventHandler Event

This event is raised when the Run method has completed.

event EventHandler Finished;

See Also

IStatus Interface | Aptify.Framework.Application Namespace


IStatus.StatusChangedEventHandler Event

event StatusChangedEventHandler StatusChanged;

Event Data

The event handler receives an argument of type StatusChangedEventArgs containing data related to this event. The following StatusChangedEventArgs property provides information specific to this event.

Property | Description
Status |

See Also

IStatus Interface | Aptify.Framework.Application Namespace


ListItem Class

For a list of all members of this type, see ListItem Members.

System.Object
ListItem<KeyType,DataType>
ListItem

public class ListItem : ListItem<KeyType,DataType>

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyUtility (in AptifyUtility.dll)

See Also

ListItem Members | Aptify.Framework.Application Namespace


ListItem Members

ListItem overview

Public Instance Constructors

ListItem Overloaded. Initializes a new instance of the ListItem class.

Public Instance Properties

Data (inherited from ListItem<KeyType,DataType>) |
Key | Overloaded.
Text |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ListItem<KeyType,DataType>) | Returns the String Version of the ListItem

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ListItem Class | Aptify.Framework.Application Namespace


ListItem Constructor

Initializes a new instance of the ListItem class.

Overload List

Initializes a new instance of the ListItem class.

public ListItem();

public ListItem(Object);

public ListItem(String);

public ListItem(String,Object);

See Also

ListItem Class | Aptify.Framework.Application Namespace


ListItem Constructor ()

Initializes a new instance of the ListItem class.

public ListItem();

See Also

ListItem Class | Aptify.Framework.Application Namespace | ListItem Constructor Overload List


ListItem Constructor (String)

public ListItem(
String Text
);

See Also

ListItem Class | Aptify.Framework.Application Namespace | ListItem Constructor Overload List


ListItem Constructor (Object)

public ListItem(
Object Data
);

See Also

ListItem Class | Aptify.Framework.Application Namespace | ListItem Constructor Overload List


ListItem Constructor (String, Object)

public ListItem(
String Text,
Object Data
);

See Also

ListItem Class | Aptify.Framework.Application Namespace | ListItem Constructor Overload List


ListItem Properties

The properties of the ListItem class are listed below. For a complete list of ListItem class members, see the ListItem Members topic.

Public Instance Properties

Data (inherited from ListItem<KeyType,DataType>) |
Key | Overloaded.
Text |

See Also

ListItem Class | Aptify.Framework.Application Namespace


Key Property

Aptify 5.0 Software Development Kit (SDK)

ListItem.Key Property

public override String Key {get; set;}

See Also

ListItem Class | Aptify.Framework.Application Namespace


Text Property

Aptify 5.0 Software Development Kit (SDK)

ListItem.Text Property

public String Text {get; set;}

See Also

ListItem Class | Aptify.Framework.Application Namespace


ListItem<KeyType,DataType> Class

Used to represent any Keyed Object.

For a list of all members of this type, see ListItem<KeyType,DataType> Members.

System.Object
ListItem<KeyType,DataType>
ListItem

public class ListItem<KeyType,DataType>

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyUtility (in AptifyUtility.dll)

See Also

ListItem<KeyType,DataType> Members | Aptify.Framework.Application Namespace


ListItem<KeyType,DataType> Members

ListItem<KeyType,DataType> overview

Public Instance Constructors

ListItem<KeyType,DataType> Overloaded. Initializes a new instance of the ListItem<KeyType,DataType> class.

Public Instance Properties

Data |
Key | A key used to identify a List Item.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns the String Version of the ListItem

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ListItem<KeyType,DataType> Class | Aptify.Framework.Application Namespace


ListItem<KeyType,DataType> Constructor

Overload List

public ListItem<KeyType,DataType>(ListItem<KeyType,DataType>.KeyType);

public ListItem<KeyType,DataType>(ListItem<KeyType,DataType>.KeyType,ListItem<KeyType,DataType>.DataType);

public ListItem<KeyType,DataType>(ListItem<KeyType,DataType>.DataType);

See Also

ListItem<KeyType,DataType> Class | Aptify.Framework.Application Namespace


ListItem<KeyType,DataType> Constructor (KeyType)

public ListItem<KeyType,DataType>(
ListItem<KeyType,DataType>.KeyType Key
);

See Also

ListItem<KeyType,DataType> Class | Aptify.Framework.Application Namespace | ListItem<KeyType,DataType> Constructor Overload List


ListItem<KeyType,DataType> Constructor (DataType)

public ListItem<KeyType,DataType>(
ListItem<KeyType,DataType>.DataType Data
);

See Also

ListItem<KeyType,DataType> Class | Aptify.Framework.Application Namespace | ListItem<KeyType,DataType> Constructor Overload List


ListItem<KeyType,DataType> Constructor (KeyType, DataType)

public ListItem<KeyType,DataType>(
ListItem<KeyType,DataType>.KeyType Key,
ListItem<KeyType,DataType>.DataType Data
);

See Also

ListItem<KeyType,DataType> Class | Aptify.Framework.Application Namespace | ListItem<KeyType,DataType> Constructor Overload List


ListItem<KeyType,DataType> Properties

The properties of the ListItem<KeyType,DataType> class are listed below. For a complete list of ListItem<KeyType,DataType> class members, see the ListItem<KeyType,DataType> Members topic.

Public Instance Properties

Data |
Key | A key used to identify a List Item.

See Also

ListItem<KeyType,DataType> Class | Aptify.Framework.Application Namespace


Data Property

Aptify 5.0 Software Development Kit (SDK)

ListItem<KeyType,DataType>.Data Property

public virtual ListItem<KeyType,DataType>.DataType Data {get; set;}

See Also

ListItem<KeyType,DataType> Class | Aptify.Framework.Application Namespace


Key Property

Aptify 5.0 Software Development Kit (SDK)

ListItem<KeyType,DataType>.Key Property

A key used to identify a List Item.

public virtual ListItem<KeyType,DataType>.KeyType Key {get; set;}

Property Value

Remarks

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown when the key is set to Null.

See Also

ListItem<KeyType,DataType> Class | Aptify.Framework.Application Namespace


ListItem<KeyType,DataType> Methods

The methods of the ListItem<KeyType,DataType> class are listed below. For a complete list of ListItem<KeyType,DataType> class members, see the ListItem<KeyType,DataType> Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns the String Version of the ListItem

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ListItem<KeyType,DataType> Class | Aptify.Framework.Application Namespace


ListItem<KeyType,DataType>.ToString Method

Returns the String Version of the ListItem

public override string ToString();

Return Value

Remarks

Returns the empty string or the String representation of the Key.

See Also

ListItem<KeyType,DataType> Class | Aptify.Framework.Application Namespace


MathFunctions Class

Contains

For a list of all members of this type, see MathFunctions Members.

System.Object
MathFunctions

public class MathFunctions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyUtility (in AptifyUtility.dll)

See Also

MathFunctions Members | Aptify.Framework.Application Namespace


MathFunctions Members

MathFunctions overview

Public Static Methods

Round Rounds a number to a user-defined number of significant digits or to the nearest integer if digits is not specified. Note that this function uses symmetric arithmetic rounding which matches the rounding algorithm used by SQL Server. Values above 0 at the mid-point of the rounding range will round to the next higher number in the rounding range. Values below 0 at the mid-point of the rounding range will round to the next lower number in the rounding range. Example: value = 2.5, digits = 0: Returns = 3 value = -2.5, digits = 0: Returns = -3 value = 2.6, digits = 0: Returns = 3 value = 2.4, digits = 0: Returns = 2 value = -2.4, digits = 0: Returns = -2 value = -2.6, digits = 0: Returns = -3

Public Instance Constructors

MathFunctions Constructor Initializes a new instance of the MathFunctions class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MathFunctions Class | Aptify.Framework.Application Namespace


MathFunctions Constructor

Initializes a new instance of the MathFunctions class.

public MathFunctions();

See Also

MathFunctions Class | Aptify.Framework.Application Namespace


MathFunctions Methods

The methods of the MathFunctions class are listed below. For a complete list of MathFunctions class members, see the MathFunctions Members topic.

Public Static Methods

Round Rounds a number to a user-defined number of significant digits or to the nearest integer if digits is not specified. Note that this function uses symmetric arithmetic rounding which matches the rounding algorithm used by SQL Server. Values above 0 at the mid-point of the rounding range will round to the next higher number in the rounding range. Values below 0 at the mid-point of the rounding range will round to the next lower number in the rounding range. Example: value = 2.5, digits = 0: Returns = 3 value = -2.5, digits = 0: Returns = -3 value = 2.6, digits = 0: Returns = 3 value = 2.4, digits = 0: Returns = 2 value = -2.4, digits = 0: Returns = -2 value = -2.6, digits = 0: Returns = -3

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MathFunctions Class | Aptify.Framework.Application Namespace


MathFunctions.Round Method

Rounds a number to a user-defined number of significant digits or to the nearest integer if digits is not specified. Note that this function uses symmetric arithmetic rounding which matches the rounding algorithm used by SQL Server. Values above 0 at the mid-point of the rounding range will round to the next higher number in the rounding range. Values below 0 at the mid-point of the rounding range will round to the next lower number in the rounding range. Example: value = 2.5, digits = 0: Returns = 3 value = -2.5, digits = 0: Returns = -3 value = 2.6, digits = 0: Returns = 3 value = 2.4, digits = 0: Returns = 2 value = -2.4, digits = 0: Returns = -2 value = -2.6, digits = 0: Returns = -3

public static decimal Round(
Decimal value,
Int32 digits
);

Parameters

value
A decimal value to be rounded
digits
The number of significant digits (precision) in the return value.

Return Value

value rounded to the number of significant digits specified by digits.

Remarks

See Also

MathFunctions Class | Aptify.Framework.Application Namespace


ReservedSQLParser Class

For a list of all members of this type, see ReservedSQLParser Members.

System.Object
ReservedSQLParser

public class ReservedSQLParser

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyApplication (in AptifyApplication.dll)

See Also

ReservedSQLParser Members | Aptify.Framework.Application Namespace


ReservedSQLParser Members

ReservedSQLParser overview

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsReservedWord |
TokenType |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ReservedSQLParser Class | Aptify.Framework.Application Namespace


ReservedSQLParser Methods

The methods of the ReservedSQLParser class are listed below. For a complete list of ReservedSQLParser class members, see the ReservedSQLParser Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsReservedWord |
TokenType |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ReservedSQLParser Class | Aptify.Framework.Application Namespace


ReservedSQLParser.IsReservedWord Method

public bool IsReservedWord(
String Token
);

See Also

ReservedSQLParser Class | Aptify.Framework.Application Namespace


ReservedSQLParser.TokenType Method

public SQLTokenType TokenType(
String Token
);

See Also

ReservedSQLParser Class | Aptify.Framework.Application Namespace


ReservedSQLParser.SQLTokenType Enumeration

public enum ReservedSQLParser.SQLTokenType

Members

Member Name | Description
KeyWord |
SystemStoredProcedure |
SystemFunction |
SystemTable |
Text |

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyApplication (in AptifyApplication.dll)

See Also

Aptify.Framework.Application Namespace


ShowDependenciesForm Class

This form will display a list of record dependencies that exist for a given entity record. Record dependencies are determined using the GetEntityDependencies() method on the Application Object. In addition, this class provides a constructor where a custom defined set of dependencies can be provided.

For a list of all members of this type, see ShowDependenciesForm Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
ShowDependenciesForm

public class ShowDependenciesForm : Form

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyApplication (in AptifyApplication.dll)

See Also

ShowDependenciesForm Members | Aptify.Framework.Application Namespace


ShowDependenciesForm Members

ShowDependenciesForm overview

Public Instance Constructors

ShowDependenciesForm Constructor Initializes a new instance of the ShowDependenciesForm class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
ConvertDependenciesToDataTable | This method will convert the provided Entity Dependencies object into a data table with the following columns. EntityIconEntityEntityDisplayNameSubTypeSubTypeDisplayNameFieldFieldDisplayNameRecordIDRecordNameHasDependencies
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
GroupDependencyData | This method will group dependency data together in the provided data table. Grouping occurs on the basis of the same Entity and RecordID columns. If multiple rows are found for a given Entity and RecordID combination, then the values are combined into a single row and the values in the FieldDisplayName and SubTypeDisplayName columns are merged into a comma,delimted list of the values that were in the previously separate rows. The data table passed in is assumed to have the following columns. EntityIconEntityEntityDisplayNameSubTypeSubTypeDisplayNameFieldFieldDisplayNameRecordIDRecordNameHasDependencies
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDependencies | Overloaded. This overload calls the ShowDependencies() method with True for all of the parameters provided by the method.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ShowDependenciesForm Class | Aptify.Framework.Application Namespace


ShowDependenciesForm Constructor

Initializes a new instance of the ShowDependenciesForm class.

public ShowDependenciesForm();

See Also

ShowDependenciesForm Class | Aptify.Framework.Application Namespace


ShowDependenciesForm Methods

The methods of the ShowDependenciesForm class are listed below. For a complete list of ShowDependenciesForm class members, see the ShowDependenciesForm Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
ConvertDependenciesToDataTable | This method will convert the provided Entity Dependencies object into a data table with the following columns. EntityIconEntityEntityDisplayNameSubTypeSubTypeDisplayNameFieldFieldDisplayNameRecordIDRecordNameHasDependencies
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
GroupDependencyData | This method will group dependency data together in the provided data table. Grouping occurs on the basis of the same Entity and RecordID columns. If multiple rows are found for a given Entity and RecordID combination, then the values are combined into a single row and the values in the FieldDisplayName and SubTypeDisplayName columns are merged into a comma,delimted list of the values that were in the previously separate rows. The data table passed in is assumed to have the following columns. EntityIconEntityEntityDisplayNameSubTypeSubTypeDisplayNameFieldFieldDisplayNameRecordIDRecordNameHasDependencies
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDependencies | Overloaded. This overload calls the ShowDependencies() method with True for all of the parameters provided by the method.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ShowDependenciesForm Class | Aptify.Framework.Application Namespace


ShowDependenciesForm.ConvertDependenciesToDataTable Method

This method will convert the provided Entity Dependencies object into a data table with the following columns. EntityIconEntityEntityDisplayNameSubTypeSubTypeDisplayNameFieldFieldDisplayNameRecordIDRecordNameHasDependencies

public DataTable ConvertDependenciesToDataTable(
EntityDependenciesBase Dependencies,
String EntityToSkip,
Int64 RecordIDToSkip,
ref Boolean& HasSubTypeDependencies
);

Parameters

Dependencies
EntityToSkip
If this is provided and RecordIDToSkip is provided, the combined Entity/RecordID pair will be skipped when building the table.
RecordIDToSkip
HasSubTypeDependencies
This parameter is optional and will return a value indicating if any of the dependency links are at the sub-type level. If none are at the sub-type level, this parameter will return False, if one or more are at the sub-type level, then this parameter will return True

Return Value

Remarks

See Also

ShowDependenciesForm Class | Aptify.Framework.Application Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

ShowDependenciesForm.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

ShowDependenciesForm Class | Aptify.Framework.Application Namespace


ShowDependenciesForm.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

ShowDependenciesForm Class | Aptify.Framework.Application Namespace | ShowDependenciesForm.Dispose Overload List


ShowDependenciesForm.GroupDependencyData Method

This method will group dependency data together in the provided data table. Grouping occurs on the basis of the same Entity and RecordID columns. If multiple rows are found for a given Entity and RecordID combination, then the values are combined into a single row and the values in the FieldDisplayName and SubTypeDisplayName columns are merged into a comma,delimted list of the values that were in the previously separate rows. The data table passed in is assumed to have the following columns. EntityIconEntityEntityDisplayNameSubTypeSubTypeDisplayNameFieldFieldDisplayNameRecordIDRecordNameHasDependencies

public virtual void GroupDependencyData(
DataTable dt
);

Parameters

dt

Remarks

See Also

ShowDependenciesForm Class | Aptify.Framework.Application Namespace


ShowDependencies Method

Aptify 5.0 Software Development Kit (SDK)

ShowDependenciesForm.ShowDependencies Method

This overload calls the ShowDependencies() method with True for all of the parameters provided by the method.

Overload List

This overload calls the ShowDependencies() method with True for all of the parameters provided by the method.

public bool ShowDependencies();

This method will display the form and the dependencies provided in the constructor of the class.

public bool ShowDependencies(Boolean,Boolean,Boolean);

public bool ShowDependencies(Boolean,Boolean,Boolean,Form);

public bool ShowDependencies(Form);

See Also

ShowDependenciesForm Class | Aptify.Framework.Application Namespace


ShowDependenciesForm.ShowDependencies Method ()

This overload calls the ShowDependencies() method with True for all of the parameters provided by the method.

public bool ShowDependencies();

Remarks

See Also

ShowDependenciesForm Class | Aptify.Framework.Application Namespace | ShowDependenciesForm.ShowDependencies Overload List


ShowDependenciesForm.ShowDependencies Method (Boolean, Boolean, Boolean)

This method will display the form and the dependencies provided in the constructor of the class.

public bool ShowDependencies(
Boolean GroupRecords,
Boolean ShowFieldColumn,
Boolean ShowSubTypeColumn
);

Parameters

GroupRecords
If this parameter is set to True then the rows in the display grid will be grouped based on the uniqueness of the Entity and RecordID combination. Since multiple dependencies can exist for the same record due to additional links that can exist (e.g. two or more foreign keys from a record that point to another record), this parameter allows those same records to be grouped into a single line item.
ShowFieldColumn
If set to True, this parameter will result in the Field column being displayed. If records are being grouped then the field will be displayed, unless there are mutliple such links in which case they will be shown in the cell.
ShowSubTypeColumn
If set to True, this parameter will result in the Sub-Type column being displayed. If records are being grouped then the sub-type name will be shown, unless there are multiple such links in which case they will be shown in the cell.

Remarks

See Also

ShowDependenciesForm Class | Aptify.Framework.Application Namespace | ShowDependenciesForm.ShowDependencies Overload List


ShowDependenciesForm.ShowDependencies Method (Boolean, Boolean, Boolean, Form)

public bool ShowDependencies(
Boolean GroupRecords,
Boolean ShowFieldColumn,
Boolean ShowSubTypeColumn,
Form ParentForm
);

See Also

ShowDependenciesForm Class | Aptify.Framework.Application Namespace | ShowDependenciesForm.ShowDependencies Overload List


ShowDependenciesForm.ShowDependencies Method (Form)

public bool ShowDependencies(
Form ParentForm
);

See Also

ShowDependenciesForm Class | Aptify.Framework.Application Namespace | ShowDependenciesForm.ShowDependencies Overload List


SQLClause Class

This class represents a Clause or "section" of a SQL Statement. For example, the SELECT Clause, FROM clause, WHERE Clause, ORDER BY Clause, etc

For a list of all members of this type, see SQLClause Members.

System.Object
SQLClause

public class SQLClause

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyApplication (in AptifyApplication.dll)

See Also

SQLClause Members | Aptify.Framework.Application Namespace


SQLClause Members

SQLClause overview

Public Instance Constructors

SQLClause Constructor

Public Instance Properties

Text
Type

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SQLClause Class | Aptify.Framework.Application Namespace


SQLClause Constructor

public SQLClause(
SQLClauseType Type,
String Text
);

See Also

SQLClause Class | Aptify.Framework.Application Namespace


SQLClause Properties

The properties of the SQLClause class are listed below. For a complete list of SQLClause class members, see the SQLClause Members topic.

Public Instance Properties

Text
Type

See Also

SQLClause Class | Aptify.Framework.Application Namespace


Text Property

Aptify 5.0 Software Development Kit (SDK)

SQLClause.Text Property

public virtual String Text {get;}

See Also

SQLClause Class | Aptify.Framework.Application Namespace


Type Property

Aptify 5.0 Software Development Kit (SDK)

SQLClause.Type Property

public virtual SQLClauseType Type {get;}

See Also

SQLClause Class | Aptify.Framework.Application Namespace


SQLClauseType Enumeration

Different types of SQL Clauses such as SELECT, WHERE, etc.

public enum SQLClauseType

Remarks

Members

Member Name | Description
SELECT |
FROM |
WHERE |
GROUPBY |
HAVING |
ORDERBY |

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyApplication (in AptifyApplication.dll)

See Also

Aptify.Framework.Application Namespace


SQLPageMethod Enumeration

This enumerated type tracks the different methods of creating Paging SQL to turn a SELECT statement into a page-based SQL call.

public enum SQLPageMethod

Remarks

Members

Member Name | Description
OrderedView | Uses SQL 2005 Ordered View functionality to create a page sql statement. Requires ORDER BY clause to not use any functions or statements.
TopAndOrderBy | Uses SQL TOP and ORDER BY to create paging SQL

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyApplication (in AptifyApplication.dll)

See Also

Aptify.Framework.Application Namespace


SQLStatement Class

Utility class for parsing SELECT statements, breaks up the statement into various clauses to simplify parsing.

For a list of all members of this type, see SQLStatement Members.

System.Object
SQLStatement

public class SQLStatement

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyApplication (in AptifyApplication.dll)

See Also

SQLStatement Members | Aptify.Framework.Application Namespace


SQLStatement Members

SQLStatement overview

Public Instance Constructors

SQLStatement Constructor

Public Instance Properties

DataAction | Aptify DataAction Class Instance
FROMClause |
GROUPBYClause |
HAVINGClause |
ORDERBYClause |
SELECTClause |
SQL |
SQLClauses |
SQLScanner | This property returns the internal instance of the SQLScanner class
WHEREClause |

Public Instance Methods

AppendFilterSQL | This method will append an additional expression as specified by the FilterSQL parameter to the where clause of the current SQL Statement. If no WHERE clause exists, the where clause will be created automatically. After this operation finishes, the SQL property can be accessed to gain the updated SQL statement string value. To assure that operator precedence is respected as the statement(s) were originally designed, the original where clause(if it existes) and the new FilterSQL are wrapped in parenthesis and then combined with the SQL AND operator.
EnsureOrderByFieldsAreInSelect | This method will return a SQLStatement class instance that is guaranteed to have the fields from the ORDER BY clause included in the SELECT Clause. This is necessary to have for sql statements that are going to be executed using a ORDERED temporary view as the GetPageSQL() method does. MAKE SURE to call this method before calling GetPageSQL(). If ORDER BY is not used on the current SQL Statement, the same SQLStatement Object instance is returned.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindSQLClause | Returns the SQLClause matching the type specified. If no SQL Clause exists in the SQL Statement for the specified type, this method will return Nothing.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPageCount | Returns the number of pages for the current SQL statement based on the current number of rows (by calling) GetRowCount() and the PageSize specified
GetPageSQL | Overloaded. This method returns a modified "Paged" SQL statement for the SQL statement that was provided in the SQL Property of this class The return value is a SQL Statement that is "Paged" based on the SQL Statement's internal SQL. Make sure to call the EnsureOrderByFieldsAreInSelect() method and only use this method on the result of that method to make sure that all of the fields in the ORDER BY clause are in the SELECT clause as well.
GetRowCount | This method returns the number of rows that a given SQL statement would return. The method does not run the actual SQL statement, rather, it will generate a SELECT COUNT() query based on the FROM clause and WHERE clause within the SQL statement. The SQL statement used to get the row count can be retrieved directly (without running it) by calling the GetRowCountSQL() method.
GetRowCountSQL | This method returns a SQL statement based on the current SQL statement within the object (from the SQL property) that calculates the number of rows that the statement will return.
GetType (inherited from Object) | Gets the Type of the current instance.
StripToFieldNames | This method will strip strings down to their field names from the specified SQL segment, for example APTIFY.dbo.vwEntities.Name or Aptify..vwEntities.Name or vwEntities.Name will all be stripped to just Name. This works on a single field or a comma delimited list of names such as those used in ORDER BY clauses.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetClauseText This method will return a string that contains the body of a SQL Clause for the given starting position. The method continues through the token stream until it finds another SQL Clause starting key word such as SELECT, FROM, WHERE, ETC, respecting scope levels (e.g. sub-queries are parsed in their entirety and do not impact the end of this process)
Example SQL Statement:
   SELECT
      Field1, Field2, Field3,
      (SELECT Field4 FROM Table2 WHERE ForeignKeyID=Table1.ID) As 'TheField'
   FROM
      Table1
   WHERE
      Table1.Field1='The Value'
   ORDER BY
      Table1.Field2
In the above example SQL Statement, if the starting position passed in was the token right after the SELECT reserved word, everything up until the FROM reserved word before "Table1" would be included. The reason is that the sub-query that is part of the outer SQL statement's SELECT clause would be incorporated into this SQL Statement.
GetOrderedViewPageSQL | This method is responsible for the Ordered View implementation of the GetPageSQL() method.
GetTopAndOrderByPageSQL | This method is responsible for the TOP/ORDER BY implementation of the GetPageSQL() method.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ParseSQL

See Also

SQLStatement Class | Aptify.Framework.Application Namespace


SQLStatement Constructor

public SQLStatement(
String SQL,
DataAction DataAction
);

See Also

SQLStatement Class | Aptify.Framework.Application Namespace


SQLStatement Properties

The properties of the SQLStatement class are listed below. For a complete list of SQLStatement class members, see the SQLStatement Members topic.

Public Instance Properties

DataAction | Aptify DataAction Class Instance
FROMClause |
GROUPBYClause |
HAVINGClause |
ORDERBYClause |
SELECTClause |
SQL |
SQLClauses |
SQLScanner | This property returns the internal instance of the SQLScanner class
WHEREClause |

See Also

SQLStatement Class | Aptify.Framework.Application Namespace


DataAction Property

Aptify 5.0 Software Development Kit (SDK)

SQLStatement.DataAction Property

Aptify DataAction Class Instance

public virtual DataAction DataAction {get;}

Property Value

Remarks

See Also

SQLStatement Class | Aptify.Framework.Application Namespace


FROMClause Property

Aptify 5.0 Software Development Kit (SDK)

SQLStatement.FROMClause Property

public virtual SQLClause FROMClause {get;}

See Also

SQLStatement Class | Aptify.Framework.Application Namespace


GROUPBYClause Property

Aptify 5.0 Software Development Kit (SDK)

SQLStatement.GROUPBYClause Property

public virtual SQLClause GROUPBYClause {get;}

See Also

SQLStatement Class | Aptify.Framework.Application Namespace


HAVINGClause Property

Aptify 5.0 Software Development Kit (SDK)

SQLStatement.HAVINGClause Property

public virtual SQLClause HAVINGClause {get;}

See Also

SQLStatement Class | Aptify.Framework.Application Namespace


ORDERBYClause Property

Aptify 5.0 Software Development Kit (SDK)

SQLStatement.ORDERBYClause Property

public virtual SQLClause ORDERBYClause {get;}

See Also

SQLStatement Class | Aptify.Framework.Application Namespace


SELECTClause Property

Aptify 5.0 Software Development Kit (SDK)

SQLStatement.SELECTClause Property

public virtual SQLClause SELECTClause {get;}

See Also

SQLStatement Class | Aptify.Framework.Application Namespace


SQL Property

Aptify 5.0 Software Development Kit (SDK)

SQLStatement.SQL Property

public virtual String SQL {get; set;}

See Also

SQLStatement Class | Aptify.Framework.Application Namespace


SQLClauses Property

Aptify 5.0 Software Development Kit (SDK)

SQLStatement.SQLClauses Property

public virtual List<T> SQLClauses {get;}

See Also

SQLStatement Class | Aptify.Framework.Application Namespace


SQLScanner Property

Aptify 5.0 Software Development Kit (SDK)

SQLStatement.SQLScanner Property

This property returns the internal instance of the SQLScanner class

public virtual SQLScanner SQLScanner {get;}

Property Value

Remarks

See Also

SQLStatement Class | Aptify.Framework.Application Namespace


WHEREClause Property

Aptify 5.0 Software Development Kit (SDK)

SQLStatement.WHEREClause Property

public virtual SQLClause WHEREClause {get;}

See Also

SQLStatement Class | Aptify.Framework.Application Namespace


SQLStatement Methods

The methods of the SQLStatement class are listed below. For a complete list of SQLStatement class members, see the SQLStatement Members topic.

Public Instance Methods

AppendFilterSQL | This method will append an additional expression as specified by the FilterSQL parameter to the where clause of the current SQL Statement. If no WHERE clause exists, the where clause will be created automatically. After this operation finishes, the SQL property can be accessed to gain the updated SQL statement string value. To assure that operator precedence is respected as the statement(s) were originally designed, the original where clause(if it existes) and the new FilterSQL are wrapped in parenthesis and then combined with the SQL AND operator.
EnsureOrderByFieldsAreInSelect | This method will return a SQLStatement class instance that is guaranteed to have the fields from the ORDER BY clause included in the SELECT Clause. This is necessary to have for sql statements that are going to be executed using a ORDERED temporary view as the GetPageSQL() method does. MAKE SURE to call this method before calling GetPageSQL(). If ORDER BY is not used on the current SQL Statement, the same SQLStatement Object instance is returned.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindSQLClause | Returns the SQLClause matching the type specified. If no SQL Clause exists in the SQL Statement for the specified type, this method will return Nothing.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPageCount | Returns the number of pages for the current SQL statement based on the current number of rows (by calling) GetRowCount() and the PageSize specified
GetPageSQL | Overloaded. This method returns a modified "Paged" SQL statement for the SQL statement that was provided in the SQL Property of this class The return value is a SQL Statement that is "Paged" based on the SQL Statement's internal SQL. Make sure to call the EnsureOrderByFieldsAreInSelect() method and only use this method on the result of that method to make sure that all of the fields in the ORDER BY clause are in the SELECT clause as well.
GetRowCount | This method returns the number of rows that a given SQL statement would return. The method does not run the actual SQL statement, rather, it will generate a SELECT COUNT() query based on the FROM clause and WHERE clause within the SQL statement. The SQL statement used to get the row count can be retrieved directly (without running it) by calling the GetRowCountSQL() method.
GetRowCountSQL | This method returns a SQL statement based on the current SQL statement within the object (from the SQL property) that calculates the number of rows that the statement will return.
GetType (inherited from Object) | Gets the Type of the current instance.
StripToFieldNames | This method will strip strings down to their field names from the specified SQL segment, for example APTIFY.dbo.vwEntities.Name or Aptify..vwEntities.Name or vwEntities.Name will all be stripped to just Name. This works on a single field or a comma delimited list of names such as those used in ORDER BY clauses.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetClauseText This method will return a string that contains the body of a SQL Clause for the given starting position. The method continues through the token stream until it finds another SQL Clause starting key word such as SELECT, FROM, WHERE, ETC, respecting scope levels (e.g. sub-queries are parsed in their entirety and do not impact the end of this process)
Example SQL Statement:
   SELECT
      Field1, Field2, Field3,
      (SELECT Field4 FROM Table2 WHERE ForeignKeyID=Table1.ID) As 'TheField'
   FROM
      Table1
   WHERE
      Table1.Field1='The Value'
   ORDER BY
      Table1.Field2
In the above example SQL Statement, if the starting position passed in was the token right after the SELECT reserved word, everything up until the FROM reserved word before "Table1" would be included. The reason is that the sub-query that is part of the outer SQL statement's SELECT clause would be incorporated into this SQL Statement.
GetOrderedViewPageSQL | This method is responsible for the Ordered View implementation of the GetPageSQL() method.
GetTopAndOrderByPageSQL | This method is responsible for the TOP/ORDER BY implementation of the GetPageSQL() method.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ParseSQL

See Also

SQLStatement Class | Aptify.Framework.Application Namespace


SQLStatement.AppendFilterSQL Method

This method will append an additional expression as specified by the FilterSQL parameter to the where clause of the current SQL Statement. If no WHERE clause exists, the where clause will be created automatically. After this operation finishes, the SQL property can be accessed to gain the updated SQL statement string value. To assure that operator precedence is respected as the statement(s) were originally designed, the original where clause(if it existes) and the new FilterSQL are wrapped in parenthesis and then combined with the SQL AND operator.

public virtual void AppendFilterSQL(
String FilterSQL
);

Parameters

FilterSQL

Remarks

See Also

SQLStatement Class | Aptify.Framework.Application Namespace


SQLStatement.EnsureOrderByFieldsAreInSelect Method

This method will return a SQLStatement class instance that is guaranteed to have the fields from the ORDER BY clause included in the SELECT Clause. This is necessary to have for sql statements that are going to be executed using a ORDERED temporary view as the GetPageSQL() method does. MAKE SURE to call this method before calling GetPageSQL(). If ORDER BY is not used on the current SQL Statement, the same SQLStatement Object instance is returned.

public virtual SQLStatement EnsureOrderByFieldsAreInSelect(
String Database,
String View
);

Parameters

Database
Name of the database containin the view(s) used in the query
View
Name of the primary view being used in the query, to be used for those instances of field names that are not explicitly referenced

Return Value

Remarks

See Also

SQLStatement Class | Aptify.Framework.Application Namespace


SQLStatement.FindSQLClause Method

Returns the SQLClause matching the type specified. If no SQL Clause exists in the SQL Statement for the specified type, this method will return Nothing.

public SQLClause FindSQLClause(
SQLClauseType ClauseType
);

Parameters

ClauseType

Return Value

Remarks

See Also

SQLStatement Class | Aptify.Framework.Application Namespace


SQLStatement.GetClauseText Method

This method will return a string that contains the body of a SQL Clause for the given starting position. The method continues through the token stream until it finds another SQL Clause starting key word such as SELECT, FROM, WHERE, ETC, respecting scope levels (e.g. sub-queries are parsed in their entirety and do not impact the end of this process)

Example SQL Statement:
   SELECT
      Field1, Field2, Field3,
      (SELECT Field4 FROM Table2 WHERE ForeignKeyID=Table1.ID) As 'TheField'
   FROM
      Table1
   WHERE
      Table1.Field1='The Value'
   ORDER BY
      Table1.Field2
In the above example SQL Statement, if the starting position passed in was the token right after the SELECT reserved word, everything up until the FROM reserved word before "Table1" would be included. The reason is that the sub-query that is part of the outer SQL statement's SELECT clause would be incorporated into this SQL Statement.

protected virtual string GetClauseText(
String TokenStream,
List<T> TokenList,
Int32 StartingTokenIndex,
ref Int32& EndingTokenIndex
);

Parameters

TokenStream
TokenList
StartingTokenIndex
EndingTokenIndex

Return Value

Remarks

See Also

SQLStatement Class | Aptify.Framework.Application Namespace


SQLStatement.GetOrderedViewPageSQL Method

This method is responsible for the Ordered View implementation of the GetPageSQL() method.

protected virtual string GetOrderedViewPageSQL(
Int64 PageIndex,
Int64 PageSize
);

Parameters

PageIndex
PageSize

Return Value

Remarks

See Also

SQLStatement Class | Aptify.Framework.Application Namespace


SQLStatement.GetPageCount Method

Returns the number of pages for the current SQL statement based on the current number of rows (by calling) GetRowCount() and the PageSize specified

public virtual long GetPageCount(
Int32 PageSize
);

Parameters

PageSize

Return Value

Remarks

See Also

SQLStatement Class | Aptify.Framework.Application Namespace


GetPageSQL Method

Aptify 5.0 Software Development Kit (SDK)

SQLStatement.GetPageSQL Method

This method returns a modified "Paged" SQL statement for the SQL statement that was provided in the SQL Property of this class The return value is a SQL Statement that is "Paged" based on the SQL Statement's internal SQL. Make sure to call the EnsureOrderByFieldsAreInSelect() method and only use this method on the result of that method to make sure that all of the fields in the ORDER BY clause are in the SELECT clause as well. This method calls the GetPageSQL() overload that uses TopAndOrderBy as the paging method, if you want to use the Ordered View method of paging, call the GetPageSQL() function directly that has the PagingMethod parameter.

Overload List

This method returns a modified "Paged" SQL statement for the SQL statement that was provided in the SQL Property of this class The return value is a SQL Statement that is "Paged" based on the SQL Statement's internal SQL. Make sure to call the EnsureOrderByFieldsAreInSelect() method and only use this method on the result of that method to make sure that all of the fields in the ORDER BY clause are in the SELECT clause as well. This method calls the GetPageSQL() overload that uses TopAndOrderBy as the paging method, if you want to use the Ordered View method of paging, call the GetPageSQL() function directly that has the PagingMethod parameter.

public virtual string GetPageSQL(Int64,Int64);

This method returns a modified "Paged" SQL statement for the SQL statement that was provided in the SQL Property of this class The return value is a SQL Statement that is "Paged" based on the SQL Statement's internal SQL. Make sure to call the EnsureOrderByFieldsAreInSelect() method and only use this method on the result of that method to make sure that all of the fields in the ORDER BY clause are in the SELECT clause as well.

public virtual string GetPageSQL(Int64,Int64,SQLPageMethod);

See Also

SQLStatement Class | Aptify.Framework.Application Namespace


SQLStatement.GetPageSQL Method (Int64, Int64)

This method returns a modified "Paged" SQL statement for the SQL statement that was provided in the SQL Property of this class The return value is a SQL Statement that is "Paged" based on the SQL Statement's internal SQL. Make sure to call the EnsureOrderByFieldsAreInSelect() method and only use this method on the result of that method to make sure that all of the fields in the ORDER BY clause are in the SELECT clause as well. This method calls the GetPageSQL() overload that uses TopAndOrderBy as the paging method, if you want to use the Ordered View method of paging, call the GetPageSQL() function directly that has the PagingMethod parameter.

public virtual string GetPageSQL(
Int64 PageIndex,
Int64 PageSize
);

Parameters

PageIndex
One-Relative Page Index (1 to N)
PageSize
Size of each Page

Return Value

Remarks

See Also

SQLStatement Class | Aptify.Framework.Application Namespace | SQLStatement.GetPageSQL Overload List


SQLStatement.GetPageSQL Method (Int64, Int64, SQLPageMethod)

This method returns a modified "Paged" SQL statement for the SQL statement that was provided in the SQL Property of this class The return value is a SQL Statement that is "Paged" based on the SQL Statement's internal SQL. Make sure to call the EnsureOrderByFieldsAreInSelect() method and only use this method on the result of that method to make sure that all of the fields in the ORDER BY clause are in the SELECT clause as well.

public virtual string GetPageSQL(
Int64 PageIndex,
Int64 PageSize,
SQLPageMethod PageMethod
);

Parameters

PageIndex
One-Relative Page Index (1 to N)
PageSize
Size of each Page
PageMethod
The paging method to use, seeSQLPageMethod for more details.

Return Value

Remarks

See Also

SQLStatement Class | Aptify.Framework.Application Namespace | SQLStatement.GetPageSQL Overload List


SQLStatement.GetRowCount Method

This method returns the number of rows that a given SQL statement would return. The method does not run the actual SQL statement, rather, it will generate a SELECT COUNT() query based on the FROM clause and WHERE clause within the SQL statement. The SQL statement used to get the row count can be retrieved directly (without running it) by calling the GetRowCountSQL() method.

public virtual long GetRowCount();

Return Value

Remarks

See Also

SQLStatement Class | Aptify.Framework.Application Namespace


SQLStatement.GetRowCountSQL Method

This method returns a SQL statement based on the current SQL statement within the object (from the SQL property) that calculates the number of rows that the statement will return.

public virtual string GetRowCountSQL();

Return Value

Remarks

See Also

SQLStatement Class | Aptify.Framework.Application Namespace


SQLStatement.GetTopAndOrderByPageSQL Method

This method is responsible for the TOP/ORDER BY implementation of the GetPageSQL() method.

protected virtual string GetTopAndOrderByPageSQL(
Int64 PageIndex,
Int64 PageSize
);

Parameters

PageIndex
PageSize

Return Value

Remarks

See Also

SQLStatement Class | Aptify.Framework.Application Namespace


SQLStatement.ParseSQL Method

protected virtual void ParseSQL(
String SQL
);

See Also

SQLStatement Class | Aptify.Framework.Application Namespace


SQLStatement.StripToFieldNames Method

This method will strip strings down to their field names from the specified SQL segment, for example APTIFY.dbo.vwEntities.Name or Aptify..vwEntities.Name or vwEntities.Name will all be stripped to just Name. This works on a single field or a comma delimited list of names such as those used in ORDER BY clauses.

public string StripToFieldNames(
String SQL
);

Parameters

SQL

Return Value

Remarks

See Also

SQLStatement Class | Aptify.Framework.Application Namespace


Status Class

Used to represent the status of a current task.

For a list of all members of this type, see Status Members.

System.Object
Status

public class Status : ISerializable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyUtility (in AptifyUtility.dll)

See Also

Status Members | Aptify.Framework.Application Namespace


Status Members

Status overview

Public Instance Constructors

Status Overloaded. Initializes a new instance of the Status class.

Public Instance Properties

Completed | The number of Items that have been completed during the task.
Message |
Total | The total number of items that needed to be processed.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

StatusChanged This event is fired when any property of the status is changed.

Protected Instance Constructors

Status Overloaded. Initializes a new instance of the Status class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetObjectData |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnStatusChanged |

See Also

Status Class | Aptify.Framework.Application Namespace


Status Constructor

Initializes a new instance of the Status class.

Overload List

Initializes a new instance of the Status class.

public Status();

protected Status(SerializationInfo,StreamingContext);

public Status(String,Int64,Int64);

See Also

Status Class | Aptify.Framework.Application Namespace


Status Constructor ()

Initializes a new instance of the Status class.

public Status();

See Also

Status Class | Aptify.Framework.Application Namespace | Status Constructor Overload List


Status Constructor (String, Int64, Int64)

public Status(
String Message,
Int64 Completed,
Int64 Total
);

See Also

Status Class | Aptify.Framework.Application Namespace | Status Constructor Overload List


Status Constructor (SerializationInfo, StreamingContext)

protected Status(
SerializationInfo info,
StreamingContext context
);

See Also

Status Class | Aptify.Framework.Application Namespace | Status Constructor Overload List


Status Properties

The properties of the Status class are listed below. For a complete list of Status class members, see the Status Members topic.

Public Instance Properties

Completed | The number of Items that have been completed during the task.
Message |
Total | The total number of items that needed to be processed.

See Also

Status Class | Aptify.Framework.Application Namespace


Completed Property

Aptify 5.0 Software Development Kit (SDK)

Status.Completed Property

The number of Items that have been completed during the task.

public virtual Int64 Completed {get; set;}

See Also

Status Class | Aptify.Framework.Application Namespace


Message Property

Aptify 5.0 Software Development Kit (SDK)

Status.Message Property

public virtual String Message {get; set;}

See Also

Status Class | Aptify.Framework.Application Namespace


Total Property

Aptify 5.0 Software Development Kit (SDK)

Status.Total Property

The total number of items that needed to be processed.

public virtual Int64 Total {get; set;}

See Also

Status Class | Aptify.Framework.Application Namespace


Status Methods

The methods of the Status class are listed below. For a complete list of Status class members, see the Status Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetObjectData |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnStatusChanged |

See Also

Status Class | Aptify.Framework.Application Namespace


Status.GetObjectData Method

protected virtual void GetObjectData(
SerializationInfo info,
StreamingContext context
);

Implements

ISerializable.

See Also

Status Class | Aptify.Framework.Application Namespace


Status.OnStatusChanged Method

protected virtual void OnStatusChanged(
StatusChangedEventArgs StatusChangedArgument
);

See Also

Status Class | Aptify.Framework.Application Namespace


Status Events

The events of the Status class are listed below. For a complete list of Status class members, see the Status Members topic.

Public Instance Events

StatusChanged This event is fired when any property of the status is changed.

See Also

Status Class | Aptify.Framework.Application Namespace


Status.StatusChangedEventHandler Event

This event is fired when any property of the status is changed.

public event StatusChangedEventHandler StatusChanged;

Event Data

The event handler receives an argument of type StatusChangedEventArgs containing data related to this event. The following StatusChangedEventArgs property provides information specific to this event.

Property | Description
Status |

See Also

Status Class | Aptify.Framework.Application Namespace


StatusChangedEventArgs Class

The base object returned from the StatusChangedEventHandler

For a list of all members of this type, see StatusChangedEventArgs Members.

System.Object
EventArgs
StatusChangedEventArgs

public class StatusChangedEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyUtility (in AptifyUtility.dll)

See Also

StatusChangedEventArgs Members | Aptify.Framework.Application Namespace


StatusChangedEventArgs Members

StatusChangedEventArgs overview

Public Instance Constructors

StatusChangedEventArgs Overloaded. Initializes a new instance of the StatusChangedEventArgs class.

Public Instance Properties

Status

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StatusChangedEventArgs Class | Aptify.Framework.Application Namespace


StatusChangedEventArgs Constructor

Initializes a new instance of the StatusChangedEventArgs class.

Overload List

Initializes a new instance of the StatusChangedEventArgs class.

public StatusChangedEventArgs();

public StatusChangedEventArgs(Status);

See Also

StatusChangedEventArgs Class | Aptify.Framework.Application Namespace


StatusChangedEventArgs Constructor ()

Initializes a new instance of the StatusChangedEventArgs class.

public StatusChangedEventArgs();

See Also

StatusChangedEventArgs Class | Aptify.Framework.Application Namespace | StatusChangedEventArgs Constructor Overload List


StatusChangedEventArgs Constructor (Status)

public StatusChangedEventArgs(
Status Status
);

See Also

StatusChangedEventArgs Class | Aptify.Framework.Application Namespace | StatusChangedEventArgs Constructor Overload List


StatusChangedEventArgs Properties

The properties of the StatusChangedEventArgs class are listed below. For a complete list of StatusChangedEventArgs class members, see the StatusChangedEventArgs Members topic.

Public Instance Properties

Status

See Also

StatusChangedEventArgs Class | Aptify.Framework.Application Namespace


Status Property

Aptify 5.0 Software Development Kit (SDK)

StatusChangedEventArgs.Status Property

public Status Status {get;}

See Also

StatusChangedEventArgs Class | Aptify.Framework.Application Namespace


StatusChangedEventHandler Delegate

Used to send status updates from long running processes.

public delegate void StatusChangedEventHandler(
Object Sender,
StatusChangedEventArgs e
);

Remarks

This delegate may or may not be called across threads. The reciever should check to see if they need to marshal a call before accessing a visual component from withing this delegates target.

Example

Public Sub UpdateRecieved(byval Sender as object,ByVal Message As String, ByVal Completed As Long, ByVal Total As Long)
    If Me.InvokeRequired Then
        Me.BeginInvoke(New StatusEventHandler(AddressOf UpdateReceived), New Object() {Message, Completed, Total})
    Else
        Me.SetText(Message)
    End If
End Sub
Public Sub SetText(ByVal Message As String)
    Me.Text = Message
End Sub

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyUtility (in AptifyUtility.dll)

See Also

Aptify.Framework.Application Namespace


SubView Class

A data-only object that provides information regarding a subview. When a user displays hierarchies in a view, the system displays the sub-type or related record information in a subview.

For a list of all members of this type, see SubView Members.

System.Object
SubView

public class SubView

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyApplication (in AptifyApplication.dll)

See Also

SubView Members | Aptify.Framework.Application Namespace


SubView Members

SubView overview

Public Instance Properties

AllowDelete | Specifies if a user can delete records from within a subview.
AllowEdit | Specifies if the user can edit records from a subview.
ChildLink | Field to join with the child entity.
Description | Long description of the subview.
EntityID | Primary key of the entity.
EntityName | Unique name of the entity.
IsGenerated | Specifies if the view is generated.
Name | Name of the subview.
ParentLink | Field to join with the parent entity.
SQL | T-SQL of the subview.
SubViewID | Primary key of the subview.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SubView Class | Aptify.Framework.Application Namespace


SubView Properties

The properties of the SubView class are listed below. For a complete list of SubView class members, see the SubView Members topic.

Public Instance Properties

AllowDelete | Specifies if a user can delete records from within a subview.
AllowEdit | Specifies if the user can edit records from a subview.
ChildLink | Field to join with the child entity.
Description | Long description of the subview.
EntityID | Primary key of the entity.
EntityName | Unique name of the entity.
IsGenerated | Specifies if the view is generated.
Name | Name of the subview.
ParentLink | Field to join with the parent entity.
SQL | T-SQL of the subview.
SubViewID | Primary key of the subview.

See Also

SubView Class | Aptify.Framework.Application Namespace


AllowDelete Property

Aptify 5.0 Software Development Kit (SDK)

SubView.AllowDelete Property

Specifies if a user can delete records from within a subview.

public Boolean AllowDelete {get;}

Property Value

Remarks

See Also

SubView Class | Aptify.Framework.Application Namespace


AllowEdit Property

Aptify 5.0 Software Development Kit (SDK)

SubView.AllowEdit Property

Specifies if the user can edit records from a subview.

public Boolean AllowEdit {get;}

Property Value

Remarks

See Also

SubView Class | Aptify.Framework.Application Namespace


ChildLink Property

Aptify 5.0 Software Development Kit (SDK)

SubView.ChildLink Property

Field to join with the child entity.

public String ChildLink {get;}

Property Value

Remarks

See Also

SubView Class | Aptify.Framework.Application Namespace


Description Property

Aptify 5.0 Software Development Kit (SDK)

SubView.Description Property

Long description of the subview.

public String Description {get;}

Remarks

See Also

SubView Class | Aptify.Framework.Application Namespace


EntityID Property

Aptify 5.0 Software Development Kit (SDK)

SubView.EntityID Property

Primary key of the entity.

public Int64 EntityID {get;}

Remarks

See Also

SubView Class | Aptify.Framework.Application Namespace


EntityName Property

Aptify 5.0 Software Development Kit (SDK)

SubView.EntityName Property

Unique name of the entity.

public String EntityName {get;}

Remarks

See Also

SubView Class | Aptify.Framework.Application Namespace


IsGenerated Property

Aptify 5.0 Software Development Kit (SDK)

SubView.IsGenerated Property

Specifies if the view is generated.

public Boolean IsGenerated {get;}

Property Value

Remarks

See Also

SubView Class | Aptify.Framework.Application Namespace


Name Property

Aptify 5.0 Software Development Kit (SDK)

SubView.Name Property

Name of the subview.

public String Name {get;}

Remarks

See Also

SubView Class | Aptify.Framework.Application Namespace


ParentLink Property

Aptify 5.0 Software Development Kit (SDK)

SubView.ParentLink Property

Field to join with the parent entity.

public String ParentLink {get;}

Property Value

Remarks

See Also

SubView Class | Aptify.Framework.Application Namespace


SQL Property

Aptify 5.0 Software Development Kit (SDK)

SubView.SQL Property

T-SQL of the subview.

public String SQL {get;}

Property Value

Remarks

See Also

SubView Class | Aptify.Framework.Application Namespace


SubViewID Property

Aptify 5.0 Software Development Kit (SDK)

SubView.SubViewID Property

Primary key of the subview.

public Int64 SubViewID {get;}

Remarks

See Also

SubView Class | Aptify.Framework.Application Namespace


SubViews Class

Provides a basic implementation of a collection for subview objects.

For a list of all members of this type, see SubViews Members.

System.Object
SubViews

public class SubViews

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyApplication (in AptifyApplication.dll)

See Also

SubViews Members | Aptify.Framework.Application Namespace


SubViews Members

SubViews overview

Public Instance Properties

Count

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Item |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SubViews Class | Aptify.Framework.Application Namespace


SubViews Properties

The properties of the SubViews class are listed below. For a complete list of SubViews class members, see the SubViews Members topic.

Public Instance Properties

Count

See Also

SubViews Class | Aptify.Framework.Application Namespace


Count Property

Aptify 5.0 Software Development Kit (SDK)

SubViews.Count Property

public Int32 Count {get;}

See Also

SubViews Class | Aptify.Framework.Application Namespace


SubViews Methods

The methods of the SubViews class are listed below. For a complete list of SubViews class members, see the SubViews Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Item |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SubViews Class | Aptify.Framework.Application Namespace


SubViews.Item Method

public SubView Item(
Int32 Index
);

See Also

SubViews Class | Aptify.Framework.Application Namespace


UtilityConstants Class

For a list of all members of this type, see UtilityConstants Members.

System.Object
UtilityConstants

public class UtilityConstants

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyUtility (in AptifyUtility.dll)

See Also

UtilityConstants Members | Aptify.Framework.Application Namespace


UtilityConstants Members

UtilityConstants overview

Public Static Fields

KEY_NOT_IN_COLLECTION
LOG_APPLICATION_ERROR_BREAK
LOG_APPLICATION_ERROR_HEADER
LOG_APPLICATION_ERROR_MESSAGE
LOG_APPLICATION_ERROR_MORE
LOG_APPLICATION_ERROR_TITLE

Public Static Properties

KeyNotInCollectionMessage
LogApplicationErrorHeader
LogApplicationErrorBreak
LogApplicationErrorTitle
LogApplicationErrorMessage
LogApplicationErrorMore

Public Static Methods

GetResourceString

Public Instance Constructors

UtilityConstants Constructor Initializes a new instance of the UtilityConstants class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UtilityConstants Class | Aptify.Framework.Application Namespace


UtilityConstants Constructor

Initializes a new instance of the UtilityConstants class.

public UtilityConstants();

See Also

UtilityConstants Class | Aptify.Framework.Application Namespace


UtilityConstants Fields

The fields of the UtilityConstants class are listed below. For a complete list of UtilityConstants class members, see the UtilityConstants Members topic.

Public Static Fields

KEY_NOT_IN_COLLECTION
LOG_APPLICATION_ERROR_BREAK
LOG_APPLICATION_ERROR_HEADER
LOG_APPLICATION_ERROR_MESSAGE
LOG_APPLICATION_ERROR_MORE
LOG_APPLICATION_ERROR_TITLE

See Also

UtilityConstants Class | Aptify.Framework.Application Namespace


UtilityConstants.KEY_NOT_IN_COLLECTION Field

public const KEY_NOT_IN_COLLECTION KEY_NOT_IN_COLLECTION = "KEY_NOT_IN_COLLECTION";

See Also

UtilityConstants Class | Aptify.Framework.Application Namespace


UtilityConstants.LOG_APPLICATION_ERROR_BREAK Field

public const LOG_APPLICATION_ERROR_BREAK LOG_APPLICATION_ERROR_BREAK = "LOG_APPLICATION_ERROR_BREAK";

See Also

UtilityConstants Class | Aptify.Framework.Application Namespace


UtilityConstants.LOG_APPLICATION_ERROR_HEADER Field

public const LOG_APPLICATION_ERROR_HEADER LOG_APPLICATION_ERROR_HEADER = "LOG_APPLICATION_ERROR_HEADER";

See Also

UtilityConstants Class | Aptify.Framework.Application Namespace


UtilityConstants.LOG_APPLICATION_ERROR_MESSAGE Field

public const LOG_APPLICATION_ERROR_MESSAGE LOG_APPLICATION_ERROR_MESSAGE = "LOG_APPLICATION_ERROR_MESSAGE";

See Also

UtilityConstants Class | Aptify.Framework.Application Namespace


UtilityConstants.LOG_APPLICATION_ERROR_MORE Field

public const LOG_APPLICATION_ERROR_MORE LOG_APPLICATION_ERROR_MORE = "LOG_APPLICATION_ERROR_MORE";

See Also

UtilityConstants Class | Aptify.Framework.Application Namespace


UtilityConstants.LOG_APPLICATION_ERROR_TITLE Field

public const LOG_APPLICATION_ERROR_TITLE LOG_APPLICATION_ERROR_TITLE = "LOG_APPLICATION_ERROR_TITLE";

See Also

UtilityConstants Class | Aptify.Framework.Application Namespace


UtilityConstants Properties

The properties of the UtilityConstants class are listed below. For a complete list of UtilityConstants class members, see the UtilityConstants Members topic.

Public Static Properties

KeyNotInCollectionMessage
LogApplicationErrorHeader
LogApplicationErrorBreak
LogApplicationErrorTitle
LogApplicationErrorMessage
LogApplicationErrorMore

See Also

UtilityConstants Class | Aptify.Framework.Application Namespace


KeyNotInCollectionMessage Property

Aptify 5.0 Software Development Kit (SDK)

UtilityConstants.KeyNotInCollectionMessage Property

public static String KeyNotInCollectionMessage {get;}

See Also

UtilityConstants Class | Aptify.Framework.Application Namespace


LogApplicationErrorBreak Property

Aptify 5.0 Software Development Kit (SDK)

UtilityConstants.LogApplicationErrorBreak Property

public static String LogApplicationErrorBreak {get;}

See Also

UtilityConstants Class | Aptify.Framework.Application Namespace


LogApplicationErrorHeader Property

Aptify 5.0 Software Development Kit (SDK)

UtilityConstants.LogApplicationErrorHeader Property

public static String this[
DateTime DateLogged
] {get;}

See Also

UtilityConstants Class | Aptify.Framework.Application Namespace


LogApplicationErrorMessage Property

Aptify 5.0 Software Development Kit (SDK)

UtilityConstants.LogApplicationErrorMessage Property

public static String LogApplicationErrorMessage {get;}

See Also

UtilityConstants Class | Aptify.Framework.Application Namespace


LogApplicationErrorMore Property

Aptify 5.0 Software Development Kit (SDK)

UtilityConstants.LogApplicationErrorMore Property

public static String LogApplicationErrorMore {get;}

See Also

UtilityConstants Class | Aptify.Framework.Application Namespace


LogApplicationErrorTitle Property

Aptify 5.0 Software Development Kit (SDK)

UtilityConstants.LogApplicationErrorTitle Property

public static String LogApplicationErrorTitle {get;}

See Also

UtilityConstants Class | Aptify.Framework.Application Namespace


UtilityConstants Methods

The methods of the UtilityConstants class are listed below. For a complete list of UtilityConstants class members, see the UtilityConstants Members topic.

Public Static Methods

GetResourceString

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UtilityConstants Class | Aptify.Framework.Application Namespace


UtilityConstants.GetResourceString Method

public static string GetResourceString(
String ResourceKey
);

See Also

UtilityConstants Class | Aptify.Framework.Application Namespace


ViewField Class

ViewField is a data-only object that contains field information.

For a list of all members of this type, see ViewField Members.

System.Object
ViewField

public class ViewField

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyApplication (in AptifyApplication.dll)

See Also

ViewField Members | Aptify.Framework.Application Namespace


ViewField Members

ViewField overview

Public Instance Constructors

ViewField Overloaded. Initializes a new instance of the ViewField class.

Public Instance Properties

AllowResizing | Specifies if the field can be resized.
AptifyFieldType | Converts the SQL Server data type to AptifyDataFieldType enum.
BackColor | Windows color for background.
BorderColor |
BorderStyle |
BorderWidth |
CustomFormat |
DefaultAlignment | Location of the label.
Description | Long description of the field.
DisplayName | Name to show the user.
Entity |
EntityField |
EntityFieldMetadata |
FieldName | Name of the field.
FontBold |
FontItalic |
FontName |
FontSize |
FontUnderline |
FormatCategory |
FormatDecimalPlaces |
FormatNegativeNumType |
FormatString |
FormatUse1000Separator |
Sequence | Ordinal of the field.
SQLAllowNull |
SQLDataType | SQL Server data type (e.g., nvarchar, datetime, etc.)
TextAlignment |
TextColor | Windows color for the text.
UseViewFormatting |
Visible | Specifies if the label is visible to the user.
Width | Size of the field. Used for variable length.
WordWrap | Specifies if the display for the view's T-SQL statement supports word wrapping.
WrapText |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ViewField Class | Aptify.Framework.Application Namespace


ViewField Constructor

Overload List

public ViewField(String,String,String,String,Boolean,Int32);

public ViewField(String,String,String,String,Boolean,Int32,String,String,AptifyApplication);

public ViewField(String,String,String,String,Int32);

public ViewField(String,String,String,String,Int32,String,String,AptifyApplication);

See Also

ViewField Class | Aptify.Framework.Application Namespace


ViewField Constructor (String, String, String, String, Int32)

public ViewField(
String FieldName,
String DisplayName,
String Description,
String SQLDataType,
Int32 Width
);

See Also

ViewField Class | Aptify.Framework.Application Namespace | ViewField Constructor Overload List


ViewField Constructor (String, String, String, String, Int32, String, String, AptifyApplication)

public ViewField(
String FieldName,
String DisplayName,
String Description,
String SQLDataType,
Int32 Width,
String Entity,
String EntityField,
AptifyApplication Application
);

See Also

ViewField Class | Aptify.Framework.Application Namespace | ViewField Constructor Overload List


ViewField Constructor (String, String, String, String, Boolean, Int32)

public ViewField(
String FieldName,
String DisplayName,
String Description,
String SQLDataType,
Boolean SQLAllowNull,
Int32 Width
);

See Also

ViewField Class | Aptify.Framework.Application Namespace | ViewField Constructor Overload List


ViewField Constructor (String, String, String, String, Boolean, Int32, String, String, AptifyApplication)

public ViewField(
String FieldName,
String DisplayName,
String Description,
String SQLDataType,
Boolean SQLAllowNull,
Int32 Width,
String Entity,
String EntityField,
AptifyApplication Application
);

See Also

ViewField Class | Aptify.Framework.Application Namespace | ViewField Constructor Overload List


ViewField Properties

The properties of the ViewField class are listed below. For a complete list of ViewField class members, see the ViewField Members topic.

Public Instance Properties

AllowResizing | Specifies if the field can be resized.
AptifyFieldType | Converts the SQL Server data type to AptifyDataFieldType enum.
BackColor | Windows color for background.
BorderColor |
BorderStyle |
BorderWidth |
CustomFormat |
DefaultAlignment | Location of the label.
Description | Long description of the field.
DisplayName | Name to show the user.
Entity |
EntityField |
EntityFieldMetadata |
FieldName | Name of the field.
FontBold |
FontItalic |
FontName |
FontSize |
FontUnderline |
FormatCategory |
FormatDecimalPlaces |
FormatNegativeNumType |
FormatString |
FormatUse1000Separator |
Sequence | Ordinal of the field.
SQLAllowNull |
SQLDataType | SQL Server data type (e.g., nvarchar, datetime, etc.)
TextAlignment |
TextColor | Windows color for the text.
UseViewFormatting |
Visible | Specifies if the label is visible to the user.
Width | Size of the field. Used for variable length.
WordWrap | Specifies if the display for the view's T-SQL statement supports word wrapping.
WrapText |

See Also

ViewField Class | Aptify.Framework.Application Namespace


AllowResizing Property

Aptify 5.0 Software Development Kit (SDK)

ViewField.AllowResizing Property

Specifies if the field can be resized.

public Boolean AllowResizing {get;}

Remarks

See Also

ViewField Class | Aptify.Framework.Application Namespace


AptifyFieldType Property

Aptify 5.0 Software Development Kit (SDK)

ViewField.AptifyFieldType Property

Converts the SQL Server data type to AptifyDataFieldType enum.

public AptifyDataFieldType AptifyFieldType {get;}

Remarks

See Also

ViewField Class | Aptify.Framework.Application Namespace


BackColor Property

Aptify 5.0 Software Development Kit (SDK)

ViewField.BackColor Property

Windows color for background.

public Color BackColor {get;}

Remarks

See Also

ViewField Class | Aptify.Framework.Application Namespace


BorderColor Property

Aptify 5.0 Software Development Kit (SDK)

ViewField.BorderColor Property

public Color BorderColor {get;}

See Also

ViewField Class | Aptify.Framework.Application Namespace


BorderStyle Property

Aptify 5.0 Software Development Kit (SDK)

ViewField.BorderStyle Property

public ViewFieldBorderStyle BorderStyle {get;}

See Also

ViewField Class | Aptify.Framework.Application Namespace


BorderWidth Property

Aptify 5.0 Software Development Kit (SDK)

ViewField.BorderWidth Property

public Int32 BorderWidth {get;}

See Also

ViewField Class | Aptify.Framework.Application Namespace


CustomFormat Property

Aptify 5.0 Software Development Kit (SDK)

ViewField.CustomFormat Property

public Boolean CustomFormat {get;}

See Also

ViewField Class | Aptify.Framework.Application Namespace


DefaultAlignment Property

Aptify 5.0 Software Development Kit (SDK)

ViewField.DefaultAlignment Property

Location of the label.

public ViewFieldAlignment DefaultAlignment {get;}

Remarks

AN - 4/4/05 - CHANGED THIS TO DEFAULT ALIGNMENT basedon FIELD TYPE WE NOW HAVE FULL FIELD-LEVEL FORMATTING OPTIONS, see belo THIS PROP IS STILL USEFUL B/C we can use it for default settings

See Also

ViewField Class | Aptify.Framework.Application Namespace


Description Property

Aptify 5.0 Software Development Kit (SDK)

ViewField.Description Property

Long description of the field.

public String Description {get;}

Remarks

See Also

ViewField Class | Aptify.Framework.Application Namespace


DisplayName Property

Aptify 5.0 Software Development Kit (SDK)

ViewField.DisplayName Property

Name to show the user.

public String DisplayName {get;}

Remarks

See Also

ViewField Class | Aptify.Framework.Application Namespace


Entity Property

Aptify 5.0 Software Development Kit (SDK)

ViewField.Entity Property

public String Entity {get;}

See Also

ViewField Class | Aptify.Framework.Application Namespace


EntityField Property

Aptify 5.0 Software Development Kit (SDK)

ViewField.EntityField Property

public String EntityField {get;}

See Also

ViewField Class | Aptify.Framework.Application Namespace


EntityFieldMetadata Property

Aptify 5.0 Software Development Kit (SDK)

ViewField.EntityFieldMetadata Property

public EntityFieldMetaData EntityFieldMetadata {get;}

See Also

ViewField Class | Aptify.Framework.Application Namespace


FieldName Property

Aptify 5.0 Software Development Kit (SDK)

ViewField.FieldName Property

Name of the field.

public String FieldName {get;}

Remarks

See Also

ViewField Class | Aptify.Framework.Application Namespace


FontBold Property

Aptify 5.0 Software Development Kit (SDK)

ViewField.FontBold Property

public Boolean FontBold {get;}

See Also

ViewField Class | Aptify.Framework.Application Namespace


FontItalic Property

Aptify 5.0 Software Development Kit (SDK)

ViewField.FontItalic Property

public Boolean FontItalic {get;}

See Also

ViewField Class | Aptify.Framework.Application Namespace


FontName Property

Aptify 5.0 Software Development Kit (SDK)

ViewField.FontName Property

public String FontName {get;}

See Also

ViewField Class | Aptify.Framework.Application Namespace


FontSize Property

Aptify 5.0 Software Development Kit (SDK)

ViewField.FontSize Property

public Single FontSize {get;}

See Also

ViewField Class | Aptify.Framework.Application Namespace


FontUnderline Property

Aptify 5.0 Software Development Kit (SDK)

ViewField.FontUnderline Property

public Boolean FontUnderline {get;}

See Also

ViewField Class | Aptify.Framework.Application Namespace


FormatCategory Property

Aptify 5.0 Software Development Kit (SDK)

ViewField.FormatCategory Property

public ViewFieldFormatCategory FormatCategory {get;}

See Also

ViewField Class | Aptify.Framework.Application Namespace


FormatDecimalPlaces Property

Aptify 5.0 Software Development Kit (SDK)

ViewField.FormatDecimalPlaces Property

public Int32 FormatDecimalPlaces {get;}

See Also

ViewField Class | Aptify.Framework.Application Namespace


FormatNegativeNumType Property

Aptify 5.0 Software Development Kit (SDK)

ViewField.FormatNegativeNumType Property

public ViewFieldFormatNegativeNum FormatNegativeNumType {get;}

See Also

ViewField Class | Aptify.Framework.Application Namespace


FormatString Property

Aptify 5.0 Software Development Kit (SDK)

ViewField.FormatString Property

public String FormatString {get;}

See Also

ViewField Class | Aptify.Framework.Application Namespace


FormatUse1000Separator Property

Aptify 5.0 Software Development Kit (SDK)

ViewField.FormatUse1000Separator Property

public Boolean FormatUse1000Separator {get;}

See Also

ViewField Class | Aptify.Framework.Application Namespace


Sequence Property

Aptify 5.0 Software Development Kit (SDK)

ViewField.Sequence Property

Ordinal of the field.

public Int32 Sequence {get;}

Remarks

See Also

ViewField Class | Aptify.Framework.Application Namespace


SQLAllowNull Property

Aptify 5.0 Software Development Kit (SDK)

ViewField.SQLAllowNull Property

public Boolean SQLAllowNull {get;}

See Also

ViewField Class | Aptify.Framework.Application Namespace


SQLDataType Property

Aptify 5.0 Software Development Kit (SDK)

ViewField.SQLDataType Property

SQL Server data type (e.g., nvarchar, datetime, etc.)

public String SQLDataType {get;}

Remarks

See Also

ViewField Class | Aptify.Framework.Application Namespace


TextAlignment Property

Aptify 5.0 Software Development Kit (SDK)

ViewField.TextAlignment Property

public ViewFieldAlignment TextAlignment {get;}

See Also

ViewField Class | Aptify.Framework.Application Namespace


TextColor Property

Aptify 5.0 Software Development Kit (SDK)

ViewField.TextColor Property

Windows color for the text.

public Color TextColor {get;}

Remarks

See Also

ViewField Class | Aptify.Framework.Application Namespace


UseViewFormatting Property

Aptify 5.0 Software Development Kit (SDK)

ViewField.UseViewFormatting Property

public Boolean UseViewFormatting {get;}

See Also

ViewField Class | Aptify.Framework.Application Namespace


Visible Property

Aptify 5.0 Software Development Kit (SDK)

ViewField.Visible Property

Specifies if the label is visible to the user.

public Boolean Visible {get;}

Remarks

See Also

ViewField Class | Aptify.Framework.Application Namespace


Width Property

Aptify 5.0 Software Development Kit (SDK)

ViewField.Width Property

Size of the field. Used for variable length.

public Int32 Width {get;}

Remarks

See Also

ViewField Class | Aptify.Framework.Application Namespace


WordWrap Property

Aptify 5.0 Software Development Kit (SDK)

ViewField.WordWrap Property

Specifies if the display for the view's T-SQL statement supports word wrapping.

public Boolean WordWrap {get;}

Remarks

See Also

ViewField Class | Aptify.Framework.Application Namespace


WrapText Property

Aptify 5.0 Software Development Kit (SDK)

ViewField.WrapText Property

public Boolean WrapText {get;}

See Also

ViewField Class | Aptify.Framework.Application Namespace


ViewFieldAlignment Enumeration

public enum ViewFieldAlignment

Members

Member Name | Description
DefaultAlignment |
Left |
Center |
Right |

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyApplication (in AptifyApplication.dll)

See Also

Aptify.Framework.Application Namespace


ViewFieldBorderStyle Enumeration

public enum ViewFieldBorderStyle

Members

Member Name | Description
Default |
None |
Flat |
Double |
Raised |
Inset |
Groove |
Fillet |
Dotted |

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyApplication (in AptifyApplication.dll)

See Also

Aptify.Framework.Application Namespace


ViewFieldFormatCategory Enumeration

public enum ViewFieldFormatCategory

Members

Member Name | Description
General |
Number |
Currency |
DateFormat |
TimeFormat |
DateAndTimeFormat |
Percentage |
Custom |

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyApplication (in AptifyApplication.dll)

See Also

Aptify.Framework.Application Namespace


ViewFieldFormatNegativeNum Enumeration

public enum ViewFieldFormatNegativeNum

Members

Member Name | Description
UseMinusSign |
UseParenthesis |

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyApplication (in AptifyApplication.dll)

See Also

Aptify.Framework.Application Namespace


ViewFields Class

ViewFields is a collection of ViewField objects.

For a list of all members of this type, see ViewFields Members.

System.Object
NameObjectCollectionBase
AptifyCollection
ViewFields

public class ViewFields : AptifyCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyApplication (in AptifyApplication.dll)

See Also

ViewFields Members | Aptify.Framework.Application Namespace


ViewFields Members

ViewFields overview

Public Instance Constructors

ViewFields Constructor Initializes a new instance of the ViewFields class.

Public Instance Properties

Count (inherited from NameObjectCollectionBase) | Gets the number of key/value pairs contained in the NameObjectCollectionBase instance.
Item | Overloaded.
Keys (inherited from NameObjectCollectionBase) | Gets a KeysCollection instance that contains all the keys in the NameObjectCollectionBase instance.

Public Instance Methods

Add | Overloaded.
Clear (inherited from AptifyCollection) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from AptifyCollection) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from NameObjectCollectionBase) | Implements the ISerializable interface and returns the data needed to serialize the NameObjectCollectionBase instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from AptifyCollection) | Gets the index of the item with the specified Key.
Merge (inherited from AptifyCollection) | Allows a user to merge items from another collection to this collection.
OnDeserialization (inherited from NameObjectCollectionBase) | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete.
Remove (inherited from AptifyCollection) | Overloaded.
RemoveAt (inherited from AptifyCollection) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

IsReadOnly (inherited from NameObjectCollectionBase) Gets or sets a value indicating whether the NameObjectCollectionBase instance is read-only.

Protected Instance Methods

BaseAdd (inherited from NameObjectCollectionBase) | Adds an entry with the specified key and value into the NameObjectCollectionBase instance.
BaseClear (inherited from NameObjectCollectionBase) | Removes all entries from the NameObjectCollectionBase instance.
BaseGet (inherited from NameObjectCollectionBase) | Overloaded. Gets the value of the first entry with the specified key from the NameObjectCollectionBase instance.
BaseGetAllKeys (inherited from NameObjectCollectionBase) | Returns a String array that contains all the keys in the NameObjectCollectionBase instance.
BaseGetAllValues (inherited from NameObjectCollectionBase) | Overloaded. Returns an Object array that contains all the values in the NameObjectCollectionBase instance.
BaseGetKey (inherited from NameObjectCollectionBase) | Gets the key of the entry at the specified index of the NameObjectCollectionBase instance.
BaseHasKeys (inherited from NameObjectCollectionBase) | Gets a value indicating whether the NameObjectCollectionBase instance contains entries whose keys are not null.
BaseRemove (inherited from NameObjectCollectionBase) | Removes the entries with the specified key from the NameObjectCollectionBase instance.
BaseRemoveAt (inherited from NameObjectCollectionBase) | Removes the entry at the specified index of the NameObjectCollectionBase instance.
BaseSet (inherited from NameObjectCollectionBase) | Overloaded. Sets the value of the first entry with the specified key in the NameObjectCollectionBase instance, if found; otherwise, adds an entry with the specified key and value into the NameObjectCollectionBase instance.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ViewFields Class | Aptify.Framework.Application Namespace


ViewFields Constructor

Initializes a new instance of the ViewFields class.

public ViewFields();

See Also

ViewFields Class | Aptify.Framework.Application Namespace


ViewFields Properties

The properties of the ViewFields class are listed below. For a complete list of ViewFields class members, see the ViewFields Members topic.

Public Instance Properties

Count (inherited from NameObjectCollectionBase) | Gets the number of key/value pairs contained in the NameObjectCollectionBase instance.
Item | Overloaded.
Keys (inherited from NameObjectCollectionBase) | Gets a KeysCollection instance that contains all the keys in the NameObjectCollectionBase instance.

Protected Instance Properties

IsReadOnly (inherited from NameObjectCollectionBase) Gets or sets a value indicating whether the NameObjectCollectionBase instance is read-only.

See Also

ViewFields Class | Aptify.Framework.Application Namespace


ViewField Property

Aptify 5.0 Software Development Kit (SDK)

ViewFields.ViewField Property

Overload List

new public ViewField this[Int32] {get;}

new public ViewField this[String] {get;}

See Also

ViewFields Class | Aptify.Framework.Application Namespace


Item Property (Int32)

Aptify 5.0 Software Development Kit (SDK)

ViewFields.Item Property (Int32)

new public ViewField this[
Int32 Index
] {get;}

See Also

ViewFields Class | Aptify.Framework.Application Namespace | ViewFields.ViewField Overload List


Item Property (String)

Aptify 5.0 Software Development Kit (SDK)

ViewFields.Item Property (String)

new public ViewField this[
String Key
] {get;}

See Also

ViewFields Class | Aptify.Framework.Application Namespace | ViewFields.ViewField Overload List


ViewFields Methods

The methods of the ViewFields class are listed below. For a complete list of ViewFields class members, see the ViewFields Members topic.

Public Instance Methods

Add | Overloaded.
Clear (inherited from AptifyCollection) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from AptifyCollection) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from NameObjectCollectionBase) | Implements the ISerializable interface and returns the data needed to serialize the NameObjectCollectionBase instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from AptifyCollection) | Gets the index of the item with the specified Key.
Merge (inherited from AptifyCollection) | Allows a user to merge items from another collection to this collection.
OnDeserialization (inherited from NameObjectCollectionBase) | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete.
Remove (inherited from AptifyCollection) | Overloaded.
RemoveAt (inherited from AptifyCollection) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

BaseAdd (inherited from NameObjectCollectionBase) | Adds an entry with the specified key and value into the NameObjectCollectionBase instance.
BaseClear (inherited from NameObjectCollectionBase) | Removes all entries from the NameObjectCollectionBase instance.
BaseGet (inherited from NameObjectCollectionBase) | Overloaded. Gets the value of the first entry with the specified key from the NameObjectCollectionBase instance.
BaseGetAllKeys (inherited from NameObjectCollectionBase) | Returns a String array that contains all the keys in the NameObjectCollectionBase instance.
BaseGetAllValues (inherited from NameObjectCollectionBase) | Overloaded. Returns an Object array that contains all the values in the NameObjectCollectionBase instance.
BaseGetKey (inherited from NameObjectCollectionBase) | Gets the key of the entry at the specified index of the NameObjectCollectionBase instance.
BaseHasKeys (inherited from NameObjectCollectionBase) | Gets a value indicating whether the NameObjectCollectionBase instance contains entries whose keys are not null.
BaseRemove (inherited from NameObjectCollectionBase) | Removes the entries with the specified key from the NameObjectCollectionBase instance.
BaseRemoveAt (inherited from NameObjectCollectionBase) | Removes the entry at the specified index of the NameObjectCollectionBase instance.
BaseSet (inherited from NameObjectCollectionBase) | Overloaded. Sets the value of the first entry with the specified key in the NameObjectCollectionBase instance, if found; otherwise, adds an entry with the specified key and value into the NameObjectCollectionBase instance.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ViewFields Class | Aptify.Framework.Application Namespace


Add Method

Aptify 5.0 Software Development Kit (SDK)

ViewFields.Add Method

Overload List

public int Add(ViewField);

public override int Add(Object);

public override int Add(Object,String);

See Also

ViewFields Class | Aptify.Framework.Application Namespace


ViewFields.Add Method (ViewField)

public int Add(
ViewField Value
);

See Also

ViewFields Class | Aptify.Framework.Application Namespace | ViewFields.Add Overload List


ViewFields.Add Method (Object)

public override int Add(
Object Value
);

See Also

ViewFields Class | Aptify.Framework.Application Namespace | ViewFields.Add Overload List


ViewFields.Add Method (Object, String)

public override int Add(
Object Value,
String Key
);

See Also

ViewFields Class | Aptify.Framework.Application Namespace | ViewFields.Add Overload List


ViewInfo Class

A data-only object that can be retrieved from the Aptify application object that contains a view's properties. ViewInfo is a data-only object. All properties access data members in the class.

For a list of all members of this type, see ViewInfo Members.

System.Object
ViewInfo

public class ViewInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyApplication (in AptifyApplication.dll)

See Also

ViewInfo Members | Aptify.Framework.Application Namespace


ViewInfo Members

ViewInfo overview

Public Instance Properties

AlternateRowBackColor |
AppendDateToFileName |
AutoRefreshInterval |
AutoRefreshMode |
BaseDatabase |
BaseView |
CustomFormatting |
EmailRecipients |
EntityBaseViewName |
EntityID | Primary key of the entity.
EntityName | Unique name of the entity.
FieldLevelFormatting |
FontBold |
FontItalic |
FontName |
FontSize |
FontUnderline |
FromSQL | FROM portion of the view's SQL statement.
IsPromptedView | If true, the view prompts the user for values.
IsScheduled |
OrderBySQL | ORDER BY portion of the view's TSQL statement.
OutputFileDirectory |
OutputFileName |
OutputMode |
OutputPrinter |
OutputType |
PagingEnabled | Specifies if the view has the paging feature (where the viewer displays rows on multiple pages) is enabled.
PagingSize | Number of records displayed on a page in a view (when paging is enabled).
PrimarySortAsc |
PrimarySortField |
Report |
RowBackColor |
RowHeight |
ScheduledTaskID |
SelectSQL | SELECT portion of the view's T-SQL statement.
ShowPreviewPane | Returns the Show preview pane value of the view
ShowRefreshIntervalTimer |
SubViews | A collection of SubViews objects.
TextColor |
Value |
ValueExists |
ViewFields | A collection of ViewFields objects.
ViewID | Primary key of the view.
ViewName | Name of the view.
ViewSQL | The view's full T-SQL statement.
ViewSQLStatement | Returns a SQLStatement object for the ViewSQL
ViewType |
ViewTypeID |
WhereSQL | WHERE clause portion of the view's SQL statement.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
LoadEmailRecipientsToArrays |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ParseViewSQL | This method parses the ViewSQL() into its component parts. It is called automatically the first time one of the component parts such as SelectSQL, or WhereSQL is accessed for a given View. If the ViewSQL is changed at some point, this method must be called manually to refresh the component parts.

See Also

ViewInfo Class | Aptify.Framework.Application Namespace


ViewInfo Properties

The properties of the ViewInfo class are listed below. For a complete list of ViewInfo class members, see the ViewInfo Members topic.

Public Instance Properties

AlternateRowBackColor |
AppendDateToFileName |
AutoRefreshInterval |
AutoRefreshMode |
BaseDatabase |
BaseView |
CustomFormatting |
EmailRecipients |
EntityBaseViewName |
EntityID | Primary key of the entity.
EntityName | Unique name of the entity.
FieldLevelFormatting |
FontBold |
FontItalic |
FontName |
FontSize |
FontUnderline |
FromSQL | FROM portion of the view's SQL statement.
IsPromptedView | If true, the view prompts the user for values.
IsScheduled |
OrderBySQL | ORDER BY portion of the view's TSQL statement.
OutputFileDirectory |
OutputFileName |
OutputMode |
OutputPrinter |
OutputType |
PagingEnabled | Specifies if the view has the paging feature (where the viewer displays rows on multiple pages) is enabled.
PagingSize | Number of records displayed on a page in a view (when paging is enabled).
PrimarySortAsc |
PrimarySortField |
Report |
RowBackColor |
RowHeight |
ScheduledTaskID |
SelectSQL | SELECT portion of the view's T-SQL statement.
ShowPreviewPane | Returns the Show preview pane value of the view
ShowRefreshIntervalTimer |
SubViews | A collection of SubViews objects.
TextColor |
Value |
ValueExists |
ViewFields | A collection of ViewFields objects.
ViewID | Primary key of the view.
ViewName | Name of the view.
ViewSQL | The view's full T-SQL statement.
ViewSQLStatement | Returns a SQLStatement object for the ViewSQL
ViewType |
ViewTypeID |
WhereSQL | WHERE clause portion of the view's SQL statement.

See Also

ViewInfo Class | Aptify.Framework.Application Namespace


AlternateRowBackColor Property

Aptify 5.0 Software Development Kit (SDK)

ViewInfo.AlternateRowBackColor Property

public Color AlternateRowBackColor {get;}

See Also

ViewInfo Class | Aptify.Framework.Application Namespace


AppendDateToFileName Property

Aptify 5.0 Software Development Kit (SDK)

ViewInfo.AppendDateToFileName Property

public Boolean AppendDateToFileName {get;}

See Also

ViewInfo Class | Aptify.Framework.Application Namespace


AutoRefreshInterval Property

Aptify 5.0 Software Development Kit (SDK)

ViewInfo.AutoRefreshInterval Property

public Single AutoRefreshInterval {get;}

See Also

ViewInfo Class | Aptify.Framework.Application Namespace


AutoRefreshMode Property

Aptify 5.0 Software Development Kit (SDK)

ViewInfo.AutoRefreshMode Property

public ViewInfo.ViewAutoRefreshMode AutoRefreshMode {get;}

See Also

ViewInfo Class | Aptify.Framework.Application Namespace


BaseDatabase Property

Aptify 5.0 Software Development Kit (SDK)

ViewInfo.BaseDatabase Property

public String BaseDatabase {get;}

See Also

ViewInfo Class | Aptify.Framework.Application Namespace


BaseView Property

Aptify 5.0 Software Development Kit (SDK)

ViewInfo.BaseView Property

public String BaseView {get;}

See Also

ViewInfo Class | Aptify.Framework.Application Namespace


CustomFormatting Property

Aptify 5.0 Software Development Kit (SDK)

ViewInfo.CustomFormatting Property

public Boolean CustomFormatting {get;}

See Also

ViewInfo Class | Aptify.Framework.Application Namespace


EmailRecipients Property

Aptify 5.0 Software Development Kit (SDK)

ViewInfo.EmailRecipients Property

public ViewEmailRecipient[] EmailRecipients {get;}

See Also

ViewInfo Class | Aptify.Framework.Application Namespace


EntityBaseViewName Property

Aptify 5.0 Software Development Kit (SDK)

ViewInfo.EntityBaseViewName Property

public String EntityBaseViewName {get;}

See Also

ViewInfo Class | Aptify.Framework.Application Namespace


EntityID Property

Aptify 5.0 Software Development Kit (SDK)

ViewInfo.EntityID Property

Primary key of the entity.

public Int64 EntityID {get;}

Remarks

See Also

ViewInfo Class | Aptify.Framework.Application Namespace


EntityName Property

Aptify 5.0 Software Development Kit (SDK)

ViewInfo.EntityName Property

Unique name of the entity.

public String EntityName {get;}

Remarks

See Also

ViewInfo Class | Aptify.Framework.Application Namespace


FieldLevelFormatting Property

Aptify 5.0 Software Development Kit (SDK)

ViewInfo.FieldLevelFormatting Property

public Boolean FieldLevelFormatting {get;}

See Also

ViewInfo Class | Aptify.Framework.Application Namespace


FontBold Property

Aptify 5.0 Software Development Kit (SDK)

ViewInfo.FontBold Property

public Boolean FontBold {get;}

See Also

ViewInfo Class | Aptify.Framework.Application Namespace


FontItalic Property

Aptify 5.0 Software Development Kit (SDK)

ViewInfo.FontItalic Property

public Boolean FontItalic {get;}

See Also

ViewInfo Class | Aptify.Framework.Application Namespace


FontName Property

Aptify 5.0 Software Development Kit (SDK)

ViewInfo.FontName Property

public String FontName {get;}

See Also

ViewInfo Class | Aptify.Framework.Application Namespace


FontSize Property

Aptify 5.0 Software Development Kit (SDK)

ViewInfo.FontSize Property

public Single FontSize {get;}

See Also

ViewInfo Class | Aptify.Framework.Application Namespace


FontUnderline Property

Aptify 5.0 Software Development Kit (SDK)

ViewInfo.FontUnderline Property

public Boolean FontUnderline {get;}

See Also

ViewInfo Class | Aptify.Framework.Application Namespace


FromSQL Property

Aptify 5.0 Software Development Kit (SDK)

ViewInfo.FromSQL Property

FROM portion of the view's SQL statement.

public String FromSQL {get;}

Remarks

See Also

ViewInfo Class | Aptify.Framework.Application Namespace


IsPromptedView Property

Aptify 5.0 Software Development Kit (SDK)

ViewInfo.IsPromptedView Property

If true, the view prompts the user for values.

public Boolean IsPromptedView {get;}

Remarks

See Also

ViewInfo Class | Aptify.Framework.Application Namespace


IsScheduled Property

Aptify 5.0 Software Development Kit (SDK)

ViewInfo.IsScheduled Property

public Boolean IsScheduled {get;}

See Also

ViewInfo Class | Aptify.Framework.Application Namespace


OrderBySQL Property

Aptify 5.0 Software Development Kit (SDK)

ViewInfo.OrderBySQL Property

ORDER BY portion of the view's TSQL statement.

public String OrderBySQL {get;}

Remarks

See Also

ViewInfo Class | Aptify.Framework.Application Namespace


OutputFileDirectory Property

Aptify 5.0 Software Development Kit (SDK)

ViewInfo.OutputFileDirectory Property

public String OutputFileDirectory {get;}

See Also

ViewInfo Class | Aptify.Framework.Application Namespace


OutputFileName Property

Aptify 5.0 Software Development Kit (SDK)

ViewInfo.OutputFileName Property

public String OutputFileName {get;}

See Also

ViewInfo Class | Aptify.Framework.Application Namespace


OutputMode Property

Aptify 5.0 Software Development Kit (SDK)

ViewInfo.OutputMode Property

public ViewInfo.ViewOutputMode OutputMode {get;}

See Also

ViewInfo Class | Aptify.Framework.Application Namespace


OutputPrinter Property

Aptify 5.0 Software Development Kit (SDK)

ViewInfo.OutputPrinter Property

public String OutputPrinter {get;}

See Also

ViewInfo Class | Aptify.Framework.Application Namespace


OutputType Property

Aptify 5.0 Software Development Kit (SDK)

ViewInfo.OutputType Property

public ViewInfo.ViewOutputType OutputType {get;}

See Also

ViewInfo Class | Aptify.Framework.Application Namespace


PagingEnabled Property

Aptify 5.0 Software Development Kit (SDK)

ViewInfo.PagingEnabled Property

Specifies if the view has the paging feature (where the viewer displays rows on multiple pages) is enabled.

public Boolean PagingEnabled {get; set;}

Remarks

See Also

ViewInfo Class | Aptify.Framework.Application Namespace


PagingSize Property

Aptify 5.0 Software Development Kit (SDK)

ViewInfo.PagingSize Property

Number of records displayed on a page in a view (when paging is enabled).

public Int32 PagingSize {get; set;}

Remarks

See Also

ViewInfo Class | Aptify.Framework.Application Namespace


PrimarySortAsc Property

Aptify 5.0 Software Development Kit (SDK)

ViewInfo.PrimarySortAsc Property

public Boolean PrimarySortAsc {get;}

See Also

ViewInfo Class | Aptify.Framework.Application Namespace


PrimarySortField Property

Aptify 5.0 Software Development Kit (SDK)

ViewInfo.PrimarySortField Property

public String PrimarySortField {get;}

See Also

ViewInfo Class | Aptify.Framework.Application Namespace


Report Property

Aptify 5.0 Software Development Kit (SDK)

ViewInfo.Report Property

public String Report {get;}

See Also

ViewInfo Class | Aptify.Framework.Application Namespace


RowBackColor Property

Aptify 5.0 Software Development Kit (SDK)

ViewInfo.RowBackColor Property

public Color RowBackColor {get;}

See Also

ViewInfo Class | Aptify.Framework.Application Namespace


RowHeight Property

Aptify 5.0 Software Development Kit (SDK)

ViewInfo.RowHeight Property

public Int32 RowHeight {get;}

See Also

ViewInfo Class | Aptify.Framework.Application Namespace


ScheduledTaskID Property

Aptify 5.0 Software Development Kit (SDK)

ViewInfo.ScheduledTaskID Property

public Int64 ScheduledTaskID {get;}

See Also

ViewInfo Class | Aptify.Framework.Application Namespace


SelectSQL Property

Aptify 5.0 Software Development Kit (SDK)

ViewInfo.SelectSQL Property

SELECT portion of the view's T-SQL statement.

public String SelectSQL {get;}

Remarks

See Also

ViewInfo Class | Aptify.Framework.Application Namespace


ShowPreviewPane Property

Aptify 5.0 Software Development Kit (SDK)

ViewInfo.ShowPreviewPane Property

Returns the Show preview pane value of the view

public Boolean ShowPreviewPane {get;}

Property Value

Remarks

See Also

ViewInfo Class | Aptify.Framework.Application Namespace


ShowRefreshIntervalTimer Property

Aptify 5.0 Software Development Kit (SDK)

ViewInfo.ShowRefreshIntervalTimer Property

public Boolean ShowRefreshIntervalTimer {get;}

See Also

ViewInfo Class | Aptify.Framework.Application Namespace


SubViews Property

Aptify 5.0 Software Development Kit (SDK)

ViewInfo.SubViews Property

A collection of SubViews objects.

public SubViews SubViews {get;}

Property Value

Remarks

See Also

ViewInfo Class | Aptify.Framework.Application Namespace


TextColor Property

Aptify 5.0 Software Development Kit (SDK)

ViewInfo.TextColor Property

public Color TextColor {get;}

See Also

ViewInfo Class | Aptify.Framework.Application Namespace


Value Property

Aptify 5.0 Software Development Kit (SDK)

ViewInfo.Value Property

public Object this[
String Name
] {get;}

See Also

ViewInfo Class | Aptify.Framework.Application Namespace


ValueExists Property

Aptify 5.0 Software Development Kit (SDK)

ViewInfo.ValueExists Property

public Boolean this[
String Name
] {get;}

See Also

ViewInfo Class | Aptify.Framework.Application Namespace


ViewFields Property

Aptify 5.0 Software Development Kit (SDK)

ViewInfo.ViewFields Property

A collection of ViewFields objects.

public ViewFields ViewFields {get;}

Remarks

See Also

ViewInfo Class | Aptify.Framework.Application Namespace


ViewID Property

Aptify 5.0 Software Development Kit (SDK)

ViewInfo.ViewID Property

Primary key of the view.

public Int64 ViewID {get;}

Remarks

See Also

ViewInfo Class | Aptify.Framework.Application Namespace


ViewName Property

Aptify 5.0 Software Development Kit (SDK)

ViewInfo.ViewName Property

Name of the view.

public String ViewName {get;}

Remarks

See Also

ViewInfo Class | Aptify.Framework.Application Namespace


ViewSQL Property

Aptify 5.0 Software Development Kit (SDK)

ViewInfo.ViewSQL Property

The view's full T-SQL statement.

public String ViewSQL {get;}

Remarks

See Also

ViewInfo Class | Aptify.Framework.Application Namespace


ViewSQLStatement Property

Aptify 5.0 Software Development Kit (SDK)

ViewInfo.ViewSQLStatement Property

Returns a SQLStatement object for the ViewSQL

public SQLStatement ViewSQLStatement {get;}

Property Value

Remarks

See Also

ViewInfo Class | Aptify.Framework.Application Namespace


ViewType Property

Aptify 5.0 Software Development Kit (SDK)

ViewInfo.ViewType Property

public String ViewType {get;}

See Also

ViewInfo Class | Aptify.Framework.Application Namespace


ViewTypeID Property

Aptify 5.0 Software Development Kit (SDK)

ViewInfo.ViewTypeID Property

public Int64 ViewTypeID {get;}

See Also

ViewInfo Class | Aptify.Framework.Application Namespace


WhereSQL Property

Aptify 5.0 Software Development Kit (SDK)

ViewInfo.WhereSQL Property

WHERE clause portion of the view's SQL statement.

public String WhereSQL {get;}

Remarks

Currently Aptify does not have logic that parses SQL statements to return it's WHERE clause. Until this logic is completed, Aptify is relying on View Filters and the ViewsEntity to return our WhereSQL. If the View is based on custom SQL, then String.Empty will be returned. If the ViewId is less than 1, then String.Empty will be returned. If there is a valid Where clause returned, then WHERE will begin the string. The GenerateWhereSQL is reserved by Aptify and should not be called directly.

See Also

ViewInfo Class | Aptify.Framework.Application Namespace


ViewInfo Methods

The methods of the ViewInfo class are listed below. For a complete list of ViewInfo class members, see the ViewInfo Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
LoadEmailRecipientsToArrays |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ParseViewSQL | This method parses the ViewSQL() into its component parts. It is called automatically the first time one of the component parts such as SelectSQL, or WhereSQL is accessed for a given View. If the ViewSQL is changed at some point, this method must be called manually to refresh the component parts.

See Also

ViewInfo Class | Aptify.Framework.Application Namespace


ViewInfo.LoadEmailRecipientsToArrays Method

public void LoadEmailRecipientsToArrays(
String[] ToList,
String[] CCList,
String[] BCCList
);

See Also

ViewInfo Class | Aptify.Framework.Application Namespace


ViewInfo.ParseViewSQL Method

This method parses the ViewSQL() into its component parts. It is called automatically the first time one of the component parts such as SelectSQL, or WhereSQL is accessed for a given View. If the ViewSQL is changed at some point, this method must be called manually to refresh the component parts.

protected virtual void ParseViewSQL();

Remarks

See Also

ViewInfo Class | Aptify.Framework.Application Namespace


ViewInfo.ViewAutoRefreshMode Enumeration

public enum ViewInfo.ViewAutoRefreshMode

Members

Member Name | Description
None |
LocalDataChanges |
IntervalBased |

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyApplication (in AptifyApplication.dll)

See Also

Aptify.Framework.Application Namespace


ViewInfo.ViewEmailRecipient Structure

For a list of all members of this type, see ViewInfo.ViewEmailRecipient Members.

System.Object
ValueType
ViewInfo.ViewEmailRecipient

public struct ViewInfo.ViewEmailRecipient

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyApplication (in AptifyApplication.dll)

See Also

ViewInfo.ViewEmailRecipient Members | Aptify.Framework.Application Namespace


ViewInfo.ViewEmailRecipient Members

ViewInfo.ViewEmailRecipient overview

Public Instance Fields

EmailAddress
RecipientType

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

ViewInfo.ViewEmailRecipient Structure | Aptify.Framework.Application Namespace


ViewInfo.ViewEmailRecipient Fields

The fields of the ViewInfo.ViewEmailRecipient structure are listed below. For a complete list of ViewInfo.ViewEmailRecipient structure members, see the ViewInfo.ViewEmailRecipient Members topic.

Public Instance Fields

EmailAddress
RecipientType

See Also

ViewInfo.ViewEmailRecipient Structure | Aptify.Framework.Application Namespace


ViewInfo.ViewEmailRecipient.EmailAddress Field

public EmailAddress EmailAddress;

See Also

ViewInfo.ViewEmailRecipient Class | Aptify.Framework.Application Namespace


ViewInfo.ViewEmailRecipient.RecipientType Field

public RecipientType RecipientType;

See Also

ViewInfo.ViewEmailRecipient Class | Aptify.Framework.Application Namespace


ViewInfo.ViewEmailRecipientType Enumeration

public enum ViewInfo.ViewEmailRecipientType

Members

Member Name | Description
ToRecipient |
CCRecipient |
BCCRecipient |

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyApplication (in AptifyApplication.dll)

See Also

Aptify.Framework.Application Namespace


ViewInfo.ViewOutputMode Enumeration

public enum ViewInfo.ViewOutputMode

Members

Member Name | Description
Email |
File |
Print |

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyApplication (in AptifyApplication.dll)

See Also

Aptify.Framework.Application Namespace


ViewInfo.ViewOutputType Enumeration

public enum ViewInfo.ViewOutputType

Members

Member Name | Description
View |
Report |
Excel |

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyApplication (in AptifyApplication.dll)

See Also

Aptify.Framework.Application Namespace


WeakReference<ItemType> Class

This Subclasses WeakReference`1 as a Generic.

For a list of all members of this type, see WeakReference<ItemType> Members.

System.Object
WeakReference
WeakReference<ItemType>

public class WeakReference<ItemType> : WeakReference

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.Application

Assembly: AptifyUtility (in AptifyUtility.dll)

See Also

WeakReference<ItemType> Members | Aptify.Framework.Application Namespace


WeakReference<ItemType> Members

WeakReference<ItemType> overview

Public Instance Constructors

WeakReference<ItemType> Overloaded. Initializes a new instance of the WeakReference<ItemType> class.

Public Instance Properties

IsAlive (inherited from WeakReference) | Gets an indication whether the object referenced by the current WeakReference object has been garbage collected.
Target | Overloaded. Gets or sets the object referenced by this type.
Test |
TrackResurrection (inherited from WeakReference) | Gets an indication whether the object referenced by the current WeakReference object is tracked after it is finalized.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from WeakReference) | Populates a SerializationInfo object with all the data needed to serialize the current WeakReference object.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from WeakReference) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

WeakReference<ItemType> Class | Aptify.Framework.Application Namespace


WeakReference<ItemType> Constructor

Overload List

public WeakReference<ItemType>(WeakReference<ItemType>.ItemType);

public WeakReference<ItemType>(WeakReference<ItemType>.ItemType,Boolean);

public WeakReference<ItemType>(SerializationInfo,StreamingContext);

See Also

WeakReference<ItemType> Class | Aptify.Framework.Application Namespace


WeakReference<ItemType> Constructor (ItemType)

public WeakReference<ItemType>(
WeakReference<ItemType>.ItemType Target
);

See Also

WeakReference<ItemType> Class | Aptify.Framework.Application Namespace | WeakReference<ItemType> Constructor Overload List


WeakReference<ItemType> Constructor (ItemType, Boolean)

public WeakReference<ItemType>(
WeakReference<ItemType>.ItemType Target,
Boolean TrackResurrection
);

See Also

WeakReference<ItemType> Class | Aptify.Framework.Application Namespace | WeakReference<ItemType> Constructor Overload List


WeakReference<ItemType> Constructor (SerializationInfo, StreamingContext)

public WeakReference<ItemType>(
SerializationInfo Info,
StreamingContext Context
);

See Also

WeakReference<ItemType> Class | Aptify.Framework.Application Namespace | WeakReference<ItemType> Constructor Overload List


WeakReference<ItemType> Properties

The properties of the WeakReference<ItemType> class are listed below. For a complete list of WeakReference<ItemType> class members, see the WeakReference<ItemType> Members topic.

Public Instance Properties

IsAlive (inherited from WeakReference) | Gets an indication whether the object referenced by the current WeakReference object has been garbage collected.
Target | Overloaded. Gets or sets the object referenced by this type.
Test |
TrackResurrection (inherited from WeakReference) | Gets an indication whether the object referenced by the current WeakReference object is tracked after it is finalized.

See Also

WeakReference<ItemType> Class | Aptify.Framework.Application Namespace


Target Property

Aptify 5.0 Software Development Kit (SDK)

WeakReference<ItemType>.Target Property

Gets or sets the object referenced by this type.

new public WeakReference<ItemType>.ItemType Target {get; set;}

Property Value

Remarks

The target if it exists and Nothing if it has been garbage collected. If the target is a different type than expected, then Nothing will be returned.

See Also

WeakReference<ItemType> Class | Aptify.Framework.Application Namespace


Test Property

Aptify 5.0 Software Development Kit (SDK)

WeakReference<ItemType>.Test Property

public WeakReference<ItemType>.ItemType Test {get; set;}

See Also

WeakReference<ItemType> Class | Aptify.Framework.Application Namespace


Aptify.Framework.ApplicationRibbonGroup.Components

Aptify 5.0 Software Development Kit (SDK)

Aptify.Framework.ApplicationRibbonGroup.Components Namespace

This namespace contains the available action type components that be used to create buttons in an Aptify Ribbon.

Namespace hierarchy

Classes

Class | Description
DropDownParams |
FindDlgParams |
GenericDataWizardParams | This class will provide functionality to add and run Aptify Generic Data Wizard from Dashboard
OpenFormParams |
ProcessFlowParams |
ReportParams |
RibbonButtonButton |
RibbonButtons |
RibbonGroupButtonForm |
RibbonGroupConstants |
RibbonGroupForm |
SwitchDashboardParams |
WizardParams |

Interfaces

Interface | Description
IRibbonButtonPropPage | This interface implemented by a user control that will act as a property page for a RibbonButton entity. IRibbonButtonPropPage provides an interface for components that will act as property pages for RibbonButton entities.


DropDownParams Class

For a list of all members of this type, see DropDownParams Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
DropDownParams

public class DropDownParams : UserControl, IRibbonButtonPropPage

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.ApplicationRibbonGroup.Components

Assembly: AptifyApplicationRibbonGroup (in AptifyApplicationRibbonGroup.dll)

See Also

DropDownParams Members | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


DropDownParams Members

DropDownParams overview

Public Instance Constructors

DropDownParams Constructor Initializes a new instance of the DropDownParams class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LoadProperties |
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
SaveProperties |
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

DropDownParams Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


DropDownParams Constructor

Initializes a new instance of the DropDownParams class.

public DropDownParams();

See Also

DropDownParams Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


DropDownParams Methods

The methods of the DropDownParams class are listed below. For a complete list of DropDownParams class members, see the DropDownParams Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LoadProperties |
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
SaveProperties |
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

DropDownParams Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


DropDownParams.Config Method

public void Config(
AptifyApplication ApplicationObject
);

Implements

IRibbonButtonPropPage.

See Also

DropDownParams Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

DropDownParams.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

DropDownParams Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


DropDownParams.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

DropDownParams Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace | DropDownParams.Dispose Overload List


DropDownParams.LoadProperties Method

public void LoadProperties(
AptifyGenericEntityBase Part
);

Implements

IRibbonButtonPropPage.

See Also

DropDownParams Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


DropDownParams.SaveProperties Method

public void SaveProperties();

Implements

IRibbonButtonPropPage.

See Also

DropDownParams Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


FindDlgParams Class

For a list of all members of this type, see FindDlgParams Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FindDlgParams

public class FindDlgParams : UserControl, IRibbonButtonPropPage

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.ApplicationRibbonGroup.Components

Assembly: AptifyApplicationRibbonGroup (in AptifyApplicationRibbonGroup.dll)

See Also

FindDlgParams Members | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


FindDlgParams Members

FindDlgParams overview

Public Instance Constructors

FindDlgParams Constructor Initializes a new instance of the FindDlgParams class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LoadProperties |
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
SaveProperties |
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

FindDlgParams Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


FindDlgParams Constructor

Initializes a new instance of the FindDlgParams class.

public FindDlgParams();

See Also

FindDlgParams Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


FindDlgParams Methods

The methods of the FindDlgParams class are listed below. For a complete list of FindDlgParams class members, see the FindDlgParams Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LoadProperties |
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
SaveProperties |
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

FindDlgParams Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


FindDlgParams.Config Method

public void Config(
AptifyApplication ApplicationObject
);

Implements

IRibbonButtonPropPage.

See Also

FindDlgParams Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

FindDlgParams.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

FindDlgParams Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


FindDlgParams.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

FindDlgParams Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace | FindDlgParams.Dispose Overload List


FindDlgParams.LoadProperties Method

public void LoadProperties(
AptifyGenericEntityBase Part
);

Implements

IRibbonButtonPropPage.

See Also

FindDlgParams Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


FindDlgParams.SaveProperties Method

public void SaveProperties();

Implements

IRibbonButtonPropPage.

See Also

FindDlgParams Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


GenericDataWizardParams Class

This class will provide functionality to add and run Aptify Generic Data Wizard from Dashboard

For a list of all members of this type, see GenericDataWizardParams Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
GenericDataWizardParams

public class GenericDataWizardParams : UserControl, IRibbonButtonPropPage

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.ApplicationRibbonGroup.Components

Assembly: AptifyApplicationRibbonGroup (in AptifyApplicationRibbonGroup.dll)

See Also

GenericDataWizardParams Members | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


GenericDataWizardParams Members

GenericDataWizardParams overview

Public Instance Constructors

GenericDataWizardParams Constructor Initializes a new instance of the GenericDataWizardParams class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AreaId |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LoadProperties |
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
SaveProperties |
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

GenericDataWizardParams Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


GenericDataWizardParams Constructor

Initializes a new instance of the GenericDataWizardParams class.

public GenericDataWizardParams();

See Also

GenericDataWizardParams Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


GenericDataWizardParams Properties

The properties of the GenericDataWizardParams class are listed below. For a complete list of GenericDataWizardParams class members, see the GenericDataWizardParams Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AreaId |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

GenericDataWizardParams Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


AreaId Property

Aptify 5.0 Software Development Kit (SDK)

GenericDataWizardParams.AreaId Property

public Int64 AreaId {set;}

See Also

GenericDataWizardParams Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


GenericDataWizardParams Methods

The methods of the GenericDataWizardParams class are listed below. For a complete list of GenericDataWizardParams class members, see the GenericDataWizardParams Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LoadProperties |
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
SaveProperties |
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

GenericDataWizardParams Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


GenericDataWizardParams.Config Method

public void Config(
AptifyApplication ApplicationObject
);

Implements

IRibbonButtonPropPage.

See Also

GenericDataWizardParams Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

GenericDataWizardParams.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

GenericDataWizardParams Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


GenericDataWizardParams.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

GenericDataWizardParams Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace | GenericDataWizardParams.Dispose Overload List


GenericDataWizardParams.LoadProperties Method

public void LoadProperties(
AptifyGenericEntityBase Part
);

Implements

IRibbonButtonPropPage.

See Also

GenericDataWizardParams Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


GenericDataWizardParams.SaveProperties Method

public void SaveProperties();

Implements

IRibbonButtonPropPage.

See Also

GenericDataWizardParams Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


IRibbonButtonPropPage Interface

This interface implemented by a user control that will act as a property page for a RibbonButton entity. IRibbonButtonPropPage provides an interface for components that will act as property pages for RibbonButton entities.

For a list of all members of this type, see IRibbonButtonPropPage Members.

public interface IRibbonButtonPropPage

Types that implement IRibbonButtonPropPage

Type | Description
DropDownParams |
FindDlgParams |
GenericDataWizardParams | This class will provide functionality to add and run Aptify Generic Data Wizard from Dashboard
OpenFormParams |
ProcessFlowParams |
ReportParams |
SwitchDashboardParams |
WizardParams |
EntityBulkOperationsRibbonButtonPropertiesPage |

Requirements

Namespace: Aptify.Framework.ApplicationRibbonGroup.Components

Assembly: AptifyApplicationRibbonGroup (in AptifyApplicationRibbonGroup.dll)

See Also

IRibbonButtonPropPage Members | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


IRibbonButtonPropPage Members

IRibbonButtonPropPage overview

Public Instance Methods

Config | Config allows the RibbonButtonPropPage to be initialized with a ApplicationObject.
LoadProperties | This initializes the property page with the current set of properties and defaults.
SaveProperties | SaveProperties is responsible for updating the GE with the current values on the property page.

See Also

IRibbonButtonPropPage Interface | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


IRibbonButtonPropPage Methods

The methods of the IRibbonButtonPropPage interface are listed below. For a complete list of IRibbonButtonPropPage interface members, see the IRibbonButtonPropPage Members topic.

Public Instance Methods

Config | Config allows the RibbonButtonPropPage to be initialized with a ApplicationObject.
LoadProperties | This initializes the property page with the current set of properties and defaults.
SaveProperties | SaveProperties is responsible for updating the GE with the current values on the property page.

See Also

IRibbonButtonPropPage Interface | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


IRibbonButtonPropPage.Config Method

Config allows the RibbonButtonPropPage to be initialized with a ApplicationObject.

void Config(
AptifyApplication ApplicationObject
);

Parameters

ApplicationObject
An instantiated class that is used to retrieve general system information.

See Also

IRibbonButtonPropPage Interface | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


IRibbonButtonPropPage.LoadProperties Method

This initializes the property page with the current set of properties and defaults.

void LoadProperties(
AptifyGenericEntityBase Part
);

Parameters

Part
This is a GE record that contains the properties for this property page. This interface is used in many places so the Type of the GE record is not specific to this interface. The developer should be familiar with the process that they are working with.

Remarks

See Also

IRibbonButtonPropPage Interface | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


IRibbonButtonPropPage.SaveProperties Method

SaveProperties is responsible for updating the GE with the current values on the property page.

void SaveProperties();

Remarks

If a Property value is required and has not been provided or the value is in an invalid format, then this member should throw an exception. If an exception is thrown then the message will be displayed and the data will not be saved.

See Also

IRibbonButtonPropPage Interface | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


OpenFormParams Class

For a list of all members of this type, see OpenFormParams Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
OpenFormParams

public class OpenFormParams : UserControl, IRibbonButtonPropPage

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.ApplicationRibbonGroup.Components

Assembly: AptifyApplicationRibbonGroup (in AptifyApplicationRibbonGroup.dll)

See Also

OpenFormParams Members | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


OpenFormParams Members

OpenFormParams overview

Public Instance Constructors

OpenFormParams Constructor Initializes a new instance of the OpenFormParams class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LoadProperties |
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
SaveProperties |
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

OpenFormParams Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


OpenFormParams Constructor

Initializes a new instance of the OpenFormParams class.

public OpenFormParams();

See Also

OpenFormParams Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


OpenFormParams Methods

The methods of the OpenFormParams class are listed below. For a complete list of OpenFormParams class members, see the OpenFormParams Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LoadProperties |
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
SaveProperties |
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

OpenFormParams Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


OpenFormParams.Config Method

public void Config(
AptifyApplication ApplicationObject
);

Implements

IRibbonButtonPropPage.

See Also

OpenFormParams Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

OpenFormParams.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

OpenFormParams Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


OpenFormParams.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

OpenFormParams Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace | OpenFormParams.Dispose Overload List


OpenFormParams.LoadProperties Method

public void LoadProperties(
AptifyGenericEntityBase Part
);

Implements

IRibbonButtonPropPage.

See Also

OpenFormParams Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


OpenFormParams.SaveProperties Method

public void SaveProperties();

Implements

IRibbonButtonPropPage.

See Also

OpenFormParams Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


ProcessFlowParams Class

For a list of all members of this type, see ProcessFlowParams Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
ProcessFlowParams

public class ProcessFlowParams : UserControl, IRibbonButtonPropPage

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.ApplicationRibbonGroup.Components

Assembly: AptifyApplicationRibbonGroup (in AptifyApplicationRibbonGroup.dll)

See Also

ProcessFlowParams Members | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


ProcessFlowParams Members

ProcessFlowParams overview

Public Instance Constructors

ProcessFlowParams Constructor Initializes a new instance of the ProcessFlowParams class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LoadProperties |
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
SaveProperties |
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ProcessFlowParams Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


ProcessFlowParams Constructor

Initializes a new instance of the ProcessFlowParams class.

public ProcessFlowParams();

See Also

ProcessFlowParams Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


ProcessFlowParams Methods

The methods of the ProcessFlowParams class are listed below. For a complete list of ProcessFlowParams class members, see the ProcessFlowParams Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LoadProperties |
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
SaveProperties |
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ProcessFlowParams Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


ProcessFlowParams.Config Method

public void Config(
AptifyApplication ApplicationObject
);

Implements

IRibbonButtonPropPage.

See Also

ProcessFlowParams Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowParams.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

ProcessFlowParams Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


ProcessFlowParams.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

ProcessFlowParams Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace | ProcessFlowParams.Dispose Overload List


ProcessFlowParams.LoadProperties Method

public void LoadProperties(
AptifyGenericEntityBase Part
);

Implements

IRibbonButtonPropPage.

See Also

ProcessFlowParams Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


ProcessFlowParams.SaveProperties Method

public void SaveProperties();

Implements

IRibbonButtonPropPage.

See Also

ProcessFlowParams Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


ReportParams Class

For a list of all members of this type, see ReportParams Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
ReportParams

public class ReportParams : UserControl, IRibbonButtonPropPage

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.ApplicationRibbonGroup.Components

Assembly: AptifyApplicationRibbonGroup (in AptifyApplicationRibbonGroup.dll)

See Also

ReportParams Members | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


ReportParams Members

ReportParams overview

Public Instance Constructors

ReportParams Constructor Initializes a new instance of the ReportParams class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LoadProperties |
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
SaveProperties |
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ReportParams Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


ReportParams Constructor

Initializes a new instance of the ReportParams class.

public ReportParams();

See Also

ReportParams Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


ReportParams Methods

The methods of the ReportParams class are listed below. For a complete list of ReportParams class members, see the ReportParams Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LoadProperties |
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
SaveProperties |
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ReportParams Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


ReportParams.Config Method

public void Config(
AptifyApplication ApplicationObject
);

Implements

IRibbonButtonPropPage.

See Also

ReportParams Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

ReportParams.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

ReportParams Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


ReportParams.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

ReportParams Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace | ReportParams.Dispose Overload List


ReportParams.LoadProperties Method

public void LoadProperties(
AptifyGenericEntityBase Part
);

Implements

IRibbonButtonPropPage.

See Also

ReportParams Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


ReportParams.SaveProperties Method

public void SaveProperties();

Implements

IRibbonButtonPropPage.

See Also

ReportParams Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


RibbonButtonButton Class

For a list of all members of this type, see RibbonButtonButton Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
RibbonButtonButton

public class RibbonButtonButton : Form, IAptifySubTypeViewer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.ApplicationRibbonGroup.Components

Assembly: AptifyApplicationRibbonGroup (in AptifyApplicationRibbonGroup.dll)

See Also

RibbonButtonButton Members | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


RibbonButtonButton Members

RibbonButtonButton overview

Public Instance Constructors

RibbonButtonButton Constructor Initializes a new instance of the RibbonButtonButton class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config | Overloaded.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog | Overloaded.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog with the specified owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

RibbonButtonButton Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


RibbonButtonButton Constructor

Initializes a new instance of the RibbonButtonButton class.

public RibbonButtonButton();

See Also

RibbonButtonButton Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


RibbonButtonButton Methods

The methods of the RibbonButtonButton class are listed below. For a complete list of RibbonButtonButton class members, see the RibbonButtonButton Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config | Overloaded.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog | Overloaded.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog with the specified owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

RibbonButtonButton Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


RibbonButtonButton.ApplySkin Method

protected virtual void ApplySkin();

See Also

RibbonButtonButton Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


Config Method

Aptify 5.0 Software Development Kit (SDK)

RibbonButtonButton.Config Method

Overload List

public void Config(AptifyGenericEntityBase);

public void Config(AptifyGenericEntityBase,String);

public void Config(AptifyGenericEntityBase,String,String);

See Also

RibbonButtonButton Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


RibbonButtonButton.Config Method (AptifyGenericEntityBase)

public void Config(
AptifyGenericEntityBase subTypeGE
);

Implements

IAptifySubTypeViewer.

See Also

RibbonButtonButton Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace | RibbonButtonButton.Config Overload List


RibbonButtonButton.Config Method (AptifyGenericEntityBase, String)

public void Config(
AptifyGenericEntityBase subTypeGE,
String CmdString
);

Implements

IAptifySubTypeViewer.

See Also

RibbonButtonButton Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace | RibbonButtonButton.Config Overload List


RibbonButtonButton.Config Method (AptifyGenericEntityBase, String, String)

public void Config(
AptifyGenericEntityBase subTypeGE,
String CmdString,
String Caption
);

Implements

IAptifySubTypeViewer.

See Also

RibbonButtonButton Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace | RibbonButtonButton.Config Overload List


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

RibbonButtonButton.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

RibbonButtonButton Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


RibbonButtonButton.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

RibbonButtonButton Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace | RibbonButtonButton.Dispose Overload List


ShowDialog Method

Aptify 5.0 Software Development Kit (SDK)

RibbonButtonButton.ShowDialog Method

Overload List

new public DialogResult ShowDialog();

public DialogResult ShowDialog(Form);

Inherited from Form.

public DialogResult ShowDialog(IWin32Window);

See Also

RibbonButtonButton Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


RibbonButtonButton.ShowDialog Method ()

new public DialogResult ShowDialog();

Implements

IAptifySubTypeViewer.

See Also

RibbonButtonButton Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace | RibbonButtonButton.ShowDialog Overload List


RibbonButtonButton.ShowDialog Method (Form)

public DialogResult ShowDialog(
Form parentForm
);

Implements

IAptifySubTypeViewer.

See Also

RibbonButtonButton Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace | RibbonButtonButton.ShowDialog Overload List


RibbonButtons Class

For a list of all members of this type, see RibbonButtons Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
RibbonButtons

public class RibbonButtons : UserControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.ApplicationRibbonGroup.Components

Assembly: AptifyApplicationRibbonGroup (in AptifyApplicationRibbonGroup.dll)

See Also

RibbonButtons Members | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


RibbonButtons Members

RibbonButtons overview

Public Instance Constructors

RibbonButtons Constructor Initializes a new instance of the RibbonButtons class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
ButtonGE |
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DataField | Optional property - set this to the DataField object in the GE that this control is bound to so that it will receive events automatically.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
TransferDataToObject |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
ApplySkin |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

RibbonButtons Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


RibbonButtons Constructor

Initializes a new instance of the RibbonButtons class.

public RibbonButtons();

See Also

RibbonButtons Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


RibbonButtons Properties

The properties of the RibbonButtons class are listed below. For a complete list of RibbonButtons class members, see the RibbonButtons Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
ButtonGE |
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DataField | Optional property - set this to the DataField object in the GE that this control is bound to so that it will receive events automatically.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

RibbonButtons Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


ButtonGE Property

Aptify 5.0 Software Development Kit (SDK)

RibbonButtons.ButtonGE Property

public AptifyGenericEntityBase ButtonGE {get;}

See Also

RibbonButtons Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


DataField Property

Aptify 5.0 Software Development Kit (SDK)

RibbonButtons.DataField Property

Optional property - set this to the DataField object in the GE that this control is bound to so that it will receive events automatically.

public AptifyDataFieldBase DataField {get; set;}

Property Value

Remarks

See Also

RibbonButtons Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


RibbonButtons Methods

The methods of the RibbonButtons class are listed below. For a complete list of RibbonButtons class members, see the RibbonButtons Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
TransferDataToObject |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
ApplySkin |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

RibbonButtons Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


RibbonButtons.ApplySkin Method

protected virtual void ApplySkin();

See Also

RibbonButtons Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

RibbonButtons.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

RibbonButtons Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


RibbonButtons.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

RibbonButtons Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace | RibbonButtons.Dispose Overload List


RibbonButtons.TransferDataToObject Method

public virtual void TransferDataToObject(
ref Boolean& Cancel
);

See Also

RibbonButtons Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


RibbonGroupButtonForm Class

For a list of all members of this type, see RibbonGroupButtonForm Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
RibbonGroupButtonForm

public class RibbonGroupButtonForm : Form, IAptifySubTypeViewer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.ApplicationRibbonGroup.Components

Assembly: AptifyApplicationRibbonGroup (in AptifyApplicationRibbonGroup.dll)

See Also

RibbonGroupButtonForm Members | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


RibbonGroupButtonForm Members

RibbonGroupButtonForm overview

Public Instance Constructors

RibbonGroupButtonForm Constructor Initializes a new instance of the RibbonGroupButtonForm class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config | Overloaded.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog | Overloaded.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog with the specified owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

RibbonGroupButtonForm Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


RibbonGroupButtonForm Constructor

Initializes a new instance of the RibbonGroupButtonForm class.

public RibbonGroupButtonForm();

See Also

RibbonGroupButtonForm Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


RibbonGroupButtonForm Methods

The methods of the RibbonGroupButtonForm class are listed below. For a complete list of RibbonGroupButtonForm class members, see the RibbonGroupButtonForm Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config | Overloaded.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog | Overloaded.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog with the specified owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

RibbonGroupButtonForm Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


RibbonGroupButtonForm.ApplySkin Method

protected virtual void ApplySkin();

See Also

RibbonGroupButtonForm Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


Config Method

Aptify 5.0 Software Development Kit (SDK)

RibbonGroupButtonForm.Config Method

Overload List

public void Config(AptifyGenericEntityBase);

public void Config(AptifyGenericEntityBase,String);

public void Config(AptifyGenericEntityBase,String,String);

See Also

RibbonGroupButtonForm Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


RibbonGroupButtonForm.Config Method (AptifyGenericEntityBase)

public void Config(
AptifyGenericEntityBase subTypeGE
);

Implements

IAptifySubTypeViewer.

See Also

RibbonGroupButtonForm Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace | RibbonGroupButtonForm.Config Overload List


RibbonGroupButtonForm.Config Method (AptifyGenericEntityBase, String)

public void Config(
AptifyGenericEntityBase subTypeGE,
String CmdString
);

Implements

IAptifySubTypeViewer.

See Also

RibbonGroupButtonForm Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace | RibbonGroupButtonForm.Config Overload List


RibbonGroupButtonForm.Config Method (AptifyGenericEntityBase, String, String)

public void Config(
AptifyGenericEntityBase subTypeGE,
String CmdString,
String Caption
);

Implements

IAptifySubTypeViewer.

See Also

RibbonGroupButtonForm Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace | RibbonGroupButtonForm.Config Overload List


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

RibbonGroupButtonForm.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

RibbonGroupButtonForm Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


RibbonGroupButtonForm.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

RibbonGroupButtonForm Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace | RibbonGroupButtonForm.Dispose Overload List


ShowDialog Method

Aptify 5.0 Software Development Kit (SDK)

RibbonGroupButtonForm.ShowDialog Method

Overload List

new public DialogResult ShowDialog();

public DialogResult ShowDialog(Form);

Inherited from Form.

public DialogResult ShowDialog(IWin32Window);

See Also

RibbonGroupButtonForm Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


RibbonGroupButtonForm.ShowDialog Method ()

new public DialogResult ShowDialog();

Implements

IAptifySubTypeViewer.

See Also

RibbonGroupButtonForm Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace | RibbonGroupButtonForm.ShowDialog Overload List


RibbonGroupButtonForm.ShowDialog Method (Form)

public DialogResult ShowDialog(
Form parentForm
);

Implements

IAptifySubTypeViewer.

See Also

RibbonGroupButtonForm Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace | RibbonGroupButtonForm.ShowDialog Overload List


RibbonGroupConstants Class

For a list of all members of this type, see RibbonGroupConstants Members.

System.Object
RibbonGroupConstants

public class RibbonGroupConstants

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.ApplicationRibbonGroup.Components

Assembly: AptifyApplicationRibbonGroup (in AptifyApplicationRibbonGroup.dll)

See Also

RibbonGroupConstants Members | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


RibbonGroupConstants Members

RibbonGroupConstants overview

Public Static Fields

GUI_EXCEPTION_MESSAGE
INVALID_ACTION_MESSAGE
INVALID_BULK_OPERATION_MESSAGE
INVALID_ENTITY_ID_MESSAGE
INVALID_PARAMETER_VALUE
INVALID_PROPERTIES_MESSAGE
REMOVE_BUTTON_QUESTION

Public Static Methods

GetString Overloaded.

Public Instance Constructors

RibbonGroupConstants Constructor Initializes a new instance of the RibbonGroupConstants class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RibbonGroupConstants Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


RibbonGroupConstants Constructor

Initializes a new instance of the RibbonGroupConstants class.

public RibbonGroupConstants();

See Also

RibbonGroupConstants Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


RibbonGroupConstants Fields

The fields of the RibbonGroupConstants class are listed below. For a complete list of RibbonGroupConstants class members, see the RibbonGroupConstants Members topic.

Public Static Fields

GUI_EXCEPTION_MESSAGE
INVALID_ACTION_MESSAGE
INVALID_BULK_OPERATION_MESSAGE
INVALID_ENTITY_ID_MESSAGE
INVALID_PARAMETER_VALUE
INVALID_PROPERTIES_MESSAGE
REMOVE_BUTTON_QUESTION

See Also

RibbonGroupConstants Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


RibbonGroupConstants.GUI_EXCEPTION_MESSAGE Field

public const GUI_EXCEPTION_MESSAGE GUI_EXCEPTION_MESSAGE = "GUI_EXCEPTION_MESSAGE";

See Also

RibbonGroupConstants Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


RibbonGroupConstants.INVALID_ACTION_MESSAGE Field

public const INVALID_ACTION_MESSAGE INVALID_ACTION_MESSAGE = "INVALID_ACTION_MESSAGE";

See Also

RibbonGroupConstants Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


RibbonGroupConstants.INVALID_BULK_OPERATION_MESSAGE Field

public const INVALID_BULK_OPERATION_MESSAGE INVALID_BULK_OPERATION_MESSAGE = "INVALID_BULK_OPERATION_MESSAGE";

See Also

RibbonGroupConstants Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


RibbonGroupConstants.INVALID_ENTITY_ID_MESSAGE Field

public const INVALID_ENTITY_ID_MESSAGE INVALID_ENTITY_ID_MESSAGE = "INVALID_ENTITY_ID_MESSAGE";

See Also

RibbonGroupConstants Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


RibbonGroupConstants.INVALID_PARAMETER_VALUE Field

public const INVALID_PARAMETER_VALUE INVALID_PARAMETER_VALUE = "INVALID_PARAMETER_VALUE";

See Also

RibbonGroupConstants Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


RibbonGroupConstants.INVALID_PROPERTIES_MESSAGE Field

public const INVALID_PROPERTIES_MESSAGE INVALID_PROPERTIES_MESSAGE = "INVALID_PROPERTIES_MESSAGE";

See Also

RibbonGroupConstants Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


RibbonGroupConstants.REMOVE_BUTTON_QUESTION Field

public const REMOVE_BUTTON_QUESTION REMOVE_BUTTON_QUESTION = "REMOVE_BUTTON_QUESTION";

See Also

RibbonGroupConstants Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


RibbonGroupConstants Methods

The methods of the RibbonGroupConstants class are listed below. For a complete list of RibbonGroupConstants class members, see the RibbonGroupConstants Members topic.

Public Static Methods

GetString Overloaded.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RibbonGroupConstants Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


GetString Method

Aptify 5.0 Software Development Kit (SDK)

RibbonGroupConstants.GetString Method

Overload List

public static string GetString(String);

public static string GetString(String,params String[]);

See Also

RibbonGroupConstants Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


RibbonGroupConstants.GetString Method (String)

public static string GetString(
String Text
);

See Also

RibbonGroupConstants Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace | RibbonGroupConstants.GetString Overload List


RibbonGroupConstants.GetString Method (String, String[])

public static string GetString(
String Text,
params String[] FormatParameters
);

See Also

RibbonGroupConstants Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace | RibbonGroupConstants.GetString Overload List


RibbonGroupForm Class

For a list of all members of this type, see RibbonGroupForm Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
RibbonGroupForm

public class RibbonGroupForm : Form, IAptifySubTypeViewer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.ApplicationRibbonGroup.Components

Assembly: AptifyApplicationRibbonGroup (in AptifyApplicationRibbonGroup.dll)

See Also

RibbonGroupForm Members | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


RibbonGroupForm Members

RibbonGroupForm overview

Public Instance Constructors

RibbonGroupForm Constructor Initializes a new instance of the RibbonGroupForm class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config | Overloaded.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog | Overloaded.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog with the specified owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

RibbonGroupForm Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


RibbonGroupForm Constructor

Initializes a new instance of the RibbonGroupForm class.

public RibbonGroupForm();

See Also

RibbonGroupForm Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


RibbonGroupForm Methods

The methods of the RibbonGroupForm class are listed below. For a complete list of RibbonGroupForm class members, see the RibbonGroupForm Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config | Overloaded.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog | Overloaded.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog with the specified owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

RibbonGroupForm Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


RibbonGroupForm.ApplySkin Method

protected virtual void ApplySkin();

See Also

RibbonGroupForm Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


Config Method

Aptify 5.0 Software Development Kit (SDK)

RibbonGroupForm.Config Method

Overload List

public void Config(AptifyGenericEntityBase);

public void Config(AptifyGenericEntityBase,String);

public void Config(AptifyGenericEntityBase,String,String);

See Also

RibbonGroupForm Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


RibbonGroupForm.Config Method (AptifyGenericEntityBase)

public void Config(
AptifyGenericEntityBase subTypeGE
);

Implements

IAptifySubTypeViewer.

See Also

RibbonGroupForm Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace | RibbonGroupForm.Config Overload List


RibbonGroupForm.Config Method (AptifyGenericEntityBase, String)

public void Config(
AptifyGenericEntityBase subTypeGE,
String CmdString
);

Implements

IAptifySubTypeViewer.

See Also

RibbonGroupForm Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace | RibbonGroupForm.Config Overload List


RibbonGroupForm.Config Method (AptifyGenericEntityBase, String, String)

public void Config(
AptifyGenericEntityBase subTypeGE,
String CmdString,
String Caption
);

Implements

IAptifySubTypeViewer.

See Also

RibbonGroupForm Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace | RibbonGroupForm.Config Overload List


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

RibbonGroupForm.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

RibbonGroupForm Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


RibbonGroupForm.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

RibbonGroupForm Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace | RibbonGroupForm.Dispose Overload List


ShowDialog Method

Aptify 5.0 Software Development Kit (SDK)

RibbonGroupForm.ShowDialog Method

Overload List

new public DialogResult ShowDialog();

public DialogResult ShowDialog(Form);

Inherited from Form.

public DialogResult ShowDialog(IWin32Window);

See Also

RibbonGroupForm Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


RibbonGroupForm.ShowDialog Method ()

new public DialogResult ShowDialog();

Implements

IAptifySubTypeViewer.

See Also

RibbonGroupForm Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace | RibbonGroupForm.ShowDialog Overload List


RibbonGroupForm.ShowDialog Method (Form)

public DialogResult ShowDialog(
Form parentForm
);

Implements

IAptifySubTypeViewer.

See Also

RibbonGroupForm Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace | RibbonGroupForm.ShowDialog Overload List


SwitchDashboardParams Class

For a list of all members of this type, see SwitchDashboardParams Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
SwitchDashboardParams

public class SwitchDashboardParams : UserControl, IRibbonButtonPropPage

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.ApplicationRibbonGroup.Components

Assembly: AptifyApplicationRibbonGroup (in AptifyApplicationRibbonGroup.dll)

See Also

SwitchDashboardParams Members | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


SwitchDashboardParams Members

SwitchDashboardParams overview

Public Instance Constructors

SwitchDashboardParams Constructor Initializes a new instance of the SwitchDashboardParams class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LoadProperties |
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
SaveProperties |
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

SwitchDashboardParams Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


SwitchDashboardParams Constructor

Initializes a new instance of the SwitchDashboardParams class.

public SwitchDashboardParams();

See Also

SwitchDashboardParams Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


SwitchDashboardParams Methods

The methods of the SwitchDashboardParams class are listed below. For a complete list of SwitchDashboardParams class members, see the SwitchDashboardParams Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LoadProperties |
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
SaveProperties |
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

SwitchDashboardParams Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


SwitchDashboardParams.Config Method

public void Config(
AptifyApplication ApplicationObject
);

Implements

IRibbonButtonPropPage.

See Also

SwitchDashboardParams Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

SwitchDashboardParams.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

SwitchDashboardParams Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


SwitchDashboardParams.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

SwitchDashboardParams Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace | SwitchDashboardParams.Dispose Overload List


SwitchDashboardParams.LoadProperties Method

public void LoadProperties(
AptifyGenericEntityBase Part
);

Implements

IRibbonButtonPropPage.

See Also

SwitchDashboardParams Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


SwitchDashboardParams.SaveProperties Method

public void SaveProperties();

Implements

IRibbonButtonPropPage.

See Also

SwitchDashboardParams Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


WizardParams Class

For a list of all members of this type, see WizardParams Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
WizardParams

public class WizardParams : UserControl, IRibbonButtonPropPage

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.ApplicationRibbonGroup.Components

Assembly: AptifyApplicationRibbonGroup (in AptifyApplicationRibbonGroup.dll)

See Also

WizardParams Members | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


WizardParams Members

WizardParams overview

Public Instance Constructors

WizardParams Constructor Initializes a new instance of the WizardParams class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LoadProperties |
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
SaveProperties |
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

WizardParams Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


WizardParams Constructor

Initializes a new instance of the WizardParams class.

public WizardParams();

See Also

WizardParams Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


WizardParams Methods

The methods of the WizardParams class are listed below. For a complete list of WizardParams class members, see the WizardParams Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LoadProperties |
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
SaveProperties |
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

WizardParams Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


WizardParams.Config Method

public void Config(
AptifyApplication ApplicationObject
);

Implements

IRibbonButtonPropPage.

See Also

WizardParams Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

WizardParams.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

WizardParams Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


WizardParams.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

WizardParams Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace | WizardParams.Dispose Overload List


WizardParams.LoadProperties Method

public void LoadProperties(
AptifyGenericEntityBase Part
);

Implements

IRibbonButtonPropPage.

See Also

WizardParams Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


WizardParams.SaveProperties Method

public void SaveProperties();

Implements

IRibbonButtonPropPage.

See Also

WizardParams Class | Aptify.Framework.ApplicationRibbonGroup.Components Namespace


Aptify.Framework.Archive

Aptify 5.0 Software Development Kit (SDK)

Aptify.Framework.Archive Namespace

This namespace contains objects and interfaces related to Aptify's Archive Tool. The namespace provides an entry point for development of Archive Type plugins and for automation of the Archive Tool features. Usage: As an organization uses the Aptify system, the amount of certain transactional data grows over time, such as Record History information and Lists records. An organization can use the Archive Tool to identify older transactional information (that is, Record History and Lists data) and move it to another server for safekeeping while freeing up disk space on the production database server.

Namespace hierarchy

Classes

Class | Description
ArchiveEntity | Entity object for the Archive Runs entity. Provides all archival functionality within the Archive Run record.
ArchiveRecordBase | ArchiveRecordBase is a base class used to build archive type objects for use in archiving new record types. ArchiveRecordBase implements the IArchiveRecords object.
ArchiveRecordBase.ArchiveTable | The ArchiveTable class is a data class used to store information about each table which is part of the archive type.
ArchiveRunViewer | The ArchiveRunViewer class is the data form used to display Archive Runs records.
ArchiveStatus |
ArchiveType | The Archive Type object is used to manage the plugin features of the Aptify Archive tool. The object is initialized by responding to the ArchiveType of the Archive Run record.
Lists | The lists class inherits from ArchiveRecordBase. It is designed to handle the archival of Lists records. It is an approved plugin which is driven by the archival process.
ListsControl | The Lists Control is used to provide functionality to assist the user with forming the selection criterion for use in the archive run.
RecordHistory | The lists class inherits from ArchiveRecordBase. It is designed to handle the archival of Record History (EntityRecordVersions) records. It is an approved plugin which is driven by the archival process.
RecordHistoryControl | The Record History Control is used to provide functionality to assist the user with forming the selection criterion for use in the archive run.

Interfaces

Interface | Description
IAptifyArchiveGUI | Interface that will be implemented by UserControls that will plug in to the Archive Runs Data Form. UserControls can provide specific UI elements tailored to an Archive Type. The main responsibility of the control is to determine that the selected options are valid, and if so, to provide a SQL statement that will be used for the selection criteria of the Archive Run.
IAptifyArchiveRecords | This interface is used by the Archive feature in Aptify. All archive and delete operations must have a class that implements this interface. The implementation is responsible for providing configuration data to the Archive Run record, validating the supplied criteria and to executing the desired operation. (Archive, Copy, Delete)
IAptifyArchiveRun | This interface provides all extended functionality for the Archive Run Object. To be implemented by the GE Wrapper for the Achive Runs entity. Provides specific access to configuration data specific to an archive run.
IAptifyArchiveType | This interface is implemented for each list type. Two public members exist pointing to plugins of the list type.

Delegates

Delegate | Description
IAptifyArchiveRecords.BatchCompleteEventHandler |
IAptifyArchiveRecords.BatchStartedEventHandler |
IAptifyArchiveRecords.CriticalErrorEventHandler |
IAptifyArchiveRecords.IncidentalErrorEventHandler |
IAptifyArchiveRecords.RunCompletedEventHandler |
IAptifyArchiveRecords.RunStartedEventHandler |
IAptifyArchiveRecords.UpdateStatusEventHandler |

Enumerations

Enumeration | Description
ArchiveRecordBase.enObjectEvents |
IAptifyArchiveRecords.arOperations | Enumerated values representing the possible supported operations in the implementation of the Archive Records interface.


ArchiveEntity Class

Entity object for the Archive Runs entity. Provides all archival functionality within the Archive Run record.

For a list of all members of this type, see ArchiveEntity Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
ArchiveEntity

public class ArchiveEntity : AptifyGenericEntity, IAptifyArchiveRun

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Inherits from AptifyGenericEntity.

Requirements

Namespace: Aptify.Framework.Archive

Assembly: AptifyArchive (in AptifyArchive.dll)

See Also

ArchiveEntity Members | Aptify.Framework.Archive Namespace


ArchiveEntity Members

ArchiveEntity overview

Public Instance Constructors

ArchiveEntity Constructor Initializes a new instance of the ArchiveEntity class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
ArchiveTypeObject | Property referencing the Archive Type utility object used for the Archival process.
BatchSize | Property indicating the size of a batch.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CreateTables | Property representing if table creation should be attempted.
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
Database | Property indicating the Archive Database.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DeleteRecords | Property indicating whether the object is configured for deletion.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
Password | Property indicating the password to be utilized in the transaction, if untrusted.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SelectionSQL | Property indicating the SQL Query used for the selecting the source records for the Archive Run.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
ServerName | Property indicating the name of the Archive Server.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SingleTransaction | Property representing the directive to complete the Archive Run in a single transaction.
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
TransferRecords | Property indicating whether the object is configured for data transfers.
TrustedConnection | Property indicating if Trusted Security should be utilized or not.
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.
UserName | Property indicating the username for the destination server if Trusted Security is not enabled.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone | Overloaded.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config | Overloaded. Method used to configure the Generic Entity object.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ExecuteTest | Method used to complete a test run of the Archive Operation.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded. Archival functionality is built primarily into the save process.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue | SetValue is called for each field and overloaded field in the Generic Entity. It is overloaded here to check for specific fields in a new record as they are also used in the implementation of the IAptifyArchiveRun interface.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded. Method used to provide validation of the record. Overloaded in the Archive Runs entity to provide validation related to the destination connection parameters and other features.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

ArchiveEntity Class | Aptify.Framework.Archive Namespace


ArchiveEntity Constructor

Initializes a new instance of the ArchiveEntity class.

public ArchiveEntity();

See Also

ArchiveEntity Class | Aptify.Framework.Archive Namespace


ArchiveEntity Properties

The properties of the ArchiveEntity class are listed below. For a complete list of ArchiveEntity class members, see the ArchiveEntity Members topic.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
ArchiveTypeObject | Property referencing the Archive Type utility object used for the Archival process.
BatchSize | Property indicating the size of a batch.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CreateTables | Property representing if table creation should be attempted.
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
Database | Property indicating the Archive Database.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DeleteRecords | Property indicating whether the object is configured for deletion.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
Password | Property indicating the password to be utilized in the transaction, if untrusted.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SelectionSQL | Property indicating the SQL Query used for the selecting the source records for the Archive Run.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
ServerName | Property indicating the name of the Archive Server.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SingleTransaction | Property representing the directive to complete the Archive Run in a single transaction.
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
TransferRecords | Property indicating whether the object is configured for data transfers.
TrustedConnection | Property indicating if Trusted Security should be utilized or not.
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.
UserName | Property indicating the username for the destination server if Trusted Security is not enabled.

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

ArchiveEntity Class | Aptify.Framework.Archive Namespace


ArchiveTypeObject Property

Aptify 5.0 Software Development Kit (SDK)

ArchiveEntity.ArchiveTypeObject Property

Property referencing the Archive Type utility object used for the Archival process.

public IAptifyArchiveType ArchiveTypeObject {get;}

Property Value

Returns object of type IAptifyArchiveType.

Implements

IAptifyArchiveRun.

Remarks

Refer to the IAptifyArchiveRun interface for more information.

See Also

ArchiveEntity Class | Aptify.Framework.Archive Namespace


BatchSize Property

Aptify 5.0 Software Development Kit (SDK)

ArchiveEntity.BatchSize Property

Property indicating the size of a batch.

public Int64 BatchSize {get; set;}

Property Value

Returns a long containing the number of rows to include in the batch.

Implements

IAptifyArchiveRun.

Remarks

Refer to the IAptifyArchiveRun interface for more information.

See Also

ArchiveEntity Class | Aptify.Framework.Archive Namespace


CreateTables Property

Aptify 5.0 Software Development Kit (SDK)

ArchiveEntity.CreateTables Property

Property representing if table creation should be attempted.

public Boolean CreateTables {get; set;}

Property Value

Returns a boolean. TRUE indicates yes and FALSE, no.

Implements

IAptifyArchiveRun.

Remarks

Refer to the IAptifyArchiveRun interface for more information.

See Also

ArchiveEntity Class | Aptify.Framework.Archive Namespace


Database Property

Aptify 5.0 Software Development Kit (SDK)

ArchiveEntity.Database Property

Property indicating the Archive Database.

public String Database {get; set;}

Property Value

Returns a string representing the target database.

Implements

IAptifyArchiveRun.

Remarks

Refer to the IAptifyArchiveRun interface for more information.

See Also

ArchiveEntity Class | Aptify.Framework.Archive Namespace


DeleteRecords Property

Aptify 5.0 Software Development Kit (SDK)

ArchiveEntity.DeleteRecords Property

Property indicating whether the object is configured for deletion.

public Boolean DeleteRecords {get;}

Property Value

Returns TRUE if object is ready for deletion.

Implements

IAptifyArchiveRun.

Remarks

Refer to the IAptifyArchiveRun interface for more information.

See Also

ArchiveEntity Class | Aptify.Framework.Archive Namespace


Password Property

Aptify 5.0 Software Development Kit (SDK)

ArchiveEntity.Password Property

Property indicating the password to be utilized in the transaction, if untrusted.

public String Password {get; set;}

Property Value

Returns a string containing the password in play.

Implements

IAptifyArchiveRun.

Remarks

Refer to the IAptifyArchiveRun interface for more information.

See Also

ArchiveEntity Class | Aptify.Framework.Archive Namespace


SelectionSQL Property

Aptify 5.0 Software Development Kit (SDK)

ArchiveEntity.SelectionSQL Property

Property indicating the SQL Query used for the selecting the source records for the Archive Run.

public String SelectionSQL {get; set;}

Property Value

Returns a string.

Implements

IAptifyArchiveRun.

Remarks

Refer to the IAptifyArchiveRun interface for more information.

See Also

ArchiveEntity Class | Aptify.Framework.Archive Namespace


ServerName Property

Aptify 5.0 Software Development Kit (SDK)

ArchiveEntity.ServerName Property

Property indicating the name of the Archive Server.

public String ServerName {get; set;}

Property Value

Returns a string representing the archive server.

Implements

IAptifyArchiveRun.

Remarks

Refer to the IAptifyArchiveRun interface for more information.

See Also

ArchiveEntity Class | Aptify.Framework.Archive Namespace


SingleTransaction Property

Aptify 5.0 Software Development Kit (SDK)

ArchiveEntity.SingleTransaction Property

Property representing the directive to complete the Archive Run in a single transaction.

public Boolean SingleTransaction {get; set;}

Property Value

Returns TRUE if single transaction treatment is desired.

Implements

IAptifyArchiveRun.

Remarks

Refer to the IAptifyArchiveRun interface for more information.

See Also

ArchiveEntity Class | Aptify.Framework.Archive Namespace


TransferRecords Property

Aptify 5.0 Software Development Kit (SDK)

ArchiveEntity.TransferRecords Property

Property indicating whether the object is configured for data transfers.

public Boolean TransferRecords {get;}

Property Value

Returns TRUE if object is ready for transfers.

Implements

IAptifyArchiveRun.

Remarks

Refer to the IAptifyArchiveRun interface for more information.

See Also

ArchiveEntity Class | Aptify.Framework.Archive Namespace


TrustedConnection Property

Aptify 5.0 Software Development Kit (SDK)

ArchiveEntity.TrustedConnection Property

Property indicating if Trusted Security should be utilized or not.

public Boolean TrustedConnection {get; set;}

Property Value

Returns TRUE if trusted security is desired.

Implements

IAptifyArchiveRun.

Remarks

Refer to the IAptifyArchiveRun interface for more information.

See Also

ArchiveEntity Class | Aptify.Framework.Archive Namespace


UserName Property

Aptify 5.0 Software Development Kit (SDK)

ArchiveEntity.UserName Property

Property indicating the username for the destination server if Trusted Security is not enabled.

public String UserName {get; set;}

Property Value

Returns a string containing the username to suer for untrusted security.

Implements

IAptifyArchiveRun.

Remarks

Refer to the IAptifyArchiveRun interface for more information.

See Also

ArchiveEntity Class | Aptify.Framework.Archive Namespace


ArchiveEntity Methods

The methods of the ArchiveEntity class are listed below. For a complete list of ArchiveEntity class members, see the ArchiveEntity Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone | Overloaded.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config | Overloaded. Method used to configure the Generic Entity object.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ExecuteTest | Method used to complete a test run of the Archive Operation.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded. Archival functionality is built primarily into the save process.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue | SetValue is called for each field and overloaded field in the Generic Entity. It is overloaded here to check for specific fields in a new record as they are also used in the implementation of the IAptifyArchiveRun interface.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded. Method used to provide validation of the record. Overloaded in the Archive Runs entity to provide validation related to the destination connection parameters and other features.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

ArchiveEntity Class | Aptify.Framework.Archive Namespace


Clone Method

Aptify 5.0 Software Development Kit (SDK)

ArchiveEntity.Clone Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual void Clone(AptifyGenericEntityBase);

public override void Clone(AptifyGenericEntityBase,Boolean);

See Also

ArchiveEntity Class | Aptify.Framework.Archive Namespace


ArchiveEntity.Clone Method (AptifyGenericEntityBase, Boolean)

public override void Clone(
AptifyGenericEntityBase ObjectToClone,
Boolean Merge
);

See Also

ArchiveEntity Class | Aptify.Framework.Archive Namespace | ArchiveEntity.Clone Overload List


Config Method

Aptify 5.0 Software Development Kit (SDK)

ArchiveEntity.Config Method

Method used to configure the Generic Entity object.

Overload List

Inherited from AptifyGenericEntityBase.

public virtual void Config(AptifySubTypeBase);

Inherited from AptifyGenericEntity.

public override void Config(AptifySubTypeBase,Int64);

Inherited from AptifyGenericEntityBase.

public virtual void Config(UserCredentials,String);

Method used to configure the Generic Entity object.

public override void Config(UserCredentials,String,Int64);

See Also

ArchiveEntity Class | Aptify.Framework.Archive Namespace


ArchiveEntity.Config Method (UserCredentials, String, Int64)

Method used to configure the Generic Entity object.

public override void Config(
UserCredentials UserCredentials,
String EntityName,
Int64 RecordID
);

Parameters

UserCredentials
UserCredentials object representing the connection parameters for this connection.
EntityName
Name of the entity represented by this instance of the Generic Entity.
RecordID
ID of the record represented by this instance of the Generic Entity.

Remarks

RecordID is equal to -1 when the record is new.

See Also

ArchiveEntity Class | Aptify.Framework.Archive Namespace | ArchiveEntity.Config Overload List


ArchiveEntity.ExecuteTest Method

Method used to complete a test run of the Archive Operation.

public bool ExecuteTest(
ref String& sOutput,
Boolean bShowGUI
);

Parameters

sOutput
ByRef parameter used to return output from the test run.
bShowGUI
Boolean indicating that the operation should display its user interface.

Return Value

Returns TRUE If the test run completes successfully.

Implements

IAptifyArchiveRun.

Remarks

See Also

ArchiveEntity Class | Aptify.Framework.Archive Namespace


Save Method

Aptify 5.0 Software Development Kit (SDK)

ArchiveEntity.Save Method

Archival functionality is built primarily into the save process.

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Save();

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean,ref String&);

Archival functionality is built primarily into the save process.

public override bool Save(Boolean,ref String&,String);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(ref String&);

See Also

ArchiveEntity Class | Aptify.Framework.Archive Namespace


ArchiveEntity.Save Method (Boolean, String&, String)

Archival functionality is built primarily into the save process.

public override bool Save(
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

Parameters

AllowGUI
Parameter that specifies whether a GUI should be displayed or not. Refers to the Status window.
ErrorString
Parameter
TransactionID

Return Value

Function returns a Boolean representing if the save succeded.

Remarks

Once the record is saved, the archive process will run. Any feedback from the archival process will be reported back to the user in the Archive Run record.

See Also

ArchiveEntity Class | Aptify.Framework.Archive Namespace | ArchiveEntity.Save Overload List


ArchiveEntity.SetValue Method

SetValue is called for each field and overloaded field in the Generic Entity. It is overloaded here to check for specific fields in a new record as they are also used in the implementation of the IAptifyArchiveRun interface.

public override void SetValue(
String FieldName,
Object Value
);

Parameters

FieldName
Name of the field whose value is being set.
Value
Value of the field being set.

Remarks

See Also

ArchiveEntity Class | Aptify.Framework.Archive Namespace


Validate Method

Aptify 5.0 Software Development Kit (SDK)

ArchiveEntity.Validate Method

Method used to provide validation of the record. Overloaded in the Archive Runs entity to provide validation related to the destination connection parameters and other features.

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Validate();

Method used to provide validation of the record. Overloaded in the Archive Runs entity to provide validation related to the destination connection parameters and other features.

public override bool Validate(ref String&);

See Also

ArchiveEntity Class | Aptify.Framework.Archive Namespace


ArchiveEntity.Validate Method (String&)

Method used to provide validation of the record. Overloaded in the Archive Runs entity to provide validation related to the destination connection parameters and other features.

public override bool Validate(
ref String& ErrorString
);

Parameters

ErrorString
ByRef string used to return the any error messages determined in the validation logic of the method.

Return Value

A value of TRUE should be returned when validation rule succeed and FALSE when they do not.

Remarks

See Also

ArchiveEntity Class | Aptify.Framework.Archive Namespace | ArchiveEntity.Validate Overload List


ArchiveRecordBase Class

ArchiveRecordBase is a base class used to build archive type objects for use in archiving new record types. ArchiveRecordBase implements the IArchiveRecords object.

For a list of all members of this type, see ArchiveRecordBase Members.

System.Object
ArchiveRecordBase
Lists
RecordHistory

public class ArchiveRecordBase : IAptifyArchiveRecords

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.Archive

Assembly: AptifyArchive (in AptifyArchive.dll)

See Also

ArchiveRecordBase Members | Aptify.Framework.Archive Namespace


ArchiveRecordBase Members

ArchiveRecordBase overview

Protected Static Fields

m_lBATCH_SIZE_DEF

Public Instance Constructors

ArchiveRecordBase Constructor Initializes a new instance of the ArchiveRecordBase class.

Public Instance Properties

LastMessage | String parameter used to retrieve error messages from the object.
SupportedOperations |

Public Instance Methods

Config | Function used to configure the object.
CreateTables | Function used to create the tables. This function must be overridden.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute | Execute method in the base class is used to configure data members in the object. (Derived classes are used to flesh out the implementation details for a given archive type.)
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ResetCounts |
ToString (inherited from Object) | Returns a String that represents the current Object.
Validate | Validation provided in the Archive Record Base class validates the presence of appropriate connection parameters.

Protected Instance Fields

m_arSupportedOperations
m_bShowErrors
m_bTestRun
m_connDestination
m_DSAction
m_iArchiveTypeID
m_iDestinationStatementCount
m_iSourceStatementCount
m_oApplication
m_oArchiveRun
m_oArchiveRunGE
m_oArchiveTables
m_oUserCredentials
m_sConnString
m_sDestinationBatchStatement
m_sLastMessage
m_sSourceBatchStatement

Protected Instance Methods

AddDestinationBatchStatement | Function used to add a SQL statement to the batch to be sent to the destination server.
AddSourceBatchStatement | Function used to add a SQL statement to the batch to be sent to the source server.
AddStatus | Internal function used to report status via the object event model.
AddTable | This function is used to create ArchiveTable objects and add them to the array list.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetConnectionString | Function that creates a connection string, based on the parameters. Will create a connection string for trusted and untrusted connections.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OpenConnection | Function that opens a connection to the database. Is used primarily to create a connection to the target database.

Protected Instance Events

BatchComplete
BatchStarted
CriticalError
IncidentalError
RunCompleted
RunStarted
UpdateStatus

See Also

ArchiveRecordBase Class | Aptify.Framework.Archive Namespace


ArchiveRecordBase Constructor

Initializes a new instance of the ArchiveRecordBase class.

public ArchiveRecordBase();

See Also

ArchiveRecordBase Class | Aptify.Framework.Archive Namespace


ArchiveRecordBase Fields

The fields of the ArchiveRecordBase class are listed below. For a complete list of ArchiveRecordBase class members, see the ArchiveRecordBase Members topic.

Protected Static Fields

m_lBATCH_SIZE_DEF

Protected Instance Fields

m_arSupportedOperations
m_bShowErrors
m_bTestRun
m_connDestination
m_DSAction
m_iArchiveTypeID
m_iDestinationStatementCount
m_iSourceStatementCount
m_oApplication
m_oArchiveRun
m_oArchiveRunGE
m_oArchiveTables
m_oUserCredentials
m_sConnString
m_sDestinationBatchStatement
m_sLastMessage
m_sSourceBatchStatement

See Also

ArchiveRecordBase Class | Aptify.Framework.Archive Namespace


ArchiveRecordBase.m_arSupportedOperations Field

protected m_arSupportedOperations m_arSupportedOperations;

See Also

ArchiveRecordBase Class | Aptify.Framework.Archive Namespace


ArchiveRecordBase.m_bShowErrors Field

protected m_bShowErrors m_bShowErrors;

See Also

ArchiveRecordBase Class | Aptify.Framework.Archive Namespace


ArchiveRecordBase.m_bTestRun Field

protected m_bTestRun m_bTestRun;

See Also

ArchiveRecordBase Class | Aptify.Framework.Archive Namespace


ArchiveRecordBase.m_connDestination Field

protected m_connDestination m_connDestination;

See Also

ArchiveRecordBase Class | Aptify.Framework.Archive Namespace


ArchiveRecordBase.m_DSAction Field

protected m_DSAction m_DSAction;

See Also

ArchiveRecordBase Class | Aptify.Framework.Archive Namespace


ArchiveRecordBase.m_iArchiveTypeID Field

protected m_iArchiveTypeID m_iArchiveTypeID;

See Also

ArchiveRecordBase Class | Aptify.Framework.Archive Namespace


ArchiveRecordBase.m_iDestinationStatementCount Field

protected m_iDestinationStatementCount m_iDestinationStatementCount;

See Also

ArchiveRecordBase Class | Aptify.Framework.Archive Namespace


ArchiveRecordBase.m_iSourceStatementCount Field

protected m_iSourceStatementCount m_iSourceStatementCount;

See Also

ArchiveRecordBase Class | Aptify.Framework.Archive Namespace


ArchiveRecordBase.m_lBATCH_SIZE_DEF Field

protected const m_lBATCH_SIZE_DEF m_lBATCH_SIZE_DEF = 50;

See Also

ArchiveRecordBase Class | Aptify.Framework.Archive Namespace


ArchiveRecordBase.m_oApplication Field

protected m_oApplication m_oApplication;

See Also

ArchiveRecordBase Class | Aptify.Framework.Archive Namespace


ArchiveRecordBase.m_oArchiveRun Field

protected m_oArchiveRun m_oArchiveRun;

See Also

ArchiveRecordBase Class | Aptify.Framework.Archive Namespace


ArchiveRecordBase.m_oArchiveRunGE Field

protected m_oArchiveRunGE m_oArchiveRunGE;

See Also

ArchiveRecordBase Class | Aptify.Framework.Archive Namespace


ArchiveRecordBase.m_oArchiveTables Field

protected m_oArchiveTables m_oArchiveTables;

See Also

ArchiveRecordBase Class | Aptify.Framework.Archive Namespace


ArchiveRecordBase.m_oUserCredentials Field

protected m_oUserCredentials m_oUserCredentials;

See Also

ArchiveRecordBase Class | Aptify.Framework.Archive Namespace


ArchiveRecordBase.m_sConnString Field

protected m_sConnString m_sConnString;

See Also

ArchiveRecordBase Class | Aptify.Framework.Archive Namespace


ArchiveRecordBase.m_sDestinationBatchStatement Field

protected m_sDestinationBatchStatement m_sDestinationBatchStatement;

See Also

ArchiveRecordBase Class | Aptify.Framework.Archive Namespace


ArchiveRecordBase.m_sLastMessage Field

protected m_sLastMessage m_sLastMessage;

See Also

ArchiveRecordBase Class | Aptify.Framework.Archive Namespace


ArchiveRecordBase.m_sSourceBatchStatement Field

protected m_sSourceBatchStatement m_sSourceBatchStatement;

See Also

ArchiveRecordBase Class | Aptify.Framework.Archive Namespace


ArchiveRecordBase Properties

The properties of the ArchiveRecordBase class are listed below. For a complete list of ArchiveRecordBase class members, see the ArchiveRecordBase Members topic.

Public Instance Properties

LastMessage | String parameter used to retrieve error messages from the object.
SupportedOperations |

See Also

ArchiveRecordBase Class | Aptify.Framework.Archive Namespace


LastMessage Property

Aptify 5.0 Software Development Kit (SDK)

ArchiveRecordBase.LastMessage Property

String parameter used to retrieve error messages from the object.

public String LastMessage {get;}

Property Value

Returns a string.

Implements

IAptifyArchiveRecords.

Remarks

See Also

ArchiveRecordBase Class | Aptify.Framework.Archive Namespace


SupportedOperations Property

Aptify 5.0 Software Development Kit (SDK)

ArchiveRecordBase.SupportedOperations Property

public abstract IAptifyArchiveRecords.arOperations SupportedOperations {get;}

Implements

IAptifyArchiveRecords.

See Also

ArchiveRecordBase Class | Aptify.Framework.Archive Namespace


ArchiveRecordBase Methods

The methods of the ArchiveRecordBase class are listed below. For a complete list of ArchiveRecordBase class members, see the ArchiveRecordBase Members topic.

Public Instance Methods

Config | Function used to configure the object.
CreateTables | Function used to create the tables. This function must be overridden.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute | Execute method in the base class is used to configure data members in the object. (Derived classes are used to flesh out the implementation details for a given archive type.)
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ResetCounts |
ToString (inherited from Object) | Returns a String that represents the current Object.
Validate | Validation provided in the Archive Record Base class validates the presence of appropriate connection parameters.

Protected Instance Methods

AddDestinationBatchStatement | Function used to add a SQL statement to the batch to be sent to the destination server.
AddSourceBatchStatement | Function used to add a SQL statement to the batch to be sent to the source server.
AddStatus | Internal function used to report status via the object event model.
AddTable | This function is used to create ArchiveTable objects and add them to the array list.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetConnectionString | Function that creates a connection string, based on the parameters. Will create a connection string for trusted and untrusted connections.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OpenConnection | Function that opens a connection to the database. Is used primarily to create a connection to the target database.

See Also

ArchiveRecordBase Class | Aptify.Framework.Archive Namespace


ArchiveRecordBase.AddDestinationBatchStatement Method

Function used to add a SQL statement to the batch to be sent to the destination server.

protected bool AddDestinationBatchStatement(
String sSQL,
Boolean bInit
);

Parameters

sSQL
String representing the individual statement to be added to the batch.
bInit
Boolean indicating if the batch should be initialized before adding the enclosed statement.

Return Value

Returns a boolean indicating if the statement was added correctly or not.

Remarks

See Also

ArchiveRecordBase Class | Aptify.Framework.Archive Namespace


ArchiveRecordBase.AddSourceBatchStatement Method

Function used to add a SQL statement to the batch to be sent to the source server.

protected bool AddSourceBatchStatement(
String sSQL,
Boolean bInit
);

Parameters

sSQL
String representing the individual statement to be added to the batch.
bInit
Boolean indicating if the batch should be initialized before adding the enclosed statement.

Return Value

Returns a boolean indicating if the statement was added correctly or not.

Remarks

See Also

ArchiveRecordBase Class | Aptify.Framework.Archive Namespace


ArchiveRecordBase.AddStatus Method

Internal function used to report status via the object event model.

protected void AddStatus(
String sMessage,
ArchiveRecordBase.enObjectEvents EventType
);

Parameters

sMessage
String used to pass in the status message to report.
EventType
The type of the event to report. Corresponds to the event definitions available in the IAptifyArchive interfaces.

Remarks

See Also

ArchiveRecordBase Class | Aptify.Framework.Archive Namespace


ArchiveRecordBase.AddTable Method

This function is used to create ArchiveTable objects and add them to the array list.

protected int AddTable(
String sSourceDB,
String sSourceTable,
String sDestinationDB,
String sDestinationTable,
Boolean bInit
);

Parameters

sSourceDB
String representing the source database.
sSourceTable
String representing the source table.
sDestinationDB
String representing the destination database.
sDestinationTable
String representing the destination table.
bInit
Boolean indicating if the array should be initialize with this item. If true, the array list is initialized and the table added as the first element. Defaults to false.

Return Value

Function returns boolean indicating if the Archive Table object was correctly created. True if it was, false if not.

Remarks

See Also

ArchiveRecordBase Class | Aptify.Framework.Archive Namespace


ArchiveRecordBase.Config Method

Function used to configure the object.

public virtual bool Config(
ref AptifyGenericEntityBase& oArchiveRunGE
);

Parameters

oArchiveRunGE
A Generic Entity object passed is passed in to the function to give the implementation access to all of the data members of the Archive Run record.

Return Value

Returns a boolean indicating success/failure of configuring the object.

Implements

IAptifyArchiveRecords.

Remarks

See Also

ArchiveRecordBase Class | Aptify.Framework.Archive Namespace


ArchiveRecordBase.CreateTables Method

Function used to create the tables. This function must be overridden.

public abstract bool CreateTables();

Return Value

True, if tables are created and false if they are not.

Remarks

See Also

ArchiveRecordBase Class | Aptify.Framework.Archive Namespace


ArchiveRecordBase.Execute Method

Execute method in the base class is used to configure data members in the object. (Derived classes are used to flesh out the implementation details for a given archive type.)

public virtual bool Execute(
String sSelectionSQL,
Boolean bCreateTables,
Boolean bSingleTransaction,
Int64 lBatchSize,
Boolean bTestRun,
Boolean bShowGUI
);

Parameters

sSelectionSQL
String passed to the function containing the SQL statement representing the source data.
bCreateTables
Boolean indicating that the tables should be created or not.
bSingleTransaction
Boolean indicating that the archive run should be completed in a single transaction or not.
lBatchSize
Long indiciating the size of the batch. Default is provided in the Base Class.
bTestRun
Boolean indicating if this is a test run or not.
bShowGUI
Boolean indicating if the GUI should be available or not. It is very important to not display a GUI if the object is being utilized from the application server.

Return Value

Returns a boolean indicating if the archive run executed successfully.

Implements

IAptifyArchiveRecords.

Remarks

See Also

ArchiveRecordBase Class | Aptify.Framework.Archive Namespace


ArchiveRecordBase.GetConnectionString Method

Function that creates a connection string, based on the parameters. Will create a connection string for trusted and untrusted connections.

protected string GetConnectionString(
Boolean bTrusted,
String sServer,
String sDatabase,
String sUsername,
String sPassword
);

Parameters

bTrusted
Boolean indicating if the connection string should be for a trusted or untrusted connection.
sServer
Name of the server to connect to.
sDatabase
Name of the database to connect to.
sUsername
Username needed by the connection. (Untrusted connections only.)
sPassword
Password needed by the connection. (Untrusted connections only.)

Return Value

Returns a configured connection string.

Remarks

See Also

ArchiveRecordBase Class | Aptify.Framework.Archive Namespace


ArchiveRecordBase.OpenConnection Method

Function that opens a connection to the database. Is used primarily to create a connection to the target database.

protected SqlConnection OpenConnection(
String sConnectionString
);

Parameters

sConnectionString
Connection string used for creating the connection.

Return Value

Returns a configured SQLConnection object.

Remarks

See Also

ArchiveRecordBase Class | Aptify.Framework.Archive Namespace


ArchiveRecordBase.ResetCounts Method

public abstract void ResetCounts();

Implements

IAptifyArchiveRecords.

See Also

ArchiveRecordBase Class | Aptify.Framework.Archive Namespace


ArchiveRecordBase.Validate Method

Validation provided in the Archive Record Base class validates the presence of appropriate connection parameters.

public virtual bool Validate(
ref String& sError
);

Parameters

sError
Output parameter used to return error messages to the caller.

Return Value

Returns true if validation succeeds and false if it fails.

Implements

IAptifyArchiveRecords.

Remarks

See Also

ArchiveRecordBase Class | Aptify.Framework.Archive Namespace


ArchiveRecordBase Events

The events of the ArchiveRecordBase class are listed below. For a complete list of ArchiveRecordBase class members, see the ArchiveRecordBase Members topic.

Protected Instance Events

BatchComplete
BatchStarted
CriticalError
IncidentalError
RunCompleted
RunStarted
UpdateStatus

See Also

ArchiveRecordBase Class | Aptify.Framework.Archive Namespace


ArchiveRecordBase.IAptifyArchiveRecords.BatchCompleteEventHandler Event

protected event IAptifyArchiveRecords.BatchCompleteEventHandler BatchComplete;

Implements

IAptifyArchiveRecords.

See Also

ArchiveRecordBase Class | Aptify.Framework.Archive Namespace


ArchiveRecordBase.IAptifyArchiveRecords.BatchStartedEventHandler Event

protected event IAptifyArchiveRecords.BatchStartedEventHandler BatchStarted;

Implements

IAptifyArchiveRecords.

See Also

ArchiveRecordBase Class | Aptify.Framework.Archive Namespace


ArchiveRecordBase.IAptifyArchiveRecords.CriticalErrorEventHandler Event

protected event IAptifyArchiveRecords.CriticalErrorEventHandler CriticalError;

Implements

IAptifyArchiveRecords.

See Also

ArchiveRecordBase Class | Aptify.Framework.Archive Namespace


ArchiveRecordBase.IAptifyArchiveRecords.IncidentalErrorEventHandler Event

protected event IAptifyArchiveRecords.IncidentalErrorEventHandler IncidentalError;

Implements

IAptifyArchiveRecords.

See Also

ArchiveRecordBase Class | Aptify.Framework.Archive Namespace


ArchiveRecordBase.IAptifyArchiveRecords.RunCompletedEventHandler Event

protected event IAptifyArchiveRecords.RunCompletedEventHandler RunCompleted;

Implements

IAptifyArchiveRecords.

See Also

ArchiveRecordBase Class | Aptify.Framework.Archive Namespace


ArchiveRecordBase.IAptifyArchiveRecords.RunStartedEventHandler Event

protected event IAptifyArchiveRecords.RunStartedEventHandler RunStarted;

Implements

IAptifyArchiveRecords.

See Also

ArchiveRecordBase Class | Aptify.Framework.Archive Namespace


ArchiveRecordBase.IAptifyArchiveRecords.UpdateStatusEventHandler Event

protected event IAptifyArchiveRecords.UpdateStatusEventHandler UpdateStatus;

Implements

IAptifyArchiveRecords.

See Also

ArchiveRecordBase Class | Aptify.Framework.Archive Namespace


ArchiveRecordBase.ArchiveTable Class

The ArchiveTable class is a data class used to store information about each table which is part of the archive type.

For a list of all members of this type, see ArchiveRecordBase.ArchiveTable Members.

System.Object
ArchiveRecordBase.ArchiveTable

protected class ArchiveRecordBase.ArchiveTable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.Archive

Assembly: AptifyArchive (in AptifyArchive.dll)

See Also

ArchiveRecordBase.ArchiveTable Members | Aptify.Framework.Archive Namespace


ArchiveRecordBase.ArchiveTable Members

ArchiveRecordBase.ArchiveTable overview

Public Instance Constructors

ArchiveRecordBase.ArchiveTable Constructor Initializes a new instance of the ArchiveRecordBase.ArchiveTable class.

Public Instance Properties

DestinationDB | Meta-data representing the destination database for the archiving process.
DestinationTable | Meta-data representing the target table for the archiving process.
SourceDB | Meta-data representing the source database for the archiving process.
SourceTable | Meta-data representing the source table for the archiving process.

Public Instance Methods

DestTableExists | Function used to determine if the destination table exists.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ArchiveRecordBase.ArchiveTable Class | Aptify.Framework.Archive Namespace


ArchiveRecordBase.ArchiveTable Constructor

Initializes a new instance of the ArchiveRecordBase.ArchiveTable class.

public ArchiveRecordBase.ArchiveTable();

See Also

ArchiveRecordBase.ArchiveTable Class | Aptify.Framework.Archive Namespace


ArchiveRecordBase.ArchiveTable Properties

The properties of the ArchiveRecordBase.ArchiveTable class are listed below. For a complete list of ArchiveRecordBase.ArchiveTable class members, see the ArchiveRecordBase.ArchiveTable Members topic.

Public Instance Properties

DestinationDB | Meta-data representing the destination database for the archiving process.
DestinationTable | Meta-data representing the target table for the archiving process.
SourceDB | Meta-data representing the source database for the archiving process.
SourceTable | Meta-data representing the source table for the archiving process.

See Also

ArchiveRecordBase.ArchiveTable Class | Aptify.Framework.Archive Namespace


DestinationDB Property

Aptify 5.0 Software Development Kit (SDK)

ArchiveRecordBase.ArchiveTable.DestinationDB Property

Meta-data representing the destination database for the archiving process.

public String DestinationDB {get; set;}

Property Value

Returns a string containing the destination database name.

Remarks

See Also

ArchiveRecordBase.ArchiveTable Class | Aptify.Framework.Archive Namespace


DestinationTable Property

Aptify 5.0 Software Development Kit (SDK)

ArchiveRecordBase.ArchiveTable.DestinationTable Property

Meta-data representing the target table for the archiving process.

public String DestinationTable {get; set;}

Property Value

Returns a string containing the destination table.

Remarks

See Also

ArchiveRecordBase.ArchiveTable Class | Aptify.Framework.Archive Namespace


SourceDB Property

Aptify 5.0 Software Development Kit (SDK)

ArchiveRecordBase.ArchiveTable.SourceDB Property

Meta-data representing the source database for the archiving process.

public String SourceDB {get; set;}

Property Value

Returns a string containing the source database name.

Remarks

See Also

ArchiveRecordBase.ArchiveTable Class | Aptify.Framework.Archive Namespace


SourceTable Property

Aptify 5.0 Software Development Kit (SDK)

ArchiveRecordBase.ArchiveTable.SourceTable Property

Meta-data representing the source table for the archiving process.

public String SourceTable {get; set;}

Property Value

Returns a string containing the source table.

Remarks

See Also

ArchiveRecordBase.ArchiveTable Class | Aptify.Framework.Archive Namespace


ArchiveRecordBase.ArchiveTable Methods

The methods of the ArchiveRecordBase.ArchiveTable class are listed below. For a complete list of ArchiveRecordBase.ArchiveTable class members, see the ArchiveRecordBase.ArchiveTable Members topic.

Public Instance Methods

DestTableExists | Function used to determine if the destination table exists.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ArchiveRecordBase.ArchiveTable Class | Aptify.Framework.Archive Namespace


ArchiveRecordBase.ArchiveTable.DestTableExists Method

Function used to determine if the destination table exists.

public bool DestTableExists(
ref SqlConnection& oConnection
);

Parameters

oConnection
SQLConnection object to use to perform the query. Must be a connection to the destination database.

Return Value

Returns true if the table exists and false if it does not.

Remarks

This function is called internally when determining if the table should be created or not.

See Also

ArchiveRecordBase.ArchiveTable Class | Aptify.Framework.Archive Namespace


ArchiveRecordBase.enObjectEvents Enumeration

protected enum ArchiveRecordBase.enObjectEvents

Members

Member Name | Description
RunBegin |
RunEnd |
BatchBegin |
BatchEnd |
Update |
IncidentalErrorEncountered |
CriticalErrorEncountered |

Requirements

Namespace: Aptify.Framework.Archive

Assembly: AptifyArchive (in AptifyArchive.dll)

See Also

Aptify.Framework.Archive Namespace


ArchiveRunViewer Class

The ArchiveRunViewer class is the data form used to display Archive Runs records.

For a list of all members of this type, see ArchiveRunViewer Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
ArchiveRunViewer

public class ArchiveRunViewer : Form, IAptifyTopLevelViewer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.Archive

Assembly: AptifyArchive (in AptifyArchive.dll)

See Also

ArchiveRunViewer Members | Aptify.Framework.Archive Namespace


ArchiveRunViewer Members

ArchiveRunViewer overview

Public Instance Constructors

ArchiveRunViewer Constructor Initializes a new instance of the ArchiveRunViewer class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config | Overloaded. Method used for initialization of the entity viewer.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show | Overloaded. Method used to display the viewer form.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
ShowDialog | Overloaded. Method used to display the viewer form in dialog mode.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog with the specified owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ArchiveRunViewer Class | Aptify.Framework.Archive Namespace


ArchiveRunViewer Constructor

Initializes a new instance of the ArchiveRunViewer class.

public ArchiveRunViewer();

See Also

ArchiveRunViewer Class | Aptify.Framework.Archive Namespace


ArchiveRunViewer Methods

The methods of the ArchiveRunViewer class are listed below. For a complete list of ArchiveRunViewer class members, see the ArchiveRunViewer Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config | Overloaded. Method used for initialization of the entity viewer.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show | Overloaded. Method used to display the viewer form.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
ShowDialog | Overloaded. Method used to display the viewer form in dialog mode.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog with the specified owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ArchiveRunViewer Class | Aptify.Framework.Archive Namespace


ArchiveRunViewer.ApplySkin Method

protected virtual void ApplySkin();

See Also

ArchiveRunViewer Class | Aptify.Framework.Archive Namespace


Config Method

Aptify 5.0 Software Development Kit (SDK)

ArchiveRunViewer.Config Method

Method used for initialization of the entity viewer.

Overload List

Method used for initialization of the entity viewer.

public void Config(AptifyGenericEntityBase);

Method used for initialization of the entity viewer.

public void Config(UserCredentials,String);

Method used for initialization of the entity viewer.

public void Config(UserCredentials,String,Int64);

Method used for initialization of the entity viewer.

public void Config(UserCredentials,String,String);

See Also

ArchiveRunViewer Class | Aptify.Framework.Archive Namespace


ArchiveRunViewer.Config Method (AptifyGenericEntityBase)

Method used for initialization of the entity viewer.

public void Config(
AptifyGenericEntityBase GE
);

Parameters

GE
Generic Entity representing the record to be displayed inside the form.

Implements

IAptifyTopLevelViewer.

Remarks

See Also

ArchiveRunViewer Class | Aptify.Framework.Archive Namespace | ArchiveRunViewer.Config Overload List


ArchiveRunViewer.Config Method (UserCredentials, String)

Method used for initialization of the entity viewer.

public void Config(
UserCredentials UserCredentials,
String CmdString
);

Parameters

UserCredentials
UserCredentials object representing the current Aptify session.
CmdString
Operation desired to be performed in the viewer form.

Implements

IAptifyTopLevelViewer.

Remarks

See Also

ArchiveRunViewer Class | Aptify.Framework.Archive Namespace | ArchiveRunViewer.Config Overload List


ArchiveRunViewer.Config Method (UserCredentials, String, Int64)

Method used for initialization of the entity viewer.

public void Config(
UserCredentials UserCredentials,
String EntityName,
Int64 RecordID
);

Parameters

UserCredentials
UserCredentials object representing the current Aptify session.
EntityName
Name of the entity to be represented by the form.
RecordID
ID of the record to be represented by the form.

Implements

IAptifyTopLevelViewer.

Remarks

See Also

ArchiveRunViewer Class | Aptify.Framework.Archive Namespace | ArchiveRunViewer.Config Overload List


ArchiveRunViewer.Config Method (UserCredentials, String, String)

Method used for initialization of the entity viewer.

public void Config(
UserCredentials UserCredentials,
String EntityName,
String NewRecordParameters
);

Parameters

UserCredentials
UserCredentials object representing the current Aptify session.
EntityName
Name of the entity to be represented by the form.
NewRecordParameters
Set of key/value pairs used to populate the underlying Generic Entity during initialization of a new record.

Implements

IAptifyTopLevelViewer.

Remarks

See Also

ArchiveRunViewer Class | Aptify.Framework.Archive Namespace | ArchiveRunViewer.Config Overload List


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

ArchiveRunViewer.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

ArchiveRunViewer Class | Aptify.Framework.Archive Namespace


ArchiveRunViewer.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

ArchiveRunViewer Class | Aptify.Framework.Archive Namespace | ArchiveRunViewer.Dispose Overload List


Show Method

Aptify 5.0 Software Development Kit (SDK)

ArchiveRunViewer.Show Method

Method used to display the viewer form.

Overload List

Method used to display the viewer form.

new public void Show();

Method used to display the viewer form.

public void Show(Form);

Inherited from Form.

public void Show(IWin32Window);

See Also

ArchiveRunViewer Class | Aptify.Framework.Archive Namespace


ArchiveRunViewer.Show Method ()

Method used to display the viewer form.

new public void Show();

Implements

IAptifyTopLevelViewer.

Remarks

See Also

ArchiveRunViewer Class | Aptify.Framework.Archive Namespace | ArchiveRunViewer.Show Overload List


ArchiveRunViewer.Show Method (Form)

Method used to display the viewer form.

public void Show(
Form ParentForm
);

Parameters

ParentForm
Form object which raised the current form.

Implements

IAptifyTopLevelViewer.

Remarks

See Also

ArchiveRunViewer Class | Aptify.Framework.Archive Namespace | ArchiveRunViewer.Show Overload List


ShowDialog Method

Aptify 5.0 Software Development Kit (SDK)

ArchiveRunViewer.ShowDialog Method

Method used to display the viewer form in dialog mode.

Overload List

Method used to display the viewer form in dialog mode.

new public DialogResult ShowDialog();

Method used to display the viewer form in dialog mode.

public DialogResult ShowDialog(Form);

Inherited from Form.

public DialogResult ShowDialog(IWin32Window);

See Also

ArchiveRunViewer Class | Aptify.Framework.Archive Namespace


ArchiveRunViewer.ShowDialog Method ()

Method used to display the viewer form in dialog mode.

new public DialogResult ShowDialog();

Return Value

Implements

IAptifyTopLevelViewer.

Remarks

See Also

ArchiveRunViewer Class | Aptify.Framework.Archive Namespace | ArchiveRunViewer.ShowDialog Overload List


ArchiveRunViewer.ShowDialog Method (Form)

Method used to display the viewer form in dialog mode.

public DialogResult ShowDialog(
Form ParentForm
);

Parameters

ParentForm
Form object which raised the current form.

Return Value

Implements

IAptifyTopLevelViewer.

Remarks

See Also

ArchiveRunViewer Class | Aptify.Framework.Archive Namespace | ArchiveRunViewer.ShowDialog Overload List


ArchiveStatus Class

For a list of all members of this type, see ArchiveStatus Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
ArchiveStatus

public class ArchiveStatus : Form

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.Archive

Assembly: AptifyArchive (in AptifyArchive.dll)

See Also

ArchiveStatus Members | Aptify.Framework.Archive Namespace


ArchiveStatus Members

ArchiveStatus overview

Public Instance Constructors

ArchiveStatus Overloaded. Initializes a new instance of the ArchiveStatus class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetStatusMsg |
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
SetStatus | Overloaded. Method used to pass a status message to the status object.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ArchiveStatus Class | Aptify.Framework.Archive Namespace


ArchiveStatus Constructor

Initializes a new instance of the ArchiveStatus class.

Overload List

Initializes a new instance of the ArchiveStatus class.

public ArchiveStatus();

public ArchiveStatus(UserCredentials);

See Also

ArchiveStatus Class | Aptify.Framework.Archive Namespace


ArchiveStatus Constructor ()

Initializes a new instance of the ArchiveStatus class.

public ArchiveStatus();

See Also

ArchiveStatus Class | Aptify.Framework.Archive Namespace | ArchiveStatus Constructor Overload List


ArchiveStatus Constructor (UserCredentials)

public ArchiveStatus(
UserCredentials pUserCredential
);

See Also

ArchiveStatus Class | Aptify.Framework.Archive Namespace | ArchiveStatus Constructor Overload List


ArchiveStatus Methods

The methods of the ArchiveStatus class are listed below. For a complete list of ArchiveStatus class members, see the ArchiveStatus Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetStatusMsg |
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
SetStatus | Overloaded. Method used to pass a status message to the status object.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ArchiveStatus Class | Aptify.Framework.Archive Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

ArchiveStatus.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

ArchiveStatus Class | Aptify.Framework.Archive Namespace


ArchiveStatus.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

ArchiveStatus Class | Aptify.Framework.Archive Namespace | ArchiveStatus.Dispose Overload List


ArchiveStatus.GetStatusMsg Method

public string GetStatusMsg();

See Also

ArchiveStatus Class | Aptify.Framework.Archive Namespace


SetStatus Method

Aptify 5.0 Software Development Kit (SDK)

ArchiveStatus.SetStatus Method

Method used to pass a status message to the status object.

Overload List

Method used to pass a status message to the status object.

public void SetStatus(String,Boolean);

Method used to pass a status message to the status object.

public void SetStatus(String,String,Boolean);

See Also

ArchiveStatus Class | Aptify.Framework.Archive Namespace


ArchiveStatus.SetStatus Method (String, Boolean)

Method used to pass a status message to the status object.

public void SetStatus(
String sMessage,
Boolean bInit
);

Parameters

sMessage
String representing the ststus muessage.
bInit
Boolean indicatingif the status queue should be initialized.

Remarks

See Also

ArchiveStatus Class | Aptify.Framework.Archive Namespace | ArchiveStatus.SetStatus Overload List


ArchiveStatus.SetStatus Method (String, String, Boolean)

Method used to pass a status message to the status object.

public void SetStatus(
String sCulturestringName,
String sMessage,
Boolean bInit
);

Parameters

sCulturestringName
sMessage
String representing the ststus muessage.
bInit
Boolean indicatingif the status queue should be initialized.

Remarks

See Also

ArchiveStatus Class | Aptify.Framework.Archive Namespace | ArchiveStatus.SetStatus Overload List


ArchiveType Class

The Archive Type object is used to manage the plugin features of the Aptify Archive tool. The object is initialized by responding to the ArchiveType of the Archive Run record.

For a list of all members of this type, see ArchiveType Members.

System.Object
ArchiveType

public class ArchiveType : IAptifyArchiveType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.Archive

Assembly: AptifyArchive (in AptifyArchive.dll)

See Also

ArchiveType Members | Aptify.Framework.Archive Namespace


ArchiveType Members

ArchiveType overview

Public Instance Constructors

ArchiveType Constructor Initializes a new instance of the ArchiveType class.

Public Instance Properties

AllowArchive | Read Only Property identifying if the configured archive type allows archiving.
AllowDelete | Read Only Property identifying if the configured archive type allows deletion.
ArchiveRecords | Reference to an ArchiveRecords object, appropriate to the archive type.
ArchiveSelectionGUI | Reference to an ArchiveGUI object, appropriate to the archive type.
ArchiveTypeID | Read only property identifying the configured Archive Type ID.
GUIAssembly | Read only property identifying the Assembly used to display the selection criterion control.
GUIClass | Read only property identifying the Class name used to display the selection criterion control.
GUIObject | Read only property identifying the Object Repository name used to display the selection criterion control.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SetArchiveTypeID | Method used to update the reconfigure the Archive Type object with a new archive type value.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ArchiveType Class | Aptify.Framework.Archive Namespace


ArchiveType Constructor

Initializes a new instance of the ArchiveType class.

public ArchiveType();

See Also

ArchiveType Class | Aptify.Framework.Archive Namespace


ArchiveType Properties

The properties of the ArchiveType class are listed below. For a complete list of ArchiveType class members, see the ArchiveType Members topic.

Public Instance Properties

AllowArchive | Read Only Property identifying if the configured archive type allows archiving.
AllowDelete | Read Only Property identifying if the configured archive type allows deletion.
ArchiveRecords | Reference to an ArchiveRecords object, appropriate to the archive type.
ArchiveSelectionGUI | Reference to an ArchiveGUI object, appropriate to the archive type.
ArchiveTypeID | Read only property identifying the configured Archive Type ID.
GUIAssembly | Read only property identifying the Assembly used to display the selection criterion control.
GUIClass | Read only property identifying the Class name used to display the selection criterion control.
GUIObject | Read only property identifying the Object Repository name used to display the selection criterion control.

See Also

ArchiveType Class | Aptify.Framework.Archive Namespace


AllowArchive Property

Aptify 5.0 Software Development Kit (SDK)

ArchiveType.AllowArchive Property

Read Only Property identifying if the configured archive type allows archiving.

public Boolean AllowArchive {get;}

Property Value

Returns TRUE if the object supports Archiving.

Implements

IAptifyArchiveType.

Remarks

See Also

ArchiveType Class | Aptify.Framework.Archive Namespace


AllowDelete Property

Aptify 5.0 Software Development Kit (SDK)

ArchiveType.AllowDelete Property

Read Only Property identifying if the configured archive type allows deletion.

public Boolean AllowDelete {get;}

Property Value

Returns TRUE if the object supports deletion.

Implements

IAptifyArchiveType.

Remarks

See Also

ArchiveType Class | Aptify.Framework.Archive Namespace


ArchiveRecords Property

Aptify 5.0 Software Development Kit (SDK)

ArchiveType.ArchiveRecords Property

Reference to an ArchiveRecords object, appropriate to the archive type.

public IAptifyArchiveRecords ArchiveRecords {get;}

Property Value

Reference to an ArchiveRecords object.

Implements

IAptifyArchiveType.

Remarks

See Also

ArchiveType Class | Aptify.Framework.Archive Namespace


ArchiveSelectionGUI Property

Aptify 5.0 Software Development Kit (SDK)

ArchiveType.ArchiveSelectionGUI Property

Reference to an ArchiveGUI object, appropriate to the archive type.

public IAptifyArchiveGUI ArchiveSelectionGUI {get;}

Property Value

Reference to an ArchiveGUI object.

Implements

IAptifyArchiveType.

Remarks

See Also

ArchiveType Class | Aptify.Framework.Archive Namespace


ArchiveTypeID Property

Aptify 5.0 Software Development Kit (SDK)

ArchiveType.ArchiveTypeID Property

Read only property identifying the configured Archive Type ID.

public Int64 ArchiveTypeID {get;}

Property Value

Returns a long with the ID of the Archive Type entity.

Implements

IAptifyArchiveType.

Remarks

See Also

ArchiveType Class | Aptify.Framework.Archive Namespace


GUIAssembly Property

Aptify 5.0 Software Development Kit (SDK)

ArchiveType.GUIAssembly Property

Read only property identifying the Assembly used to display the selection criterion control.

public String GUIAssembly {get;}

Property Value

Returns a string containing the control's assembly name.

Implements

IAptifyArchiveType.

Remarks

See Also

ArchiveType Class | Aptify.Framework.Archive Namespace


GUIClass Property

Aptify 5.0 Software Development Kit (SDK)

ArchiveType.GUIClass Property

Read only property identifying the Class name used to display the selection criterion control.

public String GUIClass {get;}

Property Value

Returns a string containing the control's class name.

Implements

IAptifyArchiveType.

Remarks

See Also

ArchiveType Class | Aptify.Framework.Archive Namespace


GUIObject Property

Aptify 5.0 Software Development Kit (SDK)

ArchiveType.GUIObject Property

Read only property identifying the Object Repository name used to display the selection criterion control.

public String GUIObject {get;}

Property Value

Returns a string containing the control's Object Reopsitory name.

Implements

IAptifyArchiveType.

Remarks

See Also

ArchiveType Class | Aptify.Framework.Archive Namespace


ArchiveType Methods

The methods of the ArchiveType class are listed below. For a complete list of ArchiveType class members, see the ArchiveType Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SetArchiveTypeID | Method used to update the reconfigure the Archive Type object with a new archive type value.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ArchiveType Class | Aptify.Framework.Archive Namespace


ArchiveType.SetArchiveTypeID Method

Method used to update the reconfigure the Archive Type object with a new archive type value.

public bool SetArchiveTypeID(
ref AptifyGenericEntityBase& GE,
Int64 lArchiveTypeID
);

Parameters

GE
Archive Run GE object used to configure the Archive Type object with a new context.
lArchiveTypeID
A long representing the new ArchiveType.

Return Value

Returns a TRUE indicating that the method suceeded and false if not.

Implements

IAptifyArchiveType.

Remarks

By calling this method, the developer is reconfiguring the object with the appropriate values to the new archive type.

See Also

ArchiveType Class | Aptify.Framework.Archive Namespace


IAptifyArchiveGUI Interface

Interface that will be implemented by UserControls that will plug in to the Archive Runs Data Form. UserControls can provide specific UI elements tailored to an Archive Type. The main responsibility of the control is to determine that the selected options are valid, and if so, to provide a SQL statement that will be used for the selection criteria of the Archive Run.

For a list of all members of this type, see IAptifyArchiveGUI Members.

public interface IAptifyArchiveGUI

Types that implement IAptifyArchiveGUI

Type | Description
ListsControl | The Lists Control is used to provide functionality to assist the user with forming the selection criterion for use in the archive run.
RecordHistoryControl | The Record History Control is used to provide functionality to assist the user with forming the selection criterion for use in the archive run.

Remarks

Requirements

Namespace: Aptify.Framework.Archive

Assembly: AptifyArchive (in AptifyArchive.dll)

See Also

IAptifyArchiveGUI Members | Aptify.Framework.Archive Namespace


IAptifyArchiveGUI Members

IAptifyArchiveGUI overview

Public Instance Properties

ArchiveSelectionSQL | Property representing the selection SQL as rendered by the control. Used to represent the working data set.
ArchiveSelectionText | Textual representation of the working set.

Public Instance Methods

Config The Config Method is used to allow the control access to the data of the Generic Entity being displayed in the control. Implementing objects should return TRUE if component is configured properly and FALSE if not.

See Also

IAptifyArchiveGUI Interface | Aptify.Framework.Archive Namespace


IAptifyArchiveGUI Properties

The properties of the IAptifyArchiveGUI interface are listed below. For a complete list of IAptifyArchiveGUI interface members, see the IAptifyArchiveGUI Members topic.

Public Instance Properties

ArchiveSelectionSQL | Property representing the selection SQL as rendered by the control. Used to represent the working data set.
ArchiveSelectionText | Textual representation of the working set.

See Also

IAptifyArchiveGUI Interface | Aptify.Framework.Archive Namespace


ArchiveSelectionSQL Property

Aptify 5.0 Software Development Kit (SDK)

IAptifyArchiveGUI.ArchiveSelectionSQL Property

Property representing the selection SQL as rendered by the control. Used to represent the working data set.

String ArchiveSelectionSQL {get;}

Property Value

String

Remarks

See Also

IAptifyArchiveGUI Interface | Aptify.Framework.Archive Namespace


ArchiveSelectionText Property

Aptify 5.0 Software Development Kit (SDK)

IAptifyArchiveGUI.ArchiveSelectionText Property

Textual representation of the working set.

String ArchiveSelectionText {get;}

Property Value

String

Remarks

See Also

IAptifyArchiveGUI Interface | Aptify.Framework.Archive Namespace


IAptifyArchiveGUI Methods

The methods of the IAptifyArchiveGUI interface are listed below. For a complete list of IAptifyArchiveGUI interface members, see the IAptifyArchiveGUI Members topic.

Public Instance Methods

Config The Config Method is used to allow the control access to the data of the Generic Entity being displayed in the control. Implementing objects should return TRUE if component is configured properly and FALSE if not.

See Also

IAptifyArchiveGUI Interface | Aptify.Framework.Archive Namespace


IAptifyArchiveGUI.Config Method

The Config Method is used to allow the control access to the data of the Generic Entity being displayed in the control. Implementing objects should return TRUE if component is configured properly and FALSE if not.

bool Config(
ref AptifyGenericEntityBase& oArchiveRunGE
);

Parameters

oArchiveRunGE
The Generic Entity used to configure the object.

Return Value

Boolean

Remarks

See Also

IAptifyArchiveGUI Interface | Aptify.Framework.Archive Namespace


IAptifyArchiveRecords Interface

This interface is used by the Archive feature in Aptify. All archive and delete operations must have a class that implements this interface. The implementation is responsible for providing configuration data to the Archive Run record, validating the supplied criteria and to executing the desired operation. (Archive, Copy, Delete)

For a list of all members of this type, see IAptifyArchiveRecords Members.

public interface IAptifyArchiveRecords

Types that implement IAptifyArchiveRecords

Type | Description
ArchiveRecordBase | ArchiveRecordBase is a base class used to build archive type objects for use in archiving new record types. ArchiveRecordBase implements the IArchiveRecords object.
Lists | The lists class inherits from ArchiveRecordBase. It is designed to handle the archival of Lists records. It is an approved plugin which is driven by the archival process.
RecordHistory | The lists class inherits from ArchiveRecordBase. It is designed to handle the archival of Record History (EntityRecordVersions) records. It is an approved plugin which is driven by the archival process.

Remarks

Requirements

Namespace: Aptify.Framework.Archive

Assembly: AptifyArchive (in AptifyArchive.dll)

See Also

IAptifyArchiveRecords Members | Aptify.Framework.Archive Namespace


IAptifyArchiveRecords Members

IAptifyArchiveRecords overview

Public Instance Properties

LastMessage | Used to return a message to the caller.
SupportedOperations | Used to return the operations that are supported by the object.

Public Instance Methods

Config | Method used to configure the archive records object.
Execute | Performs the Archive, Copy or Delete operation as determined by the values in the ArchiveRun GE object
ResetCounts | Method used to reset the counters inside the Archive Record plugin.
Validate | Function used to provide a means of validating the current standing of the Archive Records implementation object.

Public Instance Events

BatchComplete | Event fires when Batch of records is completed.
BatchStarted | Event fires when Batch of records is begun.
CriticalError | Event fires for a critical error.
IncidentalError | Event fires for non critical error.
RunCompleted | Event fires for completion of process.
RunStarted | Event fires for begin of process.
UpdateStatus | Catchall event used to post a general message.

See Also

IAptifyArchiveRecords Interface | Aptify.Framework.Archive Namespace


IAptifyArchiveRecords Properties

The properties of the IAptifyArchiveRecords interface are listed below. For a complete list of IAptifyArchiveRecords interface members, see the IAptifyArchiveRecords Members topic.

Public Instance Properties

LastMessage | Used to return a message to the caller.
SupportedOperations | Used to return the operations that are supported by the object.

See Also

IAptifyArchiveRecords Interface | Aptify.Framework.Archive Namespace


LastMessage Property

Aptify 5.0 Software Development Kit (SDK)

IAptifyArchiveRecords.LastMessage Property

Used to return a message to the caller.

String LastMessage {get;}

Property Value

String

Remarks

For example, if Config returns False, LastMessage should be populated with information about the failure. Calls to any method should reset LastMessage to an empty string.

See Also

IAptifyArchiveRecords Interface | Aptify.Framework.Archive Namespace


SupportedOperations Property

Aptify 5.0 Software Development Kit (SDK)

IAptifyArchiveRecords.SupportedOperations Property

Used to return the operations that are supported by the object.

IAptifyArchiveRecords.arOperations SupportedOperations {get;}

Property Value

arOperations enumerated value.

Remarks

If ArchiveTypeID is used in any way to determine supported operations then it is only valid to call this property after Config has been successfully called. Implementations can support Archive and Delete operations. Possible Values: UnableToDetermine (0), Arcihve (1), Delete (2), Archive and Delete (3). A value of UnableToDetermine should record information in the Aptify Error Log and populate LastMessage with an explanation.

Example

    Dim oAR as IAptifyArchiveRecords
    Dim bDelete as Boolean
    If oAR.SupportedOperations = aroDelete then
        bDelete = True
    Else
        bDelete = False
    End If

See Also

IAptifyArchiveRecords Interface | Aptify.Framework.Archive Namespace


IAptifyArchiveRecords Methods

The methods of the IAptifyArchiveRecords interface are listed below. For a complete list of IAptifyArchiveRecords interface members, see the IAptifyArchiveRecords Members topic.

Public Instance Methods

Config | Method used to configure the archive records object.
Execute | Performs the Archive, Copy or Delete operation as determined by the values in the ArchiveRun GE object
ResetCounts | Method used to reset the counters inside the Archive Record plugin.
Validate | Function used to provide a means of validating the current standing of the Archive Records implementation object.

See Also

IAptifyArchiveRecords Interface | Aptify.Framework.Archive Namespace


IAptifyArchiveRecords.Config Method

Method used to configure the archive records object.

bool Config(
ref AptifyGenericEntityBase& oArchiveRunGE
);

Parameters

oArchiveRunGE
A GE representing the current Archive Run record.

Return Value

Remarks

oArchiveRunGE is a valid reference to an Archive Runs GE object configured to create a new record upon save. Also, the ArchiveTypeID field must have a value that links to an existing Archive Types record. If the object is not properly configured, an error should be recorded to the log and the Config method should return False.

See Also

IAptifyArchiveRecords Interface | Aptify.Framework.Archive Namespace


IAptifyArchiveRecords.Execute Method

Performs the Archive, Copy or Delete operation as determined by the values in the ArchiveRun GE object

bool Execute(
String sSelectionSQL,
Boolean bCreateTables,
Boolean bSingleTransaction,
Int64 lBatchSize,
Boolean bTestRun,
Boolean bShowGUI
);

Parameters

sSelectionSQL
A SQL statement that returns the main records that will be processed. The SQL statement must return the Primary Key for each record.
bCreateTables
Tables in the Destination Database will be created, if the tables don't already exist. Implementation component will be responsible for correctly building the destination tables.
bSingleTransaction
Archive/Copy/Delete operation will occur in a single transaction if True. Each Archive batch will be committed as they complete.
lBatchSize
The number of main records to work on at a time. Larger numbers are usually more efficient but will provide less feedback to the user. A BatchSize of -1 indicates that the default batch size should be used. Each implementation should provide its own default.
bTestRun
If False, execute the operation. If True, do not Archive, Copy or Delete records, just gather information about the operation and provide it in the Status Window (if bShowGUI = True). This can provide information about record counts so that the user can feel confident that the selection criteria is correct.
bShowGUI
If True, then a Status window can be displayed to provide feedback to the user as the operation executes. If False, the object should not display any GUI components.

Return Value

Returns True upon successful completion of the operation. Otherwise, returns False. When returning False, the implemention should log an error and update LastMessage with an explanation.

Remarks

See Also

IAptifyArchiveRecords Interface | Aptify.Framework.Archive Namespace


IAptifyArchiveRecords.ResetCounts Method

Method used to reset the counters inside the Archive Record plugin.

void ResetCounts();

Remarks

See Also

IAptifyArchiveRecords Interface | Aptify.Framework.Archive Namespace


IAptifyArchiveRecords.Validate Method

Function used to provide a means of validating the current standing of the Archive Records implementation object.

bool Validate(
ref String& sError
);

Parameters

sError
Parameter used to return any error messages that may be generated in the validation process.

Return Value

Boolean

Remarks

Validates the information in the ArchiveRun GE and, for an Archive operation, validates that a connection to the destination database can be established and that the SelectionSQL statement has been provided. If everything is OK, Validate should return True. If not, Validate should return False and populate LastMessage with an explanation.

See Also

IAptifyArchiveRecords Interface | Aptify.Framework.Archive Namespace


IAptifyArchiveRecords Events

The events of the IAptifyArchiveRecords interface are listed below. For a complete list of IAptifyArchiveRecords interface members, see the IAptifyArchiveRecords Members topic.

Public Instance Events

BatchComplete | Event fires when Batch of records is completed.
BatchStarted | Event fires when Batch of records is begun.
CriticalError | Event fires for a critical error.
IncidentalError | Event fires for non critical error.
RunCompleted | Event fires for completion of process.
RunStarted | Event fires for begin of process.
UpdateStatus | Catchall event used to post a general message.

See Also

IAptifyArchiveRecords Interface | Aptify.Framework.Archive Namespace


IAptifyArchiveRecords.IAptifyArchiveRecords.BatchCompleteEventHandler Event

Event fires when Batch of records is completed.

event IAptifyArchiveRecords.BatchCompleteEventHandler BatchComplete;

Remarks

See Also

IAptifyArchiveRecords Interface | Aptify.Framework.Archive Namespace


IAptifyArchiveRecords.IAptifyArchiveRecords.BatchStartedEventHandler Event

Event fires when Batch of records is begun.

event IAptifyArchiveRecords.BatchStartedEventHandler BatchStarted;

Remarks

See Also

IAptifyArchiveRecords Interface | Aptify.Framework.Archive Namespace


IAptifyArchiveRecords.IAptifyArchiveRecords.CriticalErrorEventHandler Event

Event fires for a critical error.

event IAptifyArchiveRecords.CriticalErrorEventHandler CriticalError;

Remarks

See Also

IAptifyArchiveRecords Interface | Aptify.Framework.Archive Namespace


IAptifyArchiveRecords.IAptifyArchiveRecords.IncidentalErrorEventHandler Event

Event fires for non critical error.

event IAptifyArchiveRecords.IncidentalErrorEventHandler IncidentalError;

Remarks

See Also

IAptifyArchiveRecords Interface | Aptify.Framework.Archive Namespace


IAptifyArchiveRecords.IAptifyArchiveRecords.RunCompletedEventHandler Event

Event fires for completion of process.

event IAptifyArchiveRecords.RunCompletedEventHandler RunCompleted;

Remarks

See Also

IAptifyArchiveRecords Interface | Aptify.Framework.Archive Namespace


IAptifyArchiveRecords.IAptifyArchiveRecords.RunStartedEventHandler Event

Event fires for begin of process.

event IAptifyArchiveRecords.RunStartedEventHandler RunStarted;

Remarks

See Also

IAptifyArchiveRecords Interface | Aptify.Framework.Archive Namespace


IAptifyArchiveRecords.IAptifyArchiveRecords.UpdateStatusEventHandler Event

Catchall event used to post a general message.

event IAptifyArchiveRecords.UpdateStatusEventHandler UpdateStatus;

Remarks

See Also

IAptifyArchiveRecords Interface | Aptify.Framework.Archive Namespace


IAptifyArchiveRecords.arOperations Enumeration

Enumerated values representing the possible supported operations in the implementation of the Archive Records interface.

public enum IAptifyArchiveRecords.arOperations

Remarks

Members

Member Name | Description
aroUnableToDetermine |
aroArchive |
aroDelete |
aroArchiveAndDelete |

Requirements

Namespace: Aptify.Framework.Archive

Assembly: AptifyArchive (in AptifyArchive.dll)

See Also

Aptify.Framework.Archive Namespace


IAptifyArchiveRecords.BatchCompleteEventHandler Delegate

public delegate void IAptifyArchiveRecords.BatchCompleteEventHandler(
String sMessage
);

Requirements

Namespace: Aptify.Framework.Archive

Assembly: AptifyArchive (in AptifyArchive.dll)

See Also

Aptify.Framework.Archive Namespace


IAptifyArchiveRecords.BatchStartedEventHandler Delegate

public delegate void IAptifyArchiveRecords.BatchStartedEventHandler(
String sMessage
);

Requirements

Namespace: Aptify.Framework.Archive

Assembly: AptifyArchive (in AptifyArchive.dll)

See Also

Aptify.Framework.Archive Namespace


IAptifyArchiveRecords.CriticalErrorEventHandler Delegate

public delegate void IAptifyArchiveRecords.CriticalErrorEventHandler(
String sMessage
);

Requirements

Namespace: Aptify.Framework.Archive

Assembly: AptifyArchive (in AptifyArchive.dll)

See Also

Aptify.Framework.Archive Namespace


IAptifyArchiveRecords.IncidentalErrorEventHandler Delegate

public delegate void IAptifyArchiveRecords.IncidentalErrorEventHandler(
String sMessage
);

Requirements

Namespace: Aptify.Framework.Archive

Assembly: AptifyArchive (in AptifyArchive.dll)

See Also

Aptify.Framework.Archive Namespace


IAptifyArchiveRecords.RunCompletedEventHandler Delegate

public delegate void IAptifyArchiveRecords.RunCompletedEventHandler(
String sMessage
);

Requirements

Namespace: Aptify.Framework.Archive

Assembly: AptifyArchive (in AptifyArchive.dll)

See Also

Aptify.Framework.Archive Namespace


IAptifyArchiveRecords.RunStartedEventHandler Delegate

public delegate void IAptifyArchiveRecords.RunStartedEventHandler(
String sMessage
);

Requirements

Namespace: Aptify.Framework.Archive

Assembly: AptifyArchive (in AptifyArchive.dll)

See Also

Aptify.Framework.Archive Namespace


IAptifyArchiveRecords.UpdateStatusEventHandler Delegate

public delegate void IAptifyArchiveRecords.UpdateStatusEventHandler(
String sMessage
);

Requirements

Namespace: Aptify.Framework.Archive

Assembly: AptifyArchive (in AptifyArchive.dll)

See Also

Aptify.Framework.Archive Namespace


IAptifyArchiveRun Interface

This interface provides all extended functionality for the Archive Run Object. To be implemented by the GE Wrapper for the Achive Runs entity. Provides specific access to configuration data specific to an archive run.

For a list of all members of this type, see IAptifyArchiveRun Members.

public interface IAptifyArchiveRun

Types that implement IAptifyArchiveRun

Type | Description
ArchiveEntity | Entity object for the Archive Runs entity. Provides all archival functionality within the Archive Run record.

Remarks

Requirements

Namespace: Aptify.Framework.Archive

Assembly: AptifyArchive (in AptifyArchive.dll)

See Also

IAptifyArchiveRun Members | Aptify.Framework.Archive Namespace


IAptifyArchiveRun Members

IAptifyArchiveRun overview

Public Instance Properties

ArchiveTypeObject | Returns the active ArchiveTypeObject, if is has been instantiated and configured. If not, it returns Nothing and the GE's LastErrorMessage should be updated with an explanation.
BatchSize | Returns the batch size as configured in the GE object.
CreateTables | Returns a boolean representing if tables should be created during the archive operation. Will return TRUE if tables are to be created and FALSE if not.
Database | Returns the name of the target database for the archive process.
DeleteRecords | Boolean property that indicates if records are deleted or not. Value is set based on the operation type of the archive run record.
Password | Returns the Password as provided during the login process. This value will not be persisted in the database. This property will not be utilized for trusted connections.
SelectionSQL | Returns the current value of the SelectionSQL statement.
ServerName | Returns the name of the target server for the archive process.
SingleTransaction | Returns a boolean representing if the Archive Run should be attempted in a single SQL Transaction.
TransferRecords | Boolean property that indicates if records are transfered or not. Value is set based on the operation type of the archive run record.
TrustedConnection | Returns a boolean indicating if the connection to the target database should be trusted or untrusted.
UserName | Returns the username as provided during the login process. This value will not be persisted in the Archive Run record. This property will not be utilized for trusted connections.

Public Instance Methods

ExecuteTest Method used to invoke a test run of the archive tool.

See Also

IAptifyArchiveRun Interface | Aptify.Framework.Archive Namespace


IAptifyArchiveRun Properties

The properties of the IAptifyArchiveRun interface are listed below. For a complete list of IAptifyArchiveRun interface members, see the IAptifyArchiveRun Members topic.

Public Instance Properties

ArchiveTypeObject | Returns the active ArchiveTypeObject, if is has been instantiated and configured. If not, it returns Nothing and the GE's LastErrorMessage should be updated with an explanation.
BatchSize | Returns the batch size as configured in the GE object.
CreateTables | Returns a boolean representing if tables should be created during the archive operation. Will return TRUE if tables are to be created and FALSE if not.
Database | Returns the name of the target database for the archive process.
DeleteRecords | Boolean property that indicates if records are deleted or not. Value is set based on the operation type of the archive run record.
Password | Returns the Password as provided during the login process. This value will not be persisted in the database. This property will not be utilized for trusted connections.
SelectionSQL | Returns the current value of the SelectionSQL statement.
ServerName | Returns the name of the target server for the archive process.
SingleTransaction | Returns a boolean representing if the Archive Run should be attempted in a single SQL Transaction.
TransferRecords | Boolean property that indicates if records are transfered or not. Value is set based on the operation type of the archive run record.
TrustedConnection | Returns a boolean indicating if the connection to the target database should be trusted or untrusted.
UserName | Returns the username as provided during the login process. This value will not be persisted in the Archive Run record. This property will not be utilized for trusted connections.

See Also

IAptifyArchiveRun Interface | Aptify.Framework.Archive Namespace


ArchiveTypeObject Property

Aptify 5.0 Software Development Kit (SDK)

IAptifyArchiveRun.ArchiveTypeObject Property

Returns the active ArchiveTypeObject, if is has been instantiated and configured. If not, it returns Nothing and the GE's LastErrorMessage should be updated with an explanation.

IAptifyArchiveType ArchiveTypeObject {get;}

Property Value

ArchiveTypeObject

Remarks

See Also

IAptifyArchiveRun Interface | Aptify.Framework.Archive Namespace


BatchSize Property

Aptify 5.0 Software Development Kit (SDK)

IAptifyArchiveRun.BatchSize Property

Returns the batch size as configured in the GE object.

Int64 BatchSize {get; set;}

Property Value

Long

Remarks

See Also

IAptifyArchiveRun Interface | Aptify.Framework.Archive Namespace


CreateTables Property

Aptify 5.0 Software Development Kit (SDK)

IAptifyArchiveRun.CreateTables Property

Returns a boolean representing if tables should be created during the archive operation. Will return TRUE if tables are to be created and FALSE if not.

Boolean CreateTables {get; set;}

Property Value

Boolean

Remarks

See Also

IAptifyArchiveRun Interface | Aptify.Framework.Archive Namespace


Database Property

Aptify 5.0 Software Development Kit (SDK)

IAptifyArchiveRun.Database Property

Returns the name of the target database for the archive process.

String Database {get; set;}

Property Value

String

Remarks

See Also

IAptifyArchiveRun Interface | Aptify.Framework.Archive Namespace


DeleteRecords Property

Aptify 5.0 Software Development Kit (SDK)

IAptifyArchiveRun.DeleteRecords Property

Boolean property that indicates if records are deleted or not. Value is set based on the operation type of the archive run record.

Boolean DeleteRecords {get;}

Property Value

Returns True if Operation Type dictates records are to be deleted.

Remarks

See Also

IAptifyArchiveRun Interface | Aptify.Framework.Archive Namespace


Password Property

Aptify 5.0 Software Development Kit (SDK)

IAptifyArchiveRun.Password Property

Returns the Password as provided during the login process. This value will not be persisted in the database. This property will not be utilized for trusted connections.

String Password {get; set;}

Property Value

String

Remarks

See Also

IAptifyArchiveRun Interface | Aptify.Framework.Archive Namespace


SelectionSQL Property

Aptify 5.0 Software Development Kit (SDK)

IAptifyArchiveRun.SelectionSQL Property

Returns the current value of the SelectionSQL statement.

String SelectionSQL {get; set;}

Property Value

String

Remarks

See Also

IAptifyArchiveRun Interface | Aptify.Framework.Archive Namespace


ServerName Property

Aptify 5.0 Software Development Kit (SDK)

IAptifyArchiveRun.ServerName Property

Returns the name of the target server for the archive process.

String ServerName {get; set;}

Property Value

String

Remarks

See Also

IAptifyArchiveRun Interface | Aptify.Framework.Archive Namespace


SingleTransaction Property

Aptify 5.0 Software Development Kit (SDK)

IAptifyArchiveRun.SingleTransaction Property

Returns a boolean representing if the Archive Run should be attempted in a single SQL Transaction.

Boolean SingleTransaction {get; set;}

Property Value

Boolean

Remarks

See Also

IAptifyArchiveRun Interface | Aptify.Framework.Archive Namespace


TransferRecords Property

Aptify 5.0 Software Development Kit (SDK)

IAptifyArchiveRun.TransferRecords Property

Boolean property that indicates if records are transfered or not. Value is set based on the operation type of the archive run record.

Boolean TransferRecords {get;}

Property Value

Returns True if the Operation Type dictates records are to be transfered.

Remarks

See Also

IAptifyArchiveRun Interface | Aptify.Framework.Archive Namespace


TrustedConnection Property

Aptify 5.0 Software Development Kit (SDK)

IAptifyArchiveRun.TrustedConnection Property

Returns a boolean indicating if the connection to the target database should be trusted or untrusted.

Boolean TrustedConnection {get; set;}

Property Value

Boolean

Remarks

See Also

IAptifyArchiveRun Interface | Aptify.Framework.Archive Namespace


UserName Property

Aptify 5.0 Software Development Kit (SDK)

IAptifyArchiveRun.UserName Property

Returns the username as provided during the login process. This value will not be persisted in the Archive Run record. This property will not be utilized for trusted connections.

String UserName {get; set;}

Property Value

String

Remarks

See Also

IAptifyArchiveRun Interface | Aptify.Framework.Archive Namespace


IAptifyArchiveRun Methods

The methods of the IAptifyArchiveRun interface are listed below. For a complete list of IAptifyArchiveRun interface members, see the IAptifyArchiveRun Members topic.

Public Instance Methods

ExecuteTest Method used to invoke a test run of the archive tool.

See Also

IAptifyArchiveRun Interface | Aptify.Framework.Archive Namespace


IAptifyArchiveRun.ExecuteTest Method

Method used to invoke a test run of the archive tool.

bool ExecuteTest(
ref String& sOutput,
Boolean bShowGUI
);

Parameters

sOutput
Optional parameter used to pass the resulting output back to the caller.
bShowGUI
Optional parameter used to determine if the object should display GUI results on it's own.

Return Value

Returns a log of the resulting output.

Remarks

See Also

IAptifyArchiveRun Interface | Aptify.Framework.Archive Namespace


IAptifyArchiveType Interface

This interface is implemented for each list type. Two public members exist pointing to plugins of the list type.

For a list of all members of this type, see IAptifyArchiveType Members.

public interface IAptifyArchiveType

Types that implement IAptifyArchiveType

Type | Description
ArchiveType | The Archive Type object is used to manage the plugin features of the Aptify Archive tool. The object is initialized by responding to the ArchiveType of the Archive Run record.

Remarks

Requirements

Namespace: Aptify.Framework.Archive

Assembly: AptifyArchive (in AptifyArchive.dll)

See Also

IAptifyArchiveType Members | Aptify.Framework.Archive Namespace


IAptifyArchiveType Members

IAptifyArchiveType overview

Public Instance Properties

AllowArchive | Returns a boolean indicating that the archive type allows archiving.
AllowDelete | Returns a boolean indicating that the archive type allows deletion.
ArchiveRecords | Returns the active ArchiveRecordsObject instance, if it has been instantiated and configured.
ArchiveSelectionGUI | Returns the active ArchiveSelectionGUI instance, if it has been instantiated and configured.
ArchiveTypeID | Returns the value of the ArchiveTypeID.
GUIAssembly | Returns the Assembly name for the ArchiveSelectionGUI control.
GUIClass | Returns the type name for the GUIClass. Is used to configure the ArchiveSelectionGUI.
GUIObject | Returns the object repository location for the ArchiveSelectionGUI.

Public Instance Methods

SetArchiveTypeID Configures the ArchiveRecordsObject and ArchiveSelectionGUI object when the ArchiveTypeID is changed. This method is used to manage this process.

See Also

IAptifyArchiveType Interface | Aptify.Framework.Archive Namespace


IAptifyArchiveType Properties

The properties of the IAptifyArchiveType interface are listed below. For a complete list of IAptifyArchiveType interface members, see the IAptifyArchiveType Members topic.

Public Instance Properties

AllowArchive | Returns a boolean indicating that the archive type allows archiving.
AllowDelete | Returns a boolean indicating that the archive type allows deletion.
ArchiveRecords | Returns the active ArchiveRecordsObject instance, if it has been instantiated and configured.
ArchiveSelectionGUI | Returns the active ArchiveSelectionGUI instance, if it has been instantiated and configured.
ArchiveTypeID | Returns the value of the ArchiveTypeID.
GUIAssembly | Returns the Assembly name for the ArchiveSelectionGUI control.
GUIClass | Returns the type name for the GUIClass. Is used to configure the ArchiveSelectionGUI.
GUIObject | Returns the object repository location for the ArchiveSelectionGUI.

See Also

IAptifyArchiveType Interface | Aptify.Framework.Archive Namespace


AllowArchive Property

Aptify 5.0 Software Development Kit (SDK)

IAptifyArchiveType.AllowArchive Property

Returns a boolean indicating that the archive type allows archiving.

Boolean AllowArchive {get;}

Property Value

Boolean

Remarks

See Also

IAptifyArchiveType Interface | Aptify.Framework.Archive Namespace


AllowDelete Property

Aptify 5.0 Software Development Kit (SDK)

IAptifyArchiveType.AllowDelete Property

Returns a boolean indicating that the archive type allows deletion.

Boolean AllowDelete {get;}

Property Value

Boolean

Remarks

See Also

IAptifyArchiveType Interface | Aptify.Framework.Archive Namespace


ArchiveRecords Property

Aptify 5.0 Software Development Kit (SDK)

IAptifyArchiveType.ArchiveRecords Property

Returns the active ArchiveRecordsObject instance, if it has been instantiated and configured.

IAptifyArchiveRecords ArchiveRecords {get;}

Property Value

ArchiveRecordsObject

Remarks

See Also

IAptifyArchiveType Interface | Aptify.Framework.Archive Namespace


ArchiveSelectionGUI Property

Aptify 5.0 Software Development Kit (SDK)

IAptifyArchiveType.ArchiveSelectionGUI Property

Returns the active ArchiveSelectionGUI instance, if it has been instantiated and configured.

IAptifyArchiveGUI ArchiveSelectionGUI {get;}

Property Value

ArchiveSelectionGUI

Remarks

See Also

IAptifyArchiveType Interface | Aptify.Framework.Archive Namespace


ArchiveTypeID Property

Aptify 5.0 Software Development Kit (SDK)

IAptifyArchiveType.ArchiveTypeID Property

Returns the value of the ArchiveTypeID.

Int64 ArchiveTypeID {get;}

Property Value

Long

Remarks

See Also

IAptifyArchiveType Interface | Aptify.Framework.Archive Namespace


GUIAssembly Property

Aptify 5.0 Software Development Kit (SDK)

IAptifyArchiveType.GUIAssembly Property

Returns the Assembly name for the ArchiveSelectionGUI control.

String GUIAssembly {get;}

Property Value

String

Remarks

See Also

IAptifyArchiveType Interface | Aptify.Framework.Archive Namespace


GUIClass Property

Aptify 5.0 Software Development Kit (SDK)

IAptifyArchiveType.GUIClass Property

Returns the type name for the GUIClass. Is used to configure the ArchiveSelectionGUI.

String GUIClass {get;}

Property Value

String

Remarks

See Also

IAptifyArchiveType Interface | Aptify.Framework.Archive Namespace


GUIObject Property

Aptify 5.0 Software Development Kit (SDK)

IAptifyArchiveType.GUIObject Property

Returns the object repository location for the ArchiveSelectionGUI.

String GUIObject {get;}

Property Value

String

Remarks

See Also

IAptifyArchiveType Interface | Aptify.Framework.Archive Namespace


IAptifyArchiveType Methods

The methods of the IAptifyArchiveType interface are listed below. For a complete list of IAptifyArchiveType interface members, see the IAptifyArchiveType Members topic.

Public Instance Methods

SetArchiveTypeID Configures the ArchiveRecordsObject and ArchiveSelectionGUI object when the ArchiveTypeID is changed. This method is used to manage this process.

See Also

IAptifyArchiveType Interface | Aptify.Framework.Archive Namespace


IAptifyArchiveType.SetArchiveTypeID Method

Configures the ArchiveRecordsObject and ArchiveSelectionGUI object when the ArchiveTypeID is changed. This method is used to manage this process.

bool SetArchiveTypeID(
ref AptifyGenericEntityBase& oArchiveRunGE,
Int64 lArchiveTypeID
);

Parameters

oArchiveRunGE
The GE representing the ArchiveRun object.
lArchiveTypeID
The new ArchiveTypeID, as is configured in the record.

Return Value

Boolean

Remarks

See Also

IAptifyArchiveType Interface | Aptify.Framework.Archive Namespace


Lists Class

The lists class inherits from ArchiveRecordBase. It is designed to handle the archival of Lists records. It is an approved plugin which is driven by the archival process.

For a list of all members of this type, see Lists Members.

System.Object
ArchiveRecordBase
Lists

public class Lists : ArchiveRecordBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.Archive

Assembly: AptifyArchive (in AptifyArchive.dll)

See Also

Lists Members | Aptify.Framework.Archive Namespace


Lists Members

Lists overview

Public Instance Constructors

Lists Constructor Initializes a new instance of the Lists class.

Public Instance Properties

LastMessage (inherited from ArchiveRecordBase) | String parameter used to retrieve error messages from the object.
SupportedOperations | Property that indicates the functionality supported by any of the plugin components.

Public Instance Methods

Config | Method used to intialize the lists object for use.
CreateTables | Method used to create the SQL tables utilized for storing the archived lists data.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute | Method used to execute the archive of list records.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ResetCounts | Lists-specific method used to clear the counters used within the component.
ToString (inherited from Object) | Returns a String that represents the current Object.
Validate (inherited from ArchiveRecordBase) | Validation provided in the Archive Record Base class validates the presence of appropriate connection parameters.

Protected Instance Fields

m_arSupportedOperations (inherited from ArchiveRecordBase)
m_bShowErrors (inherited from ArchiveRecordBase)
m_bTestRun (inherited from ArchiveRecordBase)
m_connDestination (inherited from ArchiveRecordBase)
m_DSAction (inherited from ArchiveRecordBase)
m_iArchiveTypeID (inherited from ArchiveRecordBase)
m_iDestinationStatementCount (inherited from ArchiveRecordBase)
m_iSourceStatementCount (inherited from ArchiveRecordBase)
m_oApplication (inherited from ArchiveRecordBase)
m_oArchiveRun (inherited from ArchiveRecordBase)
m_oArchiveRunGE (inherited from ArchiveRecordBase)
m_oArchiveTables (inherited from ArchiveRecordBase)
m_oUserCredentials (inherited from ArchiveRecordBase)
m_sConnString (inherited from ArchiveRecordBase)
m_sDestinationBatchStatement (inherited from ArchiveRecordBase)
m_sLastMessage (inherited from ArchiveRecordBase)
m_sSourceBatchStatement (inherited from ArchiveRecordBase)

Protected Instance Methods

AddDestinationBatchStatement (inherited from ArchiveRecordBase) | Function used to add a SQL statement to the batch to be sent to the destination server.
AddSourceBatchStatement (inherited from ArchiveRecordBase) | Function used to add a SQL statement to the batch to be sent to the source server.
AddStatus (inherited from ArchiveRecordBase) | Internal function used to report status via the object event model.
AddTable (inherited from ArchiveRecordBase) | This function is used to create ArchiveTable objects and add them to the array list.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetConnectionString (inherited from ArchiveRecordBase) | Function that creates a connection string, based on the parameters. Will create a connection string for trusted and untrusted connections.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OpenConnection (inherited from ArchiveRecordBase) | Function that opens a connection to the database. Is used primarily to create a connection to the target database.

Protected Instance Events

BatchComplete (inherited from ArchiveRecordBase)
BatchStarted (inherited from ArchiveRecordBase)
CriticalError (inherited from ArchiveRecordBase)
IncidentalError (inherited from ArchiveRecordBase)
RunCompleted (inherited from ArchiveRecordBase)
RunStarted (inherited from ArchiveRecordBase)
UpdateStatus (inherited from ArchiveRecordBase)

See Also

Lists Class | Aptify.Framework.Archive Namespace


Lists Constructor

Initializes a new instance of the Lists class.

public Lists();

See Also

Lists Class | Aptify.Framework.Archive Namespace


Lists Properties

The properties of the Lists class are listed below. For a complete list of Lists class members, see the Lists Members topic.

Public Instance Properties

LastMessage (inherited from ArchiveRecordBase) | String parameter used to retrieve error messages from the object.
SupportedOperations | Property that indicates the functionality supported by any of the plugin components.

See Also

Lists Class | Aptify.Framework.Archive Namespace


SupportedOperations Property

Aptify 5.0 Software Development Kit (SDK)

Lists.SupportedOperations Property

Property that indicates the functionality supported by any of the plugin components.

public override IAptifyArchiveRecords.arOperations SupportedOperations {get;}

Property Value

The value returned indicates the the available operations. The interface definition contains more detailed information on how to implemente this property.

Implements

IAptifyArchiveRecords.

Remarks

See Also

Lists Class | Aptify.Framework.Archive Namespace


Lists Methods

The methods of the Lists class are listed below. For a complete list of Lists class members, see the Lists Members topic.

Public Instance Methods

Config | Method used to intialize the lists object for use.
CreateTables | Method used to create the SQL tables utilized for storing the archived lists data.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute | Method used to execute the archive of list records.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ResetCounts | Lists-specific method used to clear the counters used within the component.
ToString (inherited from Object) | Returns a String that represents the current Object.
Validate (inherited from ArchiveRecordBase) | Validation provided in the Archive Record Base class validates the presence of appropriate connection parameters.

Protected Instance Methods

AddDestinationBatchStatement (inherited from ArchiveRecordBase) | Function used to add a SQL statement to the batch to be sent to the destination server.
AddSourceBatchStatement (inherited from ArchiveRecordBase) | Function used to add a SQL statement to the batch to be sent to the source server.
AddStatus (inherited from ArchiveRecordBase) | Internal function used to report status via the object event model.
AddTable (inherited from ArchiveRecordBase) | This function is used to create ArchiveTable objects and add them to the array list.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetConnectionString (inherited from ArchiveRecordBase) | Function that creates a connection string, based on the parameters. Will create a connection string for trusted and untrusted connections.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OpenConnection (inherited from ArchiveRecordBase) | Function that opens a connection to the database. Is used primarily to create a connection to the target database.

See Also

Lists Class | Aptify.Framework.Archive Namespace


Lists.Config Method

Method used to intialize the lists object for use.

public override bool Config(
ref AptifyGenericEntityBase& oArchiveRunGE
);

Parameters

oArchiveRunGE
ByRef parameter passed in to present the Lists object with access to the data of the Archive Run.

Return Value

Returns TRUE if initialization succeded and FALSE if not.

Implements

IAptifyArchiveRecords.

Remarks

See Also

Lists Class | Aptify.Framework.Archive Namespace


Lists.CreateTables Method

Method used to create the SQL tables utilized for storing the archived lists data.

public override bool CreateTables();

Return Value

Returns TRUE if the tables are created correctly.

Remarks

See Also

Lists Class | Aptify.Framework.Archive Namespace


Lists.Execute Method

Method used to execute the archive of list records.

public override bool Execute(
String sSelectionSQL,
Boolean bCreateTables,
Boolean bSingleTransaction,
Int64 lBatchSize,
Boolean bTestRun,
Boolean bShowGUI
);

Parameters

sSelectionSQL
SQL Statement representing the list records to archive. The critical element of this SQL Statement is the where clause as it determines the scope of records to be archived.
bCreateTables
Boolean parameter indicating when or not the component should attempt to create the archive tables, if they do not already exist.
bSingleTransaction
Boolean parameter indicating whether or not the archive operation should be transacted within a single transaction boundary.
lBatchSize
The number of records to include in each batch.
bTestRun
Boolean indicating if this execution is for test purposes or not.
bShowGUI
Boolean indicating if a User Interface should be used to display the status during the execution.

Return Value

TRUE is returned if the Execute method succeeds or not.

Implements

IAptifyArchiveRecords.

Remarks

See Also

Lists Class | Aptify.Framework.Archive Namespace


Lists.ResetCounts Method

Lists-specific method used to clear the counters used within the component.

public override void ResetCounts();

Implements

IAptifyArchiveRecords.

Remarks

See Also

Lists Class | Aptify.Framework.Archive Namespace


ListsControl Class

The Lists Control is used to provide functionality to assist the user with forming the selection criterion for use in the archive run.

For a list of all members of this type, see ListsControl Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
ListsControl

public class ListsControl : UserControl, IAptifyArchiveGUI

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.Archive

Assembly: AptifyArchive (in AptifyArchive.dll)

See Also

ListsControl Members | Aptify.Framework.Archive Namespace


ListsControl Members

ListsControl overview

Public Instance Constructors

ListsControl Constructor Initializes a new instance of the ListsControl class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ArchiveSelectionSQL | Property indicating the selection criterion to be used by the archive run.
ArchiveSelectionText | Property indicating a selection description for the criterion used by the archive run.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config | Method used to configure the selection control for use.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ListsControl Class | Aptify.Framework.Archive Namespace


ListsControl Constructor

Initializes a new instance of the ListsControl class.

public ListsControl();

See Also

ListsControl Class | Aptify.Framework.Archive Namespace


ListsControl Properties

The properties of the ListsControl class are listed below. For a complete list of ListsControl class members, see the ListsControl Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ArchiveSelectionSQL | Property indicating the selection criterion to be used by the archive run.
ArchiveSelectionText | Property indicating a selection description for the criterion used by the archive run.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

ListsControl Class | Aptify.Framework.Archive Namespace


ArchiveSelectionSQL Property

Aptify 5.0 Software Development Kit (SDK)

ListsControl.ArchiveSelectionSQL Property

Property indicating the selection criterion to be used by the archive run.

public String ArchiveSelectionSQL {get;}

Property Value

Returns a string containing the SWL statement to be used by the archive process.

Implements

IAptifyArchiveGUI.

Remarks

Refer to the IAptifyArchiveGUI interface for more information.

See Also

ListsControl Class | Aptify.Framework.Archive Namespace


ArchiveSelectionText Property

Aptify 5.0 Software Development Kit (SDK)

ListsControl.ArchiveSelectionText Property

Property indicating a selection description for the criterion used by the archive run.

public String ArchiveSelectionText {get;}

Property Value

Returns a string with the description.

Implements

IAptifyArchiveGUI.

Remarks

Refer to the IAptifyArchiveGUI interface for more information.

See Also

ListsControl Class | Aptify.Framework.Archive Namespace


ListsControl Methods

The methods of the ListsControl class are listed below. For a complete list of ListsControl class members, see the ListsControl Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config | Method used to configure the selection control for use.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ListsControl Class | Aptify.Framework.Archive Namespace


ListsControl.Config Method

Method used to configure the selection control for use.

public bool Config(
ref AptifyGenericEntityBase& oArchiveRunGE
);

Parameters

oArchiveRunGE
ByRef parameter used to provide access to the current GE record.

Return Value

Returns TRUE if the object was configured properly.

Implements

IAptifyArchiveGUI.

Remarks

Refer to the IAptifyArchiveGUI interface for more information.

See Also

ListsControl Class | Aptify.Framework.Archive Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

ListsControl.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

ListsControl Class | Aptify.Framework.Archive Namespace


ListsControl.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

ListsControl Class | Aptify.Framework.Archive Namespace | ListsControl.Dispose Overload List


RecordHistory Class

The lists class inherits from ArchiveRecordBase. It is designed to handle the archival of Record History (EntityRecordVersions) records. It is an approved plugin which is driven by the archival process.

For a list of all members of this type, see RecordHistory Members.

System.Object
ArchiveRecordBase
RecordHistory

public class RecordHistory : ArchiveRecordBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.Archive

Assembly: AptifyArchive (in AptifyArchive.dll)

See Also

RecordHistory Members | Aptify.Framework.Archive Namespace


RecordHistory Members

RecordHistory overview

Public Instance Constructors

RecordHistory Constructor Initializes a new instance of the RecordHistory class.

Public Instance Properties

LastMessage (inherited from ArchiveRecordBase) | String parameter used to retrieve error messages from the object.
SupportedOperations | Property that indicates the functionality supported by any of the plugin components.

Public Instance Methods

Config | Method used to intialize the record history object for use.
CreateTables | Method used to create the SQL tables utilized for storing the archived lists data.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute | Method used to execute the archive of list records.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ResetCounts | Record History-specific method used to clear the counters used within the component.
ToString (inherited from Object) | Returns a String that represents the current Object.
Validate (inherited from ArchiveRecordBase) | Validation provided in the Archive Record Base class validates the presence of appropriate connection parameters.

Protected Instance Fields

m_arSupportedOperations (inherited from ArchiveRecordBase)
m_bShowErrors (inherited from ArchiveRecordBase)
m_bTestRun (inherited from ArchiveRecordBase)
m_connDestination (inherited from ArchiveRecordBase)
m_DSAction (inherited from ArchiveRecordBase)
m_iArchiveTypeID (inherited from ArchiveRecordBase)
m_iDestinationStatementCount (inherited from ArchiveRecordBase)
m_iSourceStatementCount (inherited from ArchiveRecordBase)
m_oApplication (inherited from ArchiveRecordBase)
m_oArchiveRun (inherited from ArchiveRecordBase)
m_oArchiveRunGE (inherited from ArchiveRecordBase)
m_oArchiveTables (inherited from ArchiveRecordBase)
m_oUserCredentials (inherited from ArchiveRecordBase)
m_sConnString (inherited from ArchiveRecordBase)
m_sDestinationBatchStatement (inherited from ArchiveRecordBase)
m_sLastMessage (inherited from ArchiveRecordBase)
m_sSourceBatchStatement (inherited from ArchiveRecordBase)

Protected Instance Methods

AddDestinationBatchStatement (inherited from ArchiveRecordBase) | Function used to add a SQL statement to the batch to be sent to the destination server.
AddSourceBatchStatement (inherited from ArchiveRecordBase) | Function used to add a SQL statement to the batch to be sent to the source server.
AddStatus (inherited from ArchiveRecordBase) | Internal function used to report status via the object event model.
AddTable (inherited from ArchiveRecordBase) | This function is used to create ArchiveTable objects and add them to the array list.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetConnectionString (inherited from ArchiveRecordBase) | Function that creates a connection string, based on the parameters. Will create a connection string for trusted and untrusted connections.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OpenConnection (inherited from ArchiveRecordBase) | Function that opens a connection to the database. Is used primarily to create a connection to the target database.

Protected Instance Events

BatchComplete (inherited from ArchiveRecordBase)
BatchStarted (inherited from ArchiveRecordBase)
CriticalError (inherited from ArchiveRecordBase)
IncidentalError (inherited from ArchiveRecordBase)
RunCompleted (inherited from ArchiveRecordBase)
RunStarted (inherited from ArchiveRecordBase)
UpdateStatus (inherited from ArchiveRecordBase)

See Also

RecordHistory Class | Aptify.Framework.Archive Namespace


RecordHistory Constructor

Initializes a new instance of the RecordHistory class.

public RecordHistory();

See Also

RecordHistory Class | Aptify.Framework.Archive Namespace


RecordHistory Properties

The properties of the RecordHistory class are listed below. For a complete list of RecordHistory class members, see the RecordHistory Members topic.

Public Instance Properties

LastMessage (inherited from ArchiveRecordBase) | String parameter used to retrieve error messages from the object.
SupportedOperations | Property that indicates the functionality supported by any of the plugin components.

See Also

RecordHistory Class | Aptify.Framework.Archive Namespace


SupportedOperations Property

Aptify 5.0 Software Development Kit (SDK)

RecordHistory.SupportedOperations Property

Property that indicates the functionality supported by any of the plugin components.

public override IAptifyArchiveRecords.arOperations SupportedOperations {get;}

Property Value

The value returned indicates the the available operations. The interface definition contains more detailed information on how to implemente this property.

Implements

IAptifyArchiveRecords.

Remarks

See Also

RecordHistory Class | Aptify.Framework.Archive Namespace


RecordHistory Methods

The methods of the RecordHistory class are listed below. For a complete list of RecordHistory class members, see the RecordHistory Members topic.

Public Instance Methods

Config | Method used to intialize the record history object for use.
CreateTables | Method used to create the SQL tables utilized for storing the archived lists data.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute | Method used to execute the archive of list records.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ResetCounts | Record History-specific method used to clear the counters used within the component.
ToString (inherited from Object) | Returns a String that represents the current Object.
Validate (inherited from ArchiveRecordBase) | Validation provided in the Archive Record Base class validates the presence of appropriate connection parameters.

Protected Instance Methods

AddDestinationBatchStatement (inherited from ArchiveRecordBase) | Function used to add a SQL statement to the batch to be sent to the destination server.
AddSourceBatchStatement (inherited from ArchiveRecordBase) | Function used to add a SQL statement to the batch to be sent to the source server.
AddStatus (inherited from ArchiveRecordBase) | Internal function used to report status via the object event model.
AddTable (inherited from ArchiveRecordBase) | This function is used to create ArchiveTable objects and add them to the array list.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetConnectionString (inherited from ArchiveRecordBase) | Function that creates a connection string, based on the parameters. Will create a connection string for trusted and untrusted connections.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OpenConnection (inherited from ArchiveRecordBase) | Function that opens a connection to the database. Is used primarily to create a connection to the target database.

See Also

RecordHistory Class | Aptify.Framework.Archive Namespace


RecordHistory.Config Method

Method used to intialize the record history object for use.

public override bool Config(
ref AptifyGenericEntityBase& oArchiveRunGE
);

Parameters

oArchiveRunGE
ByRef parameter passed in to present the Lists object with access to the data of the Archive Run.

Return Value

Returns TRUE if initialization succeded and FALSE if not.

Implements

IAptifyArchiveRecords.

Remarks

See Also

RecordHistory Class | Aptify.Framework.Archive Namespace


RecordHistory.CreateTables Method

Method used to create the SQL tables utilized for storing the archived lists data.

public override bool CreateTables();

Return Value

Returns TRUE if the tables are created correctly.

Remarks

See Also

RecordHistory Class | Aptify.Framework.Archive Namespace


RecordHistory.Execute Method

Method used to execute the archive of list records.

public override bool Execute(
String sSelectionSQL,
Boolean bCreateTables,
Boolean bSingleTransaction,
Int64 lBatchSize,
Boolean bTestRun,
Boolean bShowGUI
);

Parameters

sSelectionSQL
SQL Statement representing the list records to archive. The critical element of this SQL Statement is the where clause as it determines the scope of records to be archived.
bCreateTables
Boolean parameter indicating when or not the component should attempt to create the archive tables, if they do not already exist.
bSingleTransaction
Boolean parameter indicating whether or not the archive operation should be transacted within a single transaction boundary.
lBatchSize
The number of records to include in each batch.
bTestRun
Boolean indicating if this execution is for test purposes or not.
bShowGUI
Boolean indicating if a User Interface should be used to display the status during the execution.

Return Value

TRUE is returned if the Execute method succeeds or not.

Implements

IAptifyArchiveRecords.

Remarks

See Also

RecordHistory Class | Aptify.Framework.Archive Namespace


RecordHistory.ResetCounts Method

Record History-specific method used to clear the counters used within the component.

public override void ResetCounts();

Implements

IAptifyArchiveRecords.

Remarks

See Also

RecordHistory Class | Aptify.Framework.Archive Namespace


RecordHistoryControl Class

The Record History Control is used to provide functionality to assist the user with forming the selection criterion for use in the archive run.

For a list of all members of this type, see RecordHistoryControl Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
RecordHistoryControl

public class RecordHistoryControl : UserControl, IAptifyArchiveGUI

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Refer to the IAptifyArchiveGUI interface for more information.

Requirements

Namespace: Aptify.Framework.Archive

Assembly: AptifyArchive (in AptifyArchive.dll)

See Also

RecordHistoryControl Members | Aptify.Framework.Archive Namespace


RecordHistoryControl Members

RecordHistoryControl overview

Public Instance Constructors

RecordHistoryControl Constructor Initializes a new instance of the RecordHistoryControl class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ArchiveSelectionSQL | Property exposing the Selection SQL to be use to define the scope of the record history to be included in the Archive Run.
ArchiveSelectionText | Property exposing a description of the selection criteria.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config | Method used to configure the record history control for use.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

RecordHistoryControl Class | Aptify.Framework.Archive Namespace


RecordHistoryControl Constructor

Initializes a new instance of the RecordHistoryControl class.

public RecordHistoryControl();

See Also

RecordHistoryControl Class | Aptify.Framework.Archive Namespace


RecordHistoryControl Properties

The properties of the RecordHistoryControl class are listed below. For a complete list of RecordHistoryControl class members, see the RecordHistoryControl Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ArchiveSelectionSQL | Property exposing the Selection SQL to be use to define the scope of the record history to be included in the Archive Run.
ArchiveSelectionText | Property exposing a description of the selection criteria.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

RecordHistoryControl Class | Aptify.Framework.Archive Namespace


ArchiveSelectionSQL Property

Aptify 5.0 Software Development Kit (SDK)

RecordHistoryControl.ArchiveSelectionSQL Property

Property exposing the Selection SQL to be use to define the scope of the record history to be included in the Archive Run.

public String ArchiveSelectionSQL {get;}

Property Value

Returns selection criteria.

Implements

IAptifyArchiveGUI.

Remarks

ByRef parameter used to provide access to the current GE record.

See Also

RecordHistoryControl Class | Aptify.Framework.Archive Namespace


ArchiveSelectionText Property

Aptify 5.0 Software Development Kit (SDK)

RecordHistoryControl.ArchiveSelectionText Property

Property exposing a description of the selection criteria.

public String ArchiveSelectionText {get;}

Property Value

Returns a textual description.

Implements

IAptifyArchiveGUI.

Remarks

ByRef parameter used to provide access to the current GE record.

See Also

RecordHistoryControl Class | Aptify.Framework.Archive Namespace


RecordHistoryControl Methods

The methods of the RecordHistoryControl class are listed below. For a complete list of RecordHistoryControl class members, see the RecordHistoryControl Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config | Method used to configure the record history control for use.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

RecordHistoryControl Class | Aptify.Framework.Archive Namespace


RecordHistoryControl.Config Method

Method used to configure the record history control for use.

public bool Config(
ref AptifyGenericEntityBase& oArchiveRunGE
);

Parameters

oArchiveRunGE
ByRef parameter used to provide access to the current GE record.

Return Value

Returns TRUE if the control is properly configured.

Implements

IAptifyArchiveGUI.

Remarks

Refer to the IAptifyArchiveGUI interface for more information.

See Also

RecordHistoryControl Class | Aptify.Framework.Archive Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

RecordHistoryControl.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

RecordHistoryControl Class | Aptify.Framework.Archive Namespace


RecordHistoryControl.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

RecordHistoryControl Class | Aptify.Framework.Archive Namespace | RecordHistoryControl.Dispose Overload List


Aptify.Framework.AttributeManagement

Aptify 5.0 Software Development Kit (SDK)

Aptify.Framework.AttributeManagement Namespace

This namespace contains classes that are responsible for creating, retrieving, and changing code level custom attributes.

Namespace hierarchy

Classes

Class | Description
AppConfigAttributeSource |
Attribute |
AttributeManager |
AttributeManagerSectionHandler |
AttributeManagerSettings |
AttributeSourceSettings |
AttributeValue |
AvailableInAttributeViewerAttribute |
Constants |
DatabaseAttributeSource |
XMLAttributeSource |

Enumerations

Enumeration | Description
AttributeManagementMode |
AttributeValueState |


AppConfigAttributeSource Class

For a list of all members of this type, see AppConfigAttributeSource Members.

System.Object
AppConfigAttributeSource

public class AppConfigAttributeSource : IAttributeSourceReader

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.AttributeManagement

Assembly: AptifyAttributeManagement (in AptifyAttributeManagement.dll)

See Also

AppConfigAttributeSource Members | Aptify.Framework.AttributeManagement Namespace


AppConfigAttributeSource Members

AppConfigAttributeSource overview

Public Instance Constructors

AppConfigAttributeSource Constructor Initializes a new instance of the AppConfigAttributeSource class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAttributeValue | Overloaded.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AppConfigAttributeSource Class | Aptify.Framework.AttributeManagement Namespace


AppConfigAttributeSource Constructor

Initializes a new instance of the AppConfigAttributeSource class.

public AppConfigAttributeSource();

See Also

AppConfigAttributeSource Class | Aptify.Framework.AttributeManagement Namespace


AppConfigAttributeSource Methods

The methods of the AppConfigAttributeSource class are listed below. For a complete list of AppConfigAttributeSource class members, see the AppConfigAttributeSource Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAttributeValue | Overloaded.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AppConfigAttributeSource Class | Aptify.Framework.AttributeManagement Namespace


GetAttributeValue Method

Aptify 5.0 Software Development Kit (SDK)

AppConfigAttributeSource.GetAttributeValue Method

Overload List

public AttributeValue GetAttributeValue(Attribute,NameValueCollection);

public AttributeValue GetAttributeValue(String,NameValueCollection);

See Also

AppConfigAttributeSource Class | Aptify.Framework.AttributeManagement Namespace


AppConfigAttributeSource.GetAttributeValue Method (Attribute, NameValueCollection)

public AttributeValue GetAttributeValue(
Attribute Attribute,
NameValueCollection ConfigSettings
);

Implements

IAttributeSourceReader.

See Also

AppConfigAttributeSource Class | Aptify.Framework.AttributeManagement Namespace | AppConfigAttributeSource.GetAttributeValue Overload List


AppConfigAttributeSource.GetAttributeValue Method (String, NameValueCollection)

public AttributeValue GetAttributeValue(
String FullName,
NameValueCollection ConfigSettings
);

Implements

IAttributeSourceReader.

See Also

AppConfigAttributeSource Class | Aptify.Framework.AttributeManagement Namespace | AppConfigAttributeSource.GetAttributeValue Overload List


Attribute Class

For a list of all members of this type, see Attribute Members.

System.Object
Attribute
Attribute

public class Attribute : Attribute, IComparable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.AttributeManagement

Assembly: AptifyAttributeManagement (in AptifyAttributeManagement.dll)

See Also

Attribute Members | Aptify.Framework.AttributeManagement Namespace


Attribute Members

Attribute overview

Public Instance Constructors

Attribute Overloaded. Initializes a new instance of the Attribute class.

Public Instance Properties

AttributeValue |
CacheValue |
ContainingType |
DefaultValue |
Description |
Exception |
FullName |
IsPersistable |
IsReadOnly |
Name |
PossibleValues |
ResultType |
TypeId (inherited from Attribute) | When implemented in a derived class, gets a unique identifier for this Attribute.
ValueState |

Public Instance Methods

CompareTo |
Equals (inherited from Attribute) | Returns a value that indicates whether this instance is equal to a specified object.
GetHashCode (inherited from Attribute) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IsDefaultAttribute (inherited from Attribute) | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class.
Match (inherited from Attribute) | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object.
ToString (inherited from Object) | Returns a String that represents the current Object.
Validate | Overloaded.

Protected Instance Constructors

Attribute Overloaded. Initializes a new instance of the Attribute class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetObjectData |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Attribute Class | Aptify.Framework.AttributeManagement Namespace


Attribute Constructor

Overload List

protected Attribute(SerializationInfo,StreamingContext);

public Attribute(Type,String,Type);

See Also

Attribute Class | Aptify.Framework.AttributeManagement Namespace


Attribute Constructor (Type, String, Type)

public Attribute(
Type ContainingType,
String Name,
Type ResultType
);

See Also

Attribute Class | Aptify.Framework.AttributeManagement Namespace | Attribute Constructor Overload List


Attribute Constructor (SerializationInfo, StreamingContext)

protected Attribute(
SerializationInfo Info,
StreamingContext Context
);

See Also

Attribute Class | Aptify.Framework.AttributeManagement Namespace | Attribute Constructor Overload List


Attribute Properties

The properties of the Attribute class are listed below. For a complete list of Attribute class members, see the Attribute Members topic.

Public Instance Properties

AttributeValue |
CacheValue |
ContainingType |
DefaultValue |
Description |
Exception |
FullName |
IsPersistable |
IsReadOnly |
Name |
PossibleValues |
ResultType |
TypeId (inherited from Attribute) | When implemented in a derived class, gets a unique identifier for this Attribute.
ValueState |

See Also

Attribute Class | Aptify.Framework.AttributeManagement Namespace


AttributeValue Property

Aptify 5.0 Software Development Kit (SDK)

Attribute.AttributeValue Property

public AttributeValue AttributeValue {get;}

See Also

Attribute Class | Aptify.Framework.AttributeManagement Namespace


CacheValue Property

Aptify 5.0 Software Development Kit (SDK)

Attribute.CacheValue Property

public Boolean CacheValue {get; set;}

See Also

Attribute Class | Aptify.Framework.AttributeManagement Namespace


ContainingType Property

Aptify 5.0 Software Development Kit (SDK)

Attribute.ContainingType Property

public Type ContainingType {get;}

See Also

Attribute Class | Aptify.Framework.AttributeManagement Namespace


DefaultValue Property

Aptify 5.0 Software Development Kit (SDK)

Attribute.DefaultValue Property

public String DefaultValue {get; set;}

See Also

Attribute Class | Aptify.Framework.AttributeManagement Namespace


Description Property

Aptify 5.0 Software Development Kit (SDK)

Attribute.Description Property

public String Description {get; set;}

See Also

Attribute Class | Aptify.Framework.AttributeManagement Namespace


Exception Property

Aptify 5.0 Software Development Kit (SDK)

Attribute.Exception Property

public BaseApplicationException Exception {get;}

See Also

Attribute Class | Aptify.Framework.AttributeManagement Namespace


FullName Property

Aptify 5.0 Software Development Kit (SDK)

Attribute.FullName Property

public String FullName {get;}

See Also

Attribute Class | Aptify.Framework.AttributeManagement Namespace


IsPersistable Property

Aptify 5.0 Software Development Kit (SDK)

Attribute.IsPersistable Property

public Boolean IsPersistable {get;}

See Also

Attribute Class | Aptify.Framework.AttributeManagement Namespace


IsReadOnly Property

Aptify 5.0 Software Development Kit (SDK)

Attribute.IsReadOnly Property

public Boolean IsReadOnly {get; set;}

See Also

Attribute Class | Aptify.Framework.AttributeManagement Namespace


Name Property

Aptify 5.0 Software Development Kit (SDK)

Attribute.Name Property

public String Name {get;}

See Also

Attribute Class | Aptify.Framework.AttributeManagement Namespace


PossibleValues Property

Aptify 5.0 Software Development Kit (SDK)

Attribute.PossibleValues Property

public String PossibleValues {get; set;}

See Also

Attribute Class | Aptify.Framework.AttributeManagement Namespace


ResultType Property

Aptify 5.0 Software Development Kit (SDK)

Attribute.ResultType Property

public Type ResultType {get; set;}

See Also

Attribute Class | Aptify.Framework.AttributeManagement Namespace


ValueState Property

Aptify 5.0 Software Development Kit (SDK)

Attribute.ValueState Property

public AttributeValueState ValueState {get;}

See Also

Attribute Class | Aptify.Framework.AttributeManagement Namespace


Attribute Methods

The methods of the Attribute class are listed below. For a complete list of Attribute class members, see the Attribute Members topic.

Public Instance Methods

CompareTo |
Equals (inherited from Attribute) | Returns a value that indicates whether this instance is equal to a specified object.
GetHashCode (inherited from Attribute) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IsDefaultAttribute (inherited from Attribute) | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class.
Match (inherited from Attribute) | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object.
ToString (inherited from Object) | Returns a String that represents the current Object.
Validate | Overloaded.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetObjectData |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Attribute Class | Aptify.Framework.AttributeManagement Namespace


Attribute.CompareTo Method

public int CompareTo(
Object AptifyAttribute
);

Implements

IComparable.

See Also

Attribute Class | Aptify.Framework.AttributeManagement Namespace


Attribute.GetObjectData Method

protected void GetObjectData(
SerializationInfo Info,
StreamingContext Context
);

See Also

Attribute Class | Aptify.Framework.AttributeManagement Namespace


Validate Method

Aptify 5.0 Software Development Kit (SDK)

Attribute.Validate Method

Overload List

public bool Validate(AttributeValue);

public bool Validate(AttributeValue,IFormatProvider);

See Also

Attribute Class | Aptify.Framework.AttributeManagement Namespace


Attribute.Validate Method (AttributeValue)

public bool Validate(
AttributeValue ValuetoValidate
);

See Also

Attribute Class | Aptify.Framework.AttributeManagement Namespace | Attribute.Validate Overload List


Attribute.Validate Method (AttributeValue, IFormatProvider)

public bool Validate(
AttributeValue ValueToValidate,
IFormatProvider Provider
);

See Also

Attribute Class | Aptify.Framework.AttributeManagement Namespace | Attribute.Validate Overload List


AttributeManagementMode Enumeration

public enum AttributeManagementMode

Members

Member Name | Description
On |
Off |

Requirements

Namespace: Aptify.Framework.AttributeManagement

Assembly: AptifyAttributeManagement (in AptifyAttributeManagement.dll)

See Also

Aptify.Framework.AttributeManagement Namespace


AttributeManager Class

For a list of all members of this type, see AttributeManager Members.

System.Object
AttributeManager

public class AttributeManager

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.AttributeManagement

Assembly: AptifyAttributeManagement (in AptifyAttributeManagement.dll)

See Also

AttributeManager Members | Aptify.Framework.AttributeManagement Namespace


AttributeManager Members

AttributeManager overview

Public Static Properties

Settings

Public Static Methods

ClearCache |
GetAttribute |
GetAttributeValue | Overloaded.
OverrideInMemoryAttributeValue | Overloaded.
PersistAttributeValue | Overloaded.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AttributeManager Class | Aptify.Framework.AttributeManagement Namespace


AttributeManager Properties

The properties of the AttributeManager class are listed below. For a complete list of AttributeManager class members, see the AttributeManager Members topic.

Public Static Properties

Settings

See Also

AttributeManager Class | Aptify.Framework.AttributeManagement Namespace


Settings Property

Aptify 5.0 Software Development Kit (SDK)

AttributeManager.Settings Property

public static AttributeManagerSettings Settings {get;}

See Also

AttributeManager Class | Aptify.Framework.AttributeManagement Namespace


AttributeManager Methods

The methods of the AttributeManager class are listed below. For a complete list of AttributeManager class members, see the AttributeManager Members topic.

Public Static Methods

ClearCache |
GetAttribute |
GetAttributeValue | Overloaded.
OverrideInMemoryAttributeValue | Overloaded.
PersistAttributeValue | Overloaded.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AttributeManager Class | Aptify.Framework.AttributeManagement Namespace


AttributeManager.ClearCache Method

public static void ClearCache();

See Also

AttributeManager Class | Aptify.Framework.AttributeManagement Namespace


AttributeManager.GetAttribute Method

public static Attribute GetAttribute(
Type ContainingType,
String Name
);

See Also

AttributeManager Class | Aptify.Framework.AttributeManagement Namespace


GetAttributeValue Method

Aptify 5.0 Software Development Kit (SDK)

AttributeManager.GetAttributeValue Method

Overload List

public static AttributeValue GetAttributeValue(Attribute);

public static AttributeValue GetAttributeValue(String);

public static AttributeValue GetAttributeValue(String,Boolean);

See Also

AttributeManager Class | Aptify.Framework.AttributeManagement Namespace


AttributeManager.GetAttributeValue Method (Attribute)

public static AttributeValue GetAttributeValue(
Attribute Attribute
);

See Also

AttributeManager Class | Aptify.Framework.AttributeManagement Namespace | AttributeManager.GetAttributeValue Overload List


AttributeManager.GetAttributeValue Method (String)

public static AttributeValue GetAttributeValue(
String FullName
);

See Also

AttributeManager Class | Aptify.Framework.AttributeManagement Namespace | AttributeManager.GetAttributeValue Overload List


AttributeManager.GetAttributeValue Method (String, Boolean)

public static AttributeValue GetAttributeValue(
String FullName,
Boolean UseCache
);

See Also

AttributeManager Class | Aptify.Framework.AttributeManagement Namespace | AttributeManager.GetAttributeValue Overload List


OverrideInMemoryAttributeValue Method

Aptify 5.0 Software Development Kit (SDK)

AttributeManager.OverrideInMemoryAttributeValue Method

Overload List

public static void OverrideInMemoryAttributeValue(Attribute,IConvertible,Type);

public static void OverrideInMemoryAttributeValue(String,IConvertible,Type);

See Also

AttributeManager Class | Aptify.Framework.AttributeManagement Namespace


AttributeManager.OverrideInMemoryAttributeValue Method (Attribute, IConvertible, Type)

public static void OverrideInMemoryAttributeValue(
Attribute Attribute,
IConvertible Value,
Type SettingType
);

See Also

AttributeManager Class | Aptify.Framework.AttributeManagement Namespace | AttributeManager.OverrideInMemoryAttributeValue Overload List


AttributeManager.OverrideInMemoryAttributeValue Method (String, IConvertible, Type)

public static void OverrideInMemoryAttributeValue(
String FullName,
IConvertible Value,
Type SettingType
);

See Also

AttributeManager Class | Aptify.Framework.AttributeManagement Namespace | AttributeManager.OverrideInMemoryAttributeValue Overload List


PersistAttributeValue Method

Aptify 5.0 Software Development Kit (SDK)

AttributeManager.PersistAttributeValue Method

Overload List

public static AttributeValue PersistAttributeValue(Attribute,IConvertible);

public static AttributeValue PersistAttributeValue(Type,String,IConvertible);

See Also

AttributeManager Class | Aptify.Framework.AttributeManagement Namespace


AttributeManager.PersistAttributeValue Method (Attribute, IConvertible)

public static AttributeValue PersistAttributeValue(
Attribute Attribute,
IConvertible NewValue
);

See Also

AttributeManager Class | Aptify.Framework.AttributeManagement Namespace | AttributeManager.PersistAttributeValue Overload List


AttributeManager.PersistAttributeValue Method (Type, String, IConvertible)

public static AttributeValue PersistAttributeValue(
Type ContainingType,
String Name,
IConvertible NewValue
);

See Also

AttributeManager Class | Aptify.Framework.AttributeManagement Namespace | AttributeManager.PersistAttributeValue Overload List


AttributeManagerSectionHandler Class

For a list of all members of this type, see AttributeManagerSectionHandler Members.

System.Object
AttributeManagerSectionHandler

public class AttributeManagerSectionHandler : IConfigurationSectionHandler

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.AttributeManagement

Assembly: AptifyAttributeManagement (in AptifyAttributeManagement.dll)

See Also

AttributeManagerSectionHandler Members | Aptify.Framework.AttributeManagement Namespace


AttributeManagerSectionHandler Members

AttributeManagerSectionHandler overview

Public Static Fields

CONFIGURATION_EXCEPTION_SEVERITY_DEFUALT
DEFAULT_NAME_DELIMITER
INVALID_ATTRIBUTEVALUE_TYPE_SEVERITY_DEFAULT
NOT_FOUND_SEVERITY_DEFUALT
READ_ONLY_SEVERITY_DEFAULT

Public Instance Constructors

AttributeManagerSectionHandler Constructor Initializes a new instance of the AttributeManagerSectionHandler class.

Public Instance Methods

Create |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AttributeManagerSectionHandler Class | Aptify.Framework.AttributeManagement Namespace


AttributeManagerSectionHandler Constructor

Initializes a new instance of the AttributeManagerSectionHandler class.

public AttributeManagerSectionHandler();

See Also

AttributeManagerSectionHandler Class | Aptify.Framework.AttributeManagement Namespace


AttributeManagerSectionHandler Fields

The fields of the AttributeManagerSectionHandler class are listed below. For a complete list of AttributeManagerSectionHandler class members, see the AttributeManagerSectionHandler Members topic.

Public Static Fields

CONFIGURATION_EXCEPTION_SEVERITY_DEFUALT
DEFAULT_NAME_DELIMITER
INVALID_ATTRIBUTEVALUE_TYPE_SEVERITY_DEFAULT
NOT_FOUND_SEVERITY_DEFUALT
READ_ONLY_SEVERITY_DEFAULT

See Also

AttributeManagerSectionHandler Class | Aptify.Framework.AttributeManagement Namespace


AttributeManagerSectionHandler.CONFIGURATION_EXCEPTION_SEVERITY_DEFUALT Field

public const CONFIGURATION_EXCEPTION_SEVERITY_DEFUALT CONFIGURATION_EXCEPTION_SEVERITY_DEFUALT = 50;

See Also

AttributeManagerSectionHandler Class | Aptify.Framework.AttributeManagement Namespace


AttributeManagerSectionHandler.DEFAULT_NAME_DELIMITER Field

public const DEFAULT_NAME_DELIMITER DEFAULT_NAME_DELIMITER = ".";

See Also

AttributeManagerSectionHandler Class | Aptify.Framework.AttributeManagement Namespace


AttributeManagerSectionHandler.INVALID_ATTRIBUTEVALUE_TYPE_SEVERITY_DEFAULT Field

public const INVALID_ATTRIBUTEVALUE_TYPE_SEVERITY_DEFAULT INVALID_ATTRIBUTEVALUE_TYPE_SEVERITY_DEFAULT = 50;

See Also

AttributeManagerSectionHandler Class | Aptify.Framework.AttributeManagement Namespace


AttributeManagerSectionHandler.NOT_FOUND_SEVERITY_DEFUALT Field

public const NOT_FOUND_SEVERITY_DEFUALT NOT_FOUND_SEVERITY_DEFUALT = 50;

See Also

AttributeManagerSectionHandler Class | Aptify.Framework.AttributeManagement Namespace


AttributeManagerSectionHandler.READ_ONLY_SEVERITY_DEFAULT Field

public const READ_ONLY_SEVERITY_DEFAULT READ_ONLY_SEVERITY_DEFAULT = 50;

See Also

AttributeManagerSectionHandler Class | Aptify.Framework.AttributeManagement Namespace


AttributeManagerSectionHandler Methods

The methods of the AttributeManagerSectionHandler class are listed below. For a complete list of AttributeManagerSectionHandler class members, see the AttributeManagerSectionHandler Members topic.

Public Instance Methods

Create |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AttributeManagerSectionHandler Class | Aptify.Framework.AttributeManagement Namespace


AttributeManagerSectionHandler.Create Method

public virtual object Create(
Object parent,
Object configContext,
XmlNode section
);

Implements

IConfigurationSectionHandler.

See Also

AttributeManagerSectionHandler Class | Aptify.Framework.AttributeManagement Namespace


AttributeManagerSettings Class

For a list of all members of this type, see AttributeManagerSettings Members.

System.Object
AttributeManagerSettings

public class AttributeManagerSettings

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.AttributeManagement

Assembly: AptifyAttributeManagement (in AptifyAttributeManagement.dll)

See Also

AttributeManagerSettings Members | Aptify.Framework.AttributeManagement Namespace


AttributeManagerSettings Members

AttributeManagerSettings overview

Public Instance Constructors

AttributeManagerSettings Constructor Initializes a new instance of the AttributeManagerSettings class.

Public Instance Properties

AttributeSourceSettings
ConfigurationExceptionSeverity
InvalidAttributeValueTypeSeverity
Mode
NameDelimiter
ReadOnlyExceptionSeverity
ValueNotFoundSeverity

Public Instance Methods

AddAttributeSourceSettings |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AttributeManagerSettings Class | Aptify.Framework.AttributeManagement Namespace


AttributeManagerSettings Constructor

Initializes a new instance of the AttributeManagerSettings class.

public AttributeManagerSettings();

See Also

AttributeManagerSettings Class | Aptify.Framework.AttributeManagement Namespace


AttributeManagerSettings Properties

The properties of the AttributeManagerSettings class are listed below. For a complete list of AttributeManagerSettings class members, see the AttributeManagerSettings Members topic.

Public Instance Properties

AttributeSourceSettings
ConfigurationExceptionSeverity
InvalidAttributeValueTypeSeverity
Mode
NameDelimiter
ReadOnlyExceptionSeverity
ValueNotFoundSeverity

See Also

AttributeManagerSettings Class | Aptify.Framework.AttributeManagement Namespace


AttributeSourceSettings Property

Aptify 5.0 Software Development Kit (SDK)

AttributeManagerSettings.AttributeSourceSettings Property

public ArrayList AttributeSourceSettings {get;}

See Also

AttributeManagerSettings Class | Aptify.Framework.AttributeManagement Namespace


ConfigurationExceptionSeverity Property

Aptify 5.0 Software Development Kit (SDK)

AttributeManagerSettings.ConfigurationExceptionSeverity Property

public Int32 ConfigurationExceptionSeverity {get; set;}

See Also

AttributeManagerSettings Class | Aptify.Framework.AttributeManagement Namespace


InvalidAttributeValueTypeSeverity Property

Aptify 5.0 Software Development Kit (SDK)

AttributeManagerSettings.InvalidAttributeValueTypeSeverity Property

public Int32 InvalidAttributeValueTypeSeverity {get; set;}

See Also

AttributeManagerSettings Class | Aptify.Framework.AttributeManagement Namespace


Mode Property

Aptify 5.0 Software Development Kit (SDK)

AttributeManagerSettings.Mode Property

public AttributeManagementMode Mode {get; set;}

See Also

AttributeManagerSettings Class | Aptify.Framework.AttributeManagement Namespace


NameDelimiter Property

Aptify 5.0 Software Development Kit (SDK)

AttributeManagerSettings.NameDelimiter Property

public String NameDelimiter {get; set;}

See Also

AttributeManagerSettings Class | Aptify.Framework.AttributeManagement Namespace


ReadOnlyExceptionSeverity Property

Aptify 5.0 Software Development Kit (SDK)

AttributeManagerSettings.ReadOnlyExceptionSeverity Property

public Int32 ReadOnlyExceptionSeverity {get; set;}

See Also

AttributeManagerSettings Class | Aptify.Framework.AttributeManagement Namespace


ValueNotFoundSeverity Property

Aptify 5.0 Software Development Kit (SDK)

AttributeManagerSettings.ValueNotFoundSeverity Property

public Int32 ValueNotFoundSeverity {get; set;}

See Also

AttributeManagerSettings Class | Aptify.Framework.AttributeManagement Namespace


AttributeManagerSettings Methods

The methods of the AttributeManagerSettings class are listed below. For a complete list of AttributeManagerSettings class members, see the AttributeManagerSettings Members topic.

Public Instance Methods

AddAttributeSourceSettings |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AttributeManagerSettings Class | Aptify.Framework.AttributeManagement Namespace


AttributeManagerSettings.AddAttributeSourceSettings Method

public void AddAttributeSourceSettings(
AttributeSourceSettings NewSource
);

See Also

AttributeManagerSettings Class | Aptify.Framework.AttributeManagement Namespace


AttributeSourceSettings Class

For a list of all members of this type, see AttributeSourceSettings Members.

System.Object
AttributeSourceSettings

public class AttributeSourceSettings

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.AttributeManagement

Assembly: AptifyAttributeManagement (in AptifyAttributeManagement.dll)

See Also

AttributeSourceSettings Members | Aptify.Framework.AttributeManagement Namespace


AttributeSourceSettings Members

AttributeSourceSettings overview

Public Instance Constructors

AttributeSourceSettings Constructor Initializes a new instance of the AttributeSourceSettings class.

Public Instance Properties

AssemblyName
Mode
OtherAttributes
TypeName

Public Instance Methods

AddOtherAttributes |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AttributeSourceSettings Class | Aptify.Framework.AttributeManagement Namespace


AttributeSourceSettings Constructor

Initializes a new instance of the AttributeSourceSettings class.

public AttributeSourceSettings();

See Also

AttributeSourceSettings Class | Aptify.Framework.AttributeManagement Namespace


AttributeSourceSettings Properties

The properties of the AttributeSourceSettings class are listed below. For a complete list of AttributeSourceSettings class members, see the AttributeSourceSettings Members topic.

Public Instance Properties

AssemblyName
Mode
OtherAttributes
TypeName

See Also

AttributeSourceSettings Class | Aptify.Framework.AttributeManagement Namespace


AssemblyName Property

Aptify 5.0 Software Development Kit (SDK)

AttributeSourceSettings.AssemblyName Property

public String AssemblyName {get; set;}

See Also

AttributeSourceSettings Class | Aptify.Framework.AttributeManagement Namespace


Mode Property

Aptify 5.0 Software Development Kit (SDK)

AttributeSourceSettings.Mode Property

public AttributeManagementMode Mode {get; set;}

See Also

AttributeSourceSettings Class | Aptify.Framework.AttributeManagement Namespace


OtherAttributes Property

Aptify 5.0 Software Development Kit (SDK)

AttributeSourceSettings.OtherAttributes Property

public NameValueCollection OtherAttributes {get;}

See Also

AttributeSourceSettings Class | Aptify.Framework.AttributeManagement Namespace


TypeName Property

Aptify 5.0 Software Development Kit (SDK)

AttributeSourceSettings.TypeName Property

public String TypeName {get; set;}

See Also

AttributeSourceSettings Class | Aptify.Framework.AttributeManagement Namespace


AttributeSourceSettings Methods

The methods of the AttributeSourceSettings class are listed below. For a complete list of AttributeSourceSettings class members, see the AttributeSourceSettings Members topic.

Public Instance Methods

AddOtherAttributes |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AttributeSourceSettings Class | Aptify.Framework.AttributeManagement Namespace


AttributeSourceSettings.AddOtherAttributes Method

public void AddOtherAttributes(
String Name,
String Value
);

See Also

AttributeSourceSettings Class | Aptify.Framework.AttributeManagement Namespace


AttributeValue Class

For a list of all members of this type, see AttributeValue Members.

System.Object
AttributeValue

public class AttributeValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.AttributeManagement

Assembly: AptifyAttributeManagement (in AptifyAttributeManagement.dll)

See Also

AttributeValue Members | Aptify.Framework.AttributeManagement Namespace


AttributeValue Members

AttributeValue overview

Public Instance Constructors

AttributeValue Overloaded. Initializes a new instance of the AttributeValue class.

Public Instance Properties

IsPersistable
Name
RetrievedBy
TimeStamp
Value

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

Protected Instance Constructors

AttributeValue Overloaded. Initializes a new instance of the AttributeValue class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetObjectData |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AttributeValue Class | Aptify.Framework.AttributeManagement Namespace


AttributeValue Constructor

Overload List

protected AttributeValue(SerializationInfo,StreamingContext);

public AttributeValue(String,IConvertible,Type);

See Also

AttributeValue Class | Aptify.Framework.AttributeManagement Namespace


AttributeValue Constructor (SerializationInfo, StreamingContext)

protected AttributeValue(
SerializationInfo Info,
StreamingContext Context
);

See Also

AttributeValue Class | Aptify.Framework.AttributeManagement Namespace | AttributeValue Constructor Overload List


AttributeValue Constructor (String, IConvertible, Type)

public AttributeValue(
String Name,
IConvertible Value,
Type RetrievedBy
);

See Also

AttributeValue Class | Aptify.Framework.AttributeManagement Namespace | AttributeValue Constructor Overload List


AttributeValue Properties

The properties of the AttributeValue class are listed below. For a complete list of AttributeValue class members, see the AttributeValue Members topic.

Public Instance Properties

IsPersistable
Name
RetrievedBy
TimeStamp
Value

See Also

AttributeValue Class | Aptify.Framework.AttributeManagement Namespace


IsPersistable Property

Aptify 5.0 Software Development Kit (SDK)

AttributeValue.IsPersistable Property

public Boolean IsPersistable {get;}

See Also

AttributeValue Class | Aptify.Framework.AttributeManagement Namespace


Name Property

Aptify 5.0 Software Development Kit (SDK)

AttributeValue.Name Property

public String Name {get;}

See Also

AttributeValue Class | Aptify.Framework.AttributeManagement Namespace


RetrievedBy Property

Aptify 5.0 Software Development Kit (SDK)

AttributeValue.RetrievedBy Property

public Type RetrievedBy {get;}

See Also

AttributeValue Class | Aptify.Framework.AttributeManagement Namespace


TimeStamp Property

Aptify 5.0 Software Development Kit (SDK)

AttributeValue.TimeStamp Property

public DateTime TimeStamp {get;}

See Also

AttributeValue Class | Aptify.Framework.AttributeManagement Namespace


Value Property

Aptify 5.0 Software Development Kit (SDK)

AttributeValue.Value Property

public IConvertible Value {get;}

See Also

AttributeValue Class | Aptify.Framework.AttributeManagement Namespace


AttributeValue Methods

The methods of the AttributeValue class are listed below. For a complete list of AttributeValue class members, see the AttributeValue Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetObjectData |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AttributeValue Class | Aptify.Framework.AttributeManagement Namespace


AttributeValue.GetObjectData Method

protected void GetObjectData(
SerializationInfo Info,
StreamingContext Context
);

See Also

AttributeValue Class | Aptify.Framework.AttributeManagement Namespace


AttributeValue.ToString Method

new public string ToString();

See Also

AttributeValue Class | Aptify.Framework.AttributeManagement Namespace


AttributeValueState Enumeration

public enum AttributeValueState

Members

Member Name | Description
NoGetAttempted |
Retrieved |
Overriden |
UsingDefault |
ExceptionOccured |

Requirements

Namespace: Aptify.Framework.AttributeManagement

Assembly: AptifyAttributeManagement (in AptifyAttributeManagement.dll)

See Also

Aptify.Framework.AttributeManagement Namespace


AvailableInAttributeViewerAttribute Class

For a list of all members of this type, see AvailableInAttributeViewerAttribute Members.

System.Object
Attribute
AvailableInAttributeViewerAttribute

public class AvailableInAttributeViewerAttribute : Attribute

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.AttributeManagement

Assembly: AptifyAttributeManagement (in AptifyAttributeManagement.dll)

See Also

AvailableInAttributeViewerAttribute Members | Aptify.Framework.AttributeManagement Namespace


AvailableInAttributeViewerAttribute Members

AvailableInAttributeViewerAttribute overview

Public Instance Constructors

AvailableInAttributeViewerAttribute Constructor Initializes a new instance of the AvailableInAttributeViewerAttribute class.

Public Instance Properties

TypeId (inherited from Attribute) When implemented in a derived class, gets a unique identifier for this Attribute.

Public Instance Methods

Equals (inherited from Attribute) | Returns a value that indicates whether this instance is equal to a specified object.
GetHashCode (inherited from Attribute) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IsDefaultAttribute (inherited from Attribute) | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class.
Match (inherited from Attribute) | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AvailableInAttributeViewerAttribute Class | Aptify.Framework.AttributeManagement Namespace


AvailableInAttributeViewerAttribute Constructor

Initializes a new instance of the AvailableInAttributeViewerAttribute class.

public AvailableInAttributeViewerAttribute();

See Also

AvailableInAttributeViewerAttribute Class | Aptify.Framework.AttributeManagement Namespace


Constants Class

For a list of all members of this type, see Constants Members.

System.Object
Constants

public class Constants

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.AttributeManagement

Assembly: AptifyAttributeManagement (in AptifyAttributeManagement.dll)

See Also

Constants Members | Aptify.Framework.AttributeManagement Namespace


Constants Members

Constants overview

Public Static Fields

ATTRIBUTE_MANAGER_CONFIGURATION_EXCEPTION_MESSAGE
ATTRIBUTE_NOT_AN_INTEGER_EXCEPTION_MESSAGE
ATTRIBUTE_NOT_FOUND_EXCEPTION_MESSAGE
ATTRIBUTE_NOT_ICONVERTIBLE_EXCEPTION_MESSAGE
COMPARABLE_ARGUMENT_INVALID_TYPE_EXCEPTION_MESSAGE
DATABASE_ATTRIBUTE_EXCEPTION
INVALID_ATTRIBUTE_VALUE_TYPE_EXCEPTION_MESSAGE
READ_ONLY_ATTRIBUTE_VALUE_EXCEPTION_MESSAGE
RESOURCE_FILE_NAME
XML_ATTRIBUTE_SOURCE_FILE_NAME
XML_ATTRIBUTE_SOURCE_FILE_NAME_DEFAULT_VALUE

Public Static Methods

GetAttributeManagerConfigurationException
GetAttributeNotFoundException
GetIConvertibleException
GetInvalidAttributeValueTypeException
GetParseIntegerInnerException
GetReadOnlyException
GetResourceString

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Constants Class | Aptify.Framework.AttributeManagement Namespace


Constants Fields

The fields of the Constants class are listed below. For a complete list of Constants class members, see the Constants Members topic.

Public Static Fields

ATTRIBUTE_MANAGER_CONFIGURATION_EXCEPTION_MESSAGE
ATTRIBUTE_NOT_AN_INTEGER_EXCEPTION_MESSAGE
ATTRIBUTE_NOT_FOUND_EXCEPTION_MESSAGE
ATTRIBUTE_NOT_ICONVERTIBLE_EXCEPTION_MESSAGE
COMPARABLE_ARGUMENT_INVALID_TYPE_EXCEPTION_MESSAGE
DATABASE_ATTRIBUTE_EXCEPTION
INVALID_ATTRIBUTE_VALUE_TYPE_EXCEPTION_MESSAGE
READ_ONLY_ATTRIBUTE_VALUE_EXCEPTION_MESSAGE
RESOURCE_FILE_NAME
XML_ATTRIBUTE_SOURCE_FILE_NAME
XML_ATTRIBUTE_SOURCE_FILE_NAME_DEFAULT_VALUE

See Also

Constants Class | Aptify.Framework.AttributeManagement Namespace


Constants.ATTRIBUTE_MANAGER_CONFIGURATION_EXCEPTION_MESSAGE Field

public const ATTRIBUTE_MANAGER_CONFIGURATION_EXCEPTION_MESSAGE ATTRIBUTE_MANAGER_CONFIGURATION_EXCEPTION_MESSAGE = "ATTRIBUTE_CONFIGURATION_EXCEPTION_MESSAGE";

See Also

Constants Class | Aptify.Framework.AttributeManagement Namespace


Constants.ATTRIBUTE_NOT_AN_INTEGER_EXCEPTION_MESSAGE Field

public const ATTRIBUTE_NOT_AN_INTEGER_EXCEPTION_MESSAGE ATTRIBUTE_NOT_AN_INTEGER_EXCEPTION_MESSAGE = "ATTRIBUTE_NOT_AN_INTEGER_EXCEPTION_MESSAGE";

See Also

Constants Class | Aptify.Framework.AttributeManagement Namespace


Constants.ATTRIBUTE_NOT_FOUND_EXCEPTION_MESSAGE Field

public const ATTRIBUTE_NOT_FOUND_EXCEPTION_MESSAGE ATTRIBUTE_NOT_FOUND_EXCEPTION_MESSAGE = "ATTRIBUTE_NOT_FOUND_EXCEPTION_MESSAGE";

See Also

Constants Class | Aptify.Framework.AttributeManagement Namespace


Constants.ATTRIBUTE_NOT_ICONVERTIBLE_EXCEPTION_MESSAGE Field

public const ATTRIBUTE_NOT_ICONVERTIBLE_EXCEPTION_MESSAGE ATTRIBUTE_NOT_ICONVERTIBLE_EXCEPTION_MESSAGE = "ATTRIBUTE_NOT_ICONVERTIBLE_EXCEPTION_MESSAGE";

See Also

Constants Class | Aptify.Framework.AttributeManagement Namespace


Constants.COMPARABLE_ARGUMENT_INVALID_TYPE_EXCEPTION_MESSAGE Field

public const COMPARABLE_ARGUMENT_INVALID_TYPE_EXCEPTION_MESSAGE COMPARABLE_ARGUMENT_INVALID_TYPE_EXCEPTION_MESSAGE = "COMPARABLE_ARGUMENT_INVALID_TYPE_EXCEPTION_MESSAGE";

See Also

Constants Class | Aptify.Framework.AttributeManagement Namespace


Constants.DATABASE_ATTRIBUTE_EXCEPTION Field

public const DATABASE_ATTRIBUTE_EXCEPTION DATABASE_ATTRIBUTE_EXCEPTION = "DATABASE_ATTRIBUTE_EXCEPTION";

See Also

Constants Class | Aptify.Framework.AttributeManagement Namespace


Constants.INVALID_ATTRIBUTE_VALUE_TYPE_EXCEPTION_MESSAGE Field

public const INVALID_ATTRIBUTE_VALUE_TYPE_EXCEPTION_MESSAGE INVALID_ATTRIBUTE_VALUE_TYPE_EXCEPTION_MESSAGE = "INVALID_ATTRIBUTE_VALUE_TYPE_EXCEPTION_MESSAGE";

See Also

Constants Class | Aptify.Framework.AttributeManagement Namespace


Constants.READ_ONLY_ATTRIBUTE_VALUE_EXCEPTION_MESSAGE Field

public const READ_ONLY_ATTRIBUTE_VALUE_EXCEPTION_MESSAGE READ_ONLY_ATTRIBUTE_VALUE_EXCEPTION_MESSAGE = "READ_ONLY_ATTRIBUTE_EXCEPTION_MESSAGE";

See Also

Constants Class | Aptify.Framework.AttributeManagement Namespace


Constants.RESOURCE_FILE_NAME Field

public const RESOURCE_FILE_NAME RESOURCE_FILE_NAME = "AttributeManagementResource";

See Also

Constants Class | Aptify.Framework.AttributeManagement Namespace


Constants.XML_ATTRIBUTE_SOURCE_FILE_NAME Field

public const XML_ATTRIBUTE_SOURCE_FILE_NAME XML_ATTRIBUTE_SOURCE_FILE_NAME = "filename";

See Also

Constants Class | Aptify.Framework.AttributeManagement Namespace


Constants.XML_ATTRIBUTE_SOURCE_FILE_NAME_DEFAULT_VALUE Field

public const XML_ATTRIBUTE_SOURCE_FILE_NAME_DEFAULT_VALUE XML_ATTRIBUTE_SOURCE_FILE_NAME_DEFAULT_VALUE = "attributes.xml";

See Also

Constants Class | Aptify.Framework.AttributeManagement Namespace


Constants Methods

The methods of the Constants class are listed below. For a complete list of Constants class members, see the Constants Members topic.

Public Static Methods

GetAttributeManagerConfigurationException
GetAttributeNotFoundException
GetIConvertibleException
GetInvalidAttributeValueTypeException
GetParseIntegerInnerException
GetReadOnlyException
GetResourceString

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Constants Class | Aptify.Framework.AttributeManagement Namespace


Constants.GetAttributeManagerConfigurationException Method

public static AttributeManagerConfigurationException GetAttributeManagerConfigurationException(
AttributeManagerSettings Settings,
Exception InnerException,
String FileName
);

See Also

Constants Class | Aptify.Framework.AttributeManagement Namespace


Constants.GetAttributeNotFoundException Method

public static AttributeNotFoundException GetAttributeNotFoundException(
AttributeManagerSettings Settings,
String FullName
);

See Also

Constants Class | Aptify.Framework.AttributeManagement Namespace


Constants.GetIConvertibleException Method

public static NotIConvertibleException GetIConvertibleException(
AttributeValue AttributeValue
);

See Also

Constants Class | Aptify.Framework.AttributeManagement Namespace


Constants.GetInvalidAttributeValueTypeException Method

public static InvalidAttributeValueTypeException GetInvalidAttributeValueTypeException(
AttributeManagerSettings Settings,
Object ActualValue,
Type ExpectedType
);

See Also

Constants Class | Aptify.Framework.AttributeManagement Namespace


Constants.GetParseIntegerInnerException Method

public static ConfigurationException GetParseIntegerInnerException(
String AttributeName,
Exception InnerException
);

See Also

Constants Class | Aptify.Framework.AttributeManagement Namespace


Constants.GetReadOnlyException Method

public static ReadOnlyAttributeValueException GetReadOnlyException(
AttributeManagerSettings Settings,
String FullName
);

See Also

Constants Class | Aptify.Framework.AttributeManagement Namespace


Constants.GetResourceString Method

public static string GetResourceString(
String Message
);

See Also

Constants Class | Aptify.Framework.AttributeManagement Namespace


DatabaseAttributeSource Class

For a list of all members of this type, see DatabaseAttributeSource Members.

System.Object
DatabaseAttributeSource

public class DatabaseAttributeSource : IAttributeSourceReader

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.AttributeManagement

Assembly: AptifyAttributeManagement (in AptifyAttributeManagement.dll)

See Also

DatabaseAttributeSource Members | Aptify.Framework.AttributeManagement Namespace


DatabaseAttributeSource Members

DatabaseAttributeSource overview

Public Static Fields

ATTRIBUTE_DATABASE_SOURCE_CONNECTION_STRING
ATTRIBUTE_DATABASE_SOURCE_DATABASE_NAME

Public Instance Constructors

DatabaseAttributeSource Constructor Initializes a new instance of the DatabaseAttributeSource class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAttributeValue | Overloaded.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DatabaseAttributeSource Class | Aptify.Framework.AttributeManagement Namespace


DatabaseAttributeSource Constructor

Initializes a new instance of the DatabaseAttributeSource class.

public DatabaseAttributeSource();

See Also

DatabaseAttributeSource Class | Aptify.Framework.AttributeManagement Namespace


DatabaseAttributeSource Fields

The fields of the DatabaseAttributeSource class are listed below. For a complete list of DatabaseAttributeSource class members, see the DatabaseAttributeSource Members topic.

Public Static Fields

ATTRIBUTE_DATABASE_SOURCE_CONNECTION_STRING
ATTRIBUTE_DATABASE_SOURCE_DATABASE_NAME

See Also

DatabaseAttributeSource Class | Aptify.Framework.AttributeManagement Namespace


DatabaseAttributeSource.ATTRIBUTE_DATABASE_SOURCE_CONNECTION_STRING Field

public const ATTRIBUTE_DATABASE_SOURCE_CONNECTION_STRING ATTRIBUTE_DATABASE_SOURCE_CONNECTION_STRING = "connectionstring";

See Also

DatabaseAttributeSource Class | Aptify.Framework.AttributeManagement Namespace


DatabaseAttributeSource.ATTRIBUTE_DATABASE_SOURCE_DATABASE_NAME Field

public const ATTRIBUTE_DATABASE_SOURCE_DATABASE_NAME ATTRIBUTE_DATABASE_SOURCE_DATABASE_NAME = "database";

See Also

DatabaseAttributeSource Class | Aptify.Framework.AttributeManagement Namespace


DatabaseAttributeSource Methods

The methods of the DatabaseAttributeSource class are listed below. For a complete list of DatabaseAttributeSource class members, see the DatabaseAttributeSource Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAttributeValue | Overloaded.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DatabaseAttributeSource Class | Aptify.Framework.AttributeManagement Namespace


GetAttributeValue Method

Aptify 5.0 Software Development Kit (SDK)

DatabaseAttributeSource.GetAttributeValue Method

Overload List

public AttributeValue GetAttributeValue(Attribute,NameValueCollection);

public AttributeValue GetAttributeValue(String,NameValueCollection);

See Also

DatabaseAttributeSource Class | Aptify.Framework.AttributeManagement Namespace


DatabaseAttributeSource.GetAttributeValue Method (Attribute, NameValueCollection)

public AttributeValue GetAttributeValue(
Attribute Attribute,
NameValueCollection ConfigSettings
);

Implements

IAttributeSourceReader.

See Also

DatabaseAttributeSource Class | Aptify.Framework.AttributeManagement Namespace | DatabaseAttributeSource.GetAttributeValue Overload List


DatabaseAttributeSource.GetAttributeValue Method (String, NameValueCollection)

public AttributeValue GetAttributeValue(
String FullName,
NameValueCollection ConfigSettings
);

Implements

IAttributeSourceReader.

See Also

DatabaseAttributeSource Class | Aptify.Framework.AttributeManagement Namespace | DatabaseAttributeSource.GetAttributeValue Overload List


XMLAttributeSource Class

For a list of all members of this type, see XMLAttributeSource Members.

System.Object
XMLAttributeSource

public class XMLAttributeSource : ICompleteAttributeSource, IAttributeSourceReader, IAttributeSourceWriter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.AttributeManagement

Assembly: AptifyAttributeManagement (in AptifyAttributeManagement.dll)

See Also

XMLAttributeSource Members | Aptify.Framework.AttributeManagement Namespace


XMLAttributeSource Members

XMLAttributeSource overview

Public Instance Constructors

XMLAttributeSource Constructor Initializes a new instance of the XMLAttributeSource class.

Public Instance Properties

WindowsTempPath

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAttributeValue | Overloaded.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
PersistAttributeValue |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XMLAttributeSource Class | Aptify.Framework.AttributeManagement Namespace


XMLAttributeSource Constructor

Initializes a new instance of the XMLAttributeSource class.

public XMLAttributeSource();

See Also

XMLAttributeSource Class | Aptify.Framework.AttributeManagement Namespace


XMLAttributeSource Properties

The properties of the XMLAttributeSource class are listed below. For a complete list of XMLAttributeSource class members, see the XMLAttributeSource Members topic.

Public Instance Properties

WindowsTempPath

See Also

XMLAttributeSource Class | Aptify.Framework.AttributeManagement Namespace


WindowsTempPath Property

Aptify 5.0 Software Development Kit (SDK)

XMLAttributeSource.WindowsTempPath Property

public String WindowsTempPath {get;}

See Also

XMLAttributeSource Class | Aptify.Framework.AttributeManagement Namespace


XMLAttributeSource Methods

The methods of the XMLAttributeSource class are listed below. For a complete list of XMLAttributeSource class members, see the XMLAttributeSource Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAttributeValue | Overloaded.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
PersistAttributeValue |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XMLAttributeSource Class | Aptify.Framework.AttributeManagement Namespace


GetAttributeValue Method

Aptify 5.0 Software Development Kit (SDK)

XMLAttributeSource.GetAttributeValue Method

Overload List

public AttributeValue GetAttributeValue(Attribute,NameValueCollection);

public AttributeValue GetAttributeValue(String,NameValueCollection);

See Also

XMLAttributeSource Class | Aptify.Framework.AttributeManagement Namespace


XMLAttributeSource.GetAttributeValue Method (Attribute, NameValueCollection)

public AttributeValue GetAttributeValue(
Attribute Attribute,
NameValueCollection ConfigSettings
);

Implements

IAttributeSourceReader.

See Also

XMLAttributeSource Class | Aptify.Framework.AttributeManagement Namespace | XMLAttributeSource.GetAttributeValue Overload List


XMLAttributeSource.GetAttributeValue Method (String, NameValueCollection)

public AttributeValue GetAttributeValue(
String FullName,
NameValueCollection ConfigSettings
);

Implements

IAttributeSourceReader.

See Also

XMLAttributeSource Class | Aptify.Framework.AttributeManagement Namespace | XMLAttributeSource.GetAttributeValue Overload List


XMLAttributeSource.PersistAttributeValue Method

public void PersistAttributeValue(
Attribute AttributeToPersist,
NameValueCollection ConfigSettings,
IConvertible NewValue
);

Implements

IAttributeSourceWriter.

See Also

XMLAttributeSource Class | Aptify.Framework.AttributeManagement Namespace


Aptify.Framework.AttributeManagement.Exceptions

Aptify 5.0 Software Development Kit (SDK)

Aptify.Framework.AttributeManagement.Exceptions Namespace

This namespace contains the possible exceptions that can occur when using the Attribute Manager, such as the "Attribute Not Found" exception and the "Attribute is Read Only" exception.

Namespace hierarchy

Classes

Class | Description
AttributeManagerConfigurationException |
AttributeNotFoundException |
InvalidAttributeValueTypeException |
NotIConvertibleException |
ReadOnlyAttributeValueException |


AttributeManagerConfigurationException Class

For a list of all members of this type, see AttributeManagerConfigurationException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
AttributeManagerConfigurationException

public class AttributeManagerConfigurationException : BaseApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.AttributeManagement.Exceptions

Assembly: AptifyAttributeManagement (in AptifyAttributeManagement.dll)

See Also

AttributeManagerConfigurationException Members | Aptify.Framework.AttributeManagement.Exceptions Namespace


AttributeManagerConfigurationException Members

AttributeManagerConfigurationException overview

Public Instance Constructors

AttributeManagerConfigurationException Overloaded. Initializes a new instance of the AttributeManagerConfigurationException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
FileName |
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message |
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AttributeManagerConfigurationException Class | Aptify.Framework.AttributeManagement.Exceptions Namespace


AttributeManagerConfigurationException Constructor

Overload List

Initializes a new instance of the AttributeManagerConfigurationException class.

public AttributeManagerConfigurationException();

public AttributeManagerConfigurationException(Int32);

public AttributeManagerConfigurationException(Int32,Exception,String);

public AttributeManagerConfigurationException(Int32,Int32);

public AttributeManagerConfigurationException(Int32,Int32,String);

public AttributeManagerConfigurationException(Int32,Int32,String,Exception);

public AttributeManagerConfigurationException(SerializationInfo,StreamingContext);

public AttributeManagerConfigurationException(String);

See Also

AttributeManagerConfigurationException Class | Aptify.Framework.AttributeManagement.Exceptions Namespace


AttributeManagerConfigurationException Constructor (Int32, Exception, String)

public AttributeManagerConfigurationException(
Int32 Severity,
Exception InnerException,
String FileName
);

See Also

AttributeManagerConfigurationException Class | Aptify.Framework.AttributeManagement.Exceptions Namespace | AttributeManagerConfigurationException Constructor Overload List


AttributeManagerConfigurationException Constructor ()

Initializes a new instance of the AttributeManagerConfigurationException class.

public AttributeManagerConfigurationException();

See Also

AttributeManagerConfigurationException Class | Aptify.Framework.AttributeManagement.Exceptions Namespace | AttributeManagerConfigurationException Constructor Overload List


AttributeManagerConfigurationException Constructor (Int32, Int32)

public AttributeManagerConfigurationException(
Int32 ErrorNumber,
Int32 Severity
);

See Also

AttributeManagerConfigurationException Class | Aptify.Framework.AttributeManagement.Exceptions Namespace | AttributeManagerConfigurationException Constructor Overload List


AttributeManagerConfigurationException Constructor (Int32)

public AttributeManagerConfigurationException(
Int32 ErrorNumber
);

See Also

AttributeManagerConfigurationException Class | Aptify.Framework.AttributeManagement.Exceptions Namespace | AttributeManagerConfigurationException Constructor Overload List


AttributeManagerConfigurationException Constructor (Int32, Int32, String)

public AttributeManagerConfigurationException(
Int32 ErrorNumber,
Int32 Severity,
String Message
);

See Also

AttributeManagerConfigurationException Class | Aptify.Framework.AttributeManagement.Exceptions Namespace | AttributeManagerConfigurationException Constructor Overload List


AttributeManagerConfigurationException Constructor (Int32, Int32, String, Exception)

public AttributeManagerConfigurationException(
Int32 ErrorNumber,
Int32 Severity,
String Message,
Exception InnerException
);

See Also

AttributeManagerConfigurationException Class | Aptify.Framework.AttributeManagement.Exceptions Namespace | AttributeManagerConfigurationException Constructor Overload List


AttributeManagerConfigurationException Constructor (String)

public AttributeManagerConfigurationException(
String Message
);

See Also

AttributeManagerConfigurationException Class | Aptify.Framework.AttributeManagement.Exceptions Namespace | AttributeManagerConfigurationException Constructor Overload List


AttributeManagerConfigurationException Constructor (SerializationInfo, StreamingContext)

public AttributeManagerConfigurationException(
SerializationInfo Info,
StreamingContext Context
);

See Also

AttributeManagerConfigurationException Class | Aptify.Framework.AttributeManagement.Exceptions Namespace | AttributeManagerConfigurationException Constructor Overload List


AttributeManagerConfigurationException Properties

The properties of the AttributeManagerConfigurationException class are listed below. For a complete list of AttributeManagerConfigurationException class members, see the AttributeManagerConfigurationException Members topic.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
FileName |
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message |
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

See Also

AttributeManagerConfigurationException Class | Aptify.Framework.AttributeManagement.Exceptions Namespace


FileName Property

Aptify 5.0 Software Development Kit (SDK)

AttributeManagerConfigurationException.FileName Property

public String FileName {get;}

See Also

AttributeManagerConfigurationException Class | Aptify.Framework.AttributeManagement.Exceptions Namespace


Message Property

Aptify 5.0 Software Development Kit (SDK)

AttributeManagerConfigurationException.Message Property

public override String Message {get;}

See Also

AttributeManagerConfigurationException Class | Aptify.Framework.AttributeManagement.Exceptions Namespace


AttributeManagerConfigurationException Methods

The methods of the AttributeManagerConfigurationException class are listed below. For a complete list of AttributeManagerConfigurationException class members, see the AttributeManagerConfigurationException Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AttributeManagerConfigurationException Class | Aptify.Framework.AttributeManagement.Exceptions Namespace


AttributeManagerConfigurationException.GetObjectData Method

public override void GetObjectData(
SerializationInfo Info,
StreamingContext Context
);

Implements

ISerializable.

See Also

AttributeManagerConfigurationException Class | Aptify.Framework.AttributeManagement.Exceptions Namespace


AttributeNotFoundException Class

For a list of all members of this type, see AttributeNotFoundException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
AttributeNotFoundException

public class AttributeNotFoundException : BaseApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.AttributeManagement.Exceptions

Assembly: AptifyAttributeManagement (in AptifyAttributeManagement.dll)

See Also

AttributeNotFoundException Members | Aptify.Framework.AttributeManagement.Exceptions Namespace


AttributeNotFoundException Members

AttributeNotFoundException overview

Public Instance Constructors

AttributeNotFoundException Overloaded. Initializes a new instance of the AttributeNotFoundException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
AttributeName |
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message |
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Constructors

AttributeNotFoundException Overloaded. Initializes a new instance of the AttributeNotFoundException class.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AttributeNotFoundException Class | Aptify.Framework.AttributeManagement.Exceptions Namespace


AttributeNotFoundException Constructor

Overload List

Initializes a new instance of the AttributeNotFoundException class.

public AttributeNotFoundException();

public AttributeNotFoundException(Int32);

public AttributeNotFoundException(Int32,Int32);

public AttributeNotFoundException(Int32,Int32,String);

public AttributeNotFoundException(Int32,Int32,String,Exception);

public AttributeNotFoundException(Int32,String);

protected AttributeNotFoundException(SerializationInfo,StreamingContext);

public AttributeNotFoundException(String);

See Also

AttributeNotFoundException Class | Aptify.Framework.AttributeManagement.Exceptions Namespace


AttributeNotFoundException Constructor (Int32, String)

public AttributeNotFoundException(
Int32 Severity,
String FullAttributeName
);

See Also

AttributeNotFoundException Class | Aptify.Framework.AttributeManagement.Exceptions Namespace | AttributeNotFoundException Constructor Overload List


AttributeNotFoundException Constructor ()

Initializes a new instance of the AttributeNotFoundException class.

public AttributeNotFoundException();

See Also

AttributeNotFoundException Class | Aptify.Framework.AttributeManagement.Exceptions Namespace | AttributeNotFoundException Constructor Overload List


AttributeNotFoundException Constructor (Int32, Int32)

public AttributeNotFoundException(
Int32 ErrorNumber,
Int32 Severity
);

See Also

AttributeNotFoundException Class | Aptify.Framework.AttributeManagement.Exceptions Namespace | AttributeNotFoundException Constructor Overload List


AttributeNotFoundException Constructor (Int32)

public AttributeNotFoundException(
Int32 ErrorNumber
);

See Also

AttributeNotFoundException Class | Aptify.Framework.AttributeManagement.Exceptions Namespace | AttributeNotFoundException Constructor Overload List


AttributeNotFoundException Constructor (Int32, Int32, String)

public AttributeNotFoundException(
Int32 ErrorNumber,
Int32 Severity,
String Message
);

See Also

AttributeNotFoundException Class | Aptify.Framework.AttributeManagement.Exceptions Namespace | AttributeNotFoundException Constructor Overload List


AttributeNotFoundException Constructor (Int32, Int32, String, Exception)

public AttributeNotFoundException(
Int32 ErrorNumber,
Int32 Severity,
String Message,
Exception InnerException
);

See Also

AttributeNotFoundException Class | Aptify.Framework.AttributeManagement.Exceptions Namespace | AttributeNotFoundException Constructor Overload List


AttributeNotFoundException Constructor (String)

public AttributeNotFoundException(
String Message
);

See Also

AttributeNotFoundException Class | Aptify.Framework.AttributeManagement.Exceptions Namespace | AttributeNotFoundException Constructor Overload List


AttributeNotFoundException Constructor (SerializationInfo, StreamingContext)

protected AttributeNotFoundException(
SerializationInfo Info,
StreamingContext Context
);

See Also

AttributeNotFoundException Class | Aptify.Framework.AttributeManagement.Exceptions Namespace | AttributeNotFoundException Constructor Overload List


AttributeNotFoundException Properties

The properties of the AttributeNotFoundException class are listed below. For a complete list of AttributeNotFoundException class members, see the AttributeNotFoundException Members topic.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
AttributeName |
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message |
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

See Also

AttributeNotFoundException Class | Aptify.Framework.AttributeManagement.Exceptions Namespace


AttributeName Property

Aptify 5.0 Software Development Kit (SDK)

AttributeNotFoundException.AttributeName Property

public String AttributeName {get; set;}

See Also

AttributeNotFoundException Class | Aptify.Framework.AttributeManagement.Exceptions Namespace


Message Property

Aptify 5.0 Software Development Kit (SDK)

AttributeNotFoundException.Message Property

public override String Message {get;}

See Also

AttributeNotFoundException Class | Aptify.Framework.AttributeManagement.Exceptions Namespace


AttributeNotFoundException Methods

The methods of the AttributeNotFoundException class are listed below. For a complete list of AttributeNotFoundException class members, see the AttributeNotFoundException Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AttributeNotFoundException Class | Aptify.Framework.AttributeManagement.Exceptions Namespace


AttributeNotFoundException.GetObjectData Method

public override void GetObjectData(
SerializationInfo Info,
StreamingContext Context
);

Implements

ISerializable.

See Also

AttributeNotFoundException Class | Aptify.Framework.AttributeManagement.Exceptions Namespace


InvalidAttributeValueTypeException Class

For a list of all members of this type, see InvalidAttributeValueTypeException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
InvalidAttributeValueTypeException

public class InvalidAttributeValueTypeException : BaseApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.AttributeManagement.Exceptions

Assembly: AptifyAttributeManagement (in AptifyAttributeManagement.dll)

See Also

InvalidAttributeValueTypeException Members | Aptify.Framework.AttributeManagement.Exceptions Namespace


InvalidAttributeValueTypeException Members

InvalidAttributeValueTypeException overview

Public Instance Constructors

InvalidAttributeValueTypeException Overloaded. Initializes a new instance of the InvalidAttributeValueTypeException class.

Public Instance Properties

ActualValue |
AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
ExpectedType |
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message |
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

InvalidAttributeValueTypeException Class | Aptify.Framework.AttributeManagement.Exceptions Namespace


InvalidAttributeValueTypeException Constructor

Overload List

Initializes a new instance of the InvalidAttributeValueTypeException class.

public InvalidAttributeValueTypeException();

public InvalidAttributeValueTypeException(Int32);

public InvalidAttributeValueTypeException(Int32,Int32);

public InvalidAttributeValueTypeException(Int32,Int32,String);

public InvalidAttributeValueTypeException(Int32,Int32,String,Exception);

public InvalidAttributeValueTypeException(Int32,Object,Type);

public InvalidAttributeValueTypeException(SerializationInfo,StreamingContext);

public InvalidAttributeValueTypeException(String);

See Also

InvalidAttributeValueTypeException Class | Aptify.Framework.AttributeManagement.Exceptions Namespace


InvalidAttributeValueTypeException Constructor (Int32, Object, Type)

public InvalidAttributeValueTypeException(
Int32 Severity,
Object ActualValue,
Type ExpectedType
);

See Also

InvalidAttributeValueTypeException Class | Aptify.Framework.AttributeManagement.Exceptions Namespace | InvalidAttributeValueTypeException Constructor Overload List


InvalidAttributeValueTypeException Constructor ()

Initializes a new instance of the InvalidAttributeValueTypeException class.

public InvalidAttributeValueTypeException();

See Also

InvalidAttributeValueTypeException Class | Aptify.Framework.AttributeManagement.Exceptions Namespace | InvalidAttributeValueTypeException Constructor Overload List


InvalidAttributeValueTypeException Constructor (Int32, Int32)

public InvalidAttributeValueTypeException(
Int32 ErrorNumber,
Int32 Severity
);

See Also

InvalidAttributeValueTypeException Class | Aptify.Framework.AttributeManagement.Exceptions Namespace | InvalidAttributeValueTypeException Constructor Overload List


InvalidAttributeValueTypeException Constructor (Int32)

public InvalidAttributeValueTypeException(
Int32 ErrorNumber
);

See Also

InvalidAttributeValueTypeException Class | Aptify.Framework.AttributeManagement.Exceptions Namespace | InvalidAttributeValueTypeException Constructor Overload List


InvalidAttributeValueTypeException Constructor (Int32, Int32, String)

public InvalidAttributeValueTypeException(
Int32 ErrorNumber,
Int32 Severity,
String Message
);

See Also

InvalidAttributeValueTypeException Class | Aptify.Framework.AttributeManagement.Exceptions Namespace | InvalidAttributeValueTypeException Constructor Overload List


InvalidAttributeValueTypeException Constructor (Int32, Int32, String, Exception)

public InvalidAttributeValueTypeException(
Int32 ErrorNumber,
Int32 Severity,
String Message,
Exception InnerException
);

See Also

InvalidAttributeValueTypeException Class | Aptify.Framework.AttributeManagement.Exceptions Namespace | InvalidAttributeValueTypeException Constructor Overload List


InvalidAttributeValueTypeException Constructor (String)

public InvalidAttributeValueTypeException(
String Message
);

See Also

InvalidAttributeValueTypeException Class | Aptify.Framework.AttributeManagement.Exceptions Namespace | InvalidAttributeValueTypeException Constructor Overload List


InvalidAttributeValueTypeException Constructor (SerializationInfo, StreamingContext)

public InvalidAttributeValueTypeException(
SerializationInfo Info,
StreamingContext Context
);

See Also

InvalidAttributeValueTypeException Class | Aptify.Framework.AttributeManagement.Exceptions Namespace | InvalidAttributeValueTypeException Constructor Overload List


InvalidAttributeValueTypeException Properties

The properties of the InvalidAttributeValueTypeException class are listed below. For a complete list of InvalidAttributeValueTypeException class members, see the InvalidAttributeValueTypeException Members topic.

Public Instance Properties

ActualValue |
AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
ExpectedType |
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message |
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

See Also

InvalidAttributeValueTypeException Class | Aptify.Framework.AttributeManagement.Exceptions Namespace


ActualValue Property

Aptify 5.0 Software Development Kit (SDK)

InvalidAttributeValueTypeException.ActualValue Property

public Object ActualValue {get; set;}

See Also

InvalidAttributeValueTypeException Class | Aptify.Framework.AttributeManagement.Exceptions Namespace


ExpectedType Property

Aptify 5.0 Software Development Kit (SDK)

InvalidAttributeValueTypeException.ExpectedType Property

public Type ExpectedType {get; set;}

See Also

InvalidAttributeValueTypeException Class | Aptify.Framework.AttributeManagement.Exceptions Namespace


Message Property

Aptify 5.0 Software Development Kit (SDK)

InvalidAttributeValueTypeException.Message Property

public override String Message {get;}

See Also

InvalidAttributeValueTypeException Class | Aptify.Framework.AttributeManagement.Exceptions Namespace


InvalidAttributeValueTypeException Methods

The methods of the InvalidAttributeValueTypeException class are listed below. For a complete list of InvalidAttributeValueTypeException class members, see the InvalidAttributeValueTypeException Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

InvalidAttributeValueTypeException Class | Aptify.Framework.AttributeManagement.Exceptions Namespace


InvalidAttributeValueTypeException.GetObjectData Method

public override void GetObjectData(
SerializationInfo Info,
StreamingContext Context
);

Implements

ISerializable.

See Also

InvalidAttributeValueTypeException Class | Aptify.Framework.AttributeManagement.Exceptions Namespace


NotIConvertibleException Class

For a list of all members of this type, see NotIConvertibleException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
NotIConvertibleException

public class NotIConvertibleException : BaseApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.AttributeManagement.Exceptions

Assembly: AptifyAttributeManagement (in AptifyAttributeManagement.dll)

See Also

NotIConvertibleException Members | Aptify.Framework.AttributeManagement.Exceptions Namespace


NotIConvertibleException Members

NotIConvertibleException overview

Public Instance Constructors

NotIConvertibleException Overloaded. Initializes a new instance of the NotIConvertibleException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
AttributeName |
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message |
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NotIConvertibleException Class | Aptify.Framework.AttributeManagement.Exceptions Namespace


NotIConvertibleException Constructor

Overload List

Initializes a new instance of the NotIConvertibleException class.

public NotIConvertibleException();

public NotIConvertibleException(AttributeValue);

public NotIConvertibleException(Int32);

public NotIConvertibleException(Int32,Int32);

public NotIConvertibleException(Int32,Int32,String);

public NotIConvertibleException(Int32,Int32,String,Exception);

public NotIConvertibleException(SerializationInfo,StreamingContext);

public NotIConvertibleException(String);

See Also

NotIConvertibleException Class | Aptify.Framework.AttributeManagement.Exceptions Namespace


NotIConvertibleException Constructor (AttributeValue)

public NotIConvertibleException(
AttributeValue AttributeValue
);

See Also

NotIConvertibleException Class | Aptify.Framework.AttributeManagement.Exceptions Namespace | NotIConvertibleException Constructor Overload List


NotIConvertibleException Constructor ()

Initializes a new instance of the NotIConvertibleException class.

public NotIConvertibleException();

See Also

NotIConvertibleException Class | Aptify.Framework.AttributeManagement.Exceptions Namespace | NotIConvertibleException Constructor Overload List


NotIConvertibleException Constructor (Int32, Int32)

public NotIConvertibleException(
Int32 ErrorNumber,
Int32 Severity
);

See Also

NotIConvertibleException Class | Aptify.Framework.AttributeManagement.Exceptions Namespace | NotIConvertibleException Constructor Overload List


NotIConvertibleException Constructor (Int32)

public NotIConvertibleException(
Int32 ErrorNumber
);

See Also

NotIConvertibleException Class | Aptify.Framework.AttributeManagement.Exceptions Namespace | NotIConvertibleException Constructor Overload List


NotIConvertibleException Constructor (Int32, Int32, String)

public NotIConvertibleException(
Int32 ErrorNumber,
Int32 Severity,
String Message
);

See Also

NotIConvertibleException Class | Aptify.Framework.AttributeManagement.Exceptions Namespace | NotIConvertibleException Constructor Overload List


NotIConvertibleException Constructor (Int32, Int32, String, Exception)

public NotIConvertibleException(
Int32 ErrorNumber,
Int32 Severity,
String Message,
Exception InnerException
);

See Also

NotIConvertibleException Class | Aptify.Framework.AttributeManagement.Exceptions Namespace | NotIConvertibleException Constructor Overload List


NotIConvertibleException Constructor (String)

public NotIConvertibleException(
String Message
);

See Also

NotIConvertibleException Class | Aptify.Framework.AttributeManagement.Exceptions Namespace | NotIConvertibleException Constructor Overload List


NotIConvertibleException Constructor (SerializationInfo, StreamingContext)

public NotIConvertibleException(
SerializationInfo Info,
StreamingContext Context
);

See Also

NotIConvertibleException Class | Aptify.Framework.AttributeManagement.Exceptions Namespace | NotIConvertibleException Constructor Overload List


NotIConvertibleException Properties

The properties of the NotIConvertibleException class are listed below. For a complete list of NotIConvertibleException class members, see the NotIConvertibleException Members topic.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
AttributeName |
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message |
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

See Also

NotIConvertibleException Class | Aptify.Framework.AttributeManagement.Exceptions Namespace


AttributeName Property

Aptify 5.0 Software Development Kit (SDK)

NotIConvertibleException.AttributeName Property

public String AttributeName {get; set;}

See Also

NotIConvertibleException Class | Aptify.Framework.AttributeManagement.Exceptions Namespace


Message Property

Aptify 5.0 Software Development Kit (SDK)

NotIConvertibleException.Message Property

public override String Message {get;}

See Also

NotIConvertibleException Class | Aptify.Framework.AttributeManagement.Exceptions Namespace


NotIConvertibleException Methods

The methods of the NotIConvertibleException class are listed below. For a complete list of NotIConvertibleException class members, see the NotIConvertibleException Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NotIConvertibleException Class | Aptify.Framework.AttributeManagement.Exceptions Namespace


NotIConvertibleException.GetObjectData Method

public override void GetObjectData(
SerializationInfo Info,
StreamingContext Context
);

Implements

ISerializable.

See Also

NotIConvertibleException Class | Aptify.Framework.AttributeManagement.Exceptions Namespace


ReadOnlyAttributeValueException Class

For a list of all members of this type, see ReadOnlyAttributeValueException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
ReadOnlyAttributeValueException

public class ReadOnlyAttributeValueException : BaseApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.AttributeManagement.Exceptions

Assembly: AptifyAttributeManagement (in AptifyAttributeManagement.dll)

See Also

ReadOnlyAttributeValueException Members | Aptify.Framework.AttributeManagement.Exceptions Namespace


ReadOnlyAttributeValueException Members

ReadOnlyAttributeValueException overview

Public Instance Constructors

ReadOnlyAttributeValueException Overloaded. Initializes a new instance of the ReadOnlyAttributeValueException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
AttributeName |
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message |
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ReadOnlyAttributeValueException Class | Aptify.Framework.AttributeManagement.Exceptions Namespace


ReadOnlyAttributeValueException Constructor

Overload List

Initializes a new instance of the ReadOnlyAttributeValueException class.

public ReadOnlyAttributeValueException();

public ReadOnlyAttributeValueException(Int32);

public ReadOnlyAttributeValueException(Int32,Int32);

public ReadOnlyAttributeValueException(Int32,Int32,String);

public ReadOnlyAttributeValueException(Int32,Int32,String,Exception);

public ReadOnlyAttributeValueException(Int32,String);

public ReadOnlyAttributeValueException(SerializationInfo,StreamingContext);

public ReadOnlyAttributeValueException(String);

See Also

ReadOnlyAttributeValueException Class | Aptify.Framework.AttributeManagement.Exceptions Namespace


ReadOnlyAttributeValueException Constructor (Int32, String)

public ReadOnlyAttributeValueException(
Int32 Severity,
String FullAttributeName
);

See Also

ReadOnlyAttributeValueException Class | Aptify.Framework.AttributeManagement.Exceptions Namespace | ReadOnlyAttributeValueException Constructor Overload List


ReadOnlyAttributeValueException Constructor ()

Initializes a new instance of the ReadOnlyAttributeValueException class.

public ReadOnlyAttributeValueException();

See Also

ReadOnlyAttributeValueException Class | Aptify.Framework.AttributeManagement.Exceptions Namespace | ReadOnlyAttributeValueException Constructor Overload List


ReadOnlyAttributeValueException Constructor (Int32, Int32)

public ReadOnlyAttributeValueException(
Int32 ErrorNumber,
Int32 Severity
);

See Also

ReadOnlyAttributeValueException Class | Aptify.Framework.AttributeManagement.Exceptions Namespace | ReadOnlyAttributeValueException Constructor Overload List


ReadOnlyAttributeValueException Constructor (Int32)

public ReadOnlyAttributeValueException(
Int32 ErrorNumber
);

See Also

ReadOnlyAttributeValueException Class | Aptify.Framework.AttributeManagement.Exceptions Namespace | ReadOnlyAttributeValueException Constructor Overload List


ReadOnlyAttributeValueException Constructor (Int32, Int32, String)

public ReadOnlyAttributeValueException(
Int32 ErrorNumber,
Int32 Severity,
String Message
);

See Also

ReadOnlyAttributeValueException Class | Aptify.Framework.AttributeManagement.Exceptions Namespace | ReadOnlyAttributeValueException Constructor Overload List


ReadOnlyAttributeValueException Constructor (Int32, Int32, String, Exception)

public ReadOnlyAttributeValueException(
Int32 ErrorNumber,
Int32 Severity,
String Message,
Exception InnerException
);

See Also

ReadOnlyAttributeValueException Class | Aptify.Framework.AttributeManagement.Exceptions Namespace | ReadOnlyAttributeValueException Constructor Overload List


ReadOnlyAttributeValueException Constructor (String)

public ReadOnlyAttributeValueException(
String Message
);

See Also

ReadOnlyAttributeValueException Class | Aptify.Framework.AttributeManagement.Exceptions Namespace | ReadOnlyAttributeValueException Constructor Overload List


ReadOnlyAttributeValueException Constructor (SerializationInfo, StreamingContext)

public ReadOnlyAttributeValueException(
SerializationInfo Info,
StreamingContext Context
);

See Also

ReadOnlyAttributeValueException Class | Aptify.Framework.AttributeManagement.Exceptions Namespace | ReadOnlyAttributeValueException Constructor Overload List


ReadOnlyAttributeValueException Properties

The properties of the ReadOnlyAttributeValueException class are listed below. For a complete list of ReadOnlyAttributeValueException class members, see the ReadOnlyAttributeValueException Members topic.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
AttributeName |
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message |
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

See Also

ReadOnlyAttributeValueException Class | Aptify.Framework.AttributeManagement.Exceptions Namespace


AttributeName Property

Aptify 5.0 Software Development Kit (SDK)

ReadOnlyAttributeValueException.AttributeName Property

public String AttributeName {get; set;}

See Also

ReadOnlyAttributeValueException Class | Aptify.Framework.AttributeManagement.Exceptions Namespace


Message Property

Aptify 5.0 Software Development Kit (SDK)

ReadOnlyAttributeValueException.Message Property

public override String Message {get;}

See Also

ReadOnlyAttributeValueException Class | Aptify.Framework.AttributeManagement.Exceptions Namespace


ReadOnlyAttributeValueException Methods

The methods of the ReadOnlyAttributeValueException class are listed below. For a complete list of ReadOnlyAttributeValueException class members, see the ReadOnlyAttributeValueException Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ReadOnlyAttributeValueException Class | Aptify.Framework.AttributeManagement.Exceptions Namespace


ReadOnlyAttributeValueException.GetObjectData Method

public override void GetObjectData(
SerializationInfo Info,
StreamingContext Context
);

Implements

ISerializable.

See Also

ReadOnlyAttributeValueException Class | Aptify.Framework.AttributeManagement.Exceptions Namespace


Aptify.Framework.AttributeManagement.Interfaces

Aptify 5.0 Software Development Kit (SDK)

Aptify.Framework.AttributeManagement.Interfaces Namespace

The namespace contains interfaces that should be implemented when creating classes with the intention of plugging them into the Aptify Attribute Management Framework.

Namespace hierarchy

Interfaces

Interface | Description
IAttributeSourceReader |
IAttributeSourceWriter |
ICompleteAttributeSource |
ISupportsAttributes |


IAttributeSourceReader Interface

For a list of all members of this type, see IAttributeSourceReader Members.

Aptify.Framework.AttributeManagement.Interfaces.IAttributeSourceReader
ICompleteAttributeSource

public interface IAttributeSourceReader

Types that implement IAttributeSourceReader

Type | Description
AppConfigAttributeSource |
DatabaseAttributeSource |
XMLAttributeSource |

Requirements

Namespace: Aptify.Framework.AttributeManagement.Interfaces

Assembly: AptifyAttributeManagement (in AptifyAttributeManagement.dll)

See Also

IAttributeSourceReader Members | Aptify.Framework.AttributeManagement.Interfaces Namespace


IAttributeSourceReader Members

IAttributeSourceReader overview

Public Instance Methods

GetAttributeValue Overloaded.

See Also

IAttributeSourceReader Interface | Aptify.Framework.AttributeManagement.Interfaces Namespace


IAttributeSourceReader Methods

The methods of the IAttributeSourceReader interface are listed below. For a complete list of IAttributeSourceReader interface members, see the IAttributeSourceReader Members topic.

Public Instance Methods

GetAttributeValue Overloaded.

See Also

IAttributeSourceReader Interface | Aptify.Framework.AttributeManagement.Interfaces Namespace


GetAttributeValue Method

Aptify 5.0 Software Development Kit (SDK)

IAttributeSourceReader.GetAttributeValue Method

Overload List

AttributeValue GetAttributeValue(Attribute,NameValueCollection);

AttributeValue GetAttributeValue(String,NameValueCollection);

See Also

IAttributeSourceReader Interface | Aptify.Framework.AttributeManagement.Interfaces Namespace


IAttributeSourceReader.GetAttributeValue Method (Attribute, NameValueCollection)

AttributeValue GetAttributeValue(
Attribute Attribute,
NameValueCollection ConfigSettings
);

See Also

IAttributeSourceReader Interface | Aptify.Framework.AttributeManagement.Interfaces Namespace | IAttributeSourceReader.GetAttributeValue Overload List


IAttributeSourceReader.GetAttributeValue Method (String, NameValueCollection)

AttributeValue GetAttributeValue(
String FullName,
NameValueCollection ConfigSettings
);

See Also

IAttributeSourceReader Interface | Aptify.Framework.AttributeManagement.Interfaces Namespace | IAttributeSourceReader.GetAttributeValue Overload List


IAttributeSourceWriter Interface

For a list of all members of this type, see IAttributeSourceWriter Members.

Aptify.Framework.AttributeManagement.Interfaces.IAttributeSourceWriter
ICompleteAttributeSource

public interface IAttributeSourceWriter

Types that implement IAttributeSourceWriter

Type | Description
XMLAttributeSource |

Requirements

Namespace: Aptify.Framework.AttributeManagement.Interfaces

Assembly: AptifyAttributeManagement (in AptifyAttributeManagement.dll)

See Also

IAttributeSourceWriter Members | Aptify.Framework.AttributeManagement.Interfaces Namespace


IAttributeSourceWriter Members

IAttributeSourceWriter overview

Public Instance Methods

PersistAttributeValue

See Also

IAttributeSourceWriter Interface | Aptify.Framework.AttributeManagement.Interfaces Namespace


IAttributeSourceWriter Methods

The methods of the IAttributeSourceWriter interface are listed below. For a complete list of IAttributeSourceWriter interface members, see the IAttributeSourceWriter Members topic.

Public Instance Methods

PersistAttributeValue

See Also

IAttributeSourceWriter Interface | Aptify.Framework.AttributeManagement.Interfaces Namespace


IAttributeSourceWriter.PersistAttributeValue Method

void PersistAttributeValue(
Attribute AttributeToPersist,
NameValueCollection ConfigSettings,
IConvertible NewValue
);

See Also

IAttributeSourceWriter Interface | Aptify.Framework.AttributeManagement.Interfaces Namespace


ICompleteAttributeSource Interface

public interface ICompleteAttributeSource : IAttributeSourceReader, IAttributeSourceWriter

Types that implement ICompleteAttributeSource

Type | Description
XMLAttributeSource |

Requirements

Namespace: Aptify.Framework.AttributeManagement.Interfaces

Assembly: AptifyAttributeManagement (in AptifyAttributeManagement.dll)

See Also

Aptify.Framework.AttributeManagement.Interfaces Namespace


ISupportsAttributes Interface

For a list of all members of this type, see ISupportsAttributes Members.

public interface ISupportsAttributes

Types that implement ISupportsAttributes

Type | Description
ScheduleOnly |
WindowsScheduler | The Windows Scheduled Tasks implementation of the Scheduled Task Services interface. Scheduled Tasks that use the Windows Scheduler Scheduled Task Service will use the Scheduled Tasks functionality in Mircosoft Windows to trigger an executable that creates a Process Flow Runs record for immediate execution based on the information within the Scheduled Tasks record
AsyncRetrieveData |
Constants |
DataAction | The DataAction class in AptifyGenericDataServices is the main Data Services Layer class that is used for all synchronous data access for applications developed with Aptify Technology Platform. The DataAction component also manages connections and data caching intrinsically. This class is not bound to a specific database engine. Hence, the Generic nomenclature. Through configuration information, the generic Data Services Layer binds to a specific database engine. The default implementation is for Microsoft SQL Server which is contained in the assembly, AptifySQLDataServices.
UISettings |
AptifyLogin | Responsible for initial access to the Aptify application. Checks attribute information, accepts information from the caller and can prompt for more information, if the configuration attributes allow the class to display GUI.

Requirements

Namespace: Aptify.Framework.AttributeManagement.Interfaces

Assembly: AptifyAttributeManagement (in AptifyAttributeManagement.dll)

See Also

ISupportsAttributes Members | Aptify.Framework.AttributeManagement.Interfaces Namespace


ISupportsAttributes Members

ISupportsAttributes overview

Public Instance Methods

GetAttribute

See Also

ISupportsAttributes Interface | Aptify.Framework.AttributeManagement.Interfaces Namespace


ISupportsAttributes Methods

The methods of the ISupportsAttributes interface are listed below. For a complete list of ISupportsAttributes interface members, see the ISupportsAttributes Members topic.

Public Instance Methods

GetAttribute

See Also

ISupportsAttributes Interface | Aptify.Framework.AttributeManagement.Interfaces Namespace


ISupportsAttributes.GetAttribute Method

Attribute GetAttribute(
String Name
);

See Also

ISupportsAttributes Interface | Aptify.Framework.AttributeManagement.Interfaces Namespace


Aptify.Framework.BusinessLogic

Aptify 5.0 Software Development Kit (SDK)

Aptify.Framework.BusinessLogic Namespace

This namespace contains objects related to the system's generic business logic. This includes functionality related to User Management (Users and Groups entities and assigning SQL server roles) and record merging processes.

Namespace hierarchy

Classes

Class | Description
Aptify_TC_CL_Task_SaveException |
AptifyDeleteSQLRole |
AptifyDMO |
AptifyGroupsEntity |
AptifyLoadMergeException |
AptifyMergeException |
AptifyNull_TC_CL_Task_GEException |
AptifyNullKeepIDOrEntityNameException |
AptifyNullMergeIDException |
AptifyQuotesNotAllowed |
AptifyRelinkMergeException |
AptifySaveMergeException |
AptifySecurityException |
AptifyUserEntityException |
AptifyUsersEntity |
CommandMetaData | This class represents an instance of meta-data for a specific Command. The base class for CommandMetaData is FormTemplateMetadataBase. While this class has nothing to do with the Form Template architecture, the base class in Form Template Meta-data provides useful generic functionality that is leveraged here.
CommandMetadataCache | This class handles the process of accessing the Command Meta-Data via its Shared Instance() method which returns a class instance that is shared amongst all of the various classes that need Command Meta-Data within a process. To look-up a meta-data record for a Command, simply access the Command Instance shared property and call the Commands property.
ConversionEventHandler |
CountryMetaData |
CountryMetaDataList |
CountryMetadataSingleton |
CultureStringLocalMetaData |
CultureStringLocalMetaDataList |
CultureStringMetaData |
CultureStringMetaDataList |
CultureStringMetadataSingleton |
CultureUtility |
DatabaseRole |
DatabaseRoleCollection |
DynamicSharingRelationshipMetaData |
DynamicSharingRelationshipMetaDataList |
EntityBaseViewFieldMetaData |
EntityBaseViewFieldMetaDataList |
EntityBaseViewFilterMetaData |
EntityBaseViewFilterMetaDataList |
EntityBaseViewGroupPermissionMetaData |
EntityBaseViewGroupPermissionMetaDataList |
EntityBaseViewMetaData |
EntityBaseViewMetaDataList | Allows for the enumerating or listing of all the fields in an entity Public class that is not createable outside this dll
EntityBaseViewUserPermissionMetaData |
EntityBaseViewUserPermissionMetaDataList |
EntityDefaultBaseViewMetaData |
EntityDefaultBaseViewMetaDataList | Allows for the enumerating or listing of all the fields in an entity Public class that is not createable outside this dll
EntityFieldMetaData |
EntityFieldMetaDataList |
EntityFieldValueMetaData |
EntityFieldValueMetaDataList |
EntityLevelMetaData |
EntityLevelMetaDataList |
ExtenderEntityMetaData | Defines meta-data related to the Entity Extension
ExtenderEntityMetaDataCache |
GenericEntityCollection |
LinkedEntityFieldMetaData | Tracks meta-data associated with linked fields that bind entities together
MasterTaskAndContactLogLink |
MasterTopicCodeLink |
Merge |
MergeField |
MergeFieldCollection |
MergeForm |
MergingGUI |
MetadataSingleton |
ObjectRepositoryObjectsEntity |
oroEntityConstants |
ReadDataRow |
Role |
RoleCollection |
SQLServerDMO |
StatusForm |

Delegates

Delegate | Description
Merge.StatusEventEventHandler |
Merge.SubStatusEventEventHandler |

Enumerations

Enumeration | Description
AllowedSearchMethod |
DatabaseRoles |
EmbeddedLinkSharingMode |
ExtenderEntityMetaData.ExtenderEntityType |
FieldAlignment |
FieldGenericDataType |
FieldGUITypeMultiSelect |
FieldGUITypeSingleSelect |
FieldLinkType |
FieldValueListType |
InPlaceEditSecurity |
InputMaskType |
RoleType |
ServerRoles |
TextInterpretationMode |


AllowedSearchMethod Enumeration

public enum AllowedSearchMethod

Members

Member Name | Description
All |
ExactMatchOnly |
ExactMatchPlusBeginsWith |
None |

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: Metadata (in Metadata.dll)

See Also

Aptify.Framework.BusinessLogic Namespace


Aptify_TC_CL_Task_SaveException Class

For a list of all members of this type, see Aptify_TC_CL_Task_SaveException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
AptifyMergeException
Aptify_TC_CL_Task_SaveException

public class Aptify_TC_CL_Task_SaveException : AptifyMergeException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: AptifyMerge (in AptifyMerge.dll)

See Also

Aptify_TC_CL_Task_SaveException Members | Aptify.Framework.BusinessLogic Namespace


Aptify_TC_CL_Task_SaveException Members

Aptify_TC_CL_Task_SaveException overview

Public Instance Constructors

Aptify_TC_CL_Task_SaveException Constructor

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from AptifyMergeException) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Aptify_TC_CL_Task_SaveException Class | Aptify.Framework.BusinessLogic Namespace


Aptify_TC_CL_Task_SaveException Constructor

public Aptify_TC_CL_Task_SaveException(
String Message
);

See Also

Aptify_TC_CL_Task_SaveException Class | Aptify.Framework.BusinessLogic Namespace


AptifyDeleteSQLRole Class

For a list of all members of this type, see AptifyDeleteSQLRole Members.

System.Object
Exception
ApplicationException
BaseApplicationException
AptifyUserEntityException
AptifyDeleteSQLRole

public class AptifyDeleteSQLRole : AptifyUserEntityException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: AptifyUsersAndGroupsEntities (in AptifyUsersAndGroupsEntities.dll)

See Also

AptifyDeleteSQLRole Members | Aptify.Framework.BusinessLogic Namespace


AptifyDeleteSQLRole Members

AptifyDeleteSQLRole overview

Public Instance Constructors

AptifyDeleteSQLRole Constructor

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from AptifyUserEntityException) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyDeleteSQLRole Class | Aptify.Framework.BusinessLogic Namespace


AptifyDeleteSQLRole Constructor

public AptifyDeleteSQLRole(
String Message
);

See Also

AptifyDeleteSQLRole Class | Aptify.Framework.BusinessLogic Namespace


AptifyDMO Class

For a list of all members of this type, see AptifyDMO Members.

System.Object
AptifyDMO
SQLServerDMO

public class AptifyDMO

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: AptifyUsersAndGroupsEntities (in AptifyUsersAndGroupsEntities.dll)

See Also

AptifyDMO Members | Aptify.Framework.BusinessLogic Namespace


AptifyDMO Members

AptifyDMO overview

Public Instance Constructors

AptifyDMO Constructor

Public Instance Properties

AptifyRole |
DataAction |
Databases |
Exists |
IsTrusted |
RoleMembers |
Roles | Overloaded.
USE |
UserCredential |
UserInAptifyList |
UserInDatabase | Overloaded.
UserInFixedRoles |
UserInRole |
UserInRoles |

Public Instance Methods

AddAptifyRole |
AddAptifyRoles |
AddLogin | Overloaded.
AddRole |
AddRoles | Overloaded.
AddUser |
ChangePassword | Overloaded.
DefaultDatabase |
DropAptifyRole |
DropAptifyRoles |
DropRole |
DropRoles | Overloaded.
DropUser |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

IsAptifyRole
IsDbRole

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyDMO Class | Aptify.Framework.BusinessLogic Namespace


AptifyDMO Constructor

public AptifyDMO(
UserCredentials UserCredential,
String Database
);

See Also

AptifyDMO Class | Aptify.Framework.BusinessLogic Namespace


AptifyDMO Properties

The properties of the AptifyDMO class are listed below. For a complete list of AptifyDMO class members, see the AptifyDMO Members topic.

Public Instance Properties

AptifyRole |
DataAction |
Databases |
Exists |
IsTrusted |
RoleMembers |
Roles | Overloaded.
USE |
UserCredential |
UserInAptifyList |
UserInDatabase | Overloaded.
UserInFixedRoles |
UserInRole |
UserInRoles |

Protected Instance Properties

IsAptifyRole
IsDbRole

See Also

AptifyDMO Class | Aptify.Framework.BusinessLogic Namespace


AptifyRole Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDMO.AptifyRole Property

public abstract Role this[
String RoleName
] {get;}

See Also

AptifyDMO Class | Aptify.Framework.BusinessLogic Namespace


DataAction Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDMO.DataAction Property

public DataAction DataAction {get;}

See Also

AptifyDMO Class | Aptify.Framework.BusinessLogic Namespace


Databases Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDMO.Databases Property

public abstract ArrayList this[
Boolean AptifyOnly
] {get;}

See Also

AptifyDMO Class | Aptify.Framework.BusinessLogic Namespace


Exists Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDMO.Exists Property

public abstract Boolean this[
String User
] {get;}

See Also

AptifyDMO Class | Aptify.Framework.BusinessLogic Namespace


IsAptifyRole Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDMO.IsAptifyRole Property

protected Boolean this[
String Str
] {get;}

See Also

AptifyDMO Class | Aptify.Framework.BusinessLogic Namespace


IsDbRole Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDMO.IsDbRole Property

protected Boolean this[
String Str
] {get;}

See Also

AptifyDMO Class | Aptify.Framework.BusinessLogic Namespace


IsTrusted Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDMO.IsTrusted Property

public abstract Boolean this[
String User
] {get;}

See Also

AptifyDMO Class | Aptify.Framework.BusinessLogic Namespace


RoleMembers Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDMO.RoleMembers Property

public abstract ArrayList this[
String RoleName
] {get;}

See Also

AptifyDMO Class | Aptify.Framework.BusinessLogic Namespace


RoleCollection Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDMO.RoleCollection Property

Overload List

public abstract RoleCollection this[RoleType] {get;}

public abstract RoleCollection this[String, RoleType] {get;}

See Also

AptifyDMO Class | Aptify.Framework.BusinessLogic Namespace


Roles Property (RoleType)

Aptify 5.0 Software Development Kit (SDK)

AptifyDMO.Roles Property (RoleType)

public abstract RoleCollection this[
RoleType RoleType
] {get;}

See Also

AptifyDMO Class | Aptify.Framework.BusinessLogic Namespace | AptifyDMO.RoleCollection Overload List


Roles Property (String, RoleType)

Aptify 5.0 Software Development Kit (SDK)

AptifyDMO.Roles Property (String, RoleType)

public abstract RoleCollection this[
String User,
RoleType RoleType
] {get;}

See Also

AptifyDMO Class | Aptify.Framework.BusinessLogic Namespace | AptifyDMO.RoleCollection Overload List


USE Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDMO.USE Property

public String USE {get; set;}

See Also

AptifyDMO Class | Aptify.Framework.BusinessLogic Namespace


UserCredential Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDMO.UserCredential Property

public UserCredentials UserCredential {get;}

See Also

AptifyDMO Class | Aptify.Framework.BusinessLogic Namespace


UserInAptifyList Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDMO.UserInAptifyList Property

public abstract Boolean this[
String User
] {get;}

See Also

AptifyDMO Class | Aptify.Framework.BusinessLogic Namespace


Boolean Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDMO.Boolean Property

Overload List

public abstract Boolean this[String] {get;}

public abstract Boolean this[String, Boolean] {get;}

See Also

AptifyDMO Class | Aptify.Framework.BusinessLogic Namespace


UserInDatabase Property (String)

Aptify 5.0 Software Development Kit (SDK)

AptifyDMO.UserInDatabase Property (String)

public abstract Boolean this[
String User
] {get;}

See Also

AptifyDMO Class | Aptify.Framework.BusinessLogic Namespace | AptifyDMO.Boolean Overload List


UserInDatabase Property (String, Boolean)

Aptify 5.0 Software Development Kit (SDK)

AptifyDMO.UserInDatabase Property (String, Boolean)

public abstract Boolean this[
String User,
Boolean Explicit
] {get;}

See Also

AptifyDMO Class | Aptify.Framework.BusinessLogic Namespace | AptifyDMO.Boolean Overload List


UserInFixedRoles Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDMO.UserInFixedRoles Property

public abstract Boolean this[
String User,
ServerRoles ServerRoles,
DatabaseRoles DBRoles
] {get;}

See Also

AptifyDMO Class | Aptify.Framework.BusinessLogic Namespace


UserInRole Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDMO.UserInRole Property

public abstract Boolean this[
String User,
Role Role
] {get;}

See Also

AptifyDMO Class | Aptify.Framework.BusinessLogic Namespace


UserInRoles Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDMO.UserInRoles Property

public abstract Boolean this[
String User,
RoleCollection Roles
] {get;}

See Also

AptifyDMO Class | Aptify.Framework.BusinessLogic Namespace


AptifyDMO Methods

The methods of the AptifyDMO class are listed below. For a complete list of AptifyDMO class members, see the AptifyDMO Members topic.

Public Instance Methods

AddAptifyRole |
AddAptifyRoles |
AddLogin | Overloaded.
AddRole |
AddRoles | Overloaded.
AddUser |
ChangePassword | Overloaded.
DefaultDatabase |
DropAptifyRole |
DropAptifyRoles |
DropRole |
DropRoles | Overloaded.
DropUser |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyDMO Class | Aptify.Framework.BusinessLogic Namespace


AptifyDMO.AddAptifyRole Method

public abstract void AddAptifyRole(
Role Role
);

See Also

AptifyDMO Class | Aptify.Framework.BusinessLogic Namespace


AptifyDMO.AddAptifyRoles Method

public abstract void AddAptifyRoles(
RoleCollection Roles
);

See Also

AptifyDMO Class | Aptify.Framework.BusinessLogic Namespace


AddLogin Method

Aptify 5.0 Software Development Kit (SDK)

AptifyDMO.AddLogin Method

Overload List

public abstract bool AddLogin(String);

public abstract bool AddLogin(String,String);

public abstract bool AddLogin(String,String,ref String&);

See Also

AptifyDMO Class | Aptify.Framework.BusinessLogic Namespace


AptifyDMO.AddLogin Method (String)

public abstract bool AddLogin(
String User
);

See Also

AptifyDMO Class | Aptify.Framework.BusinessLogic Namespace | AptifyDMO.AddLogin Overload List


AptifyDMO.AddLogin Method (String, String)

public abstract bool AddLogin(
String User,
String Password
);

See Also

AptifyDMO Class | Aptify.Framework.BusinessLogic Namespace | AptifyDMO.AddLogin Overload List


AptifyDMO.AddLogin Method (String, String, String&)

public abstract bool AddLogin(
String User,
String Password,
ref String& sError
);

See Also

AptifyDMO Class | Aptify.Framework.BusinessLogic Namespace | AptifyDMO.AddLogin Overload List


AptifyDMO.AddRole Method

public abstract void AddRole(
String User,
Role Role
);

See Also

AptifyDMO Class | Aptify.Framework.BusinessLogic Namespace


AddRoles Method

Aptify 5.0 Software Development Kit (SDK)

AptifyDMO.AddRoles Method

Overload List

public abstract void AddRoles(String,RoleCollection);

public abstract void AddRoles(String,ServerRoles,DatabaseRoles);

See Also

AptifyDMO Class | Aptify.Framework.BusinessLogic Namespace


AptifyDMO.AddRoles Method (String, RoleCollection)

public abstract void AddRoles(
String User,
RoleCollection Roles
);

See Also

AptifyDMO Class | Aptify.Framework.BusinessLogic Namespace | AptifyDMO.AddRoles Overload List


AptifyDMO.AddRoles Method (String, ServerRoles, DatabaseRoles)

public abstract void AddRoles(
String User,
ServerRoles ServerRoles,
DatabaseRoles DBRoles
);

See Also

AptifyDMO Class | Aptify.Framework.BusinessLogic Namespace | AptifyDMO.AddRoles Overload List


AptifyDMO.AddUser Method

public abstract void AddUser(
String User
);

See Also

AptifyDMO Class | Aptify.Framework.BusinessLogic Namespace


ChangePassword Method

Aptify 5.0 Software Development Kit (SDK)

AptifyDMO.ChangePassword Method

Overload List

public abstract bool ChangePassword(String,String);

public abstract bool ChangePassword(String,String,ref String&);

See Also

AptifyDMO Class | Aptify.Framework.BusinessLogic Namespace


AptifyDMO.ChangePassword Method (String, String)

public abstract bool ChangePassword(
String User,
String Password
);

See Also

AptifyDMO Class | Aptify.Framework.BusinessLogic Namespace | AptifyDMO.ChangePassword Overload List


AptifyDMO.ChangePassword Method (String, String, String&)

public abstract bool ChangePassword(
String User,
String Password,
ref String& sError
);

See Also

AptifyDMO Class | Aptify.Framework.BusinessLogic Namespace | AptifyDMO.ChangePassword Overload List


AptifyDMO.DefaultDatabase Method

public abstract void DefaultDatabase(
String User,
String DefaultDB
);

See Also

AptifyDMO Class | Aptify.Framework.BusinessLogic Namespace


AptifyDMO.DropAptifyRole Method

public abstract void DropAptifyRole(
Role Role
);

See Also

AptifyDMO Class | Aptify.Framework.BusinessLogic Namespace


AptifyDMO.DropAptifyRoles Method

public abstract void DropAptifyRoles(
RoleCollection Roles
);

See Also

AptifyDMO Class | Aptify.Framework.BusinessLogic Namespace


AptifyDMO.DropRole Method

public abstract void DropRole(
String User,
Role Role
);

See Also

AptifyDMO Class | Aptify.Framework.BusinessLogic Namespace


DropRoles Method

Aptify 5.0 Software Development Kit (SDK)

AptifyDMO.DropRoles Method

Overload List

public abstract void DropRoles(String,RoleCollection);

public abstract void DropRoles(String,ServerRoles,DatabaseRoles);

See Also

AptifyDMO Class | Aptify.Framework.BusinessLogic Namespace


AptifyDMO.DropRoles Method (String, RoleCollection)

public abstract void DropRoles(
String User,
RoleCollection Roles
);

See Also

AptifyDMO Class | Aptify.Framework.BusinessLogic Namespace | AptifyDMO.DropRoles Overload List


AptifyDMO.DropRoles Method (String, ServerRoles, DatabaseRoles)

public abstract void DropRoles(
String User,
ServerRoles ServerRoles,
DatabaseRoles DBRoles
);

See Also

AptifyDMO Class | Aptify.Framework.BusinessLogic Namespace | AptifyDMO.DropRoles Overload List


AptifyDMO.DropUser Method

public abstract void DropUser(
String User
);

See Also

AptifyDMO Class | Aptify.Framework.BusinessLogic Namespace


AptifyGroupsEntity Class

For a list of all members of this type, see AptifyGroupsEntity Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
AptifyGroupsEntity

public class AptifyGroupsEntity : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: AptifyUsersAndGroupsEntities (in AptifyUsersAndGroupsEntities.dll)

See Also

AptifyGroupsEntity Members | Aptify.Framework.BusinessLogic Namespace


AptifyGroupsEntity Members

AptifyGroupsEntity overview

Public Instance Constructors

AptifyGroupsEntity Constructor Initializes a new instance of the AptifyGroupsEntity class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete | Overloaded.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

AptifyApplication |
AptifyDMO |
CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

AptifyGroupsEntity Class | Aptify.Framework.BusinessLogic Namespace


AptifyGroupsEntity Constructor

Initializes a new instance of the AptifyGroupsEntity class.

public AptifyGroupsEntity();

See Also

AptifyGroupsEntity Class | Aptify.Framework.BusinessLogic Namespace


AptifyGroupsEntity Properties

The properties of the AptifyGroupsEntity class are listed below. For a complete list of AptifyGroupsEntity class members, see the AptifyGroupsEntity Members topic.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Protected Instance Properties

AptifyApplication |
AptifyDMO |
CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

AptifyGroupsEntity Class | Aptify.Framework.BusinessLogic Namespace


AptifyApplication Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGroupsEntity.AptifyApplication Property

protected AptifyApplication AptifyApplication {get;}

See Also

AptifyGroupsEntity Class | Aptify.Framework.BusinessLogic Namespace


AptifyDMO Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGroupsEntity.AptifyDMO Property

protected AptifyDMO AptifyDMO {get;}

See Also

AptifyGroupsEntity Class | Aptify.Framework.BusinessLogic Namespace


AptifyGroupsEntity Methods

The methods of the AptifyGroupsEntity class are listed below. For a complete list of AptifyGroupsEntity class members, see the AptifyGroupsEntity Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete | Overloaded.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

AptifyGroupsEntity Class | Aptify.Framework.BusinessLogic Namespace


Delete Method

Aptify 5.0 Software Development Kit (SDK)

AptifyGroupsEntity.Delete Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Delete();

public override bool Delete(String);

See Also

AptifyGroupsEntity Class | Aptify.Framework.BusinessLogic Namespace


AptifyGroupsEntity.Delete Method (String)

public override bool Delete(
String TransactionID
);

See Also

AptifyGroupsEntity Class | Aptify.Framework.BusinessLogic Namespace | AptifyGroupsEntity.Delete Overload List


Save Method

Aptify 5.0 Software Development Kit (SDK)

AptifyGroupsEntity.Save Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Save();

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean,ref String&);

public override bool Save(Boolean,ref String&,String);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(ref String&);

See Also

AptifyGroupsEntity Class | Aptify.Framework.BusinessLogic Namespace


AptifyGroupsEntity.Save Method (Boolean, String&, String)

public override bool Save(
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

See Also

AptifyGroupsEntity Class | Aptify.Framework.BusinessLogic Namespace | AptifyGroupsEntity.Save Overload List


Validate Method

Aptify 5.0 Software Development Kit (SDK)

AptifyGroupsEntity.Validate Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Validate();

public override bool Validate(ref String&);

See Also

AptifyGroupsEntity Class | Aptify.Framework.BusinessLogic Namespace


AptifyGroupsEntity.Validate Method (String&)

public override bool Validate(
ref String& ErrorString
);

See Also

AptifyGroupsEntity Class | Aptify.Framework.BusinessLogic Namespace | AptifyGroupsEntity.Validate Overload List


AptifyLoadMergeException Class

For a list of all members of this type, see AptifyLoadMergeException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
AptifyMergeException
AptifyLoadMergeException

public class AptifyLoadMergeException : AptifyMergeException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: AptifyMerge (in AptifyMerge.dll)

See Also

AptifyLoadMergeException Members | Aptify.Framework.BusinessLogic Namespace


AptifyLoadMergeException Members

AptifyLoadMergeException overview

Public Instance Constructors

AptifyLoadMergeException Constructor

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from AptifyMergeException) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyLoadMergeException Class | Aptify.Framework.BusinessLogic Namespace


AptifyLoadMergeException Constructor

public AptifyLoadMergeException(
String Message
);

See Also

AptifyLoadMergeException Class | Aptify.Framework.BusinessLogic Namespace


AptifyMergeException Class

For a list of all members of this type, see AptifyMergeException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
AptifyMergeException
Derived types

public class AptifyMergeException : BaseApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: AptifyMerge (in AptifyMerge.dll)

See Also

AptifyMergeException Members | Aptify.Framework.BusinessLogic Namespace


AptifyMergeException Members

AptifyMergeException overview

Public Instance Constructors

AptifyMergeException Overloaded. Initializes a new instance of the AptifyMergeException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Constructors

AptifyMergeException Overloaded. Initializes a new instance of the AptifyMergeException class.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyMergeException Class | Aptify.Framework.BusinessLogic Namespace


AptifyMergeException Constructor

Overload List

protected AptifyMergeException(SerializationInfo,StreamingContext);

public AptifyMergeException(String);

See Also

AptifyMergeException Class | Aptify.Framework.BusinessLogic Namespace


AptifyMergeException Constructor (String)

public AptifyMergeException(
String Message
);

See Also

AptifyMergeException Class | Aptify.Framework.BusinessLogic Namespace | AptifyMergeException Constructor Overload List


AptifyMergeException Constructor (SerializationInfo, StreamingContext)

protected AptifyMergeException(
SerializationInfo info,
StreamingContext context
);

See Also

AptifyMergeException Class | Aptify.Framework.BusinessLogic Namespace | AptifyMergeException Constructor Overload List


AptifyMergeException Methods

The methods of the AptifyMergeException class are listed below. For a complete list of AptifyMergeException class members, see the AptifyMergeException Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyMergeException Class | Aptify.Framework.BusinessLogic Namespace


AptifyMergeException.GetObjectData Method

public override void GetObjectData(
SerializationInfo info,
StreamingContext context
);

Implements

ISerializable.

See Also

AptifyMergeException Class | Aptify.Framework.BusinessLogic Namespace


AptifyNull_TC_CL_Task_GEException Class

For a list of all members of this type, see AptifyNull_TC_CL_Task_GEException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
AptifyMergeException
AptifyNull_TC_CL_Task_GEException

public class AptifyNull_TC_CL_Task_GEException : AptifyMergeException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: AptifyMerge (in AptifyMerge.dll)

See Also

AptifyNull_TC_CL_Task_GEException Members | Aptify.Framework.BusinessLogic Namespace


AptifyNull_TC_CL_Task_GEException Members

AptifyNull_TC_CL_Task_GEException overview

Public Instance Constructors

AptifyNull_TC_CL_Task_GEException Constructor

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from AptifyMergeException) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyNull_TC_CL_Task_GEException Class | Aptify.Framework.BusinessLogic Namespace


AptifyNull_TC_CL_Task_GEException Constructor

public AptifyNull_TC_CL_Task_GEException(
String Message
);

See Also

AptifyNull_TC_CL_Task_GEException Class | Aptify.Framework.BusinessLogic Namespace


AptifyNullKeepIDOrEntityNameException Class

For a list of all members of this type, see AptifyNullKeepIDOrEntityNameException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
AptifyMergeException
AptifyNullKeepIDOrEntityNameException

public class AptifyNullKeepIDOrEntityNameException : AptifyMergeException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: AptifyMerge (in AptifyMerge.dll)

See Also

AptifyNullKeepIDOrEntityNameException Members | Aptify.Framework.BusinessLogic Namespace


AptifyNullKeepIDOrEntityNameException Members

AptifyNullKeepIDOrEntityNameException overview

Public Instance Constructors

AptifyNullKeepIDOrEntityNameException Constructor

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from AptifyMergeException) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyNullKeepIDOrEntityNameException Class | Aptify.Framework.BusinessLogic Namespace


AptifyNullKeepIDOrEntityNameException Constructor

public AptifyNullKeepIDOrEntityNameException(
String Message
);

See Also

AptifyNullKeepIDOrEntityNameException Class | Aptify.Framework.BusinessLogic Namespace


AptifyNullMergeIDException Class

For a list of all members of this type, see AptifyNullMergeIDException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
AptifyMergeException
AptifyNullMergeIDException

public class AptifyNullMergeIDException : AptifyMergeException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: AptifyMerge (in AptifyMerge.dll)

See Also

AptifyNullMergeIDException Members | Aptify.Framework.BusinessLogic Namespace


AptifyNullMergeIDException Members

AptifyNullMergeIDException overview

Public Instance Constructors

AptifyNullMergeIDException Constructor

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from AptifyMergeException) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyNullMergeIDException Class | Aptify.Framework.BusinessLogic Namespace


AptifyNullMergeIDException Constructor

public AptifyNullMergeIDException(
String Message
);

See Also

AptifyNullMergeIDException Class | Aptify.Framework.BusinessLogic Namespace


AptifyQuotesNotAllowed Class

For a list of all members of this type, see AptifyQuotesNotAllowed Members.

System.Object
Exception
ApplicationException
BaseApplicationException
AptifyUserEntityException
AptifyQuotesNotAllowed

public class AptifyQuotesNotAllowed : AptifyUserEntityException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: AptifyUsersAndGroupsEntities (in AptifyUsersAndGroupsEntities.dll)

See Also

AptifyQuotesNotAllowed Members | Aptify.Framework.BusinessLogic Namespace


AptifyQuotesNotAllowed Members

AptifyQuotesNotAllowed overview

Public Instance Constructors

AptifyQuotesNotAllowed Constructor

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from AptifyUserEntityException) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyQuotesNotAllowed Class | Aptify.Framework.BusinessLogic Namespace


AptifyQuotesNotAllowed Constructor

public AptifyQuotesNotAllowed(
String Message
);

See Also

AptifyQuotesNotAllowed Class | Aptify.Framework.BusinessLogic Namespace


AptifyRelinkMergeException Class

For a list of all members of this type, see AptifyRelinkMergeException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
AptifyMergeException
AptifyRelinkMergeException

public class AptifyRelinkMergeException : AptifyMergeException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: AptifyMerge (in AptifyMerge.dll)

See Also

AptifyRelinkMergeException Members | Aptify.Framework.BusinessLogic Namespace


AptifyRelinkMergeException Members

AptifyRelinkMergeException overview

Public Instance Constructors

AptifyRelinkMergeException Constructor

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from AptifyMergeException) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyRelinkMergeException Class | Aptify.Framework.BusinessLogic Namespace


AptifyRelinkMergeException Constructor

public AptifyRelinkMergeException(
String Message
);

See Also

AptifyRelinkMergeException Class | Aptify.Framework.BusinessLogic Namespace


AptifySaveMergeException Class

For a list of all members of this type, see AptifySaveMergeException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
AptifyMergeException
AptifySaveMergeException

public class AptifySaveMergeException : AptifyMergeException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: AptifyMerge (in AptifyMerge.dll)

See Also

AptifySaveMergeException Members | Aptify.Framework.BusinessLogic Namespace


AptifySaveMergeException Members

AptifySaveMergeException overview

Public Instance Constructors

AptifySaveMergeException Constructor

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from AptifyMergeException) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifySaveMergeException Class | Aptify.Framework.BusinessLogic Namespace


AptifySaveMergeException Constructor

public AptifySaveMergeException(
String Message
);

See Also

AptifySaveMergeException Class | Aptify.Framework.BusinessLogic Namespace


AptifySecurityException Class

For a list of all members of this type, see AptifySecurityException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
AptifyUserEntityException
AptifySecurityException

public class AptifySecurityException : AptifyUserEntityException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: AptifyUsersAndGroupsEntities (in AptifyUsersAndGroupsEntities.dll)

See Also

AptifySecurityException Members | Aptify.Framework.BusinessLogic Namespace


AptifySecurityException Members

AptifySecurityException overview

Public Instance Constructors

AptifySecurityException Constructor

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from AptifyUserEntityException) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifySecurityException Class | Aptify.Framework.BusinessLogic Namespace


AptifySecurityException Constructor

public AptifySecurityException(
String Message
);

See Also

AptifySecurityException Class | Aptify.Framework.BusinessLogic Namespace


AptifyUserEntityException Class

For a list of all members of this type, see AptifyUserEntityException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
AptifyUserEntityException
AptifyDeleteSQLRole
AptifyQuotesNotAllowed
AptifySecurityException

public class AptifyUserEntityException : BaseApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: AptifyUsersAndGroupsEntities (in AptifyUsersAndGroupsEntities.dll)

See Also

AptifyUserEntityException Members | Aptify.Framework.BusinessLogic Namespace


AptifyUserEntityException Members

AptifyUserEntityException overview

Public Instance Constructors

AptifyUserEntityException Overloaded. Initializes a new instance of the AptifyUserEntityException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Constructors

AptifyUserEntityException Overloaded. Initializes a new instance of the AptifyUserEntityException class.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyUserEntityException Class | Aptify.Framework.BusinessLogic Namespace


AptifyUserEntityException Constructor

Overload List

protected AptifyUserEntityException(SerializationInfo,StreamingContext);

public AptifyUserEntityException(String);

See Also

AptifyUserEntityException Class | Aptify.Framework.BusinessLogic Namespace


AptifyUserEntityException Constructor (String)

public AptifyUserEntityException(
String Message
);

See Also

AptifyUserEntityException Class | Aptify.Framework.BusinessLogic Namespace | AptifyUserEntityException Constructor Overload List


AptifyUserEntityException Constructor (SerializationInfo, StreamingContext)

protected AptifyUserEntityException(
SerializationInfo info,
StreamingContext context
);

See Also

AptifyUserEntityException Class | Aptify.Framework.BusinessLogic Namespace | AptifyUserEntityException Constructor Overload List


AptifyUserEntityException Methods

The methods of the AptifyUserEntityException class are listed below. For a complete list of AptifyUserEntityException class members, see the AptifyUserEntityException Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyUserEntityException Class | Aptify.Framework.BusinessLogic Namespace


AptifyUserEntityException.GetObjectData Method

public override void GetObjectData(
SerializationInfo info,
StreamingContext context
);

Implements

ISerializable.

See Also

AptifyUserEntityException Class | Aptify.Framework.BusinessLogic Namespace


AptifyUsersEntity Class

For a list of all members of this type, see AptifyUsersEntity Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
AptifyUsersEntity

public class AptifyUsersEntity : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: AptifyUsersAndGroupsEntities (in AptifyUsersAndGroupsEntities.dll)

See Also

AptifyUsersEntity Members | Aptify.Framework.BusinessLogic Namespace


AptifyUsersEntity Members

AptifyUsersEntity overview

Public Instance Constructors

AptifyUsersEntity Constructor Initializes a new instance of the AptifyUsersEntity class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CopyUserID |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DatabaseRoles |
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config | Overloaded.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded.
Delete | Overloaded.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

AptifyDMO |
CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

AptifyUsersEntity Class | Aptify.Framework.BusinessLogic Namespace


AptifyUsersEntity Constructor

Initializes a new instance of the AptifyUsersEntity class.

public AptifyUsersEntity();

See Also

AptifyUsersEntity Class | Aptify.Framework.BusinessLogic Namespace


AptifyUsersEntity Properties

The properties of the AptifyUsersEntity class are listed below. For a complete list of AptifyUsersEntity class members, see the AptifyUsersEntity Members topic.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CopyUserID |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DatabaseRoles |
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Protected Instance Properties

AptifyDMO |
CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

AptifyUsersEntity Class | Aptify.Framework.BusinessLogic Namespace


AptifyDMO Property

Aptify 5.0 Software Development Kit (SDK)

AptifyUsersEntity.AptifyDMO Property

protected AptifyDMO AptifyDMO {get;}

See Also

AptifyUsersEntity Class | Aptify.Framework.BusinessLogic Namespace


CopyUserID Property

Aptify 5.0 Software Development Kit (SDK)

AptifyUsersEntity.CopyUserID Property

public Int64 CopyUserID {get; set;}

See Also

AptifyUsersEntity Class | Aptify.Framework.BusinessLogic Namespace


DatabaseRoles Property

Aptify 5.0 Software Development Kit (SDK)

AptifyUsersEntity.DatabaseRoles Property

public DatabaseRoleCollection DatabaseRoles {get;}

See Also

AptifyUsersEntity Class | Aptify.Framework.BusinessLogic Namespace


AptifyUsersEntity Methods

The methods of the AptifyUsersEntity class are listed below. For a complete list of AptifyUsersEntity class members, see the AptifyUsersEntity Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config | Overloaded.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded.
Delete | Overloaded.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

AptifyUsersEntity Class | Aptify.Framework.BusinessLogic Namespace


Config Method

Aptify 5.0 Software Development Kit (SDK)

AptifyUsersEntity.Config Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual void Config(AptifySubTypeBase);

Inherited from AptifyGenericEntity.

public override void Config(AptifySubTypeBase,Int64);

public override void Config(UserCredentials,String);

Inherited from AptifyGenericEntity.

public override void Config(UserCredentials,String,Int64);

See Also

AptifyUsersEntity Class | Aptify.Framework.BusinessLogic Namespace


AptifyUsersEntity.Config Method (UserCredentials, String)

public override void Config(
UserCredentials UserCredentials,
String EntityName
);

See Also

AptifyUsersEntity Class | Aptify.Framework.BusinessLogic Namespace | AptifyUsersEntity.Config Overload List


Delete Method

Aptify 5.0 Software Development Kit (SDK)

AptifyUsersEntity.Delete Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Delete();

public override bool Delete(String);

See Also

AptifyUsersEntity Class | Aptify.Framework.BusinessLogic Namespace


AptifyUsersEntity.Delete Method (String)

public override bool Delete(
String TransactionID
);

See Also

AptifyUsersEntity Class | Aptify.Framework.BusinessLogic Namespace | AptifyUsersEntity.Delete Overload List


Save Method

Aptify 5.0 Software Development Kit (SDK)

AptifyUsersEntity.Save Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Save();

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean,ref String&);

public override bool Save(Boolean,ref String&,String);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(ref String&);

See Also

AptifyUsersEntity Class | Aptify.Framework.BusinessLogic Namespace


AptifyUsersEntity.Save Method (Boolean, String&, String)

public override bool Save(
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

See Also

AptifyUsersEntity Class | Aptify.Framework.BusinessLogic Namespace | AptifyUsersEntity.Save Overload List


Validate Method

Aptify 5.0 Software Development Kit (SDK)

AptifyUsersEntity.Validate Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Validate();

public override bool Validate(ref String&);

See Also

AptifyUsersEntity Class | Aptify.Framework.BusinessLogic Namespace


AptifyUsersEntity.Validate Method (String&)

public override bool Validate(
ref String& ErrorString
);

See Also

AptifyUsersEntity Class | Aptify.Framework.BusinessLogic Namespace | AptifyUsersEntity.Validate Overload List


CommandMetaData Class

This class represents an instance of meta-data for a specific Command. The base class for CommandMetaData is FormTemplateMetadataBase. While this class has nothing to do with the Form Template architecture, the base class in Form Template Meta-data provides useful generic functionality that is leveraged here.

For a list of all members of this type, see CommandMetaData Members.

System.Object
FormTemplateMetadataBase
CommandMetaData

public class CommandMetaData : FormTemplateMetadataBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: AptifyCommandMetaData (in AptifyCommandMetaData.dll)

See Also

CommandMetaData Members | Aptify.Framework.BusinessLogic Namespace


CommandMetaData Members

CommandMetaData overview

Public Instance Constructors

CommandMetaData Overloaded. Initializes a new instance of the CommandMetaData class.

Public Instance Properties

Application (inherited from FormTemplateMetadataBase)
Assembly
Category
CategoryID
Class
CommandID
Comments
CultureString
CultureStringID
Data (inherited from FormTemplateMetadataBase)
DataAction (inherited from FormTemplateMetadataBase)
Description
Item (inherited from FormTemplateMetadataBase)
Key
Name
Object
Parent
ParentID
ToolTipCultureString
ToolTipCultureStringID

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Refresh | Refresh the Form Template meta-data in the database
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

Database (inherited from FormTemplateMetadataBase)
DataRow (inherited from FormTemplateMetadataBase)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CommandMetaData Class | Aptify.Framework.BusinessLogic Namespace


CommandMetaData Constructor

Overload List

public CommandMetaData(AptifyApplication,DataAction,DataRow);

public CommandMetaData(AptifyApplication,DataAction,Int64);

See Also

CommandMetaData Class | Aptify.Framework.BusinessLogic Namespace


CommandMetaData Constructor (AptifyApplication, DataAction, Int64)

public CommandMetaData(
AptifyApplication Application,
DataAction DataAction,
Int64 CommandID
);

See Also

CommandMetaData Class | Aptify.Framework.BusinessLogic Namespace | CommandMetaData Constructor Overload List


CommandMetaData Constructor (AptifyApplication, DataAction, DataRow)

public CommandMetaData(
AptifyApplication Application,
DataAction DataAction,
DataRow DataRow
);

See Also

CommandMetaData Class | Aptify.Framework.BusinessLogic Namespace | CommandMetaData Constructor Overload List


CommandMetaData Properties

The properties of the CommandMetaData class are listed below. For a complete list of CommandMetaData class members, see the CommandMetaData Members topic.

Public Instance Properties

Application (inherited from FormTemplateMetadataBase)
Assembly
Category
CategoryID
Class
CommandID
Comments
CultureString
CultureStringID
Data (inherited from FormTemplateMetadataBase)
DataAction (inherited from FormTemplateMetadataBase)
Description
Item (inherited from FormTemplateMetadataBase)
Key
Name
Object
Parent
ParentID
ToolTipCultureString
ToolTipCultureStringID

Protected Instance Properties

Database (inherited from FormTemplateMetadataBase)
DataRow (inherited from FormTemplateMetadataBase)

See Also

CommandMetaData Class | Aptify.Framework.BusinessLogic Namespace


Assembly Property

Aptify 5.0 Software Development Kit (SDK)

CommandMetaData.Assembly Property

public virtual String Assembly {get;}

See Also

CommandMetaData Class | Aptify.Framework.BusinessLogic Namespace


Category Property

Aptify 5.0 Software Development Kit (SDK)

CommandMetaData.Category Property

public virtual String Category {get;}

See Also

CommandMetaData Class | Aptify.Framework.BusinessLogic Namespace


CategoryID Property

Aptify 5.0 Software Development Kit (SDK)

CommandMetaData.CategoryID Property

public virtual Int64 CategoryID {get;}

See Also

CommandMetaData Class | Aptify.Framework.BusinessLogic Namespace


Class Property

Aptify 5.0 Software Development Kit (SDK)

CommandMetaData.Class Property

public virtual String Class {get;}

See Also

CommandMetaData Class | Aptify.Framework.BusinessLogic Namespace


CommandID Property

Aptify 5.0 Software Development Kit (SDK)

CommandMetaData.CommandID Property

public virtual Int64 CommandID {get;}

See Also

CommandMetaData Class | Aptify.Framework.BusinessLogic Namespace


Comments Property

Aptify 5.0 Software Development Kit (SDK)

CommandMetaData.Comments Property

public virtual String Comments {get;}

See Also

CommandMetaData Class | Aptify.Framework.BusinessLogic Namespace


CultureString Property

Aptify 5.0 Software Development Kit (SDK)

CommandMetaData.CultureString Property

public virtual String CultureString {get;}

See Also

CommandMetaData Class | Aptify.Framework.BusinessLogic Namespace


CultureStringID Property

Aptify 5.0 Software Development Kit (SDK)

CommandMetaData.CultureStringID Property

public virtual Int64 CultureStringID {get;}

See Also

CommandMetaData Class | Aptify.Framework.BusinessLogic Namespace


Description Property

Aptify 5.0 Software Development Kit (SDK)

CommandMetaData.Description Property

public virtual String Description {get;}

See Also

CommandMetaData Class | Aptify.Framework.BusinessLogic Namespace


Key Property

Aptify 5.0 Software Development Kit (SDK)

CommandMetaData.Key Property

public virtual String Key {get;}

See Also

CommandMetaData Class | Aptify.Framework.BusinessLogic Namespace


Name Property

Aptify 5.0 Software Development Kit (SDK)

CommandMetaData.Name Property

public virtual String Name {get;}

See Also

CommandMetaData Class | Aptify.Framework.BusinessLogic Namespace


Object Property

Aptify 5.0 Software Development Kit (SDK)

CommandMetaData.Object Property

public virtual String Object {get;}

See Also

CommandMetaData Class | Aptify.Framework.BusinessLogic Namespace


Parent Property

Aptify 5.0 Software Development Kit (SDK)

CommandMetaData.Parent Property

public virtual String Parent {get;}

See Also

CommandMetaData Class | Aptify.Framework.BusinessLogic Namespace


ParentID Property

Aptify 5.0 Software Development Kit (SDK)

CommandMetaData.ParentID Property

public virtual Int64 ParentID {get;}

See Also

CommandMetaData Class | Aptify.Framework.BusinessLogic Namespace


ToolTipCultureString Property

Aptify 5.0 Software Development Kit (SDK)

CommandMetaData.ToolTipCultureString Property

public virtual String ToolTipCultureString {get;}

See Also

CommandMetaData Class | Aptify.Framework.BusinessLogic Namespace


ToolTipCultureStringID Property

Aptify 5.0 Software Development Kit (SDK)

CommandMetaData.ToolTipCultureStringID Property

public virtual Int64 ToolTipCultureStringID {get;}

See Also

CommandMetaData Class | Aptify.Framework.BusinessLogic Namespace


CommandMetaData Methods

The methods of the CommandMetaData class are listed below. For a complete list of CommandMetaData class members, see the CommandMetaData Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Refresh | Refresh the Form Template meta-data in the database
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CommandMetaData Class | Aptify.Framework.BusinessLogic Namespace


CommandMetaData.Refresh Method

Refresh the Form Template meta-data in the database

public override void Refresh(
Boolean RefreshDataCache
);

Remarks

See Also

CommandMetaData Class | Aptify.Framework.BusinessLogic Namespace


CommandMetadataCache Class

This class handles the process of accessing the Command Meta-Data via its Shared Instance() method which returns a class instance that is shared amongst all of the various classes that need Command Meta-Data within a process. To look-up a meta-data record for a Command, simply access the Command Instance shared property and call the Commands property.

For a list of all members of this type, see CommandMetadataCache Members.

System.Object
CommandMetadataCache

public class CommandMetadataCache

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: AptifyCommandMetaData (in AptifyCommandMetaData.dll)

See Also

CommandMetadataCache Members | Aptify.Framework.BusinessLogic Namespace


CommandMetadataCache Members

CommandMetadataCache overview

Public Static Methods

Instance

Public Instance Constructors

CommandMetadataCache Constructor

Public Instance Properties

Commands Overloaded. This method will either return a Command meta-data object from the cache if one exists, or it will load a new meta-data instance if required.

Public Instance Methods

ClearCommand |
ClearCommands |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
LoadCommands | This method is responsible for loading up all of the commands in the database
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CommandMetadataCache Class | Aptify.Framework.BusinessLogic Namespace


CommandMetadataCache Constructor

public CommandMetadataCache(
AptifyApplication Application
);

See Also

CommandMetadataCache Class | Aptify.Framework.BusinessLogic Namespace


CommandMetadataCache Properties

The properties of the CommandMetadataCache class are listed below. For a complete list of CommandMetadataCache class members, see the CommandMetadataCache Members topic.

Public Instance Properties

Commands Overloaded. This method will either return a Command meta-data object from the cache if one exists, or it will load a new meta-data instance if required.

See Also

CommandMetadataCache Class | Aptify.Framework.BusinessLogic Namespace


CommandMetaData Property

Aptify 5.0 Software Development Kit (SDK)

CommandMetadataCache.CommandMetaData Property

This method will either return a Command meta-data object from the cache if one exists, or it will load a new meta-data instance if required.

Overload List

This method will either return a Command meta-data object from the cache if one exists, or it will load a new meta-data instance if required.

public virtual CommandMetaData this[Int64, Boolean] {get;}

This method will either return a Command meta-data object from the cache if one exists, or it will load a new meta-data instance if required.

public virtual CommandMetaData this[String, Boolean] {get;}

See Also

CommandMetadataCache Class | Aptify.Framework.BusinessLogic Namespace


Commands Property (Int64, Boolean)

Aptify 5.0 Software Development Kit (SDK)

CommandMetadataCache.Commands Property (Int64, Boolean)

This method will either return a Command meta-data object from the cache if one exists, or it will load a new meta-data instance if required.

public virtual CommandMetaData this[
Int64 CommandID,
Boolean ForceRefresh
] {get;}

Parameters

CommandID
ForceRefresh

Property Value

Remarks

See Also

CommandMetadataCache Class | Aptify.Framework.BusinessLogic Namespace | CommandMetadataCache.CommandMetaData Overload List


Commands Property (String, Boolean)

Aptify 5.0 Software Development Kit (SDK)

CommandMetadataCache.Commands Property (String, Boolean)

This method will either return a Command meta-data object from the cache if one exists, or it will load a new meta-data instance if required.

public virtual CommandMetaData this[
String CommandKey,
Boolean ForceRefresh
] {get;}

Parameters

CommandKey
KeyValue field of the Command record
ForceRefresh

Property Value

Remarks

See Also

CommandMetadataCache Class | Aptify.Framework.BusinessLogic Namespace | CommandMetadataCache.CommandMetaData Overload List


CommandMetadataCache Methods

The methods of the CommandMetadataCache class are listed below. For a complete list of CommandMetadataCache class members, see the CommandMetadataCache Members topic.

Public Static Methods

Instance

Public Instance Methods

ClearCommand |
ClearCommands |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
LoadCommands | This method is responsible for loading up all of the commands in the database
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CommandMetadataCache Class | Aptify.Framework.BusinessLogic Namespace


CommandMetadataCache.ClearCommand Method

public virtual void ClearCommand(
Int64 CommandID
);

See Also

CommandMetadataCache Class | Aptify.Framework.BusinessLogic Namespace


CommandMetadataCache.ClearCommands Method

public virtual void ClearCommands();

See Also

CommandMetadataCache Class | Aptify.Framework.BusinessLogic Namespace


CommandMetadataCache.Instance Method

public static CommandMetadataCache Instance(
AptifyApplication Application
);

See Also

CommandMetadataCache Class | Aptify.Framework.BusinessLogic Namespace


CommandMetadataCache.LoadCommands Method

This method is responsible for loading up all of the commands in the database

protected virtual void LoadCommands();

Remarks

See Also

CommandMetadataCache Class | Aptify.Framework.BusinessLogic Namespace


ConversionEventHandler Class

For a list of all members of this type, see ConversionEventHandler Members.

System.Object
ConversionEventHandler

public class ConversionEventHandler : ITypeLibImporterNotifySink

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: AptifyObjectRepositoryObjectsEntity (in AptifyObjectRepositoryObjectsEntity.dll)

See Also

ConversionEventHandler Members | Aptify.Framework.BusinessLogic Namespace


ConversionEventHandler Members

ConversionEventHandler overview

Public Instance Constructors

ConversionEventHandler Constructor Initializes a new instance of the ConversionEventHandler class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ReportEvent |
ResolveRef |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ConversionEventHandler Class | Aptify.Framework.BusinessLogic Namespace


ConversionEventHandler Constructor

Initializes a new instance of the ConversionEventHandler class.

public ConversionEventHandler();

See Also

ConversionEventHandler Class | Aptify.Framework.BusinessLogic Namespace


ConversionEventHandler Methods

The methods of the ConversionEventHandler class are listed below. For a complete list of ConversionEventHandler class members, see the ConversionEventHandler Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ReportEvent |
ResolveRef |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ConversionEventHandler Class | Aptify.Framework.BusinessLogic Namespace


ConversionEventHandler.ReportEvent Method

public void ReportEvent(
ImporterEventKind eventKind,
Int32 eventCode,
String eventMsg
);

Implements

ITypeLibImporterNotifySink.

See Also

ConversionEventHandler Class | Aptify.Framework.BusinessLogic Namespace


ConversionEventHandler.ResolveRef Method

public Assembly ResolveRef(
Object typeLib
);

Implements

ITypeLibImporterNotifySink.

See Also

ConversionEventHandler Class | Aptify.Framework.BusinessLogic Namespace


CountryMetaData Class

For a list of all members of this type, see CountryMetaData Members.

System.Object
ReadDataRow
CountryMetaData

public class CountryMetaData : ReadDataRow

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: Metadata (in Metadata.dll)

See Also

CountryMetaData Members | Aptify.Framework.BusinessLogic Namespace


CountryMetaData Members

CountryMetaData overview

Public Instance Properties

Country
DefaultCulture
DefaultCultureID
ID
ISOCode
TelephoneCode

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

CountryMetaData Class | Aptify.Framework.BusinessLogic Namespace


CountryMetaData Properties

The properties of the CountryMetaData class are listed below. For a complete list of CountryMetaData class members, see the CountryMetaData Members topic.

Public Instance Properties

Country
DefaultCulture
DefaultCultureID
ID
ISOCode
TelephoneCode

See Also

CountryMetaData Class | Aptify.Framework.BusinessLogic Namespace


Country Property

Aptify 5.0 Software Development Kit (SDK)

CountryMetaData.Country Property

public String Country {get;}

See Also

CountryMetaData Class | Aptify.Framework.BusinessLogic Namespace


DefaultCulture Property

Aptify 5.0 Software Development Kit (SDK)

CountryMetaData.DefaultCulture Property

public String DefaultCulture {get;}

See Also

CountryMetaData Class | Aptify.Framework.BusinessLogic Namespace


DefaultCultureID Property

Aptify 5.0 Software Development Kit (SDK)

CountryMetaData.DefaultCultureID Property

public Int64 DefaultCultureID {get;}

See Also

CountryMetaData Class | Aptify.Framework.BusinessLogic Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

CountryMetaData.ID Property

public Int64 ID {get;}

See Also

CountryMetaData Class | Aptify.Framework.BusinessLogic Namespace


ISOCode Property

Aptify 5.0 Software Development Kit (SDK)

CountryMetaData.ISOCode Property

public String ISOCode {get;}

See Also

CountryMetaData Class | Aptify.Framework.BusinessLogic Namespace


TelephoneCode Property

Aptify 5.0 Software Development Kit (SDK)

CountryMetaData.TelephoneCode Property

public String TelephoneCode {get;}

See Also

CountryMetaData Class | Aptify.Framework.BusinessLogic Namespace


CountryMetaDataList Class

For a list of all members of this type, see CountryMetaDataList Members.

System.Object
CountryMetaDataList

public class CountryMetaDataList : IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: Metadata (in Metadata.dll)

See Also

CountryMetaDataList Members | Aptify.Framework.BusinessLogic Namespace


CountryMetaDataList Members

CountryMetaDataList overview

Public Instance Properties

Count |
Item | Overloaded.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

CountryMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


CountryMetaDataList Properties

The properties of the CountryMetaDataList class are listed below. For a complete list of CountryMetaDataList class members, see the CountryMetaDataList Members topic.

Public Instance Properties

Count |
Item | Overloaded.

See Also

CountryMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


Count Property

Aptify 5.0 Software Development Kit (SDK)

CountryMetaDataList.Count Property

public Int32 Count {get;}

See Also

CountryMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


CountryMetaData Property

Aptify 5.0 Software Development Kit (SDK)

CountryMetaDataList.CountryMetaData Property

Overload List

public CountryMetaData this[Int32] {get;}

public CountryMetaData this[String] {get;}

See Also

CountryMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


Item Property (Int32)

Aptify 5.0 Software Development Kit (SDK)

CountryMetaDataList.Item Property (Int32)

public CountryMetaData this[
Int32 Index
] {get;}

See Also

CountryMetaDataList Class | Aptify.Framework.BusinessLogic Namespace | CountryMetaDataList.CountryMetaData Overload List


Item Property (String)

Aptify 5.0 Software Development Kit (SDK)

CountryMetaDataList.Item Property (String)

public CountryMetaData this[
String Name
] {get;}

See Also

CountryMetaDataList Class | Aptify.Framework.BusinessLogic Namespace | CountryMetaDataList.CountryMetaData Overload List


CountryMetaDataList Methods

The methods of the CountryMetaDataList class are listed below. For a complete list of CountryMetaDataList class members, see the CountryMetaDataList Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

CountryMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


CountryMetaDataList.GetEnumerator Method

public IEnumerator GetEnumerator();

Implements

IEnumerable.

See Also

CountryMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


CountryMetadataSingleton Class

For a list of all members of this type, see CountryMetadataSingleton Members.

System.Object
CountryMetadataSingleton

public class CountryMetadataSingleton

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: Metadata (in Metadata.dll)

See Also

CountryMetadataSingleton Members | Aptify.Framework.BusinessLogic Namespace


CountryMetadataSingleton Members

CountryMetadataSingleton overview

Public Static Properties

Instance Overloaded.

Public Instance Methods

AptifyCountryIDExists |
CountryMetaData | Overloaded.
CountryMetaDataFromCountryName |
CountryMetaDataFromTelephoneCode |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAptifyCountryIDFromCountryName |
GetAptifyCountryIDFromISOCode |
GetAptifyCountryIDFromTelephoneCode |
GetCountryName | Overloaded.
GetCountryNameFromTelephoneCode |
GetDefaultCultureID | Overloaded.
GetDefaultCultureIDFromCountryName |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetISOCode | Overloaded.
GetISOCodeFromTelephoneCode |
GetTelephoneCode | Overloaded.
GetTelephoneCodeFromCountryName |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

CountryMetadataSingleton Class | Aptify.Framework.BusinessLogic Namespace


CountryMetadataSingleton Properties

The properties of the CountryMetadataSingleton class are listed below. For a complete list of CountryMetadataSingleton class members, see the CountryMetadataSingleton Members topic.

Public Static Properties

Instance Overloaded.

See Also

CountryMetadataSingleton Class | Aptify.Framework.BusinessLogic Namespace


CountryMetadataSingleton Property

Aptify 5.0 Software Development Kit (SDK)

CountryMetadataSingleton.CountryMetadataSingleton Property

Overload List

public static CountryMetadataSingleton Instance {get;}

public static CountryMetadataSingleton this[Boolean] {get;}

See Also

CountryMetadataSingleton Class | Aptify.Framework.BusinessLogic Namespace


Instance Property

Aptify 5.0 Software Development Kit (SDK)

CountryMetadataSingleton.Instance Property

public static CountryMetadataSingleton Instance {get;}

See Also

CountryMetadataSingleton Class | Aptify.Framework.BusinessLogic Namespace | CountryMetadataSingleton.CountryMetadataSingleton Overload List


Instance Property (Boolean)

Aptify 5.0 Software Development Kit (SDK)

CountryMetadataSingleton.Instance Property (Boolean)

public static CountryMetadataSingleton this[
Boolean reload
] {get;}

See Also

CountryMetadataSingleton Class | Aptify.Framework.BusinessLogic Namespace | CountryMetadataSingleton.CountryMetadataSingleton Overload List


CountryMetadataSingleton Methods

The methods of the CountryMetadataSingleton class are listed below. For a complete list of CountryMetadataSingleton class members, see the CountryMetadataSingleton Members topic.

Public Instance Methods

AptifyCountryIDExists |
CountryMetaData | Overloaded.
CountryMetaDataFromCountryName |
CountryMetaDataFromTelephoneCode |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAptifyCountryIDFromCountryName |
GetAptifyCountryIDFromISOCode |
GetAptifyCountryIDFromTelephoneCode |
GetCountryName | Overloaded.
GetCountryNameFromTelephoneCode |
GetDefaultCultureID | Overloaded.
GetDefaultCultureIDFromCountryName |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetISOCode | Overloaded.
GetISOCodeFromTelephoneCode |
GetTelephoneCode | Overloaded.
GetTelephoneCodeFromCountryName |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

CountryMetadataSingleton Class | Aptify.Framework.BusinessLogic Namespace


CountryMetadataSingleton.AptifyCountryIDExists Method

public bool AptifyCountryIDExists(
Int64 CountryID,
UserCredentials UserCredential
);

See Also

CountryMetadataSingleton Class | Aptify.Framework.BusinessLogic Namespace


CountryMetaData Method

Aptify 5.0 Software Development Kit (SDK)

CountryMetadataSingleton.CountryMetaData Method

Overload List

public CountryMetaData CountryMetaData(Int64,UserCredentials);

public CountryMetaData CountryMetaData(String,UserCredentials);

See Also

CountryMetadataSingleton Class | Aptify.Framework.BusinessLogic Namespace


CountryMetadataSingleton.CountryMetaData Method (Int64, UserCredentials)

public CountryMetaData CountryMetaData(
Int64 AptifyCountryID,
UserCredentials UserCredential
);

See Also

CountryMetadataSingleton Class | Aptify.Framework.BusinessLogic Namespace | CountryMetadataSingleton.CountryMetaData Overload List


CountryMetadataSingleton.CountryMetaData Method (String, UserCredentials)

public CountryMetaData CountryMetaData(
String ISOCode,
UserCredentials UserCredential
);

See Also

CountryMetadataSingleton Class | Aptify.Framework.BusinessLogic Namespace | CountryMetadataSingleton.CountryMetaData Overload List


CountryMetadataSingleton.CountryMetaDataFromCountryName Method

public CountryMetaData CountryMetaDataFromCountryName(
String CountryName,
UserCredentials UserCredential
);

See Also

CountryMetadataSingleton Class | Aptify.Framework.BusinessLogic Namespace


CountryMetadataSingleton.CountryMetaDataFromTelephoneCode Method

public CountryMetaData CountryMetaDataFromTelephoneCode(
String TelephoneCode,
UserCredentials UserCredential
);

See Also

CountryMetadataSingleton Class | Aptify.Framework.BusinessLogic Namespace


CountryMetadataSingleton.GetAptifyCountryIDFromCountryName Method

public long GetAptifyCountryIDFromCountryName(
String CountryName,
UserCredentials UserCredential
);

See Also

CountryMetadataSingleton Class | Aptify.Framework.BusinessLogic Namespace


CountryMetadataSingleton.GetAptifyCountryIDFromISOCode Method

public long GetAptifyCountryIDFromISOCode(
String ISOCode,
UserCredentials UserCredential
);

See Also

CountryMetadataSingleton Class | Aptify.Framework.BusinessLogic Namespace


CountryMetadataSingleton.GetAptifyCountryIDFromTelephoneCode Method

public long GetAptifyCountryIDFromTelephoneCode(
String TelephoneCode,
UserCredentials UserCredential
);

See Also

CountryMetadataSingleton Class | Aptify.Framework.BusinessLogic Namespace


GetCountryName Method

Aptify 5.0 Software Development Kit (SDK)

CountryMetadataSingleton.GetCountryName Method

Overload List

public string GetCountryName(Int64,UserCredentials);

public string GetCountryName(String,UserCredentials);

See Also

CountryMetadataSingleton Class | Aptify.Framework.BusinessLogic Namespace


CountryMetadataSingleton.GetCountryName Method (Int64, UserCredentials)

public string GetCountryName(
Int64 CountryID,
UserCredentials UserCredential
);

See Also

CountryMetadataSingleton Class | Aptify.Framework.BusinessLogic Namespace | CountryMetadataSingleton.GetCountryName Overload List


CountryMetadataSingleton.GetCountryName Method (String, UserCredentials)

public string GetCountryName(
String ISOCode,
UserCredentials UserCredential
);

See Also

CountryMetadataSingleton Class | Aptify.Framework.BusinessLogic Namespace | CountryMetadataSingleton.GetCountryName Overload List


CountryMetadataSingleton.GetCountryNameFromTelephoneCode Method

public string GetCountryNameFromTelephoneCode(
String TelephoneCode,
UserCredentials UserCredential
);

See Also

CountryMetadataSingleton Class | Aptify.Framework.BusinessLogic Namespace


GetDefaultCultureID Method

Aptify 5.0 Software Development Kit (SDK)

CountryMetadataSingleton.GetDefaultCultureID Method

Overload List

public string GetDefaultCultureID(Int64,UserCredentials);

public string GetDefaultCultureID(String,UserCredentials);

See Also

CountryMetadataSingleton Class | Aptify.Framework.BusinessLogic Namespace


CountryMetadataSingleton.GetDefaultCultureID Method (Int64, UserCredentials)

public string GetDefaultCultureID(
Int64 CountryID,
UserCredentials UserCredential
);

See Also

CountryMetadataSingleton Class | Aptify.Framework.BusinessLogic Namespace | CountryMetadataSingleton.GetDefaultCultureID Overload List


CountryMetadataSingleton.GetDefaultCultureID Method (String, UserCredentials)

public string GetDefaultCultureID(
String ISOCode,
UserCredentials UserCredential
);

See Also

CountryMetadataSingleton Class | Aptify.Framework.BusinessLogic Namespace | CountryMetadataSingleton.GetDefaultCultureID Overload List


CountryMetadataSingleton.GetDefaultCultureIDFromCountryName Method

public string GetDefaultCultureIDFromCountryName(
String CountryName,
UserCredentials UserCredential
);

See Also

CountryMetadataSingleton Class | Aptify.Framework.BusinessLogic Namespace


GetISOCode Method

Aptify 5.0 Software Development Kit (SDK)

CountryMetadataSingleton.GetISOCode Method

Overload List

public string GetISOCode(Int64,UserCredentials);

public string GetISOCode(String,UserCredentials);

See Also

CountryMetadataSingleton Class | Aptify.Framework.BusinessLogic Namespace


CountryMetadataSingleton.GetISOCode Method (Int64, UserCredentials)

public string GetISOCode(
Int64 CountryID,
UserCredentials UserCredential
);

See Also

CountryMetadataSingleton Class | Aptify.Framework.BusinessLogic Namespace | CountryMetadataSingleton.GetISOCode Overload List


CountryMetadataSingleton.GetISOCode Method (String, UserCredentials)

public string GetISOCode(
String CountryName,
UserCredentials UserCredential
);

See Also

CountryMetadataSingleton Class | Aptify.Framework.BusinessLogic Namespace | CountryMetadataSingleton.GetISOCode Overload List


CountryMetadataSingleton.GetISOCodeFromTelephoneCode Method

public string GetISOCodeFromTelephoneCode(
String TelephoneCode,
UserCredentials UserCredential
);

See Also

CountryMetadataSingleton Class | Aptify.Framework.BusinessLogic Namespace


GetTelephoneCode Method

Aptify 5.0 Software Development Kit (SDK)

CountryMetadataSingleton.GetTelephoneCode Method

Overload List

public string GetTelephoneCode(Int64,UserCredentials);

public string GetTelephoneCode(String,UserCredentials);

See Also

CountryMetadataSingleton Class | Aptify.Framework.BusinessLogic Namespace


CountryMetadataSingleton.GetTelephoneCode Method (Int64, UserCredentials)

public string GetTelephoneCode(
Int64 CountryID,
UserCredentials UserCredential
);

See Also

CountryMetadataSingleton Class | Aptify.Framework.BusinessLogic Namespace | CountryMetadataSingleton.GetTelephoneCode Overload List


CountryMetadataSingleton.GetTelephoneCode Method (String, UserCredentials)

public string GetTelephoneCode(
String ISOCode,
UserCredentials UserCredential
);

See Also

CountryMetadataSingleton Class | Aptify.Framework.BusinessLogic Namespace | CountryMetadataSingleton.GetTelephoneCode Overload List


CountryMetadataSingleton.GetTelephoneCodeFromCountryName Method

public string GetTelephoneCodeFromCountryName(
String CountryName,
UserCredentials UserCredential
);

See Also

CountryMetadataSingleton Class | Aptify.Framework.BusinessLogic Namespace


CultureStringLocalMetaData Class

For a list of all members of this type, see CultureStringLocalMetaData Members.

System.Object
ReadDataRow
CultureStringLocalMetaData
CultureStringLocalMetaDataList

public class CultureStringLocalMetaData : ReadDataRow

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: Metadata (in Metadata.dll)

See Also

CultureStringLocalMetaData Members | Aptify.Framework.BusinessLogic Namespace


CultureStringLocalMetaData Members

CultureStringLocalMetaData overview

Public Instance Properties

Comments
Culture
CultureID
CultureStringID
LocalString
Sequence

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Fields

m_drCurrentRow (inherited from ReadDataRow)

Protected Instance Properties

CurrentRow (inherited from ReadDataRow)
Dt
Item (inherited from ReadDataRow)
Item (inherited from ReadDataRow)
Pkeys
Pos
Rows

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CultureStringLocalMetaData Class | Aptify.Framework.BusinessLogic Namespace


CultureStringLocalMetaData Properties

The properties of the CultureStringLocalMetaData class are listed below. For a complete list of CultureStringLocalMetaData class members, see the CultureStringLocalMetaData Members topic.

Public Instance Properties

Comments
Culture
CultureID
CultureStringID
LocalString
Sequence

Protected Instance Properties

CurrentRow (inherited from ReadDataRow)
Dt
Item (inherited from ReadDataRow)
Item (inherited from ReadDataRow)
Pkeys
Pos
Rows

See Also

CultureStringLocalMetaData Class | Aptify.Framework.BusinessLogic Namespace


Comments Property

Aptify 5.0 Software Development Kit (SDK)

CultureStringLocalMetaData.Comments Property

public String Comments {get;}

See Also

CultureStringLocalMetaData Class | Aptify.Framework.BusinessLogic Namespace


Culture Property

Aptify 5.0 Software Development Kit (SDK)

CultureStringLocalMetaData.Culture Property

public String Culture {get;}

See Also

CultureStringLocalMetaData Class | Aptify.Framework.BusinessLogic Namespace


CultureID Property

Aptify 5.0 Software Development Kit (SDK)

CultureStringLocalMetaData.CultureID Property

public Int64 CultureID {get;}

See Also

CultureStringLocalMetaData Class | Aptify.Framework.BusinessLogic Namespace


CultureStringID Property

Aptify 5.0 Software Development Kit (SDK)

CultureStringLocalMetaData.CultureStringID Property

public Int64 CultureStringID {get;}

See Also

CultureStringLocalMetaData Class | Aptify.Framework.BusinessLogic Namespace


Dt Property

Aptify 5.0 Software Development Kit (SDK)

CultureStringLocalMetaData.Dt Property

protected DataTable Dt {get; set;}

See Also

CultureStringLocalMetaData Class | Aptify.Framework.BusinessLogic Namespace


LocalString Property

Aptify 5.0 Software Development Kit (SDK)

CultureStringLocalMetaData.LocalString Property

public String LocalString {get;}

See Also

CultureStringLocalMetaData Class | Aptify.Framework.BusinessLogic Namespace


Pkeys Property

Aptify 5.0 Software Development Kit (SDK)

CultureStringLocalMetaData.Pkeys Property

protected Object[] Pkeys {get; set;}

See Also

CultureStringLocalMetaData Class | Aptify.Framework.BusinessLogic Namespace


Pos Property

Aptify 5.0 Software Development Kit (SDK)

CultureStringLocalMetaData.Pos Property

protected Int32 Pos {get; set;}

See Also

CultureStringLocalMetaData Class | Aptify.Framework.BusinessLogic Namespace


Rows Property

Aptify 5.0 Software Development Kit (SDK)

CultureStringLocalMetaData.Rows Property

protected DataRow[] Rows {get; set;}

See Also

CultureStringLocalMetaData Class | Aptify.Framework.BusinessLogic Namespace


Sequence Property

Aptify 5.0 Software Development Kit (SDK)

CultureStringLocalMetaData.Sequence Property

public Int32 Sequence {get;}

See Also

CultureStringLocalMetaData Class | Aptify.Framework.BusinessLogic Namespace


CultureStringLocalMetaDataList Class

For a list of all members of this type, see CultureStringLocalMetaDataList Members.

System.Object
ReadDataRow
CultureStringLocalMetaData
CultureStringLocalMetaDataList

public class CultureStringLocalMetaDataList : CultureStringLocalMetaData, IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: Metadata (in Metadata.dll)

See Also

CultureStringLocalMetaDataList Members | Aptify.Framework.BusinessLogic Namespace


CultureStringLocalMetaDataList Members

CultureStringLocalMetaDataList overview

Public Instance Properties

Comments (inherited from CultureStringLocalMetaData) |
Count |
Culture (inherited from CultureStringLocalMetaData) |
CultureID (inherited from CultureStringLocalMetaData) |
CultureStringID (inherited from CultureStringLocalMetaData) |
Item | Overloaded.
LocalString (inherited from CultureStringLocalMetaData) |
Sequence (inherited from CultureStringLocalMetaData) |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

CultureStringLocalMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


CultureStringLocalMetaDataList Properties

The properties of the CultureStringLocalMetaDataList class are listed below. For a complete list of CultureStringLocalMetaDataList class members, see the CultureStringLocalMetaDataList Members topic.

Public Instance Properties

Comments (inherited from CultureStringLocalMetaData) |
Count |
Culture (inherited from CultureStringLocalMetaData) |
CultureID (inherited from CultureStringLocalMetaData) |
CultureStringID (inherited from CultureStringLocalMetaData) |
Item | Overloaded.
LocalString (inherited from CultureStringLocalMetaData) |
Sequence (inherited from CultureStringLocalMetaData) |

See Also

CultureStringLocalMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


Count Property

Aptify 5.0 Software Development Kit (SDK)

CultureStringLocalMetaDataList.Count Property

public Int32 Count {get;}

See Also

CultureStringLocalMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


CultureStringLocalMetaData Property

Aptify 5.0 Software Development Kit (SDK)

CultureStringLocalMetaDataList.CultureStringLocalMetaData Property

Overload List

public CultureStringLocalMetaData this[Int32] {get;}

public CultureStringLocalMetaData this[String] {get;}

See Also

CultureStringLocalMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


Item Property (Int32)

Aptify 5.0 Software Development Kit (SDK)

CultureStringLocalMetaDataList.Item Property (Int32)

public CultureStringLocalMetaData this[
Int32 Index
] {get;}

See Also

CultureStringLocalMetaDataList Class | Aptify.Framework.BusinessLogic Namespace | CultureStringLocalMetaDataList.CultureStringLocalMetaData Overload List


Item Property (String)

Aptify 5.0 Software Development Kit (SDK)

CultureStringLocalMetaDataList.Item Property (String)

public CultureStringLocalMetaData this[
String Name
] {get;}

See Also

CultureStringLocalMetaDataList Class | Aptify.Framework.BusinessLogic Namespace | CultureStringLocalMetaDataList.CultureStringLocalMetaData Overload List


CultureStringLocalMetaDataList Methods

The methods of the CultureStringLocalMetaDataList class are listed below. For a complete list of CultureStringLocalMetaDataList class members, see the CultureStringLocalMetaDataList Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

CultureStringLocalMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


CultureStringLocalMetaDataList.GetEnumerator Method

public IEnumerator GetEnumerator();

Implements

IEnumerable.

See Also

CultureStringLocalMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


CultureStringMetaData Class

For a list of all members of this type, see CultureStringMetaData Members.

System.Object
ReadDataRow
CultureStringMetaData

public class CultureStringMetaData : ReadDataRow

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: Metadata (in Metadata.dll)

See Also

CultureStringMetaData Members | Aptify.Framework.BusinessLogic Namespace


CultureStringMetaData Members

CultureStringMetaData overview

Public Instance Properties

BaseString
Category
CategoryID
CultureStringName
Description
ID
Locals

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCultureLocalString | Overloaded.
GetCultureStringIDFromBaseString |
GetCultureStringMetaData | Overloaded.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

CultureStringMetaData Class | Aptify.Framework.BusinessLogic Namespace


CultureStringMetaData Properties

The properties of the CultureStringMetaData class are listed below. For a complete list of CultureStringMetaData class members, see the CultureStringMetaData Members topic.

Public Instance Properties

BaseString
Category
CategoryID
CultureStringName
Description
ID
Locals

See Also

CultureStringMetaData Class | Aptify.Framework.BusinessLogic Namespace


BaseString Property

Aptify 5.0 Software Development Kit (SDK)

CultureStringMetaData.BaseString Property

public String BaseString {get;}

See Also

CultureStringMetaData Class | Aptify.Framework.BusinessLogic Namespace


Category Property

Aptify 5.0 Software Development Kit (SDK)

CultureStringMetaData.Category Property

public String Category {get;}

See Also

CultureStringMetaData Class | Aptify.Framework.BusinessLogic Namespace


CategoryID Property

Aptify 5.0 Software Development Kit (SDK)

CultureStringMetaData.CategoryID Property

public Int64 CategoryID {get;}

See Also

CultureStringMetaData Class | Aptify.Framework.BusinessLogic Namespace


CultureStringName Property

Aptify 5.0 Software Development Kit (SDK)

CultureStringMetaData.CultureStringName Property

public String CultureStringName {get;}

See Also

CultureStringMetaData Class | Aptify.Framework.BusinessLogic Namespace


Description Property

Aptify 5.0 Software Development Kit (SDK)

CultureStringMetaData.Description Property

public String Description {get;}

See Also

CultureStringMetaData Class | Aptify.Framework.BusinessLogic Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

CultureStringMetaData.ID Property

public Int64 ID {get;}

See Also

CultureStringMetaData Class | Aptify.Framework.BusinessLogic Namespace


Locals Property

Aptify 5.0 Software Development Kit (SDK)

CultureStringMetaData.Locals Property

public CultureStringLocalMetaDataList Locals {get;}

See Also

CultureStringMetaData Class | Aptify.Framework.BusinessLogic Namespace


CultureStringMetaData Methods

The methods of the CultureStringMetaData class are listed below. For a complete list of CultureStringMetaData class members, see the CultureStringMetaData Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCultureLocalString | Overloaded.
GetCultureStringIDFromBaseString |
GetCultureStringMetaData | Overloaded.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

CultureStringMetaData Class | Aptify.Framework.BusinessLogic Namespace


GetCultureLocalString Method

Aptify 5.0 Software Development Kit (SDK)

CultureStringMetaData.GetCultureLocalString Method

Overload List

public string GetCultureLocalString(Int64,Int64);

public string GetCultureLocalString(String,Int64);

See Also

CultureStringMetaData Class | Aptify.Framework.BusinessLogic Namespace


CultureStringMetaData.GetCultureLocalString Method (Int64, Int64)

public string GetCultureLocalString(
Int64 CultureStringID,
Int64 CultureID
);

See Also

CultureStringMetaData Class | Aptify.Framework.BusinessLogic Namespace | CultureStringMetaData.GetCultureLocalString Overload List


CultureStringMetaData.GetCultureLocalString Method (String, Int64)

public string GetCultureLocalString(
String BaseString,
Int64 CultureID
);

See Also

CultureStringMetaData Class | Aptify.Framework.BusinessLogic Namespace | CultureStringMetaData.GetCultureLocalString Overload List


CultureStringMetaData.GetCultureStringIDFromBaseString Method

public long GetCultureStringIDFromBaseString(
String BaseString
);

See Also

CultureStringMetaData Class | Aptify.Framework.BusinessLogic Namespace


GetCultureStringMetaData Method

Aptify 5.0 Software Development Kit (SDK)

CultureStringMetaData.GetCultureStringMetaData Method

Overload List

public CultureStringMetaData GetCultureStringMetaData(Int64);

public CultureStringMetaData GetCultureStringMetaData(String);

See Also

CultureStringMetaData Class | Aptify.Framework.BusinessLogic Namespace


CultureStringMetaData.GetCultureStringMetaData Method (Int64)

public CultureStringMetaData GetCultureStringMetaData(
Int64 CultureStringID
);

See Also

CultureStringMetaData Class | Aptify.Framework.BusinessLogic Namespace | CultureStringMetaData.GetCultureStringMetaData Overload List


CultureStringMetaData.GetCultureStringMetaData Method (String)

public CultureStringMetaData GetCultureStringMetaData(
String BaseString
);

See Also

CultureStringMetaData Class | Aptify.Framework.BusinessLogic Namespace | CultureStringMetaData.GetCultureStringMetaData Overload List


CultureStringMetaDataList Class

For a list of all members of this type, see CultureStringMetaDataList Members.

System.Object
CultureStringMetaDataList

public class CultureStringMetaDataList : IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: Metadata (in Metadata.dll)

See Also

CultureStringMetaDataList Members | Aptify.Framework.BusinessLogic Namespace


CultureStringMetaDataList Members

CultureStringMetaDataList overview

Public Instance Properties

Count |
Item | Overloaded.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

CultureStringMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


CultureStringMetaDataList Properties

The properties of the CultureStringMetaDataList class are listed below. For a complete list of CultureStringMetaDataList class members, see the CultureStringMetaDataList Members topic.

Public Instance Properties

Count |
Item | Overloaded.

See Also

CultureStringMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


Count Property

Aptify 5.0 Software Development Kit (SDK)

CultureStringMetaDataList.Count Property

public Int32 Count {get;}

See Also

CultureStringMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


CultureStringMetaData Property

Aptify 5.0 Software Development Kit (SDK)

CultureStringMetaDataList.CultureStringMetaData Property

Overload List

public CultureStringMetaData this[Int32] {get;}

public CultureStringMetaData this[Int64] {get;}

public CultureStringMetaData this[String] {get;}

See Also

CultureStringMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


Item Property (Int32)

Aptify 5.0 Software Development Kit (SDK)

CultureStringMetaDataList.Item Property (Int32)

public CultureStringMetaData this[
Int32 Index
] {get;}

See Also

CultureStringMetaDataList Class | Aptify.Framework.BusinessLogic Namespace | CultureStringMetaDataList.CultureStringMetaData Overload List


Item Property (Int64)

Aptify 5.0 Software Development Kit (SDK)

CultureStringMetaDataList.Item Property (Int64)

public CultureStringMetaData this[
Int64 CultureStringID
] {get;}

See Also

CultureStringMetaDataList Class | Aptify.Framework.BusinessLogic Namespace | CultureStringMetaDataList.CultureStringMetaData Overload List


Item Property (String)

Aptify 5.0 Software Development Kit (SDK)

CultureStringMetaDataList.Item Property (String)

public CultureStringMetaData this[
String BaseString
] {get;}

See Also

CultureStringMetaDataList Class | Aptify.Framework.BusinessLogic Namespace | CultureStringMetaDataList.CultureStringMetaData Overload List


CultureStringMetaDataList Methods

The methods of the CultureStringMetaDataList class are listed below. For a complete list of CultureStringMetaDataList class members, see the CultureStringMetaDataList Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

CultureStringMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


CultureStringMetaDataList.GetEnumerator Method

public IEnumerator GetEnumerator();

Implements

IEnumerable.

See Also

CultureStringMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


CultureStringMetadataSingleton Class

For a list of all members of this type, see CultureStringMetadataSingleton Members.

System.Object
CultureStringMetadataSingleton

public class CultureStringMetadataSingleton

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: Metadata (in Metadata.dll)

See Also

CultureStringMetadataSingleton Members | Aptify.Framework.BusinessLogic Namespace


CultureStringMetadataSingleton Members

CultureStringMetadataSingleton overview

Public Static Properties

Instance Overloaded.

Public Instance Methods

CultureStringMetaData | Overloaded.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

CultureStringMetadataSingleton Class | Aptify.Framework.BusinessLogic Namespace


CultureStringMetadataSingleton Properties

The properties of the CultureStringMetadataSingleton class are listed below. For a complete list of CultureStringMetadataSingleton class members, see the CultureStringMetadataSingleton Members topic.

Public Static Properties

Instance Overloaded.

See Also

CultureStringMetadataSingleton Class | Aptify.Framework.BusinessLogic Namespace


CultureStringMetadataSingleton Property

Aptify 5.0 Software Development Kit (SDK)

CultureStringMetadataSingleton.CultureStringMetadataSingleton Property

Overload List

public static CultureStringMetadataSingleton Instance {get;}

public static CultureStringMetadataSingleton this[Boolean] {get;}

See Also

CultureStringMetadataSingleton Class | Aptify.Framework.BusinessLogic Namespace


Instance Property

Aptify 5.0 Software Development Kit (SDK)

CultureStringMetadataSingleton.Instance Property

public static CultureStringMetadataSingleton Instance {get;}

See Also

CultureStringMetadataSingleton Class | Aptify.Framework.BusinessLogic Namespace | CultureStringMetadataSingleton.CultureStringMetadataSingleton Overload List


Instance Property (Boolean)

Aptify 5.0 Software Development Kit (SDK)

CultureStringMetadataSingleton.Instance Property (Boolean)

public static CultureStringMetadataSingleton this[
Boolean reload
] {get;}

See Also

CultureStringMetadataSingleton Class | Aptify.Framework.BusinessLogic Namespace | CultureStringMetadataSingleton.CultureStringMetadataSingleton Overload List


CultureStringMetadataSingleton Methods

The methods of the CultureStringMetadataSingleton class are listed below. For a complete list of CultureStringMetadataSingleton class members, see the CultureStringMetadataSingleton Members topic.

Public Instance Methods

CultureStringMetaData | Overloaded.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

CultureStringMetadataSingleton Class | Aptify.Framework.BusinessLogic Namespace


CultureStringMetaData Method

Aptify 5.0 Software Development Kit (SDK)

CultureStringMetadataSingleton.CultureStringMetaData Method

Overload List

public CultureStringMetaData CultureStringMetaData(Int64,UserCredentials);

public CultureStringMetaData CultureStringMetaData(Int64,UserCredentials,Int64);

public CultureStringMetaData CultureStringMetaData(String,UserCredentials);

public CultureStringMetaData CultureStringMetaData(String,UserCredentials,Int64);

public CultureStringMetaData CultureStringMetaData(String,String,UserCredentials);

public CultureStringMetaData CultureStringMetaData(String,String,UserCredentials,Int64);

See Also

CultureStringMetadataSingleton Class | Aptify.Framework.BusinessLogic Namespace


CultureStringMetadataSingleton.CultureStringMetaData Method (Int64, UserCredentials)

public CultureStringMetaData CultureStringMetaData(
Int64 CultureStringID,
UserCredentials UserCredential
);

See Also

CultureStringMetadataSingleton Class | Aptify.Framework.BusinessLogic Namespace | CultureStringMetadataSingleton.CultureStringMetaData Overload List


CultureStringMetadataSingleton.CultureStringMetaData Method (Int64, UserCredentials, Int64)

public CultureStringMetaData CultureStringMetaData(
Int64 CultureStringID,
UserCredentials UserCredential,
Int64 CategoryId
);

See Also

CultureStringMetadataSingleton Class | Aptify.Framework.BusinessLogic Namespace | CultureStringMetadataSingleton.CultureStringMetaData Overload List


CultureStringMetadataSingleton.CultureStringMetaData Method (String, UserCredentials)

public CultureStringMetaData CultureStringMetaData(
String BaseString,
UserCredentials UserCredential
);

See Also

CultureStringMetadataSingleton Class | Aptify.Framework.BusinessLogic Namespace | CultureStringMetadataSingleton.CultureStringMetaData Overload List


CultureStringMetadataSingleton.CultureStringMetaData Method (String, UserCredentials, Int64)

public CultureStringMetaData CultureStringMetaData(
String BaseString,
UserCredentials UserCredential,
Int64 CategoryId
);

See Also

CultureStringMetadataSingleton Class | Aptify.Framework.BusinessLogic Namespace | CultureStringMetadataSingleton.CultureStringMetaData Overload List


CultureStringMetadataSingleton.CultureStringMetaData Method (String, String, UserCredentials)

public CultureStringMetaData CultureStringMetaData(
String CultureStringName,
String BaseString,
UserCredentials UserCredential
);

See Also

CultureStringMetadataSingleton Class | Aptify.Framework.BusinessLogic Namespace | CultureStringMetadataSingleton.CultureStringMetaData Overload List


CultureStringMetadataSingleton.CultureStringMetaData Method (String, String, UserCredentials, Int64)

public CultureStringMetaData CultureStringMetaData(
String CultureStringName,
String BaseString,
UserCredentials UserCredential,
Int64 CategoryId
);

See Also

CultureStringMetadataSingleton Class | Aptify.Framework.BusinessLogic Namespace | CultureStringMetadataSingleton.CultureStringMetaData Overload List


CultureUtility Class

For a list of all members of this type, see CultureUtility Members.

System.Object
CultureUtility

public class CultureUtility

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: Metadata (in Metadata.dll)

See Also

CultureUtility Members | Aptify.Framework.BusinessLogic Namespace


CultureUtility Members

CultureUtility overview

Public Static Methods

GetCultureLocal | Overloaded. This method will take base string, Culture ID and User Credentials and return a Culture Local String based on the parameters provided
GetDisplayNameWithCulture | Overloaded.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

CultureUtility Class | Aptify.Framework.BusinessLogic Namespace


CultureUtility Methods

The methods of the CultureUtility class are listed below. For a complete list of CultureUtility class members, see the CultureUtility Members topic.

Public Static Methods

GetCultureLocal | Overloaded. This method will take base string, Culture ID and User Credentials and return a Culture Local String based on the parameters provided
GetDisplayNameWithCulture | Overloaded.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

CultureUtility Class | Aptify.Framework.BusinessLogic Namespace


GetCultureLocal Method

Aptify 5.0 Software Development Kit (SDK)

CultureUtility.GetCultureLocal Method

Overload List

public static string GetCultureLocal(Int64,Int64,UserCredentials);

This method will take base string, Culture ID and User Credentials and return a Culture Local String based on the parameters provided

public static string GetCultureLocal(String,Int64,UserCredentials);

This method will take base string, Culture ID, User Credentials and Category Id, and return a Culture Local String based on the parameters provided. Category Id here will determine if we want to search Culture String from a certain category only.

public static string GetCultureLocal(String,Int64,UserCredentials,Int64);

This overload will take Culture String Name, Base String, Culture ID and User Credentials and will return a Culture Local String based on the parameters provided. If no Culture String is found for the Culture String Name provided then function will return Base String provided.

public static string GetCultureLocal(String,String,UserCredentials);

This overload will take Culture String Name, Base String, Culture ID, User Credentials and Category Id and will return a Culture Local String based on the parameters provided. Category Id here will determine if we want to search Culture String from a certain category only. If no Culture String is found for the Culture String Name provided then function will return Base String provided.

public static string GetCultureLocal(String,String,UserCredentials,Int64);

See Also

CultureUtility Class | Aptify.Framework.BusinessLogic Namespace


CultureUtility.GetCultureLocal Method (Int64, Int64, UserCredentials)

public static string GetCultureLocal(
Int64 CultureStringID,
Int64 CultureID,
UserCredentials UserCredentials
);

See Also

CultureUtility Class | Aptify.Framework.BusinessLogic Namespace | CultureUtility.GetCultureLocal Overload List


CultureUtility.GetCultureLocal Method (String, Int64, UserCredentials)

This method will take base string, Culture ID and User Credentials and return a Culture Local String based on the parameters provided

public static string GetCultureLocal(
String BaseString,
Int64 CultureID,
UserCredentials UserCredentials
);

Parameters

BaseString
CultureID
UserCredentials

Return Value

Remarks

See Also

CultureUtility Class | Aptify.Framework.BusinessLogic Namespace | CultureUtility.GetCultureLocal Overload List


CultureUtility.GetCultureLocal Method (String, Int64, UserCredentials, Int64)

This method will take base string, Culture ID, User Credentials and Category Id, and return a Culture Local String based on the parameters provided. Category Id here will determine if we want to search Culture String from a certain category only.

public static string GetCultureLocal(
String BaseString,
Int64 CultureID,
UserCredentials UserCredentials,
Int64 CategoryId
);

Parameters

BaseString
CultureID
UserCredentials
CategoryId

Return Value

Remarks

See Also

CultureUtility Class | Aptify.Framework.BusinessLogic Namespace | CultureUtility.GetCultureLocal Overload List


CultureUtility.GetCultureLocal Method (String, String, UserCredentials)

This overload will take Culture String Name, Base String, Culture ID and User Credentials and will return a Culture Local String based on the parameters provided. If no Culture String is found for the Culture String Name provided then function will return Base String provided.

public static string GetCultureLocal(
String CultureStringName,
String BaseString,
UserCredentials UserCredentials
);

Parameters

CultureStringName
BaseString
UserCredentials

Return Value

Remarks

See Also

CultureUtility Class | Aptify.Framework.BusinessLogic Namespace | CultureUtility.GetCultureLocal Overload List


CultureUtility.GetCultureLocal Method (String, String, UserCredentials, Int64)

This overload will take Culture String Name, Base String, Culture ID, User Credentials and Category Id and will return a Culture Local String based on the parameters provided. Category Id here will determine if we want to search Culture String from a certain category only. If no Culture String is found for the Culture String Name provided then function will return Base String provided.

public static string GetCultureLocal(
String CultureStringName,
String BaseString,
UserCredentials UserCredentials,
Int64 CategoryId
);

Parameters

CultureStringName
BaseString
UserCredentials
CategoryId

Return Value

Remarks

See Also

CultureUtility Class | Aptify.Framework.BusinessLogic Namespace | CultureUtility.GetCultureLocal Overload List


GetDisplayNameWithCulture Method

Aptify 5.0 Software Development Kit (SDK)

CultureUtility.GetDisplayNameWithCulture Method

Overload List

public static string GetDisplayNameWithCulture(Int64,Int64,Boolean,String,UserCredentials);

public static string GetDisplayNameWithCulture(Int64,Int64,String,UserCredentials);

See Also

CultureUtility Class | Aptify.Framework.BusinessLogic Namespace


CultureUtility.GetDisplayNameWithCulture Method (Int64, Int64, Boolean, String, UserCredentials)

public static string GetDisplayNameWithCulture(
Int64 CultureStringID,
Int64 CultureID,
Boolean AutoMapDisplayName,
String DisplayName,
UserCredentials UserCredentials
);

See Also

CultureUtility Class | Aptify.Framework.BusinessLogic Namespace | CultureUtility.GetDisplayNameWithCulture Overload List


CultureUtility.GetDisplayNameWithCulture Method (Int64, Int64, String, UserCredentials)

public static string GetDisplayNameWithCulture(
Int64 CultureStringID,
Int64 CultureID,
String DisplayName,
UserCredentials UserCredentials
);

See Also

CultureUtility Class | Aptify.Framework.BusinessLogic Namespace | CultureUtility.GetDisplayNameWithCulture Overload List


DatabaseRole Class

For a list of all members of this type, see DatabaseRole Members.

System.Object
DatabaseRole

public class DatabaseRole

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: AptifyUsersAndGroupsEntities (in AptifyUsersAndGroupsEntities.dll)

See Also

DatabaseRole Members | Aptify.Framework.BusinessLogic Namespace


DatabaseRole Members

DatabaseRole overview

Public Instance Constructors

DatabaseRole Constructor

Public Instance Properties

Database
Name

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DatabaseRole Class | Aptify.Framework.BusinessLogic Namespace


DatabaseRole Constructor

public DatabaseRole(
String Database,
String Role
);

See Also

DatabaseRole Class | Aptify.Framework.BusinessLogic Namespace


DatabaseRole Properties

The properties of the DatabaseRole class are listed below. For a complete list of DatabaseRole class members, see the DatabaseRole Members topic.

Public Instance Properties

Database
Name

See Also

DatabaseRole Class | Aptify.Framework.BusinessLogic Namespace


Database Property

Aptify 5.0 Software Development Kit (SDK)

DatabaseRole.Database Property

public String Database {get; set;}

See Also

DatabaseRole Class | Aptify.Framework.BusinessLogic Namespace


Name Property

Aptify 5.0 Software Development Kit (SDK)

DatabaseRole.Name Property

public String Name {get; set;}

See Also

DatabaseRole Class | Aptify.Framework.BusinessLogic Namespace


DatabaseRoleCollection Class

For a list of all members of this type, see DatabaseRoleCollection Members.

System.Object
CollectionBase
DatabaseRoleCollection

public class DatabaseRoleCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: AptifyUsersAndGroupsEntities (in AptifyUsersAndGroupsEntities.dll)

See Also

DatabaseRoleCollection Members | Aptify.Framework.BusinessLogic Namespace


DatabaseRoleCollection Members

DatabaseRoleCollection overview

Public Instance Constructors

DatabaseRoleCollection Constructor Initializes a new instance of the DatabaseRoleCollection class.

Public Instance Properties

Capacity (inherited from CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.

Public Instance Methods

Add |
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that iterates through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Remove |
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

DatabaseRoleCollection Class | Aptify.Framework.BusinessLogic Namespace


DatabaseRoleCollection Constructor

Initializes a new instance of the DatabaseRoleCollection class.

public DatabaseRoleCollection();

See Also

DatabaseRoleCollection Class | Aptify.Framework.BusinessLogic Namespace


DatabaseRoleCollection Methods

The methods of the DatabaseRoleCollection class are listed below. For a complete list of DatabaseRoleCollection class members, see the DatabaseRoleCollection Members topic.

Public Instance Methods

Add |
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that iterates through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Remove |
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

DatabaseRoleCollection Class | Aptify.Framework.BusinessLogic Namespace


DatabaseRoleCollection.Add Method

public void Add(
DatabaseRole Role
);

See Also

DatabaseRoleCollection Class | Aptify.Framework.BusinessLogic Namespace


DatabaseRoleCollection.Remove Method

public void Remove(
DatabaseRole Role
);

See Also

DatabaseRoleCollection Class | Aptify.Framework.BusinessLogic Namespace


DatabaseRoles Enumeration

public enum DatabaseRoles

Members

Member Name | Description
public |
db_owner |
db_accessadmin |
db_securityadmin |
db_ddladmin |
db_backupoperator |
db_datareader |
db_datawriter |
db_denydatareader |
db_denydatawriter |

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: AptifyUsersAndGroupsEntities (in AptifyUsersAndGroupsEntities.dll)

See Also

Aptify.Framework.BusinessLogic Namespace


DynamicSharingRelationshipMetaData Class

For a list of all members of this type, see DynamicSharingRelationshipMetaData Members.

System.Object
ReadDataRow
DynamicSharingRelationshipMetaData
DynamicSharingRelationshipMetaDataList

public class DynamicSharingRelationshipMetaData : ReadDataRow

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: Metadata (in Metadata.dll)

See Also

DynamicSharingRelationshipMetaData Members | Aptify.Framework.BusinessLogic Namespace


DynamicSharingRelationshipMetaData Members

DynamicSharingRelationshipMetaData overview

Public Instance Properties

DynamicFlowdownFilter
RelatedEntity
RelatedEntityField
Sequence

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Fields

m_drCurrentRow (inherited from ReadDataRow)

Protected Instance Properties

CurrentRow (inherited from ReadDataRow)
Item (inherited from ReadDataRow)
Item (inherited from ReadDataRow)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DynamicSharingRelationshipMetaData Class | Aptify.Framework.BusinessLogic Namespace


DynamicSharingRelationshipMetaData Properties

The properties of the DynamicSharingRelationshipMetaData class are listed below. For a complete list of DynamicSharingRelationshipMetaData class members, see the DynamicSharingRelationshipMetaData Members topic.

Public Instance Properties

DynamicFlowdownFilter
RelatedEntity
RelatedEntityField
Sequence

Protected Instance Properties

CurrentRow (inherited from ReadDataRow)
Item (inherited from ReadDataRow)
Item (inherited from ReadDataRow)

See Also

DynamicSharingRelationshipMetaData Class | Aptify.Framework.BusinessLogic Namespace


DynamicFlowdownFilter Property

Aptify 5.0 Software Development Kit (SDK)

DynamicSharingRelationshipMetaData.DynamicFlowdownFilter Property

public String DynamicFlowdownFilter {get;}

See Also

DynamicSharingRelationshipMetaData Class | Aptify.Framework.BusinessLogic Namespace


RelatedEntity Property

Aptify 5.0 Software Development Kit (SDK)

DynamicSharingRelationshipMetaData.RelatedEntity Property

public String RelatedEntity {get;}

See Also

DynamicSharingRelationshipMetaData Class | Aptify.Framework.BusinessLogic Namespace


RelatedEntityField Property

Aptify 5.0 Software Development Kit (SDK)

DynamicSharingRelationshipMetaData.RelatedEntityField Property

public String RelatedEntityField {get;}

See Also

DynamicSharingRelationshipMetaData Class | Aptify.Framework.BusinessLogic Namespace


Sequence Property

Aptify 5.0 Software Development Kit (SDK)

DynamicSharingRelationshipMetaData.Sequence Property

public Int32 Sequence {get;}

See Also

DynamicSharingRelationshipMetaData Class | Aptify.Framework.BusinessLogic Namespace


DynamicSharingRelationshipMetaDataList Class

For a list of all members of this type, see DynamicSharingRelationshipMetaDataList Members.

System.Object
ReadDataRow
DynamicSharingRelationshipMetaData
DynamicSharingRelationshipMetaDataList

public class DynamicSharingRelationshipMetaDataList : DynamicSharingRelationshipMetaData, IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: Metadata (in Metadata.dll)

See Also

DynamicSharingRelationshipMetaDataList Members | Aptify.Framework.BusinessLogic Namespace


DynamicSharingRelationshipMetaDataList Members

DynamicSharingRelationshipMetaDataList overview

Public Instance Properties

Count |
DynamicFlowdownFilter (inherited from DynamicSharingRelationshipMetaData) |
EntityFieldsID |
Item | Overloaded.
RelatedEntity (inherited from DynamicSharingRelationshipMetaData) |
RelatedEntityField (inherited from DynamicSharingRelationshipMetaData) |
Sequence (inherited from DynamicSharingRelationshipMetaData) |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

DynamicSharingRelationshipMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


DynamicSharingRelationshipMetaDataList Properties

The properties of the DynamicSharingRelationshipMetaDataList class are listed below. For a complete list of DynamicSharingRelationshipMetaDataList class members, see the DynamicSharingRelationshipMetaDataList Members topic.

Public Instance Properties

Count |
DynamicFlowdownFilter (inherited from DynamicSharingRelationshipMetaData) |
EntityFieldsID |
Item | Overloaded.
RelatedEntity (inherited from DynamicSharingRelationshipMetaData) |
RelatedEntityField (inherited from DynamicSharingRelationshipMetaData) |
Sequence (inherited from DynamicSharingRelationshipMetaData) |

See Also

DynamicSharingRelationshipMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


Count Property

Aptify 5.0 Software Development Kit (SDK)

DynamicSharingRelationshipMetaDataList.Count Property

public Int32 Count {get;}

See Also

DynamicSharingRelationshipMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


EntityFieldsID Property

Aptify 5.0 Software Development Kit (SDK)

DynamicSharingRelationshipMetaDataList.EntityFieldsID Property

public Int64 EntityFieldsID {get;}

See Also

DynamicSharingRelationshipMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


DynamicSharingRelationshipMetaData Property

Aptify 5.0 Software Development Kit (SDK)

DynamicSharingRelationshipMetaDataList.DynamicSharingRelationshipMetaData Property

Overload List

public DynamicSharingRelationshipMetaData this[Int32] {get;}

public DynamicSharingRelationshipMetaData this[String] {get;}

See Also

DynamicSharingRelationshipMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


Item Property (Int32)

Aptify 5.0 Software Development Kit (SDK)

DynamicSharingRelationshipMetaDataList.Item Property (Int32)

public DynamicSharingRelationshipMetaData this[
Int32 Index
] {get;}

See Also

DynamicSharingRelationshipMetaDataList Class | Aptify.Framework.BusinessLogic Namespace | DynamicSharingRelationshipMetaDataList.DynamicSharingRelationshipMetaData Overload List


Item Property (String)

Aptify 5.0 Software Development Kit (SDK)

DynamicSharingRelationshipMetaDataList.Item Property (String)

public DynamicSharingRelationshipMetaData this[
String Name
] {get;}

See Also

DynamicSharingRelationshipMetaDataList Class | Aptify.Framework.BusinessLogic Namespace | DynamicSharingRelationshipMetaDataList.DynamicSharingRelationshipMetaData Overload List


DynamicSharingRelationshipMetaDataList Methods

The methods of the DynamicSharingRelationshipMetaDataList class are listed below. For a complete list of DynamicSharingRelationshipMetaDataList class members, see the DynamicSharingRelationshipMetaDataList Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

DynamicSharingRelationshipMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


DynamicSharingRelationshipMetaDataList.GetEnumerator Method

public IEnumerator GetEnumerator();

Implements

IEnumerable.

See Also

DynamicSharingRelationshipMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


EmbeddedLinkSharingMode Enumeration

public enum EmbeddedLinkSharingMode

Members

Member Name | Description
None |
StaticShare |
Dynamic |

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: Metadata (in Metadata.dll)

See Also

Aptify.Framework.BusinessLogic Namespace


EntityBaseViewFieldMetaData Class

For a list of all members of this type, see EntityBaseViewFieldMetaData Members.

System.Object
ReadDataRow
EntityBaseViewFieldMetaData
EntityBaseViewFieldMetaDataList

public class EntityBaseViewFieldMetaData : ReadDataRow

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: Metadata (in Metadata.dll)

See Also

EntityBaseViewFieldMetaData Members | Aptify.Framework.BusinessLogic Namespace


EntityBaseViewFieldMetaData Members

EntityBaseViewFieldMetaData overview

Public Instance Properties

CalculatedFieldExpression
DefaultInvView
Description
DescriptionCultureStringID
DescriptionWithCulture
DisplayName
DisplayNameCultureStringID
DisplayNameWithCulture
Entity
EntityBaseView
EntityBaseViewID
EntityField
FieldType
ID
JoinedEntityBaseDatabase
JoinedEntityBaseTable
JoinedEntityBaseView
JoinForeignKey
JoinType
Name
Sequence
ShowInFind
SQLAllowNull
SQLDataType
SQLFieldSize
Width

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Fields

m_drCurrentRow (inherited from ReadDataRow)

Protected Instance Properties

CurrentRow (inherited from ReadDataRow)
Dt
Item (inherited from ReadDataRow)
Item (inherited from ReadDataRow)
Pkeys
Pos
Rows

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EntityBaseViewFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


EntityBaseViewFieldMetaData Properties

The properties of the EntityBaseViewFieldMetaData class are listed below. For a complete list of EntityBaseViewFieldMetaData class members, see the EntityBaseViewFieldMetaData Members topic.

Public Instance Properties

CalculatedFieldExpression
DefaultInvView
Description
DescriptionCultureStringID
DescriptionWithCulture
DisplayName
DisplayNameCultureStringID
DisplayNameWithCulture
Entity
EntityBaseView
EntityBaseViewID
EntityField
FieldType
ID
JoinedEntityBaseDatabase
JoinedEntityBaseTable
JoinedEntityBaseView
JoinForeignKey
JoinType
Name
Sequence
ShowInFind
SQLAllowNull
SQLDataType
SQLFieldSize
Width

Protected Instance Properties

CurrentRow (inherited from ReadDataRow)
Dt
Item (inherited from ReadDataRow)
Item (inherited from ReadDataRow)
Pkeys
Pos
Rows

See Also

EntityBaseViewFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


CalculatedFieldExpression Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewFieldMetaData.CalculatedFieldExpression Property

public String CalculatedFieldExpression {get;}

See Also

EntityBaseViewFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


DefaultInvView Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewFieldMetaData.DefaultInvView Property

public Boolean DefaultInvView {get;}

See Also

EntityBaseViewFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


Description Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewFieldMetaData.Description Property

public String Description {get;}

See Also

EntityBaseViewFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


DescriptionCultureStringID Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewFieldMetaData.DescriptionCultureStringID Property

public Int64 DescriptionCultureStringID {get;}

See Also

EntityBaseViewFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


DescriptionWithCulture Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewFieldMetaData.DescriptionWithCulture Property

public String this[
Int64 CultureID,
UserCredentials UserCredentials
] {get;}

See Also

EntityBaseViewFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


DisplayName Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewFieldMetaData.DisplayName Property

public String DisplayName {get;}

See Also

EntityBaseViewFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


DisplayNameCultureStringID Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewFieldMetaData.DisplayNameCultureStringID Property

public Int64 DisplayNameCultureStringID {get;}

See Also

EntityBaseViewFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


DisplayNameWithCulture Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewFieldMetaData.DisplayNameWithCulture Property

public String this[
Int64 CultureID,
UserCredentials UserCredentials
] {get;}

See Also

EntityBaseViewFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


Dt Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewFieldMetaData.Dt Property

protected DataTable Dt {get; set;}

See Also

EntityBaseViewFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


Entity Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewFieldMetaData.Entity Property

public String Entity {get;}

See Also

EntityBaseViewFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


EntityBaseView Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewFieldMetaData.EntityBaseView Property

public EntityBaseViewMetaData EntityBaseView {get;}

See Also

EntityBaseViewFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


EntityBaseViewID Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewFieldMetaData.EntityBaseViewID Property

public Int64 EntityBaseViewID {get;}

See Also

EntityBaseViewFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


EntityField Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewFieldMetaData.EntityField Property

public String EntityField {get;}

See Also

EntityBaseViewFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


FieldType Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewFieldMetaData.FieldType Property

public String FieldType {get;}

See Also

EntityBaseViewFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewFieldMetaData.ID Property

public Int64 ID {get;}

See Also

EntityBaseViewFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


JoinedEntityBaseDatabase Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewFieldMetaData.JoinedEntityBaseDatabase Property

public String JoinedEntityBaseDatabase {get;}

See Also

EntityBaseViewFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


JoinedEntityBaseTable Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewFieldMetaData.JoinedEntityBaseTable Property

public String JoinedEntityBaseTable {get;}

See Also

EntityBaseViewFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


JoinedEntityBaseView Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewFieldMetaData.JoinedEntityBaseView Property

public String JoinedEntityBaseView {get;}

See Also

EntityBaseViewFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


JoinForeignKey Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewFieldMetaData.JoinForeignKey Property

public String JoinForeignKey {get;}

See Also

EntityBaseViewFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


JoinType Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewFieldMetaData.JoinType Property

public String JoinType {get;}

See Also

EntityBaseViewFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


Name Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewFieldMetaData.Name Property

public String Name {get;}

See Also

EntityBaseViewFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


Pkeys Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewFieldMetaData.Pkeys Property

protected Object[] Pkeys {get; set;}

See Also

EntityBaseViewFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


Pos Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewFieldMetaData.Pos Property

protected Int32 Pos {get; set;}

See Also

EntityBaseViewFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


Rows Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewFieldMetaData.Rows Property

protected DataRow[] Rows {get; set;}

See Also

EntityBaseViewFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


Sequence Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewFieldMetaData.Sequence Property

public Int32 Sequence {get;}

See Also

EntityBaseViewFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


ShowInFind Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewFieldMetaData.ShowInFind Property

public Boolean ShowInFind {get;}

See Also

EntityBaseViewFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


SQLAllowNull Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewFieldMetaData.SQLAllowNull Property

public Boolean SQLAllowNull {get;}

See Also

EntityBaseViewFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


SQLDataType Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewFieldMetaData.SQLDataType Property

public String SQLDataType {get;}

See Also

EntityBaseViewFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


SQLFieldSize Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewFieldMetaData.SQLFieldSize Property

public Int32 SQLFieldSize {get;}

See Also

EntityBaseViewFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


Width Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewFieldMetaData.Width Property

public Int32 Width {get;}

See Also

EntityBaseViewFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


EntityBaseViewFieldMetaDataList Class

For a list of all members of this type, see EntityBaseViewFieldMetaDataList Members.

System.Object
ReadDataRow
EntityBaseViewFieldMetaData
EntityBaseViewFieldMetaDataList

public class EntityBaseViewFieldMetaDataList : EntityBaseViewFieldMetaData, IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: Metadata (in Metadata.dll)

See Also

EntityBaseViewFieldMetaDataList Members | Aptify.Framework.BusinessLogic Namespace


EntityBaseViewFieldMetaDataList Members

EntityBaseViewFieldMetaDataList overview

Public Instance Properties

CalculatedFieldExpression (inherited from EntityBaseViewFieldMetaData) |
Count |
DefaultInvView (inherited from EntityBaseViewFieldMetaData) |
Description (inherited from EntityBaseViewFieldMetaData) |
DescriptionCultureStringID (inherited from EntityBaseViewFieldMetaData) |
DescriptionWithCulture (inherited from EntityBaseViewFieldMetaData) |
DisplayName (inherited from EntityBaseViewFieldMetaData) |
DisplayNameCultureStringID (inherited from EntityBaseViewFieldMetaData) |
DisplayNameWithCulture (inherited from EntityBaseViewFieldMetaData) |
Entity (inherited from EntityBaseViewFieldMetaData) |
EntityBaseView (inherited from EntityBaseViewFieldMetaData) |
EntityBaseViewID (inherited from EntityBaseViewFieldMetaData) |
EntityField (inherited from EntityBaseViewFieldMetaData) |
FieldType (inherited from EntityBaseViewFieldMetaData) |
ID (inherited from EntityBaseViewFieldMetaData) |
Item | Overloaded.
JoinedEntityBaseDatabase (inherited from EntityBaseViewFieldMetaData) |
JoinedEntityBaseTable (inherited from EntityBaseViewFieldMetaData) |
JoinedEntityBaseView (inherited from EntityBaseViewFieldMetaData) |
JoinForeignKey (inherited from EntityBaseViewFieldMetaData) |
JoinType (inherited from EntityBaseViewFieldMetaData) |
Name (inherited from EntityBaseViewFieldMetaData) |
Sequence (inherited from EntityBaseViewFieldMetaData) |
ShowInFind (inherited from EntityBaseViewFieldMetaData) |
SQLAllowNull (inherited from EntityBaseViewFieldMetaData) |
SQLDataType (inherited from EntityBaseViewFieldMetaData) |
SQLFieldSize (inherited from EntityBaseViewFieldMetaData) |
Width (inherited from EntityBaseViewFieldMetaData) |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

EntityBaseViewFieldMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


EntityBaseViewFieldMetaDataList Properties

The properties of the EntityBaseViewFieldMetaDataList class are listed below. For a complete list of EntityBaseViewFieldMetaDataList class members, see the EntityBaseViewFieldMetaDataList Members topic.

Public Instance Properties

CalculatedFieldExpression (inherited from EntityBaseViewFieldMetaData) |
Count |
DefaultInvView (inherited from EntityBaseViewFieldMetaData) |
Description (inherited from EntityBaseViewFieldMetaData) |
DescriptionCultureStringID (inherited from EntityBaseViewFieldMetaData) |
DescriptionWithCulture (inherited from EntityBaseViewFieldMetaData) |
DisplayName (inherited from EntityBaseViewFieldMetaData) |
DisplayNameCultureStringID (inherited from EntityBaseViewFieldMetaData) |
DisplayNameWithCulture (inherited from EntityBaseViewFieldMetaData) |
Entity (inherited from EntityBaseViewFieldMetaData) |
EntityBaseView (inherited from EntityBaseViewFieldMetaData) |
EntityBaseViewID (inherited from EntityBaseViewFieldMetaData) |
EntityField (inherited from EntityBaseViewFieldMetaData) |
FieldType (inherited from EntityBaseViewFieldMetaData) |
ID (inherited from EntityBaseViewFieldMetaData) |
Item | Overloaded.
JoinedEntityBaseDatabase (inherited from EntityBaseViewFieldMetaData) |
JoinedEntityBaseTable (inherited from EntityBaseViewFieldMetaData) |
JoinedEntityBaseView (inherited from EntityBaseViewFieldMetaData) |
JoinForeignKey (inherited from EntityBaseViewFieldMetaData) |
JoinType (inherited from EntityBaseViewFieldMetaData) |
Name (inherited from EntityBaseViewFieldMetaData) |
Sequence (inherited from EntityBaseViewFieldMetaData) |
ShowInFind (inherited from EntityBaseViewFieldMetaData) |
SQLAllowNull (inherited from EntityBaseViewFieldMetaData) |
SQLDataType (inherited from EntityBaseViewFieldMetaData) |
SQLFieldSize (inherited from EntityBaseViewFieldMetaData) |
Width (inherited from EntityBaseViewFieldMetaData) |

See Also

EntityBaseViewFieldMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


Count Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewFieldMetaDataList.Count Property

public Int32 Count {get;}

See Also

EntityBaseViewFieldMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


EntityBaseViewFieldMetaData Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewFieldMetaDataList.EntityBaseViewFieldMetaData Property

Overload List

public EntityBaseViewFieldMetaData this[Int32] {get;}

public EntityBaseViewFieldMetaData this[String] {get;}

See Also

EntityBaseViewFieldMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


Item Property (Int32)

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewFieldMetaDataList.Item Property (Int32)

public EntityBaseViewFieldMetaData this[
Int32 Index
] {get;}

See Also

EntityBaseViewFieldMetaDataList Class | Aptify.Framework.BusinessLogic Namespace | EntityBaseViewFieldMetaDataList.EntityBaseViewFieldMetaData Overload List


Item Property (String)

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewFieldMetaDataList.Item Property (String)

public EntityBaseViewFieldMetaData this[
String Name
] {get;}

See Also

EntityBaseViewFieldMetaDataList Class | Aptify.Framework.BusinessLogic Namespace | EntityBaseViewFieldMetaDataList.EntityBaseViewFieldMetaData Overload List


EntityBaseViewFieldMetaDataList Methods

The methods of the EntityBaseViewFieldMetaDataList class are listed below. For a complete list of EntityBaseViewFieldMetaDataList class members, see the EntityBaseViewFieldMetaDataList Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

EntityBaseViewFieldMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


EntityBaseViewFieldMetaDataList.GetEnumerator Method

public IEnumerator GetEnumerator();

Implements

IEnumerable.

See Also

EntityBaseViewFieldMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


EntityBaseViewFilterMetaData Class

For a list of all members of this type, see EntityBaseViewFilterMetaData Members.

System.Object
ReadDataRow
EntityBaseViewFilterMetaData
EntityBaseViewFilterMetaDataList

public class EntityBaseViewFilterMetaData : ReadDataRow

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: Metadata (in Metadata.dll)

See Also

EntityBaseViewFilterMetaData Members | Aptify.Framework.BusinessLogic Namespace


EntityBaseViewFilterMetaData Members

EntityBaseViewFilterMetaData overview

Public Instance Properties

EntityBaseView
EntityBaseViewID
FieldName
FilterOperator
ID
Sequence
ShortValue
Value

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Fields

m_drCurrentRow (inherited from ReadDataRow)

Protected Instance Properties

CurrentRow (inherited from ReadDataRow)
Dt
Item (inherited from ReadDataRow)
Item (inherited from ReadDataRow)
Pkeys
Pos
Rows

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EntityBaseViewFilterMetaData Class | Aptify.Framework.BusinessLogic Namespace


EntityBaseViewFilterMetaData Properties

The properties of the EntityBaseViewFilterMetaData class are listed below. For a complete list of EntityBaseViewFilterMetaData class members, see the EntityBaseViewFilterMetaData Members topic.

Public Instance Properties

EntityBaseView
EntityBaseViewID
FieldName
FilterOperator
ID
Sequence
ShortValue
Value

Protected Instance Properties

CurrentRow (inherited from ReadDataRow)
Dt
Item (inherited from ReadDataRow)
Item (inherited from ReadDataRow)
Pkeys
Pos
Rows

See Also

EntityBaseViewFilterMetaData Class | Aptify.Framework.BusinessLogic Namespace


Dt Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewFilterMetaData.Dt Property

protected DataTable Dt {get; set;}

See Also

EntityBaseViewFilterMetaData Class | Aptify.Framework.BusinessLogic Namespace


EntityBaseView Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewFilterMetaData.EntityBaseView Property

public EntityBaseViewMetaData EntityBaseView {get;}

See Also

EntityBaseViewFilterMetaData Class | Aptify.Framework.BusinessLogic Namespace


EntityBaseViewID Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewFilterMetaData.EntityBaseViewID Property

public Int64 EntityBaseViewID {get;}

See Also

EntityBaseViewFilterMetaData Class | Aptify.Framework.BusinessLogic Namespace


FieldName Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewFilterMetaData.FieldName Property

public String FieldName {get;}

See Also

EntityBaseViewFilterMetaData Class | Aptify.Framework.BusinessLogic Namespace


FilterOperator Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewFilterMetaData.FilterOperator Property

public Int32 FilterOperator {get;}

See Also

EntityBaseViewFilterMetaData Class | Aptify.Framework.BusinessLogic Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewFilterMetaData.ID Property

public Int64 ID {get;}

See Also

EntityBaseViewFilterMetaData Class | Aptify.Framework.BusinessLogic Namespace


Pkeys Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewFilterMetaData.Pkeys Property

protected Object[] Pkeys {get; set;}

See Also

EntityBaseViewFilterMetaData Class | Aptify.Framework.BusinessLogic Namespace


Pos Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewFilterMetaData.Pos Property

protected Int32 Pos {get; set;}

See Also

EntityBaseViewFilterMetaData Class | Aptify.Framework.BusinessLogic Namespace


Rows Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewFilterMetaData.Rows Property

protected DataRow[] Rows {get; set;}

See Also

EntityBaseViewFilterMetaData Class | Aptify.Framework.BusinessLogic Namespace


Sequence Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewFilterMetaData.Sequence Property

public Int32 Sequence {get;}

See Also

EntityBaseViewFilterMetaData Class | Aptify.Framework.BusinessLogic Namespace


ShortValue Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewFilterMetaData.ShortValue Property

public String ShortValue {get;}

See Also

EntityBaseViewFilterMetaData Class | Aptify.Framework.BusinessLogic Namespace


Value Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewFilterMetaData.Value Property

public String Value {get;}

See Also

EntityBaseViewFilterMetaData Class | Aptify.Framework.BusinessLogic Namespace


EntityBaseViewFilterMetaDataList Class

For a list of all members of this type, see EntityBaseViewFilterMetaDataList Members.

System.Object
ReadDataRow
EntityBaseViewFilterMetaData
EntityBaseViewFilterMetaDataList

public class EntityBaseViewFilterMetaDataList : EntityBaseViewFilterMetaData, IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: Metadata (in Metadata.dll)

See Also

EntityBaseViewFilterMetaDataList Members | Aptify.Framework.BusinessLogic Namespace


EntityBaseViewFilterMetaDataList Members

EntityBaseViewFilterMetaDataList overview

Public Instance Properties

Count |
EntityBaseView (inherited from EntityBaseViewFilterMetaData) |
EntityBaseViewID (inherited from EntityBaseViewFilterMetaData) |
FieldName (inherited from EntityBaseViewFilterMetaData) |
FilterOperator (inherited from EntityBaseViewFilterMetaData) |
ID (inherited from EntityBaseViewFilterMetaData) |
Item | Overloaded.
Sequence (inherited from EntityBaseViewFilterMetaData) |
ShortValue (inherited from EntityBaseViewFilterMetaData) |
Value (inherited from EntityBaseViewFilterMetaData) |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

EntityBaseViewFilterMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


EntityBaseViewFilterMetaDataList Properties

The properties of the EntityBaseViewFilterMetaDataList class are listed below. For a complete list of EntityBaseViewFilterMetaDataList class members, see the EntityBaseViewFilterMetaDataList Members topic.

Public Instance Properties

Count |
EntityBaseView (inherited from EntityBaseViewFilterMetaData) |
EntityBaseViewID (inherited from EntityBaseViewFilterMetaData) |
FieldName (inherited from EntityBaseViewFilterMetaData) |
FilterOperator (inherited from EntityBaseViewFilterMetaData) |
ID (inherited from EntityBaseViewFilterMetaData) |
Item | Overloaded.
Sequence (inherited from EntityBaseViewFilterMetaData) |
ShortValue (inherited from EntityBaseViewFilterMetaData) |
Value (inherited from EntityBaseViewFilterMetaData) |

See Also

EntityBaseViewFilterMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


Count Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewFilterMetaDataList.Count Property

public Int32 Count {get;}

See Also

EntityBaseViewFilterMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


Item Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewFilterMetaDataList.Item Property

public EntityBaseViewFilterMetaData this[
Int32 Index
] {get;}

See Also

EntityBaseViewFilterMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


EntityBaseViewFilterMetaDataList Methods

The methods of the EntityBaseViewFilterMetaDataList class are listed below. For a complete list of EntityBaseViewFilterMetaDataList class members, see the EntityBaseViewFilterMetaDataList Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

EntityBaseViewFilterMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


EntityBaseViewFilterMetaDataList.GetEnumerator Method

public IEnumerator GetEnumerator();

Implements

IEnumerable.

See Also

EntityBaseViewFilterMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


EntityBaseViewGroupPermissionMetaData Class

For a list of all members of this type, see EntityBaseViewGroupPermissionMetaData Members.

System.Object
ReadDataRow
EntityBaseViewGroupPermissionMetaData
EntityBaseViewGroupPermissionMetaDataList

public class EntityBaseViewGroupPermissionMetaData : ReadDataRow

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: Metadata (in Metadata.dll)

See Also

EntityBaseViewGroupPermissionMetaData Members | Aptify.Framework.BusinessLogic Namespace


EntityBaseViewGroupPermissionMetaData Members

EntityBaseViewGroupPermissionMetaData overview

Public Instance Properties

EntityBaseView
EntityBaseViewID
Group
GroupID
ID
Sequence

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Fields

m_drCurrentRow (inherited from ReadDataRow)

Protected Instance Properties

CurrentRow (inherited from ReadDataRow)
Dt
Item (inherited from ReadDataRow)
Item (inherited from ReadDataRow)
Pkeys
Pos
Rows

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EntityBaseViewGroupPermissionMetaData Class | Aptify.Framework.BusinessLogic Namespace


EntityBaseViewGroupPermissionMetaData Properties

The properties of the EntityBaseViewGroupPermissionMetaData class are listed below. For a complete list of EntityBaseViewGroupPermissionMetaData class members, see the EntityBaseViewGroupPermissionMetaData Members topic.

Public Instance Properties

EntityBaseView
EntityBaseViewID
Group
GroupID
ID
Sequence

Protected Instance Properties

CurrentRow (inherited from ReadDataRow)
Dt
Item (inherited from ReadDataRow)
Item (inherited from ReadDataRow)
Pkeys
Pos
Rows

See Also

EntityBaseViewGroupPermissionMetaData Class | Aptify.Framework.BusinessLogic Namespace


Dt Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewGroupPermissionMetaData.Dt Property

protected DataTable Dt {get; set;}

See Also

EntityBaseViewGroupPermissionMetaData Class | Aptify.Framework.BusinessLogic Namespace


EntityBaseView Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewGroupPermissionMetaData.EntityBaseView Property

public EntityBaseViewMetaData EntityBaseView {get;}

See Also

EntityBaseViewGroupPermissionMetaData Class | Aptify.Framework.BusinessLogic Namespace


EntityBaseViewID Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewGroupPermissionMetaData.EntityBaseViewID Property

public Int64 EntityBaseViewID {get;}

See Also

EntityBaseViewGroupPermissionMetaData Class | Aptify.Framework.BusinessLogic Namespace


Group Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewGroupPermissionMetaData.Group Property

public String Group {get;}

See Also

EntityBaseViewGroupPermissionMetaData Class | Aptify.Framework.BusinessLogic Namespace


GroupID Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewGroupPermissionMetaData.GroupID Property

public Int32 GroupID {get;}

See Also

EntityBaseViewGroupPermissionMetaData Class | Aptify.Framework.BusinessLogic Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewGroupPermissionMetaData.ID Property

public Int64 ID {get;}

See Also

EntityBaseViewGroupPermissionMetaData Class | Aptify.Framework.BusinessLogic Namespace


Pkeys Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewGroupPermissionMetaData.Pkeys Property

protected Object[] Pkeys {get; set;}

See Also

EntityBaseViewGroupPermissionMetaData Class | Aptify.Framework.BusinessLogic Namespace


Pos Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewGroupPermissionMetaData.Pos Property

protected Int32 Pos {get; set;}

See Also

EntityBaseViewGroupPermissionMetaData Class | Aptify.Framework.BusinessLogic Namespace


Rows Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewGroupPermissionMetaData.Rows Property

protected DataRow[] Rows {get; set;}

See Also

EntityBaseViewGroupPermissionMetaData Class | Aptify.Framework.BusinessLogic Namespace


Sequence Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewGroupPermissionMetaData.Sequence Property

public Int32 Sequence {get;}

See Also

EntityBaseViewGroupPermissionMetaData Class | Aptify.Framework.BusinessLogic Namespace


EntityBaseViewGroupPermissionMetaDataList Class

For a list of all members of this type, see EntityBaseViewGroupPermissionMetaDataList Members.

System.Object
ReadDataRow
EntityBaseViewGroupPermissionMetaData
EntityBaseViewGroupPermissionMetaDataList

public class EntityBaseViewGroupPermissionMetaDataList : EntityBaseViewGroupPermissionMetaData, IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: Metadata (in Metadata.dll)

See Also

EntityBaseViewGroupPermissionMetaDataList Members | Aptify.Framework.BusinessLogic Namespace


EntityBaseViewGroupPermissionMetaDataList Members

EntityBaseViewGroupPermissionMetaDataList overview

Public Instance Properties

Count |
EntityBaseView (inherited from EntityBaseViewGroupPermissionMetaData) |
EntityBaseViewID (inherited from EntityBaseViewGroupPermissionMetaData) |
Group (inherited from EntityBaseViewGroupPermissionMetaData) |
GroupID (inherited from EntityBaseViewGroupPermissionMetaData) |
ID (inherited from EntityBaseViewGroupPermissionMetaData) |
Item | Overloaded.
Sequence (inherited from EntityBaseViewGroupPermissionMetaData) |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

EntityBaseViewGroupPermissionMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


EntityBaseViewGroupPermissionMetaDataList Properties

The properties of the EntityBaseViewGroupPermissionMetaDataList class are listed below. For a complete list of EntityBaseViewGroupPermissionMetaDataList class members, see the EntityBaseViewGroupPermissionMetaDataList Members topic.

Public Instance Properties

Count |
EntityBaseView (inherited from EntityBaseViewGroupPermissionMetaData) |
EntityBaseViewID (inherited from EntityBaseViewGroupPermissionMetaData) |
Group (inherited from EntityBaseViewGroupPermissionMetaData) |
GroupID (inherited from EntityBaseViewGroupPermissionMetaData) |
ID (inherited from EntityBaseViewGroupPermissionMetaData) |
Item | Overloaded.
Sequence (inherited from EntityBaseViewGroupPermissionMetaData) |

See Also

EntityBaseViewGroupPermissionMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


Count Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewGroupPermissionMetaDataList.Count Property

public Int32 Count {get;}

See Also

EntityBaseViewGroupPermissionMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


Item Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewGroupPermissionMetaDataList.Item Property

public EntityBaseViewGroupPermissionMetaData this[
Int32 Index
] {get;}

See Also

EntityBaseViewGroupPermissionMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


EntityBaseViewGroupPermissionMetaDataList Methods

The methods of the EntityBaseViewGroupPermissionMetaDataList class are listed below. For a complete list of EntityBaseViewGroupPermissionMetaDataList class members, see the EntityBaseViewGroupPermissionMetaDataList Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

EntityBaseViewGroupPermissionMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


EntityBaseViewGroupPermissionMetaDataList.GetEnumerator Method

public IEnumerator GetEnumerator();

Implements

IEnumerable.

See Also

EntityBaseViewGroupPermissionMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


EntityBaseViewMetaData Class

For a list of all members of this type, see EntityBaseViewMetaData Members.

System.Object
ReadDataRow
EntityBaseViewMetaData
EntityBaseViewMetaDataList

public class EntityBaseViewMetaData : ReadDataRow

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: Metadata (in Metadata.dll)

See Also

EntityBaseViewMetaData Members | Aptify.Framework.BusinessLogic Namespace


EntityBaseViewMetaData Members

EntityBaseViewMetaData overview

Public Instance Properties

BaseView
BaseViewDatabase
BaseViewGrantSQLIsGenerated
BaseViewSecurity
BaseViewSQLIsGenerated
Description
DescriptionCultureStringID
DescriptionWithCulture
DisplayName
DisplayNameCultureStringID
DisplayNameWithCulture
Entity
EntityID
Fields
Filters
ID
LogicString
Name
Sequence

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Fields

m_drCurrentRow (inherited from ReadDataRow)

Protected Instance Properties

CurrentRow (inherited from ReadDataRow)
Dt
FieldsPtr
FiltersPtr
Item (inherited from ReadDataRow)
Item (inherited from ReadDataRow)
Pkeys
Pos
Rows

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EntityBaseViewMetaData Class | Aptify.Framework.BusinessLogic Namespace


EntityBaseViewMetaData Properties

The properties of the EntityBaseViewMetaData class are listed below. For a complete list of EntityBaseViewMetaData class members, see the EntityBaseViewMetaData Members topic.

Public Instance Properties

BaseView
BaseViewDatabase
BaseViewGrantSQLIsGenerated
BaseViewSecurity
BaseViewSQLIsGenerated
Description
DescriptionCultureStringID
DescriptionWithCulture
DisplayName
DisplayNameCultureStringID
DisplayNameWithCulture
Entity
EntityID
Fields
Filters
ID
LogicString
Name
Sequence

Protected Instance Properties

CurrentRow (inherited from ReadDataRow)
Dt
FieldsPtr
FiltersPtr
Item (inherited from ReadDataRow)
Item (inherited from ReadDataRow)
Pkeys
Pos
Rows

See Also

EntityBaseViewMetaData Class | Aptify.Framework.BusinessLogic Namespace


BaseView Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewMetaData.BaseView Property

public String BaseView {get;}

See Also

EntityBaseViewMetaData Class | Aptify.Framework.BusinessLogic Namespace


BaseViewDatabase Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewMetaData.BaseViewDatabase Property

public String BaseViewDatabase {get;}

See Also

EntityBaseViewMetaData Class | Aptify.Framework.BusinessLogic Namespace


BaseViewGrantSQLIsGenerated Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewMetaData.BaseViewGrantSQLIsGenerated Property

public Boolean BaseViewGrantSQLIsGenerated {get;}

See Also

EntityBaseViewMetaData Class | Aptify.Framework.BusinessLogic Namespace


BaseViewSecurity Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewMetaData.BaseViewSecurity Property

public Boolean BaseViewSecurity {get;}

See Also

EntityBaseViewMetaData Class | Aptify.Framework.BusinessLogic Namespace


BaseViewSQLIsGenerated Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewMetaData.BaseViewSQLIsGenerated Property

public Boolean BaseViewSQLIsGenerated {get;}

See Also

EntityBaseViewMetaData Class | Aptify.Framework.BusinessLogic Namespace


Description Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewMetaData.Description Property

public String Description {get;}

See Also

EntityBaseViewMetaData Class | Aptify.Framework.BusinessLogic Namespace


DescriptionCultureStringID Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewMetaData.DescriptionCultureStringID Property

public Int64 DescriptionCultureStringID {get;}

See Also

EntityBaseViewMetaData Class | Aptify.Framework.BusinessLogic Namespace


DescriptionWithCulture Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewMetaData.DescriptionWithCulture Property

public String this[
Int64 CultureID,
UserCredentials UserCredentials
] {get;}

See Also

EntityBaseViewMetaData Class | Aptify.Framework.BusinessLogic Namespace


DisplayName Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewMetaData.DisplayName Property

public String DisplayName {get;}

See Also

EntityBaseViewMetaData Class | Aptify.Framework.BusinessLogic Namespace


DisplayNameCultureStringID Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewMetaData.DisplayNameCultureStringID Property

public Int64 DisplayNameCultureStringID {get;}

See Also

EntityBaseViewMetaData Class | Aptify.Framework.BusinessLogic Namespace


DisplayNameWithCulture Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewMetaData.DisplayNameWithCulture Property

public String this[
Int64 CultureID,
UserCredentials UserCredentials
] {get;}

See Also

EntityBaseViewMetaData Class | Aptify.Framework.BusinessLogic Namespace


Dt Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewMetaData.Dt Property

protected DataTable Dt {get; set;}

See Also

EntityBaseViewMetaData Class | Aptify.Framework.BusinessLogic Namespace


Entity Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewMetaData.Entity Property

public EntityLevelMetaData Entity {get;}

See Also

EntityBaseViewMetaData Class | Aptify.Framework.BusinessLogic Namespace


EntityID Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewMetaData.EntityID Property

public Int64 EntityID {get;}

See Also

EntityBaseViewMetaData Class | Aptify.Framework.BusinessLogic Namespace


Fields Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewMetaData.Fields Property

public EntityBaseViewFieldMetaDataList Fields {get;}

See Also

EntityBaseViewMetaData Class | Aptify.Framework.BusinessLogic Namespace


FieldsPtr Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewMetaData.FieldsPtr Property

protected EntityBaseViewFieldMetaDataList FieldsPtr {get; set;}

See Also

EntityBaseViewMetaData Class | Aptify.Framework.BusinessLogic Namespace


Filters Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewMetaData.Filters Property

public EntityBaseViewFilterMetaDataList Filters {get;}

See Also

EntityBaseViewMetaData Class | Aptify.Framework.BusinessLogic Namespace


FiltersPtr Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewMetaData.FiltersPtr Property

protected EntityBaseViewFilterMetaDataList FiltersPtr {get; set;}

See Also

EntityBaseViewMetaData Class | Aptify.Framework.BusinessLogic Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewMetaData.ID Property

public Int64 ID {get;}

See Also

EntityBaseViewMetaData Class | Aptify.Framework.BusinessLogic Namespace


LogicString Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewMetaData.LogicString Property

public String LogicString {get;}

See Also

EntityBaseViewMetaData Class | Aptify.Framework.BusinessLogic Namespace


Name Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewMetaData.Name Property

public String Name {get;}

See Also

EntityBaseViewMetaData Class | Aptify.Framework.BusinessLogic Namespace


Pkeys Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewMetaData.Pkeys Property

protected Object[] Pkeys {get; set;}

See Also

EntityBaseViewMetaData Class | Aptify.Framework.BusinessLogic Namespace


Pos Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewMetaData.Pos Property

protected Int32 Pos {get; set;}

See Also

EntityBaseViewMetaData Class | Aptify.Framework.BusinessLogic Namespace


Rows Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewMetaData.Rows Property

protected DataRow[] Rows {get; set;}

See Also

EntityBaseViewMetaData Class | Aptify.Framework.BusinessLogic Namespace


Sequence Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewMetaData.Sequence Property

public Int32 Sequence {get;}

See Also

EntityBaseViewMetaData Class | Aptify.Framework.BusinessLogic Namespace


EntityBaseViewMetaDataList Class

Allows for the enumerating or listing of all the fields in an entity Public class that is not createable outside this dll

For a list of all members of this type, see EntityBaseViewMetaDataList Members.

System.Object
ReadDataRow
EntityBaseViewMetaData
EntityBaseViewMetaDataList

public class EntityBaseViewMetaDataList : EntityBaseViewMetaData, IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: Metadata (in Metadata.dll)

See Also

EntityBaseViewMetaDataList Members | Aptify.Framework.BusinessLogic Namespace


EntityBaseViewMetaDataList Members

EntityBaseViewMetaDataList overview

Public Instance Properties

BaseView (inherited from EntityBaseViewMetaData) |
BaseViewDatabase (inherited from EntityBaseViewMetaData) |
BaseViewGrantSQLIsGenerated (inherited from EntityBaseViewMetaData) |
BaseViewSecurity (inherited from EntityBaseViewMetaData) |
BaseViewSQLIsGenerated (inherited from EntityBaseViewMetaData) |
Count |
Description (inherited from EntityBaseViewMetaData) |
DescriptionCultureStringID (inherited from EntityBaseViewMetaData) |
DescriptionWithCulture (inherited from EntityBaseViewMetaData) |
DisplayName (inherited from EntityBaseViewMetaData) |
DisplayNameCultureStringID (inherited from EntityBaseViewMetaData) |
DisplayNameWithCulture (inherited from EntityBaseViewMetaData) |
Entity (inherited from EntityBaseViewMetaData) |
EntityID (inherited from EntityBaseViewMetaData) |
Fields (inherited from EntityBaseViewMetaData) |
Filters (inherited from EntityBaseViewMetaData) |
ID (inherited from EntityBaseViewMetaData) |
Item | Overloaded.
ItemByBaseView |
LogicString (inherited from EntityBaseViewMetaData) |
Name (inherited from EntityBaseViewMetaData) |
Sequence (inherited from EntityBaseViewMetaData) |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

EntityBaseViewMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


EntityBaseViewMetaDataList Properties

The properties of the EntityBaseViewMetaDataList class are listed below. For a complete list of EntityBaseViewMetaDataList class members, see the EntityBaseViewMetaDataList Members topic.

Public Instance Properties

BaseView (inherited from EntityBaseViewMetaData) |
BaseViewDatabase (inherited from EntityBaseViewMetaData) |
BaseViewGrantSQLIsGenerated (inherited from EntityBaseViewMetaData) |
BaseViewSecurity (inherited from EntityBaseViewMetaData) |
BaseViewSQLIsGenerated (inherited from EntityBaseViewMetaData) |
Count |
Description (inherited from EntityBaseViewMetaData) |
DescriptionCultureStringID (inherited from EntityBaseViewMetaData) |
DescriptionWithCulture (inherited from EntityBaseViewMetaData) |
DisplayName (inherited from EntityBaseViewMetaData) |
DisplayNameCultureStringID (inherited from EntityBaseViewMetaData) |
DisplayNameWithCulture (inherited from EntityBaseViewMetaData) |
Entity (inherited from EntityBaseViewMetaData) |
EntityID (inherited from EntityBaseViewMetaData) |
Fields (inherited from EntityBaseViewMetaData) |
Filters (inherited from EntityBaseViewMetaData) |
ID (inherited from EntityBaseViewMetaData) |
Item | Overloaded.
ItemByBaseView |
LogicString (inherited from EntityBaseViewMetaData) |
Name (inherited from EntityBaseViewMetaData) |
Sequence (inherited from EntityBaseViewMetaData) |

See Also

EntityBaseViewMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


Count Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewMetaDataList.Count Property

public Int32 Count {get;}

See Also

EntityBaseViewMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


EntityBaseViewMetaData Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewMetaDataList.EntityBaseViewMetaData Property

Overload List

public EntityBaseViewMetaData this[Int32] {get;}

public EntityBaseViewMetaData this[String] {get;}

See Also

EntityBaseViewMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


Item Property (Int32)

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewMetaDataList.Item Property (Int32)

public EntityBaseViewMetaData this[
Int32 Index
] {get;}

See Also

EntityBaseViewMetaDataList Class | Aptify.Framework.BusinessLogic Namespace | EntityBaseViewMetaDataList.EntityBaseViewMetaData Overload List


Item Property (String)

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewMetaDataList.Item Property (String)

public EntityBaseViewMetaData this[
String Name
] {get;}

See Also

EntityBaseViewMetaDataList Class | Aptify.Framework.BusinessLogic Namespace | EntityBaseViewMetaDataList.EntityBaseViewMetaData Overload List


ItemByBaseView Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewMetaDataList.ItemByBaseView Property

public EntityBaseViewMetaData this[
String BaseView
] {get;}

See Also

EntityBaseViewMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


EntityBaseViewMetaDataList Methods

The methods of the EntityBaseViewMetaDataList class are listed below. For a complete list of EntityBaseViewMetaDataList class members, see the EntityBaseViewMetaDataList Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

EntityBaseViewMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


EntityBaseViewMetaDataList.GetEnumerator Method

public IEnumerator GetEnumerator();

Implements

IEnumerable.

See Also

EntityBaseViewMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


EntityBaseViewUserPermissionMetaData Class

For a list of all members of this type, see EntityBaseViewUserPermissionMetaData Members.

System.Object
ReadDataRow
EntityBaseViewUserPermissionMetaData
EntityBaseViewUserPermissionMetaDataList

public class EntityBaseViewUserPermissionMetaData : ReadDataRow

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: Metadata (in Metadata.dll)

See Also

EntityBaseViewUserPermissionMetaData Members | Aptify.Framework.BusinessLogic Namespace


EntityBaseViewUserPermissionMetaData Members

EntityBaseViewUserPermissionMetaData overview

Public Instance Properties

EntityBaseView
EntityBaseViewID
ID
Sequence
User
UserID

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Fields

m_drCurrentRow (inherited from ReadDataRow)

Protected Instance Properties

CurrentRow (inherited from ReadDataRow)
Dt
Item (inherited from ReadDataRow)
Item (inherited from ReadDataRow)
Pkeys
Pos
Rows

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EntityBaseViewUserPermissionMetaData Class | Aptify.Framework.BusinessLogic Namespace


EntityBaseViewUserPermissionMetaData Properties

The properties of the EntityBaseViewUserPermissionMetaData class are listed below. For a complete list of EntityBaseViewUserPermissionMetaData class members, see the EntityBaseViewUserPermissionMetaData Members topic.

Public Instance Properties

EntityBaseView
EntityBaseViewID
ID
Sequence
User
UserID

Protected Instance Properties

CurrentRow (inherited from ReadDataRow)
Dt
Item (inherited from ReadDataRow)
Item (inherited from ReadDataRow)
Pkeys
Pos
Rows

See Also

EntityBaseViewUserPermissionMetaData Class | Aptify.Framework.BusinessLogic Namespace


Dt Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewUserPermissionMetaData.Dt Property

protected DataTable Dt {get; set;}

See Also

EntityBaseViewUserPermissionMetaData Class | Aptify.Framework.BusinessLogic Namespace


EntityBaseView Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewUserPermissionMetaData.EntityBaseView Property

public EntityBaseViewMetaData EntityBaseView {get;}

See Also

EntityBaseViewUserPermissionMetaData Class | Aptify.Framework.BusinessLogic Namespace


EntityBaseViewID Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewUserPermissionMetaData.EntityBaseViewID Property

public Int64 EntityBaseViewID {get;}

See Also

EntityBaseViewUserPermissionMetaData Class | Aptify.Framework.BusinessLogic Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewUserPermissionMetaData.ID Property

public Int64 ID {get;}

See Also

EntityBaseViewUserPermissionMetaData Class | Aptify.Framework.BusinessLogic Namespace


Pkeys Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewUserPermissionMetaData.Pkeys Property

protected Object[] Pkeys {get; set;}

See Also

EntityBaseViewUserPermissionMetaData Class | Aptify.Framework.BusinessLogic Namespace


Pos Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewUserPermissionMetaData.Pos Property

protected Int32 Pos {get; set;}

See Also

EntityBaseViewUserPermissionMetaData Class | Aptify.Framework.BusinessLogic Namespace


Rows Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewUserPermissionMetaData.Rows Property

protected DataRow[] Rows {get; set;}

See Also

EntityBaseViewUserPermissionMetaData Class | Aptify.Framework.BusinessLogic Namespace


Sequence Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewUserPermissionMetaData.Sequence Property

public Int32 Sequence {get;}

See Also

EntityBaseViewUserPermissionMetaData Class | Aptify.Framework.BusinessLogic Namespace


User Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewUserPermissionMetaData.User Property

public String User {get;}

See Also

EntityBaseViewUserPermissionMetaData Class | Aptify.Framework.BusinessLogic Namespace


UserID Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewUserPermissionMetaData.UserID Property

public Int32 UserID {get;}

See Also

EntityBaseViewUserPermissionMetaData Class | Aptify.Framework.BusinessLogic Namespace


EntityBaseViewUserPermissionMetaDataList Class

For a list of all members of this type, see EntityBaseViewUserPermissionMetaDataList Members.

System.Object
ReadDataRow
EntityBaseViewUserPermissionMetaData
EntityBaseViewUserPermissionMetaDataList

public class EntityBaseViewUserPermissionMetaDataList : EntityBaseViewUserPermissionMetaData, IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: Metadata (in Metadata.dll)

See Also

EntityBaseViewUserPermissionMetaDataList Members | Aptify.Framework.BusinessLogic Namespace


EntityBaseViewUserPermissionMetaDataList Members

EntityBaseViewUserPermissionMetaDataList overview

Public Instance Properties

Count |
EntityBaseView (inherited from EntityBaseViewUserPermissionMetaData) |
EntityBaseViewID (inherited from EntityBaseViewUserPermissionMetaData) |
ID (inherited from EntityBaseViewUserPermissionMetaData) |
Item | Overloaded.
Sequence (inherited from EntityBaseViewUserPermissionMetaData) |
User (inherited from EntityBaseViewUserPermissionMetaData) |
UserID (inherited from EntityBaseViewUserPermissionMetaData) |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

EntityBaseViewUserPermissionMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


EntityBaseViewUserPermissionMetaDataList Properties

The properties of the EntityBaseViewUserPermissionMetaDataList class are listed below. For a complete list of EntityBaseViewUserPermissionMetaDataList class members, see the EntityBaseViewUserPermissionMetaDataList Members topic.

Public Instance Properties

Count |
EntityBaseView (inherited from EntityBaseViewUserPermissionMetaData) |
EntityBaseViewID (inherited from EntityBaseViewUserPermissionMetaData) |
ID (inherited from EntityBaseViewUserPermissionMetaData) |
Item | Overloaded.
Sequence (inherited from EntityBaseViewUserPermissionMetaData) |
User (inherited from EntityBaseViewUserPermissionMetaData) |
UserID (inherited from EntityBaseViewUserPermissionMetaData) |

See Also

EntityBaseViewUserPermissionMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


Count Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewUserPermissionMetaDataList.Count Property

public Int32 Count {get;}

See Also

EntityBaseViewUserPermissionMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


Item Property

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewUserPermissionMetaDataList.Item Property

public EntityBaseViewUserPermissionMetaData this[
Int32 Index
] {get;}

See Also

EntityBaseViewUserPermissionMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


EntityBaseViewUserPermissionMetaDataList Methods

The methods of the EntityBaseViewUserPermissionMetaDataList class are listed below. For a complete list of EntityBaseViewUserPermissionMetaDataList class members, see the EntityBaseViewUserPermissionMetaDataList Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

EntityBaseViewUserPermissionMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


EntityBaseViewUserPermissionMetaDataList.GetEnumerator Method

public IEnumerator GetEnumerator();

Implements

IEnumerable.

See Also

EntityBaseViewUserPermissionMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


EntityDefaultBaseViewMetaData Class

For a list of all members of this type, see EntityDefaultBaseViewMetaData Members.

System.Object
ReadDataRow
EntityDefaultBaseViewMetaData
EntityDefaultBaseViewMetaDataList

public class EntityDefaultBaseViewMetaData : ReadDataRow

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: Metadata (in Metadata.dll)

See Also

EntityDefaultBaseViewMetaData Members | Aptify.Framework.BusinessLogic Namespace


EntityDefaultBaseViewMetaData Members

EntityDefaultBaseViewMetaData overview

Public Instance Properties

AppliesToFind |
AppliesToViewingSystem |
BaseView |
BaseViewMetaData | Returns the EntityBaseView meta-data object if the Default record references an EntityBaseView. Returns Nothing if the record indicates the Entity's Base View is referenced or if the EntityBaseView cannot be found based on the BaseView value that is recorded in the Default record.
DefaultType |
Entity |
EntityID |
ID |
IsEntityBaseView | Returns True if the Default Base View record indicates that the Entity's Base View is the Default Base View. Otherwise, returns False.
Sequence |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Fields

m_drCurrentRow (inherited from ReadDataRow)

Protected Instance Properties

CurrentRow (inherited from ReadDataRow)
Dt
Item (inherited from ReadDataRow)
Item (inherited from ReadDataRow)
Pkeys
Pos
Rows

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EntityDefaultBaseViewMetaData Class | Aptify.Framework.BusinessLogic Namespace


EntityDefaultBaseViewMetaData Properties

The properties of the EntityDefaultBaseViewMetaData class are listed below. For a complete list of EntityDefaultBaseViewMetaData class members, see the EntityDefaultBaseViewMetaData Members topic.

Public Instance Properties

AppliesToFind |
AppliesToViewingSystem |
BaseView |
BaseViewMetaData | Returns the EntityBaseView meta-data object if the Default record references an EntityBaseView. Returns Nothing if the record indicates the Entity's Base View is referenced or if the EntityBaseView cannot be found based on the BaseView value that is recorded in the Default record.
DefaultType |
Entity |
EntityID |
ID |
IsEntityBaseView | Returns True if the Default Base View record indicates that the Entity's Base View is the Default Base View. Otherwise, returns False.
Sequence |

Protected Instance Properties

CurrentRow (inherited from ReadDataRow)
Dt
Item (inherited from ReadDataRow)
Item (inherited from ReadDataRow)
Pkeys
Pos
Rows

See Also

EntityDefaultBaseViewMetaData Class | Aptify.Framework.BusinessLogic Namespace


AppliesToFind Property

Aptify 5.0 Software Development Kit (SDK)

EntityDefaultBaseViewMetaData.AppliesToFind Property

public Boolean AppliesToFind {get;}

See Also

EntityDefaultBaseViewMetaData Class | Aptify.Framework.BusinessLogic Namespace


AppliesToViewingSystem Property

Aptify 5.0 Software Development Kit (SDK)

EntityDefaultBaseViewMetaData.AppliesToViewingSystem Property

public Boolean AppliesToViewingSystem {get;}

See Also

EntityDefaultBaseViewMetaData Class | Aptify.Framework.BusinessLogic Namespace


BaseView Property

Aptify 5.0 Software Development Kit (SDK)

EntityDefaultBaseViewMetaData.BaseView Property

public String BaseView {get;}

See Also

EntityDefaultBaseViewMetaData Class | Aptify.Framework.BusinessLogic Namespace


BaseViewMetaData Property

Aptify 5.0 Software Development Kit (SDK)

EntityDefaultBaseViewMetaData.BaseViewMetaData Property

Returns the EntityBaseView meta-data object if the Default record references an EntityBaseView. Returns Nothing if the record indicates the Entity's Base View is referenced or if the EntityBaseView cannot be found based on the BaseView value that is recorded in the Default record.

public EntityBaseViewMetaData BaseViewMetaData {get;}

Property Value

Remarks

See Also

EntityDefaultBaseViewMetaData Class | Aptify.Framework.BusinessLogic Namespace


DefaultType Property

Aptify 5.0 Software Development Kit (SDK)

EntityDefaultBaseViewMetaData.DefaultType Property

public String DefaultType {get;}

See Also

EntityDefaultBaseViewMetaData Class | Aptify.Framework.BusinessLogic Namespace


Dt Property

Aptify 5.0 Software Development Kit (SDK)

EntityDefaultBaseViewMetaData.Dt Property

protected DataTable Dt {get; set;}

See Also

EntityDefaultBaseViewMetaData Class | Aptify.Framework.BusinessLogic Namespace


Entity Property

Aptify 5.0 Software Development Kit (SDK)

EntityDefaultBaseViewMetaData.Entity Property

public EntityLevelMetaData Entity {get;}

See Also

EntityDefaultBaseViewMetaData Class | Aptify.Framework.BusinessLogic Namespace


EntityID Property

Aptify 5.0 Software Development Kit (SDK)

EntityDefaultBaseViewMetaData.EntityID Property

public Int64 EntityID {get;}

See Also

EntityDefaultBaseViewMetaData Class | Aptify.Framework.BusinessLogic Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

EntityDefaultBaseViewMetaData.ID Property

public Int64 ID {get;}

See Also

EntityDefaultBaseViewMetaData Class | Aptify.Framework.BusinessLogic Namespace


IsEntityBaseView Property

Aptify 5.0 Software Development Kit (SDK)

EntityDefaultBaseViewMetaData.IsEntityBaseView Property

Returns True if the Default Base View record indicates that the Entity's Base View is the Default Base View. Otherwise, returns False.

public Boolean IsEntityBaseView {get;}

Property Value

Remarks

See Also

EntityDefaultBaseViewMetaData Class | Aptify.Framework.BusinessLogic Namespace


Pkeys Property

Aptify 5.0 Software Development Kit (SDK)

EntityDefaultBaseViewMetaData.Pkeys Property

protected Object[] Pkeys {get; set;}

See Also

EntityDefaultBaseViewMetaData Class | Aptify.Framework.BusinessLogic Namespace


Pos Property

Aptify 5.0 Software Development Kit (SDK)

EntityDefaultBaseViewMetaData.Pos Property

protected Int32 Pos {get; set;}

See Also

EntityDefaultBaseViewMetaData Class | Aptify.Framework.BusinessLogic Namespace


Rows Property

Aptify 5.0 Software Development Kit (SDK)

EntityDefaultBaseViewMetaData.Rows Property

protected DataRow[] Rows {get; set;}

See Also

EntityDefaultBaseViewMetaData Class | Aptify.Framework.BusinessLogic Namespace


Sequence Property

Aptify 5.0 Software Development Kit (SDK)

EntityDefaultBaseViewMetaData.Sequence Property

public Int32 Sequence {get;}

See Also

EntityDefaultBaseViewMetaData Class | Aptify.Framework.BusinessLogic Namespace


EntityDefaultBaseViewMetaDataList Class

Allows for the enumerating or listing of all the fields in an entity Public class that is not createable outside this dll

For a list of all members of this type, see EntityDefaultBaseViewMetaDataList Members.

System.Object
ReadDataRow
EntityDefaultBaseViewMetaData
EntityDefaultBaseViewMetaDataList

public class EntityDefaultBaseViewMetaDataList : EntityDefaultBaseViewMetaData, IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: Metadata (in Metadata.dll)

See Also

EntityDefaultBaseViewMetaDataList Members | Aptify.Framework.BusinessLogic Namespace


EntityDefaultBaseViewMetaDataList Members

EntityDefaultBaseViewMetaDataList overview

Public Instance Properties

AppliesToFind (inherited from EntityDefaultBaseViewMetaData) |
AppliesToViewingSystem (inherited from EntityDefaultBaseViewMetaData) |
BaseView (inherited from EntityDefaultBaseViewMetaData) |
BaseViewMetaData (inherited from EntityDefaultBaseViewMetaData) | Returns the EntityBaseView meta-data object if the Default record references an EntityBaseView. Returns Nothing if the record indicates the Entity's Base View is referenced or if the EntityBaseView cannot be found based on the BaseView value that is recorded in the Default record.
Count |
DefaultType (inherited from EntityDefaultBaseViewMetaData) |
Entity (inherited from EntityDefaultBaseViewMetaData) |
EntityID (inherited from EntityDefaultBaseViewMetaData) |
ID (inherited from EntityDefaultBaseViewMetaData) |
IsEntityBaseView (inherited from EntityDefaultBaseViewMetaData) | Returns True if the Default Base View record indicates that the Entity's Base View is the Default Base View. Otherwise, returns False.
Item | Overloaded.
Sequence (inherited from EntityDefaultBaseViewMetaData) |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

EntityDefaultBaseViewMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


EntityDefaultBaseViewMetaDataList Properties

The properties of the EntityDefaultBaseViewMetaDataList class are listed below. For a complete list of EntityDefaultBaseViewMetaDataList class members, see the EntityDefaultBaseViewMetaDataList Members topic.

Public Instance Properties

AppliesToFind (inherited from EntityDefaultBaseViewMetaData) |
AppliesToViewingSystem (inherited from EntityDefaultBaseViewMetaData) |
BaseView (inherited from EntityDefaultBaseViewMetaData) |
BaseViewMetaData (inherited from EntityDefaultBaseViewMetaData) | Returns the EntityBaseView meta-data object if the Default record references an EntityBaseView. Returns Nothing if the record indicates the Entity's Base View is referenced or if the EntityBaseView cannot be found based on the BaseView value that is recorded in the Default record.
Count |
DefaultType (inherited from EntityDefaultBaseViewMetaData) |
Entity (inherited from EntityDefaultBaseViewMetaData) |
EntityID (inherited from EntityDefaultBaseViewMetaData) |
ID (inherited from EntityDefaultBaseViewMetaData) |
IsEntityBaseView (inherited from EntityDefaultBaseViewMetaData) | Returns True if the Default Base View record indicates that the Entity's Base View is the Default Base View. Otherwise, returns False.
Item | Overloaded.
Sequence (inherited from EntityDefaultBaseViewMetaData) |

See Also

EntityDefaultBaseViewMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


Count Property

Aptify 5.0 Software Development Kit (SDK)

EntityDefaultBaseViewMetaDataList.Count Property

public Int32 Count {get;}

See Also

EntityDefaultBaseViewMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


Item Property

Aptify 5.0 Software Development Kit (SDK)

EntityDefaultBaseViewMetaDataList.Item Property

public EntityDefaultBaseViewMetaData this[
Int32 Index
] {get;}

See Also

EntityDefaultBaseViewMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


EntityDefaultBaseViewMetaDataList Methods

The methods of the EntityDefaultBaseViewMetaDataList class are listed below. For a complete list of EntityDefaultBaseViewMetaDataList class members, see the EntityDefaultBaseViewMetaDataList Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

EntityDefaultBaseViewMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


EntityDefaultBaseViewMetaDataList.GetEnumerator Method

public IEnumerator GetEnumerator();

Implements

IEnumerable.

See Also

EntityDefaultBaseViewMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


EntityFieldMetaData Class

For a list of all members of this type, see EntityFieldMetaData Members.

System.Object
ReadDataRow
EntityFieldMetaData
EntityFieldMetaDataList

public class EntityFieldMetaData : ReadDataRow

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: Metadata (in Metadata.dll)

See Also

EntityFieldMetaData Members | Aptify.Framework.BusinessLogic Namespace


EntityFieldMetaData Members

EntityFieldMetaData overview

Public Instance Properties

Alignment |
AllowedSearchMethods |
AllowInPlaceEditing |
AllowSorting |
BaseField |
BaseTable |
Category |
CurrencyTypeField |
CustomGUIObjRepLoc |
CustomGUIProgID |
DefaultInView |
DefaultValue |
Description |
DisplayCultureString |
DisplayCultureStringID |
DisplayName |
DisplayNameWithCulture | Overloaded.
DynamicSharingRelationships |
EmbeddedLinkSharingMode |
EncryptData |
Entity |
EntityID |
ExtendedType |
FieldValues |
GUITypeMultiSelect |
GUITypeSingleSelect |
HelpObject |
HelpText |
HelpTextCultureStringID |
HelpTextCultureStringName |
HelpURL |
ID |
InPlaceEditSecurity |
InputMask |
InputMaskType |
InTable |
IsIndexed |
IsInstalled |
IsNameField |
IsRequired |
IsSequence |
IsSystem |
IsUnique |
IsValidated |
JoinedEntity |
JoinedEntityBaseDatabase |
JoinedEntityBaseTable |
JoinedEntityBaseView |
JoinedField |
JoinForeignKey |
JoinType |
LinkedEntity |
LinkedEntityField |
LinkType |
Name |
ParamName |
ParentLinkedValue |
SecurityKeyID |
Sequence |
ShowInFind |
spDynamicFlowdown |
SQLAllowNull |
SQLDataType |
SQLFieldPrecision |
SQLFieldScale |
SQLFieldSize |
SupportsMultipleCurrencies |
TextInterpretationMode |
ToDbType |
ToSqlType |
ToType |
Type |
Updateable |
ValidationRangeDateLowerBound |
ValidationRangeDateUpperBound |
ValidationRangeLowerBound |
ValidationRangeUpperBound |
ValidationScript |
ValidationType |
ValueListType |
VirtualFieldCalculation |
VirtualFieldType |
Width |

Public Instance Methods

DynamicSharingRelationshipExists |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Fields

m_drCurrentRow (inherited from ReadDataRow)

Protected Instance Properties

CurrentRow (inherited from ReadDataRow)
Dt
DynamicSharingRelationshipPtr
FieldValuesPtr
Item (inherited from ReadDataRow)
Item (inherited from ReadDataRow)
Pkeys
Pos
Rows

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


EntityFieldMetaData Properties

The properties of the EntityFieldMetaData class are listed below. For a complete list of EntityFieldMetaData class members, see the EntityFieldMetaData Members topic.

Public Instance Properties

Alignment |
AllowedSearchMethods |
AllowInPlaceEditing |
AllowSorting |
BaseField |
BaseTable |
Category |
CurrencyTypeField |
CustomGUIObjRepLoc |
CustomGUIProgID |
DefaultInView |
DefaultValue |
Description |
DisplayCultureString |
DisplayCultureStringID |
DisplayName |
DisplayNameWithCulture | Overloaded.
DynamicSharingRelationships |
EmbeddedLinkSharingMode |
EncryptData |
Entity |
EntityID |
ExtendedType |
FieldValues |
GUITypeMultiSelect |
GUITypeSingleSelect |
HelpObject |
HelpText |
HelpTextCultureStringID |
HelpTextCultureStringName |
HelpURL |
ID |
InPlaceEditSecurity |
InputMask |
InputMaskType |
InTable |
IsIndexed |
IsInstalled |
IsNameField |
IsRequired |
IsSequence |
IsSystem |
IsUnique |
IsValidated |
JoinedEntity |
JoinedEntityBaseDatabase |
JoinedEntityBaseTable |
JoinedEntityBaseView |
JoinedField |
JoinForeignKey |
JoinType |
LinkedEntity |
LinkedEntityField |
LinkType |
Name |
ParamName |
ParentLinkedValue |
SecurityKeyID |
Sequence |
ShowInFind |
spDynamicFlowdown |
SQLAllowNull |
SQLDataType |
SQLFieldPrecision |
SQLFieldScale |
SQLFieldSize |
SupportsMultipleCurrencies |
TextInterpretationMode |
ToDbType |
ToSqlType |
ToType |
Type |
Updateable |
ValidationRangeDateLowerBound |
ValidationRangeDateUpperBound |
ValidationRangeLowerBound |
ValidationRangeUpperBound |
ValidationScript |
ValidationType |
ValueListType |
VirtualFieldCalculation |
VirtualFieldType |
Width |

Protected Instance Properties

CurrentRow (inherited from ReadDataRow)
Dt
DynamicSharingRelationshipPtr
FieldValuesPtr
Item (inherited from ReadDataRow)
Item (inherited from ReadDataRow)
Pkeys
Pos
Rows

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


Alignment Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.Alignment Property

public FieldAlignment Alignment {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


AllowedSearchMethods Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.AllowedSearchMethods Property

public AllowedSearchMethod AllowedSearchMethods {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


AllowInPlaceEditing Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.AllowInPlaceEditing Property

public Boolean AllowInPlaceEditing {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


AllowSorting Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.AllowSorting Property

public Boolean AllowSorting {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


BaseField Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.BaseField Property

public String BaseField {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


BaseTable Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.BaseTable Property

public String BaseTable {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


Category Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.Category Property

public String Category {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


CurrencyTypeField Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.CurrencyTypeField Property

public String CurrencyTypeField {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


CustomGUIObjRepLoc Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.CustomGUIObjRepLoc Property

public String CustomGUIObjRepLoc {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


CustomGUIProgID Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.CustomGUIProgID Property

public String CustomGUIProgID {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


DefaultInView Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.DefaultInView Property

public Boolean DefaultInView {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


DefaultValue Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.DefaultValue Property

public String DefaultValue {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


Description Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.Description Property

public String Description {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


DisplayCultureString Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.DisplayCultureString Property

public String DisplayCultureString {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


DisplayCultureStringID Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.DisplayCultureStringID Property

public Int64 DisplayCultureStringID {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


DisplayName Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.DisplayName Property

public String DisplayName {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


String Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.String Property

Overload List

public String this[Int64, UserCredentials] {get;}

public String this[Int64, Boolean, UserCredentials] {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


DisplayNameWithCulture Property (Int64, UserCredentials)

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.DisplayNameWithCulture Property (Int64, UserCredentials)

public String this[
Int64 CultureID,
UserCredentials UserCredentials
] {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace | EntityFieldMetaData.String Overload List


DisplayNameWithCulture Property (Int64, Boolean, UserCredentials)

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.DisplayNameWithCulture Property (Int64, Boolean, UserCredentials)

public String this[
Int64 CultureID,
Boolean AutoMapDisplayName,
UserCredentials UserCredentials
] {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace | EntityFieldMetaData.String Overload List


Dt Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.Dt Property

protected DataTable Dt {get; set;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


DynamicSharingRelationshipPtr Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.DynamicSharingRelationshipPtr Property

protected DynamicSharingRelationshipMetaDataList DynamicSharingRelationshipPtr {get; set;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


DynamicSharingRelationships Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.DynamicSharingRelationships Property

public DynamicSharingRelationshipMetaDataList DynamicSharingRelationships {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


EmbeddedLinkSharingMode Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.EmbeddedLinkSharingMode Property

public EmbeddedLinkSharingMode EmbeddedLinkSharingMode {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


EncryptData Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.EncryptData Property

public Boolean EncryptData {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


Entity Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.Entity Property

public EntityLevelMetaData Entity {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


EntityID Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.EntityID Property

public Int64 EntityID {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


ExtendedType Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.ExtendedType Property

public String ExtendedType {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


FieldValues Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.FieldValues Property

public EntityFieldValueMetaDataList FieldValues {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


FieldValuesPtr Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.FieldValuesPtr Property

protected EntityFieldValueMetaDataList FieldValuesPtr {get; set;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


GUITypeMultiSelect Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.GUITypeMultiSelect Property

public FieldGUITypeMultiSelect GUITypeMultiSelect {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


GUITypeSingleSelect Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.GUITypeSingleSelect Property

public FieldGUITypeSingleSelect GUITypeSingleSelect {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


HelpObject Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.HelpObject Property

public String HelpObject {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


HelpText Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.HelpText Property

public String HelpText {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


HelpTextCultureStringID Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.HelpTextCultureStringID Property

public Int64 HelpTextCultureStringID {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


HelpTextCultureStringName Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.HelpTextCultureStringName Property

public String HelpTextCultureStringName {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


HelpURL Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.HelpURL Property

public String HelpURL {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.ID Property

public Int64 ID {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


InPlaceEditSecurity Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.InPlaceEditSecurity Property

public InPlaceEditSecurity InPlaceEditSecurity {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


InputMask Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.InputMask Property

public String InputMask {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


InputMaskType Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.InputMaskType Property

public InputMaskType InputMaskType {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


InTable Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.InTable Property

public Boolean InTable {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


IsIndexed Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.IsIndexed Property

public Boolean IsIndexed {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


IsInstalled Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.IsInstalled Property

public Boolean IsInstalled {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


IsNameField Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.IsNameField Property

public Boolean IsNameField {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


IsRequired Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.IsRequired Property

public Boolean IsRequired {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


IsSequence Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.IsSequence Property

public Boolean IsSequence {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


IsSystem Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.IsSystem Property

public Boolean IsSystem {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


IsUnique Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.IsUnique Property

public Boolean IsUnique {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


IsValidated Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.IsValidated Property

public Boolean IsValidated {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


JoinedEntity Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.JoinedEntity Property

public String JoinedEntity {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


JoinedEntityBaseDatabase Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.JoinedEntityBaseDatabase Property

public String JoinedEntityBaseDatabase {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


JoinedEntityBaseTable Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.JoinedEntityBaseTable Property

public String JoinedEntityBaseTable {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


JoinedEntityBaseView Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.JoinedEntityBaseView Property

public String JoinedEntityBaseView {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


JoinedField Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.JoinedField Property

public String JoinedField {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


JoinForeignKey Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.JoinForeignKey Property

public String JoinForeignKey {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


JoinType Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.JoinType Property

public String JoinType {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


LinkedEntity Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.LinkedEntity Property

public String LinkedEntity {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


LinkedEntityField Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.LinkedEntityField Property

public String LinkedEntityField {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


LinkType Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.LinkType Property

public FieldLinkType LinkType {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


Name Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.Name Property

public String Name {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


ParamName Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.ParamName Property

public String ParamName {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


ParentLinkedValue Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.ParentLinkedValue Property

public String ParentLinkedValue {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


Pkeys Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.Pkeys Property

protected Object[] Pkeys {get; set;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


Pos Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.Pos Property

protected Int32 Pos {get; set;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


Rows Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.Rows Property

protected DataRow[] Rows {get; set;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


SecurityKeyID Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.SecurityKeyID Property

public Int64 SecurityKeyID {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


Sequence Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.Sequence Property

public Int32 Sequence {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


ShowInFind Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.ShowInFind Property

public Boolean ShowInFind {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


spDynamicFlowdown Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.spDynamicFlowdown Property

public String spDynamicFlowdown {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


SQLAllowNull Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.SQLAllowNull Property

public Boolean SQLAllowNull {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


SQLDataType Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.SQLDataType Property

public String SQLDataType {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


SQLFieldPrecision Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.SQLFieldPrecision Property

public Int32 SQLFieldPrecision {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


SQLFieldScale Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.SQLFieldScale Property

public Int32 SQLFieldScale {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


SQLFieldSize Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.SQLFieldSize Property

public Int32 SQLFieldSize {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


SupportsMultipleCurrencies Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.SupportsMultipleCurrencies Property

public Boolean SupportsMultipleCurrencies {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


TextInterpretationMode Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.TextInterpretationMode Property

public TextInterpretationMode TextInterpretationMode {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


ToDbType Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.ToDbType Property

public DbType ToDbType {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


ToSqlType Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.ToSqlType Property

public SqlDbType ToSqlType {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


ToType Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.ToType Property

public Type ToType {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


Type Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.Type Property

public FieldGenericDataType Type {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


Updateable Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.Updateable Property

public Boolean Updateable {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


ValidationRangeDateLowerBound Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.ValidationRangeDateLowerBound Property

public DateTime ValidationRangeDateLowerBound {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


ValidationRangeDateUpperBound Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.ValidationRangeDateUpperBound Property

public DateTime ValidationRangeDateUpperBound {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


ValidationRangeLowerBound Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.ValidationRangeLowerBound Property

public Double ValidationRangeLowerBound {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


ValidationRangeUpperBound Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.ValidationRangeUpperBound Property

public Double ValidationRangeUpperBound {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


ValidationScript Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.ValidationScript Property

public String ValidationScript {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


ValidationType Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.ValidationType Property

public String ValidationType {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


ValueListType Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.ValueListType Property

public FieldValueListType ValueListType {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


VirtualFieldCalculation Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.VirtualFieldCalculation Property

public String VirtualFieldCalculation {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


VirtualFieldType Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.VirtualFieldType Property

public String VirtualFieldType {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


Width Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaData.Width Property

public Int32 Width {get;}

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


EntityFieldMetaData Methods

The methods of the EntityFieldMetaData class are listed below. For a complete list of EntityFieldMetaData class members, see the EntityFieldMetaData Members topic.

Public Instance Methods

DynamicSharingRelationshipExists |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


EntityFieldMetaData.DynamicSharingRelationshipExists Method

public bool DynamicSharingRelationshipExists(
Int64 OwnerEntityID
);

See Also

EntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


EntityFieldMetaDataList Class

For a list of all members of this type, see EntityFieldMetaDataList Members.

System.Object
ReadDataRow
EntityFieldMetaData
EntityFieldMetaDataList

public class EntityFieldMetaDataList : EntityFieldMetaData, IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: Metadata (in Metadata.dll)

See Also

EntityFieldMetaDataList Members | Aptify.Framework.BusinessLogic Namespace


EntityFieldMetaDataList Members

EntityFieldMetaDataList overview

Public Instance Properties

Alignment (inherited from EntityFieldMetaData) |
AllowedSearchMethods (inherited from EntityFieldMetaData) |
AllowInPlaceEditing (inherited from EntityFieldMetaData) |
AllowSorting (inherited from EntityFieldMetaData) |
BaseField (inherited from EntityFieldMetaData) |
BaseTable (inherited from EntityFieldMetaData) |
Category (inherited from EntityFieldMetaData) |
Count |
CurrencyTypeField (inherited from EntityFieldMetaData) |
CustomGUIObjRepLoc (inherited from EntityFieldMetaData) |
CustomGUIProgID (inherited from EntityFieldMetaData) |
DefaultInView (inherited from EntityFieldMetaData) |
DefaultValue (inherited from EntityFieldMetaData) |
Description (inherited from EntityFieldMetaData) |
DisplayCultureString (inherited from EntityFieldMetaData) |
DisplayCultureStringID (inherited from EntityFieldMetaData) |
DisplayName (inherited from EntityFieldMetaData) |
DisplayNameWithCulture (inherited from EntityFieldMetaData) |
DisplayNameWithCulture (inherited from EntityFieldMetaData) |
DynamicSharingRelationships (inherited from EntityFieldMetaData) |
EmbeddedLinkSharingMode (inherited from EntityFieldMetaData) |
EncryptData (inherited from EntityFieldMetaData) |
Entity (inherited from EntityFieldMetaData) |
EntityID (inherited from EntityFieldMetaData) |
ExtendedType (inherited from EntityFieldMetaData) |
FieldValues (inherited from EntityFieldMetaData) |
GUITypeMultiSelect (inherited from EntityFieldMetaData) |
GUITypeSingleSelect (inherited from EntityFieldMetaData) |
HelpObject (inherited from EntityFieldMetaData) |
HelpText (inherited from EntityFieldMetaData) |
HelpTextCultureStringID (inherited from EntityFieldMetaData) |
HelpTextCultureStringName (inherited from EntityFieldMetaData) |
HelpURL (inherited from EntityFieldMetaData) |
ID (inherited from EntityFieldMetaData) |
InPlaceEditSecurity (inherited from EntityFieldMetaData) |
InputMask (inherited from EntityFieldMetaData) |
InputMaskType (inherited from EntityFieldMetaData) |
InTable (inherited from EntityFieldMetaData) |
IsIndexed (inherited from EntityFieldMetaData) |
IsInstalled (inherited from EntityFieldMetaData) |
IsNameField (inherited from EntityFieldMetaData) |
IsRequired (inherited from EntityFieldMetaData) |
IsSequence (inherited from EntityFieldMetaData) |
IsSystem (inherited from EntityFieldMetaData) |
IsUnique (inherited from EntityFieldMetaData) |
IsValidated (inherited from EntityFieldMetaData) |
Item | Overloaded.
JoinedEntity (inherited from EntityFieldMetaData) |
JoinedEntityBaseDatabase (inherited from EntityFieldMetaData) |
JoinedEntityBaseTable (inherited from EntityFieldMetaData) |
JoinedEntityBaseView (inherited from EntityFieldMetaData) |
JoinedField (inherited from EntityFieldMetaData) |
JoinForeignKey (inherited from EntityFieldMetaData) |
JoinType (inherited from EntityFieldMetaData) |
LinkedEntity (inherited from EntityFieldMetaData) |
LinkedEntityField (inherited from EntityFieldMetaData) |
LinkType (inherited from EntityFieldMetaData) |
Name (inherited from EntityFieldMetaData) |
ParamName (inherited from EntityFieldMetaData) |
ParentLinkedValue (inherited from EntityFieldMetaData) |
SecurityKeyID (inherited from EntityFieldMetaData) |
Sequence (inherited from EntityFieldMetaData) |
ShowInFind (inherited from EntityFieldMetaData) |
spDynamicFlowdown (inherited from EntityFieldMetaData) |
SQLAllowNull (inherited from EntityFieldMetaData) |
SQLDataType (inherited from EntityFieldMetaData) |
SQLFieldPrecision (inherited from EntityFieldMetaData) |
SQLFieldScale (inherited from EntityFieldMetaData) |
SQLFieldSize (inherited from EntityFieldMetaData) |
SupportsMultipleCurrencies (inherited from EntityFieldMetaData) |
TextInterpretationMode (inherited from EntityFieldMetaData) |
ToDbType (inherited from EntityFieldMetaData) |
ToSqlType (inherited from EntityFieldMetaData) |
ToType (inherited from EntityFieldMetaData) |
Type (inherited from EntityFieldMetaData) |
Updateable (inherited from EntityFieldMetaData) |
ValidationRangeDateLowerBound (inherited from EntityFieldMetaData) |
ValidationRangeDateUpperBound (inherited from EntityFieldMetaData) |
ValidationRangeLowerBound (inherited from EntityFieldMetaData) |
ValidationRangeUpperBound (inherited from EntityFieldMetaData) |
ValidationScript (inherited from EntityFieldMetaData) |
ValidationType (inherited from EntityFieldMetaData) |
ValueListType (inherited from EntityFieldMetaData) |
VirtualFieldCalculation (inherited from EntityFieldMetaData) |
VirtualFieldType (inherited from EntityFieldMetaData) |
Width (inherited from EntityFieldMetaData) |

Public Instance Methods

DynamicSharingRelationshipExists (inherited from EntityFieldMetaData) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

EntityFieldMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


EntityFieldMetaDataList Properties

The properties of the EntityFieldMetaDataList class are listed below. For a complete list of EntityFieldMetaDataList class members, see the EntityFieldMetaDataList Members topic.

Public Instance Properties

Alignment (inherited from EntityFieldMetaData) |
AllowedSearchMethods (inherited from EntityFieldMetaData) |
AllowInPlaceEditing (inherited from EntityFieldMetaData) |
AllowSorting (inherited from EntityFieldMetaData) |
BaseField (inherited from EntityFieldMetaData) |
BaseTable (inherited from EntityFieldMetaData) |
Category (inherited from EntityFieldMetaData) |
Count |
CurrencyTypeField (inherited from EntityFieldMetaData) |
CustomGUIObjRepLoc (inherited from EntityFieldMetaData) |
CustomGUIProgID (inherited from EntityFieldMetaData) |
DefaultInView (inherited from EntityFieldMetaData) |
DefaultValue (inherited from EntityFieldMetaData) |
Description (inherited from EntityFieldMetaData) |
DisplayCultureString (inherited from EntityFieldMetaData) |
DisplayCultureStringID (inherited from EntityFieldMetaData) |
DisplayName (inherited from EntityFieldMetaData) |
DisplayNameWithCulture (inherited from EntityFieldMetaData) |
DisplayNameWithCulture (inherited from EntityFieldMetaData) |
DynamicSharingRelationships (inherited from EntityFieldMetaData) |
EmbeddedLinkSharingMode (inherited from EntityFieldMetaData) |
EncryptData (inherited from EntityFieldMetaData) |
Entity (inherited from EntityFieldMetaData) |
EntityID (inherited from EntityFieldMetaData) |
ExtendedType (inherited from EntityFieldMetaData) |
FieldValues (inherited from EntityFieldMetaData) |
GUITypeMultiSelect (inherited from EntityFieldMetaData) |
GUITypeSingleSelect (inherited from EntityFieldMetaData) |
HelpObject (inherited from EntityFieldMetaData) |
HelpText (inherited from EntityFieldMetaData) |
HelpTextCultureStringID (inherited from EntityFieldMetaData) |
HelpTextCultureStringName (inherited from EntityFieldMetaData) |
HelpURL (inherited from EntityFieldMetaData) |
ID (inherited from EntityFieldMetaData) |
InPlaceEditSecurity (inherited from EntityFieldMetaData) |
InputMask (inherited from EntityFieldMetaData) |
InputMaskType (inherited from EntityFieldMetaData) |
InTable (inherited from EntityFieldMetaData) |
IsIndexed (inherited from EntityFieldMetaData) |
IsInstalled (inherited from EntityFieldMetaData) |
IsNameField (inherited from EntityFieldMetaData) |
IsRequired (inherited from EntityFieldMetaData) |
IsSequence (inherited from EntityFieldMetaData) |
IsSystem (inherited from EntityFieldMetaData) |
IsUnique (inherited from EntityFieldMetaData) |
IsValidated (inherited from EntityFieldMetaData) |
Item | Overloaded.
JoinedEntity (inherited from EntityFieldMetaData) |
JoinedEntityBaseDatabase (inherited from EntityFieldMetaData) |
JoinedEntityBaseTable (inherited from EntityFieldMetaData) |
JoinedEntityBaseView (inherited from EntityFieldMetaData) |
JoinedField (inherited from EntityFieldMetaData) |
JoinForeignKey (inherited from EntityFieldMetaData) |
JoinType (inherited from EntityFieldMetaData) |
LinkedEntity (inherited from EntityFieldMetaData) |
LinkedEntityField (inherited from EntityFieldMetaData) |
LinkType (inherited from EntityFieldMetaData) |
Name (inherited from EntityFieldMetaData) |
ParamName (inherited from EntityFieldMetaData) |
ParentLinkedValue (inherited from EntityFieldMetaData) |
SecurityKeyID (inherited from EntityFieldMetaData) |
Sequence (inherited from EntityFieldMetaData) |
ShowInFind (inherited from EntityFieldMetaData) |
spDynamicFlowdown (inherited from EntityFieldMetaData) |
SQLAllowNull (inherited from EntityFieldMetaData) |
SQLDataType (inherited from EntityFieldMetaData) |
SQLFieldPrecision (inherited from EntityFieldMetaData) |
SQLFieldScale (inherited from EntityFieldMetaData) |
SQLFieldSize (inherited from EntityFieldMetaData) |
SupportsMultipleCurrencies (inherited from EntityFieldMetaData) |
TextInterpretationMode (inherited from EntityFieldMetaData) |
ToDbType (inherited from EntityFieldMetaData) |
ToSqlType (inherited from EntityFieldMetaData) |
ToType (inherited from EntityFieldMetaData) |
Type (inherited from EntityFieldMetaData) |
Updateable (inherited from EntityFieldMetaData) |
ValidationRangeDateLowerBound (inherited from EntityFieldMetaData) |
ValidationRangeDateUpperBound (inherited from EntityFieldMetaData) |
ValidationRangeLowerBound (inherited from EntityFieldMetaData) |
ValidationRangeUpperBound (inherited from EntityFieldMetaData) |
ValidationScript (inherited from EntityFieldMetaData) |
ValidationType (inherited from EntityFieldMetaData) |
ValueListType (inherited from EntityFieldMetaData) |
VirtualFieldCalculation (inherited from EntityFieldMetaData) |
VirtualFieldType (inherited from EntityFieldMetaData) |
Width (inherited from EntityFieldMetaData) |

See Also

EntityFieldMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


Count Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaDataList.Count Property

public Int32 Count {get;}

See Also

EntityFieldMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


EntityFieldMetaData Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaDataList.EntityFieldMetaData Property

Overload List

public EntityFieldMetaData this[Int32] {get;}

public EntityFieldMetaData this[String] {get;}

See Also

EntityFieldMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


Item Property (Int32)

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaDataList.Item Property (Int32)

public EntityFieldMetaData this[
Int32 Index
] {get;}

See Also

EntityFieldMetaDataList Class | Aptify.Framework.BusinessLogic Namespace | EntityFieldMetaDataList.EntityFieldMetaData Overload List


Item Property (String)

Aptify 5.0 Software Development Kit (SDK)

EntityFieldMetaDataList.Item Property (String)

public EntityFieldMetaData this[
String Name
] {get;}

See Also

EntityFieldMetaDataList Class | Aptify.Framework.BusinessLogic Namespace | EntityFieldMetaDataList.EntityFieldMetaData Overload List


EntityFieldMetaDataList Methods

The methods of the EntityFieldMetaDataList class are listed below. For a complete list of EntityFieldMetaDataList class members, see the EntityFieldMetaDataList Members topic.

Public Instance Methods

DynamicSharingRelationshipExists (inherited from EntityFieldMetaData) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

EntityFieldMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


EntityFieldMetaDataList.GetEnumerator Method

public IEnumerator GetEnumerator();

Implements

IEnumerable.

See Also

EntityFieldMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


EntityFieldValueMetaData Class

For a list of all members of this type, see EntityFieldValueMetaData Members.

System.Object
ReadDataRow
EntityFieldValueMetaData
EntityFieldValueMetaDataList

public class EntityFieldValueMetaData : ReadDataRow

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: Metadata (in Metadata.dll)

See Also

EntityFieldValueMetaData Members | Aptify.Framework.BusinessLogic Namespace


EntityFieldValueMetaData Members

EntityFieldValueMetaData overview

Public Instance Properties

Description
DisplayFields
OrderBy
Sequence
Value
WhereClause

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Fields

m_drCurrentRow (inherited from ReadDataRow)

Protected Instance Properties

CurrentRow (inherited from ReadDataRow)
Item (inherited from ReadDataRow)
Item (inherited from ReadDataRow)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EntityFieldValueMetaData Class | Aptify.Framework.BusinessLogic Namespace


EntityFieldValueMetaData Properties

The properties of the EntityFieldValueMetaData class are listed below. For a complete list of EntityFieldValueMetaData class members, see the EntityFieldValueMetaData Members topic.

Public Instance Properties

Description
DisplayFields
OrderBy
Sequence
Value
WhereClause

Protected Instance Properties

CurrentRow (inherited from ReadDataRow)
Item (inherited from ReadDataRow)
Item (inherited from ReadDataRow)

See Also

EntityFieldValueMetaData Class | Aptify.Framework.BusinessLogic Namespace


Description Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldValueMetaData.Description Property

public String Description {get;}

See Also

EntityFieldValueMetaData Class | Aptify.Framework.BusinessLogic Namespace


DisplayFields Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldValueMetaData.DisplayFields Property

public String DisplayFields {get;}

See Also

EntityFieldValueMetaData Class | Aptify.Framework.BusinessLogic Namespace


OrderBy Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldValueMetaData.OrderBy Property

public String OrderBy {get;}

See Also

EntityFieldValueMetaData Class | Aptify.Framework.BusinessLogic Namespace


Sequence Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldValueMetaData.Sequence Property

public Int32 Sequence {get;}

See Also

EntityFieldValueMetaData Class | Aptify.Framework.BusinessLogic Namespace


Value Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldValueMetaData.Value Property

public String Value {get;}

See Also

EntityFieldValueMetaData Class | Aptify.Framework.BusinessLogic Namespace


WhereClause Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldValueMetaData.WhereClause Property

public String WhereClause {get;}

See Also

EntityFieldValueMetaData Class | Aptify.Framework.BusinessLogic Namespace


EntityFieldValueMetaDataList Class

For a list of all members of this type, see EntityFieldValueMetaDataList Members.

System.Object
ReadDataRow
EntityFieldValueMetaData
EntityFieldValueMetaDataList

public class EntityFieldValueMetaDataList : EntityFieldValueMetaData, IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: Metadata (in Metadata.dll)

See Also

EntityFieldValueMetaDataList Members | Aptify.Framework.BusinessLogic Namespace


EntityFieldValueMetaDataList Members

EntityFieldValueMetaDataList overview

Public Instance Properties

Count |
Description (inherited from EntityFieldValueMetaData) |
DisplayFields (inherited from EntityFieldValueMetaData) |
EntityFieldsID |
Item | Overloaded.
OrderBy (inherited from EntityFieldValueMetaData) |
Sequence (inherited from EntityFieldValueMetaData) |
Value (inherited from EntityFieldValueMetaData) |
WhereClause (inherited from EntityFieldValueMetaData) |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

EntityFieldValueMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


EntityFieldValueMetaDataList Properties

The properties of the EntityFieldValueMetaDataList class are listed below. For a complete list of EntityFieldValueMetaDataList class members, see the EntityFieldValueMetaDataList Members topic.

Public Instance Properties

Count |
Description (inherited from EntityFieldValueMetaData) |
DisplayFields (inherited from EntityFieldValueMetaData) |
EntityFieldsID |
Item | Overloaded.
OrderBy (inherited from EntityFieldValueMetaData) |
Sequence (inherited from EntityFieldValueMetaData) |
Value (inherited from EntityFieldValueMetaData) |
WhereClause (inherited from EntityFieldValueMetaData) |

See Also

EntityFieldValueMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


Count Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldValueMetaDataList.Count Property

public Int32 Count {get;}

See Also

EntityFieldValueMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


EntityFieldsID Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldValueMetaDataList.EntityFieldsID Property

public Int64 EntityFieldsID {get;}

See Also

EntityFieldValueMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


EntityFieldValueMetaData Property

Aptify 5.0 Software Development Kit (SDK)

EntityFieldValueMetaDataList.EntityFieldValueMetaData Property

Overload List

public EntityFieldValueMetaData this[Int32] {get;}

public EntityFieldValueMetaData this[String] {get;}

See Also

EntityFieldValueMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


Item Property (Int32)

Aptify 5.0 Software Development Kit (SDK)

EntityFieldValueMetaDataList.Item Property (Int32)

public EntityFieldValueMetaData this[
Int32 Index
] {get;}

See Also

EntityFieldValueMetaDataList Class | Aptify.Framework.BusinessLogic Namespace | EntityFieldValueMetaDataList.EntityFieldValueMetaData Overload List


Item Property (String)

Aptify 5.0 Software Development Kit (SDK)

EntityFieldValueMetaDataList.Item Property (String)

public EntityFieldValueMetaData this[
String Name
] {get;}

See Also

EntityFieldValueMetaDataList Class | Aptify.Framework.BusinessLogic Namespace | EntityFieldValueMetaDataList.EntityFieldValueMetaData Overload List


EntityFieldValueMetaDataList Methods

The methods of the EntityFieldValueMetaDataList class are listed below. For a complete list of EntityFieldValueMetaDataList class members, see the EntityFieldValueMetaDataList Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

EntityFieldValueMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


EntityFieldValueMetaDataList.GetEnumerator Method

public IEnumerator GetEnumerator();

Implements

IEnumerable.

See Also

EntityFieldValueMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


EntityLevelMetaData Class

For a list of all members of this type, see EntityLevelMetaData Members.

System.Object
ReadDataRow
EntityLevelMetaData

public class EntityLevelMetaData : ReadDataRow

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: Metadata (in Metadata.dll)

See Also

EntityLevelMetaData Members | Aptify.Framework.BusinessLogic Namespace


EntityLevelMetaData Members

EntityLevelMetaData overview

Public Instance Properties

AllowInPlaceEditing |
AllowRecordHistoryRestore |
AppDLL |
AppDLLClass |
BaseDatabase |
BaseDSN |
BaseTable |
BaseView |
BaseViews |
BaseViewSQL |
Children |
ConfiguredUsers |
CreatePage |
DataObject |
DataOLEClass |
DefaultBaseViewForCurrentUser | Given a UserID, return the User's DefaultBaseView for the Entity. If no Default Base View has been defined for the User, return Nothing.
DefaultBaseViews |
DefaultPreviewPaneTemplateID | Returns Template ID attached for the preview pane.
DefaultViewTypeID |
DeletePage |
Description |
DisplayCultureString |
DisplayCultureStringID |
DisplayName |
DisplayNameWithCulture | Overloaded.
DisplayRequiredFieldIndicator | This property returns Require Field Indicator flag to determine whether custom color to be displayed or not.
EditPage |
EnableMRU |
EnableRecordsetQueryLimitation |
EnableViewer |
ExtensionApp |
ExtensionAppClass |
FieldLevelSecurity |
Fields |
FileExtension |
Filter |
FilterClass |
GenerateTable |
HelpObject |
HelpText |
HelpTextCultureStringID |
HelpTextCultureStringName |
HelpUrl |
Icon |
IconLarge |
ID |
IncludeInSetupCheckList |
InPlaceEditSecurity |
IsInstalled |
LicensedUsers |
LinkedEntityFields |
ListPage |
Name |
ParentID |
PluralName |
ReplicationSupport |
RequiredFieldBackColor | Returns required field Back color for required field.
RequiredFieldFontName | Returns required field font color for required field.
RequiredFieldFontSize | Returns required field font size for required field.
RequiredFieldFontStyle | Returns required field font style for required field.
RequiredFieldTextColor | Returns required field text color for required field.
RequireVersionComment |
ShowListFilters |
ShowRecordHistoryFilters |
ShowTopicCodeFilters |
spAddToList |
spCreateRecord |
spDeleteRecord |
spDeleteRelatedRecords |
spGetDependants |
spGetRecord |
spGetRelatedRecords |
spGetRelatedRecordsOrderBy |
spRelinkDependants |
spUpdateRecord |
SupportsDynamicSharing |
TrackVersions |
VerifyObject |
VerifyOLEClass |
ViewPage |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


EntityLevelMetaData Properties

The properties of the EntityLevelMetaData class are listed below. For a complete list of EntityLevelMetaData class members, see the EntityLevelMetaData Members topic.

Public Instance Properties

AllowInPlaceEditing |
AllowRecordHistoryRestore |
AppDLL |
AppDLLClass |
BaseDatabase |
BaseDSN |
BaseTable |
BaseView |
BaseViews |
BaseViewSQL |
Children |
ConfiguredUsers |
CreatePage |
DataObject |
DataOLEClass |
DefaultBaseViewForCurrentUser | Given a UserID, return the User's DefaultBaseView for the Entity. If no Default Base View has been defined for the User, return Nothing.
DefaultBaseViews |
DefaultPreviewPaneTemplateID | Returns Template ID attached for the preview pane.
DefaultViewTypeID |
DeletePage |
Description |
DisplayCultureString |
DisplayCultureStringID |
DisplayName |
DisplayNameWithCulture | Overloaded.
DisplayRequiredFieldIndicator | This property returns Require Field Indicator flag to determine whether custom color to be displayed or not.
EditPage |
EnableMRU |
EnableRecordsetQueryLimitation |
EnableViewer |
ExtensionApp |
ExtensionAppClass |
FieldLevelSecurity |
Fields |
FileExtension |
Filter |
FilterClass |
GenerateTable |
HelpObject |
HelpText |
HelpTextCultureStringID |
HelpTextCultureStringName |
HelpUrl |
Icon |
IconLarge |
ID |
IncludeInSetupCheckList |
InPlaceEditSecurity |
IsInstalled |
LicensedUsers |
LinkedEntityFields |
ListPage |
Name |
ParentID |
PluralName |
ReplicationSupport |
RequiredFieldBackColor | Returns required field Back color for required field.
RequiredFieldFontName | Returns required field font color for required field.
RequiredFieldFontSize | Returns required field font size for required field.
RequiredFieldFontStyle | Returns required field font style for required field.
RequiredFieldTextColor | Returns required field text color for required field.
RequireVersionComment |
ShowListFilters |
ShowRecordHistoryFilters |
ShowTopicCodeFilters |
spAddToList |
spCreateRecord |
spDeleteRecord |
spDeleteRelatedRecords |
spGetDependants |
spGetRecord |
spGetRelatedRecords |
spGetRelatedRecordsOrderBy |
spRelinkDependants |
spUpdateRecord |
SupportsDynamicSharing |
TrackVersions |
VerifyObject |
VerifyOLEClass |
ViewPage |

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


AllowInPlaceEditing Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.AllowInPlaceEditing Property

public Boolean AllowInPlaceEditing {get;}

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


AllowRecordHistoryRestore Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.AllowRecordHistoryRestore Property

public Boolean AllowRecordHistoryRestore {get;}

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


AppDLL Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.AppDLL Property

public String AppDLL {get;}

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


AppDLLClass Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.AppDLLClass Property

public String AppDLLClass {get;}

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


BaseDatabase Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.BaseDatabase Property

public String BaseDatabase {get;}

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


BaseDSN Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.BaseDSN Property

public String BaseDSN {get;}

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


BaseTable Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.BaseTable Property

public String BaseTable {get;}

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


BaseView Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.BaseView Property

public String BaseView {get;}

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


BaseViews Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.BaseViews Property

public EntityBaseViewMetaDataList BaseViews {get;}

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


BaseViewSQL Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.BaseViewSQL Property

public String BaseViewSQL {get;}

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


Children Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.Children Property

public EntityLevelMetaDataList Children {get;}

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


ConfiguredUsers Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.ConfiguredUsers Property

public Int64 ConfiguredUsers {get;}

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


CreatePage Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.CreatePage Property

public String CreatePage {get;}

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


DataObject Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.DataObject Property

public String DataObject {get;}

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


DataOLEClass Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.DataOLEClass Property

public String DataOLEClass {get;}

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


DefaultBaseViewForCurrentUser Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.DefaultBaseViewForCurrentUser Property

Given a UserID, return the User's DefaultBaseView for the Entity. If no Default Base View has been defined for the User, return Nothing.

public EntityBaseViewMetaData DefaultBaseViewForCurrentUser {get;}

Property Value

Remarks

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


DefaultBaseViews Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.DefaultBaseViews Property

public EntityDefaultBaseViewMetaDataList DefaultBaseViews {get;}

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


DefaultPreviewPaneTemplateID Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.DefaultPreviewPaneTemplateID Property

Returns Template ID attached for the preview pane.

public Int64 DefaultPreviewPaneTemplateID {get;}

Property Value

Remarks

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


DefaultViewTypeID Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.DefaultViewTypeID Property

public Int64 DefaultViewTypeID {get;}

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


DeletePage Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.DeletePage Property

public String DeletePage {get;}

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


Description Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.Description Property

public String Description {get;}

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


DisplayCultureString Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.DisplayCultureString Property

public String DisplayCultureString {get;}

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


DisplayCultureStringID Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.DisplayCultureStringID Property

public Int64 DisplayCultureStringID {get;}

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


DisplayName Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.DisplayName Property

public String DisplayName {get;}

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


String Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.String Property

Overload List

public String this[Int64, UserCredentials] {get;}

public String this[Int64, Boolean, UserCredentials] {get;}

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


DisplayNameWithCulture Property (Int64, UserCredentials)

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.DisplayNameWithCulture Property (Int64, UserCredentials)

public String this[
Int64 CultureID,
UserCredentials UserCredentials
] {get;}

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace | EntityLevelMetaData.String Overload List


DisplayNameWithCulture Property (Int64, Boolean, UserCredentials)

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.DisplayNameWithCulture Property (Int64, Boolean, UserCredentials)

public String this[
Int64 CultureID,
Boolean AutoMapDisplayName,
UserCredentials UserCredentials
] {get;}

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace | EntityLevelMetaData.String Overload List


DisplayRequiredFieldIndicator Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.DisplayRequiredFieldIndicator Property

This property returns Require Field Indicator flag to determine whether custom color to be displayed or not.

public Boolean DisplayRequiredFieldIndicator {get;}

Property Value

Remarks

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


EditPage Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.EditPage Property

public String EditPage {get;}

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


EnableMRU Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.EnableMRU Property

public Boolean EnableMRU {get;}

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


EnableRecordsetQueryLimitation Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.EnableRecordsetQueryLimitation Property

public Boolean EnableRecordsetQueryLimitation {get;}

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


EnableViewer Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.EnableViewer Property

public Boolean EnableViewer {get;}

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


ExtensionApp Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.ExtensionApp Property

public String ExtensionApp {get;}

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


ExtensionAppClass Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.ExtensionAppClass Property

public String ExtensionAppClass {get;}

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


FieldLevelSecurity Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.FieldLevelSecurity Property

public Boolean FieldLevelSecurity {get;}

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


Fields Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.Fields Property

public EntityFieldMetaDataList Fields {get;}

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


FileExtension Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.FileExtension Property

public String FileExtension {get;}

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


Filter Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.Filter Property

public String Filter {get;}

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


FilterClass Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.FilterClass Property

public String FilterClass {get;}

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


GenerateTable Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.GenerateTable Property

public Boolean GenerateTable {get;}

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


HelpObject Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.HelpObject Property

public String HelpObject {get;}

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


HelpText Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.HelpText Property

public String HelpText {get;}

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


HelpTextCultureStringID Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.HelpTextCultureStringID Property

public Int64 HelpTextCultureStringID {get;}

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


HelpTextCultureStringName Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.HelpTextCultureStringName Property

public String HelpTextCultureStringName {get;}

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


HelpUrl Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.HelpUrl Property

public String HelpUrl {get;}

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


Icon Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.Icon Property

public String Icon {get;}

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


IconLarge Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.IconLarge Property

public String IconLarge {get;}

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.ID Property

public Int64 ID {get;}

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


IncludeInSetupCheckList Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.IncludeInSetupCheckList Property

public Boolean IncludeInSetupCheckList {get;}

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


InPlaceEditSecurity Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.InPlaceEditSecurity Property

public InPlaceEditSecurity InPlaceEditSecurity {get;}

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


IsInstalled Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.IsInstalled Property

public Boolean IsInstalled {get;}

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


LicensedUsers Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.LicensedUsers Property

public Int64 LicensedUsers {get;}

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


LinkedEntityFields Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.LinkedEntityFields Property

public List<T> LinkedEntityFields {get;}

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


ListPage Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.ListPage Property

public String ListPage {get;}

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


Name Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.Name Property

public String Name {get;}

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


ParentID Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.ParentID Property

public Int64 ParentID {get;}

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


PluralName Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.PluralName Property

public String PluralName {get;}

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


ReplicationSupport Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.ReplicationSupport Property

public String ReplicationSupport {get;}

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


RequiredFieldBackColor Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.RequiredFieldBackColor Property

Returns required field Back color for required field.

public String RequiredFieldBackColor {get;}

Property Value

Remarks

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


RequiredFieldFontName Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.RequiredFieldFontName Property

Returns required field font color for required field.

public String RequiredFieldFontName {get;}

Property Value

Remarks

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


RequiredFieldFontSize Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.RequiredFieldFontSize Property

Returns required field font size for required field.

public Int64 RequiredFieldFontSize {get;}

Property Value

Remarks

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


RequiredFieldFontStyle Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.RequiredFieldFontStyle Property

Returns required field font style for required field.

public String RequiredFieldFontStyle {get;}

Property Value

Remarks

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


RequiredFieldTextColor Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.RequiredFieldTextColor Property

Returns required field text color for required field.

public String RequiredFieldTextColor {get;}

Property Value

Remarks

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


RequireVersionComment Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.RequireVersionComment Property

public Boolean RequireVersionComment {get;}

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


ShowListFilters Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.ShowListFilters Property

public Boolean ShowListFilters {get;}

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


ShowRecordHistoryFilters Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.ShowRecordHistoryFilters Property

public Boolean ShowRecordHistoryFilters {get;}

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


ShowTopicCodeFilters Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.ShowTopicCodeFilters Property

public Boolean ShowTopicCodeFilters {get;}

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


spAddToList Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.spAddToList Property

public String spAddToList {get;}

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


spCreateRecord Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.spCreateRecord Property

public String spCreateRecord {get;}

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


spDeleteRecord Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.spDeleteRecord Property

public String spDeleteRecord {get;}

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


spDeleteRelatedRecords Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.spDeleteRelatedRecords Property

public String spDeleteRelatedRecords {get;}

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


spGetDependants Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.spGetDependants Property

public String spGetDependants {get;}

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


spGetRecord Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.spGetRecord Property

public String spGetRecord {get;}

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


spGetRelatedRecords Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.spGetRelatedRecords Property

public String spGetRelatedRecords {get;}

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


spGetRelatedRecordsOrderBy Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.spGetRelatedRecordsOrderBy Property

public String spGetRelatedRecordsOrderBy {get;}

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


spRelinkDependants Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.spRelinkDependants Property

public String spRelinkDependants {get;}

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


spUpdateRecord Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.spUpdateRecord Property

public String spUpdateRecord {get;}

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


SupportsDynamicSharing Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.SupportsDynamicSharing Property

public Boolean SupportsDynamicSharing {get;}

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


TrackVersions Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.TrackVersions Property

public Boolean TrackVersions {get;}

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


VerifyObject Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.VerifyObject Property

public String VerifyObject {get;}

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


VerifyOLEClass Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.VerifyOLEClass Property

public String VerifyOLEClass {get;}

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


ViewPage Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaData.ViewPage Property

public String ViewPage {get;}

See Also

EntityLevelMetaData Class | Aptify.Framework.BusinessLogic Namespace


EntityLevelMetaDataList Class

For a list of all members of this type, see EntityLevelMetaDataList Members.

System.Object
EntityLevelMetaDataList

public class EntityLevelMetaDataList : IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: Metadata (in Metadata.dll)

See Also

EntityLevelMetaDataList Members | Aptify.Framework.BusinessLogic Namespace


EntityLevelMetaDataList Members

EntityLevelMetaDataList overview

Public Instance Properties

Count |
Item | Overloaded.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

EntityLevelMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


EntityLevelMetaDataList Properties

The properties of the EntityLevelMetaDataList class are listed below. For a complete list of EntityLevelMetaDataList class members, see the EntityLevelMetaDataList Members topic.

Public Instance Properties

Count |
Item | Overloaded.

See Also

EntityLevelMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


Count Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaDataList.Count Property

public Int32 Count {get;}

See Also

EntityLevelMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


EntityLevelMetaData Property

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaDataList.EntityLevelMetaData Property

Overload List

public EntityLevelMetaData this[Int32] {get;}

public EntityLevelMetaData this[String] {get;}

See Also

EntityLevelMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


Item Property (Int32)

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaDataList.Item Property (Int32)

public EntityLevelMetaData this[
Int32 Index
] {get;}

See Also

EntityLevelMetaDataList Class | Aptify.Framework.BusinessLogic Namespace | EntityLevelMetaDataList.EntityLevelMetaData Overload List


Item Property (String)

Aptify 5.0 Software Development Kit (SDK)

EntityLevelMetaDataList.Item Property (String)

public EntityLevelMetaData this[
String Name
] {get;}

See Also

EntityLevelMetaDataList Class | Aptify.Framework.BusinessLogic Namespace | EntityLevelMetaDataList.EntityLevelMetaData Overload List


EntityLevelMetaDataList Methods

The methods of the EntityLevelMetaDataList class are listed below. For a complete list of EntityLevelMetaDataList class members, see the EntityLevelMetaDataList Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

EntityLevelMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


EntityLevelMetaDataList.GetEnumerator Method

public IEnumerator GetEnumerator();

Implements

IEnumerable.

See Also

EntityLevelMetaDataList Class | Aptify.Framework.BusinessLogic Namespace


ExtenderEntityMetaData Class

Defines meta-data related to the Entity Extension

For a list of all members of this type, see ExtenderEntityMetaData Members.

System.Object
ExtenderEntityMetaData

public class ExtenderEntityMetaData

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: Metadata (in Metadata.dll)

See Also

ExtenderEntityMetaData Members | Aptify.Framework.BusinessLogic Namespace


ExtenderEntityMetaData Members

ExtenderEntityMetaData overview

Public Instance Constructors

ExtenderEntityMetaData Constructor

Public Instance Properties

DisplayCultureStringID |
DisplayName |
DisplayNameWithCulture | Overloaded.
Entity | Name of the extender entity
ExtenderEntityID |
ExtenderType |
FilterRuleID |
ParentEntityID |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetExtenderEntityParentLinkField | This method determines which field within the specified Extender Entity meta-data is the foreign key link to the parent/owner entity.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExtenderEntityMetaData Class | Aptify.Framework.BusinessLogic Namespace


ExtenderEntityMetaData Constructor

public ExtenderEntityMetaData(
DataRow DataRow
);

See Also

ExtenderEntityMetaData Class | Aptify.Framework.BusinessLogic Namespace


ExtenderEntityMetaData Properties

The properties of the ExtenderEntityMetaData class are listed below. For a complete list of ExtenderEntityMetaData class members, see the ExtenderEntityMetaData Members topic.

Public Instance Properties

DisplayCultureStringID |
DisplayName |
DisplayNameWithCulture | Overloaded.
Entity | Name of the extender entity
ExtenderEntityID |
ExtenderType |
FilterRuleID |
ParentEntityID |

See Also

ExtenderEntityMetaData Class | Aptify.Framework.BusinessLogic Namespace


DisplayCultureStringID Property

Aptify 5.0 Software Development Kit (SDK)

ExtenderEntityMetaData.DisplayCultureStringID Property

public virtual Int64 DisplayCultureStringID {get;}

See Also

ExtenderEntityMetaData Class | Aptify.Framework.BusinessLogic Namespace


DisplayName Property

Aptify 5.0 Software Development Kit (SDK)

ExtenderEntityMetaData.DisplayName Property

public virtual String DisplayName {get;}

See Also

ExtenderEntityMetaData Class | Aptify.Framework.BusinessLogic Namespace


String Property

Aptify 5.0 Software Development Kit (SDK)

ExtenderEntityMetaData.String Property

Overload List

public String this[Int64, UserCredentials] {get;}

public String this[Int64, Boolean, UserCredentials] {get;}

See Also

ExtenderEntityMetaData Class | Aptify.Framework.BusinessLogic Namespace


DisplayNameWithCulture Property (Int64, UserCredentials)

Aptify 5.0 Software Development Kit (SDK)

ExtenderEntityMetaData.DisplayNameWithCulture Property (Int64, UserCredentials)

public String this[
Int64 CultureID,
UserCredentials UserCredentials
] {get;}

See Also

ExtenderEntityMetaData Class | Aptify.Framework.BusinessLogic Namespace | ExtenderEntityMetaData.String Overload List


DisplayNameWithCulture Property (Int64, Boolean, UserCredentials)

Aptify 5.0 Software Development Kit (SDK)

ExtenderEntityMetaData.DisplayNameWithCulture Property (Int64, Boolean, UserCredentials)

public String this[
Int64 CultureID,
Boolean AutoMapDisplayName,
UserCredentials UserCredentials
] {get;}

See Also

ExtenderEntityMetaData Class | Aptify.Framework.BusinessLogic Namespace | ExtenderEntityMetaData.String Overload List


Entity Property

Aptify 5.0 Software Development Kit (SDK)

ExtenderEntityMetaData.Entity Property

Name of the extender entity

public virtual String Entity {get;}

Property Value

Remarks

See Also

ExtenderEntityMetaData Class | Aptify.Framework.BusinessLogic Namespace


ExtenderEntityID Property

Aptify 5.0 Software Development Kit (SDK)

ExtenderEntityMetaData.ExtenderEntityID Property

public virtual Int64 ExtenderEntityID {get;}

See Also

ExtenderEntityMetaData Class | Aptify.Framework.BusinessLogic Namespace


ExtenderType Property

Aptify 5.0 Software Development Kit (SDK)

ExtenderEntityMetaData.ExtenderType Property

public virtual ExtenderEntityMetaData.ExtenderEntityType ExtenderType {get;}

See Also

ExtenderEntityMetaData Class | Aptify.Framework.BusinessLogic Namespace


FilterRuleID Property

Aptify 5.0 Software Development Kit (SDK)

ExtenderEntityMetaData.FilterRuleID Property

public virtual Int64 FilterRuleID {get;}

See Also

ExtenderEntityMetaData Class | Aptify.Framework.BusinessLogic Namespace


ParentEntityID Property

Aptify 5.0 Software Development Kit (SDK)

ExtenderEntityMetaData.ParentEntityID Property

public virtual Int64 ParentEntityID {get;}

See Also

ExtenderEntityMetaData Class | Aptify.Framework.BusinessLogic Namespace


ExtenderEntityMetaData Methods

The methods of the ExtenderEntityMetaData class are listed below. For a complete list of ExtenderEntityMetaData class members, see the ExtenderEntityMetaData Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetExtenderEntityParentLinkField | This method determines which field within the specified Extender Entity meta-data is the foreign key link to the parent/owner entity.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExtenderEntityMetaData Class | Aptify.Framework.BusinessLogic Namespace


ExtenderEntityMetaData.GetExtenderEntityParentLinkField Method

This method determines which field within the specified Extender Entity meta-data is the foreign key link to the parent/owner entity.

public virtual string GetExtenderEntityParentLinkField(
EntityLevelMetaData ExtenderEntityMetaData
);

Parameters

ExtenderEntityMetaData
EntityLevelMetaData class instance for the extender entity. See the MetadataSingleton class for information on how to access the meta-data cache

Return Value

Remarks

See Also

ExtenderEntityMetaData Class | Aptify.Framework.BusinessLogic Namespace


ExtenderEntityMetaData.ExtenderEntityType Enumeration

public enum ExtenderEntityMetaData.ExtenderEntityType

Members

Member Name | Description
Required |
Optional |

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: Metadata (in Metadata.dll)

See Also

Aptify.Framework.BusinessLogic Namespace


ExtenderEntityMetaDataCache Class

For a list of all members of this type, see ExtenderEntityMetaDataCache Members.

System.Object
ExtenderEntityMetaDataCache

public class ExtenderEntityMetaDataCache

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: Metadata (in Metadata.dll)

See Also

ExtenderEntityMetaDataCache Members | Aptify.Framework.BusinessLogic Namespace


ExtenderEntityMetaDataCache Members

ExtenderEntityMetaDataCache overview

Public Static Properties

Instance

Public Instance Properties

DataAction
Table

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetExtenderEntities | Returns a list of extender entities for a given entity. Utility function - access the ExtenderEntities property of the EntityLevelMetaData to access this more efficiently as the result of this function is cached within the ExtenderEntities property of the EntityLevelMetaData class.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExtenderEntityMetaDataCache Class | Aptify.Framework.BusinessLogic Namespace


ExtenderEntityMetaDataCache Properties

The properties of the ExtenderEntityMetaDataCache class are listed below. For a complete list of ExtenderEntityMetaDataCache class members, see the ExtenderEntityMetaDataCache Members topic.

Public Static Properties

Instance

Public Instance Properties

DataAction
Table

See Also

ExtenderEntityMetaDataCache Class | Aptify.Framework.BusinessLogic Namespace


DataAction Property

Aptify 5.0 Software Development Kit (SDK)

ExtenderEntityMetaDataCache.DataAction Property

public virtual DataAction DataAction {get;}

See Also

ExtenderEntityMetaDataCache Class | Aptify.Framework.BusinessLogic Namespace


Instance Property

Aptify 5.0 Software Development Kit (SDK)

ExtenderEntityMetaDataCache.Instance Property

public static ExtenderEntityMetaDataCache this[
UserCredentials UserCredentials,
Boolean Refresh
] {get;}

See Also

ExtenderEntityMetaDataCache Class | Aptify.Framework.BusinessLogic Namespace


Table Property

Aptify 5.0 Software Development Kit (SDK)

ExtenderEntityMetaDataCache.Table Property

public virtual DataTable Table {get;}

See Also

ExtenderEntityMetaDataCache Class | Aptify.Framework.BusinessLogic Namespace


ExtenderEntityMetaDataCache Methods

The methods of the ExtenderEntityMetaDataCache class are listed below. For a complete list of ExtenderEntityMetaDataCache class members, see the ExtenderEntityMetaDataCache Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetExtenderEntities | Returns a list of extender entities for a given entity. Utility function - access the ExtenderEntities property of the EntityLevelMetaData to access this more efficiently as the result of this function is cached within the ExtenderEntities property of the EntityLevelMetaData class.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExtenderEntityMetaDataCache Class | Aptify.Framework.BusinessLogic Namespace


ExtenderEntityMetaDataCache.GetExtenderEntities Method

Returns a list of extender entities for a given entity. Utility function - access the ExtenderEntities property of the EntityLevelMetaData to access this more efficiently as the result of this function is cached within the ExtenderEntities property of the EntityLevelMetaData class.

public virtual List<T> GetExtenderEntities(
Int64 EntityID
);

Parameters

EntityID

Return Value

Remarks

See Also

ExtenderEntityMetaDataCache Class | Aptify.Framework.BusinessLogic Namespace


FieldAlignment Enumeration

public enum FieldAlignment

Members

Member Name | Description
SystemDefault |
Left |
Center |
Right |

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: Metadata (in Metadata.dll)

See Also

Aptify.Framework.BusinessLogic Namespace


FieldGenericDataType Enumeration

public enum FieldGenericDataType

Members

Member Name | Description
Numeric |
Text |
DateTime |
Time |

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: Metadata (in Metadata.dll)

See Also

Aptify.Framework.BusinessLogic Namespace


FieldGUITypeMultiSelect Enumeration

public enum FieldGUITypeMultiSelect

Members

Member Name | Description
NotSupported |
SupportedStandardDialog |
SupportedCustomDialog |

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: Metadata (in Metadata.dll)

See Also

Aptify.Framework.BusinessLogic Namespace


FieldGUITypeSingleSelect Enumeration

public enum FieldGUITypeSingleSelect

Members

Member Name | Description
NotSupported |
Supported |

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: Metadata (in Metadata.dll)

See Also

Aptify.Framework.BusinessLogic Namespace


FieldLinkType Enumeration

public enum FieldLinkType

Members

Member Name | Description
Standard |
Embedded |

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: Metadata (in Metadata.dll)

See Also

Aptify.Framework.BusinessLogic Namespace


FieldValueListType Enumeration

public enum FieldValueListType

Members

Member Name | Description
StaticList |
SQLStatement |
EntityLink |

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: Metadata (in Metadata.dll)

See Also

Aptify.Framework.BusinessLogic Namespace


GenericEntityCollection Class

For a list of all members of this type, see GenericEntityCollection Members.

System.Object
CollectionBase
GenericEntityCollection

public class GenericEntityCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: AptifyMerge (in AptifyMerge.dll)

See Also

GenericEntityCollection Members | Aptify.Framework.BusinessLogic Namespace


GenericEntityCollection Members

GenericEntityCollection overview

Public Instance Constructors

GenericEntityCollection Constructor Initializes a new instance of the GenericEntityCollection class.

Public Instance Properties

Capacity (inherited from CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
Item | Overloaded.

Public Instance Methods

Add |
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that iterates through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Remove |
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

GenericEntityCollection Class | Aptify.Framework.BusinessLogic Namespace


GenericEntityCollection Constructor

Initializes a new instance of the GenericEntityCollection class.

public GenericEntityCollection();

See Also

GenericEntityCollection Class | Aptify.Framework.BusinessLogic Namespace


GenericEntityCollection Properties

The properties of the GenericEntityCollection class are listed below. For a complete list of GenericEntityCollection class members, see the GenericEntityCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
Item | Overloaded.

See Also

GenericEntityCollection Class | Aptify.Framework.BusinessLogic Namespace


AptifyGenericEntityBase Property

Aptify 5.0 Software Development Kit (SDK)

GenericEntityCollection.AptifyGenericEntityBase Property

Overload List

public AptifyGenericEntityBase this[Int32] {get;}

public AptifyGenericEntityBase this[String] {get;}

See Also

GenericEntityCollection Class | Aptify.Framework.BusinessLogic Namespace


Item Property (Int32)

Aptify 5.0 Software Development Kit (SDK)

GenericEntityCollection.Item Property (Int32)

public AptifyGenericEntityBase this[
Int32 index
] {get;}

See Also

GenericEntityCollection Class | Aptify.Framework.BusinessLogic Namespace | GenericEntityCollection.AptifyGenericEntityBase Overload List


Item Property (String)

Aptify 5.0 Software Development Kit (SDK)

GenericEntityCollection.Item Property (String)

public AptifyGenericEntityBase this[
String key
] {get;}

See Also

GenericEntityCollection Class | Aptify.Framework.BusinessLogic Namespace | GenericEntityCollection.AptifyGenericEntityBase Overload List


GenericEntityCollection Methods

The methods of the GenericEntityCollection class are listed below. For a complete list of GenericEntityCollection class members, see the GenericEntityCollection Members topic.

Public Instance Methods

Add |
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that iterates through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Remove |
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

GenericEntityCollection Class | Aptify.Framework.BusinessLogic Namespace


GenericEntityCollection.Add Method

public void Add(
AptifyGenericEntityBase Ge,
String Key
);

See Also

GenericEntityCollection Class | Aptify.Framework.BusinessLogic Namespace


GenericEntityCollection.Remove Method

public void Remove(
String key,
Int32 index
);

See Also

GenericEntityCollection Class | Aptify.Framework.BusinessLogic Namespace


InPlaceEditSecurity Enumeration

public enum InPlaceEditSecurity

Members

Member Name | Description
AllUsers |
SpecifiedUsersGroups |

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: Metadata (in Metadata.dll)

See Also

Aptify.Framework.BusinessLogic Namespace


InputMaskType Enumeration

public enum InputMaskType

Members

Member Name | Description
Automatic |
Manual |

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: Metadata (in Metadata.dll)

See Also

Aptify.Framework.BusinessLogic Namespace


LinkedEntityFieldMetaData Class

Tracks meta-data associated with linked fields that bind entities together

For a list of all members of this type, see LinkedEntityFieldMetaData Members.

System.Object
LinkedEntityFieldMetaData

public class LinkedEntityFieldMetaData

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: Metadata (in Metadata.dll)

See Also

LinkedEntityFieldMetaData Members | Aptify.Framework.BusinessLogic Namespace


LinkedEntityFieldMetaData Members

LinkedEntityFieldMetaData overview

Public Instance Constructors

LinkedEntityFieldMetaData Overloaded. Initializes a new instance of the LinkedEntityFieldMetaData class.

Public Instance Properties

DisplayName
EntityBaseDatabase
EntityBaseTable
EntityBaseView
EntityDisplayName
EntityID
EntityName
EntityParentID
LinkedEntityField
Name
ParentLinkedValue
Sequence
SQLDataType

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LinkedEntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


LinkedEntityFieldMetaData Constructor

Overload List

public LinkedEntityFieldMetaData(Int64,String,String,String,String,String,Int64,String,Int32,String,String,String,String);

public LinkedEntityFieldMetaData(Int64,String,String,String,String,String,Int64,String,Int32,String,String,String,String,Boolean);

See Also

LinkedEntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


LinkedEntityFieldMetaData Constructor (Int64, String, String, String, String, String, Int64, String, Int32, String, String, String, String)

public LinkedEntityFieldMetaData(
Int64 EntityID,
String EntityName,
String EntityDisplayName,
String EntityBaseTable,
String EntityBaseView,
String EntityBaseDatabase,
Int64 EntityParentID,
String Name,
Int32 Sequence,
String DisplayName,
String SQLDataType,
String ParentLinkedValue,
String LinkedEntityField
);

See Also

LinkedEntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace | LinkedEntityFieldMetaData Constructor Overload List


LinkedEntityFieldMetaData Constructor (Int64, String, String, String, String, String, Int64, String, Int32, String, String, String, String, Boolean)

public LinkedEntityFieldMetaData(
Int64 EntityID,
String EntityName,
String EntityDisplayName,
String EntityBaseTable,
String EntityBaseView,
String EntityBaseDatabase,
Int64 EntityParentID,
String Name,
Int32 Sequence,
String DisplayName,
String SQLDataType,
String ParentLinkedValue,
String LinkedEntityField,
Boolean HasForeignKey
);

See Also

LinkedEntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace | LinkedEntityFieldMetaData Constructor Overload List


LinkedEntityFieldMetaData Properties

The properties of the LinkedEntityFieldMetaData class are listed below. For a complete list of LinkedEntityFieldMetaData class members, see the LinkedEntityFieldMetaData Members topic.

Public Instance Properties

DisplayName
EntityBaseDatabase
EntityBaseTable
EntityBaseView
EntityDisplayName
EntityID
EntityName
EntityParentID
LinkedEntityField
Name
ParentLinkedValue
Sequence
SQLDataType

See Also

LinkedEntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


DisplayName Property

Aptify 5.0 Software Development Kit (SDK)

LinkedEntityFieldMetaData.DisplayName Property

public String DisplayName {get;}

See Also

LinkedEntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


EntityBaseDatabase Property

Aptify 5.0 Software Development Kit (SDK)

LinkedEntityFieldMetaData.EntityBaseDatabase Property

public String EntityBaseDatabase {get;}

See Also

LinkedEntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


EntityBaseTable Property

Aptify 5.0 Software Development Kit (SDK)

LinkedEntityFieldMetaData.EntityBaseTable Property

public String EntityBaseTable {get;}

See Also

LinkedEntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


EntityBaseView Property

Aptify 5.0 Software Development Kit (SDK)

LinkedEntityFieldMetaData.EntityBaseView Property

public String EntityBaseView {get;}

See Also

LinkedEntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


EntityDisplayName Property

Aptify 5.0 Software Development Kit (SDK)

LinkedEntityFieldMetaData.EntityDisplayName Property

public String EntityDisplayName {get;}

See Also

LinkedEntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


EntityID Property

Aptify 5.0 Software Development Kit (SDK)

LinkedEntityFieldMetaData.EntityID Property

public Int64 EntityID {get;}

See Also

LinkedEntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


EntityName Property

Aptify 5.0 Software Development Kit (SDK)

LinkedEntityFieldMetaData.EntityName Property

public String EntityName {get;}

See Also

LinkedEntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


EntityParentID Property

Aptify 5.0 Software Development Kit (SDK)

LinkedEntityFieldMetaData.EntityParentID Property

public Int64 EntityParentID {get;}

See Also

LinkedEntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


LinkedEntityField Property

Aptify 5.0 Software Development Kit (SDK)

LinkedEntityFieldMetaData.LinkedEntityField Property

public String LinkedEntityField {get;}

See Also

LinkedEntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


Name Property

Aptify 5.0 Software Development Kit (SDK)

LinkedEntityFieldMetaData.Name Property

public String Name {get;}

See Also

LinkedEntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


ParentLinkedValue Property

Aptify 5.0 Software Development Kit (SDK)

LinkedEntityFieldMetaData.ParentLinkedValue Property

public String ParentLinkedValue {get;}

See Also

LinkedEntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


Sequence Property

Aptify 5.0 Software Development Kit (SDK)

LinkedEntityFieldMetaData.Sequence Property

public Int32 Sequence {get;}

See Also

LinkedEntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


SQLDataType Property

Aptify 5.0 Software Development Kit (SDK)

LinkedEntityFieldMetaData.SQLDataType Property

public String SQLDataType {get;}

See Also

LinkedEntityFieldMetaData Class | Aptify.Framework.BusinessLogic Namespace


MasterTaskAndContactLogLink Class

For a list of all members of this type, see MasterTaskAndContactLogLink Members.

System.Object
MasterTaskAndContactLogLink

public class MasterTaskAndContactLogLink

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: AptifyMerge (in AptifyMerge.dll)

See Also

MasterTaskAndContactLogLink Members | Aptify.Framework.BusinessLogic Namespace


MasterTaskAndContactLogLink Members

MasterTaskAndContactLogLink overview

Public Instance Constructors

MasterTaskAndContactLogLink Constructor

Public Instance Properties

IsDirty

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ProcessLink |
Save |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MasterTaskAndContactLogLink Class | Aptify.Framework.BusinessLogic Namespace


MasterTaskAndContactLogLink Constructor

public MasterTaskAndContactLogLink(
String LinkType,
UserCredentials UserCredential,
String EntityName,
Int64 RecordID
);

See Also

MasterTaskAndContactLogLink Class | Aptify.Framework.BusinessLogic Namespace


MasterTaskAndContactLogLink Properties

The properties of the MasterTaskAndContactLogLink class are listed below. For a complete list of MasterTaskAndContactLogLink class members, see the MasterTaskAndContactLogLink Members topic.

Public Instance Properties

IsDirty

See Also

MasterTaskAndContactLogLink Class | Aptify.Framework.BusinessLogic Namespace


IsDirty Property

Aptify 5.0 Software Development Kit (SDK)

MasterTaskAndContactLogLink.IsDirty Property

public Boolean IsDirty {get;}

See Also

MasterTaskAndContactLogLink Class | Aptify.Framework.BusinessLogic Namespace


MasterTaskAndContactLogLink Methods

The methods of the MasterTaskAndContactLogLink class are listed below. For a complete list of MasterTaskAndContactLogLink class members, see the MasterTaskAndContactLogLink Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ProcessLink |
Save |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MasterTaskAndContactLogLink Class | Aptify.Framework.BusinessLogic Namespace


MasterTaskAndContactLogLink.ProcessLink Method

public void ProcessLink(
Int64 RecordID,
ArrayList MergeIDs
);

See Also

MasterTaskAndContactLogLink Class | Aptify.Framework.BusinessLogic Namespace


MasterTaskAndContactLogLink.Save Method

public void Save();

See Also

MasterTaskAndContactLogLink Class | Aptify.Framework.BusinessLogic Namespace


MasterTopicCodeLink Class

For a list of all members of this type, see MasterTopicCodeLink Members.

System.Object
MasterTopicCodeLink

public class MasterTopicCodeLink

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: AptifyMerge (in AptifyMerge.dll)

See Also

MasterTopicCodeLink Members | Aptify.Framework.BusinessLogic Namespace


MasterTopicCodeLink Members

MasterTopicCodeLink overview

Public Instance Constructors

MasterTopicCodeLink Constructor

Public Instance Properties

IsDirty

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ProcessTopicCodeLink |
Save |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MasterTopicCodeLink Class | Aptify.Framework.BusinessLogic Namespace


MasterTopicCodeLink Constructor

public MasterTopicCodeLink(
UserCredentials UserCredential,
String EntityName,
Int64 RecordID
);

See Also

MasterTopicCodeLink Class | Aptify.Framework.BusinessLogic Namespace


MasterTopicCodeLink Properties

The properties of the MasterTopicCodeLink class are listed below. For a complete list of MasterTopicCodeLink class members, see the MasterTopicCodeLink Members topic.

Public Instance Properties

IsDirty

See Also

MasterTopicCodeLink Class | Aptify.Framework.BusinessLogic Namespace


IsDirty Property

Aptify 5.0 Software Development Kit (SDK)

MasterTopicCodeLink.IsDirty Property

public Boolean IsDirty {get;}

See Also

MasterTopicCodeLink Class | Aptify.Framework.BusinessLogic Namespace


MasterTopicCodeLink Methods

The methods of the MasterTopicCodeLink class are listed below. For a complete list of MasterTopicCodeLink class members, see the MasterTopicCodeLink Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ProcessTopicCodeLink |
Save |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MasterTopicCodeLink Class | Aptify.Framework.BusinessLogic Namespace


MasterTopicCodeLink.ProcessTopicCodeLink Method

public void ProcessTopicCodeLink(
Int64 TopicCodeLinkID,
Int64 TopicCodeID,
String Status,
Object Value
);

See Also

MasterTopicCodeLink Class | Aptify.Framework.BusinessLogic Namespace


MasterTopicCodeLink.Save Method

public void Save();

See Also

MasterTopicCodeLink Class | Aptify.Framework.BusinessLogic Namespace


Merge Class

For a list of all members of this type, see Merge Members.

System.Object
Merge

public class Merge

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: AptifyMerge (in AptifyMerge.dll)

See Also

Merge Members | Aptify.Framework.BusinessLogic Namespace


Merge Members

Merge overview

Protected Static Methods

AreValuesEqual

Public Instance Constructors

Merge Overloaded. Initializes a new instance of the Merge class.

Public Instance Properties

Status

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Merge | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

StatusEvent
SubStatusEvent

Protected Instance Properties

AptifyApplication
Dal

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetDependencies |
LoadDependencies |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RelinkDependents |
SaveRecordsToMaster |
SetMasterRecordFields |

Protected Internal Instance Properties

MergeFieldCollection

See Also

Merge Class | Aptify.Framework.BusinessLogic Namespace


Merge Constructor

Overload List

Initializes a new instance of the Merge class.

public Merge();

public Merge(UserCredentials);

See Also

Merge Class | Aptify.Framework.BusinessLogic Namespace


Merge Constructor (UserCredentials)

public Merge(
UserCredentials UserCredential
);

See Also

Merge Class | Aptify.Framework.BusinessLogic Namespace | Merge Constructor Overload List


Merge Constructor ()

Initializes a new instance of the Merge class.

public Merge();

See Also

Merge Class | Aptify.Framework.BusinessLogic Namespace | Merge Constructor Overload List


Merge Properties

The properties of the Merge class are listed below. For a complete list of Merge class members, see the Merge Members topic.

Public Instance Properties

Status

Protected Instance Properties

AptifyApplication
Dal

Protected Internal Instance Properties

MergeFieldCollection

See Also

Merge Class | Aptify.Framework.BusinessLogic Namespace


AptifyApplication Property

Aptify 5.0 Software Development Kit (SDK)

Merge.AptifyApplication Property

protected AptifyApplication AptifyApplication {get;}

See Also

Merge Class | Aptify.Framework.BusinessLogic Namespace


Dal Property

Aptify 5.0 Software Development Kit (SDK)

Merge.Dal Property

protected DataAction Dal {get;}

See Also

Merge Class | Aptify.Framework.BusinessLogic Namespace


MergeFieldCollection Property

Aptify 5.0 Software Development Kit (SDK)

Merge.MergeFieldCollection Property

protected internal MergeFieldCollection MergeFieldCollection {get;}

See Also

Merge Class | Aptify.Framework.BusinessLogic Namespace


Status Property

Aptify 5.0 Software Development Kit (SDK)

Merge.Status Property

public Boolean Status {get; set;}

See Also

Merge Class | Aptify.Framework.BusinessLogic Namespace


Merge Methods

The methods of the Merge class are listed below. For a complete list of Merge class members, see the Merge Members topic.

Protected Static Methods

AreValuesEqual

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Merge | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetDependencies |
LoadDependencies |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RelinkDependents |
SaveRecordsToMaster |
SetMasterRecordFields |

See Also

Merge Class | Aptify.Framework.BusinessLogic Namespace


Merge.AreValuesEqual Method

protected static bool AreValuesEqual(
Object ValueOne,
Object ValueTwo
);

See Also

Merge Class | Aptify.Framework.BusinessLogic Namespace


Merge.GetDependencies Method

protected virtual void GetDependencies();

See Also

Merge Class | Aptify.Framework.BusinessLogic Namespace


Merge.LoadDependencies Method

protected virtual void LoadDependencies(
GenericEntityCollection GeCollection
);

See Also

Merge Class | Aptify.Framework.BusinessLogic Namespace


Merge Method

Aptify 5.0 Software Development Kit (SDK)

Merge.Merge Method

Overload List

public void Merge(String,Int64,ArrayList);

public virtual void Merge(String,Int64,ArrayList,Boolean);

See Also

Merge Class | Aptify.Framework.BusinessLogic Namespace


Merge.Merge Method (String, Int64, ArrayList)

public void Merge(
String EntityName,
Int64 KeepID,
ArrayList MergeIDs
);

See Also

Merge Class | Aptify.Framework.BusinessLogic Namespace | Merge.Merge Overload List


Merge.Merge Method (String, Int64, ArrayList, Boolean)

public virtual void Merge(
String EntityName,
Int64 KeepID,
ArrayList MergeIds,
Boolean DisplayStatus
);

See Also

Merge Class | Aptify.Framework.BusinessLogic Namespace | Merge.Merge Overload List


Merge.RelinkDependents Method

protected virtual void RelinkDependents();

See Also

Merge Class | Aptify.Framework.BusinessLogic Namespace


Merge.SaveRecordsToMaster Method

protected virtual void SaveRecordsToMaster();

See Also

Merge Class | Aptify.Framework.BusinessLogic Namespace


Merge.SetMasterRecordFields Method

protected virtual void SetMasterRecordFields();

See Also

Merge Class | Aptify.Framework.BusinessLogic Namespace


Merge Events

The events of the Merge class are listed below. For a complete list of Merge class members, see the Merge Members topic.

Public Instance Events

StatusEvent
SubStatusEvent

See Also

Merge Class | Aptify.Framework.BusinessLogic Namespace


Merge.Merge.StatusEventEventHandler Event

public event Merge.StatusEventEventHandler StatusEvent;

See Also

Merge Class | Aptify.Framework.BusinessLogic Namespace


Merge.Merge.SubStatusEventEventHandler Event

public event Merge.SubStatusEventEventHandler SubStatusEvent;

See Also

Merge Class | Aptify.Framework.BusinessLogic Namespace


Merge.StatusEventEventHandler Delegate

public delegate void Merge.StatusEventEventHandler(
Int32 ProgressPercentage,
String Caption
);

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: AptifyMerge (in AptifyMerge.dll)

See Also

Aptify.Framework.BusinessLogic Namespace


Merge.SubStatusEventEventHandler Delegate

public delegate void Merge.SubStatusEventEventHandler(
Int32 ProgressPercentage,
String Caption
);

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: AptifyMerge (in AptifyMerge.dll)

See Also

Aptify.Framework.BusinessLogic Namespace


MergeField Class

For a list of all members of this type, see MergeField Members.

System.Object
MergeField

public class MergeField

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: AptifyMerge (in AptifyMerge.dll)

See Also

MergeField Members | Aptify.Framework.BusinessLogic Namespace


MergeField Members

MergeField overview

Public Instance Constructors

MergeField Constructor

Public Instance Properties

Children
Field
RecordID
Value

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MergeField Class | Aptify.Framework.BusinessLogic Namespace


MergeField Constructor

public MergeField(
Int64 RecordID,
String Field,
Object Value
);

See Also

MergeField Class | Aptify.Framework.BusinessLogic Namespace


MergeField Properties

The properties of the MergeField class are listed below. For a complete list of MergeField class members, see the MergeField Members topic.

Public Instance Properties

Children
Field
RecordID
Value

See Also

MergeField Class | Aptify.Framework.BusinessLogic Namespace


Children Property

Aptify 5.0 Software Development Kit (SDK)

MergeField.Children Property

public MergeFieldCollection Children {get;}

See Also

MergeField Class | Aptify.Framework.BusinessLogic Namespace


Field Property

Aptify 5.0 Software Development Kit (SDK)

MergeField.Field Property

public String Field {get;}

See Also

MergeField Class | Aptify.Framework.BusinessLogic Namespace


RecordID Property

Aptify 5.0 Software Development Kit (SDK)

MergeField.RecordID Property

public Int64 RecordID {get;}

See Also

MergeField Class | Aptify.Framework.BusinessLogic Namespace


Value Property

Aptify 5.0 Software Development Kit (SDK)

MergeField.Value Property

public Object Value {get;}

See Also

MergeField Class | Aptify.Framework.BusinessLogic Namespace


MergeFieldCollection Class

For a list of all members of this type, see MergeFieldCollection Members.

System.Object
CollectionBase
MergeFieldCollection

public class MergeFieldCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: AptifyMerge (in AptifyMerge.dll)

See Also

MergeFieldCollection Members | Aptify.Framework.BusinessLogic Namespace


MergeFieldCollection Members

MergeFieldCollection overview

Public Instance Constructors

MergeFieldCollection Constructor Initializes a new instance of the MergeFieldCollection class.

Public Instance Properties

Capacity (inherited from CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
Item |

Public Instance Methods

Add |
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that iterates through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Remove |
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MergeFieldCollection Class | Aptify.Framework.BusinessLogic Namespace


MergeFieldCollection Constructor

Initializes a new instance of the MergeFieldCollection class.

public MergeFieldCollection();

See Also

MergeFieldCollection Class | Aptify.Framework.BusinessLogic Namespace


MergeFieldCollection Properties

The properties of the MergeFieldCollection class are listed below. For a complete list of MergeFieldCollection class members, see the MergeFieldCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
Item |

See Also

MergeFieldCollection Class | Aptify.Framework.BusinessLogic Namespace


Item Property

Aptify 5.0 Software Development Kit (SDK)

MergeFieldCollection.Item Property

public MergeField this[
Int32 index
] {get;}

See Also

MergeFieldCollection Class | Aptify.Framework.BusinessLogic Namespace


MergeFieldCollection Methods

The methods of the MergeFieldCollection class are listed below. For a complete list of MergeFieldCollection class members, see the MergeFieldCollection Members topic.

Public Instance Methods

Add |
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that iterates through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Remove |
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MergeFieldCollection Class | Aptify.Framework.BusinessLogic Namespace


MergeFieldCollection.Add Method

public void Add(
MergeField MergeField
);

See Also

MergeFieldCollection Class | Aptify.Framework.BusinessLogic Namespace


MergeFieldCollection.Remove Method

public void Remove(
MergeField MergeField
);

See Also

MergeFieldCollection Class | Aptify.Framework.BusinessLogic Namespace


MergeForm Class

For a list of all members of this type, see MergeForm Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
MergeForm

public class MergeForm : Form

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: AptifyMerge (in AptifyMerge.dll)

See Also

MergeForm Members | Aptify.Framework.BusinessLogic Namespace


MergeForm Members

MergeForm overview

Public Static Fields

GENERIC_MERGE_ASSEMBLY
GENERIC_MERGE_TYPE

Public Instance Constructors

MergeForm Overloaded. Initializes a new instance of the MergeForm class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DeletedIDs | Property which is queried to MergeSuccessful = TRUE to return an ArrayList of Deleted (Merged) IDs.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MergeSuccessful | Property which is queried to determine if the merge form operation was successful or not.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
SurvivingID | Property which is queried if MergeSuccessful = TRUE to return the SurvivingID value.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Updates the bounds of the control with the current size and location.

See Also

MergeForm Class | Aptify.Framework.BusinessLogic Namespace


MergeForm Constructor

Initializes a new instance of the MergeForm class.

Overload List

Initializes a new instance of the MergeForm class.

public MergeForm();

public MergeForm(UserCredentials,String,ArrayList);

See Also

MergeForm Class | Aptify.Framework.BusinessLogic Namespace


MergeForm Constructor ()

Initializes a new instance of the MergeForm class.

public MergeForm();

See Also

MergeForm Class | Aptify.Framework.BusinessLogic Namespace | MergeForm Constructor Overload List


MergeForm Constructor (UserCredentials, String, ArrayList)

public MergeForm(
UserCredentials UserCredential,
String EntityName,
ArrayList SelectList
);

See Also

MergeForm Class | Aptify.Framework.BusinessLogic Namespace | MergeForm Constructor Overload List


MergeForm Fields

The fields of the MergeForm class are listed below. For a complete list of MergeForm class members, see the MergeForm Members topic.

Public Static Fields

GENERIC_MERGE_ASSEMBLY
GENERIC_MERGE_TYPE

See Also

MergeForm Class | Aptify.Framework.BusinessLogic Namespace


MergeForm.GENERIC_MERGE_ASSEMBLY Field

public const GENERIC_MERGE_ASSEMBLY GENERIC_MERGE_ASSEMBLY = "AptifyMerge";

See Also

MergeForm Class | Aptify.Framework.BusinessLogic Namespace


MergeForm.GENERIC_MERGE_TYPE Field

public const GENERIC_MERGE_TYPE GENERIC_MERGE_TYPE = "Aptify.Framework.BusinessLogic.Merge";

See Also

MergeForm Class | Aptify.Framework.BusinessLogic Namespace


MergeForm Properties

The properties of the MergeForm class are listed below. For a complete list of MergeForm class members, see the MergeForm Members topic.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DeletedIDs | Property which is queried to MergeSuccessful = TRUE to return an ArrayList of Deleted (Merged) IDs.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MergeSuccessful | Property which is queried to determine if the merge form operation was successful or not.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
SurvivingID | Property which is queried if MergeSuccessful = TRUE to return the SurvivingID value.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

MergeForm Class | Aptify.Framework.BusinessLogic Namespace


DeletedIDs Property

Aptify 5.0 Software Development Kit (SDK)

MergeForm.DeletedIDs Property

Property which is queried to MergeSuccessful = TRUE to return an ArrayList of Deleted (Merged) IDs.

public ArrayList DeletedIDs {get;}

Property Value

Remarks

See Also

MergeForm Class | Aptify.Framework.BusinessLogic Namespace


MergeSuccessful Property

Aptify 5.0 Software Development Kit (SDK)

MergeForm.MergeSuccessful Property

Property which is queried to determine if the merge form operation was successful or not.

public Boolean MergeSuccessful {get;}

Property Value

Remarks

See Also

MergeForm Class | Aptify.Framework.BusinessLogic Namespace


SurvivingID Property

Aptify 5.0 Software Development Kit (SDK)

MergeForm.SurvivingID Property

Property which is queried if MergeSuccessful = TRUE to return the SurvivingID value.

public Int64 SurvivingID {get;}

Property Value

Remarks

See Also

MergeForm Class | Aptify.Framework.BusinessLogic Namespace


MergingGUI Class

For a list of all members of this type, see MergingGUI Members.

System.Object
MergingGUI

public class MergingGUI

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: AptifyMerge (in AptifyMerge.dll)

See Also

MergingGUI Members | Aptify.Framework.BusinessLogic Namespace


MergingGUI Members

MergingGUI overview

Public Instance Constructors

MergingGUI Constructor Initializes a new instance of the MergingGUI class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize | Overloaded.
Show |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MergingGUI Class | Aptify.Framework.BusinessLogic Namespace


MergingGUI Constructor

Initializes a new instance of the MergingGUI class.

public MergingGUI();

See Also

MergingGUI Class | Aptify.Framework.BusinessLogic Namespace


MergingGUI Methods

The methods of the MergingGUI class are listed below. For a complete list of MergingGUI class members, see the MergingGUI Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize | Overloaded.
Show |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MergingGUI Class | Aptify.Framework.BusinessLogic Namespace


Initialize Method

Aptify 5.0 Software Development Kit (SDK)

MergingGUI.Initialize Method

Overload List

public void Initialize(UserCredentials,ArrayList,String);

public void Initialize(UserCredentials,String,String);

See Also

MergingGUI Class | Aptify.Framework.BusinessLogic Namespace


MergingGUI.Initialize Method (UserCredentials, ArrayList, String)

public void Initialize(
UserCredentials UserCredential,
ArrayList SelList,
String EntityName
);

See Also

MergingGUI Class | Aptify.Framework.BusinessLogic Namespace | MergingGUI.Initialize Overload List


MergingGUI.Initialize Method (UserCredentials, String, String)

public void Initialize(
UserCredentials UserCredential,
String SelList,
String EntityName
);

See Also

MergingGUI Class | Aptify.Framework.BusinessLogic Namespace | MergingGUI.Initialize Overload List


MergingGUI.Show Method

public void Show(
Boolean Modal,
Control Parent
);

See Also

MergingGUI Class | Aptify.Framework.BusinessLogic Namespace


MetadataSingleton Class

For a list of all members of this type, see MetadataSingleton Members.

System.Object
MetadataSingleton

public class MetadataSingleton

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: Metadata (in Metadata.dll)

See Also

MetadataSingleton Members | Aptify.Framework.BusinessLogic Namespace


MetadataSingleton Members

MetadataSingleton overview

Public Static Properties

Instance | Overloaded.
UserCredentials |

Public Instance Methods

EntityMetaData | Overloaded. Look up entity level meta-data by Name
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MetadataSingleton Class | Aptify.Framework.BusinessLogic Namespace


MetadataSingleton Properties

The properties of the MetadataSingleton class are listed below. For a complete list of MetadataSingleton class members, see the MetadataSingleton Members topic.

Public Static Properties

Instance | Overloaded.
UserCredentials |

See Also

MetadataSingleton Class | Aptify.Framework.BusinessLogic Namespace


MetadataSingleton Property

Aptify 5.0 Software Development Kit (SDK)

MetadataSingleton.MetadataSingleton Property

Overload List

public static MetadataSingleton Instance {get;}

public static MetadataSingleton this[Boolean] {get;}

See Also

MetadataSingleton Class | Aptify.Framework.BusinessLogic Namespace


Instance Property

Aptify 5.0 Software Development Kit (SDK)

MetadataSingleton.Instance Property

public static MetadataSingleton Instance {get;}

See Also

MetadataSingleton Class | Aptify.Framework.BusinessLogic Namespace | MetadataSingleton.MetadataSingleton Overload List


Instance Property (Boolean)

Aptify 5.0 Software Development Kit (SDK)

MetadataSingleton.Instance Property (Boolean)

public static MetadataSingleton this[
Boolean reload
] {get;}

See Also

MetadataSingleton Class | Aptify.Framework.BusinessLogic Namespace | MetadataSingleton.MetadataSingleton Overload List


UserCredentials Property

Aptify 5.0 Software Development Kit (SDK)

MetadataSingleton.UserCredentials Property

public static UserCredentials UserCredentials {get;}

See Also

MetadataSingleton Class | Aptify.Framework.BusinessLogic Namespace


MetadataSingleton Methods

The methods of the MetadataSingleton class are listed below. For a complete list of MetadataSingleton class members, see the MetadataSingleton Members topic.

Public Instance Methods

EntityMetaData | Overloaded. Look up entity level meta-data by Name
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MetadataSingleton Class | Aptify.Framework.BusinessLogic Namespace


EntityMetaData Method

Aptify 5.0 Software Development Kit (SDK)

MetadataSingleton.EntityMetaData Method

Look up Entity Level Meta-Data By EntityID

Overload List

Look up Entity Level Meta-Data By EntityID

public EntityLevelMetaData EntityMetaData(Int64,UserCredentials,Boolean);

Look up entity level meta-data by Name

public EntityLevelMetaData EntityMetaData(String,UserCredentials);

See Also

MetadataSingleton Class | Aptify.Framework.BusinessLogic Namespace


MetadataSingleton.EntityMetaData Method (Int64, UserCredentials, Boolean)

Look up Entity Level Meta-Data By EntityID

public EntityLevelMetaData EntityMetaData(
Int64 EntityID,
UserCredentials UserCredential,
Boolean ForceRefresh
);

Parameters

EntityID
ID of the record in the Entities Service
UserCredential
Aptify User Credentials
ForceRefresh
If this parameter is set to True, the data will be refreshed in memory. If this value is not provided or set to False(default), the data will be pulled from the cache in memory when available

Return Value

Remarks

See Also

MetadataSingleton Class | Aptify.Framework.BusinessLogic Namespace | MetadataSingleton.EntityMetaData Overload List


MetadataSingleton.EntityMetaData Method (String, UserCredentials)

Look up entity level meta-data by Name

public EntityLevelMetaData EntityMetaData(
String EntityName,
UserCredentials UserCredential
);

Parameters

EntityName
UserCredential

Return Value

Remarks

See Also

MetadataSingleton Class | Aptify.Framework.BusinessLogic Namespace | MetadataSingleton.EntityMetaData Overload List


ObjectRepositoryObjectsEntity Class

For a list of all members of this type, see ObjectRepositoryObjectsEntity Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
ObjectRepositoryObjectsEntity

public class ObjectRepositoryObjectsEntity : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: AptifyObjectRepositoryObjectsEntity (in AptifyObjectRepositoryObjectsEntity.dll)

See Also

ObjectRepositoryObjectsEntity Members | Aptify.Framework.BusinessLogic Namespace


ObjectRepositoryObjectsEntity Members

ObjectRepositoryObjectsEntity overview

Public Instance Constructors

ObjectRepositoryObjectsEntity Constructor Initializes a new instance of the ObjectRepositoryObjectsEntity class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config | Overloaded.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

ObjectRepositoryObjectsEntity Class | Aptify.Framework.BusinessLogic Namespace


ObjectRepositoryObjectsEntity Constructor

Initializes a new instance of the ObjectRepositoryObjectsEntity class.

public ObjectRepositoryObjectsEntity();

See Also

ObjectRepositoryObjectsEntity Class | Aptify.Framework.BusinessLogic Namespace


ObjectRepositoryObjectsEntity Methods

The methods of the ObjectRepositoryObjectsEntity class are listed below. For a complete list of ObjectRepositoryObjectsEntity class members, see the ObjectRepositoryObjectsEntity Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config | Overloaded.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

ObjectRepositoryObjectsEntity Class | Aptify.Framework.BusinessLogic Namespace


Config Method

Aptify 5.0 Software Development Kit (SDK)

ObjectRepositoryObjectsEntity.Config Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual void Config(AptifySubTypeBase);

Inherited from AptifyGenericEntity.

public override void Config(AptifySubTypeBase,Int64);

Inherited from AptifyGenericEntityBase.

public virtual void Config(UserCredentials,String);

public override void Config(UserCredentials,String,Int64);

See Also

ObjectRepositoryObjectsEntity Class | Aptify.Framework.BusinessLogic Namespace


ObjectRepositoryObjectsEntity.Config Method (UserCredentials, String, Int64)

public override void Config(
UserCredentials UserCredentials,
String EntityName,
Int64 RecordID
);

See Also

ObjectRepositoryObjectsEntity Class | Aptify.Framework.BusinessLogic Namespace | ObjectRepositoryObjectsEntity.Config Overload List


Save Method

Aptify 5.0 Software Development Kit (SDK)

ObjectRepositoryObjectsEntity.Save Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Save();

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean,ref String&);

public override bool Save(Boolean,ref String&,String);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(ref String&);

See Also

ObjectRepositoryObjectsEntity Class | Aptify.Framework.BusinessLogic Namespace


ObjectRepositoryObjectsEntity.Save Method (Boolean, String&, String)

public override bool Save(
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

See Also

ObjectRepositoryObjectsEntity Class | Aptify.Framework.BusinessLogic Namespace | ObjectRepositoryObjectsEntity.Save Overload List


Validate Method

Aptify 5.0 Software Development Kit (SDK)

ObjectRepositoryObjectsEntity.Validate Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Validate();

public override bool Validate(ref String&);

See Also

ObjectRepositoryObjectsEntity Class | Aptify.Framework.BusinessLogic Namespace


ObjectRepositoryObjectsEntity.Validate Method (String&)

public override bool Validate(
ref String& ErrorString
);

See Also

ObjectRepositoryObjectsEntity Class | Aptify.Framework.BusinessLogic Namespace | ObjectRepositoryObjectsEntity.Validate Overload List


oroEntityConstants Class

For a list of all members of this type, see oroEntityConstants Members.

System.Object
oroEntityConstants

public class oroEntityConstants

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: AptifyObjectRepositoryObjectsEntity (in AptifyObjectRepositoryObjectsEntity.dll)

See Also

oroEntityConstants Members | Aptify.Framework.BusinessLogic Namespace


oroEntityConstants Members

oroEntityConstants overview

Public Static Fields

CONFIG_ERROR_INVALID_ENTITY
DIRECTSTOREOBJECTBLOB_EXCEPTION_MESSAGE
DIRECTSTOREOBJECTUPDATE_EXCEPTION_MESSAGE
ITEM_DELETED_MESSAGE
OBJECTREPOSITORYCLASS_LICENSE_UPDATE_ERROR
OBJECTREPOSITORYCLASS_LOADED_ERROR
OBJECTREPOSITORYCLASS_SAVEENTITYOBJECT_EXCEPTION_MESSAGE
OBJECTREPOSITORYCLASS_UPDATE_BYPASS

Public Static Methods

GetLocalString

Public Instance Constructors

oroEntityConstants Constructor Initializes a new instance of the oroEntityConstants class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

oroEntityConstants Class | Aptify.Framework.BusinessLogic Namespace


oroEntityConstants Constructor

Initializes a new instance of the oroEntityConstants class.

public oroEntityConstants();

See Also

oroEntityConstants Class | Aptify.Framework.BusinessLogic Namespace


oroEntityConstants Fields

The fields of the oroEntityConstants class are listed below. For a complete list of oroEntityConstants class members, see the oroEntityConstants Members topic.

Public Static Fields

CONFIG_ERROR_INVALID_ENTITY
DIRECTSTOREOBJECTBLOB_EXCEPTION_MESSAGE
DIRECTSTOREOBJECTUPDATE_EXCEPTION_MESSAGE
ITEM_DELETED_MESSAGE
OBJECTREPOSITORYCLASS_LICENSE_UPDATE_ERROR
OBJECTREPOSITORYCLASS_LOADED_ERROR
OBJECTREPOSITORYCLASS_SAVEENTITYOBJECT_EXCEPTION_MESSAGE
OBJECTREPOSITORYCLASS_UPDATE_BYPASS

See Also

oroEntityConstants Class | Aptify.Framework.BusinessLogic Namespace


oroEntityConstants.CONFIG_ERROR_INVALID_ENTITY Field

public const CONFIG_ERROR_INVALID_ENTITY CONFIG_ERROR_INVALID_ENTITY = "CONFIG_ERROR_INVALID_ENTITY";

See Also

oroEntityConstants Class | Aptify.Framework.BusinessLogic Namespace


oroEntityConstants.DIRECTSTOREOBJECTBLOB_EXCEPTION_MESSAGE Field

public const DIRECTSTOREOBJECTBLOB_EXCEPTION_MESSAGE DIRECTSTOREOBJECTBLOB_EXCEPTION_MESSAGE = "DIRECTSTOREOBJECTBLOB_EXCEPTION_MESSAGE";

See Also

oroEntityConstants Class | Aptify.Framework.BusinessLogic Namespace


oroEntityConstants.DIRECTSTOREOBJECTUPDATE_EXCEPTION_MESSAGE Field

public const DIRECTSTOREOBJECTUPDATE_EXCEPTION_MESSAGE DIRECTSTOREOBJECTUPDATE_EXCEPTION_MESSAGE = "DIRECTSTOREOBJECT_EXCEPTION_MESSAGE";

See Also

oroEntityConstants Class | Aptify.Framework.BusinessLogic Namespace


oroEntityConstants.ITEM_DELETED_MESSAGE Field

public const ITEM_DELETED_MESSAGE ITEM_DELETED_MESSAGE = "ITEM_DELETED_MESSAGE";

See Also

oroEntityConstants Class | Aptify.Framework.BusinessLogic Namespace


oroEntityConstants.OBJECTREPOSITORYCLASS_LICENSE_UPDATE_ERROR Field

public const OBJECTREPOSITORYCLASS_LICENSE_UPDATE_ERROR OBJECTREPOSITORYCLASS_LICENSE_UPDATE_ERROR = "OBJECTREPOSITORYCLASS_LICENSE_UPDATE_ERROR";

See Also

oroEntityConstants Class | Aptify.Framework.BusinessLogic Namespace


oroEntityConstants.OBJECTREPOSITORYCLASS_LOADED_ERROR Field

public const OBJECTREPOSITORYCLASS_LOADED_ERROR OBJECTREPOSITORYCLASS_LOADED_ERROR = "OBJECTREPOSITORYCLASS_LOADED_ERROR";

See Also

oroEntityConstants Class | Aptify.Framework.BusinessLogic Namespace


oroEntityConstants.OBJECTREPOSITORYCLASS_SAVEENTITYOBJECT_EXCEPTION_MESSAGE Field

public const OBJECTREPOSITORYCLASS_SAVEENTITYOBJECT_EXCEPTION_MESSAGE OBJECTREPOSITORYCLASS_SAVEENTITYOBJECT_EXCEPTION_MESSAGE = "OBJECTREPOSITORYCLASS_SAVEENTITYOBJECT_EXCEPTION_MESSAGE";

See Also

oroEntityConstants Class | Aptify.Framework.BusinessLogic Namespace


oroEntityConstants.OBJECTREPOSITORYCLASS_UPDATE_BYPASS Field

public const OBJECTREPOSITORYCLASS_UPDATE_BYPASS OBJECTREPOSITORYCLASS_UPDATE_BYPASS = "OBJECTREPOSITORYCLASS_UPDATE_BYPASS";

See Also

oroEntityConstants Class | Aptify.Framework.BusinessLogic Namespace


oroEntityConstants Methods

The methods of the oroEntityConstants class are listed below. For a complete list of oroEntityConstants class members, see the oroEntityConstants Members topic.

Public Static Methods

GetLocalString

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

oroEntityConstants Class | Aptify.Framework.BusinessLogic Namespace


oroEntityConstants.GetLocalString Method

public static string GetLocalString(
String LocalString
);

See Also

oroEntityConstants Class | Aptify.Framework.BusinessLogic Namespace


ReadDataRow Class

For a list of all members of this type, see ReadDataRow Members.

System.Object
ReadDataRow
Derived types

public class ReadDataRow

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: Metadata (in Metadata.dll)

See Also

ReadDataRow Members | Aptify.Framework.BusinessLogic Namespace


ReadDataRow Members

ReadDataRow overview

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Fields

m_drCurrentRow

Protected Instance Properties

CurrentRow |
Item | Overloaded.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ReadDataRow Class | Aptify.Framework.BusinessLogic Namespace


ReadDataRow Fields

The fields of the ReadDataRow class are listed below. For a complete list of ReadDataRow class members, see the ReadDataRow Members topic.

Protected Instance Fields

m_drCurrentRow

See Also

ReadDataRow Class | Aptify.Framework.BusinessLogic Namespace


ReadDataRow.m_drCurrentRow Field

protected m_drCurrentRow m_drCurrentRow;

See Also

ReadDataRow Class | Aptify.Framework.BusinessLogic Namespace


ReadDataRow Properties

The properties of the ReadDataRow class are listed below. For a complete list of ReadDataRow class members, see the ReadDataRow Members topic.

Protected Instance Properties

CurrentRow |
Item | Overloaded.

See Also

ReadDataRow Class | Aptify.Framework.BusinessLogic Namespace


CurrentRow Property

Aptify 5.0 Software Development Kit (SDK)

ReadDataRow.CurrentRow Property

protected DataRow CurrentRow {get; set;}

See Also

ReadDataRow Class | Aptify.Framework.BusinessLogic Namespace


Object Property

Aptify 5.0 Software Development Kit (SDK)

ReadDataRow.Object Property

Overload List

protected Object this[Int32, TypeCode] {get;}

protected Object this[String, TypeCode] {get;}

See Also

ReadDataRow Class | Aptify.Framework.BusinessLogic Namespace


Item Property (Int32, TypeCode)

Aptify 5.0 Software Development Kit (SDK)

ReadDataRow.Item Property (Int32, TypeCode)

protected Object this[
Int32 Index,
TypeCode Type
] {get;}

See Also

ReadDataRow Class | Aptify.Framework.BusinessLogic Namespace | ReadDataRow.Object Overload List


Item Property (String, TypeCode)

Aptify 5.0 Software Development Kit (SDK)

ReadDataRow.Item Property (String, TypeCode)

protected Object this[
String Name,
TypeCode Type
] {get;}

See Also

ReadDataRow Class | Aptify.Framework.BusinessLogic Namespace | ReadDataRow.Object Overload List


Role Class

For a list of all members of this type, see Role Members.

System.Object
Role

public class Role : IComparable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: AptifyUsersAndGroupsEntities (in AptifyUsersAndGroupsEntities.dll)

See Also

Role Members | Aptify.Framework.BusinessLogic Namespace


Role Members

Role overview

Public Instance Constructors

Role Constructor

Public Instance Properties

Name
Type

Public Instance Methods

CompareTo |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Role Class | Aptify.Framework.BusinessLogic Namespace


Role Constructor

public Role(
String Name,
RoleType Type
);

See Also

Role Class | Aptify.Framework.BusinessLogic Namespace


Role Properties

The properties of the Role class are listed below. For a complete list of Role class members, see the Role Members topic.

Public Instance Properties

Name
Type

See Also

Role Class | Aptify.Framework.BusinessLogic Namespace


Name Property

Aptify 5.0 Software Development Kit (SDK)

Role.Name Property

public String Name {get; set;}

See Also

Role Class | Aptify.Framework.BusinessLogic Namespace


Type Property

Aptify 5.0 Software Development Kit (SDK)

Role.Type Property

public RoleType Type {get; set;}

See Also

Role Class | Aptify.Framework.BusinessLogic Namespace


Role Methods

The methods of the Role class are listed below. For a complete list of Role class members, see the Role Members topic.

Public Instance Methods

CompareTo |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Role Class | Aptify.Framework.BusinessLogic Namespace


Role.CompareTo Method

public int CompareTo(
Object obj
);

Implements

IComparable.

See Also

Role Class | Aptify.Framework.BusinessLogic Namespace


RoleCollection Class

For a list of all members of this type, see RoleCollection Members.

System.Object
CollectionBase
RoleCollection

public class RoleCollection : CollectionBase, IComparable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: AptifyUsersAndGroupsEntities (in AptifyUsersAndGroupsEntities.dll)

See Also

RoleCollection Members | Aptify.Framework.BusinessLogic Namespace


RoleCollection Members

RoleCollection overview

Public Static Methods

ToCollection

Public Instance Constructors

RoleCollection Constructor Initializes a new instance of the RoleCollection class.

Public Instance Properties

Capacity (inherited from CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.

Public Instance Methods

Add |
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
CompareTo |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that iterates through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Remove |
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

RoleCollection Class | Aptify.Framework.BusinessLogic Namespace


RoleCollection Constructor

Initializes a new instance of the RoleCollection class.

public RoleCollection();

See Also

RoleCollection Class | Aptify.Framework.BusinessLogic Namespace


RoleCollection Methods

The methods of the RoleCollection class are listed below. For a complete list of RoleCollection class members, see the RoleCollection Members topic.

Public Static Methods

ToCollection

Public Instance Methods

Add |
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
CompareTo |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that iterates through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Remove |
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from CollectionBase) | Performs additional custom processes when clearing the contents of the CollectionBase instance.
OnClearComplete (inherited from CollectionBase) | Performs additional custom processes after clearing the contents of the CollectionBase instance.
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete (inherited from CollectionBase) | Performs additional custom processes after inserting a new element into the CollectionBase instance.
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete (inherited from CollectionBase) | Performs additional custom processes after removing an element from the CollectionBase instance.
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

RoleCollection Class | Aptify.Framework.BusinessLogic Namespace


RoleCollection.Add Method

public void Add(
Role Role
);

See Also

RoleCollection Class | Aptify.Framework.BusinessLogic Namespace


RoleCollection.CompareTo Method

public int CompareTo(
Object obj
);

Implements

IComparable.

See Also

RoleCollection Class | Aptify.Framework.BusinessLogic Namespace


RoleCollection.Remove Method

public void Remove(
Role Role
);

See Also

RoleCollection Class | Aptify.Framework.BusinessLogic Namespace


RoleCollection.ToCollection Method

public static RoleCollection ToCollection(
ServerRoles ServerRoles,
DatabaseRoles DBRoles
);

See Also

RoleCollection Class | Aptify.Framework.BusinessLogic Namespace


RoleType Enumeration

public enum RoleType

Members

Member Name | Description
Server |
Aptify |
Database |

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: AptifyUsersAndGroupsEntities (in AptifyUsersAndGroupsEntities.dll)

See Also

Aptify.Framework.BusinessLogic Namespace


ServerRoles Enumeration

public enum ServerRoles

Members

Member Name | Description
sysadmin |
securityadmin |
serveradmin |
setupadmin |
processadmin |
dbcreator |
bulkadmin |

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: AptifyUsersAndGroupsEntities (in AptifyUsersAndGroupsEntities.dll)

See Also

Aptify.Framework.BusinessLogic Namespace


SQLServerDMO Class

For a list of all members of this type, see SQLServerDMO Members.

System.Object
AptifyDMO
SQLServerDMO

public class SQLServerDMO : AptifyDMO

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: AptifyUsersAndGroupsEntities (in AptifyUsersAndGroupsEntities.dll)

See Also

SQLServerDMO Members | Aptify.Framework.BusinessLogic Namespace


SQLServerDMO Members

SQLServerDMO overview

Public Instance Constructors

SQLServerDMO Constructor

Public Instance Properties

AptifyRole |
CacheServerRoles |
DataAction (inherited from AptifyDMO) |
Databases |
Exists |
IsTrusted |
RoleMembers |
Roles | Overloaded.
USE (inherited from AptifyDMO) |
UserCredential (inherited from AptifyDMO) |
UserInAptifyList |
UserInDatabase | Overloaded.
UserInFixedRoles |
UserInRole |
UserInRoles |

Public Instance Methods

AddAptifyRole |
AddAptifyRoles |
AddLogin | Overloaded.
AddRole |
AddRoles | Overloaded.
AddUser |
ChangePassword | Overloaded.
DefaultDatabase |
DropAptifyRole |
DropAptifyRoles |
DropRole |
DropRoles | Overloaded.
DropUser |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

IsAptifyRole (inherited from AptifyDMO)
IsDbRole (inherited from AptifyDMO)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SQLServerDMO Class | Aptify.Framework.BusinessLogic Namespace


SQLServerDMO Constructor

public SQLServerDMO(
UserCredentials UserCredential,
String Database
);

See Also

SQLServerDMO Class | Aptify.Framework.BusinessLogic Namespace


SQLServerDMO Properties

The properties of the SQLServerDMO class are listed below. For a complete list of SQLServerDMO class members, see the SQLServerDMO Members topic.

Public Instance Properties

AptifyRole |
CacheServerRoles |
DataAction (inherited from AptifyDMO) |
Databases |
Exists |
IsTrusted |
RoleMembers |
Roles | Overloaded.
USE (inherited from AptifyDMO) |
UserCredential (inherited from AptifyDMO) |
UserInAptifyList |
UserInDatabase | Overloaded.
UserInFixedRoles |
UserInRole |
UserInRoles |

Protected Instance Properties

IsAptifyRole (inherited from AptifyDMO)
IsDbRole (inherited from AptifyDMO)

See Also

SQLServerDMO Class | Aptify.Framework.BusinessLogic Namespace


AptifyRole Property

Aptify 5.0 Software Development Kit (SDK)

SQLServerDMO.AptifyRole Property

public override Role this[
String RoleName
] {get;}

See Also

SQLServerDMO Class | Aptify.Framework.BusinessLogic Namespace


CacheServerRoles Property

Aptify 5.0 Software Development Kit (SDK)

SQLServerDMO.CacheServerRoles Property

public Boolean CacheServerRoles {get; set;}

See Also

SQLServerDMO Class | Aptify.Framework.BusinessLogic Namespace


Databases Property

Aptify 5.0 Software Development Kit (SDK)

SQLServerDMO.Databases Property

public override ArrayList this[
Boolean AptifyOnly
] {get;}

See Also

SQLServerDMO Class | Aptify.Framework.BusinessLogic Namespace


Exists Property

Aptify 5.0 Software Development Kit (SDK)

SQLServerDMO.Exists Property

public override Boolean this[
String User
] {get;}

See Also

SQLServerDMO Class | Aptify.Framework.BusinessLogic Namespace


IsTrusted Property

Aptify 5.0 Software Development Kit (SDK)

SQLServerDMO.IsTrusted Property

public override Boolean this[
String User
] {get;}

See Also

SQLServerDMO Class | Aptify.Framework.BusinessLogic Namespace


RoleMembers Property

Aptify 5.0 Software Development Kit (SDK)

SQLServerDMO.RoleMembers Property

public override ArrayList this[
String RoleName
] {get;}

See Also

SQLServerDMO Class | Aptify.Framework.BusinessLogic Namespace


RoleCollection Property

Aptify 5.0 Software Development Kit (SDK)

SQLServerDMO.RoleCollection Property

Overload List

public override RoleCollection this[RoleType] {get;}

public override RoleCollection this[String, RoleType] {get;}

See Also

SQLServerDMO Class | Aptify.Framework.BusinessLogic Namespace


Roles Property (RoleType)

Aptify 5.0 Software Development Kit (SDK)

SQLServerDMO.Roles Property (RoleType)

public override RoleCollection this[
RoleType GetRoleType
] {get;}

See Also

SQLServerDMO Class | Aptify.Framework.BusinessLogic Namespace | SQLServerDMO.RoleCollection Overload List


Roles Property (String, RoleType)

Aptify 5.0 Software Development Kit (SDK)

SQLServerDMO.Roles Property (String, RoleType)

public override RoleCollection this[
String User,
RoleType GetRoleType
] {get;}

See Also

SQLServerDMO Class | Aptify.Framework.BusinessLogic Namespace | SQLServerDMO.RoleCollection Overload List


UserInAptifyList Property

Aptify 5.0 Software Development Kit (SDK)

SQLServerDMO.UserInAptifyList Property

public override Boolean this[
String User
] {get;}

See Also

SQLServerDMO Class | Aptify.Framework.BusinessLogic Namespace


Boolean Property

Aptify 5.0 Software Development Kit (SDK)

SQLServerDMO.Boolean Property

Overload List

public override Boolean this[String] {get;}

public override Boolean this[String, Boolean] {get;}

See Also

SQLServerDMO Class | Aptify.Framework.BusinessLogic Namespace


UserInDatabase Property (String)

Aptify 5.0 Software Development Kit (SDK)

SQLServerDMO.UserInDatabase Property (String)

public override Boolean this[
String User
] {get;}

See Also

SQLServerDMO Class | Aptify.Framework.BusinessLogic Namespace | SQLServerDMO.Boolean Overload List


UserInDatabase Property (String, Boolean)

Aptify 5.0 Software Development Kit (SDK)

SQLServerDMO.UserInDatabase Property (String, Boolean)

public override Boolean this[
String User,
Boolean Explicit
] {get;}

See Also

SQLServerDMO Class | Aptify.Framework.BusinessLogic Namespace | SQLServerDMO.Boolean Overload List


UserInFixedRoles Property

Aptify 5.0 Software Development Kit (SDK)

SQLServerDMO.UserInFixedRoles Property

public override Boolean this[
String User,
ServerRoles ServerRoles,
DatabaseRoles DBRoles
] {get;}

See Also

SQLServerDMO Class | Aptify.Framework.BusinessLogic Namespace


UserInRole Property

Aptify 5.0 Software Development Kit (SDK)

SQLServerDMO.UserInRole Property

public override Boolean this[
String User,
Role Role
] {get;}

See Also

SQLServerDMO Class | Aptify.Framework.BusinessLogic Namespace


UserInRoles Property

Aptify 5.0 Software Development Kit (SDK)

SQLServerDMO.UserInRoles Property

public override Boolean this[
String User,
RoleCollection Roles
] {get;}

See Also

SQLServerDMO Class | Aptify.Framework.BusinessLogic Namespace


SQLServerDMO Methods

The methods of the SQLServerDMO class are listed below. For a complete list of SQLServerDMO class members, see the SQLServerDMO Members topic.

Public Instance Methods

AddAptifyRole |
AddAptifyRoles |
AddLogin | Overloaded.
AddRole |
AddRoles | Overloaded.
AddUser |
ChangePassword | Overloaded.
DefaultDatabase |
DropAptifyRole |
DropAptifyRoles |
DropRole |
DropRoles | Overloaded.
DropUser |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SQLServerDMO Class | Aptify.Framework.BusinessLogic Namespace


SQLServerDMO.AddAptifyRole Method

public override void AddAptifyRole(
Role Role
);

See Also

SQLServerDMO Class | Aptify.Framework.BusinessLogic Namespace


SQLServerDMO.AddAptifyRoles Method

public override void AddAptifyRoles(
RoleCollection Roles
);

See Also

SQLServerDMO Class | Aptify.Framework.BusinessLogic Namespace


AddLogin Method

Aptify 5.0 Software Development Kit (SDK)

SQLServerDMO.AddLogin Method

Overload List

public override bool AddLogin(String);

public override bool AddLogin(String,String);

public override bool AddLogin(String,String,ref String&);

See Also

SQLServerDMO Class | Aptify.Framework.BusinessLogic Namespace


SQLServerDMO.AddLogin Method (String)

public override bool AddLogin(
String User
);

See Also

SQLServerDMO Class | Aptify.Framework.BusinessLogic Namespace | SQLServerDMO.AddLogin Overload List


SQLServerDMO.AddLogin Method (String, String)

public override bool AddLogin(
String User,
String Password
);

See Also

SQLServerDMO Class | Aptify.Framework.BusinessLogic Namespace | SQLServerDMO.AddLogin Overload List


SQLServerDMO.AddLogin Method (String, String, String&)

public override bool AddLogin(
String User,
String Password,
ref String& sError
);

See Also

SQLServerDMO Class | Aptify.Framework.BusinessLogic Namespace | SQLServerDMO.AddLogin Overload List


SQLServerDMO.AddRole Method

public override void AddRole(
String User,
Role Role
);

See Also

SQLServerDMO Class | Aptify.Framework.BusinessLogic Namespace


AddRoles Method

Aptify 5.0 Software Development Kit (SDK)

SQLServerDMO.AddRoles Method

Overload List

public override void AddRoles(String,RoleCollection);

public override void AddRoles(String,ServerRoles,DatabaseRoles);

See Also

SQLServerDMO Class | Aptify.Framework.BusinessLogic Namespace


SQLServerDMO.AddRoles Method (String, RoleCollection)

public override void AddRoles(
String User,
RoleCollection Roles
);

See Also

SQLServerDMO Class | Aptify.Framework.BusinessLogic Namespace | SQLServerDMO.AddRoles Overload List


SQLServerDMO.AddRoles Method (String, ServerRoles, DatabaseRoles)

public override void AddRoles(
String User,
ServerRoles ServerRoles,
DatabaseRoles DBRoles
);

See Also

SQLServerDMO Class | Aptify.Framework.BusinessLogic Namespace | SQLServerDMO.AddRoles Overload List


SQLServerDMO.AddUser Method

public override void AddUser(
String user
);

See Also

SQLServerDMO Class | Aptify.Framework.BusinessLogic Namespace


ChangePassword Method

Aptify 5.0 Software Development Kit (SDK)

SQLServerDMO.ChangePassword Method

Overload List

public override bool ChangePassword(String,String);

public override bool ChangePassword(String,String,ref String&);

See Also

SQLServerDMO Class | Aptify.Framework.BusinessLogic Namespace


SQLServerDMO.ChangePassword Method (String, String)

public override bool ChangePassword(
String User,
String Password
);

See Also

SQLServerDMO Class | Aptify.Framework.BusinessLogic Namespace | SQLServerDMO.ChangePassword Overload List


SQLServerDMO.ChangePassword Method (String, String, String&)

public override bool ChangePassword(
String User,
String Password,
ref String& sError
);

See Also

SQLServerDMO Class | Aptify.Framework.BusinessLogic Namespace | SQLServerDMO.ChangePassword Overload List


SQLServerDMO.DefaultDatabase Method

public override void DefaultDatabase(
String User,
String DefaultDB
);

See Also

SQLServerDMO Class | Aptify.Framework.BusinessLogic Namespace


SQLServerDMO.DropAptifyRole Method

public override void DropAptifyRole(
Role Role
);

See Also

SQLServerDMO Class | Aptify.Framework.BusinessLogic Namespace


SQLServerDMO.DropAptifyRoles Method

public override void DropAptifyRoles(
RoleCollection Roles
);

See Also

SQLServerDMO Class | Aptify.Framework.BusinessLogic Namespace


SQLServerDMO.DropRole Method

public override void DropRole(
String User,
Role Role
);

See Also

SQLServerDMO Class | Aptify.Framework.BusinessLogic Namespace


DropRoles Method

Aptify 5.0 Software Development Kit (SDK)

SQLServerDMO.DropRoles Method

Overload List

public override void DropRoles(String,RoleCollection);

public override void DropRoles(String,ServerRoles,DatabaseRoles);

See Also

SQLServerDMO Class | Aptify.Framework.BusinessLogic Namespace


SQLServerDMO.DropRoles Method (String, RoleCollection)

public override void DropRoles(
String User,
RoleCollection Roles
);

See Also

SQLServerDMO Class | Aptify.Framework.BusinessLogic Namespace | SQLServerDMO.DropRoles Overload List


SQLServerDMO.DropRoles Method (String, ServerRoles, DatabaseRoles)

public override void DropRoles(
String User,
ServerRoles ServerRoles,
DatabaseRoles DBRoles
);

See Also

SQLServerDMO Class | Aptify.Framework.BusinessLogic Namespace | SQLServerDMO.DropRoles Overload List


SQLServerDMO.DropUser Method

public override void DropUser(
String user
);

See Also

SQLServerDMO Class | Aptify.Framework.BusinessLogic Namespace


StatusForm Class

For a list of all members of this type, see StatusForm Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
StatusForm

public class StatusForm : Form

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: AptifyMerge (in AptifyMerge.dll)

See Also

StatusForm Members | Aptify.Framework.BusinessLogic Namespace


StatusForm Members

StatusForm overview

Public Instance Constructors

StatusForm Overloaded. Initializes a new instance of the StatusForm class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UserCredential |
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DoLocalization |
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

StatusForm Class | Aptify.Framework.BusinessLogic Namespace


StatusForm Constructor

Initializes a new instance of the StatusForm class.

Overload List

Initializes a new instance of the StatusForm class.

public StatusForm();

public StatusForm(Merge);

See Also

StatusForm Class | Aptify.Framework.BusinessLogic Namespace


StatusForm Constructor ()

Initializes a new instance of the StatusForm class.

public StatusForm();

See Also

StatusForm Class | Aptify.Framework.BusinessLogic Namespace | StatusForm Constructor Overload List


StatusForm Constructor (Merge)

public StatusForm(
Merge Merge
);

See Also

StatusForm Class | Aptify.Framework.BusinessLogic Namespace | StatusForm Constructor Overload List


StatusForm Properties

The properties of the StatusForm class are listed below. For a complete list of StatusForm class members, see the StatusForm Members topic.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UserCredential |
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

StatusForm Class | Aptify.Framework.BusinessLogic Namespace


UserCredential Property

Aptify 5.0 Software Development Kit (SDK)

StatusForm.UserCredential Property

public UserCredentials UserCredential {get; set;}

See Also

StatusForm Class | Aptify.Framework.BusinessLogic Namespace


StatusForm Methods

The methods of the StatusForm class are listed below. For a complete list of StatusForm class members, see the StatusForm Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DoLocalization |
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

StatusForm Class | Aptify.Framework.BusinessLogic Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

StatusForm.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

StatusForm Class | Aptify.Framework.BusinessLogic Namespace


StatusForm.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

StatusForm Class | Aptify.Framework.BusinessLogic Namespace | StatusForm.Dispose Overload List


StatusForm.DoLocalization Method

public void DoLocalization();

See Also

StatusForm Class | Aptify.Framework.BusinessLogic Namespace


TextInterpretationMode Enumeration

public enum TextInterpretationMode

Members

Member Name | Description
None |
RTF |
HTML |

Requirements

Namespace: Aptify.Framework.BusinessLogic

Assembly: Metadata (in Metadata.dll)

See Also

Aptify.Framework.BusinessLogic Namespace


Aptify.Framework.BusinessLogic.Address

Aptify 5.0 Software Development Kit (SDK)

Aptify.Framework.BusinessLogic.Address Namespace

This namespace corresponds to Aptify 4.0's Address Management functionality.

Namespace hierarchy

Classes

Class | Description
AddressInfo | Tracks Address Information and Provides Utility Functionality for lookups. Handles address verification through generic IAptifyAddressVerify Interface
AddressInfoCollection | Collection of Address Info Items
AddressVerifySystemInfo |
AptifyAccumailDriver | Aptify Implemention of IAptifyAddressVerify/IAptifyAddressBatchVerify for integration with Accumail
AptifyMelissaData |
AptifyPostalCode | Utility Class to be used to get information about postal codes
AptifyQuickAddress |
Constants |
GenericAddressDriver |

Interfaces

Interface | Description
IAptifyAddressBatchVerify |
IAptifyAddressVerify |
IAptifyAddressVerifyUI |
IAptifyPostalCodeMultipleSelectGUI |

Delegates

Delegate | Description
IAptifyAddressBatchVerify.ProgressUpdateEventHandler |

Enumerations

Enumeration | Description
AddressBatchVerifyMode |
AddressVerifyResult |
AddressVerifySystemScope |


AddressBatchVerifyMode Enumeration

public enum AddressBatchVerifyMode

Members

Member Name | Description
CorrectOnly |
LogOnly |
LogAndCorrect |

Requirements

Namespace: Aptify.Framework.BusinessLogic.Address

Assembly: AptifyAddressInterface (in AptifyAddressInterface.dll)

See Also

Aptify.Framework.BusinessLogic.Address Namespace


AddressInfo Class

Tracks Address Information and Provides Utility Functionality for lookups. Handles address verification through generic IAptifyAddressVerify Interface

For a list of all members of this type, see AddressInfo Members.

System.Object
AddressInfo
OrderAddressInfo

public class AddressInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.Address

Assembly: AptifyAddressInterface (in AptifyAddressInterface.dll)

See Also

AddressInfo Members | Aptify.Framework.BusinessLogic.Address Namespace


AddressInfo Members

AddressInfo overview

Public Instance Constructors

AddressInfo Overloaded. Initializes a new instance of the AddressInfo class.

Public Instance Properties

AptifyCountryID |
Attributes | Property which exposes attributes as key/value pairs. The purpose of this dictionary is to allow additional attributes to be added to the AddressInfo object, such as new fields which have been added to the Addresses entity.
City |
Country |
CountryTelephoneCode |
County |
ID |
ISOCountryCode |
Line1 |
Line2 |
Line3 |
Line4 |
PostalCode |
StateProvince |
SuggestedAddress |
SuggestedAddresses |
SuggestedAddressExists |
USCongress |

Public Instance Methods

AptifyCountryIDExists |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAddressVerifySystemID | Returns info class for the Address Verification System to be used for the Aptify Country Code ID specified
GetAddressVerifySystemInfo | Returns info class for the Address Verification System to be used for the CURRENT address(based on country)
GetAptifyCountryIDFromCountryName |
GetAptifyCountryIDFromISOCode |
GetAptifyCountryIDFromTelephoneCode |
GetCountryName | Overloaded.
GetCountryNameFromTelephoneCode |
GetCountyFromPostalCode | Returns the name of a county for a given postal code and ISO Country Code
GetCountyFromZIPCode | Returns the Name of a county within the United States where a particular US Zip Code is located. This function is to be used only for US Zip Codes. For Postal Codes outside of the US, use the GetCountyFromPostalCode function instead.
GetDefaultLabelLines |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetISOCode | Overloaded.
GetISOCodeFromTelephoneCode |
GetLabelLinesForCountry | Overloaded.
GetLabelLinesForCountryFromCountryName |
GetLabelText | Returns a single string that contains the text for a label based on the values in the current address info object instance
GetLabelTextLines | Returns a string array with one element for each line that contains the text for a label based on the values in the current address info object instance
GetTelephoneCode | Overloaded.
GetTelephoneCodeFromCountryName |
GetType (inherited from Object) | Gets the Type of the current instance.
LoadFromDataRow | This function sets the values in the Address Info Class Based on Values in the Data Row. The Data Row Object passed in is assumed to be loaded up with a valid record from the Addresses Entity.
LoadFromGE | This function sets the values in the Address Info Class Based on Values in the GE Object. The GE Object passed in is assumed to be loaded up with a valid instance of a Addresses Entity Record.
ParsePopulateString |
SetValuesInGE | This function sets the values in the GE Class passed on based on the valeus that are currently in the Address Info Class. The GE Object passed in is assumed to be loaded up with a valid instance of a Addresses Entity Record.
ToString (inherited from Object) | Returns a String that represents the current Object.
Verify | Verifies the address using the the IAptifyAddressVerify interface and the meta-data in the Address Verification Systems entity

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AddressInfo Class | Aptify.Framework.BusinessLogic.Address Namespace


AddressInfo Constructor

Overload List

public AddressInfo(AptifyApplication);

public AddressInfo(AptifyApplication,DataRow);

public AddressInfo(AptifyGenericEntityBase);

See Also

AddressInfo Class | Aptify.Framework.BusinessLogic.Address Namespace


AddressInfo Constructor (AptifyApplication)

public AddressInfo(
AptifyApplication AptifyApplication
);

See Also

AddressInfo Class | Aptify.Framework.BusinessLogic.Address Namespace | AddressInfo Constructor Overload List


AddressInfo Constructor (AptifyGenericEntityBase)

public AddressInfo(
AptifyGenericEntityBase AddressGEToLoad
);

See Also

AddressInfo Class | Aptify.Framework.BusinessLogic.Address Namespace | AddressInfo Constructor Overload List


AddressInfo Constructor (AptifyApplication, DataRow)

public AddressInfo(
AptifyApplication AptifyApplication,
DataRow AddressDataRow
);

See Also

AddressInfo Class | Aptify.Framework.BusinessLogic.Address Namespace | AddressInfo Constructor Overload List


AddressInfo Properties

The properties of the AddressInfo class are listed below. For a complete list of AddressInfo class members, see the AddressInfo Members topic.

Public Instance Properties

AptifyCountryID |
Attributes | Property which exposes attributes as key/value pairs. The purpose of this dictionary is to allow additional attributes to be added to the AddressInfo object, such as new fields which have been added to the Addresses entity.
City |
Country |
CountryTelephoneCode |
County |
ID |
ISOCountryCode |
Line1 |
Line2 |
Line3 |
Line4 |
PostalCode |
StateProvince |
SuggestedAddress |
SuggestedAddresses |
SuggestedAddressExists |
USCongress |

See Also

AddressInfo Class | Aptify.Framework.BusinessLogic.Address Namespace


AptifyCountryID Property

Aptify 5.0 Software Development Kit (SDK)

AddressInfo.AptifyCountryID Property

public Int64 AptifyCountryID {get; set;}

See Also

AddressInfo Class | Aptify.Framework.BusinessLogic.Address Namespace


Attributes Property

Aptify 5.0 Software Development Kit (SDK)

AddressInfo.Attributes Property

Property which exposes attributes as key/value pairs. The purpose of this dictionary is to allow additional attributes to be added to the AddressInfo object, such as new fields which have been added to the Addresses entity.

public Dictionary<TKey,TValue> Attributes {get;}

Property Value

Remarks

See Also

AddressInfo Class | Aptify.Framework.BusinessLogic.Address Namespace


City Property

Aptify 5.0 Software Development Kit (SDK)

AddressInfo.City Property

public String City {get; set;}

See Also

AddressInfo Class | Aptify.Framework.BusinessLogic.Address Namespace


Country Property

Aptify 5.0 Software Development Kit (SDK)

AddressInfo.Country Property

public String Country {get; set;}

See Also

AddressInfo Class | Aptify.Framework.BusinessLogic.Address Namespace


CountryTelephoneCode Property

Aptify 5.0 Software Development Kit (SDK)

AddressInfo.CountryTelephoneCode Property

public String CountryTelephoneCode {get; set;}

See Also

AddressInfo Class | Aptify.Framework.BusinessLogic.Address Namespace


County Property

Aptify 5.0 Software Development Kit (SDK)

AddressInfo.County Property

public String County {get; set;}

See Also

AddressInfo Class | Aptify.Framework.BusinessLogic.Address Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

AddressInfo.ID Property

public Int64 ID {get; set;}

See Also

AddressInfo Class | Aptify.Framework.BusinessLogic.Address Namespace


ISOCountryCode Property

Aptify 5.0 Software Development Kit (SDK)

AddressInfo.ISOCountryCode Property

public String ISOCountryCode {get; set;}

See Also

AddressInfo Class | Aptify.Framework.BusinessLogic.Address Namespace


Line1 Property

Aptify 5.0 Software Development Kit (SDK)

AddressInfo.Line1 Property

public String Line1 {get; set;}

See Also

AddressInfo Class | Aptify.Framework.BusinessLogic.Address Namespace


Line2 Property

Aptify 5.0 Software Development Kit (SDK)

AddressInfo.Line2 Property

public String Line2 {get; set;}

See Also

AddressInfo Class | Aptify.Framework.BusinessLogic.Address Namespace


Line3 Property

Aptify 5.0 Software Development Kit (SDK)

AddressInfo.Line3 Property

public String Line3 {get; set;}

See Also

AddressInfo Class | Aptify.Framework.BusinessLogic.Address Namespace


Line4 Property

Aptify 5.0 Software Development Kit (SDK)

AddressInfo.Line4 Property

public String Line4 {get; set;}

See Also

AddressInfo Class | Aptify.Framework.BusinessLogic.Address Namespace


PostalCode Property

Aptify 5.0 Software Development Kit (SDK)

AddressInfo.PostalCode Property

public String PostalCode {get; set;}

See Also

AddressInfo Class | Aptify.Framework.BusinessLogic.Address Namespace


StateProvince Property

Aptify 5.0 Software Development Kit (SDK)

AddressInfo.StateProvince Property

public String StateProvince {get; set;}

See Also

AddressInfo Class | Aptify.Framework.BusinessLogic.Address Namespace


SuggestedAddress Property

Aptify 5.0 Software Development Kit (SDK)

AddressInfo.SuggestedAddress Property

public AddressInfo SuggestedAddress {get; set;}

See Also

AddressInfo Class | Aptify.Framework.BusinessLogic.Address Namespace


SuggestedAddresses Property

Aptify 5.0 Software Development Kit (SDK)

AddressInfo.SuggestedAddresses Property

public List<T> SuggestedAddresses {get;}

See Also

AddressInfo Class | Aptify.Framework.BusinessLogic.Address Namespace


SuggestedAddressExists Property

Aptify 5.0 Software Development Kit (SDK)

AddressInfo.SuggestedAddressExists Property

public Boolean SuggestedAddressExists {get;}

See Also

AddressInfo Class | Aptify.Framework.BusinessLogic.Address Namespace


USCongress Property

Aptify 5.0 Software Development Kit (SDK)

AddressInfo.USCongress Property

public String USCongress {get; set;}

See Also

AddressInfo Class | Aptify.Framework.BusinessLogic.Address Namespace


AddressInfo Methods

The methods of the AddressInfo class are listed below. For a complete list of AddressInfo class members, see the AddressInfo Members topic.

Public Instance Methods

AptifyCountryIDExists |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAddressVerifySystemID | Returns info class for the Address Verification System to be used for the Aptify Country Code ID specified
GetAddressVerifySystemInfo | Returns info class for the Address Verification System to be used for the CURRENT address(based on country)
GetAptifyCountryIDFromCountryName |
GetAptifyCountryIDFromISOCode |
GetAptifyCountryIDFromTelephoneCode |
GetCountryName | Overloaded.
GetCountryNameFromTelephoneCode |
GetCountyFromPostalCode | Returns the name of a county for a given postal code and ISO Country Code
GetCountyFromZIPCode | Returns the Name of a county within the United States where a particular US Zip Code is located. This function is to be used only for US Zip Codes. For Postal Codes outside of the US, use the GetCountyFromPostalCode function instead.
GetDefaultLabelLines |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetISOCode | Overloaded.
GetISOCodeFromTelephoneCode |
GetLabelLinesForCountry | Overloaded.
GetLabelLinesForCountryFromCountryName |
GetLabelText | Returns a single string that contains the text for a label based on the values in the current address info object instance
GetLabelTextLines | Returns a string array with one element for each line that contains the text for a label based on the values in the current address info object instance
GetTelephoneCode | Overloaded.
GetTelephoneCodeFromCountryName |
GetType (inherited from Object) | Gets the Type of the current instance.
LoadFromDataRow | This function sets the values in the Address Info Class Based on Values in the Data Row. The Data Row Object passed in is assumed to be loaded up with a valid record from the Addresses Entity.
LoadFromGE | This function sets the values in the Address Info Class Based on Values in the GE Object. The GE Object passed in is assumed to be loaded up with a valid instance of a Addresses Entity Record.
ParsePopulateString |
SetValuesInGE | This function sets the values in the GE Class passed on based on the valeus that are currently in the Address Info Class. The GE Object passed in is assumed to be loaded up with a valid instance of a Addresses Entity Record.
ToString (inherited from Object) | Returns a String that represents the current Object.
Verify | Verifies the address using the the IAptifyAddressVerify interface and the meta-data in the Address Verification Systems entity

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AddressInfo Class | Aptify.Framework.BusinessLogic.Address Namespace


AddressInfo.AptifyCountryIDExists Method

public bool AptifyCountryIDExists(
Int64 CountryID
);

See Also

AddressInfo Class | Aptify.Framework.BusinessLogic.Address Namespace


AddressInfo.GetAddressVerifySystemID Method

Returns info class for the Address Verification System to be used for the Aptify Country Code ID specified

public virtual AddressVerifySystemInfo GetAddressVerifySystemID(
Int64 AptifyCountryCodeID
);

Parameters

AptifyCountryCodeID

Return Value

Remarks

See Also

AddressInfo Class | Aptify.Framework.BusinessLogic.Address Namespace


AddressInfo.GetAddressVerifySystemInfo Method

Returns info class for the Address Verification System to be used for the CURRENT address(based on country)

public virtual AddressVerifySystemInfo GetAddressVerifySystemInfo();

Return Value

Remarks

See Also

AddressInfo Class | Aptify.Framework.BusinessLogic.Address Namespace


AddressInfo.GetAptifyCountryIDFromCountryName Method

public long GetAptifyCountryIDFromCountryName(
String CountryName
);

See Also

AddressInfo Class | Aptify.Framework.BusinessLogic.Address Namespace


AddressInfo.GetAptifyCountryIDFromISOCode Method

public long GetAptifyCountryIDFromISOCode(
String ISOCode
);

See Also

AddressInfo Class | Aptify.Framework.BusinessLogic.Address Namespace


AddressInfo.GetAptifyCountryIDFromTelephoneCode Method

public long GetAptifyCountryIDFromTelephoneCode(
String TelephoneCode
);

See Also

AddressInfo Class | Aptify.Framework.BusinessLogic.Address Namespace


GetCountryName Method

Aptify 5.0 Software Development Kit (SDK)

AddressInfo.GetCountryName Method

Overload List

public string GetCountryName(Int64);

public string GetCountryName(String);

See Also

AddressInfo Class | Aptify.Framework.BusinessLogic.Address Namespace


AddressInfo.GetCountryName Method (Int64)

public string GetCountryName(
Int64 CountryID
);

See Also

AddressInfo Class | Aptify.Framework.BusinessLogic.Address Namespace | AddressInfo.GetCountryName Overload List


AddressInfo.GetCountryName Method (String)

public string GetCountryName(
String ISOCode
);

See Also

AddressInfo Class | Aptify.Framework.BusinessLogic.Address Namespace | AddressInfo.GetCountryName Overload List


AddressInfo.GetCountryNameFromTelephoneCode Method

public string GetCountryNameFromTelephoneCode(
String TelephoneCode
);

See Also

AddressInfo Class | Aptify.Framework.BusinessLogic.Address Namespace


AddressInfo.GetCountyFromPostalCode Method

Returns the name of a county for a given postal code and ISO Country Code

public string GetCountyFromPostalCode(
String PostalCode,
String ISOCountryCode
);

Parameters

PostalCode
Postal Code To Return County From
ISOCountryCode
ISO Country Code Where PostalCode Is Located

Return Value

Remarks

See Also

AddressInfo Class | Aptify.Framework.BusinessLogic.Address Namespace


AddressInfo.GetCountyFromZIPCode Method

Returns the Name of a county within the United States where a particular US Zip Code is located. This function is to be used only for US Zip Codes. For Postal Codes outside of the US, use the GetCountyFromPostalCode function instead.

public string GetCountyFromZIPCode(
String ZIPCode
);

Parameters

ZIPCode
US Zip Code To Find County

Return Value

Remarks

See Also

AddressInfo Class | Aptify.Framework.BusinessLogic.Address Namespace


AddressInfo.GetDefaultLabelLines Method

public string[] GetDefaultLabelLines();

See Also

AddressInfo Class | Aptify.Framework.BusinessLogic.Address Namespace


GetISOCode Method

Aptify 5.0 Software Development Kit (SDK)

AddressInfo.GetISOCode Method

Overload List

public string GetISOCode(Int64);

public string GetISOCode(String);

See Also

AddressInfo Class | Aptify.Framework.BusinessLogic.Address Namespace


AddressInfo.GetISOCode Method (Int64)

public string GetISOCode(
Int64 CountryID
);

See Also

AddressInfo Class | Aptify.Framework.BusinessLogic.Address Namespace | AddressInfo.GetISOCode Overload List


AddressInfo.GetISOCode Method (String)

public string GetISOCode(
String CountryName
);

See Also

AddressInfo Class | Aptify.Framework.BusinessLogic.Address Namespace | AddressInfo.GetISOCode Overload List


AddressInfo.GetISOCodeFromTelephoneCode Method

public string GetISOCodeFromTelephoneCode(
String TelephoneCode
);

See Also

AddressInfo Class | Aptify.Framework.BusinessLogic.Address Namespace


GetLabelLinesForCountry Method

Aptify 5.0 Software Development Kit (SDK)

AddressInfo.GetLabelLinesForCountry Method

Overload List

public string[] GetLabelLinesForCountry();

public string[] GetLabelLinesForCountry(Int64);

public string[] GetLabelLinesForCountry(String);

See Also

AddressInfo Class | Aptify.Framework.BusinessLogic.Address Namespace


AddressInfo.GetLabelLinesForCountry Method ()

public string[] GetLabelLinesForCountry();

See Also

AddressInfo Class | Aptify.Framework.BusinessLogic.Address Namespace | AddressInfo.GetLabelLinesForCountry Overload List


AddressInfo.GetLabelLinesForCountry Method (Int64)

public string[] GetLabelLinesForCountry(
Int64 AptifyCountryID
);

See Also

AddressInfo Class | Aptify.Framework.BusinessLogic.Address Namespace | AddressInfo.GetLabelLinesForCountry Overload List


AddressInfo.GetLabelLinesForCountry Method (String)

public string[] GetLabelLinesForCountry(
String ISOCode
);

See Also

AddressInfo Class | Aptify.Framework.BusinessLogic.Address Namespace | AddressInfo.GetLabelLinesForCountry Overload List


AddressInfo.GetLabelLinesForCountryFromCountryName Method

public string[] GetLabelLinesForCountryFromCountryName(
String CountryName
);

See Also

AddressInfo Class | Aptify.Framework.BusinessLogic.Address Namespace


AddressInfo.GetLabelText Method

Returns a single string that contains the text for a label based on the values in the current address info object instance

public string GetLabelText(
AptifyGenericEntityBase AddressOwnerGE,
Boolean SuppressBlankLines
);

Parameters

AddressOwnerGE
This parameter, if provided is the parent GE that owns the Address object that is having its label text processed. This parameter can be provided so that information from the Parent GE can be included in the label text. As an example, if a Person record was the Owner GE for the Address and the Label Lines included a tag called
Record Name
then the IsName field from the parent record will be populated. In addition, other attributes from the Parent record can be included in the Label definition and will be included here automatically if the AddressOwnerGE is provided
SuppressBlankLines

Return Value

Remarks

See Also

AddressInfo Class | Aptify.Framework.BusinessLogic.Address Namespace


AddressInfo.GetLabelTextLines Method

Returns a string array with one element for each line that contains the text for a label based on the values in the current address info object instance

public string[] GetLabelTextLines(
AptifyGenericEntityBase AddressOwnerGE
);

Parameters

AddressOwnerGE
This parameter, if provided is the parent GE that owns the Address object that is having its label text processed. This parameter can be provided so that information from the Parent GE can be included in the label text. As an example, if a Person record was the Owner GE for the Address and the Label Lines included a tag called
Record Name
then the IsName field from the parent record will be populated. In addition, other attributes from the Parent record can be included in the Label definition and will be included here automatically if the AddressOwnerGE is provided

Return Value

Remarks

See Also

AddressInfo Class | Aptify.Framework.BusinessLogic.Address Namespace


GetTelephoneCode Method

Aptify 5.0 Software Development Kit (SDK)

AddressInfo.GetTelephoneCode Method

Overload List

public string GetTelephoneCode(Int64);

public string GetTelephoneCode(String);

See Also

AddressInfo Class | Aptify.Framework.BusinessLogic.Address Namespace


AddressInfo.GetTelephoneCode Method (Int64)

public string GetTelephoneCode(
Int64 CountryID
);

See Also

AddressInfo Class | Aptify.Framework.BusinessLogic.Address Namespace | AddressInfo.GetTelephoneCode Overload List


AddressInfo.GetTelephoneCode Method (String)

public string GetTelephoneCode(
String ISOCode
);

See Also

AddressInfo Class | Aptify.Framework.BusinessLogic.Address Namespace | AddressInfo.GetTelephoneCode Overload List


AddressInfo.GetTelephoneCodeFromCountryName Method

public string GetTelephoneCodeFromCountryName(
String CountryName
);

See Also

AddressInfo Class | Aptify.Framework.BusinessLogic.Address Namespace


AddressInfo.LoadFromDataRow Method

This function sets the values in the Address Info Class Based on Values in the Data Row. The Data Row Object passed in is assumed to be loaded up with a valid record from the Addresses Entity.

public virtual void LoadFromDataRow(
DataRow AddressDataRow
);

Parameters

AddressDataRow

Remarks

See Also

AddressInfo Class | Aptify.Framework.BusinessLogic.Address Namespace


AddressInfo.LoadFromGE Method

This function sets the values in the Address Info Class Based on Values in the GE Object. The GE Object passed in is assumed to be loaded up with a valid instance of a Addresses Entity Record.

public virtual void LoadFromGE(
AptifyGenericEntityBase AddressGEToLoad
);

Parameters

AddressGEToLoad

Remarks

See Also

AddressInfo Class | Aptify.Framework.BusinessLogic.Address Namespace


AddressInfo.ParsePopulateString Method

public string ParsePopulateString(
String StringToParse,
Boolean URLEncode,
AptifyGenericEntityBase AddressOwnerGE
);

See Also

AddressInfo Class | Aptify.Framework.BusinessLogic.Address Namespace


AddressInfo.SetValuesInGE Method

This function sets the values in the GE Class passed on based on the valeus that are currently in the Address Info Class. The GE Object passed in is assumed to be loaded up with a valid instance of a Addresses Entity Record.

public virtual void SetValuesInGE(
AptifyGenericEntityBase AddressGEToSetValuesIn
);

Parameters

AddressGEToSetValuesIn

Remarks

See Also

AddressInfo Class | Aptify.Framework.BusinessLogic.Address Namespace


AddressInfo.Verify Method

Verifies the address using the the IAptifyAddressVerify interface and the meta-data in the Address Verification Systems entity

public virtual AddressVerifyResult Verify(
ref String& ErrorMessage
);

Parameters

ErrorMessage

Return Value

Remarks

See Also

AddressInfo Class | Aptify.Framework.BusinessLogic.Address Namespace


AddressInfoCollection Class

Collection of Address Info Items

For a list of all members of this type, see AddressInfoCollection Members.

System.Object
ArrayList
AddressInfoCollection

public class AddressInfoCollection : ArrayList

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.Address

Assembly: AptifyAddressInterface (in AptifyAddressInterface.dll)

See Also

AddressInfoCollection Members | Aptify.Framework.BusinessLogic.Address Namespace


AddressInfoCollection Members

AddressInfoCollection overview

Public Instance Constructors

AddressInfoCollection Constructor Initializes a new instance of the AddressInfoCollection class.

Public Instance Properties

Capacity (inherited from ArrayList) | Gets or sets the number of elements that the ArrayList can contain.
Count (inherited from ArrayList) | Gets the number of elements actually contained in the ArrayList.
IsFixedSize (inherited from ArrayList) | Gets a value indicating whether the ArrayList has a fixed size.
IsReadOnly (inherited from ArrayList) | Gets a value indicating whether the ArrayList is read-only.
IsSynchronized (inherited from ArrayList) | Gets a value indicating whether access to the ArrayList is synchronized (thread safe).
Item | Overloaded.
SyncRoot (inherited from ArrayList) | Gets an object that can be used to synchronize access to the ArrayList.

Public Instance Methods

Add | Overloaded.
Add (inherited from ArrayList) | Overloaded. Adds an object to the end of the ArrayList.
AddRange (inherited from ArrayList) | Adds the elements of an ICollection to the end of the ArrayList.
BinarySearch (inherited from ArrayList) | Overloaded. Searches a range of elements in the sorted ArrayList for an element using the specified comparer and returns the zero-based index of the element.
Clear (inherited from ArrayList) | Removes all elements from the ArrayList.
Clone (inherited from ArrayList) | Creates a shallow copy of the ArrayList.
Contains (inherited from ArrayList) | Determines whether an element is in the ArrayList.
CopyTo (inherited from ArrayList) | Overloaded. Copies the entire ArrayList to a compatible one-dimensional Array, starting at the beginning of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from ArrayList) | Overloaded. Returns an enumerator for the entire ArrayList.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetRange (inherited from ArrayList) | Returns an ArrayList which represents a subset of the elements in the source ArrayList.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from ArrayList) | Overloaded. Searches for the specified Object and returns the zero-based index of the first occurrence within the entire ArrayList.
Insert (inherited from ArrayList) | Inserts an element into the ArrayList at the specified index.
InsertRange (inherited from ArrayList) | Inserts the elements of a collection into the ArrayList at the specified index.
LastIndexOf (inherited from ArrayList) | Overloaded. Searches for the specified Object and returns the zero-based index of the last occurrence within the entire ArrayList.
Remove (inherited from ArrayList) | Removes the first occurrence of a specific object from the ArrayList.
RemoveAt (inherited from ArrayList) | Removes the element at the specified index of the ArrayList.
RemoveRange (inherited from ArrayList) | Removes a range of elements from the ArrayList.
Reverse (inherited from ArrayList) | Overloaded. Reverses the order of the elements in the entire ArrayList.
SetRange (inherited from ArrayList) | Copies the elements of a collection over a range of elements in the ArrayList.
Sort (inherited from ArrayList) | Overloaded. Sorts the elements in the entire ArrayList using the IComparable implementation of each element.
ToArray (inherited from ArrayList) | Overloaded. Copies the elements of the ArrayList to a new Object array.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimToSize (inherited from ArrayList) | Sets the capacity to the actual number of elements in the ArrayList.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AddressInfoCollection Class | Aptify.Framework.BusinessLogic.Address Namespace


AddressInfoCollection Constructor

Initializes a new instance of the AddressInfoCollection class.

public AddressInfoCollection();

See Also

AddressInfoCollection Class | Aptify.Framework.BusinessLogic.Address Namespace


AddressInfoCollection Properties

The properties of the AddressInfoCollection class are listed below. For a complete list of AddressInfoCollection class members, see the AddressInfoCollection Members topic.

Public Instance Properties

Capacity (inherited from ArrayList) | Gets or sets the number of elements that the ArrayList can contain.
Count (inherited from ArrayList) | Gets the number of elements actually contained in the ArrayList.
IsFixedSize (inherited from ArrayList) | Gets a value indicating whether the ArrayList has a fixed size.
IsReadOnly (inherited from ArrayList) | Gets a value indicating whether the ArrayList is read-only.
IsSynchronized (inherited from ArrayList) | Gets a value indicating whether access to the ArrayList is synchronized (thread safe).
Item | Overloaded.
SyncRoot (inherited from ArrayList) | Gets an object that can be used to synchronize access to the ArrayList.

See Also

AddressInfoCollection Class | Aptify.Framework.BusinessLogic.Address Namespace


Item Property

Aptify 5.0 Software Development Kit (SDK)

AddressInfoCollection.Item Property

public AddressInfo this[
Int32 index
] {get; set;}

See Also

AddressInfoCollection Class | Aptify.Framework.BusinessLogic.Address Namespace


AddressInfoCollection Methods

The methods of the AddressInfoCollection class are listed below. For a complete list of AddressInfoCollection class members, see the AddressInfoCollection Members topic.

Public Instance Methods

Add | Overloaded.
Add (inherited from ArrayList) | Overloaded. Adds an object to the end of the ArrayList.
AddRange (inherited from ArrayList) | Adds the elements of an ICollection to the end of the ArrayList.
BinarySearch (inherited from ArrayList) | Overloaded. Searches a range of elements in the sorted ArrayList for an element using the specified comparer and returns the zero-based index of the element.
Clear (inherited from ArrayList) | Removes all elements from the ArrayList.
Clone (inherited from ArrayList) | Creates a shallow copy of the ArrayList.
Contains (inherited from ArrayList) | Determines whether an element is in the ArrayList.
CopyTo (inherited from ArrayList) | Overloaded. Copies the entire ArrayList to a compatible one-dimensional Array, starting at the beginning of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from ArrayList) | Overloaded. Returns an enumerator for the entire ArrayList.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetRange (inherited from ArrayList) | Returns an ArrayList which represents a subset of the elements in the source ArrayList.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from ArrayList) | Overloaded. Searches for the specified Object and returns the zero-based index of the first occurrence within the entire ArrayList.
Insert (inherited from ArrayList) | Inserts an element into the ArrayList at the specified index.
InsertRange (inherited from ArrayList) | Inserts the elements of a collection into the ArrayList at the specified index.
LastIndexOf (inherited from ArrayList) | Overloaded. Searches for the specified Object and returns the zero-based index of the last occurrence within the entire ArrayList.
Remove (inherited from ArrayList) | Removes the first occurrence of a specific object from the ArrayList.
RemoveAt (inherited from ArrayList) | Removes the element at the specified index of the ArrayList.
RemoveRange (inherited from ArrayList) | Removes a range of elements from the ArrayList.
Reverse (inherited from ArrayList) | Overloaded. Reverses the order of the elements in the entire ArrayList.
SetRange (inherited from ArrayList) | Copies the elements of a collection over a range of elements in the ArrayList.
Sort (inherited from ArrayList) | Overloaded. Sorts the elements in the entire ArrayList using the IComparable implementation of each element.
ToArray (inherited from ArrayList) | Overloaded. Copies the elements of the ArrayList to a new Object array.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimToSize (inherited from ArrayList) | Sets the capacity to the actual number of elements in the ArrayList.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AddressInfoCollection Class | Aptify.Framework.BusinessLogic.Address Namespace


Add Method

Aptify 5.0 Software Development Kit (SDK)

AddressInfoCollection.Add Method

Overload List

public int Add(AddressInfo);

Inherited from ArrayList.

public virtual int Add(Object);

See Also

AddressInfoCollection Class | Aptify.Framework.BusinessLogic.Address Namespace


AddressInfoCollection.Add Method (AddressInfo)

public int Add(
AddressInfo value
);

See Also

AddressInfoCollection Class | Aptify.Framework.BusinessLogic.Address Namespace | AddressInfoCollection.Add Overload List


AddressVerifyResult Enumeration

public enum AddressVerifyResult

Members

Member Name | Description
Success |
ChangeSuggested |
Failed |

Requirements

Namespace: Aptify.Framework.BusinessLogic.Address

Assembly: AptifyAddressInterface (in AptifyAddressInterface.dll)

See Also

Aptify.Framework.BusinessLogic.Address Namespace


AddressVerifySystemInfo Class

For a list of all members of this type, see AddressVerifySystemInfo Members.

System.Object
AddressVerifySystemInfo

public class AddressVerifySystemInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.Address

Assembly: AptifyAddressInterface (in AptifyAddressInterface.dll)

See Also

AddressVerifySystemInfo Members | Aptify.Framework.BusinessLogic.Address Namespace


AddressVerifySystemInfo Members

AddressVerifySystemInfo overview

Public Instance Constructors

AddressVerifySystemInfo Constructor

Public Instance Properties

AssemblyName |
ClassName |
Comments |
Description |
ID |
Name |
ObjectName |
Rank |
Scope |
ShowUserInterface |
SupportsBatch |
SupportsRealTime |
UIAssemblyName | Property representing the Assembly name of the Viewer plugin.
UIClassName | Property representing the Type name of the Viewer plugin.
UIObjectName | Property representing the Repository Object Location of the UI plugin.
UIPluginPresent | Property indicates presence of a UI plugin for display of all suggested addresses.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAssemblyNameFromFileName |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
GetVerificationObject |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AddressVerifySystemInfo Class | Aptify.Framework.BusinessLogic.Address Namespace


AddressVerifySystemInfo Constructor

public AddressVerifySystemInfo(
AptifyApplication AptifyApplication,
DataRow dr
);

See Also

AddressVerifySystemInfo Class | Aptify.Framework.BusinessLogic.Address Namespace


AddressVerifySystemInfo Properties

The properties of the AddressVerifySystemInfo class are listed below. For a complete list of AddressVerifySystemInfo class members, see the AddressVerifySystemInfo Members topic.

Public Instance Properties

AssemblyName |
ClassName |
Comments |
Description |
ID |
Name |
ObjectName |
Rank |
Scope |
ShowUserInterface |
SupportsBatch |
SupportsRealTime |
UIAssemblyName | Property representing the Assembly name of the Viewer plugin.
UIClassName | Property representing the Type name of the Viewer plugin.
UIObjectName | Property representing the Repository Object Location of the UI plugin.
UIPluginPresent | Property indicates presence of a UI plugin for display of all suggested addresses.

See Also

AddressVerifySystemInfo Class | Aptify.Framework.BusinessLogic.Address Namespace


AssemblyName Property

Aptify 5.0 Software Development Kit (SDK)

AddressVerifySystemInfo.AssemblyName Property

public String AssemblyName {get;}

See Also

AddressVerifySystemInfo Class | Aptify.Framework.BusinessLogic.Address Namespace


ClassName Property

Aptify 5.0 Software Development Kit (SDK)

AddressVerifySystemInfo.ClassName Property

public String ClassName {get;}

See Also

AddressVerifySystemInfo Class | Aptify.Framework.BusinessLogic.Address Namespace


Comments Property

Aptify 5.0 Software Development Kit (SDK)

AddressVerifySystemInfo.Comments Property

public String Comments {get;}

See Also

AddressVerifySystemInfo Class | Aptify.Framework.BusinessLogic.Address Namespace


Description Property

Aptify 5.0 Software Development Kit (SDK)

AddressVerifySystemInfo.Description Property

public String Description {get;}

See Also

AddressVerifySystemInfo Class | Aptify.Framework.BusinessLogic.Address Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

AddressVerifySystemInfo.ID Property

public Int64 ID {get;}

See Also

AddressVerifySystemInfo Class | Aptify.Framework.BusinessLogic.Address Namespace


Name Property

Aptify 5.0 Software Development Kit (SDK)

AddressVerifySystemInfo.Name Property

public String Name {get;}

See Also

AddressVerifySystemInfo Class | Aptify.Framework.BusinessLogic.Address Namespace


ObjectName Property

Aptify 5.0 Software Development Kit (SDK)

AddressVerifySystemInfo.ObjectName Property

public String ObjectName {get;}

See Also

AddressVerifySystemInfo Class | Aptify.Framework.BusinessLogic.Address Namespace


Rank Property

Aptify 5.0 Software Development Kit (SDK)

AddressVerifySystemInfo.Rank Property

public Int32 Rank {get;}

See Also

AddressVerifySystemInfo Class | Aptify.Framework.BusinessLogic.Address Namespace


Scope Property

Aptify 5.0 Software Development Kit (SDK)

AddressVerifySystemInfo.Scope Property

public AddressVerifySystemScope Scope {get;}

See Also

AddressVerifySystemInfo Class | Aptify.Framework.BusinessLogic.Address Namespace


ShowUserInterface Property

Aptify 5.0 Software Development Kit (SDK)

AddressVerifySystemInfo.ShowUserInterface Property

public Boolean ShowUserInterface {get;}

See Also

AddressVerifySystemInfo Class | Aptify.Framework.BusinessLogic.Address Namespace


SupportsBatch Property

Aptify 5.0 Software Development Kit (SDK)

AddressVerifySystemInfo.SupportsBatch Property

public Boolean SupportsBatch {get;}

See Also

AddressVerifySystemInfo Class | Aptify.Framework.BusinessLogic.Address Namespace


SupportsRealTime Property

Aptify 5.0 Software Development Kit (SDK)

AddressVerifySystemInfo.SupportsRealTime Property

public Boolean SupportsRealTime {get;}

See Also

AddressVerifySystemInfo Class | Aptify.Framework.BusinessLogic.Address Namespace


UIAssemblyName Property

Aptify 5.0 Software Development Kit (SDK)

AddressVerifySystemInfo.UIAssemblyName Property

Property representing the Assembly name of the Viewer plugin.

public String UIAssemblyName {get;}

Property Value

Remarks

See Also

AddressVerifySystemInfo Class | Aptify.Framework.BusinessLogic.Address Namespace


UIClassName Property

Aptify 5.0 Software Development Kit (SDK)

AddressVerifySystemInfo.UIClassName Property

Property representing the Type name of the Viewer plugin.

public String UIClassName {get;}

Property Value

Remarks

See Also

AddressVerifySystemInfo Class | Aptify.Framework.BusinessLogic.Address Namespace


UIObjectName Property

Aptify 5.0 Software Development Kit (SDK)

AddressVerifySystemInfo.UIObjectName Property

Property representing the Repository Object Location of the UI plugin.

public String UIObjectName {get;}

Property Value

Remarks

See Also

AddressVerifySystemInfo Class | Aptify.Framework.BusinessLogic.Address Namespace


UIPluginPresent Property

Aptify 5.0 Software Development Kit (SDK)

AddressVerifySystemInfo.UIPluginPresent Property

Property indicates presence of a UI plugin for display of all suggested addresses.

public Boolean UIPluginPresent {get;}

Property Value

Remarks

See Also

AddressVerifySystemInfo Class | Aptify.Framework.BusinessLogic.Address Namespace


AddressVerifySystemInfo Methods

The methods of the AddressVerifySystemInfo class are listed below. For a complete list of AddressVerifySystemInfo class members, see the AddressVerifySystemInfo Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAssemblyNameFromFileName |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
GetVerificationObject |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AddressVerifySystemInfo Class | Aptify.Framework.BusinessLogic.Address Namespace


AddressVerifySystemInfo.GetAssemblyNameFromFileName Method

public string GetAssemblyNameFromFileName(
String FileName
);

See Also

AddressVerifySystemInfo Class | Aptify.Framework.BusinessLogic.Address Namespace


AddressVerifySystemInfo.GetVerificationObject Method

public IAptifyAddressVerify GetVerificationObject();

See Also

AddressVerifySystemInfo Class | Aptify.Framework.BusinessLogic.Address Namespace


AddressVerifySystemScope Enumeration

public enum AddressVerifySystemScope

Members

Member Name | Description
Global |
CountrySpecific |

Requirements

Namespace: Aptify.Framework.BusinessLogic.Address

Assembly: AptifyAddressInterface (in AptifyAddressInterface.dll)

See Also

Aptify.Framework.BusinessLogic.Address Namespace


AptifyAccumailDriver Class

Aptify Implemention of IAptifyAddressVerify/IAptifyAddressBatchVerify for integration with Accumail

For a list of all members of this type, see AptifyAccumailDriver Members.

System.Object
GenericAddressDriver
AptifyAccumailDriver

public class AptifyAccumailDriver : GenericAddressDriver

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.Address

Assembly: AptifyAddressDrivers (in AptifyAddressDrivers.dll)

See Also

AptifyAccumailDriver Members | Aptify.Framework.BusinessLogic.Address Namespace


AptifyAccumailDriver Members

AptifyAccumailDriver overview

Public Instance Constructors

AptifyAccumailDriver Constructor Initializes a new instance of the AptifyAccumailDriver class.

Public Instance Properties

Application (inherited from GenericAddressDriver) |
AttributesDataTable (inherited from GenericAddressDriver) | Returns a list of Configuration Attributes for the current address verification system
DataAction (inherited from GenericAddressDriver) |
ProgressUpdateInterval (inherited from GenericAddressDriver) |
VerificationSystemID (inherited from GenericAddressDriver) | Returns the verification system ID value passed into Config()

Public Instance Methods

Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
LoadDriverConfigAttributes (inherited from GenericAddressDriver) | Responsibile for loading the driver configuration attributes. Automatically called the first time GetDriverConfigAttribute() is called
ToString (inherited from Object) | Returns a String that represents the current Object.
VerifyAddressBatch (inherited from GenericAddressDriver) | Overloaded.
VerifyMultipleAddresses (inherited from GenericAddressDriver) | Overloaded.
VerifySingleAddress | Overloaded.
VerifySingleAddress (inherited from GenericAddressDriver) | Overloaded.

Public Instance Events

ProgressUpdate (inherited from GenericAddressDriver)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetDriverConfigAttribute (inherited from GenericAddressDriver) | Overloaded. This method is responsible for going through the rows in the data table and finding the attribute by the name of AttributeName and returning the associated value, if found. If not found, DefaultValue is returned.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyAccumailDriver Class | Aptify.Framework.BusinessLogic.Address Namespace


AptifyAccumailDriver Constructor

Initializes a new instance of the AptifyAccumailDriver class.

public AptifyAccumailDriver();

See Also

AptifyAccumailDriver Class | Aptify.Framework.BusinessLogic.Address Namespace


AptifyAccumailDriver Methods

The methods of the AptifyAccumailDriver class are listed below. For a complete list of AptifyAccumailDriver class members, see the AptifyAccumailDriver Members topic.

Public Instance Methods

Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
LoadDriverConfigAttributes (inherited from GenericAddressDriver) | Responsibile for loading the driver configuration attributes. Automatically called the first time GetDriverConfigAttribute() is called
ToString (inherited from Object) | Returns a String that represents the current Object.
VerifyAddressBatch (inherited from GenericAddressDriver) | Overloaded.
VerifyMultipleAddresses (inherited from GenericAddressDriver) | Overloaded.
VerifySingleAddress | Overloaded.
VerifySingleAddress (inherited from GenericAddressDriver) | Overloaded.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetDriverConfigAttribute (inherited from GenericAddressDriver) | Overloaded. This method is responsible for going through the rows in the data table and finding the attribute by the name of AttributeName and returning the associated value, if found. If not found, DefaultValue is returned.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyAccumailDriver Class | Aptify.Framework.BusinessLogic.Address Namespace


AptifyAccumailDriver.Config Method

public override bool Config(
AptifyApplication AptifyApplication,
Int64 VerificationSystemID
);

Implements

IAptifyAddressBatchVerify.

See Also

AptifyAccumailDriver Class | Aptify.Framework.BusinessLogic.Address Namespace


VerifySingleAddress Method

Aptify 5.0 Software Development Kit (SDK)

AptifyAccumailDriver.VerifySingleAddress Method

Overload List

Inherited from GenericAddressDriver.

public virtual AddressVerifyResult VerifySingleAddress(AddressInfo);

public override AddressVerifyResult VerifySingleAddress(AddressInfo,ref String&);

See Also

AptifyAccumailDriver Class | Aptify.Framework.BusinessLogic.Address Namespace


AptifyAccumailDriver.VerifySingleAddress Method (AddressInfo, String&)

public override AddressVerifyResult VerifySingleAddress(
AddressInfo Address,
ref String& ErrorString
);

Implements

IAptifyAddressVerify.

See Also

AptifyAccumailDriver Class | Aptify.Framework.BusinessLogic.Address Namespace | AptifyAccumailDriver.VerifySingleAddress Overload List


AptifyMelissaData Class

For a list of all members of this type, see AptifyMelissaData Members.

System.Object
GenericAddressDriver
AptifyMelissaData

public class AptifyMelissaData : GenericAddressDriver

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.Address

Assembly: AptifyAddressDrivers (in AptifyAddressDrivers.dll)

See Also

AptifyMelissaData Members | Aptify.Framework.BusinessLogic.Address Namespace


AptifyMelissaData Members

AptifyMelissaData overview

Public Instance Constructors

AptifyMelissaData Constructor Initializes a new instance of the AptifyMelissaData class.

Public Instance Properties

Application (inherited from GenericAddressDriver) |
AttributesDataTable (inherited from GenericAddressDriver) | Returns a list of Configuration Attributes for the current address verification system
DataAction (inherited from GenericAddressDriver) |
ProgressUpdateInterval (inherited from GenericAddressDriver) |
VerificationSystemID (inherited from GenericAddressDriver) | Returns the verification system ID value passed into Config()

Public Instance Methods

Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
LoadDriverConfigAttributes (inherited from GenericAddressDriver) | Responsibile for loading the driver configuration attributes. Automatically called the first time GetDriverConfigAttribute() is called
ToString (inherited from Object) | Returns a String that represents the current Object.
VerifyAddressBatch (inherited from GenericAddressDriver) | Overloaded.
VerifyMultipleAddresses (inherited from GenericAddressDriver) | Overloaded.
VerifySingleAddress | Overloaded.
VerifySingleAddress (inherited from GenericAddressDriver) | Overloaded.

Public Instance Events

ProgressUpdate (inherited from GenericAddressDriver)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetDriverConfigAttribute (inherited from GenericAddressDriver) | Overloaded. This method is responsible for going through the rows in the data table and finding the attribute by the name of AttributeName and returning the associated value, if found. If not found, DefaultValue is returned.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyMelissaData Class | Aptify.Framework.BusinessLogic.Address Namespace


AptifyMelissaData Constructor

Initializes a new instance of the AptifyMelissaData class.

public AptifyMelissaData();

See Also

AptifyMelissaData Class | Aptify.Framework.BusinessLogic.Address Namespace


AptifyMelissaData Methods

The methods of the AptifyMelissaData class are listed below. For a complete list of AptifyMelissaData class members, see the AptifyMelissaData Members topic.

Public Instance Methods

Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
LoadDriverConfigAttributes (inherited from GenericAddressDriver) | Responsibile for loading the driver configuration attributes. Automatically called the first time GetDriverConfigAttribute() is called
ToString (inherited from Object) | Returns a String that represents the current Object.
VerifyAddressBatch (inherited from GenericAddressDriver) | Overloaded.
VerifyMultipleAddresses (inherited from GenericAddressDriver) | Overloaded.
VerifySingleAddress | Overloaded.
VerifySingleAddress (inherited from GenericAddressDriver) | Overloaded.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetDriverConfigAttribute (inherited from GenericAddressDriver) | Overloaded. This method is responsible for going through the rows in the data table and finding the attribute by the name of AttributeName and returning the associated value, if found. If not found, DefaultValue is returned.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyMelissaData Class | Aptify.Framework.BusinessLogic.Address Namespace


AptifyMelissaData.Config Method

public override bool Config(
AptifyApplication AptifyApplication,
Int64 VerificationSystemID
);

Implements

IAptifyAddressBatchVerify.

See Also

AptifyMelissaData Class | Aptify.Framework.BusinessLogic.Address Namespace


VerifySingleAddress Method

Aptify 5.0 Software Development Kit (SDK)

AptifyMelissaData.VerifySingleAddress Method

Overload List

Inherited from GenericAddressDriver.

public virtual AddressVerifyResult VerifySingleAddress(AddressInfo);

public override AddressVerifyResult VerifySingleAddress(AddressInfo,ref String&);

See Also

AptifyMelissaData Class | Aptify.Framework.BusinessLogic.Address Namespace


AptifyMelissaData.VerifySingleAddress Method (AddressInfo, String&)

public override AddressVerifyResult VerifySingleAddress(
AddressInfo Address,
ref String& ErrorString
);

Implements

IAptifyAddressVerify.

See Also

AptifyMelissaData Class | Aptify.Framework.BusinessLogic.Address Namespace | AptifyMelissaData.VerifySingleAddress Overload List


AptifyPostalCode Class

Utility Class to be used to get information about postal codes

For a list of all members of this type, see AptifyPostalCode Members.

System.Object
AptifyPostalCode

public class AptifyPostalCode

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.Address

Assembly: AptifyAddressInterface (in AptifyAddressInterface.dll)

See Also

AptifyPostalCode Members | Aptify.Framework.BusinessLogic.Address Namespace


AptifyPostalCode Members

AptifyPostalCode overview

Public Instance Constructors

AptifyPostalCode Overloaded. Initializes a new instance of the AptifyPostalCode class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPostalCodeAreaCode | Overloaded. This function assumes the postal code is in the United States
GetPostalCodeFromCityCounty | Overloaded. This function assumes the postal code is in the United States
GetPostalCodeFromCityStateProvince | Overloaded. This function assumes the postal code is in the United States
GetPostalCodeFromCityStateProvinceCounty | Overloaded. This function assumes the postal code is in the United States
GetPostalCodeInfo | Overloaded.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyPostalCode Class | Aptify.Framework.BusinessLogic.Address Namespace


AptifyPostalCode Constructor

Overload List

public AptifyPostalCode(AptifyApplication);

public AptifyPostalCode(UserCredentials);

See Also

AptifyPostalCode Class | Aptify.Framework.BusinessLogic.Address Namespace


AptifyPostalCode Constructor (AptifyApplication)

public AptifyPostalCode(
AptifyApplication Application
);

See Also

AptifyPostalCode Class | Aptify.Framework.BusinessLogic.Address Namespace | AptifyPostalCode Constructor Overload List


AptifyPostalCode Constructor (UserCredentials)

public AptifyPostalCode(
UserCredentials UserCredentials
);

See Also

AptifyPostalCode Class | Aptify.Framework.BusinessLogic.Address Namespace | AptifyPostalCode Constructor Overload List


AptifyPostalCode Methods

The methods of the AptifyPostalCode class are listed below. For a complete list of AptifyPostalCode class members, see the AptifyPostalCode Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPostalCodeAreaCode | Overloaded. This function assumes the postal code is in the United States
GetPostalCodeFromCityCounty | Overloaded. This function assumes the postal code is in the United States
GetPostalCodeFromCityStateProvince | Overloaded. This function assumes the postal code is in the United States
GetPostalCodeFromCityStateProvinceCounty | Overloaded. This function assumes the postal code is in the United States
GetPostalCodeInfo | Overloaded.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyPostalCode Class | Aptify.Framework.BusinessLogic.Address Namespace


GetPostalCodeAreaCode Method

Aptify 5.0 Software Development Kit (SDK)

AptifyPostalCode.GetPostalCodeAreaCode Method

Overload List

public bool GetPostalCodeAreaCode(String,String,ref String&);

public bool GetPostalCodeAreaCode(String,String,ref String&,Boolean);

This function assumes the postal code is in the United States

public bool GetPostalCodeAreaCode(String,ref String&);

This function assumes the postal code is in the United States

public bool GetPostalCodeAreaCode(String,ref String&,Boolean);

See Also

AptifyPostalCode Class | Aptify.Framework.BusinessLogic.Address Namespace


AptifyPostalCode.GetPostalCodeAreaCode Method (String, String, String&)

public bool GetPostalCodeAreaCode(
String PostalCode,
String ISOCountryCode,
ref String& AreaCode
);

See Also

AptifyPostalCode Class | Aptify.Framework.BusinessLogic.Address Namespace | AptifyPostalCode.GetPostalCodeAreaCode Overload List


AptifyPostalCode.GetPostalCodeAreaCode Method (String, String, String&, Boolean)

public bool GetPostalCodeAreaCode(
String PostalCode,
String ISOCountryCode,
ref String& AreaCode,
Boolean AllowGUI
);

See Also

AptifyPostalCode Class | Aptify.Framework.BusinessLogic.Address Namespace | AptifyPostalCode.GetPostalCodeAreaCode Overload List


AptifyPostalCode.GetPostalCodeAreaCode Method (String, String&)

This function assumes the postal code is in the United States

public bool GetPostalCodeAreaCode(
String PostalCode,
ref String& AreaCode
);

Parameters

PostalCode
AreaCode

Return Value

Remarks

See Also

AptifyPostalCode Class | Aptify.Framework.BusinessLogic.Address Namespace | AptifyPostalCode.GetPostalCodeAreaCode Overload List


AptifyPostalCode.GetPostalCodeAreaCode Method (String, String&, Boolean)

This function assumes the postal code is in the United States

public bool GetPostalCodeAreaCode(
String PostalCode,
ref String& AreaCode,
Boolean AllowGUI
);

Parameters

PostalCode
AreaCode
AllowGUI

Return Value

Remarks

See Also

AptifyPostalCode Class | Aptify.Framework.BusinessLogic.Address Namespace | AptifyPostalCode.GetPostalCodeAreaCode Overload List


GetPostalCodeFromCityCounty Method

Aptify 5.0 Software Development Kit (SDK)

AptifyPostalCode.GetPostalCodeFromCityCounty Method

This function assumes the postal code is in the United States

Overload List

This function assumes the postal code is in the United States

public bool GetPostalCodeFromCityCounty(String,String,ref DataTable&);

public bool GetPostalCodeFromCityCounty(String,String,Int64,ref DataTable&);

public bool GetPostalCodeFromCityCounty(String,String,Int64,ref String&);

public bool GetPostalCodeFromCityCounty(String,String,String,ref DataTable&);

public bool GetPostalCodeFromCityCounty(String,String,String,ref String&);

This function assumes the postal code is in the United States

public bool GetPostalCodeFromCityCounty(String,String,ref String&);

See Also

AptifyPostalCode Class | Aptify.Framework.BusinessLogic.Address Namespace


AptifyPostalCode.GetPostalCodeFromCityCounty Method (String, String, DataTable&)

This function assumes the postal code is in the United States

public bool GetPostalCodeFromCityCounty(
String City,
String County,
ref DataTable& PostalCodeTable
);

Parameters

City
County
PostalCodeTable

Return Value

Remarks

See Also

AptifyPostalCode Class | Aptify.Framework.BusinessLogic.Address Namespace | AptifyPostalCode.GetPostalCodeFromCityCounty Overload List


AptifyPostalCode.GetPostalCodeFromCityCounty Method (String, String, Int64, DataTable&)

public bool GetPostalCodeFromCityCounty(
String City,
String County,
Int64 AptifyCountryCodeID,
ref DataTable& PostalCodeTable
);

See Also

AptifyPostalCode Class | Aptify.Framework.BusinessLogic.Address Namespace | AptifyPostalCode.GetPostalCodeFromCityCounty Overload List


AptifyPostalCode.GetPostalCodeFromCityCounty Method (String, String, Int64, String&)

public bool GetPostalCodeFromCityCounty(
String City,
String County,
Int64 AptifyCountryCodeID,
ref String& PostalCode
);

See Also

AptifyPostalCode Class | Aptify.Framework.BusinessLogic.Address Namespace | AptifyPostalCode.GetPostalCodeFromCityCounty Overload List


AptifyPostalCode.GetPostalCodeFromCityCounty Method (String, String, String, DataTable&)

public bool GetPostalCodeFromCityCounty(
String City,
String County,
String ISOCountryCode,
ref DataTable& PostalCodeTable
);

See Also

AptifyPostalCode Class | Aptify.Framework.BusinessLogic.Address Namespace | AptifyPostalCode.GetPostalCodeFromCityCounty Overload List


AptifyPostalCode.GetPostalCodeFromCityCounty Method (String, String, String, String&)

public bool GetPostalCodeFromCityCounty(
String City,
String County,
String ISOCountryCode,
ref String& PostalCode
);

See Also

AptifyPostalCode Class | Aptify.Framework.BusinessLogic.Address Namespace | AptifyPostalCode.GetPostalCodeFromCityCounty Overload List


AptifyPostalCode.GetPostalCodeFromCityCounty Method (String, String, String&)

This function assumes the postal code is in the United States

public bool GetPostalCodeFromCityCounty(
String City,
String County,
ref String& PostalCode
);

Parameters

City
County
PostalCode

Return Value

Remarks

See Also

AptifyPostalCode Class | Aptify.Framework.BusinessLogic.Address Namespace | AptifyPostalCode.GetPostalCodeFromCityCounty Overload List


GetPostalCodeFromCityStateProvince Method

Aptify 5.0 Software Development Kit (SDK)

AptifyPostalCode.GetPostalCodeFromCityStateProvince Method

This function assumes the postal code is in the United States

Overload List

This function assumes the postal code is in the United States

public bool GetPostalCodeFromCityStateProvince(String,String,ref DataTable&);

public bool GetPostalCodeFromCityStateProvince(String,String,Int64,ref DataTable&);

public bool GetPostalCodeFromCityStateProvince(String,String,Int64,ref String&);

public bool GetPostalCodeFromCityStateProvince(String,String,String,ref DataTable&);

public bool GetPostalCodeFromCityStateProvince(String,String,String,ref String&);

This function assumes the postal code is in the United States

public bool GetPostalCodeFromCityStateProvince(String,String,ref String&);

See Also

AptifyPostalCode Class | Aptify.Framework.BusinessLogic.Address Namespace


AptifyPostalCode.GetPostalCodeFromCityStateProvince Method (String, String, DataTable&)

This function assumes the postal code is in the United States

public bool GetPostalCodeFromCityStateProvince(
String City,
String StateProvince,
ref DataTable& PostalCodeTable
);

Parameters

City
StateProvince
PostalCodeTable

Return Value

Remarks

See Also

AptifyPostalCode Class | Aptify.Framework.BusinessLogic.Address Namespace | AptifyPostalCode.GetPostalCodeFromCityStateProvince Overload List


AptifyPostalCode.GetPostalCodeFromCityStateProvince Method (String, String, Int64, DataTable&)

public bool GetPostalCodeFromCityStateProvince(
String City,
String StateProvince,
Int64 AptifyCountryCodeID,
ref DataTable& PostalCodeTable
);

See Also

AptifyPostalCode Class | Aptify.Framework.BusinessLogic.Address Namespace | AptifyPostalCode.GetPostalCodeFromCityStateProvince Overload List


AptifyPostalCode.GetPostalCodeFromCityStateProvince Method (String, String, Int64, String&)

public bool GetPostalCodeFromCityStateProvince(
String City,
String StateProvince,
Int64 AptifyCountryCodeID,
ref String& PostalCode
);

See Also

AptifyPostalCode Class | Aptify.Framework.BusinessLogic.Address Namespace | AptifyPostalCode.GetPostalCodeFromCityStateProvince Overload List


AptifyPostalCode.GetPostalCodeFromCityStateProvince Method (String, String, String, DataTable&)

public bool GetPostalCodeFromCityStateProvince(
String City,
String StateProvince,
String ISOCountryCode,
ref DataTable& PostalCodeTable
);

See Also

AptifyPostalCode Class | Aptify.Framework.BusinessLogic.Address Namespace | AptifyPostalCode.GetPostalCodeFromCityStateProvince Overload List


AptifyPostalCode.GetPostalCodeFromCityStateProvince Method (String, String, String, String&)

public bool GetPostalCodeFromCityStateProvince(
String City,
String StateProvince,
String ISOCountryCode,
ref String& PostalCode
);

See Also

AptifyPostalCode Class | Aptify.Framework.BusinessLogic.Address Namespace | AptifyPostalCode.GetPostalCodeFromCityStateProvince Overload List


AptifyPostalCode.GetPostalCodeFromCityStateProvince Method (String, String, String&)

This function assumes the postal code is in the United States

public bool GetPostalCodeFromCityStateProvince(
String City,
String StateProvince,
ref String& PostalCode
);

Parameters

City
StateProvince
PostalCode

Return Value

Remarks

See Also

AptifyPostalCode Class | Aptify.Framework.BusinessLogic.Address Namespace | AptifyPostalCode.GetPostalCodeFromCityStateProvince Overload List


GetPostalCodeFromCityStateProvinceCounty Method

Aptify 5.0 Software Development Kit (SDK)

AptifyPostalCode.GetPostalCodeFromCityStateProvinceCounty Method

Overload List

public bool GetPostalCodeFromCityStateProvinceCounty(String,String,String,ref DataTable&);

public bool GetPostalCodeFromCityStateProvinceCounty(String,String,String,Int64,ref DataTable&);

public bool GetPostalCodeFromCityStateProvinceCounty(String,String,String,Int64,ref String&);

public bool GetPostalCodeFromCityStateProvinceCounty(String,String,String,String,ref DataTable&);

public bool GetPostalCodeFromCityStateProvinceCounty(String,String,String,String,ref String&);

This function assumes the postal code is in the United States

public bool GetPostalCodeFromCityStateProvinceCounty(String,String,String,ref String&);

See Also

AptifyPostalCode Class | Aptify.Framework.BusinessLogic.Address Namespace


AptifyPostalCode.GetPostalCodeFromCityStateProvinceCounty Method (String, String, String, DataTable&)

public bool GetPostalCodeFromCityStateProvinceCounty(
String City,
String StateProvince,
String County,
ref DataTable& PostalCodeTable
);

See Also

AptifyPostalCode Class | Aptify.Framework.BusinessLogic.Address Namespace | AptifyPostalCode.GetPostalCodeFromCityStateProvinceCounty Overload List


AptifyPostalCode.GetPostalCodeFromCityStateProvinceCounty Method (String, String, String, Int64, DataTable&)

public bool GetPostalCodeFromCityStateProvinceCounty(
String City,
String StateProvince,
String County,
Int64 AptifyCountryCodeID,
ref DataTable& PostalCodeTable
);

See Also

AptifyPostalCode Class | Aptify.Framework.BusinessLogic.Address Namespace | AptifyPostalCode.GetPostalCodeFromCityStateProvinceCounty Overload List


AptifyPostalCode.GetPostalCodeFromCityStateProvinceCounty Method (String, String, String, Int64, String&)

public bool GetPostalCodeFromCityStateProvinceCounty(
String City,
String StateProvince,
String County,
Int64 AptifyCountryCodeID,
ref String& PostalCode
);

See Also

AptifyPostalCode Class | Aptify.Framework.BusinessLogic.Address Namespace | AptifyPostalCode.GetPostalCodeFromCityStateProvinceCounty Overload List


AptifyPostalCode.GetPostalCodeFromCityStateProvinceCounty Method (String, String, String, String, DataTable&)

public bool GetPostalCodeFromCityStateProvinceCounty(
String City,
String StateProvince,
String County,
String ISOCountryCode,
ref DataTable& PostalCodeTable
);

See Also

AptifyPostalCode Class | Aptify.Framework.BusinessLogic.Address Namespace | AptifyPostalCode.GetPostalCodeFromCityStateProvinceCounty Overload List


AptifyPostalCode.GetPostalCodeFromCityStateProvinceCounty Method (String, String, String, String, String&)

public bool GetPostalCodeFromCityStateProvinceCounty(
String City,
String StateProvince,
String County,
String ISOCountryCode,
ref String& PostalCode
);

See Also

AptifyPostalCode Class | Aptify.Framework.BusinessLogic.Address Namespace | AptifyPostalCode.GetPostalCodeFromCityStateProvinceCounty Overload List


AptifyPostalCode.GetPostalCodeFromCityStateProvinceCounty Method (String, String, String, String&)

This function assumes the postal code is in the United States

public bool GetPostalCodeFromCityStateProvinceCounty(
String City,
String StateProvince,
String County,
ref String& PostalCode
);

Parameters

City
StateProvince
County
PostalCode

Return Value

Remarks

See Also

AptifyPostalCode Class | Aptify.Framework.BusinessLogic.Address Namespace | AptifyPostalCode.GetPostalCodeFromCityStateProvinceCounty Overload List


GetPostalCodeInfo Method

Aptify 5.0 Software Development Kit (SDK)

AptifyPostalCode.GetPostalCodeInfo Method

Overload List

public bool GetPostalCodeInfo(ref String&,ref Int64&,ref String&,ref String&,ref String&,ref String&,ref String&,ref String&,ref String&,ref String&,ref String&,ref String&,ref String&,ref String&,ref String&,ref String&,Boolean,IAptifyPostalCodeMultipleSelectGUI);

public bool GetPostalCodeInfo(ref String&,ref String&,ref String&,ref String&,ref String&,ref String&,ref String&,ref String&,ref String&,ref String&,ref String&,ref String&,ref String&,ref String&,ref String&,ref String&,Boolean,IAptifyPostalCodeMultipleSelectGUI);

See Also

AptifyPostalCode Class | Aptify.Framework.BusinessLogic.Address Namespace


AptifyPostalCode.GetPostalCodeInfo Method (String&, Int64&, String&, String&, String&, String&, String&, String&, String&, String&, String&, String&, String&, String&, String&, String&, Boolean, IAptifyPostalCodeMultipleSelectGUI)

public bool GetPostalCodeInfo(
ref String& PostalCode,
ref Int64& AptifyCountryCodeID,
ref String& City,
ref String& StateProvince,
ref String& AreaCode,
ref String& FIPSCode,
ref String& County,
ref String& Pref,
ref String& TimeZone,
ref String& DST,
ref String& Latitude,
ref String& Longitude,
ref String& MSA,
ref String& PMSA,
ref String& CongDist,
ref String& Country,
Boolean AllowGUI,
IAptifyPostalCodeMultipleSelectGUI PostalCodeSelectGUI
);

See Also

AptifyPostalCode Class | Aptify.Framework.BusinessLogic.Address Namespace | AptifyPostalCode.GetPostalCodeInfo Overload List


AptifyPostalCode.GetPostalCodeInfo Method (String&, String&, String&, String&, String&, String&, String&, String&, String&, String&, String&, String&, String&, String&, String&, String&, Boolean, IAptifyPostalCodeMultipleSelectGUI)

public bool GetPostalCodeInfo(
ref String& PostalCode,
ref String& ISOCountryCode,
ref String& City,
ref String& StateProvince,
ref String& AreaCode,
ref String& FIPSCode,
ref String& County,
ref String& Pref,
ref String& TimeZone,
ref String& DST,
ref String& Latitude,
ref String& Longitude,
ref String& MSA,
ref String& PMSA,
ref String& CongDist,
ref String& Country,
Boolean AllowGUI,
IAptifyPostalCodeMultipleSelectGUI PostalCodeSelectGUI
);

See Also

AptifyPostalCode Class | Aptify.Framework.BusinessLogic.Address Namespace | AptifyPostalCode.GetPostalCodeInfo Overload List


AptifyQuickAddress Class

For a list of all members of this type, see AptifyQuickAddress Members.

System.Object
GenericAddressDriver
AptifyQuickAddress

public class AptifyQuickAddress : GenericAddressDriver

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.Address

Assembly: AptifyAddressDrivers (in AptifyAddressDrivers.dll)

See Also

AptifyQuickAddress Members | Aptify.Framework.BusinessLogic.Address Namespace


AptifyQuickAddress Members

AptifyQuickAddress overview

Public Instance Constructors

AptifyQuickAddress Constructor Initializes a new instance of the AptifyQuickAddress class.

Public Instance Properties

Application (inherited from GenericAddressDriver) |
AttributesDataTable (inherited from GenericAddressDriver) | Returns a list of Configuration Attributes for the current address verification system
DataAction (inherited from GenericAddressDriver) |
ProgressUpdateInterval (inherited from GenericAddressDriver) |
VerificationSystemID (inherited from GenericAddressDriver) | Returns the verification system ID value passed into Config()

Public Instance Methods

Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
LoadDriverConfigAttributes (inherited from GenericAddressDriver) | Responsibile for loading the driver configuration attributes. Automatically called the first time GetDriverConfigAttribute() is called
ToString (inherited from Object) | Returns a String that represents the current Object.
VerifyAddressBatch (inherited from GenericAddressDriver) | Overloaded.
VerifyMultipleAddresses (inherited from GenericAddressDriver) | Overloaded.
VerifySingleAddress | Overloaded.
VerifySingleAddress (inherited from GenericAddressDriver) | Overloaded.

Public Instance Events

ProgressUpdate (inherited from GenericAddressDriver)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetDriverConfigAttribute (inherited from GenericAddressDriver) | Overloaded. This method is responsible for going through the rows in the data table and finding the attribute by the name of AttributeName and returning the associated value, if found. If not found, DefaultValue is returned.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyQuickAddress Class | Aptify.Framework.BusinessLogic.Address Namespace


AptifyQuickAddress Constructor

Initializes a new instance of the AptifyQuickAddress class.

public AptifyQuickAddress();

See Also

AptifyQuickAddress Class | Aptify.Framework.BusinessLogic.Address Namespace


AptifyQuickAddress Methods

The methods of the AptifyQuickAddress class are listed below. For a complete list of AptifyQuickAddress class members, see the AptifyQuickAddress Members topic.

Public Instance Methods

Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
LoadDriverConfigAttributes (inherited from GenericAddressDriver) | Responsibile for loading the driver configuration attributes. Automatically called the first time GetDriverConfigAttribute() is called
ToString (inherited from Object) | Returns a String that represents the current Object.
VerifyAddressBatch (inherited from GenericAddressDriver) | Overloaded.
VerifyMultipleAddresses (inherited from GenericAddressDriver) | Overloaded.
VerifySingleAddress | Overloaded.
VerifySingleAddress (inherited from GenericAddressDriver) | Overloaded.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetDriverConfigAttribute (inherited from GenericAddressDriver) | Overloaded. This method is responsible for going through the rows in the data table and finding the attribute by the name of AttributeName and returning the associated value, if found. If not found, DefaultValue is returned.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyQuickAddress Class | Aptify.Framework.BusinessLogic.Address Namespace


AptifyQuickAddress.Config Method

public override bool Config(
AptifyApplication AptifyApplication,
Int64 VerificationSystemID
);

Implements

IAptifyAddressBatchVerify.

See Also

AptifyQuickAddress Class | Aptify.Framework.BusinessLogic.Address Namespace


VerifySingleAddress Method

Aptify 5.0 Software Development Kit (SDK)

AptifyQuickAddress.VerifySingleAddress Method

Overload List

Inherited from GenericAddressDriver.

public virtual AddressVerifyResult VerifySingleAddress(AddressInfo);

public override AddressVerifyResult VerifySingleAddress(AddressInfo,ref String&);

See Also

AptifyQuickAddress Class | Aptify.Framework.BusinessLogic.Address Namespace


AptifyQuickAddress.VerifySingleAddress Method (AddressInfo, String&)

public override AddressVerifyResult VerifySingleAddress(
AddressInfo Address,
ref String& ErrorString
);

Implements

IAptifyAddressVerify.

See Also

AptifyQuickAddress Class | Aptify.Framework.BusinessLogic.Address Namespace | AptifyQuickAddress.VerifySingleAddress Overload List


Constants Class

For a list of all members of this type, see Constants Members.

System.Object
Constants

public class Constants

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.Address

Assembly: AptifyAddressInterface (in AptifyAddressInterface.dll)

See Also

Constants Members | Aptify.Framework.BusinessLogic.Address Namespace


Constants Members

Constants overview

Public Static Fields

POSTAL_CODE_NO_MATCH_CITY_STATE

Public Static Properties

PostalCodeNoMatchCityStateMessage

Public Static Methods

GetResourceString

Public Instance Constructors

Constants Constructor Initializes a new instance of the Constants class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Constants Class | Aptify.Framework.BusinessLogic.Address Namespace


Constants Constructor

Initializes a new instance of the Constants class.

public Constants();

See Also

Constants Class | Aptify.Framework.BusinessLogic.Address Namespace


Constants Fields

The fields of the Constants class are listed below. For a complete list of Constants class members, see the Constants Members topic.

Public Static Fields

POSTAL_CODE_NO_MATCH_CITY_STATE

See Also

Constants Class | Aptify.Framework.BusinessLogic.Address Namespace


Constants.POSTAL_CODE_NO_MATCH_CITY_STATE Field

public const POSTAL_CODE_NO_MATCH_CITY_STATE POSTAL_CODE_NO_MATCH_CITY_STATE = "POSTAL_CODE_NO_MATCH_CITY_STATE";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Address Namespace


Constants Properties

The properties of the Constants class are listed below. For a complete list of Constants class members, see the Constants Members topic.

Public Static Properties

PostalCodeNoMatchCityStateMessage

See Also

Constants Class | Aptify.Framework.BusinessLogic.Address Namespace


PostalCodeNoMatchCityStateMessage Property

Aptify 5.0 Software Development Kit (SDK)

Constants.PostalCodeNoMatchCityStateMessage Property

public static String this[
String City,
String State
] {get;}

See Also

Constants Class | Aptify.Framework.BusinessLogic.Address Namespace


Constants Methods

The methods of the Constants class are listed below. For a complete list of Constants class members, see the Constants Members topic.

Public Static Methods

GetResourceString

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Constants Class | Aptify.Framework.BusinessLogic.Address Namespace


Constants.GetResourceString Method

public static string GetResourceString(
String ResourceKey
);

See Also

Constants Class | Aptify.Framework.BusinessLogic.Address Namespace


GenericAddressDriver Class

For a list of all members of this type, see GenericAddressDriver Members.

System.Object
GenericAddressDriver
AptifyAccumailDriver
AptifyMelissaData
AptifyQuickAddress

public class GenericAddressDriver : IAptifyAddressVerify, IAptifyAddressBatchVerify

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.Address

Assembly: AptifyAddressDrivers (in AptifyAddressDrivers.dll)

See Also

GenericAddressDriver Members | Aptify.Framework.BusinessLogic.Address Namespace


GenericAddressDriver Members

GenericAddressDriver overview

Public Instance Constructors

GenericAddressDriver Constructor Initializes a new instance of the GenericAddressDriver class.

Public Instance Properties

Application |
AttributesDataTable | Returns a list of Configuration Attributes for the current address verification system
DataAction |
ProgressUpdateInterval |
VerificationSystemID | Returns the verification system ID value passed into Config()

Public Instance Methods

Config | Configures the object for processing
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
LoadDriverConfigAttributes | Responsibile for loading the driver configuration attributes. Automatically called the first time GetDriverConfigAttribute() is called
ToString (inherited from Object) | Returns a String that represents the current Object.
VerifyAddressBatch | Overloaded.
VerifyMultipleAddresses | Overloaded.
VerifySingleAddress | Overloaded.

Public Instance Events

ProgressUpdate

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetDriverConfigAttribute | Overloaded. This method is responsible for going through the rows in the data table and finding the attribute by the name of AttributeName and returning the associated value, if found. If not found, DefaultValue is returned.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GenericAddressDriver Class | Aptify.Framework.BusinessLogic.Address Namespace


GenericAddressDriver Constructor

Initializes a new instance of the GenericAddressDriver class.

public GenericAddressDriver();

See Also

GenericAddressDriver Class | Aptify.Framework.BusinessLogic.Address Namespace


GenericAddressDriver Properties

The properties of the GenericAddressDriver class are listed below. For a complete list of GenericAddressDriver class members, see the GenericAddressDriver Members topic.

Public Instance Properties

Application |
AttributesDataTable | Returns a list of Configuration Attributes for the current address verification system
DataAction |
ProgressUpdateInterval |
VerificationSystemID | Returns the verification system ID value passed into Config()

See Also

GenericAddressDriver Class | Aptify.Framework.BusinessLogic.Address Namespace


Application Property

Aptify 5.0 Software Development Kit (SDK)

GenericAddressDriver.Application Property

public virtual AptifyApplication Application {get;}

See Also

GenericAddressDriver Class | Aptify.Framework.BusinessLogic.Address Namespace


AttributesDataTable Property

Aptify 5.0 Software Development Kit (SDK)

GenericAddressDriver.AttributesDataTable Property

Returns a list of Configuration Attributes for the current address verification system

public virtual DataTable AttributesDataTable {get;}

Property Value

Remarks

See Also

GenericAddressDriver Class | Aptify.Framework.BusinessLogic.Address Namespace


DataAction Property

Aptify 5.0 Software Development Kit (SDK)

GenericAddressDriver.DataAction Property

public virtual DataAction DataAction {get;}

See Also

GenericAddressDriver Class | Aptify.Framework.BusinessLogic.Address Namespace


ProgressUpdateInterval Property

Aptify 5.0 Software Development Kit (SDK)

GenericAddressDriver.ProgressUpdateInterval Property

public Int32 ProgressUpdateInterval {get; set;}

Implements

IAptifyAddressBatchVerify.

See Also

GenericAddressDriver Class | Aptify.Framework.BusinessLogic.Address Namespace


VerificationSystemID Property

Aptify 5.0 Software Development Kit (SDK)

GenericAddressDriver.VerificationSystemID Property

Returns the verification system ID value passed into Config()

public virtual Int64 VerificationSystemID {get;}

Property Value

Remarks

See Also

GenericAddressDriver Class | Aptify.Framework.BusinessLogic.Address Namespace | Config()


GenericAddressDriver Methods

The methods of the GenericAddressDriver class are listed below. For a complete list of GenericAddressDriver class members, see the GenericAddressDriver Members topic.

Public Instance Methods

Config | Configures the object for processing
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
LoadDriverConfigAttributes | Responsibile for loading the driver configuration attributes. Automatically called the first time GetDriverConfigAttribute() is called
ToString (inherited from Object) | Returns a String that represents the current Object.
VerifyAddressBatch | Overloaded.
VerifyMultipleAddresses | Overloaded.
VerifySingleAddress | Overloaded.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetDriverConfigAttribute | Overloaded. This method is responsible for going through the rows in the data table and finding the attribute by the name of AttributeName and returning the associated value, if found. If not found, DefaultValue is returned.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GenericAddressDriver Class | Aptify.Framework.BusinessLogic.Address Namespace


GenericAddressDriver.Config Method

Configures the object for processing

public virtual bool Config(
AptifyApplication AptifyApplication,
Int64 VerificationSystemID
);

Parameters

AptifyApplication
VerificationSystemID

Return Value

Implements

IAptifyAddressBatchVerify.

Remarks

See Also

GenericAddressDriver Class | Aptify.Framework.BusinessLogic.Address Namespace


GetDriverConfigAttribute Method

Aptify 5.0 Software Development Kit (SDK)

GenericAddressDriver.GetDriverConfigAttribute Method

This method is responsible for going through the rows in the data table and finding the attribute by the name of AttributeName and returning the associated value, if found. If not found, DefaultValue is returned.

Overload List

This method is responsible for going through the rows in the data table and finding the attribute by the name of AttributeName and returning the associated value, if found. If not found, DefaultValue is returned.

protected virtual bool GetDriverConfigAttribute(String,Boolean);

This method is responsible for going through the rows in the data table and finding the attribute by the name of AttributeName and returning the associated value, if found. If not found, DefaultValue is returned.

protected virtual string GetDriverConfigAttribute(String,String);

See Also

GenericAddressDriver Class | Aptify.Framework.BusinessLogic.Address Namespace


GenericAddressDriver.GetDriverConfigAttribute Method (String, Boolean)

This method is responsible for going through the rows in the data table and finding the attribute by the name of AttributeName and returning the associated value, if found. If not found, DefaultValue is returned.

protected virtual bool GetDriverConfigAttribute(
String AttributeName,
Boolean DefaultValue
);

Parameters

AttributeName
DefaultValue

Return Value

Remarks

See Also

GenericAddressDriver Class | Aptify.Framework.BusinessLogic.Address Namespace | GenericAddressDriver.GetDriverConfigAttribute Overload List


GenericAddressDriver.GetDriverConfigAttribute Method (String, String)

This method is responsible for going through the rows in the data table and finding the attribute by the name of AttributeName and returning the associated value, if found. If not found, DefaultValue is returned.

protected virtual string GetDriverConfigAttribute(
String AttributeName,
String DefaultValue
);

Parameters

AttributeName
DefaultValue

Return Value

Remarks

See Also

GenericAddressDriver Class | Aptify.Framework.BusinessLogic.Address Namespace | GenericAddressDriver.GetDriverConfigAttribute Overload List


GenericAddressDriver.LoadDriverConfigAttributes Method

Responsibile for loading the driver configuration attributes. Automatically called the first time GetDriverConfigAttribute() is called

public virtual void LoadDriverConfigAttributes(
Boolean RefreshCache
);

Remarks

See Also

GenericAddressDriver Class | Aptify.Framework.BusinessLogic.Address Namespace


VerifyAddressBatch Method

Aptify 5.0 Software Development Kit (SDK)

GenericAddressDriver.VerifyAddressBatch Method

Overload List

public virtual void VerifyAddressBatch(AddressBatchVerifyMode,ArrayList);

public virtual void VerifyAddressBatch(AddressBatchVerifyMode,Int64);

public virtual void VerifyAddressBatch(AddressBatchVerifyMode,Int64[]);

public virtual void VerifyAddressBatch(AddressBatchVerifyMode,String);

See Also

GenericAddressDriver Class | Aptify.Framework.BusinessLogic.Address Namespace


GenericAddressDriver.VerifyAddressBatch Method (AddressBatchVerifyMode, ArrayList)

public virtual void VerifyAddressBatch(
AddressBatchVerifyMode Mode,
ArrayList IDArray
);

Implements

IAptifyAddressBatchVerify.

See Also

GenericAddressDriver Class | Aptify.Framework.BusinessLogic.Address Namespace | GenericAddressDriver.VerifyAddressBatch Overload List


GenericAddressDriver.VerifyAddressBatch Method (AddressBatchVerifyMode, Int64)

public virtual void VerifyAddressBatch(
AddressBatchVerifyMode Mode,
Int64 AptifyListID
);

Implements

IAptifyAddressBatchVerify.

See Also

GenericAddressDriver Class | Aptify.Framework.BusinessLogic.Address Namespace | GenericAddressDriver.VerifyAddressBatch Overload List


GenericAddressDriver.VerifyAddressBatch Method (AddressBatchVerifyMode, Int64[])

public virtual void VerifyAddressBatch(
AddressBatchVerifyMode Mode,
Int64[] IDArray
);

Implements

IAptifyAddressBatchVerify.

See Also

GenericAddressDriver Class | Aptify.Framework.BusinessLogic.Address Namespace | GenericAddressDriver.VerifyAddressBatch Overload List


GenericAddressDriver.VerifyAddressBatch Method (AddressBatchVerifyMode, String)

public virtual void VerifyAddressBatch(
AddressBatchVerifyMode Mode,
String AddressSQL
);

Implements

IAptifyAddressBatchVerify.

See Also

GenericAddressDriver Class | Aptify.Framework.BusinessLogic.Address Namespace | GenericAddressDriver.VerifyAddressBatch Overload List


VerifyMultipleAddresses Method

Aptify 5.0 Software Development Kit (SDK)

GenericAddressDriver.VerifyMultipleAddresses Method

Overload List

public virtual AddressVerifyResult[] VerifyMultipleAddresses(AddressInfoCollection);

public virtual AddressVerifyResult[] VerifyMultipleAddresses(AddressInfoCollection,ref String[]&);

See Also

GenericAddressDriver Class | Aptify.Framework.BusinessLogic.Address Namespace


GenericAddressDriver.VerifyMultipleAddresses Method (AddressInfoCollection)

public virtual AddressVerifyResult[] VerifyMultipleAddresses(
AddressInfoCollection AddressCollection
);

Implements

IAptifyAddressVerify.

See Also

GenericAddressDriver Class | Aptify.Framework.BusinessLogic.Address Namespace | GenericAddressDriver.VerifyMultipleAddresses Overload List


GenericAddressDriver.VerifyMultipleAddresses Method (AddressInfoCollection, String[]&)

public virtual AddressVerifyResult[] VerifyMultipleAddresses(
AddressInfoCollection AddressCollection,
ref String[]& ErrorString
);

Implements

IAptifyAddressVerify.

See Also

GenericAddressDriver Class | Aptify.Framework.BusinessLogic.Address Namespace | GenericAddressDriver.VerifyMultipleAddresses Overload List


VerifySingleAddress Method

Aptify 5.0 Software Development Kit (SDK)

GenericAddressDriver.VerifySingleAddress Method

Overload List

public virtual AddressVerifyResult VerifySingleAddress(AddressInfo);

public abstract AddressVerifyResult VerifySingleAddress(AddressInfo,ref String&);

See Also

GenericAddressDriver Class | Aptify.Framework.BusinessLogic.Address Namespace


GenericAddressDriver.VerifySingleAddress Method (AddressInfo)

public virtual AddressVerifyResult VerifySingleAddress(
AddressInfo Address
);

Implements

IAptifyAddressVerify.

See Also

GenericAddressDriver Class | Aptify.Framework.BusinessLogic.Address Namespace | GenericAddressDriver.VerifySingleAddress Overload List


GenericAddressDriver.VerifySingleAddress Method (AddressInfo, String&)

public abstract AddressVerifyResult VerifySingleAddress(
AddressInfo Address,
ref String& ErrorString
);

Implements

IAptifyAddressVerify.

See Also

GenericAddressDriver Class | Aptify.Framework.BusinessLogic.Address Namespace | GenericAddressDriver.VerifySingleAddress Overload List


GenericAddressDriver Events

The events of the GenericAddressDriver class are listed below. For a complete list of GenericAddressDriver class members, see the GenericAddressDriver Members topic.

Public Instance Events

ProgressUpdate

See Also

GenericAddressDriver Class | Aptify.Framework.BusinessLogic.Address Namespace


GenericAddressDriver.IAptifyAddressBatchVerify.ProgressUpdateEventHandler Event

public event IAptifyAddressBatchVerify.ProgressUpdateEventHandler ProgressUpdate;

Implements

IAptifyAddressBatchVerify.

See Also

GenericAddressDriver Class | Aptify.Framework.BusinessLogic.Address Namespace


IAptifyAddressBatchVerify Interface

For a list of all members of this type, see IAptifyAddressBatchVerify Members.

public interface IAptifyAddressBatchVerify

Types that implement IAptifyAddressBatchVerify

Type | Description
AptifyAccumailDriver | Aptify Implemention of IAptifyAddressVerify/IAptifyAddressBatchVerify for integration with Accumail
AptifyMelissaData |
AptifyQuickAddress |
GenericAddressDriver |

Requirements

Namespace: Aptify.Framework.BusinessLogic.Address

Assembly: AptifyAddressInterface (in AptifyAddressInterface.dll)

See Also

IAptifyAddressBatchVerify Members | Aptify.Framework.BusinessLogic.Address Namespace


IAptifyAddressBatchVerify Members

IAptifyAddressBatchVerify overview

Public Instance Properties

ProgressUpdateInterval

Public Instance Methods

Config |
VerifyAddressBatch | Overloaded.

Public Instance Events

ProgressUpdate

See Also

IAptifyAddressBatchVerify Interface | Aptify.Framework.BusinessLogic.Address Namespace


IAptifyAddressBatchVerify Properties

The properties of the IAptifyAddressBatchVerify interface are listed below. For a complete list of IAptifyAddressBatchVerify interface members, see the IAptifyAddressBatchVerify Members topic.

Public Instance Properties

ProgressUpdateInterval

See Also

IAptifyAddressBatchVerify Interface | Aptify.Framework.BusinessLogic.Address Namespace


ProgressUpdateInterval Property

Aptify 5.0 Software Development Kit (SDK)

IAptifyAddressBatchVerify.ProgressUpdateInterval Property

Int32 ProgressUpdateInterval {get; set;}

See Also

IAptifyAddressBatchVerify Interface | Aptify.Framework.BusinessLogic.Address Namespace


IAptifyAddressBatchVerify Methods

The methods of the IAptifyAddressBatchVerify interface are listed below. For a complete list of IAptifyAddressBatchVerify interface members, see the IAptifyAddressBatchVerify Members topic.

Public Instance Methods

Config |
VerifyAddressBatch | Overloaded.

See Also

IAptifyAddressBatchVerify Interface | Aptify.Framework.BusinessLogic.Address Namespace


IAptifyAddressBatchVerify.Config Method

bool Config(
AptifyApplication AptifyApplication,
Int64 VerificationSystemID
);

See Also

IAptifyAddressBatchVerify Interface | Aptify.Framework.BusinessLogic.Address Namespace


VerifyAddressBatch Method

Aptify 5.0 Software Development Kit (SDK)

IAptifyAddressBatchVerify.VerifyAddressBatch Method

Overload List

void VerifyAddressBatch(AddressBatchVerifyMode,ArrayList);

void VerifyAddressBatch(AddressBatchVerifyMode,Int64);

void VerifyAddressBatch(AddressBatchVerifyMode,Int64[]);

void VerifyAddressBatch(AddressBatchVerifyMode,String);

See Also

IAptifyAddressBatchVerify Interface | Aptify.Framework.BusinessLogic.Address Namespace


IAptifyAddressBatchVerify.VerifyAddressBatch Method (AddressBatchVerifyMode, ArrayList)

void VerifyAddressBatch(
AddressBatchVerifyMode Mode,
ArrayList IDArray
);

See Also

IAptifyAddressBatchVerify Interface | Aptify.Framework.BusinessLogic.Address Namespace | IAptifyAddressBatchVerify.VerifyAddressBatch Overload List


IAptifyAddressBatchVerify.VerifyAddressBatch Method (AddressBatchVerifyMode, Int64)

void VerifyAddressBatch(
AddressBatchVerifyMode Mode,
Int64 AptifyListID
);

See Also

IAptifyAddressBatchVerify Interface | Aptify.Framework.BusinessLogic.Address Namespace | IAptifyAddressBatchVerify.VerifyAddressBatch Overload List


IAptifyAddressBatchVerify.VerifyAddressBatch Method (AddressBatchVerifyMode, Int64[])

void VerifyAddressBatch(
AddressBatchVerifyMode Mode,
Int64[] IDArray
);

See Also

IAptifyAddressBatchVerify Interface | Aptify.Framework.BusinessLogic.Address Namespace | IAptifyAddressBatchVerify.VerifyAddressBatch Overload List


IAptifyAddressBatchVerify.VerifyAddressBatch Method (AddressBatchVerifyMode, String)

void VerifyAddressBatch(
AddressBatchVerifyMode Mode,
String AddressSQL
);

See Also

IAptifyAddressBatchVerify Interface | Aptify.Framework.BusinessLogic.Address Namespace | IAptifyAddressBatchVerify.VerifyAddressBatch Overload List


IAptifyAddressBatchVerify Events

The events of the IAptifyAddressBatchVerify interface are listed below. For a complete list of IAptifyAddressBatchVerify interface members, see the IAptifyAddressBatchVerify Members topic.

Public Instance Events

ProgressUpdate

See Also

IAptifyAddressBatchVerify Interface | Aptify.Framework.BusinessLogic.Address Namespace


IAptifyAddressBatchVerify.IAptifyAddressBatchVerify.ProgressUpdateEventHandler Event

event IAptifyAddressBatchVerify.ProgressUpdateEventHandler ProgressUpdate;

See Also

IAptifyAddressBatchVerify Interface | Aptify.Framework.BusinessLogic.Address Namespace


IAptifyAddressBatchVerify.ProgressUpdateEventHandler Delegate

public delegate void IAptifyAddressBatchVerify.ProgressUpdateEventHandler(
Int32 RecordsProcessed,
Int32 RecordsLeft,
ref Boolean& CancelOperation
);

Requirements

Namespace: Aptify.Framework.BusinessLogic.Address

Assembly: AptifyAddressInterface (in AptifyAddressInterface.dll)

See Also

Aptify.Framework.BusinessLogic.Address Namespace


IAptifyAddressVerify Interface

For a list of all members of this type, see IAptifyAddressVerify Members.

public interface IAptifyAddressVerify

Types that implement IAptifyAddressVerify

Type | Description
AptifyAccumailDriver | Aptify Implemention of IAptifyAddressVerify/IAptifyAddressBatchVerify for integration with Accumail
AptifyMelissaData |
AptifyQuickAddress |
GenericAddressDriver |

Requirements

Namespace: Aptify.Framework.BusinessLogic.Address

Assembly: AptifyAddressInterface (in AptifyAddressInterface.dll)

See Also

IAptifyAddressVerify Members | Aptify.Framework.BusinessLogic.Address Namespace


IAptifyAddressVerify Members

IAptifyAddressVerify overview

Public Instance Methods

Config |
VerifyMultipleAddresses | Overloaded.
VerifySingleAddress | Overloaded.

See Also

IAptifyAddressVerify Interface | Aptify.Framework.BusinessLogic.Address Namespace


IAptifyAddressVerify Methods

The methods of the IAptifyAddressVerify interface are listed below. For a complete list of IAptifyAddressVerify interface members, see the IAptifyAddressVerify Members topic.

Public Instance Methods

Config |
VerifyMultipleAddresses | Overloaded.
VerifySingleAddress | Overloaded.

See Also

IAptifyAddressVerify Interface | Aptify.Framework.BusinessLogic.Address Namespace


IAptifyAddressVerify.Config Method

bool Config(
AptifyApplication AptifyApplication,
Int64 VerificationSystemID
);

See Also

IAptifyAddressVerify Interface | Aptify.Framework.BusinessLogic.Address Namespace


VerifyMultipleAddresses Method

Aptify 5.0 Software Development Kit (SDK)

IAptifyAddressVerify.VerifyMultipleAddresses Method

Overload List

AddressVerifyResult[] VerifyMultipleAddresses(AddressInfoCollection);

AddressVerifyResult[] VerifyMultipleAddresses(AddressInfoCollection,ref String[]&);

See Also

IAptifyAddressVerify Interface | Aptify.Framework.BusinessLogic.Address Namespace


IAptifyAddressVerify.VerifyMultipleAddresses Method (AddressInfoCollection)

AddressVerifyResult[] VerifyMultipleAddresses(
AddressInfoCollection AddressCollection
);

See Also

IAptifyAddressVerify Interface | Aptify.Framework.BusinessLogic.Address Namespace | IAptifyAddressVerify.VerifyMultipleAddresses Overload List


IAptifyAddressVerify.VerifyMultipleAddresses Method (AddressInfoCollection, String[]&)

AddressVerifyResult[] VerifyMultipleAddresses(
AddressInfoCollection AddressCollection,
ref String[]& ErrorMessage
);

See Also

IAptifyAddressVerify Interface | Aptify.Framework.BusinessLogic.Address Namespace | IAptifyAddressVerify.VerifyMultipleAddresses Overload List


VerifySingleAddress Method

Aptify 5.0 Software Development Kit (SDK)

IAptifyAddressVerify.VerifySingleAddress Method

Overload List

AddressVerifyResult VerifySingleAddress(AddressInfo);

AddressVerifyResult VerifySingleAddress(AddressInfo,ref String&);

See Also

IAptifyAddressVerify Interface | Aptify.Framework.BusinessLogic.Address Namespace


IAptifyAddressVerify.VerifySingleAddress Method (AddressInfo)

AddressVerifyResult VerifySingleAddress(
AddressInfo Address
);

See Also

IAptifyAddressVerify Interface | Aptify.Framework.BusinessLogic.Address Namespace | IAptifyAddressVerify.VerifySingleAddress Overload List


IAptifyAddressVerify.VerifySingleAddress Method (AddressInfo, String&)

AddressVerifyResult VerifySingleAddress(
AddressInfo Address,
ref String& ErrorMessage
);

See Also

IAptifyAddressVerify Interface | Aptify.Framework.BusinessLogic.Address Namespace | IAptifyAddressVerify.VerifySingleAddress Overload List


IAptifyAddressVerifyUI Interface

For a list of all members of this type, see IAptifyAddressVerifyUI Members.

public interface IAptifyAddressVerifyUI

Types that implement IAptifyAddressVerifyUI

Type | Description
AddressChangeSuggested |

Requirements

Namespace: Aptify.Framework.BusinessLogic.Address

Assembly: AptifyAddressInterface (in AptifyAddressInterface.dll)

See Also

IAptifyAddressVerifyUI Members | Aptify.Framework.BusinessLogic.Address Namespace


IAptifyAddressVerifyUI Members

IAptifyAddressVerifyUI overview

Public Instance Properties

AddressInfo

Public Instance Methods

ShowViewer

See Also

IAptifyAddressVerifyUI Interface | Aptify.Framework.BusinessLogic.Address Namespace


IAptifyAddressVerifyUI Properties

The properties of the IAptifyAddressVerifyUI interface are listed below. For a complete list of IAptifyAddressVerifyUI interface members, see the IAptifyAddressVerifyUI Members topic.

Public Instance Properties

AddressInfo

See Also

IAptifyAddressVerifyUI Interface | Aptify.Framework.BusinessLogic.Address Namespace


AddressInfo Property

Aptify 5.0 Software Development Kit (SDK)

IAptifyAddressVerifyUI.AddressInfo Property

AddressInfo AddressInfo {get; set;}

See Also

IAptifyAddressVerifyUI Interface | Aptify.Framework.BusinessLogic.Address Namespace


IAptifyAddressVerifyUI Methods

The methods of the IAptifyAddressVerifyUI interface are listed below. For a complete list of IAptifyAddressVerifyUI interface members, see the IAptifyAddressVerifyUI Members topic.

Public Instance Methods

ShowViewer

See Also

IAptifyAddressVerifyUI Interface | Aptify.Framework.BusinessLogic.Address Namespace


IAptifyAddressVerifyUI.ShowViewer Method

DialogResult ShowViewer();

See Also

IAptifyAddressVerifyUI Interface | Aptify.Framework.BusinessLogic.Address Namespace


IAptifyPostalCodeMultipleSelectGUI Interface

For a list of all members of this type, see IAptifyPostalCodeMultipleSelectGUI Members.

public interface IAptifyPostalCodeMultipleSelectGUI

Types that implement IAptifyPostalCodeMultipleSelectGUI

Type | Description
PostalCodeSelectForm |

Requirements

Namespace: Aptify.Framework.BusinessLogic.Address

Assembly: AptifyAddressInterface (in AptifyAddressInterface.dll)

See Also

IAptifyPostalCodeMultipleSelectGUI Members | Aptify.Framework.BusinessLogic.Address Namespace


IAptifyPostalCodeMultipleSelectGUI Members

IAptifyPostalCodeMultipleSelectGUI overview

Public Instance Properties

PostalCodesSourceTable
SelectedPostalCodeRow

Public Instance Methods

ShowDialog

See Also

IAptifyPostalCodeMultipleSelectGUI Interface | Aptify.Framework.BusinessLogic.Address Namespace


IAptifyPostalCodeMultipleSelectGUI Properties

The properties of the IAptifyPostalCodeMultipleSelectGUI interface are listed below. For a complete list of IAptifyPostalCodeMultipleSelectGUI interface members, see the IAptifyPostalCodeMultipleSelectGUI Members topic.

Public Instance Properties

PostalCodesSourceTable
SelectedPostalCodeRow

See Also

IAptifyPostalCodeMultipleSelectGUI Interface | Aptify.Framework.BusinessLogic.Address Namespace


PostalCodesSourceTable Property

Aptify 5.0 Software Development Kit (SDK)

IAptifyPostalCodeMultipleSelectGUI.PostalCodesSourceTable Property

DataTable PostalCodesSourceTable {get; set;}

See Also

IAptifyPostalCodeMultipleSelectGUI Interface | Aptify.Framework.BusinessLogic.Address Namespace


SelectedPostalCodeRow Property

Aptify 5.0 Software Development Kit (SDK)

IAptifyPostalCodeMultipleSelectGUI.SelectedPostalCodeRow Property

DataRow SelectedPostalCodeRow {get;}

See Also

IAptifyPostalCodeMultipleSelectGUI Interface | Aptify.Framework.BusinessLogic.Address Namespace


IAptifyPostalCodeMultipleSelectGUI Methods

The methods of the IAptifyPostalCodeMultipleSelectGUI interface are listed below. For a complete list of IAptifyPostalCodeMultipleSelectGUI interface members, see the IAptifyPostalCodeMultipleSelectGUI Members topic.

Public Instance Methods

ShowDialog

See Also

IAptifyPostalCodeMultipleSelectGUI Interface | Aptify.Framework.BusinessLogic.Address Namespace


IAptifyPostalCodeMultipleSelectGUI.ShowDialog Method

DialogResult ShowDialog();

See Also

IAptifyPostalCodeMultipleSelectGUI Interface | Aptify.Framework.BusinessLogic.Address Namespace


Aptify.Framework.BusinessLogic.Alerts

Aptify 5.0 Software Development Kit (SDK)

Aptify.Framework.BusinessLogic.Alerts Namespace

This namespace corresponds to Aptify's Alert system, which notifies users of events related to the current record, including any pending changes or conflicts. An Alerts icon appears in the Data Control Bar of all records by default.

Namespace hierarchy

Classes

Class | Description
AlertDetailDialog |
AlertListDialog |
AlertManager |
AlertManager.Alert |
AlertManager.AlertType |

Interfaces

Interface | Description
IAlertViewer |
IAlertViewer500 |

Delegates

Delegate | Description
IAlertViewer.AfterClearAlertEventHandler |
IAlertViewer.BeforeClearAlertEventHandler |
IAlertViewer500.AfterClearAlertEventHandler |
IAlertViewer500.BeforeClearAlertEventHandler |

Enumerations

Enumeration | Description
AlertManager.AlertType.AlertTypeImportance |


AlertDetailDialog Class

For a list of all members of this type, see AlertDetailDialog Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
AlertDetailDialog

public class AlertDetailDialog : Form, IAlertViewer500

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.Alerts

Assembly: AptifyAlerts (in AptifyAlerts.dll)

See Also

AlertDetailDialog Members | Aptify.Framework.BusinessLogic.Alerts Namespace


AlertDetailDialog Members

AlertDetailDialog overview

Public Instance Constructors

AlertDetailDialog Constructor Initializes a new instance of the AlertDetailDialog class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UserCredentials |
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ClearAlert |
Close (inherited from Form) | Closes the form.
Configure | Overloaded.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
ShowForm |
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AfterClearAlert |
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BeforeClearAlert |
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

AlertDetailDialog Class | Aptify.Framework.BusinessLogic.Alerts Namespace


AlertDetailDialog Constructor

Initializes a new instance of the AlertDetailDialog class.

public AlertDetailDialog();

See Also

AlertDetailDialog Class | Aptify.Framework.BusinessLogic.Alerts Namespace


AlertDetailDialog Properties

The properties of the AlertDetailDialog class are listed below. For a complete list of AlertDetailDialog class members, see the AlertDetailDialog Members topic.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UserCredentials |
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

AlertDetailDialog Class | Aptify.Framework.BusinessLogic.Alerts Namespace


UserCredentials Property

Aptify 5.0 Software Development Kit (SDK)

AlertDetailDialog.UserCredentials Property

public UserCredentials UserCredentials {get; set;}

Implements

IAlertViewer500.

See Also

AlertDetailDialog Class | Aptify.Framework.BusinessLogic.Alerts Namespace


AlertDetailDialog Methods

The methods of the AlertDetailDialog class are listed below. For a complete list of AlertDetailDialog class members, see the AlertDetailDialog Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ClearAlert |
Close (inherited from Form) | Closes the form.
Configure | Overloaded.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
ShowForm |
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

AlertDetailDialog Class | Aptify.Framework.BusinessLogic.Alerts Namespace


AlertDetailDialog.ClearAlert Method

public void ClearAlert();

Implements

IAlertViewer500.

See Also

AlertDetailDialog Class | Aptify.Framework.BusinessLogic.Alerts Namespace


Configure Method

Aptify 5.0 Software Development Kit (SDK)

AlertDetailDialog.Configure Method

Overload List

public void Configure(AlertManager,String,String,Int64,Int64);

public void Configure(String,String,Int64,Int64);

See Also

AlertDetailDialog Class | Aptify.Framework.BusinessLogic.Alerts Namespace


AlertDetailDialog.Configure Method (AlertManager, String, String, Int64, Int64)

public void Configure(
AlertManager oAlertManager,
String AlertKey,
String AlertText,
Int64 EntityID,
Int64 RecordID
);

Implements

IAlertViewer500.

See Also

AlertDetailDialog Class | Aptify.Framework.BusinessLogic.Alerts Namespace | AlertDetailDialog.Configure Overload List


AlertDetailDialog.Configure Method (String, String, Int64, Int64)

public void Configure(
String AlertKey,
String AlertText,
Int64 EntityID,
Int64 RecordID
);

Implements

IAlertViewer500.

See Also

AlertDetailDialog Class | Aptify.Framework.BusinessLogic.Alerts Namespace | AlertDetailDialog.Configure Overload List


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

AlertDetailDialog.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

AlertDetailDialog Class | Aptify.Framework.BusinessLogic.Alerts Namespace


AlertDetailDialog.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

AlertDetailDialog Class | Aptify.Framework.BusinessLogic.Alerts Namespace | AlertDetailDialog.Dispose Overload List


AlertDetailDialog.ShowForm Method

public void ShowForm();

Implements

IAlertViewer500.

See Also

AlertDetailDialog Class | Aptify.Framework.BusinessLogic.Alerts Namespace


AlertDetailDialog Events

The events of the AlertDetailDialog class are listed below. For a complete list of AlertDetailDialog class members, see the AlertDetailDialog Members topic.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AfterClearAlert |
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BeforeClearAlert |
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

AlertDetailDialog Class | Aptify.Framework.BusinessLogic.Alerts Namespace


AlertDetailDialog.IAlertViewer500.AfterClearAlertEventHandler Event

public event IAlertViewer500.AfterClearAlertEventHandler AfterClearAlert;

Implements

IAlertViewer500.

See Also

AlertDetailDialog Class | Aptify.Framework.BusinessLogic.Alerts Namespace


AlertDetailDialog.IAlertViewer500.BeforeClearAlertEventHandler Event

public event IAlertViewer500.BeforeClearAlertEventHandler BeforeClearAlert;

Implements

IAlertViewer500.

See Also

AlertDetailDialog Class | Aptify.Framework.BusinessLogic.Alerts Namespace


AlertListDialog Class

For a list of all members of this type, see AlertListDialog Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
AlertListDialog

public class AlertListDialog : Form

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.Alerts

Assembly: AptifyAlerts (in AptifyAlerts.dll)

See Also

AlertListDialog Members | Aptify.Framework.BusinessLogic.Alerts Namespace


AlertListDialog Members

AlertListDialog overview

Public Instance Constructors

AlertListDialog Constructor

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
LoadData |
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RefreshAlerts |
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

AlertListDialog Class | Aptify.Framework.BusinessLogic.Alerts Namespace


AlertListDialog Constructor

public AlertListDialog(
ref AptifyApplication& Application
);

See Also

AlertListDialog Class | Aptify.Framework.BusinessLogic.Alerts Namespace


AlertListDialog Methods

The methods of the AlertListDialog class are listed below. For a complete list of AlertListDialog class members, see the AlertListDialog Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
LoadData |
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RefreshAlerts |
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

AlertListDialog Class | Aptify.Framework.BusinessLogic.Alerts Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

AlertListDialog.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

AlertListDialog Class | Aptify.Framework.BusinessLogic.Alerts Namespace


AlertListDialog.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

AlertListDialog Class | Aptify.Framework.BusinessLogic.Alerts Namespace | AlertListDialog.Dispose Overload List


AlertListDialog.LoadData Method

public void LoadData(
ref AlertManager& AlertManager
);

See Also

AlertListDialog Class | Aptify.Framework.BusinessLogic.Alerts Namespace


AlertListDialog.RefreshAlerts Method

public void RefreshAlerts();

See Also

AlertListDialog Class | Aptify.Framework.BusinessLogic.Alerts Namespace


AlertManager Class

For a list of all members of this type, see AlertManager Members.

System.Object
AlertManager

public class AlertManager

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.Alerts

Assembly: AptifyAlerts (in AptifyAlerts.dll)

See Also

AlertManager Members | Aptify.Framework.BusinessLogic.Alerts Namespace


AlertManager Members

AlertManager overview

Public Instance Constructors

AlertManager Overloaded. Initializes a new instance of the AlertManager class.

Public Instance Properties

AlertCount
Alerts
AlertTypes
ApplicationObject
Coordinator
CurrentAlertListDialog
EntityID
GEObject
RecordID

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
LoadAlerts |
RefreshAlerts |
ShowListDialog |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AlertManager Class | Aptify.Framework.BusinessLogic.Alerts Namespace


AlertManager Constructor

Overload List

public AlertManager(AptifyApplication);

public AlertManager(AptifyApplication,Boolean,Int64,Int64);

See Also

AlertManager Class | Aptify.Framework.BusinessLogic.Alerts Namespace


AlertManager Constructor (AptifyApplication, Boolean, Int64, Int64)

public AlertManager(
AptifyApplication Application,
Boolean PopulateAlerts,
Int64 lEntityID,
Int64 lRecordID
);

See Also

AlertManager Class | Aptify.Framework.BusinessLogic.Alerts Namespace | AlertManager Constructor Overload List


AlertManager Constructor (AptifyApplication)

public AlertManager(
AptifyApplication Application
);

See Also

AlertManager Class | Aptify.Framework.BusinessLogic.Alerts Namespace | AlertManager Constructor Overload List


AlertManager Properties

The properties of the AlertManager class are listed below. For a complete list of AlertManager class members, see the AlertManager Members topic.

Public Instance Properties

AlertCount
Alerts
AlertTypes
ApplicationObject
Coordinator
CurrentAlertListDialog
EntityID
GEObject
RecordID

See Also

AlertManager Class | Aptify.Framework.BusinessLogic.Alerts Namespace


AlertCount Property

Aptify 5.0 Software Development Kit (SDK)

AlertManager.AlertCount Property

public virtual Int32 AlertCount {get;}

See Also

AlertManager Class | Aptify.Framework.BusinessLogic.Alerts Namespace


Alerts Property

Aptify 5.0 Software Development Kit (SDK)

AlertManager.Alerts Property

public Dictionary<TKey,TValue> Alerts {get;}

See Also

AlertManager Class | Aptify.Framework.BusinessLogic.Alerts Namespace


AlertTypes Property

Aptify 5.0 Software Development Kit (SDK)

AlertManager.AlertTypes Property

public Dictionary<TKey,TValue> AlertTypes {get;}

See Also

AlertManager Class | Aptify.Framework.BusinessLogic.Alerts Namespace


ApplicationObject Property

Aptify 5.0 Software Development Kit (SDK)

AlertManager.ApplicationObject Property

public AptifyApplication ApplicationObject {get;}

See Also

AlertManager Class | Aptify.Framework.BusinessLogic.Alerts Namespace


Coordinator Property

Aptify 5.0 Software Development Kit (SDK)

AlertManager.Coordinator Property

public AptifyMessageCoordinator Coordinator {get; set;}

See Also

AlertManager Class | Aptify.Framework.BusinessLogic.Alerts Namespace


CurrentAlertListDialog Property

Aptify 5.0 Software Development Kit (SDK)

AlertManager.CurrentAlertListDialog Property

public AlertListDialog CurrentAlertListDialog {get;}

See Also

AlertManager Class | Aptify.Framework.BusinessLogic.Alerts Namespace


EntityID Property

Aptify 5.0 Software Development Kit (SDK)

AlertManager.EntityID Property

public Int64 EntityID {get;}

See Also

AlertManager Class | Aptify.Framework.BusinessLogic.Alerts Namespace


GEObject Property

Aptify 5.0 Software Development Kit (SDK)

AlertManager.GEObject Property

public AptifyGenericEntityBase GEObject {get; set;}

See Also

AlertManager Class | Aptify.Framework.BusinessLogic.Alerts Namespace


RecordID Property

Aptify 5.0 Software Development Kit (SDK)

AlertManager.RecordID Property

public Int64 RecordID {get;}

See Also

AlertManager Class | Aptify.Framework.BusinessLogic.Alerts Namespace


AlertManager Methods

The methods of the AlertManager class are listed below. For a complete list of AlertManager class members, see the AlertManager Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
LoadAlerts |
RefreshAlerts |
ShowListDialog |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AlertManager Class | Aptify.Framework.BusinessLogic.Alerts Namespace


AlertManager.LoadAlerts Method

public virtual void LoadAlerts(
Boolean bCountOnly
);

See Also

AlertManager Class | Aptify.Framework.BusinessLogic.Alerts Namespace


AlertManager.RefreshAlerts Method

public void RefreshAlerts();

See Also

AlertManager Class | Aptify.Framework.BusinessLogic.Alerts Namespace


AlertManager.ShowListDialog Method

public virtual void ShowListDialog();

See Also

AlertManager Class | Aptify.Framework.BusinessLogic.Alerts Namespace


AlertManager.Alert Class

For a list of all members of this type, see AlertManager.Alert Members.

System.Object
AlertManager.Alert

public class AlertManager.Alert

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.Alerts

Assembly: AptifyAlerts (in AptifyAlerts.dll)

See Also

AlertManager.Alert Members | Aptify.Framework.BusinessLogic.Alerts Namespace


AlertManager.Alert Members

AlertManager.Alert overview

Public Instance Constructors

AlertManager.Alert Constructor Initializes a new instance of the AlertManager.Alert class.

Public Instance Properties

AlertType
EntityID
Key
Message
Name
RecordID

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ShowDetail | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AlertManager.Alert Class | Aptify.Framework.BusinessLogic.Alerts Namespace


AlertManager.Alert Constructor

Initializes a new instance of the AlertManager.Alert class.

public AlertManager.Alert();

See Also

AlertManager.Alert Class | Aptify.Framework.BusinessLogic.Alerts Namespace


AlertManager.Alert Properties

The properties of the AlertManager.Alert class are listed below. For a complete list of AlertManager.Alert class members, see the AlertManager.Alert Members topic.

Public Instance Properties

AlertType
EntityID
Key
Message
Name
RecordID

See Also

AlertManager.Alert Class | Aptify.Framework.BusinessLogic.Alerts Namespace


AlertType Property

Aptify 5.0 Software Development Kit (SDK)

AlertManager.Alert.AlertType Property

public AlertManager.AlertType AlertType {get; set;}

See Also

AlertManager.Alert Class | Aptify.Framework.BusinessLogic.Alerts Namespace


EntityID Property

Aptify 5.0 Software Development Kit (SDK)

AlertManager.Alert.EntityID Property

public Int64 EntityID {get; set;}

See Also

AlertManager.Alert Class | Aptify.Framework.BusinessLogic.Alerts Namespace


Key Property

Aptify 5.0 Software Development Kit (SDK)

AlertManager.Alert.Key Property

public String Key {get; set;}

See Also

AlertManager.Alert Class | Aptify.Framework.BusinessLogic.Alerts Namespace


Message Property

Aptify 5.0 Software Development Kit (SDK)

AlertManager.Alert.Message Property

public String Message {get; set;}

See Also

AlertManager.Alert Class | Aptify.Framework.BusinessLogic.Alerts Namespace


Name Property

Aptify 5.0 Software Development Kit (SDK)

AlertManager.Alert.Name Property

public String Name {get; set;}

See Also

AlertManager.Alert Class | Aptify.Framework.BusinessLogic.Alerts Namespace


RecordID Property

Aptify 5.0 Software Development Kit (SDK)

AlertManager.Alert.RecordID Property

public Int64 RecordID {get; set;}

See Also

AlertManager.Alert Class | Aptify.Framework.BusinessLogic.Alerts Namespace


AlertManager.Alert Methods

The methods of the AlertManager.Alert class are listed below. For a complete list of AlertManager.Alert class members, see the AlertManager.Alert Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ShowDetail | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AlertManager.Alert Class | Aptify.Framework.BusinessLogic.Alerts Namespace


ShowDetail Method

Aptify 5.0 Software Development Kit (SDK)

AlertManager.Alert.ShowDetail Method

Overload List

public void ShowDetail();

public void ShowDetail(UserCredentials);

See Also

AlertManager.Alert Class | Aptify.Framework.BusinessLogic.Alerts Namespace


AlertManager.Alert.ShowDetail Method ()

public void ShowDetail();

See Also

AlertManager.Alert Class | Aptify.Framework.BusinessLogic.Alerts Namespace | AlertManager.Alert.ShowDetail Overload List


AlertManager.Alert.ShowDetail Method (UserCredentials)

public void ShowDetail(
UserCredentials UserCredential
);

See Also

AlertManager.Alert Class | Aptify.Framework.BusinessLogic.Alerts Namespace | AlertManager.Alert.ShowDetail Overload List


AlertManager.AlertType Class

For a list of all members of this type, see AlertManager.AlertType Members.

System.Object
AlertManager.AlertType

public class AlertManager.AlertType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.Alerts

Assembly: AptifyAlerts (in AptifyAlerts.dll)

See Also

AlertManager.AlertType Members | Aptify.Framework.BusinessLogic.Alerts Namespace


AlertManager.AlertType Members

AlertManager.AlertType overview

Public Instance Constructors

AlertManager.AlertType Overloaded. Initializes a new instance of the AlertManager.AlertType class.

Public Instance Properties

AllowsClearing
DefaultImportance
Icon
Name
SourceScript
Viewer
ViewerAssembly
ViewerClass
ViewerObject

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ShowViewerObject | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AlertManager.AlertType Class | Aptify.Framework.BusinessLogic.Alerts Namespace


AlertManager.AlertType Constructor

Overload List

public AlertManager.AlertType(String,String,String,String,String,Boolean,String);

public AlertManager.AlertType(String,String,String,String,String,Boolean,String,AlertManager);

See Also

AlertManager.AlertType Class | Aptify.Framework.BusinessLogic.Alerts Namespace


AlertManager.AlertType Constructor (String, String, String, String, String, Boolean, String)

public AlertManager.AlertType(
String sName,
String sIcon,
String sViewerClass,
String sViewerObject,
String sViewerAssembly,
Boolean bAllowsClearing,
String sSourceScript
);

See Also

AlertManager.AlertType Class | Aptify.Framework.BusinessLogic.Alerts Namespace | AlertManager.AlertType Constructor Overload List


AlertManager.AlertType Constructor (String, String, String, String, String, Boolean, String, AlertManager)

public AlertManager.AlertType(
String sName,
String sIcon,
String sViewerClass,
String sViewerObject,
String sViewerAssembly,
Boolean bAllowsClearing,
String sSourceScript,
AlertManager oAlertManager
);

See Also

AlertManager.AlertType Class | Aptify.Framework.BusinessLogic.Alerts Namespace | AlertManager.AlertType Constructor Overload List


AlertManager.AlertType Properties

The properties of the AlertManager.AlertType class are listed below. For a complete list of AlertManager.AlertType class members, see the AlertManager.AlertType Members topic.

Public Instance Properties

AllowsClearing
DefaultImportance
Icon
Name
SourceScript
Viewer
ViewerAssembly
ViewerClass
ViewerObject

See Also

AlertManager.AlertType Class | Aptify.Framework.BusinessLogic.Alerts Namespace


AllowsClearing Property

Aptify 5.0 Software Development Kit (SDK)

AlertManager.AlertType.AllowsClearing Property

public Boolean AllowsClearing {get;}

See Also

AlertManager.AlertType Class | Aptify.Framework.BusinessLogic.Alerts Namespace


DefaultImportance Property

Aptify 5.0 Software Development Kit (SDK)

AlertManager.AlertType.DefaultImportance Property

public AlertManager.AlertType.AlertTypeImportance DefaultImportance {get;}

See Also

AlertManager.AlertType Class | Aptify.Framework.BusinessLogic.Alerts Namespace


Icon Property

Aptify 5.0 Software Development Kit (SDK)

AlertManager.AlertType.Icon Property

public String Icon {get;}

See Also

AlertManager.AlertType Class | Aptify.Framework.BusinessLogic.Alerts Namespace


Name Property

Aptify 5.0 Software Development Kit (SDK)

AlertManager.AlertType.Name Property

public String Name {get;}

See Also

AlertManager.AlertType Class | Aptify.Framework.BusinessLogic.Alerts Namespace


SourceScript Property

Aptify 5.0 Software Development Kit (SDK)

AlertManager.AlertType.SourceScript Property

public String SourceScript {get;}

See Also

AlertManager.AlertType Class | Aptify.Framework.BusinessLogic.Alerts Namespace


Viewer Property

Aptify 5.0 Software Development Kit (SDK)

AlertManager.AlertType.Viewer Property

public IAlertViewer Viewer {get;}

See Also

AlertManager.AlertType Class | Aptify.Framework.BusinessLogic.Alerts Namespace


ViewerAssembly Property

Aptify 5.0 Software Development Kit (SDK)

AlertManager.AlertType.ViewerAssembly Property

public String ViewerAssembly {get;}

See Also

AlertManager.AlertType Class | Aptify.Framework.BusinessLogic.Alerts Namespace


ViewerClass Property

Aptify 5.0 Software Development Kit (SDK)

AlertManager.AlertType.ViewerClass Property

public String ViewerClass {get;}

See Also

AlertManager.AlertType Class | Aptify.Framework.BusinessLogic.Alerts Namespace


ViewerObject Property

Aptify 5.0 Software Development Kit (SDK)

AlertManager.AlertType.ViewerObject Property

public String ViewerObject {get;}

See Also

AlertManager.AlertType Class | Aptify.Framework.BusinessLogic.Alerts Namespace


AlertManager.AlertType Methods

The methods of the AlertManager.AlertType class are listed below. For a complete list of AlertManager.AlertType class members, see the AlertManager.AlertType Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ShowViewerObject | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AlertManager.AlertType Class | Aptify.Framework.BusinessLogic.Alerts Namespace


ShowViewerObject Method

Aptify 5.0 Software Development Kit (SDK)

AlertManager.AlertType.ShowViewerObject Method

Overload List

public bool ShowViewerObject(AlertManager.Alert);

public bool ShowViewerObject(AlertManager.Alert,UserCredentials);

See Also

AlertManager.AlertType Class | Aptify.Framework.BusinessLogic.Alerts Namespace


AlertManager.AlertType.ShowViewerObject Method (Alert)

public bool ShowViewerObject(
AlertManager.Alert Alert
);

See Also

AlertManager.AlertType Class | Aptify.Framework.BusinessLogic.Alerts Namespace | AlertManager.AlertType.ShowViewerObject Overload List


AlertManager.AlertType.ShowViewerObject Method (Alert, UserCredentials)

public bool ShowViewerObject(
AlertManager.Alert Alert,
UserCredentials UserCredential
);

See Also

AlertManager.AlertType Class | Aptify.Framework.BusinessLogic.Alerts Namespace | AlertManager.AlertType.ShowViewerObject Overload List


AlertManager.AlertType.AlertTypeImportance Enumeration

public enum AlertManager.AlertType.AlertTypeImportance

Members

Member Name | Description
Critical |
High |
Medium |
Low |

Requirements

Namespace: Aptify.Framework.BusinessLogic.Alerts

Assembly: AptifyAlerts (in AptifyAlerts.dll)

See Also

Aptify.Framework.BusinessLogic.Alerts Namespace


IAlertViewer Interface

For a list of all members of this type, see IAlertViewer Members.

public interface IAlertViewer

Requirements

Namespace: Aptify.Framework.BusinessLogic.Alerts

Assembly: AptifyAlerts (in AptifyAlerts.dll)

See Also

IAlertViewer Members | Aptify.Framework.BusinessLogic.Alerts Namespace


IAlertViewer Members

IAlertViewer overview

Public Instance Methods

ClearAlert
Configure
ShowForm

Public Instance Events

AfterClearAlert
BeforeClearAlert

See Also

IAlertViewer Interface | Aptify.Framework.BusinessLogic.Alerts Namespace


IAlertViewer Methods

The methods of the IAlertViewer interface are listed below. For a complete list of IAlertViewer interface members, see the IAlertViewer Members topic.

Public Instance Methods

ClearAlert
Configure
ShowForm

See Also

IAlertViewer Interface | Aptify.Framework.BusinessLogic.Alerts Namespace


IAlertViewer.ClearAlert Method

void ClearAlert();

See Also

IAlertViewer Interface | Aptify.Framework.BusinessLogic.Alerts Namespace


IAlertViewer.Configure Method

void Configure(
String AlertKey,
String AlertText,
Int64 EntityID,
Int64 RecordID
);

See Also

IAlertViewer Interface | Aptify.Framework.BusinessLogic.Alerts Namespace


IAlertViewer.ShowForm Method

void ShowForm();

See Also

IAlertViewer Interface | Aptify.Framework.BusinessLogic.Alerts Namespace


IAlertViewer Events

The events of the IAlertViewer interface are listed below. For a complete list of IAlertViewer interface members, see the IAlertViewer Members topic.

Public Instance Events

AfterClearAlert
BeforeClearAlert

See Also

IAlertViewer Interface | Aptify.Framework.BusinessLogic.Alerts Namespace


IAlertViewer.IAlertViewer.AfterClearAlertEventHandler Event

event IAlertViewer.AfterClearAlertEventHandler AfterClearAlert;

See Also

IAlertViewer Interface | Aptify.Framework.BusinessLogic.Alerts Namespace


IAlertViewer.IAlertViewer.BeforeClearAlertEventHandler Event

event IAlertViewer.BeforeClearAlertEventHandler BeforeClearAlert;

See Also

IAlertViewer Interface | Aptify.Framework.BusinessLogic.Alerts Namespace


IAlertViewer.AfterClearAlertEventHandler Delegate

public delegate void IAlertViewer.AfterClearAlertEventHandler();

Requirements

Namespace: Aptify.Framework.BusinessLogic.Alerts

Assembly: AptifyAlerts (in AptifyAlerts.dll)

See Also

Aptify.Framework.BusinessLogic.Alerts Namespace


IAlertViewer.BeforeClearAlertEventHandler Delegate

public delegate void IAlertViewer.BeforeClearAlertEventHandler(
Boolean Cancel
);

Requirements

Namespace: Aptify.Framework.BusinessLogic.Alerts

Assembly: AptifyAlerts (in AptifyAlerts.dll)

See Also

Aptify.Framework.BusinessLogic.Alerts Namespace


IAlertViewer500 Interface

For a list of all members of this type, see IAlertViewer500 Members.

public interface IAlertViewer500

Types that implement IAlertViewer500

Type | Description
AlertDetailDialog |

Requirements

Namespace: Aptify.Framework.BusinessLogic.Alerts

Assembly: AptifyAlerts (in AptifyAlerts.dll)

See Also

IAlertViewer500 Members | Aptify.Framework.BusinessLogic.Alerts Namespace


IAlertViewer500 Members

IAlertViewer500 overview

Public Instance Properties

UserCredentials

Public Instance Methods

ClearAlert |
Configure | Overloaded.
ShowForm |

Public Instance Events

AfterClearAlert
BeforeClearAlert

See Also

IAlertViewer500 Interface | Aptify.Framework.BusinessLogic.Alerts Namespace


IAlertViewer500 Properties

The properties of the IAlertViewer500 interface are listed below. For a complete list of IAlertViewer500 interface members, see the IAlertViewer500 Members topic.

Public Instance Properties

UserCredentials

See Also

IAlertViewer500 Interface | Aptify.Framework.BusinessLogic.Alerts Namespace


UserCredentials Property

Aptify 5.0 Software Development Kit (SDK)

IAlertViewer500.UserCredentials Property

UserCredentials UserCredentials {get; set;}

See Also

IAlertViewer500 Interface | Aptify.Framework.BusinessLogic.Alerts Namespace


IAlertViewer500 Methods

The methods of the IAlertViewer500 interface are listed below. For a complete list of IAlertViewer500 interface members, see the IAlertViewer500 Members topic.

Public Instance Methods

ClearAlert |
Configure | Overloaded.
ShowForm |

See Also

IAlertViewer500 Interface | Aptify.Framework.BusinessLogic.Alerts Namespace


IAlertViewer500.ClearAlert Method

void ClearAlert();

See Also

IAlertViewer500 Interface | Aptify.Framework.BusinessLogic.Alerts Namespace


Configure Method

Aptify 5.0 Software Development Kit (SDK)

IAlertViewer500.Configure Method

Overload List

void Configure(AlertManager,String,String,Int64,Int64);

void Configure(String,String,Int64,Int64);

See Also

IAlertViewer500 Interface | Aptify.Framework.BusinessLogic.Alerts Namespace


IAlertViewer500.Configure Method (AlertManager, String, String, Int64, Int64)

void Configure(
AlertManager oAlertManager,
String AlertKey,
String AlertText,
Int64 EntityID,
Int64 RecordID
);

See Also

IAlertViewer500 Interface | Aptify.Framework.BusinessLogic.Alerts Namespace | IAlertViewer500.Configure Overload List


IAlertViewer500.Configure Method (String, String, Int64, Int64)

void Configure(
String AlertKey,
String AlertText,
Int64 EntityID,
Int64 RecordID
);

See Also

IAlertViewer500 Interface | Aptify.Framework.BusinessLogic.Alerts Namespace | IAlertViewer500.Configure Overload List


IAlertViewer500.ShowForm Method

void ShowForm();

See Also

IAlertViewer500 Interface | Aptify.Framework.BusinessLogic.Alerts Namespace


IAlertViewer500 Events

The events of the IAlertViewer500 interface are listed below. For a complete list of IAlertViewer500 interface members, see the IAlertViewer500 Members topic.

Public Instance Events

AfterClearAlert
BeforeClearAlert

See Also

IAlertViewer500 Interface | Aptify.Framework.BusinessLogic.Alerts Namespace


IAlertViewer500.IAlertViewer500.AfterClearAlertEventHandler Event

event IAlertViewer500.AfterClearAlertEventHandler AfterClearAlert;

See Also

IAlertViewer500 Interface | Aptify.Framework.BusinessLogic.Alerts Namespace


IAlertViewer500.IAlertViewer500.BeforeClearAlertEventHandler Event

event IAlertViewer500.BeforeClearAlertEventHandler BeforeClearAlert;

See Also

IAlertViewer500 Interface | Aptify.Framework.BusinessLogic.Alerts Namespace


IAlertViewer500.AfterClearAlertEventHandler Delegate

public delegate void IAlertViewer500.AfterClearAlertEventHandler();

Requirements

Namespace: Aptify.Framework.BusinessLogic.Alerts

Assembly: AptifyAlerts (in AptifyAlerts.dll)

See Also

Aptify.Framework.BusinessLogic.Alerts Namespace


IAlertViewer500.BeforeClearAlertEventHandler Delegate

public delegate void IAlertViewer500.BeforeClearAlertEventHandler(
Boolean Cancel
);

Requirements

Namespace: Aptify.Framework.BusinessLogic.Alerts

Assembly: AptifyAlerts (in AptifyAlerts.dll)

See Also

Aptify.Framework.BusinessLogic.Alerts Namespace


Aptify.Framework.BusinessLogic.AttachmentCategories

Aptify 5.0 Software Development Kit (SDK)

Aptify.Framework.BusinessLogic.AttachmentCategories Namespace

This namespace corresponds to objects used to secure and manage Attachment Categories.

Namespace hierarchy

Classes

Class | Description
AttachmentCategoryEntity |


AttachmentCategoryEntity Class

For a list of all members of this type, see AttachmentCategoryEntity Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
AttachmentCategoryEntity

public class AttachmentCategoryEntity : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.AttachmentCategories

Assembly: AptifyAttachmentCategoriesEntity (in AptifyAttachmentCategoriesEntity.dll)

See Also

AttachmentCategoryEntity Members | Aptify.Framework.BusinessLogic.AttachmentCategories Namespace


AttachmentCategoryEntity Members

AttachmentCategoryEntity overview

Public Instance Constructors

AttachmentCategoryEntity Constructor Initializes a new instance of the AttachmentCategoryEntity class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded. Set value "_CanSaveAttCategory_" as a False if this is read only.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

AttachmentCategoryEntity Class | Aptify.Framework.BusinessLogic.AttachmentCategories Namespace


AttachmentCategoryEntity Constructor

Initializes a new instance of the AttachmentCategoryEntity class.

public AttachmentCategoryEntity();

See Also

AttachmentCategoryEntity Class | Aptify.Framework.BusinessLogic.AttachmentCategories Namespace


AttachmentCategoryEntity Methods

The methods of the AttachmentCategoryEntity class are listed below. For a complete list of AttachmentCategoryEntity class members, see the AttachmentCategoryEntity Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded. Set value "_CanSaveAttCategory_" as a False if this is read only.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

AttachmentCategoryEntity Class | Aptify.Framework.BusinessLogic.AttachmentCategories Namespace


Validate Method

Aptify 5.0 Software Development Kit (SDK)

AttachmentCategoryEntity.Validate Method

Set value "_CanSaveAttCategory_" as a False if this is read only.

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Validate();

Set value "_CanSaveAttCategory_" as a False if this is read only.

public override bool Validate(ref String&);

See Also

AttachmentCategoryEntity Class | Aptify.Framework.BusinessLogic.AttachmentCategories Namespace


AttachmentCategoryEntity.Validate Method (String&)

Set value "_CanSaveAttCategory_" as a False if this is read only.

public override bool Validate(
ref String& ErrorString
);

Parameters

ErrorString

Return Value

Remarks

See Also

AttachmentCategoryEntity Class | Aptify.Framework.BusinessLogic.AttachmentCategories Namespace | AttachmentCategoryEntity.Validate Overload List


Aptify.Framework.BusinessLogic.CalendarView

Aptify 5.0 Software Development Kit (SDK)

Aptify.Framework.BusinessLogic.CalendarView Namespace

This namespace contains objects used by Aptify's Calendar View type to display record data on a calendar based on date/time fields stored in the records.

Namespace hierarchy

Classes

Class | Description
CalendarViewException | This is thrown when there is a problem executing an Aptify Calendar view.
CalendarViewInfo |

Enumerations

Enumeration | Description
CalendarModeType |
DurationMode |
FirstVisibleDateType |
GroupingStyle |
TimeSlotInterval |


CalendarModeType Enumeration

public enum CalendarModeType

Members

Member Name | Description
Day |
Week |
WorkWeek |
Month |
MultiMonth |

Requirements

Namespace: Aptify.Framework.BusinessLogic.CalendarView

Assembly: AptifyCalendarViewUtility (in AptifyCalendarViewUtility.dll)

See Also

Aptify.Framework.BusinessLogic.CalendarView Namespace


CalendarViewException Class

This is thrown when there is a problem executing an Aptify Calendar view.

For a list of all members of this type, see CalendarViewException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
CalendarViewException

public class CalendarViewException : BaseApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.CalendarView

Assembly: AptifyCalendarViewUtility (in AptifyCalendarViewUtility.dll)

See Also

CalendarViewException Members | Aptify.Framework.BusinessLogic.CalendarView Namespace


CalendarViewException Members

CalendarViewException overview

Public Instance Constructors

CalendarViewException Overloaded. Initializes a new instance of the CalendarViewException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from BaseApplicationException) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CalendarViewException Class | Aptify.Framework.BusinessLogic.CalendarView Namespace


CalendarViewException Constructor

Initializes a new instance of the CalendarViewException class.

Overload List

Initializes a new instance of the CalendarViewException class.

public CalendarViewException();

public CalendarViewException(String);

public CalendarViewException(String,Exception);

See Also

CalendarViewException Class | Aptify.Framework.BusinessLogic.CalendarView Namespace


CalendarViewException Constructor ()

Initializes a new instance of the CalendarViewException class.

public CalendarViewException();

See Also

CalendarViewException Class | Aptify.Framework.BusinessLogic.CalendarView Namespace | CalendarViewException Constructor Overload List


CalendarViewException Constructor (String)

public CalendarViewException(
String Message
);

See Also

CalendarViewException Class | Aptify.Framework.BusinessLogic.CalendarView Namespace | CalendarViewException Constructor Overload List


CalendarViewException Constructor (String, Exception)

public CalendarViewException(
String Message,
Exception InnerException
);

See Also

CalendarViewException Class | Aptify.Framework.BusinessLogic.CalendarView Namespace | CalendarViewException Constructor Overload List


CalendarViewInfo Class

For a list of all members of this type, see CalendarViewInfo Members.

System.Object
CalendarViewInfo

public class CalendarViewInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.CalendarView

Assembly: AptifyCalendarViewUtility (in AptifyCalendarViewUtility.dll)

See Also

CalendarViewInfo Members | Aptify.Framework.BusinessLogic.CalendarView Namespace


CalendarViewInfo Members

CalendarViewInfo overview

Public Instance Constructors

CalendarViewInfo Constructor Initializes a new instance of the CalendarViewInfo class.

Public Instance Properties

AppointmentShadow
BackColor
CurrentTimeIndicator
DurationField
DurationMode
EndDateField
FirstVisibleDate
FirstVisibleDateType
GroupField
GroupingStyle
ID
IdleTimeBackColor
Mode
NonWorkingHoursBackColor
NumVisibleDays
StandardDuration
StartDateField
TimeSlotInterval
TitleField
WorkingHoursBackColor

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Load |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CalendarViewInfo Class | Aptify.Framework.BusinessLogic.CalendarView Namespace


CalendarViewInfo Constructor

Initializes a new instance of the CalendarViewInfo class.

public CalendarViewInfo();

See Also

CalendarViewInfo Class | Aptify.Framework.BusinessLogic.CalendarView Namespace


CalendarViewInfo Properties

The properties of the CalendarViewInfo class are listed below. For a complete list of CalendarViewInfo class members, see the CalendarViewInfo Members topic.

Public Instance Properties

AppointmentShadow
BackColor
CurrentTimeIndicator
DurationField
DurationMode
EndDateField
FirstVisibleDate
FirstVisibleDateType
GroupField
GroupingStyle
ID
IdleTimeBackColor
Mode
NonWorkingHoursBackColor
NumVisibleDays
StandardDuration
StartDateField
TimeSlotInterval
TitleField
WorkingHoursBackColor

See Also

CalendarViewInfo Class | Aptify.Framework.BusinessLogic.CalendarView Namespace


AppointmentShadow Property

Aptify 5.0 Software Development Kit (SDK)

CalendarViewInfo.AppointmentShadow Property

public Boolean AppointmentShadow {get; set;}

See Also

CalendarViewInfo Class | Aptify.Framework.BusinessLogic.CalendarView Namespace


BackColor Property

Aptify 5.0 Software Development Kit (SDK)

CalendarViewInfo.BackColor Property

public Color BackColor {get; set;}

See Also

CalendarViewInfo Class | Aptify.Framework.BusinessLogic.CalendarView Namespace


CurrentTimeIndicator Property

Aptify 5.0 Software Development Kit (SDK)

CalendarViewInfo.CurrentTimeIndicator Property

public Boolean CurrentTimeIndicator {get; set;}

See Also

CalendarViewInfo Class | Aptify.Framework.BusinessLogic.CalendarView Namespace


DurationField Property

Aptify 5.0 Software Development Kit (SDK)

CalendarViewInfo.DurationField Property

public String DurationField {get; set;}

See Also

CalendarViewInfo Class | Aptify.Framework.BusinessLogic.CalendarView Namespace


DurationMode Property

Aptify 5.0 Software Development Kit (SDK)

CalendarViewInfo.DurationMode Property

public DurationMode DurationMode {get; set;}

See Also

CalendarViewInfo Class | Aptify.Framework.BusinessLogic.CalendarView Namespace


EndDateField Property

Aptify 5.0 Software Development Kit (SDK)

CalendarViewInfo.EndDateField Property

public String EndDateField {get; set;}

See Also

CalendarViewInfo Class | Aptify.Framework.BusinessLogic.CalendarView Namespace


FirstVisibleDate Property

Aptify 5.0 Software Development Kit (SDK)

CalendarViewInfo.FirstVisibleDate Property

public DateTime FirstVisibleDate {get; set;}

See Also

CalendarViewInfo Class | Aptify.Framework.BusinessLogic.CalendarView Namespace


FirstVisibleDateType Property

Aptify 5.0 Software Development Kit (SDK)

CalendarViewInfo.FirstVisibleDateType Property

public FirstVisibleDateType FirstVisibleDateType {get; set;}

See Also

CalendarViewInfo Class | Aptify.Framework.BusinessLogic.CalendarView Namespace


GroupField Property

Aptify 5.0 Software Development Kit (SDK)

CalendarViewInfo.GroupField Property

public String GroupField {get; set;}

See Also

CalendarViewInfo Class | Aptify.Framework.BusinessLogic.CalendarView Namespace


GroupingStyle Property

Aptify 5.0 Software Development Kit (SDK)

CalendarViewInfo.GroupingStyle Property

public GroupingStyle GroupingStyle {get; set;}

See Also

CalendarViewInfo Class | Aptify.Framework.BusinessLogic.CalendarView Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

CalendarViewInfo.ID Property

public Int64 ID {get; set;}

See Also

CalendarViewInfo Class | Aptify.Framework.BusinessLogic.CalendarView Namespace


IdleTimeBackColor Property

Aptify 5.0 Software Development Kit (SDK)

CalendarViewInfo.IdleTimeBackColor Property

public Color IdleTimeBackColor {get; set;}

See Also

CalendarViewInfo Class | Aptify.Framework.BusinessLogic.CalendarView Namespace


Mode Property

Aptify 5.0 Software Development Kit (SDK)

CalendarViewInfo.Mode Property

public CalendarModeType Mode {get; set;}

See Also

CalendarViewInfo Class | Aptify.Framework.BusinessLogic.CalendarView Namespace


NonWorkingHoursBackColor Property

Aptify 5.0 Software Development Kit (SDK)

CalendarViewInfo.NonWorkingHoursBackColor Property

public Color NonWorkingHoursBackColor {get; set;}

See Also

CalendarViewInfo Class | Aptify.Framework.BusinessLogic.CalendarView Namespace


NumVisibleDays Property

Aptify 5.0 Software Development Kit (SDK)

CalendarViewInfo.NumVisibleDays Property

public Int32 NumVisibleDays {get; set;}

See Also

CalendarViewInfo Class | Aptify.Framework.BusinessLogic.CalendarView Namespace


StandardDuration Property

Aptify 5.0 Software Development Kit (SDK)

CalendarViewInfo.StandardDuration Property

public Single StandardDuration {get; set;}

See Also

CalendarViewInfo Class | Aptify.Framework.BusinessLogic.CalendarView Namespace


StartDateField Property

Aptify 5.0 Software Development Kit (SDK)

CalendarViewInfo.StartDateField Property

public String StartDateField {get; set;}

See Also

CalendarViewInfo Class | Aptify.Framework.BusinessLogic.CalendarView Namespace


TimeSlotInterval Property

Aptify 5.0 Software Development Kit (SDK)

CalendarViewInfo.TimeSlotInterval Property

public TimeSlotInterval TimeSlotInterval {get; set;}

See Also

CalendarViewInfo Class | Aptify.Framework.BusinessLogic.CalendarView Namespace


TitleField Property

Aptify 5.0 Software Development Kit (SDK)

CalendarViewInfo.TitleField Property

public String TitleField {get; set;}

See Also

CalendarViewInfo Class | Aptify.Framework.BusinessLogic.CalendarView Namespace


WorkingHoursBackColor Property

Aptify 5.0 Software Development Kit (SDK)

CalendarViewInfo.WorkingHoursBackColor Property

public Color WorkingHoursBackColor {get; set;}

See Also

CalendarViewInfo Class | Aptify.Framework.BusinessLogic.CalendarView Namespace


CalendarViewInfo Methods

The methods of the CalendarViewInfo class are listed below. For a complete list of CalendarViewInfo class members, see the CalendarViewInfo Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Load |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CalendarViewInfo Class | Aptify.Framework.BusinessLogic.CalendarView Namespace


CalendarViewInfo.Load Method

public void Load(
DataRow Row
);

See Also

CalendarViewInfo Class | Aptify.Framework.BusinessLogic.CalendarView Namespace


DurationMode Enumeration

public enum DurationMode

Members

Member Name | Description
EndDate |
Duration |
StandardDuration |

Requirements

Namespace: Aptify.Framework.BusinessLogic.CalendarView

Assembly: AptifyCalendarViewUtility (in AptifyCalendarViewUtility.dll)

See Also

Aptify.Framework.BusinessLogic.CalendarView Namespace


FirstVisibleDateType Enumeration

public enum FirstVisibleDateType

Members

Member Name | Description
Automatic |
Manual |

Requirements

Namespace: Aptify.Framework.BusinessLogic.CalendarView

Assembly: AptifyCalendarViewUtility (in AptifyCalendarViewUtility.dll)

See Also

Aptify.Framework.BusinessLogic.CalendarView Namespace


GroupingStyle Enumeration

public enum GroupingStyle

Members

Member Name | Description
None |
GroupInsideDate |
DateInsideGroup |

Requirements

Namespace: Aptify.Framework.BusinessLogic.CalendarView

Assembly: AptifyCalendarViewUtility (in AptifyCalendarViewUtility.dll)

See Also

Aptify.Framework.BusinessLogic.CalendarView Namespace


TimeSlotInterval Enumeration

public enum TimeSlotInterval

Members

Member Name | Description
ts1Minute |
ts2Minutes |
ts3Minutes |
ts4Minutes |
ts5Minutes |
ts6Minutes |
ts10Minutes |
ts12Minutes |
ts15Minutes |
ts20Minutes |
ts30Minutes |
ts60Minutes |

Requirements

Namespace: Aptify.Framework.BusinessLogic.CalendarView

Assembly: AptifyCalendarViewUtility (in AptifyCalendarViewUtility.dll)

See Also

Aptify.Framework.BusinessLogic.CalendarView Namespace


Aptify.Framework.BusinessLogic.DBObject

Aptify 5.0 Software Development Kit (SDK)

Aptify.Framework.BusinessLogic.DBObject Namespace

This namespace corresponds to the system's Database Objects functionality, including the Database Objects entity and the ability to add and modify the Database Object information on the SQL server.

Namespace hierarchy

Classes

Class | Description
Constants |
DatabaseObjectEntity |
DataBaseObjectException |

Interfaces

Interface | Description
IDatabaseObject |


Constants Class

For a list of all members of this type, see Constants Members.

System.Object
Constants

public class Constants

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.DBObject

Assembly: AptifyDBObjectInterfaces (in AptifyDBObjectInterfaces.dll)

See Also

Constants Members | Aptify.Framework.BusinessLogic.DBObject Namespace


Constants Members

Constants overview

Public Static Fields

BLANK_NAME_MESSAGE
CONFIG_ERROR_INVALID_ENTITY
CURRENT_USER_NOT_ADMINISTRATOR_MESSAGE

Public Static Methods

GetMessage
GetResourceString

Public Instance Constructors

Constants Constructor Initializes a new instance of the Constants class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Constants Class | Aptify.Framework.BusinessLogic.DBObject Namespace


Constants Constructor

Initializes a new instance of the Constants class.

public Constants();

See Also

Constants Class | Aptify.Framework.BusinessLogic.DBObject Namespace


Constants Fields

The fields of the Constants class are listed below. For a complete list of Constants class members, see the Constants Members topic.

Public Static Fields

BLANK_NAME_MESSAGE
CONFIG_ERROR_INVALID_ENTITY
CURRENT_USER_NOT_ADMINISTRATOR_MESSAGE

See Also

Constants Class | Aptify.Framework.BusinessLogic.DBObject Namespace


Constants.BLANK_NAME_MESSAGE Field

public const BLANK_NAME_MESSAGE BLANK_NAME_MESSAGE = "BLANK_NAME_MESSAGE";

See Also

Constants Class | Aptify.Framework.BusinessLogic.DBObject Namespace


Constants.CONFIG_ERROR_INVALID_ENTITY Field

public const CONFIG_ERROR_INVALID_ENTITY CONFIG_ERROR_INVALID_ENTITY = "CONFIG_ERROR_INVALID_ENTITY";

See Also

Constants Class | Aptify.Framework.BusinessLogic.DBObject Namespace


Constants.CURRENT_USER_NOT_ADMINISTRATOR_MESSAGE Field

public const CURRENT_USER_NOT_ADMINISTRATOR_MESSAGE CURRENT_USER_NOT_ADMINISTRATOR_MESSAGE = "CURRENT_USER_NOT_ADMINISTRATOR_MESSAGE";

See Also

Constants Class | Aptify.Framework.BusinessLogic.DBObject Namespace


Constants Methods

The methods of the Constants class are listed below. For a complete list of Constants class members, see the Constants Members topic.

Public Static Methods

GetMessage
GetResourceString

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Constants Class | Aptify.Framework.BusinessLogic.DBObject Namespace


Constants.GetMessage Method

public static string GetMessage(
String MessageKey,
params String[] FormatParameters
);

See Also

Constants Class | Aptify.Framework.BusinessLogic.DBObject Namespace


Constants.GetResourceString Method

public static string GetResourceString(
String Key
);

See Also

Constants Class | Aptify.Framework.BusinessLogic.DBObject Namespace


DatabaseObjectEntity Class

For a list of all members of this type, see DatabaseObjectEntity Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
DatabaseObjectEntity

public class DatabaseObjectEntity : AptifyGenericEntity, IDatabaseObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.DBObject

Assembly: AptifyDBObject (in AptifyDBObject.dll)

See Also

DatabaseObjectEntity Members | Aptify.Framework.BusinessLogic.DBObject Namespace


DatabaseObjectEntity Members

DatabaseObjectEntity overview

Public Instance Constructors

DatabaseObjectEntity Constructor Initializes a new instance of the DatabaseObjectEntity class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config | Overloaded.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete | Overloaded.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
Recompile |
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

DatabaseObjectEntity Class | Aptify.Framework.BusinessLogic.DBObject Namespace


DatabaseObjectEntity Constructor

Initializes a new instance of the DatabaseObjectEntity class.

public DatabaseObjectEntity();

See Also

DatabaseObjectEntity Class | Aptify.Framework.BusinessLogic.DBObject Namespace


DatabaseObjectEntity Methods

The methods of the DatabaseObjectEntity class are listed below. For a complete list of DatabaseObjectEntity class members, see the DatabaseObjectEntity Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config | Overloaded.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete | Overloaded.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
Recompile |
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

DatabaseObjectEntity Class | Aptify.Framework.BusinessLogic.DBObject Namespace


Config Method

Aptify 5.0 Software Development Kit (SDK)

DatabaseObjectEntity.Config Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual void Config(AptifySubTypeBase);

Inherited from AptifyGenericEntity.

public override void Config(AptifySubTypeBase,Int64);

Inherited from AptifyGenericEntityBase.

public virtual void Config(UserCredentials,String);

public override void Config(UserCredentials,String,Int64);

See Also

DatabaseObjectEntity Class | Aptify.Framework.BusinessLogic.DBObject Namespace


DatabaseObjectEntity.Config Method (UserCredentials, String, Int64)

public override void Config(
UserCredentials UserCredentials,
String EntityName,
Int64 RecordID
);

See Also

DatabaseObjectEntity Class | Aptify.Framework.BusinessLogic.DBObject Namespace | DatabaseObjectEntity.Config Overload List


Delete Method

Aptify 5.0 Software Development Kit (SDK)

DatabaseObjectEntity.Delete Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Delete();

public override bool Delete(String);

See Also

DatabaseObjectEntity Class | Aptify.Framework.BusinessLogic.DBObject Namespace


DatabaseObjectEntity.Delete Method (String)

public override bool Delete(
String TransactionID
);

See Also

DatabaseObjectEntity Class | Aptify.Framework.BusinessLogic.DBObject Namespace | DatabaseObjectEntity.Delete Overload List


DatabaseObjectEntity.Recompile Method

public void Recompile();

Implements

IDatabaseObject.

See Also

DatabaseObjectEntity Class | Aptify.Framework.BusinessLogic.DBObject Namespace


Save Method

Aptify 5.0 Software Development Kit (SDK)

DatabaseObjectEntity.Save Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Save();

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean,ref String&);

public override bool Save(Boolean,ref String&,String);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(ref String&);

See Also

DatabaseObjectEntity Class | Aptify.Framework.BusinessLogic.DBObject Namespace


DatabaseObjectEntity.Save Method (Boolean, String&, String)

public override bool Save(
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

See Also

DatabaseObjectEntity Class | Aptify.Framework.BusinessLogic.DBObject Namespace | DatabaseObjectEntity.Save Overload List


Validate Method

Aptify 5.0 Software Development Kit (SDK)

DatabaseObjectEntity.Validate Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Validate();

public override bool Validate(ref String&);

See Also

DatabaseObjectEntity Class | Aptify.Framework.BusinessLogic.DBObject Namespace


DatabaseObjectEntity.Validate Method (String&)

public override bool Validate(
ref String& ErrorString
);

See Also

DatabaseObjectEntity Class | Aptify.Framework.BusinessLogic.DBObject Namespace | DatabaseObjectEntity.Validate Overload List


DataBaseObjectException Class

For a list of all members of this type, see DataBaseObjectException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
DataBaseObjectException

public class DataBaseObjectException : BaseApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.DBObject

Assembly: AptifyDBObject (in AptifyDBObject.dll)

See Also

DataBaseObjectException Members | Aptify.Framework.BusinessLogic.DBObject Namespace


DataBaseObjectException Members

DataBaseObjectException overview

Public Instance Constructors

DataBaseObjectException Overloaded. Initializes a new instance of the DataBaseObjectException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from BaseApplicationException) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DataBaseObjectException Class | Aptify.Framework.BusinessLogic.DBObject Namespace


DataBaseObjectException Constructor

Initializes a new instance of the DataBaseObjectException class.

Overload List

Initializes a new instance of the DataBaseObjectException class.

public DataBaseObjectException();

public DataBaseObjectException(String);

public DataBaseObjectException(String,Exception);

See Also

DataBaseObjectException Class | Aptify.Framework.BusinessLogic.DBObject Namespace


DataBaseObjectException Constructor ()

Initializes a new instance of the DataBaseObjectException class.

public DataBaseObjectException();

See Also

DataBaseObjectException Class | Aptify.Framework.BusinessLogic.DBObject Namespace | DataBaseObjectException Constructor Overload List


DataBaseObjectException Constructor (String)

public DataBaseObjectException(
String Message
);

See Also

DataBaseObjectException Class | Aptify.Framework.BusinessLogic.DBObject Namespace | DataBaseObjectException Constructor Overload List


DataBaseObjectException Constructor (String, Exception)

public DataBaseObjectException(
String Message,
Exception InnerException
);

See Also

DataBaseObjectException Class | Aptify.Framework.BusinessLogic.DBObject Namespace | DataBaseObjectException Constructor Overload List


IDatabaseObject Interface

For a list of all members of this type, see IDatabaseObject Members.

public interface IDatabaseObject

Types that implement IDatabaseObject

Type | Description
DatabaseObjectEntity |

Requirements

Namespace: Aptify.Framework.BusinessLogic.DBObject

Assembly: AptifyDBObjectInterfaces (in AptifyDBObjectInterfaces.dll)

See Also

IDatabaseObject Members | Aptify.Framework.BusinessLogic.DBObject Namespace


IDatabaseObject Members

IDatabaseObject overview

Public Instance Methods

Recompile

See Also

IDatabaseObject Interface | Aptify.Framework.BusinessLogic.DBObject Namespace


IDatabaseObject Methods

The methods of the IDatabaseObject interface are listed below. For a complete list of IDatabaseObject interface members, see the IDatabaseObject Members topic.

Public Instance Methods

Recompile

See Also

IDatabaseObject Interface | Aptify.Framework.BusinessLogic.DBObject Namespace


IDatabaseObject.Recompile Method

void Recompile();

See Also

IDatabaseObject Interface | Aptify.Framework.BusinessLogic.DBObject Namespace


Aptify.Framework.BusinessLogic.DBObject.Exceptions

Aptify 5.0 Software Development Kit (SDK)

Aptify.Framework.BusinessLogic.DBObject.Exceptions Namespace

This namespace contains the functionality that handles the possible exceptions that can be thrown when working with Database Objects in Aptify.

Namespace hierarchy

Classes

Class | Description
DBObjectException |


DBObjectException Class

For a list of all members of this type, see DBObjectException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
DBObjectException

public class DBObjectException : BaseApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.DBObject.Exceptions

Assembly: AptifyDBObjectInterfaces (in AptifyDBObjectInterfaces.dll)

See Also

DBObjectException Members | Aptify.Framework.BusinessLogic.DBObject.Exceptions Namespace


DBObjectException Members

DBObjectException overview

Public Instance Constructors

DBObjectException Overloaded. Initializes a new instance of the DBObjectException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message |
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DBObjectException Class | Aptify.Framework.BusinessLogic.DBObject.Exceptions Namespace


DBObjectException Constructor

Overload List

public DBObjectException(SerializationInfo,StreamingContext);

public DBObjectException(String);

See Also

DBObjectException Class | Aptify.Framework.BusinessLogic.DBObject.Exceptions Namespace


DBObjectException Constructor (String)

public DBObjectException(
String Message
);

See Also

DBObjectException Class | Aptify.Framework.BusinessLogic.DBObject.Exceptions Namespace | DBObjectException Constructor Overload List


DBObjectException Constructor (SerializationInfo, StreamingContext)

public DBObjectException(
SerializationInfo Info,
StreamingContext Context
);

See Also

DBObjectException Class | Aptify.Framework.BusinessLogic.DBObject.Exceptions Namespace | DBObjectException Constructor Overload List


DBObjectException Properties

The properties of the DBObjectException class are listed below. For a complete list of DBObjectException class members, see the DBObjectException Members topic.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message |
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

See Also

DBObjectException Class | Aptify.Framework.BusinessLogic.DBObject.Exceptions Namespace


Message Property

Aptify 5.0 Software Development Kit (SDK)

DBObjectException.Message Property

public override String Message {get;}

See Also

DBObjectException Class | Aptify.Framework.BusinessLogic.DBObject.Exceptions Namespace


DBObjectException Methods

The methods of the DBObjectException class are listed below. For a complete list of DBObjectException class members, see the DBObjectException Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DBObjectException Class | Aptify.Framework.BusinessLogic.DBObject.Exceptions Namespace


DBObjectException.GetObjectData Method

public override void GetObjectData(
SerializationInfo Info,
StreamingContext Context
);

Implements

ISerializable.

See Also

DBObjectException Class | Aptify.Framework.BusinessLogic.DBObject.Exceptions Namespace


Aptify.Framework.BusinessLogic.DuplicateProcessing

Aptify 5.0 Software Development Kit (SDK)

Aptify.Framework.BusinessLogic.DuplicateProcessing Namespace

The objects in the namespace correspond to Aptify's Duplicate Processing functionality to identify and handle duplicate records in the database.

Namespace hierarchy

Classes

Class | Description
DupeEligibleEntity | Class used to define the attributes of Entities which are eligible for dupe checking.
DupeEntity |
DupeProcessor | The Dupe Processor class is used for batch processing of a duplicate process for an entity. In some cases, it is desireable to implement a post process which can check for duplicates across the database over type. It is also utilized internally by the Replication process to check for duplicates when synchronization is completed.
DuplicateViewer |

Enumerations

Enumeration | Description
DupeEntity.MergeRetainRuleTypes | Defines a set of rules available for the MergeRecords method.


DupeEligibleEntity Class

Class used to define the attributes of Entities which are eligible for dupe checking.

For a list of all members of this type, see DupeEligibleEntity Members.

System.Object
DupeEligibleEntity

public class DupeEligibleEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.DuplicateProcessing

Assembly: AptifyDuplicatesObject (in AptifyDuplicatesObject.dll)

See Also

DupeEligibleEntity Members | Aptify.Framework.BusinessLogic.DuplicateProcessing Namespace


DupeEligibleEntity Members

DupeEligibleEntity overview

Public Instance Constructors

DupeEligibleEntity Constructor Constructor method for the DupeEligibleEntity object.

Public Instance Properties

DupeProcessor | Property referencing the DupeProcessor object.
EntityID | ID of the entity.
EntityName | Name of the entity.
IDList | ArrayList defining the IDs to be used in the dupe checking process.

Public Instance Methods

DetectDuplicates | Method used to process a list of records of the current entity to determine if they have duplicates.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
LoadRecentInserts | Overloaded. Methods which obtains the IDs of the most recent inserts into the database, using the record history functionality.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
WriteDuplicateToQueue | Overloaded. Method that creates a Duplicate Record entity record with the provided RecordIDs.

See Also

DupeEligibleEntity Class | Aptify.Framework.BusinessLogic.DuplicateProcessing Namespace


DupeEligibleEntity Constructor

Constructor method for the DupeEligibleEntity object.

public DupeEligibleEntity(
ref DupeProcessor& DupeProcessor
);

Parameters

DupeProcessor
Reference to the DupeProcessor object.

Remarks

See Also

DupeEligibleEntity Class | Aptify.Framework.BusinessLogic.DuplicateProcessing Namespace


DupeEligibleEntity Properties

The properties of the DupeEligibleEntity class are listed below. For a complete list of DupeEligibleEntity class members, see the DupeEligibleEntity Members topic.

Public Instance Properties

DupeProcessor | Property referencing the DupeProcessor object.
EntityID | ID of the entity.
EntityName | Name of the entity.
IDList | ArrayList defining the IDs to be used in the dupe checking process.

See Also

DupeEligibleEntity Class | Aptify.Framework.BusinessLogic.DuplicateProcessing Namespace


DupeProcessor Property

Aptify 5.0 Software Development Kit (SDK)

DupeEligibleEntity.DupeProcessor Property

Property referencing the DupeProcessor object.

public DupeProcessor DupeProcessor {get;}

Property Value

Remarks

See Also

DupeEligibleEntity Class | Aptify.Framework.BusinessLogic.DuplicateProcessing Namespace


EntityID Property

Aptify 5.0 Software Development Kit (SDK)

DupeEligibleEntity.EntityID Property

ID of the entity.

public Int64 EntityID {get; set;}

Property Value

Remarks

See Also

DupeEligibleEntity Class | Aptify.Framework.BusinessLogic.DuplicateProcessing Namespace


EntityName Property

Aptify 5.0 Software Development Kit (SDK)

DupeEligibleEntity.EntityName Property

Name of the entity.

public String EntityName {get; set;}

Property Value

Remarks

See Also

DupeEligibleEntity Class | Aptify.Framework.BusinessLogic.DuplicateProcessing Namespace


IDList Property

Aptify 5.0 Software Development Kit (SDK)

DupeEligibleEntity.IDList Property

ArrayList defining the IDs to be used in the dupe checking process.

public ArrayList IDList {get;}

Property Value

Remarks

See Also

DupeEligibleEntity Class | Aptify.Framework.BusinessLogic.DuplicateProcessing Namespace


DupeEligibleEntity Methods

The methods of the DupeEligibleEntity class are listed below. For a complete list of DupeEligibleEntity class members, see the DupeEligibleEntity Members topic.

Public Instance Methods

DetectDuplicates | Method used to process a list of records of the current entity to determine if they have duplicates.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
LoadRecentInserts | Overloaded. Methods which obtains the IDs of the most recent inserts into the database, using the record history functionality.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
WriteDuplicateToQueue | Overloaded. Method that creates a Duplicate Record entity record with the provided RecordIDs.

See Also

DupeEligibleEntity Class | Aptify.Framework.BusinessLogic.DuplicateProcessing Namespace


DupeEligibleEntity.DetectDuplicates Method

Method used to process a list of records of the current entity to determine if they have duplicates.

public void DetectDuplicates(
ArrayList arlRecordIDs
);

Parameters

arlRecordIDs
ArrayList of IDs to check.

Remarks

See Also

DupeEligibleEntity Class | Aptify.Framework.BusinessLogic.DuplicateProcessing Namespace


LoadRecentInserts Method

Aptify 5.0 Software Development Kit (SDK)

DupeEligibleEntity.LoadRecentInserts Method

Methods which obtains the IDs of the most recent inserts into the database, using the record history functionality.

Overload List

Methods which obtains the IDs of the most recent inserts into the database, using the record history functionality.

public long LoadRecentInserts(DateTime);

Methods which obtains the IDs of the most recent inserts into the database, using the record history functionality.

public long LoadRecentInserts(DateTime,Boolean);

See Also

DupeEligibleEntity Class | Aptify.Framework.BusinessLogic.DuplicateProcessing Namespace


DupeEligibleEntity.LoadRecentInserts Method (DateTime)

Methods which obtains the IDs of the most recent inserts into the database, using the record history functionality.

public long LoadRecentInserts(
DateTime dStartDate
);

Parameters

dStartDate
Date provided as a begin date for searching for newly inserted records.

Return Value

Remarks

This method requires record history to be enabled on a given entity for duplicate processing to be effective.

See Also

DupeEligibleEntity Class | Aptify.Framework.BusinessLogic.DuplicateProcessing Namespace | DupeEligibleEntity.LoadRecentInserts Overload List


DupeEligibleEntity.LoadRecentInserts Method (DateTime, Boolean)

Methods which obtains the IDs of the most recent inserts into the database, using the record history functionality.

public long LoadRecentInserts(
DateTime dStartDate,
Boolean bDetectDuplicates
);

Parameters

dStartDate
Date provided as a begin date for searching for newly inserted records.
bDetectDuplicates
Boolean indicating if the Duplicate Detection process should be launched once the new inserts are found.

Return Value

Remarks

This method requires record history to be enabled on a given entity for duplicate processing to be effective.

See Also

DupeEligibleEntity Class | Aptify.Framework.BusinessLogic.DuplicateProcessing Namespace | DupeEligibleEntity.LoadRecentInserts Overload List


WriteDuplicateToQueue Method

Aptify 5.0 Software Development Kit (SDK)

DupeEligibleEntity.WriteDuplicateToQueue Method

Method that creates a Duplicate Record entity record with the provided RecordIDs.

Overload List

Method that creates a Duplicate Record entity record with the provided RecordIDs.

protected void WriteDuplicateToQueue(ArrayList,Int32);

Method that creates a Duplicate Record entity record with the provided RecordIDs.

protected void WriteDuplicateToQueue(Int64[],Int32);

See Also

DupeEligibleEntity Class | Aptify.Framework.BusinessLogic.DuplicateProcessing Namespace


DupeEligibleEntity.WriteDuplicateToQueue Method (ArrayList, Int32)

Method that creates a Duplicate Record entity record with the provided RecordIDs.

protected void WriteDuplicateToQueue(
ArrayList RecordIDs,
Int32 iScore
);

Parameters

RecordIDs
List of record IDs.
iScore
Score indicates the severity of the duplicate records. For future use.

Remarks

See Also

DupeEligibleEntity Class | Aptify.Framework.BusinessLogic.DuplicateProcessing Namespace | DupeEligibleEntity.WriteDuplicateToQueue Overload List


DupeEligibleEntity.WriteDuplicateToQueue Method (Int64[], Int32)

Method that creates a Duplicate Record entity record with the provided RecordIDs.

protected void WriteDuplicateToQueue(
Int64[] Records,
Int32 iScore
);

Parameters

Records
Array of record IDs provided for the detail of the duplicate.
iScore
Score indicates the severity of the duplicate records. For future use.

Remarks

See Also

DupeEligibleEntity Class | Aptify.Framework.BusinessLogic.DuplicateProcessing Namespace | DupeEligibleEntity.WriteDuplicateToQueue Overload List


DupeEntity Class

For a list of all members of this type, see DupeEntity Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
DupeEntity

public class DupeEntity : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.DuplicateProcessing

Assembly: AptifyDuplicatesObject (in AptifyDuplicatesObject.dll)

See Also

DupeEntity Members | Aptify.Framework.BusinessLogic.DuplicateProcessing Namespace


DupeEntity Members

DupeEntity overview

Public Instance Constructors

DupeEntity Constructor Initializes a new instance of the DupeEntity class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordIDs | Overloaded. Method which returns an ArrayList containing the IDs from the DuplicateRecordDetail subtype.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
MergeRecords | Overloaded. Method used to merge the records contained in the DuplicateRecordDetail subtype, using the rule supplied.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateDupeStatuses | Method used to update the duplicate status of a duplicate records record.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

DupeEntity Class | Aptify.Framework.BusinessLogic.DuplicateProcessing Namespace


DupeEntity Constructor

Initializes a new instance of the DupeEntity class.

public DupeEntity();

See Also

DupeEntity Class | Aptify.Framework.BusinessLogic.DuplicateProcessing Namespace


DupeEntity Methods

The methods of the DupeEntity class are listed below. For a complete list of DupeEntity class members, see the DupeEntity Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordIDs | Overloaded. Method which returns an ArrayList containing the IDs from the DuplicateRecordDetail subtype.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
MergeRecords | Overloaded. Method used to merge the records contained in the DuplicateRecordDetail subtype, using the rule supplied.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateDupeStatuses | Method used to update the duplicate status of a duplicate records record.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

DupeEntity Class | Aptify.Framework.BusinessLogic.DuplicateProcessing Namespace


GetRecordIDs Method

Aptify 5.0 Software Development Kit (SDK)

DupeEntity.GetRecordIDs Method

Method which returns an ArrayList containing the IDs from the DuplicateRecordDetail subtype.

Overload List

Method which returns an ArrayList containing the IDs from the DuplicateRecordDetail subtype.

public ArrayList GetRecordIDs();

Method which returns an ArrayList containing the IDs from the DuplicateRecordDetail subtype, excluding the ID supplied in the RetainID parameter.

public ArrayList GetRecordIDs(Int64);

See Also

DupeEntity Class | Aptify.Framework.BusinessLogic.DuplicateProcessing Namespace


DupeEntity.GetRecordIDs Method ()

Method which returns an ArrayList containing the IDs from the DuplicateRecordDetail subtype.

public ArrayList GetRecordIDs();

Return Value

Remarks

See Also

DupeEntity Class | Aptify.Framework.BusinessLogic.DuplicateProcessing Namespace | DupeEntity.GetRecordIDs Overload List


DupeEntity.GetRecordIDs Method (Int64)

Method which returns an ArrayList containing the IDs from the DuplicateRecordDetail subtype, excluding the ID supplied in the RetainID parameter.

public ArrayList GetRecordIDs(
Int64 RetainID
);

Parameters

RetainID
The ID of the record to exclude from the ArrayList.

Return Value

Remarks

This overload is called when the list to be returned is used to enumerate the records which will be removed in the merge process while excluding the ID to be retained.

See Also

DupeEntity Class | Aptify.Framework.BusinessLogic.DuplicateProcessing Namespace | DupeEntity.GetRecordIDs Overload List


MergeRecords Method

Aptify 5.0 Software Development Kit (SDK)

DupeEntity.MergeRecords Method

Method used to merge the records contained in the DuplicateRecordDetail subtype, using the rule supplied.

Overload List

Method used to merge the records contained in the DuplicateRecordDetail subtype, using the rule supplied.

public void MergeRecords(DupeEntity.MergeRetainRuleTypes);

Method used to merge the records contained in the DuplicateRecordDetail subtype, using an ID provided.

public void MergeRecords(Int64);

See Also

DupeEntity Class | Aptify.Framework.BusinessLogic.DuplicateProcessing Namespace


DupeEntity.MergeRecords Method (MergeRetainRuleTypes)

Method used to merge the records contained in the DuplicateRecordDetail subtype, using the rule supplied.

public void MergeRecords(
DupeEntity.MergeRetainRuleTypes RecordRetainRule
);

Parameters

RecordRetainRule
Parameter that indicates the rule to employ when selecting a surviving record id.

Remarks

See Also

DupeEntity Class | Aptify.Framework.BusinessLogic.DuplicateProcessing Namespace | DupeEntity.MergeRecords Overload List


DupeEntity.MergeRecords Method (Int64)

Method used to merge the records contained in the DuplicateRecordDetail subtype, using an ID provided.

public void MergeRecords(
Int64 SurvivingID
);

Parameters

SurvivingID
The ID of the record to retain in the merge process.

Remarks

See Also

DupeEntity Class | Aptify.Framework.BusinessLogic.DuplicateProcessing Namespace | DupeEntity.MergeRecords Overload List


DupeEntity.UpdateDupeStatuses Method

Method used to update the duplicate status of a duplicate records record.

public void UpdateDupeStatuses(
Int64 SurvivingID,
ArrayList DeletedIDs
);

Parameters

SurvivingID
Parameter identifying the ID of the surviving record.
DeletedIDs
Parameter identifying a list of deleted IDs.

Remarks

See Also

DupeEntity Class | Aptify.Framework.BusinessLogic.DuplicateProcessing Namespace


DupeEntity.MergeRetainRuleTypes Enumeration

Defines a set of rules available for the MergeRecords method.

public enum DupeEntity.MergeRetainRuleTypes

Remarks

Members

Member Name | Description
RetainFirst | Indicates that the first record in the detail subtype should be retained.
RetainMostDependencies | Indicates that the record having the most dependencies should be retained.

Requirements

Namespace: Aptify.Framework.BusinessLogic.DuplicateProcessing

Assembly: AptifyDuplicatesObject (in AptifyDuplicatesObject.dll)

See Also

Aptify.Framework.BusinessLogic.DuplicateProcessing Namespace


DupeProcessor Class

The Dupe Processor class is used for batch processing of a duplicate process for an entity. In some cases, it is desireable to implement a post process which can check for duplicates across the database over type. It is also utilized internally by the Replication process to check for duplicates when synchronization is completed.

For a list of all members of this type, see DupeProcessor Members.

System.Object
DupeProcessor

public class DupeProcessor

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.DuplicateProcessing

Assembly: AptifyDuplicatesObject (in AptifyDuplicatesObject.dll)

See Also

DupeProcessor Members | Aptify.Framework.BusinessLogic.DuplicateProcessing Namespace


DupeProcessor Members

DupeProcessor overview

Public Instance Constructors

DupeProcessor Overloaded. Initializes a new instance of the DupeProcessor class.

Public Instance Properties

AppObject | Property containing a reference to the Application Object.
EligibleEntities | Dictionary of DupeEligibleEntity objects.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
LoadEligibleEntities | Method used to configure the DupeProcessor by loading up the EligibleEntities dictionary.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DupeProcessor Class | Aptify.Framework.BusinessLogic.DuplicateProcessing Namespace


DupeProcessor Constructor

Constructor method to be used only by the Process Pipeline engine. Developers should use the New(UserCredentials) signature.

Overload List

Constructor method to be used only by the Process Pipeline engine. Developers should use the New(UserCredentials) signature.

public DupeProcessor();

Constructor method to be used when this object is called directly.

public DupeProcessor(UserCredentials);

See Also

DupeProcessor Class | Aptify.Framework.BusinessLogic.DuplicateProcessing Namespace


DupeProcessor Constructor ()

Constructor method to be used only by the Process Pipeline engine. Developers should use the New(UserCredentials) signature.

public DupeProcessor();

Remarks

See Also

DupeProcessor Class | Aptify.Framework.BusinessLogic.DuplicateProcessing Namespace | DupeProcessor Constructor Overload List


DupeProcessor Constructor (UserCredentials)

Constructor method to be used when this object is called directly.

public DupeProcessor(
UserCredentials UserCredentials
);

Parameters

UserCredentials

Remarks

See Also

DupeProcessor Class | Aptify.Framework.BusinessLogic.DuplicateProcessing Namespace | DupeProcessor Constructor Overload List


DupeProcessor Properties

The properties of the DupeProcessor class are listed below. For a complete list of DupeProcessor class members, see the DupeProcessor Members topic.

Public Instance Properties

AppObject | Property containing a reference to the Application Object.
EligibleEntities | Dictionary of DupeEligibleEntity objects.

See Also

DupeProcessor Class | Aptify.Framework.BusinessLogic.DuplicateProcessing Namespace


AppObject Property

Aptify 5.0 Software Development Kit (SDK)

DupeProcessor.AppObject Property

Property containing a reference to the Application Object.

public AptifyApplication AppObject {get;}

Property Value

Remarks

See Also

DupeProcessor Class | Aptify.Framework.BusinessLogic.DuplicateProcessing Namespace


EligibleEntities Property

Aptify 5.0 Software Development Kit (SDK)

DupeProcessor.EligibleEntities Property

Dictionary of DupeEligibleEntity objects.

public Dictionary<TKey,TValue> EligibleEntities {get;}

Property Value

Remarks

Used to describe enumerate the entities which have duplicate check objects associated with them.

See Also

DupeProcessor Class | Aptify.Framework.BusinessLogic.DuplicateProcessing Namespace


DupeProcessor Methods

The methods of the DupeProcessor class are listed below. For a complete list of DupeProcessor class members, see the DupeProcessor Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
LoadEligibleEntities | Method used to configure the DupeProcessor by loading up the EligibleEntities dictionary.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DupeProcessor Class | Aptify.Framework.BusinessLogic.DuplicateProcessing Namespace


DupeProcessor.LoadEligibleEntities Method

Method used to configure the DupeProcessor by loading up the EligibleEntities dictionary.

public void LoadEligibleEntities();

Remarks

See Also

DupeProcessor Class | Aptify.Framework.BusinessLogic.DuplicateProcessing Namespace


DuplicateViewer Class

For a list of all members of this type, see DuplicateViewer Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
DuplicateViewer

public class DuplicateViewer : Form, IAptifyTopLevelViewer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.DuplicateProcessing

Assembly: AptifyDuplicatesUI (in AptifyDuplicatesUI.dll)

See Also

DuplicateViewer Members | Aptify.Framework.BusinessLogic.DuplicateProcessing Namespace


DuplicateViewer Members

DuplicateViewer overview

Public Instance Constructors

DuplicateViewer Constructor Initializes a new instance of the DuplicateViewer class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config | Overloaded. Method used for initialization of the entity viewer.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show | Overloaded. Method used to display the viewer form.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
ShowDialog | Overloaded. Method used to display the viewer form in dialog mode.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog with the specified owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

DuplicateViewer Class | Aptify.Framework.BusinessLogic.DuplicateProcessing Namespace


DuplicateViewer Constructor

Initializes a new instance of the DuplicateViewer class.

public DuplicateViewer();

See Also

DuplicateViewer Class | Aptify.Framework.BusinessLogic.DuplicateProcessing Namespace


DuplicateViewer Methods

The methods of the DuplicateViewer class are listed below. For a complete list of DuplicateViewer class members, see the DuplicateViewer Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config | Overloaded. Method used for initialization of the entity viewer.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show | Overloaded. Method used to display the viewer form.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
ShowDialog | Overloaded. Method used to display the viewer form in dialog mode.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog with the specified owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

DuplicateViewer Class | Aptify.Framework.BusinessLogic.DuplicateProcessing Namespace


Config Method

Aptify 5.0 Software Development Kit (SDK)

DuplicateViewer.Config Method

Method used for initialization of the entity viewer.

Overload List

Method used for initialization of the entity viewer.

public void Config(AptifyGenericEntityBase);

Method used for initialization of the entity viewer.

public void Config(UserCredentials,String);

Method used for initialization of the entity viewer.

public void Config(UserCredentials,String,Int64);

Method used for initialization of the entity viewer.

public void Config(UserCredentials,String,String);

See Also

DuplicateViewer Class | Aptify.Framework.BusinessLogic.DuplicateProcessing Namespace


DuplicateViewer.Config Method (AptifyGenericEntityBase)

Method used for initialization of the entity viewer.

public void Config(
AptifyGenericEntityBase GE
);

Parameters

GE
Generic Entity representing the record to be displayed inside the form.

Implements

IAptifyTopLevelViewer.

Remarks

See Also

DuplicateViewer Class | Aptify.Framework.BusinessLogic.DuplicateProcessing Namespace | DuplicateViewer.Config Overload List


DuplicateViewer.Config Method (UserCredentials, String)

Method used for initialization of the entity viewer.

public void Config(
UserCredentials UserCredentials,
String CmdString
);

Parameters

UserCredentials
UserCredentials object representing the current Aptify session.
CmdString
Operation desired to be performed in the viewer form.

Implements

IAptifyTopLevelViewer.

Remarks

See Also

DuplicateViewer Class | Aptify.Framework.BusinessLogic.DuplicateProcessing Namespace | DuplicateViewer.Config Overload List


DuplicateViewer.Config Method (UserCredentials, String, Int64)

Method used for initialization of the entity viewer.

public void Config(
UserCredentials UserCredentials,
String EntityName,
Int64 RecordID
);

Parameters

UserCredentials
UserCredentials object representing the current Aptify session.
EntityName
Name of the entity to be represented by the form.
RecordID
ID of the record to be represented by the form.

Implements

IAptifyTopLevelViewer.

Remarks

See Also

DuplicateViewer Class | Aptify.Framework.BusinessLogic.DuplicateProcessing Namespace | DuplicateViewer.Config Overload List


DuplicateViewer.Config Method (UserCredentials, String, String)

Method used for initialization of the entity viewer.

public void Config(
UserCredentials UserCredentials,
String EntityName,
String NewRecordParameters
);

Parameters

UserCredentials
UserCredentials object representing the current Aptify session.
EntityName
Name of the entity to be represented by the form.
NewRecordParameters
Set of key/value pairs used to populate the underlying Generic Entity during initialization of a new record.

Implements

IAptifyTopLevelViewer.

Remarks

See Also

DuplicateViewer Class | Aptify.Framework.BusinessLogic.DuplicateProcessing Namespace | DuplicateViewer.Config Overload List


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

DuplicateViewer.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

DuplicateViewer Class | Aptify.Framework.BusinessLogic.DuplicateProcessing Namespace


DuplicateViewer.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

DuplicateViewer Class | Aptify.Framework.BusinessLogic.DuplicateProcessing Namespace | DuplicateViewer.Dispose Overload List


Show Method

Aptify 5.0 Software Development Kit (SDK)

DuplicateViewer.Show Method

Method used to display the viewer form.

Overload List

Method used to display the viewer form.

new public void Show();

Method used to display the viewer form.

public void Show(Form);

Inherited from Form.

public void Show(IWin32Window);

See Also

DuplicateViewer Class | Aptify.Framework.BusinessLogic.DuplicateProcessing Namespace


DuplicateViewer.Show Method ()

Method used to display the viewer form.

new public void Show();

Implements

IAptifyTopLevelViewer.

Remarks

See Also

DuplicateViewer Class | Aptify.Framework.BusinessLogic.DuplicateProcessing Namespace | DuplicateViewer.Show Overload List


DuplicateViewer.Show Method (Form)

Method used to display the viewer form.

public void Show(
Form ParentForm
);

Parameters

ParentForm
Parameter used to provide a reference to the Parent Form object.

Implements

IAptifyTopLevelViewer.

Remarks

See Also

DuplicateViewer Class | Aptify.Framework.BusinessLogic.DuplicateProcessing Namespace | DuplicateViewer.Show Overload List


ShowDialog Method

Aptify 5.0 Software Development Kit (SDK)

DuplicateViewer.ShowDialog Method

Method used to display the viewer form in dialog mode.

Overload List

Method used to display the viewer form in dialog mode.

new public DialogResult ShowDialog();

Method used to display the viewer form in dialog mode.

public DialogResult ShowDialog(Form);

Inherited from Form.

public DialogResult ShowDialog(IWin32Window);

See Also

DuplicateViewer Class | Aptify.Framework.BusinessLogic.DuplicateProcessing Namespace


DuplicateViewer.ShowDialog Method ()

Method used to display the viewer form in dialog mode.

new public DialogResult ShowDialog();

Return Value

Implements

IAptifyTopLevelViewer.

Remarks

See Also

DuplicateViewer Class | Aptify.Framework.BusinessLogic.DuplicateProcessing Namespace | DuplicateViewer.ShowDialog Overload List


DuplicateViewer.ShowDialog Method (Form)

Method used to display the viewer form in dialog mode.

public DialogResult ShowDialog(
Form ParentForm
);

Parameters

ParentForm
Form object which raised the current form.

Return Value

Implements

IAptifyTopLevelViewer.

Remarks

See Also

DuplicateViewer Class | Aptify.Framework.BusinessLogic.DuplicateProcessing Namespace | DuplicateViewer.ShowDialog Overload List


Aptify.Framework.BusinessLogic.Entity

Aptify 5.0 Software Development Kit (SDK)

Aptify.Framework.BusinessLogic.Entity Namespace

This namespace contains objects related to common Entity functionality as well as viewer forms for certain entities. This includes working with records in the Entities entity, Base Fields, Entity Bulk Operations, the Event Handler form, the Form Templates form, the Process Flow form, and Topic Codes functionality.

Namespace hierarchy

Classes

Class | Description
BaseFieldsEntity | Provides additional functionality required during the save of an Aptify Base Fields entity record.
BaseFieldsStatusForm |
Constants |
EntitiesEntity | Aptify Entities Entity GE Sub-Class. This class implements all of the functionality related to entity management as a sub-class to the AptifyGenericEntityBase class.
EntityBaseViewsEntity |
EntityBulkOperation | The standard Aptify implementation of IEntityBulkOperation
EntityBulkOperationException | This exception may be thrown while an Entity Bulk Operation is attempting to process.
EntityBulkOperationGroupPermissionsViewer | This is the custom viewer data form for Enity Bulk Operations GroupPermissions subtype entity.
EntityBulkOperationProcess | The standard Aptify implementation of the IEntityBulkOperationProcessor interface.
EntityBulkOperationRulesViewer | This is the custom viewer data form for Enity Bulk Operations Rules subtype entity.
EntityBulkOperationsDashboardButtonPropertiesPage |
EntityBulkOperationsRibbonButtonPropertiesPage |
EntityBulkOperationsViewer | This is the custom viewer data form for Enity Bulk Operations entity.
EntityBulkOperationsWizardForm | Provides the user interface for the standard Aptify Entity Bulk Operations Wizard.
EntityBulkOperationUserPermissionsViewer | This is the custom viewer data form for Enity Bulk Operations UserPermissions subtype entity.
EntityConstraintsEntity | This is the Data Plug-In that should be used with the Entity Constraints entity.
EntityDefaultBaseViewsEntity |
EntityFieldsEntity |
EntityUserPermissionsEntity |
EventDefinitionsViewer | Provides a custom GUI for the [Event Definitions] entity.
EventHandlerDetailForm |
EventHandlerFormComponent |
EventHandlerRecordsViewer | Provides a custom GUI for the [Event Handlers Record Viewer] entity.
EventHandlersViewer | This form is used as a Plug-In Viewer for the Event Handlers entity.
FormTemplatePartsViewer | This is a custom form that should be used with form templates
FormTemplatesEntity | This is the GE wrapper for Form Templates.
FormTemplatesViewer | This is a custom form that should be used with form templates
GeneratedLabel | This is used to display Generate or Not Generated
MailMergeException | The base application that is thrown from MailMergeTemplate classes.
ProcessFlowStepControl |
RunEntityBulkOperationProcessComponent | Process Component that runs an Entity Bulk Operation on a specified record set.
TopicCodeLinksEntity | This class is the GE wrapper around the Topic Code Links Entity
TopicCodeLinksGeneralTab |
TopicCodeSelector | Implements functionality that finds records in the database that match a set of selected topic codes. Functionality can be used for any business application that needs to look for records in any entity that are linked to one or more topic codes. This class provides for a generic implementation model for selection of records using an object-based filtering model. For more information, see the FindRecords method of this class.
TopicCodeSelector.TopicCodeLink | Utility class that provides information about a topic code link record
TopicCodeSelector.TopicCodeLinkedRecord | Utility class that provides information about a record that is linked to a topic code.
TopicCodesEntity | This class is the GE wrapper around the Topic Codes Entity
TopicCodesGeneralTab | This tab contains all of the logic needed to properly display the General Tab of the Topic Codes Entity.
TopicCodesTopicCodeLinksTab | This tab contains all of the logic needed to properly display the Topic Code Links of the Topic Codes Entity.

Interfaces

Interface | Description
IEntityBulkOperation | The IEntityBulkOperation interface represents a singular Entity Bulk Operation.
IEntityBulkOperationProcessor | The IEntityBulkOperationProcessor interface represents a batch of Entity Bulk Operations
IEntityInstall |
IEntitySchema |
IMailMerge | Allows a User to Perform a Mail Merge based on a View and a Template.

Enumerations

Enumeration | Description
EntitiesEntity.EntityDBObject |
EventHandlerType |
LaunchOption | Specifies an initial action for an item at startup.
TopicCodeSelector.TopicCodeLinkStatus |
TopicCodeValueType | Possible topic code value type enumeration


BaseFieldsEntity Class

Provides additional functionality required during the save of an Aptify Base Fields entity record.

For a list of all members of this type, see BaseFieldsEntity Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
BaseFieldsEntity

public class BaseFieldsEntity : AptifyGenericEntity, IStatus

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.Entity

Assembly: AptifyBaseFieldsModule (in AptifyBaseFieldsModule.dll)

See Also

BaseFieldsEntity Members | Aptify.Framework.BusinessLogic.Entity Namespace


BaseFieldsEntity Members

BaseFieldsEntity overview

Public Instance Constructors

BaseFieldsEntity Constructor Initializes a new instance of the BaseFieldsEntity class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
Status | Attaching to the status property allows objects to be notified of incremental status changes.
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded. Performs a standard Generic Entity Save and then propagates changes to all dependent base fields in the system.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Canceled | This event is raised if a user decides to cancel the Flow Down operation.
Finished | Finished will be raised before exiting the Save member regardless of the status of the save.
StatusChanged | This event is raised when a member of the Status property is changed.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

BaseFieldsEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


BaseFieldsEntity Constructor

Initializes a new instance of the BaseFieldsEntity class.

public BaseFieldsEntity();

See Also

BaseFieldsEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


BaseFieldsEntity Properties

The properties of the BaseFieldsEntity class are listed below. For a complete list of BaseFieldsEntity class members, see the BaseFieldsEntity Members topic.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
Status | Attaching to the status property allows objects to be notified of incremental status changes.
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

BaseFieldsEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


Status Property

Aptify 5.0 Software Development Kit (SDK)

BaseFieldsEntity.Status Property

Attaching to the status property allows objects to be notified of incremental status changes.

public Status Status {get;}

Property Value

The current Status object.

Implements

IStatus.

Remarks

Any caller that needs to monitor the status of the process should attach to the status object and then monitor the Status changed event. The monitoring process should attempt to ensure thread safety.

 Public Class BaseFieldsStatusForm
 Inherits System.Windows.Forms.Form

    Private WithEvents m_oStatus As Application.Status

    Public Property Status() As Application.Status
         Get
            Try
                Return Me.m_oStatus
            Catch ex As Exception
                'just publish and swallow
                ExceptionManagement.ExceptionManager.Publish(ex)
            End Try
        End Get
        Set(ByVal Value As Application.Status)
            Try
                Me.m_oStatus = Value
            Catch ex As Exception
                'just publish and swallow
                ExceptionManagement.ExceptionManager.Publish(ex)
            End Try
        End Set
    End Property

    Private Sub UpdateStatus()
        Try
            Dim iPercentDone As Integer = 0
            Me.lblCaption.Text = Me.m_oStatus.Message
            If Me.m_oStatus.Total > 0 Then
                iPercentDone = CInt((Me.m_oStatus.Completed / Me.m_oStatus.Total) * 100)
            End If
            Windows.Forms.MessageBox.Show(iPercentDone)
            If Me.WindowState = Windows.Forms.FormWindowState.Minimized Then
                Windows.Forms.MessageBox.Show(String.Concat(iPercentDone, "% Complete"))
            Else
                Windows.Forms.MessageBox.Show("Message Run Status")
            End If
        Catch ex As Exception
            'just publish and swallow
            ExceptionManagement.ExceptionManager.Publish(ex)
        End Try
    End Sub

    Private Sub m_oStatus_StatusChanged(ByVal Sender As Object, ByVal e As Application.StatusChangedEventArgs) Handles m_oStatus.StatusChanged
        Try
            If Not Me.IsDisposed AndAlso Me.IsHandleCreated Then
                If Me.InvokeRquired Then
                    Me.BeginInvoke(New Windows.Forms.MethodInvoker(AddressOf Me.UpdateStatus))
                Else
                    Me.UpdateStatus
                End If
            End If
        Catch ex As Exception
            'just publish and swallow
            ExceptionManagement.ExceptionManager.Publish(ex)
        End Try
    End Sub
 End Class

See Also

BaseFieldsEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


BaseFieldsEntity Methods

The methods of the BaseFieldsEntity class are listed below. For a complete list of BaseFieldsEntity class members, see the BaseFieldsEntity Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded. Performs a standard Generic Entity Save and then propagates changes to all dependent base fields in the system.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

BaseFieldsEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


Save Method

Aptify 5.0 Software Development Kit (SDK)

BaseFieldsEntity.Save Method

Performs a standard Generic Entity Save and then propagates changes to all dependent base fields in the system.

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Save();

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean,ref String&);

Performs a standard Generic Entity Save and then propagates changes to all dependent base fields in the system.

public override bool Save(Boolean,ref String&,String);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(ref String&);

See Also

BaseFieldsEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


BaseFieldsEntity.Save Method (Boolean, String&, String)

Performs a standard Generic Entity Save and then propagates changes to all dependent base fields in the system.

public override bool Save(
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

Parameters

AllowGUI
ErrorString
TransactionID

Return Value

Remarks

See Also

BaseFieldsEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace | BaseFieldsEntity.Save Overload List


BaseFieldsEntity Events

The events of the BaseFieldsEntity class are listed below. For a complete list of BaseFieldsEntity class members, see the BaseFieldsEntity Members topic.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Canceled | This event is raised if a user decides to cancel the Flow Down operation.
Finished | Finished will be raised before exiting the Save member regardless of the status of the save.
StatusChanged | This event is raised when a member of the Status property is changed.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

See Also

BaseFieldsEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


BaseFieldsEntity.EventHandler Event

This event is raised if a user decides to cancel the Flow Down operation.

public event EventHandler Canceled;

Implements

IStatus.

See Also

BaseFieldsEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


BaseFieldsEntity.EventHandler Event

Finished will be raised before exiting the Save member regardless of the status of the save.

public event EventHandler Finished;

Implements

IStatus.

Remarks

See Also

BaseFieldsEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


BaseFieldsEntity.StatusChangedEventHandler Event

This event is raised when a member of the Status property is changed.

public event StatusChangedEventHandler StatusChanged;

Event Data

The event handler receives an argument of type StatusChangedEventArgs containing data related to this event. The following StatusChangedEventArgs property provides information specific to this event.

Property | Description
Status |

Implements

IStatus.

Remarks

See Also

BaseFieldsEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


BaseFieldsStatusForm Class

For a list of all members of this type, see BaseFieldsStatusForm Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
BaseFieldsStatusForm

public class BaseFieldsStatusForm : Form

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.Entity

Assembly: AptifyBaseFieldsModule (in AptifyBaseFieldsModule.dll)

See Also

BaseFieldsStatusForm Members | Aptify.Framework.BusinessLogic.Entity Namespace


BaseFieldsStatusForm Members

BaseFieldsStatusForm overview

Public Instance Constructors

BaseFieldsStatusForm Constructor Initializes a new instance of the BaseFieldsStatusForm class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
Status |
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

BaseFieldsStatusForm Class | Aptify.Framework.BusinessLogic.Entity Namespace


BaseFieldsStatusForm Constructor

Initializes a new instance of the BaseFieldsStatusForm class.

public BaseFieldsStatusForm();

See Also

BaseFieldsStatusForm Class | Aptify.Framework.BusinessLogic.Entity Namespace


BaseFieldsStatusForm Properties

The properties of the BaseFieldsStatusForm class are listed below. For a complete list of BaseFieldsStatusForm class members, see the BaseFieldsStatusForm Members topic.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
Status |
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

BaseFieldsStatusForm Class | Aptify.Framework.BusinessLogic.Entity Namespace


Status Property

Aptify 5.0 Software Development Kit (SDK)

BaseFieldsStatusForm.Status Property

public Status Status {get; set;}

See Also

BaseFieldsStatusForm Class | Aptify.Framework.BusinessLogic.Entity Namespace


BaseFieldsStatusForm Methods

The methods of the BaseFieldsStatusForm class are listed below. For a complete list of BaseFieldsStatusForm class members, see the BaseFieldsStatusForm Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

BaseFieldsStatusForm Class | Aptify.Framework.BusinessLogic.Entity Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

BaseFieldsStatusForm.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

BaseFieldsStatusForm Class | Aptify.Framework.BusinessLogic.Entity Namespace


BaseFieldsStatusForm.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

BaseFieldsStatusForm Class | Aptify.Framework.BusinessLogic.Entity Namespace | BaseFieldsStatusForm.Dispose Overload List


Constants Class

For a list of all members of this type, see Constants Members.

System.Object
Constants

public class Constants

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.Entity

Assembly: AptifyEntityInterfaces (in AptifyEntityInterfaces.dll)

See Also

Constants Members | Aptify.Framework.BusinessLogic.Entity Namespace


Constants Members

Constants overview

Public Static Fields

APTIFY_ENCRYPTION_DIALOG_TITLE
CANNOT_ADD_FIELD_MESSAGE
CANNOT_REBUILD_MESSAGE
CANNOT_RETRIEVE_FIELD_MESSAGE
CHANGES_DO_NOT_REQUIRE_REGENERATE_MESSAGE
CHANGES_DO_NOT_REQUIRE_UPDATE_MESSAGE
CHANGES_REQUIRE_REGENERATE_MESSAGE
CHANGES_REQUIRE_UPDATE_MESSAGE
CHECKING_FOR_ENTITY_CHANGES_MESSAGE
CHECKING_FOR_REGENERATE_MESSAGE
CHECKING_TABLE_REQUIRES_UPDATE_MESSAGE
COMPLETING_TRANSACTION_MESSAGE
CONFIG_ERROR_INVALID_ENTITY
CONTINUE_ENCRYPTION_MESSAGE
COPYING_RANGE_MESSAGE
COULD_NOT_DELETE_ENTITY_MESSAGE
COULD_NOT_GET_SERVER_MESSAGE
CREATING_BASE_TABLE_MESSAGE
CREATING_STORED_PROCEDURES_MESSAGE
CREATING_TABLE_INDEXES_MESSAGE
CURRENT_USER_NOT_ADMIN_MESSAGE
DAL_COULD_NOT_BE_STARTED_MESSAGE
ENCRYPTION_FAILED_MESSAGE
ENCRYPTION_SUCCESS_MESSAGE
ENTER_DEFAULT_VALUE_MESSAGE
ENTITY_MODULE_DIALOG_TITLE
ERROR_REBUILDING_DBOBJECT_MESSAGE
FAILURE
FIELD_DOES_NOT_HAVE_VALID_SQL_MESSAGE
FORM_TEMPLATE_BYPASSED_MESSAGE
FORM_TEMPLATE_MESSAGE
FORM_TEMPLATE_WARNING
GENERIC_CREATE_MESSAGE
INVALID_FIELD_PRECISION_MESSAGE
INVALID_FIELD_SCALE_MESSAGE
INVALID_FIELD_SIZE_MESSAGE
NEW_KEY_FOUND_MESSAGE
NEW_KEY_NOT_FOUND_MESSAGE
NON_FATAL_EXCEPTION_MESSAGE
OLD_KEY_FOUND_MESSAGE
OLD_KEY_NOT_FOUND_MESSAGE
REBUILDING_DB_OBJECTS_MESSAGE
REBUILT_DBOBJECT_MESSAGE
REGENERATE_DBOBJECTS_QUESTION
ROLLBACK_TRANSACTION_MESSAGE
SAVE_COMPLETED_MESSAGE
SAVING_ENTITY_MESSAGE
SECURITY_KEY_NOT_FOUND_MESSAGE
SEQUENCE_FIELD_NOT_FOUND_MESSAGE
START_ENCRYPTION_MESSAGE
STARTING_PROCESS_MESSAGE
STATUS_ENCRYPT_BEGIN_PROCESSING
STATUS_ENCRYPT_BEGIN_UPDATING
STATUS_ENCRYPT_END_UPDATING
STATUS_ENCRYPT_PROCESSING
SUB_TYPE_MESSAGE
SUB_TYPE_SEQUENCE_MESSAGE
SUCCESS
TABLE_ALIAS_NOT_FOUND_MESSAGE
TABLE_DOES_NOT_EXIST_MESSAGE
TABLE_DOES_NOT_EXIST_QUESTION
TOP_LEVEL_MESSAGE
TOP_LEVEL_SECOND_FIELD_MESSAGE
TOP_LEVEL_SINGLE_MESSAGE
TOP_LEVEL_SINGLE_UNLESS_MESSAGE
UNABLE_TO_RETRIEVE_USER_MESSAGE
UPDATING_BASE_TABLE_MESSAGE
UPDATING_PARENT_LINKAGE_MESSAGE
UPDATING_SCHEMA_MESSAGE
USER_ABORTED_MESSAGE
USER_ID_NOT_FOUND_EXCEPTION_MESSAGE
VALIDATING_ENTITY_MESSAGE
VALIDATING_PERCENT_MESSAGE
VALIDATING_SECURITY_MESSAGE
VALUE_LIST_TYPE_COUNT_MESSAGE
VALUE_LIST_TYPE_MESSAGE
VALUE_NEEDED_DIALOG_TITLE

Public Static Methods

GetMessage
GetResourceString

Public Instance Constructors

Constants Constructor Initializes a new instance of the Constants class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants Constructor

Initializes a new instance of the Constants class.

public Constants();

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants Fields

The fields of the Constants class are listed below. For a complete list of Constants class members, see the Constants Members topic.

Public Static Fields

APTIFY_ENCRYPTION_DIALOG_TITLE
CANNOT_ADD_FIELD_MESSAGE
CANNOT_REBUILD_MESSAGE
CANNOT_RETRIEVE_FIELD_MESSAGE
CHANGES_DO_NOT_REQUIRE_REGENERATE_MESSAGE
CHANGES_DO_NOT_REQUIRE_UPDATE_MESSAGE
CHANGES_REQUIRE_REGENERATE_MESSAGE
CHANGES_REQUIRE_UPDATE_MESSAGE
CHECKING_FOR_ENTITY_CHANGES_MESSAGE
CHECKING_FOR_REGENERATE_MESSAGE
CHECKING_TABLE_REQUIRES_UPDATE_MESSAGE
COMPLETING_TRANSACTION_MESSAGE
CONFIG_ERROR_INVALID_ENTITY
CONTINUE_ENCRYPTION_MESSAGE
COPYING_RANGE_MESSAGE
COULD_NOT_DELETE_ENTITY_MESSAGE
COULD_NOT_GET_SERVER_MESSAGE
CREATING_BASE_TABLE_MESSAGE
CREATING_STORED_PROCEDURES_MESSAGE
CREATING_TABLE_INDEXES_MESSAGE
CURRENT_USER_NOT_ADMIN_MESSAGE
DAL_COULD_NOT_BE_STARTED_MESSAGE
ENCRYPTION_FAILED_MESSAGE
ENCRYPTION_SUCCESS_MESSAGE
ENTER_DEFAULT_VALUE_MESSAGE
ENTITY_MODULE_DIALOG_TITLE
ERROR_REBUILDING_DBOBJECT_MESSAGE
FAILURE
FIELD_DOES_NOT_HAVE_VALID_SQL_MESSAGE
FORM_TEMPLATE_BYPASSED_MESSAGE
FORM_TEMPLATE_MESSAGE
FORM_TEMPLATE_WARNING
GENERIC_CREATE_MESSAGE
INVALID_FIELD_PRECISION_MESSAGE
INVALID_FIELD_SCALE_MESSAGE
INVALID_FIELD_SIZE_MESSAGE
NEW_KEY_FOUND_MESSAGE
NEW_KEY_NOT_FOUND_MESSAGE
NON_FATAL_EXCEPTION_MESSAGE
OLD_KEY_FOUND_MESSAGE
OLD_KEY_NOT_FOUND_MESSAGE
REBUILDING_DB_OBJECTS_MESSAGE
REBUILT_DBOBJECT_MESSAGE
REGENERATE_DBOBJECTS_QUESTION
ROLLBACK_TRANSACTION_MESSAGE
SAVE_COMPLETED_MESSAGE
SAVING_ENTITY_MESSAGE
SECURITY_KEY_NOT_FOUND_MESSAGE
SEQUENCE_FIELD_NOT_FOUND_MESSAGE
START_ENCRYPTION_MESSAGE
STARTING_PROCESS_MESSAGE
STATUS_ENCRYPT_BEGIN_PROCESSING
STATUS_ENCRYPT_BEGIN_UPDATING
STATUS_ENCRYPT_END_UPDATING
STATUS_ENCRYPT_PROCESSING
SUB_TYPE_MESSAGE
SUB_TYPE_SEQUENCE_MESSAGE
SUCCESS
TABLE_ALIAS_NOT_FOUND_MESSAGE
TABLE_DOES_NOT_EXIST_MESSAGE
TABLE_DOES_NOT_EXIST_QUESTION
TOP_LEVEL_MESSAGE
TOP_LEVEL_SECOND_FIELD_MESSAGE
TOP_LEVEL_SINGLE_MESSAGE
TOP_LEVEL_SINGLE_UNLESS_MESSAGE
UNABLE_TO_RETRIEVE_USER_MESSAGE
UPDATING_BASE_TABLE_MESSAGE
UPDATING_PARENT_LINKAGE_MESSAGE
UPDATING_SCHEMA_MESSAGE
USER_ABORTED_MESSAGE
USER_ID_NOT_FOUND_EXCEPTION_MESSAGE
VALIDATING_ENTITY_MESSAGE
VALIDATING_PERCENT_MESSAGE
VALIDATING_SECURITY_MESSAGE
VALUE_LIST_TYPE_COUNT_MESSAGE
VALUE_LIST_TYPE_MESSAGE
VALUE_NEEDED_DIALOG_TITLE

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.APTIFY_ENCRYPTION_DIALOG_TITLE Field

public const APTIFY_ENCRYPTION_DIALOG_TITLE APTIFY_ENCRYPTION_DIALOG_TITLE = "APTIFY_ENCRYPTION_DIALOG_TITLE";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.CANNOT_ADD_FIELD_MESSAGE Field

public const CANNOT_ADD_FIELD_MESSAGE CANNOT_ADD_FIELD_MESSAGE = "CANNOT_ADD_FIELD_MESSAGE";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.CANNOT_REBUILD_MESSAGE Field

public const CANNOT_REBUILD_MESSAGE CANNOT_REBUILD_MESSAGE = "CANNOT_REBUILD_MESSAGE";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.CANNOT_RETRIEVE_FIELD_MESSAGE Field

public const CANNOT_RETRIEVE_FIELD_MESSAGE CANNOT_RETRIEVE_FIELD_MESSAGE = "CANNOT_RETRIEVE_FIELD_MESSAGE";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.CHANGES_DO_NOT_REQUIRE_REGENERATE_MESSAGE Field

public const CHANGES_DO_NOT_REQUIRE_REGENERATE_MESSAGE CHANGES_DO_NOT_REQUIRE_REGENERATE_MESSAGE = "CHANGES_DO_NOT_REQUIRE_REGENERATE_MESSAGE";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.CHANGES_DO_NOT_REQUIRE_UPDATE_MESSAGE Field

public const CHANGES_DO_NOT_REQUIRE_UPDATE_MESSAGE CHANGES_DO_NOT_REQUIRE_UPDATE_MESSAGE = "CHANGES_DO_NOT_REQUIRE_UPDATE_MESSAGE";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.CHANGES_REQUIRE_REGENERATE_MESSAGE Field

public const CHANGES_REQUIRE_REGENERATE_MESSAGE CHANGES_REQUIRE_REGENERATE_MESSAGE = "CHANGES_REQUIRE_REGENERATE_MESSAGE";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.CHANGES_REQUIRE_UPDATE_MESSAGE Field

public const CHANGES_REQUIRE_UPDATE_MESSAGE CHANGES_REQUIRE_UPDATE_MESSAGE = "CHANGES_REQUIRE_UPDATE_MESSAGE";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.CHECKING_FOR_ENTITY_CHANGES_MESSAGE Field

public const CHECKING_FOR_ENTITY_CHANGES_MESSAGE CHECKING_FOR_ENTITY_CHANGES_MESSAGE = "CHECKING_FOR_ENTITY_CHANGES_MESSAGE";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.CHECKING_FOR_REGENERATE_MESSAGE Field

public const CHECKING_FOR_REGENERATE_MESSAGE CHECKING_FOR_REGENERATE_MESSAGE = "CHECKING_FOR_REGENERATE_MESSAGE";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.CHECKING_TABLE_REQUIRES_UPDATE_MESSAGE Field

public const CHECKING_TABLE_REQUIRES_UPDATE_MESSAGE CHECKING_TABLE_REQUIRES_UPDATE_MESSAGE = "CHECKING_TABLE_REQUIRES_UPDATE_MESSAGE";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.COMPLETING_TRANSACTION_MESSAGE Field

public const COMPLETING_TRANSACTION_MESSAGE COMPLETING_TRANSACTION_MESSAGE = "COMPLETING_TRANSACTION_MESSAGE";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.CONFIG_ERROR_INVALID_ENTITY Field

public const CONFIG_ERROR_INVALID_ENTITY CONFIG_ERROR_INVALID_ENTITY = "CONFIG_ERROR_INVALID_ENTITY";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.CONTINUE_ENCRYPTION_MESSAGE Field

public const CONTINUE_ENCRYPTION_MESSAGE CONTINUE_ENCRYPTION_MESSAGE = "CONTINUE_ENCRYPTION_MESSAGE";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.COPYING_RANGE_MESSAGE Field

public const COPYING_RANGE_MESSAGE COPYING_RANGE_MESSAGE = "COPYING_RANGE_MESSAGE";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.COULD_NOT_DELETE_ENTITY_MESSAGE Field

public const COULD_NOT_DELETE_ENTITY_MESSAGE COULD_NOT_DELETE_ENTITY_MESSAGE = "COULD_NOT_DELETE_ENTITY_MESSAGE";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.COULD_NOT_GET_SERVER_MESSAGE Field

public const COULD_NOT_GET_SERVER_MESSAGE COULD_NOT_GET_SERVER_MESSAGE = "COULD_NOT_GET_SERVER_MESSAGE";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.CREATING_BASE_TABLE_MESSAGE Field

public const CREATING_BASE_TABLE_MESSAGE CREATING_BASE_TABLE_MESSAGE = "CREATING_BASE_TABLE_MESSAGE";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.CREATING_STORED_PROCEDURES_MESSAGE Field

public const CREATING_STORED_PROCEDURES_MESSAGE CREATING_STORED_PROCEDURES_MESSAGE = "CREATING_STORED_PROCEDURES_MESSAGE";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.CREATING_TABLE_INDEXES_MESSAGE Field

public const CREATING_TABLE_INDEXES_MESSAGE CREATING_TABLE_INDEXES_MESSAGE = "CREATING_TABLE_INDEXES_MESSAGE";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.CURRENT_USER_NOT_ADMIN_MESSAGE Field

public const CURRENT_USER_NOT_ADMIN_MESSAGE CURRENT_USER_NOT_ADMIN_MESSAGE = "CURRENT_USER_NOT_ADMIN_MESSAGE";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.DAL_COULD_NOT_BE_STARTED_MESSAGE Field

public const DAL_COULD_NOT_BE_STARTED_MESSAGE DAL_COULD_NOT_BE_STARTED_MESSAGE = "DAL_COULD_NOT_BE_STARTED_MESSAGE";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.ENCRYPTION_FAILED_MESSAGE Field

public const ENCRYPTION_FAILED_MESSAGE ENCRYPTION_FAILED_MESSAGE = "ENCRYPTION_FAILED_MESSAGE";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.ENCRYPTION_SUCCESS_MESSAGE Field

public const ENCRYPTION_SUCCESS_MESSAGE ENCRYPTION_SUCCESS_MESSAGE = "ENCRYPTION_SUCCESS_MESSAGE";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.ENTER_DEFAULT_VALUE_MESSAGE Field

public const ENTER_DEFAULT_VALUE_MESSAGE ENTER_DEFAULT_VALUE_MESSAGE = "ENTER_DEFAULT_VALUE_MESSAGE";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.ENTITY_MODULE_DIALOG_TITLE Field

public const ENTITY_MODULE_DIALOG_TITLE ENTITY_MODULE_DIALOG_TITLE = "ENTITY_MODULE_DIALOG_TITLE";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.ERROR_REBUILDING_DBOBJECT_MESSAGE Field

public const ERROR_REBUILDING_DBOBJECT_MESSAGE ERROR_REBUILDING_DBOBJECT_MESSAGE = "ERROR_REBUILDING_DBOBJECT_MESSAGE";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.FAILURE Field

public const FAILURE FAILURE = "FAILURE";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.FIELD_DOES_NOT_HAVE_VALID_SQL_MESSAGE Field

public const FIELD_DOES_NOT_HAVE_VALID_SQL_MESSAGE FIELD_DOES_NOT_HAVE_VALID_SQL_MESSAGE = "FIELD_DOES_NOT_HAVE_VALID_SQL_MESSAGE";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.FORM_TEMPLATE_BYPASSED_MESSAGE Field

public const FORM_TEMPLATE_BYPASSED_MESSAGE FORM_TEMPLATE_BYPASSED_MESSAGE = "FORM_TEMPLATE_BYPASSED_MESSAGE";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.FORM_TEMPLATE_MESSAGE Field

public const FORM_TEMPLATE_MESSAGE FORM_TEMPLATE_MESSAGE = "FORM_TEMPLATE_MESSAGE";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.FORM_TEMPLATE_WARNING Field

public const FORM_TEMPLATE_WARNING FORM_TEMPLATE_WARNING = "FORM_TEMPLATE_WARNING";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.GENERIC_CREATE_MESSAGE Field

public const GENERIC_CREATE_MESSAGE GENERIC_CREATE_MESSAGE = "GENERIC_CREATE_MESSAGE";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.INVALID_FIELD_PRECISION_MESSAGE Field

public const INVALID_FIELD_PRECISION_MESSAGE INVALID_FIELD_PRECISION_MESSAGE = "INVALID_FIELD_PRECISION_MESSAGE";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.INVALID_FIELD_SCALE_MESSAGE Field

public const INVALID_FIELD_SCALE_MESSAGE INVALID_FIELD_SCALE_MESSAGE = "INVALID_FIELD_SCALE_MESSAGE";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.INVALID_FIELD_SIZE_MESSAGE Field

public const INVALID_FIELD_SIZE_MESSAGE INVALID_FIELD_SIZE_MESSAGE = "INVALID_FIELD_SIZE_MESSAGE";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.NEW_KEY_FOUND_MESSAGE Field

public const NEW_KEY_FOUND_MESSAGE NEW_KEY_FOUND_MESSAGE = "NEW_KEY_FOUND_MESSAGE";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.NEW_KEY_NOT_FOUND_MESSAGE Field

public const NEW_KEY_NOT_FOUND_MESSAGE NEW_KEY_NOT_FOUND_MESSAGE = "NEW_KEY_NOT_FOUND_MESSAGE";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.NON_FATAL_EXCEPTION_MESSAGE Field

public const NON_FATAL_EXCEPTION_MESSAGE NON_FATAL_EXCEPTION_MESSAGE = "NON_FATAL_EXCEPTION_MESSAGE";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.OLD_KEY_FOUND_MESSAGE Field

public const OLD_KEY_FOUND_MESSAGE OLD_KEY_FOUND_MESSAGE = "OLD_KEY_FOUND_MESSAGE";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.OLD_KEY_NOT_FOUND_MESSAGE Field

public const OLD_KEY_NOT_FOUND_MESSAGE OLD_KEY_NOT_FOUND_MESSAGE = "OLD_KEY_NOT_FOUND_MESSAGE";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.REBUILDING_DB_OBJECTS_MESSAGE Field

public const REBUILDING_DB_OBJECTS_MESSAGE REBUILDING_DB_OBJECTS_MESSAGE = "REBUILDING_DB_OBJECTS_MESSAGE";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.REBUILT_DBOBJECT_MESSAGE Field

public const REBUILT_DBOBJECT_MESSAGE REBUILT_DBOBJECT_MESSAGE = "REBUILT_DBOBJECT_MESSAGE";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.REGENERATE_DBOBJECTS_QUESTION Field

public const REGENERATE_DBOBJECTS_QUESTION REGENERATE_DBOBJECTS_QUESTION = "REGENERATE_DBOBJECTS_QUESTION";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.ROLLBACK_TRANSACTION_MESSAGE Field

public const ROLLBACK_TRANSACTION_MESSAGE ROLLBACK_TRANSACTION_MESSAGE = "ROLLBACK_TRANSACTION_MESSAGE";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.SAVE_COMPLETED_MESSAGE Field

public const SAVE_COMPLETED_MESSAGE SAVE_COMPLETED_MESSAGE = "SAVE_COMPLETED_MESSAGE";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.SAVING_ENTITY_MESSAGE Field

public const SAVING_ENTITY_MESSAGE SAVING_ENTITY_MESSAGE = "SAVING_ENTITY_MESSAGE";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.SECURITY_KEY_NOT_FOUND_MESSAGE Field

public const SECURITY_KEY_NOT_FOUND_MESSAGE SECURITY_KEY_NOT_FOUND_MESSAGE = "SECURITY_KEY_NOT_FOUND_MESSAGE";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.SEQUENCE_FIELD_NOT_FOUND_MESSAGE Field

public const SEQUENCE_FIELD_NOT_FOUND_MESSAGE SEQUENCE_FIELD_NOT_FOUND_MESSAGE = "SEQUENCE_FIELD_NOT_FOUND_MESSAGE";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.START_ENCRYPTION_MESSAGE Field

public const START_ENCRYPTION_MESSAGE START_ENCRYPTION_MESSAGE = "START_ENCRYPTION_MESSAGE";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.STARTING_PROCESS_MESSAGE Field

public const STARTING_PROCESS_MESSAGE STARTING_PROCESS_MESSAGE = "STARTING_PROCESS_MESSAGE";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.STATUS_ENCRYPT_BEGIN_PROCESSING Field

public const STATUS_ENCRYPT_BEGIN_PROCESSING STATUS_ENCRYPT_BEGIN_PROCESSING = "STATUS_ENCRYPT_BEGIN_PROCESSING";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.STATUS_ENCRYPT_BEGIN_UPDATING Field

public const STATUS_ENCRYPT_BEGIN_UPDATING STATUS_ENCRYPT_BEGIN_UPDATING = "STATUS_ENCRYPT_BEGIN_UPDATING";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.STATUS_ENCRYPT_END_UPDATING Field

public const STATUS_ENCRYPT_END_UPDATING STATUS_ENCRYPT_END_UPDATING = "STATUS_ENCRYPT_END_UPDATING";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.STATUS_ENCRYPT_PROCESSING Field

public const STATUS_ENCRYPT_PROCESSING STATUS_ENCRYPT_PROCESSING = "STATUS_ENCRYPT_PROCESSING";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.SUB_TYPE_MESSAGE Field

public const SUB_TYPE_MESSAGE SUB_TYPE_MESSAGE = "SUB_TYPE_MESSAGE";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.SUB_TYPE_SEQUENCE_MESSAGE Field

public const SUB_TYPE_SEQUENCE_MESSAGE SUB_TYPE_SEQUENCE_MESSAGE = "SUB_TYPE_SEQUENCE_MESSAGE";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.SUCCESS Field

public const SUCCESS SUCCESS = "SUCCESS";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.TABLE_ALIAS_NOT_FOUND_MESSAGE Field

public const TABLE_ALIAS_NOT_FOUND_MESSAGE TABLE_ALIAS_NOT_FOUND_MESSAGE = "TABLE_ALIAS_NOT_FOUND_MESSAGE";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.TABLE_DOES_NOT_EXIST_MESSAGE Field

public const TABLE_DOES_NOT_EXIST_MESSAGE TABLE_DOES_NOT_EXIST_MESSAGE = "TABLE_DOES_NOT_EXIST_MESSAGE";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.TABLE_DOES_NOT_EXIST_QUESTION Field

public const TABLE_DOES_NOT_EXIST_QUESTION TABLE_DOES_NOT_EXIST_QUESTION = "TABLE_DOES_NOT_EXIST_QUESTION";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.TOP_LEVEL_MESSAGE Field

public const TOP_LEVEL_MESSAGE TOP_LEVEL_MESSAGE = "TOP_LEVEL_MESSAGE";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.TOP_LEVEL_SECOND_FIELD_MESSAGE Field

public const TOP_LEVEL_SECOND_FIELD_MESSAGE TOP_LEVEL_SECOND_FIELD_MESSAGE = "TOP_LEVEL_SECOND_FIELD_MESSAGE";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.TOP_LEVEL_SINGLE_MESSAGE Field

public const TOP_LEVEL_SINGLE_MESSAGE TOP_LEVEL_SINGLE_MESSAGE = "TOP_LEVEL_SINGLE_MESSAGE";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.TOP_LEVEL_SINGLE_UNLESS_MESSAGE Field

public const TOP_LEVEL_SINGLE_UNLESS_MESSAGE TOP_LEVEL_SINGLE_UNLESS_MESSAGE = "TOP_LEVEL_SINGLE_UNLESS_MESSAGE";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.UNABLE_TO_RETRIEVE_USER_MESSAGE Field

public const UNABLE_TO_RETRIEVE_USER_MESSAGE UNABLE_TO_RETRIEVE_USER_MESSAGE = "UNABLE_TO_RETRIEVE_USER_MESSAGE";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.UPDATING_BASE_TABLE_MESSAGE Field

public const UPDATING_BASE_TABLE_MESSAGE UPDATING_BASE_TABLE_MESSAGE = "UPDATING_BASE_TABLE_MESSAGE";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.UPDATING_PARENT_LINKAGE_MESSAGE Field

public const UPDATING_PARENT_LINKAGE_MESSAGE UPDATING_PARENT_LINKAGE_MESSAGE = "UPDATING_PARENT_LINKAGE_MESSAGE";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.UPDATING_SCHEMA_MESSAGE Field

public const UPDATING_SCHEMA_MESSAGE UPDATING_SCHEMA_MESSAGE = "UPDATING_SCHEMA_MESSAGE";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.USER_ABORTED_MESSAGE Field

public const USER_ABORTED_MESSAGE USER_ABORTED_MESSAGE = "USER_ABORTED_MESSAGE";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.USER_ID_NOT_FOUND_EXCEPTION_MESSAGE Field

public const USER_ID_NOT_FOUND_EXCEPTION_MESSAGE USER_ID_NOT_FOUND_EXCEPTION_MESSAGE = "USER_ID_NOT_FOUND_EXCEPTION_MESSAGE";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.VALIDATING_ENTITY_MESSAGE Field

public const VALIDATING_ENTITY_MESSAGE VALIDATING_ENTITY_MESSAGE = "VALIDATING_ENTITY_MESSAGE";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.VALIDATING_PERCENT_MESSAGE Field

public const VALIDATING_PERCENT_MESSAGE VALIDATING_PERCENT_MESSAGE = "VALIDATING_PERCENT_MESSAGE";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.VALIDATING_SECURITY_MESSAGE Field

public const VALIDATING_SECURITY_MESSAGE VALIDATING_SECURITY_MESSAGE = "VALIDATING_SECURITY_MESSAGE";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.VALUE_LIST_TYPE_COUNT_MESSAGE Field

public const VALUE_LIST_TYPE_COUNT_MESSAGE VALUE_LIST_TYPE_COUNT_MESSAGE = "VALUE_LIST_TYPE_COUNT_MESSAGE";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.VALUE_LIST_TYPE_MESSAGE Field

public const VALUE_LIST_TYPE_MESSAGE VALUE_LIST_TYPE_MESSAGE = "VALUE_LIST_TYPE_MESSAGE";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.VALUE_NEEDED_DIALOG_TITLE Field

public const VALUE_NEEDED_DIALOG_TITLE VALUE_NEEDED_DIALOG_TITLE = "VALUE_NEEDED_DIALOG_TITLE";

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants Methods

The methods of the Constants class are listed below. For a complete list of Constants class members, see the Constants Members topic.

Public Static Methods

GetMessage
GetResourceString

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.GetMessage Method

public static string GetMessage(
String MessageKey,
params Object[] FormatParameters
);

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


Constants.GetResourceString Method

public static string GetResourceString(
String Key
);

See Also

Constants Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntitiesEntity Class

Aptify Entities Entity GE Sub-Class. This class implements all of the functionality related to entity management as a sub-class to the AptifyGenericEntityBase class.

For a list of all members of this type, see EntitiesEntity Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
EntitiesEntity

public class EntitiesEntity : AptifyGenericEntity, IEntitySchema, IEntityInstall

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.Entity

Assembly: AptifyEntitiesEntity (in AptifyEntitiesEntity.dll)

See Also

EntitiesEntity Members | Aptify.Framework.BusinessLogic.Entity Namespace


EntitiesEntity Members

EntitiesEntity overview

Public Instance Constructors

EntitiesEntity Constructor Initializes a new instance of the EntitiesEntity class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

AddSQLDataTypsInArrayObject | Add the Large-value data types (like ntext/nvarchar(max) etc.) into the arraylist object. This arraylist object is being used while checking whether to enable/disable Text/Image File group drop down list on Entity Viewer form as well as on EntitySubTable (subtype) form.
AllowToEnableTextImageFileGroup | Overloaded. Returns True if any field contains large-value data type (like nText/Image/XML etc...)
BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config | Overloaded.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
CreateSingleFieldDefSQL |
Delete | Overloaded.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
DoesTableContainLargeDataType | Check if the table('s schema) contains any field where data type is any of these - text, ntext, image, varchar(max), nvarchar(max), varbinary(max), xml or large user defined type columns. If it contains, return True. So that Text/Image FileGroup drop down will be enabled/disabled on UI form Or create table syntax should include "TEXTIMAGE_ON" modifier.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetSQLType |
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
IsWordInString | Find for the particular text into String.
Load | Overloaded.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NeedsQuotes |
NewRecord |
RebuildBaseView | This method will rebuild the base view for the given entity object.
RebuildStoredProcs | Overloaded. This method will rebuild the generated stored procedures for the given entity. This method will only perform this operation if the GenerateTable field of the Entity object is set to a value of 1. In other cases, an EntityObjectException will be thrown.
RegenerateBaselineFormTemplate | This method will regenerate the baseline form template for the given entity object.
RenameTable |
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveSchema | This method will save the schema for an entity, which includes the table definition, and where needed the stored procedures and base view. This method attempts to use ALTER table whenever possible, but will automatically drop and recreate a table if required based on the types of changes being made to the entity definition.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SaveWithoutDBObjects |
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue |
ShowMessageBox | Utility method that will display a message box either using the Status Form as the parent window, if it is visible, or the top level Windows.Forms.MessageBox.Show() method.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.
VerifyForeignKeys | This method will get a list of the foreign keys that exist on the entity and then compare it with the meta-data and automatically add any missing foreign keys.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateGetDependenciesLinkedFieldSQL |
GenerateGetDependenciesSQL |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
GetFileGroup | Gets the name of a FileGroup of the passed table (in argument).
GetTextImageFileGroup | Gets the name of a FileGroup for the large-value data types for the passed table (in argument).
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterEntityBaseViewsItemRemove | EntityBaseView is being removed from the collection. Scan the EntityDefaultBaseViews to remove any records that refer to the EntityBaseView that was removed.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeEntityBaseViewsItemRemove | Before a EntityBaseView record is removed, check to see it is used in a View. If it is used in a View, it cannot be removed.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

EntitiesEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntitiesEntity Constructor

Initializes a new instance of the EntitiesEntity class.

public EntitiesEntity();

See Also

EntitiesEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntitiesEntity Methods

The methods of the EntitiesEntity class are listed below. For a complete list of EntitiesEntity class members, see the EntitiesEntity Members topic.

Public Instance Methods

AddSQLDataTypsInArrayObject | Add the Large-value data types (like ntext/nvarchar(max) etc.) into the arraylist object. This arraylist object is being used while checking whether to enable/disable Text/Image File group drop down list on Entity Viewer form as well as on EntitySubTable (subtype) form.
AllowToEnableTextImageFileGroup | Overloaded. Returns True if any field contains large-value data type (like nText/Image/XML etc...)
BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config | Overloaded.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
CreateSingleFieldDefSQL |
Delete | Overloaded.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
DoesTableContainLargeDataType | Check if the table('s schema) contains any field where data type is any of these - text, ntext, image, varchar(max), nvarchar(max), varbinary(max), xml or large user defined type columns. If it contains, return True. So that Text/Image FileGroup drop down will be enabled/disabled on UI form Or create table syntax should include "TEXTIMAGE_ON" modifier.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetSQLType |
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
IsWordInString | Find for the particular text into String.
Load | Overloaded.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NeedsQuotes |
NewRecord |
RebuildBaseView | This method will rebuild the base view for the given entity object.
RebuildStoredProcs | Overloaded. This method will rebuild the generated stored procedures for the given entity. This method will only perform this operation if the GenerateTable field of the Entity object is set to a value of 1. In other cases, an EntityObjectException will be thrown.
RegenerateBaselineFormTemplate | This method will regenerate the baseline form template for the given entity object.
RenameTable |
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveSchema | This method will save the schema for an entity, which includes the table definition, and where needed the stored procedures and base view. This method attempts to use ALTER table whenever possible, but will automatically drop and recreate a table if required based on the types of changes being made to the entity definition.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SaveWithoutDBObjects |
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue |
ShowMessageBox | Utility method that will display a message box either using the Status Form as the parent window, if it is visible, or the top level Windows.Forms.MessageBox.Show() method.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.
VerifyForeignKeys | This method will get a list of the foreign keys that exist on the entity and then compare it with the meta-data and automatically add any missing foreign keys.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateGetDependenciesLinkedFieldSQL |
GenerateGetDependenciesSQL |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
GetFileGroup | Gets the name of a FileGroup of the passed table (in argument).
GetTextImageFileGroup | Gets the name of a FileGroup for the large-value data types for the passed table (in argument).
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterEntityBaseViewsItemRemove | EntityBaseView is being removed from the collection. Scan the EntityDefaultBaseViews to remove any records that refer to the EntityBaseView that was removed.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeEntityBaseViewsItemRemove | Before a EntityBaseView record is removed, check to see it is used in a View. If it is used in a View, it cannot be removed.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

EntitiesEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntitiesEntity.AddSQLDataTypsInArrayObject Method

Add the Large-value data types (like ntext/nvarchar(max) etc.) into the arraylist object. This arraylist object is being used while checking whether to enable/disable Text/Image File group drop down list on Entity Viewer form as well as on EntitySubTable (subtype) form.

public virtual void AddSQLDataTypsInArrayObject();

Remarks

See Also

EntitiesEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


AllowToEnableTextImageFileGroup Method

Aptify 5.0 Software Development Kit (SDK)

EntitiesEntity.AllowToEnableTextImageFileGroup Method

Enable the Text/Image FileGroup drop down if the newly added field contains large-value data types.

Overload List

Enable the Text/Image FileGroup drop down if the newly added field contains large-value data types.

public virtual bool AllowToEnableTextImageFileGroup(AptifyGenericEntityBase);

Enable Text/Image drop down list if GE contains any field with Large-value data type. This will be useful when user re-opens the saved entity.

public virtual bool AllowToEnableTextImageFileGroup(AptifySubTypeBase,String);

Returns True if any field contains large-value data type (like nText/Image/XML etc...)

public virtual bool AllowToEnableTextImageFileGroup(String);

See Also

EntitiesEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntitiesEntity.AllowToEnableTextImageFileGroup Method (AptifyGenericEntityBase)

Enable the Text/Image FileGroup drop down if the newly added field contains large-value data types.

public virtual bool AllowToEnableTextImageFileGroup(
AptifyGenericEntityBase oEntityFieldGE
);

Parameters

oEntityFieldGE

Return Value

Remarks

See Also

EntitiesEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace | EntitiesEntity.AllowToEnableTextImageFileGroup Overload List


EntitiesEntity.AllowToEnableTextImageFileGroup Method (AptifySubTypeBase, String)

Enable Text/Image drop down list if GE contains any field with Large-value data type. This will be useful when user re-opens the saved entity.

public virtual bool AllowToEnableTextImageFileGroup(
AptifySubTypeBase oEntityFieldsGE,
String sBaseTableOfDataControl
);

Parameters

oEntityFieldsGE
sBaseTableOfDataControl

Return Value

Remarks

See Also

EntitiesEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace | EntitiesEntity.AllowToEnableTextImageFileGroup Overload List


EntitiesEntity.AllowToEnableTextImageFileGroup Method (String)

Returns True if any field contains large-value data type (like nText/Image/XML etc...)

public virtual bool AllowToEnableTextImageFileGroup(
String sSQLDataType
);

Parameters

sSQLDataType

Return Value

Remarks

See Also

EntitiesEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace | EntitiesEntity.AllowToEnableTextImageFileGroup Overload List


Config Method

Aptify 5.0 Software Development Kit (SDK)

EntitiesEntity.Config Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual void Config(AptifySubTypeBase);

Inherited from AptifyGenericEntity.

public override void Config(AptifySubTypeBase,Int64);

Inherited from AptifyGenericEntityBase.

public virtual void Config(UserCredentials,String);

public override void Config(UserCredentials,String,Int64);

See Also

EntitiesEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntitiesEntity.Config Method (UserCredentials, String, Int64)

public override void Config(
UserCredentials UserCredentials,
String EntityName,
Int64 RecordID
);

See Also

EntitiesEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace | EntitiesEntity.Config Overload List


EntitiesEntity.CreateSingleFieldDefSQL Method

public string CreateSingleFieldDefSQL(
ref AptifyGenericEntityBase& Field,
Boolean bDefaultWithValues
);

See Also

EntitiesEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


Delete Method

Aptify 5.0 Software Development Kit (SDK)

EntitiesEntity.Delete Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Delete();

public override bool Delete(String);

See Also

EntitiesEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntitiesEntity.Delete Method (String)

public override bool Delete(
String TransactionID
);

See Also

EntitiesEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace | EntitiesEntity.Delete Overload List


EntitiesEntity.DoesTableContainLargeDataType Method

Check if the table('s schema) contains any field where data type is any of these - text, ntext, image, varchar(max), nvarchar(max), varbinary(max), xml or large user defined type columns. If it contains, return True. So that Text/Image FileGroup drop down will be enabled/disabled on UI form Or create table syntax should include "TEXTIMAGE_ON" modifier.

public virtual bool DoesTableContainLargeDataType(
String sSQL
);

Parameters

sSQL

Return Value

Remarks

Issue 4929, Maulik Patel, 03/19/2008

See Also

EntitiesEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntitiesEntity.GenerateGetDependenciesLinkedFieldSQL Method

protected virtual StringBuilder GenerateGetDependenciesLinkedFieldSQL(
String sEntityName
);

See Also

EntitiesEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntitiesEntity.GenerateGetDependenciesSQL Method

protected virtual string GenerateGetDependenciesSQL(
String sEntityName,
String sSPName
);

See Also

EntitiesEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntitiesEntity.GetFileGroup Method

Gets the name of a FileGroup of the passed table (in argument).

protected virtual string GetFileGroup(
ref String& sTableName
);

Parameters

sTableName

Return Value

Name of FileGroup

Remarks

Issue 4929, Maulik Patel, 03/19/2008

See Also

EntitiesEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntitiesEntity.GetSQLType Method

public string GetSQLType(
ref AptifyGenericEntityBase& Field
);

See Also

EntitiesEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntitiesEntity.GetTextImageFileGroup Method

Gets the name of a FileGroup for the large-value data types for the passed table (in argument).

protected virtual string GetTextImageFileGroup(
ref String& sTableName
);

Parameters

sTableName

Return Value

Name of FileGroup for Text/Image (large-value data type) fields

Remarks

Issue 4929, Maulik Patel, 03/19/2008

See Also

EntitiesEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntitiesEntity.IsWordInString Method

Find for the particular text into String.

public bool IsWordInString(
String word,
String strSQL
);

Parameters

word
strSQL

Return Value

Remarks

See Also

EntitiesEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


Load Method

Aptify 5.0 Software Development Kit (SDK)

EntitiesEntity.Load Method

Overload List

Inherited from AptifyGenericEntity.

public override void Load(DataRow);

Inherited from AptifyGenericEntity.

public override void Load(IDataReader);

public override void Load(Int64);

Inherited from AptifyGenericEntityBase.

public virtual void Load(String);

Inherited from AptifyGenericEntity.

public override void Load(String,Boolean);

See Also

EntitiesEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntitiesEntity.Load Method (Int64)

public override void Load(
Int64 ID
);

See Also

EntitiesEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace | EntitiesEntity.Load Overload List


EntitiesEntity.NeedsQuotes Method

public bool NeedsQuotes(
ref AptifyGenericEntityBase& Field
);

See Also

EntitiesEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntitiesEntity.NewRecord Method

public override bool NewRecord();

See Also

EntitiesEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntitiesEntity.OnAfterEntityBaseViewsItemRemove Method

EntityBaseView is being removed from the collection. Scan the EntityDefaultBaseViews to remove any records that refer to the EntityBaseView that was removed.

protected virtual void OnAfterEntityBaseViewsItemRemove(
AfterSubTypeItemRemoveEventArgs e
);

Parameters

e

Remarks

See Also

EntitiesEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntitiesEntity.OnBeforeEntityBaseViewsItemRemove Method

Before a EntityBaseView record is removed, check to see it is used in a View. If it is used in a View, it cannot be removed.

protected virtual void OnBeforeEntityBaseViewsItemRemove(
BeforeSubTypeItemRemoveEventArgs e
);

Parameters

e

Remarks

See Also

EntitiesEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntitiesEntity.RebuildBaseView Method

This method will rebuild the base view for the given entity object.

public bool RebuildBaseView(
Boolean AllowGUI
);

Parameters

AllowGUI
If set to True, the object is allowed to interact with the user, if set to False, the object will not interact with the user.

Return Value

Implements

IEntitySchema.

Remarks

See Also

EntitiesEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


RebuildStoredProcs Method

Aptify 5.0 Software Development Kit (SDK)

EntitiesEntity.RebuildStoredProcs Method

Overload List

public bool RebuildStoredProcs(EntitiesEntity.EntityDBObject,Boolean);

This method will rebuild the generated stored procedures for the given entity. This method will only perform this operation if the GenerateTable field of the Entity object is set to a value of 1. In other cases, an EntityObjectException will be thrown.

public bool RebuildStoredProcs(Boolean);

See Also

EntitiesEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntitiesEntity.RebuildStoredProcs Method (EntityDBObject, Boolean)

public bool RebuildStoredProcs(
EntitiesEntity.EntityDBObject RegenerateFlags,
Boolean AllowGUI
);

See Also

EntitiesEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace | EntitiesEntity.RebuildStoredProcs Overload List


EntitiesEntity.RebuildStoredProcs Method (Boolean)

This method will rebuild the generated stored procedures for the given entity. This method will only perform this operation if the GenerateTable field of the Entity object is set to a value of 1. In other cases, an EntityObjectException will be thrown.

public bool RebuildStoredProcs(
Boolean AllowGUI
);

Parameters

AllowGUI

Return Value

Implements

IEntitySchema.

Remarks

See Also

EntitiesEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace | EntitiesEntity.RebuildStoredProcs Overload List


EntitiesEntity.RegenerateBaselineFormTemplate Method

This method will regenerate the baseline form template for the given entity object.

public bool RegenerateBaselineFormTemplate(
Boolean AllowGUI
);

Parameters

AllowGUI

Return Value

Implements

IEntitySchema.

Remarks

See Also

EntitiesEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntitiesEntity.RenameTable Method

public void RenameTable(
ref String& sOldName,
ref String& sNewName
);

See Also

EntitiesEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


Save Method

Aptify 5.0 Software Development Kit (SDK)

EntitiesEntity.Save Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Save();

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean,ref String&);

public override bool Save(Boolean,ref String&,String);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(ref String&);

See Also

EntitiesEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntitiesEntity.Save Method (Boolean, String&, String)

public override bool Save(
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

See Also

EntitiesEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace | EntitiesEntity.Save Overload List


EntitiesEntity.SaveSchema Method

This method will save the schema for an entity, which includes the table definition, and where needed the stored procedures and base view. This method attempts to use ALTER table whenever possible, but will automatically drop and recreate a table if required based on the types of changes being made to the entity definition.

public bool SaveSchema(
Boolean AllowGUI
);

Parameters

AllowGUI

Return Value

Implements

IEntitySchema.

Remarks

See Also

EntitiesEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntitiesEntity.SaveWithoutDBObjects Method

public void SaveWithoutDBObjects(
Boolean AllowGUI
);

Implements

IEntityInstall.

See Also

EntitiesEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntitiesEntity.SetValue Method

public override void SetValue(
String FieldName,
Object Value
);

See Also

EntitiesEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntitiesEntity.ShowMessageBox Method

Utility method that will display a message box either using the Status Form as the parent window, if it is visible, or the top level Windows.Forms.MessageBox.Show() method.

public DialogResult ShowMessageBox(
String Text,
String Caption,
MessageBoxButtons Buttons,
MessageBoxIcon Icon
);

Parameters

Text
Caption
Buttons
Icon

Return Value

Remarks

See Also

EntitiesEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


Validate Method

Aptify 5.0 Software Development Kit (SDK)

EntitiesEntity.Validate Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Validate();

public override bool Validate(ref String&);

See Also

EntitiesEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntitiesEntity.Validate Method (String&)

public override bool Validate(
ref String& ErrorString
);

See Also

EntitiesEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace | EntitiesEntity.Validate Overload List


EntitiesEntity.VerifyForeignKeys Method

This method will get a list of the foreign keys that exist on the entity and then compare it with the meta-data and automatically add any missing foreign keys.

public void VerifyForeignKeys(
Boolean AllowGUI
);

Parameters

AllowGUI

Implements

IEntitySchema.

Remarks

See Also

EntitiesEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntitiesEntity.EntityDBObject Enumeration

public enum EntitiesEntity.EntityDBObject

Members

Member Name | Description
GetRecord |
GetRelatedRecords |
CreateRecord |
UpdateRecord |
DeleteRecord |
DeleteRelatedRecords |
GetDependants |

Requirements

Namespace: Aptify.Framework.BusinessLogic.Entity

Assembly: AptifyEntitiesEntity (in AptifyEntitiesEntity.dll)

See Also

Aptify.Framework.BusinessLogic.Entity Namespace


EntityBaseViewsEntity Class

For a list of all members of this type, see EntityBaseViewsEntity Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
EntityBaseViewsEntity

public class EntityBaseViewsEntity : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.Entity

Assembly: AptifyEntitiesEntity (in AptifyEntitiesEntity.dll)

See Also

EntityBaseViewsEntity Members | Aptify.Framework.BusinessLogic.Entity Namespace


EntityBaseViewsEntity Members

EntityBaseViewsEntity overview

Public Instance Constructors

EntityBaseViewsEntity Constructor Initializes a new instance of the EntityBaseViewsEntity class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded. After the standard validation logic, check the other EntityBaseViews sub-type records looking for a duplicate Name, including a match with the Entity's Base View. If a duplicate is found, validation fails. Also, there must be at least one EntityBaseViewFields record and one of the Fields must be ID.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

EntityBaseViewsEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntityBaseViewsEntity Constructor

Initializes a new instance of the EntityBaseViewsEntity class.

public EntityBaseViewsEntity();

See Also

EntityBaseViewsEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntityBaseViewsEntity Methods

The methods of the EntityBaseViewsEntity class are listed below. For a complete list of EntityBaseViewsEntity class members, see the EntityBaseViewsEntity Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded. After the standard validation logic, check the other EntityBaseViews sub-type records looking for a duplicate Name, including a match with the Entity's Base View. If a duplicate is found, validation fails. Also, there must be at least one EntityBaseViewFields record and one of the Fields must be ID.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

EntityBaseViewsEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


Validate Method

Aptify 5.0 Software Development Kit (SDK)

EntityBaseViewsEntity.Validate Method

After the standard validation logic, check the other EntityBaseViews sub-type records looking for a duplicate Name, including a match with the Entity's Base View. If a duplicate is found, validation fails. Also, there must be at least one EntityBaseViewFields record and one of the Fields must be ID.

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Validate();

After the standard validation logic, check the other EntityBaseViews sub-type records looking for a duplicate Name, including a match with the Entity's Base View. If a duplicate is found, validation fails. Also, there must be at least one EntityBaseViewFields record and one of the Fields must be ID.

public override bool Validate(ref String&);

See Also

EntityBaseViewsEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntityBaseViewsEntity.Validate Method (String&)

After the standard validation logic, check the other EntityBaseViews sub-type records looking for a duplicate Name, including a match with the Entity's Base View. If a duplicate is found, validation fails. Also, there must be at least one EntityBaseViewFields record and one of the Fields must be ID.

public override bool Validate(
ref String& ErrorString
);

Parameters

ErrorString

Return Value

Remarks

See Also

EntityBaseViewsEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace | EntityBaseViewsEntity.Validate Overload List


EntityBulkOperation Class

The standard Aptify implementation of IEntityBulkOperation

For a list of all members of this type, see EntityBulkOperation Members.

System.Object
EntityBulkOperation

public class EntityBulkOperation : IEntityBulkOperation

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

This class is sealed. If a developer wishes to develop a new Entity Bulk Operation, then they should implement IEntityBulkOperation.

Requirements

Namespace: Aptify.Framework.BusinessLogic.Entity

Assembly: AptifyEntityBulkOperations (in AptifyEntityBulkOperations.dll)

See Also

EntityBulkOperation Members | Aptify.Framework.BusinessLogic.Entity Namespace


EntityBulkOperation Members

EntityBulkOperation overview

Public Instance Constructors

EntityBulkOperation Constructor Initializes a new instance of the EntityBulkOperation class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ProcessRecord | Processes a Record GE based on the Entity Bulk Operation provided.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

EntityBulkOperation Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntityBulkOperation Constructor

Initializes a new instance of the EntityBulkOperation class.

public EntityBulkOperation();

See Also

EntityBulkOperation Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntityBulkOperation Methods

The methods of the EntityBulkOperation class are listed below. For a complete list of EntityBulkOperation class members, see the EntityBulkOperation Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ProcessRecord | Processes a Record GE based on the Entity Bulk Operation provided.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

EntityBulkOperation Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntityBulkOperation.ProcessRecord Method

Processes a Record GE based on the Entity Bulk Operation provided.

public void ProcessRecord(
AptifyApplication ApplicationObject,
Boolean AllowGUI,
AptifyGenericEntityBase EntityBulkOperationGE,
AptifyGenericEntityBase RecordToProcessGE,
params Object[] PromptValues
);

Implements

IEntityBulkOperation.

See Also

EntityBulkOperation Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntityBulkOperationException Class

This exception may be thrown while an Entity Bulk Operation is attempting to process.

For a list of all members of this type, see EntityBulkOperationException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
EntityBulkOperationException

public class EntityBulkOperationException : BaseApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.Entity

Assembly: AptifyEntityBulkOperations (in AptifyEntityBulkOperations.dll)

See Also

EntityBulkOperationException Members | Aptify.Framework.BusinessLogic.Entity Namespace


EntityBulkOperationException Members

EntityBulkOperationException overview

Public Instance Constructors

EntityBulkOperationException Overloaded. Initializes a new instance of the EntityBulkOperationException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from BaseApplicationException) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EntityBulkOperationException Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntityBulkOperationException Constructor

Initializes a new instance of the EntityBulkOperationException class.

Overload List

Initializes a new instance of the EntityBulkOperationException class.

public EntityBulkOperationException();

public EntityBulkOperationException(String);

public EntityBulkOperationException(String,Exception);

See Also

EntityBulkOperationException Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntityBulkOperationException Constructor ()

Initializes a new instance of the EntityBulkOperationException class.

public EntityBulkOperationException();

See Also

EntityBulkOperationException Class | Aptify.Framework.BusinessLogic.Entity Namespace | EntityBulkOperationException Constructor Overload List


EntityBulkOperationException Constructor (String)

public EntityBulkOperationException(
String Message
);

See Also

EntityBulkOperationException Class | Aptify.Framework.BusinessLogic.Entity Namespace | EntityBulkOperationException Constructor Overload List


EntityBulkOperationException Constructor (String, Exception)

public EntityBulkOperationException(
String Message,
Exception InnerException
);

See Also

EntityBulkOperationException Class | Aptify.Framework.BusinessLogic.Entity Namespace | EntityBulkOperationException Constructor Overload List


EntityBulkOperationGroupPermissionsViewer Class

This is the custom viewer data form for Enity Bulk Operations GroupPermissions subtype entity.

For a list of all members of this type, see EntityBulkOperationGroupPermissionsViewer Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
EntityBulkOperationGroupPermissionsViewer

public class EntityBulkOperationGroupPermissionsViewer : Form, IAptifySubTypeViewer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.Entity

Assembly: AptifyEntityBulkOperationsViewer (in AptifyEntityBulkOperationsViewer.dll)

See Also

EntityBulkOperationGroupPermissionsViewer Members | Aptify.Framework.BusinessLogic.Entity Namespace


EntityBulkOperationGroupPermissionsViewer Members

EntityBulkOperationGroupPermissionsViewer overview

Public Instance Constructors

EntityBulkOperationGroupPermissionsViewer Constructor Initializes a new instance of the EntityBulkOperationGroupPermissionsViewer class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config | Overloaded.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog | Overloaded.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog with the specified owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

EntityBulkOperationGroupPermissionsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntityBulkOperationGroupPermissionsViewer Constructor

Initializes a new instance of the EntityBulkOperationGroupPermissionsViewer class.

public EntityBulkOperationGroupPermissionsViewer();

See Also

EntityBulkOperationGroupPermissionsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntityBulkOperationGroupPermissionsViewer Methods

The methods of the EntityBulkOperationGroupPermissionsViewer class are listed below. For a complete list of EntityBulkOperationGroupPermissionsViewer class members, see the EntityBulkOperationGroupPermissionsViewer Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config | Overloaded.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog | Overloaded.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog with the specified owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

EntityBulkOperationGroupPermissionsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace


Config Method

Aptify 5.0 Software Development Kit (SDK)

EntityBulkOperationGroupPermissionsViewer.Config Method

Overload List

public void Config(AptifyGenericEntityBase);

public void Config(AptifyGenericEntityBase,String);

public void Config(AptifyGenericEntityBase,String,String);

See Also

EntityBulkOperationGroupPermissionsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntityBulkOperationGroupPermissionsViewer.Config Method (AptifyGenericEntityBase)

public void Config(
AptifyGenericEntityBase subTypeGE
);

Implements

IAptifySubTypeViewer.

See Also

EntityBulkOperationGroupPermissionsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace | EntityBulkOperationGroupPermissionsViewer.Config Overload List


EntityBulkOperationGroupPermissionsViewer.Config Method (AptifyGenericEntityBase, String)

public void Config(
AptifyGenericEntityBase subTypeGE,
String CmdString
);

Implements

IAptifySubTypeViewer.

See Also

EntityBulkOperationGroupPermissionsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace | EntityBulkOperationGroupPermissionsViewer.Config Overload List


EntityBulkOperationGroupPermissionsViewer.Config Method (AptifyGenericEntityBase, String, String)

public void Config(
AptifyGenericEntityBase subTypeGE,
String CmdString,
String Caption
);

Implements

IAptifySubTypeViewer.

See Also

EntityBulkOperationGroupPermissionsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace | EntityBulkOperationGroupPermissionsViewer.Config Overload List


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

EntityBulkOperationGroupPermissionsViewer.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

EntityBulkOperationGroupPermissionsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntityBulkOperationGroupPermissionsViewer.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

EntityBulkOperationGroupPermissionsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace | EntityBulkOperationGroupPermissionsViewer.Dispose Overload List


ShowDialog Method

Aptify 5.0 Software Development Kit (SDK)

EntityBulkOperationGroupPermissionsViewer.ShowDialog Method

Overload List

new public DialogResult ShowDialog();

public DialogResult ShowDialog(Form);

Inherited from Form.

public DialogResult ShowDialog(IWin32Window);

See Also

EntityBulkOperationGroupPermissionsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntityBulkOperationGroupPermissionsViewer.ShowDialog Method ()

new public DialogResult ShowDialog();

Implements

IAptifySubTypeViewer.

See Also

EntityBulkOperationGroupPermissionsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace | EntityBulkOperationGroupPermissionsViewer.ShowDialog Overload List


EntityBulkOperationGroupPermissionsViewer.ShowDialog Method (Form)

public DialogResult ShowDialog(
Form parentForm
);

Implements

IAptifySubTypeViewer.

See Also

EntityBulkOperationGroupPermissionsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace | EntityBulkOperationGroupPermissionsViewer.ShowDialog Overload List


EntityBulkOperationProcess Class

The standard Aptify implementation of the IEntityBulkOperationProcessor interface.

For a list of all members of this type, see EntityBulkOperationProcess Members.

System.Object
EntityBulkOperationProcess

public class EntityBulkOperationProcess : IEntityBulkOperationProcessor, IStatus

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

If you do not want the Object Repository to try and download the Standard Record Processor, then omit the StandardRecordObject attribute from the [Entity Bulk Operations] entity.

Requirements

Namespace: Aptify.Framework.BusinessLogic.Entity

Assembly: AptifyEntityBulkOperations (in AptifyEntityBulkOperations.dll)

See Also

EntityBulkOperationProcess Members | Aptify.Framework.BusinessLogic.Entity Namespace


EntityBulkOperationProcess Members

EntityBulkOperationProcess overview

Public Instance Constructors

EntityBulkOperationProcess Constructor Initializes a new instance of the EntityBulkOperationProcess class.

Public Instance Properties

Status

Public Instance Methods

Cancel |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

Canceled
Finished
StatusChanged

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EntityBulkOperationProcess Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntityBulkOperationProcess Constructor

Initializes a new instance of the EntityBulkOperationProcess class.

public EntityBulkOperationProcess();

See Also

EntityBulkOperationProcess Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntityBulkOperationProcess Properties

The properties of the EntityBulkOperationProcess class are listed below. For a complete list of EntityBulkOperationProcess class members, see the EntityBulkOperationProcess Members topic.

Public Instance Properties

Status

See Also

EntityBulkOperationProcess Class | Aptify.Framework.BusinessLogic.Entity Namespace


Status Property

Aptify 5.0 Software Development Kit (SDK)

EntityBulkOperationProcess.Status Property

public Status Status {get;}

Implements

IStatus.

See Also

EntityBulkOperationProcess Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntityBulkOperationProcess Methods

The methods of the EntityBulkOperationProcess class are listed below. For a complete list of EntityBulkOperationProcess class members, see the EntityBulkOperationProcess Members topic.

Public Instance Methods

Cancel |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EntityBulkOperationProcess Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntityBulkOperationProcess.Cancel Method

public virtual void Cancel();

Implements

IEntityBulkOperationProcessor.

See Also

EntityBulkOperationProcess Class | Aptify.Framework.BusinessLogic.Entity Namespace


Run Method

Aptify 5.0 Software Development Kit (SDK)

EntityBulkOperationProcess.Run Method

Overload List

public virtual void Run(UserCredentials,Boolean,Int64,Int64,params Object[]);

public virtual void Run(UserCredentials,Boolean,Int64,Object[],params Object[]);

public virtual void Run(UserCredentials,Boolean,Int64,String,params Object[]);

See Also

EntityBulkOperationProcess Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntityBulkOperationProcess.Run Method (UserCredentials, Boolean, Int64, Int64, Object[])

public virtual void Run(
UserCredentials UserCredential,
Boolean AllowGUI,
Int64 EntityBulkOperationID,
Int64 ViewID,
params Object[] PromptValues
);

Implements

IEntityBulkOperationProcessor.

See Also

EntityBulkOperationProcess Class | Aptify.Framework.BusinessLogic.Entity Namespace | EntityBulkOperationProcess.Run Overload List


EntityBulkOperationProcess.Run Method (UserCredentials, Boolean, Int64, Object[], Object[])

public virtual void Run(
UserCredentials UserCredential,
Boolean AllowGUI,
Int64 EntityBulkOperationID,
Object[] SelectedIDs,
params Object[] PromptValues
);

Implements

IEntityBulkOperationProcessor.

See Also

EntityBulkOperationProcess Class | Aptify.Framework.BusinessLogic.Entity Namespace | EntityBulkOperationProcess.Run Overload List


EntityBulkOperationProcess.Run Method (UserCredentials, Boolean, Int64, String, Object[])

public virtual void Run(
UserCredentials UserCredential,
Boolean AllowGUI,
Int64 EntityBulkOperationID,
String SQL,
params Object[] PromptValues
);

Implements

IEntityBulkOperationProcessor.

See Also

EntityBulkOperationProcess Class | Aptify.Framework.BusinessLogic.Entity Namespace | EntityBulkOperationProcess.Run Overload List


EntityBulkOperationProcess Events

The events of the EntityBulkOperationProcess class are listed below. For a complete list of EntityBulkOperationProcess class members, see the EntityBulkOperationProcess Members topic.

Public Instance Events

Canceled
Finished
StatusChanged

See Also

EntityBulkOperationProcess Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntityBulkOperationProcess.EventHandler Event

public event EventHandler Canceled;

Implements

IStatus.

See Also

EntityBulkOperationProcess Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntityBulkOperationProcess.EventHandler Event

public event EventHandler Finished;

Implements

IStatus.

See Also

EntityBulkOperationProcess Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntityBulkOperationProcess.StatusChangedEventHandler Event

public event StatusChangedEventHandler StatusChanged;

Event Data

The event handler receives an argument of type StatusChangedEventArgs containing data related to this event. The following StatusChangedEventArgs property provides information specific to this event.

Property | Description
Status |

Implements

IStatus.

See Also

EntityBulkOperationProcess Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntityBulkOperationRulesViewer Class

This is the custom viewer data form for Enity Bulk Operations Rules subtype entity.

For a list of all members of this type, see EntityBulkOperationRulesViewer Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
EntityBulkOperationRulesViewer

public class EntityBulkOperationRulesViewer : Form, IAptifySubTypeViewer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.Entity

Assembly: AptifyEntityBulkOperationsViewer (in AptifyEntityBulkOperationsViewer.dll)

See Also

EntityBulkOperationRulesViewer Members | Aptify.Framework.BusinessLogic.Entity Namespace


EntityBulkOperationRulesViewer Members

EntityBulkOperationRulesViewer overview

Public Instance Constructors

EntityBulkOperationRulesViewer Constructor Initializes a new instance of the EntityBulkOperationRulesViewer class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config | Overloaded.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog | Overloaded.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog with the specified owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

EntityBulkOperationRulesViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntityBulkOperationRulesViewer Constructor

Initializes a new instance of the EntityBulkOperationRulesViewer class.

public EntityBulkOperationRulesViewer();

See Also

EntityBulkOperationRulesViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntityBulkOperationRulesViewer Methods

The methods of the EntityBulkOperationRulesViewer class are listed below. For a complete list of EntityBulkOperationRulesViewer class members, see the EntityBulkOperationRulesViewer Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config | Overloaded.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog | Overloaded.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog with the specified owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

EntityBulkOperationRulesViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntityBulkOperationRulesViewer.ApplySkin Method

protected virtual void ApplySkin();

See Also

EntityBulkOperationRulesViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace


Config Method

Aptify 5.0 Software Development Kit (SDK)

EntityBulkOperationRulesViewer.Config Method

Overload List

public void Config(AptifyGenericEntityBase);

public void Config(AptifyGenericEntityBase,String);

public void Config(AptifyGenericEntityBase,String,String);

See Also

EntityBulkOperationRulesViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntityBulkOperationRulesViewer.Config Method (AptifyGenericEntityBase)

public void Config(
AptifyGenericEntityBase subTypeGE
);

Implements

IAptifySubTypeViewer.

See Also

EntityBulkOperationRulesViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace | EntityBulkOperationRulesViewer.Config Overload List


EntityBulkOperationRulesViewer.Config Method (AptifyGenericEntityBase, String)

public void Config(
AptifyGenericEntityBase subTypeGE,
String CmdString
);

Implements

IAptifySubTypeViewer.

See Also

EntityBulkOperationRulesViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace | EntityBulkOperationRulesViewer.Config Overload List


EntityBulkOperationRulesViewer.Config Method (AptifyGenericEntityBase, String, String)

public void Config(
AptifyGenericEntityBase subTypeGE,
String CmdString,
String Caption
);

Implements

IAptifySubTypeViewer.

See Also

EntityBulkOperationRulesViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace | EntityBulkOperationRulesViewer.Config Overload List


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

EntityBulkOperationRulesViewer.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

EntityBulkOperationRulesViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntityBulkOperationRulesViewer.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

EntityBulkOperationRulesViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace | EntityBulkOperationRulesViewer.Dispose Overload List


ShowDialog Method

Aptify 5.0 Software Development Kit (SDK)

EntityBulkOperationRulesViewer.ShowDialog Method

Overload List

new public DialogResult ShowDialog();

public DialogResult ShowDialog(Form);

Inherited from Form.

public DialogResult ShowDialog(IWin32Window);

See Also

EntityBulkOperationRulesViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntityBulkOperationRulesViewer.ShowDialog Method ()

new public DialogResult ShowDialog();

Implements

IAptifySubTypeViewer.

See Also

EntityBulkOperationRulesViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace | EntityBulkOperationRulesViewer.ShowDialog Overload List


EntityBulkOperationRulesViewer.ShowDialog Method (Form)

public DialogResult ShowDialog(
Form parentForm
);

Implements

IAptifySubTypeViewer.

See Also

EntityBulkOperationRulesViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace | EntityBulkOperationRulesViewer.ShowDialog Overload List


EntityBulkOperationsDashboardButtonPropertiesPage Class

For a list of all members of this type, see EntityBulkOperationsDashboardButtonPropertiesPage Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
EntityBulkOperationsDashboardButtonPropertiesPage

public class EntityBulkOperationsDashboardButtonPropertiesPage : UserControl, IDashboardPropPage

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.Entity

Assembly: AptifyEntityBulkOperationsDashboard (in AptifyEntityBulkOperationsDashboard.dll)

See Also

EntityBulkOperationsDashboardButtonPropertiesPage Members | Aptify.Framework.BusinessLogic.Entity Namespace


EntityBulkOperationsDashboardButtonPropertiesPage Members

EntityBulkOperationsDashboardButtonPropertiesPage overview

Public Instance Constructors

EntityBulkOperationsDashboardButtonPropertiesPage Constructor Initializes a new instance of the EntityBulkOperationsDashboardButtonPropertiesPage class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LoadProperties |
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
SaveProperties |
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

EntityBulkOperationsDashboardButtonPropertiesPage Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntityBulkOperationsDashboardButtonPropertiesPage Constructor

Initializes a new instance of the EntityBulkOperationsDashboardButtonPropertiesPage class.

public EntityBulkOperationsDashboardButtonPropertiesPage();

See Also

EntityBulkOperationsDashboardButtonPropertiesPage Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntityBulkOperationsDashboardButtonPropertiesPage Methods

The methods of the EntityBulkOperationsDashboardButtonPropertiesPage class are listed below. For a complete list of EntityBulkOperationsDashboardButtonPropertiesPage class members, see the EntityBulkOperationsDashboardButtonPropertiesPage Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LoadProperties |
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
SaveProperties |
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

EntityBulkOperationsDashboardButtonPropertiesPage Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntityBulkOperationsDashboardButtonPropertiesPage.Config Method

public void Config(
AptifyApplication ApplicationObject
);

Implements

IDashboardPropPage.

See Also

EntityBulkOperationsDashboardButtonPropertiesPage Class | Aptify.Framework.BusinessLogic.Entity Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

EntityBulkOperationsDashboardButtonPropertiesPage.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

EntityBulkOperationsDashboardButtonPropertiesPage Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntityBulkOperationsDashboardButtonPropertiesPage.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

EntityBulkOperationsDashboardButtonPropertiesPage Class | Aptify.Framework.BusinessLogic.Entity Namespace | EntityBulkOperationsDashboardButtonPropertiesPage.Dispose Overload List


EntityBulkOperationsDashboardButtonPropertiesPage.LoadProperties Method

public void LoadProperties(
AptifyGenericEntityBase Part
);

Implements

IDashboardPropPage.

See Also

EntityBulkOperationsDashboardButtonPropertiesPage Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntityBulkOperationsDashboardButtonPropertiesPage.SaveProperties Method

public void SaveProperties();

Implements

IDashboardPropPage.

See Also

EntityBulkOperationsDashboardButtonPropertiesPage Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntityBulkOperationsRibbonButtonPropertiesPage Class

For a list of all members of this type, see EntityBulkOperationsRibbonButtonPropertiesPage Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
EntityBulkOperationsRibbonButtonPropertiesPage

public class EntityBulkOperationsRibbonButtonPropertiesPage : UserControl, IRibbonButtonPropPage

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.Entity

Assembly: AptifyEntityBulkOperationsRibbon (in AptifyEntityBulkOperationsRibbon.dll)

See Also

EntityBulkOperationsRibbonButtonPropertiesPage Members | Aptify.Framework.BusinessLogic.Entity Namespace


EntityBulkOperationsRibbonButtonPropertiesPage Members

EntityBulkOperationsRibbonButtonPropertiesPage overview

Public Instance Constructors

EntityBulkOperationsRibbonButtonPropertiesPage Constructor Initializes a new instance of the EntityBulkOperationsRibbonButtonPropertiesPage class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LoadProperties |
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
SaveProperties |
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

EntityBulkOperationsRibbonButtonPropertiesPage Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntityBulkOperationsRibbonButtonPropertiesPage Constructor

Initializes a new instance of the EntityBulkOperationsRibbonButtonPropertiesPage class.

public EntityBulkOperationsRibbonButtonPropertiesPage();

See Also

EntityBulkOperationsRibbonButtonPropertiesPage Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntityBulkOperationsRibbonButtonPropertiesPage Methods

The methods of the EntityBulkOperationsRibbonButtonPropertiesPage class are listed below. For a complete list of EntityBulkOperationsRibbonButtonPropertiesPage class members, see the EntityBulkOperationsRibbonButtonPropertiesPage Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LoadProperties |
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
SaveProperties |
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

EntityBulkOperationsRibbonButtonPropertiesPage Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntityBulkOperationsRibbonButtonPropertiesPage.Config Method

public void Config(
AptifyApplication ApplicationObject
);

Implements

IRibbonButtonPropPage.

See Also

EntityBulkOperationsRibbonButtonPropertiesPage Class | Aptify.Framework.BusinessLogic.Entity Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

EntityBulkOperationsRibbonButtonPropertiesPage.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

EntityBulkOperationsRibbonButtonPropertiesPage Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntityBulkOperationsRibbonButtonPropertiesPage.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

EntityBulkOperationsRibbonButtonPropertiesPage Class | Aptify.Framework.BusinessLogic.Entity Namespace | EntityBulkOperationsRibbonButtonPropertiesPage.Dispose Overload List


EntityBulkOperationsRibbonButtonPropertiesPage.LoadProperties Method

public void LoadProperties(
AptifyGenericEntityBase Part
);

Implements

IRibbonButtonPropPage.

See Also

EntityBulkOperationsRibbonButtonPropertiesPage Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntityBulkOperationsRibbonButtonPropertiesPage.SaveProperties Method

public void SaveProperties();

Implements

IRibbonButtonPropPage.

See Also

EntityBulkOperationsRibbonButtonPropertiesPage Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntityBulkOperationsViewer Class

This is the custom viewer data form for Enity Bulk Operations entity.

For a list of all members of this type, see EntityBulkOperationsViewer Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
EntityBulkOperationsViewer

public class EntityBulkOperationsViewer : Form, IAptifyTopLevelViewer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.Entity

Assembly: AptifyEntityBulkOperationsViewer (in AptifyEntityBulkOperationsViewer.dll)

See Also

EntityBulkOperationsViewer Members | Aptify.Framework.BusinessLogic.Entity Namespace


EntityBulkOperationsViewer Members

EntityBulkOperationsViewer overview

Public Instance Constructors

EntityBulkOperationsViewer Constructor Initializes a new instance of the EntityBulkOperationsViewer class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config | Overloaded.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show | Overloaded.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
ShowDialog | Overloaded.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog with the specified owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

EntityBulkOperationsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntityBulkOperationsViewer Constructor

Initializes a new instance of the EntityBulkOperationsViewer class.

public EntityBulkOperationsViewer();

See Also

EntityBulkOperationsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntityBulkOperationsViewer Methods

The methods of the EntityBulkOperationsViewer class are listed below. For a complete list of EntityBulkOperationsViewer class members, see the EntityBulkOperationsViewer Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config | Overloaded.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show | Overloaded.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
ShowDialog | Overloaded.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog with the specified owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

EntityBulkOperationsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntityBulkOperationsViewer.ApplySkin Method

protected virtual void ApplySkin();

See Also

EntityBulkOperationsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace


Config Method

Aptify 5.0 Software Development Kit (SDK)

EntityBulkOperationsViewer.Config Method

Overload List

public void Config(AptifyGenericEntityBase);

public void Config(UserCredentials,String);

public void Config(UserCredentials,String,Int64);

public void Config(UserCredentials,String,String);

See Also

EntityBulkOperationsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntityBulkOperationsViewer.Config Method (AptifyGenericEntityBase)

public void Config(
AptifyGenericEntityBase GE
);

Implements

IAptifyTopLevelViewer.

See Also

EntityBulkOperationsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace | EntityBulkOperationsViewer.Config Overload List


EntityBulkOperationsViewer.Config Method (UserCredentials, String)

public void Config(
UserCredentials UserCredentials,
String CmdString
);

Implements

IAptifyTopLevelViewer.

See Also

EntityBulkOperationsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace | EntityBulkOperationsViewer.Config Overload List


EntityBulkOperationsViewer.Config Method (UserCredentials, String, Int64)

public void Config(
UserCredentials UserCredentials,
String EntityName,
Int64 RecordID
);

Implements

IAptifyTopLevelViewer.

See Also

EntityBulkOperationsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace | EntityBulkOperationsViewer.Config Overload List


EntityBulkOperationsViewer.Config Method (UserCredentials, String, String)

public void Config(
UserCredentials UserCredentials,
String EntityName,
String NewRecordParameters
);

Implements

IAptifyTopLevelViewer.

See Also

EntityBulkOperationsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace | EntityBulkOperationsViewer.Config Overload List


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

EntityBulkOperationsViewer.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

EntityBulkOperationsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntityBulkOperationsViewer.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

EntityBulkOperationsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace | EntityBulkOperationsViewer.Dispose Overload List


Show Method

Aptify 5.0 Software Development Kit (SDK)

EntityBulkOperationsViewer.Show Method

Overload List

new public void Show();

public void Show(Form);

Inherited from Form.

public void Show(IWin32Window);

See Also

EntityBulkOperationsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntityBulkOperationsViewer.Show Method ()

new public void Show();

Implements

IAptifyTopLevelViewer.

See Also

EntityBulkOperationsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace | EntityBulkOperationsViewer.Show Overload List


EntityBulkOperationsViewer.Show Method (Form)

public void Show(
Form ParentForm
);

Implements

IAptifyTopLevelViewer.

See Also

EntityBulkOperationsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace | EntityBulkOperationsViewer.Show Overload List


ShowDialog Method

Aptify 5.0 Software Development Kit (SDK)

EntityBulkOperationsViewer.ShowDialog Method

Overload List

new public DialogResult ShowDialog();

public DialogResult ShowDialog(Form);

Inherited from Form.

public DialogResult ShowDialog(IWin32Window);

See Also

EntityBulkOperationsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntityBulkOperationsViewer.ShowDialog Method ()

new public DialogResult ShowDialog();

Implements

IAptifyTopLevelViewer.

See Also

EntityBulkOperationsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace | EntityBulkOperationsViewer.ShowDialog Overload List


EntityBulkOperationsViewer.ShowDialog Method (Form)

public DialogResult ShowDialog(
Form ParentForm
);

Implements

IAptifyTopLevelViewer.

See Also

EntityBulkOperationsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace | EntityBulkOperationsViewer.ShowDialog Overload List


EntityBulkOperationsWizardForm Class

Provides the user interface for the standard Aptify Entity Bulk Operations Wizard.

For a list of all members of this type, see EntityBulkOperationsWizardForm Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
EntityBulkOperationsWizardForm

public class EntityBulkOperationsWizardForm : Form, IAptifyAction

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

This is called from the Entity List View. If you do not want the Object repository to try and download the Processor object from the repository then do not specify the [ProcessObject] attribute on the [Entity Bulk Operations] entity.

Requirements

Namespace: Aptify.Framework.BusinessLogic.Entity

Assembly: AptifyEntityBulkOperationsWizard (in AptifyEntityBulkOperationsWizard.dll)

See Also

EntityBulkOperationsWizardForm Members | Aptify.Framework.BusinessLogic.Entity Namespace


EntityBulkOperationsWizardForm Members

EntityBulkOperationsWizardForm overview

Public Instance Constructors

EntityBulkOperationsWizardForm Constructor Initializes a new instance of the EntityBulkOperationsWizardForm class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config | Allows a user to configure the Wizard prior to running the form in a stand alone mode.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoAction | Overloaded.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

EntityBulkOperationsWizardForm Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntityBulkOperationsWizardForm Constructor

Initializes a new instance of the EntityBulkOperationsWizardForm class.

public EntityBulkOperationsWizardForm();

See Also

EntityBulkOperationsWizardForm Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntityBulkOperationsWizardForm Methods

The methods of the EntityBulkOperationsWizardForm class are listed below. For a complete list of EntityBulkOperationsWizardForm class members, see the EntityBulkOperationsWizardForm Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config | Allows a user to configure the Wizard prior to running the form in a stand alone mode.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoAction | Overloaded.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

EntityBulkOperationsWizardForm Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntityBulkOperationsWizardForm.Config Method

Allows a user to configure the Wizard prior to running the form in a stand alone mode.

public void Config(
AptifyApplication ApplicationObject,
Int64 EntityID
);

Parameters

ApplicationObject
EntityID

See Also

EntityBulkOperationsWizardForm Class | Aptify.Framework.BusinessLogic.Entity Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

EntityBulkOperationsWizardForm.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

EntityBulkOperationsWizardForm Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntityBulkOperationsWizardForm.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

EntityBulkOperationsWizardForm Class | Aptify.Framework.BusinessLogic.Entity Namespace | EntityBulkOperationsWizardForm.Dispose Overload List


DoAction Method

Aptify 5.0 Software Development Kit (SDK)

EntityBulkOperationsWizardForm.DoAction Method

Overload List

public void DoAction(AptifyApplication,Int64);

public void DoAction(AptifyApplication,Int64,Int64);

Configures and displays the Entity Bulk Operations Wizard.

public void DoAction(AptifyApplication,Int64,Int64,params Object[]);

public void DoAction(AptifyApplication,Int64,params String[]);

See Also

EntityBulkOperationsWizardForm Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntityBulkOperationsWizardForm.DoAction Method (AptifyApplication, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID
);

Implements

IAptifyAction.

See Also

EntityBulkOperationsWizardForm Class | Aptify.Framework.BusinessLogic.Entity Namespace | EntityBulkOperationsWizardForm.DoAction Overload List


EntityBulkOperationsWizardForm.DoAction Method (AptifyApplication, Int64, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID
);

Implements

IAptifyAction.

See Also

EntityBulkOperationsWizardForm Class | Aptify.Framework.BusinessLogic.Entity Namespace | EntityBulkOperationsWizardForm.DoAction Overload List


EntityBulkOperationsWizardForm.DoAction Method (AptifyApplication, Int64, Int64, Object[])

Configures and displays the Entity Bulk Operations Wizard.

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID,
params Object[] SelectedItems
);

Parameters

ApplicationObject
EntityID
ViewID
SelectedItems

Implements

IAptifyAction.

Remarks

See Also

EntityBulkOperationsWizardForm Class | Aptify.Framework.BusinessLogic.Entity Namespace | EntityBulkOperationsWizardForm.DoAction Overload List


EntityBulkOperationsWizardForm.DoAction Method (AptifyApplication, Int64, String[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
params String[] SelectedItems
);

Implements

IAptifyAction.

See Also

EntityBulkOperationsWizardForm Class | Aptify.Framework.BusinessLogic.Entity Namespace | EntityBulkOperationsWizardForm.DoAction Overload List


EntityBulkOperationUserPermissionsViewer Class

This is the custom viewer data form for Enity Bulk Operations UserPermissions subtype entity.

For a list of all members of this type, see EntityBulkOperationUserPermissionsViewer Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
EntityBulkOperationUserPermissionsViewer

public class EntityBulkOperationUserPermissionsViewer : Form, IAptifySubTypeViewer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.Entity

Assembly: AptifyEntityBulkOperationsViewer (in AptifyEntityBulkOperationsViewer.dll)

See Also

EntityBulkOperationUserPermissionsViewer Members | Aptify.Framework.BusinessLogic.Entity Namespace


EntityBulkOperationUserPermissionsViewer Members

EntityBulkOperationUserPermissionsViewer overview

Public Instance Constructors

EntityBulkOperationUserPermissionsViewer Constructor Initializes a new instance of the EntityBulkOperationUserPermissionsViewer class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config | Overloaded.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog | Overloaded.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog with the specified owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

EntityBulkOperationUserPermissionsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntityBulkOperationUserPermissionsViewer Constructor

Initializes a new instance of the EntityBulkOperationUserPermissionsViewer class.

public EntityBulkOperationUserPermissionsViewer();

See Also

EntityBulkOperationUserPermissionsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntityBulkOperationUserPermissionsViewer Methods

The methods of the EntityBulkOperationUserPermissionsViewer class are listed below. For a complete list of EntityBulkOperationUserPermissionsViewer class members, see the EntityBulkOperationUserPermissionsViewer Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config | Overloaded.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog | Overloaded.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog with the specified owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

EntityBulkOperationUserPermissionsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace


Config Method

Aptify 5.0 Software Development Kit (SDK)

EntityBulkOperationUserPermissionsViewer.Config Method

Overload List

public void Config(AptifyGenericEntityBase);

public void Config(AptifyGenericEntityBase,String);

public void Config(AptifyGenericEntityBase,String,String);

See Also

EntityBulkOperationUserPermissionsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntityBulkOperationUserPermissionsViewer.Config Method (AptifyGenericEntityBase)

public void Config(
AptifyGenericEntityBase subTypeGE
);

Implements

IAptifySubTypeViewer.

See Also

EntityBulkOperationUserPermissionsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace | EntityBulkOperationUserPermissionsViewer.Config Overload List


EntityBulkOperationUserPermissionsViewer.Config Method (AptifyGenericEntityBase, String)

public void Config(
AptifyGenericEntityBase subTypeGE,
String CmdString
);

Implements

IAptifySubTypeViewer.

See Also

EntityBulkOperationUserPermissionsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace | EntityBulkOperationUserPermissionsViewer.Config Overload List


EntityBulkOperationUserPermissionsViewer.Config Method (AptifyGenericEntityBase, String, String)

public void Config(
AptifyGenericEntityBase subTypeGE,
String CmdString,
String Caption
);

Implements

IAptifySubTypeViewer.

See Also

EntityBulkOperationUserPermissionsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace | EntityBulkOperationUserPermissionsViewer.Config Overload List


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

EntityBulkOperationUserPermissionsViewer.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

EntityBulkOperationUserPermissionsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntityBulkOperationUserPermissionsViewer.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

EntityBulkOperationUserPermissionsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace | EntityBulkOperationUserPermissionsViewer.Dispose Overload List


ShowDialog Method

Aptify 5.0 Software Development Kit (SDK)

EntityBulkOperationUserPermissionsViewer.ShowDialog Method

Overload List

new public DialogResult ShowDialog();

public DialogResult ShowDialog(Form);

Inherited from Form.

public DialogResult ShowDialog(IWin32Window);

See Also

EntityBulkOperationUserPermissionsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntityBulkOperationUserPermissionsViewer.ShowDialog Method ()

new public DialogResult ShowDialog();

Implements

IAptifySubTypeViewer.

See Also

EntityBulkOperationUserPermissionsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace | EntityBulkOperationUserPermissionsViewer.ShowDialog Overload List


EntityBulkOperationUserPermissionsViewer.ShowDialog Method (Form)

public DialogResult ShowDialog(
Form parentForm
);

Implements

IAptifySubTypeViewer.

See Also

EntityBulkOperationUserPermissionsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace | EntityBulkOperationUserPermissionsViewer.ShowDialog Overload List


EntityConstraintsEntity Class

This is the Data Plug-In that should be used with the Entity Constraints entity.

For a list of all members of this type, see EntityConstraintsEntity Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
EntityConstraintsEntity

public class EntityConstraintsEntity : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.Entity

Assembly: AptifyEntitiesEntity (in AptifyEntitiesEntity.dll)

See Also

EntityConstraintsEntity Members | Aptify.Framework.BusinessLogic.Entity Namespace


EntityConstraintsEntity Members

EntityConstraintsEntity overview

Public Instance Constructors

EntityConstraintsEntity Constructor Initializes a new instance of the EntityConstraintsEntity class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config | Overloaded.
Delete | Overloaded.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord |
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

EntityConstraintsEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntityConstraintsEntity Constructor

Initializes a new instance of the EntityConstraintsEntity class.

public EntityConstraintsEntity();

See Also

EntityConstraintsEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntityConstraintsEntity Methods

The methods of the EntityConstraintsEntity class are listed below. For a complete list of EntityConstraintsEntity class members, see the EntityConstraintsEntity Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config | Overloaded.
Delete | Overloaded.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord |
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

EntityConstraintsEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


Config Method

Aptify 5.0 Software Development Kit (SDK)

EntityConstraintsEntity.Config Method

Overload List

public override void Config(AptifySubTypeBase);

public override void Config(AptifySubTypeBase,Int64);

public override void Config(UserCredentials,String);

public override void Config(UserCredentials,String,Int64);

See Also

EntityConstraintsEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntityConstraintsEntity.Config Method (AptifySubTypeBase)

public override void Config(
AptifySubTypeBase subType
);

See Also

EntityConstraintsEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace | EntityConstraintsEntity.Config Overload List


EntityConstraintsEntity.Config Method (AptifySubTypeBase, Int64)

public override void Config(
AptifySubTypeBase subType,
Int64 RecordID
);

See Also

EntityConstraintsEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace | EntityConstraintsEntity.Config Overload List


EntityConstraintsEntity.Config Method (UserCredentials, String)

public override void Config(
UserCredentials UserCredentials,
String EntityName
);

See Also

EntityConstraintsEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace | EntityConstraintsEntity.Config Overload List


EntityConstraintsEntity.Config Method (UserCredentials, String, Int64)

public override void Config(
UserCredentials UserCredentials,
String EntityName,
Int64 RecordID
);

See Also

EntityConstraintsEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace | EntityConstraintsEntity.Config Overload List


Delete Method

Aptify 5.0 Software Development Kit (SDK)

EntityConstraintsEntity.Delete Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Delete();

public override bool Delete(String);

See Also

EntityConstraintsEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntityConstraintsEntity.Delete Method (String)

public override bool Delete(
String TransactionID
);

See Also

EntityConstraintsEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace | EntityConstraintsEntity.Delete Overload List


EntityConstraintsEntity.NewRecord Method

public override bool NewRecord();

See Also

EntityConstraintsEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


Validate Method

Aptify 5.0 Software Development Kit (SDK)

EntityConstraintsEntity.Validate Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Validate();

public override bool Validate(ref String&);

See Also

EntityConstraintsEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntityConstraintsEntity.Validate Method (String&)

public override bool Validate(
ref String& ErrorString
);

See Also

EntityConstraintsEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace | EntityConstraintsEntity.Validate Overload List


EntityDefaultBaseViewsEntity Class

For a list of all members of this type, see EntityDefaultBaseViewsEntity Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
EntityDefaultBaseViewsEntity

public class EntityDefaultBaseViewsEntity : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.Entity

Assembly: AptifyEntitiesEntity (in AptifyEntitiesEntity.dll)

See Also

EntityDefaultBaseViewsEntity Members | Aptify.Framework.BusinessLogic.Entity Namespace


EntityDefaultBaseViewsEntity Members

EntityDefaultBaseViewsEntity overview

Public Instance Constructors

EntityDefaultBaseViewsEntity Constructor Initializes a new instance of the EntityDefaultBaseViewsEntity class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded. In addition to the standard validation: 1. The DefaultType value is validated. 2. If the DefaultType is Global, GroupID and UserID are set to -1. 3. If the DefaultType is Group, GroupID is required. 4. If the DefaultType is User, UserID is required. 5. One or both AppliesToViewingSystem and AppliesToFind must be true. 6. BaseView must be either the Name of the Entity or it must match the Name of one of the EntityBaseViews records associated with the Entity.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

EntityDefaultBaseViewsEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntityDefaultBaseViewsEntity Constructor

Initializes a new instance of the EntityDefaultBaseViewsEntity class.

public EntityDefaultBaseViewsEntity();

See Also

EntityDefaultBaseViewsEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntityDefaultBaseViewsEntity Methods

The methods of the EntityDefaultBaseViewsEntity class are listed below. For a complete list of EntityDefaultBaseViewsEntity class members, see the EntityDefaultBaseViewsEntity Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded. In addition to the standard validation: 1. The DefaultType value is validated. 2. If the DefaultType is Global, GroupID and UserID are set to -1. 3. If the DefaultType is Group, GroupID is required. 4. If the DefaultType is User, UserID is required. 5. One or both AppliesToViewingSystem and AppliesToFind must be true. 6. BaseView must be either the Name of the Entity or it must match the Name of one of the EntityBaseViews records associated with the Entity.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

EntityDefaultBaseViewsEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


Validate Method

Aptify 5.0 Software Development Kit (SDK)

EntityDefaultBaseViewsEntity.Validate Method

In addition to the standard validation: 1. The DefaultType value is validated. 2. If the DefaultType is Global, GroupID and UserID are set to -1. 3. If the DefaultType is Group, GroupID is required. 4. If the DefaultType is User, UserID is required. 5. One or both AppliesToViewingSystem and AppliesToFind must be true. 6. BaseView must be either the Name of the Entity or it must match the Name of one of the EntityBaseViews records associated with the Entity.

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Validate();

In addition to the standard validation: 1. The DefaultType value is validated. 2. If the DefaultType is Global, GroupID and UserID are set to -1. 3. If the DefaultType is Group, GroupID is required. 4. If the DefaultType is User, UserID is required. 5. One or both AppliesToViewingSystem and AppliesToFind must be true. 6. BaseView must be either the Name of the Entity or it must match the Name of one of the EntityBaseViews records associated with the Entity.

public override bool Validate(ref String&);

See Also

EntityDefaultBaseViewsEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntityDefaultBaseViewsEntity.Validate Method (String&)

In addition to the standard validation: 1. The DefaultType value is validated. 2. If the DefaultType is Global, GroupID and UserID are set to -1. 3. If the DefaultType is Group, GroupID is required. 4. If the DefaultType is User, UserID is required. 5. One or both AppliesToViewingSystem and AppliesToFind must be true. 6. BaseView must be either the Name of the Entity or it must match the Name of one of the EntityBaseViews records associated with the Entity.

public override bool Validate(
ref String& ErrorString
);

Parameters

ErrorString

Return Value

Remarks

See Also

EntityDefaultBaseViewsEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace | EntityDefaultBaseViewsEntity.Validate Overload List


EntityFieldsEntity Class

For a list of all members of this type, see EntityFieldsEntity Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
EntityFieldsEntity

public class EntityFieldsEntity : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.Entity

Assembly: AptifyEntitiesEntity (in AptifyEntitiesEntity.dll)

See Also

EntityFieldsEntity Members | Aptify.Framework.BusinessLogic.Entity Namespace


EntityFieldsEntity Members

EntityFieldsEntity overview

Public Instance Constructors

EntityFieldsEntity Constructor Initializes a new instance of the EntityFieldsEntity class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config | Overloaded.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
EstimateColumnWidth | This method recalculates the column width of the current entity field based on the SQLDataType and SQLFieldSize. The Column Width is represented by the "Width" field in the meta-data for Entity Fields and is used by the vieiwng system to generate the default viewing column widths in list views. The user can override this to set it to any value so it is only set by this method whenever the Width field is previously set to a blank or zero value. This method is called by the base EntityFieldsEntity class automatically from the SetValue() call for either SQLDataType or SQLFieldSize
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load | Overloaded.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord |
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue |
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded. Validate the entity field with special handling
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

EntityFieldsEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntityFieldsEntity Constructor

Initializes a new instance of the EntityFieldsEntity class.

public EntityFieldsEntity();

See Also

EntityFieldsEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntityFieldsEntity Methods

The methods of the EntityFieldsEntity class are listed below. For a complete list of EntityFieldsEntity class members, see the EntityFieldsEntity Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config | Overloaded.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
EstimateColumnWidth | This method recalculates the column width of the current entity field based on the SQLDataType and SQLFieldSize. The Column Width is represented by the "Width" field in the meta-data for Entity Fields and is used by the vieiwng system to generate the default viewing column widths in list views. The user can override this to set it to any value so it is only set by this method whenever the Width field is previously set to a blank or zero value. This method is called by the base EntityFieldsEntity class automatically from the SetValue() call for either SQLDataType or SQLFieldSize
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load | Overloaded.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord |
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue |
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded. Validate the entity field with special handling
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

EntityFieldsEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


Config Method

Aptify 5.0 Software Development Kit (SDK)

EntityFieldsEntity.Config Method

Overload List

public override void Config(AptifySubTypeBase);

public override void Config(AptifySubTypeBase,Int64);

public override void Config(UserCredentials,String);

public override void Config(UserCredentials,String,Int64);

See Also

EntityFieldsEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntityFieldsEntity.Config Method (AptifySubTypeBase)

public override void Config(
AptifySubTypeBase subType
);

See Also

EntityFieldsEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace | EntityFieldsEntity.Config Overload List


EntityFieldsEntity.Config Method (AptifySubTypeBase, Int64)

public override void Config(
AptifySubTypeBase subType,
Int64 RecordID
);

See Also

EntityFieldsEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace | EntityFieldsEntity.Config Overload List


EntityFieldsEntity.Config Method (UserCredentials, String)

public override void Config(
UserCredentials UserCredentials,
String EntityName
);

See Also

EntityFieldsEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace | EntityFieldsEntity.Config Overload List


EntityFieldsEntity.Config Method (UserCredentials, String, Int64)

public override void Config(
UserCredentials UserCredentials,
String EntityName,
Int64 RecordID
);

See Also

EntityFieldsEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace | EntityFieldsEntity.Config Overload List


EntityFieldsEntity.EstimateColumnWidth Method

This method recalculates the column width of the current entity field based on the SQLDataType and SQLFieldSize. The Column Width is represented by the "Width" field in the meta-data for Entity Fields and is used by the vieiwng system to generate the default viewing column widths in list views. The user can override this to set it to any value so it is only set by this method whenever the Width field is previously set to a blank or zero value. This method is called by the base EntityFieldsEntity class automatically from the SetValue() call for either SQLDataType or SQLFieldSize

public virtual int EstimateColumnWidth(
String SQLDataType,
Int32 SQLFieldSize,
Int32 MaximumWidth
);

Parameters

SQLDataType
SQL Data Type such as char,nchar,ntext, numeric, etc
SQLFieldSize
SQL Field Size, only relevant for fields such as text, char, nchar, varchar, etc
MaximumWidth
Specifies the maximum width (in pixels) that the width will be set to. Defaults to 250 pixels if not provided

Remarks

See Also

EntityFieldsEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


Load Method

Aptify 5.0 Software Development Kit (SDK)

EntityFieldsEntity.Load Method

Overload List

Inherited from AptifyGenericEntity.

public override void Load(DataRow);

Inherited from AptifyGenericEntity.

public override void Load(IDataReader);

public override void Load(Int64);

Inherited from AptifyGenericEntityBase.

public virtual void Load(String);

Inherited from AptifyGenericEntity.

public override void Load(String,Boolean);

See Also

EntityFieldsEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntityFieldsEntity.Load Method (Int64)

public override void Load(
Int64 ID
);

See Also

EntityFieldsEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace | EntityFieldsEntity.Load Overload List


EntityFieldsEntity.NewRecord Method

public override bool NewRecord();

See Also

EntityFieldsEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntityFieldsEntity.SetValue Method

public override void SetValue(
String FieldName,
Object Value
);

See Also

EntityFieldsEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


Validate Method

Aptify 5.0 Software Development Kit (SDK)

EntityFieldsEntity.Validate Method

Validate the entity field with special handling

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Validate();

Validate the entity field with special handling

public override bool Validate(ref String&);

See Also

EntityFieldsEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntityFieldsEntity.Validate Method (String&)

Validate the entity field with special handling

public override bool Validate(
ref String& ErrorString
);

Parameters

ErrorString

Return Value

Remarks

If the EntityField is supposed to validate with script and script is supplied, then we should try to compile the script and make sure it works.

See Also

EntityFieldsEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace | EntityFieldsEntity.Validate Overload List


EntityUserPermissionsEntity Class

For a list of all members of this type, see EntityUserPermissionsEntity Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
EntityUserPermissionsEntity

public class EntityUserPermissionsEntity : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.Entity

Assembly: AptifyEntitiesEntity (in AptifyEntitiesEntity.dll)

See Also

EntityUserPermissionsEntity Members | Aptify.Framework.BusinessLogic.Entity Namespace


EntityUserPermissionsEntity Members

EntityUserPermissionsEntity overview

Public Instance Constructors

EntityUserPermissionsEntity Constructor Initializes a new instance of the EntityUserPermissionsEntity class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config | Overloaded.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue | Overloaded.
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

EntityUserPermissionsEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntityUserPermissionsEntity Constructor

Initializes a new instance of the EntityUserPermissionsEntity class.

public EntityUserPermissionsEntity();

See Also

EntityUserPermissionsEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntityUserPermissionsEntity Methods

The methods of the EntityUserPermissionsEntity class are listed below. For a complete list of EntityUserPermissionsEntity class members, see the EntityUserPermissionsEntity Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config | Overloaded.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue | Overloaded.
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

EntityUserPermissionsEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


Config Method

Aptify 5.0 Software Development Kit (SDK)

EntityUserPermissionsEntity.Config Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual void Config(AptifySubTypeBase);

public override void Config(AptifySubTypeBase,Int64);

Inherited from AptifyGenericEntityBase.

public virtual void Config(UserCredentials,String);

Inherited from AptifyGenericEntity.

public override void Config(UserCredentials,String,Int64);

See Also

EntityUserPermissionsEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntityUserPermissionsEntity.Config Method (AptifySubTypeBase, Int64)

public override void Config(
AptifySubTypeBase subType,
Int64 RecordID
);

See Also

EntityUserPermissionsEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace | EntityUserPermissionsEntity.Config Overload List


SetAddValue Method

Aptify 5.0 Software Development Kit (SDK)

EntityUserPermissionsEntity.SetAddValue Method

Overload List

public override void SetAddValue(String,Object);

Inherited from AptifyGenericEntity.

public override void SetAddValue(String,String,Object);

See Also

EntityUserPermissionsEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


EntityUserPermissionsEntity.SetAddValue Method (String, Object)

public override void SetAddValue(
String FieldName,
Object Value
);

See Also

EntityUserPermissionsEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace | EntityUserPermissionsEntity.SetAddValue Overload List


EventDefinitionsViewer Class

Provides a custom GUI for the [Event Definitions] entity.

For a list of all members of this type, see EventDefinitionsViewer Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
EventDefinitionsViewer

public class EventDefinitionsViewer : Form, IAptifyTopLevelViewer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.Entity

Assembly: AptifyProcessPipelineGUI (in AptifyProcessPipelineGUI.dll)

See Also

EventDefinitionsViewer Members | Aptify.Framework.BusinessLogic.Entity Namespace


EventDefinitionsViewer Members

EventDefinitionsViewer overview

Public Instance Constructors

EventDefinitionsViewer Constructor Initializes a new instance of the EventDefinitionsViewer class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config | Overloaded.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show | Overloaded.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
ShowDialog | Overloaded.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog with the specified owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

EventDefinitionsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace


EventDefinitionsViewer Constructor

Initializes a new instance of the EventDefinitionsViewer class.

public EventDefinitionsViewer();

See Also

EventDefinitionsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace


EventDefinitionsViewer Methods

The methods of the EventDefinitionsViewer class are listed below. For a complete list of EventDefinitionsViewer class members, see the EventDefinitionsViewer Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config | Overloaded.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show | Overloaded.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
ShowDialog | Overloaded.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog with the specified owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

EventDefinitionsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace


EventDefinitionsViewer.ApplySkin Method

protected virtual void ApplySkin();

See Also

EventDefinitionsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace


Config Method

Aptify 5.0 Software Development Kit (SDK)

EventDefinitionsViewer.Config Method

Overload List

public void Config(AptifyGenericEntityBase);

public void Config(UserCredentials,String);

public void Config(UserCredentials,String,Int64);

public void Config(UserCredentials,String,String);

See Also

EventDefinitionsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace


EventDefinitionsViewer.Config Method (AptifyGenericEntityBase)

public void Config(
AptifyGenericEntityBase GE
);

Implements

IAptifyTopLevelViewer.

See Also

EventDefinitionsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace | EventDefinitionsViewer.Config Overload List


EventDefinitionsViewer.Config Method (UserCredentials, String)

public void Config(
UserCredentials UserCredentials,
String CmdString
);

Implements

IAptifyTopLevelViewer.

See Also

EventDefinitionsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace | EventDefinitionsViewer.Config Overload List


EventDefinitionsViewer.Config Method (UserCredentials, String, Int64)

public void Config(
UserCredentials UserCredentials,
String EntityName,
Int64 RecordID
);

Implements

IAptifyTopLevelViewer.

See Also

EventDefinitionsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace | EventDefinitionsViewer.Config Overload List


EventDefinitionsViewer.Config Method (UserCredentials, String, String)

public void Config(
UserCredentials UserCredentials,
String EntityName,
String NewRecordParameters
);

Implements

IAptifyTopLevelViewer.

See Also

EventDefinitionsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace | EventDefinitionsViewer.Config Overload List


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

EventDefinitionsViewer.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

EventDefinitionsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace


EventDefinitionsViewer.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

EventDefinitionsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace | EventDefinitionsViewer.Dispose Overload List


Show Method

Aptify 5.0 Software Development Kit (SDK)

EventDefinitionsViewer.Show Method

Overload List

new public void Show();

public void Show(Form);

Inherited from Form.

public void Show(IWin32Window);

See Also

EventDefinitionsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace


EventDefinitionsViewer.Show Method ()

new public void Show();

Implements

IAptifyTopLevelViewer.

See Also

EventDefinitionsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace | EventDefinitionsViewer.Show Overload List


EventDefinitionsViewer.Show Method (Form)

public void Show(
Form ParentForm
);

Implements

IAptifyTopLevelViewer.

See Also

EventDefinitionsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace | EventDefinitionsViewer.Show Overload List


ShowDialog Method

Aptify 5.0 Software Development Kit (SDK)

EventDefinitionsViewer.ShowDialog Method

Overload List

new public DialogResult ShowDialog();

public DialogResult ShowDialog(Form);

Inherited from Form.

public DialogResult ShowDialog(IWin32Window);

See Also

EventDefinitionsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace


EventDefinitionsViewer.ShowDialog Method ()

new public DialogResult ShowDialog();

Implements

IAptifyTopLevelViewer.

See Also

EventDefinitionsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace | EventDefinitionsViewer.ShowDialog Overload List


EventDefinitionsViewer.ShowDialog Method (Form)

public DialogResult ShowDialog(
Form ParentForm
);

Implements

IAptifyTopLevelViewer.

See Also

EventDefinitionsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace | EventDefinitionsViewer.ShowDialog Overload List


EventHandlerDetailForm Class

For a list of all members of this type, see EventHandlerDetailForm Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
EventHandlerDetailForm

public class EventHandlerDetailForm : Form

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.Entity

Assembly: AptifyProcessPipelineGUI (in AptifyProcessPipelineGUI.dll)

See Also

EventHandlerDetailForm Members | Aptify.Framework.BusinessLogic.Entity Namespace


EventHandlerDetailForm Members

EventHandlerDetailForm overview

Public Instance Constructors

EventHandlerDetailForm Constructor Initializes a new instance of the EventHandlerDetailForm class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config | Overloaded.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

EventHandlerDetailForm Class | Aptify.Framework.BusinessLogic.Entity Namespace


EventHandlerDetailForm Constructor

Initializes a new instance of the EventHandlerDetailForm class.

public EventHandlerDetailForm();

See Also

EventHandlerDetailForm Class | Aptify.Framework.BusinessLogic.Entity Namespace


EventHandlerDetailForm Methods

The methods of the EventHandlerDetailForm class are listed below. For a complete list of EventHandlerDetailForm class members, see the EventHandlerDetailForm Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config | Overloaded.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

EventHandlerDetailForm Class | Aptify.Framework.BusinessLogic.Entity Namespace


EventHandlerDetailForm.ApplySkin Method

protected virtual void ApplySkin();

See Also

EventHandlerDetailForm Class | Aptify.Framework.BusinessLogic.Entity Namespace


Config Method

Aptify 5.0 Software Development Kit (SDK)

EventHandlerDetailForm.Config Method

Overload List

public void Config(AptifyApplication);

public void Config(AptifyApplication,EventHandlerType,String,Int64);

public void Config(AptifyApplication,String,AptifyGenericEntityBase);

See Also

EventHandlerDetailForm Class | Aptify.Framework.BusinessLogic.Entity Namespace


EventHandlerDetailForm.Config Method (AptifyApplication)

public void Config(
AptifyApplication ApplicationObject
);

See Also

EventHandlerDetailForm Class | Aptify.Framework.BusinessLogic.Entity Namespace | EventHandlerDetailForm.Config Overload List


EventHandlerDetailForm.Config Method (AptifyApplication, EventHandlerType, String, Int64)

public void Config(
AptifyApplication ApplicationObject,
EventHandlerType Type,
String Name,
Int64 ID
);

See Also

EventHandlerDetailForm Class | Aptify.Framework.BusinessLogic.Entity Namespace | EventHandlerDetailForm.Config Overload List


EventHandlerDetailForm.Config Method (AptifyApplication, String, AptifyGenericEntityBase)

public void Config(
AptifyApplication ApplicationObject,
String Name,
AptifyGenericEntityBase EventEntityObject
);

See Also

EventHandlerDetailForm Class | Aptify.Framework.BusinessLogic.Entity Namespace | EventHandlerDetailForm.Config Overload List


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

EventHandlerDetailForm.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

EventHandlerDetailForm Class | Aptify.Framework.BusinessLogic.Entity Namespace


EventHandlerDetailForm.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

EventHandlerDetailForm Class | Aptify.Framework.BusinessLogic.Entity Namespace | EventHandlerDetailForm.Dispose Overload List


EventHandlerFormComponent Class

For a list of all members of this type, see EventHandlerFormComponent Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
EventHandlerFormComponent

public class EventHandlerFormComponent : FormComponent, IDashboardComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.Entity

Assembly: AptifyProcessPipelineGUI (in AptifyProcessPipelineGUI.dll)

See Also

EventHandlerFormComponent Members | Aptify.Framework.BusinessLogic.Entity Namespace


EventHandlerFormComponent Members

EventHandlerFormComponent overview

Public Instance Constructors

EventHandlerFormComponent Constructor Initializes a new instance of the EventHandlerFormComponent class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ID |
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Properties | Overloaded.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
State |
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormComponent) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateContext (inherited from FormComponent) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
ApplySkin |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormComponent) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormComponent) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormComponent) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

EventHandlerFormComponent Class | Aptify.Framework.BusinessLogic.Entity Namespace


EventHandlerFormComponent Constructor

Initializes a new instance of the EventHandlerFormComponent class.

public EventHandlerFormComponent();

See Also

EventHandlerFormComponent Class | Aptify.Framework.BusinessLogic.Entity Namespace


EventHandlerFormComponent Properties

The properties of the EventHandlerFormComponent class are listed below. For a complete list of EventHandlerFormComponent class members, see the EventHandlerFormComponent Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ID |
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Properties | Overloaded.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
State |
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateContext (inherited from FormComponent) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

EventHandlerFormComponent Class | Aptify.Framework.BusinessLogic.Entity Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

EventHandlerFormComponent.ID Property

public Int64 ID {get;}

Implements

IDashboardComponent.

See Also

EventHandlerFormComponent Class | Aptify.Framework.BusinessLogic.Entity Namespace


Mode Property

Aptify 5.0 Software Development Kit (SDK)

EventHandlerFormComponent.Mode Property

public DashboardMode Mode {get; set;}

Implements

IDashboardComponent.

See Also

EventHandlerFormComponent Class | Aptify.Framework.BusinessLogic.Entity Namespace


Properties Property

Aptify 5.0 Software Development Kit (SDK)

EventHandlerFormComponent.Properties Property

new public AptifyProperties Properties {get;}

Implements

IDashboardComponent.

See Also

EventHandlerFormComponent Class | Aptify.Framework.BusinessLogic.Entity Namespace


State Property

Aptify 5.0 Software Development Kit (SDK)

EventHandlerFormComponent.State Property

public ComponentState State {get; set;}

Implements

IDashboardComponent.

See Also

EventHandlerFormComponent Class | Aptify.Framework.BusinessLogic.Entity Namespace


EventHandlerFormComponent Methods

The methods of the EventHandlerFormComponent class are listed below. For a complete list of EventHandlerFormComponent class members, see the EventHandlerFormComponent Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormComponent) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
ApplySkin |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormComponent) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormComponent) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormComponent) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

EventHandlerFormComponent Class | Aptify.Framework.BusinessLogic.Entity Namespace


EventHandlerFormComponent.ApplySkin Method

protected virtual void ApplySkin();

See Also

EventHandlerFormComponent Class | Aptify.Framework.BusinessLogic.Entity Namespace


EventHandlerFormComponent.Config Method

public void Config(
AptifyApplication ApplicationObject,
IDashboardArea Area,
Int64 PartID,
ComponentOrientation Orientation
);

Implements

IDashboardComponent.

See Also

EventHandlerFormComponent Class | Aptify.Framework.BusinessLogic.Entity Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

EventHandlerFormComponent.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

EventHandlerFormComponent Class | Aptify.Framework.BusinessLogic.Entity Namespace


EventHandlerFormComponent.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

EventHandlerFormComponent Class | Aptify.Framework.BusinessLogic.Entity Namespace | EventHandlerFormComponent.Dispose Overload List


EventHandlerFormComponent.OnFormComponentConfig Method

protected override void OnFormComponentConfig(
AptifyFormTemplateContext FormTemplateContext
);

Implements

IFormComponent.

See Also

EventHandlerFormComponent Class | Aptify.Framework.BusinessLogic.Entity Namespace


EventHandlerRecordsViewer Class

Provides a custom GUI for the [Event Handlers Record Viewer] entity.

For a list of all members of this type, see EventHandlerRecordsViewer Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
EventHandlerRecordsViewer

public class EventHandlerRecordsViewer : Form, IAptifyTopLevelViewer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.Entity

Assembly: AptifyProcessPipelineGUI (in AptifyProcessPipelineGUI.dll)

See Also

EventHandlerRecordsViewer Members | Aptify.Framework.BusinessLogic.Entity Namespace


EventHandlerRecordsViewer Members

EventHandlerRecordsViewer overview

Public Instance Constructors

EventHandlerRecordsViewer Constructor Initializes a new instance of the EventHandlerRecordsViewer class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config | Overloaded.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show | Overloaded.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
ShowDialog | Overloaded.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog with the specified owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

EventHandlerRecordsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace


EventHandlerRecordsViewer Constructor

Initializes a new instance of the EventHandlerRecordsViewer class.

public EventHandlerRecordsViewer();

See Also

EventHandlerRecordsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace


EventHandlerRecordsViewer Methods

The methods of the EventHandlerRecordsViewer class are listed below. For a complete list of EventHandlerRecordsViewer class members, see the EventHandlerRecordsViewer Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config | Overloaded.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show | Overloaded.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
ShowDialog | Overloaded.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog with the specified owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

EventHandlerRecordsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace


Config Method

Aptify 5.0 Software Development Kit (SDK)

EventHandlerRecordsViewer.Config Method

Overload List

public void Config(AptifyGenericEntityBase);

public void Config(UserCredentials,String);

public void Config(UserCredentials,String,Int64);

public void Config(UserCredentials,String,String);

See Also

EventHandlerRecordsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace


EventHandlerRecordsViewer.Config Method (AptifyGenericEntityBase)

public void Config(
AptifyGenericEntityBase GE
);

Implements

IAptifyTopLevelViewer.

See Also

EventHandlerRecordsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace | EventHandlerRecordsViewer.Config Overload List


EventHandlerRecordsViewer.Config Method (UserCredentials, String)

public void Config(
UserCredentials UserCredentials,
String CmdString
);

Implements

IAptifyTopLevelViewer.

See Also

EventHandlerRecordsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace | EventHandlerRecordsViewer.Config Overload List


EventHandlerRecordsViewer.Config Method (UserCredentials, String, Int64)

public void Config(
UserCredentials UserCredentials,
String EntityName,
Int64 RecordID
);

Implements

IAptifyTopLevelViewer.

See Also

EventHandlerRecordsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace | EventHandlerRecordsViewer.Config Overload List


EventHandlerRecordsViewer.Config Method (UserCredentials, String, String)

public void Config(
UserCredentials UserCredentials,
String EntityName,
String NewRecordParameters
);

Implements

IAptifyTopLevelViewer.

See Also

EventHandlerRecordsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace | EventHandlerRecordsViewer.Config Overload List


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

EventHandlerRecordsViewer.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

EventHandlerRecordsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace


EventHandlerRecordsViewer.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

EventHandlerRecordsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace | EventHandlerRecordsViewer.Dispose Overload List


Show Method

Aptify 5.0 Software Development Kit (SDK)

EventHandlerRecordsViewer.Show Method

Overload List

new public void Show();

public void Show(Form);

Inherited from Form.

public void Show(IWin32Window);

See Also

EventHandlerRecordsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace


EventHandlerRecordsViewer.Show Method ()

new public void Show();

Implements

IAptifyTopLevelViewer.

See Also

EventHandlerRecordsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace | EventHandlerRecordsViewer.Show Overload List


EventHandlerRecordsViewer.Show Method (Form)

public void Show(
Form ParentForm
);

Implements

IAptifyTopLevelViewer.

See Also

EventHandlerRecordsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace | EventHandlerRecordsViewer.Show Overload List


ShowDialog Method

Aptify 5.0 Software Development Kit (SDK)

EventHandlerRecordsViewer.ShowDialog Method

Overload List

new public DialogResult ShowDialog();

public DialogResult ShowDialog(Form);

Inherited from Form.

public DialogResult ShowDialog(IWin32Window);

See Also

EventHandlerRecordsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace


EventHandlerRecordsViewer.ShowDialog Method ()

new public DialogResult ShowDialog();

Implements

IAptifyTopLevelViewer.

See Also

EventHandlerRecordsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace | EventHandlerRecordsViewer.ShowDialog Overload List


EventHandlerRecordsViewer.ShowDialog Method (Form)

public DialogResult ShowDialog(
Form ParentForm
);

Implements

IAptifyTopLevelViewer.

See Also

EventHandlerRecordsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace | EventHandlerRecordsViewer.ShowDialog Overload List


EventHandlersViewer Class

This form is used as a Plug-In Viewer for the Event Handlers entity.

For a list of all members of this type, see EventHandlersViewer Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
EventHandlersViewer

public class EventHandlersViewer : Form, IAptifyTopLevelViewer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.Entity

Assembly: AptifyProcessPipelineGUI (in AptifyProcessPipelineGUI.dll)

See Also

EventHandlersViewer Members | Aptify.Framework.BusinessLogic.Entity Namespace


EventHandlersViewer Members

EventHandlersViewer overview

Public Instance Constructors

EventHandlersViewer Constructor Initializes a new instance of the EventHandlersViewer class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config | Overloaded.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show | Overloaded.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
ShowDialog | Overloaded.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog with the specified owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

EventHandlersViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace


EventHandlersViewer Constructor

Initializes a new instance of the EventHandlersViewer class.

public EventHandlersViewer();

See Also

EventHandlersViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace


EventHandlersViewer Methods

The methods of the EventHandlersViewer class are listed below. For a complete list of EventHandlersViewer class members, see the EventHandlersViewer Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config | Overloaded.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show | Overloaded.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
ShowDialog | Overloaded.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog with the specified owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

EventHandlersViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace


Config Method

Aptify 5.0 Software Development Kit (SDK)

EventHandlersViewer.Config Method

Overload List

public void Config(AptifyGenericEntityBase);

public void Config(UserCredentials,String);

public void Config(UserCredentials,String,Int64);

public void Config(UserCredentials,String,String);

See Also

EventHandlersViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace


EventHandlersViewer.Config Method (AptifyGenericEntityBase)

public void Config(
AptifyGenericEntityBase GE
);

Implements

IAptifyTopLevelViewer.

See Also

EventHandlersViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace | EventHandlersViewer.Config Overload List


EventHandlersViewer.Config Method (UserCredentials, String)

public void Config(
UserCredentials UserCredentials,
String CmdString
);

Implements

IAptifyTopLevelViewer.

See Also

EventHandlersViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace | EventHandlersViewer.Config Overload List


EventHandlersViewer.Config Method (UserCredentials, String, Int64)

public void Config(
UserCredentials UserCredentials,
String EntityName,
Int64 RecordID
);

Implements

IAptifyTopLevelViewer.

See Also

EventHandlersViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace | EventHandlersViewer.Config Overload List


EventHandlersViewer.Config Method (UserCredentials, String, String)

public void Config(
UserCredentials UserCredentials,
String EntityName,
String NewRecordParameters
);

Implements

IAptifyTopLevelViewer.

See Also

EventHandlersViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace | EventHandlersViewer.Config Overload List


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

EventHandlersViewer.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

EventHandlersViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace


EventHandlersViewer.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

EventHandlersViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace | EventHandlersViewer.Dispose Overload List


Show Method

Aptify 5.0 Software Development Kit (SDK)

EventHandlersViewer.Show Method

Overload List

new public void Show();

public void Show(Form);

Inherited from Form.

public void Show(IWin32Window);

See Also

EventHandlersViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace


EventHandlersViewer.Show Method ()

new public void Show();

Implements

IAptifyTopLevelViewer.

See Also

EventHandlersViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace | EventHandlersViewer.Show Overload List


EventHandlersViewer.Show Method (Form)

public void Show(
Form ParentForm
);

Implements

IAptifyTopLevelViewer.

See Also

EventHandlersViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace | EventHandlersViewer.Show Overload List


ShowDialog Method

Aptify 5.0 Software Development Kit (SDK)

EventHandlersViewer.ShowDialog Method

Overload List

new public DialogResult ShowDialog();

public DialogResult ShowDialog(Form);

Inherited from Form.

public DialogResult ShowDialog(IWin32Window);

See Also

EventHandlersViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace


EventHandlersViewer.ShowDialog Method ()

new public DialogResult ShowDialog();

Implements

IAptifyTopLevelViewer.

See Also

EventHandlersViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace | EventHandlersViewer.ShowDialog Overload List


EventHandlersViewer.ShowDialog Method (Form)

public DialogResult ShowDialog(
Form ParentForm
);

Implements

IAptifyTopLevelViewer.

See Also

EventHandlersViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace | EventHandlersViewer.ShowDialog Overload List


EventHandlerType Enumeration

public enum EventHandlerType

Members

Member Name | Description
Global |
Application |
Entity |

Requirements

Namespace: Aptify.Framework.BusinessLogic.Entity

Assembly: AptifyProcessPipelineGUI (in AptifyProcessPipelineGUI.dll)

See Also

Aptify.Framework.BusinessLogic.Entity Namespace


FormTemplatePartsViewer Class

This is a custom form that should be used with form templates

For a list of all members of this type, see FormTemplatePartsViewer Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
FormTemplatePartsViewer

public class FormTemplatePartsViewer : Form, IAptifyTopLevelViewer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

The Form Template Parts entity is a framework entity and for this reason, the form is built NOT using Form Templates which prevents user configuration.

Requirements

Namespace: Aptify.Framework.BusinessLogic.Entity

Assembly: AptifyFormTemplateGUI (in AptifyFormTemplateGUI.dll)

See Also

FormTemplatePartsViewer Members | Aptify.Framework.BusinessLogic.Entity Namespace


FormTemplatePartsViewer Members

FormTemplatePartsViewer overview

Public Instance Constructors

FormTemplatePartsViewer Constructor Initializes a new instance of the FormTemplatePartsViewer class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config | Overloaded.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show | Overloaded.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
ShowDialog | Overloaded.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog with the specified owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

FormTemplatePartsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace


FormTemplatePartsViewer Constructor

Initializes a new instance of the FormTemplatePartsViewer class.

public FormTemplatePartsViewer();

See Also

FormTemplatePartsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace


FormTemplatePartsViewer Methods

The methods of the FormTemplatePartsViewer class are listed below. For a complete list of FormTemplatePartsViewer class members, see the FormTemplatePartsViewer Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config | Overloaded.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show | Overloaded.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
ShowDialog | Overloaded.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog with the specified owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

FormTemplatePartsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace


FormTemplatePartsViewer.ApplySkin Method

protected virtual void ApplySkin();

See Also

FormTemplatePartsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace


Config Method

Aptify 5.0 Software Development Kit (SDK)

FormTemplatePartsViewer.Config Method

Overload List

public void Config(AptifyGenericEntityBase);

public void Config(UserCredentials,String);

public void Config(UserCredentials,String,Int64);

public void Config(UserCredentials,String,String);

See Also

FormTemplatePartsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace


FormTemplatePartsViewer.Config Method (AptifyGenericEntityBase)

public void Config(
AptifyGenericEntityBase GE
);

Implements

IAptifyTopLevelViewer.

See Also

FormTemplatePartsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace | FormTemplatePartsViewer.Config Overload List


FormTemplatePartsViewer.Config Method (UserCredentials, String)

public void Config(
UserCredentials UserCredentials,
String CmdString
);

Implements

IAptifyTopLevelViewer.

See Also

FormTemplatePartsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace | FormTemplatePartsViewer.Config Overload List


FormTemplatePartsViewer.Config Method (UserCredentials, String, Int64)

public void Config(
UserCredentials UserCredentials,
String EntityName,
Int64 RecordID
);

Implements

IAptifyTopLevelViewer.

See Also

FormTemplatePartsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace | FormTemplatePartsViewer.Config Overload List


FormTemplatePartsViewer.Config Method (UserCredentials, String, String)

public void Config(
UserCredentials UserCredentials,
String EntityName,
String NewRecordParameters
);

Implements

IAptifyTopLevelViewer.

See Also

FormTemplatePartsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace | FormTemplatePartsViewer.Config Overload List


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

FormTemplatePartsViewer.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

FormTemplatePartsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace


FormTemplatePartsViewer.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

FormTemplatePartsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace | FormTemplatePartsViewer.Dispose Overload List


Show Method

Aptify 5.0 Software Development Kit (SDK)

FormTemplatePartsViewer.Show Method

Overload List

new public void Show();

public void Show(Form);

Inherited from Form.

public void Show(IWin32Window);

See Also

FormTemplatePartsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace


FormTemplatePartsViewer.Show Method ()

new public void Show();

Implements

IAptifyTopLevelViewer.

See Also

FormTemplatePartsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace | FormTemplatePartsViewer.Show Overload List


FormTemplatePartsViewer.Show Method (Form)

public void Show(
Form ParentForm
);

Implements

IAptifyTopLevelViewer.

See Also

FormTemplatePartsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace | FormTemplatePartsViewer.Show Overload List


ShowDialog Method

Aptify 5.0 Software Development Kit (SDK)

FormTemplatePartsViewer.ShowDialog Method

Overload List

new public DialogResult ShowDialog();

public DialogResult ShowDialog(Form);

Inherited from Form.

public DialogResult ShowDialog(IWin32Window);

See Also

FormTemplatePartsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace


FormTemplatePartsViewer.ShowDialog Method ()

new public DialogResult ShowDialog();

Implements

IAptifyTopLevelViewer.

See Also

FormTemplatePartsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace | FormTemplatePartsViewer.ShowDialog Overload List


FormTemplatePartsViewer.ShowDialog Method (Form)

public DialogResult ShowDialog(
Form ParentForm
);

Implements

IAptifyTopLevelViewer.

See Also

FormTemplatePartsViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace | FormTemplatePartsViewer.ShowDialog Overload List


FormTemplatesEntity Class

This is the GE wrapper for Form Templates.

For a list of all members of this type, see FormTemplatesEntity Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
FormTemplatesEntity

public class FormTemplatesEntity : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

We override the save event so we can notify the user that their changes will stop the template from re-generating.

Requirements

Namespace: Aptify.Framework.BusinessLogic.Entity

Assembly: AptifyFormTemplatesEntity (in AptifyFormTemplatesEntity.dll)

See Also

FormTemplatesEntity Members | Aptify.Framework.BusinessLogic.Entity Namespace


FormTemplatesEntity Members

FormTemplatesEntity overview

Public Instance Constructors

FormTemplatesEntity Constructor Initializes a new instance of the FormTemplatesEntity class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded. Saves the Form Template record.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

FormTemplatesEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


FormTemplatesEntity Constructor

Initializes a new instance of the FormTemplatesEntity class.

public FormTemplatesEntity();

See Also

FormTemplatesEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


FormTemplatesEntity Methods

The methods of the FormTemplatesEntity class are listed below. For a complete list of FormTemplatesEntity class members, see the FormTemplatesEntity Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded. Saves the Form Template record.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

FormTemplatesEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


Save Method

Aptify 5.0 Software Development Kit (SDK)

FormTemplatesEntity.Save Method

Saves the Form Template record.

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Save();

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean,ref String&);

Saves the Form Template record.

public override bool Save(Boolean,ref String&,String);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(ref String&);

See Also

FormTemplatesEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


FormTemplatesEntity.Save Method (Boolean, String&, String)

Saves the Form Template record.

public override bool Save(
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

Parameters

AllowGUI
If this is true then we will notify the user before we mark the Form Template as not generated.
ErrorString
If an error occurs then we will populate this string.
TransactionID
The transaction that this segment should be rolled into.

Remarks

If anything has changed other than the rank then we will mark this as a non-generated Form Template record.

See Also

FormTemplatesEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace | FormTemplatesEntity.Save Overload List


FormTemplatesViewer Class

This is a custom form that should be used with form templates

For a list of all members of this type, see FormTemplatesViewer Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
FormTemplatesViewer

public class FormTemplatesViewer : Form, IAptifyTopLevelViewer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

The Form Templates entity is a framework entity and for this reason, the form is built NOT using Form Templates which prevents user configuration.

Requirements

Namespace: Aptify.Framework.BusinessLogic.Entity

Assembly: AptifyFormTemplateGUI (in AptifyFormTemplateGUI.dll)

See Also

FormTemplatesViewer Members | Aptify.Framework.BusinessLogic.Entity Namespace


FormTemplatesViewer Members

FormTemplatesViewer overview

Public Instance Constructors

FormTemplatesViewer Constructor Initializes a new instance of the FormTemplatesViewer class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config | Overloaded.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show | Overloaded.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
ShowDialog | Overloaded.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog with the specified owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

FormTemplatesViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace


FormTemplatesViewer Constructor

Initializes a new instance of the FormTemplatesViewer class.

public FormTemplatesViewer();

See Also

FormTemplatesViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace


FormTemplatesViewer Methods

The methods of the FormTemplatesViewer class are listed below. For a complete list of FormTemplatesViewer class members, see the FormTemplatesViewer Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config | Overloaded.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show | Overloaded.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
ShowDialog | Overloaded.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog with the specified owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

FormTemplatesViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace


FormTemplatesViewer.ApplySkin Method

protected virtual void ApplySkin();

See Also

FormTemplatesViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace


Config Method

Aptify 5.0 Software Development Kit (SDK)

FormTemplatesViewer.Config Method

Overload List

public void Config(AptifyGenericEntityBase);

public void Config(UserCredentials,String);

public void Config(UserCredentials,String,Int64);

public void Config(UserCredentials,String,String);

See Also

FormTemplatesViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace


FormTemplatesViewer.Config Method (AptifyGenericEntityBase)

public void Config(
AptifyGenericEntityBase GE
);

Implements

IAptifyTopLevelViewer.

See Also

FormTemplatesViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace | FormTemplatesViewer.Config Overload List


FormTemplatesViewer.Config Method (UserCredentials, String)

public void Config(
UserCredentials UserCredentials,
String CmdString
);

Implements

IAptifyTopLevelViewer.

See Also

FormTemplatesViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace | FormTemplatesViewer.Config Overload List


FormTemplatesViewer.Config Method (UserCredentials, String, Int64)

public void Config(
UserCredentials UserCredentials,
String EntityName,
Int64 RecordID
);

Implements

IAptifyTopLevelViewer.

See Also

FormTemplatesViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace | FormTemplatesViewer.Config Overload List


FormTemplatesViewer.Config Method (UserCredentials, String, String)

public void Config(
UserCredentials UserCredentials,
String EntityName,
String NewRecordParameters
);

Implements

IAptifyTopLevelViewer.

See Also

FormTemplatesViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace | FormTemplatesViewer.Config Overload List


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

FormTemplatesViewer.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

FormTemplatesViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace


FormTemplatesViewer.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

FormTemplatesViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace | FormTemplatesViewer.Dispose Overload List


Show Method

Aptify 5.0 Software Development Kit (SDK)

FormTemplatesViewer.Show Method

Overload List

new public void Show();

public void Show(Form);

Inherited from Form.

public void Show(IWin32Window);

See Also

FormTemplatesViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace


FormTemplatesViewer.Show Method ()

new public void Show();

Implements

IAptifyTopLevelViewer.

See Also

FormTemplatesViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace | FormTemplatesViewer.Show Overload List


FormTemplatesViewer.Show Method (Form)

public void Show(
Form ParentForm
);

Implements

IAptifyTopLevelViewer.

See Also

FormTemplatesViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace | FormTemplatesViewer.Show Overload List


ShowDialog Method

Aptify 5.0 Software Development Kit (SDK)

FormTemplatesViewer.ShowDialog Method

Overload List

new public DialogResult ShowDialog();

public DialogResult ShowDialog(Form);

Inherited from Form.

public DialogResult ShowDialog(IWin32Window);

See Also

FormTemplatesViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace


FormTemplatesViewer.ShowDialog Method ()

new public DialogResult ShowDialog();

Implements

IAptifyTopLevelViewer.

See Also

FormTemplatesViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace | FormTemplatesViewer.ShowDialog Overload List


FormTemplatesViewer.ShowDialog Method (Form)

public DialogResult ShowDialog(
Form ParentForm
);

Implements

IAptifyTopLevelViewer.

See Also

FormTemplatesViewer Class | Aptify.Framework.BusinessLogic.Entity Namespace | FormTemplatesViewer.ShowDialog Overload List


GeneratedLabel Class

This is used to display Generate or Not Generated

For a list of all members of this type, see GeneratedLabel Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
GeneratedLabel

public class GeneratedLabel : UserControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.Entity

Assembly: AptifyFormTemplateGUI (in AptifyFormTemplateGUI.dll)

See Also

GeneratedLabel Members | Aptify.Framework.BusinessLogic.Entity Namespace


GeneratedLabel Members

GeneratedLabel overview

Public Instance Constructors

GeneratedLabel Constructor Initializes a new instance of the GeneratedLabel class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetValue |
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

GeneratedLabel Class | Aptify.Framework.BusinessLogic.Entity Namespace


GeneratedLabel Constructor

Initializes a new instance of the GeneratedLabel class.

public GeneratedLabel();

See Also

GeneratedLabel Class | Aptify.Framework.BusinessLogic.Entity Namespace


GeneratedLabel Methods

The methods of the GeneratedLabel class are listed below. For a complete list of GeneratedLabel class members, see the GeneratedLabel Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetValue |
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

GeneratedLabel Class | Aptify.Framework.BusinessLogic.Entity Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

GeneratedLabel.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

GeneratedLabel Class | Aptify.Framework.BusinessLogic.Entity Namespace


GeneratedLabel.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

GeneratedLabel Class | Aptify.Framework.BusinessLogic.Entity Namespace | GeneratedLabel.Dispose Overload List


GeneratedLabel.SetValue Method

public void SetValue(
Object Value
);

See Also

GeneratedLabel Class | Aptify.Framework.BusinessLogic.Entity Namespace


IEntityBulkOperation Interface

The IEntityBulkOperation interface represents a singular Entity Bulk Operation.

For a list of all members of this type, see IEntityBulkOperation Members.

public interface IEntityBulkOperation

Types that implement IEntityBulkOperation

Type | Description
EntityBulkOperation | The standard Aptify implementation of IEntityBulkOperation

Remarks

Once a class implements this interface, it is eligible to be used as an Entity Bulk Operation.

Requirements

Namespace: Aptify.Framework.BusinessLogic.Entity

Assembly: AptifyEntityBulkOperations (in AptifyEntityBulkOperations.dll)

See Also

IEntityBulkOperation Members | Aptify.Framework.BusinessLogic.Entity Namespace


IEntityBulkOperation Members

IEntityBulkOperation overview

Public Instance Methods

ProcessRecord Executes an operation on a Generic Entity Record.

See Also

IEntityBulkOperation Interface | Aptify.Framework.BusinessLogic.Entity Namespace


IEntityBulkOperation Methods

The methods of the IEntityBulkOperation interface are listed below. For a complete list of IEntityBulkOperation interface members, see the IEntityBulkOperation Members topic.

Public Instance Methods

ProcessRecord Executes an operation on a Generic Entity Record.

See Also

IEntityBulkOperation Interface | Aptify.Framework.BusinessLogic.Entity Namespace


IEntityBulkOperation.ProcessRecord Method

Executes an operation on a Generic Entity Record.

void ProcessRecord(
AptifyApplication ApplicationObject,
Boolean AllowGUI,
AptifyGenericEntityBase EntityBulkOperationGE,
AptifyGenericEntityBase RecordToProcessGE,
params Object[] PromptValues
);

See Also

IEntityBulkOperation Interface | Aptify.Framework.BusinessLogic.Entity Namespace


IEntityBulkOperationProcessor Interface

The IEntityBulkOperationProcessor interface represents a batch of Entity Bulk Operations

For a list of all members of this type, see IEntityBulkOperationProcessor Members.

public interface IEntityBulkOperationProcessor : IStatus

Types that implement IEntityBulkOperationProcessor

Type | Description
EntityBulkOperationProcess | The standard Aptify implementation of the IEntityBulkOperationProcessor interface.

Requirements

Namespace: Aptify.Framework.BusinessLogic.Entity

Assembly: AptifyEntityBulkOperations (in AptifyEntityBulkOperations.dll)

See Also

IEntityBulkOperationProcessor Members | Aptify.Framework.BusinessLogic.Entity Namespace


IEntityBulkOperationProcessor Members

IEntityBulkOperationProcessor overview

Public Instance Methods

Cancel | Sends a request to the Engine to stop processing the batch.
Run | Overloaded. Runs an Entity Bulk Operations based on a View provided by the user.

See Also

IEntityBulkOperationProcessor Interface | Aptify.Framework.BusinessLogic.Entity Namespace


IEntityBulkOperationProcessor Methods

The methods of the IEntityBulkOperationProcessor interface are listed below. For a complete list of IEntityBulkOperationProcessor interface members, see the IEntityBulkOperationProcessor Members topic.

Public Instance Methods

Cancel | Sends a request to the Engine to stop processing the batch.
Run | Overloaded. Runs an Entity Bulk Operations based on a View provided by the user.

See Also

IEntityBulkOperationProcessor Interface | Aptify.Framework.BusinessLogic.Entity Namespace


IEntityBulkOperationProcessor.Cancel Method

Sends a request to the Engine to stop processing the batch.

void Cancel();

See Also

IEntityBulkOperationProcessor Interface | Aptify.Framework.BusinessLogic.Entity Namespace


Run Method

Aptify 5.0 Software Development Kit (SDK)

IEntityBulkOperationProcessor.Run Method

Runs an Entity Bulk Operations based on a View provided by the user.

Overload List

Runs an Entity Bulk Operations based on a View provided by the user.

void Run(UserCredentials,Boolean,Int64,Int64,params Object[]);

Runs an Entity Bulk Operations based on a list of Entity Record IDs provided by the user.

void Run(UserCredentials,Boolean,Int64,Object[],params Object[]);

Runs an Entity Bulk Operations based on a custom View of Entities Records provided by the user.

void Run(UserCredentials,Boolean,Int64,String,params Object[]);

See Also

IEntityBulkOperationProcessor Interface | Aptify.Framework.BusinessLogic.Entity Namespace


IEntityBulkOperationProcessor.Run Method (UserCredentials, Boolean, Int64, Int64, Object[])

Runs an Entity Bulk Operations based on a View provided by the user.

void Run(
UserCredentials UserCredential,
Boolean AllowGUI,
Int64 EntityBulkOperationID,
Int64 ViewID,
params Object[] PromptValues
);

See Also

IEntityBulkOperationProcessor Interface | Aptify.Framework.BusinessLogic.Entity Namespace | IEntityBulkOperationProcessor.Run Overload List


IEntityBulkOperationProcessor.Run Method (UserCredentials, Boolean, Int64, Object[], Object[])

Runs an Entity Bulk Operations based on a list of Entity Record IDs provided by the user.

void Run(
UserCredentials UserCredential,
Boolean AllowGUI,
Int64 EntityBulkOperationID,
Object[] SelectedItems,
params Object[] PromptValues
);

See Also

IEntityBulkOperationProcessor Interface | Aptify.Framework.BusinessLogic.Entity Namespace | IEntityBulkOperationProcessor.Run Overload List


IEntityBulkOperationProcessor.Run Method (UserCredentials, Boolean, Int64, String, Object[])

Runs an Entity Bulk Operations based on a custom View of Entities Records provided by the user.

void Run(
UserCredentials UserCredential,
Boolean AllowGUI,
Int64 EntityBulkOperationID,
String ViewSQL,
params Object[] PromptValues
);

See Also

IEntityBulkOperationProcessor Interface | Aptify.Framework.BusinessLogic.Entity Namespace | IEntityBulkOperationProcessor.Run Overload List


IEntityInstall Interface

For a list of all members of this type, see IEntityInstall Members.

public interface IEntityInstall

Types that implement IEntityInstall

Type | Description
EntitiesEntity | Aptify Entities Entity GE Sub-Class. This class implements all of the functionality related to entity management as a sub-class to the AptifyGenericEntityBase class.

Requirements

Namespace: Aptify.Framework.BusinessLogic.Entity

Assembly: AptifyEntityInterfaces (in AptifyEntityInterfaces.dll)

See Also

IEntityInstall Members | Aptify.Framework.BusinessLogic.Entity Namespace


IEntityInstall Members

IEntityInstall overview

Public Instance Methods

SaveWithoutDBObjects

See Also

IEntityInstall Interface | Aptify.Framework.BusinessLogic.Entity Namespace


IEntityInstall Methods

The methods of the IEntityInstall interface are listed below. For a complete list of IEntityInstall interface members, see the IEntityInstall Members topic.

Public Instance Methods

SaveWithoutDBObjects

See Also

IEntityInstall Interface | Aptify.Framework.BusinessLogic.Entity Namespace


IEntityInstall.SaveWithoutDBObjects Method

void SaveWithoutDBObjects(
Boolean AllowGUI
);

See Also

IEntityInstall Interface | Aptify.Framework.BusinessLogic.Entity Namespace


IEntitySchema Interface

For a list of all members of this type, see IEntitySchema Members.

public interface IEntitySchema

Types that implement IEntitySchema

Type | Description
EntitiesEntity | Aptify Entities Entity GE Sub-Class. This class implements all of the functionality related to entity management as a sub-class to the AptifyGenericEntityBase class.

Requirements

Namespace: Aptify.Framework.BusinessLogic.Entity

Assembly: AptifyEntityInterfaces (in AptifyEntityInterfaces.dll)

See Also

IEntitySchema Members | Aptify.Framework.BusinessLogic.Entity Namespace


IEntitySchema Members

IEntitySchema overview

Public Instance Methods

RebuildBaseView |
RebuildStoredProcs |
RegenerateBaselineFormTemplate |
SaveSchema |
VerifyForeignKeys | Verifies that the appropriate Foreign Keys exist based on the Entity's Field definitions. If a foreign key should exist but does not, it will be created. Foreign Keys will be generated only if the Entity's GenerateTable flag is true.

See Also

IEntitySchema Interface | Aptify.Framework.BusinessLogic.Entity Namespace


IEntitySchema Methods

The methods of the IEntitySchema interface are listed below. For a complete list of IEntitySchema interface members, see the IEntitySchema Members topic.

Public Instance Methods

RebuildBaseView |
RebuildStoredProcs |
RegenerateBaselineFormTemplate |
SaveSchema |
VerifyForeignKeys | Verifies that the appropriate Foreign Keys exist based on the Entity's Field definitions. If a foreign key should exist but does not, it will be created. Foreign Keys will be generated only if the Entity's GenerateTable flag is true.

See Also

IEntitySchema Interface | Aptify.Framework.BusinessLogic.Entity Namespace


IEntitySchema.RebuildBaseView Method

bool RebuildBaseView(
Boolean AllowGUI
);

See Also

IEntitySchema Interface | Aptify.Framework.BusinessLogic.Entity Namespace


IEntitySchema.RebuildStoredProcs Method

bool RebuildStoredProcs(
Boolean AllowGUI
);

See Also

IEntitySchema Interface | Aptify.Framework.BusinessLogic.Entity Namespace


IEntitySchema.RegenerateBaselineFormTemplate Method

bool RegenerateBaselineFormTemplate(
Boolean AllowGUI
);

See Also

IEntitySchema Interface | Aptify.Framework.BusinessLogic.Entity Namespace


IEntitySchema.SaveSchema Method

bool SaveSchema(
Boolean AllowGUI
);

See Also

IEntitySchema Interface | Aptify.Framework.BusinessLogic.Entity Namespace


IEntitySchema.VerifyForeignKeys Method

Verifies that the appropriate Foreign Keys exist based on the Entity's Field definitions. If a foreign key should exist but does not, it will be created. Foreign Keys will be generated only if the Entity's GenerateTable flag is true.

void VerifyForeignKeys(
Boolean AllowGUI
);

Parameters

AllowGUI
Indicates whether or not the method can interact with the user.

Remarks

See Also

IEntitySchema Interface | Aptify.Framework.BusinessLogic.Entity Namespace


IMailMerge Interface

Allows a User to Perform a Mail Merge based on a View and a Template.

For a list of all members of this type, see IMailMerge Members.

public interface IMailMerge

Types that implement IMailMerge

Type | Description
MSWordMailMerge | Use Microsoft Word to execute a Mail Merge with a Word Template.

Requirements

Namespace: Aptify.Framework.BusinessLogic.Entity

Assembly: AptifyMailMergeInterfaces (in AptifyMailMergeInterfaces.dll)

See Also

IMailMerge Members | Aptify.Framework.BusinessLogic.Entity Namespace


IMailMerge Members

IMailMerge overview

Public Instance Methods

Config | Configures the Mail Merge for use.
Merge | Overloaded. Merges a Template with a View that is based on an existing View.

See Also

IMailMerge Interface | Aptify.Framework.BusinessLogic.Entity Namespace


IMailMerge Methods

The methods of the IMailMerge interface are listed below. For a complete list of IMailMerge interface members, see the IMailMerge Members topic.

Public Instance Methods

Config | Configures the Mail Merge for use.
Merge | Overloaded. Merges a Template with a View that is based on an existing View.

See Also

IMailMerge Interface | Aptify.Framework.BusinessLogic.Entity Namespace


IMailMerge.Config Method

Configures the Mail Merge for use.

void Config(
AptifyApplication ApplicationObject
);

Parameters

ApplicationObject

Remarks

This should be called prior to calling any other IMailMerge members.

See Also

IMailMerge Interface | Aptify.Framework.BusinessLogic.Entity Namespace


Merge Method

Aptify 5.0 Software Development Kit (SDK)

IMailMerge.Merge Method

Merges a Template with a View that is based on an existing View.

Overload List

Merges a Template with a View that is based on an existing View.

void Merge(Int64,LaunchOption,String,Int64);

Merges a Template with a view that is based on Custom View SQL.

void Merge(Int64,LaunchOption,String,String);

See Also

IMailMerge Interface | Aptify.Framework.BusinessLogic.Entity Namespace


IMailMerge.Merge Method (Int64, LaunchOption, String, Int64)

Merges a Template with a View that is based on an existing View.

void Merge(
Int64 TemplateID,
LaunchOption MergeOption,
String FileName,
Int64 ViewID
);

Parameters

TemplateID
MergeOption
FileName
The default file name that should be used when saving the results of the merge. This value can be a null reference.
ViewID

See Also

IMailMerge Interface | Aptify.Framework.BusinessLogic.Entity Namespace | IMailMerge.Merge Overload List


IMailMerge.Merge Method (Int64, LaunchOption, String, String)

Merges a Template with a view that is based on Custom View SQL.

void Merge(
Int64 TemplateID,
LaunchOption MergeOption,
String FileName,
String ViewSQL
);

Parameters

TemplateID
MergeOption
FileName
The default file name that should be used when saving the results of the merge. This value can be a null reference.
ViewSQL

See Also

IMailMerge Interface | Aptify.Framework.BusinessLogic.Entity Namespace | IMailMerge.Merge Overload List


LaunchOption Enumeration

Specifies an initial action for an item at startup.

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

public enum LaunchOption

Remarks

This enumeration is a bit flag and is safe for use in combination.

Members

Member Name | Description | Value
View | This should cause an action item to launch with a Viewer. | 2
Save | This should cause an action item to Save upon launch. | 4

Requirements

Namespace: Aptify.Framework.BusinessLogic.Entity

Assembly: AptifyMailMergeInterfaces (in AptifyMailMergeInterfaces.dll)

See Also

Aptify.Framework.BusinessLogic.Entity Namespace


MailMergeException Class

The base application that is thrown from MailMergeTemplate classes.

For a list of all members of this type, see MailMergeException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
MailMergeException

public class MailMergeException : BaseApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.Entity

Assembly: AptifyMailMergeInterfaces (in AptifyMailMergeInterfaces.dll)

See Also

MailMergeException Members | Aptify.Framework.BusinessLogic.Entity Namespace


MailMergeException Members

MailMergeException overview

Public Instance Constructors

MailMergeException Overloaded. Initializes a new instance of the MailMergeException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from BaseApplicationException) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MailMergeException Class | Aptify.Framework.BusinessLogic.Entity Namespace


MailMergeException Constructor

Overload List

public MailMergeException(String);

public MailMergeException(String,Exception);

See Also

MailMergeException Class | Aptify.Framework.BusinessLogic.Entity Namespace


MailMergeException Constructor (String)

public MailMergeException(
String Message
);

See Also

MailMergeException Class | Aptify.Framework.BusinessLogic.Entity Namespace | MailMergeException Constructor Overload List


MailMergeException Constructor (String, Exception)

public MailMergeException(
String Message,
Exception InnerException
);

See Also

MailMergeException Class | Aptify.Framework.BusinessLogic.Entity Namespace | MailMergeException Constructor Overload List


ProcessFlowStepControl Class

For a list of all members of this type, see ProcessFlowStepControl Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
ProcessFlowStepControl

public class ProcessFlowStepControl : FormComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.Entity

Assembly: AptifyProcessPipelineGUI (in AptifyProcessPipelineGUI.dll)

See Also

ProcessFlowStepControl Members | Aptify.Framework.BusinessLogic.Entity Namespace


ProcessFlowStepControl Members

ProcessFlowStepControl overview

Public Instance Constructors

ProcessFlowStepControl Constructor Initializes a new instance of the ProcessFlowStepControl class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
InputMapIsValid |
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormComponent) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateContext (inherited from FormComponent) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
ApplySkin |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormComponent) |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormComponent) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormComponent) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ProcessFlowStepControl Class | Aptify.Framework.BusinessLogic.Entity Namespace


ProcessFlowStepControl Constructor

Initializes a new instance of the ProcessFlowStepControl class.

public ProcessFlowStepControl();

See Also

ProcessFlowStepControl Class | Aptify.Framework.BusinessLogic.Entity Namespace


ProcessFlowStepControl Methods

The methods of the ProcessFlowStepControl class are listed below. For a complete list of ProcessFlowStepControl class members, see the ProcessFlowStepControl Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
InputMapIsValid |
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormComponent) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
ApplySkin |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormComponent) |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormComponent) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormComponent) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ProcessFlowStepControl Class | Aptify.Framework.BusinessLogic.Entity Namespace


ProcessFlowStepControl.ApplySkin Method

protected virtual void ApplySkin();

See Also

ProcessFlowStepControl Class | Aptify.Framework.BusinessLogic.Entity Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowStepControl.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

ProcessFlowStepControl Class | Aptify.Framework.BusinessLogic.Entity Namespace


ProcessFlowStepControl.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

ProcessFlowStepControl Class | Aptify.Framework.BusinessLogic.Entity Namespace | ProcessFlowStepControl.Dispose Overload List


ProcessFlowStepControl.InputMapIsValid Method

public string InputMapIsValid();

See Also

ProcessFlowStepControl Class | Aptify.Framework.BusinessLogic.Entity Namespace


ProcessFlowStepControl.OnConfigureApplicationObject Method

protected override void OnConfigureApplicationObject(
AptifyFormTemplateContext FormTemplateContext
);

See Also

ProcessFlowStepControl Class | Aptify.Framework.BusinessLogic.Entity Namespace


ProcessFlowStepControl.OnTransferDataToObject Method

protected override void OnTransferDataToObject(
ref Boolean& Cancel
);

Implements

IFormComponent.

See Also

ProcessFlowStepControl Class | Aptify.Framework.BusinessLogic.Entity Namespace


RunEntityBulkOperationProcessComponent Class

Process Component that runs an Entity Bulk Operation on a specified record set.

For a list of all members of this type, see RunEntityBulkOperationProcessComponent Members.

System.Object
RunEntityBulkOperationProcessComponent

public class RunEntityBulkOperationProcessComponent : IProcessComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.Entity

Assembly: AptifyEntityBulkOperationsProcessComponent (in AptifyEntityBulkOperationsProcessComponent.dll)

See Also

RunEntityBulkOperationProcessComponent Members | Aptify.Framework.BusinessLogic.Entity Namespace


RunEntityBulkOperationProcessComponent Members

RunEntityBulkOperationProcessComponent overview

Public Instance Constructors

RunEntityBulkOperationProcessComponent Constructor Initializes a new instance of the RunEntityBulkOperationProcessComponent class.

Public Instance Properties

Properties Aptify Properties Collection used for Input and Output Properties for the component.

Public Instance Methods

Config | This method must be called before any other member of this class is accessed. Retrieves input properties and instantiates Entity Bulk Operation Process object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run | Runs the selected bulk operation. The operation is run on the record set specified by the input properties ViewSQL, ViewID, or SelectionList. The first non-empty property found in that order is selected. At least one property must be supplied.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RunEntityBulkOperationProcessComponent Class | Aptify.Framework.BusinessLogic.Entity Namespace


RunEntityBulkOperationProcessComponent Constructor

Initializes a new instance of the RunEntityBulkOperationProcessComponent class.

public RunEntityBulkOperationProcessComponent();

See Also

RunEntityBulkOperationProcessComponent Class | Aptify.Framework.BusinessLogic.Entity Namespace


RunEntityBulkOperationProcessComponent Properties

The properties of the RunEntityBulkOperationProcessComponent class are listed below. For a complete list of RunEntityBulkOperationProcessComponent class members, see the RunEntityBulkOperationProcessComponent Members topic.

Public Instance Properties

Properties Aptify Properties Collection used for Input and Output Properties for the component.

See Also

RunEntityBulkOperationProcessComponent Class | Aptify.Framework.BusinessLogic.Entity Namespace


Properties Property

Aptify 5.0 Software Development Kit (SDK)

RunEntityBulkOperationProcessComponent.Properties Property

Aptify Properties Collection used for Input and Output Properties for the component.

public virtual AptifyProperties Properties {get;}

Property Value

Implements

IProcessComponent.

Remarks

See Also

RunEntityBulkOperationProcessComponent Class | Aptify.Framework.BusinessLogic.Entity Namespace


RunEntityBulkOperationProcessComponent Methods

The methods of the RunEntityBulkOperationProcessComponent class are listed below. For a complete list of RunEntityBulkOperationProcessComponent class members, see the RunEntityBulkOperationProcessComponent Members topic.

Public Instance Methods

Config | This method must be called before any other member of this class is accessed. Retrieves input properties and instantiates Entity Bulk Operation Process object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run | Runs the selected bulk operation. The operation is run on the record set specified by the input properties ViewSQL, ViewID, or SelectionList. The first non-empty property found in that order is selected. At least one property must be supplied.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RunEntityBulkOperationProcessComponent Class | Aptify.Framework.BusinessLogic.Entity Namespace


RunEntityBulkOperationProcessComponent.Config Method

This method must be called before any other member of this class is accessed. Retrieves input properties and instantiates Entity Bulk Operation Process object.

public virtual void Config(
AptifyApplication ApplicationObject
);

Parameters

ApplicationObject

Implements

IProcessComponent.

Remarks

See Also

RunEntityBulkOperationProcessComponent Class | Aptify.Framework.BusinessLogic.Entity Namespace


RunEntityBulkOperationProcessComponent.Run Method

Runs the selected bulk operation. The operation is run on the record set specified by the input properties ViewSQL, ViewID, or SelectionList. The first non-empty property found in that order is selected. At least one property must be supplied.

public string Run();

Return Value

Success if process completed without error, else failure.

Implements

IProcessComponent.

Remarks

See Also

RunEntityBulkOperationProcessComponent Class | Aptify.Framework.BusinessLogic.Entity Namespace


TopicCodeLinksEntity Class

This class is the GE wrapper around the Topic Code Links Entity

For a list of all members of this type, see TopicCodeLinksEntity Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
TopicCodeLinksEntity

public class TopicCodeLinksEntity : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.Entity

Assembly: AptifyTopicCodeLinks (in AptifyTopicCodeLinks.dll)

See Also

TopicCodeLinksEntity Members | Aptify.Framework.BusinessLogic.Entity Namespace


TopicCodeLinksEntity Members

TopicCodeLinksEntity overview

Public Instance Constructors

TopicCodeLinksEntity Constructor Initializes a new instance of the TopicCodeLinksEntity class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config | Overloaded. Configures the wrapper for use.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetTopicCodeValueType |
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded. Saves the data for the Topic Code Links record
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded. This method overrides the base Validate() function to add in validation to ensure that values in the Topic Code Link confirm to the possible values for the type of topic code. For Numeric topic codes, only numeric values are allowed. For Yes/No topic codes only the values Yes/No are allowed.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

TopicCodeLinksEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


TopicCodeLinksEntity Constructor

Initializes a new instance of the TopicCodeLinksEntity class.

public TopicCodeLinksEntity();

See Also

TopicCodeLinksEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


TopicCodeLinksEntity Methods

The methods of the TopicCodeLinksEntity class are listed below. For a complete list of TopicCodeLinksEntity class members, see the TopicCodeLinksEntity Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config | Overloaded. Configures the wrapper for use.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetTopicCodeValueType |
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded. Saves the data for the Topic Code Links record
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded. This method overrides the base Validate() function to add in validation to ensure that values in the Topic Code Link confirm to the possible values for the type of topic code. For Numeric topic codes, only numeric values are allowed. For Yes/No topic codes only the values Yes/No are allowed.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

TopicCodeLinksEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


Config Method

Aptify 5.0 Software Development Kit (SDK)

TopicCodeLinksEntity.Config Method

Configures the wrapper for use.

Overload List

Inherited from AptifyGenericEntityBase.

public virtual void Config(AptifySubTypeBase);

Inherited from AptifyGenericEntity.

public override void Config(AptifySubTypeBase,Int64);

Inherited from AptifyGenericEntityBase.

public virtual void Config(UserCredentials,String);

Configures the wrapper for use.

public override void Config(UserCredentials,String,Int64);

See Also

TopicCodeLinksEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


TopicCodeLinksEntity.Config Method (UserCredentials, String, Int64)

Configures the wrapper for use.

public override void Config(
UserCredentials UserCredentials,
String EntityName,
Int64 RecordID
);

Remarks

This wrapper can only be used with the Topic Code Links entity.

See Also

TopicCodeLinksEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace | TopicCodeLinksEntity.Config Overload List


TopicCodeLinksEntity.GetTopicCodeValueType Method

public virtual TopicCodeValueType GetTopicCodeValueType(
Int64 TopicCodeID
);

See Also

TopicCodeLinksEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


Save Method

Aptify 5.0 Software Development Kit (SDK)

TopicCodeLinksEntity.Save Method

Saves the data for the Topic Code Links record

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Save();

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean,ref String&);

Saves the data for the Topic Code Links record

public override bool Save(Boolean,ref String&,String);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(ref String&);

See Also

TopicCodeLinksEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


TopicCodeLinksEntity.Save Method (Boolean, String&, String)

Saves the data for the Topic Code Links record

public override bool Save(
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

Remarks

This function is where the RecordName field is populated. If you want to manually set the RecordName field, then you should add a field named _xSkipRecordName and have its value set to some string with length >0; i.e. geTopicCodeLinks.SetAddValue("_xSkipRecordName","true")

See Also

TopicCodeLinksEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace | TopicCodeLinksEntity.Save Overload List


Validate Method

Aptify 5.0 Software Development Kit (SDK)

TopicCodeLinksEntity.Validate Method

This method overrides the base Validate() function to add in validation to ensure that values in the Topic Code Link confirm to the possible values for the type of topic code. For Numeric topic codes, only numeric values are allowed. For Yes/No topic codes only the values Yes/No are allowed.

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Validate();

This method overrides the base Validate() function to add in validation to ensure that values in the Topic Code Link confirm to the possible values for the type of topic code. For Numeric topic codes, only numeric values are allowed. For Yes/No topic codes only the values Yes/No are allowed.

public override bool Validate(ref String&);

See Also

TopicCodeLinksEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


TopicCodeLinksEntity.Validate Method (String&)

This method overrides the base Validate() function to add in validation to ensure that values in the Topic Code Link confirm to the possible values for the type of topic code. For Numeric topic codes, only numeric values are allowed. For Yes/No topic codes only the values Yes/No are allowed.

public override bool Validate(
ref String& ErrorString
);

Parameters

ErrorString

Return Value

Remarks

See Also

TopicCodeLinksEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace | TopicCodeLinksEntity.Validate Overload List


TopicCodeLinksGeneralTab Class

For a list of all members of this type, see TopicCodeLinksGeneralTab Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
TopicCodeLinksGeneralTab

public class TopicCodeLinksGeneralTab : FormComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.Entity

Assembly: AptifyTopicCodeLinks (in AptifyTopicCodeLinks.dll)

See Also

TopicCodeLinksGeneralTab Members | Aptify.Framework.BusinessLogic.Entity Namespace


TopicCodeLinksGeneralTab Members

TopicCodeLinksGeneralTab overview

Public Instance Constructors

TopicCodeLinksGeneralTab Constructor Initializes a new instance of the TopicCodeLinksGeneralTab class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormComponent) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateContext (inherited from FormComponent) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormComponent) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormComponent) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

TopicCodeLinksGeneralTab Class | Aptify.Framework.BusinessLogic.Entity Namespace


TopicCodeLinksGeneralTab Constructor

Initializes a new instance of the TopicCodeLinksGeneralTab class.

public TopicCodeLinksGeneralTab();

See Also

TopicCodeLinksGeneralTab Class | Aptify.Framework.BusinessLogic.Entity Namespace


TopicCodeLinksGeneralTab Methods

The methods of the TopicCodeLinksGeneralTab class are listed below. For a complete list of TopicCodeLinksGeneralTab class members, see the TopicCodeLinksGeneralTab Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormComponent) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormComponent) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormComponent) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

TopicCodeLinksGeneralTab Class | Aptify.Framework.BusinessLogic.Entity Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

TopicCodeLinksGeneralTab.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

TopicCodeLinksGeneralTab Class | Aptify.Framework.BusinessLogic.Entity Namespace


TopicCodeLinksGeneralTab.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

TopicCodeLinksGeneralTab Class | Aptify.Framework.BusinessLogic.Entity Namespace | TopicCodeLinksGeneralTab.Dispose Overload List


TopicCodeLinksGeneralTab.OnFormComponentConfig Method

protected override void OnFormComponentConfig(
AptifyFormTemplateContext FormTemplateContext
);

Implements

IFormComponent.

See Also

TopicCodeLinksGeneralTab Class | Aptify.Framework.BusinessLogic.Entity Namespace


TopicCodeLinksGeneralTab.OnTransferDataToObject Method

protected override void OnTransferDataToObject(
ref Boolean& Cancel
);

Implements

IFormComponent.

See Also

TopicCodeLinksGeneralTab Class | Aptify.Framework.BusinessLogic.Entity Namespace


TopicCodeSelector Class

Implements functionality that finds records in the database that match a set of selected topic codes. Functionality can be used for any business application that needs to look for records in any entity that are linked to one or more topic codes. This class provides for a generic implementation model for selection of records using an object-based filtering model. For more information, see the FindRecords method of this class.

For a list of all members of this type, see TopicCodeSelector Members.

System.Object
TopicCodeSelector

public class TopicCodeSelector

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.Entity

Assembly: AptifyTopicCodeSelector (in AptifyTopicCodeSelector.dll)

See Also

TopicCodeSelector Members | Aptify.Framework.BusinessLogic.Entity Namespace


TopicCodeSelector Members

TopicCodeSelector overview

Public Instance Constructors

TopicCodeSelector Constructor

Public Instance Properties

Application
DataAction

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindRecords | Overloaded. This overload finds all records linked to the specified TopicCodeID within the specified EntityID. This overload only returns records that are linked with Topic Code link records that have a Status=Active
GetEntityRecordTopicCodes | Overloaded. This method returns a list of topic code ID values that are associated with a specific entity record that have a topic code link status of Active
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GenerateAllRequiredSQL | Overloaded. This method is used to generate the SQL statement required to return a list of records within the given list of entities that have ALL of the topic codes specified in the list. This functionality generates joins for each topic code to ensure that every one of the topic codes listed is tested distinctly.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TopicCodeSelector Class | Aptify.Framework.BusinessLogic.Entity Namespace


TopicCodeSelector Constructor

public TopicCodeSelector(
AptifyApplication Application
);

See Also

TopicCodeSelector Class | Aptify.Framework.BusinessLogic.Entity Namespace


TopicCodeSelector Properties

The properties of the TopicCodeSelector class are listed below. For a complete list of TopicCodeSelector class members, see the TopicCodeSelector Members topic.

Public Instance Properties

Application
DataAction

See Also

TopicCodeSelector Class | Aptify.Framework.BusinessLogic.Entity Namespace


Application Property

Aptify 5.0 Software Development Kit (SDK)

TopicCodeSelector.Application Property

public virtual AptifyApplication Application {get;}

See Also

TopicCodeSelector Class | Aptify.Framework.BusinessLogic.Entity Namespace


DataAction Property

Aptify 5.0 Software Development Kit (SDK)

TopicCodeSelector.DataAction Property

public virtual DataAction DataAction {get;}

See Also

TopicCodeSelector Class | Aptify.Framework.BusinessLogic.Entity Namespace


TopicCodeSelector Methods

The methods of the TopicCodeSelector class are listed below. For a complete list of TopicCodeSelector class members, see the TopicCodeSelector Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindRecords | Overloaded. This overload finds all records linked to the specified TopicCodeID within the specified EntityID. This overload only returns records that are linked with Topic Code link records that have a Status=Active
GetEntityRecordTopicCodes | Overloaded. This method returns a list of topic code ID values that are associated with a specific entity record that have a topic code link status of Active
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GenerateAllRequiredSQL | Overloaded. This method is used to generate the SQL statement required to return a list of records within the given list of entities that have ALL of the topic codes specified in the list. This functionality generates joins for each topic code to ensure that every one of the topic codes listed is tested distinctly.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TopicCodeSelector Class | Aptify.Framework.BusinessLogic.Entity Namespace


FindRecords Method

Aptify 5.0 Software Development Kit (SDK)

TopicCodeSelector.FindRecords Method

This overload finds all records linked to the specified TopicCodeIDs within the specified list of entity id values.

Overload List

This overload finds all records linked to the specified TopicCodeIDs within the specified list of entity id values.

public virtual List<T> FindRecords(List<T>,Boolean,List<T>,TopicCodeSelector.TopicCodeLinkStatus,String);

This overload finds all records linked to the specified TopicCodeIDs within the specified list of entity id values. This overload only returns topic codes that are linked via Topic code link records with a status of Active

public virtual List<T> FindRecords(List<T>,Boolean,List<T>,String);

This overload finds all records linked to the specified TopicCodeIDs within the specified list of entities.

public virtual List<T> FindRecords(List<T>,Boolean,List<T>,TopicCodeSelector.TopicCodeLinkStatus,String);

This overload finds all records linked to the specified TopicCodeIDs within the specified list of entities. This overload only returns records that are linked with a Topic Code Link with status=Active.

public virtual List<T> FindRecords(List<T>,Boolean,List<T>,String);

This overload finds all records linked to the specified TopicCodeIDs within the specified entity ID value.

public virtual List<T> FindRecords(List<T>,Boolean,Int64,TopicCodeSelector.TopicCodeLinkStatus,String);

This overload finds all records linked to the specified TopicCodeIDs within the specified entity ID value. Only returns topic codes that are linked via Topic Code Link records with a status of active

public virtual List<T> FindRecords(List<T>,Boolean,Int64,String);

This overload finds all records linked to the specified TopicCodeIDs within the specified entity.

public virtual List<T> FindRecords(List<T>,Boolean,String,TopicCodeSelector.TopicCodeLinkStatus,String);

This overload finds all records linked to the specified TopicCodeIDs within the specified entity. This overload only returns topic codes that have links with a status=Active.

public virtual List<T> FindRecords(List<T>,Boolean,String,String);

This overload finds all records linked to the specified TopicCodeID within the specified list of entity id values.

public virtual List<T> FindRecords(Int64,List<T>,TopicCodeSelector.TopicCodeLinkStatus,String);

This overload finds all records linked to the specified TopicCodeID within the specified list of entity id values. This overload only returns topic codes linked with Topic Code Link records that have a status of Active

public virtual List<T> FindRecords(Int64,List<T>,String);

This overload finds all records linked to the specified TopicCodeID within the specified list of entities.

public virtual List<T> FindRecords(Int64,List<T>,TopicCodeSelector.TopicCodeLinkStatus,String);

This overload finds all records linked to the specified TopicCodeID within the specified list of entities. This overload only returns topic codes that are linked via Topic Code Link records with a status of Active

public virtual List<T> FindRecords(Int64,List<T>,String);

This overload finds all records linked to the specified TopicCodeID within the specified EntityID

public virtual List<T> FindRecords(Int64,Int64,TopicCodeSelector.TopicCodeLinkStatus,String);

This overload finds all records linked to the specified TopicCodeID within the specified EntityID. This overload only returns records that are linked with Topic Code link records that have a Status=Active

public virtual List<T> FindRecords(Int64,Int64,String);

This overload finds all records linked to the specified TopicCodeID within the specified Entity

public virtual List<T> FindRecords(Int64,String,TopicCodeSelector.TopicCodeLinkStatus,String);

This overload finds all records linked to the specified TopicCodeID within the specified Entity. This overload only returns topic codes that have topic code links to the entity record with a status of Active.

public virtual List<T> FindRecords(Int64,String,String);

See Also

TopicCodeSelector Class | Aptify.Framework.BusinessLogic.Entity Namespace


TopicCodeSelector.FindRecords Method (List<T>, Boolean, List<T>, TopicCodeLinkStatus, String)

This overload finds all records linked to the specified TopicCodeIDs within the specified list of entity id values.

public virtual List<T> FindRecords(
List<T> TopicCodeIDs,
Boolean RequireAllTopicCodes,
List<T> EntityIDs,
TopicCodeSelector.TopicCodeLinkStatus TopicCodeLinkStatus,
String FilterSQL
);

Parameters

TopicCodeIDs
List of topic codes to search for
RequireAllTopicCodes
If this parameter is set to True, all of the topic codes in the TopicCodeIDs list parameter will be required, if set to false, one or more links to the topic codes in the TopicCodeIDs list will be sufficient for a record to be returned.
EntityIDs
List of entities to include in search
TopicCodeLinkStatus
FilterSQL
If provided, this string is appended to the query to find records as an AND filter.

Return Value

Remarks

See Also

TopicCodeSelector Class | Aptify.Framework.BusinessLogic.Entity Namespace | TopicCodeSelector.FindRecords Overload List


TopicCodeSelector.FindRecords Method (List<T>, Boolean, List<T>, String)

This overload finds all records linked to the specified TopicCodeIDs within the specified list of entity id values. This overload only returns topic codes that are linked via Topic code link records with a status of Active

public virtual List<T> FindRecords(
List<T> TopicCodeIDs,
Boolean RequireAllTopicCodes,
List<T> EntityIDs,
String FilterSQL
);

Parameters

TopicCodeIDs
List of topic codes to search for
RequireAllTopicCodes
If this parameter is set to True, all of the topic codes in the TopicCodeIDs list parameter will be required, if set to false, one or more links to the topic codes in the TopicCodeIDs list will be sufficient for a record to be returned.
EntityIDs
List of entities to include in search
FilterSQL
If provided, this string is appended to the query to find records as an AND filter.

Return Value

Remarks

See Also

TopicCodeSelector Class | Aptify.Framework.BusinessLogic.Entity Namespace | TopicCodeSelector.FindRecords Overload List


TopicCodeSelector.FindRecords Method (List<T>, Boolean, List<T>, TopicCodeLinkStatus, String)

This overload finds all records linked to the specified TopicCodeIDs within the specified list of entities.

public virtual List<T> FindRecords(
List<T> TopicCodeIDs,
Boolean RequireAllTopicCodes,
List<T> Entities,
TopicCodeSelector.TopicCodeLinkStatus TopicCodeLinkStatus,
String FilterSQL
);

Parameters

TopicCodeIDs
List of topic codes to search for
RequireAllTopicCodes
If this parameter is set to True, all of the topic codes in the TopicCodeIDs list parameter will be required, if set to false, one or more links to the topic codes in the TopicCodeIDs list will be sufficient for a record to be returned.
Entities
List of entities to include in search
TopicCodeLinkStatus
FilterSQL
If provided, this string is appended to the query to find records as an AND filter.

Return Value

Remarks

See Also

TopicCodeSelector Class | Aptify.Framework.BusinessLogic.Entity Namespace | TopicCodeSelector.FindRecords Overload List


TopicCodeSelector.FindRecords Method (List<T>, Boolean, List<T>, String)

This overload finds all records linked to the specified TopicCodeIDs within the specified list of entities. This overload only returns records that are linked with a Topic Code Link with status=Active.

public virtual List<T> FindRecords(
List<T> TopicCodeIDs,
Boolean RequireAllTopicCodes,
List<T> Entities,
String FilterSQL
);

Parameters

TopicCodeIDs
List of topic codes to search for
RequireAllTopicCodes
If this parameter is set to True, all of the topic codes in the TopicCodeIDs list parameter will be required, if set to false, one or more links to the topic codes in the TopicCodeIDs list will be sufficient for a record to be returned.
Entities
List of entities to include in search
FilterSQL
If provided, this string is appended to the query to find records as an AND filter.

Return Value

Remarks

See Also

TopicCodeSelector Class | Aptify.Framework.BusinessLogic.Entity Namespace | TopicCodeSelector.FindRecords Overload List


TopicCodeSelector.FindRecords Method (List<T>, Boolean, Int64, TopicCodeLinkStatus, String)

This overload finds all records linked to the specified TopicCodeIDs within the specified entity ID value.

public virtual List<T> FindRecords(
List<T> TopicCodeIDs,
Boolean RequireAllTopicCodes,
Int64 EntityID,
TopicCodeSelector.TopicCodeLinkStatus TopicCodeLinkStatus,
String FilterSQL
);

Parameters

TopicCodeIDs
List of topic codes to search for
RequireAllTopicCodes
If this parameter is set to True, all of the topic codes in the TopicCodeIDs list parameter will be required, if set to false, one or more links to the topic codes in the TopicCodeIDs list will be sufficient for a record to be returned.
EntityID
TopicCodeLinkStatus
FilterSQL
If provided, this string is appended to the query to find records as an AND filter.

Return Value

Remarks

See Also

TopicCodeSelector Class | Aptify.Framework.BusinessLogic.Entity Namespace | TopicCodeSelector.FindRecords Overload List


TopicCodeSelector.FindRecords Method (List<T>, Boolean, Int64, String)

This overload finds all records linked to the specified TopicCodeIDs within the specified entity ID value. Only returns topic codes that are linked via Topic Code Link records with a status of active

public virtual List<T> FindRecords(
List<T> TopicCodeIDs,
Boolean RequireAllTopicCodes,
Int64 EntityID,
String FilterSQL
);

Parameters

TopicCodeIDs
List of topic codes to search for
RequireAllTopicCodes
If this parameter is set to True, all of the topic codes in the TopicCodeIDs list parameter will be required, if set to false, one or more links to the topic codes in the TopicCodeIDs list will be sufficient for a record to be returned.
EntityID
FilterSQL
If provided, this string is appended to the query to find records as an AND filter.

Return Value

Remarks

See Also

TopicCodeSelector Class | Aptify.Framework.BusinessLogic.Entity Namespace | TopicCodeSelector.FindRecords Overload List


TopicCodeSelector.FindRecords Method (List<T>, Boolean, String, TopicCodeLinkStatus, String)

This overload finds all records linked to the specified TopicCodeIDs within the specified entity.

public virtual List<T> FindRecords(
List<T> TopicCodeIDs,
Boolean RequireAllTopicCodes,
String Entity,
TopicCodeSelector.TopicCodeLinkStatus TopicCodeLinkStatus,
String FilterSQL
);

Parameters

TopicCodeIDs
List of topic codes to search for
RequireAllTopicCodes
If this parameter is set to True, all of the topic codes in the TopicCodeIDs list parameter will be required, if set to false, one or more links to the topic codes in the TopicCodeIDs list will be sufficient for a record to be returned.
Entity
TopicCodeLinkStatus
FilterSQL
If provided, this string is appended to the query to find records as an AND filter.

Return Value

Remarks

See Also

TopicCodeSelector Class | Aptify.Framework.BusinessLogic.Entity Namespace | TopicCodeSelector.FindRecords Overload List


TopicCodeSelector.FindRecords Method (List<T>, Boolean, String, String)

This overload finds all records linked to the specified TopicCodeIDs within the specified entity. This overload only returns topic codes that have links with a status=Active.

public virtual List<T> FindRecords(
List<T> TopicCodeIDs,
Boolean RequireAllTopicCodes,
String Entity,
String FilterSQL
);

Parameters

TopicCodeIDs
List of topic codes to search for
RequireAllTopicCodes
If this parameter is set to True, all of the topic codes in the TopicCodeIDs list parameter will be required, if set to false, one or more links to the topic codes in the TopicCodeIDs list will be sufficient for a record to be returned.
Entity
FilterSQL
If provided, this string is appended to the query to find records as an AND filter.

Return Value

Remarks

See Also

TopicCodeSelector Class | Aptify.Framework.BusinessLogic.Entity Namespace | TopicCodeSelector.FindRecords Overload List


TopicCodeSelector.FindRecords Method (Int64, List<T>, TopicCodeLinkStatus, String)

This overload finds all records linked to the specified TopicCodeID within the specified list of entity id values.

public virtual List<T> FindRecords(
Int64 TopicCodeID,
List<T> EntityIDs,
TopicCodeSelector.TopicCodeLinkStatus TopicCodeLinkStatus,
String FilterSQL
);

Parameters

TopicCodeID
EntityIDs
List of entities to include in search
TopicCodeLinkStatus
FilterSQL
If provided, this string is appended to the query to find records as an AND filter.

Return Value

Remarks

See Also

TopicCodeSelector Class | Aptify.Framework.BusinessLogic.Entity Namespace | TopicCodeSelector.FindRecords Overload List


TopicCodeSelector.FindRecords Method (Int64, List<T>, String)

This overload finds all records linked to the specified TopicCodeID within the specified list of entity id values. This overload only returns topic codes linked with Topic Code Link records that have a status of Active

public virtual List<T> FindRecords(
Int64 TopicCodeID,
List<T> EntityIDs,
String FilterSQL
);

Parameters

TopicCodeID
EntityIDs
List of entities to include in search
FilterSQL
If provided, this string is appended to the query to find records as an AND filter.

Return Value

Remarks

See Also

TopicCodeSelector Class | Aptify.Framework.BusinessLogic.Entity Namespace | TopicCodeSelector.FindRecords Overload List


TopicCodeSelector.FindRecords Method (Int64, List<T>, TopicCodeLinkStatus, String)

This overload finds all records linked to the specified TopicCodeID within the specified list of entities.

public virtual List<T> FindRecords(
Int64 TopicCodeID,
List<T> Entities,
TopicCodeSelector.TopicCodeLinkStatus TopicCodeLinkStatus,
String FilterSQL
);

Parameters

TopicCodeID
Entities
List of entities to include in search
TopicCodeLinkStatus
FilterSQL
If provided, this string is appended to the query to find records as an AND filter.

Return Value

Remarks

See Also

TopicCodeSelector Class | Aptify.Framework.BusinessLogic.Entity Namespace | TopicCodeSelector.FindRecords Overload List


TopicCodeSelector.FindRecords Method (Int64, List<T>, String)

This overload finds all records linked to the specified TopicCodeID within the specified list of entities. This overload only returns topic codes that are linked via Topic Code Link records with a status of Active

public virtual List<T> FindRecords(
Int64 TopicCodeID,
List<T> Entities,
String FilterSQL
);

Parameters

TopicCodeID
Entities
List of entities to include in search
FilterSQL
If provided, this string is appended to the query to find records as an AND filter.

Return Value

Remarks

See Also

TopicCodeSelector Class | Aptify.Framework.BusinessLogic.Entity Namespace | TopicCodeSelector.FindRecords Overload List


TopicCodeSelector.FindRecords Method (Int64, Int64, TopicCodeLinkStatus, String)

This overload finds all records linked to the specified TopicCodeID within the specified EntityID

public virtual List<T> FindRecords(
Int64 TopicCodeID,
Int64 EntityID,
TopicCodeSelector.TopicCodeLinkStatus TopicCodeLinkStatus,
String FilterSQL
);

Parameters

TopicCodeID
EntityID
TopicCodeLinkStatus
FilterSQL
If provided, this string is appended to the query to find records as an AND filter.

Return Value

Remarks

See Also

TopicCodeSelector Class | Aptify.Framework.BusinessLogic.Entity Namespace | TopicCodeSelector.FindRecords Overload List


TopicCodeSelector.FindRecords Method (Int64, Int64, String)

This overload finds all records linked to the specified TopicCodeID within the specified EntityID. This overload only returns records that are linked with Topic Code link records that have a Status=Active

public virtual List<T> FindRecords(
Int64 TopicCodeID,
Int64 EntityID,
String FilterSQL
);

Parameters

TopicCodeID
EntityID
FilterSQL
If provided, this string is appended to the query to find records as an AND filter.

Return Value

Remarks

See Also

TopicCodeSelector Class | Aptify.Framework.BusinessLogic.Entity Namespace | TopicCodeSelector.FindRecords Overload List


TopicCodeSelector.FindRecords Method (Int64, String, TopicCodeLinkStatus, String)

This overload finds all records linked to the specified TopicCodeID within the specified Entity

public virtual List<T> FindRecords(
Int64 TopicCodeID,
String Entity,
TopicCodeSelector.TopicCodeLinkStatus TopicCodeLinkStatus,
String FilterSQL
);

Parameters

TopicCodeID
Entity
TopicCodeLinkStatus
FilterSQL
If provided, this string is appended to the query to find records as an AND filter.

Return Value

Remarks

See Also

TopicCodeSelector Class | Aptify.Framework.BusinessLogic.Entity Namespace | TopicCodeSelector.FindRecords Overload List


TopicCodeSelector.FindRecords Method (Int64, String, String)

This overload finds all records linked to the specified TopicCodeID within the specified Entity. This overload only returns topic codes that have topic code links to the entity record with a status of Active.

public virtual List<T> FindRecords(
Int64 TopicCodeID,
String Entity,
String FilterSQL
);

Parameters

TopicCodeID
Entity
FilterSQL
If provided, this string is appended to the query to find records as an AND filter.

Return Value

Remarks

See Also

TopicCodeSelector Class | Aptify.Framework.BusinessLogic.Entity Namespace | TopicCodeSelector.FindRecords Overload List


GenerateAllRequiredSQL Method

Aptify 5.0 Software Development Kit (SDK)

TopicCodeSelector.GenerateAllRequiredSQL Method

This method is used to generate the SQL statement required to return a list of records within the given list of entities that have ALL of the topic codes specified in the list. This functionality generates joins for each topic code to ensure that every one of the topic codes listed is tested distinctly. This overload only returns topic code links with a status of Active. Use the other overload to get back all topic code links, or other status codes.

Overload List

This method is used to generate the SQL statement required to return a list of records within the given list of entities that have ALL of the topic codes specified in the list. This functionality generates joins for each topic code to ensure that every one of the topic codes listed is tested distinctly. This overload only returns topic code links with a status of Active. Use the other overload to get back all topic code links, or other status codes.

protected virtual string GenerateAllRequiredSQL(List<T>,List<T>,String);

This method is used to generate the SQL statement required to return a list of records within the given list of entities that have ALL of the topic codes specified in the list. This functionality generates joins for each topic code to ensure that every one of the topic codes listed is tested distinctly.

protected virtual string GenerateAllRequiredSQL(List<T>,List<T>,String,TopicCodeSelector.TopicCodeLinkStatus);

See Also

TopicCodeSelector Class | Aptify.Framework.BusinessLogic.Entity Namespace


TopicCodeSelector.GenerateAllRequiredSQL Method (List<T>, List<T>, String)

This method is used to generate the SQL statement required to return a list of records within the given list of entities that have ALL of the topic codes specified in the list. This functionality generates joins for each topic code to ensure that every one of the topic codes listed is tested distinctly. This overload only returns topic code links with a status of Active. Use the other overload to get back all topic code links, or other status codes.

protected virtual string GenerateAllRequiredSQL(
List<T> EntityIDs,
List<T> TopicCodeIDs,
String FilterSQL
);

Parameters

EntityIDs
TopicCodeIDs
FilterSQL

Return Value

Remarks

See Also

TopicCodeSelector Class | Aptify.Framework.BusinessLogic.Entity Namespace | TopicCodeSelector.GenerateAllRequiredSQL Overload List


TopicCodeSelector.GenerateAllRequiredSQL Method (List<T>, List<T>, String, TopicCodeLinkStatus)

This method is used to generate the SQL statement required to return a list of records within the given list of entities that have ALL of the topic codes specified in the list. This functionality generates joins for each topic code to ensure that every one of the topic codes listed is tested distinctly.

protected virtual string GenerateAllRequiredSQL(
List<T> EntityIDs,
List<T> TopicCodeIDs,
String FilterSQL,
TopicCodeSelector.TopicCodeLinkStatus TopicCodeLinkStatus
);

Parameters

EntityIDs
TopicCodeIDs
FilterSQL
TopicCodeLinkStatus
Status of the topic code links

Return Value

Remarks

See Also

TopicCodeSelector Class | Aptify.Framework.BusinessLogic.Entity Namespace | TopicCodeSelector.GenerateAllRequiredSQL Overload List


GetEntityRecordTopicCodes Method

Aptify 5.0 Software Development Kit (SDK)

TopicCodeSelector.GetEntityRecordTopicCodes Method

This method returns a list of topic code ID values that are associated with a specific entity record that have a topic code link status of Active

Overload List

This method returns a list of topic code ID values that are associated with a specific entity record that have a topic code link status of Active

public virtual List<T> GetEntityRecordTopicCodes(Int64,Int64);

This method returns a list of topic code ID values that are associated with a specific entity record

public virtual List<T> GetEntityRecordTopicCodes(Int64,Int64,TopicCodeSelector.TopicCodeLinkStatus);

This method returns a list of topic code ID values that are associated with a specific entity record with a topic code link status of Active.

public virtual List<T> GetEntityRecordTopicCodes(String,Int64);

This method returns a list of topic code ID values that are associated with a specific entity record

public virtual List<T> GetEntityRecordTopicCodes(String,Int64,TopicCodeSelector.TopicCodeLinkStatus);

See Also

TopicCodeSelector Class | Aptify.Framework.BusinessLogic.Entity Namespace


TopicCodeSelector.GetEntityRecordTopicCodes Method (Int64, Int64)

This method returns a list of topic code ID values that are associated with a specific entity record that have a topic code link status of Active

public virtual List<T> GetEntityRecordTopicCodes(
Int64 EntityID,
Int64 RecordID
);

Parameters

EntityID
RecordID

Return Value

Remarks

See Also

TopicCodeSelector Class | Aptify.Framework.BusinessLogic.Entity Namespace | TopicCodeSelector.GetEntityRecordTopicCodes Overload List


TopicCodeSelector.GetEntityRecordTopicCodes Method (Int64, Int64, TopicCodeLinkStatus)

This method returns a list of topic code ID values that are associated with a specific entity record

public virtual List<T> GetEntityRecordTopicCodes(
Int64 EntityID,
Int64 RecordID,
TopicCodeSelector.TopicCodeLinkStatus TopicCodeLinkStatus
);

Parameters

EntityID
RecordID
TopicCodeLinkStatus

Return Value

Remarks

See Also

TopicCodeSelector Class | Aptify.Framework.BusinessLogic.Entity Namespace | TopicCodeSelector.GetEntityRecordTopicCodes Overload List


TopicCodeSelector.GetEntityRecordTopicCodes Method (String, Int64)

This method returns a list of topic code ID values that are associated with a specific entity record with a topic code link status of Active.

public virtual List<T> GetEntityRecordTopicCodes(
String Entity,
Int64 RecordID
);

Parameters

Entity
RecordID

Return Value

Remarks

See Also

TopicCodeSelector Class | Aptify.Framework.BusinessLogic.Entity Namespace | TopicCodeSelector.GetEntityRecordTopicCodes Overload List


TopicCodeSelector.GetEntityRecordTopicCodes Method (String, Int64, TopicCodeLinkStatus)

This method returns a list of topic code ID values that are associated with a specific entity record

public virtual List<T> GetEntityRecordTopicCodes(
String Entity,
Int64 RecordID,
TopicCodeSelector.TopicCodeLinkStatus TopicCodeLinkStatus
);

Parameters

Entity
RecordID
TopicCodeLinkStatus

Return Value

Remarks

See Also

TopicCodeSelector Class | Aptify.Framework.BusinessLogic.Entity Namespace | TopicCodeSelector.GetEntityRecordTopicCodes Overload List


TopicCodeSelector.TopicCodeLink Class

Utility class that provides information about a topic code link record

For a list of all members of this type, see TopicCodeSelector.TopicCodeLink Members.

System.Object
TopicCodeSelector.TopicCodeLink

public class TopicCodeSelector.TopicCodeLink

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.Entity

Assembly: AptifyTopicCodeSelector (in AptifyTopicCodeSelector.dll)

See Also

TopicCodeSelector.TopicCodeLink Members | Aptify.Framework.BusinessLogic.Entity Namespace


TopicCodeSelector.TopicCodeLink Members

TopicCodeSelector.TopicCodeLink overview

Public Instance Properties

DateAdded
Entity
RecordID
Status
TopicCodeID
TopicCodeLinkID
TopicCodeName
Value

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TopicCodeSelector.TopicCodeLink Class | Aptify.Framework.BusinessLogic.Entity Namespace


TopicCodeSelector.TopicCodeLink Properties

The properties of the TopicCodeSelector.TopicCodeLink class are listed below. For a complete list of TopicCodeSelector.TopicCodeLink class members, see the TopicCodeSelector.TopicCodeLink Members topic.

Public Instance Properties

DateAdded
Entity
RecordID
Status
TopicCodeID
TopicCodeLinkID
TopicCodeName
Value

See Also

TopicCodeSelector.TopicCodeLink Class | Aptify.Framework.BusinessLogic.Entity Namespace


DateAdded Property

Aptify 5.0 Software Development Kit (SDK)

TopicCodeSelector.TopicCodeLink.DateAdded Property

public virtual DateTime DateAdded {get;}

See Also

TopicCodeSelector.TopicCodeLink Class | Aptify.Framework.BusinessLogic.Entity Namespace


Entity Property

Aptify 5.0 Software Development Kit (SDK)

TopicCodeSelector.TopicCodeLink.Entity Property

public virtual String Entity {get;}

See Also

TopicCodeSelector.TopicCodeLink Class | Aptify.Framework.BusinessLogic.Entity Namespace


RecordID Property

Aptify 5.0 Software Development Kit (SDK)

TopicCodeSelector.TopicCodeLink.RecordID Property

public virtual Int64 RecordID {get;}

See Also

TopicCodeSelector.TopicCodeLink Class | Aptify.Framework.BusinessLogic.Entity Namespace


Status Property

Aptify 5.0 Software Development Kit (SDK)

TopicCodeSelector.TopicCodeLink.Status Property

public virtual String Status {get;}

See Also

TopicCodeSelector.TopicCodeLink Class | Aptify.Framework.BusinessLogic.Entity Namespace


TopicCodeID Property

Aptify 5.0 Software Development Kit (SDK)

TopicCodeSelector.TopicCodeLink.TopicCodeID Property

public virtual Int64 TopicCodeID {get;}

See Also

TopicCodeSelector.TopicCodeLink Class | Aptify.Framework.BusinessLogic.Entity Namespace


TopicCodeLinkID Property

Aptify 5.0 Software Development Kit (SDK)

TopicCodeSelector.TopicCodeLink.TopicCodeLinkID Property

public virtual Int64 TopicCodeLinkID {get;}

See Also

TopicCodeSelector.TopicCodeLink Class | Aptify.Framework.BusinessLogic.Entity Namespace


TopicCodeName Property

Aptify 5.0 Software Development Kit (SDK)

TopicCodeSelector.TopicCodeLink.TopicCodeName Property

public virtual String TopicCodeName {get;}

See Also

TopicCodeSelector.TopicCodeLink Class | Aptify.Framework.BusinessLogic.Entity Namespace


Value Property

Aptify 5.0 Software Development Kit (SDK)

TopicCodeSelector.TopicCodeLink.Value Property

public virtual String Value {get;}

See Also

TopicCodeSelector.TopicCodeLink Class | Aptify.Framework.BusinessLogic.Entity Namespace


TopicCodeSelector.TopicCodeLinkedRecord Class

Utility class that provides information about a record that is linked to a topic code.

For a list of all members of this type, see TopicCodeSelector.TopicCodeLinkedRecord Members.

System.Object
TopicCodeSelector.TopicCodeLinkedRecord

public class TopicCodeSelector.TopicCodeLinkedRecord

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.Entity

Assembly: AptifyTopicCodeSelector (in AptifyTopicCodeSelector.dll)

See Also

TopicCodeSelector.TopicCodeLinkedRecord Members | Aptify.Framework.BusinessLogic.Entity Namespace


TopicCodeSelector.TopicCodeLinkedRecord Members

TopicCodeSelector.TopicCodeLinkedRecord overview

Public Instance Properties

Application |
DataAction |
Entity |
LinkedTopicCodes | Returns a list of the topic code links for this record.
RecordID |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
RefreshLinkedTopicCodes | This method will refresh the LinkedTopicCodes list.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PopulateTopicCodeLinks |

See Also

TopicCodeSelector.TopicCodeLinkedRecord Class | Aptify.Framework.BusinessLogic.Entity Namespace


TopicCodeSelector.TopicCodeLinkedRecord Properties

The properties of the TopicCodeSelector.TopicCodeLinkedRecord class are listed below. For a complete list of TopicCodeSelector.TopicCodeLinkedRecord class members, see the TopicCodeSelector.TopicCodeLinkedRecord Members topic.

Public Instance Properties

Application |
DataAction |
Entity |
LinkedTopicCodes | Returns a list of the topic code links for this record.
RecordID |

See Also

TopicCodeSelector.TopicCodeLinkedRecord Class | Aptify.Framework.BusinessLogic.Entity Namespace


Application Property

Aptify 5.0 Software Development Kit (SDK)

TopicCodeSelector.TopicCodeLinkedRecord.Application Property

public virtual AptifyApplication Application {get;}

See Also

TopicCodeSelector.TopicCodeLinkedRecord Class | Aptify.Framework.BusinessLogic.Entity Namespace


DataAction Property

Aptify 5.0 Software Development Kit (SDK)

TopicCodeSelector.TopicCodeLinkedRecord.DataAction Property

public virtual DataAction DataAction {get;}

See Also

TopicCodeSelector.TopicCodeLinkedRecord Class | Aptify.Framework.BusinessLogic.Entity Namespace


Entity Property

Aptify 5.0 Software Development Kit (SDK)

TopicCodeSelector.TopicCodeLinkedRecord.Entity Property

public virtual String Entity {get;}

See Also

TopicCodeSelector.TopicCodeLinkedRecord Class | Aptify.Framework.BusinessLogic.Entity Namespace


LinkedTopicCodes Property

Aptify 5.0 Software Development Kit (SDK)

TopicCodeSelector.TopicCodeLinkedRecord.LinkedTopicCodes Property

Returns a list of the topic code links for this record.

public virtual List<T> LinkedTopicCodes {get;}

Property Value

Remarks

See Also

TopicCodeSelector.TopicCodeLinkedRecord Class | Aptify.Framework.BusinessLogic.Entity Namespace


RecordID Property

Aptify 5.0 Software Development Kit (SDK)

TopicCodeSelector.TopicCodeLinkedRecord.RecordID Property

public virtual Int64 RecordID {get;}

See Also

TopicCodeSelector.TopicCodeLinkedRecord Class | Aptify.Framework.BusinessLogic.Entity Namespace


TopicCodeSelector.TopicCodeLinkedRecord Methods

The methods of the TopicCodeSelector.TopicCodeLinkedRecord class are listed below. For a complete list of TopicCodeSelector.TopicCodeLinkedRecord class members, see the TopicCodeSelector.TopicCodeLinkedRecord Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
RefreshLinkedTopicCodes | This method will refresh the LinkedTopicCodes list.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PopulateTopicCodeLinks |

See Also

TopicCodeSelector.TopicCodeLinkedRecord Class | Aptify.Framework.BusinessLogic.Entity Namespace


TopicCodeSelector.TopicCodeLinkedRecord.PopulateTopicCodeLinks Method

protected virtual void PopulateTopicCodeLinks();

See Also

TopicCodeSelector.TopicCodeLinkedRecord Class | Aptify.Framework.BusinessLogic.Entity Namespace


TopicCodeSelector.TopicCodeLinkedRecord.RefreshLinkedTopicCodes Method

This method will refresh the LinkedTopicCodes list.

public virtual void RefreshLinkedTopicCodes();

Remarks

See Also

TopicCodeSelector.TopicCodeLinkedRecord Class | Aptify.Framework.BusinessLogic.Entity Namespace


TopicCodeSelector.TopicCodeLinkStatus Enumeration

public enum TopicCodeSelector.TopicCodeLinkStatus

Members

Member Name | Description
Inactive |
Active |
All |

Requirements

Namespace: Aptify.Framework.BusinessLogic.Entity

Assembly: AptifyTopicCodeSelector (in AptifyTopicCodeSelector.dll)

See Also

Aptify.Framework.BusinessLogic.Entity Namespace


TopicCodesEntity Class

This class is the GE wrapper around the Topic Codes Entity

For a list of all members of this type, see TopicCodesEntity Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
TopicCodesEntity

public class TopicCodesEntity : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.Entity

Assembly: AptifyTopicCodes (in AptifyTopicCodes.dll)

See Also

TopicCodesEntity Members | Aptify.Framework.BusinessLogic.Entity Namespace


TopicCodesEntity Members

TopicCodesEntity overview

Public Static Methods

GetTopicCodeTextFromType | This member maps topic code type to a string value TopicCodeType.YesNo - Maps to "Yes/No" TopicCodeType.MultipleChoice - Maps to "Multiple Choice" TopicCodeType.Numeric - Maps to "Numeric" TopicCodeType.Text - Maps to "Text"
GetTopicCodeValueTypeFromText | This member maps a string to a topic code type based on values in the database "Yes/No" - Maps to TopicCodeType.YesNo "Multiple Choice" - Maps to TopicCodeType.MultipleChoice "Numeric" - Maps to TopicCodeType.Numeric "Text" - Maps to TopicCodeType.Text

Public Instance Constructors

TopicCodesEntity Constructor Initializes a new instance of the TopicCodesEntity class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.
ValueType | Returns the Value Type enum for the current topic code record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config | Overloaded. Configures the wrapper for use.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded. Validates the integrity of the current data loaded in the wrapper.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

TopicCodesEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


TopicCodesEntity Constructor

Initializes a new instance of the TopicCodesEntity class.

public TopicCodesEntity();

See Also

TopicCodesEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


TopicCodesEntity Properties

The properties of the TopicCodesEntity class are listed below. For a complete list of TopicCodesEntity class members, see the TopicCodesEntity Members topic.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.
ValueType | Returns the Value Type enum for the current topic code record.

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

TopicCodesEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


ValueType Property

Aptify 5.0 Software Development Kit (SDK)

TopicCodesEntity.ValueType Property

Returns the Value Type enum for the current topic code record.

public virtual TopicCodeValueType ValueType {get;}

Property Value

Remarks

See Also

TopicCodesEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


TopicCodesEntity Methods

The methods of the TopicCodesEntity class are listed below. For a complete list of TopicCodesEntity class members, see the TopicCodesEntity Members topic.

Public Static Methods

GetTopicCodeTextFromType | This member maps topic code type to a string value TopicCodeType.YesNo - Maps to "Yes/No" TopicCodeType.MultipleChoice - Maps to "Multiple Choice" TopicCodeType.Numeric - Maps to "Numeric" TopicCodeType.Text - Maps to "Text"
GetTopicCodeValueTypeFromText | This member maps a string to a topic code type based on values in the database "Yes/No" - Maps to TopicCodeType.YesNo "Multiple Choice" - Maps to TopicCodeType.MultipleChoice "Numeric" - Maps to TopicCodeType.Numeric "Text" - Maps to TopicCodeType.Text

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config | Overloaded. Configures the wrapper for use.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate | Overloaded. Validates the integrity of the current data loaded in the wrapper.
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

TopicCodesEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


Config Method

Aptify 5.0 Software Development Kit (SDK)

TopicCodesEntity.Config Method

Configures the wrapper for use.

Overload List

Inherited from AptifyGenericEntityBase.

public virtual void Config(AptifySubTypeBase);

Inherited from AptifyGenericEntity.

public override void Config(AptifySubTypeBase,Int64);

Inherited from AptifyGenericEntityBase.

public virtual void Config(UserCredentials,String);

Configures the wrapper for use.

public override void Config(UserCredentials,String,Int64);

See Also

TopicCodesEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


TopicCodesEntity.Config Method (UserCredentials, String, Int64)

Configures the wrapper for use.

public override void Config(
UserCredentials UserCredentials,
String EntityName,
Int64 RecordID
);

Parameters

UserCredentials
EntityName
RecordID

Remarks

This wrapper can only be used with the Topic Codes entity.

See Also

TopicCodesEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace | TopicCodesEntity.Config Overload List


TopicCodesEntity.GetTopicCodeTextFromType Method

This member maps topic code type to a string value TopicCodeType.YesNo - Maps to "Yes/No" TopicCodeType.MultipleChoice - Maps to "Multiple Choice" TopicCodeType.Numeric - Maps to "Numeric" TopicCodeType.Text - Maps to "Text"

public static string GetTopicCodeTextFromType(
TopicCodeValueType ValueType
);

Parameters

ValueType

Return Value

Remarks

See Also

TopicCodesEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


TopicCodesEntity.GetTopicCodeValueTypeFromText Method

This member maps a string to a topic code type based on values in the database "Yes/No" - Maps to TopicCodeType.YesNo "Multiple Choice" - Maps to TopicCodeType.MultipleChoice "Numeric" - Maps to TopicCodeType.Numeric "Text" - Maps to TopicCodeType.Text

public static TopicCodeValueType GetTopicCodeValueTypeFromText(
String TopicCodeType
);

Parameters

TopicCodeType
String Value to Map Topic Code

Return Value

Remarks

See Also

TopicCodesEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


Validate Method

Aptify 5.0 Software Development Kit (SDK)

TopicCodesEntity.Validate Method

Validates the integrity of the current data loaded in the wrapper.

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Validate();

Validates the integrity of the current data loaded in the wrapper.

public override bool Validate(ref String&);

See Also

TopicCodesEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace


TopicCodesEntity.Validate Method (String&)

Validates the integrity of the current data loaded in the wrapper.

public override bool Validate(
ref String& ErrorString
);

Parameters

ErrorString
If there was an issue then this string contains the description of the problem.

Return Value

True if it is valid, else False.

Remarks

Make sure there is not a recursive link to this record's parent.

See Also

TopicCodesEntity Class | Aptify.Framework.BusinessLogic.Entity Namespace | TopicCodesEntity.Validate Overload List


TopicCodesGeneralTab Class

This tab contains all of the logic needed to properly display the General Tab of the Topic Codes Entity.

For a list of all members of this type, see TopicCodesGeneralTab Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
TopicCodesGeneralTab

public class TopicCodesGeneralTab : FormComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.Entity

Assembly: AptifyTopicCodes (in AptifyTopicCodes.dll)

See Also

TopicCodesGeneralTab Members | Aptify.Framework.BusinessLogic.Entity Namespace


TopicCodesGeneralTab Members

TopicCodesGeneralTab overview

Public Instance Constructors

TopicCodesGeneralTab Constructor Initializes a new instance of the TopicCodesGeneralTab class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormComponent) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateContext (inherited from FormComponent) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormComponent) |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormComponent) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormComponent) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormComponent) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

TopicCodesGeneralTab Class | Aptify.Framework.BusinessLogic.Entity Namespace


TopicCodesGeneralTab Constructor

Initializes a new instance of the TopicCodesGeneralTab class.

public TopicCodesGeneralTab();

See Also

TopicCodesGeneralTab Class | Aptify.Framework.BusinessLogic.Entity Namespace


TopicCodesGeneralTab Methods

The methods of the TopicCodesGeneralTab class are listed below. For a complete list of TopicCodesGeneralTab class members, see the TopicCodesGeneralTab Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormComponent) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormComponent) |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormComponent) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormComponent) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormComponent) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

TopicCodesGeneralTab Class | Aptify.Framework.BusinessLogic.Entity Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

TopicCodesGeneralTab.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

TopicCodesGeneralTab Class | Aptify.Framework.BusinessLogic.Entity Namespace


TopicCodesGeneralTab.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

TopicCodesGeneralTab Class | Aptify.Framework.BusinessLogic.Entity Namespace | TopicCodesGeneralTab.Dispose Overload List


TopicCodesTopicCodeLinksTab Class

This tab contains all of the logic needed to properly display the Topic Code Links of the Topic Codes Entity.

For a list of all members of this type, see TopicCodesTopicCodeLinksTab Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
TopicCodesTopicCodeLinksTab

public class TopicCodesTopicCodeLinksTab : FormComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.Entity

Assembly: AptifyTopicCodes (in AptifyTopicCodes.dll)

See Also

TopicCodesTopicCodeLinksTab Members | Aptify.Framework.BusinessLogic.Entity Namespace


TopicCodesTopicCodeLinksTab Members

TopicCodesTopicCodeLinksTab overview

Public Instance Constructors

TopicCodesTopicCodeLinksTab Constructor Initializes a new instance of the TopicCodesTopicCodeLinksTab class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormComponent) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateContext (inherited from FormComponent) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormComponent) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormComponent) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormComponent) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

TopicCodesTopicCodeLinksTab Class | Aptify.Framework.BusinessLogic.Entity Namespace


TopicCodesTopicCodeLinksTab Constructor

Initializes a new instance of the TopicCodesTopicCodeLinksTab class.

public TopicCodesTopicCodeLinksTab();

See Also

TopicCodesTopicCodeLinksTab Class | Aptify.Framework.BusinessLogic.Entity Namespace


TopicCodesTopicCodeLinksTab Methods

The methods of the TopicCodesTopicCodeLinksTab class are listed below. For a complete list of TopicCodesTopicCodeLinksTab class members, see the TopicCodesTopicCodeLinksTab Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormComponent) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig |
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormComponent) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormComponent) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormComponent) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

TopicCodesTopicCodeLinksTab Class | Aptify.Framework.BusinessLogic.Entity Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

TopicCodesTopicCodeLinksTab.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

TopicCodesTopicCodeLinksTab Class | Aptify.Framework.BusinessLogic.Entity Namespace


TopicCodesTopicCodeLinksTab.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

TopicCodesTopicCodeLinksTab Class | Aptify.Framework.BusinessLogic.Entity Namespace | TopicCodesTopicCodeLinksTab.Dispose Overload List


TopicCodesTopicCodeLinksTab.OnFormComponentConfig Method

protected override void OnFormComponentConfig(
AptifyFormTemplateContext FormTemplateContext
);

Implements

IFormComponent.

See Also

TopicCodesTopicCodeLinksTab Class | Aptify.Framework.BusinessLogic.Entity Namespace


TopicCodeValueType Enumeration

Possible topic code value type enumeration

public enum TopicCodeValueType

Remarks

Members

Member Name | Description
YesNo |
MultipleChoice |
Numeric |
Text |

Requirements

Namespace: Aptify.Framework.BusinessLogic.Entity

Assembly: AptifyTopicCodes (in AptifyTopicCodes.dll)

See Also

Aptify.Framework.BusinessLogic.Entity Namespace


Aptify.Framework.BusinessLogic.Entity.Employees

Aptify 5.0 Software Development Kit (SDK)

Aptify.Framework.BusinessLogic.Entity.Employees Namespace

This namespace defines the logic and form template used by the Employees entity.

Namespace hierarchy

Classes

Class | Description
EmployeesEntity | Contains logic needed to create, read, updated, and delete Employees entity records.
EmployeesFormLayout | Contains custom logic that deals with controls on the Top Area Layout


EmployeesEntity Class

Contains logic needed to create, read, updated, and delete Employees entity records.

For a list of all members of this type, see EmployeesEntity Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
EmployeesClass
EmployeesEntity

public class EmployeesEntity : EmployeesClass

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.Entity.Employees

Assembly: AptifyEmployeesObject (in AptifyEmployeesObject.dll)

See Also

EmployeesEntity Members | Aptify.Framework.BusinessLogic.Entity.Employees Namespace


EmployeesEntity Members

EmployeesEntity overview

Public Instance Constructors

EmployeesEntity Constructor Initializes a new instance of the EmployeesEntity class.

Public Instance Properties

AllowFree (inherited from EmployeesClass) |
AllowPriceOverride (inherited from EmployeesClass) |
AllowPriceSelection (inherited from EmployeesClass) |
AllowRelatedProductPromptClose (inherited from EmployeesClass) |
Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BillRate (inherited from EmployeesClass) |
Birthday (inherited from EmployeesClass) |
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
CellAreaCode (inherited from EmployeesClass) |
CellCountryCode (inherited from EmployeesClass) |
CellPhone (inherited from EmployeesClass) |
CellPhoneID (inherited from EmployeesClass) |
Comments (inherited from EmployeesClass) |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DateCreated (inherited from EmployeesClass) |
DateHired (inherited from EmployeesClass) |
DateLastReviewed (inherited from EmployeesClass) |
DateReviewDue (inherited from EmployeesClass) |
DateTerminated (inherited from EmployeesClass) |
DateUpdated (inherited from EmployeesClass) |
DbUser (inherited from EmployeesClass) |
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
Department (inherited from EmployeesClass) |
DepartmentID (inherited from EmployeesClass) |
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
Email1 (inherited from EmployeesClass) |
Email2 (inherited from EmployeesClass) |
Email3 (inherited from EmployeesClass) |
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
FirstLast (inherited from EmployeesClass) |
FirstName (inherited from EmployeesClass) |
Gender (inherited from EmployeesClass) |
HomeAddressID (inherited from EmployeesClass) |
HomeAddressLine1 (inherited from EmployeesClass) |
HomeAddressLine2 (inherited from EmployeesClass) |
HomeAddressLine3 (inherited from EmployeesClass) |
HomeAddressLine4 (inherited from EmployeesClass) |
HomeAreaCode (inherited from EmployeesClass) |
HomeCity (inherited from EmployeesClass) |
HomeCountry (inherited from EmployeesClass) |
HomeCountryCode (inherited from EmployeesClass) |
HomeCounty (inherited from EmployeesClass) |
HomeFax (inherited from EmployeesClass) |
HomeFaxAreaCode (inherited from EmployeesClass) |
HomeFaxCountryCode (inherited from EmployeesClass) |
HomeFaxID (inherited from EmployeesClass) |
HomePhone (inherited from EmployeesClass) |
HomePhoneID (inherited from EmployeesClass) |
HomeState (inherited from EmployeesClass) |
HomeZipCode (inherited from EmployeesClass) |
ID (inherited from EmployeesClass) |
ImportantDate1 (inherited from EmployeesClass) |
ImportantDate2 (inherited from EmployeesClass) |
ImportantDate3 (inherited from EmployeesClass) |
ImportantDescription1 (inherited from EmployeesClass) |
ImportantDescription2 (inherited from EmployeesClass) |
ImportantDescription3 (inherited from EmployeesClass) |
Inactive (inherited from EmployeesClass) |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
Kids (inherited from EmployeesClass) |
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastName (inherited from EmployeesClass) |
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LinkedPersonID (inherited from EmployeesClass) |
MiddleName (inherited from EmployeesClass) |
Organization (inherited from EmployeesClass) |
OrganizationID (inherited from EmployeesClass) |
PagerAreaCode (inherited from EmployeesClass) |
PagerCountryCode (inherited from EmployeesClass) |
PagerPhone (inherited from EmployeesClass) |
PagerPhoneID (inherited from EmployeesClass) |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PayRate (inherited from EmployeesClass) |
PositionCode (inherited from EmployeesClass) |
PositionCodeID (inherited from EmployeesClass) |
Prefix (inherited from EmployeesClass) |
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
PurchaseLimit (inherited from EmployeesClass) |
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
ReferencesCheckedBy (inherited from EmployeesClass) |
ReferencesCheckedDate (inherited from EmployeesClass) |
ReferralType (inherited from EmployeesClass) |
ReferredBy (inherited from EmployeesClass) |
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
ResumeLink (inherited from EmployeesClass) |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SpouseName (inherited from EmployeesClass) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
Suffix (inherited from EmployeesClass) |
Supervisor (inherited from EmployeesClass) |
SupervisorID (inherited from EmployeesClass) |
SupervisorTitle (inherited from EmployeesClass) |
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
Title (inherited from EmployeesClass) |
USCitizen (inherited from EmployeesClass) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.
VisaType (inherited from EmployeesClass) |
WantsContract (inherited from EmployeesClass) |
WantsPermanent (inherited from EmployeesClass) |
WebPage (inherited from EmployeesClass) |
WhoCreated (inherited from EmployeesClass) |
WhoUpdated (inherited from EmployeesClass) |
Will1099 (inherited from EmployeesClass) |
WillContract (inherited from EmployeesClass) |
WillFTE (inherited from EmployeesClass) |
WillInc (inherited from EmployeesClass) |
WillW2 (inherited from EmployeesClass) |
WorkAddressID (inherited from EmployeesClass) |
WorkAddressIDObject (inherited from EmployeesClass) |
WorkAddressLine1 (inherited from EmployeesClass) |
WorkAddressLine2 (inherited from EmployeesClass) |
WorkAddressLine3 (inherited from EmployeesClass) |
WorkAddressLine4 (inherited from EmployeesClass) |
WorkAreaCode (inherited from EmployeesClass) |
WorkCity (inherited from EmployeesClass) |
WorkCountry (inherited from EmployeesClass) |
WorkCountryCode (inherited from EmployeesClass) |
WorkCounty (inherited from EmployeesClass) |
WorkExtension (inherited from EmployeesClass) |
WorkFax (inherited from EmployeesClass) |
WorkFaxAreaCode (inherited from EmployeesClass) |
WorkFaxCountryCode (inherited from EmployeesClass) |
WorkFaxID (inherited from EmployeesClass) |
WorkFaxIDObject (inherited from EmployeesClass) |
WorkPhone (inherited from EmployeesClass) |
WorkPhoneID (inherited from EmployeesClass) |
WorkPhoneIDObject (inherited from EmployeesClass) |
WorkState (inherited from EmployeesClass) |
WorkZipCode (inherited from EmployeesClass) |
XCon (inherited from EmployeesClass) |

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
CreateLinkedPerson | Creates a Person record that is prepopulated with information from the Employee. The Employee's Object is Saved after, the Employee's LinkedPersonID field is set to the Person Record's ID.
CreatePerson | Creates a Person record that is prepopulated with information from the Employee.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Employee_Skills (inherited from EmployeesClass) |
Employee_SkillsObject (inherited from EmployeesClass) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetNewLinkedPersonParamString |
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded. Saves the Employee Object.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue | Updates values in the DataField of the entity.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
GetEmployeeRelatedFieldNameFromPerson | Translates a Person field name in to an equivalent Employee field name. Currently, the fields requiring mapping from Person to Employee are: * AddressID to WorkAddressID * PhoneID to WorkPhoneID * FaxID to WorkFaxID
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

EmployeesEntity Class | Aptify.Framework.BusinessLogic.Entity.Employees Namespace


EmployeesEntity Constructor

Initializes a new instance of the EmployeesEntity class.

public EmployeesEntity();

See Also

EmployeesEntity Class | Aptify.Framework.BusinessLogic.Entity.Employees Namespace


EmployeesEntity Methods

The methods of the EmployeesEntity class are listed below. For a complete list of EmployeesEntity class members, see the EmployeesEntity Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
CreateLinkedPerson | Creates a Person record that is prepopulated with information from the Employee. The Employee's Object is Saved after, the Employee's LinkedPersonID field is set to the Person Record's ID.
CreatePerson | Creates a Person record that is prepopulated with information from the Employee.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Employee_Skills (inherited from EmployeesClass) |
Employee_SkillsObject (inherited from EmployeesClass) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetNewLinkedPersonParamString |
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded. Saves the Employee Object.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue | Updates values in the DataField of the entity.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
GetEmployeeRelatedFieldNameFromPerson | Translates a Person field name in to an equivalent Employee field name. Currently, the fields requiring mapping from Person to Employee are: * AddressID to WorkAddressID * PhoneID to WorkPhoneID * FaxID to WorkFaxID
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

EmployeesEntity Class | Aptify.Framework.BusinessLogic.Entity.Employees Namespace


EmployeesEntity.CreateLinkedPerson Method

Creates a Person record that is prepopulated with information from the Employee. The Employee's Object is Saved after, the Employee's LinkedPersonID field is set to the Person Record's ID.

public virtual AptifyGenericEntityBase CreateLinkedPerson();

Return Value

A saved, configured Persons Entity. If the RecordID of the GE is less than 1, then the person record was not saved properly and the LastUserError property should be checked.

Remarks

All updateable Person fields, whose name matches the name of an Employee field, will have its value set to the value of the Employee field, for which it corresponds.

See Also

EmployeesEntity Class | Aptify.Framework.BusinessLogic.Entity.Employees Namespace


EmployeesEntity.CreatePerson Method

Creates a Person record that is prepopulated with information from the Employee.

public virtual AptifyGenericEntityBase CreatePerson();

Return Value

A saved, configured Persons Entity. If the RecordID of the GE is less than 1, then the person record was not saved properly and the LastUserError property should be checked.

Remarks

All updateable Person fields, whose name matches the name of an Employee field, will have its value set to the value of the Employee field, for which it corresponds.

See Also

EmployeesEntity Class | Aptify.Framework.BusinessLogic.Entity.Employees Namespace


EmployeesEntity.GetEmployeeRelatedFieldNameFromPerson Method

Translates a Person field name in to an equivalent Employee field name. Currently, the fields requiring mapping from Person to Employee are: * AddressID to WorkAddressID * PhoneID to WorkPhoneID * FaxID to WorkFaxID

protected string GetEmployeeRelatedFieldNameFromPerson(
String sPersonField
);

Parameters

sPersonField
The person field name to be mapped.

Return Value

Equivalent employee field name.

Remarks

Currently, the fields requiring mapping from Person to Employee are: * AddressID to WorkAddressID * PhoneID to WorkPhoneID * FaxID to WorkFaxID Otherwise this function will return the Person field name passed.

See Also

EmployeesEntity Class | Aptify.Framework.BusinessLogic.Entity.Employees Namespace


EmployeesEntity.GetNewLinkedPersonParamString Method

public virtual string GetNewLinkedPersonParamString();

See Also

EmployeesEntity Class | Aptify.Framework.BusinessLogic.Entity.Employees Namespace


Save Method

Aptify 5.0 Software Development Kit (SDK)

EmployeesEntity.Save Method

Saves the Employee Object.

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Save();

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean,ref String&);

Saves the Employee Object.

public override bool Save(Boolean,ref String&,String);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(ref String&);

See Also

EmployeesEntity Class | Aptify.Framework.BusinessLogic.Entity.Employees Namespace


EmployeesEntity.Save Method (Boolean, String&, String)

Saves the Employee Object.

public override bool Save(
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

Parameters

AllowGUI
ErrorString
TransactionID

Return Value

Remarks

See Also

EmployeesEntity Class | Aptify.Framework.BusinessLogic.Entity.Employees Namespace | EmployeesEntity.Save Overload List


EmployeesEntity.SetValue Method

Updates values in the DataField of the entity.

public override void SetValue(
String FieldName,
Object Value
);

Parameters

FieldName
Value

Remarks

Adds specific logic to flow down the work address when the organization is changed.

See Also

EmployeesEntity Class | Aptify.Framework.BusinessLogic.Entity.Employees Namespace


EmployeesFormLayout Class

Contains custom logic that deals with controls on the Top Area Layout

For a list of all members of this type, see EmployeesFormLayout Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
EmployeesFormLayout

public class EmployeesFormLayout : FormTemplateLayout

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.Entity.Employees

Assembly: AptifyEmployeesGUI (in AptifyEmployeesGUI.dll)

See Also

EmployeesFormLayout Members | Aptify.Framework.BusinessLogic.Entity.Employees Namespace


EmployeesFormLayout Members

EmployeesFormLayout overview

Public Instance Constructors

EmployeesFormLayout Constructor Initializes a new instance of the EmployeesFormLayout class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded | Contains logic to setup Event handlers for controls on the FormTemplate Layout.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

EmployeesFormLayout Class | Aptify.Framework.BusinessLogic.Entity.Employees Namespace


EmployeesFormLayout Constructor

Initializes a new instance of the EmployeesFormLayout class.

public EmployeesFormLayout();

See Also

EmployeesFormLayout Class | Aptify.Framework.BusinessLogic.Entity.Employees Namespace


EmployeesFormLayout Methods

The methods of the EmployeesFormLayout class are listed below. For a complete list of EmployeesFormLayout class members, see the EmployeesFormLayout Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded | Contains logic to setup Event handlers for controls on the FormTemplate Layout.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

EmployeesFormLayout Class | Aptify.Framework.BusinessLogic.Entity.Employees Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

EmployeesFormLayout.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

EmployeesFormLayout Class | Aptify.Framework.BusinessLogic.Entity.Employees Namespace


EmployeesFormLayout.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

EmployeesFormLayout Class | Aptify.Framework.BusinessLogic.Entity.Employees Namespace | EmployeesFormLayout.Dispose Overload List


EmployeesFormLayout.OnFormTemplateLoaded Method

Contains logic to setup Event handlers for controls on the FormTemplate Layout.

protected override void OnFormTemplateLoaded(
FormTemplateLayout.FormTemplateLoadedEventArgs e
);

Parameters

e

Remarks

See Also

EmployeesFormLayout Class | Aptify.Framework.BusinessLogic.Entity.Employees Namespace


Aptify.Framework.BusinessLogic.Entity.EntitySubTables

Aptify 5.0 Software Development Kit (SDK)

Aptify.Framework.BusinessLogic.Entity.EntitySubTables Namespace

This namespace corresponds to the component that provides the visual interface for assigning an entity's sub-tables to SQL Filegroups.

Namespace hierarchy

Classes

Class | Description
EntitySubTablesFormLayout | Contains custom logic that deals with enabling/disabling the drop down list of the Text/Image FileGroup on EntitySubTables form (subtype form).


EntitySubTablesFormLayout Class

Contains custom logic that deals with enabling/disabling the drop down list of the Text/Image FileGroup on EntitySubTables form (subtype form).

For a list of all members of this type, see EntitySubTablesFormLayout Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
FormComponent
FormTemplateLayout
EntitySubTablesFormLayout

public class EntitySubTablesFormLayout : FormTemplateLayout

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.Entity.EntitySubTables

Assembly: AptifyEntitySubTablesGUI (in AptifyEntitySubTablesGUI.dll)

See Also

EntitySubTablesFormLayout Members | Aptify.Framework.BusinessLogic.Entity.EntitySubTables Namespace


EntitySubTablesFormLayout Members

EntitySubTablesFormLayout overview

Public Instance Constructors

EntitySubTablesFormLayout Constructor Initializes a new instance of the EntitySubTablesFormLayout class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
ApplicationObject (inherited from FormComponent) |
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainerText (inherited from FormComponent) |
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataAction (inherited from FormComponent) |
DataBindings (inherited from Control) | Gets the data bindings for the control.
DefaultFormTemplateLoadedArgs (inherited from FormTemplateLayout) |
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateID (inherited from FormTemplateLayout) | This property returns the currently loaded Form Template ID
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
IgnoreFormTemplateContextGEChangedEvent (inherited from FormTemplateLayout) | This property can be used to set the GE Changed Event Handler to False for the Form Template Context Object. The purpose of the event handler in the FormTemplateContext object is to allow consumers of the Form Template Context to know when the GE changes. However, in some cases, it is desirable for the control not to use its default processing logic (reconfiguring itself) when that happens.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode (inherited from FormTemplateLayout) |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecievesFormTemplateLoadedEvent (inherited from FormTemplateLayout) | Detemines if the Form Template Layout. will recieve the Form Template Loaded event.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormComponentClick (inherited from FormComponent) |
FormComponentDoubleClick (inherited from FormComponent) |
FormComponentGotFocus (inherited from FormComponent) |
FormComponentLostFocus (inherited from FormComponent) |
FormTemplateLoaded (inherited from FormTemplateLayout) | Raised After a Form template is loaded.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from FormComponent) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
Control (inherited from FormComponent) |
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
FormTemplateComponents (inherited from FormTemplateLayout) |
FormTemplateContext (inherited from FormTemplateLayout) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded | Contains logic to setup Event handlers for controls on the FormTemplate Layout.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

EntitySubTablesFormLayout Class | Aptify.Framework.BusinessLogic.Entity.EntitySubTables Namespace


EntitySubTablesFormLayout Constructor

Initializes a new instance of the EntitySubTablesFormLayout class.

public EntitySubTablesFormLayout();

See Also

EntitySubTablesFormLayout Class | Aptify.Framework.BusinessLogic.Entity.EntitySubTables Namespace


EntitySubTablesFormLayout Methods

The methods of the EntitySubTablesFormLayout class are listed below. For a complete list of EntitySubTablesFormLayout class members, see the EntitySubTablesFormLayout Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ChildTemplateLoaded (inherited from FormTemplateLayout) | Called by a Child Form Template to inform the Parent Layout Control that it has loaded.
Clear (inherited from FormTemplateLayout) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DeleteComponents (inherited from FormTemplateLayout) |
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
NotifyPartChanged (inherited from FormTemplateLayout) | Overloaded. This method handles notification to the form template layout that a part within it has changed. This results in the part being refreshed in place. The primary use for this method is for the form template designer functionality. This overload allows for adjusting the ResizeWidth and ResizeHeight parameters dynamically as well.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseClick (inherited from FormComponent) |
RaiseDoubleClick (inherited from FormComponent) |
RaiseGotFocus (inherited from FormComponent) |
RaiseLostFocus (inherited from FormComponent) |
RaiseValueChanged (inherited from FormComponent) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from FormTemplateLayout) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
SwitchToRunTimeWithoutSaving (inherited from FormTemplateLayout) |
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetFormComponent (inherited from FormTemplateLayout) | Recursively finds the first instance of a control that has a specific name.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
MergeFormContextProperties (inherited from FormComponent) |
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnConfigureApplicationObject (inherited from FormComponent) |
OnConfigureDataAction (inherited from FormComponent) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormComponentConfig (inherited from FormTemplateLayout) |
OnFormTemplateLoaded | Contains logic to setup Event handlers for controls on the FormTemplate Layout.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnHide (inherited from FormTemplateLayout) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRefresh (inherited from FormTemplateLayout) |
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShow (inherited from FormTemplateLayout) | Overloaded.
OnShow (inherited from FormComponent) | Overloaded.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTransferDataToObject (inherited from FormTemplateLayout) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshChildren (inherited from FormComponent) | Calls refresh for all of the children in the Control tree.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

EntitySubTablesFormLayout Class | Aptify.Framework.BusinessLogic.Entity.EntitySubTables Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

EntitySubTablesFormLayout.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

EntitySubTablesFormLayout Class | Aptify.Framework.BusinessLogic.Entity.EntitySubTables Namespace


EntitySubTablesFormLayout.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

EntitySubTablesFormLayout Class | Aptify.Framework.BusinessLogic.Entity.EntitySubTables Namespace | EntitySubTablesFormLayout.Dispose Overload List


EntitySubTablesFormLayout.OnFormTemplateLoaded Method

Contains logic to setup Event handlers for controls on the FormTemplate Layout.

protected override void OnFormTemplateLoaded(
FormTemplateLayout.FormTemplateLoadedEventArgs e
);

Parameters

e

Remarks

See Also

EntitySubTablesFormLayout Class | Aptify.Framework.BusinessLogic.Entity.EntitySubTables Namespace


Aptify.Framework.BusinessLogic.Entity.Exceptions

Aptify 5.0 Software Development Kit (SDK)

Aptify.Framework.BusinessLogic.Entity.Exceptions Namespace

This namespace contains the functionality that handles the possible exceptions related to the Entity object.

Namespace hierarchy

Classes

Class | Description
EntityObjectException |
SequenceFieldNotFoundException |
UserIDNotFoundException |


EntityObjectException Class

For a list of all members of this type, see EntityObjectException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
EntityObjectException
SequenceFieldNotFoundException
UserIDNotFoundException

public class EntityObjectException : BaseApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.Entity.Exceptions

Assembly: AptifyEntityInterfaces (in AptifyEntityInterfaces.dll)

See Also

EntityObjectException Members | Aptify.Framework.BusinessLogic.Entity.Exceptions Namespace


EntityObjectException Members

EntityObjectException overview

Public Instance Constructors

EntityObjectException Overloaded. Initializes a new instance of the EntityObjectException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message |
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EntityObjectException Class | Aptify.Framework.BusinessLogic.Entity.Exceptions Namespace


EntityObjectException Constructor

Overload List

public EntityObjectException(SerializationInfo,StreamingContext);

public EntityObjectException(String);

See Also

EntityObjectException Class | Aptify.Framework.BusinessLogic.Entity.Exceptions Namespace


EntityObjectException Constructor (String)

public EntityObjectException(
String Message
);

See Also

EntityObjectException Class | Aptify.Framework.BusinessLogic.Entity.Exceptions Namespace | EntityObjectException Constructor Overload List


EntityObjectException Constructor (SerializationInfo, StreamingContext)

public EntityObjectException(
SerializationInfo Info,
StreamingContext Context
);

See Also

EntityObjectException Class | Aptify.Framework.BusinessLogic.Entity.Exceptions Namespace | EntityObjectException Constructor Overload List


EntityObjectException Properties

The properties of the EntityObjectException class are listed below. For a complete list of EntityObjectException class members, see the EntityObjectException Members topic.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message |
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

See Also

EntityObjectException Class | Aptify.Framework.BusinessLogic.Entity.Exceptions Namespace


Message Property

Aptify 5.0 Software Development Kit (SDK)

EntityObjectException.Message Property

public override String Message {get;}

See Also

EntityObjectException Class | Aptify.Framework.BusinessLogic.Entity.Exceptions Namespace


EntityObjectException Methods

The methods of the EntityObjectException class are listed below. For a complete list of EntityObjectException class members, see the EntityObjectException Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EntityObjectException Class | Aptify.Framework.BusinessLogic.Entity.Exceptions Namespace


EntityObjectException.GetObjectData Method

public override void GetObjectData(
SerializationInfo Info,
StreamingContext Context
);

Implements

ISerializable.

See Also

EntityObjectException Class | Aptify.Framework.BusinessLogic.Entity.Exceptions Namespace


SequenceFieldNotFoundException Class

For a list of all members of this type, see SequenceFieldNotFoundException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
EntityObjectException
SequenceFieldNotFoundException

public class SequenceFieldNotFoundException : EntityObjectException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.Entity.Exceptions

Assembly: AptifyEntityInterfaces (in AptifyEntityInterfaces.dll)

See Also

SequenceFieldNotFoundException Members | Aptify.Framework.BusinessLogic.Entity.Exceptions Namespace


SequenceFieldNotFoundException Members

SequenceFieldNotFoundException overview

Public Instance Constructors

SequenceFieldNotFoundException Overloaded. Initializes a new instance of the SequenceFieldNotFoundException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from EntityObjectException) |
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SequenceFieldNotFoundException Class | Aptify.Framework.BusinessLogic.Entity.Exceptions Namespace


SequenceFieldNotFoundException Constructor

Initializes a new instance of the SequenceFieldNotFoundException class.

Overload List

Initializes a new instance of the SequenceFieldNotFoundException class.

public SequenceFieldNotFoundException();

public SequenceFieldNotFoundException(SerializationInfo,StreamingContext);

public SequenceFieldNotFoundException(String);

See Also

SequenceFieldNotFoundException Class | Aptify.Framework.BusinessLogic.Entity.Exceptions Namespace


SequenceFieldNotFoundException Constructor ()

Initializes a new instance of the SequenceFieldNotFoundException class.

public SequenceFieldNotFoundException();

See Also

SequenceFieldNotFoundException Class | Aptify.Framework.BusinessLogic.Entity.Exceptions Namespace | SequenceFieldNotFoundException Constructor Overload List


SequenceFieldNotFoundException Constructor (String)

public SequenceFieldNotFoundException(
String Message
);

See Also

SequenceFieldNotFoundException Class | Aptify.Framework.BusinessLogic.Entity.Exceptions Namespace | SequenceFieldNotFoundException Constructor Overload List


SequenceFieldNotFoundException Constructor (SerializationInfo, StreamingContext)

public SequenceFieldNotFoundException(
SerializationInfo Info,
StreamingContext Context
);

See Also

SequenceFieldNotFoundException Class | Aptify.Framework.BusinessLogic.Entity.Exceptions Namespace | SequenceFieldNotFoundException Constructor Overload List


SequenceFieldNotFoundException Methods

The methods of the SequenceFieldNotFoundException class are listed below. For a complete list of SequenceFieldNotFoundException class members, see the SequenceFieldNotFoundException Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SequenceFieldNotFoundException Class | Aptify.Framework.BusinessLogic.Entity.Exceptions Namespace


SequenceFieldNotFoundException.GetObjectData Method

public override void GetObjectData(
SerializationInfo Info,
StreamingContext Context
);

Implements

ISerializable.

See Also

SequenceFieldNotFoundException Class | Aptify.Framework.BusinessLogic.Entity.Exceptions Namespace


UserIDNotFoundException Class

For a list of all members of this type, see UserIDNotFoundException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
EntityObjectException
UserIDNotFoundException

public class UserIDNotFoundException : EntityObjectException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.Entity.Exceptions

Assembly: AptifyEntityInterfaces (in AptifyEntityInterfaces.dll)

See Also

UserIDNotFoundException Members | Aptify.Framework.BusinessLogic.Entity.Exceptions Namespace


UserIDNotFoundException Members

UserIDNotFoundException overview

Public Instance Constructors

UserIDNotFoundException Overloaded. Initializes a new instance of the UserIDNotFoundException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message |
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
UserID |
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UserIDNotFoundException Class | Aptify.Framework.BusinessLogic.Entity.Exceptions Namespace


UserIDNotFoundException Constructor

Initializes a new instance of the UserIDNotFoundException class.

Overload List

Initializes a new instance of the UserIDNotFoundException class.

public UserIDNotFoundException();

public UserIDNotFoundException(SerializationInfo,StreamingContext);

public UserIDNotFoundException(String);

public UserIDNotFoundException(String,String);

See Also

UserIDNotFoundException Class | Aptify.Framework.BusinessLogic.Entity.Exceptions Namespace


UserIDNotFoundException Constructor ()

Initializes a new instance of the UserIDNotFoundException class.

public UserIDNotFoundException();

See Also

UserIDNotFoundException Class | Aptify.Framework.BusinessLogic.Entity.Exceptions Namespace | UserIDNotFoundException Constructor Overload List


UserIDNotFoundException Constructor (String)

public UserIDNotFoundException(
String Message
);

See Also

UserIDNotFoundException Class | Aptify.Framework.BusinessLogic.Entity.Exceptions Namespace | UserIDNotFoundException Constructor Overload List


UserIDNotFoundException Constructor (String, String)

public UserIDNotFoundException(
String Message,
String UserId
);

See Also

UserIDNotFoundException Class | Aptify.Framework.BusinessLogic.Entity.Exceptions Namespace | UserIDNotFoundException Constructor Overload List


UserIDNotFoundException Constructor (SerializationInfo, StreamingContext)

public UserIDNotFoundException(
SerializationInfo Info,
StreamingContext Context
);

See Also

UserIDNotFoundException Class | Aptify.Framework.BusinessLogic.Entity.Exceptions Namespace | UserIDNotFoundException Constructor Overload List


UserIDNotFoundException Properties

The properties of the UserIDNotFoundException class are listed below. For a complete list of UserIDNotFoundException class members, see the UserIDNotFoundException Members topic.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message |
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
UserID |
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

See Also

UserIDNotFoundException Class | Aptify.Framework.BusinessLogic.Entity.Exceptions Namespace


Message Property

Aptify 5.0 Software Development Kit (SDK)

UserIDNotFoundException.Message Property

public override String Message {get;}

See Also

UserIDNotFoundException Class | Aptify.Framework.BusinessLogic.Entity.Exceptions Namespace


UserID Property

Aptify 5.0 Software Development Kit (SDK)

UserIDNotFoundException.UserID Property

public String UserID {get; set;}

See Also

UserIDNotFoundException Class | Aptify.Framework.BusinessLogic.Entity.Exceptions Namespace


UserIDNotFoundException Methods

The methods of the UserIDNotFoundException class are listed below. For a complete list of UserIDNotFoundException class members, see the UserIDNotFoundException Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UserIDNotFoundException Class | Aptify.Framework.BusinessLogic.Entity.Exceptions Namespace


UserIDNotFoundException.GetObjectData Method

public override void GetObjectData(
SerializationInfo Info,
StreamingContext Context
);

Implements

ISerializable.

See Also

UserIDNotFoundException Class | Aptify.Framework.BusinessLogic.Entity.Exceptions Namespace


Aptify.Framework.BusinessLogic.FilterRules

Aptify 5.0 Software Development Kit (SDK)

Aptify.Framework.BusinessLogic.FilterRules Namespace

The objects in this namespace correspond to Aptify's generic Filter Rules functionality. Product pricing logic is one area of the system that can utilize the Filter Rules functionality.

Namespace hierarchy

Classes

Class | Description
FilterRule | This class provides utility functionality related to reviewing and managing Filter Rules. In addition,
FilterRule.RuleExecutionResult | This class is used internally within the FilterRuleEvaluator to keep track of the results of execution of rules and their items
FilterRuleCache | The FilterRuleCache is designed to be a shared resource to improve performance since Filter Rules generally are not going to change and can therefore be cached to improve speed of execution since the data structure required to evaluate Filter Rules doesn't need to be reloaded from either a DataTable or from the database.
FilterRuleEntityInstance | This class is used to provide run-time information for Filter Rule Evaluation for the required data to be used in evaluating a Filter Rule.
FilterRuleEvaluator | This class is the engine that evaluates a filter rule based on a set of provided inputs. This class is inheritable and has several overridable methods available for modifying the underlying logic for filter rule evaluation. The standard logic in the Filter Rule Evaluator will utilize the Logic String in the Filter Rule coupled with all of the individual Filter Rule Items that exist in the Filter Rule meta-data (Filter Rules entity in Aptify) and determine if the Filter Rule is True or False based on the provided inputs.
FilterRuleItem |
FilterRulesControl | Filter Rules Control provides a user interface control that can be used for displaying Filter Rules on any form using an embedded link. The assumption in this control is that it is provided a Data Field, like any bound control, and that data field is an embedded link foreign key to the Filter Rules entity. In addition to being used to display information as an embedded resource within an Entity that links to Filter Rules, this control can be used on a form template for Filter Rules directly as well.
FilterRulesEntity |
LogicStringParser | This class handles the lexical analysis for parsing tokens for Logic Strings The possible tokens that can exist within a Logic String are defined by the ParseToken enumerated type within this class. Call the GetToken() method on this class to utilize this functionality.

Enumerations

Enumeration | Description
FilterRule.BoolOperator |
FilterRule.EvalResult |
FilterRulesControl.ControlMode | This enumerated type tracks the two different methods of use for this control, to be used directly on a form template displaying Filter Rules or to be used to display an EMBEDDED Filter Rule on another Form Template.
LogicStringParser.ParseToken |


FilterRule Class

This class provides utility functionality related to reviewing and managing Filter Rules. In addition,

For a list of all members of this type, see FilterRule Members.

System.Object
FilterRule

public class FilterRule

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.FilterRules

Assembly: FilterRules (in FilterRules.dll)

See Also

FilterRule Members | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRule Members

FilterRule overview

Public Instance Constructors

FilterRule Overloaded. Initializes a new instance of the FilterRule class.

Public Instance Properties

Description |
ID |
Items | This method returns a collection of Filter Rule Items that represent the FilterRuleItems sub-type for the loaded Filter Rule ID
LogicString |
LogicStringGenerated |
Name |
UsedEntityInstances | This property returns a list of Entity Instances that are actually being used in the currently loaded Filter Rule, out of those that are available for the Filter Rule Type. This allows calling objects to optimize which Entity Instance data elements are loaded up and passed into this object for evaluation. Only those Entity Instance data elements that are actually used in the Rule must be present.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Evaluate | This method handles the process of evaluating a filter rule and returning the result of the filter rule evaluation. In the event that the filter rule fails to evaluate, an exception will be thrown by this method that should be caught by the caller. This method evaluates the LogicString to determine how to combine the filters and combine their values. EvaluateFilter() is called for each individual filter that is part of the logic string, but only called once even if the filter is used multiple times within the logic string. Additionally, if an Item exists within the Filter Rule that is NOT used within the logic string, it will never be evaluated with the EvaluateFilter() method.
EvaluateFilter | This method is called once for each unique use of a Filter Rule Item within the logic string of a Filter Rule. The method is responsible for determining if the Filter Rule is True or False based on the Entity Instance data provided.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Load | Loads up the Filter Rule specified by the Filter Rule ID.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

Results This property provides a collection that has results that are cached during a single evaluation process. This cache is cleared out each time Evaluate() is called before the process of evaluating filter expressions actually occurs.

Protected Instance Methods

EvaluateDateTimeFilter | This method is called from EvaluateFilter() for Date/Time field types and is responsible for handling the filter tests for Date/Time data types only.
EvaluateExpression | This method is used to evaluate expressions which have the capability to have any level of nested sub-expressions which are evaluated via recursive calls to this method. An example of an expression that would be evaluated by this method is: 1 AND (2 OR 3) AND (5 OR (6 AND 7)) The numeric values represent the item numbers of the Filter and the nested/parenthesis represent operator precedence used in evaluating the expression. In the event that parenthesis are not used, the expression is evaluated from left to right with the leftmost operators being evaluated first. For example, in the below expression the AND operator is evaluated first. 1 AND 2 OR 3 This method calls HandleToken() and UpdateRunningResult() in that order inside a loop until either TOKEN_EOF or TOKEN_CLOSE_PAREN is found(in sub-expression/recursive cases).
EvaluateNumericFilter | This method is called from EvaluateFilter() for numeric(int, numeric, currency, etc) field types and is responsible for handling the filter tests for numeric data types only.
EvaluateTextFilter | This method is called from EvaluateFilter() for Text(char,nchar,varchar,text, etc.) field types and is responsible for handling the filter tests for text data types only.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetEntityInstance | This method returns an EntityInstance from a collection by the name of the instance.
HandleToken | This method is responsible for processing a single token from the Scanner(lex analyzer) object and determines how to handle that token in the context of evaluating an expression. In the event that the token represents an Identifer (for a Filter Rule Item), that Rule Item is evaluated and the Running Result for the expression is updated.
LoadItems | This method is responsible for loading up the Items collection within the Filter Rule class instance.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
UpdateRunningResult | This method is responsible for updating the running result for the expression evaluation and is passed the current result that was found from the HandleToken method. In some cases, CurrentResult is Null when HandleToken hit a token such as a Left Parenthesis, or an operator. This method updates the NextOperator to Op_None in the event that Current Result is NOT null and returns the new RunningResult value in the Return value.

See Also

FilterRule Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRule Constructor

Overload List

public FilterRule(AptifyApplication,DataAction);

public FilterRule(Int64,AptifyApplication,DataAction);

public FilterRule(Int64,Boolean,AptifyApplication,DataAction);

See Also

FilterRule Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRule Constructor (Int64, Boolean, AptifyApplication, DataAction)

public FilterRule(
Int64 FilterRuleID,
Boolean RefreshCache,
AptifyApplication Application,
DataAction DataAction
);

See Also

FilterRule Class | Aptify.Framework.BusinessLogic.FilterRules Namespace | FilterRule Constructor Overload List


FilterRule Constructor (Int64, AptifyApplication, DataAction)

public FilterRule(
Int64 FilterRuleID,
AptifyApplication Application,
DataAction DataAction
);

See Also

FilterRule Class | Aptify.Framework.BusinessLogic.FilterRules Namespace | FilterRule Constructor Overload List


FilterRule Constructor (AptifyApplication, DataAction)

public FilterRule(
AptifyApplication Application,
DataAction DataAction
);

See Also

FilterRule Class | Aptify.Framework.BusinessLogic.FilterRules Namespace | FilterRule Constructor Overload List


FilterRule Properties

The properties of the FilterRule class are listed below. For a complete list of FilterRule class members, see the FilterRule Members topic.

Public Instance Properties

Description |
ID |
Items | This method returns a collection of Filter Rule Items that represent the FilterRuleItems sub-type for the loaded Filter Rule ID
LogicString |
LogicStringGenerated |
Name |
UsedEntityInstances | This property returns a list of Entity Instances that are actually being used in the currently loaded Filter Rule, out of those that are available for the Filter Rule Type. This allows calling objects to optimize which Entity Instance data elements are loaded up and passed into this object for evaluation. Only those Entity Instance data elements that are actually used in the Rule must be present.

Protected Instance Properties

Results This property provides a collection that has results that are cached during a single evaluation process. This cache is cleared out each time Evaluate() is called before the process of evaluating filter expressions actually occurs.

See Also

FilterRule Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


Description Property

Aptify 5.0 Software Development Kit (SDK)

FilterRule.Description Property

public virtual String Description {get;}

See Also

FilterRule Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

FilterRule.ID Property

public virtual Int64 ID {get;}

See Also

FilterRule Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


Items Property

Aptify 5.0 Software Development Kit (SDK)

FilterRule.Items Property

This method returns a collection of Filter Rule Items that represent the FilterRuleItems sub-type for the loaded Filter Rule ID

public virtual List<T> Items {get;}

Property Value

Remarks

See Also

FilterRule Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


LogicString Property

Aptify 5.0 Software Development Kit (SDK)

FilterRule.LogicString Property

public virtual String LogicString {get;}

See Also

FilterRule Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


LogicStringGenerated Property

Aptify 5.0 Software Development Kit (SDK)

FilterRule.LogicStringGenerated Property

public virtual Boolean LogicStringGenerated {get;}

See Also

FilterRule Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


Name Property

Aptify 5.0 Software Development Kit (SDK)

FilterRule.Name Property

public virtual String Name {get;}

See Also

FilterRule Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


Results Property

Aptify 5.0 Software Development Kit (SDK)

FilterRule.Results Property

This property provides a collection that has results that are cached during a single evaluation process. This cache is cleared out each time Evaluate() is called before the process of evaluating filter expressions actually occurs.

protected virtual Dictionary<TKey,TValue> Results {get;}

Property Value

Remarks

See Also

FilterRule Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


UsedEntityInstances Property

Aptify 5.0 Software Development Kit (SDK)

FilterRule.UsedEntityInstances Property

This property returns a list of Entity Instances that are actually being used in the currently loaded Filter Rule, out of those that are available for the Filter Rule Type. This allows calling objects to optimize which Entity Instance data elements are loaded up and passed into this object for evaluation. Only those Entity Instance data elements that are actually used in the Rule must be present.

public virtual List<T> UsedEntityInstances {get;}

Property Value

Remarks

See Also

FilterRule Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRule Methods

The methods of the FilterRule class are listed below. For a complete list of FilterRule class members, see the FilterRule Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Evaluate | This method handles the process of evaluating a filter rule and returning the result of the filter rule evaluation. In the event that the filter rule fails to evaluate, an exception will be thrown by this method that should be caught by the caller. This method evaluates the LogicString to determine how to combine the filters and combine their values. EvaluateFilter() is called for each individual filter that is part of the logic string, but only called once even if the filter is used multiple times within the logic string. Additionally, if an Item exists within the Filter Rule that is NOT used within the logic string, it will never be evaluated with the EvaluateFilter() method.
EvaluateFilter | This method is called once for each unique use of a Filter Rule Item within the logic string of a Filter Rule. The method is responsible for determining if the Filter Rule is True or False based on the Entity Instance data provided.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Load | Loads up the Filter Rule specified by the Filter Rule ID.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

EvaluateDateTimeFilter | This method is called from EvaluateFilter() for Date/Time field types and is responsible for handling the filter tests for Date/Time data types only.
EvaluateExpression | This method is used to evaluate expressions which have the capability to have any level of nested sub-expressions which are evaluated via recursive calls to this method. An example of an expression that would be evaluated by this method is: 1 AND (2 OR 3) AND (5 OR (6 AND 7)) The numeric values represent the item numbers of the Filter and the nested/parenthesis represent operator precedence used in evaluating the expression. In the event that parenthesis are not used, the expression is evaluated from left to right with the leftmost operators being evaluated first. For example, in the below expression the AND operator is evaluated first. 1 AND 2 OR 3 This method calls HandleToken() and UpdateRunningResult() in that order inside a loop until either TOKEN_EOF or TOKEN_CLOSE_PAREN is found(in sub-expression/recursive cases).
EvaluateNumericFilter | This method is called from EvaluateFilter() for numeric(int, numeric, currency, etc) field types and is responsible for handling the filter tests for numeric data types only.
EvaluateTextFilter | This method is called from EvaluateFilter() for Text(char,nchar,varchar,text, etc.) field types and is responsible for handling the filter tests for text data types only.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetEntityInstance | This method returns an EntityInstance from a collection by the name of the instance.
HandleToken | This method is responsible for processing a single token from the Scanner(lex analyzer) object and determines how to handle that token in the context of evaluating an expression. In the event that the token represents an Identifer (for a Filter Rule Item), that Rule Item is evaluated and the Running Result for the expression is updated.
LoadItems | This method is responsible for loading up the Items collection within the Filter Rule class instance.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
UpdateRunningResult | This method is responsible for updating the running result for the expression evaluation and is passed the current result that was found from the HandleToken method. In some cases, CurrentResult is Null when HandleToken hit a token such as a Left Parenthesis, or an operator. This method updates the NextOperator to Op_None in the event that Current Result is NOT null and returns the new RunningResult value in the Return value.

See Also

FilterRule Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRule.Evaluate Method

This method handles the process of evaluating a filter rule and returning the result of the filter rule evaluation. In the event that the filter rule fails to evaluate, an exception will be thrown by this method that should be caught by the caller. This method evaluates the LogicString to determine how to combine the filters and combine their values. EvaluateFilter() is called for each individual filter that is part of the logic string, but only called once even if the filter is used multiple times within the logic string. Additionally, if an Item exists within the Filter Rule that is NOT used within the logic string, it will never be evaluated with the EvaluateFilter() method.

public virtual bool Evaluate(
List<T> EntityInstances
);

Parameters

EntityInstances
Instance data for each entity instance that is used by the filter rule to evaluate

Return Value

Remarks

See Also

FilterRule Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRule.EvaluateDateTimeFilter Method

This method is called from EvaluateFilter() for Date/Time field types and is responsible for handling the filter tests for Date/Time data types only.

protected virtual bool EvaluateDateTimeFilter(
FilterRuleItem Item,
FilterRuleEntityInstance EntityInstance
);

Parameters

Item
EntityInstance

Return Value

Remarks

See Also

FilterRule Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRule.EvaluateExpression Method

This method is used to evaluate expressions which have the capability to have any level of nested sub-expressions which are evaluated via recursive calls to this method. An example of an expression that would be evaluated by this method is: 1 AND (2 OR 3) AND (5 OR (6 AND 7)) The numeric values represent the item numbers of the Filter and the nested/parenthesis represent operator precedence used in evaluating the expression. In the event that parenthesis are not used, the expression is evaluated from left to right with the leftmost operators being evaluated first. For example, in the below expression the AND operator is evaluated first. 1 AND 2 OR 3 This method calls HandleToken() and UpdateRunningResult() in that order inside a loop until either TOKEN_EOF or TOKEN_CLOSE_PAREN is found(in sub-expression/recursive cases).

protected bool EvaluateExpression(
LogicStringParser Scanner,
List<T> EntityInstances
);

Parameters

Scanner
EntityInstances

Return Value

Remarks

See Also

FilterRule Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRule.EvaluateFilter Method

This method is called once for each unique use of a Filter Rule Item within the logic string of a Filter Rule. The method is responsible for determining if the Filter Rule is True or False based on the Entity Instance data provided.

public virtual bool EvaluateFilter(
FilterRuleItem Item,
FilterRuleEntityInstance EntityInstance
);

Parameters

Item
EntityInstance

Return Value

Remarks

See Also

FilterRule Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRule.EvaluateNumericFilter Method

This method is called from EvaluateFilter() for numeric(int, numeric, currency, etc) field types and is responsible for handling the filter tests for numeric data types only.

protected virtual bool EvaluateNumericFilter(
FilterRuleItem Item,
FilterRuleEntityInstance EntityInstance
);

Parameters

Item
EntityInstance

Return Value

Remarks

See Also

FilterRule Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRule.EvaluateTextFilter Method

This method is called from EvaluateFilter() for Text(char,nchar,varchar,text, etc.) field types and is responsible for handling the filter tests for text data types only.

protected virtual bool EvaluateTextFilter(
FilterRuleItem Item,
FilterRuleEntityInstance EntityInstance
);

Parameters

Item
EntityInstance

Return Value

Remarks

See Also

FilterRule Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRule.GetEntityInstance Method

This method returns an EntityInstance from a collection by the name of the instance.

protected FilterRuleEntityInstance GetEntityInstance(
String EntityInstanceName,
List<T> EntityInstances
);

Parameters

EntityInstanceName
EntityInstances

Return Value

Remarks

See Also

FilterRule Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRule.HandleToken Method

This method is responsible for processing a single token from the Scanner(lex analyzer) object and determines how to handle that token in the context of evaluating an expression. In the event that the token represents an Identifer (for a Filter Rule Item), that Rule Item is evaluated and the Running Result for the expression is updated.

protected virtual EvalResult HandleToken(
LogicStringParser Scanner,
ref BoolOperator& NextOperator,
List<T> EntityInstances,
ref ParseToken& Token,
ref String& TokenText
);

Parameters

Scanner
NextOperator
EntityInstances
Token
TokenText

Return Value

Remarks

See Also

FilterRule Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRule.Load Method

Loads up the Filter Rule specified by the Filter Rule ID.

public virtual void Load(
Int64 FilterRuleID,
Boolean RefreshCache
);

Parameters

FilterRuleID
RefreshCache

Remarks

See Also

FilterRule Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRule.LoadItems Method

This method is responsible for loading up the Items collection within the Filter Rule class instance.

protected virtual void LoadItems(
Boolean RefreshCache
);

Parameters

RefreshCache
If set to True, Data cache is refreshed, otherwise cache is used to load the Filter Rule Items

Remarks

See Also

FilterRule Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRule.UpdateRunningResult Method

This method is responsible for updating the running result for the expression evaluation and is passed the current result that was found from the HandleToken method. In some cases, CurrentResult is Null when HandleToken hit a token such as a Left Parenthesis, or an operator. This method updates the NextOperator to Op_None in the event that Current Result is NOT null and returns the new RunningResult value in the Return value.

protected virtual EvalResult UpdateRunningResult(
FilterRule.EvalResult CurrentResult,
FilterRule.EvalResult RunningResult,
ref BoolOperator& NextOperator,
String TokenText
);

Parameters

CurrentResult
RunningResult
NextOperator
TokenText

Return Value

Remarks

See Also

FilterRule Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRule.BoolOperator Enumeration

protected enum FilterRule.BoolOperator

Members

Member Name | Description
Op_None |
Op_And |
Op_Or |

Requirements

Namespace: Aptify.Framework.BusinessLogic.FilterRules

Assembly: FilterRules (in FilterRules.dll)

See Also

Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRule.EvalResult Enumeration

protected enum FilterRule.EvalResult

Members

Member Name | Description
Eval_Null |
Eval_True |
Eval_False |

Requirements

Namespace: Aptify.Framework.BusinessLogic.FilterRules

Assembly: FilterRules (in FilterRules.dll)

See Also

Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRule.RuleExecutionResult Class

This class is used internally within the FilterRuleEvaluator to keep track of the results of execution of rules and their items

For a list of all members of this type, see FilterRule.RuleExecutionResult Members.

System.Object
FilterRule.RuleExecutionResult

protected class FilterRule.RuleExecutionResult

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.FilterRules

Assembly: FilterRules (in FilterRules.dll)

See Also

FilterRule.RuleExecutionResult Members | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRule.RuleExecutionResult Members

FilterRule.RuleExecutionResult overview

Public Instance Constructors

FilterRule.RuleExecutionResult Constructor Initializes a new instance of the FilterRule.RuleExecutionResult class.

Public Instance Fields

Result
RuleItem

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FilterRule.RuleExecutionResult Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRule.RuleExecutionResult Constructor

Initializes a new instance of the FilterRule.RuleExecutionResult class.

public FilterRule.RuleExecutionResult();

See Also

FilterRule.RuleExecutionResult Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRule.RuleExecutionResult Fields

The fields of the FilterRule.RuleExecutionResult class are listed below. For a complete list of FilterRule.RuleExecutionResult class members, see the FilterRule.RuleExecutionResult Members topic.

Public Instance Fields

Result
RuleItem

See Also

FilterRule.RuleExecutionResult Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRule.RuleExecutionResult.Result Field

public Result Result;

See Also

FilterRule.RuleExecutionResult Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRule.RuleExecutionResult.RuleItem Field

public RuleItem RuleItem;

See Also

FilterRule.RuleExecutionResult Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRuleCache Class

The FilterRuleCache is designed to be a shared resource to improve performance since Filter Rules generally are not going to change and can therefore be cached to improve speed of execution since the data structure required to evaluate Filter Rules doesn't need to be reloaded from either a DataTable or from the database.

For a list of all members of this type, see FilterRuleCache Members.

System.Object
FilterRuleCache

public class FilterRuleCache

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.FilterRules

Assembly: FilterRules (in FilterRules.dll)

See Also

FilterRuleCache Members | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRuleCache Members

FilterRuleCache overview

Public Static Methods

ClearCache | Clears the Filter Rule Cache
Config | This method must be called from within the process before the cache is first used
Exists | Determines if a filter rule exists in the cache or not
GetFilterRule | Returns a Filter Rule for the specified Filter Rule ID. If the filter rule has not previously been loaded then it is automatically loaded and added to the cache as well.

Public Instance Constructors

FilterRuleCache Constructor Initializes a new instance of the FilterRuleCache class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FilterRuleCache Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRuleCache Constructor

Initializes a new instance of the FilterRuleCache class.

public FilterRuleCache();

See Also

FilterRuleCache Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRuleCache Methods

The methods of the FilterRuleCache class are listed below. For a complete list of FilterRuleCache class members, see the FilterRuleCache Members topic.

Public Static Methods

ClearCache | Clears the Filter Rule Cache
Config | This method must be called from within the process before the cache is first used
Exists | Determines if a filter rule exists in the cache or not
GetFilterRule | Returns a Filter Rule for the specified Filter Rule ID. If the filter rule has not previously been loaded then it is automatically loaded and added to the cache as well.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FilterRuleCache Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRuleCache.ClearCache Method

Clears the Filter Rule Cache

public static void ClearCache();

Remarks

See Also

FilterRuleCache Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRuleCache.Config Method

This method must be called from within the process before the cache is first used

public static void Config(
AptifyApplication Application,
DataAction DataAction
);

Parameters

Application
DataAction

Remarks

See Also

FilterRuleCache Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRuleCache.Exists Method

Determines if a filter rule exists in the cache or not

public static bool Exists(
Int64 FilterRuleID
);

Parameters

FilterRuleID

Return Value

Remarks

See Also

FilterRuleCache Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRuleCache.GetFilterRule Method

Returns a Filter Rule for the specified Filter Rule ID. If the filter rule has not previously been loaded then it is automatically loaded and added to the cache as well.

public static FilterRule GetFilterRule(
Int64 FilterRuleID,
Boolean RefreshCache
);

Parameters

FilterRuleID
RefreshCache

Return Value

Remarks

See Also

FilterRuleCache Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRuleEntityInstance Class

This class is used to provide run-time information for Filter Rule Evaluation for the required data to be used in evaluating a Filter Rule.

For a list of all members of this type, see FilterRuleEntityInstance Members.

System.Object
FilterRuleEntityInstance

public class FilterRuleEntityInstance

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.FilterRules

Assembly: FilterRules (in FilterRules.dll)

See Also

FilterRuleEntityInstance Members | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRuleEntityInstance Members

FilterRuleEntityInstance overview

Public Instance Constructors

FilterRuleEntityInstance Constructor Initializes a new instance of the FilterRuleEntityInstance class.

Public Instance Fields

InstanceData | Instance Data is the run-time instance information that is used by the Filter Rule evaluator when evaluating the rules. The instance data is assumed to contain all of the required fields from the specified entity that are used in the Filter Rule being executed.
Name | The name of the Entity Instance

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FilterRuleEntityInstance Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRuleEntityInstance Constructor

Initializes a new instance of the FilterRuleEntityInstance class.

public FilterRuleEntityInstance();

See Also

FilterRuleEntityInstance Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRuleEntityInstance Fields

The fields of the FilterRuleEntityInstance class are listed below. For a complete list of FilterRuleEntityInstance class members, see the FilterRuleEntityInstance Members topic.

Public Instance Fields

InstanceData | Instance Data is the run-time instance information that is used by the Filter Rule evaluator when evaluating the rules. The instance data is assumed to contain all of the required fields from the specified entity that are used in the Filter Rule being executed.
Name | The name of the Entity Instance

See Also

FilterRuleEntityInstance Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRuleEntityInstance.InstanceData Field

Instance Data is the run-time instance information that is used by the Filter Rule evaluator when evaluating the rules. The instance data is assumed to contain all of the required fields from the specified entity that are used in the Filter Rule being executed.

public InstanceData InstanceData;

Remarks

See Also

FilterRuleEntityInstance Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRuleEntityInstance.Name Field

The name of the Entity Instance

public Name Name;

Remarks

See Also

FilterRuleEntityInstance Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRuleEvaluator Class

This class is the engine that evaluates a filter rule based on a set of provided inputs. This class is inheritable and has several overridable methods available for modifying the underlying logic for filter rule evaluation. The standard logic in the Filter Rule Evaluator will utilize the Logic String in the Filter Rule coupled with all of the individual Filter Rule Items that exist in the Filter Rule meta-data (Filter Rules entity in Aptify) and determine if the Filter Rule is True or False based on the provided inputs.

For a list of all members of this type, see FilterRuleEvaluator Members.

System.Object
FilterRuleEvaluator

public class FilterRuleEvaluator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.FilterRules

Assembly: FilterRules (in FilterRules.dll)

See Also

FilterRuleEvaluator Members | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRuleEvaluator Members

FilterRuleEvaluator overview

Public Instance Constructors

FilterRuleEvaluator Constructor Initializes a new instance of the FilterRuleEvaluator class.

Public Instance Methods

Config | This method must be called before any other member of the class is accessed
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
EvaluateFilterRule | This method handles the process of evaluating a filter rule and returning the result of the filter rule evaluation. In the event that the filter rule fails to evaluate, an exception will be thrown by this method that should be caught by the caller. This method uses the FilterRuleCache to load up a filter rule and then calls the Evaluate() method on the FilterRule class.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

Application | Returns an instance of AptifyApplication which can be used as required by sub-classes
DataAction | Returns an instance of the DataAction class to be used by sub-classes as required

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FilterRuleEvaluator Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRuleEvaluator Constructor

Initializes a new instance of the FilterRuleEvaluator class.

public FilterRuleEvaluator();

See Also

FilterRuleEvaluator Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRuleEvaluator Properties

The properties of the FilterRuleEvaluator class are listed below. For a complete list of FilterRuleEvaluator class members, see the FilterRuleEvaluator Members topic.

Protected Instance Properties

Application | Returns an instance of AptifyApplication which can be used as required by sub-classes
DataAction | Returns an instance of the DataAction class to be used by sub-classes as required

See Also

FilterRuleEvaluator Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


Application Property

Aptify 5.0 Software Development Kit (SDK)

FilterRuleEvaluator.Application Property

Returns an instance of AptifyApplication which can be used as required by sub-classes

protected virtual AptifyApplication Application {get;}

Property Value

Remarks

See Also

FilterRuleEvaluator Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


DataAction Property

Aptify 5.0 Software Development Kit (SDK)

FilterRuleEvaluator.DataAction Property

Returns an instance of the DataAction class to be used by sub-classes as required

protected virtual DataAction DataAction {get;}

Property Value

Remarks

See Also

FilterRuleEvaluator Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRuleEvaluator Methods

The methods of the FilterRuleEvaluator class are listed below. For a complete list of FilterRuleEvaluator class members, see the FilterRuleEvaluator Members topic.

Public Instance Methods

Config | This method must be called before any other member of the class is accessed
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
EvaluateFilterRule | This method handles the process of evaluating a filter rule and returning the result of the filter rule evaluation. In the event that the filter rule fails to evaluate, an exception will be thrown by this method that should be caught by the caller. This method uses the FilterRuleCache to load up a filter rule and then calls the Evaluate() method on the FilterRule class.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FilterRuleEvaluator Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRuleEvaluator.Config Method

This method must be called before any other member of the class is accessed

public virtual void Config(
AptifyApplication Application
);

Parameters

Application

Remarks

See Also

FilterRuleEvaluator Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRuleEvaluator.EvaluateFilterRule Method

This method handles the process of evaluating a filter rule and returning the result of the filter rule evaluation. In the event that the filter rule fails to evaluate, an exception will be thrown by this method that should be caught by the caller. This method uses the FilterRuleCache to load up a filter rule and then calls the Evaluate() method on the FilterRule class.

public virtual bool EvaluateFilterRule(
Int64 FilterRuleID,
List<T> EntityInstances,
Boolean RefreshCache
);

Parameters

FilterRuleID
Filter Rule Record ID Number from the Filter Rules Entity in Aptify
EntityInstances
List of Filter Rule Entity Instances Objects - this provides the data required for evaluating the specified filter rule
RefreshCache

Return Value

Remarks

See Also

FilterRuleEvaluator Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRuleItem Class

For a list of all members of this type, see FilterRuleItem Members.

System.Object
FilterRuleItem

public class FilterRuleItem

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.FilterRules

Assembly: FilterRules (in FilterRules.dll)

See Also

FilterRuleItem Members | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRuleItem Members

FilterRuleItem overview

Public Instance Constructors

FilterRuleItem Constructor Initializes a new instance of the FilterRuleItem class.

Public Instance Fields

Entity | The Aptify Entity Name for the EntityInstanceName
EntityInstanceName |
Field |
ItemNumber |
OperatorID |
OperatorName |
Value |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FilterRuleItem Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRuleItem Constructor

Initializes a new instance of the FilterRuleItem class.

public FilterRuleItem();

See Also

FilterRuleItem Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRuleItem Fields

The fields of the FilterRuleItem class are listed below. For a complete list of FilterRuleItem class members, see the FilterRuleItem Members topic.

Public Instance Fields

Entity | The Aptify Entity Name for the EntityInstanceName
EntityInstanceName |
Field |
ItemNumber |
OperatorID |
OperatorName |
Value |

See Also

FilterRuleItem Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRuleItem.Entity Field

The Aptify Entity Name for the EntityInstanceName

public Entity Entity;

Remarks

See Also

FilterRuleItem Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRuleItem.EntityInstanceName Field

public EntityInstanceName EntityInstanceName;

See Also

FilterRuleItem Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRuleItem.Field Field

public Field Field;

See Also

FilterRuleItem Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRuleItem.ItemNumber Field

public ItemNumber ItemNumber;

See Also

FilterRuleItem Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRuleItem.OperatorID Field

public OperatorID OperatorID;

See Also

FilterRuleItem Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRuleItem.OperatorName Field

public OperatorName OperatorName;

See Also

FilterRuleItem Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRuleItem.Value Field

public Value Value;

See Also

FilterRuleItem Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRulesControl Class

Filter Rules Control provides a user interface control that can be used for displaying Filter Rules on any form using an embedded link. The assumption in this control is that it is provided a Data Field, like any bound control, and that data field is an embedded link foreign key to the Filter Rules entity. In addition to being used to display information as an embedded resource within an Entity that links to Filter Rules, this control can be used on a form template for Filter Rules directly as well.

For a list of all members of this type, see FilterRulesControl Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
AptifyControlBase
AptifyDataFieldControlBase
FilterRulesControl

public class FilterRulesControl : AptifyDataFieldControlBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.FilterRules

Assembly: FilterRulesUI (in FilterRulesUI.dll)

See Also

FilterRulesControl Members | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRulesControl Members

FilterRulesControl overview

Public Instance Constructors

FilterRulesControl Constructor Initializes a new instance of the FilterRulesControl class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Control (inherited from AptifyControlBase) |
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
CurrentControlMode |
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DataControl (inherited from AptifyControlBase) | Adds a reference to the object for the data control. In the case of it being added, the reference to the bound control base object is added to the data controls collection.
DataField (inherited from AptifyDataFieldControlBase) | This is the field in the GE to whose value read/write operations are applied.
DataSource (inherited from AptifyDataFieldControlBase) |
DisableGeDataTransfer (inherited from AptifyControlBase) | If true, the implementer is required to move the value to/from the bound control to the GE or other data access method.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
FieldHelp (inherited from AptifyControlBase) |
FilterRuleGE | This method returns the FilterRulesGE which can come from one of two places. If the CurrentControlMode= Embedded, then this comes from the embedded GE object for the current data field. If the CurrentControlMode= FilterRulesEntity then this is the GE directly from the Form Template Context.
FilterRuleTypeID | This property represents the Filter Rule Type for the current filter rule
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from AptifyDataFieldControlBase) | The font for the internal control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateContext (inherited from AptifyControlBase) | Returns the reference that if is local that is returned else if a DataControl exists, it is returned.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpObject (inherited from AptifyDataFieldControlBase) | This member is overriden in this class to provide field-level help if available
HelpURL (inherited from AptifyDataFieldControlBase) | This member is overriden in this class to provide field-level help if available
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LabelFont (inherited from AptifyDataFieldControlBase) | The font of the label.
LabelRequiredFont (inherited from AptifyDataFieldControlBase) |
LabelSize (inherited from AptifyDataFieldControlBase) | Size of the label.
LabelText (inherited from AptifyDataFieldControlBase) |
LabelTextAlign (inherited from AptifyDataFieldControlBase) |
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
ObjectRepository (inherited from AptifyControlBase) |
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Required (inherited from AptifyDataFieldControlBase) |
RequiredFieldBackColor (inherited from AptifyDataFieldControlBase) |
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ShowLabel (inherited from AptifyDataFieldControlBase) |
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
Value (inherited from AptifyDataFieldControlBase) | Sets a value for the current data field
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BoundControlConfig |
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ClearData (inherited from AptifyDataFieldControlBase) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DisplayControlHelp (inherited from AptifyControlBase) | This method will display control-level help information. This method will use the HelpTitle and HelpText overridable members to display the Field Help object from Aptify.Framework.WindowsControls.FieldHelp. If the title and text is desired to be overriden it is not necessary to override this method, rather override the HelpTitle and HelpText properties which are used by this method.
DisplayEntityHelp (inherited from AptifyControlBase) | This method is responsible for displaying the help file to the user and will attempt to provide context sensitive help based on the particular entity being displayed. If no entity-specific help file is available for the user then the standard Aptify Shell.Aptify Help file will be used to display help to the user. Override this method in sub-classes to change the method for displaying help.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetDefaultHelpObject (inherited from AptifyControlBase) | This method returns the default help object file in the Aptify Object repository to be used in the event that no entity-specific file exists
GetEntityFieldSpecificHelpObject (inherited from AptifyDataFieldControlBase) | This method returns the Aptify Object Repository Object location for the help file that is specific to this entity field.
GetEntityFieldSpecificHelpTopicURL (inherited from AptifyDataFieldControlBase) | This method returns the Topic URL location within the help file that is specific to this entity field.
GetEntitySpecificHelpObject (inherited from AptifyControlBase) | This method returns the Aptify Object Repository Object location for the help file that is specific to this entity.
GetEntitySpecificHelpTopicURL (inherited from AptifyControlBase) | This method returns the Topic URL location within the help file that is specific to this entity.
GetFilterRuleTypeID | This method finds the corresponding Record ID for a Filter Rule Type record that matches the provided Name for the Filter Rule. Returns the ID of the matching record, if found, otherwise returns -1.
GetGeneratedLogicString | This method is responsible for generating and returning a default logic string to use for the current Filter Rule. The base class by default generates a string that combines the filters together with AND statements. For example, if there were 3 filters in place in a Filter Rule, the method would combine them together as "1 AND 2 AND 3". To change the default logic for this method sub-class the FilterRulesControl and then override this method.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LoadFilterRule | This method is responsible for loading up the control with the information for the specified Filter Rule.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseValueChanged (inherited from AptifyControlBase) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from AptifyDataFieldControlBase) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetUserCredential (inherited from AptifyControlBase) |
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
TransferDataToObject |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AfterDisplayEntityHelp (inherited from AptifyControlBase) | This event is fired after the help file is displayed.
AptifyControlBaseTextChanged (inherited from AptifyControlBase) |
AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BeforeDisplayEntityHelp (inherited from AptifyControlBase) | This event is fired before the help file is displayed. To prevent help from being displayed set the Cancel parameter to True.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from AptifyControlBase) |
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from AptifyControlBase) |
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from AptifyControlBase) |
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from AptifyControlBase) |
KeyPress (inherited from AptifyControlBase) |
KeyUp (inherited from AptifyControlBase) |
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from AptifyControlBase) |
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from AptifyControlBase) |
MouseEnter (inherited from AptifyControlBase) |
MouseHover (inherited from AptifyControlBase) |
MouseLeave (inherited from AptifyControlBase) |
MouseMove (inherited from AptifyControlBase) |
MouseUp (inherited from AptifyControlBase) |
MouseWheel (inherited from AptifyControlBase) |
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from AptifyControlBase) |
Validated (inherited from AptifyControlBase) |
Validating (inherited from AptifyControlBase) |
ValueChanged (inherited from AptifyControlBase) |
VisibleChanged (inherited from AptifyControlBase) |

Protected Instance Fields

m_bEdit (inherited from AptifyDataFieldControlBase)
m_bNewTypedValue (inherited from AptifyDataFieldControlBase)
m_bPreConfig (inherited from AptifyDataFieldControlBase)
m_bRead (inherited from AptifyDataFieldControlBase)
m_bRequired (inherited from AptifyDataFieldControlBase)
m_iDataControl (inherited from AptifyControlBase)
m_oAptifyApplication (inherited from AptifyControlBase)
m_oDeleteList
m_oFormTemplateContext (inherited from AptifyControlBase)
m_oUserCredential (inherited from AptifyControlBase)
m_sDataField (inherited from AptifyDataFieldControlBase)

Protected Instance Properties

AptifyApplication (inherited from AptifyControlBase) | Returns an instance of the Aptify Application Object
AptifyMessage (inherited from AptifyDataFieldControlBase) |
AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
CurrencyTypeCache (inherited from AptifyControlBase) |
DataAction | Returns an instance of the DataAction class
Database | Returns the name of the database used for the Filter Rules entity
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DisplayName (inherited from AptifyControlBase) |
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
EntityFieldDataTableCache | This property is used to cache data tables that contain the entity fields that are displayed within the Field drop down so they don't need to be reloaded
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
ExtendedType (inherited from AptifyDataFieldControlBase) |
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HelpText (inherited from AptifyControlBase) |
HelpTitle (inherited from AptifyDataFieldControlBase) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
IconCache | This is used to cache icons that are loaded for each display service so that they do not need to be reloaded for display each time the entity instance drop down is loaded.
ImeModeBase (inherited from Control) |
InternalControl (inherited from AptifyControlBase) | Specifies the Main Control of interest in a composite control.
Label (inherited from AptifyDataFieldControlBase) |
m_oInternalControl (inherited from AptifyControlBase) |
MyApplication (inherited from AptifyControlBase) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowDisplayHelpHyperlink (inherited from AptifyControlBase) | This property can be overriden by sub-classes to be able to selectively turn on or off the Display Help hyperlink that appears by default on the FieldHelp object.
UserCredential (inherited from AptifyControlBase) |
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
ApplySkin |
AptifyControlBaseValueChangedHandler (inherited from AptifyDataFieldControlBase) |
ConfigHelp (inherited from AptifyDataFieldControlBase) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
CreateMessageObjects (inherited from AptifyDataFieldControlBase) |
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
DoFormComponentConfig (inherited from AptifyDataFieldControlBase) |
DoFormComponentConfigRunMode (inherited from AptifyDataFieldControlBase) |
DoPostal_Leave (inherited from AptifyDataFieldControlBase) |
Finalize (inherited from AptifyControlBase) |
FormComponentConfig (inherited from AptifyControlBase) |
FormComponentHide (inherited from AptifyControlBase) |
FormComponentShow | Overloaded.
FormComponentShow (inherited from AptifyControlBase) | Overloaded.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetIcon | This method is responsible for returning an image from the Aptify Object Repository. The image is loaded from file and is returned as a System.Drawing.Bitmap unless it is not found in which case Nothing is returned.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
LoadEntityInstances | This method is called from LoadFilterRule as well as any time that the FilterRuleTypeID property is changed in order to load up the list of Entity Instances that are available for the Filter Rule Type ID.
LoadFields | This method is called before the Field column is selected in the grid in order to populate the list of fields that are shown for a selected entity instance.
LoadFilterRuleData | This method is responsible for loading up the filter rules from the Filter Rule Items sub-type into the control. This method is called from the LoadFilterRule() method after LoadEntityInstances() is called.
LoadOperators | This method is called before the Operator column is selected in the grid in order to populate the list of operators that are shown for a selected entity instance and selected field.
LookupPostalInfo (inherited from AptifyDataFieldControlBase) |
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnGridAfterRowsDeleted | This method is responsible for handling the AfterRowsDeleted event in the main grid control (grdMain)
OnGridBeforeCellActivate | This method is responsible for handling the BeforeCellActivative event in the grdMain object which represents the main grid within the Filter Rules Control.
OnGridBeforeRowsDeleted | This method is responsible for handling the BeforeRowsDeleted event in the main grid control. The default implementation of this method populates the m_oDeleteList List object with the objects that are being deleted, rather than deleting directly from the Items sub-type, since the user should be able to hit the cancel button when using this within a Sub-Type Dialog.
OnGridInitializeLayout | This method is responsible for handling the InitializeLayout event in the main grid control and sets up several initialization properties for the main grid control.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResetLogicStringClick | This method is responsible for responding to the button click for reseting the logic string and if desired, interacting with the user and asking if the logic string should be reset.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnUpdateLogicString | This method is responsible for handing the updates of the logic string. This method by default will check to see if the user has previously overriden the logic string and if so, no changes will be made. If the user has not previously overriden the logic string, then this will update the logic string.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RequiredGECheck (inherited from AptifyControlBase) |
RequiredPropertiesCheck (inherited from AptifyControlBase) |
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlMetaData (inherited from AptifyDataFieldControlBase) |
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetSecurity (inherited from AptifyDataFieldControlBase) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetupValueCell | This method is responsible for setting up the Value Cell for a given row and this method is called before a user activates a particular value cell.
SetValueFromGe (inherited from AptifyDataFieldControlBase) |
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Instance Events

PostConfig (inherited from AptifyDataFieldControlBase)
PreConfig (inherited from AptifyDataFieldControlBase)

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.
StopInitialization (inherited from AptifyDataFieldControlBase) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

FilterRulesControl Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRulesControl Constructor

Initializes a new instance of the FilterRulesControl class.

public FilterRulesControl();

See Also

FilterRulesControl Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRulesControl Fields

The fields of the FilterRulesControl class are listed below. For a complete list of FilterRulesControl class members, see the FilterRulesControl Members topic.

Protected Instance Fields

m_bEdit (inherited from AptifyDataFieldControlBase)
m_bNewTypedValue (inherited from AptifyDataFieldControlBase)
m_bPreConfig (inherited from AptifyDataFieldControlBase)
m_bRead (inherited from AptifyDataFieldControlBase)
m_bRequired (inherited from AptifyDataFieldControlBase)
m_iDataControl (inherited from AptifyControlBase)
m_oAptifyApplication (inherited from AptifyControlBase)
m_oDeleteList
m_oFormTemplateContext (inherited from AptifyControlBase)
m_oUserCredential (inherited from AptifyControlBase)
m_sDataField (inherited from AptifyDataFieldControlBase)

See Also

FilterRulesControl Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRulesControl.m_oDeleteList Field

protected m_oDeleteList m_oDeleteList;

See Also

FilterRulesControl Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRulesControl Properties

The properties of the FilterRulesControl class are listed below. For a complete list of FilterRulesControl class members, see the FilterRulesControl Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Control (inherited from AptifyControlBase) |
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
CurrentControlMode |
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DataControl (inherited from AptifyControlBase) | Adds a reference to the object for the data control. In the case of it being added, the reference to the bound control base object is added to the data controls collection.
DataField (inherited from AptifyDataFieldControlBase) | This is the field in the GE to whose value read/write operations are applied.
DataSource (inherited from AptifyDataFieldControlBase) |
DisableGeDataTransfer (inherited from AptifyControlBase) | If true, the implementer is required to move the value to/from the bound control to the GE or other data access method.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
FieldHelp (inherited from AptifyControlBase) |
FilterRuleGE | This method returns the FilterRulesGE which can come from one of two places. If the CurrentControlMode= Embedded, then this comes from the embedded GE object for the current data field. If the CurrentControlMode= FilterRulesEntity then this is the GE directly from the Form Template Context.
FilterRuleTypeID | This property represents the Filter Rule Type for the current filter rule
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from AptifyDataFieldControlBase) | The font for the internal control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormTemplateContext (inherited from AptifyControlBase) | Returns the reference that if is local that is returned else if a DataControl exists, it is returned.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpObject (inherited from AptifyDataFieldControlBase) | This member is overriden in this class to provide field-level help if available
HelpURL (inherited from AptifyDataFieldControlBase) | This member is overriden in this class to provide field-level help if available
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LabelFont (inherited from AptifyDataFieldControlBase) | The font of the label.
LabelRequiredFont (inherited from AptifyDataFieldControlBase) |
LabelSize (inherited from AptifyDataFieldControlBase) | Size of the label.
LabelText (inherited from AptifyDataFieldControlBase) |
LabelTextAlign (inherited from AptifyDataFieldControlBase) |
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
ObjectRepository (inherited from AptifyControlBase) |
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Required (inherited from AptifyDataFieldControlBase) |
RequiredFieldBackColor (inherited from AptifyDataFieldControlBase) |
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ShowLabel (inherited from AptifyDataFieldControlBase) |
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
Value (inherited from AptifyDataFieldControlBase) | Sets a value for the current data field
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AptifyApplication (inherited from AptifyControlBase) | Returns an instance of the Aptify Application Object
AptifyMessage (inherited from AptifyDataFieldControlBase) |
AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
CurrencyTypeCache (inherited from AptifyControlBase) |
DataAction | Returns an instance of the DataAction class
Database | Returns the name of the database used for the Filter Rules entity
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DisplayName (inherited from AptifyControlBase) |
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
EntityFieldDataTableCache | This property is used to cache data tables that contain the entity fields that are displayed within the Field drop down so they don't need to be reloaded
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
ExtendedType (inherited from AptifyDataFieldControlBase) |
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HelpText (inherited from AptifyControlBase) |
HelpTitle (inherited from AptifyDataFieldControlBase) |
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
IconCache | This is used to cache icons that are loaded for each display service so that they do not need to be reloaded for display each time the entity instance drop down is loaded.
ImeModeBase (inherited from Control) |
InternalControl (inherited from AptifyControlBase) | Specifies the Main Control of interest in a composite control.
Label (inherited from AptifyDataFieldControlBase) |
m_oInternalControl (inherited from AptifyControlBase) |
MyApplication (inherited from AptifyControlBase) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowDisplayHelpHyperlink (inherited from AptifyControlBase) | This property can be overriden by sub-classes to be able to selectively turn on or off the Display Help hyperlink that appears by default on the FieldHelp object.
UserCredential (inherited from AptifyControlBase) |
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.
StopInitialization (inherited from AptifyDataFieldControlBase) |

See Also

FilterRulesControl Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


CurrentControlMode Property

Aptify 5.0 Software Development Kit (SDK)

FilterRulesControl.CurrentControlMode Property

public FilterRulesControl.ControlMode CurrentControlMode {get;}

See Also

FilterRulesControl Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


DataAction Property

Aptify 5.0 Software Development Kit (SDK)

FilterRulesControl.DataAction Property

Returns an instance of the DataAction class

protected virtual DataAction DataAction {get;}

Property Value

Remarks

See Also

FilterRulesControl Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


Database Property

Aptify 5.0 Software Development Kit (SDK)

FilterRulesControl.Database Property

Returns the name of the database used for the Filter Rules entity

protected virtual String Database {get;}

Property Value

Remarks

See Also

FilterRulesControl Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


EntityFieldDataTableCache Property

Aptify 5.0 Software Development Kit (SDK)

FilterRulesControl.EntityFieldDataTableCache Property

This property is used to cache data tables that contain the entity fields that are displayed within the Field drop down so they don't need to be reloaded

protected virtual Dictionary<TKey,TValue> EntityFieldDataTableCache {get;}

Property Value

Remarks

See Also

FilterRulesControl Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRuleGE Property

Aptify 5.0 Software Development Kit (SDK)

FilterRulesControl.FilterRuleGE Property

This method returns the FilterRulesGE which can come from one of two places. If the CurrentControlMode= Embedded, then this comes from the embedded GE object for the current data field. If the CurrentControlMode= FilterRulesEntity then this is the GE directly from the Form Template Context.

public AptifyGenericEntityBase FilterRuleGE {get;}

Property Value

Remarks

See Also

FilterRulesControl Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRuleTypeID Property

Aptify 5.0 Software Development Kit (SDK)

FilterRulesControl.FilterRuleTypeID Property

This property represents the Filter Rule Type for the current filter rule

public Int64 FilterRuleTypeID {get; set;}

Property Value

Remarks

See Also

FilterRulesControl Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


IconCache Property

Aptify 5.0 Software Development Kit (SDK)

FilterRulesControl.IconCache Property

This is used to cache icons that are loaded for each display service so that they do not need to be reloaded for display each time the entity instance drop down is loaded.

protected virtual Dictionary<TKey,TValue> IconCache {get;}

Property Value

Remarks

See Also

FilterRulesControl Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


Text Property

Aptify 5.0 Software Development Kit (SDK)

FilterRulesControl.Text Property

public override String Text {get; set;}

See Also

FilterRulesControl Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRulesControl Methods

The methods of the FilterRulesControl class are listed below. For a complete list of FilterRulesControl class members, see the FilterRulesControl Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BoundControlConfig |
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ClearData (inherited from AptifyDataFieldControlBase) |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
DisplayControlHelp (inherited from AptifyControlBase) | This method will display control-level help information. This method will use the HelpTitle and HelpText overridable members to display the Field Help object from Aptify.Framework.WindowsControls.FieldHelp. If the title and text is desired to be overriden it is not necessary to override this method, rather override the HelpTitle and HelpText properties which are used by this method.
DisplayEntityHelp (inherited from AptifyControlBase) | This method is responsible for displaying the help file to the user and will attempt to provide context sensitive help based on the particular entity being displayed. If no entity-specific help file is available for the user then the standard Aptify Shell.Aptify Help file will be used to display help to the user. Override this method in sub-classes to change the method for displaying help.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetDefaultHelpObject (inherited from AptifyControlBase) | This method returns the default help object file in the Aptify Object repository to be used in the event that no entity-specific file exists
GetEntityFieldSpecificHelpObject (inherited from AptifyDataFieldControlBase) | This method returns the Aptify Object Repository Object location for the help file that is specific to this entity field.
GetEntityFieldSpecificHelpTopicURL (inherited from AptifyDataFieldControlBase) | This method returns the Topic URL location within the help file that is specific to this entity field.
GetEntitySpecificHelpObject (inherited from AptifyControlBase) | This method returns the Aptify Object Repository Object location for the help file that is specific to this entity.
GetEntitySpecificHelpTopicURL (inherited from AptifyControlBase) | This method returns the Topic URL location within the help file that is specific to this entity.
GetFilterRuleTypeID | This method finds the corresponding Record ID for a Filter Rule Type record that matches the provided Name for the Filter Rule. Returns the ID of the matching record, if found, otherwise returns -1.
GetGeneratedLogicString | This method is responsible for generating and returning a default logic string to use for the current Filter Rule. The base class by default generates a string that combines the filters together with AND statements. For example, if there were 3 filters in place in a Filter Rule, the method would combine them together as "1 AND 2 AND 3". To change the default logic for this method sub-class the FilterRulesControl and then override this method.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LoadFilterRule | This method is responsible for loading up the control with the information for the specified Filter Rule.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RaiseValueChanged (inherited from AptifyControlBase) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from AptifyDataFieldControlBase) |
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetUserCredential (inherited from AptifyControlBase) |
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
TransferDataToObject |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
ApplySkin |
AptifyControlBaseValueChangedHandler (inherited from AptifyDataFieldControlBase) |
ConfigHelp (inherited from AptifyDataFieldControlBase) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
CreateMessageObjects (inherited from AptifyDataFieldControlBase) |
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
DoFormComponentConfig (inherited from AptifyDataFieldControlBase) |
DoFormComponentConfigRunMode (inherited from AptifyDataFieldControlBase) |
DoPostal_Leave (inherited from AptifyDataFieldControlBase) |
Finalize (inherited from AptifyControlBase) |
FormComponentConfig (inherited from AptifyControlBase) |
FormComponentHide (inherited from AptifyControlBase) |
FormComponentShow | Overloaded.
FormComponentShow (inherited from AptifyControlBase) | Overloaded.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetIcon | This method is responsible for returning an image from the Aptify Object Repository. The image is loaded from file and is returned as a System.Drawing.Bitmap unless it is not found in which case Nothing is returned.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
LoadEntityInstances | This method is called from LoadFilterRule as well as any time that the FilterRuleTypeID property is changed in order to load up the list of Entity Instances that are available for the Filter Rule Type ID.
LoadFields | This method is called before the Field column is selected in the grid in order to populate the list of fields that are shown for a selected entity instance.
LoadFilterRuleData | This method is responsible for loading up the filter rules from the Filter Rule Items sub-type into the control. This method is called from the LoadFilterRule() method after LoadEntityInstances() is called.
LoadOperators | This method is called before the Operator column is selected in the grid in order to populate the list of operators that are shown for a selected entity instance and selected field.
LookupPostalInfo (inherited from AptifyDataFieldControlBase) |
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnGridAfterRowsDeleted | This method is responsible for handling the AfterRowsDeleted event in the main grid control (grdMain)
OnGridBeforeCellActivate | This method is responsible for handling the BeforeCellActivative event in the grdMain object which represents the main grid within the Filter Rules Control.
OnGridBeforeRowsDeleted | This method is responsible for handling the BeforeRowsDeleted event in the main grid control. The default implementation of this method populates the m_oDeleteList List object with the objects that are being deleted, rather than deleting directly from the Items sub-type, since the user should be able to hit the cancel button when using this within a Sub-Type Dialog.
OnGridInitializeLayout | This method is responsible for handling the InitializeLayout event in the main grid control and sets up several initialization properties for the main grid control.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResetLogicStringClick | This method is responsible for responding to the button click for reseting the logic string and if desired, interacting with the user and asking if the logic string should be reset.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnUpdateLogicString | This method is responsible for handing the updates of the logic string. This method by default will check to see if the user has previously overriden the logic string and if so, no changes will be made. If the user has not previously overriden the logic string, then this will update the logic string.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RequiredGECheck (inherited from AptifyControlBase) |
RequiredPropertiesCheck (inherited from AptifyControlBase) |
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetControlMetaData (inherited from AptifyDataFieldControlBase) |
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetSecurity (inherited from AptifyDataFieldControlBase) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetupValueCell | This method is responsible for setting up the Value Cell for a given row and this method is called before a user activates a particular value cell.
SetValueFromGe (inherited from AptifyDataFieldControlBase) |
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

FilterRulesControl Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRulesControl.ApplySkin Method

protected virtual void ApplySkin();

See Also

FilterRulesControl Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRulesControl.BoundControlConfig Method

public override void BoundControlConfig();

Implements

IAptifyControlBase.

See Also

FilterRulesControl Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

FilterRulesControl.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

FilterRulesControl Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRulesControl.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

FilterRulesControl Class | Aptify.Framework.BusinessLogic.FilterRules Namespace | FilterRulesControl.Dispose Overload List


FormComponentShow Method

Aptify 5.0 Software Development Kit (SDK)

FilterRulesControl.FormComponentShow Method

Overload List

Inherited from AptifyControlBase.

protected virtual void FormComponentShow();

protected override void FormComponentShow(Boolean);

See Also

FilterRulesControl Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRulesControl.FormComponentShow Method (Boolean)

protected override void FormComponentShow(
Boolean Refresh
);

Implements

IFormComponent.

See Also

FilterRulesControl Class | Aptify.Framework.BusinessLogic.FilterRules Namespace | FilterRulesControl.FormComponentShow Overload List


FilterRulesControl.GetFilterRuleTypeID Method

This method finds the corresponding Record ID for a Filter Rule Type record that matches the provided Name for the Filter Rule. Returns the ID of the matching record, if found, otherwise returns -1.

public virtual long GetFilterRuleTypeID(
String FilterRuleTypeName
);

Parameters

FilterRuleTypeName

Return Value

Remarks

See Also

FilterRulesControl Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRulesControl.GetGeneratedLogicString Method

This method is responsible for generating and returning a default logic string to use for the current Filter Rule. The base class by default generates a string that combines the filters together with AND statements. For example, if there were 3 filters in place in a Filter Rule, the method would combine them together as "1 AND 2 AND 3". To change the default logic for this method sub-class the FilterRulesControl and then override this method.

public virtual string GetGeneratedLogicString();

Return Value

Remarks

See Also

FilterRulesControl Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRulesControl.GetIcon Method

This method is responsible for returning an image from the Aptify Object Repository. The image is loaded from file and is returned as a System.Drawing.Bitmap unless it is not found in which case Nothing is returned.

protected Bitmap GetIcon(
String IconInRepository
);

Parameters

IconInRepository

Return Value

Remarks

See Also

FilterRulesControl Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRulesControl.LoadEntityInstances Method

This method is called from LoadFilterRule as well as any time that the FilterRuleTypeID property is changed in order to load up the list of Entity Instances that are available for the Filter Rule Type ID.

protected virtual void LoadEntityInstances(
Boolean RefreshCache
);

Remarks

See Also

FilterRulesControl Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRulesControl.LoadFields Method

This method is called before the Field column is selected in the grid in order to populate the list of fields that are shown for a selected entity instance.

protected virtual void LoadFields(
UltraGridRow Row,
Boolean RefreshCache
);

Parameters

Row
RefreshCache

Remarks

See Also

FilterRulesControl Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRulesControl.LoadFilterRule Method

This method is responsible for loading up the control with the information for the specified Filter Rule.

public virtual void LoadFilterRule();

Remarks

See Also

FilterRulesControl Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRulesControl.LoadFilterRuleData Method

This method is responsible for loading up the filter rules from the Filter Rule Items sub-type into the control. This method is called from the LoadFilterRule() method after LoadEntityInstances() is called.

protected virtual void LoadFilterRuleData();

Remarks

See Also

FilterRulesControl Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRulesControl.LoadOperators Method

This method is called before the Operator column is selected in the grid in order to populate the list of operators that are shown for a selected entity instance and selected field.

protected virtual void LoadOperators(
UltraGridRow Row,
Boolean RefreshCache
);

Parameters

Row
RefreshCache

Remarks

See Also

FilterRulesControl Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRulesControl.OnGridAfterRowsDeleted Method

This method is responsible for handling the AfterRowsDeleted event in the main grid control (grdMain)

protected virtual void OnGridAfterRowsDeleted(
Object sender,
EventArgs e
);

Parameters

sender
e

Remarks

See Also

FilterRulesControl Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRulesControl.OnGridBeforeCellActivate Method

This method is responsible for handling the BeforeCellActivative event in the grdMain object which represents the main grid within the Filter Rules Control.

protected virtual void OnGridBeforeCellActivate(
Object sender,
CancelableCellEventArgs e
);

Parameters

sender
e

Remarks

See Also

FilterRulesControl Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRulesControl.OnGridBeforeRowsDeleted Method

This method is responsible for handling the BeforeRowsDeleted event in the main grid control. The default implementation of this method populates the m_oDeleteList List object with the objects that are being deleted, rather than deleting directly from the Items sub-type, since the user should be able to hit the cancel button when using this within a Sub-Type Dialog.

protected virtual void OnGridBeforeRowsDeleted(
Object sender,
BeforeRowsDeletedEventArgs e
);

Parameters

sender
e

Remarks

See Also

FilterRulesControl Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRulesControl.OnGridInitializeLayout Method

This method is responsible for handling the InitializeLayout event in the main grid control and sets up several initialization properties for the main grid control.

protected virtual void OnGridInitializeLayout(
Object sender,
InitializeLayoutEventArgs e
);

Parameters

sender
e

Remarks

See Also

FilterRulesControl Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRulesControl.OnResetLogicStringClick Method

This method is responsible for responding to the button click for reseting the logic string and if desired, interacting with the user and asking if the logic string should be reset.

protected void OnResetLogicStringClick(
Object sender,
EventArgs e
);

Parameters

sender
e

Remarks

See Also

FilterRulesControl Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRulesControl.OnUpdateLogicString Method

This method is responsible for handing the updates of the logic string. This method by default will check to see if the user has previously overriden the logic string and if so, no changes will be made. If the user has not previously overriden the logic string, then this will update the logic string.

protected virtual void OnUpdateLogicString();

Remarks

See Also

FilterRulesControl Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRulesControl.SetupValueCell Method

This method is responsible for setting up the Value Cell for a given row and this method is called before a user activates a particular value cell.

protected virtual void SetupValueCell(
UltraGridRow Row
);

Parameters

Row

Remarks

See Also

FilterRulesControl Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRulesControl.TransferDataToObject Method

public override void TransferDataToObject(
ref Boolean& Cancel
);

Implements

IFormComponent.

See Also

FilterRulesControl Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRulesControl.ControlMode Enumeration

This enumerated type tracks the two different methods of use for this control, to be used directly on a form template displaying Filter Rules or to be used to display an EMBEDDED Filter Rule on another Form Template.

public enum FilterRulesControl.ControlMode

Remarks

Members

Member Name | Description
Embedded |
FilterRulesEntity |
GENotLoaded |

Requirements

Namespace: Aptify.Framework.BusinessLogic.FilterRules

Assembly: FilterRulesUI (in FilterRulesUI.dll)

See Also

Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRulesEntity Class

For a list of all members of this type, see FilterRulesEntity Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
FilterRulesEntity

public class FilterRulesEntity : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.FilterRules

Assembly: AptifyFilterRules (in AptifyFilterRules.dll)

See Also

FilterRulesEntity Members | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRulesEntity Members

FilterRulesEntity overview

Public Instance Constructors

FilterRulesEntity Constructor Initializes a new instance of the FilterRulesEntity class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty |
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded. This method overrides the base functionality to ensure that if the Filter Rule has no items, it is no longer a Filter Rule that will be stored in the system. New Filter Rules will not be saved and existing Filter Rules will be deleted.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

FilterRulesEntity Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRulesEntity Constructor

Initializes a new instance of the FilterRulesEntity class.

public FilterRulesEntity();

See Also

FilterRulesEntity Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRulesEntity Properties

The properties of the FilterRulesEntity class are listed below. For a complete list of FilterRulesEntity class members, see the FilterRulesEntity Members topic.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty |
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

FilterRulesEntity Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


IsDirty Property

Aptify 5.0 Software Development Kit (SDK)

FilterRulesEntity.IsDirty Property

public override Boolean IsDirty {get;}

See Also

FilterRulesEntity Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRulesEntity Methods

The methods of the FilterRulesEntity class are listed below. For a complete list of FilterRulesEntity class members, see the FilterRulesEntity Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded. This method overrides the base functionality to ensure that if the Filter Rule has no items, it is no longer a Filter Rule that will be stored in the system. New Filter Rules will not be saved and existing Filter Rules will be deleted.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

FilterRulesEntity Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


Save Method

Aptify 5.0 Software Development Kit (SDK)

FilterRulesEntity.Save Method

This method overrides the base functionality to ensure that if the Filter Rule has no items, it is no longer a Filter Rule that will be stored in the system. New Filter Rules will not be saved and existing Filter Rules will be deleted.

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Save();

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean,ref String&);

This method overrides the base functionality to ensure that if the Filter Rule has no items, it is no longer a Filter Rule that will be stored in the system. New Filter Rules will not be saved and existing Filter Rules will be deleted.

public override bool Save(Boolean,ref String&,String);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(ref String&);

See Also

FilterRulesEntity Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


FilterRulesEntity.Save Method (Boolean, String&, String)

This method overrides the base functionality to ensure that if the Filter Rule has no items, it is no longer a Filter Rule that will be stored in the system. New Filter Rules will not be saved and existing Filter Rules will be deleted.

public override bool Save(
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

Parameters

AllowGUI
ErrorString
TransactionID

Return Value

Remarks

See Also

FilterRulesEntity Class | Aptify.Framework.BusinessLogic.FilterRules Namespace | FilterRulesEntity.Save Overload List


LogicStringParser Class

This class handles the lexical analysis for parsing tokens for Logic Strings The possible tokens that can exist within a Logic String are defined by the ParseToken enumerated type within this class. Call the GetToken() method on this class to utilize this functionality.

For a list of all members of this type, see LogicStringParser Members.

System.Object
LogicStringParser

public class LogicStringParser

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.FilterRules

Assembly: FilterRules (in FilterRules.dll)

See Also

LogicStringParser Members | Aptify.Framework.BusinessLogic.FilterRules Namespace


LogicStringParser Members

LogicStringParser overview

Public Instance Constructors

LogicStringParser Constructor Initializes a new instance of the LogicStringParser class.

Public Instance Properties

TokenPosition | This property returns the current TokenPosition (which is an zero-based position offset into the TokenStream). The Token Position is automatically advanced when GetToken() is called.
TokenStream | This property must be set before other members of this class are accessed. When TokenStream is Set, the ResetTokenPosition() method is automatically called which sets the internal token position to the beginning of the TokenStream.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetToken | Set the TokenStream property before calling this method. This method can be called repeatedly until TOKEN_EOF is returned at which point the end of the token stream that was set has been reached.
GetType (inherited from Object) | Gets the Type of the current instance.
ResetTokenPosition | This method resets the internal token position if it is necessary to restart the process of retrieving tokens from the TokenStream
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
IsValidIdentifierCharacter | This method returns true if the character sent is a legal character within an identifier token. Valid Identifier characters are alphanumeric(A-Z, a-z, 0-9) and the underscore character.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LogicStringParser Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


LogicStringParser Constructor

Initializes a new instance of the LogicStringParser class.

public LogicStringParser();

See Also

LogicStringParser Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


LogicStringParser Properties

The properties of the LogicStringParser class are listed below. For a complete list of LogicStringParser class members, see the LogicStringParser Members topic.

Public Instance Properties

TokenPosition | This property returns the current TokenPosition (which is an zero-based position offset into the TokenStream). The Token Position is automatically advanced when GetToken() is called.
TokenStream | This property must be set before other members of this class are accessed. When TokenStream is Set, the ResetTokenPosition() method is automatically called which sets the internal token position to the beginning of the TokenStream.

See Also

LogicStringParser Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


TokenPosition Property

Aptify 5.0 Software Development Kit (SDK)

LogicStringParser.TokenPosition Property

This property returns the current TokenPosition (which is an zero-based position offset into the TokenStream). The Token Position is automatically advanced when GetToken() is called.

public virtual Int32 TokenPosition {get;}

Property Value

Remarks

See Also

LogicStringParser Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


TokenStream Property

Aptify 5.0 Software Development Kit (SDK)

LogicStringParser.TokenStream Property

This property must be set before other members of this class are accessed. When TokenStream is Set, the ResetTokenPosition() method is automatically called which sets the internal token position to the beginning of the TokenStream.

public virtual String TokenStream {get; set;}

Property Value

Remarks

See Also

LogicStringParser Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


LogicStringParser Methods

The methods of the LogicStringParser class are listed below. For a complete list of LogicStringParser class members, see the LogicStringParser Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetToken | Set the TokenStream property before calling this method. This method can be called repeatedly until TOKEN_EOF is returned at which point the end of the token stream that was set has been reached.
GetType (inherited from Object) | Gets the Type of the current instance.
ResetTokenPosition | This method resets the internal token position if it is necessary to restart the process of retrieving tokens from the TokenStream
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
IsValidIdentifierCharacter | This method returns true if the character sent is a legal character within an identifier token. Valid Identifier characters are alphanumeric(A-Z, a-z, 0-9) and the underscore character.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LogicStringParser Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


LogicStringParser.GetToken Method

Set the TokenStream property before calling this method. This method can be called repeatedly until TOKEN_EOF is returned at which point the end of the token stream that was set has been reached.

public virtual ParseToken GetToken(
ref String& TokenText
);

Parameters

TokenText
OUT Parameter: returns the text associated with the token that was returned

Return Value

Remarks

See Also

LogicStringParser Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


LogicStringParser.IsValidIdentifierCharacter Method

This method returns true if the character sent is a legal character within an identifier token. Valid Identifier characters are alphanumeric(A-Z, a-z, 0-9) and the underscore character.

protected virtual bool IsValidIdentifierCharacter(
String c
);

Parameters

c

Return Value

Remarks

See Also

LogicStringParser Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


LogicStringParser.ResetTokenPosition Method

This method resets the internal token position if it is necessary to restart the process of retrieving tokens from the TokenStream

public virtual void ResetTokenPosition();

Remarks

See Also

LogicStringParser Class | Aptify.Framework.BusinessLogic.FilterRules Namespace


LogicStringParser.ParseToken Enumeration

public enum LogicStringParser.ParseToken

Members

Member Name | Description
TOKEN_EOF |
TOKEN_OPEN_PAREN |
TOKEN_CLOSE_PAREN |
TOKEN_AND |
TOKEN_OR |
TOKEN_NOT |
TOKEN_IDENTIFIER |
TOKEN_LITERAL |

Requirements

Namespace: Aptify.Framework.BusinessLogic.FilterRules

Assembly: FilterRules (in FilterRules.dll)

See Also

Aptify.Framework.BusinessLogic.FilterRules Namespace


Aptify.Framework.BusinessLogic.FormTemplate

Aptify 5.0 Software Development Kit (SDK)

Aptify.Framework.BusinessLogic.FormTemplate Namespace

This namespace contains the Aptify Baseline Form Template Generator, which automatically creates and updates form templates for entities.

Namespace hierarchy

Classes

Class | Description
AptifyBaselineTemplateGenerator | This component is the standard implementation of the component and currently is called from the Entity Module. In the future, other components (perhaps a wizard) will also use this component. This object encapsulates all the logic needed to generate a basic template for an entity. The rules for how the template is generated is embedded within this object.

Structures

Structure | Description
AptifyBaselineTemplateGenerator.TemplateInfo | This struture contains information about a form template meta-data instance.


AptifyBaselineTemplateGenerator Class

This component is the standard implementation of the component and currently is called from the Entity Module. In the future, other components (perhaps a wizard) will also use this component. This object encapsulates all the logic needed to generate a basic template for an entity. The rules for how the template is generated is embedded within this object.

For a list of all members of this type, see AptifyBaselineTemplateGenerator Members.

System.Object
AptifyBaselineTemplateGenerator

public class AptifyBaselineTemplateGenerator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.FormTemplate

Assembly: AptifyBaselineTemplateGenerator (in AptifyBaselineTemplateGenerator.dll)

See Also

AptifyBaselineTemplateGenerator Members | Aptify.Framework.BusinessLogic.FormTemplate Namespace


AptifyBaselineTemplateGenerator Members

AptifyBaselineTemplateGenerator overview

Public Instance Constructors

AptifyBaselineTemplateGenerator Constructor

Public Instance Methods

ClearFormTemplatePartLinks | This method will remove all of the links from the provided Form Template object. In addition, for those Form Template Parts that are on this Form Template that are EXCLUSIVE to it, meaning they are not used by any other Form Template, they will be deleted. This method is exposed as a utility. Within the BaselineTemplateGenerator, this method is only called when a Form Template is generated.
CreateFormTemplate | This method will create a new generated form template for the specified entity object instance and return the FormTemplateID created through the FormTemplateID OUT parameter, if the method is succesful.
DeleteFormTemplate | This method will delete a form template and all of its associated parts and sub-templates.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindFormTemplate | This method will return a Form Template Record ID that matches the specified EntityID, Form Template Name, Usage Scope and Generated attribute, or return -1, if no such record is found. If more than one such record matches the provided criteria, the lowest ID value is returned.
FindFormTemplatePart | This method attempts to find a Form Template Part that matches the provided parameter information, and return the lowest matching record ID value if more than one such record exists. -1 is returned if no records match.
FormTemplatePartUsageCount | This method will calculate the total number of instances where a particular Form Template Part is being used. If provided, the ExcludeFormTemplateID parameter is used to exclude a specific Form Template from the count.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
GlobalTemplateExists | This method determines if a template exists in the Form Template meta-data for the given EntityID. The method returns the results through the FormTemplateInfo OUT parameter
IsFormTemplateTopLevel | This method determines if the specified form template is a top-level form template or not. Top level form templates are defined as form templates that are NOT in use anywhere as a sub-template.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateFormTemplate | This method is NOT currently implemented and is designed to update a form template in place for a given entity object. Instead of using this method, currently, it is expected that a form template that is generated will be deleted and re-created when necessary.

Protected Instance Methods

CreateSubTypePart | This method is responsible for creating a sub-type form template part for the specified sub-type.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FindCreateSubTypePart | This method is responsible for finding a sub-type form template part and if one doesn't exist, automatically creating a sub-type form template part for the specified sub-type.
FindSubTypePart | This method is responsible for finding an existing sub-type form template part record and returning it, if it exists. If no record is found, -1 is returned
GetSubTypePartName | This method is responsible for generating the sub-type form template part name to be used for the specified combination of a top level entity name and sub-type name. The default logic in the base class creates a string that has "TopLevelEntityName.Tabs.SubTypeName" as the string pattern. Override this method in a sub-class to alter the naming.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyBaselineTemplateGenerator Class | Aptify.Framework.BusinessLogic.FormTemplate Namespace


AptifyBaselineTemplateGenerator Constructor

public AptifyBaselineTemplateGenerator(
UserCredentials UserCredentials
);

See Also

AptifyBaselineTemplateGenerator Class | Aptify.Framework.BusinessLogic.FormTemplate Namespace


AptifyBaselineTemplateGenerator Methods

The methods of the AptifyBaselineTemplateGenerator class are listed below. For a complete list of AptifyBaselineTemplateGenerator class members, see the AptifyBaselineTemplateGenerator Members topic.

Public Instance Methods

ClearFormTemplatePartLinks | This method will remove all of the links from the provided Form Template object. In addition, for those Form Template Parts that are on this Form Template that are EXCLUSIVE to it, meaning they are not used by any other Form Template, they will be deleted. This method is exposed as a utility. Within the BaselineTemplateGenerator, this method is only called when a Form Template is generated.
CreateFormTemplate | This method will create a new generated form template for the specified entity object instance and return the FormTemplateID created through the FormTemplateID OUT parameter, if the method is succesful.
DeleteFormTemplate | This method will delete a form template and all of its associated parts and sub-templates.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindFormTemplate | This method will return a Form Template Record ID that matches the specified EntityID, Form Template Name, Usage Scope and Generated attribute, or return -1, if no such record is found. If more than one such record matches the provided criteria, the lowest ID value is returned.
FindFormTemplatePart | This method attempts to find a Form Template Part that matches the provided parameter information, and return the lowest matching record ID value if more than one such record exists. -1 is returned if no records match.
FormTemplatePartUsageCount | This method will calculate the total number of instances where a particular Form Template Part is being used. If provided, the ExcludeFormTemplateID parameter is used to exclude a specific Form Template from the count.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
GlobalTemplateExists | This method determines if a template exists in the Form Template meta-data for the given EntityID. The method returns the results through the FormTemplateInfo OUT parameter
IsFormTemplateTopLevel | This method determines if the specified form template is a top-level form template or not. Top level form templates are defined as form templates that are NOT in use anywhere as a sub-template.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateFormTemplate | This method is NOT currently implemented and is designed to update a form template in place for a given entity object. Instead of using this method, currently, it is expected that a form template that is generated will be deleted and re-created when necessary.

Protected Instance Methods

CreateSubTypePart | This method is responsible for creating a sub-type form template part for the specified sub-type.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FindCreateSubTypePart | This method is responsible for finding a sub-type form template part and if one doesn't exist, automatically creating a sub-type form template part for the specified sub-type.
FindSubTypePart | This method is responsible for finding an existing sub-type form template part record and returning it, if it exists. If no record is found, -1 is returned
GetSubTypePartName | This method is responsible for generating the sub-type form template part name to be used for the specified combination of a top level entity name and sub-type name. The default logic in the base class creates a string that has "TopLevelEntityName.Tabs.SubTypeName" as the string pattern. Override this method in a sub-class to alter the naming.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyBaselineTemplateGenerator Class | Aptify.Framework.BusinessLogic.FormTemplate Namespace


AptifyBaselineTemplateGenerator.ClearFormTemplatePartLinks Method

This method will remove all of the links from the provided Form Template object. In addition, for those Form Template Parts that are on this Form Template that are EXCLUSIVE to it, meaning they are not used by any other Form Template, they will be deleted. This method is exposed as a utility. Within the BaselineTemplateGenerator, this method is only called when a Form Template is generated.

public virtual bool ClearFormTemplatePartLinks(
AptifyGenericEntityBase FormTemplateGE
);

Parameters

FormTemplateGE

Remarks

See Also

AptifyBaselineTemplateGenerator Class | Aptify.Framework.BusinessLogic.FormTemplate Namespace


AptifyBaselineTemplateGenerator.CreateFormTemplate Method

This method will create a new generated form template for the specified entity object instance and return the FormTemplateID created through the FormTemplateID OUT parameter, if the method is succesful.

public bool CreateFormTemplate(
AptifyGenericEntityBase EntityObject,
ref Int64& FormTemplateID
);

Parameters

EntityObject
FormTemplateID

Return Value

True if succesful, False otherwise

Remarks

See Also

AptifyBaselineTemplateGenerator Class | Aptify.Framework.BusinessLogic.FormTemplate Namespace


AptifyBaselineTemplateGenerator.CreateSubTypePart Method

This method is responsible for creating a sub-type form template part for the specified sub-type.

protected virtual long CreateSubTypePart(
String TopLevelEntityName,
String SubTypeName,
String SubTypeDisplayName,
Int64 CultureStringID
);

Parameters

TopLevelEntityName
SubTypeName
SubTypeDisplayName
CultureStringID

Return Value

Remarks

See Also

AptifyBaselineTemplateGenerator Class | Aptify.Framework.BusinessLogic.FormTemplate Namespace


AptifyBaselineTemplateGenerator.DeleteFormTemplate Method

This method will delete a form template and all of its associated parts and sub-templates.

public bool DeleteFormTemplate(
Int64 FormTemplateID
);

Parameters

FormTemplateID

Return Value

Remarks

See Also

AptifyBaselineTemplateGenerator Class | Aptify.Framework.BusinessLogic.FormTemplate Namespace


AptifyBaselineTemplateGenerator.FindCreateSubTypePart Method

This method is responsible for finding a sub-type form template part and if one doesn't exist, automatically creating a sub-type form template part for the specified sub-type.

protected virtual long FindCreateSubTypePart(
String TopLevelEntityName,
String SubTypeName,
String SubTypeDisplayName,
Int64 CultureStringID,
ref Boolean& NewPartCreated
);

Parameters

TopLevelEntityName
SubTypeName
SubTypeDisplayName
CultureStringID
NewPartCreated

Return Value

Remarks

See Also

AptifyBaselineTemplateGenerator Class | Aptify.Framework.BusinessLogic.FormTemplate Namespace


AptifyBaselineTemplateGenerator.FindFormTemplate Method

This method will return a Form Template Record ID that matches the specified EntityID, Form Template Name, Usage Scope and Generated attribute, or return -1, if no such record is found. If more than one such record matches the provided criteria, the lowest ID value is returned.

public virtual long FindFormTemplate(
Int64 EntityID,
String Name,
String UsageScope,
Boolean IsGenerated,
Boolean IgnoreGeneratedStatus
);

Parameters

EntityID
Name
UsageScope
IsGenerated
IgnoreGeneratedStatus
If this parameter is set to True, the IsGenerated BIT field is ignored and the IsGenerated paramater has no effect on the results of this method.

Return Value

Remarks

See Also

AptifyBaselineTemplateGenerator Class | Aptify.Framework.BusinessLogic.FormTemplate Namespace


AptifyBaselineTemplateGenerator.FindFormTemplatePart Method

This method attempts to find a Form Template Part that matches the provided parameter information, and return the lowest matching record ID value if more than one such record exists. -1 is returned if no records match.

public virtual long FindFormTemplatePart(
String Name,
Int64 FormTemplatePartCategoryID,
Int64 FormComponentID
);

Parameters

Name
FormTemplatePartCategoryID
FormComponentID

Return Value

Remarks

See Also

AptifyBaselineTemplateGenerator Class | Aptify.Framework.BusinessLogic.FormTemplate Namespace


AptifyBaselineTemplateGenerator.FindSubTypePart Method

This method is responsible for finding an existing sub-type form template part record and returning it, if it exists. If no record is found, -1 is returned

protected virtual long FindSubTypePart(
String TopLevelEntityName,
String SubTypeName,
String SubTypeDisplayName,
Int64 CultureStringID
);

Return Value

Remarks

See Also

AptifyBaselineTemplateGenerator Class | Aptify.Framework.BusinessLogic.FormTemplate Namespace


AptifyBaselineTemplateGenerator.FormTemplatePartUsageCount Method

This method will calculate the total number of instances where a particular Form Template Part is being used. If provided, the ExcludeFormTemplateID parameter is used to exclude a specific Form Template from the count.

public virtual int FormTemplatePartUsageCount(
Int64 FormTemplatePartID,
Int64 ExcludeFormTemplateID
);

Parameters

FormTemplatePartID
ExcludeFormTemplateID

Return Value

Remarks

See Also

AptifyBaselineTemplateGenerator Class | Aptify.Framework.BusinessLogic.FormTemplate Namespace


AptifyBaselineTemplateGenerator.GetSubTypePartName Method

This method is responsible for generating the sub-type form template part name to be used for the specified combination of a top level entity name and sub-type name. The default logic in the base class creates a string that has "TopLevelEntityName.Tabs.SubTypeName" as the string pattern. Override this method in a sub-class to alter the naming.

protected virtual string GetSubTypePartName(
String TopLevelEntityName,
String SubTypeName
);

Parameters

TopLevelEntityName
SubTypeName

Return Value

Remarks

See Also

AptifyBaselineTemplateGenerator Class | Aptify.Framework.BusinessLogic.FormTemplate Namespace


AptifyBaselineTemplateGenerator.GlobalTemplateExists Method

This method determines if a template exists in the Form Template meta-data for the given EntityID. The method returns the results through the FormTemplateInfo OUT parameter

public bool GlobalTemplateExists(
Int64 EntityID,
ref TemplateInfo[]& FormTemplateInfo,
Boolean TopLevelTemplatesOnly
);

Parameters

EntityID
FormTemplateInfo
TopLevelTemplatesOnly
If set to True, only top-level form templates are used (top level templates defined as templates that are not used as sub-templated anywhere in the system meta-data), if False, all templates are returned that are global in scope.

Return Value

Remarks

See Also

AptifyBaselineTemplateGenerator Class | Aptify.Framework.BusinessLogic.FormTemplate Namespace


AptifyBaselineTemplateGenerator.IsFormTemplateTopLevel Method

This method determines if the specified form template is a top-level form template or not. Top level form templates are defined as form templates that are NOT in use anywhere as a sub-template.

public bool IsFormTemplateTopLevel(
Int64 FormTemplateID
);

Parameters

FormTemplateID

Return Value

Remarks

See Also

AptifyBaselineTemplateGenerator Class | Aptify.Framework.BusinessLogic.FormTemplate Namespace


AptifyBaselineTemplateGenerator.UpdateFormTemplate Method

This method is NOT currently implemented and is designed to update a form template in place for a given entity object. Instead of using this method, currently, it is expected that a form template that is generated will be deleted and re-created when necessary.

public bool UpdateFormTemplate(
AptifyGenericEntityBase EntityObject,
Int64 FormTemplateID
);

Parameters

EntityObject
FormTemplateID

Return Value

Remarks

See Also

AptifyBaselineTemplateGenerator Class | Aptify.Framework.BusinessLogic.FormTemplate Namespace


AptifyBaselineTemplateGenerator.TemplateInfo Structure

This struture contains information about a form template meta-data instance.

For a list of all members of this type, see AptifyBaselineTemplateGenerator.TemplateInfo Members.

System.Object
ValueType
AptifyBaselineTemplateGenerator.TemplateInfo

public struct AptifyBaselineTemplateGenerator.TemplateInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.FormTemplate

Assembly: AptifyBaselineTemplateGenerator (in AptifyBaselineTemplateGenerator.dll)

See Also

AptifyBaselineTemplateGenerator.TemplateInfo Members | Aptify.Framework.BusinessLogic.FormTemplate Namespace


AptifyBaselineTemplateGenerator.TemplateInfo Members

AptifyBaselineTemplateGenerator.TemplateInfo overview

Public Instance Fields

IsGenerated
IsTopLevel
TemplateID

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

AptifyBaselineTemplateGenerator.TemplateInfo Structure | Aptify.Framework.BusinessLogic.FormTemplate Namespace


AptifyBaselineTemplateGenerator.TemplateInfo Fields

The fields of the AptifyBaselineTemplateGenerator.TemplateInfo structure are listed below. For a complete list of AptifyBaselineTemplateGenerator.TemplateInfo structure members, see the AptifyBaselineTemplateGenerator.TemplateInfo Members topic.

Public Instance Fields

IsGenerated
IsTopLevel
TemplateID

See Also

AptifyBaselineTemplateGenerator.TemplateInfo Structure | Aptify.Framework.BusinessLogic.FormTemplate Namespace


AptifyBaselineTemplateGenerator.TemplateInfo.IsGenerated Field

public IsGenerated IsGenerated;

See Also

AptifyBaselineTemplateGenerator.TemplateInfo Class | Aptify.Framework.BusinessLogic.FormTemplate Namespace


AptifyBaselineTemplateGenerator.TemplateInfo.IsTopLevel Field

public IsTopLevel IsTopLevel;

See Also

AptifyBaselineTemplateGenerator.TemplateInfo Class | Aptify.Framework.BusinessLogic.FormTemplate Namespace


AptifyBaselineTemplateGenerator.TemplateInfo.TemplateID Field

public TemplateID TemplateID;

See Also

AptifyBaselineTemplateGenerator.TemplateInfo Class | Aptify.Framework.BusinessLogic.FormTemplate Namespace


Aptify.Framework.BusinessLogic.GenericEntity

Aptify 5.0 Software Development Kit (SDK)

Aptify.Framework.BusinessLogic.GenericEntity Namespace

This namespace contains objects related to Aptify’s Generic Entity architecture, which provides a standard, generic interface to relational data models.

Namespace hierarchy

Classes

Class | Description
AfterDataFieldValidateEventArgs | Holds the Event arguments for the AfterDataFieldValidate Event in the AptifyDataFieldBase class.
AfterDeleteRecordEventArgs | Holds the Event arguments for the AfterDeleteRecord Event in the AptifyGenericEntityBase class
AfterLoadEmbeddedObjectEventArgs | Holds the Event arguments for the AfterLoadEmbeddedObject Event.
AfterSaveRecordEventArgs | Holds the Event arguments for the AfterSaveRecord Event in the AptifyGenericEntityBase class
AfterSubTypeItemAddEventArgs | Holds the Event arguments for the AfterItemAdd Event in the AptifySubTypeBase class
AfterSubTypeItemRemoveEventArgs | Holds the Event arguments for the AfterItemRemove Event in the AptifySubTypeBase class
AfterValidateRecordEventArgs | Holds the Event arguments for the AfterRecordValidate Event in the AptifyGenericEntitydBase class
AfterValueChangedEventArgs | Holds the Event arguments for the AfterValueChanged Event in the AptifyDataFieldBase class
AptifyDataField |
AptifyDataFieldBase |
AptifyDataFieldDoesNotExistException |
AptifyDataFields |
AptifyDataFieldsBase |
AptifyDuplicateMessage |
AptifyEntityPermissionDeniedException |
AptifyGenericEntity | The standard implementation for the AptifyGenericEntityBase
AptifyGenericEntityBase | Base class for the Aptify Generic Entity, the main business object in the Aptify Technology Platform
AptifyGenericEntityConflictException |
AptifyGenericEntityDatabaseOperationException |
AptifyGenericEntityDuplicateCheckFailureException |
AptifyGenericEntityEventFailureException | Thrown when an Aptify Event returns a Failure.
AptifyGenericEntityException |
AptifyGenericEntityRecordNotFoundException |
AptifyGenericEntitySQLException |
AptifyGenericEntityTransactionMismatchException |
AptifyGenericEntityValidationException |
AptifySubType |
AptifySubTypeBase |
AptifySubTypes |
AptifyTransferMapping |
AptifyTransferMappingNoMatchException |
BeforeCloneRecordEventArgs | Holds the Event arguments for the BeforeClone Event in the AptifyGenericEntityBase class
BeforeDataFieldCloneEventArgs | Holds the Event arguments for the BeforeClone Event in the AptifyDataFieldBase class
BeforeDataFieldValidateEventArgs | Holds the Event arguments for the BeforeDataFieldValidate Event in the AptifyDataFieldBase class
BeforeDeleteRecordEventArgs | Holds the Event arguments for the BeforeDeleteRecord Event in the AptifyGenericEntityBase class
BeforeLoadRecordEventArgs | Holds the Event arguments for the BeforeLoadRecord Event in the AptifyGenericEntityBase class
BeforeSaveRecordEventArgs | Holds the Event arguments for the BeforeSaveRecord Event in the AptifyGenericEntityBase class
BeforeSubTypeItemAddEventArgs | Holds the Event arguments for the BeforeItemAdd Event in the AptifySubTypeBase class
BeforeSubTypeItemRemoveEventArgs | Holds the Event arguments for the BeforeItemRemove Event in the AptifySubTypeBase class
BeforeValidateRecordEventArgs | Holds the Event arguments for the BeforeValidateRecord Event in the AptifyGenericEntityBase class
BeforeValueChangedEventArgs | Holds the Event arguments for the BeforeValueChanged Event in the AptifyDataFieldBase class
ClassNameInfo |
DuplicateMessageForm |
EntityDependant | An object that represents a single dependent entity.
EntityDependenciesBase |
ExtenderInstance | Extends the functionality of ExtenderInstanceBase providing implementations for the required MustOverride methods of the base class.
ExtenderInstanceBase | Provides information about an instance of an extender GE.
ExtenderObjectList |
ExtenderObjectListBase |
GEBaseConstants |
GEConstants |
GESubClassCompiler | This class is capable of compiling a generated GE Sub-Class by using VB command line compilation. The methods specified allow you to compile the code files and generate a DLL.
GESubClassGenerator | This class is used to generate Generic Entity sub-classes that inherit from the Generic Entity and create strongly typed accessor methods for properties and sub-types with XML comments from the meta-data.
GESubClassIntegrator | This class is responsible for using the GE sub-class generator and compiler classes and integrating the resulting compiled DLL objects into the object repository. This class implements IProcessComponent so that it can be called from a process flow
LegacyParser | This object supports the Record Data format that was used in CGI Explorer 1.x and 2.x. Starting with CGI Explorer 3.0, an XML format was used and a different parser is responsible for deserializing the GE.
RequestForLatestValueArgs | Holds the Event arguments for the AfterLoadEmbeddedObject Event.
SecurityKeyPermissionException | This exception will be thrown if a user that does not have access to a security key tries to access it.
ServiceGeneratorForm |
ValidationScriptResult | This class is used as the result from Validation Scripts.
VersionCommentsForm |
WarningEventArgs | Provides attributes that are used in the case of a warning event being raised by the AptifyGenericEntityBase class or sub-classes.
WebServiceGenerator | This class is used to generate web services for each of the four major operations that are commonly needed, Create, Read, Update, Delete (CRUD) operations for any entity or set of entities.
XMLParser |

Interfaces

Interface | Description
IAptifyDuplicateCheck |
IAptifyDuplicateMessage |
IAptifyTransferMap |
IAptifyVerify |

Structures

Structure | Description
DataLocation |
FieldAndParamName | A data structure that holds the name of the field (Field) and the name of the parameter used by the stored procedures used by the Generic Entity object (ParamName).
SubTypeLink |

Delegates

Delegate | Description
AptifyDataFieldBase.AfterCloneEventHandler |
AptifyDataFieldBase.AfterLoadEmbeddedObjectEventHandler |
AptifyDataFieldBase.AfterValidateEventHandler |
AptifyDataFieldBase.AfterValueChangedEventHandler |
AptifyDataFieldBase.BeforeCloneEventHandler |
AptifyDataFieldBase.BeforeLoadEmbeddedObjectEventHandler |
AptifyDataFieldBase.BeforeValidateEventHandler |
AptifyDataFieldBase.BeforeValueChangedEventHandler |
AptifyDataFieldBase.RequestForLatestValueEventHandler |
AptifyGenericEntityBase.AfterCloneRecordEventHandler |
AptifyGenericEntityBase.AfterDeleteRecordEventHandler |
AptifyGenericEntityBase.AfterLoadRecordEventHandler |
AptifyGenericEntityBase.AfterNewRecordEventHandler |
AptifyGenericEntityBase.AfterSaveRecordEventHandler |
AptifyGenericEntityBase.AfterValidateRecordEventHandler |
AptifyGenericEntityBase.BeforeCloneRecordEventHandler |
AptifyGenericEntityBase.BeforeDeleteRecordEventHandler |
AptifyGenericEntityBase.BeforeLoadRecordEventHandler |
AptifyGenericEntityBase.BeforeNewRecordEventHandler |
AptifyGenericEntityBase.BeforeSaveRecordEventHandler |
AptifyGenericEntityBase.BeforeValidateRecordEventHandler |
AptifyGenericEntityBase.WarningEventHandler |
AptifySubTypeBase.AfterClearEventHandler |
AptifySubTypeBase.AfterItemAddEventHandler |
AptifySubTypeBase.AfterItemRemoveEventHandler |
AptifySubTypeBase.BeforeClearEventHandler |
AptifySubTypeBase.BeforeItemAddEventHandler |
AptifySubTypeBase.BeforeItemRemoveEventHandler |
AptifySubTypeBase.FindPositionPercentChangedEventHandler |
GESubClassGenerator.StatusUpdateEventHandler |
WebServiceGenerator.StatusUpdateEventHandler |

Enumerations

Enumeration | Description
AptifyCompare |
AptifyDataFieldBase.AptifyDataFieldEvents | Enumeration that identifies the different Event settings available on a Data Field.
AptifyGenericEntityBase.AptifyGenericEntityEvents | Enumeration that identifies the different Event settings available on a Generic Entity.
AptifyGenericEntityBase.PendingChangeUpdateType | Enumerated Constant representing primarily conflict row types.
AptifyMoveObjectOptions |
AptifySortDirection |
AptifySubTypeBase.AptifySubTypeEvents | Enumeration that identifies the different Event settings available on a SubType.
BeforeLoadRecordEventArgs.LoadRecordEventLoadType |
DuplicateCheckMessageAction |
DuplicateCheckResult |


AfterDataFieldValidateEventArgs Class

Holds the Event arguments for the AfterDataFieldValidate Event in the AptifyDataFieldBase class.

For a list of all members of this type, see AfterDataFieldValidateEventArgs Members.

System.Object
EventArgs
AfterDataFieldValidateEventArgs

public class AfterDataFieldValidateEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

AfterDataFieldValidateEventArgs Members | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AfterDataFieldValidateEventArgs Members

AfterDataFieldValidateEventArgs overview

Public Instance Constructors

AfterDataFieldValidateEventArgs Constructor

Public Instance Properties

ErrorString | Contains the ErrorString populated by the Data Field's Validate routine. The ErrorString property can be changed by the Event Handler.
IsValid | A flag that indicates whether or not the Validate routine found the Data Field valid. The IsValid property can be changed by the Event Handler.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AfterDataFieldValidateEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AfterDataFieldValidateEventArgs Constructor

public AfterDataFieldValidateEventArgs(
Boolean IsValid,
String ErrorString
);

See Also

AfterDataFieldValidateEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AfterDataFieldValidateEventArgs Properties

The properties of the AfterDataFieldValidateEventArgs class are listed below. For a complete list of AfterDataFieldValidateEventArgs class members, see the AfterDataFieldValidateEventArgs Members topic.

Public Instance Properties

ErrorString | Contains the ErrorString populated by the Data Field's Validate routine. The ErrorString property can be changed by the Event Handler.
IsValid | A flag that indicates whether or not the Validate routine found the Data Field valid. The IsValid property can be changed by the Event Handler.

See Also

AfterDataFieldValidateEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ErrorString Property

Aptify 5.0 Software Development Kit (SDK)

AfterDataFieldValidateEventArgs.ErrorString Property

Contains the ErrorString populated by the Data Field's Validate routine. The ErrorString property can be changed by the Event Handler.

public String ErrorString {get; set;}

Property Value

Remarks

See Also

AfterDataFieldValidateEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


IsValid Property

Aptify 5.0 Software Development Kit (SDK)

AfterDataFieldValidateEventArgs.IsValid Property

A flag that indicates whether or not the Validate routine found the Data Field valid. The IsValid property can be changed by the Event Handler.

public Boolean IsValid {get; set;}

Property Value

Remarks

See Also

AfterDataFieldValidateEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AfterDeleteRecordEventArgs Class

Holds the Event arguments for the AfterDeleteRecord Event in the AptifyGenericEntityBase class

For a list of all members of this type, see AfterDeleteRecordEventArgs Members.

System.Object
EventArgs
AfterDeleteRecordEventArgs

public class AfterDeleteRecordEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

AfterDeleteRecordEventArgs Members | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AfterDeleteRecordEventArgs Members

AfterDeleteRecordEventArgs overview

Public Instance Constructors

AfterDeleteRecordEventArgs Constructor

Public Instance Properties

TransactionID

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AfterDeleteRecordEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AfterDeleteRecordEventArgs Constructor

public AfterDeleteRecordEventArgs(
String TransactionID
);

See Also

AfterDeleteRecordEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AfterDeleteRecordEventArgs Properties

The properties of the AfterDeleteRecordEventArgs class are listed below. For a complete list of AfterDeleteRecordEventArgs class members, see the AfterDeleteRecordEventArgs Members topic.

Public Instance Properties

TransactionID

See Also

AfterDeleteRecordEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


TransactionID Property

Aptify 5.0 Software Development Kit (SDK)

AfterDeleteRecordEventArgs.TransactionID Property

public String TransactionID {get;}

See Also

AfterDeleteRecordEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AfterLoadEmbeddedObjectEventArgs Class

Holds the Event arguments for the AfterLoadEmbeddedObject Event.

For a list of all members of this type, see AfterLoadEmbeddedObjectEventArgs Members.

System.Object
EventArgs
AfterLoadEmbeddedObjectEventArgs

public class AfterLoadEmbeddedObjectEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

AfterLoadEmbeddedObjectEventArgs Members | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AfterLoadEmbeddedObjectEventArgs Members

AfterLoadEmbeddedObjectEventArgs overview

Public Instance Constructors

AfterLoadEmbeddedObjectEventArgs Constructor

Public Instance Properties

EmbeddedGE A reference to the Embedded Object. The EmbeddedGE property can be changed by the Event Handler.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AfterLoadEmbeddedObjectEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AfterLoadEmbeddedObjectEventArgs Constructor

public AfterLoadEmbeddedObjectEventArgs(
AptifyGenericEntityBase EmbeddedGE
);

See Also

AfterLoadEmbeddedObjectEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AfterLoadEmbeddedObjectEventArgs Properties

The properties of the AfterLoadEmbeddedObjectEventArgs class are listed below. For a complete list of AfterLoadEmbeddedObjectEventArgs class members, see the AfterLoadEmbeddedObjectEventArgs Members topic.

Public Instance Properties

EmbeddedGE A reference to the Embedded Object. The EmbeddedGE property can be changed by the Event Handler.

See Also

AfterLoadEmbeddedObjectEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


EmbeddedGE Property

Aptify 5.0 Software Development Kit (SDK)

AfterLoadEmbeddedObjectEventArgs.EmbeddedGE Property

A reference to the Embedded Object. The EmbeddedGE property can be changed by the Event Handler.

public AptifyGenericEntityBase EmbeddedGE {get; set;}

Property Value

Remarks

See Also

AfterLoadEmbeddedObjectEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AfterSaveRecordEventArgs Class

Holds the Event arguments for the AfterSaveRecord Event in the AptifyGenericEntityBase class

For a list of all members of this type, see AfterSaveRecordEventArgs Members.

System.Object
EventArgs
AfterSaveRecordEventArgs

public class AfterSaveRecordEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

AfterSaveRecordEventArgs Members | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AfterSaveRecordEventArgs Members

AfterSaveRecordEventArgs overview

Public Instance Constructors

AfterSaveRecordEventArgs Constructor

Public Instance Properties

AllowGUI
TransactionID

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AfterSaveRecordEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AfterSaveRecordEventArgs Constructor

public AfterSaveRecordEventArgs(
Boolean AllowGUI,
String TransactionID
);

See Also

AfterSaveRecordEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AfterSaveRecordEventArgs Properties

The properties of the AfterSaveRecordEventArgs class are listed below. For a complete list of AfterSaveRecordEventArgs class members, see the AfterSaveRecordEventArgs Members topic.

Public Instance Properties

AllowGUI
TransactionID

See Also

AfterSaveRecordEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AllowGUI Property

Aptify 5.0 Software Development Kit (SDK)

AfterSaveRecordEventArgs.AllowGUI Property

public Boolean AllowGUI {get;}

See Also

AfterSaveRecordEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


TransactionID Property

Aptify 5.0 Software Development Kit (SDK)

AfterSaveRecordEventArgs.TransactionID Property

public String TransactionID {get;}

See Also

AfterSaveRecordEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AfterSubTypeItemAddEventArgs Class

Holds the Event arguments for the AfterItemAdd Event in the AptifySubTypeBase class

For a list of all members of this type, see AfterSubTypeItemAddEventArgs Members.

System.Object
EventArgs
AfterSubTypeItemAddEventArgs

public class AfterSubTypeItemAddEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

AfterSubTypeItemAddEventArgs Members | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AfterSubTypeItemAddEventArgs Members

AfterSubTypeItemAddEventArgs overview

Public Instance Constructors

AfterSubTypeItemAddEventArgs Constructor

Public Instance Properties

geAdded | Contains a reference to the AptifyGenericEntityBase object that was added to the Sub-Type
Index | Contains the index position of the newly added object in the Sub-Type's list.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AfterSubTypeItemAddEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AfterSubTypeItemAddEventArgs Constructor

public AfterSubTypeItemAddEventArgs(
AptifyGenericEntityBase geAdded,
Int32 Index
);

See Also

AfterSubTypeItemAddEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AfterSubTypeItemAddEventArgs Properties

The properties of the AfterSubTypeItemAddEventArgs class are listed below. For a complete list of AfterSubTypeItemAddEventArgs class members, see the AfterSubTypeItemAddEventArgs Members topic.

Public Instance Properties

geAdded | Contains a reference to the AptifyGenericEntityBase object that was added to the Sub-Type
Index | Contains the index position of the newly added object in the Sub-Type's list.

See Also

AfterSubTypeItemAddEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


geAdded Property

Aptify 5.0 Software Development Kit (SDK)

AfterSubTypeItemAddEventArgs.geAdded Property

Contains a reference to the AptifyGenericEntityBase object that was added to the Sub-Type

public AptifyGenericEntityBase geAdded {get;}

Property Value

Remarks

See Also

AfterSubTypeItemAddEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


Index Property

Aptify 5.0 Software Development Kit (SDK)

AfterSubTypeItemAddEventArgs.Index Property

Contains the index position of the newly added object in the Sub-Type's list.

public Int32 Index {get;}

Property Value

Remarks

See Also

AfterSubTypeItemAddEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AfterSubTypeItemRemoveEventArgs Class

Holds the Event arguments for the AfterItemRemove Event in the AptifySubTypeBase class

For a list of all members of this type, see AfterSubTypeItemRemoveEventArgs Members.

System.Object
EventArgs
AfterSubTypeItemRemoveEventArgs

public class AfterSubTypeItemRemoveEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

AfterSubTypeItemRemoveEventArgs Members | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AfterSubTypeItemRemoveEventArgs Members

AfterSubTypeItemRemoveEventArgs overview

Public Instance Constructors

AfterSubTypeItemRemoveEventArgs Constructor

Public Instance Properties

geRemoved Contains a reference to the AptifyGenericEntityBase object that was removed from the Sub-Type

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AfterSubTypeItemRemoveEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AfterSubTypeItemRemoveEventArgs Constructor

public AfterSubTypeItemRemoveEventArgs(
AptifyGenericEntityBase geRemoved
);

See Also

AfterSubTypeItemRemoveEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AfterSubTypeItemRemoveEventArgs Properties

The properties of the AfterSubTypeItemRemoveEventArgs class are listed below. For a complete list of AfterSubTypeItemRemoveEventArgs class members, see the AfterSubTypeItemRemoveEventArgs Members topic.

Public Instance Properties

geRemoved Contains a reference to the AptifyGenericEntityBase object that was removed from the Sub-Type

See Also

AfterSubTypeItemRemoveEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


geRemoved Property

Aptify 5.0 Software Development Kit (SDK)

AfterSubTypeItemRemoveEventArgs.geRemoved Property

Contains a reference to the AptifyGenericEntityBase object that was removed from the Sub-Type

public AptifyGenericEntityBase geRemoved {get;}

Property Value

Remarks

See Also

AfterSubTypeItemRemoveEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AfterValidateRecordEventArgs Class

Holds the Event arguments for the AfterRecordValidate Event in the AptifyGenericEntitydBase class

For a list of all members of this type, see AfterValidateRecordEventArgs Members.

System.Object
EventArgs
AfterValidateRecordEventArgs

public class AfterValidateRecordEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

AfterValidateRecordEventArgs Members | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AfterValidateRecordEventArgs Members

AfterValidateRecordEventArgs overview

Public Instance Constructors

AfterValidateRecordEventArgs Constructor

Public Instance Properties

ErrorString Contains the ErrorString populated by the Generic Entity's Validate routine. The ErrorString property can be changed by the Event Handler.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AfterValidateRecordEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AfterValidateRecordEventArgs Constructor

public AfterValidateRecordEventArgs(
String ErrorString
);

See Also

AfterValidateRecordEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AfterValidateRecordEventArgs Properties

The properties of the AfterValidateRecordEventArgs class are listed below. For a complete list of AfterValidateRecordEventArgs class members, see the AfterValidateRecordEventArgs Members topic.

Public Instance Properties

ErrorString Contains the ErrorString populated by the Generic Entity's Validate routine. The ErrorString property can be changed by the Event Handler.

See Also

AfterValidateRecordEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ErrorString Property

Aptify 5.0 Software Development Kit (SDK)

AfterValidateRecordEventArgs.ErrorString Property

Contains the ErrorString populated by the Generic Entity's Validate routine. The ErrorString property can be changed by the Event Handler.

public String ErrorString {get; set;}

Property Value

Remarks

See Also

AfterValidateRecordEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AfterValueChangedEventArgs Class

Holds the Event arguments for the AfterValueChanged Event in the AptifyDataFieldBase class

For a list of all members of this type, see AfterValueChangedEventArgs Members.

System.Object
EventArgs
AfterValueChangedEventArgs

public class AfterValueChangedEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

AfterValueChangedEventArgs Members | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AfterValueChangedEventArgs Members

AfterValueChangedEventArgs overview

Public Instance Constructors

AfterValueChangedEventArgs Constructor

Public Instance Properties

FieldName | Represents the name of the Data Field that was changed. If this is a field from an embedded object, the parent object's Embedded Link Name with a dot will be prefixed to the field name.
NewValue | Represents the value that was applied to the Data Field.
OldValue | Represents the value of the Data Field prior to the change.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AfterValueChangedEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AfterValueChangedEventArgs Constructor

public AfterValueChangedEventArgs(
String FieldName,
Object OldValue,
Object NewValue
);

See Also

AfterValueChangedEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AfterValueChangedEventArgs Properties

The properties of the AfterValueChangedEventArgs class are listed below. For a complete list of AfterValueChangedEventArgs class members, see the AfterValueChangedEventArgs Members topic.

Public Instance Properties

FieldName | Represents the name of the Data Field that was changed. If this is a field from an embedded object, the parent object's Embedded Link Name with a dot will be prefixed to the field name.
NewValue | Represents the value that was applied to the Data Field.
OldValue | Represents the value of the Data Field prior to the change.

See Also

AfterValueChangedEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


FieldName Property

Aptify 5.0 Software Development Kit (SDK)

AfterValueChangedEventArgs.FieldName Property

Represents the name of the Data Field that was changed. If this is a field from an embedded object, the parent object's Embedded Link Name with a dot will be prefixed to the field name.

public String FieldName {get;}

Property Value

Remarks

See Also

AfterValueChangedEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


NewValue Property

Aptify 5.0 Software Development Kit (SDK)

AfterValueChangedEventArgs.NewValue Property

Represents the value that was applied to the Data Field.

public Object NewValue {get; set;}

Property Value

Remarks

See Also

AfterValueChangedEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


OldValue Property

Aptify 5.0 Software Development Kit (SDK)

AfterValueChangedEventArgs.OldValue Property

Represents the value of the Data Field prior to the change.

public Object OldValue {get;}

Property Value

Remarks

See Also

AfterValueChangedEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyCompare Enumeration

public enum AptifyCompare

Members

Member Name | Description
AptifyExactmatch |
AptifyBeginsWith |
AptifyEndsWith |
AptifyContains |
AptifyGreaterThan |
AptifyGreaterThanOrEqual |
AptifyLessThan |
AptifyLessThanOrEqual |
AptifyNotEqual |
AptifyIsTrue |
AptifyIsFalse |

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataField Class

For a list of all members of this type, see AptifyDataField Members.

System.Object
AptifyDataFieldBase
AptifyDataField

public class AptifyDataField : AptifyDataFieldBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntity (in AptifyGenericEntity.dll)

See Also

AptifyDataField Members | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataField Members

AptifyDataField overview

Public Static Fields

VALIDATION_SCRIPT_TIMEOUT_ATTRIBUTE This is the partial name of the Attribute that controls the length of the Validation Script Timeout.

Public Instance Properties

Alignment (inherited from AptifyDataFieldBase) |
AllowedSearchMethods (inherited from AptifyDataFieldBase) |
AllowSorting (inherited from AptifyDataFieldBase) |
BaseTable (inherited from AptifyDataFieldBase) | Get base table name for this field.
Category (inherited from AptifyDataFieldBase) |
CurrencyTypeField (inherited from AptifyDataFieldBase) |
CurrencyTypeFieldObject (inherited from AptifyDataFieldBase) |
CustomGUIObjRepLoc (inherited from AptifyDataFieldBase) |
CustomGUIProgID (inherited from AptifyDataFieldBase) |
DefaultInView (inherited from AptifyDataFieldBase) |
DefaultValue (inherited from AptifyDataFieldBase) |
Description (inherited from AptifyDataFieldBase) |
DisplayCultureString (inherited from AptifyDataFieldBase) |
DisplayCultureStringID (inherited from AptifyDataFieldBase) |
DisplayName (inherited from AptifyDataFieldBase) |
DisplayNameWCulture (inherited from AptifyDataFieldBase) |
DisplayNameWCulture (inherited from AptifyDataFieldBase) |
DisplayNameWCulture (inherited from AptifyDataFieldBase) |
DisplayNameWCulture (inherited from AptifyDataFieldBase) |
EmbeddedLinkTypeSharingMode (inherited from AptifyDataFieldBase) |
EmbeddedObject |
EmbeddedObjectExists |
EncryptData (inherited from AptifyDataFieldBase) |
EncryptedData | Property returning the encrypted data.
EventsToFire (inherited from AptifyDataFieldBase) | Used to configure the Events that will be fired by the Data Field object.
ExtendedType (inherited from AptifyDataFieldBase) |
FieldValues (inherited from AptifyDataFieldBase) |
GUITypeMultiSelect (inherited from AptifyDataFieldBase) |
GUITypeSingleSelect (inherited from AptifyDataFieldBase) |
HelpObject (inherited from AptifyDataFieldBase) |
HelpText (inherited from AptifyDataFieldBase) |
HelpURL (inherited from AptifyDataFieldBase) |
InputMask (inherited from AptifyDataFieldBase) |
InputMaskType (inherited from AptifyDataFieldBase) |
InTable (inherited from AptifyDataFieldBase) |
IsDirty | Property returning if the field is in a Dirty state, indicating if it has changed since last saved.
IsInstalled (inherited from AptifyDataFieldBase) |
IsNameField (inherited from AptifyDataFieldBase) |
IsRequired (inherited from AptifyDataFieldBase) |
IsSequence (inherited from AptifyDataFieldBase) |
IsSystem (inherited from AptifyDataFieldBase) |
IsValidated (inherited from AptifyDataFieldBase) |
JoinedEntity (inherited from AptifyDataFieldBase) |
JoinedField (inherited from AptifyDataFieldBase) |
JoinForeignKey (inherited from AptifyDataFieldBase) |
JoinType (inherited from AptifyDataFieldBase) |
LinkedEntity (inherited from AptifyDataFieldBase) |
LinkedEntityField (inherited from AptifyDataFieldBase) |
LinkType (inherited from AptifyDataFieldBase) |
Name (inherited from AptifyDataFieldBase) |
NeedsQuotes (inherited from AptifyDataFieldBase) |
NeedToRefreshLinkedFields (inherited from AptifyDataFieldBase) |
NeverSet | Property representing if the field has been set within this instance of the GE.
ParamName (inherited from AptifyDataFieldBase) |
ParentGE (inherited from AptifyDataFieldBase) |
ParentLinkedValue (inherited from AptifyDataFieldBase) |
SecurityKeyID (inherited from AptifyDataFieldBase) |
ShowInFind (inherited from AptifyDataFieldBase) |
spDynamicFlowdown (inherited from AptifyDataFieldBase) |
SQLAllowNull (inherited from AptifyDataFieldBase) |
SQLDataType (inherited from AptifyDataFieldBase) |
SQLFieldPrecision (inherited from AptifyDataFieldBase) |
SQLFieldScale (inherited from AptifyDataFieldBase) |
SQLFieldSize (inherited from AptifyDataFieldBase) |
SupportsMultipleCurrencies (inherited from AptifyDataFieldBase) |
TextInterpretationMode (inherited from AptifyDataFieldBase) |
Type (inherited from AptifyDataFieldBase) |
Updateable (inherited from AptifyDataFieldBase) | Returns the Updateable Value that exists in the EntityFields metadata.
UpdateableThroughEmbedded | Determines if this Field is updateable from a GUI.
UserCanEdit | Property representing user edit permissions on this field.
UserCanRead | Property representing user read permissions on this field.
ValidationRangeDateLowerBound (inherited from AptifyDataFieldBase) |
ValidationRangeDateUpperBound (inherited from AptifyDataFieldBase) |
ValidationRangeLowerBound (inherited from AptifyDataFieldBase) |
ValidationRangeUpperBound (inherited from AptifyDataFieldBase) |
ValidationScript (inherited from AptifyDataFieldBase) |
ValidationType (inherited from AptifyDataFieldBase) |
Value | Overloaded. Property representing the field value.
ValueListType (inherited from AptifyDataFieldBase) |
VirtualFieldCalculation (inherited from AptifyDataFieldBase) |
VirtualFieldType (inherited from AptifyDataFieldBase) |
Width (inherited from AptifyDataFieldBase) |

Public Instance Methods

ClearDirty | Clears dirty flags set at the field level indicating that this field’s value in the Generic Entity is no longer out of synch with the database.
Clone | Clones a data field object.
DynamicSharingRelationshipExists (inherited from AptifyDataFieldBase) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDataString | Method that retrieves the XML markup for this field and its value.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLastError | Returns the most recent error from the error object.
GetOldValue | Returns the value of the field as of the most recent save of the record, either in this session or as loaded from the database.
GetProcFormat | Returns the representation of how this field will be formatted in Update and Insert stored procedure calls.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEmbeddedObjectBlank | Determines whether or not an Embedded Object exists and, if it does determines whether or not any field has been changed from the default. If this method is called on a field that does not support an Embedded Link, an exception will be thrown.
IsTime | Validate if given string is valid Time value or not.
Revert | Restores the in-memory value of the field to its last known value.
SaveEmbeddedObject | Overloaded.
SetValue | Overloaded. Method allows programmer to assign a value to the field object.
ToString (inherited from Object) | Returns a String that represents the current Object.
Validate | Method that validates the field based on the standard validation rules.
ValidateEmbeddedObject | Overloaded.

Public Instance Events

AfterClone (inherited from AptifyDataFieldBase) | Fired when the Data Field's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Data Field's EventsToFire property setting includes the Clone Events.
AfterLoadEmbeddedObject (inherited from AptifyDataFieldBase) | Fired after an Embedded Linked Data Field's Embedded Object is created. Note the event will only be fired if the Data Field's EventsToFire property setting includes the LoadEmbedded Events.
AfterValidate (inherited from AptifyDataFieldBase) | Fired when the Data Field's Validate method is called and after the internal validation logic has executed. Note the event will only be fired if the Data Field's EventsToFire property setting includes the Validate Events.
AfterValueChanged (inherited from AptifyDataFieldBase) | Fired after the Value of a Data Field object has changed. Note the event will only be fired if the Data Field's EventsToFire property setting includes the ValueChanged Event.
BeforeClone (inherited from AptifyDataFieldBase) | Fired when the Data Field's Clone method is called, before the Clone occurs. Note the event will only be fired if the Data Field's EventsToFire property setting includes the Clone Events.
BeforeLoadEmbeddedObject (inherited from AptifyDataFieldBase) | Fired just prior to an Embedded Linked Data Field's Embedded Object creation. Note the event will only be fired if the Data Field's EventsToFire property setting includes the LoadEmbedded Events.
BeforeValidate (inherited from AptifyDataFieldBase) | Fired when the Data Field's Validate method is called, before the internal validation logic has executed. Note the event will only be fired if the Data Field's EventsToFire property setting includes the Validate Events.
BeforeValueChanged (inherited from AptifyDataFieldBase) | Fired when the Value of a Data Field object is changed but before the change is applied. Note the event will only be fired if the Data Field's EventsToFire property setting includes the ValueChanged Event.
RequestForLatestValue (inherited from AptifyDataFieldBase) | Fired when an internal operation to the GE requires the most up-to-date value, particularly from the UI.

Protected Instance Properties

SecurityKeyObject
TemporaryField (inherited from AptifyDataFieldBase)

Protected Instance Methods

DoDecryptData |
DoEncryptData |
DoFormat (inherited from AptifyDataFieldBase) |
ExecuteScript | This function will Initialize the Script Engine Based on the [Field] Script Type.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
LoadEmbeddedObject | Loads the Embedded Generic Entity object when requested by the internal operations of the AptifyDataField object. If the EmbeddedObject Property is referenced, this method will be called in the Embedded GE object is not already loaded.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterClone (inherited from AptifyDataFieldBase) | Verifies whether or not the AfterClone event should be fired. If the event should be fired, it is fired.
OnAfterLoadEmbeddedObject (inherited from AptifyDataFieldBase) | Fired after an Embedded Linked Data Field's Embedded Object is created. Note the event will only be fired if the Data Field's EventsToFire property setting includes the LoadEmbedded Events.
OnAfterValidate (inherited from AptifyDataFieldBase) | Verifies whether or not the AfterValidate event should be fired. If the event should be fired, it is fired.
OnAfterValueChanged (inherited from AptifyDataFieldBase) | Verifies whether or not the AfterValueChanged event should be fired. If the event should be fired, it is fired.
OnBeforeClone (inherited from AptifyDataFieldBase) | Verifies whether or not the BeforeClone event should be fired. If the event should be fired, it is fired.
OnBeforeLoadEmbeddedObject (inherited from AptifyDataFieldBase) | Verifies whether or not the BeforeLoadEmbeddedObject event should be fired. If the event should be fired, it is fired.
OnBeforeValidate (inherited from AptifyDataFieldBase) | Verifies whether or not the BeforeValidate event should be fired. If the event should be fired, it is fired.
OnBeforeValueChanged (inherited from AptifyDataFieldBase) | Verifies whether or not the BeforeValueChanged event should be fired. If the event should be fired, it is fired.
OnRequestForLatestValue (inherited from AptifyDataFieldBase) | Verifies whether or not the BeforeValueChanged event should be fired. If the event should be fired, it is fired.
WrapField |

See Also

AptifyDataField Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataField Fields

The fields of the AptifyDataField class are listed below. For a complete list of AptifyDataField class members, see the AptifyDataField Members topic.

Public Static Fields

VALIDATION_SCRIPT_TIMEOUT_ATTRIBUTE This is the partial name of the Attribute that controls the length of the Validation Script Timeout.

See Also

AptifyDataField Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataField.VALIDATION_SCRIPT_TIMEOUT_ATTRIBUTE Field

This is the partial name of the Attribute that controls the length of the Validation Script Timeout.

public const VALIDATION_SCRIPT_TIMEOUT_ATTRIBUTE VALIDATION_SCRIPT_TIMEOUT_ATTRIBUTE = "ValidationScriptTimeOut";

See Also

AptifyDataField Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataField Properties

The properties of the AptifyDataField class are listed below. For a complete list of AptifyDataField class members, see the AptifyDataField Members topic.

Public Instance Properties

Alignment (inherited from AptifyDataFieldBase) |
AllowedSearchMethods (inherited from AptifyDataFieldBase) |
AllowSorting (inherited from AptifyDataFieldBase) |
BaseTable (inherited from AptifyDataFieldBase) | Get base table name for this field.
Category (inherited from AptifyDataFieldBase) |
CurrencyTypeField (inherited from AptifyDataFieldBase) |
CurrencyTypeFieldObject (inherited from AptifyDataFieldBase) |
CustomGUIObjRepLoc (inherited from AptifyDataFieldBase) |
CustomGUIProgID (inherited from AptifyDataFieldBase) |
DefaultInView (inherited from AptifyDataFieldBase) |
DefaultValue (inherited from AptifyDataFieldBase) |
Description (inherited from AptifyDataFieldBase) |
DisplayCultureString (inherited from AptifyDataFieldBase) |
DisplayCultureStringID (inherited from AptifyDataFieldBase) |
DisplayName (inherited from AptifyDataFieldBase) |
DisplayNameWCulture (inherited from AptifyDataFieldBase) |
DisplayNameWCulture (inherited from AptifyDataFieldBase) |
DisplayNameWCulture (inherited from AptifyDataFieldBase) |
DisplayNameWCulture (inherited from AptifyDataFieldBase) |
EmbeddedLinkTypeSharingMode (inherited from AptifyDataFieldBase) |
EmbeddedObject |
EmbeddedObjectExists |
EncryptData (inherited from AptifyDataFieldBase) |
EncryptedData | Property returning the encrypted data.
EventsToFire (inherited from AptifyDataFieldBase) | Used to configure the Events that will be fired by the Data Field object.
ExtendedType (inherited from AptifyDataFieldBase) |
FieldValues (inherited from AptifyDataFieldBase) |
GUITypeMultiSelect (inherited from AptifyDataFieldBase) |
GUITypeSingleSelect (inherited from AptifyDataFieldBase) |
HelpObject (inherited from AptifyDataFieldBase) |
HelpText (inherited from AptifyDataFieldBase) |
HelpURL (inherited from AptifyDataFieldBase) |
InputMask (inherited from AptifyDataFieldBase) |
InputMaskType (inherited from AptifyDataFieldBase) |
InTable (inherited from AptifyDataFieldBase) |
IsDirty | Property returning if the field is in a Dirty state, indicating if it has changed since last saved.
IsInstalled (inherited from AptifyDataFieldBase) |
IsNameField (inherited from AptifyDataFieldBase) |
IsRequired (inherited from AptifyDataFieldBase) |
IsSequence (inherited from AptifyDataFieldBase) |
IsSystem (inherited from AptifyDataFieldBase) |
IsValidated (inherited from AptifyDataFieldBase) |
JoinedEntity (inherited from AptifyDataFieldBase) |
JoinedField (inherited from AptifyDataFieldBase) |
JoinForeignKey (inherited from AptifyDataFieldBase) |
JoinType (inherited from AptifyDataFieldBase) |
LinkedEntity (inherited from AptifyDataFieldBase) |
LinkedEntityField (inherited from AptifyDataFieldBase) |
LinkType (inherited from AptifyDataFieldBase) |
Name (inherited from AptifyDataFieldBase) |
NeedsQuotes (inherited from AptifyDataFieldBase) |
NeedToRefreshLinkedFields (inherited from AptifyDataFieldBase) |
NeverSet | Property representing if the field has been set within this instance of the GE.
ParamName (inherited from AptifyDataFieldBase) |
ParentGE (inherited from AptifyDataFieldBase) |
ParentLinkedValue (inherited from AptifyDataFieldBase) |
SecurityKeyID (inherited from AptifyDataFieldBase) |
ShowInFind (inherited from AptifyDataFieldBase) |
spDynamicFlowdown (inherited from AptifyDataFieldBase) |
SQLAllowNull (inherited from AptifyDataFieldBase) |
SQLDataType (inherited from AptifyDataFieldBase) |
SQLFieldPrecision (inherited from AptifyDataFieldBase) |
SQLFieldScale (inherited from AptifyDataFieldBase) |
SQLFieldSize (inherited from AptifyDataFieldBase) |
SupportsMultipleCurrencies (inherited from AptifyDataFieldBase) |
TextInterpretationMode (inherited from AptifyDataFieldBase) |
Type (inherited from AptifyDataFieldBase) |
Updateable (inherited from AptifyDataFieldBase) | Returns the Updateable Value that exists in the EntityFields metadata.
UpdateableThroughEmbedded | Determines if this Field is updateable from a GUI.
UserCanEdit | Property representing user edit permissions on this field.
UserCanRead | Property representing user read permissions on this field.
ValidationRangeDateLowerBound (inherited from AptifyDataFieldBase) |
ValidationRangeDateUpperBound (inherited from AptifyDataFieldBase) |
ValidationRangeLowerBound (inherited from AptifyDataFieldBase) |
ValidationRangeUpperBound (inherited from AptifyDataFieldBase) |
ValidationScript (inherited from AptifyDataFieldBase) |
ValidationType (inherited from AptifyDataFieldBase) |
Value | Overloaded. Property representing the field value.
ValueListType (inherited from AptifyDataFieldBase) |
VirtualFieldCalculation (inherited from AptifyDataFieldBase) |
VirtualFieldType (inherited from AptifyDataFieldBase) |
Width (inherited from AptifyDataFieldBase) |

Protected Instance Properties

SecurityKeyObject
TemporaryField (inherited from AptifyDataFieldBase)

See Also

AptifyDataField Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


EmbeddedObject Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataField.EmbeddedObject Property

public override AptifyGenericEntityBase EmbeddedObject {get;}

See Also

AptifyDataField Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


EmbeddedObjectExists Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataField.EmbeddedObjectExists Property

public override Boolean EmbeddedObjectExists {get;}

See Also

AptifyDataField Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


EncryptedData Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataField.EncryptedData Property

Property returning the encrypted data.

public override String EncryptedData {get;}

Remarks

See Also

AptifyDataField Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


IsDirty Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataField.IsDirty Property

Property returning if the field is in a Dirty state, indicating if it has changed since last saved.

public override Boolean IsDirty {get;}

Remarks

See Also

AptifyDataField Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


NeverSet Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataField.NeverSet Property

Property representing if the field has been set within this instance of the GE.

public override Boolean NeverSet {get;}

Remarks

See Also

AptifyDataField Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


SecurityKeyObject Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataField.SecurityKeyObject Property

protected AptifySecurityKey SecurityKeyObject {get;}

See Also

AptifyDataField Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


UpdateableThroughEmbedded Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataField.UpdateableThroughEmbedded Property

Determines if this Field is updateable from a GUI.

public override Boolean UpdateableThroughEmbedded {get;}

Property Value

Remarks

If a field is virtual field, then it would not normally be considered updateable. If a field is related to an embedded field, then it will be considered updateable if the field is updateable on the embedded entity.

See Also

AptifyDataField Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


UserCanEdit Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataField.UserCanEdit Property

Property representing user edit permissions on this field.

public override Boolean UserCanEdit {get;}

Remarks

See Also

AptifyDataField Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


UserCanRead Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataField.UserCanRead Property

Property representing user read permissions on this field.

public override Boolean UserCanRead {get;}

Property Value

Remarks

See Also

AptifyDataField Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


Object Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataField.Object Property

Property representing the field value.

Overload List

Property representing the field value.

public override Object Value {get; set;}

Property representing the field value. Allows for passing a boolean which requests that the calling object refresh the GE with the current value. Used by the aptify windows controls.

public override Object this[Boolean] {get; set;}

See Also

AptifyDataField Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


Value Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataField.Value Property

Property representing the field value.

public override Object Value {get; set;}

Remarks

See Also

AptifyDataField Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyDataField.Object Overload List


Value Property (Boolean)

Aptify 5.0 Software Development Kit (SDK)

AptifyDataField.Value Property (Boolean)

Property representing the field value. Allows for passing a boolean which requests that the calling object refresh the GE with the current value. Used by the aptify windows controls.

public override Object this[
Boolean ForceRefresh
] {get; set;}

Parameters

ForceRefresh

Property Value

Remarks

See Also

AptifyDataField Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyDataField.Object Overload List


AptifyDataField Methods

The methods of the AptifyDataField class are listed below. For a complete list of AptifyDataField class members, see the AptifyDataField Members topic.

Public Instance Methods

ClearDirty | Clears dirty flags set at the field level indicating that this field’s value in the Generic Entity is no longer out of synch with the database.
Clone | Clones a data field object.
DynamicSharingRelationshipExists (inherited from AptifyDataFieldBase) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDataString | Method that retrieves the XML markup for this field and its value.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLastError | Returns the most recent error from the error object.
GetOldValue | Returns the value of the field as of the most recent save of the record, either in this session or as loaded from the database.
GetProcFormat | Returns the representation of how this field will be formatted in Update and Insert stored procedure calls.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEmbeddedObjectBlank | Determines whether or not an Embedded Object exists and, if it does determines whether or not any field has been changed from the default. If this method is called on a field that does not support an Embedded Link, an exception will be thrown.
IsTime | Validate if given string is valid Time value or not.
Revert | Restores the in-memory value of the field to its last known value.
SaveEmbeddedObject | Overloaded.
SetValue | Overloaded. Method allows programmer to assign a value to the field object.
ToString (inherited from Object) | Returns a String that represents the current Object.
Validate | Method that validates the field based on the standard validation rules.
ValidateEmbeddedObject | Overloaded.

Protected Instance Methods

DoDecryptData |
DoEncryptData |
DoFormat (inherited from AptifyDataFieldBase) |
ExecuteScript | This function will Initialize the Script Engine Based on the [Field] Script Type.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
LoadEmbeddedObject | Loads the Embedded Generic Entity object when requested by the internal operations of the AptifyDataField object. If the EmbeddedObject Property is referenced, this method will be called in the Embedded GE object is not already loaded.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterClone (inherited from AptifyDataFieldBase) | Verifies whether or not the AfterClone event should be fired. If the event should be fired, it is fired.
OnAfterLoadEmbeddedObject (inherited from AptifyDataFieldBase) | Fired after an Embedded Linked Data Field's Embedded Object is created. Note the event will only be fired if the Data Field's EventsToFire property setting includes the LoadEmbedded Events.
OnAfterValidate (inherited from AptifyDataFieldBase) | Verifies whether or not the AfterValidate event should be fired. If the event should be fired, it is fired.
OnAfterValueChanged (inherited from AptifyDataFieldBase) | Verifies whether or not the AfterValueChanged event should be fired. If the event should be fired, it is fired.
OnBeforeClone (inherited from AptifyDataFieldBase) | Verifies whether or not the BeforeClone event should be fired. If the event should be fired, it is fired.
OnBeforeLoadEmbeddedObject (inherited from AptifyDataFieldBase) | Verifies whether or not the BeforeLoadEmbeddedObject event should be fired. If the event should be fired, it is fired.
OnBeforeValidate (inherited from AptifyDataFieldBase) | Verifies whether or not the BeforeValidate event should be fired. If the event should be fired, it is fired.
OnBeforeValueChanged (inherited from AptifyDataFieldBase) | Verifies whether or not the BeforeValueChanged event should be fired. If the event should be fired, it is fired.
OnRequestForLatestValue (inherited from AptifyDataFieldBase) | Verifies whether or not the BeforeValueChanged event should be fired. If the event should be fired, it is fired.
WrapField |

See Also

AptifyDataField Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataField.ClearDirty Method

Clears dirty flags set at the field level indicating that this field’s value in the Generic Entity is no longer out of synch with the database.

public override void ClearDirty();

Remarks

See Also

AptifyDataField Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataField.Clone Method

Clones a data field object.

public override void Clone(
AptifyDataFieldBase Field
);

Parameters

Field

Remarks

See Also

AptifyDataField Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataField.DoDecryptData Method

protected void DoDecryptData(
Int64 KeyID,
Object EncryptedDataValue,
ref Object& Data
);

See Also

AptifyDataField Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataField.DoEncryptData Method

protected void DoEncryptData(
Int64 KeyID,
Object Data,
ref Object& EncryptedDataValue
);

See Also

AptifyDataField Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataField.ExecuteScript Method

This function will Initialize the Script Engine Based on the [Field] Script Type.

protected virtual ValidationScriptResult ExecuteScript(
String ScriptToExecute
);

Parameters

ScriptToExecute
Ad-Hoc VB Script

Return Value

This will return an instantiated ValidationScriptResult that contains the result of the script execution.

Remarks

If you want to use a Script Type other than [Field], then this should be overriden. This can also be overriden if you would like multiple script types to be run. This script will have a 60 second timeout by default. You can modify this value by changing the attribute in the attribute manager.

       'We do not allow the key value to change once we save.
       If geRecord.RecordID > 0 Then
           'This is an existing record
           'Check to see if the value has changed
           If geRecord.Fields("KeyValue").IsDirty Then
               oResult.Success = False
               oResult.Message = "Once a key has been saved you may not change its value."
           Else
               oResult.Message = "There were no problems with the KeyValue"
               oResult.Success = True
           End If
       Else
           oResult.Message = "This is a new record we do not need to validate the KeyValue."
           oResult.Success = True
       End If

See Also

AptifyDataField Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataField.GetDataString Method

Method that retrieves the XML markup for this field and its value.

public override string GetDataString();

Return Value

Remarks

See Also

AptifyDataField Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataField.GetLastError Method

Returns the most recent error from the error object.

public override string GetLastError();

Return Value

Remarks

See Also

AptifyDataField Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataField.GetOldValue Method

Returns the value of the field as of the most recent save of the record, either in this session or as loaded from the database.

public override object GetOldValue();

Return Value

Remarks

See Also

AptifyDataField Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataField.GetProcFormat Method

Returns the representation of how this field will be formatted in Update and Insert stored procedure calls.

public override string GetProcFormat();

See Also

AptifyDataField Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataField.IsEmbeddedObjectBlank Method

Determines whether or not an Embedded Object exists and, if it does determines whether or not any field has been changed from the default. If this method is called on a field that does not support an Embedded Link, an exception will be thrown.

public override bool IsEmbeddedObjectBlank();

Return Value

True, if the Embedded Object has not been loaded or, if it has been loaded, all fields values are blank or match the default values.

Remarks

See Also

AptifyDataField Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataField.IsTime Method

Validate if given string is valid Time value or not.

public bool IsTime(
String argInputString
);

Parameters

argInputString

Return Value

Remarks

See Also

AptifyDataField Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataField.LoadEmbeddedObject Method

Loads the Embedded Generic Entity object when requested by the internal operations of the AptifyDataField object. If the EmbeddedObject Property is referenced, this method will be called in the Embedded GE object is not already loaded.

protected virtual void LoadEmbeddedObject();

Remarks

See Also

AptifyDataField Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataField.Revert Method

Restores the in-memory value of the field to its last known value.

public override void Revert();

Remarks

See Also

AptifyDataField Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


SaveEmbeddedObject Method

Aptify 5.0 Software Development Kit (SDK)

AptifyDataField.SaveEmbeddedObject Method

Overload List

public override bool SaveEmbeddedObject();

public override bool SaveEmbeddedObject(Boolean);

public override bool SaveEmbeddedObject(Boolean,ref String&);

public override bool SaveEmbeddedObject(Boolean,ref String&,String);

public override bool SaveEmbeddedObject(ref String&);

See Also

AptifyDataField Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataField.SaveEmbeddedObject Method ()

public override bool SaveEmbeddedObject();

See Also

AptifyDataField Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyDataField.SaveEmbeddedObject Overload List


AptifyDataField.SaveEmbeddedObject Method (Boolean)

public override bool SaveEmbeddedObject(
Boolean AllowGUI
);

See Also

AptifyDataField Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyDataField.SaveEmbeddedObject Overload List


AptifyDataField.SaveEmbeddedObject Method (Boolean, String&)

public override bool SaveEmbeddedObject(
Boolean AllowGUI,
ref String& ErrorString
);

See Also

AptifyDataField Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyDataField.SaveEmbeddedObject Overload List


AptifyDataField.SaveEmbeddedObject Method (Boolean, String&, String)

public override bool SaveEmbeddedObject(
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

See Also

AptifyDataField Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyDataField.SaveEmbeddedObject Overload List


AptifyDataField.SaveEmbeddedObject Method (String&)

public override bool SaveEmbeddedObject(
ref String& ErrorString
);

See Also

AptifyDataField Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyDataField.SaveEmbeddedObject Overload List


SetValue Method

Aptify 5.0 Software Development Kit (SDK)

AptifyDataField.SetValue Method

Method allows programmer to assign a value to the field object.

Overload List

Method allows programmer to assign a value to the field object.

public override void SetValue(Object);

Method allows programmer to assign a value to the field object.

public override void SetValue(Object,Boolean);

See Also

AptifyDataField Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataField.SetValue Method (Object)

Method allows programmer to assign a value to the field object.

public override void SetValue(
Object Value
);

Parameters

Value

Remarks

See Also

AptifyDataField Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyDataField.SetValue Overload List


AptifyDataField.SetValue Method (Object, Boolean)

Method allows programmer to assign a value to the field object.

public override void SetValue(
Object Value,
Boolean LoadedValue
);

Parameters

Value
LoadedValue

Remarks

See Also

AptifyDataField Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyDataField.SetValue Overload List


AptifyDataField.Validate Method

Method that validates the field based on the standard validation rules.

public override bool Validate();

Return Value

Returns True if validation succeeded.

See Also

AptifyDataField Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ValidateEmbeddedObject Method

Aptify 5.0 Software Development Kit (SDK)

AptifyDataField.ValidateEmbeddedObject Method

Overload List

public override bool ValidateEmbeddedObject();

public override bool ValidateEmbeddedObject(ref String&);

See Also

AptifyDataField Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataField.ValidateEmbeddedObject Method ()

public override bool ValidateEmbeddedObject();

See Also

AptifyDataField Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyDataField.ValidateEmbeddedObject Overload List


AptifyDataField.ValidateEmbeddedObject Method (String&)

public override bool ValidateEmbeddedObject(
ref String& ErrorString
);

See Also

AptifyDataField Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyDataField.ValidateEmbeddedObject Overload List


AptifyDataField.WrapField Method

protected override string WrapField();

See Also

AptifyDataField Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataFieldBase Class

For a list of all members of this type, see AptifyDataFieldBase Members.

System.Object
AptifyDataFieldBase
AptifyDataField

public class AptifyDataFieldBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

AptifyDataFieldBase Members | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataFieldBase Members

AptifyDataFieldBase overview

Public Instance Constructors

AptifyDataFieldBase Overloaded. Initializes a new instance of the AptifyDataFieldBase class.

Public Instance Properties

Alignment |
AllowedSearchMethods |
AllowSorting |
BaseTable | Get base table name for this field.
Category |
CurrencyTypeField |
CurrencyTypeFieldObject |
CustomGUIObjRepLoc |
CustomGUIProgID |
DefaultInView |
DefaultValue |
Description |
DisplayCultureString |
DisplayCultureStringID |
DisplayName |
DisplayNameWCulture | Overloaded.
EmbeddedLinkTypeSharingMode |
EmbeddedObject |
EmbeddedObjectExists |
EncryptData |
EncryptedData |
EventsToFire | Used to configure the Events that will be fired by the Data Field object.
ExtendedType |
FieldValues |
GUITypeMultiSelect |
GUITypeSingleSelect |
HelpObject |
HelpText |
HelpURL |
InputMask |
InputMaskType |
InTable |
IsDirty |
IsInstalled |
IsNameField |
IsRequired |
IsSequence |
IsSystem |
IsValidated |
JoinedEntity |
JoinedField |
JoinForeignKey |
JoinType |
LinkedEntity |
LinkedEntityField |
LinkType |
Name |
NeedsQuotes |
NeedToRefreshLinkedFields |
NeverSet |
ParamName |
ParentGE |
ParentLinkedValue |
SecurityKeyID |
ShowInFind |
spDynamicFlowdown |
SQLAllowNull |
SQLDataType |
SQLFieldPrecision |
SQLFieldScale |
SQLFieldSize |
SupportsMultipleCurrencies |
TextInterpretationMode |
Type |
Updateable | Returns the Updateable Value that exists in the EntityFields metadata.
UpdateableThroughEmbedded | Determines if this Field is updateable through the use of an embedded field.
UserCanEdit |
UserCanRead |
ValidationRangeDateLowerBound |
ValidationRangeDateUpperBound |
ValidationRangeLowerBound |
ValidationRangeUpperBound |
ValidationScript |
ValidationType |
Value | Overloaded.
ValueListType |
VirtualFieldCalculation |
VirtualFieldType |
Width |

Public Instance Methods

ClearDirty |
Clone |
DynamicSharingRelationshipExists |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDataString |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLastError |
GetOldValue |
GetProcFormat |
GetType (inherited from Object) | Gets the Type of the current instance.
IsEmbeddedObjectBlank |
Revert |
SaveEmbeddedObject | Overloaded.
SetValue | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.
Validate |
ValidateEmbeddedObject | Overloaded.

Public Instance Events

AfterClone | Fired when the Data Field's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Data Field's EventsToFire property setting includes the Clone Events.
AfterLoadEmbeddedObject | Fired after an Embedded Linked Data Field's Embedded Object is created. Note the event will only be fired if the Data Field's EventsToFire property setting includes the LoadEmbedded Events.
AfterValidate | Fired when the Data Field's Validate method is called and after the internal validation logic has executed. Note the event will only be fired if the Data Field's EventsToFire property setting includes the Validate Events.
AfterValueChanged | Fired after the Value of a Data Field object has changed. Note the event will only be fired if the Data Field's EventsToFire property setting includes the ValueChanged Event.
BeforeClone | Fired when the Data Field's Clone method is called, before the Clone occurs. Note the event will only be fired if the Data Field's EventsToFire property setting includes the Clone Events.
BeforeLoadEmbeddedObject | Fired just prior to an Embedded Linked Data Field's Embedded Object creation. Note the event will only be fired if the Data Field's EventsToFire property setting includes the LoadEmbedded Events.
BeforeValidate | Fired when the Data Field's Validate method is called, before the internal validation logic has executed. Note the event will only be fired if the Data Field's EventsToFire property setting includes the Validate Events.
BeforeValueChanged | Fired when the Value of a Data Field object is changed but before the change is applied. Note the event will only be fired if the Data Field's EventsToFire property setting includes the ValueChanged Event.
RequestForLatestValue | Fired when an internal operation to the GE requires the most up-to-date value, particularly from the UI.

Protected Instance Properties

TemporaryField

Protected Instance Methods

DoFormat |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterClone | Verifies whether or not the AfterClone event should be fired. If the event should be fired, it is fired.
OnAfterLoadEmbeddedObject | Fired after an Embedded Linked Data Field's Embedded Object is created. Note the event will only be fired if the Data Field's EventsToFire property setting includes the LoadEmbedded Events.
OnAfterValidate | Verifies whether or not the AfterValidate event should be fired. If the event should be fired, it is fired.
OnAfterValueChanged | Verifies whether or not the AfterValueChanged event should be fired. If the event should be fired, it is fired.
OnBeforeClone | Verifies whether or not the BeforeClone event should be fired. If the event should be fired, it is fired.
OnBeforeLoadEmbeddedObject | Verifies whether or not the BeforeLoadEmbeddedObject event should be fired. If the event should be fired, it is fired.
OnBeforeValidate | Verifies whether or not the BeforeValidate event should be fired. If the event should be fired, it is fired.
OnBeforeValueChanged | Verifies whether or not the BeforeValueChanged event should be fired. If the event should be fired, it is fired.
OnRequestForLatestValue | Verifies whether or not the BeforeValueChanged event should be fired. If the event should be fired, it is fired.
WrapField |

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataFieldBase Constructor

Overload List

public AptifyDataFieldBase(AptifyGenericEntityBase,String);

public AptifyDataFieldBase(AptifyGenericEntityBase,String,Boolean);

public AptifyDataFieldBase(AptifyGenericEntityBase,String,Boolean,String);

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataFieldBase Constructor (AptifyGenericEntityBase, String)

public AptifyDataFieldBase(
AptifyGenericEntityBase GE,
String FieldName
);

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyDataFieldBase Constructor Overload List


AptifyDataFieldBase Constructor (AptifyGenericEntityBase, String, Boolean)

public AptifyDataFieldBase(
AptifyGenericEntityBase GE,
String FieldName,
Boolean TemporaryField
);

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyDataFieldBase Constructor Overload List


AptifyDataFieldBase Constructor (AptifyGenericEntityBase, String, Boolean, String)

public AptifyDataFieldBase(
AptifyGenericEntityBase GE,
String FieldName,
Boolean TemporaryField,
String TemporaryFieldDataType
);

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyDataFieldBase Constructor Overload List


AptifyDataFieldBase Properties

The properties of the AptifyDataFieldBase class are listed below. For a complete list of AptifyDataFieldBase class members, see the AptifyDataFieldBase Members topic.

Public Instance Properties

Alignment |
AllowedSearchMethods |
AllowSorting |
BaseTable | Get base table name for this field.
Category |
CurrencyTypeField |
CurrencyTypeFieldObject |
CustomGUIObjRepLoc |
CustomGUIProgID |
DefaultInView |
DefaultValue |
Description |
DisplayCultureString |
DisplayCultureStringID |
DisplayName |
DisplayNameWCulture | Overloaded.
EmbeddedLinkTypeSharingMode |
EmbeddedObject |
EmbeddedObjectExists |
EncryptData |
EncryptedData |
EventsToFire | Used to configure the Events that will be fired by the Data Field object.
ExtendedType |
FieldValues |
GUITypeMultiSelect |
GUITypeSingleSelect |
HelpObject |
HelpText |
HelpURL |
InputMask |
InputMaskType |
InTable |
IsDirty |
IsInstalled |
IsNameField |
IsRequired |
IsSequence |
IsSystem |
IsValidated |
JoinedEntity |
JoinedField |
JoinForeignKey |
JoinType |
LinkedEntity |
LinkedEntityField |
LinkType |
Name |
NeedsQuotes |
NeedToRefreshLinkedFields |
NeverSet |
ParamName |
ParentGE |
ParentLinkedValue |
SecurityKeyID |
ShowInFind |
spDynamicFlowdown |
SQLAllowNull |
SQLDataType |
SQLFieldPrecision |
SQLFieldScale |
SQLFieldSize |
SupportsMultipleCurrencies |
TextInterpretationMode |
Type |
Updateable | Returns the Updateable Value that exists in the EntityFields metadata.
UpdateableThroughEmbedded | Determines if this Field is updateable through the use of an embedded field.
UserCanEdit |
UserCanRead |
ValidationRangeDateLowerBound |
ValidationRangeDateUpperBound |
ValidationRangeLowerBound |
ValidationRangeUpperBound |
ValidationScript |
ValidationType |
Value | Overloaded.
ValueListType |
VirtualFieldCalculation |
VirtualFieldType |
Width |

Protected Instance Properties

TemporaryField

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


Alignment Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.Alignment Property

public virtual FieldAlignment Alignment {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AllowedSearchMethods Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.AllowedSearchMethods Property

public virtual AllowedSearchMethod AllowedSearchMethods {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AllowSorting Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.AllowSorting Property

public virtual Boolean AllowSorting {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


BaseTable Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.BaseTable Property

Get base table name for this field.

public virtual String BaseTable {get;}

Property Value

Remarks

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


Category Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.Category Property

public virtual String Category {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


CurrencyTypeField Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.CurrencyTypeField Property

public virtual String CurrencyTypeField {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


CurrencyTypeFieldObject Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.CurrencyTypeFieldObject Property

public virtual AptifyDataFieldBase CurrencyTypeFieldObject {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


CustomGUIObjRepLoc Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.CustomGUIObjRepLoc Property

public virtual String CustomGUIObjRepLoc {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


CustomGUIProgID Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.CustomGUIProgID Property

public virtual String CustomGUIProgID {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


DefaultInView Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.DefaultInView Property

public virtual Boolean DefaultInView {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


DefaultValue Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.DefaultValue Property

public virtual Object DefaultValue {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


Description Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.Description Property

public virtual String Description {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


DisplayCultureString Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.DisplayCultureString Property

public virtual String DisplayCultureString {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


DisplayCultureStringID Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.DisplayCultureStringID Property

public virtual Int64 DisplayCultureStringID {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


DisplayName Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.DisplayName Property

public virtual String DisplayName {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


String Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.String Property

Overload List

public virtual String DisplayNameWCulture {get;}

public virtual String this[Boolean] {get;}

public virtual String this[Int64] {get;}

public virtual String this[Int64, Boolean] {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


DisplayNameWCulture Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.DisplayNameWCulture Property

public virtual String DisplayNameWCulture {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyDataFieldBase.String Overload List


DisplayNameWCulture Property (Boolean)

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.DisplayNameWCulture Property (Boolean)

public virtual String this[
Boolean AutoMapDisplayName
] {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyDataFieldBase.String Overload List


DisplayNameWCulture Property (Int64)

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.DisplayNameWCulture Property (Int64)

public virtual String this[
Int64 CultureID
] {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyDataFieldBase.String Overload List


DisplayNameWCulture Property (Int64, Boolean)

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.DisplayNameWCulture Property (Int64, Boolean)

public virtual String this[
Int64 CultureID,
Boolean AutoMapDisplayName
] {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyDataFieldBase.String Overload List


EmbeddedLinkTypeSharingMode Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.EmbeddedLinkTypeSharingMode Property

public virtual EmbeddedLinkSharingMode EmbeddedLinkTypeSharingMode {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


EmbeddedObject Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.EmbeddedObject Property

public abstract AptifyGenericEntityBase EmbeddedObject {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


EmbeddedObjectExists Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.EmbeddedObjectExists Property

public abstract Boolean EmbeddedObjectExists {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


EncryptData Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.EncryptData Property

public virtual Boolean EncryptData {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


EncryptedData Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.EncryptedData Property

public abstract String EncryptedData {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


EventsToFire Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.EventsToFire Property

Used to configure the Events that will be fired by the Data Field object.

public AptifyDataFieldBase.AptifyDataFieldEvents EventsToFire {get; set;}

Property Value

Remarks

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ExtendedType Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.ExtendedType Property

public virtual String ExtendedType {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


FieldValues Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.FieldValues Property

public virtual EntityFieldValueMetaDataList FieldValues {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GUITypeMultiSelect Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.GUITypeMultiSelect Property

public virtual FieldGUITypeMultiSelect GUITypeMultiSelect {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GUITypeSingleSelect Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.GUITypeSingleSelect Property

public virtual FieldGUITypeSingleSelect GUITypeSingleSelect {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


HelpObject Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.HelpObject Property

public virtual String HelpObject {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


HelpText Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.HelpText Property

public virtual String HelpText {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


HelpURL Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.HelpURL Property

public virtual String HelpURL {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


InputMask Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.InputMask Property

public virtual String InputMask {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


InputMaskType Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.InputMaskType Property

public virtual InputMaskType InputMaskType {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


InTable Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.InTable Property

public virtual Boolean InTable {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


IsDirty Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.IsDirty Property

public abstract Boolean IsDirty {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


IsInstalled Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.IsInstalled Property

public virtual Boolean IsInstalled {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


IsNameField Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.IsNameField Property

public virtual Boolean IsNameField {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


IsRequired Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.IsRequired Property

public virtual Boolean IsRequired {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


IsSequence Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.IsSequence Property

public virtual Boolean IsSequence {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


IsSystem Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.IsSystem Property

public virtual Boolean IsSystem {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


IsValidated Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.IsValidated Property

public virtual Boolean IsValidated {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


JoinedEntity Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.JoinedEntity Property

public virtual String JoinedEntity {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


JoinedField Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.JoinedField Property

public virtual String JoinedField {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


JoinForeignKey Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.JoinForeignKey Property

public virtual String JoinForeignKey {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


JoinType Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.JoinType Property

public virtual String JoinType {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


LinkedEntity Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.LinkedEntity Property

public virtual String LinkedEntity {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


LinkedEntityField Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.LinkedEntityField Property

public virtual String LinkedEntityField {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


LinkType Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.LinkType Property

public virtual FieldLinkType LinkType {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


Name Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.Name Property

public virtual String Name {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


NeedsQuotes Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.NeedsQuotes Property

public virtual Boolean NeedsQuotes {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


NeedToRefreshLinkedFields Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.NeedToRefreshLinkedFields Property

public virtual Boolean NeedToRefreshLinkedFields {get; set;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


NeverSet Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.NeverSet Property

public abstract Boolean NeverSet {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ParamName Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.ParamName Property

public virtual String ParamName {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ParentGE Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.ParentGE Property

public AptifyGenericEntityBase ParentGE {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ParentLinkedValue Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.ParentLinkedValue Property

public virtual String ParentLinkedValue {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


SecurityKeyID Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.SecurityKeyID Property

public virtual Int64 SecurityKeyID {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ShowInFind Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.ShowInFind Property

public virtual Boolean ShowInFind {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


spDynamicFlowdown Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.spDynamicFlowdown Property

public virtual String spDynamicFlowdown {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


SQLAllowNull Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.SQLAllowNull Property

public virtual Boolean SQLAllowNull {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


SQLDataType Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.SQLDataType Property

public virtual String SQLDataType {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


SQLFieldPrecision Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.SQLFieldPrecision Property

public virtual Int32 SQLFieldPrecision {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


SQLFieldScale Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.SQLFieldScale Property

public virtual Int32 SQLFieldScale {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


SQLFieldSize Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.SQLFieldSize Property

public virtual Int32 SQLFieldSize {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


SupportsMultipleCurrencies Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.SupportsMultipleCurrencies Property

public virtual Boolean SupportsMultipleCurrencies {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


TemporaryField Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.TemporaryField Property

protected virtual Boolean TemporaryField {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


TextInterpretationMode Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.TextInterpretationMode Property

public virtual TextInterpretationMode TextInterpretationMode {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


Type Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.Type Property

public virtual FieldGenericDataType Type {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


Updateable Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.Updateable Property

Returns the Updateable Value that exists in the EntityFields metadata.

public virtual Boolean Updateable {get;}

Property Value

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


UpdateableThroughEmbedded Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.UpdateableThroughEmbedded Property

Determines if this Field is updateable through the use of an embedded field.

public abstract Boolean UpdateableThroughEmbedded {get;}

Property Value

Remarks

If this field's Updateable property is true, then it will be considered UpdateableThroughEmbedded. If a field is virtual field, then it would not normally be considered updateable. If a field is related to an embedded field, then it will be considered updateable if the field is updateable on the embedded entity.

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


UserCanEdit Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.UserCanEdit Property

public abstract Boolean UserCanEdit {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


UserCanRead Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.UserCanRead Property

public abstract Boolean UserCanRead {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ValidationRangeDateLowerBound Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.ValidationRangeDateLowerBound Property

public virtual DateTime ValidationRangeDateLowerBound {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ValidationRangeDateUpperBound Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.ValidationRangeDateUpperBound Property

public virtual DateTime ValidationRangeDateUpperBound {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ValidationRangeLowerBound Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.ValidationRangeLowerBound Property

public virtual Double ValidationRangeLowerBound {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ValidationRangeUpperBound Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.ValidationRangeUpperBound Property

public virtual Double ValidationRangeUpperBound {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ValidationScript Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.ValidationScript Property

public virtual String ValidationScript {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ValidationType Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.ValidationType Property

public virtual String ValidationType {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


Object Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.Object Property

Overload List

public abstract Object Value {get; set;}

public abstract Object this[Boolean] {get; set;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


Value Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.Value Property

public abstract Object Value {get; set;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyDataFieldBase.Object Overload List


Value Property (Boolean)

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.Value Property (Boolean)

public abstract Object this[
Boolean ForceRefresh
] {get; set;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyDataFieldBase.Object Overload List


ValueListType Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.ValueListType Property

public virtual FieldValueListType ValueListType {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


VirtualFieldCalculation Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.VirtualFieldCalculation Property

public virtual String VirtualFieldCalculation {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


VirtualFieldType Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.VirtualFieldType Property

public virtual String VirtualFieldType {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


Width Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.Width Property

public virtual Int32 Width {get;}

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataFieldBase Methods

The methods of the AptifyDataFieldBase class are listed below. For a complete list of AptifyDataFieldBase class members, see the AptifyDataFieldBase Members topic.

Public Instance Methods

ClearDirty |
Clone |
DynamicSharingRelationshipExists |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDataString |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLastError |
GetOldValue |
GetProcFormat |
GetType (inherited from Object) | Gets the Type of the current instance.
IsEmbeddedObjectBlank |
Revert |
SaveEmbeddedObject | Overloaded.
SetValue | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.
Validate |
ValidateEmbeddedObject | Overloaded.

Protected Instance Methods

DoFormat |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterClone | Verifies whether or not the AfterClone event should be fired. If the event should be fired, it is fired.
OnAfterLoadEmbeddedObject | Fired after an Embedded Linked Data Field's Embedded Object is created. Note the event will only be fired if the Data Field's EventsToFire property setting includes the LoadEmbedded Events.
OnAfterValidate | Verifies whether or not the AfterValidate event should be fired. If the event should be fired, it is fired.
OnAfterValueChanged | Verifies whether or not the AfterValueChanged event should be fired. If the event should be fired, it is fired.
OnBeforeClone | Verifies whether or not the BeforeClone event should be fired. If the event should be fired, it is fired.
OnBeforeLoadEmbeddedObject | Verifies whether or not the BeforeLoadEmbeddedObject event should be fired. If the event should be fired, it is fired.
OnBeforeValidate | Verifies whether or not the BeforeValidate event should be fired. If the event should be fired, it is fired.
OnBeforeValueChanged | Verifies whether or not the BeforeValueChanged event should be fired. If the event should be fired, it is fired.
OnRequestForLatestValue | Verifies whether or not the BeforeValueChanged event should be fired. If the event should be fired, it is fired.
WrapField |

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataFieldBase.ClearDirty Method

public abstract void ClearDirty();

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataFieldBase.Clone Method

public abstract void Clone(
AptifyDataFieldBase Field
);

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataFieldBase.DoFormat Method

protected object DoFormat(
Object unformattedValue
);

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataFieldBase.DynamicSharingRelationshipExists Method

public virtual bool DynamicSharingRelationshipExists(
Int64 OwnerEntityID
);

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataFieldBase.GetDataString Method

public abstract string GetDataString();

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataFieldBase.GetLastError Method

public abstract string GetLastError();

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataFieldBase.GetOldValue Method

public abstract object GetOldValue();

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataFieldBase.GetProcFormat Method

public abstract string GetProcFormat();

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataFieldBase.IsEmbeddedObjectBlank Method

public abstract bool IsEmbeddedObjectBlank();

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataFieldBase.OnAfterClone Method

Verifies whether or not the AfterClone event should be fired. If the event should be fired, it is fired.

protected virtual void OnAfterClone();

Remarks

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataFieldBase.OnAfterLoadEmbeddedObject Method

Fired after an Embedded Linked Data Field's Embedded Object is created. Note the event will only be fired if the Data Field's EventsToFire property setting includes the LoadEmbedded Events.

protected virtual void OnAfterLoadEmbeddedObject(
ref AptifyGenericEntityBase& EmbeddedGE
);

Remarks

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataFieldBase.OnAfterValidate Method

Verifies whether or not the AfterValidate event should be fired. If the event should be fired, it is fired.

protected void OnAfterValidate(
ref Boolean& IsValid,
ref String& ErrorString
);

Parameters

IsValid
A boolean flag that indicates whether or not the Validation routine found the field valid.
ErrorString
Contains the error string resulting from the execution of the Data Field's Validate method. An event handler can alter this string and it will be passed back to the Data Field. If ErrorString is not an empty string, the Validate method will return false.

Remarks

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataFieldBase.OnAfterValueChanged Method

Verifies whether or not the AfterValueChanged event should be fired. If the event should be fired, it is fired.

protected void OnAfterValueChanged(
String FieldName,
Object OldValue,
Object NewValue
);

Parameters

FieldName
OldValue
NewValue

Remarks

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataFieldBase.OnBeforeClone Method

Verifies whether or not the BeforeClone event should be fired. If the event should be fired, it is fired.

protected virtual bool OnBeforeClone(
AptifyDataFieldBase FieldToClone
);

Parameters

FieldToClone

Return Value

Returns false if the BeforeClone event handler set Cancel property to True or if an exception was raised by the event handler. Otherwise, returns True.

Remarks

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataFieldBase.OnBeforeLoadEmbeddedObject Method

Verifies whether or not the BeforeLoadEmbeddedObject event should be fired. If the event should be fired, it is fired.

protected virtual bool OnBeforeLoadEmbeddedObject();

Return Value

Returns false if the BeforeLoadEmbeddedObject event handler set Cancel property to True or if an exception was raised by the event handler. Otherwise, returns True.

Remarks

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataFieldBase.OnBeforeValidate Method

Verifies whether or not the BeforeValidate event should be fired. If the event should be fired, it is fired.

protected bool OnBeforeValidate(
ref String& ErrorString
);

Parameters

ErrorString

Return Value

Returns false if the BeforeValidate event handler set Cancel property to True or if an exception was raised by the event handler. Otherwise, returns True.

Remarks

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataFieldBase.OnBeforeValueChanged Method

Verifies whether or not the BeforeValueChanged event should be fired. If the event should be fired, it is fired.

protected bool OnBeforeValueChanged(
String FieldName,
Object OldValue,
ref Object& NewValue
);

Parameters

FieldName
OldValue
NewValue

Return Value

Remarks

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataFieldBase.OnRequestForLatestValue Method

Verifies whether or not the BeforeValueChanged event should be fired. If the event should be fired, it is fired.

protected void OnRequestForLatestValue(
String FieldName,
Object CurrentValue
);

Parameters

FieldName
CurrentValue

Remarks

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataFieldBase.Revert Method

public abstract void Revert();

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


SaveEmbeddedObject Method

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.SaveEmbeddedObject Method

Overload List

public abstract bool SaveEmbeddedObject();

public abstract bool SaveEmbeddedObject(Boolean);

public abstract bool SaveEmbeddedObject(Boolean,ref String&);

public abstract bool SaveEmbeddedObject(Boolean,ref String&,String);

public abstract bool SaveEmbeddedObject(ref String&);

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataFieldBase.SaveEmbeddedObject Method ()

public abstract bool SaveEmbeddedObject();

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyDataFieldBase.SaveEmbeddedObject Overload List


AptifyDataFieldBase.SaveEmbeddedObject Method (Boolean)

public abstract bool SaveEmbeddedObject(
Boolean AllowGUI
);

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyDataFieldBase.SaveEmbeddedObject Overload List


AptifyDataFieldBase.SaveEmbeddedObject Method (Boolean, String&)

public abstract bool SaveEmbeddedObject(
Boolean AllowGUI,
ref String& ErrorString
);

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyDataFieldBase.SaveEmbeddedObject Overload List


AptifyDataFieldBase.SaveEmbeddedObject Method (Boolean, String&, String)

public abstract bool SaveEmbeddedObject(
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyDataFieldBase.SaveEmbeddedObject Overload List


AptifyDataFieldBase.SaveEmbeddedObject Method (String&)

public abstract bool SaveEmbeddedObject(
ref String& ErrorString
);

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyDataFieldBase.SaveEmbeddedObject Overload List


SetValue Method

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.SetValue Method

Overload List

public abstract void SetValue(Object);

public abstract void SetValue(Object,Boolean);

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataFieldBase.SetValue Method (Object)

public abstract void SetValue(
Object Value
);

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyDataFieldBase.SetValue Overload List


AptifyDataFieldBase.SetValue Method (Object, Boolean)

public abstract void SetValue(
Object Value,
Boolean LoadedValue
);

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyDataFieldBase.SetValue Overload List


AptifyDataFieldBase.Validate Method

public abstract bool Validate();

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ValidateEmbeddedObject Method

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldBase.ValidateEmbeddedObject Method

Overload List

public abstract bool ValidateEmbeddedObject();

public abstract bool ValidateEmbeddedObject(ref String&);

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataFieldBase.ValidateEmbeddedObject Method ()

public abstract bool ValidateEmbeddedObject();

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyDataFieldBase.ValidateEmbeddedObject Overload List


AptifyDataFieldBase.ValidateEmbeddedObject Method (String&)

public abstract bool ValidateEmbeddedObject(
ref String& ErrorString
);

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyDataFieldBase.ValidateEmbeddedObject Overload List


AptifyDataFieldBase.WrapField Method

protected abstract string WrapField();

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataFieldBase Events

The events of the AptifyDataFieldBase class are listed below. For a complete list of AptifyDataFieldBase class members, see the AptifyDataFieldBase Members topic.

Public Instance Events

AfterClone | Fired when the Data Field's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Data Field's EventsToFire property setting includes the Clone Events.
AfterLoadEmbeddedObject | Fired after an Embedded Linked Data Field's Embedded Object is created. Note the event will only be fired if the Data Field's EventsToFire property setting includes the LoadEmbedded Events.
AfterValidate | Fired when the Data Field's Validate method is called and after the internal validation logic has executed. Note the event will only be fired if the Data Field's EventsToFire property setting includes the Validate Events.
AfterValueChanged | Fired after the Value of a Data Field object has changed. Note the event will only be fired if the Data Field's EventsToFire property setting includes the ValueChanged Event.
BeforeClone | Fired when the Data Field's Clone method is called, before the Clone occurs. Note the event will only be fired if the Data Field's EventsToFire property setting includes the Clone Events.
BeforeLoadEmbeddedObject | Fired just prior to an Embedded Linked Data Field's Embedded Object creation. Note the event will only be fired if the Data Field's EventsToFire property setting includes the LoadEmbedded Events.
BeforeValidate | Fired when the Data Field's Validate method is called, before the internal validation logic has executed. Note the event will only be fired if the Data Field's EventsToFire property setting includes the Validate Events.
BeforeValueChanged | Fired when the Value of a Data Field object is changed but before the change is applied. Note the event will only be fired if the Data Field's EventsToFire property setting includes the ValueChanged Event.
RequestForLatestValue | Fired when an internal operation to the GE requires the most up-to-date value, particularly from the UI.

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataFieldBase.AptifyDataFieldBase.AfterCloneEventHandler Event

Fired when the Data Field's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Data Field's EventsToFire property setting includes the Clone Events.

public event AptifyDataFieldBase.AfterCloneEventHandler AfterClone;

Remarks

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataFieldBase.AptifyDataFieldBase.AfterLoadEmbeddedObjectEventHandler Event

Fired after an Embedded Linked Data Field's Embedded Object is created. Note the event will only be fired if the Data Field's EventsToFire property setting includes the LoadEmbedded Events.

public event AptifyDataFieldBase.AfterLoadEmbeddedObjectEventHandler AfterLoadEmbeddedObject;

Event Data

The event handler receives an argument of type AfterLoadEmbeddedObjectEventArgs containing data related to this event. The following AfterLoadEmbeddedObjectEventArgs property provides information specific to this event.

Property | Description
EmbeddedGE | A reference to the Embedded Object. The EmbeddedGE property can be changed by the Event Handler.

Remarks

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataFieldBase.AptifyDataFieldBase.AfterValidateEventHandler Event

Fired when the Data Field's Validate method is called and after the internal validation logic has executed. Note the event will only be fired if the Data Field's EventsToFire property setting includes the Validate Events.

public event AptifyDataFieldBase.AfterValidateEventHandler AfterValidate;

Event Data

The event handler receives an argument of type AfterDataFieldValidateEventArgs containing data related to this event. The following AfterDataFieldValidateEventArgs properties provide information specific to this event.

Property | Description
ErrorString | Contains the ErrorString populated by the Data Field's Validate routine. The ErrorString property can be changed by the Event Handler.
IsValid | A flag that indicates whether or not the Validate routine found the Data Field valid. The IsValid property can be changed by the Event Handler.

Remarks

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataFieldBase.AptifyDataFieldBase.AfterValueChangedEventHandler Event

Fired after the Value of a Data Field object has changed. Note the event will only be fired if the Data Field's EventsToFire property setting includes the ValueChanged Event.

public event AptifyDataFieldBase.AfterValueChangedEventHandler AfterValueChanged;

Event Data

The event handler receives an argument of type AfterValueChangedEventArgs containing data related to this event. The following AfterValueChangedEventArgs properties provide information specific to this event.

Property | Description
FieldName | Represents the name of the Data Field that was changed. If this is a field from an embedded object, the parent object's Embedded Link Name with a dot will be prefixed to the field name.
NewValue | Represents the value that was applied to the Data Field.
OldValue | Represents the value of the Data Field prior to the change.

Remarks

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataFieldBase.AptifyDataFieldBase.BeforeCloneEventHandler Event

Fired when the Data Field's Clone method is called, before the Clone occurs. Note the event will only be fired if the Data Field's EventsToFire property setting includes the Clone Events.

public event AptifyDataFieldBase.BeforeCloneEventHandler BeforeClone;

Event Data

The event handler receives an argument of type BeforeDataFieldCloneEventArgs containing data related to this event. The following BeforeDataFieldCloneEventArgs properties provide information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.
FieldToClone | Represents the Data Field object that will be cloned.

Remarks

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataFieldBase.AptifyDataFieldBase.BeforeLoadEmbeddedObjectEventHandler Event

Fired just prior to an Embedded Linked Data Field's Embedded Object creation. Note the event will only be fired if the Data Field's EventsToFire property setting includes the LoadEmbedded Events.

public event AptifyDataFieldBase.BeforeLoadEmbeddedObjectEventHandler BeforeLoadEmbeddedObject;

Remarks

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataFieldBase.AptifyDataFieldBase.BeforeValidateEventHandler Event

Fired when the Data Field's Validate method is called, before the internal validation logic has executed. Note the event will only be fired if the Data Field's EventsToFire property setting includes the Validate Events.

public event AptifyDataFieldBase.BeforeValidateEventHandler BeforeValidate;

Event Data

The event handler receives an argument of type BeforeDataFieldValidateEventArgs containing data related to this event. The following BeforeDataFieldValidateEventArgs properties provide information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.
ErrorString | Used to pass an error into the Validate routine. The Field's GetLastError method will return the ErrorString.

Remarks

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataFieldBase.AptifyDataFieldBase.BeforeValueChangedEventHandler Event

Fired when the Value of a Data Field object is changed but before the change is applied. Note the event will only be fired if the Data Field's EventsToFire property setting includes the ValueChanged Event.

public event AptifyDataFieldBase.BeforeValueChangedEventHandler BeforeValueChanged;

Event Data

The event handler receives an argument of type BeforeValueChangedEventArgs containing data related to this event. The following BeforeValueChangedEventArgs properties provide information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.
FieldName | Represents the name of the Data Field being changed. If this is a field from an embedded object, the parent object's Embedded Link Name with a dot will be prefixed to the field name.
NewValue | Represents the value that will apply to the Data Field if the change is allowed and successful.
OldValue | Represents the value of the Data Field prior to any change.

Remarks

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataFieldBase.AptifyDataFieldBase.RequestForLatestValueEventHandler Event

Fired when an internal operation to the GE requires the most up-to-date value, particularly from the UI.

public event AptifyDataFieldBase.RequestForLatestValueEventHandler RequestForLatestValue;

Remarks

See Also

AptifyDataFieldBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataFieldBase.AfterCloneEventHandler Delegate

public delegate void AptifyDataFieldBase.AfterCloneEventHandler(
AptifyDataFieldBase sender,
EventArgs e
);

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataFieldBase.AfterLoadEmbeddedObjectEventHandler Delegate

public delegate void AptifyDataFieldBase.AfterLoadEmbeddedObjectEventHandler(
AptifyDataFieldBase sender,
AfterLoadEmbeddedObjectEventArgs e
);

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataFieldBase.AfterValidateEventHandler Delegate

public delegate void AptifyDataFieldBase.AfterValidateEventHandler(
AptifyDataFieldBase sender,
AfterDataFieldValidateEventArgs e
);

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataFieldBase.AfterValueChangedEventHandler Delegate

public delegate void AptifyDataFieldBase.AfterValueChangedEventHandler(
AptifyDataFieldBase sender,
AfterValueChangedEventArgs e
);

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataFieldBase.AptifyDataFieldEvents Enumeration

Enumeration that identifies the different Event settings available on a Data Field.

public enum AptifyDataFieldBase.AptifyDataFieldEvents

Remarks

Members

Member Name | Description
None |
AllEvents |
ValueChanged |
Clone |
Validate |
LoadEmbedded |
UpdateRequests |

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataFieldBase.BeforeCloneEventHandler Delegate

public delegate void AptifyDataFieldBase.BeforeCloneEventHandler(
AptifyDataFieldBase sender,
BeforeDataFieldCloneEventArgs e
);

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataFieldBase.BeforeLoadEmbeddedObjectEventHandler Delegate

public delegate void AptifyDataFieldBase.BeforeLoadEmbeddedObjectEventHandler(
AptifyDataFieldBase sender,
CancelEventArgs e
);

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataFieldBase.BeforeValidateEventHandler Delegate

public delegate void AptifyDataFieldBase.BeforeValidateEventHandler(
AptifyDataFieldBase sender,
BeforeDataFieldValidateEventArgs e
);

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataFieldBase.BeforeValueChangedEventHandler Delegate

public delegate void AptifyDataFieldBase.BeforeValueChangedEventHandler(
AptifyDataFieldBase sender,
BeforeValueChangedEventArgs e
);

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataFieldBase.RequestForLatestValueEventHandler Delegate

public delegate void AptifyDataFieldBase.RequestForLatestValueEventHandler(
AptifyDataFieldBase sender,
RequestForLatestValueArgs e
);

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataFieldDoesNotExistException Class

For a list of all members of this type, see AptifyDataFieldDoesNotExistException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
AptifyGenericEntityException
AptifyDataFieldDoesNotExistException

public class AptifyDataFieldDoesNotExistException : AptifyGenericEntityException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

AptifyDataFieldDoesNotExistException Members | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataFieldDoesNotExistException Members

AptifyDataFieldDoesNotExistException overview

Public Instance Constructors

AptifyDataFieldDoesNotExistException Overloaded. Initializes a new instance of the AptifyDataFieldDoesNotExistException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Constructors

AptifyDataFieldDoesNotExistException Overloaded. Initializes a new instance of the AptifyDataFieldDoesNotExistException class.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyDataFieldDoesNotExistException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataFieldDoesNotExistException Constructor

Overload List

protected AptifyDataFieldDoesNotExistException(SerializationInfo,StreamingContext);

public AptifyDataFieldDoesNotExistException(String,String);

public AptifyDataFieldDoesNotExistException(String,String,Exception);

See Also

AptifyDataFieldDoesNotExistException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataFieldDoesNotExistException Constructor (String, String)

public AptifyDataFieldDoesNotExistException(
String Entity,
String Field
);

See Also

AptifyDataFieldDoesNotExistException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyDataFieldDoesNotExistException Constructor Overload List


AptifyDataFieldDoesNotExistException Constructor (String, String, Exception)

public AptifyDataFieldDoesNotExistException(
String Entity,
String Field,
Exception inner
);

See Also

AptifyDataFieldDoesNotExistException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyDataFieldDoesNotExistException Constructor Overload List


AptifyDataFieldDoesNotExistException Constructor (SerializationInfo, StreamingContext)

protected AptifyDataFieldDoesNotExistException(
SerializationInfo info,
StreamingContext context
);

See Also

AptifyDataFieldDoesNotExistException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyDataFieldDoesNotExistException Constructor Overload List


AptifyDataFieldDoesNotExistException Methods

The methods of the AptifyDataFieldDoesNotExistException class are listed below. For a complete list of AptifyDataFieldDoesNotExistException class members, see the AptifyDataFieldDoesNotExistException Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyDataFieldDoesNotExistException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataFieldDoesNotExistException.GetObjectData Method

public override void GetObjectData(
SerializationInfo info,
StreamingContext context
);

Implements

ISerializable.

See Also

AptifyDataFieldDoesNotExistException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataFields Class

For a list of all members of this type, see AptifyDataFields Members.

System.Object
NameObjectCollectionBase
AptifyCollection
AptifyDataFieldsBase
AptifyDataFields

public class AptifyDataFields : AptifyDataFieldsBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntity (in AptifyGenericEntity.dll)

See Also

AptifyDataFields Members | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataFields Members

AptifyDataFields overview

Public Instance Constructors

AptifyDataFields Constructor

Public Instance Properties

Count (inherited from NameObjectCollectionBase) | Gets the number of key/value pairs contained in the NameObjectCollectionBase instance.
Item (inherited from AptifyDataFieldsBase) |
Item (inherited from AptifyDataFieldsBase) |
Keys (inherited from NameObjectCollectionBase) | Gets a KeysCollection instance that contains all the keys in the NameObjectCollectionBase instance.

Public Instance Methods

Add (inherited from AptifyDataFieldsBase) | Overloaded.
Clear (inherited from AptifyCollection) |
Clone | Clones an AptifyDataFields object and it’s contained DataField objects.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from AptifyCollection) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from NameObjectCollectionBase) | Implements the ISerializable interface and returns the data needed to serialize the NameObjectCollectionBase instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from AptifyDataFieldsBase) |
Merge (inherited from AptifyCollection) | Allows a user to merge items from another collection to this collection.
OnDeserialization (inherited from NameObjectCollectionBase) | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete.
Remove (inherited from AptifyCollection) | Overloaded.
RemoveAt (inherited from AptifyCollection) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Fields

m_GE (inherited from AptifyDataFieldsBase)

Protected Instance Properties

IsReadOnly (inherited from NameObjectCollectionBase) Gets or sets a value indicating whether the NameObjectCollectionBase instance is read-only.

Protected Instance Methods

BaseAdd (inherited from NameObjectCollectionBase) | Adds an entry with the specified key and value into the NameObjectCollectionBase instance.
BaseClear (inherited from NameObjectCollectionBase) | Removes all entries from the NameObjectCollectionBase instance.
BaseGet (inherited from NameObjectCollectionBase) | Overloaded. Gets the value of the first entry with the specified key from the NameObjectCollectionBase instance.
BaseGetAllKeys (inherited from NameObjectCollectionBase) | Returns a String array that contains all the keys in the NameObjectCollectionBase instance.
BaseGetAllValues (inherited from NameObjectCollectionBase) | Overloaded. Returns an Object array that contains all the values in the NameObjectCollectionBase instance.
BaseGetKey (inherited from NameObjectCollectionBase) | Gets the key of the entry at the specified index of the NameObjectCollectionBase instance.
BaseHasKeys (inherited from NameObjectCollectionBase) | Gets a value indicating whether the NameObjectCollectionBase instance contains entries whose keys are not null.
BaseRemove (inherited from NameObjectCollectionBase) | Removes the entries with the specified key from the NameObjectCollectionBase instance.
BaseRemoveAt (inherited from NameObjectCollectionBase) | Removes the entry at the specified index of the NameObjectCollectionBase instance.
BaseSet (inherited from NameObjectCollectionBase) | Overloaded. Sets the value of the first entry with the specified key in the NameObjectCollectionBase instance, if found; otherwise, adds an entry with the specified key and value into the NameObjectCollectionBase instance.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyDataFields Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataFields Constructor

public AptifyDataFields(
AptifyGenericEntityBase GE
);

See Also

AptifyDataFields Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataFields Methods

The methods of the AptifyDataFields class are listed below. For a complete list of AptifyDataFields class members, see the AptifyDataFields Members topic.

Public Instance Methods

Add (inherited from AptifyDataFieldsBase) | Overloaded.
Clear (inherited from AptifyCollection) |
Clone | Clones an AptifyDataFields object and it’s contained DataField objects.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from AptifyCollection) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from NameObjectCollectionBase) | Implements the ISerializable interface and returns the data needed to serialize the NameObjectCollectionBase instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from AptifyDataFieldsBase) |
Merge (inherited from AptifyCollection) | Allows a user to merge items from another collection to this collection.
OnDeserialization (inherited from NameObjectCollectionBase) | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete.
Remove (inherited from AptifyCollection) | Overloaded.
RemoveAt (inherited from AptifyCollection) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

BaseAdd (inherited from NameObjectCollectionBase) | Adds an entry with the specified key and value into the NameObjectCollectionBase instance.
BaseClear (inherited from NameObjectCollectionBase) | Removes all entries from the NameObjectCollectionBase instance.
BaseGet (inherited from NameObjectCollectionBase) | Overloaded. Gets the value of the first entry with the specified key from the NameObjectCollectionBase instance.
BaseGetAllKeys (inherited from NameObjectCollectionBase) | Returns a String array that contains all the keys in the NameObjectCollectionBase instance.
BaseGetAllValues (inherited from NameObjectCollectionBase) | Overloaded. Returns an Object array that contains all the values in the NameObjectCollectionBase instance.
BaseGetKey (inherited from NameObjectCollectionBase) | Gets the key of the entry at the specified index of the NameObjectCollectionBase instance.
BaseHasKeys (inherited from NameObjectCollectionBase) | Gets a value indicating whether the NameObjectCollectionBase instance contains entries whose keys are not null.
BaseRemove (inherited from NameObjectCollectionBase) | Removes the entries with the specified key from the NameObjectCollectionBase instance.
BaseRemoveAt (inherited from NameObjectCollectionBase) | Removes the entry at the specified index of the NameObjectCollectionBase instance.
BaseSet (inherited from NameObjectCollectionBase) | Overloaded. Sets the value of the first entry with the specified key in the NameObjectCollectionBase instance, if found; otherwise, adds an entry with the specified key and value into the NameObjectCollectionBase instance.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyDataFields Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataFields.Clone Method

Clones an AptifyDataFields object and it’s contained DataField objects.

public override void Clone(
AptifyDataFieldsBase DataFieldsToClone
);

Parameters

DataFieldsToClone

See Also

AptifyDataFields Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataFieldsBase Class

For a list of all members of this type, see AptifyDataFieldsBase Members.

System.Object
NameObjectCollectionBase
AptifyCollection
AptifyDataFieldsBase
AptifyDataFields

public class AptifyDataFieldsBase : AptifyCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

AptifyDataFieldsBase Members | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataFieldsBase Members

AptifyDataFieldsBase overview

Public Instance Constructors

AptifyDataFieldsBase Constructor

Public Instance Properties

Count (inherited from NameObjectCollectionBase) | Gets the number of key/value pairs contained in the NameObjectCollectionBase instance.
Item | Overloaded.
Keys (inherited from NameObjectCollectionBase) | Gets a KeysCollection instance that contains all the keys in the NameObjectCollectionBase instance.

Public Instance Methods

Add | Overloaded.
Clear (inherited from AptifyCollection) |
Clone |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from AptifyCollection) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from NameObjectCollectionBase) | Implements the ISerializable interface and returns the data needed to serialize the NameObjectCollectionBase instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf |
Merge (inherited from AptifyCollection) | Allows a user to merge items from another collection to this collection.
OnDeserialization (inherited from NameObjectCollectionBase) | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete.
Remove (inherited from AptifyCollection) | Overloaded.
RemoveAt (inherited from AptifyCollection) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Fields

m_GE

Protected Instance Properties

IsReadOnly (inherited from NameObjectCollectionBase) Gets or sets a value indicating whether the NameObjectCollectionBase instance is read-only.

Protected Instance Methods

BaseAdd (inherited from NameObjectCollectionBase) | Adds an entry with the specified key and value into the NameObjectCollectionBase instance.
BaseClear (inherited from NameObjectCollectionBase) | Removes all entries from the NameObjectCollectionBase instance.
BaseGet (inherited from NameObjectCollectionBase) | Overloaded. Gets the value of the first entry with the specified key from the NameObjectCollectionBase instance.
BaseGetAllKeys (inherited from NameObjectCollectionBase) | Returns a String array that contains all the keys in the NameObjectCollectionBase instance.
BaseGetAllValues (inherited from NameObjectCollectionBase) | Overloaded. Returns an Object array that contains all the values in the NameObjectCollectionBase instance.
BaseGetKey (inherited from NameObjectCollectionBase) | Gets the key of the entry at the specified index of the NameObjectCollectionBase instance.
BaseHasKeys (inherited from NameObjectCollectionBase) | Gets a value indicating whether the NameObjectCollectionBase instance contains entries whose keys are not null.
BaseRemove (inherited from NameObjectCollectionBase) | Removes the entries with the specified key from the NameObjectCollectionBase instance.
BaseRemoveAt (inherited from NameObjectCollectionBase) | Removes the entry at the specified index of the NameObjectCollectionBase instance.
BaseSet (inherited from NameObjectCollectionBase) | Overloaded. Sets the value of the first entry with the specified key in the NameObjectCollectionBase instance, if found; otherwise, adds an entry with the specified key and value into the NameObjectCollectionBase instance.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyDataFieldsBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataFieldsBase Constructor

public AptifyDataFieldsBase(
AptifyGenericEntityBase GE
);

See Also

AptifyDataFieldsBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataFieldsBase Fields

The fields of the AptifyDataFieldsBase class are listed below. For a complete list of AptifyDataFieldsBase class members, see the AptifyDataFieldsBase Members topic.

Protected Instance Fields

m_GE

See Also

AptifyDataFieldsBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataFieldsBase.m_GE Field

protected m_GE m_GE;

See Also

AptifyDataFieldsBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataFieldsBase Properties

The properties of the AptifyDataFieldsBase class are listed below. For a complete list of AptifyDataFieldsBase class members, see the AptifyDataFieldsBase Members topic.

Public Instance Properties

Count (inherited from NameObjectCollectionBase) | Gets the number of key/value pairs contained in the NameObjectCollectionBase instance.
Item | Overloaded.
Keys (inherited from NameObjectCollectionBase) | Gets a KeysCollection instance that contains all the keys in the NameObjectCollectionBase instance.

Protected Instance Properties

IsReadOnly (inherited from NameObjectCollectionBase) Gets or sets a value indicating whether the NameObjectCollectionBase instance is read-only.

See Also

AptifyDataFieldsBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataFieldBase Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldsBase.AptifyDataFieldBase Property

Overload List

public virtual AptifyDataFieldBase this[Int32] {get; set;}

public virtual AptifyDataFieldBase this[String] {get; set;}

See Also

AptifyDataFieldsBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


Item Property (Int32)

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldsBase.Item Property (Int32)

public virtual AptifyDataFieldBase this[
Int32 Index
] {get; set;}

See Also

AptifyDataFieldsBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyDataFieldsBase.AptifyDataFieldBase Overload List


Item Property (String)

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldsBase.Item Property (String)

public virtual AptifyDataFieldBase this[
String Key
] {get; set;}

See Also

AptifyDataFieldsBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyDataFieldsBase.AptifyDataFieldBase Overload List


AptifyDataFieldsBase Methods

The methods of the AptifyDataFieldsBase class are listed below. For a complete list of AptifyDataFieldsBase class members, see the AptifyDataFieldsBase Members topic.

Public Instance Methods

Add | Overloaded.
Clear (inherited from AptifyCollection) |
Clone |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from AptifyCollection) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from NameObjectCollectionBase) | Implements the ISerializable interface and returns the data needed to serialize the NameObjectCollectionBase instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf |
Merge (inherited from AptifyCollection) | Allows a user to merge items from another collection to this collection.
OnDeserialization (inherited from NameObjectCollectionBase) | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete.
Remove (inherited from AptifyCollection) | Overloaded.
RemoveAt (inherited from AptifyCollection) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

BaseAdd (inherited from NameObjectCollectionBase) | Adds an entry with the specified key and value into the NameObjectCollectionBase instance.
BaseClear (inherited from NameObjectCollectionBase) | Removes all entries from the NameObjectCollectionBase instance.
BaseGet (inherited from NameObjectCollectionBase) | Overloaded. Gets the value of the first entry with the specified key from the NameObjectCollectionBase instance.
BaseGetAllKeys (inherited from NameObjectCollectionBase) | Returns a String array that contains all the keys in the NameObjectCollectionBase instance.
BaseGetAllValues (inherited from NameObjectCollectionBase) | Overloaded. Returns an Object array that contains all the values in the NameObjectCollectionBase instance.
BaseGetKey (inherited from NameObjectCollectionBase) | Gets the key of the entry at the specified index of the NameObjectCollectionBase instance.
BaseHasKeys (inherited from NameObjectCollectionBase) | Gets a value indicating whether the NameObjectCollectionBase instance contains entries whose keys are not null.
BaseRemove (inherited from NameObjectCollectionBase) | Removes the entries with the specified key from the NameObjectCollectionBase instance.
BaseRemoveAt (inherited from NameObjectCollectionBase) | Removes the entry at the specified index of the NameObjectCollectionBase instance.
BaseSet (inherited from NameObjectCollectionBase) | Overloaded. Sets the value of the first entry with the specified key in the NameObjectCollectionBase instance, if found; otherwise, adds an entry with the specified key and value into the NameObjectCollectionBase instance.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyDataFieldsBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


Add Method

Aptify 5.0 Software Development Kit (SDK)

AptifyDataFieldsBase.Add Method

Overload List

public virtual int Add(AptifyDataFieldBase);

public virtual int Add(AptifyDataFieldBase,String);

new public virtual int Add(Object);

new public virtual int Add(Object,String);

See Also

AptifyDataFieldsBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataFieldsBase.Add Method (AptifyDataFieldBase)

public virtual int Add(
AptifyDataFieldBase Value
);

See Also

AptifyDataFieldsBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyDataFieldsBase.Add Overload List


AptifyDataFieldsBase.Add Method (AptifyDataFieldBase, String)

public virtual int Add(
AptifyDataFieldBase Value,
String Key
);

See Also

AptifyDataFieldsBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyDataFieldsBase.Add Overload List


AptifyDataFieldsBase.Add Method (Object)

new public virtual int Add(
Object Value
);

See Also

AptifyDataFieldsBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyDataFieldsBase.Add Overload List


AptifyDataFieldsBase.Add Method (Object, String)

new public virtual int Add(
Object Value,
String Key
);

See Also

AptifyDataFieldsBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyDataFieldsBase.Add Overload List


AptifyDataFieldsBase.Clone Method

public abstract void Clone(
AptifyDataFieldsBase DataFieldsToClone
);

See Also

AptifyDataFieldsBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDataFieldsBase.IndexOf Method

new public virtual int IndexOf(
String Key
);

See Also

AptifyDataFieldsBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDuplicateMessage Class

For a list of all members of this type, see AptifyDuplicateMessage Members.

System.Object
AptifyDuplicateMessage

public class AptifyDuplicateMessage : IAptifyDuplicateMessage

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntity (in AptifyGenericEntity.dll)

See Also

AptifyDuplicateMessage Members | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDuplicateMessage Members

AptifyDuplicateMessage overview

Public Instance Constructors

AptifyDuplicateMessage Constructor Initializes a new instance of the AptifyDuplicateMessage class.

Public Instance Properties

DuplicateIDs
DuplicateResult
GE

Public Instance Methods

Display |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyDuplicateMessage Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDuplicateMessage Constructor

Initializes a new instance of the AptifyDuplicateMessage class.

public AptifyDuplicateMessage();

See Also

AptifyDuplicateMessage Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDuplicateMessage Properties

The properties of the AptifyDuplicateMessage class are listed below. For a complete list of AptifyDuplicateMessage class members, see the AptifyDuplicateMessage Members topic.

Public Instance Properties

DuplicateIDs
DuplicateResult
GE

See Also

AptifyDuplicateMessage Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


DuplicateIDs Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDuplicateMessage.DuplicateIDs Property

public Int64[] DuplicateIDs {set;}

Implements

IAptifyDuplicateMessage.

See Also

AptifyDuplicateMessage Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


DuplicateResult Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDuplicateMessage.DuplicateResult Property

public DuplicateCheckResult DuplicateResult {set;}

Implements

IAptifyDuplicateMessage.

See Also

AptifyDuplicateMessage Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GE Property

Aptify 5.0 Software Development Kit (SDK)

AptifyDuplicateMessage.GE Property

public AptifyGenericEntityBase GE {set;}

Implements

IAptifyDuplicateMessage.

See Also

AptifyDuplicateMessage Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDuplicateMessage Methods

The methods of the AptifyDuplicateMessage class are listed below. For a complete list of AptifyDuplicateMessage class members, see the AptifyDuplicateMessage Members topic.

Public Instance Methods

Display |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyDuplicateMessage Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyDuplicateMessage.Display Method

public DuplicateCheckMessageAction Display();

Implements

IAptifyDuplicateMessage.

See Also

AptifyDuplicateMessage Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyEntityPermissionDeniedException Class

For a list of all members of this type, see AptifyEntityPermissionDeniedException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
AptifyGenericEntityException
AptifyEntityPermissionDeniedException

public class AptifyEntityPermissionDeniedException : AptifyGenericEntityException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntity (in AptifyGenericEntity.dll)

See Also

AptifyEntityPermissionDeniedException Members | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyEntityPermissionDeniedException Members

AptifyEntityPermissionDeniedException overview

Public Instance Constructors

AptifyEntityPermissionDeniedException Overloaded. Initializes a new instance of the AptifyEntityPermissionDeniedException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Constructors

AptifyEntityPermissionDeniedException Overloaded. Initializes a new instance of the AptifyEntityPermissionDeniedException class.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyEntityPermissionDeniedException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyEntityPermissionDeniedException Constructor

Overload List

protected AptifyEntityPermissionDeniedException(SerializationInfo,StreamingContext);

public AptifyEntityPermissionDeniedException(String,String);

public AptifyEntityPermissionDeniedException(String,String,Exception);

See Also

AptifyEntityPermissionDeniedException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyEntityPermissionDeniedException Constructor (String, String)

public AptifyEntityPermissionDeniedException(
String Entity,
String Operation
);

See Also

AptifyEntityPermissionDeniedException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyEntityPermissionDeniedException Constructor Overload List


AptifyEntityPermissionDeniedException Constructor (String, String, Exception)

public AptifyEntityPermissionDeniedException(
String Entity,
String Operation,
Exception inner
);

See Also

AptifyEntityPermissionDeniedException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyEntityPermissionDeniedException Constructor Overload List


AptifyEntityPermissionDeniedException Constructor (SerializationInfo, StreamingContext)

protected AptifyEntityPermissionDeniedException(
SerializationInfo info,
StreamingContext context
);

See Also

AptifyEntityPermissionDeniedException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyEntityPermissionDeniedException Constructor Overload List


AptifyEntityPermissionDeniedException Methods

The methods of the AptifyEntityPermissionDeniedException class are listed below. For a complete list of AptifyEntityPermissionDeniedException class members, see the AptifyEntityPermissionDeniedException Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyEntityPermissionDeniedException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyEntityPermissionDeniedException.GetObjectData Method

public override void GetObjectData(
SerializationInfo info,
StreamingContext context
);

Implements

ISerializable.

See Also

AptifyEntityPermissionDeniedException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntity Class

The standard implementation for the AptifyGenericEntityBase

For a list of all members of this type, see AptifyGenericEntity Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
Derived types

public class AptifyGenericEntity : AptifyGenericEntityBase, ISerializable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntity (in AptifyGenericEntity.dll)

See Also

AptifyGenericEntity Members | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntity Members

AptifyGenericEntity overview

Protected Static Fields

m_c_GESerializationConstant This constant is the key value used to set/get the GE's internal XML data into the SerializationInfo class that is passed into the GetObjectData() serialization method and the specialized New() constructor that serialization calls.

Public Instance Constructors

AptifyGenericEntity Overloaded. Initializes a new instance of the AptifyGenericEntity class.

Public Instance Properties

Application | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID | Overloaded. This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects | Returns the extender objects for this GE, if any
Fields | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString | Overloaded. Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction | Commits the current transaction.
Config | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies | Overloaded. NOT IMPLEMENTED
GetDuplicateList | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion | Returns the Latest Record Version for this GE Record.
GetObjectData | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction | Rolls back the current transaction.
Save | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode
m_sTempRecordChangeString
m_sTempRecordChangeXML
ObjectDataForTransactionRollback

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject |
GetVerifyObject |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType |
CreateExtenderInstance | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord |
CreateSubTypeRecord |
CreateTopLevelRecord |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction |
FinishTransactionSubType |
FinishTransactionTopLevel |
FireEvent |
FireValidationEvent |
GenerateCreateParametrizedSQL |
GenerateCreateSQL |
GenerateDeleteSQL |
GenerateFieldSQL |
GenerateUpdateSQL |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo |
RefreshLinkedFields |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists |
RestoreCopiedFields |
RollbackEmbeddedObjects |
SaveExtenderObjects | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction |
SetupTransactionSubType |
SetupTransactionTopLevel |
UpdateRecord |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject |

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntity Constructor

Initializes a new instance of the AptifyGenericEntity class.

Overload List

Initializes a new instance of the AptifyGenericEntity class.

public AptifyGenericEntity();

Deserialization constructor. This constructor is called by objects that are performing deserialization on the object. The constructor internally retrieves the data from the info parameter and then calls the Config() method passing in the UserCredentials and EntityName that were previously serialized (as UserCredentials and EntityName, respectively). Subsequently, the Load() method is called within this constructor which will load up the GE with the XML stream that was serialized and should be availalbe inside the SerializationInfo object keyed with the m_c_GESerializationConstant key.

public AptifyGenericEntity(SerializationInfo,StreamingContext);

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntity Constructor ()

Initializes a new instance of the AptifyGenericEntity class.

public AptifyGenericEntity();

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntity Constructor Overload List


AptifyGenericEntity Constructor (SerializationInfo, StreamingContext)

Deserialization constructor. This constructor is called by objects that are performing deserialization on the object. The constructor internally retrieves the data from the info parameter and then calls the Config() method passing in the UserCredentials and EntityName that were previously serialized (as UserCredentials and EntityName, respectively). Subsequently, the Load() method is called within this constructor which will load up the GE with the XML stream that was serialized and should be availalbe inside the SerializationInfo object keyed with the m_c_GESerializationConstant key.

public AptifyGenericEntity(
SerializationInfo info,
StreamingContext context
);

Parameters

info
context

Remarks

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntity Constructor Overload List


AptifyGenericEntity Fields

The fields of the AptifyGenericEntity class are listed below. For a complete list of AptifyGenericEntity class members, see the AptifyGenericEntity Members topic.

Protected Static Fields

m_c_GESerializationConstant This constant is the key value used to set/get the GE's internal XML data into the SerializationInfo class that is passed into the GetObjectData() serialization method and the specialized New() constructor that serialization calls.

Protected Instance Fields

InEditMode
m_sTempRecordChangeString
m_sTempRecordChangeXML
ObjectDataForTransactionRollback

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntity.InEditMode Field

protected InEditMode InEditMode;

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntity.m_c_GESerializationConstant Field

This constant is the key value used to set/get the GE's internal XML data into the SerializationInfo class that is passed into the GetObjectData() serialization method and the specialized New() constructor that serialization calls.

protected const m_c_GESerializationConstant m_c_GESerializationConstant = "_GE_Object_Data";

Remarks

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntity.m_sTempRecordChangeString Field

protected m_sTempRecordChangeString m_sTempRecordChangeString;

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntity.m_sTempRecordChangeXML Field

protected m_sTempRecordChangeXML m_sTempRecordChangeXML;

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntity.ObjectDataForTransactionRollback Field

protected ObjectDataForTransactionRollback ObjectDataForTransactionRollback;

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntity Properties

The properties of the AptifyGenericEntity class are listed below. For a complete list of AptifyGenericEntity class members, see the AptifyGenericEntity Members topic.

Public Instance Properties

Application | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID | Overloaded. This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects | Returns the extender objects for this GE, if any
Fields | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString | Overloaded. Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject |
GetVerifyObject |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


Application Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntity.Application Property

This property can be use to gain access to the internal application object so a new one does not need to be created.

public AptifyApplication Application {get;}

Property Value

Remarks

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


BroadcastState Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntity.BroadcastState Property

Allows a developer to set a Value for the BroadCast State of the loaded record.

public override Boolean BroadcastState {get; set;}

Remarks

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


CacheDirectory Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntity.CacheDirectory Property

Sets a directory that should be used when caching information for a GE Instance.

public override String CacheDirectory {get; set;}

Remarks

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


CacheUpToDate Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntity.CacheUpToDate Property

Makes sure the CacheDirectory has up to date information for this GE Instance.

public override Boolean this[
Int64 RecordID
] {get;}

Parameters

RecordID

Remarks

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


DataAction Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntity.DataAction Property

This property can be use to gain access to the internal DataAction object so a new one does not need to be created.

public IAptifyDataAction DataAction {get;}

Property Value

Remarks

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


DisconnectedEmbeddedObjects Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntity.DisconnectedEmbeddedObjects Property

public override List<T> DisconnectedEmbeddedObjects {get;}

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


EmbeddedObjectsNeedingRecordID Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntity.EmbeddedObjectsNeedingRecordID Property

This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.

public override List<T> this[
Boolean CreateIfNothing
] {get;}

Parameters

CreateIfNothing

Property Value

Remarks

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ExtenderObjects Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntity.ExtenderObjects Property

Returns the extender objects for this GE, if any

public override ExtenderObjectListBase ExtenderObjects {get;}

Property Value

Remarks

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


Fields Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntity.Fields Property

Returns a collection of Datafields that are associated with the GE Record.

public override AptifyDataFieldsBase Fields {get;}

Remarks

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GetDupeObject Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntity.GetDupeObject Property

protected override IAptifyDuplicateCheck GetDupeObject {get;}

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GetVerifyObject Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntity.GetVerifyObject Property

protected override IAptifyVerify GetVerifyObject {get;}

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


RecordChangeString Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntity.RecordChangeString Property

Returns a string describing what changed in the record between the current version in memory and the "LAST" version.

public override String this[
String sLinePrefix
] {get;}

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


RecordHistoryOmitObjectData Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntity.RecordHistoryOmitObjectData Property

protected override Boolean RecordHistoryOmitObjectData {get;}

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


SubTypes Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntity.SubTypes Property

Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.

public override AptifySubTypes SubTypes {get;}

Remarks

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


UseCache Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntity.UseCache Property

Allows a user to store whether or not Caching should be used for the loaded record.

public override Boolean UseCache {get; set;}

Remarks

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntity Methods

The methods of the AptifyGenericEntity class are listed below. For a complete list of AptifyGenericEntity class members, see the AptifyGenericEntity Members topic.

Public Instance Methods

BeginTransaction | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction | Commits the current transaction.
Config | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies | Overloaded. NOT IMPLEMENTED
GetDuplicateList | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion | Returns the Latest Record Version for this GE Record.
GetObjectData | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction | Rolls back the current transaction.
Save | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType |
CreateExtenderInstance | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord |
CreateSubTypeRecord |
CreateTopLevelRecord |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction |
FinishTransactionSubType |
FinishTransactionTopLevel |
FireEvent |
FireValidationEvent |
GenerateCreateParametrizedSQL |
GenerateCreateSQL |
GenerateDeleteSQL |
GenerateFieldSQL |
GenerateUpdateSQL |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo |
RefreshLinkedFields |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists |
RestoreCopiedFields |
RollbackEmbeddedObjects |
SaveExtenderObjects | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction |
SetupTransactionSubType |
SetupTransactionTopLevel |
UpdateRecord |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject |

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


BeginTransaction Method

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntity.BeginTransaction Method

This will begin a new transaction for the current transaction id.

Overload List

Inherited from AptifyGenericEntityBase.

public virtual string BeginTransaction();

This will begin a new transaction for the current transaction id.

public override string BeginTransaction(String);

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntity.BeginTransaction Method (String)

This will begin a new transaction for the current transaction id.

public override string BeginTransaction(
String TransactionID
);

Parameters

TransactionID
An existing transaction ID or a null reference.

Return Value

The Id of the transaction that was used.

Remarks

If there is no current transaction then TransactionID should be the emtpy string. This method will throw an exception if a transaction id is passed in that is not the current transaction.

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntity.BeginTransaction Overload List


AptifyGenericEntity.BroadcastChange Method

protected override void BroadcastChange();

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntity.CheckForDuplicates Method

Checks for duplicate records based on the entity and the currently loaded data.

public override bool CheckForDuplicates(
Boolean AllowGUI
);

Parameters

AllowGUI

Return Value

Remarks

This function will check for duplicate records of this record type and do one of several things. If a duplicate checker object is registered for the entity type, then it will do as follows:

  • If no dupe object is registered, then it will always return TRUE
  • If no match is found, the CheckForDuplicates routine will return TRUE
  • If absolute match(s) are found, CheckForDuplicates will return FALSE
  • If Potential match(s) are found, then the user will be notified

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntity.ClearDirtyFlags Method

Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.

public override void ClearDirtyFlags();

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntity.ClearFields Method

Calls the Clear member for each associated Datafield.

public override void ClearFields();

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntity.CloneSubType Method

protected override void CloneSubType(
AptifySubTypeBase SubTypeToClone,
Boolean Merge
);

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntity.CommitTransaction Method

Commits the current transaction.

public override bool CommitTransaction();

Return Value

Remarks

If there is no current transaction then an exception is thrown.

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


Config Method

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntity.Config Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual void Config(AptifySubTypeBase);

public override void Config(AptifySubTypeBase,Int64);

Inherited from AptifyGenericEntityBase.

public virtual void Config(UserCredentials,String);

Configures a GE Instance to reflect the Sub-type information provided.

public override void Config(UserCredentials,String,Int64);

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntity.Config Method (AptifySubTypeBase, Int64)

public override void Config(
AptifySubTypeBase subType,
Int64 RecordID
);

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntity.Config Overload List


AptifyGenericEntity.Config Method (UserCredentials, String, Int64)

Configures a GE Instance to reflect the Sub-type information provided.

public override void Config(
UserCredentials UserCredentials,
String EntityName,
Int64 RecordID
);

Parameters

UserCredentials
EntityName
RecordID

Remarks

The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntity.Config Overload List


AptifyGenericEntity.CreateExtenderInstance Method

This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.

protected virtual ExtenderInstanceBase CreateExtenderInstance(
AptifyGenericEntityBase ExtenderGE,
AptifyGenericEntityBase ParentGE,
ExtenderEntityMetaData ExtenderEntityMetadata
);

Parameters

ExtenderGE
ParentGE
ExtenderEntityMetadata

Return Value

Remarks

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntity.CreateRecord Method

protected virtual bool CreateRecord(
String TransactionID,
ref String& ErrorString
);

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntity.CreateSubTypeRecord Method

protected virtual bool CreateSubTypeRecord(
String TransactionID,
ref String& ErrorString
);

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntity.CreateTopLevelRecord Method

protected virtual bool CreateTopLevelRecord(
String TransactionID,
ref String& ErrorString
);

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


Delete Method

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntity.Delete Method

Deletes the currently loaded GE record.

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Delete();

Deletes the currently loaded GE record.

public override bool Delete(String);

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntity.Delete Method (String)

Deletes the currently loaded GE record.

public override bool Delete(
String TransactionID
);

Parameters

TransactionID

Return Value

Remarks

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntity.Delete Overload List


AptifyGenericEntity.DeleteTopicCodeLinks Method

Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.

protected virtual void DeleteTopicCodeLinks(
String TransactionID
);

Parameters

TransactionID

Remarks

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntity.Display Method

Displays the current record in the Aptify Object Viewer.

public override void Display();

Remarks

This call maintains the previous version's functionality by displaying the Object Viewer. This could be changed to display the normal GUI, or it could be overloaded to provide that control or it could be removed because it's a single call to the Application object.

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntity.DistributeNewSubTypeRecordInfo Method

protected virtual void DistributeNewSubTypeRecordInfo(
AptifySubTypes SubTypesToProcess,
DataTable dtSubTypeInfo
);

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntity.FinalizeTransaction Method

Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.

public override void FinalizeTransaction();

Remarks

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntity.FinishTransaction Method

protected virtual bool FinishTransaction(
Boolean Commit,
String TransactionID,
Boolean CheckDirtyAgain,
Boolean SaveSubTypes
);

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntity.FinishTransactionSubType Method

protected virtual bool FinishTransactionSubType(
Boolean Commit,
String TransactionID,
ref Boolean& InTransaction,
Boolean CheckDirtyAgain,
Boolean SaveSubTypes
);

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntity.FinishTransactionTopLevel Method

protected virtual bool FinishTransactionTopLevel(
Boolean Commit,
String TransactionID,
ref Boolean& InTransaction,
Boolean CheckDirtyAgain,
Boolean SaveSubTypes
);

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntity.FireEvent Method

protected virtual bool FireEvent(
String EventName
);

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntity.FireValidationEvent Method

protected virtual bool FireValidationEvent(
String EventName,
ref String& ValidationMessage
);

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntity.GenerateCreateParametrizedSQL Method

protected virtual string GenerateCreateParametrizedSQL(
ref IDataParameter[]& paramCreate
);

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntity.GenerateCreateSQL Method

protected virtual string GenerateCreateSQL();

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntity.GenerateDeleteSQL Method

protected virtual string GenerateDeleteSQL();

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntity.GenerateFieldSQL Method

protected virtual string GenerateFieldSQL(
Boolean ForCreate,
String TempID,
Boolean OnlyDirty
);

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntity.GenerateUpdateSQL Method

protected virtual string GenerateUpdateSQL();

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntity.GenericRelinkDependants Method

Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.

public override bool GenericRelinkDependants(
String Entity,
Int64 NewID,
Int64 OldID
);

Parameters

Entity
NewID
OldID

Remarks

In other words, this stored procedure handles the links to tables that can link to any record in any entity. (ListDetail, Attachment, ContactLogLink, etc.)

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntity.GetDataString Method

Returns an XML string representation of the data belonging to the Object in Memory.

public override string GetDataString();

Return Value

Remarks

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GetDependencies Method

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntity.GetDependencies Method

Overload List

public override EntityDependenciesBase GetDependencies();

NOT IMPLEMENTED

public override bool GetDependencies(ref AptifyGenericEntityBase[]&);

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntity.GetDependencies Method ()

public override EntityDependenciesBase GetDependencies();

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntity.GetDependencies Overload List


AptifyGenericEntity.GetDependencies Method (AptifyGenericEntityBase[]&)

NOT IMPLEMENTED

public override bool GetDependencies(
ref AptifyGenericEntityBase[]& GEs
);

Parameters

GEs

Return Value

Remarks

BUG (This should return the Dependent objects instead of returning a boolean value)

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntity.GetDependencies Overload List


AptifyGenericEntity.GetDuplicateList Method

Returns a list of duplicates that are either potential or absolute duplicates for the current object.

public override DuplicateCheckResult GetDuplicateList(
ref Int64[]& DuplicateIDs
);

Parameters

DuplicateIDs

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntity.GetLatestRecordVersion Method

Returns the Latest Record Version for this GE Record.

public override long GetLatestRecordVersion();

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GetObjectData Method

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntity.GetObjectData Method

Returns an XML string representation of the Object in Memory.

Overload List

Returns an XML string representation of the Object in Memory.

public override string GetObjectData(Boolean);

public virtual void GetObjectData(SerializationInfo,StreamingContext);

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntity.GetObjectData Method (Boolean)

Returns an XML string representation of the Object in Memory.

public override string GetObjectData(
Boolean bIncrementVersion
);

Parameters

bIncrementVersion

Remarks

The returned string includes the Object's structure.

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntity.GetObjectData Overload List


AptifyGenericEntity.GetObjectData Method (SerializationInfo, StreamingContext)

public virtual void GetObjectData(
SerializationInfo info,
StreamingContext context
);

Implements

ISerializable.

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntity.GetObjectData Overload List


AptifyGenericEntity.GetRecordVersion Method

Returns the current version of the loaded record.

public override long GetRecordVersion();

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntity.InnerValidate Method

Runs Validation on all SubTypes and DataFields.

protected override bool InnerValidate(
ref String& ErrorString
);

Parameters

ErrorString
If an error occurs during InnerValidate, the error message will be assigned to ErrorString

Return Value

True if all Validation is successful. False if any part of the validation fails.

Remarks

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


Load Method

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntity.Load Method

Loads an existing instance with data.

Overload List

Loads an existing instance with data from a field with the supplied DataRow.

public override void Load(DataRow);

Loads an existing instance with data from a field with the supplied IDataReader.

public override void Load(IDataReader);

Loads an existing instance with data from a field with the supplied ID.

public override void Load(Int64);

Inherited from AptifyGenericEntityBase.

public virtual void Load(String);

Loads an existing instance with data from a field with the supplied File Name. This method can also be used to load the GE with an XML string.

public override void Load(String,Boolean);

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntity.Load Method (DataRow)

Loads an existing instance with data from a field with the supplied DataRow.

public override void Load(
DataRow DataRow
);

Parameters

DataRow

Remarks

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntity.Load Overload List


AptifyGenericEntity.Load Method (IDataReader)

Loads an existing instance with data from a field with the supplied IDataReader.

public override void Load(
IDataReader DataReader
);

Parameters

DataReader

Remarks

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntity.Load Overload List


AptifyGenericEntity.Load Method (Int64)

Loads an existing instance with data from a field with the supplied ID.

public override void Load(
Int64 ID
);

Parameters

ID

Remarks

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntity.Load Overload List


AptifyGenericEntity.Load Method (String, Boolean)

Loads an existing instance with data from a field with the supplied File Name. This method can also be used to load the GE with an XML string.

public override void Load(
String FileName,
Boolean MergeSubTypes
);

Parameters

FileName
The name of the XML file that will be used to load the GE or an XML string. When passing in an XML string, the first character must be a pipe(|) character followed by the XML string. The pipe character will be removed and the XML string will be used to load the GE.
MergeSubTypes
When false, each Sub-Type in the XML stream will cause the object's Sub-Type to be cleared prior to loading the information in the XML Stream. When true, the Sub-Type will be scanned for a matching Sub-Type record ID. If found, the existing record will be updated. If not, a new record will be added to the Sub-Type.

Remarks

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntity.Load Overload List


LogRecordHistory Method

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntity.LogRecordHistory Method

Is responsible for creating a recordhistory record.

Overload List

Inherited from AptifyGenericEntityBase.

public virtual void LogRecordHistory(String,Int64,Int64,String,String);

public override void LogRecordHistory(String,Int64,Int64,String,String,String,String,String,String,String);

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntity.LogRecordHistory Method (String, Int64, Int64, String, String, String, String, String, String, String)

public override void LogRecordHistory(
String TransactionID,
Int64 EntityID,
Int64 RecordID,
String Changes,
String RecordData,
String VersionComments,
String Person,
String Email,
String Title,
String Phone
);

Parameters

TransactionID
EntityID
RecordID
Changes
RecordData
VersionComments
Person
Email
Title
Phone

Remarks

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntity.LogRecordHistory Overload List


AptifyGenericEntity.MakeFieldsCopy Method

protected virtual void MakeFieldsCopy();

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntity.NewRecord Method

Clears all of the Fields and sub-types for a GE object.

public override bool NewRecord();

Return Value

Always return false, it should probably be a sub.

Remarks

It essentialy functions as a clear.

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntity.RecordVersionInfo Method

protected virtual bool RecordVersionInfo(
String TransactionID,
Boolean bCheckDirtyAgain
);

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntity.RefreshLinkedFields Method

protected override void RefreshLinkedFields(
AptifyDataFieldBase oFKeyField
);

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntity.ResetEmbeddedObjectLists Method

protected override void ResetEmbeddedObjectLists();

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntity.RestoreCopiedFields Method

protected virtual void RestoreCopiedFields();

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntity.RollbackEmbeddedObjects Method

protected virtual void RollbackEmbeddedObjects();

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntity.RollbackRecordID Method

It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.

public override void RollbackRecordID();

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntity.RollbackTransaction Method

Rolls back the current transaction.

public override bool RollbackTransaction();

Return Value

Remarks

If there is no current transaction then an exception is thrown.

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


Save Method

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntity.Save Method

Saves the GE Data.

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Save();

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean,ref String&);

Saves the GE Data.

public override bool Save(Boolean,ref String&,String);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(ref String&);

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntity.Save Method (Boolean, String&, String)

Saves the GE Data.

public override bool Save(
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

Parameters

AllowGUI
Can be used to determine if the Object is allowed to show a GUI to the user.
ErrorString
The message corresponding to any exceptions that may have been encountered. If the ErrorString is populated then this method will not attempt to save. It will attempt to display the ErrorString if AllowGUI is true and then it will return false.
TransactionID
The transaction that the save should be segmented onto.

Remarks

Attempts to save the Current GE data as a new record if its RecordId is less than 1 or it tries to update the existing record if its recordid > 0. The overloaded Save methods, for the base class (AptifyGenericEntityBase), chain down to the broader overloads. This means inheriting classes only need to implement the Save method. This base implementation of save provided standardized exception handling. If you would like to take advantage of this standardized exception handling, then you should make sure to call a mybase.save(AllowGUI,ErrorString,TransactionID) before exiting the function. The base implementation of save will call the implementing object's Validation member before attempting to save, therefore the Validation member of the implementing class does not need to be called if Mybase.Save is called. If both are called and Validation fails then you will see duplicate exceptions in the exception log.

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntity.Save Overload List


AptifyGenericEntity.SaveAsPendingChange Method

Saves a GE as a pending change instead of the actual change to the entity.

public override bool SaveAsPendingChange(
Int64 PendingChangeTypeID,
DateTime ScheduledDate,
String ConflictReason,
AptifyGenericEntityBase.PendingChangeUpdateType ConflictType,
Int64 SourceServerID
);

Parameters

PendingChangeTypeID
ID of the pending change type.
ScheduledDate
Optional date specifying when the change should take effect.
ConflictReason
Optional string used to specify the nature of a conflict.
ConflictType
Optional enumeration used to specify the type of the conflict.
SourceServerID

Return Value

Returns a boolean indicating if the Pending Change record saved or not.

Remarks

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


SaveExtenderObjects Method

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntity.SaveExtenderObjects Method

This method is responsible for saving extender objects associated with this GE

Overload List

This method is responsible for saving extender objects associated with this GE

protected override bool SaveExtenderObjects(Boolean,String);

This method is responsible for saving extender objects associated with this GE

protected override bool SaveExtenderObjects(Boolean,ref String&,String);

This method is responsible for saving extender objects associated with this GE

protected override bool SaveExtenderObjects(String);

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntity.SaveExtenderObjects Method (Boolean, String)

This method is responsible for saving extender objects associated with this GE

protected override bool SaveExtenderObjects(
Boolean AllowGUI,
String TransactionID
);

Parameters

AllowGUI
TransactionID

Return Value

Remarks

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntity.SaveExtenderObjects Overload List


AptifyGenericEntity.SaveExtenderObjects Method (Boolean, String&, String)

This method is responsible for saving extender objects associated with this GE

protected override bool SaveExtenderObjects(
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

Parameters

AllowGUI
ErrorString
TransactionID

Return Value

Remarks

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntity.SaveExtenderObjects Overload List


AptifyGenericEntity.SaveExtenderObjects Method (String)

This method is responsible for saving extender objects associated with this GE

protected override bool SaveExtenderObjects(
String TransactionID
);

Parameters

TransactionID

Return Value

Remarks

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntity.SaveExtenderObjects Overload List


AptifyGenericEntity.SaveToFile Method

Saves an XML Representation of the GE Object in a file with the provided name

public override void SaveToFile(
String FileName
);

Parameters

FileName

Remarks

If the file already exists then it is overwritten.

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


SetAddValue Method

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntity.SetAddValue Method

If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.

Overload List

Inherited from AptifyGenericEntityBase.

public virtual void SetAddValue(String,Object);

If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.

public override void SetAddValue(String,String,Object);

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntity.SetAddValue Method (String, String, Object)

If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.

public override void SetAddValue(
String FieldName,
String SQLDataType,
Object Value
);

Parameters

FieldName
SQLDataType
Used to set the Data Type for a temporary field. This value will be ignored if the field already exists.
Value

Remarks

If the field does then it sets its value. If the field does not then a temporary field with the given value is added to the GE's fields collection.

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntity.SetAddValue Overload List


AptifyGenericEntity.SetNewSubTypeIDAndSequence Method

Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.

public void SetNewSubTypeIDAndSequence(
Int64 ID,
Int32 Sequence
);

Parameters

ID
The ID for the new Sub-Type record.
Sequence
The Sequence value for the new Sub-Type record. If the Sub-Type does not have a Sequence field this value will be ignored.

Remarks

This is a method used for internal processing in the Generic Entity.

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntity.SetupTransaction Method

protected virtual string SetupTransaction(
Boolean CopyFields,
String TransactionID
);

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntity.SetupTransactionSubType Method

protected virtual string SetupTransactionSubType(
Boolean CopyFields,
String TransactionID
);

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntity.SetupTransactionTopLevel Method

protected virtual string SetupTransactionTopLevel(
Boolean CopyFields,
String TransactionID
);

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntity.UpdateEmbeddedObjectsNeedingRecordID Method

public override bool UpdateEmbeddedObjectsNeedingRecordID(
String TransactionID
);

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntity.UpdateRecord Method

protected virtual bool UpdateRecord(
String TransactionID,
ref String& ErrorString
);

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntity.VerifyObject Method

protected override bool VerifyObject(
Boolean AllowGUI
);

See Also

AptifyGenericEntity Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase Class

Base class for the Aptify Generic Entity, the main business object in the Aptify Technology Platform

For a list of all members of this type, see AptifyGenericEntityBase Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity

public class AptifyGenericEntityBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

It is not directly createable and must be inherited.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

AptifyGenericEntityBase Members | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase Members

AptifyGenericEntityBase overview

Protected Static Properties

NewSubTypeAddSessionID

Public Instance Constructors

AptifyGenericEntityBase Overloaded. Initializes a new instance of the AptifyGenericEntityBase class.

Public Instance Properties

BroadcastState | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField |
ContainerOwnsRecord |
CurrentTransactionCount | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID | Returns the current Transaction ID for this GE Instance.
DefaultPreviewPaneTemplateID | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects |
DisplayRequiredFieldIndicator | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID | Overloaded.
EntityDisplayName | The display name of the entity for the loaded record.
EntityDisplayNameWCulture | Overloaded.
EntityID | The Record ID of the entity for the loaded record.
EntityName | The name of the entity for the loaded record.
EventsToFire | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects | Returns the extender objects, if any, for the current GE
Fields | Returns a collection of Datafields that are associated with the GE Record.
IsDirty | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString | Overloaded. Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID | Returns the Record ID for the currently loaded data record.
RecordName | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor | Returns value of RequiredFieldTextColor field.
SequenceField | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty |
SubTypeLevel | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing |
UseCache | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates | This function will check for duplicate records of this record type.
ClearDirtyFlags | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields | Calls the Clear member for each associated Datafield.
Clone | Overloaded. Creates a new instance of the current GE object.
CommitTransaction | Commits the current transaction
Config | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete | Overloaded. Deletes the current record.
Diff | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants |
GetDataString | Returns a string which encapsulates the entire record and ALL sub types
GetDependencies | Overloaded. Returns other objects that are dependant UPON this object
GetDuplicateList | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion | Returns the Latest Record Version for this GE Record.
GetObjectData | This overridable method returns the Empty string.
GetRecordVersion | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. Returns the value of the specified DataField for the loaded record.
Load | Overloaded. Loads an existing instance with data.
LogRecordHistory | Overloaded. Responsible for creating a recordhistory record.
Merge | Overloaded. Merges two GE objects in memory.
NewRecord | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction | Rolls back the current transaction.
Save | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange | Saves the record into the Pending Changes entity instead of the current entity.
SaveToFile | Saves an XML Representation of the GE Object in a file with the provided name.
SetAddValue | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField |
SetNewSubTypeIDAndSequence | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo | Overloaded.
SetValue | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID |
Validate | Overloaded.

Public Instance Events

AfterCloneRecord | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Constructors

AptifyGenericEntityBase Overloaded. Initializes a new instance of the AptifyGenericEntityBase class.

Protected Instance Properties

CreateSQL | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity |
GetDupeObject |
GetVerifyObject |
IsLoaded |
IsNewRecord | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked |
NewSubTypeRecordTempID | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData |
RequireVersionComment |
SharedRecordHasNoOwner |
SubTypeAddTempTableName |
TrackRecordHistory |
UpdateSQL |

Protected Instance Methods

AreExtenderObjectsDirty |
BroadcastChange |
ClearSubTypeAddTempTableName |
CloneSubType |
DecrementCurrentTransactionCount |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
IncrementCurrentTransactionCount |
InnerValidate |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning | Raises the Warning Event.
RefreshLinkedFields |
ResetCurrentTransactionCount |
ResetEmbeddedObjectLists |
SaveExtenderObjects | Overloaded.
SetCurrentTransactionID |
SetLastError | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError | Sets the user error message that is retrieved by the LastUserError property
SetRecordID |
ValidateSubTypes |
VerifyObject |

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase Constructor

Initializes a new instance of the AptifyGenericEntityBase class.

Overload List

Initializes a new instance of the AptifyGenericEntityBase class.

public AptifyGenericEntityBase();

protected AptifyGenericEntityBase(SerializationInfo,StreamingContext);

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase Constructor ()

Initializes a new instance of the AptifyGenericEntityBase class.

public AptifyGenericEntityBase();

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityBase Constructor Overload List


AptifyGenericEntityBase Constructor (SerializationInfo, StreamingContext)

protected AptifyGenericEntityBase(
SerializationInfo info,
StreamingContext context
);

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityBase Constructor Overload List


AptifyGenericEntityBase Properties

The properties of the AptifyGenericEntityBase class are listed below. For a complete list of AptifyGenericEntityBase class members, see the AptifyGenericEntityBase Members topic.

Protected Static Properties

NewSubTypeAddSessionID

Public Instance Properties

BroadcastState | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField |
ContainerOwnsRecord |
CurrentTransactionCount | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID | Returns the current Transaction ID for this GE Instance.
DefaultPreviewPaneTemplateID | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects |
DisplayRequiredFieldIndicator | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID | Overloaded.
EntityDisplayName | The display name of the entity for the loaded record.
EntityDisplayNameWCulture | Overloaded.
EntityID | The Record ID of the entity for the loaded record.
EntityName | The name of the entity for the loaded record.
EventsToFire | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects | Returns the extender objects, if any, for the current GE
Fields | Returns a collection of Datafields that are associated with the GE Record.
IsDirty | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString | Overloaded. Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID | Returns the Record ID for the currently loaded data record.
RecordName | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor | Returns value of RequiredFieldTextColor field.
SequenceField | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty |
SubTypeLevel | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing |
UseCache | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials | Allows a user to associate a set of user credentials in memory with a given record.

Protected Instance Properties

CreateSQL | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity |
GetDupeObject |
GetVerifyObject |
IsLoaded |
IsNewRecord | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked |
NewSubTypeRecordTempID | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData |
RequireVersionComment |
SharedRecordHasNoOwner |
SubTypeAddTempTableName |
TrackRecordHistory |
UpdateSQL |

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


BroadcastState Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.BroadcastState Property

Allows a developer to set a Value for the BroadCast State of the loaded record.

public virtual Boolean BroadcastState {get; set;}

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


CacheDirectory Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.CacheDirectory Property

Sets a directory that should be used when caching information for a GE Instance.

public virtual String CacheDirectory {get; set;}

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


CacheUpToDate Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.CacheUpToDate Property

Makes sure the CacheDirectory has up to date information for this GE Instance.

public virtual Boolean this[
Int64 RecordID
] {get;}

Parameters

RecordID

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ContainerLinkedDataField Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.ContainerLinkedDataField Property

public virtual AptifyDataFieldBase ContainerLinkedDataField {get;}

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ContainerOwnsRecord Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.ContainerOwnsRecord Property

public virtual Boolean ContainerOwnsRecord {get;}

Property Value

Returns True if ContainerLinkedField object is not Nothing, the Owner information for this object matches (Owner Entity and Owner Record ID). Returns True is COntainerLinkedField is Nothing

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


CreateSQL Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.CreateSQL Property

Sets the name of only the CreateSQL stored procedure .

protected virtual String CreateSQL {get;}

Property Value

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


CurrentTransactionCount Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.CurrentTransactionCount Property

Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.

public virtual Int32 CurrentTransactionCount {get;}

Property Value

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


CurrentTransactionID Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.CurrentTransactionID Property

Returns the current Transaction ID for this GE Instance.

public virtual String CurrentTransactionID {get;}

Property Value

Remarks

The empty string is returned if there is no current transaction.

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


DefaultPreviewPaneTemplateID Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.DefaultPreviewPaneTemplateID Property

This will return the value for field taht is defined as the Default Preview pane Template.

public virtual Int64 DefaultPreviewPaneTemplateID {get;}

Property Value

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


DisconnectedEmbeddedObjects Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.DisconnectedEmbeddedObjects Property

public abstract List<T> DisconnectedEmbeddedObjects {get;}

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


DisplayRequiredFieldIndicator Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.DisplayRequiredFieldIndicator Property

Returns value of DisplayRequiredFieldIndicator field.

public virtual Boolean DisplayRequiredFieldIndicator {get;}

Property Value

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


List<T> Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.List<T> Property

Overload List

public virtual List<T> EmbeddedObjectsNeedingRecordID {get;}

public abstract List<T> this[Boolean] {get;}

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


EmbeddedObjectsNeedingRecordID Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.EmbeddedObjectsNeedingRecordID Property

public virtual List<T> EmbeddedObjectsNeedingRecordID {get;}

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityBase.List<T> Overload List


EmbeddedObjectsNeedingRecordID Property (Boolean)

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.EmbeddedObjectsNeedingRecordID Property (Boolean)

public abstract List<T> this[
Boolean CreateIfNothing
] {get;}

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityBase.List<T> Overload List


EntityDisplayName Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.EntityDisplayName Property

The display name of the entity for the loaded record.

public virtual String EntityDisplayName {get;}

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


String Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.String Property

Overload List

public virtual String EntityDisplayNameWCulture {get;}

public virtual String this[Boolean] {get;}

public virtual String this[Int64] {get;}

public virtual String this[Int64, Boolean] {get;}

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


EntityDisplayNameWCulture Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.EntityDisplayNameWCulture Property

public virtual String EntityDisplayNameWCulture {get;}

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityBase.String Overload List


EntityDisplayNameWCulture Property (Boolean)

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.EntityDisplayNameWCulture Property (Boolean)

public virtual String this[
Boolean AutoMapDisplayName
] {get;}

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityBase.String Overload List


EntityDisplayNameWCulture Property (Int64)

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.EntityDisplayNameWCulture Property (Int64)

public virtual String this[
Int64 CultureID
] {get;}

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityBase.String Overload List


EntityDisplayNameWCulture Property (Int64, Boolean)

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.EntityDisplayNameWCulture Property (Int64, Boolean)

public virtual String this[
Int64 CultureID,
Boolean AutoMapDisplayName
] {get;}

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityBase.String Overload List


EntityID Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.EntityID Property

The Record ID of the entity for the loaded record.

public virtual Int64 EntityID {get;}

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


EntityName Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.EntityName Property

The name of the entity for the loaded record.

public virtual String EntityName {get;}

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


EventsToFire Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.EventsToFire Property

Used to configure the Events that will be fired by the Data Field object.

public AptifyGenericEntityBase.AptifyGenericEntityEvents EventsToFire {get; set;}

Property Value

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ExtenderObjects Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.ExtenderObjects Property

Returns the extender objects, if any, for the current GE

public abstract ExtenderObjectListBase ExtenderObjects {get;}

Property Value

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


FieldLevelSecurity Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.FieldLevelSecurity Property

protected Boolean FieldLevelSecurity {get;}

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


Fields Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.Fields Property

Returns a collection of Datafields that are associated with the GE Record.

public abstract AptifyDataFieldsBase Fields {get;}

Property Value

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GetDupeObject Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.GetDupeObject Property

protected abstract IAptifyDuplicateCheck GetDupeObject {get;}

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GetVerifyObject Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.GetVerifyObject Property

protected abstract IAptifyVerify GetVerifyObject {get;}

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


IsDirty Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.IsDirty Property

If any of the data fields or the subtype is dirty then the record is considered dirty.

public virtual Boolean IsDirty {get;}

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


IsLoaded Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.IsLoaded Property

protected virtual Boolean IsLoaded {get; set;}

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


IsNewRecord Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.IsNewRecord Property

Returns True if the current record is a new record(not yet saved to the database), false otherwise

protected virtual Boolean IsNewRecord {get; set;}

Property Value

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


IsSharedRecordLocked Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.IsSharedRecordLocked Property

protected virtual Boolean IsSharedRecordLocked {get;}

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


LastError Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.LastError Property

If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.

public virtual String LastError {get;}

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


LastUserError Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.LastUserError Property

If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.

public virtual String LastUserError {get;}

Property Value

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


NewSubTypeAddSessionID Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.NewSubTypeAddSessionID Property

protected static Int64 NewSubTypeAddSessionID {get;}

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


NewSubTypeRecordTempID Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.NewSubTypeRecordTempID Property

Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.

protected Int32 NewSubTypeRecordTempID {get;}

Property Value

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ParentGE Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.ParentGE Property

If the GE is a sub-type record then it will have a reference to the Parent GE Instance.

public virtual AptifyGenericEntityBase ParentGE {get;}

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ParentSubType Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.ParentSubType Property

If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.

public virtual AptifySubTypeBase ParentSubType {get;}

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


PrimaryKey Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.PrimaryKey Property

Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.

public FieldAndParamName PrimaryKey {get;}

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


String Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.String Property

Returns a string describing what changed in the record between the current version in memory and the "LAST" version.

Overload List

Returns a string describing what changed in the record between the current version in memory and the "LAST" version.

public virtual String RecordChangeString {get;}

public abstract String this[String] {get;}

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


RecordChangeString Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.RecordChangeString Property

Returns a string describing what changed in the record between the current version in memory and the "LAST" version.

public virtual String RecordChangeString {get;}

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityBase.String Overload List


RecordChangeString Property (String)

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.RecordChangeString Property (String)

public abstract String this[
String sLinePrefix
] {get;}

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityBase.String Overload List


RecordChangeXML Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.RecordChangeXML Property

Returns an XML fragment describing the changes between the current version and the "LAST" version.

public virtual String RecordChangeXML {get;}

Property Value

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


RecordHistoryOmitObjectData Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.RecordHistoryOmitObjectData Property

protected abstract Boolean RecordHistoryOmitObjectData {get;}

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


RecordID Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.RecordID Property

Returns the Record ID for the currently loaded data record.

public virtual Int64 RecordID {get;}

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


RecordName Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.RecordName Property

This will return the value of the field that is defined as the Record Name.

public virtual String RecordName {get;}

Remarks

Entities can have a field defined to be the record name. This will return the value of the field that is defined as the Record Name.

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


RequiredFieldBackColor Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.RequiredFieldBackColor Property

Returns value of RequiredFieldTextColor field.

public virtual String RequiredFieldBackColor {get;}

Property Value

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


RequiredFieldFontName Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.RequiredFieldFontName Property

Returns value of RequiredFieldFontName field.

public virtual String RequiredFieldFontName {get;}

Property Value

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


RequiredFieldFontSize Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.RequiredFieldFontSize Property

Returns value of RequiredFieldFontSize field.

public virtual Int64 RequiredFieldFontSize {get;}

Property Value

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


RequiredFieldFontStyle Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.RequiredFieldFontStyle Property

Returns value of RequiredFieldFontStyle field.

public virtual String RequiredFieldFontStyle {get;}

Property Value

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


RequiredFieldTextColor Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.RequiredFieldTextColor Property

Returns value of RequiredFieldTextColor field.

public virtual String RequiredFieldTextColor {get;}

Property Value

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


RequireVersionComment Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.RequireVersionComment Property

protected Boolean RequireVersionComment {get;}

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


SequenceField Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.SequenceField Property

Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.

public virtual FieldAndParamName SequenceField {get;}

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


SequenceValue Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.SequenceValue Property

This will return the value of the field that is defined as the record sequence.

public virtual Object SequenceValue {get; set;}

Remarks

This will return the value of the field that is defined as the record sequence.

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


SharedObjectDataIsDirty Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.SharedObjectDataIsDirty Property

public virtual Boolean SharedObjectDataIsDirty {get;}

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


SharedRecordHasNoOwner Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.SharedRecordHasNoOwner Property

protected virtual Boolean SharedRecordHasNoOwner {get;}

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


SubTypeAddTempTableName Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.SubTypeAddTempTableName Property

protected String this[
Boolean CreateIfNecessary
] {get;}

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


SubTypeLevel Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.SubTypeLevel Property

Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.

public virtual Byte SubTypeLevel {get;}

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


SubTypes Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.SubTypes Property

Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.

public abstract AptifySubTypes SubTypes {get;}

Property Value

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


SupportsDynamicSharing Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.SupportsDynamicSharing Property

public virtual Boolean SupportsDynamicSharing {get;}

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


TrackRecordHistory Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.TrackRecordHistory Property

protected Boolean TrackRecordHistory {get;}

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


UpdateSQL Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.UpdateSQL Property

protected virtual String UpdateSQL {get;}

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


UseCache Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.UseCache Property

Allows a user to store whether or not Caching should be used for the loaded record.

public virtual Boolean UseCache {get; set;}

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


UserCredentials Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.UserCredentials Property

Allows a user to associate a set of user credentials in memory with a given record.

public virtual UserCredentials UserCredentials {get; set;}

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase Methods

The methods of the AptifyGenericEntityBase class are listed below. For a complete list of AptifyGenericEntityBase class members, see the AptifyGenericEntityBase Members topic.

Public Instance Methods

BeginTransaction | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates | This function will check for duplicate records of this record type.
ClearDirtyFlags | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields | Calls the Clear member for each associated Datafield.
Clone | Overloaded. Creates a new instance of the current GE object.
CommitTransaction | Commits the current transaction
Config | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete | Overloaded. Deletes the current record.
Diff | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants |
GetDataString | Returns a string which encapsulates the entire record and ALL sub types
GetDependencies | Overloaded. Returns other objects that are dependant UPON this object
GetDuplicateList | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion | Returns the Latest Record Version for this GE Record.
GetObjectData | This overridable method returns the Empty string.
GetRecordVersion | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. Returns the value of the specified DataField for the loaded record.
Load | Overloaded. Loads an existing instance with data.
LogRecordHistory | Overloaded. Responsible for creating a recordhistory record.
Merge | Overloaded. Merges two GE objects in memory.
NewRecord | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction | Rolls back the current transaction.
Save | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange | Saves the record into the Pending Changes entity instead of the current entity.
SaveToFile | Saves an XML Representation of the GE Object in a file with the provided name.
SetAddValue | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField |
SetNewSubTypeIDAndSequence | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo | Overloaded.
SetValue | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID |
Validate | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty |
BroadcastChange |
ClearSubTypeAddTempTableName |
CloneSubType |
DecrementCurrentTransactionCount |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
IncrementCurrentTransactionCount |
InnerValidate |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning | Raises the Warning Event.
RefreshLinkedFields |
ResetCurrentTransactionCount |
ResetEmbeddedObjectLists |
SaveExtenderObjects | Overloaded.
SetCurrentTransactionID |
SetLastError | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError | Sets the user error message that is retrieved by the LastUserError property
SetRecordID |
ValidateSubTypes |
VerifyObject |

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.AreExtenderObjectsDirty Method

protected virtual bool AreExtenderObjectsDirty();

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


BeginTransaction Method

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.BeginTransaction Method

Starts a new transaction if one has not been started or it will start a new segment on the current transaction.

Overload List

Starts a new transaction if one has not been started or it will start a new segment on the current transaction.

public virtual string BeginTransaction();

This will begin a new transaction for the current transaction id.

public abstract string BeginTransaction(String);

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.BeginTransaction Method ()

Starts a new transaction if one has not been started or it will start a new segment on the current transaction.

public virtual string BeginTransaction();

Return Value

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityBase.BeginTransaction Overload List


AptifyGenericEntityBase.BeginTransaction Method (String)

This will begin a new transaction for the current transaction id.

public abstract string BeginTransaction(
String TransactionID
);

Parameters

TransactionID

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityBase.BeginTransaction Overload List


AptifyGenericEntityBase.BroadcastChange Method

protected virtual void BroadcastChange();

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.CheckForDuplicates Method

This function will check for duplicate records of this record type.

public abstract bool CheckForDuplicates(
Boolean AllowGUI
);

Parameters

AllowGUI

Return Value

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.ClearDirtyFlags Method

Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.

public virtual void ClearDirtyFlags();

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.ClearFields Method

Calls the Clear member for each associated Datafield.

public abstract void ClearFields();

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.ClearSubTypeAddTempTableName Method

protected void ClearSubTypeAddTempTableName();

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


Clone Method

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.Clone Method

Creates a new instance of the current GE object.

Overload List

Creates a new instance of the current GE object.

public virtual void Clone(AptifyGenericEntityBase);

Creates a new instance of the current GE object.

public virtual void Clone(AptifyGenericEntityBase,Boolean);

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.Clone Method (AptifyGenericEntityBase)

Creates a new instance of the current GE object.

public virtual void Clone(
AptifyGenericEntityBase ObjectToClone
);

Parameters

ObjectToClone

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityBase.Clone Overload List


AptifyGenericEntityBase.Clone Method (AptifyGenericEntityBase, Boolean)

Creates a new instance of the current GE object.

public virtual void Clone(
AptifyGenericEntityBase ObjectToClone,
Boolean Merge
);

Parameters

ObjectToClone
Merge

Remarks

This includes Sub-Types and DataFields. If merge is set to true then it will add any datafields or sub-types that have been added in memory.

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityBase.Clone Overload List


AptifyGenericEntityBase.CloneSubType Method

protected abstract void CloneSubType(
AptifySubTypeBase SubTypeToClone,
Boolean Merge
);

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.CommitTransaction Method

Commits the current transaction

public abstract bool CommitTransaction();

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


Config Method

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.Config Method

Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.

Overload List

public virtual void Config(AptifySubTypeBase);

public virtual void Config(AptifySubTypeBase,Int64);

public virtual void Config(UserCredentials,String);

public virtual void Config(UserCredentials,String,Int64);

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.Config Method (AptifySubTypeBase)

public virtual void Config(
AptifySubTypeBase subType
);

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityBase.Config Overload List


AptifyGenericEntityBase.Config Method (AptifySubTypeBase, Int64)

public virtual void Config(
AptifySubTypeBase subType,
Int64 RecordID
);

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityBase.Config Overload List


AptifyGenericEntityBase.Config Method (UserCredentials, String)

public virtual void Config(
UserCredentials UserCredentials,
String EntityName
);

Parameters

UserCredentials
EntityName

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityBase.Config Overload List


AptifyGenericEntityBase.Config Method (UserCredentials, String, Int64)

public virtual void Config(
UserCredentials UserCredentials,
String EntityName,
Int64 RecordID
);

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityBase.Config Overload List


AptifyGenericEntityBase.DecrementCurrentTransactionCount Method

protected virtual void DecrementCurrentTransactionCount();

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


Delete Method

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.Delete Method

Deletes the current record.

Overload List

Deletes the current record.

public virtual bool Delete();

public abstract bool Delete(String);

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.Delete Method ()

Deletes the current record.

public virtual bool Delete();

Return Value

True if the delete succeeded. False if the delete failed.

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityBase.Delete Overload List


AptifyGenericEntityBase.Delete Method (String)

public abstract bool Delete(
String sTransactionID
);

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityBase.Delete Overload List


AptifyGenericEntityBase.Diff Method

Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.

public virtual void Diff(
AptifyGenericEntityBase ObjectToDiff,
String[] DiffFields
);

Parameters

ObjectToDiff
DiffFields

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.Display Method

Displays the current record in the Aptify Object Viewer.

public abstract void Display();

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.FinalizeTransaction Method

Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.

public abstract void FinalizeTransaction();

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.GenericRelinkDependants Method

public abstract bool GenericRelinkDependants(
String Entity,
Int64 NewID,
Int64 OldID
);

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.GetDataString Method

Returns a string which encapsulates the entire record and ALL sub types

public virtual string GetDataString();

Return Value

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GetDependencies Method

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.GetDependencies Method

Returns dependency information for the current record.

Overload List

Returns dependency information for the current record.

public abstract EntityDependenciesBase GetDependencies();

Returns other objects that are dependant UPON this object

public abstract bool GetDependencies(ref AptifyGenericEntityBase[]&);

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.GetDependencies Method ()

Returns dependency information for the current record.

public abstract EntityDependenciesBase GetDependencies();

Return Value

A collection of EntityDependant objects. Each EntityDependant object contains information about the record that it dependant on the current record.

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityBase.GetDependencies Overload List


AptifyGenericEntityBase.GetDependencies Method (AptifyGenericEntityBase[]&)

Returns other objects that are dependant UPON this object

public abstract bool GetDependencies(
ref AptifyGenericEntityBase[]& GEs
);

Parameters

GEs

Return Value

Returns other objects that are dependant UPON this object

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityBase.GetDependencies Overload List


AptifyGenericEntityBase.GetDuplicateList Method

Returns a list of duplicates that are either potential or absolute duplicates for the current object.

public abstract DuplicateCheckResult GetDuplicateList(
ref Int64[]& DuplicateIDs
);

Parameters

DuplicateIDs

Return Value

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.GetField Method

Returns an instance of the DataField that corresponds to the given field name.

public virtual AptifyDataFieldBase GetField(
String FieldName
);

Parameters

FieldName

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.GetFieldIndex Method

Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.

public virtual int GetFieldIndex(
String FieldName
);

Parameters

FieldName

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.GetLatestRecordVersion Method

Returns the Latest Record Version for this GE Record.

public abstract long GetLatestRecordVersion();

Remarks

GetLatestRecordVersion is a candidate for removal if new. Record History architecture implemented with triggers is adopted.

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.GetObjectData Method

This overridable method returns the Empty string.

public virtual string GetObjectData(
Boolean bIncrementVersion
);

Parameters

bIncrementVersion

Return Value

always returns the empty string

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.GetRecordVersion Method

Returns the current version of the loaded record.

public abstract long GetRecordVersion();

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GetValue Method

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.GetValue Method

Returns the value of the specified DataField for the loaded record.

Overload List

Returns the value of the specified DataField for the loaded record.

public virtual object GetValue(String);

Returns the value of the specified DataField for the loaded record. Allows the developer to request an update from the UI prior to returning the value.

public virtual object GetValue(String,Boolean);

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.GetValue Method (String)

Returns the value of the specified DataField for the loaded record.

public virtual object GetValue(
String FieldName
);

Parameters

FieldName
Name of the field.

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityBase.GetValue Overload List


AptifyGenericEntityBase.GetValue Method (String, Boolean)

Returns the value of the specified DataField for the loaded record. Allows the developer to request an update from the UI prior to returning the value.

public virtual object GetValue(
String FieldName,
Boolean ForceRefresh
);

Parameters

FieldName
Name of the field.
ForceRefresh
Boolean indicating if a refresh request should be made.

Return Value

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityBase.GetValue Overload List


AptifyGenericEntityBase.IncrementCurrentTransactionCount Method

protected virtual void IncrementCurrentTransactionCount();

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.InnerValidate Method

protected abstract bool InnerValidate(
ref String& ErrorString
);

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


Load Method

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.Load Method

Loads an existing instance with data.

Overload List

public abstract void Load(DataRow);

public abstract void Load(IDataReader);

public abstract void Load(Int64);

public virtual void Load(String);

public abstract void Load(String,Boolean);

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.Load Method (DataRow)

public abstract void Load(
DataRow DataRow
);

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityBase.Load Overload List


AptifyGenericEntityBase.Load Method (IDataReader)

public abstract void Load(
IDataReader DataReader
);

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityBase.Load Overload List


AptifyGenericEntityBase.Load Method (Int64)

public abstract void Load(
Int64 ID
);

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityBase.Load Overload List


AptifyGenericEntityBase.Load Method (String)

public virtual void Load(
String FileName
);

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityBase.Load Overload List


AptifyGenericEntityBase.Load Method (String, Boolean)

public abstract void Load(
String FileName,
Boolean MergeSubTypes
);

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityBase.Load Overload List


LogRecordHistory Method

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.LogRecordHistory Method

Responsible for creating a recordhistory record.

Overload List

public virtual void LogRecordHistory(String,Int64,Int64,String,String);

public abstract void LogRecordHistory(String,Int64,Int64,String,String,String,String,String,String,String);

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.LogRecordHistory Method (String, Int64, Int64, String, String)

public virtual void LogRecordHistory(
String TransactionID,
Int64 EntityID,
Int64 RecordID,
String Changes,
String RecordData
);

Parameters

TransactionID
EntityID
RecordID
Changes
RecordData

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityBase.LogRecordHistory Overload List


AptifyGenericEntityBase.LogRecordHistory Method (String, Int64, Int64, String, String, String, String, String, String, String)

public abstract void LogRecordHistory(
String TransactionID,
Int64 EntityID,
Int64 RecordID,
String Changes,
String RecordData,
String VersionComments,
String Person,
String Email,
String Title,
String Phone
);

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityBase.LogRecordHistory Overload List


Merge Method

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.Merge Method

Merges two GE objects in memory.

Overload List

public virtual void Merge(AptifyGenericEntityBase);

public virtual void Merge(AptifyGenericEntityBase,String);

public virtual void Merge(AptifyGenericEntityBase,String,Boolean);

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.Merge Method (AptifyGenericEntityBase)

public virtual void Merge(
AptifyGenericEntityBase ObjectToMerge
);

Parameters

ObjectToMerge

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityBase.Merge Overload List


AptifyGenericEntityBase.Merge Method (AptifyGenericEntityBase, String)

public virtual void Merge(
AptifyGenericEntityBase ObjectToMerge,
String MergeFields
);

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityBase.Merge Overload List


AptifyGenericEntityBase.Merge Method (AptifyGenericEntityBase, String, Boolean)

public virtual void Merge(
AptifyGenericEntityBase ObjectToMerge,
String MergeFields,
Boolean MergeBlanks
);

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityBase.Merge Overload List


AptifyGenericEntityBase.NewRecord Method

Clears all of the Fields and sub-types for a GE object.

public abstract bool NewRecord();

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.OnAfterCloneRecord Method

Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.

protected void OnAfterCloneRecord();

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.OnAfterDeleteRecord Method

Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.

protected void OnAfterDeleteRecord(
String TransactionID
);

Parameters

TransactionID
The TransactionID passed in to the Generic Entity's Delete method.

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.OnAfterLoadRecord Method

Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.

protected void OnAfterLoadRecord();

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.OnAfterNewRecord Method

Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.

protected void OnAfterNewRecord();

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.OnAfterSaveRecord Method

Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.

protected void OnAfterSaveRecord(
Boolean AllowGUI,
String TransactionID
);

Parameters

AllowGUI
The AllowGUI setting passed in to the Generic Entity's Save method.
TransactionID
The TransactionID passed in to the Generic Entity's Save method.

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.OnAfterValidateRecord Method

Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.

protected void OnAfterValidateRecord(
ref String& ErrorString
);

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.OnBeforeCloneRecord Method

Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.

protected bool OnBeforeCloneRecord(
AptifyGenericEntityBase ObjectToClone,
ref Boolean& Merge
);

Parameters

ObjectToClone
Generic Entity object that will be cloned, if the operation is allowed to procedure.
Merge
If true, the ObjectToClone Generic Entity will be merged with the current Generic Entity. If false, the current GE information will be replaced with the ObjectToClone Generic Entity's information.

Return Value

Returns false if the BeforeCloneRecord event handler set Cancel property to True or if an exception was raised by the event handler. Otherwise, returns True.

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.OnBeforeDeleteRecord Method

Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.

protected bool OnBeforeDeleteRecord(
String TransactionID
);

Parameters

TransactionID
The TransactionID passed in to the Generic Entity's Delete method.

Return Value

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


OnBeforeLoadRecord Method

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.OnBeforeLoadRecord Method

Overload List

protected bool OnBeforeLoadRecord(DataRow);

protected bool OnBeforeLoadRecord(IDataReader);

Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.

protected bool OnBeforeLoadRecord(Int64);

protected bool OnBeforeLoadRecord(String);

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.OnBeforeLoadRecord Method (DataRow)

protected bool OnBeforeLoadRecord(
DataRow row
);

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityBase.OnBeforeLoadRecord Overload List


AptifyGenericEntityBase.OnBeforeLoadRecord Method (IDataReader)

protected bool OnBeforeLoadRecord(
IDataReader reader
);

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityBase.OnBeforeLoadRecord Overload List


AptifyGenericEntityBase.OnBeforeLoadRecord Method (Int64)

Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.

protected bool OnBeforeLoadRecord(
Int64 ID
);

Return Value

Returns false if the BeforeLoadRecord event handler set Cancel property to True or if an exception was raised by the event handler. Otherwise, returns True.

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityBase.OnBeforeLoadRecord Overload List


AptifyGenericEntityBase.OnBeforeLoadRecord Method (String)

protected bool OnBeforeLoadRecord(
String Filename
);

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityBase.OnBeforeLoadRecord Overload List


AptifyGenericEntityBase.OnBeforeNewRecord Method

Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.

protected bool OnBeforeNewRecord();

Return Value

Returns false if the BeforeNewRecord event handler set Cancel property to True or if an exception was raised by the event handler. Otherwise, returns True.

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.OnBeforeSaveRecord Method

Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.

protected bool OnBeforeSaveRecord(
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

Parameters

AllowGUI
The AllowGUI setting passed in to the Generic Entity's Save method.
ErrorString
The ErrorString setting passed in to the Generic Entity's Save method. The Event Handler can change this value and it will be passed back to the Generic Entity's Save method.
TransactionID
The TransactionID passed in to the Generic Entity's Save method.

Return Value

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.OnBeforeValidateRecord Method

Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.

protected bool OnBeforeValidateRecord(
ref String& ErrorString
);

Return Value

Returns false if the BeforeValidateRecord event handler set Cancel property to True or if an exception was raised by the event handler. Otherwise, returns True.

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.OnWarning Method

Raises the Warning Event.

protected MsgBoxResult OnWarning(
String Message,
String Title,
MsgBoxStyle Style,
MsgBoxResult DefaultResult
);

Return Value

Returns the value of the Result property in the WarningEventArgs object. Result is set to the DefaultResult value but can be overridden by an Event Handler. If an exception is caught, Result will be set to MsgBoxResult.Abort

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.RefreshLinkedFields Method

protected abstract void RefreshLinkedFields(
AptifyDataFieldBase oFKeyField
);

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.ResetCurrentTransactionCount Method

protected virtual void ResetCurrentTransactionCount();

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.ResetEmbeddedObjectLists Method

protected abstract void ResetEmbeddedObjectLists();

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.RollbackRecordID Method

It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.

public abstract void RollbackRecordID();

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.RollbackTransaction Method

Rolls back the current transaction.

public abstract bool RollbackTransaction();

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


Save Method

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.Save Method

Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.

Overload List

Attempts to save the Current GE data.

public virtual bool Save();

public virtual bool Save(Boolean);

public virtual bool Save(Boolean,ref String&);

Attempts to save the Current GE data.

public abstract bool Save(Boolean,ref String&,String);

public virtual bool Save(ref String&);

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.Save Method ()

Attempts to save the Current GE data.

public virtual bool Save();

Return Value

Returns True if the save succeeded. Returns False if the save failed.

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityBase.Save Overload List


AptifyGenericEntityBase.Save Method (Boolean)

public virtual bool Save(
Boolean AllowGUI
);

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityBase.Save Overload List


AptifyGenericEntityBase.Save Method (Boolean, String&)

public virtual bool Save(
Boolean AllowGUI,
ref String& ErrorString
);

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityBase.Save Overload List


AptifyGenericEntityBase.Save Method (Boolean, String&, String)

Attempts to save the Current GE data.

public abstract bool Save(
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

Parameters

AllowGUI
Can be used to determine if the Object is allowed to show a GUI to the user.
ErrorString
The message corresponding to any exceptions that may have been encountered.
TransactionID
The transaction that the save should be segmented onto.

Remarks

When this method is overridden in a sub-class of this object, the sub-class should handle its own exceptions. This means that it should publish the exception and then show a GUI if it is allowed and it is desirable to show a GUI.

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityBase.Save Overload List


AptifyGenericEntityBase.Save Method (String&)

public virtual bool Save(
ref String& ErrorString
);

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityBase.Save Overload List


AptifyGenericEntityBase.SaveAsPendingChange Method

Saves the record into the Pending Changes entity instead of the current entity.

public abstract bool SaveAsPendingChange(
Int64 PendingChangeTypeID,
DateTime ScheduledDate,
String ConflictReason,
AptifyGenericEntityBase.PendingChangeUpdateType ConflictType,
Int64 SourceServerID
);

Parameters

PendingChangeTypeID
Long indicating the pending change type to save the record as.
ScheduledDate
Optional date used to specify when the pending change is to take effect. Necessary if Pending Change Type supports scheduling.
ConflictReason
ConflictType
SourceServerID

Return Value

Returns a boolean indicating if the record saved or not.

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


SaveExtenderObjects Method

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.SaveExtenderObjects Method

Overload List

protected abstract bool SaveExtenderObjects(Boolean,String);

protected abstract bool SaveExtenderObjects(Boolean,ref String&,String);

protected abstract bool SaveExtenderObjects(String);

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.SaveExtenderObjects Method (Boolean, String)

protected abstract bool SaveExtenderObjects(
Boolean AllowGUI,
String TransactionID
);

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityBase.SaveExtenderObjects Overload List


AptifyGenericEntityBase.SaveExtenderObjects Method (Boolean, String&, String)

protected abstract bool SaveExtenderObjects(
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityBase.SaveExtenderObjects Overload List


AptifyGenericEntityBase.SaveExtenderObjects Method (String)

protected abstract bool SaveExtenderObjects(
String TransactionID
);

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityBase.SaveExtenderObjects Overload List


AptifyGenericEntityBase.SaveToFile Method

Saves an XML Representation of the GE Object in a file with the provided name.

public abstract void SaveToFile(
String FileName
);

Parameters

FileName

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


SetAddValue Method

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.SetAddValue Method

Sets a value for or Adds a value for a DataField.

Overload List

Sets a value for or Adds a value for a DataField.

public virtual void SetAddValue(String,Object);

Sets a value for or Adds a value for a DataField. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.

public abstract void SetAddValue(String,String,Object);

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.SetAddValue Method (String, Object)

Sets a value for or Adds a value for a DataField.

public virtual void SetAddValue(
String FieldName,
Object Value
);

Parameters

FieldName
Value

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityBase.SetAddValue Overload List


AptifyGenericEntityBase.SetAddValue Method (String, String, Object)

Sets a value for or Adds a value for a DataField. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.

public abstract void SetAddValue(
String FieldName,
String SQLDataType,
Object Value
);

Parameters

FieldName
SQLDataType
Used to set the Data Type for a temporary field. This value will be ignored if the field already exists.
Value

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityBase.SetAddValue Overload List


AptifyGenericEntityBase.SetContainerLinkedDataField Method

public virtual void SetContainerLinkedDataField(
AptifyDataFieldBase linkedDataField
);

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.SetCurrentTransactionID Method

protected virtual void SetCurrentTransactionID(
String TransactionID
);

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.SetLastError Method

Sets the internal error code that is retrieved by the LastError property.

protected virtual void SetLastError(
String ErrorString
);

Parameters

ErrorString

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.SetLastUserError Method

Sets the user error message that is retrieved by the LastUserError property

protected virtual void SetLastUserError(
String ErrorString
);

Parameters

ErrorString

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.SetNewSubTypeIDAndSequence Method

Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.

public abstract void SetNewSubTypeIDAndSequence(
Int64 ID,
Int32 Sequence
);

Parameters

ID
The ID for the new Sub-Type record.
Sequence
The Sequence value for the new Sub-Type record. If the Sub-Type does not have a Sequence field this value will be ignored.

Remarks

This is a method used for internal processing in the Generic Entity.

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


SetProcInfo Method

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.SetProcInfo Method

Overload List

public virtual void SetProcInfo(String);

Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.

public virtual void SetProcInfo(String,String);

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.SetProcInfo Method (String)

public virtual void SetProcInfo(
String CreateSQL
);

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityBase.SetProcInfo Overload List


AptifyGenericEntityBase.SetProcInfo Method (String, String)

Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.

public virtual void SetProcInfo(
String CreateSQL,
String UpdateSQL
);

Parameters

CreateSQL
UpdateSQL

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityBase.SetProcInfo Overload List


AptifyGenericEntityBase.SetRecordID Method

protected virtual void SetRecordID(
Int64 ID
);

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.SetValue Method

Sets the value of an existing field in the fields collection.

public virtual void SetValue(
String FieldName,
Object Value
);

Parameters

FieldName
Value

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.UpdateEmbeddedObjectsNeedingRecordID Method

public abstract bool UpdateEmbeddedObjectsNeedingRecordID(
String TransactionID
);

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


Validate Method

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityBase.Validate Method

Overload List

public virtual bool Validate();

public virtual bool Validate(ref String&);

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.Validate Method ()

public virtual bool Validate();

Return Value

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityBase.Validate Overload List


AptifyGenericEntityBase.Validate Method (String&)

public virtual bool Validate(
ref String& ErrorString
);

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityBase.Validate Overload List


AptifyGenericEntityBase.ValidateSubTypes Method

protected virtual bool ValidateSubTypes(
ref String& sError
);

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.VerifyObject Method

protected abstract bool VerifyObject(
Boolean AllowGUI
);

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase Events

The events of the AptifyGenericEntityBase class are listed below. For a complete list of AptifyGenericEntityBase class members, see the AptifyGenericEntityBase Members topic.

Public Instance Events

AfterCloneRecord | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.AptifyGenericEntityBase.AfterCloneRecordEventHandler Event

Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.

public event AptifyGenericEntityBase.AfterCloneRecordEventHandler AfterCloneRecord;

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.AptifyGenericEntityBase.AfterDeleteRecordEventHandler Event

Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.

public event AptifyGenericEntityBase.AfterDeleteRecordEventHandler AfterDeleteRecord;

Event Data

The event handler receives an argument of type AfterDeleteRecordEventArgs containing data related to this event. The following AfterDeleteRecordEventArgs property provides information specific to this event.

Property | Description
TransactionID |

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.AptifyGenericEntityBase.AfterLoadRecordEventHandler Event

Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.

public event AptifyGenericEntityBase.AfterLoadRecordEventHandler AfterLoadRecord;

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.AptifyGenericEntityBase.AfterNewRecordEventHandler Event

Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.

public event AptifyGenericEntityBase.AfterNewRecordEventHandler AfterNewRecord;

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.AptifyGenericEntityBase.AfterSaveRecordEventHandler Event

Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.

public event AptifyGenericEntityBase.AfterSaveRecordEventHandler AfterSaveRecord;

Event Data

The event handler receives an argument of type AfterSaveRecordEventArgs containing data related to this event. The following AfterSaveRecordEventArgs properties provide information specific to this event.

Property | Description
AllowGUI |
TransactionID |

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.AptifyGenericEntityBase.AfterValidateRecordEventHandler Event

Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.

public event AptifyGenericEntityBase.AfterValidateRecordEventHandler AfterValidateRecord;

Event Data

The event handler receives an argument of type AfterValidateRecordEventArgs containing data related to this event. The following AfterValidateRecordEventArgs property provides information specific to this event.

Property | Description
ErrorString | Contains the ErrorString populated by the Generic Entity's Validate routine. The ErrorString property can be changed by the Event Handler.

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.AptifyGenericEntityBase.BeforeCloneRecordEventHandler Event

Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.

public event AptifyGenericEntityBase.BeforeCloneRecordEventHandler BeforeCloneRecord;

Event Data

The event handler receives an argument of type BeforeCloneRecordEventArgs containing data related to this event. The following BeforeCloneRecordEventArgs properties provide information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.
geToClone | Represents the Generic Entity object that will be cloned.
Merge | Represents the Merge setting, either True or False. The Event Handler can change this value.

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.AptifyGenericEntityBase.BeforeDeleteRecordEventHandler Event

Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.

public event AptifyGenericEntityBase.BeforeDeleteRecordEventHandler BeforeDeleteRecord;

Event Data

The event handler receives an argument of type BeforeDeleteRecordEventArgs containing data related to this event. The following BeforeDeleteRecordEventArgs properties provide information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.
TransactionID |

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.AptifyGenericEntityBase.BeforeLoadRecordEventHandler Event

Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.

public event AptifyGenericEntityBase.BeforeLoadRecordEventHandler BeforeLoadRecord;

Event Data

The event handler receives an argument of type BeforeLoadRecordEventArgs containing data related to this event. The following BeforeLoadRecordEventArgs properties provide information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.
Filename |
ID |
LoadType |
Reader |
Row |

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.AptifyGenericEntityBase.BeforeNewRecordEventHandler Event

Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.

public event AptifyGenericEntityBase.BeforeNewRecordEventHandler BeforeNewRecord;

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.AptifyGenericEntityBase.BeforeSaveRecordEventHandler Event

Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.

public event AptifyGenericEntityBase.BeforeSaveRecordEventHandler BeforeSaveRecord;

Event Data

The event handler receives an argument of type BeforeSaveRecordEventArgs containing data related to this event. The following BeforeSaveRecordEventArgs properties provide information specific to this event.

Property | Description
AllowGUI |
Cancel | Gets or sets a value indicating whether the event should be canceled.
ErrorString |
TransactionID |

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.AptifyGenericEntityBase.BeforeValidateRecordEventHandler Event

Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.

public event AptifyGenericEntityBase.BeforeValidateRecordEventHandler BeforeValidateRecord;

Event Data

The event handler receives an argument of type BeforeValidateRecordEventArgs containing data related to this event. The following BeforeValidateRecordEventArgs properties provide information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.
ErrorString | Used to pass an error into the Validate routine. If m_sError is not an empty string, the Validate routine will fail and the Generic Entity's LastError property will return the ErrorString.

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.AptifyGenericEntityBase.WarningEventHandler Event

This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

public event AptifyGenericEntityBase.WarningEventHandler Warning;

Event Data

The event handler receives an argument of type WarningEventArgs containing data related to this event. The following WarningEventArgs properties provide information specific to this event.

Property | Description
DefaultResult |
Handled |
Message |
Result |
Style |
Title |

Remarks

See Also

AptifyGenericEntityBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.AfterCloneRecordEventHandler Delegate

public delegate void AptifyGenericEntityBase.AfterCloneRecordEventHandler(
AptifyGenericEntityBase sender,
EventArgs e
);

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.AfterDeleteRecordEventHandler Delegate

public delegate void AptifyGenericEntityBase.AfterDeleteRecordEventHandler(
AptifyGenericEntityBase sender,
AfterDeleteRecordEventArgs e
);

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.AfterLoadRecordEventHandler Delegate

public delegate void AptifyGenericEntityBase.AfterLoadRecordEventHandler(
AptifyGenericEntityBase sender,
EventArgs e
);

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.AfterNewRecordEventHandler Delegate

public delegate void AptifyGenericEntityBase.AfterNewRecordEventHandler(
AptifyGenericEntityBase sender,
EventArgs e
);

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.AfterSaveRecordEventHandler Delegate

public delegate void AptifyGenericEntityBase.AfterSaveRecordEventHandler(
AptifyGenericEntityBase sender,
AfterSaveRecordEventArgs e
);

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.AfterValidateRecordEventHandler Delegate

public delegate void AptifyGenericEntityBase.AfterValidateRecordEventHandler(
AptifyGenericEntityBase sender,
AfterValidateRecordEventArgs e
);

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.AptifyGenericEntityEvents Enumeration

Enumeration that identifies the different Event settings available on a Generic Entity.

public enum AptifyGenericEntityBase.AptifyGenericEntityEvents

Remarks

Members

Member Name | Description
None |
AllEvents |
NewRecord |
LoadRecord |
ValidateRecord |
SaveRecord |
DeleteRecord |
CloneRecord |

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.BeforeCloneRecordEventHandler Delegate

public delegate void AptifyGenericEntityBase.BeforeCloneRecordEventHandler(
AptifyGenericEntityBase sender,
BeforeCloneRecordEventArgs e
);

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.BeforeDeleteRecordEventHandler Delegate

public delegate void AptifyGenericEntityBase.BeforeDeleteRecordEventHandler(
AptifyGenericEntityBase sender,
BeforeDeleteRecordEventArgs e
);

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.BeforeLoadRecordEventHandler Delegate

public delegate void AptifyGenericEntityBase.BeforeLoadRecordEventHandler(
AptifyGenericEntityBase sender,
BeforeLoadRecordEventArgs e
);

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.BeforeNewRecordEventHandler Delegate

public delegate void AptifyGenericEntityBase.BeforeNewRecordEventHandler(
AptifyGenericEntityBase sender,
CancelEventArgs e
);

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.BeforeSaveRecordEventHandler Delegate

public delegate void AptifyGenericEntityBase.BeforeSaveRecordEventHandler(
AptifyGenericEntityBase sender,
BeforeSaveRecordEventArgs e
);

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.BeforeValidateRecordEventHandler Delegate

public delegate void AptifyGenericEntityBase.BeforeValidateRecordEventHandler(
AptifyGenericEntityBase sender,
BeforeValidateRecordEventArgs e
);

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.PendingChangeUpdateType Enumeration

Enumerated Constant representing primarily conflict row types.

public enum AptifyGenericEntityBase.PendingChangeUpdateType

Remarks

Members

Member Name | Description
Insert | Conflict occurred during an insert.
Update | Conflict occurred during an update.
Delete | Conflict occurred during a delete.
Logical | Conflict occurred during a logical record operation.
None | Operation was not a conflict.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityBase.WarningEventHandler Delegate

public delegate void AptifyGenericEntityBase.WarningEventHandler(
AptifyGenericEntityBase sender,
WarningEventArgs e
);

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityConflictException Class

For a list of all members of this type, see AptifyGenericEntityConflictException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
AptifyGenericEntityException
AptifyGenericEntityConflictException

public class AptifyGenericEntityConflictException : AptifyGenericEntityException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntity (in AptifyGenericEntity.dll)

See Also

AptifyGenericEntityConflictException Members | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityConflictException Members

AptifyGenericEntityConflictException overview

Public Instance Constructors

AptifyGenericEntityConflictException Overloaded. Initializes a new instance of the AptifyGenericEntityConflictException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Entity |
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
ErrorString |
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Constructors

AptifyGenericEntityConflictException Overloaded. Initializes a new instance of the AptifyGenericEntityConflictException class.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyGenericEntityConflictException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityConflictException Constructor

Overload List

protected AptifyGenericEntityConflictException(SerializationInfo,StreamingContext);

public AptifyGenericEntityConflictException(String,String);

public AptifyGenericEntityConflictException(String,String,Exception);

See Also

AptifyGenericEntityConflictException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityConflictException Constructor (String, String)

public AptifyGenericEntityConflictException(
String Entity,
String ErrorString
);

See Also

AptifyGenericEntityConflictException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityConflictException Constructor Overload List


AptifyGenericEntityConflictException Constructor (String, String, Exception)

public AptifyGenericEntityConflictException(
String Entity,
String ErrorString,
Exception inner
);

See Also

AptifyGenericEntityConflictException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityConflictException Constructor Overload List


AptifyGenericEntityConflictException Constructor (SerializationInfo, StreamingContext)

protected AptifyGenericEntityConflictException(
SerializationInfo info,
StreamingContext context
);

See Also

AptifyGenericEntityConflictException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityConflictException Constructor Overload List


AptifyGenericEntityConflictException Properties

The properties of the AptifyGenericEntityConflictException class are listed below. For a complete list of AptifyGenericEntityConflictException class members, see the AptifyGenericEntityConflictException Members topic.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Entity |
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
ErrorString |
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

See Also

AptifyGenericEntityConflictException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


Entity Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityConflictException.Entity Property

public String Entity {get;}

See Also

AptifyGenericEntityConflictException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ErrorString Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityConflictException.ErrorString Property

public String ErrorString {get;}

See Also

AptifyGenericEntityConflictException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityConflictException Methods

The methods of the AptifyGenericEntityConflictException class are listed below. For a complete list of AptifyGenericEntityConflictException class members, see the AptifyGenericEntityConflictException Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyGenericEntityConflictException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityConflictException.GetObjectData Method

public override void GetObjectData(
SerializationInfo info,
StreamingContext context
);

Implements

ISerializable.

See Also

AptifyGenericEntityConflictException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityDatabaseOperationException Class

For a list of all members of this type, see AptifyGenericEntityDatabaseOperationException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
AptifyGenericEntityException
AptifyGenericEntityDatabaseOperationException

public class AptifyGenericEntityDatabaseOperationException : AptifyGenericEntityException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntity (in AptifyGenericEntity.dll)

See Also

AptifyGenericEntityDatabaseOperationException Members | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityDatabaseOperationException Members

AptifyGenericEntityDatabaseOperationException overview

Public Instance Constructors

AptifyGenericEntityDatabaseOperationException Overloaded. Initializes a new instance of the AptifyGenericEntityDatabaseOperationException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Entity |
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Operation |
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
SQL |
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Constructors

AptifyGenericEntityDatabaseOperationException Overloaded. Initializes a new instance of the AptifyGenericEntityDatabaseOperationException class.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyGenericEntityDatabaseOperationException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityDatabaseOperationException Constructor

Overload List

protected AptifyGenericEntityDatabaseOperationException(SerializationInfo,StreamingContext);

public AptifyGenericEntityDatabaseOperationException(String,String,String);

public AptifyGenericEntityDatabaseOperationException(String,String,String,Exception);

See Also

AptifyGenericEntityDatabaseOperationException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityDatabaseOperationException Constructor (String, String, String)

public AptifyGenericEntityDatabaseOperationException(
String Entity,
String Operation,
String SQL
);

See Also

AptifyGenericEntityDatabaseOperationException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityDatabaseOperationException Constructor Overload List


AptifyGenericEntityDatabaseOperationException Constructor (String, String, String, Exception)

public AptifyGenericEntityDatabaseOperationException(
String Entity,
String Operation,
String SQL,
Exception inner
);

See Also

AptifyGenericEntityDatabaseOperationException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityDatabaseOperationException Constructor Overload List


AptifyGenericEntityDatabaseOperationException Constructor (SerializationInfo, StreamingContext)

protected AptifyGenericEntityDatabaseOperationException(
SerializationInfo info,
StreamingContext context
);

See Also

AptifyGenericEntityDatabaseOperationException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityDatabaseOperationException Constructor Overload List


AptifyGenericEntityDatabaseOperationException Properties

The properties of the AptifyGenericEntityDatabaseOperationException class are listed below. For a complete list of AptifyGenericEntityDatabaseOperationException class members, see the AptifyGenericEntityDatabaseOperationException Members topic.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Entity |
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Operation |
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
SQL |
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

See Also

AptifyGenericEntityDatabaseOperationException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


Entity Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityDatabaseOperationException.Entity Property

public String Entity {get;}

See Also

AptifyGenericEntityDatabaseOperationException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


Operation Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityDatabaseOperationException.Operation Property

public String Operation {get;}

See Also

AptifyGenericEntityDatabaseOperationException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


SQL Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityDatabaseOperationException.SQL Property

public String SQL {get;}

See Also

AptifyGenericEntityDatabaseOperationException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityDatabaseOperationException Methods

The methods of the AptifyGenericEntityDatabaseOperationException class are listed below. For a complete list of AptifyGenericEntityDatabaseOperationException class members, see the AptifyGenericEntityDatabaseOperationException Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyGenericEntityDatabaseOperationException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityDatabaseOperationException.GetObjectData Method

public override void GetObjectData(
SerializationInfo info,
StreamingContext context
);

Implements

ISerializable.

See Also

AptifyGenericEntityDatabaseOperationException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityDuplicateCheckFailureException Class

For a list of all members of this type, see AptifyGenericEntityDuplicateCheckFailureException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
AptifyGenericEntityException
AptifyGenericEntityDuplicateCheckFailureException

public class AptifyGenericEntityDuplicateCheckFailureException : AptifyGenericEntityException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntity (in AptifyGenericEntity.dll)

See Also

AptifyGenericEntityDuplicateCheckFailureException Members | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityDuplicateCheckFailureException Members

AptifyGenericEntityDuplicateCheckFailureException overview

Public Instance Constructors

AptifyGenericEntityDuplicateCheckFailureException Overloaded. Initializes a new instance of the AptifyGenericEntityDuplicateCheckFailureException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
DuplicateIDString |
Entity |
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Constructors

AptifyGenericEntityDuplicateCheckFailureException Overloaded. Initializes a new instance of the AptifyGenericEntityDuplicateCheckFailureException class.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyGenericEntityDuplicateCheckFailureException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityDuplicateCheckFailureException Constructor

Overload List

protected AptifyGenericEntityDuplicateCheckFailureException(SerializationInfo,StreamingContext);

public AptifyGenericEntityDuplicateCheckFailureException(String,Int64[]);

public AptifyGenericEntityDuplicateCheckFailureException(String,Int64[],Exception);

See Also

AptifyGenericEntityDuplicateCheckFailureException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityDuplicateCheckFailureException Constructor (String, Int64[])

public AptifyGenericEntityDuplicateCheckFailureException(
String Entity,
Int64[] DuplicateIDs
);

See Also

AptifyGenericEntityDuplicateCheckFailureException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityDuplicateCheckFailureException Constructor Overload List


AptifyGenericEntityDuplicateCheckFailureException Constructor (String, Int64[], Exception)

public AptifyGenericEntityDuplicateCheckFailureException(
String Entity,
Int64[] DuplicateIDs,
Exception inner
);

See Also

AptifyGenericEntityDuplicateCheckFailureException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityDuplicateCheckFailureException Constructor Overload List


AptifyGenericEntityDuplicateCheckFailureException Constructor (SerializationInfo, StreamingContext)

protected AptifyGenericEntityDuplicateCheckFailureException(
SerializationInfo info,
StreamingContext context
);

See Also

AptifyGenericEntityDuplicateCheckFailureException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityDuplicateCheckFailureException Constructor Overload List


AptifyGenericEntityDuplicateCheckFailureException Properties

The properties of the AptifyGenericEntityDuplicateCheckFailureException class are listed below. For a complete list of AptifyGenericEntityDuplicateCheckFailureException class members, see the AptifyGenericEntityDuplicateCheckFailureException Members topic.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
DuplicateIDString |
Entity |
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

See Also

AptifyGenericEntityDuplicateCheckFailureException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


DuplicateIDString Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityDuplicateCheckFailureException.DuplicateIDString Property

public String DuplicateIDString {get;}

See Also

AptifyGenericEntityDuplicateCheckFailureException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


Entity Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityDuplicateCheckFailureException.Entity Property

public String Entity {get;}

See Also

AptifyGenericEntityDuplicateCheckFailureException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityDuplicateCheckFailureException Methods

The methods of the AptifyGenericEntityDuplicateCheckFailureException class are listed below. For a complete list of AptifyGenericEntityDuplicateCheckFailureException class members, see the AptifyGenericEntityDuplicateCheckFailureException Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyGenericEntityDuplicateCheckFailureException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityDuplicateCheckFailureException.GetObjectData Method

public override void GetObjectData(
SerializationInfo info,
StreamingContext context
);

Implements

ISerializable.

See Also

AptifyGenericEntityDuplicateCheckFailureException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityEventFailureException Class

Thrown when an Aptify Event returns a Failure.

For a list of all members of this type, see AptifyGenericEntityEventFailureException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
AptifyGenericEntityException
AptifyGenericEntityEventFailureException

public class AptifyGenericEntityEventFailureException : AptifyGenericEntityException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntity (in AptifyGenericEntity.dll)

See Also

AptifyGenericEntityEventFailureException Members | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityEventFailureException Members

AptifyGenericEntityEventFailureException overview

Public Instance Constructors

AptifyGenericEntityEventFailureException Overloaded. Initializes a new instance of the AptifyGenericEntityEventFailureException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Entity |
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
ErrorString |
EventName |
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
ResultCode |
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Constructors

AptifyGenericEntityEventFailureException Overloaded. Initializes a new instance of the AptifyGenericEntityEventFailureException class.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyGenericEntityEventFailureException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityEventFailureException Constructor

Overload List

protected AptifyGenericEntityEventFailureException(SerializationInfo,StreamingContext);

public AptifyGenericEntityEventFailureException(String,String,String,String);

public AptifyGenericEntityEventFailureException(String,String,String,String,Exception);

See Also

AptifyGenericEntityEventFailureException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityEventFailureException Constructor (String, String, String, String)

public AptifyGenericEntityEventFailureException(
String Entity,
String EventName,
String ResultCode,
String ErrorString
);

See Also

AptifyGenericEntityEventFailureException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityEventFailureException Constructor Overload List


AptifyGenericEntityEventFailureException Constructor (String, String, String, String, Exception)

public AptifyGenericEntityEventFailureException(
String Entity,
String EventName,
String ResultCode,
String ErrorString,
Exception inner
);

See Also

AptifyGenericEntityEventFailureException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityEventFailureException Constructor Overload List


AptifyGenericEntityEventFailureException Constructor (SerializationInfo, StreamingContext)

protected AptifyGenericEntityEventFailureException(
SerializationInfo info,
StreamingContext context
);

See Also

AptifyGenericEntityEventFailureException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityEventFailureException Constructor Overload List


AptifyGenericEntityEventFailureException Properties

The properties of the AptifyGenericEntityEventFailureException class are listed below. For a complete list of AptifyGenericEntityEventFailureException class members, see the AptifyGenericEntityEventFailureException Members topic.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Entity |
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
ErrorString |
EventName |
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
ResultCode |
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

See Also

AptifyGenericEntityEventFailureException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


Entity Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityEventFailureException.Entity Property

public String Entity {get;}

See Also

AptifyGenericEntityEventFailureException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ErrorString Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityEventFailureException.ErrorString Property

public String ErrorString {get;}

See Also

AptifyGenericEntityEventFailureException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


EventName Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityEventFailureException.EventName Property

public String EventName {get;}

See Also

AptifyGenericEntityEventFailureException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ResultCode Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityEventFailureException.ResultCode Property

public String ResultCode {get;}

See Also

AptifyGenericEntityEventFailureException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityEventFailureException Methods

The methods of the AptifyGenericEntityEventFailureException class are listed below. For a complete list of AptifyGenericEntityEventFailureException class members, see the AptifyGenericEntityEventFailureException Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyGenericEntityEventFailureException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityEventFailureException.GetObjectData Method

public override void GetObjectData(
SerializationInfo info,
StreamingContext context
);

Implements

ISerializable.

See Also

AptifyGenericEntityEventFailureException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityException Class

For a list of all members of this type, see AptifyGenericEntityException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
AptifyGenericEntityException
Derived types

public class AptifyGenericEntityException : BaseApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

AptifyGenericEntityException Members | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityException Members

AptifyGenericEntityException overview

Public Instance Constructors

AptifyGenericEntityException Overloaded. Initializes a new instance of the AptifyGenericEntityException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Constructors

AptifyGenericEntityException Overloaded. Initializes a new instance of the AptifyGenericEntityException class.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyGenericEntityException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityException Constructor

Overload List

public AptifyGenericEntityException(Int32,Int32,String);

public AptifyGenericEntityException(Int32,Int32,String,Exception);

protected AptifyGenericEntityException(SerializationInfo,StreamingContext);

public AptifyGenericEntityException(String);

public AptifyGenericEntityException(String,Exception);

See Also

AptifyGenericEntityException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityException Constructor (String)

public AptifyGenericEntityException(
String Message
);

See Also

AptifyGenericEntityException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityException Constructor Overload List


AptifyGenericEntityException Constructor (String, Exception)

public AptifyGenericEntityException(
String Message,
Exception inner
);

See Also

AptifyGenericEntityException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityException Constructor Overload List


AptifyGenericEntityException Constructor (Int32, Int32, String)

public AptifyGenericEntityException(
Int32 ErrorNumber,
Int32 Severity,
String Message
);

See Also

AptifyGenericEntityException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityException Constructor Overload List


AptifyGenericEntityException Constructor (Int32, Int32, String, Exception)

public AptifyGenericEntityException(
Int32 ErrorNumber,
Int32 Severity,
String Message,
Exception inner
);

See Also

AptifyGenericEntityException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityException Constructor Overload List


AptifyGenericEntityException Constructor (SerializationInfo, StreamingContext)

protected AptifyGenericEntityException(
SerializationInfo info,
StreamingContext context
);

See Also

AptifyGenericEntityException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityException Constructor Overload List


AptifyGenericEntityException Methods

The methods of the AptifyGenericEntityException class are listed below. For a complete list of AptifyGenericEntityException class members, see the AptifyGenericEntityException Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyGenericEntityException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityException.GetObjectData Method

public override void GetObjectData(
SerializationInfo info,
StreamingContext context
);

Implements

ISerializable.

See Also

AptifyGenericEntityException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityRecordNotFoundException Class

For a list of all members of this type, see AptifyGenericEntityRecordNotFoundException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
AptifyGenericEntityException
AptifyGenericEntityRecordNotFoundException

public class AptifyGenericEntityRecordNotFoundException : AptifyGenericEntityException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntity (in AptifyGenericEntity.dll)

See Also

AptifyGenericEntityRecordNotFoundException Members | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityRecordNotFoundException Members

AptifyGenericEntityRecordNotFoundException overview

Public Instance Constructors

AptifyGenericEntityRecordNotFoundException Overloaded. Initializes a new instance of the AptifyGenericEntityRecordNotFoundException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Entity |
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
RecordID |
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Constructors

AptifyGenericEntityRecordNotFoundException Overloaded. Initializes a new instance of the AptifyGenericEntityRecordNotFoundException class.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyGenericEntityRecordNotFoundException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityRecordNotFoundException Constructor

Overload List

protected AptifyGenericEntityRecordNotFoundException(SerializationInfo,StreamingContext);

public AptifyGenericEntityRecordNotFoundException(String,Int64);

public AptifyGenericEntityRecordNotFoundException(String,Int64,Exception);

See Also

AptifyGenericEntityRecordNotFoundException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityRecordNotFoundException Constructor (String, Int64)

public AptifyGenericEntityRecordNotFoundException(
String Entity,
Int64 RecordID
);

See Also

AptifyGenericEntityRecordNotFoundException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityRecordNotFoundException Constructor Overload List


AptifyGenericEntityRecordNotFoundException Constructor (String, Int64, Exception)

public AptifyGenericEntityRecordNotFoundException(
String Entity,
Int64 RecordID,
Exception inner
);

See Also

AptifyGenericEntityRecordNotFoundException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityRecordNotFoundException Constructor Overload List


AptifyGenericEntityRecordNotFoundException Constructor (SerializationInfo, StreamingContext)

protected AptifyGenericEntityRecordNotFoundException(
SerializationInfo info,
StreamingContext context
);

See Also

AptifyGenericEntityRecordNotFoundException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityRecordNotFoundException Constructor Overload List


AptifyGenericEntityRecordNotFoundException Properties

The properties of the AptifyGenericEntityRecordNotFoundException class are listed below. For a complete list of AptifyGenericEntityRecordNotFoundException class members, see the AptifyGenericEntityRecordNotFoundException Members topic.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Entity |
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
RecordID |
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

See Also

AptifyGenericEntityRecordNotFoundException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


Entity Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityRecordNotFoundException.Entity Property

public String Entity {get;}

See Also

AptifyGenericEntityRecordNotFoundException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


RecordID Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityRecordNotFoundException.RecordID Property

public Int64 RecordID {get;}

See Also

AptifyGenericEntityRecordNotFoundException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityRecordNotFoundException Methods

The methods of the AptifyGenericEntityRecordNotFoundException class are listed below. For a complete list of AptifyGenericEntityRecordNotFoundException class members, see the AptifyGenericEntityRecordNotFoundException Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyGenericEntityRecordNotFoundException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityRecordNotFoundException.GetObjectData Method

public override void GetObjectData(
SerializationInfo info,
StreamingContext context
);

Implements

ISerializable.

See Also

AptifyGenericEntityRecordNotFoundException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntitySQLException Class

For a list of all members of this type, see AptifyGenericEntitySQLException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
AptifyGenericEntityException
AptifyGenericEntitySQLException

public class AptifyGenericEntitySQLException : AptifyGenericEntityException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntity (in AptifyGenericEntity.dll)

See Also

AptifyGenericEntitySQLException Members | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntitySQLException Members

AptifyGenericEntitySQLException overview

Public Instance Constructors

AptifyGenericEntitySQLException Overloaded. Initializes a new instance of the AptifyGenericEntitySQLException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Entity |
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Operation |
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Constructors

AptifyGenericEntitySQLException Overloaded. Initializes a new instance of the AptifyGenericEntitySQLException class.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyGenericEntitySQLException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntitySQLException Constructor

Overload List

protected AptifyGenericEntitySQLException(SerializationInfo,StreamingContext);

public AptifyGenericEntitySQLException(String,String);

public AptifyGenericEntitySQLException(String,String,Exception);

See Also

AptifyGenericEntitySQLException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntitySQLException Constructor (String, String)

public AptifyGenericEntitySQLException(
String Entity,
String Operation
);

See Also

AptifyGenericEntitySQLException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntitySQLException Constructor Overload List


AptifyGenericEntitySQLException Constructor (String, String, Exception)

public AptifyGenericEntitySQLException(
String Entity,
String Operation,
Exception inner
);

See Also

AptifyGenericEntitySQLException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntitySQLException Constructor Overload List


AptifyGenericEntitySQLException Constructor (SerializationInfo, StreamingContext)

protected AptifyGenericEntitySQLException(
SerializationInfo info,
StreamingContext context
);

See Also

AptifyGenericEntitySQLException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntitySQLException Constructor Overload List


AptifyGenericEntitySQLException Properties

The properties of the AptifyGenericEntitySQLException class are listed below. For a complete list of AptifyGenericEntitySQLException class members, see the AptifyGenericEntitySQLException Members topic.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Entity |
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Operation |
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

See Also

AptifyGenericEntitySQLException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


Entity Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntitySQLException.Entity Property

public String Entity {get;}

See Also

AptifyGenericEntitySQLException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


Operation Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntitySQLException.Operation Property

public String Operation {get;}

See Also

AptifyGenericEntitySQLException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntitySQLException Methods

The methods of the AptifyGenericEntitySQLException class are listed below. For a complete list of AptifyGenericEntitySQLException class members, see the AptifyGenericEntitySQLException Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyGenericEntitySQLException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntitySQLException.GetObjectData Method

public override void GetObjectData(
SerializationInfo info,
StreamingContext context
);

Implements

ISerializable.

See Also

AptifyGenericEntitySQLException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityTransactionMismatchException Class

For a list of all members of this type, see AptifyGenericEntityTransactionMismatchException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
AptifyGenericEntityException
AptifyGenericEntityTransactionMismatchException

public class AptifyGenericEntityTransactionMismatchException : AptifyGenericEntityException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntity (in AptifyGenericEntity.dll)

See Also

AptifyGenericEntityTransactionMismatchException Members | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityTransactionMismatchException Members

AptifyGenericEntityTransactionMismatchException overview

Public Instance Constructors

AptifyGenericEntityTransactionMismatchException Overloaded. Initializes a new instance of the AptifyGenericEntityTransactionMismatchException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
GETransactionID |
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
NewTransactionID |
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Constructors

AptifyGenericEntityTransactionMismatchException Overloaded. Initializes a new instance of the AptifyGenericEntityTransactionMismatchException class.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyGenericEntityTransactionMismatchException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityTransactionMismatchException Constructor

Overload List

protected AptifyGenericEntityTransactionMismatchException(SerializationInfo,StreamingContext);

public AptifyGenericEntityTransactionMismatchException(String,String);

public AptifyGenericEntityTransactionMismatchException(String,String,Exception);

See Also

AptifyGenericEntityTransactionMismatchException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityTransactionMismatchException Constructor (String, String)

public AptifyGenericEntityTransactionMismatchException(
String GETransactionID,
String NewTransactionID
);

See Also

AptifyGenericEntityTransactionMismatchException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityTransactionMismatchException Constructor Overload List


AptifyGenericEntityTransactionMismatchException Constructor (String, String, Exception)

public AptifyGenericEntityTransactionMismatchException(
String GETransactionID,
String NewTransactionID,
Exception inner
);

See Also

AptifyGenericEntityTransactionMismatchException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityTransactionMismatchException Constructor Overload List


AptifyGenericEntityTransactionMismatchException Constructor (SerializationInfo, StreamingContext)

protected AptifyGenericEntityTransactionMismatchException(
SerializationInfo info,
StreamingContext context
);

See Also

AptifyGenericEntityTransactionMismatchException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityTransactionMismatchException Constructor Overload List


AptifyGenericEntityTransactionMismatchException Properties

The properties of the AptifyGenericEntityTransactionMismatchException class are listed below. For a complete list of AptifyGenericEntityTransactionMismatchException class members, see the AptifyGenericEntityTransactionMismatchException Members topic.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
GETransactionID |
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
NewTransactionID |
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

See Also

AptifyGenericEntityTransactionMismatchException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GETransactionID Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityTransactionMismatchException.GETransactionID Property

public String GETransactionID {get;}

See Also

AptifyGenericEntityTransactionMismatchException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


NewTransactionID Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityTransactionMismatchException.NewTransactionID Property

public String NewTransactionID {get;}

See Also

AptifyGenericEntityTransactionMismatchException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityTransactionMismatchException Methods

The methods of the AptifyGenericEntityTransactionMismatchException class are listed below. For a complete list of AptifyGenericEntityTransactionMismatchException class members, see the AptifyGenericEntityTransactionMismatchException Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyGenericEntityTransactionMismatchException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityTransactionMismatchException.GetObjectData Method

public override void GetObjectData(
SerializationInfo info,
StreamingContext context
);

Implements

ISerializable.

See Also

AptifyGenericEntityTransactionMismatchException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityValidationException Class

For a list of all members of this type, see AptifyGenericEntityValidationException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
AptifyGenericEntityException
AptifyGenericEntityValidationException

public class AptifyGenericEntityValidationException : AptifyGenericEntityException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntity (in AptifyGenericEntity.dll)

See Also

AptifyGenericEntityValidationException Members | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityValidationException Members

AptifyGenericEntityValidationException overview

Public Instance Constructors

AptifyGenericEntityValidationException Overloaded. Initializes a new instance of the AptifyGenericEntityValidationException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Entity |
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
ErrorString |
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Constructors

AptifyGenericEntityValidationException Overloaded. Initializes a new instance of the AptifyGenericEntityValidationException class.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyGenericEntityValidationException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityValidationException Constructor

Overload List

protected AptifyGenericEntityValidationException(SerializationInfo,StreamingContext);

public AptifyGenericEntityValidationException(String,String);

public AptifyGenericEntityValidationException(String,String,Exception);

See Also

AptifyGenericEntityValidationException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityValidationException Constructor (String, String)

public AptifyGenericEntityValidationException(
String Entity,
String ErrorString
);

See Also

AptifyGenericEntityValidationException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityValidationException Constructor Overload List


AptifyGenericEntityValidationException Constructor (String, String, Exception)

public AptifyGenericEntityValidationException(
String Entity,
String ErrorString,
Exception inner
);

See Also

AptifyGenericEntityValidationException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityValidationException Constructor Overload List


AptifyGenericEntityValidationException Constructor (SerializationInfo, StreamingContext)

protected AptifyGenericEntityValidationException(
SerializationInfo info,
StreamingContext context
);

See Also

AptifyGenericEntityValidationException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyGenericEntityValidationException Constructor Overload List


AptifyGenericEntityValidationException Properties

The properties of the AptifyGenericEntityValidationException class are listed below. For a complete list of AptifyGenericEntityValidationException class members, see the AptifyGenericEntityValidationException Members topic.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Entity |
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
ErrorString |
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

See Also

AptifyGenericEntityValidationException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


Entity Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityValidationException.Entity Property

public String Entity {get;}

See Also

AptifyGenericEntityValidationException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ErrorString Property

Aptify 5.0 Software Development Kit (SDK)

AptifyGenericEntityValidationException.ErrorString Property

public String ErrorString {get;}

See Also

AptifyGenericEntityValidationException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityValidationException Methods

The methods of the AptifyGenericEntityValidationException class are listed below. For a complete list of AptifyGenericEntityValidationException class members, see the AptifyGenericEntityValidationException Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyGenericEntityValidationException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyGenericEntityValidationException.GetObjectData Method

public override void GetObjectData(
SerializationInfo info,
StreamingContext context
);

Implements

ISerializable.

See Also

AptifyGenericEntityValidationException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyMoveObjectOptions Enumeration

public enum AptifyMoveObjectOptions

Members

Member Name | Description
aptifyShift |
aptifySwap |
aptifyReplace |

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifySortDirection Enumeration

public enum AptifySortDirection

Members

Member Name | Description
aptifyAscending |
aptifyDescending |

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifySubType Class

For a list of all members of this type, see AptifySubType Members.

System.Object
AptifySubTypeBase
AptifySubType

public class AptifySubType : AptifySubTypeBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntity (in AptifyGenericEntity.dll)

See Also

AptifySubType Members | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifySubType Members

AptifySubType overview

Public Instance Constructors

AptifySubType Overloaded. Initializes a new instance of the AptifySubType class.

Public Instance Properties

BaseDatabase (inherited from AptifySubTypeBase) | The base database for the loaded sub-type.
BatchSQL | Returns the Batch SQL back to the caller.
Count | Returns the count of records loaded in the sub-type.
Description (inherited from AptifySubTypeBase) | Description for the sub-type.
DisplayName (inherited from AptifySubTypeBase) | Returns the DisplayName for the loaded sub-type.
DisplayNameWithCulture (inherited from AptifySubTypeBase) | Returns the DisplayName With Culture for the loaded sub-type.
EventsToFire (inherited from AptifySubTypeBase) | Used to configure the Events that will be fired by the Data Field object.
ExistingRowsRemoved | Indicates if previously saved rows have been removed from the subtype.
IsDirty | Returns true if any information related to the sub-type has been changed, otherwise it returns false.
Item | Returns a specific GE record from the sub-type's records.
LastError | Returns the exception string for the last exception that occurred when working with this sub-type.
Name (inherited from AptifySubTypeBase) | Returns the Name of the loaded Sub-type.
ParentGE (inherited from AptifySubTypeBase) |
RecordChangeString | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML |
SequenceField (inherited from AptifySubTypeBase) | The name of the field that is defined as the record sequence.
SPDeleteAll | The name of the SProc that is called to delete all records when the entity is saved.
SPGetAll | The name of the SProc that is called when the sub-type is loaded.
spUpdate (inherited from AptifySubTypeBase) | The name of the SProc that is called when the Sub-Type is updated.
SubTypeDataAssembly | The name of the Assembly that holds the Entity wrapper for this sub-type.
SubTypeDataClass | The name of the Type that holds the Entity wrapper that should be instantiated for this Sub-Type.
SubTypeDataObject | The name of the Object repository Object that holds the assembly for this sub-type's wrapper.
SubTypeLevel (inherited from AptifySubTypeBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypeLinks (inherited from AptifySubTypeBase) | Returns all of the fields that are linked values for this sub-type.
SubTypeViewerAssembly | The name of the Assembly that holds the Entity viewer for this sub-type.
SubTypeViewerClass | The name of the Type that holds the Entity viewer that should be instantiated for this Sub-Type.
SubTypeViewerObject | The name of the Object repository Object that holds the assembly for this sub-type's viewer.

Public Instance Methods

Add | Overloaded. Adds a record to the sub-type
Append (inherited from AptifySubTypeBase) | Allows the user to add an initialized record to the internal collection of GE records.
Clear | Removes all of the GE records from memory that are contained in this SubType Instance.
ClearDirtyFlags | Clears all dirty flags associated with this instance and the GE record instances that are associated with this instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Find (inherited from AptifySubTypeBase) | Finds the first record associated with this instance that has a specific value for a specific field.
FindMultiple (inherited from AptifySubTypeBase) | Finds all records associated with this instance that has a specific value for a specific field.
FindPosition | Find the position of a Field Value combination in the Sub-Type instances records.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Gets the value of a field from a specific record position.
IndexOf (inherited from AptifySubTypeBase) | Gets the index of a specific GE record. If it does not exist, then -1 is returned.
IsTime | Validate if given string is valid Time value or not.
Load | Loads all of the sub-type records for the instance of the sub-type.
MoveObject | Overloaded. Changes the position of a record in the Sub-Type's records.
NewRecord |
NewSubTypeRecord | Returns a new instance of a GE object that corresponds to the currently loaded sub-type record.
Remove |
RemoveAt | Overloaded.
RemoveAt (inherited from AptifySubTypeBase) | Overloaded.
Save | Saves the Sub-Type instance.
ShowFindGUI | Show a Find dialog with the Field value to search on already populated.
Sort | Overloaded. Sorts the records in the sub-type based on the field specified.
ToString (inherited from Object) | Returns a String that represents the current Object.
Validate | Validates that all of the GE instances in the sub-type have valid values.

Public Instance Events

AfterClear (inherited from AptifySubTypeBase) | Fired when the Sub-Type's Clear method is called, before the Clear occurs. Note the event will only be fired if the Sub-Type's EventsToFire property setting includes the Clear Events.
AfterItemAdd (inherited from AptifySubTypeBase) | Fired at the end of the Sub-Type's Add method after the object has been added.
AfterItemRemove (inherited from AptifySubTypeBase) |
BeforeClear (inherited from AptifySubTypeBase) | Fired when the Sub-Type's Clear method is called, before the Clear occurs. Note the event will only be fired if the Sub-Type's EventsToFire property setting includes the Clear Events.
BeforeItemAdd (inherited from AptifySubTypeBase) | Fired when the Sub-Type's Add method is called, before the Add occurs. Note the event will only be fired if the Sub-Type's EventsToFire property setting includes the ItemAdd Events.
BeforeItemRemove (inherited from AptifySubTypeBase) |
FindPositionPercentChanged (inherited from AptifySubTypeBase) | An event that occurs as the search position changes during a FindPosition member call.

Protected Instance Properties

InnerList (inherited from AptifySubTypeBase)

Protected Instance Methods

CreateSubTypeGE |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterClear (inherited from AptifySubTypeBase) | Verifies whether or not the AfterClear event should be fired. If the event should be fired, it is fired.
OnAfterItemAdd (inherited from AptifySubTypeBase) | Verifies whether or not the AfterItemAdd event should be fired. If the event should be fired, it is fired.
OnAfterItemRemove (inherited from AptifySubTypeBase) | Verifies whether or not the AfterItemRemove event should be fired. If the event should be fired, it is fired.
OnBeforeClear (inherited from AptifySubTypeBase) | Verifies whether or not the BeforeClear event should be fired. If the event should be fired, it is fired.
OnBeforeItemAdd (inherited from AptifySubTypeBase) | Verifies whether or not the BeforeItemAdd event should be fired. If the event should be fired, it is fired.
OnBeforeItemRemove (inherited from AptifySubTypeBase) | Verifies whether or not the BeforeItemRemove event should be fired. If the event should be fired, it is fired.
OnFindPositionPercentChanged (inherited from AptifySubTypeBase) |

See Also

AptifySubType Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifySubType Constructor

Overload List

public AptifySubType(AptifyGenericEntityBase,String);

public AptifySubType(AptifyGenericEntityBase,String,DataTable);

See Also

AptifySubType Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifySubType Constructor (AptifyGenericEntityBase, String)

public AptifySubType(
AptifyGenericEntityBase GE,
String SubTypeName
);

See Also

AptifySubType Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifySubType Constructor Overload List


AptifySubType Constructor (AptifyGenericEntityBase, String, DataTable)

public AptifySubType(
AptifyGenericEntityBase GE,
String SubTypeName,
DataTable data
);

See Also

AptifySubType Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifySubType Constructor Overload List


AptifySubType Properties

The properties of the AptifySubType class are listed below. For a complete list of AptifySubType class members, see the AptifySubType Members topic.

Public Instance Properties

BaseDatabase (inherited from AptifySubTypeBase) | The base database for the loaded sub-type.
BatchSQL | Returns the Batch SQL back to the caller.
Count | Returns the count of records loaded in the sub-type.
Description (inherited from AptifySubTypeBase) | Description for the sub-type.
DisplayName (inherited from AptifySubTypeBase) | Returns the DisplayName for the loaded sub-type.
DisplayNameWithCulture (inherited from AptifySubTypeBase) | Returns the DisplayName With Culture for the loaded sub-type.
EventsToFire (inherited from AptifySubTypeBase) | Used to configure the Events that will be fired by the Data Field object.
ExistingRowsRemoved | Indicates if previously saved rows have been removed from the subtype.
IsDirty | Returns true if any information related to the sub-type has been changed, otherwise it returns false.
Item | Returns a specific GE record from the sub-type's records.
LastError | Returns the exception string for the last exception that occurred when working with this sub-type.
Name (inherited from AptifySubTypeBase) | Returns the Name of the loaded Sub-type.
ParentGE (inherited from AptifySubTypeBase) |
RecordChangeString | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML |
SequenceField (inherited from AptifySubTypeBase) | The name of the field that is defined as the record sequence.
SPDeleteAll | The name of the SProc that is called to delete all records when the entity is saved.
SPGetAll | The name of the SProc that is called when the sub-type is loaded.
spUpdate (inherited from AptifySubTypeBase) | The name of the SProc that is called when the Sub-Type is updated.
SubTypeDataAssembly | The name of the Assembly that holds the Entity wrapper for this sub-type.
SubTypeDataClass | The name of the Type that holds the Entity wrapper that should be instantiated for this Sub-Type.
SubTypeDataObject | The name of the Object repository Object that holds the assembly for this sub-type's wrapper.
SubTypeLevel (inherited from AptifySubTypeBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypeLinks (inherited from AptifySubTypeBase) | Returns all of the fields that are linked values for this sub-type.
SubTypeViewerAssembly | The name of the Assembly that holds the Entity viewer for this sub-type.
SubTypeViewerClass | The name of the Type that holds the Entity viewer that should be instantiated for this Sub-Type.
SubTypeViewerObject | The name of the Object repository Object that holds the assembly for this sub-type's viewer.

Protected Instance Properties

InnerList (inherited from AptifySubTypeBase)

See Also

AptifySubType Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


BatchSQL Property

Aptify 5.0 Software Development Kit (SDK)

AptifySubType.BatchSQL Property

Returns the Batch SQL back to the caller.

public override String BatchSQL {get;}

Remarks

See Also

AptifySubType Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


Count Property

Aptify 5.0 Software Development Kit (SDK)

AptifySubType.Count Property

Returns the count of records loaded in the sub-type.

public override Int32 Count {get;}

Remarks

See Also

AptifySubType Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ExistingRowsRemoved Property

Aptify 5.0 Software Development Kit (SDK)

AptifySubType.ExistingRowsRemoved Property

Indicates if previously saved rows have been removed from the subtype.

public override Boolean ExistingRowsRemoved {get;}

Property Value

Remarks

See Also

AptifySubType Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


IsDirty Property

Aptify 5.0 Software Development Kit (SDK)

AptifySubType.IsDirty Property

Returns true if any information related to the sub-type has been changed, otherwise it returns false.

public override Boolean IsDirty {get;}

Remarks

See Also

AptifySubType Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


Item Property

Aptify 5.0 Software Development Kit (SDK)

AptifySubType.Item Property

Returns a specific GE record from the sub-type's records.

public override AptifyGenericEntityBase this[
Int32 Index
] {get;}

Parameters

Index

Remarks

See Also

AptifySubType Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


LastError Property

Aptify 5.0 Software Development Kit (SDK)

AptifySubType.LastError Property

Returns the exception string for the last exception that occurred when working with this sub-type.

public override String LastError {get;}

Remarks

See Also

AptifySubType Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


RecordChangeString Property

Aptify 5.0 Software Development Kit (SDK)

AptifySubType.RecordChangeString Property

Returns a string describing what changed in the record between the current version in memory and the "LAST" version.

public override String RecordChangeString {get;}

Remarks

See Also

AptifySubType Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


RecordChangeXML Property

Aptify 5.0 Software Development Kit (SDK)

AptifySubType.RecordChangeXML Property

public override String RecordChangeXML {get;}

See Also

AptifySubType Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


SPDeleteAll Property

Aptify 5.0 Software Development Kit (SDK)

AptifySubType.SPDeleteAll Property

The name of the SProc that is called to delete all records when the entity is saved.

public override String SPDeleteAll {get; set;}

Remarks

See Also

AptifySubType Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


SPGetAll Property

Aptify 5.0 Software Development Kit (SDK)

AptifySubType.SPGetAll Property

The name of the SProc that is called when the sub-type is loaded.

public override String SPGetAll {get; set;}

Remarks

See Also

AptifySubType Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


SubTypeDataAssembly Property

Aptify 5.0 Software Development Kit (SDK)

AptifySubType.SubTypeDataAssembly Property

The name of the Assembly that holds the Entity wrapper for this sub-type.

public override String SubTypeDataAssembly {get;}

Remarks

See Also

AptifySubType Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


SubTypeDataClass Property

Aptify 5.0 Software Development Kit (SDK)

AptifySubType.SubTypeDataClass Property

The name of the Type that holds the Entity wrapper that should be instantiated for this Sub-Type.

public override String SubTypeDataClass {get;}

Remarks

See Also

AptifySubType Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


SubTypeDataObject Property

Aptify 5.0 Software Development Kit (SDK)

AptifySubType.SubTypeDataObject Property

The name of the Object repository Object that holds the assembly for this sub-type's wrapper.

public override String SubTypeDataObject {get;}

Remarks

See Also

AptifySubType Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


SubTypeViewerAssembly Property

Aptify 5.0 Software Development Kit (SDK)

AptifySubType.SubTypeViewerAssembly Property

The name of the Assembly that holds the Entity viewer for this sub-type.

public override String SubTypeViewerAssembly {get;}

Remarks

See Also

AptifySubType Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


SubTypeViewerClass Property

Aptify 5.0 Software Development Kit (SDK)

AptifySubType.SubTypeViewerClass Property

The name of the Type that holds the Entity viewer that should be instantiated for this Sub-Type.

public override String SubTypeViewerClass {get;}

Remarks

See Also

AptifySubType Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


SubTypeViewerObject Property

Aptify 5.0 Software Development Kit (SDK)

AptifySubType.SubTypeViewerObject Property

The name of the Object repository Object that holds the assembly for this sub-type's viewer.

public override String SubTypeViewerObject {get;}

Remarks

See Also

AptifySubType Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifySubType Methods

The methods of the AptifySubType class are listed below. For a complete list of AptifySubType class members, see the AptifySubType Members topic.

Public Instance Methods

Add | Overloaded. Adds a record to the sub-type
Append (inherited from AptifySubTypeBase) | Allows the user to add an initialized record to the internal collection of GE records.
Clear | Removes all of the GE records from memory that are contained in this SubType Instance.
ClearDirtyFlags | Clears all dirty flags associated with this instance and the GE record instances that are associated with this instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Find (inherited from AptifySubTypeBase) | Finds the first record associated with this instance that has a specific value for a specific field.
FindMultiple (inherited from AptifySubTypeBase) | Finds all records associated with this instance that has a specific value for a specific field.
FindPosition | Find the position of a Field Value combination in the Sub-Type instances records.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Gets the value of a field from a specific record position.
IndexOf (inherited from AptifySubTypeBase) | Gets the index of a specific GE record. If it does not exist, then -1 is returned.
IsTime | Validate if given string is valid Time value or not.
Load | Loads all of the sub-type records for the instance of the sub-type.
MoveObject | Overloaded. Changes the position of a record in the Sub-Type's records.
NewRecord |
NewSubTypeRecord | Returns a new instance of a GE object that corresponds to the currently loaded sub-type record.
Remove |
RemoveAt | Overloaded.
RemoveAt (inherited from AptifySubTypeBase) | Overloaded.
Save | Saves the Sub-Type instance.
ShowFindGUI | Show a Find dialog with the Field value to search on already populated.
Sort | Overloaded. Sorts the records in the sub-type based on the field specified.
ToString (inherited from Object) | Returns a String that represents the current Object.
Validate | Validates that all of the GE instances in the sub-type have valid values.

Protected Instance Methods

CreateSubTypeGE |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterClear (inherited from AptifySubTypeBase) | Verifies whether or not the AfterClear event should be fired. If the event should be fired, it is fired.
OnAfterItemAdd (inherited from AptifySubTypeBase) | Verifies whether or not the AfterItemAdd event should be fired. If the event should be fired, it is fired.
OnAfterItemRemove (inherited from AptifySubTypeBase) | Verifies whether or not the AfterItemRemove event should be fired. If the event should be fired, it is fired.
OnBeforeClear (inherited from AptifySubTypeBase) | Verifies whether or not the BeforeClear event should be fired. If the event should be fired, it is fired.
OnBeforeItemAdd (inherited from AptifySubTypeBase) | Verifies whether or not the BeforeItemAdd event should be fired. If the event should be fired, it is fired.
OnBeforeItemRemove (inherited from AptifySubTypeBase) | Verifies whether or not the BeforeItemRemove event should be fired. If the event should be fired, it is fired.
OnFindPositionPercentChanged (inherited from AptifySubTypeBase) |

See Also

AptifySubType Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


Add Method

Aptify 5.0 Software Development Kit (SDK)

AptifySubType.Add Method

Adds a record to the sub-type

Overload List

Returns an initialized GE record for the current sub-type definition.

public override AptifyGenericEntityBase Add();

Allows the user to add an initialized record to the internal collection of GE records.

public override int Add(AptifyGenericEntityBase);

See Also

AptifySubType Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifySubType.Add Method ()

Returns an initialized GE record for the current sub-type definition.

public override AptifyGenericEntityBase Add();

Return Value

Remarks

It also adds the new record to the internal collection of records.

See Also

AptifySubType Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifySubType.Add Overload List


AptifySubType.Add Method (AptifyGenericEntityBase)

Allows the user to add an initialized record to the internal collection of GE records.

public override int Add(
AptifyGenericEntityBase Value
);

Parameters

Value

Return Value

It returns the Index at which the Record was added to the collection.

See Also

AptifySubType Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifySubType.Add Overload List


AptifySubType.Clear Method

Removes all of the GE records from memory that are contained in this SubType Instance.

public override void Clear();

Remarks

See Also

AptifySubType Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifySubType.ClearDirtyFlags Method

Clears all dirty flags associated with this instance and the GE record instances that are associated with this instance.

public override void ClearDirtyFlags();

Remarks

See Also

AptifySubType Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifySubType.CreateSubTypeGE Method

protected override AptifyGenericEntityBase CreateSubTypeGE(
Boolean ForLoad
);

See Also

AptifySubType Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifySubType.FindPosition Method

Find the position of a Field Value combination in the Sub-Type instances records.

public override bool FindPosition(
String Field,
String Value,
AptifyCompare Compare,
ref Int32& Position,
Boolean CaseInsensitive,
Int32 StartPosition
);

Parameters

Field
Value
Compare
Position
CaseInsensitive
StartPosition

Return Value

Remarks

The execution time for this member may be extensive, so a cancel feature can be utilized by catching the FindPositionPercentChanged event.

See Also

AptifySubType Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifySubType.GetValue Method

Gets the value of a field from a specific record position.

public override object GetValue(
Int32 Index,
String Field
);

Parameters

Index
Field

Return Value

Remarks

See Also

AptifySubType Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifySubType.IsTime Method

Validate if given string is valid Time value or not.

public bool IsTime(
String argInputString
);

Parameters

argInputString

Return Value

Remarks

See Also

AptifySubType Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifySubType.Load Method

Loads all of the sub-type records for the instance of the sub-type.

public override bool Load();

Return Value

Remarks

See Also

AptifySubType Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


MoveObject Method

Aptify 5.0 Software Development Kit (SDK)

AptifySubType.MoveObject Method

Changes the position of a record in the Sub-Type's records.

Overload List

Changes the position of a record in the Sub-Type's records.

public override void MoveObject(Int32,Int32);

public override void MoveObject(Int32,Int32,AptifyMoveObjectOptions);

See Also

AptifySubType Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifySubType.MoveObject Method (Int32, Int32)

Changes the position of a record in the Sub-Type's records.

public override void MoveObject(
Int32 CurPos,
Int32 NewPos
);

Parameters

CurPos
NewPos

Remarks

See Also

AptifySubType Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifySubType.MoveObject Overload List


AptifySubType.MoveObject Method (Int32, Int32, AptifyMoveObjectOptions)

public override void MoveObject(
Int32 CurPos,
Int32 NewPos,
AptifyMoveObjectOptions MoveOption
);

See Also

AptifySubType Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifySubType.MoveObject Overload List


AptifySubType.NewRecord Method

public override void NewRecord();

See Also

AptifySubType Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifySubType.NewSubTypeRecord Method

Returns a new instance of a GE object that corresponds to the currently loaded sub-type record.

public override AptifyGenericEntityBase NewSubTypeRecord();

Return Value

Remarks

See Also

AptifySubType Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifySubType.Remove Method

public override void Remove(
AptifyGenericEntityBase Value
);

See Also

AptifySubType Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


RemoveAt Method

Aptify 5.0 Software Development Kit (SDK)

AptifySubType.RemoveAt Method

Overload List

public override void RemoveAt(Int32);

Inherited from AptifySubTypeBase.

public virtual void RemoveAt(Int32[]);

See Also

AptifySubType Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifySubType.RemoveAt Method (Int32)

public override void RemoveAt(
Int32 Index
);

See Also

AptifySubType Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifySubType.RemoveAt Overload List


AptifySubType.Save Method

Saves the Sub-Type instance.

public override bool Save(
ref String& ErrorString,
String TransactionID
);

Parameters

ErrorString
TransactionID

Return Value

Remarks

See Also

AptifySubType Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifySubType.ShowFindGUI Method

Show a Find dialog with the Field value to search on already populated.

public override bool ShowFindGUI(
ref String& Field,
ref Int32& Position,
ref String& Value,
ref AptifyCompare& Compare,
ref Boolean& CaseInsensitive,
Int32 StartPosition
);

Parameters

Field
Position
Value
Compare
CaseInsensitive
StartPosition

Return Value

Remarks

See Also

AptifySubType Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


Sort Method

Aptify 5.0 Software Development Kit (SDK)

AptifySubType.Sort Method

Sorts the records in the sub-type based on the field specified.

Overload List

public override void Sort(String);

Sorts the records in the sub-type based on the field specified.

public override void Sort(String,AptifySortDirection);

See Also

AptifySubType Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifySubType.Sort Method (String)

public override void Sort(
String Field
);

See Also

AptifySubType Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifySubType.Sort Overload List


AptifySubType.Sort Method (String, AptifySortDirection)

Sorts the records in the sub-type based on the field specified.

public override void Sort(
String Field,
AptifySortDirection Direction
);

Parameters

Field
Direction

Remarks

See Also

AptifySubType Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifySubType.Sort Overload List


AptifySubType.Validate Method

Validates that all of the GE instances in the sub-type have valid values.

public override bool Validate(
ref String& ErrorString
);

Parameters

ErrorString

Return Value

Remarks

See Also

AptifySubType Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifySubTypeBase Class

For a list of all members of this type, see AptifySubTypeBase Members.

System.Object
AptifySubTypeBase
AptifySubType

public class AptifySubTypeBase : IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

AptifySubTypeBase Members | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifySubTypeBase Members

AptifySubTypeBase overview

Public Instance Constructors

AptifySubTypeBase Constructor

Public Instance Properties

BaseDatabase | The base database for the loaded sub-type.
BatchSQL | Returns the Batch SQL back to the caller.
Count | Returns the count of records loaded in the sub-type.
Description | Description for the sub-type.
DisplayName | Returns the DisplayName for the loaded sub-type.
DisplayNameWithCulture | Returns the DisplayName With Culture for the loaded sub-type.
EventsToFire | Used to configure the Events that will be fired by the Data Field object.
ExistingRowsRemoved | Property used to indicate if rows have been removed from the subtype which have been previously been saved to the database.
IsDirty | Returns true if any information related to the sub-type has been changed, otherwise it returns false.
Item | Returns a specific GE record from the sub-type's records.
LastError | Returns the exception string for the last exception that occurred when working with this sub-type.
Name | Returns the Name of the loaded Sub-type.
ParentGE |
RecordChangeString | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML | Returns an XML fragment describing the changes between the current version in memory and the "LAST" version.
SequenceField | The name of the field that is defined as the record sequence.
SPDeleteAll | The name of the SProc that is called to delete all records when the entity is saved.
SPGetAll | The name of the SProc that is called when the sub-type is loaded.
spUpdate | The name of the SProc that is called when the Sub-Type is updated.
SubTypeDataAssembly | The name of the Assembly that holds the Entity wrapper for this sub-type.
SubTypeDataClass | The name of the Type that holds the Entity wrapper that should be instantiated for this Sub-Type.
SubTypeDataObject | The name of the Object repository Object that holds the assembly for this sub-type's wrapper.
SubTypeLevel | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypeLinks | Returns all of the fields that are linked values for this sub-type.
SubTypeViewerAssembly | The name of the Assembly that holds the Entity viewer for this sub-type.
SubTypeViewerClass | The name of the Type that holds the Entity viewer that should be instantiated for this Sub-Type.
SubTypeViewerObject | The name of the Object repository Object that holds the assembly for this sub-type's viewer.

Public Instance Methods

Add | Overloaded. Adds a GE record to the Sub-Type.
Append | Allows the user to add an initialized record to the internal collection of GE records.
Clear | Removes all of the GE records from memory that are contained in this SubType Instance.
ClearDirtyFlags | Clears all dirty flags associated with this instance and the GE record instances that are associated with this instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Find | Finds the first record associated with this instance that has a specific value for a specific field.
FindMultiple | Finds all records associated with this instance that has a specific value for a specific field.
FindPosition | Find the position of a Field Value combination in the Sub-Type instances records.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Gets the value of a field from a specific record position.
IndexOf | Gets the index of a specific GE record. If it does not exist, then -1 is returned.
Load | Loads all of the sub-type records for the instance of the sub-type.
MoveObject | Overloaded. Changes the position of a record in the Sub-Type's records.
NewRecord | Clears the current instance.
NewSubTypeRecord | Returns a new instance of a GE object that corresponds to the currently loaded sub-type record.
Remove | Removes specified GE instance from the Sub-Type's records.
RemoveAt | Overloaded. Removes GE records by Index.
Save | Saves the Sub-Type instance.
ShowFindGUI | Show a Find dialog with the Field value to search on already populated.
Sort | Overloaded. Sorts the records in the sub-type based on the field specified.
ToString (inherited from Object) | Returns a String that represents the current Object.
Validate | Validates that all of the GE instances in the sub-type have valid values.

Public Instance Events

AfterClear | Fired when the Sub-Type's Clear method is called, before the Clear occurs. Note the event will only be fired if the Sub-Type's EventsToFire property setting includes the Clear Events.
AfterItemAdd | Fired at the end of the Sub-Type's Add method after the object has been added.
AfterItemRemove |
BeforeClear | Fired when the Sub-Type's Clear method is called, before the Clear occurs. Note the event will only be fired if the Sub-Type's EventsToFire property setting includes the Clear Events.
BeforeItemAdd | Fired when the Sub-Type's Add method is called, before the Add occurs. Note the event will only be fired if the Sub-Type's EventsToFire property setting includes the ItemAdd Events.
BeforeItemRemove |
FindPositionPercentChanged | An event that occurs as the search position changes during a FindPosition member call.

Protected Instance Properties

InnerList

Protected Instance Methods

CreateSubTypeGE | Creates and returns a configured Entity object for the Sub-Type Entity.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterClear | Verifies whether or not the AfterClear event should be fired. If the event should be fired, it is fired.
OnAfterItemAdd | Verifies whether or not the AfterItemAdd event should be fired. If the event should be fired, it is fired.
OnAfterItemRemove | Verifies whether or not the AfterItemRemove event should be fired. If the event should be fired, it is fired.
OnBeforeClear | Verifies whether or not the BeforeClear event should be fired. If the event should be fired, it is fired.
OnBeforeItemAdd | Verifies whether or not the BeforeItemAdd event should be fired. If the event should be fired, it is fired.
OnBeforeItemRemove | Verifies whether or not the BeforeItemRemove event should be fired. If the event should be fired, it is fired.
OnFindPositionPercentChanged |

See Also

AptifySubTypeBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifySubTypeBase Constructor

public AptifySubTypeBase(
AptifyGenericEntityBase GE,
String SubTypeName
);

See Also

AptifySubTypeBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifySubTypeBase Properties

The properties of the AptifySubTypeBase class are listed below. For a complete list of AptifySubTypeBase class members, see the AptifySubTypeBase Members topic.

Public Instance Properties

BaseDatabase | The base database for the loaded sub-type.
BatchSQL | Returns the Batch SQL back to the caller.
Count | Returns the count of records loaded in the sub-type.
Description | Description for the sub-type.
DisplayName | Returns the DisplayName for the loaded sub-type.
DisplayNameWithCulture | Returns the DisplayName With Culture for the loaded sub-type.
EventsToFire | Used to configure the Events that will be fired by the Data Field object.
ExistingRowsRemoved | Property used to indicate if rows have been removed from the subtype which have been previously been saved to the database.
IsDirty | Returns true if any information related to the sub-type has been changed, otherwise it returns false.
Item | Returns a specific GE record from the sub-type's records.
LastError | Returns the exception string for the last exception that occurred when working with this sub-type.
Name | Returns the Name of the loaded Sub-type.
ParentGE |
RecordChangeString | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML | Returns an XML fragment describing the changes between the current version in memory and the "LAST" version.
SequenceField | The name of the field that is defined as the record sequence.
SPDeleteAll | The name of the SProc that is called to delete all records when the entity is saved.
SPGetAll | The name of the SProc that is called when the sub-type is loaded.
spUpdate | The name of the SProc that is called when the Sub-Type is updated.
SubTypeDataAssembly | The name of the Assembly that holds the Entity wrapper for this sub-type.
SubTypeDataClass | The name of the Type that holds the Entity wrapper that should be instantiated for this Sub-Type.
SubTypeDataObject | The name of the Object repository Object that holds the assembly for this sub-type's wrapper.
SubTypeLevel | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypeLinks | Returns all of the fields that are linked values for this sub-type.
SubTypeViewerAssembly | The name of the Assembly that holds the Entity viewer for this sub-type.
SubTypeViewerClass | The name of the Type that holds the Entity viewer that should be instantiated for this Sub-Type.
SubTypeViewerObject | The name of the Object repository Object that holds the assembly for this sub-type's viewer.

Protected Instance Properties

InnerList

See Also

AptifySubTypeBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


BaseDatabase Property

Aptify 5.0 Software Development Kit (SDK)

AptifySubTypeBase.BaseDatabase Property

The base database for the loaded sub-type.

public virtual String BaseDatabase {get;}

Remarks

See Also

AptifySubTypeBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


BatchSQL Property

Aptify 5.0 Software Development Kit (SDK)

AptifySubTypeBase.BatchSQL Property

Returns the Batch SQL back to the caller.

public abstract String BatchSQL {get;}

Property Value

Remarks

Transferred from ICGISTBatchSQL

See Also

AptifySubTypeBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


Count Property

Aptify 5.0 Software Development Kit (SDK)

AptifySubTypeBase.Count Property

Returns the count of records loaded in the sub-type.

public virtual Int32 Count {get;}

Remarks

See Also

AptifySubTypeBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


Description Property

Aptify 5.0 Software Development Kit (SDK)

AptifySubTypeBase.Description Property

Description for the sub-type.

public virtual String Description {get;}

Remarks

See Also

AptifySubTypeBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


DisplayName Property

Aptify 5.0 Software Development Kit (SDK)

AptifySubTypeBase.DisplayName Property

Returns the DisplayName for the loaded sub-type.

public virtual String DisplayName {get;}

Remarks

See Also

AptifySubTypeBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


DisplayNameWithCulture Property

Aptify 5.0 Software Development Kit (SDK)

AptifySubTypeBase.DisplayNameWithCulture Property

Returns the DisplayName With Culture for the loaded sub-type.

public virtual String DisplayNameWithCulture {get;}

Remarks

See Also

AptifySubTypeBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


EventsToFire Property

Aptify 5.0 Software Development Kit (SDK)

AptifySubTypeBase.EventsToFire Property

Used to configure the Events that will be fired by the Data Field object.

public AptifySubTypeBase.AptifySubTypeEvents EventsToFire {get; set;}

Property Value

Remarks

See Also

AptifySubTypeBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ExistingRowsRemoved Property

Aptify 5.0 Software Development Kit (SDK)

AptifySubTypeBase.ExistingRowsRemoved Property

Property used to indicate if rows have been removed from the subtype which have been previously been saved to the database.

public abstract Boolean ExistingRowsRemoved {get;}

Property Value

Returns TRUE if rows have been removed which already exist in the database.

Remarks

See Also

AptifySubTypeBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


InnerList Property

Aptify 5.0 Software Development Kit (SDK)

AptifySubTypeBase.InnerList Property

protected ArrayList InnerList {get;}

See Also

AptifySubTypeBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


IsDirty Property

Aptify 5.0 Software Development Kit (SDK)

AptifySubTypeBase.IsDirty Property

Returns true if any information related to the sub-type has been changed, otherwise it returns false.

public abstract Boolean IsDirty {get;}

Property Value

Remarks

See Also

AptifySubTypeBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


Item Property

Aptify 5.0 Software Development Kit (SDK)

AptifySubTypeBase.Item Property

Returns a specific GE record from the sub-type's records.

public virtual AptifyGenericEntityBase this[
Int32 Index
] {get;}

Parameters

Index

Remarks

See Also

AptifySubTypeBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


LastError Property

Aptify 5.0 Software Development Kit (SDK)

AptifySubTypeBase.LastError Property

Returns the exception string for the last exception that occurred when working with this sub-type.

public abstract String LastError {get;}

Property Value

Remarks

See Also

AptifySubTypeBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


Name Property

Aptify 5.0 Software Development Kit (SDK)

AptifySubTypeBase.Name Property

Returns the Name of the loaded Sub-type.

public virtual String Name {get;}

Remarks

See Also

AptifySubTypeBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ParentGE Property

Aptify 5.0 Software Development Kit (SDK)

AptifySubTypeBase.ParentGE Property

public virtual AptifyGenericEntityBase ParentGE {get;}

See Also

AptifySubTypeBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


RecordChangeString Property

Aptify 5.0 Software Development Kit (SDK)

AptifySubTypeBase.RecordChangeString Property

Returns a string describing what changed in the record between the current version in memory and the "LAST" version.

public abstract String RecordChangeString {get;}

Property Value

Remarks

See Also

AptifySubTypeBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


RecordChangeXML Property

Aptify 5.0 Software Development Kit (SDK)

AptifySubTypeBase.RecordChangeXML Property

Returns an XML fragment describing the changes between the current version in memory and the "LAST" version.

public abstract String RecordChangeXML {get;}

Property Value

Remarks

See Also

AptifySubTypeBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


SequenceField Property

Aptify 5.0 Software Development Kit (SDK)

AptifySubTypeBase.SequenceField Property

The name of the field that is defined as the record sequence.

public virtual String SequenceField {get;}

Remarks

Entities can have a field defined to be the record sequence. This will return the name of the field that is defined as the record sequence.

See Also

AptifySubTypeBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


SPDeleteAll Property

Aptify 5.0 Software Development Kit (SDK)

AptifySubTypeBase.SPDeleteAll Property

The name of the SProc that is called to delete all records when the entity is saved.

public virtual String SPDeleteAll {get; set;}

Remarks

The name of the stored procedure that is used to delete all recods for this sub-type.

See Also

AptifySubTypeBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


SPGetAll Property

Aptify 5.0 Software Development Kit (SDK)

AptifySubTypeBase.SPGetAll Property

The name of the SProc that is called when the sub-type is loaded.

public virtual String SPGetAll {get; set;}

Remarks

See Also

AptifySubTypeBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


spUpdate Property

Aptify 5.0 Software Development Kit (SDK)

AptifySubTypeBase.spUpdate Property

The name of the SProc that is called when the Sub-Type is updated.

public String spUpdate {get; set;}

Remarks

See Also

AptifySubTypeBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


SubTypeDataAssembly Property

Aptify 5.0 Software Development Kit (SDK)

AptifySubTypeBase.SubTypeDataAssembly Property

The name of the Assembly that holds the Entity wrapper for this sub-type.

public abstract String SubTypeDataAssembly {get;}

Property Value

Remarks

See Also

AptifySubTypeBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


SubTypeDataClass Property

Aptify 5.0 Software Development Kit (SDK)

AptifySubTypeBase.SubTypeDataClass Property

The name of the Type that holds the Entity wrapper that should be instantiated for this Sub-Type.

public abstract String SubTypeDataClass {get;}

Property Value

Remarks

See Also

AptifySubTypeBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


SubTypeDataObject Property

Aptify 5.0 Software Development Kit (SDK)

AptifySubTypeBase.SubTypeDataObject Property

The name of the Object repository Object that holds the assembly for this sub-type's wrapper.

public abstract String SubTypeDataObject {get;}

Property Value

Remarks

See Also

AptifySubTypeBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


SubTypeLevel Property

Aptify 5.0 Software Development Kit (SDK)

AptifySubTypeBase.SubTypeLevel Property

Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.

public virtual Byte SubTypeLevel {get;}

Remarks

See Also

AptifySubTypeBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


SubTypeLinks Property

Aptify 5.0 Software Development Kit (SDK)

AptifySubTypeBase.SubTypeLinks Property

Returns all of the fields that are linked values for this sub-type.

public virtual SubTypeLink[] SubTypeLinks {get;}

Remarks

See Also

AptifySubTypeBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


SubTypeViewerAssembly Property

Aptify 5.0 Software Development Kit (SDK)

AptifySubTypeBase.SubTypeViewerAssembly Property

The name of the Assembly that holds the Entity viewer for this sub-type.

public abstract String SubTypeViewerAssembly {get;}

Property Value

Remarks

See Also

AptifySubTypeBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


SubTypeViewerClass Property

Aptify 5.0 Software Development Kit (SDK)

AptifySubTypeBase.SubTypeViewerClass Property

The name of the Type that holds the Entity viewer that should be instantiated for this Sub-Type.

public abstract String SubTypeViewerClass {get;}

Property Value

Remarks

See Also

AptifySubTypeBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


SubTypeViewerObject Property

Aptify 5.0 Software Development Kit (SDK)

AptifySubTypeBase.SubTypeViewerObject Property

The name of the Object repository Object that holds the assembly for this sub-type's viewer.

public abstract String SubTypeViewerObject {get;}

Property Value

Remarks

See Also

AptifySubTypeBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifySubTypeBase Methods

The methods of the AptifySubTypeBase class are listed below. For a complete list of AptifySubTypeBase class members, see the AptifySubTypeBase Members topic.

Public Instance Methods

Add | Overloaded. Adds a GE record to the Sub-Type.
Append | Allows the user to add an initialized record to the internal collection of GE records.
Clear | Removes all of the GE records from memory that are contained in this SubType Instance.
ClearDirtyFlags | Clears all dirty flags associated with this instance and the GE record instances that are associated with this instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Find | Finds the first record associated with this instance that has a specific value for a specific field.
FindMultiple | Finds all records associated with this instance that has a specific value for a specific field.
FindPosition | Find the position of a Field Value combination in the Sub-Type instances records.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Gets the value of a field from a specific record position.
IndexOf | Gets the index of a specific GE record. If it does not exist, then -1 is returned.
Load | Loads all of the sub-type records for the instance of the sub-type.
MoveObject | Overloaded. Changes the position of a record in the Sub-Type's records.
NewRecord | Clears the current instance.
NewSubTypeRecord | Returns a new instance of a GE object that corresponds to the currently loaded sub-type record.
Remove | Removes specified GE instance from the Sub-Type's records.
RemoveAt | Overloaded. Removes GE records by Index.
Save | Saves the Sub-Type instance.
ShowFindGUI | Show a Find dialog with the Field value to search on already populated.
Sort | Overloaded. Sorts the records in the sub-type based on the field specified.
ToString (inherited from Object) | Returns a String that represents the current Object.
Validate | Validates that all of the GE instances in the sub-type have valid values.

Protected Instance Methods

CreateSubTypeGE | Creates and returns a configured Entity object for the Sub-Type Entity.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterClear | Verifies whether or not the AfterClear event should be fired. If the event should be fired, it is fired.
OnAfterItemAdd | Verifies whether or not the AfterItemAdd event should be fired. If the event should be fired, it is fired.
OnAfterItemRemove | Verifies whether or not the AfterItemRemove event should be fired. If the event should be fired, it is fired.
OnBeforeClear | Verifies whether or not the BeforeClear event should be fired. If the event should be fired, it is fired.
OnBeforeItemAdd | Verifies whether or not the BeforeItemAdd event should be fired. If the event should be fired, it is fired.
OnBeforeItemRemove | Verifies whether or not the BeforeItemRemove event should be fired. If the event should be fired, it is fired.
OnFindPositionPercentChanged |

See Also

AptifySubTypeBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


Add Method

Aptify 5.0 Software Development Kit (SDK)

AptifySubTypeBase.Add Method

Adds a GE record to the Sub-Type.

Overload List

public abstract AptifyGenericEntityBase Add();

public virtual int Add(AptifyGenericEntityBase);

See Also

AptifySubTypeBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifySubTypeBase.Add Method ()

public abstract AptifyGenericEntityBase Add();

See Also

AptifySubTypeBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifySubTypeBase.Add Overload List


AptifySubTypeBase.Add Method (AptifyGenericEntityBase)

public virtual int Add(
AptifyGenericEntityBase Value
);

Parameters

Value

Return Value

Remarks

See Also

AptifySubTypeBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifySubTypeBase.Add Overload List


AptifySubTypeBase.Append Method

Allows the user to add an initialized record to the internal collection of GE records.

public virtual AptifyGenericEntityBase Append(
AptifyGenericEntityBase NewGE
);

Parameters

NewGE

Return Value

It returns the GE record if it was successfully added.

Remarks

Aptify suggests that Add is called.

See Also

AptifySubTypeBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifySubTypeBase.Clear Method

Removes all of the GE records from memory that are contained in this SubType Instance.

public virtual void Clear();

Remarks

See Also

AptifySubTypeBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifySubTypeBase.ClearDirtyFlags Method

Clears all dirty flags associated with this instance and the GE record instances that are associated with this instance.

public abstract void ClearDirtyFlags();

Remarks

See Also

AptifySubTypeBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifySubTypeBase.CreateSubTypeGE Method

Creates and returns a configured Entity object for the Sub-Type Entity.

protected abstract AptifyGenericEntityBase CreateSubTypeGE(
Boolean ForLoad
);

Parameters

ForLoad
If ForLoad is false, the Sub-Type Entity object will be configured as a new record. If ForLoad is True, the object will be configured by not initialized as a new record. ForLoad = True is used when existing Sub-Type records are being loaded.

Return Value

Remarks

See Also

AptifySubTypeBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifySubTypeBase.Find Method

Finds the first record associated with this instance that has a specific value for a specific field.

public virtual AptifyGenericEntityBase Find(
String Field,
Object Value
);

Parameters

Field
The name of a field that exists in the current sub-type. This is the field that the search will be conducted on.
Value
The Value that we should search for.

Return Value

Nothing if a match is not found. The first GE record that has a field with the specified name and the field has a value that matches the supplied value.

Exceptions

Exception Type | Condition
AptifyDataFieldDoesNotExist | Throw when Field does not correspond to an existing Field on this SubType.

See Also

AptifySubTypeBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifySubTypeBase.FindMultiple Method

Finds all records associated with this instance that has a specific value for a specific field.

public virtual AptifyGenericEntityBase[] FindMultiple(
String Field,
String Value
);

Parameters

Field
Value

Return Value

Remarks

See Also

AptifySubTypeBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifySubTypeBase.FindPosition Method

Find the position of a Field Value combination in the Sub-Type instances records.

public abstract bool FindPosition(
String Field,
String Value,
AptifyCompare Compare,
ref Int32& Position,
Boolean CaseInsensitive,
Int32 StartPosition
);

Parameters

Field
Value
Compare
Position
CaseInsensitive
StartPosition

Return Value

Remarks

The execution time for this member may be extensive, so a cancel feature can be utilized by catching the FindPositionPercentChanged event. Transfered from ICGISTInfoFind2, was Find now FindPosition

See Also

AptifySubTypeBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifySubTypeBase.GetValue Method

Gets the value of a field from a specific record position.

public abstract object GetValue(
Int32 Index,
String Field
);

Parameters

Index
Field

Return Value

Remarks

Transfered from ICGISTInfoVal

See Also

AptifySubTypeBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifySubTypeBase.IndexOf Method

Gets the index of a specific GE record. If it does not exist, then -1 is returned.

public virtual int IndexOf(
AptifyGenericEntityBase Value
);

Parameters

Value

Return Value

Remarks

See Also

AptifySubTypeBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifySubTypeBase.Load Method

Loads all of the sub-type records for the instance of the sub-type.

public abstract bool Load();

Return Value

Remarks

See Also

AptifySubTypeBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


MoveObject Method

Aptify 5.0 Software Development Kit (SDK)

AptifySubTypeBase.MoveObject Method

Changes the position of a record in the Sub-Type's records.

Overload List

Changes the position of a record in the Sub-Type's records.

public virtual void MoveObject(Int32,Int32);

Changes the position of a record in the Sub-Type's records.

public abstract void MoveObject(Int32,Int32,AptifyMoveObjectOptions);

See Also

AptifySubTypeBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifySubTypeBase.MoveObject Method (Int32, Int32)

Changes the position of a record in the Sub-Type's records.

public virtual void MoveObject(
Int32 CurPos,
Int32 NewPos
);

Parameters

CurPos
NewPos

Remarks

See Also

AptifySubTypeBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifySubTypeBase.MoveObject Overload List


AptifySubTypeBase.MoveObject Method (Int32, Int32, AptifyMoveObjectOptions)

Changes the position of a record in the Sub-Type's records.

public abstract void MoveObject(
Int32 CurPos,
Int32 NewPos,
AptifyMoveObjectOptions MoveOption
);

Parameters

CurPos
NewPos
MoveOption

Remarks

See Also

AptifySubTypeBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifySubTypeBase.MoveObject Overload List


AptifySubTypeBase.NewRecord Method

Clears the current instance.

public abstract void NewRecord();

Remarks

See Also

AptifySubTypeBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifySubTypeBase.NewSubTypeRecord Method

Returns a new instance of a GE object that corresponds to the currently loaded sub-type record.

public abstract AptifyGenericEntityBase NewSubTypeRecord();

Return Value

Remarks

See Also

AptifySubTypeBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifySubTypeBase.OnAfterClear Method

Verifies whether or not the AfterClear event should be fired. If the event should be fired, it is fired.

protected void OnAfterClear();

Remarks

See Also

AptifySubTypeBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifySubTypeBase.OnAfterItemAdd Method

Verifies whether or not the AfterItemAdd event should be fired. If the event should be fired, it is fired.

protected void OnAfterItemAdd(
AptifyGenericEntityBase geAdded,
Int32 Index
);

Parameters

geAdded
Contains a reference to the AptifyGenericEntityBase object that was added to the Sub-Type.
Index
Contains the index position of new object with the Sub-Type's list.

Remarks

See Also

AptifySubTypeBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifySubTypeBase.OnAfterItemRemove Method

Verifies whether or not the AfterItemRemove event should be fired. If the event should be fired, it is fired.

protected void OnAfterItemRemove(
AptifyGenericEntityBase geRemoved
);

Parameters

geRemoved
Contains a reference to the AptifyGenericEntityBase object that was removed from the Sub-Type.

Remarks

See Also

AptifySubTypeBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifySubTypeBase.OnBeforeClear Method

Verifies whether or not the BeforeClear event should be fired. If the event should be fired, it is fired.

protected bool OnBeforeClear();

Return Value

Returns false if the BeforeClear event handler set Cancel property to true or if an exception was raised by the event handler. Otherwise, returns true.

Remarks

See Also

AptifySubTypeBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifySubTypeBase.OnBeforeItemAdd Method

Verifies whether or not the BeforeItemAdd event should be fired. If the event should be fired, it is fired.

protected bool OnBeforeItemAdd(
AptifyGenericEntityBase geToAdd
);

Parameters

geToAdd
Contains a reference to the AptifyGenericEntityBase object that will be added to the Sub-Type if the operation is succesful.

Return Value

Returns false if the BeforeItemAdd event handler set Cancel property to true or if an exception was raised by the event handler. Otherwise, returns true.

Remarks

See Also

AptifySubTypeBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifySubTypeBase.OnBeforeItemRemove Method

Verifies whether or not the BeforeItemRemove event should be fired. If the event should be fired, it is fired.

protected bool OnBeforeItemRemove(
AptifyGenericEntityBase geToRemove
);

Parameters

geToRemove
Contains a reference to the AptifyGenericEntityBase object that will be removed from the Sub-Type if the operation is succesful.

Return Value

Returns false if the BeforeItemRemove event handler set Cancel property to true or if an exception was raised by the event handler. Otherwise, returns true.

Remarks

See Also

AptifySubTypeBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifySubTypeBase.OnFindPositionPercentChanged Method

protected void OnFindPositionPercentChanged(
Int32 PercentComplete,
ref Boolean& Cancel
);

See Also

AptifySubTypeBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifySubTypeBase.Remove Method

Removes specified GE instance from the Sub-Type's records.

public virtual void Remove(
AptifyGenericEntityBase Value
);

Parameters

Value

Remarks

See Also

AptifySubTypeBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


RemoveAt Method

Aptify 5.0 Software Development Kit (SDK)

AptifySubTypeBase.RemoveAt Method

Removes GE records by Index.

Overload List

public virtual void RemoveAt(Int32);

public virtual void RemoveAt(Int32[]);

See Also

AptifySubTypeBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifySubTypeBase.RemoveAt Method (Int32)

public virtual void RemoveAt(
Int32 Index
);

Parameters

Index

Remarks

See Also

AptifySubTypeBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifySubTypeBase.RemoveAt Overload List


AptifySubTypeBase.RemoveAt Method (Int32[])

public virtual void RemoveAt(
Int32[] Indexes
);

See Also

AptifySubTypeBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifySubTypeBase.RemoveAt Overload List


AptifySubTypeBase.Save Method

Saves the Sub-Type instance.

public abstract bool Save(
ref String& ErrorString,
String TransactionID
);

Parameters

ErrorString
TransactionID

Return Value

Remarks

See Also

AptifySubTypeBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifySubTypeBase.ShowFindGUI Method

Show a Find dialog with the Field value to search on already populated.

public abstract bool ShowFindGUI(
ref String& Field,
ref Int32& Position,
ref String& Value,
ref AptifyCompare& Compare,
ref Boolean& CaseInsensitive,
Int32 StartPosition
);

Parameters

Field
Position
Value
Compare
CaseInsensitive
StartPosition

Return Value

Remarks

See Also

AptifySubTypeBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


Sort Method

Aptify 5.0 Software Development Kit (SDK)

AptifySubTypeBase.Sort Method

Sorts the records in the sub-type based on the field specified.

Overload List

Sorts the records in the sub-type based on the field specified.

public abstract void Sort(String);

Sorts the records in the sub-type based on the field specified.

public abstract void Sort(String,AptifySortDirection);

See Also

AptifySubTypeBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifySubTypeBase.Sort Method (String)

Sorts the records in the sub-type based on the field specified.

public abstract void Sort(
String Field
);

Parameters

Field

Remarks

Transfered from ICGISTPosition

See Also

AptifySubTypeBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifySubTypeBase.Sort Overload List


AptifySubTypeBase.Sort Method (String, AptifySortDirection)

Sorts the records in the sub-type based on the field specified.

public abstract void Sort(
String Field,
AptifySortDirection Direction
);

Parameters

Field
Direction

Remarks

See Also

AptifySubTypeBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifySubTypeBase.Sort Overload List


AptifySubTypeBase.Validate Method

Validates that all of the GE instances in the sub-type have valid values.

public abstract bool Validate(
ref String& ErrorString
);

Parameters

ErrorString

Return Value

Remarks

See Also

AptifySubTypeBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifySubTypeBase Events

The events of the AptifySubTypeBase class are listed below. For a complete list of AptifySubTypeBase class members, see the AptifySubTypeBase Members topic.

Public Instance Events

AfterClear | Fired when the Sub-Type's Clear method is called, before the Clear occurs. Note the event will only be fired if the Sub-Type's EventsToFire property setting includes the Clear Events.
AfterItemAdd | Fired at the end of the Sub-Type's Add method after the object has been added.
AfterItemRemove |
BeforeClear | Fired when the Sub-Type's Clear method is called, before the Clear occurs. Note the event will only be fired if the Sub-Type's EventsToFire property setting includes the Clear Events.
BeforeItemAdd | Fired when the Sub-Type's Add method is called, before the Add occurs. Note the event will only be fired if the Sub-Type's EventsToFire property setting includes the ItemAdd Events.
BeforeItemRemove |
FindPositionPercentChanged | An event that occurs as the search position changes during a FindPosition member call.

See Also

AptifySubTypeBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifySubTypeBase.AptifySubTypeBase.AfterClearEventHandler Event

Fired when the Sub-Type's Clear method is called, before the Clear occurs. Note the event will only be fired if the Sub-Type's EventsToFire property setting includes the Clear Events.

public event AptifySubTypeBase.AfterClearEventHandler AfterClear;

Remarks

See Also

AptifySubTypeBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifySubTypeBase.AptifySubTypeBase.AfterItemAddEventHandler Event

Fired at the end of the Sub-Type's Add method after the object has been added.

public event AptifySubTypeBase.AfterItemAddEventHandler AfterItemAdd;

Event Data

The event handler receives an argument of type AfterSubTypeItemAddEventArgs containing data related to this event. The following AfterSubTypeItemAddEventArgs properties provide information specific to this event.

Property | Description
geAdded | Contains a reference to the AptifyGenericEntityBase object that was added to the Sub-Type
Index | Contains the index position of the newly added object in the Sub-Type's list.

Remarks

See Also

AptifySubTypeBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifySubTypeBase.AptifySubTypeBase.AfterItemRemoveEventHandler Event

public event AptifySubTypeBase.AfterItemRemoveEventHandler AfterItemRemove;

See Also

AptifySubTypeBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifySubTypeBase.AptifySubTypeBase.BeforeClearEventHandler Event

Fired when the Sub-Type's Clear method is called, before the Clear occurs. Note the event will only be fired if the Sub-Type's EventsToFire property setting includes the Clear Events.

public event AptifySubTypeBase.BeforeClearEventHandler BeforeClear;

Remarks

See Also

AptifySubTypeBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifySubTypeBase.AptifySubTypeBase.BeforeItemAddEventHandler Event

Fired when the Sub-Type's Add method is called, before the Add occurs. Note the event will only be fired if the Sub-Type's EventsToFire property setting includes the ItemAdd Events.

public event AptifySubTypeBase.BeforeItemAddEventHandler BeforeItemAdd;

Event Data

The event handler receives an argument of type BeforeSubTypeItemAddEventArgs containing data related to this event. The following BeforeSubTypeItemAddEventArgs properties provide information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.
geToAdd | Contains a reference to the AptifyGenericEntityBase object that will be added to the Sub-Type if the operation is successful.

Remarks

See Also

AptifySubTypeBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifySubTypeBase.AptifySubTypeBase.BeforeItemRemoveEventHandler Event

public event AptifySubTypeBase.BeforeItemRemoveEventHandler BeforeItemRemove;

Event Data

The event handler receives an argument of type BeforeSubTypeItemRemoveEventArgs containing data related to this event. The following BeforeSubTypeItemRemoveEventArgs properties provide information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.
geToRemove | Contains a reference to the AptifyGenericEntityBase object that will be removed from the Sub-Type if the operation is successful.

See Also

AptifySubTypeBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifySubTypeBase.AptifySubTypeBase.FindPositionPercentChangedEventHandler Event

An event that occurs as the search position changes during a FindPosition member call.

public event AptifySubTypeBase.FindPositionPercentChangedEventHandler FindPositionPercentChanged;

See Also

AptifySubTypeBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifySubTypeBase.AfterClearEventHandler Delegate

public delegate void AptifySubTypeBase.AfterClearEventHandler(
AptifySubTypeBase sender,
EventArgs e
);

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifySubTypeBase.AfterItemAddEventHandler Delegate

public delegate void AptifySubTypeBase.AfterItemAddEventHandler(
AptifySubTypeBase sender,
AfterSubTypeItemAddEventArgs e
);

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifySubTypeBase.AfterItemRemoveEventHandler Delegate

public delegate void AptifySubTypeBase.AfterItemRemoveEventHandler(
AptifySubTypeBase sender,
EventArgs e
);

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifySubTypeBase.AptifySubTypeEvents Enumeration

Enumeration that identifies the different Event settings available on a SubType.

public enum AptifySubTypeBase.AptifySubTypeEvents

Remarks

Members

Member Name | Description
None |
AllEvents |
Clear |
ItemAdd |
ItemRemove |
Sort |
ItemMove |

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifySubTypeBase.BeforeClearEventHandler Delegate

public delegate void AptifySubTypeBase.BeforeClearEventHandler(
AptifySubTypeBase sender,
CancelEventArgs e
);

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifySubTypeBase.BeforeItemAddEventHandler Delegate

public delegate void AptifySubTypeBase.BeforeItemAddEventHandler(
AptifySubTypeBase sender,
BeforeSubTypeItemAddEventArgs e
);

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifySubTypeBase.BeforeItemRemoveEventHandler Delegate

public delegate void AptifySubTypeBase.BeforeItemRemoveEventHandler(
AptifySubTypeBase sender,
BeforeSubTypeItemRemoveEventArgs e
);

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifySubTypeBase.FindPositionPercentChangedEventHandler Delegate

public delegate void AptifySubTypeBase.FindPositionPercentChangedEventHandler(
Int32 PercentComplete,
ref Boolean& Cancel
);

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifySubTypes Class

For a list of all members of this type, see AptifySubTypes Members.

System.Object
NameObjectCollectionBase
AptifyCollection
AptifySubTypes

public class AptifySubTypes : AptifyCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

AptifySubTypes Members | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifySubTypes Members

AptifySubTypes overview

Public Instance Constructors

AptifySubTypes Constructor

Public Instance Properties

BatchSQL |
Count (inherited from NameObjectCollectionBase) | Gets the number of key/value pairs contained in the NameObjectCollectionBase instance.
ExistingRowsDeleted | Property which determines if any of the contained subtype objects have ExistingRowsDeleted = TRUE.
Item | Overloaded.
Keys (inherited from NameObjectCollectionBase) | Gets a KeysCollection instance that contains all the keys in the NameObjectCollectionBase instance.
RecordChangeString |
RecordChangeXML |

Public Instance Methods

Add | Overloaded.
Clear (inherited from AptifyCollection) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindIndexByName |
GetEnumerator (inherited from AptifyCollection) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from NameObjectCollectionBase) | Implements the ISerializable interface and returns the data needed to serialize the NameObjectCollectionBase instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf |
Merge (inherited from AptifyCollection) | Allows a user to merge items from another collection to this collection.
OnDeserialization (inherited from NameObjectCollectionBase) | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete.
Remove (inherited from AptifyCollection) | Overloaded.
RemoveAt (inherited from AptifyCollection) |
Save |
ToString (inherited from Object) | Returns a String that represents the current Object.
Validate |

Protected Instance Properties

IsReadOnly (inherited from NameObjectCollectionBase) Gets or sets a value indicating whether the NameObjectCollectionBase instance is read-only.

Protected Instance Methods

BaseAdd (inherited from NameObjectCollectionBase) | Adds an entry with the specified key and value into the NameObjectCollectionBase instance.
BaseClear (inherited from NameObjectCollectionBase) | Removes all entries from the NameObjectCollectionBase instance.
BaseGet (inherited from NameObjectCollectionBase) | Overloaded. Gets the value of the first entry with the specified key from the NameObjectCollectionBase instance.
BaseGetAllKeys (inherited from NameObjectCollectionBase) | Returns a String array that contains all the keys in the NameObjectCollectionBase instance.
BaseGetAllValues (inherited from NameObjectCollectionBase) | Overloaded. Returns an Object array that contains all the values in the NameObjectCollectionBase instance.
BaseGetKey (inherited from NameObjectCollectionBase) | Gets the key of the entry at the specified index of the NameObjectCollectionBase instance.
BaseHasKeys (inherited from NameObjectCollectionBase) | Gets a value indicating whether the NameObjectCollectionBase instance contains entries whose keys are not null.
BaseRemove (inherited from NameObjectCollectionBase) | Removes the entries with the specified key from the NameObjectCollectionBase instance.
BaseRemoveAt (inherited from NameObjectCollectionBase) | Removes the entry at the specified index of the NameObjectCollectionBase instance.
BaseSet (inherited from NameObjectCollectionBase) | Overloaded. Sets the value of the first entry with the specified key in the NameObjectCollectionBase instance, if found; otherwise, adds an entry with the specified key and value into the NameObjectCollectionBase instance.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifySubTypes Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifySubTypes Constructor

public AptifySubTypes(
AptifyGenericEntityBase ParentGE
);

See Also

AptifySubTypes Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifySubTypes Properties

The properties of the AptifySubTypes class are listed below. For a complete list of AptifySubTypes class members, see the AptifySubTypes Members topic.

Public Instance Properties

BatchSQL |
Count (inherited from NameObjectCollectionBase) | Gets the number of key/value pairs contained in the NameObjectCollectionBase instance.
ExistingRowsDeleted | Property which determines if any of the contained subtype objects have ExistingRowsDeleted = TRUE.
Item | Overloaded.
Keys (inherited from NameObjectCollectionBase) | Gets a KeysCollection instance that contains all the keys in the NameObjectCollectionBase instance.
RecordChangeString |
RecordChangeXML |

Protected Instance Properties

IsReadOnly (inherited from NameObjectCollectionBase) Gets or sets a value indicating whether the NameObjectCollectionBase instance is read-only.

See Also

AptifySubTypes Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


BatchSQL Property

Aptify 5.0 Software Development Kit (SDK)

AptifySubTypes.BatchSQL Property

public virtual String BatchSQL {get;}

See Also

AptifySubTypes Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ExistingRowsDeleted Property

Aptify 5.0 Software Development Kit (SDK)

AptifySubTypes.ExistingRowsDeleted Property

Property which determines if any of the contained subtype objects have ExistingRowsDeleted = TRUE.

public virtual Boolean ExistingRowsDeleted {get;}

Property Value

Returns TRUE if any contained subtypes have existing rows which have been deleted.

Remarks

See Also

AptifySubTypes Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifySubTypeBase Property

Aptify 5.0 Software Development Kit (SDK)

AptifySubTypes.AptifySubTypeBase Property

Overload List

public virtual AptifySubTypeBase this[Int32] {get; set;}

public virtual AptifySubTypeBase this[String] {get; set;}

See Also

AptifySubTypes Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


Item Property (Int32)

Aptify 5.0 Software Development Kit (SDK)

AptifySubTypes.Item Property (Int32)

public virtual AptifySubTypeBase this[
Int32 Index
] {get; set;}

See Also

AptifySubTypes Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifySubTypes.AptifySubTypeBase Overload List


Item Property (String)

Aptify 5.0 Software Development Kit (SDK)

AptifySubTypes.Item Property (String)

public virtual AptifySubTypeBase this[
String Key
] {get; set;}

See Also

AptifySubTypes Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifySubTypes.AptifySubTypeBase Overload List


RecordChangeString Property

Aptify 5.0 Software Development Kit (SDK)

AptifySubTypes.RecordChangeString Property

public virtual String RecordChangeString {get;}

See Also

AptifySubTypes Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


RecordChangeXML Property

Aptify 5.0 Software Development Kit (SDK)

AptifySubTypes.RecordChangeXML Property

public virtual String RecordChangeXML {get;}

See Also

AptifySubTypes Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifySubTypes Methods

The methods of the AptifySubTypes class are listed below. For a complete list of AptifySubTypes class members, see the AptifySubTypes Members topic.

Public Instance Methods

Add | Overloaded.
Clear (inherited from AptifyCollection) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindIndexByName |
GetEnumerator (inherited from AptifyCollection) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from NameObjectCollectionBase) | Implements the ISerializable interface and returns the data needed to serialize the NameObjectCollectionBase instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf |
Merge (inherited from AptifyCollection) | Allows a user to merge items from another collection to this collection.
OnDeserialization (inherited from NameObjectCollectionBase) | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete.
Remove (inherited from AptifyCollection) | Overloaded.
RemoveAt (inherited from AptifyCollection) |
Save |
ToString (inherited from Object) | Returns a String that represents the current Object.
Validate |

Protected Instance Methods

BaseAdd (inherited from NameObjectCollectionBase) | Adds an entry with the specified key and value into the NameObjectCollectionBase instance.
BaseClear (inherited from NameObjectCollectionBase) | Removes all entries from the NameObjectCollectionBase instance.
BaseGet (inherited from NameObjectCollectionBase) | Overloaded. Gets the value of the first entry with the specified key from the NameObjectCollectionBase instance.
BaseGetAllKeys (inherited from NameObjectCollectionBase) | Returns a String array that contains all the keys in the NameObjectCollectionBase instance.
BaseGetAllValues (inherited from NameObjectCollectionBase) | Overloaded. Returns an Object array that contains all the values in the NameObjectCollectionBase instance.
BaseGetKey (inherited from NameObjectCollectionBase) | Gets the key of the entry at the specified index of the NameObjectCollectionBase instance.
BaseHasKeys (inherited from NameObjectCollectionBase) | Gets a value indicating whether the NameObjectCollectionBase instance contains entries whose keys are not null.
BaseRemove (inherited from NameObjectCollectionBase) | Removes the entries with the specified key from the NameObjectCollectionBase instance.
BaseRemoveAt (inherited from NameObjectCollectionBase) | Removes the entry at the specified index of the NameObjectCollectionBase instance.
BaseSet (inherited from NameObjectCollectionBase) | Overloaded. Sets the value of the first entry with the specified key in the NameObjectCollectionBase instance, if found; otherwise, adds an entry with the specified key and value into the NameObjectCollectionBase instance.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifySubTypes Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


Add Method

Aptify 5.0 Software Development Kit (SDK)

AptifySubTypes.Add Method

Overload List

public virtual int Add(AptifySubTypeBase);

public virtual int Add(AptifySubTypeBase,String);

public override int Add(Object);

public override int Add(Object,String);

See Also

AptifySubTypes Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifySubTypes.Add Method (AptifySubTypeBase)

public virtual int Add(
AptifySubTypeBase Value
);

See Also

AptifySubTypes Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifySubTypes.Add Overload List


AptifySubTypes.Add Method (AptifySubTypeBase, String)

public virtual int Add(
AptifySubTypeBase Value,
String Key
);

See Also

AptifySubTypes Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifySubTypes.Add Overload List


AptifySubTypes.Add Method (Object)

public override int Add(
Object Value
);

See Also

AptifySubTypes Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifySubTypes.Add Overload List


AptifySubTypes.Add Method (Object, String)

public override int Add(
Object Value,
String Key
);

See Also

AptifySubTypes Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifySubTypes.Add Overload List


AptifySubTypes.FindIndexByName Method

public virtual int FindIndexByName(
String Key
);

See Also

AptifySubTypes Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifySubTypes.IndexOf Method

new public virtual int IndexOf(
String Key
);

See Also

AptifySubTypes Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifySubTypes.Save Method

public virtual bool Save(
ref String& ErrorString,
String TransactionID
);

See Also

AptifySubTypes Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifySubTypes.Validate Method

public virtual bool Validate(
ref String& ErrorString
);

See Also

AptifySubTypes Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyTransferMapping Class

For a list of all members of this type, see AptifyTransferMapping Members.

System.Object
AptifyTransferMapping

public class AptifyTransferMapping : IAptifyTransferMap

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntity (in AptifyGenericEntity.dll)

See Also

AptifyTransferMapping Members | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyTransferMapping Members

AptifyTransferMapping overview

Public Instance Constructors

AptifyTransferMapping Constructor

Public Instance Methods

AddMapping |
ClearMappings |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetMapping |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyTransferMapping Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyTransferMapping Constructor

public AptifyTransferMapping(
UserCredentials UserCredentials
);

See Also

AptifyTransferMapping Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyTransferMapping Methods

The methods of the AptifyTransferMapping class are listed below. For a complete list of AptifyTransferMapping class members, see the AptifyTransferMapping Members topic.

Public Instance Methods

AddMapping |
ClearMappings |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetMapping |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyTransferMapping Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyTransferMapping.AddMapping Method

public void AddMapping(
String Entity,
DataLocation MapLocation,
Int64 SourceID,
DataLocation SourceLocation,
Int64 DestID,
DataLocation DestLocation
);

Implements

IAptifyTransferMap.

See Also

AptifyTransferMapping Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyTransferMapping.ClearMappings Method

public void ClearMappings(
DataLocation MapLocation
);

Implements

IAptifyTransferMap.

See Also

AptifyTransferMapping Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyTransferMapping.GetMapping Method

public int GetMapping(
String Entity,
DataLocation MapLocation,
Int64 SourceID,
DataLocation SourceLocation,
DataLocation DestLocation
);

Implements

IAptifyTransferMap.

See Also

AptifyTransferMapping Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyTransferMappingNoMatchException Class

For a list of all members of this type, see AptifyTransferMappingNoMatchException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
AptifyTransferMappingNoMatchException

public class AptifyTransferMappingNoMatchException : BaseApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntity (in AptifyGenericEntity.dll)

See Also

AptifyTransferMappingNoMatchException Members | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyTransferMappingNoMatchException Members

AptifyTransferMappingNoMatchException overview

Public Instance Constructors

AptifyTransferMappingNoMatchException Overloaded. Initializes a new instance of the AptifyTransferMappingNoMatchException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Constructors

AptifyTransferMappingNoMatchException Overloaded. Initializes a new instance of the AptifyTransferMappingNoMatchException class.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyTransferMappingNoMatchException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyTransferMappingNoMatchException Constructor

Overload List

protected AptifyTransferMappingNoMatchException(SerializationInfo,StreamingContext);

public AptifyTransferMappingNoMatchException(String,DataLocation,DataLocation,Int64,DataLocation);

See Also

AptifyTransferMappingNoMatchException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyTransferMappingNoMatchException Constructor (String, DataLocation, DataLocation, Int64, DataLocation)

public AptifyTransferMappingNoMatchException(
String Entity,
DataLocation MapLocation,
DataLocation SourceLocation,
Int64 SourceID,
DataLocation DestLocation
);

See Also

AptifyTransferMappingNoMatchException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyTransferMappingNoMatchException Constructor Overload List


AptifyTransferMappingNoMatchException Constructor (SerializationInfo, StreamingContext)

protected AptifyTransferMappingNoMatchException(
SerializationInfo info,
StreamingContext context
);

See Also

AptifyTransferMappingNoMatchException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | AptifyTransferMappingNoMatchException Constructor Overload List


AptifyTransferMappingNoMatchException Methods

The methods of the AptifyTransferMappingNoMatchException class are listed below. For a complete list of AptifyTransferMappingNoMatchException class members, see the AptifyTransferMappingNoMatchException Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyTransferMappingNoMatchException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AptifyTransferMappingNoMatchException.GetObjectData Method

public override void GetObjectData(
SerializationInfo info,
StreamingContext context
);

Implements

ISerializable.

See Also

AptifyTransferMappingNoMatchException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


BeforeCloneRecordEventArgs Class

Holds the Event arguments for the BeforeClone Event in the AptifyGenericEntityBase class

For a list of all members of this type, see BeforeCloneRecordEventArgs Members.

System.Object
EventArgs
CancelEventArgs
BeforeCloneRecordEventArgs

public class BeforeCloneRecordEventArgs : CancelEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

BeforeCloneRecordEventArgs Members | Aptify.Framework.BusinessLogic.GenericEntity Namespace


BeforeCloneRecordEventArgs Members

BeforeCloneRecordEventArgs overview

Public Instance Constructors

BeforeCloneRecordEventArgs Constructor

Public Instance Properties

Cancel (inherited from CancelEventArgs) | Gets or sets a value indicating whether the event should be canceled.
geToClone | Represents the Generic Entity object that will be cloned.
Merge | Represents the Merge setting, either True or False. The Event Handler can change this value.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BeforeCloneRecordEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


BeforeCloneRecordEventArgs Constructor

public BeforeCloneRecordEventArgs(
AptifyGenericEntityBase geToClone,
Boolean Merge
);

See Also

BeforeCloneRecordEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


BeforeCloneRecordEventArgs Properties

The properties of the BeforeCloneRecordEventArgs class are listed below. For a complete list of BeforeCloneRecordEventArgs class members, see the BeforeCloneRecordEventArgs Members topic.

Public Instance Properties

Cancel (inherited from CancelEventArgs) | Gets or sets a value indicating whether the event should be canceled.
geToClone | Represents the Generic Entity object that will be cloned.
Merge | Represents the Merge setting, either True or False. The Event Handler can change this value.

See Also

BeforeCloneRecordEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


geToClone Property

Aptify 5.0 Software Development Kit (SDK)

BeforeCloneRecordEventArgs.geToClone Property

Represents the Generic Entity object that will be cloned.

public AptifyGenericEntityBase geToClone {get; set;}

Property Value

Remarks

See Also

BeforeCloneRecordEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


Merge Property

Aptify 5.0 Software Development Kit (SDK)

BeforeCloneRecordEventArgs.Merge Property

Represents the Merge setting, either True or False. The Event Handler can change this value.

public Boolean Merge {get; set;}

Property Value

Remarks

See Also

BeforeCloneRecordEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


BeforeDataFieldCloneEventArgs Class

Holds the Event arguments for the BeforeClone Event in the AptifyDataFieldBase class

For a list of all members of this type, see BeforeDataFieldCloneEventArgs Members.

System.Object
EventArgs
CancelEventArgs
BeforeDataFieldCloneEventArgs

public class BeforeDataFieldCloneEventArgs : CancelEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

BeforeDataFieldCloneEventArgs Members | Aptify.Framework.BusinessLogic.GenericEntity Namespace


BeforeDataFieldCloneEventArgs Members

BeforeDataFieldCloneEventArgs overview

Public Instance Constructors

BeforeDataFieldCloneEventArgs Constructor

Public Instance Properties

Cancel (inherited from CancelEventArgs) | Gets or sets a value indicating whether the event should be canceled.
FieldToClone | Represents the Data Field object that will be cloned.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BeforeDataFieldCloneEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


BeforeDataFieldCloneEventArgs Constructor

public BeforeDataFieldCloneEventArgs(
AptifyDataFieldBase m_FieldToClone
);

See Also

BeforeDataFieldCloneEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


BeforeDataFieldCloneEventArgs Properties

The properties of the BeforeDataFieldCloneEventArgs class are listed below. For a complete list of BeforeDataFieldCloneEventArgs class members, see the BeforeDataFieldCloneEventArgs Members topic.

Public Instance Properties

Cancel (inherited from CancelEventArgs) | Gets or sets a value indicating whether the event should be canceled.
FieldToClone | Represents the Data Field object that will be cloned.

See Also

BeforeDataFieldCloneEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


FieldToClone Property

Aptify 5.0 Software Development Kit (SDK)

BeforeDataFieldCloneEventArgs.FieldToClone Property

Represents the Data Field object that will be cloned.

public AptifyDataFieldBase FieldToClone {get; set;}

Property Value

Remarks

See Also

BeforeDataFieldCloneEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


BeforeDataFieldValidateEventArgs Class

Holds the Event arguments for the BeforeDataFieldValidate Event in the AptifyDataFieldBase class

For a list of all members of this type, see BeforeDataFieldValidateEventArgs Members.

System.Object
EventArgs
CancelEventArgs
BeforeDataFieldValidateEventArgs

public class BeforeDataFieldValidateEventArgs : CancelEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

BeforeDataFieldValidateEventArgs Members | Aptify.Framework.BusinessLogic.GenericEntity Namespace


BeforeDataFieldValidateEventArgs Members

BeforeDataFieldValidateEventArgs overview

Public Instance Constructors

BeforeDataFieldValidateEventArgs Constructor Initializes a new instance of the BeforeDataFieldValidateEventArgs class.

Public Instance Properties

Cancel (inherited from CancelEventArgs) | Gets or sets a value indicating whether the event should be canceled.
ErrorString | Used to pass an error into the Validate routine. The Field's GetLastError method will return the ErrorString.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BeforeDataFieldValidateEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


BeforeDataFieldValidateEventArgs Constructor

Initializes a new instance of the BeforeDataFieldValidateEventArgs class.

public BeforeDataFieldValidateEventArgs();

See Also

BeforeDataFieldValidateEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


BeforeDataFieldValidateEventArgs Properties

The properties of the BeforeDataFieldValidateEventArgs class are listed below. For a complete list of BeforeDataFieldValidateEventArgs class members, see the BeforeDataFieldValidateEventArgs Members topic.

Public Instance Properties

Cancel (inherited from CancelEventArgs) | Gets or sets a value indicating whether the event should be canceled.
ErrorString | Used to pass an error into the Validate routine. The Field's GetLastError method will return the ErrorString.

See Also

BeforeDataFieldValidateEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ErrorString Property

Aptify 5.0 Software Development Kit (SDK)

BeforeDataFieldValidateEventArgs.ErrorString Property

Used to pass an error into the Validate routine. The Field's GetLastError method will return the ErrorString.

public String ErrorString {get; set;}

Property Value

Remarks

See Also

BeforeDataFieldValidateEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


BeforeDeleteRecordEventArgs Class

Holds the Event arguments for the BeforeDeleteRecord Event in the AptifyGenericEntityBase class

For a list of all members of this type, see BeforeDeleteRecordEventArgs Members.

System.Object
EventArgs
CancelEventArgs
BeforeDeleteRecordEventArgs

public class BeforeDeleteRecordEventArgs : CancelEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

BeforeDeleteRecordEventArgs Members | Aptify.Framework.BusinessLogic.GenericEntity Namespace


BeforeDeleteRecordEventArgs Members

BeforeDeleteRecordEventArgs overview

Public Instance Constructors

BeforeDeleteRecordEventArgs Constructor

Public Instance Properties

Cancel (inherited from CancelEventArgs) | Gets or sets a value indicating whether the event should be canceled.
TransactionID |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BeforeDeleteRecordEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


BeforeDeleteRecordEventArgs Constructor

public BeforeDeleteRecordEventArgs(
String TransactionID
);

See Also

BeforeDeleteRecordEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


BeforeDeleteRecordEventArgs Properties

The properties of the BeforeDeleteRecordEventArgs class are listed below. For a complete list of BeforeDeleteRecordEventArgs class members, see the BeforeDeleteRecordEventArgs Members topic.

Public Instance Properties

Cancel (inherited from CancelEventArgs) | Gets or sets a value indicating whether the event should be canceled.
TransactionID |

See Also

BeforeDeleteRecordEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


TransactionID Property

Aptify 5.0 Software Development Kit (SDK)

BeforeDeleteRecordEventArgs.TransactionID Property

public String TransactionID {get;}

See Also

BeforeDeleteRecordEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


BeforeLoadRecordEventArgs Class

Holds the Event arguments for the BeforeLoadRecord Event in the AptifyGenericEntityBase class

For a list of all members of this type, see BeforeLoadRecordEventArgs Members.

System.Object
EventArgs
CancelEventArgs
BeforeLoadRecordEventArgs

public class BeforeLoadRecordEventArgs : CancelEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

BeforeLoadRecordEventArgs Members | Aptify.Framework.BusinessLogic.GenericEntity Namespace


BeforeLoadRecordEventArgs Members

BeforeLoadRecordEventArgs overview

Public Instance Constructors

BeforeLoadRecordEventArgs Overloaded. Initializes a new instance of the BeforeLoadRecordEventArgs class.

Public Instance Properties

Cancel (inherited from CancelEventArgs) | Gets or sets a value indicating whether the event should be canceled.
Filename |
ID |
LoadType |
Reader |
Row |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BeforeLoadRecordEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


BeforeLoadRecordEventArgs Constructor

Overload List

public BeforeLoadRecordEventArgs(DataRow);

public BeforeLoadRecordEventArgs(IDataReader);

public BeforeLoadRecordEventArgs(Int64);

public BeforeLoadRecordEventArgs(String);

See Also

BeforeLoadRecordEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


BeforeLoadRecordEventArgs Constructor (Int64)

public BeforeLoadRecordEventArgs(
Int64 ID
);

See Also

BeforeLoadRecordEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | BeforeLoadRecordEventArgs Constructor Overload List


BeforeLoadRecordEventArgs Constructor (String)

public BeforeLoadRecordEventArgs(
String FileName
);

See Also

BeforeLoadRecordEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | BeforeLoadRecordEventArgs Constructor Overload List


BeforeLoadRecordEventArgs Constructor (DataRow)

public BeforeLoadRecordEventArgs(
DataRow row
);

See Also

BeforeLoadRecordEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | BeforeLoadRecordEventArgs Constructor Overload List


BeforeLoadRecordEventArgs Constructor (IDataReader)

public BeforeLoadRecordEventArgs(
IDataReader reader
);

See Also

BeforeLoadRecordEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | BeforeLoadRecordEventArgs Constructor Overload List


BeforeLoadRecordEventArgs Properties

The properties of the BeforeLoadRecordEventArgs class are listed below. For a complete list of BeforeLoadRecordEventArgs class members, see the BeforeLoadRecordEventArgs Members topic.

Public Instance Properties

Cancel (inherited from CancelEventArgs) | Gets or sets a value indicating whether the event should be canceled.
Filename |
ID |
LoadType |
Reader |
Row |

See Also

BeforeLoadRecordEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


Filename Property

Aptify 5.0 Software Development Kit (SDK)

BeforeLoadRecordEventArgs.Filename Property

public String Filename {get;}

See Also

BeforeLoadRecordEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

BeforeLoadRecordEventArgs.ID Property

public Int64 ID {get;}

See Also

BeforeLoadRecordEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


LoadType Property

Aptify 5.0 Software Development Kit (SDK)

BeforeLoadRecordEventArgs.LoadType Property

public BeforeLoadRecordEventArgs.LoadRecordEventLoadType LoadType {get;}

See Also

BeforeLoadRecordEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


Reader Property

Aptify 5.0 Software Development Kit (SDK)

BeforeLoadRecordEventArgs.Reader Property

public IDataReader Reader {get;}

See Also

BeforeLoadRecordEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


Row Property

Aptify 5.0 Software Development Kit (SDK)

BeforeLoadRecordEventArgs.Row Property

public DataRow Row {get;}

See Also

BeforeLoadRecordEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


BeforeLoadRecordEventArgs.LoadRecordEventLoadType Enumeration

public enum BeforeLoadRecordEventArgs.LoadRecordEventLoadType

Members

Member Name | Description
ID |
Filename |
Row |
Reader |

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

Aptify.Framework.BusinessLogic.GenericEntity Namespace


BeforeSaveRecordEventArgs Class

Holds the Event arguments for the BeforeSaveRecord Event in the AptifyGenericEntityBase class

For a list of all members of this type, see BeforeSaveRecordEventArgs Members.

System.Object
EventArgs
CancelEventArgs
BeforeSaveRecordEventArgs

public class BeforeSaveRecordEventArgs : CancelEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

BeforeSaveRecordEventArgs Members | Aptify.Framework.BusinessLogic.GenericEntity Namespace


BeforeSaveRecordEventArgs Members

BeforeSaveRecordEventArgs overview

Public Instance Constructors

BeforeSaveRecordEventArgs Constructor

Public Instance Properties

AllowGUI |
Cancel (inherited from CancelEventArgs) | Gets or sets a value indicating whether the event should be canceled.
ErrorString |
TransactionID |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BeforeSaveRecordEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


BeforeSaveRecordEventArgs Constructor

public BeforeSaveRecordEventArgs(
Boolean AllowGUI,
String ErrorString,
String TransactionID
);

See Also

BeforeSaveRecordEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


BeforeSaveRecordEventArgs Properties

The properties of the BeforeSaveRecordEventArgs class are listed below. For a complete list of BeforeSaveRecordEventArgs class members, see the BeforeSaveRecordEventArgs Members topic.

Public Instance Properties

AllowGUI |
Cancel (inherited from CancelEventArgs) | Gets or sets a value indicating whether the event should be canceled.
ErrorString |
TransactionID |

See Also

BeforeSaveRecordEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


AllowGUI Property

Aptify 5.0 Software Development Kit (SDK)

BeforeSaveRecordEventArgs.AllowGUI Property

public Boolean AllowGUI {get;}

See Also

BeforeSaveRecordEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ErrorString Property

Aptify 5.0 Software Development Kit (SDK)

BeforeSaveRecordEventArgs.ErrorString Property

public String ErrorString {get;}

See Also

BeforeSaveRecordEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


TransactionID Property

Aptify 5.0 Software Development Kit (SDK)

BeforeSaveRecordEventArgs.TransactionID Property

public String TransactionID {get;}

See Also

BeforeSaveRecordEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


BeforeSubTypeItemAddEventArgs Class

Holds the Event arguments for the BeforeItemAdd Event in the AptifySubTypeBase class

For a list of all members of this type, see BeforeSubTypeItemAddEventArgs Members.

System.Object
EventArgs
CancelEventArgs
BeforeSubTypeItemAddEventArgs

public class BeforeSubTypeItemAddEventArgs : CancelEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

BeforeSubTypeItemAddEventArgs Members | Aptify.Framework.BusinessLogic.GenericEntity Namespace


BeforeSubTypeItemAddEventArgs Members

BeforeSubTypeItemAddEventArgs overview

Public Instance Constructors

BeforeSubTypeItemAddEventArgs Constructor

Public Instance Properties

Cancel (inherited from CancelEventArgs) | Gets or sets a value indicating whether the event should be canceled.
geToAdd | Contains a reference to the AptifyGenericEntityBase object that will be added to the Sub-Type if the operation is successful.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BeforeSubTypeItemAddEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


BeforeSubTypeItemAddEventArgs Constructor

public BeforeSubTypeItemAddEventArgs(
AptifyGenericEntityBase geToAdd
);

See Also

BeforeSubTypeItemAddEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


BeforeSubTypeItemAddEventArgs Properties

The properties of the BeforeSubTypeItemAddEventArgs class are listed below. For a complete list of BeforeSubTypeItemAddEventArgs class members, see the BeforeSubTypeItemAddEventArgs Members topic.

Public Instance Properties

Cancel (inherited from CancelEventArgs) | Gets or sets a value indicating whether the event should be canceled.
geToAdd | Contains a reference to the AptifyGenericEntityBase object that will be added to the Sub-Type if the operation is successful.

See Also

BeforeSubTypeItemAddEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


geToAdd Property

Aptify 5.0 Software Development Kit (SDK)

BeforeSubTypeItemAddEventArgs.geToAdd Property

Contains a reference to the AptifyGenericEntityBase object that will be added to the Sub-Type if the operation is successful.

public AptifyGenericEntityBase geToAdd {get;}

Property Value

Remarks

See Also

BeforeSubTypeItemAddEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


BeforeSubTypeItemRemoveEventArgs Class

Holds the Event arguments for the BeforeItemRemove Event in the AptifySubTypeBase class

For a list of all members of this type, see BeforeSubTypeItemRemoveEventArgs Members.

System.Object
EventArgs
CancelEventArgs
BeforeSubTypeItemRemoveEventArgs

public class BeforeSubTypeItemRemoveEventArgs : CancelEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

BeforeSubTypeItemRemoveEventArgs Members | Aptify.Framework.BusinessLogic.GenericEntity Namespace


BeforeSubTypeItemRemoveEventArgs Members

BeforeSubTypeItemRemoveEventArgs overview

Public Instance Constructors

BeforeSubTypeItemRemoveEventArgs Constructor

Public Instance Properties

Cancel (inherited from CancelEventArgs) | Gets or sets a value indicating whether the event should be canceled.
geToRemove | Contains a reference to the AptifyGenericEntityBase object that will be removed from the Sub-Type if the operation is successful.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BeforeSubTypeItemRemoveEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


BeforeSubTypeItemRemoveEventArgs Constructor

public BeforeSubTypeItemRemoveEventArgs(
AptifyGenericEntityBase geToRemove
);

See Also

BeforeSubTypeItemRemoveEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


BeforeSubTypeItemRemoveEventArgs Properties

The properties of the BeforeSubTypeItemRemoveEventArgs class are listed below. For a complete list of BeforeSubTypeItemRemoveEventArgs class members, see the BeforeSubTypeItemRemoveEventArgs Members topic.

Public Instance Properties

Cancel (inherited from CancelEventArgs) | Gets or sets a value indicating whether the event should be canceled.
geToRemove | Contains a reference to the AptifyGenericEntityBase object that will be removed from the Sub-Type if the operation is successful.

See Also

BeforeSubTypeItemRemoveEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


geToRemove Property

Aptify 5.0 Software Development Kit (SDK)

BeforeSubTypeItemRemoveEventArgs.geToRemove Property

Contains a reference to the AptifyGenericEntityBase object that will be removed from the Sub-Type if the operation is successful.

public AptifyGenericEntityBase geToRemove {get;}

Property Value

Remarks

See Also

BeforeSubTypeItemRemoveEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


BeforeValidateRecordEventArgs Class

Holds the Event arguments for the BeforeValidateRecord Event in the AptifyGenericEntityBase class

For a list of all members of this type, see BeforeValidateRecordEventArgs Members.

System.Object
EventArgs
CancelEventArgs
BeforeValidateRecordEventArgs

public class BeforeValidateRecordEventArgs : CancelEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

BeforeValidateRecordEventArgs Members | Aptify.Framework.BusinessLogic.GenericEntity Namespace


BeforeValidateRecordEventArgs Members

BeforeValidateRecordEventArgs overview

Public Instance Constructors

BeforeValidateRecordEventArgs Constructor

Public Instance Properties

Cancel (inherited from CancelEventArgs) | Gets or sets a value indicating whether the event should be canceled.
ErrorString | Used to pass an error into the Validate routine. If m_sError is not an empty string, the Validate routine will fail and the Generic Entity's LastError property will return the ErrorString.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BeforeValidateRecordEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


BeforeValidateRecordEventArgs Constructor

public BeforeValidateRecordEventArgs(
String ErrorString
);

See Also

BeforeValidateRecordEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


BeforeValidateRecordEventArgs Properties

The properties of the BeforeValidateRecordEventArgs class are listed below. For a complete list of BeforeValidateRecordEventArgs class members, see the BeforeValidateRecordEventArgs Members topic.

Public Instance Properties

Cancel (inherited from CancelEventArgs) | Gets or sets a value indicating whether the event should be canceled.
ErrorString | Used to pass an error into the Validate routine. If m_sError is not an empty string, the Validate routine will fail and the Generic Entity's LastError property will return the ErrorString.

See Also

BeforeValidateRecordEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ErrorString Property

Aptify 5.0 Software Development Kit (SDK)

BeforeValidateRecordEventArgs.ErrorString Property

Used to pass an error into the Validate routine. If m_sError is not an empty string, the Validate routine will fail and the Generic Entity's LastError property will return the ErrorString.

public String ErrorString {get; set;}

Property Value

Remarks

See Also

BeforeValidateRecordEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


BeforeValueChangedEventArgs Class

Holds the Event arguments for the BeforeValueChanged Event in the AptifyDataFieldBase class

For a list of all members of this type, see BeforeValueChangedEventArgs Members.

System.Object
EventArgs
CancelEventArgs
BeforeValueChangedEventArgs

public class BeforeValueChangedEventArgs : CancelEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

BeforeValueChangedEventArgs Members | Aptify.Framework.BusinessLogic.GenericEntity Namespace


BeforeValueChangedEventArgs Members

BeforeValueChangedEventArgs overview

Public Instance Constructors

BeforeValueChangedEventArgs Constructor

Public Instance Properties

Cancel (inherited from CancelEventArgs) | Gets or sets a value indicating whether the event should be canceled.
FieldName | Represents the name of the Data Field being changed. If this is a field from an embedded object, the parent object's Embedded Link Name with a dot will be prefixed to the field name.
NewValue | Represents the value that will apply to the Data Field if the change is allowed and successful.
OldValue | Represents the value of the Data Field prior to any change.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BeforeValueChangedEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


BeforeValueChangedEventArgs Constructor

public BeforeValueChangedEventArgs(
String FieldName,
Object OldValue,
Object NewValue
);

See Also

BeforeValueChangedEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


BeforeValueChangedEventArgs Properties

The properties of the BeforeValueChangedEventArgs class are listed below. For a complete list of BeforeValueChangedEventArgs class members, see the BeforeValueChangedEventArgs Members topic.

Public Instance Properties

Cancel (inherited from CancelEventArgs) | Gets or sets a value indicating whether the event should be canceled.
FieldName | Represents the name of the Data Field being changed. If this is a field from an embedded object, the parent object's Embedded Link Name with a dot will be prefixed to the field name.
NewValue | Represents the value that will apply to the Data Field if the change is allowed and successful.
OldValue | Represents the value of the Data Field prior to any change.

See Also

BeforeValueChangedEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


FieldName Property

Aptify 5.0 Software Development Kit (SDK)

BeforeValueChangedEventArgs.FieldName Property

Represents the name of the Data Field being changed. If this is a field from an embedded object, the parent object's Embedded Link Name with a dot will be prefixed to the field name.

public String FieldName {get;}

Property Value

Remarks

See Also

BeforeValueChangedEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


NewValue Property

Aptify 5.0 Software Development Kit (SDK)

BeforeValueChangedEventArgs.NewValue Property

Represents the value that will apply to the Data Field if the change is allowed and successful.

public Object NewValue {get; set;}

Property Value

Remarks

See Also

BeforeValueChangedEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


OldValue Property

Aptify 5.0 Software Development Kit (SDK)

BeforeValueChangedEventArgs.OldValue Property

Represents the value of the Data Field prior to any change.

public Object OldValue {get;}

Property Value

Remarks

See Also

BeforeValueChangedEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ClassNameInfo Class

For a list of all members of this type, see ClassNameInfo Members.

System.Object
ClassNameInfo

public class ClassNameInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: GESubClassGenerator (in GESubClassGenerator.dll)

See Also

ClassNameInfo Members | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ClassNameInfo Members

ClassNameInfo overview

Public Instance Constructors

ClassNameInfo Constructor Initializes a new instance of the ClassNameInfo class.

Public Instance Fields

ClassName
EntityName

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ClassNameInfo Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ClassNameInfo Constructor

Initializes a new instance of the ClassNameInfo class.

public ClassNameInfo();

See Also

ClassNameInfo Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ClassNameInfo Fields

The fields of the ClassNameInfo class are listed below. For a complete list of ClassNameInfo class members, see the ClassNameInfo Members topic.

Public Instance Fields

ClassName
EntityName

See Also

ClassNameInfo Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ClassNameInfo.ClassName Field

public ClassName ClassName;

See Also

ClassNameInfo Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ClassNameInfo.EntityName Field

public EntityName EntityName;

See Also

ClassNameInfo Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


DataLocation Structure

For a list of all members of this type, see DataLocation Members.

System.Object
ValueType
DataLocation

public struct DataLocation

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

DataLocation Members | Aptify.Framework.BusinessLogic.GenericEntity Namespace


DataLocation Members

DataLocation overview

Public Instance Fields

Database
Server

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

DataLocation Structure | Aptify.Framework.BusinessLogic.GenericEntity Namespace


DataLocation Fields

The fields of the DataLocation structure are listed below. For a complete list of DataLocation structure members, see the DataLocation Members topic.

Public Instance Fields

Database
Server

See Also

DataLocation Structure | Aptify.Framework.BusinessLogic.GenericEntity Namespace


DataLocation.Database Field

public Database Database;

See Also

DataLocation Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


DataLocation.Server Field

public Server Server;

See Also

DataLocation Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


DuplicateCheckMessageAction Enumeration

public enum DuplicateCheckMessageAction

Members

Member Name | Description
IgnoreDuplicates |
ViewDuplicates |
CancelSave |

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

Aptify.Framework.BusinessLogic.GenericEntity Namespace


DuplicateCheckResult Enumeration

public enum DuplicateCheckResult

Members

Member Name | Description
None |
Potential |
Exact |

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

Aptify.Framework.BusinessLogic.GenericEntity Namespace


DuplicateMessageForm Class

For a list of all members of this type, see DuplicateMessageForm Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
DuplicateMessageForm

public class DuplicateMessageForm : Form

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntity (in AptifyGenericEntity.dll)

See Also

DuplicateMessageForm Members | Aptify.Framework.BusinessLogic.GenericEntity Namespace


DuplicateMessageForm Members

DuplicateMessageForm overview

Public Instance Constructors

DuplicateMessageForm Constructor Initializes a new instance of the DuplicateMessageForm class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
DuplicateAction |
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

DuplicateMessageForm Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


DuplicateMessageForm Constructor

Initializes a new instance of the DuplicateMessageForm class.

public DuplicateMessageForm();

See Also

DuplicateMessageForm Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


DuplicateMessageForm Properties

The properties of the DuplicateMessageForm class are listed below. For a complete list of DuplicateMessageForm class members, see the DuplicateMessageForm Members topic.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
DuplicateAction |
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

DuplicateMessageForm Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


DuplicateAction Property

Aptify 5.0 Software Development Kit (SDK)

DuplicateMessageForm.DuplicateAction Property

public DuplicateCheckMessageAction DuplicateAction {get;}

See Also

DuplicateMessageForm Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


DuplicateMessageForm Methods

The methods of the DuplicateMessageForm class are listed below. For a complete list of DuplicateMessageForm class members, see the DuplicateMessageForm Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

DuplicateMessageForm Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


DuplicateMessageForm.Config Method

public void Config(
String Message,
String EntityDisplayName
);

See Also

DuplicateMessageForm Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

DuplicateMessageForm.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

DuplicateMessageForm Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


DuplicateMessageForm.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

DuplicateMessageForm Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | DuplicateMessageForm.Dispose Overload List


EntityDependant Class

An object that represents a single dependent entity.

For a list of all members of this type, see EntityDependant Members.

System.Object
EntityDependant

public class EntityDependant

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

This is not intended to be called from directly. It is returned as part of an Entity Dependencies collection. That collection is returned from calls in the AptifyApplication object.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

EntityDependant Members | Aptify.Framework.BusinessLogic.GenericEntity Namespace


EntityDependant Members

EntityDependant overview

Public Instance Constructors

EntityDependant Overloaded. Initializes a new instance of the EntityDependant class.

Public Instance Properties

Entity | Name of the entity.
EntityDependencies | A collection of EntityDependent objects; children of the current object.
EntityDisplayName | Name visible to the user.
Field | Name of the field.
FieldDisplayName | Display name of the field; the visible description for the user.
RecordID | Primary key of the record.
SubType | Name of the SubType.
SubTypeDisplayName | Visible name to the user for the sub type.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EntityDependant Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


EntityDependant Constructor

Initializes a new instance of the EntityDependant class.

Overload List

Initializes a new instance of the EntityDependant class.

public EntityDependant();

public EntityDependant(String,String,String,String,String,String,Int64);

public EntityDependant(String,String,String,String,String,String,Int64,EntityDependenciesBase);

See Also

EntityDependant Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


EntityDependant Constructor ()

Initializes a new instance of the EntityDependant class.

public EntityDependant();

See Also

EntityDependant Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | EntityDependant Constructor Overload List


EntityDependant Constructor (String, String, String, String, String, String, Int64)

public EntityDependant(
String Entity,
String EntityDisplayName,
String SubType,
String SubTypeDisplayName,
String Field,
String FieldDisplayName,
Int64 RecordID
);

See Also

EntityDependant Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | EntityDependant Constructor Overload List


EntityDependant Constructor (String, String, String, String, String, String, Int64, EntityDependenciesBase)

public EntityDependant(
String Entity,
String EntityDisplayName,
String SubType,
String SubTypeDisplayName,
String Field,
String FieldDisplayName,
Int64 RecordID,
EntityDependenciesBase EntityDependencies
);

See Also

EntityDependant Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | EntityDependant Constructor Overload List


EntityDependant Properties

The properties of the EntityDependant class are listed below. For a complete list of EntityDependant class members, see the EntityDependant Members topic.

Public Instance Properties

Entity | Name of the entity.
EntityDependencies | A collection of EntityDependent objects; children of the current object.
EntityDisplayName | Name visible to the user.
Field | Name of the field.
FieldDisplayName | Display name of the field; the visible description for the user.
RecordID | Primary key of the record.
SubType | Name of the SubType.
SubTypeDisplayName | Visible name to the user for the sub type.

See Also

EntityDependant Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


Entity Property

Aptify 5.0 Software Development Kit (SDK)

EntityDependant.Entity Property

Name of the entity.

public String Entity {get;}

Remarks

See Also

EntityDependant Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


EntityDependencies Property

Aptify 5.0 Software Development Kit (SDK)

EntityDependant.EntityDependencies Property

A collection of EntityDependent objects; children of the current object.

public EntityDependenciesBase EntityDependencies {get;}

Remarks

See Also

EntityDependant Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


EntityDisplayName Property

Aptify 5.0 Software Development Kit (SDK)

EntityDependant.EntityDisplayName Property

Name visible to the user.

public String EntityDisplayName {get;}

Remarks

See Also

EntityDependant Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


Field Property

Aptify 5.0 Software Development Kit (SDK)

EntityDependant.Field Property

Name of the field.

public String Field {get;}

Property Value

Remarks

See Also

EntityDependant Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


FieldDisplayName Property

Aptify 5.0 Software Development Kit (SDK)

EntityDependant.FieldDisplayName Property

Display name of the field; the visible description for the user.

public String FieldDisplayName {get;}

Remarks

See Also

EntityDependant Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


RecordID Property

Aptify 5.0 Software Development Kit (SDK)

EntityDependant.RecordID Property

Primary key of the record.

public Int64 RecordID {get;}

Remarks

See Also

EntityDependant Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


SubType Property

Aptify 5.0 Software Development Kit (SDK)

EntityDependant.SubType Property

Name of the SubType.

public String SubType {get;}

Remarks

See Also

EntityDependant Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


SubTypeDisplayName Property

Aptify 5.0 Software Development Kit (SDK)

EntityDependant.SubTypeDisplayName Property

Visible name to the user for the sub type.

public String SubTypeDisplayName {get;}

Remarks

See Also

EntityDependant Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


EntityDependenciesBase Class

For a list of all members of this type, see EntityDependenciesBase Members.

System.Object
NameObjectCollectionBase
AptifyCollection
EntityDependenciesBase
EntityDependencies

public class EntityDependenciesBase : AptifyCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

EntityDependenciesBase Members | Aptify.Framework.BusinessLogic.GenericEntity Namespace


EntityDependenciesBase Members

EntityDependenciesBase overview

Public Instance Constructors

EntityDependenciesBase Constructor Initializes a new instance of the EntityDependenciesBase class.

Public Instance Properties

Count (inherited from NameObjectCollectionBase) | Gets the number of key/value pairs contained in the NameObjectCollectionBase instance.
Entity |
ExistenceCheck |
ForeignKeysExcluded |
Item | Overloaded.
Keys (inherited from NameObjectCollectionBase) | Gets a KeysCollection instance that contains all the keys in the NameObjectCollectionBase instance.
RecordID |

Public Instance Methods

Add | Overloaded.
Clear (inherited from AptifyCollection) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from AptifyCollection) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from NameObjectCollectionBase) | Implements the ISerializable interface and returns the data needed to serialize the NameObjectCollectionBase instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from AptifyCollection) | Gets the index of the item with the specified Key.
Merge (inherited from AptifyCollection) | Allows a user to merge items from another collection to this collection.
OnDeserialization (inherited from NameObjectCollectionBase) | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete.
Remove (inherited from AptifyCollection) | Overloaded.
RemoveAt (inherited from AptifyCollection) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

IsReadOnly (inherited from NameObjectCollectionBase) Gets or sets a value indicating whether the NameObjectCollectionBase instance is read-only.

Protected Instance Methods

BaseAdd (inherited from NameObjectCollectionBase) | Adds an entry with the specified key and value into the NameObjectCollectionBase instance.
BaseClear (inherited from NameObjectCollectionBase) | Removes all entries from the NameObjectCollectionBase instance.
BaseGet (inherited from NameObjectCollectionBase) | Overloaded. Gets the value of the first entry with the specified key from the NameObjectCollectionBase instance.
BaseGetAllKeys (inherited from NameObjectCollectionBase) | Returns a String array that contains all the keys in the NameObjectCollectionBase instance.
BaseGetAllValues (inherited from NameObjectCollectionBase) | Overloaded. Returns an Object array that contains all the values in the NameObjectCollectionBase instance.
BaseGetKey (inherited from NameObjectCollectionBase) | Gets the key of the entry at the specified index of the NameObjectCollectionBase instance.
BaseHasKeys (inherited from NameObjectCollectionBase) | Gets a value indicating whether the NameObjectCollectionBase instance contains entries whose keys are not null.
BaseRemove (inherited from NameObjectCollectionBase) | Removes the entries with the specified key from the NameObjectCollectionBase instance.
BaseRemoveAt (inherited from NameObjectCollectionBase) | Removes the entry at the specified index of the NameObjectCollectionBase instance.
BaseSet (inherited from NameObjectCollectionBase) | Overloaded. Sets the value of the first entry with the specified key in the NameObjectCollectionBase instance, if found; otherwise, adds an entry with the specified key and value into the NameObjectCollectionBase instance.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EntityDependenciesBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


EntityDependenciesBase Constructor

Initializes a new instance of the EntityDependenciesBase class.

public EntityDependenciesBase();

See Also

EntityDependenciesBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


EntityDependenciesBase Properties

The properties of the EntityDependenciesBase class are listed below. For a complete list of EntityDependenciesBase class members, see the EntityDependenciesBase Members topic.

Public Instance Properties

Count (inherited from NameObjectCollectionBase) | Gets the number of key/value pairs contained in the NameObjectCollectionBase instance.
Entity |
ExistenceCheck |
ForeignKeysExcluded |
Item | Overloaded.
Keys (inherited from NameObjectCollectionBase) | Gets a KeysCollection instance that contains all the keys in the NameObjectCollectionBase instance.
RecordID |

Protected Instance Properties

IsReadOnly (inherited from NameObjectCollectionBase) Gets or sets a value indicating whether the NameObjectCollectionBase instance is read-only.

See Also

EntityDependenciesBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


Entity Property

Aptify 5.0 Software Development Kit (SDK)

EntityDependenciesBase.Entity Property

public abstract String Entity {get;}

See Also

EntityDependenciesBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ExistenceCheck Property

Aptify 5.0 Software Development Kit (SDK)

EntityDependenciesBase.ExistenceCheck Property

public abstract Boolean ExistenceCheck {get;}

See Also

EntityDependenciesBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ForeignKeysExcluded Property

Aptify 5.0 Software Development Kit (SDK)

EntityDependenciesBase.ForeignKeysExcluded Property

public abstract Boolean ForeignKeysExcluded {get;}

See Also

EntityDependenciesBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


EntityDependant Property

Aptify 5.0 Software Development Kit (SDK)

EntityDependenciesBase.EntityDependant Property

Overload List

public EntityDependant this[Int32] {get; set;}

public EntityDependant this[String] {get; set;}

See Also

EntityDependenciesBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


Item Property (Int32)

Aptify 5.0 Software Development Kit (SDK)

EntityDependenciesBase.Item Property (Int32)

public EntityDependant this[
Int32 Index
] {get; set;}

See Also

EntityDependenciesBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | EntityDependenciesBase.EntityDependant Overload List


Item Property (String)

Aptify 5.0 Software Development Kit (SDK)

EntityDependenciesBase.Item Property (String)

public EntityDependant this[
String Key
] {get; set;}

See Also

EntityDependenciesBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | EntityDependenciesBase.EntityDependant Overload List


RecordID Property

Aptify 5.0 Software Development Kit (SDK)

EntityDependenciesBase.RecordID Property

public abstract Int64 RecordID {get;}

See Also

EntityDependenciesBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


EntityDependenciesBase Methods

The methods of the EntityDependenciesBase class are listed below. For a complete list of EntityDependenciesBase class members, see the EntityDependenciesBase Members topic.

Public Instance Methods

Add | Overloaded.
Clear (inherited from AptifyCollection) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from AptifyCollection) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from NameObjectCollectionBase) | Implements the ISerializable interface and returns the data needed to serialize the NameObjectCollectionBase instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from AptifyCollection) | Gets the index of the item with the specified Key.
Merge (inherited from AptifyCollection) | Allows a user to merge items from another collection to this collection.
OnDeserialization (inherited from NameObjectCollectionBase) | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete.
Remove (inherited from AptifyCollection) | Overloaded.
RemoveAt (inherited from AptifyCollection) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

BaseAdd (inherited from NameObjectCollectionBase) | Adds an entry with the specified key and value into the NameObjectCollectionBase instance.
BaseClear (inherited from NameObjectCollectionBase) | Removes all entries from the NameObjectCollectionBase instance.
BaseGet (inherited from NameObjectCollectionBase) | Overloaded. Gets the value of the first entry with the specified key from the NameObjectCollectionBase instance.
BaseGetAllKeys (inherited from NameObjectCollectionBase) | Returns a String array that contains all the keys in the NameObjectCollectionBase instance.
BaseGetAllValues (inherited from NameObjectCollectionBase) | Overloaded. Returns an Object array that contains all the values in the NameObjectCollectionBase instance.
BaseGetKey (inherited from NameObjectCollectionBase) | Gets the key of the entry at the specified index of the NameObjectCollectionBase instance.
BaseHasKeys (inherited from NameObjectCollectionBase) | Gets a value indicating whether the NameObjectCollectionBase instance contains entries whose keys are not null.
BaseRemove (inherited from NameObjectCollectionBase) | Removes the entries with the specified key from the NameObjectCollectionBase instance.
BaseRemoveAt (inherited from NameObjectCollectionBase) | Removes the entry at the specified index of the NameObjectCollectionBase instance.
BaseSet (inherited from NameObjectCollectionBase) | Overloaded. Sets the value of the first entry with the specified key in the NameObjectCollectionBase instance, if found; otherwise, adds an entry with the specified key and value into the NameObjectCollectionBase instance.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EntityDependenciesBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


Add Method

Aptify 5.0 Software Development Kit (SDK)

EntityDependenciesBase.Add Method

Overload List

public int Add(EntityDependant);

public int Add(EntityDependant,String);

public override int Add(Object);

public override int Add(Object,String);

public int Add(String,String,String,String,String,String,Int64);

public int Add(String,String,String,String,String,String,Int64,EntityDependenciesBase);

public int Add(String,String,String,String,String,String,Int64,EntityDependenciesBase,String);

public int Add(String,String,String,String,String,String,Int64,String);

See Also

EntityDependenciesBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


EntityDependenciesBase.Add Method (EntityDependant)

public int Add(
EntityDependant Value
);

See Also

EntityDependenciesBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | EntityDependenciesBase.Add Overload List


EntityDependenciesBase.Add Method (EntityDependant, String)

public int Add(
EntityDependant Value,
String Key
);

See Also

EntityDependenciesBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | EntityDependenciesBase.Add Overload List


EntityDependenciesBase.Add Method (Object)

public override int Add(
Object Value
);

See Also

EntityDependenciesBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | EntityDependenciesBase.Add Overload List


EntityDependenciesBase.Add Method (Object, String)

public override int Add(
Object Value,
String Key
);

See Also

EntityDependenciesBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | EntityDependenciesBase.Add Overload List


EntityDependenciesBase.Add Method (String, String, String, String, String, String, Int64)

public int Add(
String Entity,
String EntityDisplayName,
String SubType,
String SubTypeDisplayName,
String Field,
String FieldDisplayName,
Int64 RecordID
);

See Also

EntityDependenciesBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | EntityDependenciesBase.Add Overload List


EntityDependenciesBase.Add Method (String, String, String, String, String, String, Int64, EntityDependenciesBase)

public int Add(
String Entity,
String EntityDisplayName,
String SubType,
String SubTypeDisplayName,
String Field,
String FieldDisplayName,
Int64 RecordID,
EntityDependenciesBase EntityDependencies
);

See Also

EntityDependenciesBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | EntityDependenciesBase.Add Overload List


EntityDependenciesBase.Add Method (String, String, String, String, String, String, Int64, EntityDependenciesBase, String)

public int Add(
String Entity,
String EntityDisplayName,
String SubType,
String SubTypeDisplayName,
String Field,
String FieldDisplayName,
Int64 RecordID,
EntityDependenciesBase EntityDependencies,
String Key
);

See Also

EntityDependenciesBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | EntityDependenciesBase.Add Overload List


EntityDependenciesBase.Add Method (String, String, String, String, String, String, Int64, String)

public int Add(
String Entity,
String EntityDisplayName,
String SubType,
String SubTypeDisplayName,
String Field,
String FieldDisplayName,
Int64 RecordID,
String Key
);

See Also

EntityDependenciesBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | EntityDependenciesBase.Add Overload List


ExtenderInstance Class

Extends the functionality of ExtenderInstanceBase providing implementations for the required MustOverride methods of the base class.

For a list of all members of this type, see ExtenderInstance Members.

System.Object
ExtenderInstanceBase
ExtenderInstance

public class ExtenderInstance : ExtenderInstanceBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntity (in AptifyGenericEntity.dll)

See Also

ExtenderInstance Members | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ExtenderInstance Members

ExtenderInstance overview

Public Instance Constructors

ExtenderInstance Constructor

Public Instance Properties

DataAction |
ExtenderEntityLevelMetaData |
ExtenderGE (inherited from ExtenderInstanceBase) | Returns the Extender GE
ExtenderGELoaded (inherited from ExtenderInstanceBase) | This property will return True if the extender GE is loaded, False otherwise. It is important to check this property to determine if the ExtenderGE is in place as this class will automatically load the ExtenderGE on demand the first time the ExtenderGE property is accessed. This property will NOT load the ExtenderGE, rather it simply returns whether or not the ExtenderGE is currently loaded at the time of the call.
Metadata (inherited from ExtenderInstanceBase) |
ParentGE (inherited from ExtenderInstanceBase) | Returns the Parent GE
UserCredential (inherited from ExtenderInstanceBase) |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetExtenderRecordID (inherited from ExtenderInstanceBase) | This method will determine if there is a record in the database for the extender entity that maps to the ParentGE. If so, the record ID is returned, otherwise, -1 is returned.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SaveExtenderObject (inherited from ExtenderInstanceBase) | Overloaded. This method will save the extender object within the instance. Also, if necessary, a new instance will be created for either an existing record that was not previously loaded,
ShouldHaveExtenderGE (inherited from ExtenderInstanceBase) | This method returns True if the ExtenderGE should exist in the context of the Parent GE. If the ExtenderType is Required, then the result of this property will always be true. If the ExtenderType is Optional, then the result of this property will be based on the execution of the FilterRule associated with the Extender definition.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

ExecuteFilterRule |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetDataRowFromGE | This is a utility method that will take all of the values from the GE and put them into a data row. This is useful for interaction with the Filter Rules engine and other places where data rows are helpful
GetExtenderGE | Overloaded. This method will return an extender GE instance for the current meta-data and parent GE record. The method will determine if an existing record is in the database that is linked to the parent GE, and if so, will load it. Otherwise, a new record instance of the extender GE entity will be returned
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExtenderInstance Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ExtenderInstance Constructor

public ExtenderInstance(
AptifyGenericEntityBase ExtenderGE,
AptifyGenericEntityBase ParentGE,
ExtenderEntityMetaData MetaData
);

See Also

ExtenderInstance Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ExtenderInstance Properties

The properties of the ExtenderInstance class are listed below. For a complete list of ExtenderInstance class members, see the ExtenderInstance Members topic.

Public Instance Properties

DataAction |
ExtenderEntityLevelMetaData |
ExtenderGE (inherited from ExtenderInstanceBase) | Returns the Extender GE
ExtenderGELoaded (inherited from ExtenderInstanceBase) | This property will return True if the extender GE is loaded, False otherwise. It is important to check this property to determine if the ExtenderGE is in place as this class will automatically load the ExtenderGE on demand the first time the ExtenderGE property is accessed. This property will NOT load the ExtenderGE, rather it simply returns whether or not the ExtenderGE is currently loaded at the time of the call.
Metadata (inherited from ExtenderInstanceBase) |
ParentGE (inherited from ExtenderInstanceBase) | Returns the Parent GE
UserCredential (inherited from ExtenderInstanceBase) |

See Also

ExtenderInstance Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


DataAction Property

Aptify 5.0 Software Development Kit (SDK)

ExtenderInstance.DataAction Property

public override IAptifyDataAction DataAction {get;}

See Also

ExtenderInstance Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ExtenderEntityLevelMetaData Property

Aptify 5.0 Software Development Kit (SDK)

ExtenderInstance.ExtenderEntityLevelMetaData Property

public override EntityLevelMetaData ExtenderEntityLevelMetaData {get;}

See Also

ExtenderInstance Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ExtenderInstance Methods

The methods of the ExtenderInstance class are listed below. For a complete list of ExtenderInstance class members, see the ExtenderInstance Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetExtenderRecordID (inherited from ExtenderInstanceBase) | This method will determine if there is a record in the database for the extender entity that maps to the ParentGE. If so, the record ID is returned, otherwise, -1 is returned.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SaveExtenderObject (inherited from ExtenderInstanceBase) | Overloaded. This method will save the extender object within the instance. Also, if necessary, a new instance will be created for either an existing record that was not previously loaded,
ShouldHaveExtenderGE (inherited from ExtenderInstanceBase) | This method returns True if the ExtenderGE should exist in the context of the Parent GE. If the ExtenderType is Required, then the result of this property will always be true. If the ExtenderType is Optional, then the result of this property will be based on the execution of the FilterRule associated with the Extender definition.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

ExecuteFilterRule |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetDataRowFromGE | This is a utility method that will take all of the values from the GE and put them into a data row. This is useful for interaction with the Filter Rules engine and other places where data rows are helpful
GetExtenderGE | Overloaded. This method will return an extender GE instance for the current meta-data and parent GE record. The method will determine if an existing record is in the database that is linked to the parent GE, and if so, will load it. Otherwise, a new record instance of the extender GE entity will be returned
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExtenderInstance Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ExtenderInstance.ExecuteFilterRule Method

protected override bool ExecuteFilterRule();

See Also

ExtenderInstance Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ExtenderInstance.GetDataRowFromGE Method

This is a utility method that will take all of the values from the GE and put them into a data row. This is useful for interaction with the Filter Rules engine and other places where data rows are helpful

protected virtual DataRow GetDataRowFromGE(
AptifyGenericEntityBase GE
);

Return Value

Remarks

See Also

ExtenderInstance Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GetExtenderGE Method

Aptify 5.0 Software Development Kit (SDK)

ExtenderInstance.GetExtenderGE Method

This method will return an extender GE instance for the current meta-data and parent GE record. The method will determine if an existing record is in the database that is linked to the parent GE, and if so, will load it. Otherwise, a new record instance of the extender GE entity will be returned

Overload List

This method will return an extender GE instance for the current meta-data and parent GE record. The method will determine if an existing record is in the database that is linked to the parent GE, and if so, will load it. Otherwise, a new record instance of the extender GE entity will be returned

protected override AptifyGenericEntityBase GetExtenderGE();

This method will return an extender GE instance for the current meta-data and parent GE record. The method will determine if an existing record is in the database that is linked to the parent GE, and if so, will load it. Otherwise, a new record instance of the extender GE entity will be returned. This overload takes in a record ID which is an optimization opportunity if you already know the record ID for the extender entity record. If a value less than 0 is passed in for the ExtenderRecordID parameter, the record ID will be determined by calling GetExtenderRecordID().

protected override AptifyGenericEntityBase GetExtenderGE(Int64);

See Also

ExtenderInstance Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ExtenderInstance.GetExtenderGE Method ()

This method will return an extender GE instance for the current meta-data and parent GE record. The method will determine if an existing record is in the database that is linked to the parent GE, and if so, will load it. Otherwise, a new record instance of the extender GE entity will be returned

protected override AptifyGenericEntityBase GetExtenderGE();

Return Value

Remarks

See Also

ExtenderInstance Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | ExtenderInstance.GetExtenderGE Overload List


ExtenderInstance.GetExtenderGE Method (Int64)

This method will return an extender GE instance for the current meta-data and parent GE record. The method will determine if an existing record is in the database that is linked to the parent GE, and if so, will load it. Otherwise, a new record instance of the extender GE entity will be returned. This overload takes in a record ID which is an optimization opportunity if you already know the record ID for the extender entity record. If a value less than 0 is passed in for the ExtenderRecordID parameter, the record ID will be determined by calling GetExtenderRecordID().

protected override AptifyGenericEntityBase GetExtenderGE(
Int64 ExtenderRecordID
);

Return Value

Remarks

See Also

ExtenderInstance Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | ExtenderInstance.GetExtenderGE Overload List


ExtenderInstanceBase Class

Provides information about an instance of an extender GE.

For a list of all members of this type, see ExtenderInstanceBase Members.

System.Object
ExtenderInstanceBase
ExtenderInstance

public class ExtenderInstanceBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

ExtenderInstanceBase Members | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ExtenderInstanceBase Members

ExtenderInstanceBase overview

Public Instance Constructors

ExtenderInstanceBase Constructor

Public Instance Properties

DataAction |
ExtenderEntityLevelMetaData |
ExtenderGE | Returns the Extender GE
ExtenderGELoaded | This property will return True if the extender GE is loaded, False otherwise. It is important to check this property to determine if the ExtenderGE is in place as this class will automatically load the ExtenderGE on demand the first time the ExtenderGE property is accessed. This property will NOT load the ExtenderGE, rather it simply returns whether or not the ExtenderGE is currently loaded at the time of the call.
Metadata |
ParentGE | Returns the Parent GE
UserCredential |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetExtenderRecordID | This method will determine if there is a record in the database for the extender entity that maps to the ParentGE. If so, the record ID is returned, otherwise, -1 is returned.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SaveExtenderObject | Overloaded. This method will save the extender object within the instance. Also, if necessary, a new instance will be created for either an existing record that was not previously loaded,
ShouldHaveExtenderGE | This method returns True if the ExtenderGE should exist in the context of the Parent GE. If the ExtenderType is Required, then the result of this property will always be true. If the ExtenderType is Optional, then the result of this property will be based on the execution of the FilterRule associated with the Extender definition.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

ExecuteFilterRule |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetExtenderGE | Overloaded.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExtenderInstanceBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ExtenderInstanceBase Constructor

public ExtenderInstanceBase(
AptifyGenericEntityBase ExtenderGE,
AptifyGenericEntityBase ParentGE,
ExtenderEntityMetaData MetaData
);

See Also

ExtenderInstanceBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ExtenderInstanceBase Properties

The properties of the ExtenderInstanceBase class are listed below. For a complete list of ExtenderInstanceBase class members, see the ExtenderInstanceBase Members topic.

Public Instance Properties

DataAction |
ExtenderEntityLevelMetaData |
ExtenderGE | Returns the Extender GE
ExtenderGELoaded | This property will return True if the extender GE is loaded, False otherwise. It is important to check this property to determine if the ExtenderGE is in place as this class will automatically load the ExtenderGE on demand the first time the ExtenderGE property is accessed. This property will NOT load the ExtenderGE, rather it simply returns whether or not the ExtenderGE is currently loaded at the time of the call.
Metadata |
ParentGE | Returns the Parent GE
UserCredential |

See Also

ExtenderInstanceBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


DataAction Property

Aptify 5.0 Software Development Kit (SDK)

ExtenderInstanceBase.DataAction Property

public abstract IAptifyDataAction DataAction {get;}

See Also

ExtenderInstanceBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ExtenderEntityLevelMetaData Property

Aptify 5.0 Software Development Kit (SDK)

ExtenderInstanceBase.ExtenderEntityLevelMetaData Property

public abstract EntityLevelMetaData ExtenderEntityLevelMetaData {get;}

See Also

ExtenderInstanceBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ExtenderGE Property

Aptify 5.0 Software Development Kit (SDK)

ExtenderInstanceBase.ExtenderGE Property

Returns the Extender GE

public virtual AptifyGenericEntityBase ExtenderGE {get;}

Property Value

Remarks

See Also

ExtenderInstanceBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ExtenderGELoaded Property

Aptify 5.0 Software Development Kit (SDK)

ExtenderInstanceBase.ExtenderGELoaded Property

This property will return True if the extender GE is loaded, False otherwise. It is important to check this property to determine if the ExtenderGE is in place as this class will automatically load the ExtenderGE on demand the first time the ExtenderGE property is accessed. This property will NOT load the ExtenderGE, rather it simply returns whether or not the ExtenderGE is currently loaded at the time of the call.

public virtual Boolean ExtenderGELoaded {get;}

Property Value

Remarks

See Also

ExtenderInstanceBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


Metadata Property

Aptify 5.0 Software Development Kit (SDK)

ExtenderInstanceBase.Metadata Property

public virtual ExtenderEntityMetaData Metadata {get;}

See Also

ExtenderInstanceBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ParentGE Property

Aptify 5.0 Software Development Kit (SDK)

ExtenderInstanceBase.ParentGE Property

Returns the Parent GE

public virtual AptifyGenericEntityBase ParentGE {get;}

Property Value

Remarks

See Also

ExtenderInstanceBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


UserCredential Property

Aptify 5.0 Software Development Kit (SDK)

ExtenderInstanceBase.UserCredential Property

public UserCredentials UserCredential {get; set;}

See Also

ExtenderInstanceBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ExtenderInstanceBase Methods

The methods of the ExtenderInstanceBase class are listed below. For a complete list of ExtenderInstanceBase class members, see the ExtenderInstanceBase Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetExtenderRecordID | This method will determine if there is a record in the database for the extender entity that maps to the ParentGE. If so, the record ID is returned, otherwise, -1 is returned.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SaveExtenderObject | Overloaded. This method will save the extender object within the instance. Also, if necessary, a new instance will be created for either an existing record that was not previously loaded,
ShouldHaveExtenderGE | This method returns True if the ExtenderGE should exist in the context of the Parent GE. If the ExtenderType is Required, then the result of this property will always be true. If the ExtenderType is Optional, then the result of this property will be based on the execution of the FilterRule associated with the Extender definition.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

ExecuteFilterRule |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetExtenderGE | Overloaded.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExtenderInstanceBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ExtenderInstanceBase.ExecuteFilterRule Method

protected abstract bool ExecuteFilterRule();

See Also

ExtenderInstanceBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GetExtenderGE Method

Aptify 5.0 Software Development Kit (SDK)

ExtenderInstanceBase.GetExtenderGE Method

Overload List

protected abstract AptifyGenericEntityBase GetExtenderGE();

protected abstract AptifyGenericEntityBase GetExtenderGE(Int64);

See Also

ExtenderInstanceBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ExtenderInstanceBase.GetExtenderGE Method ()

protected abstract AptifyGenericEntityBase GetExtenderGE();

See Also

ExtenderInstanceBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | ExtenderInstanceBase.GetExtenderGE Overload List


ExtenderInstanceBase.GetExtenderGE Method (Int64)

protected abstract AptifyGenericEntityBase GetExtenderGE(
Int64 ExtenderRecordID
);

See Also

ExtenderInstanceBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | ExtenderInstanceBase.GetExtenderGE Overload List


ExtenderInstanceBase.GetExtenderRecordID Method

This method will determine if there is a record in the database for the extender entity that maps to the ParentGE. If so, the record ID is returned, otherwise, -1 is returned.

public virtual long GetExtenderRecordID();

Return Value

Remarks

See Also

ExtenderInstanceBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


SaveExtenderObject Method

Aptify 5.0 Software Development Kit (SDK)

ExtenderInstanceBase.SaveExtenderObject Method

Overload List

public virtual bool SaveExtenderObject();

public virtual bool SaveExtenderObject(Boolean,String);

This method will save the extender object within the instance. Also, if necessary, a new instance will be created for either an existing record that was not previously loaded,

public virtual bool SaveExtenderObject(Boolean,ref String&,String);

public virtual bool SaveExtenderObject(String);

See Also

ExtenderInstanceBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ExtenderInstanceBase.SaveExtenderObject Method ()

public virtual bool SaveExtenderObject();

See Also

ExtenderInstanceBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | ExtenderInstanceBase.SaveExtenderObject Overload List


ExtenderInstanceBase.SaveExtenderObject Method (Boolean, String)

public virtual bool SaveExtenderObject(
Boolean AllowGUI,
String TransactionID
);

See Also

ExtenderInstanceBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | ExtenderInstanceBase.SaveExtenderObject Overload List


ExtenderInstanceBase.SaveExtenderObject Method (Boolean, String&, String)

This method will save the extender object within the instance. Also, if necessary, a new instance will be created for either an existing record that was not previously loaded,

public virtual bool SaveExtenderObject(
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

Parameters

AllowGUI
ErrorString
TransactionID

Remarks

See Also

ExtenderInstanceBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | ExtenderInstanceBase.SaveExtenderObject Overload List


ExtenderInstanceBase.SaveExtenderObject Method (String)

public virtual bool SaveExtenderObject(
String TransactionID
);

See Also

ExtenderInstanceBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | ExtenderInstanceBase.SaveExtenderObject Overload List


ExtenderInstanceBase.ShouldHaveExtenderGE Method

This method returns True if the ExtenderGE should exist in the context of the Parent GE. If the ExtenderType is Required, then the result of this property will always be true. If the ExtenderType is Optional, then the result of this property will be based on the execution of the FilterRule associated with the Extender definition.

public virtual bool ShouldHaveExtenderGE();

Return Value

Remarks

See Also

ExtenderInstanceBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ExtenderObjectList Class

For a list of all members of this type, see ExtenderObjectList Members.

System.Object
ExtenderObjectListBase
ExtenderObjectList

public class ExtenderObjectList : ExtenderObjectListBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntity (in AptifyGenericEntity.dll)

See Also

ExtenderObjectList Members | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ExtenderObjectList Members

ExtenderObjectList overview

Public Instance Constructors

ExtenderObjectList Constructor Initializes a new instance of the ExtenderObjectList class.

Public Instance Properties

Count (inherited from ExtenderObjectListBase)
Item (inherited from ExtenderObjectListBase)
Item (inherited from ExtenderObjectListBase)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

List (inherited from ExtenderObjectListBase)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

DoAdd (inherited from ExtenderObjectListBase)
DoClear (inherited from ExtenderObjectListBase)
DoRemove (inherited from ExtenderObjectListBase)

See Also

ExtenderObjectList Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ExtenderObjectList Constructor

Initializes a new instance of the ExtenderObjectList class.

public ExtenderObjectList();

See Also

ExtenderObjectList Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ExtenderObjectListBase Class

For a list of all members of this type, see ExtenderObjectListBase Members.

System.Object
ExtenderObjectListBase
ExtenderObjectList

public class ExtenderObjectListBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

ExtenderObjectListBase Members | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ExtenderObjectListBase Members

ExtenderObjectListBase overview

Public Instance Constructors

ExtenderObjectListBase Constructor Initializes a new instance of the ExtenderObjectListBase class.

Public Instance Properties

Count |
Item | Overloaded.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

List

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

DoAdd
DoClear
DoRemove

See Also

ExtenderObjectListBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ExtenderObjectListBase Constructor

Initializes a new instance of the ExtenderObjectListBase class.

public ExtenderObjectListBase();

See Also

ExtenderObjectListBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ExtenderObjectListBase Properties

The properties of the ExtenderObjectListBase class are listed below. For a complete list of ExtenderObjectListBase class members, see the ExtenderObjectListBase Members topic.

Public Instance Properties

Count |
Item | Overloaded.

Protected Instance Properties

List

See Also

ExtenderObjectListBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


Count Property

Aptify 5.0 Software Development Kit (SDK)

ExtenderObjectListBase.Count Property

public virtual Int64 Count {get;}

See Also

ExtenderObjectListBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ExtenderInstanceBase Property

Aptify 5.0 Software Development Kit (SDK)

ExtenderObjectListBase.ExtenderInstanceBase Property

Overload List

public virtual ExtenderInstanceBase this[Int32] {get;}

public virtual ExtenderInstanceBase this[String] {get;}

See Also

ExtenderObjectListBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


Item Property (Int32)

Aptify 5.0 Software Development Kit (SDK)

ExtenderObjectListBase.Item Property (Int32)

public virtual ExtenderInstanceBase this[
Int32 Index
] {get;}

See Also

ExtenderObjectListBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | ExtenderObjectListBase.ExtenderInstanceBase Overload List


Item Property (String)

Aptify 5.0 Software Development Kit (SDK)

ExtenderObjectListBase.Item Property (String)

public virtual ExtenderInstanceBase this[
String EntityName
] {get;}

See Also

ExtenderObjectListBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | ExtenderObjectListBase.ExtenderInstanceBase Overload List


List Property

Aptify 5.0 Software Development Kit (SDK)

ExtenderObjectListBase.List Property

protected virtual List<T> List {get;}

See Also

ExtenderObjectListBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ExtenderObjectListBase Methods

The methods of the ExtenderObjectListBase class are listed below. For a complete list of ExtenderObjectListBase class members, see the ExtenderObjectListBase Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

DoAdd
DoClear
DoRemove

See Also

ExtenderObjectListBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ExtenderObjectListBase.DoAdd Method

protected internal virtual void DoAdd(
ExtenderInstanceBase Instance
);

See Also

ExtenderObjectListBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ExtenderObjectListBase.DoClear Method

protected internal virtual void DoClear();

See Also

ExtenderObjectListBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ExtenderObjectListBase.DoRemove Method

protected internal virtual void DoRemove(
ExtenderInstanceBase Instance
);

See Also

ExtenderObjectListBase Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


FieldAndParamName Structure

A data structure that holds the name of the field (Field) and the name of the parameter used by the stored procedures used by the Generic Entity object (ParamName).

For a list of all members of this type, see FieldAndParamName Members.

System.Object
ValueType
FieldAndParamName

public struct FieldAndParamName

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

FieldAndParamName Members | Aptify.Framework.BusinessLogic.GenericEntity Namespace


FieldAndParamName Members

FieldAndParamName overview

Public Instance Fields

Field
ParamName
SQLDataType
SQLFieldSize

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

FieldAndParamName Structure | Aptify.Framework.BusinessLogic.GenericEntity Namespace


FieldAndParamName Fields

The fields of the FieldAndParamName structure are listed below. For a complete list of FieldAndParamName structure members, see the FieldAndParamName Members topic.

Public Instance Fields

Field
ParamName
SQLDataType
SQLFieldSize

See Also

FieldAndParamName Structure | Aptify.Framework.BusinessLogic.GenericEntity Namespace


FieldAndParamName.Field Field

public Field Field;

See Also

FieldAndParamName Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


FieldAndParamName.ParamName Field

public ParamName ParamName;

See Also

FieldAndParamName Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


FieldAndParamName.SQLDataType Field

public SQLDataType SQLDataType;

See Also

FieldAndParamName Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


FieldAndParamName.SQLFieldSize Field

public SQLFieldSize SQLFieldSize;

See Also

FieldAndParamName Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GEBaseConstants Class

For a list of all members of this type, see GEBaseConstants Members.

System.Object
GEBaseConstants

public class GEBaseConstants

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

GEBaseConstants Members | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GEBaseConstants Members

GEBaseConstants overview

Public Static Methods

DataFieldLoadFailureMessage |
GetDataType |
GetFieldTextName |
GetOperatorName |
GetOperatorText | Overloaded.
GetResourceString |
SubTypeLoadFailureMessage |

Public Instance Constructors

GEBaseConstants Constructor Initializes a new instance of the GEBaseConstants class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GEBaseConstants Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GEBaseConstants Constructor

Initializes a new instance of the GEBaseConstants class.

public GEBaseConstants();

See Also

GEBaseConstants Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GEBaseConstants Methods

The methods of the GEBaseConstants class are listed below. For a complete list of GEBaseConstants class members, see the GEBaseConstants Members topic.

Public Static Methods

DataFieldLoadFailureMessage |
GetDataType |
GetFieldTextName |
GetOperatorName |
GetOperatorText | Overloaded.
GetResourceString |
SubTypeLoadFailureMessage |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GEBaseConstants Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GEBaseConstants.DataFieldLoadFailureMessage Method

public static string DataFieldLoadFailureMessage(
String Field,
String Entity
);

See Also

GEBaseConstants Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GEBaseConstants.GetDataType Method

public static string GetDataType(
String DataType
);

See Also

GEBaseConstants Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GEBaseConstants.GetFieldTextName Method

public static string GetFieldTextName(
String TextName
);

See Also

GEBaseConstants Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GEBaseConstants.GetOperatorName Method

public static string GetOperatorName();

See Also

GEBaseConstants Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GetOperatorText Method

Aptify 5.0 Software Development Kit (SDK)

GEBaseConstants.GetOperatorText Method

Overload List

public static string GetOperatorText(String);

public static string GetOperatorText(String,UserCredentials);

See Also

GEBaseConstants Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GEBaseConstants.GetOperatorText Method (String)

public static string GetOperatorText(
String Operation
);

See Also

GEBaseConstants Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | GEBaseConstants.GetOperatorText Overload List


GEBaseConstants.GetOperatorText Method (String, UserCredentials)

public static string GetOperatorText(
String Operation,
UserCredentials UserCredential
);

See Also

GEBaseConstants Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | GEBaseConstants.GetOperatorText Overload List


GEBaseConstants.GetResourceString Method

public static string GetResourceString(
String ResourceKey
);

See Also

GEBaseConstants Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GEBaseConstants.SubTypeLoadFailureMessage Method

public static string SubTypeLoadFailureMessage(
String Entity,
Int32 Index,
String ParentEntity,
Int64 ParentEntityRecordID
);

See Also

GEBaseConstants Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GEConstants Class

For a list of all members of this type, see GEConstants Members.

System.Object
GEConstants

public class GEConstants

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntity (in AptifyGenericEntity.dll)

See Also

GEConstants Members | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GEConstants Members

GEConstants overview

Public Static Fields

GENERIC_ENTITY_ASSEMBLY
GENERIC_ENTITY_TYPE

Public Static Properties

SubTypeFindNoRecordFound
SubTypeFindNoRecordFoundContinue
SubTypeFindRequiresMoreInfo
SubTypeFindNoRecords
ConflictWizardUnresolvedMessage
UserCredentials

Public Static Methods

CreateFailedUniqueKeyViolationMessage
DataFieldDoesNotExistMessage
DeleteFailureBeforeRecordDeletedMessage
DeleteFailureDependenciesExistMessage
DisplayDuplicatesCaption
DuplicateCheckFailureMessage
DuplicateCheckMessageCaption
ExactDuplicateRecordQueryMessage
FieldValidationBlankValueNotOKMessage
FieldValidationDateOutOfBoundsMessage
FieldValidationDateTooEarlyMessage
FieldValidationDateTooLateMessage
FieldValidationNotABooleanMessage
FieldValidationNotADateMessage
FieldValidationNotANumberMessage
FieldValidationNotATimeMessage
FieldValidationNumOutOfRange
FieldValidationNumTooLarge
FieldValidationNumTooSmall
FieldValidationTextTooLongMessage
FieldValidationTimeNotAllowedMessage
FieldValidationTimeOutOfBoundsMessage
FieldValidationTimeTooEarlyMessage
FieldValidationTimeTooLateMessage
FieldValidationUnknownTypeMessage
GEDatabaseOperationExceptionMessage
GenericEntitySQLExceptionMessage
GESaveSubTypeTransactionErrorMessage
GETransactionMismatchExceptionMessage
GetResourceString
IndexOutOfRangeMessage
LogDuplicatesFailureMessage
MissingEntityDatabaseObjectMessage
PermissionDeniedEditRecord
PermissionDeniedRecordMessage
PotentialDuplicateRecordQueryMessage
RecordNotFoundMessage
SubTypeFindCaption
TransferMappingNoMatchMessage
UpdateFailedUniqueKeyViolationMessage
ValidationScriptCompileFailureMessage

Public Instance Constructors

GEConstants Constructor Initializes a new instance of the GEConstants class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GEConstants Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GEConstants Constructor

Initializes a new instance of the GEConstants class.

public GEConstants();

See Also

GEConstants Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GEConstants Fields

The fields of the GEConstants class are listed below. For a complete list of GEConstants class members, see the GEConstants Members topic.

Public Static Fields

GENERIC_ENTITY_ASSEMBLY
GENERIC_ENTITY_TYPE

See Also

GEConstants Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GEConstants.GENERIC_ENTITY_ASSEMBLY Field

public const GENERIC_ENTITY_ASSEMBLY GENERIC_ENTITY_ASSEMBLY = "AptifyGenericEntity";

See Also

GEConstants Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GEConstants.GENERIC_ENTITY_TYPE Field

public const GENERIC_ENTITY_TYPE GENERIC_ENTITY_TYPE = "Aptify.Framework.BusinessLogic.GenericEntity.AptifyGenericEntity";

See Also

GEConstants Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GEConstants Properties

The properties of the GEConstants class are listed below. For a complete list of GEConstants class members, see the GEConstants Members topic.

Public Static Properties

SubTypeFindNoRecordFound
SubTypeFindNoRecordFoundContinue
SubTypeFindRequiresMoreInfo
SubTypeFindNoRecords
ConflictWizardUnresolvedMessage
UserCredentials

See Also

GEConstants Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ConflictWizardUnresolvedMessage Property

Aptify 5.0 Software Development Kit (SDK)

GEConstants.ConflictWizardUnresolvedMessage Property

public static String ConflictWizardUnresolvedMessage {get;}

See Also

GEConstants Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


SubTypeFindNoRecordFound Property

Aptify 5.0 Software Development Kit (SDK)

GEConstants.SubTypeFindNoRecordFound Property

public static String SubTypeFindNoRecordFound {get;}

See Also

GEConstants Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


SubTypeFindNoRecordFoundContinue Property

Aptify 5.0 Software Development Kit (SDK)

GEConstants.SubTypeFindNoRecordFoundContinue Property

public static String SubTypeFindNoRecordFoundContinue {get;}

See Also

GEConstants Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


SubTypeFindNoRecords Property

Aptify 5.0 Software Development Kit (SDK)

GEConstants.SubTypeFindNoRecords Property

public static String SubTypeFindNoRecords {get;}

See Also

GEConstants Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


SubTypeFindRequiresMoreInfo Property

Aptify 5.0 Software Development Kit (SDK)

GEConstants.SubTypeFindRequiresMoreInfo Property

public static String SubTypeFindRequiresMoreInfo {get;}

See Also

GEConstants Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


UserCredentials Property

Aptify 5.0 Software Development Kit (SDK)

GEConstants.UserCredentials Property

public static UserCredentials UserCredentials {set;}

See Also

GEConstants Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GEConstants Methods

The methods of the GEConstants class are listed below. For a complete list of GEConstants class members, see the GEConstants Members topic.

Public Static Methods

CreateFailedUniqueKeyViolationMessage
DataFieldDoesNotExistMessage
DeleteFailureBeforeRecordDeletedMessage
DeleteFailureDependenciesExistMessage
DisplayDuplicatesCaption
DuplicateCheckFailureMessage
DuplicateCheckMessageCaption
ExactDuplicateRecordQueryMessage
FieldValidationBlankValueNotOKMessage
FieldValidationDateOutOfBoundsMessage
FieldValidationDateTooEarlyMessage
FieldValidationDateTooLateMessage
FieldValidationNotABooleanMessage
FieldValidationNotADateMessage
FieldValidationNotANumberMessage
FieldValidationNotATimeMessage
FieldValidationNumOutOfRange
FieldValidationNumTooLarge
FieldValidationNumTooSmall
FieldValidationTextTooLongMessage
FieldValidationTimeNotAllowedMessage
FieldValidationTimeOutOfBoundsMessage
FieldValidationTimeTooEarlyMessage
FieldValidationTimeTooLateMessage
FieldValidationUnknownTypeMessage
GEDatabaseOperationExceptionMessage
GenericEntitySQLExceptionMessage
GESaveSubTypeTransactionErrorMessage
GETransactionMismatchExceptionMessage
GetResourceString
IndexOutOfRangeMessage
LogDuplicatesFailureMessage
MissingEntityDatabaseObjectMessage
PermissionDeniedEditRecord
PermissionDeniedRecordMessage
PotentialDuplicateRecordQueryMessage
RecordNotFoundMessage
SubTypeFindCaption
TransferMappingNoMatchMessage
UpdateFailedUniqueKeyViolationMessage
ValidationScriptCompileFailureMessage

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GEConstants Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GEConstants.CreateFailedUniqueKeyViolationMessage Method

public static string CreateFailedUniqueKeyViolationMessage(
String EntityDisplayName
);

See Also

GEConstants Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GEConstants.DataFieldDoesNotExistMessage Method

public static string DataFieldDoesNotExistMessage(
String Field
);

See Also

GEConstants Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GEConstants.DeleteFailureBeforeRecordDeletedMessage Method

public static string DeleteFailureBeforeRecordDeletedMessage(
String EntityName,
Int64 RecordID
);

See Also

GEConstants Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GEConstants.DeleteFailureDependenciesExistMessage Method

public static string DeleteFailureDependenciesExistMessage(
String EntityName,
Int64 RecordID
);

See Also

GEConstants Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GEConstants.DisplayDuplicatesCaption Method

public static string DisplayDuplicatesCaption(
String EntityName
);

See Also

GEConstants Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GEConstants.DuplicateCheckFailureMessage Method

public static string DuplicateCheckFailureMessage(
String EntityName
);

See Also

GEConstants Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GEConstants.DuplicateCheckMessageCaption Method

public static string DuplicateCheckMessageCaption(
String EntityName
);

See Also

GEConstants Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GEConstants.ExactDuplicateRecordQueryMessage Method

public static string ExactDuplicateRecordQueryMessage(
Int32 iDuplicateCount
);

See Also

GEConstants Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GEConstants.FieldValidationBlankValueNotOKMessage Method

public static string FieldValidationBlankValueNotOKMessage(
String FieldName
);

See Also

GEConstants Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GEConstants.FieldValidationDateOutOfBoundsMessage Method

public static string FieldValidationDateOutOfBoundsMessage(
String Value,
String FieldName,
String LowerBound,
String UpperBound
);

See Also

GEConstants Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GEConstants.FieldValidationDateTooEarlyMessage Method

public static string FieldValidationDateTooEarlyMessage(
String Value,
String FieldName,
String LowerBound
);

See Also

GEConstants Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GEConstants.FieldValidationDateTooLateMessage Method

public static string FieldValidationDateTooLateMessage(
String Value,
String FieldName,
String UpperBound
);

See Also

GEConstants Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GEConstants.FieldValidationNotABooleanMessage Method

public static string FieldValidationNotABooleanMessage(
String Value,
String FieldName
);

See Also

GEConstants Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GEConstants.FieldValidationNotADateMessage Method

public static string FieldValidationNotADateMessage(
String Value,
String FieldName
);

See Also

GEConstants Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GEConstants.FieldValidationNotANumberMessage Method

public static string FieldValidationNotANumberMessage(
String Value,
String FieldName
);

See Also

GEConstants Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GEConstants.FieldValidationNotATimeMessage Method

public static string FieldValidationNotATimeMessage(
String Value,
String FieldName
);

See Also

GEConstants Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GEConstants.FieldValidationNumOutOfRange Method

public static string FieldValidationNumOutOfRange(
String Value,
String FieldName,
Object LowerBound,
Object UpperBound
);

See Also

GEConstants Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GEConstants.FieldValidationNumTooLarge Method

public static string FieldValidationNumTooLarge(
String Value,
String FieldName,
Object UpperBound
);

See Also

GEConstants Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GEConstants.FieldValidationNumTooSmall Method

public static string FieldValidationNumTooSmall(
String Value,
String FieldName,
Object LowerBound
);

See Also

GEConstants Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GEConstants.FieldValidationTextTooLongMessage Method

public static string FieldValidationTextTooLongMessage(
String FieldName,
String FieldSize,
String Value
);

See Also

GEConstants Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GEConstants.FieldValidationTimeNotAllowedMessage Method

public static string FieldValidationTimeNotAllowedMessage(
String Value,
String FieldName
);

See Also

GEConstants Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GEConstants.FieldValidationTimeOutOfBoundsMessage Method

public static string FieldValidationTimeOutOfBoundsMessage(
String Value,
String FieldName,
String LowerBound,
String UpperBound
);

See Also

GEConstants Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GEConstants.FieldValidationTimeTooEarlyMessage Method

public static string FieldValidationTimeTooEarlyMessage(
String Value,
String FieldName,
String LowerBound
);

See Also

GEConstants Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GEConstants.FieldValidationTimeTooLateMessage Method

public static string FieldValidationTimeTooLateMessage(
String Value,
String FieldName,
String UpperBound
);

See Also

GEConstants Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GEConstants.FieldValidationUnknownTypeMessage Method

public static string FieldValidationUnknownTypeMessage(
String Value,
String FieldName,
String SQLDataType
);

See Also

GEConstants Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GEConstants.GEDatabaseOperationExceptionMessage Method

public static string GEDatabaseOperationExceptionMessage(
String EntityName,
String Operation,
String SQL
);

See Also

GEConstants Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GEConstants.GenericEntitySQLExceptionMessage Method

public static string GenericEntitySQLExceptionMessage(
String EntityName,
String Operation
);

See Also

GEConstants Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GEConstants.GESaveSubTypeTransactionErrorMessage Method

public static string GESaveSubTypeTransactionErrorMessage(
String EntityName
);

See Also

GEConstants Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GEConstants.GETransactionMismatchExceptionMessage Method

public static string GETransactionMismatchExceptionMessage(
String GETransactionID,
String NewTransactionID
);

See Also

GEConstants Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GEConstants.GetResourceString Method

public static string GetResourceString(
String ResourceKey,
String CultureStringName
);

See Also

GEConstants Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GEConstants.IndexOutOfRangeMessage Method

public static string IndexOutOfRangeMessage();

See Also

GEConstants Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GEConstants.LogDuplicatesFailureMessage Method

public static string LogDuplicatesFailureMessage(
String EntityName
);

See Also

GEConstants Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GEConstants.MissingEntityDatabaseObjectMessage Method

public static string MissingEntityDatabaseObjectMessage(
String DatabaseObject,
String EntityName
);

See Also

GEConstants Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GEConstants.PermissionDeniedEditRecord Method

public static string PermissionDeniedEditRecord(
String FieldName
);

See Also

GEConstants Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GEConstants.PermissionDeniedRecordMessage Method

public static string PermissionDeniedRecordMessage(
String Operation,
String EntityName
);

See Also

GEConstants Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GEConstants.PotentialDuplicateRecordQueryMessage Method

public static string PotentialDuplicateRecordQueryMessage(
Int32 iDuplicateCount
);

See Also

GEConstants Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GEConstants.RecordNotFoundMessage Method

public static string RecordNotFoundMessage(
String EntityName,
Int64 RecordID
);

See Also

GEConstants Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GEConstants.SubTypeFindCaption Method

public static string SubTypeFindCaption(
String EntityName
);

See Also

GEConstants Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GEConstants.TransferMappingNoMatchMessage Method

public static string TransferMappingNoMatchMessage(
String Entity,
DataLocation MapLocation,
DataLocation SourceLocation,
Int64 SourceID,
DataLocation DestLocation
);

See Also

GEConstants Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GEConstants.UpdateFailedUniqueKeyViolationMessage Method

public static string UpdateFailedUniqueKeyViolationMessage(
String EntityDisplayName,
Int64 RecordID
);

See Also

GEConstants Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GEConstants.ValidationScriptCompileFailureMessage Method

public static string ValidationScriptCompileFailureMessage(
String EntityName,
String FieldName,
String compileError
);

See Also

GEConstants Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GESubClassCompiler Class

This class is capable of compiling a generated GE Sub-Class by using VB command line compilation. The methods specified allow you to compile the code files and generate a DLL.

For a list of all members of this type, see GESubClassCompiler Members.

System.Object
GESubClassCompiler

public class GESubClassCompiler

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: GESubClassGenerator (in GESubClassGenerator.dll)

See Also

GESubClassCompiler Members | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GESubClassCompiler Members

GESubClassCompiler overview

Public Instance Constructors

GESubClassCompiler Constructor Initializes a new instance of the GESubClassCompiler class.

Public Instance Properties

ReferenceDLLs |
ReferencePath |
VBCompilerExists | This property returns True if the Visual Basic .NET compiler exists on the current computer and False if it does not
VBCPath | This property sets/gets the location of the VBC executable which is the command-line VB compiler executable

Public Instance Methods

Compile | Overloaded.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetReferences |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GESubClassCompiler Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GESubClassCompiler Constructor

Initializes a new instance of the GESubClassCompiler class.

public GESubClassCompiler();

See Also

GESubClassCompiler Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GESubClassCompiler Properties

The properties of the GESubClassCompiler class are listed below. For a complete list of GESubClassCompiler class members, see the GESubClassCompiler Members topic.

Public Instance Properties

ReferenceDLLs |
ReferencePath |
VBCompilerExists | This property returns True if the Visual Basic .NET compiler exists on the current computer and False if it does not
VBCPath | This property sets/gets the location of the VBC executable which is the command-line VB compiler executable

See Also

GESubClassCompiler Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ReferenceDLLs Property

Aptify 5.0 Software Development Kit (SDK)

GESubClassCompiler.ReferenceDLLs Property

public virtual List<T> ReferenceDLLs {get;}

See Also

GESubClassCompiler Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ReferencePath Property

Aptify 5.0 Software Development Kit (SDK)

GESubClassCompiler.ReferencePath Property

public virtual String ReferencePath {get; set;}

See Also

GESubClassCompiler Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


VBCompilerExists Property

Aptify 5.0 Software Development Kit (SDK)

GESubClassCompiler.VBCompilerExists Property

This property returns True if the Visual Basic .NET compiler exists on the current computer and False if it does not

public virtual Boolean VBCompilerExists {get;}

Property Value

Remarks

See Also

GESubClassCompiler Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


VBCPath Property

Aptify 5.0 Software Development Kit (SDK)

GESubClassCompiler.VBCPath Property

This property sets/gets the location of the VBC executable which is the command-line VB compiler executable

public virtual String VBCPath {get; set;}

Property Value

Remarks

See Also

GESubClassCompiler Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GESubClassCompiler Methods

The methods of the GESubClassCompiler class are listed below. For a complete list of GESubClassCompiler class members, see the GESubClassCompiler Members topic.

Public Instance Methods

Compile | Overloaded.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetReferences |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GESubClassCompiler Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


Compile Method

Aptify 5.0 Software Development Kit (SDK)

GESubClassCompiler.Compile Method

Overload List

public virtual bool Compile(String);

public virtual bool Compile(String,ref String&);

See Also

GESubClassCompiler Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GESubClassCompiler.Compile Method (String)

public virtual bool Compile(
String SourceFile
);

See Also

GESubClassCompiler Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | GESubClassCompiler.Compile Overload List


GESubClassCompiler.Compile Method (String, String&)

public virtual bool Compile(
String SourceFile,
ref String& DLLFileName
);

See Also

GESubClassCompiler Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | GESubClassCompiler.Compile Overload List


GESubClassCompiler.GetReferences Method

public virtual string GetReferences();

See Also

GESubClassCompiler Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GESubClassGenerator Class

This class is used to generate Generic Entity sub-classes that inherit from the Generic Entity and create strongly typed accessor methods for properties and sub-types with XML comments from the meta-data.

For a list of all members of this type, see GESubClassGenerator Members.

System.Object
GESubClassGenerator

public class GESubClassGenerator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: GESubClassGenerator (in GESubClassGenerator.dll)

See Also

GESubClassGenerator Members | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GESubClassGenerator Members

GESubClassGenerator overview

Public Instance Constructors

GESubClassGenerator Constructor

Public Instance Properties

Application

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GenerateEntityObjectFileName | This member is responsible for generating a file name for the specified entity based on the provided entity name and output path
GenerateGESubClass | Overloaded.
GenerateGESubClasses | Overloaded. Creates one or more GE Sub-Classes based on the information provided
GetEntitySubClassName | This method returns the generated name for the class for the specified entity name
GetGESubClassCode | Overloaded.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

StatusUpdate

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FixName | This method determines if the provided Name parameter will have any issue/conflict with reserved words in VB/.NET, and if so, will add the "StringToAppend" parameter to the end of it and return the result.
GeneratedEmbeddedFieldAccessorCode | This method will generate the property accessor for an embedded field that returns the embedded object GE
GenerateFieldAccessorCode | This method is responsible for generating the source code for a single accessor property for a given field. In the case of fields that represent embedded objects, two accessor properties will be created. One will be created for the field to retrieve the ID value of the related record, the second will return the embedded object.
GenerateSubTypeAccessorCode | This method will generate accessor properites in an entity for the specified sub-type
IsFieldReadOnlyAccessor | This method determines if the specified entity field should have a read only accessor property or a read/write accessor property.
MapDotNetTypeToConversionType |
MapFieldTypeToDotNetType | This method will map a SQL Server column data type to a type that is usable in VB.NET
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GESubClassGenerator Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GESubClassGenerator Constructor

public GESubClassGenerator(
AptifyApplication Application
);

See Also

GESubClassGenerator Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GESubClassGenerator Properties

The properties of the GESubClassGenerator class are listed below. For a complete list of GESubClassGenerator class members, see the GESubClassGenerator Members topic.

Public Instance Properties

Application

See Also

GESubClassGenerator Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


Application Property

Aptify 5.0 Software Development Kit (SDK)

GESubClassGenerator.Application Property

public virtual AptifyApplication Application {get;}

See Also

GESubClassGenerator Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GESubClassGenerator Methods

The methods of the GESubClassGenerator class are listed below. For a complete list of GESubClassGenerator class members, see the GESubClassGenerator Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GenerateEntityObjectFileName | This member is responsible for generating a file name for the specified entity based on the provided entity name and output path
GenerateGESubClass | Overloaded.
GenerateGESubClasses | Overloaded. Creates one or more GE Sub-Classes based on the information provided
GetEntitySubClassName | This method returns the generated name for the class for the specified entity name
GetGESubClassCode | Overloaded.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FixName | This method determines if the provided Name parameter will have any issue/conflict with reserved words in VB/.NET, and if so, will add the "StringToAppend" parameter to the end of it and return the result.
GeneratedEmbeddedFieldAccessorCode | This method will generate the property accessor for an embedded field that returns the embedded object GE
GenerateFieldAccessorCode | This method is responsible for generating the source code for a single accessor property for a given field. In the case of fields that represent embedded objects, two accessor properties will be created. One will be created for the field to retrieve the ID value of the related record, the second will return the embedded object.
GenerateSubTypeAccessorCode | This method will generate accessor properites in an entity for the specified sub-type
IsFieldReadOnlyAccessor | This method determines if the specified entity field should have a read only accessor property or a read/write accessor property.
MapDotNetTypeToConversionType |
MapFieldTypeToDotNetType | This method will map a SQL Server column data type to a type that is usable in VB.NET
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GESubClassGenerator Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GESubClassGenerator.FixName Method

This method determines if the provided Name parameter will have any issue/conflict with reserved words in VB/.NET, and if so, will add the "StringToAppend" parameter to the end of it and return the result.

protected virtual string FixName(
String Name,
String StringToAppend
);

Parameters

Name
StringToAppend

Return Value

Remarks

See Also

GESubClassGenerator Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GESubClassGenerator.GeneratedEmbeddedFieldAccessorCode Method

This method will generate the property accessor for an embedded field that returns the embedded object GE

protected virtual void GeneratedEmbeddedFieldAccessorCode(
StringBuilder sBuilder,
EntityFieldMetaData f
);

Parameters

sBuilder
f

Remarks

See Also

GESubClassGenerator Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GESubClassGenerator.GenerateEntityObjectFileName Method

This member is responsible for generating a file name for the specified entity based on the provided entity name and output path

public virtual string GenerateEntityObjectFileName(
String EntityName,
String OutputPath
);

Parameters

EntityName
OutputPath

Return Value

Remarks

See Also

GESubClassGenerator Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GESubClassGenerator.GenerateFieldAccessorCode Method

This method is responsible for generating the source code for a single accessor property for a given field. In the case of fields that represent embedded objects, two accessor properties will be created. One will be created for the field to retrieve the ID value of the related record, the second will return the embedded object.

protected virtual void GenerateFieldAccessorCode(
StringBuilder sBuilder,
EntityFieldMetaData f
);

Parameters

sBuilder
f

Remarks

See Also

GESubClassGenerator Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GenerateGESubClass Method

Aptify 5.0 Software Development Kit (SDK)

GESubClassGenerator.GenerateGESubClass Method

Overload List

public virtual bool GenerateGESubClass(String,String,ref String&);

public virtual bool GenerateGESubClass(String,String,ref String&,Dictionary<TKey,TValue>);

See Also

GESubClassGenerator Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GESubClassGenerator.GenerateGESubClass Method (String, String, String&)

public virtual bool GenerateGESubClass(
String EntityName,
String OutputPath,
ref String& EntityObjectFileName
);

See Also

GESubClassGenerator Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | GESubClassGenerator.GenerateGESubClass Overload List


GESubClassGenerator.GenerateGESubClass Method (String, String, String&, Dictionary<TKey,TValue>)

public virtual bool GenerateGESubClass(
String EntityName,
String OutputPath,
ref String& EntityObjectFileName,
Dictionary<TKey,TValue> ClassNames
);

See Also

GESubClassGenerator Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | GESubClassGenerator.GenerateGESubClass Overload List


GenerateGESubClasses Method

Aptify 5.0 Software Development Kit (SDK)

GESubClassGenerator.GenerateGESubClasses Method

Creates one or more GE Sub-Classes based on the information provided

Overload List

Creates one or more GE Sub-Classes based on the information provided

public virtual bool GenerateGESubClasses(List<T>,String,List<T>);

Creates one or more GE Sub-Classes based on the information provided

public virtual bool GenerateGESubClasses(List<T>,String,List<T>);

See Also

GESubClassGenerator Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GESubClassGenerator.GenerateGESubClasses Method (List<T>, String, List<T>)

Creates one or more GE Sub-Classes based on the information provided

public virtual bool GenerateGESubClasses(
List<T> EntityIDs,
String OutputPath,
List<T> OutputFiles
);

Parameters

EntityIDs
OutputPath
OutputFiles

Return Value

Remarks

See Also

GESubClassGenerator Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | GESubClassGenerator.GenerateGESubClasses Overload List


GESubClassGenerator.GenerateGESubClasses Method (List<T>, String, List<T>)

Creates one or more GE Sub-Classes based on the information provided

public virtual bool GenerateGESubClasses(
List<T> EntityNames,
String OutputPath,
List<T> OutputFiles
);

Parameters

EntityNames
OutputPath
OutputFiles

Return Value

Remarks

See Also

GESubClassGenerator Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | GESubClassGenerator.GenerateGESubClasses Overload List


GESubClassGenerator.GenerateSubTypeAccessorCode Method

This method will generate accessor properites in an entity for the specified sub-type

protected virtual void GenerateSubTypeAccessorCode(
StringBuilder sBuilder,
EntityLevelMetaData st
);

Parameters

sBuilder
st

Remarks

See Also

GESubClassGenerator Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GESubClassGenerator.GetEntitySubClassName Method

This method returns the generated name for the class for the specified entity name

public virtual string GetEntitySubClassName(
String EntityName
);

Parameters

EntityName

Return Value

Remarks

See Also

GESubClassGenerator Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GetGESubClassCode Method

Aptify 5.0 Software Development Kit (SDK)

GESubClassGenerator.GetGESubClassCode Method

Overload List

public virtual string GetGESubClassCode(String,ref Dictionary`2&);

This method is the main method that will generate the code for a GE Sub-Class for a given entity that has strongly typed accessor methods for fields and sub-classes.

public virtual string GetGESubClassCode(StringBuilder,String,Dictionary<TKey,TValue>);

See Also

GESubClassGenerator Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GESubClassGenerator.GetGESubClassCode Method (String, Dictionary`2&)

public virtual string GetGESubClassCode(
String EntityName,
ref Dictionary`2& ClassNames
);

See Also

GESubClassGenerator Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | GESubClassGenerator.GetGESubClassCode Overload List


GESubClassGenerator.GetGESubClassCode Method (StringBuilder, String, Dictionary<TKey,TValue>)

This method is the main method that will generate the code for a GE Sub-Class for a given entity that has strongly typed accessor methods for fields and sub-classes.

public virtual string GetGESubClassCode(
StringBuilder sBuilder,
String EntityName,
Dictionary<TKey,TValue> ClassNames
);

Parameters

sBuilder
EntityName
ClassNames

Return Value

Remarks

See Also

GESubClassGenerator Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | GESubClassGenerator.GetGESubClassCode Overload List


GESubClassGenerator.IsFieldReadOnlyAccessor Method

This method determines if the specified entity field should have a read only accessor property or a read/write accessor property.

protected virtual bool IsFieldReadOnlyAccessor(
EntityFieldMetaData FieldMD
);

Parameters

FieldMD

Return Value

Remarks

See Also

GESubClassGenerator Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GESubClassGenerator.MapDotNetTypeToConversionType Method

protected virtual string MapDotNetTypeToConversionType(
String DotNetType
);

See Also

GESubClassGenerator Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GESubClassGenerator.MapFieldTypeToDotNetType Method

This method will map a SQL Server column data type to a type that is usable in VB.NET

protected virtual string MapFieldTypeToDotNetType(
String SQLDataType
);

Parameters

SQLDataType

Return Value

Remarks

See Also

GESubClassGenerator Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GESubClassGenerator Events

The events of the GESubClassGenerator class are listed below. For a complete list of GESubClassGenerator class members, see the GESubClassGenerator Members topic.

Public Instance Events

StatusUpdate

See Also

GESubClassGenerator Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GESubClassGenerator.GESubClassGenerator.StatusUpdateEventHandler Event

public event GESubClassGenerator.StatusUpdateEventHandler StatusUpdate;

See Also

GESubClassGenerator Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GESubClassGenerator.StatusUpdateEventHandler Delegate

public delegate void GESubClassGenerator.StatusUpdateEventHandler(
Int32 CurrentEntity,
Int32 TotalEntities,
String CurrentEntityName,
ref Boolean& Cancel
);

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: GESubClassGenerator (in GESubClassGenerator.dll)

See Also

Aptify.Framework.BusinessLogic.GenericEntity Namespace


GESubClassIntegrator Class

This class is responsible for using the GE sub-class generator and compiler classes and integrating the resulting compiled DLL objects into the object repository. This class implements IProcessComponent so that it can be called from a process flow

For a list of all members of this type, see GESubClassIntegrator Members.

System.Object
GESubClassIntegrator

public class GESubClassIntegrator : IProcessComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: GESubClassGenerator (in GESubClassGenerator.dll)

See Also

GESubClassIntegrator Members | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GESubClassIntegrator Members

GESubClassIntegrator overview

Public Instance Constructors

GESubClassIntegrator Constructor Initializes a new instance of the GESubClassIntegrator class.

Public Instance Properties

Application
DataAction
Properties

Public Instance Methods

Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEntityPlugInTypeID |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run | This method executes the GE Sub-Class Integrator Object. The following parameters are enabled for the component 1) EntityName - this parameter is required and specifies the entity name to generate the sub-class for. This class performs the following functions: 1) Generate sub-class DLL 2) Upload the DLL to the Object Repository 3) If the Entity definition for the provided entity (and/or its sub-types) do not have information already specified for a GE sub-class plug-in, provide that meta-data to the entity and save it.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
UpdateEntityMetaData | This method is responsible for updating an entity and its sub-types with information about the new GE sub-classes. This method will NOT override information that is already in place in the entity meta-data but will insert the meta-data initially.

See Also

GESubClassIntegrator Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GESubClassIntegrator Constructor

Initializes a new instance of the GESubClassIntegrator class.

public GESubClassIntegrator();

See Also

GESubClassIntegrator Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GESubClassIntegrator Properties

The properties of the GESubClassIntegrator class are listed below. For a complete list of GESubClassIntegrator class members, see the GESubClassIntegrator Members topic.

Public Instance Properties

Application
DataAction
Properties

See Also

GESubClassIntegrator Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


Application Property

Aptify 5.0 Software Development Kit (SDK)

GESubClassIntegrator.Application Property

public virtual AptifyApplication Application {get;}

See Also

GESubClassIntegrator Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


DataAction Property

Aptify 5.0 Software Development Kit (SDK)

GESubClassIntegrator.DataAction Property

public virtual DataAction DataAction {get;}

See Also

GESubClassIntegrator Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


Properties Property

Aptify 5.0 Software Development Kit (SDK)

GESubClassIntegrator.Properties Property

public AptifyProperties Properties {get;}

Implements

IProcessComponent.

See Also

GESubClassIntegrator Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GESubClassIntegrator Methods

The methods of the GESubClassIntegrator class are listed below. For a complete list of GESubClassIntegrator class members, see the GESubClassIntegrator Members topic.

Public Instance Methods

Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEntityPlugInTypeID |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run | This method executes the GE Sub-Class Integrator Object. The following parameters are enabled for the component 1) EntityName - this parameter is required and specifies the entity name to generate the sub-class for. This class performs the following functions: 1) Generate sub-class DLL 2) Upload the DLL to the Object Repository 3) If the Entity definition for the provided entity (and/or its sub-types) do not have information already specified for a GE sub-class plug-in, provide that meta-data to the entity and save it.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
UpdateEntityMetaData | This method is responsible for updating an entity and its sub-types with information about the new GE sub-classes. This method will NOT override information that is already in place in the entity meta-data but will insert the meta-data initially.

See Also

GESubClassIntegrator Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GESubClassIntegrator.Config Method

public void Config(
AptifyApplication ApplicationObject
);

Implements

IProcessComponent.

See Also

GESubClassIntegrator Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GESubClassIntegrator.GetEntityPlugInTypeID Method

public virtual long GetEntityPlugInTypeID(
String PlugInType
);

See Also

GESubClassIntegrator Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GESubClassIntegrator.Run Method

This method executes the GE Sub-Class Integrator Object. The following parameters are enabled for the component 1) EntityName - this parameter is required and specifies the entity name to generate the sub-class for. This class performs the following functions: 1) Generate sub-class DLL 2) Upload the DLL to the Object Repository 3) If the Entity definition for the provided entity (and/or its sub-types) do not have information already specified for a GE sub-class plug-in, provide that meta-data to the entity and save it.

public string Run();

Return Value

Implements

IProcessComponent.

Remarks

See Also

GESubClassIntegrator Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GESubClassIntegrator.UpdateEntityMetaData Method

This method is responsible for updating an entity and its sub-types with information about the new GE sub-classes. This method will NOT override information that is already in place in the entity meta-data but will insert the meta-data initially.

protected virtual object UpdateEntityMetaData(
String EntityName,
Dictionary<TKey,TValue> ClassNames,
String ObjectName,
String AssemblyName
);

Parameters

EntityName
ClassNames
ObjectName
AssemblyName

Return Value

Remarks

See Also

GESubClassIntegrator Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


IAptifyDuplicateCheck Interface

For a list of all members of this type, see IAptifyDuplicateCheck Members.

public interface IAptifyDuplicateCheck

Types that implement IAptifyDuplicateCheck

Type | Description
CompanyDupeCheck | Implements a sample set of logic for duplicate checking for the Companies entity
PersonDupeCheck | Implements a sample set of logic for duplicate checking for the Persons entity

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

IAptifyDuplicateCheck Members | Aptify.Framework.BusinessLogic.GenericEntity Namespace


IAptifyDuplicateCheck Members

IAptifyDuplicateCheck overview

Public Instance Properties

DuplicateMessageObject Returns a duplicate check message object which allows for a custom duplicate message. If the standard duplicate message should be displayed DuplicateMessageObject should return Nothing.

Public Instance Methods

CheckForDuplicates

See Also

IAptifyDuplicateCheck Interface | Aptify.Framework.BusinessLogic.GenericEntity Namespace


IAptifyDuplicateCheck Properties

The properties of the IAptifyDuplicateCheck interface are listed below. For a complete list of IAptifyDuplicateCheck interface members, see the IAptifyDuplicateCheck Members topic.

Public Instance Properties

DuplicateMessageObject Returns a duplicate check message object which allows for a custom duplicate message. If the standard duplicate message should be displayed DuplicateMessageObject should return Nothing.

See Also

IAptifyDuplicateCheck Interface | Aptify.Framework.BusinessLogic.GenericEntity Namespace


DuplicateMessageObject Property

Aptify 5.0 Software Development Kit (SDK)

IAptifyDuplicateCheck.DuplicateMessageObject Property

Returns a duplicate check message object which allows for a custom duplicate message. If the standard duplicate message should be displayed DuplicateMessageObject should return Nothing.

IAptifyDuplicateMessage DuplicateMessageObject {get;}

Property Value

Remarks

See Also

IAptifyDuplicateCheck Interface | Aptify.Framework.BusinessLogic.GenericEntity Namespace


IAptifyDuplicateCheck Methods

The methods of the IAptifyDuplicateCheck interface are listed below. For a complete list of IAptifyDuplicateCheck interface members, see the IAptifyDuplicateCheck Members topic.

Public Instance Methods

CheckForDuplicates

See Also

IAptifyDuplicateCheck Interface | Aptify.Framework.BusinessLogic.GenericEntity Namespace


IAptifyDuplicateCheck.CheckForDuplicates Method

DuplicateCheckResult CheckForDuplicates(
AptifyGenericEntityBase GE,
ref Int64[]& DuplicateIDs
);

See Also

IAptifyDuplicateCheck Interface | Aptify.Framework.BusinessLogic.GenericEntity Namespace


IAptifyDuplicateMessage Interface

For a list of all members of this type, see IAptifyDuplicateMessage Members.

public interface IAptifyDuplicateMessage

Types that implement IAptifyDuplicateMessage

Type | Description
AptifyDuplicateMessage |

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

IAptifyDuplicateMessage Members | Aptify.Framework.BusinessLogic.GenericEntity Namespace


IAptifyDuplicateMessage Members

IAptifyDuplicateMessage overview

Public Instance Properties

DuplicateIDs
DuplicateResult
GE

Public Instance Methods

Display

See Also

IAptifyDuplicateMessage Interface | Aptify.Framework.BusinessLogic.GenericEntity Namespace


IAptifyDuplicateMessage Properties

The properties of the IAptifyDuplicateMessage interface are listed below. For a complete list of IAptifyDuplicateMessage interface members, see the IAptifyDuplicateMessage Members topic.

Public Instance Properties

DuplicateIDs
DuplicateResult
GE

See Also

IAptifyDuplicateMessage Interface | Aptify.Framework.BusinessLogic.GenericEntity Namespace


DuplicateIDs Property

Aptify 5.0 Software Development Kit (SDK)

IAptifyDuplicateMessage.DuplicateIDs Property

Int64[] DuplicateIDs {set;}

See Also

IAptifyDuplicateMessage Interface | Aptify.Framework.BusinessLogic.GenericEntity Namespace


DuplicateResult Property

Aptify 5.0 Software Development Kit (SDK)

IAptifyDuplicateMessage.DuplicateResult Property

DuplicateCheckResult DuplicateResult {set;}

See Also

IAptifyDuplicateMessage Interface | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GE Property

Aptify 5.0 Software Development Kit (SDK)

IAptifyDuplicateMessage.GE Property

AptifyGenericEntityBase GE {set;}

See Also

IAptifyDuplicateMessage Interface | Aptify.Framework.BusinessLogic.GenericEntity Namespace


IAptifyDuplicateMessage Methods

The methods of the IAptifyDuplicateMessage interface are listed below. For a complete list of IAptifyDuplicateMessage interface members, see the IAptifyDuplicateMessage Members topic.

Public Instance Methods

Display

See Also

IAptifyDuplicateMessage Interface | Aptify.Framework.BusinessLogic.GenericEntity Namespace


IAptifyDuplicateMessage.Display Method

DuplicateCheckMessageAction Display();

See Also

IAptifyDuplicateMessage Interface | Aptify.Framework.BusinessLogic.GenericEntity Namespace


IAptifyTransferMap Interface

For a list of all members of this type, see IAptifyTransferMap Members.

public interface IAptifyTransferMap

Types that implement IAptifyTransferMap

Type | Description
AptifyTransferMapping |

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

IAptifyTransferMap Members | Aptify.Framework.BusinessLogic.GenericEntity Namespace


IAptifyTransferMap Members

IAptifyTransferMap overview

Public Instance Methods

AddMapping
ClearMappings
GetMapping

See Also

IAptifyTransferMap Interface | Aptify.Framework.BusinessLogic.GenericEntity Namespace


IAptifyTransferMap Methods

The methods of the IAptifyTransferMap interface are listed below. For a complete list of IAptifyTransferMap interface members, see the IAptifyTransferMap Members topic.

Public Instance Methods

AddMapping
ClearMappings
GetMapping

See Also

IAptifyTransferMap Interface | Aptify.Framework.BusinessLogic.GenericEntity Namespace


IAptifyTransferMap.AddMapping Method

void AddMapping(
String Entity,
DataLocation MapLocation,
Int64 SourceID,
DataLocation SourceLocation,
Int64 DestID,
DataLocation DestLocation
);

See Also

IAptifyTransferMap Interface | Aptify.Framework.BusinessLogic.GenericEntity Namespace


IAptifyTransferMap.ClearMappings Method

void ClearMappings(
DataLocation MapLocation
);

See Also

IAptifyTransferMap Interface | Aptify.Framework.BusinessLogic.GenericEntity Namespace


IAptifyTransferMap.GetMapping Method

int GetMapping(
String Entity,
DataLocation MapLocation,
Int64 SourceID,
DataLocation SourceLocation,
DataLocation DestLocation
);

See Also

IAptifyTransferMap Interface | Aptify.Framework.BusinessLogic.GenericEntity Namespace


IAptifyVerify Interface

For a list of all members of this type, see IAptifyVerify Members.

public interface IAptifyVerify

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

IAptifyVerify Members | Aptify.Framework.BusinessLogic.GenericEntity Namespace


IAptifyVerify Members

IAptifyVerify overview

Public Instance Methods

VerifyRecord

See Also

IAptifyVerify Interface | Aptify.Framework.BusinessLogic.GenericEntity Namespace


IAptifyVerify Methods

The methods of the IAptifyVerify interface are listed below. For a complete list of IAptifyVerify interface members, see the IAptifyVerify Members topic.

Public Instance Methods

VerifyRecord

See Also

IAptifyVerify Interface | Aptify.Framework.BusinessLogic.GenericEntity Namespace


IAptifyVerify.VerifyRecord Method

bool VerifyRecord(
AptifyGenericEntityBase GE,
ref String& ErrorString
);

See Also

IAptifyVerify Interface | Aptify.Framework.BusinessLogic.GenericEntity Namespace


LegacyParser Class

This object supports the Record Data format that was used in CGI Explorer 1.x and 2.x. Starting with CGI Explorer 3.0, an XML format was used and a different parser is responsible for deserializing the GE.

For a list of all members of this type, see LegacyParser Members.

System.Object
LegacyParser

public class LegacyParser

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntity (in AptifyGenericEntity.dll)

See Also

LegacyParser Members | Aptify.Framework.BusinessLogic.GenericEntity Namespace


LegacyParser Members

LegacyParser overview

Public Instance Constructors

LegacyParser Constructor Initializes a new instance of the LegacyParser class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
GetVersionNumber |
InitParser |
RunParser |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LegacyParser Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


LegacyParser Constructor

Initializes a new instance of the LegacyParser class.

public LegacyParser();

See Also

LegacyParser Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


LegacyParser Methods

The methods of the LegacyParser class are listed below. For a complete list of LegacyParser class members, see the LegacyParser Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
GetVersionNumber |
InitParser |
RunParser |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LegacyParser Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


LegacyParser.GetVersionNumber Method

public int GetVersionNumber();

See Also

LegacyParser Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


LegacyParser.InitParser Method

public void InitParser(
String sInput
);

See Also

LegacyParser Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


LegacyParser.RunParser Method

public void RunParser(
AptifyGenericEntityBase oObject
);

See Also

LegacyParser Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


RequestForLatestValueArgs Class

Holds the Event arguments for the AfterLoadEmbeddedObject Event.

For a list of all members of this type, see RequestForLatestValueArgs Members.

System.Object
RequestForLatestValueArgs

public class RequestForLatestValueArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

RequestForLatestValueArgs Members | Aptify.Framework.BusinessLogic.GenericEntity Namespace


RequestForLatestValueArgs Members

RequestForLatestValueArgs overview

Public Instance Constructors

RequestForLatestValueArgs Constructor

Public Instance Properties

CurrentValue | Represents the value of the Data Field prior to the request.
FieldName | Represents the name of the Data Field that was changed. If this is a field from an embedded object, the parent object's Embedded Link Name with a dot will be prefixed to the field name.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RequestForLatestValueArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


RequestForLatestValueArgs Constructor

public RequestForLatestValueArgs(
String FieldName,
Object CurrentValue
);

See Also

RequestForLatestValueArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


RequestForLatestValueArgs Properties

The properties of the RequestForLatestValueArgs class are listed below. For a complete list of RequestForLatestValueArgs class members, see the RequestForLatestValueArgs Members topic.

Public Instance Properties

CurrentValue | Represents the value of the Data Field prior to the request.
FieldName | Represents the name of the Data Field that was changed. If this is a field from an embedded object, the parent object's Embedded Link Name with a dot will be prefixed to the field name.

See Also

RequestForLatestValueArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


CurrentValue Property

Aptify 5.0 Software Development Kit (SDK)

RequestForLatestValueArgs.CurrentValue Property

Represents the value of the Data Field prior to the request.

public Object CurrentValue {get;}

Property Value

Remarks

See Also

RequestForLatestValueArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


FieldName Property

Aptify 5.0 Software Development Kit (SDK)

RequestForLatestValueArgs.FieldName Property

Represents the name of the Data Field that was changed. If this is a field from an embedded object, the parent object's Embedded Link Name with a dot will be prefixed to the field name.

public String FieldName {get;}

Property Value

Remarks

See Also

RequestForLatestValueArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


SecurityKeyPermissionException Class

This exception will be thrown if a user that does not have access to a security key tries to access it.

For a list of all members of this type, see SecurityKeyPermissionException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
SecurityKeyPermissionException

public class SecurityKeyPermissionException : BaseApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntity (in AptifyGenericEntity.dll)

See Also

SecurityKeyPermissionException Members | Aptify.Framework.BusinessLogic.GenericEntity Namespace


SecurityKeyPermissionException Members

SecurityKeyPermissionException overview

Public Instance Constructors

SecurityKeyPermissionException Overloaded. Initializes a new instance of the SecurityKeyPermissionException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from BaseApplicationException) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SecurityKeyPermissionException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


SecurityKeyPermissionException Constructor

Initializes a new instance of the SecurityKeyPermissionException class.

Overload List

Initializes a new instance of the SecurityKeyPermissionException class.

public SecurityKeyPermissionException();

public SecurityKeyPermissionException(String);

public SecurityKeyPermissionException(String,Exception);

See Also

SecurityKeyPermissionException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


SecurityKeyPermissionException Constructor ()

Initializes a new instance of the SecurityKeyPermissionException class.

public SecurityKeyPermissionException();

See Also

SecurityKeyPermissionException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | SecurityKeyPermissionException Constructor Overload List


SecurityKeyPermissionException Constructor (String)

public SecurityKeyPermissionException(
String Message
);

See Also

SecurityKeyPermissionException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | SecurityKeyPermissionException Constructor Overload List


SecurityKeyPermissionException Constructor (String, Exception)

public SecurityKeyPermissionException(
String Message,
Exception InnerException
);

See Also

SecurityKeyPermissionException Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | SecurityKeyPermissionException Constructor Overload List


ServiceGeneratorForm Class

For a list of all members of this type, see ServiceGeneratorForm Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
ServiceGeneratorForm

public class ServiceGeneratorForm : Form, IAptifyAction

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: WebServiceGenerator (in WebServiceGenerator.dll)

See Also

ServiceGeneratorForm Members | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ServiceGeneratorForm Members

ServiceGeneratorForm overview

Public Instance Constructors

ServiceGeneratorForm Constructor Initializes a new instance of the ServiceGeneratorForm class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoAction | Overloaded.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ServiceGeneratorForm Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ServiceGeneratorForm Constructor

Initializes a new instance of the ServiceGeneratorForm class.

public ServiceGeneratorForm();

See Also

ServiceGeneratorForm Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ServiceGeneratorForm Methods

The methods of the ServiceGeneratorForm class are listed below. For a complete list of ServiceGeneratorForm class members, see the ServiceGeneratorForm Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoAction | Overloaded.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ServiceGeneratorForm Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ServiceGeneratorForm.ApplySkin Method

protected virtual void ApplySkin();

See Also

ServiceGeneratorForm Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ServiceGeneratorForm.Config Method

public bool Config(
AptifyApplication Application,
Int64 ViewID,
Int64 SelectedItemCount
);

See Also

ServiceGeneratorForm Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

ServiceGeneratorForm.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

ServiceGeneratorForm Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ServiceGeneratorForm.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

ServiceGeneratorForm Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | ServiceGeneratorForm.Dispose Overload List


DoAction Method

Aptify 5.0 Software Development Kit (SDK)

ServiceGeneratorForm.DoAction Method

Overload List

public void DoAction(AptifyApplication,Int64);

public void DoAction(AptifyApplication,Int64,Int64);

public void DoAction(AptifyApplication,Int64,Int64,params Object[]);

public void DoAction(AptifyApplication,Int64,params String[]);

See Also

ServiceGeneratorForm Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ServiceGeneratorForm.DoAction Method (AptifyApplication, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID
);

Implements

IAptifyAction.

See Also

ServiceGeneratorForm Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | ServiceGeneratorForm.DoAction Overload List


ServiceGeneratorForm.DoAction Method (AptifyApplication, Int64, Int64)

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID
);

Implements

IAptifyAction.

See Also

ServiceGeneratorForm Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | ServiceGeneratorForm.DoAction Overload List


ServiceGeneratorForm.DoAction Method (AptifyApplication, Int64, Int64, Object[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
Int64 ViewID,
params Object[] SelectedItems
);

Implements

IAptifyAction.

See Also

ServiceGeneratorForm Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | ServiceGeneratorForm.DoAction Overload List


ServiceGeneratorForm.DoAction Method (AptifyApplication, Int64, String[])

public void DoAction(
AptifyApplication ApplicationObject,
Int64 EntityID,
params String[] SelectedItems
);

Implements

IAptifyAction.

See Also

ServiceGeneratorForm Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | ServiceGeneratorForm.DoAction Overload List


SubTypeLink Structure

For a list of all members of this type, see SubTypeLink Members.

System.Object
ValueType
SubTypeLink

public struct SubTypeLink

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

SubTypeLink Members | Aptify.Framework.BusinessLogic.GenericEntity Namespace


SubTypeLink Members

SubTypeLink overview

Public Instance Fields

ParentLinkedValue
SubTypeField
SubTypeFieldParamName

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

SubTypeLink Structure | Aptify.Framework.BusinessLogic.GenericEntity Namespace


SubTypeLink Fields

The fields of the SubTypeLink structure are listed below. For a complete list of SubTypeLink structure members, see the SubTypeLink Members topic.

Public Instance Fields

ParentLinkedValue
SubTypeField
SubTypeFieldParamName

See Also

SubTypeLink Structure | Aptify.Framework.BusinessLogic.GenericEntity Namespace


SubTypeLink.ParentLinkedValue Field

public ParentLinkedValue ParentLinkedValue;

See Also

SubTypeLink Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


SubTypeLink.SubTypeField Field

public SubTypeField SubTypeField;

See Also

SubTypeLink Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


SubTypeLink.SubTypeFieldParamName Field

public SubTypeFieldParamName SubTypeFieldParamName;

See Also

SubTypeLink Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ValidationScriptResult Class

This class is used as the result from Validation Scripts.

For a list of all members of this type, see ValidationScriptResult Members.

System.Object
ValidationScriptResult

public class ValidationScriptResult

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

ValidationScriptResult Members | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ValidationScriptResult Members

ValidationScriptResult overview

Public Instance Constructors

ValidationScriptResult Constructor Initializes a new instance of the ValidationScriptResult class.

Public Instance Properties

Message | contains string messages that need to be passed in to or out of a validation script.
Success | This is the value that resulted from running a validation script.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ValidationScriptResult Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ValidationScriptResult Constructor

Initializes a new instance of the ValidationScriptResult class.

public ValidationScriptResult();

See Also

ValidationScriptResult Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ValidationScriptResult Properties

The properties of the ValidationScriptResult class are listed below. For a complete list of ValidationScriptResult class members, see the ValidationScriptResult Members topic.

Public Instance Properties

Message | contains string messages that need to be passed in to or out of a validation script.
Success | This is the value that resulted from running a validation script.

See Also

ValidationScriptResult Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


Message Property

Aptify 5.0 Software Development Kit (SDK)

ValidationScriptResult.Message Property

contains string messages that need to be passed in to or out of a validation script.

public String Message {get; set;}

Property Value

Remarks

This is usually used for error messages.

See Also

ValidationScriptResult Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


Success Property

Aptify 5.0 Software Development Kit (SDK)

ValidationScriptResult.Success Property

This is the value that resulted from running a validation script.

public Boolean Success {get; set;}

Property Value

Remarks

This value is false by default.

See Also

ValidationScriptResult Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


VersionCommentsForm Class

For a list of all members of this type, see VersionCommentsForm Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
VersionCommentsForm

public class VersionCommentsForm : Form

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntity (in AptifyGenericEntity.dll)

See Also

VersionCommentsForm Members | Aptify.Framework.BusinessLogic.GenericEntity Namespace


VersionCommentsForm Members

VersionCommentsForm overview

Public Instance Constructors

VersionCommentsForm Overloaded. Initializes a new instance of the VersionCommentsForm class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CommentsValue |
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
EmailValue |
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
NameValue |
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PhoneValue |
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
TitleValue |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

VersionCommentsForm Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


VersionCommentsForm Constructor

Overload List

Initializes a new instance of the VersionCommentsForm class.

public VersionCommentsForm();

public VersionCommentsForm(String);

See Also

VersionCommentsForm Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


VersionCommentsForm Constructor (String)

public VersionCommentsForm(
String Changes
);

See Also

VersionCommentsForm Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | VersionCommentsForm Constructor Overload List


VersionCommentsForm Constructor ()

Initializes a new instance of the VersionCommentsForm class.

public VersionCommentsForm();

See Also

VersionCommentsForm Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | VersionCommentsForm Constructor Overload List


VersionCommentsForm Properties

The properties of the VersionCommentsForm class are listed below. For a complete list of VersionCommentsForm class members, see the VersionCommentsForm Members topic.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CommentsValue |
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
EmailValue |
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
NameValue |
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PhoneValue |
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
TitleValue |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

VersionCommentsForm Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


CommentsValue Property

Aptify 5.0 Software Development Kit (SDK)

VersionCommentsForm.CommentsValue Property

public String CommentsValue {get;}

See Also

VersionCommentsForm Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


EmailValue Property

Aptify 5.0 Software Development Kit (SDK)

VersionCommentsForm.EmailValue Property

public String EmailValue {get;}

See Also

VersionCommentsForm Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


NameValue Property

Aptify 5.0 Software Development Kit (SDK)

VersionCommentsForm.NameValue Property

public String NameValue {get;}

See Also

VersionCommentsForm Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


PhoneValue Property

Aptify 5.0 Software Development Kit (SDK)

VersionCommentsForm.PhoneValue Property

public String PhoneValue {get;}

See Also

VersionCommentsForm Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


TitleValue Property

Aptify 5.0 Software Development Kit (SDK)

VersionCommentsForm.TitleValue Property

public String TitleValue {get;}

See Also

VersionCommentsForm Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


VersionCommentsForm Methods

The methods of the VersionCommentsForm class are listed below. For a complete list of VersionCommentsForm class members, see the VersionCommentsForm Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

VersionCommentsForm Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

VersionCommentsForm.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

VersionCommentsForm Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


VersionCommentsForm.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

VersionCommentsForm Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | VersionCommentsForm.Dispose Overload List


WarningEventArgs Class

Provides attributes that are used in the case of a warning event being raised by the AptifyGenericEntityBase class or sub-classes.

For a list of all members of this type, see WarningEventArgs Members.

System.Object
EventArgs
WarningEventArgs

public class WarningEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntityBase (in AptifyGenericEntityBase.dll)

See Also

WarningEventArgs Members | Aptify.Framework.BusinessLogic.GenericEntity Namespace


WarningEventArgs Members

WarningEventArgs overview

Public Instance Constructors

WarningEventArgs Constructor

Public Instance Properties

DefaultResult
Handled
Message
Result
Style
Title

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

WarningEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


WarningEventArgs Constructor

public WarningEventArgs(
String Message,
String Title,
MsgBoxStyle Style,
MsgBoxResult DefaultResult
);

See Also

WarningEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


WarningEventArgs Properties

The properties of the WarningEventArgs class are listed below. For a complete list of WarningEventArgs class members, see the WarningEventArgs Members topic.

Public Instance Properties

DefaultResult
Handled
Message
Result
Style
Title

See Also

WarningEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


DefaultResult Property

Aptify 5.0 Software Development Kit (SDK)

WarningEventArgs.DefaultResult Property

public MsgBoxResult DefaultResult {get;}

See Also

WarningEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


Handled Property

Aptify 5.0 Software Development Kit (SDK)

WarningEventArgs.Handled Property

public Boolean Handled {get; set;}

See Also

WarningEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


Message Property

Aptify 5.0 Software Development Kit (SDK)

WarningEventArgs.Message Property

public String Message {get;}

See Also

WarningEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


Result Property

Aptify 5.0 Software Development Kit (SDK)

WarningEventArgs.Result Property

public MsgBoxResult Result {get; set;}

See Also

WarningEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


Style Property

Aptify 5.0 Software Development Kit (SDK)

WarningEventArgs.Style Property

public MsgBoxStyle Style {get;}

See Also

WarningEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


Title Property

Aptify 5.0 Software Development Kit (SDK)

WarningEventArgs.Title Property

public String Title {get;}

See Also

WarningEventArgs Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


WebServiceGenerator Class

This class is used to generate web services for each of the four major operations that are commonly needed, Create, Read, Update, Delete (CRUD) operations for any entity or set of entities.

For a list of all members of this type, see WebServiceGenerator Members.

System.Object
WebServiceGenerator

public class WebServiceGenerator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: WebServiceGenerator (in WebServiceGenerator.dll)

See Also

WebServiceGenerator Members | Aptify.Framework.BusinessLogic.GenericEntity Namespace


WebServiceGenerator Members

WebServiceGenerator overview

Public Instance Constructors

WebServiceGenerator Overloaded. Initializes a new instance of the WebServiceGenerator class.

Public Instance Properties

CreateRecordMethodName |
DeleteRecordMethodName |
ReadRecordMethodName |
UpdateRecordMethodName |
WebServiceNameSpace | Gets/Sets the name of the namespace to create web service server objects in

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GenerateCreateMethod | This method appends the Create Method for the ASP.NET Server side page to the string builder
GenerateDeleteMethod | This method appends the Read Method for the ASP.NET Server side page to the string builder
GenerateReadMethod | This method appends the Read Method for the ASP.NET Server side page to the string builder
GenerateUpdateMethod | This method appends the Update Method for the ASP.NET Server side page to the string builder
GenerateWebSerivce | Create a single web service
GenerateWebService | Overloaded. Create a single web service
GenerateWebServiceFileName | This member is responsible for generating a file name for the specified entity based on the provided entity name and output path
GenerateWebServices | Overloaded. Creates one or more web services based on the information provided
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
GetWebServiceText | Overloaded. This method returns the contents of the web service for the ASP.NET server file implementation.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

StatusUpdate

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetParameters | This method is responsible for outputing the parameters for the VB method for create/update
GetParamsHeader | This method is responsible for outputing the params for the xml meta-data for a method that is incorporated into the header for the class
GetSetValues | This method outputs a series of GE.SetValue() method calls for each updatable field in the entity and is used for create/update method generation.
MapFieldTypeToVBType | This method is responsible for returning the VB.NET datatype that maps to the specified field
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

WebServiceGenerator Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


WebServiceGenerator Constructor

Initializes a new instance of the WebServiceGenerator class.

Overload List

Initializes a new instance of the WebServiceGenerator class.

public WebServiceGenerator();

public WebServiceGenerator(AptifyApplication);

See Also

WebServiceGenerator Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


WebServiceGenerator Constructor ()

Initializes a new instance of the WebServiceGenerator class.

public WebServiceGenerator();

See Also

WebServiceGenerator Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | WebServiceGenerator Constructor Overload List


WebServiceGenerator Constructor (AptifyApplication)

public WebServiceGenerator(
AptifyApplication Application
);

See Also

WebServiceGenerator Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | WebServiceGenerator Constructor Overload List


WebServiceGenerator Properties

The properties of the WebServiceGenerator class are listed below. For a complete list of WebServiceGenerator class members, see the WebServiceGenerator Members topic.

Public Instance Properties

CreateRecordMethodName |
DeleteRecordMethodName |
ReadRecordMethodName |
UpdateRecordMethodName |
WebServiceNameSpace | Gets/Sets the name of the namespace to create web service server objects in

See Also

WebServiceGenerator Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


CreateRecordMethodName Property

Aptify 5.0 Software Development Kit (SDK)

WebServiceGenerator.CreateRecordMethodName Property

public virtual String CreateRecordMethodName {get;}

See Also

WebServiceGenerator Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


DeleteRecordMethodName Property

Aptify 5.0 Software Development Kit (SDK)

WebServiceGenerator.DeleteRecordMethodName Property

public virtual String DeleteRecordMethodName {get;}

See Also

WebServiceGenerator Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


ReadRecordMethodName Property

Aptify 5.0 Software Development Kit (SDK)

WebServiceGenerator.ReadRecordMethodName Property

public virtual String ReadRecordMethodName {get;}

See Also

WebServiceGenerator Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


UpdateRecordMethodName Property

Aptify 5.0 Software Development Kit (SDK)

WebServiceGenerator.UpdateRecordMethodName Property

public virtual String UpdateRecordMethodName {get;}

See Also

WebServiceGenerator Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


WebServiceNameSpace Property

Aptify 5.0 Software Development Kit (SDK)

WebServiceGenerator.WebServiceNameSpace Property

Gets/Sets the name of the namespace to create web service server objects in

public virtual String WebServiceNameSpace {get; set;}

Property Value

Remarks

See Also

WebServiceGenerator Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


WebServiceGenerator Methods

The methods of the WebServiceGenerator class are listed below. For a complete list of WebServiceGenerator class members, see the WebServiceGenerator Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GenerateCreateMethod | This method appends the Create Method for the ASP.NET Server side page to the string builder
GenerateDeleteMethod | This method appends the Read Method for the ASP.NET Server side page to the string builder
GenerateReadMethod | This method appends the Read Method for the ASP.NET Server side page to the string builder
GenerateUpdateMethod | This method appends the Update Method for the ASP.NET Server side page to the string builder
GenerateWebSerivce | Create a single web service
GenerateWebService | Overloaded. Create a single web service
GenerateWebServiceFileName | This member is responsible for generating a file name for the specified entity based on the provided entity name and output path
GenerateWebServices | Overloaded. Creates one or more web services based on the information provided
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
GetWebServiceText | Overloaded. This method returns the contents of the web service for the ASP.NET server file implementation.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetParameters | This method is responsible for outputing the parameters for the VB method for create/update
GetParamsHeader | This method is responsible for outputing the params for the xml meta-data for a method that is incorporated into the header for the class
GetSetValues | This method outputs a series of GE.SetValue() method calls for each updatable field in the entity and is used for create/update method generation.
MapFieldTypeToVBType | This method is responsible for returning the VB.NET datatype that maps to the specified field
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

WebServiceGenerator Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


WebServiceGenerator.GenerateCreateMethod Method

This method appends the Create Method for the ASP.NET Server side page to the string builder

public virtual void GenerateCreateMethod(
StringBuilder Builder,
String EntityName
);

Parameters

Builder
EntityName

Remarks

See Also

WebServiceGenerator Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


WebServiceGenerator.GenerateDeleteMethod Method

This method appends the Read Method for the ASP.NET Server side page to the string builder

public virtual void GenerateDeleteMethod(
StringBuilder Builder,
String EntityName
);

Parameters

Builder
EntityName

Remarks

See Also

WebServiceGenerator Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


WebServiceGenerator.GenerateReadMethod Method

This method appends the Read Method for the ASP.NET Server side page to the string builder

public virtual void GenerateReadMethod(
StringBuilder Builder,
String EntityName
);

Parameters

Builder
EntityName

Remarks

See Also

WebServiceGenerator Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


WebServiceGenerator.GenerateUpdateMethod Method

This method appends the Update Method for the ASP.NET Server side page to the string builder

public virtual void GenerateUpdateMethod(
StringBuilder Builder,
String EntityName
);

Parameters

Builder
EntityName

Remarks

See Also

WebServiceGenerator Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


WebServiceGenerator.GenerateWebSerivce Method

Create a single web service

public virtual bool GenerateWebSerivce(
String EntityName,
String OutputPath,
ref String& WebServiceFileName
);

Parameters

EntityName
OutputPath
WebServiceFileName

Return Value

Remarks

See Also

WebServiceGenerator Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GenerateWebService Method

Aptify 5.0 Software Development Kit (SDK)

WebServiceGenerator.GenerateWebService Method

Create a single web service

Overload List

Create a single web service

public virtual bool GenerateWebService(Int64,String,Boolean,Boolean,Boolean,Boolean,ref String&);

Create a single web service

public virtual bool GenerateWebService(Int64,String,ref String&);

public virtual bool GenerateWebService(String,String,Boolean,Boolean,Boolean,Boolean,ref String&);

See Also

WebServiceGenerator Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


WebServiceGenerator.GenerateWebService Method (Int64, String, Boolean, Boolean, Boolean, Boolean, String&)

Create a single web service

public virtual bool GenerateWebService(
Int64 EntityID,
String OutputPath,
Boolean Create,
Boolean Read,
Boolean Update,
Boolean Delete,
ref String& WebServiceFileName
);

Parameters

EntityID
OutputPath
Create
Read
Update
Delete
WebServiceFileName

Return Value

Remarks

See Also

WebServiceGenerator Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | WebServiceGenerator.GenerateWebService Overload List


WebServiceGenerator.GenerateWebService Method (Int64, String, String&)

Create a single web service

public virtual bool GenerateWebService(
Int64 EntityID,
String OutputPath,
ref String& WebServiceFileName
);

Parameters

EntityID
OutputPath
WebServiceFileName

Return Value

Remarks

See Also

WebServiceGenerator Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | WebServiceGenerator.GenerateWebService Overload List


WebServiceGenerator.GenerateWebService Method (String, String, Boolean, Boolean, Boolean, Boolean, String&)

public virtual bool GenerateWebService(
String EntityName,
String OutputPath,
Boolean Create,
Boolean Read,
Boolean Update,
Boolean Delete,
ref String& WebServiceFileName
);

See Also

WebServiceGenerator Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | WebServiceGenerator.GenerateWebService Overload List


WebServiceGenerator.GenerateWebServiceFileName Method

This member is responsible for generating a file name for the specified entity based on the provided entity name and output path

public virtual string GenerateWebServiceFileName(
String EntityName,
String OutputPath
);

Parameters

EntityName
OutputPath

Return Value

Remarks

See Also

WebServiceGenerator Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GenerateWebServices Method

Aptify 5.0 Software Development Kit (SDK)

WebServiceGenerator.GenerateWebServices Method

Creates one or more web services based on the information provided

Overload List

Creates one or more web services based on the information provided

public virtual bool GenerateWebServices(List<T>,String);

Creates one or more web services based on the information provided

public virtual bool GenerateWebServices(List<T>,String,Boolean,Boolean,Boolean,Boolean);

Creates one or more web services based on the information provided

public virtual bool GenerateWebServices(List<T>,String);

Creates one or more web services based on the information provided

public virtual bool GenerateWebServices(List<T>,String,Boolean,Boolean,Boolean,Boolean);

See Also

WebServiceGenerator Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


WebServiceGenerator.GenerateWebServices Method (List<T>, String)

Creates one or more web services based on the information provided

public virtual bool GenerateWebServices(
List<T> EntityIDs,
String OutputPath
);

Parameters

EntityIDs
OutputPath

Return Value

Remarks

See Also

WebServiceGenerator Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | WebServiceGenerator.GenerateWebServices Overload List


WebServiceGenerator.GenerateWebServices Method (List<T>, String, Boolean, Boolean, Boolean, Boolean)

Creates one or more web services based on the information provided

public virtual bool GenerateWebServices(
List<T> EntityIDs,
String OutputPath,
Boolean Create,
Boolean Read,
Boolean Update,
Boolean Delete
);

Parameters

EntityIDs
OutputPath
Create
Read
Update
Delete

Return Value

Remarks

See Also

WebServiceGenerator Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | WebServiceGenerator.GenerateWebServices Overload List


WebServiceGenerator.GenerateWebServices Method (List<T>, String)

Creates one or more web services based on the information provided

public virtual bool GenerateWebServices(
List<T> EntityNames,
String OutputPath
);

Parameters

EntityNames
OutputPath

Return Value

Remarks

See Also

WebServiceGenerator Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | WebServiceGenerator.GenerateWebServices Overload List


WebServiceGenerator.GenerateWebServices Method (List<T>, String, Boolean, Boolean, Boolean, Boolean)

Creates one or more web services based on the information provided

public virtual bool GenerateWebServices(
List<T> EntityNames,
String OutputPath,
Boolean Create,
Boolean Read,
Boolean Update,
Boolean Delete
);

Parameters

EntityNames
OutputPath
Create
Read
Update
Delete

Return Value

Remarks

See Also

WebServiceGenerator Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | WebServiceGenerator.GenerateWebServices Overload List


WebServiceGenerator.GetParameters Method

This method is responsible for outputing the parameters for the VB method for create/update

protected virtual void GetParameters(
StringBuilder Builder,
String EntityName
);

Parameters

Builder
EntityName

Remarks

See Also

WebServiceGenerator Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


WebServiceGenerator.GetParamsHeader Method

This method is responsible for outputing the params for the xml meta-data for a method that is incorporated into the header for the class

protected virtual void GetParamsHeader(
StringBuilder Builder,
String EntityName
);

Parameters

Builder
EntityName

Remarks

See Also

WebServiceGenerator Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


WebServiceGenerator.GetSetValues Method

This method outputs a series of GE.SetValue() method calls for each updatable field in the entity and is used for create/update method generation.

protected virtual void GetSetValues(
StringBuilder Builder,
String EntityName
);

Parameters

Builder
EntityName

Remarks

See Also

WebServiceGenerator Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


GetWebServiceText Method

Aptify 5.0 Software Development Kit (SDK)

WebServiceGenerator.GetWebServiceText Method

Overload List

public virtual string GetWebServiceText(Int64,Boolean,Boolean,Boolean,Boolean);

This method returns the contents of the web service for the ASP.NET server file implementation.

public virtual string GetWebServiceText(String,Boolean,Boolean,Boolean,Boolean,ref String&);

See Also

WebServiceGenerator Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


WebServiceGenerator.GetWebServiceText Method (Int64, Boolean, Boolean, Boolean, Boolean)

public virtual string GetWebServiceText(
Int64 EntityID,
Boolean Create,
Boolean Read,
Boolean Update,
Boolean Delete
);

See Also

WebServiceGenerator Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | WebServiceGenerator.GetWebServiceText Overload List


WebServiceGenerator.GetWebServiceText Method (String, Boolean, Boolean, Boolean, Boolean, String&)

This method returns the contents of the web service for the ASP.NET server file implementation.

public virtual string GetWebServiceText(
String EntityName,
Boolean Create,
Boolean Read,
Boolean Update,
Boolean Delete,
ref String& ClassName
);

Parameters

EntityName
Create
Read
Update
Delete
ClassName

Return Value

Remarks

See Also

WebServiceGenerator Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | WebServiceGenerator.GetWebServiceText Overload List


WebServiceGenerator.MapFieldTypeToVBType Method

This method is responsible for returning the VB.NET datatype that maps to the specified field

protected virtual string MapFieldTypeToVBType(
EntityFieldMetaData field
);

Parameters

field

Return Value

Remarks

See Also

WebServiceGenerator Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


WebServiceGenerator Events

The events of the WebServiceGenerator class are listed below. For a complete list of WebServiceGenerator class members, see the WebServiceGenerator Members topic.

Public Instance Events

StatusUpdate

See Also

WebServiceGenerator Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


WebServiceGenerator.WebServiceGenerator.StatusUpdateEventHandler Event

public event WebServiceGenerator.StatusUpdateEventHandler StatusUpdate;

See Also

WebServiceGenerator Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


WebServiceGenerator.StatusUpdateEventHandler Delegate

public delegate void WebServiceGenerator.StatusUpdateEventHandler(
Int32 CurrentService,
Int32 TotalServices,
String CurrentServiceName,
ref Boolean& Cancel
);

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: WebServiceGenerator (in WebServiceGenerator.dll)

See Also

Aptify.Framework.BusinessLogic.GenericEntity Namespace


XMLParser Class

For a list of all members of this type, see XMLParser Members.

System.Object
XMLParser

public class XMLParser

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity

Assembly: AptifyGenericEntity (in AptifyGenericEntity.dll)

See Also

XMLParser Members | Aptify.Framework.BusinessLogic.GenericEntity Namespace


XMLParser Members

XMLParser overview

Public Instance Constructors

XMLParser Constructor Initializes a new instance of the XMLParser class.

Public Instance Properties

UserCredential

Public Instance Methods

CreateXMLStream | Overloaded.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
LoadGEFromXMLReader | Overloaded.
LoadGEFromXMLString | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XMLParser Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


XMLParser Constructor

Initializes a new instance of the XMLParser class.

public XMLParser();

See Also

XMLParser Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


XMLParser Properties

The properties of the XMLParser class are listed below. For a complete list of XMLParser class members, see the XMLParser Members topic.

Public Instance Properties

UserCredential

See Also

XMLParser Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


UserCredential Property

Aptify 5.0 Software Development Kit (SDK)

XMLParser.UserCredential Property

public UserCredentials UserCredential {get; set;}

See Also

XMLParser Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


XMLParser Methods

The methods of the XMLParser class are listed below. For a complete list of XMLParser class members, see the XMLParser Members topic.

Public Instance Methods

CreateXMLStream | Overloaded.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
LoadGEFromXMLReader | Overloaded.
LoadGEFromXMLString | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XMLParser Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


CreateXMLStream Method

Aptify 5.0 Software Development Kit (SDK)

XMLParser.CreateXMLStream Method

Overload List

public bool CreateXMLStream(ref MemoryStream&,AptifyGenericEntityBase,Boolean,Boolean);

public bool CreateXMLStream(ref String&,AptifyGenericEntityBase,Boolean,Boolean);

See Also

XMLParser Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


XMLParser.CreateXMLStream Method (MemoryStream&, AptifyGenericEntityBase, Boolean, Boolean)

public bool CreateXMLStream(
ref MemoryStream& XML,
AptifyGenericEntityBase GE,
Boolean IncludeObjectTag,
Boolean IncrementVersion
);

See Also

XMLParser Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | XMLParser.CreateXMLStream Overload List


XMLParser.CreateXMLStream Method (String&, AptifyGenericEntityBase, Boolean, Boolean)

public bool CreateXMLStream(
ref String& XML,
AptifyGenericEntityBase GE,
Boolean IncludeObject,
Boolean IncrementVersion
);

See Also

XMLParser Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | XMLParser.CreateXMLStream Overload List


LoadGEFromXMLReader Method

Aptify 5.0 Software Development Kit (SDK)

XMLParser.LoadGEFromXMLReader Method

Overload List

public bool LoadGEFromXMLReader(XmlReader,ref AptifyGenericEntityBase&);

public bool LoadGEFromXMLReader(XmlReader,ref AptifyGenericEntityBase&,Boolean);

See Also

XMLParser Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


XMLParser.LoadGEFromXMLReader Method (XmlReader, AptifyGenericEntityBase&)

public bool LoadGEFromXMLReader(
XmlReader XMLReader,
ref AptifyGenericEntityBase& GE
);

See Also

XMLParser Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | XMLParser.LoadGEFromXMLReader Overload List


XMLParser.LoadGEFromXMLReader Method (XmlReader, AptifyGenericEntityBase&, Boolean)

public bool LoadGEFromXMLReader(
XmlReader XMLReader,
ref AptifyGenericEntityBase& GE,
Boolean MergeSubTypes
);

See Also

XMLParser Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | XMLParser.LoadGEFromXMLReader Overload List


LoadGEFromXMLString Method

Aptify 5.0 Software Development Kit (SDK)

XMLParser.LoadGEFromXMLString Method

Overload List

public bool LoadGEFromXMLString(String,ref AptifyGenericEntityBase&);

public bool LoadGEFromXMLString(String,ref AptifyGenericEntityBase&,Boolean);

See Also

XMLParser Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace


XMLParser.LoadGEFromXMLString Method (String, AptifyGenericEntityBase&)

public bool LoadGEFromXMLString(
String XML,
ref AptifyGenericEntityBase& GE
);

See Also

XMLParser Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | XMLParser.LoadGEFromXMLString Overload List


XMLParser.LoadGEFromXMLString Method (String, AptifyGenericEntityBase&, Boolean)

public bool LoadGEFromXMLString(
String XML,
ref AptifyGenericEntityBase& GE,
Boolean MergeSubTypes
);

See Also

XMLParser Class | Aptify.Framework.BusinessLogic.GenericEntity Namespace | XMLParser.LoadGEFromXMLString Overload List


Aptify.Framework.BusinessLogic.GenericEntity.Generated

Aptify 5.0 Software Development Kit (SDK)

Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace

The Aptify 5.0 release includes a strongly typed entity object generator. This generator is capable of acting upon any entity in the system and results in the generation of a strongly typed entity object for the entity as well as all related sub-type records. This functionality is available in the form of a wizard rather than as a process that runs automatically for each entity save. This facilitates a phased approach to rolling out this functionality to the user community and is more conservative than attempting to roll this directly into the entity save process. Also, the generator has been written as a process component, so a developer could hook up a process flow to the Entity Save process itself and eliminate the need to run the wizard separately. In addition to generating the strongly typed object code, the generator compiles the dot net assembly using the Microsoft .NET Framework build tools (meaning that Visual Studio is not required on the system), uploads the generated object to the Object Repository, and creates an entity plug in record referencing the generated object if no existing plug in object is registered with the entity. In Aptify 5.0, Aptify has generated strongly typed entity objects for the following entities (as well as all of the sub-types associated with these entities). Since most of these entities had pre-existing plug in entity objects, we also modified the entity objects to inherit from the strongly typed entity object for that entity rather than directly from the Generic Entity. The entities included are: Companies, Contact Logs, Employees, Orders, Organizations, Payments, Persons, Scheduled Transactions, and Subscriptions.

Namespace hierarchy

Classes

Class | Description
CompaniesClass |
CompanyAccountManagersClass |
CompanyAddressClass |
CompanyPhoneClass |
CompanyProductCodesClass |
CompanyRelationshipsClass |
CompanySavedPaymentMethodsClass |
CompanyTaxExemptCodesClass |
ContactLogClass |
ContactLogLinksClass |
EmployeesClass |
EmployeeSkillsClass |
OrderCurrencySpotRateClass |
OrderGLEntryClass |
OrderInvAllocationClass |
OrderLinesClass |
OrderLineTaxesClass |
OrderPaymentScheduleClass |
OrdersClass |
OrderShipmentsClass |
OrderShipmentTaxesClass |
OrganizationAddressesClass |
OrganizationGLAccountsClass |
OrganizationInterCompanyGLClass |
OrganizationsClass |
PaymentAuthorizationsClass |
PaymentGLEntryClass |
PaymentLinesClass |
PaymentsClass |
PersonAccountManagersClass |
PersonAddressClass |
PersonCompaniesClass |
PersonCompanyFunctionsClass |
PersonEducationClass |
PersonFunctionsClass |
PersonPhoneClass |
PersonRelationshipsClass |
PersonSavedPaymentMethodsClass |
PersonsClass |
PersonTaxExemptCodesClass |
ScheduledTransactionAccountEntriesClass |
ScheduledTransactionsClass |
SubscriptionDeliveryLogClass |
SubscriptionDeliveryScheduleClass |
SubscriptionPurchasesClass |
SubscriptionsClass |


CompaniesClass Class

For a list of all members of this type, see CompaniesClass Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
CompaniesClass
CompanyObject

public class CompaniesClass : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity.Generated

Assembly: Aptify.Framework.BusinessLogic.GenericEntity.Generated.Companies (in Aptify.Framework.BusinessLogic.GenericEntity.Generated.Companies.dll)

See Also

CompaniesClass Members | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CompaniesClass Members

CompaniesClass overview

Public Instance Constructors

CompaniesClass Constructor Initializes a new instance of the CompaniesClass class.

Public Instance Properties

AbbreviatedName |
AddressID |
AddressIDObject |
AddressLine1 |
AddressLine2 |
AddressLine3 |
AddressLine4 |
Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
APVendorID |
Atmosphere |
BillingAddressID |
BillingAddressIDObject |
BillingAddressLine1 |
BillingAddressLine2 |
BillingAddressLine3 |
BillingAddressLine4 |
BillingCity |
BillingCountry |
BillingCounty |
BillingState |
BillingTerms |
BillingZipCode |
BillingZipCode5Numeric |
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
City |
Comments |
CompanyType |
CompanyTypeID |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
Country |
CountryCodeID |
County |
CountyDistrict |
CreditLimit |
CreditLimitCurrencyTypeID |
CreditStatus |
CreditStatusID |
CRRT |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DateCreated |
DateUpdated |
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DirDescription |
Directions |
DirExclude |
DirLetter |
DirSort |
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
DivisionName |
DnBRating |
DomainName |
DuesCategory |
DuesCategoryID |
DuesPaidThru |
EmailExclude |
EmailPattern |
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
Established |
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
FaxExclude |
FedTaxID |
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
GLOrderLevel |
GLOrderLevelID |
GLPaymentLevel |
GLPaymentLevelID |
ID |
InfoEmail |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
JobsEmail |
JoinDate |
LastDuesAmount |
LastDuesAmountCurrencyTypeID |
LastDuesPaymentDate |
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
MailCode |
MailExclude |
MainAccountManager |
MainAccountManagerID |
MainAreaCode |
MainCountryCode |
MainEmail |
MainFaxAreaCode |
MainFaxCountryCode |
MainFaxID |
MainFaxIDObject |
MainFaxNumber |
MainPhone |
MainPhoneID |
MainPhoneIDObject |
MemberType |
MemberTypeID |
Name |
NumberEmployees |
OfficeType |
OldID |
Organization |
OrganizationID |
OwnType |
Parent |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentID |
ParentMemberType |
ParentMemberTypeID |
ParentName |
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
POBox |
POBoxAddressID |
POBoxCity |
POBoxCountry |
POBoxCounty |
POBoxLine2 |
POBoxLine3 |
POBoxLine4 |
POBoxState |
POBoxZipCode |
POBoxZipCode5Numeric |
PreferredCurrencyType |
PreferredCurrencyTypeID |
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
PrimaryProductCode |
PrimaryProductCodeID |
PrimaryShareholder |
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Revenue |
RevenueCategory |
RevenueCategoryID |
RootCompany |
RootCompanyID |
RootMemberType |
RootMemberTypeID |
RootName |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SICCode |
State |
StateHouse |
StateSenate |
Status |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
TerminationDate |
UnpubRevenue |
USCongress |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.
VerifyStatus |
WebSite |
WhoCreated |
WhoUpdated |
ZipCode |
ZipCode5Numeric |

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
CompanyAccountManagers |
CompanyAccountManagersObject |
CompanyAddress |
CompanyAddressObject |
CompanyPhone |
CompanyPhoneObject |
CompanyProductCodes |
CompanyProductCodesObject |
CompanyRelationships |
CompanyRelationshipsObject |
CompanySavedPaymentMethods |
CompanySavedPaymentMethodsObject |
CompanyTaxExemptCodes |
CompanyTaxExemptCodesObject |
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CompaniesClass Constructor

Initializes a new instance of the CompaniesClass class.

public CompaniesClass();

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CompaniesClass Properties

The properties of the CompaniesClass class are listed below. For a complete list of CompaniesClass class members, see the CompaniesClass Members topic.

Public Instance Properties

AbbreviatedName |
AddressID |
AddressIDObject |
AddressLine1 |
AddressLine2 |
AddressLine3 |
AddressLine4 |
Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
APVendorID |
Atmosphere |
BillingAddressID |
BillingAddressIDObject |
BillingAddressLine1 |
BillingAddressLine2 |
BillingAddressLine3 |
BillingAddressLine4 |
BillingCity |
BillingCountry |
BillingCounty |
BillingState |
BillingTerms |
BillingZipCode |
BillingZipCode5Numeric |
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
City |
Comments |
CompanyType |
CompanyTypeID |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
Country |
CountryCodeID |
County |
CountyDistrict |
CreditLimit |
CreditLimitCurrencyTypeID |
CreditStatus |
CreditStatusID |
CRRT |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DateCreated |
DateUpdated |
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DirDescription |
Directions |
DirExclude |
DirLetter |
DirSort |
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
DivisionName |
DnBRating |
DomainName |
DuesCategory |
DuesCategoryID |
DuesPaidThru |
EmailExclude |
EmailPattern |
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
Established |
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
FaxExclude |
FedTaxID |
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
GLOrderLevel |
GLOrderLevelID |
GLPaymentLevel |
GLPaymentLevelID |
ID |
InfoEmail |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
JobsEmail |
JoinDate |
LastDuesAmount |
LastDuesAmountCurrencyTypeID |
LastDuesPaymentDate |
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
MailCode |
MailExclude |
MainAccountManager |
MainAccountManagerID |
MainAreaCode |
MainCountryCode |
MainEmail |
MainFaxAreaCode |
MainFaxCountryCode |
MainFaxID |
MainFaxIDObject |
MainFaxNumber |
MainPhone |
MainPhoneID |
MainPhoneIDObject |
MemberType |
MemberTypeID |
Name |
NumberEmployees |
OfficeType |
OldID |
Organization |
OrganizationID |
OwnType |
Parent |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentID |
ParentMemberType |
ParentMemberTypeID |
ParentName |
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
POBox |
POBoxAddressID |
POBoxCity |
POBoxCountry |
POBoxCounty |
POBoxLine2 |
POBoxLine3 |
POBoxLine4 |
POBoxState |
POBoxZipCode |
POBoxZipCode5Numeric |
PreferredCurrencyType |
PreferredCurrencyTypeID |
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
PrimaryProductCode |
PrimaryProductCodeID |
PrimaryShareholder |
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Revenue |
RevenueCategory |
RevenueCategoryID |
RootCompany |
RootCompanyID |
RootMemberType |
RootMemberTypeID |
RootName |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SICCode |
State |
StateHouse |
StateSenate |
Status |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
TerminationDate |
UnpubRevenue |
USCongress |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.
VerifyStatus |
WebSite |
WhoCreated |
WhoUpdated |
ZipCode |
ZipCode5Numeric |

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AbbreviatedName Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.AbbreviatedName Property

public virtual String AbbreviatedName {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AddressID Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.AddressID Property

public virtual Int32 AddressID {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AddressIDObject Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.AddressIDObject Property

public virtual AptifyGenericEntityBase AddressIDObject {get;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AddressLine1 Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.AddressLine1 Property

public virtual String AddressLine1 {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AddressLine2 Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.AddressLine2 Property

public virtual String AddressLine2 {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AddressLine3 Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.AddressLine3 Property

public virtual String AddressLine3 {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AddressLine4 Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.AddressLine4 Property

public virtual String AddressLine4 {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


APVendorID Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.APVendorID Property

public virtual String APVendorID {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Atmosphere Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.Atmosphere Property

public virtual String Atmosphere {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BillingAddressID Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.BillingAddressID Property

public virtual Int32 BillingAddressID {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BillingAddressIDObject Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.BillingAddressIDObject Property

public virtual AptifyGenericEntityBase BillingAddressIDObject {get;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BillingAddressLine1 Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.BillingAddressLine1 Property

public virtual String BillingAddressLine1 {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BillingAddressLine2 Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.BillingAddressLine2 Property

public virtual String BillingAddressLine2 {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BillingAddressLine3 Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.BillingAddressLine3 Property

public virtual String BillingAddressLine3 {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BillingAddressLine4 Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.BillingAddressLine4 Property

public virtual String BillingAddressLine4 {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BillingCity Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.BillingCity Property

public virtual String BillingCity {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BillingCountry Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.BillingCountry Property

public virtual String BillingCountry {get;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BillingCounty Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.BillingCounty Property

public virtual String BillingCounty {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BillingState Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.BillingState Property

public virtual String BillingState {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BillingTerms Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.BillingTerms Property

public virtual String BillingTerms {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BillingZipCode Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.BillingZipCode Property

public virtual String BillingZipCode {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BillingZipCode5Numeric Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.BillingZipCode5Numeric Property

public virtual Int32 BillingZipCode5Numeric {get;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


City Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.City Property

public virtual String City {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Comments Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.Comments Property

public virtual String Comments {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CompanyType Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.CompanyType Property

public virtual String CompanyType {get;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CompanyTypeID Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.CompanyTypeID Property

public virtual Int32 CompanyTypeID {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Country Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.Country Property

public virtual String Country {get;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CountryCodeID Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.CountryCodeID Property

public virtual Int32 CountryCodeID {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


County Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.County Property

public virtual String County {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CountyDistrict Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.CountyDistrict Property

public virtual String CountyDistrict {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CreditLimit Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.CreditLimit Property

public virtual Decimal CreditLimit {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CreditLimitCurrencyTypeID Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.CreditLimitCurrencyTypeID Property

public virtual Int32 CreditLimitCurrencyTypeID {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CreditStatus Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.CreditStatus Property

public virtual String CreditStatus {get;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CreditStatusID Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.CreditStatusID Property

public virtual Int32 CreditStatusID {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CRRT Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.CRRT Property

public virtual String CRRT {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


DateCreated Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.DateCreated Property

public virtual DateTime DateCreated {get;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


DateUpdated Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.DateUpdated Property

public virtual DateTime DateUpdated {get;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


DirDescription Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.DirDescription Property

public virtual String DirDescription {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Directions Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.Directions Property

public virtual String Directions {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


DirExclude Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.DirExclude Property

public virtual Boolean DirExclude {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


DirLetter Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.DirLetter Property

public virtual String DirLetter {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


DirSort Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.DirSort Property

public virtual String DirSort {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


DivisionName Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.DivisionName Property

public virtual String DivisionName {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


DnBRating Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.DnBRating Property

public virtual String DnBRating {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


DomainName Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.DomainName Property

public virtual String DomainName {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


DuesCategory Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.DuesCategory Property

public virtual String DuesCategory {get;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


DuesCategoryID Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.DuesCategoryID Property

public virtual Int32 DuesCategoryID {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


DuesPaidThru Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.DuesPaidThru Property

public virtual DateTime DuesPaidThru {get;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


EmailExclude Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.EmailExclude Property

public virtual Boolean EmailExclude {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


EmailPattern Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.EmailPattern Property

public virtual String EmailPattern {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Established Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.Established Property

public virtual DateTime Established {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


FaxExclude Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.FaxExclude Property

public virtual Boolean FaxExclude {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


FedTaxID Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.FedTaxID Property

public virtual String FedTaxID {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


GLOrderLevel Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.GLOrderLevel Property

public virtual String GLOrderLevel {get;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


GLOrderLevelID Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.GLOrderLevelID Property

public virtual Int32 GLOrderLevelID {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


GLPaymentLevel Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.GLPaymentLevel Property

public virtual String GLPaymentLevel {get;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


GLPaymentLevelID Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.GLPaymentLevelID Property

public virtual Int32 GLPaymentLevelID {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.ID Property

public virtual Int32 ID {get;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


InfoEmail Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.InfoEmail Property

public virtual String InfoEmail {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


JobsEmail Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.JobsEmail Property

public virtual String JobsEmail {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


JoinDate Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.JoinDate Property

public virtual DateTime JoinDate {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


LastDuesAmount Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.LastDuesAmount Property

public virtual Decimal LastDuesAmount {get;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


LastDuesAmountCurrencyTypeID Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.LastDuesAmountCurrencyTypeID Property

public virtual Int32 LastDuesAmountCurrencyTypeID {get;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


LastDuesPaymentDate Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.LastDuesPaymentDate Property

public virtual DateTime LastDuesPaymentDate {get;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


MailCode Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.MailCode Property

public virtual String MailCode {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


MailExclude Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.MailExclude Property

public virtual Boolean MailExclude {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


MainAccountManager Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.MainAccountManager Property

public virtual String MainAccountManager {get;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


MainAccountManagerID Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.MainAccountManagerID Property

public virtual Int32 MainAccountManagerID {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


MainAreaCode Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.MainAreaCode Property

public virtual String MainAreaCode {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


MainCountryCode Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.MainCountryCode Property

public virtual String MainCountryCode {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


MainEmail Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.MainEmail Property

public virtual String MainEmail {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


MainFaxAreaCode Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.MainFaxAreaCode Property

public virtual String MainFaxAreaCode {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


MainFaxCountryCode Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.MainFaxCountryCode Property

public virtual String MainFaxCountryCode {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


MainFaxID Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.MainFaxID Property

public virtual Int32 MainFaxID {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


MainFaxIDObject Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.MainFaxIDObject Property

public virtual AptifyGenericEntityBase MainFaxIDObject {get;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


MainFaxNumber Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.MainFaxNumber Property

public virtual String MainFaxNumber {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


MainPhone Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.MainPhone Property

public virtual String MainPhone {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


MainPhoneID Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.MainPhoneID Property

public virtual Int32 MainPhoneID {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


MainPhoneIDObject Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.MainPhoneIDObject Property

public virtual AptifyGenericEntityBase MainPhoneIDObject {get;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


MemberType Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.MemberType Property

public virtual String MemberType {get;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


MemberTypeID Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.MemberTypeID Property

public virtual Int32 MemberTypeID {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Name Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.Name Property

public virtual String Name {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


NumberEmployees Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.NumberEmployees Property

public virtual Int32 NumberEmployees {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OfficeType Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.OfficeType Property

public virtual String OfficeType {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OldID Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.OldID Property

public virtual String OldID {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Organization Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.Organization Property

public virtual String Organization {get;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrganizationID Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.OrganizationID Property

public virtual Int32 OrganizationID {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OwnType Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.OwnType Property

public virtual String OwnType {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Parent Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.Parent Property

public virtual String Parent {get;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ParentID Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.ParentID Property

public virtual Int32 ParentID {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ParentMemberType Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.ParentMemberType Property

public virtual String ParentMemberType {get;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ParentMemberTypeID Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.ParentMemberTypeID Property

public virtual String ParentMemberTypeID {get;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ParentName Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.ParentName Property

public virtual String ParentName {get;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


POBox Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.POBox Property

public virtual String POBox {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


POBoxAddressID Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.POBoxAddressID Property

public virtual Int32 POBoxAddressID {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


POBoxCity Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.POBoxCity Property

public virtual String POBoxCity {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


POBoxCountry Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.POBoxCountry Property

public virtual String POBoxCountry {get;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


POBoxCounty Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.POBoxCounty Property

public virtual String POBoxCounty {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


POBoxLine2 Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.POBoxLine2 Property

public virtual String POBoxLine2 {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


POBoxLine3 Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.POBoxLine3 Property

public virtual String POBoxLine3 {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


POBoxLine4 Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.POBoxLine4 Property

public virtual String POBoxLine4 {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


POBoxState Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.POBoxState Property

public virtual String POBoxState {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


POBoxZipCode Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.POBoxZipCode Property

public virtual String POBoxZipCode {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


POBoxZipCode5Numeric Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.POBoxZipCode5Numeric Property

public virtual Int32 POBoxZipCode5Numeric {get;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PreferredCurrencyType Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.PreferredCurrencyType Property

public virtual String PreferredCurrencyType {get;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PreferredCurrencyTypeID Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.PreferredCurrencyTypeID Property

public virtual Int32 PreferredCurrencyTypeID {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PrimaryProductCode Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.PrimaryProductCode Property

public virtual String PrimaryProductCode {get;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PrimaryProductCodeID Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.PrimaryProductCodeID Property

public virtual Int32 PrimaryProductCodeID {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PrimaryShareholder Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.PrimaryShareholder Property

public virtual String PrimaryShareholder {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Revenue Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.Revenue Property

public virtual Decimal Revenue {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


RevenueCategory Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.RevenueCategory Property

public virtual String RevenueCategory {get;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


RevenueCategoryID Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.RevenueCategoryID Property

public virtual Int32 RevenueCategoryID {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


RootCompany Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.RootCompany Property

public virtual String RootCompany {get;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


RootCompanyID Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.RootCompanyID Property

public virtual Int32 RootCompanyID {get;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


RootMemberType Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.RootMemberType Property

public virtual String RootMemberType {get;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


RootMemberTypeID Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.RootMemberTypeID Property

public virtual String RootMemberTypeID {get;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


RootName Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.RootName Property

public virtual String RootName {get;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


SICCode Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.SICCode Property

public virtual String SICCode {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


State Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.State Property

public virtual String State {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


StateHouse Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.StateHouse Property

public virtual String StateHouse {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


StateSenate Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.StateSenate Property

public virtual String StateSenate {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Status Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.Status Property

public virtual Int32 Status {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


TerminationDate Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.TerminationDate Property

public virtual DateTime TerminationDate {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


UnpubRevenue Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.UnpubRevenue Property

public virtual Decimal UnpubRevenue {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


USCongress Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.USCongress Property

public virtual String USCongress {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


VerifyStatus Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.VerifyStatus Property

public virtual String VerifyStatus {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


WebSite Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.WebSite Property

public virtual String WebSite {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


WhoCreated Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.WhoCreated Property

public virtual String WhoCreated {get;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


WhoUpdated Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.WhoUpdated Property

public virtual String WhoUpdated {get;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ZipCode Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.ZipCode Property

public virtual String ZipCode {get; set;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ZipCode5Numeric Property

Aptify 5.0 Software Development Kit (SDK)

CompaniesClass.ZipCode5Numeric Property

public virtual Int32 ZipCode5Numeric {get;}

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CompaniesClass Methods

The methods of the CompaniesClass class are listed below. For a complete list of CompaniesClass class members, see the CompaniesClass Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
CompanyAccountManagers |
CompanyAccountManagersObject |
CompanyAddress |
CompanyAddressObject |
CompanyPhone |
CompanyPhoneObject |
CompanyProductCodes |
CompanyProductCodesObject |
CompanyRelationships |
CompanyRelationshipsObject |
CompanySavedPaymentMethods |
CompanySavedPaymentMethodsObject |
CompanyTaxExemptCodes |
CompanyTaxExemptCodesObject |
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CompaniesClass.CompanyAccountManagers Method

public virtual CompanyAccountManagersClass CompanyAccountManagers(
Int32 Index
);

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CompaniesClass.CompanyAccountManagersObject Method

public virtual AptifySubTypeBase CompanyAccountManagersObject();

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CompaniesClass.CompanyAddress Method

public virtual CompanyAddressClass CompanyAddress(
Int32 Index
);

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CompaniesClass.CompanyAddressObject Method

public virtual AptifySubTypeBase CompanyAddressObject();

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CompaniesClass.CompanyPhone Method

public virtual CompanyPhoneClass CompanyPhone(
Int32 Index
);

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CompaniesClass.CompanyPhoneObject Method

public virtual AptifySubTypeBase CompanyPhoneObject();

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CompaniesClass.CompanyProductCodes Method

public virtual CompanyProductCodesClass CompanyProductCodes(
Int32 Index
);

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CompaniesClass.CompanyProductCodesObject Method

public virtual AptifySubTypeBase CompanyProductCodesObject();

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CompaniesClass.CompanyRelationships Method

public virtual CompanyRelationshipsClass CompanyRelationships(
Int32 Index
);

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CompaniesClass.CompanyRelationshipsObject Method

public virtual AptifySubTypeBase CompanyRelationshipsObject();

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CompaniesClass.CompanySavedPaymentMethods Method

public virtual CompanySavedPaymentMethodsClass CompanySavedPaymentMethods(
Int32 Index
);

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CompaniesClass.CompanySavedPaymentMethodsObject Method

public virtual AptifySubTypeBase CompanySavedPaymentMethodsObject();

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CompaniesClass.CompanyTaxExemptCodes Method

public virtual CompanyTaxExemptCodesClass CompanyTaxExemptCodes(
Int32 Index
);

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CompaniesClass.CompanyTaxExemptCodesObject Method

public virtual AptifySubTypeBase CompanyTaxExemptCodesObject();

See Also

CompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CompanyAccountManagersClass Class

For a list of all members of this type, see CompanyAccountManagersClass Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
CompanyAccountManagersClass

public class CompanyAccountManagersClass : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity.Generated

Assembly: Aptify.Framework.BusinessLogic.GenericEntity.Generated.Companies (in Aptify.Framework.BusinessLogic.GenericEntity.Generated.Companies.dll)

See Also

CompanyAccountManagersClass Members | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CompanyAccountManagersClass Members

CompanyAccountManagersClass overview

Public Instance Constructors

CompanyAccountManagersClass Constructor Initializes a new instance of the CompanyAccountManagersClass class.

Public Instance Properties

AccountManagerID |
AccountManagerID_Name |
Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
Comments |
CompanyID |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EndDate |
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
FunctionID |
FunctionID_Name |
ID |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
Organization |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Sequence |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
StartDate |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

CompanyAccountManagersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CompanyAccountManagersClass Constructor

Initializes a new instance of the CompanyAccountManagersClass class.

public CompanyAccountManagersClass();

See Also

CompanyAccountManagersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CompanyAccountManagersClass Properties

The properties of the CompanyAccountManagersClass class are listed below. For a complete list of CompanyAccountManagersClass class members, see the CompanyAccountManagersClass Members topic.

Public Instance Properties

AccountManagerID |
AccountManagerID_Name |
Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
Comments |
CompanyID |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EndDate |
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
FunctionID |
FunctionID_Name |
ID |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
Organization |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Sequence |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
StartDate |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

CompanyAccountManagersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AccountManagerID Property

Aptify 5.0 Software Development Kit (SDK)

CompanyAccountManagersClass.AccountManagerID Property

public virtual Int32 AccountManagerID {get; set;}

See Also

CompanyAccountManagersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AccountManagerID_Name Property

Aptify 5.0 Software Development Kit (SDK)

CompanyAccountManagersClass.AccountManagerID_Name Property

public virtual String AccountManagerID_Name {get;}

See Also

CompanyAccountManagersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Comments Property

Aptify 5.0 Software Development Kit (SDK)

CompanyAccountManagersClass.Comments Property

public virtual String Comments {get; set;}

See Also

CompanyAccountManagersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CompanyID Property

Aptify 5.0 Software Development Kit (SDK)

CompanyAccountManagersClass.CompanyID Property

public virtual Int32 CompanyID {get;}

See Also

CompanyAccountManagersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


EndDate Property

Aptify 5.0 Software Development Kit (SDK)

CompanyAccountManagersClass.EndDate Property

public virtual DateTime EndDate {get; set;}

See Also

CompanyAccountManagersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


FunctionID Property

Aptify 5.0 Software Development Kit (SDK)

CompanyAccountManagersClass.FunctionID Property

public virtual Int32 FunctionID {get; set;}

See Also

CompanyAccountManagersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


FunctionID_Name Property

Aptify 5.0 Software Development Kit (SDK)

CompanyAccountManagersClass.FunctionID_Name Property

public virtual String FunctionID_Name {get;}

See Also

CompanyAccountManagersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

CompanyAccountManagersClass.ID Property

public virtual Int32 ID {get;}

See Also

CompanyAccountManagersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Organization Property

Aptify 5.0 Software Development Kit (SDK)

CompanyAccountManagersClass.Organization Property

public virtual String Organization {get;}

See Also

CompanyAccountManagersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Sequence Property

Aptify 5.0 Software Development Kit (SDK)

CompanyAccountManagersClass.Sequence Property

public virtual Int32 Sequence {get;}

See Also

CompanyAccountManagersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


StartDate Property

Aptify 5.0 Software Development Kit (SDK)

CompanyAccountManagersClass.StartDate Property

public virtual DateTime StartDate {get; set;}

See Also

CompanyAccountManagersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CompanyAddressClass Class

For a list of all members of this type, see CompanyAddressClass Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
CompanyAddressClass

public class CompanyAddressClass : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity.Generated

Assembly: Aptify.Framework.BusinessLogic.GenericEntity.Generated.Companies (in Aptify.Framework.BusinessLogic.GenericEntity.Generated.Companies.dll)

See Also

CompanyAddressClass Members | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CompanyAddressClass Members

CompanyAddressClass overview

Public Instance Constructors

CompanyAddressClass Constructor Initializes a new instance of the CompanyAddressClass class.

Public Instance Properties

AddressID |
AddressLine1 |
AddressLine2 |
AddressLine3 |
AddressLine4 |
AddressTypeID |
AddressTypeID_Name |
Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
AreaCode |
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
City |
CompanyID |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
Country |
County |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultEndDate |
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DefaultSetting |
DefaultStartDate |
Description |
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
ID |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
Name |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
Phone |
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Sequence |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
State |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseAsPreferredDuringDateRange |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.
ZipCode |

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

CompanyAddressClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CompanyAddressClass Constructor

Initializes a new instance of the CompanyAddressClass class.

public CompanyAddressClass();

See Also

CompanyAddressClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CompanyAddressClass Properties

The properties of the CompanyAddressClass class are listed below. For a complete list of CompanyAddressClass class members, see the CompanyAddressClass Members topic.

Public Instance Properties

AddressID |
AddressLine1 |
AddressLine2 |
AddressLine3 |
AddressLine4 |
AddressTypeID |
AddressTypeID_Name |
Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
AreaCode |
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
City |
CompanyID |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
Country |
County |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultEndDate |
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DefaultSetting |
DefaultStartDate |
Description |
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
ID |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
Name |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
Phone |
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Sequence |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
State |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseAsPreferredDuringDateRange |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.
ZipCode |

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

CompanyAddressClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AddressID Property

Aptify 5.0 Software Development Kit (SDK)

CompanyAddressClass.AddressID Property

public virtual Int32 AddressID {get; set;}

See Also

CompanyAddressClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AddressLine1 Property

Aptify 5.0 Software Development Kit (SDK)

CompanyAddressClass.AddressLine1 Property

public virtual String AddressLine1 {get; set;}

See Also

CompanyAddressClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AddressLine2 Property

Aptify 5.0 Software Development Kit (SDK)

CompanyAddressClass.AddressLine2 Property

public virtual String AddressLine2 {get; set;}

See Also

CompanyAddressClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AddressLine3 Property

Aptify 5.0 Software Development Kit (SDK)

CompanyAddressClass.AddressLine3 Property

public virtual String AddressLine3 {get; set;}

See Also

CompanyAddressClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AddressLine4 Property

Aptify 5.0 Software Development Kit (SDK)

CompanyAddressClass.AddressLine4 Property

public virtual String AddressLine4 {get; set;}

See Also

CompanyAddressClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AddressTypeID Property

Aptify 5.0 Software Development Kit (SDK)

CompanyAddressClass.AddressTypeID Property

public virtual Int32 AddressTypeID {get; set;}

See Also

CompanyAddressClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AddressTypeID_Name Property

Aptify 5.0 Software Development Kit (SDK)

CompanyAddressClass.AddressTypeID_Name Property

public virtual String AddressTypeID_Name {get;}

See Also

CompanyAddressClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AreaCode Property

Aptify 5.0 Software Development Kit (SDK)

CompanyAddressClass.AreaCode Property

public virtual String AreaCode {get; set;}

See Also

CompanyAddressClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


City Property

Aptify 5.0 Software Development Kit (SDK)

CompanyAddressClass.City Property

public virtual String City {get; set;}

See Also

CompanyAddressClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CompanyID Property

Aptify 5.0 Software Development Kit (SDK)

CompanyAddressClass.CompanyID Property

public virtual Int32 CompanyID {get;}

See Also

CompanyAddressClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Country Property

Aptify 5.0 Software Development Kit (SDK)

CompanyAddressClass.Country Property

public virtual String Country {get;}

See Also

CompanyAddressClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


County Property

Aptify 5.0 Software Development Kit (SDK)

CompanyAddressClass.County Property

public virtual String County {get; set;}

See Also

CompanyAddressClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


DefaultEndDate Property

Aptify 5.0 Software Development Kit (SDK)

CompanyAddressClass.DefaultEndDate Property

public virtual DateTime DefaultEndDate {get; set;}

See Also

CompanyAddressClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


DefaultSetting Property

Aptify 5.0 Software Development Kit (SDK)

CompanyAddressClass.DefaultSetting Property

public virtual String DefaultSetting {get; set;}

See Also

CompanyAddressClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


DefaultStartDate Property

Aptify 5.0 Software Development Kit (SDK)

CompanyAddressClass.DefaultStartDate Property

public virtual DateTime DefaultStartDate {get; set;}

See Also

CompanyAddressClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Description Property

Aptify 5.0 Software Development Kit (SDK)

CompanyAddressClass.Description Property

public virtual String Description {get; set;}

See Also

CompanyAddressClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

CompanyAddressClass.ID Property

public virtual Int32 ID {get;}

See Also

CompanyAddressClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Name Property

Aptify 5.0 Software Development Kit (SDK)

CompanyAddressClass.Name Property

public virtual String Name {get; set;}

See Also

CompanyAddressClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Phone Property

Aptify 5.0 Software Development Kit (SDK)

CompanyAddressClass.Phone Property

public virtual String Phone {get; set;}

See Also

CompanyAddressClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Sequence Property

Aptify 5.0 Software Development Kit (SDK)

CompanyAddressClass.Sequence Property

public virtual Int32 Sequence {get;}

See Also

CompanyAddressClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


State Property

Aptify 5.0 Software Development Kit (SDK)

CompanyAddressClass.State Property

public virtual String State {get; set;}

See Also

CompanyAddressClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


UseAsPreferredDuringDateRange Property

Aptify 5.0 Software Development Kit (SDK)

CompanyAddressClass.UseAsPreferredDuringDateRange Property

public virtual Boolean UseAsPreferredDuringDateRange {get; set;}

See Also

CompanyAddressClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ZipCode Property

Aptify 5.0 Software Development Kit (SDK)

CompanyAddressClass.ZipCode Property

public virtual String ZipCode {get; set;}

See Also

CompanyAddressClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CompanyPhoneClass Class

For a list of all members of this type, see CompanyPhoneClass Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
CompanyPhoneClass

public class CompanyPhoneClass : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity.Generated

Assembly: Aptify.Framework.BusinessLogic.GenericEntity.Generated.Companies (in Aptify.Framework.BusinessLogic.GenericEntity.Generated.Companies.dll)

See Also

CompanyPhoneClass Members | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CompanyPhoneClass Members

CompanyPhoneClass overview

Public Instance Constructors

CompanyPhoneClass Constructor Initializes a new instance of the CompanyPhoneClass class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
AreaCode |
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
CompanyID |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CountryCode |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
ID |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
Name |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
Phone |
PhoneExtension |
PhoneID |
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Sequence |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

CompanyPhoneClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CompanyPhoneClass Constructor

Initializes a new instance of the CompanyPhoneClass class.

public CompanyPhoneClass();

See Also

CompanyPhoneClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CompanyPhoneClass Properties

The properties of the CompanyPhoneClass class are listed below. For a complete list of CompanyPhoneClass class members, see the CompanyPhoneClass Members topic.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
AreaCode |
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
CompanyID |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CountryCode |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
ID |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
Name |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
Phone |
PhoneExtension |
PhoneID |
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Sequence |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

CompanyPhoneClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AreaCode Property

Aptify 5.0 Software Development Kit (SDK)

CompanyPhoneClass.AreaCode Property

public virtual String AreaCode {get; set;}

See Also

CompanyPhoneClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CompanyID Property

Aptify 5.0 Software Development Kit (SDK)

CompanyPhoneClass.CompanyID Property

public virtual Int32 CompanyID {get;}

See Also

CompanyPhoneClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CountryCode Property

Aptify 5.0 Software Development Kit (SDK)

CompanyPhoneClass.CountryCode Property

public virtual String CountryCode {get; set;}

See Also

CompanyPhoneClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

CompanyPhoneClass.ID Property

public virtual Int32 ID {get;}

See Also

CompanyPhoneClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Name Property

Aptify 5.0 Software Development Kit (SDK)

CompanyPhoneClass.Name Property

public virtual String Name {get; set;}

See Also

CompanyPhoneClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Phone Property

Aptify 5.0 Software Development Kit (SDK)

CompanyPhoneClass.Phone Property

public virtual String Phone {get; set;}

See Also

CompanyPhoneClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PhoneExtension Property

Aptify 5.0 Software Development Kit (SDK)

CompanyPhoneClass.PhoneExtension Property

public virtual String PhoneExtension {get; set;}

See Also

CompanyPhoneClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PhoneID Property

Aptify 5.0 Software Development Kit (SDK)

CompanyPhoneClass.PhoneID Property

public virtual Int32 PhoneID {get; set;}

See Also

CompanyPhoneClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Sequence Property

Aptify 5.0 Software Development Kit (SDK)

CompanyPhoneClass.Sequence Property

public virtual Int32 Sequence {get;}

See Also

CompanyPhoneClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CompanyProductCodesClass Class

For a list of all members of this type, see CompanyProductCodesClass Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
CompanyProductCodesClass

public class CompanyProductCodesClass : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity.Generated

Assembly: Aptify.Framework.BusinessLogic.GenericEntity.Generated.Companies (in Aptify.Framework.BusinessLogic.GenericEntity.Generated.Companies.dll)

See Also

CompanyProductCodesClass Members | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CompanyProductCodesClass Members

CompanyProductCodesClass overview

Public Instance Constructors

CompanyProductCodesClass Constructor Initializes a new instance of the CompanyProductCodesClass class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
CompanyID |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DateStarted |
DateStopped |
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
ID |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PercentOfRevenue |
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
ProductCode |
ProductCodeID |
ProductCodeID_Name |
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Sequence |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

CompanyProductCodesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CompanyProductCodesClass Constructor

Initializes a new instance of the CompanyProductCodesClass class.

public CompanyProductCodesClass();

See Also

CompanyProductCodesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CompanyProductCodesClass Properties

The properties of the CompanyProductCodesClass class are listed below. For a complete list of CompanyProductCodesClass class members, see the CompanyProductCodesClass Members topic.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
CompanyID |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DateStarted |
DateStopped |
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
ID |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PercentOfRevenue |
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
ProductCode |
ProductCodeID |
ProductCodeID_Name |
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Sequence |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

CompanyProductCodesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CompanyID Property

Aptify 5.0 Software Development Kit (SDK)

CompanyProductCodesClass.CompanyID Property

public virtual Int32 CompanyID {get;}

See Also

CompanyProductCodesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


DateStarted Property

Aptify 5.0 Software Development Kit (SDK)

CompanyProductCodesClass.DateStarted Property

public virtual DateTime DateStarted {get; set;}

See Also

CompanyProductCodesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


DateStopped Property

Aptify 5.0 Software Development Kit (SDK)

CompanyProductCodesClass.DateStopped Property

public virtual DateTime DateStopped {get; set;}

See Also

CompanyProductCodesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

CompanyProductCodesClass.ID Property

public virtual Int32 ID {get;}

See Also

CompanyProductCodesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PercentOfRevenue Property

Aptify 5.0 Software Development Kit (SDK)

CompanyProductCodesClass.PercentOfRevenue Property

public virtual Int32 PercentOfRevenue {get; set;}

See Also

CompanyProductCodesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ProductCode Property

Aptify 5.0 Software Development Kit (SDK)

CompanyProductCodesClass.ProductCode Property

public virtual String ProductCode {get;}

See Also

CompanyProductCodesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ProductCodeID Property

Aptify 5.0 Software Development Kit (SDK)

CompanyProductCodesClass.ProductCodeID Property

public virtual Int32 ProductCodeID {get; set;}

See Also

CompanyProductCodesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ProductCodeID_Name Property

Aptify 5.0 Software Development Kit (SDK)

CompanyProductCodesClass.ProductCodeID_Name Property

public virtual String ProductCodeID_Name {get;}

See Also

CompanyProductCodesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Sequence Property

Aptify 5.0 Software Development Kit (SDK)

CompanyProductCodesClass.Sequence Property

public virtual Int32 Sequence {get;}

See Also

CompanyProductCodesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CompanyRelationshipsClass Class

For a list of all members of this type, see CompanyRelationshipsClass Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
CompanyRelationshipsClass

public class CompanyRelationshipsClass : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity.Generated

Assembly: Aptify.Framework.BusinessLogic.GenericEntity.Generated.Companies (in Aptify.Framework.BusinessLogic.GenericEntity.Generated.Companies.dll)

See Also

CompanyRelationshipsClass Members | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CompanyRelationshipsClass Members

CompanyRelationshipsClass overview

Public Instance Constructors

CompanyRelationshipsClass Constructor Initializes a new instance of the CompanyRelationshipsClass class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
Comments |
CompanyID |
CompanyRelationshipTypeID |
CompanyRelationshipTypeID_Name |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EndDate |
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
ID |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RelatedCompanyID |
RelatedCompanyID_Name |
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Sequence |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
StartDate |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

CompanyRelationshipsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CompanyRelationshipsClass Constructor

Initializes a new instance of the CompanyRelationshipsClass class.

public CompanyRelationshipsClass();

See Also

CompanyRelationshipsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CompanyRelationshipsClass Properties

The properties of the CompanyRelationshipsClass class are listed below. For a complete list of CompanyRelationshipsClass class members, see the CompanyRelationshipsClass Members topic.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
Comments |
CompanyID |
CompanyRelationshipTypeID |
CompanyRelationshipTypeID_Name |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EndDate |
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
ID |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RelatedCompanyID |
RelatedCompanyID_Name |
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Sequence |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
StartDate |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

CompanyRelationshipsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Comments Property

Aptify 5.0 Software Development Kit (SDK)

CompanyRelationshipsClass.Comments Property

public virtual String Comments {get; set;}

See Also

CompanyRelationshipsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CompanyID Property

Aptify 5.0 Software Development Kit (SDK)

CompanyRelationshipsClass.CompanyID Property

public virtual Int32 CompanyID {get;}

See Also

CompanyRelationshipsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CompanyRelationshipTypeID Property

Aptify 5.0 Software Development Kit (SDK)

CompanyRelationshipsClass.CompanyRelationshipTypeID Property

public virtual Int32 CompanyRelationshipTypeID {get; set;}

See Also

CompanyRelationshipsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CompanyRelationshipTypeID_Name Property

Aptify 5.0 Software Development Kit (SDK)

CompanyRelationshipsClass.CompanyRelationshipTypeID_Name Property

public virtual String CompanyRelationshipTypeID_Name {get;}

See Also

CompanyRelationshipsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


EndDate Property

Aptify 5.0 Software Development Kit (SDK)

CompanyRelationshipsClass.EndDate Property

public virtual DateTime EndDate {get; set;}

See Also

CompanyRelationshipsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

CompanyRelationshipsClass.ID Property

public virtual Int32 ID {get;}

See Also

CompanyRelationshipsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


RelatedCompanyID Property

Aptify 5.0 Software Development Kit (SDK)

CompanyRelationshipsClass.RelatedCompanyID Property

public virtual Int32 RelatedCompanyID {get; set;}

See Also

CompanyRelationshipsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


RelatedCompanyID_Name Property

Aptify 5.0 Software Development Kit (SDK)

CompanyRelationshipsClass.RelatedCompanyID_Name Property

public virtual String RelatedCompanyID_Name {get;}

See Also

CompanyRelationshipsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Sequence Property

Aptify 5.0 Software Development Kit (SDK)

CompanyRelationshipsClass.Sequence Property

public virtual Int32 Sequence {get;}

See Also

CompanyRelationshipsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


StartDate Property

Aptify 5.0 Software Development Kit (SDK)

CompanyRelationshipsClass.StartDate Property

public virtual DateTime StartDate {get; set;}

See Also

CompanyRelationshipsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CompanySavedPaymentMethodsClass Class

For a list of all members of this type, see CompanySavedPaymentMethodsClass Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
CompanySavedPaymentMethodsClass
CompanySPMEntity

public class CompanySavedPaymentMethodsClass : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity.Generated

Assembly: Aptify.Framework.BusinessLogic.GenericEntity.Generated.Companies (in Aptify.Framework.BusinessLogic.GenericEntity.Generated.Companies.dll)

See Also

CompanySavedPaymentMethodsClass Members | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CompanySavedPaymentMethodsClass Members

CompanySavedPaymentMethodsClass overview

Public Instance Constructors

CompanySavedPaymentMethodsClass Constructor Initializes a new instance of the CompanySavedPaymentMethodsClass class.

Public Instance Properties

ABA |
AccountNumber |
Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
Bank |
BranchName |
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
CCAccountNumber |
CCExpireDate |
CCPartial |
CompanyID |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CreditOrderID |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
Description |
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
DueDate |
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EndDate |
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
ID |
IsActive |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
Name |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PaymentInformationID |
PaymentType |
PaymentTypeID |
PONumber |
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Sequence |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
StartDate |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
Terms |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

CompanySavedPaymentMethodsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CompanySavedPaymentMethodsClass Constructor

Initializes a new instance of the CompanySavedPaymentMethodsClass class.

public CompanySavedPaymentMethodsClass();

See Also

CompanySavedPaymentMethodsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CompanySavedPaymentMethodsClass Properties

The properties of the CompanySavedPaymentMethodsClass class are listed below. For a complete list of CompanySavedPaymentMethodsClass class members, see the CompanySavedPaymentMethodsClass Members topic.

Public Instance Properties

ABA |
AccountNumber |
Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
Bank |
BranchName |
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
CCAccountNumber |
CCExpireDate |
CCPartial |
CompanyID |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CreditOrderID |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
Description |
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
DueDate |
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EndDate |
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
ID |
IsActive |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
Name |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PaymentInformationID |
PaymentType |
PaymentTypeID |
PONumber |
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Sequence |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
StartDate |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
Terms |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

CompanySavedPaymentMethodsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ABA Property

Aptify 5.0 Software Development Kit (SDK)

CompanySavedPaymentMethodsClass.ABA Property

public virtual String ABA {get; set;}

See Also

CompanySavedPaymentMethodsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AccountNumber Property

Aptify 5.0 Software Development Kit (SDK)

CompanySavedPaymentMethodsClass.AccountNumber Property

public virtual String AccountNumber {get; set;}

See Also

CompanySavedPaymentMethodsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Bank Property

Aptify 5.0 Software Development Kit (SDK)

CompanySavedPaymentMethodsClass.Bank Property

public virtual String Bank {get; set;}

See Also

CompanySavedPaymentMethodsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BranchName Property

Aptify 5.0 Software Development Kit (SDK)

CompanySavedPaymentMethodsClass.BranchName Property

public virtual String BranchName {get; set;}

See Also

CompanySavedPaymentMethodsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CCAccountNumber Property

Aptify 5.0 Software Development Kit (SDK)

CompanySavedPaymentMethodsClass.CCAccountNumber Property

public virtual String CCAccountNumber {get; set;}

See Also

CompanySavedPaymentMethodsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CCExpireDate Property

Aptify 5.0 Software Development Kit (SDK)

CompanySavedPaymentMethodsClass.CCExpireDate Property

public virtual DateTime CCExpireDate {get; set;}

See Also

CompanySavedPaymentMethodsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CCPartial Property

Aptify 5.0 Software Development Kit (SDK)

CompanySavedPaymentMethodsClass.CCPartial Property

public virtual String CCPartial {get; set;}

See Also

CompanySavedPaymentMethodsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CompanyID Property

Aptify 5.0 Software Development Kit (SDK)

CompanySavedPaymentMethodsClass.CompanyID Property

public virtual Int32 CompanyID {get;}

See Also

CompanySavedPaymentMethodsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CreditOrderID Property

Aptify 5.0 Software Development Kit (SDK)

CompanySavedPaymentMethodsClass.CreditOrderID Property

public virtual Int32 CreditOrderID {get; set;}

See Also

CompanySavedPaymentMethodsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Description Property

Aptify 5.0 Software Development Kit (SDK)

CompanySavedPaymentMethodsClass.Description Property

public virtual String Description {get; set;}

See Also

CompanySavedPaymentMethodsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


DueDate Property

Aptify 5.0 Software Development Kit (SDK)

CompanySavedPaymentMethodsClass.DueDate Property

public virtual DateTime DueDate {get; set;}

See Also

CompanySavedPaymentMethodsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


EndDate Property

Aptify 5.0 Software Development Kit (SDK)

CompanySavedPaymentMethodsClass.EndDate Property

public virtual DateTime EndDate {get; set;}

See Also

CompanySavedPaymentMethodsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

CompanySavedPaymentMethodsClass.ID Property

public virtual Int32 ID {get;}

See Also

CompanySavedPaymentMethodsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


IsActive Property

Aptify 5.0 Software Development Kit (SDK)

CompanySavedPaymentMethodsClass.IsActive Property

public virtual Boolean IsActive {get; set;}

See Also

CompanySavedPaymentMethodsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Name Property

Aptify 5.0 Software Development Kit (SDK)

CompanySavedPaymentMethodsClass.Name Property

public virtual String Name {get; set;}

See Also

CompanySavedPaymentMethodsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PaymentInformationID Property

Aptify 5.0 Software Development Kit (SDK)

CompanySavedPaymentMethodsClass.PaymentInformationID Property

public virtual Int32 PaymentInformationID {get; set;}

See Also

CompanySavedPaymentMethodsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PaymentType Property

Aptify 5.0 Software Development Kit (SDK)

CompanySavedPaymentMethodsClass.PaymentType Property

public virtual String PaymentType {get;}

See Also

CompanySavedPaymentMethodsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PaymentTypeID Property

Aptify 5.0 Software Development Kit (SDK)

CompanySavedPaymentMethodsClass.PaymentTypeID Property

public virtual Int32 PaymentTypeID {get; set;}

See Also

CompanySavedPaymentMethodsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PONumber Property

Aptify 5.0 Software Development Kit (SDK)

CompanySavedPaymentMethodsClass.PONumber Property

public virtual String PONumber {get; set;}

See Also

CompanySavedPaymentMethodsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Sequence Property

Aptify 5.0 Software Development Kit (SDK)

CompanySavedPaymentMethodsClass.Sequence Property

public virtual Int32 Sequence {get;}

See Also

CompanySavedPaymentMethodsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


StartDate Property

Aptify 5.0 Software Development Kit (SDK)

CompanySavedPaymentMethodsClass.StartDate Property

public virtual DateTime StartDate {get; set;}

See Also

CompanySavedPaymentMethodsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Terms Property

Aptify 5.0 Software Development Kit (SDK)

CompanySavedPaymentMethodsClass.Terms Property

public virtual String Terms {get; set;}

See Also

CompanySavedPaymentMethodsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CompanyTaxExemptCodesClass Class

For a list of all members of this type, see CompanyTaxExemptCodesClass Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
CompanyTaxExemptCodesClass

public class CompanyTaxExemptCodesClass : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity.Generated

Assembly: Aptify.Framework.BusinessLogic.GenericEntity.Generated.Companies (in Aptify.Framework.BusinessLogic.GenericEntity.Generated.Companies.dll)

See Also

CompanyTaxExemptCodesClass Members | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CompanyTaxExemptCodesClass Members

CompanyTaxExemptCodesClass overview

Public Instance Constructors

CompanyTaxExemptCodesClass Constructor Initializes a new instance of the CompanyTaxExemptCodesClass class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
City |
CompanyID |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
Country |
CountryCodeID |
County |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
ID |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
ISOCountryCode |
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PostalCode |
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SalesTax |
SalesTaxRateID |
Sequence |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
State |
StateProvince |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
TaxExemptCode |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.
ZipCode |

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

CompanyTaxExemptCodesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CompanyTaxExemptCodesClass Constructor

Initializes a new instance of the CompanyTaxExemptCodesClass class.

public CompanyTaxExemptCodesClass();

See Also

CompanyTaxExemptCodesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CompanyTaxExemptCodesClass Properties

The properties of the CompanyTaxExemptCodesClass class are listed below. For a complete list of CompanyTaxExemptCodesClass class members, see the CompanyTaxExemptCodesClass Members topic.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
City |
CompanyID |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
Country |
CountryCodeID |
County |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
ID |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
ISOCountryCode |
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PostalCode |
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SalesTax |
SalesTaxRateID |
Sequence |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
State |
StateProvince |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
TaxExemptCode |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.
ZipCode |

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

CompanyTaxExemptCodesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


City Property

Aptify 5.0 Software Development Kit (SDK)

CompanyTaxExemptCodesClass.City Property

public virtual String City {get;}

See Also

CompanyTaxExemptCodesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CompanyID Property

Aptify 5.0 Software Development Kit (SDK)

CompanyTaxExemptCodesClass.CompanyID Property

public virtual Int32 CompanyID {get;}

See Also

CompanyTaxExemptCodesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Country Property

Aptify 5.0 Software Development Kit (SDK)

CompanyTaxExemptCodesClass.Country Property

public virtual String Country {get;}

See Also

CompanyTaxExemptCodesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CountryCodeID Property

Aptify 5.0 Software Development Kit (SDK)

CompanyTaxExemptCodesClass.CountryCodeID Property

public virtual Int32 CountryCodeID {get;}

See Also

CompanyTaxExemptCodesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


County Property

Aptify 5.0 Software Development Kit (SDK)

CompanyTaxExemptCodesClass.County Property

public virtual String County {get;}

See Also

CompanyTaxExemptCodesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

CompanyTaxExemptCodesClass.ID Property

public virtual Int32 ID {get;}

See Also

CompanyTaxExemptCodesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ISOCountryCode Property

Aptify 5.0 Software Development Kit (SDK)

CompanyTaxExemptCodesClass.ISOCountryCode Property

public virtual String ISOCountryCode {get;}

See Also

CompanyTaxExemptCodesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PostalCode Property

Aptify 5.0 Software Development Kit (SDK)

CompanyTaxExemptCodesClass.PostalCode Property

public virtual String PostalCode {get;}

See Also

CompanyTaxExemptCodesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


SalesTax Property

Aptify 5.0 Software Development Kit (SDK)

CompanyTaxExemptCodesClass.SalesTax Property

public virtual String SalesTax {get;}

See Also

CompanyTaxExemptCodesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


SalesTaxRateID Property

Aptify 5.0 Software Development Kit (SDK)

CompanyTaxExemptCodesClass.SalesTaxRateID Property

public virtual Int32 SalesTaxRateID {get; set;}

See Also

CompanyTaxExemptCodesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Sequence Property

Aptify 5.0 Software Development Kit (SDK)

CompanyTaxExemptCodesClass.Sequence Property

public virtual Int32 Sequence {get;}

See Also

CompanyTaxExemptCodesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


State Property

Aptify 5.0 Software Development Kit (SDK)

CompanyTaxExemptCodesClass.State Property

public virtual String State {get;}

See Also

CompanyTaxExemptCodesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


StateProvince Property

Aptify 5.0 Software Development Kit (SDK)

CompanyTaxExemptCodesClass.StateProvince Property

public virtual String StateProvince {get;}

See Also

CompanyTaxExemptCodesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


TaxExemptCode Property

Aptify 5.0 Software Development Kit (SDK)

CompanyTaxExemptCodesClass.TaxExemptCode Property

public virtual String TaxExemptCode {get; set;}

See Also

CompanyTaxExemptCodesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ZipCode Property

Aptify 5.0 Software Development Kit (SDK)

CompanyTaxExemptCodesClass.ZipCode Property

public virtual String ZipCode {get;}

See Also

CompanyTaxExemptCodesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ContactLogClass Class

For a list of all members of this type, see ContactLogClass Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
ContactLogClass
ContactLog

public class ContactLogClass : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity.Generated

Assembly: Aptify.Framework.BusinessLogic.GenericEntity.Generated.ContactLog (in Aptify.Framework.BusinessLogic.GenericEntity.Generated.ContactLog.dll)

See Also

ContactLogClass Members | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ContactLogClass Members

ContactLogClass overview

Public Instance Constructors

ContactLogClass Constructor Initializes a new instance of the ContactLogClass class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
AssignedTo |
AssignedToID |
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
Category |
CategoryID |
Completed |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DateCreated |
DateField |
DateUpdated |
DefaultEmployeeLinkID |
DefaultPersonLinkID |
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
Description |
Details |
Direction |
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
Forward |
ForwardID |
ID |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
NextContactDate |
NextContactReason |
NextContactStatus |
OwnerID |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentID |
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
Priority |
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
Type |
TypeID |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.
WhoCreated |
WhoUpdated |

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
ContactLogLinks |
ContactLogLinksObject |
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

ContactLogClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ContactLogClass Constructor

Initializes a new instance of the ContactLogClass class.

public ContactLogClass();

See Also

ContactLogClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ContactLogClass Properties

The properties of the ContactLogClass class are listed below. For a complete list of ContactLogClass class members, see the ContactLogClass Members topic.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
AssignedTo |
AssignedToID |
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
Category |
CategoryID |
Completed |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DateCreated |
DateField |
DateUpdated |
DefaultEmployeeLinkID |
DefaultPersonLinkID |
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
Description |
Details |
Direction |
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
Forward |
ForwardID |
ID |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
NextContactDate |
NextContactReason |
NextContactStatus |
OwnerID |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentID |
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
Priority |
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
Type |
TypeID |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.
WhoCreated |
WhoUpdated |

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

ContactLogClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AssignedTo Property

Aptify 5.0 Software Development Kit (SDK)

ContactLogClass.AssignedTo Property

public virtual String AssignedTo {get;}

See Also

ContactLogClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AssignedToID Property

Aptify 5.0 Software Development Kit (SDK)

ContactLogClass.AssignedToID Property

public virtual Int32 AssignedToID {get; set;}

See Also

ContactLogClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Category Property

Aptify 5.0 Software Development Kit (SDK)

ContactLogClass.Category Property

public virtual String Category {get;}

See Also

ContactLogClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CategoryID Property

Aptify 5.0 Software Development Kit (SDK)

ContactLogClass.CategoryID Property

public virtual Int32 CategoryID {get; set;}

See Also

ContactLogClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Completed Property

Aptify 5.0 Software Development Kit (SDK)

ContactLogClass.Completed Property

public virtual Boolean Completed {get;}

See Also

ContactLogClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


DateCreated Property

Aptify 5.0 Software Development Kit (SDK)

ContactLogClass.DateCreated Property

public virtual DateTime DateCreated {get; set;}

See Also

ContactLogClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


DateField Property

Aptify 5.0 Software Development Kit (SDK)

ContactLogClass.DateField Property

public virtual DateTime DateField {get; set;}

See Also

ContactLogClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


DateUpdated Property

Aptify 5.0 Software Development Kit (SDK)

ContactLogClass.DateUpdated Property

public virtual DateTime DateUpdated {get; set;}

See Also

ContactLogClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


DefaultEmployeeLinkID Property

Aptify 5.0 Software Development Kit (SDK)

ContactLogClass.DefaultEmployeeLinkID Property

public virtual Int32 DefaultEmployeeLinkID {get; set;}

See Also

ContactLogClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


DefaultPersonLinkID Property

Aptify 5.0 Software Development Kit (SDK)

ContactLogClass.DefaultPersonLinkID Property

public virtual Int32 DefaultPersonLinkID {get; set;}

See Also

ContactLogClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Description Property

Aptify 5.0 Software Development Kit (SDK)

ContactLogClass.Description Property

public virtual String Description {get; set;}

See Also

ContactLogClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Details Property

Aptify 5.0 Software Development Kit (SDK)

ContactLogClass.Details Property

public virtual String Details {get; set;}

See Also

ContactLogClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Direction Property

Aptify 5.0 Software Development Kit (SDK)

ContactLogClass.Direction Property

public virtual String Direction {get; set;}

See Also

ContactLogClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Forward Property

Aptify 5.0 Software Development Kit (SDK)

ContactLogClass.Forward Property

public virtual String Forward {get;}

See Also

ContactLogClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ForwardID Property

Aptify 5.0 Software Development Kit (SDK)

ContactLogClass.ForwardID Property

public virtual Int32 ForwardID {get; set;}

See Also

ContactLogClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

ContactLogClass.ID Property

public virtual Int32 ID {get;}

See Also

ContactLogClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


NextContactDate Property

Aptify 5.0 Software Development Kit (SDK)

ContactLogClass.NextContactDate Property

public virtual DateTime NextContactDate {get; set;}

See Also

ContactLogClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


NextContactReason Property

Aptify 5.0 Software Development Kit (SDK)

ContactLogClass.NextContactReason Property

public virtual String NextContactReason {get; set;}

See Also

ContactLogClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


NextContactStatus Property

Aptify 5.0 Software Development Kit (SDK)

ContactLogClass.NextContactStatus Property

public virtual String NextContactStatus {get; set;}

See Also

ContactLogClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OwnerID Property

Aptify 5.0 Software Development Kit (SDK)

ContactLogClass.OwnerID Property

public virtual String OwnerID {get;}

See Also

ContactLogClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ParentID Property

Aptify 5.0 Software Development Kit (SDK)

ContactLogClass.ParentID Property

public virtual Int32 ParentID {get; set;}

See Also

ContactLogClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Priority Property

Aptify 5.0 Software Development Kit (SDK)

ContactLogClass.Priority Property

public virtual String Priority {get; set;}

See Also

ContactLogClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Type Property

Aptify 5.0 Software Development Kit (SDK)

ContactLogClass.Type Property

public virtual String Type {get;}

See Also

ContactLogClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


TypeID Property

Aptify 5.0 Software Development Kit (SDK)

ContactLogClass.TypeID Property

public virtual Int32 TypeID {get; set;}

See Also

ContactLogClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


WhoCreated Property

Aptify 5.0 Software Development Kit (SDK)

ContactLogClass.WhoCreated Property

public virtual String WhoCreated {get; set;}

See Also

ContactLogClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


WhoUpdated Property

Aptify 5.0 Software Development Kit (SDK)

ContactLogClass.WhoUpdated Property

public virtual String WhoUpdated {get; set;}

See Also

ContactLogClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ContactLogClass Methods

The methods of the ContactLogClass class are listed below. For a complete list of ContactLogClass class members, see the ContactLogClass Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
ContactLogLinks |
ContactLogLinksObject |
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

ContactLogClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ContactLogClass.ContactLogLinks Method

public virtual ContactLogLinksClass ContactLogLinks(
Int32 Index
);

See Also

ContactLogClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ContactLogClass.ContactLogLinksObject Method

public virtual AptifySubTypeBase ContactLogLinksObject();

See Also

ContactLogClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ContactLogLinksClass Class

For a list of all members of this type, see ContactLogLinksClass Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
ContactLogLinksClass

public class ContactLogLinksClass : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity.Generated

Assembly: Aptify.Framework.BusinessLogic.GenericEntity.Generated.ContactLog (in Aptify.Framework.BusinessLogic.GenericEntity.Generated.ContactLog.dll)

See Also

ContactLogLinksClass Members | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ContactLogLinksClass Members

ContactLogLinksClass overview

Public Instance Constructors

ContactLogLinksClass Constructor Initializes a new instance of the ContactLogLinksClass class.

Public Instance Properties

AltID |
Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContactLogID |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
Entity |
EntityDisplayName |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID | Overloaded.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
ID |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName |
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Sequence |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

ContactLogLinksClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ContactLogLinksClass Constructor

Initializes a new instance of the ContactLogLinksClass class.

public ContactLogLinksClass();

See Also

ContactLogLinksClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ContactLogLinksClass Properties

The properties of the ContactLogLinksClass class are listed below. For a complete list of ContactLogLinksClass class members, see the ContactLogLinksClass Members topic.

Public Instance Properties

AltID |
Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContactLogID |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
Entity |
EntityDisplayName |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID | Overloaded.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
ID |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName |
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Sequence |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

ContactLogLinksClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AltID Property

Aptify 5.0 Software Development Kit (SDK)

ContactLogLinksClass.AltID Property

public virtual Int32 AltID {get; set;}

See Also

ContactLogLinksClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ContactLogID Property

Aptify 5.0 Software Development Kit (SDK)

ContactLogLinksClass.ContactLogID Property

public virtual Int32 ContactLogID {get;}

See Also

ContactLogLinksClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Entity Property

Aptify 5.0 Software Development Kit (SDK)

ContactLogLinksClass.Entity Property

public virtual String Entity {get;}

See Also

ContactLogLinksClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


EntityDisplayName Property

Aptify 5.0 Software Development Kit (SDK)

ContactLogLinksClass.EntityDisplayName Property

new public virtual String EntityDisplayName {get;}

See Also

ContactLogLinksClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


EntityID Property

Aptify 5.0 Software Development Kit (SDK)

ContactLogLinksClass.EntityID Property

new public virtual Int32 EntityID {get; set;}

See Also

ContactLogLinksClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

ContactLogLinksClass.ID Property

public virtual Int32 ID {get;}

See Also

ContactLogLinksClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


RecordName Property

Aptify 5.0 Software Development Kit (SDK)

ContactLogLinksClass.RecordName Property

new public virtual String RecordName {get;}

See Also

ContactLogLinksClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Sequence Property

Aptify 5.0 Software Development Kit (SDK)

ContactLogLinksClass.Sequence Property

public virtual Int32 Sequence {get;}

See Also

ContactLogLinksClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


EmployeesClass Class

For a list of all members of this type, see EmployeesClass Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
EmployeesClass
EmployeesEntity

public class EmployeesClass : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity.Generated

Assembly: Aptify.Framework.BusinessLogic.GenericEntity.Generated.Employees (in Aptify.Framework.BusinessLogic.GenericEntity.Generated.Employees.dll)

See Also

EmployeesClass Members | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


EmployeesClass Members

EmployeesClass overview

Public Instance Constructors

EmployeesClass Constructor Initializes a new instance of the EmployeesClass class.

Public Instance Properties

AllowFree |
AllowPriceOverride |
AllowPriceSelection |
AllowRelatedProductPromptClose |
Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BillRate |
Birthday |
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
CellAreaCode |
CellCountryCode |
CellPhone |
CellPhoneID |
Comments |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DateCreated |
DateHired |
DateLastReviewed |
DateReviewDue |
DateTerminated |
DateUpdated |
DbUser |
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
Department |
DepartmentID |
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
Email1 |
Email2 |
Email3 |
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
FirstLast |
FirstName |
Gender |
HomeAddressID |
HomeAddressLine1 |
HomeAddressLine2 |
HomeAddressLine3 |
HomeAddressLine4 |
HomeAreaCode |
HomeCity |
HomeCountry |
HomeCountryCode |
HomeCounty |
HomeFax |
HomeFaxAreaCode |
HomeFaxCountryCode |
HomeFaxID |
HomePhone |
HomePhoneID |
HomeState |
HomeZipCode |
ID |
ImportantDate1 |
ImportantDate2 |
ImportantDate3 |
ImportantDescription1 |
ImportantDescription2 |
ImportantDescription3 |
Inactive |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
Kids |
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastName |
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LinkedPersonID |
MiddleName |
Organization |
OrganizationID |
PagerAreaCode |
PagerCountryCode |
PagerPhone |
PagerPhoneID |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PayRate |
PositionCode |
PositionCodeID |
Prefix |
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
PurchaseLimit |
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
ReferencesCheckedBy |
ReferencesCheckedDate |
ReferralType |
ReferredBy |
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
ResumeLink |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SpouseName |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
Suffix |
Supervisor |
SupervisorID |
SupervisorTitle |
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
Title |
USCitizen |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.
VisaType |
WantsContract |
WantsPermanent |
WebPage |
WhoCreated |
WhoUpdated |
Will1099 |
WillContract |
WillFTE |
WillInc |
WillW2 |
WorkAddressID |
WorkAddressIDObject |
WorkAddressLine1 |
WorkAddressLine2 |
WorkAddressLine3 |
WorkAddressLine4 |
WorkAreaCode |
WorkCity |
WorkCountry |
WorkCountryCode |
WorkCounty |
WorkExtension |
WorkFax |
WorkFaxAreaCode |
WorkFaxCountryCode |
WorkFaxID |
WorkFaxIDObject |
WorkPhone |
WorkPhoneID |
WorkPhoneIDObject |
WorkState |
WorkZipCode |
XCon |

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Employee_Skills |
Employee_SkillsObject |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


EmployeesClass Constructor

Initializes a new instance of the EmployeesClass class.

public EmployeesClass();

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


EmployeesClass Properties

The properties of the EmployeesClass class are listed below. For a complete list of EmployeesClass class members, see the EmployeesClass Members topic.

Public Instance Properties

AllowFree |
AllowPriceOverride |
AllowPriceSelection |
AllowRelatedProductPromptClose |
Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BillRate |
Birthday |
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
CellAreaCode |
CellCountryCode |
CellPhone |
CellPhoneID |
Comments |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DateCreated |
DateHired |
DateLastReviewed |
DateReviewDue |
DateTerminated |
DateUpdated |
DbUser |
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
Department |
DepartmentID |
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
Email1 |
Email2 |
Email3 |
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
FirstLast |
FirstName |
Gender |
HomeAddressID |
HomeAddressLine1 |
HomeAddressLine2 |
HomeAddressLine3 |
HomeAddressLine4 |
HomeAreaCode |
HomeCity |
HomeCountry |
HomeCountryCode |
HomeCounty |
HomeFax |
HomeFaxAreaCode |
HomeFaxCountryCode |
HomeFaxID |
HomePhone |
HomePhoneID |
HomeState |
HomeZipCode |
ID |
ImportantDate1 |
ImportantDate2 |
ImportantDate3 |
ImportantDescription1 |
ImportantDescription2 |
ImportantDescription3 |
Inactive |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
Kids |
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastName |
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LinkedPersonID |
MiddleName |
Organization |
OrganizationID |
PagerAreaCode |
PagerCountryCode |
PagerPhone |
PagerPhoneID |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PayRate |
PositionCode |
PositionCodeID |
Prefix |
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
PurchaseLimit |
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
ReferencesCheckedBy |
ReferencesCheckedDate |
ReferralType |
ReferredBy |
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
ResumeLink |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SpouseName |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
Suffix |
Supervisor |
SupervisorID |
SupervisorTitle |
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
Title |
USCitizen |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.
VisaType |
WantsContract |
WantsPermanent |
WebPage |
WhoCreated |
WhoUpdated |
Will1099 |
WillContract |
WillFTE |
WillInc |
WillW2 |
WorkAddressID |
WorkAddressIDObject |
WorkAddressLine1 |
WorkAddressLine2 |
WorkAddressLine3 |
WorkAddressLine4 |
WorkAreaCode |
WorkCity |
WorkCountry |
WorkCountryCode |
WorkCounty |
WorkExtension |
WorkFax |
WorkFaxAreaCode |
WorkFaxCountryCode |
WorkFaxID |
WorkFaxIDObject |
WorkPhone |
WorkPhoneID |
WorkPhoneIDObject |
WorkState |
WorkZipCode |
XCon |

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AllowFree Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.AllowFree Property

public virtual Boolean AllowFree {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AllowPriceOverride Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.AllowPriceOverride Property

public virtual Boolean AllowPriceOverride {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AllowPriceSelection Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.AllowPriceSelection Property

public virtual Boolean AllowPriceSelection {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AllowRelatedProductPromptClose Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.AllowRelatedProductPromptClose Property

public virtual Boolean AllowRelatedProductPromptClose {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BillRate Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.BillRate Property

public virtual Decimal BillRate {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Birthday Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.Birthday Property

public virtual DateTime Birthday {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CellAreaCode Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.CellAreaCode Property

public virtual String CellAreaCode {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CellCountryCode Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.CellCountryCode Property

public virtual String CellCountryCode {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CellPhone Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.CellPhone Property

public virtual String CellPhone {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CellPhoneID Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.CellPhoneID Property

public virtual Int32 CellPhoneID {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Comments Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.Comments Property

public virtual String Comments {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


DateCreated Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.DateCreated Property

public virtual DateTime DateCreated {get;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


DateHired Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.DateHired Property

public virtual DateTime DateHired {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


DateLastReviewed Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.DateLastReviewed Property

public virtual DateTime DateLastReviewed {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


DateReviewDue Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.DateReviewDue Property

public virtual DateTime DateReviewDue {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


DateTerminated Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.DateTerminated Property

public virtual DateTime DateTerminated {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


DateUpdated Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.DateUpdated Property

public virtual DateTime DateUpdated {get;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


DbUser Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.DbUser Property

public virtual String DbUser {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Department Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.Department Property

public virtual String Department {get;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


DepartmentID Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.DepartmentID Property

public virtual Int32 DepartmentID {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Email1 Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.Email1 Property

public virtual String Email1 {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Email2 Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.Email2 Property

public virtual String Email2 {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Email3 Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.Email3 Property

public virtual String Email3 {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


FirstLast Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.FirstLast Property

public virtual String FirstLast {get;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


FirstName Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.FirstName Property

public virtual String FirstName {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Gender Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.Gender Property

public virtual Boolean Gender {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


HomeAddressID Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.HomeAddressID Property

public virtual Int32 HomeAddressID {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


HomeAddressLine1 Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.HomeAddressLine1 Property

public virtual String HomeAddressLine1 {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


HomeAddressLine2 Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.HomeAddressLine2 Property

public virtual String HomeAddressLine2 {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


HomeAddressLine3 Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.HomeAddressLine3 Property

public virtual String HomeAddressLine3 {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


HomeAddressLine4 Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.HomeAddressLine4 Property

public virtual String HomeAddressLine4 {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


HomeAreaCode Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.HomeAreaCode Property

public virtual String HomeAreaCode {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


HomeCity Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.HomeCity Property

public virtual String HomeCity {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


HomeCountry Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.HomeCountry Property

public virtual String HomeCountry {get;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


HomeCountryCode Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.HomeCountryCode Property

public virtual String HomeCountryCode {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


HomeCounty Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.HomeCounty Property

public virtual String HomeCounty {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


HomeFax Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.HomeFax Property

public virtual String HomeFax {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


HomeFaxAreaCode Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.HomeFaxAreaCode Property

public virtual String HomeFaxAreaCode {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


HomeFaxCountryCode Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.HomeFaxCountryCode Property

public virtual String HomeFaxCountryCode {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


HomeFaxID Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.HomeFaxID Property

public virtual Int32 HomeFaxID {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


HomePhone Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.HomePhone Property

public virtual String HomePhone {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


HomePhoneID Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.HomePhoneID Property

public virtual Int32 HomePhoneID {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


HomeState Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.HomeState Property

public virtual String HomeState {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


HomeZipCode Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.HomeZipCode Property

public virtual String HomeZipCode {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.ID Property

public virtual Int32 ID {get;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ImportantDate1 Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.ImportantDate1 Property

public virtual DateTime ImportantDate1 {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ImportantDate2 Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.ImportantDate2 Property

public virtual DateTime ImportantDate2 {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ImportantDate3 Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.ImportantDate3 Property

public virtual DateTime ImportantDate3 {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ImportantDescription1 Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.ImportantDescription1 Property

public virtual String ImportantDescription1 {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ImportantDescription2 Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.ImportantDescription2 Property

public virtual String ImportantDescription2 {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ImportantDescription3 Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.ImportantDescription3 Property

public virtual String ImportantDescription3 {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Inactive Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.Inactive Property

public virtual Boolean Inactive {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Kids Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.Kids Property

public virtual String Kids {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


LastName Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.LastName Property

public virtual String LastName {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


LinkedPersonID Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.LinkedPersonID Property

public virtual Int32 LinkedPersonID {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


MiddleName Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.MiddleName Property

public virtual String MiddleName {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Organization Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.Organization Property

public virtual String Organization {get;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrganizationID Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.OrganizationID Property

public virtual Int32 OrganizationID {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PagerAreaCode Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.PagerAreaCode Property

public virtual String PagerAreaCode {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PagerCountryCode Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.PagerCountryCode Property

public virtual String PagerCountryCode {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PagerPhone Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.PagerPhone Property

public virtual String PagerPhone {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PagerPhoneID Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.PagerPhoneID Property

public virtual Int32 PagerPhoneID {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PayRate Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.PayRate Property

public virtual Decimal PayRate {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PositionCode Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.PositionCode Property

public virtual String PositionCode {get;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PositionCodeID Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.PositionCodeID Property

public virtual Int32 PositionCodeID {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Prefix Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.Prefix Property

public virtual String Prefix {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PurchaseLimit Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.PurchaseLimit Property

public virtual Decimal PurchaseLimit {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ReferencesCheckedBy Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.ReferencesCheckedBy Property

public virtual Int32 ReferencesCheckedBy {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ReferencesCheckedDate Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.ReferencesCheckedDate Property

public virtual DateTime ReferencesCheckedDate {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ReferralType Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.ReferralType Property

public virtual String ReferralType {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ReferredBy Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.ReferredBy Property

public virtual Int32 ReferredBy {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ResumeLink Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.ResumeLink Property

public virtual String ResumeLink {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


SpouseName Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.SpouseName Property

public virtual String SpouseName {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Suffix Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.Suffix Property

public virtual String Suffix {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Supervisor Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.Supervisor Property

public virtual String Supervisor {get;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


SupervisorID Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.SupervisorID Property

public virtual Int32 SupervisorID {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


SupervisorTitle Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.SupervisorTitle Property

public virtual String SupervisorTitle {get;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Title Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.Title Property

public virtual String Title {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


USCitizen Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.USCitizen Property

public virtual Boolean USCitizen {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


VisaType Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.VisaType Property

public virtual String VisaType {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


WantsContract Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.WantsContract Property

public virtual Boolean WantsContract {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


WantsPermanent Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.WantsPermanent Property

public virtual Boolean WantsPermanent {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


WebPage Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.WebPage Property

public virtual String WebPage {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


WhoCreated Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.WhoCreated Property

public virtual String WhoCreated {get;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


WhoUpdated Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.WhoUpdated Property

public virtual String WhoUpdated {get;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Will1099 Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.Will1099 Property

public virtual Boolean Will1099 {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


WillContract Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.WillContract Property

public virtual Boolean WillContract {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


WillFTE Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.WillFTE Property

public virtual Boolean WillFTE {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


WillInc Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.WillInc Property

public virtual Boolean WillInc {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


WillW2 Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.WillW2 Property

public virtual Boolean WillW2 {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


WorkAddressID Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.WorkAddressID Property

public virtual Int32 WorkAddressID {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


WorkAddressIDObject Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.WorkAddressIDObject Property

public virtual AptifyGenericEntityBase WorkAddressIDObject {get;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


WorkAddressLine1 Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.WorkAddressLine1 Property

public virtual String WorkAddressLine1 {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


WorkAddressLine2 Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.WorkAddressLine2 Property

public virtual String WorkAddressLine2 {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


WorkAddressLine3 Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.WorkAddressLine3 Property

public virtual String WorkAddressLine3 {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


WorkAddressLine4 Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.WorkAddressLine4 Property

public virtual String WorkAddressLine4 {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


WorkAreaCode Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.WorkAreaCode Property

public virtual String WorkAreaCode {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


WorkCity Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.WorkCity Property

public virtual String WorkCity {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


WorkCountry Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.WorkCountry Property

public virtual String WorkCountry {get;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


WorkCountryCode Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.WorkCountryCode Property

public virtual String WorkCountryCode {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


WorkCounty Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.WorkCounty Property

public virtual String WorkCounty {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


WorkExtension Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.WorkExtension Property

public virtual String WorkExtension {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


WorkFax Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.WorkFax Property

public virtual String WorkFax {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


WorkFaxAreaCode Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.WorkFaxAreaCode Property

public virtual String WorkFaxAreaCode {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


WorkFaxCountryCode Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.WorkFaxCountryCode Property

public virtual String WorkFaxCountryCode {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


WorkFaxID Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.WorkFaxID Property

public virtual Int32 WorkFaxID {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


WorkFaxIDObject Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.WorkFaxIDObject Property

public virtual AptifyGenericEntityBase WorkFaxIDObject {get;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


WorkPhone Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.WorkPhone Property

public virtual String WorkPhone {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


WorkPhoneID Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.WorkPhoneID Property

public virtual Int32 WorkPhoneID {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


WorkPhoneIDObject Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.WorkPhoneIDObject Property

public virtual AptifyGenericEntityBase WorkPhoneIDObject {get;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


WorkState Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.WorkState Property

public virtual String WorkState {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


WorkZipCode Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.WorkZipCode Property

public virtual String WorkZipCode {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


XCon Property

Aptify 5.0 Software Development Kit (SDK)

EmployeesClass.XCon Property

public virtual Boolean XCon {get; set;}

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


EmployeesClass Methods

The methods of the EmployeesClass class are listed below. For a complete list of EmployeesClass class members, see the EmployeesClass Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Employee_Skills |
Employee_SkillsObject |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


EmployeesClass.Employee_Skills Method

public virtual EmployeeSkillsClass Employee_Skills(
Int32 Index
);

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


EmployeesClass.Employee_SkillsObject Method

public virtual AptifySubTypeBase Employee_SkillsObject();

See Also

EmployeesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


EmployeeSkillsClass Class

For a list of all members of this type, see EmployeeSkillsClass Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
EmployeeSkillsClass

public class EmployeeSkillsClass : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity.Generated

Assembly: Aptify.Framework.BusinessLogic.GenericEntity.Generated.Employees (in Aptify.Framework.BusinessLogic.GenericEntity.Generated.Employees.dll)

See Also

EmployeeSkillsClass Members | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


EmployeeSkillsClass Members

EmployeeSkillsClass overview

Public Instance Constructors

EmployeeSkillsClass Constructor Initializes a new instance of the EmployeeSkillsClass class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
Comments |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DateFirstUsed |
DateLastUsed |
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
Employee |
EmployeeID |
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
ID |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Sequence |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
Skill |
SkillID |
SkillLevel |
SkillLevelID |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

EmployeeSkillsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


EmployeeSkillsClass Constructor

Initializes a new instance of the EmployeeSkillsClass class.

public EmployeeSkillsClass();

See Also

EmployeeSkillsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


EmployeeSkillsClass Properties

The properties of the EmployeeSkillsClass class are listed below. For a complete list of EmployeeSkillsClass class members, see the EmployeeSkillsClass Members topic.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
Comments |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DateFirstUsed |
DateLastUsed |
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
Employee |
EmployeeID |
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
ID |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Sequence |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
Skill |
SkillID |
SkillLevel |
SkillLevelID |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

EmployeeSkillsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Comments Property

Aptify 5.0 Software Development Kit (SDK)

EmployeeSkillsClass.Comments Property

public virtual String Comments {get; set;}

See Also

EmployeeSkillsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


DateFirstUsed Property

Aptify 5.0 Software Development Kit (SDK)

EmployeeSkillsClass.DateFirstUsed Property

public virtual DateTime DateFirstUsed {get; set;}

See Also

EmployeeSkillsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


DateLastUsed Property

Aptify 5.0 Software Development Kit (SDK)

EmployeeSkillsClass.DateLastUsed Property

public virtual DateTime DateLastUsed {get; set;}

See Also

EmployeeSkillsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Employee Property

Aptify 5.0 Software Development Kit (SDK)

EmployeeSkillsClass.Employee Property

public virtual String Employee {get;}

See Also

EmployeeSkillsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


EmployeeID Property

Aptify 5.0 Software Development Kit (SDK)

EmployeeSkillsClass.EmployeeID Property

public virtual Int32 EmployeeID {get;}

See Also

EmployeeSkillsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

EmployeeSkillsClass.ID Property

public virtual Int32 ID {get;}

See Also

EmployeeSkillsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Sequence Property

Aptify 5.0 Software Development Kit (SDK)

EmployeeSkillsClass.Sequence Property

public virtual Int32 Sequence {get;}

See Also

EmployeeSkillsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Skill Property

Aptify 5.0 Software Development Kit (SDK)

EmployeeSkillsClass.Skill Property

public virtual String Skill {get;}

See Also

EmployeeSkillsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


SkillID Property

Aptify 5.0 Software Development Kit (SDK)

EmployeeSkillsClass.SkillID Property

public virtual Int32 SkillID {get; set;}

See Also

EmployeeSkillsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


SkillLevel Property

Aptify 5.0 Software Development Kit (SDK)

EmployeeSkillsClass.SkillLevel Property

public virtual String SkillLevel {get;}

See Also

EmployeeSkillsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


SkillLevelID Property

Aptify 5.0 Software Development Kit (SDK)

EmployeeSkillsClass.SkillLevelID Property

public virtual Int32 SkillLevelID {get; set;}

See Also

EmployeeSkillsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrderCurrencySpotRateClass Class

For a list of all members of this type, see OrderCurrencySpotRateClass Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
OrderCurrencySpotRateClass

public class OrderCurrencySpotRateClass : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity.Generated

Assembly: Aptify.Framework.BusinessLogic.GenericEntity.Generated.Orders (in Aptify.Framework.BusinessLogic.GenericEntity.Generated.Orders.dll)

See Also

OrderCurrencySpotRateClass Members | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrderCurrencySpotRateClass Members

OrderCurrencySpotRateClass overview

Public Instance Constructors

OrderCurrencySpotRateClass Constructor Initializes a new instance of the OrderCurrencySpotRateClass class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
Comments |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrencySpotRateID |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
ID |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
OrderID |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordDate |
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Sequence |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SpotRate |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
TriggerEvent |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

OrderCurrencySpotRateClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrderCurrencySpotRateClass Constructor

Initializes a new instance of the OrderCurrencySpotRateClass class.

public OrderCurrencySpotRateClass();

See Also

OrderCurrencySpotRateClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrderCurrencySpotRateClass Properties

The properties of the OrderCurrencySpotRateClass class are listed below. For a complete list of OrderCurrencySpotRateClass class members, see the OrderCurrencySpotRateClass Members topic.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
Comments |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrencySpotRateID |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
ID |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
OrderID |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordDate |
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Sequence |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SpotRate |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
TriggerEvent |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

OrderCurrencySpotRateClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Comments Property

Aptify 5.0 Software Development Kit (SDK)

OrderCurrencySpotRateClass.Comments Property

public virtual String Comments {get; set;}

See Also

OrderCurrencySpotRateClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CurrencySpotRateID Property

Aptify 5.0 Software Development Kit (SDK)

OrderCurrencySpotRateClass.CurrencySpotRateID Property

public virtual Int32 CurrencySpotRateID {get; set;}

See Also

OrderCurrencySpotRateClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

OrderCurrencySpotRateClass.ID Property

public virtual Int32 ID {get;}

See Also

OrderCurrencySpotRateClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrderID Property

Aptify 5.0 Software Development Kit (SDK)

OrderCurrencySpotRateClass.OrderID Property

public virtual Int32 OrderID {get;}

See Also

OrderCurrencySpotRateClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


RecordDate Property

Aptify 5.0 Software Development Kit (SDK)

OrderCurrencySpotRateClass.RecordDate Property

public virtual DateTime RecordDate {get; set;}

See Also

OrderCurrencySpotRateClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Sequence Property

Aptify 5.0 Software Development Kit (SDK)

OrderCurrencySpotRateClass.Sequence Property

public virtual Int32 Sequence {get;}

See Also

OrderCurrencySpotRateClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


SpotRate Property

Aptify 5.0 Software Development Kit (SDK)

OrderCurrencySpotRateClass.SpotRate Property

public virtual Decimal SpotRate {get;}

See Also

OrderCurrencySpotRateClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


TriggerEvent Property

Aptify 5.0 Software Development Kit (SDK)

OrderCurrencySpotRateClass.TriggerEvent Property

public virtual String TriggerEvent {get; set;}

See Also

OrderCurrencySpotRateClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrderGLEntryClass Class

For a list of all members of this type, see OrderGLEntryClass Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
OrderGLEntryClass

public class OrderGLEntryClass : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity.Generated

Assembly: Aptify.Framework.BusinessLogic.GenericEntity.Generated.Orders (in Aptify.Framework.BusinessLogic.GenericEntity.Generated.Orders.dll)

See Also

OrderGLEntryClass Members | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrderGLEntryClass Members

OrderGLEntryClass overview

Public Instance Constructors

OrderGLEntryClass Constructor Initializes a new instance of the OrderGLEntryClass class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CreditAmount |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DebitAmount |
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
Description |
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
GLAccount |
ID |
IsCustom |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
OrderID |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Sequence |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

OrderGLEntryClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrderGLEntryClass Constructor

Initializes a new instance of the OrderGLEntryClass class.

public OrderGLEntryClass();

See Also

OrderGLEntryClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrderGLEntryClass Properties

The properties of the OrderGLEntryClass class are listed below. For a complete list of OrderGLEntryClass class members, see the OrderGLEntryClass Members topic.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CreditAmount |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DebitAmount |
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
Description |
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
GLAccount |
ID |
IsCustom |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
OrderID |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Sequence |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

OrderGLEntryClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CreditAmount Property

Aptify 5.0 Software Development Kit (SDK)

OrderGLEntryClass.CreditAmount Property

public virtual Decimal CreditAmount {get; set;}

See Also

OrderGLEntryClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


DebitAmount Property

Aptify 5.0 Software Development Kit (SDK)

OrderGLEntryClass.DebitAmount Property

public virtual Decimal DebitAmount {get; set;}

See Also

OrderGLEntryClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Description Property

Aptify 5.0 Software Development Kit (SDK)

OrderGLEntryClass.Description Property

public virtual String Description {get; set;}

See Also

OrderGLEntryClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


GLAccount Property

Aptify 5.0 Software Development Kit (SDK)

OrderGLEntryClass.GLAccount Property

public virtual String GLAccount {get; set;}

See Also

OrderGLEntryClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

OrderGLEntryClass.ID Property

public virtual Int32 ID {get;}

See Also

OrderGLEntryClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


IsCustom Property

Aptify 5.0 Software Development Kit (SDK)

OrderGLEntryClass.IsCustom Property

public virtual Boolean IsCustom {get; set;}

See Also

OrderGLEntryClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrderID Property

Aptify 5.0 Software Development Kit (SDK)

OrderGLEntryClass.OrderID Property

public virtual Int32 OrderID {get;}

See Also

OrderGLEntryClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Sequence Property

Aptify 5.0 Software Development Kit (SDK)

OrderGLEntryClass.Sequence Property

public virtual Int32 Sequence {get;}

See Also

OrderGLEntryClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrderInvAllocationClass Class

For a list of all members of this type, see OrderInvAllocationClass Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
OrderInvAllocationClass

public class OrderInvAllocationClass : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity.Generated

Assembly: Aptify.Framework.BusinessLogic.GenericEntity.Generated.Orders (in Aptify.Framework.BusinessLogic.GenericEntity.Generated.Orders.dll)

See Also

OrderInvAllocationClass Members | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrderInvAllocationClass Members

OrderInvAllocationClass overview

Public Instance Constructors

OrderInvAllocationClass Constructor Initializes a new instance of the OrderInvAllocationClass class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
ID |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
OrderID |
OrderLine |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
ProdInvLedgerEntryID |
Quantity |
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Sequence |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

OrderInvAllocationClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrderInvAllocationClass Constructor

Initializes a new instance of the OrderInvAllocationClass class.

public OrderInvAllocationClass();

See Also

OrderInvAllocationClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrderInvAllocationClass Properties

The properties of the OrderInvAllocationClass class are listed below. For a complete list of OrderInvAllocationClass class members, see the OrderInvAllocationClass Members topic.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
ID |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
OrderID |
OrderLine |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
ProdInvLedgerEntryID |
Quantity |
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Sequence |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

OrderInvAllocationClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

OrderInvAllocationClass.ID Property

public virtual Int32 ID {get;}

See Also

OrderInvAllocationClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrderID Property

Aptify 5.0 Software Development Kit (SDK)

OrderInvAllocationClass.OrderID Property

public virtual Int32 OrderID {get;}

See Also

OrderInvAllocationClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrderLine Property

Aptify 5.0 Software Development Kit (SDK)

OrderInvAllocationClass.OrderLine Property

public virtual Int32 OrderLine {get; set;}

See Also

OrderInvAllocationClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ProdInvLedgerEntryID Property

Aptify 5.0 Software Development Kit (SDK)

OrderInvAllocationClass.ProdInvLedgerEntryID Property

public virtual Int32 ProdInvLedgerEntryID {get; set;}

See Also

OrderInvAllocationClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Quantity Property

Aptify 5.0 Software Development Kit (SDK)

OrderInvAllocationClass.Quantity Property

public virtual Decimal Quantity {get; set;}

See Also

OrderInvAllocationClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Sequence Property

Aptify 5.0 Software Development Kit (SDK)

OrderInvAllocationClass.Sequence Property

public virtual Int32 Sequence {get;}

See Also

OrderInvAllocationClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrderLinesClass Class

For a list of all members of this type, see OrderLinesClass Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
OrderLinesClass
OrderLinesEntity

public class OrderLinesClass : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity.Generated

Assembly: Aptify.Framework.BusinessLogic.GenericEntity.Generated.Orders (in Aptify.Framework.BusinessLogic.GenericEntity.Generated.Orders.dll)

See Also

OrderLinesClass Members | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrderLinesClass Members

OrderLinesClass overview

Public Instance Constructors

OrderLinesClass Constructor Initializes a new instance of the OrderLinesClass class.

Public Instance Properties

AgentOrderNumber |
Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
AutoRenew |
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
CampaignCodeID |
ChapterID |
Comments |
CommentsExternal |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
Description |
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
Discount |
DiscountAmount |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
Extended |
ExtendedAttributeID |
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
ID |
InHonorOfID |
InMemoryOfID |
InventoryLocationID |
IsBulkSubscription |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
NotReturnedToStock |
OrderID |
OriginalOrderDetailID |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSequence |
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
Price |
PriceName |
PriceOverrideComment |
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
Product |
ProductID |
ProductType |
PurchaseType |
Quantity |
QuantityShipped |
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Sequence |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
ShipToAddressID |
ShipToAddrLine1 |
ShipToAddrLine2 |
ShipToAddrLine3 |
ShipToAreaCode |
ShipToCity |
ShipToCountry |
ShipToCountryCode |
ShipToCounty |
ShipToID |
ShipToName |
ShipToPhone |
ShipToPhoneExtension |
ShipToPhoneID |
ShipToState |
ShipToZipCode |
ShipType |
ShipTypeID |
SubscriberID |
SubscriptionCopies |
SubscriptionStartDate |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
Taxable |
TaxIncludedInPrice |
TaxJurisdiction |
TaxJurisdictionID |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.
UserPricingOverride |

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
OrderLineTaxes |
OrderLineTaxesObject |
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

OrderLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrderLinesClass Constructor

Initializes a new instance of the OrderLinesClass class.

public OrderLinesClass();

See Also

OrderLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrderLinesClass Properties

The properties of the OrderLinesClass class are listed below. For a complete list of OrderLinesClass class members, see the OrderLinesClass Members topic.

Public Instance Properties

AgentOrderNumber |
Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
AutoRenew |
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
CampaignCodeID |
ChapterID |
Comments |
CommentsExternal |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
Description |
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
Discount |
DiscountAmount |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
Extended |
ExtendedAttributeID |
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
ID |
InHonorOfID |
InMemoryOfID |
InventoryLocationID |
IsBulkSubscription |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
NotReturnedToStock |
OrderID |
OriginalOrderDetailID |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSequence |
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
Price |
PriceName |
PriceOverrideComment |
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
Product |
ProductID |
ProductType |
PurchaseType |
Quantity |
QuantityShipped |
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Sequence |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
ShipToAddressID |
ShipToAddrLine1 |
ShipToAddrLine2 |
ShipToAddrLine3 |
ShipToAreaCode |
ShipToCity |
ShipToCountry |
ShipToCountryCode |
ShipToCounty |
ShipToID |
ShipToName |
ShipToPhone |
ShipToPhoneExtension |
ShipToPhoneID |
ShipToState |
ShipToZipCode |
ShipType |
ShipTypeID |
SubscriberID |
SubscriptionCopies |
SubscriptionStartDate |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
Taxable |
TaxIncludedInPrice |
TaxJurisdiction |
TaxJurisdictionID |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.
UserPricingOverride |

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

OrderLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AgentOrderNumber Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesClass.AgentOrderNumber Property

public virtual String AgentOrderNumber {get; set;}

See Also

OrderLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AutoRenew Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesClass.AutoRenew Property

public virtual Boolean AutoRenew {get; set;}

See Also

OrderLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CampaignCodeID Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesClass.CampaignCodeID Property

public virtual Int32 CampaignCodeID {get; set;}

See Also

OrderLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ChapterID Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesClass.ChapterID Property

public virtual Int32 ChapterID {get; set;}

See Also

OrderLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Comments Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesClass.Comments Property

public virtual String Comments {get; set;}

See Also

OrderLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CommentsExternal Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesClass.CommentsExternal Property

public virtual Boolean CommentsExternal {get; set;}

See Also

OrderLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Description Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesClass.Description Property

public virtual String Description {get; set;}

See Also

OrderLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Discount Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesClass.Discount Property

public virtual Decimal Discount {get; set;}

See Also

OrderLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


DiscountAmount Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesClass.DiscountAmount Property

public virtual Decimal DiscountAmount {get;}

See Also

OrderLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Extended Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesClass.Extended Property

public virtual Decimal Extended {get;}

See Also

OrderLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ExtendedAttributeID Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesClass.ExtendedAttributeID Property

public virtual Int32 ExtendedAttributeID {get; set;}

See Also

OrderLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesClass.ID Property

public virtual Int32 ID {get;}

See Also

OrderLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


InHonorOfID Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesClass.InHonorOfID Property

public virtual Int32 InHonorOfID {get; set;}

See Also

OrderLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


InMemoryOfID Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesClass.InMemoryOfID Property

public virtual Int32 InMemoryOfID {get; set;}

See Also

OrderLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


InventoryLocationID Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesClass.InventoryLocationID Property

public virtual Int32 InventoryLocationID {get; set;}

See Also

OrderLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


IsBulkSubscription Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesClass.IsBulkSubscription Property

public virtual Boolean IsBulkSubscription {get;}

See Also

OrderLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


NotReturnedToStock Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesClass.NotReturnedToStock Property

public virtual Boolean NotReturnedToStock {get; set;}

See Also

OrderLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrderID Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesClass.OrderID Property

public virtual Int32 OrderID {get;}

See Also

OrderLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OriginalOrderDetailID Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesClass.OriginalOrderDetailID Property

public virtual Int32 OriginalOrderDetailID {get; set;}

See Also

OrderLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ParentSequence Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesClass.ParentSequence Property

public virtual Int32 ParentSequence {get; set;}

See Also

OrderLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Price Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesClass.Price Property

public virtual Decimal Price {get; set;}

See Also

OrderLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PriceName Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesClass.PriceName Property

public virtual String PriceName {get; set;}

See Also

OrderLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PriceOverrideComment Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesClass.PriceOverrideComment Property

public virtual String PriceOverrideComment {get;}

See Also

OrderLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Product Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesClass.Product Property

public virtual String Product {get;}

See Also

OrderLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ProductID Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesClass.ProductID Property

public virtual Int32 ProductID {get; set;}

See Also

OrderLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ProductType Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesClass.ProductType Property

public virtual String ProductType {get;}

See Also

OrderLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PurchaseType Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesClass.PurchaseType Property

public virtual String PurchaseType {get; set;}

See Also

OrderLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Quantity Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesClass.Quantity Property

public virtual Decimal Quantity {get; set;}

See Also

OrderLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


QuantityShipped Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesClass.QuantityShipped Property

public virtual Decimal QuantityShipped {get; set;}

See Also

OrderLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Sequence Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesClass.Sequence Property

public virtual Int32 Sequence {get;}

See Also

OrderLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ShipToAddressID Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesClass.ShipToAddressID Property

public virtual Int32 ShipToAddressID {get; set;}

See Also

OrderLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ShipToAddrLine1 Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesClass.ShipToAddrLine1 Property

public virtual String ShipToAddrLine1 {get; set;}

See Also

OrderLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ShipToAddrLine2 Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesClass.ShipToAddrLine2 Property

public virtual String ShipToAddrLine2 {get; set;}

See Also

OrderLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ShipToAddrLine3 Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesClass.ShipToAddrLine3 Property

public virtual String ShipToAddrLine3 {get; set;}

See Also

OrderLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ShipToAreaCode Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesClass.ShipToAreaCode Property

public virtual String ShipToAreaCode {get; set;}

See Also

OrderLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ShipToCity Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesClass.ShipToCity Property

public virtual String ShipToCity {get; set;}

See Also

OrderLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ShipToCountry Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesClass.ShipToCountry Property

public virtual String ShipToCountry {get;}

See Also

OrderLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ShipToCountryCode Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesClass.ShipToCountryCode Property

public virtual String ShipToCountryCode {get; set;}

See Also

OrderLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ShipToCounty Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesClass.ShipToCounty Property

public virtual String ShipToCounty {get; set;}

See Also

OrderLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ShipToID Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesClass.ShipToID Property

public virtual Int32 ShipToID {get; set;}

See Also

OrderLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ShipToName Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesClass.ShipToName Property

public virtual String ShipToName {get;}

See Also

OrderLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ShipToPhone Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesClass.ShipToPhone Property

public virtual String ShipToPhone {get; set;}

See Also

OrderLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ShipToPhoneExtension Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesClass.ShipToPhoneExtension Property

public virtual String ShipToPhoneExtension {get; set;}

See Also

OrderLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ShipToPhoneID Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesClass.ShipToPhoneID Property

public virtual Int32 ShipToPhoneID {get; set;}

See Also

OrderLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ShipToState Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesClass.ShipToState Property

public virtual String ShipToState {get; set;}

See Also

OrderLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ShipToZipCode Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesClass.ShipToZipCode Property

public virtual String ShipToZipCode {get; set;}

See Also

OrderLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ShipType Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesClass.ShipType Property

public virtual String ShipType {get;}

See Also

OrderLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ShipTypeID Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesClass.ShipTypeID Property

public virtual Int32 ShipTypeID {get; set;}

See Also

OrderLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


SubscriberID Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesClass.SubscriberID Property

public virtual Int32 SubscriberID {get; set;}

See Also

OrderLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


SubscriptionCopies Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesClass.SubscriptionCopies Property

public virtual Int32 SubscriptionCopies {get; set;}

See Also

OrderLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


SubscriptionStartDate Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesClass.SubscriptionStartDate Property

public virtual DateTime SubscriptionStartDate {get; set;}

See Also

OrderLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Taxable Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesClass.Taxable Property

public virtual Boolean Taxable {get;}

See Also

OrderLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


TaxIncludedInPrice Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesClass.TaxIncludedInPrice Property

public virtual Boolean TaxIncludedInPrice {get; set;}

See Also

OrderLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


TaxJurisdiction Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesClass.TaxJurisdiction Property

public virtual String TaxJurisdiction {get;}

See Also

OrderLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


TaxJurisdictionID Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesClass.TaxJurisdictionID Property

public virtual Int32 TaxJurisdictionID {get; set;}

See Also

OrderLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


UserPricingOverride Property

Aptify 5.0 Software Development Kit (SDK)

OrderLinesClass.UserPricingOverride Property

public virtual Boolean UserPricingOverride {get; set;}

See Also

OrderLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrderLinesClass Methods

The methods of the OrderLinesClass class are listed below. For a complete list of OrderLinesClass class members, see the OrderLinesClass Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
OrderLineTaxes |
OrderLineTaxesObject |
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

OrderLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrderLinesClass.OrderLineTaxes Method

public virtual OrderLineTaxesClass OrderLineTaxes(
Int32 Index
);

See Also

OrderLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrderLinesClass.OrderLineTaxesObject Method

public virtual AptifySubTypeBase OrderLineTaxesObject();

See Also

OrderLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrderLineTaxesClass Class

For a list of all members of this type, see OrderLineTaxesClass Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
OrderLineTaxesClass

public class OrderLineTaxesClass : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity.Generated

Assembly: Aptify.Framework.BusinessLogic.GenericEntity.Generated.Orders (in Aptify.Framework.BusinessLogic.GenericEntity.Generated.Orders.dll)

See Also

OrderLineTaxesClass Members | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrderLineTaxesClass Members

OrderLineTaxesClass overview

Public Instance Constructors

OrderLineTaxesClass Constructor Initializes a new instance of the OrderLineTaxesClass class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
ID |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
IsSalesTaxExempted |
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
OrderDetailID |
OrderID |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
Rate |
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SalesTax |
SalesTaxRateID |
Sequence |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
TaxableAmount |
TaxAmount |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

OrderLineTaxesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrderLineTaxesClass Constructor

Initializes a new instance of the OrderLineTaxesClass class.

public OrderLineTaxesClass();

See Also

OrderLineTaxesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrderLineTaxesClass Properties

The properties of the OrderLineTaxesClass class are listed below. For a complete list of OrderLineTaxesClass class members, see the OrderLineTaxesClass Members topic.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
ID |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
IsSalesTaxExempted |
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
OrderDetailID |
OrderID |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
Rate |
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SalesTax |
SalesTaxRateID |
Sequence |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
TaxableAmount |
TaxAmount |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

OrderLineTaxesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

OrderLineTaxesClass.ID Property

public virtual Int32 ID {get;}

See Also

OrderLineTaxesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


IsSalesTaxExempted Property

Aptify 5.0 Software Development Kit (SDK)

OrderLineTaxesClass.IsSalesTaxExempted Property

public virtual Boolean IsSalesTaxExempted {get; set;}

See Also

OrderLineTaxesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrderDetailID Property

Aptify 5.0 Software Development Kit (SDK)

OrderLineTaxesClass.OrderDetailID Property

public virtual Int32 OrderDetailID {get;}

See Also

OrderLineTaxesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrderID Property

Aptify 5.0 Software Development Kit (SDK)

OrderLineTaxesClass.OrderID Property

public virtual Int32 OrderID {get;}

See Also

OrderLineTaxesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Rate Property

Aptify 5.0 Software Development Kit (SDK)

OrderLineTaxesClass.Rate Property

public virtual Decimal Rate {get; set;}

See Also

OrderLineTaxesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


SalesTax Property

Aptify 5.0 Software Development Kit (SDK)

OrderLineTaxesClass.SalesTax Property

public virtual String SalesTax {get;}

See Also

OrderLineTaxesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


SalesTaxRateID Property

Aptify 5.0 Software Development Kit (SDK)

OrderLineTaxesClass.SalesTaxRateID Property

public virtual Int32 SalesTaxRateID {get; set;}

See Also

OrderLineTaxesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Sequence Property

Aptify 5.0 Software Development Kit (SDK)

OrderLineTaxesClass.Sequence Property

public virtual Int32 Sequence {get;}

See Also

OrderLineTaxesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


TaxableAmount Property

Aptify 5.0 Software Development Kit (SDK)

OrderLineTaxesClass.TaxableAmount Property

public virtual Decimal TaxableAmount {get; set;}

See Also

OrderLineTaxesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


TaxAmount Property

Aptify 5.0 Software Development Kit (SDK)

OrderLineTaxesClass.TaxAmount Property

public virtual Decimal TaxAmount {get; set;}

See Also

OrderLineTaxesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrderPaymentScheduleClass Class

For a list of all members of this type, see OrderPaymentScheduleClass Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
OrderPaymentScheduleClass

public class OrderPaymentScheduleClass : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity.Generated

Assembly: Aptify.Framework.BusinessLogic.GenericEntity.Generated.Orders (in Aptify.Framework.BusinessLogic.GenericEntity.Generated.Orders.dll)

See Also

OrderPaymentScheduleClass Members | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrderPaymentScheduleClass Members

OrderPaymentScheduleClass overview

Public Instance Constructors

OrderPaymentScheduleClass Constructor Initializes a new instance of the OrderPaymentScheduleClass class.

Public Instance Properties

Amount |
Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DateField |
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
Description |
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
ID |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
OrderID |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PercentOfTotal |
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Sequence |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

OrderPaymentScheduleClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrderPaymentScheduleClass Constructor

Initializes a new instance of the OrderPaymentScheduleClass class.

public OrderPaymentScheduleClass();

See Also

OrderPaymentScheduleClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrderPaymentScheduleClass Properties

The properties of the OrderPaymentScheduleClass class are listed below. For a complete list of OrderPaymentScheduleClass class members, see the OrderPaymentScheduleClass Members topic.

Public Instance Properties

Amount |
Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DateField |
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
Description |
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
ID |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
OrderID |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PercentOfTotal |
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Sequence |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

OrderPaymentScheduleClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Amount Property

Aptify 5.0 Software Development Kit (SDK)

OrderPaymentScheduleClass.Amount Property

public virtual Decimal Amount {get; set;}

See Also

OrderPaymentScheduleClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


DateField Property

Aptify 5.0 Software Development Kit (SDK)

OrderPaymentScheduleClass.DateField Property

public virtual DateTime DateField {get; set;}

See Also

OrderPaymentScheduleClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Description Property

Aptify 5.0 Software Development Kit (SDK)

OrderPaymentScheduleClass.Description Property

public virtual String Description {get; set;}

See Also

OrderPaymentScheduleClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

OrderPaymentScheduleClass.ID Property

public virtual Int32 ID {get;}

See Also

OrderPaymentScheduleClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrderID Property

Aptify 5.0 Software Development Kit (SDK)

OrderPaymentScheduleClass.OrderID Property

public virtual Int32 OrderID {get;}

See Also

OrderPaymentScheduleClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PercentOfTotal Property

Aptify 5.0 Software Development Kit (SDK)

OrderPaymentScheduleClass.PercentOfTotal Property

public virtual Decimal PercentOfTotal {get; set;}

See Also

OrderPaymentScheduleClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Sequence Property

Aptify 5.0 Software Development Kit (SDK)

OrderPaymentScheduleClass.Sequence Property

public virtual Int32 Sequence {get;}

See Also

OrderPaymentScheduleClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrdersClass Class

For a list of all members of this type, see OrdersClass Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
OrdersClass
OrdersEntity

public class OrdersClass : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity.Generated

Assembly: Aptify.Framework.BusinessLogic.GenericEntity.Generated.Orders (in Aptify.Framework.BusinessLogic.GenericEntity.Generated.Orders.dll)

See Also

OrdersClass Members | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrdersClass Members

OrdersClass overview

Public Instance Constructors

OrdersClass Constructor Initializes a new instance of the OrdersClass class.

Public Instance Properties

ABA |
AccountName |
AccountNumber |
Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
ArrivalDate |
Balance |
Bank |
BasePaymentType |
BatchID |
BillToAddressID |
BillToAddressIDObject |
BillToAddrLine1 |
BillToAddrLine2 |
BillToAddrLine3 |
BillToAreaCode |
BillToCity |
BillToCompany |
BillToCompanyID |
BillToCountry |
BillToCountryCode |
BillToCountryCodeID |
BillToCounty |
BillToEmail |
BillToID |
BillToName |
BillToPhone |
BillToPhoneExtension |
BillToPhoneID |
BillToPhoneIDObject |
BillToSameAsShipTo |
BillToState |
BillToZipCode |
BranchName |
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
CALC_AdjustedTotal |
CALC_Discount |
CALC_GrandTotal |
CALC_HandlingCharge |
CALC_LineCount |
CALC_PaymentTotal |
CALC_SalesTax |
CALC_ShippingCharge |
CALC_ShippingExpense |
CALC_SubTotal |
CALC_TaxableTotal |
CampaignCodeID |
CampaignCodeName |
CancellationReasonID |
CashCtrlBatchID |
CCAccountNumber |
CCAuthCode |
CCExpireDate |
CCPartial |
CCSecurityNumber |
CheckNumber |
Comments |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CreditOrderID |
CurrencyType |
CurrencyTypeID |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
CustShipAcctNum |
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DateCreated |
DateUpdated |
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DepositDate |
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
DropShip |
DueDate |
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
Employee |
EmployeeID |
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
GrandTotal |
HoldUntil |
ID |
InitialPaymentAmount |
InvoiceMessage |
InvoiceNumber |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
Line1_ProductCategory |
Line1_ProductID |
Line1_ProductName |
OrderDate |
OrderLevel |
OrderLevelID |
OrderSource |
OrderSourceID |
OrderStatus |
OrderStatusID |
OrderType |
OrderTypeID |
Organization |
OrganizationID |
OriginalOrderID |
OverrideShippingCalc |
PackingSlipsPrinted |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PaymentInformationID |
PaymentScheduleOptions |
PayType |
PayTypeID |
PONumber |
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
PromiseDate |
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
ReferralListID |
ReferredBy |
ReferredByID |
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
ReturnShippingCharge |
SalesRep |
SalesRepID |
SalesTaxRate |
SalesTaxRateID |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
ShipCharge |
ShipDate |
ShipExpense |
ShippedBy |
ShippedByID |
ShipToAddressID |
ShipToAddressIDObject |
ShipToAddrLine1 |
ShipToAddrLine2 |
ShipToAddrLine3 |
ShipToAreaCode |
ShipToCity |
ShipToCompany |
ShipToCompanyID |
ShipToCountry |
ShipToCountryCode |
ShipToCountryCodeID |
ShipToCounty |
ShipToEmail |
ShipToID |
ShipToName |
ShipToPhone |
ShipToPhoneExtension |
ShipToPhoneID |
ShipToPhoneIDObject |
ShipToState |
ShipToZipCode |
ShipTrackingNum |
ShipType |
ShipTypeID |
SubscriptionID |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
TaxJurisdiction |
TaxJurisdictionID |
Terms |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.
WhoCreated |
WhoUpdated |

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
OrderCurrencySpotRate |
OrderCurrencySpotRateObject |
OrderGLEntry |
OrderGLEntryObject |
OrderInvAllocation |
OrderInvAllocationObject |
OrderLines |
OrderLinesObject |
OrderPaymentSchedule |
OrderPaymentScheduleObject |
OrderShipments |
OrderShipmentsObject |
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrdersClass Constructor

Initializes a new instance of the OrdersClass class.

public OrdersClass();

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrdersClass Properties

The properties of the OrdersClass class are listed below. For a complete list of OrdersClass class members, see the OrdersClass Members topic.

Public Instance Properties

ABA |
AccountName |
AccountNumber |
Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
ArrivalDate |
Balance |
Bank |
BasePaymentType |
BatchID |
BillToAddressID |
BillToAddressIDObject |
BillToAddrLine1 |
BillToAddrLine2 |
BillToAddrLine3 |
BillToAreaCode |
BillToCity |
BillToCompany |
BillToCompanyID |
BillToCountry |
BillToCountryCode |
BillToCountryCodeID |
BillToCounty |
BillToEmail |
BillToID |
BillToName |
BillToPhone |
BillToPhoneExtension |
BillToPhoneID |
BillToPhoneIDObject |
BillToSameAsShipTo |
BillToState |
BillToZipCode |
BranchName |
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
CALC_AdjustedTotal |
CALC_Discount |
CALC_GrandTotal |
CALC_HandlingCharge |
CALC_LineCount |
CALC_PaymentTotal |
CALC_SalesTax |
CALC_ShippingCharge |
CALC_ShippingExpense |
CALC_SubTotal |
CALC_TaxableTotal |
CampaignCodeID |
CampaignCodeName |
CancellationReasonID |
CashCtrlBatchID |
CCAccountNumber |
CCAuthCode |
CCExpireDate |
CCPartial |
CCSecurityNumber |
CheckNumber |
Comments |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CreditOrderID |
CurrencyType |
CurrencyTypeID |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
CustShipAcctNum |
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DateCreated |
DateUpdated |
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DepositDate |
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
DropShip |
DueDate |
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
Employee |
EmployeeID |
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
GrandTotal |
HoldUntil |
ID |
InitialPaymentAmount |
InvoiceMessage |
InvoiceNumber |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
Line1_ProductCategory |
Line1_ProductID |
Line1_ProductName |
OrderDate |
OrderLevel |
OrderLevelID |
OrderSource |
OrderSourceID |
OrderStatus |
OrderStatusID |
OrderType |
OrderTypeID |
Organization |
OrganizationID |
OriginalOrderID |
OverrideShippingCalc |
PackingSlipsPrinted |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PaymentInformationID |
PaymentScheduleOptions |
PayType |
PayTypeID |
PONumber |
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
PromiseDate |
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
ReferralListID |
ReferredBy |
ReferredByID |
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
ReturnShippingCharge |
SalesRep |
SalesRepID |
SalesTaxRate |
SalesTaxRateID |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
ShipCharge |
ShipDate |
ShipExpense |
ShippedBy |
ShippedByID |
ShipToAddressID |
ShipToAddressIDObject |
ShipToAddrLine1 |
ShipToAddrLine2 |
ShipToAddrLine3 |
ShipToAreaCode |
ShipToCity |
ShipToCompany |
ShipToCompanyID |
ShipToCountry |
ShipToCountryCode |
ShipToCountryCodeID |
ShipToCounty |
ShipToEmail |
ShipToID |
ShipToName |
ShipToPhone |
ShipToPhoneExtension |
ShipToPhoneID |
ShipToPhoneIDObject |
ShipToState |
ShipToZipCode |
ShipTrackingNum |
ShipType |
ShipTypeID |
SubscriptionID |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
TaxJurisdiction |
TaxJurisdictionID |
Terms |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.
WhoCreated |
WhoUpdated |

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ABA Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.ABA Property

public virtual String ABA {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AccountName Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.AccountName Property

public virtual String AccountName {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AccountNumber Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.AccountNumber Property

public virtual String AccountNumber {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ArrivalDate Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.ArrivalDate Property

public virtual DateTime ArrivalDate {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Balance Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.Balance Property

public virtual Decimal Balance {get;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Bank Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.Bank Property

public virtual String Bank {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BasePaymentType Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.BasePaymentType Property

public virtual String BasePaymentType {get;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BatchID Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.BatchID Property

public virtual Int32 BatchID {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BillToAddressID Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.BillToAddressID Property

public virtual Int32 BillToAddressID {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BillToAddressIDObject Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.BillToAddressIDObject Property

public virtual AptifyGenericEntityBase BillToAddressIDObject {get;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BillToAddrLine1 Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.BillToAddrLine1 Property

public virtual String BillToAddrLine1 {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BillToAddrLine2 Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.BillToAddrLine2 Property

public virtual String BillToAddrLine2 {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BillToAddrLine3 Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.BillToAddrLine3 Property

public virtual String BillToAddrLine3 {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BillToAreaCode Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.BillToAreaCode Property

public virtual String BillToAreaCode {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BillToCity Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.BillToCity Property

public virtual String BillToCity {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BillToCompany Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.BillToCompany Property

public virtual String BillToCompany {get;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BillToCompanyID Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.BillToCompanyID Property

public virtual Int32 BillToCompanyID {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BillToCountry Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.BillToCountry Property

public virtual String BillToCountry {get;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BillToCountryCode Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.BillToCountryCode Property

public virtual String BillToCountryCode {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BillToCountryCodeID Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.BillToCountryCodeID Property

public virtual Int32 BillToCountryCodeID {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BillToCounty Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.BillToCounty Property

public virtual String BillToCounty {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BillToEmail Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.BillToEmail Property

public virtual String BillToEmail {get;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BillToID Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.BillToID Property

public virtual Int32 BillToID {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BillToName Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.BillToName Property

public virtual String BillToName {get;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BillToPhone Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.BillToPhone Property

public virtual String BillToPhone {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BillToPhoneExtension Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.BillToPhoneExtension Property

public virtual String BillToPhoneExtension {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BillToPhoneID Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.BillToPhoneID Property

public virtual Int32 BillToPhoneID {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BillToPhoneIDObject Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.BillToPhoneIDObject Property

public virtual AptifyGenericEntityBase BillToPhoneIDObject {get;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BillToSameAsShipTo Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.BillToSameAsShipTo Property

public virtual Boolean BillToSameAsShipTo {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BillToState Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.BillToState Property

public virtual String BillToState {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BillToZipCode Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.BillToZipCode Property

public virtual String BillToZipCode {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BranchName Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.BranchName Property

public virtual String BranchName {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CALC_AdjustedTotal Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.CALC_AdjustedTotal Property

public virtual Decimal CALC_AdjustedTotal {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CALC_Discount Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.CALC_Discount Property

public virtual Decimal CALC_Discount {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CALC_GrandTotal Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.CALC_GrandTotal Property

public virtual Decimal CALC_GrandTotal {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CALC_HandlingCharge Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.CALC_HandlingCharge Property

public virtual Decimal CALC_HandlingCharge {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CALC_LineCount Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.CALC_LineCount Property

public virtual Int32 CALC_LineCount {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CALC_PaymentTotal Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.CALC_PaymentTotal Property

public virtual Decimal CALC_PaymentTotal {get;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CALC_SalesTax Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.CALC_SalesTax Property

public virtual Decimal CALC_SalesTax {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CALC_ShippingCharge Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.CALC_ShippingCharge Property

public virtual Decimal CALC_ShippingCharge {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CALC_ShippingExpense Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.CALC_ShippingExpense Property

public virtual Decimal CALC_ShippingExpense {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CALC_SubTotal Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.CALC_SubTotal Property

public virtual Decimal CALC_SubTotal {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CALC_TaxableTotal Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.CALC_TaxableTotal Property

public virtual Decimal CALC_TaxableTotal {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CampaignCodeID Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.CampaignCodeID Property

public virtual Int32 CampaignCodeID {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CampaignCodeName Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.CampaignCodeName Property

public virtual String CampaignCodeName {get;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CancellationReasonID Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.CancellationReasonID Property

public virtual Int32 CancellationReasonID {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CashCtrlBatchID Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.CashCtrlBatchID Property

public virtual Int32 CashCtrlBatchID {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CCAccountNumber Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.CCAccountNumber Property

public virtual String CCAccountNumber {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CCAuthCode Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.CCAuthCode Property

public virtual String CCAuthCode {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CCExpireDate Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.CCExpireDate Property

public virtual DateTime CCExpireDate {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CCPartial Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.CCPartial Property

public virtual String CCPartial {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CCSecurityNumber Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.CCSecurityNumber Property

public virtual String CCSecurityNumber {get;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CheckNumber Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.CheckNumber Property

public virtual String CheckNumber {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Comments Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.Comments Property

public virtual String Comments {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CreditOrderID Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.CreditOrderID Property

public virtual Int32 CreditOrderID {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CurrencyType Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.CurrencyType Property

public virtual String CurrencyType {get;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CurrencyTypeID Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.CurrencyTypeID Property

public virtual Int32 CurrencyTypeID {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CustShipAcctNum Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.CustShipAcctNum Property

public virtual String CustShipAcctNum {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


DateCreated Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.DateCreated Property

public virtual DateTime DateCreated {get;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


DateUpdated Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.DateUpdated Property

public virtual DateTime DateUpdated {get;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


DepositDate Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.DepositDate Property

public virtual DateTime DepositDate {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


DropShip Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.DropShip Property

public virtual Boolean DropShip {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


DueDate Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.DueDate Property

public virtual DateTime DueDate {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Employee Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.Employee Property

public virtual String Employee {get;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


EmployeeID Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.EmployeeID Property

public virtual Int32 EmployeeID {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


GrandTotal Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.GrandTotal Property

public virtual Decimal GrandTotal {get;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


HoldUntil Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.HoldUntil Property

public virtual DateTime HoldUntil {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.ID Property

public virtual Int32 ID {get;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


InitialPaymentAmount Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.InitialPaymentAmount Property

public virtual Decimal InitialPaymentAmount {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


InvoiceMessage Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.InvoiceMessage Property

public virtual String InvoiceMessage {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


InvoiceNumber Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.InvoiceNumber Property

public virtual String InvoiceNumber {get;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Line1_ProductCategory Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.Line1_ProductCategory Property

public virtual String Line1_ProductCategory {get;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Line1_ProductID Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.Line1_ProductID Property

public virtual Int32 Line1_ProductID {get;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Line1_ProductName Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.Line1_ProductName Property

public virtual String Line1_ProductName {get;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrderDate Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.OrderDate Property

public virtual DateTime OrderDate {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrderLevel Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.OrderLevel Property

public virtual String OrderLevel {get;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrderLevelID Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.OrderLevelID Property

public virtual Int32 OrderLevelID {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrderSource Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.OrderSource Property

public virtual String OrderSource {get;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrderSourceID Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.OrderSourceID Property

public virtual Int32 OrderSourceID {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrderStatus Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.OrderStatus Property

public virtual String OrderStatus {get;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrderStatusID Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.OrderStatusID Property

public virtual Int32 OrderStatusID {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrderType Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.OrderType Property

public virtual String OrderType {get;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrderTypeID Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.OrderTypeID Property

public virtual Int32 OrderTypeID {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Organization Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.Organization Property

public virtual String Organization {get;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrganizationID Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.OrganizationID Property

public virtual Int32 OrganizationID {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OriginalOrderID Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.OriginalOrderID Property

public virtual Int32 OriginalOrderID {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OverrideShippingCalc Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.OverrideShippingCalc Property

public virtual Boolean OverrideShippingCalc {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PackingSlipsPrinted Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.PackingSlipsPrinted Property

public virtual Boolean PackingSlipsPrinted {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PaymentInformationID Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.PaymentInformationID Property

public virtual Int32 PaymentInformationID {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PaymentScheduleOptions Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.PaymentScheduleOptions Property

public virtual String PaymentScheduleOptions {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PayType Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.PayType Property

public virtual String PayType {get;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PayTypeID Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.PayTypeID Property

public virtual Int32 PayTypeID {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PONumber Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.PONumber Property

public virtual String PONumber {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PromiseDate Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.PromiseDate Property

public virtual DateTime PromiseDate {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ReferralListID Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.ReferralListID Property

public virtual Int32 ReferralListID {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ReferredBy Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.ReferredBy Property

public virtual String ReferredBy {get;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ReferredByID Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.ReferredByID Property

public virtual Int32 ReferredByID {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ReturnShippingCharge Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.ReturnShippingCharge Property

public virtual Boolean ReturnShippingCharge {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


SalesRep Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.SalesRep Property

public virtual String SalesRep {get;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


SalesRepID Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.SalesRepID Property

public virtual Int32 SalesRepID {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


SalesTaxRate Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.SalesTaxRate Property

public virtual Decimal SalesTaxRate {get;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


SalesTaxRateID Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.SalesTaxRateID Property

public virtual Int32 SalesTaxRateID {get;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ShipCharge Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.ShipCharge Property

public virtual Decimal ShipCharge {get;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ShipDate Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.ShipDate Property

public virtual DateTime ShipDate {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ShipExpense Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.ShipExpense Property

public virtual Decimal ShipExpense {get;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ShippedBy Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.ShippedBy Property

public virtual String ShippedBy {get;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ShippedByID Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.ShippedByID Property

public virtual Int32 ShippedByID {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ShipToAddressID Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.ShipToAddressID Property

public virtual Int32 ShipToAddressID {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ShipToAddressIDObject Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.ShipToAddressIDObject Property

public virtual AptifyGenericEntityBase ShipToAddressIDObject {get;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ShipToAddrLine1 Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.ShipToAddrLine1 Property

public virtual String ShipToAddrLine1 {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ShipToAddrLine2 Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.ShipToAddrLine2 Property

public virtual String ShipToAddrLine2 {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ShipToAddrLine3 Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.ShipToAddrLine3 Property

public virtual String ShipToAddrLine3 {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ShipToAreaCode Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.ShipToAreaCode Property

public virtual String ShipToAreaCode {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ShipToCity Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.ShipToCity Property

public virtual String ShipToCity {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ShipToCompany Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.ShipToCompany Property

public virtual String ShipToCompany {get;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ShipToCompanyID Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.ShipToCompanyID Property

public virtual Int32 ShipToCompanyID {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ShipToCountry Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.ShipToCountry Property

public virtual String ShipToCountry {get;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ShipToCountryCode Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.ShipToCountryCode Property

public virtual String ShipToCountryCode {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ShipToCountryCodeID Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.ShipToCountryCodeID Property

public virtual Int32 ShipToCountryCodeID {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ShipToCounty Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.ShipToCounty Property

public virtual String ShipToCounty {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ShipToEmail Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.ShipToEmail Property

public virtual String ShipToEmail {get;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ShipToID Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.ShipToID Property

public virtual Int32 ShipToID {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ShipToName Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.ShipToName Property

public virtual String ShipToName {get;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ShipToPhone Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.ShipToPhone Property

public virtual String ShipToPhone {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ShipToPhoneExtension Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.ShipToPhoneExtension Property

public virtual String ShipToPhoneExtension {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ShipToPhoneID Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.ShipToPhoneID Property

public virtual Int32 ShipToPhoneID {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ShipToPhoneIDObject Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.ShipToPhoneIDObject Property

public virtual AptifyGenericEntityBase ShipToPhoneIDObject {get;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ShipToState Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.ShipToState Property

public virtual String ShipToState {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ShipToZipCode Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.ShipToZipCode Property

public virtual String ShipToZipCode {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ShipTrackingNum Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.ShipTrackingNum Property

public virtual String ShipTrackingNum {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ShipType Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.ShipType Property

public virtual String ShipType {get;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ShipTypeID Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.ShipTypeID Property

public virtual Int32 ShipTypeID {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


SubscriptionID Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.SubscriptionID Property

public virtual Int32 SubscriptionID {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


TaxJurisdiction Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.TaxJurisdiction Property

public virtual String TaxJurisdiction {get;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


TaxJurisdictionID Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.TaxJurisdictionID Property

public virtual Int32 TaxJurisdictionID {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Terms Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.Terms Property

public virtual String Terms {get; set;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


WhoCreated Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.WhoCreated Property

public virtual String WhoCreated {get;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


WhoUpdated Property

Aptify 5.0 Software Development Kit (SDK)

OrdersClass.WhoUpdated Property

public virtual String WhoUpdated {get;}

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrdersClass Methods

The methods of the OrdersClass class are listed below. For a complete list of OrdersClass class members, see the OrdersClass Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
OrderCurrencySpotRate |
OrderCurrencySpotRateObject |
OrderGLEntry |
OrderGLEntryObject |
OrderInvAllocation |
OrderInvAllocationObject |
OrderLines |
OrderLinesObject |
OrderPaymentSchedule |
OrderPaymentScheduleObject |
OrderShipments |
OrderShipmentsObject |
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrdersClass.OrderCurrencySpotRate Method

public virtual OrderCurrencySpotRateClass OrderCurrencySpotRate(
Int32 Index
);

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrdersClass.OrderCurrencySpotRateObject Method

public virtual AptifySubTypeBase OrderCurrencySpotRateObject();

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrdersClass.OrderGLEntry Method

public virtual OrderGLEntryClass OrderGLEntry(
Int32 Index
);

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrdersClass.OrderGLEntryObject Method

public virtual AptifySubTypeBase OrderGLEntryObject();

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrdersClass.OrderInvAllocation Method

public virtual OrderInvAllocationClass OrderInvAllocation(
Int32 Index
);

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrdersClass.OrderInvAllocationObject Method

public virtual AptifySubTypeBase OrderInvAllocationObject();

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrdersClass.OrderLines Method

public virtual OrderLinesClass OrderLines(
Int32 Index
);

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrdersClass.OrderLinesObject Method

public virtual AptifySubTypeBase OrderLinesObject();

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrdersClass.OrderPaymentSchedule Method

public virtual OrderPaymentScheduleClass OrderPaymentSchedule(
Int32 Index
);

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrdersClass.OrderPaymentScheduleObject Method

public virtual AptifySubTypeBase OrderPaymentScheduleObject();

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrdersClass.OrderShipments Method

public virtual OrderShipmentsClass OrderShipments(
Int32 Index
);

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrdersClass.OrderShipmentsObject Method

public virtual AptifySubTypeBase OrderShipmentsObject();

See Also

OrdersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrderShipmentsClass Class

For a list of all members of this type, see OrderShipmentsClass Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
OrderShipmentsClass
OrderShipmentsEntity

public class OrderShipmentsClass : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity.Generated

Assembly: Aptify.Framework.BusinessLogic.GenericEntity.Generated.Orders (in Aptify.Framework.BusinessLogic.GenericEntity.Generated.Orders.dll)

See Also

OrderShipmentsClass Members | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrderShipmentsClass Members

OrderShipmentsClass overview

Public Instance Constructors

OrderShipmentsClass Constructor Initializes a new instance of the OrderShipmentsClass class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
CustShippingAcctNum |
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
HandlingCharge |
ID |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
OrderID |
OverrideHandlingCalc |
OverrideShippingCalc |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Sequence |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
ShipmentTypeGrouping |
ShipmentTypeGroupingID |
ShipmentTypeMatrix |
ShipmentTypeMatrixID |
ShippingCharge |
ShippingCost |
ShipTo |
ShipToAddressID |
ShipToAddressIDObject |
ShipToID |
ShipTrackingNum |
ShipType |
ShipTypeID |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
TaxIncludedInCharges |
TaxJurisdiction |
TaxJurisdictionID |
TotalQuantity |
TotalWeight |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.
WeightUnits |

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
OrderShipmentTaxes |
OrderShipmentTaxesObject |
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

OrderShipmentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrderShipmentsClass Constructor

Initializes a new instance of the OrderShipmentsClass class.

public OrderShipmentsClass();

See Also

OrderShipmentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrderShipmentsClass Properties

The properties of the OrderShipmentsClass class are listed below. For a complete list of OrderShipmentsClass class members, see the OrderShipmentsClass Members topic.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
CustShippingAcctNum |
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
HandlingCharge |
ID |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
OrderID |
OverrideHandlingCalc |
OverrideShippingCalc |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Sequence |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
ShipmentTypeGrouping |
ShipmentTypeGroupingID |
ShipmentTypeMatrix |
ShipmentTypeMatrixID |
ShippingCharge |
ShippingCost |
ShipTo |
ShipToAddressID |
ShipToAddressIDObject |
ShipToID |
ShipTrackingNum |
ShipType |
ShipTypeID |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
TaxIncludedInCharges |
TaxJurisdiction |
TaxJurisdictionID |
TotalQuantity |
TotalWeight |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.
WeightUnits |

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

OrderShipmentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CustShippingAcctNum Property

Aptify 5.0 Software Development Kit (SDK)

OrderShipmentsClass.CustShippingAcctNum Property

public virtual String CustShippingAcctNum {get; set;}

See Also

OrderShipmentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


HandlingCharge Property

Aptify 5.0 Software Development Kit (SDK)

OrderShipmentsClass.HandlingCharge Property

public virtual Decimal HandlingCharge {get; set;}

See Also

OrderShipmentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

OrderShipmentsClass.ID Property

public virtual Int32 ID {get;}

See Also

OrderShipmentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrderID Property

Aptify 5.0 Software Development Kit (SDK)

OrderShipmentsClass.OrderID Property

public virtual Int32 OrderID {get;}

See Also

OrderShipmentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OverrideHandlingCalc Property

Aptify 5.0 Software Development Kit (SDK)

OrderShipmentsClass.OverrideHandlingCalc Property

public virtual Boolean OverrideHandlingCalc {get; set;}

See Also

OrderShipmentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OverrideShippingCalc Property

Aptify 5.0 Software Development Kit (SDK)

OrderShipmentsClass.OverrideShippingCalc Property

public virtual Boolean OverrideShippingCalc {get; set;}

See Also

OrderShipmentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Sequence Property

Aptify 5.0 Software Development Kit (SDK)

OrderShipmentsClass.Sequence Property

public virtual Int32 Sequence {get;}

See Also

OrderShipmentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ShipmentTypeGrouping Property

Aptify 5.0 Software Development Kit (SDK)

OrderShipmentsClass.ShipmentTypeGrouping Property

public virtual String ShipmentTypeGrouping {get;}

See Also

OrderShipmentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ShipmentTypeGroupingID Property

Aptify 5.0 Software Development Kit (SDK)

OrderShipmentsClass.ShipmentTypeGroupingID Property

public virtual Int32 ShipmentTypeGroupingID {get; set;}

See Also

OrderShipmentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ShipmentTypeMatrix Property

Aptify 5.0 Software Development Kit (SDK)

OrderShipmentsClass.ShipmentTypeMatrix Property

public virtual String ShipmentTypeMatrix {get;}

See Also

OrderShipmentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ShipmentTypeMatrixID Property

Aptify 5.0 Software Development Kit (SDK)

OrderShipmentsClass.ShipmentTypeMatrixID Property

public virtual Int32 ShipmentTypeMatrixID {get; set;}

See Also

OrderShipmentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ShippingCharge Property

Aptify 5.0 Software Development Kit (SDK)

OrderShipmentsClass.ShippingCharge Property

public virtual Decimal ShippingCharge {get; set;}

See Also

OrderShipmentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ShippingCost Property

Aptify 5.0 Software Development Kit (SDK)

OrderShipmentsClass.ShippingCost Property

public virtual Decimal ShippingCost {get; set;}

See Also

OrderShipmentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ShipTo Property

Aptify 5.0 Software Development Kit (SDK)

OrderShipmentsClass.ShipTo Property

public virtual String ShipTo {get;}

See Also

OrderShipmentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ShipToAddressID Property

Aptify 5.0 Software Development Kit (SDK)

OrderShipmentsClass.ShipToAddressID Property

public virtual Int32 ShipToAddressID {get; set;}

See Also

OrderShipmentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ShipToAddressIDObject Property

Aptify 5.0 Software Development Kit (SDK)

OrderShipmentsClass.ShipToAddressIDObject Property

public virtual AptifyGenericEntityBase ShipToAddressIDObject {get;}

See Also

OrderShipmentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ShipToID Property

Aptify 5.0 Software Development Kit (SDK)

OrderShipmentsClass.ShipToID Property

public virtual Int32 ShipToID {get; set;}

See Also

OrderShipmentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ShipTrackingNum Property

Aptify 5.0 Software Development Kit (SDK)

OrderShipmentsClass.ShipTrackingNum Property

public virtual String ShipTrackingNum {get; set;}

See Also

OrderShipmentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ShipType Property

Aptify 5.0 Software Development Kit (SDK)

OrderShipmentsClass.ShipType Property

public virtual String ShipType {get;}

See Also

OrderShipmentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ShipTypeID Property

Aptify 5.0 Software Development Kit (SDK)

OrderShipmentsClass.ShipTypeID Property

public virtual Int32 ShipTypeID {get; set;}

See Also

OrderShipmentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


TaxIncludedInCharges Property

Aptify 5.0 Software Development Kit (SDK)

OrderShipmentsClass.TaxIncludedInCharges Property

public virtual Boolean TaxIncludedInCharges {get; set;}

See Also

OrderShipmentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


TaxJurisdiction Property

Aptify 5.0 Software Development Kit (SDK)

OrderShipmentsClass.TaxJurisdiction Property

public virtual String TaxJurisdiction {get;}

See Also

OrderShipmentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


TaxJurisdictionID Property

Aptify 5.0 Software Development Kit (SDK)

OrderShipmentsClass.TaxJurisdictionID Property

public virtual Int32 TaxJurisdictionID {get; set;}

See Also

OrderShipmentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


TotalQuantity Property

Aptify 5.0 Software Development Kit (SDK)

OrderShipmentsClass.TotalQuantity Property

public virtual Decimal TotalQuantity {get; set;}

See Also

OrderShipmentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


TotalWeight Property

Aptify 5.0 Software Development Kit (SDK)

OrderShipmentsClass.TotalWeight Property

public virtual Decimal TotalWeight {get; set;}

See Also

OrderShipmentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


WeightUnits Property

Aptify 5.0 Software Development Kit (SDK)

OrderShipmentsClass.WeightUnits Property

public virtual String WeightUnits {get; set;}

See Also

OrderShipmentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrderShipmentsClass Methods

The methods of the OrderShipmentsClass class are listed below. For a complete list of OrderShipmentsClass class members, see the OrderShipmentsClass Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
OrderShipmentTaxes |
OrderShipmentTaxesObject |
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

OrderShipmentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrderShipmentsClass.OrderShipmentTaxes Method

public virtual OrderShipmentTaxesClass OrderShipmentTaxes(
Int32 Index
);

See Also

OrderShipmentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrderShipmentsClass.OrderShipmentTaxesObject Method

public virtual AptifySubTypeBase OrderShipmentTaxesObject();

See Also

OrderShipmentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrderShipmentTaxesClass Class

For a list of all members of this type, see OrderShipmentTaxesClass Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
OrderShipmentTaxesClass

public class OrderShipmentTaxesClass : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity.Generated

Assembly: Aptify.Framework.BusinessLogic.GenericEntity.Generated.Orders (in Aptify.Framework.BusinessLogic.GenericEntity.Generated.Orders.dll)

See Also

OrderShipmentTaxesClass Members | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrderShipmentTaxesClass Members

OrderShipmentTaxesClass overview

Public Instance Constructors

OrderShipmentTaxesClass Constructor Initializes a new instance of the OrderShipmentTaxesClass class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
ID |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
IsSalesTaxExempted |
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
OrderID |
OrderShipmentID |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
Rate |
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SalesTax |
SalesTaxRateID |
Sequence |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
TaxableAmount |
TaxAmount |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

OrderShipmentTaxesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrderShipmentTaxesClass Constructor

Initializes a new instance of the OrderShipmentTaxesClass class.

public OrderShipmentTaxesClass();

See Also

OrderShipmentTaxesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrderShipmentTaxesClass Properties

The properties of the OrderShipmentTaxesClass class are listed below. For a complete list of OrderShipmentTaxesClass class members, see the OrderShipmentTaxesClass Members topic.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
ID |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
IsSalesTaxExempted |
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
OrderID |
OrderShipmentID |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
Rate |
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SalesTax |
SalesTaxRateID |
Sequence |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
TaxableAmount |
TaxAmount |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

OrderShipmentTaxesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

OrderShipmentTaxesClass.ID Property

public virtual Int32 ID {get;}

See Also

OrderShipmentTaxesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


IsSalesTaxExempted Property

Aptify 5.0 Software Development Kit (SDK)

OrderShipmentTaxesClass.IsSalesTaxExempted Property

public virtual Boolean IsSalesTaxExempted {get; set;}

See Also

OrderShipmentTaxesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrderID Property

Aptify 5.0 Software Development Kit (SDK)

OrderShipmentTaxesClass.OrderID Property

public virtual Int32 OrderID {get;}

See Also

OrderShipmentTaxesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrderShipmentID Property

Aptify 5.0 Software Development Kit (SDK)

OrderShipmentTaxesClass.OrderShipmentID Property

public virtual Int32 OrderShipmentID {get;}

See Also

OrderShipmentTaxesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Rate Property

Aptify 5.0 Software Development Kit (SDK)

OrderShipmentTaxesClass.Rate Property

public virtual Decimal Rate {get; set;}

See Also

OrderShipmentTaxesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


SalesTax Property

Aptify 5.0 Software Development Kit (SDK)

OrderShipmentTaxesClass.SalesTax Property

public virtual String SalesTax {get;}

See Also

OrderShipmentTaxesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


SalesTaxRateID Property

Aptify 5.0 Software Development Kit (SDK)

OrderShipmentTaxesClass.SalesTaxRateID Property

public virtual Int32 SalesTaxRateID {get; set;}

See Also

OrderShipmentTaxesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Sequence Property

Aptify 5.0 Software Development Kit (SDK)

OrderShipmentTaxesClass.Sequence Property

public virtual Int32 Sequence {get;}

See Also

OrderShipmentTaxesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


TaxableAmount Property

Aptify 5.0 Software Development Kit (SDK)

OrderShipmentTaxesClass.TaxableAmount Property

public virtual Decimal TaxableAmount {get; set;}

See Also

OrderShipmentTaxesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


TaxAmount Property

Aptify 5.0 Software Development Kit (SDK)

OrderShipmentTaxesClass.TaxAmount Property

public virtual Decimal TaxAmount {get; set;}

See Also

OrderShipmentTaxesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrganizationAddressesClass Class

For a list of all members of this type, see OrganizationAddressesClass Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
OrganizationAddressesClass

public class OrganizationAddressesClass : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity.Generated

Assembly: Aptify.Framework.BusinessLogic.GenericEntity.Generated.Organizations (in Aptify.Framework.BusinessLogic.GenericEntity.Generated.Organizations.dll)

See Also

OrganizationAddressesClass Members | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrganizationAddressesClass Members

OrganizationAddressesClass overview

Public Instance Constructors

OrganizationAddressesClass Constructor Initializes a new instance of the OrganizationAddressesClass class.

Public Instance Properties

AddressID |
Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
ID |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
Name |
OrganizationID |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Sequence |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

OrganizationAddressesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrganizationAddressesClass Constructor

Initializes a new instance of the OrganizationAddressesClass class.

public OrganizationAddressesClass();

See Also

OrganizationAddressesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrganizationAddressesClass Properties

The properties of the OrganizationAddressesClass class are listed below. For a complete list of OrganizationAddressesClass class members, see the OrganizationAddressesClass Members topic.

Public Instance Properties

AddressID |
Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
ID |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
Name |
OrganizationID |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Sequence |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

OrganizationAddressesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AddressID Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationAddressesClass.AddressID Property

public virtual Int32 AddressID {get; set;}

See Also

OrganizationAddressesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationAddressesClass.ID Property

public virtual Int32 ID {get;}

See Also

OrganizationAddressesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Name Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationAddressesClass.Name Property

public virtual String Name {get; set;}

See Also

OrganizationAddressesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrganizationID Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationAddressesClass.OrganizationID Property

public virtual Int32 OrganizationID {get;}

See Also

OrganizationAddressesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Sequence Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationAddressesClass.Sequence Property

public virtual Int32 Sequence {get;}

See Also

OrganizationAddressesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrganizationGLAccountsClass Class

For a list of all members of this type, see OrganizationGLAccountsClass Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
OrganizationGLAccountsClass

public class OrganizationGLAccountsClass : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity.Generated

Assembly: Aptify.Framework.BusinessLogic.GenericEntity.Generated.Organizations (in Aptify.Framework.BusinessLogic.GenericEntity.Generated.Organizations.dll)

See Also

OrganizationGLAccountsClass Members | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrganizationGLAccountsClass Members

OrganizationGLAccountsClass overview

Public Instance Constructors

OrganizationGLAccountsClass Constructor Initializes a new instance of the OrganizationGLAccountsClass class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
GLAccountNumber |
GLOrderLevel |
GLOrderLevel_Name |
ID |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
OrganizationID |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Sequence |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
Type |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

OrganizationGLAccountsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrganizationGLAccountsClass Constructor

Initializes a new instance of the OrganizationGLAccountsClass class.

public OrganizationGLAccountsClass();

See Also

OrganizationGLAccountsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrganizationGLAccountsClass Properties

The properties of the OrganizationGLAccountsClass class are listed below. For a complete list of OrganizationGLAccountsClass class members, see the OrganizationGLAccountsClass Members topic.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
GLAccountNumber |
GLOrderLevel |
GLOrderLevel_Name |
ID |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
OrganizationID |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Sequence |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
Type |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

OrganizationGLAccountsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


GLAccountNumber Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationGLAccountsClass.GLAccountNumber Property

public virtual String GLAccountNumber {get; set;}

See Also

OrganizationGLAccountsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


GLOrderLevel Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationGLAccountsClass.GLOrderLevel Property

public virtual Int32 GLOrderLevel {get; set;}

See Also

OrganizationGLAccountsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


GLOrderLevel_Name Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationGLAccountsClass.GLOrderLevel_Name Property

public virtual String GLOrderLevel_Name {get;}

See Also

OrganizationGLAccountsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationGLAccountsClass.ID Property

public virtual Int32 ID {get;}

See Also

OrganizationGLAccountsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrganizationID Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationGLAccountsClass.OrganizationID Property

public virtual Int32 OrganizationID {get;}

See Also

OrganizationGLAccountsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Sequence Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationGLAccountsClass.Sequence Property

public virtual Int32 Sequence {get;}

See Also

OrganizationGLAccountsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Type Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationGLAccountsClass.Type Property

public virtual String Type {get; set;}

See Also

OrganizationGLAccountsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrganizationInterCompanyGLClass Class

For a list of all members of this type, see OrganizationInterCompanyGLClass Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
OrganizationInterCompanyGLClass

public class OrganizationInterCompanyGLClass : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity.Generated

Assembly: Aptify.Framework.BusinessLogic.GenericEntity.Generated.Organizations (in Aptify.Framework.BusinessLogic.GenericEntity.Generated.Organizations.dll)

See Also

OrganizationInterCompanyGLClass Members | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrganizationInterCompanyGLClass Members

OrganizationInterCompanyGLClass overview

Public Instance Constructors

OrganizationInterCompanyGLClass Constructor Initializes a new instance of the OrganizationInterCompanyGLClass class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
Comments |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
DueFromGLAccount |
DueToGLAccount |
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
ID |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
OrganizationID |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RelatedOrganizationID |
RelatedOrganizationID_Name |
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Sequence |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

OrganizationInterCompanyGLClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrganizationInterCompanyGLClass Constructor

Initializes a new instance of the OrganizationInterCompanyGLClass class.

public OrganizationInterCompanyGLClass();

See Also

OrganizationInterCompanyGLClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrganizationInterCompanyGLClass Properties

The properties of the OrganizationInterCompanyGLClass class are listed below. For a complete list of OrganizationInterCompanyGLClass class members, see the OrganizationInterCompanyGLClass Members topic.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
Comments |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
DueFromGLAccount |
DueToGLAccount |
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
ID |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
OrganizationID |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RelatedOrganizationID |
RelatedOrganizationID_Name |
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Sequence |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

OrganizationInterCompanyGLClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Comments Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationInterCompanyGLClass.Comments Property

public virtual String Comments {get; set;}

See Also

OrganizationInterCompanyGLClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


DueFromGLAccount Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationInterCompanyGLClass.DueFromGLAccount Property

public virtual String DueFromGLAccount {get; set;}

See Also

OrganizationInterCompanyGLClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


DueToGLAccount Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationInterCompanyGLClass.DueToGLAccount Property

public virtual String DueToGLAccount {get; set;}

See Also

OrganizationInterCompanyGLClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationInterCompanyGLClass.ID Property

public virtual Int32 ID {get;}

See Also

OrganizationInterCompanyGLClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrganizationID Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationInterCompanyGLClass.OrganizationID Property

public virtual Int32 OrganizationID {get;}

See Also

OrganizationInterCompanyGLClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


RelatedOrganizationID Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationInterCompanyGLClass.RelatedOrganizationID Property

public virtual Int32 RelatedOrganizationID {get; set;}

See Also

OrganizationInterCompanyGLClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


RelatedOrganizationID_Name Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationInterCompanyGLClass.RelatedOrganizationID_Name Property

public virtual String RelatedOrganizationID_Name {get;}

See Also

OrganizationInterCompanyGLClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Sequence Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationInterCompanyGLClass.Sequence Property

public virtual Int32 Sequence {get;}

See Also

OrganizationInterCompanyGLClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrganizationsClass Class

For a list of all members of this type, see OrganizationsClass Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
OrganizationsClass
OrganizationObject

public class OrganizationsClass : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity.Generated

Assembly: Aptify.Framework.BusinessLogic.GenericEntity.Generated.Organizations (in Aptify.Framework.BusinessLogic.GenericEntity.Generated.Organizations.dll)

See Also

OrganizationsClass Members | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrganizationsClass Members

OrganizationsClass overview

Public Instance Constructors

OrganizationsClass Constructor Initializes a new instance of the OrganizationsClass class.

Public Instance Properties

AddressID |
AddressIDObject |
AddressLine1 |
AddressLine2 |
AddressLine3 |
AddressLine4 |
AllowFree |
AllowPriceOverride |
AllowPriceSelection |
AllowRelatedProductPromptClose |
Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BillingAddressID |
BillingAddressIDObject |
BillingAddressLine1 |
BillingAddressLine2 |
BillingAddressLine3 |
BillingAddressLine4 |
BillingCity |
BillingCountry |
BillingCounty |
BillingPostalCode |
BillingState |
BillingStateProvince |
BillingTerms |
BillingZipCode |
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
City |
Comments |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
ConversionAdjustmentGLAccount |
Country |
County |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DateCreated |
DateUpdated |
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
Directions |
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
Established |
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExchangeRateGainGLAccount |
ExchangeRateLossGLAccount |
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
FedTaxID |
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
FiscalYearEnd |
FunctionalCurrencyType |
FunctionalCurrencyTypeID |
GenerateInterCompanyEntries |
ID |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
MainAreaCode |
MainCountryCode |
MainEmail |
MainFaxAreaCode |
MainFaxCountryCode |
MainFaxExtension |
MainFaxID |
MainFaxIDObject |
MainFaxNumber |
MainPhone |
MainPhoneExtension |
MainPhoneID |
MainPhoneIDObject |
Name |
NumberEmployees |
OwnType |
Parent |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentID |
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PostalCode |
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
PrimaryShareholder |
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Revenue |
RootOrganization |
RootOrganizationID |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
State |
StateProvince |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.
WebSite |
WhoCreated |
WhoUpdated |
ZipCode |

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
OrganizationAddresses |
OrganizationAddressesObject |
OrganizationGLAccounts |
OrganizationGLAccountsObject |
OrganizationInterCompanyGL |
OrganizationInterCompanyGLObject |
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrganizationsClass Constructor

Initializes a new instance of the OrganizationsClass class.

public OrganizationsClass();

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrganizationsClass Properties

The properties of the OrganizationsClass class are listed below. For a complete list of OrganizationsClass class members, see the OrganizationsClass Members topic.

Public Instance Properties

AddressID |
AddressIDObject |
AddressLine1 |
AddressLine2 |
AddressLine3 |
AddressLine4 |
AllowFree |
AllowPriceOverride |
AllowPriceSelection |
AllowRelatedProductPromptClose |
Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BillingAddressID |
BillingAddressIDObject |
BillingAddressLine1 |
BillingAddressLine2 |
BillingAddressLine3 |
BillingAddressLine4 |
BillingCity |
BillingCountry |
BillingCounty |
BillingPostalCode |
BillingState |
BillingStateProvince |
BillingTerms |
BillingZipCode |
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
City |
Comments |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
ConversionAdjustmentGLAccount |
Country |
County |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DateCreated |
DateUpdated |
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
Directions |
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
Established |
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExchangeRateGainGLAccount |
ExchangeRateLossGLAccount |
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
FedTaxID |
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
FiscalYearEnd |
FunctionalCurrencyType |
FunctionalCurrencyTypeID |
GenerateInterCompanyEntries |
ID |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
MainAreaCode |
MainCountryCode |
MainEmail |
MainFaxAreaCode |
MainFaxCountryCode |
MainFaxExtension |
MainFaxID |
MainFaxIDObject |
MainFaxNumber |
MainPhone |
MainPhoneExtension |
MainPhoneID |
MainPhoneIDObject |
Name |
NumberEmployees |
OwnType |
Parent |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentID |
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PostalCode |
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
PrimaryShareholder |
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Revenue |
RootOrganization |
RootOrganizationID |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
State |
StateProvince |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.
WebSite |
WhoCreated |
WhoUpdated |
ZipCode |

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AddressID Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationsClass.AddressID Property

public virtual Int32 AddressID {get; set;}

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AddressIDObject Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationsClass.AddressIDObject Property

public virtual AptifyGenericEntityBase AddressIDObject {get;}

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AddressLine1 Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationsClass.AddressLine1 Property

public virtual String AddressLine1 {get; set;}

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AddressLine2 Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationsClass.AddressLine2 Property

public virtual String AddressLine2 {get; set;}

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AddressLine3 Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationsClass.AddressLine3 Property

public virtual String AddressLine3 {get; set;}

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AddressLine4 Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationsClass.AddressLine4 Property

public virtual String AddressLine4 {get; set;}

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AllowFree Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationsClass.AllowFree Property

public virtual Boolean AllowFree {get; set;}

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AllowPriceOverride Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationsClass.AllowPriceOverride Property

public virtual Boolean AllowPriceOverride {get; set;}

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AllowPriceSelection Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationsClass.AllowPriceSelection Property

public virtual Boolean AllowPriceSelection {get; set;}

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AllowRelatedProductPromptClose Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationsClass.AllowRelatedProductPromptClose Property

public virtual Boolean AllowRelatedProductPromptClose {get; set;}

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BillingAddressID Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationsClass.BillingAddressID Property

public virtual Int32 BillingAddressID {get; set;}

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BillingAddressIDObject Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationsClass.BillingAddressIDObject Property

public virtual AptifyGenericEntityBase BillingAddressIDObject {get;}

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BillingAddressLine1 Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationsClass.BillingAddressLine1 Property

public virtual String BillingAddressLine1 {get; set;}

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BillingAddressLine2 Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationsClass.BillingAddressLine2 Property

public virtual String BillingAddressLine2 {get; set;}

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BillingAddressLine3 Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationsClass.BillingAddressLine3 Property

public virtual String BillingAddressLine3 {get; set;}

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BillingAddressLine4 Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationsClass.BillingAddressLine4 Property

public virtual String BillingAddressLine4 {get; set;}

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BillingCity Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationsClass.BillingCity Property

public virtual String BillingCity {get; set;}

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BillingCountry Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationsClass.BillingCountry Property

public virtual String BillingCountry {get;}

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BillingCounty Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationsClass.BillingCounty Property

public virtual String BillingCounty {get; set;}

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BillingPostalCode Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationsClass.BillingPostalCode Property

public virtual String BillingPostalCode {get; set;}

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BillingState Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationsClass.BillingState Property

public virtual String BillingState {get; set;}

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BillingStateProvince Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationsClass.BillingStateProvince Property

public virtual String BillingStateProvince {get; set;}

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BillingTerms Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationsClass.BillingTerms Property

public virtual String BillingTerms {get; set;}

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BillingZipCode Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationsClass.BillingZipCode Property

public virtual String BillingZipCode {get; set;}

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


City Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationsClass.City Property

public virtual String City {get; set;}

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Comments Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationsClass.Comments Property

public virtual String Comments {get; set;}

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ConversionAdjustmentGLAccount Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationsClass.ConversionAdjustmentGLAccount Property

public virtual String ConversionAdjustmentGLAccount {get; set;}

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Country Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationsClass.Country Property

public virtual String Country {get;}

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


County Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationsClass.County Property

public virtual String County {get; set;}

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


DateCreated Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationsClass.DateCreated Property

public virtual DateTime DateCreated {get;}

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


DateUpdated Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationsClass.DateUpdated Property

public virtual DateTime DateUpdated {get;}

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Directions Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationsClass.Directions Property

public virtual String Directions {get; set;}

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Established Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationsClass.Established Property

public virtual DateTime Established {get; set;}

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ExchangeRateGainGLAccount Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationsClass.ExchangeRateGainGLAccount Property

public virtual String ExchangeRateGainGLAccount {get; set;}

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ExchangeRateLossGLAccount Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationsClass.ExchangeRateLossGLAccount Property

public virtual String ExchangeRateLossGLAccount {get; set;}

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


FedTaxID Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationsClass.FedTaxID Property

public virtual String FedTaxID {get; set;}

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


FiscalYearEnd Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationsClass.FiscalYearEnd Property

public virtual DateTime FiscalYearEnd {get; set;}

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


FunctionalCurrencyType Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationsClass.FunctionalCurrencyType Property

public virtual String FunctionalCurrencyType {get;}

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


FunctionalCurrencyTypeID Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationsClass.FunctionalCurrencyTypeID Property

public virtual Int32 FunctionalCurrencyTypeID {get; set;}

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


GenerateInterCompanyEntries Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationsClass.GenerateInterCompanyEntries Property

public virtual Boolean GenerateInterCompanyEntries {get; set;}

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationsClass.ID Property

public virtual Int32 ID {get;}

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


MainAreaCode Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationsClass.MainAreaCode Property

public virtual String MainAreaCode {get; set;}

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


MainCountryCode Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationsClass.MainCountryCode Property

public virtual String MainCountryCode {get; set;}

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


MainEmail Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationsClass.MainEmail Property

public virtual String MainEmail {get; set;}

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


MainFaxAreaCode Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationsClass.MainFaxAreaCode Property

public virtual String MainFaxAreaCode {get; set;}

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


MainFaxCountryCode Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationsClass.MainFaxCountryCode Property

public virtual String MainFaxCountryCode {get; set;}

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


MainFaxExtension Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationsClass.MainFaxExtension Property

public virtual String MainFaxExtension {get; set;}

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


MainFaxID Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationsClass.MainFaxID Property

public virtual Int32 MainFaxID {get; set;}

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


MainFaxIDObject Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationsClass.MainFaxIDObject Property

public virtual AptifyGenericEntityBase MainFaxIDObject {get;}

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


MainFaxNumber Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationsClass.MainFaxNumber Property

public virtual String MainFaxNumber {get; set;}

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


MainPhone Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationsClass.MainPhone Property

public virtual String MainPhone {get; set;}

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


MainPhoneExtension Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationsClass.MainPhoneExtension Property

public virtual String MainPhoneExtension {get; set;}

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


MainPhoneID Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationsClass.MainPhoneID Property

public virtual Int32 MainPhoneID {get; set;}

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


MainPhoneIDObject Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationsClass.MainPhoneIDObject Property

public virtual AptifyGenericEntityBase MainPhoneIDObject {get;}

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Name Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationsClass.Name Property

public virtual String Name {get; set;}

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


NumberEmployees Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationsClass.NumberEmployees Property

public virtual Int32 NumberEmployees {get; set;}

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OwnType Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationsClass.OwnType Property

public virtual String OwnType {get; set;}

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Parent Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationsClass.Parent Property

public virtual String Parent {get;}

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ParentID Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationsClass.ParentID Property

public virtual Int32 ParentID {get; set;}

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PostalCode Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationsClass.PostalCode Property

public virtual String PostalCode {get; set;}

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PrimaryShareholder Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationsClass.PrimaryShareholder Property

public virtual String PrimaryShareholder {get; set;}

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Revenue Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationsClass.Revenue Property

public virtual Decimal Revenue {get; set;}

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


RootOrganization Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationsClass.RootOrganization Property

public virtual String RootOrganization {get;}

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


RootOrganizationID Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationsClass.RootOrganizationID Property

public virtual Int32 RootOrganizationID {get;}

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


State Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationsClass.State Property

public virtual String State {get; set;}

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


StateProvince Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationsClass.StateProvince Property

public virtual String StateProvince {get; set;}

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


WebSite Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationsClass.WebSite Property

public virtual String WebSite {get; set;}

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


WhoCreated Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationsClass.WhoCreated Property

public virtual String WhoCreated {get;}

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


WhoUpdated Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationsClass.WhoUpdated Property

public virtual String WhoUpdated {get;}

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ZipCode Property

Aptify 5.0 Software Development Kit (SDK)

OrganizationsClass.ZipCode Property

public virtual String ZipCode {get; set;}

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrganizationsClass Methods

The methods of the OrganizationsClass class are listed below. For a complete list of OrganizationsClass class members, see the OrganizationsClass Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
OrganizationAddresses |
OrganizationAddressesObject |
OrganizationGLAccounts |
OrganizationGLAccountsObject |
OrganizationInterCompanyGL |
OrganizationInterCompanyGLObject |
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrganizationsClass.OrganizationAddresses Method

public virtual OrganizationAddressesClass OrganizationAddresses(
Int32 Index
);

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrganizationsClass.OrganizationAddressesObject Method

public virtual AptifySubTypeBase OrganizationAddressesObject();

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrganizationsClass.OrganizationGLAccounts Method

public virtual OrganizationGLAccountsClass OrganizationGLAccounts(
Int32 Index
);

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrganizationsClass.OrganizationGLAccountsObject Method

public virtual AptifySubTypeBase OrganizationGLAccountsObject();

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrganizationsClass.OrganizationInterCompanyGL Method

public virtual OrganizationInterCompanyGLClass OrganizationInterCompanyGL(
Int32 Index
);

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrganizationsClass.OrganizationInterCompanyGLObject Method

public virtual AptifySubTypeBase OrganizationInterCompanyGLObject();

See Also

OrganizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PaymentAuthorizationsClass Class

For a list of all members of this type, see PaymentAuthorizationsClass Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
PaymentAuthorizationsClass

public class PaymentAuthorizationsClass : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity.Generated

Assembly: Aptify.Framework.BusinessLogic.GenericEntity.Generated.Payments (in Aptify.Framework.BusinessLogic.GenericEntity.Generated.Payments.dll)

See Also

PaymentAuthorizationsClass Members | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PaymentAuthorizationsClass Members

PaymentAuthorizationsClass overview

Public Instance Constructors

PaymentAuthorizationsClass Constructor Initializes a new instance of the PaymentAuthorizationsClass class.

Public Instance Properties

Amount |
Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
AuthorizationCode |
AuthorizationDate |
AuthorizationType |
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
ID |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
MerchantAccount |
MerchantAccountID |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PaymentID |
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
ProcessorRefNumber |
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
ReferenceNumber |
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Sequence |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

PaymentAuthorizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PaymentAuthorizationsClass Constructor

Initializes a new instance of the PaymentAuthorizationsClass class.

public PaymentAuthorizationsClass();

See Also

PaymentAuthorizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PaymentAuthorizationsClass Properties

The properties of the PaymentAuthorizationsClass class are listed below. For a complete list of PaymentAuthorizationsClass class members, see the PaymentAuthorizationsClass Members topic.

Public Instance Properties

Amount |
Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
AuthorizationCode |
AuthorizationDate |
AuthorizationType |
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
ID |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
MerchantAccount |
MerchantAccountID |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PaymentID |
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
ProcessorRefNumber |
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
ReferenceNumber |
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Sequence |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

PaymentAuthorizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Amount Property

Aptify 5.0 Software Development Kit (SDK)

PaymentAuthorizationsClass.Amount Property

public virtual Decimal Amount {get; set;}

See Also

PaymentAuthorizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AuthorizationCode Property

Aptify 5.0 Software Development Kit (SDK)

PaymentAuthorizationsClass.AuthorizationCode Property

public virtual String AuthorizationCode {get; set;}

See Also

PaymentAuthorizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AuthorizationDate Property

Aptify 5.0 Software Development Kit (SDK)

PaymentAuthorizationsClass.AuthorizationDate Property

public virtual DateTime AuthorizationDate {get; set;}

See Also

PaymentAuthorizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AuthorizationType Property

Aptify 5.0 Software Development Kit (SDK)

PaymentAuthorizationsClass.AuthorizationType Property

public virtual String AuthorizationType {get; set;}

See Also

PaymentAuthorizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

PaymentAuthorizationsClass.ID Property

public virtual Int32 ID {get;}

See Also

PaymentAuthorizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


MerchantAccount Property

Aptify 5.0 Software Development Kit (SDK)

PaymentAuthorizationsClass.MerchantAccount Property

public virtual String MerchantAccount {get;}

See Also

PaymentAuthorizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


MerchantAccountID Property

Aptify 5.0 Software Development Kit (SDK)

PaymentAuthorizationsClass.MerchantAccountID Property

public virtual Int32 MerchantAccountID {get; set;}

See Also

PaymentAuthorizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PaymentID Property

Aptify 5.0 Software Development Kit (SDK)

PaymentAuthorizationsClass.PaymentID Property

public virtual Int32 PaymentID {get;}

See Also

PaymentAuthorizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ProcessorRefNumber Property

Aptify 5.0 Software Development Kit (SDK)

PaymentAuthorizationsClass.ProcessorRefNumber Property

public virtual String ProcessorRefNumber {get; set;}

See Also

PaymentAuthorizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ReferenceNumber Property

Aptify 5.0 Software Development Kit (SDK)

PaymentAuthorizationsClass.ReferenceNumber Property

public virtual String ReferenceNumber {get; set;}

See Also

PaymentAuthorizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Sequence Property

Aptify 5.0 Software Development Kit (SDK)

PaymentAuthorizationsClass.Sequence Property

public virtual Int32 Sequence {get;}

See Also

PaymentAuthorizationsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PaymentGLEntryClass Class

For a list of all members of this type, see PaymentGLEntryClass Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
PaymentGLEntryClass

public class PaymentGLEntryClass : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity.Generated

Assembly: Aptify.Framework.BusinessLogic.GenericEntity.Generated.Payments (in Aptify.Framework.BusinessLogic.GenericEntity.Generated.Payments.dll)

See Also

PaymentGLEntryClass Members | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PaymentGLEntryClass Members

PaymentGLEntryClass overview

Public Instance Constructors

PaymentGLEntryClass Constructor Initializes a new instance of the PaymentGLEntryClass class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CreditAmount |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DebitAmount |
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
Description |
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
GLAccount |
ID |
IsCustom |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PaymentID |
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Sequence |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

PaymentGLEntryClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PaymentGLEntryClass Constructor

Initializes a new instance of the PaymentGLEntryClass class.

public PaymentGLEntryClass();

See Also

PaymentGLEntryClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PaymentGLEntryClass Properties

The properties of the PaymentGLEntryClass class are listed below. For a complete list of PaymentGLEntryClass class members, see the PaymentGLEntryClass Members topic.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CreditAmount |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DebitAmount |
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
Description |
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
GLAccount |
ID |
IsCustom |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PaymentID |
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Sequence |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

PaymentGLEntryClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CreditAmount Property

Aptify 5.0 Software Development Kit (SDK)

PaymentGLEntryClass.CreditAmount Property

public virtual Decimal CreditAmount {get; set;}

See Also

PaymentGLEntryClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


DebitAmount Property

Aptify 5.0 Software Development Kit (SDK)

PaymentGLEntryClass.DebitAmount Property

public virtual Decimal DebitAmount {get; set;}

See Also

PaymentGLEntryClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Description Property

Aptify 5.0 Software Development Kit (SDK)

PaymentGLEntryClass.Description Property

public virtual String Description {get; set;}

See Also

PaymentGLEntryClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


GLAccount Property

Aptify 5.0 Software Development Kit (SDK)

PaymentGLEntryClass.GLAccount Property

public virtual String GLAccount {get; set;}

See Also

PaymentGLEntryClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

PaymentGLEntryClass.ID Property

public virtual Int32 ID {get;}

See Also

PaymentGLEntryClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


IsCustom Property

Aptify 5.0 Software Development Kit (SDK)

PaymentGLEntryClass.IsCustom Property

public virtual Boolean IsCustom {get; set;}

See Also

PaymentGLEntryClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PaymentID Property

Aptify 5.0 Software Development Kit (SDK)

PaymentGLEntryClass.PaymentID Property

public virtual Int32 PaymentID {get;}

See Also

PaymentGLEntryClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Sequence Property

Aptify 5.0 Software Development Kit (SDK)

PaymentGLEntryClass.Sequence Property

public virtual Int32 Sequence {get;}

See Also

PaymentGLEntryClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PaymentLinesClass Class

For a list of all members of this type, see PaymentLinesClass Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
PaymentLinesClass
PaymentLinesEntity

public class PaymentLinesClass : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity.Generated

Assembly: Aptify.Framework.BusinessLogic.GenericEntity.Generated.Payments (in Aptify.Framework.BusinessLogic.GenericEntity.Generated.Payments.dll)

See Also

PaymentLinesClass Members | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PaymentLinesClass Members

PaymentLinesClass overview

Public Instance Constructors

PaymentLinesClass Constructor Initializes a new instance of the PaymentLinesClass class.

Public Instance Properties

Amount |
AmountCurrencyType |
AmountCurrencyTypeID |
Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
AppliesTo |
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
Comments |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
ConversionAdjustmentAmount |
ConversionCurrencySpotRate |
ConversionCurrencySpotRateID |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
ID |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
IsShipping |
IsTax |
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LineNumber |
OrderDetailID |
OrderID |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PaymentAmount |
PaymentID |
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Sequence |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

PaymentLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PaymentLinesClass Constructor

Initializes a new instance of the PaymentLinesClass class.

public PaymentLinesClass();

See Also

PaymentLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PaymentLinesClass Properties

The properties of the PaymentLinesClass class are listed below. For a complete list of PaymentLinesClass class members, see the PaymentLinesClass Members topic.

Public Instance Properties

Amount |
AmountCurrencyType |
AmountCurrencyTypeID |
Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
AppliesTo |
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
Comments |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
ConversionAdjustmentAmount |
ConversionCurrencySpotRate |
ConversionCurrencySpotRateID |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
ID |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
IsShipping |
IsTax |
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LineNumber |
OrderDetailID |
OrderID |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PaymentAmount |
PaymentID |
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Sequence |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

PaymentLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Amount Property

Aptify 5.0 Software Development Kit (SDK)

PaymentLinesClass.Amount Property

public virtual Decimal Amount {get; set;}

See Also

PaymentLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AmountCurrencyType Property

Aptify 5.0 Software Development Kit (SDK)

PaymentLinesClass.AmountCurrencyType Property

public virtual String AmountCurrencyType {get;}

See Also

PaymentLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AmountCurrencyTypeID Property

Aptify 5.0 Software Development Kit (SDK)

PaymentLinesClass.AmountCurrencyTypeID Property

public virtual Int32 AmountCurrencyTypeID {get; set;}

See Also

PaymentLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AppliesTo Property

Aptify 5.0 Software Development Kit (SDK)

PaymentLinesClass.AppliesTo Property

public virtual String AppliesTo {get; set;}

See Also

PaymentLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Comments Property

Aptify 5.0 Software Development Kit (SDK)

PaymentLinesClass.Comments Property

public virtual String Comments {get; set;}

See Also

PaymentLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ConversionAdjustmentAmount Property

Aptify 5.0 Software Development Kit (SDK)

PaymentLinesClass.ConversionAdjustmentAmount Property

public virtual Decimal ConversionAdjustmentAmount {get; set;}

See Also

PaymentLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ConversionCurrencySpotRate Property

Aptify 5.0 Software Development Kit (SDK)

PaymentLinesClass.ConversionCurrencySpotRate Property

public virtual String ConversionCurrencySpotRate {get;}

See Also

PaymentLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ConversionCurrencySpotRateID Property

Aptify 5.0 Software Development Kit (SDK)

PaymentLinesClass.ConversionCurrencySpotRateID Property

public virtual Int32 ConversionCurrencySpotRateID {get; set;}

See Also

PaymentLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

PaymentLinesClass.ID Property

public virtual Int32 ID {get;}

See Also

PaymentLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


IsShipping Property

Aptify 5.0 Software Development Kit (SDK)

PaymentLinesClass.IsShipping Property

public virtual Boolean IsShipping {get;}

See Also

PaymentLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


IsTax Property

Aptify 5.0 Software Development Kit (SDK)

PaymentLinesClass.IsTax Property

public virtual Boolean IsTax {get;}

See Also

PaymentLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


LineNumber Property

Aptify 5.0 Software Development Kit (SDK)

PaymentLinesClass.LineNumber Property

public virtual Int32 LineNumber {get;}

See Also

PaymentLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrderDetailID Property

Aptify 5.0 Software Development Kit (SDK)

PaymentLinesClass.OrderDetailID Property

public virtual Int32 OrderDetailID {get; set;}

See Also

PaymentLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrderID Property

Aptify 5.0 Software Development Kit (SDK)

PaymentLinesClass.OrderID Property

public virtual Int32 OrderID {get; set;}

See Also

PaymentLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PaymentAmount Property

Aptify 5.0 Software Development Kit (SDK)

PaymentLinesClass.PaymentAmount Property

public virtual Decimal PaymentAmount {get; set;}

See Also

PaymentLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PaymentID Property

Aptify 5.0 Software Development Kit (SDK)

PaymentLinesClass.PaymentID Property

public virtual Int32 PaymentID {get;}

See Also

PaymentLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Sequence Property

Aptify 5.0 Software Development Kit (SDK)

PaymentLinesClass.Sequence Property

public virtual Int32 Sequence {get;}

See Also

PaymentLinesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PaymentsClass Class

For a list of all members of this type, see PaymentsClass Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
PaymentsClass
PaymentsEntity

public class PaymentsClass : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity.Generated

Assembly: Aptify.Framework.BusinessLogic.GenericEntity.Generated.Payments (in Aptify.Framework.BusinessLogic.GenericEntity.Generated.Payments.dll)

See Also

PaymentsClass Members | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PaymentsClass Members

PaymentsClass overview

Public Instance Constructors

PaymentsClass Constructor Initializes a new instance of the PaymentsClass class.

Public Instance Properties

ABA |
AccountName |
AccountNumber |
APExportRunID |
APImportRunID |
Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
Bank |
BatchID |
BranchName |
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
CALC_Amount |
CALC_ConversionAdjustmentAmount |
CashCtrlBatchID |
CCAccountNumber |
CCAuthCode |
CCAuthType |
CCExpireDate |
CCPartial |
CCSecurityNumber |
CheckNumber |
Comments |
CompanyID |
CompanyName |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CreditOrderID |
CurrencySpotRateID |
CurrencyType |
CurrencyTypeID |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DateCreated |
DateExportedToAP |
DateImportedFromAP |
DateUpdated |
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DepositDate |
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EffectiveDate |
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
Employee |
EmployeeID |
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
ID |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
IsRefund |
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
Organization |
OrganizationID |
PaidBy |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PaymentAmount |
PaymentDate |
PaymentInformationID |
PaymentLevel |
PaymentLevelID |
PaymentStatusID |
PaymentStatusInfo |
PaymentType |
PaymentTypeID |
PersonID |
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RefundCheckNumber |
RefundPaidDate |
RefundPayeeName |
RefundReason |
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
ServiceCharge |
ServiceChargeGLAccount |
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
Status |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
Type |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.
WhoCreated |
WhoUpdated |

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
PaymentAuthorizations |
PaymentAuthorizationsObject |
PaymentGLEntry |
PaymentGLEntryObject |
PaymentLines |
PaymentLinesObject |
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

PaymentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PaymentsClass Constructor

Initializes a new instance of the PaymentsClass class.

public PaymentsClass();

See Also

PaymentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PaymentsClass Properties

The properties of the PaymentsClass class are listed below. For a complete list of PaymentsClass class members, see the PaymentsClass Members topic.

Public Instance Properties

ABA |
AccountName |
AccountNumber |
APExportRunID |
APImportRunID |
Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
Bank |
BatchID |
BranchName |
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
CALC_Amount |
CALC_ConversionAdjustmentAmount |
CashCtrlBatchID |
CCAccountNumber |
CCAuthCode |
CCAuthType |
CCExpireDate |
CCPartial |
CCSecurityNumber |
CheckNumber |
Comments |
CompanyID |
CompanyName |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CreditOrderID |
CurrencySpotRateID |
CurrencyType |
CurrencyTypeID |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DateCreated |
DateExportedToAP |
DateImportedFromAP |
DateUpdated |
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DepositDate |
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EffectiveDate |
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
Employee |
EmployeeID |
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
ID |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
IsRefund |
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
Organization |
OrganizationID |
PaidBy |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PaymentAmount |
PaymentDate |
PaymentInformationID |
PaymentLevel |
PaymentLevelID |
PaymentStatusID |
PaymentStatusInfo |
PaymentType |
PaymentTypeID |
PersonID |
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RefundCheckNumber |
RefundPaidDate |
RefundPayeeName |
RefundReason |
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
ServiceCharge |
ServiceChargeGLAccount |
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
Status |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
Type |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.
WhoCreated |
WhoUpdated |

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

PaymentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ABA Property

Aptify 5.0 Software Development Kit (SDK)

PaymentsClass.ABA Property

public virtual String ABA {get; set;}

See Also

PaymentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AccountName Property

Aptify 5.0 Software Development Kit (SDK)

PaymentsClass.AccountName Property

public virtual String AccountName {get; set;}

See Also

PaymentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AccountNumber Property

Aptify 5.0 Software Development Kit (SDK)

PaymentsClass.AccountNumber Property

public virtual String AccountNumber {get; set;}

See Also

PaymentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


APExportRunID Property

Aptify 5.0 Software Development Kit (SDK)

PaymentsClass.APExportRunID Property

public virtual Int32 APExportRunID {get; set;}

See Also

PaymentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


APImportRunID Property

Aptify 5.0 Software Development Kit (SDK)

PaymentsClass.APImportRunID Property

public virtual Int32 APImportRunID {get; set;}

See Also

PaymentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Bank Property

Aptify 5.0 Software Development Kit (SDK)

PaymentsClass.Bank Property

public virtual String Bank {get; set;}

See Also

PaymentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BatchID Property

Aptify 5.0 Software Development Kit (SDK)

PaymentsClass.BatchID Property

public virtual Int32 BatchID {get; set;}

See Also

PaymentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BranchName Property

Aptify 5.0 Software Development Kit (SDK)

PaymentsClass.BranchName Property

public virtual String BranchName {get; set;}

See Also

PaymentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CALC_Amount Property

Aptify 5.0 Software Development Kit (SDK)

PaymentsClass.CALC_Amount Property

public virtual Decimal CALC_Amount {get;}

See Also

PaymentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CALC_ConversionAdjustmentAmount Property

Aptify 5.0 Software Development Kit (SDK)

PaymentsClass.CALC_ConversionAdjustmentAmount Property

public virtual Decimal CALC_ConversionAdjustmentAmount {get;}

See Also

PaymentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CashCtrlBatchID Property

Aptify 5.0 Software Development Kit (SDK)

PaymentsClass.CashCtrlBatchID Property

public virtual Int32 CashCtrlBatchID {get; set;}

See Also

PaymentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CCAccountNumber Property

Aptify 5.0 Software Development Kit (SDK)

PaymentsClass.CCAccountNumber Property

public virtual String CCAccountNumber {get; set;}

See Also

PaymentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CCAuthCode Property

Aptify 5.0 Software Development Kit (SDK)

PaymentsClass.CCAuthCode Property

public virtual String CCAuthCode {get; set;}

See Also

PaymentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CCAuthType Property

Aptify 5.0 Software Development Kit (SDK)

PaymentsClass.CCAuthType Property

public virtual String CCAuthType {get; set;}

See Also

PaymentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CCExpireDate Property

Aptify 5.0 Software Development Kit (SDK)

PaymentsClass.CCExpireDate Property

public virtual DateTime CCExpireDate {get; set;}

See Also

PaymentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CCPartial Property

Aptify 5.0 Software Development Kit (SDK)

PaymentsClass.CCPartial Property

public virtual String CCPartial {get; set;}

See Also

PaymentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CCSecurityNumber Property

Aptify 5.0 Software Development Kit (SDK)

PaymentsClass.CCSecurityNumber Property

public virtual String CCSecurityNumber {get;}

See Also

PaymentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CheckNumber Property

Aptify 5.0 Software Development Kit (SDK)

PaymentsClass.CheckNumber Property

public virtual String CheckNumber {get; set;}

See Also

PaymentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Comments Property

Aptify 5.0 Software Development Kit (SDK)

PaymentsClass.Comments Property

public virtual String Comments {get; set;}

See Also

PaymentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CompanyID Property

Aptify 5.0 Software Development Kit (SDK)

PaymentsClass.CompanyID Property

public virtual Int32 CompanyID {get; set;}

See Also

PaymentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CompanyName Property

Aptify 5.0 Software Development Kit (SDK)

PaymentsClass.CompanyName Property

public virtual String CompanyName {get;}

See Also

PaymentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CreditOrderID Property

Aptify 5.0 Software Development Kit (SDK)

PaymentsClass.CreditOrderID Property

public virtual Int32 CreditOrderID {get; set;}

See Also

PaymentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CurrencySpotRateID Property

Aptify 5.0 Software Development Kit (SDK)

PaymentsClass.CurrencySpotRateID Property

public virtual Int32 CurrencySpotRateID {get; set;}

See Also

PaymentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CurrencyType Property

Aptify 5.0 Software Development Kit (SDK)

PaymentsClass.CurrencyType Property

public virtual String CurrencyType {get;}

See Also

PaymentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CurrencyTypeID Property

Aptify 5.0 Software Development Kit (SDK)

PaymentsClass.CurrencyTypeID Property

public virtual Int32 CurrencyTypeID {get; set;}

See Also

PaymentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


DateCreated Property

Aptify 5.0 Software Development Kit (SDK)

PaymentsClass.DateCreated Property

public virtual DateTime DateCreated {get;}

See Also

PaymentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


DateExportedToAP Property

Aptify 5.0 Software Development Kit (SDK)

PaymentsClass.DateExportedToAP Property

public virtual DateTime DateExportedToAP {get; set;}

See Also

PaymentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


DateImportedFromAP Property

Aptify 5.0 Software Development Kit (SDK)

PaymentsClass.DateImportedFromAP Property

public virtual DateTime DateImportedFromAP {get; set;}

See Also

PaymentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


DateUpdated Property

Aptify 5.0 Software Development Kit (SDK)

PaymentsClass.DateUpdated Property

public virtual DateTime DateUpdated {get;}

See Also

PaymentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


DepositDate Property

Aptify 5.0 Software Development Kit (SDK)

PaymentsClass.DepositDate Property

public virtual DateTime DepositDate {get; set;}

See Also

PaymentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


EffectiveDate Property

Aptify 5.0 Software Development Kit (SDK)

PaymentsClass.EffectiveDate Property

public virtual DateTime EffectiveDate {get; set;}

See Also

PaymentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Employee Property

Aptify 5.0 Software Development Kit (SDK)

PaymentsClass.Employee Property

public virtual String Employee {get;}

See Also

PaymentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


EmployeeID Property

Aptify 5.0 Software Development Kit (SDK)

PaymentsClass.EmployeeID Property

public virtual Int32 EmployeeID {get; set;}

See Also

PaymentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

PaymentsClass.ID Property

public virtual Int32 ID {get;}

See Also

PaymentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


IsRefund Property

Aptify 5.0 Software Development Kit (SDK)

PaymentsClass.IsRefund Property

public virtual Boolean IsRefund {get; set;}

See Also

PaymentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Organization Property

Aptify 5.0 Software Development Kit (SDK)

PaymentsClass.Organization Property

public virtual String Organization {get;}

See Also

PaymentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrganizationID Property

Aptify 5.0 Software Development Kit (SDK)

PaymentsClass.OrganizationID Property

public virtual Int32 OrganizationID {get; set;}

See Also

PaymentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PaidBy Property

Aptify 5.0 Software Development Kit (SDK)

PaymentsClass.PaidBy Property

public virtual String PaidBy {get;}

See Also

PaymentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PaymentAmount Property

Aptify 5.0 Software Development Kit (SDK)

PaymentsClass.PaymentAmount Property

public virtual Decimal PaymentAmount {get;}

See Also

PaymentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PaymentDate Property

Aptify 5.0 Software Development Kit (SDK)

PaymentsClass.PaymentDate Property

public virtual DateTime PaymentDate {get; set;}

See Also

PaymentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PaymentInformationID Property

Aptify 5.0 Software Development Kit (SDK)

PaymentsClass.PaymentInformationID Property

public virtual Int32 PaymentInformationID {get; set;}

See Also

PaymentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PaymentLevel Property

Aptify 5.0 Software Development Kit (SDK)

PaymentsClass.PaymentLevel Property

public virtual String PaymentLevel {get;}

See Also

PaymentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PaymentLevelID Property

Aptify 5.0 Software Development Kit (SDK)

PaymentsClass.PaymentLevelID Property

public virtual Int32 PaymentLevelID {get; set;}

See Also

PaymentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PaymentStatusID Property

Aptify 5.0 Software Development Kit (SDK)

PaymentsClass.PaymentStatusID Property

public virtual Int32 PaymentStatusID {get; set;}

See Also

PaymentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PaymentStatusInfo Property

Aptify 5.0 Software Development Kit (SDK)

PaymentsClass.PaymentStatusInfo Property

public virtual String PaymentStatusInfo {get; set;}

See Also

PaymentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PaymentType Property

Aptify 5.0 Software Development Kit (SDK)

PaymentsClass.PaymentType Property

public virtual String PaymentType {get;}

See Also

PaymentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PaymentTypeID Property

Aptify 5.0 Software Development Kit (SDK)

PaymentsClass.PaymentTypeID Property

public virtual Int32 PaymentTypeID {get; set;}

See Also

PaymentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonID Property

Aptify 5.0 Software Development Kit (SDK)

PaymentsClass.PersonID Property

public virtual Int32 PersonID {get; set;}

See Also

PaymentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


RefundCheckNumber Property

Aptify 5.0 Software Development Kit (SDK)

PaymentsClass.RefundCheckNumber Property

public virtual String RefundCheckNumber {get; set;}

See Also

PaymentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


RefundPaidDate Property

Aptify 5.0 Software Development Kit (SDK)

PaymentsClass.RefundPaidDate Property

public virtual DateTime RefundPaidDate {get; set;}

See Also

PaymentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


RefundPayeeName Property

Aptify 5.0 Software Development Kit (SDK)

PaymentsClass.RefundPayeeName Property

public virtual String RefundPayeeName {get; set;}

See Also

PaymentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


RefundReason Property

Aptify 5.0 Software Development Kit (SDK)

PaymentsClass.RefundReason Property

public virtual String RefundReason {get; set;}

See Also

PaymentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ServiceCharge Property

Aptify 5.0 Software Development Kit (SDK)

PaymentsClass.ServiceCharge Property

public virtual Decimal ServiceCharge {get; set;}

See Also

PaymentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ServiceChargeGLAccount Property

Aptify 5.0 Software Development Kit (SDK)

PaymentsClass.ServiceChargeGLAccount Property

public virtual String ServiceChargeGLAccount {get; set;}

See Also

PaymentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Status Property

Aptify 5.0 Software Development Kit (SDK)

PaymentsClass.Status Property

public virtual String Status {get;}

See Also

PaymentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Type Property

Aptify 5.0 Software Development Kit (SDK)

PaymentsClass.Type Property

public virtual String Type {get;}

See Also

PaymentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


WhoCreated Property

Aptify 5.0 Software Development Kit (SDK)

PaymentsClass.WhoCreated Property

public virtual String WhoCreated {get;}

See Also

PaymentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


WhoUpdated Property

Aptify 5.0 Software Development Kit (SDK)

PaymentsClass.WhoUpdated Property

public virtual String WhoUpdated {get;}

See Also

PaymentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PaymentsClass Methods

The methods of the PaymentsClass class are listed below. For a complete list of PaymentsClass class members, see the PaymentsClass Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
PaymentAuthorizations |
PaymentAuthorizationsObject |
PaymentGLEntry |
PaymentGLEntryObject |
PaymentLines |
PaymentLinesObject |
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

PaymentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PaymentsClass.PaymentAuthorizations Method

public virtual PaymentAuthorizationsClass PaymentAuthorizations(
Int32 Index
);

See Also

PaymentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PaymentsClass.PaymentAuthorizationsObject Method

public virtual AptifySubTypeBase PaymentAuthorizationsObject();

See Also

PaymentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PaymentsClass.PaymentGLEntry Method

public virtual PaymentGLEntryClass PaymentGLEntry(
Int32 Index
);

See Also

PaymentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PaymentsClass.PaymentGLEntryObject Method

public virtual AptifySubTypeBase PaymentGLEntryObject();

See Also

PaymentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PaymentsClass.PaymentLines Method

public virtual PaymentLinesClass PaymentLines(
Int32 Index
);

See Also

PaymentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PaymentsClass.PaymentLinesObject Method

public virtual AptifySubTypeBase PaymentLinesObject();

See Also

PaymentsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonAccountManagersClass Class

For a list of all members of this type, see PersonAccountManagersClass Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
PersonAccountManagersClass

public class PersonAccountManagersClass : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity.Generated

Assembly: Aptify.Framework.BusinessLogic.GenericEntity.Generated.Persons (in Aptify.Framework.BusinessLogic.GenericEntity.Generated.Persons.dll)

See Also

PersonAccountManagersClass Members | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonAccountManagersClass Members

PersonAccountManagersClass overview

Public Instance Constructors

PersonAccountManagersClass Constructor Initializes a new instance of the PersonAccountManagersClass class.

Public Instance Properties

AccountManagerID |
AccountManagerID_Name |
Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
Comments |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EndDate |
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
ID |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
Organization |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PersonID |
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Sequence |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
StartDate |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

PersonAccountManagersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonAccountManagersClass Constructor

Initializes a new instance of the PersonAccountManagersClass class.

public PersonAccountManagersClass();

See Also

PersonAccountManagersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonAccountManagersClass Properties

The properties of the PersonAccountManagersClass class are listed below. For a complete list of PersonAccountManagersClass class members, see the PersonAccountManagersClass Members topic.

Public Instance Properties

AccountManagerID |
AccountManagerID_Name |
Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
Comments |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EndDate |
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
ID |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
Organization |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PersonID |
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Sequence |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
StartDate |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

PersonAccountManagersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AccountManagerID Property

Aptify 5.0 Software Development Kit (SDK)

PersonAccountManagersClass.AccountManagerID Property

public virtual Int32 AccountManagerID {get; set;}

See Also

PersonAccountManagersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AccountManagerID_Name Property

Aptify 5.0 Software Development Kit (SDK)

PersonAccountManagersClass.AccountManagerID_Name Property

public virtual String AccountManagerID_Name {get;}

See Also

PersonAccountManagersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Comments Property

Aptify 5.0 Software Development Kit (SDK)

PersonAccountManagersClass.Comments Property

public virtual String Comments {get; set;}

See Also

PersonAccountManagersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


EndDate Property

Aptify 5.0 Software Development Kit (SDK)

PersonAccountManagersClass.EndDate Property

public virtual DateTime EndDate {get; set;}

See Also

PersonAccountManagersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

PersonAccountManagersClass.ID Property

public virtual Int32 ID {get;}

See Also

PersonAccountManagersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Organization Property

Aptify 5.0 Software Development Kit (SDK)

PersonAccountManagersClass.Organization Property

public virtual String Organization {get;}

See Also

PersonAccountManagersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonID Property

Aptify 5.0 Software Development Kit (SDK)

PersonAccountManagersClass.PersonID Property

public virtual Int32 PersonID {get;}

See Also

PersonAccountManagersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Sequence Property

Aptify 5.0 Software Development Kit (SDK)

PersonAccountManagersClass.Sequence Property

public virtual Int32 Sequence {get;}

See Also

PersonAccountManagersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


StartDate Property

Aptify 5.0 Software Development Kit (SDK)

PersonAccountManagersClass.StartDate Property

public virtual DateTime StartDate {get; set;}

See Also

PersonAccountManagersClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonAddressClass Class

For a list of all members of this type, see PersonAddressClass Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
PersonAddressClass

public class PersonAddressClass : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity.Generated

Assembly: Aptify.Framework.BusinessLogic.GenericEntity.Generated.Persons (in Aptify.Framework.BusinessLogic.GenericEntity.Generated.Persons.dll)

See Also

PersonAddressClass Members | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonAddressClass Members

PersonAddressClass overview

Public Instance Constructors

PersonAddressClass Constructor Initializes a new instance of the PersonAddressClass class.

Public Instance Properties

AddressID |
AddressLine1 |
AddressLine2 |
AddressLine3 |
AddressLine4 |
AddressTypeID |
AddressTypeID_Name |
Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
City |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
Country |
County |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultEndDate |
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DefaultSetting |
DefaultStartDate |
Description |
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
ID |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
Name |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PersonID |
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Sequence |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
State |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.
ZipCode |

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

PersonAddressClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonAddressClass Constructor

Initializes a new instance of the PersonAddressClass class.

public PersonAddressClass();

See Also

PersonAddressClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonAddressClass Properties

The properties of the PersonAddressClass class are listed below. For a complete list of PersonAddressClass class members, see the PersonAddressClass Members topic.

Public Instance Properties

AddressID |
AddressLine1 |
AddressLine2 |
AddressLine3 |
AddressLine4 |
AddressTypeID |
AddressTypeID_Name |
Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
City |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
Country |
County |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultEndDate |
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DefaultSetting |
DefaultStartDate |
Description |
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
ID |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
Name |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PersonID |
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Sequence |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
State |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.
ZipCode |

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

PersonAddressClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AddressID Property

Aptify 5.0 Software Development Kit (SDK)

PersonAddressClass.AddressID Property

public virtual Int32 AddressID {get; set;}

See Also

PersonAddressClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AddressLine1 Property

Aptify 5.0 Software Development Kit (SDK)

PersonAddressClass.AddressLine1 Property

public virtual String AddressLine1 {get; set;}

See Also

PersonAddressClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AddressLine2 Property

Aptify 5.0 Software Development Kit (SDK)

PersonAddressClass.AddressLine2 Property

public virtual String AddressLine2 {get; set;}

See Also

PersonAddressClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AddressLine3 Property

Aptify 5.0 Software Development Kit (SDK)

PersonAddressClass.AddressLine3 Property

public virtual String AddressLine3 {get; set;}

See Also

PersonAddressClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AddressLine4 Property

Aptify 5.0 Software Development Kit (SDK)

PersonAddressClass.AddressLine4 Property

public virtual String AddressLine4 {get; set;}

See Also

PersonAddressClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AddressTypeID Property

Aptify 5.0 Software Development Kit (SDK)

PersonAddressClass.AddressTypeID Property

public virtual Int32 AddressTypeID {get; set;}

See Also

PersonAddressClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AddressTypeID_Name Property

Aptify 5.0 Software Development Kit (SDK)

PersonAddressClass.AddressTypeID_Name Property

public virtual String AddressTypeID_Name {get;}

See Also

PersonAddressClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


City Property

Aptify 5.0 Software Development Kit (SDK)

PersonAddressClass.City Property

public virtual String City {get; set;}

See Also

PersonAddressClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Country Property

Aptify 5.0 Software Development Kit (SDK)

PersonAddressClass.Country Property

public virtual String Country {get;}

See Also

PersonAddressClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


County Property

Aptify 5.0 Software Development Kit (SDK)

PersonAddressClass.County Property

public virtual String County {get; set;}

See Also

PersonAddressClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


DefaultEndDate Property

Aptify 5.0 Software Development Kit (SDK)

PersonAddressClass.DefaultEndDate Property

public virtual DateTime DefaultEndDate {get; set;}

See Also

PersonAddressClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


DefaultSetting Property

Aptify 5.0 Software Development Kit (SDK)

PersonAddressClass.DefaultSetting Property

public virtual String DefaultSetting {get; set;}

See Also

PersonAddressClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


DefaultStartDate Property

Aptify 5.0 Software Development Kit (SDK)

PersonAddressClass.DefaultStartDate Property

public virtual DateTime DefaultStartDate {get; set;}

See Also

PersonAddressClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Description Property

Aptify 5.0 Software Development Kit (SDK)

PersonAddressClass.Description Property

public virtual String Description {get; set;}

See Also

PersonAddressClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

PersonAddressClass.ID Property

public virtual Int32 ID {get;}

See Also

PersonAddressClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Name Property

Aptify 5.0 Software Development Kit (SDK)

PersonAddressClass.Name Property

public virtual String Name {get; set;}

See Also

PersonAddressClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonID Property

Aptify 5.0 Software Development Kit (SDK)

PersonAddressClass.PersonID Property

public virtual Int32 PersonID {get;}

See Also

PersonAddressClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Sequence Property

Aptify 5.0 Software Development Kit (SDK)

PersonAddressClass.Sequence Property

public virtual Int32 Sequence {get;}

See Also

PersonAddressClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


State Property

Aptify 5.0 Software Development Kit (SDK)

PersonAddressClass.State Property

public virtual String State {get; set;}

See Also

PersonAddressClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ZipCode Property

Aptify 5.0 Software Development Kit (SDK)

PersonAddressClass.ZipCode Property

public virtual String ZipCode {get; set;}

See Also

PersonAddressClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonCompaniesClass Class

For a list of all members of this type, see PersonCompaniesClass Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
PersonCompaniesClass

public class PersonCompaniesClass : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity.Generated

Assembly: Aptify.Framework.BusinessLogic.GenericEntity.Generated.Persons (in Aptify.Framework.BusinessLogic.GenericEntity.Generated.Persons.dll)

See Also

PersonCompaniesClass Members | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonCompaniesClass Members

PersonCompaniesClass overview

Public Instance Constructors

PersonCompaniesClass Constructor Initializes a new instance of the PersonCompaniesClass class.

Public Instance Properties

AddressID |
AddressLine1 |
AddressLine2 |
AddressLine3 |
AddressLine4 |
Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
AssistantsAreaCode |
AssistantsCountryCode |
AssistantsName |
AssistantsPhone |
AssistantsPhoneExtension |
AssistantsPhoneID |
Atmosphere |
BillingAddressID |
BillingAddressLine1 |
BillingAddressLine2 |
BillingAddressLine3 |
BillingAddressLine4 |
BillingCity |
BillingCountry |
BillingCounty |
BillingState |
BillingTerms |
BillingZipCode |
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
City |
Comments |
CompanyID |
CompanyID_Name |
ContactRank |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
Country |
County |
CRRT |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
Department |
DirExclude |
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
Email |
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
FaxAreaCode |
FaxCountryCode |
FaxID |
FaxPhone |
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
ID |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
MailCode |
MailExclude |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PersonID |
Phone |
PhoneAreaCode |
PhoneCountryCode |
PhoneExtension |
PhoneID |
PrimaryFunction |
PrimaryFunctionID |
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Sequence |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
State |
StateHouse |
StateSenate |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
Supervisor |
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
Title |
USCongress |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.
WebSite |
ZipCode |

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
PersonCompanyFunctions |
PersonCompanyFunctionsObject |
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

PersonCompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonCompaniesClass Constructor

Initializes a new instance of the PersonCompaniesClass class.

public PersonCompaniesClass();

See Also

PersonCompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonCompaniesClass Properties

The properties of the PersonCompaniesClass class are listed below. For a complete list of PersonCompaniesClass class members, see the PersonCompaniesClass Members topic.

Public Instance Properties

AddressID |
AddressLine1 |
AddressLine2 |
AddressLine3 |
AddressLine4 |
Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
AssistantsAreaCode |
AssistantsCountryCode |
AssistantsName |
AssistantsPhone |
AssistantsPhoneExtension |
AssistantsPhoneID |
Atmosphere |
BillingAddressID |
BillingAddressLine1 |
BillingAddressLine2 |
BillingAddressLine3 |
BillingAddressLine4 |
BillingCity |
BillingCountry |
BillingCounty |
BillingState |
BillingTerms |
BillingZipCode |
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
City |
Comments |
CompanyID |
CompanyID_Name |
ContactRank |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
Country |
County |
CRRT |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
Department |
DirExclude |
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
Email |
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
FaxAreaCode |
FaxCountryCode |
FaxID |
FaxPhone |
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
ID |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
MailCode |
MailExclude |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PersonID |
Phone |
PhoneAreaCode |
PhoneCountryCode |
PhoneExtension |
PhoneID |
PrimaryFunction |
PrimaryFunctionID |
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Sequence |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
State |
StateHouse |
StateSenate |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
Supervisor |
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
Title |
USCongress |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.
WebSite |
ZipCode |

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

PersonCompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AddressID Property

Aptify 5.0 Software Development Kit (SDK)

PersonCompaniesClass.AddressID Property

public virtual Int32 AddressID {get; set;}

See Also

PersonCompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AddressLine1 Property

Aptify 5.0 Software Development Kit (SDK)

PersonCompaniesClass.AddressLine1 Property

public virtual String AddressLine1 {get; set;}

See Also

PersonCompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AddressLine2 Property

Aptify 5.0 Software Development Kit (SDK)

PersonCompaniesClass.AddressLine2 Property

public virtual String AddressLine2 {get; set;}

See Also

PersonCompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AddressLine3 Property

Aptify 5.0 Software Development Kit (SDK)

PersonCompaniesClass.AddressLine3 Property

public virtual String AddressLine3 {get; set;}

See Also

PersonCompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AddressLine4 Property

Aptify 5.0 Software Development Kit (SDK)

PersonCompaniesClass.AddressLine4 Property

public virtual String AddressLine4 {get; set;}

See Also

PersonCompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AssistantsAreaCode Property

Aptify 5.0 Software Development Kit (SDK)

PersonCompaniesClass.AssistantsAreaCode Property

public virtual String AssistantsAreaCode {get; set;}

See Also

PersonCompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AssistantsCountryCode Property

Aptify 5.0 Software Development Kit (SDK)

PersonCompaniesClass.AssistantsCountryCode Property

public virtual String AssistantsCountryCode {get; set;}

See Also

PersonCompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AssistantsName Property

Aptify 5.0 Software Development Kit (SDK)

PersonCompaniesClass.AssistantsName Property

public virtual String AssistantsName {get; set;}

See Also

PersonCompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AssistantsPhone Property

Aptify 5.0 Software Development Kit (SDK)

PersonCompaniesClass.AssistantsPhone Property

public virtual String AssistantsPhone {get; set;}

See Also

PersonCompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AssistantsPhoneExtension Property

Aptify 5.0 Software Development Kit (SDK)

PersonCompaniesClass.AssistantsPhoneExtension Property

public virtual String AssistantsPhoneExtension {get; set;}

See Also

PersonCompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AssistantsPhoneID Property

Aptify 5.0 Software Development Kit (SDK)

PersonCompaniesClass.AssistantsPhoneID Property

public virtual Int32 AssistantsPhoneID {get; set;}

See Also

PersonCompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Atmosphere Property

Aptify 5.0 Software Development Kit (SDK)

PersonCompaniesClass.Atmosphere Property

public virtual String Atmosphere {get; set;}

See Also

PersonCompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BillingAddressID Property

Aptify 5.0 Software Development Kit (SDK)

PersonCompaniesClass.BillingAddressID Property

public virtual Int32 BillingAddressID {get; set;}

See Also

PersonCompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BillingAddressLine1 Property

Aptify 5.0 Software Development Kit (SDK)

PersonCompaniesClass.BillingAddressLine1 Property

public virtual String BillingAddressLine1 {get; set;}

See Also

PersonCompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BillingAddressLine2 Property

Aptify 5.0 Software Development Kit (SDK)

PersonCompaniesClass.BillingAddressLine2 Property

public virtual String BillingAddressLine2 {get; set;}

See Also

PersonCompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BillingAddressLine3 Property

Aptify 5.0 Software Development Kit (SDK)

PersonCompaniesClass.BillingAddressLine3 Property

public virtual String BillingAddressLine3 {get; set;}

See Also

PersonCompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BillingAddressLine4 Property

Aptify 5.0 Software Development Kit (SDK)

PersonCompaniesClass.BillingAddressLine4 Property

public virtual String BillingAddressLine4 {get; set;}

See Also

PersonCompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BillingCity Property

Aptify 5.0 Software Development Kit (SDK)

PersonCompaniesClass.BillingCity Property

public virtual String BillingCity {get; set;}

See Also

PersonCompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BillingCountry Property

Aptify 5.0 Software Development Kit (SDK)

PersonCompaniesClass.BillingCountry Property

public virtual String BillingCountry {get;}

See Also

PersonCompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BillingCounty Property

Aptify 5.0 Software Development Kit (SDK)

PersonCompaniesClass.BillingCounty Property

public virtual String BillingCounty {get; set;}

See Also

PersonCompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BillingState Property

Aptify 5.0 Software Development Kit (SDK)

PersonCompaniesClass.BillingState Property

public virtual String BillingState {get; set;}

See Also

PersonCompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BillingTerms Property

Aptify 5.0 Software Development Kit (SDK)

PersonCompaniesClass.BillingTerms Property

public virtual String BillingTerms {get; set;}

See Also

PersonCompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BillingZipCode Property

Aptify 5.0 Software Development Kit (SDK)

PersonCompaniesClass.BillingZipCode Property

public virtual String BillingZipCode {get; set;}

See Also

PersonCompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


City Property

Aptify 5.0 Software Development Kit (SDK)

PersonCompaniesClass.City Property

public virtual String City {get; set;}

See Also

PersonCompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Comments Property

Aptify 5.0 Software Development Kit (SDK)

PersonCompaniesClass.Comments Property

public virtual String Comments {get; set;}

See Also

PersonCompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CompanyID Property

Aptify 5.0 Software Development Kit (SDK)

PersonCompaniesClass.CompanyID Property

public virtual Int32 CompanyID {get; set;}

See Also

PersonCompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CompanyID_Name Property

Aptify 5.0 Software Development Kit (SDK)

PersonCompaniesClass.CompanyID_Name Property

public virtual String CompanyID_Name {get;}

See Also

PersonCompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ContactRank Property

Aptify 5.0 Software Development Kit (SDK)

PersonCompaniesClass.ContactRank Property

public virtual String ContactRank {get; set;}

See Also

PersonCompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Country Property

Aptify 5.0 Software Development Kit (SDK)

PersonCompaniesClass.Country Property

public virtual String Country {get;}

See Also

PersonCompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


County Property

Aptify 5.0 Software Development Kit (SDK)

PersonCompaniesClass.County Property

public virtual String County {get; set;}

See Also

PersonCompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CRRT Property

Aptify 5.0 Software Development Kit (SDK)

PersonCompaniesClass.CRRT Property

public virtual String CRRT {get; set;}

See Also

PersonCompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Department Property

Aptify 5.0 Software Development Kit (SDK)

PersonCompaniesClass.Department Property

public virtual String Department {get; set;}

See Also

PersonCompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


DirExclude Property

Aptify 5.0 Software Development Kit (SDK)

PersonCompaniesClass.DirExclude Property

public virtual Boolean DirExclude {get; set;}

See Also

PersonCompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Email Property

Aptify 5.0 Software Development Kit (SDK)

PersonCompaniesClass.Email Property

public virtual String Email {get; set;}

See Also

PersonCompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


FaxAreaCode Property

Aptify 5.0 Software Development Kit (SDK)

PersonCompaniesClass.FaxAreaCode Property

public virtual String FaxAreaCode {get; set;}

See Also

PersonCompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


FaxCountryCode Property

Aptify 5.0 Software Development Kit (SDK)

PersonCompaniesClass.FaxCountryCode Property

public virtual String FaxCountryCode {get; set;}

See Also

PersonCompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


FaxID Property

Aptify 5.0 Software Development Kit (SDK)

PersonCompaniesClass.FaxID Property

public virtual Int32 FaxID {get; set;}

See Also

PersonCompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


FaxPhone Property

Aptify 5.0 Software Development Kit (SDK)

PersonCompaniesClass.FaxPhone Property

public virtual String FaxPhone {get; set;}

See Also

PersonCompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

PersonCompaniesClass.ID Property

public virtual Int32 ID {get;}

See Also

PersonCompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


MailCode Property

Aptify 5.0 Software Development Kit (SDK)

PersonCompaniesClass.MailCode Property

public virtual String MailCode {get; set;}

See Also

PersonCompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


MailExclude Property

Aptify 5.0 Software Development Kit (SDK)

PersonCompaniesClass.MailExclude Property

public virtual Boolean MailExclude {get; set;}

See Also

PersonCompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonID Property

Aptify 5.0 Software Development Kit (SDK)

PersonCompaniesClass.PersonID Property

public virtual Int32 PersonID {get;}

See Also

PersonCompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Phone Property

Aptify 5.0 Software Development Kit (SDK)

PersonCompaniesClass.Phone Property

public virtual String Phone {get; set;}

See Also

PersonCompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PhoneAreaCode Property

Aptify 5.0 Software Development Kit (SDK)

PersonCompaniesClass.PhoneAreaCode Property

public virtual String PhoneAreaCode {get; set;}

See Also

PersonCompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PhoneCountryCode Property

Aptify 5.0 Software Development Kit (SDK)

PersonCompaniesClass.PhoneCountryCode Property

public virtual String PhoneCountryCode {get; set;}

See Also

PersonCompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PhoneExtension Property

Aptify 5.0 Software Development Kit (SDK)

PersonCompaniesClass.PhoneExtension Property

public virtual String PhoneExtension {get; set;}

See Also

PersonCompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PhoneID Property

Aptify 5.0 Software Development Kit (SDK)

PersonCompaniesClass.PhoneID Property

public virtual Int32 PhoneID {get; set;}

See Also

PersonCompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PrimaryFunction Property

Aptify 5.0 Software Development Kit (SDK)

PersonCompaniesClass.PrimaryFunction Property

public virtual String PrimaryFunction {get;}

See Also

PersonCompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PrimaryFunctionID Property

Aptify 5.0 Software Development Kit (SDK)

PersonCompaniesClass.PrimaryFunctionID Property

public virtual Int32 PrimaryFunctionID {get; set;}

See Also

PersonCompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Sequence Property

Aptify 5.0 Software Development Kit (SDK)

PersonCompaniesClass.Sequence Property

public virtual Int32 Sequence {get;}

See Also

PersonCompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


State Property

Aptify 5.0 Software Development Kit (SDK)

PersonCompaniesClass.State Property

public virtual String State {get; set;}

See Also

PersonCompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


StateHouse Property

Aptify 5.0 Software Development Kit (SDK)

PersonCompaniesClass.StateHouse Property

public virtual String StateHouse {get; set;}

See Also

PersonCompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


StateSenate Property

Aptify 5.0 Software Development Kit (SDK)

PersonCompaniesClass.StateSenate Property

public virtual String StateSenate {get; set;}

See Also

PersonCompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Supervisor Property

Aptify 5.0 Software Development Kit (SDK)

PersonCompaniesClass.Supervisor Property

public virtual String Supervisor {get; set;}

See Also

PersonCompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Title Property

Aptify 5.0 Software Development Kit (SDK)

PersonCompaniesClass.Title Property

public virtual String Title {get; set;}

See Also

PersonCompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


USCongress Property

Aptify 5.0 Software Development Kit (SDK)

PersonCompaniesClass.USCongress Property

public virtual String USCongress {get; set;}

See Also

PersonCompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


WebSite Property

Aptify 5.0 Software Development Kit (SDK)

PersonCompaniesClass.WebSite Property

public virtual String WebSite {get; set;}

See Also

PersonCompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ZipCode Property

Aptify 5.0 Software Development Kit (SDK)

PersonCompaniesClass.ZipCode Property

public virtual String ZipCode {get; set;}

See Also

PersonCompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonCompaniesClass Methods

The methods of the PersonCompaniesClass class are listed below. For a complete list of PersonCompaniesClass class members, see the PersonCompaniesClass Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
PersonCompanyFunctions |
PersonCompanyFunctionsObject |
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

PersonCompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonCompaniesClass.PersonCompanyFunctions Method

public virtual PersonCompanyFunctionsClass PersonCompanyFunctions(
Int32 Index
);

See Also

PersonCompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonCompaniesClass.PersonCompanyFunctionsObject Method

public virtual AptifySubTypeBase PersonCompanyFunctionsObject();

See Also

PersonCompaniesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonCompanyFunctionsClass Class

For a list of all members of this type, see PersonCompanyFunctionsClass Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
PersonCompanyFunctionsClass
PersonCompaniesEntity

public class PersonCompanyFunctionsClass : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity.Generated

Assembly: Aptify.Framework.BusinessLogic.GenericEntity.Generated.Persons (in Aptify.Framework.BusinessLogic.GenericEntity.Generated.Persons.dll)

See Also

PersonCompanyFunctionsClass Members | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonCompanyFunctionsClass Members

PersonCompanyFunctionsClass overview

Public Instance Constructors

PersonCompanyFunctionsClass Constructor Initializes a new instance of the PersonCompanyFunctionsClass class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
Comments |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EndDate |
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
FunctionID |
FunctionID_Name |
ID |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PerCoSequence |
PersonCompanyID |
PersonID |
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Sequence |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
StartDate |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

PersonCompanyFunctionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonCompanyFunctionsClass Constructor

Initializes a new instance of the PersonCompanyFunctionsClass class.

public PersonCompanyFunctionsClass();

See Also

PersonCompanyFunctionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonCompanyFunctionsClass Properties

The properties of the PersonCompanyFunctionsClass class are listed below. For a complete list of PersonCompanyFunctionsClass class members, see the PersonCompanyFunctionsClass Members topic.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
Comments |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EndDate |
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
FunctionID |
FunctionID_Name |
ID |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PerCoSequence |
PersonCompanyID |
PersonID |
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Sequence |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
StartDate |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

PersonCompanyFunctionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Comments Property

Aptify 5.0 Software Development Kit (SDK)

PersonCompanyFunctionsClass.Comments Property

public virtual String Comments {get; set;}

See Also

PersonCompanyFunctionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


EndDate Property

Aptify 5.0 Software Development Kit (SDK)

PersonCompanyFunctionsClass.EndDate Property

public virtual DateTime EndDate {get; set;}

See Also

PersonCompanyFunctionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


FunctionID Property

Aptify 5.0 Software Development Kit (SDK)

PersonCompanyFunctionsClass.FunctionID Property

public virtual Int32 FunctionID {get; set;}

See Also

PersonCompanyFunctionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


FunctionID_Name Property

Aptify 5.0 Software Development Kit (SDK)

PersonCompanyFunctionsClass.FunctionID_Name Property

public virtual String FunctionID_Name {get;}

See Also

PersonCompanyFunctionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

PersonCompanyFunctionsClass.ID Property

public virtual Int32 ID {get;}

See Also

PersonCompanyFunctionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PerCoSequence Property

Aptify 5.0 Software Development Kit (SDK)

PersonCompanyFunctionsClass.PerCoSequence Property

public virtual Int32 PerCoSequence {get;}

See Also

PersonCompanyFunctionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonCompanyID Property

Aptify 5.0 Software Development Kit (SDK)

PersonCompanyFunctionsClass.PersonCompanyID Property

public virtual Int32 PersonCompanyID {get;}

See Also

PersonCompanyFunctionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonID Property

Aptify 5.0 Software Development Kit (SDK)

PersonCompanyFunctionsClass.PersonID Property

public virtual Int32 PersonID {get;}

See Also

PersonCompanyFunctionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Sequence Property

Aptify 5.0 Software Development Kit (SDK)

PersonCompanyFunctionsClass.Sequence Property

public virtual Int32 Sequence {get;}

See Also

PersonCompanyFunctionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


StartDate Property

Aptify 5.0 Software Development Kit (SDK)

PersonCompanyFunctionsClass.StartDate Property

public virtual DateTime StartDate {get; set;}

See Also

PersonCompanyFunctionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonEducationClass Class

For a list of all members of this type, see PersonEducationClass Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
PersonEducationClass

public class PersonEducationClass : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity.Generated

Assembly: Aptify.Framework.BusinessLogic.GenericEntity.Generated.Persons (in Aptify.Framework.BusinessLogic.GenericEntity.Generated.Persons.dll)

See Also

PersonEducationClass Members | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonEducationClass Members

PersonEducationClass overview

Public Instance Constructors

PersonEducationClass Constructor Initializes a new instance of the PersonEducationClass class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
Comments |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DegreeTitle |
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EducationFieldID |
EducationFieldID_Name |
EducationLevelID |
EducationLevelID_Name |
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EndDate |
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
ID |
InstitutionID |
InstitutionID_Name |
IsCompleted |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
MajorGPA |
OverallGPA |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PersonID |
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Sequence |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
StartDate |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

PersonEducationClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonEducationClass Constructor

Initializes a new instance of the PersonEducationClass class.

public PersonEducationClass();

See Also

PersonEducationClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonEducationClass Properties

The properties of the PersonEducationClass class are listed below. For a complete list of PersonEducationClass class members, see the PersonEducationClass Members topic.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
Comments |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DegreeTitle |
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EducationFieldID |
EducationFieldID_Name |
EducationLevelID |
EducationLevelID_Name |
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EndDate |
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
ID |
InstitutionID |
InstitutionID_Name |
IsCompleted |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
MajorGPA |
OverallGPA |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PersonID |
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Sequence |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
StartDate |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

PersonEducationClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Comments Property

Aptify 5.0 Software Development Kit (SDK)

PersonEducationClass.Comments Property

public virtual String Comments {get; set;}

See Also

PersonEducationClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


DegreeTitle Property

Aptify 5.0 Software Development Kit (SDK)

PersonEducationClass.DegreeTitle Property

public virtual String DegreeTitle {get; set;}

See Also

PersonEducationClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


EducationFieldID Property

Aptify 5.0 Software Development Kit (SDK)

PersonEducationClass.EducationFieldID Property

public virtual Int32 EducationFieldID {get; set;}

See Also

PersonEducationClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


EducationFieldID_Name Property

Aptify 5.0 Software Development Kit (SDK)

PersonEducationClass.EducationFieldID_Name Property

public virtual String EducationFieldID_Name {get;}

See Also

PersonEducationClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


EducationLevelID Property

Aptify 5.0 Software Development Kit (SDK)

PersonEducationClass.EducationLevelID Property

public virtual Int32 EducationLevelID {get; set;}

See Also

PersonEducationClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


EducationLevelID_Name Property

Aptify 5.0 Software Development Kit (SDK)

PersonEducationClass.EducationLevelID_Name Property

public virtual String EducationLevelID_Name {get;}

See Also

PersonEducationClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


EndDate Property

Aptify 5.0 Software Development Kit (SDK)

PersonEducationClass.EndDate Property

public virtual DateTime EndDate {get; set;}

See Also

PersonEducationClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

PersonEducationClass.ID Property

public virtual Int32 ID {get;}

See Also

PersonEducationClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


InstitutionID Property

Aptify 5.0 Software Development Kit (SDK)

PersonEducationClass.InstitutionID Property

public virtual Int32 InstitutionID {get; set;}

See Also

PersonEducationClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


InstitutionID_Name Property

Aptify 5.0 Software Development Kit (SDK)

PersonEducationClass.InstitutionID_Name Property

public virtual String InstitutionID_Name {get;}

See Also

PersonEducationClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


IsCompleted Property

Aptify 5.0 Software Development Kit (SDK)

PersonEducationClass.IsCompleted Property

public virtual Boolean IsCompleted {get; set;}

See Also

PersonEducationClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


MajorGPA Property

Aptify 5.0 Software Development Kit (SDK)

PersonEducationClass.MajorGPA Property

public virtual Decimal MajorGPA {get; set;}

See Also

PersonEducationClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OverallGPA Property

Aptify 5.0 Software Development Kit (SDK)

PersonEducationClass.OverallGPA Property

public virtual Decimal OverallGPA {get; set;}

See Also

PersonEducationClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonID Property

Aptify 5.0 Software Development Kit (SDK)

PersonEducationClass.PersonID Property

public virtual Int32 PersonID {get;}

See Also

PersonEducationClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Sequence Property

Aptify 5.0 Software Development Kit (SDK)

PersonEducationClass.Sequence Property

public virtual Int32 Sequence {get;}

See Also

PersonEducationClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


StartDate Property

Aptify 5.0 Software Development Kit (SDK)

PersonEducationClass.StartDate Property

public virtual DateTime StartDate {get; set;}

See Also

PersonEducationClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonFunctionsClass Class

For a list of all members of this type, see PersonFunctionsClass Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
PersonFunctionsClass

public class PersonFunctionsClass : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity.Generated

Assembly: Aptify.Framework.BusinessLogic.GenericEntity.Generated.Persons (in Aptify.Framework.BusinessLogic.GenericEntity.Generated.Persons.dll)

See Also

PersonFunctionsClass Members | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonFunctionsClass Members

PersonFunctionsClass overview

Public Instance Constructors

PersonFunctionsClass Constructor Initializes a new instance of the PersonFunctionsClass class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
Comments |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EndDate |
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
FunctionID |
FunctionID_Name |
ID |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PersonID |
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Sequence |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
StartDate |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

PersonFunctionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonFunctionsClass Constructor

Initializes a new instance of the PersonFunctionsClass class.

public PersonFunctionsClass();

See Also

PersonFunctionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonFunctionsClass Properties

The properties of the PersonFunctionsClass class are listed below. For a complete list of PersonFunctionsClass class members, see the PersonFunctionsClass Members topic.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
Comments |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EndDate |
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
FunctionID |
FunctionID_Name |
ID |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PersonID |
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Sequence |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
StartDate |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

PersonFunctionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Comments Property

Aptify 5.0 Software Development Kit (SDK)

PersonFunctionsClass.Comments Property

public virtual String Comments {get; set;}

See Also

PersonFunctionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


EndDate Property

Aptify 5.0 Software Development Kit (SDK)

PersonFunctionsClass.EndDate Property

public virtual DateTime EndDate {get; set;}

See Also

PersonFunctionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


FunctionID Property

Aptify 5.0 Software Development Kit (SDK)

PersonFunctionsClass.FunctionID Property

public virtual Int32 FunctionID {get; set;}

See Also

PersonFunctionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


FunctionID_Name Property

Aptify 5.0 Software Development Kit (SDK)

PersonFunctionsClass.FunctionID_Name Property

public virtual String FunctionID_Name {get;}

See Also

PersonFunctionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

PersonFunctionsClass.ID Property

public virtual Int32 ID {get;}

See Also

PersonFunctionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonID Property

Aptify 5.0 Software Development Kit (SDK)

PersonFunctionsClass.PersonID Property

public virtual Int32 PersonID {get;}

See Also

PersonFunctionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Sequence Property

Aptify 5.0 Software Development Kit (SDK)

PersonFunctionsClass.Sequence Property

public virtual Int32 Sequence {get;}

See Also

PersonFunctionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


StartDate Property

Aptify 5.0 Software Development Kit (SDK)

PersonFunctionsClass.StartDate Property

public virtual DateTime StartDate {get; set;}

See Also

PersonFunctionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonPhoneClass Class

For a list of all members of this type, see PersonPhoneClass Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
PersonPhoneClass

public class PersonPhoneClass : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity.Generated

Assembly: Aptify.Framework.BusinessLogic.GenericEntity.Generated.Persons (in Aptify.Framework.BusinessLogic.GenericEntity.Generated.Persons.dll)

See Also

PersonPhoneClass Members | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonPhoneClass Members

PersonPhoneClass overview

Public Instance Constructors

PersonPhoneClass Constructor Initializes a new instance of the PersonPhoneClass class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
AreaCode |
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CountryCode |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
ID |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
Name |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PersonID |
Phone |
PhoneExtension |
PhoneID |
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Sequence |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

PersonPhoneClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonPhoneClass Constructor

Initializes a new instance of the PersonPhoneClass class.

public PersonPhoneClass();

See Also

PersonPhoneClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonPhoneClass Properties

The properties of the PersonPhoneClass class are listed below. For a complete list of PersonPhoneClass class members, see the PersonPhoneClass Members topic.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
AreaCode |
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CountryCode |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
ID |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
Name |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PersonID |
Phone |
PhoneExtension |
PhoneID |
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Sequence |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

PersonPhoneClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AreaCode Property

Aptify 5.0 Software Development Kit (SDK)

PersonPhoneClass.AreaCode Property

public virtual String AreaCode {get; set;}

See Also

PersonPhoneClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CountryCode Property

Aptify 5.0 Software Development Kit (SDK)

PersonPhoneClass.CountryCode Property

public virtual String CountryCode {get; set;}

See Also

PersonPhoneClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

PersonPhoneClass.ID Property

public virtual Int32 ID {get;}

See Also

PersonPhoneClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Name Property

Aptify 5.0 Software Development Kit (SDK)

PersonPhoneClass.Name Property

public virtual String Name {get; set;}

See Also

PersonPhoneClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonID Property

Aptify 5.0 Software Development Kit (SDK)

PersonPhoneClass.PersonID Property

public virtual Int32 PersonID {get;}

See Also

PersonPhoneClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Phone Property

Aptify 5.0 Software Development Kit (SDK)

PersonPhoneClass.Phone Property

public virtual String Phone {get; set;}

See Also

PersonPhoneClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PhoneExtension Property

Aptify 5.0 Software Development Kit (SDK)

PersonPhoneClass.PhoneExtension Property

public virtual String PhoneExtension {get; set;}

See Also

PersonPhoneClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PhoneID Property

Aptify 5.0 Software Development Kit (SDK)

PersonPhoneClass.PhoneID Property

public virtual Int32 PhoneID {get; set;}

See Also

PersonPhoneClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Sequence Property

Aptify 5.0 Software Development Kit (SDK)

PersonPhoneClass.Sequence Property

public virtual Int32 Sequence {get;}

See Also

PersonPhoneClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonRelationshipsClass Class

For a list of all members of this type, see PersonRelationshipsClass Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
PersonRelationshipsClass

public class PersonRelationshipsClass : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity.Generated

Assembly: Aptify.Framework.BusinessLogic.GenericEntity.Generated.Persons (in Aptify.Framework.BusinessLogic.GenericEntity.Generated.Persons.dll)

See Also

PersonRelationshipsClass Members | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonRelationshipsClass Members

PersonRelationshipsClass overview

Public Instance Constructors

PersonRelationshipsClass Constructor Initializes a new instance of the PersonRelationshipsClass class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
Comments |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EndDate |
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
ID |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PersonID |
PersonRelationshipTypeID |
PersonRelationshipTypeID_Name |
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RelatedPersonID |
RelatedPersonID_Name |
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Sequence |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
StartDate |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

PersonRelationshipsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonRelationshipsClass Constructor

Initializes a new instance of the PersonRelationshipsClass class.

public PersonRelationshipsClass();

See Also

PersonRelationshipsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonRelationshipsClass Properties

The properties of the PersonRelationshipsClass class are listed below. For a complete list of PersonRelationshipsClass class members, see the PersonRelationshipsClass Members topic.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
Comments |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EndDate |
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
ID |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PersonID |
PersonRelationshipTypeID |
PersonRelationshipTypeID_Name |
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RelatedPersonID |
RelatedPersonID_Name |
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Sequence |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
StartDate |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

PersonRelationshipsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Comments Property

Aptify 5.0 Software Development Kit (SDK)

PersonRelationshipsClass.Comments Property

public virtual String Comments {get; set;}

See Also

PersonRelationshipsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


EndDate Property

Aptify 5.0 Software Development Kit (SDK)

PersonRelationshipsClass.EndDate Property

public virtual DateTime EndDate {get; set;}

See Also

PersonRelationshipsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

PersonRelationshipsClass.ID Property

public virtual Int32 ID {get;}

See Also

PersonRelationshipsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonID Property

Aptify 5.0 Software Development Kit (SDK)

PersonRelationshipsClass.PersonID Property

public virtual Int32 PersonID {get;}

See Also

PersonRelationshipsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonRelationshipTypeID Property

Aptify 5.0 Software Development Kit (SDK)

PersonRelationshipsClass.PersonRelationshipTypeID Property

public virtual Int32 PersonRelationshipTypeID {get; set;}

See Also

PersonRelationshipsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonRelationshipTypeID_Name Property

Aptify 5.0 Software Development Kit (SDK)

PersonRelationshipsClass.PersonRelationshipTypeID_Name Property

public virtual String PersonRelationshipTypeID_Name {get;}

See Also

PersonRelationshipsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


RelatedPersonID Property

Aptify 5.0 Software Development Kit (SDK)

PersonRelationshipsClass.RelatedPersonID Property

public virtual Int32 RelatedPersonID {get; set;}

See Also

PersonRelationshipsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


RelatedPersonID_Name Property

Aptify 5.0 Software Development Kit (SDK)

PersonRelationshipsClass.RelatedPersonID_Name Property

public virtual String RelatedPersonID_Name {get;}

See Also

PersonRelationshipsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Sequence Property

Aptify 5.0 Software Development Kit (SDK)

PersonRelationshipsClass.Sequence Property

public virtual Int32 Sequence {get;}

See Also

PersonRelationshipsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


StartDate Property

Aptify 5.0 Software Development Kit (SDK)

PersonRelationshipsClass.StartDate Property

public virtual DateTime StartDate {get; set;}

See Also

PersonRelationshipsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonSavedPaymentMethodsClass Class

For a list of all members of this type, see PersonSavedPaymentMethodsClass Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
PersonSavedPaymentMethodsClass
PersonSPMEntity

public class PersonSavedPaymentMethodsClass : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity.Generated

Assembly: Aptify.Framework.BusinessLogic.GenericEntity.Generated.Persons (in Aptify.Framework.BusinessLogic.GenericEntity.Generated.Persons.dll)

See Also

PersonSavedPaymentMethodsClass Members | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonSavedPaymentMethodsClass Members

PersonSavedPaymentMethodsClass overview

Public Instance Constructors

PersonSavedPaymentMethodsClass Constructor Initializes a new instance of the PersonSavedPaymentMethodsClass class.

Public Instance Properties

ABA |
AccountNumber |
Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
Bank |
BranchName |
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
CCAccountNumber |
CCExpireDate |
CCPartial |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CreditOrderID |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
Description |
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
DueDate |
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EndDate |
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
ID |
IsActive |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
Name |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PaymentInformationID |
PaymentType |
PaymentTypeID |
PersonID |
PONumber |
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Sequence |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
StartDate |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
Terms |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

PersonSavedPaymentMethodsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonSavedPaymentMethodsClass Constructor

Initializes a new instance of the PersonSavedPaymentMethodsClass class.

public PersonSavedPaymentMethodsClass();

See Also

PersonSavedPaymentMethodsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonSavedPaymentMethodsClass Properties

The properties of the PersonSavedPaymentMethodsClass class are listed below. For a complete list of PersonSavedPaymentMethodsClass class members, see the PersonSavedPaymentMethodsClass Members topic.

Public Instance Properties

ABA |
AccountNumber |
Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
Bank |
BranchName |
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
CCAccountNumber |
CCExpireDate |
CCPartial |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CreditOrderID |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
Description |
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
DueDate |
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EndDate |
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
ID |
IsActive |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
Name |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PaymentInformationID |
PaymentType |
PaymentTypeID |
PersonID |
PONumber |
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Sequence |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
StartDate |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
Terms |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

PersonSavedPaymentMethodsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ABA Property

Aptify 5.0 Software Development Kit (SDK)

PersonSavedPaymentMethodsClass.ABA Property

public virtual String ABA {get; set;}

See Also

PersonSavedPaymentMethodsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AccountNumber Property

Aptify 5.0 Software Development Kit (SDK)

PersonSavedPaymentMethodsClass.AccountNumber Property

public virtual String AccountNumber {get; set;}

See Also

PersonSavedPaymentMethodsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Bank Property

Aptify 5.0 Software Development Kit (SDK)

PersonSavedPaymentMethodsClass.Bank Property

public virtual String Bank {get; set;}

See Also

PersonSavedPaymentMethodsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BranchName Property

Aptify 5.0 Software Development Kit (SDK)

PersonSavedPaymentMethodsClass.BranchName Property

public virtual String BranchName {get; set;}

See Also

PersonSavedPaymentMethodsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CCAccountNumber Property

Aptify 5.0 Software Development Kit (SDK)

PersonSavedPaymentMethodsClass.CCAccountNumber Property

public virtual String CCAccountNumber {get; set;}

See Also

PersonSavedPaymentMethodsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CCExpireDate Property

Aptify 5.0 Software Development Kit (SDK)

PersonSavedPaymentMethodsClass.CCExpireDate Property

public virtual DateTime CCExpireDate {get; set;}

See Also

PersonSavedPaymentMethodsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CCPartial Property

Aptify 5.0 Software Development Kit (SDK)

PersonSavedPaymentMethodsClass.CCPartial Property

public virtual String CCPartial {get; set;}

See Also

PersonSavedPaymentMethodsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CreditOrderID Property

Aptify 5.0 Software Development Kit (SDK)

PersonSavedPaymentMethodsClass.CreditOrderID Property

public virtual Int32 CreditOrderID {get; set;}

See Also

PersonSavedPaymentMethodsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Description Property

Aptify 5.0 Software Development Kit (SDK)

PersonSavedPaymentMethodsClass.Description Property

public virtual String Description {get; set;}

See Also

PersonSavedPaymentMethodsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


DueDate Property

Aptify 5.0 Software Development Kit (SDK)

PersonSavedPaymentMethodsClass.DueDate Property

public virtual DateTime DueDate {get; set;}

See Also

PersonSavedPaymentMethodsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


EndDate Property

Aptify 5.0 Software Development Kit (SDK)

PersonSavedPaymentMethodsClass.EndDate Property

public virtual DateTime EndDate {get; set;}

See Also

PersonSavedPaymentMethodsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

PersonSavedPaymentMethodsClass.ID Property

public virtual Int32 ID {get;}

See Also

PersonSavedPaymentMethodsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


IsActive Property

Aptify 5.0 Software Development Kit (SDK)

PersonSavedPaymentMethodsClass.IsActive Property

public virtual Boolean IsActive {get; set;}

See Also

PersonSavedPaymentMethodsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Name Property

Aptify 5.0 Software Development Kit (SDK)

PersonSavedPaymentMethodsClass.Name Property

public virtual String Name {get; set;}

See Also

PersonSavedPaymentMethodsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PaymentInformationID Property

Aptify 5.0 Software Development Kit (SDK)

PersonSavedPaymentMethodsClass.PaymentInformationID Property

public virtual Int32 PaymentInformationID {get; set;}

See Also

PersonSavedPaymentMethodsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PaymentType Property

Aptify 5.0 Software Development Kit (SDK)

PersonSavedPaymentMethodsClass.PaymentType Property

public virtual String PaymentType {get;}

See Also

PersonSavedPaymentMethodsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PaymentTypeID Property

Aptify 5.0 Software Development Kit (SDK)

PersonSavedPaymentMethodsClass.PaymentTypeID Property

public virtual Int32 PaymentTypeID {get; set;}

See Also

PersonSavedPaymentMethodsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonID Property

Aptify 5.0 Software Development Kit (SDK)

PersonSavedPaymentMethodsClass.PersonID Property

public virtual Int32 PersonID {get;}

See Also

PersonSavedPaymentMethodsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PONumber Property

Aptify 5.0 Software Development Kit (SDK)

PersonSavedPaymentMethodsClass.PONumber Property

public virtual String PONumber {get; set;}

See Also

PersonSavedPaymentMethodsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Sequence Property

Aptify 5.0 Software Development Kit (SDK)

PersonSavedPaymentMethodsClass.Sequence Property

public virtual Int32 Sequence {get;}

See Also

PersonSavedPaymentMethodsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


StartDate Property

Aptify 5.0 Software Development Kit (SDK)

PersonSavedPaymentMethodsClass.StartDate Property

public virtual DateTime StartDate {get; set;}

See Also

PersonSavedPaymentMethodsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Terms Property

Aptify 5.0 Software Development Kit (SDK)

PersonSavedPaymentMethodsClass.Terms Property

public virtual String Terms {get; set;}

See Also

PersonSavedPaymentMethodsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonsClass Class

For a list of all members of this type, see PersonsClass Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
PersonsClass
PersonsEntity

public class PersonsClass : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity.Generated

Assembly: Aptify.Framework.BusinessLogic.GenericEntity.Generated.Persons (in Aptify.Framework.BusinessLogic.GenericEntity.Generated.Persons.dll)

See Also

PersonsClass Members | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonsClass Members

PersonsClass overview

Public Instance Constructors

PersonsClass Constructor Initializes a new instance of the PersonsClass class.

Public Instance Properties

AddressID |
AddressIDObject |
AddressLine1 |
AddressLine2 |
AddressLine3 |
AddressLine4 |
Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
APVendorID |
AssistantsAreaCode |
AssistantsCountryCode |
AssistantsExtension |
AssistantsName |
AssistantsPhone |
AssistantsPhoneID |
Atmosphere |
BillingAddressID |
BillingAddressLine1 |
BillingAddressLine2 |
BillingAddressLine3 |
BillingAddressLine4 |
BillingCity |
BillingCountry |
BillingCounty |
BillingState |
BillingTerms |
BillingZipCode |
Birthday |
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
CellAreaCode |
CellCountryCode |
CellPhone |
CellPhoneID |
City |
CoMemberType |
Comments |
Company |
CompanyDuesPaidThru |
CompanyID |
CompanyJoinDate |
CompanyLastDuesAmount |
CompanyLastDuesAmountCurrencyTypeID |
CompanyLastDuesPaymentDate |
CompanyMemberType |
CompanyMemberTypeID |
CompanyName |
CompanyTerminationDate |
ContactManagerID |
ContactRank |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
Country |
CountryCodeID |
County |
CountyDistrict |
CreditLimit |
CreditLimitCurrencyTypeID |
CreditStatusID |
CRRT |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DateCreated |
DateUpdated |
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
Department |
Directions |
DirExclude |
DirRank |
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
DuesPaidThru |
Email |
Email1 |
Email2 |
Email3 |
EmailExclude |
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
FaxAreaCode |
FaxCountryCode |
FaxExclude |
FaxID |
FaxPhone |
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
FirstLast |
FirstName |
FunctionalTitle |
Gender |
GLOrderLevelID |
GLPaymentLevelID |
HomeAddressID |
HomeAddressLine1 |
HomeAddressLine2 |
HomeAddressLine3 |
HomeAddressLine4 |
HomeAreaCode |
HomeCity |
HomeCountry |
HomeCountryCode |
HomeCounty |
HomePhone |
HomePhoneID |
HomeState |
HomeZipCode |
ID |
ImportantDate1 |
ImportantDate2 |
ImportantDate3 |
ImportantDescription1 |
ImportantDescription2 |
ImportantDescription3 |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
JoinDate |
Kids |
LastDuesAmount |
LastDuesAmountCurrencyTypeID |
LastDuesPaymentDate |
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastName |
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
MailCode |
MailExclude |
MainAccountManager |
MainAccountManagerName |
MemberType |
MemberTypeID |
MiddleName |
NameWCompany |
NextContactDate |
Nickname |
OldCompanyID |
OldID |
OrganizationID |
PagerAreaCode |
PagerCountryCode |
PagerPhone |
PagerPhoneID |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
Phone |
PhoneAreaCode |
PhoneCountryCode |
PhoneExtension |
PhoneID |
PhoneIDObject |
POBox |
POBoxAddressID |
POBoxCity |
POBoxCountry |
POBoxCounty |
POBoxLine2 |
POBoxLine3 |
POBoxLine4 |
POBoxState |
POBoxZipCode |
PrefCommMethodID |
PreferredAddress |
PreferredBillingAddress |
PreferredCurrencyTypeID |
PreferredShippingAddress |
Prefix |
PrimaryFunction |
PrimaryFunctionID |
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
Ranking |
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
ReferralType |
ReferredBy |
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SocialSecurity |
SpouseName |
State |
StateHouse |
StateSenate |
Status |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
Suffix |
Supervisor |
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
TerminationDate |
Title |
USCongress |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.
VerifyStatus |
WebSite |
WhoCreated |
WhoUpdated |
ZipCode |
ZipCode5Numeric |

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
PersonAccountManagers |
PersonAccountManagersObject |
PersonAddress |
PersonAddressObject |
PersonCompanies |
PersonCompaniesObject |
PersonEducation |
PersonEducationObject |
PersonFunctions |
PersonFunctionsObject |
PersonPhone |
PersonPhoneObject |
PersonRelationships |
PersonRelationshipsObject |
PersonSavedPaymentMethods |
PersonSavedPaymentMethodsObject |
PersonTaxExemptCodes |
PersonTaxExemptCodesObject |
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonsClass Constructor

Initializes a new instance of the PersonsClass class.

public PersonsClass();

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonsClass Properties

The properties of the PersonsClass class are listed below. For a complete list of PersonsClass class members, see the PersonsClass Members topic.

Public Instance Properties

AddressID |
AddressIDObject |
AddressLine1 |
AddressLine2 |
AddressLine3 |
AddressLine4 |
Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
APVendorID |
AssistantsAreaCode |
AssistantsCountryCode |
AssistantsExtension |
AssistantsName |
AssistantsPhone |
AssistantsPhoneID |
Atmosphere |
BillingAddressID |
BillingAddressLine1 |
BillingAddressLine2 |
BillingAddressLine3 |
BillingAddressLine4 |
BillingCity |
BillingCountry |
BillingCounty |
BillingState |
BillingTerms |
BillingZipCode |
Birthday |
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
CellAreaCode |
CellCountryCode |
CellPhone |
CellPhoneID |
City |
CoMemberType |
Comments |
Company |
CompanyDuesPaidThru |
CompanyID |
CompanyJoinDate |
CompanyLastDuesAmount |
CompanyLastDuesAmountCurrencyTypeID |
CompanyLastDuesPaymentDate |
CompanyMemberType |
CompanyMemberTypeID |
CompanyName |
CompanyTerminationDate |
ContactManagerID |
ContactRank |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
Country |
CountryCodeID |
County |
CountyDistrict |
CreditLimit |
CreditLimitCurrencyTypeID |
CreditStatusID |
CRRT |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DateCreated |
DateUpdated |
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
Department |
Directions |
DirExclude |
DirRank |
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
DuesPaidThru |
Email |
Email1 |
Email2 |
Email3 |
EmailExclude |
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
FaxAreaCode |
FaxCountryCode |
FaxExclude |
FaxID |
FaxPhone |
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
FirstLast |
FirstName |
FunctionalTitle |
Gender |
GLOrderLevelID |
GLPaymentLevelID |
HomeAddressID |
HomeAddressLine1 |
HomeAddressLine2 |
HomeAddressLine3 |
HomeAddressLine4 |
HomeAreaCode |
HomeCity |
HomeCountry |
HomeCountryCode |
HomeCounty |
HomePhone |
HomePhoneID |
HomeState |
HomeZipCode |
ID |
ImportantDate1 |
ImportantDate2 |
ImportantDate3 |
ImportantDescription1 |
ImportantDescription2 |
ImportantDescription3 |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
JoinDate |
Kids |
LastDuesAmount |
LastDuesAmountCurrencyTypeID |
LastDuesPaymentDate |
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastName |
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
MailCode |
MailExclude |
MainAccountManager |
MainAccountManagerName |
MemberType |
MemberTypeID |
MiddleName |
NameWCompany |
NextContactDate |
Nickname |
OldCompanyID |
OldID |
OrganizationID |
PagerAreaCode |
PagerCountryCode |
PagerPhone |
PagerPhoneID |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
Phone |
PhoneAreaCode |
PhoneCountryCode |
PhoneExtension |
PhoneID |
PhoneIDObject |
POBox |
POBoxAddressID |
POBoxCity |
POBoxCountry |
POBoxCounty |
POBoxLine2 |
POBoxLine3 |
POBoxLine4 |
POBoxState |
POBoxZipCode |
PrefCommMethodID |
PreferredAddress |
PreferredBillingAddress |
PreferredCurrencyTypeID |
PreferredShippingAddress |
Prefix |
PrimaryFunction |
PrimaryFunctionID |
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
Ranking |
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
ReferralType |
ReferredBy |
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SocialSecurity |
SpouseName |
State |
StateHouse |
StateSenate |
Status |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
Suffix |
Supervisor |
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
TerminationDate |
Title |
USCongress |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.
VerifyStatus |
WebSite |
WhoCreated |
WhoUpdated |
ZipCode |
ZipCode5Numeric |

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AddressID Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.AddressID Property

public virtual Int32 AddressID {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AddressIDObject Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.AddressIDObject Property

public virtual AptifyGenericEntityBase AddressIDObject {get;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AddressLine1 Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.AddressLine1 Property

public virtual String AddressLine1 {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AddressLine2 Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.AddressLine2 Property

public virtual String AddressLine2 {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AddressLine3 Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.AddressLine3 Property

public virtual String AddressLine3 {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AddressLine4 Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.AddressLine4 Property

public virtual String AddressLine4 {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


APVendorID Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.APVendorID Property

public virtual String APVendorID {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AssistantsAreaCode Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.AssistantsAreaCode Property

public virtual String AssistantsAreaCode {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AssistantsCountryCode Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.AssistantsCountryCode Property

public virtual String AssistantsCountryCode {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AssistantsExtension Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.AssistantsExtension Property

public virtual String AssistantsExtension {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AssistantsName Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.AssistantsName Property

public virtual String AssistantsName {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AssistantsPhone Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.AssistantsPhone Property

public virtual String AssistantsPhone {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AssistantsPhoneID Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.AssistantsPhoneID Property

public virtual Int32 AssistantsPhoneID {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Atmosphere Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.Atmosphere Property

public virtual String Atmosphere {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BillingAddressID Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.BillingAddressID Property

public virtual Int32 BillingAddressID {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BillingAddressLine1 Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.BillingAddressLine1 Property

public virtual String BillingAddressLine1 {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BillingAddressLine2 Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.BillingAddressLine2 Property

public virtual String BillingAddressLine2 {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BillingAddressLine3 Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.BillingAddressLine3 Property

public virtual String BillingAddressLine3 {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BillingAddressLine4 Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.BillingAddressLine4 Property

public virtual String BillingAddressLine4 {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BillingCity Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.BillingCity Property

public virtual String BillingCity {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BillingCountry Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.BillingCountry Property

public virtual String BillingCountry {get;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BillingCounty Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.BillingCounty Property

public virtual String BillingCounty {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BillingState Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.BillingState Property

public virtual String BillingState {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BillingTerms Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.BillingTerms Property

public virtual String BillingTerms {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BillingZipCode Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.BillingZipCode Property

public virtual String BillingZipCode {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Birthday Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.Birthday Property

public virtual DateTime Birthday {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CellAreaCode Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.CellAreaCode Property

public virtual String CellAreaCode {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CellCountryCode Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.CellCountryCode Property

public virtual String CellCountryCode {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CellPhone Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.CellPhone Property

public virtual String CellPhone {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CellPhoneID Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.CellPhoneID Property

public virtual Int32 CellPhoneID {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


City Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.City Property

public virtual String City {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CoMemberType Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.CoMemberType Property

public virtual String CoMemberType {get;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Comments Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.Comments Property

public virtual String Comments {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Company Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.Company Property

public virtual String Company {get;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CompanyDuesPaidThru Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.CompanyDuesPaidThru Property

public virtual DateTime CompanyDuesPaidThru {get;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CompanyID Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.CompanyID Property

public virtual Int32 CompanyID {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CompanyJoinDate Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.CompanyJoinDate Property

public virtual DateTime CompanyJoinDate {get;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CompanyLastDuesAmount Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.CompanyLastDuesAmount Property

public virtual Decimal CompanyLastDuesAmount {get;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CompanyLastDuesAmountCurrencyTypeID Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.CompanyLastDuesAmountCurrencyTypeID Property

public virtual Int32 CompanyLastDuesAmountCurrencyTypeID {get;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CompanyLastDuesPaymentDate Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.CompanyLastDuesPaymentDate Property

public virtual DateTime CompanyLastDuesPaymentDate {get;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CompanyMemberType Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.CompanyMemberType Property

public virtual String CompanyMemberType {get;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CompanyMemberTypeID Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.CompanyMemberTypeID Property

public virtual Int32 CompanyMemberTypeID {get;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CompanyName Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.CompanyName Property

public virtual String CompanyName {get;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CompanyTerminationDate Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.CompanyTerminationDate Property

public virtual DateTime CompanyTerminationDate {get;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ContactManagerID Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.ContactManagerID Property

public virtual String ContactManagerID {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ContactRank Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.ContactRank Property

public virtual String ContactRank {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Country Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.Country Property

public virtual String Country {get;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CountryCodeID Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.CountryCodeID Property

public virtual Int32 CountryCodeID {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


County Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.County Property

public virtual String County {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CountyDistrict Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.CountyDistrict Property

public virtual String CountyDistrict {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CreditLimit Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.CreditLimit Property

public virtual Decimal CreditLimit {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CreditLimitCurrencyTypeID Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.CreditLimitCurrencyTypeID Property

public virtual Int32 CreditLimitCurrencyTypeID {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CreditStatusID Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.CreditStatusID Property

public virtual Int32 CreditStatusID {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CRRT Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.CRRT Property

public virtual String CRRT {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


DateCreated Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.DateCreated Property

public virtual DateTime DateCreated {get;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


DateUpdated Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.DateUpdated Property

public virtual DateTime DateUpdated {get;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Department Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.Department Property

public virtual String Department {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Directions Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.Directions Property

public virtual String Directions {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


DirExclude Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.DirExclude Property

public virtual Boolean DirExclude {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


DirRank Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.DirRank Property

public virtual Int32 DirRank {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


DuesPaidThru Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.DuesPaidThru Property

public virtual DateTime DuesPaidThru {get;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Email Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.Email Property

public virtual String Email {get;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Email1 Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.Email1 Property

public virtual String Email1 {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Email2 Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.Email2 Property

public virtual String Email2 {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Email3 Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.Email3 Property

public virtual String Email3 {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


EmailExclude Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.EmailExclude Property

public virtual Boolean EmailExclude {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


FaxAreaCode Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.FaxAreaCode Property

public virtual String FaxAreaCode {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


FaxCountryCode Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.FaxCountryCode Property

public virtual String FaxCountryCode {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


FaxExclude Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.FaxExclude Property

public virtual Boolean FaxExclude {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


FaxID Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.FaxID Property

public virtual Int32 FaxID {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


FaxPhone Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.FaxPhone Property

public virtual String FaxPhone {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


FirstLast Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.FirstLast Property

public virtual String FirstLast {get;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


FirstName Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.FirstName Property

public virtual String FirstName {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


FunctionalTitle Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.FunctionalTitle Property

public virtual String FunctionalTitle {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Gender Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.Gender Property

public virtual Int32 Gender {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


GLOrderLevelID Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.GLOrderLevelID Property

public virtual Int32 GLOrderLevelID {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


GLPaymentLevelID Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.GLPaymentLevelID Property

public virtual Int32 GLPaymentLevelID {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


HomeAddressID Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.HomeAddressID Property

public virtual Int32 HomeAddressID {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


HomeAddressLine1 Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.HomeAddressLine1 Property

public virtual String HomeAddressLine1 {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


HomeAddressLine2 Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.HomeAddressLine2 Property

public virtual String HomeAddressLine2 {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


HomeAddressLine3 Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.HomeAddressLine3 Property

public virtual String HomeAddressLine3 {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


HomeAddressLine4 Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.HomeAddressLine4 Property

public virtual String HomeAddressLine4 {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


HomeAreaCode Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.HomeAreaCode Property

public virtual String HomeAreaCode {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


HomeCity Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.HomeCity Property

public virtual String HomeCity {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


HomeCountry Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.HomeCountry Property

public virtual String HomeCountry {get;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


HomeCountryCode Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.HomeCountryCode Property

public virtual String HomeCountryCode {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


HomeCounty Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.HomeCounty Property

public virtual String HomeCounty {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


HomePhone Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.HomePhone Property

public virtual String HomePhone {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


HomePhoneID Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.HomePhoneID Property

public virtual Int32 HomePhoneID {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


HomeState Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.HomeState Property

public virtual String HomeState {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


HomeZipCode Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.HomeZipCode Property

public virtual String HomeZipCode {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.ID Property

public virtual Int32 ID {get;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ImportantDate1 Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.ImportantDate1 Property

public virtual DateTime ImportantDate1 {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ImportantDate2 Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.ImportantDate2 Property

public virtual DateTime ImportantDate2 {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ImportantDate3 Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.ImportantDate3 Property

public virtual DateTime ImportantDate3 {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ImportantDescription1 Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.ImportantDescription1 Property

public virtual String ImportantDescription1 {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ImportantDescription2 Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.ImportantDescription2 Property

public virtual String ImportantDescription2 {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ImportantDescription3 Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.ImportantDescription3 Property

public virtual String ImportantDescription3 {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


JoinDate Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.JoinDate Property

public virtual DateTime JoinDate {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Kids Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.Kids Property

public virtual String Kids {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


LastDuesAmount Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.LastDuesAmount Property

public virtual Decimal LastDuesAmount {get;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


LastDuesAmountCurrencyTypeID Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.LastDuesAmountCurrencyTypeID Property

public virtual Int32 LastDuesAmountCurrencyTypeID {get;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


LastDuesPaymentDate Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.LastDuesPaymentDate Property

public virtual DateTime LastDuesPaymentDate {get;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


LastName Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.LastName Property

public virtual String LastName {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


MailCode Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.MailCode Property

public virtual String MailCode {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


MailExclude Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.MailExclude Property

public virtual Boolean MailExclude {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


MainAccountManager Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.MainAccountManager Property

public virtual Int32 MainAccountManager {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


MainAccountManagerName Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.MainAccountManagerName Property

public virtual String MainAccountManagerName {get;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


MemberType Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.MemberType Property

public virtual String MemberType {get;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


MemberTypeID Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.MemberTypeID Property

public virtual Int32 MemberTypeID {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


MiddleName Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.MiddleName Property

public virtual String MiddleName {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


NameWCompany Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.NameWCompany Property

public virtual String NameWCompany {get;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


NextContactDate Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.NextContactDate Property

public virtual DateTime NextContactDate {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Nickname Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.Nickname Property

public virtual String Nickname {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OldCompanyID Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.OldCompanyID Property

public virtual String OldCompanyID {get;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OldID Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.OldID Property

public virtual String OldID {get;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrganizationID Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.OrganizationID Property

public virtual Int32 OrganizationID {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PagerAreaCode Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.PagerAreaCode Property

public virtual String PagerAreaCode {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PagerCountryCode Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.PagerCountryCode Property

public virtual String PagerCountryCode {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PagerPhone Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.PagerPhone Property

public virtual String PagerPhone {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PagerPhoneID Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.PagerPhoneID Property

public virtual Int32 PagerPhoneID {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Phone Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.Phone Property

public virtual String Phone {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PhoneAreaCode Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.PhoneAreaCode Property

public virtual String PhoneAreaCode {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PhoneCountryCode Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.PhoneCountryCode Property

public virtual String PhoneCountryCode {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PhoneExtension Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.PhoneExtension Property

public virtual String PhoneExtension {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PhoneID Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.PhoneID Property

public virtual Int32 PhoneID {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PhoneIDObject Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.PhoneIDObject Property

public virtual AptifyGenericEntityBase PhoneIDObject {get;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


POBox Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.POBox Property

public virtual String POBox {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


POBoxAddressID Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.POBoxAddressID Property

public virtual Int32 POBoxAddressID {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


POBoxCity Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.POBoxCity Property

public virtual String POBoxCity {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


POBoxCountry Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.POBoxCountry Property

public virtual String POBoxCountry {get;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


POBoxCounty Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.POBoxCounty Property

public virtual String POBoxCounty {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


POBoxLine2 Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.POBoxLine2 Property

public virtual String POBoxLine2 {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


POBoxLine3 Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.POBoxLine3 Property

public virtual String POBoxLine3 {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


POBoxLine4 Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.POBoxLine4 Property

public virtual String POBoxLine4 {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


POBoxState Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.POBoxState Property

public virtual String POBoxState {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


POBoxZipCode Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.POBoxZipCode Property

public virtual String POBoxZipCode {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PrefCommMethodID Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.PrefCommMethodID Property

public virtual Int32 PrefCommMethodID {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PreferredAddress Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.PreferredAddress Property

public virtual String PreferredAddress {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PreferredBillingAddress Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.PreferredBillingAddress Property

public virtual String PreferredBillingAddress {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PreferredCurrencyTypeID Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.PreferredCurrencyTypeID Property

public virtual Int32 PreferredCurrencyTypeID {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PreferredShippingAddress Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.PreferredShippingAddress Property

public virtual String PreferredShippingAddress {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Prefix Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.Prefix Property

public virtual String Prefix {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PrimaryFunction Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.PrimaryFunction Property

public virtual String PrimaryFunction {get;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PrimaryFunctionID Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.PrimaryFunctionID Property

public virtual Int32 PrimaryFunctionID {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Ranking Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.Ranking Property

public virtual Int32 Ranking {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ReferralType Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.ReferralType Property

public virtual String ReferralType {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ReferredBy Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.ReferredBy Property

public virtual Int32 ReferredBy {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


SocialSecurity Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.SocialSecurity Property

public virtual String SocialSecurity {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


SpouseName Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.SpouseName Property

public virtual String SpouseName {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


State Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.State Property

public virtual String State {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


StateHouse Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.StateHouse Property

public virtual String StateHouse {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


StateSenate Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.StateSenate Property

public virtual String StateSenate {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Status Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.Status Property

public virtual Int32 Status {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Suffix Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.Suffix Property

public virtual String Suffix {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Supervisor Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.Supervisor Property

public virtual String Supervisor {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


TerminationDate Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.TerminationDate Property

public virtual DateTime TerminationDate {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Title Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.Title Property

public virtual String Title {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


USCongress Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.USCongress Property

public virtual String USCongress {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


VerifyStatus Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.VerifyStatus Property

public virtual String VerifyStatus {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


WebSite Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.WebSite Property

public virtual String WebSite {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


WhoCreated Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.WhoCreated Property

public virtual String WhoCreated {get;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


WhoUpdated Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.WhoUpdated Property

public virtual String WhoUpdated {get;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ZipCode Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.ZipCode Property

public virtual String ZipCode {get; set;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ZipCode5Numeric Property

Aptify 5.0 Software Development Kit (SDK)

PersonsClass.ZipCode5Numeric Property

public virtual Int32 ZipCode5Numeric {get;}

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonsClass Methods

The methods of the PersonsClass class are listed below. For a complete list of PersonsClass class members, see the PersonsClass Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
PersonAccountManagers |
PersonAccountManagersObject |
PersonAddress |
PersonAddressObject |
PersonCompanies |
PersonCompaniesObject |
PersonEducation |
PersonEducationObject |
PersonFunctions |
PersonFunctionsObject |
PersonPhone |
PersonPhoneObject |
PersonRelationships |
PersonRelationshipsObject |
PersonSavedPaymentMethods |
PersonSavedPaymentMethodsObject |
PersonTaxExemptCodes |
PersonTaxExemptCodesObject |
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonsClass.PersonAccountManagers Method

public virtual PersonAccountManagersClass PersonAccountManagers(
Int32 Index
);

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonsClass.PersonAccountManagersObject Method

public virtual AptifySubTypeBase PersonAccountManagersObject();

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonsClass.PersonAddress Method

public virtual PersonAddressClass PersonAddress(
Int32 Index
);

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonsClass.PersonAddressObject Method

public virtual AptifySubTypeBase PersonAddressObject();

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonsClass.PersonCompanies Method

public virtual PersonCompaniesClass PersonCompanies(
Int32 Index
);

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonsClass.PersonCompaniesObject Method

public virtual AptifySubTypeBase PersonCompaniesObject();

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonsClass.PersonEducation Method

public virtual PersonEducationClass PersonEducation(
Int32 Index
);

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonsClass.PersonEducationObject Method

public virtual AptifySubTypeBase PersonEducationObject();

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonsClass.PersonFunctions Method

public virtual PersonFunctionsClass PersonFunctions(
Int32 Index
);

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonsClass.PersonFunctionsObject Method

public virtual AptifySubTypeBase PersonFunctionsObject();

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonsClass.PersonPhone Method

public virtual PersonPhoneClass PersonPhone(
Int32 Index
);

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonsClass.PersonPhoneObject Method

public virtual AptifySubTypeBase PersonPhoneObject();

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonsClass.PersonRelationships Method

public virtual PersonRelationshipsClass PersonRelationships(
Int32 Index
);

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonsClass.PersonRelationshipsObject Method

public virtual AptifySubTypeBase PersonRelationshipsObject();

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonsClass.PersonSavedPaymentMethods Method

public virtual PersonSavedPaymentMethodsClass PersonSavedPaymentMethods(
Int32 Index
);

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonsClass.PersonSavedPaymentMethodsObject Method

public virtual AptifySubTypeBase PersonSavedPaymentMethodsObject();

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonsClass.PersonTaxExemptCodes Method

public virtual PersonTaxExemptCodesClass PersonTaxExemptCodes(
Int32 Index
);

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonsClass.PersonTaxExemptCodesObject Method

public virtual AptifySubTypeBase PersonTaxExemptCodesObject();

See Also

PersonsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonTaxExemptCodesClass Class

For a list of all members of this type, see PersonTaxExemptCodesClass Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
PersonTaxExemptCodesClass

public class PersonTaxExemptCodesClass : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity.Generated

Assembly: Aptify.Framework.BusinessLogic.GenericEntity.Generated.Persons (in Aptify.Framework.BusinessLogic.GenericEntity.Generated.Persons.dll)

See Also

PersonTaxExemptCodesClass Members | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonTaxExemptCodesClass Members

PersonTaxExemptCodesClass overview

Public Instance Constructors

PersonTaxExemptCodesClass Constructor Initializes a new instance of the PersonTaxExemptCodesClass class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
City |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
Country |
CountryCodeID |
County |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
ID |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
ISOCountryCode |
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PersonID |
PostalCode |
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SalesTax |
SalesTaxRateID |
Sequence |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
StateProvince |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
TaxExemptCode |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

PersonTaxExemptCodesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonTaxExemptCodesClass Constructor

Initializes a new instance of the PersonTaxExemptCodesClass class.

public PersonTaxExemptCodesClass();

See Also

PersonTaxExemptCodesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonTaxExemptCodesClass Properties

The properties of the PersonTaxExemptCodesClass class are listed below. For a complete list of PersonTaxExemptCodesClass class members, see the PersonTaxExemptCodesClass Members topic.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
City |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
Country |
CountryCodeID |
County |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
ID |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
ISOCountryCode |
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PersonID |
PostalCode |
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SalesTax |
SalesTaxRateID |
Sequence |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
StateProvince |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
TaxExemptCode |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

PersonTaxExemptCodesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


City Property

Aptify 5.0 Software Development Kit (SDK)

PersonTaxExemptCodesClass.City Property

public virtual String City {get;}

See Also

PersonTaxExemptCodesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Country Property

Aptify 5.0 Software Development Kit (SDK)

PersonTaxExemptCodesClass.Country Property

public virtual String Country {get;}

See Also

PersonTaxExemptCodesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CountryCodeID Property

Aptify 5.0 Software Development Kit (SDK)

PersonTaxExemptCodesClass.CountryCodeID Property

public virtual Int32 CountryCodeID {get;}

See Also

PersonTaxExemptCodesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


County Property

Aptify 5.0 Software Development Kit (SDK)

PersonTaxExemptCodesClass.County Property

public virtual String County {get;}

See Also

PersonTaxExemptCodesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

PersonTaxExemptCodesClass.ID Property

public virtual Int32 ID {get;}

See Also

PersonTaxExemptCodesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ISOCountryCode Property

Aptify 5.0 Software Development Kit (SDK)

PersonTaxExemptCodesClass.ISOCountryCode Property

public virtual String ISOCountryCode {get;}

See Also

PersonTaxExemptCodesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonID Property

Aptify 5.0 Software Development Kit (SDK)

PersonTaxExemptCodesClass.PersonID Property

public virtual Int32 PersonID {get;}

See Also

PersonTaxExemptCodesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PostalCode Property

Aptify 5.0 Software Development Kit (SDK)

PersonTaxExemptCodesClass.PostalCode Property

public virtual String PostalCode {get;}

See Also

PersonTaxExemptCodesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


SalesTax Property

Aptify 5.0 Software Development Kit (SDK)

PersonTaxExemptCodesClass.SalesTax Property

public virtual String SalesTax {get;}

See Also

PersonTaxExemptCodesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


SalesTaxRateID Property

Aptify 5.0 Software Development Kit (SDK)

PersonTaxExemptCodesClass.SalesTaxRateID Property

public virtual Int32 SalesTaxRateID {get; set;}

See Also

PersonTaxExemptCodesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Sequence Property

Aptify 5.0 Software Development Kit (SDK)

PersonTaxExemptCodesClass.Sequence Property

public virtual Int32 Sequence {get;}

See Also

PersonTaxExemptCodesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


StateProvince Property

Aptify 5.0 Software Development Kit (SDK)

PersonTaxExemptCodesClass.StateProvince Property

public virtual String StateProvince {get;}

See Also

PersonTaxExemptCodesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


TaxExemptCode Property

Aptify 5.0 Software Development Kit (SDK)

PersonTaxExemptCodesClass.TaxExemptCode Property

public virtual String TaxExemptCode {get; set;}

See Also

PersonTaxExemptCodesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ScheduledTransactionAccountEntriesClass Class

For a list of all members of this type, see ScheduledTransactionAccountEntriesClass Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
ScheduledTransactionAccountEntriesClass

public class ScheduledTransactionAccountEntriesClass : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity.Generated

Assembly: Aptify.Framework.BusinessLogic.GenericEntity.Generated.ScheduledTransactions (in Aptify.Framework.BusinessLogic.GenericEntity.Generated.ScheduledTransactions.dll)

See Also

ScheduledTransactionAccountEntriesClass Members | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ScheduledTransactionAccountEntriesClass Members

ScheduledTransactionAccountEntriesClass overview

Public Instance Constructors

ScheduledTransactionAccountEntriesClass Constructor Initializes a new instance of the ScheduledTransactionAccountEntriesClass class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CreditAmount |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DebitAmount |
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
GLAccount |
ID |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
ScheduledTransactionID |
Sequence |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

ScheduledTransactionAccountEntriesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ScheduledTransactionAccountEntriesClass Constructor

Initializes a new instance of the ScheduledTransactionAccountEntriesClass class.

public ScheduledTransactionAccountEntriesClass();

See Also

ScheduledTransactionAccountEntriesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ScheduledTransactionAccountEntriesClass Properties

The properties of the ScheduledTransactionAccountEntriesClass class are listed below. For a complete list of ScheduledTransactionAccountEntriesClass class members, see the ScheduledTransactionAccountEntriesClass Members topic.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CreditAmount |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DebitAmount |
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
GLAccount |
ID |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
ScheduledTransactionID |
Sequence |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

ScheduledTransactionAccountEntriesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CreditAmount Property

Aptify 5.0 Software Development Kit (SDK)

ScheduledTransactionAccountEntriesClass.CreditAmount Property

public virtual Decimal CreditAmount {get; set;}

See Also

ScheduledTransactionAccountEntriesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


DebitAmount Property

Aptify 5.0 Software Development Kit (SDK)

ScheduledTransactionAccountEntriesClass.DebitAmount Property

public virtual Decimal DebitAmount {get; set;}

See Also

ScheduledTransactionAccountEntriesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


GLAccount Property

Aptify 5.0 Software Development Kit (SDK)

ScheduledTransactionAccountEntriesClass.GLAccount Property

public virtual String GLAccount {get; set;}

See Also

ScheduledTransactionAccountEntriesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

ScheduledTransactionAccountEntriesClass.ID Property

public virtual Int32 ID {get;}

See Also

ScheduledTransactionAccountEntriesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ScheduledTransactionID Property

Aptify 5.0 Software Development Kit (SDK)

ScheduledTransactionAccountEntriesClass.ScheduledTransactionID Property

public virtual Int32 ScheduledTransactionID {get;}

See Also

ScheduledTransactionAccountEntriesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Sequence Property

Aptify 5.0 Software Development Kit (SDK)

ScheduledTransactionAccountEntriesClass.Sequence Property

public virtual Int32 Sequence {get;}

See Also

ScheduledTransactionAccountEntriesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ScheduledTransactionsClass Class

For a list of all members of this type, see ScheduledTransactionsClass Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
ScheduledTransactionsClass
ScheduledTransaction

public class ScheduledTransactionsClass : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity.Generated

Assembly: Aptify.Framework.BusinessLogic.GenericEntity.Generated.ScheduledTransactions (in Aptify.Framework.BusinessLogic.GenericEntity.Generated.ScheduledTransactions.dll)

See Also

ScheduledTransactionsClass Members | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ScheduledTransactionsClass Members

ScheduledTransactionsClass overview

Public Instance Constructors

ScheduledTransactionsClass Constructor Initializes a new instance of the ScheduledTransactionsClass class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BatchID |
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
CALC_Total |
Comments |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrencySpotRateID |
CurrencyType |
CurrencyTypeID |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DateCreated |
DateUpdated |
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
Description |
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
ID |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
OrderID |
OrderStatusID |
Organization |
OrganizationID |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
ScheduledDate |
ScheduledTransactionGroupID |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
Type |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.
WhoCreated |
WhoUpdated |

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
ScheduledTransactionAccountEntries |
ScheduledTransactionAccountEntriesObject |
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

ScheduledTransactionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ScheduledTransactionsClass Constructor

Initializes a new instance of the ScheduledTransactionsClass class.

public ScheduledTransactionsClass();

See Also

ScheduledTransactionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ScheduledTransactionsClass Properties

The properties of the ScheduledTransactionsClass class are listed below. For a complete list of ScheduledTransactionsClass class members, see the ScheduledTransactionsClass Members topic.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BatchID |
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
CALC_Total |
Comments |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrencySpotRateID |
CurrencyType |
CurrencyTypeID |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DateCreated |
DateUpdated |
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
Description |
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
ID |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
OrderID |
OrderStatusID |
Organization |
OrganizationID |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
ScheduledDate |
ScheduledTransactionGroupID |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
Type |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.
WhoCreated |
WhoUpdated |

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

ScheduledTransactionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BatchID Property

Aptify 5.0 Software Development Kit (SDK)

ScheduledTransactionsClass.BatchID Property

public virtual Int32 BatchID {get; set;}

See Also

ScheduledTransactionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CALC_Total Property

Aptify 5.0 Software Development Kit (SDK)

ScheduledTransactionsClass.CALC_Total Property

public virtual Decimal CALC_Total {get;}

See Also

ScheduledTransactionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Comments Property

Aptify 5.0 Software Development Kit (SDK)

ScheduledTransactionsClass.Comments Property

public virtual String Comments {get; set;}

See Also

ScheduledTransactionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CurrencySpotRateID Property

Aptify 5.0 Software Development Kit (SDK)

ScheduledTransactionsClass.CurrencySpotRateID Property

public virtual Int32 CurrencySpotRateID {get; set;}

See Also

ScheduledTransactionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CurrencyType Property

Aptify 5.0 Software Development Kit (SDK)

ScheduledTransactionsClass.CurrencyType Property

public virtual String CurrencyType {get;}

See Also

ScheduledTransactionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CurrencyTypeID Property

Aptify 5.0 Software Development Kit (SDK)

ScheduledTransactionsClass.CurrencyTypeID Property

public virtual Int32 CurrencyTypeID {get; set;}

See Also

ScheduledTransactionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


DateCreated Property

Aptify 5.0 Software Development Kit (SDK)

ScheduledTransactionsClass.DateCreated Property

public virtual DateTime DateCreated {get;}

See Also

ScheduledTransactionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


DateUpdated Property

Aptify 5.0 Software Development Kit (SDK)

ScheduledTransactionsClass.DateUpdated Property

public virtual DateTime DateUpdated {get;}

See Also

ScheduledTransactionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Description Property

Aptify 5.0 Software Development Kit (SDK)

ScheduledTransactionsClass.Description Property

public virtual String Description {get; set;}

See Also

ScheduledTransactionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

ScheduledTransactionsClass.ID Property

public virtual Int32 ID {get;}

See Also

ScheduledTransactionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrderID Property

Aptify 5.0 Software Development Kit (SDK)

ScheduledTransactionsClass.OrderID Property

public virtual Int32 OrderID {get; set;}

See Also

ScheduledTransactionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrderStatusID Property

Aptify 5.0 Software Development Kit (SDK)

ScheduledTransactionsClass.OrderStatusID Property

public virtual Int32 OrderStatusID {get;}

See Also

ScheduledTransactionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Organization Property

Aptify 5.0 Software Development Kit (SDK)

ScheduledTransactionsClass.Organization Property

public virtual String Organization {get;}

See Also

ScheduledTransactionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrganizationID Property

Aptify 5.0 Software Development Kit (SDK)

ScheduledTransactionsClass.OrganizationID Property

public virtual Int32 OrganizationID {get; set;}

See Also

ScheduledTransactionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ScheduledDate Property

Aptify 5.0 Software Development Kit (SDK)

ScheduledTransactionsClass.ScheduledDate Property

public virtual DateTime ScheduledDate {get; set;}

See Also

ScheduledTransactionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ScheduledTransactionGroupID Property

Aptify 5.0 Software Development Kit (SDK)

ScheduledTransactionsClass.ScheduledTransactionGroupID Property

public virtual Int32 ScheduledTransactionGroupID {get; set;}

See Also

ScheduledTransactionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Type Property

Aptify 5.0 Software Development Kit (SDK)

ScheduledTransactionsClass.Type Property

public virtual String Type {get; set;}

See Also

ScheduledTransactionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


WhoCreated Property

Aptify 5.0 Software Development Kit (SDK)

ScheduledTransactionsClass.WhoCreated Property

public virtual String WhoCreated {get;}

See Also

ScheduledTransactionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


WhoUpdated Property

Aptify 5.0 Software Development Kit (SDK)

ScheduledTransactionsClass.WhoUpdated Property

public virtual String WhoUpdated {get;}

See Also

ScheduledTransactionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ScheduledTransactionsClass Methods

The methods of the ScheduledTransactionsClass class are listed below. For a complete list of ScheduledTransactionsClass class members, see the ScheduledTransactionsClass Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
ScheduledTransactionAccountEntries |
ScheduledTransactionAccountEntriesObject |
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

ScheduledTransactionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ScheduledTransactionsClass.ScheduledTransactionAccountEntries Method

public virtual ScheduledTransactionAccountEntriesClass ScheduledTransactionAccountEntries(
Int32 Index
);

See Also

ScheduledTransactionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ScheduledTransactionsClass.ScheduledTransactionAccountEntriesObject Method

public virtual AptifySubTypeBase ScheduledTransactionAccountEntriesObject();

See Also

ScheduledTransactionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


SubscriptionDeliveryLogClass Class

For a list of all members of this type, see SubscriptionDeliveryLogClass Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
SubscriptionDeliveryLogClass

public class SubscriptionDeliveryLogClass : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity.Generated

Assembly: Aptify.Framework.BusinessLogic.GenericEntity.Generated.Subscriptions (in Aptify.Framework.BusinessLogic.GenericEntity.Generated.Subscriptions.dll)

See Also

SubscriptionDeliveryLogClass Members | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


SubscriptionDeliveryLogClass Members

SubscriptionDeliveryLogClass overview

Public Instance Constructors

SubscriptionDeliveryLogClass Constructor Initializes a new instance of the SubscriptionDeliveryLogClass class.

Public Instance Properties

AddressID |
AddressLine1 |
AddressLine2 |
AddressLine3 |
AddressLine4 |
Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
BulkCopiesSent |
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
City |
Comments |
Company_Name |
CompanyID |
Complaint |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
Country |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DeliveryDate |
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
DistributionType |
DistributionTypeID |
DistributionTypeID_Name |
DivisionName |
Email |
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fax |
FaxAreaCode |
FaxCountryCode |
FaxID |
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
FullfillmentID |
ID |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
Issue |
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PersonID |
PersonID_Name |
Phone |
PhoneAreaCode |
PhoneCountryCode |
PhoneExtension |
PhoneID |
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
ProductID |
Received |
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SentTo |
Sequence |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
State |
SubscriptionID |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.
Volume |
ZipCode |

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

SubscriptionDeliveryLogClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


SubscriptionDeliveryLogClass Constructor

Initializes a new instance of the SubscriptionDeliveryLogClass class.

public SubscriptionDeliveryLogClass();

See Also

SubscriptionDeliveryLogClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


SubscriptionDeliveryLogClass Properties

The properties of the SubscriptionDeliveryLogClass class are listed below. For a complete list of SubscriptionDeliveryLogClass class members, see the SubscriptionDeliveryLogClass Members topic.

Public Instance Properties

AddressID |
AddressLine1 |
AddressLine2 |
AddressLine3 |
AddressLine4 |
Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
BulkCopiesSent |
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
City |
Comments |
Company_Name |
CompanyID |
Complaint |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
Country |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DeliveryDate |
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
DistributionType |
DistributionTypeID |
DistributionTypeID_Name |
DivisionName |
Email |
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fax |
FaxAreaCode |
FaxCountryCode |
FaxID |
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
FullfillmentID |
ID |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
Issue |
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PersonID |
PersonID_Name |
Phone |
PhoneAreaCode |
PhoneCountryCode |
PhoneExtension |
PhoneID |
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
ProductID |
Received |
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SentTo |
Sequence |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
State |
SubscriptionID |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.
Volume |
ZipCode |

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

SubscriptionDeliveryLogClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AddressID Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionDeliveryLogClass.AddressID Property

public virtual Int32 AddressID {get; set;}

See Also

SubscriptionDeliveryLogClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AddressLine1 Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionDeliveryLogClass.AddressLine1 Property

public virtual String AddressLine1 {get; set;}

See Also

SubscriptionDeliveryLogClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AddressLine2 Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionDeliveryLogClass.AddressLine2 Property

public virtual String AddressLine2 {get; set;}

See Also

SubscriptionDeliveryLogClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AddressLine3 Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionDeliveryLogClass.AddressLine3 Property

public virtual String AddressLine3 {get; set;}

See Also

SubscriptionDeliveryLogClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AddressLine4 Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionDeliveryLogClass.AddressLine4 Property

public virtual String AddressLine4 {get; set;}

See Also

SubscriptionDeliveryLogClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BulkCopiesSent Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionDeliveryLogClass.BulkCopiesSent Property

public virtual Int32 BulkCopiesSent {get; set;}

See Also

SubscriptionDeliveryLogClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


City Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionDeliveryLogClass.City Property

public virtual String City {get; set;}

See Also

SubscriptionDeliveryLogClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Comments Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionDeliveryLogClass.Comments Property

public virtual String Comments {get; set;}

See Also

SubscriptionDeliveryLogClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Company_Name Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionDeliveryLogClass.Company_Name Property

public virtual String Company_Name {get;}

See Also

SubscriptionDeliveryLogClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CompanyID Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionDeliveryLogClass.CompanyID Property

public virtual Int32 CompanyID {get; set;}

See Also

SubscriptionDeliveryLogClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Complaint Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionDeliveryLogClass.Complaint Property

public virtual Boolean Complaint {get; set;}

See Also

SubscriptionDeliveryLogClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Country Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionDeliveryLogClass.Country Property

public virtual String Country {get;}

See Also

SubscriptionDeliveryLogClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


DeliveryDate Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionDeliveryLogClass.DeliveryDate Property

public virtual DateTime DeliveryDate {get;}

See Also

SubscriptionDeliveryLogClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


DistributionType Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionDeliveryLogClass.DistributionType Property

public virtual String DistributionType {get;}

See Also

SubscriptionDeliveryLogClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


DistributionTypeID Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionDeliveryLogClass.DistributionTypeID Property

public virtual Int32 DistributionTypeID {get; set;}

See Also

SubscriptionDeliveryLogClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


DistributionTypeID_Name Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionDeliveryLogClass.DistributionTypeID_Name Property

public virtual String DistributionTypeID_Name {get;}

See Also

SubscriptionDeliveryLogClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


DivisionName Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionDeliveryLogClass.DivisionName Property

public virtual String DivisionName {get; set;}

See Also

SubscriptionDeliveryLogClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Email Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionDeliveryLogClass.Email Property

public virtual String Email {get; set;}

See Also

SubscriptionDeliveryLogClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Fax Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionDeliveryLogClass.Fax Property

public virtual String Fax {get; set;}

See Also

SubscriptionDeliveryLogClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


FaxAreaCode Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionDeliveryLogClass.FaxAreaCode Property

public virtual String FaxAreaCode {get; set;}

See Also

SubscriptionDeliveryLogClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


FaxCountryCode Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionDeliveryLogClass.FaxCountryCode Property

public virtual String FaxCountryCode {get; set;}

See Also

SubscriptionDeliveryLogClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


FaxID Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionDeliveryLogClass.FaxID Property

public virtual Int32 FaxID {get; set;}

See Also

SubscriptionDeliveryLogClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


FullfillmentID Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionDeliveryLogClass.FullfillmentID Property

public virtual Int32 FullfillmentID {get; set;}

See Also

SubscriptionDeliveryLogClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionDeliveryLogClass.ID Property

public virtual Int32 ID {get;}

See Also

SubscriptionDeliveryLogClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Issue Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionDeliveryLogClass.Issue Property

public virtual String Issue {get;}

See Also

SubscriptionDeliveryLogClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonID Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionDeliveryLogClass.PersonID Property

public virtual Int32 PersonID {get; set;}

See Also

SubscriptionDeliveryLogClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PersonID_Name Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionDeliveryLogClass.PersonID_Name Property

public virtual String PersonID_Name {get;}

See Also

SubscriptionDeliveryLogClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Phone Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionDeliveryLogClass.Phone Property

public virtual String Phone {get; set;}

See Also

SubscriptionDeliveryLogClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PhoneAreaCode Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionDeliveryLogClass.PhoneAreaCode Property

public virtual String PhoneAreaCode {get; set;}

See Also

SubscriptionDeliveryLogClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PhoneCountryCode Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionDeliveryLogClass.PhoneCountryCode Property

public virtual String PhoneCountryCode {get; set;}

See Also

SubscriptionDeliveryLogClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PhoneExtension Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionDeliveryLogClass.PhoneExtension Property

public virtual String PhoneExtension {get; set;}

See Also

SubscriptionDeliveryLogClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PhoneID Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionDeliveryLogClass.PhoneID Property

public virtual Int32 PhoneID {get; set;}

See Also

SubscriptionDeliveryLogClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ProductID Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionDeliveryLogClass.ProductID Property

public virtual Int32 ProductID {get;}

See Also

SubscriptionDeliveryLogClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Received Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionDeliveryLogClass.Received Property

public virtual Boolean Received {get; set;}

See Also

SubscriptionDeliveryLogClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


SentTo Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionDeliveryLogClass.SentTo Property

public virtual String SentTo {get;}

See Also

SubscriptionDeliveryLogClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Sequence Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionDeliveryLogClass.Sequence Property

public virtual Int32 Sequence {get;}

See Also

SubscriptionDeliveryLogClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


State Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionDeliveryLogClass.State Property

public virtual String State {get; set;}

See Also

SubscriptionDeliveryLogClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


SubscriptionID Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionDeliveryLogClass.SubscriptionID Property

public virtual Int32 SubscriptionID {get;}

See Also

SubscriptionDeliveryLogClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Volume Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionDeliveryLogClass.Volume Property

public virtual String Volume {get;}

See Also

SubscriptionDeliveryLogClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ZipCode Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionDeliveryLogClass.ZipCode Property

public virtual String ZipCode {get; set;}

See Also

SubscriptionDeliveryLogClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


SubscriptionDeliveryScheduleClass Class

For a list of all members of this type, see SubscriptionDeliveryScheduleClass Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
SubscriptionDeliveryScheduleClass

public class SubscriptionDeliveryScheduleClass : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity.Generated

Assembly: Aptify.Framework.BusinessLogic.GenericEntity.Generated.Subscriptions (in Aptify.Framework.BusinessLogic.GenericEntity.Generated.Subscriptions.dll)

See Also

SubscriptionDeliveryScheduleClass Members | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


SubscriptionDeliveryScheduleClass Members

SubscriptionDeliveryScheduleClass overview

Public Instance Constructors

SubscriptionDeliveryScheduleClass Constructor Initializes a new instance of the SubscriptionDeliveryScheduleClass class.

Public Instance Properties

AddressID |
AddressLine1 |
AddressLine2 |
AddressLine3 |
AddressLine4 |
Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
City |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
Country |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
DistributionTypeID |
DistributionTypeID_Name |
Email |
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EndDate |
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fax |
FaxAreaCode |
FaxCountryCode |
FaxID |
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
ID |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
Phone |
PhoneAreaCode |
PhoneCountryCode |
PhoneExtension |
PhoneID |
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequestedByID |
RequestedByID_Name |
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Sequence |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
StartDate |
State |
SubscriptionID |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.
ZipCode |

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

SubscriptionDeliveryScheduleClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


SubscriptionDeliveryScheduleClass Constructor

Initializes a new instance of the SubscriptionDeliveryScheduleClass class.

public SubscriptionDeliveryScheduleClass();

See Also

SubscriptionDeliveryScheduleClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


SubscriptionDeliveryScheduleClass Properties

The properties of the SubscriptionDeliveryScheduleClass class are listed below. For a complete list of SubscriptionDeliveryScheduleClass class members, see the SubscriptionDeliveryScheduleClass Members topic.

Public Instance Properties

AddressID |
AddressLine1 |
AddressLine2 |
AddressLine3 |
AddressLine4 |
Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
City |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
Country |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
DistributionTypeID |
DistributionTypeID_Name |
Email |
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EndDate |
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fax |
FaxAreaCode |
FaxCountryCode |
FaxID |
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
ID |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
Phone |
PhoneAreaCode |
PhoneCountryCode |
PhoneExtension |
PhoneID |
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequestedByID |
RequestedByID_Name |
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Sequence |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
StartDate |
State |
SubscriptionID |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.
ZipCode |

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

SubscriptionDeliveryScheduleClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AddressID Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionDeliveryScheduleClass.AddressID Property

public virtual Int32 AddressID {get; set;}

See Also

SubscriptionDeliveryScheduleClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AddressLine1 Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionDeliveryScheduleClass.AddressLine1 Property

public virtual String AddressLine1 {get; set;}

See Also

SubscriptionDeliveryScheduleClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AddressLine2 Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionDeliveryScheduleClass.AddressLine2 Property

public virtual String AddressLine2 {get; set;}

See Also

SubscriptionDeliveryScheduleClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AddressLine3 Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionDeliveryScheduleClass.AddressLine3 Property

public virtual String AddressLine3 {get; set;}

See Also

SubscriptionDeliveryScheduleClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AddressLine4 Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionDeliveryScheduleClass.AddressLine4 Property

public virtual String AddressLine4 {get; set;}

See Also

SubscriptionDeliveryScheduleClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


City Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionDeliveryScheduleClass.City Property

public virtual String City {get; set;}

See Also

SubscriptionDeliveryScheduleClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Country Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionDeliveryScheduleClass.Country Property

public virtual String Country {get;}

See Also

SubscriptionDeliveryScheduleClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


DistributionTypeID Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionDeliveryScheduleClass.DistributionTypeID Property

public virtual Int32 DistributionTypeID {get; set;}

See Also

SubscriptionDeliveryScheduleClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


DistributionTypeID_Name Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionDeliveryScheduleClass.DistributionTypeID_Name Property

public virtual String DistributionTypeID_Name {get;}

See Also

SubscriptionDeliveryScheduleClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Email Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionDeliveryScheduleClass.Email Property

public virtual String Email {get; set;}

See Also

SubscriptionDeliveryScheduleClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


EndDate Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionDeliveryScheduleClass.EndDate Property

public virtual DateTime EndDate {get; set;}

See Also

SubscriptionDeliveryScheduleClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Fax Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionDeliveryScheduleClass.Fax Property

public virtual String Fax {get; set;}

See Also

SubscriptionDeliveryScheduleClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


FaxAreaCode Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionDeliveryScheduleClass.FaxAreaCode Property

public virtual String FaxAreaCode {get; set;}

See Also

SubscriptionDeliveryScheduleClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


FaxCountryCode Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionDeliveryScheduleClass.FaxCountryCode Property

public virtual String FaxCountryCode {get; set;}

See Also

SubscriptionDeliveryScheduleClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


FaxID Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionDeliveryScheduleClass.FaxID Property

public virtual Int32 FaxID {get; set;}

See Also

SubscriptionDeliveryScheduleClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionDeliveryScheduleClass.ID Property

public virtual Int32 ID {get;}

See Also

SubscriptionDeliveryScheduleClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Phone Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionDeliveryScheduleClass.Phone Property

public virtual String Phone {get; set;}

See Also

SubscriptionDeliveryScheduleClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PhoneAreaCode Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionDeliveryScheduleClass.PhoneAreaCode Property

public virtual String PhoneAreaCode {get; set;}

See Also

SubscriptionDeliveryScheduleClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PhoneCountryCode Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionDeliveryScheduleClass.PhoneCountryCode Property

public virtual String PhoneCountryCode {get; set;}

See Also

SubscriptionDeliveryScheduleClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PhoneExtension Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionDeliveryScheduleClass.PhoneExtension Property

public virtual String PhoneExtension {get; set;}

See Also

SubscriptionDeliveryScheduleClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


PhoneID Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionDeliveryScheduleClass.PhoneID Property

public virtual Int32 PhoneID {get; set;}

See Also

SubscriptionDeliveryScheduleClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


RequestedByID Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionDeliveryScheduleClass.RequestedByID Property

public virtual Int32 RequestedByID {get; set;}

See Also

SubscriptionDeliveryScheduleClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


RequestedByID_Name Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionDeliveryScheduleClass.RequestedByID_Name Property

public virtual String RequestedByID_Name {get;}

See Also

SubscriptionDeliveryScheduleClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Sequence Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionDeliveryScheduleClass.Sequence Property

public virtual Int32 Sequence {get;}

See Also

SubscriptionDeliveryScheduleClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


StartDate Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionDeliveryScheduleClass.StartDate Property

public virtual DateTime StartDate {get; set;}

See Also

SubscriptionDeliveryScheduleClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


State Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionDeliveryScheduleClass.State Property

public virtual String State {get; set;}

See Also

SubscriptionDeliveryScheduleClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


SubscriptionID Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionDeliveryScheduleClass.SubscriptionID Property

public virtual Int32 SubscriptionID {get;}

See Also

SubscriptionDeliveryScheduleClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ZipCode Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionDeliveryScheduleClass.ZipCode Property

public virtual String ZipCode {get; set;}

See Also

SubscriptionDeliveryScheduleClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


SubscriptionPurchasesClass Class

For a list of all members of this type, see SubscriptionPurchasesClass Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
SubscriptionPurchasesClass

public class SubscriptionPurchasesClass : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity.Generated

Assembly: Aptify.Framework.BusinessLogic.GenericEntity.Generated.Subscriptions (in Aptify.Framework.BusinessLogic.GenericEntity.Generated.Subscriptions.dll)

See Also

SubscriptionPurchasesClass Members | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


SubscriptionPurchasesClass Members

SubscriptionPurchasesClass overview

Public Instance Constructors

SubscriptionPurchasesClass Constructor Initializes a new instance of the SubscriptionPurchasesClass class.

Public Instance Properties

Agent |
AgentID |
AgentOrderNumber |
Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EndDate |
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
ID |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
NumCopies |
NumIssues |
OrderDetailID |
OrderID |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
ReferredBy |
ReferredByID |
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Sequence |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
StartDate |
SubscriptionID |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

SubscriptionPurchasesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


SubscriptionPurchasesClass Constructor

Initializes a new instance of the SubscriptionPurchasesClass class.

public SubscriptionPurchasesClass();

See Also

SubscriptionPurchasesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


SubscriptionPurchasesClass Properties

The properties of the SubscriptionPurchasesClass class are listed below. For a complete list of SubscriptionPurchasesClass class members, see the SubscriptionPurchasesClass Members topic.

Public Instance Properties

Agent |
AgentID |
AgentOrderNumber |
Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EndDate |
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
ID |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
NumCopies |
NumIssues |
OrderDetailID |
OrderID |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
ReferredBy |
ReferredByID |
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
Sequence |
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
StartDate |
SubscriptionID |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

SubscriptionPurchasesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Agent Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionPurchasesClass.Agent Property

public virtual String Agent {get;}

See Also

SubscriptionPurchasesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AgentID Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionPurchasesClass.AgentID Property

public virtual Int32 AgentID {get; set;}

See Also

SubscriptionPurchasesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AgentOrderNumber Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionPurchasesClass.AgentOrderNumber Property

public virtual String AgentOrderNumber {get; set;}

See Also

SubscriptionPurchasesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


EndDate Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionPurchasesClass.EndDate Property

public virtual DateTime EndDate {get; set;}

See Also

SubscriptionPurchasesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionPurchasesClass.ID Property

public virtual Int32 ID {get;}

See Also

SubscriptionPurchasesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


NumCopies Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionPurchasesClass.NumCopies Property

public virtual Int32 NumCopies {get; set;}

See Also

SubscriptionPurchasesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


NumIssues Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionPurchasesClass.NumIssues Property

public virtual Int32 NumIssues {get; set;}

See Also

SubscriptionPurchasesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrderDetailID Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionPurchasesClass.OrderDetailID Property

public virtual Int32 OrderDetailID {get; set;}

See Also

SubscriptionPurchasesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


OrderID Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionPurchasesClass.OrderID Property

public virtual Int32 OrderID {get; set;}

See Also

SubscriptionPurchasesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ReferredBy Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionPurchasesClass.ReferredBy Property

public virtual String ReferredBy {get;}

See Also

SubscriptionPurchasesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ReferredByID Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionPurchasesClass.ReferredByID Property

public virtual Int32 ReferredByID {get; set;}

See Also

SubscriptionPurchasesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Sequence Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionPurchasesClass.Sequence Property

public virtual Int32 Sequence {get;}

See Also

SubscriptionPurchasesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


StartDate Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionPurchasesClass.StartDate Property

public virtual DateTime StartDate {get; set;}

See Also

SubscriptionPurchasesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


SubscriptionID Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionPurchasesClass.SubscriptionID Property

public virtual Int32 SubscriptionID {get;}

See Also

SubscriptionPurchasesClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


SubscriptionsClass Class

For a list of all members of this type, see SubscriptionsClass Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
SubscriptionsClass
SubscriptionEntity

public class SubscriptionsClass : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.GenericEntity.Generated

Assembly: Aptify.Framework.BusinessLogic.GenericEntity.Generated.Subscriptions (in Aptify.Framework.BusinessLogic.GenericEntity.Generated.Subscriptions.dll)

See Also

SubscriptionsClass Members | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


SubscriptionsClass Members

SubscriptionsClass overview

Public Instance Constructors

SubscriptionsClass Constructor Initializes a new instance of the SubscriptionsClass class.

Public Instance Properties

Agency |
AgentID |
AgentOrderNumber |
Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
AutoRenew |
AutoRenewStandingOrderID |
BaseIssuesSent |
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
CALC_EndDate |
CALC_IssuesPurchased |
CALC_IssuesSent |
CALC_NumPurchases |
CALC_StartDate |
Campaign |
CampaignID |
CancelComments |
CancelReason |
CancelReasonID |
ChapterID |
Comments |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DateCreated |
DateUpdated |
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
DistributionType |
DistributionTypeID |
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EndDate |
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
ID |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
IssuesLeft |
IssuesPurchased |
IssuesSent |
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
Product |
ProductID |
Purchases |
Quantity |
Recipient |
RecipientCompany |
RecipientID |
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
ReferredBy |
ReferredByID |
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
ShipToID |
StartDate |
Status |
StatusID |
Subscriber |
SubscriberCompany |
SubscriberCompanyID |
SubscriberID |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.
WhoCreated |
WhoUpdated |

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
SubscriptionDeliveryLog |
SubscriptionDeliveryLogObject |
SubscriptionDeliverySchedule |
SubscriptionDeliveryScheduleObject |
SubscriptionPurchases |
SubscriptionPurchasesObject |
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

SubscriptionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


SubscriptionsClass Constructor

Initializes a new instance of the SubscriptionsClass class.

public SubscriptionsClass();

See Also

SubscriptionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


SubscriptionsClass Properties

The properties of the SubscriptionsClass class are listed below. For a complete list of SubscriptionsClass class members, see the SubscriptionsClass Members topic.

Public Instance Properties

Agency |
AgentID |
AgentOrderNumber |
Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
AutoRenew |
AutoRenewStandingOrderID |
BaseIssuesSent |
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
CALC_EndDate |
CALC_IssuesPurchased |
CALC_IssuesSent |
CALC_NumPurchases |
CALC_StartDate |
Campaign |
CampaignID |
CancelComments |
CancelReason |
CancelReasonID |
ChapterID |
Comments |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DateCreated |
DateUpdated |
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
DistributionType |
DistributionTypeID |
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EndDate |
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
ID |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
IssuesLeft |
IssuesPurchased |
IssuesSent |
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
Product |
ProductID |
Purchases |
Quantity |
Recipient |
RecipientCompany |
RecipientID |
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
ReferredBy |
ReferredByID |
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
ShipToID |
StartDate |
Status |
StatusID |
Subscriber |
SubscriberCompany |
SubscriberCompanyID |
SubscriberID |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.
WhoCreated |
WhoUpdated |

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

SubscriptionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Agency Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionsClass.Agency Property

public virtual String Agency {get;}

See Also

SubscriptionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AgentID Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionsClass.AgentID Property

public virtual Int32 AgentID {get; set;}

See Also

SubscriptionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AgentOrderNumber Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionsClass.AgentOrderNumber Property

public virtual String AgentOrderNumber {get; set;}

See Also

SubscriptionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AutoRenew Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionsClass.AutoRenew Property

public virtual Boolean AutoRenew {get; set;}

See Also

SubscriptionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


AutoRenewStandingOrderID Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionsClass.AutoRenewStandingOrderID Property

public virtual Int32 AutoRenewStandingOrderID {get; set;}

See Also

SubscriptionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


BaseIssuesSent Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionsClass.BaseIssuesSent Property

public virtual Int32 BaseIssuesSent {get;}

See Also

SubscriptionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CALC_EndDate Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionsClass.CALC_EndDate Property

public virtual DateTime CALC_EndDate {get;}

See Also

SubscriptionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CALC_IssuesPurchased Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionsClass.CALC_IssuesPurchased Property

public virtual Int32 CALC_IssuesPurchased {get;}

See Also

SubscriptionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CALC_IssuesSent Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionsClass.CALC_IssuesSent Property

public virtual Int32 CALC_IssuesSent {get;}

See Also

SubscriptionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CALC_NumPurchases Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionsClass.CALC_NumPurchases Property

public virtual Int32 CALC_NumPurchases {get;}

See Also

SubscriptionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CALC_StartDate Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionsClass.CALC_StartDate Property

public virtual DateTime CALC_StartDate {get;}

See Also

SubscriptionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Campaign Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionsClass.Campaign Property

public virtual String Campaign {get;}

See Also

SubscriptionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CampaignID Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionsClass.CampaignID Property

public virtual Int32 CampaignID {get; set;}

See Also

SubscriptionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CancelComments Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionsClass.CancelComments Property

public virtual String CancelComments {get; set;}

See Also

SubscriptionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CancelReason Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionsClass.CancelReason Property

public virtual String CancelReason {get;}

See Also

SubscriptionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


CancelReasonID Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionsClass.CancelReasonID Property

public virtual Int32 CancelReasonID {get; set;}

See Also

SubscriptionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ChapterID Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionsClass.ChapterID Property

public virtual Int32 ChapterID {get; set;}

See Also

SubscriptionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Comments Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionsClass.Comments Property

public virtual String Comments {get; set;}

See Also

SubscriptionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


DateCreated Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionsClass.DateCreated Property

public virtual DateTime DateCreated {get;}

See Also

SubscriptionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


DateUpdated Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionsClass.DateUpdated Property

public virtual DateTime DateUpdated {get;}

See Also

SubscriptionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


DistributionType Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionsClass.DistributionType Property

public virtual String DistributionType {get;}

See Also

SubscriptionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


DistributionTypeID Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionsClass.DistributionTypeID Property

public virtual Int32 DistributionTypeID {get; set;}

See Also

SubscriptionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


EndDate Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionsClass.EndDate Property

public virtual DateTime EndDate {get;}

See Also

SubscriptionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionsClass.ID Property

public virtual Int32 ID {get;}

See Also

SubscriptionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


IssuesLeft Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionsClass.IssuesLeft Property

public virtual Int32 IssuesLeft {get;}

See Also

SubscriptionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


IssuesPurchased Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionsClass.IssuesPurchased Property

public virtual Int32 IssuesPurchased {get;}

See Also

SubscriptionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


IssuesSent Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionsClass.IssuesSent Property

public virtual Int32 IssuesSent {get;}

See Also

SubscriptionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Product Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionsClass.Product Property

public virtual String Product {get;}

See Also

SubscriptionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ProductID Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionsClass.ProductID Property

public virtual Int32 ProductID {get; set;}

See Also

SubscriptionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Purchases Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionsClass.Purchases Property

public virtual Int32 Purchases {get;}

See Also

SubscriptionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Quantity Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionsClass.Quantity Property

public virtual Decimal Quantity {get; set;}

See Also

SubscriptionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Recipient Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionsClass.Recipient Property

public virtual String Recipient {get;}

See Also

SubscriptionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


RecipientCompany Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionsClass.RecipientCompany Property

public virtual String RecipientCompany {get;}

See Also

SubscriptionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


RecipientID Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionsClass.RecipientID Property

public virtual Int32 RecipientID {get;}

See Also

SubscriptionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ReferredBy Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionsClass.ReferredBy Property

public virtual String ReferredBy {get;}

See Also

SubscriptionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ReferredByID Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionsClass.ReferredByID Property

public virtual Int32 ReferredByID {get; set;}

See Also

SubscriptionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


ShipToID Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionsClass.ShipToID Property

public virtual Int32 ShipToID {get; set;}

See Also

SubscriptionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


StartDate Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionsClass.StartDate Property

public virtual DateTime StartDate {get;}

See Also

SubscriptionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Status Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionsClass.Status Property

public virtual String Status {get;}

See Also

SubscriptionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


StatusID Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionsClass.StatusID Property

public virtual Int32 StatusID {get; set;}

See Also

SubscriptionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Subscriber Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionsClass.Subscriber Property

public virtual String Subscriber {get;}

See Also

SubscriptionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


SubscriberCompany Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionsClass.SubscriberCompany Property

public virtual String SubscriberCompany {get;}

See Also

SubscriptionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


SubscriberCompanyID Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionsClass.SubscriberCompanyID Property

public virtual Int32 SubscriberCompanyID {get; set;}

See Also

SubscriptionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


SubscriberID Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionsClass.SubscriberID Property

public virtual Int32 SubscriberID {get; set;}

See Also

SubscriptionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


WhoCreated Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionsClass.WhoCreated Property

public virtual String WhoCreated {get;}

See Also

SubscriptionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


WhoUpdated Property

Aptify 5.0 Software Development Kit (SDK)

SubscriptionsClass.WhoUpdated Property

public virtual String WhoUpdated {get;}

See Also

SubscriptionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


SubscriptionsClass Methods

The methods of the SubscriptionsClass class are listed below. For a complete list of SubscriptionsClass class members, see the SubscriptionsClass Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
SubscriptionDeliveryLog |
SubscriptionDeliveryLogObject |
SubscriptionDeliverySchedule |
SubscriptionDeliveryScheduleObject |
SubscriptionPurchases |
SubscriptionPurchasesObject |
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

SubscriptionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


SubscriptionsClass.SubscriptionDeliveryLog Method

public virtual SubscriptionDeliveryLogClass SubscriptionDeliveryLog(
Int32 Index
);

See Also

SubscriptionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


SubscriptionsClass.SubscriptionDeliveryLogObject Method

public virtual AptifySubTypeBase SubscriptionDeliveryLogObject();

See Also

SubscriptionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


SubscriptionsClass.SubscriptionDeliverySchedule Method

public virtual SubscriptionDeliveryScheduleClass SubscriptionDeliverySchedule(
Int32 Index
);

See Also

SubscriptionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


SubscriptionsClass.SubscriptionDeliveryScheduleObject Method

public virtual AptifySubTypeBase SubscriptionDeliveryScheduleObject();

See Also

SubscriptionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


SubscriptionsClass.SubscriptionPurchases Method

public virtual SubscriptionPurchasesClass SubscriptionPurchases(
Int32 Index
);

See Also

SubscriptionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


SubscriptionsClass.SubscriptionPurchasesObject Method

public virtual AptifySubTypeBase SubscriptionPurchasesObject();

See Also

SubscriptionsClass Class | Aptify.Framework.BusinessLogic.GenericEntity.Generated Namespace


Aptify.Framework.BusinessLogic.Packers

Aptify 5.0 Software Development Kit (SDK)

Aptify.Framework.BusinessLogic.Packers Namespace

The objects in this namespace correspond to Aptify's Pack Loader entity and provide the means for unpacking entities from earlier versions of Aptify. See Aptify.Framework.DataPacker and Aptify.Framework.EntityPacker for information on the Entity Packer and Data Packer wizards.

Namespace hierarchy

Classes

Class | Description
CGI35SP4PackLoaderBase | Provides the base functionality needed to parse 35 GE packs and populate a GE for the current version of the software.
DBObjectsPackLoader35SP4To40Beta3 |
EntityPackLoader35SP4To40Beta3 | Loads Entities packed in CGI 3.5 sp4 into a 4.0 Beta 3 Generic entity.
EntityPackLoader40To40 | Loads Generic Entity Objects packed in the current version into a Generic Entity for the current version.
PackLoadersEntity | Holds the needed information to represent a Pack Loader
TranslationException | Thrown if there is a problem while trying to translate a pack from one version to another.
TranslationManager | Encapsulates functionality that is responsible for translating Pack Files.

Interfaces

Interface | Description
IPackLoader | The pack loader is responsible for loading a packfile from a specific version of aptify software.


CGI35SP4PackLoaderBase Class

Provides the base functionality needed to parse 35 GE packs and populate a GE for the current version of the software.

For a list of all members of this type, see CGI35SP4PackLoaderBase Members.

System.Object
CGI35SP4PackLoaderBase
DBObjectsPackLoader35SP4To40Beta3
EntityPackLoader35SP4To40Beta3

public class CGI35SP4PackLoaderBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.Packers

Assembly: AptifyPackTranslation (in AptifyPackTranslation.dll)

See Also

CGI35SP4PackLoaderBase Members | Aptify.Framework.BusinessLogic.Packers Namespace


CGI35SP4PackLoaderBase Members

CGI35SP4PackLoaderBase overview

Protected Static Fields

oRegex Provides a regular expression that will find any word that matches a 3.x database name

Public Instance Constructors

CGI35SP4PackLoaderBase Constructor Initializes a new instance of the CGI35SP4PackLoaderBase class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
LoadPack | Overloaded. Populates a Current Version's GE structure with a 3.5 pack file.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PostLoad | After the ge has been loaded with the pack this can be called to do any clean up.
PreLoad | This method should take a GE that has been created to reflect the current schema of a GE Object and then populate any missing defaults.

See Also

CGI35SP4PackLoaderBase Class | Aptify.Framework.BusinessLogic.Packers Namespace


CGI35SP4PackLoaderBase Constructor

Initializes a new instance of the CGI35SP4PackLoaderBase class.

public CGI35SP4PackLoaderBase();

See Also

CGI35SP4PackLoaderBase Class | Aptify.Framework.BusinessLogic.Packers Namespace


CGI35SP4PackLoaderBase Fields

The fields of the CGI35SP4PackLoaderBase class are listed below. For a complete list of CGI35SP4PackLoaderBase class members, see the CGI35SP4PackLoaderBase Members topic.

Protected Static Fields

oRegex Provides a regular expression that will find any word that matches a 3.x database name

See Also

CGI35SP4PackLoaderBase Class | Aptify.Framework.BusinessLogic.Packers Namespace


CGI35SP4PackLoaderBase.oRegex Field

Provides a regular expression that will find any word that matches a 3.x database name

protected static readonly oRegex oRegex;

Remarks

See Also

CGI35SP4PackLoaderBase Class | Aptify.Framework.BusinessLogic.Packers Namespace


CGI35SP4PackLoaderBase Methods

The methods of the CGI35SP4PackLoaderBase class are listed below. For a complete list of CGI35SP4PackLoaderBase class members, see the CGI35SP4PackLoaderBase Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
LoadPack | Overloaded. Populates a Current Version's GE structure with a 3.5 pack file.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PostLoad | After the ge has been loaded with the pack this can be called to do any clean up.
PreLoad | This method should take a GE that has been created to reflect the current schema of a GE Object and then populate any missing defaults.

See Also

CGI35SP4PackLoaderBase Class | Aptify.Framework.BusinessLogic.Packers Namespace


LoadPack Method

Aptify 5.0 Software Development Kit (SDK)

CGI35SP4PackLoaderBase.LoadPack Method

Overload List

protected virtual void LoadPack(AptifyApplication,AptifyGenericEntityBase,FileInfo);

Populates a Current Version's GE structure with a 3.5 pack file.

protected virtual AptifyGenericEntityBase LoadPack(AptifyApplication,String,FileInfo);

See Also

CGI35SP4PackLoaderBase Class | Aptify.Framework.BusinessLogic.Packers Namespace


CGI35SP4PackLoaderBase.LoadPack Method (AptifyApplication, AptifyGenericEntityBase, FileInfo)

protected virtual void LoadPack(
AptifyApplication ApplicationObject,
AptifyGenericEntityBase GEToLoad,
FileInfo PackFileInfo
);

See Also

CGI35SP4PackLoaderBase Class | Aptify.Framework.BusinessLogic.Packers Namespace | CGI35SP4PackLoaderBase.LoadPack Overload List


CGI35SP4PackLoaderBase.LoadPack Method (AptifyApplication, String, FileInfo)

Populates a Current Version's GE structure with a 3.5 pack file.

protected virtual AptifyGenericEntityBase LoadPack(
AptifyApplication ApplicationObject,
String EntityName,
FileInfo PackFileInfo
);

Parameters

ApplicationObject
EntityName
PackFileInfo

Return Value

Remarks

calls the preload, loadpack, and postload methods in that order.

See Also

CGI35SP4PackLoaderBase Class | Aptify.Framework.BusinessLogic.Packers Namespace | CGI35SP4PackLoaderBase.LoadPack Overload List


CGI35SP4PackLoaderBase.PostLoad Method

After the ge has been loaded with the pack this can be called to do any clean up.

protected abstract void PostLoad(
AptifyApplication ApplicationObject,
ref AptifyGenericEntityBase& LoadedGE,
FileInfo PackFileInfo
);

Parameters

ApplicationObject
LoadedGE
PackFileInfo

Remarks

See Also

CGI35SP4PackLoaderBase Class | Aptify.Framework.BusinessLogic.Packers Namespace


CGI35SP4PackLoaderBase.PreLoad Method

This method should take a GE that has been created to reflect the current schema of a GE Object and then populate any missing defaults.

protected abstract void PreLoad(
AptifyApplication ApplicationObject,
ref AptifyGenericEntityBase& GEToLoad,
FileInfo PackFileInfo
);

Parameters

ApplicationObject
GEToLoad
Returns a GE object such that the schema that did not exist in 3.5 has been populated with the Target Versions Defaults.
PackFileInfo

Remarks

See Also

CGI35SP4PackLoaderBase Class | Aptify.Framework.BusinessLogic.Packers Namespace


DBObjectsPackLoader35SP4To40Beta3 Class

For a list of all members of this type, see DBObjectsPackLoader35SP4To40Beta3 Members.

System.Object
CGI35SP4PackLoaderBase
DBObjectsPackLoader35SP4To40Beta3

public class DBObjectsPackLoader35SP4To40Beta3 : CGI35SP4PackLoaderBase, IPackLoader

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.Packers

Assembly: AptifyPackTranslation (in AptifyPackTranslation.dll)

See Also

DBObjectsPackLoader35SP4To40Beta3 Members | Aptify.Framework.BusinessLogic.Packers Namespace


DBObjectsPackLoader35SP4To40Beta3 Members

DBObjectsPackLoader35SP4To40Beta3 overview

Public Instance Constructors

DBObjectsPackLoader35SP4To40Beta3 Constructor Initializes a new instance of the DBObjectsPackLoader35SP4To40Beta3 class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
LoadPack | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
LoadPack | Overloaded.
LoadPack (inherited from CGI35SP4PackLoaderBase) | Overloaded. Populates a Current Version's GE structure with a 3.5 pack file.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PostLoad |
PreLoad |

See Also

DBObjectsPackLoader35SP4To40Beta3 Class | Aptify.Framework.BusinessLogic.Packers Namespace


DBObjectsPackLoader35SP4To40Beta3 Constructor

Initializes a new instance of the DBObjectsPackLoader35SP4To40Beta3 class.

public DBObjectsPackLoader35SP4To40Beta3();

See Also

DBObjectsPackLoader35SP4To40Beta3 Class | Aptify.Framework.BusinessLogic.Packers Namespace


DBObjectsPackLoader35SP4To40Beta3 Methods

The methods of the DBObjectsPackLoader35SP4To40Beta3 class are listed below. For a complete list of DBObjectsPackLoader35SP4To40Beta3 class members, see the DBObjectsPackLoader35SP4To40Beta3 Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
LoadPack | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
LoadPack | Overloaded.
LoadPack (inherited from CGI35SP4PackLoaderBase) | Overloaded. Populates a Current Version's GE structure with a 3.5 pack file.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PostLoad |
PreLoad |

See Also

DBObjectsPackLoader35SP4To40Beta3 Class | Aptify.Framework.BusinessLogic.Packers Namespace


LoadPack Method

Aptify 5.0 Software Development Kit (SDK)

DBObjectsPackLoader35SP4To40Beta3.LoadPack Method

Overload List

protected override void LoadPack(AptifyApplication,AptifyGenericEntityBase,FileInfo);

public AptifyGenericEntityBase LoadPack(AptifyApplication,FileInfo);

Inherited from CGI35SP4PackLoaderBase.

protected virtual AptifyGenericEntityBase LoadPack(AptifyApplication,String,FileInfo);

See Also

DBObjectsPackLoader35SP4To40Beta3 Class | Aptify.Framework.BusinessLogic.Packers Namespace


DBObjectsPackLoader35SP4To40Beta3.LoadPack Method (AptifyApplication, AptifyGenericEntityBase, FileInfo)

protected override void LoadPack(
AptifyApplication ApplicationObject,
AptifyGenericEntityBase GEToLoad,
FileInfo PackFileInfo
);

See Also

DBObjectsPackLoader35SP4To40Beta3 Class | Aptify.Framework.BusinessLogic.Packers Namespace | DBObjectsPackLoader35SP4To40Beta3.LoadPack Overload List


DBObjectsPackLoader35SP4To40Beta3.LoadPack Method (AptifyApplication, FileInfo)

public AptifyGenericEntityBase LoadPack(
AptifyApplication ApplicationObject,
FileInfo PackFileInfo
);

Implements

IPackLoader.

See Also

DBObjectsPackLoader35SP4To40Beta3 Class | Aptify.Framework.BusinessLogic.Packers Namespace | DBObjectsPackLoader35SP4To40Beta3.LoadPack Overload List


DBObjectsPackLoader35SP4To40Beta3.PostLoad Method

protected override void PostLoad(
AptifyApplication ApplicationObject,
ref AptifyGenericEntityBase& LoadedGE,
FileInfo PackFileInfo
);

See Also

DBObjectsPackLoader35SP4To40Beta3 Class | Aptify.Framework.BusinessLogic.Packers Namespace


DBObjectsPackLoader35SP4To40Beta3.PreLoad Method

protected override void PreLoad(
AptifyApplication ApplicationObject,
ref AptifyGenericEntityBase& GEToLoad,
FileInfo PackFileInfo
);

See Also

DBObjectsPackLoader35SP4To40Beta3 Class | Aptify.Framework.BusinessLogic.Packers Namespace


EntityPackLoader35SP4To40Beta3 Class

Loads Entities packed in CGI 3.5 sp4 into a 4.0 Beta 3 Generic entity.

For a list of all members of this type, see EntityPackLoader35SP4To40Beta3 Members.

System.Object
CGI35SP4PackLoaderBase
EntityPackLoader35SP4To40Beta3

public class EntityPackLoader35SP4To40Beta3 : CGI35SP4PackLoaderBase, IPackLoader

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.Packers

Assembly: AptifyPackTranslation (in AptifyPackTranslation.dll)

See Also

EntityPackLoader35SP4To40Beta3 Members | Aptify.Framework.BusinessLogic.Packers Namespace


EntityPackLoader35SP4To40Beta3 Members

EntityPackLoader35SP4To40Beta3 overview

Public Instance Constructors

EntityPackLoader35SP4To40Beta3 Constructor Initializes a new instance of the EntityPackLoader35SP4To40Beta3 class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
LoadPack | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
LoadPack | Overloaded.
LoadPack (inherited from CGI35SP4PackLoaderBase) | Overloaded. Populates a Current Version's GE structure with a 3.5 pack file.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PostLoad |
PreLoad |

See Also

EntityPackLoader35SP4To40Beta3 Class | Aptify.Framework.BusinessLogic.Packers Namespace


EntityPackLoader35SP4To40Beta3 Constructor

Initializes a new instance of the EntityPackLoader35SP4To40Beta3 class.

public EntityPackLoader35SP4To40Beta3();

See Also

EntityPackLoader35SP4To40Beta3 Class | Aptify.Framework.BusinessLogic.Packers Namespace


EntityPackLoader35SP4To40Beta3 Methods

The methods of the EntityPackLoader35SP4To40Beta3 class are listed below. For a complete list of EntityPackLoader35SP4To40Beta3 class members, see the EntityPackLoader35SP4To40Beta3 Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
LoadPack | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
LoadPack | Overloaded.
LoadPack (inherited from CGI35SP4PackLoaderBase) | Overloaded. Populates a Current Version's GE structure with a 3.5 pack file.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PostLoad |
PreLoad |

See Also

EntityPackLoader35SP4To40Beta3 Class | Aptify.Framework.BusinessLogic.Packers Namespace


LoadPack Method

Aptify 5.0 Software Development Kit (SDK)

EntityPackLoader35SP4To40Beta3.LoadPack Method

Overload List

protected override void LoadPack(AptifyApplication,AptifyGenericEntityBase,FileInfo);

public AptifyGenericEntityBase LoadPack(AptifyApplication,FileInfo);

Inherited from CGI35SP4PackLoaderBase.

protected virtual AptifyGenericEntityBase LoadPack(AptifyApplication,String,FileInfo);

See Also

EntityPackLoader35SP4To40Beta3 Class | Aptify.Framework.BusinessLogic.Packers Namespace


EntityPackLoader35SP4To40Beta3.LoadPack Method (AptifyApplication, AptifyGenericEntityBase, FileInfo)

protected override void LoadPack(
AptifyApplication ApplicationObject,
AptifyGenericEntityBase GEToLoad,
FileInfo PackFileInfo
);

See Also

EntityPackLoader35SP4To40Beta3 Class | Aptify.Framework.BusinessLogic.Packers Namespace | EntityPackLoader35SP4To40Beta3.LoadPack Overload List


EntityPackLoader35SP4To40Beta3.LoadPack Method (AptifyApplication, FileInfo)

public AptifyGenericEntityBase LoadPack(
AptifyApplication ApplicationObject,
FileInfo PackFileInfo
);

Implements

IPackLoader.

See Also

EntityPackLoader35SP4To40Beta3 Class | Aptify.Framework.BusinessLogic.Packers Namespace | EntityPackLoader35SP4To40Beta3.LoadPack Overload List


EntityPackLoader35SP4To40Beta3.PostLoad Method

protected override void PostLoad(
AptifyApplication ApplicationObject,
ref AptifyGenericEntityBase& LoadedGE,
FileInfo PackFileInfo
);

See Also

EntityPackLoader35SP4To40Beta3 Class | Aptify.Framework.BusinessLogic.Packers Namespace


EntityPackLoader35SP4To40Beta3.PreLoad Method

protected override void PreLoad(
AptifyApplication ApplicationObject,
ref AptifyGenericEntityBase& GEToLoad,
FileInfo PackFileInfo
);

See Also

EntityPackLoader35SP4To40Beta3 Class | Aptify.Framework.BusinessLogic.Packers Namespace


EntityPackLoader40To40 Class

Loads Generic Entity Objects packed in the current version into a Generic Entity for the current version.

For a list of all members of this type, see EntityPackLoader40To40 Members.

System.Object
EntityPackLoader40To40

public class EntityPackLoader40To40 : IPackLoader

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

This will be used by default for the current version. If a user specifies a specific pack loader for the entity, the current version as source, and the current version as target in the Application Configuration File, then that loader will be used.

Requirements

Namespace: Aptify.Framework.BusinessLogic.Packers

Assembly: AptifyPackTranslation (in AptifyPackTranslation.dll)

See Also

EntityPackLoader40To40 Members | Aptify.Framework.BusinessLogic.Packers Namespace


EntityPackLoader40To40 Members

EntityPackLoader40To40 overview

Public Instance Constructors

EntityPackLoader40To40 Constructor Initializes a new instance of the EntityPackLoader40To40 class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
LoadPack |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EntityPackLoader40To40 Class | Aptify.Framework.BusinessLogic.Packers Namespace


EntityPackLoader40To40 Constructor

Initializes a new instance of the EntityPackLoader40To40 class.

public EntityPackLoader40To40();

See Also

EntityPackLoader40To40 Class | Aptify.Framework.BusinessLogic.Packers Namespace


EntityPackLoader40To40 Methods

The methods of the EntityPackLoader40To40 class are listed below. For a complete list of EntityPackLoader40To40 class members, see the EntityPackLoader40To40 Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
LoadPack |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EntityPackLoader40To40 Class | Aptify.Framework.BusinessLogic.Packers Namespace


EntityPackLoader40To40.LoadPack Method

public virtual AptifyGenericEntityBase LoadPack(
AptifyApplication ApplicationObject,
FileInfo PackFileInfo
);

Implements

IPackLoader.

See Also

EntityPackLoader40To40 Class | Aptify.Framework.BusinessLogic.Packers Namespace


IPackLoader Interface

The pack loader is responsible for loading a packfile from a specific version of aptify software.

For a list of all members of this type, see IPackLoader Members.

public interface IPackLoader

Types that implement IPackLoader

Type | Description
DBObjectsPackLoader35SP4To40Beta3 |
EntityPackLoader35SP4To40Beta3 | Loads Entities packed in CGI 3.5 sp4 into a 4.0 Beta 3 Generic entity.
EntityPackLoader40To40 | Loads Generic Entity Objects packed in the current version into a Generic Entity for the current version.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.Packers

Assembly: AptifyPackTranslation (in AptifyPackTranslation.dll)

See Also

IPackLoader Members | Aptify.Framework.BusinessLogic.Packers Namespace


IPackLoader Members

IPackLoader overview

Public Instance Methods

LoadPack Loads the file at the specified location and returns a valid Generic Entity Object.

See Also

IPackLoader Interface | Aptify.Framework.BusinessLogic.Packers Namespace


IPackLoader Methods

The methods of the IPackLoader interface are listed below. For a complete list of IPackLoader interface members, see the IPackLoader Members topic.

Public Instance Methods

LoadPack Loads the file at the specified location and returns a valid Generic Entity Object.

See Also

IPackLoader Interface | Aptify.Framework.BusinessLogic.Packers Namespace


IPackLoader.LoadPack Method

Loads the file at the specified location and returns a valid Generic Entity Object.

AptifyGenericEntityBase LoadPack(
AptifyApplication ApplicationObject,
FileInfo PackFileInfo
);

Parameters

ApplicationObject
PackFileInfo

Return Value

Remarks

We do not require EntityName as a property, because we expect the Pack Loader to know what Entity it is loading.

See Also

IPackLoader Interface | Aptify.Framework.BusinessLogic.Packers Namespace


PackLoadersEntity Class

Holds the needed information to represent a Pack Loader

For a list of all members of this type, see PackLoadersEntity Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
PackLoadersEntity

public class PackLoadersEntity : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.Packers

Assembly: AptifyPackTranslation (in AptifyPackTranslation.dll)

See Also

PackLoadersEntity Members | Aptify.Framework.BusinessLogic.Packers Namespace


PackLoadersEntity Members

PackLoadersEntity overview

Public Instance Constructors

PackLoadersEntity Constructor Initializes a new instance of the PackLoadersEntity class.

Public Instance Properties

Active |
Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
AssemblyName |
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ClassName |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EntityToLoadFor |
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
FileExtension |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LinkedDataDirectory |
MapFile |
ObjectName |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SortOrder |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
TargetVersion |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
PackLoader | Returns a PackLoader that is identified by the properties of the PackLoaderInformation.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

PackLoadersEntity Class | Aptify.Framework.BusinessLogic.Packers Namespace


PackLoadersEntity Constructor

Initializes a new instance of the PackLoadersEntity class.

public PackLoadersEntity();

See Also

PackLoadersEntity Class | Aptify.Framework.BusinessLogic.Packers Namespace


PackLoadersEntity Properties

The properties of the PackLoadersEntity class are listed below. For a complete list of PackLoadersEntity class members, see the PackLoadersEntity Members topic.

Public Instance Properties

Active |
Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
AssemblyName |
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ClassName |
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EntityToLoadFor |
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
FileExtension |
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
LinkedDataDirectory |
MapFile |
ObjectName |
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SortOrder |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
TargetVersion |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

PackLoadersEntity Class | Aptify.Framework.BusinessLogic.Packers Namespace


Active Property

Aptify 5.0 Software Development Kit (SDK)

PackLoadersEntity.Active Property

public Boolean Active {get; set;}

See Also

PackLoadersEntity Class | Aptify.Framework.BusinessLogic.Packers Namespace


AssemblyName Property

Aptify 5.0 Software Development Kit (SDK)

PackLoadersEntity.AssemblyName Property

public String AssemblyName {get; set;}

See Also

PackLoadersEntity Class | Aptify.Framework.BusinessLogic.Packers Namespace


ClassName Property

Aptify 5.0 Software Development Kit (SDK)

PackLoadersEntity.ClassName Property

public String ClassName {get; set;}

See Also

PackLoadersEntity Class | Aptify.Framework.BusinessLogic.Packers Namespace


EntityToLoadFor Property

Aptify 5.0 Software Development Kit (SDK)

PackLoadersEntity.EntityToLoadFor Property

public String EntityToLoadFor {get; set;}

See Also

PackLoadersEntity Class | Aptify.Framework.BusinessLogic.Packers Namespace


FileExtension Property

Aptify 5.0 Software Development Kit (SDK)

PackLoadersEntity.FileExtension Property

public String FileExtension {get; set;}

See Also

PackLoadersEntity Class | Aptify.Framework.BusinessLogic.Packers Namespace


LinkedDataDirectory Property

Aptify 5.0 Software Development Kit (SDK)

PackLoadersEntity.LinkedDataDirectory Property

public String LinkedDataDirectory {get; set;}

See Also

PackLoadersEntity Class | Aptify.Framework.BusinessLogic.Packers Namespace


MapFile Property

Aptify 5.0 Software Development Kit (SDK)

PackLoadersEntity.MapFile Property

public String MapFile {get; set;}

See Also

PackLoadersEntity Class | Aptify.Framework.BusinessLogic.Packers Namespace


ObjectName Property

Aptify 5.0 Software Development Kit (SDK)

PackLoadersEntity.ObjectName Property

public String ObjectName {get; set;}

See Also

PackLoadersEntity Class | Aptify.Framework.BusinessLogic.Packers Namespace


SortOrder Property

Aptify 5.0 Software Development Kit (SDK)

PackLoadersEntity.SortOrder Property

public Int32 SortOrder {get; set;}

See Also

PackLoadersEntity Class | Aptify.Framework.BusinessLogic.Packers Namespace


TargetVersion Property

Aptify 5.0 Software Development Kit (SDK)

PackLoadersEntity.TargetVersion Property

public String TargetVersion {get; set;}

See Also

PackLoadersEntity Class | Aptify.Framework.BusinessLogic.Packers Namespace


PackLoadersEntity Methods

The methods of the PackLoadersEntity class are listed below. For a complete list of PackLoadersEntity class members, see the PackLoadersEntity Members topic.

Public Instance Methods

BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
PackLoader | Returns a PackLoader that is identified by the properties of the PackLoaderInformation.
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save (inherited from AptifyGenericEntity) | Overloaded. Saves the GE Data.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

PackLoadersEntity Class | Aptify.Framework.BusinessLogic.Packers Namespace


PackLoadersEntity.PackLoader Method

Returns a PackLoader that is identified by the properties of the PackLoaderInformation.

public IPackLoader PackLoader();

Remarks

See Also

PackLoadersEntity Class | Aptify.Framework.BusinessLogic.Packers Namespace


TranslationException Class

Thrown if there is a problem while trying to translate a pack from one version to another.

For a list of all members of this type, see TranslationException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
TranslationException

public class TranslationException : BaseApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.Packers

Assembly: AptifyPackTranslation (in AptifyPackTranslation.dll)

See Also

TranslationException Members | Aptify.Framework.BusinessLogic.Packers Namespace


TranslationException Members

TranslationException overview

Public Instance Constructors

TranslationException Overloaded. Initializes a new instance of the TranslationException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from BaseApplicationException) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TranslationException Class | Aptify.Framework.BusinessLogic.Packers Namespace


TranslationException Constructor

Initializes a new instance of the TranslationException class.

Overload List

Initializes a new instance of the TranslationException class.

public TranslationException();

public TranslationException(String);

public TranslationException(String,Exception);

See Also

TranslationException Class | Aptify.Framework.BusinessLogic.Packers Namespace


TranslationException Constructor ()

Initializes a new instance of the TranslationException class.

public TranslationException();

See Also

TranslationException Class | Aptify.Framework.BusinessLogic.Packers Namespace | TranslationException Constructor Overload List


TranslationException Constructor (String)

public TranslationException(
String Message
);

See Also

TranslationException Class | Aptify.Framework.BusinessLogic.Packers Namespace | TranslationException Constructor Overload List


TranslationException Constructor (String, Exception)

public TranslationException(
String Message,
Exception Innerexception
);

See Also

TranslationException Class | Aptify.Framework.BusinessLogic.Packers Namespace | TranslationException Constructor Overload List


TranslationManager Class

Encapsulates functionality that is responsible for translating Pack Files.

For a list of all members of this type, see TranslationManager Members.

System.Object
TranslationManager

public class TranslationManager

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.Packers

Assembly: AptifyPackTranslation (in AptifyPackTranslation.dll)

See Also

TranslationManager Members | Aptify.Framework.BusinessLogic.Packers Namespace


TranslationManager Members

TranslationManager overview

Public Static Methods

GetEntityName |
GetFileExtension | Overloaded. Loops through all of the pack loaders in the system and looks for files that have a matching extension
GetMapFile | Searches for possible map files and returns the first match.
LoadGenericEntity | Accepts Information about a Pack File and returns a Valid AptifyGenericEntity
SetApplicationObject |

Public Instance Constructors

TranslationManager Constructor Initializes a new instance of the TranslationManager class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TranslationManager Class | Aptify.Framework.BusinessLogic.Packers Namespace


TranslationManager Constructor

Initializes a new instance of the TranslationManager class.

public TranslationManager();

See Also

TranslationManager Class | Aptify.Framework.BusinessLogic.Packers Namespace


TranslationManager Methods

The methods of the TranslationManager class are listed below. For a complete list of TranslationManager class members, see the TranslationManager Members topic.

Public Static Methods

GetEntityName |
GetFileExtension | Overloaded. Loops through all of the pack loaders in the system and looks for files that have a matching extension
GetMapFile | Searches for possible map files and returns the first match.
LoadGenericEntity | Accepts Information about a Pack File and returns a Valid AptifyGenericEntity
SetApplicationObject |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TranslationManager Class | Aptify.Framework.BusinessLogic.Packers Namespace


TranslationManager.GetEntityName Method

public static string GetEntityName(
XmlDocument XMLDoc
);

See Also

TranslationManager Class | Aptify.Framework.BusinessLogic.Packers Namespace


GetFileExtension Method

Aptify 5.0 Software Development Kit (SDK)

TranslationManager.GetFileExtension Method

Loops through all of the pack loaders in the system and looks for files that have a matching extension

Overload List

Loops through all of the pack loaders in the system and looks for files that have a matching extension

public static string GetFileExtension(DirectoryInfo);

uses the provided ge to find an extension.

public static string GetFileExtension(DirectoryInfo,AptifyGenericEntityBase);

See Also

TranslationManager Class | Aptify.Framework.BusinessLogic.Packers Namespace


TranslationManager.GetFileExtension Method (DirectoryInfo)

Loops through all of the pack loaders in the system and looks for files that have a matching extension

public static string GetFileExtension(
DirectoryInfo WorkingDirectory
);

Return Value

String.Empty if no matching extension is found or the Working directory is Empty.

Remarks

An extension including the dot if an extension is found.

See Also

TranslationManager Class | Aptify.Framework.BusinessLogic.Packers Namespace | TranslationManager.GetFileExtension Overload List


TranslationManager.GetFileExtension Method (DirectoryInfo, AptifyGenericEntityBase)

uses the provided ge to find an extension.

public static string GetFileExtension(
DirectoryInfo WorkingDirectory,
AptifyGenericEntityBase LoadedGE
);

Parameters

WorkingDirectory
LoadedGE

Return Value

Remarks

if no extension is found then it attempts to locate one by exhaustion.

See Also

TranslationManager Class | Aptify.Framework.BusinessLogic.Packers Namespace | TranslationManager.GetFileExtension Overload List


TranslationManager.GetMapFile Method

Searches for possible map files and returns the first match.

public static string GetMapFile(
DirectoryInfo WorkingDirectory
);

Parameters

WorkingDirectory

Return Value

Returns String.Empty if no match is found.

Remarks

See Also

TranslationManager Class | Aptify.Framework.BusinessLogic.Packers Namespace


TranslationManager.LoadGenericEntity Method

Accepts Information about a Pack File and returns a Valid AptifyGenericEntity

public static AptifyGenericEntityBase LoadGenericEntity(
AptifyApplication ApplicationObject,
FileInfo FileInfo
);

Parameters

ApplicationObject
FileInfo
Information describing the location of the Pack File that should be loaded.

Return Value

Remarks

See Also

TranslationManager Class | Aptify.Framework.BusinessLogic.Packers Namespace


TranslationManager.SetApplicationObject Method

public static void SetApplicationObject(
AptifyApplication ApplicationObject
);

See Also

TranslationManager Class | Aptify.Framework.BusinessLogic.Packers Namespace


Aptify.Framework.BusinessLogic.PendingChanges

Aptify 5.0 Software Development Kit (SDK)

Aptify.Framework.BusinessLogic.PendingChanges Namespace

The objects in this namespace correspond to Aptify's Pending Changes functionality for use with replication conflicts and scheduled changes that should occur at a future date.

Namespace hierarchy

Classes

Class | Description
PendingChangeBase |
PendingChangeCompareControl |
PendingChangesConsole |
PendingChangesEntity | The PendingChangesEntity object is designed to provide functionality for pending change records. The following features are implemented: - Verifies approval permissions for pending changes requiring approvals. - Verifies conflict resolution/application permssions for conflict permissions. - Applies pending changes, using the pending changes data subtype
PendingChangesViewer |
PendingChangeType |
PendingChangeUpdate | Process Component for updating Pending Changes records.
PostAvailablePendingChangeBatchPC |
PostSinglePendingChangePC |

Delegates

Delegate | Description
PendingChangesEntity.AfterPendingChangeApprovedEventHandler |
PendingChangesEntity.AfterPendingChangeDeferredEventHandler |
PendingChangesEntity.AfterPendingChangePostedEventHandler |
PendingChangesEntity.AfterPendingChangeRejectedEventHandler |
PendingChangesEntity.BeforePendingChangeApprovedEventHandler |
PendingChangesEntity.BeforePendingChangeDeferredEventHandler |
PendingChangesEntity.BeforePendingChangePostedEventHandler |
PendingChangesEntity.BeforePendingChangeRejectedEventHandler |

Enumerations

Enumeration | Description
PendingChangesEntity.PendingChangeType |


PendingChangeBase Class

For a list of all members of this type, see PendingChangeBase Members.

System.Object
PendingChangeBase
PendingChangeUpdate

public class PendingChangeBase : IProcessComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.PendingChanges

Assembly: PendingChangeComponent (in PendingChangeComponent.dll)

See Also

PendingChangeBase Members | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangeBase Members

PendingChangeBase overview

Public Instance Constructors

PendingChangeBase Constructor Initializes a new instance of the PendingChangeBase class.

Public Instance Properties

DataAction |
ProcessComponentID | Returns the Process Component ID in use for the current instance of the class.
Properties | Aptify Properties Collection used for Input and Output Properties for the component.

Public Instance Methods

Config | This method must be called before any other member of this class is accessed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

Application | Aptify Application Object.
InitData | This method returns the InitData string for processing as required by ParseInitData() or other methods.
InitDataItems | This member will return a dictionary of init data items (string values) that are keyed based on their attribute name. For example, for the Init Data string that contains a single XML node of Entity with a value of "Demo Entity", this dictionary will have one entry with a value of "Demo Entity" keyed as "Entity".
InitDataXMLDoc | This member returns an instance of the System.Xml.XmlDocument class that is instantiated and loaded with the InitData from the Form Component record for this instance of the component. This method is used by ParseInitData and other internal members of the base class in order to access initialization attributes from the Form Component record. Utilize this method to access the XML attributes of the InitData string.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ParseInitData | This method is called when necessary by the component internally to access "Init Data", which is the InitData field in the Process Component record. This information is necessary to determine the name of the entity and other properties that can vary from one Process Component meta-data record to another. Since the Entity CRUD components are generic in nature, they have no inherent knowledge of which entity they are bound to at a given time. That is the key to what Process Component InitData strings tell the components - the Entity Name, among other attributes. In sub-classes, this method can be overriden to access the underlying InitData string directly to access other attributes from the string in addition to the Entity Name which is the single attribute extracted by the base class implementation of this method.
UpdatePendingRecord |

See Also

PendingChangeBase Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangeBase Constructor

Initializes a new instance of the PendingChangeBase class.

public PendingChangeBase();

See Also

PendingChangeBase Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangeBase Properties

The properties of the PendingChangeBase class are listed below. For a complete list of PendingChangeBase class members, see the PendingChangeBase Members topic.

Public Instance Properties

DataAction |
ProcessComponentID | Returns the Process Component ID in use for the current instance of the class.
Properties | Aptify Properties Collection used for Input and Output Properties for the component.

Protected Instance Properties

Application | Aptify Application Object.
InitData | This method returns the InitData string for processing as required by ParseInitData() or other methods.
InitDataItems | This member will return a dictionary of init data items (string values) that are keyed based on their attribute name. For example, for the Init Data string that contains a single XML node of Entity with a value of "Demo Entity", this dictionary will have one entry with a value of "Demo Entity" keyed as "Entity".
InitDataXMLDoc | This member returns an instance of the System.Xml.XmlDocument class that is instantiated and loaded with the InitData from the Form Component record for this instance of the component. This method is used by ParseInitData and other internal members of the base class in order to access initialization attributes from the Form Component record. Utilize this method to access the XML attributes of the InitData string.

See Also

PendingChangeBase Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


Application Property

Aptify 5.0 Software Development Kit (SDK)

PendingChangeBase.Application Property

Aptify Application Object.

protected virtual AptifyApplication Application {get;}

Property Value

Remarks

See Also

PendingChangeBase Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


DataAction Property

Aptify 5.0 Software Development Kit (SDK)

PendingChangeBase.DataAction Property

public virtual DataAction DataAction {get;}

See Also

PendingChangeBase Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


InitData Property

Aptify 5.0 Software Development Kit (SDK)

PendingChangeBase.InitData Property

This method returns the InitData string for processing as required by ParseInitData() or other methods.

protected virtual String InitData {get;}

Property Value

Remarks

See Also

PendingChangeBase Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


InitDataItems Property

Aptify 5.0 Software Development Kit (SDK)

PendingChangeBase.InitDataItems Property

This member will return a dictionary of init data items (string values) that are keyed based on their attribute name. For example, for the Init Data string that contains a single XML node of Entity with a value of "Demo Entity", this dictionary will have one entry with a value of "Demo Entity" keyed as "Entity".

protected virtual Dictionary<TKey,TValue> InitDataItems {get;}

Property Value

Remarks

Important Note: ALL KEYS/ATTRIBUTE NAMES ARE LOWER CASE, make sure you use lower case in doing key lookups for attributes in the dictionary

See Also

PendingChangeBase Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


InitDataXMLDoc Property

Aptify 5.0 Software Development Kit (SDK)

PendingChangeBase.InitDataXMLDoc Property

This member returns an instance of the System.Xml.XmlDocument class that is instantiated and loaded with the InitData from the Form Component record for this instance of the component. This method is used by ParseInitData and other internal members of the base class in order to access initialization attributes from the Form Component record. Utilize this method to access the XML attributes of the InitData string.

protected virtual XmlDocument InitDataXMLDoc {get;}

Property Value

Remarks

Changes made to the XML Document returned will NOT have any persistent effect, the instance of the XML Document returned is not reused or linked to other internal component attributes.

See Also

PendingChangeBase Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


ProcessComponentID Property

Aptify 5.0 Software Development Kit (SDK)

PendingChangeBase.ProcessComponentID Property

Returns the Process Component ID in use for the current instance of the class.

public virtual Int64 ProcessComponentID {get;}

Property Value

Remarks

See Also

PendingChangeBase Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


Properties Property

Aptify 5.0 Software Development Kit (SDK)

PendingChangeBase.Properties Property

Aptify Properties Collection used for Input and Output Properties for the component.

public AptifyProperties Properties {get;}

Property Value

Implements

IProcessComponent.

Remarks

See Also

PendingChangeBase Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangeBase Methods

The methods of the PendingChangeBase class are listed below. For a complete list of PendingChangeBase class members, see the PendingChangeBase Members topic.

Public Instance Methods

Config | This method must be called before any other member of this class is accessed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ParseInitData | This method is called when necessary by the component internally to access "Init Data", which is the InitData field in the Process Component record. This information is necessary to determine the name of the entity and other properties that can vary from one Process Component meta-data record to another. Since the Entity CRUD components are generic in nature, they have no inherent knowledge of which entity they are bound to at a given time. That is the key to what Process Component InitData strings tell the components - the Entity Name, among other attributes. In sub-classes, this method can be overriden to access the underlying InitData string directly to access other attributes from the string in addition to the Entity Name which is the single attribute extracted by the base class implementation of this method.
UpdatePendingRecord |

See Also

PendingChangeBase Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangeBase.Config Method

This method must be called before any other member of this class is accessed.

public void Config(
AptifyApplication ApplicationObject
);

Parameters

ApplicationObject

Implements

IProcessComponent.

Remarks

See Also

PendingChangeBase Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangeBase.ParseInitData Method

This method is called when necessary by the component internally to access "Init Data", which is the InitData field in the Process Component record. This information is necessary to determine the name of the entity and other properties that can vary from one Process Component meta-data record to another. Since the Entity CRUD components are generic in nature, they have no inherent knowledge of which entity they are bound to at a given time. That is the key to what Process Component InitData strings tell the components - the Entity Name, among other attributes. In sub-classes, this method can be overriden to access the underlying InitData string directly to access other attributes from the string in addition to the Entity Name which is the single attribute extracted by the base class implementation of this method.

protected virtual void ParseInitData();

Remarks

See Also

PendingChangeBase Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangeBase.Run Method

public abstract string Run();

Implements

IProcessComponent.

See Also

PendingChangeBase Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangeBase.UpdatePendingRecord Method

protected virtual void UpdatePendingRecord(
Int64 RecordID
);

See Also

PendingChangeBase Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangeCompareControl Class

For a list of all members of this type, see PendingChangeCompareControl Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
PendingChangeCompareControl

public class PendingChangeCompareControl : UserControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.PendingChanges

Assembly: AptifyPendingChangesUI (in AptifyPendingChangesUI.dll)

See Also

PendingChangeCompareControl Members | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangeCompareControl Members

PendingChangeCompareControl overview

Public Instance Constructors

PendingChangeCompareControl Constructor Initializes a new instance of the PendingChangeCompareControl class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Configure |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LoadData |
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

PendingChangeCompareControl Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangeCompareControl Constructor

Initializes a new instance of the PendingChangeCompareControl class.

public PendingChangeCompareControl();

See Also

PendingChangeCompareControl Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangeCompareControl Methods

The methods of the PendingChangeCompareControl class are listed below. For a complete list of PendingChangeCompareControl class members, see the PendingChangeCompareControl Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Configure |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LoadData |
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

PendingChangeCompareControl Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangeCompareControl.Configure Method

public void Configure(
ref UserCredentials& UserCredentials
);

See Also

PendingChangeCompareControl Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

PendingChangeCompareControl.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

PendingChangeCompareControl Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangeCompareControl.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

PendingChangeCompareControl Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace | PendingChangeCompareControl.Dispose Overload List


PendingChangeCompareControl.LoadData Method

public void LoadData(
ref AptifyGenericEntityBase& PendingChangeGE
);

See Also

PendingChangeCompareControl Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangesConsole Class

For a list of all members of this type, see PendingChangesConsole Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
PendingChangesConsole

public class PendingChangesConsole : UserControl, IDashboardComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.PendingChanges

Assembly: AptifyPendingChangesUI (in AptifyPendingChangesUI.dll)

See Also

PendingChangesConsole Members | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangesConsole Members

PendingChangesConsole overview

Public Instance Constructors

PendingChangesConsole Constructor Initializes a new instance of the PendingChangesConsole class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Entity |
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
GroupableFieldList |
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ID |
IDColumnName |
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Log |
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Properties | Overloaded.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
State |
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RefreshData | Overloaded.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AddGroupingNodes | Overloaded.
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
DoApproveSelected |
DoCheckAll |
DoCheckGroup |
DoDeferSelected |
DoPostSelected |
DoRejectSelected |
DoShowDetail |
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetCheckedRecords |
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

PendingChangesConsole Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangesConsole Constructor

Initializes a new instance of the PendingChangesConsole class.

public PendingChangesConsole();

See Also

PendingChangesConsole Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangesConsole Properties

The properties of the PendingChangesConsole class are listed below. For a complete list of PendingChangesConsole class members, see the PendingChangesConsole Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Entity |
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
GroupableFieldList |
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ID |
IDColumnName |
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Log |
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Mode |
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Properties | Overloaded.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
State |
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

PendingChangesConsole Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


Entity Property

Aptify 5.0 Software Development Kit (SDK)

PendingChangesConsole.Entity Property

public String Entity {get; set;}

See Also

PendingChangesConsole Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


GroupableFieldList Property

Aptify 5.0 Software Development Kit (SDK)

PendingChangesConsole.GroupableFieldList Property

public ArrayList GroupableFieldList {get;}

See Also

PendingChangesConsole Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


ID Property

Aptify 5.0 Software Development Kit (SDK)

PendingChangesConsole.ID Property

public Int64 ID {get;}

Implements

IDashboardComponent.

See Also

PendingChangesConsole Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


IDColumnName Property

Aptify 5.0 Software Development Kit (SDK)

PendingChangesConsole.IDColumnName Property

public String IDColumnName {get; set;}

See Also

PendingChangesConsole Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


Log Property

Aptify 5.0 Software Development Kit (SDK)

PendingChangesConsole.Log Property

public virtual StringBuilder Log {get;}

See Also

PendingChangesConsole Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


Mode Property

Aptify 5.0 Software Development Kit (SDK)

PendingChangesConsole.Mode Property

public DashboardMode Mode {get; set;}

Implements

IDashboardComponent.

See Also

PendingChangesConsole Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


Properties Property

Aptify 5.0 Software Development Kit (SDK)

PendingChangesConsole.Properties Property

new public AptifyProperties Properties {get;}

Implements

IDashboardComponent.

See Also

PendingChangesConsole Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


State Property

Aptify 5.0 Software Development Kit (SDK)

PendingChangesConsole.State Property

public ComponentState State {get; set;}

Implements

IDashboardComponent.

See Also

PendingChangesConsole Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangesConsole Methods

The methods of the PendingChangesConsole class are listed below. For a complete list of PendingChangesConsole class members, see the PendingChangesConsole Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Config |
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RefreshData | Overloaded.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AddGroupingNodes | Overloaded.
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
DoApproveSelected |
DoCheckAll |
DoCheckGroup |
DoDeferSelected |
DoPostSelected |
DoRejectSelected |
DoShowDetail |
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetCheckedRecords |
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

PendingChangesConsole Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


AddGroupingNodes Method

Aptify 5.0 Software Development Kit (SDK)

PendingChangesConsole.AddGroupingNodes Method

Overload List

protected virtual void AddGroupingNodes(Int32);

protected virtual void AddGroupingNodes(Int32,String);

protected virtual void AddGroupingNodes(String);

protected virtual void AddGroupingNodes(String,String);

See Also

PendingChangesConsole Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangesConsole.AddGroupingNodes Method (Int32)

protected virtual void AddGroupingNodes(
Int32 iColIndex
);

See Also

PendingChangesConsole Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace | PendingChangesConsole.AddGroupingNodes Overload List


PendingChangesConsole.AddGroupingNodes Method (Int32, String)

protected virtual void AddGroupingNodes(
Int32 iColIndex,
String sHighlightValue
);

See Also

PendingChangesConsole Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace | PendingChangesConsole.AddGroupingNodes Overload List


PendingChangesConsole.AddGroupingNodes Method (String)

protected virtual void AddGroupingNodes(
String sColumn
);

See Also

PendingChangesConsole Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace | PendingChangesConsole.AddGroupingNodes Overload List


PendingChangesConsole.AddGroupingNodes Method (String, String)

protected virtual void AddGroupingNodes(
String sColumn,
String sHighlightValue
);

See Also

PendingChangesConsole Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace | PendingChangesConsole.AddGroupingNodes Overload List


PendingChangesConsole.Config Method

public void Config(
AptifyApplication ApplicationObject,
IDashboardArea Area,
Int64 PartID,
ComponentOrientation Orientation
);

Implements

IDashboardComponent.

See Also

PendingChangesConsole Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

PendingChangesConsole.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

PendingChangesConsole Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangesConsole.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

PendingChangesConsole Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace | PendingChangesConsole.Dispose Overload List


PendingChangesConsole.DoApproveSelected Method

protected virtual void DoApproveSelected();

See Also

PendingChangesConsole Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangesConsole.DoCheckAll Method

protected virtual void DoCheckAll(
Boolean bCheck
);

See Also

PendingChangesConsole Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangesConsole.DoCheckGroup Method

protected virtual void DoCheckGroup();

See Also

PendingChangesConsole Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangesConsole.DoDeferSelected Method

protected virtual void DoDeferSelected();

See Also

PendingChangesConsole Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangesConsole.DoPostSelected Method

protected virtual void DoPostSelected();

See Also

PendingChangesConsole Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangesConsole.DoRejectSelected Method

protected virtual void DoRejectSelected();

See Also

PendingChangesConsole Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangesConsole.DoShowDetail Method

protected virtual void DoShowDetail(
Int64 lRecID
);

See Also

PendingChangesConsole Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangesConsole.GetCheckedRecords Method

protected virtual long[] GetCheckedRecords();

See Also

PendingChangesConsole Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


RefreshData Method

Aptify 5.0 Software Development Kit (SDK)

PendingChangesConsole.RefreshData Method

Overload List

public virtual void RefreshData();

public virtual void RefreshData(Boolean);

public virtual void RefreshData(String);

public virtual void RefreshData(String,Boolean);

See Also

PendingChangesConsole Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangesConsole.RefreshData Method ()

public virtual void RefreshData();

See Also

PendingChangesConsole Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace | PendingChangesConsole.RefreshData Overload List


PendingChangesConsole.RefreshData Method (Boolean)

public virtual void RefreshData(
Boolean bUpdateGroups
);

See Also

PendingChangesConsole Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace | PendingChangesConsole.RefreshData Overload List


PendingChangesConsole.RefreshData Method (String)

public virtual void RefreshData(
String sSQL
);

See Also

PendingChangesConsole Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace | PendingChangesConsole.RefreshData Overload List


PendingChangesConsole.RefreshData Method (String, Boolean)

public virtual void RefreshData(
String sSQL,
Boolean bUpdateGroups
);

See Also

PendingChangesConsole Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace | PendingChangesConsole.RefreshData Overload List


PendingChangesEntity Class

The PendingChangesEntity object is designed to provide functionality for pending change records. The following features are implemented: - Verifies approval permissions for pending changes requiring approvals. - Verifies conflict resolution/application permssions for conflict permissions. - Applies pending changes, using the pending changes data subtype

For a list of all members of this type, see PendingChangesEntity Members.

System.Object
AptifyGenericEntityBase
AptifyGenericEntity
PendingChangesEntity

public class PendingChangesEntity : AptifyGenericEntity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.PendingChanges

Assembly: AptifyPendingChangesObject (in AptifyPendingChangesObject.dll)

See Also

PendingChangesEntity Members | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangesEntity Members

PendingChangesEntity overview

Public Instance Constructors

PendingChangesEntity Constructor Initializes a new instance of the PendingChangesEntity class.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError |
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PendingChangeTypes |
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
TypeIsConflict |
TypeIsScheduled |
TypeRequiresApproval |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCanApprove |
UserCanPost |
UserCanPostConflict |
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Public Instance Methods

ApprovePendingChange |
BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
DeferPendingChange |
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
PostPendingChange |
RejectPendingChange |
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterPendingChangeApproved |
AfterPendingChangeDeferred |
AfterPendingChangePosted |
AfterPendingChangeRejected |
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforePendingChangeApproved |
BeforePendingChangeDeferred |
BeforePendingChangePosted |
BeforePendingChangeRejected |
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

Protected Instance Fields

InEditMode (inherited from AptifyGenericEntity)
m_sTempRecordChangeString (inherited from AptifyGenericEntity)
m_sTempRecordChangeXML (inherited from AptifyGenericEntity)
ObjectDataForTransactionRollback (inherited from AptifyGenericEntity)

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
LoadPendingChangeTypes |
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSetApproved |
ValidateSetDeferred |
ValidateSetPending |
ValidateSetPosted |
ValidateSetRejected |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

PendingChangesEntity Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangesEntity Constructor

Initializes a new instance of the PendingChangesEntity class.

public PendingChangesEntity();

See Also

PendingChangesEntity Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangesEntity Properties

The properties of the PendingChangesEntity class are listed below. For a complete list of PendingChangesEntity class members, see the PendingChangesEntity Members topic.

Public Instance Properties

Application (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal application object so a new one does not need to be created.
BroadcastState (inherited from AptifyGenericEntity) | Allows a developer to set a Value for the BroadCast State of the loaded record.
CacheDirectory (inherited from AptifyGenericEntity) | Sets a directory that should be used when caching information for a GE Instance.
CacheUpToDate (inherited from AptifyGenericEntity) | Makes sure the CacheDirectory has up to date information for this GE Instance.
ContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
ContainerOwnsRecord (inherited from AptifyGenericEntityBase) |
CurrentTransactionCount (inherited from AptifyGenericEntityBase) | Returns the current transaction count. If there is no Current Transaction, a value of 0 will be returned. If a current transaction is open for the object, a value greater than or equal to 1 will be returned. For every BeginTransaction call, the current transaction count will be incremented by one. For each CommitTransaction call, the current transaction count will be decremented by 1. If the RollbackTransaction method is called, the current transaction count will be reset to 0.
CurrentTransactionID (inherited from AptifyGenericEntityBase) | Returns the current Transaction ID for this GE Instance.
DataAction (inherited from AptifyGenericEntity) | This property can be use to gain access to the internal DataAction object so a new one does not need to be created.
DefaultPreviewPaneTemplateID (inherited from AptifyGenericEntityBase) | This will return the value for field taht is defined as the Default Preview pane Template.
DisconnectedEmbeddedObjects (inherited from AptifyGenericEntity) |
DisplayRequiredFieldIndicator (inherited from AptifyGenericEntityBase) | Returns value of DisplayRequiredFieldIndicator field.
EmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) | This collection keeps track of embedded objects that require a record ID update from the owner GE Object so that the GE can automatically pass the newly created record ID, when needed to the sub-components. This method is exposed to allow both sub-classes and consumer components to manipulate the object model for custom handling, where required.
EntityDisplayName (inherited from AptifyGenericEntityBase) | The display name of the entity for the loaded record.
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityDisplayNameWCulture (inherited from AptifyGenericEntityBase) |
EntityID (inherited from AptifyGenericEntityBase) | The Record ID of the entity for the loaded record.
EntityName (inherited from AptifyGenericEntityBase) | The name of the entity for the loaded record.
EventsToFire (inherited from AptifyGenericEntityBase) | Used to configure the Events that will be fired by the Data Field object.
ExtenderObjects (inherited from AptifyGenericEntity) | Returns the extender objects for this GE, if any
Fields (inherited from AptifyGenericEntity) | Returns a collection of Datafields that are associated with the GE Record.
IsDirty (inherited from AptifyGenericEntityBase) | If any of the data fields or the subtype is dirty then the record is considered dirty.
LastError |
LastUserError (inherited from AptifyGenericEntityBase) | If an exception occurs during a GE Operation, then the message associated with that exception is available through this property.
ParentGE (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record then it will have a reference to the Parent GE Instance.
ParentSubType (inherited from AptifyGenericEntityBase) | If the GE is a sub-type record and its parent is a sub-type, then it will have a reference to the Parent GE Instance.
PendingChangeTypes |
PrimaryKey (inherited from AptifyGenericEntityBase) | Returns the Name and Parameter Name of the primary key field that is defined for the loaded entity.
RecordChangeString (inherited from AptifyGenericEntity) | Returns a string describing what changed in the record between the current version in memory and the "LAST" version.
RecordChangeXML (inherited from AptifyGenericEntityBase) | Returns an XML fragment describing the changes between the current version and the "LAST" version.
RecordID (inherited from AptifyGenericEntityBase) | Returns the Record ID for the currently loaded data record.
RecordName (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the Record Name.
RequiredFieldBackColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
RequiredFieldFontName (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontName field.
RequiredFieldFontSize (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontSize field.
RequiredFieldFontStyle (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldFontStyle field.
RequiredFieldTextColor (inherited from AptifyGenericEntityBase) | Returns value of RequiredFieldTextColor field.
SequenceField (inherited from AptifyGenericEntityBase) | Returns the Field Name and Parameter Name of the loaded entity's Sequence field. If one is defined.
SequenceValue (inherited from AptifyGenericEntityBase) | This will return the value of the field that is defined as the record sequence.
SharedObjectDataIsDirty (inherited from AptifyGenericEntityBase) |
SubTypeLevel (inherited from AptifyGenericEntityBase) | Sub-Types can be nested N-Levels deep. This will return the number of levels deep that it is actually nested.
SubTypes (inherited from AptifyGenericEntity) | Returns an AptifySubTypes instance that contains all of the AptifySubType instances that are associated with the loaded record.
SupportsDynamicSharing (inherited from AptifyGenericEntityBase) |
TypeIsConflict |
TypeIsScheduled |
TypeRequiresApproval |
UseCache (inherited from AptifyGenericEntity) | Allows a user to store whether or not Caching should be used for the loaded record.
UserCanApprove |
UserCanPost |
UserCanPostConflict |
UserCredentials (inherited from AptifyGenericEntityBase) | Allows a user to associate a set of user credentials in memory with a given record.

Protected Instance Properties

CreateSQL (inherited from AptifyGenericEntityBase) | Sets the name of only the CreateSQL stored procedure .
FieldLevelSecurity (inherited from AptifyGenericEntityBase) |
GetDupeObject (inherited from AptifyGenericEntity) |
GetVerifyObject (inherited from AptifyGenericEntity) |
IsLoaded (inherited from AptifyGenericEntityBase) |
IsNewRecord (inherited from AptifyGenericEntityBase) | Returns True if the current record is a new record(not yet saved to the database), false otherwise
IsSharedRecordLocked (inherited from AptifyGenericEntityBase) |
NewSubTypeRecordTempID (inherited from AptifyGenericEntityBase) | Generates a unique (within the transaction) ID that is used as a temporary ID for all new Sub-Type records under the top-level record.
RecordHistoryOmitObjectData (inherited from AptifyGenericEntity) |
RequireVersionComment (inherited from AptifyGenericEntityBase) |
SharedRecordHasNoOwner (inherited from AptifyGenericEntityBase) |
SubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
TrackRecordHistory (inherited from AptifyGenericEntityBase) |
UpdateSQL (inherited from AptifyGenericEntityBase) |

See Also

PendingChangesEntity Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


LastError Property

Aptify 5.0 Software Development Kit (SDK)

PendingChangesEntity.LastError Property

public override String LastError {get;}

See Also

PendingChangesEntity Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangeTypes Property

Aptify 5.0 Software Development Kit (SDK)

PendingChangesEntity.PendingChangeTypes Property

public Dictionary<TKey,TValue> PendingChangeTypes {get;}

See Also

PendingChangesEntity Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


TypeIsConflict Property

Aptify 5.0 Software Development Kit (SDK)

PendingChangesEntity.TypeIsConflict Property

public Boolean TypeIsConflict {get;}

See Also

PendingChangesEntity Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


TypeIsScheduled Property

Aptify 5.0 Software Development Kit (SDK)

PendingChangesEntity.TypeIsScheduled Property

public Boolean TypeIsScheduled {get;}

See Also

PendingChangesEntity Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


TypeRequiresApproval Property

Aptify 5.0 Software Development Kit (SDK)

PendingChangesEntity.TypeRequiresApproval Property

public Boolean TypeRequiresApproval {get;}

See Also

PendingChangesEntity Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


UserCanApprove Property

Aptify 5.0 Software Development Kit (SDK)

PendingChangesEntity.UserCanApprove Property

public Boolean UserCanApprove {get;}

See Also

PendingChangesEntity Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


UserCanPost Property

Aptify 5.0 Software Development Kit (SDK)

PendingChangesEntity.UserCanPost Property

public Boolean UserCanPost {get;}

See Also

PendingChangesEntity Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


UserCanPostConflict Property

Aptify 5.0 Software Development Kit (SDK)

PendingChangesEntity.UserCanPostConflict Property

public Boolean UserCanPostConflict {get;}

See Also

PendingChangesEntity Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangesEntity Methods

The methods of the PendingChangesEntity class are listed below. For a complete list of PendingChangesEntity class members, see the PendingChangesEntity Members topic.

Public Instance Methods

ApprovePendingChange |
BeginTransaction (inherited from AptifyGenericEntity) | Overloaded. This will begin a new transaction for the current transaction id.
BeginTransaction (inherited from AptifyGenericEntityBase) | Overloaded. Starts a new transaction if one has not been started or it will start a new segment on the current transaction.
CheckForDuplicates (inherited from AptifyGenericEntity) | Checks for duplicate records based on the entity and the currently loaded data.
ClearDirtyFlags (inherited from AptifyGenericEntity) | Clears the Dirty flag for the GE instance, all of its subtype instances, and all data fields.
ClearFields (inherited from AptifyGenericEntity) | Calls the Clear member for each associated Datafield.
Clone (inherited from AptifyGenericEntityBase) | Overloaded. Creates a new instance of the current GE object.
CommitTransaction (inherited from AptifyGenericEntity) | Commits the current transaction.
Config (inherited from AptifyGenericEntity) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided.
Config (inherited from AptifyGenericEntityBase) | Overloaded. Configures a GE Instance to reflect the Sub-type information provided. The new instance will not be the instance of a wrapper as is the case of Aptifyapplication.GetEntityObject where used.
DeferPendingChange |
Delete (inherited from AptifyGenericEntity) | Overloaded. Deletes the currently loaded GE record.
Delete (inherited from AptifyGenericEntityBase) | Overloaded. Deletes the current record.
Diff (inherited from AptifyGenericEntityBase) | Determines the difference of the Current object with any other Object that implements ICGIGenericEntity and uses arDiffFields() to return a list of different fields.
Display (inherited from AptifyGenericEntity) | Displays the current record in the Aptify Object Viewer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeTransaction (inherited from AptifyGenericEntity) | Called when the top-level transaction has been committed. This is used to inform the object and all of it's sub-types that the object's changes have been committed to the database.
GenericRelinkDependants (inherited from AptifyGenericEntity) | Handles the relinking of special cases where records are linked to the record, but the link is identified by an entityID and the recordID.
GetDataString (inherited from AptifyGenericEntity) | Returns an XML string representation of the data belonging to the Object in Memory.
GetDependencies (inherited from AptifyGenericEntity) | Overloaded. NOT IMPLEMENTED
GetDuplicateList (inherited from AptifyGenericEntity) | Returns a list of duplicates that are either potential or absolute duplicates for the current object.
GetField (inherited from AptifyGenericEntityBase) | Returns an instance of the DataField that corresponds to the given field name.
GetFieldIndex (inherited from AptifyGenericEntityBase) | Returns the index of the DataField that corresponds to the given field name in the GE's fields collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLatestRecordVersion (inherited from AptifyGenericEntity) | Returns the Latest Record Version for this GE Record.
GetObjectData (inherited from AptifyGenericEntity) | Overloaded. Returns an XML string representation of the Object in Memory.
GetRecordVersion (inherited from AptifyGenericEntity) | Returns the current version of the loaded record.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from AptifyGenericEntityBase) | Overloaded. Returns the value of the specified DataField for the loaded record.
Load (inherited from AptifyGenericEntity) | Overloaded. Loads an existing instance with data.
Load (inherited from AptifyGenericEntityBase) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntity) | Overloaded.
LogRecordHistory (inherited from AptifyGenericEntityBase) | Overloaded.
Merge (inherited from AptifyGenericEntityBase) | Overloaded. Merges two GE objects in memory.
NewRecord (inherited from AptifyGenericEntity) | Clears all of the Fields and sub-types for a GE object.
PostPendingChange |
RejectPendingChange |
RollbackRecordID (inherited from AptifyGenericEntity) | It resets the Current Record ID to -1 if the GE record was a new record that had just been saved.
RollbackTransaction (inherited from AptifyGenericEntity) | Rolls back the current transaction.
Save | Overloaded.
Save (inherited from AptifyGenericEntityBase) | Overloaded. Attempts to save the Current GE data. The overloaded Save methods chain down to the broader overloads. This means inheriting classes only need to implement the Save method.
SaveAsPendingChange (inherited from AptifyGenericEntity) | Saves a GE as a pending change instead of the actual change to the entity.
SaveToFile (inherited from AptifyGenericEntity) | Saves an XML Representation of the GE Object in a file with the provided name
SetAddValue (inherited from AptifyGenericEntity) | Overloaded. If a Field matching the FieldName is found, SetAddValue calls the SetValue method, passing in the FieldName and Value. If the Field does not exist, it is added to the Fields collection with its value set to the Value parameter. When adding a temporary field, the SQL Data Type for the field can be specified. If left blank, the SQL Data Type will default to nvarchar.
SetAddValue (inherited from AptifyGenericEntityBase) | Overloaded. Sets a value for or Adds a value for a DataField.
SetContainerLinkedDataField (inherited from AptifyGenericEntityBase) |
SetNewSubTypeIDAndSequence (inherited from AptifyGenericEntity) | Used to update a newly added Sub-Type record's ID and Sequence values which are created by the database when the record is added. Also updates the object with any Parent Linked Values, using the sub-type's Parent GE object. This method is only valid for newly created Sub-Type records. Calling this method for a Sub-Type record that already has an ID will result in an Exception.
SetProcInfo (inherited from AptifyGenericEntityBase) | Overloaded. Sets the name of the CreateSQL stored procedure and the UpdateSQL stored procedure.
SetValue (inherited from AptifyGenericEntityBase) | Sets the value of an existing field in the fields collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateEmbeddedObjectsNeedingRecordID (inherited from AptifyGenericEntity) |
Validate (inherited from AptifyGenericEntityBase) | Overloaded.

Protected Instance Methods

AreExtenderObjectsDirty (inherited from AptifyGenericEntityBase) |
BroadcastChange (inherited from AptifyGenericEntity) |
ClearSubTypeAddTempTableName (inherited from AptifyGenericEntityBase) |
CloneSubType (inherited from AptifyGenericEntity) |
CreateExtenderInstance (inherited from AptifyGenericEntity) | This method implements the construction process for a new class that derives from the ExtenderInstanceBase class. The purpose of this method is to create a new class instance of a ExtenderInstanceBase derived class. Sub-classes of AptifyGenericEntity can override this method and provide their own sub-classes of ExtenderInstanceBase in order to modify the functionality of the ExtenderInstance class. It is recommended that sub-classes use the ExtenderInstance as the base-class rather than directly sub-classing ExtenderInstanceBase.
CreateRecord (inherited from AptifyGenericEntity) |
CreateSubTypeRecord (inherited from AptifyGenericEntity) |
CreateTopLevelRecord (inherited from AptifyGenericEntity) |
DecrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
DeleteTopicCodeLinks (inherited from AptifyGenericEntity) | Deletes the Topic Code Link records linked to the current record. This method is called from the Delete method after submitting the SQL to delete the current record.
DistributeNewSubTypeRecordInfo (inherited from AptifyGenericEntity) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FinishTransaction (inherited from AptifyGenericEntity) |
FinishTransactionSubType (inherited from AptifyGenericEntity) |
FinishTransactionTopLevel (inherited from AptifyGenericEntity) |
FireEvent (inherited from AptifyGenericEntity) |
FireValidationEvent (inherited from AptifyGenericEntity) |
GenerateCreateParametrizedSQL (inherited from AptifyGenericEntity) |
GenerateCreateSQL (inherited from AptifyGenericEntity) |
GenerateDeleteSQL (inherited from AptifyGenericEntity) |
GenerateFieldSQL (inherited from AptifyGenericEntity) |
GenerateUpdateSQL (inherited from AptifyGenericEntity) |
IncrementCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
InnerValidate (inherited from AptifyGenericEntity) | Runs Validation on all SubTypes and DataFields.
LoadPendingChangeTypes |
MakeFieldsCopy (inherited from AptifyGenericEntity) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAfterCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterCloneRecord event should be fired. If the event should be fired, it is fired.
OnAfterDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterDeleteRecord event should be fired. If the event should be fired, it is fired.
OnAfterLoadRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterLoadRecord event should be fired. If the event should be fired, it is fired.
OnAfterNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterNewRecord event should be fired. If the event should be fired, it is fired.
OnAfterSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterSaveRecord event should be fired. If the event should be fired, it is fired.
OnAfterValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the AfterValidateRecord event should be fired. If the event should be fired, it is fired.
OnBeforeCloneRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeCloneRecord event should be fired. If the event should be fired, it is fired.
OnBeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeDeleteRecord event should be fired. If the event should be fired, it is fired.
OnBeforeLoadRecord (inherited from AptifyGenericEntityBase) | Overloaded. Verifies whether or not the BeforeLoadRecord event should be fired. If the event should be fired, it is fired.
OnBeforeNewRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeNewRecord event should be fired. If the event should be fired, it is fired.
OnBeforeSaveRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeSaveRecord event should be fired. If the event should be fired, it is fired.
OnBeforeValidateRecord (inherited from AptifyGenericEntityBase) | Verifies whether or not the BeforeValidateRecord event should be fired. If the event should be fired, it is fired.
OnWarning (inherited from AptifyGenericEntityBase) | Raises the Warning Event.
RecordVersionInfo (inherited from AptifyGenericEntity) |
RefreshLinkedFields (inherited from AptifyGenericEntity) |
ResetCurrentTransactionCount (inherited from AptifyGenericEntityBase) |
ResetEmbeddedObjectLists (inherited from AptifyGenericEntity) |
RestoreCopiedFields (inherited from AptifyGenericEntity) |
RollbackEmbeddedObjects (inherited from AptifyGenericEntity) |
SaveExtenderObjects (inherited from AptifyGenericEntity) | Overloaded. This method is responsible for saving extender objects associated with this GE
SetCurrentTransactionID (inherited from AptifyGenericEntityBase) |
SetLastError (inherited from AptifyGenericEntityBase) | Sets the internal error code that is retrieved by the LastError property.
SetLastUserError (inherited from AptifyGenericEntityBase) | Sets the user error message that is retrieved by the LastUserError property
SetRecordID (inherited from AptifyGenericEntityBase) |
SetupTransaction (inherited from AptifyGenericEntity) |
SetupTransactionSubType (inherited from AptifyGenericEntity) |
SetupTransactionTopLevel (inherited from AptifyGenericEntity) |
UpdateRecord (inherited from AptifyGenericEntity) |
ValidateSetApproved |
ValidateSetDeferred |
ValidateSetPending |
ValidateSetPosted |
ValidateSetRejected |
ValidateSubTypes (inherited from AptifyGenericEntityBase) |
VerifyObject (inherited from AptifyGenericEntity) |

See Also

PendingChangesEntity Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangesEntity.ApprovePendingChange Method

public virtual void ApprovePendingChange(
Boolean AllowGUI
);

See Also

PendingChangesEntity Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangesEntity.DeferPendingChange Method

public virtual void DeferPendingChange(
Boolean AllowGUI
);

See Also

PendingChangesEntity Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangesEntity.LoadPendingChangeTypes Method

protected virtual void LoadPendingChangeTypes();

See Also

PendingChangesEntity Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangesEntity.PostPendingChange Method

public virtual void PostPendingChange(
Boolean AllowGUI
);

See Also

PendingChangesEntity Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangesEntity.RejectPendingChange Method

public virtual void RejectPendingChange(
Boolean AllowGUI
);

See Also

PendingChangesEntity Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


Save Method

Aptify 5.0 Software Development Kit (SDK)

PendingChangesEntity.Save Method

Overload List

Inherited from AptifyGenericEntityBase.

public virtual bool Save();

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(Boolean,ref String&);

public override bool Save(Boolean,ref String&,String);

Inherited from AptifyGenericEntityBase.

public virtual bool Save(ref String&);

See Also

PendingChangesEntity Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangesEntity.Save Method (Boolean, String&, String)

public override bool Save(
Boolean AllowGUI,
ref String& ErrorString,
String TransactionID
);

See Also

PendingChangesEntity Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace | PendingChangesEntity.Save Overload List


PendingChangesEntity.ValidateSetApproved Method

protected virtual bool ValidateSetApproved(
ref String& sError
);

See Also

PendingChangesEntity Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangesEntity.ValidateSetDeferred Method

protected virtual bool ValidateSetDeferred(
ref String& sError
);

See Also

PendingChangesEntity Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangesEntity.ValidateSetPending Method

protected virtual bool ValidateSetPending(
ref String& sError
);

See Also

PendingChangesEntity Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangesEntity.ValidateSetPosted Method

protected virtual bool ValidateSetPosted(
ref String& sError
);

See Also

PendingChangesEntity Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangesEntity.ValidateSetRejected Method

protected virtual bool ValidateSetRejected(
ref String& sError
);

See Also

PendingChangesEntity Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangesEntity Events

The events of the PendingChangesEntity class are listed below. For a complete list of PendingChangesEntity class members, see the PendingChangesEntity Members topic.

Public Instance Events

AfterCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and the internal clone operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Clone Events.
AfterDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and the internal delete operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Delete Events.
AfterLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and the internal load operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Load Events.
AfterNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called and the internal NewRecord operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
AfterPendingChangeApproved |
AfterPendingChangeDeferred |
AfterPendingChangePosted |
AfterPendingChangeRejected |
AfterSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and the internal save operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
AfterValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and the internal validate operation has been completed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the Validate Events.
BeforeCloneRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Clone method is called and before the internal clone logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the CloneRecord Events.
BeforeDeleteRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Delete method is called and before the internal delete logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the DeleteRecord Events.
BeforeLoadRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Load method is called and before the internal Load operation has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the LoadRecord Events.
BeforeNewRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's NewRecord method is called, before the internal NewRecord logic has executed. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the NewRecord Events.
BeforePendingChangeApproved |
BeforePendingChangeDeferred |
BeforePendingChangePosted |
BeforePendingChangeRejected |
BeforeSaveRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Save method is called and before the internal save logic has occurred. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the SaveRecord Events.
BeforeValidateRecord (inherited from AptifyGenericEntityBase) | Fired when the Generic Entity's Validate method is called and before the internal Validate operation has begun. Note the event will only be fired if the Generic Entity's EventsToFire property setting includes the ValidateRecord Events.
Warning (inherited from AptifyGenericEntityBase) | This event is raised whenever a warning needs to be relayed from within the Generic Entity to a consumer of the object.

See Also

PendingChangesEntity Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangesEntity.PendingChangesEntity.AfterPendingChangeApprovedEventHandler Event

public event PendingChangesEntity.AfterPendingChangeApprovedEventHandler AfterPendingChangeApproved;

See Also

PendingChangesEntity Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangesEntity.PendingChangesEntity.AfterPendingChangeDeferredEventHandler Event

public event PendingChangesEntity.AfterPendingChangeDeferredEventHandler AfterPendingChangeDeferred;

See Also

PendingChangesEntity Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangesEntity.PendingChangesEntity.AfterPendingChangePostedEventHandler Event

public event PendingChangesEntity.AfterPendingChangePostedEventHandler AfterPendingChangePosted;

See Also

PendingChangesEntity Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangesEntity.PendingChangesEntity.AfterPendingChangeRejectedEventHandler Event

public event PendingChangesEntity.AfterPendingChangeRejectedEventHandler AfterPendingChangeRejected;

See Also

PendingChangesEntity Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangesEntity.PendingChangesEntity.BeforePendingChangeApprovedEventHandler Event

public event PendingChangesEntity.BeforePendingChangeApprovedEventHandler BeforePendingChangeApproved;

See Also

PendingChangesEntity Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangesEntity.PendingChangesEntity.BeforePendingChangeDeferredEventHandler Event

public event PendingChangesEntity.BeforePendingChangeDeferredEventHandler BeforePendingChangeDeferred;

See Also

PendingChangesEntity Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangesEntity.PendingChangesEntity.BeforePendingChangePostedEventHandler Event

public event PendingChangesEntity.BeforePendingChangePostedEventHandler BeforePendingChangePosted;

See Also

PendingChangesEntity Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangesEntity.PendingChangesEntity.BeforePendingChangeRejectedEventHandler Event

public event PendingChangesEntity.BeforePendingChangeRejectedEventHandler BeforePendingChangeRejected;

See Also

PendingChangesEntity Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangesEntity.AfterPendingChangeApprovedEventHandler Delegate

public delegate void PendingChangesEntity.AfterPendingChangeApprovedEventHandler();

Requirements

Namespace: Aptify.Framework.BusinessLogic.PendingChanges

Assembly: AptifyPendingChangesObject (in AptifyPendingChangesObject.dll)

See Also

Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangesEntity.AfterPendingChangeDeferredEventHandler Delegate

public delegate void PendingChangesEntity.AfterPendingChangeDeferredEventHandler();

Requirements

Namespace: Aptify.Framework.BusinessLogic.PendingChanges

Assembly: AptifyPendingChangesObject (in AptifyPendingChangesObject.dll)

See Also

Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangesEntity.AfterPendingChangePostedEventHandler Delegate

public delegate void PendingChangesEntity.AfterPendingChangePostedEventHandler();

Requirements

Namespace: Aptify.Framework.BusinessLogic.PendingChanges

Assembly: AptifyPendingChangesObject (in AptifyPendingChangesObject.dll)

See Also

Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangesEntity.AfterPendingChangeRejectedEventHandler Delegate

public delegate void PendingChangesEntity.AfterPendingChangeRejectedEventHandler();

Requirements

Namespace: Aptify.Framework.BusinessLogic.PendingChanges

Assembly: AptifyPendingChangesObject (in AptifyPendingChangesObject.dll)

See Also

Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangesEntity.BeforePendingChangeApprovedEventHandler Delegate

public delegate void PendingChangesEntity.BeforePendingChangeApprovedEventHandler(
ref Boolean& Cancel
);

Requirements

Namespace: Aptify.Framework.BusinessLogic.PendingChanges

Assembly: AptifyPendingChangesObject (in AptifyPendingChangesObject.dll)

See Also

Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangesEntity.BeforePendingChangeDeferredEventHandler Delegate

public delegate void PendingChangesEntity.BeforePendingChangeDeferredEventHandler(
ref Boolean& Cancel
);

Requirements

Namespace: Aptify.Framework.BusinessLogic.PendingChanges

Assembly: AptifyPendingChangesObject (in AptifyPendingChangesObject.dll)

See Also

Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangesEntity.BeforePendingChangePostedEventHandler Delegate

public delegate void PendingChangesEntity.BeforePendingChangePostedEventHandler(
ref Boolean& Cancel
);

Requirements

Namespace: Aptify.Framework.BusinessLogic.PendingChanges

Assembly: AptifyPendingChangesObject (in AptifyPendingChangesObject.dll)

See Also

Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangesEntity.BeforePendingChangeRejectedEventHandler Delegate

public delegate void PendingChangesEntity.BeforePendingChangeRejectedEventHandler(
ref Boolean& Cancel
);

Requirements

Namespace: Aptify.Framework.BusinessLogic.PendingChanges

Assembly: AptifyPendingChangesObject (in AptifyPendingChangesObject.dll)

See Also

Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangesEntity.PendingChangeType Enumeration

public enum PendingChangesEntity.PendingChangeType

Members

Member Name | Description
Scheduled |
Conflict |
ApprovalRequest |
ScheduledPlusConflict |
ScheduledPlusApprovalRequest |
ConflictPlusApprovalRequest |
NotSupported |

Requirements

Namespace: Aptify.Framework.BusinessLogic.PendingChanges

Assembly: AptifyPendingChangesObject (in AptifyPendingChangesObject.dll)

See Also

Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangesViewer Class

For a list of all members of this type, see PendingChangesViewer Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
PendingChangesViewer

public class PendingChangesViewer : Form, IAptifyTopLevelViewer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.PendingChanges

Assembly: AptifyPendingChangesUI (in AptifyPendingChangesUI.dll)

See Also

PendingChangesViewer Members | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangesViewer Members

PendingChangesViewer overview

Public Instance Constructors

PendingChangesViewer Constructor Initializes a new instance of the PendingChangesViewer class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config | Overloaded. Method used for initialization of the entity viewer.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show | Overloaded. Method used to display the viewer form.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
ShowDialog | Overloaded. Method used to display the viewer form in dialog mode.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog with the specified owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

PendingChangesViewer Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangesViewer Constructor

Initializes a new instance of the PendingChangesViewer class.

public PendingChangesViewer();

See Also

PendingChangesViewer Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangesViewer Methods

The methods of the PendingChangesViewer class are listed below. For a complete list of PendingChangesViewer class members, see the PendingChangesViewer Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config | Overloaded. Method used for initialization of the entity viewer.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show | Overloaded. Method used to display the viewer form.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
ShowDialog | Overloaded. Method used to display the viewer form in dialog mode.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog with the specified owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

PendingChangesViewer Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangesViewer.ApplySkin Method

protected virtual void ApplySkin();

See Also

PendingChangesViewer Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


Config Method

Aptify 5.0 Software Development Kit (SDK)

PendingChangesViewer.Config Method

Method used for initialization of the entity viewer.

Overload List

Method used for initialization of the entity viewer.

public void Config(AptifyGenericEntityBase);

Method used for initialization of the entity viewer.

public void Config(UserCredentials,String);

Method used for initialization of the entity viewer.

public void Config(UserCredentials,String,Int64);

Method used for initialization of the entity viewer.

public void Config(UserCredentials,String,String);

See Also

PendingChangesViewer Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangesViewer.Config Method (AptifyGenericEntityBase)

Method used for initialization of the entity viewer.

public void Config(
AptifyGenericEntityBase GE
);

Parameters

GE
Generic Entity representing the record to be displayed inside the form.

Implements

IAptifyTopLevelViewer.

Remarks

See Also

PendingChangesViewer Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace | PendingChangesViewer.Config Overload List


PendingChangesViewer.Config Method (UserCredentials, String)

Method used for initialization of the entity viewer.

public void Config(
UserCredentials UserCredentials,
String CmdString
);

Parameters

UserCredentials
UserCredentials object representing the current Aptify session.
CmdString
Operation desired to be performed in the viewer form.

Implements

IAptifyTopLevelViewer.

Remarks

See Also

PendingChangesViewer Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace | PendingChangesViewer.Config Overload List


PendingChangesViewer.Config Method (UserCredentials, String, Int64)

Method used for initialization of the entity viewer.

public void Config(
UserCredentials UserCredentials,
String EntityName,
Int64 RecordID
);

Parameters

UserCredentials
UserCredentials object representing the current Aptify session.
EntityName
Name of the entity to be represented by the form.
RecordID
ID of the record to be represented by the form.

Implements

IAptifyTopLevelViewer.

Remarks

See Also

PendingChangesViewer Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace | PendingChangesViewer.Config Overload List


PendingChangesViewer.Config Method (UserCredentials, String, String)

Method used for initialization of the entity viewer.

public void Config(
UserCredentials UserCredentials,
String EntityName,
String NewRecordParameters
);

Parameters

UserCredentials
UserCredentials object representing the current Aptify session.
EntityName
Name of the entity to be represented by the form.
NewRecordParameters
Set of key/value pairs used to populate the underlying Generic Entity during initialization of a new record.

Implements

IAptifyTopLevelViewer.

Remarks

See Also

PendingChangesViewer Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace | PendingChangesViewer.Config Overload List


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

PendingChangesViewer.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

PendingChangesViewer Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangesViewer.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

PendingChangesViewer Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace | PendingChangesViewer.Dispose Overload List


Show Method

Aptify 5.0 Software Development Kit (SDK)

PendingChangesViewer.Show Method

Method used to display the viewer form.

Overload List

Method used to display the viewer form.

new public void Show();

Method used to display the viewer form.

public void Show(Form);

Inherited from Form.

public void Show(IWin32Window);

See Also

PendingChangesViewer Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangesViewer.Show Method ()

Method used to display the viewer form.

new public void Show();

Implements

IAptifyTopLevelViewer.

Remarks

See Also

PendingChangesViewer Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace | PendingChangesViewer.Show Overload List


PendingChangesViewer.Show Method (Form)

Method used to display the viewer form.

public void Show(
Form ParentForm
);

Parameters

ParentForm
Form object which raised the current form.

Implements

IAptifyTopLevelViewer.

Remarks

See Also

PendingChangesViewer Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace | PendingChangesViewer.Show Overload List


ShowDialog Method

Aptify 5.0 Software Development Kit (SDK)

PendingChangesViewer.ShowDialog Method

Method used to display the viewer form in dialog mode.

Overload List

Method used to display the viewer form in dialog mode.

new public DialogResult ShowDialog();

Method used to display the viewer form in dialog mode.

public DialogResult ShowDialog(Form);

Inherited from Form.

public DialogResult ShowDialog(IWin32Window);

See Also

PendingChangesViewer Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangesViewer.ShowDialog Method ()

Method used to display the viewer form in dialog mode.

new public DialogResult ShowDialog();

Return Value

Implements

IAptifyTopLevelViewer.

Remarks

See Also

PendingChangesViewer Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace | PendingChangesViewer.ShowDialog Overload List


PendingChangesViewer.ShowDialog Method (Form)

Method used to display the viewer form in dialog mode.

public DialogResult ShowDialog(
Form ParentForm
);

Parameters

ParentForm
Form object which raised the current form.

Return Value

Implements

IAptifyTopLevelViewer.

Remarks

See Also

PendingChangesViewer Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace | PendingChangesViewer.ShowDialog Overload List


PendingChangeType Class

For a list of all members of this type, see PendingChangeType Members.

System.Object
PendingChangeType

public class PendingChangeType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.PendingChanges

Assembly: AptifyPendingChangesObject (in AptifyPendingChangesObject.dll)

See Also

PendingChangeType Members | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangeType Members

PendingChangeType overview

Public Instance Constructors

PendingChangeType Constructor Initializes a new instance of the PendingChangeType class.

Public Instance Properties

IsApprovalRequest
IsConflict
IsScheduled
TypeName

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PendingChangeType Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangeType Constructor

Initializes a new instance of the PendingChangeType class.

public PendingChangeType();

See Also

PendingChangeType Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangeType Properties

The properties of the PendingChangeType class are listed below. For a complete list of PendingChangeType class members, see the PendingChangeType Members topic.

Public Instance Properties

IsApprovalRequest
IsConflict
IsScheduled
TypeName

See Also

PendingChangeType Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


IsApprovalRequest Property

Aptify 5.0 Software Development Kit (SDK)

PendingChangeType.IsApprovalRequest Property

public Boolean IsApprovalRequest {get;}

See Also

PendingChangeType Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


IsConflict Property

Aptify 5.0 Software Development Kit (SDK)

PendingChangeType.IsConflict Property

public Boolean IsConflict {get;}

See Also

PendingChangeType Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


IsScheduled Property

Aptify 5.0 Software Development Kit (SDK)

PendingChangeType.IsScheduled Property

public Boolean IsScheduled {get;}

See Also

PendingChangeType Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


TypeName Property

Aptify 5.0 Software Development Kit (SDK)

PendingChangeType.TypeName Property

public String TypeName {get;}

See Also

PendingChangeType Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangeUpdate Class

Process Component for updating Pending Changes records.

For a list of all members of this type, see PendingChangeUpdate Members.

System.Object
PendingChangeBase
PendingChangeUpdate

public class PendingChangeUpdate : PendingChangeBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.PendingChanges

Assembly: PendingChangeComponent (in PendingChangeComponent.dll)

See Also

PendingChangeUpdate Members | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangeUpdate Members

PendingChangeUpdate overview

Public Instance Constructors

PendingChangeUpdate Constructor Initializes a new instance of the PendingChangeUpdate class.

Public Instance Properties

DataAction (inherited from PendingChangeBase) |
ProcessComponentID (inherited from PendingChangeBase) | Returns the Process Component ID in use for the current instance of the class.
Properties (inherited from PendingChangeBase) | Aptify Properties Collection used for Input and Output Properties for the component.

Public Instance Methods

Config (inherited from PendingChangeBase) | This method must be called before any other member of this class is accessed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run | Implementation of the IProcessComponent.Run() method which will execute the function of updating all Pending Change records that are approved and, if scheduled, the scheduled time has past.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

Application (inherited from PendingChangeBase) | Aptify Application Object.
InitData (inherited from PendingChangeBase) | This method returns the InitData string for processing as required by ParseInitData() or other methods.
InitDataItems (inherited from PendingChangeBase) | This member will return a dictionary of init data items (string values) that are keyed based on their attribute name. For example, for the Init Data string that contains a single XML node of Entity with a value of "Demo Entity", this dictionary will have one entry with a value of "Demo Entity" keyed as "Entity".
InitDataXMLDoc (inherited from PendingChangeBase) | This member returns an instance of the System.Xml.XmlDocument class that is instantiated and loaded with the InitData from the Form Component record for this instance of the component. This method is used by ParseInitData and other internal members of the base class in order to access initialization attributes from the Form Component record. Utilize this method to access the XML attributes of the InitData string.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ParseInitData (inherited from PendingChangeBase) | This method is called when necessary by the component internally to access "Init Data", which is the InitData field in the Process Component record. This information is necessary to determine the name of the entity and other properties that can vary from one Process Component meta-data record to another. Since the Entity CRUD components are generic in nature, they have no inherent knowledge of which entity they are bound to at a given time. That is the key to what Process Component InitData strings tell the components - the Entity Name, among other attributes. In sub-classes, this method can be overriden to access the underlying InitData string directly to access other attributes from the string in addition to the Entity Name which is the single attribute extracted by the base class implementation of this method.
UpdatePendingRecord (inherited from PendingChangeBase) |

See Also

PendingChangeUpdate Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangeUpdate Constructor

Initializes a new instance of the PendingChangeUpdate class.

public PendingChangeUpdate();

See Also

PendingChangeUpdate Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangeUpdate Methods

The methods of the PendingChangeUpdate class are listed below. For a complete list of PendingChangeUpdate class members, see the PendingChangeUpdate Members topic.

Public Instance Methods

Config (inherited from PendingChangeBase) | This method must be called before any other member of this class is accessed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run | Implementation of the IProcessComponent.Run() method which will execute the function of updating all Pending Change records that are approved and, if scheduled, the scheduled time has past.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ParseInitData (inherited from PendingChangeBase) | This method is called when necessary by the component internally to access "Init Data", which is the InitData field in the Process Component record. This information is necessary to determine the name of the entity and other properties that can vary from one Process Component meta-data record to another. Since the Entity CRUD components are generic in nature, they have no inherent knowledge of which entity they are bound to at a given time. That is the key to what Process Component InitData strings tell the components - the Entity Name, among other attributes. In sub-classes, this method can be overriden to access the underlying InitData string directly to access other attributes from the string in addition to the Entity Name which is the single attribute extracted by the base class implementation of this method.
UpdatePendingRecord (inherited from PendingChangeBase) |

See Also

PendingChangeUpdate Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PendingChangeUpdate.Run Method

Implementation of the IProcessComponent.Run() method which will execute the function of updating all Pending Change records that are approved and, if scheduled, the scheduled time has past.

public override string Run();

Return Value

Success or Failed

Implements

IProcessComponent.

See Also

PendingChangeUpdate Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PostAvailablePendingChangeBatchPC Class

For a list of all members of this type, see PostAvailablePendingChangeBatchPC Members.

System.Object
PostAvailablePendingChangeBatchPC

public class PostAvailablePendingChangeBatchPC : IProcessComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.PendingChanges

Assembly: AptifyPendingChangesObject (in AptifyPendingChangesObject.dll)

See Also

PostAvailablePendingChangeBatchPC Members | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PostAvailablePendingChangeBatchPC Members

PostAvailablePendingChangeBatchPC overview

Public Instance Constructors

PostAvailablePendingChangeBatchPC Constructor Initializes a new instance of the PostAvailablePendingChangeBatchPC class.

Public Instance Properties

Properties

Public Instance Methods

Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PostAvailablePendingChangeBatchPC Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PostAvailablePendingChangeBatchPC Constructor

Initializes a new instance of the PostAvailablePendingChangeBatchPC class.

public PostAvailablePendingChangeBatchPC();

See Also

PostAvailablePendingChangeBatchPC Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PostAvailablePendingChangeBatchPC Properties

The properties of the PostAvailablePendingChangeBatchPC class are listed below. For a complete list of PostAvailablePendingChangeBatchPC class members, see the PostAvailablePendingChangeBatchPC Members topic.

Public Instance Properties

Properties

See Also

PostAvailablePendingChangeBatchPC Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


Properties Property

Aptify 5.0 Software Development Kit (SDK)

PostAvailablePendingChangeBatchPC.Properties Property

public AptifyProperties Properties {get;}

Implements

IProcessComponent.

See Also

PostAvailablePendingChangeBatchPC Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PostAvailablePendingChangeBatchPC Methods

The methods of the PostAvailablePendingChangeBatchPC class are listed below. For a complete list of PostAvailablePendingChangeBatchPC class members, see the PostAvailablePendingChangeBatchPC Members topic.

Public Instance Methods

Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PostAvailablePendingChangeBatchPC Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PostAvailablePendingChangeBatchPC.Config Method

public void Config(
AptifyApplication ApplicationObject
);

Implements

IProcessComponent.

See Also

PostAvailablePendingChangeBatchPC Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PostAvailablePendingChangeBatchPC.Run Method

public string Run();

Implements

IProcessComponent.

See Also

PostAvailablePendingChangeBatchPC Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PostSinglePendingChangePC Class

For a list of all members of this type, see PostSinglePendingChangePC Members.

System.Object
PostSinglePendingChangePC

public class PostSinglePendingChangePC : IProcessComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.PendingChanges

Assembly: AptifyPendingChangesObject (in AptifyPendingChangesObject.dll)

See Also

PostSinglePendingChangePC Members | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PostSinglePendingChangePC Members

PostSinglePendingChangePC overview

Public Instance Constructors

PostSinglePendingChangePC Constructor Initializes a new instance of the PostSinglePendingChangePC class.

Public Instance Properties

Properties

Public Instance Methods

Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PostSinglePendingChangePC Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PostSinglePendingChangePC Constructor

Initializes a new instance of the PostSinglePendingChangePC class.

public PostSinglePendingChangePC();

See Also

PostSinglePendingChangePC Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PostSinglePendingChangePC Properties

The properties of the PostSinglePendingChangePC class are listed below. For a complete list of PostSinglePendingChangePC class members, see the PostSinglePendingChangePC Members topic.

Public Instance Properties

Properties

See Also

PostSinglePendingChangePC Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


Properties Property

Aptify 5.0 Software Development Kit (SDK)

PostSinglePendingChangePC.Properties Property

public AptifyProperties Properties {get;}

Implements

IProcessComponent.

See Also

PostSinglePendingChangePC Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PostSinglePendingChangePC Methods

The methods of the PostSinglePendingChangePC class are listed below. For a complete list of PostSinglePendingChangePC class members, see the PostSinglePendingChangePC Members topic.

Public Instance Methods

Config |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PostSinglePendingChangePC Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PostSinglePendingChangePC.Config Method

public void Config(
AptifyApplication ApplicationObject
);

Implements

IProcessComponent.

See Also

PostSinglePendingChangePC Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


PostSinglePendingChangePC.Run Method

public string Run();

Implements

IProcessComponent.

See Also

PostSinglePendingChangePC Class | Aptify.Framework.BusinessLogic.PendingChanges Namespace


Aptify.Framework.BusinessLogic.PendingChanges.Exceptions

Aptify 5.0 Software Development Kit (SDK)

Aptify.Framework.BusinessLogic.PendingChanges.Exceptions Namespace

This namespace contains the functionality that handles the possible exceptions related to the Pending Changes functionality.

Namespace hierarchy

Classes

Class | Description
PendingChangePermissionsException |


PendingChangePermissionsException Class

For a list of all members of this type, see PendingChangePermissionsException Members.

System.Object
Exception
ApplicationException
PendingChangePermissionsException

public class PendingChangePermissionsException : ApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.PendingChanges.Exceptions

Assembly: AptifyPendingChangesObject (in AptifyPendingChangesObject.dll)

See Also

PendingChangePermissionsException Members | Aptify.Framework.BusinessLogic.PendingChanges.Exceptions Namespace


PendingChangePermissionsException Members

PendingChangePermissionsException overview

Public Instance Constructors

PendingChangePermissionsException Constructor Initializes a new instance of the PendingChangePermissionsException class.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message |
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PendingChangePermissionsException Class | Aptify.Framework.BusinessLogic.PendingChanges.Exceptions Namespace


PendingChangePermissionsException Constructor

Initializes a new instance of the PendingChangePermissionsException class.

public PendingChangePermissionsException();

See Also

PendingChangePermissionsException Class | Aptify.Framework.BusinessLogic.PendingChanges.Exceptions Namespace


PendingChangePermissionsException Properties

The properties of the PendingChangePermissionsException class are listed below. For a complete list of PendingChangePermissionsException class members, see the PendingChangePermissionsException Members topic.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message |
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

See Also

PendingChangePermissionsException Class | Aptify.Framework.BusinessLogic.PendingChanges.Exceptions Namespace


Message Property

Aptify 5.0 Software Development Kit (SDK)

PendingChangePermissionsException.Message Property

public override String Message {get;}

See Also

PendingChangePermissionsException Class | Aptify.Framework.BusinessLogic.PendingChanges.Exceptions Namespace


Aptify.Framework.BusinessLogic.ProcessPipeline

Aptify 5.0 Software Development Kit (SDK)

Aptify.Framework.BusinessLogic.ProcessPipeline Namespace

This namespace contains objects related to Aptify's Process Pipeline functionality. This includes the Process Flows Engine that executes process flows as well as the Aptify Asynchronous Processor, which is used by Application Servers to execute asynchronous process flow runs.

Namespace hierarchy

Classes

Class | Description
AptifyEventFire |
BreakPointEditor | Used for viewing/editing breakpoints for a process flow debug run
CompileProcessFlowComponent | Process Flow Component that is used to compile Process Flows into a DLL.
CurrentStepDialog | View/Edit Current Step Information During Debugging
EventCache |
EventFireConstants |
ExecutionRuleException |
GenericCreateRecord | Generic Process Component for creating new records for both Top-Level and Sub-Type entities
GenericCRUDBase | Base class for all other Aptify Generic CRUD Process Components
GenericDeleteRecord | Generic Process Component for deleting records for both Top-Level and Sub-Type entities
GenericReadRecord | Generic Process Component for reading records for both Top-Level and Sub-Type entities
GenericUpdateRecord | Generic Process Component for updating records for both Top-Level and Sub-Type entities
GetDataTableValueProcessComponent |
InfoCacheItem |
InputBoxProcessComponent | Aptify Input Box(Windows Only) Process Component
LoadDataTableProcessComponent |
MapProperty |
MessageBoxBase | Base class for Aptify Message Box and Input Box Process Components
MessageBoxProcessComponent | Aptify Message Box(Windows Only) Process Component
MoveDataTableProcessComponent |
PipeLineLog |
ProcessComponentBase | This class provides a base from which process components can be easily derived without having to directly implement IProcessComponent and implement the Properties collection. This base class also has a base Config() method and handles dynamic creation of a DataAction class using the UserCredentials provided by the Application Object passed into the Config() method. Subclass this class to create new process components whenever possible to minimize code redundancy.
ProcessComponentGenerator |
ProcessEngineException |
ProcessFlowCompileException | Thrown when there is a problem compiling a Process Flow into an Assembly.
ProcessFlowCompiler | Compiles an Aptify Process Flow record into a VB.Net assembly.
ProcessFlowDebugInfo | Debug information class to be used to communicate between callers of a process flow and the ProcessFlowEngine class. Pass in an instance of this class to the ProcessFlowEngine when executing a process flow to invoke the debugging functionality of the process flow engine.
ProcessFlowDebugInfo.BreakPointInfo | Class that contains information about breakpoints
ProcessFlowDebugInfo.StepExecutionLog | Class contains the log results for a given process flow step execution
ProcessFlowDebugRun | Debugger Class for Aptify Process Flows
ProcessFlowEngine | Aptify Process Flow Engine Component - This class is the base class for executing any process flow defined in Aptify meta-data.
ProcessFlowExecutionRule | Class used by the Process Flow engine to determine if process flows should be executed based on a number of environmental conditions. In the event these conditions are not sufficient, the class can be extended through inheritance.
ProcessFlowsEntity |
ProcessFlowUnsuccessful |
ProcessPipeLineException |
ResultCode | This class is used to get the result of Script based Steps.
SaveGEObject |
SingleStepView |
StepLog |
ValueCheckerBase | Base class for Aptify Generic Value Retriever and Value Tester Process Components
ValueRetriever | This class is used to retrieve values from either a GE object or from an entity, or the context object. Simply provide the Entity Object or Entity Name and Record ID, and provide the field name to be retrieved and the value will be returned as the RESULT CODE for the component
ValueTester | This class is capable of testing any value against another value. It is useful for doing quick checks against database or context object values to determine workflow logic.
vCalendarBase | Base class for Aptify Generic vCalendar Writer and Reader
vCalendarReader | This class is NOT implemented, and will in the future contain an implementation to read the contents of a vCalendar file and parse the file into properties.
vCalendarWriter | This class is used to create a vCalendar file based on the provided input properties
VirtualFieldUpdateProcessComponent | Updates linked virtual fields based on foreign key changes.

Interfaces

Interface | Description
IProcessComponent | This is the interface an object must implement to be included as a Process Component in a Process Flow. The interface defines methods needed for an object to participate as a step in a Process Flow. If you are implementing this interface for a component, consider using the ProcessComponentBase class as a starting point for a sub-class rather than directly implementing this interface as the base class provides some standard functionality.
IProcessFlow | Provides a mechanism for components to be run as a Process Flow.
IProcessFlowCompiler | Compiles a Process Flow into executable code.

Structures

Structure | Description
ProcessFlowResult | The result of a Process Flow run.

Delegates

Delegate | Description
ProcessFlowDebugInfo.HandleBreakpointEventHandler |

Enumerations

Enumeration | Description
ProcessFlowDebugInfo.BreakPointInfo.BreakpointMode |
ProcessFlowDebugInfo.BreakPointResult | Results that the listener of the HandleBreakpoint event pass back to the event to indicate the next step the process flow engine should take.
ProcessFlowExecutionRule.ExecutionRuleResultReasons | Defines a set of known failure results.
ProcessFlowExecutionRule.ExecutionRuleResults | Defines a set of results to be used by the process flow engine in determining how to execute a process flow.
ProcessFlowExecutionRule.PermissionTypes | Defines a set characteristics of a user's ability to execute the process flow.


AptifyEventFire Class

For a list of all members of this type, see AptifyEventFire Members.

System.Object
AptifyEventFire

public class AptifyEventFire

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline

Assembly: AptifyEventFire (in AptifyEventFire.dll)

See Also

AptifyEventFire Members | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


AptifyEventFire Members

AptifyEventFire overview

Public Instance Constructors

AptifyEventFire Constructor

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FireApplicationEvent |
FireEntityEvent |
FireEntityValidationEvent |
FireGlobalEvent |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

ExecuteScript | This function will Initialize the Script Engine Based on the [Events] Script Type.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyEventFire Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


AptifyEventFire Constructor

public AptifyEventFire(
UserCredentials UserCredentials
);

See Also

AptifyEventFire Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


AptifyEventFire Methods

The methods of the AptifyEventFire class are listed below. For a complete list of AptifyEventFire class members, see the AptifyEventFire Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FireApplicationEvent |
FireEntityEvent |
FireEntityValidationEvent |
FireGlobalEvent |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

ExecuteScript | This function will Initialize the Script Engine Based on the [Events] Script Type.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AptifyEventFire Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


AptifyEventFire.ExecuteScript Method

This function will Initialize the Script Engine Based on the [Events] Script Type.

protected virtual ValidationScriptResult ExecuteScript(
String EventDefinitionName,
AptifyGenericEntityBase GE,
String ScriptToExecute
);

Parameters

EventDefinitionName
The name of the event definition that is running the filter trigger.
GE
A configured GE that will be used for the script to interact with.
ScriptToExecute
Ad-Hoc VB Script

Return Value

This will return an instantiated ValidationScriptResult that contains the result of the script execution.

Remarks

If you want to use a Script Type other than [Events], then this should be overriden. This can also be overriden if you would like multiple script types to be run.

       'We do not allow the key value to change once we save.
       If geRecord.RecordID > 0 Then
           'This is an existing record
           'Check to see if the value has changed
           If geRecord.Fields("KeyValue").IsDirty Then
               oResult.Success = False
               oResult.Message = "Once a key has been saved you may not change its value."
           Else
               oResult.Message = "There were no problems with the KeyValue"
               oResult.Success = True
           End If
       Else
           oResult.Message = "This is a new record we do not need to validate the KeyValue."
           oResult.Success = True
       End If

See Also

AptifyEventFire Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


AptifyEventFire.FireApplicationEvent Method

public virtual bool FireApplicationEvent(
String EventName,
Int64 ApplicationID,
AptifyContext Context,
ref String& ErrorString
);

See Also

AptifyEventFire Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


AptifyEventFire.FireEntityEvent Method

public virtual bool FireEntityEvent(
String EventName,
AptifyGenericEntityBase GE,
ref String& ErrorString
);

See Also

AptifyEventFire Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


AptifyEventFire.FireEntityValidationEvent Method

public virtual bool FireEntityValidationEvent(
String EventName,
AptifyGenericEntityBase GE,
ref String& ValidationMessage
);

See Also

AptifyEventFire Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


AptifyEventFire.FireGlobalEvent Method

public virtual bool FireGlobalEvent(
String EventName,
AptifyContext Context,
ref String& ErrorString
);

See Also

AptifyEventFire Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


BreakPointEditor Class

Used for viewing/editing breakpoints for a process flow debug run

For a list of all members of this type, see BreakPointEditor Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
BreakPointEditor

public class BreakPointEditor : UserControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline

Assembly: ProcessFlowDebugHarness (in ProcessFlowDebugHarness.dll)

See Also

BreakPointEditor Members | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


BreakPointEditor Members

BreakPointEditor overview

Public Instance Constructors

BreakPointEditor Constructor Initializes a new instance of the BreakPointEditor class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from UserControl) |
AutoSizeMode (inherited from UserControl) | Gets or sets how the control will resize itself.
AutoValidate (inherited from UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
BorderStyle (inherited from UserControl) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LoadBreakpoints |
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
UpdateData |
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Public Instance Events

AutoSizeChanged (inherited from UserControl) |
AutoValidateChanged (inherited from UserControl) | Occurs when the AutoValidate property changes.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from UserControl) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
ApplySkin |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

BreakPointEditor Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


BreakPointEditor Constructor

Initializes a new instance of the BreakPointEditor class.

public BreakPointEditor();

See Also

BreakPointEditor Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


BreakPointEditor Methods

The methods of the BreakPointEditor class are listed below. For a complete list of BreakPointEditor class members, see the BreakPointEditor Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LoadBreakpoints |
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
UpdateData |
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from UserControl) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ContainerControl) |
ApplySkin |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from ContainerControl) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ContainerControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from UserControl) |
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from ContainerControl) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from ContainerControl) | Overloaded.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from ContainerControl) | When overridden by a derived class, updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

BreakPointEditor Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


BreakPointEditor.ApplySkin Method

protected virtual void ApplySkin();

See Also

BreakPointEditor Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

BreakPointEditor.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

BreakPointEditor Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


BreakPointEditor.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

BreakPointEditor Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace | BreakPointEditor.Dispose Overload List


BreakPointEditor.LoadBreakpoints Method

public void LoadBreakpoints(
AptifyApplication Application,
DataAction DataAction,
Int64 ProcessFlowID,
List<T> Breakpoints
);

See Also

BreakPointEditor Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


BreakPointEditor.UpdateData Method

public void UpdateData();

See Also

BreakPointEditor Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


CompileProcessFlowComponent Class

Process Flow Component that is used to compile Process Flows into a DLL.

For a list of all members of this type, see CompileProcessFlowComponent Members.

System.Object
CompileProcessFlowComponent

public class CompileProcessFlowComponent : IProcessComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline

Assembly: AptifyProcessFlowEngine (in AptifyProcessFlowEngine.dll)

See Also

CompileProcessFlowComponent Members | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


CompileProcessFlowComponent Members

CompileProcessFlowComponent overview

Public Instance Constructors

CompileProcessFlowComponent Constructor Initializes a new instance of the CompileProcessFlowComponent class.

Public Instance Properties

Properties Provides a storage mechanism that is used throughout the course of the Process Component's lifecycle.

Public Instance Methods

Config | Configures the component so it can function.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run | Runs the process component.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CompileProcessFlowComponent Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


CompileProcessFlowComponent Constructor

Initializes a new instance of the CompileProcessFlowComponent class.

public CompileProcessFlowComponent();

See Also

CompileProcessFlowComponent Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


CompileProcessFlowComponent Properties

The properties of the CompileProcessFlowComponent class are listed below. For a complete list of CompileProcessFlowComponent class members, see the CompileProcessFlowComponent Members topic.

Public Instance Properties

Properties Provides a storage mechanism that is used throughout the course of the Process Component's lifecycle.

See Also

CompileProcessFlowComponent Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


Properties Property

Aptify 5.0 Software Development Kit (SDK)

CompileProcessFlowComponent.Properties Property

Provides a storage mechanism that is used throughout the course of the Process Component's lifecycle.

public AptifyProperties Properties {get;}

Property Value

Implements

IProcessComponent.

Remarks

ProcessFlowID should be passed in as a property. This is the ID of the Process Flow to be compiled.

See Also

CompileProcessFlowComponent Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


CompileProcessFlowComponent Methods

The methods of the CompileProcessFlowComponent class are listed below. For a complete list of CompileProcessFlowComponent class members, see the CompileProcessFlowComponent Members topic.

Public Instance Methods

Config | Configures the component so it can function.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run | Runs the process component.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CompileProcessFlowComponent Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


CompileProcessFlowComponent.Config Method

Configures the component so it can function.

public void Config(
AptifyApplication ApplicationObject
);

Implements

IProcessComponent.

Remarks

This component will look for Entity attributes on the [Process Flows] entity. The attributes will control the object that is used to compile a Process Flow. The Attribute Names are CompilerObject, CompilerAssembly, and CompilerClass. The attributes should point to an object that implement IProcessFlowCompiler. If these attributes are not supplied, then the following values will be used respectively, [Startup.AptifyProcessFlowEngine],[AptifyProcessFlowEngine],and [Aptify.Framework.BusinessLogic.ProcessPipeline.ProcessFlowCompiler].

See Also

CompileProcessFlowComponent Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace | ProcessFlowCompiler


CompileProcessFlowComponent.Run Method

Runs the process component.

public string Run();

Return Value

Compiled if the compile was a succes. Error if there was a problem compiling.

Implements

IProcessComponent.

Remarks

This will attempt to compile the specified Process Flow in to a compiled DLL. The DLL will then be stored in the object repository. It will updated the Process Flow's CompiledStatus, CompiledObject, CompiledAssemblyName, and CompiledClass properties based on the results of the compile.

See Also

CompileProcessFlowComponent Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


CurrentStepDialog Class

View/Edit Current Step Information During Debugging

For a list of all members of this type, see CurrentStepDialog Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
CurrentStepDialog

public class CurrentStepDialog : Form

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline

Assembly: ProcessFlowDebugHarness (in ProcessFlowDebugHarness.dll)

See Also

CurrentStepDialog Members | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


CurrentStepDialog Members

CurrentStepDialog overview

Public Instance Constructors

CurrentStepDialog Constructor Initializes a new instance of the CurrentStepDialog class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Result |
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
LoadStep |
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CurrentStepDialog Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


CurrentStepDialog Constructor

Initializes a new instance of the CurrentStepDialog class.

public CurrentStepDialog();

See Also

CurrentStepDialog Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


CurrentStepDialog Properties

The properties of the CurrentStepDialog class are listed below. For a complete list of CurrentStepDialog class members, see the CurrentStepDialog Members topic.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Result |
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

CurrentStepDialog Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


Result Property

Aptify 5.0 Software Development Kit (SDK)

CurrentStepDialog.Result Property

public virtual ProcessFlowDebugInfo.BreakPointResult Result {get;}

See Also

CurrentStepDialog Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


CurrentStepDialog Methods

The methods of the CurrentStepDialog class are listed below. For a complete list of CurrentStepDialog class members, see the CurrentStepDialog Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
LoadStep |
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

CurrentStepDialog Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


CurrentStepDialog.ApplySkin Method

protected virtual void ApplySkin();

See Also

CurrentStepDialog Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


Dispose Method

Aptify 5.0 Software Development Kit (SDK)

CurrentStepDialog.Dispose Method

Overload List

Inherited from Component.

public void Dispose();

protected override void Dispose(Boolean);

See Also

CurrentStepDialog Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


CurrentStepDialog.Dispose Method (Boolean)

protected override void Dispose(
Boolean disposing
);

See Also

CurrentStepDialog Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace | CurrentStepDialog.Dispose Overload List


CurrentStepDialog.LoadStep Method

public void LoadStep(
ProcessFlowDebugInfo DebugInfo,
Int64 StepID,
AptifyContext Context,
AptifyApplication Application,
DataAction DataAction
);

See Also

CurrentStepDialog Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


EventCache Class

For a list of all members of this type, see EventCache Members.

System.Object
EventCache

public class EventCache

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline

Assembly: AptifyEventFire (in AptifyEventFire.dll)

See Also

EventCache Members | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


EventCache Members

EventCache overview

Public Static Methods

Instance

Public Instance Constructors

EventCache Constructor

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Refresh |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EventCache Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


EventCache Constructor

public EventCache(
AptifyApplication Application
);

See Also

EventCache Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


EventCache Methods

The methods of the EventCache class are listed below. For a complete list of EventCache class members, see the EventCache Members topic.

Public Static Methods

Instance

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Refresh |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EventCache Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


EventCache.Instance Method

public static EventCache Instance(
AptifyApplication Application
);

See Also

EventCache Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


EventCache.Refresh Method

public void Refresh();

See Also

EventCache Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


EventFireConstants Class

For a list of all members of this type, see EventFireConstants Members.

System.Object
EventFireConstants

public class EventFireConstants

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline

Assembly: AptifyEventFire (in AptifyEventFire.dll)

See Also

EventFireConstants Members | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


EventFireConstants Members

EventFireConstants overview

Public Static Methods

ApplicationEventDoesNotExistMessage
EntityEventDoesNotExistMessage
EventDoesNotExistMessage
GetResourceString
GlobalEventDoesNotExistMessage

Public Instance Constructors

EventFireConstants Constructor Initializes a new instance of the EventFireConstants class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EventFireConstants Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


EventFireConstants Constructor

Initializes a new instance of the EventFireConstants class.

public EventFireConstants();

See Also

EventFireConstants Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


EventFireConstants Methods

The methods of the EventFireConstants class are listed below. For a complete list of EventFireConstants class members, see the EventFireConstants Members topic.

Public Static Methods

ApplicationEventDoesNotExistMessage
EntityEventDoesNotExistMessage
EventDoesNotExistMessage
GetResourceString
GlobalEventDoesNotExistMessage

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EventFireConstants Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


EventFireConstants.ApplicationEventDoesNotExistMessage Method

public static string ApplicationEventDoesNotExistMessage(
String EventName,
Int64 ApplicationID
);

See Also

EventFireConstants Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


EventFireConstants.EntityEventDoesNotExistMessage Method

public static string EntityEventDoesNotExistMessage(
String EventName,
Int64 EntityID
);

See Also

EventFireConstants Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


EventFireConstants.EventDoesNotExistMessage Method

public static string EventDoesNotExistMessage(
String EventName
);

See Also

EventFireConstants Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


EventFireConstants.GetResourceString Method

public static string GetResourceString(
String ResourceKey
);

See Also

EventFireConstants Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


EventFireConstants.GlobalEventDoesNotExistMessage Method

public static string GlobalEventDoesNotExistMessage(
String EventName
);

See Also

EventFireConstants Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ExecutionRuleException Class

For a list of all members of this type, see ExecutionRuleException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
AptifyApplicationException
ExecutionRuleException

public class ExecutionRuleException : AptifyApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline

Assembly: AptifyProcessFlowEngine (in AptifyProcessFlowEngine.dll)

See Also

ExecutionRuleException Members | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ExecutionRuleException Members

ExecutionRuleException overview

Public Instance Constructors

ExecutionRuleException Constructor Initializes a new instance of the ExecutionRuleException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from AptifyApplicationException) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExecutionRuleException Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ExecutionRuleException Constructor

Initializes a new instance of the ExecutionRuleException class.

public ExecutionRuleException();

See Also

ExecutionRuleException Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


GenericCreateRecord Class

Generic Process Component for creating new records for both Top-Level and Sub-Type entities

For a list of all members of this type, see GenericCreateRecord Members.

System.Object
GenericCRUDBase
GenericCreateRecord

public class GenericCreateRecord : GenericCRUDBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline

Assembly: EntityCRUDProcessComponents (in EntityCRUDProcessComponents.dll)

See Also

GenericCreateRecord Members | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


GenericCreateRecord Members

GenericCreateRecord overview

Public Instance Constructors

GenericCreateRecord Constructor Initializes a new instance of the GenericCreateRecord class.

Public Instance Properties

EntityName (inherited from GenericCRUDBase) | This member returns the name of the entity being operated upon by the component instance
ParentGE (inherited from GenericCRUDBase) | This property is a strongly typed return for the ParentGEObject (or ParentGE) property in the AptifyProperties context object for this control. This member returns the ParentGE object.
ProcessComponentID (inherited from GenericCRUDBase) | Returns the Process Component ID in use for the current instance of the class
Properties (inherited from GenericCRUDBase) | Aptify Properties Collection used for Input and Output Properties for the component.

Public Instance Methods

Config (inherited from GenericCRUDBase) | This method must be called before any other member of this class is accessed
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsSubType (inherited from GenericCRUDBase) | This member returns true if the current entity is a sub-type, and false if it is not a sub-type(e.g. a top level entity)
Run | Implementation of the IProcessComponent.Run() method which will execute the function of creating a new record in the database based on the InitData and provided Input Properties. The new record ID will be returned via the RecordID Output Property and the GE Object created will be returned via the GEObject output property as well.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

Application (inherited from GenericCRUDBase) | Aptify Application Object
InitData (inherited from GenericCRUDBase) | This method returns the InitData string for processing as required by ParseInitData() or other methods.
InitDataItems (inherited from GenericCRUDBase) | This member will return a dictionary of init data items (string values) that are keyed based on their attribute name. For example, for the Init Data string that contains a single XML node of Entity with a value of "Demo Entity", this dictionary will have one entry with a value of "Demo Entity" keyed as "Entity".
InitDataXMLDoc (inherited from GenericCRUDBase) | This member returns an instance of the System.Xml.XmlDocument class that is instantiated and loaded with the InitData from the Form Component record for this instance of the component. This method is used by ParseInitData and other internal members of the base class in order to access initialization attributes from the Form Component record. Utilize this method to access the XML attributes of the InitData string.
SaveRecordProperty (inherited from GenericCRUDBase) | This member provides a type-specific access for reading the value of the Save Record Input Property for the Process Flow Step. The Save Record Input Property has two possible values in the Process Flow meta-data, Yes and No as text strings. This member translates those text values to Boolean type values as a utility for functionality that requires checks against this process flow input property.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetGEObject (inherited from GenericCRUDBase) | This method is designed to be used as a utility by sub-classes to retrieve the GE object to be used for Read/Update/Delete operations. This method will retrieve either the Top-Level object corresponding to the RecordID input property or the Sub-Type object relative to the SubTypeName and Sequence input properties. If CheckGEObjectProperty is set to True, this method first checks the GEObject input property, and if that is provided, will return the GEObject input property.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ParseInitData (inherited from GenericCRUDBase) | This method is called when necessary by the component internally to access "Init Data", which is the InitData field in the Process Component record. This information is necessary to determine the name of the entity and other properties that can vary from one Process Component meta-data record to another. Since the Entity CRUD components are generic in nature, they have no inherent knowledge of which entity they are bound to at a given time. That is the key to what Process Component InitData strings tell the components - the Entity Name, among other attributes. In sub-classes, this method can be overriden to access the underlying InitData string directly to access other attributes from the string in addition to the Entity Name which is the single attribute extracted by the base class implementation of this method.
SetDataFields (inherited from GenericCRUDBase) | This method is used to set the values of the specified GEObject to the values that have been provided in the Input Properties for the Process Flow Step and are resident in the Properties collection for this instance.

See Also

GenericCreateRecord Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


GenericCreateRecord Constructor

Initializes a new instance of the GenericCreateRecord class.

public GenericCreateRecord();

See Also

GenericCreateRecord Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


GenericCreateRecord Methods

The methods of the GenericCreateRecord class are listed below. For a complete list of GenericCreateRecord class members, see the GenericCreateRecord Members topic.

Public Instance Methods

Config (inherited from GenericCRUDBase) | This method must be called before any other member of this class is accessed
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsSubType (inherited from GenericCRUDBase) | This member returns true if the current entity is a sub-type, and false if it is not a sub-type(e.g. a top level entity)
Run | Implementation of the IProcessComponent.Run() method which will execute the function of creating a new record in the database based on the InitData and provided Input Properties. The new record ID will be returned via the RecordID Output Property and the GE Object created will be returned via the GEObject output property as well.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetGEObject (inherited from GenericCRUDBase) | This method is designed to be used as a utility by sub-classes to retrieve the GE object to be used for Read/Update/Delete operations. This method will retrieve either the Top-Level object corresponding to the RecordID input property or the Sub-Type object relative to the SubTypeName and Sequence input properties. If CheckGEObjectProperty is set to True, this method first checks the GEObject input property, and if that is provided, will return the GEObject input property.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ParseInitData (inherited from GenericCRUDBase) | This method is called when necessary by the component internally to access "Init Data", which is the InitData field in the Process Component record. This information is necessary to determine the name of the entity and other properties that can vary from one Process Component meta-data record to another. Since the Entity CRUD components are generic in nature, they have no inherent knowledge of which entity they are bound to at a given time. That is the key to what Process Component InitData strings tell the components - the Entity Name, among other attributes. In sub-classes, this method can be overriden to access the underlying InitData string directly to access other attributes from the string in addition to the Entity Name which is the single attribute extracted by the base class implementation of this method.
SetDataFields (inherited from GenericCRUDBase) | This method is used to set the values of the specified GEObject to the values that have been provided in the Input Properties for the Process Flow Step and are resident in the Properties collection for this instance.

See Also

GenericCreateRecord Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


GenericCreateRecord.Run Method

Implementation of the IProcessComponent.Run() method which will execute the function of creating a new record in the database based on the InitData and provided Input Properties. The new record ID will be returned via the RecordID Output Property and the GE Object created will be returned via the GEObject output property as well.

public override string Run();

Return Value

Success or Failed

Implements

IProcessComponent.

Remarks

See Also

GenericCreateRecord Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


GenericCRUDBase Class

Base class for all other Aptify Generic CRUD Process Components

For a list of all members of this type, see GenericCRUDBase Members.

System.Object
GenericCRUDBase
GenericCreateRecord
GenericDeleteRecord
GenericReadRecord
GenericUpdateRecord
SaveGEObject

public class GenericCRUDBase : IProcessComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline

Assembly: EntityCRUDProcessComponents (in EntityCRUDProcessComponents.dll)

See Also

GenericCRUDBase Members | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


GenericCRUDBase Members

GenericCRUDBase overview

Public Static Methods

GetTopLevelGE This method will return the top level GE object associated with any GE object. This is utilized for sub-types and embedded objects to traverse the ParentGE attribute in each such GE object until reaching the top level where the ParentGE property of the GE instance is Nothing/Null.

Public Instance Constructors

GenericCRUDBase Constructor Initializes a new instance of the GenericCRUDBase class.

Public Instance Properties

EntityName | This member returns the name of the entity being operated upon by the component instance
ParentGE | This property is a strongly typed return for the ParentGEObject (or ParentGE) property in the AptifyProperties context object for this control. This member returns the ParentGE object.
ProcessComponentID | Returns the Process Component ID in use for the current instance of the class
Properties | Aptify Properties Collection used for Input and Output Properties for the component.

Public Instance Methods

Config | This method must be called before any other member of this class is accessed
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsSubType | This member returns true if the current entity is a sub-type, and false if it is not a sub-type(e.g. a top level entity)
Run |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

Application | Aptify Application Object
InitData | This method returns the InitData string for processing as required by ParseInitData() or other methods.
InitDataItems | This member will return a dictionary of init data items (string values) that are keyed based on their attribute name. For example, for the Init Data string that contains a single XML node of Entity with a value of "Demo Entity", this dictionary will have one entry with a value of "Demo Entity" keyed as "Entity".
InitDataXMLDoc | This member returns an instance of the System.Xml.XmlDocument class that is instantiated and loaded with the InitData from the Form Component record for this instance of the component. This method is used by ParseInitData and other internal members of the base class in order to access initialization attributes from the Form Component record. Utilize this method to access the XML attributes of the InitData string.
SaveRecordProperty | This member provides a type-specific access for reading the value of the Save Record Input Property for the Process Flow Step. The Save Record Input Property has two possible values in the Process Flow meta-data, Yes and No as text strings. This member translates those text values to Boolean type values as a utility for functionality that requires checks against this process flow input property.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetGEObject | This method is designed to be used as a utility by sub-classes to retrieve the GE object to be used for Read/Update/Delete operations. This method will retrieve either the Top-Level object corresponding to the RecordID input property or the Sub-Type object relative to the SubTypeName and Sequence input properties. If CheckGEObjectProperty is set to True, this method first checks the GEObject input property, and if that is provided, will return the GEObject input property.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ParseInitData | This method is called when necessary by the component internally to access "Init Data", which is the InitData field in the Process Component record. This information is necessary to determine the name of the entity and other properties that can vary from one Process Component meta-data record to another. Since the Entity CRUD components are generic in nature, they have no inherent knowledge of which entity they are bound to at a given time. That is the key to what Process Component InitData strings tell the components - the Entity Name, among other attributes. In sub-classes, this method can be overriden to access the underlying InitData string directly to access other attributes from the string in addition to the Entity Name which is the single attribute extracted by the base class implementation of this method.
SetDataFields | This method is used to set the values of the specified GEObject to the values that have been provided in the Input Properties for the Process Flow Step and are resident in the Properties collection for this instance.

See Also

GenericCRUDBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


GenericCRUDBase Constructor

Initializes a new instance of the GenericCRUDBase class.

public GenericCRUDBase();

See Also

GenericCRUDBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


GenericCRUDBase Properties

The properties of the GenericCRUDBase class are listed below. For a complete list of GenericCRUDBase class members, see the GenericCRUDBase Members topic.

Public Instance Properties

EntityName | This member returns the name of the entity being operated upon by the component instance
ParentGE | This property is a strongly typed return for the ParentGEObject (or ParentGE) property in the AptifyProperties context object for this control. This member returns the ParentGE object.
ProcessComponentID | Returns the Process Component ID in use for the current instance of the class
Properties | Aptify Properties Collection used for Input and Output Properties for the component.

Protected Instance Properties

Application | Aptify Application Object
InitData | This method returns the InitData string for processing as required by ParseInitData() or other methods.
InitDataItems | This member will return a dictionary of init data items (string values) that are keyed based on their attribute name. For example, for the Init Data string that contains a single XML node of Entity with a value of "Demo Entity", this dictionary will have one entry with a value of "Demo Entity" keyed as "Entity".
InitDataXMLDoc | This member returns an instance of the System.Xml.XmlDocument class that is instantiated and loaded with the InitData from the Form Component record for this instance of the component. This method is used by ParseInitData and other internal members of the base class in order to access initialization attributes from the Form Component record. Utilize this method to access the XML attributes of the InitData string.
SaveRecordProperty | This member provides a type-specific access for reading the value of the Save Record Input Property for the Process Flow Step. The Save Record Input Property has two possible values in the Process Flow meta-data, Yes and No as text strings. This member translates those text values to Boolean type values as a utility for functionality that requires checks against this process flow input property.

See Also

GenericCRUDBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


Application Property

Aptify 5.0 Software Development Kit (SDK)

GenericCRUDBase.Application Property

Aptify Application Object

protected virtual AptifyApplication Application {get;}

Property Value

Remarks

See Also

GenericCRUDBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


EntityName Property

Aptify 5.0 Software Development Kit (SDK)

GenericCRUDBase.EntityName Property

This member returns the name of the entity being operated upon by the component instance

public virtual String EntityName {get;}

Property Value

Remarks

See Also

GenericCRUDBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


InitData Property

Aptify 5.0 Software Development Kit (SDK)

GenericCRUDBase.InitData Property

This method returns the InitData string for processing as required by ParseInitData() or other methods.

protected virtual String InitData {get;}

Property Value

Remarks

See Also

GenericCRUDBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


InitDataItems Property

Aptify 5.0 Software Development Kit (SDK)

GenericCRUDBase.InitDataItems Property

This member will return a dictionary of init data items (string values) that are keyed based on their attribute name. For example, for the Init Data string that contains a single XML node of Entity with a value of "Demo Entity", this dictionary will have one entry with a value of "Demo Entity" keyed as "Entity".

protected virtual Dictionary<TKey,TValue> InitDataItems {get;}

Property Value

Remarks

Important Note: ALL KEYS/ATTRIBUTE NAMES ARE LOWER CASE, make sure you use lower case in doing key lookups for attributes in the dictionary

See Also

GenericCRUDBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


InitDataXMLDoc Property

Aptify 5.0 Software Development Kit (SDK)

GenericCRUDBase.InitDataXMLDoc Property

This member returns an instance of the System.Xml.XmlDocument class that is instantiated and loaded with the InitData from the Form Component record for this instance of the component. This method is used by ParseInitData and other internal members of the base class in order to access initialization attributes from the Form Component record. Utilize this method to access the XML attributes of the InitData string.

protected virtual XmlDocument InitDataXMLDoc {get;}

Property Value

Remarks

Changes made to the XML Document returned will NOT have any persistent effect, the instance of the XML Document returned is not reused or linked to other internal component attributes.

See Also

GenericCRUDBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ParentGE Property

Aptify 5.0 Software Development Kit (SDK)

GenericCRUDBase.ParentGE Property

This property is a strongly typed return for the ParentGEObject (or ParentGE) property in the AptifyProperties context object for this control. This member returns the ParentGE object.

public AptifyGenericEntityBase ParentGE {get;}

Property Value

Remarks

See Also

GenericCRUDBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessComponentID Property

Aptify 5.0 Software Development Kit (SDK)

GenericCRUDBase.ProcessComponentID Property

Returns the Process Component ID in use for the current instance of the class

public virtual Int64 ProcessComponentID {get;}

Property Value

Remarks

See Also

GenericCRUDBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


Properties Property

Aptify 5.0 Software Development Kit (SDK)

GenericCRUDBase.Properties Property

Aptify Properties Collection used for Input and Output Properties for the component.

public virtual AptifyProperties Properties {get;}

Property Value

Implements

IProcessComponent.

Remarks

See Also

GenericCRUDBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


SaveRecordProperty Property

Aptify 5.0 Software Development Kit (SDK)

GenericCRUDBase.SaveRecordProperty Property

This member provides a type-specific access for reading the value of the Save Record Input Property for the Process Flow Step. The Save Record Input Property has two possible values in the Process Flow meta-data, Yes and No as text strings. This member translates those text values to Boolean type values as a utility for functionality that requires checks against this process flow input property.

protected virtual Boolean SaveRecordProperty {get;}

Property Value

Remarks

See Also

GenericCRUDBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


GenericCRUDBase Methods

The methods of the GenericCRUDBase class are listed below. For a complete list of GenericCRUDBase class members, see the GenericCRUDBase Members topic.

Public Static Methods

GetTopLevelGE This method will return the top level GE object associated with any GE object. This is utilized for sub-types and embedded objects to traverse the ParentGE attribute in each such GE object until reaching the top level where the ParentGE property of the GE instance is Nothing/Null.

Public Instance Methods

Config | This method must be called before any other member of this class is accessed
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsSubType | This member returns true if the current entity is a sub-type, and false if it is not a sub-type(e.g. a top level entity)
Run |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetGEObject | This method is designed to be used as a utility by sub-classes to retrieve the GE object to be used for Read/Update/Delete operations. This method will retrieve either the Top-Level object corresponding to the RecordID input property or the Sub-Type object relative to the SubTypeName and Sequence input properties. If CheckGEObjectProperty is set to True, this method first checks the GEObject input property, and if that is provided, will return the GEObject input property.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ParseInitData | This method is called when necessary by the component internally to access "Init Data", which is the InitData field in the Process Component record. This information is necessary to determine the name of the entity and other properties that can vary from one Process Component meta-data record to another. Since the Entity CRUD components are generic in nature, they have no inherent knowledge of which entity they are bound to at a given time. That is the key to what Process Component InitData strings tell the components - the Entity Name, among other attributes. In sub-classes, this method can be overriden to access the underlying InitData string directly to access other attributes from the string in addition to the Entity Name which is the single attribute extracted by the base class implementation of this method.
SetDataFields | This method is used to set the values of the specified GEObject to the values that have been provided in the Input Properties for the Process Flow Step and are resident in the Properties collection for this instance.

See Also

GenericCRUDBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


GenericCRUDBase.Config Method

This method must be called before any other member of this class is accessed

public virtual void Config(
AptifyApplication ApplicationObject
);

Parameters

ApplicationObject

Implements

IProcessComponent.

Remarks

See Also

GenericCRUDBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


GenericCRUDBase.GetGEObject Method

This method is designed to be used as a utility by sub-classes to retrieve the GE object to be used for Read/Update/Delete operations. This method will retrieve either the Top-Level object corresponding to the RecordID input property or the Sub-Type object relative to the SubTypeName and Sequence input properties. If CheckGEObjectProperty is set to True, this method first checks the GEObject input property, and if that is provided, will return the GEObject input property.

protected virtual AptifyGenericEntityBase GetGEObject(
Boolean CheckGEObjectProperty
);

Return Value

Remarks

Sequence Input Property is 1-relative as is the data in the database for Sequence values. In the object model, the index values are zero-relative, so this method translates the Sequence Input Property provided by the Input Property to a zero-relative value.

See Also

GenericCRUDBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


GenericCRUDBase.GetTopLevelGE Method

This method will return the top level GE object associated with any GE object. This is utilized for sub-types and embedded objects to traverse the ParentGE attribute in each such GE object until reaching the top level where the ParentGE property of the GE instance is Nothing/Null.

public static AptifyGenericEntityBase GetTopLevelGE(
AptifyGenericEntityBase oGE
);

Parameters

oGE

Return Value

Remarks

See Also

GenericCRUDBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


GenericCRUDBase.IsSubType Method

This member returns true if the current entity is a sub-type, and false if it is not a sub-type(e.g. a top level entity)

public virtual bool IsSubType();

Return Value

Remarks

See Also

GenericCRUDBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


GenericCRUDBase.ParseInitData Method

This method is called when necessary by the component internally to access "Init Data", which is the InitData field in the Process Component record. This information is necessary to determine the name of the entity and other properties that can vary from one Process Component meta-data record to another. Since the Entity CRUD components are generic in nature, they have no inherent knowledge of which entity they are bound to at a given time. That is the key to what Process Component InitData strings tell the components - the Entity Name, among other attributes. In sub-classes, this method can be overriden to access the underlying InitData string directly to access other attributes from the string in addition to the Entity Name which is the single attribute extracted by the base class implementation of this method.

protected virtual void ParseInitData();

Remarks

See Also

GenericCRUDBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


GenericCRUDBase.Run Method

public abstract string Run();

Implements

IProcessComponent.

See Also

GenericCRUDBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


GenericCRUDBase.SetDataFields Method

This method is used to set the values of the specified GEObject to the values that have been provided in the Input Properties for the Process Flow Step and are resident in the Properties collection for this instance.

protected virtual bool SetDataFields(
AptifyGenericEntityBase GEObject,
Boolean IgnoreBlankValues
);

Parameters

GEObject
The Generic Entity Instance
IgnoreBlankValues
If set to True, blank values in the Input Property collection will be ignored and NOT set into the GEObject field(s). If set to False, blank values will used and set into the field values in the GEObject

Return Value

True if the operation is successful, False otherwise

Remarks

See Also

GenericCRUDBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


GenericDeleteRecord Class

Generic Process Component for deleting records for both Top-Level and Sub-Type entities

For a list of all members of this type, see GenericDeleteRecord Members.

System.Object
GenericCRUDBase
GenericDeleteRecord

public class GenericDeleteRecord : GenericCRUDBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline

Assembly: EntityCRUDProcessComponents (in EntityCRUDProcessComponents.dll)

See Also

GenericDeleteRecord Members | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


GenericDeleteRecord Members

GenericDeleteRecord overview

Public Instance Constructors

GenericDeleteRecord Constructor Initializes a new instance of the GenericDeleteRecord class.

Public Instance Properties

EntityName (inherited from GenericCRUDBase) | This member returns the name of the entity being operated upon by the component instance
ParentGE (inherited from GenericCRUDBase) | This property is a strongly typed return for the ParentGEObject (or ParentGE) property in the AptifyProperties context object for this control. This member returns the ParentGE object.
ProcessComponentID (inherited from GenericCRUDBase) | Returns the Process Component ID in use for the current instance of the class
Properties (inherited from GenericCRUDBase) | Aptify Properties Collection used for Input and Output Properties for the component.

Public Instance Methods

Config (inherited from GenericCRUDBase) | This method must be called before any other member of this class is accessed
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsSubType (inherited from GenericCRUDBase) | This member returns true if the current entity is a sub-type, and false if it is not a sub-type(e.g. a top level entity)
Run | Implementation of the IProcessComponent.Run() method which will execute the function of deleting a record in the database based on the InitData and provided Input Properties.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

Application (inherited from GenericCRUDBase) | Aptify Application Object
InitData (inherited from GenericCRUDBase) | This method returns the InitData string for processing as required by ParseInitData() or other methods.
InitDataItems (inherited from GenericCRUDBase) | This member will return a dictionary of init data items (string values) that are keyed based on their attribute name. For example, for the Init Data string that contains a single XML node of Entity with a value of "Demo Entity", this dictionary will have one entry with a value of "Demo Entity" keyed as "Entity".
InitDataXMLDoc (inherited from GenericCRUDBase) | This member returns an instance of the System.Xml.XmlDocument class that is instantiated and loaded with the InitData from the Form Component record for this instance of the component. This method is used by ParseInitData and other internal members of the base class in order to access initialization attributes from the Form Component record. Utilize this method to access the XML attributes of the InitData string.
SaveRecordProperty (inherited from GenericCRUDBase) | This member provides a type-specific access for reading the value of the Save Record Input Property for the Process Flow Step. The Save Record Input Property has two possible values in the Process Flow meta-data, Yes and No as text strings. This member translates those text values to Boolean type values as a utility for functionality that requires checks against this process flow input property.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetGEObject (inherited from GenericCRUDBase) | This method is designed to be used as a utility by sub-classes to retrieve the GE object to be used for Read/Update/Delete operations. This method will retrieve either the Top-Level object corresponding to the RecordID input property or the Sub-Type object relative to the SubTypeName and Sequence input properties. If CheckGEObjectProperty is set to True, this method first checks the GEObject input property, and if that is provided, will return the GEObject input property.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ParseInitData (inherited from GenericCRUDBase) | This method is called when necessary by the component internally to access "Init Data", which is the InitData field in the Process Component record. This information is necessary to determine the name of the entity and other properties that can vary from one Process Component meta-data record to another. Since the Entity CRUD components are generic in nature, they have no inherent knowledge of which entity they are bound to at a given time. That is the key to what Process Component InitData strings tell the components - the Entity Name, among other attributes. In sub-classes, this method can be overriden to access the underlying InitData string directly to access other attributes from the string in addition to the Entity Name which is the single attribute extracted by the base class implementation of this method.
SetDataFields (inherited from GenericCRUDBase) | This method is used to set the values of the specified GEObject to the values that have been provided in the Input Properties for the Process Flow Step and are resident in the Properties collection for this instance.

See Also

GenericDeleteRecord Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


GenericDeleteRecord Constructor

Initializes a new instance of the GenericDeleteRecord class.

public GenericDeleteRecord();

See Also

GenericDeleteRecord Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


GenericDeleteRecord Methods

The methods of the GenericDeleteRecord class are listed below. For a complete list of GenericDeleteRecord class members, see the GenericDeleteRecord Members topic.

Public Instance Methods

Config (inherited from GenericCRUDBase) | This method must be called before any other member of this class is accessed
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsSubType (inherited from GenericCRUDBase) | This member returns true if the current entity is a sub-type, and false if it is not a sub-type(e.g. a top level entity)
Run | Implementation of the IProcessComponent.Run() method which will execute the function of deleting a record in the database based on the InitData and provided Input Properties.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetGEObject (inherited from GenericCRUDBase) | This method is designed to be used as a utility by sub-classes to retrieve the GE object to be used for Read/Update/Delete operations. This method will retrieve either the Top-Level object corresponding to the RecordID input property or the Sub-Type object relative to the SubTypeName and Sequence input properties. If CheckGEObjectProperty is set to True, this method first checks the GEObject input property, and if that is provided, will return the GEObject input property.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ParseInitData (inherited from GenericCRUDBase) | This method is called when necessary by the component internally to access "Init Data", which is the InitData field in the Process Component record. This information is necessary to determine the name of the entity and other properties that can vary from one Process Component meta-data record to another. Since the Entity CRUD components are generic in nature, they have no inherent knowledge of which entity they are bound to at a given time. That is the key to what Process Component InitData strings tell the components - the Entity Name, among other attributes. In sub-classes, this method can be overriden to access the underlying InitData string directly to access other attributes from the string in addition to the Entity Name which is the single attribute extracted by the base class implementation of this method.
SetDataFields (inherited from GenericCRUDBase) | This method is used to set the values of the specified GEObject to the values that have been provided in the Input Properties for the Process Flow Step and are resident in the Properties collection for this instance.

See Also

GenericDeleteRecord Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


GenericDeleteRecord.Run Method

Implementation of the IProcessComponent.Run() method which will execute the function of deleting a record in the database based on the InitData and provided Input Properties.

public override string Run();

Return Value

Success or Failed

Implements

IProcessComponent.

Remarks

See Also

GenericDeleteRecord Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


GenericReadRecord Class

Generic Process Component for reading records for both Top-Level and Sub-Type entities

For a list of all members of this type, see GenericReadRecord Members.

System.Object
GenericCRUDBase
GenericReadRecord

public class GenericReadRecord : GenericCRUDBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline

Assembly: EntityCRUDProcessComponents (in EntityCRUDProcessComponents.dll)

See Also

GenericReadRecord Members | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


GenericReadRecord Members

GenericReadRecord overview

Public Instance Constructors

GenericReadRecord Constructor Initializes a new instance of the GenericReadRecord class.

Public Instance Properties

EntityName (inherited from GenericCRUDBase) | This member returns the name of the entity being operated upon by the component instance
ParentGE (inherited from GenericCRUDBase) | This property is a strongly typed return for the ParentGEObject (or ParentGE) property in the AptifyProperties context object for this control. This member returns the ParentGE object.
ProcessComponentID (inherited from GenericCRUDBase) | Returns the Process Component ID in use for the current instance of the class
Properties (inherited from GenericCRUDBase) | Aptify Properties Collection used for Input and Output Properties for the component.

Public Instance Methods

Config (inherited from GenericCRUDBase) | This method must be called before any other member of this class is accessed
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsSubType (inherited from GenericCRUDBase) | This member returns true if the current entity is a sub-type, and false if it is not a sub-type(e.g. a top level entity)
Run | Implementation of the IProcessComponent.Run() method which will execute the function of loading a record in the database based on the InitData and provided Input Properties and returning it via the GEObject output property.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

Application (inherited from GenericCRUDBase) | Aptify Application Object
InitData (inherited from GenericCRUDBase) | This method returns the InitData string for processing as required by ParseInitData() or other methods.
InitDataItems (inherited from GenericCRUDBase) | This member will return a dictionary of init data items (string values) that are keyed based on their attribute name. For example, for the Init Data string that contains a single XML node of Entity with a value of "Demo Entity", this dictionary will have one entry with a value of "Demo Entity" keyed as "Entity".
InitDataXMLDoc (inherited from GenericCRUDBase) | This member returns an instance of the System.Xml.XmlDocument class that is instantiated and loaded with the InitData from the Form Component record for this instance of the component. This method is used by ParseInitData and other internal members of the base class in order to access initialization attributes from the Form Component record. Utilize this method to access the XML attributes of the InitData string.
SaveRecordProperty (inherited from GenericCRUDBase) | This member provides a type-specific access for reading the value of the Save Record Input Property for the Process Flow Step. The Save Record Input Property has two possible values in the Process Flow meta-data, Yes and No as text strings. This member translates those text values to Boolean type values as a utility for functionality that requires checks against this process flow input property.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetGEObject (inherited from GenericCRUDBase) | This method is designed to be used as a utility by sub-classes to retrieve the GE object to be used for Read/Update/Delete operations. This method will retrieve either the Top-Level object corresponding to the RecordID input property or the Sub-Type object relative to the SubTypeName and Sequence input properties. If CheckGEObjectProperty is set to True, this method first checks the GEObject input property, and if that is provided, will return the GEObject input property.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ParseInitData (inherited from GenericCRUDBase) | This method is called when necessary by the component internally to access "Init Data", which is the InitData field in the Process Component record. This information is necessary to determine the name of the entity and other properties that can vary from one Process Component meta-data record to another. Since the Entity CRUD components are generic in nature, they have no inherent knowledge of which entity they are bound to at a given time. That is the key to what Process Component InitData strings tell the components - the Entity Name, among other attributes. In sub-classes, this method can be overriden to access the underlying InitData string directly to access other attributes from the string in addition to the Entity Name which is the single attribute extracted by the base class implementation of this method.
SetDataFields (inherited from GenericCRUDBase) | This method is used to set the values of the specified GEObject to the values that have been provided in the Input Properties for the Process Flow Step and are resident in the Properties collection for this instance.

See Also

GenericReadRecord Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


GenericReadRecord Constructor

Initializes a new instance of the GenericReadRecord class.

public GenericReadRecord();

See Also

GenericReadRecord Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


GenericReadRecord Methods

The methods of the GenericReadRecord class are listed below. For a complete list of GenericReadRecord class members, see the GenericReadRecord Members topic.

Public Instance Methods

Config (inherited from GenericCRUDBase) | This method must be called before any other member of this class is accessed
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsSubType (inherited from GenericCRUDBase) | This member returns true if the current entity is a sub-type, and false if it is not a sub-type(e.g. a top level entity)
Run | Implementation of the IProcessComponent.Run() method which will execute the function of loading a record in the database based on the InitData and provided Input Properties and returning it via the GEObject output property.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetGEObject (inherited from GenericCRUDBase) | This method is designed to be used as a utility by sub-classes to retrieve the GE object to be used for Read/Update/Delete operations. This method will retrieve either the Top-Level object corresponding to the RecordID input property or the Sub-Type object relative to the SubTypeName and Sequence input properties. If CheckGEObjectProperty is set to True, this method first checks the GEObject input property, and if that is provided, will return the GEObject input property.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ParseInitData (inherited from GenericCRUDBase) | This method is called when necessary by the component internally to access "Init Data", which is the InitData field in the Process Component record. This information is necessary to determine the name of the entity and other properties that can vary from one Process Component meta-data record to another. Since the Entity CRUD components are generic in nature, they have no inherent knowledge of which entity they are bound to at a given time. That is the key to what Process Component InitData strings tell the components - the Entity Name, among other attributes. In sub-classes, this method can be overriden to access the underlying InitData string directly to access other attributes from the string in addition to the Entity Name which is the single attribute extracted by the base class implementation of this method.
SetDataFields (inherited from GenericCRUDBase) | This method is used to set the values of the specified GEObject to the values that have been provided in the Input Properties for the Process Flow Step and are resident in the Properties collection for this instance.

See Also

GenericReadRecord Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


GenericReadRecord.Run Method

Implementation of the IProcessComponent.Run() method which will execute the function of loading a record in the database based on the InitData and provided Input Properties and returning it via the GEObject output property.

public override string Run();

Return Value

Success or Failed

Implements

IProcessComponent.

Remarks

See Also

GenericReadRecord Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


GenericUpdateRecord Class

Generic Process Component for updating records for both Top-Level and Sub-Type entities

For a list of all members of this type, see GenericUpdateRecord Members.

System.Object
GenericCRUDBase
GenericUpdateRecord

public class GenericUpdateRecord : GenericCRUDBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline

Assembly: EntityCRUDProcessComponents (in EntityCRUDProcessComponents.dll)

See Also

GenericUpdateRecord Members | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


GenericUpdateRecord Members

GenericUpdateRecord overview

Public Instance Constructors

GenericUpdateRecord Constructor Initializes a new instance of the GenericUpdateRecord class.

Public Instance Properties

EntityName (inherited from GenericCRUDBase) | This member returns the name of the entity being operated upon by the component instance
ParentGE (inherited from GenericCRUDBase) | This property is a strongly typed return for the ParentGEObject (or ParentGE) property in the AptifyProperties context object for this control. This member returns the ParentGE object.
ProcessComponentID (inherited from GenericCRUDBase) | Returns the Process Component ID in use for the current instance of the class
Properties (inherited from GenericCRUDBase) | Aptify Properties Collection used for Input and Output Properties for the component.

Public Instance Methods

Config (inherited from GenericCRUDBase) | This method must be called before any other member of this class is accessed
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsSubType (inherited from GenericCRUDBase) | This member returns true if the current entity is a sub-type, and false if it is not a sub-type(e.g. a top level entity)
Run | Implementation of the IProcessComponent.Run() method which will execute the function of updating a record in the database based on the InitData and provided Input Properties. The Record ID will be returned via the RecordID Output Property and the GE Object created will be returned via the GEObject output property as well.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

Application (inherited from GenericCRUDBase) | Aptify Application Object
InitData (inherited from GenericCRUDBase) | This method returns the InitData string for processing as required by ParseInitData() or other methods.
InitDataItems (inherited from GenericCRUDBase) | This member will return a dictionary of init data items (string values) that are keyed based on their attribute name. For example, for the Init Data string that contains a single XML node of Entity with a value of "Demo Entity", this dictionary will have one entry with a value of "Demo Entity" keyed as "Entity".
InitDataXMLDoc (inherited from GenericCRUDBase) | This member returns an instance of the System.Xml.XmlDocument class that is instantiated and loaded with the InitData from the Form Component record for this instance of the component. This method is used by ParseInitData and other internal members of the base class in order to access initialization attributes from the Form Component record. Utilize this method to access the XML attributes of the InitData string.
SaveRecordProperty (inherited from GenericCRUDBase) | This member provides a type-specific access for reading the value of the Save Record Input Property for the Process Flow Step. The Save Record Input Property has two possible values in the Process Flow meta-data, Yes and No as text strings. This member translates those text values to Boolean type values as a utility for functionality that requires checks against this process flow input property.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetGEObject (inherited from GenericCRUDBase) | This method is designed to be used as a utility by sub-classes to retrieve the GE object to be used for Read/Update/Delete operations. This method will retrieve either the Top-Level object corresponding to the RecordID input property or the Sub-Type object relative to the SubTypeName and Sequence input properties. If CheckGEObjectProperty is set to True, this method first checks the GEObject input property, and if that is provided, will return the GEObject input property.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ParseInitData (inherited from GenericCRUDBase) | This method is called when necessary by the component internally to access "Init Data", which is the InitData field in the Process Component record. This information is necessary to determine the name of the entity and other properties that can vary from one Process Component meta-data record to another. Since the Entity CRUD components are generic in nature, they have no inherent knowledge of which entity they are bound to at a given time. That is the key to what Process Component InitData strings tell the components - the Entity Name, among other attributes. In sub-classes, this method can be overriden to access the underlying InitData string directly to access other attributes from the string in addition to the Entity Name which is the single attribute extracted by the base class implementation of this method.
SetDataFields (inherited from GenericCRUDBase) | This method is used to set the values of the specified GEObject to the values that have been provided in the Input Properties for the Process Flow Step and are resident in the Properties collection for this instance.

See Also

GenericUpdateRecord Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


GenericUpdateRecord Constructor

Initializes a new instance of the GenericUpdateRecord class.

public GenericUpdateRecord();

See Also

GenericUpdateRecord Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


GenericUpdateRecord Methods

The methods of the GenericUpdateRecord class are listed below. For a complete list of GenericUpdateRecord class members, see the GenericUpdateRecord Members topic.

Public Instance Methods

Config (inherited from GenericCRUDBase) | This method must be called before any other member of this class is accessed
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsSubType (inherited from GenericCRUDBase) | This member returns true if the current entity is a sub-type, and false if it is not a sub-type(e.g. a top level entity)
Run | Implementation of the IProcessComponent.Run() method which will execute the function of updating a record in the database based on the InitData and provided Input Properties. The Record ID will be returned via the RecordID Output Property and the GE Object created will be returned via the GEObject output property as well.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetGEObject (inherited from GenericCRUDBase) | This method is designed to be used as a utility by sub-classes to retrieve the GE object to be used for Read/Update/Delete operations. This method will retrieve either the Top-Level object corresponding to the RecordID input property or the Sub-Type object relative to the SubTypeName and Sequence input properties. If CheckGEObjectProperty is set to True, this method first checks the GEObject input property, and if that is provided, will return the GEObject input property.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ParseInitData (inherited from GenericCRUDBase) | This method is called when necessary by the component internally to access "Init Data", which is the InitData field in the Process Component record. This information is necessary to determine the name of the entity and other properties that can vary from one Process Component meta-data record to another. Since the Entity CRUD components are generic in nature, they have no inherent knowledge of which entity they are bound to at a given time. That is the key to what Process Component InitData strings tell the components - the Entity Name, among other attributes. In sub-classes, this method can be overriden to access the underlying InitData string directly to access other attributes from the string in addition to the Entity Name which is the single attribute extracted by the base class implementation of this method.
SetDataFields (inherited from GenericCRUDBase) | This method is used to set the values of the specified GEObject to the values that have been provided in the Input Properties for the Process Flow Step and are resident in the Properties collection for this instance.

See Also

GenericUpdateRecord Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


GenericUpdateRecord.Run Method

Implementation of the IProcessComponent.Run() method which will execute the function of updating a record in the database based on the InitData and provided Input Properties. The Record ID will be returned via the RecordID Output Property and the GE Object created will be returned via the GEObject output property as well.

public override string Run();

Return Value

Success or Failed

Implements

IProcessComponent.

Remarks

See Also

GenericUpdateRecord Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


GetDataTableValueProcessComponent Class

For a list of all members of this type, see GetDataTableValueProcessComponent Members.

System.Object
GetDataTableValueProcessComponent

public class GetDataTableValueProcessComponent : IProcessComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline

Assembly: DataTableProcessComponents (in DataTableProcessComponents.dll)

See Also

GetDataTableValueProcessComponent Members | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


GetDataTableValueProcessComponent Members

GetDataTableValueProcessComponent overview

Public Instance Constructors

GetDataTableValueProcessComponent Constructor Initializes a new instance of the GetDataTableValueProcessComponent class.

Public Instance Properties

Properties Aptify Properties Collection used for Input and Output Properties for the component.

Public Instance Methods

Config | This method must be called before any other member of this class is accessed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run | Retrieves the specified field from the current row of the data table.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetDataTableValueProcessComponent Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


GetDataTableValueProcessComponent Constructor

Initializes a new instance of the GetDataTableValueProcessComponent class.

public GetDataTableValueProcessComponent();

See Also

GetDataTableValueProcessComponent Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


GetDataTableValueProcessComponent Properties

The properties of the GetDataTableValueProcessComponent class are listed below. For a complete list of GetDataTableValueProcessComponent class members, see the GetDataTableValueProcessComponent Members topic.

Public Instance Properties

Properties Aptify Properties Collection used for Input and Output Properties for the component.

See Also

GetDataTableValueProcessComponent Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


Properties Property

Aptify 5.0 Software Development Kit (SDK)

GetDataTableValueProcessComponent.Properties Property

Aptify Properties Collection used for Input and Output Properties for the component.

public virtual AptifyProperties Properties {get;}

Property Value

Implements

IProcessComponent.

Remarks

See Also

GetDataTableValueProcessComponent Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


GetDataTableValueProcessComponent Methods

The methods of the GetDataTableValueProcessComponent class are listed below. For a complete list of GetDataTableValueProcessComponent class members, see the GetDataTableValueProcessComponent Members topic.

Public Instance Methods

Config | This method must be called before any other member of this class is accessed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run | Retrieves the specified field from the current row of the data table.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetDataTableValueProcessComponent Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


GetDataTableValueProcessComponent.Config Method

This method must be called before any other member of this class is accessed.

public virtual void Config(
AptifyApplication ApplicationObject
);

Parameters

ApplicationObject

Implements

IProcessComponent.

Remarks

See Also

GetDataTableValueProcessComponent Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


GetDataTableValueProcessComponent.Run Method

Retrieves the specified field from the current row of the data table.

public string Run();

Return Value

Success if process completed without error, EOF if no rows returned, else failure.

Implements

IProcessComponent.

Remarks

See Also

GetDataTableValueProcessComponent Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


InfoCacheItem Class

For a list of all members of this type, see InfoCacheItem Members.

System.Object
InfoCacheItem

public class InfoCacheItem

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline

Assembly: AptifyProcessFlowEngine (in AptifyProcessFlowEngine.dll)

See Also

InfoCacheItem Members | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


InfoCacheItem Members

InfoCacheItem overview

Public Instance Constructors

InfoCacheItem Constructor Initializes a new instance of the InfoCacheItem class.

Public Instance Fields

ID

Public Instance Properties

InputMapProperties

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
LoadRecord | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Fields

m_alInputMap

Protected Instance Methods

AddMapProperty | Overloaded.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnLoadRecord |

See Also

InfoCacheItem Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


InfoCacheItem Constructor

Initializes a new instance of the InfoCacheItem class.

public InfoCacheItem();

See Also

InfoCacheItem Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


InfoCacheItem Fields

The fields of the InfoCacheItem class are listed below. For a complete list of InfoCacheItem class members, see the InfoCacheItem Members topic.

Public Instance Fields

ID

Protected Instance Fields

m_alInputMap

See Also

InfoCacheItem Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


InfoCacheItem.ID Field

public ID ID;

See Also

InfoCacheItem Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


InfoCacheItem.m_alInputMap Field

protected m_alInputMap m_alInputMap;

See Also

InfoCacheItem Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


InfoCacheItem Properties

The properties of the InfoCacheItem class are listed below. For a complete list of InfoCacheItem class members, see the InfoCacheItem Members topic.

Public Instance Properties

InputMapProperties

See Also

InfoCacheItem Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


InputMapProperties Property

Aptify 5.0 Software Development Kit (SDK)

InfoCacheItem.InputMapProperties Property

public ArrayList InputMapProperties {get;}

See Also

InfoCacheItem Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


InfoCacheItem Methods

The methods of the InfoCacheItem class are listed below. For a complete list of InfoCacheItem class members, see the InfoCacheItem Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
LoadRecord | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

AddMapProperty | Overloaded.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnLoadRecord |

See Also

InfoCacheItem Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


AddMapProperty Method

Aptify 5.0 Software Development Kit (SDK)

InfoCacheItem.AddMapProperty Method

Overload List

protected MapProperty AddMapProperty(ArrayList,Object,Object,Object);

protected MapProperty AddMapProperty(ArrayList,Object,Object,Object,Object);

See Also

InfoCacheItem Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


InfoCacheItem.AddMapProperty Method (ArrayList, Object, Object, Object)

protected MapProperty AddMapProperty(
ArrayList TargetArrayList,
Object Type,
Object Name,
Object Value
);

See Also

InfoCacheItem Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace | InfoCacheItem.AddMapProperty Overload List


InfoCacheItem.AddMapProperty Method (ArrayList, Object, Object, Object, Object)

protected MapProperty AddMapProperty(
ArrayList TargetArrayList,
Object Type,
Object Name,
Object Value,
Object Required
);

See Also

InfoCacheItem Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace | InfoCacheItem.AddMapProperty Overload List


LoadRecord Method

Aptify 5.0 Software Development Kit (SDK)

InfoCacheItem.LoadRecord Method

Overload List

public abstract void LoadRecord(Int64,AptifyApplication);

public abstract void LoadRecord(Int64,DataRow,DataTable,DataTable,DataTable);

See Also

InfoCacheItem Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


InfoCacheItem.LoadRecord Method (Int64, AptifyApplication)

public abstract void LoadRecord(
Int64 ID,
AptifyApplication Application
);

See Also

InfoCacheItem Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace | InfoCacheItem.LoadRecord Overload List


InfoCacheItem.LoadRecord Method (Int64, DataRow, DataTable, DataTable, DataTable)

public abstract void LoadRecord(
Int64 ID,
DataRow rowItem,
DataTable dtInputMap,
DataTable dtOutputMap,
DataTable dtActionMap
);

See Also

InfoCacheItem Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace | InfoCacheItem.LoadRecord Overload List


InfoCacheItem.OnLoadRecord Method

protected virtual void OnLoadRecord(
Int64 ID
);

See Also

InfoCacheItem Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


InputBoxProcessComponent Class

Aptify Input Box(Windows Only) Process Component

For a list of all members of this type, see InputBoxProcessComponent Members.

System.Object
MessageBoxBase
InputBoxProcessComponent

public class InputBoxProcessComponent : MessageBoxBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline

Assembly: MessageBoxProcessComponents (in MessageBoxProcessComponents.dll)

See Also

InputBoxProcessComponent Members | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


InputBoxProcessComponent Members

InputBoxProcessComponent overview

Public Instance Constructors

InputBoxProcessComponent Constructor Initializes a new instance of the InputBoxProcessComponent class.

Public Instance Properties

Application (inherited from MessageBoxBase) | Aptify Application Object
DataAction (inherited from MessageBoxBase) | Aptify DataAction Object
Properties (inherited from MessageBoxBase) | Aptify Properties Collection used for Input and Output Properties for the component.

Public Instance Methods

Config (inherited from MessageBoxBase) | This method must be called before any other member of this class is accessed
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run | Input Properties Supported: 1) Prompt - Required - text to be displayed inside the input box 2) Title - Optional - Title for the input box window 3) Default Response - Optional - Default response to prepopulate in the input box 4) X Pos - Optional - Left Position of Input Box from Left of Screen Edge 5) Y Pos - Optional - Top Position of Input Box from Top of Screen Edge 6) Result Code Mode - Required - Mode of output for the result code. Either "Value" or "Success/Failed". If "Value" is chosen, the actual value entered by the user is returned as the result code. If "Success/Failed" is chosen, then the component returns _SUCCESS or _FAILED depending on if the component was succesful. If Result Code Mode = "Value", then the result code will be the value entered by the user or the value "_NO RESPONSE FROM USER" if the user doesn't respond, or "_FAILED" if the process fails The result will be also placed into an Output Property called InputBoxResult
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

InputBoxProcessComponent Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


InputBoxProcessComponent Constructor

Initializes a new instance of the InputBoxProcessComponent class.

public InputBoxProcessComponent();

See Also

InputBoxProcessComponent Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


InputBoxProcessComponent Methods

The methods of the InputBoxProcessComponent class are listed below. For a complete list of InputBoxProcessComponent class members, see the InputBoxProcessComponent Members topic.

Public Instance Methods

Config (inherited from MessageBoxBase) | This method must be called before any other member of this class is accessed
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run | Input Properties Supported: 1) Prompt - Required - text to be displayed inside the input box 2) Title - Optional - Title for the input box window 3) Default Response - Optional - Default response to prepopulate in the input box 4) X Pos - Optional - Left Position of Input Box from Left of Screen Edge 5) Y Pos - Optional - Top Position of Input Box from Top of Screen Edge 6) Result Code Mode - Required - Mode of output for the result code. Either "Value" or "Success/Failed". If "Value" is chosen, the actual value entered by the user is returned as the result code. If "Success/Failed" is chosen, then the component returns _SUCCESS or _FAILED depending on if the component was succesful. If Result Code Mode = "Value", then the result code will be the value entered by the user or the value "_NO RESPONSE FROM USER" if the user doesn't respond, or "_FAILED" if the process fails The result will be also placed into an Output Property called InputBoxResult
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

InputBoxProcessComponent Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


InputBoxProcessComponent.Run Method

Input Properties Supported: 1) Prompt - Required - text to be displayed inside the input box 2) Title - Optional - Title for the input box window 3) Default Response - Optional - Default response to prepopulate in the input box 4) X Pos - Optional - Left Position of Input Box from Left of Screen Edge 5) Y Pos - Optional - Top Position of Input Box from Top of Screen Edge 6) Result Code Mode - Required - Mode of output for the result code. Either "Value" or "Success/Failed". If "Value" is chosen, the actual value entered by the user is returned as the result code. If "Success/Failed" is chosen, then the component returns _SUCCESS or _FAILED depending on if the component was succesful. If Result Code Mode = "Value", then the result code will be the value entered by the user or the value "_NO RESPONSE FROM USER" if the user doesn't respond, or "_FAILED" if the process fails The result will be also placed into an Output Property called InputBoxResult

public override string Run();

Return Value

Implements

IProcessComponent.

Remarks

See Also

InputBoxProcessComponent Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


IProcessComponent Interface

This is the interface an object must implement to be included as a Process Component in a Process Flow. The interface defines methods needed for an object to participate as a step in a Process Flow. If you are implementing this interface for a component, consider using the ProcessComponentBase class as a starting point for a sub-class rather than directly implementing this interface as the base class provides some standard functionality.

For a list of all members of this type, see IProcessComponent Members.

public interface IProcessComponent

Types that implement IProcessComponent

Type | Description
Batch | This class is the Batch Object Generic Entity sub-class and handles functionality related to creating, and managing GL Export Batches in Aptify.
CurrencyMarkToMarket | This class implements the ICurrencyMarkToMarket interface and is the base class for marking Currency to market in the Aptify CRM/Order Entry system. If functional changes are required to this area of the system, it is recommended that this class be sub-classed and the appropriate methods of this class be overriden to augment/alter the functionality. Alternatively, it is also possible to implement the ICurrencyMarkToMarket interface by a completely separate class if that is required. Additional details on the methods provided in this class can be obtained in the documentation for the ICurrencyMarkToMarket interface.
DemoLockBoxImport | This is a demonstration of a bank file import for the Aptify Lock Box Import Wizard The purpose of this class is to provide an example of how to plug in file formats that can accomodate various types of import options The demo file format has a first line comment, a second line that contains header information, and third lines and beyond contain payment line items. First Line: Comment - Ignore it Second Line: DepositDate,BankBatch,Total,PaymentType Third+ Lines: OrderID, Customer Name, PaymentAmount, Check Number
ExpandScheduledTransactions | Written by Ravi Nagarajan, October 13, 1999 The purpose of this object is to review Scheduled Transaction Group records in the database and create the associated scheduled transaction records based on the group attributes. This process was introduced starting with the 1.20 build to improve the speed of the order entry system. Rather than generating individual scheduled transaction records during the Order save process, we create a single record per order line from which we can later generate the individual scheduled transaction records.
GLExport |
InvoiceConsolidation | This class implements the functionality for consolidation of invoices for persons and/or companies. The class provides a type-specific set of members for direct access and also implements IProcessComponent for use with the Process Pipeline architecture.
LockBoxImportBase | This class provides a set of utility functions as a base class for all other import objects that need to provide lock box import functionality
LockBoxMatch | This class provides the default Aptify implementation for the ILockBoxMatch interface. The base class implements a number of basic matching methods which are overridable if it is necessary to alter the functionality that the matching object provides.
LockBoxPost | This class provides the default Aptify implementation for the ILockBoxPost interface
LockBoxTextFileImport | This is a base class for all text file based imports for lock box and provides general file manipulation utilities to all of its sub-classes.
StandingOrderFulfillment | Provides functionality to fulfill a group of standing orders based on a list of standing order record ID values or based on a View of Standing Orders. This object implements a specialized set of methods that are publicly available as well as IProcessComponent
CampaignListBuilderObject | Provides functionality to handle the building of a campaign prospect list based on the Campaign Segments that have been defined within the campaign.
CampaignListImporter | This object provides the default implementation in Aptify CRM for the ICampaignListImporter interface
CampaignListMatch | This object provides the default implementation in Aptify CRM for the ICampaignListMatch interface
CampaignListPost | Class implements the ICampaignListPost interface and provides import list posting functionality.
ChapterAssignmentRules | Implements functionality to automatically determine a chapter for a given person, or order line. Supports both a type-specific interface and also the IProcessComponent interface
CommissionPaymentWizardObject |
CompanyFlowDownBase | Base class used by the other company flow down business object classes
FlowDownAbbreviatedName | This object handles the flow-down of a name from the Companies Entity Name field into the AbbreviatedName field which is used to store the short/acronym version of a company name. The default functionality in the base class automatically populates this field from the Company Name as long as the Abbreviated Name has not previously been manually overriden by the user (tested by checking the old value of the Name field of the Company against the value of AbbreviatedName using the same Abbreviated Name generation).
FlowDownDirSort | This object handles the flow-down of a name from the Companies Entity Name field into the DirSort field which is used to handle sorting and searching without special characters. The default functionality in the base class automatically populates this field from the Company Name as long as the DirSort has not previously been manually overriden by the user (tested by checking the old value of the Name field of the Company against the value of DirSort). In addition, this object will also auto-populate the DirLetter field with the first character in the Name, using the same logic as described above.
OutlookContactLogImport | Provides functionality to imports Contact Log records into Aptify from Microsoft Outlook emails. This is a non-visual class that can be used from wizards as well as Process Components.
CertificatePrintObject |
ScantronImport | This class is responsible for importing data from a scantron file into the Aptify Answer Sheets and Persons entities. The object contains several overridable methods that can be used to configure the business logic of the import process as required.
ScantronImport | This class is responsible for importing data from a scantron file into the Aptify Answer Sheets and Persons entities. The object contains several overridable methods that can be used to configure the business logic of the import process as required.
CreatePriorityPoints | Implements a process component that will create priority points for a given order when it ships.
ExpoBoothSync | Aptify Generic Booth Synchronization Object
ContributionPaymentObject |
PledgeMatchingObject |
HousingImportObject | Provides functionality to import data into the Aptify Housing management application from a format that hotels provide after they receive information on individuals that have reserved rooms within a block. This component is usable from both the HousingImportWizard as well as at the object level through the methods provided here. In addition, this object implements IProcessComponent which provides for a Process Component that can be included in Process Flows.
HousingTransferObject | Provides functionality to export data (transfer data) from the Aptify Housing management application to a format that can be sent to the hotel(s) where room blocks are reserved. This component is usable from both the HousingTransferWizard as well as at the object level through the methods provided here. In addition, this object implements IProcessComponent which provides for a Process Component that can be included in Process Flows.
CheckCredit | This object implements the Aptify.Applications.OrderEntry.ICheckCredit interface. The purpose of this component is to check the credit for an order and return the status of that credit check back to the calling object.
PaymentGenerateGL | This object implements the Aptify.Applications.Accounting.IGenerateGL interface. The purpose of this component is to generate GL entries for a payment
AddPersonToCommittees | This class provides both type-specific methods and IProcessComponent methods for adding person record(s) to one or more commmittee terms. This object is used by the Add Person to Committees GUI for both adding single and multiple individuals to a committee record. This object can be used programatically via the type-specific methods as well as through process pipeline through the IProcessComponent support. See the Run() method on this class for details on the Input Properties and Output Properties provided through the Process Component members.
SyncContact | This class is responsible for synchronizing a specific Outlook Contact with a specific Aptify Person record.
SyncFolder | This class implements IProcessComponent and handles the process of synchronizing a specific Outlook Folder with the Aptify Persons entity.
SyncView | This class is responsible for synchronizing a specific view of Person records with a specified Outlook Folder.
OpportunityHistoryGenerator | Implements functionality to automatically generate history records in the OpportunityHistory sub-type whenever changes are made to an Opportunity Record that justify a history record being created. The logic in this class utilizes Process Component Input Properties(or parameters to the type-specific functions) to determine which fields in the Opportunity Record being modified will drive the creation of an OpportunityHistory sub-type record being created. This process component is designed to be called from the BeforeSave() event for the Opportunities entity.
SelectReferralRequestVendors | Implements functionality to automatically generate ReferralRequestVendor sub-type records based on the type of referral request. When a referral request has QualificationMode="Open" and the Status="Pending", this process component will automatically maintain the list of records in the ReferralRequestVendors sub-type.
SubscriptionRenewal | This class is responsible for renewing subscriptions and supports execution through an Action interface, view extension as well as a Process Component. This component can be used with its type-specific members as well.
AcctMgrTransferPFComp |
RunEntityBulkOperationProcessComponent | Process Component that runs an Entity Bulk Operation on a specified record set.
GESubClassIntegrator | This class is responsible for using the GE sub-class generator and compiler classes and integrating the resulting compiled DLL objects into the object repository. This class implements IProcessComponent so that it can be called from a process flow
PendingChangeBase |
PendingChangeUpdate | Process Component for updating Pending Changes records.
PostAvailablePendingChangeBatchPC |
PostSinglePendingChangePC |
CompileProcessFlowComponent | Process Flow Component that is used to compile Process Flows into a DLL.
CreateWorkBook | Provides functionality to export an Aptify View to an Excel spreadsheet.
GenericCreateRecord | Generic Process Component for creating new records for both Top-Level and Sub-Type entities
GenericCRUDBase | Base class for all other Aptify Generic CRUD Process Components
GenericDeleteRecord | Generic Process Component for deleting records for both Top-Level and Sub-Type entities
GenericReadRecord | Generic Process Component for reading records for both Top-Level and Sub-Type entities
GenericUpdateRecord | Generic Process Component for updating records for both Top-Level and Sub-Type entities
GetDataTableValueProcessComponent |
InputBoxProcessComponent | Aptify Input Box(Windows Only) Process Component
LoadDataTableProcessComponent |
MessageBoxBase | Base class for Aptify Message Box and Input Box Process Components
MessageBoxProcessComponent | Aptify Message Box(Windows Only) Process Component
MoveDataTableProcessComponent |
ProcessComponentBase | This class provides a base from which process components can be easily derived without having to directly implement IProcessComponent and implement the Properties collection. This base class also has a base Config() method and handles dynamic creation of a DataAction class using the UserCredentials provided by the Application Object passed into the Config() method. Subclass this class to create new process components whenever possible to minimize code redundancy.
SaveGEObject |
ValueCheckerBase | Base class for Aptify Generic Value Retriever and Value Tester Process Components
ValueRetriever | This class is used to retrieve values from either a GE object or from an entity, or the context object. Simply provide the Entity Object or Entity Name and Record ID, and provide the field name to be retrieved and the value will be returned as the RESULT CODE for the component
ValueTester | This class is capable of testing any value against another value. It is useful for doing quick checks against database or context object values to determine workflow logic.
vCalendarBase | Base class for Aptify Generic vCalendar Writer and Reader
vCalendarReader | This class is NOT implemented, and will in the future contain an implementation to read the contents of a vCalendar file and parse the file into properties.
vCalendarWriter | This class is used to create a vCalendar file based on the provided input properties
VirtualFieldUpdateProcessComponent | Updates linked virtual fields based on foreign key changes.
RemoteSchedulerDelete | Deletes a Scheduled Task based on a Scheduler and the TaskName.
RemoteSchedulerUpdate | Opens the Scheduled Task with a specific ScheduledTaskName, Changes the Scheduled Task Service Name, and Saves the record.
SetWizardResult | Process Component that sets the Wizard Result to a specified value
MessageEngine | The standard Aptify implementation of IMessageEngine. The implementation of IProcessComponent is for use with the [Send Message Run] process flow.
SendEmailProcessComponent | Sends a single email.
ExecuteViewNonUI | This class can execute a View non-visually and process the results accordingly.

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline

Assembly: AptifyProcessFlowEngine (in AptifyProcessFlowEngine.dll)

See Also

IProcessComponent Members | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


IProcessComponent Members

IProcessComponent overview

Public Instance Properties

Properties Provides a storage mechanism that is used throughout the course of the Process Component's lifecycle. The process flow engine will populate the properties collection with input properties before the Run method is called and will also look in this collection for Output Properties after the Run method completes

Public Instance Methods

Config | Configures the Process Component with information that it needs to perform its intended action.
Run | Performs the Process Component's intended action and then returns the result of the execution.

See Also

IProcessComponent Interface | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


IProcessComponent Properties

The properties of the IProcessComponent interface are listed below. For a complete list of IProcessComponent interface members, see the IProcessComponent Members topic.

Public Instance Properties

Properties Provides a storage mechanism that is used throughout the course of the Process Component's lifecycle. The process flow engine will populate the properties collection with input properties before the Run method is called and will also look in this collection for Output Properties after the Run method completes

See Also

IProcessComponent Interface | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


Properties Property

Aptify 5.0 Software Development Kit (SDK)

IProcessComponent.Properties Property

Provides a storage mechanism that is used throughout the course of the Process Component's lifecycle. The process flow engine will populate the properties collection with input properties before the Run method is called and will also look in this collection for Output Properties after the Run method completes

AptifyProperties Properties {get;}

See Also

IProcessComponent Interface | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


IProcessComponent Methods

The methods of the IProcessComponent interface are listed below. For a complete list of IProcessComponent interface members, see the IProcessComponent Members topic.

Public Instance Methods

Config | Configures the Process Component with information that it needs to perform its intended action.
Run | Performs the Process Component's intended action and then returns the result of the execution.

See Also

IProcessComponent Interface | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


IProcessComponent.Config Method

Configures the Process Component with information that it needs to perform its intended action.

void Config(
AptifyApplication ApplicationObject
);

Parameters

ApplicationObject

See Also

IProcessComponent Interface | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


IProcessComponent.Run Method

Performs the Process Component's intended action and then returns the result of the execution.

string Run();

See Also

IProcessComponent Interface | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


IProcessFlow Interface

Provides a mechanism for components to be run as a Process Flow.

For a list of all members of this type, see IProcessFlow Members.

public interface IProcessFlow

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline

Assembly: AptifyProcessFlowEngine (in AptifyProcessFlowEngine.dll)

See Also

IProcessFlow Members | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


IProcessFlow Members

IProcessFlow overview

Public Instance Methods

Run Executes the intended action of the Process Flow.

See Also

IProcessFlow Interface | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


IProcessFlow Methods

The methods of the IProcessFlow interface are listed below. For a complete list of IProcessFlow interface members, see the IProcessFlow Members topic.

Public Instance Methods

Run Executes the intended action of the Process Flow.

See Also

IProcessFlow Interface | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


IProcessFlow.Run Method

Executes the intended action of the Process Flow.

ProcessFlowResult Run(
AptifyApplication Application,
Int64 ProcessFlowID,
AptifyContext Context,
Boolean ForceSynchronousExecution
);

Parameters

Application
ProcessFlowID
Context
ForceSynchronousExecution

Return Value

Remarks

See Also

IProcessFlow Interface | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


IProcessFlowCompiler Interface

Compiles a Process Flow into executable code.

For a list of all members of this type, see IProcessFlowCompiler Members.

public interface IProcessFlowCompiler

Types that implement IProcessFlowCompiler

Type | Description
ProcessFlowCompiler | Compiles an Aptify Process Flow record into a VB.Net assembly.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline

Assembly: AptifyProcessFlowEngine (in AptifyProcessFlowEngine.dll)

See Also

IProcessFlowCompiler Members | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


IProcessFlowCompiler Members

IProcessFlowCompiler overview

Public Instance Methods

Compile | Compiles a Process Flow into executable code.
Config | Configures the compiler for execution.

See Also

IProcessFlowCompiler Interface | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


IProcessFlowCompiler Methods

The methods of the IProcessFlowCompiler interface are listed below. For a complete list of IProcessFlowCompiler interface members, see the IProcessFlowCompiler Members topic.

Public Instance Methods

Compile | Compiles a Process Flow into executable code.
Config | Configures the compiler for execution.

See Also

IProcessFlowCompiler Interface | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


IProcessFlowCompiler.Compile Method

Compiles a Process Flow into executable code.

void Compile(
Int64 ProcessFlowID,
ref String& CompiledAssembly,
ref String& CompiledClass
);

Parameters

ProcessFlowID
The ID of the Process Flow to be compiled.
CompiledAssembly
Returns the name of the Assembly that contains the compiled Process Flow.
CompiledClass
Returns the name of the Class that contains entry point for the compiled Process Flow.

Remarks

The class that is returned must implement the IProcessFlow interface. If there is a problem, while compiling the Process Flow, then an exception should be thrown.

Exceptions

Exception Type | Condition
ProcessFlowCompileException | Thrown when there is a problem compiling the Process Flow.

See Also

IProcessFlowCompiler Interface | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


IProcessFlowCompiler.Config Method

Configures the compiler for execution.

void Config(
AptifyApplication ApplicationObject
);

Parameters

ApplicationObject

Remarks

See Also

IProcessFlowCompiler Interface | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


LoadDataTableProcessComponent Class

For a list of all members of this type, see LoadDataTableProcessComponent Members.

System.Object
LoadDataTableProcessComponent

public class LoadDataTableProcessComponent : IProcessComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline

Assembly: DataTableProcessComponents (in DataTableProcessComponents.dll)

See Also

LoadDataTableProcessComponent Members | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


LoadDataTableProcessComponent Members

LoadDataTableProcessComponent overview

Public Instance Constructors

LoadDataTableProcessComponent Constructor Initializes a new instance of the LoadDataTableProcessComponent class.

Public Instance Properties

Properties Aptify Properties Collection used for Input and Output Properties for the component.

Public Instance Methods

Config | This method must be called before any other member of this class is accessed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run | Runs the specified SQL query and places the resultant data table into the outbound properties collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LoadDataTableProcessComponent Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


LoadDataTableProcessComponent Constructor

Initializes a new instance of the LoadDataTableProcessComponent class.

public LoadDataTableProcessComponent();

See Also

LoadDataTableProcessComponent Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


LoadDataTableProcessComponent Properties

The properties of the LoadDataTableProcessComponent class are listed below. For a complete list of LoadDataTableProcessComponent class members, see the LoadDataTableProcessComponent Members topic.

Public Instance Properties

Properties Aptify Properties Collection used for Input and Output Properties for the component.

See Also

LoadDataTableProcessComponent Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


Properties Property

Aptify 5.0 Software Development Kit (SDK)

LoadDataTableProcessComponent.Properties Property

Aptify Properties Collection used for Input and Output Properties for the component.

public virtual AptifyProperties Properties {get;}

Property Value

Implements

IProcessComponent.

Remarks

See Also

LoadDataTableProcessComponent Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


LoadDataTableProcessComponent Methods

The methods of the LoadDataTableProcessComponent class are listed below. For a complete list of LoadDataTableProcessComponent class members, see the LoadDataTableProcessComponent Members topic.

Public Instance Methods

Config | This method must be called before any other member of this class is accessed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run | Runs the specified SQL query and places the resultant data table into the outbound properties collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LoadDataTableProcessComponent Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


LoadDataTableProcessComponent.Config Method

This method must be called before any other member of this class is accessed.

public virtual void Config(
AptifyApplication ApplicationObject
);

Parameters

ApplicationObject

Implements

IProcessComponent.

Remarks

See Also

LoadDataTableProcessComponent Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


LoadDataTableProcessComponent.Run Method

Runs the specified SQL query and places the resultant data table into the outbound properties collection.

public string Run();

Return Value

Success if process completed without error, EOF if no rows returned, else failed.

Implements

IProcessComponent.

Remarks

See Also

LoadDataTableProcessComponent Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


MapProperty Class

For a list of all members of this type, see MapProperty Members.

System.Object
MapProperty

public class MapProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline

Assembly: AptifyProcessFlowEngine (in AptifyProcessFlowEngine.dll)

See Also

MapProperty Members | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


MapProperty Members

MapProperty overview

Public Instance Constructors

MapProperty Constructor Initializes a new instance of the MapProperty class.

Public Instance Fields

Name
Required
Type
Value

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MapProperty Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


MapProperty Constructor

Initializes a new instance of the MapProperty class.

public MapProperty();

See Also

MapProperty Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


MapProperty Fields

The fields of the MapProperty class are listed below. For a complete list of MapProperty class members, see the MapProperty Members topic.

Public Instance Fields

Name
Required
Type
Value

See Also

MapProperty Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


MapProperty.Name Field

public Name Name;

See Also

MapProperty Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


MapProperty.Required Field

public Required Required;

See Also

MapProperty Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


MapProperty.Type Field

public Type Type;

See Also

MapProperty Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


MapProperty.Value Field

public Value Value;

See Also

MapProperty Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


MessageBoxBase Class

Base class for Aptify Message Box and Input Box Process Components

For a list of all members of this type, see MessageBoxBase Members.

System.Object
MessageBoxBase
InputBoxProcessComponent
MessageBoxProcessComponent

public class MessageBoxBase : IProcessComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline

Assembly: MessageBoxProcessComponents (in MessageBoxProcessComponents.dll)

See Also

MessageBoxBase Members | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


MessageBoxBase Members

MessageBoxBase overview

Public Instance Constructors

MessageBoxBase Constructor Initializes a new instance of the MessageBoxBase class.

Public Instance Properties

Application | Aptify Application Object
DataAction | Aptify DataAction Object
Properties | Aptify Properties Collection used for Input and Output Properties for the component.

Public Instance Methods

Config | This method must be called before any other member of this class is accessed
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MessageBoxBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


MessageBoxBase Constructor

Initializes a new instance of the MessageBoxBase class.

public MessageBoxBase();

See Also

MessageBoxBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


MessageBoxBase Properties

The properties of the MessageBoxBase class are listed below. For a complete list of MessageBoxBase class members, see the MessageBoxBase Members topic.

Public Instance Properties

Application | Aptify Application Object
DataAction | Aptify DataAction Object
Properties | Aptify Properties Collection used for Input and Output Properties for the component.

See Also

MessageBoxBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


Application Property

Aptify 5.0 Software Development Kit (SDK)

MessageBoxBase.Application Property

Aptify Application Object

public virtual AptifyApplication Application {get;}

Property Value

Remarks

See Also

MessageBoxBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


DataAction Property

Aptify 5.0 Software Development Kit (SDK)

MessageBoxBase.DataAction Property

Aptify DataAction Object

public virtual DataAction DataAction {get;}

Property Value

Remarks

See Also

MessageBoxBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


Properties Property

Aptify 5.0 Software Development Kit (SDK)

MessageBoxBase.Properties Property

Aptify Properties Collection used for Input and Output Properties for the component.

public virtual AptifyProperties Properties {get;}

Property Value

Implements

IProcessComponent.

Remarks

See Also

MessageBoxBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


MessageBoxBase Methods

The methods of the MessageBoxBase class are listed below. For a complete list of MessageBoxBase class members, see the MessageBoxBase Members topic.

Public Instance Methods

Config | This method must be called before any other member of this class is accessed
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MessageBoxBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


MessageBoxBase.Config Method

This method must be called before any other member of this class is accessed

public virtual void Config(
AptifyApplication ApplicationObject
);

Parameters

ApplicationObject

Implements

IProcessComponent.

Remarks

See Also

MessageBoxBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


MessageBoxBase.Run Method

public abstract string Run();

Implements

IProcessComponent.

See Also

MessageBoxBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


MessageBoxProcessComponent Class

Aptify Message Box(Windows Only) Process Component

For a list of all members of this type, see MessageBoxProcessComponent Members.

System.Object
MessageBoxBase
MessageBoxProcessComponent

public class MessageBoxProcessComponent : MessageBoxBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline

Assembly: MessageBoxProcessComponents (in MessageBoxProcessComponents.dll)

See Also

MessageBoxProcessComponent Members | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


MessageBoxProcessComponent Members

MessageBoxProcessComponent overview

Public Instance Constructors

MessageBoxProcessComponent Constructor Initializes a new instance of the MessageBoxProcessComponent class.

Public Instance Properties

Application (inherited from MessageBoxBase) | Aptify Application Object
DataAction (inherited from MessageBoxBase) | Aptify DataAction Object
Properties (inherited from MessageBoxBase) | Aptify Properties Collection used for Input and Output Properties for the component.

Public Instance Methods

Config (inherited from MessageBoxBase) | This method must be called before any other member of this class is accessed
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run | Input Properties Supported: 1) Prompt - Required - text to be displayed inside the message box 2) Mode - Required - Button choice for the message box, Choice of "OK Cancel", "OK Only", "Yes No", "Yes No Cancel", "Retry Cancel", "Abort Retry Ignore", Defaults to "OK Only" 3) Icon - Required - Choice of "No Icon", "Information, "Question", "Critical", "Help" or "Exclamation", Defaults to "Information" 4) Title - Optional - Title for the message box window Possible Result Codes returned by component (dependant on the Mode selected) 1) Yes 2) No 3) OK 4) Cancel 5) Abort 6) Retry 7) Ignore 8) FAILED - this result code occurs when the message box fails
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MessageBoxProcessComponent Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


MessageBoxProcessComponent Constructor

Initializes a new instance of the MessageBoxProcessComponent class.

public MessageBoxProcessComponent();

See Also

MessageBoxProcessComponent Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


MessageBoxProcessComponent Methods

The methods of the MessageBoxProcessComponent class are listed below. For a complete list of MessageBoxProcessComponent class members, see the MessageBoxProcessComponent Members topic.

Public Instance Methods

Config (inherited from MessageBoxBase) | This method must be called before any other member of this class is accessed
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run | Input Properties Supported: 1) Prompt - Required - text to be displayed inside the message box 2) Mode - Required - Button choice for the message box, Choice of "OK Cancel", "OK Only", "Yes No", "Yes No Cancel", "Retry Cancel", "Abort Retry Ignore", Defaults to "OK Only" 3) Icon - Required - Choice of "No Icon", "Information, "Question", "Critical", "Help" or "Exclamation", Defaults to "Information" 4) Title - Optional - Title for the message box window Possible Result Codes returned by component (dependant on the Mode selected) 1) Yes 2) No 3) OK 4) Cancel 5) Abort 6) Retry 7) Ignore 8) FAILED - this result code occurs when the message box fails
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MessageBoxProcessComponent Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


MessageBoxProcessComponent.Run Method

Input Properties Supported: 1) Prompt - Required - text to be displayed inside the message box 2) Mode - Required - Button choice for the message box, Choice of "OK Cancel", "OK Only", "Yes No", "Yes No Cancel", "Retry Cancel", "Abort Retry Ignore", Defaults to "OK Only" 3) Icon - Required - Choice of "No Icon", "Information, "Question", "Critical", "Help" or "Exclamation", Defaults to "Information" 4) Title - Optional - Title for the message box window Possible Result Codes returned by component (dependant on the Mode selected) 1) Yes 2) No 3) OK 4) Cancel 5) Abort 6) Retry 7) Ignore 8) FAILED - this result code occurs when the message box fails

public override string Run();

Return Value

Implements

IProcessComponent.

Remarks

See Also

MessageBoxProcessComponent Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


MoveDataTableProcessComponent Class

For a list of all members of this type, see MoveDataTableProcessComponent Members.

System.Object
MoveDataTableProcessComponent

public class MoveDataTableProcessComponent : IProcessComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline

Assembly: DataTableProcessComponents (in DataTableProcessComponents.dll)

See Also

MoveDataTableProcessComponent Members | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


MoveDataTableProcessComponent Members

MoveDataTableProcessComponent overview

Public Instance Constructors

MoveDataTableProcessComponent Constructor Initializes a new instance of the MoveDataTableProcessComponent class.

Public Instance Properties

Properties Aptify Properties Collection used for Input and Output Properties for the component.

Public Instance Methods

Config | This method must be called before any other member of this class is accessed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run | Moves the current record of the data table.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MoveDataTableProcessComponent Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


MoveDataTableProcessComponent Constructor

Initializes a new instance of the MoveDataTableProcessComponent class.

public MoveDataTableProcessComponent();

See Also

MoveDataTableProcessComponent Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


MoveDataTableProcessComponent Properties

The properties of the MoveDataTableProcessComponent class are listed below. For a complete list of MoveDataTableProcessComponent class members, see the MoveDataTableProcessComponent Members topic.

Public Instance Properties

Properties Aptify Properties Collection used for Input and Output Properties for the component.

See Also

MoveDataTableProcessComponent Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


Properties Property

Aptify 5.0 Software Development Kit (SDK)

MoveDataTableProcessComponent.Properties Property

Aptify Properties Collection used for Input and Output Properties for the component.

public virtual AptifyProperties Properties {get;}

Property Value

Implements

IProcessComponent.

Remarks

See Also

MoveDataTableProcessComponent Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


MoveDataTableProcessComponent Methods

The methods of the MoveDataTableProcessComponent class are listed below. For a complete list of MoveDataTableProcessComponent class members, see the MoveDataTableProcessComponent Members topic.

Public Instance Methods

Config | This method must be called before any other member of this class is accessed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run | Moves the current record of the data table.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MoveDataTableProcessComponent Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


MoveDataTableProcessComponent.Config Method

This method must be called before any other member of this class is accessed.

public virtual void Config(
AptifyApplication ApplicationObject
);

Parameters

ApplicationObject

Implements

IProcessComponent.

Remarks

See Also

MoveDataTableProcessComponent Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


MoveDataTableProcessComponent.Run Method

Moves the current record of the data table.

public string Run();

Return Value

Success if process completed without error, else failed.

Implements

IProcessComponent.

Remarks

See Also

MoveDataTableProcessComponent Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


PipeLineLog Class

For a list of all members of this type, see PipeLineLog Members.

System.Object
Exception
ApplicationException
BaseApplicationException
PipeLineLog

public class PipeLineLog : BaseApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline

Assembly: AptifyProcessFlowEngine (in AptifyProcessFlowEngine.dll)

See Also

PipeLineLog Members | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


PipeLineLog Members

PipeLineLog overview

Public Instance Constructors

PipeLineLog Overloaded. Initializes a new instance of the PipeLineLog class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
ComponentID |
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
OutputPropertyName |
OutputPropertyType |
OutputPropertyValue |
ProcessFlowID |
ProcessStepID |
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PipeLineLog Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


PipeLineLog Constructor

Overload List

public PipeLineLog(Int64,Int64,Int64,String,String,String);

public PipeLineLog(SerializationInfo,StreamingContext);

See Also

PipeLineLog Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


PipeLineLog Constructor (SerializationInfo, StreamingContext)

public PipeLineLog(
SerializationInfo Info,
StreamingContext Context
);

See Also

PipeLineLog Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace | PipeLineLog Constructor Overload List


PipeLineLog Constructor (Int64, Int64, Int64, String, String, String)

public PipeLineLog(
Int64 FlowID,
Int64 StepID,
Int64 ComponentID,
String OutPropName,
String OutPropType,
String OutPropValue
);

See Also

PipeLineLog Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace | PipeLineLog Constructor Overload List


PipeLineLog Properties

The properties of the PipeLineLog class are listed below. For a complete list of PipeLineLog class members, see the PipeLineLog Members topic.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
ComponentID |
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
OutputPropertyName |
OutputPropertyType |
OutputPropertyValue |
ProcessFlowID |
ProcessStepID |
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

See Also

PipeLineLog Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ComponentID Property

Aptify 5.0 Software Development Kit (SDK)

PipeLineLog.ComponentID Property

public Int64 ComponentID {get;}

See Also

PipeLineLog Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


OutputPropertyName Property

Aptify 5.0 Software Development Kit (SDK)

PipeLineLog.OutputPropertyName Property

public String OutputPropertyName {get;}

See Also

PipeLineLog Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


OutputPropertyType Property

Aptify 5.0 Software Development Kit (SDK)

PipeLineLog.OutputPropertyType Property

public String OutputPropertyType {get;}

See Also

PipeLineLog Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


OutputPropertyValue Property

Aptify 5.0 Software Development Kit (SDK)

PipeLineLog.OutputPropertyValue Property

public String OutputPropertyValue {get;}

See Also

PipeLineLog Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowID Property

Aptify 5.0 Software Development Kit (SDK)

PipeLineLog.ProcessFlowID Property

public Int64 ProcessFlowID {get;}

See Also

PipeLineLog Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessStepID Property

Aptify 5.0 Software Development Kit (SDK)

PipeLineLog.ProcessStepID Property

public Int64 ProcessStepID {get;}

See Also

PipeLineLog Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


PipeLineLog Methods

The methods of the PipeLineLog class are listed below. For a complete list of PipeLineLog class members, see the PipeLineLog Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PipeLineLog Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


PipeLineLog.GetObjectData Method

public override void GetObjectData(
SerializationInfo Info,
StreamingContext Context
);

Implements

ISerializable.

See Also

PipeLineLog Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessComponentBase Class

This class provides a base from which process components can be easily derived without having to directly implement IProcessComponent and implement the Properties collection. This base class also has a base Config() method and handles dynamic creation of a DataAction class using the UserCredentials provided by the Application Object passed into the Config() method. Subclass this class to create new process components whenever possible to minimize code redundancy.

For a list of all members of this type, see ProcessComponentBase Members.

System.Object
ProcessComponentBase

public class ProcessComponentBase : IProcessComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline

Assembly: AptifyProcessFlowEngine (in AptifyProcessFlowEngine.dll)

See Also

ProcessComponentBase Members | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessComponentBase Members

ProcessComponentBase overview

Public Instance Constructors

ProcessComponentBase Constructor Initializes a new instance of the ProcessComponentBase class.

Public Instance Properties

Application | Returns the internal instance of the Aptify Application object
DataAction | Returns an internal instance of the Aptify DataAction object. This object is created dynamically the first time this property is accessed for each class instance.
Properties | Provides a storage mechanism that is used throughout the course of the Process Component's lifecycle. The process flow engine will populate the properties collection with input properties before the Run method is called and will also look in this collection for Output Properties after the Run method completes

Public Instance Methods

Config | Configures the Process Component with information that it needs to perform its intended action.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run | Performs the Process Component's intended action and then returns the result of the execution.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProcessComponentBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessComponentBase Constructor

Initializes a new instance of the ProcessComponentBase class.

public ProcessComponentBase();

See Also

ProcessComponentBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessComponentBase Properties

The properties of the ProcessComponentBase class are listed below. For a complete list of ProcessComponentBase class members, see the ProcessComponentBase Members topic.

Public Instance Properties

Application | Returns the internal instance of the Aptify Application object
DataAction | Returns an internal instance of the Aptify DataAction object. This object is created dynamically the first time this property is accessed for each class instance.
Properties | Provides a storage mechanism that is used throughout the course of the Process Component's lifecycle. The process flow engine will populate the properties collection with input properties before the Run method is called and will also look in this collection for Output Properties after the Run method completes

See Also

ProcessComponentBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


Application Property

Aptify 5.0 Software Development Kit (SDK)

ProcessComponentBase.Application Property

Returns the internal instance of the Aptify Application object

public virtual AptifyApplication Application {get;}

Property Value

Remarks

See Also

ProcessComponentBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


DataAction Property

Aptify 5.0 Software Development Kit (SDK)

ProcessComponentBase.DataAction Property

Returns an internal instance of the Aptify DataAction object. This object is created dynamically the first time this property is accessed for each class instance.

public virtual DataAction DataAction {get;}

Property Value

Remarks

See Also

ProcessComponentBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


Properties Property

Aptify 5.0 Software Development Kit (SDK)

ProcessComponentBase.Properties Property

Provides a storage mechanism that is used throughout the course of the Process Component's lifecycle. The process flow engine will populate the properties collection with input properties before the Run method is called and will also look in this collection for Output Properties after the Run method completes

public virtual AptifyProperties Properties {get;}

Property Value

Implements

IProcessComponent.

Remarks

See Also

ProcessComponentBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessComponentBase Methods

The methods of the ProcessComponentBase class are listed below. For a complete list of ProcessComponentBase class members, see the ProcessComponentBase Members topic.

Public Instance Methods

Config | Configures the Process Component with information that it needs to perform its intended action.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run | Performs the Process Component's intended action and then returns the result of the execution.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProcessComponentBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessComponentBase.Config Method

Configures the Process Component with information that it needs to perform its intended action.

public virtual void Config(
AptifyApplication ApplicationObject
);

Parameters

ApplicationObject

Implements

IProcessComponent.

Remarks

See Also

ProcessComponentBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessComponentBase.Run Method

Performs the Process Component's intended action and then returns the result of the execution.

public abstract string Run();

Return Value

Implements

IProcessComponent.

Remarks

See Also

ProcessComponentBase Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessComponentGenerator Class

For a list of all members of this type, see ProcessComponentGenerator Members.

System.Object
ProcessComponentGenerator

public class ProcessComponentGenerator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline

Assembly: ProcessComponentGenerator (in ProcessComponentGenerator.dll)

See Also

ProcessComponentGenerator Members | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessComponentGenerator Members

ProcessComponentGenerator overview

Public Static Fields

AssemblyName
CreateObjectClassName
DeleteObjectClassName
ObjectNameSpace
ObjectRepositoryLocation
ReadObjectClassName
UpdateObjectClassName

Public Instance Constructors

ProcessComponentGenerator Constructor

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GenerateProcessComponents | Overloaded.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProcessComponentGenerator Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessComponentGenerator Constructor

public ProcessComponentGenerator(
AptifyApplication Application
);

See Also

ProcessComponentGenerator Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessComponentGenerator Fields

The fields of the ProcessComponentGenerator class are listed below. For a complete list of ProcessComponentGenerator class members, see the ProcessComponentGenerator Members topic.

Public Static Fields

AssemblyName
CreateObjectClassName
DeleteObjectClassName
ObjectNameSpace
ObjectRepositoryLocation
ReadObjectClassName
UpdateObjectClassName

See Also

ProcessComponentGenerator Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessComponentGenerator.AssemblyName Field

public const AssemblyName AssemblyName = "EntityCRUDProcessComponents";

See Also

ProcessComponentGenerator Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessComponentGenerator.CreateObjectClassName Field

public const CreateObjectClassName CreateObjectClassName = "GenericCreateRecord";

See Also

ProcessComponentGenerator Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessComponentGenerator.DeleteObjectClassName Field

public const DeleteObjectClassName DeleteObjectClassName = "GenericDeleteRecord";

See Also

ProcessComponentGenerator Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessComponentGenerator.ObjectNameSpace Field

public const ObjectNameSpace ObjectNameSpace = "Aptify.Framework.BusinessLogic.ProcessPipeline";

See Also

ProcessComponentGenerator Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessComponentGenerator.ObjectRepositoryLocation Field

public const ObjectRepositoryLocation ObjectRepositoryLocation = "DataModules.EntityCRUDProcessComponents";

See Also

ProcessComponentGenerator Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessComponentGenerator.ReadObjectClassName Field

public const ReadObjectClassName ReadObjectClassName = "GenericReadRecord";

See Also

ProcessComponentGenerator Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessComponentGenerator.UpdateObjectClassName Field

public const UpdateObjectClassName UpdateObjectClassName = "GenericUpdateRecord";

See Also

ProcessComponentGenerator Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessComponentGenerator Methods

The methods of the ProcessComponentGenerator class are listed below. For a complete list of ProcessComponentGenerator class members, see the ProcessComponentGenerator Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GenerateProcessComponents | Overloaded.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProcessComponentGenerator Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


GenerateProcessComponents Method

Aptify 5.0 Software Development Kit (SDK)

ProcessComponentGenerator.GenerateProcessComponents Method

Overload List

public bool GenerateProcessComponents(AptifyGenericEntityBase);

public bool GenerateProcessComponents(AptifyGenericEntityBase,Boolean,Boolean,Boolean,Boolean);

public bool GenerateProcessComponents(AptifyGenericEntityBase,Boolean,String,Boolean,String,Boolean,String,Boolean,String);

See Also

ProcessComponentGenerator Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessComponentGenerator.GenerateProcessComponents Method (AptifyGenericEntityBase)

public bool GenerateProcessComponents(
AptifyGenericEntityBase EntityGE
);

See Also

ProcessComponentGenerator Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace | ProcessComponentGenerator.GenerateProcessComponents Overload List


ProcessComponentGenerator.GenerateProcessComponents Method (AptifyGenericEntityBase, Boolean, Boolean, Boolean, Boolean)

public bool GenerateProcessComponents(
AptifyGenericEntityBase EntityGE,
Boolean CreateObject,
Boolean ReadObject,
Boolean UpdateObject,
Boolean DeleteObject
);

See Also

ProcessComponentGenerator Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace | ProcessComponentGenerator.GenerateProcessComponents Overload List


ProcessComponentGenerator.GenerateProcessComponents Method (AptifyGenericEntityBase, Boolean, String, Boolean, String, Boolean, String, Boolean, String)

public bool GenerateProcessComponents(
AptifyGenericEntityBase EntityGE,
Boolean CreateObject,
String CreateObjectName,
Boolean ReadObject,
String ReadObjectName,
Boolean UpdateObject,
String UpdateObjectName,
Boolean DeleteObject,
String DeleteObjectName
);

See Also

ProcessComponentGenerator Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace | ProcessComponentGenerator.GenerateProcessComponents Overload List


ProcessEngineException Class

For a list of all members of this type, see ProcessEngineException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
ProcessPipeLineException
ProcessEngineException

public class ProcessEngineException : ProcessPipeLineException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline

Assembly: AptifyProcessFlowEngine (in AptifyProcessFlowEngine.dll)

See Also

ProcessEngineException Members | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessEngineException Members

ProcessEngineException overview

Public Instance Constructors

ProcessEngineException Overloaded. Initializes a new instance of the ProcessEngineException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
ProcessFlowID |
ProcessStepID |
ResultCode |
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProcessEngineException Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessEngineException Constructor

Overload List

public ProcessEngineException(SerializationInfo,StreamingContext);

public ProcessEngineException(String,Int64,Int64,String);

public ProcessEngineException(String,Int64,Int64,String,Exception);

See Also

ProcessEngineException Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessEngineException Constructor (String, Int64, Int64, String)

public ProcessEngineException(
String Message,
Int64 ProcessFlowID,
Int64 ProcessStepID,
String ResultCode
);

See Also

ProcessEngineException Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace | ProcessEngineException Constructor Overload List


ProcessEngineException Constructor (String, Int64, Int64, String, Exception)

public ProcessEngineException(
String Message,
Int64 ProcessFlowID,
Int64 ProcessStepID,
String ResultCode,
Exception InnerException
);

See Also

ProcessEngineException Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace | ProcessEngineException Constructor Overload List


ProcessEngineException Constructor (SerializationInfo, StreamingContext)

public ProcessEngineException(
SerializationInfo Info,
StreamingContext Context
);

See Also

ProcessEngineException Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace | ProcessEngineException Constructor Overload List


ProcessEngineException Properties

The properties of the ProcessEngineException class are listed below. For a complete list of ProcessEngineException class members, see the ProcessEngineException Members topic.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
ProcessFlowID |
ProcessStepID |
ResultCode |
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

See Also

ProcessEngineException Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowID Property

Aptify 5.0 Software Development Kit (SDK)

ProcessEngineException.ProcessFlowID Property

public Int64 ProcessFlowID {get;}

See Also

ProcessEngineException Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessStepID Property

Aptify 5.0 Software Development Kit (SDK)

ProcessEngineException.ProcessStepID Property

public Int64 ProcessStepID {get;}

See Also

ProcessEngineException Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ResultCode Property

Aptify 5.0 Software Development Kit (SDK)

ProcessEngineException.ResultCode Property

public String ResultCode {get;}

See Also

ProcessEngineException Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessEngineException Methods

The methods of the ProcessEngineException class are listed below. For a complete list of ProcessEngineException class members, see the ProcessEngineException Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProcessEngineException Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessEngineException.GetObjectData Method

public override void GetObjectData(
SerializationInfo Info,
StreamingContext Context
);

Implements

ISerializable.

See Also

ProcessEngineException Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowCompileException Class

Thrown when there is a problem compiling a Process Flow into an Assembly.

For a list of all members of this type, see ProcessFlowCompileException Members.

System.Object
Exception
ApplicationException
BaseApplicationException
ProcessPipeLineException
ProcessFlowCompileException

public class ProcessFlowCompileException : ProcessPipeLineException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline

Assembly: AptifyProcessFlowEngine (in AptifyProcessFlowEngine.dll)

See Also

ProcessFlowCompileException Members | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowCompileException Members

ProcessFlowCompileException overview

Public Instance Constructors

ProcessFlowCompileException Overloaded. Initializes a new instance of the ProcessFlowCompileException class.

Public Instance Properties

AdditionalInformation (inherited from BaseApplicationException) | Collection allowing additional information to be added to the exception.
AppDomainName (inherited from BaseApplicationException) | AppDomain name where the exception occurred.
CreatedDateTime (inherited from BaseApplicationException) | Date and Time the exception was created.
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorNumber (inherited from BaseApplicationException) | A number that is associated with a particular exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
MachineName (inherited from BaseApplicationException) | Machine name where the exception occurred.
Message (inherited from Exception) | Gets a message that describes the current exception.
Severity (inherited from BaseApplicationException) | A number that represents how Severe the exception is in terms of System Health.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ThreadIdentityName (inherited from BaseApplicationException) | Identity of the executing thread on which the exception was created.
WindowsIdentityName (inherited from BaseApplicationException) | Windows identity under which the code was running.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from BaseApplicationException) |
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProcessFlowCompileException Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowCompileException Constructor

Overload List

public ProcessFlowCompileException(String);

public ProcessFlowCompileException(String,Exception);

See Also

ProcessFlowCompileException Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowCompileException Constructor (String)

public ProcessFlowCompileException(
String Message
);

See Also

ProcessFlowCompileException Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace | ProcessFlowCompileException Constructor Overload List


ProcessFlowCompileException Constructor (String, Exception)

public ProcessFlowCompileException(
String Message,
Exception InnerException
);

See Also

ProcessFlowCompileException Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace | ProcessFlowCompileException Constructor Overload List


ProcessFlowCompiler Class

Compiles an Aptify Process Flow record into a VB.Net assembly.

For a list of all members of this type, see ProcessFlowCompiler Members.

System.Object
ProcessFlowCompiler

public class ProcessFlowCompiler : IProcessFlowCompiler

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline

Assembly: AptifyProcessFlowEngine (in AptifyProcessFlowEngine.dll)

See Also

ProcessFlowCompiler Members | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowCompiler Members

ProcessFlowCompiler overview

Public Instance Constructors

ProcessFlowCompiler Constructor Initializes a new instance of the ProcessFlowCompiler class.

Public Instance Methods

Compile | Compiles a VB.Net assembly and persists it to Disk.
Config | Configures the Compiler with any needed information to perform the compile.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
OutputComponent |
OutputSubProcess |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProcessFlowCompiler Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowCompiler Constructor

Initializes a new instance of the ProcessFlowCompiler class.

public ProcessFlowCompiler();

See Also

ProcessFlowCompiler Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowCompiler Methods

The methods of the ProcessFlowCompiler class are listed below. For a complete list of ProcessFlowCompiler class members, see the ProcessFlowCompiler Members topic.

Public Instance Methods

Compile | Compiles a VB.Net assembly and persists it to Disk.
Config | Configures the Compiler with any needed information to perform the compile.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
OutputComponent |
OutputSubProcess |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProcessFlowCompiler Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowCompiler.Compile Method

Compiles a VB.Net assembly and persists it to Disk.

public void Compile(
Int64 ProcessFlowID,
ref String& CompiledAssembly,
ref String& CompiledClass
);

Parameters

ProcessFlowID
The ID of the Process Flow that should be compiled.
CompiledAssembly
The name of the Assembly that has been created on Disk. The assembly will be persisted to the application's base directory.
CompiledClass
The full typename for the class that is created in the assembly.

Implements

IProcessFlowCompiler.

Exceptions

Exception Type | Condition
ProcessFlowCompileException | Thrown when there is a problem compiling the Process Flow.

See Also

ProcessFlowCompiler Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowCompiler.Config Method

Configures the Compiler with any needed information to perform the compile.

public void Config(
AptifyApplication ApplicationObject
);

Implements

IProcessFlowCompiler.

See Also

ProcessFlowCompiler Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowCompiler.OutputComponent Method

public void OutputComponent(
StringBuilder Code,
AptifyGenericEntityBase StepGE,
String FunctionName
);

See Also

ProcessFlowCompiler Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowCompiler.OutputSubProcess Method

public void OutputSubProcess(
StringBuilder Code,
AptifyGenericEntityBase StepGE,
String FunctionName
);

See Also

ProcessFlowCompiler Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowDebugInfo Class

Debug information class to be used to communicate between callers of a process flow and the ProcessFlowEngine class. Pass in an instance of this class to the ProcessFlowEngine when executing a process flow to invoke the debugging functionality of the process flow engine.

For a list of all members of this type, see ProcessFlowDebugInfo Members.

System.Object
ProcessFlowDebugInfo

public class ProcessFlowDebugInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline

Assembly: AptifyProcessFlowEngine (in AptifyProcessFlowEngine.dll)

See Also

ProcessFlowDebugInfo Members | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowDebugInfo Members

ProcessFlowDebugInfo overview

Public Instance Constructors

ProcessFlowDebugInfo Constructor Initializes a new instance of the ProcessFlowDebugInfo class.

Public Instance Properties

BreakPoints | List of breakpoints, if any for the debug execution process
CurrentParentStep | This property is used to set/get the current parent step for execution logging. This is used for calling sub-processes so that sub-steps can be hierarchically stored in the data structure.
DebugState | Debug State - True means the debugger is on, False means it is off. Default is True.
SingleStepMode | Gets/Sets if the debugger is executing freely between breakpoints or is in "single step" execution mode where the HandleBreakpoint() event is raised for every step before and after it is executed
StepResults | This property returns a list of the results of execution of the process flow and its steps.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindBreakpoint |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
OnHandleBreakpoint | This method is responsible for raising the Breakpoint event
ToString | Overrides ToString functionality to generate a string that represents the internal state of the debugger.

Public Instance Events

HandleBreakpoint This event is raised whenever a breakpoint is hit, or a single step is executed in single-step mode and the next step is pending.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProcessFlowDebugInfo Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowDebugInfo Constructor

Initializes a new instance of the ProcessFlowDebugInfo class.

public ProcessFlowDebugInfo();

See Also

ProcessFlowDebugInfo Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowDebugInfo Properties

The properties of the ProcessFlowDebugInfo class are listed below. For a complete list of ProcessFlowDebugInfo class members, see the ProcessFlowDebugInfo Members topic.

Public Instance Properties

BreakPoints | List of breakpoints, if any for the debug execution process
CurrentParentStep | This property is used to set/get the current parent step for execution logging. This is used for calling sub-processes so that sub-steps can be hierarchically stored in the data structure.
DebugState | Debug State - True means the debugger is on, False means it is off. Default is True.
SingleStepMode | Gets/Sets if the debugger is executing freely between breakpoints or is in "single step" execution mode where the HandleBreakpoint() event is raised for every step before and after it is executed
StepResults | This property returns a list of the results of execution of the process flow and its steps.

See Also

ProcessFlowDebugInfo Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


BreakPoints Property

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowDebugInfo.BreakPoints Property

List of breakpoints, if any for the debug execution process

public virtual List<T> BreakPoints {get;}

Property Value

Remarks

See Also

ProcessFlowDebugInfo Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


CurrentParentStep Property

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowDebugInfo.CurrentParentStep Property

This property is used to set/get the current parent step for execution logging. This is used for calling sub-processes so that sub-steps can be hierarchically stored in the data structure.

public virtual ProcessFlowDebugInfo.StepExecutionLog CurrentParentStep {get; set;}

Property Value

Remarks

See Also

ProcessFlowDebugInfo Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


DebugState Property

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowDebugInfo.DebugState Property

Debug State - True means the debugger is on, False means it is off. Default is True.

public virtual Boolean DebugState {get; set;}

Property Value

Remarks

See Also

ProcessFlowDebugInfo Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


SingleStepMode Property

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowDebugInfo.SingleStepMode Property

Gets/Sets if the debugger is executing freely between breakpoints or is in "single step" execution mode where the HandleBreakpoint() event is raised for every step before and after it is executed

public virtual Boolean SingleStepMode {get; set;}

Property Value

Remarks

See Also

ProcessFlowDebugInfo Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


StepResults Property

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowDebugInfo.StepResults Property

This property returns a list of the results of execution of the process flow and its steps.

public virtual List<T> StepResults {get;}

Property Value

Remarks

See Also

ProcessFlowDebugInfo Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowDebugInfo Methods

The methods of the ProcessFlowDebugInfo class are listed below. For a complete list of ProcessFlowDebugInfo class members, see the ProcessFlowDebugInfo Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindBreakpoint |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
OnHandleBreakpoint | This method is responsible for raising the Breakpoint event
ToString | Overrides ToString functionality to generate a string that represents the internal state of the debugger.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProcessFlowDebugInfo Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowDebugInfo.FindBreakpoint Method

public virtual BreakPointInfo FindBreakpoint(
Int64 StepID,
ProcessFlowDebugInfo.BreakPointInfo.BreakpointMode Mode
);

See Also

ProcessFlowDebugInfo Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowDebugInfo.OnHandleBreakpoint Method

This method is responsible for raising the Breakpoint event

public virtual void OnHandleBreakpoint(
Int64 StepID,
AptifyContext Context,
AptifyApplication Application,
DataAction DataAction,
ref BreakPointResult& Result
);

Parameters

StepID
Context
Application
DataAction
Result

Remarks

See Also

ProcessFlowDebugInfo Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowDebugInfo.ToString Method

Overrides ToString functionality to generate a string that represents the internal state of the debugger.

public override string ToString();

Return Value

Remarks

See Also

ProcessFlowDebugInfo Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowDebugInfo Events

The events of the ProcessFlowDebugInfo class are listed below. For a complete list of ProcessFlowDebugInfo class members, see the ProcessFlowDebugInfo Members topic.

Public Instance Events

HandleBreakpoint This event is raised whenever a breakpoint is hit, or a single step is executed in single-step mode and the next step is pending.

See Also

ProcessFlowDebugInfo Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowDebugInfo.ProcessFlowDebugInfo.HandleBreakpointEventHandler Event

This event is raised whenever a breakpoint is hit, or a single step is executed in single-step mode and the next step is pending.

public event ProcessFlowDebugInfo.HandleBreakpointEventHandler HandleBreakpoint;

Remarks

See Also

ProcessFlowDebugInfo Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowDebugInfo.BreakPointInfo Class

Class that contains information about breakpoints

For a list of all members of this type, see ProcessFlowDebugInfo.BreakPointInfo Members.

System.Object
ProcessFlowDebugInfo.BreakPointInfo

public class ProcessFlowDebugInfo.BreakPointInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline

Assembly: AptifyProcessFlowEngine (in AptifyProcessFlowEngine.dll)

See Also

ProcessFlowDebugInfo.BreakPointInfo Members | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowDebugInfo.BreakPointInfo Members

ProcessFlowDebugInfo.BreakPointInfo overview

Public Instance Constructors

ProcessFlowDebugInfo.BreakPointInfo Overloaded. Initializes a new instance of the ProcessFlowDebugInfo.BreakPointInfo class.

Public Instance Fields

Enabled
Mode
StepID

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProcessFlowDebugInfo.BreakPointInfo Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowDebugInfo.BreakPointInfo Constructor

Initializes a new instance of the ProcessFlowDebugInfo.BreakPointInfo class.

Overload List

Initializes a new instance of the ProcessFlowDebugInfo.BreakPointInfo class.

public ProcessFlowDebugInfo.BreakPointInfo();

public ProcessFlowDebugInfo.BreakPointInfo(Int64);

public ProcessFlowDebugInfo.BreakPointInfo(Int64,ProcessFlowDebugInfo.BreakPointInfo.BreakpointMode);

public ProcessFlowDebugInfo.BreakPointInfo(Int64,ProcessFlowDebugInfo.BreakPointInfo.BreakpointMode,Boolean);

See Also

ProcessFlowDebugInfo.BreakPointInfo Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowDebugInfo.BreakPointInfo Constructor ()

Initializes a new instance of the ProcessFlowDebugInfo.BreakPointInfo class.

public ProcessFlowDebugInfo.BreakPointInfo();

See Also

ProcessFlowDebugInfo.BreakPointInfo Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace | ProcessFlowDebugInfo.BreakPointInfo Constructor Overload List


ProcessFlowDebugInfo.BreakPointInfo Constructor (Int64)

public ProcessFlowDebugInfo.BreakPointInfo(
Int64 StepID
);

See Also

ProcessFlowDebugInfo.BreakPointInfo Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace | ProcessFlowDebugInfo.BreakPointInfo Constructor Overload List


ProcessFlowDebugInfo.BreakPointInfo Constructor (Int64, BreakpointMode)

public ProcessFlowDebugInfo.BreakPointInfo(
Int64 StepID,
ProcessFlowDebugInfo.BreakPointInfo.BreakpointMode Mode
);

See Also

ProcessFlowDebugInfo.BreakPointInfo Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace | ProcessFlowDebugInfo.BreakPointInfo Constructor Overload List


ProcessFlowDebugInfo.BreakPointInfo Constructor (Int64, BreakpointMode, Boolean)

public ProcessFlowDebugInfo.BreakPointInfo(
Int64 StepID,
ProcessFlowDebugInfo.BreakPointInfo.BreakpointMode Mode,
Boolean Enabled
);

See Also

ProcessFlowDebugInfo.BreakPointInfo Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace | ProcessFlowDebugInfo.BreakPointInfo Constructor Overload List


ProcessFlowDebugInfo.BreakPointInfo Fields

The fields of the ProcessFlowDebugInfo.BreakPointInfo class are listed below. For a complete list of ProcessFlowDebugInfo.BreakPointInfo class members, see the ProcessFlowDebugInfo.BreakPointInfo Members topic.

Public Instance Fields

Enabled
Mode
StepID

See Also

ProcessFlowDebugInfo.BreakPointInfo Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowDebugInfo.BreakPointInfo.Enabled Field

public Enabled Enabled;

See Also

ProcessFlowDebugInfo.BreakPointInfo Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowDebugInfo.BreakPointInfo.Mode Field

public Mode Mode;

See Also

ProcessFlowDebugInfo.BreakPointInfo Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowDebugInfo.BreakPointInfo.StepID Field

public StepID StepID;

See Also

ProcessFlowDebugInfo.BreakPointInfo Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowDebugInfo.BreakPointInfo.BreakpointMode Enumeration

public enum ProcessFlowDebugInfo.BreakPointInfo.BreakpointMode

Members

Member Name | Description
BeforeStep |
AfterStep |

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline

Assembly: AptifyProcessFlowEngine (in AptifyProcessFlowEngine.dll)

See Also

Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowDebugInfo.BreakPointResult Enumeration

Results that the listener of the HandleBreakpoint event pass back to the event to indicate the next step the process flow engine should take.

public enum ProcessFlowDebugInfo.BreakPointResult

Remarks

Members

Member Name | Description
Run | Run indicates that the process flow should continue until the next breakpoint, or end of execution
SingleStep | Single Step indicates that the process flow should only execute a single step and then break again, even if no breakpoint was defined
EndProcess |

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline

Assembly: AptifyProcessFlowEngine (in AptifyProcessFlowEngine.dll)

See Also

Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowDebugInfo.HandleBreakpointEventHandler Delegate

public delegate void ProcessFlowDebugInfo.HandleBreakpointEventHandler(
Int64 StepID,
AptifyContext Context,
AptifyApplication Application,
DataAction DataAction,
ref BreakPointResult& Result
);

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline

Assembly: AptifyProcessFlowEngine (in AptifyProcessFlowEngine.dll)

See Also

Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowDebugInfo.StepExecutionLog Class

Class contains the log results for a given process flow step execution

For a list of all members of this type, see ProcessFlowDebugInfo.StepExecutionLog Members.

System.Object
ProcessFlowDebugInfo.StepExecutionLog

public class ProcessFlowDebugInfo.StepExecutionLog

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline

Assembly: AptifyProcessFlowEngine (in AptifyProcessFlowEngine.dll)

See Also

ProcessFlowDebugInfo.StepExecutionLog Members | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowDebugInfo.StepExecutionLog Members

ProcessFlowDebugInfo.StepExecutionLog overview

Public Instance Constructors

ProcessFlowDebugInfo.StepExecutionLog Constructor Initializes a new instance of the ProcessFlowDebugInfo.StepExecutionLog class.

Public Instance Properties

ElapsedTime |
EndTime |
ParentStep | Gets/Sets the Parent Execution Log Step
PropertiesAfter |
PropertiesBefore |
Result |
StartTime |
StepID |
StepName |
StepType |
SubSteps | List of sub-steps executed within this step

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Overloaded. Overrides base ToString() method to generate a string representation of the members of this class
ToString (inherited from Object) | Overloaded. Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProcessFlowDebugInfo.StepExecutionLog Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowDebugInfo.StepExecutionLog Constructor

Initializes a new instance of the ProcessFlowDebugInfo.StepExecutionLog class.

public ProcessFlowDebugInfo.StepExecutionLog();

See Also

ProcessFlowDebugInfo.StepExecutionLog Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowDebugInfo.StepExecutionLog Properties

The properties of the ProcessFlowDebugInfo.StepExecutionLog class are listed below. For a complete list of ProcessFlowDebugInfo.StepExecutionLog class members, see the ProcessFlowDebugInfo.StepExecutionLog Members topic.

Public Instance Properties

ElapsedTime |
EndTime |
ParentStep | Gets/Sets the Parent Execution Log Step
PropertiesAfter |
PropertiesBefore |
Result |
StartTime |
StepID |
StepName |
StepType |
SubSteps | List of sub-steps executed within this step

See Also

ProcessFlowDebugInfo.StepExecutionLog Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ElapsedTime Property

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowDebugInfo.StepExecutionLog.ElapsedTime Property

public virtual TimeSpan ElapsedTime {get;}

See Also

ProcessFlowDebugInfo.StepExecutionLog Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


EndTime Property

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowDebugInfo.StepExecutionLog.EndTime Property

public virtual DateTime EndTime {get; set;}

See Also

ProcessFlowDebugInfo.StepExecutionLog Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ParentStep Property

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowDebugInfo.StepExecutionLog.ParentStep Property

Gets/Sets the Parent Execution Log Step

public virtual ProcessFlowDebugInfo.StepExecutionLog ParentStep {get; set;}

Property Value

Remarks

See Also

ProcessFlowDebugInfo.StepExecutionLog Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


PropertiesAfter Property

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowDebugInfo.StepExecutionLog.PropertiesAfter Property

public virtual AptifyProperties PropertiesAfter {get;}

See Also

ProcessFlowDebugInfo.StepExecutionLog Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


PropertiesBefore Property

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowDebugInfo.StepExecutionLog.PropertiesBefore Property

public virtual AptifyProperties PropertiesBefore {get;}

See Also

ProcessFlowDebugInfo.StepExecutionLog Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


Result Property

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowDebugInfo.StepExecutionLog.Result Property

public virtual ProcessFlowResult Result {get; set;}

See Also

ProcessFlowDebugInfo.StepExecutionLog Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


StartTime Property

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowDebugInfo.StepExecutionLog.StartTime Property

public virtual DateTime StartTime {get; set;}

See Also

ProcessFlowDebugInfo.StepExecutionLog Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


StepID Property

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowDebugInfo.StepExecutionLog.StepID Property

public virtual Int64 StepID {get; set;}

See Also

ProcessFlowDebugInfo.StepExecutionLog Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


StepName Property

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowDebugInfo.StepExecutionLog.StepName Property

public virtual String StepName {get; set;}

See Also

ProcessFlowDebugInfo.StepExecutionLog Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


StepType Property

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowDebugInfo.StepExecutionLog.StepType Property

public virtual String StepType {get; set;}

See Also

ProcessFlowDebugInfo.StepExecutionLog Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


SubSteps Property

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowDebugInfo.StepExecutionLog.SubSteps Property

List of sub-steps executed within this step

public virtual List<T> SubSteps {get;}

Property Value

Remarks

See Also

ProcessFlowDebugInfo.StepExecutionLog Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowDebugInfo.StepExecutionLog Methods

The methods of the ProcessFlowDebugInfo.StepExecutionLog class are listed below. For a complete list of ProcessFlowDebugInfo.StepExecutionLog class members, see the ProcessFlowDebugInfo.StepExecutionLog Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Overloaded. Overrides base ToString() method to generate a string representation of the members of this class
ToString (inherited from Object) | Overloaded. Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProcessFlowDebugInfo.StepExecutionLog Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ToString Method

Aptify 5.0 Software Development Kit (SDK)

ProcessFlowDebugInfo.StepExecutionLog.ToString Method

Overrides base ToString() method to generate a string representation of the members of this class

Overload List

Inherited from Object.

public virtual string ToString();

Overrides base ToString() method to generate a string representation of the members of this class

public string ToString(String);

See Also

ProcessFlowDebugInfo.StepExecutionLog Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowDebugInfo.StepExecutionLog.ToString Method (String)

Overrides base ToString() method to generate a string representation of the members of this class

public string ToString(
String LinePrefix
);

Return Value

Remarks

See Also

ProcessFlowDebugInfo.StepExecutionLog Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace | ProcessFlowDebugInfo.StepExecutionLog.ToString Overload List


ProcessFlowDebugRun Class

Debugger Class for Aptify Process Flows

For a list of all members of this type, see ProcessFlowDebugRun Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
ProcessFlowDebugRun

public class ProcessFlowDebugRun : Form, IAptifyAction

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aptify.Framework.BusinessLogic.ProcessPipeline

Assembly: ProcessFlowDebugHarness (in ProcessFlowDebugHarness.dll)

See Also

ProcessFlowDebugRun Members | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowDebugRun Members

ProcessFlowDebugRun overview

Public Instance Constructors

ProcessFlowDebugRun Constructor Initializes a new instance of the ProcessFlowDebugRun class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Gets or sets a value indicating whether the opacity of the form can be adjusted.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScale (inherited from Form) | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScaleDimensions (inherited from ContainerControl) | Gets or sets the dimensions that the control was designed to.
AutoScaleMode (inherited from ContainerControl) | Gets or sets the automatic scaling mode of the control.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Form) |
AutoSizeMode (inherited from Form) | Gets or sets the mode by which the form automatically resizes itself.
AutoValidate (inherited from Form) |
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAutoScaleDimensions (inherited from ContainerControl) | Gets the current run-time dimensions of the screen.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
IsRestrictedWindow (inherited from Form) | Gets a value indicating whether the form can use all windows and user input events without restriction.
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Form) |
MainMenuStrip (inherited from Form) | Gets or sets the primary menu container for the form.
Margin (inherited from Form) |
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
RestoreBounds (inherited from Form) | Gets the location and size of the form in its normal window state.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RightToLeftLayout (inherited from Form) | Gets or sets a value indicating whether right-to-left mirror placement is turned on.
ShowIcon (inherited from Form) | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Form) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Form) |
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as a topmost form.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Config | This method must be called before any other member of the class is accessed
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoAction | Overloaded.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformAutoScale (inherited from ContainerControl) | Performs scaling of the container control and its children.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
PreProcessMessage (inherited from Control) | Preprocesses keyboard or input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Form) | Overloaded. Shows the form with the specified owner to the user.
Show (inherited from Control) | Overloaded. Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with the currently active window set as its owner.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
ValidateChildren (inherited from Form) | Overloaded.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
AutoSizeChanged (inherited from Form) |
AutoValidateChanged (inherited from Form) |
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is no longer the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
FormClosed (inherited from Form) | Occurs after the form is closed.
FormClosing (inherited from Form) | Occurs before the form is closed.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpButtonClicked (inherited from Form) | Occurs when the Help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Form) |
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
ResizeBegin (inherited from Form) | Occurs when a form enters resizing mode.
ResizeEnd (inherited from Form) | Occurs when a form exits resizing mode.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs after the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
Shown (inherited from Form) | Occurs whenever the form is first displayed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) | Occurs when the value of the TabIndex property changes.
TabStopChanged (inherited from Form) |
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

AutoScaleFactor (inherited from ContainerControl) | Gets the scaling factor between the current and design-time automatic scaling dimensions.
CanEnableIme (inherited from ContainerControl) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Form) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
ShowWithoutActivation (inherited from Form) | Gets a value indicating whether the window will be activated when it is shown.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
ActivateMdiChild (inherited from Form) | Activates the MDI child of a form.
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font.
ApplySkin |
CenterToParent (inherited from Form) | Centers the position of the form within the bounds of the parent form.
CenterToScreen (inherited from Form) | Centers the form on the current screen.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation.
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Form) |
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnActivated (inherited from Form) | Raises the Activated event.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnAutoValidateChanged (inherited from ContainerControl) | Raises the AutoValidateChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Form) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Form) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Form) |
OnEnter (inherited from Form) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnFormClosed (inherited from Form) | Raises the FormClosed event.
OnFormClosing (inherited from Form) | Raises the FormClosing event.
OnFormLoad | This method handles the Form's Load Event and can be overriden by sub-classes as required
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpButtonClicked (inherited from Form) | Raises the HelpButtonClicked event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Form) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Form) |
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from ContainerControl) |
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Form) |
OnResizeBegin (inherited from Form) | Raises the ResizeBegin event.
OnResizeEnd (inherited from Form) | Raises the ResizeEnd event.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnRightToLeftLayoutChanged (inherited from Form) | Raises the RightToLeftLayoutChanged event.
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnShown (inherited from Form) | Raises the Shown event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Form) | Processes a command key.
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from Form) |
ScaleCore (inherited from Form) | Base function that performs scaling of the form.
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Form) | Overloaded. Selects this form, and optionally selects the next/previous control.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateDefaultButton (inherited from Form) | Updates which button is the default button.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessMnemonic (inherited from Form) |
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

ProcessFlowDebugRun Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace


ProcessFlowDebugRun Constructor

Initializes a new instance of the ProcessFlowDebugRun class.

public ProcessFlowDebugRun();

See Also

ProcessFlowDebugRun Class | Aptify.Framework.BusinessLogic.ProcessPipeline Namespace